Oracle Reports Building Reports
Release 6i

A73172-01

Contents

Index

Prev Next

1
Basic Report Builder Concepts

This chapter introduces some basic information about Report Builder, such as:

1.1 What is Report Builder?

Oracle Reports is a suite of programs that allows your organization to centralize report processing and to better manage reporting. Report Builder is one of the program components included with Oracle Reports.

Report Builder includes:

Oracle Reports can access data from any database you may have in your organization, including: Oracle, Microsoft SQL Server, Sybase, Informix, DB2, and any ODBC-compliant data source.

1.2 Tools for working with reports in Report Builder

Report Builder provides the tools to help you create and manage reports. These tools are described in the following sections:

1.2.1 Using wizards to automate report design

Report Builder has a Report Wizard, Data Wizard, and Web Wizard to automate the creation of reports. Most often, you can create a report by starting with one of the wizards, and then refining the report that the wizard creates.

For example, you can start with the Report Wizard to create an initial report, which the Report Wizard automatically displays in the Live Previewer. From there, you can make modifications to the report in the Live Previewer, Layout Model view, Data Model view, and Parameter Form view. See Section 1.2.2, "Using the Report Editor to view and edit reports" for information about report views.

1.2.1.1 Report Wizard

The easiest way to create a report is to use the Report Wizard. The Report Wizard takes you through the steps required to create a report, and is a great way to start building a report. The Report Wizard alone may give you a report that satisfies your requirements. If it doesn't, you can use the Data Model view, the Live Previewer, and the Layout Model view to further refine your report.

Many of the sample reports in this manual will instruct you on how to build a report using the Report Wizard. A brief overview of how to use the Report Wizard follows:

  1. Start Report Builder.

  2. If the Welcome dialog box appears, click Use the Report Wizard and click OK.

    If the Welcome dialog box does not appear, choose File->New->Report. Click Use the Report Wizard and click OK.

  3. Fill out each page of the Report Wizard, getting help when needed by clicking the Help button.

  4. On the last page of the Report Wizard, click Finish. A report is created and appears in the Live Previewer.

  5. From the Live Previewer, you can edit the report as desired. Note that the Live Previewer is one of several report views that are available in the Report Editor. Using the View menu or the toolbar, you can switch to other report views to further edit your report. Section 1.2.2, "Using the Report Editor to view and edit reports" talks more about different ways to view a report.

For more information about the Report Wizard, see the online help:

 

  1. For online help on this topic, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    report wizard, about

  3. Then click Display to view help topic...
    Report Wizard: Welcome page

 

1.2.1.2 Data Wizard

If you need to create multiple queries for your report, use the Data Wizard to create them. From the Data Model view, choose Tools->Data Wizard. Section 5.1.1, "Building queries using the Data Wizard" contains an example that uses the Data Wizard. For more information, see the online help:

 

  1. For online help on this topic, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    data wizard, about

  3. Then click Display to view help topic...
    Data Wizard: Welcome page

 

1.2.1.3 Web Wizard

If you want to quickly deploy your reports on the Web, use the Web Wizard. Choose Tools->Web Wizard. Section 4.4, "Adding bookmarks to parts of your report" contains an example that uses the Web Wizard. For more information, see the online help:

 

  1. For online help on this topic, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    web wizard, about

  3. Then click Display to view help topic...
    Web Wizard: Welcome page

 

1.2.2 Using the Report Editor to view and edit reports

The Report Editor and the Object Navigator appear when you first start up Report Builder. (For information about the Object Navigator, see Section 1.2.3, "Using the Object Navigator to locate report elements".) In the Report Editor, you can view information about a report in four different ways. You can switch between these views using the View menu or the toolbar icons.

You will work in each of the following Report Editor views as you create the sample reports in this manual:

For more information, see the online help:

 

  1. For online help on these topics, choose Help->Report Builder Help Topics

  2. On the Index page, type...
    Live Previewer, about; or Data Model view, about; or Layout Model view, about; or Parameter Form view, about

  3. Then click Display to view help topic.

 

1.2.2.1 Live Previewer

This view displays your report as an end user would see it. If you are using live data, the Live Previewer will update the report as data changes. Any modifications that you make to the report in the Live Previewer display immediately. To display your report in the Live Previewer, click .

1.2.2.2 Data Model view

This view displays your report data as data model objects so that you can see the relationships between queries, groups, columns, parameters, and links. To display your report in the Data Model view, click .

1.2.2.3 Layout Model view

This view displays the attributes of your report as objects so that you can see the attribute types and relationships. You can edit layout objects, such as frames, repeating frames, fields, boilerplates, anchors, and graphics in this view in order to change the appearance of the report. To display your report in the Layout Model view, click .

1.2.2.4 Parameter Form view

This view lets you create a Runtime Parameter Form for your report. When a user runs your report, the user enters values for parameters in this form to determine how the report will execute, or the user accepts the defaults. If you do not define a Runtime Parameter Form in the Parameter Form view, Report Builder displays a default Parameter Form at runtime. You can select which system and user parameters to use for your form using the Parameter Form Builder, or you can create your own from scratch. To display the Parameter Form view, click .

1.2.3 Using the Object Navigator to locate report elements

The Object Navigator and Report Editor appear when you first start up Report Builder. The Object Navigator provides a hierarchical display of all major objects in a report or template, including attached libraries and external queries. Using the Object Navigator, you can:

When you select an object in the Object Navigator, the corresponding object is simultaneously selected in the Live Previewer, Data Model view, or Layout Model view (whichever view is open at the time).

1.3 Obtaining database access before you start

In order to build the reports as described in this manual, you must be able to access the Oracle Developer demo tables. Use the demo CD that came with your product package to install the SQL scripts that are used to install the demo tables in your database. These SQL scripts can be run from the Start->Programs menu.

Before starting a report, be sure to log into the database that contains the Oracle Developer demo tables. You log in by selecting File->Connect.

1.4 Other software needed before you start

The following programs may be required to view some of the sample reports. Before you start, check that your system has the following:

1.5 Operating system considerations

The steps in this book were written based on the Windows 95/NT operating environment. If you are using another operating system, for example a UNIX-based system, there may be slight variations in some of the steps you need to perform.


Prev Next
Oracle
Copyright © 1999 Oracle Corporation.

All Rights Reserved.

Contents

Index