Skip Headers
Oracle® Enterprise Manager Cloud Control Basic Installation Guide
12c Release 2 (12.1.0.2)
E22624-20
  Go To Table Of Contents
Contents
Go To Index
Index

Previous
Previous
 
Next
Next
 

4 Meeting Package, Kernel Parameter, and Library Requirements

This chapter describes the packages, kernel parameters settings, and libraries required on different platforms (32-bit and 64-bit) for installing a new Enterprise Manager system, an additional Oracle Management Service (OMS), and a standalone Oracle Management Agent (Management Agent).

In particular, this chapter covers the following:


Note:

The packages and libraries are NOT required for Microsoft Windows platforms.

Package Requirements

This section lists the packages required on different platforms (32-bit and 64-bit) for installing an OMS or a Management Agent. In particular, this section covers the following:


Note:

To manage or monitor database targets on SuSE 10 platform, you must install the packages libaio-32bit-0.3.104-14.2 and libaio-devel-32bit-0.3.104-14.2 on the SuSE 10 host where the Management Agent is running.

Identifying Installed Packages

To identify the packages already installed on your system, run the following command. If the command does not list the packages listed in Package Requirements for Oracle Management Service or Package Requirements for Oracle Management Agent, then install them manually.


Note:

The following command is meant only for Linux x86 and x86-64 platforms. To know the command for other platforms, contact your system administrator or refer to the platform-specific manual.

For Linux Platforms

rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}(%{ARCH})\n" | grep glibc

The command lists all the packages installed on the system. The 32-bit ones are appended with (i386) or (i686), and the 64-bit ones are appended with (x86_64).

For example, if you run the command on a 32-bit system, you should see something similar to the following:

glibc-devel-2.3.4-2.43(i386)
glibc-headers-2.3.4-2.43(i386)
glibc-2.3.4-2.43(i686)
compat-glibc-headers-2.3.2-95.30(i386)
glibc-profile-2.3.4-2.43(i386)
glibc-utils-2.3.4-2.43(i386)
glibc-kernheaders-2.4-9.1.103.EL(i386)
glibc-common-2.3.4-2.43(i386)
compat-glibc-2.3.2-95.30(i386)

For example, if you run the command on a 64-bit system, you should see something similar to the following:

glibc-common-2.3.4-2.43(x86_64)
glibc-devel-2.3.4-2.43(x86_64)
glibc-profile-2.3.4-2.43(x86_64)
glibc-headers-2.3.4-2.43(x86_64)
glibc-utils-2.3.4-2.43(x86_64)
glibc-2.3.4-2.43(x86_64)

For Solaris Platforms

pkginfo <package_name>

For example,

pkginfo SUNWbtool

For AIX Platforms

lslpp -l <package name>

For example,

lslpp -l  bos.perf.proctools

For HP Platforms

To determine whether a bundle, product, or fileset is installed, enter the following command, where level is either bundle, product, or fileset:

# /usr/sbin/swlist -l level |more

For example,

/usr/sbin/swlist -l bundle |grep QPK

Package Requirements for Oracle Management Service

Table 4-1 lists the packages required on different platforms (32-bit and 64-bit) for installing a new Enterprise Manager system or an additional OMS.

Table 4-1 Package Requirements for Oracle Management Service

Platform 32-Bit Packages for 32-Bit Platform 64-Bit Packages for 64-Bit Platform

Oracle Linux 6.x

(Red Hat 6 Kernel and Unbreakable Enterprise Kernel (UEK))

Not Supported

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc-4.1.1

  • libaio-0.3.106

  • glibc-common-2.3.4

  • libstdc++-4.1.1

  • libXtst-1.0.99.2-3.el6.x86_64.rpm

  • sysstat-5.0.5

  • glibc-devel-2.5-49-i686 (This is a 32-bit package)

  • glibc-devel-2.5-49-x86_64 (This is a 64-bit package)

  • (Applicable only for Oracle Linux 6.2) glibc-2.12-1.47.0.2

Oracle Linux 5.x

Red Hat Enterprise Linux 5.x

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc-4.1.1

  • libaio-0.3.106

  • glibc-common-2.3.4

  • compat-libstdc++296-2.96

  • libstdc++ 4.1.1

  • libstdc++devel-4.1.0

  • setarch-1.6

  • sysstat-5.0.5

  • compat-db 4.1.25

  • rng-utils-2.0

  • libXtst-1.0.1-3.1(i386)

  • xorg-x11-utils (This package is required only for GUI-based interactive installation, and not for silent installation)

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc -4.1.1

  • libaio-0.3.106

  • glibc-common-2.3.4

  • libstdc++ -4.1.1

  • setarch-1.6

  • sysstat-5.0.5

  • rng-utils-2.0

  • libXtst-1.0.1-3.1(x86_64)

  • xorg-x11-utils (This package is required only for GUI-based interactive installation, and not for silent installation)

In addition, install the 32-bit version as well as the 64-bit version of glibc-devel-2.5-49 to avoid any linking errors while installing the OMS. The installer checks for this package, so if this package is not installed, the installer displays an error.

Oracle Linux 4.x

Red Hat Enterprise Linux 4.x

  • make-3.80

  • binutils-2.15.92.0.2

  • gcc-3.4.5

  • libaio-0.3.105

  • glibc-common-2.3.4

  • libstdc++-3.4.5

  • libstdc++-devel-3.4.3

  • pdksh-5.2.14

  • setarch-1.6

  • sysstat-5.0.5

  • compat-db-4.1.25

  • kernel-utils-2.4

  • libXtst-1.0.1-3.1(i386)

  • xorg-x11-utils (This package is required only for GUI-based interactive installation, and not for silent installation)

Not Supported

SUSE Linux Enterprise 10

  • make-3.80

  • binutils-2.16.91.0.5

  • gcc-4.1.0

  • libstdc++ 4.1.0

Not Supported

SUSE Linux Enterprise 11

  • make-3.81

  • binutils-2.19-9.3

  • gcc-4.3-62.198

  • libstdc++ 43.4.3

  • make-3.80

  • binutils-2.16.91.0.5

  • gcc -4.1.0

  • libstdc++ 43.4.3

In addition, install the 32-bit version as well as the 64-bit version of glibc-devel-2.5-49 to avoid any linking errors while installing the OMS. The installer checks for this package, so if this package is not installed, the installer displays an error.

Asianux Server 3

  • make-3.81-3AXS3-i386

  • binutils-2.17.50.0.6-9AXS3-i386

  • gcc-4.1.2-44.1-i386

  • libaio-0.3.106-3.2-i386

  • glibc-common-2.5-34.1AXS3-i386

  • compat-libstdc++-296-2.96-138.2AX-i386

  • libstdc++-4.1.2-44.1-i386

  • libstdc++-devel-4.1.2-44.1-i386

  • setarch-2.0-1.1-i386

  • sysstat-7.0.4-1AX-i386

  • compat-db-4.2.52-5.1-i386

  • libXtst-1.0.1-3.1(i386)

  • xorg-x11-utils (This package is required only for GUI-based interactive installation, and not for silent installation)

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc -4.1.1

  • libaio-0.3.106

  • glibc-common-2.3.4

  • libstdc++ -4.1.1

  • setarch-1.6

  • sysstat-5.0.5

  • libXtst-1.0.1-3.1(x86_64)

  • xorg-x11-utils (This package is required only for GUI-based interactive installation, and not for silent installation)

In addition, install the 32-bit version as well as the 64-bit version of glibc-devel-2.5-49 to avoid any linking errors while installing the OMS. The installer checks for this package, so if this package is not installed, the installer displays an error.

Solaris SPARC 5.9

Not Supported

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWsprox

  • SUNWtoo

  • SUNWi1of

  • SUNWxwfnt

Solaris SPARC 5.10

Also supported on Solaris Local Container

Not Supported

SUNWbtool

Solaris SPARC 5.11

Not Supported

  • SUNWbtool

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWxwplt (This is for setting xwindow)

  • SUNWfont-xorg-core (This package is required only for GUI-based interactive installation, and not for silent installation)

  • SUNWlibC

  • SUNWcsl

Solaris x86-64 5.11

Not Supported

  • SUNWbtool

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWxwplt (This is for setting xwindow)

  • SUNWfont-xorg-core (This package is required only for GUI-based interactive installation, and not for silent installation)

  • SUNWlibC

  • SUNWcsl

Solaris x86-64 5.10

Not Supported

  • SUNWbtool

  • SUNWarc

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWi1of

  • SUNWi1cs

  • SUNWi15cs

  • SUNWxwfnt

IBM AIX 5.3.00.04

Note: Maintenance level 4 and higher are supported for AIX 5.3.

Check the maintenance level using the following command:

oslevel -r

Not Supported

  • bos.perf.proctools(0.0)

  • bos.adt.base(0.0)

  • bos.adt.libm(0.0)

  • rsct.basic.rte(0.0)

  • rsct.compat.clients.rte(0.0)

IBM AIX 6.1

Note: All maintenance levels are supported.

Check the maintenance level using the following command:

oslevel -r

Not Supported

  • bos.adt.base(0.0)

  • bos.adt.lib(0.0)

  • bos.adt.libm(0.0)

  • bos.perf.libperfstat(0.0)

  • bos.perf.perfstat(0.0)

  • bos.perf.proctools(0.0)

  • rsct.basic.rte(0.0)

  • rsct.compat.clients.rte(0.0)

  • xlC.aix61.rte.(9.0.0.0)

  • xlC.rte.(9.0.0.0)

IBM AIX 7.1

Note: All maintenance levels are supported.

Check the maintenance level using the following command:

oslevel -r

Not Supported

  • bos.adt.base(0.0)

  • bos.adt.lib(0.0)

  • bos.adt.libm(0.0)

  • bos.perf.libperfstat(0.0)

  • bos.perf.perfstat(0.0)

  • bos.perf.proctools(0.0)

  • rsct.basic.rte(0.0)

  • rsct.compat.clients.rte(0.0)

  • xlC.aix61.rte.(9.0.0.0)

  • xlC.rte.(9.0.0.0)


Package Requirements for Oracle Management Agent

Table 4-2 lists the packages required on different platforms (32-bit and 64-bit) for installing a Management Agent.

Table 4-2 Package Requirements for Oracle Management Agent

Platform 32-Bit Packages for 32-Bit Platform 64-Bit Packages for 64-Bit Platform

Oracle Linux 6.x

(Red Hat 6 Kernel and Unbreakable Enterprise Kernel (UEK))

Not Supported

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc-4.1.1

  • libaio-0.3.106

  • glibc-common-2.3.4

  • libstdc++-4.1.1

  • libXtst-1.0.99.2-3.el6.x86_64.rpm

  • sysstat-5.0.5

Oracle Linux 5.x

Red Hat Enterprise Linux 5.x

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc-4.1.1

  • libstdc++-4.1.1

  • libXtst-1.0.1-3.1(i386)

Oracle Linux 5.x and Red Hat Enterprise Linux 5.x, where x <= 5 [for example, Oracle Linux 5.3]

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc -4.1.1

  • libstdc++ -4.1.1

  • libXtst-1.0.1-3.1(x86_64)

Oracle Linux 5.x and Red Hat Enterprise Linux 5.x, where x > 5 [for example, Oracle Linux 5.6]

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc -4.1.1

  • libaio-0.3.106

  • glibc-common-2.3.4

  • libstdc++ -4.1.1

  • setarch-1.6

  • sysstat-5.0.5

  • rng-utils-2

  • libXtst-1.0.1-3.1(x86_64)

Oracle Linux 4.x

Red Hat Enterprise Linux 4.x

  • make-3.80

  • binutils-2.15.92.0.2

  • gcc-3.4.5

  • libstdc++-3.4.5

  • kernel-utils-2.4

  • libXtst-1.0.1-3.1(i386)

64-bit Management Agent is NOT supported on 64-bit platform, but 32-bit Management Agent is supported, so install all 32-bit packages (listed in the previous column) on your 64-bit platform.

SUSE Linux Enterprise 10

  • make-3.80

  • binutils-2.16.91.0.5

  • gcc-4.1.0

  • libstdc++ 4.1.0

  • libaio-32bit-0.3.104-14.2

  • libaio-devel-32bit-0.3.104-14.2

64-bit Management Agent is NOT supported on 64-bit platform, but 32-bit Management Agent is supported, so install all 32-bit packages (listed in the previous column) on your 64-bit platform.

SUSE Linux Enterprise 11

  • make-3.81

  • binutils-2.19-9.3

  • gcc-4.3-62.198

  • libstdc++ 43.4.3

  • make-3.80

  • binutils-2.16.91.0.5

  • gcc -4.1.0

  • libstdc++ 43.4.3

Asianux Server 3

  • make-3.81-3AXS3-i386

  • binutils-2.17.50.0.6-9AXS3-i386

  • gcc-4.1.2-44.1-i386

  • libstdc++-4.1.2-44.1-i386

  • libXtst-1.0.1-3.1(i386)

  • make-3.81

  • binutils-2.17.50.0.6

  • gcc -4.1.1

  • libstdc++ -4.1.1

  • libXtst-1.0.1-3.1(x86_64)

Solaris SPARC 5.9

Not Supported

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWsprox

  • SUNWtoo

  • SUNWi1of

  • SUNWxwfnt

Solaris SPARC 5.10

Also supported on Solaris Local Container

Not Supported

SUNWbtool

Solaris SPARC 5.11

Not Supported

  • SUNWbtool

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWlibC

  • SUNWcsl

Solaris x86-64 5.11

Not Supported

  • SUNWbtool

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWlibC

  • SUNWcsl

Solaris x86-64 5.10

Not Supported

  • SUNWbtool

  • SUNWarc

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWi1of

  • SUNWi1cs

  • SUNWi15cs

  • SUNWxwfnt

Solaris Express 5.11 x86-64

Note: The supported Kernel ID is 175.0.0.0.2.0,151.0.1.12.

To check the kernel ID, run the following command:

uname -X |grep KernelID

Not Supported

  • SUNWbtool

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWlibC

  • SUNWcsl

Solaris SPARC Express 5.11

Note: The supported Kernel ID is 175.0.0.0.2.0,151.0.1.12.

To check kernel ID, run the following command:

uname -X |grep KernelID

Not Supported

  • SUNWbtool

  • SUNWhea

  • SUNWlibm

  • SUNWlibms

  • SUNWsprot

  • SUNWtoo

  • SUNWlibC

  • SUNWcsl

IBM AIX 5.3.00.04

Note: Maintenance level 4 and higher are supported for AIX 5.3.

Maintenance level can be checked using the following command:

oslevel -r

Not Supported

  • bos.perf.proctools(5.3.0.50)

  • bos.adt.base(0.0)

  • bos.adt.libm(0.0)

  • rsct.basic.rte(0.0)

  • rsct.compat.clients.rte(0.0)

IBM AIX 6.1

Note: All maintenance levels are supported.

Check the maintenance level using the following command:

oslevel -r

Not Supported

  • bos.adt.base(0.0)

  • bos.adt.lib(0.0)

  • bos.adt.libm(0.0)

  • bos.perf.libperfstat(0.0)

  • bos.perf.perfstat(0.0)

  • bos.perf.proctools(0.0)

  • rsct.basic.rte(0.0)

  • rsct.compat.clients.rte(0.0)

  • xlC.aix61.rte.(9.0.0.0)

  • xlC.rte.(9.0.0.0)

IBM AIX 7.1

Note: All maintenance levels are supported.

Check the maintenance level using the following command:

oslevel -r

Not Supported

  • bos.adt.base(0.0)

  • bos.adt.lib(0.0)

  • bos.adt.libm(0.0)

  • bos.perf.libperfstat(0.0)

  • bos.perf.perfstat(0.0)

  • bos.perf.proctools(0.0)

  • rsct.basic.rte(0.0)

  • rsct.compat.clients.rte(0.0)

  • xlC.aix61.rte.(9.0.0.0)

  • xlC.rte.(9.0.0.0)

HP PA-RISC 11.23

Not Supported

BUNDLE11i(B.11.23.0409.3)

HP PA-RISC 11.31

Not Supported

  • OnlineDiag(B.11.31.01.03)

  • Base-VXFS(B.11.31)

HP-UX Itanium 11.23

Not Supported

BUNDLE11i(B.11.23.0409.3)

HP-UX Itanium 11.31

Not Supported

OS-Core(B.11.31)


Kernel Parameter Requirements

If OMS and Management Repository Are on Different Hosts

If you are installing OMS and Management Repository (database) on different hosts, which are running on Linux operating systems (32-bit or 64-bit), then on the OMS host, set the kernel.shmmax parameter to a value 1 byte less than 4 GB or 4294967295.

Oracle recommends this value to avoid lack of memory issues for other applications and to enable a complete and successful core file generation under any and all circumstances.

To verify the value assigned to kernel.shmmax parameter, run the following command:

cat /proc/sys/kernel/shmmax

To set the value for kernel.shmmax parameter, run the following command:

sysctl -w kernel.shmmax=<new value>

If OMS and Management Repository Are on the Same Host

If you are installing OMS and Management Repository (database) on the same host, which is running on a Linux operating system (32-bit or 64-bit), then set the kernel.shmmax parameter to a value prescribed in the Oracle Database Installation Guide 11g Release 2 (11.2) for Linux.

Library Requirements

This section lists the libraries required on different platforms (32-bit and 64-bit) for installing an OMS or a Management Agent. In particular, this section covers the following:

Library Requirements for Oracle Management Service

Table 4-3 lists the libraries required on different platforms (32-bit and 64-bit) for installing a new Enterprise Manager system or an additional OMS.

Table 4-3 Library Requirements for Oracle Management Service

Platform 32-Bit Libraries for 32-Bit Platform 64-Bit Libraries for 64-Bit Platform

Oracle Linux 6.x

Red Hat Enterprise Linux 6.x

Not Supported

glibc-2.5.12

Oracle Linux 5.x

Red Hat Enterprise Linux 5.x

glibc-2.5-12

glibc-2.5.12

Oracle Linux 4.x

Red Hat Enterprise Linux 4.x

glibc-2.3.4-2.43.i386

-

SUSE Linux Enterprise 10

glibc-2.2.4-31.7

-

SUSE Linux Enterprise 11

glibc-2.9

glibc-2.9

Asianux Server 3

glibc-2.3.4-2.9

glibc-2.3.4-2.9


Library Requirements for Oracle Management Agent

There are no library requirements for Management Agent.