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Preface

This manual describes how to use the online display capabilities of the
Oracle Trace for OpenVMS Monitor Version 2.2.

The Oracle Trace Monitor is a windows application (based on the Motif
interface) that displays charts showing resource use for the processes
running on your system. You can monitor resource use interactively either
as it takes place or after the fact.

Intended Audience
This manual is intended for application programmers, software
performance analysts, and database administrators who want to
interactively display event-based data online.

Prerequisite Software
You need the following software to run the Oracle Trace Monitor:

• OpenVMS VAX Version 5.4-3 or higher or OpenVMS Alpha Version 1.5
or higher

• DECwindows Motif Version 1.1 or higher

• Oracle Rdb Version 4.0B or higher

Prerequisite Hardware
You need a mouse to use the Oracle Trace Monitor software.
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Document Structure
This manual has the following structure:

• Chapter 1 provides a brief description of Oracle Trace for OpenVMS.
It also provides a description of the Monitor windows and the types of
information displayed in each.

• Chapter 2 provides instructions on how to limit the monitor display to
certain types of data. It also describes how to set thresholds and set up
command procedures to execute when thresholds are exceeded.

• Chapter 3 provides instructions on how to change display
characteristics of the monitor windows, such as color, size, and
position.

• Appendix A provides format information for command procedures
that you link to thresholds. It also provides the location of a sample
command procedure.

Associated Documentation
The other manuals in the Oracle Trace documentation set are:

• Oracle Trace Installation Guide Version 2.2 — Provides instructions for
installing the Oracle Trace software on an OpenVMS system.

• Oracle Trace Getting Started Version 2.2 — Provides an introduction to
the Oracle Trace software and instructions for scheduling a collection
and generating a report.

• Oracle Trace Collector User’s Guide Version 2.2 — Describes how to
collect event-based data and instrument applications for collection.

• Oracle Trace Reporter User’s Guide Version 2.2 — Describes how to
format and generate hardcopy reports from event-based data.

Conventions
The conventions used in this book are listed in Table 1.
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Table 1 Conventions

Conventions Meaning

Ctrl/x A sequence such as Ctrl/x indicates that you must hold down
the key labeled Ctrl while you press another key or a pointing
device button; for example, Ctrl/C or Ctrl/Z.

[ ] Brackets indicate optional elements.

. . . Horizontal ellipsis indicate that you can enter additional
parameters, values, or information.

$ The dollar sign is used to indicate the DCL prompt. This prompt
may be different on your system.

Getting Help on the Monitor
To receive basic help on the Monitor while you are using it, select the
Tutorial option from the Help menu.

Once you select the Help facility, it remains enabled and automatically
displays help for any new Monitor windows you open. To disable the
automatic display of help, click on the Cancel button in any Help window.

ix





1
Introduction

The Oracle Trace Monitor is a component of Oracle Trace for OpenVMS,
which is a layered product that collects and reports event-based data from
any combination of OpenVMS layered products and application programs
containing Oracle Trace service routine calls. The Oracle Trace documentation
set refers to application programs that contain Oracle Trace service routines as
facilities. The following Oracle products are facilities:

• Oracle CODASYL DBMS

• Oracle RALLY

• Oracle Rdb

• Oracle Expert for Rdb

Oracle Trace provides Oracle Expert for Rdb with data that it uses for
optimizing existing Oracle Rdb databases.

Additionally, the following products from Digital Equipment Corporation are
also facilities:

• DEC ACMS

• ALL–IN–1

• DECforms

You can collect event-based data from existing facilities, and you can also
add Oracle Trace service routines to your own applications to collect data
from them. The process of adding Oracle Trace service routine calls to an
application is called instrumenting an application. The documentation for
instrumented products describe how the product is instrumented.

Oracle Trace software operates with minimal performance impact on the
system. It can run with both the development and production versions of your
application to give you information about the behavior of your application.
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Several third-party, fourth-generation language (4GL) products contain Oracle
Trace service routine calls and work with Oracle Trace and Oracle Expert for
Rdb. Contact your 4GL vendor for more information.

1.1 Oracle Trace Components
In addition to the Monitor component described in this manual, Oracle Trace
has Collector and Reporter components. These components perform the
following functions:

• Collector — Gathers event-based data from instrumented layered
products and applications. With the Oracle Trace Collector, you can
schedule, control, track, and cancel collections. You can also instrument
your own applications using the Oracle Trace service routines.

• Reporter — The Reporter provides hardcopy reports from a formatted
Oracle Trace database. These reports help you to gain an in-depth
understanding of the resources your application uses.

The Oracle Trace components are interrelated, as shown in Figure 1–1.

Figure 1–1 Oracle Trace Components
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For further information about the Collector and Reporter, refer to Oracle Trace
Collector User’s Guide and Oracle Trace Reporter User’s Guide.
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1.2 Before Using the Monitor
To use the Monitor, it is not necessary that you know how to instrument
applications or set up collections. However, to understand and make maximum
use of the data that the Monitor displays, you must be familiar enough with
the application being monitored to know what the displayed items mean in
relation to the application. Otherwise, many of the items displayed in the
Monitor windows will make little sense to you.

For example, many of the sample screens in this manual show data collected
from the Oracle Rdb facility. Items such as CPU and DIO may be immediately
understandable, but to understand the significance of other items such as
PC_CLIENT and REQ_HANDLE, you must have specific knowledge about
Oracle Rdb.

If you are monitoring Oracle facilities, see the documentation for these facilities
for information on how they are instrumented.

1.3 Controlling Monitor Displays
The Monitor provides you with the options of running in real-time or replay
mode. If you are in replay mode, you can specify the replay speed. Whether
you are running in real-time or replay mode, you have the option of pausing
the data display at any point. Each of these options is described in the
following sections.

1.3.1 Starting the Monitor
Real-time Mode To use the monitor in real-time, displaying data from an active data collection

file, use the following command (replacing sample_data.dat with the name of
your own data collection file):

$ COLLECT MONITOR sample_data.dat

Replay Mode To display information contained in a previously collected data collection
file, use the /REPLAY qualifier of the MONITOR command, as shown in the
following example (replace sample_data.dat with the name of your own data
collection file):

$ COLLECT MONITOR/REPLAY sample_data.dat

You can replay a previously collected data collection file from a specific point
within the file by using the /SINCE qualifier as shown in the following
example:

$ COLLECT MONITOR/REPLAY/SINCE="30-DEC-1994 19:00" sample_data.dat
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The Monitor displays information from the data collection file starting from
7 p.m. December 30, 1994.

Monitor Demo If you do not have your own data collection to monitor you can use the Oracle
Trace Monitor demonstration file by entering the following command:

$ COLLECT MONITOR/REPLAY EPC$EXAMPLES:DEMO_DATA.DAT

This command will start the Monitor in replay mode and display sample Oracle
Trace data. The screen shots in this guide are from this demonstration.

Replay Speed The Monitor provides a selection of speeds at which you can replay a data
collection file. The default replay speed is 5:5. This means that the screen
is updated every 5 seconds with the totals from the last 5 seconds of data
collection.

To change the speed, select Replay Speed from the Options menu. For example,
if you click on the 5:10 toggle button, the screen is updated every 5 seconds
with the totals from the last 10 seconds of data collection.

This allows you to run through the replay more quickly without visually
speeding up the replay on the screen or making the data appear to flash by
more quickly. It simply consolidates a longer period of data collection into a
shorter update interval.

Conversely, if you click on the 5:1 toggle button, you run through the replay
more slowly. One second of data is displayed every 5 seconds. This is useful if
you want to pinpoint exactly when and where an event occurred.

1.3.2 Pausing a Monitor Display
Occasionally you might want to pause a monitor display to study it more
closely or to perform a screen capture. Select the Pause item from the
Commands menu in any window to temporarily freeze the display.

Select Resume from the Commands menu to begin displaying monitor activity
again. If you paused while you were viewing an active collection, it may take
a while to "catch up" to real-time viewing when you select Resume. This is
because the Monitor displays, at normal speed, all events that occurred during
the Pause interval.

1.3.3 Stopping the Monitor
To stop the Monitor, select the EXIT option from the File menu at the top of
the Process window (shown in Figure 1–2). If you stop the Monitor before the
specified data collection period expires, data collection continues even after the
Monitor is stopped.
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1.4 Monitor Windows
The Monitor uses three main windows to progressively display resource use at
the following levels:

• Process

• Facility within a process

• Event within a facility

• Application-specific items within an event

The following sections describe how to use these windows to display data at
each of these levels. For details on how to tailor the windows to display specific
information, refer to Chapter 2.

1.5 Displaying Resource Use at the Process Level
When you start the monitor, the first window displayed is the Process window,
similar to the one shown in Figure 1–2. By default, the Process window
displays total DIO for currently running processes. To change the default item
displayed, use the Select Item choice in the Options menu.
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Figure 1–2 Process Window
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1.5.1 Removing and Restoring Process Names
If the Process window displays processes in which you are not interested, you
can temporarily remove them. The Monitor continues to collect data for the
removed process and creates a Culled Process window in which to display it.

Remove Process To remove processes from the Process window, click on the process name(s) and
then click on the Remove Processes button.

The Monitor removes the processes from the Process window and displays
them in a Culled Process window similar to the one shown in Figure 1–3.
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Figure 1–3 Culled Process Window
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Restore Process To redisplay processes, click on the process name(s) in the Culled Process
window that you wish to redisplay. Then click on the Restore Processes button
in the Culled Process window.

The Monitor removes the processes from the Culled Process window and
redisplays them in the Process window.

Note

If you find that you are consistently removing certain processes from
the Process window, you can reduce overhead and improve Monitor
performance by using the /REGISTRATION_ID qualifier on subsequent
collections. In this way you can limit these collections to images or
users of interest. For further details on this qualifier, refer to the
description of the SCHEDULE COLLECTION command in the Oracle
Trace Collector User’s Guide.
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1.6 Displaying Resource Use at the Facility Level
To display resource use for the facilities within a process, double-click on a
process name in the Process window. This expands the information displayed
for the process, by also showing the facilities within the process. The window
display is similar to that shown in Figure 1–4.

Figure 1–4 Process Window with Facilities Displayed
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To collapse the facility names from the Process window, double-click again on
the process name.
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1.7 Displaying Resource Use at the Event Level
To display resource use for the events within a facility, double-click on the
facility name in the Process window. The Monitor displays a Facility window
similar to the one shown in Figure 1–5. The window is labeled at the top with
the facility name. The events within the facility are listed in the left column of
the window.

Figure 1–5 Facility Window
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1.8 Displaying Resource Use at the Item Level
To display information about resource use at the event level, grouped by
application-specific items, double-click on an event name in the Facility
window. The Monitor displays an Event-Item window labeled at the top with
the name of the facility and the event. The window is similar to the one shown
in Figure 1–6, but it will not contain any data until you specify items for
display, as described in Section 2.5.

Figure 1–6 Event-Item Window
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Note that in the Event-Item window, the item label over the bar graph
corresponds to the report headers specified in the facility definition.
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To make optimal use of the data you can display in the Event-Item window,
you need an understanding of the application being monitored and how
it is instrumented. If you are monitoring Oracle facilities, refer to their
documentation for information on how they are instrumented.

1.9 Window Timestamps
The Monitor displays the following timestamps at the top of each window
(except for the Culled Process window):

• Current Time — determined by whether you are running the Monitor in
real-time or replay mode. In real-time mode, the Current Time reflects the
current time of day. In replay mode, the Current Time reflects the time at
which the data was originally collected. In either case, the Monitor updates
the Current Time in 5-second intervals.

• Running Since — starts out as either:

– The time that you started running the monitor in real-time

– The time in the data collection file, specified with the /SINCE qualifier,
at which you started the monitor in replay mode

If you reset running statistics, the Running Since time reflects the time
at which the reset took place. See Section 2.4 for further information.

• Last Event — the time at which the last event occurred that affected the
display.
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2
Selecting Data for Display

Since you may be interested in only certain data at certain times, the Monitor
allows you to select specific items for display in each of the Monitor windows.
In addition to allowing you to specify which items you want displayed, the
Monitor allows you to specify:

• The statistic types to display for each item

• The threshold values associated with each item

In Oracle Trace, items are elements of data associated with each event. Items
are classified as either Level, Counter, Percent, Text, or Private. Oracle Trace
automatically collects data for the following items:

• Counter Items

BIO

DIO

PAGEFAULTS

PAGEFAULTS_IO

CPU

• Level Items

CURRENT_PRIO

VIRTUAL_SIZE

WS_SIZE

WS_PRIVATE

WS_GLOBAL

Any other items that you see displayed in Monitor windows were user-specified
when the facility definition was created. Refer to the Oracle Trace Collector
User’s Guide for more information on items and on creating facility definitions.
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The following sections describe how to specify which data is displayed.

2.1 Selecting Items and Statistic Types
For each item you choose to display, you can choose up to four types of
statistics. Although some statistic types make more sense when associated
with specific items, Oracle Trace does allow you to associate any statistic type
with any item.

Follow these steps to select items and statistic types. If you are working from
the Process window, you can select only one statistic/item pair at a time. This
provides you with an overview of one item at a time across all processes.

1. Choose Select Item from the Options menu.

The Monitor displays the Select Item dialog box, which contains a list of
items for the current facility and the statistic types you can associate with
them. Figure 2–1 shows a sample of the Select Item dialog box.

Figure 2–1 Select Item Dialog Box
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2. Select one or more statistic types by clicking on the Statistic type toggle
buttons. Statistic types must be selected before Item types. (Remember
that if you are working from the Process window, you are only allowed to
select one statistic type at a time.)

3. Select items to pair with the selected statistic types by clicking on the
Item toggle buttons. (Remember that if you are working from the Process
window, you are only allowed to select one item type at a time.)
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To select all items for the selected statistic types, click on the Select All
button.

To deselect all previously selected items, click on the Clear All button.

Note

Since you can select only one statistic/item pair at a time from the
Process window, the Select All and Clear All functions are not present
at the process level.

4. The items and statistic types that you select are displayed in the window.
If you select many of them, you can use the scroll bars to view all of them.

Close the dialog box by clicking on the OK button.

5. Optional Step: If you want to save your choices to be the default display
any time you open this window, select Save Current Settings from the
Options menu.

2.2 Setting Threshold Values
Threshold values define limits of resource use according to the following levels:
Low, Medium, High, Critical, and Severe. You can define the values associated
with each level so that they meet the needs of your application.

Threshold values are set for one statistic/item pair at a time.

Follow these steps to set threshold values:

1. Choose Select Threshold Values from the Options menu.

The Monitor displays the Threshold Type Selection dialog box, as shown in
Figure 2–2.
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Figure 2–2 Threshold Type Selection Dialog Box
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2. Select a statistic type by clicking on the appropriate toggle button.

3. Click on a name in the Items list and click again in the Selection field to
place it there.

4. Click on the Set Values button.

The Monitor displays the Threshold Value Selection dialog box, as shown
in Figure 2–3.
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Figure 2–3 Threshold Value Selection Dialog Box
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5. Specify minimum and maximum values by entering them in the
appropriate fields. Specify Low, Medium, High, Critical, and Severe
values by positioning the sliders appropriately.

Linking to
Command
Procedures

6. If you have a command procedure that you want executed when severe
thresholds are reached for the statistic/item pair, enter a file specification
for the procedure in the Severe Threshold Procedure box. (See Appendix A
for information on the required format for such a command procedure.)

If you do not want to enter a command procedure, proceed to step 7.

The file specification you enter cannot exceed 50 characters. You should
create a logical name for the file if the file specifications is longer than 50
characters.

To change the name of a command procedure that you previously specified
for this item and statistic type, enter the name of the new command
procedure in the Severe Threshold Procedure text field.
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To permanently eliminate the link between an item and command
procedure, delete the command procedure name from the Severe Threshold
Procedure text field and then select Save Current Settings from the
Options menu.

Although you can link severe thresholds with command procedures from
any of the three Monitor windows, the window at which you specify a link
determines how and when notification takes place. Specifically:

• If the command procedure is specified at the Process and Facility
windows, it executes whenever resource use for any event in any
process exceeds the item’s severe threshold, whether or not the Monitor
is currently displaying the item value.

• If the command procedure is specified at the Event-Item window,
it executes only if the Monitor is displaying the item value when
it exceeds the severe threshold. This is because in the Event-Item
window, the Monitor only retains data while it is displayed.

Note

If you plan to use the threshold notification capability, Oracle
recommends that you select values for the severe thresholds with
care, because excessive execution of command procedures can degrade
Monitor performance.

7. At this point you can still click on the Cancel button to cancel any changes
you have made and close the Threshold Value Selection dialog box. Or you
can apply the changes by going on to the next step.

8. Click on the OK or Apply button to see the new thresholds reflected in the
bar graph. The Apply button keeps the Threshold Value Selection dialog
box open; the OK button closes it.

9. Now you can either set threshold values for another statistic/item pair or
you can finish setting threshold values.

To set values for another pair, return to the Threshold Type Selection
dialog box (step 2).

To finish setting threshold values, close the Threshold Value Selection
dialog box by clicking on the OK button. Then click on the Cancel button
in the Threshold Type Selection dialog box to close that box.

10. Optional step: You can save the threshold values you have set as the
defaults by selecting Save Current Settings from the Options menu.
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2.3 Disabling Command Procedure Execution
To temporarily disable execution of the command procedures for all Monitor
windows, select Threshold Notification from the Options menu and click on
Disable.

To reinstate command procedure execution, select Threshold Notification from
the Options menu and click on Enable.

2.4 Resetting Running Totals and Averages
The Monitor allows you to reset the values of running totals and running
averages so that you can track resource use from a specific time. The Monitor
displays the time of the reset in the Running Since timestamp.

The running values that get reset are determined by the window at which you
select the Reset option. This is described further in Table 2–1.

Table 2–1 Resetting Running Values

To reset running values... Do this...

At the process level Select Reset-Totals from the Options menu
in the Process window and click on Process.

For all items in all windows Select Reset-Totals from the Options menu
in the Process window and click on Select
All.

For all events Select Reset-Event-Totals from the Options
menu in the Facility window.

For all items in the current Event-Item
window

Select Reset-Event-Totals from the Options
menu in the Event-Item window.

2.5 Displaying Resource Use Grouped by Item Value
The Monitor allows you to display resource use for each event, grouped by the
values of level and text items. This capability is similar to that provided by the
/GROUP_BY qualifier in the Oracle Trace Reporter.

The following steps describe how to specify which items you want displayed in
the Event-Item window and how you want them grouped.

1. From the Event-Item window, choose Select Items from the Options menu.

Selecting Data for Display 2–7



The Monitor displays the Item Selection dialog box, which contains statistic
types and counter items associated with the event. Figure 2–4 shows a
sample Item Selection box.

Figure 2–4 Event-Item Selection Dialog Box

NU−3131A−RA

2. Select one or more statistic types by clicking on the toggle buttons.

3. Perform the action associated with the result that you want:

• To select an item for the selected statistic types, click on the toggle
button for the item.

• To select all items for the selected statistic types, click on the Select All
button.

• To deselect all previously selected items, click on the Clear All button.

4. From the Event-Item window, choose Group By from the Options menu.
The Monitor displays the Item Grouping Selection dialog box, shown in
Figure 2–5. This box displays the level and text items that were specified
in the facility definition. See the Oracle Trace Collector User’s Guide for
information on creating facility definitions.
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Figure 2–5 Item Grouping Selection Dialog Box
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5. To select the items by which you want to group the data, do the following:

a. Click on an item in the list labeled Group By. Then click in either the
Level 1, Level 2, or Level 3 text field (items must be entered in order).
The item is displayed in the text field. (You must select at least one
item in order for any data to appear.)

Data is grouped first by Level 1, then by Level 2, and last by Level 3.

You can remove items from a text field by clicking on them and then
clicking on the Remove button.

b. Click on the OK or Apply button to display event occurrences grouped
according to the items you selected.

The Apply button keeps the Item Grouping Selection dialog box open;
the OK button closes it.

c. Optional step: Select the Save Current Settings option from the
Options menu to save these items as defaults.
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If the Event-Item window is not wide enough to display all the information,
you can widen it using the Resize_screen option in the Commands menu.
You can also change the size of the scroll lists in this window by editing the
EPC_MONITOR.DAT file. See Chapter 3 for further information on both of
these features.
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3
Customizing Monitor Displays

Oracle Trace allows you to customize your monitor displays by changing
window colors and window size and position. Window size and position are
changed from within the Monitor. Colors and other features such as the
size of scroll lists and column characteristics are changed by editing the
EPC_MONITOR.DAT file.

3.1 Changing Window Size and Position
If you need to change the size of Oracle Trace windows, use the following steps:

1. Change the window to the desired size and then click on the Resize_screen
option in the Commands menu. The data displayed in the window is
adjusted to fit within the new window dimensions. (Resize_screen is not
available for the Process window.)

2. Optional Step: If you want the new size for this window to be in effect in
subsequent sessions, click on Save Current Settings in the Options menu.
Otherwise, the new size is in effect only for the current session.

You can also use Save Current Settings if you have moved a window and
want to save the new position of the window for future sessions.

When you select Save Current Settings, a message is displayed that tells you
the name of the file in which the settings have been saved. You should make a
note of this file name in case you want to edit it in the future.

3.2 Changing Display Characteristics
Oracle Trace allows you to customize certain aspects of monitor displays such
as colors, fonts, and column characteristics. To do this, you must edit the
EPC_MONITOR.DAT file. The Monitor creates this file in your SYS$LOGIN
directory the first time you run the Monitor.
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If you have not run the Monitor yet, you need to copy the file to the directory
from which you plan to run the Monitor. Use the following command to do
this:

$ COPY DECW$SYSTEM_DEFAULTS:EPC_MONITOR.DAT SYS$LOGIN:*.*

Edit the file and make the appropriate changes as described in Table 3–1.

Table 3–1 Customizations by Editing EPC_MONITOR.DAT

If You Want to Change . . . Search for . . . And . . .

the size of the scroll list in
the event level windows

eveite_vlist_vframe.height: change its value to the size (in font
units) that you want for the event level
windows.

threshold colors the color that you want to
change. Threshold colors are
associated with process.xxxxx
threshold names, for example
process.high_color

replace it with the color you prefer. If
you are running the Monitor on a black
and white terminal, set all colors to
black.

column positions or remove a
column from the Process level
window

process.xxxx_position, for
example process.node_
position

change values as appropriate:

– Value 1 = the left-most column
position

– Value 5 = the right-most column
position

– Value 0 = do not display the column

column widths process.xxxx_width, for
example, process.node_width

change the value to the width (in
characters) that you want for the
column.

the direction in which the
Monitor sorts Process window
items

Sort_by_item Change values as appropriate:

– Value 1 = sorted from large to small
resource item

– Value 0 = sorted from small to large

The Monitor will re-sort the list for every
refresh cycle.

the font used for the event
names and statistics

VHist.font: change the font name and size.

(continued on next page)
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Table 3–1 (Cont.) Customizations by Editing EPC_MONITOR.DAT

If You Want to Change . . . Search for . . . And . . .

the font used for process
names (this also affects
Event-item names and
information in the Event-item
window)

VList.fontTable: change the font name and size.

the font used for display
headers

VHeader.fontTable: change the font name and size.

the font used for menu items,
date, and time

fontList: change the font name and size.

the Facility window to
display complete Event
names (if they are being
cut off on the left side)

vhist_w.leftLabelWidth: increase the value as necessary.

the Facility window to
display complete bar graph
on the right side

vhist_w.rightLabelWidth: increase the value as necessary.

Since fonts can appear to look slightly different on different terminals, you
may have to experiment with a few font/size combinations until you find one
that suits you. The default font settings should work well for most terminals.
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A
Command Procedure Format

The command procedures that you create for the Monitor to call when item
values exceed severe threshold limits can be any size and can perform any
actions. Oracle supplies a sample command procedure that you can use as an
example when you write your own. The sample command procedure, found
in EPC$EXAMPLES:EPC_MON_THRESH.COM, writes severe threshold
notification messages to EPC$MON_THRESH_ERR.LOG.

When the Monitor calls your command procedures, it passes an argument in
the form of a text string. The argument contains the following fields. Each
field is delimited by the pound sign character (#).

Time the event occurred
Node Name
Process ID
Image Name — Trimmed to 32 characters, no disk or directory information
Process Name
Facility Number
Event Number
Item Number
Threshold type — 5 (to indicate the severe threshold)
Threshold statistic type

0 = totals
1 = average
2 = running totals
3 = running average

Threshold value — The value of the severe threshold
Item value — The item value that exceeded the threshold. If values exceed
the threshold at the Event-Item window where the Monitor displays data
sorted by item values, the argument also contains values of up to three
sort keys. These fields are limited to 20 characters each.
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