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1 

Introduction 

Oracle Enterprise Governance, Risk and Compliance (GRC) is a set of products that 

regulate activity in business-management applications. This document provides instruc-

tions for the installation or upgrade of the following GRC products: 

• Oracle Enterprise Governance, Risk and Compliance Manager (EGRCM) forms 

a documentary record of a company’s strategy for addressing risk and complying 

with regulatory requirements. 

• Oracle Advanced Controls enables users to create “models” and “continuous con-

trols.” Two Advanced Controls applications run from within the GRC platform: 

– In Oracle Enterprise Transaction Controls Governor (ETCG), models and 

controls specify circumstances under which individual transactions display 

evidence of error, fraud, or other risk.  

– In Oracle Application Access Controls Governor (AACG), models and 

controls define conflicts among duties that can be assigned in a company’s 

applications, and identify users who have access to those conflicting duties. 

AACG can also implement “preventive analysis” — it can evaluate controls 

as duties are assigned to users of the company’s applications, preventing them 

from gaining risky access. 

• Oracle Fusion GRC Intelligence (GRCI) extracts data from GRC for display in 

dashboards and reports. 

You can install GRC on its own, or to be integrated with an OID LDAP server that 

manages GRC users. (OID stands for Oracle Internet Directory; LDAP for Lightweight 

Directory Access Protocol.)  

You can embed a GRCI instance within GRC. To use GRCI, install GRC first (see 

chapter 2). Then integrate GRCI with GRC (see chapter 3). 
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Prerequisites 

You can install GRC 8.6.6.4000 only as an upgrade to version 8.6.6.3000. GRC runs 

on a 64-bit Linux server and requires the following. It’s assumed you will continue to 

use components already installed for version 8.6.6.3000. 

• An Oracle 12.1.0.2 (12c) database, by preference. During earlier upgrades, you 

may have retained an Oracle 11.2.0.4 or 11.2.0.3 database. You can continue to 

use that database with version 8.6.6.4000. 

In the database, a GRC schema must be created. If you implement GRCI, a data 

analytics (DA) schema must exist as well. The database that supports the GRC 

schema must use the AL32UTF8 character set. 

If you want to upgrade to the 12c database, follow this sequence to install GRC 

8.6.6.4000: Upgrade your database to 12c, import your GRC schema to the 12c 

database, upgrade GRC, then point your GRC instance to the new database (see 

“GRC Configuration” beginning on page 8). 

• Java: Oracle JDK 1.7 or higher. GRC must have its own dedicated Java con-

tainer. It was not designed to coexist in a container with other web applications. 

• Middleware: To support GRC, use WebLogic Server 12c (12.1.2) or Tomcat 

Application Server 7.0.47. If you use WebLogic Server (WLS), you also need Ap-

plication Development Runtime (ADR) 12.1.2 and Repository Creation Utility 

(RCU) 12.1.2. In the 12c release, RCU is packaged with ADR. 

If you intend to run GRCI, you also need WLS 11g (10.3.6), installed with RCU 

11.1.1.7 and ADR 11.1.1.7. This is true even if you use WLS 12c to support GRC 

itself.  

As an option, an OID LDAP server can manage GRC users. 

On the server or a client system, the following web browsers can display the GRC 

interface: Microsoft Internet Explorer 11x or FireFox 38.5 or 43.04.  

For details about supported components, see the Oracle Enterprise Governance, 

Risk and Compliance Certifications Document. 

Recording Configuration Values 

Make a note of certain configuration values for version 8.6.6.3000, as you will need 

to re-enter them for version 8.6.6.4000. All these values are displayed in the GRC 

Manage Application Configurations page. (Start the GRC 8.6.6.3000 instance, then 

select Navigator → Setup and Administration → Setup → Manage Application 

Configurations). 

• Select a Properties tab and note values you will need to enter in a ConfigUI 

page during 8.6.6.4000 installation. 

• If you have set up GRC to work with an OID LDAP repository, select a User 

Integration tab and note the values entered there. 

• If you use GRCI, select an Analytics tab and note the values entered there. 
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Downloading Files 

Create a staging directory on your GRC server. (Throughout this document, 

<grc_stage> represents the full path to this directory.) 

To upgrade GRC, download a file called grc866_4037.zip to <grc_stage>, and 

extract its contents there. To validate your download, generate a checksum and 

compare it with a checksum value published in Release Notes for the instance you 

are installing. To generate a checksum, run the command md5sum grc.ear. 

If you have not embedded GRCI in your 8.6.6.3000 instance, but wish to do so for 

8.6.6.4000, you can do so only if you created a Data Analytics (DA) schema for 

GRC 8.6.6.1000 and upgraded it (reconnected it to GRC) for in each subsequent 

release. If so, download files called grc865_1_OBIEE_ 1of3.tar.gz, grc865_1_OBIEE_ 

2of3.tar.gz, and grc865_1_OBIEE_3of3.tar.gz to <grc_stage>.  

For you to embed GRCI in GRC, your instance must run with WebLogic. If you use 

Tomcat, you can run GRCI only as a standalone application. You do not need the three 

grc865_1_OBIEE files for standalone GRCI, or if you have already embedded GRCI 

in your 8.6.6.3000 instance. 
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Upgrading GRC 

In broad terms, the upgrade to GRC 8.6.6.4000 involves these steps: 

1. Ensure that two directories, for the storage of GRC report data and ETL data, 

are ready for use. 

2. Remove some files installed for your GRC 8.6.6.3000 instance, and run a setup 

script. 

3. Restart the WebLogic or Tomcat application server, then perform configuration 

steps in a GRC ConfigUI page. 

4. Restart your application server to complete the installation. 

No matter whether you use WebLogic or Tomcat, you will (as noted in chapter 1) 

reuse Java and middleware components installed for GRC 8.6.6.3000. 

You may continue to use the database installed for your 8.6.6.3000 instance or, if 

that database is 11.2.0.3 or 11.2.0.4, you may upgrade to 12c. If so, perform the 

upgrade and import your GRC and DA schemas to the new database before com-

pleting the procedures in this chapter. 

Back up your database, schema, middleware components, and report and transaction 

ETL repositories. 

GRC Repositories 

For your earlier version of GRC, you should have created two “repositories” — 

directories that store data generated by GRC. A report repository stores copies of 

GRC reports that users schedule to be run. A second repository stores synchroniza-

tion data used for transaction analysis. 

Reuse these repositories for GRC 8.6.6.4000. Retain the contents of the transaction 

synchronization repository. Note the paths to the repositories, as you will need to 

supply them later as configuration values. 
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GRC with WebLogic 

If you installed GRC to run with WebLogic Server, complete the following steps: 

1. Stop the WebLogic Administration Server and (if any exist in your installation) 

managed servers. 

2. During installation of earlier GRC releases, a directory called grc866 was created, 

typically as a subdirectory of your middleware home directory (represented in 

this document as <MW_HOME>). Delete the contents of this directory. 

3. Navigate to <grc_stage>/dist, and locate a grc.ear file. 

4. Extract the contents of grc.ear into the grc866 directory. 

5. Navigate to <grc_stage>/dist. From there, run the file grc_wls_setup.sh. Supply 

the path to the grc866 directory (into which you extracted the contents of the 

grc.ear file in step 4). For example: 

cmd> ./grc_wls_setup.sh <MW_HOME>/grc866 

6. Remove content from the following directories. (In these paths, <grc_domain> 

represents the name of the WebLogic domain created for GRC during installa-

tion of version 8.6.6.1000, and <managed_server> is the name of a WebLogic 

managed server, if one was created during installation of version 8.6.6.1000.) 

<MW_HOME>/user_projects/domains/<grc_domain>/servers/AdminServer/logs 

<MW_HOME>/user_projects/domains/<grc_domain>/servers/AdminServer/cache 

<MW_HOME>/user_projects/domains/<grc_domain>/servers/AdminServer/tmp 

<MW_HOME>/user_projects/domains/<grc_domain>/servers/<managed_server>/ 

logs 

<MW_HOME>/user_projects/domains/<grc_domain>/servers/<managed_server>/

cache 

<MW_HOME>/user_projects/domains/<grc_domain>/servers/<managed_server>/ 

tmp 

7. Copy the files jython-2.5.1.jar and xdoparser-10.1.3.4.jar from <grc_stage>/lib 

to <MW_HOME>/user_projects/domains/<grc_domain>/lib. 

8. Navigate to the file setDomainEnv.sh, and open it in a text editor. The file is 

located in the <MW_HOME>/user_projects/domains/<grc_domain>/bin directory. 

9. In setDomainEnv.sh, locate the following lines: 

if [ "${PRE_CLASSPATH}" != "" ] ; then 

CLASSPATH="${PRE_CLASSPATH}${CLASSPATHSEP}${CLASSPATH}" 

export CLASSPATH fi 

10. Add the following before those lines: 

PRE_CLASSPATH="<MW_HOME>/user_projects/domains/<grc_domain>/

lib/jython-2.5.1.jar:${PRE_CLASSPATH}" export PRE_CLASSPATH 

(Replace <MW_HOME> and <grc_domain> with the specific values appropriate 

for your environment.) 

Note: You may skip steps 7–10 if you have already performed them for a prior 

release. 

11. Restart the WebLogic servers. 
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GRC with Tomcat 
If you installed GRC to run with Tomcat Application Server, complete the follow-

ing steps: 

1. Shut down the Tomcat Application Server. 

2. Remove the directory <TomcatHome>/webapps/grc and all its contents. 

3. Remove the Catalina directory from the Tomcat work area (<TomcatHome>/work/ 

Catalina). Delete the contents of <TomcatHome>/temp. Also delete Tomcat logs, 

located at <TomcatHome>/logs. (You may want to save them to another location.) 

4. Navigate to <TomcatHome>/webapps and delete the grc.war file. 

5. Navigate to <grc_stage>/dist. From there, run the file grc_tomcat_setup.sh. 

Supply the paths to the <grc_stage>/dist subdirectory, <TomcatHome>, and the 

full path to your Java home as parameters: 

cmd> ./grc_tomcat_setup.sh <grc_stage>/dist <TomcatHome> 

<JavaHomePath> 

6. Copy the file xdoparser-10.1.3.4.jar from <grc_stage>/lib to 

<TomcatHome>/webapps/grc/WEB-INF/lib. 

7. Start the Tomcat application server. 

GRC Log-On URL 
When you installed release 8.6.6.1000 of GRC, you may have set it up to support 

Secure Sockets Layer (SSL). How you log on to GRC depends on whether it does or 

does not support SSL. 

If you have not set up GRC to use SSL, log on with the following URL: 

http://host:http_port/grc 

Replace host with the fully qualified domain name (FQDN) of your GRC server. 

Select one of the following values for http_port: 

• If you use WebLogic 12c, enter the port number you chose for the Administra-

tion Server as you created a WebLogic domain. 

• If you use Tomcat, enter 8080 (if you accepted the default value when you 

installed Tomcat) or your configured value (if you changed the default during 

Tomcat installation). 

If you have set up GRC to use SSL, log on with the following URL: 

https://host:https_port/grc 

Again, replace host with the FQDN of your GRC server. Select one of the following 

values for https_port: 

• If you use WebLogic 12c, enter the port number you selected as the SSL Listen 

Port when you set up SSL for GRC. 

• If you use Tomcat, enter the port number you selected as the Connector Port 

when you set up SSL for GRC. 

However, a third logon URL applies if you set up GRC to recognize Single Sign On 

(SSO). See “Integrating with Single Sign On Authentication,” beginning on page 12. 
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GRC Configuration 

Regardless of whether you use WebLogic or Tomcat, perform GRC-specific config-

uration: 

1. Open a ConfigUI page: Navigate to your GRC log-on URL. If prompted, supply 

the admin user ID along with a password established for that user ID during 

installation of version 8.6.6.1000. 

2. In the Installation Configuration section, type or select appropriate property 

values: 

• User Name: Supply the user name for the GRC database. 

• Password: Supply the password for the GRC database.  

• Confirm Password: Re-enter the password for the GRC database.  

• Port Number: Supply the port number at which the GRC database server 

communicates with other applications.  

• Service Identifier: Supply the service identifier (SID) for the GRC database 

server, as configured in the tnsnames.ora file.  

• Server Name: Supply the FQDN of the database server.  

• Maximum DB Connections: Default is 50. You can edit this value. 

• Report Repository Path: Supply the full path to the Report Repository 

directory discussed in “GRC Repositories” on page 5.  

• Log Threshold: Select a value that sets the level of detail in log-file entries. 

From least to greatest detail, valid entries are error, warn, info, debug, and 

trace. Select trace only if Oracle Support instructs you to do so. 

• Transaction ETL Path: Enter the full path to the directory you created to 

hold ETL data used by Enterprise Transaction Controls Governor (see 

“GRC Repositories” on page 5). 

• App Server Library Path: Enter the full path to the library subdirectory of 

your web application server (for use in the upload of custom connectors for 

AACG). If you use Tomcat Application server and intend to enable parallel 

processing (see step 4 below), set this field to the “lib/adf” subdirectory of the 

Tomcat home directory. 

3. In the Language Preferences section of the ConfigUI page, select check boxes 

for up to twelve languages in which you want GRC to be able to display infor-

mation to its users. “English (U.S.)” should be selected by default; do not 

deselect it. 

4. In the Performance Configuration section of the ConfigUI page, select or clear 

check boxes: 

• Optimize Appliance-Based Operation: Select the check box to optimize 

performance if the GRC application and GRC schema reside on the same 

machine. Do not select this check box if the GRC application and schema 

do not reside on the same machine. When you select this check box, an 

ORACLE_HOME Path field appears. In it, enter the full, absolute path to your 
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Oracle Home — the directory in which you have installed the Oracle data-

base that houses the GRC schema. 

• Enable Graph Synchronization Date Limit: “Data synchronization” enables 

GRC to recognize data changes in each business application subject to 

models and controls. Although the concept applies to AACG and ETCG, 

the process works differently for the two applications. 

Either application recognizes “business objects,” each of which is a set of 

related fields from a “data source” (business application). ETCG distin-

guishes among three categories of business object — Transaction (in which 

records are created or updated frequently), and Operational and Configura-

tion (consisting of master-data or setup records that change infrequently).  

For ETCG only, select the Enable Graph Synchronization Date Limit check 

box to cause the synchronization of Transaction business objects to operate 

only on records created or updated in data sources on or after a specified date.  

The setting of this check box has no effect on ETCG Operational or Config-

uration business objects, for which a synchronization run encompasses all 

records, no matter when they were created or updated. Moreover, AACG 

does not distinguish among business-object categories, and the setting of 

this check box has no effect on AACG synchronization runs. 

When you select the check box, a Transactions Created As Of field appears. 

In it, enter the cutoff date for the synchronization of ETCG Transaction busi-

ness objects. When you click in the field, a pop-up calendar appears. Click 

left- or right-pointing arrows to select earlier or later months (and years), 

and then click on a date in a selected month. 

• Externalize Report Engine: Select the check box to enable the reporting 

engine to run in its own java process, so that the generation of large reports 

does not affect the performance of other functionality. But select the check 

box only if you have installed GRC on hardware identified as “certified” in 

the Oracle Enterprise Governance, Risk and Compliance Certifications Doc-

ument; clear the check box if you use hardware identified as “supported.” 

• Enable Parallel Processing: Select this check box to enable multiple jobs to 

run simultaneously. When you select the Enable Parallel Processing check 

box, two fields appear:  

Number of Cores Available for Processing: Enter the number of processor 

cores you wish to devote to parallel processing. GRC uses one core for each 

job, until as many cores as you specify here are in use.  

Maximum Megabytes of Physical RAM Available: Specify an amount of 

memory for use in parallel processing. Ensure that this value is at least 16 

GB times the number of cores. GRC then divides the memory value by the 

core value to determine the actual amount of memory per core.  

This value is in addition to what is already allocated to the WebLogic 

Admin server or Tomcat server. Review the amount of memory allocated to 

other processes (such as Linux or database management) before allocating 

memory to parallel processing. Important: Allocating more memory than 

what is available causes disk swapping, which causes poor performance 

during peak load. 
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• Enforce Allocated Analysis Time Per Filter: Select this check box, and 

enter a number in the Minutes field, to limit the time that transaction models 

and controls can run.  

A model or control consists of filters, each of which defines some aspect of 

a risk and selects transactions that meet its definition. When the Allocated 

Analysis Time feature is enabled, each filter runs no longer than the number 

of minutes you specify. If time expires, the filter passes records it has selected 

to the next filter for analysis, but ignores records it has not yet examined. So 

a filter may not capture every record that meets its definition, and the model 

or control results are labeled “partial” in GRC job-management pages.  

Once enabled here, this feature may be disabled for individual models (and 

for the controls developed from those models). This feature applies only to 

transaction models and controls, not to access models and controls, and not 

to EGRCM objects.  

5. In the ConfigUI page, click on Actions → Save. GRC tests the values you’ve 

entered and, if they are valid, saves them. (If any are invalid, an error message 

instructs you to re-enter them.) 

6. Exit the ConfigUI page.  

Completing the Installation 

With components in place and properly configured, complete the installation, in 

effect by running your web application server.  

1. Shut down your server — the Administration Server if you’re using WebLogic, 

or the Tomcat application server if you’re using Tomcat. Then restart the server. 

2. In a web browser, enter the GRC URL (see “GRC Log-On URL,” page 7).  

3. Wait for a progress bar to indicate that initialization is complete.  

4. You are redirected to a GRC logon page. Log on to the application. Use the 

admin user ID, with a password established for that user ID during the installation 

of version 8.6.6.1000. 

If you have not set up an external OID LDAP repository to manage users, basic 

GRC installation is complete. (You may, however, choose complete other proce-

dures described later.) 

If you have set up an OID LDAP repository, complete these additional steps: 

1. In GRC, select Navigator → Setup and Administration → Setup → Manage 

Application Configurations. 

2. To configure external OID LDAP, select the User Integration tab and enter the 

following values: 

• Enable Single Sign On: See “Integrating with Single Sign On Authentica-

tion” on page 12. 

• Enable Integration: Select the check box to permit integration with LDAP to 

occur. 
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• User Name: Supply the user name (common name) to log in to the LDAP 

server. This user should have admin privileges.  

• Password: Enter the password for the user identified in the User Name field. 

• Confirm Password: Re-enter the password for the user identified in the User 

Name field. 

• Port: Enter the port number at which the LDAP server communicates with 

other applications. 

• Server Name: Enter the host name of the LDAP server.  

• Bind DN Suffix: Enter the “User Base DN.”  

• Enable SSL Authentication: Select the box to allow GRC to access the LDAP 

server through SSL. If you select this option, the LDAP server must be con-

figured to support SSL. 

• Perform LDAP Recursive Search: Select the check box to search recursively 

for users in subfolders along with those in the base path specified in the Bind 

DN Suffix field. 

• Unique User Identifier: uid 

3. In the Manage Application Configurations page, click on Actions → Save. Then 

log off of GRC. 

4. Stop the GRC Deployment in the WebLogic Console: 

a Log in to the WebLogic Console at  

http://host:port/console 

Replace host with the FQDN of your GRC server, and port with the number 

you selected for the WebLogic Administration Server as you set up a 

WebLogic domain. 

b From the Domain Structure menu, select Deployments. 

c From the Deployment page, locate the GRC deployment and verify the state 

is Active. 

d Click the checkbox next to the GRC deployment. 

e From the toolbar, click Stop → Force Stop Now. 

5. Start the GRC Deployment in the WebLogic Console: 

a From the Domain Structure menu, select Deployments. 

b From the Deployment page, locate the GRC deployment and verify the state 

is Prepared. 

c Click the checkbox next to the GRC deployment. 

d From the toolbar, click Start → Servicing All Requests.  
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Integrating with Single Sign On Authentication 

Rather than use the GRC authentication system to authenticate GRC users, you can 

integrate GRC with Oracle Access Management (OAM) Single Sign On (SSO). To do 

so, you must have installed GRC to run with WebLogic; SSO is not supported in a GRC 

instance that runs with Tomcat. Moreover, you require not only OAM 11gR2, but 

also Oracle HTTP Server (OHS) 11g Webgate for OAM. 

First, register OHS Webgate 11g Agent for OAM 11g: 

1. Log on to the OAM console. Its URL is 

http://<oam_host>:<oam_port>/oamconsole, in which <oam_host> is 

the host name of the OAM server, and <oam_port> is its port number.  

2. On the Agents grid of the Application Security tab, select Create Webgate. 

3. On the Create Webgate page, enter the following values: 

• Version: Select 11g. 

• Name: Enter any value to create a name for the agent.  

• Base URL: Enter http://<host>:<port>, in which <host> is the host 

name of the machine where Oracle HTTP Server 11g Webgate is installed, 

and <port> is its port number.  

• Security: Select Open.  

• Host Identifier: Enter either the Name or the Base URL value. 

• Select the Auto Create Policies check box. 

• In the Protected Resource List, add /grc. 

Leave the Access Client Password and User Defined Parameters fields blank, 

and leave the Virtual Host and IP Validation checkboxes unselected.  

4. Click the Apply button.  

5. The Create Webgate page refreshes. In a new Logout URL field, enter a logout 

URL, for instance /oamsso/logout.html. 

6. Click the Apply button again.  

Once the agent is created, update the authentication scheme to your LDAP scheme:  

1. Select the Application Security tab.  

2. Click Application Domains, then search for and select your agent name.  

3. Select the Authentication Policies tab. On it, click Protected Resource Policy. 

4. Click the Open icon.  

5. Select your LDAP authentication scheme. 

6. Click the Apply button. 

Next, create a response: 

1. Select the Application Security tab. 

2. Click Application Domains, then search for and select your agent name. 
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3. Select the Authorization Policies tab. On it, click Protected Resource Policy. 

4. Click the Add icon. 

5. Enter these values: 

• Name: OAM_REMOTE_USER 

• Type: Header 

• Value: $user.userid 

6. Click Add. 

7. Click the Apply button. 

Next, copy the Webgate artifacts.  

1. Copy ObAccessClient.xml and cwallet.sso 

From: <oam_domain_home>/output/<agent>/ 

To: <MW_HOME>Oracle_WT1/instances/instance1/config/OHS/ohs1/ 

webgate/config 

Next, modify OHS to redirect to GRC.  

1. On the server on which you’ve installed OHS, navigate to 

<MW_HOME>/Oracle_WT1/instances/instance1/config/OHS/ohs1.  

2. Open the mod_wl_ohs.conf file in a text editor and add the following infor-

mation to it: 

<IfModule weblogic_module> 

  Debug ON 

  WLLogFile /tmp/weblogic.log 

</IfModule> 

<Location /grc> 

  SetHandler weblogic-handler 

  WebLogicHost <GRC_HOST_NAME> 

  WebLogicPort <GRC_PORT_NUMBER> 

</Location> 

Replace <GRC_HOST_NAME> with the FQDN of your GRC server. Replace 

<GRC_PORT_NUMBER> the number of your HTTP Port if SSL is not enabled, or 

your HTTPS Port if SSL is enabled. See “GRC Log-On URL” (page 7) for 

more information on identifying these port numbers. 

3. Save and close the mod_wl_ohs.conf file. 

4. Restart the OAM server and Webgate. 

Next, add the OAM Identity Asserter to the GRC domain: 

1. Log in to the WebLogic Server Administration Console: 

http://host:port/console 

Replace host with the FQDN of your GRC server, and port with the number you 

selected for the WebLogic Administration Server.  

2. Click Lock and Edit. 

3. Click Security Realms (on the left under Domain Structure), then click myrealm. 
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4. In the Providers tab, click the New button, and enter OAM Identity Asserter for 

both Name and Type. Then click the OK button. 

5. In the Providers tab, click the newly created OAM Identity Asserter. 

6. In the Common tab, select: 

• ControlFlag: Required 

• Active Types — Choose: OAM_REMOTE_USER (remove ObSSOCookie 

from the Chosen box) 

Click the Save option. 

7. Return to the Providers tab, click on DefaultAuthenticator, change the 

ControlFlag to SUFFICIENT, and click the Save option.  

8. In the Providers tab, reorder the authentication providers so that OAM Identity 

Asserter is first, DefaultAuthenticator is second, and DefaultIdentityAsserter is 

third. Then click the OK button. 

9. Click Activate Changes and restart the application server.  

Finally, enable SSO in GRC: 

1. Log on to GRC and select Navigator → Setup and Administration → Setup → 

Manage Application Configurations. Select the User Integration tab. (You are 

presumed to have already set OID LDAP values on this page, as described in 

“Completing the Installation,” beginning on page 10.) 

2. Select the Enable Single Sign On check box.  

3. Enter your logout URL in the OAM 11gR2 Logout URL field.  (This should be 

the same value as you entered in the Create Webgate page as you registered an 

agent for GRC.) 

4. Select the Save option from the Actions menu. Verify that you receive a message 

stating that configuration values were saved successfully. 

5. Select Navigator → Setup and Administration → Security → Manage Users. 

Select the Import from LDAP option from the Actions menu and import users. 

6. To enable SSO logout: 

• Log off of GRC and navigate to <MW_HOME>/wlserver/common/bin/. 

• Execute the following command to start wlst.sh: 

./wlst.sh 

• Execute the following command at the wls:/> prompt: 

addOAMSSOProvider(loginuri="/${app.context}/adfAuthentication", 

logouturi="/oamsso/logout.html", autologinuri="/obrar.cgi") 

Once you have configured SSO for GRC, the URL to access GRC is: 

http://<webgate_host>:<webgate_port>/grc 

Or, if a secure protocol like SSL or TLS has been enabled in the OAM application 

server, the leading characters of the URL are https:// 

https://<webgate_host>:<webgate_port>/grc 

Communicate this URL to all GRC users. 
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GRC and SSL 

When you installed release 8.6.6.1000 of GRC, you may have set it up to support 

Secure Sockets Layer (SSL). If so, complete the following steps to ensure that GRC 

communicates properly with preventive enforcement agents (PEAs) installed in Oracle 

E-Business Suite instances subject to AACG analysis.  

1. Copy the file axis2.xml from <grc_stage>/conf to: 

• <MW_HOME>/user_projects/domains/<grc_domain>/grc/WEB-INF/conf, if 

you installed GRC to run with WebLogic. 

• <TomcatHome>/webapps/grc/WEB-INF/conf, if you installed GRC to run 

with Tomcat. 

2. Copy the file addressing-1.7.3.mar from <grc_stage>/modules to: 

• <MW_HOME>/user_projects/domains/<grc_domain>/grc/WEB-INF/modules, 

if you installed GRC to run with WebLogic. 

• <TomcatHome>/webapps/grc/WEB-INF/modules, if you installed GRC to 

run with WebLogic. 

3. Open the axis2.xml file in a text editor. In it, search for the following text: 

<transportReceiver name="http" 

class="org.apache.axis2.transport.http.AxisServletListener">  

<parameter name="port"><add HTTP Port></parameter>  

</transportReceiver>  

<transportReceiver name="https" 

class="org.apache.axis2.transport.http.AxisServletListener">  

<parameter name="port"><add HTTPS Port></parameter>  

</transportReceiver> 

4. In that passage:  

• Replace the phrase “add HTTP Port” with the number of the port GRC 

would use if SSL were not enabled. 

• Replace the phrase “add HTTPS Port” with the number of the port GRC 

uses once SSL is enabled. 

See “GRC Log-On URL” (page 7) for more information on identifying these 

port numbers. 
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Integrating GRCI 

Oracle Fusion GRC Intelligence (GRCI) makes use of Oracle Business Intelligence 

Enterprise Edition (OBIEE) and a Data Analytics (DA) schema. (The database that 

supports the DA schema should have an initial temporary tablespace of 100 GB with 

autoextend enabled.) 

You can run GRCI only if the DA schema was created for a release of GRC that 

could be installed independently of earlier releases — in this case, 8.6.6.1000 —

then reconnected to GRC for each subsequent upgrade-only release of GRC. 

GRCI components have not changed for this release. If you are updating an instance 

of GRCI already present in GRC 8.6.6.3000, you need only reconnect your DA schema 

(as described in the following section).  

You may install a “fresh” instance of GRCI only if a DA schema was created for 

release 8.6.6.1000, then reconnected to GRC for release 8.6.6.2000 and 8.6.6.3000. 

If so, install OBIEE and supporting middleware components as instructed in version 

8.6.6.1000 of the GRC Installation Guide, and perform upgrades as instructed in 

versions 8.6.6.2000 and 8.6.6.3000 of the GRC Installation Guide. 

Connecting to the DA Schema 

The GRC schema used by GRC supplies data to the DA schema used by GRCI. For 

this to happen, you need to enter connectivity information in GRC.  

1. Log on to GRC (see “GRC Log-On URL,” page 7). Select Navigator → Tools 

→ Setup and Administration → Setup → Manage Application Configurations → 

Analytics. 

2. In the Data Analytics Configuration section, enter values that identify the DA 

schema. (These are values that you noted earlier. See “Recording Configuration 

Values” on page 2.) 

• User Name: Supply the user name for the DA database. 

• Password: Supply the password for the DA database. 

• Confirm Password: Re-enter the password for the DA database. 

• Port Number: Supply the port number at which the database server 

communicates with other applications. 
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• Service Identifier: Supply the service identifier (SID) for the database 

server. 

• Server Name: Supply the fully qualified domain name of the database server. 

3. When you finish entering property values, click on Actions → Save. GRC tests 

the values you’ve entered and, if they are valid, saves them. (If any are invalid, 

an error message instructs you to re-enter them.) 

4. Look for the prompt, “Successfully saved configuration values.”  

After that message appears, a one-time process runs in the background. It creates the 

DA schema tables and views. This process takes approximately fifteen minutes. Do 

not stop your WebLogic or Tomcat server during this period.  

Once you have connected to the DA schema, set a schedule on which the schema is 

refreshed — on which the DA schema reads from the GRC schema. You can modify a 

schedule at any time. (A refresh can take up to 90 minutes to finish.)  

1. Select the Analytics tab of the Manage Applications Configurations page.  

2. Click on the Schedule Data Analytics Update button.  

3. A Schedule Parameter dialog opens. Enter values that set the name of the sched-

ule, its start date and time, the regularity with which the DA schema should be 

refreshed, and an end date (if any). Then click on the Schedule button.  

4. Click on Actions → Save.  

To view the status of a scheduled refresh, go to Tools → Setup and Administration 

→ Manage Jobs. To view the Data Analytics schedule, go to Tools → Setup and 

Administration → Manage Scheduling.  
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Additional Advanced Controls Configuration 

Once you’ve upgraded to GRC 8.6.6.4000, complete additional configuration pro-

cedures as needed if you intend to use AACG or ETCG: 

• Define information with which GRC creates “global users.” Business applica-

tions subject to models and controls may have user-account information that 

varies from one application to the next. GRC maps each person’s business-

application IDs to a global-user ID. You can determine what information GRC 

uses to do so.  

If you are upgrading, version 8.6.6.4000 inherits the global-user definition from 

your earlier version. If you are satisfied with your configuration for the earlier 

version, you need not redefine it for version 8.6.6.4000. 

• Decide whether to implement a Page Access Configurations business object, 

which enables AACG users to build models and controls that take PeopleSoft 

user preferences into account. This feature is enabled by default. If your access 

models and controls do not cite PeopleSoft user preferences, you can disable 

this feature to improve performance and reduce memory requirements. 

• Set up data sources — connections to business applications in which GRC is to 

perform analysis. However, if you are upgrading, version 8.6.6.4000 inherits 

data sources configured for your earlier version. For version 8.6.6.4000, you need 

to set up only new data sources. 

• Complete the following procedures in the order indicated: 

1. Perform access synchronization on all data sources used for AACG analysis 

(see “How to Synchronize Data,” page 25).  

2. Perform a graph rebuild on all data sources used for ETCG analysis (again, 

see “How to Synchronize Data” on page 25). 

3. Run all controls that compile data for user defined objects (controls for which 

the result type is “Dataset”). 

4. Run all models and all controls that generate incidents (controls for which the 

result type is “Incidents”). 

Note, however, that if you are upgrading through several releases (for example, from 

version 8.6.6.1000 to 8.6.6.2000 to 8.6.6.3000 to 8.6.6.4000), then synchronize access 

data, rebuild the graph for transaction data, and run controls and models only once, 
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after the final upgrade is complete. For information on running models and controls, 

and distinguishing between control types, see the user guides for AACG and ETCG. 

Configuring Global Users 

Implement one of the following options to determine the information GRC uses to 

create global users. Important: Select an option that identifies each person uniquely. 

• EMAIL_ONLY: Match the global user to email addresses from distinct data 

sources (or within one data source). This is the default. 

• EMAIL_AND_USERNAME: Match the global user to email address plus username 

from distinct data sources (or within one data source). Because PeopleSoft imple-

mentations often do not use the email address for users, customers who imple-

ment PeopleSoft usually select this option as well. 

• EMAIL_AND_ALL_NAMES: Match the global user to email address, username, 

given name, and surname from distinct data sources (or within one data source). 

GRC users regularly synchronize data and analyze controls to produce “incidents” 

(records of control violations). If no data has been synchronized and no controls have 

been analyzed (in version 8.6.6.4000 or any earlier version), complete the following 

three steps to change a global-user configuration.  

1. Use SQL*Plus, or any other tool with the ability to execute SQL commands on 

a database, to connect to the GRC schema.  

2. Run the following SQL statement: 

DELETE FROM GRC_PROPERTIES 

WHERE NAME like 'GLOBAL_USER_CONFIG'; 

COMMIT; 

3. Run one of the following SQL statements, depending on the global-user format 

you want to implement: 

For email and username, run the following statement: 

Insert into GRC_PROPERTIES (NAME, VALUE, DESCRIPTION, DEFAULT_VALUE, 

VISIBLE, CONFIGURABLE, DATA_TYPE_ID)Values ('GLOBAL_USER_CONFIG', 

'EMAIL_AND_USERNAME', 'Global User configuration. Possible values: 

EMAIL_ONLY, EMAIL_AND_USERNAME, EMAIL_AND_ALL_NAMES', 'EMAIL_ONLY', 

0, 0, 0); 

COMMIT; 

For email, username, given name, and surname, run the following statement: 

Insert into GRC_PROPERTIES (NAME, VALUE, DESCRIPTION, DEFAULT_VALUE, 

VISIBLE, CONFIGURABLE, DATA_TYPE_ID) Values ('GLOBAL_USER_CONFIG', 

'EMAIL_AND_ALL_NAMES', 'Global User configuration. Possible values: 

EMAIL_ONLY, EMAIL_AND_USERNAME, EMAIL_AND_ALL_NAMES', 'EMAIL_ONLY', 

0, 0, 0);  

COMMIT; 

For email only, run the following statement. (As already noted, email-only is the 

default configuration. Run this statement only if you have changed your global-

user configuration to one of the other formats, and want to change back.) 

Insert into GRC_PROPERTIES (NAME, VALUE, DESCRIPTION, DEFAULT_VALUE, 

VISIBLE, CONFIGURABLE, DATA_TYPE_ID) Values ('GLOBAL_USER_CONFIG', 
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'EMAIL_ONLY', 'Global User configuration. Possible values: EMAIL_ONLY, 

EMAIL_AND_USERNAME, EMAIL_AND_ALL_NAMES', 'EMAIL_ONLY', 0, 0, 0); 

COMMIT; 

A second possibility is that data has been synchronized, but controls have not been 

analyzed. If so, changing your global-user configuration wipes out all existing global-

user data. 

1. Complete the steps outlined above for the first global-user-configuration sce-

nario (in which data synchronization and control analysis have not occurred). 

2. Sill logged on to your SQL tool, also run the following SQL statement: 

TRUNCATE TABLE GRC_SRC_USER_MAPPING; 

TRUNCATE TABLE GRC_GLOBAL USER; 

COMMIT; 

A third possibility is that data has been synchronized, controls have been analyzed, 

and incidents have been generated. In this case, when you change your global-user 

configuration, all existing incidents become invalid, and all existing global-user data 

is wiped out.  

1. Log on to GRC (see “GRC Log-On URL,” page 7).  

2. From the Navigator, select Tools → Setup and Administration → Setup → 

Manage Application Configurations. Select the Maintenance tab, and from the 

Maintenance page, purge all existing incidents. (For detailed instructions on 

purging incidents, see the Governance, Risk and Compliance User Guide.) 

3. Still logged on to GRC, select Navigator → Continuous Control Management 

→ Results Management → Manage Incident Results. In a Manage Results page, 

select Incident Result in the View By list box. Confirm that no incidents exist.  

4. Log off of GRC and shut down the application server.  

5. Complete the steps outlined above for the first global-user-configuration sce-

nario (in which data synchronization and control analysis have not occurred). 

6. While logged on to your SQL tool, also run the following SQL statement: 

TRUNCATE TABLE GRC_SUM_CTRL_INC; 

TRUNCATE TABLE GRC_SRC_USER_MAPPING; 

TRUNCATE TABLE GRC_GLOBAL USER; 

COMMIT; 

7. Clear the contents of your Transaction ETL Path folder. (This folder is specified 

as GRC properties are set. See “GRC Configuration,” page 8.) 

Enabling or Disabling Page Access Configurations 

An access model or control may include filters that serve as conditions — they 

specify users or other objects that are exempt from analysis. Like any other access 

filter, a condition filter specifies a business object — a set of related fields from a 

data source (business application). A business object called Page Access Configura-

tions makes PeopleSoft user-preference values available for use in condition filters. 

By default, processing of data provided by this business object is enabled. 
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If your site does not use PeopleSoft user-preference values in access models and con-

trols, you may choose to disable the processing of Page Access Configurations data. 

This improves performance and reduces memory requirements.  

Important Note: If you disable Page Access Configurations data processing, the 

business object will nevertheless appear to be available for use in models. Users may 

create filters that cite this object, but GRC will ignore those filters. This may cause 

models (and controls developed from those models) to return results that differ from 

those that users expect. If you disable Page Access Configurations data processing, 

alert users not to use the Page Access Configurations business object as they create 

models.  

To disable Page Access Configurations data processing: 

1. Shut down the GRC application server. 

2. Use SQL*Plus, or any other tool with the ability to execute SQL commands on 

a database, to connect to the GRC schema. 

3. Run the following SQL statement 

update GRC_PROPERTIES set VALUE = 'FALSE' where NAME = 

'grc.access.user.preferences'; 

COMMIT; 

4. Restart the GRC application server.  

Configuring Data Sources and Synchronizing Data 
Connect GRC to data sources (instances of business-management applications that 

are to be subject to GRC models or controls). Also synchronize data for each data 

source — collect information required for AACG or ETCG analysis. 

Synchronization and Global Users 

The order in which you synchronize access data from data sources determines how 

GRC creates global-user IDs: It adopts the ID configured for each user in the first 

data source to be synchronized. When data from a second data source is synchronized, 

GRC matches users who also exist in the first data source to their already-existing 

global-user IDs. For each user who did not exist in the first data source, GRC adopts 

the user ID from the second data source as the user’s global ID. And so on. 

AACG pages display the global-user ID for each business-application user. You may 

prefer to set IDs from a particular data source as the global-user IDs. 

However, during an upgrade, GRC inherits the global-user IDs existing on the 

earlier version. For version 8.6.6.4000, global-user IDs are initially the same as they 

were for version 8.6.6.3000. 

If you modify the global-user configuration (see page 20), existing global-user IDs 

are wiped out. In that case, or as you add new data sources, consider the following:  
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Configure all data sources in which you expect to apply AACG models and controls 

before you synchronize data for any of them. Next, choose a data source from which 

you want GRC to adopt IDs as global-user IDs, and synchronize that data source 

first. Establish an order for the remaining data sources, each of which sets global 

IDs for users who do not exist in the data sources for which synchronization has 

already been completed. Then synchronize the remaining data sources in that order. 

To configure data sources or to synchronize their data, log on to GRC (see “GRC 

Log-On URL,” page 7). Select Setup and Administration under Tools in the Naviga-

tor, then Manage Application Datasources under Setup. 

Special Cases Involving SQL Server 

You must install the Microsoft JDBC Driver 4.0 for SQL Server if your GRC instance 

connects to a Microsoft SQL Server data source and if either of the following is true: 

• Your GRC instance runs with Tomcat Application Server. 

• Your GRC instance runs with WebLogic and implements Secure Sockets Layer. 

Install the driver before you synchronize data for the SQL Server data source. How-

ever, if you are upgrading and have already competed this procedure for your earlier 

GRC version, you need not reinstall the driver.  

On the GRC server: 

1. Download the UNIX version of the JDBC driver — sqljdbc_*.tar.gz — from 

http://msdn.microsoft.com/en-us/data/aa937724.aspx. 

2. Shut down your application server. 

3. From the download file, extract the JDBC driver for SQL Server 2005 and 

newer — sqljdbc4.jar. (A SQL Server 2000 driver is also included in the down-

load file, but is not supported by GRC.) 

4. Copy the sqljdbc4.jar file to a directory appropriate for your application server: 

• If you use Tomcat, the directory is <TomcatHome>/webapps/grc/WEB-

INF/lib. 

• If you use WebLogic, the directory is <MW_HOME>/user_projects/domains/ 

<grc_domain>/lib 

5. If you use WebLogic, edit the setDomainEnv.sh file. (Skip this step if you use 

Tomcat.) 

The setDomain Env.sh file is located in the <MW_HOME>/user_projects/ 

domains/<grc_domain>/bin directory. In it, locate the following line: 

if [ "${PRE_CLASSPATH}" != "" ] ; then 

Immediately before that line, add the following line: 

PRE_CLASSPATH="<MW_HOME>/user_projects/domains/<grc_domain>

/lib/sqljdbc4.jar:${PRE_CLASSPATH}" export PRE_CLASSPATH 

Replace <MW_HOME> and <grc_domain> with the specific values appropriate 

for your environment. 

6. Restart your application server. 



 

24 Oracle Enterprise Governance, Risk and Compliance Installation Guide 

How to Configure Data Source 

To configure a data source, complete these steps. However, remember that GRC 

version 8.6.6.4000 inherits data sources configured for your earlier GRC version, 

and you need not reconfigure them.  

1. In the GRC Manage Application Datasources page click on Actions → Create 

New. A Create Datasource window opens. Enter the following values: 

• Datasource Name: Create a name for the data source. 

• Description: Type a brief description of the data source (optional). 

• Application Type: Select the type of business application to which you are 

connecting, such as EBS or PeopleSoft. 

• Application Type Version: Select the version number of the business-

management application to which you are connecting. 

• Default Datasource: Select the checkbox to make the data source you are 

configuring the default for use in transaction models. Only one data source 

can have this value selected. 

• Connector Type: For an Oracle EBS or PeopleSoft data source, select 

Default. For any other application, you would need to have created and 

uploaded a custom connector; select it. 

• Connector Properties: Enter values required for the connector you specified 

in Connector Type. Values vary by connector. They may include: 

– ERP Database Type: Select the type of database — Oracle, Oracle RAC, 

MS SQL Server, DB2, or MySQL — used by the business-management 

application being configured as a data source. 

– Hostname: For Oracle EBS or PeopleSoft, supply the FQDN for the 

machine that hosts the database used by the business-management 

application. Or, if the database is RAC-enabled, enter 

RAC@<SCAN_NAME>, where <SCAN_NAME> is the IP 

address/host name configured for the RAC database. 

– Service Name: For Oracle EBS or PeopleSoft, supply the SID value 

configured for the business-application database in the tnsnames.ora 

file. Or, if the database is RAC-enabled, enter the RAC service name 

configured for the RAC database. 

– Port: For Oracle EBS or PeopleSoft, enter the port number that the busi-

ness-application database uses to communicate with other applications.  

– Username: For Oracle EBS or PeopleSoft, supply the user name for the 

business-application database. (For an Oracle database, this is the same 

as Schema Name; for an Oracle EBS instance, this is typically APPS.)  

– Password: Supply the password that authenticates the user name for the 

business-application database. 

2. After entering values, click on the Test Connection button.  

3. When the test completes successfully, click the Save or Save and Close button. 

A row representing the data source appears in the Manage Application Data-

sources grid. 



 

 Additional Advanced Controls Configuration 25 

How to Synchronize Data 

You must synchronize data from every data source used for access analysis, and 

“rebuild the graph” for every data source used for transaction analysis — even data 

sources inherited from your earlier GRC version.  

An ordinary synchronization run creates or updates only records that are new or 

have changed since the previous synchronization. A graph rebuild deletes all data 

for a given data source and replaces it with a complete set of current data. This 

typically takes longer than ordinary synchronization. 

To synchronize access data, complete these steps: 

1. In the Manage Application Datasources page, select the row for the data source 

with which you want to synchronize data.  

2. Click on Actions → Synchronize Access. 

3. A confirmation message appears; click its OK button. 

To rebuild the graph for transaction data, complete these steps: 

1. In the Manage Application Datasources page, select the row for a transaction 

data source. 

2. Select Actions → Rebuild Graph. 

3. A confirmation message appears; click its OK button. 

There is an option to synchronize transaction data; it’s the preferred option for routine 

use of ETCG. However, do not use it in this instance. During a GRC upgrade, you must 

perform a graph rebuild on transaction data sources. 

Each time a data source is synchronized, GRC updates fields in the row for that data 

source: Last Access Synchronization Date and Last Access Synchronization Status 

show the date of the most recent access synchronization, and its completion status. 

Last Transaction Synchronization Date and Last Transaction Synchronization Status 

do the same for the most recent transaction synchronization or graph rebuild. 

Determining Data Source IDs 

When you configure a data source, GRC assigns an ID number to it. If you intend to 

implement preventive analysis for an Oracle EBS datasource, you need to know its 

data source ID. To determine the number, configure the data source, then complete 

the following steps: 

1. In the Manage Application Datasources page, select View → Columns.  

2. A list of available columns appears. In it, select Datasource ID. 

3. The Manage Application Datasources page now displays a Datasource ID 

column. In it, note the ID number assigned to the data source you’ve 

configured. 

If, having determined the data source IDs for your data sources, you wish to remove 

the Datasource ID column from view, repeat this procedure but clear the Datasource 

ID selection.  
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5 

Installing PEAs 

In support of the AACG preventive analysis feature, ensure that a Preventive 

Enforcement Agent (PEA) is installed on each Oracle EBS instance that is to be subject 

to AACG analysis.  

If a PEA for the prior release of GRC exists on an EBS instance, you need not 

reinstall the PEA on that instance. However, if you want to set up an EBS instance 

as an access data source, and that instance does not have a PEA, you need to install 

one. 

• See the Oracle Enterprise Governance, Risk and Compliance Certifications 

Document for supported versions of Oracle EBS. 

• See the GRC Installation Guide for version 8.6.6.3000 for the procedure to 

install an Oracle EBS PEA.  
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