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Preface

Welcome to the Service for Communications, Release 11i.

This Detailed Implementation Guide provides information and instructions about 
the implementation of the Oracle Service for Communications application.

This preface explains implementation considerations and processes is organized 
and introduces other sources of information that can help you.

Intended Audience
This guide is aimed at the following users:

� Product Implementation team (Oracle and Customer)

� Oracle and Customer Project Managers

� Technical Support Associates

� System Administrators (SAs), Database Administrators (DBAs), and others with 
similar responsibility.

This guide assumes you have the following prerequisites:

� Understanding of the product implementation processes.

� Knowledge of Oracle Network Logistics operation and services 

� Basic understanding of Oracle and Developer/2000

� Understanding of the interface protocol to each of the fulfillment elements 
(telnet, script)

� Background in SQL, PL/SQL, SQL* Plus programming
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Structure
This manual contains the following chapters:

� Considerations for planning

� User Roles

� Typical Release Dependencies

� Setting up Oracle Service for Communications

� System Profile Options

� Considerations for Future Upgrades

Related Documents
The following are resources related to Oracle Service for Communications

URLs
� http://crm.us.oracle.com

� http://products.us.oracle.com

Published Resources
Aim Documentation

� CR010: Scope, Objectives, and Approach

� BR020: Business Requirements Mapping Form

� BR110: Application Setup

� TE070: Unit Test Scripts

� Oracle Product Name Concepts and Procedures

Conventions
The following conventions are also used in this manual:
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Convention Meaning

    .
    .
    .

Vertical ellipsis points in an example mean that information not 
directly related to the example has been omitted.

. . . Horizontal ellipsis points in statements or commands mean that 
parts of the statement or command not directly related to the 
example have been omitted

boldface text Boldface type in text indicates a term defined in the text, the glossary, 
or in both locations.

< >  Angle brackets enclose user-supplied names.

[ ] Brackets enclose optional clauses from which you can choose one or 
none.
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Implementing Oracle Service for
Communications

Considerations for Planning an Implementation Project
The following items are part of planning an Oracle Service for Communications 
Implementation:

n Overview of Oracle Service for Communications

n Application architecture

n Features and functions

n User roles

n Other considerations

Overview of Oracle Service for Communications

Service for Communications Defined
Oracle Service for Communications extends the features of Oracle Support and 
Oracle Service to include the customer care processes in the communications 
industry. Specifically, it offers features that:

n Maintain a directory of products and services customers have purchased in the 
Installed Base

n Log, track, and resolve trouble reports made against installed products and 
services
                                                            Implementing Oracle Service for Communications 1



Considerations for Planning an Implementation Project
Integration with Other Oracle Modules
The primary area of customer care that this application supports is service request 
management. In addition, this application integrates with the customer service 
management tools found in the Oracle modules shown in the following table.

Service for Communications Integration with Oracle Modules

Oracle Application Functionality

Oracle Service Contracts Creates, updates, and displays service agreements for 
service contract management.

Oracle Customer Care Manages customer interaction through the Customer 
Care Contact Center.

Provides computer-telephony integration necessary for 
call-centers.

Allows quick service request creation.

Oracle SDP Provisioning Provides an environment for diagnostic testing of 
network elements in the Test Center.

Oracle Sales for Communications Includes product catalog, order management, and 
diagnostic test definitions.
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Understanding Service Request Management
Service request management begins when customers call to report trouble with 
installed products and services. Support agents receive customer trouble reports 
and enter the information into a service request window. 

After a service request is entered, agents and technicians can view the request and 
track its status. If several service requests are related to one network problem, those 
related requests can be linked and tracked together. 

Service request management includes these tasks:

n Receiving trouble reports from customers or service personnel

n Service testing through Test Center

n Determining the cause of trouble reports

n Creating service requests

n Viewing and tracking the progress of service requests

n Entering service requests to third-party service providers

n Confirming that a problem has been resolved and notifying the customer

n Closing service requests

For a detailed description of service requests, see Overview of Service Requests.

Service Requests are Received
Agents access Oracle Service for Communications as a stand-alone application. 
When customers call to report a problem with a product or service, the Customer 
Care Contact Center (or via integration with the Customer Care Center) 
immediately displays the caller’s account information to the agent via 
computer-telephony integration. When the agent elects to log a service request by 
accessing Service for Communications from Customer Care, the caller context is 
populated onto the Service Request form.
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Agents Troubleshoot Customer Trouble Reports
When customers describe their service problems, agents can quickly perform 
research and diagnostic tests to immediately resolve simple problems. If the 
problem cannot be immediately resolved, then agents can gather information that 
can be relayed to the technician to reduce the amount of time it takes to resolve 
problems. The application provides the following methods for diagnosing the cause 
of a problem before the service request is dispatched to a technician:

n Search the Knowledge Base to find similar problems that were resolved in the 
past. 

The Knowledge Base is a history file of previously logged service requests. It 
contains troubleshooting information that includes which network elements 
have caused similar problems in the past. See Knowledge Base.

n Use the Test Center to determine whether the network fulfillment element, 
which provides the service, is working. 

The Test Center contains a selection of predefined diagnostic tests that can be 
applied to elements in the network. See Test Center.

Third-Party Service Providers are Notified of Problems
To provide more comprehensive products and services to their customers, 
communications service providers often engage in reselling arrangements with 
third-party service providers. If customer problems are related to faults in the 
third-party service provider’s network, then you must notify that service provider. 
However, your organization must be the single point of contact for the customer.

You can enter a service provider request to notify the third-party provider. You can 
track the third-party service provider’s external reference number, to keep yourself 
and your customer informed on the progress of the service request. See Service 
Request Types.

How Customers are Notified of Problem Resolutions
When customers call to report service problems, a support agent opens a service 
request. As a result, the customer service request workflow is automatically 
activated. This workflow ensures that customers are contacted to confirm that a 
service problem has been resolved to their satisfaction before the service request can 
be closed. See Types of Pre-defined Service Requests.
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Features and Functions

Overview of Service Requests
A service request contains details about the customer, product, and problem. 
Typically, support agents create service requests when they receive reports of 
network problems from customers, network engineers, or field service personnel.

When setting up user profiles for the application, you determine who has the 
necessary privileges to create service requests for your organization. See Default 
Service Request Owner Setup. You can also use application programming interfaces 
(APIs) to create service requests.

For procedures that describe how to create service requests, see Creating Service 
Requests.

The following table describes the tabs found in the Service Request main window. 
Each tab gives access to a function that contributes to the process of managing a 
service request. The support agent can use these tabs to manage customer 
information, problem details, problem resolution, service history, and task 
assignment to assist and sustain a support center.

Service Request Tabs

Tab Name Function

Product Coverage View and edit product attributes and service coverage 
information.

Links Link two or more related service requests. 

Workbench Post a problem summary note to the Knowledge Base to 
review support recommendations or provide solution results 
for other support agents.

Log View the history of customer contact with your company 
across all service requests.

Contacts View and edit customer contact information.

Addresses View and edit customer billing, shipping, and installation 
address information.

Task View or assign tasks associated with a service request.

Interactions View or contribute to the customer contact history of the 
selected service request.

Test Center .Communicate with network elements and apply 
diagnostic tests.
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Workflows Monitor the Resolution Process
The creation of a service request triggers a service request workflow, which 
monitors the resolution of the problem. When a service request needs attention, the 
workflow notifies responsible individuals. For more information about workflows, 
see About Service Request Workflows and the documentation for Oracle Workflow.

The Knowledge Base in Service for Communications
Oracle Service for Communications creates a knowledge base of previously 
reported problems and their resolutions. When responding to a service request, 
service personnel may search this knowledge base to identify solutions that have 
worked in the past. As new problems are resolved, the Knowledge Base is updated 
to include these problems and their resolutions. For more information about the 
Knowledge Base, see Using Knowledge Base Search.

Types of Service Requests
Three types of service requests that are specific to the communications industry 
have been pre-defined and configured during the setup of the application:

n Customer service request

n Network service request

n Service provider service request

Customer Service Request 
Use this request to describe a customer problem. As the customer and product 
information are collected on the service request form, you can validate details about 
the customer, the product, and the current service coverage against the Installed 
Base. If the customer is unknown to the Installed Base, all the information can be 
collected in a non-verify mode and verified later.

Network Service Request 
Use this request to record information about a problem with the network elements 
in your communications network. You may create a network service request as a 
result of customer reports, or second-level repair personnel may create one after 
troubleshooting a customer service request. You can also create a network service 
request in response to a network problem that may or may not impact customer 
service.
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Service Provider Service Request
Use this request to record a problem related to third-party network elements. You 
may generate service provider requests based on customer service requests or on 
network service requests. Service providers are pre-defined in the Installed Base.

Overview of Status of Service Requests
The service request status may change at different stages in the process of resolving 
a problem. Each pre-defined service request status is described in the following 
table. If you define your own types of request status, you must use Oracle 
Workflow to re-design the workflows, or processes, that are driven by the 
user-defined status. 

Audit History Log
Oracle Service for Communications maintains an audit history that records all 
changes made to service requests. For example, if you change the status of a service 
request from Queued to Open/Active, then the audit history records the old and 
new status values, as well as the user who made the change and the date. 

Note: Only a customer service request can have a Clear status.

Service Request Status

Status Definition

Open Action has been initiated to resolve a service request.

Clear The service problem is resolved but the service request is not 
yet closed. Through the customer service request in "Clear 
States"will create a notification to the customer. The customer 
must approve of the resolution before the request can be 
closed. 

Closed The service problem resolution process is complete.
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About Service Request Linking
You can link any service request to one or more service requests in a parent-child, or 
cause-and-affect, relationship. If several customers report the same problem and 
you discover the problem is occurring in a single network element, then you can 
link these customer service requests together. 

For example, you may have several customer service requests related to voice mail 
problems. After further diagnosis, you find that the voice mail server is down and 
you need to open a network service request. You can link the multiple customer 
service requests as child service requests to the parent network service request. 

You may also link two related parent service requests to one or more child requests. 
For example, you may discover a secondary problem that is unrelated to the 
original customer service request. However, if it is not resolved, this secondary 
problem may have an impact on the original customer service request. In this case, 
you would link the secondary problem as a second parent to the child(ren) service 
requests. Both parent service requests must be resolved as part of the overall 
resolution process. 

For information about how to link service requests to one another, see Linking 
Service Requests.

Status Propagation in Linked Service Requests
Service requests can have links with other service requests in a one-to-many, 
one-to-one, many-to-one, or many-to-many relationship. When you link several 
service requests together in a parent-child relationship, you tie the status of each 
child service request to the status of the parent.

Status propagation ensures that the status of the parent service request affects the 
status of all its child requests. When you close a service request, whether it is linked 
or not, the system automatically checks for dependencies on the closed service 
request according to the business rules discussed in About Service Request Linking.

For example, a customer service request might be logged against an email service in 
the Installed Base. If the problem is the result of a server problem, then the network 
service request for the server is the parent to the child customer service request. As 
long as the network service request is open, the child service request remains open.

When the server is repaired and the network service request is closed, the 
associated child service request for the customer is given the Clear status. Customer 
service requests are the only request that can have a status of Clear. 

When the customer service request has a Clear status, the customer is notified of the 
problem resolution. If the customer is satisfied with the resolution, the status of the 
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customer request becomes Closed. If the customer is not satisfied, the status of the 
customer service request becomes Open and a notification is sent to the owner of 
the request.

Understanding the Test Center
The Test Center provides an environment for agents to communicate with network 
elements and apply diagnostic tests. Often, agents can use the Test Center to quickly 
resolve customer problems, while customers are still on the line. Or they can 
perform a simple test and then call the customer back immediately with the test 
results.

You set up the tests that you need to use as part of the definition of products in the 
Sales for Communications’ Product Catalog. To set up the tests, you must map 
actions that have been defined in Service for Communications to work items that 
have been associated to parameters of network elements in Oracle SDP 
Provisioning.

To implement the Test Center, you must integrate Oracle Service for 
Communications with Oracle SDP Provisioning, which provides the service 
delivery platform that communicates with your network. In the process of setting 
up the Test Center, you need to define actions, work items and parameters. 

Actions 
An action is an operation performed on a service or product. When you set up 
Oracle Service for Communications, use the test type of actions to define the actions 
used in the Test Center. They should include the actions that you perform on 
products and those that comprise the services you provide. These actions are not 
predefined in the Test Center. See Defining Test Type Actions.

Work Items
In Oracle SDP Provisioning, you define work items that describe the subprocedures 
that can be performed against network elements. When you set up the Test Center 
in this application, you must map these work items to actions. For more detailed 
information, see Work Items in Oracle Provisioning.

Work Item Parameters
Each work item that is defined in Oracle SDP Provisioning is associated to 
parameters. These parameters are the characteristics of the network elements. If you 
do not define unique parameters in Oracle SDP Provisioning, the parameters use 
the default values. For more detailed information, see Defining a New Work Item 
Parameter.
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About Service Request Workflows 
When you enter a Customer Service Request for that customer, the application uses 
Oracle Workflow technology to drive the resolution process. A workflow routes 
information to people inside your enterprise, according to business rules that you 
can easily modify. 

Oracle Service for Communications provides a pre-defined workflow process for 
each of the pre-defined request types:

n Comms Customer Service Request Process

n Comms Network Service Request Process

n Comms Service Provider Request Process

Each workflow comprises activities required to drive a service request to resolution. 
Each activity generates information that can be recorded and tracked. You can use 
Oracle Workflow to create custom workflows for user-defined service requests. Use 
the Service Request Types setup window to define relationships between request 
types and workflows.

Customized Response to Service Requests
You can route service requests to individuals or roles in your organization and 
move them through a workflow-based resolution process tailored to your own 
unique business requirements. You can implement procedures that:

n Select and notify service personnel

n Facilitate the transfer and automatic escalation of service requests

You can define business rules that identify actions that violate your service 
standards or response guidelines and then take corrective actions or escalate those 
requests to the appropriate person. You can analyze the exact routing of each 
service request to identify and eliminate the bottlenecks in your resolution process. 
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User Roles

Creating Service Requests
For directions on creating service requests, select the one of the three types of 
pre-defined service requests:

Customer Service Requests

Network Service Requests

Service Provider Requests

Creating Customer Service Requests
When a customer calls to report a problem, use this procedure to enter information 
about the problem and the product on a customer service request.

Prerequisites
Before creating customer service requests, you must:

n Define customer products in the Installed Base.

n Define items in Inventory.

n Define customer accounts in Accounts Receivable

Steps
The following steps are an example of creating a Service Request. Please note that 
this is one of many combinations that can be used to perform this procedure.

1.  Select Service Request > View Comms Service Requests in the Navigator,

The fields for Date Opened, Type, Status, Urgency and Owner contain default 
values.

2.  Select Customer Service Request from the Type drop-down menu under 
Request Information,.

3. Select the appropriate Caller Type and fill in the Last name field.

The fields for First name, Company, Phone, Ext, and Email should contain the 
appropriate information.

4. Enter Account or select the appropriate account from the drop-down menu.

5. Select the Time Zone from the drop-down menu.
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6. Check the Installed Base checkbox and select the Product from the drop-down 
menu.

The "Desc" field shows the product description. If applicable, the product 
Revision, Serial Number, and Service Key appear. If applicable, information 
related to the service contract appears.

7. Select the Test Center tab and select a test name (if applicable).

The Work Items button becomes available. You may click Work Items to see a 
list of all work items and their parameters.

8. Click Submit to run the selected test.

The test name and results are displayed.

9. Select the Workbench tab and fill in the required fields to describe the problem 
and the date a resolution is expected.

10. Click Save to save the service request.

The new Customer Service Request is now in the system.

Reference
For more information on service requests, see Service Requests.

See also Testing Network Elements. 

Creating Network Service Requests
When a problem with a communication network occurs, use this procedure to enter 
a network service request.

Steps

1. Select Service Request > Comms Service Requests in the Navigator.

The fields for Date Opened, Type, Status, Urgency and Owner contain default 
values.

2. Select employee from the Caller Type drop-down menu and fill in the Last 
name field.

The fields for First name, Company, Phone, Ext, and Email should contain the 
appropriate information.

3. Select the Time Zone from the drop-down menu.
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4. Select Network Service Request from the Type drop-down menu under Request 
Information.

If applicable, enter a reference to a network element. (For example, external 
number or location identification)

5. Select a network fulfillment element from the Source list of values.

6. Select the Workbench tab and fill in the required fields to describe the problem 
and the date a resolution is expected.

7. Select File > Save to save the service request.

The new Network Service Request is now in the system.

Reference

For more information on service requests, see Service Requests.

Creating Service Provider Requests
When a problem is related to a product or service provided by a third party, use this 
procedure to enter information into a service provider request.

Prerequisites
The third-party service provider must exist as an inventory entry in Purchasing. 
The third-party service provide must generate a reference number through their 
service request system.

Steps
1. Select Service Request > Comms Service Requests in the Navigator.

The fields for Date Opened, Type, Status, Urgency and Owner contain default 
values.

2. Select Service Provider Request from the Type drop-down menu under Request 
Information.

3. Select the service provider from the drop-down menu and enter the service 
provider’s reference number.

4. Select employee from the Caller Type drop-down menu and fill in the Last 
name field.

The fields for First name, Company, Phone, Ext, and Email should contain the 
appropriate information.
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5. Select the Time Zone from the drop-down menu.

6. Select the Workbench tab and fill in the required fields to describe the problem 
and the date a resolution is expected.

7. Click Save to save the service request.

The new Service Provider Request is now in the system.

Reference
For more information on service requests, see Service Requests.

Viewing and Updating Service Requests
Use this procedure to view and update customer information, product information, 
and any current or previous service requests. You can search by Customer, Number, 
Status or other fields of information.

Prerequisites
None.

Steps
1. Select Service Request > View Comms Service Requests from the Navigator.

The Find Window opens.

2. Enter information about the service request of interest in one or more fields and 
click Find.

The Service Request window displays one or more lines of requests that contain 
the information you entered.

3. Click to select a particular line and view details about that associated request. 

At this point, you may update information about the request.

4. Select File > Save to save your changes.
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Linking Service Requests
When a service request is a direct result of a problem for which another service 
request has been opened, use this procedure to link one or more service requests in 
a parent/child relationship.

Prerequisites
None.

Steps
1.  select Service Request > from the Navigator.

2. Create a new Service Request by:

n  Use Enter Comms Service Request or,

n Locate an existing service using View Comms Service Request

3. Select the Links tab in the Service Requests window.

The lines on the Links tab display all service requests that are associated to this 
request and the type of link, either parent or child.

4.  Enter that number on a blank line, if you know the request number of the 
request you want to link to.

As an alternative, click New Association to open the Find Service Request 
window.

In the Find Service Request window, enter information in one or more of the 
fields and click Find. Select a service request to return to the Links tab.

5. Select the relationship you want the link to represent, either parent or child.

All other columns on the Links tab are view-only. 

6. Click Save Association to save the new link.

7. Repeat this procedure for each service request you want to link.

Guidelines
When you close a service request and change its status to closed, the application 
automatically checks for dependencies on the closed service request. For 
information about the business rules that apply to closing linked service requests, 
see About Service Request Linking.
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References
Only customer service requests can have a Clear status. The following table lists 
which statuses can apply to the three types of service requests.

Testing Network Elements
When customers call to report trouble with products and services, use this 
procedure to run diagnostic tests while the customer waits.

Prerequisites
Tests must be set up during implementation of this application before you can test 
products or services. For more information, see Test Center.

Steps
1. Select Service Request > Comms Service Requests from the Navigator.

2.  Enter the service request information in the Service Requests window,.

3. Choose the Test Center tab.

The Test Procedures region displays all test Actions that are associated with the 
product displayed. To view work items that are associated with a test 
procedure, click View Workitems in the Test Procedures region of the Test 
Center tab window.

4. Select the desired test action and click Submit to perform the test.

The Test Results are displayed in a read-only panel for each work item 
associated to the test action.

Service Request Types and Statuses

Service Request Type Allowed Status

Customer Service Request n Open

n Clear

n Closed

Network Service Request n Open

n Closed

Service Provider Request n Open

n Closed
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Guidelines
The Test Center tab is active only when you have entered sufficient information to 
uniquely identify an active product or service.

Troubleshooting
If no work items have been associated to a test action for the product or service, 
then the View Workitems button is inactive. To activate it, contact your system 
administrator to associate work items with the test action item in Oracle SDP 
Provisioning.

Viewing Product Information in the Installed Base
The Installed Base contains data about products and services that have already been 
purchased by customers. Use this procedure to view product information in the 
Installed Base.

Prerequisites
None.

Steps
1. Use the Navigator to open Installed Base > Customer Products.

The Find Product window opens in front of the Product Summary and Details 
form.

2. Enter information in the blanks on the Find Product window to describe the 
product or account information you want to view.

Click Search Account to open the Search Account Number window for finding 
account numbers.

3. Click Find when one or more blanks in the Find Product window contain 
information.

One or more lines at the top of the Product Summary and Details form become 
populated with details about the related product or account.

4. Select a line to see more details about that entry appear in the bottom of the 
form.

5. Click tabs to review more information about a selected line.
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Typical Release Dependencies
References
To understand how product information may be organized in the Installed Base, 
see:

n About the Installed Base

n Installed Base Tabs

Typical Release Dependencies
Oracle Service for Communications 11i is based on the foundation of the Oracle 
installed base that includes:

n Common Data Model

n Technical Stack
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Setting Up Oracle Service for Communications
Setting Up Oracle Service for Communications 
Before setting up Oracle Service for Communications, you must install and fully 
implement these Oracle applications or components:

n Oracle Service Installed Base module

n Oracle Support Service Request module

n Oracle Field Service, if you wish to use the dispatching feature

n Oracle SDP Provisioning, if you wish to use the Test Center

For information regarding the installation and implementation of these applications 
and components, see the appropriate documentation for each product. The 
implementation tasks described here are tasks that are necessary to use the 
additional functionality included with Oracle Service for Communications.

Implementation of this application includes setting up these features and options:

n Service request statuses

n Linking workflow notifications to service request types

n Default service request owner

n Default service request escalation time

n Default network service request escalation time

n Default customer response time

n Test Center tests

Service Request Status Setup
Use service request status to indicate where a service request is in the resolution 
process. This application provides three pre-defined service request status: Open, 
Clear and Closed. You can define any number of additional statuses to reflect your 
organization’s business processes.

For a description of all of the pre-defined statuses, see Overview of Service 
Requests.
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Setting Up Oracle Service for Communications
Workflow Setup
When a service request is created, the associated Workflow launches, based on the 
service request type. A service request type may be defined to use a standard or 
customized workflow. The standard service request types used in this application 
and their corresponding workflows are listed in the following table.

Linking a Workflow to a Service Request Type
For the correct workflow to launch when a service request is created, you must link 
each workflows to the appropriate service request type. Use the following 
procedure to link a service request type to a workflow.

Prerequisites
None

Steps
1. Select Setup > Service Requests > Request Types from the Navigator.

2. Locate the appropriate Service Request Type.

3. Choose the appropriate workflow from the list of values […].

4. Select File > Save to save your work.

Service Request Type Associated Workflow

Customer Service Request Comms Customer Service Request Process

Network Service Request Comms Network Service Request Process

Service Provider Request Comms Service Provider Request Process
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Setting Up Oracle Service for Communications
Profile Options Setup
During implementation, the System Administrator assigns a value for each profile 
option. The values define access privileges and how the application processes data.

The profile options are set at one or more of the following levels: site, application, 
responsibility, and user. The system administrator sets and updates profile values 
using the System Profile Options window.

The following table describes the profile options that are unique to Oracle Service 
for Communications.

Profile Option Description

Service: Default Workflow 
Customer Service Request 
Escalation Time

(XNS_RESPONSE_TIME)

Workflow resolution uses the expected resolution date 
that is specified in the service request to determine the 
date of escalation. When no expected resolution date is 
specified, the escalation time is 3 days. 

Use the profile to define a default escalation timeframe 
in hours. The default system profile is set at 72 hours.

Service: Default Workflow 
Network Service Request 
Escalation Time

(XNS_NW_RESPONSE_TIME)

A network service request is more critical than a 
customer service request because it may impact a 
significant number of customers. Network service 
requests should be resolved as quickly as possible and 
escalation should occur in a shorter timeframe—in a 
matter of hours instead of days. Use this profile option to 
define the escalation timeframe in hours.

The default escalation time is set at 8 hours. The time 
count begins as soon as the initial workflow notification 
is sent. If the notification is forwarded within the 
timeframe, the new escalation deadline does not extend 
an additional 8 hours. Instead, escalation must occur 
within the timeframe specified in the first workflow 
notification.

Service: Default Customer 
Response Time

(XNS_CUST_RESPONSE_
TIME)

When a service request is resolved, the status changes to 
cleared. At this point, the agent who created the service 
request receives a workflow notification to contact the 
customer and confirm that the problem is resolved. If the 
customer agrees that the problem is resolved, then the 
service request is closed.

This profile option defines how many days a service 
request can remain in the cleared state. The default 
response time is 72 hours.
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Setting Up Oracle Service for Communications
Default Service Request Owner Setup
The person who receives a workflow notification must be defined in these areas of 
Oracle Applications:

Customer Care: Service Request 
Check Form

This profile option calls the Comms Service Request 
form from Oracle Customer Care. Set this profile option 
to the following:

Value: Comms Service Requests

Level: Responsibility

Responsibility Name: Oracle Service for 
Communications

Start Menu in Quick Menu This profile option calls the Comms Quick Menu. Set this 
profile option to the following:

Value: XNS_QUICK_MENU

Level: Responsibility

Responsibility Name: Oracle Service for 
Communications

Oracle Human 
Resources Management 
System (HRMS)

Individuals must be defined in Oracle HRMS before they can 
receive a workflow notification. In addition an individual’s 
Assignment, Organization, Job, Position, and their Supervisor 
must also be defined in Oracle HRMS. The Supervisor must be 
defined so a workflow escalation notification can be routed to 
the appropriate management contact. For information about 
setting up an employee in Oracle HRMS, see the Oracle Human 
Resources Management System user’s documentation.

Application Object 
Application User

When an application user is created, the user must be linked to 
the person defined in oracle HRMS, and the appropriate 
responsibilities must also be assigned. For information about 
how to create application users, see the Oracle System 
Administrator user’s documentation.

Profile Option Description
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Setting Up Oracle Service for Communications
Resetting the Default Service Request Owner
The Service Request window displays the default owner, based on the profile 
option that is defined at the system or user level. The owner may be changed when 
the service request is created. However, the default service request owner may be 
reset as required. Use this procedure to reset the default service request owner.

Prerequisites
The new default service request owner must be defined in the Oracle Human 
Resources Management System (HRMS) area of this application.

Steps
1. Select Other > Profile from the Navigator in the Oracle Service for 

Communications responsibility.

2. Query for the profile option, Service: Default Service Request Owner. 

The window displays the default value.

3. Choose the appropriate user from the list of values […].

4. Select File > Save to save your work.

Guidelines
To reset the default service request owner, submit a request to your system 
administrator to change this profile option.
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Setting Up Oracle Service for Communications
Defining Test Type Actions
An action is an operation performed on a service or product. Use the test type of 
actions to define the actions used in the Test Center. The actions should include the 
actions that you perform on products as well as the services you provide. Use this 
procedure to define test type actions.

Prerequisites
None.

Steps
1.  Navigate to Setup > Test Center > Item Action Parameters in the Service for 

Communications responsibility.

The Organizations window appears.

2. Select your organization from the list of organizations and click OK.

The Action Parameters window appears.

3. choose Test in the Action Type list of values.

4. Use the Item field to describe the item being tested. Use the Description field to 
describe the action.

Leave the fields on the Main and Entity tab blank.

5. Select File > Save to save the definitions.

6. Click Map Work Items to open the form for mapping the defined action to one 
or a series of work items.

See Mapping Actions to Work Items for the Test Center
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Setting Up Oracle Service for Communications
Mapping Actions to Work Items for the Test Center
If you want to use the Test Center in Oracle Service for Communications, you must 
map test type item actions to the work items that are defined in Oracle SDP 
Provisioning. The application uses these mappings to communicate with network 
elements and apply diagnostic tests to those elements. Use this procedure to map 
actions to work items.

Prerequisites
Before you can map actions to work items, you must define the actions in Oracle 
Service for Communications. Then you must associate work items to network 
parameters in Oracle SDP Provisioning. For more information, see Test Center.

For detailed information about defining work items, see Work Items in Oracle 
Provisioning.

Steps
1. Select Service Request > Comms Workitems Mapping from the Navigator.

2. Select an Action Name from the list of values by clicking the […] in the field in 
the Mapping Action to Workitems window.

Only test-type action items will display in the list of values.

3. Select the work items from the list of values in the Name column in the 
appropriate sequence in the Work Items region of the window.

When you select a work item, the parameters that are associated to it are 
displayed in the read-only Parameters region of the window.

4. Choose File > Save to save this mapping association.
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System Profile Options
System Profile Options

About the Installed Base 
The Installed Base is a repository of information about installed products and 
customers. Agents can view Installed Base data when customers call or when they 
need to create service requests. For more information, see Viewing Product 
Information in the Installed Base.

When you use Oracle Service for Communications to review information in the 
Installed Base, you start in the Product Summaries and Details window. This 
window has three tabs that are specific to Service for Communications:

n Related Products

n Parameters

n Network Configuration

Related Products Tab Shows Product Hierarchies
Use the Related Products tab on the Product Summaries and Details window to 
look at product hierarchies in the Installed Base. The Related Products tab shows 
the product of interest with its immediate Parent and Child products.

Configurable products in a communications service network are related to each 
other in either a one-to-many or many-to-one relationship. To reflect these 
relationships, products in the Installed Base are organized into parent-child 
relationships. These parent-child relationships form the product hierarchy, 
illustrated in the Product Hierarchy Example diagram.
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System Profile Options
.

Product Hierarchy Example

Levels of Product Hierarchies
Product hierarchies are defined in one of two ways:

n In the Product Catalog that is implemented with Oracle Sales for 
Communications

n By specific APIs that populate the Installed Base with product information

As necessary, you may add levels to the product hierarchy to accurately represent 
your product structure. In the above Product Hierarchy Example, for instance, you 
may add several hierarchical levels between the POTS parent product and the child 
products to categorize products into market segments, residential versus business, 
or geographical regions. 

Only one level of relative, either a parent or child product, is displayed in the 
Relations window of the Installed Base module. For more information, see Viewing 
Product Information in the Installed Base.

Note: One product can simultaneously be a parent and a child, as is the 
case for Caller ID in the Product Hierarchy Example diagram 

Pla in  O ld  Te le p h o n e
S e r v ic e
( PO TS )

Ca ll W a itin g Ca ll Fo r w a r d in g Ca lle r  ID

Ca lle r  ID  B o x Ca ll W a it in g  Ca lle r  ID

Pa r e n t Pr o d u c ts

Ch ild  Pr o d u c ts
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Considerations for Future Upgrade Paths
Parameters in the Installed Base
Use the Parameters tab in the Product Summary and Details window to review the 
attributes of a selected service or product in the Installed Base. The information on 
the Parameters tab is for viewing only and cannot be edited in the window.

Service Key. A service key is a number or string of characters that is used to identify 
a communications product or service sold to a customer. For example, a phone 
number or an email address may be a service key.

Network Configurations
Use the Network Configurations tab in the Product Summary and Details window 
to review the fulfillment elements of a selected product in the Installed Base. The 
information on this tab can be edited. Access to this tab can be restricted to 
knowledgeable personnel during implementation.

Considerations for Future Upgrade Paths
The following are considerations for future System-Level upgrades:

n System Profiles

n Enabled Workflows

n Employees and Security

n Multicurrency capabilities

n Customization Issues
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