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Preface

Welcome to Release 11i of the Oracle Activity-Based Management Installation Guide.  
Use this guide to familiarize yourself with the steps to install ABM, which includes 
the following components:

� Activity-Based Management (ABM)

� ABM Web Reports

� ABM Analyzer

� SEM Exchange

Intended Audience
This guide is the primary source of information about installing the Oracle ABM 
Products.  This guide is intended for any user responsible for installing, upgrading, 
and configuring ABM products and their required components, including:

� Internal and external consultants

� System administrators

Structure
This manual contains the following sections:

Introduction
� Overview:  Provides an overview of the Oracle ABM Products.

� System Architecture:  Details the architecture options for ABM and the usage of 
each module of the ABM products.
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� System Requirements:  Describes the software and hardware requirements for 
deploying the ABM products.

Installing ABM
� Enterprise Database Installation:  Contains the steps to deploy the enterprise 

technology components, including the end-user viewer.

� ABM Installation:  Contains steps to install ABM and describes the basic 
deployment steps.

Installing Web Reports
� Technology Components: Describes the software requirements for Web Reports

� Preinstallation Tasks:  Covers the tasks that must be completed prior to 
installing Web Reports.

� Installing Web Reports:  Outlines installation tasks.

� Postinstallation Tasks:  Outlines postinstallation tasks such as defining profile 
options and report server environmental variables.

Installing ABM Analyzer
� Technology Components:  Describes the software requirements for ABM 

Analyzer.

� Preinstallation Tasks:  Covers the tasks that must be completed prior to 
installing ABM Analyzer.

� Installing ABM Analyzer:  Outlines installation tasks.

� Postinstallation Tasks:  Outlines postinstallation tasks such as setting up the 
application to run correctly through the Self-Service Web Applications 
environment.

Installing SEM Exchange
� Technology Components: Describes the software requirements for SEM 

Exchange.

� Installing SEM Exchange:  Describes the steps to install SEM Exchange.

Migrating Data from Activa 3.x
� Prerequisites: Covers the required tasks prior to migrating a model from Activa 

3.x.
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� Migration Process:  Outlines the migration process from Activa 3.x to ABM 11i.

Assumptions
This guide  assumes that you have a working knowledge of Oracle’s ABM products. 
If you are not familiar with these applications, we suggest you attend one or more 
of the related training classes that are available through Oracle Education Services. 
See "Training and Support" on page -xii for more information about Oracle training.

Do Not Use Database Tools to Modify Oracle Applications Data
Because Oracle Applications tables are interrelated, any change you make using 
Oracle Applications can update many tables at once.  But when you modify Oracle 
Applications data using anything other than Oracle Applications, you may change a 
row in one table without making corresponding changes in related tables.  If your 
tables get out of synchronization with each other, you risk retrieving erroneous 
information and unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, the system automatically 
checks that your changes are valid.  Oracle Applications also keeps track of who 
changes information.  If you enter information into database tables using database 
tools, you may store invalid information.  You also lost the ability to track who has 
changed your information because SQL*Plus and other database tools do not keep a 
record of changes.

Consequently we STRONGLY RECOMMEND that you never use SQL*Plus or 
any other tool to modify Oracle Applications data unless otherwise instructed.

Related Documents
You may wish to consult these related documents (for Release 11i) for additional 
information:

� Oracle Activity-Based Management User Guide

� Oracle ABM Analyzer User Guide

� Oracle SEM Exchange User Guide

� Installing Oracle Applications
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Conventions
The following conventions are used in this manual:

Training and Support

Training
Oracle offers a complete set of formal training courses to help you and your staff 
master each application product.  You have a choice of educational environments. 
You can attend Oracle applications courses at any Oracle Education Center, or you 
can arrange for Oracle trainers to teach at your facility. In addition, Oracle training 
professionals can tailor standard courses or develop custom courses to meet your 
needs. 

Support
From on-site support to central support, Oracle’s experienced professionals provide 
the help and information you need to keep the ABM Solution working for you. This 
team includes your technical representative, account manager, and Oracle’s large 
staff of consultants and support specialists with expertise in your business area, in 
managing an Oracle server, and in your hardware and software environments.

About Oracle Corporation
Oracle Corporation develops and markets an integrated line of software products 
for database management, applications development, decision support, and office 
automation, as well as Oracle Applications, an integrated suite of more than 45 
software modules for financial management, supply chain management, 

Convention Meaning

 italicized text Italicized type indicates the name of an Oracle reference manual.

boldface text Boldface type in text indicates a term defined in the text, the glossary, 
or in both locations.

Courier Text Identifies command line examples.

< >  Angle brackets enclose user-supplied names.

[ ] Brackets enclose optional clauses from which you can choose one or 
none.
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manufacturing, project systems, human resources, and sales and service 
management.

Oracle products are available for mainframes, minicomputers, personal computers, 
network computers, and personal digital assistants, enabling organizations to 
integrate different computers, different operating systems, different networks, and 
even different database management systems, into a single, unified computing and 
information resource.

Oracle is the world’s leading supplier of software for information management, and 
the world’s second largest software company. Oracle offers its database, tools, and 
applications products, along with related consulting, education, and support 
services, in over 140 countries.

Thank You...
Thank you for using Oracle Activity-Based Management Installation Guide.

We value your comments and feedback. At the front of this guide is a reader’s 
comment form you can use to explain what you like or dislike about this product. 
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1
Introduction

This chapter provides an overview of the architecture, options, and system 
requirements of the Oracle Activity-Based Management product suite.  

Overview
ABM products include:

❏ Activity-Based Management (ABM) — part of Oracle’s Strategic Enterprise 
Management (SEM) suite of analytical applications.   ABM is an enterprise wide 
activity-based costing and management application that supports any ABC 
methodology in any industry. ABM provides flexible modeling to allow profit 
and loss analysis to occur at any level in the organization. Activity-based 
analysis of profitability provides new decision making foundation for customer 
profitability, accurate product and service profitability, and volume-based 
forecasting of expenses, capacity, and resources.

❏ ABM Analyzer — a relational OLAP reporting and analysis solution 
specifically created for ABM. It gives users throughout an organization the 
ability to generate multidimensional custom reports without writing any code. 
It uses Oracle Discoverer’s tools to provide high performance and an 
easy-to-use interface to select information, which reduces the cost of installing a 
customized solution to allow users access to the information they need for their 
decision processes. Using ABM Analyzer, all users can have customized 
reporting to suit their specific needs.

❏ SEM Exchange — an end-user controlled, rules-based systems integration 
process that extracts data from Oracle General Ledger and transfers it to Oracle 
ABM, enabling enterprise Activity Based Costing and Management 
(ABC/ABM) models. SEM Exchange provides the bridge between traditional 
accounting for financial reporting and activity-based management, and it 
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enables state of the art performance management and profitability analysis 
decision making.

System Architecture
ABM is a Web-based end-user tool that can be deployed in a three-tier architecture.  
The ABM end-user connects to an Oracle Applications database server through a 
Java-enabled Web browser and a middle-tier server.  The middle tier consists of a 
Web server, forms servers and Internet Interoperability Protocol (IIOP) servers.



System Requirements

Introduction 1-3

System Requirements
This section outlines the system requirements for the ABM products, including 
requirements for the web browser, software, and hardware.

Web Browser Requirements
To use the ABM products, your users must be running a Java-enabled web browser. 
The desktop client requires a network connection to the Oracle Applications Release 
11i application environment. Recommended web browsers are Netscape 
Communicator 4.5 or higher and Microsoft Internet Explorer 5.0 or higher.

Software Requirements

ABM Release 11i
� Oracle Applications Release 11i, with Self-Service Web Applications (SSWA) 

implemented

� Inprise VisiBroker for Java 3.4, included on the Oracle ABM Release 11i 
CD-ROM

ABM Web Reports Release 11i
� Oracle ABM Release 11i, installed and configured

ABM Analyzer Release 11i
� Oracle ABM Release 11i, installed and configured

� Oracle Discoverer Release 3.1.42

– Administration Edition 

– User Edition

� Oracle Web Discoverer Release 3.3.59

� Oracle Web Discoverer Viewer Release 3.3.59

SEM Exchange Release 11i
� Oracle ABM Release 11i, installed and configured

� Oracle General Ledger Release 11i implemented
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Hardware Requirements

Database and Applications Tier
Check the guide Installing Oracle Applications for Release 11i for information about 
database and applications tier hardware requirements.

Check Oracle Discoverer 3.1 Installation and Upgrade Guide for information about 
Oracle Discoverer hardware requirements.

Check Oracle Web Discoverer 3i Installation and Administration Guide for information 
about Oracle Web Discoverer hardware requirements.

Client Tier
❏ A Pentium-based PC, or equivalent, with a minimum processor speed of 266 

MHz.

❏ Minimum Disk Space of 100 MB.

❏ Minimum recommended memory of 128 MB.

Note: Please check Oracle MetaLink for the most up-to-date 
information on required versions of the web browser and the 
JInitiator plug-in. The Oracle Applications Release Notes, Release 11i 
and Oracle Applications Installation Update Notes are also available on 
MetaLink.
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2
Installing ABM

This chapter covers the steps for installing ABM.

Prerequisites
❏ Install and configure Oracle Application Release 11i.  See:  Installing Oracle 

Applications, Release 11i.

❏ Deploy Oracle Self-Service Web Applications (SSWA) on a server against which 
user authentication is performed.  See:  Oracle Self-Service Web Applications 
Implementation Manual, Release 11i.

Apply the ABM Server Patch
This procedure installs the ABM patch in your Oracle Applications Release 11i 
environment. Repeat this procedure for every server in this environment, including 
the administration server, concurrent processing server(s), Forms server(s), reports 
servers, and Web server(s).

For Additional Information See:

� AutoPatch, Maintaining Oracle Applications, Release 11i for your 
platform
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◗◗ To apply the ABM product patch:
1. Log in to your Oracle Applications Release 11i environment using the 

Applications owner account.

2. Choose a patch directory.

3. Copy the ABM patch 1588595 from the Oracle ABM Release 11i CD-ROM to 
your patch directory. Make sure to choose the patch file for your platform.

4. Unzip the patch file for your platform.

5. Use ADPATCH to apply the patch drivers in the following order:

� c1588595.drv (should be applied to all servers in your Release 11i 
environment).

� d1588595.drv (should be applied to the Administration server only).

� g1588595.drv (should be applied to all servers in your Release 11i 
environment).

6. (On the Administration server only) Run ADADMIN, from the Maintain 
Applications Database Objects menu, select the Compile APPS schema(s) 
option.

Install Inprise VisiBroker for Java on a UNIX Platform      
This section explains how to set up Inprise VisiBroker for Java in the middle tier on 
a UNIX platform.  It also provides the steps needed to start the ABM Java Server 
process.

1. Sign in to the account that has access to the web server file system.  

2. Install VisiBroker for Java 3.4

Caution:

� Check your log after installing each patch driver.  The log is 
located in the $APPL_TOP/admin/<dbname>/log directory.

� Backup the log file before installing the next patch driver.

� Resolve any issues with the current patch driver before 
proceeding to run the next patch driver.
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VisiBroker for Java 3.4 is available on the Oracle ABM Release 11i CD-ROM. It is 
located in the VisiBroker directory under the corresponding platform 
subdirectories.

You can run the Oracle Installer in one of two modes: Character or Motif.

To run Oracle Installer in character mode:  

To run in character mode, enter the commands:

$ cd /<CD-ROM>/VISIBROKER/<platform>/VBJ/orainst
$ orainst /c 

or 

$ orainst

(where $ is the unix command prompt)

You will see the character mode version of the Installation Options: Home 
Locator window.  In this window, use the Tab Key to move your cursor.

Figure 2–1 Installation Options: Home Locator Window

To run Oracle Installer in Motif Mode:  

To run the Installer in Motif mode, the Motif libraries must be available on your 
UNIX machine. If they are, to run the Installer you must first set either the 
TERM or ORACLE_TERM environment variable to one of the terminals 

Note: You must set the TERM variable for both Character and 
Motif modes.
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supported by the Installer. The supported terminals include VT100, VT200, 
XSUN5, SUN5, SUN, and XSUN.

To set an environment variable in a Bourne Shell, please enter the following 
commands:

$ TERM=<supported terminal> 
$ export TERM

To set an environment variable in a C shell, enter the following command:

$setenv TERM <supported terminal>

Make sure the environment variable DISPLAY is set.  For example:

$ DISPLAY=ap1470pc:00;export display

Note that the dollar sign represents the UNIX prompt. Once you’ve set your 
environment variable, enter the following command to start the Oracle Installer 
in Motif mode:

$ orainst /m

The Installer Setup window appears, followed by the Motif version of the 
Installation Options: Home Locator window.

Figure 2–2 Installer Setup Window

Note: The remainder of the steps below show the Motif versions 
of the related installation windows. The steps however are the same 
for either the character mode or Motif mode installation process.
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To Install VisiBroker for Java  

In the Installation Options: Home Locator window, enter the path for your 
ORACLE_HOME. You must have write permission for this path. Choose OK to 
continue.

Figure 2–3 Enter Oracle_Home Location

In the Logging and Status window, enter the path where the Installer, SQL, 
Makefile, and operating system logs will be written. Choose OK to continue.

Note: This is the directory under which VisiBroker will be 
installed. It can be any location, and does not have to be in a valid 
ORACLE-HOME or APPL-TOP.
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Figure 2–4 Logging and Status Window

The $ORACLE_LINK Directory window appears. Use this window to enter the 
$ORACLE_LINK environment variable. The $ORACLE_LINK environment 
variable is used for some CD ROMs that do not support long path names.  If it 
supports the long pathname, the window below will not appear in your 
installation.

Figure 2–5 $ORACLE_LINK Directory Window

Enter the pathname from which you are installing, then choose OK. For 
example, if you install directly from the CD ROM, enter 
/<CD-ROM>/<PLATFORM>/VBJ/VISIBROKER as the $ORACLE_LINK 
directory.
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The NLS window appears. Select American English, then choose OK.

Figure 2–6 NLS Window

The Software Asset Manager window appears. Select VisiBroker Products 3.3, 
then choose the Install button.

Note: VisiBroker for Java 3.4 is contained within VisiBroker 
Products 3.3. 
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Figure 2–7 Software Asset Manager Window

Once the installation process has completed, choose the Exit button from the 
Software Asset Manager window to close the Installer.

JRE 1.1.8 is installed with Oracle Applications Release 11i.  By default, it is 
installed in COMMON_TOP/util/jre/1.1.8, which is your <JRE_PATH>.

VisiBroker will be installed in <ORACLE_HOME>/vbroker. <ORACLE_
HOME> is the directory path you entered in the previous screen; it can be any 
location and does not need to be a valid ORACLE_HOME.

The directory <ORACLE_HOME>/vbroker will be referred to as 
<VISIBROKER_INSTALL_DIR> in the subsequent steps.

3. Start VisiBroker OSAgent and GateKeeper in a Bourne shell.

These processes are needed to allow applet clients from the client browser (such 
as, Netscape Navigator or Internet Explorer) running on the client machine to 
communicate with middle tier objects through an IIOP protocol.
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Setting Up the Unix Environment  

In a Bourne shell, set the following environment variable values for VisiBroker:

$ VBROKER_ADM=<VISIBROKER_INSTALL_DIR>/adm
$ export VBROKER_ADM

$ VBROKER_JAVAVM=<JRE_PATH>/bin/jre
$ export VBROKER_JAVAVM

$ OSAGENT_PORT=14000
$ export OSAGENT_PORT

$ LD_LIBRARY_PATH=<VISIBROKER_INSTALL_DIR>/lib:$LD_LIBRARY_PATH
$ export LD_LIBRARY_PATH

$ PATH=<VISIBROKER_INSTALL_DIR>/bin:$PATH
$ export PATH

$ CLASSPATH=<JRE_PATH>/lib/rt.jar:<JRE_PATH>/lib/i18n.jar
$ export CLASSPATH

Notes: 

� <JRE_PATH> could correspond to $OA_JRE_TOP in an Oracle 
Applications 11i environment, or to any other location where JRE 1.1.8 
is installed.

� <VISIBROKER_INSTALL_DIR> is the Inprise VisiBroker product 
installation root directory. <JRE_PATH> is the root directory where the 
JRE has been installed.

� VBROKER_JAVAVM value is used as a Java run-time environment for 
VisiBroker and it must point to the jre that was installed.  In general, 
this value can point to either Java or jre shell script, and it takes 
precedence over any Java or jre in the PATH setting.  If this 
environment variable is not defined, VisiBroker looks for Java in your 
PATH setting.

Note: We recommend that you set these variables before starting 
the OSAGENT and GATEKEEPER processes in a fresh new UNIX 
session.
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� Make sure that the PATH value above does not contain any components 
that can conflict with the VisiBroker path settings.  If another software 
application contains a separate VisiBroker as its component, its path 
settings could conflict with the setting of VisiBroker that you just 
installed.  For instance, Oracle Application Server or Oracle Discoverer 
contain their own VisiBroker components, and their path values should 
not exist in the PATH for VisiBroker above.

� OSAGENT_PORT is the port number on which the osagent process 
runs.  The default number is 14000.  This port number should be 
different from the port number of your GateKeeper process (the 
exterior_port variable mentioned below), when you configure the 
gatekeeper property file.

� Every time you start OSAgent and GateKeeper, you must perform the 
steps above.

Create Gatekeeper Properties file  

This file contains GateKeeper configurations.  The file is created in the 
directory <VISIBROKER_INSTALL_DIR>/bin

If the gkconfig utility is available in your <VISIBROKER_INSTALL_
DIR>/bin directory, then you can run this utility to set up your GateKeeper 
configurations and save the properties into a file named 
gatekeeper.properties.  If the gkconfig utility is not available, you can use a 
text editor to create or edit the gatekeeper.properties file:

– Run gkconfig from <VISIBROKER_INSTALL_DIRECTORY>/bin.

– On the General tab, make sure that the Enable Callback checkbox is 
cheked and that the Log Level is set to Quiet.  Also make sure to enter 
the IOR file location.

– On the Exterior tab, set the Exterior Port to a port that is not being used.  
See the VisiBroker installation documentation for more details.

Note: This step is needed only once after VisiBroker installation.

Note: Set your DISPLAY environment variable appropriately 
prior to proceeding, see instructions on page 2-4.
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– On the Properties tab, create a new property with the following values:

The gatekeeper.properties file should have the following contents.  
(ORBagentAddr line should be manually added after using gkconfig 
utility.)

    exterior_port= <port#>
    enable_callbacks=true
    ior_file_name= <ior file name with absolute filepath>   
    log_level=quiet
    ORBagentAddr= <IP address of VisiBroker host>   

The ior file is generated every time you run the gatekeeper program.  This 
value specifies where your ior file will exist.

Example:

    exterior_port= 15000
    enable_callbacks=true
    ior_file_name=/d01/prodcomn/portal/demo/gatekeeper.ior
    log_level=quiet
    ORBagentAddr= 111.11.111.11   

Notes:

� For more information on the above parameters settings, please refer to 
Chapter 3, Gatekeeper Configuration Manager in Gatekeeper Guide 
located at Inprise Online Books web page:

http://www.inprise.com/techpubs/books/vbj/vbj33/index.html 

� If you specify an invalid file path for ior_file_name, gatekeeper process 
will exit.

Name=ORBagentAddr The name is case sensitive. Be sure 
to type it exactly as it is shown here.

Value=<IP address of osagent> To identify the address of a host 
machine, type the command 
’ping -ns <machine name>’ 
from a UNIX command prompt.
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Start OSAgent  

Use the following command to start the VisiBroker OSAgent in Console 
mode:

$ osagent &

Note: Use the following command to check to see if OSAgent is already 
running:

ps -ef |grep osagent 

Start Gatekeeper  

Use the following command to run the GateKeeper process in the same 
Bourne shell:

$ gatekeeper -props <gatekeeper.properties path>/gatekeeper.properties &

Notes:

� <gatekeeper.properties path> is where your gatekeeper.properties file 
exists.  In order to shut down the gatekeeper, make sure the associated 
child processes are killed as well (e.g., kill -9 19254 -19254).  This will 
kill 19254 (gatekeeper pid -- search for "jre" process running in the 
background with "ps -ef | grep jre" command) and all the processes 
that belong to process group id 19254 (i.e., all the processes that are 
child processes of 19254).

� Only one gatekeeper process should be running at a time.

The gatekeeper.ior file is generated every time you run the gatekeeper 
process.  This file is needed to allow applet clients from the client browser 
to communicate with the server-side classes through an IIOP protocol. The 
parameter ior_file_name from the gatekeeper.properties file specifies the 
location where the gatekeeper.ior file will be created. The value for this 
parameter is <VISIBROKER_INSTALL_DIR>/bin.  

Note: When starting the OSAgent, Gatekeeper, and ABM middle 
tier, please record the process ID’s for later use. Before starting 
these processes, make sure all existing ABM processes are shut 
down.
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Start Middle-Tier ABM Java Server Process  

� Log onto Release 11i environment using the applications owner account.

� Start your middle-tier ABM Java server process by running the abmsrvst.sh 
shell script:

$ cd $ABM_TOP/bin

The  syntax for running the shell script is as follows:

$ abmsrvst.sh <ORB_AGENT_ADDR> <ORB_AGENT_PORT> <DEBUG_MODE>

Use the following syntax to start the middle tier in debug mode:

$ abmsrvst.sh myserver 14000 Y

or use the following syntax to start the middle tier in non-debug mode:

$ abmsrvst.sh myserver 14000 N

Notes:

– <ORB_AGENT_ADDR>  The VisiBroker Agent address.

– <ORB_AGENT_PORT>  The VisiBroker Agent port.

– <DEBUG_MODE>  If you set this parameter to Y, you can review the 
debug output in the file named abmsrvst.out.

Install Inprise VisiBroker for Java on a Windows NT Platform     
This section explains how to set up Inprise VisiBroker for Java in the middle tier on 
Windows NT.  It also provides the steps needed to start the ABM Java Server 
process.

1. Install Visibroker for Java 3.4.

Assuming that G: is your CD-ROM drive, the Windows NT ABM  Visibroker  
for Java 3.4 files are located under: 

G:\VISIBROKER\WINNT\VBJ

Run  Setup.exe from this directory. Make sure that you enter the DEFAULT_
HOME in the Oracle Home Name field at Oracle Installation Settings Window 
(see the figure below.)
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Figure 2–8 Oracle Installation Settings

You can download JRE 1.1.8 and install it on your NT server. <JRE_PATH> in the 
subsequent steps is the root directory where the JRE is installed.

VisiBroker will be installed in <ORACLE_HOME>\vbroker. <ORACLE_HOME> is 
the directory path you entered in the previous screen; it can be any location and 
does not need to be a valid ORACLE_HOME.

The directory <ORACLE_HOME>\vbroker will be referred to as <VISIBROKER_
INSTALL_DIR> in the subsequent steps.

In the next window, you can see the installation starts.  The progress window will 
disappear after installation completes successfully. 

Note: This is the directory under which VISIBROKER will be 
installed. It can be any location and does not have to be in a valid 
ORACLE_HOME or APPL_TOP.
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Figure 2–9 Installation Progress Window

2. Start VisiBroker OSAgent and GateKeeper in a DOS shell:

These processes are needed to allow applet clients from the client browser (such 
as Netscape Navigator or Internet Explorer) running in the client machine to 
communicate with middle tier objects through an IIOP protocol.

Set Up the DOS Environment  

In a DOS shell, set the following environment variable values for VisiBroker:

set VBROKER_ADM = <VISIBROKER_INSTALL_DIR>\adm
set VBROKER_JAVAVM = <JRE_PATH>\bin\jre
set PATH = <VISIBROKER_INSTALL_DIR>\bin
set CLASSPATH



Install Inprise VisiBroker for Java on a Windows NT Platform

2-16 Oracle Activity-Based Management Installation Guide

Notes:

� <VISIBROKER_INSTALL_DIR> is the Inprise VisiBroker product install 
root directory. <JRE_PATH> is the root directory where the JRE has 
been installed.

� VBROKER_JAVAVM value is used as a Java run-time environment for 
VisiBroker and must point to the jre.exe that was installed. In general, 
this value can point to either a Java or jre executable, and it takes 
precedence over any Java or jre in the PATH setting. If this environment 
variable is not defined, VisiBroker looks for jre.exe in your PATH 
setting. 

� Make sure that the PATH value above does not contain any components 
that can conflict with the VisiBroker path settings.  If another software 
application contains a separate VisiBroker as its component, its path 
settings could conflict with the setting of VisiBroker that you just 
installed.  For instance, Oracle Application Server or Oracle Discoverer 
contain their own VisiBroker components, and their path values should 
not exist in the PATH for VisiBroker above. 

� Setting classpath without a value unsets the CLASSPATH environment 
variable for the DOS session.  The Gatekeeper process internally uses its 
own classpath, and thus we need to unset the classpath before starting 
gatekeeper, to avoid any clash in classes.  

� In general, it is better to set these environment variable values for the 
DOS session rather than permanently set them as system variables.  
This is to avoid any clash with other system environment settings that 
are imposed by other software components.

� OSAGENT_PORT is the port number on which the osagent process 
runs.  The default number is 14000.  This port number should be 
different from the exterior_port variable you set below, when you 
configure your gatekeeper property file.

Create gatekeeper.properties file   

This step is needed only once after VisiBroker installation.  This file contains 
gatekeeper configurations.  If you have the gkconfig.exe utility available in 
your <VISIBROKER_INSTALL_DIR>\bin directory, then you can run this 
utility program to set up gatekeeper configurations and then save the 
properties into a file called gatekeeper.properties.  Otherwise, you can 
manually edit the gatekeeper.properties file using a text editor:
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– Run gkconfig from <VISIBROKER_INSTALL_DIRECTORY>\bin.

– On the General tab, make sure that the Enable Callback checkbox is 
cheked and that the Log Level is set to Quiet.  Also make sure to enter 
the IOR file location.

– On the Exterior tab, set the Exterior Port to a port that is not being used.  
See the VisiBroker installation documentation for more details.

– On the Properties tab, create a new property with the following values:

The gatekeeper.properties file should have the following contents:

exterior_port= <port#>
enable_callbacks=true
ior_file_name= <ior file name with absolute filepath>   
log_level=quiet
ORBagentAddr= <IP address of VisiBroker host>

The ior file is generated when you run the gatekeeper.exe program.  This 
value specifies where your ior file will exist.

Example:

    exterior_port= 15000
    enable_callbacks=true
    ior_file_name=C:\\orant\\ows\\4.0\\doc\\gatekeeper.ior
    log_level=quiet
    ORBagentAddr= 111.11.111.11   

Notes:

� For more information on the above parameters settings, please refer to 
Chapter 3, Gatekeeper Configuration Manager in Gatekeeper Guide 
located at Inprise Online Books web page:

http://www.inprise.com/techpubs/books/vbj/vbj33/index.html

Name=ORBagentAddr The name is case sensitive. Be sure 
to type it exactly as it is shown here.

Value=<IP address of osagent> To identify the address of a host 
machine, type the command 
’ping <machine name>’ from a 
DOS command prompt.
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� If you specify an invalid file path for ior_file_name, the gatekeeper 
process will exit.  For NT, if you put ’\’ in gkconfig utility, ’\\’(double 
backslash) will be inserted into gatekeeper.properties file.

Start OSAgent  

Use the following command to start the VisiBroker OSAgent in Console 
mode:

C:\> osagent  -C

Start Gatekeeper  

Use the following command to run the GateKeeper process in the same 
DOS shell:

C:\> gatekeeper -props <gatekeeper.properties path>\gatekeeper.properties 

The gatekeeper.ior file is generated every time you run the GateKeeper 
process.  This file is needed to allow applet clients from the client browser 
to communicate with the server-side classes through an IIOP protocol.  The 
parameter ior_file_name from the gatekeeper.properties file specifies the 
location where the gatekeeper.ior file will be created. The value for this 
parameter is <VISIBROKER_INSTALL_DIR>\bin.

Note:

� (Optional) You can run 'netstat -a' to verify whether the Gatekeeper 
process is listening on the exterior port(15000) by opening another  DOS 
shell, then entering the following command:

C:\> netstat -a

3. Log onto your Release 11i Environment using the Application Owner account.

4. Start your middle-tier ABM server process by running the abmsrvst batch file in 
MKS Toolkit’s Korn shell or C shell.  For more information about MKS Toolkit, 
please see: Installing Oracle Applications, Release 11i.

c:\> cd %ABM_TOP%\bin

Note: <gatekeeper.properties path> is where your 
gatekeeper.properties file exists. Only one GateKeeper process 
should be running at a time.
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Run abmsrvst.bat by using the following syntax:

$ abmsrvst.sh <ORB_AGENT_ADDR> <ORB_AGENT_PORT> <DEBUG_MODE>

For example:

c:\> abmsrvst.sh myserver 14000 Y

or 

C:\> abmsrvst.sh myserver 14000 N

Notes:

– <ORB_AGENT_ADDR>  The VisiBroker Agent address.

– <ORB_AGENT_PORT>  The VisiBroker Agent port.

– <DEBUG_MODE>  If you set this parameter to Y, you can review the debug 
output in the file named abmsrvst_apps.out.

– Use a new DOS window to execute the following commands.

(Optional)  Run 'osfind' to see if your osagent service is running:

 C:\> set PATH = <VISIBROKER_INSTALL_DIR>\bin
 C:\> osfind

Define Profile Options  
Log onto Oracle Applications Release 11i Forms session. Use the Profile Options 
window to supply values for the profile options that define where the various 
components comprising ABM reside.  The following table describes the profile 
options.
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Grant User Access
At this point, all of the technology pieces have been installed. You must now grant 
access to ABM.  This requires Oracle Applications Release 11i for assigning an 
appropriate ABM responsibility to the users who need access to ABM.  For new 

Table 2–1 ABM Profile Options

Profile Option Name Sample Value Description

ABM: Web Server Host ap123.us.oracle.com (if your web server 
address is http://ap123.us.oracle.com)

This value identifies the DNS 
(Domain Name Service) name of 
your self service web server.

ABM: Web Server Port 80 This value identifies the self 
service web server port number.

ABM: VisiBroker Remote 
Host Address

123.45.67.890 This value identifies the IP 
address of the  VisiBroker OS 
Agent Host. 

 Note: Web Server and 
GateKeeper processes should run 
on the same host. The osagent 
process can run on a different 
host.  The current release 
supports the  configuration to run 
web server, GateKeeper, and 
osagent processes in the same 
host.

ABM: VisiBroker Remote Port 15000 This value identifies the 
VisiBroker GateKeeper port 
number.

ABM: ORB Gatekeeper IOR http://ap123sun.us.oracle.com:15000/gate
keeper.ior

Where ap123sun is the host machine for 
Gatekeeper processes; 15000 is the 
gatekeeper port; and gatekeeper.ior is the 
ior filename.

This value identifies the full URL 
path for the GateKeeper IOR file.

ABM: APPLET PLUGIN URL oajinit.exe This value identifies the JInitiator 
plug-in executable location

ABM: APPLET PLUGIN TYPE application/x-jinit-applet;version= 
<JINITIATOR_version_in_release11i_
environment>

This value identifies the JInitiator 
plug-in executable type
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users, you may need to create user accounts; this is optional. The following ABM 
responsibilities are installed:

� ABM Manager:  Access to ABM functions

� ABM Supervisor:  Access to ABM concurrent manager processes

� ABM Web Reports:  Access to ABM Web Reports

◗◗ To grant user access to ABM:
1. (Optional)  If you do not want to use the provided ABM responsibilities ,create 

new responsibilities for accessing ABM.

2. Set the Oracle Self Service Web Applications flag to true for the new 
responsibilities created.

3. Set the Menu option to ABM Main Menu.

4. Assign ABM responsibilities to those users who need access to ABM.

See: Oracle Applications System Administrator’s Guide
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3
Installing Web Reports

ABM uses Oracle Developer/2000 Report Server to publish reports on the web in a 
HTML format.  This chapter covers the steps to install and configure Web Reports 
for use with ABM.  

Technology Components
The following diagram illustrates how the technology components are used by 
ABM for the Developer 2000 Reports Server.
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Figure 3–1 ABM Web Reports Technology Components

Prerequisites
❏ Install and configure Oracle Applications Release 11i.  For more guidance on 

installing Oracle Applications, (See: Installing Oracle Applications)

❏ Deploy the Self Service environment on a server against which user 
authentication is performed ( See Oracle Self-Service Web Applications 
Implementation Manual Release 11i)

❏ Install and configure ABM 11i as described earlier in this guide.
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Set Up the Environment
1. By installing the ABM patch on top of the Oracle Applications Release 11i 

installation, you will have copied the PL/SQL library files (i.e., files with the 
extension .PLL) and the Report files (i.e., files with the .RDF extension) to the 
following directories:

� AU_TOP/plsql for the .PLL files

� ABM_TOP/reports/US for the .RDF files

2. Edit the REPORTS60_PATH (i.e., Report Server path) to include the following 
directories:

� AU_TOP/plsql

� AU_TOP/graphs

� ABM_TOP/reports/US

3. Edit the GRAPHICS60_PATH to include the following directories:

� AU_TOP/plsql

� AU_TOP/graphs

� ABM_TOP/reports/US

4. Edit the ORAPLSQLLOADPATH path to include the following directory:

� AU_TOP/plsql

Define Values for Profile Options  
Log onto Oracle Applications Release 11i Forms session. Use the Profile Options 
window to supply values for the profile options that define where the various 
technology components comprising the ABM reside. For most installations, you 
must supply both a site-level and a user-level value. Refer to the table below.

Note: You need to modify APPLSYS.ENV and <ORACLE_
SID>.env files, which are located under APPL_TOP, to edit the 
following environmental variables.
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Considerations for Windows NT
❏ Check that the following reports environmental variables or logical names are 

set correctly.  If the reports server is installed on a different machine than the 
web server and the cache is not shared between the reports server and web 
server, set the variables as follows:

Table 3–1 ABM Profile Options

Profile Option Name Sample Value Description

ICX:Report Cache http://<Reports Web Server>:<Web 
server port>/cache

This value identifies the virtual directory 
for Report Cache at the HTTP listener.

ICX: Report Format HTML This value must be set toHTML.

ICX: Report Image http://<Reports Web Server>:<Web 
server port>/OA_MEDIA

This value is embedded into HTML report 
output so that reports can include standard 
image files.

ICX: Report Launcher http://<Reports Web Server>:<Web 
server port>/cgi-bin/rwcgi60

This value identifies the Report Server that 
will run reports and produce HTML 
output. See: Add a Key to cgicmd.dat: page 

ICX: Report Link For Apache:

http://<Reports Web Server>:<Web 
server port>/pls/<ORACLESID>

For WebDB:

http://<Reports Web Server>:<Web 
server port>/<ORACLESID>

This value is embedded into HTML report 
output so that reports can include 
drilldown links to other reports. 

ICX: Report Server <ABM Report Server name> Provide the name of the Report Server 
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Create cgicmd.dat File  
Create a file named cgicmd.dat in the {ORACLE_HOME}\reports60 directory. 
The Report Server CGI Interface uses values from this file to produce HTML 
output for display in a web browser. The values in the file never appear in a 
URL that is visible to end users. This ensures that critical data, such as database 
username and password, is hidden from end users. Only the user who runs the 
Report Server service needs to access the cgicmd.dat file. You can maximize 
security over this file by allowing only one user read access to the file.

Each line in the cgicmd.dat file is called a Key. You need one Key for each    
database that is accessed by the Report Server. The Key is referenced in the     
profile option ICX: Report Launcher.

Add a key to cgicmd.dat as follows:

<keyname>: userid=<apps database username>/<apps database
password>@<database connect string> destype=cache %*

Example:

abm: userid=apps/apps@abm115 destype=cache %*

Table 3–2 Report Server Environment Variables for Windows NT

Name Value Description

REPORTS60_SHARED_CACHE YES Specifies whether the location of Report 
Server cache is shared with the Web 
serverís cache.

REPORTS60_VIRTUAL_MAP /CACHE The Virtual directory where the Web 
Server looks for the report output

REPORTS60_PHYSICAL_MAP  /d4/db/db/dev60/reports60/server/cache The Physcial location where the Web 
Server looks for the report output

REPORT60_OWSMAP or 
REPORTS60_CGIMAP

 $ORACLE_HOME/reports60/cgicmd.dat For Web Reports Web CGI or the 
Reports Web Cartridge.  Defines fully 
qualified file name/location of the 
RWCGI or RWOWS map file (if map file 
configuration is used)
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Grant User Access
At this point, all of the technology pieces have been installed. You must now grant 
user access to the ABM WebReports. This requires using Oracle Applications 
Release 11i Forms session to assign the ABM Web Reports responsibility to those 
Apps users who are authorized to use the ABM Web Reports.

Client Browser Setup
You must set the browser’s memory cache and disk cache size greater than 0 
kilobytes.  If the cache is set to 0, the user will not be able to make any edits to the 
page. The page will instead automatically refresh regardless of the user’s choice. 

❏ To check the cache size in Netscape, select the Edit menu option > Preferences > 
double-click on Advanced > Cache.

❏ To check the cache size in Microsoft Internet Explorer, select View menu option 
> Internet Options. On the General tab, click Settings.

The recommended browser settings for color and fonts are as follows:

� Text Color:  Black

� Browser or user colors:  Choose browser colors.  For example, in Netscape the 
option is a checkbox titled "Always use my colors".  This option should be 
unchecked in Netscape.

� Variable width font: Arial, size 10

� Fixed width font: Times New Roman, size 10

� Default or Document-Specified Fonts:  Choose an option to use 
document-specified fonts.  If there is more than one "document-specified" 
option, you may choose any of them.
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4
Installing ABM Analyzer

This chapter covers the steps to install and configure ABM Analyzer.  Before 
installing, check to see that you have all the required software and hardware 
components.  Also check with your system administrator to ensure that you have 
the necessary information.  You will need the following information from the 
system administrator:

❏ Database name:  The name of the database containing your ABM data.

❏ Host name:  The name of the host computer that contains the ABM database. 

❏ Database administrator username/password:  The default is 
SYSTEM/MANAGER, but check with your system administrator to verify the 
database administrator password (this is the DB user password).

❏ Administrative rights:  You may need administrative rights to use SQL*Plus to 
navigate databases and run scripts.  When you obtain your database 
administrator’s username/password, you should have these rights, but check 
to make sure.

Throughout this chapter the notation <abmdir> refers to the root directory of the 
ABM Release 11i CD-ROM.

Technology Components
ABM Analyzer runs in a three-tier environment with a database tier, a mid-level 
application tier and a client tier.  Users can access the ABM Analyzer workbooks 
through a Java-enabled Web browser, by using Oracle Discoverer User Edition to 
navigate the workbooks.  The back-end is a database containing ABM business 
objects and data, on which the ABM Analyzer workbooks are based.  
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Figure 4–1 ABM Analyzer Technology Components

Prerequisites
Complete these preinstallation steps before proceeding to install ABM Analyzer.  
The steps must be completed sequentially.

1. Install and configure Oracle Applications Release 11i.  See: Installing Oracle 
Applications, Release 11i.

2. Deploy Oracle Self-Service Web Applications on a server against which user 
authentication is performed.  See: Oracle Self-Service Web Applications 
Implementation Manual.

3. Install and configure ABM 11i.  See:  Chapter 2, "Installing ABM").

4. Install Oracle Discoverer Administration and User Editions.  See: Oracle 
Discoverer Installation Guide and Oracle Discoverer Administrator’s Guide.  

5. Install Oracle Web Discoverer 3i.  See:  Oracle Web Discoverer 3i Installation and 
Administration Guide.  Make sure you also install the Viewer component.

Note: To connect to the database, you will need an entry in the 
tnsnames.ora file on the Web Discoverer server.



Installing ABM Analyzer

Installing ABM Analyzer 4-3

Installing ABM Analyzer
The ABM Analyzer installation process can be broken into these main steps:

1. Copy DBC File to Web Discoverer Server

2. Create the Discoverer End User Layer

3. Grant FND Object Privileges to EUL Owner

4. Copy ABM Analyzer Workbooks to Discoverer Server

5. Install the ABM Analyzer Business Areas

6. Grant Access to Discoverer Administrator and User Editions

7. Create Applications User

8. Save ABM Analyzer Workbooks

9. Grant Workbook Access to Oracle Applications Eesponsibilities.

Copy DBC File to Web Discoverer Server
On the server where you installed Web Discoverer, create a subdirectory named 
’secure’ (e.g., d:\secure).  Once this is completed, follow these steps:

1. From Windows NT, open the Control Panel, then choose the System icon.

2. On the Environment tab of the System Properties window, create a new system 
variable named FND_TOP and set its value to the root directory (e.g., d:\) of 
the ’secure’ subdirectory you created earlier.

3. Copy the DBC file for each applications database into the 
%FND_TOP%\secure\ directory.  In the first two steps above, FND_TOP was 
set to "d:\", therefore, copy the DBC file to d:\secure\.  For instructions on 
creating DBC files, see: Oracle Applications Self-Service Web Applications 
Implementation Manual.
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4. Reboot your Web Discoverer server for the changes you’ve just made to take 
effect.

5. Make sure that the tnsnames.ora file on your Web Discoverer server has an 
entry for the database.

Create the Discoverer End User Layer

◗◗ To create the End User Layer:
1. Log into Discoverer Administration Edition in application mode as username 

"system". 

� See: Creating Applications-Mode End User Layer, Oracle Discoverer 3.1 
Administration Guide.
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2. One of the following occurs:

If you have no EUL assigned to your user ID, a message displays asking if you 
want to create an EUL.  Choose Yes to open the EUL Manager.

If you have an EUL assigned to your user ID, the Load Wizard displays asking 
you to choose a business area.  Choose Cancel.

3. Choose Tools > EUL Manager.  You are given options to Create/Delete an EUL 
or Install/Uninstall the Tutorial.
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4. Choose Create an EUL.

Create a new user as the owner of the EUL.  Choose ’Create a new user’ and 
indicate whether you want to grant access to this EUL to the PUBLIC user 
schema.  Next, enter a name for the User, as well as a Password.  Choose Next 
when you are ready.  

Notes:

� The form of the user name must be <userid>_<lang>, where 
<userid> is the username and <lang> is the user’s language 
code.  For example, an English-speaking U.S. user named 
"EUL" would be given the name EUL_US.

� The ABM EUL name must not conflict with the BIS EUL name.
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5. Select a default and temporary tablespace for this EUL.  Choose Finish to create 
the EUL.

6. Discoverer creates an End User Layer owned by the user you specified.  You are 
given an option to install tutorial data in the EUL.  You are then asked if you 
wish to reconnect as the new EUL user.  

Grant FND Object Privileges to EUL Owner
Grant the EUL owner privileges to FND objects.  To do so, log onto the machine 
where you unloaded your files during ABM installation.  Log into the database as 
the APPS user and run the following SQL script:

SQL> @$ABM_TOP/patch/115/sql/abmgseul.sql <EUL owner userid>

Example:  

SQL> @$ABM_TOP/patch/115/sql/abmgseul.sql EUL_US

When the script is finished, you should receive a message, ’Grant Succeeded.’ 

Copy ABM Analyzer Workbooks to Discoverer Server
Copy the following files from the $AU_TOP/discover/<language> directory to a 
valid directory on your NT server where you installed Discoverer Administration 
and User Editions (e.g., ’c:\stage):  
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abmimp.eex
abmcowk.dis
abmmatwk.dis
abmdepwk.dis
abmactwk.dis

Copy the following files from the $ABM_TOP/bin directory to a valid directory on 
your NT server where you installed Discoverer Administration and User Editions 
(e.g., ’c:\stage):  

abminst.sh
abminswb.sh

After copying these files to the staging area on the NT machine, rename the files 
abminst.sh and abminswb.sh to abminst.bat and abminswb.bat respectively.

You will later install these workbooks to the server containing your ABM database 
(see: Save ABM Analyzer Workbooks).

Install ABM Analyzer Business Areas
To install the ABM business areas, run the ’abminst.bat’ file from the staging 
directory on your Discoverer server.  You will need the EUL owner database user 
ID, EUL password, and database name to complete this step.

Enter the following command at the MS-DOS prompt:

abminst <EUL owner> <password> <database name>

When the batch file executes, you should receive a message similar to the following:
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Close Discoverer Administrator Edition after the End User Layer is saved to the 
database.  Check the log file, ’abminst.log’, to ensure that the import ran 
successfully.

When you open Discoverer Administration or User Edition, set the default EUL 
before modifying your business areas, as described below.

◗◗To set the default EUL: 

1. Log into Discoverer Administration Edition in application mode, using the 
username of the EUL owner you created earlier. 

Caution: After you run the abminst command you will lose all 
attribute folders you created previously in any business areas you 
also created.  To restore your old business areas, enter the 
command below:

abminst -r <user> <password> <database name>
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2. Choose File > Set Default EUL from the menu.  You should see a window with a 
list of EULs:

3. Select your EUL from the list of EULs owned by this EUL owner.  Discoverer 
will use this EUL as the default each time you connect to that database.  Choose 
OK.

4. Exit Discoverer Administrator Edition. 

Grant Access to Discoverer Administrator and User Editions

◗◗ To grant access to Oracle Discoverer Administration and User Editions:
1. Log into Discoverer Administration Edition as the EUL owner in Oracle 

Applications mode.

2. Choose Open Existing Business Areas.

3. Select all ABM Analyzer business areas and choose Finish.
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4. Choose Tools > Privileges from the menu.  The Privileges window will appear.
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5. Select the ABM Manager responsibility from the poplist, then mark the 
appropriate check boxes in the Privilege area to grant the related access 
privileges within Discoverer Administration or User Editions.

6. Choose OK to save your work.

Create Applications User
� You must create the Oracle Applications user through Oracle Applications.  To 

do so, log into Oracle Applications as the system administrator responsibility 
and navigate to Security > User > Define.  If your username is not assigned the 
system administrator responsibility, check with your organization’s system 
administrator to get access.

� Assign ABM Manager Responsibility to the User.

Note: If the responsibility to which you are granting access is not 
a Self-Service responsibility, it cannot be accessed later through the 
Self-Service Web Applications login.
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Set the Default EUL in the Discoverer User Edition for an Applications User
1. Log onto Discoverer user edition in Oracle Applications mode. Use the 

applications Userid created in the previous step, applications responsibility 
ABM Manager, applications password and database name.

2. Navigate to Tools>Options. Go to the EUL tab and select default EUL.

Save ABM Analyzer Workbooks
Now you can save the ABM Analyzer workbooks from the staging area to your 
ABM database.  From the staging directory where you saved the workbooks on 
your Web Discoverer server, run the batch file ’abminswb.bat’, including your 
Applications user ID, Applications responsibility, Applications password, and 
database name as parameters:

abminswb <Apps user ID> <Apps responsibility> <Apps pwd> <db name>

For example:

abminswb vision "ABM Manager" vision98 abm115db

Grant Workbook Access to Oracle Applications Responsibilities

◗◗ To grant workbook access:
1. Log into Oracle Discoverer User Edition in Oracle Applications mode.  Use the 

same Applications user ID, Applications responsibility, Applications password, 
and database name you used above when you saved your ABM Analyzer 
workbooks.
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2. From the File menu, choose Manage Workbooks > Sharing.

3. Choose the User --> Workbook tabbed region.

4. From the User poplist, choose the responsibility to which you want to grant 
workbook access.

5. In the Workbooks region of the window, select the Available workbooks that 
you want to share, then choose the Add button to move them to the Shared 
area.

6. To see all the responsibilities that have been granted access to a workbook, 
choose the Workbook --> User tabbed region, then select the Workbook from the 
poplist.  For example, in the figure below, you can see that ABM Manager is the 
only responsibility currently granted access to the workbook named 
"abmactwk".
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Define Applications Profile Options (required) 
1. Log into Oracle Applications using the system administrator responsibility and 

navigate to Profile > System.  

2. At the Site or Responsibility level, enter appropriate values for the following 
profile options:

ICX: Discoverer Default Workbook Enter a default ABM Analyzer workbook

ICX: Discoverer End User Layer Enter your EUL name

ICX: Discoverer Launcher Enter the URL to Web Discoverer

ICX: Discoverer Viewer Launcher Enter the URL of the Discoverer Viewer

ICX: Discoverer Use Viewer Enter Yes or No
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Following is an example of the Discoverer Launcher URL:

Update Discoverer EUL Item Labels (optional):

The following diagram illustrates how ABM components are mapped to database 
objects:

Note: This is only required if the user wants to use site modified 
labels in their Discoverer instance.
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Example:

The mapping between Folders > Business Views, Items > Business View Columns is 
stored in Oracle Discoverer End User Layer (EUL) tables.

The mapping between Business View Columns and Lookups is stored in the ABM_
BV_LABEL_MAPPING table.
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The item names "Master List Name" and "Activity Name" are translated values 
derived from FEM_LOOKUPS.Meaning column. If you change the meaning of a 
lookup associated with an EUL Item, run the following script to propogate the 
change to the EUL item:

sqlplus <EUL userid>/<EUL passwd> @abmueull.sql <apps_username> <Business Area 
Name>

For example:

sqlplus eul_us/eul @abmueull.sql apps 'ABM Activities'

Upgrade Any Existing ABM Analyzer Workbooks (optional):

1. Log into Activa 3.0 Discoverer Administration edition in NON APPS mode.

2. Open all Activa Business areas.  Supported Business Areas include:

� Reporting Entities

� Cost Objects

� Materials

� Activities

3. Select all the business areas and export them.  To export, choose the menu 
option File --> Export. Enter the export filename when prompted, then choose 
Save.

4. Log into ABM 11i discoverer administration edition in APPS mode

5. Enter the EUL database userid and password to connect to the database.

Note: Before you upgrade any existing ABM Analyzer 
workbooks, you must first install ABM Release 11i and ABM 
Analyzer Release 11i.

Note: Use the EUL userid and password that you used to import 
ABM 11i Business areas (i.e., the userid and password that you 
passed to the script abminst.bat).
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6. From the menu choose File > Import.

7. Enter the file name from step 3, then choose OK.

8. Choose Tools > Security from the menu and grant access to ABM Manager     
responsibility for all the imported Business Areas.

Remove ABMBV and ACTIVA from the "selected users/roles" section. Make 
sure "Allow Administration" check box is checked for ABM Manager.

9. Generate tagset views.  Please refer to ABM analyzer user's guide for 
instructions on generating tagset views.

10. Log into Discoverer Administration edition as Applications user.  For example:

userid = vision:ABM Manager
passwd = vision
DB Connect string = oracle

Select all the folders in each business areas (Press and hold the Control key to 
select multiple folders).  Open the folder properties (right mouse button, then 
select Properties).  In the Properties window change the owner to Oracle 
Applications APPS schema name.

11. From the menu select File > Refresh, which will open the Refresh wizard.  Select 
the On-Line option and choose finish.  This option will list all differences 
between the EUL object and it's corresponding database object.

If the list contains only the following invalid items, then choose OK to remove 
them:

� sequence_number,

� account_reference, 

� statistic_reference

12. From the menu Select View > Validate Folders.  This will validate all the folders 
and display any errors next to the folder name.  Errors include things like 
invalid table or column names. 

Please contact Oracle Support if any seeded folders are invalid. Note that any 
errors caused by customizations must be resolved by you.  Oracle does not 
provide support for any customizations.

13. Log into the Activa 3.0 database using Discoverer User Edition. Open all 
existing Activa 3.0 workbooks and save them to your local hard drive.
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14. Log in to the ABM 11i database in Applications mode, using Discoverer User 
Edition. Open all of the Activa 3.0 workbooks that you saved to your local hard 
drive in step 13.

An alert will appear asking if you want to open the workbook in the current 
database account. Choose OK without changing the default selection.

15.  Save the workbook to database.

16. Grant workbook access to the ABM Manager responsibility.  Optionally, you 
can grant access to other responsibilities.

To Grant access, choose Manage Workbooks >Sharing from the File menu, the 
select the Workbooks > Users tab.  Select the workbook from the poplist. Grant 
access by moving the responsibility (ABM Manager) from the Available area to 
the Shared area.  Follow the same steps to grant access to other responsibilities.

17. You have to add your workbooks to Self-Service Menu to access from Self 
Service.  The workbooks can also be accessed from ABM Application by 
choosing the ABM Analyzer option.

18. Adding workbooks to the menu involves two steps:

� Create a function to invoke Workbook

� Add the function to the Menu

To create a function:

a. Login to Oracle Applications and choose "Application developer" 
responsibility

b. Navigate to Application --> Function

c. Enter the values for Function and User Function Name

d. For "Type" always enter WWW

e. Select the Web HTML tab. In the HTML call field enter:

OracleOasis.RunDiscoverer

f. Select the Form tab.  In the parameters field enter:

workbook=<your workbook name>

Note: To log in, use an Applications userid:responsibility and 
password.
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To add the function to the menu:

a. In the Application developer responsibility navigate to Application > 
Menu.

b. Query the menu that needs to be modified.

c. Add the function you created in the previous step to the menu.

Reference Material:
The following publications provide additional information that you may find useful 
when upgrading your existing ABM Analyzer workbooks:

ABM Analyzer User's Guide, Release 11i

Oracle Discoverer 3.1 Administration Guide and Release Notes

Oracle Discoverer 3.1 User's Guide

Launching ABM Analyzer from Self-Service Web Applications
Once you’ve installed and configured all components, you are ready to launch ABM 
Analyzer through Self-Service Web Applications. 

◗◗To launch ABM Analyzer through SSWA: 

1. Check to confirm that your PC has Oracle JInitiator installed.  Go to Start > 
Programs > JInitiator Control Panel.  Make the following selections on the Basic 
tabbed region, then choose Apply:

Show Java Console:  Deselect if selected

Enable JInitiator:  Select

Network Access:  Unrestricted

Note: Look at workbook functions created for ABM 11i by 
querying functions starting with ABM.  This info should help you 
in creating new workbooks functions.

For more information about creating functions, refer to Oracle 
Applications Application Object Library User Guide, Release 11i.
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Java Runtime Parameters:  -dx100m -dcache.size=20M

2. Point your browser to the Self-Service URL (check with your system 
administrator to confirm this URL):

http://ap906sun.us.oracle.com:1500/OA_HTML/US/ICINDEX.htm

3. Enter your username and password to log in.

4. Choose the ABM Manager link. 

5. Choose any workbook link under the Workbooks area of your screen.

Note: Your version of JInitiator should be the same version you 
use in your Oracle Applications Release 11i environment.
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5
Installing SEM Exchange

This chapter describes the installation process for SEM Exchange 11i.

Prerequisites
❏ Install and configure Oracle Applications Release 11i with General Ledger fully 

implemented.

❏ Install and configure Oracle ABM (Activity-Based Management) Release 11i.

Apply the SEM Exchange Server Patch
This section provides the procedures required to install SEM Exchange with Oracle 
Applications Release 11i.

This procedure creates the required SEM Exchange database objects, packages, seed 
data, and reports - within the Oracle Applications Release 11i environment.

Note: This installation procedure explains how to install SEM 
Exchange for an Oracle Applications Release 11i environment.  This 
section also describes how to apply patches to a Release 11.0 or 10.7 
NCA installation to enable the use of SEM Exchange in those 
environments with ABM Release 11i.

Note: The AD Administration (ADADMIN) and AutoPatch 
(ADPATCH) utilities are used throughout the installation 
procedures. For information about these utilities, see: Maintaining 
Oracle Applications, Release 11i .
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1. Log on to your Release 11i environment using the Oracle Applications owner 
account.

2. Choose the patch directory.

3. Use ADPATCH to install the patch driver c1550940.drv. This driver needs to be 
applied on all servers in your Release 11i environment.

4. Install the SEM Exchange server patch d1550940.drv using ADPATCH. This 
patch creates the database objects, packages, and seed data. This driver must be 
applied to the administration server only.

5. Install the SEM Exchange server patch g1550940.drv using ADPATCH. This 
patch regenerates the reports and forms. This driver must be applied to all 
Forms servers, Web servers, administration servers, and concurrent processing 
servers.

6. Restart the concurrent manager.  See: Server Processes, Maintaining Oracle 
Applications, Release 11i.

7. On the administration server, use ADADMIN to re-generate the message files 
by choosing the Maintain Application Files Menu option, and the Generate 
Message Files suboption.

8. Shut down and restart your Forms servers. See: Installing Oracle Applications, 
Release 11i for your platform.

Assign Responsibility
You must assign the Oracle Applications responsibility SEM Exchange Manager to 
the appropriate users before they can use SEM Exchange.

See Also:

Managing Oracle Applications Security
     Oracle Applications System Administrator’s Guide

Verify Installation
This section provides procedures to verify proper installation of the Oracle SEM 
Exchange forms and concurrent programs.

◗◗ To verify Oracle SEM Exchange Forms:
1. Use a browser to start Oracle Applications, and connect using the SEM 

Exchange Manager Responsibility (you may have to set up a user account first).
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2. Open each of the following forms:

� Setup Master Lists

� Segment Mappings

� Rule Sets

� Preview Collections

Each of the forms opens a separate window; close the window and return to the 
SEM Exchange Navigation Menu.

◗◗ To verify Oracle SEM Exchange concurrent programs:
1. From the SEM Exchange Navigation Menu, choose Other > Report > Run, 

which opens the Submit Requests window.

2. Use the popist in the Name field to display the five concurrent programs; close 
the window and exit Oracle Applications. 

Using Earlier Versions of SEM Exchange and Oracle General Ledger 
with ABM Release 11i 

Required Software Components:
❏ Sem Exchange 11.0/10.7 NCA

❏ ABM 11i

❏ Oracle Applications Release 11.0 with the 11.0.3 (or later) maintainence pack 
applied and GL fully installed

OR (for 10.7 customers)

Oracle Applications Release 10.7 NCA, with GL patchset A applied.

Installation Procedures:
❏ Install ABM 11i

❏ Apply SEM Exchange server patch I to your 11.0 or 10.7 NCA instance

❏ Create database link between SEM Exchange 11.0/10.7 database and ABM 11i 
database instances.

❏ Apply SEM Exchange server patch II to your 11.0 or 10.7 NCA instance
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◗◗ To Install ABM Release 11i:
❏ See earlier chapters of this installation guide.

◗◗ To apply SEM Exchange server patch I:
❏ Use ADPATCH to install the patch driver c1248059.drv.  Make sure you have 

the patch for your version of Oracle Applications.

◗◗ To create a database link between SEM Exchange 11.0/10.7
database and ABM Release 11i database instances:
1. Logon to Oracle Applications Release 11.0/10.7 database instance via SQL*Plus 

using Oracle Applications owner account(APPS)

2. Run the following script from the SQL> prompt:

@$EAA_TOP/patch/110/sql/eaalnks1.sql <db link name> <ABM 11i un_apps>           
<ABM 11i pw_apps> <ABM 11i ORACLE_SID>

For example:

SQL>@$EAA_TOP/patch/110/sql/eaalnks1.sql semx110_abm11i apps apps abm11idb

For 10.7:

@$EAA_TOP/patchsc/107/sql/eaalnks1.sql <db link name> 
<ABM 11i un_apps> <ABM 11i pw_apps> <ABM 11i ORACLE_SID>

For example:

SQL>@$EAA_TOP/patchsc/107/sql/eaalnks1.sql semx107_abm11i apps apps abm11idb

3. Check eaalnks1.log for any errors in your current directory.

4. Verify database link creation by reviewing the contents of the user_db_links 
table.

◗◗ To apply SEM Exchange server patch II:
1. Apply patch driver d1248059.drv using ADPATCH, this driver will upgrade 

seeddata and SEM Exchange Data Model.

2. Install SEM Exchange server patch g1248059.drv using ADPATCH. This will 
regenerate the forms/reports.
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A
Migrating Data From Activa 3.x

If you are currently running a version of Activa 3.x, you will need to migrate your 
data from the existing database to the new ABM Release 11i format.  The following 
section describes how to perform this migration.

Prerequisites
� ABM 11i must be installed as part of an Oracle Applications 11i instance.

� Migration from an Activa 3.x database to an 11i database must use a clean ABM 
11i schema.  If data exists other than the pre-installed seed data, it must be 
removed.

� To purge existing ABM user data from an Applications 11i Database:

1. Disable foreign key constraints.

– Log onto the database as abm, then run the ABMFKCON.sql script to 
remove the foreign key constraints.

Usage:

$ sqlplus abm/<abm_schema_password>@<ABM11i_db_SID>
sql> @ABMFKCON.sql abm <abm_schema_password>
sql> Exit

2. Purge existing data.

Note: All of the scripts mentioned below are located in $ABM_
TOP/patch/115/sql in your environment.
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– Log onto SQL*Plus using the APPS user ID, then run abmprgdt.sql to 
delete any user data that has been created in the database.

Usage:

$ sqlplus apps/<apps_schema_password>@<ABM11i_db_SID>
sql>@abmprgdt.sql
sql>Exit

3. Reapply driver d1588595.drv to recreate ABM seed data.

– Use the ADPATCH utility to apply the d1588595.drv to your ABM 11i 
database to recreate the seed data.

4. Recompile the APPS schema using the ADADMIN utility.

� Data migration is only supported from an Activa 3.x database to 11i.  If you are 
running an earlier version of Activa, you must first upgrade to Activa 3.x

� Make sure that a TNSNAMES entry exists for the Activa 3.x database that you 
are migrating, in relation to your Applications 11i instance.

Migration Process

Step 1  — Create a DB Link from your Activa 3.02 database to the Applications 
11i database and apply stored procedures to run the migration.
Run the script abmlnksy.sql against the APPS schema of your 11i database. This 
script will create a DB Link from the APPS Schema of the 11i database to the Activa 
database.  It also creates any necessary synoynyms for Activa Activa 3.x objects in 
the ABM 11i database. 

Usage: 

$ sqlplus apps/<apps_password>@<ABM11i_db_SID> 

SQL> @abmlnksy.sql  <ActivaActiva 3.x_username>  <ActivaActiva 3.x_password>  
<ActivaActiva 3.x SID>

Run the following two scripts, using SQL*Plus, to apply the stored procedures that 
perform the migration process:

SQL> @ABMUMAPB.pls  
SQL> @ABMUPGRB.pls  
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Step 2  — Disable Foreign Key Constraints in ABM Schema
1. Run the script abmfkcon.sql against the Apps schema of your 11i database.  

This will disable all foreign key contrainsts.

Usage: 

$ sqlplus abm/<schema_password>@<ABM11i_db_SID>  
SQL> @ABMFKCON.sql  abm <abm_schema_password> 

2. Review the abmfkcon.log file for any errors. 

Step 3  — Run the Data Migration Concurrrent Program.
1. Log onto Oracle Applications and select the ABM Supervisor responsibility.

2. Navigate to Requests, then choose Run.

3. On the next window, choose Single Request.

4. From the list of concurrent programs, select ABM:Migrate Data from Activa 
Activa 3.x, then choose Ok.

5. On the parameters window, you will need to enter values for the following 
parameters:

� Model Name (Required):  This is a list of values that displays all models in 
the source Activa 3.x database.  Select the model that you would like to 
migrate.

� Data Set Effective Date (Optional):  All data sets that are after this date 
will be selected for migration.  If you select 01-JAN-1995, then all datasets 
after that date will be migrated.  Any data sets prior to that date will not be 
migrated.  If you don’t select a date, all data sets will be migrated.

� Default Data Set Name (Required):  This is the data set that will contain 
consumption quantities after the migration is performed.  (In Activa 3.x, 
consumption quantities were not stored in a data set.)  You will be provided 
a list of values for all of the existing data sets in your Actva 3.02 database.

� Default Activity Hierarchy ID (Required):  Since multiple activity 
hierarchies are supported in 11i, you must specify a name for the existing 
hierarchy structure in your Activa 3.x database.  For this entry, you just type 
in a value into the text box.
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Step 4  — Enable the Foreign Key Constraints in the ABM Schema
1. Run the abmfken.sql  script against the Apps schema of your 11i database.  This 

will enable all foreign key constraints.

Usage: 

$ sqlplus abm/<schema_password>@<ABM11i_db_SID> 
SQL> @ABMFKEN.sql  abm <abm_schema_password> 

2. Review the abmfken.log file for any errors. 

If the concurrent program errors out, the exception will be logged in the ABM_
UPGRADE_LOGS table. Query on the table where the STATUS='EXCEPTION'. Fix 
the issue and run the migration again.  Only when the concurrent request completes 
successfully is migration for the particular model complete! 

Notes
� Navigation Procedures from Activa 3.x are not migrated.  You will need to enter 

any navigation procedures again in ABM 11i.

� Security is migrated, but ABM 11i provides much greater granularity.   See: 
ABM User Guide for details.

� Mapping formulas from Activa 3.x are transformed into a mapping calculation 
with parameters and source and targets.  Specific conversion rules are as 
follows:

� The mapping calculation parameter requires a rate and distribution data 
set.  These values are defaulted from the first rate and distribution data set 
found from an individual mapping rule.

� Data set offsets found at the mapping rule level are not migrated.  (In ABM 
11i, offsets at the individual rule level are not supported.)

� In the case where cross model references exist for a bill or department hierarchy, 
it is required that all models using cross references be migrated. Only then 
should the foreign key constraints be applied.  If foreign key constraints are 
applied after migration of a single model, it will result in a situation where 
referential integrity constraints are not being enforced.  It is important that  
models be migrated sequentially, keeping in mind any dependencies. 

� We recommended that you run calculations in Activa before you upgrade your 
data to ABM 11i. 

� Remember:  In Activa 3.02, the "Consumption Quantity PDS" parameter for the 
"Cost Object Unit Cost" calculation was optional.  This parameter is now 
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required for ABM 11i and is NOT migrated. In ABM 11i, you MUST enter this 
parameter before running any Cost Object Unit Cost Calculations for the first 
time.

� SQL Scripts required for the migration procedure include:

abmprgdt.sql

abmlnksy.sql

ABMFKCON.sql

ABMFKEN.sql
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