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Preface

Welcome to the Oracle Customer Relationship Management, Release 11i, suite of 
applications.

This Implementation Guide provides information and instructions to help you work 
effectively with Oracle Marketing Online.

This preface explains how this guide is organized and introduces other sources of 
information that may be helpful to you.

Structure
This guide is optimized for online help. It is written in short, self-contained, 
task-oriented topics linked together with hyperlinks. Using this document in 
printed form does not permit you to follow the hyperlinks between topics.

Documentation Accessibility 
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle Corporation is actively engaged with other 
market-leading technology vendors to address technical obstacles so that our 
documentation can be accessible to all of our customers. For additional information, 
visit the Oracle Accessibility Program web site at 
http://www.oracle.com/accessibility/.
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Intended Audience
This Implementing Guide is to be used by experienced system administrators and 
Oracle implementation consultants who understand Oracle ERP applications only. 

Related Documentation and Resources
The following documents are useful for implementing Oracle Marketing Online:

Oracle Marketing Online Concepts & Procedures 11i
This guide provides a basic understanding of the concepts of Oracle Marketing 
Online and the procedures for using the application. 

Oracle Applications Concepts
This guide provides an introduction to the concepts, features, technology stack, 
architecture, and terminology for Oracle Applications Release 11i. This guide 
introduces the concepts behind and major issues for applications-wide features such 
as Business Intelligence (BIS), languages, character sets, and self-service 
applications. It also describes Forms-based and HTML-based products. 

Oracle Applications System Administrator’s Guide
This guide provides planning and reference information for the Oracle Applications 
System Administrator. It contains information on how to define security, customize 
menus and online help, and manage processing. It also includes information 
relevant to integrating Oracle Marketing Online with Oracle Web Discoverer. 

Oracle Pricing User’s Guide
Implementers will need this guide to set up pricing features of the Oracle Marketing 
Online.

Oracle System Administrator’s Guide
The Implementation Appendix of this guide gives valuable information on 
implementing Oracle applications.

Note: You should be an experienced system administrator and 
have a good understanding of Oracle ERP applications before 
continuing with the procedures in this Implementation Guide.
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Implementing CRM Applications Release 11i
This guide outlines the steps required for implementing the Oracle Marketing 
Encyclopedia System. 

CRM Foundation Implementation Guide
This guide outlines the steps required to implement the foundation components of 
the CRM suite of applications.

Oracle Inventory User’s Guide
This guide outlines the implementation steps required to set up Oracle Inventory.

Discoverer 3i Installation & Administration Guide Release 3.3 for the 
Web 
This guide outlines the implementation steps for Oracle Web Discoverer.

BIS11i Implementation Guide 
This guide outlines the steps required to create the End User Layer (EUL) and 
import EUL Export File (EEX) for Oracle Web Discoverer. 
                                                                               ix
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Major Implementation Steps
Implementing Oracle Marketing Online

The implementation group of topics explains how to set up and customize Oracle 
Marketing Online.

You can customize Oracle Marketing Online by setting up system profile options, 
which control the overall behavior of the product, and by setting up lists of values 
(LOVs) and drop-down lists for individual fields within the product. 

The choices users see in the LOVs and drop-down lists come from two sources:

■ Lookups you set while logged in to the Oracle Forms interface under the Oracle 
Marketing Administrator responsibility.

■ Setups you perform in the Administration tab of Oracle Marketing Online.

For this reason, you must log into both Oracle Applications under the Oracle 
Marketing Administrator responsibility (this is the Forms-based interface) and the 
Oracle Marketing Online application (HTML interface).

Major Implementation Steps
Below are the major steps to complete an Oracle Marketing Online implementation. 
Use this procedure to plan out your implementation. Each step indicates whether it 
is required or not. Follow links to more detailed procedures. 

Prerequisites
Complete installation of the CRM suite as described in:

■ Oracle System Administrator’s Guide, Implementation Appendix

■ Implementing CRM Applications Release 11i, Marketing Applications

Steps
1. Set up an implementation user. (Required)

2. If you are implementing a new installation of Oracle Marketing Online in an 
environment where Oracle ERP applications are not implemented, then you 
must set up basic ERP functions before implementing the application itself. 
(Required)
Implementing Oracle Marketing Online 1



Major Implementation Steps
3. Log into Oracle Applications under the Oracle Marketing Administrator 
responsibility (this is the Forms-based interface). (Required)

4. Log into the Oracle Marketing Online application (this is an HTML interface 
accessed through your browser). (Required)

Throughout the implementation you will be switching between the 
Forms-based Oracle Marketing Administration application, which you use to 
set up system profiles and lookups, and the HTML-based Oracle Marketing 
Online application itself, where most of the setup is done in the Administration 
tab.

5. Set up CRM foundation modules. (Required)

6. Create Oracle Marketing Online users. These users are the owners of different 
objects in the application. Objects include events, collateral, and campaigns.

7. Set Oracle Marketing Online lookups. (Required)

8. Set up status classifications. These are the drop-down lists that can be used to 
classify most Oracle Marketing Online objects, including campaigns, events, 
and deliverables. (Required)

9. Create category and subcategory classifications for campaigns, deliverables, 
events, budgets, metrics, and costs. (Optional)

10. Enable the budget tab. (Required)

11. Set up the campaign tab. (Required)

12. Set up metrics and costs for your campaigns and events. (Required)

13. Create venues for your events. (Required)

14. Set up the data fields to restrict the number of columns available for list 
generation. (Optional)

15. Set up deduplication rules. (Required)

16. Set up word replacement rules. These are lists of similar words used to identify 
duplicate records in lists. (Required)

17. Set up geographical regions. (Optional)

18. Map your customer model. This step requires consulting help. (Optional)

19. Set up system profile options. (Required)

20. Implement Oracle Web Discoverer. (Required)

21. Set up news and stock quotes for user’s home pages. (Optional)
2 Oracle Marketing Online Implementation Guide



Setting Up ERP Applications for New Installations
Setting Up the Implementation User
Use this procedure to set yourself up as a user for the implementation.

Prerequisites
None

Steps
1. Log in as Sysadmin.

2. Navigate to Security > User >Define.

3. Create a user. (For example: <IMPLEMENT>)

4. Assign the following responsibilities to the user: 

■ General Ledger Super User 

■ US HRMS Manager 

■ Inventory 

■ CRM Administration 

■ Oracle Marketing Administration 

■ Oracle Marketing Super User (Self Service) 

■ Preferences (Self Service) 

■ System Administrator

5. Log out and log in as <IMPLEMENT>. 

6. Change your password. 

Setting Up ERP Applications for New Installations
Use this procedure to set up ERP applications for use with Oracle Marketing Online 
in new installations. This procedure covers only steps required to make ERP 
applications work with Oracle Marketing Online, not the steps required to 
implement those applications.

Steps
1. Set up Oracle General Ledger. (Required)

2. Set up Oracle Human Resources. (Required)
Implementing Oracle Marketing Online 3



Implementing Oracle General Ledger
3. Set up Oracle Inventory. (Required)

4. Set up Advanced Pricing following the instructions specified in Oracle Pricing 
User’s Guide. (Required)

Implementing Oracle General Ledger

Prerequisites
Knowledge of setting up Key Flexfields is a must. 

Steps
1. Log in as the <IMPLEMENT> user. 

2. Choose the General Ledger responsibility.

3. Set up accounting calendar types (Setup > Financials > Calendars > Types). 

4. Set up the accounting calendar (Setup > Financials > Calendar >Accounting) 

5. Set up currencies (Setup > Currencies > Define) that are needed for your 
implementation.

6. Set up exchange rates. (Setup > Currencies > Rates > Daily)

7. Set up accounting flexfields (Setup > Financials > Flexfields > Key > 
Segments). 

Make sure the concurrent process for flexfield compilation is complete before 
proceeding further. 

8. Define a set of books (Setup > Financial > Books > Define).

9. Use SqlPlus to check your Set of Books (SOB) under table GL_SETS_OF_
BOOKS

Implementing Oracle Human Resources

Prerequisites
You must complete your implementation of Oracle General Ledger.

Steps
1. Switch Responsibility to US HRMS Manager.
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Implementing Oracle Human Resources
2. Define Org Types (Other Definitions > Lookup Tables). Org Types can be 
Business Group, Department, HQ, or any other types suited to your business 
needs. 

3. Define locations (Work Structures > Location). These are used to set up 
organizations in the next step.

4. Define organizations (Work Structures > Organization > Description). In the 
Organization Classifications region, assign business groups. 

5. Use SqlPlus to check your work and make a note of your ORGANIZATION_ID 
and BUSINESS_GROUP_ID from table HR_ALL_ORGANIZATION_UNITS.

6. Switch responsibility to System Administrator.

7. Set the site level value for profile option HR: Business Group to one of the new 
business groups defined above. 

8. Set the responsibility-level (US HRMS Manager) value for profile option HR: 
Business Group to one of the new business groups defined above. 

9. Set the site-level value for profile option HR: Security Profile to one of the new 
business groups defined above. 

10. Set the responsibility-level (US HRMS Manager) value for profile option HR: 
Security Profile to one of the new business groups defined above. 

11. Switch responsibility to US HRMS Manager.

12. Define Legal Entity (Workstructure > Organization >Description): 

a. Associate the GRE/Legal Entity classification with your organization and 
continue with additional setups as needed. 

b. Enter the set of books. 

13. Double check your work:

a.  Under Help > Diagnostics, examine for block HOU1 and field BUSINESS_
GROUP_ID.

b. Verify the value of BUSINESS_GROUP_ID for block $PROFILES$ and field 
PER_BUSINESS_GROUP_ID,

Note:  A single Organization can act as a business group, a legal 
entity and an operating unit. Please be very clear before starting 
this setup.
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Implementing Oracle Human Resources
c.  Verify the value of BUSINESS_GROUP_ID. 

14. Define your operating unit (Workstructure > Organization >Description) 

a. Associate the Operating Unit classification with your organization and 
continue with additional setups needed. 

b. Enter the legal entity. 

c. Switch to the Sysadmin responsibility.

d. Change the site level profile option for MO: Operating Unit to the operating 
unit you defined.

15. Switch to the HR responsibility.

16. Define the HR Organization (Workstructure > Organization > Description) 

a. Associate the HR Organization classification with your organization. 

17. Define Inventory Organization (Workstructure > Organization > Description) 

a. Associate the Inventory Organization classification.

b. Click Others. 

c. In Accounting Information, enter the legal entity, the set of books, and the 
operating unit created earlier. 

d. Use SqlPlus to double-check data in tables HR_ALL_ORGANIZATION_
UNITS, HR_ORGANIZATION_INFORMATION, HR_LEGAL_ENTITIES, 
and HR_OPERATING_UNITS.

18. If you wish to enable multi-organizational features for new installations, then 
run the Adadmin concurrent program to enable Multi-Org at site level. 
Adadmin will pick the MO: Operating Unit profile value set at the site level. 

19. If you are implementing a new installation you must create employees:

a. Define the employee. (People > Enter and Maintain)

b. Define the manager of the employee by clicking Assignment. This step also 
assigns the employee to an organization. The manager’s organization must 
be one of the HR business groups you defined previously. 
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Implementing Inventory
20. Set up a Business Unit: 

a. Navigate to US HR MANAGER > Other Definitions > Look Up Tables. 

b. In the Look Up Tables form, search for and set up values for ORG_TYPE.

c. In the CODE field for ORG_TYPE, enter the value BU (This is the key). 

d. In the meaning field enter the value Business Unit and a free-form 
description. 

e. As an option, you may also define Company with the code COMP and 
Department with the code DEPT.

f. After you have defined your ORG_TYPE, you must describe your ORG_
TYPE. This is done by navigating to US HR MANAGER > Work Structures 
>Org > Description. 

g. Once you have opened the Description form, select the New tab. 

h. In the Name field, enter the business unit name. For example, Business 
Computer Organization. 

i. Using the Type list of values, select the Business Unit that you defined 
previously. 

j. Enter an address.

k. Save the record. 

Implementing Inventory
You must implement Oracle Inventory using this procedure if you wish to make 
marketing deliverables and events available through other CRM applications, 
including Oracle iStore and Oracle TeleSales.

Only the steps listed here are required to set up Oracle Marketing Online for use 
with Oracle Inventory. For more details on how to carry out these steps, please see 
Oracle Inventory User’s Guide. 

Note:  You must enter the manager for an employee for Oracle 
Marketing Online Workflow approval to work correctly. If you are 
creating a new business group instead of using the seeded business 
group, and if you receive the flexfield error (Code = GRP), then you 
must set up the People Group flexfield.
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Implementing Inventory
Prerequisites
You must complete your implementation of Oracle General Ledger.

Steps
1. Switch Responsibility to Inventory. 

2. Define the Item Flexfield (Setup > Flexfields > Key > Segments).

3. Make sure you compile each flexfield before preceding to the next step.

4. Define the Item Categories flexfield (Setup > Flexfields > Key > Segments). 

5. Define the Item Catalog Group flexfield (Setup > Flexfields > Key > 
Segments). 

6. Define the Stock Locator flexfield (Setup > Flexfields > Key > Segments).

7. Define Sales Orders flexfield (Setup > Flexfields > Key > Segments).

8. Define locations (Setup > Organization > Location).

9. Define the organization calendar (Setup > Organization > Calendar). 

10. Switch responsibility to System Administrator. 

11. Set the value at the responsibility level for Profile Option (HR:User Type) to HR 
User. 

12. Switch responsibility to Inventory.

13. Define the inventory organization (Setup > Organization > Organization).

14. Define the organization parameters (Setup > Organization > Organization 
Parameter). You can do this by clicking Others in the previous step).

15. Change the organization (Setup > Change Organization).

16. Define Unit of Measure Classes (Setup > Unit of Measure > Classes). 

17. Define the Unit of Measure (Setup > Unit of Measure > Unit of Measure). 

18. Define Unit of Measure conversions (Setup > Unit of Measure > Conversions).

19. Define category codes (Setup > Items > Categories > Category Codes).

20. Define category sets (Setup > Items > Categories > Category Sets). 

21. Define default category sets (Setup > Items > Categories > Default Category 
Sets).

22. Log in as a System Administrator.
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Setting Up CRM Foundation Modules
23. Set the following system profile options at the application level:

■       INV: Default Primary Unit of Measure

■       INV: Accounting Category Set

■       INV: Item Master Flexfield

■       INV: Product Family Item Template Name

24. Log in under the Marketing Administrator responsibility.

25. Set the following system profile options at the site level:

■ AMS: Item Validation Master Organization

■ AMS: Pricelist Header Name for Events. 

■ AMS: Should Call to Inventory Module. Set to Y.

■ AMS: Should Call to Pricing Module. Set to Y. 

Setting Up CRM Foundation Modules
1. You must set up the following modules in CRM Foundation:

■ Resource manager types: You must set up people and venues.

■ Resource manager roles: These are used in execution events for the Resource 
item on the side panel menu.

■ Note types: These are used in the Notes item on the side panel menu in the field 
Note Types.

■ Source to Note-Type Mapping: This determines which notes show up in the 
Note item on the side panel menu under campaigns, events, deliverables, 
messages, and all of the other Oracle Marketing Online objects.

■ Task types: These appear in the Task Type drop-down list. 

■ Task status: The values you add here determine what appears in the Status 
drop-down list for tasks.

■ Task priority: This determines the values that appear in the Priority drop-down 
list for tasks.

2. Import geographic hierarchies (Required):

a. Log into Oracle Applications under the CRM Administration responsiblity.

b. Run the concurrent program Load Geographic Hierarchies.
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Creating Oracle Marketing Online Users
Guidelines
Refer to the corresponding topic in CRM Foundation Implementation Guide. You can 
find relevant information on these topics:

Creating Oracle Marketing Online Users
Use this procedure to create users for Oracle Marketing Online. These are referred 
to in the application as owners. The procedure for creating users requires two 
additional steps beyond the usual procedure of setting up users in the Oracle 
Human Resources application

Prerequisites
None

Steps
1. Log on as the implementer.

2. Choose the responsibility: Human Resources.

3. Create an employee.

a. Navigate to People > Enter and Maintain.

b. Make sure Person Type is Employee. 

c. Enter all other required fields.

4. Switch to the System Administrator responsibility.

5. Create Oracle Marketing Online users:

a. Create a user. 

Information Sources for CRM Setups

CRM Foundation Module CRM Foundation Concepts Topic

Resource Manager Roles Understanding Resource Manager

Implementing Resource Manager

Note Types Implementing Notes 

Task Type

Task Status

Task Priority

Implementing Task Manager
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Setting Up Oracle Marketing Online Lookups
b. Assign Oracle Marketing Super User as the responsibility. 

c. Assign the newly created person in the Person field.

d. Open the System Profile Values window.

e.  Set up the following Profile options for the user:

*  ICX_LANGUAGE. Must be set to your language, for example, 
American English. 

*  JTF_PROFILE_DEFAULT_APPLICATION: Enter "530". This takes users 
directly to Oracle Marketing Online when they sign on. 

*  JTF_PROFILE_DEFAULT_RESPONSIBILITY: Enter "21706" 

6. Import the employee as a resource:

a. Switch to the CRM Administrator responsibility.

b. Navigate to Maintain Resource > Import Resources. 

c. In the Name field, enter the employee you have created.

d. Click Search. 

e. Click Create Resource. 

f. Click OK.

g. Click Save Resources. 

h. Click Details to verify the User ID you created.

Setting Up Oracle Marketing Online Lookups
Oracle Marketing Online includes lookups with three different levels of 
modification:

Note: The DEFAULT_APPLICATION and DEFAULT_
RESPONSIBILITY values are important because they determine the 
menu structure that is displayed when the user logs in. If you want 
your application menus to launch when the user logs in, then you 
must set the default application to your appID and default 
responsibility to the respID that maps to the menu structure.
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Setting Up Oracle Marketing Online Lookups
■ System: The implementer can only change the wording of the choices the user 
sees in the List of Values (LOV). No deletions or additions are allowed.

■ Extensible: The implementer can change both the wording of the LOV choices 
and add new choices for the user.

■ User: The implementer can change the lookup completely, deleting and adding 
LOV choices at will.

The lookup table in this section lists the three different types of lookups 
alphabetically. Included are their seeded values, navigation paths, and the names of 
the fields they affect.

About Navigation Paths in the Lookup Table
The navigation paths are included to give you an idea what areas of the application 
are affected by each lookup. Some lookups may affect a field that is found in 
multiple tabs. Not all of these are covered. Other lookups affect item on the side 
panel menus for campaigns and events and require you to navigate through a 
campaign or event you have created. You may not be able to navigate to that 
attribute through every campaign or event because which attributes appear 
depends on the way you implement custom setups.

Here is how to read the navigation paths in this table:

■ Campaign > any campaign > Schedule

Navigate to the Campaign tab, drill down on any campaign, select the Schedule 
item on the side panel menu.

■ Event > Execution Event > any execution event > Registration

Navigate to the Event tab, select the Execution Event subtab, drill down on any 
execution event, and select the Registration item on the side panel menu.

■ Campaign > Rollup or Execution Campaign > any campaign > Offers > lump-sum 
offer

Navigate to the Campaign tab, select either the Rollup Campaign or Execution 
Campaign subtab, drill down on any campaign that has a Offers attribute, select 
the Offers attribute, and create a lump-sum offer or examine the details of an 
existing one.
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Setting Up Oracle Marketing Online Lookups
Oracle Marketing Online Lookups 

Lookup Type Code Meaning Affected areas Field 
Access 
Level

AMS_ACCESS_TYPE GROUP Team Campaign > any 
campaign > Team

User/Role System

USER User

AMS_APPROVAL_TYPE BOTH Theme and Budget 
Approval

Administration > 
Custom Setup

Enables one or 
both of the 
following 
fields: Theme 
Approval, 
Budget 
Approval

System

BUDGET Budget

THEME Theme

AMS_ATTACHMENT_
TYPE

FILE

URL

File Attachment item 
on the side panel 
menu used in all 
tabs. 

 Type

(Classification 
for 
attachments)

Extensible

URL

AMS_BUDGET_
APPROVAL

APPROVED Approved Budget > any 
budget

Status

(of budget)

User

CLOSED Accounting Closed

NEW Planning

PENDING Pending Approval

REJECTED Rejected by Approver

AMS_BUDGET_TRANS_
TYPE

CREDIT Credit Budget > any 
budget

Specifies 
whether 
posting to 
General 
Ledger is a 
credit or a 
debit.

User

DEBIT Debit

AMS_CAMPAIGN_
PURPOSE

AWARENESS Awareness Campaign > any 
campaign > Purpose

 Purpose Extensible

LEAD Lead Generation

LEAD_
MATURATION

Lead Maturation

SALES_
READINESS

Sales Readiness
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Setting Up Oracle Marketing Online Lookups
AMS_CAMPAIGN_
SCHEDULE_STATUS

ACTIVE Active Campaign > any 
campaign > 
Schedule

 Status System

ARCHIVED Archived

BOOKED Booked

CANCELLED Cancelled

COMPLETED Completed

NEW New

AMS_CAMPAIGN_STATUS ACTIVE Active Campaign > any 
campaign 

Status System

ARCHIVED Archived

AVAILABLE Available

CANCELLED Cancelled

COMPLETED Completed

DENIED_BA Denied - Budget 
Approval

DENIED_TA Denied - Theme 
Approval

NEW New

ON_HOLD On-hold

PLANNING Planning

SUBMITTED_BA Submitted - Budget 
Approval

SUBMITTED_TA Submitted - Theme 
Approval

AMS_CHANNEL_RATING BAD Bad Administration > 
General > 
Marketing Medium

 Rating Extensible

EXCELLENT Excellent

GOOD Good

MODERATE Moderate

VGOOD Very Good

AMS_CHANNEL_TYPE EXTERNAL External Administration > 
General > 
Marketing Medium

 Type System

INTERNAL Internal

Oracle Marketing Online Lookups 

Lookup Type Code Meaning Affected areas Field 
Access 
Level
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Setting Up Oracle Marketing Online Lookups
AMS_DELIV_STATUS ARCHIVED Archived Campaign > any 
campaign > 
Deliverable> any 
deliverable

 Status 
(deliverable)

System

AVAILABLE Available

CANCELLED Cancelled

DENIED_BA Denied - Budget 
Approval

NEW New

SUBMITTED_BA Submitted - Budget 
Approval

SUPERCEDED Superseded

AMS_DELIVERY_MEDIA_
TYPE

ISEMINAR iSeminar Event > Execution 
Event > any 
execution event

Delivery 
Method

Extensible

ON_SITE On Site

WEB Web

AMS_EVENT_AGENDA_
STATUS

CONFIRMED Confirmed Event > Execution 
Event > any 
execution event > 
Agenda

 Status (event 
agenda)

System

UNCONFIRMED Unconfirmed

AMS_EVENT_
ATTENDANCE_FAILURE

AGENDA_
CHANGE

Agenda Change Event > Execution 
Event > any 
execution event > 
Registration > 
View Reason

(View Reason is a 
hyperlink on the 
Registration 
attribute)

Reason Extensible

DISASTER Natural Disaster

PERSONAL_
EMERGENCY

Personal Emergency

SCHEDULE_
CONFLICT

Schedule Conflict

SPEAKER_
CHANGE

Speaker Change

VENUE_
CHANGE

Venue Change

WORK_
EMERGENCY

Work Emergency

AMS_EVENT_CERT_
CREDIT_TYPE

GENERAL General Event > Execution 
Event > any 
execution event > 
Registration

Credit Type User

Oracle Marketing Online Lookups 

Lookup Type Code Meaning Affected areas Field 
Access 
Level
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AMS_EVENT_DAY FIVE 5 Event > any rollup 
or executive event > 
Event Agenda

Day System

FOUR 4

ONE 1

THREE 3

TWO 2

AMS_EVENT_PAYMENT_
STATUS

COMP Complimentary Event > Execution 
Event > any 
execution event > 
Registration

Marketing 
Event Payment 
Status

System

FREE Free

INVOICED Invoiced

PAID Paid

REFUNDED Refunded

AMS_EVENT_REG_
STATUS

CANCELLED Cancelled Event > Execution 
Event > any 
execution event > 
Registration

Status (event 
registration)

System

ENROLLED Enrolled

REGISTERED Registered

TARGETED Targeted

WAITLISTED Wait-listed

AMS_EVENT_RESOURCE_
TYPE

AMS_PEOPLE People Event > Execution 
or Rollup Event > 
any event > 
Resources

 Type System

AMS_VENUES Venues

AMS_EVENT_SPEAKER_
STATUS

BOOKED Booked Event > Execution 
Event > any 
execution event > 
Event Agenda

 Status

(speaker)

System

CANCELLED Cancelled

CONFIRMED Confirmed

SCHEDULED Scheduled

Oracle Marketing Online Lookups 
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Level
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AMS_EVENT_STATUS ACTIVE Active Event Marketing 
Event Status

System

ARCHIVED Archived

AVAILABLE Available

CANCELLED Cancelled

CLOSED Closed

DENIED_BA Denied Budget 
Approval

DENIED_TA Denied Theme 
Approval

NEW New

ON_HOLD On Hold

PLANNING Planning

SUBMITTED_BA Submitted Budget 
Approval

SUBMITTED_TA Submitted Theme 
Approval

AMS_EVENT_STREAM_
TYPE

A A Event > Rollup or 
Execution Event > 
any event > Event 
Agenda

Track Extensible

B B

C C

D D

Oracle Marketing Online Lookups 

Lookup Type Code Meaning Affected areas Field 
Access 
Level
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AMS_EVENT_TYPE BRIEFING Briefing Event  Type System

CONFERENCE Conference

EXHIBITION Exhibition

HOSPITALITY Hospitality

INTERNAL_
EVENT

Internal Event

LAUNCH Launch

SEMINAR Seminar

SPEAKING_
ENGAGEMENT

Speaking 
Engagement

SPONSORSHIP_
EVENT

Sponsorship

TRADE_SHOW Trade Show

WEB_SEMINAR Web Seminar

WORKSHOP Workshop

AMS_EVENT_WAITLIST_
ACTION

FIRST_COME_
FIRST

First Come First Event > Execution 
Event > any 
execution event > 
Registration

Rule

(for wait list)

System

AMS_FCAST_BASE_UOL_
SOURCE

For Trade 
Management 
marketing 
applications only. 
Affects budgets 
and claims.

AMS_FCAST_PERIOD_
VIEW

For Trade 
Management 
marketing 
applications only. 
Affects budgets 
and claims.

AMS_FCAST_UOM CS CS For Trade 
Management 
marketing 
applications only. 
Affects budgets 
and claims.

Extensible

EA EA

USD USD

Oracle Marketing Online Lookups 

Lookup Type Code Meaning Affected areas Field 
Access 
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AMS_FND_ALLOC_
ALLOC_BASIS

EVEN Even distribution Budget > 
Allocation’

The method of 
fund allocation to 
budgets

Extensible

AMS_FND_ALLOC_UOM USD USD Unit of measure for 
fund allocations

Extensible

AMS_FORMULA_TYPE ALLOCATION Allocation For Trade 
Management 
marketing 
applications only. 
Affects budgets 
and claims.

Extensible

HOLDBACK Hold Back

AMS_FUND_SOURCE CAMP Campaign Campaign > any 
campaign > Budget

Type System

EVEH Rollup Event

EVEO Execution Event

FUND Budget

AMS_IMPORT_STATUS ARCHIVED Archived Audience>Import  Status System

AVAILABLE Available

NEW New

PROCESSED Processed

PROCESSED-INC
OMPLETE

Processed - 
Incomplete

AMS_IMPORT_TYPE EVENT Event Audience > Import 
> any list

Type System

LEAD Lead

RESPONSE Response

SOURCE Rented List

AMS_IMP_DELIMITER_
TYPE

"Double Quotation Audience > Import 
> Create

Field Enclosed 
by

System

'Single Quotation

, Comma

; Semi-colon

FIXED Fixed Length

SPACE Space

TAB Tab

Oracle Marketing Online Lookups 

Lookup Type Code Meaning Affected areas Field 
Access 
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AMS_LIST_ROW_SELECT_
TYPE

NTH_RECORD Nth Record Audience > 
Audience > any list

Selection Size System

RANDOM Random

STANDARD Standard

AMS_LIST_SEARCH A All lists Audience > 
Audience

View System

U My lists

AMS_LIST_SELECT_
ACTION

EXCLUDE Exclude Audience > 
Audience > any list

Selection criteria 
for Action fields

Action System

INCLUDE Include

INTERSECT Intersect

AMS_LIST_SELECT_TYPE CELL Target Segment Audience > 
Audience > any list

Type System

DIWB WorkBook

LIST Existing List

AMS_LIST_STATUS ARCHIVED Archived Audience > 
Audience > any list

 Status System

AVAILABLE Available

LOCKED Locked

NEW New

PENDING Pending

RESERVED Reserved

AMS_LIST_TYPE TARGET Target Audience > 
Audience > any list

Type System

TEMPLATE Template

AMS_MARKET_ELIG_
TYPE

GEO_AREA Geographic Area Budget > any 
budget > Allocation

Trade 
Management 
marketing use 
only

System

MARKET_
SEGEMENT

Market Segment

TERRITORY Territory

Oracle Marketing Online Lookups 
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AMS_MEDIA_TYPE BROADCAST Advertising Administration > 
Activity

(affects all Activity 
Type fields in 
campaigns)

Activity Type System

DEAL Deal

DIRECT_
MARKETING

Direct Marketing

EVENTS Events

INTERNET iMarketing

IN_STORE In-store

PUBLIC_
RELATIONS

Press and Analyst 
Relations

TRADE_
PROMOTION

Trade Promotion

AMS_MESSAGE_TYPE BRAND Product Family Message Type Extensible

PRODUCT Product

VISION Vision

AMS_METRIC_ACCRUAL_
TYPE

FIXED Fixed For internal system 
use only. Does not 
affect UI

System

VARIABLE Variable

AMS_METRIC_VALUE_
TYPE

N Numeric Administration > 
General > Metrics

Return Value System

R Ratio

AMS_MKT_SEGMENT_
TYPE

CELL Target Segment Audience > 
Segment > Create

Type System

MARKET_
SEGMENT

Market Segment

AMS_OBJECT_USAGE_
TYPE

CREATED Created Campaign > 
Rollup or 
Execution 
Campaign > any 
campaign > 
Deliverable

 Usage System

USED_BY Used By

AMS_OFFER_LUMPSUM_
PAYMENT

ACCRUE Accrue Campaign > 
Rollup or 
Execution 
Campaign > any 
campaign > Offers > 
lump-sum offer

Payment Type

(in Lumpsum 
offers only)

Extensible

CHECK Issue Check

Oracle Marketing Online Lookups 
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AMS_OFFER_STATUS ACTIVE Active Campaign > any 
campaign > Offer

Status System

CLOSED Closed

DRAFT Draft

PENDING Pending

REJECTED Rejected

AMS_OFFER_TYPE ACCRUAL Accruals Campaign > any 
campaign > Offer

Type System

LUMPSUM Lump Sum

OFF_INVOICE Off Invoice

OID Promotional Goods

ORDER Order value

AMS_PRIORITY FAST_TRACK Fast Track Campaign > any 
campaign 

Priority Extensible

HIGH High

STANDARD Standard

LOW Low

MEDIUM Medium

VERY HIGH Very High

AMS_PRODUCT_LEVEL FAMILY Product Family Campaign > any 
campaign > 
Products 

Level System

PRODUCT Product

AMS_RESOURCE_STATUS BOOKED Booked Event > Execution 
Event > any event > 
Resources

 Status System

CONFIRMED Confirmed

AMS_TRIGGER_
FREQUENCY_TYPE

DAILY Daily Campaign > any 
campaign > Trigger 
> Setup

Frequency System

HOURLY Hourly

MONTHLY Monthly

NONE None

QUARTERLY Quarterly

WEEKLY Weekly

YEARLY Yearly

Oracle Marketing Online Lookups 
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AMS_TRIGGER_TYPE DATE Date Campaign > any 
campaign > Trigger

Comparison 
Type

System

METRIC_
METRIC

Metric to Metric

METRIC_VALUE Metric to Value

METRIC_
WORKBOOK

Metric to Workbook

AMS_VENUE_TYPE CONVENTION_
CENTER

Convention Center Administration > 
General > Venue

 Venue Type User

HOTEL Hotel

KIOSK_BOOTH Kiosk/Booth

OZF_FUND_REQUEST_
STATUS

APPROVED Approved Campaign > any 
campaign > Budget

 Status System

PENDING Pending Approval

REJECTED Rejected

OZF_FUND_STATUS ACTIVE Active Budget> Budgets > 
Create

 Status System

CLOSED Closed

DRAFT Draft

PENDING Pending Approval

OZF_FUND_TYPE FIXED Fixed Budget> Budgets > 
Create

Type System

FULLY 
ACCRUED

Fully Accrued

STATISTICAL Statistical

OZF_PAYMENT_METHOD ADJUSTMENT Adjustment Trade Management 
marketing use only. 
Affects budgets 
and claims.

System

CHECK Check

CREDIT_MEMO Credit Memo

DEBIT_MEMO Debit Memo

REJECT Reject

WRITE_OFF Write Off

OZF_UTILIZATION_TYPE ACCRUAL Accrual Trade Management 
marketing use only. 
Affects budgets 
and claims.

Utilization 
Type

System

ADJUSTMENT Adjustment

UTILIZED Utilized

Oracle Marketing Online Lookups 
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Setting Up Status Classifications
Use this procedure to set up the status classifications used to categorize objects 
ranging from deliverables to speakers. The statuses you set up appear in the Status 
drop-down lists in each object. 

You can use this procedure to set up status designations for the following objects:

■ List import

■ Campaign schedules

■ Campaigns

■ Deliverables

■ Marketing event agendas

■ Marketing event registration

■ Marketing event speakers

■ Marketing events

For example, you may want to classify deliverables as draft or approved, and 
speakers as contacted, confirmed, or cancelled.

Steps
1. Navigate to Administration > Setup > User Status.

2. In a blank record, use the Activity drop-down list to select the type of 
classification you wish to set up.

3. Use the System Status drop-down list select the status you want to map the 
classification to.

4. In User Status, enter the status.

5. If you wish to make this classification available only for a limited period of 
time, then enter a range of dates in the Start Date and End Date fields.

6. Click Update.

Creating and Editing Categories and Subcategories
Use this procedure to create both the Category and Subcategory drop-down lists 
used to classify campaigns, deliverables, events, budgets, metrics, and costs. The 
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Enabling the Budget Tab
only difference between creating a category and a subcategory is that you specify a 
parent for a subcategory.

Prerequisites
If you are creating a subcategory, then you must create the parent category first.

Steps
1. Navigate to Administration > Setup > Category.

2. If you wish to create new categories, then:

a. Click Create. 

The Create Category subtab appears.

b. Enter the name of the new category or subcategory. This name will appear 
in the Category or Subcategory drop-down list.

c. From the Created For drop-down list, select the object for which you are 
creating this category or subcategory. 

d. If you are creating a subcategory, then, in Parent Category, click Go and use 
the list of values to enter the parent category.

e. Leave Liability Account and Adjustment Account blank. These are used by 
Trade Management marketing implementations only.

f. Enter an optional description.

g. Make sure the Enabled check box is selected. Deselecting removes this 
category or subcategory from use.

h. Click Create.

3. If you wish to edit an existing category, then:

a. Click on the category link. 

The Create Details subtab appears.

b. Make your modifications.

c. Click Update.

Enabling the Budget Tab
Use this procedure to enable the budget tab.
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Prerequisites
None

Steps
1.  Log in to Oracle Applications under the Application Developer responsibility.

2. Navigate to Applications > Menu.

3. From the View menu, choose Find.

4. Find "Oracle Marketing Root Menu".

5. In the Navigator Prompt column, locate Budget.

6. In the Budget record, use the list of values to make the following entries:

a. For Submenu, enter OZF_BUDGET_SUBMENU.

b. For Function, enter OZF_BUDGET_OVERVIEW. 

7. Save the record.

8. Bounce your Apache Server.

Setting Up the Campaign Tab
Use this procedure to set up the Campaign tab.

Prerequisites
Log into Oracle Marketing Online. 

Steps
1. Set up the marketing mediums used to execute campaign activities. Please note 

that when a marketing medium is associated with an activity, it cannot be 
associated with another activity in the same time period. (Required)

2. Set up activities.(Required)

3. Create custom setups that will be used in campaigns and events. (Required)

Setting Up Geographical Regions
Use this procedure to set up geographical regions that are used to target campaigns. 
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Prerequisites
None

Steps
1. If you wish to change the names of geographical levels the user sees in the 

Level drop-down list, then: 

a. Navigate to Administration > Geography > Location Type.

b. For each level, you can modify the existing Location Name. The user sees 
the Location Name in the Campaign Geography attribute list of values 
(LOV). You cannot add any additional locations or modify the preset levels. 

c. Enter an optional description.

d. Click Update.

2. Navigate to Administration > Geography > Geographic Area.

3. Enter the geographical hierarchy for your campaigns:

a. Click Create. 

The Geographic Areas dialog appears.

b. Use the Parent list of values (LOV) to enter a parent region for the child 
region you are creating. For example, if your company is targeting 
campaigns by different counties, then you will enter a specific state as a 
parent.

The Type field is filled in automatically.

c. In the Child region, use the Type drop-down list to enter the type of area 
you are creating. In our example, county.

d. Enter a name and optional short name for the area.

e. Enter a start date. 

f. If you wish for this geographical area to expire, then enter an end date.

g. Click Update.

Setting Up Approval Rules
Use this procedure to set up default approval rules. Oracle Marketing Online uses 
this default for all approvals until you specify detailed approval rules. For example, 
if you define an approval process for campaigns, but have not yet defined a process 
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Setting Up Approval Rules
for events, the default approver will receive the approval notification for event 
related requests.

Note that the user initiating the approval process will always receive the ’FYI’ 
notification.

Prerequisites
None

Steps
1. Setup a Default Approval Role

a. Log into Oracle Application (Forms Interface).

b. Click CRM Resource Manager Responsibility.

c. Create Role Type using Setup > Role Types.

d. Add new code using block letters, as follows:

Code=AMSAPPR

(Meaning: Default Marketing Approver, Description: Default Marketing 
Approver, Enabled=Y)

e. Save the transaction. 

2. Create Role

a. Navigate to Setup > Roles.

b. Enter the following values:

Code: AMS_DEFAULT_APPROVER

Name: Default Marketing Approver Role

Type: Default Marketing Approver (This is the type created in step 1.)

Description: Default Marketing Approver Role

Manager=’Y’

Active=’Y’

c. Save the transaction.

3. Associate an existing Resource with above created Role.

a. Navigate to Maintain Resources > Resource.
28 Oracle Marketing Online Implementation Guide



Setting Up Data Fields for Lists
b. Select your resource for the role.

c. Click the Resource Detail button.

The system displays information on the chosen resource.

d. Click the Roles tab and enter the following values:

Role Type: Default Marketing Approver

Role: Default Marketing Approver Role

Manager=’Y’

e. Save the transaction.

4. Set Cut-off percentage for Approvals.

a. From the Form Interface at login, select System Administrator 
Responsibility.

b. Navigate to Profile > System.

c. Locate the profile:

AMS: Cut off percentage for Approvals.

d. Update the default value to 50 or 100% (depending on the business 
process.)

You have now completed the creation of the default role. For any other specific 
changes to approval rules, access the Approval Rules screen under the 
Administration > Setup tabs. 

Only users with Super User privileges can access the Approval Rules screen. For 
any custom menu created, use the function AMS_APPROVALS_VIEW.

Mapping Your Customer Model to Oracle Marketing Online
You can map your existing customer model to Oracle Marketing Online. Contact 
Oracle Consulting for further information.

Setting Up Data Fields for Lists
Use this procedure to determine which AMS_LIST_ENTRIES and AMS_IMPORT_
SOURCE_LINES table columns are available for list generation. Both tables contain 
256 user definable columns. By default, all columns are available. 
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Prerequisites
None

Steps
1. Navigate to Administration > List > Data Fields.

2. Use the View drop-down list to select a table.

3. Deselect the Active check box for any field you wish to disable.

4. Click Update.

Setting Up Deduplication Rules
Use this procedure to determine which field(s) (table columns) will be used for 
deduplication. The software uses the logical operator AND for deduping. This 
means that if you create a rule which uses multiple fields for deduping, then all of 
the fields have to match. 

Prerequisites
None

Steps
1. Navigate to Administration > List > Deduplication Rules

2. If you wish to create a new deduplication rule, then:

a. Enter the rule name in the empty text box in the Rule Name column.

b. Enter an optional description.

c. From the Type drop-down list, select what type of list this rule will apply 
to, Target or Import.

d. Click Update.

The new rule appears in the list.

3. Select the name of the rule you just created or you wish to edit.

The List Rule subtab appears.

4. If you wish to add a column that will be used for deduplication, then: 

a. Click Go in the Column Name field and use the list of values to enter the 
name of that column. 
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b. In Data Length, enter the number of characters to be matched. For example, 
if you specify 5 on a last name, then any two last names with the first five 
matching characters will be considered duplicates.

c. Click Update.

5. If you wish to remove a field from the rule, then: 

a. Select the Remove check box next to the rule you wish to remove.

b. Click Update.

Setting Up Word Replacement Rules
The Word replacement rules you enter using this procedure tell the application 
what words may be potential duplicates of each other. For example, a customer 
with the name of Robert Smith may be the same customer with the name of Bob 
Smith. Use this procedure to set up potential duplicate words for specific tables and 
columns.

Steps
1. Navigate to Administration > List > Word Replacement

The Create Word Replacement subtab appears.

2. In the Original Word field, enter the target word, for example, Bob.

3. In the Replacement Word field, enter the duplicate word, for example, Robert.

4. Click Update.

5. Click the Details link for the word you just entered.

The List Word Replace Fields region appears.

6. Use the Field Table Name drop-down list to select the table you wish to use for 
this entry.

7. Use the Field Column Name list of values to select the name of the column you 
wish to use.

8. Click Update.

9. If you wish to apply this entry to multiple columns, make additional entries in 
the Field Table Name and Field Column Name fields.
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Setting Oracle Marketing Online System Profile Options
You can set the following system profile options:

Oracle Marketing Online System Profile Options

PROFILE NAME PROFILE DESCRIPTION

AMS: Admin Group Defines Super Admin Group with super admin 
privileges. Members of this group can edit Marketing 
objects belonging to any user.

AMS_AUTO_REGISTER_FLAG If set to Yes, the profile automatically registers an 
individual on a wait list for an event when an enrollee 
cancels.         

Can be set at: Site, Application                                                                             

AMS_CALL_CENTER_
ENABLED

Setting this system profile option to Yes enables the 
transfer of data into Oracle Call Center. 

Can be set at: Site, Application                                         

AMS_CAMPAIGN_DEFAULT_
CALENDER

AMS: Marketing Calendar

Can be set at: Site

AMS_CONF_CODE_PREFIX This prefix is added to the generated confirmation code 
for event registrations. The code can be alphanumeric, 
for example, a company name.      

Can be set at: Site, Application                                                                         

AMS_COPY_EVH_TO_EVO Enables copying Rollup Event information to its 
Execution Events.

Can be set at: Site                                                                                                

AMS_CURR_CONVERSION_
TYPE

This profile is used to specify the Oracle General Ledger 
conversion type that is used for Oracle Marketing Online 
transactions. For example, the currency conversion rate 
can be determined by a corporate conversion rate or a 
daily spot rate. 

Can be set at: Site, Application             

AMS: Cut off percentage for 
Approvals

Defines the cutoff percentage before an object is allowed 
to go active

AMS: DATE FORMAT Defines Date format

AMS_DEFAULT_CURR_CODE Determines the currency used for price list creation.          

Can be set at: Site                                                                
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AMS:DEFAULT_TASK_RULE AMS: Default Task Rule

Can be set at: Application, Site             

AMS:DEFAULT_TIMEOUT AMS: Default Time Out Use For

Can be set at: Site             

AMS_HZ_DEDUPE_RULE Specifies which rule is used to control unwanted 
duplicates when customers are saved in the customer 
master table 
HZ_PARTIES.

Can be set at: Site, Application                                                                          

AMS_IMP_CTL_PATH Specifies the path to the SQL*Loader control file used for 
importing data. You must set this profile to run the 
AMSIPROC concurrent program. Set the path to be the 
same as the AMS_IMP_DATA_PATH to simplify your 
list import process.

Can be set at: Site

AMS_IMP_DATA_PATH Specifies the path for the data file to be imported. You 
must set this profile to run the AMSIPROC concurrent 
program.

Default = /amsdev/ams/11.5/bin/ 

Can be set at: Site

AMS_IMP_DEDUPE_RULES Specifies the rule the application follows to search for 
duplicates in the imported file itself. You must set this 
profile to run the AMSIPROC concurrent program.

Can be set at: Site, Application                                                                         

AMS_INV_API_CALLOUT AMS: Should Call to Inventory

Can be set at: Site

AMS_ITEM_ORGANIZATION_
ID

Determines the inventory organization (Master 
Organization) for the inventory items created for 
collateral and events in Oracle Marketing Online.

Can be set at: Site, Application                                                                            

AMS_LOWEST_
NOTIFICATION_LEVEL

AMS: Lowest importance level f

Can be set at: Site

AMS: Marketing Calendar Selects calendar to be displayed for periods

Oracle Marketing Online System Profile Options

PROFILE NAME PROFILE DESCRIPTION
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AMS_NEWS_PER_COMPANY Determines the number of news items to be displayed 
for each company listed on a user’s home page. Users set 
this profile using the Preferences tab in the application.

Can be set at: Site, Application               

AMS_NUM_BIN_ITEMS Determines the number of items to be displayed in each 
of the bins on the home page. Users can set this profile 
using the Preferences tab in the application.

Can be set at: Site, Application                  

AMS Numeric Format Defines numeric format

AMS_PRICELIST_HEADER_
NAME

All Events pricing will align under this price list header.

Can be set at: Site          

AMS_PROFILE_SEARCH_SET_
SIZE

For Future Use

AMS_QP_PRICING_CALLOUT AMS: Should Call to Pricing Mo

Can be set at: Site      

AMS: Should Call to Inventory 
Modules be Made?

If a delv is created and updated as inventoried item, it 
will be created in Oracle Inventory Scehma only if this 
profile is set to Y.

AMS: Should Call to Pricing 
Modules be Made?

If a delv is created and updated as an inventoried item, it 
will also create a price list header and price list line for 
this delv if the profile is set to Y. If a price list header 
already exists, it will only create aprice list line for the 
deliv.

AMS_SRCGEN_DATE_
PATTERN

AMS: Source Code Date Format

Can be set at: Site

AMS_SRCGEN_SEQUENCE_
LENGTH

AMS: Source Code Sequence Length

Can be set at: Site

AMS_SRCGEN_USER_CITY AMS: User country.

AMS_STOCK_SYMBOLS Determines which stock information displays on the 
home page. Enter the desired stock symbols. Users can 
set up this list using the Preferences tab in the 
application.

Can be set at: Site, Application                                           

Oracle Marketing Online System Profile Options

PROFILE NAME PROFILE DESCRIPTION
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Implementing Oracle Web Discoverer
Use this procedure to install and implement Oracle Web Discoverer.

AMS_SYSTEM_TIMEZONE_ID Enter the time zone for the system that runs system the 
Concurrent Manager. This profile option is required only 
for organizations working across multiple time zones.

Can be set at: Site              

AMS_TIME_FORMAT Controls the format in which time is displayed in Oracle 
Marketing Online.

Can be set at: Site, Application                         

AMS: Uom Area Devines lovs for area. Used in Venues.

AMS: Uom Length Devines lovs for length. Used in Venues.

AMS: Uom Quantity Defines lovs for quantity. Used in Venues.

AMS: Uom Time Devines lovs for time. Used in Events.

AMS_USER_DEFAULT_TEAM AMS: Default Team for User

Can be set at: Site, Application, Responsibility, User         

AMS_USER_TIMEZONE_ID User’s time zone. This profile option is required only for 
organizations working across multiple time zones.

Can be set at: Site, Application                        

AMV_PROFILE_DEFAULT_
TICKER

Can be set at: Site

AMV_PROFILES_NEWS_ITEMS Can be set at: Site, User

OZF_AP_SOURCE OZF: AP Source for Trade Management Marketing

Can be set at: Site

OZF_ARCM_BATCH_SOURCE OZF: Credit Memo Batch Source for Trade Management 
Marketing

Can be set at: Site

OZF_ARDM_BATCH_SOURCE OZF: Debit Memo Batch Source for Trade Management 
Marketing

Can be set at: Site

Oracle Marketing Online System Profile Options

PROFILE NAME PROFILE DESCRIPTION
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Implementing Oracle Web Discoverer
Prerequisites
None

Steps
1. Install Oracle Web Discoverer from your CD. This includes the product and the 

patch. Make sure that you use the Oracle installer Discoverer provides. Use 
default Oracle Home while installing.

2. Verify your work:

a. Set up TNSNAMES by using oracle 8i Net8 easy configuration from your 
Start > Programs > Oracle Windows NT.

b. Launch Discoverer Admin Edition by selecting Start > Programs > Oracle 
Discoverer 3.1 > Administration Edition. 

3. Install the Web Discoverer Server from your Discoverer 3i CD. Follow the 
installation guide Discoverer 3i Installation & Administration Guide Release 3.3 for 
the Web.

4. Make sure your Web server and browser are both supported by Oracle.

Oracle supported HTTP servers are:

■ Oracle Application Server 

■ Netscape Enterprise Server 

■ Apache Server 

■ MS Internet Information Server

Oracle Web Discoverer supported web browsers are:

■ IE 3.x with JInitiator 

■ IE 4.01 (4.72.3110.8 in the About box) and higher. 

■ IE 5.0

■ Netscape 3.0, 4.0X with Jinitiator 1.1.7

5. Make sure that the Locator (where your http server runs), Session, and 
Preferences components (where Oracle Web Discoverer server runs) must all be 
installed on the same subnet. You can ping them to get their IP address.

6. Make sure that the applet and HTML are accessible to the web server. Set up 
aliases in your web server configuration file if necessary. Test it by launching 
Oracle Web Discoverer welcome page provided in the documentation. If you 
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cannot launch the welcome page, your Oracle Web Discoverer installation has 
problems. Go back to your documentation and make sure you have followed 
the steps.

7. Make sure that the following parameters have been set up correctly in your 
preferences file (pref.txt) and apply the file:

■ Machine Ips = "web server machine IP address or name"

■ ShowUserTypeChoice 1

■ DefaultUserTypeIsApps 1

■ AppsGWYUID “APPLSYSPUB/PUB”

■ AppsFNDNUM “APPS”

8. Create the End User Layer (EUL) and import EUL Export File (EEX) and 
Workbooks according to the steps outlined in the BIS11i Implementation Guide.

9. Verify your work:

a. Launch your Discoverer Admin edition

b. Open the business area Market Online.

c. Open up Market Online to see its folders.

d. Make sure you grant the right privileges and responsibilities to your 
business area.

e. Make sure that you use the right EEX for importing. Oracle Marketing 
Online business area is in biseul.eex.

f. Do not forget to refresh the business areas, the last step in the guide.

g. When creating the EUL, you must run a list of database GRANTs required 
by the EUL owner according to the documentation. Please make sure the 
following grants are run:

* grant select on FND_APPLICATION to eul_us; 

* grant select on FND_RESPONSIBILITY_VL to eul_us; 

* grant select on FND_ORACLE_USERID to eul_us; 

* grant select on FND_DATA_GROUP_UNITS to eul_us; 

* grant select on FND_USER_RESP_GROUPS to eul_us; 

* grant select on FND_USER to eul_us; 
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* grant select on FND_PRODUCT_INSTALLATIONS to eul_us; 

* grant execute on FND_CLIENT_INFO to eul_us; 

* grant select on FND_SECURITY_GROUPS_VL to eul_us;

The last two grants (highlighted in bold) are missing from the 
documentation. You must run these two grants or you will not be able to 
see Marketing Online Business Area folders.

10. Make sure that your tnsname is set up with the correct service name. (You will 
receive an “could not find service name” error if this is not set correctly.) To set 
the tnsname: 

a. Run Oracle 8 easy configuration. 

b. To verify, run SqlPlus to see whether you can connect to the database. 

11. Create a directory. For example: C:\mydisco

12. Create a sub-directory named secure under it. For example: 
C:\mydisco\secure

13. In the secure directory, create a dbc file. A typical dbc file looks like:

TWO_TASK=<database name, ex: OMDB>
GWYUID=APPLSYSPUB/PUB
GUEST_USER_PWD=<An account on Oracle application, you can create one 
with none responsibilities, ex: guest/guest>
FNDNAM=apps 
APPS_Jdbc_DRIVER_TYPE=THIN
DB_HOST=<database host name, ex: ap030sun.us.oracle.com > 
DB_PORT=<database port, ex: 1521>

14. For internal, you can go to unix $FND_TOP/secure directory to find a dbc 
template. For dbc document, refer to Appendix part in the Oracle Applications 
System Administrator’s Guide. Without setting this correctly, you will receive a 
“no dbc file found” error later on.

15. After creating dbc file, set up FND_TOP environment to where your dbc file sits 
(For example: C:\mydisco). 

a. If you are running on Microsoft NT, then set this environment in Start > 
Settings > Control Panel > System. Make sure that you set up a system 
variable instead of a user variable. Reboot.

b. If you are using the Unix operating system, then set up using the setenv 
command. 
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16. Make sure that the following ARU # 311532, 313216 have been applied to your 
system. The latest OMO ARU (1383055) has these ARUs in it. 

17. Make sure the Form Function AMS_LAUNCH_DISCO is created in the Oracle 
applications instance that will use Discoverer. To check:

a. Log on as PHP. For example: VISION\VISION98 on DOM1151.

b. Choose the APPLICATION DEVELOPER responsibility, choose 
Application > Function

c. Query Function Name AMS_LAUNCH_DISCO for details.

d. If Form Function AMS_LAUNCH_DISCO is not set up, you can set it up by 
following instructions described in the following URL: 
http://www-apps.us.oracle.com/bis/development/discoverer/index.htm

Use the navigation tree at left to navigate to Configuration > SSWA 
Integration > Form Function

18. Set the following ICX profiles in Oracle Applications:
 

19. The Oracle Applications APPS_WEB_AGENT profile must be setup and valid. 
Go to Oracle Application to verify.

20. Make sure that The EUL_TRIGGER$POST_SAVE_DOCUMENT function be 
registered and valid. This will ensure that work book SQL will be saved to the 
AMS_DISCOVERER_SQL table:

a. Navigate to Discoverer Admin edition.

b. Select Tools > Register PL/SQL functions. 

ICX _PROFILE: ICX_DISCOVERER_LAUNCHER 

Description:       URL that points to the Web Discoverer Server

Example:           http://ap152wgs.us.oracle.com/webdis/html/engli
sh/welcome.htm?Connect=[APPS_SECURE]

ICX_PROFILE: ICX_DEFAULT_EUL

Description:        This in combination with the language code make up the EUL 
owner at run time.

Example:              EUL (not EUL_US)
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c. Register this function according as follows, either by using the import 
buttons or by manually typing them in. Make sure you enter these 
parameters in order:

Name: EUL_TRIGGER$POST_SAVE_DOCUMENT
Display Name: eul_trigger$post_save_document  (lower case)
Owner: APPS
Package: AMS_DISCOVERERSQL_PVT
Database Link: <Default Database>
Return Type: Number
Check “Available in User Edition” check box

For the Arguments tab

P_WORKBOOKOWNER
P_WORKBOOKNAME
P_WORKSHEETNAME
P_SEQUENCE
P_SQLSEGMENT

All data types are varchar except for P_SEQUENCE which has a data type 
of Number. 

d. All of the arguments are required, so select the Required check box. 

e. Click Validate to validate the function you just registered. 

f. Exit Discoverer Admin Edition and User Edition (if you have them 
running) to make sure the changes are committed.

21. Create Workbooks:

a. Launch Discoverer in one of two ways:

■ Using Discoverer User Edition (client/server version)

■ By clicking the hyperlink in the Oracle Marketing Online GUI

b. After you launch Oracle Web Discoverer, select Creating Workbooks and 
pick the Oracle Marketing Online Business area. 

You will see a list of folders in this business area. Select the folder of your 
choice, click + to expand it. 

c. Each folder has one mandatory identifier item and one “Include XXX 
details” item (usually these are the first two items in your tree). You must 
select these two items for your workbook. You can but need not select the 
rest of the items.
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d. Use the wizard to specify your conditions. You can see your selections by 
executing the workbook.

22. Save the Workbooks into the database (not your computer). This create the SQL 
statement of your newly created workbook and store that into a database table.

23. If you do not see a list of workbooks from Oracle Marketing Online workbook 
LOV window and you do see a list of workbooks stored in your database, then 
your registered function is not setup correctly. You can check the function using 
Oracle Web Discoverer Administration Edition or you can also log in with 
SqlPlus to check whether there are any rows in the AMS_DISCOVERER_SQL 
table.

24. If you wish to share your Workbook with other users, then:

a. In Oracle Web Discoverer, choose File > Manage Workbooks > Sharing.

b. In Workbook > User tab, select the workbook you want to share.

c. Select the users you want to share the workbook and add these users to the 
shared area. 

d. Click OK.

Setting Up News and Stocks for the Home Tab
Use this procedure to set up the stocks and news feeds for users’ home tabs.

Prerequisites
The table AMV_STOCKS must contain data.

You must obtain a license from OneSource. Navigate to www.onesource.com for 
more information.

Steps
1. Run the KeyDaemon. Allow for 3-10 hours depending on how many stock key 

IDs you would like it to retrieve.

If you do not plan on updating the AMV_STOCKS table regularly, you don't 
need to leave the KeyDaemon running after the initial 3-10 hours. Its only 
purpose is to fetch key ids for companies whose stock symbols are in AMV_
STOCKS, but do not have key ids assigned to them yet. This will only occur 
after the initial run if you are updating the AMV_STOCKS table.
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2. Run the NewsDaemon. There are two kinds of updates that the NewsDaemon 
can perform: 

■ A User Update: This update only fetches news for companies that are 
specified in specific user’s profiles. This kind of update can be performed at 
a minimum of once per hour. 

■ A Global Update: This update fetch news for all the companies that have 
key ids in the database. This kind of update can be performed at a 
minimum of once per week. These limitations are set due to server-load 
restrictions on the content provider’s side. The update-interval for either 
type of update may be increased without limit. The NewsDaemon may be 
started with either type of update.

If a user adds a company to their profile, the news for that company will only 
show up immediately if three conditions are met: 

■ The company symbol exists in AMV_STOCKS 

■ The KeyDaemon has already retrieved the content-provider key for that 
company 

■ Another user already had that company in their profile before the last user 
update or a global update has been done at least once.

Java Class Usage for KeyDaemon and NewsDaemon
Following is a list of the arguments and their meanings for the KeyDaemon and the 
NewsDaemon

KeyDaemon

Purpose: Specify the database host, port, alias, and log-in information.

Syntax:  -d <db connect string> <user or schema> <password>

Example(s):  -d jdbc:oracle:thin:@ap012sun:1521:reldev1 apps apps

Required: Yes

Default N/A

Purpose:  Specify the content provider code.

Syntax:  -v <vendor code 1>[, vendor code 2,...]
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Example(s):  -v ONE_SOURCE,HOOVERS, -v ONE_SOURCE (*currently 
only this vendor code is available)

Required: Yes

Default: N/A

Purpose Specify the interval to sleep between updates in hours minutes, seconds 
and milliseconds.

Syntax:    -u <HH:MM:SS:mm>

Example(s):  -u 01:00:00:00 (once every hour)

Required: No

Default:  24:00:00:00 (once every day)

Purpose: Specify a file to log errors to.

Syntax:  -f <logfile path>

Example(s):  -f /home/rjainend/keyd.log

Required: No

Default:  None

Purpose: Specify a network proxy host and port.

Syntax:  -p <proxy hostname> <proxy port>

Example(s):  -p www-proxy.us.oracle.com 80

Required:  Required only for organizations behind a fire wall.

Default:  None

Purpose: View the usage text.

Syntax: -h

Purpose: Write messages to standard output.
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Sample Usage
java oracle.apps.amv.news.KeyDaemon -d 
jdbc:oracle:thin:@ap012sun:1521:reldev1 apps apps -v ONE_
SOURCE -u 4:00:00:00 -f keyd.log -p www-proxy.us.oracle.com 80 
-verbose

Daemon News Usage

Syntax: -verbose

Purpose: Write debugging info to standard output.

Syntax: -debug

Purpose:  Specify the database host, port, alias, and log-in information.

Syntax: -d <db connect string> <user or schema> 
<password>

Example:  -d jdbc:oracle:thin:@ap012sun:1521:reldev1 apps 
apps

Required? Yes

Default:  N/A

Purpose:  Specify the content provider code.

Syntax: -v <vendor code 1>[, vendor code 2,...]

Examples: -v ONE_SOURCE,HOOVERS -v ONE_SOURCE (*currently only 
this vendor code is available)

Required?  Yes

Default:  N/A

Purpose:  Specify the interval to sleep between User Updates in hours, 
minutes,        seconds and milliseconds.

Syntax:  -su <HH:MM:SS:mm>

Example: -su 1:00:00:00 (once every hour)
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Required?  No

Default:  1:00:00:00 (once every hour)

Purpose:  Specify the interval to sleep between Global Updates in hours, 
minutes, seconds and milliseconds.

Syntax:  -lu <HH:MM:SS:mm>

Example:  -lu 168:00:00:00 (once every week)

Required? No

Default:  168:00:00:00 (once every week)

Purpose:  Specify the number of news items to fetch for each company 
during a User Update.

Syntax:  -sn <number of news items>

Example:  -sn 20

Required? No

Default:  20 (This is also the maximum number of news items allowed for 
a User Update)

Purpose:  Specify the number of news items to fetch for each company 
during a Global Update.

Syntax:  -ln <number of news items>

Example:  -ln 10

Required?  No

Default:  10 (This is also the maximum number of news items allowed for 
a Global Update)

Purpose:  Specify a file to log errors to.

Syntax:  -f <logfile path>

Example:  -f /home/rjainend/newsd.log

Required?  No
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Sample Usage
java oracle.apps.amv.news.NewsDaemon -d 
jdbc:oracle:thin:@ap012sun:1521:reldev1 apps apps -v ONE_
SOURCE -su 4:00:00:00 -sn 5 -lu 200:00:00:00 -ln 5 -f keyd.log 
-p www-proxy.us.oracle.com 80 -verbose -short

Known Problems with Oracle Web Discoverer
■ Current release does not work if cookies are disabled.

Default:  None

Purpose:  Specify a network proxy host and port.

Syntax:  -p <proxy hostname> <proxy port>

Example:  -p www-proxy.us.oracle.com 80

Required? No. Only necessary for an organization behind a fire wall.

Default:  None

Purpose:  Start the NewsDaemon in User Update mode. If this argument 
is not specified, the NewsDaemon starts in Global Update mode.

Syntax: -short

Purpose:  View the usage text.

Syntax: -h

Purpose:  Write messages to standard output.

Syntax:  -verbose

Purpose: Write debugging info to standard output.

Syntax: -debug
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■ If you do a refresh of the database, then the applications user password must be 
reset before users can log into Oracle Web Discoverer again.

■ Errors with text such as: "Failed to connect to database - Unable to connect to 
Oracle Applications database (asfcpgcs)"

This occurs when you click on the Oracle Web Discoverer icon, bring up the 
Discoverer applet, but it fails to connect to the applications database. 

Cause: Discoverer dbc file in the secure directory is not set up correctly. or the 
TNSNAME is not set up right in Discoverer server.

■ Errors such as "Wide Area Network Connection failed." often mean that you 
need to bounce the server. 

■ If you have accessed another version of Oracle Web Discoverer before, then 
your browser cache may have the latest version of Discoverer objects. If you 
access a lower version of Oracle Web Discoverer, then you will get the wide area 
network connection error in Internet Explorer. 

For example:

“Unable to connect to the Oracle Discoverer Application Server:   -Wide 
area network connection failed. Locator interface incorrect.    Expecting 
version 3.3.3 got version 3.3.2.”

To resolve this in Internet Explorer:

1. Navigate to Tools > Internet Options > Settings > View Objects. 

2. Delete the Oracle Discoverer 3i and Oracle Discoverer 3i Initializer entries.

3. Exit all Internet Explorer browser windows and reconnect to the Oracle 
Marketing Online site.

Seeded Workflows

Application System Workflow File Name

AMS Continuous Campaign amsccamp.wft

Marketing Approvals amsvappr.wft

OZF Fund Request Approvals ozfvwreq.wft
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Administering Oracle Marketing Online

This group of topics explains how to administer different functions of Oracle 
Marketing Online. Depending on your implementation, these procedures may be 
restricted to applications administrators only.

Enabling Campaign and Event Approval Workflow
Use this procedure to enable the Workflow approval process for campaign themes 
and budgets. You must enable the Workflow for each campaign and event setup 
separately.

Prerequisites
You must create campaign setups first. 

Steps
1. Navigate to Administration > Setup > Custom Setup.

2. Click on the name of the setup you wish to enable.

The Custom Setup subtab appears.

3. If you wish to enable campaign theme approval using the default Oracle 
Marketing Online Workflow, then select the Show check box for Theme 
Approval. This is one of the last items on the list.

4. If you wish to enable campaign budget approval using the default Oracle 
Marketing Online Workflow, then select the Show check box for Budget 
Approval. This is one of the last items on the list.

5. Click Update.

Setting Up Marketing Mediums for Campaigns
Use this procedure to create or edit marketing mediums you use to execute the 
marketing activities for your company. A marketing medium can be a magazine or 
a television station you advertise in, an email server that sends out email 
promotions, or a telemarketing center. A marketing medium can have only one 
marketing activity associated with it at one time.
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Prerequisites
Optional entry in Preferred Vendor, Party, and Managed By fields requires setup in 
Oracle financial applications.

Steps
1. Navigate to Administration > General > Marketing Medium.

2. If you are creating a new entry, then click Create. Otherwise select the name of 
the marketing medium you wish to edit.

The Create Marketing Medium or Marketing Medium Detail subtab appears.

3. Enter or edit the name for the marketing medium.

4. Optionally, enter the other fields. The list of values for Preferred Vendor, Party, 
and Managed by come from ERP setups.

5. If you have not yet set up activities, then leave the Activity field blank. You can 
associate marketing mediums to activities while creating activities.

6. Click Create or Update.

You are now ready to set up activities.

Guidelines
The optional fields include:

Field Name Description

Preferred Vendor Company name set up in Oracle Accounts Payable

Managed By Individual name set up in Oracle Human Resources

Party Party from the Oracle Customer Model

Active From and Active 
To 

Dates this marketing medium can be used

Internal, Outbound, and 
Inbound check boxes

Specifies which type of campaigns the marketing medium can 
be used for 

Activity Lets you assign a marketing medium to an activity. If you have 
not yet created your activities, then leave this field blank. 
Instead, do the assignment while creating your activities. 

Description Free text description
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Setting Up or Editing Activities for Campaigns and Events
Use this procedure to set up the activities for your campaigns and events. Each 
activity must be associated with one or more marketing mediums through which it 
is carried out. 

For example, if you are running print ads in two newspapers, the Wall Street 
Journal and the Washington Post, and broadcasting a spot on one television station, 
then you may want to create two separate activities, one named "Print Advertising" 
and another named "Television Advertising". You associate the Print Advertising 
activity with two marketing mediums: The Wall Street Journal and the Washington 
Post. You associate the Television Advertising activity with the television marketing 
medium.

Prerequisites
You must set up marketing mediums before you can complete this procedure.

Steps
1. Navigate to Administration > Setup > Activity

2. If you are creating a new activity, then click Create.

3. If you are editing an existing activity, then select the name of the activity you 
wish to edit.

The Create Activity or Activity Details subtab appears, depending on whether 
you are creating or editing the activity.

4. Enter or modify the name of the activity. This activity name appears in the 
Activity drop-down list in campaigns and events.

5. Use the Activity Type list of values (LOV) to select an activity type for this 
activity. The activity appears in the Activity list of values, when users select this 
activity type only.

6. Select the Active check box.

7. Enter a description.

8. In the Marketing Mediums region, enter one or more media that can be used for 
this activity:

a. Use the Name drop-down list to select the marketing medium.
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b. In Active From and Active To fields enter the date range for this activity. 
The dates must fall between the effective dates for the marketing medium 
you have chosen. 

9. Click Create or Update.

Guidelines
The optional fields include:

Creating Custom Setups for Campaigns and Events
Use this procedure to create custom setups that customize what information users 
must enter for campaigns and events. A custom setup specifies:

■ Which item on the side panel menus appear during campaign and event 
creation

■ Which of these must be filled in by users before they can make a campaign or 
an event active

■ The order in which the attributes are listed in the checklist

When users create campaigns and events, they select one of the custom setups you 
create using the Setup Type drop-down list. 

Prerequisites
Before you carry out this procedure, you must set up:

■ Marketing mediums

■ Activities

Steps
1. Navigate to Administration > Setup > Custom Setup.

Field Name Description

Active, Response check 
boxes

Lets you classify if an Activity is related to outbound or inbound 
marketing activities.

Description Free text.

Marketing Medium 
Name

List of values with the marketing mediums you have set up 
previously.
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2. Click Create.

The Create Custom Setup subtab appears.

3. In Setup Name, enter a name for this custom setup. This is the name that 
appears in the Setup Type drop-down list during campaign and event creation 
and above the list of item on the side panel menus.

4. From the Associated With drop-down list, select whether you want to use this 
template for execution campaigns, rollup campaigns, execution events, or 
rollup events.

5. Use the Activity Type drop-down list to select an activity where this custom 
setup will appear. 

6. If you wish to limit the use of this custom setup further, then select an activity 
for the activity type. If you do not select an activity type, then this custom setup 
can be used for all activities for the activity type.

7. In the Components region, select the Show check box for attributes you wish to 
appear on the checklist for the campaign or event using this custom setup.

8. If you wish to make any of the attributes mandatory for a campaign, then select 
the Mandatory check box next to each attribute. If a user does not make an 
entry in a mandatory attribute of a campaign, then the campaign cannot be 
used.

9. If you wish to modify the order in which the attributes appear on the checklist 
then modify the numbering in the Sequence field.

10. If you wish to enable campaign theme approval using the default Oracle 
Marketing Online Workflow, then select the Show check box for Theme 
Approval. 

11. If you wish to enable campaign budget approval using the default Oracle 
Marketing Online Workflow, then select the Show check box for Budget 
Approval. 

12. Click Create.

Note: Making a item on the side panel menu mandatory requires 
users to make an entry in the attribute but does not require them to 
fill in all the information requested. Any entry satisfies the 
requirement and marks the attribute with a check mark. 
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Guidelines
The optional fields include:

Creating Metrics
Use this procedure to set up all metrics. This includes cost metrics as well as those 
metrics used to track the performance of your campaigns, events, and deliverables.

Prerequisites
None

Steps
1. Navigate to Administration > General > Metric.

2. If you wish to create a new metric, then click Create.

3. If you wish to edit an existing metric, then select the metric to edit from the list. 

The Metrics Definition subtab appears.

4. Enter the metric name.

5. Optionally, select the metric category and subcategory.

6. From the Used With drop-down list, select what object uses this metric.

7. Enter an optional description.

8. In the Calculation region, select the radio button that describes how this metric 
is getting its values:

Field Name Description

Active check box Deselecting this check box removes this template from use.

Source Code Suffix Enter a suffix for the source code that is generated automatically 
whenever an agent creates a campaign.

This source code becomes the primary reference to the campaign 
and is referred to by the Oracle Telesales and Oracle Order 
Capture applications. It can be used to track the effectiveness of 
a campaign through consumer activity. When a campaign is 
defined, a source code may be manually entered by the user, or 
generated by the system automatically.

Marketing Medium 
Name 

LOV of Marketing Mediums you have set up previously.
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■ If users are entering values in this metric, then select the Enter Value 
Manually.

■ If this metric is getting its values from another metric then select Accrue 
through summarization. Use this selection both for metrics that summarize 
other metrics at the same level in the campaign or event hierarchy and 
those that summarize values from levels down the campaign or event 
hierarchy.

■ If the metric is to get its value using an external program, then select the 
Calculate using Program and enter the path in the text box provided.

■ If you wish the metric to be calculated using another metric, select 
Calculate using Metric, click Go and use the list of values (LOV) to enter 
the metric.

9. In the Summarize to region, enter information about where the metric is 
passing its values. Select one of the three radio buttons:

■ If the metric is not passing its value to another metric, then select None.

■ If the metric is passing its value to a metric in a parent rollup campaign or 
parent rollup event, then select of the Parent, click Go, and use the list of 
values (LOV) to enter the metric. The destination metric must be of type 
Accrue through summarization.

■ If this metric is sending its values to another metric at the same level in the 
campaign or event hierarchy, then select at same level, click Go, and use 
the LOV to enter the name of the metric to which you are passing data. 

10. Click Update.

Creating Venues 
Venues describe the physical location where an event is being held. Use this 
procedure to set up venues for your events.

Prerequisites
None

Steps
1. Navigate to Administration > General > Venue

2. Click Create.
54 Oracle Marketing Online Implementation Guide



About Workbooks, Worksheets, and Oracle Web Discoverer
The Create Venue subtab appears.

3. Enter the venue name, venue type, and other appropriate information about the 
venue.

4. Select the Active check box.

5. Click Create.

Guidelines
Make sure to use a unique name to identify a venue. For example, the name Hyatt 
Regency covers hotels in many locations. Use Hyatt Regency San Francisco instead.

 Help for This Feature Under Development
There is no help available on this feature at this time. 

About Workbooks, Worksheets, and Oracle Web Discoverer
Oracle Marketing Online includes Oracle Web Discoverer, a separate application 
which non-technical users can use to create database queries for list creation.

This topic explains a few key terms:

■ Folders, field icons, and the End User Layer (EUL)

■ Worksheets

■ Workbooks

■ Conditions

Folders, Field Icons, and the End User Layer (EUL)
Oracle Web Discoverer’s graphical user interface represents query terms as folders 
and field icons. Users move these from left to right to create a query. See Using Web 
Discoverer for more information.

The folders represent different views of the database. The Contacts OK to email 
folder, for example, lists all of the customers in the database who have indicated 
that they can be emailed. 
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The fields represent customer attributes, including name, telephone number, age, 
and so on. 

Oracle Marketing Online application development team has created folders and 
fields in Oracle Web Discoverer that are specific to marketing. Together this is called 
the End-User Layer.

Worksheets
The query you create by moving the folders and fields to the right side of the 
window is called a worksheet. It is these individual worksheets that you use in the 
list creation process.

Workbooks
When you save the query, Discoverer automatically creates a workbook for the 
worksheet. In this respect, Discoverer is analogous to Microsoft Excel where each 
sheet is stored in a book. 

If you wish, you can store multiple worksheets in a workbook. But for the purposes 
of Oracle Marketing Online you are better off having just one worksheet per 
workbook.

This is because you select individual worksheets and not workbooks for list 
creation.

Oracle Marketing Online does not distinguish between worksheets and workbooks. 
Both are called by the generic term workbook and both appear in the list of values 
when you add workbooks during list creation. 

Conditions
You can apply a condition to the worksheet to further constrain the query. For 
example, if you wish to create a worksheet that retrieves only the contact and email 
records for one organization, the Global Enterprise organization, then the condition 
you will use is Organization Name = “Global Enterprise”.

See Also
 Creating Workbooks in Discoverer
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Available Mailmerge Fields
The following fields are available for use in cover letters depending on which of the 
two seeded queries you select:

Marketing Simple Query:
■ title

■ first_name

■ last_name

■ pin_code

Marketing Detailed Query:
■ title 

■ first_name

■ last_name

■ pin_code

■ inbound_dscript_name

■ inbound_url

■ inbound_email_id

■ inbound_phone_no

■ source_code

■ offer_code

References
■ For information on how to create a mailmerge letter using these fields, see 

Creating a Mailmerge Letter
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