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This document describes the steps necessary to implement Oracle HTML 
Quoting and to set up your sales representatives and other personnel to 
create and subsequently modify quotes.

1 Overview of Setting Up Oracle HTML Quoting
Sales representatives and other organization personnel can use Oracle 
HTML Quoting to create and manage quotes on a customer’s behalf. 

You must first set the sales representatives up as Oracle HTML Quoting 
users who have Sales Representative roles. A Sales Representative role’s 
permissions determine whether the user can submit quotes as orders, and 
to what extent the user can modify a quote.

You can assign a Sales Representative role to sales personnel within your 
organization, to value-added distributors and partners (VAD/Partner) of 
your organization, and to anyone else who should be authorized to create 
quotes for your customers.

2 Dependencies
Oracle HTML Quoting depends on Oracle iStore, Oracle Inventory, Oracle 
Order Capture, Oracle Order Management, and Oracle Pricing, which in 
turn depend on other Oracle application modules.

2.1 Oracle iStore
You must install Oracle iStore before using Oracle HTML Quoting. Oracle 
HTML Quoting uses the Oracle iStore permissions, specialty stores, and 
shopping cart, as well as some Oracle iStore (IBE) profile options.
Oracle is a registered trademark. Other names may be trademarks of their respective owners.



Permissions A Sales Representative role in Oracle HTML Quoting uses 
Oracle iStore permissions. See Oracle iStore Implementation Guide for more 
information about Oracle iStore permissions.

Specialty stores You must set up at least one Oracle iStore specialty store 
with the products that you want the sales representatives to sell.

You can set up multiple specialty stores for your sales representatives with 
different listings of products, which allows additional flexibility and control 
for you to do the following:

� Organize products to help your sales representatives find specific 
products easily

� Restrict which products a given sales representative can sell, by giving 
him or her access to some specialty stores and excluding him or her 
from others

See Oracle iStore Implementation Guide and Oracle iStore Concepts and 
Procedures for more information about setting up specialty stores.

Shopping cart The sales representative builds quotes for customers by 
leveraging the Oracle iStore shopping cart functionality. For all intents and 
purposes, a shopping cart and a quote are the same. The same object is 
referred to as a shopping cart with respect to B2B and B2C customers in 
Oracle iStore, and as a quote with respect to the sales representatives in 
Oracle HTML Quoting. See Oracle iStore Concepts and Procedures for more 
information about the Oracle iStore shopping cart.

Profile Options See Section 9, "Profile Options" for more information about 
the Oracle iStore profile options that you need to set when implementing 
Oracle HTML Quoting.

2.2 Oracle Inventory
The setup of Oracle iStore is dependent on product item setup in Oracle 
Inventory. See Oracle iStore Implementation Guide and Oracle Inventory User’s 
Guide for more information.

This section addresses the setup of items to allow trade-ins, a specific 
Oracle HTML Quoting functionality.

If your merchant organization provides credit to customers for returning or 
decommissioning existing products when they purchase new products, you 

Note: Specialty stores are also called "minisites."
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can set up Oracle HTML Quoting to allow a sales representative to add a 
customer’s trade-in items to a quote.

Sales representatives add trade-in items to a quote by performing a product 
search for the items, adding the items to the quote, and marking their line 
type as Return. When the application calculates the order total, it 
recognizes items with the line type Return as trade-in items. The 
application treats the trade-in items’ prices as credits and subtracts them 
from the order total.

All items on a quote, including trade-in items, must exist in Oracle 
Inventory. All items that are eligible for trade-in must have their Returnable 
flags set to Yes.

Any obsolete items that are eligible for trade-in must still exist in Oracle 
Inventory.

If your merchant organization allows trade-ins of other merchants’ 
products that would not exist in your instance of Oracle Inventory, you 
must set up dummy items in Oracle Inventory to represent these trade-in 
items for the quotes.

For obsolete or dummy items, set the Customer Orderable flag to No.

Use the following procedure to set the Returnable flag for an item that is 
eligible for trade-in.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in with the Inventory responsibility.

3. Choose Items > Master Items.

The Organizations window opens.

4. In the Organizations window, search for and highlight the organization 
that has the trade-in item, and click OK.

The Master Item form opens.

5. Choose View > Find.

The Find Master Items window opens.

6. In the Find Master Items window, enter your search criteria for the 
trade-in item, and click Find.
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The Master Items Summary window opens.

7. Highlight the trade-in item and click Open.

The Master Item form for the trade-in item opens.

8. In the Order Management tab, check the Returnable checkbox.

9. Optional: In the Order Management tab, uncheck the Customer Orders 
Enabled checkbox for obsolete or dummy trade-in items.

10. Click the Save icon in the toolbar to save the record.

You must also set the profile option IBE: Use Line Types to Yes to allow 
sales representatives to mark items as trade-ins by changing their line types 
to Return. See Section 9, "Profile Options" for more information.

2.3 Oracle Order Capture
Oracle iStore is dependent on the setup of Oracle Order Capture. See Oracle 
iStore Implementation Guide and Oracle Order Capture Implementation Guide 
for more information.

This section addresses the setup of quote status transitions to allow quote 
versioning in Oracle HTML Quoting.

Sales representatives can create multiple versions of a quote for a customer.

To enable the versioning functionality, you must set up Oracle Order 
Capture to allow the quote status to transition from Drafted to Drafted.

Use the following procedure to set up the Drafted-to-Drafted status 
transition.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in with the Order Capture Sales Manager responsibility.

3. Choose Quote Status Setup.

The Quote Status Setup window opens.

4. In the Quote Statuses region, select Drafted.

The Allowed Transition to Status region is populated with the quote 
statuses that can be assigned to a quote of Drafted status.
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5. In the Allowed Transition to Status region, select Drafted from a Code 
field’s list of values (LOV) if it is not already listed in the region.

6. Click the Save icon in the toolbar to save the record.

2.4 Oracle Order Management and Oracle Pricing
Oracle HTML Quoting allows sales representatives to use pricing 
agreements to price quotes.

Pricing agreements are created in Oracle Order Management or Oracle 
Pricing. They set up the billing specifications that allow a quote to be 
priced. The attributes of a pricing agreement are price list, purchase order 
number, bill-to address, bill-to contact, invoicing terms, payment terms, and 
shipment terms. These attributes set up and apply default pricing rules in 
Oracle Order Management.

Each pricing agreement can have only one price list assigned to it, but one 
list can be linked to multiple agreements. You can create universal and 
customer-specific pricing agreements.

You can also set up promotion codes (also known as "offer codes") in Oracle 
Pricing. Sales representatives using Oracle HTML Quoting can enter these 
promotion codes to capture automatic discounts set up in the Oracle Pricing 
engine as available to request.

See Oracle Pricing User’s Guide for more information.

3 Related Documentation
See the manuals listed below for more information relevant to 
implementing Oracle HTML Quoting:

� Oracle HTML Quoting Concepts and Procedures, Release 11i

This document provides users with information on using Oracle HTML 
Quoting to create, manage, and personalize quotes for customers in a 
secure Web-based environment.

� Oracle iStore Implementation Guide, Release 11i 

This document provides users with information on implementing 
Oracle iStore, including procedures for setting up and customizing 
Oracle iStore, profile option descriptions, and API documentation.

� Oracle iStore Concepts and Procedures, Release 11i 

This document provides users with information on general principles 
and procedures for maintaining Web stores using Oracle iStore.
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� Oracle Inventory User’s Guide, Release 11i 

This document provides users with information on setting up products 
in Oracle Inventory.

� Oracle Order Capture Implementation Guide, Release 11i 

This document provides users with information on implementing 
Oracle Order Capture, including procedures for setting up quote 
statuses and status transitions.

� Oracle Pricing User’s Guide, Release 11i 

This document provides users with information on setting up 
promotion codes, pricing agreements, and price lists in Oracle Pricing.

� Oracle Applications System Administrator’s Guide, Release 11i 

This document provides users with information on creating 
responsibilities and other system administrator tasks in Oracle 
Applications.

� Oracle CRM Foundation Implementation Guide, Release 11i 

This document provides users with information on implementing 
Oracle CRM Foundation, including procedures for creating user roles 
and details about CRM resources.

� Implementing Oracle CRM: ERP Functional Checklist, available at 
http://metalink.oracle.com

This document provides users with information on the functional flows 
of other Oracle Enterprise Resource Planning (ERP) Applications when 
integrated with Oracle Customer Relationship Management products.

� Implementing Oracle CRM: Foundation Functional Checklist, available at 
http://metalink.oracle.com

This document provides users with information on the functional flows 
of other Oracle Foundation Applications when integrated with Oracle 
Customer Relationship Management products.
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4 The Sales Representative Role and Permissions
The seeded Sales Representative role for Oracle HTML Quoting is IBE_
SALESREP_ROLE. You can also create new Sales Representative roles for 
your sales representatives with any set of quote creation permissions that 
you specify. 

See Oracle CRM Foundation Implementation Guide for more information about 
creating roles. See Oracle iStore Implementation Guide and Oracle iStore 
Concepts and Procedures for more information about the Oracle iStore quote 
creation permissions.

The Sales Representative role IBE_SALESREP_ROLE has all available quote 
creation permissions. It is appropriate for assignment to sales 
representatives and other employees of your organization. The following 
table describes the permissions for IBE_SALESREP_ROLE.

Table 1 Permissions for IBE_SALESREP_ROLE 

Name Description

IBE_ALLOW_PRICE_OVERRIDE Allows the user to override prices 
manually

IBE_ASSIGN_SALES_CREDITS Allows a user to assign sales credits.

IBE_BILLTO_ANY_ACCOUNT Allows a user to search on and retrieve all 
existing customers rather than only those 
with an existing billing relationship with 
the sold-to customer

IBE_CHANGE_BILLTO_CONTACT Allows a user to change the bill-to contact 
from the default (if any) bill-to contact

IBE_CHANGE_BILLTO_CUSTOMER Allows a user to change the bill-to 
customer from the default bill-to customer

IBE_CHANGE_SHIPTO_CONTACT Allows a user to change the ship-to contact 
from the default (if any) ship-to contact

IBE_CHANGE_SHIPTO_CUSTOMER Allows a user to change the ship-to 
customer from the default ship-to 
customer

IBE_CREATE_BILLTO_CONTACT Allows the user to create a new contact for 
the bill-to customer who will have a bill-to 
relationship with the bill-to customer

IBE_CREATE_BILLTO_CONTACT_
ADDRESS

Allows the user to create a new address 
associated with the bill-to contact which 
will have a bill-to relationship with the 
bill-to contact

IBE_CREATE_BILLTO_CUSTOMER Allows a user to create a new customer 
with a billing relationship to the sold-to 
customer
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IBE_CREATE_BILLTO_CUSTOMER_
ADDRESS

Allows the user to create a new address 
associated with the bill-to customer which 
will have a bill-to relationship with the 
bill-to customer

IBE_CREATE_ORDER Allows a user to submit a quote or cart as 
an order

IBE_MODIFY_CART Not used in Release 11i.

IBE_MODIFY_ORDER Not used in Release 11i.

IBE_CREATE_SHIPTO_CONTACT Allows the user to create a new contact for 
the ship-to customer who will have a 
ship-to relationship with the ship-to 
customer

IBE_CREATE_SHIPTO_CONTACT_
ADDRESS

Allows the user to create a new address 
associated with the ship-to contact which 
will have a ship-to relationship with the 
ship-to contact

IBE_CREATE_SHIPTO_CUSTOMER Allows a user to create a new customer 
with a shipping relationship to the sold-to 
customer

IBE_CREATE_SHIPTO_CUSTOMER_
ADDRESS

Allows the user to create a new address 
associated with the ship-to customer which 
will have a ship-to relationship with the 
ship-to customer

IBE_CREATE_SOLDTO_CUSTOMER Allows a user to create a new customer in 
the context of assigning a sold-to customer 
during quote creation

IBE_SHIPTO_ANY_ACCOUNT Allows a user to search on and retrieve all 
existing customers rather than only those 
with an existing shipping relationship with 
the sold-to customer

IBE_USE_ATTACHMENT Allows the user to use attachments

IBE_USE_PRICING_AGREEMENT Allows the user to use pricing agreements

IBE_VIEW_CUST_WITHOUT_
ACCOUNT

Allows a user to search on and retrieve 
existing customers without an account

Table 1 Permissions for IBE_SALESREP_ROLE (Cont.)

Name Description
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5 Process Flow for Required Sales Representative Setups
Follow the overall process flow illustrated in the following diagram to 
perform the required setups that are related to creating Oracle HTML 
Quoting sales representatives.

6 Defining a Sales Representative Responsibility
Before you can approve employees or other personnel as sales 
representatives, you must define at least one responsibility to assign to 
them. You can set up a structure of sales representative responsibilities that 
meets your business needs.

If you want some of your sales representatives to be able to sell all of your 
products, you can create a specialty store that contains every product listed 
in Oracle Inventory, then give them a responsibility that is supported by 
this specialty store and associated with the Master Inventory Organization.

You can associate different responsibilities with various operating units and 
specialty stores. In other words, you can set up specific sales representative 
responsibilities that allow a sales representative to create quotes only 
against a certain operating unit or within certain specialty stores.
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For more information about creating responsibilities, see Oracle Applications 
System Administrator’s Guide, Release 11i.

Use the following procedure to create a responsibility for sales 
representatives and associate it with an operating unit and at least one 
specialty store.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in with the System Administrator responsibility.

3. Choose Security > Responsibility > Define.

The Responsibilities form opens.

4. Create a responsibility for an application, setting Data Group Name to 
Standard, Data Group Application to iStore, and Menu to iStore 
Quotes Root Menu.

5. Click the Save icon in the toolbar to save the record.

6. With your cursor in any field of the record, choose Help > Diagnostics 
> Examine.

The Examine Field and Variable Values window opens.

7. In the Examine Field and Variable Values window, choose 
APPLICATION_ID in the Field LOV. 

The Value field in the Examine Field and Variable Values window is 
populated with the value of APPLICATION_ID. Note this value.

8. In the Examine Field and Variable Values window, choose 
RESPONSIBILITY_ID in the Field LOV. 

The Value field in the Examine Field and Variable Values window is 
populated with the value of RESPONSIBILITY_ID. Note this value.

9. From the Navigator - System Administrator window, choose Profile > 
System.

The Find System Profile Values window opens.

Note: Choose a clearly identifiable responsibility name. 
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10. Check Site, Application, and Responsibility. Use the Application LOV 
to choose CRM Foundation. Use the Responsibility LOV to choose 
CRM Resource Manager.

11. In the Profile field, enter MO: Operating Unit.

12. Click Find.

The System Profile Values form opens with the results of your search.

13. Note the value of the profile MO: Operating Unit at the CRM Resource 
Manager responsibility level. Optionally, you can change it.

If the profile is not set at this level, note its value at the CRM 
Foundation application level. Optionally, you can change it.

If the profile is not set at this level, note its value at the site level. 
Optionally, you can change it.

14. Choose View > Find.

The Find System Profile Values window opens.

15. Check Responsibility, and use the Responsibility LOV to search for 
and enter the name of the sales representative responsibility.

16. In the Profile field, enter MO: Operating Unit.

17. Click Find.

The System Profile Values form opens with the results of your search.

18. Set the profile MO: Operating Unit at the responsibility level to the 
operating unit that is the value of the profile MO: Operating Unit at the 
CRM Resource Manager responsibility/CRM Foundation 
application/site level.

19. Click the Save icon in the toolbar to save the record.

20. Launch the Oracle iStore Merchant UI by logging in to the Oracle CRM 
Applications login page at: 

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

with a user name that has the default responsibility IBE_
ADMINISTRATOR and the default application iStore. (In other words, 
the user’s JTF_PROFILE_DEFAULT_RESPONSIBILITY profile option is 
set to 21819, and the user’s JTF_PROFILE_DEFAULT_APPLICATION 
profile option is set to 671).

21. In the Setup tab, click on the name link of the specialty store to which 
you want to assign the responsibility.

The Specialty Store Detail page opens.
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22. Click Supported Responsibilities.

The Supported Responsibilities page opens.

23. Click Add Responsibility. 

The Select Responsibility pop-up window opens.

24. In the Select Responsibility pop-up window, search for the sales 
representative responsibility that you want this specialty store to 
support by application and responsibility name, key, or description. 
Check the Select checkbox next to the responsibility, and click Add. 
When you are finished, click Done. 

25. In the Supported Responsibilities page, click Update to save your 
changes.

You can now assign this responsibility to employees and other personnel so 
that they can create quotes against the operating unit in the specialty stores 
that support the responsibility.

7 Setting Up Sales Representatives
You must perform the following tasks to set up each of your sales 
representatives:

Steps
1. Creating a User Name for a Sales Representative

2. Assigning a Sales Representative Role

3. Importing a CRM Resource

If you are setting up an employee as a sales representative, you must first 
create a record of the employee before proceeding with these tasks. See 
Section 7.1, "Creating an Employee Record" for more information.
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7.1 Creating an Employee Record
There must be a record of your employee in Oracle Human Resources 
before you set him or her up as a sales representative.

Use the following procedure to verify or create a record of your employee.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in with the Human Resources responsibility.

3. Choose People > Enter and Maintain.

The Find Person window opens.

4. In the Find Person window, enter the search criteria for the employee 
and click Find.

5. If a record of the employee exists, the People form opens with the 
record. 

Note the employee’s number.

6. If a record of the employee does not exist, proceed through these steps 
to create a record:

a. In the Find Person window, click New to create an employee’s 
record.

A blank People form opens.

b. In the People form, enter at least the employee’s Last Name, Social 
Security Number, and Birth Date.

c. Place your cursor in the Type field and click the LOV button. 

The Person Types window opens.

d. Highlight Employee and click OK.

e. Click the Save icon in the toolbar to save this employee’s record.

f. Note the employee’s number.
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7.2 Creating a User Name for a Sales Representative
For each sales representative, you must create an Oracle HTML Quoting 
user name and password, assign responsibilities to the user name, and set 
up its profile options.

Use the following procedure to set up an Oracle HTML Quoting user name 
for a sales representative.

Prerequisites
You have defined a responsibility for sales representatives and noted its 
APPLICATION_ID and RESPONSIBILITY_ID. See Section 6, "Defining a 
Sales Representative Responsibility" for more information.

If you are setting up an Oracle HTML Quoting user name for an employee, 
a record of the employee must exist in Oracle Human Resources. See 
Section 7.1, "Creating an Employee Record" for more information.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in with the System Administrator responsibility.

3. Choose Security > User > Define.

The Users window opens.

4. In the User Name field, enter the user name that the sales 
representative will use to log in to Oracle HTML Quoting.

5. In the Password field, enter the sales representative’s password.

6. Place your cursor in the Person field or Customer field, depending on 
the resource category of the sales representative:

� If the sales representative is an employee, choose the Person field.

� If the sales representative is not an employee, choose the Customer 
field.

7. Use the LOV to search for and select the sales representative.

8. In the Responsibilities block, use the LOV button in a Responsibility 
field to assign a sales representative responsibility to the user name. 

9. Click the Save icon in the toolbar to save this user record.
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10. From the Navigator - System Administrator window, choose Profile > 
System.

The Find System Profile Values window opens.

11. Check the checkbox next to the User field, and use the LOV to search 
for and enter the sales representative’s user name.

12. In the Profile field, enter JTF_PROFILE%.

13. Click Find.

The System Profile Values form opens with the results of your search.

14. Set the profile option JTF_PROFILE_DEFAULT_APPLICATION at the 
user level to the APPLICATION_ID value of the user name’s sales 
representative responsibility.

15. Set the profile option JTF_PROFILE_DEFAULT_RESPONSIBILITY at 
the user level to the RESPONSIBILITY_ID value of the user name’s 
sales representative responsibility.

16. Click the Save icon in the toolbar to save the records.

Guidelines
When assigning responsibilities to a sales representative, choose 
responsibilities that are associated with the operating units and specialty 
stores for which he or she should create quotes. If you want the sales 
representative to create quotes for all operating units, assign a responsibility 
that is associated with an operating unit linked to the Master Inventory 
Organization. See Oracle iStore Implementation Guide for more information 
about defining the Master Inventory Organization in Oracle Inventory and 
associating responsibilities with operating units.

7.3 Assigning a Sales Representative Role
You must assign a Sales Representative role to the sales representative’s 
user name.

Use the following procedure to assign a Sales Representative role to a sales 
representative’s user name.

Prerequisites
A user name for the sales representative exists. See Section 7.2, "Creating a 
User Name for a Sales Representative" for more information.
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Steps
1. Log in as SYSADMIN to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. In the Users tab, choose User Name from the Find Users pull-down 
menu, enter the sales representative’s user name in the adjacent text 
field, and click Go.

The Users page displays the sales representative’s user name in the 
search results.

3. Click on the user name link.

The User Details page for the user name opens.

4. Click Roles.

The User Role Mapping page opens.

5. Highlight IBE_SALESREP_ROLE (or another Sales Representative role 
that you have created) in the Available Roles list and click the ">" 
button to move it to the Assigned Roles list.

6. Click Update to save this role assignment.

7.4 Importing a CRM Resource
You must set up a sales representative as a CRM Resource, with a 
salesperson number and sales credit type, after assigning to him or her an 
Oracle HTML Quoting user name and a Sales Representative role.

You can import a resource into the Oracle CRM Foundation Resource 
Manager from different application databases depending on the resource 
type you choose. After selecting a resource based on its type, you identify 
its role and eligibility dates before saving it to Resource Manager as a CRM 
Resource.

Use the following procedure to set up a sales representative as a CRM 
Resource.

Prerequisites
If you are importing an employee as a resource, a record of the employee 
must exist in Oracle Human Resources, and you should know the 
employee’s number. See Section 7.1, "Creating an Employee Record" for 
more information.

A user name for the sales representative exists, and you have assigned a 
Sales Representative role to it. See Section 7.2, "Creating a User Name for a 
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Sales Representative" and Section 7.3, "Assigning a Sales Representative 
Role" for more information.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in with the CRM Resource Manager responsibility.

3. Choose Maintain Resources > Import Resources.

The Selection Criterion window opens.

4. Choose Employee, Partner, Supplier Contact, Party, or another 
category from the Resource Category pull-down menu, as appropriate 
to the sales representative.

5. Optional: Enter other search criteria.

6. Optional: If you are importing an employee resource, in the Number 
field, enter the employee number you noted when viewing or creating 
the employee’s record. 

7. Click Search.

The search results appear in the Search Results region of the Selection 
Criterion window.

8. Check the Select checkbox next to the person or organization that you 
are setting up as a sales representative. 

9. Click Create Resource.

The Default Values window opens.

10. Optional: You can enter active dates, manager’s name, and role 
information in this window.

11. Click OK.

The Selected Resources window opens, showing the sales 
representative as a resource.

12. Check the Select checkbox next to the sales representative’s resource 
record and click Save Resource.

The sales representative is now saved as a CRM Resource.

13. Click Details.
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The Resource form for the sales representative opens.

14. In the Salesperson Number field, enter an identifying number for the 
sales representative.

15. Click on the Receivables tab.

16. In the Sales Credit type field, use the LOV to assign a sales credit type 
to the sales representative.

17. Click the Save icon in the toolbar to save the record.

The sales representative can now log in to Oracle HTML Quoting with 
his or her user name and create quotes.

8 Limiting the Available Countries
When sales representatives search for and create customers, contacts, and 
addresses, they use a Country pull-down menu to select the country of the 
customer, contact, or address.

By default, all countries are available in the Country pull-down menus.

If necessary, you can limit the countries that appear in these menus.

8.1 Limiting Bill-To Countries
You can limit which countries appear in the Country pull-down menus for 
bill-to information, using the following procedure.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in with the Human Resources responsibility.

3. Choose Work Structures > Organization > Description.

The Find Organization window opens.

4. In the Find Organization window, enter the search criteria for your 
merchant organization and click Find.

The Organization form opens with the organization’s record.

5. In the Organization Classifications region, select Operating Unit in the 
Name fields.
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6. Click Others.

The Additional Organization Information window opens.

7. In the Additional Organization Information window, enter %Country 
in the Find field and click Find.

8. In the search results, choose Bill to Country and click OK.

The Additional Organization Information window for Bill to Country 
opens.

9. Place your cursor in a Bill to Country field.

The Bill to Country window opens.

10. Add countries to the Additional Organization Information window for 
Bill to Country as follows:

a. In the Bill to Country window, click the Bill to Country LOV 
button.

The Bill to Country search window opens.

b. Search for a country, highlight it, and click OK.

The Bill to Country field in the Bill to Country window is 
populated with the value of this country.

c. Click OK to add the country to the Additional Organization 
Information window for Bill to Country.

d. Repeat for each country that you want to add to the sales 
representatives’ bill-to Country pull-down menus.

11. When you are finished adding countries, click OK in the Additional 
Organization Information window for Bill to Country.

You return to the Organization form with the organization’s record.

8.2 Limiting Ship-To Countries
You can limit which countries appear in the Country pull-down menus for 
ship-to information, using the following procedure.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).
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2. Log in with the Human Resources responsibility.

3. Choose Work Structures > Organization > Description.

The Find Organization window opens.

4. In the Find Organization window, enter the search criteria for your 
merchant organization and click Find.

The Organization form opens with the organization’s record.

5. In the Organization Classifications region, select Operating Unit in the 
Name fields.

6. Click Others.

The Additional Organization Information window opens.

7. In the Additional Organization Information window, enter %Country 
in the Find field and click Find.

8. In the search results, choose Ship to Country and click OK.

The Additional Organization Information window for Ship to Country 
opens.

9. Place your cursor in a Ship to Country field.

The Ship to Country window opens.

10. Add countries to the Additional Organization Information window for 
Ship to Country as follows:

a. In the Ship to Country window, click the Ship to Country LOV 
button.

The Ship to Country search window opens.

b. Search for a country, highlight it, and click OK.

The Ship to Country field in the Ship to Country window is 
populated with the value of this country.

c. Click OK to add the country to the Additional Organization 
Information window for Ship to Country.

d. Repeat for each country that you want to add to the sales 
representatives’ ship-to Country pull-down menus.

11. When you are finished adding countries, click OK in the Additional 
Organization Information window for Ship to Country.

You return to the Organization form with the organization’s record.
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9 Profile Options
When implementing Oracle HTML Quoting, you must set certain Oracle 
iStore (IBE) profile options.

Use the following procedure to set IBE profile options. See Oracle iStore 
Implementation Guide for more information about these profile options.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms 
cartridge (UNIX).

2. Log in as SYSADMIN.

3. Choose the System Administrator responsibility.

4. Go to Profile > System.

The Find System Profile Values window opens.

5. Check Application, and choose iStore.

6. In the Profile field, enter IBE%, and click Find.

7. Verify and/or set the iStore (IBE) profile options listed below at the 
application level only, unless another level is specified.

The IBE profile options are summarized in the following tables, 
categorized according to the aspect of Oracle HTML Quoting that they 
impact: Search, Pricing, Quotes, and Functionality.

Note: The settings of the IBE profile options affect both 
the Oracle HTML Quoting user interface and the Oracle 
iStore customer user interface.
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Table 2 IBE Profile Options for Oracle HTML Quoting Search 

Name Description

IBE: Enable Fuzzy 
Search

If the profile is set to Yes, the application allows users to 
perform fuzzy product searches, so that they do not have 
to type in the exact spelling of their search criteria to 
retrieve results that match these criteria. If the profile is 
not set, it defaults to value No.

IBE: No of Results in 
Search

This profile specifies the number of hits returned by a 
store search. It defaults to value 200 if not set.

IBE: Search Lines Per 
Page

This profile specifies the number of quotes displayed on 
a single quote listing page for users with a Sales 
Representatives role. It defaults to value 20 if not set.

IBE: Use Category 
Search

This profile specifies whether Oracle HTML Quoting 
allows sales representatives to search for products by 
category or minisite section. Yes activates Category 
search so that the advanced search pull-down menu 
shows categories with publishable items. No activates 
Section search so that the advanced search pull-down 
menu shows top level sections for the minisite where the 
sales representative is creating a quote. Null value 
removes the advanced search pull-down menu so that 
search is only enabled in all products.

You must set this profile option to Yes if the IBE: Use 
CABO UI profile option is set to No.

Table 3 IBE Profile Options for Oracle HTML Quoting Pricing 

Name Description

IBE: Use Price list 
associated with 
Specialty Store

If the profile is set to Yes, the price list at the specialty 
store is used for registered and B2B customers. If the 
profile is set to No, Oracle HTML Quoting passes a null 
price list with the party ID and account ID to the Pricing 
engine, which then determines a price list for which the 
customer qualifies. If the profile is not set, it defaults to 
value Yes.

IBE: Pricing Event — 
Before Shopping Cart 

This profile specifies the user-defined pricing event 
(defined in Pricing) for the catalog stage.

Recommended value: Enter Order Line

IBE: Pricing Event for 
Shopping Cart

The merchant can choose any user-defined pricing event 
for processing the price for the shopping cart. These 
user-defined pricing events should first be created in 
Pricing.

Recommended value: Enter Order Line
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IBE: Recalculate Price in 
Order Management

If the profile is set to No, the quote-related prices are 
passed on to Order Management unchanged. If the 
profile is set to Yes, the quote-related prices can be 
changed in the order because Order Management is 
allowed to recalculate the prices for the quote. If the 
profile is not set, it defaults to value No.

IBE: Request Type to get 
a Price

Select the transaction application (e.g., Order 
Management) that calls the Pricing engine.

Table 4 IBE Profile Options for Oracle HTML Quoting Quotes 

Name Description

IBE: Shopping Cart 
Expiration Duration

This profile specifies the number of days that quotes are 
available to the merchant and customer. If the profile is 
not set, it defaults to value 0.

IBE: Authorize Payment 
Offline during normal 
Checkout 

This profile specifies if payment authorization offline 
before checkout is allowed. Yes enables offline 
authorization. No allows only online authorization. If the 
profile is not set, it defaults to value Yes.

IBE: Create Order in 
Entered State, if it has 
errors while booking

This profile specifies if the order should be created in the 
Entered state even if there are errors while booking it. If 
the profile is not set, it defaults to value No.

IBE: Default Payment 
Term

This profile specifies the default payment term. If the 
profile is not set, the option is ignored.

IBE: Merge Shopping 
Cart Lines

This profile specifies whether to merge item lines in the 
quote if the same item is added to the quote more than 
once. If the profile is not set, it defaults to value No.

Table 5 IBE Profile Options for Oracle HTML Quoting Functionality 

Name Description

IBE: Use Line Types This profile specifies whether sales representatives can 
modify line types for items in quotes. A sales 
representative marks an item as a trade-in by setting its 
line type to Return, so this profile’s value determines 
whether Oracle HTML Quoting’s trade-in functionality 
is available. Yes enables line type changes and 
consequently trade-in functionality. No disables line type 
changes and trade-in functionality. If the profile is not 
set, it defaults to value No.

Table 3 IBE Profile Options for Oracle HTML Quoting Pricing (Cont.)

Name Description
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10 Documentation Accessibility 
Oracle’s goal is to make our products, services, and supporting 
documentation accessible to the disabled community with good usability. 
To that end, our documentation includes features that make information 
available to users of assistive technology. This documentation is available in 
HTML format, and contains markup to facilitate access by the disabled 
community. Standards will continue to evolve over time, and Oracle is 
actively engaged with other market-leading technology vendors to address 
technical obstacles so that our documentation can be accessible to all of our 
customers. For additional information, visit the Oracle Accessibility 
Program web site at http://www.oracle.com/accessibility/. 

IBE: Use Notes This profile specifies whether to turn on the Notes 
functionality in Oracle HTML Quoting. Yes activates the 
Notes functionality. No deactivates it. The default value 
is No.

Oracle Sales Online must be installed before the Notes 
functionality can be activated.

IBE: Use Tasks This profile specifies whether to turn on the Tasks 
functionality in Oracle HTML Quoting. Yes activates the 
Tasks functionality. No deactivates it. The default value 
is No.

Oracle Sales Online must be installed before the Tasks 
functionality can be activated.

Table 5 IBE Profile Options for Oracle HTML Quoting Functionality (Cont.)

Name Description
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