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Preface

This implementation guide describes the implementation and administration of 
Oracle iSupport, Release 11.5.5.

Topics include:

■ Intended Audience

■ Other Sources of Information

■ Structure

■ Documentation Accessibility

Intended Audience
This guide is aimed at the following users:

■ Technical Service Representatives (TSR)

■ Customer Service Representatives (CSR)

■ System Administrators (SA), Database Administrators (DBA), iSupport 
Administrators (ISA), and other IT professionals who are responsible for 
implementing and maintaining Oracle iSupport. 

This guide assumes you have the following prerequisites:

Note: To obtain the most recent documentation for this product, 
visit OracleMetaLink at http://metalink.oracle.com (use keywords: 
ibu, iSupport, documentation).
ix



■ Understanding of the company business processes.

■ Knowledge of products and services as defined by your marketing policies.

■ Basic understanding of Oracle applications and Developer/2000.

■ Basic understanding of SQL, PL/SQL, SQL* Plus programming.

Other Sources of Information/Getting Help
Oracle iSupport shares business and setup information with other Oracle 
Applications products. Therefore, you will need to refer to other user guides when 
you set up and use Oracle iSupport. Documentation that is not available on your 
Documentation Library CD can be found on Oracle MetaLink 
(http://metalink.oracle.com). You can download some softcopy documentation 
from http://docs.oracle.com, or you may purchase bound copies from the Oracle 
Store (http://oraclestore.oracle.com

For a list of suggested guides, please see Appendix A, Getting Help/Additional Information.

Structure
This guide is organized into the following chapters:

■ Chapter 1 provides an overview of the Oracle iSupport application.

■ Chapter 2 discusses dependencies and implementation considerations.

■ Chapter 3 discusses users and user management, roles and responsibilities.

■ Chapter 4 details setting up the Service Request function.

■ Chapter 5 details setting up the Transactional Inquiries function.

■ Chapter 6 discusses the set up of the Knowledge Management function and 
MES setups for the Homepage.

■ Chapter 7 details setting up the Products function.

■ Chapter 8 contains setup details for the Forums function.

■ Chapter 9 contains details on how to set up the Homepage.

■ Chapter 10 covers User Communications setups.

■ Chapter 11 discusses system profile options and concurrent programs.

■ Appendix A can be used as a resource for additional information and help.
x



Documentation Accessibility
Oracle’s goal is to make our products, services, and supporting documentation 
accessible to the disabled community with good usability. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be 
accessible to all of our customers. For additional information, visit the Oracle 
Accessibility Program web site at http://www.oracle.com/accessibility. 
xi
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Oracle iSupport 11i Overview

This chapter provides an overview of the features and architecture of Oracle 
iSupport 11i. Topics include:

■ Product Overview

■ Architectural Overview

■ Hardware Requirements

1.1 Product Overview
Oracle iSupport is an Internet-based customer support application that enables 
merchants to provide self-service customer support online. Oracle iSupport 
functionality allows organizations to provide users with multiple sources of 
product information and problem solutions if optional applications are 
implemented. Integration with other Oracle products gives users the ability to 
manage their own service needs.

Oracle iSupport implementation, including all optional products, can reduce service 
costs, consolidate service and product information, and allow service personnel to 
focus on non-repetitive customer requests, thus increasing customer satisfaction 
and product viability.

Key features and benefits of Oracle iSupport include the following:

■ An optional Service Request system integrated with other Oracle products 
allows users to submit and manage their customer service requests online. 
Close integration with Oracle Installed Base and Oracle Contracts Suite allows 
access to product and contract history if elected by the merchant.

■ Optional integration with a powerful Knowledge Management system 
facilitates access to known problem solutions, while implementation of the 
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Product Overview
Marketing Encyclopedia System (MES) provides access to white papers, user 
guides, technical documentation, and valuable Homepage content.

■ The Installed Base, when implemented, allows customers to maintain a 
database of their product purchases, including product details, configurations, 
and service agreements.

■ Optional Transactional Inquiries allow customers to view the history and status 
of purchases, invoices, payments, and shipments, and to create return material 
authorizations (RMAs).

■ Forums allow customers to search for information, post questions, and share 
product knowledge with other users.

■ The Homepage can contain information such as links to Service Requests, 
Alerts, and Company News. The merchant is then able to decide what 
mandatory and optional content to offer. This content requires the setup of 
optional modules.

■ The Quick Link functionality permits users to bookmark essential links within 
the Oracle iSupport application. Frequently-used resources are immediately 
available.

■ Alerts and subscriptions provide notifications to customers of specific events, 
updates, and promotions. The alerts and subscriptions are displayed in the 
Company News and Alerts bins on the Homepage and require optional setups.

1.1.1 Service Request Management
Oracle iSupport enables customers to view, create, modify, and escalate Service 
Requests online, if the merchant sets up the Service Request functionality (see 
Chapter 4, Set up Service Requests). Once the information has been entered, it is 
validated by Oracle Customer Support-TeleService and assigned a unique tracking 
number for future reference. Merchants can enforce product selection and/or 
knowledge base searching during the Service Request process.

A typical business scenario might be:

■ Customer logs in to Oracle iSupport.

■ Customer accesses Create Service Request and enters contact and Service 
Request detail information. Customer sets up optional Service Request Profile 
to aid in submitting Service Request.

■ Customer queries Knowledge Base directly for troubleshooting help prior to 
creating a new request.
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Product Overview
■ Once the Service Request is submitted, the system returns a tracking number to 
the customer; customers can add a Service Request link to their Homepage.

■ Customers may view, close, update, or escalate their Service Requests at any 
time. They may also attach documents to the Service Request.

Note: This functionality is only available if the merchant sets up Service Request 
(see Chapter 4, Set up Service Request).

1.1.2 Knowledge Management and Marketing Encyclopedia System
Knowledge Management and Marketing Encyclopedia System (MES) 
implementation allow access to the known problems/solutions database, and 
allows users to locate technical documents, including white papers, user guides, 
and FAQs. The merchant benefits by increased knowledge among customers and 
reduced call center activity. The Knowledge Management and MES user interfaces 
are easy to use and feature flexible search capabilities.

A typical business scenario might be:

■ Customer logs in to Oracle iSupport. Customer views Alerts and Company 
News on the Homepage.

■ Customer accesses the optional knowledge base from the Homepage or by 
using the Support page.

■ Customer uses either basic or advanced search functions to locate answers.

■ Customer views solution detail, and can add link to the Homepage if desired.

Note: This functionality is only available if the merchant sets up Knowledge 
Management (see Chapter 6, Set up Knowledge Management).

1.1.3 Transactional Inquiries: Account Management
Oracle iSupport’s optional Transactional Inquiries functionality allows users to view 
detailed transaction history and status. Integration with Oracle Order Management 
and Oracle Order Capture allows a user to view orders, invoices, payments, and 
shipping information, as well as to create return material authorizations (RMAs). 
Integration with Oracle Contracts for Service (if implemented) provides a view of 
contracts, entitlements validation, and customer service programs and warranties. 
Customers can also query and sort data by a range of criteria. 

A typical business scenario might be:

■ Customer logs in to Oracle iSupport.
Oracle iSupport 11i Overview 1-3



Product Overview
■ Using the Accounts tab, the customer has online, real-time access to complete 
information regarding account issues, including:

■ Orders and shipments

■ Invoices and payments

■ Contracts

■ Returns

■ In addition, Service Requests can also be accessed from the Account tab.

This functionality allows customers to service their own account needs, requesting 
information by date or transaction identifiers, e.g. payment amount, invoice 
number, and customer name.

Note: This functionality is only available if the merchant sets up Transactional 
Inquiries (see Chapter 5, Set up Transactional Inquiries).

1.1.4 Installed Base: Product Management
The Installed Base is a repository of customer purchase information, including 
purchase date, product attributes, and applicable service agreements. Installed Base 
maintains information about purchased products in a tree structure showing all of 
the parent and child assemblies. It allows users to drill down to view detailed 
product information. Installed Base tracks, updates, and maintains product 
configurations whenever a new part or component is installed or replaced. It also 
allows the grouping of customer products into systems for ease of service. The 
Installed Base tracks serialized and non-serialized products and provides powerful 
search capabilities. Product returns are automatically updated in the Installed Base 
upon RMA receipt. Support organizations benefit from having customers who are 
informed about their transaction and product histories and applicable contracts.

A typical business scenario might be:

■ Customer logs in to Oracle iSupport.

■ Customer accesses optional Installed Base from the Products tab.

■ Customer may review Product Summary, Add Product or Request a Product 
Report. Users manage and track products themselves online, decreasing calls to 
customer service centers and increasing customer control over service issues.

Note: This functionality is only available if the merchant sets up Installed Base (see 
Chapter 7, Set up Products).
1-4       Oracle iSupport Implementation Guide
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1.1.5 Online Forums: Information Exchange
Oracle iSupport Forums are online message boards where customers can post 
questions and comments and review those from other users. Forums enable 
customers to share information. In Oracle iSupport, users can search for specific 
subjects or browse within a particular Forum. Oracle iSupport allows merchants to 
create, manage or delete Forums.

A typical business scenario might be:

■ Customer logs in to Oracle iSupport.

■ Customer accesses Forums tab to view available Forum categories and 
subcategories. The structured use of Forums can reduce calls to customer 
service by providing users another source of product information and problem 
solutions.

■ Advanced Search allows users to query Forums by keywords, category, date, 
message status, and author. This flexibility makes Forums extremely useful as 
an evolving knowledge capture tool.

Note: This functionality is only available if the merchant sets up Forums (see 
Chapter 8, Set up Forums).

1.2 Architectural Overview
Oracle iSupport architecture is a 3-tier system comprised of:

Data Tier - The data tier includes Oracle ERP and CRM main tables which comprise 
their common schema. These are driven by the Oracle 8i database. Most of the CRM 
application business logic that is written in PL/SQL are also in the data tier.

Application Tier - The application tier uses business logic APIs and CRM 
Foundation services, Java Server Pages (JSP), and Java APIs. In addition, the Oracle 
Application Object Library (AOL) supplies technology and common libraries for the 
applications. In Oracle applications, Internet Application Server (iAS) drives this 
tier and the Presentation tier discussed below.

Presentation Tier - Generated Java code and compiled servlet code utilize JSP 1.0 
and Servlet 2.0 to form the presentation tier. In Oracle applications, the Apache 
Server 1.3.9 drives this tier.

The diagram below depicts this 3-tier structure.
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Figure 1–1 Oracle iSupport Architecture

1.3 Hardware Requirements
The suggested hardware configuration for Oracle iSupport 11i is a series of web 
servers in the front and a high performance database server machine in the back 
end. With global systems, the necessity for high performance database servers is 
even greater.

Oracle recommends the following server requirements:

■ ERP database server machine - high throughput at fast speed (CPU)

■ Web servers running Apache for external customers

■ One forms server for administration

You can determine the actual sizing of the machines after completing capacity 
planning.

Specific hardware requirements depend on the particular installation that you 
perform. The hardware requirements listed in the following table are guidelines 
only, and assume a single-node Vision demo environment.
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Table 1–1 Minimum Hardware Requirements

Hardware Requirement

CPU 2 CPUs minimum, 4 or more highly recommended

Memory 1GB minimum

Disk Space 22GB, including 1GB in /tmp (plus an additional 9GB if 
installing from a staging area)
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Dependency Overview

This chapter describes in general terms the installation setup dependencies for 
Oracle iSupport 11i. Specific, step-by-step setup tasks begin in later chapters. Topics 
include:

■ Implementation Considerations

■ Mandatory Modules

■ Optional Modules

■ Integration Points with other Oracle Applications

■ Oracle iSupport Footprint

■ Suggested Implementation Checklist

2.1 Implementation Considerations
Since Oracle iSupport is comprised of several functional modules, merchants have 
the flexibility to choose which modules to implement, based on their organizations’ 
desires and specific requirements. Oracle iSupport’s optional dependent modules 
and functional areas, along with their associated chapters, are:

■ Service Requests - Chapter 4

■ Transactional Inquiries (Accounts) - Chapter 5

■ Knowledge Base - Chapter 6

■ Products (Installed Base) - Chapter 7

■ Forums - Chapter 8

■ Homepage - Chapter 9
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Mandatory Modules
■ Call Me, Surveys/Feedback - Chapter 10

■ Users and User Management - Chapter 3

■ Profile Options - Chapter 11

■ Concurrent Programs - Chapter 11

Setup information for each of these modules/functional areas is presented in the 
following chapters.

2.2 Mandatory Modules
Oracle iSupport relies on several Oracle ERP and CRM modules for its data and 
functionality. The modules that must be installed and set up for Oracle iSupport to 
function properly are discussed in the following paragraphs. For minimum 
hardware requirements, refer to Chapter 1 of this guide, Product Overview.

2.2.1 Oracle Application Object Library
The Oracle Applications Object Library (AOL) is a required dependency of all 
Oracle applications. Supplying technology and common libraries for Oracle 
applications, AOL allows user creation, responsibility creations and maintenance, 
and the linkage of users to responsibilities. AOL also contains Oracle Workflow, an 
application which is necessary for the processing and monitoring of workflow 
items. AOL and Workflow are contained on the Rapid Install CD.

2.2.2 Oracle CRM Foundation
CRM Foundation 11i supplies much of the data and functionality for Oracle 
iSupport. CRM Foundation consists of: System Administrator Console, Task 
Manager, Notes, Resource Manager, Calendar, Territory Management, Interaction 
History, 1-to-1 Fulfillment, Assignment Manager, and Escalation Management. See 
Appendix A, Getting Help/Additional Information, for related documentation.

2.2.3 Oracle Service
Oracle Service contains the Knowledge Management and Installed Base 
applications. See Appendix A, Getting Help/Additional Information, for related 
documentation.
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2.3 Optional Modules
The following are optional but highly recommended modules that allow Oracle 
iSupport to utilize additional data and improve functionality. 

2.3.1 Oracle Customer Support - TeleService
Oracle Customer Support - TeleService contains the Service Request functionality 
that allows customers to submit, view, edit, and manage their service requests 
online. See Appendix A, Getting Help/Additional Information, for related 
documentation.

2.3.2 Oracle Contracts Suite
Oracle iSupport relies on Oracle Contracts Suite to provide information on 
entitlements, service contracts, warranties and extended warranties, service 
technician assignment status, and response commitments for Oracle iSupport. The 
Contracts Suite is comprised of:

Contracts Core - Contracts Core is both an application that provides supporting 
master agreements, and a foundation for all other Contracts modules. The generic 
functionality required by all types of contracts is contained in the Contracts Core 
foundation layer, e.g., contract access control, renewal, termination, and notification 
management.

Contracts for Service - Contracts for Service creates and manages service contracts, 
warranties and extended warranties; provides visibility to contract entitlements and 
proactively acts upon contractual commitments within the contract. Contracts for 
Service builds upon the foundation of the Contracts Core and adds functionality to 
meet the specific needs of the service industry, e.g., coverage terms, entitlement 
checking.

See Appendix A, Getting Help/Additional Information, for related documentation.

2.3.3 Oracle Order Management/Order Capture
Part of the Oracle ERP suite of applications, Oracle Order Management provides 
Oracle iSupport with order and returns history. Oracle Order Capture is the CRM 
interface to Order Management. Without these products, customers utilizing Oracle 
iSupport will not be able to view their orders, payments, invoices, shipping details, 
returns, or place returns. See Appendix A, Getting Help/Additional Information, 
for related documentation.
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2.3.4 Oracle Accounts Receivable
Oracle Accounts Receivables provides invoice and payments data within Oracle 
iSupport. See Appendix A, Getting Help/Additional Information, for related 
documentation.

2.3.5 Oracle MultiMedia Channel Manager
The web call-back feature of Oracle iSupport is dependent upon the Oracle 
MultiMedia Channel Manager application. See Appendix A, Getting 
Help/Additional Information, for related documentation.

2.3.6 Oracle Scripting
Oracle Scripting is a CRM application that provides call-center agents with pop-up 
scripts during support calls. Scripting also allows merchants to get feedback from 
their customers. Scripting must be installed for the Surveys functions within Oracle 
iSupport to work. See Appendix A, Getting Help/Additional Information, for 
related documentation.

2.3.7 Human Resources Management System
Oracle Human Resources Management System (HRMS) provides default resource 
ID data for Service Requests within Oracle iSupport. See Appendix A, Getting 
Help/Additional Information, for related documentation.
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2.4 Oracle iSupport Footprint

Figure 2–1 Oracle iSupport Footprint

2.5 Integration Points for Functional Areas
Below is a list of the applications that Oracle iSupport calls from when performing 
various functions.

2.5.1 Users and User Management
■ Login (single sign-on) - CRM Foundation (JTF)

■ Register a new user - CRM Foundation (JTF)

■ Assign user responsibilities and roles - CRM Foundation (JTF)

2.5.2 Service Request
■ Create service request - Oracle Customer Support-TeleService

■ Update service request - Oracle Customer Support-TeleService

■ Close service request - Oracle Customer Support-TeleService

■ Escalate service request - Oracle Customer Support-TeleService
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■ Attach file to service request - CRM Foundation (JTF)

■ View service requests - Oracle Customer Support-TeleService

■ E-mail confirmation of service request - Workflow Mailer

2.5.3 Transactional Inquiries
■ View invoices - Oracle Accounts Receivable

■ View payments - Oracle Accounts Receivable

■ Create returns - Oracle Order Capture - Order Management

■ View returns - Oracle Order Management

■ View orders - Oracle Order Management

■ View shipments - Oracle Order Management

■ Verify customer entitlements - Oracle Contracts for Service

■ View contracts - Oracle Contracts for Service

2.5.4 Knowledge Management
■ Search knowledge base - Oracle Service/Knowledge Management

■ Search solutions in Solution Management System (SMS) - Oracle 
Service/Knowledge Management

■ View solutions in SMS - Oracle Service/Knowledge Management

■ Identify product symptom - Oracle Service/Knowledge Management

■ Create solution - Oracle Service/Knowledge Management

2.5.5 Products
■ View serviceable products - Oracle Inventory/Installed Base

■ View product configuration information - Installed Base

■ View Installed Base - Installed Base

■ Update Installed Base - Installed Base
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2.5.6 Forums
■ All functions - Oracle iSupport

2.5.7 Homepage
■ View company news - Marketing Encyclopedia System (MES)

■ Publish company news - Marketing Encyclopedia System (MES)

■ View Alerts - Marketing Encyclopedia System (MES)

■ View collateral documents - Marketing Encyclopedia System (MES)

■ View Service Requests - Customer Support-TeleService

2.6 Suggested Implementation Checklist
Below is a recommended checklist for implementing Oracle iSupport.

Table 2–1 Implementation Checklist

Step Required Description

1 Required Set up Forms application sysadmin functions, such as 
Responsibilities, Menus, Profile Options

2 Required Set up Key Flexfields

3 Required Set up Languages, Currencies, Set of Books

4 Optional Set up Organizations

5 Optional Define Your Employees

6 Optional Confirm Setup of Oracle Inventory & Serviceable Items

7 Optional Confirm Setup of BOM

8 Optional Confirm Setup of Advanced Pricing

9 Optional Confirm Setup of Order Management

10 Optional Confirm Setup of Accounts Receivables

11 Optional Confirm Setup of Order Capture Profile Options

12 Optional Confirm Setup of Shipping

13 Optional Confirm Setup of Workflow

14 Required Confirm Setup of Resources
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15 Required Confirm Setup of Notes

16 Optional Confirm Setup of Knowledge Management & MES

17 Optional Confirm Setup of Installed Base

18 Optional Confirm Setup of Contracts Core

19 Optional Confirm Setup of Service Contracts

20 Optional Confirm Setup of Oracle Scripting

21 Optional Confirm Setup of MultiMedia Channel Manager

22 Optional Confirm Setup of Oracle Customer Support-TeleService

23 Required Set up JTF HTML Stack

24 Required Set up Roles, Permissions

25 Required Set up Oracle iSupport Users

26 Required Set up default responsibilities for end and business users

27 Optional Assign additional roles, responsibilities to users

28 Optional Set up Service Request in iSupport

29 Optional Set up Knowledge Management and MES in iSupport

30 Optional Set up Transactional Inquiries in iSupport

31 Optional Set up Forums in iSupport

32 Optional Set up Homepage in iSupport

33 Required Set up iSupport System Profile Options

Table 2–1 (Cont.) Implementation Checklist

Step Required Description
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Users and User Management

This chapter details how to access the Oracle iSupport application, and discusses 
user management issues. Topics include:

■ Login Interfaces

■ Responsibilities, Roles, and Permissions

■ Types of Users

■ Steps to Create Users

3.1 Login Interfaces
There are two types of login interfaces within Oracle applications - the Oracle 
Applications Forms login, common to all Oracle applications, and the HTML JTF 
login screen. The Forms-based applications utilize Oracle Developer 2000, while the 
HTML applications present the JTF interface to the customer.

3.1.1 Oracle Applications Forms Login
Oracle Applications Forms is a forms-based area where the System Administrator 
(SA) controls a variety of parameters relating to Oracle iSupport. This is where the 
merchant assigns responsibilities to the Oracle iSupport Administrator. See 
Appendix A, Getting Help/Additional Information, for related documentation.

3.1.2 JTF (HTML) Console
The JTF console is where all users log in to access Oracle iSupport and other 
HTML-based applications. The menus that appear after login depend upon the 
roles and responsibilities assigned to the user logging in. Users will be unable to 
access application functionality until they have been assigned both roles and 
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responsibilities. See Appendix A, Getting Help/Additional Information, for related 
documentation.

3.2 Roles, Responsibilities, and Permissions
During the implementation process and throughout the Oracle iSupport 
application’s lifespan, it will be necessary for the merchant (as system 
administrator) or the Oracle iSupport Administrator to define application users 
with appropriate roles, responsibilities, and permissions. This section discusses the 
terms roles, responsibilities, and permissions. 

You allow a new user to sign–on to Oracle iSupport (or any Oracle Application) by 
defining an application user. An application user has a username and a password. 
You define an initial password, then the first time the application user signs on, the 
user must enter a new (secret) password. 

Responsibilities define Application Privileges, controlling the presentation of 
menus, tabs, and screens. For example, the responsibility IBU_SYS_ADMIN gives 
that user access to a different set of menus than the responsibility IBU_NORMAL_
USER given to Regular Users. When you define an application user, you assign to 
the user one or more responsibilities. If you assign only one responsibility, the user, 
after signing on, immediately enters an application. If you assign two or more 
responsibilities, the user, after signing on, sees a window listing available 
responsibilities.

A role is a collection of page- and function-level permissions that are granted to 
maintain application security. A permission is the smallest unit making up a role. 
There are two types of permissions - Functional and Data Access Control (DAC). 
Permissions dictate exactly which actions the user can perform.

Refer to Oracle Applications System Administrator’s Guide for more information. See 
Appendix A, Getting Help/Additional Information, for other related 
documentation.

3.2.1 Oracle iSupport Seeded Roles
The table below, Seeded Roles, lists the roles that are seeded within the application 
and a description for each role type.

Note: All roles and responsibilities associated with the Oracle 
iSupport application contain the prefix IBU.
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3.2.2 Oracle iSupport Seeded Responsibilities
All seeded responsibilities for all users in Oracle iSupport are IBU_NORMAL_
USER.

3.2.3 Roles and Responsibilities by User Type
The table below, Roles and Responsibilities by User Type, list the various types of 
users within Oracle iSupport, and their associated roles and responsibilities.

Table 3–1 Seeded Roles

Role Description

IBU_REG_USER Oracle iSupport regular user role: normal user functions

IBU_USER_
MANAGEMENT

Oracle iSupport primary user role: normal user functions and 
in addition can create and approve new users

IBU_SYS_ADMIN Oracle iSupport System Administrator role: sysadmin for 
Oracle iSupport role

IBU_EMPLOYEE Future release

IBU_GUEST_USER Future release

IBU_MANAGER Future release

IBU_SELF Future release

Table 3–2 Roles and Responsibilities by User Type

User Type Role Responsibility

Regular User IBU_REG_USER IBU_NORMAL_USER

Primary User IBU_REG_USER, IBU_USER_MANAGEMENT IBU_NORMAL_USER

iSupport 
SysAdmin

IBU_SYS_ADMIN, IBU_REG_USER, IBU_USER_
MANAGEMENT

IBU_NORMAL_USER
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3.3 Types of Users
For the purposes of utilizing Oracle applications, users are categorized into various 
types. User types relate to the application functionality that the users will be 
accessing. Companies implementing Oracle iSupport will receive a System 
Administrator (SA) login for the HTML and Forms-based applications. Steps for 
creating users begin in Section 3.4 below.

There are two required user types that the merchant implementing Oracle iSupport 
must set up: 

■ Oracle iSupport Administrator

■ Oracle iSupport Regular User

In addition to these two mandatory types, the merchant can optionally set up a 
Primary User and a Knowledge Management User. All of these user types are 
discussed below.

3.3.1 Oracle iSupport Administrator
The merchant implementing Oracle iSupport will use the SA login to set up the 
Oracle iSupport Administrator. This is a required user. The Oracle iSupport 
Administrator is a user chosen by the merchant to perform routine but high-level 
administrative tasks, such as:

■ Assigning roles and responsibilities to other users

■ Approving business users

■ Setting up the Homepage layout and content

■ Setting up the Service Request system

■ Setting up Product Installed Base

Note: Depending upon the version of Oracle iSupport that you are 
using, you may have, instead of IBU_USER_MANAGEMENT, the 
role of IBU_B2B_PRIMARY_USER_MANAGEMENT. These two 
roles function identically, but which role shows up will depend 
whether you are running the application with additional patchsets. 
For iSupport patch information, please visit Oracle MetaLink at 
http://metalink.oracle.com.
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■ Setting up Knowledge Management and MES

■ Setting up Transactional Inquiries functionality

■ Setting up Forums and Usergroups

3.3.2 Oracle iSupport Regular User
A Regular User covers all general users to Oracle iSupport. These can be either 
business-to-business (B2B) users, referred to in the registration process as Business 
Users, or business-to-customer (B2C) users, referred to in the registration process as 
End users. This user type is required.

■ B2B users represent customer organizations (for example, employees of the 
company using Oracle iSupport). When they register in Oracle iSupport, they 
must be approved by the merchant or a merchant representative. The merchant 
can then set roles and responsibilities for this user.

■ B2C users are individual customers. When they register in Oracle iSupport, they 
are immediately approved and can access the application. The merchant can set 
default roles and responsibilities for this user.

3.3.3 iSupport Primary User
User set up to approve other users, in order to assist the Oracle iSupport 
Administrator in this task. This function can be used as the customer site 
administrator if needed, limited to approving new users and resetting passwords.

3.3.4 Knowledge Management (KM) Admin User
This is a user who performs Knowledge Management and Marketing Encyclopedia 
System setup and management. This user is required only if the merchant will use 
the Knowledge Management functionality. For more information, see Chapter 6 of 
this guide, Set up Knowledge Management and MES.

3.4 Steps to Create Users
Below are step-by-step instructions for creating the two mandatory users (the 
Oracle iSupport Administrator and a Regular User) and the optional Primary User.
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3.4.1 Create the Oracle iSupport Administrator
The first task in creating the Oracle iSupport Administrator is to register the user in 
Oracle iSupport through the following steps:

1. At the JTF login page, click the Register Here link. This can be done by the user. 

2. Enter required information on the User Registration form. Make a note of the 
username and password. 

3. Select Business User from the drop-down list. 

4. Select Submit. The User Registration Continued screen appears.

5. Enter the Company ID (account) in the appropriate box. 

6.  Select Submit.

3.4.1.1 Approve Oracle iSupport Administrator
The next step is to approve the user within Oracle iSupport:

1. Log in to the JTF login page as sysadmin.

2. Navigate to Registration > Approval > Pending Requests.

3. In the Pending Requests screen, select the username.

4. Select the Assign Accounts button. Choose the account(s) to associate with the 
user. 

5. Select Update.

3.4.1.2 Associate Roles to Oracle iSupport Administrator
The next step is to associate the appropriate roles to the Oracle iSupport 
Administrator:

1. Log in to the JTF login page as sysadmin.

2. In the list of users, select the user just created. The User Details screen appears.

3. Select Roles. In the User-Role Mapping window select, IBU_SYS_ADMIN from 
the Available Roles list and click Assign (>). Repeat this step to assign IBU_
REG_USER and IBU_USER_MANAGEMENT.

4. Select Update.
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3.4.1.3 Associate Responsibility to Oracle iSupport Administrator
The next step is to associate the responsibility of IBU_NORMAL_USER to the 
Oracle iSupport Administrator. This task is done using Oracle Applications 
(Forms).

1. Log in to Oracle Applications (Forms) as sysadmin. When the Java applet has 
loaded, select the System Administrator responsibility. 

2. In the System Administrator Navigator window, open the Responsibilities form 
by choosing Security > Responsibilities > Define.

3. Press F11 for query mode and enter the responsibility IBU_NORMAL_USER in 
the Responsibility Name field.

4. Execute the query by pressing Control F11. The data for the IBU_NORMAL_
USER responsibility is displayed.

5. From the menu choose Help > Diagnostics > Examine.

6. Select the List of Values (LOV) for the field. Select the field APPLICATION_ID 
and click OK. The Value for the APPLICATION_ID should always be 672. (672 
is the internal application ID for Oracle iSupport.)

7. Click the LOV for the Field and select the field RESPONSIBILITY_ID.

8. Make a note of the Value for the RESPONSIBILITY_ID, and select Ok.

9. From the menu select Field > Close Form.

10. In the System Administrator Navigator, select Profile > System and open. In the 
Find System Profile Values screen check the User checkbox and accessing the 
LOV, select the username you created.

11. Uncheck the Profiles with no Values checkbox and enter JTF%PROFILE% in the 
Profile field. Select Find.

12. Ensure that the JTF_PROFILE_DEFAULT_APPLICATION for the user is set to 
672. If it is not, change it.

13. Set the JTF_PROFILE_DEFAULT_RESPONSIBILITY to the RESPONSIBILITY_
ID number identified above.

14. Click the diskette icon at the top of the screen to save and close the form.

15. Open the Users form by selecting Security > Users > Define.

16. Press F11 and enter the username. Press Control F11 to query user.
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17. Assign the user IBU_NORMAL_USER responsibility by placing the cursor in 
the Responsibility field of the first blank record.

18. Click Save; then close all forms and exit the application.

3.4.1.4 Verify Oracle iSupport Administrator Creation
1. At the JTF login page, login as the user just created.

2. Verify that appropriate menus are displayed. 

Note: The default landing page will be the user Homepage if you have assigned 
IBU_NORMAL_USER responsibility to the Oracle iSupport Administrator. This 
is where all user tabs are accessible. To view Oracle iSupport 
Administrator-specific tabs, select the Administration button.

3.4.2 Create iSupport Regular User
General users in Oracle iSupport will have the basic role IBU_REG_USER assigned 
to them.

Note: Users will not be able to access Oracle iSupport until they have the 
appropriate roles and responsibilities assigned to them.

3.4.2.1 Register Regular User
The first step is to register the user in Oracle iSupport.

1. At the JTF login page, click the Register Here link. This can be done by the user. 

2. Enter required information on the User Registration form. Make a note of the 
username and password.

3. Select End User if this user is an individual consumer. Select Business User if 
the user is a member of a company. 

Note:  End Users will be approved automatically by the application. Business 
Users require approval by a user with user management priviledges.

4. Select Submit. The User Registration Continued screen appears.

5. If you know the Company ID (account), enter it in the appropriate box. If not, 
select the I do not have my company id radio button and enter the required 
company information in the textboxes.

Note: If the user’s company is already registered, you must enter the Company 
ID number. The application will prevent your selecting the I do not have my 
company id radio button option if the company already exists in the database.
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6.  Select Submit.

3.4.2.2 Approve Regular User
The next step is to accept the user’s registration within Oracle iSupport. Note: If this 
is an end user, you will not need to perform this step - end users are automatically 
approved.

1. Log in to the JTF login page as Oracle iSupport Administrator.

2. Navigate to User > Pending Approvals.

3. In the Pending Approvals window, select the user by clicking the checkbox to 
the left of the username. 

4. Select Approve. 

3.4.2.3 Associate Role to Regular User
The next step is to associate a role to the user. At a minimum, each user must be 
assigned the IBU_REG_USER role.

1. Log in to the JTF login page as the Oracle iSupport Administrator.

2. Navigate to the User tab. A list of users appears. Select the appropriate 
username if it is visible. If it is not visible, search for the user.

To search for a user, use the Find Users drop-down menu to choose User Name, 
Last Name, or First Name. Enter the appropriate name in the search box. Select 
Go. Select the username when found.

3. At the User Details screen, select Roles.

4. In the User Role Mapping window select IBU_REG_USER. A confirmation 
message will appear.

3.4.2.4 Associate Responsibility to Regular User
The next step is to associate basic responsibility to the user.

1. As Oracle iSupport Administrator, navigate the User tab.

2. Select the user from the step above.

3. In the User Details screen, select Responsibilities.

4. In the Responsibilities screen, select the underlined link, Select, in an empty row 
to access the List of Values (LOV). 
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5. In the Find Responsibilities screen, select IBU_NORMAL_USER. The 
Responsibilities screen will reappear with the IBU_NORMAL_USER 
responsibility listed. 

6. Select Save. The Responsibilities screen will refresh.

7. Make the IBU_NORMAL_USER the default responsibility by selecting the radio 
button in the default column next to the IBU_NORMAL_USER responsibility.

8. Select Save and/or Finished to return to the User Details screen.

3.4.2.5 Verify Regular User Creation
1. At the JTF login page, login as the user from the previous regular user steps.

2. Verify that menus are functioning properly as for a Regular User.

A Regular User will be able to view and access the following tabs: Home, 
Account, Products, Support, and Forums, as well as the following buttons: 
iSupport, Profile, and Sign Out. A Regular User will not be able to access 
administrative functions through the Administration button at the top of the 
screen.

3.4.3 Primary User Role
The SA or the Oracle iSupport Administrator may choose to set up a Primary User 
who can function to approve other users and reset passwords. Depending on the 
size of your company, the number of users waiting approval and/or password 
resetting may be significant. In this case, setting up another user as a Primary User 
frees the SA and the Oracle iSupport Administrator to perform other tasks. You can 
set up as many Primary Users as you wish.

3.4.3.1 Register Primary User
The first step is to register the user in Oracle iSupport.

1. At the JTF login page, click the Register Here link. This can be done by the user. 

2. Enter required information on the User Registration form. Make a note of the 
username and password. 

3. Select Business User from the drop-down list. 

4. Select Submit. The User Registration Continued screen appears.

5. Enter the Company ID (account) in the appropriate box. 

6.  Select Submit.
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3.4.3.2 Approve Primary User
The next step is to accept the user’s registration within Oracle iSupport. .

1. As Oracle iSupport Administrator, navigate to User > Pending Approvals.

2. In the Pending Approvals window, select the user by clicking the checkbox to 
the left of the username. 

3. Select Approve. 

3.4.3.3 Associate Roles to Primary User
The next step is to associate the IBU_USER_MANAGEMENT and IBU_REG_USER 
roles to the Primary User.

1. As Oracle iSupport Administrator, navigate to the User tab.

2. Select the user you created in the previous step.

3. In the User Details screen, click Roles.

4. In the Roles screen select IBU_USER_MANAGEMENT and IBU_REG_USER.

5. Select Save.

3.4.3.4 Associate Responsibility to Primary User
The next step is to associate IBU_NORMAL_USER responsibility to the Primary 
User.

1. As the Oracle iSupport Administrator, navigate the User tab. 

2. Select the User created above.

3. In the User Details screen, select Responsibilities.

4. Click on Select to access the List of Values (LOV). Choose IBU_NORMAL_
USER. Select Save.

5. In the Default column, click the radio button next to the responsibility. 

6. Select Save.

3.4.3.5 Verify Primary User Creation
1. At the JTF login page, login as the Primary User just created. Or, have the new 

user login.

2. Verify that menus are functioning properly. A Primary User will be able to view 
and access the user management screens: accept users on the system 
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administration registration tab and change passwords using the system 
administration profile button. 

3.5 User and Registration Process Terms Defined
Below are definitions for common terms associated with users and the registration 
process.

Business User - A user of a business party that is not a Primary User. This type of 
user requires approval by the System Administrator or Primary User.

Individual User - A user of a business party that is not a Primary User. This type of 
user does not require approval.

Merchants - Refers to Oracle e-business suite customers. Used to alleviate confusion 
with the term customers, which refers to customers of a business using Oracle 
products.

Primary User - A designated person of an external organization (for example, a 
business partner) or an internal group (for example, sales department) who can be 
responsible for approving other users and resetting passwords.

Registration - Refers to the process by which any user would gain access to some 
application functionality.

Registration Admin UI - User Interface (UI) used by merchant administrator or any 
person granted privileges to maintain users and accounts.

Registration Self-Service User UI - User Interface (UI) that is used by individual users 
or business users to register themselves.

Responsibilities - A grouping of application menus that determine the user interface 
accessible to a particular user.

Roles - Groupings of permissions which are page- and function-level, granular 
privileges used to maintain application security.

Self-Service Registration - Refers to the process of users registering themselves 
through a self-service UI, as opposed to being registered by an administrator. 
Self-service registration includes the UI and background processes used to complete 
the registration processes (including assigning users the appropriate data access 
and UI access privileges).

User - Refers to any person who needs access to any application. This includes 
various types of customers, partners, suppliers, and employees.
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User Types - Users are categorized into types based on their registration 
requirements and access privileges. User types are associated with default roles, 
responsibilities, accounts, registration templates, and approval requirements.
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Set up Service Request

This chapter details how to set up the Service Request function of Oracle iSupport. 
Topics include:

■ Use Service Request: Considerations

■ Set up Basic Functionality

■ Set up Products

■ Set up Knowledge Management

■ Set up E-mail Submission

■ Disable Menu (for those not implementing Service Request)

4.1 Use Service Request: Considerations
Once you decide that you are going to use Service Request, you must set up its basic 
functionality. In addition, you can choose to implement one or all of these 
additional functions: 

■ Allow and/or enforce product selection. 

■ Allow and/or enforce knowledge base search.

■ Allow e-mail submission of Service Request details.

The diagram shown below - Service Request Implementation Decision Flowchart - 
depicts the decision points and setup flow for the various options.
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Figure 4–1 Service Request Implementation Decision Flowchart

4.2 Set up Oracle Customer Support-TeleService
Prerequisite: Confirm setup of back office applications. Confirm setup of CRM 
Foundation. 

Oracle Customer Support-TeleService provides the Service Request functionality in 
Oracle iSupport. The Customer Support application has the ability -- via integration 
with other Oracle applications and agent or customer data input -- to track all issues 
reported by users. For basic Service Request functionality in Oracle iSupport, you 
must set up the Customer Support-TeleService product. Quick-start setup details 
and information are presented here, but you will also want to refer to the entire set 
of Service Request documentation. See Appendix A, Getting Help/Additional 
Information, for that documentation.

To set up basic Service Request functionality, set the following:

■ Service Request Statuses

■ Service Request Types

■ Service Request Severities

■ Service Request Urgencies

■ Service Request Problem Codes

■ Service Request Resolution Codes

■ Service Request Notetypes
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■ Service Request Profile Options

These setups are discussed below.

4.2.1 Set up Service Request Statuses
Service Request Statuses indicate the current state of the resolution of the Service 
Request. While the state of a Service Request can only be either open or closed, you 
can set statuses to indicate the status of an open or closed Service Request, such as: 

■ New

■ Assigned

■ Working

■ Waiting

■ Closed

The statuses that you set in this step become the drop-down List of Values (LOV) 
that the administrator selects from when setting up Service Request defaults later in 
this chapter, and also the LOV that the customer selects from when entering or 
updating a Service Request in the Oracle iSupport application.

Use the following procedure to set Statuses:

1. In Oracle Forms Application, Customer Support responsibility, navigate to 
Setup > Service Request > Request Status.

2. Statuses that are seeded will display in the Status column on the left side of the 
screen.

3. To define a new status, select the New Record icon in the tool bar or select File > 
New on the menu. Enter a name for the new status in the open Status field on 
the form.

4. If the new status is a closed status, select the checkbox under the Closed column 
on the form.

5. In the Start Date field, enter the date that the status will become effective. Enter 
an End Date to disable.

6. Enter a description for the status in the Description field.

7. Save your work.
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4.2.2 Set up Service Request Types
Service Request Types can be used to categorize your Service Requests and define 
Workflow processes. Typical types might be: 

■ Technical Problem

■ Installation Request

■ Information Inquiry

■ Customer Complaint

■ Helpdesk Request

■ Preventive Maintenance Visit

Use the following procedure to set Types:

1. In Oracle Forms Application, Customer Support responsibility, navigate to 
Setup > Service Request > Request Types.

2. Types that are seeded will display in the Type column on the left side of the 
screen.

3. To define a new type, select the New Record icon in the tool bar or select File > 
New on the menu. Enter a name for the new type in the open Type field on the 
form.

4. Enter a Business Process attribute if desired; this step is optional. Business 
Process attributes are used for Service Request charges and are defined in 
Installed Base under Transaction Billing Types. Examples of Business Process 
attributes are: Returns, Expenses, and Labor.

5. In the Start Date field, enter the date that the type will become effective. Enter 
an End Date to disable. 

6. Enter a description for the type in the Description field.

7. Select the Auto Launch Workflow checkbox to allow Oracle Workflow to pick 
up the Service Request. Save your work.

4.2.3 Set up Service Request Severities
Service Request Severities indicate the agent’s perception of the reported Service 
Request. The severities you set here make up the LOVs on the Service Request 
Defaults setup screen in Oracle iSupport. Typical severities include:

■ High
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■ Medium

■ Low

Use the following procedure to set severities:

1. In Oracle Forms Application, Customer Support responsibility, navigate to 
Setup > Service Request > Request Severities.

2. Severities that are seeded will display in the Severity column on the left side of 
the screen.

3. To define a new severity, select the New Record icon in the tool bar or select File 
> New on the menu. Enter a name for the new severity in the open Severity 
field on the form.

4. Enter a relative importance level, such as 1, 2, 3, or any other scheme you 
choose.

5. Enter a description of the severity in the Description field. 

6. In the Start Date field, enter the date that the severity will become effective. 
Enter an End Date to disable.

7. Save your work.

The Defect Severity field is for integration with DEMS. See Appendix A, Getting 
Help/Additional Information, for DEMS-related documentation.

4.2.4 Set up Service Request Urgencies
Service Request Urgencies indicate the customer’s perception of the reported 
Service Request. The urgencies you set here make up the LOVs on the Service 
Request Defaults setup screen in Oracle iSupport, and will be the LOVs that the 
customer selects from. Typical urgencies include:

■ Failure

■ Working

■ Question

Use the following procedure to set Urgencies:

1. In Oracle Forms Application, Customer Support responsibility, navigate to 
Setup > Service Request > Request Urgencies.

2. Urgencies that are seeded will display in the Urgency column on the left side of 
the screen.
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3. To define a new urgency, select the New Record icon in the tool bar or select File 
> New on the menu. Enter a name for the new urgency in the open Urgency 
field on the form.

4. Enter a relative importance level, such as 10, 20, 30, or any other scheme you 
choose.

5. Enter a description of the urgency in the Description field. The description field 
is the LOV that the customer will select from.

6. In the Start Date field, enter the date that the urgency will become effective. 
Enter an End Date to disable.

7. Save your work.

4.2.5 Set up Service Request Problem Codes
Service Request Problem Codes can further isolate the reason for the Service 
Request. All problem codes are user-subjective and are not required in the Service 
Request. The problem codes you setup here are become the LOV that the customer 
will select from when submitting a Service Request. Some sample problem codes 
include: 

■ Network Incident

■ Electrical Problem

■ Usability Issue

Use the following procedure to set Problem Codes:

1. In Oracle Forms Application, Customer Support responsibility, navigate to 
Setup > Service Request > Problem Codes.

2. Codes that are seeded will display in the Code column on the left side of the 
screen.

3. To define a new problem code, select the New Record icon in the tool bar or 
select File > New on the menu. Enter a name for the new code in the open Code 
field on the form.

4. Enter a meaning in the Meaning field, such as Electrical Error, Network Error, 
User Error, or any other meanings you choose.

5. Enter a description of the code in the Description field. 
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6. The Tag field allows you to associate a tag to the code if desired. This step is 
optional. The Tag field is used for reporting purposes and is a standard for 
Oracle Applications lookup codes.

7. In the Start Date field, enter the date that the code will become effective. Enter 
an End Date to disable.

8. The Enabled Indicator (checkbox) is used to control the use of the code. 

9. The Access Level should remain set to User. 

10. Save your work.

4.2.6 Set up Service Request Resolution Codes
Service Request Resolution Codes can provide further Service Request information. 
Resolution Codes are optional. Some sample resolution codes include: 

■ Reboot Servers

■ Replace Circuit

■ Send Documentation

Use the following procedure to set Resolution Codes:

1. In Oracle Forms Application, Customer Support responsibility, navigate to 
Setup > Service Request > Resolution Codes.

2. Codes that are seeded will display in the Code column on the left side of the 
screen.

3. To define a new resolution code, placed your cursor in the multi-row block (the 
small square to the extreme left of the row), select the New Record icon in the 
tool bar or select File > New on the menu. Enter a name for the new code in the 
open Code field on the form.

4. Enter a meaning in the Meaning field, such as Reboot Servers, Replace Circuit, 
Send Manuals, or any other meanings you choose.

5. Enter a description of the code in the Description field, such as Reboot network 
servers, Replace main circuit boards, Send user manuals, or whatever 
description is appropriate. 

6. The Tag field allows you to associate a tag to the code if desired. This step is 
optional. The Tag field is used for reporting purposes and is a standard for 
Oracle Applications lookup codes.
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7. In the Start Date field, enter the date that the code will become effective. Enter 
an End Date to disable.

8. The Enabled Indicator (checkbox) is used to control the use of the code. 

9. The Access Level should remain set to User. 

10. Save your work.

4.2.7 Setting up Notes
The Notes module enables the entire CRM suite to create, maintain, and                   
share notes related to customers, opportunities, service requests, and other business 
objects. Notes allows the capture of extensive, textual, project relevant information 
within Oracle CRM applications. Notes comes seeded with predefined Note Types. 
Use the following procedure to create additional, customized Note Types.

Steps
1. Log on to Oracle Forms as sysadmin/sysadmin. In the Responsibility Form, 

navigate to CRM Administrator > Notes Setup > Note Type Setup.

2. In the Application Object Library (AOL): In the Note Types Lookups Form, 
place the cursor in the multi-rec block, and click the New Record icon in the 
menu bar to open a new record.

3. Enter the Code that you want to use, its meaning, and description in the 
appropriate columns. Enter a Tag (Note) and a Start Date. The Start Date is 
mandatory.

4. Navigate to File > Save and Proceed. Close the Form if you have no new note 
types to enter.

4.2.8 Set up Service Request Profile Options
See Chapter 11, Profile Options and Concurrent Programs, for Service Request 
Profile Options.

4.2.9 Additional Details
When creating a Service Request in Oracle iSupport, the following mandatory 
values are always captured and passed from Oracle iSupport to Oracle TeleService.
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4.2.9.1 Request Type 
You can define Service Request Types to categorize Service Requests. For each 
Service Request Type, you can set up the corresponding Service Request Status. 

4.2.9.2 Status 
You can define the Service Request Statuses to indicate the current state of a 
reported Service Request. You can set a default value for each Type. For example, at 
Service Request creation, the default status could be Open.

4.2.9.3 Severity 
Every Service Request must have a Severity associated with it. Seeded severities are   
Low, Medium or High. The merchant may define additional values. A Service 
Request Severity reflects the support person’s (agent or merchant) perception of the 
importance of the reported Service Request. 

4.2.9.4 Contact 
This is the customer contact for the Service Request. This provides a support analyst 
or support manager with the relevant customer contact information. New contacts 
can be defined in TeleService; in Oracle iSupport, you cannot create a Service 
Request unless it has contact information associated with it. 

4.2.9.5 Owner 
All Service Requests have an Owner on the agent side. The Owner is the person or 
group that is assigned to the Service Request and will drive it to resolution.

The TeleService administrator must define resources, either individuals or groups, 
who will work on the Service Requests that are created. On creation of a Service 
Request, Oracle iSupport will try to route the Service Request to the appropriate 
person or group based on the information entered in the Service Request.

4.2.9.6 Customer
A Service Request cannot be created unless it has a customer name associated with 
it. It is possible to define new customers in Oracle TeleService, but not in Oracle 
iSupport. Users do not have the ability to define a new Customer party.

4.2.9.7 Summary 
Every Service Request must have a Summary - a brief description of the problem or 
issue describing the Service Request. 
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4.2.10  Set up Service Request Defaults
Basic Service Request functionality requires that you set up certain defaults. The 
LOV for these seeded default choices comes from the choices that you enter when 
setting up the Support application. See the Oracle Support Implementation Guide 
for more information.

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Select Support > Request Management > General. In the Request Management 
Administration screen, set defaults for the following:

■ Default Severity - Set a Default Severity for new Service Requests. The 
Service Request Severity is the priority level assigned to the request when it 
is created. 

■ Default Status - Set a Default Status for new Service Requests. The Default 
Status is the status assigned to the Service Request at creation. 

■ Closed Status - From the Closed Status list, set a default for closed Service 
Request.

■ Default Create Notetype - Set a default for the notetype used when a 
Service Request is created. Seeded defaults are Action, Activity, Cause, 
Changes, Closure, Contract Articles, Deduction Notes, Fact, Interaction, 
Objective, Problem Description, Resolution Description, and Symptom.

■ Default Update Notetype - Set a default for the notetype used when a 
Service Request is updated. Seeded defaults are Action, Activity, Cause, 
Changes, Closure, Contract Articles, Deduction Notes, Fact, Interaction, 
Objective, Problem Description, Resolution Description, and Symptom.

■ Default Escalate Notetype - Set a default for the notetype used when a 
Service Request is escalated. Seeded defaults are Action, Activity, Cause, 
Changes, Closure, Contract Articles, Deduction Notes, Fact, Interaction, 
Objective, Problem Description, Resolution Description, and Symptom.

■ Default Closed Notetype - Set a default for the notetype used when a 
Service Request is closed. Seeded defaults are Action, Activity, Cause, 
Changes, Closure, Contract Articles, Deduction Notes, Fact, Interaction, 
Objective, Problem Description, Resolution Description, and Symptom.

■ Default Resource Type - From the Default Resource Type ID list, set the 
default resource type. This indicates the resource type associated with the 
Default Resource ID (see below). Seeded values include Employee 
Resource, Group Resource, Team Resource.
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■ Default Resource ID - From the Default Resource ID list, set person who 
will be the default resource for Service Request routing.

3. In the During Service Request Creation area, set the following defaults: 

■ Search Knowledge Base:

-Always Prompt Customer gives users the option of searching or not 
searching the knowledge base.

-Always Search Knowledge Base enforces knowledge base search prior to 
submission of the service request.

-Directly Submit to Oracle iSupport bypasses the knowledge base search 
option.

■ Enforce Product Selection:

-Yes enforces product selection prior to submission of the Service Request.

■ -No bypasses the product selection enforcement option.

4. When finished, select Update.

4.2.11 Testing/Verification
To test that the basic Service Request functionality is working properly:

1. At the JTF login, log in as a Regular User.

2. Access the Create Service Request screen by navigating to Support > Service 
Request > Create Request or Homepage > How can we help you? > Create 
Service Request.

3. Submit a new Service Request. If you are able to submit the new Service 
Request and the system returns a Service Request tracking number, the Service 
Request basic functionality is working.

4.3 Set up Product Association
Because Service Requests are usually logged against a particular product, it is 
recommended that you set up Oracle iSupport to allow or enforce users to associate 
a product with their Service Requests. To use this functionality, follow the 
instructions in Chapter 7 of this guide, Set up Products.
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4.4  Set up Knowledge Management
Service Request submissions can be reduced by allowing or enforcing users to 
search a knowledge base prior to submission. This enforcement is enabled when 
you set the defaults in the section Set up Service Request Defaults. See Chapter 6 of 
this guide, Set up Knowledge Management and MES, for details on how to set up 
these modules.

4.5 Set up E-mail Submission
You can set up Oracle iSupport to allow users to receive, via e-mail, their Service 
Requests details. The set up steps for this feature are discussed below. In addition, 
the diagram below depicts the setup process.

Figure 4–2 E-Mail Submission Decision Flowchart

4.5.1 Set up Workflow Mailer
E-mails sent via the Service Request system in Oracle iSupport utilize Oracle 
Workflow Mailer. To set up Oracle Workflow Mailer, follow the steps outlined in the 
Workflow Mailer Implementation Guide Release 11i.

4.5.2 Testing/Verification
Test that you have set up the e-mail submission feature:

Prerequisite: Ensure that a Profile containing an e-mail address has been set up for 
a user within Oracle iSupport.

1. Log in to Oracle iSupport as a Regular User.

2. Create and submit a Service Request.
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3. On the confirmation screen, select the Email this to me button.

4. If you successfully receive the e-mail with the Service Request details, the test 
was successful.

4.6 Disable Menu Option
If you do not plan to use Service Request, you can disable the Support tab or any of 
its subtabs. For directions on how to do this, refer to Implementing CRM Applications 
Release 11i, Installing Oracle Applications Release 11i, and Oracle Applications System 
Administrator’s Guide Release 11i.De-select sub menus under IBU_REQ_MENU as 
follows:

■ (Ask Me subtab) IBU_REQ_ASKME

■ (View/Update Requests subtab) IBU_REQ_VIEWSR

■ (Create Request subtab) IBU_REQ_CREATESR

■ (Call Me subtab) IBU_HLP_CALLME

■ (Survey subtab) IBU_HLP_FEEDBACK

■ (Patch Search subtab) IBU_REQ_PATCH
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Set up Transactional Inquiries

This chapter details how to set up the Transactional Inquiries or Accounts function 
of Oracle iSupport. Topics include:

■ Use Transactional Inquiries: Considerations

■ Set up View Orders

■ Set up View Shipments

■ Set up View Invoices

■ Set up View Payments

■ Set up View Service Contracts

■ Set up View/Create Returns

■ Set up View/Create Service Requests

■ Disable Menu (for those not implementing Transactional Inquiries)

5.1 Use Transactional Inquiries: Considerations
Since there are seven sub-functions within Transactional Inquiries, which functions 
you plan to use will determine which additional software you need to setup. Below 
are the Transactional Inquiries dependencies.

■ View Orders - Oracle Order Management/Order Capture

■ View Shipments - Oracle Order Management

■ View Invoices - Oracle Receivables

■ View Payments - Oracle Receivables

■ View Service Contracts - Oracle Contracts for Service
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■ Create/View Returns - Oracle Order Management, Oracle Order Capture

■ Create/View Service Requests - Oracle Support (TeleService)

For additional information, refer to the following guides:

■ Oracle Order Management User’s and Implementation guides Release 11i

■ Oracle Order Capture Implementation Guide Release 11i

■ Oracle Receivables User Guide Release 11i

■ Oracle Contracts for Service Concepts and Procedures Release 11i

■ Oracle Support Implementation Guide Release 11i

The setups of each sub-function of the Transactional Inquiries feature are discussed 
in the following paragraphs.

The diagram below, Transactional Inquiries Implementation Decision Flowchart, 
shows the decision-making process and steps for implementing the Transactional 
Inquiries functionality.

Figure 5–1 Transactional Inquiries Implementation Decision Flowchart

5.2 Set up View Orders
With the View Orders feature of Oracle iSupport, users can see the status of their 
orders created within Oracle Order Management. Ensure that you have set up 
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Oracle Order Management according to the Oracle Order Management Implementation 
Guide Release11i.

5.2.1 Testing/Verification
To verify that you have set up the View Orders feature properly, perform the 
following test:

1. Log in to Oracle Order Management.

2. Create and view an order for a serviceable product.

3. Log in to Oracle iSupport as the customer for whom you have just 
created an order.

4. Navigate to Accounts > Orders.

5. Verify that you can view the order.

5.3 Set up View Shipments
With the View Shipments feature of Oracle iSupport, users can see the shipment 
status of their orders shipped within Oracle Order Management. Ensure that you 
have set up Oracle Order Management according to the Oracle Order Management 
Implementation Guide Release 11i.

5.3.1 Testing/Verification
To verify that you have set up the View Shipments feature properly, perform the 
following test:

1. Log in to Oracle Order Management.

2. Ship the order that you created in Set up View Orders above.

3. Log in to Oracle iSupport as the customer for whom you have just shipped an 
order.

4. Navigate to Accounts > Orders.

5. Select the Shipments button to the right of the order you have just shipped. 
Verify that you can view the order’s shipment details.

6. Verify that you can view the product in the Installed Base (if the item was 
serviceable) after you run the Installed Base Interface program.
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5.4 Set up View Invoices
With the View Invoices feature of Oracle iSupport, users can view a list of the 
invoices that have been created for their orders. Ensure that you have set up Oracle 
Receivables according to the Oracle Receivables User Guide Release11i.

5.4.1 Testing/Verification
To verify that you have set up the View Invoices feature properly, perform the 
following test:

1. Log in to Oracle Receivables.

2. Invoice the order created in the Setting up View Orders section above.

3. Log in to Oracle iSupport as the user for whom you have just created an 
invoice.

4. Navigate to Accounts > Invoices.

5. Verify that you can see the invoice details.

5.5 Setting up View Payments
With the View Payments feature of Oracle iSupport, users can view a list of the 
payments that have been logged in Oracle Receivables. Ensure that you have set up 
Oracle Receivables according to the Oracle Receivables User Guide Release11i.

5.5.1 Testing/Verification
To verify that you have set up the View Payments feature properly, perform the 
following test:

1. Log in to Oracle Receivables.

2. Receive a payment against the order created in the Set up View Orders section 
above.

3. Log in to Oracle iSupport as the user for whom you have just received a 
payment.

4. Navigate to Accounts > Payments.

5. Verify that you can see the payment details.
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5.6 Set up View Service Contracts
With the View Service Contracts feature of Oracle iSupport, users can view a list of 
their service contracts and applicable details. Ensure that you have set up Oracle 
Contracts for Service according to the Oracle Contracts for Service Implementation 
Guide Release11i, and that you have set up Oracle Order Management according to 
the Oracle Order Management Implementation Guide Release11i.

5.6.1 Testing/Verification
To verify that you have set up the View Service Contracts feature properly, perform 
the following test:

1. Log in to Oracle Order Management.

2. Create a service order for the serviceable item created in the Setting up View 
Orders section above.

3. Run the concurrent program Installed Base Interface.

4. Log into Contracts for Service.

5. Verify that you can view the contract.

6. Log in to Oracle iSupport as the user for whom you created the contract.

7. Navigate to Accounts > Contracts.

8. Verify that you can see the contract details.

5.7 Set up View/Create Returns
With the View/Create Returns feature of Oracle iSupport, users can create returns 
against orders that have been created in Oracle Order Management and Oracle 
Order Capture. Customers can also view details of returns. 

5.7.1 Set up Oracle Order Management/Oracle Order Capture
Ensure that you have set up Oracle Order Management according to the Oracle 
Order Management Implementation Guide, Release 11i, and Oracle Order Capture 
according to the Oracle Order Capture Implementation Guide, Release 11i.
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5.7.2 Oracle Order Capture Profile Options
For a list of Order Capture profile options, see Chapter 11, Profile Options and 
Concurrent Programs.

5.7.3 Testing/Verification
To verify that you have set up the View/Create Returns feature properly, perform 
the following test:

5.7.3.1 Testing/Verification Part 1
1. Log in to Oracle Order Management.

2. Create a return against the order created in the Setting up View Orders section 
above.

3. Log in to Oracle iSupport as the user for whom you have just created a return.

4. Navigate to Accounts > Returns.

5. Verify that you can see the return details.

5.7.3.2 Testing/Verification Part 2
1. Log in to Oracle iSupport.

2. Navigate to Accounts > Returns.

3. Create a return against the order created in the Setting up View Orders section 
above.

4. Log in to Oracle Order Management as the user for whom you have just created 
a return.

5. Verify that you can see the return details.

5.8 Set up View/Create Service Requests
To set up this module, follow the instructions outlined in Chapter 4 of this guide, 
Set up Service Request.

5.9 Disable Menu Option
If you do not plan to use any of the Transactional Inquiries elements, you 
can disable the Accounts tab of Oracle iSupport. For directions on how to do 
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this, refer to Implementing CRM Applications Release 11i, Installing Oracle 
Applications Release 11i, and Oracle Applications System Administrator’s Guide 
Release 11i. De-select sub menus under IBU_INQ_MENU as follows:

■ Orders subtab - IBU_INQ_ORDERS

■ Shipments subtab - IBU_INQ_VIEWSHIP

■ Invoices subtab - IBU_INQ_INVOICES

■ Payments subtab - IBU_INQ_PAYMENTS

■ Contracts subtab - IBU_INQ_CONTRACTS

■ Returns subtab - IBU_INQ_RMAS

■ Service Request subtab - IBU_INQ_VIEWSR
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Set up Knowledge Management

This chapter details how to set up the Knowledge Management functionality of in 
Oracle iSupport. Topics include:

■ Understanding Knowledge Management

■ Understanding the Solution Management System (SMS)

■ Understanding Marketing Encyclopedia System (MES)

■ Knowledge Management and Other Oracle Applications

■ Understanding Statements and Statement Types

■ Understanding Solution Sets and Solution Types

■ Setup Dependencies for Knowledge Management

■ Knowledge Management Search Functions

■ Other KM Administrative Functions

6.1 Understanding Knowledge Management
Knowledge Management is a comprehensive information management system 
enabling merchants to manage all internal and external information using Oracle 
intelligent knowledge capture, storage, and distribution tools. Knowledge 
Management consists of two modules:

■ Solution Management System (SMS), a problem and solution management 
system and database. 
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■ Marketing Encyclopedia System (MES), a document management system that 
includes white papers, product documentation, technical bulletins, FAQs, and 
installation instructions. 

Implementing Knowledge Management furnishes easy solution capture and 
immediate access to new solutions. The relational aspect of Knowledge 
Management provides focussed results that relate more directly to the issues being 
researched, thus reducing the cost of providing service while increasing customer 
satisfaction and gaining an edge over competitors.

6.1.1 Key Benefits of Knowledge Management
A traditional support interaction involves the following flow:

■ Customers make calls to a support call center 

■ Customers select from a series of options until they get to the product area in 
which they need support 

■ Customers wait until an agent is available to provide service 

Customer satisfaction with this support interaction depends upon the skill of the 
agent and the tools available. If a Knowledge Management System is not available, 
a frequently-posed question must be repeatedly researched and relayed by the 
agent, and the customer’s experience could be different each time. In this scenario, 
several costs - both real and in terms of customer satisfaction - are incurred. Real 
costs are associated with the life cycle of the problem: Customer service 
representatives must answer the initial customer call, log the problem, request more 
information, escalate the problem, deal with bugs, find out if a solution already 
exists, communicate the fix back to the customer, and close the problem. Intangible 
costs are associated with poor customer and agent satisfaction. Knowledge 
Management allows easy solution captures and gives agents immediate access to 
new solutions. Focussed search results decrease search time and allow agents to 
respond to customer requests more effectively. 

Note: SMS and MES are two entirely different modules designed 
to meet the specific needs of document and solution information 
management.
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6.2 Understanding the Solution Management System (SMS)
The Solution Management System (SMS) is a mandatory module of Knowledge 
Management. It manages the access, creation, and storage of solution. Its 
functionality is discussed below.

6.2.0.1 Natural Language Formatted Text Queries
Queries can be entered in a normal sentence structure. The system ignores common 
words and uses significant words for the search process. The Boolean operator is 
"OR".  There is also a phrase search that can be performed on a combination of 
significant words.

6.2.0.2 Keyword Search 
A query can consist of a single search term, or multiple search terms separated by 
spaces. The system performs a Boolean search using the OR, AND, THEME, 
operators and also allows fuzzy or Intermedia search.

6.2.0.3 Flexible Solution Model
SMS is seeded with a Symptom/Cause/Action solution model out of the box, but 
allows the merchant to create additional solution models. SMS also allows the 
merchant to define the statements that are required to create a solution. Thus, the 
merchant can allow partial solutions or require that only full solutions be created. 
There is no limit to the number of possible solution models running simultaneously. 
To minimize user confusion, it is recommended that the numbers be kept 
reasonable.

6.2.0.4 Oracle InterMedia Text 8.1.6 
Knowledge Management uses InterMedia Text 8.1.6 for text searching.

6.2.0.5 Solution Scoring
Each solution is scored based on the text match performed by InterMedia Text and 
the number of times it has been successfully used to solve issues. These scores are 
shown as a combined score to indicate the strength of the match to the query 
entered. The maximum score is 100.

6.2.0.6 Full Integration with CRM Service Products
SMS communicates with other applications through APIs. The search portion of the 
application has both HTML and Web Forms versions to meet the needs of the two 
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primary tech stacks. The Forms version addresses the specific requirements of an 
agent and allows additional functionality, such as solution creation. 

6.3 Understanding Marketing Encyclopedia System (MES)
The Marketing Encyclopedia System (MES) is used for the storage and retrieval of 
any documentation that does not fit the SMS structure. These documents are 
generally technical documents like white papers, technical bulletins, installation 
instructions, product manuals, marketing information, etc. Access to MES is only 
available through Oracle iSupport for this release. MES provides the following 
functionality:

6.3.0.7 Document Access
MES stores documents such as white papers, technical bulletins, installation guides, 
product documentation, and marketing materials.

6.3.0.8 Multiple Document Formats
MES uses multiple document formats. Any text format that InterMedia Text is 
capable of searching can be used.

6.3.0.9 Provides Unlimited Level of Categories
MES stores information in its own database and uses a hierarchical approach to 
allow a user to select a major category and search subcategories in the browse 
mode.

6.3.0.10 Keyword Search 
Keyword search capability is provided by Oracle iSupport search user interface.

6.3.0.11 Access Control
MES provides user and group access privileges to document categories and 
document input approval.
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6.4 Knowledge Management and Other Oracle Applications

6.4.0.12 Oracle iSupport
Oracle iSupport uses Knowledge Management in its Search for a Solution feature. 
Knowledge Management search is accessible both from the Oracle iSupport 
Homepage and the Support tab.

6.4.0.13 Oracle Customer Support-TeleService
The Customer Support-TeleService application is a Service Request management 
system that integrates with Knowledge Management and the Service Request 
module of Oracle iSupport to provide added support depth. 

6.4.0.14 Oracle Depot Repair
Knowledge Management allows a technician in Oracle Depot Repair management 
system to review the full problem solution lifespan, starting from the initial 
diagnosis of a problem to problem resolution. Depot Repair integrates with the 
Forms version of Knowledge Management through its user interface.

6.4.0.15 Oracle iCenter
Knowledge Management integrates with the Oracle iCenter e-mail application for 
direct customer question submission and response. The Oracle iCenter Knowledge 
Management interface is designed to accept formatted and unformatted e-mail as 
knowledge base submissions. The returned solution set that can be sent as an e-mail 
message to the customer.

6.4.0.16 Defect and Enhancement Management System
The resolved defects in DEMS can be submitted to Knowledge Management for 
publication. This allows the KM users to search for previous solutions and prevents 
duplicate defect entry.

6.5 Understanding Statements and Statement Types
Statements are concise descriptions of different aspects of an issue and its 
resolution. A statement contains a Summary field limited to 2KB and a Detail field 
limited to 2GB. Statements form relationships with other statements and solution 
sets.

Examples of Statements are:
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■ A user’s computer locks up every time it is started

■ My computer uses Windows 95 as its operating system

■ I have no idea why my computer is locking up every time I start it

■ Run the disk defragmentation program for the computer

A Statement Type, is an identifying name that is associated with a particular part of 
the Solution model being used by the merchant’s organization. Examples of 
Statements Types are:

■ Symptom - What the user is experiencing

■ Fact - What is the environment (Windows 95, ViewSonic 17GA, etc.)

■ Cause - What has caused the issue (may or may not be known)

■ Action - What needs to be done to resolve the issue

Statements can be reused in multiple solutions within a particular solution type, 
and in solutions in other solution types. In each case, the statement will build a 
unique relationship with that solution. This process of building statement 
relationships to solutions is known as an associative or neural network solution 
model.

Knowledge Management is seeded with Symptom/Cause/Action solution 
type.You can define an unlimited number of your own solution types. To define a 
Statement type, an administrator should evaluate how the solution process is 
currently performed and whether there are any enhancements that can be made in 
the process. The Knowledge Management system allows any number of Statement 
types to be created. Therefore, it is best to create statements using naming 
conventions which relate to the merchant’s current process steps.

Example: A carpet manufacturer currently provides support information to 
customers in a question-and-answer mode. The company needs to have additional 
elements of information added, such as carpet type, the product name, and the dye 
lot. The possible Statement types used could include: Question, Type, Product, Dye 
Lot, and Answer.

6.6 Understanding Solution Sets and Solution Types
In SMS, information is organized by Solution Sets, governed by Solution Types. 

A Solution Set is a defined group of Statements. These Statements can either be 
unique to that Solution or shared with other Solutions. There is no physical limit to 
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the number of different solutions that can reside simultaneously in the knowledge 
base. 

A Solution Type can provide segmentation of the knowledge base, depending on 
how the information is captured and used. A Solution Type should have a 
self-descriptive name and should follow the merchant’s naming conventions. 
Common Solution Types are: 

■ SCA (Symptom, Cause, Action) 

■ PR (Problem Resolution) 

■ QA (Question Answer)

A Solution Set:

■ contains a title and links to Statements 

■ enforces an optional minimum number of statements for a complete Solution 

■ includes merchant-set viewer limitations 

■ updates not only the Solution usage count and strength of the Statement 
relationships to the Solution, but all statements within the Solution Set when it 
is selected as solved

6.6.0.17 Status of a Solution
The status of a Solution is defined as the confidence level and viewing status for a 
Solution. Merchant-definable, the status can be mapped to a user type to limit 
visibility. Common Solution statuses are: Draft, Under Edit, Ready for Technical 
Review, Ready for Editorial Review, Publish Internal, and Publish External.

6.7 Setup Dependencies For Knowledge Management
These are set up prerequisites for utilizing the Knowledge Management 
functionality:

1. Set up the JTF Notes module in Oracle CRM Foundation. 

2. Set up InterMedia Text.

3. Create a KM Administration User.

4. Set up SMS. 

5. Set up MES.

6. Set up Knowledge Management Profile Options
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6.7.1 Set up Notes
The Notes module enables the entire CRM suite to create, maintain, and                   
share notes related to customers, opportunities, service requests, and other business 
objects. Notes allows the capture of extensive, textual, project relevant information 
within Oracle CRM applications. Notes comes seeded with predefined Note Types.

Knowledge Management Note Types are preceded by CS, for example CS_
Symptom. 

IMPORTANT: The integration of Knowledge Management, which uses the concept 
of Statements, with Service Requests, which uses the concept of notes, requires that 
statements and notes be related to one another if they are to be used in both. See the 
Oracle Customer Support documentation and courseware for more information.

In order for a note to be transferred to the knowledge base search in the Customer 
Support application, the note must be defined as a knowledge base Note Type. For 
this integration to occur, it is critical that both note and statement have identical 
names (with the exception that the statement types begin with KB). 

1. Log on to Oracle Applications (Forms) as sysadmin/sysadmin. 

2. Using CRM Administrator responsibility, navigate to Notes Setup > Note Type 
Setup.

3. In the Application Object Library (AOL): In the Note Types Lookups Form, 
verify that KB note types exist. If not, enter new note types using KB_<note 
type> if the note is to be knowledge base searchable.

4. To enter a new note type, place the cursor in the multi-rec block (the small block 
to the extreme left of a row), and click the New Record icon in the menu bar to 
open a new record.

5. Enter the Code that you want to use (preceded by KB_), its meaning, and 
description in the appropriate columns. Enter a Tag (Note) and a Start Date. The 
Start Date is mandatory. To disable a Note Type, enter an End Date.

6. Navigate to File > Save and Proceed. Close the Form if you have no new note 
types to enter.

6.7.2 Set up InterMedia Text
InterMedia Text (iMT) provides integrated management of free text stored in the 
database, on websites, or on file systems. It extends the Oracle SQL query language 
to provide content-based search and retrieval on formatted documents and free text. 
This allows access to a number of advanced text search capabilities from any SQL 
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tool or interface. For iMT to return usable results, it must internally translate the 
unformatted text into formatted components (text indexes, intermediate tables, etc.). 
As iMT is operating, it is generally either creating these formatted components or 
acting on them to return usable results.

For information on Setting up InterMedia Text:

■ Navigate to http:// www.oracle.com 

■ On the left hand side menu, navigate to Communities. Click Oracle Technology 
Network > Documentation. 

■ Below the Related Features & Products section, select interMedia. 

To access the documentation, you need an account and a password, provided free 
on request. 

6.7.3 Create a KM Administration User
To use the Knowledge Management module, you must set up a user as the 
Knowledge Management administrator.

Prerequisite: The Oracle iSupport Administrator user has been set up (see Chapter 
3, Users and User Management).

6.7.3.1 Steps for Setting up a KM Administrator
The first step is to register the user in Oracle iSupport.

1. At the JTF login page, click the Register Here link. This can be done by the user. 

2. Enter required information on the User Registration form. Make a note of the 
username and password. 

3. Select Business User from the drop-down list. 

4. Select Submit. The User Registration Continued screen appears.

5. Enter the Company ID (account) in the appropriate box. 

6. Select Submit.

6.7.3.2 Approve KM Admin User
The next step is to accept the user’s registration within Oracle iSupport. .

1. As Oracle iSupport Administrator, navigate to User > Pending Approvals.
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2. In the Pending Approvals window, select the user by clicking the checkbox to 
the left of the username. 

3. Select Approve. 

6.7.3.3 Associate Roles to KM Admin User
The next step is to associate the KM administrator roles to the user.

1. As Oracle iSupport Administrator, navigate to the User tab.

2. Select the user you created in the previous step.

3. In the User Details screen, click Roles.

4. In the Roles screen select CS_SYSTEM_ADMIN.

5. Select Save.

6.7.3.4 Associate Responsibility to KM Admin User
The next step is to associate the appropriate responsibility to the user.

1. As the Oracle iSupport Administrator, navigate the User tab. 

2. Select the User created above.

3. In the User Details screen, select Responsibilities.

4. Click on Select to access the List of Values (LOV). Choose CS_KB_SYS_ADMIN. 
Select Save.

5. In the Default column, click the radio button next to the responsibility. 

6. Save.

6.7.4 Set up Marketing Encyclopedia System (MES)
Set up Marketing Encyclopedia System (MES); MES is also called Technical Library 
module. See Oracle Marketing Encyclopedia System Implementation Guide for more 
information. MES allows access to a much broader base of support by providing 
access to user guides, white papers, FAQs, and technical documents. 

Setup MES to publish content to MES viewable in Oracle iSupport. 

1. Create an employee using Oracle Forms:

a. In Oracle Applications, select Human Resource (HR) responsibility for your 
organization.
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b. Navigate to People> Enter and Maintain.

c. Create a new employee.

2. Associate the created user with an employee and/or a customer by following 
these steps:

a. Log on to Oracle Applications Forms.

b. Select System Administrator responsibility.

c. Navigate to Security > User.

d. Query the created user.

■ In the Employee/Person field, select the created employee.

■ In the Customer field, select a customer.

3. Create a resource for the employee and grant MES privileges by following these 
steps:

a. Log on to Oracle Applications Forms. Select the CRM Resource Manager 
responsibility.

b. Navigate to Maintain Resources >Import Resources.

c. Query the created employee by using the employee number (not the 
employee id) and employee name.

d. Click Search.

e. After getting results, click Create Resource.

f. In the Role field, select the desired MES resource role (MES Administrator). 
Click OK.

g. Click Save Resource.

4. Set up MES related Concurrent Programs. For more information about these 
concurrent programs, see Oracle Marketing Encyclopedia System Implementation 
Guide. To enable MES searches in your environment, you have to schedule the 
following four concurrent programs:

■ MES Intermedia Index Sync Operation to be scheduled for every three 
hours

■ MES Intermedia Index Optimization Operation to be scheduled every seven 
days. [parameter p_optimization_level=fast or full]

■ JTF Intermedia Sync Operation (every three hours)
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■ JTF Intermedia Index Operation (Every seven days) [parameter p_
optimization_level=fast or full]

5. There is also an index on FND_LOBS table. You need to run a script to alter the 
index on this table whenever you store a URL or a file. This index has to be 
periodically rebuilt depending on the volatility of the data and after large 
uploads. 

6. Create a User Group using the following steps:

a. Log on to Oracle iSupport as an iSupport Administrator user.

b. Click the Support tab and the UserGroup sub tab.

c. Click Create.

7. Enter the start and end dates for the user group and enter a sql statement of the 
following type:

“select party_id from hz_parties where party_id in (select customer_id from 
fnd_user where user_name is like ’ABC%’)”

8. Integrate with MES by following these steps:

a. Log on to Oracle Applications.

b. Select the System Administrator responsibility.

c. Run the iSupport User Group Creation Concurrent program. A group 
channel is created in MES.

9. Publish content in MES. (See Oracle Marketing Encyclopedia System 
Implementation Guide for more information).

10. Integrate with iSupport by following these steps:

a. Create a category for company news and publish items to it.

b. Create a category for technical library and publish items to it.

c. Publish items to the group channel corresponding to the user group. These 
published items can be seen as Alerts on the iSupport Home page.

11. Map MES categories to iSupport by following these steps:

Note: In the Search query, the user_name is case sensitive and 
must be entered in uppercase.
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a. On the JTF Log in screen, log on as an iSupport Administrator user.

b. Click Administration > Support tab > Technical Library.

c. Associate the technical library to the appropriate category in MES.

6.7.4.1 Testing/Verification of MES Setup
Use this procedure to test that MES has been properly set up.

Prerequisites: Set up categories, sub categories, and channels in MES. (See Oracle 
Marketing Encyclopedia System Implementation Guide for more information on how to 
do this).

1. Log on to Oracle iSupport as a Knowledge Management administrator.

2. Click the MES tab. Select the Publish subtab.

3. Contribute a document to MES.

4. Run the MES related concurrent programs.

5. Set up Technical Library in iSupport Administration screen.

6. Log on to Oracle iSupport as a regular user.

7. Search for the document by navigating to iSupport Homepage > Find a Solution 
> Technical Library. Successfully finding the document indicates that you have 
properly set up MES.

6.7.5 Set up the Solution Management System (SMS)
Set up the Knowledge Management Solution Management System (SMS) module as 
described in the latest version of Oracle Service Implementation Guide Release 11i. 
Setting up SMS for Knowledge Management will give users access to the database 
of solutions that have been set up. Below are quick start setups that will be the 
program up and running, but you should do the full setup according to the Oracle 
Service: Knowledge Management documentation.

6.7.5.1 Create a Statement Type
Prerequisite: Create a Knowledge Management Administrator.

Statement types, the basic building blocks for solution types, should be set up prior 
to setting up the solution type. Sample Statement Types are: Symptom, Action, Fact, 
Cause, Objective, and Changes. 
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IMPORTANT: The Statement Type must have a name identical to the Note Type 
that it will integrate with. See Section 6.8.1, Set up Notes, above.

1. In the JTF Login screen, log in as the Knowledge Management Administrator.

2. Navigate to SMS > Setup > Create Type. The Create Type screen appears.

3. In the Type drop-down list, select Statement.

4. Enter a name for the Statement Type in the Name field. Note: The statement 
type must be idencial to the Note type.

5. Enter a description of the Statement Type in the Description field.

6. Click Create. Statement Type screen appears with a Related section. You can 
also relate this statement type to external links.

6.7.5.2 Create a Solution Type
After Statement Types are defined, an appropriate Solution Type should be 
determined. Names used should relate to the common nomenclature used by the 
merchant and his customers. 

1. At the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Setup > Create Type.

3. From the Type drop-down list, select Solution.

4. Enter the name of the Solution in the Name field.

5. In the Description area, briefly describe the Solution Type. The Description of 
the solution is only for administrators and cannot be viewed by the customer.

6. Select Create.

6.7.5.3 Associate Statement Type to Solution Type
After you create Solution Types, then you associate the Solution and Statement 
Types. This step creates a Solution Set. 

1. On the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Setup > Solution Types. A list of existing Solution Types 
appears.

3. Click the Solution Type Number link. The Solution Type screen for the Solution 
Type Number appears. Verify that the types have the name and description that 
you desire.
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4. Click Add/Delete button. The Associate Statement Types screen appears.

5. Move the Statement Types that you wish to associate with the existing Solution 
Types by selecting the desired Statement Type from the Available Statements 
Types box and assign (>) it to the Selected Statement Types box.

6. Click Save.

6.7.5.4 Create a Statement
Statements are the building blocks of Solutions. Use this procedure to create 
appropriate Statements to complete a Solution.

1. At the JTF Login screen, log in as a Knowledge Management administrator.

2. Navigate to SMS > Statement > Create. Create Statement screen appears.

3. In the Create Statement screen, choose the Statement Type from the drop-down 
list. 

4. Enter a concise description applicable to that Statement Type in the Summary 
field.

5. If additional supportive information is required, it can be entered in the Detail 
field.

6. Select Create.

6.7.5.5 Create a Solution
Solutions consist of different types of Statements. If certain Statement Types have 
been defined as mandatory to create a solution, the system will verify that all 
mandatory statements are included and will not allow the solution to be created if 
this condition is not met.

Prerequisites: Include all mandatory Statement Types.

1. At the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Solution > Advance Search/Create. The Search/Create 
Solutions screen appears.

3. Select Solution Type from the drop-down list. 

Note: To clear the contents of all fields on this screen, choose 
Clear. No changes will be saved.
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4. Select the Statement Type in the Statements sub section from the Type 
drop-down list. 

5. Enter a Statement in the Description field.

6. To add more than one Statement, click Add Row, and enter the new Statement 
in the Description field. Add as many statements as you think are appropriate 
for this Solution.

7. After entering all statements, select Create Solution. A window appears 
requesting that the Solution title be entered. 

8. Enter a Solution title and click OK. If you want to cancel an action, select 
Cancel.

9. In the View Solution screen, choose the Status that you want to assign to the 
Solution. Click Update.

10. Click the Solved button to increment the Used Count in the database and give 
the Solution added ranking in the Knowledge Management System.

6.7.5.6 Testing/Verification of SMS Setup
Use the following procedure to test that you have properly set up SMS. 

1. Log in to Oracle iSupport as a Knowledge Management administrator.

2. Navigate to SMS > Advance Search/Create.

3. Add a Solution. The Solution status should be Public.

4. Run the concurrent programs in the Oracle Forms application.

5. Log on to Oracle iSupport as a regular user.

6. Search for a solution from the Oracle iSupport Homepage. 

Note:  Do not click Add Row again unless you plan to add 
another Statement. If you do that, you will be asked to either enter 
a new Statement or navigate out of the screen. You will not lose 
Statements that you have already created.
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6.7.6 Set up Knowledge Management Profile Options
See Chapter 11, Profile Options and Concurrent Programs, for information on 
setting Knowledge Management profile options.

6.7.7 Run Concurrent Programs
See Chapter 11, Profile Options and Concurrent Programs, for information on 
running Knowledge Management-related concurernt programs.

6.8 Knowledge Management Search Functions
The Knowledge Management system allows a variety of search options. These 
functions are discussed below.

6.8.1 Searching for a Statement
Use this procedure to search for an existing statement in Knowledge Management.

1. On the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Statement > Search. Search Statements screen appears.

3. In the Search Statements screen, enter some known information to narrow your 
search:

■ Statement Number - This is the number assigned to a statement in 
Knowledge Management when a statement is created.

■ Statement Type - This is the category assigned to a statement when a 
statement is created. 

4. Click Go.

6.8.2 Searching for a Solution
To search for a solution, you can use either Basic Search, which allows you to search 
for a solution based on the Solution Type, Solution Number, and Solution Name, or 
Advanced Search, which is more comprehensive.

6.8.2.1 Basic Search
Use basic search if you want to find a solution using a basic keyword search. For a 
more complex search, use Advanced Search.
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1. On the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Solution > Basic Search. Search Solutions screen appears.

3. In the Search Solutions screen, enter known information to narrow your search.

4. Click Go. Search Solutions Results screen appears. 

5. Click the solution number to navigate to the View Solution screen for details.

6.8.2.2 Advanced Search: Searching for a Solution
Use the Advanced Search/Create screen to perform a more comprehensive search 
than Basic Search. You can also add statements to a solution or create a new solution 
with this screen.

1. On the JTF Login screen, log in as the Knowledge Management Administrator.

2. Navigate to SMS > Solution > Advanced Search/Create. Search/Create 
Solutions screen appears.

3. In the Description field, enter any keywords associated with the Solution.

4. Ensure that the Solution is selected in the drop-down list below the Add 
Row/Delete Row buttons.

5. Click Go. The results appear in the Results sub-section of the Search/Create 
Solutions screen.

6.8.2.3 Advanced Search: Searching for a Statement
Use the steps below to search for a statement.

1. At the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Solution > Advance Search/Create. Search/Create Solutions 
screen appears.

3. Enter any part of a statement in the Description field. This can be in a question 
form, a keyword form, or as a phrase. 

4. From the drop-down list, below the Add Row/Delete Row buttons, choose 
either:

■ Matching Statements - Finds Statements that contain the words in the 
Description area. The list that appears will be prioritized based on a term 
match score built into InterMedia Text.

■ Related Statements - Finds results if the statement selected is a statement 
from the knowledge base. When this is used properly, it will return all 
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statements used in all solutions that the query statement has built a 
relationship with.

5. Click Go!

6. If your query finds either matching or related Statements, a list will appear in 
the Results section of the Search/Create Solutions screen. Choose the statement 
that you want to add (or want to replace an existing statement with) to the 
solution that you are creating, and select Add (or Replace).

6.8.2.4 Advanced Search Addition Information
■ Radio buttons to the right of the Description field can be used to select a 

statement row.

6.9 Other KM Administrative Functions
There are also several other functions related to the KM Administrator, as discussed 
below.

6.9.1 Viewing Existing Solution Types
Use this procedure to search for existing Solution Types.

1. At the JTF Login, log in as the Knowledge Management administrator.

2. Navigate to SMS > Setup > Solutions Types. The Solution Type screen 
displaying a list of existing Solution Types appears.

6.9.2 Updating Existing Solution Types
Use this procedure to update the name or description of an existing Solution Type. 

1. On the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Setup > Solutions Types. A list of existing Solution Types 
appears.

Note: While submitting a solution, the solution can be set up to 
Public. The merchant has to provide the process for who will set up 
this status.
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3. Click the Solution Type Number link. The Solution Type screen for that Solution 
Type Number appears.

4. To update the Name or Description of the Solution Type, enter the new 
information in the appropriate fields.

5. Click Update to save the changes. 

6.9.3 Searching Statement Types and External Links
You can also use the Solution Type screen to find Statement Types and external links 
related to the Solution that you are updating, or to add Statement types to the 
existing Solution. When you initially navigate to the Solution Type screen, Oracle 
iSupport automatically lists related Statement Types in this screen. The optional 
checkbox is for stating whether the statement is a mandatory statement to form a 
Solution. It is defaulted to optional.

External links are service requests or other documents that can be linked to a 
solution for references. To find related external links, choose External Links from the 
drop-down menu. The External Links are links to Service Requests.

6.9.4 Disassociating Statement Type from a Solution Type
Use the following procedure to disassociate a Statement Type from a Solution Type.

1. On the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Setup > Solution Types. A list of existing Solution Types 
appears.

3. Click the Solution Type Number link. The Solution Type screen for the Solution 
Type Number appears. Verify that the types have the name and description that 
you desire.

4. Click Add/Delete button. The Associate Statement Types screen appears.

5. Move the Statement Types that you wish to disassociate from the existing 
Solution Types by selecting the desired Statement Type from the Selected 
Statement Types box and de-assign it (<) to the Available Statements Types box.

6. Click Save.

6.9.5 Deleting Statement Types
Use this procedure to delete statement types except the default statement type.
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Prerequisites: Delete any Statements using the Statement type. Delete links to any 
Statements or Solutions related to the statement type.

1. On the JTF Login screen, log in as the Knowledge Management administrator. 
Navigate to SMS > Setup> Statement Types. Statement Types screen appears.

2. Click on the numbered link of the Statement Type that you want to delete.

3. In the Statement Type screen, ensure that there are no related solutions types or 
external links listed in the Related sub section.

4. To remove a solution type or external link within a statement type:

a. In the Remove column, check the checkboxes corresponding to the related 
solution types or external links.

b. Click Update.

5. After removing the related solution types, click Delete. This procedure cannot 
be undone.

6.9.6 Deleting Solution Types
Use this procedure to delete a solution type except the default solution type e.g., 
symptom-cause-action; problem-fix.

Prerequisites: Delete any Solutions using the solution type. Delete the links to any 
Solutions that are related to the type.

1. On the JTF Login screen, log in as the Knowledge Management administrator. 
Navigate to SMS > Setup> Solution Types. Solutions Type screen appears.

2. Click the numbered link of the Solution Type that you want to delete.

3. In the Solution Type screen, ensure that there are no related statements 
types/external links listed in the Related sub section.

4. To remove related Statement types:

a. Click Add/Delete button. The Associate Statement Types screen appears. 
Disassociate Statement Types from that Solution type. 

b. Click Save. Solution Type screen reappears with no statement types 
appearing in the Related section.

5. After removing the related statement types, click Delete. This procedure cannot 
be undone.
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6.9.7 Updating Statement Details
Use the following procedure to update statement details about an existing 
statement.

1. At the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Solution >Basic Search > Statement> Search. Search 
Statements screen appears.

3. Enter the Statement number. Or, enter any other criteria for searching.

4. Click Go. Search Statements Results screen appears.

5. Click the statement number that you want to update. View Statement screen for 
that statement number appears.

6. You can update the Summary and Detail sections and also add/remove external 
links and related solutions. Click Update.

6.9.8 Updating Solution Details
Use the following procedure to update details about a Solution.

1. On the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS> Solution> Basic Search. Search Solutions screen appears.

3. Enter a solution number or any other search criteria. Click Go. Search Solutions 
Results screen appears with the search results.

4. Click the solution number to update details about that solution. View Solutions 
screen appears.

5. You can update the status and/or title of the solution. You can also update 
Related Statements and External Links.

6. Click Update.

6.9.9 Setting up Frequently Used Solutions
You can provide your customers with a list of frequently used solutions for a 
specific time period, for example, a week, a month, or an year. Use this procedure to 
set up the frequently used solutions.

1. On the JTF Login screen, log in as the Knowledge Management administrator.

2. Navigate to SMS > Solution > Frequently Used Definition. Frequently Used 
Definitions screen appears.
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3. Select the time period that you want to use as a default time period.

4. Click Update.

5. To add a new time period, select Add, enter the new name and time period.

6. Click Update.

6.9.10 Setting up Recommended Solutions
Use this procedure to add solutions or delete solutions from the recommended list 
and sort the order in which the solutions will appear.

1. On the JTF Login screen, log in as an iSupport administrator.

2. Navigate to SMS > Solution > Recommended. Recommended Solutions screen 
appears.

3. To add a solution to the list, click Add. Enter the Solution Number. Click Done.

4. To rearrange a solution, click the box next to the solution to be moved and click 
Move Up or Move Down.

5. To delete a solution from the list, click the box next to the solution to be deleted.

6. Click Delete.

6.9.11 Associating Solutions by Using Common Statements
Use this procedure to associate solutions by using common statements.

1. At the JTF Login screen, log in as the Knowledge Management Administrator.

2. Navigate to SMS > Solution > Advanced Search/Create. Search/Create 
Solutions screen appears.

3. From the drop-down list, select the Solution Type that is associated with the 
statement(s) that you want to replace or add.

4. From the drop-down list, select the Statement Type or All. Enter a statement 
description. 

5. From the drop-down list, select Matching Statements. Click Go. A list of 
statements from the knowledge base appears in the Results sub-section of the 
screen.

6. Select a statement from the Results section by clicking the Select radio button 
corresponding to that statement.
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7. Click Replace or Add.

6.9.12 Creating a Utility to Load Existing Database to a New Database
To define and create a utility to load existing Merchant Solution information into 
Knowledge Management System, perform the following steps. Definition of a 
Utility depends on the merchant database definition. 

■ Review existing solution database for the following:

■ Maximum Information entity size

■ Existing Statement terminology

■ Existing Solution Set terminology

■ Categorize the different types of information available based on whether it 
is a typical problem/solution entity or can be considered documentation 
such as white papers, tech bulletins, product manual sets, etc.

■ Determine the number of different product types desired

■ Do the information entities consist of statement types with titles or are they 
large pieces of information

■  Review the following CRM Knowledge Management structure:

■  Statements consist of 

* Summary: Varchar2 or 2K bytes (faster than using Detail)

* Detail: CLOB or 2 Gigabytes

* No significant limit on number of types

■ Solutions consist of 

*  Solution Title: 80 characters

* Any number of Statements

* Multiple Solution Types can coexist
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Set up Products

This chapter details how to set up the Products function of Oracle iSupport. Topics 
include:

■ Use Products

■ Set up Products

■ Set up Installed Base

■ Disable menus (for those not implementing Products)

7.1 Use Products 
There are two options when setting up Products in Oracle iSupport. You can use all 
of your company’s serviceable products - which requires you to set up part of 
Oracle Inventory - and you can also set up the Installed Base, which allows you to 
include all products purchased by customers and their applicable service contracts. 
The diagram below, Products Implementation Decision Flowchart, shows the 
decision-making process and implementation steps for the Products functionality.
ducts 7-1



Set up Products
Figure 7–1 Products Implementation Decision Flowchart

7.2 Set up Products
To set up basic Products functionality, follow the steps below.

7.2.1 Set up Oracle Inventory 
Set up Oracle Inventory according to Oracle Inventory Implementation Guide Release 
11i. Be sure to set up the following:

■ Serviceable items

■ Serial Numbers

■ Lot Numbers

■ Item Revisions

■ Units of Measure

■ Profile Options

7.2.2 Verification/Testing of Basic Products Setup
To verify that you have set up basic Products functionality:
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1. Create a Item in Oracle Inventory.

2. View the created Item in Oracle iSupport.

3. If you cannot view the Item, check your Oracle Inventory Setup.

7.2.3 Set up Installed Base 
Prerequisites: Verify that Order Management, Accounts Receivable and other 
Installed Base dependencies are set up correctly. 

To set up Installed Base refer to the Oracle Service Implementation Guide Release 11i: 
Implementing Installed Base. Ensure the setup of the following:

■ Product Types

■ Product Statuses

■ System Types

■ Systems

■ Configuration Types

■ Profile Options

■ Run the Concurrent Program, Installed Base Interface

7.2.4 Verification/Testing
To verify that you have set up Installed Base properly:

1. Create and ship an order in Order Management.

2. Run the Concurrent Program Installed Base Interface.

3. Log in to Oracle iSupport as the customer for whom you created and shipped 
the order in Step 1 and verify that the product is present. 

4. Run Product Report and verify that product appears.

5. If product fails to appear, check your Installed Base and Order Management 
setups and test again. 

 

To verify that the Add Product Function is working:

1. Log in to Oracle iSupport as a Regular User.

2. Navigate to Products > Add Product and add a product.
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3. Run the Concurrent Program Installed Base Interface.

4. Navigate to Products. Verify that you can view the product.

5. If you cannot view the product, check the Installed Base setup and run the 
Installed Base Interface.

7.2.5 Disable Add Products Functionality
You can set up Installed Base without the add products functionality. To do this, 
disable the Add Product menu by following the directions in Implementing CRM 
Applications Release 11i, Installing Oracle Applications Release 11i, and Oracle 
Applications System Administrator’s Guide Release 11i. Delete the Oracle iSupport 
Product submenu IBU_INQ_INSTALLBASE_ADDPRODUCT under IBU_IB_MENU.

7.3 Disable Product Menu Option
If you do not plan to use Products, you can disable the Products tab of Oracle 
iSupport. For directions on how to do this, refer to Implementing CRM Applications 
Release 11i, Installing Oracle Applications Release 11i, and Oracle Applications System 
Administrator’s Guide Release 11i. De-select submenus under IBU_IB_MENU as follows:

■ (Summary subtab) IBU_INQ_INSTALLBASE

■ (Add Products subtab) IBU_INQ_INSTALLBASE_ADDPRODUCT

■ (Reports subtab) IBU_INQ_INSTALLBASEREPORT 
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Set up Forums

This chapter details how to set up and maintain the Forums function of Oracle 
iSupport. Topics include:

■ Set up Forums

■ Restrict Access to Forums

■ Change Forum Access to Open

■ Set Forum Access to Disabled

■ Additional Information:

■ Forums Search Function

■ Maintaining Categories, Forums, and Messages

■ Disable menus (for those not implementing Forums)

You can set up individual Forums as open or with the Restricted Access feature. The 
diagram below, Forums Implementation Decision Flowchart, shows the 
decision-making process and implementation steps for the Forums functionality.
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Figure 8–1 Forums Implementation Decision Flowchart

8.1 Set up Forums
To set up Forums without restricted access functionality, there are two steps:

1. Create at least one Category.

2. Create at least one Forum.
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8.1.1  Create Category
Before users can post to Forums and reply to messages, the Oracle iSupport 
Administrator must create a Category and a Forum within that category. Categories 
serve to organize Forums into topic or discussion areas. To create a Category:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Category > Create.

3. To have the new Category exist at the root level, leave the Choose a parent 
category field set to Category Root. To place the new Category underneath 
another Category, select the parent category from the Choose a parent category 
drop-down list.

4. Enter a name for the Category in the Enter the name of the new category field.

5. Leave the Access Type as Open. Restricted categories are not currently 
supported.

6. Select Create.

7. At the confirmation screen select Ok.

8.1.2 Create Forum
The Oracle iSupport Administrator must create at least one Forum within a 
Category.

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Forum > Create.

3. Select the Category where the Forum will be located.

4. Enter a name for the Forum in the Enter forum name field.

5. Leave the Access Type as Open. You can change this later (see Restrict Forum 
Access, Section 8.2, below) 

Note: If Access Type is Open, it is accessible to all users. If you want to restrict 
access to the Forum at this point, select the Restrict option and follow the 
detailed steps in Section 8.2 below.

6. Select Create.

7. At the confirmation screen select Ok.

Note: There is no limit to the number of Forums you can create within any 
given category.
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8.1.3 Verification/Testing Access to Open Forum
To verify that you have set up Forums properly, test access to an Open Forum:

1. At the JTF login, log in as an Oracle iSupport Regular User.

2. Navigate to Forum.

3. Access and post a message to an Open Forum.

4. Log out.

5. Log in to the JTF login as the user in step 1 above.

6. Access your message by browsing or searching (see Forums Search Function 
below).

7. Verify that you can view the message you have just posted.

8.2 Restrict Forum Access Type
In order to restrict access to a Forum, you must set up a Usergroup and then 
associate that Usergroup with the Forum that you wish to restrict. To view or post 
messages within a restricted Forum, users must belong to the Usergroup associated 
with that Forum.

Note: Users who are not members of the Usergroup associated with the restricted 
Forum cannot view the Forum. Consider informing your users of the existence and 
nature of restricted Forums so that they can request inclusion in them, if 
appropriate.

8.2.1 Set Forum Access Type to Restricted
1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Forum > Modify Status.

3. Select the Forum to modify from the drop-down list.

4. Under Access Type, select the radio button next to Restricted.

5. Select Modify.

6. A confirmation screen appears.
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8.2.2 Create Usergroups
To create a Usergroup (Usergroups are the same for iSupport Forums and for MES 
within iSupport): 

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Support > Usergroup > Create.

3. Click the calendar icon next to Start Date and select a start date for the group. 
Repeat for End Date.

4. Enter a description for the Usergroup.

5. Enter an SQL statement to define the usergroup.

■ Sample SQL statement number 1: This statement will return customers in 
the U.S. that have placed orders where the order amount is more than 
$10,000.

select party_id from hz_parties 
where country=’US’ and total_ordered_amount > 10000

■ Sample SQL statement number 2: This statement will return all employees 
for the company.

select user_id from fnd_user where employee_id >0

Note: Both of the sample statements above would return a very large list. For 
management purposes, it is better to define usergroups by function, for 
example, the sales team, or the support team, in which case an extra where 
condition would be entered by the administrator. Please consult your 
information systems administrator for more information.

6. Select Save.

8.2.3 Run the Usergroup Creation Concurrent Program 
In order to populate additional tables and make the Usergroup visible in MES it is 
necessary to run the Usergroup Creation Concurrent Program (short name is 
IBUUG). The concurrent program must be run each time you update or add users to 
a Usergroup. For more information on concurrent programs, see Chapter 10 of this 
guide, Profile Options and Concurrent Manager.
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8.2.4 Associate Usergroup to Restricted Forum
When you choose the Access Type of Restricted for a Forum, you must associate a 
Usergroup with that Forum. 

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Usergroup > Associate.

3. Choose a Forum from the drop-down list.

4. Choose a Usergroup to associate with the Forum. 

5. Select Associate.

6. A confirmation screen appears.

8.2.5 Verification/Testing of Restricted Forum
To verify that you have properly set up the Restricted Forum Usergroups 
functionality:

1. At the JTF login, log in as a Regular User who is a member of a Usergroup.

2. Navigate to Forums.

3. Access the restricted Forum associated with your Usergroup.

4. Post a message to the restricted Forum.

5. Log out.

6. Log in to the JTF login as the same user.

7. Navigate to the Forum you posted a message to above (or search for the 
message you posted; see Forums Search Function below).

8. Verify that you can view the message you have just posted.

8.3 Set Forum Access Type to Open
If you decide to change Forum access from Restricted to Open, follow the steps 
below:

1. Login to Oracle iSupport as Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Forum > Modify Status.

3. In the drop-down box, select the restricted Forum you want to change.
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4. Choose Access Type Open

5. Select Modify.

6. Click Ok to confirmation message.

8.4 Change Forum Access Type to Disabled
To close access to a Forum while preparing it for public or restricted viewing, follow 
the steps above in Section 8.3, and select Disabled as Access Type. When you are 
ready to make the Forum accessible, set Access Type in the Modify screen 
referenced above. If Access is Restricted, follow the steps to restrict access detailed 
in the Section 8.2 above.

8.5 Forums Search Function
Follow the guidelines below to use the Forums Search Function.

1. Within Oracle iSupport, navigate to the Forum tab.

2. Select Advanced Search

3. Enter data in any one or all of the following fields:

■ Subject Keyword(s) - Enter keywords that may be in the message headers of 
the appropriate messages.

■ Message Keyword(s) - Enter keywords that may be in the bodies of the 
appropriate messages.

■ Category - Leave the drop-down list set to All to search all Categories, or 
restrict the search to a particular Category by choosing the Category from 
the list.

■ Forum - Leave the drop-down list set to All to search all Forums, or restrict 
the search to a particular Forum by choosing the Forum from the list.

■ Date - Select the calendar icon to the right of the text field, select a date, and 
then select a radio button: Before will find all messages posted before the 
date chosen, and After will find all messages posted after the date chosen.

■ Author - Enter the name of the author of the message. Use the format <first 
name> <space> <last name>
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■ Message Status - Choose from the radio buttons: Read will only search 
messages that have been viewed by a user. Unread will only search 
messages that have not been viewed by a user. All will search both types.

4. Select Search. The application will return a list of messages matching your 
search criteria.

8.5.1 Search Results
Search results are organized into table format, showing the following data, 
organized into columns:

■ Score - Score assigned by the search engine, used to indicate the closeness of the 
match.

■ Subject Name - Message header or subject.

■ Author - Name of the person who posted the message.

■ Date - Date the message was posted.

To view the message, click on the underlined link under Subject Name. You will 
then be able to reply to the message or start a new message thread within the 
message.

8.6 Maintaining Categories, Forums, and Messages
Below are some instructions for performing common Forum maintenance tasks.

8.6.1 Maintaining Categories
Following are directions for common Category maintenance tasks.

8.6.1.1 Delete a Category
To delete a Category:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Category > Delete.

3. Select the Category to delete from the drop-down list.

4. Select Ok.

5. A confirmation message appears.
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8.6.1.2 Rename a Category
To rename a Category:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Category > Rename.

3. Select the Category to rename from the drop-down list.

4. Select Modify and enter the new name.

5. A confirmation screen appears.

8.6.2 Maintaining Forums
Following are directions for common Forum maintenance tasks.

8.6.2.1 Delete a Forum
To delete a Forum:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Forum > Delete.

3. Select the Forum to delete from the drop-down list.

4. Select Remove.

5. A confirmation screen appears; click Ok.

8.6.2.2 Rename a Forum
To rename a Forum: 

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Forum > Rename.

3. Select the Forum to rename from the drop-down list.

4. Enter the new name and select Modify.

5. A confirmation screen appears; click Ok.

8.6.2.3 Move a Forum
To move a Forum from one Category to another Category:

1. At the JTF login, log in as the Oracle iSupport Administrator.
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2. Navigate to Administration > Forum > Forum > Move.

3. Choose the Forum to move from the drop-down list.

4. Choose the destination Category.

5. Select Move.

6. A confirmation screen appears; click Ok.

8.6.2.4 Modify Access Status of a Forum
To modify the Access Type of a Forum:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Forum > Modify Status.

3. Select the Forum to modify from the drop-down list.

4. Change the Access Type by selecting the radio button next to the type.

■ Open: All users have access.

■ Restricted: Only members of a Usergroup have access.

■ Disable: No users have access; no one will see the Forum in the list of 
available Forums.

5. Select Modify.

6. A confirmation screen appears; click Ok.

8.6.2.5 Modify Attributes of a Forum
The Administrator may add or modify attributes to a Forum in order to increase the 
organizational and searching capacities of the Forum:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Forum > Modify Attribute.

3. Choose the Forum to modify from the drop-down list.

4. Select Next. 

5. Select Add New Attribute. The Add Forum Attributes screen displays.

6. Enter the name of the attribute in the Header Name field.

7. Select Mandatory only if you want to require users to fill in an attribute when 
posting to the Forum. The header value is the default value for this attribute.
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8. Select Save.

9. A confirmation screen appears; click Ok.

8.6.2.6 Disassociate a Usergroup from a Forum
To disassociate a Usergroup from a Forum:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Usergroup > Disassociate.

3. Choose a Forum from the drop-down list.

4. Select Next.

5. In the Disassociate Usergroup screen, select a Usergroup from the drop-down 
list.

6. Select Next.

7. A confirmation screen appears; click Ok.

8.6.3 Maintaining Messages
Following are directions for common message maintenance tasks.

8.6.3.1 Delete Messages within a Forum
To delete messages from Forums:

1. At the JTF login, log in as the Oracle iSupport Administrator.

2. Navigate to Administration > Forum > Messages.

3. From the drop-down list, select the Forum that contains message to be deleted.

4. Select Next.

5. The Message Management screen displays a list of all messages, the dates they 
were posted and the authors’ names. Select the underlined link, Delete, next to 
the message you want to delete.

6. A confirmation screen appears; click Ok.

8.6.3.2 Move Messages within a Forum
To move messages from one Forum to another:

1. At the JTF login, log in as the Oracle iSupport Administrator.
Set up Forums 8-11



Disable Menu Option for those not Using Forums
2. Navigate to Administration > Forum > Messages.

3. From the drop-down list, select the Forum that contains message to be moved.

4. Select Next.

5. The Message Management screen displays with a list of all messages, the dates 
they were posted and the authors’ names. Select the underlined link, Move, 
next to the message you want to move.

6. From the drop-down list, select the destination Forum for the message and 
select Ok.

7. A confirmation screen appears; click Ok.

8.7 Disable Menu Option for those not Using Forums
If you do not plan to use Forums, you can disable the Forums tab of Oracle 
iSupport. For directions on how to do this, refer to Implementing CRM Applications 
Release 11i, Installing Oracle Applications Release 11i, and Oracle Applications System 
Administrator’s Guide Release 11i. De-select the menus IBU_CMN_FORUM.
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Set up Homepage

This chapter details how to set up the Homepage in Oracle iSupport. Topics include:

■ Homepage: Considerations

■ Using Default Content and Layout

■ Altering Content and Layout

■ Setting up Subscriptions

9.1 Homepage: Considerations
The Homepage is a personalizable work area for the user. The ISA can either accept 
the default settings shipped with the application (some basic setups are mandatory) 
or add bins and/or alter/add content that appears within bins. The diagram below 
- Homepage Implementation Decision Flowchart - depicts the setup steps. The 
setup steps are also outlined in the following paragraphs.

Important Note: In order to use the Service Request and Knowledge Management 
features that are accessible from the Homepage, there are additional setup steps; 
refer to chapters 4 and 6 of this guide for more information.
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Figure 9–1 Homepage Implementation Decision Flowchart

9.2 Using Default Content and Layout
If you do not wish to add bins or content or change the layout of the Homepage, 
you can leave the default setup as it is. If you wish to alter the defaults, see Section 
9.4 below. The four default bins are:

1. Service Requests. This bin contains Service Request information as determined 
by the merchant. You must set up the Service Request functionality to use this 
feature. For more information, refer to Chapter 4 of this guide, Set up Service 
Request.

2. How Can We Help You?. This bin contains three hyperlinks to commonly-used 
functions:

■ Find a Solution - This is a link to the Knowledge Management search screen. 
You must have Knowledge Management set up to access this link. For more 
information, refer to Chapter 6 of this guide, Set up Knowledge 
Management and Marketing Encyclopedia System.

■ Frequently Used Solutions - This is a link to solutions in Knowledge 
Management that have been designated as Frequently Used Solutions. You 
must have Knowledge Management set up to access this link. For more 
information, refer to Chapter 6 of this guide, Set up Knowledge 
Management and Marketing Encyclopedia System.

■ Create Service Request - This is a link to the create Service Request function. 
You must have Service Request set up to access this link. For more 
information, refer to Chapter 4 of this guide, Set up Service Request.
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3. Alerts. This bin contains hyperlinks to any Alerts you have set up in the 
Marketing Encyclopedia System (MES). You must have MES set up to access 
this link. For more information, refer to Chapter 6 of this guide, Set up 
Knowledge Management and Marketing Encyclopedia System.

4. Account. This bin displays user account information.

9.2.1 Testing/Verification of Default Content
To test that you have properly set up the Homepage using the default content and 
layout:

1. Log in to the JTF login as a Regular User.

2. Verify that you can see the default content on the Homepage.

9.3 Altering Content and Layout
There are two areas of the Homepage that you can alter: the content and the layout. 

9.3.1 About Homepage Content
Homepage Content is defined as either Mandatory or Optional, as described below:

■ Mandatory Content - Information identified as mandatory stays at a fixed 
location on the Homepage and the user cannot disable it. Any content can be 
made mandatory by the merchant.

Note: With Mandatory Content, the user has the ability to edit the format of 
some bins selecting the Edit link on the top of the bin. For example, if you set 
up Service Requests as a mandatory bin, the user can still choose the fields that 
are displayed within the bin. 

■ Optional Content - The user can choose not to display the content or can change 
its layout on the Homepage. The merchant can identify any content as optional.

Information on the Homepage comes from various sources, including Oracle 
Customer Support-TeleService, Oracle Contracts for Service, the Knowledge 
Management system, the Marketing Encyclopedia System (MES), and others as 
defined by the merchant. 
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9.3.2 Steps to Add MES Content
The Marketing Encyclopedia System (MES) supplies the seeded Alerts bin. It is also 
the source for Company News, if you choose to set up Company News. Follow the 
instructions below to add MES content. 

Important Note: You must already have set up the MES application. For more 
information, refer to Chapter 6 of this guide, Set up Knowledge Management and 
MES.

1. Log into the JTF login screen as the Oracle iSupport Administrator. 

2. Navigate to Administration > Homepage > Content > Add MES Content.

3. In the Add MES Content screen, select the content that you wish to add by 
clicking on the checkbox next to the content name.

4. Select Save. The Content Administration screen appears. 

5. Optionally, to restore original values click Clear, or select Cancel to return to the 
previous screen without saving.

9.3.3 Change Content Layout
To change the layout of the content:

1. Log into the JTF login screen as the Oracle iSupport Administrator.

2. Navigate to Administration > Homepage > Content > Mandatory Layout.

3. To change whether the bins are displayed in a wide column or a narrow 
column, use the directional buttons (<) (>). Content defined as Narrow format 
can be moved into Wide column, but not vice versa. 

4. To change the order of the bins, use the up and down arrow buttons at the top 
of the two windows.

5. When finished, select Update. Optionally, to return to original values, select 
Cancel.

9.3.3.1 Testing/Verification of Content Layout
To test that you have successfully altered the layout of the Homepage:

1. Log in to the JTF login as a Regular User.

2. Verify that you can see the new layout on Homepage.
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9.3.4 Steps to Alter Existing Content
To alter information on the Homepage:

1. Log into the JTF login screen as the Oracle iSupport Administrator (ISA).

2. Navigate to Administration > Homepage > Content.

3. In the Content Administration window, select the underlined link of the content 
to alter.

4. The items that you can alter will vary depending upon the content. Most 
content will have the following alterable fields.

■ Content Name - This is bin name, which is currently not editable.

■ Format - Use the drop-down menu to select Wide or Narrow. Wide content 
display is twice as wide as the Narrow content. If you choose Wide, the 
category will always be displayed in Wide format on the user’s Homepage. 
If you choose Narrow, users will have the choice when setting up their 
Homepages to display the category in Wide or Narrow format, but only for 
bins that are not mandatory. It is not recommended set as Narrow 
information that would best be displayed in a wide format, for example, 
long blocks of text.

■ View Status - This field determines what class(s) of users can view the 
information. The View Status column displays either Employee, Customer, 
or Both. If the status is Both, then both the Merchant and the Customer type 
of user may view the information. Employees of your company will be in 
the Merchant class, while persons registering from outside the company, 
i.e., customers, will be in the Customer class of user.

■ Content Source - Either a PL/SQL package name or Java object path 
provides the content information. 

-If the choice is PL/SQL, the merchant must provide a valid PL/SQL 
package name in the text box next to the drop-down field. Please con-
sult your information systems administrator for more information.

-If the choice is Java Object, the merchant must provide a Java class 
name, in the text box next to the drop-down field, which adheres to the 
standard interface, i.e., provides an API to retrieve. Please consult your 
information systems administrator for more information.

■ Mandatory - Requires display of the information at a fixed location on the 
Homepage. Users cannot change the location or whether or not the content 
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displays on their Homepages. Bins set as Mandatory will always display at 
the top of the column.

■ Disable - Disables the content.

5. Select Update.

6. Optionally, to restore original values click Restore, or select Cancel to return to 
the previous screen without saving.

9.3.4.1 Testing/Verification of Non-Default Content
To test that you have properly set up the Homepage using the content that you 
added in the steps above:

1. Log in to the JTF login as a Regular User.

2. Verify that you can see the new content on Homepage.

9.3.5 Overview of Content Administration Screen
The Content Administration screen displays content variables. Below is a discussion 
of the content displayed.

9.3.5.1 Column 1: Checkboxes
To delete an item, select the checkbox and click Delete Content. You cannot undo 
the delete.

9.3.5.2 Column 2: Content Name
Oracle iSupport contains four seeded content categories. These are: Account, How 
can we help you?, Service Request, and Alerts. Merchants can add categories by 
clicking Add Content or Add MES Content. 

9.3.5.3 Column 3: Disable
The Disable column indicates that the content is unavailable to users. 

9.3.5.4 Column 4: Mandatory
Users cannot unsubscribe to mandatory information or alter the layout when 
setting up their Homepages.
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9.3.5.5 Column 5: Content Format
Content format is characterized as Wide or Narrow. Wide content display is twice as 
wide as the Narrow content. 

9.3.5.6 Column 6: From MES
The From MES column indicates whether or not the information is from the 
Marketing Encyclopedia System. See Set up Knowledge Management and MES for 
more information.

9.3.5.7 Column 7: View Status
The View Status column displays either Employee, Customer, or Both. This setting 
indicates what class(s) of users may view the information. For example, if the status 
is Both, then both the Employee and the Customer type of user may view the 
information. Employees of your company will be in the Employee class, while 
persons registering from outside the company, i.e., customers, will be in the 
Customer class of user.

9.4 Set up Subscriptions
Oracle iSupport allows users to receive content from the Homepage in an e-mail. If 
the user elects to receive this e-mail, it is necessary for the user to select the Enable 
Email Subscription in the user profile. The ISA must set up Subscription Templates 
and Email Interval options to enable this functionality. 

9.4.1 Steps to Set up Subscription Templates
To set up subscription templates for e-mail content:

1. Log in to the JTF login as Oracle iSupport Administrator.

2. Navigate to Homepage > Subscription.

3. In the Subscription Template Administration screen, choose a language for the 
headers and footers of the template.

Note: The language you select as the template header/footer language, will not 
affect the language of the body of the e-mail. The language of the body is 
determined by the language chosen in the User Profile screen.

4. In the Subject text field, enter the name of the subscription template. 
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5. In the Header field, enter the information you want in the header. Seeded 
values for both header and footer are located in the Clue Word/Description 
table at the bottom of the screen. 

6. In the footer field, enter the information you want in the footer.

7. Select Update to Save the changes, Restore to return to original values, or 
Reload.

9.4.2 Set up Email Interval
To set up the time interval options between e-mails:

1. Log in to the JTF login as Oracle iSupport Administrator.

2. Navigate to Homepage > Subscription > Email Interval.

3. In the Email Subscription Interval screen, choose the minimum time between 
e-mails in the Range Start text box.

4. In the Range End box, select the maximum time between e-mails.

5. In the Range Step box, set the step between the start and end time.

6. In the Default Interval textbox, set the default interval to appear in the 
drop-down list.

7. Select Update to save or Restore to return to previous values.

9.4.3 Subscriptions Concurrent Program
The Subscriptions concurrent program for tracking user subscriptions in the queue 
will also need to be configured from Oracle Applications. The name of the program 
is Notification Mailer.
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 User Communications Setup

This chapter details how to set up the User Communications functions of Oracle 
iSupport. Topics include:

■ Use User Communications Features

■ Set up Call Me

■ Set up Surveys/Feedback

■ Disable menus (for those not implementing User Communication)

10.1 Use User Communication Features
In order to utilize Oracle iSupport’s user communications features -- Call Me and 
Surveys/Feedback -- you must set up the other applications on which they depend. 

10.2 Set up Surveys/Feedback
The Surveys/Feedback functionality of Oracle iSupport allows you to survey your 
users on topics of your choice. In order to enable Surveys, you must set up Oracle 
Scripting according to the Oracle Scripting Implementation Guide Release 11i. After you 
have set up Oracle Scripting, follow the steps below to set up Surveys/Feedback.

10.2.1 Set up Feedback Configuration
1. Log into Oracle iSupport as the Oracle iSupport Administrator.

2. Navigate to Administration > Support > Survey > Feedback Configuration.

3. Enter the required values.

4. Select Update to save the data.
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10.2.2 Create Surveys
To create a survey for users to respond to, follow these steps:

1. Log into Oracle iSupport as the Oracle iSupport Administrator.

2. Navigate to Support > Survey > Feedback List.

3. Select Add New Survey.

10.3 Set up Call Me
Call Me allows users to submit a call-back request via the Oracle iSupport user 
interface. Since the call-back request is routed through Oracle MultiMedia Manager, 
you must set up MultiMedia Manager for this feature to work properly. Refer to the 
Oracle MultiMedia Implementation Guide Release 11i for details.

After you have set up Oracle MultiMedia, follow the steps below to set up the Call 
Me function.

1. Log into Oracle iSupport as the Oracle iSupport Administrator.

2. Navigate to Support > Call Me.

3. Enter values for the following:

■ OTM Server Host Name: Enter the server that the Oracle Telephone 
Manager is running on. 

■ OTM Server Port: Enter the port that the Oracle Telephony Manager is 
running on.

4. Select Update to save the data. 

10.4 Disable Menu Option
If you do not plan to use User Communications, you can disable the Surveys and 
Call Me tabs of Oracle iSupport. For directions on how to do this, refer to 
Implementing CRM Applications Release 11i, Installing Oracle Applications Release 11i, 
and Oracle Applications System Administrator’s Guide Release 11i. De-select the menus 
IBU_HLP_FEEDBACK and/or IBU_HLP_CALLME.
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Profile Options and Concurrent Programs

This chapter discusses system profile option settings and concurrent manager 
setups. Topics include:

■ Before you Begin

■ About User Profile Options

■ Set JTF Application-Level Profile Options

■ Set Foundation (JTF) Properties

■ Concurrent Programs

11.1 Before you Begin
Before making Oracle Applications (Forms) settings, ensure that Oracle 
Applications is up and running. In particular, if you stopped concurrent managers 
before applying Oracle Applications patchsets, ensure that they are running. (See 
Concurrent Programs later in this chapter and the Oracle System Administrator’s 
Guide for more information.)

11.2 About User Profile Options
A user profile is a set of changeable options that affect the way Oracle applications 
appear and how they function. Oracle Applications uses a set of user profile options 
that are common to all the applications; in addition, each module has its own 
unique set of user profile options. User profile options are set within the Oracle 
Applications (Forms). For a list of profile options in the Oracle Application Object 
Library (AOL), see Oracle Applications System Administrator’s Guide.
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The system administrator sets user profile options at four levels that have a set 
hierarchy. From lowest level to highest, the profiles categories are:

1. Site - Option settings pertain to all users at an installation site; has the lowest 
priority.

2. Application - Option settings pertain to all users of any responsibility 
associated with the application; has the next-to-lowest priority.

3. Responsibility - Option settings pertain to all users currently signed on under 
the responsibility; has the second-highest priority.

4. User - Option settings pertain to an individual user, identified by application 
username; has the highest priority.

Each user profile ordinarily exists at each level. For example, Oracle Applications 
provides a site-level Printer option, an application-level Printer option, and so on. 
Oracle Applications enforced the level hierarchy to ensure that a higher-level option 
value overrides a lower-level value. For example, if your site-level Printer option is 
set to Printer 1, but your user-level Printer option is set to Printer 2, printing will 
occur at Printer 2. 

Site-level option values are generally set by the system administrator before profile 
options are specified at the other three levels. The options specified at site-level 
work as defaults until the same options are specified at the other levels. 

Changes to the user profile option values take effect as soon as your users log on 
again or change responsibilities.

You must set the JTF profile options before the merchant UI will display. The values 
of the profiles set the basic JTF foundation default elements and values. These 
profiles are seeded in the Profiles form in ERP, and values are defined by the user 
(as System Administrator). These profiles are set on the user level for IBU_ADMIN 
user. The IBU_SYS_ADMIN user is seeded with the product and is the owner of 
these profile options.

11.3 Set JTF Application-Level Profile Options
First you must set application-level profile options:

1. Log on to Oracle Applications (Forms) as sysadmin/sysadmin.

2. Select the System Administrator Responsibility.

3. Navigate to Profile > System > Find System Profile Values form.

4. Check Application and enter iSupport. Uncheck Site if necessary.
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5. In the Profile field, enter JTF_PROFILE%, and select Find.

6. Verify and/or set the following JTF profile options for Oracle iSupport:

JTF_PROFILE_DEFAULT_APPLICATION - This is the default application ID. 
Set it to 672.

JTF_PROFILE_DEFAULT_BLANK_ROWS - This sets the number of blank 
rows on merchant UI forms (can be set to any integer greater than zero). Set it to 
3.

JTF_PROFILE_DEFAULT_CSS - This designates the default cascading style 
sheet to use for HTML display. Set it to jtfucss.css.

JTF_PROFILE_DEFAULT_CURRENCY - This tells the application which 
country’s monetary currency to use as a default. Set it to USD for U.S. Dollars.

JTF_PROFILE_DEFAULT_NUM_ROWS - Set this value to 10.

7. On the same screen, verify and/or set the following profile option at 
application level for Oracle iSupport:

JTF_PROFILE_DEFAULT_RESPONSIBILITY - This is the default 
responsibility ID. This is different in every instance (Query the system for the 
IBU_NORMAL_USER responsibility and fill in the value found there).

See Oracle Applications System Administrator’s Guide for more information.

11.4 Set JTF User-Level Profile Options
Next, set user-level profile options for ibu_guest and sys_admin:

1. Log on to Oracle Forms as sysadmin/sysadmin.

2. Select the System Administrator Responsibility.

3. Navigate to Profile > System > Find System Profile Values form.

4. Check Application and User, enter iSupport and IBUGUEST, respectively.

5. In the Profile field, enter JTF_PROFILE%, and select Find.

6. IBUGUEST PROFILE OPTIONS: Verify and/or set the following JTF ibuguest 
profile options at the user level for Oracle iSupport:

■ JTF_PROFILE_DEFAULT_APPLICATION - This is the default application 
ID. Set it to 672.
Profile Options and Concurrent Programs 11-3



Set Foundation (JTF) Properties
■ JTF_PROFILE_DEFAULT_CURRENCY - This tells the application which 
country’s monetary currency to use as a default. Set it to USD for U.S. 
Dollars.

■ JTF_PROFILE_DEFAULT_RESPONSIBILITY - This is the default 
responsibility ID. This is different in every instance (Query the system for 
the IBU_NORMAL_USER responsibility and fill in the value found there).

7. IBU SYS ADMIN PROFILE OPTIONS: Verify and/or set the following JTF ibu 
sys admin profile options at the user level for Oracle iSupport:

■ JTF_PROFILE_DEFAULT_APPLICATION - This is the default application 
ID. Set it to 672.

■ JTF_PROFILE_DEFAULT_CURRENCY - This tells the application which 
country’s monetary currency to use as a default. Set it to USD for U.S. 
Dollars.

■ JTF_PROFILE_DEFAULT_RESPONSIBILITY - This is the default 
responsibility ID. This is different in every instance (Query the system for 
the IBU_NORMAL_USER responsibility and fill in the value found there).

See Oracle Applications System Administrator’s Guide for more information.

11.5 Set Foundation (JTF) Properties
Use the following procedure to set up JTF properties:

1. Go to http://<host>:<apache port>/html/jtflogin.jsp, then log in as 
sysadmin/sysadmin.

2. Navigate to Advanced > Properties > View JTF to view JTF properties.

3. Select Next to go to the next page. Make sure guest_partyname is IBUGUEST, 
guest_password is ibuguest2000, and guest_username is ibuguest. To change 
the password, click on it.

Note: If you change the password here, it will not be reflected in Oracle Forms. 
To maintain consistency you must also change the IBUGUEST password 
manually in Forms.

4. Find and select framework.Logging.system.level, and set sequence 1 value to 
debug.

5. Select Update twice.

6. Find service.Logging.common.level, and change it to debug.
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7. Navigate to Registration > Default Responsibility.

8. Select Business Users from the pull-down menu and set the following:

■ Set Default Application ID to 672.

■ Set Default Responsibility to the value in the IBU_NORMAL_USER 
responsibility field. This is different in every instance (Query the system for 
the IBU_NORMAL_USER responsibility and fill in the value found there).

9. Select End Users from the pull-down menu and set the following:

■ Set Default Application ID to 672.

■ Set Default Responsibility to the value in the IBU_NORMAL_USER 
responsibility field. This is different in every instance (Query the system for 
the IBU_NORMAL_USER responsibility and fill in the value found there).

10. Select Submit. You do not receive feedback on the update, and remain on the 
same webpage.

11.5.1 Set Profile Options for Language and Currency
Set the FND_LANGUAGES and FND_CURRENCY profile options in Oracle 
Applications Object Library (AOL) with the appropriate languages and currencies. 
Defaults for Oracle iSupport come from the list of values populated by the values 
that you entered in AOL for these profile options. See Oracle Applications System 
Administrator’s Guide for more information.

11.5.2 Set Multi Organization (MO) Profile Options
Use the following procedure to set up multi-organization profile options:

1. Log on to Oracle Applications (Forms) as sysadmin/sysadmin.

2. Select the System Administrator Responsibility.

3. Navigate to Profile > System > Find System Profile Values.

4. Check Site and Responsibility. Enter IBU_NORMAL_USER as the responsibility.

5. In the Profile field, enter MO% and select Find.

6. Verify and/or set the MO: Operating Unit profile option to Vision Operations at 
the responsibility level. This determines the operating unit being used in Oracle 
iSupport.

See Oracle Applications System Administrator’s Guide for more information.
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11.5.3 Profile Options for Creating Returns
For the Create Returns functionality to work in Oracle iSupport, you must set the 
following profile options in Oracle Applications (Forms) for Oracle Order Capture:

ASO: Default Currency Code - One of the two profile options that determines the 
currency of the transactions in the application. The currency defined in ASO: 
Default Order Type takes precedence over this profile option.

ASO: Default Order State - The default state of the order when the quote is 
booked. Determines whether or not the quote can be booked or entered.

ASO: Default Order Type - Determines how the order is to be processed in Oracle 
Order Management. The order types are set up in Oracle Order Management. This 
profile determines what price list and currency code appears by default in the main 
Order Capture form.

ASO: Default Person ID - The default sales representative who is allocated the 
sales credits for booked orders when the user is not entered as a sales 
representative.

ASO: Product Organization - The organization that Order Capture uses to validate 
inventory items.

ASO: Validate Salesrep - If this profile is set to Yes, then the application checks to 
see if the user is set up as a valid sales representative. If it is set to No, then the 
application uses the default sales representative entered in ASO: Default Person ID.

11.5.4 Profile Options for Service Requests
For the Service Request functionality to work in Oracle iSupport, you must set the 
following profile options in Oracle Applications (Forms) for Oracle Customer 
Support-TeleService. To determine the values, query the system using the "Service" 
keyword.

INC_DEFAULT_INCIDENT_SEVERITY: Determines the default severity when 
creating Service Request.

INC_DEFAULT_INCIDENT_STATUS: Determines the default status when 
creating Service Request.

IBU_A_CLOSED_STATUS: Determines the closed status when closing a Service 
Request.

INC_DEFAULT_INCIDENT_OWNER: Determines the default Resource ID when a 
Service Request is created.
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CS_SR_DEFAULT_OWNER_TYPE: Determines the Resource Type when a Service 
Request is created.

IBU_SR_CREATE_NOTE_TYPE: Determines the default Note Type when a Service 
Request is created.

IBU_SR_UPDATE_NOTE_TYPE: Determines the default Note Type used when a 
Service Request is updated.

IBU_SR_ESCALATE_NOTE_TYPE: Determines the default Note Type when a 
Service Request is escalated.

IBU_SR_CLOSED_NOTE_TYPE: Determines the default Note Type when a 
Service Request is closed.

IBU_A_SR_KB_OPTION: Determines whether a Knowledge Base Prompt shows 
up on the Service Request creation page or not, and whether or not the Knowledge 
Base search procedure is required.

IBU_A_SR_PRODUCT_SELECTION_OPTION: Should be set if the product 
selection enforcement option is being used.

11.5.5 Set up Knowledge Management Profile Options
CS_KB_ALLOW_KB_NOTE_UPDATE - Allows the update of notes that have been 
saved to the Knowledge Base. 

Seeded value: No

Allowed values: No, Yes

CS_KB_DEFAULT_SOLUTION_TYPE - Allows you to define a specific Solution 
Type as a default. 

Allowed values: any. 

Seeded default values: 

■ KB_SYMPTOM

■ KB_FACT

■ KB_CHANGES

■ KB_CAUSE

■ KB_OBJECTIVE

■ KB_ACTION
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CS_KB_DEF_CONTRIBUTION_STATUS - Default Status for Knowledge Base 
Contributions: You can use the status with user privileges to determine which users 
can see what information.

Seeded default value: Draft

Allowed values:

■ DRAFT

■ PUBLIC

■ PUBLIC_INTERNAL

■ TECHNICAL_REVIEW

■ UNDER_EDIT

■ PUBLIC_LIMITED

CS_KB_MAX_SEARCH_RESULTS - Maximum Number of Search Results to be 
Queried from the Database: You can set up this value to any reasonable number. 
The top scored results in the database will be displayed from the highest score to 
the lowest score.

Seeded default value: 100

11.6 Concurrent Programs
A concurrent program is an executable file that runs simultaneously with other 
concurrent programs and with online operations, fully utilizing your hardware 
capacity. Typically, a concurrent program is a long-running, data-intensive task, 
such as posting a journal, generating a report, or repopulating table data. You set up 
and run concurrent programs from Oracle Applications (Forms). The concurrent 
programs required by Oracle iSupport are discussed in this chapter. See Oracle 
Applications System Administrator’s Guide for more information on concurrent 
programs.

11.6.1 Usergroup Creation
The concurrent program, Usergroup Creation, must be run any time you add to or 
update a Usergroup. The short name for the program is IBUUG. This program 
populates additional tables and makes the Usergroup visible in the Marketing 
Encyclopedia System (MES). 
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11.6.2 Installed Base Interface
The concurrent program, Installed Base Interface, must be run any time you add to 
or update products within the Installed Base. This program adds products to the 
Installed Base.

11.6.3 Notification Mailer
The concurrent program, Notification Mailer, should be run to allow the tracking of 
user subscriptions in the queue. This is part of the Subscriptions program associated 
with the Homepage. 

11.6.4 Synchronize Employee
Changes to Human Resources will not take place in Resources until this request has 
been run. 

11.6.5 Knowledge Management and MES
It is necessary to run two concurrent programs to populate the tables that supply 
data to the Solution Management System. How often you run these programs 
depends upon the specific needs of your company. Run these programs often 
enough to pick up additions to the knowledge base in a timely manner, but not so 
often as to cause resource issues. The two concurrent programs are:

11.6.5.1 Knowledge Base Sync Indexes
This concurrent program retrieves any solutions that are entered in the knowledge 
base. You must periodically synchronize the InterMedia Index. Intermedia text does 
not generate indexes automatically. When a new entry is added to the database, you 
cannot see it until the index is rebuilt. The short name for the concurrent program is 
CS_KB_SYNC_INDEX. 

If new solutions are not retrievable after entry, the most likely cause is that a 
concurrent program failed to run or that the interval is too long.

11.6.5.2 Knowledge Base Update Used Count Summary
The Used Count table is not refreshed automatically and thus requires a concurrent 
program to update the table. This concurrent program is used to determine the 
most frequently used solutions and part of the solution score while performing a 
search. Frequently Used Solutions lists the top x solutions and is defined by the 
merchant. It is based on the number of times that a solution has been used to solve 
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an issue. Each time the Solved button is clicked, the concurrent program updates 
the count by one. 

The solution score found in the Search Results page uses the Solution Used Count 
and the InterMedia Index text match score to help place the solution properly in the 
search results list. The higher the used count and the text match score, the higher 
the solution is placed in the results list.

The short name for this concurrent program is CS_KB_UPDATE_USED_COUNT.

11.6.6 Steps to Run the Concurrent Programs
Use the following procedure to run the concurrent programs.

1. Log in to Oracle Applications Forms as sys admin.

2. Select the System Administrator responsibility.

3. Navigate to Requests > Run

4. Click Submit New Request.

5. Click Single Request.

6. Choose the program name, enter parameter if needed. (The concurrent 
programs can be scheduled to run periodically).

7. Click Ok.

11.6.7 Steps to View Concurrent Program Request Status
Use the following procedure to view concurrent programs request status.

1. Log in to Oracle Applications Forms as sys admin.

2. Select the System Administrator responsibility.

3. Navigate to Requests > View.

4. Enter the Request Id or other criteria or search all requests.

5. Click Refresh to see the latest status.
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Getting Help/Additional Information

This appendix contains information about additional information or services that 
you may find useful as you install or upgrade Oracle Applications. It contains the 
following topics:

■ Related Documentation

■ Oracle Customer Service

A.1 Related Documentation
All Release 11i documentation is included on the Oracle Applications Document 
Library CD supplied in your Release 11i CD Pack. You can download some 
soft-copy documentation from http://docs.oracle.com. Or, you can purchase 
hard-copy documentation from the Oracle Store at http://oraclestore.oracle.com. 
Documentation not found in any of these sources can be found on OracleMetaLink 
(http://metalink.oracle.com).

A.1.0.1 Oracle iSupport
■ Oracle iSupport Implementation Guide, Release 11i

■ Oracle iSupport Concepts and Procedures, Release 11i

A.1.0.2 Oracle Applications (Forms)
■ Oracle Applications Product Update Notes, Release 11i

■ Installing Oracle Applications, Release 11i

■ Oracle Applications Concepts

■ Maintaining Oracle Applications, Release 11i
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■ Upgrading Oracle Applications, Release 11i

■ Oracle Applications System Administrators Guide

■ Oracle Applications (Error) Messages Manual

■ Oracle Applications User’s Guide

■ Oracle Applications Implementation Wizard User Guide

■ Oracle Self-Service Web Applications Implementation Manual

■ Oracle Workflow Guide

■ A System Administrators’ Guide: Oracle Applications 11i Workflow

A.1.0.3 CRM Foundation (JTF)
■ Implementing Oracle CRM: ERP Functional Checklist, Release 11i

■ Implementing Oracle CRM: Foundation Functional Checklist, Release 11i

■ Implementing CRM Applications, Release 11i

■ Installing Oracle Applications, Release 11i

■ Oracle Applications Concepts, Release 11i

■ Oracle Applications System Administrator’s Guide

■ Supplemental CRM Installation Steps Release 11.5.1-11.5.3 

A.1.0.4 Architecture in Oracle Applications
■ Multiple Organizations in Oracle Applications

■ Multiple Reporting Currencies in Oracle Applications, Release 11i

■ Oracle Applications Flexfields Guide

A.1.0.5 Knowledge Management and MES
■ Oracle Service Concepts and Procedures, Release 11i

■ Oracle Service Implementation Guide, Release 11i

■ Oracle Service User's Guide Release 11i 

■ Oracle Marketing Encyclopedia System Implementation Guide, Release 11i

■ Oracle Marketing Encyclopedia System Concepts and Procedures, Release 11i
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A.1.0.6 Products/Orders
■ Oracle Inventory Implementation Guide, Release 11i

■ Oracle Inventory Concepts and Procedures, Release 11i

■ Oracle Installed Base Concepts and Procedures Release 11i

■ Oracle Order Management User’s Guide, Release 11i

■ Oracle Accounts Receivable, Release 11i

A.1.0.7 Service Requests
■ Oracle Support Concepts and Procedures, Release 11i

■ Oracle Support Implementation Guide, Release 11i

■ Oracle Customer Care Concepts and Procedures, Release 11i

■ Oracle Customer Care Implementation Guide, Release 11i

■ System Test Plan - Customer Support

A.1.0.8 Contracts
■ Oracle Contracts for Service Concepts and Procedures, Release 11i

■ Oracle Contracts Core Concepts and Procedures, Release 11i

A.1.0.9 Oracle MultiMedia Channel Manager/Telephony Manager
■ Oracle Telephony Manager Implementation Guide, Release 11i

■ Oracle Telephony Manager Concepts and Procedures, Release 11i

■ Oracle Telephony Manager Technical Reference Manual

A.1.0.10 Oracle Call Center
■ Installing Oracle Call Center Connectors

■ Oracle Call Center Connectors Implementation Guide, Release 11i

■ Installing Oracle Call Center Connectors, Release 11i

■ Oracle Call Center Applications Setup, Release 11i

A.1.0.11 Oracle Scripting
■ Oracle Scripting Implementation Guide, Release 11.5.1-11.5.3
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■ Oracle Scripting Concepts and Procedures, Release 11.5.1-11.5.3 

■ Oracle Scripting Technical Reference Manual

A.1.0.12 DEMS
■ Oracle Defect and Enhancement Management Implementation Guide, Release 11i

■ Oracle Defect and Enhancement Management Concepts & Procedures, Release 11i

A.2 Oracle Customer Service
Oracle provides the following services and sources of information to help you with 
your installation or upgrade:

OracleMetaLink
OracleMetaLink is your self-service support connection with web, telephone menu 
and email alternatives. Oracle supplies these technologies for your convenience, 
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain 
information and advice from technical libraries and forums, download patches, 
look at bug details, and create or update TARs. To use MetaLink, register at 
(http://metalink.oracle.com).

Alerts: You should check OracleMetaLink alerts before you begin to install or 
upgrade any of your Oracle Applications. Navigate to the Alerts page as follows:             
Technical Libraries/ERP Applications/Applications Installation and 
Upgrade/Alerts. 

Self-Service Toolkit: You may also find information by navigating to the 
Self-Service Toolkit page as follows: Technical Libraries/ERP 
Applications/Applications Installation and Upgrade.

Consulting Services/Support
Installing any software package can be complex due to the number of configuration 
options, network and operating systems, dependencies, and other considerations. 
Oracle Consulting Services and Oracle Support Services are the main sources of 
help for installing Oracle Applications. 

Oracle Consulting Services can help you:

■ determine machine size and database size required by Oracle Applications

■ install or upgrade Oracle Applications
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■ implement Oracle Applications products

■ customize Oracle Applications products

■ install and configure multiple language support

■ develop custom applications for use with Oracle Applications

■ train users of Oracle Applications

The Oracle Support Services website at http://www.oracle.com/support offers 
registered OracleMetaLink customers self-service support technologies, available 24 
hours a day, 7 days a week. If you contact Oracle Support Service, have this 
information available:

■ your CSI number

■ operating system and version

■ release number of Oracle Applications you are installing and the versions of the 
Oracle Server and Oracle tools you are using

■ release number of Oracle Applications you are upgrading from

■ a description of the problem as well as specific information about any error 
messages you received

■ whether you have dial-in capability

■ the output of the AD Configuration utility, contained in the adutconf.lst file 
(additional information: AD Configuration, Maintaining Oracle Applications)
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