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Preface

Welcome to the Oracle Customer Relationship Management, Release 11i, suite of 
applications.

This Implementation Guide provides general descriptions of the setup and 
configuration tasks required to implement Oracle Interaction Blending successfully. 

This preface explains how this Implementation Guide is organized and introduces 
other sources of information that can help you.

Intended Audience
This guide is aimed at the following users:

� Anyone implementing Oracle Interaction Blending

This guide assumes you have the following prerequisites:

� Understanding of the company business processes

� Basic understanding of Oracle Applications, Release 11i

� Understanding of interaction center technology
vii



Structure
This manual contains the following sections:

� Section 1.1, "Overview of Oracle Interaction Center"

� Section 1.2, "Planning the Implementation of Oracle Interaction Blending"

� Section 1.3, "Understanding Oracle Applications User Accounts"

� Section 1.4, "Defining an Oracle Interaction Blending Administrator"

� Section 1.5, "Configuring Oracle Interaction Blending"

� Section 1.6, "Setting Up an Interaction Center"

� Section 1.7, "Understanding Media Classifications"

� Section 1.8, "Integrating Oracle Interaction Blending with Oracle Universal 
Work Queue"

� Section 1.9, "Integrating Oracle Interaction Blending with Oracle Telephony 
Manager"

� Section 1.10, "Documentation Resources"

Documentation Accessibility
Oracle’s goal is to make our products, services, and supporting documentation accessible to the 
disabled community with good usability. To that end, our documentation includes features that make 
information available to users of assistive technology. This documentation is available in HTML 
format, and contains markup to facilitate access by the disabled community. Standards will continue 
to evolve over time, and Oracle is actively engaged with other market-leading technology vendors to 
address technical obstacles so that our documentation can be accessible to all of our customers. For 
additional information, visit the Oracle Accessibility Program web site at 
http://www.oracle.com/accessibility/.
viii



Implementing Oracle Interaction Ble
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Implementing Oracle Interaction Blending

This guide provides descriptions of the setup and configuration tasks required to 
implement Oracle Universal Work Queue successfully. This guide contains the 
following information:

� Overview of Oracle Interaction Center

� Planning the Implementation of Oracle Interaction Blending

� Understanding Oracle Applications User Accounts

� Defining an Oracle Interaction Blending Administrator

� Configuring Oracle Interaction Blending

� Setting Up an Interaction Center

� Understanding Media Classifications

� Integrating Oracle Interaction Blending with Oracle Universal Work Queue

� Integrating Oracle Interaction Blending with Oracle Telephony Manager

� Documentation Resources

1.1 Overview of Oracle Interaction Center
Every customer interaction -- a telephone call, an email, or a Web chat -- presents an 
opportunity to win new business or improve customer satisfaction. An interaction 
center is an environment in which human agents manage interactions with 
customers through multiple contact channels. 

Oracle Interaction Blending is one of several applications in the Oracle Interaction 
Center. The Oracle Interaction Center is a suite of applications that supports the 
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Overview of Oracle Interaction Center
management and processing of customer relationship activity across all channels of 
customer contact.

The Oracle Interaction Center suite includes:

Oracle Advanced Inbound Oracle Advanced Inbound enables Oracle Customer 
Relationship Management (CRM) business applications to handle multiple media 
channels.

Oracle Advanced Outbound Oracle Advanced Outbound provides list 
management and predictive dialing for outbound telephony campaigns.

Oracle eMail Center Oracle eMail Center is an email interaction management 
application. Oracle eMail Center can automate or suggest responses to inbound 
email.

Oracle Scripting Oracle Scripting is an application for developing and deploying 
scripted presentations for customer interactions. The scripted presentations guide 
agents through their interactions with customers.

See Also
� What is Oracle Interaction Blending?

� Integration Dependencies for Oracle Interaction Blending

� Sizing Guidelines for Oracle Interaction Blending

� Scalability for Oracle Interaction Blending

1.1.1 What is Oracle Interaction Blending?
Oracle Interaction Blending provides the ability to "blend" voice calls, e-mails, etc. 
between inbound and outbound agents. For instance as inbound call volumes 
decrease, agents can dynamically move to handle incoming e-mail or outbound 
phone calls. This significantly increases agent productivity and improves customer 
service. Oracle Interaction Blending assigns agents to handle inbound and 
outbound media depending on call volume and service levels.

See Also
� Overview of Oracle Interaction Center

� Integration Dependencies for Oracle Interaction Blending
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Overview of Oracle Interaction Center
� Sizing Guidelines for Oracle Interaction Blending

� Scalability for Oracle Interaction Blending

1.1.2 Integration Dependencies for Oracle Interaction Blending
Oracle Interaction Blending has a number of integration points with other Oracle 
products.

1.1.2.1 Installation Dependencies
Oracle Interaction Blending has references to the common and shared components 
of the following products.

� Oracle Applications Foundation (FND)

� CRM Foundation (JTF)

� Common CRM Interaction Center Technology Schema (IEO)

� Oracle Universal Work Queue

� Oracle Telephony Manager -- Routing Server

See Also
� Overview of Oracle Interaction Center

� What is Oracle Interaction Blending?

� Sizing Guidelines for Oracle Interaction Blending

� Scalability for Oracle Interaction Blending

1.1.3 Sizing Guidelines for Oracle Interaction Blending
Oracle Interaction Blending complies with the general sizing recommendations for 
the Oracle database and Oracle Applications used in your business operations.

See Also
� Overview of Oracle Interaction Center

� What is Oracle Interaction Blending?

� Integration Dependencies for Oracle Interaction Blending

� Scalability for Oracle Interaction Blending
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Planning the Implementation of Oracle Interaction Blending
1.1.4 Scalability for Oracle Interaction Blending
Oracle Interaction Blending complies with the general scalability recommendations 
for the Oracle database and Oracle Applications used in your business operations.

See Also
� Overview of Oracle Interaction Center

� What is Oracle Interaction Blending?

� Integration Dependencies for Oracle Interaction Blending

� Sizing Guidelines for Oracle Interaction Blending

1.2 Planning the Implementation of Oracle Interaction Blending
Plan your implementation to ensure that you understand the scope of the 
implementation project.

See Also
� Overview of Implementing Oracle Interaction Blending

� Implementation Starting Point

1.2.1 Overview of Implementing Oracle Interaction Blending
The following list is a high-level overview of the steps for implementing Oracle 
Interaction Blending.

1. Define an Oracle Interaction Blending administrator.

See Defining an Oracle Interaction Blending Administrator.

2. Configure Oracle Interaction Blending.

See Configuring Oracle Interaction Blending.

See Also
� Implementation Starting Point

1.2.2 Implementation Starting Point
This implementation guide assumes that you have, at a minimum:
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Understanding Oracle Applications User Accounts
� Installed Oracle Applications (database, technology stack, and Oracle 
Applications files).

See Installing Oracle Applications or Upgrading Oracle Applications.

� If implementing Oracle eMail Center, installed Microsoft Internet Explorer on 
the agent desktop -- otherwise, installed Netscape Communicator.

� Installed JInitiator on the agent desktop.

� Optionally, implemented Oracle Human Resource Management Systems.

See Implementing Oracle HRMS.

� Implemented CRM Foundation Resource Manager.

See Oracle CRM Foundation Implementation Guide.

� Implemented one of Oracle TeleSales or Oracle Support.

See Oracle TeleSales Implementation Guide or Oracle Support Implementation Guide.

� Installed and configured the media layer -- telephony or email.

See Oracle Call Center Connectors Implementation Guide or the Oracle Email Server 
documentation.

� Installed and configured the appropriate interaction servers.

See Oracle Call Center Applications Setup Guide.

� Implemented Oracle Universal Work Queue.

See Oracle Universal Work Queue Implementation Guide.

See Also
� Overview of Implementing Oracle Interaction Blending

1.3 Understanding Oracle Applications User Accounts
Every application user must be an authorized user of Oracle Applications. An 
application user is uniquely identified by a username and password. Once defined, 
an application user can sign on to Oracle Applications and access data through 
Oracle Applications user interfaces.

An application user is granted one or more responsibilities. A responsibility is a 
level of authority in Oracle Applications that allows a user to access to specific 
Oracle Applications functions. 
Implementing Oracle Interaction Blending 1-5



Understanding Oracle Applications User Accounts
For detailed information about Oracle Applications user accounts, see Oracle 
Applications System Administrator’s Guide.

1.3.1 Username Guidelines
An application user enters a username to sign on to Oracle Applications. It is 
helpful to define meaningful usernames, such as the first initial and last name of an 
employee, or, for a group account, the name of the group.

Use the following guidelines to define Oracle Applications usernames:

� The username must not contain more than one word.

� You should use only alphanumeric characters (’A’ through ’Z’, and ’0’ through 
’9’) in the username.

Please note that you must limit your username to the set of characters that your 
operating system supports for filenames.

1.3.2 Password Guidelines
An application user enters a password along with her or his username to sign on to 
Oracle Applications. Use the following guidelines to define Oracle Applications 
passwords:

� A password must be at least five characters and can extend up to 100 characters.

� You should use alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’) in 
a password. All other characters are invalid.

The application user password assigned by the system administrator is temporary. 
Upon signing on for the first time, the application user will be prompted to change 
the password.

1.3.3 Responsibilities Guidelines
All Oracle Applications products are installed with predefined responsibilities. 
Additionally, instances of the major components that help define a responsibility 
(data groups, request security groups, menus, and functions) are predefined for 
Oracle Applications. A system administrator can assign users any of the standard 
responsibilities provided with Oracle Applications, or create new custom 
responsibilities.

The responsibility key is a unique name for a responsibility. After the responsibility 
records has been saved, the responsibility key cannot be updated. However, the 
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Defining an Oracle Interaction Blending Administrator
responsibility name can be changed at any time. If a user has more than one 
responsibility, then the responsibility name appears in the Responsibilities window 
after a user signs on. 

See Also
� Defining an Oracle Interaction Blending Administrator

1.4 Defining an Oracle Interaction Blending Administrator
Use this procedure to create an Oracle Interaction Blending administrator.

The Oracle Interaction Blending administrator define a blending server, creates 
service plans, and creates service categories.

Prerequisites
� Review Oracle Applications Systems Administrator’s Guide.

� Review Understanding Oracle Applications User Accounts.

� Obtain an Oracle Applications user account with access to the System 
Administrator (SYSTEM_ADMINISTRATOR) responsibility.

Steps
1. If necessary, sign on to Oracle Applications.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears. Use the Password 
Update window to enter a new password.

2. Switch to or select the System Administrator responsibility.

� To switch to a different responsibility, choose Switch Responsibility, from 
the File menu.

3. In the Navigator window, on the Functions tab, choose Security > User > Define.

The User window appears.

4. In the User Name field, enter the name of the user account.

5. In the Password field, enter the password for the user account and then press Tab.

The cursor remains in the Password field.

6. Enter the password again to verify it.
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Configuring Oracle Interaction Blending
7. In the Responsibilities tab, add the following responsibilities:

Once the user record has been saved, you cannot delete an assigned 
responsibility. Oracle Applications maintains audit data for assigned 
responsibilities.

To deactivate an assigned responsibility, set the effective end date (in the 
Effective Dates - To field) of the assigned responsibility to the current date. To 
activate an assigned responsibility, clear or reset the effective end date.

8. From the File menu, choose Save.

See Also
� Understanding Oracle Applications User Accounts

1.5 Configuring Oracle Interaction Blending
Follow the steps in the following table to configure Oracle Interaction Blending. The 
Required column indicates whether a step is required. The Description column 
describes a high-level step and, where applicable, provides a reference to a more 
detailed topic in this document. The Responsibility column indicates the Oracle 

Note: This is a temporary password. When the user signs on to 
Oracle Applications for the first time, the message "Your password 
has expired" appears. The user can use the Password Update 
window to enter a new password.

Function Responsibility Name Responsibility Key

Define blending servers

Create service plans

Create service categories

IEB_ADMINISTRATOR IEB_ADMINISTRATOR

Create an employee in CRM Resource Manager 
(if Oracle HRMS is not installed)

Create an CRM resource

Set up Oracle Interaction Blending server for 
media work

Configure the Oracle Interaction Blending 
desktop for media work

CRM Administrator JTF_ADMINISTRATOR
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Configuring Oracle Interaction Blending
Applications user account responsibility required to complete the step. The 
Navigation column provides the path for navigating to the necessary window.

For information about administering Oracle Interaction Blending, such as 
modifying or deleting a service category, see Oracle Interaction Blending Concepts and 
Procedures.

1.5.1 Creating a Blending Server
Oracle Interaction Blending server receives media tasks and maps them to service 
categories. Oracle Interaction Blending server then evaluates service category 
statistics, agent transaction statistics, the levels of service, and the ability of the 
agents to handle a specific media task. If needed, Oracle Interaction Blending server 
moves agents among the service categories to maintain the desired levels of service.

Use this procedure to create an interaction blending server.

Prerequisites
� Install the Interaction Blending server. Review Oracle Call Center Applications 

Setup Guide.

� Define an Oracle Interaction Blending administrator. See Defining an Oracle 
Interaction Blending Administrator.

Steps
1. If necessary, sign on to Oracle eBusiness Center.

 Number Required? Description Responsibility Navigation

❏ Step 1 Required Create an interaction blending server.

See: Creating a Blending Server

IEB_
ADMINISTRATOR

Blending Server 
tab > Create

❏ Step 2 Required Create service plans for inbound and 
outbound media.

See: Creating a Service Plan

IEB_
ADMINISTRATOR

Service Plan tab 
> Create

❏ Step 3 Required Create service categories for inbound and 
outbound media.

See: Creating a Service Plan

IEB_
ADMINISTRATOR

Service 
Category tab > 
Create
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Configuring Oracle Interaction Blending
If you are signing on to Oracle eBusiness Center with this username for the first 
time, you will have to choose your default responsibility, sign out, and then sign 
on again.

2. Select the Blending Server tab.

3. In the Blending Servers page, click Create.

The Create Server page appears.

4. Enter the information for the blending server.

5. Click Create.

The Blending Servers page appears.

See Also
� Creating a Service Plan

� Creating a Service Plan

1.5.2 Creating a Service Plan
A service plan defines a set of service requirements for a service category. Service 
requirements, or levels of service, are used to measure the responsiveness of the 
interaction center to the customer.

Service plan are global, are shared among the Oracle Interaction Blending servers, 
and associated with a service category. Service plans either govern inbound media 
or outbound media, and, as such, their parameters depend on the media type.

A service plan contains at least seven regular segments, one for each day in the 
week. You can also set up service objectives for a specific date (a specific segment). 
If both a regular segment and a specific segment apply to the same day, then the 
specific segment is used.

Inbound service plans measure the percentage of media tasks to be handled within 
a time threshold (for example, 80% of the inbound calls to be answered within 60 
seconds). Outbound service plans are measured by the number of transactions to be 
handled within a time period (for example, 200 transaction).

By default, service objectives are set from 00:00 to 23:59 (server local time). 
However, any segment can be subdivided into multiple time interval (for example, 
00:00 to 08:59, 09:00 to 16:59, and 17:00 pm to 23:59), each with different service 
objectives. The segments will be repeatedly used until they are updated, divided or 
merged.
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Configuring Oracle Interaction Blending
Oracle Interaction Blending server tries to map interaction tasks to a service 
category. If the service category cannot be determined, then the media task is 
associated with the default service category for the direction (inbound or outbound) 
and media type. You should set up service plans for both default service categories 
and custom service categories.

Topics include:

� Creating a Service Plan for Inbound Media

� Creating a Service Plan for Outbound Media

See Also
� Creating a Blending Server

� Creating a Service Plan

1.5.3 Creating a Service Plan for Inbound Media
Use this procedure to create a service plan for inbound media.

Prerequisites
� Define an Oracle Interaction Blending administrator. See Defining an Oracle 

Interaction Blending Administrator.

Steps
1. Select the Service Plan tab.

The Service Plans page appears.

2. Click Create.

The General page appears.

3. Enter general information about the service plan and then click Done.

The Inbound Plan Segments page appears.

4. Enter the inbound segments and then click Done.

The Service Plans page appears.

See Also
� Creating a Blending Server
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Configuring Oracle Interaction Blending
� Creating a Service Plan for Outbound Media

� Creating a Service Plan

1.5.4 Creating a Service Plan for Outbound Media
Use this procedure to create a service plan for outbound media.

Prerequisites
� Define an Oracle Interaction Blending administrator. See Defining an Oracle 

Interaction Blending Administrator.

Steps
1. Select the Service Plan tab.

The Service Plans page appears.

2. Click Create.

The General page appears.

3. Enter general information about the service plan and then click Done.

The Outbound Plan Segments page appears.

4. Enter the outbound segments and then click Done.

The Service Plans page appears.

See Also
� Creating a Blending Server

� Creating a Service Plan for Inbound Media

� Creating a Service Plan

1.5.5 Creating a Service Category
The service category is what Oracle Interaction Blending uses to make blending 
decisions. A service category represents a subset of media tasks with similar 
characteristics (for example, inbound customer service telephone calls). The 
composition of service categories reflects a working model of the interaction center.

Service categories are always associated with an Oracle Interaction Blending server. 
Oracle Interaction Blending server maps media tasks to service categories.
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Configuring Oracle Interaction Blending
Service categories either govern inbound media or outbound media, and, as such, 
their parameters depend on their direction. Inbound media tasks are mapped to 
service categories based on media type and classification. Outbound media tasks 
are mapped to service categories based on media type and campaign. Service 
categories group media tasks, collect statistics, and measure levels of service.

Topics include:

� Creating an Inbound Service Category

� Creating an Outbound Service Category

See Also
� Creating a Blending Server

� Creating a Service Plan

1.5.6 Creating an Inbound Service Category
Use this procedure to create an interaction blending service category for inbound 
media.

Prerequisites
� Define an Oracle Interaction Blending administrator. See Defining an Oracle 

Interaction Blending Administrator.

� Create an interaction blending server. See Creating a Blending Server.

� Create an inbound media classification. See Understanding Media 
Classifications.

� Create an inbound service plan. See Creating a Service Plan for Inbound Media.

Steps
1. Select the Service Category tab.

2. Click Create.

The Create Service Category page appears.

3. Enter the name of the service category and a brief description.

4. If the service category is active, select Active.

5. In the Blending Server field, select the name of the interaction blending server 
to which the service category will be associated.
Implementing Oracle Interaction Blending 1-13



Configuring Oracle Interaction Blending
6. In the Parent Category field, select Inbound.

7. Click Continue.

The Classification page appears

8. Select the classification(s) to be associated with this service category.

9. Click Continue.

The Service Plan page appears

10. In the Service Plan field, select a service plan.

The details of the selected service plan are displayed.

11. To view the details for another day or date, select a day or date from the 
Day/Date field.

12. Click Done.

The Service Categories page appears.

Guidelines
In the following example, Blending_Server1 is created.

See Also
� Creating a Blending Server

� Creating a Service Plan

� Creating an Outbound Service Category

1.5.7 Creating an Outbound Service Category
Use this procedure to create an interaction blending service category for outbound 
media.

Prerequisites
� Define an Oracle Interaction Blending administrator. See Defining an Oracle 

Interaction Blending Administrator.

� Create an interaction blending server. See Creating a Blending Server.

� Create an outbound campaign.
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Setting Up an Interaction Center
� Create an outbound service plan. See Creating a Service Plan for Outbound 
Media.

Steps
1. Select the Service Category tab.

2. Click Create.

The Create Service Category page appears.

3. Enter general information about the service category and then click Continue.

The Campaign page appears.

4. Select a campaign and then click Continue.

The Service Plan page appears.

5. Select a service plan and then click Done.

The Service Categories page appears.

See Also
� Creating a Blending Server

� Creating a Service Plan

� Creating an Inbound Service Category

1.6 Setting Up an Interaction Center
Follow the steps in the following table to set up an interaction center. The Required 
column indicates whether a step is required. The Description column describes a 
high-level step and, where applicable, provides a reference to a more detailed topic 
in this document. The Oracle Documentation column provides a reference to other 
relevant documents.

Number Required? Description Oracle Documentation

❏ Step 1 For telephony 
only

Install and configure Oracle Call Center 
Connectors.

Oracle Call Center Connectors 
Implementation Guide

❏ Step 2 For email only Install and configure Oracle Email Server. Oracle Email Server Installation 
Guide
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Setting Up an Interaction Center
1.6.1 Defining an Oracle Interaction Center Server Group

An Oracle interaction center is represented by a logical grouping of interaction 
center processes called a server group. If there are multiple interaction centers or if 
separate lines of business are operating in the same interaction center, then there 
can be multiple server groups. Once the server group is defined, you can configure 
the individual interaction center processes in the group.

Use this procedure to define a server group.

Prerequisites
� Review Oracle Telephony Manager Implementation Guide.

� Define an Oracle Interaction Blending administrator. See Defining an Oracle 
Interaction Blending Administrator.

❏ Step 3 For IVR 
integration 
only

Install Oracle IVR Integrator. Oracle IVR Integrator 
Implementation Guide

❏ Step 4 Yes Define an interaction center server group.

See Defining an Oracle Interaction Center 
Server Group.

Oracle Telephony Manager 
Implementation Guide

❏ Step 5 Yes Define and configure the interaction center 
servers.

See Defining an Interaction Center Server.

Oracle Telephony Manager 
Implementation Guide

❏ Step 6 Yes Define and configure the CTI middleware.

See Defining the CTI Middleware for the 
Server Group.

Oracle Telephony Manager 
Implementation Guide

❏ Step 7 Optional Define the interaction center telesets. Oracle Telephony Manager 
Implementation Guide

❏ Step 8 Optional Map the inbound IVR data to fields in 
Oracle Applications.

Oracle Telephony Manager 
Implementation Guide

❏ Step 9 Yes Install the interaction center servers. Oracle Call Center Applications 
Setup Guide

Note: This procedure applies to media work only.

Number Required? Description Oracle Documentation
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Setting Up an Interaction Center
Steps
6. If necessary, sign on to Oracle Applications.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears. Use the Password 
Update window to enter a new password.

7. Switch to or select the CRM Administrator responsibility.

� To switch to a different responsibility, choose Switch Responsibility, from 
the File menu.

8. In the Navigator window, on the Functions tab, choose UWQ Server Locator > 
UWQ Server Locator.

The Server Locator window appears. To scroll through the records for all server 
groups, press Page Up or Page Down. To search for a specific server group, 
choose View > Query by Example > Enter to invoke the query entry mode. 
Enter your query and then choose View > Query by Example > Run to find the 
matching server groups.

9. To define a new server group, choose New from the File menu.

10. In the Server Group tab, define the server group.

The server group name is required. The server group location and description 
are for informational purposes only.

11. From the File menu, choose Save.

See Also
� Defining an Interaction Center Server

� Defining the CTI Middleware for the Server Group

1.6.2 Defining an Interaction Center Server

Oracle interaction center functions, such as Oracle Interaction Blending, are 
governed by individual server processes. The number and types of server processes 
in a server group will depend on how you are implementing your Oracle 

Note: This procedure applies to media work only.
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Setting Up an Interaction Center
interaction center. The server processes may run on one or more server machines. 
Each server process is configured individually.

The following table lists the recommended servers for different types of media 
processing.

If you are implementing... Then define...

Advanced Inbound Telephony 
in Passive Mode

Server Monitor

Telephony Manager

Telephony Media Controller

Inbound Telephony Server (if implementing web callback)

Routing Server (for media classification; routing not used)

Universal Work Queue Server

Advanced Inbound Telephony 
in Active Mode

Server Monitor

Telephony Manager

Telephony Media Controller

Inbound Telephony Server

Routing Server (for media classification and routing)

Interaction Blending Server (if implementing media work blending)

Universal Work Queue Server

Advanced Outbound 
Telephony

Server Monitor

Telephony Manager

Telephony Media Controller

Inbound Telephony Server

Advanced Outbound Proxy Server

Routing Server (for media classification and routing)

Interaction Blending Server (if implementing media work blending)

Universal Work Queue Server
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Use this procedure to define and configure interaction center servers.

Prerequisites
� Review Oracle Telephony Manager Implementation Guide.

� Define an interaction center server group. See Defining an Oracle Interaction 
Center Server Group.

� Define an Oracle Interaction Blending administrator. See Defining an Oracle 
Interaction Blending Administrator.

Steps
1. If necessary, sign on to Oracle Applications.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears. Use the Password 
Update window to enter a new password.

2. Switch to or select the CRM Administrator responsibility.

� To switch to a different responsibility, choose Switch Responsibility, from 
the File menu.

3. In the Navigator window, on the Functions tab, choose UWQ Server Locator > 
UWQ Server Locator.

The Server Locator window appears.

4. In the Server Group tab, find your server group

To scroll through the records for all server groups, press Page Up or Page 
Down. To search for a specific server group, choose View > Query by Example 

eMail Center Server Monitor

Telephony Manager

Telephony Media Controller

eMail Center Server

Routing Server (for media classification and routing)

Interaction Blending Server (if implementing media work blending)

Universal Work Queue Server

If you are implementing... Then define...
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> Enter to invoke the query entry mode. Enter your query and then choose 
View > Query by Example > Run to find the matching server groups.

5. Select the Server tab.

To scroll through the records for all servers in the server group, press Page Up 
or Page Down. To search for a specific server in the server group, choose View 
> Query by Example > Enter to invoke the query entry mode. Enter your query 
and then choose View > Query by Example > Run to find the matching servers.

6. To define a new server, choose New from the File menu.

7. In the Server Registration area, identify the server.

The server name and type are required. 

a. Enter a unique name for the server.

The name of the server in the Server Locator window in the Server tab must 
match the name given to the server when it is installed on a machine. To 
change the name of an interaction center server in the database, use the 
Server tab. 

b. Optionally, in the Server Location field, enter the location of the server.

c. From the Type Name list, select the server type.

The Member Group Name field automatically displays the name of the 
server group selected on the Server tab.

d. Optionally, to associate the server with another server group, select the 
server group from the Member Group Name list.

If the server is on a machine with a static IP address, then the DNS name 
and IP address are automatically displayed when the server is started for 
the first time.

e. If the server is on a machine in a DCHP or multi-homed network 
configuration, then specify the IP address of the machine in the User 
Address field.

f. Optionally, in the Description field, enter a description of the server.

8. In the Server Parameter area, configure the parameters for the server.

Each row in the Server Parameter area corresponds to a server parameter. 

a. From the Name list, select a parameter.

The parameters listed in the Name list depend on the type of type of server.
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b. Enter a value for the parameter.

Parameters must be defined for Telephony Manager Server, Inbound 
Telephony Server, Telephony Media Controller, and Oracle Interaction 
Blending Server.

Use the following table to set the parameters for Inbound Telephony Server.

Use the following table to set the parameters for Telephony Manager 
Server.

Parameter Required? Description Example

OTM_SERVER_NAME Yes The name of the Telephony Manager Server in the 
server group.

OTMServer

TELE_MIDDLEWARE_CONFIG Yes The name of the middleware configuration. The 
middleware configuration name parameter in the 
Server Locator window in the Server tab must 
match the name of the middleware configuration 
in the Call Center Administration window in the 
Middleware tab. See Defining the CTI Middleware 
for the Server Group.

MWConfig

WEB_CALL_PORT For web 
callback 
only

The port used to listen for web callback requests. 
The default port for web callback requests is 888. 
The web callback port parameter in the Server 
Locator window in the Server tab must match the 
port in the OTM Server Port field in the iSupport 
Admin UI -> Support tab -> Call Me sub-tab.

888

Parameter Required? Description Example

TELE_MIDDLEWARE_CONFIG Yes The name of the middleware configuration. The 
middleware configuration name parameter in the 
Server Locator window in the Server tab must 
match the name of the middleware configuration 
in the Call Center Administration window in the 
Middleware tab. See Defining the CTI Middleware 
for the Server Group.

MWConfig

DEFAULT_TIMEOUT Optional Default timeout for re-route in minutes. For 
example, when this parameter is set to 5, a media 
item will be re-routed if it has been waiting in 
queue for more than 5 minutes.

5

IB_SERVER_NAME Optional The name of the Interaction Blending Server in the 
server group.

IBServer
Implementing Oracle Interaction Blending 1-21



Setting Up an Interaction Center
Use the following table to set the parameters for Telephony Media 
Controller.

MQA_MODE Optional This parameter applies to the Nortel switch only. 
If multiple queue mode is on, select TRUE. If 
multiple queue mode is off, select FALSE or leave 
this parameter blank.

TRUE

PASSIVE_MODE Optional To configure Telephony Manager Server to run in 
passive mode, select TRUE. To configure 
Telephony Manager Server to run in active mode, 
select FALSE or leave this parameter blank.

FALSE

ROUTE_SERVER_1 For active 
mode only

The name of the Routing server in the server 
group. To balance the media work load, 
Telephony Manager Server can support up to 
three Routing servers. When multiple Routing 
servers are present, Telephony Manager Server 
sends media work to each Routing server on a 
round-robin basis.

RouteServer1

ROUTE_SERVER_2 Optional The name of a Routing server in the server group. RouteServer2

ROUTE_SERVER_3 Optional The name of a Routing server in the server group. RouteServer3

STANDALONE Optional To configure Telephony Manager Server to run in 
standalone mode, select STANDALONE. To 
configure Telephony Manager Server to run in 
distributed mode, select DISTRIBUTED or leave 
this parameter blank.

TRUE

Parameter Required Description Example

TELE_MIDDLEWARE_CONFIG Required The name of the middleware configuration. The 
middleware configuration name parameter in the 
Server Locator window in the Server tab must 
match the name of the middleware configuration 
in the Call Center Administration window in the 
Middleware tab. See Defining the CTI Middleware 
for the Server Group.

MWConfig

OTM_SERVER_NAME Required The name of the Telephony Manager Server in the 
server group.

SampleOTM

MQA_MODE Optional This parameter applies to the Nortel switch only. 
If multiple queue mode is on, select TRUE. If 
multiple queue mode is off, select FALSE or leave 
this parameter blank.

TRUE

PASSIVE_MODE Optional To configure Telephony Manager Server to run in 
passive mode, select TRUE. To configure 
Telephony Manager Server to run in active mode, 
select FALSE or leave this parameter blank.

FALSE

Parameter Required? Description Example
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Use the following table to set the parameters for Oracle Interaction 
Blending Server.

9. From the File menu, choose Save.

See Also
� Defining an Oracle Interaction Center Server Group

� Defining the CTI Middleware for the Server Group

1.6.3 Defining the CTI Middleware for the Server Group

CTI (computer telephony integration) middleware enables Oracle Telephony 
Manager Server and the Inbound Telephony Server to control telephony devices 
(for example, agent phones and telesets) and shared telephony resources (for 
example, phone switches).

Use this procedure to define the CTI middleware for the interaction center.

Prerequisites
� Review Oracle Telephony Manager Implementation Guide.

� Define an interaction center server group. See Defining an Oracle Interaction 
Center Server Group.

� Define an Oracle Interaction Blending administrator. See Defining an Oracle 
Interaction Blending Administrator.

Steps
1. If necessary, sign on to Oracle Applications.

Field Name Required Description Example

SERVER_PORT Required The port used to listen for media requests from the 
Oracle Interaction Blending desktop bean. The 
default port is 80. Port 80 is a commonly used 
port. If when Oracle Universal Work Queue Server 
is started, there is error message that the port is 
already in use, you can modify the port number.

80

Note: This procedure applies to media work only.
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If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears. Use the Password 
Update window to enter a new password.

2. Switch to or select the CRM Administrator responsibility.

� To switch to a different responsibility, choose Switch Responsibility, from 
the File menu.

3. In the Navigator window, on the Functions tab, choose Call Centers > Call 
Center Administration.

The Call Center Administration window appears.

4. Find your server group

To scroll through the records for all server groups, press Page Up or Page 
Down. To search for a specific server group, choose View > Query by Example 
> Enter to invoke the query entry mode. Enter your query and then choose 
View > Query by Example > Run to find the matching server groups.

5. Select the Middleware tab.

6. In the Middleware Configuration area, specify your middleware.

a. In the Configuration Name field, enter a unique name for the middleware 
configuration.

The name of the middleware configuration in the Middleware tab must 
match middleware configuration name parameter for the Inbound 
Telephony Server, Telephony Manager Server, and Telephony Media 
Controller. See Defining an Interaction Center Server.

b. From the Middleware Type list, select the middleware type.

Use the following table to determine the appropriate middleware type.
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c. In the IP Address field, enter the IP address of the middleware server.

The middleware server is the machine that is hosting the CTI middleware, 
such as Oracle Call Center Connectors.

d. In the Port field, enter the port number of the middleware server.

For Oracle Call Center Connectors, the default port number is 3201. Verify 
the port number against the actual configuration of the middleware server.

7. In the Middleware Parameters area, configure the parameters for the selected 
middleware type.

Each row in the Middleware Parameters area corresponds to an Oracle 
interaction center server parameter.

a. From the Name list, select a parameter.

The parameters listed in the Name list depend on the type of middleware 
selected from the Middleware Type list. 

b. Enter a value for the parameter.

If you are using Dialogic CT-Connect as the CTI enabler, use the following 
table to set the middleware parameters.

If the middleware is... And the CTI enabler is... And the switch is one of...
Then select middleware 
type...

Oracle Call Center Connectors Dialogic CT-Connect Alcatel 4400

Avaya (Lucent) Definity G3

Nortel Meridian

Nortel Symposium
Call Center Server

Siemens HICOM
(US and international)

Dialogic CT-Connect

Oracle Call Center Connectors Cisco ICM Aspect

Avaya (Lucent) Definity G3

Nortel Meridian

Cisco ICM/Enterprise CTI

Parameter Required Description Example

CTI Enabler IP Address Yes The IP address of the CT-Connect server. 123.45.67.890

PBX Name Yes The link logical identifier defined in the CT-Connect 
configuration to represent the CTI link between 
CT-Connect and the switch.

ctc_nortel
ctc_lucent
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PBX Type Yes The PBX type.

� For Lucent Definity, enter A.

� For Nortel Meridian or Symposium Call Center 
Server, enter M.

� For Siemens HICOM, enter S

� For Alcatel 4400, enter C

A

Middleware Server Info 1 Yes Enter the value ncacn_ip_tcp as the identifier for 
the network protocol used between Oracle Call 
Center Connectors and CT-Connect.

Enter ncacn_ip_tcp 
for TCP/IP (actual 
value)

Route Points Set 1

Route Points Set 2

Route Points Set 3

Route Points Set 4

Route Points Set 5

If using 
active mode

Devices within the PBX/ACD where inbound calls 
are initially received and route requests are issued.

� Lucent Definity

Enter one or more vector directory numbers 
(VDN), separated by commas. The format is:

vdn[,vdn...]

� Nortel Meridian:

Enter one or more CDN-immediate treatment 
pair(s), separated by commas. (CDN stands for 
Control Directory Number; the immediate 
treatment of an inbound call arriving at a CDN 
can be ringback or music). The format is:

cdn:treatment[,cdn:treatment...]

The format for treatment is:

##{R|M#musicRouteNumber}

� Siemens HiCom and Alcatel 4400:

Enter one or more pilot number(s), separated by 
commas. The format is:

pilotNumber[,pilotNumber...]

There is a 256 maximum character limit. You can 
configure as many route points in each Route Points 
Set X field as the 256-character limit permits.

7400

7400,7500

7520:##R

7530:##M#02

7400

Outgoing Prefix If using web 
callback

Numeric prefix dialed to place outside calls. Check 
against the configuration of the PBX.

9

International Dialing Prefix If using web 
callback

Numeric prefix dialed for placing international calls. 011 (from within the 
USA)

Site Country Code If using web 
callback

The country code for the site where the PBX is 
located.

1

Site Area Code If using web 
callback

The area code for the site where the PBX is located. 650

Parameter Required Description Example
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If you are using Cisco ICM (formerly Geotel) as the CTI enabler, use the 
following table to set the middleware parameters.

8. From the File menu, choose Save.

See Also
� Defining an Oracle Interaction Center Server Group

� Defining an Interaction Center Server

IVR Server Name If using IVR 
Integrator

The PC-DCE name of the IVR Integrator server. 
Check against PC-DCE configuration.

SAMPLEIVR (IVR 
server values must be 
in uppercase)

Parameter Required Description Example

CTI Enabler IP Address Yes IP address of the Cisco ICM CTI server (Server A). 123.45.67.890

Middleware Server Info 1 Yes Port number of the Cisco ICM CTI server (Port A). 42027

Middleware Server Info 2 Yes IP address of the Cisco ICM CTI server (Server B). 123.45.67.890

Middleware Server Info 3 Yes Port number of the Cisco ICM CTI server (Port B). 42027

PBX Name Yes Peripheral ID defined in Cisco ICM CTI server for 
the PBX of interest.

5008

PBX Type Yes PBX type.

� A - Lucent Definity

� M - Nortel Meridian

� P - Aspect

A

Outgoing Prefix If using web 
callback

Numeric prefix dialed to place an outside call. 
Check against the configuration of the PBX.

9

International Dialing 
Prefix

If using web 
callback

Numeric prefix dialed for placing international calls. 011

Site Country Code If using web 
callback

The country code for the site where the PBX is 
located.

1

Site Area Code If using web 
callback

The area code for the site where the PBX is located. 650

Parameter Required Description Example
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1.7 Understanding Media Classifications
A media classification is a label (for example, GoldSupport) that is assigned to an 
inbound media item. Classification rules define the conditions under which the 
classification is assigned. When the media item meets all of the conditions of the 
classification rules, then the classification is assigned to the media item. 

There are two types of classifications: literal and database procedure.

� A literal classification is a string (for example, GoldSupport). The classification 
rules for a literal classification use only predefined classification keys (for 
example, ANI = 18881234000). The literal classification is the classification value 
that is assigned to the media item (for example, Classification = GoldSupport).

� A database procedure classification is a stored procedure. A database 
procedure classification can use predefined classification keys and additional 
parameters to determine the classification. The classification value derived by 
the database procedure is assigned to the media item.

The media classification engine, a component of the Routing server, is used to 
classify inbound media -- whether Oracle Telephony Manager is operating in active 
routing mode or passive routing mode. In active routing mode, Oracle Telephony 
Manager routes inbound media by means of the Routing server. In passive mode 
routing mode, the ACD/PBX system completely handles the routing and queueing 
of inbound media.

Media classifications are used in Oracle Interaction Blending to determine which 
CRM business application to launch when a media item is delivered to the Oracle 
Interaction Blending desktop. Media classifications are also used by Oracle 
Interaction Blending to map inbound media to service categories. Finally, in active 
routing mode, media classifications are used by the Routing server to determine 
when to reroute a media item.

See Also
� Defining a Literal Classification

� Defining a Database Procedure Classification

1.7.1 Defining a Literal Classification

Note: This procedure applies to media work only.
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Use this procedure to define a literal media classification.

Prerequisites
� Install a Routing server. Review Oracle Call Center Applications Setup Guide.

� Define a Routing server in the interaction center server group. Review Oracle 
Telephony Manager Implementation Guide.

� Define an Oracle Interaction Blending administrator. See Defining an Oracle 
Interaction Blending Administrator.

Steps
1. If necessary, sign on to Oracle Applications.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears. Use the Password 
Update window to enter a new password.

2. Switch to or select the CRM Administrator responsibility.

� To switch to a different responsibility, choose Switch Responsibility, from 
the File menu.

3. In the Navigator window, on the Functions tab, choose Call Centers > 
Classification Administration.

The Call Center Administration window appears. To scroll through the records 
for all classification definitions, press Page Up or Page Down. To search for a 
specific server group, choose View > Query by Example > Enter to invoke the 
query entry mode. Enter your query and then choose View > Query by 
Example > Run to find the matching server groups.

4. If necessary, choose File > New.

5. In the Classification Definition area, define the classification.

a. Enter a unique name to describe the classification.

b. From the Type list, select Literal.

c. In the Time Out field, type the number of minutes you want to use as your 
time out period. 

For advanced inbound telephony in active mode, the time out period is the 
maximum length of time that a routed call waits in the Oracle Telephony 
Manager queue for an available agent before being re-routed.
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For advanced inbound telephony in passive mode or for email, the Time 
Out field is not used. Nonetheless, the Time Out field is required. In this 
case, Oracle recommends that you enter 1000 in this field.

d. If this classification uses the Oracle Applications database, select 
Application Database. 

e. If this classification does not use the Oracle Applications database, then 
select Non-Application Database, and enter the database driver and URL.

6. On the Classification Rules tab, define the rules for classifications.

a. From the Key list, select a key.

The classification keys provide many types of data that are typically used in 
an interaction center. These values might come directly from the ACD, an 
IVR, or even from a Web callback form.

b. From the Operation list, select an operator.

c. Enter the value for the selected key.

7. From the File menu, choose Save.

See Also
� Understanding Media Classifications

� Defining a Database Procedure Classification

1.7.2 Defining a Database Procedure Classification

Use this procedure to define a database procedure classification.

Prerequisites
� Install a Routing server. Review Oracle Call Center Applications Setup Guide.

� Define a Routing server in the interaction center server group. Review Oracle 
Telephony Manager Implementation Guide.

� Define an Oracle Interaction Blending administrator. See Defining an Oracle 
Interaction Blending Administrator.

Note: This procedure applies to media work only.
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Steps
1. Navigate to the Classification Administration window.

2. In the Navigator window, on the Functions tab, choose Call Centers > 
Classification Administration.

The Classification Administration window appears.

3. In the Classification Definition area, define the classification.

a. Enter the name of the database procedure that will determine the 
classification of the media item, for example, GET_CLASSIFICATION_
FROM_SUBJECT.

b. From the Type list, select Database Procedure.

c. In the Time Out field, type the number of minutes you want to use as your 
time out period. 

For advanced inbound telephony in active mode, the time out period is the 
maximum length of time that a routed call waits in the Oracle Telephony 
Manager queue for an available agent before being re-routed.

For advanced inbound telephony in passive mode or for email, the Time 
Out field is not used. Nonetheless, the Time Out field is required. In this 
case, Oracle recommends that you enter 1000 in this field.

d. If this procedure is stored in the Oracle Applications database, select 
Application Database. 

e. If this procedure is not stored in the Oracle Applications database, then 
select Non-Application Database, and enter the database driver and URL.

4. On the Classification Rules tab, define the rules for classification.

a. From the Key list, select a key.

The classification keys provide many types of data that are typically used in 
an interaction center. These values might come directly from the ACD, an 
IVR, or even from a Web callback form.

b. From the Operation list, select an operator.

Note: The value entered in the Classification field is not verified 
against the stored procedures. Be sure to enter the correct 
procedure name.
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c. Enter the value for the selected key.

5. In the Classification Parameters tab, define the parameters for the database 
procedure:

a. In the Parameter field, enter the name of a parameter for the database 
procedure.

b. In the Value list, select a value or enter a custom value for the parameter.

c. From the Data Type list, select the data type of the parameters (for example, 
VARCHAR).

d. From the Direction List, select the direction of the parameter (for example, 
IN).

The sequence is a generated number that indicates the sequence of the 
parameter.

6. From the File menu, choose Save.

See Also
� Understanding Media Classifications

� Defining a Literal Classification

1.8 Integrating Oracle Interaction Blending with Oracle Universal Work 
Queue

To enable media work blending for Oracle Interaction Blending, set the Blending 
Style profile option to Forced Blended. When media work blending is enabled for 
Oracle Interaction Blending, the Media node is replaced with a Blended node.

Oracle Interaction Blending must be installed and configured. Oracle Interaction 
Blending dynamically moves agents between queues and media types based on the 
service levels for the interaction center. For information about implementing Oracle 
Interaction Blending, see Oracle Interaction Blending Implementation Guide.

1.9 Integrating Oracle Interaction Blending with Oracle Telephony 
Manager

Oracle Telephony Manager must be in active mode to implement blending. To 
enable active mode for Oracle Telephony Manager, set the value of the PASSIVE_
MODE parameter for the Oracle Telephony Manager server to FALSE
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In addition, you must set the IB_SERVER_NAME parameter for the Oracle 
Telephony Manager server to the name of the Oracle Interaction Blending server in 
the server group.

1.10 Documentation Resources
The following related documentation is available on MetaLink.

Read the following documents to understand Oracle Applications:

� Oracle Applications Concepts

� Oracle Applications Product Update Notes

Read the following documents to install, upgrade, or maintain Oracle Applications 
Release 11i:

� Installing Oracle Applications

� Upgrading Oracle Applications

� Upgrading Timing Spreadsheet

� Maintaining Oracle Applications

Read the following documents to implement and use Oracle Human Resource 
Management Systems:

� Implementing Oracle HRMS

� Managing People Using Oracle HRMS

Read the following document to implement Oracle CRM:

� Implementing Oracle CRM: ERP Functional Checklist

� Implementing Oracle CRM: Foundation Functional Checklist

� Supplemental CRM Installation Steps

Read the following documents to implement the CRM business applications that 
integrate with Oracle Interaction Blending:

� Oracle CRM Foundation Implementation Guide

� Oracle Support Implementation Guide

� Oracle TeleSales Implementation Guide

Read the following documents to use or administer the CRM business applications 
that integrate with Oracle Interaction Blending:
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� Oracle CRM Foundation Concepts and Procedures

� Oracle Support Concepts and Procedures

� Oracle TeleSales Concepts and Procedures

Read the following documents to install the Oracle Interaction Center server 
processes:

� Installing Oracle Call Center Connectors

� Oracle Call Center Applications Setup Guide

� Installing Oracle Campaign Plus

� Installing Oracle IVR Integrator

� Installing Oracle Predictive

Read the following documents to implement Oracle interaction Center products:

� Oracle Call Center Connectors Implementation Guide

� Oracle Telephony Manager Implementation Guide

� Oracle IVR Integrator Implementation Guide

� Oracle eMail Center Implementation Guide

� Oracle Campaign Plus and Predictive Implementation Guide

� Oracle Universal Work Queue Implementation Guide

� Oracle Scripting Implementation Guide

Read the following documents to use or administer Oracle interaction Center 
products:

� Oracle Call Center Connectors Concepts and Procedures

� Oracle Telephony Manager Concepts and Procedures

� Oracle IVR Integrator Concepts and Procedures

� Oracle eMail Center Concepts and Procedures

� Oracle Campaign Plus Concepts and Procedures 

� Oracle Predictive Concepts and Procedures

� Oracle Universal Work Queue Concepts and Procedures

� Oracle Scripting Concepts and Procedures
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