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Preface

Welcome to the Oracle Customer Relationship Management, Release 11i, suite of 
applications.

This Implementation Guide provides general descriptions of the setup and 
configuration tasks required to implement Oracle Interaction Blending successfully. 

This preface explains how this Implementation Guide is organized and introduces 
other sources of information that can help you.

Intended Audience
This guide is aimed at the following users:

■ Anyone implementing Oracle Interaction Blending

This guide assumes you have the following prerequisites:

■ Understanding of the company business processes

■ Basic understanding of Oracle Applications, Release 11i

■ Understanding of interaction center technology
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Implementing Oracle Universal Work Queue

This guide provides descriptions of the setup and configuration tasks required to 
implement Oracle Universal Work Queue successfully. This guide contains the 
following information:

■ Overview of Oracle Universal Work Queue

■ Architecture of Oracle Universal Work Queue

■ Planning the Implementation of Oracle Universal Work Queue

■ Understanding Oracle Universal Work Queue Users

■ Defining Oracle Universal Work Queue Users

■ Understanding Oracle Universal Work Queue Profiles Options

■ Configuring Universal Work Queue System Profile Values

■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

■ Testing the Oracle Universal Work Queue Implementation

■ Understanding the Oracle Universal Work Queue Window

■ Troubleshooting Oracle Universal Work Queue

■ Documentation Resources

1.1 Overview of Oracle Universal Work Queue
Every customer interaction -- a telephone call, an email, or a Web chat -- presents an 
opportunity to win new business or improve customer satisfaction. An interaction 
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Overview of Oracle Universal Work Queue
center is an environment in which human agents manage interactions with 
customers through multiple contact channels. 

Oracle Universal Work Queue is one of several applications in the Oracle 
Interaction Center. The Oracle Interaction Center is a suite of applications that 
supports the management and processing of customer relationship activity across 
all channels of customer contact.

The Oracle Interaction Center suite includes:

Oracle Advanced Inbound Oracle Advanced Inbound enables Oracle Customer 
Relationship Management (CRM) business applications to handle multiple media 
channels.

Oracle Advanced Outbound Oracle Advanced Outbound provides list 
management and predictive dialing for outbound telephony campaigns.

Oracle eMail Center Oracle eMail Center is an email interaction management 
application. Oracle eMail Center can automate or suggest responses to inbound 
email.

Oracle Scripting Oracle Scripting is an application for developing and deploying 
scripted presentations for customer interactions. The scripted presentations guide 
agents through their interactions with customers.

See Also
■ What is Oracle Universal Work Queue?

■ Why is Oracle Universal Work Queue in the Suite?

■ Functional Flow for Oracle Universal Work Queue

1.1.1 What is Oracle Universal Work Queue?
Oracle Universal Work Queue is a agent portal for work items generated through 
customer contact channels or CRM business applications. Agents can select 
assigned work directly from the Oracle Universal Work Queue desktop user 
interface.

Work which originates from a customer contact channel, such as a telephone call or 
an email, is called a media work item. Work which originates from a CRM business 
application, such as a task or lead, is called a non-media work item. You can set up 
1-2 Oracle Universal Work Queue Implementation Guide



Overview of Oracle Universal Work Queue
Oracle Universal Work Queue to handle non-media work items only, or both 
non-media and media work items.

See Also
■ Overview of Oracle Universal Work Queue

■ Why is Oracle Universal Work Queue in the Suite?

■ Functional Flow for Oracle Universal Work Queue

1.1.2 Why is Oracle Universal Work Queue in the Suite?
Oracle Universal Work Queue:

■ Provides a desktop interface that displays a unified view of agent work.

■ Facilitates agents interactions across multiple contact channels.

■ Provides a framework that enables CRM business applications to integrate with 
media work.

■ Balances agents between media types based on the service levels for the 
interaction center 

By providing a unified view of agent work, Oracle Universal Work Queue 
minimizes the complexity of agent interactions across multiple contact channels and 
CRM business applications. Oracle Universal Work Queue also provides a standard 
programming interface for CRM business applications and media enablers to 
request, receive, and display agent work information.

Agents interact with non-media and media work through a consistent interface. 
Through integration with Oracle Interaction Blending, agents are moved between 
media queues based on the service levels for the interaction center. 

See Also
■ Overview of Oracle Universal Work Queue

■ What is Oracle Universal Work Queue?

■ Functional Flow for Oracle Universal Work Queue

1.1.3 Functional Flow for Oracle Universal Work Queue
The functional work flow for Oracle Universal Work Queue is as follows:
Implementing Oracle Universal Work Queue 1-3



Overview of Oracle Universal Work Queue
1. The applications user signs on to Oracle Applications and launches the 
Universal Work queue desktop.

2. Based on the user profile option values for the agent, the Universal Work Queue 
desktop bean may:

■ Log into the Universal Work Queue server

■ Load the desktop media plugins

■ Refresh the agent work queues

3. The Universal Work Queue desktop is displayed.

4. The agent selects a work item and clicks Get Work.

5. If a non-media work item, a CRM business application is launched. When the 
work is complete, the agent saves the work in the CRM business application.

If the work item is a task that can be updated, then the Task Manager 
application is launched. If the work item is a task that cannot be updated, then 
the CRM business application associated with the task is launched.

6. If a media work item, a CRM business application is launched when a media 
item is delivered. When the work is complete, the agent saves the work in the 
CRM business application.

The CRM business application is launched based on the media action 
definitions for Oracle Universal Work Queue. See Associating Media Work with 
a CRM Business Application.

■ To receive another media item of the same type, the agent presses End 
Interaction in the CRM business application.

■ To end media requests, the agent presses Cancel Media Request in the 
Universal Work Queue desktop, and then presses End Interaction in the 
CRM business application.

See Also
■ Overview of Oracle Universal Work Queue

■ What is Oracle Universal Work Queue?

■ Why is Oracle Universal Work Queue in the Suite?
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Architecture of Oracle Universal Work Queue
1.2 Architecture of Oracle Universal Work Queue
Oracle Universal Work Queue consists of the following main components:

■ Oracle Universal Work Queue Desktop

■ Oracle Universal Work Queue Server

The Oracle Universal Work Queue desktop operates independently of the Oracle 
Universal Work Queue server. The Oracle Universal Work Queue desktop obtains 
non-media work from the database and media work from the Oracle Universal 
Work Queue server. If you are implementing Oracle Universal Work Queue for 
non-media work only, then you do no have to install the Oracle Universal Work 
Queue server.

Oracle Universal Work Queue Desktop

The Oracle Universal Work Queue desktop comprises:

Oracle Universal Work Queue User Interface The Oracle Universal Work Queue 
user interface is an Oracle Form that presents a unified view of agent work items 
and allows the agent to select a work item for processing. 

For non-media work items, the Oracle Universal Work Queue form communicates 
with the CRM business applications. For media work items, the Oracle Universal 
Implementing Oracle Universal Work Queue 1-5



Architecture of Oracle Universal Work Queue
Work Queue form communicates with the CRM business applications and the 
Oracle Universal Work Queue desktop bean (which is described below).

Oracle Universal Work Queue Desktop Bean The Oracle Universal Work Queue 
desktop bean is invoked by the Oracle Universal Work Queue user interface when 
the agent requests a media work item. The Oracle Universal Work Queue desktop 
bean facilitates communication between the Oracle Universal Work Queue desktop 
user interface, the media enabler, and the Oracle Universal Work Queue server.

Media enablers include the telephony media enabler and the email media enabler. 
The media enablers "plug in" to the Oracle Universal Work Queue desktop bean. 
The Oracle Universal Work Queue desktop bean supports the following desktop 
media enablers.

■ SoftPhone Bean: The SoftPhone bean communicates with the Oracle Telephony 
Manager server and the Advanced Inbound server to enable telephony on the 
agent desktop.

■ eMail Center Client Bean: The eMail Center bean communicates with the Oracle 
eMail Center server to enable email on the agent desktop.

When an agent requests a media item in the Oracle Universal Work Queue user 
interface, the Oracle Universal Work Queue desktop bean communicates the request 
to the Oracle Universal Work Queue server. The Oracle Universal Work Queue 
desktop bean communicates with the Oracle Universal Work Queue server over a 
proprietary interface that supports HTTP or Sockets. For better server performance, 
Sockets is recommended.

The Oracle Universal Work Queue desktop bean passes metadata delivered by the 
Oracle Universal Work Queue server to the CRM business application and the 
media enabler. Oracle Universal Work Queue desktop bean also passes metadata 
between the CRM business application and the media enabler.

Metadata for the media item is communicated from the Oracle Universal Work 
Queue desktop bean to the Oracle Universal Work Queue user interface and the 
CRM business application by means of a PL/SQL programming interface. The 
PL’SQL programming interface is the bridge between the Oracle Universal Work 
Queue desktop Java bean and the Oracle Universal Work Queue and CRM business 
application Forms.
1-6 Oracle Universal Work Queue Implementation Guide
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Oracle Universal Work Queue Server

The Oracle Universal Work Queue server interfaces with the media providers and 
the Oracle Universal Work Queue desktop bean. The Oracle Universal Work Queue 
server services requests from the Oracle Universal Work Queue desktop bean to 
deliver media items to agents.

The Oracle Universal Work Queue server passes instructions to media providers 
requesting delivery of the next item in an agent’s queue. The Oracle Universal Work 
Queue server gets the media item metadata from the media provider and delivers it 
to the media enabler (for example, Oracle SoftPhone) and the CRM business 
application.

See Also
■ Technology Stack for Oracle Universal Work Queue

■ Integration Dependencies for Oracle Universal Work Queue

■ Sizing Guidelines for Oracle Universal Work Queue

■ Scalability for Oracle Universal Work Queue

1.2.1 Technology Stack for Oracle Universal Work Queue
The Oracle Universal Work Queue desktop is installed during the Oracle 
Applications Rapid Install. The Oracle Universal Work Queue desktop is an 
installable module on the standard Oracle Applications technology stack. 
Implementing Oracle Universal Work Queue 1-7
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The Oracle Universal Work Queue desktop objects and files consist of Forms and 
Java objects on the application tier, and several PL/SQL procedures on the database 
tier. 

The code for the Interaction Center servers is installed during the Oracle 
Applications Rapid Install. However, the startup scripts and other files for the 
Oracle Universal Work Queue server are not on the standard Oracle Applications 
technology stack. These files are installed on a server machine from the Oracle Call 
Center Applications Setup CD.

See Also
■ Architecture of Oracle Universal Work Queue

■ Integration Dependencies for Oracle Universal Work Queue

■ Sizing Guidelines for Oracle Universal Work Queue

■ Scalability for Oracle Universal Work Queue

1.2.2 Integration Dependencies for Oracle Universal Work Queue
Oracle Universal Work Queue has a number of integration points with other Oracle 
products.

1.2.2.1 Installation Dependencies
Oracle Universal Work Queue has references to the common and shared 
components of the following products.

■ Oracle Applications Foundation (FND)

■ CRM Foundation (JTF)

■ Common CRM Interaction Center Technology Schema (IEO)

1.2.2.2 Operational Dependencies for Non-Media Tasks
The following CRM business applications provide non-media work items which can 
be requested through Oracle Universal Work Queue:
 

Non-Media Item Operational Dependency

Tasks Oracle CRM Foundation

Service Requests Oracle Support
1-8 Oracle Universal Work Queue Implementation Guide
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1.2.2.3 Operational Dependencies for Media Tasks
The following media servers provide media work items which can be requested 
through Oracle Universal Work Queue:

 See Also
■ Architecture of Oracle Universal Work Queue

■ Technology Stack for Oracle Universal Work Queue

■ Sizing Guidelines for Oracle Universal Work Queue

■ Scalability for Oracle Universal Work Queue

1.2.3 Sizing Guidelines for Oracle Universal Work Queue
Oracle Universal Work Queue complies with the general sizing recommendations 
for the Oracle database and Oracle Applications used in your business operations.

The performance of the Oracle Universal Work Queue server is critical to agent 
productivity. It is recommended that the Oracle Universal Work Queue server be 
installed on its own server machine.

Although sizing is ultimately determined by many system factors, the following 
sizing information for Microsoft Windows NT is a general guideline. It assumes a 
Pentium III 500 MHz machine with 512 MB RAM.

Defects Oracle Support

Enhancements Oracle Support

Leads Oracle TeleSales

Opportunities Oracle TeleSales

Forecasts Oracle TeleSales

Media Item Operational Dependency

Inbound Telephony Oracle Advanced Inbound

Inbound Email Oracle eMail Center

Outbound Telephony Oracle Advanced Outbound

Non-Media Item Operational Dependency
Implementing Oracle Universal Work Queue 1-9
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See Also
■ Architecture of Oracle Universal Work Queue

■ Technology Stack for Oracle Universal Work Queue

■ Integration Dependencies for Oracle Universal Work Queue

■ Scalability for Oracle Universal Work Queue

1.2.4 Scalability for Oracle Universal Work Queue
Oracle Universal Work Queue complies with the general scalability 
recommendations for the Oracle database and Oracle Applications used in your 
business operations.

When using Oracle Universal Work Queue for non-media work processing, there 
are no special scalability considerations.

When using Oracle Universal Work Queue for media work processing, multiple 
Oracle Universal Work Queue servers can be deployed in each interaction center. 
The Oracle Universal Work Queue desktop bean will choose the least loaded server 

Number of Agents Number of Server Machines

Less than 50 agents One machine to run all of the Interaction Center servers.

50 to 500 agents Two machines.

■ Call Center Connectors, Telephony Manager, Telephony 
Media Controller, Inbound Telephony

■ Universal Work Queue, Routing, eMail Center

501 to 1000 agents Three machines.

■ Telephony Manager

■ Call Center Connectors, Telephony Media Controller, 
Inbound Telephony, eMail Center

■ Universal Work Queue, Routing

More than 1001 agents Four machines.

■ Telephony Manager

■ Call Center Connectors, Telephony Media Controller, 
Inbound Telephony

■ Routing, eMail Center

■ Universal Work Queue
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upon connecting. This is not a dynamic load balancing scheme, but a one time, 
connection load-balancing scheme. This scheme is useful for both scalability and 
some stateless redundancy. For fault tolerance, the Oracle Universal Work Queue 
desktop bean can reconnect to a different Oracle Universal Work Queue server in 
the same interaction center, in some cases without any user intervention.

Oracle Universal Work Queue servers cannot service multiple interaction centers. 
This means that a Oracle Universal Work Queue server can service only the 
interaction center to which it has been assigned. Agents can only be assigned to one 
interaction center. Therefore, each interaction center must be self-sufficient. 

See Also
■ Architecture of Oracle Universal Work Queue

■ Technology Stack for Oracle Universal Work Queue

■ Integration Dependencies for Oracle Universal Work Queue

■ Sizing Guidelines for Oracle Universal Work Queue

1.3 Planning the Implementation of Oracle Universal Work Queue
Plan your implementation to ensure that you understand the scope of the 
implementation project.

See Also
■ Overview of Implementing Oracle Universal Work Queue

■ Implementation Starting Point

1.3.1 Overview of Implementing Oracle Universal Work Queue
The following list is a high-level overview of the steps for implementing Oracle 
Universal Work Queue.

1. Define users for Oracle Universal Work Queue.

See Understanding Oracle Universal Work Queue Users.

2. Configure Oracle Universal Work Queue system profile options.

See Understanding Oracle Universal Work Queue Profiles Options.

3. Optionally, set up Oracle Universal Work Queue for media work.
Implementing Oracle Universal Work Queue 1-11
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See Architecture of Oracle Universal Work Queue.

a. Set up the Oracle Universal Work Queue server for media work.

See Setting Up Oracle Universal Work Queue Server for Media Work.

b. Set up the Oracle Universal Work Queue desktop for media work.

See Configuring the Oracle Universal Work Queue Desktop for Media 
Work.

4. Test the Oracle Universal Work Queue implementation.

See Testing the Oracle Universal Work Queue Implementation.

See Also
■ Implementation Starting Point

1.3.2 Implementation Starting Point
This implementation guide assumes that you have, at a minimum:

■ Installed Oracle Applications (database, technology stack, and Oracle 
Applications files).

See Installing Oracle Applications or Upgrading Oracle Applications.

■ If implementing Oracle eMail Center, installed Microsoft Internet Explorer on 
the agent desktop -- otherwise, installed Netscape Communicator.

■ Installed JInitiator on the agent desktop.

■ Optionally, implemented Oracle Human Resource Management Systems.

See Implementing Oracle HRMS.

■ Implemented CRM Foundation Resource Manager.

See Oracle CRM Foundation Implementation Guide.

■ Implemented one of Oracle TeleSales or Oracle Support.

See Oracle TeleSales Implementation Guide or Oracle Support Implementation Guide.

■ If implementing Oracle Universal Work Queue for media work, installed and 
configured the media layer -- telephony or email.

See Oracle Call Center Connectors Implementation Guide or the Oracle Email Server 
documentation.
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■ If implementing Oracle Universal Work Queue for media work, installed and 
configured the appropriate interaction servers.

See Oracle Call Center Applications Setup Guide.

See Also
■ Overview of Implementing Oracle Universal Work Queue

1.4 Understanding Oracle Universal Work Queue Users
There are several end user roles for Oracle Universal Work Queue:

■ Oracle Universal Work Queue Administrator

■ Interaction Center Server Group Administrator (optional)

■ Interaction Center Administrator (optional)

■ Interaction Center Agent

The Oracle Universal Work Queue administrator defines Oracle Universal Work 
Queue agents and configures Oracle Universal Work Queue system profile options.

The Interaction Center Administrator, which is optional for Oracle Universal Work 
Queue implementation, sets up Oracle Universal Work Queue for media work.

The interaction center agent displays the Oracle Universal Work Queue desktop 
user interface, accesses work using the Oracle Universal Work Queue desktop, and 
manages work using CRM business applications.

See Also
■ Defining an Oracle Universal Work Queue Administrator

■ Defining an Oracle Universal Work Queue Agent
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1.5 Defining Oracle Universal Work Queue Users
Every application user must be an authorized user of Oracle Applications. An 
application user is uniquely identified by a username and password. Once defined, 
an application user can sign on to Oracle Applications and access data through 
Oracle Applications user interfaces.

An application user is granted one or more responsibilities. A responsibility is a 
level of authority in Oracle Applications that allows a user to access specific Oracle 
Applications functions. If a user has more than one responsibility, then the user can 
choose a responsibility after signing on to Oracle Applications.

Oracle Applications is installed with predefined responsibilities. The responsibility 
key uniquely identifies a responsibility in Oracle Applications and cannot be 
modified after the responsibility record has been saved. However, a system 
administrator can change the responsiblity name at any time. In addition, a system 
administrator can create and assign custom custom responsibilities.

For detailed information about Oracle Applications user accounts, including 
guidelines for creating usernames and passwords, see Oracle Applications System 
Administrator’s Guide.

See Also
■ Defining an Oracle Universal Work Queue Administrator

■ Defining an Oracle Universal Work Queue Agent

1.5.1 Defining an Oracle Universal Work Queue Administrator
Use this procedure to define an Oracle Applications administrator for Oracle 
Universal Work Queue.

Prerequisites
■ Review Section 1.5, "Defining Oracle Universal Work Queue Users".

■ Review Oracle Applications Systems Administrator’s Guide.

■ Obtain an Oracle Applications user account with access to the System 
Administrator (SYSTEM_ADMINISTRATOR) responsibility.

Steps
1. If necessary, sign on to Oracle Applications using the PHP URL.
1-14 Oracle Universal Work Queue Implementation Guide



Defining Oracle Universal Work Queue Users
If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the System Administrator responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Security > User > 
Define.

The User window appears.

Use the following guidelines to define Oracle Applications usernames:

■ Use only one word.

■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).

■ Use only the set of characters that your operating system supports for 
filenames.

4. In the User Name field, enter the name of the user account.

The password is temporary. When the user signs on to Oracle Applications for 
the first time, the message "Your password has expired" appears and the user is 
prompted to set a new password.

Use the following guidelines to define Oracle Applications passwords:

■ Use at least five characters and no more than 100 characters.

■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).

5. In the Password field, enter the password for the user account and then press 
Tab.

The cursor remains in the Password field.

6. Enter the password again to verify it.

7. In the Responsibilities tab, add the following responsibilities:

Function Responsibility Name Responsibility Key

Create an employee in Oracle Human Resource 
Management Systems (if Oracle HRMS is 
installed)

HRMS Manager
(for example, US HRMS Manager)

<country code>_HRMS_MANAGER
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Once the user record has been saved, you cannot delete an assigned 
responsibility. Oracle Applications maintains audit data for assigned 
responsibilities.

To deactivate an assigned responsibility, set the effective end date (in the 
Effective Dates - To field) of the assigned responsibility to the current date. To 
activate an assigned responsibility, clear or reset the effective end date.

8. From the File menu, choose Save.

See Also
■ Section 1.4, "Understanding Oracle Universal Work Queue Users"

■ Section 1.5.2, "Defining an Interaction Center Server Group Administrator"

■ Section 1.5.3, "Defining an Interaction Center Telephony Administrator"

■ Section 1.5.4, "Defining an Oracle Universal Work Queue Agent"

Create an Oracle Applications user account

Configure Oracle Applications user profile 
options

System Administrator SYSTEM_ADMINISTRATOR

Create an employee in CRM Resource Manager 
(if Oracle HRMS is not installed)

Create an CRM resource

Configure interaction center roles and 
parameters for a CRM resource

CRM Resource Manager JTF_RESOURCE_MANAGER

Define an interaction center server group

Define interaction center servers

Call Center Server Administrator IEU_SVRLC_ADM

Define the following for the interaction center:

■ CTI middleware

■ Telesets

■ IVR mapping

■ Media classifications

■ Media routing

Call Center Administrator CCT_ADMIN_FORM

Associate media work with a CRM business 
application

UWQ Administration UWQ_ADMIN

Function Responsibility Name Responsibility Key
1-16 Oracle Universal Work Queue Implementation Guide



Defining Oracle Universal Work Queue Users
1.5.2 Defining an Interaction Center Server Group Administrator
Use this procedure to define an Oracle Applications administrator for interaction 
center server groups.

Prerequisites
■ Review Section 1.5, "Defining Oracle Universal Work Queue Users".

■ Review Oracle Applications Systems Administrator’s Guide.

■ Obtain an Oracle Applications user account with access to the System 
Administrator (SYSTEM_ADMINISTRATOR) responsibility.

Steps
1. If necessary, sign on to Oracle Applications using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the System Administrator responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Security > User > 
Define.

The User window appears.

Use the following guidelines to define Oracle Applications usernames:

■ Use only one word.

■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).

■ Use only the set of characters that your operating system supports for 
filenames.

4. In the User Name field, enter the name of the user account.

The password is temporary. When the user signs on to Oracle Applications for 
the first time, the message "Your password has expired" appears and the user is 
prompted to set a new password.

Use the following guidelines to define Oracle Applications passwords:

■ Use at least five characters and no more than 100 characters.
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■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).

5. In the Password field, enter the password for the user account and then press 
Tab.

The cursor remains in the Password field.

6. Enter the password again to verify it.

7. In the Responsibilities tab, add the following responsibility:

Once the user record has been saved, you cannot delete an assigned 
responsibility. Oracle Applications maintains audit data for assigned 
responsibilities.

To deactivate an assigned responsibility, set the effective end date (in the 
Effective Dates - To field) of the assigned responsibility to the current date. To 
activate an assigned responsibility, clear or reset the effective end date.

8. From the File menu, choose Save.

See Also
■ Section 1.4, "Understanding Oracle Universal Work Queue Users"

■ Section 1.5.1, "Defining an Oracle Universal Work Queue Administrator"

■ Section 1.5.3, "Defining an Interaction Center Telephony Administrator"

■ Section 1.5.4, "Defining an Oracle Universal Work Queue Agent"

Function Responsibility Name Responsibility Key

Administer interaction center server groups and 
servers.

IEO_SVR_ADMINISTRATOR IEO_SVR_ADMINISTRATOR
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1.5.3 Defining an Interaction Center Telephony Administrator
Use this procedure to define an Oracle Applications administrator for interaction 
center telephony.

Prerequisites
■ Review Section 1.5, "Defining Oracle Universal Work Queue Users".

■ Review Oracle Applications Systems Administrator’s Guide.

■ Obtain an Oracle Applications user account with access to the System 
Administrator (SYSTEM_ADMINISTRATOR) responsibility.

Steps
1. If necessary, sign on to Oracle Applications using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the System Administrator responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Security > User > 
Define.

The User window appears.

Use the following guidelines to define Oracle Applications usernames:

■ Use only one word.

■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).

■ Use only the set of characters that your operating system supports for 
filenames.

4. In the User Name field, enter the name of the user account.

The password is temporary. When the user signs on to Oracle Applications for 
the first time, the message "Your password has expired" appears and the user is 
prompted to set a new password.

Use the following guidelines to define Oracle Applications passwords:

■ Use at least five characters and no more than 100 characters.
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■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).

5. In the Password field, enter the password for the user account and then press 
Tab.

The cursor remains in the Password field.

6. Enter the password again to verify it.

7. In the Responsibilities tab, add the following responsibility:

Once the user record has been saved, you cannot delete an assigned 
responsibility. Oracle Applications maintains audit data for assigned 
responsibilities.

To deactivate an assigned responsibility, set the effective end date (in the 
Effective Dates - To field) of the assigned responsibility to the current date. To 
activate an assigned responsibility, clear or reset the effective end date.

8. From the File menu, choose Save.

See Also
■ Section 1.4, "Understanding Oracle Universal Work Queue Users"

■ Section 1.5.1, "Defining an Oracle Universal Work Queue Administrator"

■ Section 1.5.2, "Defining an Interaction Center Server Group Administrator"

■ Section 1.5.4, "Defining an Oracle Universal Work Queue Agent"

1.5.4 Defining an Oracle Universal Work Queue Agent
Follow the steps in the following table to create an Oracle Universal Work Queue 
agent. The Number column indicates the step order. The Required column indicates 
whether a step is required. The Description column describes a high-level step and, 
where applicable, provides a reference to a more detailed topic in this document. 
The Responsibility column indicates the Oracle Applications user account 
responsibility required to complete the step.

Function Responsibility Name Responsibility Key

Administer middleware, media classification, 
and media routing for telephony media.

Call Center HTML Administrator CCT_WEB_ADMIN
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If you have defined a user as an Oracle Universal Work Queue administrator, then 
that user will have all of the responsibilities necessary to define an Oracle Universal 
Work Queue agent.

See Also
■ Understanding Oracle Universal Work Queue Users

■ Defining an Oracle Universal Work Queue Administrator

■ Configuring Universal Work Queue System Profile Values

Number Required? Description Responsibility

❏ Step 1 Required Create an employee.

If Oracle Human Resource Management Systems is 
installed, see Creating an Employee in Oracle Human 
Resource Management Systems.

If Oracle Human Resource Management Systems is not 
installed, see Creating an Employee in CRM Resource 
Manager.

HRMS Manager for 
Oracle Human Resource 
Management Systems

OR

CRM Resource Manager 
for CRM Resource 
Manager

❏ Step 2 Required Create an Oracle Applications user account for the 
employee.

See Creating an Oracle Applications User Account for an 
Employee.

System Administration

❏ Step 3 Required Create a CRM resource for the employee.

See Creating a CRM Resource for an Employee.

CRM Resource Manager

❏ Step 4 Optional For media work, configure interaction centers roles and 
parameters for the CRM resource.

See Configuring Interaction Center Roles and Parameters 
for a CRM Resource.

CRM Resource Manager

❏ Step 5 Required Configure the Oracle Universal Work Queue profile 
options.

See Configuring Universal Work Queue System Profile 
Values.

System Administrator
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1.5.5 Creating an Employee in Oracle Human Resource Management Systems

Use this procedure to create an employee in Oracle Human Resource Management 
Systems (HRMS).

Prerequisites
■ Review Managing People Using Oracle HRMS.

■ Define an Oracle Universal Work Queue administrator. See Section 1.5.1, 
"Defining an Oracle Universal Work Queue Administrator".

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the HRMS Manager responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose People > Enter and 
Maintain.

The Find Person window appears.

4. Click New.

The People window appears.

5. Enter the information for the new person.

The following fields are required:

■ Last (Name)

■ Gender

Note: If you do not have Oracle Human Resource Management 
Systems installed, then use CRM Resource Manager to create an 
employee. See Section 1.5.6, "Creating an Employee in CRM 
Resource Manager".
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■ Type

■ Employee (Number)

Other fields may be required depending on how your enterprise has set up 
Oracle HRMS. In addition, when you save the record, you may receive one or 
more messages that explain the consequences of leaving certain fields blank.

6. From the File menu, choose Save.

See Also
■ Understanding Oracle Universal Work Queue Users

■ Defining an Oracle Universal Work Queue Agent

■ Creating an Employee in CRM Resource Manager

■ Creating an Oracle Applications User Account for an Employee

■ Creating a CRM Resource for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Configuring Universal Work Queue System Profile Values

■ Associating Media Work with a CRM Business Application

Note: In the Type field, select Employee.

Note: If the Employee field is inactive, then Oracle HRMS is setup 
to automatically generate the employee number when the record is 
saved.
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1.5.6 Creating an Employee in CRM Resource Manager

Use this procedure to create an employee when Oracle Human Resource Manager 
Systems (HRMS) is not installed. This procedure populates the same database tables 
as the People window in Oracle Human Resource Management Systems.

Prerequisites
■ Review Managing People Using Oracle HRMS.

■ Define an Oracle Universal Work Queue administrator. See Section 1.5.1, 
"Defining an Oracle Universal Work Queue Administrator".

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the CRM Resource Manager responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Maintain Employee > 
Employee.

The Find Person window appears.

4. Click New.

The People window appears.

5. Enter the information for the new person.

The following fields are required:

■ Last (Name)

Note: If Oracle Human Resource Management Systems is 
installed, then use Oracle Human Resource Management Systems 
to create an employee. See Section 1.5.5, "Creating an Employee in 
Oracle Human Resource Management Systems".
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■ Gender

■ Type

■ Employee (Number)

Other fields may be required depending on how your enterprise has set up 
Oracle HRMS. In addition, when you save the record, you may receive one or 
more messages that explain the consequences of leaving certain fields blank.

6. From the File menu, choose Save.

See Also
■ Understanding Oracle Universal Work Queue Users

■ Defining an Oracle Universal Work Queue Agent

■ Creating an Employee in Oracle Human Resource Management Systems

■ Creating an Oracle Applications User Account for an Employee

■ Creating a CRM Resource for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Configuring Universal Work Queue System Profile Values

■ Associating Media Work with a CRM Business Application

1.5.7 Creating an Oracle Applications User Account for an Employee
Use this procedure to create an Oracle Applications user account and to associate an 
employee (created in Oracle Human Resource Management Systems or CRM 
Resource Manager) with a user account.

Note: In the Type field, select Employee.

Note: If the Employee field is inactive, then Oracle HRMS is setup 
to automatically generate the employee number when the record is 
saved.
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Prerequisites
■ Review Oracle Applications Systems Administrator’s Guide.

■ Define an Oracle Universal Work Queue administrator. See Section 1.5.1, 
"Defining an Oracle Universal Work Queue Administrator".

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the System Administrator responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Security > User > 
Define.

The User window appears.

4. In the Navigator window, on the Functions tab, choose Security > User > 
Define.

The User window appears.

Use the following guidelines to define Oracle Applications usernames:

■ Use only one word.

■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).

■ Use only the set of characters that your operating system supports for 
filenames.

5. In the User Name field, enter the name of the user account.

The password is temporary. When the user signs on to Oracle Applications for 
the first time, the message "Your password has expired" appears and the user is 
prompted to set a new password.

Use the following guidelines to define Oracle Applications passwords:

■ Use at least five characters and no more than 100 characters.

■ Use only alphanumeric characters (’A’ through ’Z’, and ’0’ through ’9’).
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6. In the Password field, enter the password for the user account and then press 
Tab.

The cursor remains in the Password field.

7. Enter the password again to verify it.

8. In the Person field, select an employee to associate with this user account.

An agent must have access to:

■ the CRM business application associated with the work item

■ the Oracle Universal Work Queue desktop

Typically, Oracle Universal Work Queue is a menu option in the menu for the 
CRM business application. For example, the menu associated with the 
Customer Support responsibility includes access to Oracle Support and Oracle 
Universal Work Queue.

9. In the Responsibilities tab, add one or more of the following responsibilities:

Note: This is a temporary password. When the user signs on to 
Oracle Applications for the first time, the message "Your password 
has expired" appears and the user is prompted to set a new 
password.

Note: The menu associated with the Universal Work Queue 
Selector UI responsibility does not grant access to a CRM business 
application.

Function Responsibility Name Responsibility Key

Work on service requests, service request 
tasks, or service request enhancements 
(Oracle Support) from Oracle Universal 
Work Queue

Customer Support ORACLE_SUPPORT

Work on sales leads, sales opportunities, or 
sales forecasts (Oracle TeleSales) from 
Oracle Universal Work Queue

TeleSales Agent TELESALESAGENT
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Once the user record has been saved, you cannot delete an assigned 
responsibility. Oracle Applications maintains audit data for assigned 
responsibilities.

To deactivate an assigned responsibility, set the effective end date (in the 
Effective Dates - To field) of the assigned responsibility to the current date. To 
activate an assigned responsibility, clear or reset the effective end date.

10. From the File menu, choose Save.

See Also
■ Understanding Oracle Universal Work Queue Users

■ Defining an Oracle Universal Work Queue Agent

■ Creating an Employee in Oracle Human Resource Management Systems

■ Creating an Employee in CRM Resource Manager

■ Creating a CRM Resource for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Configuring Universal Work Queue System Profile Values

■ Associating Media Work with a CRM Business Application

1.5.8 Creating a CRM Resource for an Employee
Use this procedure to create a Customer Relationship Management (CRM) resource 
based on a person in Oracle Human Resource Management Systems (HRMS).

Prerequisites
■ Review Oracle CRM Foundation Concepts and Procedures.

■ Define an Oracle Universal Work Queue administrator. See Section 1.5.1, 
"Defining an Oracle Universal Work Queue Administrator".

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.
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2. Select or switch to the CRM Resource Manager responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Maintain Resources > 
Import Resources.

The Selection Criteria window appears.

4. In the Resource Category field, select Employee.

5. Enter any additional selection criteria.

For example, in the Name field, select the name of an employee.

6. Click Search.

Employees that meet the search criteria are listed in the Search Results area. The 
Select check boxes for the matching employees are automatically selected.

7. Clear the Select check boxes of the resources that you do not want to save.

8. Click Create Resource.

The Default Values window appears. You can add or modify this information in 
the resource details later. 

9. Click OK to accept the defaults.

The Selected Resources window appears. The Select check boxes for the 
matching resources are automatically selected. The Comments field indicate 
whether the resource is a new record, a duplicate record, or a duplicate record 
with a new role definition.

10. Clear the Select check boxes of the employees for which you do not want to 
create a CRM resource.

11. To save the resources, click Save Resource.

A transaction number appears in the Transaction Number field. The transaction 
number is associated with each resource created during this transaction. More 
than one resource can have the same transaction number.

12. To view the details about a resource, click Details.

See Also
■ Understanding Oracle Universal Work Queue Users

■ Defining an Oracle Universal Work Queue Agent
Implementing Oracle Universal Work Queue 1-29



Understanding Oracle Universal Work Queue Profiles Options
■ Creating an Employee in Oracle Human Resource Management Systems

■ Creating an Employee in CRM Resource Manager

■ Creating an Oracle Applications User Account for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Configuring Universal Work Queue System Profile Values

■ Associating Media Work with a CRM Business Application

1.6 Understanding Oracle Universal Work Queue Profiles Options
A profile option is a setting that affects the way an application functions. There are 
Oracle Applications profile options that are common to all applications and Oracle 
Applications profile options that are specific to a particular application. For a   
complete list of profile options for Oracle Universal Work Queue, see Appendix A, 
"Oracle Universal Work Queue Profile Options".

For detailed information about Oracle Applications profile options, see Oracle 
Applications System Administrator’s Guide.

1.6.1 System Profile Hierarchy
Profile options can be set at up to four different levels: site, application, 
responsibility, and user. Some profile options exists at each level. Other profile 
options exists only at certain levels.

When a profile option may be set at more than one level, site has the lowest priority, 
superseded by application, then responsibility, with user having the highest 
priority. For example, a value entered at the site level may be overridden by values 
entered at any other level. A value entered at the user level has the highest priority, 
and overrides values entered at any other level.

Profile Option Level Description

Site Site profile option values apply to all users at a given installation 
site.

Application Application profile option values apply to users working under 
responsibilities owned by a specific application. This value 
overrides the site level value.
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1.6.2 System Profile Values
A system administrator can set values for profile options at each profile level. 
Typically, the system administrator sets Site profile option values after Oracle 
Applications is installed at a site. The Site level profile option values apply until the 
system administrator or an application user changes them.

1.6.3 Personal Profile Values
Application users may set their own personal profile options at the user level. Not 
all profile options are visible to users, and some profile options, while visible, may 
not be updated by application users.

The system administrator can change the value of a user profile option at any time. 
The change takes affect as soon as the user logs on again or changes responsibility.

1.6.4 How Profile Options Values are Determined
The setting for a profile option can be determined by an actual value or by default. 
Depending on the how the profile option is used in an application, the default may 
be an actual predefined value or it may be determined dynamically at runtime.

1.7 Configuring Universal Work Queue System Profile Values
Use this procedure to view and set system profile option values. You can view and 
set profile options at the site, application, responsibility, and user levels. Profile 
option values affect users as soon as they sign on or change responsibility.

For a   complete list of profile options for Oracle Universal Work Queue, see 
Appendix A, "Oracle Universal Work Queue Profile Options".

Prerequisites
■ Review Oracle Applications Systems Administrator’s Guide.

Responsibility Responsibility profile option values apply to users working 
under a specific responsibility. This value overrides the site and 
application profile option values.

User User profile option values apply to a specific application user. 
This value overrides the site, application, and responsibility 
profile option values.

Profile Option Level Description
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■ Review Understanding Oracle Universal Work Queue Profiles Options.

■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 
Universal Work Queue Administrator.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the System Administrator responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Profile > System.

The Find System Profile Values window appears. The Site and Profiles with No 
Values checkboxes are selected by default.

4. Specify the level or levels at which you wish to view or set profile option 
values.

■ If you want to view or set profile options for all users at the installation site, 
select the Site box.

■ If you want to view or set profile options for users working under 
responsibilities owned by a specific application, select the Application box 
and then select an application from the Application list.

■ If you want to view or set profile options for users working under a specific 
responsibility, select the Responsibility box and then select a responsibility 
from the Responsibility list.

■ If you want to view or set profile options for a specific user, select the User 
box and then select a username from the User list.

5. If you want to display profile options both with and without values, select the 
Profiles with No Values checkbox.

6. If you want to display profile options that include a specific character string, 
enter the string in the Profile field.
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You may search for profile options using character strings and the wildcard 
symbol (%). For example, to find profile options prefixed by "IEU", the product 
code for Oracle Universal Work Queue, enter "IEU%".

7. Click Find.

The System Profile Values window appears.

8. Set the values for the profile options at one or more levels.

When a profile option may be set at more than one level, the value entered at 
the Site level has the lowest priority. The value entered at the Site level is 
superseded by any value entered at the Application level value and the value 
entered at the Application level is superseded by any value entered at the 
Responsibility level. The value entered at the User level has the highest priority 
and overrides values entered at any other level. 

For information about Oracle Universal Work Queue profile options, see 
Appendix A, "Oracle Universal Work Queue Profile Options".

9. From the File menu, choose Save.

Your changes take effect as soon as users sign on or change responsibility.

See Also
■ Creating an Employee in Oracle Human Resource Management Systems

■ Creating an Employee in CRM Resource Manager

■ Creating an Oracle Applications User Account for an Employee

■ Creating a CRM Resource for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Associating Media Work with a CRM Business Application
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1.8 Setting Up Oracle Universal Work Queue Server for Media Work
Follow the steps in the following table to set up Oracle Universal Work Queue 
server for media work. The Number column indicates the step order. The Required 
column indicates whether a step is required. The Description column describes a 
high-level step and, where applicable, provides a reference to a more detailed topic 
in this document. The Oracle Documentation column provides a reference to other 
relevant documents.

See Also
■ Configuring the Oracle Universal Work Queue Desktop for Media Work

Number Required? Description Oracle Documentation

❏ Step 1 For telephony 
only

Install and configure Oracle Call Center 
Connectors.

Oracle Call Center Connectors 
Implementation Guide

❏ Step 2 For email only Install and configure Oracle Email Server. Oracle Email Server Installation 
Guide

❏ Step 3 For IVR 
integration 
only

Install Oracle IVR Integrator. Oracle IVR Integrator 
Implementation Guide

❏ Step 4 Yes Define an interaction center server group.

See Defining an Oracle Interaction Center 
Server Group.

Oracle Telephony Manager 
Implementation Guide

❏ Step 5 Yes Define and configure the interaction center 
servers.

See Defining an Interaction Center Server.

Oracle Telephony Manager 
Implementation Guide

❏ Step 6 Yes Define and configure the CTI middleware.

See Defining the CTI Middleware for the 
Server Group.

Oracle Telephony Manager 
Implementation Guide

❏ Step 7 Optional Define the interaction center telesets. Oracle Telephony Manager 
Implementation Guide

❏ Step 8 Optional Map the inbound IVR data to fields in 
Oracle Applications.

Oracle Telephony Manager 
Implementation Guide

❏ Step 9 Yes Install the interaction center servers. Oracle Call Center Applications 
Setup Guide
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1.8.1 Defining an Oracle Interaction Center Server Group

An Oracle interaction center is represented by a logical grouping of interaction 
center processes called a server group. If there are multiple interaction centers or if 
separate lines of business are operating in the same interaction center, then there 
can be multiple server groups. Once the server group is defined, you can configure 
the individual interaction center processes in the group.

Use this procedure to define a server group.

Prerequisites
■ Review Oracle Telephony Manager Implementation Guide.

■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 
Universal Work Queue Administrator.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the Call Center Server Administration responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

The Server Locator window appears. To scroll through the records for all server 
groups, press Page Up or Page Down. To search for a specific server group, 
choose View > Query by Example > Enter to invoke the query entry mode. 
Enter your query and then choose View > Query by Example > Run to find the 
matching server groups.

3. To define a new server group, choose New from the File menu.

4. In the Server Group tab, define the server group.

The server group name is required. The server group location and description 
are for informational purposes only.

Note: This procedure applies to media work only.
Implementing Oracle Universal Work Queue 1-35



Setting Up Oracle Universal Work Queue Server for Media Work
5. From the File menu, choose Save.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Defining an Interaction Center Server

■ Defining the CTI Middleware for the Server Group

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

1.8.2 Defining an Interaction Center Server

Oracle interaction center functions, such as Oracle Universal Work Queue, are 
governed by individual server processes. The number and types of server processes 
in a server group will depend on how you are implementing your Oracle 
interaction center. The server processes may run on one or more server machines. 
Each server process is configured individually.

The following table lists the recommended servers for different types of media 
processing.

Note: This procedure applies to media work only.

If you are implementing... Then define...

Advanced Inbound Telephony 
in Passive Mode

Server Monitor

Telephony Manager

Telephony Media Controller

Inbound Telephony Server (if implementing web callback)

Routing Server (for media classification; routing not used)

Universal Work Queue Server
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Use this procedure to define and configure interaction center servers.

Prerequisites
■ Review Oracle Telephony Manager Implementation Guide.

■ Define an interaction center server group. See Defining an Oracle Interaction 
Center Server Group.

■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 
Universal Work Queue Administrator.

Advanced Inbound Telephony 
in Active Mode

Server Monitor

Telephony Manager

Telephony Media Controller

Inbound Telephony Server

Routing Server (for media classification and routing)

Interaction Blending Server (if implementing media work blending)

Universal Work Queue Server

Advanced Outbound 
Telephony

Server Monitor

Telephony Manager

Telephony Media Controller

Inbound Telephony Server

Advanced Outbound Proxy Server

Routing Server (for media classification and routing)

Interaction Blending Server (if implementing media work blending)

Universal Work Queue Server

eMail Center Server Monitor

Telephony Manager

Telephony Media Controller

eMail Center Server

Routing Server (for media classification and routing)

Interaction Blending Server (if implementing media work blending)

Universal Work Queue Server

If you are implementing... Then define...
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Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the Call Center Server Administration responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

The Server Locator window appears.

3. In the Server Group tab, find your server group

To scroll through the records for all server groups, press Page Up or Page 
Down. To search for a specific server group, choose View > Query by Example 
> Enter to invoke the query entry mode. Enter your query and then choose 
View > Query by Example > Run to find the matching server groups.

4. Select the Server tab.

To scroll through the records for all servers in the server group, press Page Up 
or Page Down. To search for a specific server in the server group, choose View > 
Query by Example > Enter to invoke the query entry mode. Enter your query 
and then choose View > Query by Example > Run to find the matching servers.

5. To define a new server, choose New from the File menu.

6. In the Server Registration area, identify the server.

The server name and type are required. 

a. Enter a unique name for the server.

The name of the server in the Server Locator window in the Server tab must 
match the name given to the server when it is installed on a machine. To 
change the name of an interaction center server in the database, use the 
Server tab. To change the name of an interaction center server on a machine 
after installation, see Modifying the Name of Oracle Universal Work Queue 
Server.

b. Optionally, in the Server Location field, enter the location of the server.

c. From the Type Name list, select the server type.
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The Member Group Name field automatically displays the name of the 
server group selected on the Server tab.

d. Optionally, to associate the server with another server group, select the 
server group from the Member Group Name list.

If the server is on a machine with a static IP address, then the DNS name 
and IP address are automatically displayed when the server is started for 
the first time.

e. If the server is on a machine in a DCHP or multi-homed network 
configuration, then specify the IP address of the machine in the User 
Address field.

f. Optionally, in the Description field, enter a description of the server.

7. In the Server Parameter area, configure the parameters for the server.

Each row in the Server Parameter area corresponds to a server parameter. 

a. From the Name list, select a parameter.

The parameters listed in the Name list depend on the type of type of server.

b. Enter a value for the parameter.

Parameters must be defined for Telephony Manager Server, Inbound 
Telephony Server, Telephony Media Controller, and Oracle Universal Work 
Queue Server.

Use the following table to set the parameters for Inbound Telephony Server.
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Use the following table to set the parameters for Telephony Manager Server.

Parameter Required? Description Example

OTM_SERVER_NAME Yes The name of the Telephony Manager Server in the 
server group.

OTMServer

TELE_MIDDLEWARE_CONFIG Yes The name of the middleware configuration. The 
middleware configuration name parameter in the 
Server Locator window in the Server tab must 
match the name of the middleware configuration 
in the Call Center Administration window in the 
Middleware tab. See Defining the CTI Middleware 
for the Server Group.

MWConfig

WEB_CALL_PORT For web 
callback 
only

The port used to listen for web callback requests. 
The default port for web callback requests is 888. 
The web callback port parameter in the Server 
Locator window in the Server tab must match the 
port in the OTM Server Port field in the iSupport 
Admin UI -> Support tab -> Call Me sub-tab.

888

Parameter Required? Description Example

TELE_MIDDLEWARE_CONFIG Yes The name of the middleware configuration. The 
middleware configuration name parameter in the 
Server Locator window in the Server tab must 
match the name of the middleware configuration 
in the Call Center Administration window in the 
Middleware tab. See Defining the CTI Middleware 
for the Server Group.

MWConfig

DEFAULT_TIMEOUT Optional Default timeout for re-route in minutes. For 
example, when this parameter is set to 5, a media 
item will be re-routed if it has been waiting in 
queue for more than 5 minutes.

5

IB_SERVER_NAME Optional The name of the Interaction Blending Server in the 
server group.

IBServer

MQA_MODE Optional This parameter applies to the Nortel switch only. If 
multiple queue mode is on, select TRUE. If 
multiple queue mode is off, select FALSE or leave 
this parameter blank.

TRUE

PASSIVE_MODE Optional To configure Telephony Manager Server to run in 
passive mode, select TRUE. To configure 
Telephony Manager Server to run in active mode, 
select FALSE or leave this parameter blank.

FALSE
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Use the following table to set the parameters for Telephony Media 
Controller.

Use the following table to set the parameters for Oracle Universal Work 
Queue Server.

ROUTE_SERVER_1 For active 
mode only

The name of the Routing server in the server 
group. To balance the media work load, Telephony 
Manager Server can support up to three Routing 
servers. When multiple Routing servers are 
present, Telephony Manager Server sends media 
work to each Routing server on a round-robin 
basis.

RouteServer1

ROUTE_SERVER_2 Optional The name of a Routing server in the server group. RouteServer2

ROUTE_SERVER_3 Optional The name of a Routing server in the server group. RouteServer3

STANDALONE Optional To configure Telephony Manager Server to run in 
standalone mode, select STANDALONE. To 
configure Telephony Manager Server to run in 
distributed mode, select DISTRIBUTED or leave 
this parameter blank.

TRUE

Parameter Required Description Example

TELE_MIDDLEWARE_CONFIG Required The name of the middleware configuration. The 
middleware configuration name parameter in the 
Server Locator window in the Server tab must 
match the name of the middleware configuration 
in the Call Center Administration window in the 
Middleware tab. See Defining the CTI Middleware 
for the Server Group.

MWConfig

OTM_SERVER_NAME Required The name of the Telephony Manager Server in the 
server group.

SampleOTM

MQA_MODE Optional This parameter applies to the Nortel switch only. If 
multiple queue mode is on, select TRUE. If 
multiple queue mode is off, select FALSE or leave 
this parameter blank.

TRUE

PASSIVE_MODE Optional To configure Telephony Manager Server to run in 
passive mode, select TRUE. To configure 
Telephony Manager Server to run in active mode, 
select FALSE or leave this parameter blank.

FALSE

Parameter Required? Description Example
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8. From the File menu, choose Save.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Defining an Oracle Interaction Center Server Group

■ Defining the CTI Middleware for the Server Group

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

1.8.3 Defining the CTI Middleware for the Server Group

CTI (computer telephony integration) middleware enables Oracle Telephony 
Manager Server and the Inbound Telephony Server to control telephony devices 
(for example, agent phones and telesets) and shared telephony resources (for 
example, phone switches).

Use this procedure to define the CTI middleware for the interaction center.

Prerequisites
■ Review Oracle Telephony Manager Implementation Guide.

■ Define an interaction center server group. See Defining an Oracle Interaction 
Center Server Group.

■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 
Universal Work Queue Administrator.

Field Name Required Description Example

SERVER_PORT Required The port used to listen for media requests from the 
Oracle Universal Work Queue desktop bean. The 
default port is 80. Port 80 is a commonly used 
port. If when Oracle Universal Work Queue Server 
is started, there is error message that the port is 
already in use, you can modify the port number.

80

Note: This procedure applies to media work only.
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Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the Call Center Administration responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Call Center 
Administration.

The Call Center Administration window appears.

4. Find your server group

To scroll through the records for all server groups, press Page Up or Page 
Down. To search for a specific server group, choose View > Query by Example 
> Enter to invoke the query entry mode. Enter your query and then choose 
View > Query by Example > Run to find the matching server groups.

5. Select the Middleware tab.

6. In the Middleware Configuration area, specify your middleware.

a. In the Configuration Name field, enter a unique name for the middleware 
configuration.

The name of the middleware configuration in the Middleware tab must 
match middleware configuration name parameter for the Inbound 
Telephony Server, Telephony Manager Server, and Telephony Media 
Controller. See Defining an Interaction Center Server.

b. From the Middleware Type list, select the middleware type.

Use the following table to determine the appropriate middleware type.
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c. In the IP Address field, enter the IP address of the middleware server.

The middleware server is the machine that is hosting the CTI middleware, 
such as Oracle Call Center Connectors.

d. In the Port field, enter the port number of the middleware server.

For Oracle Call Center Connectors, the default port number is 3201. Verify 
the port number against the actual configuration of the middleware server.

7. In the Middleware Parameters area, configure the parameters for the selected 
middleware type.

Each row in the Middleware Parameters area corresponds to an Oracle 
interaction center server parameter.

a. From the Name list, select a parameter.

The parameters listed in the Name list depend on the type of middleware 
selected from the Middleware Type list. 

b. Enter a value for the parameter.

If you are using Dialogic CT-Connect as the CTI enabler, use the following 
table to set the middleware parameters.

If the middleware is... And the CTI enabler is... And the switch is one of...
Then select middleware 
type...

Oracle Call Center Connectors Dialogic CT-Connect Alcatel 4400

Avaya Definity G3

Nortel Meridian

Nortel Symposium
Call Center Server

Siemens HICOM
(US and international)

Dialogic CT-Connect

Oracle Call Center Connectors Cisco ICM Aspect

Avaya Definity G3

Nortel Meridian

Cisco ICM/Enterprise CTI

Parameter Required Description Example

CTI Enabler IP Address Yes The IP address of the CT-Connect server. 123.45.67.890
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PBX Name Yes The link logical identifier defined in the CT-Connect 
configuration to represent the CTI link between 
CT-Connect and the switch.

ctc_nortel
ctc_avaya

PBX Type Yes The PBX type.

■ For Avaya Definity, enter A.

■ For Nortel Meridian or Symposium Call Center 
Server, enter M.

■ For Siemens HICOM, enter S

■ For Alcatel 4400, enter C

A

Middleware Server Info 1 Yes Enter the value ncacn_ip_tcp as the identifier for 
the network protocol used between Oracle Call 
Center Connectors and CT-Connect.

Enter ncacn_ip_tcp 
for TCP/IP (actual 
value)

Route Points Set 1

Route Points Set 2

Route Points Set 3

Route Points Set 4

Route Points Set 5

If using 
active mode

Devices within the PBX/ACD where inbound calls 
are initially received and route requests are issued.

■ Avaya Definity

Enter one or more vector directory numbers 
(VDN), separated by commas. The format is:

vdn[,vdn...]

■ Nortel Meridian:

Enter one or more CDN-immediate treatment 
pair(s), separated by commas. (CDN stands for 
Control Directory Number; the immediate 
treatment of an inbound call arriving at a CDN 
can be ringback or music). The format is:

cdn:treatment[,cdn:treatment...]

The format for treatment is:

##{R|M#musicRouteNumber}

■ Siemens HiCom and Alcatel 4400:

Enter one or more pilot number(s), separated by 
commas. The format is:

pilotNumber[,pilotNumber...]

There is a 256 maximum character limit. You can 
configure as many route points in each Route Points 
Set X field as the 256-character limit permits.

7400

7400,7500

7520:##R

7530:##M#02

7400

Outgoing Prefix If using web 
callback

Numeric prefix dialed to place outside calls. Check 
against the configuration of the PBX.

9

International Dialing Prefix If using web 
callback

Numeric prefix dialed for placing international calls. 011 (from within the 
USA)

Site Country Code If using web 
callback

The country code for the site where the PBX is 
located.

1

Parameter Required Description Example
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If you are using Cisco ICM (formerly Geotel) as the CTI enabler, use the 
following table to set the middleware parameters.

8. From the File menu, choose Save.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Defining an Oracle Interaction Center Server Group

■ Defining an Interaction Center Server

Site Area Code If using web 
callback

The area code for the site where the PBX is located. 650

IVR Server Name If using IVR 
Integrator

The PC-DCE name of the IVR Integrator server. Check 
against PC-DCE configuration.

SAMPLEIVR (IVR 
server values must be 
in uppercase)

Parameter Required Description Example

CTI Enabler IP Address Yes IP address of the Cisco ICM CTI server (Server A). 123.45.67.890

Middleware Server Info 1 Yes Port number of the Cisco ICM CTI server (Port A). 42027

Middleware Server Info 2 Yes IP address of the Cisco ICM CTI server (Server B). 123.45.67.890

Middleware Server Info 3 Yes Port number of the Cisco ICM CTI server (Port B). 42027

PBX Name Yes Peripheral ID defined in Cisco ICM CTI server for 
the PBX of interest.

5008

PBX Type Yes PBX type.

■ A - Avaya Definity

■ M - Nortel Meridian

■ P - Aspect

A

Outgoing Prefix If using web 
callback

Numeric prefix dialed to place an outside call. 
Check against the configuration of the PBX.

9

International Dialing 
Prefix

If using web 
callback

Numeric prefix dialed for placing international calls. 011

Site Country Code If using web 
callback

The country code for the site where the PBX is 
located.

1

Site Area Code If using web 
callback

The area code for the site where the PBX is located. 650

Parameter Required Description Example
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■ Configuring Interaction Center Roles and Parameters for a CRM Resource

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

1.8.4 Configuring Interaction Center Roles and Parameters for a CRM Resource

Use this procedure to configure the interaction center parameters for a CRM 
(Customer Relationship Management) resource. Use the Interaction Center tab in 
the Resource window to specify the following information for the CRM resource:

■ CRM roles

■ Interaction center server group

■ Telephony parameters

■ Email parameters (optional)

Prerequisites
■ Review Oracle Telephony Manager Implementation Guide and Oracle eMail Center 

Implementation Guide.

■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 
Universal Work Queue Administrator.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the CRM Resource Manager responsibility.

3. In the Navigator window, on the Functions tab, choose Resource Manager > 
Maintain Resources > Resources.

The Find window appears.

4. Enter any additional selection criteria.

For example, in the Name field, select the name of an employee.

Note: This procedure applies to media work only.
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5. Click Search.

The Resource window is displayed.

6. In the Roles tab, assign an interaction center role.

a. In the Role Type field, select Callcenter.

b. In the Role field, select the role.

The list of available roles is determined by the selected role type.

7. In the Interaction Center tab, specify the interaction center parameters.

a. In the Interaction Center field, select the interaction center server group for 
the agent.

b. For telephony, in the Telephony Parameters area, enter the telephony 
parameters for the agent.

Each row in the Telephony Parameters area corresponds to an agent 
telephony parameter.

* From the Middleware list, select the middleware configuration name.

* From the Name list, select a parameter.

* In the Value field, enter a value for the parameter.

The telephony parameters that are required and the description of the 
parameter will depend on the type of switch and CTI middleware in use in 
the interaction center.

If you are using a Avaya Definity switch with Dialogic CT-Connect as the 
CTI enabler, then use the following table to set the telephony parameters for 
the agent.

If you are using a Avaya Definity switch with Cisco ICM as the CTI enabler, 
then use the following table to set the telephony parameters for the agent.

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, if any, as defined in the PBX 
admin.

34181

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 34181

Field Name Description Sample Value
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If you are using a Nortel Meridian or Symposium Call Center Server switch 
with Dialogic CT-Connect as the CTI enabler, then use the following table to 
set the telephony parameters for the agent.

If you are using a Nortel Meridian switch with Cisco ICM as the CTI 
enabler, then use the following table to set the telephony parameters for the 
agent.

If you are using an Aspect switch with Cisco ICM as the CTI enabler, then 
use the following table to set the telephony parameters for the agent.

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 34181

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 34181

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46

Field Name Description Sample Value

ACD Data 1 (Require only when the switch is in login ID mode) 
Agent’s ACD login ID, as defined in the PBX admin

1001

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 1001

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 1001

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46

Parameter Description Example

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 1001

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 1001

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46
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If you are using a Siemens HICOM switch with Dialogic CT-Connect as the 
CTI enabler, then use the following table to set the telephony parameters for 
the agent.

If you are using an Alcatel 4400 switch with Dialogic CT-Connect as the CTI 
enabler, then use the following table to set the telephony parameters for the 
agent.

If you are using an Rockwell Spectrum switch with Dialogic CT-Connect as 
the CTI enabler, then use the following table to set the telephony 
parameters for the agent.

c. For email, in the Email Parameters area, enter the email account parameters 
for the agent.

Each row in the Email Parameters area corresponds to an email account 
parameter.

* From the Email Account list, select the email account.

* From the parameter list, select a Default.

* In the Value field, enter IEM_DEFAULT_VALUE (the default value).

8. From the File menu, choose Save.

Parameter Description Example

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 40027

Parameter Description Example

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 0000

ACD Data 2 Agent phone number, as defined in the PBX admin. 3551

ACD Queue Agent’s processing group number, as defined in the PBX 
admin.

3700

Field Name Description Sample Value

ACD Data 2 Directory Number associated with the Staff ID as 
configured on the Rockwell switch

5101
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See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Defining an Oracle Interaction Center Server Group

■ Defining an Interaction Center Server

■ Defining the CTI Middleware for the Server Group

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

1.9 Configuring the Oracle Universal Work Queue Desktop for Media 
Work

Follow the steps in the following table to associates a specific type of media work 
with a specific CRM (Customer Relationship Management) business applications. 
The Required column indicates whether a step is required. The Description column 
describes a high-level step and, where applicable, provides a reference to a more 
detailed topic in this document. The Oracle Documentation column provides a 
reference to other relevant documents.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Works

■ Understanding Media Classifications

■ Defining a Literal Classification

■ Defining a Database Procedure Classification

■ Associating Media Work with a CRM Business Application

Number Required? Description Oracle Documentation

❏ Step 1 Optional Define the rules for applying classifications 
to media work.

See Understanding Media Classifications

Oracle Telephony Manager 
Implementation Guide

❏ Step 2 Required Define the rules for associating media work 
with a CRM (Customer Relationship 
Management) business application.

See Associating Media Work with a CRM 
Business Application

This document
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1.9.1 Understanding Media Classifications
A media classification is a label (for example, GoldSupport) that is assigned to an 
inbound media item. Classification rules define the conditions under which the 
classification is assigned. When the media item meets all of the conditions of the 
classification rules, then the classification is assigned to the media item. 

There are two types of classifications: literal and database procedure.

■ A literal classification is a string (for example, GoldSupport). The classification 
rules for a literal classification use only predefined classification keys (for 
example, ANI = 18881234000). The literal classification is the classification value 
that is assigned to the media item (for example, Classification = GoldSupport).

■ A database procedure classification is a stored procedure. A database procedure 
classification can use predefined classification keys and additional parameters 
to determine the classification. The classification value derived by the database 
procedure is assigned to the media item.

The media classification engine, a component of the Routing server, is used to 
classify inbound media -- whether Oracle Telephony Manager is operating in active 
routing mode or passive routing mode. In active routing mode, Oracle Telephony 
Manager routes inbound media by means of the Routing server. In passive mode 
routing mode, the ACD/PBX system completely handles the routing and queueing 
of inbound media.

Media classifications are used in Oracle Universal Work Queue to determine which 
CRM business application to launch when a media item is delivered to the Oracle 
Universal Work Queue desktop. Media classifications are also used by Oracle 
Interaction Blending to map inbound media to service categories. Finally, in active 
routing mode, media classifications are used by the Routing server to determine 
when to reroute a media item.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

■ Defining a Literal Classification

■ Defining a Database Procedure Classification

■ Associating Media Work with a CRM Business Application
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1.9.2 Defining a Literal Classification

Use this procedure to define a literal media classification.

Prerequisites
■ Install a Routing server. Review Oracle Call Center Applications Setup Guide.

■ Define a Routing server in the interaction center server group. Review Oracle 
Telephony Manager Implementation Guide.

■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 
Universal Work Queue Administrator.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the Call Center Administration responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Classification 
Administration.

The Classification Administration window appears. To scroll through the 
records for all classification definitions, press Page Up or Page Down. To search 
for a specific server group, choose View > Query by Example > Enter to invoke 
the query entry mode. Enter your query and then choose View > Query by 
Example > Run to find the matching server groups.

4. If necessary, choose File > New.

5. In the Classification Definition area, define the classification.

a. Enter a unique name to describe the classification.

b. In the Type field, select Literal.

Note: This procedure applies to media work only.
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c. In the Time Out field, type the number of minutes you want to use as your 
time out period. 

For advanced inbound telephony in active mode, the time out period is the 
maximum length of time that a routed call waits in the Oracle Telephony 
Manager queue for an available agent before being re-routed.

For advanced inbound telephony in passive mode or for email, the Time 
Out field is not used. Nonetheless, the Time Out field is required. In this 
case, Oracle recommends that you enter 1000 in this field.

d. If this classification uses the Oracle Applications database, select 
Application Database. 

e. If this classification does not use the Oracle Applications database, then 
select Non-Application Database, and enter the database driver and URL.

6. On the Classification Rules tab, define the rules for classifications.

a. In the Key field, select a key.

The classification keys provide many types of data that are typically used in 
an interaction center. These values might come directly from the ACD, an 
IVR, or even from a Web callback form.

b. In the Operation field, select an operator.

c. Enter the value for the selected key.

7. From the File menu, choose Save.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

■ Understanding Media Classifications

■ Defining a Database Procedure Classification

■ Associating Media Work with a CRM Business Application
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1.9.3 Defining a Database Procedure Classification

Use this procedure to define a database procedure classification.

Prerequisites
■ Install a Routing server. Review Oracle Call Center Applications Setup Guide.

■ Define a Routing server in the interaction center server group. Review Oracle 
Telephony Manager Implementation Guide.

■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 
Universal Work Queue Administrator.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the Call Center Administration responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose Call Centers > 
Classification Administration.

The Classification Administration window appears. To scroll through the 
records for all classification definitions, press Page Up or Page Down. To search 
for a specific server group, choose View > Query by Example > Enter to invoke 
the query entry mode. Enter your query and then choose View > Query by 
Example > Run to find the matching server groups.

4. If necessary, choose File > New.

5. In the Classification Definition area, define the classification.

a. Enter the name of the database procedure that will determine the 
classification of the media item, for example, GET_CLASSIFICATION_
FROM_SUBJECT.

Note: This procedure applies to media work only.
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b. In the Type field, select Database Procedure.

c. In the Time Out field, type the number of minutes you want to use as your 
time out period. 

For advanced inbound telephony in active mode, the time out period is the 
maximum length of time that a routed call waits in the Oracle Telephony 
Manager queue for an available agent before being re-routed.

For advanced inbound telephony in passive mode or for email, the Time 
Out field is not used. Nonetheless, the Time Out field is required. In this 
case, Oracle recommends that you enter 1000 in this field.

d. If this procedure is stored in the Oracle Applications database, select 
Application Database. 

e. If this procedure is not stored in the Oracle Applications database, then 
select Non-Application Database, and enter the database driver and URL.

6. On the Classification Rules tab, define the rules for classification.

a. In the Key field, select a key.

The classification keys provide many types of data that are typically used in 
an interaction center. These values might come directly from the ACD, an 
IVR, or even from a Web callback form.

b. In the Operation field, select an operator.

c. Enter the value for the selected key.

7. In the Classification Parameters tab, define the parameters for the database 
procedure:

a. In the Parameter field, enter the name of a parameter for the database 
procedure.

b. In the Value field, select a value or enter a custom value for the parameter.

c. In the Data Type field, select the data type of the parameters (for example, 
VARCHAR).

Note: The value entered in the Classification field is not verified 
against the stored procedures. Be sure to enter the correct 
procedure name.
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d. In the Direction field, select the direction of the parameter (for example, 
IN).

The sequence is a generated number that indicates the sequence of the 
parameter.

8. From the File menu, choose Save.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

■ Understanding Media Classifications

■ Defining a Literal Classification

■ Associating Media Work with a CRM Business Application

1.9.4 Associating Media Work with a CRM Business Application

Use this procedure to associate media work with a CRM business application. 
When a media item is delivered to the Oracle Universal Work Queue desktop, a 
CRM business application is launched based on the media type and the media item 
classification.

Prerequisites
■ Define an Oracle Universal Work Queue administrator. See Defining an Oracle 

Universal Work Queue Administrator.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Select or switch to the Universal Work Queue Administration responsibility.

Note: This procedure applies to media work only.
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■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

3. In the Navigator window, on the Functions tab, choose UWQ Administration.

The Media-Action-Classification Association window appears.

4. In the Media Type field, select the type of media (for example, Inbound 
Telephony).

5. In the Classification field, type in the name of the media item classification that 
will trigger the media action (screen pop).

6. In the Media Action field, select the business application that will be launched 
when a media item of the specified type with the specified classification is 
selected from a work queue.

7. From the File menu, choose Save.

See Also
■ Setting Up Oracle Universal Work Queue Server for Media Work

■ Configuring the Oracle Universal Work Queue Desktop for Media Work

■ Understanding Media Classifications

■ Defining a Literal Classification

■ Defining a Database Procedure Classification

1.10 Integrating Oracle Universal Work Queue with Oracle Interaction 
Blending

To enable media work blending for Oracle Universal Work Queue, set the Blending 
Style profile option to Forced Blended. When media work blending is enabled for 
Oracle Universal Work Queue, the Media node is replaced with a Blended node.

Oracle Interaction Blending must be installed and configured. Oracle Interaction 
Blending dynamically moves agents between queues and media types based on the 
service levels for the interaction center. For information about implementing Oracle 
Interaction Blending, see Oracle Interaction Blending Implementation Guide.

Note: This procedure applies to media work only. This procedure 
is only required when implementing Oracle Interaction Blending.
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See Also
■ Understanding Oracle Universal Work Queue Profiles Options

■ Configuring Universal Work Queue System Profile Values

■ Appendix A, "Oracle Universal Work Queue Profile Options".

1.11 Integrating Oracle Universal Work Queue with Oracle Interaction 
Center Intelligence

To record Oracle Universal Work Queue data for Oracle Interaction Center 
Intelligence, set the Oracle Universal Work Queue server database parameter 
ENABLE_SESSION_HISTORY to TRUE. The default is FALSE.

Optionally, when you start the Oracle Universal Work Queue serer, use the enable_
session_history command line parameter turn on data recording. The database 
parameter overrides the command line parameter.

The Oracle Universal Work Queue server records the following information in the 
database:

■ Agent login

■ Agent logout

■ Media item requests

■ Media item deliveries

The additional server activity can affect the performance of the Oracle Universal 
Work Queue server.

Oracle Interaction Center Intelligence must be installed and configured. For 
information about implementing Oracle Interaction Center Intelligence, see Oracle 
Interaction Center Intelligence Implementation Guide.

See Also
■ Defining an Interaction Center Server

■ Appendix B, "Oracle Universal Work Queue Server Parameters"

Note: This procedure applies to media work only. This procedure 
is only required when implementing Oracle Interaction Center 
Intelligence.
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■ Appendix C, "Oracle Universal Work Queue Command Line Parameters"

1.12 Testing the Oracle Universal Work Queue Implementation
Test your implementation of Oracle Universal Work Queue with non-media and 
media work.

Topics include:

■ Testing a Non-Media Oracle Universal Work Queue Implementation

■ Testing a Media Oracle Universal Work Queue Implementation

1.12.1 Testing a Non-Media Oracle Universal Work Queue Implementation
Use this procedure to test your Oracle Universal Work Queue implementation with 
non-media work. Non-media work includes service requests, tasks, enhancements, 
forecasts, leads, and opportunities.

Prerequisites
■ Implement Oracle Universal Work Queue.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Define an agent. See Defining an Oracle Universal Work Queue Agent.

3. Configure the Oracle Universal Work Queue system profile options for the 
agent at the user level. See Configuring Universal Work Queue System Profile 
Values.

The following table lists the Oracle Universal Work Queue profile option values 
to be used for testing Oracle Universal Work Queue with non-media work.

Profile Option Value

IEU: Blending Style Not Blended

IEU: Desktop: Network: Proxy Port Null
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IEU: Desktop: Network: Proxy Server Null

IEU: Desktop: Network: Use Proxy No

IEU: Desktop: UI: Refresh Style Login Only

IEU: Desktop: UI: Show All Nodes Yes

IEU: Media: Email No

IEU: Media: Telephony No

IEU: Non-Media: Navigate No

IEU: Optional: Phone Extension Null

IEU: QResType: MyWork Only User’s Work

IEU: Queue Order: Blended Null

IEU: Queue Order: Forecasts Null

IEU: Queue Order: Inbound Email Null

IEU: Queue Order: Inbound Telephony Null

IEU: Queue Order: Leads Null

IEU: Queue Order: Media Nodes Null

IEU: Queue Order: My Tasks Null

IEU: Queue Order: MyWork Null

IEU: Queue Order: Opportunities Null

IEU: Queue Order: Outbound Telephony Null

IEU: Queue Order: Service Requests Null

IEU: Queue Order: Tasks Null

IEU: Queue Order: Web Collaboration Null

IEU: Queue: Defects No

IEU: Queue: Enhancements Yes

IEU: Queue: Forecasts Yes

IEU: Queue: Inbound Email No

IEU: Queue: Inbound Telephony No

IEU: Queue: Leads Yes

Profile Option Value
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4. Create a non-media work item (service request, task, enhancement, forecast, 
lead, or opportunity) and assign it to the agent that you are using to test the 
Oracle Universal Work Queue implementation.

5. Sign on to Oracle Applications as the Oracle Universal Work Queue agent.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

6. Select or switch to the Customer Support responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

7. In the Navigator window, on the Functions tab, choose Customer Management 
> Universal Work Queue.

IEU: Queue: My Tasks No

IEU: Queue: MyWork Yes

IEU: Queue: Opportunities Yes

IEU: Queue: Outbound Telephony No

IEU: Queue: Service Requests Yes

IEU: Queue: Tasks Yes

IEU: Queue: Web Callback No

IEU: Queue: Web Collaboration No

To create... Review...

A task Oracle CRM Foundation Concepts and Procedures

A service request Oracle Support Concepts and Procedures

An enhancement Oracle Support Concepts and Procedures

An opportunity Oracle TeleSales Concepts and Procedures

A lead Oracle TeleSales Concepts and Procedures

A forecast Oracle TeleSales Concepts and Procedures

Profile Option Value
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The Universal Work Queue window appears.

8. Select a queue with a work item.

9. Click Get Work.

The CRM business application in which the work item was created appears.

1.12.2 Testing a Media Oracle Universal Work Queue Implementation
Use this procedure to test your Oracle Universal Work Queue implementation with 
media work. Media work includes outbound telephony, inbound telephony, 
inbound email, and acquired email.

Prerequisites
■ Implement Oracle Universal Work Queue.

■ Start the interaction center servers. See Oracle Call Center Applications Setup 
Guide.

Steps
1. If necessary, sign on to Oracle Applications as an Oracle Universal Work Queue 

administrator using the PHP URL.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

2. Define an agent. See Defining an Oracle Universal Work Queue Agent.

3. Configure the Oracle Universal Work Queue system profile options for the 
agent at the user level. See Configuring Universal Work Queue System Profile 
Values.

The following table lists the Oracle Universal Work Queue profile option values 
to be used for testing Oracle Universal Work Queue with media work.

Profile Option Value

IEU: Blending Style Not Blended

IEU: Desktop: Network: Proxy Port Null

IEU: Desktop: Network: Proxy Server Null

IEU: Desktop: Network: Use Proxy No
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IEU: Desktop: UI: Refresh Style Login Only

IEU: Desktop: UI: Show All Nodes Yes

IEU: Media: Email No

IEU: Media: Telephony No

IEU: Non-Media: Navigate No

IEU: Optional: Phone Extension Null

IEU: QResType: MyWork Only User’s Work

IEU: Queue Order: Blended Null

IEU: Queue Order: Forecasts Null

IEU: Queue Order: Inbound Email Null

IEU: Queue Order: Inbound Telephony Null

IEU: Queue Order: Leads Null

IEU: Queue Order: Media Nodes Null

IEU: Queue Order: My Tasks Null

IEU: Queue Order: MyWork Null

IEU: Queue Order: Opportunities Null

IEU: Queue Order: Outbound Telephony Null

IEU: Queue Order: Service Requests Null

IEU: Queue Order: Tasks Null

IEU: Queue Order: Web Collaboration Null

IEU: Queue: Defects No

IEU: Queue: Enhancements Yes

IEU: Queue: Forecasts Yes

IEU: Queue: Inbound Email Yes (to test the integration of Oracle Universal 
Work Queue with Oracle eMail Center)

IEU: Queue: Inbound Telephony Yes (to test the integration of Oracle Universal 
Work Queue with Oracle Advanced Inbound)

IEU: Queue: Leads Yes

IEU: Queue: My Tasks No

Profile Option Value
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4. Generate a media work item (an inbound call, an outbound call, or an email) for 
the agent that you are using to test the Oracle Universal Work Queue 
implementation.

5. Sign on to Oracle Applications as the Oracle Universal Work Queue agent.

If you are signing on to Oracle Applications with this username for the first 
time, the message "Your password has expired" appears and you are prompted 
to set a new password.

6. Select or switch to the Customer Support responsibility.

■ In the Forms interface, to switch to a different responsibility, choose Switch 
Responsibility, from the File menu.

7. In the Navigator window, on the Functions tab, choose Universal Work Queue.

The Universal Work Queue window appears. Depending on the type of media 
queues enabled, one or more additional windows appear.

If the telephony queues are enabled, then the Phone Extension window 
appears. 

8. In the Phone Extension window, enter the phone extension of the agent.

If the email queue is enabled, then the Oracle eBusiness Suite sign on window 
appears.

9. In the Oracle eBusiness Suite window, sign on to Oracle eMail Center.

10. In the Oracle Universal Work Queue window, select a media queue with a work 
item.

IEU: Queue: MyWork No

IEU: Queue: Opportunities Yes

IEU: Queue: Outbound Telephony Yes (to test the integration of Oracle Universal 
Work Queue with Oracle Advanced Outbound)

IEU: Queue: Service Requests Yes

IEU: Queue: Tasks Yes

IEU: Queue: Web Callback No

IEU: Queue: Web Collaboration No

Profile Option Value
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11. Click Get Work.

The CRM business application associated with the media work item appears. If 
the media work item is telephony, then the SoftPhone also appears. If the media 
work item is email, then Oracle eMail Center appears with the email in preview 
mode.

1.13 Understanding the Oracle Universal Work Queue Window
Agents use the Oracle Universal Work Queue window to view or work on assigned 
work items. The Oracle Universal Work Queue window has two main panes. 

The left pane lists the work queues enabled for the agent and the count, or number, 
of work items in each queue. Counts are refreshed based on the refresh strategy 
specified in the Refresh Style profile option for the user. The right pane displays the 
details of the work items in a selected queue.
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While in the Oracle Universal Work Queue window, you can perform the following 
tasks:

Manually refresh work counts. To refresh work counts, from the Tools menu, 
choose Refresh.

Display work item details. To display work item details, select a queue. The work 
items are listed in the right pane.

Sort work items displayed in the details view. To sort work items, double-click a 
column heading.
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Rearrange columns in the details view. To rearrange columns, drag and drop the 
column heading in a new location.

Start a customer interaction for a work item. To launch the business application 
(non-media) or start a customer interaction (media), select a queue or select an 
item in the details view, and then click Get Work.

1.14 Troubleshooting Oracle Universal Work Queue
Topics include:

■ Using Oracle Universal Work Queue Server Logs

■ Common Implementation Errors

■ Modifying the Name of Oracle Universal Work Queue Server

■ Modifying Database Connection Parameters for Oracle Universal Work Queue 
Server

1.14.1 Using Oracle Universal Work Queue Server Logs
Oracle Universal Work Queue server trace function outputs detailed information 
about server activity to a console window or a file. By default, the trace function is 
off.

To turn on the trace function, set the appropriate Oracle Universal Work Queue 
server database parameters. Optionally, when you start the Oracle Universal Work 
Queue server, use the appropriate command line parameters. The database 
parameter overrides the command line parameter.

The following command line options set the trace level for the Oracle Universal 
Work Queue server.

The Oracle Universal Work Queue server does not support enabling or changing 
trace levels at runtime. You must stop and restart the server for changes take place.

Trace Level Description

trace_level_error Server errors.

trace_level_warn Server warnings and errors.

trace_level_info Server events, warning, and errors.

trace_level_debug All server activity.
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See Also
■ Appendix B, "Oracle Universal Work Queue Server Parameters"

■ Appendix C, "Oracle Universal Work Queue Command Line Parameters"

■ Common Implementation Errors

■ Modifying the Name of Oracle Universal Work Queue Server

■ Modifying Database Connection Parameters for Oracle Universal Work Queue 
Server

1.14.2 Common Implementation Errors

1.14.2.1 Signing On to Oracle Applications

User can not sign on to Oracle Applications
Indication: User can not log into Oracle Applications.

Problem: Database is down.

Solution: Contact the system DBA to ensure that the database is restarted.

No valid responsibility is available
Indication: The user attempts to log in to Oracle Applications and an error message 
displays which indicates that no valid responsibility is available. Or, the user is able 
to Log on to UWQ but receives an error message when trying to access a particular 
work item. Note: This problem can occur because you intentionally set the user 
profiles so that they could not access certain types of tasks.

Problem: User profile/responsibilities are incorrectly set.

Solution: The HRMS employee must be assigned as a resource for your business. 
The user must have responsibility to access all the forms that UWQ will open, or 
Forms will not allow the application to open. 

1.14.2.2 Launching the Oracle Universal Work Queue desktop from the Navigator

Agent Resource ID not found
Indication: The user logs in to Oracle Applications and selects to work with UWQ, 
an error message displays which indicates that the Resource ID for the agent could 
not be found.
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Problem: The employee has not been defined as a CRM resource.

Solution: Ensure that the UWQ user has been correctly set up in Oracle HRMS and 
in Resource Manager. 

Oracle Universal Work Queue desktop does not display
Indication: The user logs in to Oracle Applications and selects the Get Work button, 
the business application GUI or the UWQ GUI does not launch. 

Problem: Oracle business applications GUI or UWQ GUI is not displayed. 

Solution: Test to see if the business application can launch or if the problem lies with 
the launching of UWQ. Follow the related debugging steps in the section of this 
lesson on diagnostic tools for troubleshooting.

Take too long to launch the Oracle Universal Work Queue desktop
Indication: Your UWQ users experience a delay time before the Universal Work 
Queue window completely displays with entries in the Queue and Count columns.

Problem: Takes too long to log on to UWQ.

Solution: When using the “Login Only” value for the User Profile Option of IEU: 
Desktop: UI: Refresh Style, UWQ performs a count refresh the when the user first 
logs on to UWQ, the refresh operation takes some time. Ensure that you are using 
the appropriate refresh strategy for your business.

1.14.2.3 Viewing Work Items

No work items displayed in Oracle Universal Work Queue detail pane
Indication: When user selects My Work or selects to work on specific work item 
types in the Queue column, work items do not display in the detail screen.

Problem: Work items fail to reach UWQ.

Solution: Ensure that work items are open and are assigned to the user. Also ensure 
that the user has performed a manual refresh of work items.

Missing source document
Indication: The user selects to view a Task work item in UWQ, and receives a 
missing source document error message.

Problem: Missing source document when accessing tasks.
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Solution: This is almost always a problem with the “creation point” for the 
document, the business application that was used to create the source document 
such as a service request created from Oracle TeleService.

Work items displayed twice in detail pane
Indication: When user selects My Work or selects to work on specific work item 
types in the Queue column, double work items display in the detail screen. Note: 
UWQ displays work items for tasks that are owned or assigned to a user. 

Problem: User sees double work item entries.

Solution: This can occur when a task is both owned and assigned to the same user. 
This frequently occurs when a task is owned by a particular user and is assigned to 
be work by a group or users, of which the particular user is a member.

Count values not displayed or refreshed
Indication: The user logs on to UWQ and does not see count values displayed in the 
Count column. Or, the user has completed processing work items and the Count 
column does not reflect new count values. Or, 

Problem: Count values do not display in the Count column or counts do not update 
once work items are processed.

Solution: Ensure that you are using the appropriate refresh strategy for your 
business operations and that your users are aware of the procedures that they must 
follow to refresh their work item counts, if you are not using an “automatic” refresh 
strategy.

1.14.2.4 Accessing Work Items

No valid responsibility is available
Indication: The user attempts to log in to Oracle Applications and an error message 
displays which indicates that no valid responsibility is available. Or, the user is able 
to Log on to UWQ but receives an error message when trying to access a particular 
work item. Note: This problem can occur because you intentionally set the user 
profiles so that they could not access certain types of tasks.

Problem: User profile/responsibilities are incorrectly set.

Solution: The HRMS employee must be assigned as a resource for your business. 
The user must have responsibility to access all the forms that UWQ will open, or 
Forms will not allow the application to open. 
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Oracle Universal Work Queue desktop cannot "Get Work"
Indication: The user can view a Task work item in UWQ, but receives the message 
that he cannot do “Get Work” for the open Task work item.

Problem: User can not do “Get Work” for an open task work item.

Solution: Tasks is a multi-object schema which can store tasks and other objects like 
Service Requests and so on. From the Tasks detailed panel, click Details to display 
the Task Manager screen. Then ensure that there is a valid value in the Source 
Document field and the Source Number field. Note: When no valid source 
document is referenced, the Task Manager screen will display by default.

See Also
■ Using Oracle Universal Work Queue Server Logs

■ Modifying the Name of Oracle Universal Work Queue Server

■ Modifying Database Connection Parameters for Oracle Universal Work Queue 
Server

1.14.3 Modifying the Name of Oracle Universal Work Queue Server
Use this procedure to modify the name of Oracle Universal Work Queue Server 
after it has been installed.

Prerequisites
■ Install the Oracle Universal Work Queue server. See Oracle Call Center 

Applications Setup Guide.

Steps
1. On the machine on which Oracle Universal Work Queue Server is installed, go 

to PRODUCT_COMM\admin\scripts\cct.

2. Open ieusvr.bat using an ASCII editor (such as Notepad).

3. Modify the server name.

Note: The ieusvr.bat file is used to start Oracle Universal Work 
Queue Server.
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4. Save ieusvr.bat.

See Also
■ Using Oracle Universal Work Queue Server Logs

■ Common Implementation Errors

■ Modifying Database Connection Parameters for Oracle Universal Work Queue 
Server

1.14.4 Modifying Database Connection Parameters for Oracle Universal Work Queue 
Server

Use this procedure to modify the database connection parameters for Oracle 
Universal Work Queue server after it has been installed.

Prerequisites
■ Install the Oracle Universal Work Queue server. See Oracle Call Center 

Applications Setup Guide.

Steps
1. On the machine on which Oracle Universal Work Queue Server is installed, go 

to PRODUCT_COMM\admin\scripts\cct.

2. Open cct.dbc using an ASCII editor (such as Notepad).

3. Modify the database connection parameters.

4. Save cct.dbc.

Note: This name should be used when configuring the parameters 
for Oracle Universal Work Queue Server. See Defining an 
Interaction Center Server.

Note: If you are using multiple machines to host interaction center 
servers, be sure to manually modify the database connection 
parameters on all interaction center server machines.
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Documentation Resources
Guidelines
The following table lists the database parameters fields available during installation 
of the interaction center servers and their corresponding parameters in the cct.dbc 
file.

The following is an example of a cct.dbc file:

#DB Settings
#Thu Aug 19 18:47:53 PDT 1999
#APPL_SERVER_ID=
TWO_TASK=tst115
FNDNAM=apps
GWYUID=applsyspub/pub
FND_MAX_JDBC_CONNECTIONS=20
GUEST_USER_PWD=admin/welcome
APPS_JDBC_DRIVER_TYPE=THIN
DB_HOST=ap100sun
DB_PORT=1521

See Also
■ Using Oracle Universal Work Queue Server Logs

■ Common Implementation Errors

■ Modifying the Name of Oracle Universal Work Queue Server

1.15 Documentation Resources
The following related documentation is available on MetaLink.

Read the following documents to understand Oracle Applications:

Installation Field CCT.DBC Parameter Description/Default

TWO_TASK TWO_TASK Database name

FNDNAM FNDNAM apps

GWYUID GWYUID gateway user id/password

Database Host DB_HOST Database host name

Database Port DB_PORT Database port number

Application User Password GUEST_USER_PWD application userid/password
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Documentation Resources
■ Oracle Applications Concepts

■ Oracle Applications Product Update Notes

Read the following documents to install, upgrade, or maintain Oracle Applications 
Release 11i:

■ Installing Oracle Applications

■ Upgrading Oracle Applications

■ Upgrading Timing Spreadsheet

■ Maintaining Oracle Applications

Read the following documents to implement and use Oracle Human Resource 
Management Systems:

■ Implementing Oracle HRMS

■ Managing People Using Oracle HRMS

Read the following document to implement Oracle CRM:

■ Implementing Oracle CRM: ERP Functional Checklist

■ Implementing Oracle CRM: Foundation Functional Checklist

■ Supplemental CRM Installation Steps

Read the following documents to implement the CRM business applications that 
integrate with Oracle Universal Work Queue:

■ Oracle CRM Foundation Implementation Guide

■ Oracle Support Implementation Guide

■ Oracle TeleSales Implementation Guide

Read the following documents to use or administer the CRM business applications 
that integrate with Oracle Universal Work Queue:

■ Oracle CRM Foundation Concepts and Procedures

■ Oracle Support Concepts and Procedures

■ Oracle TeleSales Concepts and Procedures

Read the following documents to install the Oracle Interaction Center server 
processes:

■ Installing Oracle Call Center Connectors
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Documentation Resources
■ Oracle Call Center Applications Setup Guide

■ Installing Oracle Campaign Plus

■ Installing Oracle IVR Integrator

■ Installing Oracle Predictive

Read the following documents to implement Oracle interaction Center products:

■ Oracle Call Center Connectors Implementation Guide

■ Oracle Telephony Manager Implementation Guide

■ Oracle IVR Integrator Implementation Guide

■ Oracle eMail Center Implementation Guide

■ Oracle Campaign Plus and Predictive Implementation Guide

■ Oracle Interaction Blending Implementation Guide

■ Oracle Scripting Implementation Guide

Read the following documents to use or administer Oracle interaction Center 
products:

■ Oracle Call Center Connectors Concepts and Procedures

■ Oracle Telephony Manager Concepts and Procedures

■ Oracle IVR Integrator Concepts and Procedures

■ Oracle eMail Center Concepts and Procedures

■ Oracle Campaign Plus Concepts and Procedures 

■ Oracle Predictive Concepts and Procedures

■ Oracle Interaction Blending Concepts and Procedures

■ Oracle Scripting Concepts and Procedures
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Oracle Universal Work Queue Profile Op
A

Oracle Universal Work Queue Profile

Options

This topic describes all of the profile options for Oracle Universal Work Queue. The 
profile option description includes the following information:

■ Required: Indicated whether the profile option must be set.

■ Personal Profile Values: Whether a user can view or update the profile option. 
Application users may use the Personal Profile Values window to set their own 
personal profile options at the user level. Not all profile options are visible to 
users, and some profile options, while visible, may not be updated by end 
users.

■ System Profile Values: The levels at which a particular profile option can be set. 
Oracle Universal Work Queue administrators can set profile options at the site, 
application, responsibility, and user levels. Not all profile options have settings 
at all levels.

■ Settings: Available values, a description of the value, and any usage 
considerations.

■ Default Value: The setting for a profile option can be determine by an actual 
value or, if no value has been set, by default. Oracle Applications establishes a 
value for each option in a user’s profile when the user logs on or changes 
responsibility. Depending on the how the profile option is used in the 
application, the default may be an actual predefined value or it may be 
determined dynamically at runtime.
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IEU: Blending Style
A.1 IEU: Blending Style

Use this profile option to enable media work blending for Oracle Universal Work 
Queue. When media work blending is enabled for Oracle Universal Work Queue, 
the Media node is replaced with a Blended node.

Oracle Interaction Blending must be installed and configured. Oracle Interaction 
Blending dynamically moves agents between queues and media types based on the 
service levels for the interaction center. For information about implementing Oracle 
Interaction Blending, see Oracle Interaction Blending Implementation Guide.

Required
No

Personal Profile Values

System Profile Values

Settings

Note: This profile option applies to media work only.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

Force Blended Media work blending is enabled. The media node in the Oracle 
Universal Work Queue is labeled "Blended."

Not Blended Media work blending is not enabled. The media node in the Oracle 
Universal Work Queue is labeled "Media."
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IEU: Desktop: Network: Proxy Port
Default Value
Not Blended

A.2 IEU: Desktop: Network: Proxy Port

The Oracle Universal Work Queue desktop bean communicates with the Oracle 
Universal Work Queue server over a proprietary interface that supports HTTP or 
Sockets. If there is no firewall between the Oracle Universal Work Queue desktop 
and the Oracle Universal Work Queue server, then the proxy settings can be 
obtained from the Oracle Universal Work Queue server. If there is a firewall 
between the Oracle Universal Work Queue desktop and the Oracle Universal Work 
Queue server, then you must specify the proxy settings.

Use this profile option to specify the proxy port.

Required
No

Personal Profile Values

System Profile Values

Settings
Consult your network administrator for the appropriate proxy settings.

Note: This profile option applies to media work only.

View? Yes

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Desktop: Network: Proxy Server
Default Value
Not applicable.

A.3 IEU: Desktop: Network: Proxy Server

The Oracle Universal Work Queue desktop bean communicates with the Oracle 
Universal Work Queue server over a proprietary interface that supports HTTP or 
Sockets. If there is no firewall between the Oracle Universal Work Queue desktop 
and the Oracle Universal Work Queue server, then the proxy settings can be 
obtained from the Oracle Universal Work Queue server. If there is a firewall 
between the Oracle Universal Work Queue desktop and the Oracle Universal Work 
Queue server, then you must specify the proxy settings.

Use this profile option to specify the proxy port.

Required
No

Personal Profile Values

System Profile Values

Settings
Consult your network administrator for the appropriate proxy settings.

Note: This profile option applies to media work only.

View? Yes

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
A-4 Oracle Universal Work Queue Implementation Guide



IEU: Desktop: Network: Use Proxy
Default Value
Not applicable.

A.4 IEU: Desktop: Network: Use Proxy

The Oracle Universal Work Queue desktop bean communicates with the Oracle 
Universal Work Queue server over a proprietary interface that supports HTTP or 
Sockets. If there is no firewall between the Oracle Universal Work Queue desktop 
and the Oracle Universal Work Queue server, then the proxy settings can be 
obtained from the Oracle Universal Work Queue server. If there is a firewall 
between the Oracle Universal Work Queue desktop and the Oracle Universal Work 
Queue server, then you must specify the proxy settings.

Use this profile option to indicate whether the proxy settings for the Oracle 
Universal Work Queue server will be determined from the server or specified in the 
Oracle Universal Work Queue system profile options.

Required
No

Personal Profile Values

System Profile Values

Note: This profile option applies to media work only.

View? Yes

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Desktop: UI: Refresh Style
Settings

Default Value
No

A.5 IEU: Desktop: UI: Refresh Style

Use this profile option to specify the strategy for refreshing work item counts in the 
Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

No The proxy settings for the Oracle Universal Work Queue server will 
be determined from the server.

Yes The proxy settings for the Oracle Universal Work Queue server are 
specified in the Oracle Universal Work Queue system profile options.

Note: This profile option applies to non-media and media work.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Desktop: UI: Show All Nodes
Settings

Default Value
Manual

A.6 IEU: Desktop: UI: Show All Nodes

Use this profile option to display subnodes that have a zero count in t he Oracle 
Universal Work Queue desktop.

Required
No

Personal Profile Values

Automatic The Oracle Universal Work Queue desktop refreshes:

■ upon login to the Oracle Universal Work Queue desktop

■ after each delivery of media work

Automatic refresh may affect the performance of the Oracle 
Universal Work Queue server. After delivery of the work item, the 
Oracle Universal Work Queue desktop can not be used until the 
count is updated.

Login Only The Oracle Universal Work Queue desktop is refreshed once upon 
login. After login, the Oracle Universal Work Queue desktop 
must be refreshed manually.

Manual The user must manually refresh the Oracle Universal Work Queue 
desktop. The Oracle Universal Work Queue desktop is not 
automatically refreshed upon login.

Note: This profile option applies to non-media and media work.

View? No

Update? No
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IEU: Media: Email
System Profile Values

Settings

Default Value
Yes

A.7 IEU: Media: Email

Use this profile option to force the Oracle eMail Center desktop to launch upon 
login to Oracle Universal Work Queue -- even when the Inbound Email node is not 
enabled.

Required
No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No Subnodes with a zero count are not shown in the Oracle Universal 
Work Queue desktop. Main nodes with a zero count continue to be 
displayed.

Yes Subnodes with a zero count are shown in the Oracle Universal Work 
Queue desktop.

Warning: Leave this profile option null or set to No unless 
instructed to do otherwise by Oracle Support or Oracle 
Consulting.

Note: This profile option applies to media work only.
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IEU: Media: Email
Personal Profile Values

System Profile Values

Settings

Default Value
No

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Oracle eMail Center desktop does not launch until an email 
work item is selected from the Oracle Universal Work Queue 
desktop.

Yes The Oracle eMail Center desktop automatically launched upon login 
to Oracle Universal Work Queue -- even when Inbound Email is not 
enabled.
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IEU: Media: Telephony
A.8 IEU: Media: Telephony

Use this profile option to force the Oracle SoftPhone to launch upon login to Oracle 
Universal Work Queue -- even when Outbound Telephony node is not enabled.

Required
No

Personal Profile Values

System Profile Values

Settings

Warning: Leave this profile option null or set to No unless 
instructed to do otherwise by Oracle Support or Oracle 
Consulting.

Note: This profile option applies to media work only.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Oracle Softphone does not launch until an outbound telephony 
work item is selected from the Oracle Universal Work Queue 
desktop.

Yes The Oracle Softphone is automatically launched upon login to Oracle 
Universal Work Queue -- even when Outbound Telephony is not 
enabled.
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IEU: Non-Media: Navigate
Default Value
No

A.9 IEU: Non-Media: Navigate

Use this profile option to open a separate application window for each non-media 
work item selected from the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Settings

Note: This profile option applies to non-media work only.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No When a non-media work item is selected from the Oracle Universal 
Work Queue desktop, Oracle Universal Work Queue refreshes the 
currently open application window.

Yes When a non-media work item is selected from the Oracle Universal 
Work Queue desktop, Oracle Universal Work Queue opens a new 
application window.
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IEU: Optional: Phone Extension
Default Value
No

A.10 IEU: Optional: Phone Extension

Use this profile option to specify the extension of the physical phone of the agent. 
For an agent enabled for telephony, Oracle Universal Work Queue bypasses the 
Phone Extension window upon login and passes the value of this profile option 
value to Oracle Telephony Manager.

Required
No

Personal Profile Values

System Profile Values

Settings
The extension of the physical phone of the agent.

Default Value
Not applicable

Note: This profile option applies to non-media and media work.

View? No

Update? No

Site? No

Application? No

Responsibility? No

User? Yes
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IEU: QResType: MyWork
A.11 IEU: QResType: MyWork

Use this profile option to select the resource type that the MyWork queue will 
display.

Required
No

Personal Profile Values

System Profile Values

Settings

Note: This profile option applies to non-media work only.

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

All Work Displays work items assigned to the agent, the agent’s team, and 
the agent’s group.

Only User’s Work Displays work items assigned to the agent. Team and group work 
is not displayed.

User’s Team’s Work Displays work items assigned to any teams to which the agent 
belongs.

User’s Group’s Work Displays work items assigned to any groups to which the agent 
belongs.
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IEU: Queue Order: Blended
Default Value
All Work

A.12 IEU: Queue Order: Blended

Use this profile option to specify the order of the Blended node in the list of nodes 
on the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Note: For the best performance, select Only User’s Work. This 
setting produced the most efficient query.

All Work is the default in order to be compatible with previous 
releases.

Note: The Blended node is displayed only if the Blending Style 
profile option value is Forced Blended.

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Queue Order: Inbound Email
Default Value
Not applicable

A.13 IEU: Queue Order: Forecasts
Use this profile option to specify the order of the Forecasts node in the list of nodes 
on the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.14 IEU: Queue Order: Inbound Email
Use this profile option to specify the order of the Inbound Email node in the list of 
nodes on the Oracle Universal Work Queue desktop.

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Queue Order: Inbound Telephony
Required
No

Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.15 IEU: Queue Order: Inbound Telephony
Use this profile option to specify the order of the Inbound Telephony node in the 
list of nodes on the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

View? Yes

Update? Yes
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IEU: Queue Order: Leads
System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.16 IEU: Queue Order: Leads
Use this profile option to specify the order of the Leads node in the list of nodes on 
the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Queue Order: Media Nodes
Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.17 IEU: Queue Order: Media Nodes
Use this profile option to specify the order of the Media node in the list of nodes on 
the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Queue Order: MyWork
A.18 IEU: Queue Order: My Tasks
Use this profile option to specify the order of the My Tasks node in the list of nodes 
on the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.19 IEU: Queue Order: MyWork
Use this profile option to specify the order of the MyWork node in the list of nodes 
on the Oracle Universal Work Queue desktop.

Required
No

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Queue Order: Opportunities
Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.20 IEU: Queue Order: Opportunities
Use this profile option to specify the order of the Opportunities node in the list of 
nodes on the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

View? Yes

Update? Yes
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IEU: Queue Order: Outbound Telephony
System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.21 IEU: Queue Order: Outbound Telephony
Use this profile option to specify the order of the Outbound Telephony node in the 
list of nodes on the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Queue Order: Service Requests
Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.22 IEU: Queue Order: Service Requests
Use this profile option to specify the order of the Service Requests node in the list of 
nodes on the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
A-22 Oracle Universal Work Queue Implementation Guide



IEU: Queue Order: Web Collaboration
A.23 IEU: Queue Order: Tasks
Use this profile option to specify the order of the Tasks node in the list of nodes on 
the Oracle Universal Work Queue desktop.

Required
No

Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.24 IEU: Queue Order: Web Collaboration
Use this profile option to specify the order of the Web Collaboration node in the list 
of nodes on the Oracle Universal Work Queue desktop.

Required
No

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes
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IEU: Queue: Defects
Personal Profile Values

System Profile Values

Settings
Choose from numbers 1 through 26. Nodes are displayed in ascending order in the 
Oracle Universal Work Queue desktop.

Default Value
Not applicable

A.25 IEU: Queue: Defects
This profile option is reserved for future use.

A.26 IEU: Queue: Enhancements

Use this profile option to display the Enhancements node in the Oracle Universal 
Work Queue desktop. Enhancements are created in Oracle Support.

Required
No

View? Yes

Update? Yes

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

Note: This profile option applies to non-media work only.
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IEU: Queue: Forecasts
Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.27 IEU: Queue: Forecasts

Use this profile option to display the Forecasts node in the Oracle Universal Work 
Queue desktop. Enhancements are created in Oracle TeleSales.

Required
No

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Enhancements node is not displayed in the Oracle Universal 
Work Queue desktop.

Yes The Enhancements node is displayed in the Oracle Universal Work 
Queue desktop. If the user is configured as a Oracle Universal Work 
Queue agent and has the appropriate responsibilities, then the user 
will be able to access work from the Enhancements node.

Note: This profile option applies to non-media work only.
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IEU: Queue: Inbound Email
Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.28 IEU: Queue: Inbound Email

Use this profile option to display the Inbound Email node in the Oracle Universal 
Work Queue desktop. Inbound email is created when email is sent to the user’s 
email account.

Required
No

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Forecasts node is not displayed in the Oracle Universal Work 
Queue desktop.

Yes The Forecasts node is displayed in the Oracle Universal Work Queue 
desktop. If the user is configured as a Oracle Universal Work Queue 
agent and has the appropriate responsibilities, then the user will be 
able to access work from the Forecasts node.

Note: This profile option applies to media work only.
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IEU: Queue: Inbound Telephony
Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.29 IEU: Queue: Inbound Telephony

Use this profile option to display the Inbound Telephony node in the Oracle 
Universal Work Queue desktop. Inbound telephony work is created when Oracle 
Telephony Manager routes an inbound call to an agent.

Required
No

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Inbound Email node is not displayed in the Oracle Universal 
Work Queue desktop.

Yes The Inbound Email node is displayed in the Oracle Universal Work 
Queue desktop. If the user is configured as a Oracle Universal Work 
Queue agent and has the appropriate responsibilities, then the user 
will be able to access work from the Inbound Email node.

Note: This profile option applies to media work only.
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IEU: Queue: Leads
Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.30 IEU: Queue: Leads

Use this profile option to display the Leads node in the Oracle Universal Work 
Queue desktop. Leads are created in Oracle TeleSales.

Required
No

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Inbound Telephony node is not displayed in the Oracle 
Universal Work Queue desktop.

Yes The Inbound Telephony node is displayed in the Oracle Universal 
Work Queue desktop. If the user is configured as a Oracle Universal 
Work Queue agent and has the appropriate responsibilities, then the 
user will be able to access work from the Inbound Telephony node.

Note: This profile option applies to non-media work only.
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IEU: Queue: My Tasks
Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.31 IEU: Queue: My Tasks

Use this profile option to display the My Tasks node in the Oracle Universal Work 
Queue desktop. Tasks are created in Oracle CRM Foundation. The My Tasks queue 
contains the tasks owned by the agent. This is a smaller query than Tasks.

My Tasks and Tasks should not be displayed at the same time. This will cause 
duplicates to appear.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Leads node is not displayed in the Oracle Universal Work Queue 
desktop.

Yes The Leads node is displayed in the Oracle Universal Work Queue 
desktop. If the user is configured as a Oracle Universal Work Queue 
agent and has the appropriate responsibilities, then the user will be 
able to access work from the Leads node.

Note: This profile option applies to non-media work only.
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IEU: Queue: MyWork
Required
No

Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.32 IEU: Queue: MyWork

Use this profile option to display the MyWork node in the Oracle Universal Work 
Queue desktop. The MyWork queue contains all work owned by the agent.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The My Tasks node is not displayed in the Oracle Universal Work 
Queue desktop.

Yes The My Tasks node is displayed in the Oracle Universal Work Queue 
desktop. If the user is configured as a Oracle Universal Work Queue 
agent and has the appropriate responsibilities, then the user will be 
able to access work from the My Tasks node.

Note: This profile option applies to non-media work only.
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IEU: Queue: Opportunities
Required
No

Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.33 IEU: Queue: Opportunities

Use this profile option to display the Opportunities node in the Oracle Universal 
Work Queue desktop. Opportunities are created in Oracle TeleSales.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The MyWork node is not displayed in the Oracle Universal Work 
Queue desktop.

Yes The MyWork node is displayed in the Oracle Universal Work Queue 
desktop. If the user is configured as a Oracle Universal Work Queue 
agent and has the appropriate responsibilities, then the user will be 
able to access work from the MyWork node.

Note: This profile option applies to non-media work only.
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IEU: Queue: Outbound Telephony
Required
No

Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.34 IEU: Queue: Outbound Telephony

Use this profile option to display the Outbound Telephony node in the Oracle 
Universal Work Queue desktop. Outbound telephony work is created when Oracle 

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Opportunities node is not displayed in the Oracle Universal 
Work Queue desktop.

Yes The Opportunities node is displayed in the Oracle Universal Work 
Queue desktop. If the user is configured as a Oracle Universal Work 
Queue agent and has the appropriate responsibilities, then the user 
will be able to access work from the Enhancement node.

Note: This profile option applies to media work only.
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IEU: Queue: Outbound Telephony
Advanced Outbound (Oracle Campaign Plus and Predictive) assigns an outbound 
call to an agent.

Required
No

Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Outbound Telephony node is not displayed in the Oracle 
Universal Work Queue desktop.

Yes The Outbound Telephony node is displayed in the Oracle Universal 
Work Queue desktop. If the user is configured as a Oracle Universal 
Work Queue agent and has the appropriate responsibilities, then the 
user will be able to access work from the Outbound Telephony node.
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IEU: Queue: Service Requests
A.35 IEU: Queue: Service Requests

Use this profile option to display the Service Requests node in the Oracle Universal 
Work Queue desktop. Service requests are created in Oracle Support.

Required
No

Personal Profile Values

System Profile Values

Settings

Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

Note: This profile option applies to non-media work only.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Service Requests node is not displayed in the Oracle Universal 
Work Queue desktop.

Yes The Service Requests node is displayed in the Oracle Universal Work 
Queue desktop. If the user is configured as a Oracle Universal Work 
Queue agent and has the appropriate responsibilities, then the user 
will be able to access work from the Enhancement node.
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IEU: Queue: Tasks
A.36 IEU: Queue: Tasks

Use this profile option to display the Tasks node in the Oracle Universal Work 
Queue desktop. Tasks are created in Oracle CRM Foundation. The Tasks queue 
contains tasks owned by or assigned to the agent, or to a team or group to which 
the agent belongs. This is a larger query than MyTasks.

My Tasks and Tasks should not be displayed at the same time. This will cause 
duplicates to appear.

Required
No

Personal Profile Values

System Profile Values

Settings

Note: This profile option applies to non-media work only.

View? No

Update? No

Site? Yes

Application? Yes

Responsibility? Yes

User? Yes

No The Tasks node is not displayed in the Oracle Universal Work Queue 
desktop.

Yes The Tasks node is displayed in the Oracle Universal Work Queue 
desktop. If the user is configured as a Oracle Universal Work Queue 
agent and has the appropriate responsibilities, then the user will be 
able to access work from the Tasks node.
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IEU: Queue: Web Callback
Default Value
Yes, if the application user responsibilities and CRM resource configuration for the 
agent provide access to the work item and/or business application.

A.37 IEU: Queue: Web Callback
This profile option is reserved for future use.

A.38 IEU: Queue: Web Collaboration
This profile option is reserved for future use.
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Oracle Universal Work Queue Server Param
B

Oracle Universal Work Queue Server

Parameters

The following table lists and defines the parameter names for which values can be 
set for Oracle Universal Work Queue servers. The following Oracle Universal Work 
Queue server parameters are loaded from the database. Database parameters 
override any command line parameters passed to the Oracle Universal Work Queue 
server. These parameters are strings when stored in the database.

B.1 TRACE_LEVEL
The Trace level for writing traces to the Server Trace file

■ LEVEL_ERROR = 0x0001;

■ LEVEL_WARN = 0x0003;

■ LEVEL_INFO = 0x0007;

■ LEVEL_TRACE = 0x000F;

■ LEVEL_ALL   = 0xFFFF;

B.2 TRACE_FILE_NAME
Name of the UWQ Server Trace File

Type Unit Max Value Min Value Default

int N/A 0xFFFF 0 0
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TRACE_FILE_PATH
B.3 TRACE_FILE_PATH
Path of the UWQ Server Trace File

B.4 LNA_SPILLOVER_FILE
Name of the Logging and Alerting spillover file. The file generated by Logging And 
Alerting subsystem when the database connection goes down.

B.5 ENABLE_LOGGING_AND_ALERTING
Enables / Disables the logging and alerting subsystem.

B.6 TIMEOUT_WAIT_TIME
Time after which retries are done in server threads. This applies to all server threads 
including reconnection threads.

Type Unit Max Value Min Value Default

String N/A N/A N/A UWQServer_
logs

Type Unit Max Value Min Value Default

String N/A N/A N/A "."

Type Unit Max Value Min Value Default

String N/A N/A N/A spillover/uwq
spillover

Type Unit Max Value Min Value Default

boolean N/A N/A N/A false

Type Unit Max Value Min Value Default

int seconds 65,536 0 10
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USE_AOLJ
B.7 MAX_TIMEOUT_DURATION
The time after which a transaction times out in the UWQ Server. This is used mainly 
for timing out remote transactions within the UWQ Server. This time out affects any 
remote transactions done from the client

B.8 MCM_TIMEOUT_DURATION
Time after which OTM/MCM transactions time out.

Note: If the MCM_TIMEOUT_DURATION value is left unset, the default value is 
the value assigned to the MAX_TIMEOUT_DURATION parameter.

B.9 ENABLE_INTERACTION_BLENDING
Deprecated (This is set and used based on data found in the database.)

B.10 MAX_ACTIVE_DB_CONNECTIONS
Deprecated (this is set in the DBC file)

B.11 USE_AOLJ
Indicates if AOL/J is to be used to connect to the database or the connection has to 
be obtained using regular JDBC.

Type Unit Max Value Min Value Default

int seconds 65,536 0 40

Type Unit Max Value Min Value Default

int seconds 65,536 0

Type Unit Max Value Min Value Default

boolean N/A N/A N/A false

Type Unit Max Value Min Value Default

int N/A 65,536 0 3
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SESSION_TIMEOUT
B.12 SESSION_TIMEOUT
Default Session inactivity timeout period (in minutes). This may be overridden 
during client-side session creation.

B.13 SESSION_CLOSE_DELAY
Time period (in seconds) to delay session removal after a session has been 
Disconnected due to Client or Network failures. This prevents sessions from having 
to be completely reconstructed due to a brief network outage.

B.14 NETWORK_TRACE_LEVEL
Trace level for the network logs

■ NONE        = 0x000; Turns off all events

■ DETAIL     = 0x001; Detailed transactions useful for performance monitor

■ INFO          = 0x002; Informational e.g., network connection regained

■ MINOR      = 0x004; Limited failures e.g., method call failed

■ CRITICAL = 0x008; Catastrophic failure e.g., lost network connection

Type Unit Max Value Min Value Default

boolean N/A N/A N/A true

Type Unit Max Value Min Value Default

int minutes 65,536 0 1

Type Unit Max Value Min Value Default

int seconds 65,536 0 180

Type Unit Max Value Min Value Default

int N/A 0xFFF 0 0
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SERVER_PORT
B.15 NETWORK_TRACE_FILE
The network trace file name.

B.16 NETWORK_TRACE
Flag indicating if Network Traces should be generated.

B.17 NETWORK_OBJECT_NUMBER
The default number of sessions the Network layer is expected to maintain.

B.18 NETWORK_USER_NUMBER
The default number of remote objects the Network Layer is expected to maintain

B.19 SERVER_PORT
Port the UWQ Server is registered on. 

Refer to platform specific documentation regarding port usage. The UWQ Server 
utilizes HTTP communications for access by web-based agents. If the server is to be 
accessed in this way, it is recommended that the default port 80 be used since many 
HTTP proxies won’t forward HTTP requests to ports other than 80. Obviously, the 

Type Unit Max Value Min Value Default

String N/A N/A N/A UWQNetwork_
logs

Type Unit Max Value Min Value Default

boolean N/A N/A N/A false

Type Unit Max Value Min Value Default

int N/A 65,536 0 200

Type Unit Max Value Min Value Default

int N/A 65,536 0 200
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LOAD_CALC_RATE
UWQ Server won’t be able to run on the same machine as a web server if port 80 is 
selected.

On UNIX machines any port below 1024 cannot be accessed by a process which is 
non root owned.

B.20 LOAD_CALC_RATE
The rate at which the load factors on the UWQ Server are calculated.

B.21 RECONN_WAIT_TIME
Time between tries to reconnect to remote servers/database etc.

B.22 ENABLE_SESSION_HISTORY
Turns on recording of server activity for Oracle Interaction Center Intelligence.

The Oracle Universal Work Queue server records: agent login, agent logout, media 
item requests, and media item deliveries. This feature can impact the performance 
fo the Oracle Universal Work Queue server.

Type Unit Max Value Min Value Default

int N/A 65,536 0 80

Type Unit Max Value Min Value Default

int seconds 65,536 0 20

Type Unit Max Value Min Value Default

int seconds 65,536 0 60

Type Unit Max Value Min Value Default

boolean N/A N/A N/A false
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C

Oracle Universal Work Queue Command

Line Parameters

The following table lists and defines the parameters that can be set using the Oracle 
Universal Work Queue server command line:

java oracle.apps.ieu.server.UWQServerLauncher [option <value>] [...]

Command line parameters other than the required parameters and -console may be 
overridden by the database parameter for the Oracle Universal Work Queue server. 
See Appendix B, "Oracle Universal Work Queue Server Parameters".

C.1 - console
Enables display of the UWQ Server GUI control panel and console trace.

C.2 - port
Specifies the Port number the server will listen on.

Refer to platform specific documentation regarding port usage. The UWQ Server 
utilizes HTTP communications for access by web-based agents. If the server is to be 
accessed in this way, it is recommended that the default port 80 be used since many 
HTTP proxies won’t forward HTTP requests to ports other than 80. Obviously, the 
UWQ Server won’t be able to run on the same machine as a web server if port 80 is 
selected.

Value Min Length Max Length Required Default

N/A N/A N/A NO disabled
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- name
C.3 - name
The name the UWQ Server will utilize to query itself in the database.

The UWQ Server name must be unique amongst all UWQ Servers across the 
deployment. If the UWQ Server detects another instance with the same name 
already running it will wait for the other instance to shutdown before completing 
initialization.

C.4 - dbc
The file name pre-pended by the file path where the .dbc file is located.

Refer to the Universal Installer documentation regarding creation/format of the 
.dbc file.

C.5 - trace_path
The path name identifying the location of the trace file.

C.6 - trace_file_name
The name of the trace file containing debug information.

Value Min Length Max Length Required Default

Number 1 5 NO 80

Value Min Length Max Length Required Default

String 1 6,6555 YES N/A

Value Min Length Max Length1

1 Refer to platform specific documentation regarding maximum allowable file path/name size.

Required Default

String 1 255 YES N/A

Value Min Length Max Length1

1 Refer to platform specific documentation regarding maximum allowable file path/name size.

Required Default

String 1 255 NO "."
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- trace_level_debug
C.7 - max_num_threads
Defines the maximum number of threads which may be allocated to the UWQ 
Server’s internal thread pool.

The internal UWQ Server Thread Pool does not control threads allocated for remote 
communications. Thus, this by no means indicates the maximum number of threads 
which will be utilized by the UWQ Server. Also, it is recommended that this not be 
set as a command line parameter as the UWQ Server will season the value in the 
database according to levels of demand.

C.8 - min_num_threads
Defines the minimum number of threads which will be allocated to UWQ Server’s 
internal thread pool.

The internal UWQ Server Thread Pool does not control threads allocated for remote 
communications. Thus, this by no means indicates the maximum number of threads 
which will be utilized by the UWQ Server. Also, it is recommended that this not be 
set as a command line parameter as the UWQ Server will season the value in the 
database according to levels of demand.

C.9 - trace_level_debug
Turns on detailed tracing of all server activity.

Value Min Length Max Length1

1 Refer to platform specific documentation regarding maximum allowable file path/name size.

Required Default

String 1 255 NO null (Output will 
only go to 
stdout.)

Value Min Length Max Length Required Default

Number 1 10 NO 50

Value Min Length Max Length Required Default

Number 1 10 NO 5
Oracle Universal Work Queue Command Line Parameters C-3



- trace_level_warn
Only one trace level parameter may be specified. If multiple trace level parameters 
are specified the parameter appearing first will be enforced and the others 
following will be ignored. WARNING!: The trace that is produced can be very 
verbose and affect performance.

C.10 - trace_level_warn
Turns on tracing of all server warnings and errors.

Only one trace level parameter may be specified. If multiple trace level parameters 
are specified the parameter appearing first will be enforced and the others 
following will be ignored. WARNING!: The trace that is produced can be very 
verbose and affect performance.

C.11 - trace_level_info
Turns on tracing of all server events, warnings and errors.

Only one trace level parameter may be specified. If multiple trace level parameters 
are specified the parameter appearing first will be enforced and the others 
following will be ignored. WARNING!: The trace that is produced can be very 
verbose and affect performance.

C.12 - trace_level_error
Turns on tracing of only server errors.

Only one trace level parameter may be specified. If multiple trace level parameters 
are specified the parameter appearing first will be enforced and the others 
following will be ignored. WARNING!: The trace that is produced can be very 
verbose and affect performance.

Value Min Length Max Length Required Default

N/A N/A N/A NO disabled

Value Min Length Max Length Required Default

N/A N/A N/A NO disabled

Value Min Length Max Length Required Default

N/A N/A N/A NO disabled
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- enable_session_history
C.13 - command
Turns on display of the UWQ Command Prompt. This allows acceptance of control 
commands from the command line e.g., Shutdown

C.14 - enable_session_history
Turns on recording of server activity for Oracle Interaction Center Intelligence.

The Oracle Universal Work Queue server records: agent login, agent logout, media 
item requests, and media item deliveries. This feature can impact the performance 
fo the Oracle Universal Work Queue server.

Value Min Length Max Length Required Default

N/A N/A N/A NO disabled

Value Min Length Max Length Required Default

N/A N/A N/A NO disabled

Value Min Length Max Length Required Default

N/A N/A N/A NO disabled
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- enable_session_history
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