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Preface

This preface contains these topics:

■ Intended Audience

■ Documentation Accessibility

■ Organization

■ Related Documentation

■ Conventions
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Intended Audience
This book is intended for those who perform the following tasks:

■ install applications

■ maintain applications

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation
accessible, with good usability, to the disabled community. To that end, our
documentation includes features that make information available to users of
assistive technology. This documentation is available in HTML format, and contains
markup to facilitate access by the disabled community. Standards will continue to
evolve over time, and Oracle Corporation is actively engaged with other
market-leading technology vendors to address technical obstacles so that our
documentation can be accessible to all of our customers. For additional information,
visit the Oracle Accessibility Program Web site at

http://www.oracle.com/accessibility/

Accessibility of Code Examples in Documentation JAWS, a Windows screen
reader, may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an
otherwise empty line; however, JAWS may not always read a line of text that
consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation This
documentation may contain links to Web sites of other companies or organizations
that Oracle Corporation does not own or control. Oracle Corporation neither
evaluates nor makes any representations regarding the accessibility of these Web
sites.

Organization
This document contains:

Chapter 1, "Introduction"
This chapter describes the PeopleSoft adapter and the hardware and software
requirements.
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Chapter 2, "Installation and Configuration"
This chapter describes the preinstallation, installation, and configuration steps for
the PeopleSoft adapter.

Chapter 3, "Supported PeopleSoft Interfaces"
This chapter describes the PeopleSoft adapter and the supported interfaces.

Chapter 4, "Using the Configuration Editor"
This chapter provides information for using the PeopleSoft adapter configuration
editor.

Related Documentation
For more information, see these Oracle resources:

■ Oracle9iAS InterConnect User’s Guide in the Oracle9i Application Server
Documentation Library

■ Oracle9i Application Server Installation Guide

■ Oracle9iAS InterConnect Adapter Configuration Editor User’s Guide

■ Oracle9iAS InterConnect Adapter Publishing Engine User’s Guide

In North America, printed documentation is available for sale in the Oracle Store at

http://oraclestore.oracle.com/

Customers in Europe, the Middle East, and Africa (EMEA) can purchase
documentation from

http://www.oraclebookshop.com/

Other customers can contact their Oracle representative to purchase printed
documentation.

To download free release notes, installation documentation, white papers, or other
collateral, please visit the Oracle Technology Network (OTN). You must register
online before using OTN; registration is free and can be done at

http://otn.oracle.com/admin/account/membership.html

If you already have a username and password for OTN, then you can go directly to
the documentation section of the OTN Web site at
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http://otn.oracle.com/docs/index.htm

Conventions
This section describes the conventions used in the text and code examples of this
documentation set. It describes:

■ Conventions in Text

■ Conventions in Code Examples

■ Conventions for Microsoft Windows Operating Systems

Conventions in Text
We use various conventions in text to help you more quickly identify special terms.
The following table describes those conventions and provides examples of their use.

Convention Meaning Example

Bold Bold typeface indicates terms that are
defined in the text or terms that appear in
a glossary, or both.

When you specify this clause, you create an
index-organized table.

Italics Italic typeface indicates book titles or
emphasis.

Oracle9i Database Concepts

Ensure that the recovery catalog and target
database do not reside on the same disk.

UPPERCASE
monospace
(fixed-width)
font

Uppercase monospace typeface indicates
elements supplied by the system. Such
elements include parameters, privileges,
datatypes, RMAN keywords, SQL
keywords, SQL*Plus or utility commands,
packages and methods, as well as
system-supplied column names, database
objects and structures, usernames, and
roles.

You can specify this clause only for a NUMBER
column.

You can back up the database by using the
BACKUP command.

Query the TABLE_NAME column in the USER_
TABLES data dictionary view.

Use the DBMS_STATS.GENERATE_STATS
procedure.
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Conventions in Code Examples
Code examples illustrate SQL, PL/SQL, SQL*Plus, or other command-line
statements. They are displayed in a monospace (fixed-width) font and separated
from normal text as shown in this example:

SELECT username FROM dba_users WHERE username = ’MIGRATE’;

The following table describes typographic conventions used in code examples and
provides examples of their use.

lowercase
monospace
(fixed-width)
font

Lowercase monospace typeface indicates
executables, filenames, directory names,
and sample user-supplied elements. Such
elements include computer and database
names, net service names, and connect
identifiers, as well as user-supplied
database objects and structures, column
names, packages and classes, usernames
and roles, program units, and parameter
values.

Note: Some programmatic elements use a
mixture of UPPERCASE and lowercase.
Enter these elements as shown.

Enter sqlplus to open SQL*Plus.

The password is specified in the orapwd file.

Back up the datafiles and control files in the
/disk1/oracle/dbs directory.

The department_id, department_name,
and location_id columns are in the
hr.departments table.

Set the QUERY_REWRITE_ENABLED
initialization parameter to true.

Connect as oe user.

The JRepUtil class implements these
methods.

lowercase
italic
monospace
(fixed-width)
font

Lowercase italic monospace font
represents placeholders or variables.

You can specify the parallel_clause.

Run Uold_release.SQL where old_
release refers to the release you installed
prior to upgrading.

Convention Meaning Example

[ ] Brackets enclose one or more optional
items. Do not enter the brackets.

DECIMAL (digits [ , precision ])

{ } Braces enclose two or more items, one of
which is required. Do not enter the
braces.

{ENABLE | DISABLE}

| A vertical bar represents a choice of two
or more options within brackets or braces.
Enter one of the options. Do not enter the
vertical bar.

{ENABLE | DISABLE}

[COMPRESS | NOCOMPRESS]

Convention Meaning Example
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... Horizontal ellipsis points indicate either:

■ That we have omitted parts of the
code that are not directly related to
the example

■ That you can repeat a portion of the
code

CREATE TABLE ... AS subquery;

SELECT col1, col2, ... , coln FROM
employees;

 .
 .
 .

Vertical ellipsis points indicate that we
have omitted several lines of code not
directly related to the example.

Other notation You must enter symbols other than
brackets, braces, vertical bars, and ellipsis
points as shown.

   acctbal NUMBER(11,2);

   acct    CONSTANT NUMBER(4) := 3;

Italics Italicized text indicates placeholders or
variables for which you must supply
particular values.

CONNECT SYSTEM/system_password

DB_NAME = database_name

UPPERCASE Uppercase typeface indicates elements
supplied by the system. We show these
terms in uppercase in order to distinguish
them from terms you define. Unless terms
appear in brackets, enter them in the
order and with the spelling shown.
However, because these terms are not
case sensitive, you can enter them in
lowercase.

SELECT last_name, employee_id FROM
employees;

SELECT * FROM USER_TABLES;

DROP TABLE hr.employees;

lowercase Lowercase typeface indicates
programmatic elements that you supply.
For example, lowercase indicates names
of tables, columns, or files.

Note: Some programmatic elements use a
mixture of UPPERCASE and lowercase.
Enter these elements as shown.

SELECT last_name, employee_id FROM
employees;

sqlplus hr/hr

CREATE USER mjones IDENTIFIED BY ty3MU9;

Convention Meaning Example
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Conventions for Microsoft Windows Operating Systems
The following table describes conventions for Microsoft Windows operating
systems and provides examples of their use.

Convention Meaning Example

Choose Start > How to start a program. To start the Oracle Database Configuration
Assistant, choose Start > Programs > Oracle -
HOME_NAME > Configuration and Migration
Tools > Database Configuration Assistant.

File and directory
names

File and directory names are not case
sensitive. The following special characters
are not allowed: left angle bracket (<),
right angle bracket (>), colon (:), double
quotation marks ("), slash (/), pipe (|),
and dash (-). The special character
backslash (\) is treated as an element
separator, even when it appears in quotes.
If the file name begins with \\, then
Windows assumes it uses the Universal
Naming Convention.

c:\winnt"\"system32 is the same as
C:\WINNT\SYSTEM32

C:\> Represents the Windows command
prompt of the current hard disk drive.
The escape character in a command
prompt is the caret (^). Your prompt
reflects the subdirectory in which you are
working. Referred to as the command
prompt in this manual.

C:\oracle\oradata>

The backslash (\) special character is
sometimes required as an escape
character for the double quotation mark
(") special character at the Windows
command prompt. Parentheses and the
single quotation mark (’) do not require
an escape character. Refer to your
Windows operating system
documentation for more information on
escape and special characters.

C:\>exp scott/tiger TABLES=emp
QUERY=\"WHERE job=’SALESMAN’ and
sal<1600\"

C:\>imp SYSTEM/password
FROMUSER=scott TABLES=(emp, dept)

HOME_NAME Represents the Oracle home name. The
home name can be up to 16 alphanumeric
characters. The only special character
allowed in the home name is the
underscore.

C:\> net start OracleHOME_
NAMETNSListener
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ORACLE_HOME
and ORACLE_
BASE

In releases prior to Oracle8i release 8.1.3,
when you installed Oracle components,
all subdirectories were located under a
top level ORACLE_HOME directory that by
default used one of the following names:

■ C:\orant for Windows NT

■ C:\orawin95 for Windows 95

■ C:\orawin98 for Windows 98

This release complies with Optimal
Flexible Architecture (OFA) guidelines.
All subdirectories are not under a top
level ORACLE_HOME directory. There is a
top level directory called ORACLE_BASE
that by default is C:\oracle. If you
install Oracle9i release 1 (9.0.1) on a
computer with no other Oracle software
installed, then the default setting for the
first Oracle home directory is
C:\oracle\ora90. The Oracle home
directory is located directly under
ORACLE_BASE.

All directory path examples in this guide
follow OFA conventions.

Go to the ORACLE_BASE\ORACLE_
HOME\rdbms\admin directory.

Convention Meaning Example
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1
Introduction

Oracle9iAS InterConnect connects to PeopleSoft through the PeopleSoft adapter.
This chapter discuses the following topics:

■ What is PeopleSoft?
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What is PeopleSoft?
PeopleSoft supports enterprise application software. It is a system containing
PeopleSoft components, with their related tables and data formats for specific tasks,
for example, Human Resources or Inventory Control. The PeopleSoft adapter
supports PeopleSoft’s Message Agent and Open Query. The Message Agent
accesses PeopleSoft panel groups outside the PeopleSoft environment. Open Query
enables third party applications to communicate with PeopleSoft through ODBC
standards.

When interacting with PeopleSoft, the PeopleSoft adapter provides a Message
Server and a Query Server. However, in order for the Message Server to get a list of
messages from PeopleSoft, there must be a component to perform the collection.

Before interacting with PeopleSoft, you must first upload the psosa.dat file into
your PeopleSoft production environment. The psosa.dat information creates the
Message component for Oracle9iAS InterConnect in PeopleSoft. It is through this
component that the Oracle9iAS InterConnect Message Server interacts.

Using the PeopleSoft adapter you can:

■ Preview the signature of component types in a familiar format.

■ Select component types to be included in a service.

■ Generate the bindings for the items in the service.

System Requirements
To use the PeopleSoft adapter, PeopleTools does not need to be installed on your
machine. However, if using queries to messages, you must have access to the
PeopleSoft ODBC drivers or the PeopleSoft Messaging Agent binaries. The
following lists the entities you need to use queries to messages:

■ Oracle recommends to install PeopleTools to effectively use the PeopleSoft
adapter. If you use Queries, you need to have the PeopleSoft ODBC driver
installed.

■ The Application Server Name is the name of the application server. You must
have access to the PeopleSoft Messaging Agent API Libraries, either by
installing PeopleTools on your development machine or setting your path to
point to the PeopleSoft Messaging Agent Binaries.

See Also: Oracle9i Application Server Installation Guide, Appendix
C for hardware requirements
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Supported Systems
Table 1–1 lists the systems to which the PeopleSoft adapter connects.

Supported Platforms
The PeopleSoft adapter supports the following platforms:

■ Windows NT and Windows 2000—Messaging Agent & Open Query

■ Solaris 2.6—Messaging Agent only

■ Solaris 7 (2.7)—Messaging Agent only

■ HP-UX 11.0—Messaging Agent only

Table 1–1 Supported Systems

Component Support Required Components

PeopleSoft 7.5.6
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2
Installation and Configuration

The PeopleSoft adapter, specifically the Message Server, requires a modification to
the PeopleSoft panel. You must customize this panel and make it available through
the Oracle9iAS InterConnect Message Server API, psmsrv75 (for PeopleSoft 7.5.6).

This chapter discusses the following topics:

■ Installing the PeopleSoft Adapter

■ PeopleSoft Adapter Configuration

■ Starting the PeopleSoft Adapter
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Installing the PeopleSoft Adapter
This section contains these topics:

■ Preinstallation Tasks

■ Installation Tasks

Preinstallation Tasks
The PeopleSoft adapter must be installed in one of the following Oracle homes:

■ An existing Oracle9i Application Server Oracle home

■ An existing Oracle9i Application Server Infrastructure Database Oracle home

■ An existing Oracle9iAS InterConnect Oracle home

■ A new Oracle home (the installer creates this for you)

Consult the Oracle9i Application Server Installation Guide before proceeding with
PeopleSoft installation. This guide includes information on:

■ CD-ROM mounting

■ Oracle Universal Installer startup

■ Oracle9iAS InterConnect software, hardware, and system requirements

■ Oracle9iAS InterConnect installation

Installation Tasks
To install the PeopleSoft adapter:

1. Click Next on the Welcome page.

The File Locations page displays.

2. Enter the following information in the Destination fields:

■ Name—The Oracle home name.

■ Path—The full path to the Oracle home in which to install the PeopleSoft.

Note: Oracle9iAS InterConnect Hub is installable through the
Oracle9iAS InterConnect Hub installation type. You must install the
Oracle9iAS InterConnect Hub before proceeding with PeopleSoft
installation.
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3. Click Next.

The Installation Types page displays.

4. Select Oracle9iAS InterConnect Adapters and click Next.

The Available Product Components page displays.

5. Select Oracle9iAS InterConnect PeopleSoft Adapter and click Next.

6. If the PeopleSoft adapter is not being installed on the same computer as
Oracle9iAS InterConnect Hub and another adapter is not installed in the
current Oracle home, the Oracle9iAS InterConnect Hub Database page displays.
Enter the following information about the Oracle9iAS InterConnect Hub to use:

■ Host Name—The hostname of the computer on which Oracle9iAS
InterConnect Hub is installed.

■ Port Number—The port number of the computer.

■ Database SID—The system identifier (SID) of the Oracle9iAS InterConnect
Oracle9iAS Metadata Repository.

■ Password—The password for the Oracle9iAS Metadata Repository schema.

The Oracle9iAS Metadata Repository stores metadata used by Oracle9iAS
InterConnect to coordinate communication between components.

7. Click Next. The Adapter Configuration page displays. Enter the application to
be defined or already defined in iStudio in the Application Name field. White
spaces or blank spaces are not permitted. The default value is myPSApp.

8. Click Next. The installation page that displays next is based on performing this
installation on UNIX or Windows NT:

Note: Do not change the path specified in the Source field. This is
the location on the CD-ROM from which to install the PeopleSoft.

On... Then Go to Step...

UNIX 9

Windows NT 10
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9. Enter information in the following fields on the Specify PeopleSoft and Tuxedo
Install Locations page:

■ PeopleSoft Installation Path—The root directory for the PeopleSoft
installation. The default is /opt/PeopleSoft.

■ Tuxedo Installation Path—The root directory for the Tuxedo installation.
The default is /opt/tuxedo.

10. Enter the clicnet binaries location on the Specify PeopleSoft Client Binaries
Location page. The default is <HomeDrive>:/Program F.

11. Click Next. Complete the fields for any other components selected for
installation, such as other adapters. When finished, the Summary page displays.

12. Click Install to install the PeopleSoft adapter and other selected components.
The PeopleSoft adapter is installed in the following directory:

PeopleSoft Adapter Configuration
Table 2–2, Table 2–3, and Table 2–4 describe executable files, configuration files, and
directories. These files and directories are accessible from the directory shown in
Table 2–1:

Table 2–1 PeopleSoft Adapter Directory

Table 2–2 Executable Files

Platform Directory

Windows %ORACLE_HOME%\oai\9.0.2\adapters\Application

UNIX $ORACLE_HOME/oai/9.0.2/adapters/Application

On... Go to...

UNIX $ORACLE_HOME/oai/9.0.2/adapters/Application

Windows %ORACLE_HOME%\oai\9.0.2\adapters\Application

File Description

start.bat (Windows) Takes no parameters, starts the adapter.

start (UNIX)
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Table 2–3 Configuration Files

Table 2–4 Directories

Using the Application Parameter
Adapters do not have integration logic. The PeopleSoft adapter has a generic
transformation engine that processes metadata from the repository as runtime
instructions to do transformations. The application defines for an adapter what its
capabilities are. For example, it can define what messages it can publish, what
messages it can subscribe to, and what are the transformations to perform. The
application parameter allows the adapter to become smart in the context of the
application to which it is connected. It allows the adapter to retrieve from the
repository only that metadata that is relevant to the application. The application
parameter must match the corresponding application that will be defined in iStudio
under the Applications folder.

stop.bat (Windows) Takes no parameters, stops the adapter.

stop (UNIX)

ignoreErrors.bat
(Windows)

If an argument is specified, then the given error code will be
ignored. If no argument is specified, than all error codes
specified in the ErrorCodes.ini will be ignored.

ignoreErrors (UNIX)

File Description

ErrorCodes.ini
(Windows and UNIX)

Should contain one error code per line.

adapter.ini
(Windows and UNIX)

Consists of all the initialization parameters which the adapter
reads at startup. Refer to Appendix A for a typical
adapter.ini file.

File Description

persistence The messages are persisted in this directory. This directory or its
contents should not be edited

logs The logging of adapter activity is done in subdirectories of the
log directory. Each new run of the adapter creates a new
subdirectory in which logging is done in an oailog.txt file.

File Description
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If you are using pre-packaged metadata, after importing the pre-packaged metadata
into the repository, start up iStudio to find the corresponding application (under the
Applications folder in iStudio) to use as the application for the adapter you are
installing (unless the package you are using provides directions for what the
application should be).

adapter.ni Initialization Parameter File Settings
This section contains these topics:

■ Hub.ini

■ Agent Connection Parameters

■ PeopleSoft Adapter Parameters

Hub.ini
The PeopleSoft adapter connects to the hub database using parameters from the
hub.ini file located in the hub directory. The following table lists the parameter
name, a description for each parameter, the possible and default values, and an
example.

Parameter Description Example

hub_username The name of the hub database schema (or username).
Possible values are valid hub database username. There
is no default value.

hub_username=myhub

hub_password The password for the hub database user. Possible
values are the valid password for the hub database
user. There is no default value.

hub_password=manager

hub_host The name of the machine hosting the hub database.
Possible values are the valid machine name. There is no
default value.

hub_host=mpjoshipc

hub_instance The valid SID of the hub database. There is no default
value.

hub_instance=orcl

hub_port The TNS listener port number for the HUB database
instance. There is no default value.

hub_port=1521

repository_name The valid name of the repository this adapter talks to.
There is no default value.

repository_name=myrepo
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Agent Connection Parameters
The PeopleSoft adapter connects to the spoke application using parameters from the
adapter.ini file. The following table lists the parameter name, a description for
each parameter, the possible and default values and an example.

Parameter Description Example

application The name of the application this adapter connects to.
This must match with the name specified in iStudio
during creating of metadata. Any alphanumeric string
can be used. There is no default value.

application=aqapp

partition The partition this adapter handles as specified in iStudio.
Any alphanumeric string is a possible value. There is no
default value.

partition=germany

instance_number To have multiple adapter instances for the given
application with the given partition, each adapter should
have a unique instance number. Possible values are any
integer greater than 1. There is no default value.

instance_number=1

agent_log_level Specifies the amount of logging necessary. Possible
values are:

0=errors only

1=status and errors

2=trace, status, and errors

The default value is 1.

agent_log_level=2

agent_
subscriber_name

The subscriber name used when this adapter registers its
subscription. The possible value is a valid Oracle
Advanced Queuing subscriber name and there is no
default value.

agent_subscriber_
name=aqapp

agent_message_
selector

Specifies conditions for message selection when
registering its subscription with the hub. The possible
value is a valid Oracle Advanced Queuing message
selector string. There is no default value.

agent_message_
selector=recipient_
list like ’%aqapp,%’

agent_reply_
subscriber_name

The subscriber name used when multiple adapter
instances for the given application with the given
partition are used. Optional if there is only one instance
running. The possible value is application name
(parameter: application) concatenated with
instance number (parameter: instance_number).
There is no default value.

If application=aqapp,
instance_number=2, then,
agent_reply_
subscriber_name=aqapp2
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agent_reply_
message_selector

Used only if multiple adapter instances for the given
application with the given partition. The possible value
is a string built using concatenating application name
(parameter:application) with instance number
(parameter:instance_number). There is no default
value.

If application=aqapp,
instance_number=2, then
agent_reply_message_
selector=receipient_
list like ’%,aqapp2,%’

agent_tracking_
enabled

Specifies if message tracking is enabled. Set to false to
turn off all tracking of messages. Set to true to track
messages with tracking fields set in iStudio. Possible
values are true or false. The default value is true.

agent_tracking_
enabled=true

agent_
throughput_
measurement_
enabled

Specifies if throughput measurement is enabled. Set to
true to turn on all throughput measurements. Possible
values are true or false. The default value is true.

agent_throughput_
measurement_
enabled=true

agent_use_
custom_hub_dtd

Specifies if a custom DTD should be used for the
common view message when handing it to the hub. By
default adapters use an Oracle9iAS InterConnect-specific
DTD for all messages sent to the hub as other Oracle9iAS
InterConnect adapters will be retrieving the messages
from the hub and know how to interpret them. Set to
true if for every message, the DTD imported for the
message of the common view is to be used instead of the
Oracle9iAS InterConnect DTD. Only set to true if a
Oracle9iAS InterConnect adapter is not receiving the
messages from the hub. Possible values are true or
false. There is no default value.

agent_use_custom_hub_
dtd=false

agent_metadata_
caching

Specifies the metadata caching algorithm. Possible
values are:

■ startup—Cache everything at startup. This may
take a while if there are a lot of tables in the
repository.

■ demand—Cache metadata as it is used.

■ none—No caching. This slows down performance.

The default value is demand.

agent_metadata_
caching=demand

Parameter Description Example
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agent_dvm_table_
caching

Specifies the DVM caching algorithm. Possible values
are:

■ startup—Cache all DVM tables at startup. This
may take a while if there are a lot of tables in the
repository.

■ demand—Cache tables as they are used.

■ none—No caching. This slows down performance.

The default value is demand.

agent_dvm_table_
caching=demand

agent_lookup_
table_caching

Specifies the lookup table caching algorithm. Possible
values are:

■ startup—Cache all lookup tables at startup. This
may take a while if there are a lot of tables in the
repository.

■ demand—Cache tables as they are used.

■ none—No caching. This slows down performance.

The default value is demand.

agent_lookup_table_
caching=demand

agent_delete_
file_cache_at_
startup

With any of the agent caching methods enabled,
metadata from the repository is cached locally on the file
system.

Set this parameter to true to delete all cached metadata
on startup.

Note: After changing metadata or DVM tables for this
adapter in iStudio, you must delete the cache to
guarantee access to the new metadata or table
information.

Possible values are true or false. The default value is
false.

agent_delete_file_
cache_at_startup=false

agent_max_ao_
cache_size

Specifies the maximum number of application objects’
metadata to cache. Possible values are any integer
greater than 1. The default value is 200.

agent_max_ao_cache_
size=200

agent_max_co_
cache_size

Specifies the maximum number of common objects’
metadata to cache. Possible values are any integer
greater than 1. The default value is 100.

agent_max_co_cache_
size=100

agent_max_
message_
metadata_cache_
size

Specifies the maximum number of messages’ metadata
to cache (publish/subscribe and invoke/implement).
Possible values are any integer greater than 1. The
default value is 200.

agent_max_message_
metadata_cache_
size=200

Parameter Description Example
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agent_max_dvm_
table_cache_size

Specifies the maximum number of DVM tables to cache.
Possible values are any integer greater than 1. The
default value is 200.

agent_max_dvm_table_
cache_size=200

agent_max_
lookup_table_
cache_size

Specifies the maximum number of lookup tables to
cache. Possible values are any integer greater than 1. The
default value is 200.

agent_max_lookup_
table_cache_size=200

agent_max_queue_
size

Specifies the maximum size that internal Oracle9iAS
InterConnect message queues can grow. Possible values
are any integer greater than 1. The default value is 1000.

agent_max_queue_
size=1000

agent_
persistence_
queue_size

Specifies the maximum size that internal Oracle9iAS
InterConnect persistence queues can grow. Possible
values are any integer greater than 1. The default value is
1000.

agent_persistence_
queue_size=1000

agent_
persistence_
cleanup_interval

Specifies how often the persistence cleaner thread should
run. Possible values are any integer greater than 30000.
The default value is 60000.

agent_persistence_
cleanup_interval=60000

agent_
persistence_
retry_interval

Specifies how often the persistence thread should retry
when it fails to push a Oracle9iAS InterConnect message.
Possible values are any integer greater than 5000. The
default value is 60000.

agent_persistence_
retry_interval=60000

service_path Windows only. The value that the environment variable
PATH should be set to. Path is set to the specified value
before forking the Java VM. Typically, all directories
containing all necessary DLLs should be listed here.
Possible values are the valid path environment variable
setting. There is no default value.

service_
path=%JREHOME%\bin;D:\
oracle\ora902\bin

service_
classpath

The classpath used by the adapter Java VM. If a custom
adapter is developed and as a result, the adapter is to be
used to pick up any additional jars, add the jars to the
existing set of jars being picked up. Possible values are
the valid classpath. There is no default value.

service_
classpath=D:\oracle\
ora902\oai\902\lib\
oai.jar;%JREHOME%\lib\
i18n.jar;D:\oracle\ora
902\jdbc\classes12.zip

service_class The entry class for the Windows NT service. The possible
value is
oracle/oai/agent/service/AgentService. There
is no default value.

service_
class=oracle/oai/agent
/service/AgentService

service_max_
java_stack_size

Windows only. The maximum size to which the Java
VM’s stack can grow. Possible values are the valid Java
VM maximum native stack size. The default value is the
default for the Java VM.

service_max_java_
stack_size=409600

Parameter Description Example
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service_max_
native_stack_
size

Windows only. The maximum size to which the Java
VM’s native stack can grow. Possible values are the valid
Java VM maximum native stack size. The default value is
the default for the Java VM.

service_max_native_
size=131072

service_min_
heap_size

Windows only. Specifies the minimum heap size for the
adapter Java VM. Possible values are the valid Java VM
heap sizes. The default value is the default Java VM heap
size.

service_min_heap_
size=536870912

service_max_
heap_size

Windows only. Specifies the maximum heap size for the
adapter Java VM. Possible values are any valid Java VM
heap sizes. The default value is 536870912.

service_max_heap_
size=536870912

service_num_vm_
args

Windows only. The number of service_vm_arg<number>
parameters specified. Possible values are the number of
service_vm_arg<number> parameters. There is no
default value.

service_num_vm_args=1

service_vm_
arg<number>

Windows only. Specifies any additional arguments to the
Java VM. For example, to get line numbers in any of the
stack traces, set service_vm_arg1=java.compiler=NONE. If
there is a list of arguments to specify, use multiple
parameters as shown in the example by incrementing the
last digit starting with 1. Be sure to set the service_
num_vm_args correctly. Possible values are any valid
Java VM arguments. There is no default value.

service_vm_
arg1=java.compiler=
NONE

service_vm_
arg2=oai.adapter=.aq

service_jdk_
version

Windows only. The JDK version the adapter Java VM
should use. The default value is 1.3.1.

service_jdk_
version=1.3.1

service_jdk_dll Windows only. The dll the adapter Java VM should use.
The default value is jvm.dll.

service_jdk_
dll=jvm.dll

Parameter Description Example
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PeopleSoft Adapter Parameters
The following table lists the parameters specific to the PeopleSoft adapter.

Starting the PeopleSoft Adapter
Start the PeopleSoft adapter using the start script in the directory named after the
PeopleSoft adapter on Windows NT, UNIX, or HP.

On Windows NT or Windows 2000, start the PeopleSoft adapter from the Service
window available from the Start menu.

1. Access the Services window from the Start menu:

The Services window displays.

2. Select the OracleHome9iASInterConnectAdapter-Application service.

3. Start the service based on your operating system:

Parameter Description Example

bridge_class This indicates the entry class for the PeopleSoft. Do not
modify this value. A possible value is
com.actional.oai.Agent. There is no default value.

bridge_
class=com.actional.oai.
Agent

On... Choose...

Windows NT Start > Settings > Control Panel > Services

Windows 2000 Start > Settings > Control Panel > Administrative Tools > Services

On... Choose...

Windows NT Choose Start.

Windows 2000 Right click the service and choose Start from the menu that
displays.
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The PeopleSoft adapter, in turn, automatically starts the publishing engine, a tool
for notifying foreign applications of additions, deletions, or updates to the native
application (in this case, PeopleSoft objects and databases).

See Also: Oracle9iAS InterConnect Adapter Publishing Engine User’s
Guide
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3
Supported PeopleSoft Interfaces

This chapter provides information specific to PeopleSoft. The following topics are
discussed:

■ Working with Oracle and PeopleSoft

■ Importing the Oracle9iAS InterConnect Project into PeopleSoft

■ Creating a New Operator Class and Assigning Permission

■ Exception Fields

■ Message Agent

■ Open Query

■ Creating an Implemented Procedure

■ Creating a Subscribed Event

■ Creating a Published Event
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Working with Oracle and PeopleSoft
Oracle9iAS InterConnect provides a complete framework for e-Business application
integration across Application to Application, Active Server Pages (Microsoft), and
Business to Business domains. PeopleSoft users often configure PeopleSoft to
employ Oracle9iAS InterConnect connectivity. For this reason, a PeopleSoft adapter
can be installed with your PeopleSoft component.

Importing the Oracle9iAS InterConnect Project into PeopleSoft
To use PeopleSoft, you must import the Oracle9iAS InterConnect PeopleSoft
message definition project. You can import the message definition project into your
PeopleSoft environment.

To automatically import the project, you must have an existing Source Database and
a Target Database. The Source Database is the *.dat file supplied with Oracle9iAS
InterConnect, containing the current objects that you want to copy to another
database. The Target Database is the database where to want to copy your objects.

Regardless of how you create the project, you must create a class of operators and
assign permissions.

To import the Oracle9iAS InterConnect project you will need:

■ Application Update Database.

■ Peoplesoft’s Data Mover—Databases inside PeopleSoft are separate entities.
The Data Mover transfers data from one database to another inside PeopleSoft.

■ The following Connection types:

■ Source and Target Databases require a two- or three-tier connection type.

■ Data Mover requires a two-tier connection type.

See Also:

■ Chapter 3, "Supported PeopleSoft Interfaces"

■ "Exception Fields" on page 3-13

■ "Creating a New Operator Class and Assigning Permission" on
page 3-11
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Automatically Import the Oracle9iAS InterConnect Project
The goal of this section is to place the objects from a source database into a project.
This involves the following:

■ Importing the psosa.DAT file from the install_
directory\OAI\9.0.2\PeopleSoft directory into the Application Update
Database using Data Mover.

■ Copying items from the Application Update Database to the production
database.

■ Verifying that the new imported items exist.

The Project Name specified is used throughout the moving process.

Step 1  Import *.DAT to the Application Update Database using the Data Mover
1. Copy the install_directory\OAI\9.0.2\PeopleSoft\psosa.DAT file

to the c:\Temp directory or to the directory defined by the TEMP Environment
Variable setting.

2. Select Start > Programs > Peoplesoft > Data Mover.

The PeopleSoft Signon dialog displays.

Figure 3–1 PeopleSoft Signon

Note: Application Update Database is for the Message Agent only.
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3. Enter information in the following fields:

■  Connection Type—A two-tier Connection Type. For example, select
Microsoft SQL server from the dropdown select list.

■ Database Name—The name of the Application Update Database. The
Application Update Database is a temporary holding area, comprising a
development table with empty cells.

■ Operator ID—The database operator ID.

■ Password—The database password.

4. Click OK.

5. Select File > Open and access the Aurefrsh.dms located in the /Scripts
directory to refresh the Application Update Database.

6. Select File > Run Script to execute the refresh.

7. Select File > Open and access the Auimport.dms located in the /Scripts
directory to import your project into the Application Update Database.

8. Select Edit > Replace.

The Replace dialog displays.

Figure 3–2 Replace Dialog

9. Enter information in the following fields:

■ Find What—Enter AU999999.

■ Replace With—Enter your project name, for example YourProjectName.

10. Click Replace All.

See Also: The PeopleSoft Installation and Administration Guide if you
do not have an Application Update Database
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11. Select File > Run Script to execute the import.

12. Close the Data Mover.

Step 2  Copy Project to the Target Database
The following steps copy the business process definition and the activity definition
from the Application Update Database to the target database.

1. Log on to the PeopleSoft Application Designer.

2. Select File > Open.

3. Enter your project name, YourProjectName, in the Selection Criteria Name field.

4. Click Select.

5. Select Tools > Upgrade > Copy.

6. Enter the Database Name, Operator ID, and Password for the target database.

7. Click OK.

Verify that the Source database, Target database, and Object Types are correct.

Figure 3–3 Copy Dialog

8. Check the Export Project box to copy the project to the database.

9. Click Copy to complete the copy process.

10. Exit the PeopleSoft application.
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Step 3  Verify the Objects Exist
To verify the object exists, you must first log on to PeopleSoft.

1. Select Start > Programs > Peoplesoft > Application Designer.

2. Select a three-tier connection type from the dropdown menu. For example,
select Application Server.

Figure 3–4 PeopleSoft Signon

3. Select File > Open.

4. Select the Project Object Type.

5. Enter the object name, YourProjectName, and click Select.

You have successfully imported the objects into your target database. The Business
Process Object and its related object, Activity, are now in the target database.

Manually Create the Oracle9iAS InterConnect Project for 7.5.6
The following steps guide you through manually creating the Oracle9iAS
InterConnect project for 7.5.6.

Step 1  Create a Project
1. Select File > New > Project to create a project on the PeopleSoft Application

Designer.

2. Select File > New > Panel to create a panel.
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3. Select Insert > Grid to add a grid to the panel.

Select the grid by clicking on it and placing it on the panel. Click and hold the
mouse. Drag the mouse to increase the size the grid then release the mouse after
finishing your resize of the grid.

4. Press Ctrl+F or right-click Panel Field Properties to open the grid properties
dialog.

5. Select the General tab.

6. Enter PSMSGAGTDEFN in the Main Record input field.

7. Select the Columns tab and click Add.

8. Select Edit Box as the column type and click OK.

9. Enter ACTIVITYNAME in the Field Name input field.

10. Select the Label tab.

11. Enter Activity in the Text input field and click OK.

12. Click Add.

13. Select Edit Box as the column type and click OK.

14. Enter INPUTNAME in the Field Name input field.

15. Select the Label tab.

16. Enter Message and click OK.

17. Click Add.

18. Select Long Edit Box as the column type and click OK.

19. Enter DESCRLONG in the Field Name input field.

20. Select the Label tab.

21. Enter Description in the Text input field.

22. Click OK twice.

23. Resize the grid and grid columns.

24. Select File > Save to save the panel.

25. Specify a panel name, for example, PSOSA_MESSAGENAMES, and click OK.
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Step 2  Insert the Current Object into a Project
1. Close the panel dialog.

2. Select File > New > Panel Group to create a Panel Group.

3. Select Insert > Panel into the new group.

4. Enter the name of the panel just saved, for example, PSOSA_MESSAGENAMES in
the Name input field and click Insert.

5. Close the dialog box.

6. Press Alt+Enter while the panel group’s dialog is active.

7. Select the Use panel.

8. Specify PSMSGAGTDEFN as the search record.

9. Check only Update/Display.

10. Click OK.

11. Select File > Save to save the Panel Group.

12. Specify a panel group name, for example, PSOSA_MESSAGENAMES and click
OK.

13. Select Insert > Current Object into Project.

14. Close the Panel Group dialog.

Step 3  Create a Menu
1. Select File > New > Menu.

2. Click OK - Standard Menu.

3. Double-click the rectangle between Favorites and Language.

4. Enter values into the Name and Label text areas for the Bar Item, for example,
USE and Use, and click OK.

5. Double-click the rectangle below the new menu item Use.

6. Enter values into the Name and Label text areas for the Bar Item, for example,
GETMESSAGENAMES and Get Message Names and click Select.

7. Enter the name of the Panel Group, for example, PSOSA_MESSAGENAMES, in
the input field labeled Name and click Select.

8. Click OK.
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9. Press Alt+Enter.

10. Select the Use tab.

11. Specify a menu label, for example, the PeopleSoft adapter.

12. Check Menu Installed.

13. Click OK.

Step 4  Save the Menu
1. Select File > Save.

2. Specify a menu name, for example, PSOSA_MNU and click OK.

3. Select Insert > Current Object into Project.

4. Close the Menu dialog.

Step 5  Create a Business Process
1. Select File > New > Business Process.

2. Click Activity on the palette (the icon with foot prints) and clicking on the
Business Process dialog to add an activity.

3. Click OK in the Activity Choices dialog.

4. Right-click Activity and enter ObjectAdapter as the activity name.

5. Click OK.

6. Double click Activity.

7. Click Other app (the icon with a opened door) and on the Business Process
dialog to add a message.

Step 6  Create the Message Definition
1. Right-click the Message icon.

2. Enter GetMessageNames as the name of the message.

3. Enter a short description to display in the browser.

4. Click Attributes.

5. Select the new menu (PSOSA_MNU), the bar name (USE), the item name
(GETMESSAGSNAMES), the action name, (&Update/Display), and the search
record name (PSMSGAGTDEFN).
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6. Click OK.

7. Click Level Mapping... .

8. Check the Output all occurrences.

9. Click OK.

10. Click Field Mapping... .

11. Click Add.

12. Specify ACTIVITYNAME (case sensitive) as the field name.

13. Select PSMSGAGTDEFN value in the Record list.

14. Select the ACTIVITYNAME value in the Field list.

15. Select Output in the Map When combo box and click OK.

16. Click Add.

17. Specify INPUTNAME (case sensitive) as the field name.

18. Select PSMSGAGTDEFN value in the Record list.

19. Select the INPUTNAME value in the Field list.

20. Select Output in the Map When combo box and click OK.

21. Click Add.

22. Specify DESCRIPTION (case sensitive) as the field name.

23. Select PSMSGAGTDEFN value in the Record list.

24. Select the DESCRLONG in the Field list.

25. Select Output in the Map When combo box.

26. Click OK three times to return to the main menu.

27. Select File > Save to save the Business Process.

28. Specify a business process name, for example, PSOSA_BP.

29. Click OK.

30. Select Insert > Current Object into Project.

31. Close the Business Process dialog.

32. Select File > Save Project to save the project.
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33. Specify a project name, for example, PSOSA_PRJ.

Creating a New Operator Class and Assigning Permission
Regardless of how you import the Oracle9iAS InterConnect Message Agent Project,
either automatically or manually, you must give access to the new menu and panel
by creating a class of operators and assigning permission. You then assign the new
class with the permissions to the PeopleSoft adapter operator. The following steps
describe this process.

Step 1  Create a Class of Operators
1. Select Go > PeopleTools > Security Administrator.

A new PeopleSoft dialog displays.

2. Select File > New to create a new class of operator.

3. Select Class Of Operators as the value of the Security Definition Type combo.

4. Select Insert > Menu Name.

5. Select the new menu, NewMenuName, and click OK.

The Select Menu Items dialog displays.

6. Click Select All, then click OK.

7. Select File > Save and specify a name, for example, PSOSA_OP.

This saves the class of operators under the name of PSOSA_OP.

8. Click OK and close the dialog.

Step 2   Assign the Permissions of the Class to the New Operator
1. Select File > Open.

2. Select an operator.

3. Click the Classes icon.

4. Select Insert > Class.

5. Select the new class of operators, for example, PSOSA_OP.

See Also: "Creating a New Operator Class and Assigning
Permission" on page 3-11 for instructions on creating a class of
operators and assigning permissions
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6. Click OK.

7. Close the dialog and select Yes when prompted to save your changes.

Step 3  Test the New Setup
1. Run the Application designer and sign on as the operator with permission to

access the panel.

2. Select Go.

A new dialog displays.

3. Select Use > Get Message Names.

The new panel displays the list of messages defined in your Peoplesoft
database.

Additional Information
The following is additional information for the PeopleSoft adapter pre-installation
tasks.

■ Building or Altering Tables and Administering Menu Security—If you copied
tables to your target database, then you will need to either Build or Alter the
tables depending on which tables were copied.

■ Building or Altering Tables and Administering Menu Security—You may need
to administer security to objects that were copied to your target database, such
as menu items.

See Also: PeopleBooks: Development Tools/Application
Designer/Building SQL Objects

See Also: PeopleBooks: Administration Tools/Security/Security
Administrator
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Exception Fields
If an error happens during a call, the exception field generally contains a detailed
description of the error that occurred. You can then propagate this error string to the
calling application.

Consider an example where you have a setup with PeopleSoft on one side, an
Oracle9iAS InterConnect hub in the middle and a Web front end on the other side.
Suppose the Web front end tries to add a record to the PeopleSoft side, however, a
record with the same primary key already exists in PeopleSoft. In this case, you
have a non-retryable error. The exception field contains the exception data. This
data may be propagated back to the Web front end.

Example
The following is an example of an exception message:

exception: E-OAI0003: Exception occurred during call to
AddWidget@PeopleSoft://Messages/WidgetStore
User defined exception
Exception occurred:

Source: WidgetStore::AddWidget
    Cause: PeopleSoft://Messages/exception=MsgAgentException (Unique ID <none>)

Exception occurred:
Source: WidgetStore::AddWidget
Cause: PeopleSoft://Messages/exception=MsgAgentException (Unique ID <none>)

Exception data:
struct MsgAgentExceptionData =
String Source = "PSMsgProcessMessage(WidgetStore::AddWidget)"
String ErrorText = "Row exists in ADD or DATAENTRY mode (81,10)"
String Explanation = "The specified search keys resulted in an existing

level 0 row found when in ADD or DATAENTRY mode."
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Message Agent
Using the PeopleSoft Message Agent, PeopleSoft panel groups can be accessed
outside the PeopleSoft environment. Each panel in a PeopleSoft panel group is used
to enter and retrieve data. Access to PeopleSoft panels is gained through a set of
Application Programming Interfaces (APIs) together with a message definition. A
message definition creates the mapping between fields in the message definition
and fields on a PeopleSoft panel. This is the way PeopleSoft programs are exposed.
The PeopleSoft adapter acts as the client message agent program, which allows you
to access and call all message agent definitions within a PeopleSoft application
server. The PeopleSoft adapter communicates with the Message Agent Server when
a client sends an inbound call via the adapter.

Open Query
Open Query allows you to call queries that exist on the PeopleSoft application
server through the standard ODBC interface. The iStudio browser allows you to
graphically explore all Open Query definitions on an application server with the
Component Selector. This simplifies the process of invoking the queries by exposing
them as objects with a single execute method.
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Creating an Implemented Procedure
1. Start iStudio.

2. Right-click Implemented Procedures and select New under the Applications
folder.

Figure 3–5 Creating an Implemented Procedure
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The Implement Wizard—Select a Procedure dialog displays.

Figure 3–6 Implement Wizard - Select a Procedure

3. Select a procedure and click Next.

The Define Application View dialog displays. Use this dialog to import
attributes from PeopleSoft. To import attributes, you must log in to PeopleSoft.

See Also: "Importing Attributes" on page 3-18
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After logging in to PeopleSoft and importing attributes, the Define Application
View dialog is populated with the selected components.

Figure 3–7 Implement Wizard - Define Application View

4. Click Next.
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The Define Mapping Arguments dialog displays.

Figure 3–8 Implement Wizard - Define Mapping:IN Arguments

5.  Click New.

6. Define the mappings and click Finish.

Importing Attributes
To import attributes from PeopleSoft:

1. Click Import and select PeopleSoft on the Define Application View dialog.
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The PeopleSoft Login dialog displays.

Figure 3–9 PeopleSoft Login

2. Enter information in the following fields:

■ Data Source Dialog—Automatically populated by the PeopleSoft adapter
when accessed through the iStudio wizards.

■ Application Server Name—A valid application server name.

■ Operator ID—A valid operator ID.

■ Password—A valid password.

3. Click OK.

Note: If you do not have a valid operator ID or password, contact
your PeopleSoft administrator.
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The Component Selector dialog displays.

Figure 3–10 Component Selector

4. Expand the Message Agent adapter folder.

5. Double-click a message to expand the tree.

6. Select a component and click OK.

The selected component and its attributes display on the Define Application
View dialog.

Note: When publishing an event, the Component Selector
displays the Events folder. Select an Event to import and click OK.
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Creating a Subscribed Event
To create a subscribed event in iStudio:

1. Start iStudio.

2. Right-click Subscribed Event and select New under the Applications folder.

Figure 3–11 Creating a Subscribed Event
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The Subscribe Wizard—Select an Event dialog displays.

Figure 3–12 Subscribe Wizard - Select an Event

3. Select the Application and Message Type from the dropdown menus.

4. Select an Event and click Next.
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The Define Application View dialog displays.

Figure 3–13 Subscribe Wizard - Define Application View

5. Click Import and select PeopleSoft.

The Define Application View dialog displays. Use this dialog to import
attributes from PeopleSoft. To import attributes, you must log in to PeopleSoft.

See Also: "Importing Attributes" on page 3-18
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After logging in to PeopleSoft and importing attributes, the Define Application
View dialog is populated with the selected components.

Figure 3–14 Subscribe Wizard - Define Application View

6. Click Next.

The Define Mapping dialog displays.

7. Click New to define mappings and click Finish.
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Creating a Published Event
To publish an event from PeopleSoft, there is a configuration step that must be
completed. You need to define a published event in the publishing database for the
PeopleSoft adapter. These definitions can be created using the pubmgr tool.

To publish an event using iStudio:

1. Right-click Published Events under the PeopleSoft folder and click New.

Figure 3–15 Creating a Published Event

See Also: Oracle9iAS InterConnect Adapter Publishing Engine
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The Publish Wizard—Select an Event dialog displays.

Figure 3–16 Publish Wizard - Select an Event

2. Select an event and click Next.

The Define Application View dialog displays. Use this dialog to import
attributes from PeopleSoft. To import attributes, you must log in to PeopleSoft.

See Also: "Importing Attributes" on page 3-18
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After logging in to PeopleSoft and importing attributes, the Define Application
View dialog is populated with the selected components.

Figure 3–17 Publish Wizard - Define Application View

3. Click Next.

The Define Mappings dialog displays.

4. Click New to define mappings and click Finish.
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4
Using the Configuration Editor

This chapter describes how to use the Configuration Editor to configure the
PeopleSoft adapter. The Configuration Editor is only used at runtime. The following
topics are discussed:

■ Configuration Editor

■ PeopleSoft Login

■ PeopleSoft Scalability

■ Data Formats

Note: Profiles and Deployment are sensitive to the Master Key
setting. If using a shared machine, before accessing the
Configuration Editor ensure the Master Key is set to either that of
User1 or create a new Master Key for your profiles. Refer to the
Oracle9iAS InterConnect Configuration Editor User’s Guide for more
information on the Master Key.



Configuration Editor

4-2 Oracle9iAS InterConnect Adapter for PeopleSoft 7.5x Installation and User’s Guide

Configuration Editor
To configure settings for the PeopleSoft adapter you must access the PeopleSoft
Configuration Editor as follows:

1. Change directories to the installation directory using a command prompt.

2. Type configeditor and press Enter.

The Configuration Editor displays.

3. Select PeopleSoft to edit the PeopleSoft configuration settings for your profile.

4. Click Profile.

5. Select Set As Default from the Profile dropdown menu.

Note: Under some circumstances you may wish to run your
adapter under a profile other than iStudio. This may be needed, for
example, if you want to run two instances of the PeopleSoft adapter
on the same machine. You may want to have two instances of the
same type of adapter if these instances need to connect to different
backend system installations. To accomplish this create a new
profile using the configuration editor and enter the settings for this
new profile. The name of the new profile should be the same as the
name of the application. For example, if your application is called
APP2, create a profile called APP2. Now APP2 uses the settings in
the profile called APP2, whenever it runs.
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6. Select your new profile.

Figure 4–1 Configuration Settings Editor

7. Click OK.

8. Select File > Exit to exit the Configuration Editor after completing the setup.
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PeopleSoft Login
The Login branch is only available for user-defined profiles and provides
connection information to a PeopleSoft system. You must identify both the ODBC
driver and the Application driver as the PeopleSoft Service Provider supports both
queries and message.

Figure 4–2 Login Panel

Table 4–1 Login Panel Configuration Settings

Login Panel Fields Field Description

Data Source Name This works in a two-tier mode and is used for queries, for
example, Microsoft SQL Server.

Insert the ODBC driver:

1. Select the Control Panel > ODBC Data Source and make
sure that a PeopleSoft Data Source is available and that the
PeopleSoft Data Source points to the correct data.

2. Open the database by double-clicking the data source to
view the DataBase Name. Insert the Data Source Name
from the Control Panel dialog into this text area.
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Application Server Name This works in a two-tier mode and is used for queries, such as
Microsoft SQL Server.

Insert the ODBC driver:

1. Select Control Panel > ODBC Data Source and make sure
that a PeopleSoft Data Source is available and make sure
that the PeopleSoft Data Source points to the correct data.

2. Open the database by double-clicking the data source to
view the DataBase Name. Insert the Data Source Name
from the Control Panel dialog into this text area.

On a Unix systems, the form is machine_name:port_
number. For example, People2:7000.

Operator ID Insert the identification used to access the PeopleSoft
application.

Password Enter the PeopleSoft password. The Password is only editable
under specific user-defined profiles.

PeopleSoft Version Select the version of the PeopleSoft application.

Table 4–1 Login Panel Configuration Settings

Login Panel Fields Field Description
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PeopleSoft Scalability
The PeopleSoft setup predetermines the total number of servers. This tab
determines how servers are to be used with the PeopleSoft adapter and the server
process idle time-out.

Figure 4–3 Scalability Panel

Table 4–2 Scalability Panel Configuration Settings

PeopleSoft Scalability
Panel Fields  Field Description

Message Agent Servers Maximum Number of Servers—The setting defaults to one
server. The maximum number is determined by the PeopleSoft
system. The adapter’s API—psmsrv75 (for PeopleSoft 7.5.x) is
the Message Agent Server providing PeopleSoft libraries with
scalability. As PeopleSoft libraries are not multi-threaded,
scalability can only be achieved by having several processes.

Reclaiming Interval—The default setting is 5 minutes. After a
set period of time of no activity, a server process is stopped to
be re-used by another process. It is important that this setting
not be too low—making allowances for the connection time to
a PeopleSoft system.
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Data Formats
The Data Formats tab provides conversion information for date and time strings
used in messages. This tab is for those applications requiring a date, for example,
Automation applications. The information is determined by the PeopleSoft system.

Figure 4–4 Data Format Panel

Open Query Servers Maximum Number of Servers—The setting defaults to one
server. The maximum number is determined by the PeopleSoft
system. The adapter’s psqrysrv (PeopleSoft 7.5.x) is the
Query Server providing PeopleSoft libraries with scalability.
As PeopleSoft libraries are not multi-threaded, scalability can
only be achieved by having several processes.

Reclaiming Interval—The default setting is 5 minutes. After a
set period of time of no activity, a server process is stopped to
be re-used by another process. It is important that this setting
not be too low—making allowances for the connection time to
a PeopleSoft system.

Table 4–2 Scalability Panel Configuration Settings

PeopleSoft Scalability
Panel Fields  Field Description
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Table 4–3 Data Format Panel Configuration Settings

Data format Panel Fields  Field Description

Date The format is MM/DD/YYYY.

Time The format is hh:mm:ssAA, where AA is either AM or PM.

Date Time The format is MM/DD/YYY hh:mm:ssAA, where AA is either
AM or PM.
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