Oracle® Reports Developer

Building Reports

Release 6/

January, 2000
Part No. A73172-01
Contents

Send Us Your Comments ................................................................................................................... ix

Preface ................................................................................................................................................. xi

1 Basic Report Builder Concepts
  1.1 What is Report Builder? ........................................................................................................... 1
  1.2 Tools for working with reports in Report Builder .............................................................. 2
  1.2.1 Using wizards to automate report design ......................................................................... 2
  1.2.1.1 Report Wizard ............................................................................................................. 2
  1.2.1.2 Data Wizard ................................................................................................................ 3
  1.2.1.3 Web Wizard ................................................................................................................ 4
  1.2.2 Using the Report Editor to view and edit reports .......................................................... 4
  1.2.2.1 Live Previewer .......................................................................................................... 4
  1.2.2.2 Data Model view ......................................................................................................... 5
  1.2.2.3 Layout Model view ..................................................................................................... 5
  1.2.2.4 Parameter Form view ................................................................................................. 5
  1.2.3 Using the Object Navigator to locate report elements .................................................. 5
  1.3 Obtaining database access before you start ....................................................................... 6
  1.4 Other software needed before you start .............................................................................. 6
  1.5 Operating system considerations ......................................................................................... 6

2 Building a Report with Conditional Formatting
  2.1 Creating the initial report with the Report Wizard ............................................................. 10
  2.2 Making simple formatting modifications to the report ..................................................... 12
4.2 Modifying the look of your report output ............................................................... 67
  4.2.1 Modifying the layout in the Live Previewer ....................................................... 67
  4.2.2 Adding format masks ......................................................................................... 68
  4.2.3 Changing the maximum number of rows returned by your query ................ 69
  4.3 Including an HTML report header ................................................................. 70
  4.4 Adding bookmarks to parts of your report ....................................................... 71
  4.5 Changing the page separator .......................................................................... 72
  4.6 Adding hyperlink destinations and hyperlinks ............................................... 73
    4.6.1 Adding hyperlink destinations ....................................................................... 73
    4.6.2 Adding hyperlinks to destinations within the report ..................................... 74
    4.6.3 Adding hyperlinks to external destinations .................................................... 74
  4.7 Displaying pop-ups and rollovers in HTML output ......................................... 77
    4.7.1 Adding a pop-up to an image object ............................................................. 77
    4.7.2 Adding a rollover to an image object ............................................................. 78
  4.8 Using PL/SQL to conditionally hide/show objects for Web output ................. 79
  4.9 Creating a summary section with a chart ....................................................... 80
    4.9.1 Creating the data model for the summary section ....................................... 80
    4.9.2 Creating the default layout for the summary section ................................. 81
    4.9.3 Creating a chart for the summary section ..................................................... 83
    4.9.4 Adding hyperlinks to your chart ................................................................. 85
  4.10 Adding Javascript ............................................................................................ 86
    4.10.1 Creating animated objects ......................................................................... 86
    4.10.2 Using HTML page streaming ................................................................. 88
  4.11 Running the Web report from the Reports Server ......................................... 90
  4.12 Summary ....................................................................................................... 91

5 Building a Report with Sections

  5.1 Creating a data model ..................................................................................... 96
    5.1.1 Building queries using the Data Wizard ..................................................... 96
    5.1.2 Refining the Data Model ............................................................................ 98
  5.2 Designing a Runtime Parameter Form .......................................................... 105
  5.3 Creating a layout for the first section ............................................................ 106
  5.4 Refining the layout in the Layout Model view ............................................... 110
    5.4.1 Changing the properties of objects ......................................................... 111
    5.4.2 Re-arranging frames and objects .............................................................. 113
# Building a Report with Ref Cursor Queries

6.1 Defining a ref cursor type ................................................................. 130

6.2 Creating a ref cursor query ................................................................. 132

6.3 Refining the data model ...................................................................... 134

6.4 Creating links between ref cursor queries ............................................ 136

6.5 Adding summary columns .................................................................. 138

6.6 Creating a layout .................................................................................. 140

6.7 Moving the SELECT statement into a package ...................................... 143

6.8 Moving the packages into a library ....................................................... 145

6.9 Summary .............................................................................................. 147

# Building a Report Using Express Data

7.1 Creating an Express report with the Report Wizard .............................. 152

7.2 Refining the Express query ................................................................... 156

7.3 Adding summary columns and custom measures to your data model ....... 158

7.3.1 Renaming data objects ...................................................................... 160

7.3.2 Creating summary columns ............................................................... 160

7.3.3 Creating a custom measure ............................................................... 161

7.4 Enhancing the report layout ................................................................. 163

7.4.1 Inserting summary fields in the report .............................................. 163

7.4.2 Inserting the custom measure field into the report ......................... 167

7.4.3 Sorting dimension values ............................................................... 173

7.4.4 Making format changes in Live Previewer ........................................ 174
Index
Send Us Your Comments

**Oracle Reports Developer: Building Reports Release 6i**
Part No. A73172-01

Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this publication. Your input is an important part of the information used for revision.

You can send comments to us in the following ways:

- E-mail - oddoc@us.oracle.com
- Postal service
  Oracle Corporation
  Reports Developer Documentation
  500 Oracle Parkway, 2op8
  Redwood Shores, CA 94065
  USA

Please provide the following information:

Name:
Title:
Company:
Department:
E-Mail Address:
Postal Address:
Phone Number:
Book Title:
Part Number:

If you like, you can use the following questionnaire to give us feedback:

- Did you find any errors?
- Is the information clearly presented?
- Do you need more information? If so, where?
- Are the examples correct? Do you need more examples?
- What features did you like most about this manual?

If you find any errors or have any other suggestions for improvement, please indicate the chapter, section, and page number (if available).

If you have problems with the software, please contact your local Oracle Support Services.
Preface

The examples in this book are intended to help you learn about Oracle Reports Developer and its features.

Intended audience

This book is intended for anyone who uses Report Builder to build reports. The needs of both novice and advanced users are addressed. Each chapter contains step-by-step instructions to build a report from start to finish. Each report that you build will demonstrate how to use many of the powerful features in Report Builder.

Structure

This book contains the following chapters:

<table>
<thead>
<tr>
<th>Table 0–1</th>
<th>Summary of manual contents</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Chapter</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Chapter 1, &quot;Basic Report Builder Concepts&quot;</td>
<td>Contains basic information to get you started.</td>
</tr>
<tr>
<td>Chapter 2, &quot;Building a Report with Conditional Formatting&quot;</td>
<td>Describes how to build a report that uses conditional formatting so that the appearance of your report automatically changes when certain specified criteria are met.</td>
</tr>
</tbody>
</table>
The following conventions are used in this book:

Table 0–2  Notational conventions used in manual

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>boldface text</strong></td>
<td>Used for emphasis. Also used for menu items, button names, labels, and other user interface elements.</td>
</tr>
<tr>
<td><strong>italicized text</strong></td>
<td>Used to introduce new terms.</td>
</tr>
<tr>
<td><strong>courier font</strong></td>
<td>Used for path and file names, and for code and text that you type.</td>
</tr>
</tbody>
</table>
### Table 0–2  Notational conventions used in manual

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>COURIER CAPS</td>
<td>Used for:</td>
</tr>
<tr>
<td></td>
<td>■ File extensions (.PLL or .FMX)</td>
</tr>
<tr>
<td></td>
<td>■ Environment variables</td>
</tr>
<tr>
<td></td>
<td>■ SQL commands</td>
</tr>
<tr>
<td></td>
<td>■ Built-ins/package names</td>
</tr>
<tr>
<td></td>
<td>■ Executable names</td>
</tr>
</tbody>
</table>

---

**Additional information in online help**

Some of the tasks in this manual tell you how to access online help for additional information. If you see a table like the one that follows, use the steps to get more information about the task you are performing:

1. For online help on this topic, choose
2. On the Index page, type...
   report wizard, about
   Report Wizard: Welcome page
Basic Report Builder Concepts

This chapter introduces some basic information about Report Builder, such as:

- Section 1.1, "What is Report Builder?"
- Section 1.2, "Tools for working with reports in Report Builder"
- Section 1.3, "Obtaining database access before you start"
- Section 1.4, "Other software needed before you start"
- Section 1.5, "Operating system considerations"

1.1 What is Report Builder?

Oracle Reports Developer is a suite of programs that allows your organization to centralize report processing and to better manage reporting. Report Builder is one of the program components included with Reports Developer.

Report Builder includes:

- A query builder with a visual representation of the specification of SQL statements to obtain report data
- Wizards that guide you through the report design process
- Default report templates and layouts that can be customized to meet your organization’s reporting needs
- The ability to generate code to customize how reports will run
- A Live Previewer that allows you to edit report layouts in WYSIWYG mode
- An integrated chart builder that helps you to graphically represent report data
Tools for working with reports in Report Builder

- Web publishing tools that dynamically generate web pages based on your corporate data
- Other standard report output formats like HTML, PDF, PCL, Postscript, and ASCII

Reports Developer can access data from any database you may have in your organization, including: Oracle, Microsoft SQL Server, Sybase, Informix, DB2, and any ODBC-compliant data source.

1.2 Tools for working with reports in Report Builder

Report Builder provides the tools to help you create and manage reports. These tools are described in the following sections:

- Section 1.2.1, "Using wizards to automate report design"
- Section 1.2.2, "Using the Report Editor to view and edit reports"
- Section 1.2.3, "Using the Object Navigator to locate report elements"

1.2.1 Using wizards to automate report design

Report Builder has a Report Wizard, Data Wizard, and Web Wizard to automate the creation of reports. Most often, you can create a report by starting with one of the wizards, and then refining the report that the wizard creates.

For example, you can start with the Report Wizard to create an initial report, which the Report Wizard automatically displays in the Live Previewer. From there, you can make modifications to the report in the Live Previewer, Layout Model view, Data Model view, and Parameter Form view. See Section 1.2.2, "Using the Report Editor to view and edit reports" for information about report views.

1.2.1.1 Report Wizard

The easiest way to create a report is to use the Report Wizard. The Report Wizard takes you through the steps required to create a report, and is a great way to start building a report. The Report Wizard alone may give you a report that satisfies your requirements. If it doesn’t, you can use the Data Model view, the Live Previewer, and the Layout Model view to further refine your report.
Many of the sample reports in this manual will instruct you on how to build a report using the Report Wizard. A brief overview of how to use the Report Wizard follows:

2. If the Welcome dialog box appears, click **Use the Report Wizard** and click **OK**.

   If the Welcome dialog box does not appear, choose **File->New->Report**. Click **Use the Report Wizard** and click **OK**.
3. Fill out each page of the Report Wizard, getting help when needed by clicking the Help button.
4. On the last page of the Report Wizard, click **Finish**. A report is created and appears in the Live Previewer.
5. From the Live Previewer, you can edit the report as desired. Note that the Live Previewer is one of several report views that are available in the Report Editor. Using the View menu or the toolbar, you can switch to other report views to further edit your report. Section 1.2.2, "Using the Report Editor to view and edit reports" talks more about different ways to view a report.

For more information about the Report Wizard, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type... report wizard, about
3. Then click Display to view help topic... Report Wizard: Welcome page

### 1.2.1.2 Data Wizard

If you need to create multiple queries for your report, use the Data Wizard to create them. From the Data Model view, choose **Tools->Data Wizard**. Section 5.1.1, "Building queries using the Data Wizard" contains an example that uses the Data Wizard. For more information, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type... data wizard, about
3. Then click Display to view help topic... Data Wizard: Welcome page
Tools for working with reports in Report Builder

1.2.1.3 Web Wizard

If you want to quickly deploy your reports on the Web, use the Web Wizard. Choose Tools->Web Wizard. Section 4.4, "Adding bookmarks to parts of your report" contains an example that uses the Web Wizard. For more information, see the online help:

[Checklist]

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type... web wizard, about
3. Then click Display to view help topic... Web Wizard: Welcome page

1.2.2 Using the Report Editor to view and edit reports

The Report Editor and the Object Navigator appear when you first start up Report Builder. (For information about the Object Navigator, see Section 1.2.3, "Using the Object Navigator to locate report elements"). In the Report Editor, you can view information about a report in four different ways. You can switch between these views using the View menu or the toolbar icons.

You will work in each of the following Report Editor views as you create the sample reports in this manual:

- Live Previewer
- Data Model view
- Layout Model view
- Parameter Form view

For more information, see the online help:

[Checklist]

1. For online help on these topics, choose Help->Report Builder Help Topics
2. On the Index page, type... Live Previewer, about; or Data Model view, about; or Layout Model view, about; or Parameter Form view, about
3. Then click Display to view help topic.

1.2.2.1 Live Previewer

This view displays your report as an end user would see it. If you are using live data, the Live Previewer will update the report as data changes. Any modifications that you make to the report in the Live Previewer display immediately. To display your report in the Live Previewer, click .

1-4 Oracle Reports Building Reports
1.2.2.2 Data Model view
This view displays your report data as data model objects so that you can see the relationships between queries, groups, columns, parameters, and links. To display your report in the Data Model view, click  .

1.2.2.3 Layout Model view
This view displays the attributes of your report as objects so that you can see the attribute types and relationships. You can edit layout objects, such as frames, repeating frames, fields, boilerplates, anchors, and graphics in this view in order to change the appearance of the report. To display your report in the Layout Model view, click  .

1.2.2.4 Parameter Form view
This view lets you create a Runtime Parameter Form for your report. When a user runs your report, the user enters values for parameters in this form to determine how the report will execute, or the user accepts the defaults. If you do not define a Runtime Parameter Form in the Parameter Form view, Report Builder displays a default Parameter Form at runtime. You can select which system and user parameters to use for your form using the Parameter Form Builder, or you can create your own from scratch. To display the Parameter Form view, click  .

1.2.3 Using the Object Navigator to locate report elements
The Object Navigator and Report Editor appear when you first start up Report Builder. The Object Navigator provides a hierarchical display of all major objects in a report or template, including attached libraries and external queries. Using the Object Navigator, you can:

- Select an object
- Open the Property Palette to change an object’s attributes
- Edit an object’s PL/SQL
- Drag and drop PL/SQL program units
- Search for an object by name

When you select an object in the Object Navigator, the corresponding object is simultaneously selected in the Live Previewer, Data Model view, or Layout Model view (whichever view is open at the time).
1.3 Obtaining database access before you start

In order to build the reports as described in this manual, you must be able to access the Oracle Reports Developer demo tables. Use the demo CD that came with your product package to install the SQL scripts. These scripts are used to install the demo tables in your database. These SQL scripts can be run from the Start->Programs menu.

Before starting a report, be sure to log into the database that contains the Oracle Reports Developer demo tables. You log in by selecting File->Connect.

1.4 Other software needed before you start

The following programs may be required to view some of the sample reports. Before you start, check that your system has the following:

- Web browser, such as Netscape 3.x or higher, or Internet Explorer 3.x or higher, that supports HTML style sheets and Javascript
- Adobe Acrobat Reader plug-in, or the ability to view Acrobat Reader PDFs

1.5 Operating system considerations

The steps in this book were written based on the Windows 95/NT operating environment. If you are using another operating system, for example a UNIX-based system, there may be slight variations in some of the steps you need to perform.
Building a Report with Conditional Formatting

The report described in this chapter will help you learn more about Report Builder features for conditional formatting. You will build a single-query report that records company stock prices, and then displays values using conditional formatting when the price of a stock hits minimum and maximum values.

To build this report, you will use the Report Wizard to create the initial data model and report layout. You will make refinements to the report layout in the Live Previewer. You will also write PL/SQL, which is provided for you.

About conditional formatting  It is often useful to highlight certain parts of your report when particular conditions are met. For example, you can change the color of a value to red when it is greater than 5000. Report Builder provides two ways of adding conditional formatting to your report:

- The Conditional Formatting and Format Exception dialog boxes lets you specify multiple conditions and formatting attributes (font, text color, border, and fill color) for a selected layout object. You don’t write any code with this method.
- The Format Trigger property allows you to code your own PL/SQL functions to perform conditional formatting. Because you write the code yourself, you have more flexibility and complete control when compared to using the Conditional Formatting and Format Exception dialog boxes alone.

For many conditions, you often can do what you need using the Conditional Formatting and Format Exception dialog boxes. For other conditions, you may want to use the dialog boxes to get started, and then modify the generated code by editing the Format Triggers.
The following figure illustrates the condition formatting features that you will apply to your report. Table 2–1, "Features demonstrated in this Conditional Formatting sample report", describes the steps you will take to create this report.

Add bookmarks that link to minimum and maximum values. See Section 2.3

Set group headings in repeating frames to alternate between colors. See Section 2.5.
The cond.rdf file contains the report you will create after finishing the tasks in this chapter. You may want to refer to this file while you are working. This file is located in your ORACLE_HOME\TOOLS\DOC60\US\RBR60 directory.

Table 2–1 Features demonstrated in this Conditional Formatting sample report

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Report Wizard to define the SQL and create a first draft of the report.</td>
<td>Section 2.1, &quot;Creating the initial report with the Report Wizard&quot;</td>
</tr>
<tr>
<td>Modify the report layout for readability using the Live Previewer.</td>
<td>Section 2.2, &quot;Making simple formatting modifications to the report&quot;</td>
</tr>
<tr>
<td>Add a format exception to a field using the Conditional Formatting dialog box so that the appearance of the field changes when a specified condition is met.</td>
<td>Section 2.3, &quot;Adding a formatting exception to a field&quot;</td>
</tr>
<tr>
<td>Modifying the code generated by the Format Exception dialog box in order to do additional processing when a specified condition is met.</td>
<td>Section 2.4, &quot;Adding more functionality to the generated format trigger code&quot;</td>
</tr>
<tr>
<td>Add a formatting exception to a repeating frame in order to make a change that affects a number of report objects at once.</td>
<td>Section 2.5, &quot;Adding a formatting exception to a repeating frame&quot;</td>
</tr>
<tr>
<td>Modify code generated by the Format Exception dialog boxes to further customize the report.</td>
<td>Section 2.6, &quot;Modifying the generated code&quot;</td>
</tr>
</tbody>
</table>

To get started, open Report Builder. If the Welcome dialog box appears, click Use the Report Wizard and click OK. If not, choose File->New->Report. Click Use the Report Wizard and click OK.

At some point before you generate the report, you will need to log into the database. Choose File->Connect to connect to the database. Enter the appropriate log on information. See Section 1.3, "Obtaining database access before you start" for details.
2.1 Creating the initial report with the Report Wizard

The Report Wizard is a great way to start building a report. The Report Wizard alone may give you a report that satisfies your requirements. If it doesn’t, you can use the Data Model view, the Live Previewer, and the Layout Model view to further refine your report. For this report, you will start with the Report Wizard, and then use the Live Previewer and Layout Model to modify the layout and add conditional formatting to the report. The steps in this section will help you to create the initial report.

1. If the Welcome page of the Report Wizard appears, click **Next**.
2. On the Style page, enter **Stocks** as the Title, and click **Group Above** as the report style.
   
   **Tip:** If you are unsure about what to do on any page of the wizard, click **Help**.
3. Click **Next**.
4. If the Type page appears, click **SQL statement**, and click **Next**. The Type page will appear only if you have configured Report Builder to run with Oracle Express.
5. On the Data page, ignore the buttons on the page and type in the following SELECT statement:

   ```sql
   SELECT symbol,
         company,
         current_price,
         trade_date,
         number_traded_today,
         todays_high,
         todays_low
   FROM stocks
   ```

6. Click **Next**.
7. On the Groups page in the Available Fields list, click the item symbol.
8. Click > .

9. Repeat steps 7 and 8 for the company field.

10. For this report, you want one break level, but you currently have two – Level 1 and Level 2. To make one break level, click company in the Group Fields list, and drag it into Level 1.

   Tip: Groups are created to organize the columns in your report. When you create a query, Report Builder automatically creates a group that contains the columns selected by the query. You create additional groups to produce break levels in the report in order to create a group above or group left report.

11. Click Next.

12. On the Fields page, click >> . Doing this makes all fields display in the report.

13. Click Next.


15. Click Minimum. The minimum and maximum current_price fields display in the Totals list.

16. Click number_traded_today, and click Maximum.

17. Click Minimum. The minimum and maximum number_traded_today fields display in the Totals list.

18. Click Next.

19. On the Labels page, change the labels and widths as shown in the following table:

<table>
<thead>
<tr>
<th>Column</th>
<th>Label</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>Todays High</td>
<td>Today’s High</td>
<td>9</td>
</tr>
<tr>
<td>Todays Low</td>
<td>Today’s Low</td>
<td>9</td>
</tr>
</tbody>
</table>

20. Click Next.

21. On the Template page, click Predefined template if it is not already selected, and click Corporate 2 in the list box.
22. Click Finish. The report output automatically displays in the Live Previewer and should look similar to the following figure:

![Image of report output]

23. Choose File->Save As. Save the report in the directory of your choice, and name the report `cond_21.rdf`.

**Tip:** It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you don’t like some of the changes you made, you easily can go back to the previously saved file and make revisions from that point.

### 2.2 Making simple formatting modifications to the report

At this point, you could return to the Report Wizard and update any of its settings (for example, labels or widths) and regenerate the report. However, in this section, you will make a few edits in the Live Previewer to improve the appearance of the report.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...

   format mask, applying to numeric object

3. Then click Display to view help topic...

   Applying a format mask to a numeric object

1. In the Live Previewer, click the column of data below the Current Price heading. Report Builder selects every instance of the field. This means that any change you make at this point will be applied to all instances of the field.
2. Press and hold SHIFT. Then click the data under the Today’s High and Today’s Low headings. (You can select multiple columns by holding the SHIFT key while you click.)

3. Find the bold values at the end of each column. (You will need to scroll to the bottom of the first page). Shift-click on them. Find any other bold monetary values at the end of the report, and shift-click on them. Now all of the monetary values in the report are simultaneously selected, and you can easily format them all at once.

**Tip:** If you accidentally select something and want to deselect it, shift-click on it again to deselect.

4. Click $ to add a dollar sign ($) to the selected values.

5. Click + twice to add two decimal places.

6. Click in an empty area of the Live Previewer to deselect everything.

7. Click the data under the Number Traded Today heading to select it.

8. Click , to add a comma to values that have more than three digits to the left of the decimal.

9. Click in an empty area of the Live Previewer to deselect everything. The report output should look similar to the following figure:

   ![Stocks Report](image)

10. Save the report as cond_22.rdf.

Optional Exercise:

Explore the Live Previewer to see what other changes you can make.
2.3 Adding a formatting exception to a field

The Conditional Formatting dialog box is a great way to start applying formatting exceptions to your layout objects. (For example, you can make a field’s value bold when it exceeds a specified maximum value). The Conditional Formatting dialog box alone may satisfy your requirements for creating a formatting exception.

Tip: When you use the Conditional Formatting dialog box, it generates a Format Trigger for the selected object. Consequently, once you directly edit a Format Trigger for an object, you should not go back and use the Conditional Formatting dialog box to make more modifications. If you do, you may lose some of the customized modifications that you made directly to the Format Trigger.

In this section, you will set conditional formatting for two summary fields, :Maxcurrent_pricePerSymbol and :Min current_pricePerSymbol. Doing this will flag values if they are outside of the specified maximum and minimum points.

1. In the Live Previewer, click the data under the Current Price heading to select it.
   Tip: When you select data in the Live Previewer, the corresponding object is highlighted in the Object Navigator, and vice versa.

2. Choose Tools->Property Palette.

3. Under the General Layout node, find the Conditional Formatting property, and double-click the button next to it.

4. In the Conditional Formatting dialog box, click New to create a new format exception for the Current Price field object.

5. In the Format Exception dialog box, check the first check box if it is not already checked. Choose current_price from the first drop-down list of values if it is not already chosen.

6. Choose Equal from the second drop-down list of values that is next to current_price.

7. Type :Maxcurrent_pricePerSymbol in the third field next to Equal.

8. Check the check box in the second row. Note that the last drop-down list in the first row is activated and can be edited.
9. In the last drop-down list in the first row, choose OR.

10. Repeat steps 5 through 7 adding current_price, Equal, and :Mincurrent_pricePerSymbol to the second row.

11. Click Font, and choose Bold in the Font dialog box. Click OK to close the Font dialog box.

12. Click and choose red. The palette closes automatically.

13. Click and choose black. The palette closes automatically.

14. Click OK to close the Format Exception dialog box.

15. Click Apply. You will see the effect of your format exception in the Live Previewer. You should now see some values in bold with a red fill color and a black border. Looking at these values allows you to see when the price of a particular stock was at its minimum and maximum value.

16. In the Conditional Formatting dialog box, click OK. Or, click Edit to further modify your format exception.

17. Close the Property Palette. The report output should look similar to the following figure:

18. Save the report as cond_23.rdf.
Optional Exercises:

- Choose File->Generate to File->PDF. After you have created the PDF file, locate the file in Explorer and open it in the Acrobat Reader to see the report output.

- To see the format exception code that Report Builder has generated for you, go to the Object Navigator and expand the **Program Units** node for the report. Double-click the icon next to the Format Trigger to open it in the PL/SQL Editor, and view the code.

- If you want more practice, try implementing a format exception for the values under Number Traded Today that is similar to the one you just implemented for the current price. The report already contains all of the values you need to do this.

### 2.4 Adding more functionality to the generated format trigger code

In many cases, simply changing formatting attributes as done in Section 2.3, "Adding a formatting exception to a field" may suffice. However, you can also include more sophisticated processing.

The steps in this section will help you to design the report for PDF output and add bookmarks that indicate when stock prices reach a maximum point.

Because you have already generated some code with the Conditional Formatting dialog box, some of the logic you need is already in place.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...

3. Then click Display to view help topic...

1. In the Live Previewer, click the data under the Current Price heading.

2. Choose Tools->Property Palette.

3. Under the **Advanced Layout node**, find the Format Trigger property, and double-click the button next to it.
4. Modify the code so that it looks as follows. The new code that you need to add is in bold:

```plaintext
function F_current_priceFormatTrigger return boolean is
begin
   -- Automatically Generated from Report Builder.
   if ((:current_price = :Maxcurrent_pricePerSymbol) or (:current_price = :Mincurrent_pricePerSymbol))
       then
           srw.set_foreground_border_color('black');
           srw.set_border_pattern('solid');
           srw.set_foreground_fill_color('red');
           srw.set_fill_pattern('solid');
           srw.set_font_face('Arial');
           srw.set_font_size(10);
           srw.set_font_weight(srw.bold_weight);
           srw.set_font_style(srw.plain_style);
           if (:current_price = :Maxcurrent_pricePerSymbol)
               then
                   srw.set_bookmark(:symbol || ' at maximum ');
                end if;
           end if;
       end if;
   return (TRUE);
end;
```

5. Click Compile.

6. If any compilation errors occur, check the code for syntax errors, and recompile as needed.

7. Click Close.

8. Close the Property Palette.

   Tip: The next four steps require that the Live Previewer be the active window.

9. Choose View->Web Preview->Use PDF.

10. Choose View->Web Preview->Show All Pages.

11. Choose View->Web Preview->Generate to Web Browser. The PDF output for your report is now displayed in your Web browser. Test the bookmarks.

   Tip: You may be requested to locate the executable that launches your browser. Use the Browse button. Your browser must be configured to use the Acrobat Reader plug-in to view the PDF that Report Builder generated.
Adding more functionality to the generated format trigger code

If you do not have the Acrobat Reader plug-in configured for your browser, you can choose File->Generate to File->PDF, and open the PDF in the stand alone Acrobat Reader.

12. Go back into Report Builder and choose View->Web Preview->Generate to Web Browser. This turns off the Web Previewer.

   Tip: When you’re making a lot of little changes to your report, it’s best to turn off the Web preview feature. Otherwise, the Web preview is constantly updating each small change that you make.

13. Repeat steps 1 through 8. But this time, update the Format Trigger to look as follows. The new code that you need to add is in bold:

```sql
function F_current_priceFormatTrigger return boolean is
begin
   -- Automatically Generated from Report Builder.
   if ( (:current_price = :Maxcurrent_pricePerSymbol) or
      (:current_price = :Mincurrent_pricePerSymbol) )
   then
      srw.set_foreground_border_color('black');
      srw.set_border_pattern('solid');
      srw.set_foreground_fill_color('red');
      srw.set_fill_pattern('solid');
      srw.set_font_face('Arial');
      srw.set_font_size(10);
      srw.set_font_weight(srw.bold_weight);
      srw.set_font_style(srw.plain_style);
      if ( (:current_price = :Maxcurrent_pricePerSymbol) )
         then
            srw.set_bookmark(:symbol || ' at maximum ');
      elsif ( (:current_price = :Mincurrent_pricePerSymbol) )
         then
            srw.set_bookmark(:symbol || ' at minimum ');
         end if;
   end if;
end;  
```

14. Save the report as cond_24.rdf.
15. Click to view the results in the Live Previewer.

16. Repeat steps 9 through 12 to regenerate the PDF.

2.5 Adding a formatting exception to a repeating frame

Creating a formatting exception for a single field can be useful, but you can also create a formatting exception that affects a number of objects at once. Report Builder typically groups objects inside of frames or repeating frames. If the objects inside of a frame are transparent, changing the fill color of a repeating frame will effectively change the fill color of the objects inside of it.

In this section, you will change the fill color of an object in a repeating frame.

1. Go to the Data Model view.

2. Click .

3. Click the title bar of the group named G_symbol.

4. Double-click the newly created column named CS_1 to display the Property Palette. You may have to scroll down. Update the properties as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
<th>Source</th>
<th>Reset at</th>
</tr>
</thead>
<tbody>
<tr>
<td>CS_COUNT</td>
<td>Count</td>
<td>symbol</td>
<td>Report</td>
</tr>
</tbody>
</table>

5. Press ENTER or RETURN, or click any other field in the Property Palette to accept the changes.

6. Close the Property Palette.

7. In the Object Navigator, place your cursor in the Find field and type R_G_SYMBOL. Note that the search occurs as you type, so you will most likely be taken to the object before you finish typing the entire name.

8. Choose Tools->Property Palette.

9. In the Property Palette, under the General Layout node, locate the Conditional Formatting property, and double-click the button next to it.

10. Click New to create a new format exception for the field object.

11. Choose CS_COUNT from the first list of values.

12. Choose Equal from the list of values next to CS_COUNT.
13. Type 1 in the field next to Equal.
14. Click and choose a darker grey.
15. Click OK.
16. Repeat steps 10 through 14 using CS_COUNT, Equal, 0, and a light blue for the Fill Color.
17. Click OK in the Format Exception dialog box.
18. Click Apply and OK in the Conditional Formatting dialog box.
19. Check your output in the Live Previewer. Because there are non-transparent objects on top of the repeating frame, you only see the dark grey color at the very top of the first instance of the repeating frame. The light blue color never appears, but you will change that in Section 2.6, "Modifying the generated code".
20. Save the report as cond_25.rdf.

2.6 Modifying the generated code

By making a simple modification to the code that was generated by the Conditional Formatting and Format Exception dialog boxes, you can make the fill color alternate for even and odd instances of the repeating frame.

1. In the Object Navigator, click the R_G_SYMBOL object.
2. Choose Tools->Property Palette.
3. In the Property Palette, under the Advanced Layout node, locate the Format Trigger property, and double-click the button next to it.
4. Modify the code so that it looks as follows. The new code that you need to add is in bold.

**Tip:** Note that the color specifications in the following code may differ slightly from the colors specified in your code:

```sql
function R_G_symbolFormatTrigger return boolean is
begin
    -- Automatically Generated from Report Builder.
    if (:CS_count mod 2 = '1')
    then
        srw.set_foreground_fill_color('gray32');
        srw.set_fill_pattern('solid');
    end if;
    -- Automatically Generated from Report Builder.
    if (:CS_count mod 2 = '0')
    then
        srw.set_foreground_fill_color('r50g50b100');
        srw.set_fill_pattern('solid');
    end if;
    return (TRUE);
end;
```

5. Click **Compile**.

6. If any compilation errors occur, check the code for syntax errors, and recompile as needed.

7. Click **Close**.

8. Click **Run** to view the results in the Live Previewer. Note as you scroll through the report that the headings alternate between dark grey on the odd pages and light blue on the even pages.

9. Save the report as `cond_26.rdf`.

**Optional Exercise:**

Make the opaque objects on top of R_G_SYMBOL transparent so that you can see its fill color through the other objects.

**Tip:** Use the Object Navigator to choose the frames contained in the R_G_SYMBOL object.
2.7 Summary

Congratulations! You have finished the Conditional Formatting sample report. You now know how to:

- Use the Report Wizard to define a data model and layout.
- Use the Live Previewer to modify a report layout.
- Use the Conditional Formatting dialog box to add a format exception to a field.
- Modify code generated by the Conditional Formatting dialog box.
- Add formatting exceptions to a repeating frame.
- Modify code generated by the Format Exception dialog box.

For more information about conditional formatting, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type...
   conditional formatting, about
3. Then click Display to view help topic...
   About conditional formatting
The report described in this chapter is designed to help you learn more about the Report Builder features for building and applying templates.

**About templates** Templates define common characteristics and objects that you want to apply to multiple reports. For example, you can define a template that includes the company logo and sets fonts and colors for selected areas of a report.

In this report example, you will build a multi-query report that summarizes stock information by company symbol using the Tabular report style. You will create a new template and apply the template to the report. Then you will enhance the template by changing several default attributes in the template margin and body. You will enhance the template further by overriding some of the default attributes of the Group Above style. Finally, you will create an additional layout using the Group Above style, and re-apply the template to the report.

The following figure illustrates the concept of templates and the various features you will add to your template. A template defines the common look (the default attributes) of a report that can be applied globally across all report styles.

With the same template, you will change the look of a particular report style. In this example, you will override the default attributes of Group Above style.

When you create a report, you can use this template to apply a common look across many report styles (Tabular, Group Left, Matrix, and so on) or apply a unique look to a report with the Group Above report style.

Table 3–1, “Features demonstrated in this Templates sample report”, describes the steps you will take to create a template and apply it to a report.
Create a template with default attributes that apply to all report styles. Section 3.3

Change the colors and borders of frames, fields, and labels. Section 3.6.

Define override attributes that apply only to the Group Above report style. Section 3.7

Apply default attributes to a tabular report. Section 3.3.

Insert a watermark. Section 3.3.

Include an HTML file that displays a footer when the report is generated in HTML. Section 3.3.

Define format triggers that conditionally display graphics based on the page number. Section 3.3.

Oracle Reports Building Reports
The following supporting files are used to help you complete the exercises in this chapter. They are located in your `ORACLE_HOME\TOOLS\DOC60\US\RBR60` directory:

- `temp_hdrftr.htm`
- `oreplogo.gif`
- `osuplogo.jpg`
- `ostore.gif`
- `oracle.gif`
- `cconft.bmp`
- `cconfa.bmp`
- `t_image1.bmp`
- `t_image2.bmp`
- `temp.tdf`
- `temp.rdf`

You also will work with the following templates (located in your `ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US` directory):

- `corp2.tdf`
- `conf2.tdf`

You will work with the global preferences file, `cagprefs.ora` (located in your `ORACLE_HOME` directory.) The `temp.rdf` file contains the report you will create after finishing the tasks in this chapter. You may want to refer to this file while you are working. This file is located in your `ORACLE_HOME\TOOLS\DOC60\US\RBR60` directory.
To get started, open Report Builder. If the Welcome dialog box appears, click **Build a new report manually** and click **OK**. If not, choose **File->New->Report**. Click **Build a new report manually** and click **OK**. The Data Model appears.

At some point before you generate the report, you will need to log into the database. Choose **File->Connect** to connect to the database. Enter the appropriate log on information. See Section 1.3, "Obtaining database access before you start" for details.

---

**Table 3–1 Features demonstrated in this Templates sample report**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a multi-query data model and data links in the Data Model view.</td>
<td>Section 3.1, &quot;Creating a data model&quot;</td>
</tr>
<tr>
<td>Create a report using a pre-defined layout, and modify the layout in the Live Previewer.</td>
<td>Section 3.2, &quot;Creating a report&quot;</td>
</tr>
<tr>
<td>Create a new template, which will modify the appearance of your report, using the Layout Model view for templates.</td>
<td>Section 3.3, &quot;Creating a template&quot;</td>
</tr>
<tr>
<td>Add your new template to the pre-defined templates list in the Report Wizard so that you can apply it to your report.</td>
<td>Section 3.4, &quot;Adding the new template to the predefined templates list&quot;</td>
</tr>
<tr>
<td>Apply your new template to the report, and view the changes in the Live Previewer.</td>
<td>Section 3.5, &quot;Applying the customized template to the report&quot;</td>
</tr>
<tr>
<td>Change default attributes of the template that are applied globally to the body of the report.</td>
<td>Section 3.6, &quot;Enhancing the default attributes of the template&quot;</td>
</tr>
<tr>
<td>Override default attributes in the Group Above style of the template.</td>
<td>Section 3.7, &quot;Overriding the default attributes of the template&quot;</td>
</tr>
<tr>
<td>Create an additional default layout to illustrate the override attribute changes made to the template.</td>
<td>Section 3.8, &quot;Creating an additional layout&quot;</td>
</tr>
<tr>
<td>Make final format changes to the report.</td>
<td>Section 3.9, &quot;Enhancing the look of the report&quot;</td>
</tr>
</tbody>
</table>
3.1 Creating a data model

The steps in this section will help you create a multi-query data model. First, you will create two queries. Then you will create a break group for the first query. Finally, you will link the two queries.

3.1.1 Building two queries using the SQL Query tool

1. In the Data Model view, click SQL.
2. Click in the Data Model view.
3. In the SQL Query Statement dialog box, enter the following query:

   ```sql
   SELECT ic.category, SUM (h.sales), AVG (h.high_365), AVG (h.low_365),
   AVG (h.div), AVG (h.p_e)
   FROM stock_history h, indcat ic
   WHERE h.symbol=ic.symbol
   GROUP BY ic.category
   ```

4. Click OK. The query by default is labelled Q_1. You will change the query name in a later step.
5. Repeat steps 1 and 2 and enter the following code to create the second query:

   ```sql
   SELECT h.symbol, h.sales, h.high_365, h.low_365, h.div, h.p_e, ic.category
   FROM stock_history h, indcat ic
   WHERE ic.symbol=h.symbol
   ```
6. Click OK. The query by default is labelled Q_2. You will change the query name in a later step.

7. Choose File->Save As. Save the report in the directory of your choice, and name the report temp_311.rdf.

Tip: It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you don’t like some of the changes you made, you easily can go back to the previously saved file and make revisions from that point.

3.1.2 Renaming Data Model objects

In the Data Model view, make the following changes:

1. Click Q_1 and choose Tools->Property Palette.

2. Under the General Information node, set the Name property to Q_ind.

3. Repeat steps 1 and 2 for the following:

### Table 3–2 Column name changes

<table>
<thead>
<tr>
<th>Old Name</th>
<th>New Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>G_category</td>
<td>G_ind_summary</td>
</tr>
<tr>
<td>Q_2</td>
<td>Q_detail</td>
</tr>
</tbody>
</table>

4. Save the report as temp_312.rdf.

3.1.3 Creating a break group

In this section, you will create a break group using the category column in the query Q_ind:

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
   break group, creating

3. Then click Display to view help topic...
   creating a break group

1. In the Data Model view, drag the title bar of the group G_ind_summary down a few inches to make space for a new group.
2. Click and drag the category column above the G_ind_summary group to create a break group called G_category. The result will look similar to the following figure:

3. Save the report as temp_313.rdf.

### 3.1.4 Creating a data link

In this section you will create a data link between G_category and Q_detail.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type data link, creating
3. Then click Display to view help topic...
   creating a data link

1. In the Data Model view, click .
2. Click the G_category group and drag a link to the G_symbol group. Your data model will look similar to the following figure:
3. Save the report as `temp_314.rdf`.

### 3.2 Creating a report

The steps in this section will help you create a default layout using the Report Wizard. You will create the default layout using the Tabular style. Finally, you will format several objects in the report using the Live Previewer view.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
   - default layout, about

3. Then click Display to view help topic...
   - About layout defaulting

### 3.2.1 Creating the default layout


2. On the Style page, click Tabular as the report style.

3. Click Next.

4. On the Groups page, click G_symbol from the Available fields list, then click Down. G_symbol moves to the Displayed Groups list.

5. Click Next.
6. On the Fields page, click symbol, then click to move the field into the Displayed Fields list.

7. Repeat step 6 for the following fields:
   - sales
   - high_365
   - low_365
   - div
   - p_e
   - category1

8. Click Next.

9. On the Labels page, change the labels and widths as shown in the following table:

<table>
<thead>
<tr>
<th>Column</th>
<th>Label</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>symbol</td>
<td>Symbol</td>
<td>5</td>
</tr>
<tr>
<td>sales</td>
<td>Sales</td>
<td>6</td>
</tr>
<tr>
<td>high_365</td>
<td>High Stock</td>
<td>6</td>
</tr>
<tr>
<td>low_365</td>
<td>Low Stock</td>
<td>6</td>
</tr>
<tr>
<td>div</td>
<td>Dividend</td>
<td>6</td>
</tr>
<tr>
<td>p_e</td>
<td>P/E</td>
<td>6</td>
</tr>
<tr>
<td>category1</td>
<td>Industry</td>
<td>6</td>
</tr>
</tbody>
</table>

10. Click Next.

11. On the Template page, click Corporate 2 from the Predefined templates list.
12. Click Finish. The Live Previewer appears. The report will look similar to the following figure:

![Report Preview](image)

13. Save the report as `temp_321.rdf`.

### 3.2.2 Formatting objects using the Live Previewer

You will format several objects in the report by changing the format mask to display numeric values as currency. Finally, you will right justify several objects.

1. With the report displayed in Live Previewer, click the column of data under the Sales heading to select it.

2. Click ![icon](icon) to add a dollar sign.

3. Click ![icon](icon) twice to add two decimal places.

4. Click ![icon](icon) to right justify the object.

5. Repeat steps 1 through 4 for the following:
Tip: You can change several columns at one time: shift-click on all columns and choose Tools->Property Palette.

- Column under High Stock
- Column under Low Stock
- Column under Dividend
- Column under P/E

6. Shift-click the following objects, then click : 

- Sales
- High Stock
- Low Stock
- Dividend
- P/E

The result will look similar to the following figure:

![Image](image_url)

7. Save the report as temp_322.rdf, and close the Live Previewer.
3.3 Creating a template

The steps in this section will help you create a new template using the Template Editor Layout Model while in Edit Margin mode. First, you will open two templates, copy the Confidential watermark from one template and paste it into the other. Next, you will change the color of the Date label and add an HTML page footer to the template. Finally you will create a format trigger that will conditionally display graphics based on the page number of a report.

3.3.1 Creating a new template

8. Open the template corp2.tdf (located in your ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US directory). This is the Corporate 2 template that is currently applied to your report.

9. In the Object Navigator under the Templates node, click to select the CORP2 template. Then choose Tools->Template Editor to display the Layout Model view of the template.

10. Open the second template, conf2.tdf. This template contains a Confidential watermark.

11. In the Object Navigator under the CONF2 node, double-click the Layout Model node to display the Layout Model view of the template. Notice the rectangular box that spans diagonally across the template. This is the watermark.

   Tip: If you do not see the watermark, the Layout Model view might be displaying the Body.

   Click to switch between the Margin and Body. Alternatively, choose View->Layout Section. A check mark next to Edit Margin indicates the Layout Model view is in Margin mode.

12. Click the watermark, then click to copy the watermark.

   Tip: Every object in the Layout Model view is also represented in the Object Navigator. The watermark in the Layout Model view is represented as B_1 in the Object Navigator. To ensure that you have selected the watermark, arrange your workspace to display the Object Navigator and the Layout Model view side-by-side. Expand the CONF2, Layout Model, Section, and Margin nodes in the Object Navigator. When you click the watermark object in the Layout Model view, B_1 under the Margin node in the Object Navigator is highlighted. Your workspace should look similar to the following figure:
13. In the Object Navigator, click the CONF2 node, then choose File->Close without saving any changes.

14. Click the CORP2 node.

15. In the Layout Model view, click the title bar to make it active.

16. Click to paste the watermark into the template.

17. Save CORP2 as cconf.tdf in your ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US directory.

18. In the Layout Model view, click the Date label (the B_DATE1 object in the Object Navigator).

19. Click , then click a color.

20. Save the template again as cconf.tdf.

21. (Optional) Save the template under another name, such as cconf_b1.tdf, as a backup file.

Tip: Backup files are useful when you are making significant changes to your template. If you don’t like some of your changes, you always can go back to a previously saved template and make changes from that point.

22. If you saved the template as a backup, re-open the cconf.tdf template.
3.3.2 Adding an HTML header to the template

You will add an HTML footer to the template using the After Page Type and After Page Value properties.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type...
   HTML output, about
3. Then click Display to view help topic...
   About Web links for HTML output

For your convenience, this HTML footer file and its associated graphics have been provided for this exercise. These files are located in your ORACLE_HOME\TOOLS\DOC60\US\RBR60 directory. They are:

- temp_hdrftr.htm
- oreplogo.gif
- osuplogo.jpg
- ostore.gif
- oracle.gif

1. In the Object Navigator under the Templates node, double-click of the CCONF template to display the Property Palette. Under the Report Escapes node, set the following:

   Table 3–4 Property changes to objects under the Templates node

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>After Page Type</td>
<td>File</td>
</tr>
<tr>
<td>After Page Value</td>
<td>c:\ORACLE_HOME\TOOLS\DOC60\US\RBR60 temp_hdrftr.htm (where “c” is the location of your ORACLE_HOME)</td>
</tr>
</tbody>
</table>

2. Save the template as cconf.tdf.
3. (Optional) Save the template under another name as a backup file, then re-open cconf.tdf.
3.3.3 Creating a format trigger

In this exercise, you will insert two boilerplate images in the margin of the template. Then, you will create a format trigger that will conditionally hide or show each of these images based on the page number.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
   format trigger, description

3. Then click Display to view help topic...
   Format trigger

Two images are provided for this exercise and are located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory. They are:

- t_image1.bmp
- t_image2.bmp

1. With the Layout Model view open, click to insert a linked file.

2. Using the ruler as a guide, click and drag the Link File object at the 7 inch marker, making the object about 1 inch square.

3. If necessary, click:
   - to set the object to no fill
   - to set the object to no line

4. Double-click the Link File object to display the Property Palette.

5. Under the General information node, set the Name property to B_Image1.

6. Under the Link File Boilerplate node, set the following:

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source File Format</td>
<td>Image</td>
</tr>
<tr>
<td>Source Filename</td>
<td>c:\ORACLE_HOME\TOOLS\DOC60\US\RBBR60\t_image1.bmp (where “c” is the location of your ORACLE_HOME)</td>
</tr>
</tbody>
</table>
7. Under the Advanced Layout node, double-click Format Trigger property to display the PL/SQL Editor.

8. Type the following code in the editor. New code is displayed in bold:

   function B_Image1FormatTrigger return boolean is
       F_pge number;
   begin
       srw.get_page_num (F_pge);
       If F_pge=1 then
           return (TRUE);
       Else
           return (FALSE);
       End if;
   end;

9. Click Compile.

10. If any compilation errors occur, check to code for syntax errors and recompile as needed.

11. Click Close.

12. Repeat steps 1 through 11 to insert the second image and set the following properties:

   Under the General Information node, set the Name property to B_Image2.

   Under the Link File node:

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source File Format</td>
<td>Image</td>
</tr>
<tr>
<td>Source Filename</td>
<td>&quot;c:\ORACLE_HOME\TOOLS\DOC60\US\RBBR60\t_\image2.bmp&quot; (where &quot;c&quot; is the location of your ORACLE_HOME)</td>
</tr>
</tbody>
</table>
Adding the new template to the predefined templates list

Under the Advanced Layout node, type the following code in the editor. New code is displayed in bold:

```plsql
function B_Image2FormatTrigger return boolean is
  F_pge number;
begin
  srw.get_page_num (F_pge);
  if F_pge=2 then
    return (TRUE);
  else
    return (FALSE);
  end if;
end;
```

**Tip:** Place the second image directly over the first image.

13. Save the template as cconf.tdf.
14. (Optional) Save the template under another name as a backup file, then re-open cconf.tdf.

3.4 Adding the new template to the predefined templates list

The steps in this section will help you add the new template to the predefined template list in the Report Wizard. First you will look at the Style and Template pages of the Report Wizard to gain a better understanding of how templates are applied to different report styles, such as Tabular and Group Above.

You will add template definitions to a global preference file, which defines the preferences for Report Builder.

Finally, you will apply the new template to your report.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type...
   template, adding to predefined list
3. Then click Display to view help topic...
   Adding a template to a predefined templates list
### 3.4.1 Viewing report styles and the Predefined template list in the Report Wizard

The following steps are an exercise to illustrate how templates are used in the Report Wizard. You will not make changes to your report in this section.

1. In the Object Navigator, click next to your report (last saved as temp_322.rdf), and choose Tools->Report Wizard.

2. On the Style page, click Form-like.

3. On the Template page. Notice the three options:
   - Predefined template list, a convenient way to select a template from a list and apply it to your report.
   - Template file, a way to apply a template to a report by specifying the template location and file name.
   - No template, an option not to apply a template to a report.

4. Choose Predefined template list, then click Corporate 1. Notice the sample graphic of the template style.

5. Go back to the Style page, and choose another report style.

6. Go back to the Template page. Notice that the sample graphic of the report style has changed.
   This is because, by default, a single template contains layout attributes for several report styles. You will learn more about the layout attributes of templates in a later step.

7. Cancel the Report Wizard without making any changes to the report.

8. Choose File->Close to close the report without saving any changes.
3.4.2 Adding the template to the Predefined template list

In the previous exercise, you learned that one template contains layout attributes for several report styles. To make the template available for a particular report style, you must add a template description and file name to Report Builder’s global preference file. In the global preference file, you will define the template for the Tabular style and Group Above style so that they will be available in the Predefined template list in the Report Wizard.

1. In a text editor (e.g., Wordpad), open the global preferences file cagprefs.ora (located in your ORACLE_HOME directory).

   **Tip:** Most global preference changes can be made from Report Builder by selecting Tools->Preferences. For templates, however, you must add template definitions to the Predefined list using a text editor.

2. Scroll down or search for Reports.Tabular_Template_Desc.

3. Add a new line and type “Custom Confidential”, for the template name that will appear in the Predefined template list. See the bold text in the example that follows:

   ```java
   Reports.Tabular_Template_Desc =
   ("Corporate 1",
    "Corporate 2",
    "Confidential Heading",
    "Confidential Background",
    "Custom Confidential",
    "Cyan Grid",
   )
   ```

4. Scroll down to Reports.Tabular_Template_File.

5. Add a new line and type `cconf`, to identify the file name of the template. See the bold text in the example that follows.

   **Tip:** Be sure to place the file name in the same position as the description. For example, if you insert the template description in the fifth line under Reports.Tabular_Template_Desc, you must insert the template file name in the fifth line under Reports.Tabular_Template_File.

   ```java
   Reports.Tabular_Template_File =
   (corp1,
    corp2,
    conf1,
    conf2,
    cconf,
    gngd1,
   )
   ```
Adding the new template to the predefined templates list


7. Add a new line and type "Custom Confidential", for the template name that will appear in the Predefined template list:

   Reports.BreakAbove_Template_Desc =
   ("Corporate 1",
   "Corporate 2",
   "Confidential Heading",
   "Confidential Background",
   "Custom Confidential",
   "Cyan Grid",
   ...


9. Add a new line and type cconf, to identify the file name of the template:

   Reports.BreakAbove_File =
   (corp1,
   corp2,
   conf1,
   conf2,
   cconf,
   gngd1,
   ...

10. Save the changes to the preferences file and close the text editor.

3.4.3 Displaying sample template images in the Template page of the Report Wizard

In addition to adding new templates to the predefined templates list, you can display a sample image when you select the template for a particular report style in the Templates page of the Report Wizard.

For your convenience, two bitmaps are provided for this exercise. These bitmaps must be located in the same directory as the template files.

1. Locate the following bitmaps (in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory):

   - cconf.bmp for the Tabular style sample image
   - cconfa.bmp for the Group-above report style sample image

2. Copy them to your ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US directory.
These bitmaps will display in the Templates page of the Report Wizard when you select the Custom Confidential template for the Tabular and Group Above styles. You will have an opportunity to view these bitmaps in a later step.

3.5 Applying the customized template to the report

The steps in this section will help you apply the new template to the report using the Report Wizard.

1. Close and restart Report Builder for the preferences to take effect. Connect to the database.

2. Choose File->Open to open your report (last saved as temp_322.rdf).

3. In the Object Navigator, click next to your report and choose Tools->Report Wizard.

4. On the Style page, click Group Above.

5. On the Template page, notice that the template, Custom Confidential, appears in the predefined template list.

6. Click Custom Confidential. Notice the sample graphic. It should look like the following figure:

![Sample Graphic]

**Tip:** If the template does not appear in the predefined list, ensure that the template is in the correct directory (located in your ORACLE_ HOME\REPORT60\ADMIN\TEMPLATE\US directory), and that the template description and file are correctly placed in the preferences file. If the sample graphics do not appear, ensure that cconfa.bmp and cconft.bmp are also located in the ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US directory.

7. On the Style page, click Tabular.
8. On the Template page, notice the sample graphic. It should look like the following figure:

![Sample Graphic]

9. Click Finish.

10. The report appears in the Live Previewer. Notice the following:
   - The report imported the template attributes to the report (i.e., the Report run on label changed colors).
   - The currency formatting and justification you made to the report were retained. Report Builder attempts to retain any manual modifications you make to the report when you apply a different template.
   - The confidential heading is hidden. This occurred because the frame fill pattern is set to solid. In a later step, you set the fill pattern in the default section of the template to transparent.
   - An image (i.e., the Oracle logo in black) is displayed in the upper right-hand corner of the report. Right now you can’t check to see if the image changes based on the page number since this report generates only one page. In a later step, you will create an additional report layout that will generate a second page. At that time, you will see that the images change based on the page number.

11. Click to view the report in a Web browser and test the HTML header.

   Notice that the graphics are missing from the header. This occurred because Report Builder generates a temporary HTML file to your ORACLE_HOME\REPORT60\TMP directory. If you would like to preview this report with the header graphics, copy the following graphic files (located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory) to your ORACLE_HOME\REPORT60\TMP directory:

   - oreplogo.gif
   - osuplogo.jpg
   - ostore.gif
   - oracle.gif
12. Close the browser. Click again to disable the Web preview.

Tip: When you are making a lot of little changes to your report, it is sometimes better to turn off the Web preview. Otherwise, the browser is constantly updating for each change that you make.

13. Save the report as temp_350.rdf and close the Live Previewer.

3.6 Enhancing the default attributes of the template

The steps in this section will help you enhance the Custom Confidential (CCONF) template even further. You will change some of the default attributes of the template, such as making objects transparent and changing the font style and color. These changes will be applied globally across all report styles in the template.

The changes you have made to the template so far have affected objects in the margin. The changes you will make to the default attributes will be applied to the objects in the body of the report such as frames, field labels, and fields.

3.6.1 Setting default attributes

1. Choose File->Open to open your template (saved as ).

2. In the Object Navigator under the Templates and CCONF nodes, double-click the Layout Model node to display the CCONF template in the Layout Model view. Ensure that the layout is displaying the Body. Click to switch between the Margin and the Body.

3. In the Object Navigator, expand the Layout Model, Section, Body, Default, and Frames nodes.

Tip: When you select an object in the Object Navigator, it is selected in the Layout Model, and vice versa. Select the object you want to change in the Object Navigator and see the changes in the Layout Model view. You can work easily between these views by arranging your workspace to display the Object Navigator and the Layout Model view side-by-side. This technique is especially useful if you are new to editing in the Layout Model view.

4. Under the Frames node, double-click the Section Frame node. In the Property Palette under the Style node, change the Fill Pattern property to transparent.

Tip: Click to display list of values. Click the value, then click OK to accept it.

5. Use the tables that follow to set the properties of the following objects:
Tip: You can make these changes using the Property Palette. You can also change some properties (i.e., font and color) directly from the Layout Model view using the toolbar or tool palette.

Under the Frames node, set the following:

| Table 3–7 Property changes to objects under the Frames node |
|---------------------------------|------------------|----------------------|
| Object                       | Property Palette node | Property name | Set to:                                           |
| Heads Frame                  | Style              | Foreground Color     | another color from the tool palette, or specify darkblue in the Property Palette |
| Fields Frame                 | Style              | Edge Foreground Color| another color from the tool palette, or specify r0g88b75 in the Property Palette |

Under the Field/Labels Headings node, set the following:

| Table 3–8 Property changes to objects under the Field/Labels Headings node |
|---------------------------------|------------------|----------------------|
| Object                       | Property Palette node | Property name | Set to:                                           |
| Character                    | Labels            | Font               | Bold Italic                                        |
|                              |                   | Text Color         | another color from the tool palette, or specify r0g88b75 in the Property Palette |
| Number                       | Labels            | Font               | Bold Italic                                        |
|                              |                   | Text Color         | another color from the tool palette, or specify r0g88b75 in the Property Palette |
|                              |                   | Number Justification| End                                                   |

Under the Fields node, set the following:

| Table 3–9 Property changes to objects under the Field/Labels Headings node |
|---------------------------------|------------------|----------------------|
| Object                       | Property Palette node | Property name | Set to:                                           |
| Number                       | Fields            | Number Justification | End                                                  |

6. Save the template as cconf.tdf.
3.6.2 Inheriting and localizing property values

The steps in this section are designed to help you understand a template’s Inheritance feature. Inheritance determines the source from which property values are set. Default attribute properties inherit values preset by Report Builder until you change them. When you change properties, their values become localized (or contained within that template).

You can return a property back to its inherited value when you click (the Inheritance button) in the Property Palette. When a property value is inherited by its preset value, the icon next to the property in the Property Palette is a circle.

**Default template property with an inherited value:**

<table>
<thead>
<tr>
<th>Borders</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td></td>
</tr>
</tbody>
</table>

A property value becomes localized when you click (the Localize button) or change the value in the Property Palette. When a property value is localized, the icon next to the property in the Property Palette becomes a square.

**Default template property with a localized value:**

<table>
<thead>
<tr>
<th>Borders</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Bottom Only</td>
</tr>
</tbody>
</table>

1. With the Layout Model view open, in the Object Navigator, find the **Fields Frame** object under the **Frame** node, double-click it to open the Property Palette.

   Under the **Style** node, notice that icon next to the Borders property is a circle, indicating that All is an inherited value.

2. Set the Borders property to Top Only. Notice that the icon changes to a square, indicating that the value is localized.

3. With the Borders property selected, click . Notice that the value returns to its inherited value.

4. Set the Borders property to Bottom Only.

5. Save the template as `cconf.tdf`, and close the Layout Model view of the template.
3.6.3 Applying changes to the template and viewing the results in Live Previewer

1. In the Object Navigator, click on your report and choose Tools->Report Wizard.

2. On the Template page of the Report Wizard, click Custom Confidential, then click Apply.

3. In the Live Previewer, notice that none of your changes took effect (i.e., the watermark is still hidden). Report Builder retains the layout attributes in the report because you applied the same template to the report. Report Builder assumes, in this case, that the changes in the report take precedence over the changes in the template.

Tip: When you are designing your template and want to continuously preview changes in a sample report, you can:

- Delete all objects in the Live Previewer and apply the template by selecting the template in the Predefined template list on the Template page of the Report Wizard, or
- Alternate between selecting the template from the Predefined template list and specifying the template file name on the Template page of the Report Wizard.

4. On the template page of the Report Wizard, click Template file, then Browse. Locate the template file conf.tdf (located in your ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US directory).

5. Click Finish. The report will look similar to the following figure.
6. Save the report as temp_360.rdf and close the Live Previewer
3.7 Overriding the default attributes of the template

The steps in this section will help you override the default attributes in the template. You will override some of the settings for the Group Above style.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type... template, Override
3. Then click Display to view help topic...
   About template attributes

Tip: With the Property Palette open, click to return the selected property back to its inherited value, or click to localize the value.

Override attribute properties inherit their values from the template’s default attributes. When a property inherits a value from the default attribute, the icon next to the property in the Property Palette is an arrow.

Override attribute property with an inherited value:

[Image: Between Sibling Frames (Horizontal) | 0]

When a property is localized, the icon next to the property in the Property Palette becomes an arrow with a red cross through it.

Override attribute property with a localized value:

[Image: Between Sibling Frames (Horizontal) | .1]

See Section 3.6.2, "Inheriting and localizing property values" for more information on inheritance for the template’s default attributes.

1. Display the Layout Model view of the CCONF template. The template layout looks similar to the following figure. If it doesn’t, the layout most likely is in Margin mode.
If necessary, click [ ] to switch to the Body of the template. Notice in the toolbar that the report style is Default. This layout defines the default attributes for the template.

2. Click **Group Above** from the Report Style drop-down list. The layout will look similar to the following figure:

3. In the Object Navigator, if they are not already expanded, expand the **Layout Model**, **Section**, **Body**, **Override**, and **Group Above** nodes.

   Notice that two sections (Level 1 and Level 2) are available. With these section nodes, you can override the default settings at the group level.

   **Tip:** If necessary, you can add more levels using the [ ] tool. For this exercise, however, you will maintain these two section levels.

4. Expand the **Section (Level 1)** node and the **Section (Level 2)** node. Under these nodes, you will change the attributes (i.e., headings, labels, and fields) for the specified group.

5. Double-click the **Section (Level 1)** node.
6. In the Property Palette under the **Spacing** node, set the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inter-Frame (Horizontal)</td>
<td>0.4</td>
</tr>
<tr>
<td>Inter-Frame (Vertical)</td>
<td>0.4</td>
</tr>
</tbody>
</table>

**Tip:** Reviewing the changes in the Layout Model view might be more difficult when you are working with multiple sections. Some of the objects in the Layout Model view may be hidden behind other objects. The best way to review the changes made to the template is to apply it to your report and preview the report in the Live Previewer. For this exercise, however, you will make all the necessary changes first, then review the changes in a later step.

7. Use the table that follows to change the properties of the following objects under the **Section (Level 1)** node.

**Tip:** You can make these changes using the Property Palette. You can also change some properties directly from the Layout Model view, such as the font and color of an object using the toolbar or tool palette.

In the **Frames** node, set the following:

<table>
<thead>
<tr>
<th>Object</th>
<th>Property Palette node</th>
<th>Property name</th>
<th>set to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Headings</td>
<td>Style</td>
<td>Fill Pattern</td>
<td>transparent</td>
</tr>
<tr>
<td>Frame</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fields</td>
<td>Style</td>
<td>Edge Pattern</td>
<td>transparent</td>
</tr>
<tr>
<td>Frame</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

8. Double-click the **Section (Level 2)** node.

9. In the Property Palette under the **Spacing** node, set the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Between Sibling Frames (Horizontal)</td>
<td>0.1</td>
</tr>
<tr>
<td>Between Sibling Frames (Vertical)</td>
<td>0.1</td>
</tr>
</tbody>
</table>
10. Use the tables that follow to set the properties of objects under the Section (Level 2) node. In the Frames node, set the following:

<table>
<thead>
<tr>
<th>Object</th>
<th>Property Palette node</th>
<th>Property name</th>
<th>set to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Headings Frame</td>
<td>Style</td>
<td>Foreground Color</td>
<td>another color from the tool palette, or specify r50g25b50 in the Property Palette</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Edge Pattern</td>
<td>transparent</td>
</tr>
<tr>
<td>Fields Frame</td>
<td>Style</td>
<td>Foreground Color</td>
<td>another color from the tool palette, or specify r88g100b75 in the Property Palette</td>
</tr>
</tbody>
</table>

In the Field Labels/Headings node, set the following:

<table>
<thead>
<tr>
<th>Object</th>
<th>Property Palette node</th>
<th>Property name</th>
<th>set to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character</td>
<td>Labels</td>
<td>Font style</td>
<td>Bold Italic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Font size</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Text color</td>
<td>another color from the tool palette, or specify r88g100b75 in the Property Palette</td>
</tr>
<tr>
<td>Number</td>
<td>Label</td>
<td>Font style</td>
<td>Bold Italic</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Font size</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Text Color</td>
<td>another color from the tool palette, or specify r88g100b75 in the Property Palette</td>
</tr>
</tbody>
</table>
In the **Fields** node, set the following:

<table>
<thead>
<tr>
<th>Object</th>
<th>Property Palette node</th>
<th>Property name</th>
<th>set to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character</td>
<td>Fields</td>
<td>Font Size</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Text color</td>
<td>another color from the tool palette, or specify r0g75b0 in the Property Palette</td>
</tr>
<tr>
<td>Number</td>
<td>Fields</td>
<td>Font Size</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Text Color</td>
<td>another color from the tool palette, or specify r0g75b0 in the Property Palette</td>
</tr>
</tbody>
</table>

11. Save the template as *cconf.tdf*, and close the Layout Model view for the template. You will apply these changes to the report in a later step.

12. (Optional) Save the template as a backup, then re-open *cconf.tdf*.

### 3.8 Creating an additional layout

The steps in this section will help you create an additional layout using the Layout Model view. You will add the Group Above style to the main section of the report. Finally, you will apply the changes made to the template to your report and preview the results in the Live Previewer.

1. Display the Layout Model view of your report (last saved as *temp_360.rdf*).

2. Ensure that you are in the main section of the report.

3. Click 🔄 to create an additional layout area.

4. Using the ruler as a guide, click and drag a rectangle at about the 2 inch marker to define the area of the layout. The Report Wizard appears.

   **Tip:** Click and drag the width of the logical page to ensure you have enough room to insert all the selected fields. The logical page is delimited by a solid black line in the Layout Model view. If you make the layout bigger than the logical page, you will get an error when you run the report.

5. On the Style page, click **Group Above**, and type the name of the report *Stock Summary by Industry* in the Title field.
6. Click Next.

7. On the Groups page, select the following groups and directions:
   - click **G_category**, then click **Down**
   - click **G_ind_summary**, then click **Across**
   - click **G_symbol**, then click **Down**

8. Click Next.

9. On the Fields page, click to move all fields to the Displayed Fields list.

10. Click **category1** in the Displayed Fields list, then click . You should now have the following fields in the Displayed fields list:
   - category
   - SUM_h_sales
   - AVG_h_high_365
   - AVG_h_low_365
   - AVG_h_div
   - AVG_h_p_e
   - symbol
   - sales
   - high_365
   - low_365
   - div
   - p_e

11. Click Next.
12. On the Labels page, change the following columns as shown in the table:

<table>
<thead>
<tr>
<th>Column</th>
<th>Label</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>category</td>
<td>Category:</td>
<td>10</td>
</tr>
<tr>
<td>SUM_h_sales</td>
<td>Total Sales</td>
<td>6</td>
</tr>
<tr>
<td>AVG_h_high_365</td>
<td>Avg High Stock</td>
<td>6</td>
</tr>
<tr>
<td>AVG_h_low_365</td>
<td>Avg Low Stock</td>
<td>6</td>
</tr>
<tr>
<td>AVG_h_div</td>
<td>Avg Dividend</td>
<td>6</td>
</tr>
<tr>
<td>AVG_h_p_e</td>
<td>Avg P/E</td>
<td>6</td>
</tr>
</tbody>
</table>

13. Click Next.
14. On the Template page, click Predefined template, then click Custom Confidential.
15. Click Finish.

**Tip:** If the default layout region that you defined is too small, a message will appear asking if you want to extend the layout to the page boundaries. Click Yes.
16. In the Object Navigator, type `M_G_CATEGORY_GRPFR` in the Find field to locate this object. Note that the search occurs as you type, so you will most likely be taken to the object before you finish typing the entire name.
17. Choose Tools->Property Palette.
18. Under the General Layout node, set the Page Break Before property to Yes.
19. Click to view the report in Live Previewer.

20. Click to view the additional layout. The report will look similar to the following figure. Notice that logo in the upper right-hand corner of the report has changed to red.
3.9 Enhancing the look of the report

The steps in this section are optional. They will help you enhance the look of the Group Above report. You will format the numeric values as currency.

Tip: If you re-enter the Report Wizard after making manual refinements in the Live Previewer, you will lose some of your changes when you click Apply or Finish in the wizard, and your layout will default back to the state defined by the wizard.

1. With the report displayed in Live Previewer, click the column next to the Total Sales heading.

2. Click .

3. Click once.
4. Repeat steps 1 through 3 for the following:
   - Column next to Avg High Stock
   - Column next to Avg Low Stock
   - Column next to Avg Dividend
   - Column next to Avg P/E
   - Column under Sales
   - Column under High Stock
   - Column under Low Stock
   - Column under Dividend
   - Column under P/E

   The report will look similar to the following figure:

![Report](image)

5. Save the report as `temp_390.rdf`. 
3.10 Summary

Congratulations! You have finished the Templates sample report. You now know how to:

- Create a multi-query data model with data links.
- Use a pre-defined template to create a report, and modify the report in the Live Previewer.
- Create a new template using the Layout Model view.
- Add templates to the Report Wizard.
- Apply templates to a report.
- Change the global default attributes of a template.
- Override default attributes of a template.

For more information about templates, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type...
   template, about
3. Then click Display to view help topic...
   About templates
The report described in this chapter is designed to help you learn more about Report Builder features for the Web.

To build this report, you will use the Report Wizard to create a data model. Then, you will use the Web Wizard to create an HTML report. You will make fairly extensive manual refinements in the Layout Model view and the Live Previewer. In particular, you will use the Web Settings properties. You will use the Chart Wizard to create a chart, and then return to the Web Wizard to add chart hyperlinks.

To view your Web report, you will need a Web browser, such as Netscape 3.x or higher, or Internet Explorer 3.x or higher, that supports HTML style sheets and Javascript.

In this example, you will create:

- a detailed Web report containing additional HTML pages, Web links, and Javascript that shows the sales and profit results from a video sales company.
- a one-page executive summary containing a chart with chart hyperlinks.

The following figure illustrates the various Web features that you will add to your Web report. Table 4–1, "Features demonstrated in this Web sample report", describes the steps you will take to enhance your report with these Web features.
Add bookmarks with links to Sales Results, Section 4.4.

Add pop-up text that will display when dragging the mouse over the object. Section 4.7.

Add an HTML file to display a header title and graphic on every page. Section 4.3.

Insert a chart with hyperlinks to detailed Sales Results. Section 4.9.

Set Sales Results as a hyperlink destination. Section 4.6.

Add a hyperlink that points to an external Web page. Section 4.8.

Add a rollover to animate an object when dragging the mouse over the object. Section 4.10.

Add a rollover to display text in the hint line. Section 4.7.

Add navigational controls using Javascript. Section 4.10.

Click will display the Internet Movie Database.
To build this report, you will need the following files, which are located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory:

- rbweb_hdr.htm
- rbweb_ps.htm
- 1.gif
- 3.gif
- chalk.jpg
- imdb.bmp
- drama.gif
- 14 .GIFs containing page, first, back, or next as part of file name (e.g., page-e.gif).

The web.rdf file contains the report you will create after finishing the tasks in this chapter. You may want to refer to this file while you are working. This file is located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory.

**Table 4–1 Features demonstrated in this Web sample report**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Report Wizard to create a single query and a default layout.</td>
<td>Section 4.1, &quot;Creating a data model&quot;</td>
</tr>
<tr>
<td>Modify the look of your report by adding format masks to the numeric values and changing the number of rows to fetch.</td>
<td>Section 4.2, &quot;Modifying the look of your report output&quot;</td>
</tr>
<tr>
<td>Add other HTML files to implement special effects and display static objects on every page.</td>
<td>Section 4.3, &quot;Including an HTML report header&quot;</td>
</tr>
<tr>
<td>Add bookmarks to report values to facilitate navigation within your report.</td>
<td>Section 4.4, &quot;Adding bookmarks to parts of your report&quot;</td>
</tr>
<tr>
<td>Eliminate the gray page separator line that automatically appears between pages.</td>
<td>Section 4.5, &quot;Changing the page separator&quot;</td>
</tr>
<tr>
<td>Add targets to your report. Then, add hyperlink destinations within your report and to external Web sites.</td>
<td>Section 4.6, &quot;Adding hyperlink destinations and hyperlinks&quot;</td>
</tr>
<tr>
<td>Display pop-ups and rollovers as the user’s cursor rolls over an image or hyperlink in your report.</td>
<td>Section 4.7, &quot;Displaying pop-ups and rollovers in HTML output&quot;</td>
</tr>
<tr>
<td>Conditionally hide and show items for Web output.</td>
<td>Section 4.8, &quot;Using PL/SQL to conditionally hide/show objects for Web output&quot;</td>
</tr>
</tbody>
</table>
Creating a data model

4.1 Creating a data model

The steps in this section will help you use the Report Wizard to create a data model with a single query and a report with a default layout.

1. If the Welcome page of the Report Wizard appears, click Next.
2. On the Style page, click Matrix with Group.
3. Click Next.
4. If the Type page appears, click SQL statement, and click Next. The Type page will appear only if you have configured Report Builder to run with Oracle Express.
5. On the Data page, click Query Builder.

To get started, open Report Builder. If the Welcome dialog box appears, click Use the Report Wizard and click OK. If not, choose File->New->Report. Click Use the Report Wizard and click OK.

At some point before you generate the report, you will need to log into the database. Choose File->Connect to connect to the database. Enter the appropriate log on information. See Section 1.3, "Obtaining database access before you start" for details.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create an executive summary section that contains a chart.</td>
<td>Section 4.9, &quot;Creating a summary section with a chart&quot;</td>
</tr>
<tr>
<td>Create special effects using Javascript.</td>
<td>Section 4.10, &quot;Adding Javascript&quot;</td>
</tr>
<tr>
<td>Run your report using the Oracle Reports Server.</td>
<td>Section 4.11, &quot;Running the Web report from the Reports Server&quot;</td>
</tr>
</tbody>
</table>

Table 4–1 Features demonstrated in this Web sample report

To run your report using the Oracle Reports Server. See Section 4.11, "Running the Web report from the Reports Server" for details.

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type... report, building
3. Then click Display to view help topic... Building a standard report

1. If the Welcome page of the Report Wizard appears, click Next.
2. On the Style page, click Matrix with Group.
3. Click Next.
4. If the Type page appears, click SQL statement, and click Next. The Type page will appear only if you have configured Report Builder to run with Oracle Express.
5. On the Data page, click Query Builder.
6. In the Select Data Tables dialog box, click VIDEO_CATEGORY_BY_QTR.

7. Click Include.

8. Click Close.

9. Click .

Tip: Doing so checks all of the column check boxes.

10. Click the Condition field in the left-hand pane so that your cursor displays in the field.

11. In the Query window, click the SALES REGION column in the table.

12. In the Condition field, place your cursor after “SALES REGION”.

13. Type =’West’.

14. Click in the toolbar.

Tip: You now should see SALES_REGION=’West’ in the Condition field.

15. Click OK.

16. Click Next.

17. On the Groups page, click QUARTER, then click to move it into the Matrix Group Fields list.

18. Repeat step 17 to move the STATE field to the Matrix Group Fields list.

19. Click Next.

20. On the Rows page, click PRODUCT_CATEGORY, then click to move the field into the Matrix Row Fields list.

21. Click Next.
22. On the Columns page, click CITY, then click \( \rightarrow \) to move the field into the Matrix Column Fields list.

23. Click Next.

24. On the Cells page, click TOTAL_COST, then click \( \rightarrow \) to move the field into the Matrix Cell Fields list.

25. Repeat step 24 to move the following fields into the Matrix Cell Fields list:

   - TOTAL_SALES
   - TOTAL_PROFIT

26. Click Next.

27. On the Totals page, click TOTAL_COST, then click **Sum** to move the sum of the TOTAL_COST field into the Matrix Totals list.

28. Repeat step 27 to move the sums of the following fields to the Matrix Totals list:

   - TOTAL_SALES
   - TOTAL_PROFIT

29. Click Next.

30. On the Labels page, modify the widths as shown in the following table:

\[
\begin{array}{|c|c|}
\hline
\text{Column} & \text{Width} \\
\hline
\text{STATE} & 2 \\
\text{TOTAL SALES} & 6 \\
\text{TOTAL COST} & 6 \\
\text{TOTAL PROFIT} & 6 \\
\text{All Sum... columns} & 6 \\
\hline
\end{array}
\]

31. Click Next.

32. On the Template page, under Predefined templates, click the **Corporate 1** template.

33. Click Finish.
34. Choose File->Save As. Save the report in the directory of your choice, and name the report web_41.rdf.

Tip: It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you don't like some of the changes you made, you easily can go back to the previously saved file and make revisions from that point.

4.2 Modifying the look of your report output

The steps in this section will help you modify the appearance of data by using format masks and changing the maximum rows of data returned by your query.

4.2.1 Modifying the layout in the Live Previewer

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type...
   object, deleting
3. Then click Display to view help topic...
   Deleting an object

1. In the Live Previewer, click the image in the header to select it, and press DELETE.
2. Select the date and boilerplate text object labeled “Report run on:”. You can select the objects by shift-clicking on each object.
3. Press DELETE.
4. Click to go to the Layout Model view.
5. In the Object Navigator, place your cursor in the Find field and type F_SumTOTAL_SALESPerPRODUCT_CATEGORY.
6. Press DELETE.
7. Repeat steps 5 and 6 to delete these fields:
   - F_SumTOTAL_COSTPerPRODUCT_CATEGORY
   - F_SumTOTAL_PROFITPerPRODUCT_CATEGORY
   - F_SumTOTAL_SALESPerSTATE
   - F_SumTOTAL_COSTPerSTATE
   - F_SumTOTAL_PROFITPerSTATE
8. Click to go to the Live Previewer.

9. In the Live Previewer, click to go to the last page of the report.

10. Delete the following fields and their labels:

   ■ F_SumTOTAL_SALESPerReport
   ■ F_SumTOTAL_COSTPerReport
   ■ F_SumTOTAL_PROFITPerReport
   ■ the page number at the bottom of the page

Tip: You can view the name of any object by clicking on it once, then choosing Tools->Property Palette to view the Name property.

11. Save your report as web_412.rdf. Your output should look something like the following figure in the Live Previewer:

![Quarter 11-95
State AZ
Product Category City:Phoenix
Total Sales  Total Cost  Total Profit
Action  620.95  212  408.95
Children  499.51  172.67  316.64
Comedy  595.49  136.77  246.72
Drama  392.99  122.2  170.78
Horror  111  76.57  136.63
Romantic Comedy  269  231.65  458.01
SciFi  210.34  86.65  123.67
Western  286.46  116.24  368.22
Thriller  1468.8  1338.96  229.82]

4.2.2 Adding format masks

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
   format mask, applying to numeric object

3. Then click Display to view help topic...
   Applying a format mask to a numeric object

1. In the Live Previewer, click on the F_TOTAL_SALES column of data (located under the Total Sales title of data).
2. Click ☛ to add the dollar sign to each value.

3. Click + twice to add two decimal places.

4. Select all of the following objects by shift-clicking each object, then follow steps 2 and 3 to set the format masks:
   - Total Cost column of data
   - Total Profit column of data
   - F_SumTOTAL_SALESPerCITY (the last field in the Total Sales column)
   - F_SumTOTAL_COSTPerCITY (the last field in the Total Cost column)
   - F_SumTOTAL_PROFITPerCITY (the last field in the Total Profit column)

5. Click ☞ to go to the last page of the report.

6. Select all of the following objects by shift-clicking each object, then follow steps 2 and 3 to set the format masks:
   - F_SumTOTAL_SALESPerQUARTER
   - F_SumTOTAL_COSTPerQUARTER
   - F_SumTOTAL_PROFITPerQUARTER

4.2.3 Changing the maximum number of rows returned by your query

When designing a large report (i.e., one that retrieves many records), it is helpful to reduce the number of records retrieved during the design and test phases of the project.

1. In the Live Previewer, click ☛ to access the Data Model view.

2. In the Data Model view, click on Q_1.

3. Choose Tools->Property Palette.

4. In the Property Palette, under the Query node, set the Maximum Rows to Fetch property to 100.

   Tip: Note that you can change this property according to the number of rows you want to view. However, the more rows you fetch, the longer it will take for your browser to load your HTML output. When you are done designing your
Including an HTML report header

report and you want to see all of the rows of data, you should reset this
property to blank.

5. Press RETURN or ENTER.

6. Save your report as web_42.rdf.

4.3 Including an HTML report header

The steps in this section will help you to add an HTML file to your report. This will
add a title and graphic to your HTML output. It will also add a background to
every page of your HTML output. The HTML report header page contains the
information in the <HEAD> tag of your HTML output.

1. In the Object Navigator, click next to your report.

2. Choose Tools->Property Palette.

3. In the Property Palette, under the Report Escapes node, set the Before Report
   Type property to File.

4. Set the Before Report Value property to your directory\rweb_hdr.htm.

   Tip: You can click on the browse (...) button to locate this file. This file should be
   located in your ORACLE_HOME\TOOLS\DOC60\US\RBRR60 directory.

5. Optional: At this point, you can also return to the Layout Model view and
   modify the colors of the text and field objects in your layout. You can do this by
   clicking on each object, then clicking (or the other two icons above and
   below it) and choosing a color from the palette.

6. In the Object Navigator, click next to your report.

7. Save your report output as web_43.rdf.

8. Generate HTML output by choosing File->Generate to File->HTML Style
   Sheet. When prompted, save your report output as web_43.htm.

9. Open web_43.htm in your Web browser. Confirm that the title “21st Century
   Video” and a graphic appear at the beginning of your report.
Tip: At this point, your layout may overlay part of the header. This will be fixed in a later step. Note also that you can add other HTML files to your report by using the other properties under Report Escapes.

Your HTML output should look something like the following figure:

4.4 Adding bookmarks to parts of your report

The steps in this section will help you to add bookmarks to your report and generate HTML output:

1. Go from your web browser to Report Builder, if you are not already there.
2. In the Live Previewer, choose Tools->Web Wizard.
3. If the Welcome page of the Web Wizard appears, click Next.
4. On the Bookmarks page, move the QUARTER and STATE columns to the Bookmarks list by selecting each, and clicking .
5. Click Next.
6. On the HTML Headers/Footers page, you should see the HTML header file you added to your report in Section 4.3, "Including an HTML report header". Click Next.
7. On the Finished page, click **Generate HTML style sheet output now**. Note that if you check the **Generate to Web Browser** check box, not all of the additional HTML files you’ve added will display.

8. Click **Finish**. You will be prompted to choose a file name and directory. Save your file as `web_44.htm`.

9. In the Object Navigator, click **Next** next to your report.

10. Save your report output as `web_44.rdf`.

11. Open `web_44.htm` in your Web browser. Click on some of the bookmarks to check that they work properly.

   Your HTML output should look something like the following figure:

![HTML output example](image)

### 4.5 Changing the page separator

While viewing the HTML output in your browser, you will notice a gray line separating each “page” of your output. The steps in this section will help you to remove that page separator.

1. In the Object Navigator, click **Next** next to your report.

2. Choose Tools->Property Palette.
3. In the Property Palette, under the Report Escapes node, delete the After Page Value property.

4. In the Object Navigator, click next to your report.

5. Save your report output as web_45.rdf.


7. When prompted, save the HTML output as web_45.htm.

8. Open web_45.htm in your Web browser to confirm the page separator no longer displays between pages. You can compare web_45.htm to web_44.htm.

4.6 Adding hyperlink destinations and hyperlinks

In your HTML output, you may want to add hyperlinks so that you can click on text or images to access other hyperlink destinations, such as external URLs or other destinations within your report. The steps in this section will help you to add targets to your Web report, and then add hyperlinks that link to the targets, as well as to external hyperlink destinations.

4.6.1 Adding hyperlink destinations

1. In the Layout Model view, choose Edit->Select All to select all the objects, and move the entire selection down 0.5 inches.

   Tip: In addition to dragging with the mouse, you can also move selected objects using the arrow keys.

2. Click to create a boilerplate text object above the layout, and type Sales Results.
Tip: You can use the color-changing tools in the tool palette to modify the look of this text object.

3. Choose Tools->Property Palette.

4. In the Property Palette, under the General Information node, set the Name property to Text_RptTop.

5. Under the Web Settings node, set the Hyperlink Destination property to rpt_top.

6. In the Object Navigator, click next to your report.

7. Save your report output as web_461.rdf. This text object is the target of a hyperlink you will create in a later step.

4.6.2 Adding hyperlinks to destinations within the report

1. In the Layout Model view, click —. Repeating steps 2 and 3 of Section 4.6.1, "Adding hyperlink destinations", create a boilerplate text object below the layout, and type Back to Top.

2. Under the General Information node, set the Name property to text_totop.

3. Under the Web Settings node, set the Hyperlink property to #rpt_top.

4. In the Object Navigator, click next to your report.

5. Save your report output as web_462.rdf.

4.6.3 Adding hyperlinks to external destinations

1. In the Layout Model view, choose File->Import->Image.
2. In the **Import Image** dialog box, click **File**. Then either type the path and name of the image (**imdb.bmp**), or click **Browse** to find the file.

3. Click **OK**.

4. In the Layout Model view, click on the image object you just imported, and drag it down below the table and the boilerplate text object labeled “Back to Top”.

5. Choose **Tools->Property Palette**.

6. In the Property Palette, under the **General Information** node, set the **Name** property to **IMDB_BMP**.

7. Click **T** to create a boilerplate text object below the table. Type *For more information, go to the Internet Movie Database.*

8. When finished, click **.**

9. Click on the boilerplate text object you just created.

10. Click **.**

11. In the color palette, click a color, such as blue.

   **Tip:** You can also choose colors for the background of the textbox, or remove the line from the border of the textbox.

12. Shift-click the image object and the new boilerplate text object.

13. Choose **Tools->Property Palette**.

14. In the Property Palette, under the **Web Settings** node, set the **Hyperlink** property to **http://www.imdb.com**.

15. In the Layout Model view, select the boilerplate text object labeled “For more information, go to the Internet Movie Database”.

16. Choose **Tools->Property Palette**.

17. In the Property Palette, under the **General Information** node, set the **Name** property to **IMDB_text**.
Adding hyperlink destinations and hyperlinks

Your current layout should look similar to the following figure:

- In the Object Navigator, click next to your report.
- Save your report output as web_463.rdf.
- Generate HTML output by choosing File->Generate to File->HTML Style Sheet.
- When prompted, save your report output as web_463.htm.
- Open web_463.htm in your Web browser to confirm that the new hyperlinks work properly.
4.7 Displaying pop-ups and rollovers in HTML output

You can further enhance objects that contain hyperlinks by adding pop-ups and rollovers that contain textual descriptions. The steps in this section will help you to create pop-up and rollover text that displays when you drag the mouse over an object in your HTML report.

4.7.1 Adding a pop-up to an image object

1. In the Object Navigator, place your cursor in the Find field and type IMDB_BMP.
2. Choose Tools->Property Palette to display the Property Palette for the imported image object.
3. For online help on this topic, choose Help->Report Builder Help Topics
   On the Index page, type...
   display name property
   Then click Display to view help topic...
   Display Name
3. In the Property Palette, under the **Web Settings** node, set the Display Name (HTML) property to *Internet Movie Database*.

4. In the Object Navigator, click \( \text{Next} \) next to your report.

5. Save your report output as **web_471.rdf**.

6. Generate HTML output by choosing **File->Generate to File->HTML Style Sheet**.

7. When prompted, save your report output as **web_471.htm**.

8. Open **web_471.htm** in your Web browser.

9. Drag your mouse over the image object to view the pop-up text that displays over the object.

### 4.7.2 Adding a rollover to an image object

1. In the Object Navigator, under the **Main Section** node, then the **Body** node, click \( \text{Next} \) next to **IMDB_BMP**.

2. Choose **Tools->Property Palette**.

3. In the Property Palette, under the **Web Settings** node, set the Additional Hyperlink Attributes (HTML) to:

   ```html
   onMouseover="window.status='Clicking here will display the Internet Movie Database home page.';return true"
   onMouseOut="window.status=' ';return true"
   ```

4. Press RETURN or ENTER to make sure the property is set.

5. In the Object Navigator, click \( \text{Next} \) next to your report.

6. Save your report output as **web_472.rdf**.

7. Generate HTML output by choosing **File->Generate to File->HTML Style Sheet**.

8. When prompted, save your report output as **web_472.htm**.


10. Drag your mouse over the image object to view the rollover text in the hint line of your browser. Note that you will have to scroll down to the end of the HTML document in order to view the image object.
4.8 Using PL/SQL to conditionally hide/show objects for Web output

The steps in this section will help you to specify that certain objects, such as page numbers, will not display in your HTML, HTMLCSS, or PDF output. However, these items will still display in other report file formats.

1. In the Layout Model view, click the boilerplate text object labeled “Back to Top”.
2. Choose Tools->Property Palette.
3. Under the Advanced Layout node, set the Format Trigger property to:

```sql
function text_totop1FormatTrigger return boolean is
begin
  if UPPER(:DESFORMAT) = 'HTML' or
     UPPER(:DESFORMAT) = 'HTMLCSS' or
     UPPER(:DESFORMAT) = 'PDF'
  then
    return (TRUE);
  else
    return (FALSE);
  end if;
end;
```

4. Click Compile.
5. If any compilation errors occur, check the code for syntax errors, and recompile as needed.
6. Click Close.
7. In the Object Navigator, click next to your report.
8. Save your report output as web_48.rdf.
9. Click to view your report output in Report Builder’s Live Previewer.
12. Open web_48.htm in your Web browser. Compare your HTML output to your report output in the Report Builder Live Previewer. The boilerplate text object labeled “Back to Top” should display in your browser, but not in the Live Previewer.
4.9 Creating a summary section with a chart

The steps in this section will help you to create a summary section for your report, and include a pie chart in the summary section.

4.9.1 Creating the data model for the summary section

1. Return to Report Builder from the web browser if you are not already there.
2. In the Data Model view, click SQL and click on the canvas region.
   Tip: If the Data Model tool palette is not displayed, choose View->Property Palette.
3. In the SQL Query Statement dialog box, click Query Builder.
4. In the Select Data Tables dialog box, click VIDEO_CATEGORY_BY_QTR.
5. Click Include.
6. Click Close.
7. In Query Builder, check the QUARTER column check box and the TOTAL PROFIT column check box in the table.
8. In the Condition field, type the condition:
   \[ \text{SALES_REGION='West' AND TOTAL\_PROFIT>2000} \]
9. Click .
10. Click OK.
11. In the SQL Query Statement dialog box, click OK.
12. In the Object Navigator, click next to your report.
13. Save your report output as \text{web\_491.rdf}.
4.9.2 Creating the default layout for the summary section

1. In the Layout Model view, click to access the Header section of your report.

2. In the Header section, click to create a boilerplate text object at the top of the layout. Type Executive Summary of Video Sales.

3. Click on the boilerplate text object you just created, then choose Format->Font.

4. In the Font dialog box, choose a font, such as Footlight MT Light, then click OK.

   Tip: While the boilerplate text object is still selected, you can change the font and fill colors.

5. Click to create a boilerplate text object below the one you’ve just created. Type Quarter Profits.

6. Click and create a repeating frame that is about 3 inches wide and 0.5 inches tall about 4 inches from the top of the layout.

7. Choose Tools->Property Palette.

8. In the Property Palette, under the General Information node, set the Name property to R_execprof.

9. Under the Repeating Frame node, set the Source property to G_QUARTER1.

10. Click and create a field that fits inside the repeating frame (approximately 1.5 inches wide and 0.25 inches tall).

12. In the Property Palette, under the **General Information** node, set the Name property to `F_qrtr`.

13. Under the **Field** node, set the Source property to `QUARTER1`.

14. Repeat steps 10 and 11 to create a second field. Set the following properties:

   **Table 4–3 Property settings for second field**

<table>
<thead>
<tr>
<th>Node</th>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>Name</td>
<td><code>F_proffld</code></td>
</tr>
<tr>
<td>Field</td>
<td>Source</td>
<td><code>TOTAL_PROFIT1</code></td>
</tr>
<tr>
<td></td>
<td>Format Mask</td>
<td><code>$NNN,NN0.NN</code></td>
</tr>
</tbody>
</table>

15. Arrange the layout to look similar to the following figure:

16. Click ![check](image) to check that your query and layout work properly.

   **Tip:** If you receive PL/SQL errors, you can try choosing **Program->Compile->All** to compile your format triggers.

17. In the Object Navigator, click ![next](image) next to your report.

18. Save your report as `web_492.rdf`.

19. Generate HTML output by choosing **File->Generate to File->HTML Style Sheet**.

20. When prompted, save your report output as `web_492.htm`.

21. Open `web_492.htm` in your Web browser to confirm that the first page displays your new header page.
4.9.3 Creating a chart for the summary section

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type... chart, creating
3. Then click Display to view help topic... Creating a Graphics Builder chart

1. In the Layout Model view, if you are not in the Header section, click .
2. Click to bring up the Chart Wizard.
   Tip: When you launch the Chart Wizard, Oracle Graphics Builder runs in the background. On Windows, you should see this application in your taskbar.
3. If the Welcome page of the Chart Wizard displays, click Next.
4. On the Type page, click Pie in the Chart Type list and Depth in the Chart Subtype list.
5. Click Next.
6. On the Data Group page, click G_QUARTER1(QUARTER1,TOTAL_PROFIT1).
7. Click Next.
8. On the Category page, click on QUARTER1, then click to move the field into the Category Axis list.
9. Click Next.
10. On the Value page, click on TOTAL_PROFIT1, then click to move the field into the Value Axis list.
11. Click Next.
12. On the Break page, choose to display the chart at the beginning of the report.
13. Click Next.
14. On the File page, click Save As. When prompted, use the file name rbweb_chart.ogd. Save the file in the same directory as your .RDF and .HTM files.

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type... files, supported file types
3. Then click Display to view help topic... Supported files

15. Click Finish.
16. Click on the chart object.
17. Choose Tools->Property Palette.
18. In the Property Palette, under the General Information node, set the Name property to rbweb_chart.
19. Resize the chart and re-arrange the layout to look similar to the following figure:

![Executive Summary of Video Sales](chart_image.png)

20. In the Object Navigator, click ![icon](folder_icon.png) next to your report.
21. Save your report output as web_493.rdf.
22. Generate HTML output by choosing File->Generate to File->HTML Style Sheet.
23. When prompted, save your report output as web_493.htm.
24. Open web_493.htm in your Web browser to confirm that a chart displays on the first page of your output.
4.9.4 Adding hyperlinks to your chart

You can also add hyperlinks to your chart that will drill down to corresponding data. In this exercise, you will create hyperlinks from the pie chart to the summary report you created in Section 4.9.2, "Creating the default layout for the summary section".

1. In the Layout Model view, click the Chart object.
2. Choose Tools->Property Palette.
   1. In the Property Palette, under the Chart node, set the Chart Hyperlink property to #rbweb_chart&<Total_Profit1>.
   2. In the Object Navigator, place your cursor in the Find field and type F_PROFFLD.
3. Choose Tools->Property Palette.
   1. In the Property Palette, under the Web Settings node, set the Hyperlink Destination property to rbweb_chart&<Total_Profit1>.
   2. Save your report as web_494.rdf.
4. Open web_494.htm in your Web browser click an area on the pie chart to access the corresponding data in the report.
4.10 Adding Javascript

The steps in this section will help you to add Javascript to your Web report. Doing so will create additional special effects for your report, such as animation and customized navigational controls.

In order for the Javascript in this exercise to work properly, you should have completed Section 4.9, "Creating a summary section with a chart" and Section 4.3, "Including an HTML report header".

4.10.1 Creating animated objects

In this exercise, you will add Javascript to a text object that, when open in a Web browser, will change an image object from blue to red when you pass your mouse over the image.

To complete this exercise, you will need the 1.gif.

1. Copy the 1.gif file (located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory) to the destination directory (the location where the generated HTML files will reside).

2. In the Layout Model view, if you are not in the Main section, click .

3. Choose Tools->Property Palette.

4. Drag the entire selection up to the top of the Layout Model view (so that there is no empty space between the top margin and the boilerplate text object labeled “Sales Results”).

5. Click and create a boilerplate text object about 0.5 inches by 0.5 inches, directly below the layout.

6. Type the following Javascript into the boilerplate text object:

   ```html
   <a href="#webrep_bottom" onmouseover="document.images['example'].src=image02.src" onmouseout="document.images['example'].src=image01.src">
     <img src="1.gif" name="example" border=0></a>
   ```

7. Choose Tools->Property Palette.

8. In the Property Palette, under the General Information node, set the Name property to B_JS.
9. Under the **Web Settings** node, set the Contains HTML Tags property to Yes. Note that part of the necessary Javascript coding has already been entered into the head of your HTML output (the `rbweb_hdr.htm` file). In the next step you will add the Javascript to the body of your HTML output.

10. Under the **Advanced Layout** node, set the Format Trigger property to:

```javascript
function B_JSFormatTrigger return boolean is
begin
  if UPPER(:DESFORMAT) = 'HTML' or
     UPPER(:DESFORMAT) = 'HTMLCSS' or
     UPPER(:DESFORMAT) = 'PDF'
  then
    return (TRUE);
  else
    return (FALSE);
  end if;
end;
```

11. Click **Compile**.

12. If any compilation errors occur, check the code for syntax errors, and recompile as needed.

13. Click **Close**.

14. Set the **Print Object On** property to All Pages.

15. In the Layout Model view, create a boilerplate text object labeled Click on the arrow to view the Executive Summary. Place this object next to the boilerplate text object containing the Javascript (B_JS).

16. Choose **Tools->Property Palette**.

17. In the Property Palette, under the **Advanced Layout** node, set the **Print Object On** property to All Pages.

18. In the Object Navigator, click next to your report.

19. Save your report output as `web_4101.rdf`.

20. Generate HTML output by choosing **File->Generate to File->HTML Style Sheet**.

21. When prompted, save your report output as `web_4101.htm`.

22. Open `web_4101.htm` in your Web browser and confirm that the boilerplate text object you created displays. You should also see a blue arrow that turns red when you drag your mouse over it.
Tip: You can click on this arrow to access your Executive Summary if you’ve completed Section 4.9, “Creating a summary section with a chart”. You can also repeat step 3 in Section 4.8, “Using PL/SQL to conditionally hide/show objects for Web output” to conditionally show/hide the objects you created in this section, so that they only display in your HTML output.

4.10.2 Using HTML page streaming

You can use HTML page streaming in your Web report to display navigational controls so that users can easily move from one page to another. HTML page streaming enables you to display individual pages of your HTML/HTMLCSS report output in your Web browser, without having to download the entire report. From the first page of the report, you can navigate to any page in the rest of the report. When you click a bookmark or hyperlink with a destination:

- within the report, the frame that contains the current page will update with the destination page.
- outside the report, the entire base frame (including the bookmark frame, the page, and the navigation frame) will reload.

Report Builder provides default page streaming controls. For this exercise, however, you will use customized the navigational controls. For your convenience, the graphics and javascript needed to create the customized controls have been provided. They are:

- rbweb_ps.htm, which contains the javascript
- 14 .GIFs containing page, first, back, or next as part of file name (e.g., page-e.gif)

1. Copy the .GIF and .HTM files (located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory) to the destination directory (the location where the generated HTML files will reside).

2. In the Object Navigator, click next to your report.

3. Choose Tools->Property Palette.
4. In the Property Palette, under the **Report Escapes** node, set the following properties:

<table>
<thead>
<tr>
<th>Property Setting</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Navigation Control Type</td>
<td>File</td>
</tr>
<tr>
<td>Page Navigation Control Value</td>
<td>ORACLE_HOME\TOOLS\DOC60\US\RBR60\rbweb_ps.htm</td>
</tr>
</tbody>
</table>

5. Save your report output as `web_4102.rdf`.


7. Restart Report Builder from the command line by typing the following:

   `rwbld60 pagestream=yes`.

8. Open the report (last saved as `web_4102.rdf`).

9. Connect to the database.

10. Generate HTML output by choosing **File->Connect**.

11. Choose

12. In the Object Navigator, click ![next to your report.](image)


14. Open `web_4102.htm` in your Web browser and confirm that the navigational controls display.

---

1. For online help on this topic, choose **Help->Report Builder Help Topics**
2. On the Index page, type...
   - HTML page streaming, displaying individual pages
3. Then click **Display to view help topic...**
   - Displaying individual pages of HTML report output
4.11 Running the Web report from the Reports Server

The steps in this section are optional; they will help you run your report dynamically from the Reports Server.

To complete this exercise, you must have Oracle Reports Server software, and must have installed and configured the Reports Server for dynamic reporting. Refer to the Publishing Reports manual for more information, or contact your system administrator for assistance.

1. Copy the following files from the ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory on your machine to the directory where the cached files are sent. Refer to the Reports Server configuration file to determine the cache directory.
   - rbweb_hdr.htm
   - rbweb_page.htm
   - 1.gif
   - 3.gif
   - drama.gif
   - 14 .GIFs containing page, first, back, or next as part of the file name (e.g., page-e.gif).

2. Ensure that the Reports Server can locate your Web report, last saved as web_4102.rdf (i.e., the location of the report is set in the SOURCEDIR parameter of the Reports Server Configuration file or set in the REPORTS60_PATH environment variable).

3. From your Web browser, make the following request:

   http://your_webserver/cgi-bin/rwcgi60.exe?report=web_4102.rdf+
   userid=user_name/password@mydb+
   server=repserver+desformat=htmlcss+
   destype=cache+pagestream=yes

   where:

   your_webserver is the URL address of the Web server
   cgi-bin is the virtual location of the CGI or OWS executable
   user_name/password@mydb is the connection string to the database
   repserver is the name of the Reports Server
4.12 Summary

Congratulations! You have finished the Web sample report. You now know how to:

- Apply format masks.
- Add other HTML files via Report Escapes.
- Add bookmarks to facilitate navigation.
- Add hyperlinks to destinations within your report and to external Web sites.
- Display pop-ups and rollovers.
- Conditionally hide and show items for Web output.
- Create an executive summary section for your report that contains a chart.
- Create special effects using Javascript.

For more information about web-based reports, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type...
   web report, about
3. Then click Display to view help topic...
   About web reports
The report described in this chapter is designed to help you learn more about Report Builder features for report sections and distribution.

To build this report, you will use the Data Wizard to create a multi-query data model, then use the Report Wizard to create the default layout for the first section. You will make fairly extensive manual refinements in the Data Model and Layout Model views. Then, you will again use the Report Wizard to create a default layout for the second section, based on the same data model, and make minor manual refinements in the Layout Model view and Live Previewer.

In this example, you will create a detailed report in the main section showing investment fund elections, and an account summary for employees vested at a specified percentage (one landscape page per employee). Then you will create one-page summary report in the header section of all employees vested at a specified percentage. Finally, you will set up distribution parameters to output each section of the report to multiple formats and destinations.

**About sections**  Report sectioning enables you to define multiple layouts in the same report, with each layout having a different target audience, output format, page layout, page size, and orientation. You can define up to three report sections (i.e., the Main, Header, or Trailer section). In the other sections, you can define different layouts rather than creating multiple separate reports. For example, a single report can include an executive summary for senior management in one section and can also include a detailed breakdown for individual managers in another section.

The following figure provides a conceptual overview for building a report with multiple sections, and then distributing the report based on the distribution parameters defined for each section. Table 5–1, "Features demonstrated in this Sections sample report" describes the steps you will take to create this report.
Create a report with layouts in multiple sections. Sections 5.3 and 5.5.

Specify the distribution settings for the report layout in each section. Section 5.7.

Distribute the report sending each section to its specified destination. Section 5.7.
The `sect.rdf` file contains the report you will create after finishing the tasks in this chapter. You may want to refer to this file while you are working. This file is located in your `ORACLE_HOME\TOOLS\DOC60\US\RBBR60` directory.

Table 5–1  *Features demonstrated in this Sections sample report*

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a data model by building five different queries. Then refine the data model in the Data Model view.</td>
<td>Section 5.1, &quot;Creating a data model&quot;</td>
</tr>
<tr>
<td>Build a Runtime Parameter Form in which users enter parameter values that determine how the report will run.</td>
<td>Section 5.2, &quot;Designing a Runtime Parameter Form&quot;</td>
</tr>
<tr>
<td>Use the Report Wizard to create a default layout for a detailed section.</td>
<td>Section 5.3, &quot;Creating a layout for the first section&quot;</td>
</tr>
<tr>
<td>Make manual refinements to the first section in the Layout Model view.</td>
<td>Section 5.4, &quot;Refining the layout in the Layout Model view&quot;</td>
</tr>
<tr>
<td>Use the Report Wizard to create a default layout for a summary section. Then make minor manual refinements in the Layout Model view and Live Previewer.</td>
<td>Section 5.5, &quot;Creating a layout for the second section&quot;</td>
</tr>
<tr>
<td>Specify how the two sections of the report that you have created will be distributed.</td>
<td>Section 5.7, &quot;Specifying distribution&quot;</td>
</tr>
</tbody>
</table>

To get started, open Report Builder. If the Welcome dialog box appears, click **Build a new report manually** and click **OK**. If not, choose **File->New->Report**. Click **Build a new report manually** and click **OK**.

At some point before you generate the report, you will need to log into the database. Choose **File->Connect** to connect to the database. Enter the appropriate log on information. See Section 1.3, "Obtaining database access before you start" for details.
5.1 Creating a data model

The steps in this section will help you create a data model by building five different queries. Then, you will refine the data model manually in the Data Model view.

5.1.1 Building queries using the Data Wizard

When building a report with multiple queries, you typically use the Data Wizard to create each query and the Report Wizard to create the layout. The steps in this section will help you to create five different queries using the Data Wizard.

1. In the Data Model view, click to display the Data Wizard.
2. If the Welcome page appears, click Next.
3. Type Q_acct in Query Name and click Next.
4. If the Type page appears, click SQL statement, and click Next. The Type page will only appear if you have configured Report Builder to run with Oracle Express.
5. Type the following SELECT statement. This query selects personnel information for each employee, along with investment fund deferral and vested percentages:

   ```sql
   SELECT a.lastname,
          a.firstname,
          a.mi,
          a.ssn,
          a.pct_deferral,
          a.pct_vested,
          d.street,
          d.city,
          d.state,
          d.zip
   FROM   accts a,
           acct_addrs d
   WHERE  a.pct_vested=:p_pct_vested
          AND d.ssn=a.ssn
   ```
6. Click Next. If you are connected to the database, you will receive a notification that Report Builder is creating a bind parameter for you. Click OK to dismiss it. Because the WHERE clause of this query refers to a bind parameter (p_pct_vested) that does not yet exist, Report Builder creates the parameter for you and notifies you that it has been created.

7. On the Groups page, click Next. This query requires no break groups.

8. On the Summary page, click Next. You will create some totals later on in this chapter.

9. Click Finish.

10. Repeating steps 1 through 9, create four more queries with the following characteristics:

- **Query Name: Q_dist**
  Q_dist selects the percent distribution of investment fund elections for each employee.

  ```sql
  SELECT c.fund_id, c.pct_dist, c.ssn, f.name
  FROM fund_contrib c, funds f
  WHERE c.fund_id=f.fund_id
  ORDER BY f.name
  ```

- **Query Name: Q_xact**
  Q_xact selects the contribution category (emconame) and description of income (description) for each category, for each employee.

  ```sql
  SELECT DISTINCT x.description, x.type, t.ssn, t.empcomp, c.emconame
  FROM f_xact_type x, fund_xact t, f_empcomp c
  WHERE t.trans_type=x.type(+)
  AND c.empcomp=t.empcomp
  ```
Creating a data model

- Query Name: **Q_funds**
  
  Q_funds selects the name of each fund.

  ```sql
  SELECT DISTINCT
  f.name,
  f.fund_id
  FROM funds f
  ```

- Query Name: **Q_amount**
  
  Q_amount selects the amount invested in each fund, for each employee.

  ```sql
  SELECT DISTINCT
  amount,
  empcomp,
  fund_id,
  ssn,
  trans_type,
  xact_id
  FROM fund_xact
  ```

11. Choose File->Save As. Save the report in the directory of your choice, and name the report `sect_511.rdf`.

  **Tip:** It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you don’t like some of the changes you made, you easily can go back to the previously saved file and make revisions from that point.

**5.1.2 Refining the Data Model**

The steps in this section will give your groups more meaningful names, create a break group, turn your data model into a matrix data model, create data links, and create summaries.

1. In the Data Model view, double-click G_lastname, the group owned by Q_acct, to display the Property Palette.

2. Under the **General Information** node, set the Name property to G_acct.

3. Press RETURN or ENTER to set the change.
Creating a data model

4. Repeating steps 1 through 3, rename the following groups:

<table>
<thead>
<tr>
<th>Old Name</th>
<th>New Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>G_fund_id</td>
<td>G_dist</td>
</tr>
<tr>
<td>G_description</td>
<td>G_xact</td>
</tr>
<tr>
<td>G_name1</td>
<td>G_funds</td>
</tr>
</tbody>
</table>

Table 5–2  Group names

5. Click and drag the G_xact group down a couple of inches to create some space above it.

6. Click the column named empcomp in the G_xact group, and drag it outside and above the G_xact group.

7. Click the column named emconame in the G_xact group, and drag it into the new group, G_empcomp. Place emconame after the empcomp column.

8. Double-click the G_empcomp group to display the Property Palette.

9. Change the Name property to G_emco.
10. Rearrange your data model to look similar to the following figure:

![Data Model Diagram]

11. Click in the tool palette.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type...
   matrix group, creating
3. Then click Display to view help topic...
   Creating a matrix (crosstab) group

12. Drag a rectangle around groups G_emco, G_xact, and G_funds.
13. Double-click the newly created group, G_1, to display the Property Palette.
14. Change the Name property to G_matrix.
15. Click ![image] to create a column-to-column link.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type...
   - data link, creating
3. Then click Display to view help topic...
   - Creating a data link

16. Click column ssn in group G_acct and drag to column ssn1 in group G_dist.
   (This retrieves the percent distribution of investment fund elections.)

17. Repeating steps 15 and 16, create data links between:

   **Table 5–3 Data links to create in the data model**

<table>
<thead>
<tr>
<th>column ssn in group G_acct, and</th>
<th>column ssn2 in group G_xact (to retrieve the contribution category and description of income for each category)</th>
</tr>
</thead>
<tbody>
<tr>
<td>column empcomp in group G_emco, and</td>
<td>column empcomp1 in group G_amount</td>
</tr>
<tr>
<td>column ssn2 in group G_xact, and</td>
<td>column ssn3 in group G_amount</td>
</tr>
<tr>
<td>column fund_id1 in group G_funds, and</td>
<td>column fund_id2 in group G_amount (to retrieve for each income description in each contribution category in each fund, the account balance)</td>
</tr>
<tr>
<td>column type in group G_xact, and</td>
<td>column trans_type in group G_amount (to retrieve for each income description, a distinct amount)</td>
</tr>
</tbody>
</table>
Creating a data model

Your data model should now look similar to the following figure:

```
18. Click .

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type...
   totals, creating for column
3. Then click Display to view help topic...
   Creating a summary column

19. Click on the title bar of group G_matrix.

   In the following steps, you will set this new summary column to calculate totals
   on each income description in each contribution category (row totals).

20. Double-click the newly created column, CS_1 to display the Property Palette.
```
21. In the Property Palette under the **General Information** node, set the Name property to CS_xactotal.

22. Under the **Column** node, set the Width property to 38, the Product Order property to G_emco G_xact, and the Value if Null property to 0.00.

**Tip:** The values for the Product Order property can get quite long. To make these values easier to see, resize the Property Palette horizontally.

For more information on the meaning of these properties, click ![Question Mark] while the property is selected.

23. Under the **Summary** node, set the Source property to amount and the Reset At property to G_xact.

24. Repeating steps 18 through 23, create summary columns in group G_matrix with the following characteristics:

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Product Order</th>
<th>Value if Null</th>
<th>Source</th>
<th>Reset At</th>
</tr>
</thead>
<tbody>
<tr>
<td>CS_fundsubtotal</td>
<td>38</td>
<td>G_funds G_emco</td>
<td>0.00</td>
<td>amount</td>
<td>G_emco</td>
</tr>
<tr>
<td>CS_emcototal</td>
<td>38</td>
<td>G_emco</td>
<td>0.00</td>
<td>amount</td>
<td>G_emco</td>
</tr>
<tr>
<td>CS_fundtotal</td>
<td>38</td>
<td>G_funds</td>
<td>0.00</td>
<td>amount</td>
<td>G_funds</td>
</tr>
</tbody>
</table>

- CS_fundsubtotal calculates totals on each income fund in each contribution category (column totals).
- CS_emcototal calculates grand totals on each contribution category.
- CS_fundtotal calculates grand totals on each fund in all contribution categories.

25. Repeating steps 18 through 23, create a summary column in group G_acct with the following characteristics:

<table>
<thead>
<tr>
<th>Name</th>
<th>Width</th>
<th>Value if Null</th>
<th>Source</th>
<th>Reset At</th>
</tr>
</thead>
<tbody>
<tr>
<td>CS_grandtotal</td>
<td>38</td>
<td>0.00</td>
<td>CS_fundtotal</td>
<td>G_acct</td>
</tr>
</tbody>
</table>

- CS_grandtotal calculates grand totals on each fund in all contribution categories.
26. You may want to rearrange the objects inside of group G_matrix to make the summary columns more easily visible.

27. Save your report as sect_512.rdf.

Your data model should now look similar to the following figure:
5.2 Designing a Runtime Parameter Form

The steps in this section will help you design a Runtime Parameter Form so that you can run your report regularly as you make refinements.

In Section 5.1.1, "Building queries using the Data Wizard", you created a query with the bind parameter p_pct_vested. Whenever you run a report with a bind parameter, the default Runtime Parameter Form appears. You must assign a value to the bind parameter in order to run your report.

You can use the default Parameter Form to enter a value, or you can build your own Parameter Form using the Parameter Form view.

1. Choose Tools->Parameter Form Builder.
2. In the Parameter Form Builder, click the following parameters if they are not already selected:
   - DESTYPE
   - DESNAME
   - DESFORMAT
   - P_PCT_VESTED
3. Click OK to create a parameter form in the Parameter Form view.
4. Click once to select the P pct vested label, then click it again to enter edit mode. (Double-clicking will display the Property Palette.)
5. Select the text, and replace it with % Vested.
6. Double-click PF_P_PCT_VESTED to display the Property Palette.
7. Under the Parameter node, set the Initial Value property to 100.
8. Click in the List of Values property field to display the Parameter List of Values dialog box.
9. If it is not already selected, click Static Values.
10. Type 0 in the Value field, then click Add.
Creating a layout for the first section

11. Repeat step 10 to add the following values:
   10
   25
   50
   75
   100

12. Click OK to close this dialog box.

13. Close the Parameter Form view. You will have an opportunity to use the Run-time Parameter Form in a later step.

14. Save the report as sect_520.rdf.

5.3 Creating a layout for the first section

The steps in this section will help you to create a layout for a detailed section by using the Report Wizard to create a default layout. The Report Wizard by default builds a report layout in the main section of the report.


2. On the Style page, click Matrix with Group.

3. Click Next.

4. On the Groups page, select the following groups from the Available Fields list box:
   - click G_matrix, then click Matrix
   - click G_emco, then click Down

5. Click G_dist (Down) in the Displayed Group list box.

6. Click . The Groups page should look like the one in the following figure:
7. Click **Next**.

8. On the Fields page, click **lastname**, then click **»**. Repeat this step to add the following fields to the Displayed Fields list:
   - **firstname**
   - **mi**
   - **ssn**
   - **pct_deferral**
   - **pct_vested**
   - **description**
   - **emconame**
   - **name1**
   - **amount**
   - **CS_xactotal**
   - **CS_fundsubtotal**
   - **CS_emcototal**
   - **CS_fundtotal**
   - **CS_grandtotal**
9. Click Next.

10. On the Labels page, delete the labels for all of the columns listed, then rename the following columns:

<table>
<thead>
<tr>
<th>Table 5–6  Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
</tr>
<tr>
<td>ssn</td>
</tr>
<tr>
<td>pct_deferral</td>
</tr>
<tr>
<td>pct_vested</td>
</tr>
<tr>
<td>CS_grandtotal</td>
</tr>
</tbody>
</table>

11. Change the widths of the following columns:

<table>
<thead>
<tr>
<th>Table 5–7  Widths</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
</tr>
<tr>
<td>pct_deferral</td>
</tr>
<tr>
<td>pct_vested</td>
</tr>
<tr>
<td>description</td>
</tr>
<tr>
<td>emconame</td>
</tr>
<tr>
<td>name1</td>
</tr>
<tr>
<td>amount</td>
</tr>
<tr>
<td>CS_xactotal</td>
</tr>
<tr>
<td>CS_fundsubtotal</td>
</tr>
<tr>
<td>CS_emcototal</td>
</tr>
<tr>
<td>CS_fundtotal</td>
</tr>
<tr>
<td>CS_grandtotal</td>
</tr>
</tbody>
</table>

12. Click Next.

13. On the Template page, select the Predefined template Cyan Grid.

14. Click Finish.
15. In the Runtime Parameter Form, select 100 from the % Vested list box. Notice the Destination type, Destination name, and Destination format fields. You can choose another output type, such as printer, or change the format. For this exercise, however, you will use the default values.

16. Click to review your report in the Live Previewer. Your report will look similar to the following figure:

![Report Preview](image)

17. Close the Live Previewer.

18. Save your report as sect_530.rdf.
5.4 Refining the layout in the Layout Model view

The steps in this section will help you to refine the layout of your report using the Layout Model view. You will make extensive changes to your layout by doing the following:

- change the attributes of objects, such as font size
- rearrange objects in your layout
- add boilerplate objects
- change the orientation of your report to landscape

When you finish this section, the layout will look similar to the following figure. Use this layout to help guide you through this exercise.

Tip: If you re-enter the Report Wizard after making manual refinements in the Live Previewer, you will lose some of your changes when you click Apply or Finish in the wizard, and your layout will default back to the state defined by the wizard.
5.4.1 Changing the properties of objects

1. In the Object Navigator, double-click the Layout Model node to display the Layout Model view of your report.

2. In the Layout Model view, double-click F_lastname to display the Property Palette.

3. Under the General Layout node, change the Horizontal Elasticity property to Variable. Repeat this step for the following objects:
   - FFirstname
   - F_mi
   **Tip:** You can change several objects at one time: shift-click on all objects, then choose Tools->Property Palette.

4. Click in an empty area of the canvas to deselect the objects.

5. Shift-click the following objects:
   - F_lastname
   - F_firstname
   - F_mi
   - SSN:
   - F_ssn
   - Deferral Percentage:
   - F_pct_deferral
   - Vested Percentage:
   - F_pct_vest

6. In the toolbar, select 12 from the font size list box to change the font size of the selected objects.

7. Click in an empty area of the canvas.

8. Shift-click the following objects, then choose Tools->Property Palette:
   - F_pct_deferral
   - F_pct_vest
9. In the Property Palette under the Field node, type **NNNN%** (case sensitive) in the Format Mask to display the objects as a percentage.

10. Click in an empty area of the canvas.

11. Shift-click the following layout objects:
   - F_amount
   - F_CS_fundsubtotal
   - F_CS_fundtotal
   - F_CS_xactotal
   - F_CS_emcototal
   - F_CS_grandtotal

12. Click †.

13. Click ‡ twice.

14. Click †.

15. Click F_description, then click †.

16. Save the report as sect_541.rdf.

17. Click †.

18. At the Runtime Parameter Form, click † to view the changes in the Live Previewer.
5.4.2 Re-arranging frames and objects

1. In the Object Navigator, double-click to display the Layout Model view of your report.
   
   **Tip:** Every object in the Layout Model view is also represented in the Object Navigator. Sometimes it is easier to refine the layout of a report by selecting objects from the Object Navigator. Arrange your workspace to display the Object Navigator and Layout Model view side-by-side. When you click an object in the Object Navigator, this object is selected in the Layout Model view.

2. In the Object Navigator, expand the Layout Model, Main Section, Body, and M_G_ACCT_GRPFR nodes if they are not already expanded.

3. Ctrl-click M_G_ACCT_GRPFR and R_G_ACCT.

4. In the Layout Model view, using the vertical ruler as a guide, lengthen the M_G_ACCT_GRPFR and R_G_ACCT groups until the bottom of the frames reach 3 inches.
   
   **Tip:** M_G_ACCT_GRPFR is the underlying master group. It is under R_G_ACCT. In the Layout Model view, it may look like only one group is selected when, in fact, both frames are selected.

5. In the Object Navigator, type M_G_MATRIX_GRPFR in the Find field to locate this object. Note that the search occurs as you type, so you will most likely be taken to the object before you finish typing the entire name.
   
   The M_G_MATRIX_GRPFR frame in the Layout Model view looks similar to the following figure:

![M_G_MATRIX_GRPFR frame](image)

6. In the Layout Model view using the vertical rule as a guide, lengthen the M_G_MATRIX_GRPFR frame until the bottom of the frame reaches 3 inches.

7. In the Object Navigator, type R_G_FUNDS in the Find field.
The R_G_FUNDS frame in the Layout Model view looks similar to the following figure:

8. In the Layout Model view, lengthen the R_G_FUNDS frame until the bottom of the frame reaches its parent (enclosing) frame.

   **Tip:** If you are unable resize the frame as expected, you may need to toggle Confine Mode off.

   ![Confine Mode on](image)

   ![Confine Mode off](image)

9. Shift-click F_CS_fundtotal and F_CS_grandtotal. Move these objects down until they reach their parent frame.

10. In the Object Navigator under the **Dimension Repeating Frame** node, click R_G_EMCO.

    The R_G_EMCO repeating frame in the Layout Model view looks similar to the following figure:

11. In the Layout Model view, lengthen the R_G_EMCO repeating frame until it reaches the top of the F_CS_fundtotal and F_CS_grandtotal frames.

    The result will look similar to the following figure:
12. Arrange the following frames end-to-end to look like the figure that follows:
   - F_lastname
   - F_firstname
   - F_mi

13. Click and then again at the Runtime Parameter Form.
14. Save your report as sect_542.rdf.

### 5.4.3 Adding boilerplate objects

1. Display the Layout Model view of your report.
2. Click to create a boilerplate object. Then click in the area directly below F_description.
3. Type Subtotal:
4. Click .
5. Change the following, if necessary:
   - Font to Arial using the Font list box in the toolbar
   - Point size to 10
   - Font style to bold. Click .
   - Click and change the color to dark blue.
6. If necessary, arrange the boilerplate object so that it is placed next to \texttt{F\_CS\_Fundsubtotal}. The result will look similar to the following figure:

![Subtotal: F\_CS\_Fundsubtotal](image)

7. Repeat steps 2 through 6 to create the following boilerplate objects with the specified characteristics:

<table>
<thead>
<tr>
<th>Boilerplate</th>
<th>Location</th>
<th>Text Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grand Total:</td>
<td>right of \texttt{F_CS_fundtotal}</td>
<td>Yellow</td>
</tr>
<tr>
<td>Total Funds</td>
<td>Above \texttt{F_CS_xactotal}</td>
<td>Yellow</td>
</tr>
</tbody>
</table>

8. Click \[
\text{Edit Object Properties}
\]
and then again at the Runtime Parameter Form. Your report will look similar to the following figure.
9. Scroll to the right of the report, then click \[\text{button}\].

Notice that report is not wide enough to display all the columns on a single page and wraps to the second page. Later, in Section 5.6, “Specifying landscape orientation and page break”, you will change the orientation of this layout to landscape and insert a page break. This will allow the report to display one record per page. Before you change the orientation, however, you will create a layout for the second section using the Report Wizard.

10. Save the report as sect_543.rdf.

5.5 Creating a layout for the second section

The steps in this section will help you to create a layout for a summary in the header section of your report. You will use the Report Wizard to create a default layout. Then you will make manual refinements in the Layout Model view and Live Previewer.

5.5.1 Creating the default layout

1. Display the Layout Model view of your report.
2. Choose View->Layout Section->Header Section.
3. Ensure that the Body of the report is displayed.
5. On the Style page, type Vesting Summary in the Title field, and click Tabular.
6. Click Next.
7. On the Groups page, click G_acct from the Available Fields list box, then click Down.
8. Click Next.
9. On the Fields page, click lastname, then click . Repeat this step for the following fields:
   - firstname
   - mi
   - ssn
   - pct_vested
   - CS_grandtotal

10. Click Next.

11. On the Labels page, change labels and widths as follows:

<table>
<thead>
<tr>
<th>Column</th>
<th>Label</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>lastname</td>
<td>Last Name</td>
<td>8</td>
</tr>
<tr>
<td>firstname</td>
<td>First Name</td>
<td>6</td>
</tr>
<tr>
<td>mi</td>
<td>MI</td>
<td>1</td>
</tr>
<tr>
<td>ssn</td>
<td>SSN</td>
<td>6</td>
</tr>
<tr>
<td>pct_vested</td>
<td>Vested Percentage</td>
<td>4</td>
</tr>
<tr>
<td>CS_grandtotal</td>
<td>Total Balance</td>
<td>6</td>
</tr>
</tbody>
</table>

12. Click Next.

13. On the Template page, click the Predefined template Confidential Background.

14. Click Finish.

15. Click  and then again at the Runtime Parameter Form.
16. If necessary click △ to display the Vesting Summary report. Your report will look similar to the following figure:

![Vesting Summary Report](image)

17. Save your report as sect_551.rdf.

5.5.2 Refining the layout in the Live Previewer

1. In Live Previewer, shift-click the following objects, then click ▽:
   - Last Name
   - First Name
   - MI
   - SSN
   - Vested Percentage
   - Total Balance
2. Ensure that Flex Mode is on.

   Tip: indicates that Flex mode is on. indicates that Flex mode is off.
   Shift-click the data under the following headings:
   - Last Name
   - First Name
   - MI
   - SSN
   - Vested Percentage
   - Total Balance

3. Click the lower-right corner of the selected objects and drag the lower edge of the frame down about 0.25 inches. Notice that the space between the rows increases. See the before and after figures that follow:

   Report before increasing the row spacing:

   ![Report before increasing the row spacing]

   Report after increasing the row spacing:

   ![Report after increasing the row spacing]

4. Arrange your workspace so that the Object Navigator and Live Previewer are displayed side-by-side.

5. In the Object Navigator, type R_G_ACCT1 in the Find field.

6. Click the title bar in the Live Previewer to make it active.
Creating a layout for the second section

7. Choose Format->Border and choose Top to toggle off the top border. A checkmark next to an option indicates that it is toggled on.

8. Repeat step 7 for Left and Right. The bottom border will remain toggled on.

9. Click , then choose red. This will place a red line between the rows of data. Your report will similar to the following figure:

![Vesting Summary](image)

10. Save the report as sect_552.rdf.
5.6 Specifying landscape orientation and page break

The steps in this section will help you change the orientation of the layout you created in the Main section.

**Tip:** If you create multiple layouts using the Report Wizard and plan on changing the orientation setting, it is good practice to change the orientation after building all of your layouts. If you change the orientation of first layout, then build a second layout using the Report Wizard, the orientation of the first layout will revert back to the orientation settings defined in the template.

1. In the Object Navigator, if necessary, expand the **Layout Model** node, then click the **Main Section** node and choose **Tools->Property Palette**.

2. In the Property Palette under the **Section** node, make the following changes:

   **Table 5–10  Property settings for the Section node**

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Width</td>
<td>11</td>
</tr>
<tr>
<td>Height</td>
<td>8.5</td>
</tr>
<tr>
<td>Orientation</td>
<td>Landscape</td>
</tr>
</tbody>
</table>

3. Display the Layout Model view of your report.

4. Click ![display](display_icon) to display the Main section,

5. In the Layout Model view, click ![margin](margin_icon) in the toolbar to expose the Margin of your report.

   **Tip:** Click ![margin](margin_icon) to switch between the Margin and Body of your report. Alternatively, choose **View->Layout Section**. A check mark next to Edit Margin indicates the Layout Model view is in Margin mode.

6. Scroll down to the bottom of the layout, and click the border between the Body and the lower Margin.

7. Using the vertical ruler as a guide, resize the area by dragging the border up to the 7.5 inch mark.

   **Tip:** Be sure that you are re-sizing the Margin, not moving the Margin.

8. Click ![body](body_icon) to expose the Body of your report.

9. In the Layout Model view, click the lastname field.
10. Click to select the parent frame.


12. Under the Repeating Frame node, set the Maximum Records per Page property to 1.

13. Click and then again in the Runtime Parameter Form.

14. Click in the toolbar to display the layout that you created in a previous section.

   Scroll to the right of the report. Notice the orientation of the report has changed. The report can display all the columns on a single page. Notice also that only one record per page is displayed.

15. Save your report as sect_560.rdf.

5.7 Specifying distribution

The steps in this section will help you to specify the distribution for the two sections that you have created:

- a detailed report showing investment fund elections, and an account summary for employees vested at a specified percentage (at least one landscape page per employee).

- a one-page summary report of all employees vested at a specified percentage.

You will distribute your report as follows:

- print two copies of the detailed section.

- format the detailed section in HTML for access on a secure Web site.

- format the summary section as a PDF.
5.7.1 Specifying distribution for the detailed section

1. In the Object Navigator, type **Main Section** in the Find field.
2. Choose **Tools->Property Palette**.
3. Click the Distribution value field to display the Distribution dialog box. Specify two distribution output destinations for the report that summarizes account information for employees.
4. In the Distribution dialog box, specify the distribution for printing the report:

   | **Table 5–11 Distribution settings for the printed Main section** |
   |----------------------|-----------------|
   | **Field** | **Value** |
   | Distribution ID | printdist |
   | DESNAME | printer path and name |
   | DESFORMAT | BITMAP |
   | DESTYPE | Printer |
   | COPIES | 2 |

   **Tip:** If you select Printer as the DESTYPE first, the DESNAME is automatically set to your default printer. Change this value if you want to send this report to another printer.

5. Click **New**.

6. In the Distribution dialog box, define the distribution for HTML output:

   | **Table 5–12 Distribution settings for the HTML version of the Main section** |
   |----------------------|-----------------|
   | **Field** | **Value** |
   | Distribution ID | htmldist |
   | DESNAME | path and file name for the HTML output (e.g., c:\sect_rep.htm) |
   | DESFORMAT | HTML |
   | DESTYPE | File |
   | COPIES | 1 |

7. Click **OK**.

8. Save your report as sect_571.rdf.
5.7.2 Specifying distribution for the summary section

1. In the Object Navigator, click the **Header Section** node.

2. Choose **Tools->Property Palette**.

3. In the Property Palette, under the **Section** node, click in the Distribution value field to display the Distribution dialog box.

4. In the Distribution dialog box, define the distribution for sending the summary section to PDF:

   **Table 5–13  Distribution settings for the PDF version of the Header section**

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distribution ID</td>
<td>pdfdist</td>
</tr>
<tr>
<td>DESNAME</td>
<td>path and pdf file name (e.g., c:\sect_rep.pdf)</td>
</tr>
<tr>
<td>DESFORMAT</td>
<td>PDF</td>
</tr>
<tr>
<td>DESTYPE</td>
<td>File</td>
</tr>
<tr>
<td>COPIES</td>
<td>1</td>
</tr>
</tbody>
</table>

5. Save your report as **sect_572.rdf**.

**Optional Exercise:**

Try setting up distribution to e-mail the executive summary. You will need a MAPI-compliant mail application set up on your system.
5.7.3 Distributing the report

1. In the Object Navigator, click your report name, then choose File->Distribute.
2. In the Runtime Parameter Form, click .
3. In the dialog box that prompts for your confirmation to distribute to multiple destinations, click Continue.
4. Check the printer, your file system, and (optionally) your e-mail inbox to verify that your report was distributed as expected.

Optional Exercise:
Try setting up distribution by creating a .DST file and running the distribution from the command line.

Tip: You can trace report distribution. The trace file, which is similar to a .DST file, is generated when you check the Distribution check box in the Runtime Trace Settings dialog box.

5.8 Summary

Congratulations! You have finished the Sectioning sample report. You now know how to:

- Create a data model and refine it in the Data Model view.
- Build a Runtime Parameter Form.
- Create a default layout for a detailed section, and refine it in the Layout Model view.
- Create a default layout for a summary section and refine it in the Layout Model view and Live Previewer.
- Specify report distribution criteria.

For more information about sectioning and distribution, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type...
   sectioning, about
3. Then click Display to view help topic...
   About report sectioning
Building a Report with Ref Cursor Queries

The report described in this chapter is designed to help you learn more about Report Builder features for using ref cursors. To build this report, you will use the Data Model view to create a multi-query data model, and then use the Report Wizard to create the report layout. You will make fairly extensive manual refinements in the Data Model view. In this example, you will create a detailed report showing information about available shipping containers at various ports.

About ref cursor queries A ref cursor query uses PL/SQL to fetch data. Each ref cursor query is associated with a PL/SQL function that returns a strongly typed ref cursor. The PL/SQL function must ensure that the ref cursor is opened and associated with a SELECT statement that has a SELECT list that matches the ref cursor type. You base a query on a ref cursor when you want to:

- more easily administer SQL
- avoid the use of lexical parameters in your reports
- share datasources with other applications, such as Form Builder
- increase control and security
- encapsulate logic within a subprogram

Furthermore, if you use a stored program unit to implement ref cursors, you receive the added benefits that go along with storing program units in the Oracle database.

The following figure shows that you create a report with the SELECT statement in the ref cursor query of the report. It also shows that you can store the SELECT statement in a package in the database. Then, from the report, you can call the package from the database allowing you to reuse the package in many reports.

Table 6–1, "Features demonstrated in this Ref Cursor Query sample report", describes the steps you will take to create this report.
Create a report defining the ref cursor (type and SELECT statement in the .RDF file. Sections 6.1 and 6.2.

Move the SELECT statement from the .RDF into a package stored in the database. Section 6.7.

Reuse the package stored in the database in many RDFs.

In the report, create a ref cursor query that calls the package into the report. Section 6.8.
The ref.rdf file contains the report you will create after finishing the tasks in this chapter. You may want to refer to this file while you are working. In addition, the port_container.pll is the library file that is associated with ref.rdf. These files are located in your ORACLE_HOME\TOOLS\DOC60\US\RBR60 directory.

Table 6-1 Features demonstrated in this Ref Cursor Query sample report

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create package specs that define ref cursors.</td>
<td>Section 6.1, &quot;Defining a ref cursor type&quot;</td>
</tr>
<tr>
<td>Create ref cursor queries that will use the ref cursors.</td>
<td>Section 6.2, &quot;Creating a ref cursor query&quot;</td>
</tr>
<tr>
<td>Rename objects in the data model so that they have more meaningful names.</td>
<td>Section 6.3, &quot;Refining the data model&quot;</td>
</tr>
<tr>
<td>Create group-to-group data links between ref cursor queries to create relationships between them.</td>
<td>Section 6.4, &quot;Creating links between ref cursor queries&quot;</td>
</tr>
<tr>
<td>Create summaries that better describe the data.</td>
<td>Section 6.5, &quot;Adding summary columns&quot;</td>
</tr>
<tr>
<td>Use the Report Wizard to create a report layout.</td>
<td>Section 6.6, &quot;Creating a layout&quot;</td>
</tr>
<tr>
<td>Move the SELECT statements used by the ref cursor queries from the report and into packages that define the ref cursor types.</td>
<td>Section 6.7, &quot;Moving the SELECT statement into a package&quot;</td>
</tr>
<tr>
<td>Move the packages into a PL/SQL library so that other reports can share the code.</td>
<td>Section 6.8, &quot;Moving the packages into a library&quot;</td>
</tr>
</tbody>
</table>

To get started, open Report Builder. If the Welcome dialog box appears, click Build a new report manually and click OK. If not, choose File->New->Report. Click Build a new report manually, and click OK.

At some point before you generate the report, you will need to log into the database. Choose File->Connect to connect to the database. Enter the appropriate log on information. See Section 1.3, "Obtaining database access before you start" for details.
6.1 Defining a ref cursor type

To create a ref cursor query, you first create a package spec that defines the ref cursor. Then you create a query that uses the ref cursor. The steps in this section will help you create package specs that define ref cursors.

1. In the Object Navigator, click the Program Units node under your UNTITLED report node.

2. Click to add a program unit.

3. In the New Program Unit dialog box, type concl_cv as the name of the program unit.

4. Click Package Spec, and click OK.

5. Type the following package spec definition in the editor. The new code that you need to add is in bold:

```
PACKAGE concl_cv IS
  type conclass_rec is RECORD
    (ccap number,
     classid number,
     gwl number,
     twl number,
     htf number,
     hti number,
     notes varchar(50),
     teu number);
  type conclass_refcur is REF CURSOR return conclass_rec;
END;
```

This package spec does two things:

- Defines a record (conclass_rec) that describes the data you want to select from the database.
- Defines a ref cursor that returns the data in the format described by the record.

6. Click Compile.
7. If any compilation errors occur, check the code for syntax errors and recompile as needed.

8. Click Close.

9. Repeat steps 2 through 8 to create two more package specs with the following characteristics. New code is displayed in bold:

   - **Package Spec Name: cont_cv**
     ```
     PACKAGE cont_cv IS
       type container_rec is RECORD
         (title varchar(40),
          dockloc varchar(10),
          portid number,
          repno varchar(10),
          status number,
          key varchar(10),
          key2 varchar(10),
          classid2 number);
       type container_refcur is REF CURSOR return container_rec;
     END;
     ```

   - **Package Spec Name: port_cv**
     ```
     PACKAGE port_cv IS
       type portdesc_rec is RECORD
         (portid number,
          locname varchar(10));
       type portdesc_refcur is REF CURSOR return portdesc_rec;
     END;
     ```

10. Choose File->Save As. Save the report in the directory of your choice, and name the report `ref_61.rdf`.

    **Tip:** It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you don’t like some of the changes you made, you easily can go back to the previously saved file and make revisions from that point.
6.2 Creating a ref cursor query

After creating package specs that define the ref cursors, you are ready to define the queries, as described in this section.

1. In the Object Navigator, double-click to go to the Data Model view.

2. Click .

3. Click in the main area (canvas region) of the Data Model view.

4. In the Program Unit Editor, type in the bold code that follows to define the function. New code is displayed in bold:

   function q_portdescRefCurDS return port_cv.portdesc_refcur is
     temp_portdesc port_cv.portdesc_refcur;
   begin
     open temp_portdesc for select portid, locname from portdesc;
     return temp_portdesc;
   end;

5. Click Compile.

6. If any compilation errors occur, check the code for syntax errors and recompile as needed.

7. Click Close. The data objects display in the Data Model view.

8. In the Data Model view, click the ref cursor query object (QR_1), then choose Tools->Property Palette.

9. Under the General Information node, change the Name property to q_portdesc.

   Tip: It is usually a good idea to give objects meaningful names, particularly when building a report with many objects. Later when building the layout, it is helpful to have queries and groups with meaningful names.

10. Press ENTER or RETURN, or click any other field in the Property Palette to accept the change.

11. Close the Property Palette.
12. Repeat steps 2 through 10 to create two more queries with the following characteristics. Be sure to rename the queries using the Property Palette after creating them. New code is displayed in bold:

- **Query name: q_container**
  ```sql
  function q_container RefCurDS return cont_cv.container_refcur is
    temp_container cont_cv.container_refcur;
  begin
    open temp_container for select cl.title, c.DOCKLOC, c.PORTID, c.REPNO, c.STATUS, c.key, cl.key key2, c.classid classid2
    from CONTAINERS c, conlabel cl
    where cl.key=c.key
    order by c.REPNO;
    return temp_container;
  end;
  ```

- **Query name: q_conclass**
  ```sql
  function q_conclass RefCurDS return concl_cv.conclass_refcur is
    temp_concl concl_cv.conclass_refcur;
  begin
    open temp_concl for select CCAP, CLASSID, GWL, TWL, HTF, HTI, NOTES, TEU
    from CONCLASS;
    return temp_concl;
  end;
  ```

13. The Data Model should look similar to the following figure:
6.3 Refining the data model

In this section you will rename some of the objects in the data model so that they have more meaningful names. You will also create a break group.

1. In the Data Model view, drag the title bar of the group G_TITLE down a few inches to move the entire group.
2. With G_Title still selected, choose Tools->Property Palette.
3. Under the General Information node, change the Name property to G_container.
4. Press ENTER or RETURN, or click any other field in the Property Palette to accept the change.
5. Close the Property Palette.
6. Click and drag the column named TITLE out of and above G_container to create a new break group, as shown in the following figure:

For online help on this task, choose Help->Report Builder Help Topics
On the Index page, type... break group, creating
Then click Display to view help topic... Creating a break group
7. Click the title bar of the new group (probably named G_TITLE) that contains TITLE, and choose Tools->Property Palette.

8. Under the General Information node, change the Name property to G_conlabel.

9. Press ENTER or RETURN, or click any other field in the Property Palette to accept the change.

10. Close the Property Palette.

11. Drag and drop KEY2 from G_container to G_conlabel. KEY2 displays in G_conlabel and is removed from G_container.

12. Click the title bar of G_PORTID and choose Tools->Property Palette.

13. Change the Name property under the General Information node to G_portdesc.

14. Press ENTER or RETURN, or click any other field in the Property Palette to accept the change.

15. Close the Property Palette.

16. Click the title bar of G_CCAP and choose Tools->Property Palette.

17. Under the General Information node, change the Name property to G_conclass.

18. Press ENTER or RETURN, or click any other field in the Property Palette to accept the change.

19. Close the Property Palette.

20. In the Data Model view, your data model should look similar to the following figure:
6.4 Creating links between ref cursor queries

Currently, the queries that you have created are unrelated. To create relationships between them, you need to create group-to-group data links. The steps in this section will help you create the links.

1. In the Data Model view, click .
2. Click the title bar of G_portdesc, and drag to the title bar of G_container.
3. Double-click q_container. The Program Unit Editor displays.

---

21. Save the report as ref_63.rdf.
4. Now you will append code to the WHERE clause of the SELECT statement to specify which columns are being used as primary and foreign keys.

   After `WHERE cl.key=c.key`, add the following code:
   
   ```sql
   and :portid=c.PORTID
   ```

   Note that `:portid` is a bind variable referring to the PORTID column in `G_portdesc`.

5. Click Compile.

6. If any compilation errors occur, check the code for syntax errors and recompile as needed.

7. Click Close.

8. Click `Select`.

9. Click the title bar of `G_container` and drag to the title bar of `G_conclass`.

10. Double-click `q_conclass`.

11. Now you will add a WHERE clause to the SELECT statement. Insert your cursor between `FROM CONCLASS` and the semicolon (`;`), and press ENTER or RETURN to create a new line.

12. Add the following code:

   ```sql
   WHERE :classid2=conclass.classid
   ```

   Tip: Be sure that the semicolon (`;`) now follows the WHERE clause.

   Note that `:classid2` is a bind variable referring to the CLASSID2 column in `G_container`.

13. Click Compile.

14. If any compilation errors occur, check the code for syntax errors and recompile as needed.

15. Click Close.
16. Your data model should look similar to the following figure:

![Data Model Diagram]

17. Save the report as `ref_64.rdf`.

### 6.5 Adding summary columns

Now that your queries are complete and linked, the steps in this section will help you to create columns to summarize the data.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type... summary column, creating
3. Then click Display to view help topic... Creating a summary column

1. In the Data Model view, click 
2. Click inside the G_container group. This creates a new column, CS_1.
3. Double-click the newly created column to open the Property palette.
4. Under the **General Information** node, change the Name property to `CS_classcount`. 
5. Under the **Summary** node, change the following settings:

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td>Count</td>
</tr>
<tr>
<td>Source</td>
<td>KEY</td>
</tr>
<tr>
<td>Reset At</td>
<td>G_container</td>
</tr>
</tbody>
</table>

6. Click any other field in the Property Palette to accept the changes.

7. Close the Property Palette.

You have now created a summary that counts up the number of containers. You will not use the summary in this report’s layout, but you will use it as the source for other, more interesting summaries later.

8. Repeat steps 1 through 5 to create summaries with the following characteristics:

<table>
<thead>
<tr>
<th>Create in Group</th>
<th>Name</th>
<th>Function</th>
<th>Source</th>
<th>Reset At</th>
</tr>
</thead>
<tbody>
<tr>
<td>G_conlabel</td>
<td>CS_conlabel_classcount</td>
<td>Sum</td>
<td>CS_classcount</td>
<td>G_conlabel</td>
</tr>
<tr>
<td>G_portdesc</td>
<td>CS_port_count</td>
<td>Sum</td>
<td>CS_conlabel_classcount</td>
<td>G_portdesc</td>
</tr>
</tbody>
</table>

You may not understand these summaries now. Their purpose will become clearer when you create the report layout and preview the live data.
Your data model should look similar to the following figure:

9. Save the report as ref_65.rdf.

6.6 Creating a layout

Now that you have a working data model, the steps in this section will help you to create a layout.

1. Click to bring up the Report Wizard.
2. On the Style page, type Pacific Intermodal Leasing as the Title.
3. Click Group Above as the report style.
4. Click Next.
5. On the Groups page, click G_conclass and click Down.
6. Repeat step 5 for:
   - G_container
   - G_conlabel
   - G_portdesc
7. Click Next.
8. On the Fields page, click LOCNAME, and click .
9. Repeat step 8 for:
   - TITLE
   - DOCKLOC
   - REPNO
   - CLASSID2
   - CCAP
   - GWL
   - TWL
   - HTF
   - HTI
   - NOTES
   - CS_conlabel_classcount
   - CS_port_count

10. Click Next.
11. On the Labels page, type in the labels and widths as shown in the following table:

<table>
<thead>
<tr>
<th>Column</th>
<th>Label</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>LOCNAME</td>
<td>Port of:</td>
<td>15</td>
</tr>
<tr>
<td>TITLE</td>
<td>Containers</td>
<td>20</td>
</tr>
<tr>
<td>DOCKLOC</td>
<td>Location</td>
<td>10</td>
</tr>
<tr>
<td>REPNO</td>
<td>ID</td>
<td>10</td>
</tr>
<tr>
<td>CLASSID2</td>
<td>Class</td>
<td>9</td>
</tr>
<tr>
<td>CCAP</td>
<td>Cu capy</td>
<td>9</td>
</tr>
<tr>
<td>GWL</td>
<td>Gross wt</td>
<td>9</td>
</tr>
<tr>
<td>TWL</td>
<td>Tare wt</td>
<td>9</td>
</tr>
<tr>
<td>HTF</td>
<td>Htf</td>
<td>9</td>
</tr>
<tr>
<td>HTI</td>
<td>Hti</td>
<td>9</td>
</tr>
<tr>
<td>NOTES</td>
<td>Notes</td>
<td>15</td>
</tr>
<tr>
<td>CS_conlabel_classcount</td>
<td>Total available:</td>
<td>8</td>
</tr>
<tr>
<td>CS_port_count</td>
<td>Total available:</td>
<td>15</td>
</tr>
</tbody>
</table>

12. Click Next.

13. On the Template page, click Predefined template, and choose Cyan Grid Landscape.
14. Click Finish. The report automatically displays in the Live Previewer:

15. Save the report as ref_66.rdf.

6.7 Moving the SELECT statement into a package

In your current report configuration, the SELECT statements used by the ref cursor queries reside within the report itself. In many cases, it is advantageous to have SELECT statements reside in the packages that define the ref cursor types. Then, you can simply reference the packages, rather than typing the same SELECT statement directly into every report that uses it. If you need to change the SELECT statement (for example, to modify or add clauses), you simply update it once in the package, rather than in every report that uses it.

The steps in this section will help you to move the SELECT statements to the packages that define the ref cursor types.

1. In the Object Navigator, click the Program Units node for your report.

2. Click to add a program unit.

3. In the New Program Unit dialog box, type cont_cv as the name of the program unit.

4. Click Package Body, and click OK.
5. Type the following code in the editor. New code is displayed in bold:

```sql
PACKAGE BODY cont_cv IS
  function query_container (p_portid number) return container_refcur is
    tempcv_container cont_cv.container_refcur;
  begin
    open tempcv_container for select cl.title, c.DOCKLOC,
      c.PORTID, c.REPNO,
      c.STATUS, c.key,
      cl.key key2, c.classid classid2
    from CONTAINERS c, conlabel cl
    where cl.key=c.key
    and p_portid=c.PORTID
    order by c.REPNO;

    return tempcv_container;
  end;
end;
```

6. Click Compile.

7. If any compilation errors occur, check the code for syntax errors and recompile as needed.

8. Click Close.

9. Now that the function is defined, you must add it to the package spec so that it can be referenced. Other program units will know about the function in the package body only if it is described in the package spec.

   In the Object Navigator, double-click the CONT.CV(Package Spec) object.

10. In the Program Unit editor, type the following line above the END; statement:

```sql
    function query_container (p_portid number) return container_refcur;
```

11. Click Close.

12. Choose Program->Compile->All.

13. Click OK when done.

14. In the Object Navigator, double-click the Q_CONTAINERREFCURDS object under the Program Units object.
15. Edit the code to look as follows:

```plsql
function q_containerRefCurDS return cont_cv.container_refcur is
  temp_container cont_cv.container_refcur;
begin
  temp_container := cont_cv.query_container (:portid);
  return temp_container;
end;
```

When you are done, all of the query’s logic will reside in the function named `query_container`. From now on, when you change `query_container`, you will change this and any other queries that reference it.

16. Click Compile.

17. If any compilation errors occur, check the code for syntax errors and recompile as needed.

18. Click Close.

19. Double-click to view the report in the Live Previewer.

20. Save the report as `ref_67.rdf`.

Optional Exercise:
Repeat steps 1 through 19 for the other two queries in the report.

### 6.8 Moving the packages into a library

If you have many reports that use these same ref cursor types and SELECT statements, you can move the program units that you created into a PL/SQL library stored in a file or the database, so that other reports can easily share the code. The steps in this section will help you to move the program units to a PL/SQL library.

1. In the Object Navigator, click the PL/SQL Libraries object.

2. Click to add a new library.

3. Choose File->Save As.

4. Type PORT_CONTAINER as the Library.

5. Click File System.

6. Click OK.
7. Drag and drop the following program units from your report to the Program Units node under the newly created PORT_CONTAINER library:

- CONCL_CV(Package Spec)
- CONT_CV(Package Spec)
- CONT_CV(Package Body)
- PORT_CV(Package Spec)

8. Save PORT_CONTAINER.

9. If the Live Previewer is open, close it.

10. In the Object Navigator, under the Program Units node of your report, delete CONCL_CV(Package Spec), CONT_CV(Package Spec), CONT_CV(Package Body), and PORT_CV(Package Spec).

   **Tip:** If the Live Previewer is open when you delete the packages from the report, you may get some errors.

11. Click the Attached Libraries node for your report.

12. Click \[\] to add a new attached library.

13. In the Attach Library dialog box, click File System.

14. Click **Browse** to find the PORT_CONTAINER library. It will have a `.PLL` file extension. After you have found and selected PORT_CONTAINER, click **Open**.

15. Click **Attach**.


17. Click **OK** to close the Compile window.

18. Double-click \[\] to view the report.

   **Tip:** If you get an error when you attempt to view the report, repeat steps 16 through 18.

19. Save the report as `ref_68.rdf`.

**Optional Exercise:**

Store the PL/SQL library in the database rather than in a file. Note that you will need “create” privileges on the database to complete this optional exercise.
6.9 Summary

Congratulations! You have finished the Ref Cursor Query sample report. You now know how to:

- Create package specs that define ref cursors.
- Create ref cursor queries.
- Create data links between ref cursor queries.
- Create summaries to describe data.
- Create a report layout.
- Move SELECT statements into packages.
- Move packages into a PL/SQL library.

For more information about using ref cursors, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type...
   ref cursor, about
3. Then click Display to view help topic...
   About ref cursor queries
The report described in this chapter is designed to help you learn more about the Report Builder features for Express data. You will build an Express report that summarizes the yearly projected and actual sales for each region and sales channel in a product division.

To build this report, you will use the Report Wizard to create the initial data model and report layout. You will make refinements to the data model and to the Express query. Finally, you will enhance the look of the report in the Layout Model view and Live Previewer.

**About Express**  Express delivers on-line analytical processing (OLAP) using a multidimensional data model. This model is optimized for the analysis of trends or patterns of intersecting corporate data — such as sales, marketing, or financial variables.

The figure on the next page illustrates the 1997 Sales report that you will build. Think of the data you wish to extract as being contained in the volume of a cube. Each side of the cube is a list of variable data contained in a category (i.e., Product). This category and its list of values together is called a dimension. You will select portions of each dimension and analyze them for their interaction with other dimensions. This analysis is called a measure.

An example measure for a sales analysis might select data from dimensions for time, product, geographic division, and channel. With Express, you can create a query to report on information that is as broad (e.g., yearly direct and indirect sales for products sold everywhere) or as narrow (e.g., monthly direct sales for all televisions sold in California) as you like.

Table 7–1, ”Features demonstrated in this sample report of Express data” describes the steps you will take to create this report.
Product dimensions selected by divisions.

Geographic dimension selected by regions/continents.

Channel dimension selected by all channels.

Projected and actual sales measures reported by dimension values selected.

Time dimension selected by 1997 yearly sales.

1997 Sales Report

Product: Accessory Division

<table>
<thead>
<tr>
<th>Region</th>
<th>Channel</th>
<th>All Channels</th>
<th>Direct</th>
<th>Indirect</th>
</tr>
</thead>
<tbody>
<tr>
<td>North</td>
<td>1996</td>
<td>$400,000</td>
<td>$400,000</td>
<td>$100,000</td>
</tr>
<tr>
<td>South</td>
<td>1996</td>
<td>$500,000</td>
<td>$500,000</td>
<td>$150,000</td>
</tr>
</tbody>
</table>

Product: Audio Division

<table>
<thead>
<tr>
<th>Region</th>
<th>Channel</th>
<th>All Channels</th>
<th>Direct</th>
<th>Indirect</th>
</tr>
</thead>
<tbody>
<tr>
<td>North</td>
<td>1996</td>
<td>$300,000</td>
<td>$300,000</td>
<td>$70,000</td>
</tr>
<tr>
<td>South</td>
<td>1996</td>
<td>$400,000</td>
<td>$400,000</td>
<td>$100,000</td>
</tr>
</tbody>
</table>

7-150 Oracle Reports: Building Reports
The `xprs.rdf` file contains the report that you will create after finishing the tasks in this chapter. You may want to refer to this file while you are working. This file is located in your `ORACLE_HOME\TOOLS\DOC60\US\RBBR60` directory.

**Table 7–1 Features demonstrated in this sample report of Express data**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the Report Wizard to define the Express query and create a first draft of the report.</td>
<td>Section 7.1, &quot;Creating an Express report with the Report Wizard&quot;</td>
</tr>
<tr>
<td>Streamline the Express query by specifying dimension values.</td>
<td>Section 7.2, &quot;Refining the Express query&quot;</td>
</tr>
<tr>
<td>Add summary and calculated totals using the Data Model view.</td>
<td>Section 7.3, &quot;Adding summary columns and custom measures to your data model&quot;</td>
</tr>
<tr>
<td>Add summary and calculated totals to the report layout. Enhance the look of the report.</td>
<td>Section 7.4, &quot;Enhancing the report layout&quot;</td>
</tr>
</tbody>
</table>

Before you start building this Express report, you must have already configured Report Builder to run with Express Server, R6.2 and Oracle8 Server for Windows NT with Object Option, R8.0.5, or later. Refer to the *Getting Started* manual for more information on how to do this.

To get started, open Report Builder. If the Welcome dialog box appears, click **Use the Report Wizard** and click **OK**. If not, choose **File->New->Report**. Click **Use the Report Wizard** and click **OK**.

At some point before you generate the report you will need to log on to the Oracle8 database. Choose **File->Connect** to connect to the database. Enter the appropriate logon information. See Section 1.3, "Obtaining database access before you start" for details.

In addition, you will at some point also need to connect to Express Server. Choose **File->Express**
7.1 Creating an Express report with the Report Wizard

The Report Wizard is a great way to start building a report. The Report Wizard alone may give you an Express report that satisfies your requirements. If it doesn’t, you can use the Data Model view, the Live Previewer, and the Layout Model view to further refine your report. For this report, you will start with the Report Wizard. The steps in this section will help you to create the initial report.

The report that you create in this exercise will present the monthly regional and channel projected and actual sales for each product division. Your Express query will have two measures, and each measure will be dimensioned by product, time, geographic area, and channel.

1. If the Welcome page of the Report Wizard appears, click Next.
2. On the Style page, type Sales Report as the Title, and click Matrix with Group as the report style.
   Tip: If you are unsure about what to do on any page of the wizard, click Help.
3. Click Next.
4. On the Type page, click Express query, and click Next. If the Type page does not appear, ensure that you have properly configured the Report Builder to run with Express data.
5. On the Data page, click Express Query.
   Tip: If you haven’t already connected to Express Server, the Connect dialog box appears. Choose the Express Server instance that you want to access. Click OK.
6. In the Express Query dialog box, click Attach Database to choose the path and name of the database that you want to attach to your session.
7. In the Attach Database dialog box, select the directory labeled /oec62/. Select xademo.db. This is the sample database that is provided with Express Server.
8. Click Open to attach the database to your session.
9. In the Express Query dialog box, CTRL-click to select Sales and Projected Sales from the Available Measures list.
10. Click ▶ to move Sales and Projected Sales to the Selected Measures list box. The Express Query dialog will look similar to the one below:

11. Click OK to accept the Express query selections. You will return to the dialog box in a later step to refine the dimension values that are associated with the Sales and Projected Sales measures.

12. On the Data page, click Next.

   Tip: If you haven’t already connected to an Oracle8 database, the Connect dialog box appears. Enter a User Name, Password, and Database. Click OK.

13. On the Groups page, select PRODUCT in the Available Fields list box and click ▶ to move this field to the Matrix Group Fields list box.

14. Repeat this step for TIME so that the Matrix Group Fields box appears as follows:
Creating an Express report with the Report Wizard

15. Click Next.
16. On the Rows page, click GEOG_AREA.
17. Click >.
18. Click Next.
19. On the Columns page, click CHANNEL in the Available Fields list box.
20. Click >.
21. Click Next.
22. On the Cells page, select PROJECTED SALES in the Available Fields list box and click > to move this field to the Matrix Cell Fields list box.

23. Repeat this step for SALES.
25. On the Labels page, change the following labels and widths:

<table>
<thead>
<tr>
<th>Field</th>
<th>Label</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>SALES</td>
<td>Actual Sales</td>
<td>7</td>
</tr>
<tr>
<td>PROJECTED_SALES</td>
<td>Projected Sales</td>
<td>7</td>
</tr>
<tr>
<td>GEOG_AREA</td>
<td>Region</td>
<td>10</td>
</tr>
<tr>
<td>PRODUCT</td>
<td>Product:</td>
<td>10</td>
</tr>
<tr>
<td>TIME</td>
<td>Time:</td>
<td>10</td>
</tr>
<tr>
<td>CHANNEL</td>
<td>Channel</td>
<td>7</td>
</tr>
</tbody>
</table>

**Tip:** You will change the width of labels at this point because in a later step you will add a new layout column. This will cause columns to wrap to the next page at their current default width of 10 points each.

26. On the Template page, click Predefined template if it is not already selected, and click Cyan Grid Landscape in the list box.
27. Click Finish. The report output automatically displays in the Live Previewer and should look similar to the following figure.
28. Choose File->Save As. Save the report in the directory of your choice, and name the report xprs_710.rdf.

Tip: It is good practice when you are designing your report to save it frequently under a different file name. If you generate an error or if you don’t like some of the changes that you made, you easily can go back to the previously saved file and make revisions from that point.
7.2 Refining the Express query

The steps in this section will help you refine the Express query. So far you have developed a useful report that shows the monthly projected and actual sales for each region and channel in a product category. But you are really interested in the yearly projected and actual sales results for each channel and region in a product division. You can achieve this by restricting the dimension values that you want to view.

In this exercise, you will specify the following dimension values in the Express Query dialog box:

- projected and actual sales for 1997
- geographic regions, such as Asia and the Americas
- product divisions, such as the Accessory and Audio division

1. In the Live Previewer, choose Tools->Report Wizard.
2. On the Data page, click Express Query.
3. In the Express Query dialog box, click Selector.
4. In the Selector dialog box, click Time Period from the Dimensions option.
5. Click to select the List tool from the toolbar.
6. In the List dialog box, choose 1997 from the Available Time Periods list box.
7. Click Select. Notice that 1997 replaces the previous selections.
8. Click OK.
9. In the Selector dialog box, click Geographical Area from the Dimensions option.
10. Click to select the Level tool from the toolbar.
11. In the Select by Level dialog box, choose Continents/Regions in the At level(s) list box.
12. Click OK.
In the Selector dialog box, click Product from the Dimensions option.

Click .

In the Select by Level dialog box, choose Divisions in the At level(s) list box.

Click OK.

In the Selector dialog box, click OK.

In the Express Query dialog box, click OK.

On the Groups page, click TIME in the Matrix Groups Fields list box. Note that using TIME as a break group is no longer necessary since the Express query will retrieve only aggregate data for 1997.

Click . PRODUCT should be the only dimension that is listed in the Matrix Group Fields list box.

On the Style page, change the title to 1997 Sales Report.

Click Finish. Your report should look similar to the following figure:

1997 Sales Report

**Product: Audio Division**

<table>
<thead>
<tr>
<th>Region</th>
<th>Channel</th>
<th>All Channels</th>
<th>Direct</th>
<th>Indirect</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Projected Sales</td>
<td>Actual Sales</td>
<td>Projected Sales</td>
</tr>
<tr>
<td>Areas in the Americas</td>
<td></td>
<td>4692000</td>
<td>3627630</td>
<td>1671670</td>
</tr>
<tr>
<td>Australia</td>
<td></td>
<td>1630090</td>
<td>1005160</td>
<td>534039</td>
</tr>
<tr>
<td>Europe</td>
<td></td>
<td>935500</td>
<td>489870</td>
<td>2417680</td>
</tr>
<tr>
<td>Asia</td>
<td></td>
<td>595650</td>
<td>302070</td>
<td>196230</td>
</tr>
</tbody>
</table>

**Product: Video Division**

<table>
<thead>
<tr>
<th>Region</th>
<th>Channel</th>
<th>All Channels</th>
<th>Direct</th>
<th>Indirect</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>Projected Sales</td>
<td>Actual Sales</td>
<td>Projected Sales</td>
</tr>
<tr>
<td>Areas in the Americas</td>
<td></td>
<td>3763410</td>
<td>2497640</td>
<td>1255070</td>
</tr>
<tr>
<td>Australia</td>
<td></td>
<td>108670</td>
<td>735079</td>
<td>372791</td>
</tr>
</tbody>
</table>

Save the report as xprs_720.rdf.

If you want, compare this report with the one that you previously saved as xprs_710.rdf.
Notice the projected and actual sales. In the new report, each cell represents the yearly sales for a region and channel in a product division for 1997, while the previous report displays sales data for a region and channel in a product division for each month.

7.3 Adding summary columns and custom measures to your data model

The steps in this section will help you refine the data model to include summary totals for each channel in a product division. Additionally, you are curious about how accurately you predicted the actual sales. You can find this out by creating a custom measure that calculates the percent of sales above projected sales.

First, you will create the summary column using the Summary tool in the Data Model view.

Next, you will create the custom measure using the Custom Measure tool in the Express Query dialog box.
Before you begin, take a look at the data model:

![Diagram of data model]

In the Data Model view you may notice additional columns, such as S_GEOG_AREA, or S_CHANNEL. These are *dimension sorting* columns. They are visible only in the data model and are the index used to sort dimensions by logical order, as opposed to alpha-numeric order. If you move a column to a new group, you must also move the associated sort column into that group as well.

1. For online help on this task, choose Help->Report Builder Help Topics
2. On the Index page, type...
   - dimension sorting
3. In the Topics Found dialog box, select...
   - new feature
4. Then click Display to view help topic...
   - Dimension sorting

In a later step, you will sort dimension values using the **Sort** tool in the **Express Query** dialog box.
Adding summary columns and custom measures to your data model

7.3.1 Renaming data objects

1. In the Object Navigator, double-click under your report’s node if you are not already viewing the Data Model view.

2. Click QE_1.


   Tip: If you want to modify your Express query, click the Express Query property under the Query node.

4. Under the General Information node, change the Name property to QE_SALES.

5. Press Enter or click outside of the property to accept the value. Close the Property Palette.

6. Repeat steps 2 through 5 and change the Name property of the G_PROJECTED SALES group to G_SALES_DATA.

7. Save your report as xprs_731.rdf.

7.3.2 Creating summary columns

In this exercise, you will add two summary columns to the G_Cross group. Each summary column will calculate the projected and actual sales totals for each channel (all channels, direct, and indirect) in a product division.

1. In the Data Model view, click , then click the G_Cross group.

2. Select Tools->Property Palette.

3. Set the following properties for projected sales:

<table>
<thead>
<tr>
<th>Node</th>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Information</td>
<td>Name</td>
<td>CS_PjSalesPerChannel</td>
</tr>
<tr>
<td>Column</td>
<td>Product Order</td>
<td>G_CHANNEL</td>
</tr>
<tr>
<td>Summary</td>
<td>Source</td>
<td>PROJECTED_SALES</td>
</tr>
<tr>
<td></td>
<td>Reset At</td>
<td>G_CHANNEL</td>
</tr>
</tbody>
</table>

4. Press Enter or click outside of the property to accept the value. Close the Property Palette.
5. Repeat steps 1 through 4 to create a summary column for actual sales. Set the following properties:

<table>
<thead>
<tr>
<th>Node</th>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Information</td>
<td>Name</td>
<td>CS_SalesPerChannel</td>
</tr>
<tr>
<td>Column</td>
<td>Product Order</td>
<td>G_CHANNEL</td>
</tr>
<tr>
<td>Summary</td>
<td>Source</td>
<td>SALES</td>
</tr>
<tr>
<td></td>
<td>Reset At</td>
<td>G_CHANNEL</td>
</tr>
</tbody>
</table>

6. Save your report as xprs_732.rdf.

### 7.3.3 Creating a custom measure

In this exercise, you will create a custom measure that will calculate the percent of actual sales above projected sales for each region and in each product division. To do this you will use the Custom Measure tool within the Express Query dialog box to build the new measure called Increase.

1. In the Data Model view, double-click the QE_Sales query object to open the Express Query dialog box.
2. Click Custom Measure at the bottom of the Express Query dialog box.
3. Click New... to open the Custom Measure — New dialog box.
4. In the Name box type INCREASE.
5. In the Description box type Increase.
6. Click Template under Operators in the Category box. Notice a list of templates appears under Choices.
7. Select the left parenthesis and then click Insert. A left parenthesis appears in the Expression box.
8. Click Measures under Express Objects in the Category box.
9. Select FSALES and then click Insert.
10. Use the following table to build the expression:

Table 7–5  Categories and Choices for custom measure Increase

<table>
<thead>
<tr>
<th>Category</th>
<th>Sub-category</th>
<th>Choose</th>
<th>or Type:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operators</td>
<td>Numeric</td>
<td>Minus Sign</td>
<td>-</td>
</tr>
<tr>
<td>Express Objects</td>
<td>Measures</td>
<td>F.WHATIF</td>
<td>F.WHATIF</td>
</tr>
<tr>
<td>Operators</td>
<td>Template</td>
<td>Right parenthesis</td>
<td>)</td>
</tr>
<tr>
<td>Operators</td>
<td>Numeric</td>
<td>Forward slash</td>
<td>/</td>
</tr>
<tr>
<td>Express Objects</td>
<td>Measures</td>
<td>F.WHATIF</td>
<td>F.WHATIF</td>
</tr>
<tr>
<td>Operators</td>
<td>Numeric</td>
<td>asterisk</td>
<td>*</td>
</tr>
</tbody>
</table>

11. Following the asterisk, type 100 in the Expression box.

12. When you are finished, your expression should look like the following figure:
13. Click OK. Note that Increase is listed in the Custom Measures text box in the Custom Measures dialog box.

14. Click Close.

15. In the Express Query dialog box, scroll through the Available Measures box. Increase now appears alphabetically. Click Increase and then click >. Increase appears in the Selected Measures box, below Projected Sales and Sales.

16. Click OK to return to the Data Model. The group G_SALES_DATA now includes the custom measure you just created, INCREASE.

17. Click to view the report in Live Previewer. Note that neither the summary columns nor the custom measure are available in the report. This occurred because you have not yet added them as fields to the report layout. You will do this in the next few exercises.

18. Save your report as xprs_733.rdf.

7.4 Enhancing the report layout

The steps in this section will show you how to re-arrange the report layout, add the summary and custom measure columns that you created in Section 7.2, “Refining the Express query”, and format objects to further enhance the look of your report. You make these changes using the Layout Model view and Live Previewer.

7.4.1 Inserting summary fields in the report

1. In the Object Navigator, double-click under your report’s node to display the Layout Model view.

2. Arrange your workspace to display the Object Navigator and the Layout Model view side-by-side. Expand the Layout Model, Main Section, Body, and the remaining nested nodes, such as the MG_PRODUCT_GRPFR and R_G_PRODUCT nodes. Your workspace should look similar to the following figure:
3. In the Object Navigator, type `M_G_CROSS_GRPFR` in the Find field to locate this object. Note that the search occurs as you type, so you will most likely be taken to the object before you finish typing the entire name. In the Layout Model view, the master cross-matrix frame is selected as illustrated in the following figure:

![Object Navigator](image1.png)

4. Extend the selected frame down about 1/4 inch as illustrated in the following figure:

![Extended Frame](image2.png)

5. Click `F_CHANNEL` in the Object Navigator.
6. Click to select the parent frame, R_G_CHANNEL, as illustrated in the following figure:

![Frame selection](image)

Tip: You may need to resize your Layout Model window to see the button, as it is located on the far right of the toolbar.

7. Extend the frame down about 1/4 inch as illustrated in the following figure:

![Frame extension](image)

8. Click .

9. Click and drag a rectangle in the area directly under the F_PROJECTED_SALES field to insert a field object as follows:

![Field insertion](image)

10. Tools->Property Palette.

11. Set the following properties:

   **Table 7–6 Projected Sales per Channel field properties**

<table>
<thead>
<tr>
<th>Node</th>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Information</td>
<td>Name</td>
<td>F_PjSalesPerChannel</td>
</tr>
<tr>
<td>Field</td>
<td>Source</td>
<td>CS_PjSalesPerChannel</td>
</tr>
</tbody>
</table>
12. Arrange this field and change the format as follows:
   - Click to change fill color to light yellow.
   - Click to change the text color to dark brown.
   - Click to surround the field with dark brown border lines.

   **Tip:** You can turn Snap to Grid on or off as desired to help you arrange objects in the layout. Select View->Snap to Grid. A check mark indicates that the option is on.

13. Repeat steps 8 through 11 except place the new object directly under F_SALES. Set the following properties:

<table>
<thead>
<tr>
<th>Table 7–7 Sales per Channel field properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node</td>
</tr>
<tr>
<td>General Information</td>
</tr>
<tr>
<td>Field</td>
</tr>
</tbody>
</table>

   **Tip:** Note that the fill and text colors, as well as the border lines, match the field you just created, F_PjSalesPerChannel.

14. Click [T].

15. Click and drag a rectangle to fill the space directly under F_GEO_AREA.

16. Type Totals:. 

17. Align the text object to center by clicking and make format changes to match the summary fields you created.
18. Click to view the changes in the Live Previewer. Your report should look similar to the one displayed here:

![Image of a report](image)

**Product: Audio Division**

<table>
<thead>
<tr>
<th>Channel</th>
<th>All Channels</th>
<th>Actual Sales</th>
<th>Projected Sales</th>
<th>Actual Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Areas in the Americas</td>
<td>345020</td>
<td>2305080</td>
<td>3027530</td>
<td>3025320</td>
</tr>
<tr>
<td>Australia</td>
<td>1034500</td>
<td>225800</td>
<td>1005100</td>
<td>1005160</td>
</tr>
<tr>
<td>Europe</td>
<td>2345600</td>
<td>1042340</td>
<td>4997670</td>
<td>4997670</td>
</tr>
<tr>
<td>Asia</td>
<td>3045600</td>
<td>443760</td>
<td>2023600</td>
<td>2023670</td>
</tr>
<tr>
<td>Totals:</td>
<td>17442580</td>
<td>25016020</td>
<td>11550730</td>
<td>11550730</td>
</tr>
</tbody>
</table>

19. Save the report as xprs_741.rdf.

**7.4.2 Inserting the custom measure field into the report**

You will add a column to display the custom measure you created in Section 7.3.3, "Creating a custom measure" by inserting a field object in the report layout.

To do this, you will add a new column to the layout of your report and then insert the field object into the column.

**Tip:** The new field object also must have the same frequency as F_PROJECTED_SALES and F_SALES. If the field object is not at the same frequency, the report will fail to run.

1. In Live Previewer, click to display the Layout Model view. Ensure that the Layout Model view and Object Navigator are placed side-by-side.

2. In the Object Navigator, Ctrl-click M_G_PRODUCT_GRPFR and R_G_PRODUCT.

**Tip:** M_G_PRODUCT_GRPFR is the underlying master group. It is hidden directly under R_G_PRODUCT. In the Layout Model view, it may look like only one group is selected when, in fact, both frames are selected.
3. In the Layout Model, expand the width of the selected frames to about 4 3/4 inches.

   **Tip:** Click  to turn Flex mode on, or click  to turn Flex mode off if you are unable to resize or move an object.

4. In the Object Navigator, click M_G_CROSS_GRPFR.

5. In the Layout Model, expand the width of the selected frame to about 4 3/4 inches. It should look similar to the figure below:

![Diagram](image1)

6. Click the F_GEOG_AREA object, then click  to select the parent frame, R_G_GEOG_AREA:

![Diagram](image2)

7. Expand the width of the selected frame to about 4 3/4 inches.

8. Click F_CHANNEL and click  to select the parent frame, R_G_CHANNEL.

9. Expand the width of the selected frame to about 4 3/4 inches:

![Diagram](image3)

10. Click F_CHANNEL again and expand the width of the object to about 4 3/4 inches:

![Diagram](image4)
11. Click .

12. Click and drag a box to the right of the F_SALES object. It should look similar to the figure below:


14. Set the following properties:

<table>
<thead>
<tr>
<th>Node</th>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Information</td>
<td>Name</td>
<td>F_Increase</td>
</tr>
<tr>
<td>Field</td>
<td>Source</td>
<td>INCREASE</td>
</tr>
</tbody>
</table>

15. Click to run the report. You should see an error indicating that F_Increase references INCREASE at a frequency below its group. You are unable to run your report.

To understand why this error occurred, look for F_INCREASE in the Object Navigator. It is probably placed at a higher level (and lower frequency) than R_G_PROJECTED_SALES. Recall that the column INCREASE calculates the percent of actual sales above projected sales. In order to run this report, F_INCREASE must have the same frequency as F_PROJECTED_SALES and F_SALES to reference the data it needs to calculate the value.

16. Click OK to close the error message.

17. Click to display the Layout Model view.

18. Select the field F_INCREASE and delete it.

19. Click F_SALES and then click to select the parent frame, R_G_PROJECTED_SALES.
20. Expand the width of the selected frame to about 4 3/4 inches:

![Image of the modified report layout]

21. Repeat steps 11 through 14 to create the field object. Your layout model should resemble the following figure:

![Image of the modified field object]

22. With the F_Increase object selected, locate F_INCREASE in the Object Navigator to ensure that it has the same frequency as F_PROJECTED_SALES and F_SALES. The Object Navigator should look similar to the figure below:

![Image of the modified Object Navigator]
23. Change the format of the F_Increase field as follows:
   - Click \(\textcolor{yellow}{
\begin{array}{c}
\text{\textcolor{black}{\textbf{F_Increase}}} \\
\end{array}\)
\) to change fill color to light yellow.
   - Click \(\textcolor{brown}{
\begin{array}{c}
\text{\textcolor{black}{\textbf{F_Increase}}} \\
\end{array}\)
\) to change the text color to dark brown.
   - Click \(\textcolor{brown}{
\begin{array}{c}
\text{\textcolor{black}{\textbf{F_Increase}}} \\
\end{array}\)
\) to surround the field with dark brown border lines.
   - Click \(\textcolor{brown}{
\begin{array}{c}
\text{\textcolor{black}{\textbf{F_Increase}}} \\
\end{array}\)
\) to make the text darker and more noticeable.

24. Click \(\textcolor{brown}{
\begin{array}{c}
\text{\textcolor{black}{\textbf{F_Increase}}} \\
\end{array}\)
\).

25. Click and drag a rectangle above F_Increase to add the column title.

26. Type Increase.

27. Arrange the text object in the column and change the format to match the field to its left, Actual Sales.

   **Tip:** You may wish to turn off Snap to Grid on the View pull-down menu in order to extend the text object to cover the entire field. Make sure the text object is selected when you apply formatting, or it will not take effect.

   Your layout model should resemble the following image:
28. Click 📊. The report should look similar to the figure below:

![1997 Sales Report](image)

Product: Audio Division

Product: Video Division

29. Save the report as xprs_742.rdf.
7.4.3 Sorting dimension values

Suppose you wish to change the sorting order of the distribution channels in your report. In this exercise, you will change the sorting criteria for the Channel dimension by using the Selector in the Express Query dialog box. Instead of listing the order by the default channel hierarchy (top to bottom), you will display data from the lowest to the highest channel in the hierarchy. Note: the hierarchy is predefined in the database to place “All Channels” first, with “Indirect” placed last.

1. In the Data Model view, double-click the query object, QE_SALES.
2. Click Selector in the Express Query dialog box.
3. In the Dimensions list, select Distribution Channel and then click .
4. In the Sort Selection dialog box, choose the following values:

<table>
<thead>
<tr>
<th>Criteria</th>
<th>Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>based on</td>
<td>hierarchy</td>
</tr>
<tr>
<td>in order</td>
<td>bottom to top</td>
</tr>
<tr>
<td>in hierarchy</td>
<td>Standard</td>
</tr>
</tbody>
</table>

5. Click OK in the Sort Selection dialog box.
6. Click OK in the Selector dialog box.
7. Click OK in the Express Query dialog box.
8. Click . The report should look similar to the figure below. Note that Indirect is first while All Channels is last in the order:

Product: Audio Division

<table>
<thead>
<tr>
<th>Region</th>
<th>Channel</th>
<th>Indirect Projected Sales</th>
<th>Indirect Actual Sales</th>
<th>Direct Projected Sales</th>
<th>Direct Actual Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Areas in the Americas</td>
<td>Indirect</td>
<td>187,167.00</td>
<td>42,776.30</td>
<td>178,411,110.421</td>
<td>35,276.30</td>
</tr>
<tr>
<td></td>
<td>Australia</td>
<td>534,000.00</td>
<td>120,000.00</td>
<td>524,111,171.14</td>
<td>100,510.00</td>
</tr>
<tr>
<td></td>
<td>Europe</td>
<td>241,880.00</td>
<td>55,267.30</td>
<td>226,411,110.26</td>
<td>48,976.30</td>
</tr>
<tr>
<td></td>
<td>Asia</td>
<td>1068,250.00</td>
<td>241,130.00</td>
<td>1043,111,186.3</td>
<td>220,203.00</td>
</tr>
<tr>
<td><strong>Totals</strong></td>
<td><strong>Indirect</strong></td>
<td><strong>699,184.00</strong></td>
<td><strong>134,652.80</strong></td>
<td><strong>674,528.18</strong></td>
<td><strong>115,507.30</strong></td>
</tr>
</tbody>
</table>

Building a Report Using Express Data  7-173
9. Save the report as xprs_743.rdf.

7.4.4 Making format changes in Live Previewer

1. In Live Previewer, shift-click the columns under Projected Sales and Actual Sales, and the Projected Sales total and the Sales total fields.
2. Click 📊 to change the format mask to currency.
3. Click 🎯 to right justify the values.
4. Click 📊 twice to insert two decimal places
5. Click the column under Increase.
6. Click 📊 to change the format mask to percentage.
7. Click 🎯 to center the values.
8. The report should now look similar to the figure below:

![Image of the report with enhanced layout]

9. Save the report as xprs_744.rdf.
7.5 Summary

Congratulations! You have finished the Express sample report. You now know how to:

- Use the Report Wizard to define a data model and layout.
- Make changes to the Express query by restricting the dimension values.
- Use the Data Model view to add summary and custom measures columns to the report.
- Use the Layout Model view to insert fields and re-arrange the layout.
- Use the Live Previewer to enhance the look of the report.

For more information about Express, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics
2. On the Index page, type...
   Express, working with
3. Then click Display to view help topic...
   Working with Express
Index

A
accessing
database, 6
demo tables, 6
adding
boilerplate object, 115
bookmarks, 16, 71
format exception, 14
format masks, 68
HTML header to template, 36
hyperlink destinations, 73
hyperlinks, 74
hyperlinks to external destinations, 74
Javscript, 86, 90
summary columns, 138
applying template to report, 43

B
boilerplate object, adding, 115
bookmarks, adding, 16, 71
break group, creating, 28, 134

C
changing object properties, 111
chart, adding to summary section, 80
code, modifying, 20
columns, summary, 138
Conditional Formatting dialog box, about, 7
conditional formatting, about, 7
conditional hide/show for web output, 79
Confine Mode, defined, 114
creating
break group, 28, 134
data link, 29
data model, 27, 64, 96
default layout, 106
default report layout, 30
layout, 140
links between ref cursor queries, 136
package body, 143
pop-ups, 77
ref cursor query, 132
rollovers, 78
summary section with chart, 80
template, 34

D
data link, creating, 29
Data Model
objects, renaming, 28
refining, 98
view, description, 5
data model
creating, 27, 64, 96
Data Wizard
description, 3
using, 96
default attributes
overriding, 50
templates, 45
default layout, creating, 30, 106
defining
package spec, 130
ref cursor types, 130
demo table, accessing, 6
designing a Runtime Parameter Form, 105
<table>
<thead>
<tr>
<th>E</th>
<th>external destinations, adding hyperlinks to, 74</th>
</tr>
</thead>
</table>
| F | fetching data, 127  
Format Exception  

dialog box, about, 7  
format exception  

adding, 14  
adding to repeating frame, 19  
format mask, adding, 68  
Format Trigger property, about, 7  
formatting objects in Live Previewer, 32  
frames, re-arranging, 113 |
| H | HTML  

header, adding to template, 36  
report, 61  
report header, 70  
hyperlink  

adding, 74  
adding to external destinations, 74  
destinations, adding, 73 |
| I | including HTML report header, 70 |
| J | Javascript, adding, 86 |
| L | Layout Model view  

description, 5  
formatting a report, 35  
using, 110  
layout, creating, 140  
links, creating between ref cursor queries, 136  
Live Previewer  

description, 4  
formatting objects, 32  
using to modify a report, 12 |
| M | modifying  

code, 20  
report output, 67  
moving output into a library, 145  
multiple object selection, 13 |
| O | object  

boilerplate, adding, 115  
properties, changing, 111  
Object Navigator, description, 5  
objects, re-arranging, 113  
operating system considerations, 6  
overriding template attributes, 50 |
| P | package  

body, creating, 143  
moving a SELECT statement into, 143  
moving into a library, 145  
spec, defining, 130  
page  

breaks, specifying, 122  
separator, changing, 72  
Parameter Form view  

description, 5  
using, 105  
PDF, generating, 16  
PL/SQL, fetching data, 127  
pop-ups, creating, 77  
predefined template list, adding template, 39  
Program Unit Editor, using, 132  
properties, changing, 111 |
| Q | query, rows returned, 69 |
| R | re-arranging frames and objects, 113 |
ref cursor
queries, about, 127
queries, creating links between, 136
query, creating, 132
type, defining, 130
renaming Data Model objects, 28
repeating frame, adding formatting exception, 19
report
header, HTML, 70
output, modifying, 67
sections, about, 93
styles, viewing, 40
Report Builder
starting, 9, 151
what is, 1
Report Editor, description, 4
Report Wizard
description, 2
using, 10, 152
reports
basics, 1
conditional formatting, 7
Express, 149
ref cursors, 127
sections, 93
templates, 23
web, 61
required software, 6
rollover, creating, 78
rows returned by query, 69
Runtime Parameter Form, designing, 105

S
sections, about, 93
SELECT statement, moving into a package, 143
shift-clicking objects, 13
software required, 6
specifying report distribution, 123
SQL Query tool, using, 27
starting Report Builder, 9, 151
summary
columns, adding, 138
section, creating, 80
T
template
about, 23
adding HTML header, 36
adding to predefined template list, 39
applying to a report, 43
creating, 34
default attributes, 45
default attributes, overriding, 50
text conventions, xii
U
using
Data Wizard, 96
Layout Model view, 110
Report Wizard, 10, 152
Web Wizard, 71
V
viewing
report styles, 40
reports, 4
W
web report, 61
Web Wizard
description, 4
using, 71
wizards, description, 2