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Preface

The examples in this book are intended to help you learn about Oracle Reports 
Developer and its features.

Intended audience
This book is intended for anyone who uses Report Builder to build reports.   The 
needs of both novice and advanced users are addressed. Each chapter contains 
step-by-step instructions to build a report from start to finish. Each report that you 
build will demonstrate how to use many of the powerful features in Report Builder.

Structure
This book contains the following chapters:

Table 0–1 Summary of manual contents

Chapter Description

Chapter 1, "Basic Report Builder 
Concepts"

Contains basic information to get you started.

Chapter 2, "Building a Report with 
Conditional Formatting"

Describes how to build a report that uses 
conditional formatting so that the appearance 
of your report automatically changes when 
certain specified criteria are met.
xi



Notational conventions
The following conventions are used in this book:

Chapter 3, "Building and Applying 
Report Templates"

Describes how to create a template and apply it 
to a report. Templates define common 
characteristics and objects in a report. When 
you apply a template to a report, the report 
takes on the characteristics defined in the 
template.

Chapter 4, "Building a Report for the 
Web"

Describes how to create an HTML report that 
can be viewed on the web, including how to 
configure Web Settings properties. 

Chapter 5, "Building a Report with 
Sections"

Describes how to define report sections, and how to 
specify different distribution criteria for these 
sections.

Chapter 6, "Building a Report with 
Ref Cursor Queries"

Describes how to define a ref cursor query, which 
uses PL/SQL to fetch data.

Chapter 7, "Building a Report Using 
Express Data"

Describes how to build and edit a report using 
Express data, and how to add custom measures.

Table 0–2 Notational conventions used in manual

Convention Meaning

boldface text Used for emphasis. Also used for menu items, 
button names, labels, and other user interface 
elements.

italicized text Used to introduce new terms.

courier font Used for path and file names, and for code and text 
that you type.

Table 0–1 Summary of manual contents

Chapter Description
xii



Additional information in online help
Some of the tasks in this manual tell you how to access online help for additional 
information. If you see a table like the one that follows, use the steps to get more 
information about the task you are performing:

COURIER CAPS Used for:

■ File extensions (.PLL or .FMX)

■ Environment variables

■ SQL commands

■ Built-ins/package names

■ Executable names

1. For online help on this topic, choose 

2. On the Index page, type...
report wizard, about

3. Then click Display to view the help topic... 
Report Wizard: Welcome page

Table 0–2 Notational conventions used in manual

Convention Meaning
xiii
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                                         Basic Report Builder Con
1

Basic Report Builder Concepts

This chapter introduces some basic information about Report Builder, such as:

■ Section 1.1, "What is Report Builder?"

■ Section 1.2, "Tools for working with reports in Report Builder"

■ Section 1.3, "Obtaining database access before you start"

■ Section 1.4, "Other software needed before you start"

■ Section 1.5, "Operating system considerations"

1.1 What is Report Builder?
Oracle Reports Developer is a suite of programs that allows your organization to 
centralize report processing and to better manage reporting. Report Builder is one 
of the program components included with Reports Developer.

Report Builder includes:

■ A query builder with a visual representation of the specification of SQL 
statements to obtain report data

■ Wizards that guide you through the report design process

■ Default report templates and layouts that can be customized to meet your 
organization’s reporting needs

■ The ability to generate code to customize how reports will run

■ A Live Previewer that allows you to edit report layouts in WYSIWYG mode

■ An integrated chart builder that helps you to graphically represent report data
cepts 1-1



Tools for working with reports in Report Builder
■ Web publishing tools that dynamically generate web pages based on your 
corporate data

■ Other standard report output formats like HTML, PDF, PCL, Postscript, and 
ASCII

Reports Developer can access data from any database you may have in your 
organization, including: Oracle, Microsoft SQL Server, Sybase, Informix, DB2, and 
any ODBC-compliant data source.

1.2 Tools for working with reports in Report Builder
Report Builder provides the tools to help you create and manage reports. These 
tools are described in the following sections:

■ Section 1.2.1, "Using wizards to automate report design"

■ Section 1.2.2, "Using the Report Editor to view and edit reports"

■ Section 1.2.3, "Using the Object Navigator to locate report elements"

1.2.1 Using wizards to automate report design
Report Builder has a Report Wizard, Data Wizard, and Web Wizard to automate the 
creation of reports. Most often, you can create a report by starting with one of the 
wizards, and then refining the report that the wizard creates. 

For example, you can start with the Report Wizard to create an initial report, which 
the Report Wizard automatically displays in the Live Previewer. From there, you 
can make modifications to the report in the Live Previewer, Layout Model view, 
Data Model view, and Parameter Form view. See Section 1.2.2, "Using the Report 
Editor to view and edit reports" for information about report views.

1.2.1.1 Report Wizard
The easiest way to create a report is to use the Report Wizard. The Report Wizard 
takes you through the steps required to create a report, and is a great way to start 
building a report. The Report Wizard alone may give you a report that satisfies your 
requirements. If it doesn’t, you can use the Data Model view, the Live Previewer, 
and the Layout Model view to further refine your report.
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Tools for working with reports in Report Builder
Many of the sample reports in this manual will instruct you on how to build a 
report using the Report Wizard. A brief overview of how to use the Report Wizard 
follows:

1. Start Report Builder.

2. If the Welcome dialog box appears, click Use the Report Wizard and click OK. 

If the Welcome dialog box does not appear, choose File->New->Report. Click 
Use the Report Wizard and click OK.

3. Fill out each page of the Report Wizard, getting help when needed by clicking 
the Help button.

4. On the last page of the Report Wizard, click Finish. A report is created and 
appears in the Live Previewer.

5. From the Live Previewer, you can edit the report as desired. Note that the Live 
Previewer is one of several report views that are available in the Report Editor. 
Using the View menu or the toolbar, you can switch to other report views to 
further edit your report. Section 1.2.2, "Using the Report Editor to view and edit 
reports" talks more about different ways to view a report.

For more information about the Report Wizard, see the online help:

1.2.1.2 Data Wizard
If you need to create multiple queries for your report, use the Data Wizard to create 
them. From the Data Model view, choose Tools->Data Wizard. Section 5.1.1, 
"Building queries using the Data Wizard" contains an example that uses the Data 
Wizard. For more information, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
report wizard, about

3. Then click Display to view help topic... 
Report Wizard: Welcome page

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
data wizard, about

3. Then click Display to view help topic... 
Data Wizard: Welcome page
                                    Basic Report Builder Concepts 1-3



Tools for working with reports in Report Builder
1.2.1.3 Web Wizard
If you want to quickly deploy your reports on the Web, use the Web Wizard. Choose 
Tools->Web Wizard. Section 4.4, "Adding bookmarks to parts of your report" 
contains an example that uses the Web Wizard. For more information, see the online 
help:

1.2.2 Using the Report Editor to view and edit reports
The Report Editor and the Object Navigator appear when you first start up Report 
Builder. (For information about the Object Navigator, see Section 1.2.3, "Using the 
Object Navigator to locate report elements".) In the Report Editor, you can view 
information about a report in four different ways. You can switch between these 
views using the View menu or the toolbar icons.

You will work in each of the following Report Editor views as you create the sample 
reports in this manual:

■ Live Previewer

■ Data Model view

■ Layout Model view

■ Parameter Form view

For more information, see the online help:

1.2.2.1 Live Previewer
This view displays your report as an end user would see it. If you are using live 
data, the Live Previewer will update the report as data changes. Any modifications 
that you make to the report in the Live Previewer display immediately. To display 
your report in the Live Previewer, click .

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
web wizard, about

3. Then click Display to view help topic... 
Web Wizard: Welcome page

1. For online help on these topics, choose Help->Report Builder Help Topics

2. On the Index page, type...
Live Previewer, about; or Data Model view, about; or Layout Model view, about; or 
Parameter Form view, about

3. Then click Display to view help topic.
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Tools for working with reports in Report Builder
1.2.2.2 Data Model view
This view displays your report data as data model objects so that you can see the 
relationships between queries, groups, columns, parameters, and links. To display 
your report in the Data Model view, click . 

1.2.2.3 Layout Model view
This view displays the attributes of your report as objects so that you can see the 
attribute types and relationships. You can edit layout objects, such as frames, 
repeating frames, fields, boilerplates, anchors, and graphics in this view in order to 
change the appearance of the report. To display your report in the Layout Model 
view, click .

1.2.2.4 Parameter Form view
This view lets you create a Runtime Parameter Form for your report. When a user 
runs your report, the user enters values for parameters in this form to determine 
how the report will execute, or the user accepts the defaults. If you do not define a 
Runtime Parameter Form in the Parameter Form view, Report Builder displays a 
default Parameter Form at runtime. You can select which system and user 
parameters to use for your form using the Parameter Form Builder, or you can 
create your own from scratch. To display the Parameter Form view, click .

1.2.3 Using the Object Navigator to locate report elements
The Object Navigator and Report Editor appear when you first start up Report 
Builder. The Object Navigator provides a hierarchical display of all major objects in 
a report or template, including attached libraries and external queries. Using the 
Object Navigator, you can:

■ Select an object

■ Open the Property Palette to change an object’s attributes

■ Edit an object’s PL/SQL

■ Drag and drop PL/SQL program units

■ Search for an object by name

When you select an object in the Object Navigator, the corresponding object is 
simultaneously selected in the Live Previewer, Data Model view, or Layout Model 
view (whichever view is open at the time).
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Obtaining database access before you start
1.3 Obtaining database access before you start
In order to build the reports as described in this manual, you must be able to access 
the Oracle Reports Developer demo tables. Use the demo CD that came with your 
product package to install the SQL scripts. These scripts are used to install the demo 
tables in your database. These SQL scripts can be run from the Start->Programs 
menu.

Before starting a report, be sure to log into the database that contains the Oracle 
Reports Developer demo tables. You log in by selecting File->Connect.

1.4 Other software needed before you start
The following programs may be required to view some of the sample reports. 
Before you start, check that your system has the following:

■ Web browser, such as Netscape 3.x or higher, or Internet Explorer 3.x or higher, 
that supports HTML style sheets and Javascript

■ Adobe Acrobat Reader plug-in, or the ability to view Acrobat Reader PDFs

1.5 Operating system considerations
The steps in this book were written based on the Windows 95/NT operating 
environment. If you are using another operating system, for example a UNIX-based 
system, there may be slight variations in some of the steps you need to perform. 
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Building a Report with Conditional Form
2

Building a Report with Conditional

Formatting

The report described in this chapter will help you learn more about Report Builder 
features for conditional formatting. You will build a single-query report that records 
company stock prices, and then displays values using conditional formatting when 
the price of a stock hits minimum and maximum values.

To build this report, you will use the Report Wizard to create the initial data model 
and report layout. You will make refinements to the report layout in the Live 
Previewer. You will also write PL/SQL, which is provided for you.

About conditional formatting It is often useful to highlight certain parts of your 
report when particular conditions are met. For example, you can change the color of 
a value to red when it is greater than 5000. Report Builder provides two ways of 
adding conditional formatting to your report:

■ The Conditional Formatting and Format Exception dialog boxes lets you specify 
multiple conditions and formatting attributes (font, text color, border, and fill 
color) for a selected layout object. You don’t write any code with this method.

■ The Format Trigger property allows you to code your own PL/SQL functions to 
perform conditional formatting. Because you write the code yourself, you have 
more flexibility and complete control when compared to using the Conditional 
Formatting and Format Exception dialog boxes alone.

For many conditions, you often can do what you need using the Conditional 
Formatting and Format Exception dialog boxes. For other conditions, you may want 
to use the dialog boxes to get started, and then modify the generated code by 
editing the Format Triggers.
atting 2-7



The following figure illustrates the condition formatting features that you will 
apply to your report. Table 2–1, "Features demonstrated in this Conditional 
Formatting sample report", describes the steps you will take to create this report. 
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The cond.rdf file contains the report you will create after finishing the tasks in this 
chapter. You may want to refer to this file while you are working. This file is located 
in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory.

To get started, open Report Builder. If the Welcome dialog box appears, click Use 
the Report Wizard and click OK. If not, choose File->New->Report. Click Use the 
Report Wizard and click OK.

At some point before you generate the report, you will need to log into the 
database. Choose File->Connect to connect to the database. Enter the appropriate 
log on information. See Section 1.3, "Obtaining database access before you start" for 
details.

Table 2–1 Features demonstrated in this Conditional Formatting sample report

Feature Location

Use the Report Wizard to define the SQL and 
create a first draft of the report.

Section 2.1, "Creating the initial report with 
the Report Wizard"

Modify the report layout for readability 
using the Live Previewer.

Section 2.2, "Making simple formatting 
modifications to the report"

Add a format exception to a field using the 
Conditional Formatting dialog box so that 
the appearance of the field changes when a 
specified condition is met.

Section 2.3, "Adding a formatting exception 
to a field"

Modifying the code generated by the Format 
Exception dialog box in order to do 
additional processing when a specified 
condition is met. 

Section 2.4, "Adding more functionality to 
the generated format trigger code"

Add a formatting exception to a repeating 
frame in order to make a change that affects 
a number of report objects at once.

Section 2.5, "Adding a formatting exception 
to a repeating frame"

Modify code generated by the Format 
Exception dialog boxes to further customize 
the report.

Section 2.6, "Modifying the generated code"
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Creating the initial report with the Report Wizard
2.1 Creating the initial report with the Report Wizard
The Report Wizard is a great way to start building a report. The Report Wizard 
alone may give you a report that satisfies your requirements. If it doesn’t, you can 
use the Data Model view, the Live Previewer, and the Layout Model view to further 
refine your report. For this report, you will start with the Report Wizard, and then 
use the Live Previewer and Layout Model to modify the layout and add conditional 
formatting to the report. The steps in this section will help you to create the initial 
report.

1. If the Welcome page of the Report Wizard appears, click Next.

2. On the Style page, enter Stocks as the Title, and click Group Above as the 
report style.

Tip: If you are unsure about what to do on any page of the wizard, click Help.

3. Click Next.

4. If the Type page appears, click SQL statement, and click Next. The Type page 
will appear only if you have configured Report Builder to run with Oracle 
Express.

5. On the Data page, ignore the buttons on the page and type in the following 
SELECT statement:

SELECT symbol,
    company,
    current_price,
    trade_date,
    number_traded_today,
    todays_high,
    todays_low
FROM stocks

6. Click Next.

7. On the Groups page in the Available Fields list, click the item symbol.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
report wizard, about

3. Then click Display to view help topic... 
Report Wizard: Welcome page
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Creating the initial report with the Report Wizard
8. Click .

9. Repeat steps 7 and 8 for the company field.

10. For this report, you want one break level, but you currently have two – Level 1 
and Level 2. To make one break level, click company in the Group Fields list, 
and drag it into Level 1.

Tip: Groups are created to organize the columns in your report. When you 
create a query, Report Builder automatically creates a group that contains the 
columns selected by the query. You create additional groups to produce break 
levels in the report in order to create a group above or group left report.

11. Click Next.

12. On the Fields page, click . Doing this makes all fields display in the 
report.

13. Click Next.

14. On the Totals page, click current_price, and click Maximum.

15. Click Minimum. The minimum and maximum current_price fields display in 
the Totals list.

16. Click number_traded_today, and click Maximum.

17. Click Minimum. The minimum and maximum number_traded_today fields 
display in the Totals list.

18. Click Next.

19. On the Labels page, change the labels and widths as shown in the following 
table:

20. Click Next.

21. On the Template page, click Predefined template if it is not already selected, 
and click Corporate 2 in the list box.

Table 2–2 Labels and widths

Column Label Width

Todays High Today’s High 9

Todays Low Today’s Low 9
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Making simple formatting modifications to the report
22. Click Finish. The report output automatically displays in the Live Previewer 
and should look similar to the following figure:

23. Choose File->Save As. Save the report in the directory of your choice, and 
name the report cond_21.rdf.

Tip: It is good practice when you are designing your report to save it frequently 
under a different file name. If you generate an error or if you don’t like some of 
the changes you made, you easily can go back to the previously saved file and 
make revisions from that point.

2.2 Making simple formatting modifications to the report
At this point, you could return to the Report Wizard and update any of its settings 
(for example, labels or widths) and regenerate the report. However, in this section, 
you will make a few edits in the Live Previewer to improve the appearance of the 
report.

1. In the Live Previewer, click the column of data below the Current Price heading. 
Report Builder selects every instance of the field. This means that any change 
you make at this point will be applied to all instances of the field.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
format mask, applying to numeric object

3. Then click Display to view help topic... 
Applying a format mask to a numeric object
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2. Press and hold SHIFT. Then click the data under the Today’s High and Today’s 
Low headings. (You can select multiple columns by holding the SHIFT key 
while you click.)

3. Find the bold values at the end of each column. (You will need to scroll to the 
bottom of the first page). Shift-click on them. Find any other bold monetary 
values at the end of the report, and shift-click on them. Now all of the monetary 
values in the report are simultaneously selected, and you can easily format 
them all at once.

Tip: If you accidentally select something and want to deselect it, shift-click on it 
again to deselect.

4. Click  to add a dollar sign ($) to the selected values.

5. Click  twice to add two decimal places.

6. Click in an empty area of the Live Previewer to deselect everything.

7. Click the data under the Number Traded Today heading to select it.

8. Click  to add a comma to values that have more than three digits to the left 
of the decimal.

9. Click in an empty area of the Live Previewer to deselect everything. The report 
output should look similar to the following figure:

10. Save the report as cond_22.rdf.

Optional Exercise: 

Explore the Live Previewer to see what other changes you can make.
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2.3 Adding a formatting exception to a field
The Conditional Formatting dialog box is a great way to start applying formatting 
exceptions to your layout objects. (For example, you can make a field’s value bold 
when it exceeds a specified maximum value). The Conditional Formatting dialog 
box alone may satisfy your requirements for creating a formatting exception. 

Tip: When you use the Conditional Formatting dialog box, it generates a Format 
Trigger for the selected object. Consequently, once you directly edit a Format 
Trigger for an object, you should not go back and use the Conditional Formatting 
dialog box to make more modifications. If you do, you may lose some of the 
customized modifications that you made directly to the Format Trigger.

In this section, you will set conditional formatting for two summary fields, 
:Maxcurrent_pricePerSymbol and :Mincurrent_pricePerSymbol. Doing this 
will flag values if they are outside of the specified maximum and minimum points.

1. In the Live Previewer, click the data under the Current Price heading to select it.

Tip: When you select data in the Live Previewer, the corresponding object is 
highlighted in the Object Navigator, and vice versa.

2. Choose Tools->Property Palette.

3. Under the General Layout node, find the Conditional Formatting property, and 
double-click the button next to it.

4. In the Conditional Formatting dialog box, click New to create a new format 
exception for the Current Price field object. 

5. In the Format Exception dialog box, check the first check box if it is not already 
checked. Choose current_price from the first drop-down list of values if it is not 
already chosen.

6. Choose Equal from the second drop-down list of values that is next to current_
price.

7. Type :Maxcurrent_pricePerSymbol in the third field next to Equal.

8. Check the check box in the second row. Note that the last drop-down list in the 
first row is activated and can be edited.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
conditional formatting, applying to an object

3. Then click Display to view help topic... 
Applying conditional formatting to an object
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9. In the last drop-down list in the first row, choose OR.

10. Repeat steps 5 through 7 adding current_price, Equal, and :Mincurrent_
pricePerSymbol to the second row.

11. Click Font, and choose Bold in the Font dialog box. Click OK to close the Font 
dialog box.

12. Click  and choose red. The palette closes automatically.

13. Click  and choose black. The palette closes automatically.

14. Click OK to close the Format Exception dialog box.

15. Click Apply. You will see the effect of your format exception in the Live 
Previewer. You should now see some values in bold with a red fill color and a 
black border. Looking at these values allows you to see when the price of a 
particular stock was at its minimum and maximum value.

16. In the Conditional Formatting dialog box, click OK. Or, click Edit to further 
modify your format exception.

17. Close the Property Palette. The report output should look similar to the 
following figure:

18. Save the report as cond_23.rdf.
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Optional Exercises: 

■ Choose File->Generate to File->PDF. After you have created the PDF file, 
locate the file in Explorer and open it in the Acrobat Reader to see the report 
output.

■ To see the format exception code that Report Builder has generated for you, go 
to the Object Navigator and expand the Program Units node for the report. 
Double-click the icon next to the Format Trigger to open it in the PL/SQL 
Editor, and view the code.

■ If you want more practice, try implementing a format exception for the values 
under Number Traded Today that is similar to the one you just implemented for 
the current price. The report already contains all of the values you need to do 
this.

2.4 Adding more functionality to the generated format trigger code
In many cases, simply changing formatting attributes as done in Section 2.3, 
"Adding a formatting exception to a field" may suffice. However, you can also 
include more sophisticated processing.

The steps in this section will help you to design the report for PDF output and add 
bookmarks that indicate when stock prices reach a maximum point.

Because you have already generated some code with the Conditional Formatting 
dialog box, some of the logic you need is already in place.

1. In the Live Previewer, click the data under the Current Price heading. 

2. Choose Tools->Property Palette.

3. Under the Advanced Layout node, find the Format Trigger property, and 
double-click the button next to it.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
format trigger, creating

3. Then click Display to view help topic... 
Creating or editing a format trigger
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4. Modify the code so that it looks as follows. The new code that you need to add 
is in bold:

function F_current_priceFormatTrigger return boolean is
begin
  -- Automatically Generated from Report Builder.
  if ((:current_price = :Maxcurrent_pricePerSymbol) or
      (:current_price = :Mincurrent_pricePerSymbol)) 
  then
    srw.set_foreground_border_color(’black’);
    srw.set_border_pattern(’solid’);
    srw.set_foreground_fill_color(’red’);
    srw.set_fill_pattern(’solid’);
    srw.set_font_face(’Arial’);
    srw.set_font_size(10);
    srw.set_font_weight(srw.bold_weight);
    srw.set_font_style(srw.plain_style);
      if (:current_price = :Maxcurrent_pricePerSymbol)
      then
        srw.set_bookmark(:symbol || ’ at maximum ’);
      end if;
  end if;
  return (TRUE);
end;

5. Click Compile.

6. If any compilation errors occur, check the code for syntax errors, and recompile 
as needed.

7. Click Close.

8. Close the Property Palette.

Tip: The next four steps require that the Live Previewer be the active window.

9. Choose View->Web Preview->Use PDF.

10. Choose View->Web Preview->Show All Pages.

11. Choose View->Web Preview->Generate to Web Browser. The PDF output for 
your report is now displayed in your Web browser. Test the bookmarks.

Tip: You may be requested to locate the executable that launches your browser. 
Use the Browse button. Your browser must be configured to use the Acrobat 
Reader plug-in to view the PDF that Report Builder generated.
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If you do not have the Acrobat Reader plug-in configured for your browser, you 
can choose File->Generate to File->PDF, and open the PDF in the stand alone 
Acrobat Reader.

12. Go back into Report Builder and choose View->Web Preview->Generate to 
Web Browser. This turns off the Web Previewer.

Tip: When you’re making a lot of little changes to your report, it’s best to turn 
off the Web preview feature. Otherwise, the Web preview is constantly updating 
each small change that you make.

13. Repeat steps 1 through 8. But this time, update the Format Trigger to look as 
follows. The new code that you need to add is in bold:

function F_current_priceFormatTrigger return boolean is
begin

  -- Automatically Generated from Report Builder.

  if ((:current_price = :Maxcurrent_pricePerSymbol) or

      (:current_price = :Mincurrent_pricePerSymbol)) 

  then

    srw.set_foreground_border_color(’black’);

    srw.set_border_pattern(’solid’);

    srw.set_foreground_fill_color(’red’);

    srw.set_fill_pattern(’solid’);

    srw.set_font_face(’Arial’);

    srw.set_font_size(10);

    srw.set_font_weight(srw.bold_weight);

    srw.set_font_style(srw.plain_style);

      if (:current_price = :Maxcurrent_pricePerSymbol)

      then

        srw.set_bookmark(:symbol || ’ at maximum ’);

      elsif (:current_price = :Mincurrent_pricePerSymbol)

        then 

          srw.set_bookmark(:symbol || ’ at minimum ’);

      end if;

  end if;

  return (TRUE);
end;

14. Save the report as cond_24.rdf.
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15. Click  to view the results in the Live Previewer.

16. Repeat steps 9 through 12 to regenerate the PDF. 

2.5 Adding a formatting exception to a repeating frame
Creating a formatting exception for a single field can be useful, but you can also 
create a formatting exception that affects a number of objects at once. Report Builder 
typically groups objects inside of frames or repeating frames. If the objects inside of 
a frame are transparent, changing the fill color of a repeating frame will effectively 
change the fill color of the objects inside of it. 

In this section, you will change the fill color of an object in a repeating frame.

1. Go to the Data Model view. 

2. Click .

3. Click the title bar of the group named G_symbol.

4. Double-click the newly created column named CS_1 to display the Property 
Palette. You may have to scroll down. Update the properties as follows:

5. Press ENTER or RETURN, or click any other field in the Property Palette to 
accept the changes.

6. Close the Property Palette.

7. In the Object Navigator, place your cursor in the Find field and type
R_G_SYMBOL. Note that the search occurs as you type, so you will most likely be 
taken to the object before you finish typing the entire name.

8. Choose Tools->Property Palette.

9. In the Property Palette, under the General Layout node, locate the Conditional 
Formatting property, and double-click the button next to it.

10. Click New to create a new format exception for the field object.

11. Choose CS_COUNT from the first list of values.

12. Choose Equal from the list of values next to CS_COUNT.

Table 2–3

Name Function Source Reset at

CS_COUNT Count symbol Report
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13. Type 1 in the field next to Equal.

14. Click  and choose a darker grey.

15. Click OK.

16. Repeat steps 10 through 14 using CS_COUNT, Equal, 0, and a light blue for the 
Fill Color.

17. Click OK in the Format Exception dialog box.

18. Click Apply and OK in the Conditional Formatting dialog box.

19. Check your output in the Live Previewer. Because there are non-transparent 
objects on top of the repeating frame, you only see the dark grey color at the 
very top of the first instance of the repeating frame. The light blue color never 
appears, but you will change that in Section 2.6, "Modifying the generated code"
.

20. Save the report as cond_25.rdf.

2.6 Modifying the generated code
By making a simple modification to the code that was generated by the Conditional 
Formatting and Format Exception dialog boxes, you can make the fill color alternate 
for even and odd instances of the repeating frame.

1. In the Object Navigator, click the R_G_SYMBOL object.

2. Choose Tools->Property Palette.

3. In the Property Palette, under the Advanced Layout node, locate the Format 
Trigger property, and double-click the button next to it.
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4. Modify the code so that it looks as follows. The new code that you need to add 
is in bold. 

Tip: Note that the color specifications in the following code may differ slightly 
from the colors specified in your code:

function R_G_symbolFormatTrigger return boolean is
begin
  -- Automatically Generated from Report Builder.
  if (:CS_count mod 2 = ’1’)
  then
    srw.set_foreground_fill_color(’gray32’);
    srw.set_fill_pattern(’solid’);
  end if;

  -- Automatically Generated from Report Builder.
  if (:CS_count mod 2 = ’0’)
  then
    srw.set_foreground_fill_color(’r50g50b100’);
    srw.set_fill_pattern(’solid’);
  end if;

  return (TRUE);
end;

5. Click Compile.

6. If any compilation errors occur, check the code for syntax errors, and recompile 
as needed.

7. Click Close.

8. Click  to view the results in the Live Previewer. Note as you scroll through 
the report that the headings alternate between dark grey on the odd pages and 
light blue on the even pages.

9. Save the report as cond_26.rdf.

Optional Exercise: 

Make the opaque objects on top of R_G_SYMBOL transparent so that you can see its 
fill color through the other objects. 

Tip: Use the Object Navigator to choose the frames contained in the R_G_SYMBOL 
object.
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Summary
2.7 Summary
Congratulations! You have finished the Conditional Formatting sample report. You 
now know how to:

■ Use the Report Wizard to define a data model and layout.

■ Use the Live Previewer to modify a report layout.

■ Use the Conditional Formatting dialog box to add a format exception to a field.

■ Modify code generated by the Conditional Formatting dialog box. 

■ Add formatting exceptions to a repeating frame.

■ Modify code generated by the Format Exception dialog box.

For more information about conditional formatting, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
conditional formatting, about

3. Then click Display to view help topic... 
About conditional formatting
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Building and Applying Report Templates

The report described in this chapter is designed to help you learn more about the 
Report Builder features for building and applying templates.

About templates Templates define common characteristics and objects that you 
want to apply to multiple reports. For example, you can define a template that 
includes the company logo and sets fonts and colors for selected areas of a report.

In this report example, you will build a multi-query report that summarizes stock 
information by company symbol using the Tabular report style. You will create a 
new template and apply the template to the report. Then you will enhance the 
template by changing several default attributes in the template margin and body. 
You will enhance the template further by overriding some of the default attributes 
of the Group Above style. Finally, you will create an additional layout using the 
Group Above style, and re-apply the template to the report.

The following figure illustrates the concept of templates and the various features 
you will add to your template. A template defines the common look (the default 
attributes) of a report that can be applied globally across all report styles.

With the same template, you will change the look of a particular report style. In this 
example, you will override the default attributes of Group Above style.

When you create a report, you can use this template to apply a common look across 
many report styles (Tabular, Group Left, Matrix, and so on) or apply a unique look 
to a report with the Group Above report style.

Table 3–1, "Features demonstrated in this Templates sample report", describes the 
steps you will take to create a template and apply it to a report.
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The following supporting files are used to help you complete the exercises in this 
chapter. They are located in your ORACLE _HOME\TOOLS\DOC60\US\RBBR60 
directory:

■ temp_hdrftr.htm

■ oreplogo.gif

■ osuplogo.jpg

■ ostore.gif

■ oracle.gif 

■ cconft.bmp

■ cconfa.bmp

■ t_image1.bmp

■ t_image2.bmp

■ temp.tdf

■ temp.rdf

You also will work with the following templates (located in your ORACLE_
HOME\REPORT60\ADMIN\TEMPLATE\US directory):

■ corp2.tdf 

■ conf2.tdf

You will work with the global preferences file, cagprefs.ora (located in your 
ORACLE_HOME directory.) The temp.rdf file contains the report you will create after 
finishing the tasks in this chapter. You may want to refer to this file while you are 
working. This file is located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 
directory.
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To get started, open Report Builder. If the Welcome dialog box appears, click Build 
a new report manually and click OK. If not, choose File->New->Report. Click 
Build a new report manually and click OK. The Data Model appears.

At some point before you generate the report, you will need to log into the 
database. Choose File->Connect to connect to the database. Enter the appropriate 
log on information. See Section 1.3, "Obtaining database access before you start" for 
details.

Table 3–1 Features demonstrated in this Templates sample report

Feature Location

Create a multi-query data model and data 
links in the Data Model view.

Section 3.1, "Creating a data model"

Create a report using a pre-defined layout, 
and modify the layout in the Live Previewer.

Section 3.2, "Creating a report"

Create a new template, which will modify 
the appearance of your report, using the 
Layout Model view for templates.

Section 3.3, "Creating a template"

Add your new template to the pre-defined 
templates list in the Report Wizard so that 
you can apply it to your report.

Section 3.4, "Adding the new template to the 
predefined templates list"

Apply your new template to the report, and 
view the changes in the Live Previewer.

Section 3.5, "Applying the customized 
template to the report"

Change default attributes of the template 
that are applied globally to the body of the 
report.

Section 3.6, "Enhancing the default attributes 
of the template"

Override default attributes in the Group 
Above style of the template.

Section 3.7, "Overriding the default attributes 
of the template"

Create an additional default layout to 
illustrate the override attribute changes 
made to the template.

Section 3.8, "Creating an additional layout"

Make final format changes to the report. Section 3.9, "Enhancing the look of the 
report"
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Creating a data model
3.1 Creating a data model
The steps in this section will help you create a multi-query data model. First, you 
will create two queries. Then you will create a break group for the first query. 
Finally, you will link the two queries.

3.1.1 Building two queries using the SQL Query tool

1. In the Data Model view, click .

2. Click in the Data Model view.

3. In the SQL Query Statement dialog box, enter the following query:

SELECT  ic.category,

SUM (h.sales),

AVG (h.high_365),

AVG (h.low_365),

AVG (h.div),

AVG (h.p_e)

FROM stock_history h,indcat ic

WHERE h.symbol=ic.symbol
GROUP BY ic.category

4. Click OK. The query by default is labelled Q_1. You will change the query name 
in a later step.

5. Repeat steps 1 and 2 and enter the following code to create the second query:

SELECT h.symbol,
h.sales,

h.high_365,
h.low_365,
h.div,
h.p_e,
ic.category

FROM stock_history h, indcat ic
WHERE ic.symbol=h.symbol
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6. Click OK. The query by default is labelled Q_2. You will change the query name 
in a later step.

7. Choose File->Save As. Save the report in the directory of your choice, and 
name the report temp_311.rdf.

Tip: It is good practice when you are designing your report to save it frequently 
under a different file name. If you generate an error or if you don’t like some of 
the changes you made, you easily can go back to the previously saved file and 
make revisions from that point.

3.1.2 Renaming Data Model objects
In the Data Model view, make the following changes:

1. Click Q_1 and choose Tools->Property Palette.

2. Under the General Information node, set the Name property to Q_ind.

3. Repeat steps 1 and 2 for the following:

4. Save the report as temp_312.rdf.

3.1.3 Creating a break group
In this section, you will create a break group using the category column in the query 
Q_ind:

1. In the Data Model view, drag the title bar of the group G_ind_summary down a 
few inches to make space for a new group.

Table 3–2 Column name changes

Old Name New Name

G_category G_ind_summary

Q_2 Q_detail

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
break group, creating

3. Then click Display to view help topic... 
creating a break group
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2. Click and drag the category column above the G_ind_summary group to create 
a break group called G_category. The result will look similar to the 
following figure:
 

3. Save the report as temp_313.rdf.

3.1.4 Creating a data link
In this section you will create a data link between G_category and Q_detail.

1. In the Data Model view, click .

2. Click the G_category group and drag a link to the G_symbol group. Your data 
model will look similar to the following figure:

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
data link, creating

3. Then click Display to view help topic... 
creating a data link
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3. Save the report as temp_314.rdf.

3.2 Creating a report
The steps in this section will help you create a default layout using the Report 
Wizard. You will create the default layout using the Tabular style. Finally, you will 
format several objects in the report using the Live Previewer view.

3.2.1 Creating the default layout
1. In the Object Navigator, click  for your report and choose Tools->Report 

Wizard. The Report Wizard appears.

2. On the Style page, click Tabular as the report style.

3. Click Next.

4. On the Groups page, click G_symbol from the Available fields list, then click 
Down. G_symbol moves to the Displayed Groups list.

5. Click Next.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
default layout, about

3. Then click Display to view help topic... 
About layout defaulting
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6. On the Fields page, click symbol, then click  to move the field into the 
Displayed Fields list.

7. Repeat step 6 for the following fields:

■ sales

■ high_365

■ low_365

■ div

■ p_e

■ category1

8. Click Next.

9. On the Labels page, change the labels and widths as shown in the following 
table:

10. Click Next.

11. On the Template page, click Corporate 2 from the Predefined templates list.

Table 3–3 Labels and widths

Column Label Width

symbol Symbol 5

sales Sales 6

high_365 High Stock 6

low_365 Low Stock 6

div Dividend 6

p_e P/E 6

category1 Industry 6
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12. Click Finish. The Live Previewer appears. The report will look similar to the 
following figure: 

13. Save the report as temp_321.rdf.

3.2.2 Formatting objects using the Live Previewer
You will format several objects in the report by changing the format mask to display 
numeric values as currency. Finally, you will right justify several objects.

1. With the report displayed in Live Previewer, click the column of data under the 
Sales heading to select it.

2. Click  to add a dollar sign.

3. Click  twice to add two decimal places.

4. Click  to right justify the object.

5. Repeat steps 1 through 4 for the following:
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Tip: You can change several columns at one time: shift-click on all columns and 
choose Tools->Property Palette.

■ Column under High Stock

■ Column under Low Stock

■ Column under Dividend

■ Column under P/E

6. Shift-click the following objects, then click :

■ Sales

■ High Stock

■ Low Stock

■ Dividend

■ P/E

The result will look similar to the following figure:

7. Save the report as temp_322.rdf , and close the Live Previewer.
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3.3 Creating a template
The steps in this section will help you create a new template using the Template 
Editor Layout Model while in Edit Margin mode.   First, you will open two 
templates, copy the Confidential watermark from one template and paste it into the 
other. Next, you will change the color of the Date label and add an HTML page 
footer to the template. Finally you will create a format trigger that will conditionally 
display graphics based on the page number of a report.

3.3.1 Creating a new template
8. Open the template corp2.tdf (located in your ORACLE_

HOME\REPORT60\ADMIN\TEMPLATE\US directory). This is the Corporate 2 
template that is currently applied to your report.

9. In the Object Navigator under the Templates node, click  to select the 
CORP2 template. Then choose Tools->Template Editor to display the Layout 
Model view of the template.

10. Open the second template, conf2.tdf. This template contains a Confidential 
watermark.

11. In the Object Navigator under the CONF2 node, double-click the Layout Model 
node to display the Layout Model view of the template. Notice the rectangular 
box that spans diagonally across the template. This is the watermark.

Tip: If you do not see the watermark, the Layout Model view might be 
displaying the Body.

Click  to switch between the Margin and Body. Alternatively, choose 
View->Layout Section. A check mark next to Edit Margin indicates the Layout 
Model view is in Margin mode.

12. Click the watermark, then click  to copy the watermark.

Tip: Every object in the Layout Model view is also represented in the Object 
Navigator. The watermark in the Layout Model view is represented as B_1 in 
the Object Navigator. To ensure that you have selected the watermark, arrange 
your workspace to display the Object Navigator and the Layout Model view 
side-by-side. Expand the CONF2, Layout Model, Section, and Margin nodes in 
the Object Navigator. When you click the watermark object in the Layout Model 
view, B_1 under the Margin node in the Object Navigator is highlighted. Your 
workspace should look similar to the following figure:
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13. In the Object Navigator, click the CONF2 node, then choose File->Close 
without saving any changes.

14. Click the CORP2 node.

15. In the Layout Model view, click the title bar to make it active.

16. Click  to paste the watermark into the template.

17. Save CORP2 as cconf.tdf in your ORACLE_
HOME\REPORT60\ADMIN\TEMPLATE\US directory.

18. In the Layout Model view, click the Date label (the B_DATE1 object in the 
Object Navigator).

19. Click , then click a color.

20. Save the template again as cconf.tdf.

21. (Optional) Save the template under another name, such as cconf_b1.tdf, as a 
backup file.

Tip: Backup files are useful when you are making significant changes to your 
template. If you don’t like some of your changes, you always can go back to a 
previously saved template and make changes from that point.

22. If you saved the template as a backup, re-open the cconf.tdf template.
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3.3.2 Adding an HTML header to the template
You will add an HTML footer to the template using the After Page Type and After 
Page Value properties.

For your convenience, this HTML footer file and its associated graphics have been 
provided for this exercise. These files are located in your ORACLE_
HOME\TOOLS\DOC60\US\RBBR60 directory. They are:

■ temp_hdrftr.htm

■ oreplogo.gif

■ osuplogo.jpg

■ ostore.gif

■ oracle.gif 

1. In the Object Navigator under the Templates node, double-click  of the 
CCONF template to display the Property Palette. Under the Report Escapes 
node, set the following: 

2. Save the template as cconf.tdf.

3. (Optional) Save the template under another name as a backup file, then re-open 
cconf.tdf.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
HTML output, about

3. Then click Display to view help topic... 
About Web links for HTML output

Table 3–4 Property changes to objects under the Templates node

Property Setting

After Page Type File

After Page Value c:\ORACLE_HOME\TOOLS\DOC60\US\RBBR60 temp_
hdrftr.htm (where “c” is the location of your ORACLE_
HOME)
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3.3.3 Creating a format trigger
In this exercise, you will insert two boilerplate images in the margin of the template. 
Then, you will create a format trigger that will conditionally hide or show each of 
these images based on the page number.

Two images are provided for this exercise and are located in your ORACLE_
HOME\TOOLS\DOC60\US\RBBR60 directory. They are:

■ t_image1.bmp

■ t_image2.bmp

1. With the Layout Model view open, click  to insert a linked file.

2. Using the ruler as a guide, click and drag the Link File object at the 7 inch 
marker, making the object about 1 inch square.

3. If necessary, click:

■  to set the object to no fill

■  to set the object to no line

4. Double-click the Link File object to display the Property Palette.

5. Under the General information node, set the Name property to B_Image1.

6. Under the Link File Boilerplate node, set the following: 

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
format trigger, description

3. Then click Display to view help topic... 
Format trigger

Table 3–5 Property changes to t_image1 object under the Link File Boilerplate node

Property Setting

Source File Format Image

Source Filename c:\ORACLE_HOME\TOOLS\DOC60\US\RBBR60\t_
image1.bmp (where “c” is the location of your ORACLE_
HOME)
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7. Under the Advanced Layout node, double-click Format Trigger property to 
display the PL/SQL Editor.

8. Type the following code in the editor. New code is displayed in bold:

function B_Image1FormatTrigger return boolean is
F_pge number;

begin
srw.get_page_num (F_pge);
If F_pge=1 then

return (TRUE);
Else

return (FALSE);
End if;

end;

9. Click Compile.

10. If any compilation errors occur, check to code for syntax errors and recompile as 
needed.

11. Click Close.

12. Repeat steps 1 through 11 to insert the second image and set the following 
properties:

Under the General Information node, set the Name property to B_Image2.

Under the Link File node: 

Table 3–6 Property changes to t_image2 object under the Link File node

Property Setting

Source File Format Image

Source Filename c:\ORACLE_HOME\TOOLS\DOC60\US\RBBR60\t_
image2.bmp (where “c” is the location of your ORACLE_
HOME)
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Under the Advanced Layout node, type the following code in the editor. New 
code is displayed in bold:

function B_Image2FormatTrigger return boolean is
F_pge number;

begin
srw.get_page_num (F_pge);
If F_pge=2 then

return (TRUE);
Else

return (FALSE);
End if;

end;

Tip: Place the second image directly over the first image.

13. Save the template as cconf.tdf.

14. (Optional) Save the template under another name as a backup file, then re-open 
cconf.tdf.

3.4 Adding the new template to the predefined templates list
The steps in this section will help you add the new template to the predefined 
template list in the Report Wizard. First you will look at the Style and Template 
pages of the Report Wizard to gain a better understanding of how templates are 
applied to different report styles, such as Tabular and Group Above.

You will add template definitions to a global preference file, which defines the 
preferences for Report Builder.

Finally, you will apply the new template to your report.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
template, adding to predefined list

3. Then click Display to view help topic... 
Adding a template to a predefined templates list
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3.4.1 Viewing report styles and the Predefined template list in the Report Wizard
The following steps are an exercise to illustrate how templates are used in the 
Report Wizard. You will not make changes to your report in this section.

1. In the Object Navigator, click  next to your report (last saved as temp_
322.rdf), and choose Tools->Report Wizard. 

2. On the Style page, click Form-like.

3. On the Template page. Notice the three options:

■ Predefined template list, a convenient way to select a template from a list 
and apply it to your report.

■ Template file, a way to apply a template to a report by specifying the 
template location and file name.

■ No template, an option not to apply a template to a report.

4. Choose Predefined template list, then click Corporate 1. Notice the sample 
graphic of the template style.

5. Go back to the Style page, and choose another report style.

6. Go back to the Template page. Notice that the sample graphic of the report style 
has changed.

This is because, by default, a single template contains layout attributes for 
several report styles. You will learn more about the layout attributes of 
templates in a later step.

7. Cancel the Report Wizard without making any changes to the report.

8. Choose File->Close to close the report without saving any changes.
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3.4.2 Adding the template to the Predefined template list
In the previous exercise, you learned that one template contains layout attributes for 
several report styles. To make the template available for a particular report style, 
you must add a template description and file name to Report Builder’s global 
preference file. In the global preference file, you will define the template for the 
Tabular style and Group Above style so that they will be available in the Predefined 
template list in the Report Wizard.

1. In a text editor (e.g., Wordpad), open the global preferences file cagprefs.ora 
(located in your ORACLE_HOME directory).

Tip: Most global preference changes can be made from Report Builder by 
selecting Tools->Preferences. For templates, however, you must add template 
definitions to the Predefined list using a text editor.

2. Scroll down or search for Reports.Tabular_Template_Desc.

3. Add a new line and type “Custom Confidential”,  for the template name that 
will appear in the Predefined template list. See the bold text in the example that 
follows:

Reports.Tabular_Template_Desc = 
 ("Corporate 1",
  "Corporate 2",
  "Confidential Heading",
  "Confidential Background",
  "Custom Confidential",
  "Cyan Grid",

4. Scroll down to Reports.Tabular_Template_File .

5. Add a new line and type cconf,  to identify the file name of the template. See 
the bold text in the example that follows.

Tip: Be sure to place the file name in the same position as the description. For 
example, if you insert the template description in the fifth line under 
Reports.Tabular_Template_Desc , you must insert the template file name in 
the fifth line under Reports.Tabular_Template_File .

 Reports.Tabular_Template_File = 
 (corp1,
  corp2,
  conf1,
  conf2,
  cconf,
  gngd1,
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6. Scroll down to Reports.BreakAbove_Template_Desc.

7. Add a new line and type “Custom Confidential”, for the template name that 
will appear in the Predefined template list:

Reports.BreakAbove_Template_Desc = 
 ("Corporate 1",
  "Corporate 2",
  "Confidential Heading",
  "Confidential Background",
  "Custom Confidential",
  "Cyan Grid",

 

8. Scroll down to Reports.BreakAbove_Template_File .

9. Add a new line and type cconf,  to identify the file name of the template:

Reports.BreakAbove_File = 
 (corp1,
  corp2,
  conf1,
  conf2,
  cconf,
  gngd1,

10. Save the changes to the preferences file and close the text editor.

3.4.3 Displaying sample template images in the Template page of the Report Wizard
In addition to adding new templates to the predefined templates list, you can 
display a sample image when you select the template for a particular report style in 
the Templates page of the Report Wizard.

For your convenience, two bitmaps are provided for this exercise. These bitmaps 
must be located in the same directory as the template files.

1. Locate the following bitmaps (in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 
directory):

■ cconft.bmp  for the Tabular style sample image

■ cconfa.bmp  for the Group-above report style sample image

2. Copy them to your ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US directory.
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These bitmaps will display in the Templates page of the Report Wizard when 
you select the Custom Confidential template for the Tabular and Group Above 
styles. You will have an opportunity to view these bitmaps in a later step.

3.5 Applying the customized template to the report
The steps in this section will help you apply the new template to the report using 
the Report Wizard.

1. Close and restart Report Builder for the preferences to take effect. Connect to 
the database.

2. Choose File->Open to open your report (last saved as temp_322.rdf). 

3. In the Object Navigator, click  next to your report and choose 
Tools->Report Wizard.

4. On the Style page, click Group Above.

5. On the Template page, notice that the template, Custom Confidential, appears 
in the predefined template list.

6. Click Custom Confidential. Notice the sample graphic. It should look like the 
following figure:

Tip: If the template does not appear in the predefined list, ensure that the 
template is in the correct directory (located in your ORACLE_
HOME\REPORT60\ADMIN\TEMPLATE\US directory), and that the template 
description and file are correctly placed in the preferences file. If the sample 
graphics do not appear, ensure that cconfa.bmp and cconft.bmp are also 
located in the ORACLE_HOME\REPORT60\ADMIN\TEMPLATE\US directory.

7. On the Style page, click Tabular.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
template, applying to report

3. Then click Display to view help topic... 
About applying templates
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8. On the Template page, notice the sample graphic. It should look like the 
following figure:

9. Click Finish.

10. The report appears in the Live Previewer. Notice the following:

■ The report imported the template attributes to the report (i.e., the Report 
run on label changed colors).

■ The currency formatting and justification you made to the report were 
retained. Report Builder attempts to retain any manual modifications you 
make to the report when you apply a different template.

■ The confidential heading is hidden. This occurred because the frame fill 
pattern is set to solid. In a later step, you set the fill pattern in the default 
section of the template to transparent.

■ An image (i.e., the Oracle logo in black) is displayed in the upper 
right-hand corner of the report.   Right now you can’t check to see if the 
image changes based on the page number since this report generates only 
one page. In a later step, you will create an additional report layout that will 
generate a second page. At that time, you will see that the images change 
based on the page number.

11. Click  to view the report in a Web browser and test the HTML header.

Notice that the graphics are missing from the header. This occurred because 
Report Builder generates a temporary HTML file to your ORACLE_
HOME\REPORT60\TMP directory. If you would like to preview this report with the 
header graphics, copy the following graphic files (located in your ORACLE_
HOME\TOOLS\DOC60\US\RBBR60 directory) to your ORACLE_HOME\REPORT60\TMP 
directory:

■ oreplogo.gif

■ osuplogo.jpg

■ ostore.gif

■ oracle.gif
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12. Close the browser. Click  again to disable the Web preview.

Tip: When you are making a lot of little changes to your report, it is sometimes 
better to turn off the Web preview. Otherwise, the browser is constantly 
updating for each change that you make.

13. Save the report as temp_350.rdf and close the Live Previewer.

3.6 Enhancing the default attributes of the template
The steps in this section will help you enhance the Custom Confidential (CCONF) 
template even further. You will change some of the default attributes of the 
template, such as making objects transparent and changing the font style and color. 
These changes will be applied globally across all report styles in the template.

The changes you have made to the template so far have affected objects in the 
margin. The changes you will make to the default attributes will be applied to the 
objects in the body of the report such as frames, field labels, and fields.

3.6.1 Setting default attributes
1. Choose File->Open to open your template (saved as ). 

2. In the Object Navigator under the Templates and CCONF nodes, double-click 
the Layout Model node to display the CCONF template in the Layout Model 
view. Ensure that the layout is displaying the Body. Click  to switch 
between the Margin and the Body.

3. In the Object Navigator, expand the Layout Model, Section, Body, Default, and 
Frames nodes.

Tip: When you select an object in the Object Navigator, it is selected in the 
Layout Model, and vice versa. Select the object you want to change in the Object 
Navigator and see the changes in the Layout Model view. You can work easily 
between these views by arranging your workspace to display the Object 
Navigator and the Layout Model view side-by-side. This technique is especially 
useful if you are new to editing in the Layout Model view.

4. Under the Frames node, double-click the Section Frame node. In the Property 
Palette under the Style node, change the Fill Pattern property to transparent.

Tip: Click  to display list of values. Click the value, then click OK to 
accept it.

5. Use the tables that follow to set the properties of the following objects:
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Tip: You can make these changes using the Property Palette. You can also 
change some properties (i.e., font and color) directly from the Layout Model 
view using the toolbar or tool palette.

Under the Frames node, set the following:

Under the Field/Labels Headings node, set the following:

Under the Fields node, set the following:

6. Save the template as cconf.tdf.

Table 3–7 Property changes to objects under the Frames node

Object Property Palette node Property name  Set to:

Headings 
Frame

Style Foreground Color another color from the tool 
palette, or specify darkblue 
in the Property Palette

Fields 
Frame

Style Edge Foreground 
Color

another color from the tool 
palette, or specify r0g88b75 
in the Property Palette

Table 3–8 Property changes to objects under the Field/Labels Headings node

Object Property Palette node Property name  Set to:

Character Labels Font Bold Italic

Text Color another color from the tool 
palette, or specify r0g88b75 
in the Property Palette

Number Labels Font Bold Italic

Text Color another color from the tool 
palette, or specify r0g88b75 
in the Property Palette

Number 
Justification

End

Table 3–9 Property changes to objects under the Field/Labels Headings node

Object Property Palette node Property name  Set to:

Number Fields Number 
Justification

End
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3.6.2 Inheriting and localizing property values
The steps in this section are designed to help you understand a template’s 
Inheritance feature. Inheritance determines the source from which property values 
are set. Default attribute properties inherit values preset by Report Builder until you 
change them. When you change properties, their values become localized (or 
contained within that template).   

You can return a property back to its inherited value when you click  (the 
Inheritance button) in the Property Palette. When a property value is inherited by 
its preset value, the icon next to the property in the Property Palette is a circle. 

Default template property with an inherited value:

A property value becomes localized when you click  (the Localize button) or 
change the value in the Property Palette. When a property value is localized, the 
icon next to the property in the Property Palette becomes a square. 

Default template property with a localized value:

1. With the Layout Model view open, in the Object Navigator, find the Fields 
Frame object under the Frame node, double-click it to open the Property 
Palette.

Under the Style node, notice that icon next to the Borders property is a circle, 
indicating that All is an inherited value.

2. Set the Borders property to Top Only. Notice that the icon changes to a square, 
indicating that the value is localized.

3. With the Borders property selected, click . Notice that the value returns to 
its inherited value. 

4. Set the Borders property to Bottom Only. 

5. Save the template as cconf.tdf, and close the Layout Model view of the 
template.
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3.6.3 Applying changes to the template and viewing the results in Live Previewer
1. In the Object Navigator, click  next to your report and choose Tools->Report 

Wizard.

2. On the Template page of the Report Wizard, click Custom Confidential, then 
click Apply. 

3. In the Live Previewer, notice that none of your changes took effect (i.e., the 
watermark is still hidden). Report Builder retains the layout attributes in the 
report because you applied the same template to the report. Report Builder 
assumes, in this case, that the changes in the report take precedence over the 
changes in the template.

Tip: When you are designing your template and want to continuously preview 
changes in a sample report, you can:

■ Delete all objects in the Live Previewer and apply the template by selecting 
the template in the Predefined template list on the Template page of the 
Report Wizard, or

■ Alternate between selecting the template from the Predefined template list 
and specifying the template file name on the Template page of the Report 
Wizard.

4. On the template page of the Report Wizard, click Template file, then Browse. 
Locate the template file cconf.tdf (located in your ORACLE_
HOME\REPORT60\ADMIN\TEMPLATE\US directory).

5. Click Finish. The report will look similar to the following figure.
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.

6. Save the report as temp_360.rdf and close the Live Previewer
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3.7 Overriding the default attributes of the template
The steps in this section will help you override the default attributes in the 
template. You will override some of the settings for the Group Above style.

Tip: With the Property Palette open, click  to return the selected property back 
to its inherited value, or click  to localize the value.

Override attribute properties inherit their values from the template’s default 
attributes. When a property inherits a value from the default attribute, the icon next 
to the property in the Property Palette is an arrow.

Override attribute property with an inherited value:

When a property is localized, the icon next to the property in the Property Palette 
becomes an arrow with a red cross through it.

Override attribute property with a localized value:

 See Section 3.6.2, "Inheriting and localizing property values" for more information 
on inheritance for the template’s default attributes.

1. Display the Layout Model view of the CCONF template. The template layout 
looks similar to the following figure. If it doesn’t, the layout most likely is in 
Margin mode.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
template, Override

3. Then click Display to view help topic... 
About template attributes
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If necessary, click  to switch to the Body of the template. Notice in the toolbar 
that the report style is Default. This layout defines the default attributes for the 
template.

2. Click Group Above from the Report Style drop-down list. The layout will look 
similar to the following figure:

3. In the Object Navigator, if they are not already expanded, expand the Layout 
Model, Section, Body, Override, and Group Above nodes.

Notice that two sections (Level 1 and Level 2) are available. With these section 
nodes, you can override the default settings at the group level.

Tip: If necessary, you can add more levels using the  tool. For this 
exercise, however, you will maintain these two section levels.

4. Expand the Section (Level 1) node and the Section (Level 2) node. Under these 
nodes, you will change the attributes (i.e., headings, labels, and fields) for the 
specified group.

5. Double-click the Section (Level 1) node.
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6. In the Property Palette under the Spacing node, set the following properties:

Tip: Reviewing the changes in the Layout Model view might be more difficult 
when you are working with multiple sections. Some of the objects in the Layout 
Model view may be hidden behind other objects. The best way to review the 
changes made to the template is to apply it to your report and preview the 
report in the Live Previewer. For this exercise, however, you will make all the 
necessary changes first, then review the changes in a later step.

7. Use the table that follows to change the properties of the following objects 
under the Section (Level 1) node.

Tip: You can make these changes using the Property Palette. You can also 
change some properties directly from the Layout Model view, such as the font 
and color of an object using the toolbar or tool palette.

In the Frames node, set the following:

8. Double-click the Section (Level 2) node.

9. In the Property Palette under the Spacing node, set the following properties:

Table 3–10 Property changes to objects under the Spacing node

Property Setting

Inter-Frame (Horizontal) 0.4

Inter-Frame (Vertical) 0.4

Table 3–11 Property changes to objects under the Section (Level 1) Frames node 

Object Property Palette node Property name  set to:

Headings 
Frame

Style Fill Pattern transparent

Fields 
Frame

Style Edge Pattern transparent

Property Setting

Between Sibling Frames 
(Horizontal)

0.1

Between Sibiling Frames 
(Vertical)

0.1
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10. Use the tables that follow to set the properties of objects under the Section 
(Level 2) node. In the Frames node, set the following:

In the Field Labels/Headings node, set the following:

Table 3–12 Property changes to objects under the Section (Level 2) Frames node 

Object Property Palette node Property name  set to:

Headings 
Frame

Style Foreground Color another color from the tool 
palette, or specify 
r50g25b50 in the Property 
Palette

Fields Frame Style Foreground Color another color from the tool 
palette, or specify 
r88g100b75 in the Property 
Palette

Edge Pattern transparent

Table 3–13 Property changes to objects under the Section (Level 2) Field 
Labels/Headings node 

Object Property Palette node Property name  set to:

Character Labels Font style Bold Italic

Font size 8

Text color another color from the tool 
palette, or specify 
r88g100b75 in the Property 
Palette

Number Label Font style Bold Italic

Font size 8

Text Color another color from the tool 
palette, or specify 
r88g100b75 in the Property 
Palette
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In the Fields node, set the following:

11. Save the template as cconf.tdf, and close the Layout Model view for the 
template. You will apply these changes to the report in a later step.

12. (Optional) Save the template as a backup, then re-open cconf.tdf.

3.8 Creating an additional layout
The steps in this section will help you create an additional layout using the Layout 
Model view. You will add the Group Above style to the main section of the report. 
Finally, you will apply the changes made to the template to your report and 
preview the results in the Live Previewer.

1. Display the Layout Model view of your report (last saved as temp_360.rdf).

2. Ensure that you are in the main section of the report.

3. Click  to create an additional layout area.

4. Using the ruler as a guide, click and drag a rectangle at about the 2 inch marker 
to define the area of the layout. The Report Wizard appears.

Tip: Click and drag the width of the logical page to ensure you have enough 
room to insert all the selected fields. The logical page is delimited by a solid 
black line in the Layout Model view. If you make the layout bigger than the 
logical page, you will get an error when you run the report.

5. On the Style page, click Group Above, and type the name of the report Stock 
Summary by Industry in the Title field.

Table 3–14 Property changes to objects under the Section (Level 2) Fields node 

Object Property Palette node Property name  set to:

Character Fields Font Size 8

Text color another color from the tool 
palette, or specify r0g75b0 
in the Property Palette

Number Fields Font Size 8

Text Color another color from the tool 
palette, or specify r0g75b0 
in the Property Palette
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6. Click Next.

7. On the Groups page, select the following groups and directions:

■ click G_category, then click Down

■ click G_ind_summary, then click Across

■ click G_symbol, then click Down

8. Click Next.

9. On the Fields page, click  to move all fields to the Displayed Fields list.

10. Click category1 in the Displayed Fields list, then click . You should 
now have the following fields in the Displayed fields list:

■ category

■ SUM_h_sales

■ AVG_h_high_365

■ AVG_h_low_365

■ AVG_h_div

■ AVG_h_p_e

■ symbol

■ sales

■ high_365

■ low_365

■ div

■ p_e

11. Click Next.
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12. On the Labels page, change the following columns as shown in the table:

13. Click Next.

14. On the Template page, click Predefined template, then click Custom 
Confidential.

15. Click Finish.

Tip: If the default layout region that you defined is too small, a message will 
appear asking if you want to extend the layout to the page boundaries. 
Click Yes.

16. In the Object Navigator, type M_G_CATEGORY_GRPFR in the Find field to locate 
this object. Note that the search occurs as you type, so you will most likely be 
taken to the object before you finish typing the entire name.

17. Choose Tools->Property Palette. 

18. Under the General Layout node, set the Page Break Before property to Yes.

19. Click  to view the report in Live Previewer.

20. Click  to view the additional layout. The report will look similar to the 
following figure. Notice that logo in the upper right-hand corner of the report 
has changed to red.

Table 3–15 Labels and widths

Column Label Width

category Category: 10

SUM_h_sales Total Sales 6

AVG_h_high_365 Avg High Stock 6

AVG_h_low_365 Avg Low Stock 6

AVG_h_div Avg Dividend 6

AVG_h_p_e Avg P/E 6
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21. Save the report as temp_380.rdf.

3.9 Enhancing the look of the report
The steps in this section are optional. They will help you enhance the look of the 
Group Above report. You will format the numeric values as currency.

Tip: If you re-enter the Report Wizard after making manual refinements in the Live 
Previewer, you will lose some of your changes when you click Apply or Finish in 
the wizard, and your layout will default back to the state defined by the wizard.

1. With the report displayed in Live Previewer, click the column next to the Total 
Sales heading.

2. Click .

3. Click  once.
                                                  Building and Applying Report Templates 3-57



Enhancing the look of the report
4. Repeat steps 1 through 3 for the following:

■ Column next to Avg High Stock

■ Column next to Avg Low Stock

■ Column next to Avg Dividend

■ Column next to Avg P/E

■ Column under Sales

■ Column under High Stock

■ Column under Low Stock

■ Column under Dividend

■ Column under P/E

The report will look similar to the following figure:

5. Save the report as temp_390.rdf.
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3.10 Summary
Congratulations! You have finished the Templates sample report. You now know 
how to:

■ Create a multi-query data model with data links.

■ Use a pre-defined template to create a report, and modify the report in the Live 
Previewer.

■ Create a new template using the Layout Model view.

■ Add templates to the Report Wizard.

■ Apply templates to a report.

■ Change the global default attributes of a template.

■ Override default attributes of a template.

For more information about templates, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
template, about

3. Then click Display to view help topic... 
About templates
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4

Building a Report for the Web

The report described in this chapter is designed to help you learn more about 
Report Builder features for the Web.

To build this report, you will use the Report Wizard to create a data model. Then, 
you will use the Web Wizard to create an HTML report. You will make fairly 
extensive manual refinements in the Layout Model view and the Live Previewer. In 
particular, you will use the Web Settings properties. You will use the Chart Wizard 
to create a chart, and then return to the Web Wizard to add chart hyperlinks.

To view your Web report, you will need a Web browser, such as Netscape 3.x or 
higher, or Internet Explorer 3.x or higher, that supports HTML style sheets and 
Javascript.

In this example, you will create:

■ a detailed Web report containing additional HTML pages, Web links, and 
Javascript that shows the sales and profit results from a video sales company.

■ a one-page executive summary containing a chart with chart hyperlinks.

The following figure illustrates the various Web features that you will add to your 
Web report. Table 4–1, "Features demonstrated in this Web sample report", describes 
the steps you will take to enhance your report with these Web features.
Web 4-61
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To build this report, you will need the following files, which are located in your 
ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory:

■ rbweb_hdr.htm

■ rbweb_ps.htm

■ 1.gif

■ 3.gif

■ chalk.jpg

■ imdb.bmp

■ drama.gif

■ 14 .GIFs containing page, first, back, or next as part of file name (e.g., 
page-e.gif).

The web.rdf file contains the report you will create after finishing the tasks in this 
chapter. You may want to refer to this file while you are working. This file is located 
in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory.

Table 4–1 Features demonstrated in this Web sample report

Feature Location

Use the Report Wizard to create a single 
query and a default layout.

Section 4.1, "Creating a data model"

Modify the look of your report by adding 
format masks to the numeric values and 
changing the number of rows to fetch.

Section 4.2, "Modifying the look of your 
report output"

Add other HTML files to implement special 
effects and display static objects on every 
page.

Section 4.3, "Including an HTML report 
header"

Add bookmarks to report values to facilitate 
navigation within your report.

Section 4.4, "Adding bookmarks to parts of 
your report"

Eliminate the gray page separator line that 
automatically appears between pages.

Section 4.5, "Changing the page separator"

Add targets to your report. Then, add 
hyperlinks to destinations within your report 
and to external Web sites.

Section 4.6, "Adding hyperlink destinations 
and hyperlinks"

Display pop-ups and rollovers as the user’s 
cursor rolls over an image or hyperlink in 
your report.

Section 4.7, "Displaying pop-ups and 
rollovers in HTML output"

Conditionally hide and show items for Web 
output.

Section 4.8, "Using PL/SQL to conditionally 
hide/show objects for Web output"
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To get started, open Report Builder. If the Welcome dialog box appears, click Use 
the Report Wizard and click OK. If not, choose File->New->Report. Click Use the 
Report Wizard and click OK.

At some point before you generate the report, you will need to log into the 
database. Choose File->Connect to connect to the database. Enter the appropriate 
log on information. See Section 1.3, "Obtaining database access before you start" for 
details.

4.1 Creating a data model
The steps in this section will help you use the Report Wizard to create a data model 
with a single query and a report with a default layout.

1. If the Welcome page of the Report Wizard appears, click Next.

2. On the Style page, click Matrix with Group.

3. Click Next.

4. If the Type page appears, click SQL statement, and click Next. The Type page 
will appear only if you have configured Report Builder to run with Oracle 
Express.

5. On the Data page, click Query Builder.

Create an executive summary section that 
contains a chart.

Section 4.9, "Creating a summary section 
with a chart"

Create special effects using Javascript. Section 4.10, "Adding Javascript"

Run your report using the Oracle Reports 
Server.

Section 4.11, "Running the Web report from 
the Reports Server"

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
report, building

3. Then click Display to view help topic... 
Building a standard report

Table 4–1 Features demonstrated in this Web sample report

Feature Location
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6. In the Select Data Tables dialog box, click VIDEO_CATEGORY_BY_QTR.

7. Click Include.

8. Click Close.

9. Click . 

Tip: Doing so checks all of the column check boxes.

10. Click the Condition field in the left-hand pane so that your cursor displays in 
the field.

11. In the Query window, click the SALES REGION column in the table.

12. In the Condition field, place your cursor after “SALES REGION”.

13. Type =’West’.  

14. Click  in the toolbar. 

Tip: You now should see SALES_REGION=’West’ in the Condition field.

15. Click OK.

16. Click Next.

17. On the Groups page, click QUARTER, then click  to move it into the 
Matrix Group Fields list.

18. Repeat step 17 to move the STATE field to the Matrix Group Fields list.

19. Click Next.

20. On the Rows page, click PRODUCT_CATEGORY, then click  to move 
the field into the Matrix Row Fields list.

21. Click Next.

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
query, creating

3. Then click Display to view help topic... 
Creating a local query: Report Wizard

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
Query Builder, conditions

3. Then click Display to view help topic... 
Adding conditions to a query
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22. On the Columns page, click CITY, then click  to move the field into the 
Matrix Column Fields list.

23. Click Next.

24. On the Cells page, click TOTAL_COST, then click  to move the field into 
the Matrix Cell Fields list.

25. Repeat step 24 to move the following fields into the Matrix Cell Fields list:

■ TOTAL_SALES

■ TOTAL_PROFIT

26. Click Next.

27. On the Totals page, click TOTAL_COST, then click Sum to move the sum of the 
TOTAL_COST field into the Matrix Totals list.

28. Repeat step 27 to move the sums of the following fields to the Matrix Totals list:

■ TOTAL_SALES

■ TOTAL_PROFIT

29. Click Next.

30. On the Labels page, modify the widths as shown in the following table:

31. Click Next.

32. On the Template page, under Predefined templates, click the Corporate 1 
template.

33. Click Finish.

Table 4–2 Labels and widths

Column Width

STATE 2

TOTAL SALES 6

TOTAL COST 6

TOTAL PROFIT 6

All Sum... columns 6
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34. Choose File->Save As. Save the report in the directory of your choice, and 
name the report web_41.rdf.

Tip: It is good practice when you are designing your report to save it frequently 
under a different file name. If you generate an error or if you don’t like some of 
the changes you made, you easily can go back to the previously saved file and 
make revisions from that point.

4.2 Modifying the look of your report output
The steps in this section will help you modify the appearance of data by using 
format masks and changing the maximum rows of data returned by your query. 

4.2.1 Modifying the layout in the Live Previewer

1. In the Live Previewer, click the image in the header to select it, and press 
DELETE.

2. Select the date and boilerplate text object labeled “Report run on:”. You can 
select the objects by shift-clicking on each object.

3. Press DELETE.

4. Click  to go to the Layout Model view.

5. In the Object Navigator, place your cursor in the Find field and type
F_SumTOTAL_SALESPerPRODUCT_CATEGORY.

6. Press DELETE.

7. Repeat steps 5 and 6 to delete these fields:

■ F_SumTOTAL_COSTPerPRODUCT_CATEGORY

■ F_SumTOTAL_PROFITPerPRODUCT_CATEGORY

■ F_SumTOTAL_SALESPerSTATE

■ F_SumTOTAL_COSTPerSTATE

■ F_SumTOTAL_PROFITPerSTATE

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
object, deleting

3. Then click Display to view help topic... 
Deleting an object
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8. Click  to go to the Live Previewer.

9. In the Live Previewer, click  to go to the last page of the report.

10. Delete the following fields and their labels:

■ F_SumTOTAL_SALESPerReport

■ F_SumTOTAL_COSTPerReport

■ F_SumTOTAL_PROFITPerReport

■ the page number at the bottom of the page

Tip: You can view the name of any object by clicking on it once, then choosing 
Tools->Property Palette to view the Name property.

11. Save your report as web_412.rdf. Your output should look something like the 
following figure in the Live Previewer:

4.2.2 Adding format masks

1. In the Live Previewer, click on the F_TOTAL_SALES column of data (located 
under the Total Sales title of data). 

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
format mask, applying to numeric object

3. Then click Display to view help topic... 
Applying a format mask to a numeric object
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2. Click  to add the dollar sign to each value.

3. Click  twice to add two decimal places.

4. Select all of the following objects by shift-clicking each object, then follow steps 
2 and 3 to set the format masks: 

■ Total Cost column of data

■ Total Profit column of data

■ F_SumTOTAL_SALESPerCITY (the last field in the Total Sales column)

■ F_SumTOTAL_COSTPerCITY (the last field in the Total Cost column)

■ F_SumTOTAL_PROFITPerCITY (the last field in the Total Profit column)

5. Click  to go to the last page of the report.

6. Select all of the following objects by shift-clicking each object, then follow steps 
2 and 3 to set the format masks:

■ F_SumTOTAL_SALESPerQUARTER

■ F_SumTOTAL_COSTPerQUARTER

■ F_SumTOTAL_PROFITPerQUARTER

4.2.3 Changing the maximum number of rows returned by your query
When designing a large report (i.e., one that retrieves many records), it is helpful to 
reduce the number of records retrieved during the design and test phases of the 
project.

1. In the Live Previewer, click  to access the Data Model view.

2. In the Data Model view, click on Q_1.

3. Choose Tools->Property Palette.

4. In the Property Palette, under the Query node, set the Maximum Rows to Fetch 
property to 100. 

Tip: Note that you can change this property according to the number of rows 
you want to view. However, the more rows you fetch, the longer it will take for 
your browser to load your HTML output. When you are done designing your 
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report and you want to see all of the rows of data, you should reset this 
property to blank.

5. Press RETURN or ENTER.

6. Save your report as web_42.rdf.

4.3 Including an HTML report header 
The steps in this section will help you to add an HTML file to your report. This will 
add a title and graphic to your HTML output. It will also add a background to 
every page of your HTML output. The HTML report header page contains the 
information in the <HEAD> tag of your HTML output.

1. In the Object Navigator, click  next to your report.

2. Choose Tools->Property Palette.

3. In the Property Palette, under the Report Escapes node, set the Before Report 
Type property to File.

4. Set the Before Report Value property to your directory\rbweb_hdr.htm. 

Tip: You can click on the browse (...) button to locate this file. This file should be 
located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory.

5. Optional: At this point, you can also return to the Layout Model view and 
modify the colors of the text and field objects in your layout. You can do this by

clicking on each object, then clicking  (or the other two icons above and 
below it) and choosing a color from the palette.

6. In the Object Navigator, click  next to your report.

7. Save your report output as web_43.rdf.

8. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet. When prompted, save your report output as web_43.htm.

9. Open web_43.htm in your Web browser. Confirm that the title “21st Century 
Video” and a graphic appear at the beginning of your report.

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
HTML output, creating document header

3. Then click Display to view help topic... 
Creating an HTML document header
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Tip: At this point, your layout may overlay part of the header. This will be fixed 
in a later step. Note also that you can add other HTML files to your report by 
using the other properties under Report Escapes.

Your HTML output should look something like the following figure:

4.4 Adding bookmarks to parts of your report
The steps in this section will help you to add bookmarks to your report and 
generate HTML output:

1. Go from your web browser to Report Builder, if you are not already there.

2. In the Live Previewer, choose Tools->Web Wizard.

3. If the Welcome page of the Web Wizard appears, click Next.

4. On the Bookmarks page, move the QUARTER and STATE columns to the 
Bookmarks list by selecting each, and clicking .

5. Click Next.

6. On the HTML Headers/Footers page, you should see the HTML header file you 
added to your report in Section 4.3, "Including an HTML report header". Click 
Next.
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7. On the Finished page, click Generate HTML style sheet output now. Note that 
if you check the Generate to Web Browser check box, not all of the additional 
HTML files you’ve added will display.

8. Click Finish. You will be prompted to choose a file name and directory. Save 
your file as web_44.htm.

9. In the Object Navigator, click  next to your report.

10. Save your report output as web_44.rdf.

11. Open web_44.htm in your Web browser. Click on some of the bookmarks to 
check that they work properly.

Your HTML output should look something like the following figure:

4.5 Changing the page separator
While viewing the HTML output in your browser, you will notice a gray line 
separating each “page” of your output. The steps in this section will help you to 
remove that page separator. 

1. In the Object Navigator, click  next to your report.

2. Choose Tools->Property Palette.
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3. In the Property Palette, under the Report Escapes node, delete the After Page 
Value property.

4. In the Object Navigator, click  next to your report.

5. Save your report output as web_45.rdf.

6. Choose File->Generate to File->HTML Style Sheet.

7. When prompted, save the HTML output as web_45.htm.

8. Open web_45.htm in your Web browser to confirm the page separator no 
longer displays between pages. You can compare web_45.htm to web_44.htm.

4.6 Adding hyperlink destinations and hyperlinks
In your HTML output, you may want to add hyperlinks so that you can click on 
text or images to access other hyperlink destinations, such as external URLs or other 
destinations within your report. The steps in this section will help you to add 
targets to your Web report, and then add hyperlinks that link to the targets, as well 
as to external hyperlink destinations.

4.6.1 Adding hyperlink destinations
1. In the Layout Model view, choose Edit->Select All to select all the objects, and 

move the entire selection down 0.5 inches. 

Tip: In addition to dragging with the mouse, you can also move selected objects 
using the arrow keys.

2. Click  to create a boilerplate text object above the layout, and type Sales 
Results. 

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
After Page Value property

3. Then click Display to view help topic... 
After Page Value
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Tip: You can use the color-changing tools in the tool palette to modify the look 
of this text object.

3. Choose Tools->Property Palette.

4. In the Property Palette, under the General Information node, set the Name 
property to Text_RptTop.

5. Under the Web Settings node, set the Hyperlink Destination property to
rpt_top.

6. In the Object Navigator, click  next to your report.

7. Save your report output as web_461.rdf. This text object is the target of a 
hyperlink you will create in a later step.

4.6.2 Adding hyperlinks to destinations within the report

1. In the Layout Model view, click . Repeating steps 2 and 3 of Section 4.6.1, 
"Adding hyperlink destinations", create a boilerplate text object below the 
layout, and type Back to Top.

2. Under the General Information node, set the Name property to text_totop.

3. Under the Web Settings node, set the Hyperlink property to #rpt_top.

4. In the Object Navigator, click  next to your report.

5.  Save your report output as web_462.rdf.

4.6.3 Adding hyperlinks to external destinations
1. In the Layout Model view, choose File->Import->Image.

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
text, creating boilerplate

3. Then click Display to view help topic... 
Creating a boilerplate object for text

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
hyperlink destination, creating

3. Then click Display to view help topic... 
Creating a hyperlink destination using the Property palette
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2. In the Import Image dialog box, click File. Then either type the path and name 
of the image (imdb.bmp), or click Browse to find the file.

3. Click OK.

4. In the Layout Model view, click on the image object you just imported, and drag 
it down below the table and the boilerplate text object labeled “Back to Top”.

5. Choose Tools->Property Palette.

6. In the Property Palette, under the General Information node, set the Name 
property to IMDB_BMP.

7. Click  to create a boilerplate text object below the table. Type For more 
information, go to the Internet Movie Database.

8. When finished, click .

9. Click on the boilerplate text object you just created.

10. Click .

11. In the color palette, click a color, such as blue.

Tip: You can also choose colors for the background of the textbox, or remove the 
line from the border of the textbox.

12. Shift-click the image object and the new boilerplate text object. 

13. Choose Tools->Property Palette.

14. In the Property Palette, under the Web Settings node, set the Hyperlink 
property to http://www.imdb.com.

15. In the Layout Model view, select the boilerplate text object labeled “For more 
information, go to the Internet Movie Database”.

16. Choose Tools->Property Palette.

17. In the Property Palette, under the General Information node, set the Name 
property to IMDB_text.

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
hyperlink, creating

3. Then click Display to view help topic... 
Creating a hyperlink using the Property palette
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Your current layout should look similar to the following figure:

18. In the Object Navigator, click  next to your report.

19. Save your report output as web_463.rdf.

20. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

21. When prompted, save your report output as web_463.htm.

22. Open web_463.htm in your Web browser to confirm that the new hyperlinks 
work properly.
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Your HTML output should look similar to the following figure:

4.7 Displaying pop-ups and rollovers in HTML output
You can further enhance objects that contain hyperlinks by adding pop-ups and 
rollovers that contain textual descriptions. The steps in this section will help you to 
create pop-up and rollover text that displays when you drag the mouse over an 
object in your HTML report.

4.7.1 Adding a pop-up to an image object

1. In the Object Navigator, place your cursor in the Find field and type IMDB_BMP. 

2. Choose Tools->Property Palette to display the Property Palette for the 
imported image object.

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
display name property

3. Then click Display to view help topic... 
Display Name
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3. In the Property Palette, under the Web Settings node, set the Display Name 
(HTML) property to Internet Movie Database.

4. In the Object Navigator, click  next to your report.

5. Save your report output as web_471.rdf.

6. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

7. When prompted, save your report output as web_471.htm.

8. Open web_471.htm in your Web browser.

9. Drag your mouse over the image object to view the pop-up text that displays 
over the object.

4.7.2 Adding a rollover to an image object
1. In the Object Navigator, under the Main Section node, then the Body node, 

click  next to IMDB_BMP.

2. Choose Tools->Property Palette.

3. In the Property Palette, under the Web Settings node, set the Additional 
Hyperlink Attributes (HTML) to:

onMouseover="window.status=’Clicking here will display the 
Internet Movie Database home page.’;return true"
onMouseOut="window.status=’ ’;return true"

4. Press RETURN or ENTER to make sure the property is set.

5. In the Object Navigator, click  next to your report.

6. Save your report output as web_472.rdf.

7. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

8. When prompted, save your report output as web_472.htm.

9. Open web_472.htm in your Web browser.

10. Drag your mouse over the image object to view the rollover text in the hint line 
of your browser. Note that you will have to scroll down to the end of the HTML 
document in order to view the image object.
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4.8 Using PL/SQL to conditionally hide/show objects for Web output
The steps in this section will help you to specify that certain objects, such as page 
numbers, will not display in your HTML, HTMLCSS, or PDF output. However, 
these items will still display in other report file formats.

1. In the Layout Model view, click the boilerplate text object labeled “Back to Top”.

2. Choose Tools->Property Palette.

3. Under the Advanced Layout node, set the Format Trigger property to:

function text_totop1FormatTrigger return boolean is
begin
  if UPPER(:DESFORMAT) = ’HTML’ or
     UPPER(:DESFORMAT) = ’HTMLCSS’ or
     UPPER(:DESFORMAT) = ’PDF’
  then
     return (TRUE);
  else
     return (FALSE);
  end if;
end;

4. Click Compile.

5. If any compilation errors occur, check the code for syntax errors, and recompile 
as needed.

6. Click Close.

7. In the Object Navigator, click  next to your report.

8. Save your report output as web_48.rdf.

9. Click  to view your report output in Report Builder’s Live Previewer.

10. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

11. When prompted, save your report output as web_48.htm.

12. Open web_48.htm in your Web browser. Compare your HTML output to your 
report output in the Report Builder Live Previewer. The boilerplate text object 
labeled “Back to Top” should display in your browser, but not in the Live 
Previewer.
                                                    Building a Report for the Web 4-79



Creating a summary section with a chart
4.9 Creating a summary section with a chart
The steps in this section will help you to create a summary section for your report, 
and include a pie chart in the summary section.

4.9.1 Creating the data model for the summary section
1. Return to Report Builder from the web browser if you are not already there.

2. In the Data Model view, click  and click on the canvas region. 

Tip: If the Data Model tool palette is not displayed, choose View->Property 
Palette.

3. In the SQL Query Statement dialog box, click Query Builder.

4. In the Select Data Tables dialog box, click VIDEO_CATEGORY_BY_QTR.

5. Click Include.

6. Click Close.

7. In Query Builder, check the QUARTER column check box and the TOTAL 
PROFIT column check box in the table.

8. In the Condition field, type the condition:

SALES_REGION=’West’AND TOTAL_PROFIT>2000

9. Click .

10. Click OK.

11. In the SQL Query Statement dialog box, click OK.

12. In the Object Navigator, click  next to your report.

13. Save your report output as web_491.rdf .
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4.9.2 Creating the default layout for the summary section
1. In the Layout Model view, click  to access the Header section of your 

report.

2. In the Header section, click  to create a boilerplate text object at the top of 
the layout. Type Executive Summary of Video Sales.

3. Click on the boilerplate text object you just created, then choose Format->Font.

4. In the Font dialog box, choose a font, such as Footlight MT Light, then click OK.

Tip: While the boilerplate text object is still selected, you can change the font 
and fill colors.

5. Click  to create a boilerplate text object below the one you’ve just created. 
Type Quarter Profits. 

6. Click  and create a repeating frame that is about 3 inches wide and 0.5 
inches tall about 4 inches from the top of the layout.

7. Choose Tools->Property Palette.

8. In the Property Palette, under the General Information node, set the Name 
property to R_execprof.

9. Under the Repeating Frame node, set the Source property to G_QUARTER1.

10. Click  and create a field that fits inside the repeating frame (approximately

1.5 inches wide and 0.25 inches tall).

11. Choose Tools->Property Palette.

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
repeating frame, creating

3. Then click Display to view help topic... 
Creating a frame or repeating frame

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
field, creating

3. Then click Display to view help topic... 
Creating a field object
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12. In the Property Palette, under the General Information node, set the Name 
property to F_qrtr.

13. Under the Field node, set the Source property to QUARTER1.

14. Repeat steps 10 and 11 to create a second field. Set the following properties:

15. Arrange the layout to look similar to the following figure:

16. Click  to check that your query and layout work properly. 

Tip: If you receive PL/SQL errors, you can try choosing 
Program->Compile->All to compile your format triggers.

17. In the Object Navigator, click  next to your report.

18. Save your report as web_492.rdf.

19. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

20. When prompted, save your report output as web_492.htm.

21. Open web_492.htm in your Web browser to confirm that the first page displays 
your new header page. 

Table 4–3 Property settings for second field

Node Property Setting

General Name F_proffld

Field Source TOTAL_PROFIT1

Format Mask $NNN,NN0.NN
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4.9.3 Creating a chart for the summary section

1. In the Layout Model view, if you are not in the Header section, click .

2. Click  to bring up the Chart Wizard. 

Tip: When you launch the Chart Wizard, Oracle Graphics Builder runs in the 
background. On Windows, you should see this application in your taskbar.

3. If the Welcome page of the Chart Wizard displays, click Next.

4. On the Type page, click Pie in the Chart Type list and Depth in the Chart 
Subtype list.

5. Click Next.

6. On the Data Group page, click G_QUARTER1(QUARTER1,TOTAL_PROFIT1).

7. Click Next.

8. On the Category page, click on QUARTER1, then click  to move the field 
into the Category Axis list.

9. Click Next.

10. On the Value page, click on TOTAL_PROFIT1, then click  to move the 
field into the Value Axis list.

11. Click Next.

12. On the Break page, choose to display the chart at the beginning of the report.

13. Click Next.

14. On the File page, click Save As. When prompted, use the file name rbweb_
chart.ogd. Save the file in the same directory as your .RDF and .HTM files.

15. Click Finish.

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
chart, creating

3. Then click Display to view help topic... 
Creating a Graphics Builder chart

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
files, supported file types

3. Then click Display to view help topic... 
Supported files
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16. Click on the chart object.

17. Choose Tools->Property Palette.

18. In the Property Palette, under the General Information node, set the Name 
property to rbweb_chart.

19. Resize the chart and re-arrange the layout to look similar to the following 
figure:

20. In the Object Navigator, click  next to your report.

21. Save your report output as web_493.rdf.

22. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

23. When prompted, save your report output as web_493.htm.

24. Open web_493.htm in your Web browser to confirm that a chart displays on the 
first page of your output.
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4.9.4 Adding hyperlinks to your chart 
You can also add hyperlinks to your chart that will drill down to corresponding 
data. In this exercise, you will create hyperlinks from the pie chart to the summary 
report you created in Section 4.9.2, "Creating the default layout for the summary 
section". 

1.  In the Layout Model view, click the Chart object.

2. Choose Tools->Property Palette.

1. In the Property Palette, under the Chart node, set the Chart Hyperlink property 
to #rbweb_chart&<Total_Profit1>.

2. In the Object Navigator, place your cursor in the Find field and type

F_PROFFLD.

3. Choose Tools->Property Palette.

1. In the Property Palette, under the Web Settings node, set the Hyperlink 
Destination property to rbweb_chart&<Total_Profit1>.

1. Save your report as web_494.rdf.

2. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

3. When prompted, save your report output as web_494.htm.

4. Open web_494.htm in your Web browser click an area on the pie chart to access 
the corresponding data in the report. 
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4.10 Adding Javascript
The steps in this section will help you to add Javascript to your Web report. Doing 
so will create additional special effects for your report, such as animation and 
customized navigational controls.

In order for the Javascript in this exercise to work properly, you should have 
completed Section 4.9, "Creating a summary section with a chart" and Section 4.3, 
"Including an HTML report header".

4.10.1 Creating animated objects
In this exercise, you will add Javascript to a text object that, when open in a Web 
browser, will change an image object from blue to red when you pass your mouse 
over the image.

To complete this exercise, you will need the 1.gif.

1. Copy the 1.gif file (located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 
directory) to the destination directory (the location where the generated HTML 
files will reside).

2. In the Layout Model view, if you are not in the Main section, click .

3. Choose Tools->Property Palette.

4. Drag the entire selection up to the top of the Layout Model view (so that there is 
no empty space between the top margin and the boilerplate text object labeled 
“Sales Results”).

5. Click  and create a boilerplate text object about 0.5 inches by 0.5 inches,
directly below the layout.

6. Type the following Javascript into the boilerplate text object:

<a href="#webrep_bottom" onmouseover=
"document.images[’example’].src=image02.src" onmouseout=
"document.images[’example’].src=image01.src">
<img src="1.gif" name="example" border=0></a>

7. Choose Tools->Property Palette.

8. In the Property Palette, under the General Information node, set the Name 
property to B_JS.
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9. Under the Web Settings node, set the Contains HTML Tags property to Yes. 
Note that part of the necessary Javascript coding has already been entered into 
the head of your HTML output (the rbweb_hdr.htm file). In the next step you 
will add the Javascript to the body of your HTML output.

10. Under the Advanced Layout node, set the Format Trigger property to:

function B_JSFormatTrigger return boolean is
begin
  if UPPER(:DESFORMAT) = ’HTML’ or
     UPPER(:DESFORMAT) = ’HTMLCSS’ or
     UPPER(:DESFORMAT) = ’PDF’
  then
     return (TRUE);
  else
     return (FALSE);
  end if;
end;

11. Click Compile.

12. If any compilation errors occur, check the code for syntax errors, and recompile 
as needed.

13. Click Close.

14. Set the Print Object On property to All Pages.

15. In the Layout Model view, create a boilerplate text object labeled Click on the 
arrow to view the Executive Summary. Place this object next to the 
boilerplate text object containing the Javascript (B_JS).

16. Choose Tools->Property Palette.

17. In the Property Palette, under the Advanced Layout node, set the Print Object 
On property to All Pages.

18. In the Object Navigator, click  next to your report.

19. Save your report output as web_4101.rdf.

20. Generate HTML output by choosing File->Generate to File->HTML Style 
Sheet.

21. When prompted, save your report output as web_4101.htm.

22. Open web_4101.htm in your Web browser and confirm that the boilerplate text 
object you created displays. You should also see a blue arrow that turns red 
when you drag your mouse over it. 
                                                    Building a Report for the Web 4-87



Adding Javascript
Tip: You can click on this arrow to access your Executive Summary if you’ve 
completed Section 4.9, "Creating a summary section with a chart". You can also 
repeat step 3 in Section 4.8, "Using PL/SQL to conditionally hide/show objects 
for Web output" to conditionally show/hide the objects you created in this 
section, so that they only display in your HTML output.

4.10.2 Using HTML page streaming 
You can use HTML page streaming in your Web report to display navigational 
controls so that users can easily move from one page to another. HTML page 
streaming enables you to display individual pages of your HTML/HTMLCSS 
report output in your Web browser, without having to download the entire report. 
From the first page of the report, you can navigate to any page in the rest of the 
report. When you click a bookmark or hyperlink with a destination:

■ within the report, the frame that contains the current page will update with 
the destination page.

■ outside the report, the entire base frame (including the bookmark frame, the 
page, and the navigation frame) will reload.

Report Builder provides default page streaming controls. For this exercise, however, 
you will use customized the navigational controls. For your convenience, the 
graphics and javascript needed to create the customized controls have been 
provided. They are:

■ rbweb_ps.htm, which contains the javascript

■ 14 .GIFs containing page, first, back, or next as part of file name (e.g., 
page-e.gif)

1. Copy the .GIF and .HTM files (located in your ORACLE_
HOME\TOOLS\DOC60\US\RBBR60 directory) to the destination directory (the 
location where the generated HTML files will reside).

2. In the Object Navigator, click  next to your report.

3. Choose Tools->Property Palette.
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4. In the Property Palette, under the Report Escapes node, set the following 
properties:

5. Save your report output as web_4102.rdf.

6. Exit Report Builder.

7. Restart Report Builder from the command line by typing the following:

rwbld60 pagestream=yes. 

8. Open the report (last saved as web_4102.rdf).

9. Connect to the database.

10. Generate HTML output by choosing File->Connect.

11. Choose 

12. In the Object Navigator, click  next to your report.

13. When prompted, save your report output as web_4102.htm.

14. Open web_4102.htm in your Web browser and confirm that the navigational 
controls display.

Table 4–4 Property settings for page streaming

Property Setting

Page Navigation Control Type File

Page Navigation Control Value ORACLE_HOME\TOOLS\DOC60\US\ 
RBBR60\rbweb_ps.htm. 

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
HTML page streaming, displaying individual pages

3. Then click Display to view help topic... 
Displaying individual pages of HTML report output
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4.11 Running the Web report from the Reports Server
The steps in this section are optional; they will help you run your report 
dynamically from the Reports Server.

To complete this exercise, you must have Oracle Reports Server software, and must 
have installed and configured the Reports Server for dynamic reporting. Refer to 
the Publishing Reports manual for more information, or contact your system 
administrator for assistance.

1. Copy the following files from the ORACLE_HOME\TOOLS\DOC60\US\RBBR60 
directory on your machine to the directory where the cached files are sent. Refer 
to the Reports Server configuration file to determine the cache directory.

■ rbweb_hdr.htm

■ rbweb_page.htm

■ 1.gif 

■ 3.gif

■ drama.gif 

■ 14 .GIFs containing page, first, back, or next as part of the file name (e.g., 
page-e.gif).

2. Ensure that the Reports Server can locate your Web report, last saved as web_
4102.rdf (i.e., the location of the report is set in the SOURCEDIR parameter of 
the Reports Server Configuration file or set in the REPORTS60_PATH 
environment variable).

3. From your Web browser, make the following request:

http://your_webserver/cgi-bin/rwcgi60.exe?report=web_4102.rdf+
userid=user_name/password@mydb+
server=repserver+desformat=htmlcss+
destype=cache+pagestream=yes

where:

your_webserver is the URL address of the Web server

cgi-bin is the virtual location of the CGI or OWS executable

user_name/password@mydb is the connection string to the database

repserver is the name of the Reports Server 
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4.12 Summary
Congratulations! You have finished the Web sample report. You now know how to:

■ Apply format masks.

■ Add other HTML files via Report Escapes.

■ Add bookmarks to facilitate navigation.

■ Add hyperlinks to destinations within your report and to external Web sites.

■ Display pop-ups and rollovers.

■ Conditionally hide and show items for Web output.

■ Create an executive summary section for your report that contains a chart.

■ Create special effects using Javascript.

For more information about web-based reports, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
web report, about

3. Then click Display to view help topic... 
About web reports
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                                                  Building a Report with Sec
5

Building a Report with Sections

The report described in this chapter is designed to help you learn more about 
Report Builder features for report sections and distribution.

To build this report, you will use the Data Wizard to create a multi-query data 
model, then use the Report Wizard to create the default layout for the first section. 
You will make fairly extensive manual refinements in the Data Model and Layout 
Model views. Then, you will again use the Report Wizard to create a default layout 
for the second section, based on the same data model, and make minor manual 
refinements in the Layout Model view and Live Previewer.

In this example, you will create a detailed report in the main section showing 
investment fund elections, and an account summary for employees vested at a 
specified percentage (one landscape page per employee). Then you will create 
one-page summary report in the header section of all employees vested at a 
specified percentage. Finally, you will set up distribution parameters to output each 
section of the report to multiple formats and destinations.

About sections Report sectioning enables you to define multiple layouts in the 
same report, with each layout having a different target audience, output format, 
page layout, page size, and orientation. You can define up to three report sections 
(i.e., the Main, Header, or Trailer section). In the other sections, you can define 
different layouts rather than creating multiple separate reports. For example, a 
single report can include an executive summary for senior management in one 
section and can also include a detailed breakdown for individual managers in 
another section.

The following figure provides a conceptual overview for building a report with 
multiple sections, and then distributing the report based on the distribution 
parameters defined for each section. Table 5–1, "Features demonstrated in this 
Sections sample report" describes the steps you will take to create this report.
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The sect.rdf file contains the report you will create after finishing the tasks in this 
chapter. You may want to refer to this file while you are working. This file is located 
in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory.

To get started, open Report Builder. If the Welcome dialog box appears, click Build 
a new report manually and click OK. If not, choose File->New->Report. Click 
Build a new report manually and click OK.

At some point before you generate the report, you will need to log into the 
database. Choose File->Connect to connect to the database. Enter the appropriate 
log on information. See Section 1.3, "Obtaining database access before you start" for 
details.

Table 5–1 Features demonstrated in this Sections sample report

Feature Location

Create a data model by building five 
different queries.  Then refine the data model 
in the Data Model view.

Section 5.1, "Creating a data model"

Build a Runtime Parameter Form in which 
users enter parameter values that determine 
how the report will run.

Section 5.2, "Designing a Runtime Parameter 
Form"

Use the Report Wizard to create a default 
layout for a detailed section.

Section 5.3, "Creating a layout for the first 
section"

Make manual refinements to the first section 
in the Layout Model view.

Section 5.4, "Refining the layout in the 
Layout Model view"

Use the Report Wizard to create a default 
layout for a summary section. Then make 
minor manual refinements in the Layout 
Model view and Live Previewer.

Section 5.5, "Creating a layout for the second 
section"

Specify how the two sections of the report 
that you have created will be distributed.

Section 5.7, "Specifying distribution"
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5.1 Creating a data model
The steps in this section will help you create a data model by building five different 
queries. Then,  you will refine the data model manually in the Data Model view.

5.1.1 Building queries using the Data Wizard
When building a report with multiple queries, you typically use the Data Wizard to 
create each query and the Report Wizard to create the layout. The steps in this 
section will help you to create five different queries using the Data Wizard.

1. In the Data Model view, click  to display the Data Wizard.

2. If the Welcome page appears, click Next.

3. Type Q_acct in Query Name and click Next.

4. If the Type page appears, click SQL statement, and click Next. The Type page 
will only appear if you have configured Report Builder to run with Oracle 
Express.

5. Type the following SELECT statement. This query selects personnel information 
for each employee, along with investment fund deferral and vested 
percentages:

SELECT a.lastname,
a.firstname,
a.mi,
a.ssn,
a.pct_deferral,
a.pct_vested,
d.street,
d.city,
d.state,
d.zip

FROM accts a,
acct_addrs d

WHERE a.pct_vested=:p_pct_vested
AND d.ssn=a.ssn

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
query, creating

3. Then click Display to view help topic... 
Creating a local query: Data Wizard
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6. Click Next. If you are connected to the database, you will receive a notification 
that Report Builder is creating a bind parameter for you. Click OK to dismiss it. 
Because the WHERE clause of this query refers to a bind parameter (p_pct_
vested) that does not yet exist, Report Builder creates the parameter for you and 
notifies you that it has been created.

7. On the Groups page, click Next. This query requires no break groups.

8. On the Summary page, click Next. You will create some totals later on in this 
chapter.

9. Click Finish.

10. Repeating steps 1 through 9, create four more queries with the following 
characteristics: 

■ Query Name:  Q_dist

Q_dist selects the percent distribution of investment fund elections for each 
employee.

SELECT c.fund_id,
c.pct_dist,
c.ssn,
f.name

FROM fund_contrib c,
funds f

WHERE  c.fund_id=f.fund_id
ORDER BY f.name

■ Query Name:  Q_xact

Q_xact selects the contribution category (emconame) and description of 
income (description) for each category, for each employee.

SELECT DISTINCT
x.description,
x.type,
t.ssn,
t.empcomp,
c.emconame

FROM
f_xact_type x,
fund_xact t,
f_empcomp c

WHERE t.trans_type=x.type(+)
AND c.empcomp=t.empcomp
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■ Query Name:  Q_funds

Q_funds selects the name of each fund.

SELECT DISTINCT
f.name,
f.fund_id

FROM funds f

■ Query Name:  Q_amount

Q_amount selects the amount invested in each fund, for each employee.

SELECT DISTINCT
amount,
empcomp,
fund_id,
ssn,
trans_type,
xact_id

FROM fund_xact

11. Choose File->Save As. Save the report in the directory of your choice, and 
name the report sect_511.rdf.

Tip: It is good practice when you are designing your report to save it frequently 
under a different file name. If you generate an error or if you don’t like some of 
the changes you made, you easily can go back to the previously saved file and 
make revisions from that point.

5.1.2 Refining the Data Model
The steps in this section will give your groups more meaningful names, create a 
break group, turn your data model into a matrix data model, create data links, and 
create summaries.

1. In the Data Model view, double-click G_lastname, the group owned by Q_acct, 
to display the Property Palette.

2. Under the General Information node, set the Name property to G_acct.

3. Press RETURN or ENTER to set the change.
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4. Repeating steps 1 through 3, rename the following groups:

5. Click and drag the G_xact group down a couple of inches to create some space 
above it.

6. Click the column named empcomp in the G_xact group, and drag it outside and 
above the G_xact group.

7. Click the column named emconame in the G_xact group, and drag it into the 
new group, G_empcomp. Place emconame after the empcomp column.

8. Double-click the G_empcomp group to display the Property Palette.

9. Change the Name property to G_emco.

Table 5–2 Group names

Old Name New Name

G_fund_id G_dist

G_description G_xact

G_name1 G_funds

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
break group, creating

3. Then click Display to view help topic... 
Creating a break group
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10. Rearrange your data model to look similar to the following figure:

11. Click  in the tool palette.

12. Drag a rectangle around groups G_emco, G_xact, and G_funds.

13. Double-click the newly created group, G_1, to display the Property Palette.

14. Change the Name property to G_matrix.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
matrix group, creating

3. Then click Display to view help topic... 
Creating a matrix (crosstab) group
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15. Click  to create a column-to-column link.

16. Click column ssn in group G_acct and drag to column ssn1 in group G_dist. 
(This retrieves the percent distribution of investment fund elections.)

17. Repeating steps 15 and 16, create data links between:

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
data link, creating

3. Then click Display to view help topic... 
Creating a data link

Table 5–3 Data links to create in the data model

column ssn in group G_
acct, and

column ssn2 in group G_xact (to retrieve the contribution 
category and description of income for each category)

column empcomp in 
group G_emco, and

column empcomp1 in group G_amount

column ssn2 in group G_
xact, and

column ssn3 in group G_amount

column fund_id1 in group 
G_funds, and

column fund_id2 in group G_amount (to retrieve for each 
income description in each contribution category in each 
fund, the account balance)

column type in group G_
xact, and

column trans_type in group G_amount (to retrieve for each 
income description, a distinct amount)
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Your data model should now look similar to the following figure:

18. Click .

19. Click on the title bar of group G_matrix. 

In the following steps, you will set this new summary column to calculate totals 
on each income description in each contribution category (row totals).

20. Double-click the newly created column, CS_1 to display the Property Palette.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
totals, creating for column

3. Then click Display to view help topic... 
Creating a summary column
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21. In the Property Palette under the General Information node, set the Name 
property to CS_xactotal.

22. Under the Column node, set the Width property to 38, the Product Order 
property to G_emco G_xact, and the Value if Null property to 0.00.

Tip: The values for the Product Order property can get quite long. To make 
these values easier to see, resize the Property Palette horizontally. 

For more information on the meaning of these properties, click  while the 
property is selected.

23. Under the Summary node, set the Source property to amount and the Reset At 
property to G_xact.

24. Repeating steps 18 through 23, create summary columns in group G_matrix 
with the following characteristics:

■ CS_fundsubtotal calculates totals on each income fund in each contribution 
category (column totals).

■ CS_emcototal calculates grand totals on each contribution category.

■ CS_fundtotal calculates grand totals on each fund in all contribution 
categories.

25. Repeating steps 18 through 23, create a summary column in group G_acct with 
the following characteristics:

■ CS_grandtotal calculates grand totals on each fund in all contribution 
categories.

Table 5–4 Total properties

Name Width Product Order Value if Null Source Reset At

CS_fundsubtotal 38 G_funds G_emco 0.00 amount G_emco

CS_emcototal 38 G_emco 0.00 amount G_emco

CS_fundtotal 38 G_funds 0.00 amount G_funds

Table 5–5 Total properties

Name Width Value if Null Source Reset At

CS_grandtotal 38 0.00 CS_fundtotal G_acct
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26. You may want to rearrange the objects inside of group G_matrix to make the 
summary columns more easily visible.

27. Save your report as sect_512.rdf.

Your data model should now look similar to the following figure:
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5.2 Designing a Runtime Parameter Form
The steps in this section will help you design a Runtime Parameter Form so that 
you can run your report regularly as you make refinements. 

In Section 5.1.1, "Building queries using the Data Wizard", you created a query with 
the bind parameter p_pct_vested. Whenever you run a report with a bind 
parameter, the default Runtime Parameter Form appears. You must assign a value 
to the bind parameter in order to run your report.

You can use the default Parameter Form to enter a value, or you can build your own 
Parameter Form using the Parameter Form view.

1. Choose Tools->Parameter Form Builder.

2. In the Parameter Form Builder, click the following parameters if they are not 
already selected:

■ DESTYPE

■ DESNAME

■ DESFORMAT

■ P_PCT_VESTED

3. Click OK to create a parameter form in the Parameter Form view.

4. Click once to select the P pct vested label, then click it again to enter edit mode. 
(Double-clicking will display the Property Palette.)

5. Select the text, and replace it with % Vested.

6. Double-click PF_P_PCT_VESTED to display the Property Palette.

7. Under the Parameter node, set the Initial Value property to 100.

8. Click in the List of Values property field to display the Parameter List of Values 
dialog box.

9. If it is not already selected, click Static Values.

10. Type 0 in the Value field, then click Add.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
Parameter Form view, overview

3. Then click Display to view help topic... 
Parameter Form view
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11. Repeat step 10 to add the following values: 

10

25

50

75

100

12. Click OK to close this dialog box.

13. Close the Parameter Form view. You will have an opportunity to use the 
Run-time Parameter Form in a later step.

14. Save the report as sect_520.rdf.

5.3 Creating a layout for the first section
The steps in this section will help you to create a layout for a detailed section by 
using the Report Wizard to create a default layout. The Report Wizard by default 
builds a report layout in the main section of the report.

1. Choose Tools->Report Wizard.

2. On the Style page, click Matrix with Group.

3. Click Next.

4. On the Groups page, select the following groups from the Available Fields list 
box:

■ click G_matrix, then click Matrix

■ click G_emco, then click Down

5. Click G_dist (Down) in the Displayed Group list box.

6. Click . The Groups page should look like the one in the following figure:

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
default layout, creating

3. Then click Display to view help topic... 
Creating a default layout for a report
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7. Click Next.

8. On the Fields page, click lastname, then click . Repeat this step to add 
the following fields to the Displayed Fields list:

■ firstname

■ mi

■ ssn

■ pct_deferral

■ pct_vested

■ description

■ emconame

■ name1

■ amount

■ CS_xactotal

■ CS_fundsubtotal

■ CS_emcototal

■ CS_fundtotal

■ CS_grandtotal
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9. Click Next.

10. On the Labels page, delete the labels for all of the columns listed, then rename 
the following columns:

11. Change the widths of the following columns:

12. Click Next.

13. On the Template page, select the Predefined template Cyan Grid.

14. Click Finish.

Table 5–6 Labels

Column Label

ssn SSN:

pct_deferral Deferral Percentage:

pct_vested Vested Percentage:

CS_grandtotal Total Balance

Table 5–7 Widths

Column Width

pct_deferral 4

pct_vested 4

description 9

emconame 9

name1 7

amount 4

CS_xactotal 8

CS_fundsubtotal 8

CS_emcototal 8

CS_fundtotal 8

CS_grandtotal 8
5-108 Oracle Reports Building Reports                                



Creating a layout for the first section
15. In the Runtime Parameter Form, select 100 from the % Vested list box. Notice 
the Destination type, Destination name, and Destination format fields. You can 
choose another output type, such as printer, or change the format. For this 
exercise, however, you will use the default values.

16. Click  to review your report in the Live Previewer. Your report will look 
similar to the following figure:
 

17. Close the Live Previewer.

18. Save your report as sect_530.rdf.
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Refining the layout in the Layout Model view
5.4 Refining the layout in the Layout Model view
The steps in this section will help you to refine the layout of your report using the 
Layout Model view. You will make extensive changes to your layout by doing the 
following:

■ change the attributes of objects, such as font size

■ rearrange objects in your layout

■ add boilerplate objects

■ change the orientation of your report to landscape

When you finish this section, the layout will look similar to the following figure. 
Use this layout to help guide you through this exercise.

Tip: If you re-enter the Report Wizard after making manual refinements in the Live 
Previewer, you will lose some of your changes when you click Apply or Finish in 
the wizard, and your layout will default back to the state defined by the wizard.
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Refining the layout in the Layout Model view
5.4.1 Changing the properties of objects
1. In the Object Navigator, double-click the Layout Model node to display the 

Layout Model view of your report.

2. In the Layout Model view, double-click F_lastname to display the Property 
Palette.

3. Under the General Layout node, change the Horizontal Elasticity property to 
Variable.  Repeat this step for the following objects:

■ F_firstname

■ F_mi

Tip: You can change several objects at one time: shift-click on all objects, then 
choose Tools->Property Palette.

4. Click in an empty area of the canvas to deselect the objects.

5. Shift-click the following objects:

■ F_lastname

■ F_firstname

■ F_mi

■ SSN:

■ F_ssn

■ Deferral Percentage:

■ F_pct_deferral

■ Vested Percentage:

■ F_pct_vest

6. In the toolbar, select 12 from the font size list box to change the font size of the 
selected objects.

7. Click in an empty area of the canvas.

8. Shift-click the following objects, then choose Tools->Property Palette:

■ F_pct_deferral

■ F_pct_vest
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Refining the layout in the Layout Model view
9. In the Property Palette under the Field node, type NNNN% (case sensitive) in the 
Format Mask to display the objects as a percentage.

10. Click in an empty area of the canvas.

11. Shift-click the following layout objects:

■ F_amount

■ F_CS_fundsubtotal

■ F_CS_fundtotal

■ F_CS_xactotal

■ F_CS_emcototal

■ F_CS_grandtotal

12. Click .

13. Click  twice.

14. Click .

15. Click F_description, then click .

16. Save the report as sect_541.rdf.

17. Click .

18. At the Runtime Parameter Form, click  to view the changes in the Live 
Previewer.
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Refining the layout in the Layout Model view
5.4.2 Re-arranging frames and objects
1. In the Object Navigator, double-click  to display the Layout Model view of 

your report.

Tip: Every object in the Layout Model view is also represented in the Object 
Navigator. Sometimes it is easier to refine the layout of a report by selecting 
objects from the Object Navigator. Arrange your workspace to display the 
Object Navigator and Layout Model view side-by-side. When you click an 
object in the Object Navigator, this object is selected in the Layout Model view.

2. In the Object Navigator, expand the Layout Model, Main Section, Body, and 
M_G_ACCT_GRPFR nodes if they are not already expanded.

3. Ctrl-click M_G_ACCT_GRPFR and R_G_ACCT.

4. In the Layout Model view, using the vertical ruler as a guide, lengthen the M_
G_ACCT_GRPFR and R_G_ACCT groups until the bottom of the frames reach 
3 inches.

Tip: M_G_ACCT_GRPFR is the underlying master group. It is under R_G_
ACCT. In the Layout Model view, it may look like only one group is selected 
when, in fact, both frames are selected.

5. In the Object Navigator, type M_G_MATRIX_GRPFR in the Find field to locate 
this object. Note that the search occurs as you type, so you will most likely be 
taken to the object before you finish typing the entire name.

The M_G_MATRIX_GRPFR frame in the Layout Model view looks similar to 
the following figure:

6. In the Layout Model view using the vertical rule as a guide, lengthen the M_G_
MATRIX_GRPFR frame until the bottom of the frame reaches 3 inches.

7. In the Object Navigator, type R_G_FUNDS in the Find field.
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Refining the layout in the Layout Model view
The R_G_FUNDS frame in the Layout Model view looks similar to the 
following figure:

8. In the Layout Model view, lengthen the R_G_FUNDS frame until the bottom of 
the frame reaches its parent (enclosing) frame.

Tip: If you are unable resize the frame as expected, you may need to toggle 
Confine Mode off.

indicates that Confine Mode is on.  indicates that Confine Mode off.

9. Shift-click F_CS_fundtotal and F_CS_grandtotal. Move these objects down until 
they reach their parent frame.

10. In the Object Navigator under the Dimension Repeating Frame node, click R_
G_EMCO.

The R_G_EMCO repeating frame in the Layout Model view looks similar to the 
following figure:

11. In the Layout Model view, lengthen the R_G_EMCO repeating frame until it 
reaches the top of the F_CS_fundtotal and F_CS_grandtotal frames.

The result will look similar to the following figure:
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Refining the layout in the Layout Model view
12. Arrange the following frames end-to-end to look like the figure that follows:

■ F_lastname

■ F_firstname

■ F_mi

13. Click  and then again at the Runtime Parameter Form.

14. Save your report as sect_542.rdf.

5.4.3 Adding boilerplate objects

1. Display the Layout Model view of your report.

2. Click  to create a boilerplate object. Then click in the area directly below 
F_description.

3. Type Subtotal:

4. Click .

5. Change the following, if necessary:

■ Font to Arial using the Font list box in the toolbar

■ Point size to 10

■ Font style to bold. Click .

■ Click  and change the color to dark blue.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
boilerplate, about

3. Then click Display to view help topic... 
About boilerplate objects
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Refining the layout in the Layout Model view
6. If necessary, arrange the boilerplate object so that it is placed next to F_CS_
Fundsubtotal. The result will look similar to the following figure:

7. Repeat steps 2 through 6 to create the following boilerplate objects with the 
specified characteristics:

8. Click  and then again at the Runtime Parameter Form. Your report will 
look similar to the following figure.
 

Table 5–8 Boilerplate objects

Boilerplate Location Text Color

Grand Total: right of F_CS_
fundtotal

Yellow

Total Funds Above F_CS_
xactotal

Yellow
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Creating a layout for the second section
9. Scroll to the right of the report, then click . 

Notice that report is not wide enough to display all the columns on a single 
page and wraps to the second page. Later, in Section 5.6, "Specifying landscape 
orientation and page break", you will change the orientation of this layout to 
landscape and insert a page break. This will allow the report to display one 
record per page. Before you change the orientation, however, you will create a 
layout for the second section using the Report Wizard. 

10. Save the report as sect_543.rdf.

5.5 Creating a layout for the second section
The steps in this section will help you to create a layout for a summary in the 
header section of your report. You will use the Report Wizard to create a default 
layout. Then you will make manual refinements in the Layout Model view and Live 
Previewer.

5.5.1 Creating the default layout
1. Display the Layout Model view of your report.

2. Choose View->Layout Section->Header Section.

3. Ensure that the Body of the report is displayed.

4. Choose Tools->Report Wizard.

5. On the Style page, type Vesting Summary in the Title field, and click Tabular.

6. Click Next.

7. On the Groups page, click G_acct from the Available Fields list box, then click 
Down.

8. Click Next.
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9. On the Fields page, click lastname, then click . Repeat this step for the 
following fields:

■ firstname

■ mi

■ ssn

■ pct_vested

■ CS_grandtotal

10. Click Next.

11. On the Labels page, change labels and widths as follows:

12. Click Next.

13. On the Template page, click the Predefined template Confidential Background.

14. Click Finish.

15. Click  and then again at the Runtime Parameter Form. 

Table 5–9 Labels and Widths

Column Label Width

lastname Last Name 8

firstname First Name 6

mi MI 1

ssn SSN 6

pct_vested Vested Percentage 4

CS_grandtotal Total Balance 6
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Creating a layout for the second section
16. If necessary click  to display the Vesting Summary report. Your report will 
look similar to the following figure:
 

17. Save your report as sect_551.rdf.

5.5.2 Refining the layout in the Live Previewer
1. In Live Previewer, shift-click the following objects, then click :

■ Last Name

■ First Name

■ MI

■ SSN

■ Vested Percentage

■ Total Balance
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Creating a layout for the second section
2. Ensure that Flex Mode is on.

Tip:   indicates that Flex mode is on.  indicates that Flex mode is off. 
Shift-click the data under the following headings:

■ Last Name

■ First Name

■ MI

■ SSN

■ Vested Percentage

■ Total Balance

3. Click the lower-right corner of the selected objects and drag the lower edge of 
the frame down about 0.25 inches. Notice that the space between the rows 
increases. See the before and after figures that follow:

Report before increasing the row spacing:

Report after increasing the row spacing:

4. Arrange your workspace so that the Object Navigator and Live Previewer are 
displayed side-by-side.

5. In the Object Navigator, type R_G_ACCT1 in the Find field.

6. Click the title bar in the Live Previewer to make it active.
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Creating a layout for the second section
7. Choose Format->Border and choose Top to toggle off the top border. A 
checkmark next to an option indicates that it is toggled on.

8. Repeat step 7 for Left and Right. The bottom border will remain toggled on.

9. Click , then choose red. This will place a red line between the rows of 
data. Your report will similar to the following figure:

10. Save the report as sect_552.rdf.
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5.6 Specifying landscape orientation and page break
The steps in this section will help you change the orientation of the layout you 
created in the Main section.

Tip:  If you create multiple layouts using the Report Wizard and plan on changing 
the orientation setting, it is good practice to change the orientation after building all 
of your layouts. If you change the orientation of first layout, then build a second 
layout using the Report Wizard, the orientation of the first layout will revert back to 
the orientation settings defined in the template.

1. In the Object Navigator, if necessary, expand the Layout Model node, then click 
the Main Section node and choose Tools->Property Palette.

2. In the Property Palette under the Section node, make the following changes:

3. Display the Layout Model view of your report.

4. Click  to display the Main section, 

5. In the Layout Model view, click  in the toolbar to expose the Margin of 
your report.

Tip: Click  to switch between the Margin and Body of your report. 
Alternatively, choose View->Layout Section. A check mark next to Edit Margin 
indicates the Layout Model view is in Margin mode.

6. Scroll down to the bottom of the layout, and click the border between the Body 
and the lower Margin.

7. Using the vertical ruler as a guide, resize the area by dragging the border up to 
the 7.5 inch mark.

Tip: Be sure that you are re-sizing the Margin, not moving the Margin.

8. Click  to expose the Body of your report.

9. In the Layout Model view, click the lastname field.

Table 5–10 Property settings for the Section node

Property Setting

Width 11

Height 8.5

Orientation Landscape
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Specifying distribution
10. Click  to select the parent frame.

11. Choose Tools->Property Palette. 

12. Under the Repeating Frame node, set the Maximum Records per Page property 
to 1.

13. Click  and then again in the Runtime Parameter Form. 

14. Click  in the toolbar to display the layout that you created in a previous 
section.

Scroll to the right of the report. Notice the orientation of the report has changed. 
The report can display all the columns on a single page. Notice also that only 
one record per page is displayed.

15. Save your report as sect_560.rdf.

5.7 Specifying distribution
The steps in this section will help you to specify the distribution for the two sections 
that you have created:

■ a detailed report showing investment fund elections, and an account summary 
for employees vested at a specified percentage (at least one landscape page per 
employee).

■ a one-page summary report of all employees vested at a specified percentage.

You will distribute your report as follows:

■ print two copies of the detailed section.

■ format the detailed section in HTML for access on a secure Web site.

■ format the summary section as a PDF.
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Specifying distribution
5.7.1 Specifying distribution for the detailed section
1. In the Object Navigator, type Main Section in the Find field.

2. Choose Tools->Property Palette.

3. Click the Distribution value field to display the Distribution dialog box. Specify 
two distribution output destinations for the report that summarizes account 
information for employees.

4. In the Distribution dialog box, specify the distribution for printing the report:

Tip: If you select Printer as the DESTYPE first, the DESNAME is automatically 
set to your default printer.Change this value if you want to send this report to 
another printer.

5. Click New.

6. In the Distribution dialog box, define the distribution for HTML output:

7. Click OK.

8. Save your report as sect_571.rdf.

Table 5–11 Distribut ion settings for the printed Main section

Field Value

Distribution ID printdist

DESNAME printer path and name

DESFORMAT BITMAP

DESTYPE Printer

COPIES 2

Table 5–12 Distribut ion settings for the HTML version of the Main section

Field Value

Distribution ID htmldist

DESNAME path and file name for the HTML output (e.g., 
c:\sect_rep.htm)

DESFORMAT HTML

DESTYPE File

COPIES 1
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5.7.2 Specifying distribution for the summary section
1. In the Object Navigator, click the Header Section node.

2. Choose Tools->Property Palette.

3. In the Property Palette, under the Section node, click in the Distribution value 
field to display the Distribution dialog box.

4. In the Distribution dialog box, define the distribution for sending the summary 
section to PDF:

5. Save your report as sect_572.rdf.

Optional Exercise: 

Try setting up distribution to e-mail the executive summary. You will need a 
MAPI-compliant mail application set up on your system.

Table 5–13 Distribut ion settings for the PDF version of the Header section

Field Value

Distribution ID pdfdist

DESNAME path and pdf file name (e.g., c:\sect_
rep.pdf)

DESFORMAT PDF

DESTYPE File

COPIES 1
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5.7.3 Distributing the report
1. In the Object Navigator, click your report name, then choose File->Distribute.

2. In the Runtime Parameter Form, click .

3. In the dialog box that prompts for your confirmation to distribute to multiple 
destinations, click Continue.

4. Check the printer, your file system, and (optionally) your e-mail inbox to verify 
that your report was distributed as expected.

Optional Exercise: 

Try setting up distribution by creating a .DSTfile and running the distribution from 
the command line.

Tip: You can trace report distribution. The trace file, which is similar to a .DST file, 
is generated when you check the Distribution check box in the Runtime Trace 
Settings dialog box.

5.8 Summary
Congratulations! You have finished the Sectioning sample report. You now know 
how to:

■ Create a data model and refine it in the Data Model view.

■ Build a Runtime Parameter Form.

■ Create a default layout for a detailed section, and refine it in the Layout Model 
view.

■ Create a default layout for a summary section and refine it in the Layout Model 
view and Live Previewer.

■ Specify report distribution criteria.

For more information about sectioning and distribution, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
sectioning, about

3. Then click Display to view help topic... 
About report sectioning
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                                                       Building a Report with Ref Cursor Quer
6

Building a Report with Ref Cursor Queries

The report described in this chapter is designed to help you learn more about 
Report Builder features for using ref cursors. To build this report, you will use the 
Data Model view to create a multi-query data model, and then use the Report 
Wizard to create the report layout. You will make fairly extensive manual 
refinements in the Data Model view. In this example, you will create a detailed 
report showing information about available shipping containers at various ports.

About ref cursor queries A ref cursor query uses PL/SQL to fetch data. Each ref 
cursor query is associated with a PL/SQL function that returns a strongly typed ref 
cursor. The PL/SQL function must ensure that the ref cursor is opened and 
associated with a SELECT statement that has a SELECT list that matches the ref 
cursor type. You base a query on a ref cursor when you want to:

■ more easily administer SQL

■ avoid the use of lexical parameters in your reports

■ share datasources with other applications, such as Form Builder

■ increase control and security

■ encapsulate logic within a subprogram

Furthermore, if you use a stored program unit to implement ref cursors, you receive 
the added benefits that go along with storing program units in the Oracle database.

The following figure shows that you create a report with the SELECT statement in 
the ref cursor query of the report. It also shows that you can store the  SELECT 
statement in a package in the database. Then, from the report, you can call the 
package from the database allowing you to reuse the package in many reports.

Table 6–1, "Features demonstrated in this Ref Cursor Query sample report", 
describes the steps you will take to create this report.
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The ref.rdf file contains the report you will create after finishing the tasks in this 
chapter. You may want to refer to this file while you are working. In addition, the 
port_container.pll is the library file that is associated with ref.rdf.  These files 
are located in your ORACLE_HOME\TOOLS\DOC60\US\RBBR60 directory.

To get started, open Report Builder. If the Welcome dialog box appears, click Build 
a new report manually and click OK. If not, choose File->New->Report.   Click 
Build a new report manually, and click OK.

At some point before you generate the report, you will need to log into the 
database. Choose File->Connect to connect to the database. Enter the appropriate 
log on information. See Section 1.3, "Obtaining database access before you start" for 
details.

Table 6–1 Features demonstrated in this Ref Cursor Query sample report

Feature Location

Create package specs that define ref cursors. Section 6.1, "Defining a ref cursor type"

Create ref cursor queries that will use the ref 
cursors.

Section 6.2, "Creating a ref cursor query"

Rename objects in the data model so that 
they have more meaningful names.

Section 6.3, "Refining the data model"

Create group-to-group data links between ref 
cursor queries to create relationships 
between them.

Section 6.4, "Creating links between ref 
cursor queries"

Create summaries that better describe the 
data.

Section 6.5, "Adding summary columns"

Use the Report Wizard to create a report 
layout.

Section 6.6, "Creating a layout"

Move the SELECT statements used by the ref 
cursor queries from the report and into 
packages that define the ref cursor types. 

Section 6.7, "Moving the SELECT statement 
into a package"

Move the packages into a PL/SQL library so 
that other reports can share the code.

Section 6.8, "Moving the packages into a 
library"
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Defining a ref cursor type
6.1 Defining a ref cursor type
To create a ref cursor query, you first create a package spec that defines the ref 
cursor. Then you create a query that uses the ref cursor. The steps in this section will 
help you create package specs that define ref cursors.

1. In the Object Navigator, click the Program Units node under your UNTITLED 
report node.

2. Click  to add a program unit.

3. In the New Program Unit dialog box, type concl_cv as the name of the 
program unit.

4. Click Package Spec, and click OK.

5. Type the following package spec definition in the editor. The new code that you 
need to add is in bold:

PACKAGE concl_cv IS
      type conclass_rec is RECORD 
       (ccap number,
        classid number,
        gwl number,

            twl number,

        htf number,
        hti number,
        notes varchar(50),
        teu number);
    type conclass_refcur is REF CURSOR return conclass_rec;
END;

This package spec does two things:

■ Defines a record (conclass_rec) that describes the data you want to select 
from the database.

■ Defines a ref cursor that returns the data in the format described by the 
record.

6. Click Compile.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
query, creating

3. Then click Display to view help topic... 
Creating a local query: Ref Cursor Query tool
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Defining a ref cursor type
7. If any compilation errors occur, check the code for syntax errors and recompile 
as needed.

8. Click Close.

9. Repeat steps 2 through 8 to create two more package specs with the following 
characteristics. New code is displayed in bold:

■ Package Spec Name: cont_cv

PACKAGE cont_cv IS
    type container_rec is RECORD 
       (title varchar(40),
        dockloc varchar(10),
        portid number,
        repno varchar(10),
        status number,
        key varchar(10),
        key2 varchar(10),
        classid2 number);
    type container_refcur is REF CURSOR return container_rec;
END;

■ Package Spec Name: port_cv

PACKAGE port_cv IS
  type portdesc_rec is RECORD 
       (portid number,
        locname varchar(10));
  type portdesc_refcur is REF CURSOR return portdesc_rec;
END;

10. Choose File->Save As. Save the report in the directory of your choice, and 
name the report ref_61.rdf.

Tip: It is good practice when you are designing your report to save it frequently 
under a different file name. If you generate an error or if you don’t like some of 
the changes you made, you easily can go back to the previously saved file and 
make revisions from that point.
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Creating a ref cursor query
6.2 Creating a ref cursor query
After creating package specs that define the ref cursors, you are ready to define the 
queries, as described in this section.

1. In the Object Navigator, double-click  to go to the Data Model view. 

2. Click .

3. Click in the main area (canvas region) of the Data Model view.

4. In the Program Unit Editor, type in the bold code that follows to define the 
function. New code is displayed in bold:

function q_portdescRefCurDS return port_cv.portdesc_refcur is

temp_portdesc port_cv.portdesc_refcur;

begin

  open temp_portdesc for select portid, locname from portdesc;

  return temp_portdesc;

end;

5. Click Compile.

6. If any compilation errors occur, check the code for syntax errors and recompile 
as needed.

7. Click Close. The data objects display in the Data Model view.

8. In the Data Model view, click the ref cursor query object (QR_1), then choose 
Tools->Property Palette.

9. Under the General Information node, change the Name property to
q_portdesc.

Tip: It is usually a good idea to give objects meaningful names, particularly 
when building a report with many objects. Later when building the layout, it is 
helpful to have queries and groups with meaningful names.

10. Press ENTER or RETURN, or click any other field in the Property Palette to 
accept the change.

11. Close the Property Palette.
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12. Repeat steps 2 through 10 to create two more queries with the following 
characteristics. Be sure to rename the queries using the Property Palette after 
creating them. New code is displayed in bold:

■ Query name: q_container

function q_containerRefCurDS return cont_cv.container_refcur is
temp_container cont_cv.container_refcur;
begin
  open temp_container for select cl.title, c.DOCKLOC, 
                                 c.PORTID, c.REPNO, 
                                 c.STATUS, c.key, 
                                 cl.key key2, c.classid classid2
                      from CONTAINERS c, conlabel cl
                      where cl.key=c.key 
                      order by c.REPNO;
  return temp_container;
end;

■ Query name: q_conclass

function q_conclassRefCurDS return concl_cv.conclass_refcur is
temp_concl concl_cv.conclass_refcur;
begin
  open temp_concl for select CCAP, CLASSID, GWL, TWL, HTF, HTI, NOTES, 
TEU
                  from CONCLASS;
                  return temp_concl;
end;

13. The Data Model should look similar to the following figure:
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Refining the data model
14. Save the report as ref_62.rdf.

6.3 Refining the data model
In this section you will rename some of the objects in the data model so that they 
have more meaningful names. You will also create a break group.

1. In the Data Model view, drag the title bar of the group G_TITLE down a few 
inches to move the entire group.

2. With G_TITLE still selected, choose Tools->Property Palette.

3. Under the General Information node, change the Name property to
G_container.

4. Press ENTER or RETURN, or click any other field in the Property Palette to 
accept the change.

5. Close the Property Palette.

6. Click and drag the column named TITLE out of and above G_container to 
create a new break group, as shown in the following figure:

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
break group, creating

3. Then click Display to view help topic... 
Creating a break group
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Refining the data model
7. Click the title bar of the new group (probably named G_TITLE) that contains 
TITLE, and choose Tools->Property Palette.

8. Under the General Information node, change the Name property to G_
conlabel.

9. Press ENTER or RETURN, or click any other field in the Property Palette to 
accept the change.

10. Close the Property Palette.

11. Drag and drop KEY2 from G_container to G_conlabel. KEY2 displays in G_
conlabel and is removed from G_container.

12. Click the title bar of G_PORTID and choose Tools->Property Palette.

13. Change the Name property under the General Information node to G_
portdesc.

14. Press ENTER or RETURN, or click any other field in the Property Palette to 
accept the change.

15. Close the Property Palette.

16. Click the title bar of G_CCAP and choose Tools->Property Palette.

17. Under the General Information node, change the Name property to
G_conclass.

18. Press ENTER or RETURN, or click any other field in the Property Palette to 
accept the change.

19. Close the Property Palette.

20. In the Data Model view, your data model should look similar to the following 
figure:
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21. Save the report as ref_63.rdf.

6.4 Creating links between ref cursor queries
Currently, the queries that you have created are unrelated. To create relationships 
between them, you need to create group-to-group data links. The steps in this 
section will help you create the links.

1. In the Data Model view, click .

2. Click the title bar of G_portdesc, and drag to the title bar of G_container.

3. Double-click q_container. The Program Unit Editor displays.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
data link, creating

3. Then click Display to view help topic... 
Creating a data link (Report Builder Help)
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4. Now you will append code to the WHERE clause of the SELECT statement to 
specify which columns are being used as primary and foreign keys.

After where cl.key=c.key, add the following code:

and :portid=c.PORTID

Note that :portid is a bind variable referring to the PORTID column in G_
portdesc.

5. Click Compile.

6. If any compilation errors occur, check the code for syntax errors and recompile 
as needed.

7. Click Close.

8. Click .

9. Click the title bar of G_container and drag to the title bar of G_conclass.

10. Double-click q_conclass.

11. Now you will add a WHERE clause to the SELECT statement. Insert your 
cursor between FROM CONCLASS and the semicolon (;), and press ENTER or 
RETURN to create a new line.

12. Add the following code:

where :classid2=conclass.classid

Tip: Be sure that the semicolon (;) now follows the WHERE clause.

Note that :classid2 is a bind variable referring to the CLASSID2 column in G_
container.

13. Click Compile.

14. If any compilation errors occur, check the code for syntax errors and recompile 
as needed.

15. Click Close.
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16. Your data model should look similar to the following figure:

17. Save the report as ref_64.rdf.

6.5 Adding summary columns
Now that your queries are complete and linked, the steps in this section will help 
you to create columns to summarize the data.

1. In the Data Model view, click .

2. Click inside the G_container group. This creates a new column, CS_1.

3. Double-click the newly created column to open the Property palette.

4. Under the General Information node, change the Name property to
CS_classcount.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
summary column, creating

3. Then click Display to view help topic... 
Creating a summary column
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5. Under the Summary node, change the following settings:

6. Click any other field in the Property Palette to accept the changes.

7. Close the Property Palette.

You have now created a summary that counts up the number of containers. You 
will not use the summary in this report’s layout, but you will use it as the 
source for other, more interesting summaries later.

8. Repeat steps 1 through 5 to create summaries with the following characteristics:

You may not understand these summaries now. Their purpose will become 
clearer when you create the report layout and preview the live data.

Table 6–2 Property settings for the Summary node

Property Setting

Function Count

Source KEY

Reset At G_container

Table 6–3 Summary properties

Create in 
Group Name Function Source Reset At

G_conlabel CS_conlabel_classcount Sum CS_classcount G_conlabel

G_portdesc CS_port_count Sum CS_conlabel_classcount G_portdesc
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Your data model should look similar to the following figure:

9. Save the report as ref_65.rdf.

6.6 Creating a layout
Now that you have a working data model, the steps in this section will help you to 
create a layout.

1. Click  to bring up the Report Wizard.

2. On the Style page, type Pacific Intermodal Leasing as the Title.

3. Click Group Above as the report style.

4. Click Next.

5. On the Groups page, click G_conclass and click Down.

6. Repeat step 5 for:

■ G_container

■ G_conlabel

■ G_portdesc

7. Click Next.

8. On the Fields page, click LOCNAME, and click .
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9. Repeat step 8 for:

■ TITLE

■ DOCKLOC

■ REPNO

■ CLASSID2

■ CCAP

■ GWL

■ TWL

■ HTF

■ HTI

■ NOTES

■ CS_conlabel_classcount

■ CS_port_count

10. Click Next.
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11. On the Labels page, type in the labels and widths as shown in the following 
table:

12. Click Next.

13. On the Template page, click Predefined template, and choose Cyan Grid 
Landscape.

Table 6–4 Labels and widths

Column Label Width

LOCNAME Port of: 15

TITLE Containers 20

DOCKLOC Location 10

REPNO ID 10

CLASSID2 Class 9

CCAP Cu capy 9

GWL Gross wt 9

TWL Tare wt 9

HTF Htf 9

HTI Hti 9

NOTES Notes 15

CS_conlabel_classcount Total available: 8

CS_port_count Total available: 15
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14. Click Finish. The report automatically displays in the Live Previewer: 

15. Save the report as ref_66.rdf.

6.7 Moving the SELECT statement into a package
In your current report configuration, the SELECT statements used by the ref cursor 
queries reside within the report itself. In many cases, it is advantageous to have 
SELECT statements reside in the packages that define the ref cursor types. Then, 
you can simply reference the packages, rather than typing the same SELECT 
statement directly into every report that uses it. If you need to change the SELECT 
statement (for example, to modify or add clauses), you simply update it once in the 
package, rather than in every report that uses it.

The steps in this section will help you to move the SELECT statements to the 
packages that define the ref cursor types.

1. In the Object Navigator, click the Program Units node for your report.

2. Click  to add a program unit.

3. In the New Program Unit dialog box, type cont_cv as the name of the program 
unit.

4. Click Package Body, and click OK.
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5. Type the following code in the editor. New code is displayed in bold:

PACKAGE BODY cont_cv IS
function query_container (p_portid number) return container_refcur is
      tempcv_container cont_cv.container_refcur;
begin
open tempcv_container for select cl.title, c.DOCKLOC, 
                                 c.PORTID, c.REPNO, 
                                 c.STATUS, c.key, 
                                 cl.key key2, c.classid classid2
                      from CONTAINERS c, conlabel cl
                      where cl.key=c.key 
                      and p_portid=c.PORTID
                      order by c.REPNO;
return tempcv_container;
end;
END;

6. Click Compile.

7. If any compilation errors occur, check the code for syntax errors and recompile 
as needed.

8. Click Close.

9. Now that the function is defined, you must add it to the package spec so that it 
can be referenced. Other program units will know about the function in the 
package body only if it is described in the package spec.

In the Object Navigator, double-click the CONT_CV(Package Spec) object.

10. In the Program Unit editor, type the following line above the END; statement:

function query_container (p_portid number) return container_refcur;

11. Click Close.

12. Choose Program->Compile->All. 

13. Click OK when done.

14. In the Object Navigator, double-click the Q_CONTAINERREFCURDS object 
under the Program Units object.
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15. Edit the code to look as follows:

function q_containerRefCurDS return cont_cv.container_refcur is
temp_container cont_cv.container_refcur;
begin
  temp_container:=cont_cv.query_container (:portid);
  return temp_container;
end;

When you are done, all of the query’s logic will reside in the function named 
query_container. From now on, when you change query_container, you will 
change this and any other queries that reference it.

16. Click Compile.

17. If any compilation errors occur, check the code for syntax errors and recompile 
as needed.

18. Click Close.

19. Double-click  to view the report in the Live Previewer.

20. Save the report as ref_67.rdf.

Optional Exercise: 

Repeat steps 1 through 19 for the other two queries in the report.

6.8 Moving the packages into a library
If you have many reports that use these same ref cursor types and SELECT 
statements, you can move the program units that you created into a PL/SQL library 
stored in a file or the database, so that other reports can easily share the code. The 
steps in this section will help you to move the program units to a PL/SQL library.

1. In the Object Navigator, click the PL/SQL Libraries object.

2. Click  to add a new library.

3. Choose File->Save As. 

4. Type PORT_CONTAINER as the Library.

5. Click File System.

6. Click OK.
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7. Drag and drop the following program units from your report to the Program 
Units node under the newly created PORT_CONTAINER library:

■ CONCL_CV(Package Spec)

■ CONT_CV(Package Spec)

■ CONT_CV(Package Body)

■ PORT_CV(Package Spec)

8. Save PORT_CONTAINER.

9. If the Live Previewer is open, close it.

10. In the Object Navigator, under the Program Units node of your report, delete 
CONCL_CV(Package Spec), CONT_CV(Package Spec), CONT_CV(Package 
Body), and PORT_CV(Package Spec).

Tip: If the Live Previewer is open when you delete the packages from the 
report, you may get some errors.

11. Click the Attached Libraries node for your report.

12. Click  to add a new attached library.

13. In the Attach Library dialog box, click File System.

14. Click Browse to find the PORT_CONTAINER library. It will have a .PLL file 
extension. After you have found and selected PORT_CONTAINER, click Open.

15. Click Attach.

16. Choose Program->Compile->All.

17. Click OK to close the Compile window.

18. Double-click  to view the report.

Tip: If you get an error when you attempt to view the report, repeat steps 16 
through 18.

19. Save the report as ref_68.rdf.

Optional Exercise: 

Store the PL/SQL library in the database rather than in a file. Note that you will 
need “create” privileges on the database to complete this optional exercise.
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6.9 Summary
Congratulations! You have finished the Ref Cursor Query sample report. You now 
know how to:

■ Create package specs that define ref cursors.

■ Create ref cursor queries.

■ Create data links between ref cursor queries.

■ Create summaries to describe data.

■ Create a report layout.

■ Move SELECT statements into packages. 

■ Move packages into a PL/SQL library.

For more information about using ref cursors, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
ref cursor, about

3. Then click Display to view help topic... 
About ref cursor queries
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7

Building a Report Using Express Data

The report described in this chapter is designed to help you learn more about the 
Report Builder features for Express data. You will build an Express report that 
summarizes the yearly projected and actual sales for each region and sales channel 
in a product division.

To build this report, you will use the Report Wizard to create the initial data model 
and report layout. You will make refinements to the data model and to the Express 
query. Finally, you will enhance the look of the report in the Layout Model view and 
Live Previewer. 

About Express Express delivers on-line analytical processing (OLAP) using a 
multidimensional data model. This model is optimized for the analysis of trends or 
patterns of intersecting corporate data — such as sales, marketing, or financial 
variables.

The figure on the next page illustrates the 1997 Sales report that you will build. 
Think of the data you wish to extract as being contained in the volume of a cube. 
Each side of the cube is a list of variable data contained in a category (i.e.,  Product). 
This category and its list of values together is called a dimension. You will select 
portions of each dimension and analyze them for their interaction with other 
dimensions. This analysis is called a measure.

An example measure for a sales analysis might select data from dimensions for 
time, product, geographic division, and channel. With Express, you can create a 
query to report on information that is as broad (e.g., yearly direct and indirect sales 
for products sold everywhere) or as narrow (e.g., monthly direct sales for all 
televisions sold in California) as you like.

Table 7–1, "Features demonstrated in this sample report of Express data" describes 
the steps you will take to create this report.
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The xprs.rdf file contains the report that you will create after finishing the tasks in 
this chapter. You may want to refer to this file while you are working. This file is 
located in your ORACLE _HOME\TOOLS\DOC60\US\RBBR60 directory.

Before you start building this Express report, you must have already configured 
Report Builder to run with Express Server, R6.2 and Oracle8 Server for Windows 
NT with Object Option, R8.0.5, or later. Refer to the Getting Started manual for more 
information on how to do this.

To get started, open Report Builder. If the Welcome dialog box appears, click Use 
the Report Wizard and click OK. If not, choose File->New->Report. Click Use the 
Report Wizard and click OK.

At some point before you generate the report you will need to log on to the Oracle8 
database. Choose File->Connect to connect to the database. Enter the appropriate 
logon information. See Section 1.3, "Obtaining database access before you start" for 
details. 

In addition, you will at some point also need to connect to Express Server. Choose 
File->Express

Table 7–1 Features demonstrated in this sample report of Express data

Feature Location

Use the Report Wizard to define the Express 
query and create a first draft of the report.

Section 7.1, "Creating an Express report with 
the Report Wizard"

Streamline the Express query by specifying 
dimension values.

Section 7.2, "Refining the Express query"

Add summary and calculated totals using 
the Data Model view.

Section 7.3, "Adding summary columns and 
custom measures to your data model"

Add summary and calculated totals to the 
report layout. Enhance the look of the report.

Section 7.4, "Enhancing the report layout"
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7.1 Creating an Express report with the Report Wizard
The Report Wizard is a great way to start building a report. The Report Wizard 
alone may give you an Express report that satisfies your requirements. If it doesn’t, 
you can use the Data Model view, the Live Previewer, and the Layout Model view 
to further refine your report. For this report, you will start with the Report Wizard. 
The steps in this section will help you to create the initial report.

The report that you create in this exercise will present the monthly regional and 
channel projected and actual sales for each product division. Your Express query 
will have two measures, and each measure will be dimensioned by product, time, 
geographic area, and channel.

1. If the Welcome page of the Report Wizard appears, click Next.

2. On the Style page, type Sales Report as the Title, and click Matrix with Group 
as the report style.

Tip: If you are unsure about what to do on any page of the wizard, click Help.

3. Click Next.

4. On the Type page, click Express query, and click Next. If the Type page does not 
appear, ensure that you have properly configured the Report Builder to run 
with Express data.

5. On the Data page, click Express Query.

Tip: If you haven’t already connected to Express Server, the Connect dialog box 
appears. Choose the Express Server instance that you want to access. Click OK.

6. In the Express Query dialog box, click Attach Database to choose the path and 
name of the database that you want to attach to your session.

7. In the Attach Database dialog box, select the directory labeled /oec62/. Select 
xademo.db. This is the sample database that is provided with Express Server.

8. Click Open to attach the database to your session.

9. In the Express Query dialog box, CTRL-click to select Sales and Projected Sales 
from the Available Measures list.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
report wizard, about

3. Then click Display to view help topic... 
Report Wizard: Welcome page
7-152 Oracle Reports: Building Reports



Creating an Express report with the Report Wizard
10. Click  to move Sales and Projected Sales to the Selected Measures list box. 
The Express Query dialog will look similar to the one below:

11. Click OK to accept the Express query selections. You will return to the dialog 
box in a later step to refine the dimension values that are associated with the 
Sales and Projected Sales measures.

12. On the Data page, click Next.

Tip: If you haven’t already connected to an Oracle8 database, the Connect 
dialog box appears. Enter a User Name, Password, and Database. Click OK.

13. On the Groups page, select PRODUCT in the Available Fields list box and click 
 to move this field to the Matrix Group Fields list box.

14. Repeat this step for TIME so that the Matrix Group Fields box appears as 
follows:
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15. Click Next.

16. On the Rows page, click GEOG_AREA.

17. Click .

18. Click Next.

19. On the Columns page, click CHANNEL in the Available Fields list box.

20. Click .

21. Click Next.

22. On the Cells page, select PROJECTED SALES in the Available Fields list box 
and click  to move this field to the Matrix Cell Fields list box.

23. Repeat this step for SALES.

24. On the Totals page, click Next. You will add summary totals in a later step.

25. On the Labels page, change the following labels and widths:

Tip: You will change the width of labels at this point because in a later step you 
will add a new layout column. This will cause columns to wrap to the next page 
at their current default width of 10 points each.

26. On the Template page, click Predefined template if it is not already selected, 
and click Cyan Grid Landscape in the list box.

27. Click Finish. The report output automatically displays in the Live Previewer 
and should look similar to the following figure. 

Table 7–2 Labels

Field Label Width

SALES Actual Sales 7

PROJECTED_SALES Projected Sales 7

GEOG_AREA Region 10

PRODUCT Product: 10

TIME Time: 10

CHANNEL Channel 7
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28. Choose File->Save As. Save the report in the directory of your choice, and 
name the report xprs_710.rdf.

Tip: It is good practice when you are designing your report to save it frequently 
under a different file name. If you generate an error or if you don’t like some of 
the changes that you made, you easily can go back to the previously saved file 
and make revisions from that point.
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7.2 Refining the Express query
The steps in this section will help you refine the Express query. So far you have 
developed a useful report that shows the monthly projected and actual sales for 
each region and channel in a product category. But you are really interested in the 
yearly projected and actual sales results for each channel and region in a product 
division. You can achieve this by restricting the dimension values that you want to 
view.

In this exercise, you will specify the following dimension values in the Express 
Query dialog box:

■ projected and actual sales for 1997

■ geographic regions, such as Asia and the Americas

■ product divisions, such as the Accessory and Audio division

1. In the Live Previewer, choose Tools->Report Wizard. 

2. On the Data page, click Express Query.

3. In the Express Query dialog box, click Selector.

4. In the Selector dialog box, click Time Period from the Dimensions option. 

5. Click  to select the List tool from the toolbar.

6. In the List dialog box, choose 1997 from the Available Time Periods list box.

7. Click Select. Notice that 1997 replaces the previous selections.

8. Click OK.

9. In the Selector dialog box, click Geographical Area from the Dimensions 
option.

10. Click  to select the Level tool from the toolbar.

11. In the Select by Level dialog box, choose Continents/Regions in the At level(s) 
list box.

12. Click OK.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
selecting data

3. In the Topics Found dialog box, select...
selecting data.

4. Then click Display to view help topic... 
Selecting data
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13. In the Selector dialog box, click Product from the Dimensions option.

14. Click .

15. In the Select by Level dialog box, choose Divisions in the At level(s) list box.

16. Click OK.

17. In the Selector dialog box, click OK.

18. In the Express Query dialog box, click OK.

19. On the Groups page, click TIME in the Matrix Groups Fields list box. Note that 
using TIME as a break group is no longer necessary since the Express query will 
retrieve only aggregate data for 1997.

20. Click . PRODUCT should be the only dimension that is listed in the 
Matrix Group Fields list box.

21. On the Style page, change the title to 1997 Sales Report.

22. Click Finish. Your report should look similar to the following figure:

23. Save the report as xprs_720.rdf.

24. If you want, compare this report with the one that you previously saved as 
xprs_710.rdf. 
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Notice the projected and actual sales. In the new report, each cell represents the 
yearly sales for a region and channel in a product division for 1997, while the 
previous report displays sales data for a region and channel in a  product 
division for each month.

7.3 Adding summary columns and custom measures to your data 
model

The steps in this section will help your refine the data model to include summary 
totals for each channel in a product division. Additionally, you are curious about 
how accurately you predicted the actual sales. You can find this out by creating a 
custom measure that calculates the percent of sales above projected sales.

First, you will create the summary column using the Summary tool in the Data 
Model view.

Next, you will create the custom measure using the Custom Measure tool in the 
Express Query dialog box.
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Before you begin, take a look at the data model:

In the Data Model view you may notice additional columns, such as
S_GEOG_AREA, or S_CHANNEL. These are dimension sorting columns. They are 
visible only in the data model and are the index used to sort dimensions by logical 
order, as opposed to alpha-numeric order. If you move a column to a new group, 
you must also move the associated sort column into that group as well.

In a later step, you will sort dimension values using the Sort tool in the Express 
Query dialog box.

1. For online help on this task, choose Help->Report Builder Help Topics

2. On the Index page, type...
dimension sorting

3. In the Topics Found dialog box, select...
new feature

4. Then click Display to view help topic... 
Dimension sorting
Building a Report Using Express Data 7-159



Adding summary columns and custom measures to your data model
7.3.1 Renaming data objects
1. In the Object Navigator, double-click  under your report’s node if you are 

not already viewing the Data Model view. 

2. Click QE_1.

3. Select Tools->Property Palette.

Tip:  If you want to modify your Express query, click the Express Query 
property under the Query node.

4. Under the General Information node, change the Name property to QE_
SALES.

5. Press Enter or click outside of the property to accept the value. Close the 
Property Palette.

6. Repeat steps 2 through 5 and change the Name property of the G_PROJECTED 
SALES group to G_SALES_DATA.

7. Save your report as xprs_731.rdf.

7.3.2 Creating summary columns
In this exercise, you will add two summary columns to the G_Cross group. Each 
summary column will calculate the projected and actual sales totals for each 
channel (all channels, direct, and indirect) in a product division.

1. In the Data Model view, click , then click the G_Cross group.

2. Select Tools->Property Palette.

3. Set the following properties for projected sales:

4. Press Enter or click outside of the property to accept the value. Close the 
Property Palette.

Table 7–3 Summary Column properties for Projected Sales

Node Property Value

General Information Name CS_PjSalesPerChannel

Column Product Order G_CHANNEL

Summary Source PROJECTED_SALES

Reset At G_CHANNEL
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5. Repeat steps 1 through 4 to create a summary column for actual sales. Set the 
following properties:

6. Save your report as xprs_732.rdf.

7.3.3 Creating a custom measure
In this exercise, you will create a custom measure that will calculate the percent of 
actual sales above projected sales for each region and in each product division. To 
do this you will use the Custom Measure tool within the Express Query dialog box 
to build the new measure called Increase.

1. In the Data Model view, double-click the QE_Sales query object to open the 
Express Query dialog box.

2. Click Custom Measure at the bottom of the Express Query dialog box.

3. Click New... to open the Custom Measure — New dialog box.

4. In the Name box type INCREASE.

5. In the Description box type Increase.

6. Click Template under Operators in the Category box. Notice a list of templates 
appears under Choices. 

7. Select the left parenthesis and then click Insert. A left parenthesis appears in the 
Expression box.

8. Click Measures under Express Objects in the Category box. 

9. Select F.SALES and then click Insert.

Table 7–4 Summary Column properties for Actual Sales

Node Property Value

General Information Name CS_SalesPerChannel

Column Product Order G_CHANNEL

Summary Source SALES

Reset At G_CHANNEL
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10. Use the following table to build the expression:

11. Following the asterisk, type 100 in the Expression box.

12. When you are finished, your expression should look like the following figure:
 

Table 7–5 Categories and Choices for custom measure Increase

Category Sub-category Choose or Type:

Operators Numeric Minus Sign -

Express Objects Measures F.WHATIF F.WHATIF

Operators Template Right parenthesis )

Operators Numeric Forward slash /

Express Objects Measures F.WHATIF F.WHATIF

Operators Numeric asterisk *
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13. Click OK. Note that Increase is listed in the Custom Measures text box in the 
Custom Measures dialog box. 

14. Click Close.

15. In the Express Query dialog box, scroll through the Available Measures box. 
Increase now appears alphabetically. Click Increase and then click . 
Increase appears in the Selected Measures box, below Projected Sales and 
Sales.

16. Click OK to return to the Data Model. The group G_SALES_DATA now 
includes the custom measure you just created, INCREASE.

17. Click  to view the report in Live Previewer. Note that neither the summary 
columns nor the custom measure are available in the report. This occurred 
because you have not yet added them as fields to the report layout. You will do 
this in the next few exercises.

18. Save your report as xprs_733.rdf.

7.4 Enhancing the report layout
The steps in this section will show you how to re-arrange the report layout, add the 
summary and custom measure columns that you created in Section 7.2, "Refining 
the Express query", and format objects to further enhance the look of your report. 
You make these changes using the Layout Model view and Live Previewer.

7.4.1 Inserting summary fields in the report
1. In the Object Navigator, double-click  under your report’s node to display 

the Layout Model view.

2. Arrange your workspace to display the Object Navigator and the Layout Model 
view side-by-side. Expand the Layout Model, Main Section, Body, and the 
remaining nested nodes, such as the MG_PRODUCT_GRPFR and R_G_
PRODUCT nodes. Your workspace should look similar to the following figure:
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3. In the Object Navigator, type M_G_CROSS_GRPFR in the Find field to locate this 
object. Note that the search occurs as you type, so you will most likely be taken 
to the object before you finish typing the entire name. In the Layout Model 
view, the master cross-matrix frame is selected as illustrated in the following 
figure:

4. Extend the selected frame down about 1/4 inch as illustrated in the following 
figure:

5. Click F_CHANNEL in the Object Navigator.
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6. Click  to select the parent frame, R_G_CHANNEL, as illustrated in the 
following figure:

Tip: You may need to resize your Layout Model window to see the  button, 
as it is located on the far right of the toolbar.

7. Extend the frame down about 1/4 inch as illustrated in the following figure:
 

8. Click .

9. Click and drag a rectangle in the area directly under the F_PROJECTED_SALES 
field to insert a field object as follows:

10. Tools->Property Palette.

11. Set the following properties:

Table 7–6 Projected Sales per Channel field properties

Node Property Value

General Information Name F_PjSalesPerChannel

Field Source CS_PjSalesPerChannel
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12. Arrange this field and change the format as follows:

■ Click  to change fill color to light yellow.

■ Click  to change the text color to dark brown.

■ Click  to surround the field with dark brown border lines.

Tip:  You can turn Snap to Grid on or off as desired to help you arrange objects 
in the layout. Select View->Snap to Grid. A check mark indicates that the 
option is on.

13. Repeat steps 8 through 11 except place the new object directly under F_SALES. 
Set the following properties:

Tip: Note that the fill and text colors, as well as the border lines, match the field 
you just created, F_PjSalesPerChannel.

14. Click .

15. Click and drag a rectangle to fill the space directly under F_GEO_AREA.

16. Type Totals:.

17. Align the text object to center by clicking  and make format changes to 
match the summary fields you created. 

Table 7–7 Sales per Channel field properties

Node Property Value

General Information Name F_SalesPerChannel

Field Source CS_SalesPerChannel
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18. Click  to view the changes in the Live Previewer. Your report should look 
similar to the one displayed here:

19. Save the report as xprs_741.rdf.

7.4.2 Inserting the custom measure field into the report
You will add a column to display the custom measure you created in Section 7.3.3, 
"Creating a custom measure" by inserting a field object in the report layout.

To do this, you will add a new column to the layout of your report and then insert 
the field object into the column.

Tip: The new field object also must have the same frequency as F_PROJECTED_
SALES and F_SALES. If the field object is not at the same frequency, the report will 
fail to run. 

1. In Live Previewer, click  to display the Layout Model view. Ensure that the 
Layout Model view and Object Navigator are placed side-by-side.

2. In the Object Navigator, Ctrl-click M_G_PRODUCT_GRPFR and R_G_
PRODUCT.

Tip: M_G_PRODUCT_GRPFR is the underlying master group. It is hidden 
directly under R_G_PRODUCT. In the Layout Model view, it may look like only 
one group is selected when, in fact, both frames are selected.
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3. In the Layout Model, expand the width of the selected frames to about 4 3/4 
inches.

Tip: Click  to turn Flex mode on, or click  to turn Flex mode off if you 
are unable to resize or move an object.

4. In the Object Navigator, click M_G_CROSS_GRPFR.

5. In the Layout Model, expand the width of the selected frame to about 4 3/4 
inches. It should look similar to the figure below:

6. Click the F_GEOG_AREA object, then click  to select the parent frame, R_
G_GEOG_AREA:

7. Expand the width of the selected frame to about 4 3/4 inches.

8. Click F_CHANNEL and click  to select the parent frame, R_G_CHANNEL.

9. Expand the width of the selected frame to about 4 3/4 inches:

10. Click F_CHANNEL again and expand the width of the object to about 4 3/4 
inches:
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11. Click .

12. Click and drag a box to the right of the F_SALES object. It should look similar to 
the figure below:

13. Tools->Property Palette.

14. Set the following properties:

15. Click  to run the report. You should see an error indicating that F_Increase 
references INCREASE at a frequency below its group. You are unable to run 
your report. 

To understand why this error occurred, look for F_INCREASE in the Object 
Navigator. It is probably placed at a higher level (and lower frequency) than R_
G_PROJECTED_SALES. Recall that the column INCREASE calculates the 
percent of actual sales above projected sales. In order to run this report, F_
INCREASE must have the same frequency as F_PROJECTED_SALES and F_
SALES to reference the data it needs to calculate the value. 

16. Click OK to close the error message.

17. Click  to display the Layout Model view.

18. Select the field F_INCREASE and delete it.

19. Click F_SALES and then click  to select the parent frame, R_G_
PROJECTED_SALES.

Table 7–8 Increase field properties

Node Property Value

General Information Name F_Increase

Field Source INCREASE
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20. Expand the width of the selected frame to about 4 3/4 inches:

21. Repeat steps 11 through 14 to create the field object. Your layout model should 
resemble the following figure:

22. With the F_Increase object selected, locate F_INCREASE in the Object Navigator 
to ensure that it has the same frequency as F_PROJECTED_SALES and F_
SALES. The Object Navigator should look similar to the figure below:
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23. Change the format of the F_Increase field as follows:

■ Click  to change fill color to light yellow.

■ Click  to change the text color to dark brown.

■ Click  to surround the field with dark brown border lines.

■ Click  to make the text darker and more noticeable.

24. Click .

25. Click and drag a rectangle above F_Increase to add the column title.

26. Type Increase.

27. Arrange the text object in the column and change the format to match the field 
to its left, Actual Sales.

Tip: You may wish to turn off Snap to Grid on the View pull-down menu in 
order to extend the text object to cover the entire field. Make sure the text object 
is selected when you apply formatting, or it will not take effect.

Your layout model should resemble the following image:
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28. Click . The report should look similar to the figure below:

29. Save the report as xprs_742.rdf.
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7.4.3 Sorting dimension values
Suppose you wish to change the sorting order of the distribution channels in your 
report. In this exercise, you will change the sorting criteria for the Channel 
dimension by using the Selector in the Express Query dialog box. Instead of listing 
the order by the default channel hierarchy (top to bottom), you will display data 
from the lowest to the highest channel in the hierarchy. Note: the hierarchy is 
predefined in the database to place "All Channels" first, with "Indirect" placed last.

1. In the Data Model view, double-click the query object, QE_SALES. 

2. Click Selector in the Express Query dialog box.

3. In the Dimensions list, select Distribution Channel and then click  .

4. In the Sort Selection dialog box, choose the following values:

5. Click OK in the Sort Selection dialog box.

6. Click OK in the Selector dialog box.

7. Click OK in the Express Query dialog box. 

8. Click . The report should look similar to the figure below. Note that Indirect 
is first while All Channels is last in the order:

Table 7–9 Sort Selections

Criteria Selection

based on hierarchy

in order bottom to top

in hierarchy Standard
Building a Report Using Express Data 7-173



Enhancing the report layout
9. Save the report as xprs_743.rdf.

7.4.4  Making format changes in Live Previewer
1. In Live Previewer, shift-click the columns under Projected Sales and Actual 

Sales, and the Projected Sales total and the Sales total fields.

2. Click  to change the format mask to currency.

3. Click  to right justify the values.

4. Click  twice to insert two decimal places 

5. Click the column under Increase.

6. Click  to change the format mask to percentage.

7. Click  to center the values.

8. The report should now look similar to the figure below:

9. Save the report as xprs_744.rdf.
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7.5 Summary
Congratulations! You have finished the Express sample report. You now know 
how to:

■ Use the Report Wizard to define a data model and layout.

■ Make changes to the Express query by restricting the dimension values.

■ Use the Data Model view to add summary and custom measures columns to the 
report.

■ Use the Layout Model view to insert fields and re-arrange the layout.

■ Use the Live Previewer to enhance the look of the report. 

For more information about Express, see the online help:

1. For online help on this topic, choose Help->Report Builder Help Topics

2. On the Index page, type...
Express, working with

3. Then click Display to view help topic... 
Working with Express
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