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Preface

This manual describes the implementation and administration of Oracle Quality 
Online  software 11i.

Topics include:

� Intended Audience

� Related Documentation and Training

� Recommended Browser

� Documentation Accessibility

� Do Not Use Database Tools to Modify Oracle Applications Data

� About Oracle

Intended Audience
This guide is aimed at the following users:

� Technical Service Representatives (TSR)

� Customer Service Representatives (CSR)

� System Administrators,  Database Administrators (DBA), DEMS 
Administrators, and other IT professionals who are responsible for 
implementing and maintaining Oracle Quality Online. 

This guide assumes you have the following prerequisites: 

� Understanding of the company business processes.

� Knowledge of products and services as defined by your marketing policies.
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� Basic understanding of Oracle applications and Developer/2000.

� Basic understanding of SQL, PL/SQL, SQL* Plus programming.

Related Documentation and Training
Oracle Quality Online shares business and setup information with other Oracle 
Applications products. Therefore, you may want to refer to other user guides when 
you set up and use Oracle Quality Online. You can read the guides online by 
choosing Library from the expandable menu on your HTML help window, by 
reading from the Oracle Applications Document Library CD included in your 
media pack, or by using a Web browser with the following URL: 
http://docs.oracle.com. A list of suggested guides follows: 

Customer Relationship Management (CRM) Foundation
� Oracle CRM Foundation Implementation Guide Release 11i

� Oracle CRM Foundation Concepts and Procedures Release 11i

� Oracle CRM Technology Foundation Implementation Guide, Release 11i

� Oracle CRM Technology Foundation Concepts and Procedures, Release 11i

� Implementing Oracle CRM: ERP Functional Checklist Release 11i

� Implementing Oracle CRM: Foundation Functional Checklist Release 11i

� Implementing CRM Applications Release 11i

� Oracle Marketing Encyclopedia System Release 11i

� Installing Oracle Applications Release 11i

� Oracle Applications Concepts Release 11i

� Oracle Applications System Administrator’s Guide

� Supplemental CRM Installation Steps Release 11.5.1-11.5.3 

Enterprise Resource Planning (ERP)
� Implementing Oracle HRMS Release 11i

� Oracle Inventory User’s Guide Release 11i

� Oracle Bills of Material User’s Guide Release 11i

� Oracle Receivables User Guide Release 11i
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Oracle Service Request
� Oracle Support Concepts and Procedures Release 11i

� Oracle Support Implementation Guide Release 11i

Training and Support

Training
Oracle offers training courses to help you and your staff master Oracle Quality 
Online and reach full productivity quickly. You have a choice of educational 
environments. You can attend courses offered by Oracle University at any one of 
our many Education Centers, you can arrange for our trainers to teach at your 
facility, or you can use Oracle Learning Network (OLN), Oracle University’s online 
education utility. In addition, Oracle training professionals can tailor standard 
courses or develop custom courses to meet your needs. For example, you may want 
to use your organization’s structure, terminology, and data as examples in a 
customized training session delivered at your own facility.

Support
From on-site support to central support, our team of experienced professionals 
provides the help and information you need to keep Oracle Quality Online working 
for you. This team includes your Technical Representative, Account Manager, and 
Oracle’s large staff of consultants and support specialists with expertise in your 
business area, managing an Oracle8i server, and your hardware and software 
environment.

OracleMetaLink
OracleMetaLink is your self-service support connection with web, telephone menu, 
and e-mail alternatives. Oracle supplies these technologies for your convenience, 
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain 
information and advice from technical libraries and forums, download patches, 
download the latest documentation, look at bug details, and create or update TARs. 
To use MetaLink, register at (http://metalink.oracle.com).

Alerts: You should check OracleMetaLink alerts before you begin to install or 
upgrade any of your Oracle Applications. Navigate to the Alerts page as follows: 
Technical Libraries/ERP Applications/Applications Installation and 
Upgrade/Alerts.
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Self-Service Toolkit: You may also find information by navigating to the 
Self-Service Toolkit page as follows: Technical Libraries/ERP 
Applications/Applications Installation and Upgrade.

Recommended Browser
Oracle recommends the use of Microsoft Internet Explorer 5.5 or later for use with 
its CRM applications.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle Corporation is actively engaged with other 
market-leading technology vendors to address technical obstacles so that our 
documentation can be accessible to all of our customers. For additional information, 
visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
JAWS, a Windows screen reader, may not always correctly read the Java and 
SQL*Plus code examples in this document. The conventions for writing Java and 
SQL*Plus code require that closing braces should appear on an otherwise empty 
line; however, JAWS may not always read a line of text that consists solely of a 
bracket or brace.

Accessibility of Links to External Web Sites in Documentation 
This documentation may contain links to Web sites of other companies or 
organizations that Oracle Corporation does not own or control. Oracle Corporation 
neither evaluates nor makes any representations regarding the accessibility of these 
Web sites. 
xii                                                                                          



Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
Browser, database triggers, or any other tool to modify Oracle Applications data 
unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of 
your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using 
Oracle Applications can update many tables at once. But when you modify Oracle 
Applications data using anything other than Oracle Applications, you may change a 
row in one table without making corresponding changes in related tables. If your 
tables get out of synchronization with each other, you risk retrieving erroneous 
information and you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications 
automatically checks that your changes are valid. Oracle Applications also keeps 
track of who changes information. If you enter information into database tables 
using database tools, you may store invalid information. You also lose the ability to 
track who has changed your information because SQL*Plus and other database 
tools do not keep a record of changes.

About Oracle
Oracle Corporation develops and markets an integrated line of software products 
for database management, applications development, decision support, and office 
automation, as well as Oracle Applications, an integrated suite of more than 160 
software modules for financial management, supply chain management, 
manufacturing, project systems, human resources and customer relationship 
management.

Oracle products are available for mainframes, minicomputers, personal computers, 
network computers and personal digital assistants, allowing organizations to 
integrate different computers, different operating systems, different networks, and 
even different database management systems, into a single, unified computing and 
information resource.

Oracle is the world’s leading supplier of software for information management, and 
the world’s second largest software company. Oracle offers its database, tools, and 
applications products, along with related consulting, education, and support 
services, in over 145 countries around the world.
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Oracle Quality Online Introduction

This chapter provides an overview of the features and benefits of Oracle Quality 
Online.  Topics include:

� Oracle Quality Online Overview

� Key Terms and Functionality

� New in this Release

1.1 Oracle Quality Online Overview
Oracle Quality Online is a comprehensive, web based product that allows 
companies to manage the internal application development process by tracking 
product defects and enhancements. Defects are primarily identified by customer 
support representatives, developers, and/or quality assurance engineers. Allowing 
users to log new and review existing enhancement requests, the company gathers 
strategic information for user oriented functionality that helps them remain 
competitive.

Key features and benefits of Oracle Quality Online include the following:

� Configurable process management: Organizations can configure the software to 
mirror their own defect and enhancement management processes. 

� Build better products: Product quality metrics are classified, gathered, and 
reported within defects, and functional suggestions are tracked within 
enhancements. 

� Flexible prioritization: Each organization can configure prioritization criteria to 
ensure compliance with their service level goals. 
uction 1-1



Key Terms and Functionality
� Close the service process loop: Organizations can achieve high levels of 
efficiency through the integration of their defect management process with 
other products in the Oracle CRM suite. 

� Personalization: A powerful search and save mechanism allows users to create 
saved searches, saved creates, and saved reports that provide relevant 
information on demand. 

Please see Appendix C Territory Setup for sample defect and enhancement flows for 
Oracle Quality Online.

1.2 Key Terms and Functionality
 The following table contains the Oracle Quality Online Key Terms and definitions.

Term Definition

Alerts Alerts are optional short messages about scheduled outages or 
system issues sent from the system administrator. The Alerts 
bin is viewable from the Homepage.

Base Defect/Enhancement When there are dependencies between defects and 
enhancements, a Base link is created to show the dependency. 
This is important for understanding the order in which defects 
must be handled. The link is visible on the Tree hyperlink on 
the Defect or Enhancement Details page.

Category There are two Categories in Oracle Quality Online, Defects and 
Enhancements.

Defect Defects are logged when errors, unexpected behavior, or any 
other issues are found that require development intervention.

Defect/Enhancement 
Owner

In most cases, the user responsible for the Defect or 
Enhancement at a specific phase. Ownership can be assigned 
automatically or manually.

Enhancement Enhancement are requests to add new functionality.

Environment Variables Environment Variables are used for tracking additional, 
user-defined environment information such as database 
version, browser version, etc.

Escalation Escalations provide the means to identify, track, monitor, and 
manage situations requiring increased awareness and 
immediate action.
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Key Terms and Functionality
Homepage The Homepage is the application’s landing page. The 
Homepage provides an overview of work assigned to 
individuals and/or groups, alerts and information about the 
system, and quick navigation to other key areas of the 
application.

Key Audits/Audits Records showing who has accessed Oracle Quality Online, and 
what operations they have performed. Key Audits are a subset 
of Audits, hard coded in Oracle Quality Online, available in 
Notes Display Options. 

Lifecycle In Oracle Quality Online, the product lifecycle stages are used 
with product versions to further refine the defect definition. 
Seeded Lifecycle stages are Alpha, Beta, Development, and 
Production. They appear in the Product Status drop down list 
in Defect Details.

Link Type Link Types in Oracle Quality Online reflect relationships 
between objects. Link Types are configurable and allow 
relationship definitions to include dependencies.

List of Values (LOV) The LOV is the list of choices that appears when you click Go 
next to a text box. The Go button indicates that the user must 
choose from the associated, predefined list. The LOV differs 
from a drop down box, which displays a limited selection of 
data while the LOV is more extensive. 

Note Templates Configurable templates are designed to guide users in the 
creation of Defects and Enhancements through a sequence of 
questions. Questions and responses are saved in Note format. 
Templates are configurable and are displayed based on usage

Note Token Note Tokens allow any text, e.g. http://, bug 123, patch 123, to be 
hyperlinked according to specific rules . Users often type 
references directly into note text. Setting hyperlinks in the text 
provides future users with an easy way to navigate directly to 
these references.

Notification Users can request email notification at key points in the Defect 
and Enhancement management process, for example, when the 
Status or Phase of a Defect changes or when a Defect is closed. 

Phase Configurable phases are intended to reflect the business 
process steps for handling defects and enhancements and 
tracking progress from one stage to another. If desired, 
changing the phase can trigger assignment to the team or 
individual responsible for the next phase. 

Phase Status Each phase may go through many states, and the phase status 
reflects the current state of this phase.

Term Definition
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Key Terms and Functionality
Primary Contact The Primary Contact is the filer or the designated liaison for 
the filer, responsible for problem definition and 
communication. The Primary Contact may default to the user 
logging a defect or may be manually assigned at creation. 
There is only one Primary Contact. All other contacts are 
displayed on the Notifications tab.

Profile An ongoing, individual administrative function for setting up 
and maintaining personal user roles, responsibilities, and 
information.

Quick Create Quick Creates are user profiles, set up for frequently recurring 
criteria, e.g. product, platform, version, etc.These speed up the 
creation of defects and enhancements by providing relevant 
default information automatically. 

Resolution/Closure Times Resolution Times allows organizations to define the levels of 
service required to complete the defect lifecycle.

Resource Group A Resource Group in Oracle Quality Online is used for 
assignment to a virtual entity.

Source Files Files that were modified during the defect management 
process.

Tasks Tasks are a basic unit of work within Oracle Quality Online, 
and contain information relating to assigned activities. Tasks 
can be used for activities that are pertinent to  defects and 
enhancement but whose details do not add to the resolution of, 
or knowledge within, the defect or enhancement. For example, 
a request to check documentation, or a note to follow up with 
someone else.

Templates Configurable templates are designed to guide users in the 
creation of Defects and Enhancements through a sequence of 
questions. Questions and responses are saved in note format. 
Templates are configurable and are displayed based on usage.

Territory Configurable Territories consist of qualifiers and their values. 
The Territory Qualifiers (see below) determine the automatic 
assignment of defects and enhancements. For enhancements, 
Territories may be mapped to the product management 
organization. Territories and their associated Qualifiers are 
application specific.

Term Definition
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New in this Release
1.3 New in this Release
Oracle Quality Online contains the following new functionality in this release.

� Customer search by name and number: Users are able to enter and search by 
either the customer name or number in the Create Defect, Defect Details, Quick 
Create, and Advanced Search screens. Additionally, Customer Name and 
Number can be entered in the main user fields.

� Group workload management:  There are two additional key summary views, 
Open Defects my Groups Own and Open Enhancements my Groups Own.         
This allows resources to see the number of open defects and enhancements 
assigned to their group(s). Also, the key summary views Defects with Open          
Tasks I Own, and Enhancements with Open Tasks I Own  have been changed to 
Defects with My Open Tasks and Enhancements with My Open Tasks, 
respectively. The new summary view lists all the defects. enhancements that 
have an Open Task for which the person logged in is the owner or the        
assignee. 

Territory Qualifiers Qualifiers are the criteria used to delineate a territory. There are 
two types of qualifiers: transaction qualifiers and resource 
qualifiers. Use transaction qualifiers to specify how the 
territory module assigns transactions. This includes accounts, 
leads, opportunities, and service requests. Examples of 
transaction qualifiers include: customer name, postal code, 
state, and product interest. Resource qualifiers specify what 
attributes are used to select the individuals responsible for 
those transactions. Examples include job title, competence, and 
language.

Territory Type Use territory types to group transaction qualifiers used for 
creating territories. This saves you time when you are creating 
similar territories. Suppose you want to create territories by 
geographical area. In this case you can create a territory type 
with the Country and Postal Code qualifiers.

Tracking Groups Configurable list of group specific keywords. For example, if 
the User Interface group needs to report on the types of UI 
exceptions, a UI Tracking Group can be created.

Type A configurable list that classifies the defect or enhancement. 
Examples are Performance, User Interface, and Translation. 
Type can be used to determine phase and template usage. 
Types are also useful for reporting purposes. 

Term Definition
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New in this Release
� Standardized assignment rules: Assignment has been standardized to make 
automatic and manual assignment the same, based on the following rules:

� Defect owner must have the Defect and Enhancement Owner role assigned.

� Primary Contact must have the Defect and Enhancement Primary Contact 
role assigned.

� Any individual, group, or team, identified as a resource, may be assigned as 
a notification contact.

� Expanded default views: Users are able to set default note detail viewing level 
when opening a defect or enhancement.

� Advanced Search Improvements: 

� Context-enabled keyword search functionality added for enhancements. 
Also, the ability to search by Service Request, Escalation or Task Number.

� The ability in  both Advanced Search and Reports to search on component 
and subcomponent without specifying a product. 

� Hyperlinks in Notes:  Extended hyperlink functionality has been added to 
improve usability. Users are able to define what should be parsed and rendered 
as a hyperlink in Note Details. 

� Associate external objects to defects and enhancements:  Third party objects, 
such as patches, external service requests or any other object can be associated 
with defects or enhancements.

� Option to make Phase Status mandatory:  Organizations can make phase 
status optional or mandatory for both open and closed defects and 
enhancements.

� Resolution Time for Enhancements has been removed.

� Setup Changes:

� Assigning JTF Roles to Each User can now be done using the System 
Administrator Console.

� Creating Task Contact Types has been deleted since this is no longer 
necessary in Oracle Quality Online

� Setting up Alerts: the steps for administering and sending alerts has 
changed. 

� Please note the following: 
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New in this Release
� There have been some changes to the Oracle Customer Relationship 
Management (CRM) Foundation modules. Please see the most current  
CRM Foundation documentation listed in the Preface of this guide.

� Please review Chapter 6: Profile Options and Concurrent Programs, and 
Appendix A: User Permissions for updated profile and permission 
information.
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                                                         Technology, Requirements, and Perform
2

Technology, Requirements, and

Performance

This chapter covers:

� Architectural Overview

� Minimum Hardware Requirements

� Minimum Software Requirements

2.1 Architectural Overview
Oracle Quality Online’s architecture is a 3-tier system comprised of:

Data Tier - The data tier includes Oracle ERP and CRM main tables which comprise 
their common schema. These are driven by the Oracle 8i database. Most of the CRM 
application business logic that is written in PL/SQL is also in the data tier.

Application Tier - The application tier uses business logic APIs and CRM Foundation 
services, Java Server Pages (JSP), and Java APIs. In addition, the Oracle Application 
Object Library (AOL) supplies technology and common libraries for the 
applications. In Oracle applications, Internet Application Server (iAS), drives this 
tier and the Presentation tier discussed below.

Presentation Tier - Generated Java code and compiled servlet code utilize JSP 1.0 or 
higher, and Servlet 2.0 to form the presentation tier. In Oracle applications, the 
Apache Server 1.3.9 drives this tier.
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Minimum Hardware Requirements
Figure 2–1 Oracle Quality Online Architectural Overview

2.2 Minimum Hardware Requirements
The suggested hardware configuration for Oracle Quality Online 11i is a series of 
web servers in the front end and a high performance database server machine in the 
back end. With global systems, the necessity for high performance database servers 
is even greater.

Oracle recommends the following server requirements:

� Enterprise Resource Planning (ERP) database server machine - high throughput 
at fast speed (CPU)

� Web servers running Apache for external customers

� One forms server for administration

You can determine the actual sizing of the machines after completing capacity 
planning.

Specific hardware requirements depend on the particular installation that you 
perform. The hardware requirements listed in the following table are guidelines 
only, and assume a single-node Vision demo environment.
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This table lists the Oracle Quality Online hardware requirements.

2.3 Minimum Software Requirements
The minimum software requirements are listed in the following table.

Hardware Requirement

CPU 2 CPUs minimum, 4 or more highly recommended

Memory 1GB minimum

Disk Space 22GB, including 1GB in /tmp (plus an additional 9GB if 
installing from a staging area)

Table 2–1 Minimum Software Requirements 

Software Requirement

Database 8.1.7 version of Oracle8i

Middle-Tier The middle-tier requirements are an Apache 3.0 version Web 
server and Oracle Forms 6.0 server (as a part of ERP 11i 
implementation). For faster page serving, you can also use a 
caching server in front of the Web server series. The caching 
server (for example, Calypso) then serves the static content 
through the cached TCP/IP packets (or cached pages). An 
invalidated cache results in service requests being directed to the 
Web servers.
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Dependency Requirements and Verification

This chapter describes the installation setup dependencies for Oracle Quality Online 
11i. Specific, step-by-step setup tasks can be found in Chapter 5: Implementation 
Tasks.

Topics include:

� Product Footprint

� Mandatory Dependencies

� Conditional Dependencies

� Verifying the Implementation

3.1 Product Footprint
Oracle Quality Online is part of the Oracle suite of integrated applications that 
share components and depend on each other for functionality. The layered 
architecture of the applications ensures that they interact with each other and 
function in consistent ways. Oracle Quality Online is integrated with, and relies on, 
other applications and modules for data transaction, process management, and 
organization.

An overview of the functionalities of these modules is presented in this section. The 
remaining sections of this chapter detail the setup dependencies and steps for 
Oracle Quality Online. 
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Figure 3–1 Oracle Quality Online Footprint:

*not products

3.2 Mandatory Dependencies
Oracle Quality Online relies on several Customer Relationship Management (CRM) 
Oracle and Enterprise Resource Planning (ERP) modules for its data and 
functionality. These modules are critical for Oracle Quality Online workflow and 
user setups. Throughout the application lifespan, it will be necessary for system and 
Oracle Quality Online administrators to update user information, and modify the 
business workflow. 

3.2.1 Oracle Customer Relationship Management (CRM) Foundation
Oracle CRM Foundation provides the core application components, functionality, 
and data for Oracle Quality Online. 

For information on CRM Foundation usage, please see the Other Sources of 
Information section in the Preface of this guide. 

� Notes: Notes record descriptive, textual information generated by users about 
defects and enhancements.

� Resource Manager: Resources are the employees required to accomplish 
objectives. Resource Manager is used to import and view resources, define 
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resources and roles, create teams and groups, and organize resources within 
those teams and groups. Note the following: 

� It is necessary to import employees who will be Primary Contacts or 
owners into Resource Manager to enable Owner and Primary Contact 
assignments.

� The user functioning as the Oracle Quality Online Administrator must be 
imported as a resource with the MES Administrator Resource role in order 
to be able to set up MES.  

� A Defect and/or Enhancement Owner must have the Defect and 
Enhancement Owner role  (usually a developer or someone involved in the 
solution process).

�  A Primary Contact must have the Defect and Enhancement Primary Contact 
role (a primary contact not involved in the resolution process). 

�  It is necessary to run the Synchronize Employee concurrent request in 
order for changes to an existing resource to become effective.

� Territory Manager: Territory Manager is a tool allowing you to define the rules 
for automatic assignment of defects.

� Assignment Manager: Assignment Manager is the assignment engine. The 
assignment process uses criteria based on preferred Resources, qualifiers and 
Territories. It is necessary to set up Assignment Manager to automatically 
assign all Defects and Enhancements.

� Task Manager: Task Manager provides a single model for all tasks processed by 
the CRM suite. Tasks are created and assigned to groups or individuals. 

� Escalation Manager: Escalation Manager allows identification, tracking, and 
monitoring of situations that require increased attention and quick action.

3.2.2 Oracle Enterprise Resource Planning (ERP)
� Oracle Inventory: Oracle Inventory is used to define and maintain product, 

component, subcomponent, platform, and associated version information. 

� Oracle Bills of Material (BOM): A product structure tool that defines product 
relationships. BOM allows the creation of products containing multiple 
components and subcomponents.

� Oracle Human Resources Management System (HRMS): HRMS is used to 
define and maintain employee information used for assignments.
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� Oracle Receivables: Customers are set up in Oracle Receivables.

3.3 Conditional Dependencies
The following are optional but highly recommended modules that allow Oracle 
Quality Online to utilize additional data and improve functionality:

3.3.1 Service Request/Oracle TeleService
Integration with Service Request, included with TeleService, facilitates an efficient 
support process for customers and internal employees. Support agents can create a 
defect or enhancement request in response to a Service Request.

3.3.2 Knowledge Base Submit for Defects
While all defects can be submitted to the Knowledge Base, it is a business process 
decision to determine whether all or only closed defects should be submitted. 
Entries submitted to Knowledge Base are published to agents and customers. This 
enables users to search for previous solutions.

3.3.3 Oracle Marketing Encyclopedia System (MES) 
Oracle MES must be set up to use the Alerts bin on the Homepage. Alerts are short 
messages sent to subscribers from the system administrator regarding scheduled 
outages or other system issues. For more information see the Oracle Marketing 
Encyclopedia System Implementation Guide, Release 11i.

3.4 Verifying the Implementation
If defects and enhancements can be created, then the implementation has been 
successful. To verify the implementation, create a defect or enhancement, then check 
the defect or enhancement details for completeness and accuracy. If a defect can be 
successfully pushed to the Knowledge Base, then that aspect of the implementation 
has been successful.
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Implementation Overview

This chapter covers the implementation and installation overview. Topics include:

� Process Description

� Suggested Implementation Checklist

� Running Rapid Install

4.1 Process Description
Oracle Quality Online is reliant on other Oracle applications for its functionality. In 
order to successfully implement Oracle Quality Online, you must set up its 
mandatory, and optionally, its conditional dependencies.

4.2 Suggested Implementation Checklist
The following table contains high level implementation set up steps in a suggested 
order. For detailed instructions please see the relevant chapters. 

Table 4–1 Implementation Checklist

Step Description/
Tech 
Stack Responsibility/(s) Req.

1 User Setup Forms Multiple (see Chapter 5 Implementation 
Tasks)

Yes

2 Escalations Setup 
(requires Tasks)

Forms CRM Administrator

(see Chapter 5 Implementation Tasks)

No

3 Tasks Setup Forms CRM Administrator

(see Chapter 5 Implementation Tasks)

No
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4.3 Running Rapid Install
Rapid Install (RapidWiz) helps you install a complete set of Oracle Applications 
products at the latest available maintenance pack level. It installs the required 

4 Notes Setup Forms CRM Administrator

(see Chapter 5 Implementation Tasks)

Yes

5 Product, Component, 
Sub-Component 
Setup

Forms Inventory/Manufacturing and 
Distribution Manager 

(see Chapter 5 Implementation Tasks)

Yes

6 Platform Setup (if 
using Platforms)

Forms Inventory /System Administrator

(see Chapter 5 Implementation Tasks)

No

7 Product Group Setup 
(if using Product 
Groups)

Forms Inventory/System Administrator

(see Chapter 5 Implementation Tasks)

No

8 Processes HTML Oracle Quality Online Administrator

(see Chapter 5 Implementation Tasks)

Yes

9 Oracle Quality Online 
Lookups 

HTML Oracle Quality Online Administrator

(see Chapter 5 Implementation Tasks)

Yes

10 Oracle Quality Online 
Standards 

HTML Oracle Quality Online Administrator

(see Chapter 5 Implementation Tasks)

Yes

11 Oracle Quality Online 
Alerts

HTML Oracle Quality Online Administrator 
with Resource role of MES 
Administrator

(see Chapter 5 Implementation Tasks)

No

12 Assignment Setup 
including Territory 
Qualifiers, Territory 
Types, Territories, 
Escalation Territories, 
Territory Package 
Generation

Forms CRM Administrator

(see Chapter 5 Implementation Tasks)

Yes

13 Oracle Quality Online 
System Profiles 

Forms System Administrator

(see Chapter 6, Profile Options and 
Accounts)

Yes

Step Description/
Tech 
Stack Responsibility/(s) Req.
4-2 Oracle Quality Online Implementation Guide                              



Running Rapid Install
technology stack and creates the Oracle Applications database. You can use Rapid 
Install to install any of three environments: a production installation, a test 
installation, and an installation of the Vision Demo database. In addition, Rapid 
Install lets you license products, country-specific functionality, and languages.

Rapid Install stores the parameters you choose in a configuration file, and then uses 
that file as a road map to perform the installation or upgrade. It installs all 
necessary components, and then sets up your database listeners, web listener, web 
server, Forms server, and Reports server.

In a single-node installation, all servers (database, concurrent processing, forms, 
and web) are installed on a single node. This type of installation is generally used 
for smaller installations and for demonstration purposes. In a two-node installation, 
one node contains the database server, concurrent processing server, and reports 
server, and another node contains the forms server and the web server. A 
multi-node installation sets up any combination of servers you specify, on any 
number of nodes. This type of installation provides the most scalability. 

For more information on Rapid Install, see Installing Oracle Applications and 
Upgrading Oracle Applications.
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Implementation Tasks

5.1 Overview of Implementation Tasks
This chapter covers the following implementation tasks:

� Setting up Users

� Setting up Dependencies

� Oracle Quality Online Administration

5.2 Setting up Users
This section covers the following Oracle Quality Online user related topics:

� Login Interfaces

� Responsibilities, Roles, and Permissions

� User Types Overview

� User Setup

Note: Users can also be set up using the Oracle System Administrator Console. 
Please see the following documentation for additional user setup instructions and 
information:

� Oracle CRM Technology Foundation Implementation Guide, Release 11i

� Oracle CRM Technology Foundation Concepts and Procedures, Release 11i

5.3 Login Interfaces
There are two types of login interfaces within Oracle applications - the Oracle 
Applications Forms login, common to all Oracle applications, and the HTML JTF 
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login screen. The Forms-based applications utilize Oracle Developer, while the 
HTML applications present the JTF interface to the customer.

5.3.1 Oracle Applications Forms Login
The System Administrator (sysadmin) controls a variety of parameters relating to 
Oracle Quality Online, and also assigns responsibilities. 

Before making Oracle Forms settings, verify that Oracle Application is up and 
running. Because some setup steps require running concurrent programs, you must 
ensure that the Concurrent Managers are running. Consult your Applications 
System Administrator for additional information.

For more information on Oracle Applications, refer to Oracle Applications Concepts, 
Release 11i.

5.3.2 JTF (HTML) Console
The JTF console is where all users log in to access Oracle Quality Online and other 
HTML-based applications. The menus that appear after login depend upon the 
roles and responsibilities assigned to the user. Users will be unable to access 
application functionality until they have been assigned both roles and 
responsibilities.

5.4 Responsibilities, Roles, and Permissions 
During the implementation process and throughout the Oracle Quality Online 
application lifespan, it will be necessary for the system administrator or the Oracle 
Quality Online Administrator, if in possession of the necessary Responsibilities, (see 
Section 5.5.2 below) to assign roles, responsibilities, and permissions to users.

This section discusses the terms roles, responsibilities, and permissions. For 
discussion of system profile values, see Chapter 6: Profile Options and Accounts. 

A role is a collection of page- and function-level permissions that are granted to 
maintain application security. For example the Oracle Quality Online roles assigned 
to the Internal Regular User (CSS_DEF_DEFECT_MODIFY_USER and CSS_DEF_
ENH_MODIFY_USER) allow them to work with both defects and enhancements, 
but do not allow them to perform Oracle Quality Online Administrator activities. A 
permission is the smallest unit making up a role. Permissions dictate exactly which 
actions the user can perform. Oracle Quality Online user permissions include 
editing, creating, and viewing defects. 
5-2 Oracle Quality Online Implementation Guide                               



User Types Overview
Responsibilities control the presentation of menus, tabs, and screens. For example, 
the Oracle Quality Online User responsibility gives access to the user set of menus 
while the Oracle Quality Online Administrator responsibility allows access to the 
administration screens.

For information on customizing roles and responsibilities and related menus, refer 
to Oracle CRM Foundation Concepts and Procedures Release 11i and Oracle Applications 
Concepts Release 11i.

Note: Users will not be able to access application functionality until they are 
assigned roles and responsibilities. 

5.5 User Types Overview

5.5.1 System Administrator (Seeded)
The System Administrator (sysadmin/sysadmin) username and password are 
supplied with the product.  The sysadmin will have all available system and 
module permissions and be able to access the full spectrum of Oracle Forms 
responsibilities in order to complete the implementation process.

Note: Please change the password before setting up Oracle Quality Online for 
security purposes.  Log on to Oracle Forms as sysadmin. Navigate to System 
Administrator > Security > User > Define.  Enter query mode by selecting F11. 
Query sysadmin by entering SYSADMIN in the User Name field and then selecting 
Control F11.  Change the password in the Password Field.   You must tab to reenter 
and confirm.  Save and close form.

5.5.2 Oracle Quality Online Administrator
The Oracle Quality Online Administrator function, depending on the organization’s 
business practices, can be assigned by the sysadmin to another user, responsible for 
configuring and managing the following within the Oracle Quality Online 
application:

� Processes: Categories, Types, Phases, and Phase status. 

� Standards: Templates, Template options, Resolution Times and Note Token 
Rules.

� Lookups: Priorities, Severities, Languages, Tracking Groups, Environmental 
Variables, and Miscellaneous.

� Alerts: Alert Administration, Send Alert, and Alert Group. 
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Oracle Quality Online Administrator Responsibilities are:

� Oracle Quality Online User

� Oracle Quality Online Administrator

� Human Resources Manager  (for HRMS setup)

� CRM Administrator

� Manufacturing and Distribution Manager (for Inventory Setup)

� Knowledge Base System Administration (for Knowledge Base Setup): The 
Oracle Quality Online Administrator must be set up with the iSupport 
Administrator role and the Knowledge Base System Administrator 
responsibility.

Note: The user functioning as the Oracle Quality Online Administrator must be 
imported as a resource with the MES Administrator Resource role in order to be 
able to set up MES.  See Section 5.6.5 below for detailed steps.

5.5.3 Oracle Quality Online User 
The Oracle Quality Online User Responsibility is DEMS User.  A typical Oracle 
Quality Online user will create, view and update both Defects and Enhancements.  
If desired, the DEMS User can be assigned the CSS_DEF_DEFECT_RESOLUTION 
role and the CSS_DEF_ENH_RESOLUTION roles enabling the user to update 
resolutions as well.

5.6 User Setup
Below are step-by-step instructions for creating users in Oracle Quality Online. 
Please see the current documentation for Oracle HRMS (employee users) and/or 
Oracle Receivables/TCA (customer users) for complete implementation 
instructions. The Oracle HRMS instructions below are intended for rapid setup of 
your Oracle Quality Online users.

5.6.1 Creating an HR employee
If your HR system is complete and Oracle Quality Online employee users are 
already set up, you will not need to Create HR employees. Skip to section 5.6.2, 
Creating an FND User and Assigning Responsibilities.

1. Log in to Oracle Applications as System Administrator. When the Java applet 
has loaded, select your Human Resources administration responsibility.
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2. Navigate to People > Enter and Maintain. Click New at the bottom of the Find 
Person form. The People form appears.

3. Enter User first and last names in the name fields. Select user gender from the 
Gender drop down box. Select title from the Title LOV. Select Type from the 
Type LOV. 

4. Enter country specific tax identification number. The tax identification number 
is mandatory.

5. On Personal tab, enter date of birth. On Office Details tab, enter email address.

6. Navigate to File > Save and Proceed to save and clear the form. Continue to 
Create Employees as necessary.

7. To confirm that the employee has been created, navigate to People > Enter and 
Maintain. Use the Find form to locate the employee you just created. Note the 
Employee Number.

5.6.2 Creating an FND User and Assigning Responsibilities 
1. Log in to Oracle Applications as System Administrator. When the Java applet 

has loaded, select the System Administrator responsibility. Navigate to Security 
> User > Define. The Users form appears.

2. In the Users form, enter a User Name. For example, when setting up the Oracle 
Quality Online administrator, DEMS_Admin could be used.

3. To associate an FND User with an employee, use the Person LOV in the User 
Form. To associate an FND User with a customer, use the Customer LOV. Search 
for the user by clicking on the blue tab to the left of the appropriate field and 
entering a partial name to limit the search results. Select the desired association 
by double clicking on the name. 

4. Tab to Password field and enter a password. Tab to clear the field and re-enter 
the same password to validate. 

5. On the Responsibility tab, click in the Responsibility field to activate it. Search 
for DEMS responsibilities by clicking on the blue tab to the left and entering 
DE% to limit the search. Double click to select. For example, select DEMS User 
only for a regular DEMS user and both DEMS User and DEMS Administrator 
for the Oracle Quality Online Administrator.  Users with a third responsibility,  
DEMS Lookups and Concurrent Programs, will be able to check Oracle Quality 
Online lookups and run concurrent programs for the application. 
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Note: The Oracle Quality Online Administrator will require additional 
responsibilities to perform other administrative tasks.  Please see above, Section  
5.5.2.

6. Enter Effective Dates if they do not appear automatically.

7. Navigate to File > Save and Proceed to save and clear the form. Or click the 
diskette icon at the top of the screen.

5.6.3  Configuring the User profile
To determine the Default Application and Responsibility ID for all Oracle Quality 
Online users see Steps 1-6 below.

1. Log in to Oracle Applications as System Administrator. When the Java applet 
has loaded, select the System Administrator responsibility. Navigate to Security 
> Responsibilities > Define.

2. Press F11 for query mode and enter the responsibility DEMS_USER in the 
Responsibility Name field.

3. Execute the query by pressing Control F11. The data for the DEMS_User 
responsibility is displayed. 

4. From the menu choose Help > Diagnostics > Examine. If a password is called 
for, enter the password set for apps user. 

5. In the Examine Field and Variable Values form, Select the LOV for the Field.   
Double click the RESPONSIBILITY_APPLICATION_ID. The Value for the 
APPLICATION_ID should always be 514 which is the internal application ID 
for Oracle  Quality Online.

6. Re-select the LOV for the Field and double click RESPONSIBILITY_ID. Make a 
note of the Value for the RESPONSIBILITY_ID, and select OK.

7. From the menu select File > Close Form.

8. In the System Administrator Navigator, select Profile > System. In the Find 
System Profile Values screen check User and accessing the LOV, select the 
username you created.

9. Uncheck the Profiles with no Values checkbox and enter JTF%PROFILE% in the 
Profile field. Select Find.

10. In the User column, ensure that the JTF_PROFILE_DEFAULT_APPLICATION 
for the user is set to 514. If it is not, change it.
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11. In the User column, set the JTF_PROFILE_DEFAULT_RESPONSIBILITY to the 
RESPONSIBILITY_ID number identified above.

12. Navigate to File > Save and Proceed. 

5.6.4 Assigning JTF Roles to Each User
The minimum roles for DEMS User are CSS_DEF_DEFECT_MODIFY_USER, and 
CSS_DEF_ENH_MODIFY_USER. The minimum role for  DEMS Administrator is 
CSS_DEF_ADMIN.

1. Log in to the JTF login page as sysadmin. Navigate to Users > User 
Maintenance.

2. Search for the user using the drop-down box and LOV.

3. Click Go and select the user name link.

4. Click the Roles button. The User Role Mapping page appears.

5. From the Available Roles column, select the desired Role and click Assign ( >) 
Move each role individually.

6. When done assigning Roles, click Update to set the new values, or Restore to 
return to the previous values.

5.6.5 Importing an HR Employee as a Resource 
This must be done for users who will be Primary Contacts or owners. In addition, 
the user functioning as the Oracle Quality Online Administrator must be imported 
as a resource with the MES Administrator Resource role in order to be able to set up 
MES

Note that it will be necessary to run the Synchronize Employee concurrent request 
for changes to an existing resource to become effective.   

1. Log in to Oracle Applications as System Administrator. When the Java applet 
has loaded, navigate to CRM Resource Manager > Maintain Resources > Import 
Resources. The Selection Criterion window appears.

2. Search for employee in the Name Field LOV or enter the employee number. 
Select the employee name.

3. Click the Search button. Verify that the Select box is checked in Search Results, 
and that employee Category, Number, Name, and Organization data displays. 

4. Click Create Resource button. The Default Values form appears.
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5. Click on the Role field to access the LOV. Select an Oracle Quality Online Role. 
Seeded Resource Roles are Defect and Enhancement Owner (usually a 
developer or someone involved in the solution process) and Defect and 
Enhancement Primary (a primary contact not involved in the resolution 
process). For the MES role appropriate to the Oracle Quality Online 
Administrator, select MES Administrator. Click OK. 

6. Set Role Start and End Dates if desired. Click OK. The Selected Resources 
window appears. Click Save Resources to confirm.

7. Click the diskette icon at the top of the screen to save, and then close the form.

5.6.6 Creating Resource Groups
It is recommended that each group receiving automatic assignments have a 
resource group for assignment, rather than individuals, in order to insure that 
issues are covered if an employee is reassigned or is unavailable. Resource Groups 
should be used as the Primary Owner for all Territories.

1. Log in to Oracle Applications as System Administrator. When the Java applet 
has loaded, navigate to CRM Resource Manager > Maintain Resource > Groups. 
The Define Groups form appears.

2. Enter a name and description for the Resource group in the respective fields.In 
the Email Address field, enter an address for the Resource Group. 

3. Click the diskette icon at the top of the screen to save. A number will be 
automatically assigned. 

4. On the Roles tab, click the Roles Type field LOV. Select Defects and 
Enhancements to associate the Resource Group with Oracle Quality Online. 

5. Click the Roles LOV and select Defect and Enhancement Owner to associate the 
Resource Group with the Oracle Quality Online resource roles. 

6. Repeat Step 4. Click the Roles LOV and select Defect and Enhancement Primary 
Group to complete association of the Resource Group with the Oracle Quality 
Online resource roles. 

7. Set Role Start and End Dates if desired 

8. Click the diskette icon at the top of the screen to save, and then close the form.
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5.6.7 Adding an Employee to a Resource Group
1. Logon to Oracle Applications as System Administrator.  Navigate to CRM 

Resource Manager > Maintain Resources > Groups. The Define Groups form 
appears.

2. Query the desired Oracle Quality Online Resource Group

3. Select the Members tab. Go to a blank record and Click in the Category field to 
select the resource category (Employee, Other, Partner)

4. Identify the employee by name or number.  Employees must be imported as 
resources or they will not display in LOV.

5. Click the diskette icon in the menu bar to save 

5.6.8 Adding Resource Roles
1. Logon to Oracle Applications as System Administrator.  Navigate to CRM 

Resource Manager > Maintain Resources > Groups. The Define Groups form 
appears.

2. Query the desired Resource Group.

3. Select the Roles tab. Go to a blank record and Click in the Role Type field and 
select Defect and Enhancement. 

4. Select the Defect and Enhancement Owner Role for owner and then do the 
same for Defect and Enhancement Primary role. 

5. Click the diskette icon in the menu bar to save.

5.7 Setting up Dependencies
This section covers setup steps for Oracle Quality Online dependencies.

Please refer to the current documentation for Oracle Inventory and Oracle CRM 
Foundation for complete implementation instructions. The following setup steps 
are specific to Oracle Quality Online allowing for a rapid implementation.

5.8 Setting Up Oracle Inventory Management
All product items, components, sub-components and platforms must be set up as 
Inventory Items in order to be accessible in Oracle Quality Online. Product 
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hierarchies must be set up with Bills of Materials (BOM). For further information, 
please see the Oracle Inventory User’s Guide Release 11i.

Note: To enable users to create defects and enhancements based upon service 
requests, set up Oracle Inventory and Oracle Bills of Materials as a shared structure 
across service (Oracle TeleService) and engineering (Oracle Quality Online).   

It can be advantageous to plan your system so that you use the same product 
structure for sales, shipping, service and engineering to allow mapping to 
engineering cost/revenue reports. Saleable products that are not engineering 
products should be linked as the parent of the engineering product through Bills of 
Materials.

If your inventory items are already set up please make sure that changing flags will 
not affect other applications:

� If you want to enable an item to be tracked as a product in Oracle Quality 
Online, check the Defect Tracking Enabled box on the Service tab in the master 
item setup. (See 5.8.1 below for detailed steps.). Setting this flag allows the item 
to be visible in the Product LOVs. Do this only if you want to create products 
for use in Oracle Quality Online.

� To enable Bills of Materials, which allows product hierarchy creation, ensure 
that the Bills of Materials enabled flag is checked. Components and 
subcomponents will be related to the products enabled above. (See 5.8.2 below 
for detailed steps.) 

� To allow version tracking, the Revision Control box on the Inventory tab in the 
master item setup must be checked. (See 5.8.1 below for detailed steps.)

5.8.1 Setting Up Inventory Items
Oracle Inventory uses the concept of a master organization in its structure. The 
master organization holds all of the information on product items.

1. Log on to Oracle Forms by using the link provided by your System 
Administrator: http://<hostname>:<Port_number>/dev60cgi/f60cgi.

2. Log on as sysadmin. Select the Inventory Responsibility.

3. Navigate to Items > Master Items and double-click Master Items. Select your 
inventory organization from the list. The Master Item form opens. 

4. On the Master Item form enter your Item and Description. These are mandatory 
fields. Select the Inventory tab.
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5. To enable Bills of Materials, ensure that the Bills of Materials enabled flag is 
checked.

6. To allow version tracking, check the Revision Control flag on the Inventory tab. 
To set up versions, select Tools > Revisions and input your version numbers in 
ASCII order. Descriptions are mandatory for versions to be visible in Oracle 
Quality Online.

7. To enable product tracking in Oracle Quality Online navigate to the Service tab 
by selecting the small arrow to the right of the last visible tab. This will present 
additional tabs. Select the Service tab. Check the Defect Tracking Enabled box.

8. From the menu bar, select File > Save.

5.8.2 Setting up Products
After you have set up the master organization, you then define items within your 
inventory. The steps below can assist you in setting your items.

5.8.2.1 Setting up Items
1. Log on to Oracle Applications as System Administrator. In the Responsibility 

window, select the Manufacturing and Distribution Manager responsibility. 
Navigate to Inventory > Items > Master Items. Select the appropriate 
organization. The Master Item form opens.

2. Enter the Inventory Item name and description.

3. In the Inventory tab, check the Inventory Item checkbox.

4. In the Bills of Material tab, check the BOM Allowed checkbox. 

5. Check Defect Tracking Enabled in the Service tab. The tab can be found by 
clicking on the right-hand arrow button that expands the tab display.

6. Click the diskette icon on the menu bar to save.

7. From the menu bar, select Tools > Organization Assignment and, using the 
checkboxes, assign to all appropriate organizations in the Organization 
Assignment form.

8. Save and close the form. 

5.8.2.2 Setting up Item Revisions
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Manufacturing and Distribution Manager responsibility. Navigate to Inventory 
                                                                     Implementation Tasks 5-11



Setting Up Oracle Inventory Management
> Items > Master Items. Select the appropriate organization. The Master Item 
form opens. 

2. Query the item by hitting F11 in the Item Field. Execute the query by hitting 
Control F11. Select the item.

3. Select the Item, navigate to Tools > Revisions. The Item Revisions form opens.

4. Enter in a unique revision in the Revision column using an alphabetical format 
(e.g. A, B, C, etc.)

5. Enter the product version in the Description field. 

6. Enter in a valid effective date. 

7. Save and close the form. 

5.8.2.3 Setting up Bills of Materials (BOM) for Oracle Quality Online
Oracle Bills of Materials (BOM) allows the linking of products to components, and 
components to subcomponents in a hierarchical manner.

1. Log on to Oracle Forms as System Administrator. In the Responsibility window, 
select the Manufacturing and Distribution Manager responsibility. Navigate to 
Bills of Materials > Bills > Bills. Select the appropriate organization. The Bills of 
Material form opens. 

2. Query the product from the Item LOV, by hitting F11 and entering % in Item 
field in the form that opens. Execute the query by hitting Control F11. Select the 
product from the Item form list.

3. In the Main tab, select a component from the Component LOV  or from the 
Components Items list that appears.

4. Select File > Save and Proceed.

5. To link sub-components to components, repeat steps 2-3 except query the 
component instead of the product in step 2.

6. Save, and close the form. 

5.8.3 Setting up Platforms
To create platforms, you must first define at least one Category and one Category 
Set.
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Oracle Inventory allows you to set up your inventory items in categories. 
Categories are either product or platform related. A product or platform category 
has a many-to-many relationship with inventory items. 

You use the Category Flexfield Structure in Oracle Inventory to define categories for 
products and platforms, and group them.

After you set up categories, they can then be grouped into category sets. You can 
define an unlimited number of categories and group subsets of your categories into 
category sets. A category can belong to multiple category sets. You can assign a 
category to a category set either at the time you define a category set or at the time 
you assign an item to the category.

Oracle Quality Online expects two category sets - one for platform definition, and 
the other for defining product groups.

Use of product categories and category sets also allows the display of different  
product categories to different user types, e.g., employees or customers. This can be 
accomplished by setting the profile option, Service: Default Category Set at a 
responsibility level. See Oracle Inventory documentation for more details.

5.8.3.1 Creating Platforms
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Inventory responsibility. Navigate to Items > Master Items. Select the 
appropriate organization. The Master Item form opens. 

2. Enter platform in Item field (e.g. Unix, Windows etc.)

3. Enter description in Description field. 

4. Select File > Save and Proceed.

5. Enter all platforms in the same way, then close the form.

5.8.3.2 Creating Platform Revisions
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select 

Inventory. Navigate to Items > Master Items. Select appropriate organization. 
The Master Item form opens. 

2. Press F11 for query mode and enter your query in the Item field. Execute your 
query by hitting Control F11. Select the item. 

3. Navigate to Tools > Revisions.
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4. In the Revisions column, select an alphabetically based revision code (e.g. A, B, 
C, etc.).

5. Enter a description in the Description field. 

6. Enter an Effective Date.

7. Select File > Save and Proceed.

8. Continue until all Revisions have been entered. Then save, and close the form.

5.8.3.3 Creating Oracle Quality Online Platform Key Flexfield Structure
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Manufacturing responsibility. Navigate to Inventory >Setup > Flexfields > Key 
> Segments. The Key Flexfield Segments form opens.

2. Press F11 for query mode and enter Oracle Inventory in the Application field. 
Execute the query by pressing Control F11. The structure for Oracle Inventory 
will display.

3. Click a record in the Code list. Click the New record icon, located on the menu 
bar. In the new record, enter the a code in the Code column such as 
PLATFORM_CATEGORY.

4. Enter the title in the Title field.

5. Enter a description in the Description field.

6. Click the Segments button. The Segments Summary form appears.

7. Enter a name, window prompt and number in the corresponding fields.

8. Using the Column LOV, select a Segment.

9. For multiple segment structures, repeat steps 7-8.

10. From the main menu, select Save. Close the form.

11. Back in the Key Flexfield Segments form, check the Freeze Flexfield Definition 
checkbox.

12. Click the Compile button. Click OK to confirm compilation.

13. Save, and close the form. 
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5.8.3.4 Creating Platform Categories against the Platform Key Flexfield 
Structure
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select 

Inventory. Navigate to Setup > Items > Categories > Category Codes. The Find 
Categories window opens. 

2. Using the Structure Name LOV, select the structure, then click the New button. 
The Categories form opens. 

3. Select the flexfield structure from the Structure Name LOV. 

4. Enter a unique category name in the Category field.

5. Enter a description in the Description field. 

6. Enter other categories as needed. 

7. Save, and close the form. 

5.8.3.5 Creating one Platform Category Set and Associating to all Platform 
Categories
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Inventory responsibility. Navigate to Setup > Items > Categories > Category 
Sets. Select the appropriate organization. The Category Sets form opens. 

2. Enter a unique Category Set name in the Name field.

3. Enter a description in the Description field.

4. Using the Flex Structure field LOV, query and select the flexfield structure.

5. Select a control level:

� Master Level: Item assigned to this Category Set has the same category 
value in all organizations where it is assigned. 

� Org Level: Item assigned to this Category Set may have a different category 
value in each organization where it is assigned. 

6. Using the Default Category LOV, select a default category. This is the default 
category used when assigning an item to the category set. For example, a 
category set may have a default category called Unix-2. After an item is 
assigned to Unix-2, you can override the default category and choose another 
relevant category for each item. 

7. Click the Enforce List of Valid Categories checkbox.
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8. Click in a blank field in the Enforce List of Valid Categories field, and, using the 
LOVs, select the categories. 

9. Optionally, check the Allow Multiple Item Category Assignments checkbox. If 
you enable this feature, you can assign an item to multiple categories within a 
category set. If you do not enable this feature, an item can be assigned to exactly 
one category. In this case, an item can be assigned to only one default display 
category. 

10. Save, and close the form. 

5.8.3.6 Associating Platform Categories to Items that are Platforms
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Inventory responsibility. Navigate to Setup > Items > Categories > Category 
Sets. Select the appropriate organization. The Category Sets form open. 

2. Enter a unique name in the Name field.

3. Enter a description in the Description field.

4. Using the Flex Structure LOV, select the appropriate Flexfield Structure.

5. Select a control level:

� Master Level: Item assigned to this Category Set has the same category 
value in all organizations where it is assigned. 

� Org Level: Item assigned to this Category Set may have a different category 
value in each organization where it is assigned. 

6. Using the Default Category LOV, select a category.

7. Click the Assign button. The Item Assignments form opens. 

8. Using the Item field LOV, enter an item name. Press F11 for query mode, then 
press Control F11 to execute the query. Select an item. 

9. From the Category LOV, choose a category. 

10. Save, and close the form. 

5.8.3.7 Pointing Oracle Quality Online to the Category Set that Indicates which 
Items are Platforms
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 

System Administrator > Profile > System. The Find System Profile Values form 
opens. 
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2. Using the Profile field LOV, query the profile Service: Default Platform 
Category Set in the Find field of the Profiles form.

3. From the appropriate LOV, select the platform category created in Section 
5.8.3.3 Creating Oracle Quality Online Platform Key Flexfield Structure.

4. Save, and close the form.

5.8.4 Setting up Product Groups
Setting up Product Groups facilitates accurate and efficient executive reporting by 
categorizing multiple products into high-level groups.

5.8.4.1 Creating Oracle Quality Online Product Groups Key Flexfield Structure
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Inventory responsibility. Navigate to Setup > Flexfields > Key > Segments. The 
Key Flexfield Segments form opens. 

2. Press F11 for query mode and enter Oracle Inventory in the Application field.

3. Execute the query by pressing Control F11. The data for Oracle Inventory will 
display.

4. Click in a record in the Code list. Click the New record icon, located on the 
menu bar. In the new record, enter a code in the Code column such as 
PRODUCT_GROUP. Tab over to the Description field. The Title field will be 
automatically populated with the Code name data. 

5. Enter a description in the Description field. 

6. Click the Segments button. The Segments Summary form opens. 

7. Enter a number in the Number field, then a unique product group name in the 
Name field. This automatically populates the Window Prompt field. Tab over to 
the Column field.

8. Using the Column LOV, select a segment listing value from the Columns form 
that opens. 

9. Save and close the Form. 

Note: The maximum size of your value set is 40. Users may need to scroll through 
the entire flexfield segment to see the entire list of values you entered.

10. Back in the Key Flexfield Segments form, check the Freeze Flexfield Definition 
button, and then click Compile. Click OK to verify the compilation, then close 
the form.
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5.8.4.2 Creating all Product Groups Against Key Flexfield Structure
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Inventory responsibility. Navigate to Setup > Items > Categories > Category 
Codes. The Find Categories form opens. 

2. Using the Structure Name LOV, select the structure name, then click New. The 
Categories form opens. 

3. Using the Structure Name LOV, select the structure name. Click New. The 
Categories form opens.

4. Using the Structure Name LOV, select the structure name

5. Enter a unique category name in the Category field.

6. Click in the Description field. In the form that opens, enter descriptions for each 
group in the fields, then click OK.

7. Save and then close the form.

5.8.4.3 Creating one Product Group Category Set 
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 

Inventory > Setup > Items > Categories > Category Sets. Select the appropriate 
organization. The Category Sets form opens. 

2. Enter a unique Category Set name in the Name field.

3. Enter a description in the Description field.

4. Using the Flex Structure field LOV, query and select the flexfield structure.

5. Select a control level from the Controlled At LOV:

� Master Level: Item assigned to this Category Set has the same category 
value in all organizations where it is assigned. 

� Org Level: Item assigned to this Category Set may have a different category 
value in each organization where it is assigned. 

6. Using the Default Category LOV, select a default category. This is the default 
category used when assigning an item to the category set. For example, a 
category set may have a default category called New. After an item is assigned 
to New, you can override the default category and choose another relevant 
category for each item. Click OK. 

7. Click the Enforce List of Valid Categories checkbox.
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8. Click in a blank field in the Enforce List of Valid Categories field, and, using the 
LOVs, select the categories. 

9. Optionally, check the Allow Multiple Item Category Assignments checkbox. If 
you enable this feature, you can assign an item to multiple categories within a 
category set. If you do not enable this feature, an item can be assigned to exactly 
one category. In this case, an item can be assigned to only one default display 
category.

10. Save and close the form.

5.8.4.4 Associating Product Group Category Set to Products
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Inventory responsibility. Navigate to Setup > Items > Categories > Category 
Sets. Select the appropriate organization. The Category Sets form open.

2. Enter a unique name in the Name field and a description in the Description 
field.

3. From the Flex Structure LOV, select a flexfield structure name.

4. Select a control level from the Controlled At LOV:

� Master Level: Item assigned to this Category Set has the same category 
value in all organizations where it is assigned.

� Org Level: Item assigned to this Category Set may have a different category 
value in each organization where it is assigned.

5. Using the Default Category LOV, query the Product Group Category Sets by 
clicking F11 in the form that opens. Execute the query by hitting Control F11 
and selecting the default category data. Select the item from the System Items 
list. Click OK. 

6. Click Assign. The Item Assignment window opens.

7. From the Item LOV, query the item by hitting F11 and entering % in the form 
that opens. Execute the query by hitting Control F11. The Description field will 
be automatically populated with the predefined description.

8. Using the Category LOV, enter a category by hitting F11 in the form that opens. 
Execute the query by hitting Control F11.

9. Click Accept.

10. Save, and close the form.
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5.8.4.5 Pointing to Product Group Category Sets.
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 

System Administrator > Profile > System. The Find System Profile Values form 
opens. 

2. Using the Profile field LOV, query the profiles by entering Service% in the Find 
field of the Profiles form that opens. Select Service:Product Default 
Category Set, then click Find. The System Profile Values form opens.

3. From the appropriate LOV, select the product group category name.

4. Save, and close the form. 

5.9 Setting Up Oracle CRM Foundation
Oracle CRM Foundation includes modules that are shared across CRM applications.   
These include Tasks, Escalations, Notes, Territories, Resources and Assignment 
Manager. 

Within Oracle Quality Online, Tasks allow project specific activities to be defined 
and tracked, thus permitting escalation (optional) when required. Notes permit 
extensive information collection and transfer. Territories, Resources and Assignment 
Manager allow the creation of general areas of expertise (Territories), specific 
groups for handling those areas (Resources) and appropriate work assignment 
(Assignment Manager). 

5.9.1 Setting Up Tasks (Optional)
Tasks can be used for escalation, patch, document, or quality assurance requests, 
and are used to assign work activities to other users. The CRM Task Administrator 
sets up Tasks in Oracle Forms. Task set up consists of the creation of Task Types, 
Task Priorities, Task Statuses and Task Contact Type. This information is visible in 
the LOVs for the respective fields in Oracle Quality Online. To add new Tasks 
follow the instructions below. 

5.9.1.1 Creating Task Types
Task Types are currently global. This means that they are shared across all CRM 
products. 

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 
CRM Task Manager > Setup > Define Task Type. The Task Types window 
appears.
5-20 Oracle Quality Online Implementation Guide                               



Setting Up Oracle CRM Foundation
2. Click in a record in the Task Types list. Click the New record icon, located on the 
menu bar. In the new record enter the Type in the Type column.

3. Workflow and Rule information is not required for Oracle Quality Online.

4. Enter the Effective Dates if desired.

5. Unit of Measure (UOM) and Duration are optional.

6. Select Task Type flags if desired. They are not required for Oracle Quality 
Online. Task Type flag definitions:

� Notification: Launch notification workflow automatically.

� Schedulable: Reserve the resource via the Scheduler.

� Billable: Signify a Task as a service that requires billing.

� Private: Restrict Task availability.

� Seeded: Lock edit of Task Type from future users.

7. You must save changes before you can Map Types. Save and select the Map 
Types button. The Mapping Objects form appears.

8. Select Defects from the Source Object LOV to map to the defect source code. 
Then select Enhancements from the Source Object LOV. This maps your new 
type to Oracle Quality Online.

9. Save and close the form.

5.9.1.2 Creating Task Priorities
Task Priorities are mapped to specific CRM applications. If end dates or other 
parameters are changed this affects Oracle Quality Online. 

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 
CRM Task Manager > Setup > Define Task Priority. The Task Priority window 
appears.

2. Click in the last record in the Priority list. Click the New record icon, located on 
the menu bar. In the new record enter the Priority in the Priority column.

3. Enter a numerical value in the Importance field that reflects your level of 
importance for this Task Priority.

4. Enter a description in the Description field. 

5. Entering the Effective Dates is optional.
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6. You must save changes before you can Map Priorities. From File, click Save and 
Proceed. Select the Map Types button. The Mapping Objects form appears. 

7. From Source Object LOV, select Defects to map to the Source Codes. 

8. From the Task priority LOV, select the new Task Priority. Repeat Steps 7-8 for 
Enhancements so that the new Task Priority is mapped to both Defects and 
Enhancements. 

9. Entering End Date and Application is optional. 

10. Click Save and then close the form. 

5.9.1.3 Defining Task Statuses
Use this procedure to define types of task status for your users.

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 
CRM Task Manager > Setup > Define Task Status. The Task Status window 
appears.

2. Click in a record in the Status list. Click the New record icon, located on the 
menu bar. In the new record enter the Status name in the Status column.

3. Enter a description in the Description field. 

4. Enter the Effective Dates in the From and To fields. The From date is mandatory.

5. Verify that Task is visible in the Usage field. 

6. Select Task Status checkboxes as needed. The Task Status checkbox is required. 
Task Status flag definitions:

� Assigned: Assigned to an individual

� Working: In progress

� Schedulable: Scheduled or re-schedulable

� Accepted: Accepted by owner

� Rejected: Rejected by owner

� On Hold: Temporarily not active

� Approved: Approved by management

� Completed: Completed by owner

� Canceled: Canceled by owner, creator, or management

� Delete Allowed: Delete acceptable without cancellation
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� Closed: Completed and closed

� Seeded: Pre-defined task status

7. From the menu bar select File > Save and Proceed.

Note:  For information on Creating Task Templates, please see the Oracle CRM 
Application Foundation Implementation Guide.

5.9.2 Setting Up Escalations (Optional)
Escalations are currently global across all CRM products. Manual Escalations 
require Tasks to be set up. Set up affects both Oracle Quality Online and TeleService.

5.9.2.1 Setting up Escalation Reasons
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 

CRM Task Manager > Setup > Define Escalation Reason. The Escalation 
Reasons Lookups window appears. 

2. Click in the last record in the Code list. Click the New record icon, located on 
the menu bar. In the new record enter a code for the Escalation Reason.

3. Enter a definition for the Code in the Meaning column, and a description for the 
Code in the Description column. These two fields can match. 

4. The Tag field is optional. 

5. Enter the Effective Dates. The Effective From Date is mandatory and will 
automatically default to today’s date. It can be changed from the Effective From 
Date LOV.

6. Verify that Enabled has been checked. 

7. Save, and close the form.

5.9.2.2 Setting up Escalation Levels
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 

CRM Task Manager > Setup > Define Escalation Level. The Escalation Levels 
Lookups window appears. 

2. Click in the last record in the Code list. Click the New record icon, located on 
the menu bar. In the new record enter a code for the Escalation Level.

3. Enter a definition for the Code in the Meaning column, and a description for the 
Code in the Description column. These two fields can match. 
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4. The Tag field is optional.

5. Enter the Effective Dates. The Effective From Date is mandatory and will 
automatically default to today’s date. It can be changed from the Effective From 
Date LOV.

6. Verify that Enabled has been checked. 

7. Save and close the form.

5.9.2.3 Setting up Escalation Status
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 

CRM Task Manager > Setup > Define Escalation Status. The Task Status 
window appears.

2. Click in the last record in the Status list. Click the New record icon, located on 
the menu bar. In the new record enter a name for the Escalation Reason. This is 
the only mandatory entry. The followings steps are suggested.

3. Enter a description in the Description field. 

4. Enter the Effective Dates in the From and To fields.

5. Verify that Escalation is visible in the Usage column.

6. Select Escalation Status flag checkboxes as needed (see step 5.9.1.3. for 
definitions)

7. Save and close the form. 

5.9.3 Setting Up Notes
Notes allow the capture of extensive, text based, project information within Oracle 
CRM applications. In Oracle Quality Online, the Notes are intended to facilitate and 
speed up the problem solving process by allowing complete information storage 
and exchange. For Oracle Quality Online, Notes are relevant to Defects, 
Enhancements, Escalations, and Tasks. CRM Applications come with various 
predefined Note Types.

To setup new Note Types, and/or disable seeded Note Types, see the Oracle CRM 
Application Foundation Implementation Guide, Release 11i.
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5.9.3.1 Mapping Note Types
When you map a note type to a source object, you limit the visible note types for 
that source to the defined subset of note types. Prerequisite: Setting up Note Types. 
See the Oracle CRM Application Foundation Implementation Guide, Release 11i.

1. Log on to Oracle Forms as sysadmin. In the Responsibility Form select the CRM 
Administrator responsibility. Navigate to Notes Setup > Source and Note Type 
Mapping. 

2. Using the Source Object LOV, select the appropriate source (Defects, 
Enhancements, Escalations, or Tasks).

3. Select a Note Type for the Source.

4. Using the Application LOV, select the application.

5. Set an End date, if desired, using the End Date LOV.

6. Save, and close the form.

5.9.4 Setting Up Assignments 
Ownership can be auto assigned to individuals or groups based on territory 
qualifiers. Territories map to the relevant development groups in terms of defect 
ownership. For example, some development groups own defects for particular 
products, others own defects for products on specific platforms. The products, 
platforms, and groups must be associated to the relevant territories as territory 
qualifiers.

In Oracle Quality Online, Territories typically reflect organizational, not 
geographical structure.

Please see Appendix C Territory Setup or the Oracle CRM Application Foundation 
Implementation Guide and Concepts and Procedures, both  Release 11i, for more 
information.

5.9.4.1 Enabling Oracle Quality Online Territory Qualifiers
Qualifiers are the criteria used to delineate a territory.

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 
CRM Administrator > Territory Manager > Territory Administration. From the 
menu bar, select Administration > Setup Qualifiers. The Setup Qualifier form 
opens.

2. From the Usage LOV, select Oracle Defect Management. 
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3. Click the Enabled checkbox in the Status area, then Click the Find button. A list 
of qualifiers will appear.

4. Enable the Oracle Quality Online qualifiers that you wish to use by clicking on 
the corresponding checkboxes. 

5. Click Update Qualifiers, then close the form.

5.9.4.2 Creating a Territory Type
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 

CRM Administrator > Territory Manager >   Territory Administration.

2. Select Territory Types in the View By field.

3. Click on Oracle Defect Management from the tree menu.

4. Click the New record icon, located on the menu bar. The Territory Type form 
opens.

5. Enter a name and description of the new territory type.

6. Enter Start and End dates.

7. From the Transaction Types LOV, select Defect or Enhancement.

8. Select qualifiers from the LOV in the Transaction Qualifier Name field. 

9. Repeat the process until all required qualifiers for the new territory type have 
been selected.

10. From the menu bar, click Save.

5.9.4.3 Setting up Oracle Quality Online Territories
It is mandatory to set up a catch-all territory as a default. All other territories will be 
pushed as its children. This ensures default assignment in any circumstances. 

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 
CRM Administrator > Territory Manager > Territory Administration.

2. Select Territories from the LOV in the View By field.

3. Click on Oracle Defect Management from the tree menu.

4. Click the New record icon, located on the menu bar. The Territory Details form 
opens.

5. Enter a name and description of the new territory you wish to define.

6. Select Catch-All from the Parent LOV.
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7. Select Defect or Enhancement from the LOV in the Transaction Types field.

8. Set a Ranking number.

9. Enter 1 for the number of winners.

10. Click the Transaction Qualifiers tab. 

11. Select a qualifier from the Transaction Qualifier LOV.

12. Select values from the Values Form field.

13. Click the Resource tab. 

14. Select Name and Role name. This populates the Access Type fields.

15. Click Save from the menu bar. 

5.9.4.4 Generating a Territory Package
After defining territories using Territory Management, you must run the Generate 
Territory Package concurrent program to compile the territories.  If you do not 
generate the Territory Package, none of your changes will go into effect.

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, navigate to 
CRM Administrator > Resource Manager > Others > Requests > Run. 

2. In the Submit a New Request form, select Single Request.

3. In the Submit Request form, select Generate Territory Package from the listed 
Reports in the Name field LOV.

4. In the Parameters window, select Oracle Defect Management from the Usage 
field LOV.

5. Select Defect or Enhancement from the list item in the Qualifier Type field LOV.

6. Select either Yes or No from the Debug flag and SQL Trace field LOVs.

7. Click OK. 

8. Back in the Submit Request form, click Submit.

9. Optionally, click the Language, Schedule, and Options buttons to select 
language (s), submission schedules, and completion options. 

Note: You can use the Copy button to take advantage of previously entered request 
submissions.
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5.10 Setting up MES
Please see Section 5.17 Setting up Alerts.

5.11 Setting up Links for Related Documents
The steps below allow users to link related documents to defects and 
enhancements.

1. Log on to Oracle Forms as sysadmin. Select the CRM Administrator 
responsibility. Navigate to Task and Escalation Manager > Setup > Objects 
Meta-data. The Task Setup Object Types form appears.

2. Enter  values  for the related documents links in at least the four mandatory 
fields:

� Name

� Object Code

� Name Column

� ID Column

� From

3. In the Usage section, Enter DF_LINK for defects and ENH_LINK for 
enhancements in the Object User field.

4. Click Save from the menu bar.

5.  To verify that this option has been set up:

a. Log in to the application as a user.

b. Open up a defect or enhancement.

c. In the Defect or Enhancement Details page, click Link.

d. Scroll down to the bottom of the page. The Related Documents section 
should appear with the object listed in the drop-down.

5.12 Setting up Knowledge Base Submit for Defects
Because Knowledge Base is embedded in Oracle iSupport, it is necessary that the 
Oracle Quality Online Administrator also have the iSupport administrator role and 
the CS_KB_SYS_ADMIN responsibility. Please see  Section 5.6.2 Creating an FND 
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User and Assigning Responsibilities, and Section 5.6.4 Assigning JTF Roles to Each 
User.

To link Oracle Quality Online Note Types to Knowledge Base Statement Types:

1. Login to JTF as KM administrator. Navigate to SMS > Setup > Statement Types. 
The Statement Type page opens.

2. Select the appropriate statement type. The Statement Type details page opens.

3. Under the Related drop down box, select External Links. After page refreshes, 
click Add. The Select an External Object page appears.

4. Click Note Type link. The Note Type page opens. Click Go for a list of all JTF 
Note Types.

5. Select the Note Type. Click Update.

In order for the submission to take effect, run the Knowledge Base Sync Indexes 
concurrent program. Please see Chapter 6, Section 6.6 Concurrent Programs.

5.12.1 Associating/Disassociating a Statement Type to a Solution Type
To associate a statement type to a solution type:

1. Login to JTF as the Knowledge Management administrator. 

2. Navigate to SMS > Setup > Solution Types.  The Solution Types screen appears 
with a list of existing Solution Types. 

3. Click the Solution Type Number link.  The Solution Type screen for the Solution 
Type Number appears. 

4. Click Add/Delete button. The Associate Statement Types screen appears. 

5. To add a statement type to the existing solution, choose the desired statement 
type from the Available Statements Types box and assign (>) it to the Selected 
Statement Types box.  

6. To delete a statement type from the existing solution, choose the desired 
statement type from the Selected Statement Types box and use the arrow key 
(<) to move a statement that you want to disassociate to Available Statements 
Types box. 

7. Click Save to save the changes or click Cancel to restore the original values and 
return to the previous screen.
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5.13 Oracle Quality Online Administration
During the implementation of Oracle Quality Online and throughout the 
application lifespan, the Oracle Quality Online administrator must configure and 
modify the defect and enhancement management processes, standards, lookups 
and alerts. Chapter topics include:

� Before You Begin

� Setting up Processes

� Setting up Standards

� Setting up Lookups

� Setting up Alerts

� Setting up the Homepage

5.14 Before You Begin
Please note the following.

5.14.1 Understanding Sort Order 
� Seeded data comes in a default sort order. Removing, adding, or changing sort 

order indicators will cause the resulting drop down list to present the items 
with assigned sort order first. Those items- custom or seeded- without a sort 
order indicated will be listed in ASCII alphabetical order based on the Name 
field.

� All custom entry Names must be unique to allow for the above sort listing.

5.14.2 Understanding Start and End Effective Dates
Start and End Effective dates are not mandatory. They can be used to disable seeded 
data (see below) and for custom settings if desired.

5.14.3 Understanding Seeded Data
� If you disable seeded data, after having used it, but want to allow searches on 

the earlier information, set an Effective Date in the past for those seeded data 
items to make it visible in the LOV for searches.

� Changes made to seeded data will not be affected by future patches. 
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� To disable seeded (or custom) data, set an Effective Date for the value far into 
the future so that it does not show up in the LOV for searches. 

5.15 Setting up Processes
The Oracle Quality Online System Administrator configures the Defect and 
Enhancement workflow operations through Processes. 

5.15.1 Changing Responsibility within Oracle Quality Online
While performing administrative tasks, the Oracle Quality Online Administrator 
can switch Default Responsibility from within Oracle Quality Online in order to 
verify setup and/or changes.   

1. Navigate to Profile > Preferences. 

2. From the Default Responsibility drop down box, select the desired 
responsibility. Note that you must have a Responsibility for it to appear in the 
drop down box.

3. Click Update and Sign Out.

4. At the JTF login screen, click Go to log in with your changed Responsibility. 

5.15.2 Setting up Category Workflow Options
There are two Categories in Oracle Quality Online, Defects and Enhancements. 
There is one seeded workflow associated with both Categories. The Oracle Quality 
Online System Administrator assigns workflow parameters by category.

1. Log in to the JTF login page as the Oracle Quality Online Administrator.

2. Navigate to Process > Categories.

3. The seeded workflow NOTIFICATION_EMAIL is visible in the drop-down 
boxes associated with the Categories, Defect and Enhancement.

4. To automatically launch the workflow when a defect or enhancement is created, 
check Auto Launch Workflow for the desired category.

5. To end workflow when the defect or enhancement is closed, check Abort 
Workflow on Close.

6. Click Update to set the new values, or Restore to return to the previous values.
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5.15.3 Associating Types with Categories
Both defects and enhancements must be associated with Types. Types serve to 
classify the nature of the defect or enhancement and are useful for reporting 
purposes, template creation, and listing phases. They allow high level 
understanding of the kinds of problems users are experiencing and the changes 
they want in future releases. To avoid confusing users, it is recommended that you 
share phases for as many Types as possible. 

Seeded Defect Types include: 

� Data Corruption

� Documentation

� Installation

Note: For a complete list of Seeded Data, see Appendix B Seeded Data.

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Categories. 

2. Click the Types link in the Associate column. A list of all Types will be visible. 

3. To add a new Type enter a Name in the Name Field. Selecting a Sort Order will 
determine the placement of the new Type in the drop-down list. 

4. Enter a Description in the Description Field.

5. You may set Start and End Dates if desired.

6. Check Base Defect Required if necessary. 

7. If you need to clear the row for any reason click the eraser icon. 

8. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a type once it is created.

9. To add additional rows click the More Rows link or the down arrow.

Note: For a complete list of Seeded Data, see Appendix B Seeded Data.

5.15.4 Setting up Phases
Configurable phases are intended to reflect the high level business process steps for 
handling defects and enhancements and tracking progress from one stage to 
another. If desired, changing the phase can trigger assignment to the team or 
individual responsible for the next phase. Seeded Phases include:
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� Definition

� Resolution

� Customer Verification

Note: Phases should be kept to a minimum and reflect the actual processes involved 
in resolving defects and enhancements.

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Phases. A list of all Phases will be visible. 

2. To add a new Phase, enter a name in the Name Field.

3. Enter a description for the Phase in the Description field.

4. Select an option from the Phase Status Options column drop-down box.

5. You may set Start and End Dates if desired. 

6. If you need to clear the row for any reason click the eraser icon. 

7. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a Phase once it is created.

8. To add additional rows click the More Rows link or the down arrow.

5.15.5 Setting up Phase Statuses
Phase Statuses provide detailed Phase information. Phase Status should contain 
meaningful information about the associated Phase.  The relationship between 
Phase and Phase Status determines the valid defect statuses - open or closed. This 
allows you to enforce the capture resolution information. 

Seeded Defect Phase Statuses include:

� Awaiting Dependent Fix

� Could not Reproduce

� Defect Resolved 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Phases > Phase Statuses. A list of all Phase Statuses is 
visible. 

2. To add a Phase Status, enter a name in the Name field (e.g. Defect Resolved).

3. Enter a description in the Description field. 
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4. Check Base Defect Required and/or Fix Details Required if needed for this 
Phase Status.

5. If the Phase Status is equivalent to Resolved, check the Resolved checkbox. 

6. You may set Start and End Dates if desired. 

7. If you need to clear the row for any reason click the eraser icon. 

8. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a Phase Status once it is updated.

9. To add additional rows click the More Rows link or the down arrow.

Note: For a complete list of Seeded Data, see Appendix B Seeded Data.

5.15.6 Associating Phase Status with Existing Phase
After a Phase Status is created, it can then be associated with a Phase. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Phases. A list of all Phases will be visible. 

2. Click the Phase Status link in the Associated column for the Phase needing the 
association.

3. From the Phase Status column select a status from the drop-down list. Select a 
sort order if desired.

4. If you want the status to be Viewable While Open, or Viewable While Closed, 
check the relevant boxes. 

5. You may set Start and End Dates if desired.

6. If you need to clear the row for any reason click the eraser icon. 

7. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a Phase Status once it has been created.

8. To add additional rows click the More Rows link or the down arrow.

5.15.7 Associating Phases with Types
Types serve to classify the nature of the defect or enhancement. Types can be 
associated with a unique set of phases.

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Categories. 
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2. Click the Types link in the Associate column for a Category. A list of the 
Category Types will be visible.

3. Select a Type from the list by clicking on the Phases link in the Associate 
column. 

4. Select a Phase from the Phase Name column drop-down list. Select a Sort Order 
if desired.

5. Check Primary Contact Owns Phase if you want the primary contact to be 
phase owner. Otherwise Assignment Manager will assign owner based on 
defect attributes.

6. To set any phase as the default, check Default Phase. 

7. You may set Start and End Dates if desired.

8. If you need to clear the row for any reason click the eraser icon. 

9. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete an association once it has been entered.

10. To add additional rows click the More Rows link or the down arrow.

Note: For a complete list of Seeded Data, see Appendix B Seeded Data.

5.16 Setting up Standards
The Oracle Quality Online Administrator sets up and manages Templates, 
Resolution Times, and Note Token Rules. 

� Templates are set up to ensure that users provide required information when 
creating defects and enhancements. 

� Template Usage allows the administrator to designate where the template is 
enforced. 

� Template Prompts, which may be product specific, improve defect and 
enhancement information gathering. The administrator creates text 
prompts to appear in the template and sets a sort order if needed. 

� Resolution Times are set for defects based on internal product priorities and 
severity levels. 

� Setting Note Token Rules allows you to define parsing rules and destinations 
for  hyperlinking keywords in the Note Details display.
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5.16.1 Creating Templates
Templates assist users in creating well-formed defects. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Templates. A list of Templates will be visible. 

2. To create a new Template, enter a name in the Name field.

3. Enter a description in the Description field.

4. You may set Start and End Dates if desired.

5. If you need to clear the row for any reason click the eraser icon. 

6. Click Update to set the new values, or Restore to return to the previous values.

7. Once a Template has been created, edits to Usage and Prompts can be made. 
You cannot delete a Template once it has been created, but you can inactivate it 
by end-dating. 

8. To add additional rows click the More Rows link or the down arrow.

5.16.2 Setting Template Usages
1. Navigate to Standards > Templates. A list of Templates will be visible. 

2. Click the Usages link in the Edit column for the Template. The Template Usages 
page will be visible.

3. Select either Defect or Enhancement from the Category drop-down list. If you 
want the template applicable to the selected category only, proceed to step 8.

4. To associate the category specific template with a Type, select from the Type 
drop-down list. If you want the template applicable to the selected category and 
type only, proceed to step 8.

5. To associate the template with a specific product, click Go in the Product Name 
column. A product number and description LOV will be visible. 

6. Select the product by clicking on the link in the Number column. This populates 
the Number and Description fields in the Product Name column. 

7. You may clear the row before updating by clicking on the eraser icon.

8. Click Update to set the new values, or Restore to return to the previous values.

9. To remove an entry, check the Remove column.
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5.16.3 Setting up Template Prompts
Template prompts should be consistent across Products and Types, targeted and 
useful as all users must respond to the mandatory questions. 

A non-mandatory prompt can be added to the end of all Templates with an 
indication that it be used for critical severity defects only. Template prompt and 
response combined cannot exceed 2000 characters. 

You may wish to devise a visual format for entering prompts so as to distinguish 
between questions and answers. For example: 1. Question One, 2. Question Two, or 
Q1, Q2. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Templates.

2. Click the Prompts link in the Edit column for the Template. The Template 
Prompts page will be visible.

3. Enter your prompt text in the Prompt field. Select a Sort Order if desired.

4. In the Response Type column, select a text line variable, or the Yes/No Question 
option from the drop-down box. 

5. Check Response Required if a response is mandatory.

6. Check More Information Allowed if you want to provide users with the option 
of being able to add additional information.

7. You may clear the row before updating by clicking on the eraser icon.

8. Click Update to set the new values, or Restore to return to the previous values.

9. To remove an entry, check in the Remove column.

5.16.4 Setting Process Resolution Time
Setting Resolution Times allows the organization to define the levels of service 
required to complete the defect lifecycle. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Resolution Times.

2. Click Go next to the Number field in the Product column. A product number 
and description LOV will be visible 

3. Select the product by clicking on the link in the Number column. This populates 
the Number and Description fields in the Product column. 
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4.  In the Severity column, select a Severity from the drop-down list. 

5. In the Resolution column, select a desired increment in the Time field, then set a 
desired Unit of Measure (UOM).

6. Repeat the above step in the Closure column.

7. You may set Start and End Dates if desired.

8. Click Update to set the new values, or Restore to return to the previous values.

9. To add additional rows click the More Rows link or the down arrow.

5.16.5 Setting Note Token Rules
Setting Note Token Rules allows you to define parsing rules and destinations for  
hyperlinking keywords in the Note Details display.

To set Note Token Rules:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Note Token Rules.

2. Click Create Note Token Rule.

3. Enter a unique Sequence number in the Sequence text field. It does not have to 
be consecutive.  Sequences prioritize the rules that set token precedence.

4. Enter a description in the Description text field.

5. Set Start and End Dates, if desired, using the Calendar icon tool.

6. In the Token section, enter the  keyword to hyperlink in the Value field. (a name 
for the linked text, e.g. Bug, http://, etc.).

7. Set Preceding and Following Characters. The Preceding Delimiting Characters 
distinguish your token value from identical text values, and the Following 
Delimiting Characters determine where the hyperlink stops. For instance, if 
your bug link always begins after a colon and must end with a period, your 
Preceding Delimiting Character is a colon and your Following Delimiting 
Character is a period.

8. Check the appropriate checkboxes for the characters. These distinguish the 
Token and/or the Parameter from the rest of the text. For example, if you have a 
token bug with the Preceding Delimiting Characters Space checked, then a note 
with the word debug in it will not be hyperlinked because the word bug is not 
preceeded by a space.
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9. In the Parameter section, use the Type drop-down box to select a Parameter 
type.

10. Enter the Following Delimiting Characters for the parameter, if desired, and/or 
check the appropriate delimiting checkboxes. If No Parameter is selected, then 
the Following Characters, Minimum Length, and Maximum Length options are 
not allowed.

11. Enter your minimum and maximum length parameters.

12. In the Destination section, select a Type using the drop-down box. If your type 
is Function, select a User Function Name using the LOV.  If your type is URL, 
enter the base url in the Base URL text field.

13. Click Create.

5.17 Setting up Lookups
The Oracle Quality Online Administrator can configure site specific content for 
drop-down lists (lookups). Topics include :

� Setting Priorities

� Setting Severities

� Setting Languages

� Tracking Groups

� Setting Environment Variables

� Miscellaneous Lookups

5.17.1 Setting Priorities
Priorities allow identification and tracking of defect and enhancement significance 
based on internal priorities. To add to the seeded priorities: 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Priorities. A list of the seeded Priorities appears

2. To add a new Priority, enter a name in the Name Field.

3. Select a Sort Order if desired. 

4. Enter a description in the Description field.

5. You may clear the row before updating by clicking on the eraser icon.
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6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

5.17.2 Setting Severities
Severities are configurable codes that describe the seriousness of a Defect. In 
Enhancements, Severity equals Desirability. Severities are external standards chosen 
by users, as opposed to Priorities which are internally set. To add to the seeded 
Severities:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Severities.

2. Enter a name in the Name field. 

3. Select a Sort Order if desired. 

4. Enter a description in the Description field.

5. Select either Defect or Enhancement from the Category column drop-down list.

6. You may clear the row before updating by clicking on the eraser icon.

7. You may set Start and End Dates if desired. 

8. Click Update to set the new values, or Restore to return to the previous values.

9. To add additional rows click the More Rows link or the down arrow

5.17.3 Setting Languages
Defects and Enhancements can be logged for products available in multiple 
languages. To add a product language: 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Languages.

2. Enter the Language name in the Name field. 

3. Select a Sort Order if desired.

4. Enter a description for the Language in the Description field.

5. Select the language in the Oracle Application Language drop-down list.

6. You may clear the row before updating by clicking on the eraser icon.
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7. You may set Start and End Dates if desired.

8. Click Update to set the new values, or Restore to return to the previous values.

9. To add additional rows click the More Rows link or the down arrow.

Note: For all languages, enter All Languages in the Name and Description fields. 
Leave Oracle Application Language field blank. 

5.17.4 Tracking Groups
Tracking Groups allow development organizations to track particular defects. They 
can be used for targeted searches, and for special reporting requirements.  Tracking 
groups are particularly useful for reporting requirements that do not cross an entire 
organization or are group specific.

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Tracking Groups.

2. Enter a name for the Tracking Group in the Name field. 

3. Select a Sort Order if desired.

4. Enter a description for the Tracking Group in the Description field.

5. You may set Start and End Dates if desired.

6. Click Update to set the new values, or Restore to return to the previous values.

7. To add additional rows click the More Rows link or the down arrow.

5.17.5 Setting Environment Variables
Environment Variables are used for tracking additional environment information 
such as database version, browser version, etc. To set up your specific Environment 
Variables: 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookup > Environment Variables.

2. Enter a name in the Name field. 

3. Select a Sort Order if desired. 

4. Enter a description for the Environment Variable in the Description field.

5. You may set Start and End Dates if desired.

6. Click Update to set the new values, or Restore to return to the previous values.
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7. To add additional rows click the More Rows link or the down arrow.

5.17.6 Miscellaneous Lookups

5.17.6.1 Setting Reproducibility
Oracle Quality Online allows you to configure lists for determining how frequently 
a Defect can be reproduced. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous.

2. Select Reproducibility from the Attribute drop-down list. Click Go.

3. Enter a term for the Code in the Code field.

4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

5.17.6.2 Setting Lifecycle
In Oracle Quality Online, the product lifecycle stages are used with product 
versions to further refine the defect definition. Seeded Lifecycle stages are Alpha, 
Beta, Development, and Production. They appear in the Product Status drop down 
list in Defect Details. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous.

2. Select Lifecycle from the Attribute drop-down list. Click Go.

3. Enter a term for the Code in the Code field.

4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.
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5.17.6.3 Setting Source Modification Types
This step allows you to set Lookups for types of modifications. For example, Code, 
User Interface, or Documentation modifications. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous

2. Select Source Modification Types from the Attribute drop-down list. Click Go.

3. Enter a term for the Code in the Code field.

4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

5.17.6.4 Setting Link Type
Defects and Enhancements can be related and linked. Link Types in Oracle Quality 
Online reflect relationships between objects. They are configurable and allow 
relationship definitions to include dependencies. This step allows you to define 
those relationships and links. 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous.

2. Select Link Types from the Attribute drop-down list. Click Go.

3. Enter a term for the Code in the Code field.

4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

5.18 Setting up Alerts
Alerts are short messages from the system administrator reporting scheduled 
outages or system issues. The Alerts bin is viewable from the Homepage. The 
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Oracle Quality Online Administrator must be imported as a Resource with the MES 
Administrator Resource role assigned in order to create categories or groups, 
publish messages, and approve publishing items to a particular group. 

Topics include:

� Creating Groups

� Sending Alerts

5.18.1 Creating Groups 
In order for Alerts to work, it is necessary to create and manage groups. Group is the 
relevant link on the Alert Administration page. Groups are used to distribute 
content to users, and to classify content in the repository.

To create new groups:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Alerts > Alert Administration. Click Group from the Access and 
Managers bullet list. The Group Manager page appears.

2. Enter a name in the Group Name column.

3. Check the Administrator, Publish Content, and Approval checkboxes.

4. Assign the group to the profile, DEMS: Channel for System Alerts. This allows 
all users to receive alerts

5. Click Update.

5.18.2 Sending Alerts
To send Alerts:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Alerts > Send Alert. The Publish page will be visible.

2. From the Select an Item Type drop-down box, select Message.

3. Enter a title for the Alert in the Title field, then enter the author name in the 
Authors name field. 

4. Enter the message text in the Message field.

5. Enter the effective start date for the message.

6. Select either the Permanent radio button if the Alert is to be displayed 
indefinitely, or the Duration radio button if you want it to display for only a set 
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time. If selecting the Duration radio button, set duration values with the 
drop-down boxes.

7. Select a priority from the Priority drop-down list.

8. From the Available column in the Groups section, select the group and click 
Assign (>) to move your selection over to the Selected column.

9. Click Publish to Publish the Alert, or Clear to set the new values. 

5.18.3 Other Administrative Tasks
Frequently recurring tasks for the Oracle Quality Online Administrator include the 
following:

5.18.3.1 Finding a Platform
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Manufacturing and Distribution Manager responsibility. Navigate to Inventory 
> Items > Item Search. Select the appropriate organization. The Find Items form 
opens.

2. Select Item Categories from the Show LOV.

3. In the Category Set LOV, select the appropriate platform Category Set. In the 
Category LOV select the appropriate category. 

4. In the Platform Group query form, enter % and your search delimiters. Execute 
the query using Control F11. Select from the resulting list.

5. Click Find. Note the item number or description. 

5.18.3.2 Editing a Platform
1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 

Manufacturing and Distribution Manager responsibility. Navigate to Inventory 
> Items > Master Items. Select the appropriate organization.

2. Select the Find icon on the menu bar to display the Find Master Items form. 
Enter the item number 

3. Edit the Platform record as needed.

4. From File, select Save and Proceed.
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5.19 Setting up the Homepage
The Homepage is the landing page in Oracle Quality Online. It provides an 
overview of assigned and unassigned work, alerts and system information, and 
quick navigation to other key areas of the application. 

All Oracle Quality Online users must set up their Homepage options. 

5.19.1 Personalizing Homepage Content Options 
Users can choose what Key Defect and/or Enhancement Summary Views will 
appear on their Homepage. 

1. Select Profile and navigate to DEMS Profile > Home.

2. Select Defect and Enhancement Key Summary views using the checkboxes. 

3. Click Update to set the new values or Restore to return to the previous values.

5.19.2 Setting Defects Page Options

5.19.2.1 Customizing Note Details Display
To customize your Note Details displays on the Defect Details page:

1. Navigate to Profile > DEMS Profile > Defects.

2. Select a display option from the Show As Default LOV in the Details section. 
This determines the level of Note Details displayed in the Details section of a 
defect. 

3. Click Update or Restore. 

5.19.2.2 Customizing Defect Summary Views
1. Select Profile and navigate to DEMS Profile > Defects. 

2. From the Show As Default drop down box select your Defects default display 
option for the Defects page. The seeded values are Open Defects I Own, Defects 
with Open Tasks I Own, and Defects with Open Escalations I own.

3. In the View Name table, enable the seeded and/or custom Defect Summary 
Views options as desired. If you have entered custom Summary Views, you 
may remove them using the appropriate column. Select Update or Restore after 
you make any changes. 
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4. To add custom Defect Summary Views, click New Search. Input your criteria 
and select Search. Apply Summary Display Options if desired. Name your 
search in the Save Search As section. To save the resulting search as a Defect 
Summary View, Click Save and Apply Search. To save as the Summary Default 
View, select checkbox. 

5.19.2.3 Setting Defect Quick Creates Defaults
To set a Quick Create default display for the Defects page: 

1. Select Profile and navigate to DEMS Profile > Defects. 

2. Using the Show As Default drop down box in the Quick Creates section, select 
the Quick Create to display as default on the Defects page.

3. To remove Quick Creates check the Remove checkbox. 

4. To create new Quick Create viewing options click New Create to access the 
Create Page. After setting new Quick Create parameters, select Create to save 
the selection, Restore to return to the previous values, or Back to return to the 
Defects page. 

5. Click Update or Restore if you have made changes.

5.19.3 Setting Enhancements Page Options

5.19.3.1 Customizing Enhancement Note Details Display
To customize your Note Details displays on the Enhancement Details page:

1. Navigate to Profile > DEMS Profile > Enhancements.

2. Select a display option from the Show As Default LOV in the Details section. 
This determines the level of Note Details displayed in the Details section of an 
enhancement.

3. Click Update or Restore.

5.19.3.2 Customizing Enhancement Summary Views
1. Select Profile and navigate to DEMS Profile > Enhancements. 

2. From the Show As Default drop down box select your Enhancements default 
display option for the Enhancements page. The seeded values are Open 
Enhancements I Own and Defects with Open Enhancements I Own.
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3. In the View Name table, enable the seeded and/or custom Enhancement 
Summary Views options as desired. If you have entered custom Summary 
Views, you may remove them using the appropriate checkbox. Select Update or 
Restore if you have made any changes. 

4. To add custom Enhancement Summary Views, click New Search. Input your 
criteria and select Search. Apply Summary Display Options if desired.   Name 
your search in the Save Search As section. To save the resulting search as a 
Defect Summary View, Click Save and Apply Search. To save as the Summary 
Default View, select checkbox.

5.19.3.3 Setting Enhancement Quick Creates Defaults
To set a Quick Create default display for the Enhancements page: 

1. Select Profile and navigate to DEMS Profile > Enhancements. 

2. Using the Show As Default drop down box in the Quick Creates section, select 
the Quick Create to display as default on the Enhancements page.

3. To remove Quick Creates check the Remove checkbox. 

4. To create new Quick Create viewing options click New Create to access the 
Create Page. After setting new Quick Create parameters, select Create to save 
the selection, Restore to return to the previous values, or Back to return to the 
Defects page.

5. Click Update or Restore if you have made changes.
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Profile Options and Concurrent Programs

This chapter discusses system profile options and setups, and concurrent programs. 
Topics include:

� Before you Begin

� Setting Profile Options Overview

� Setting Oracle Quality Online System Profile Values

� Setting Other Profile Values

� Oracle Quality Online Profile and Internal Names

� Concurrent Programs

6.1 Before you Begin
Before making Oracle Forms settings, verify that Oracle Application is up and 
running. Because some setup steps require running concurrent programs, you must 
ensure that the Concurrent Managers are running. Consult your Applications 
System Administrator for additional information.

6.2 Setting Profile Options Overview
A profile is a set of changeable options that affect the way Oracle applications 
appear and how they function. Oracle Applications uses a set of profile options that 
are common to all the applications; in addition, each module has its own unique set 
of profile options. Profile options are set within the Oracle Forms Application. 

As System Administrator, you set profile options at four levels:
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� Site - Option settings pertain to all users at an installation site; has the lowest 
priority.

� Application - Option settings pertain to all users of any responsibility 
associated with the application; has the next-to-lowest priority.

� Responsibility - Option settings pertain to all users currently signed on under 
the responsibility; has the second-highest priority.

� User - Option settings pertain to an individual user, identified by application 
username; has the highest priority.

When a profile option may be set at more than one level, site has the lowest priority, 
superseded by application, then responsibility, with user having the highest 
priority. For example, a value entered at the site level may be overridden by values 
entered at any other level; a value entered at user level has the highest priority and 
overrides values entered at any other level. The values you set at each level provide 
run-time values for each user’s profile options. An option’s run-time value becomes 
the highest-level setting for that option. 

As System Administrator, you should set site-level option values before specifying 
profile options at the other three levels. The options specified at site-level work as 
defaults until the same options are specified at the other levels. 

Changes to the profile option values take effect as soon as your users log on again 
or change responsibilities.

6.3 Setting Oracle Quality Online System Profile Values
 To set Oracle Quality Online System Profile Values for the site:

1. Log into Oracle Forms as sysadmin. From the Responsibilities menu, navigate 
to System Administrator >Profile > System.

2. In the Find System Profile Values form, check Site. Enter DEMS% in the Profile 
text box and hit Return or click Find. The System Profile Values form lists the 
default values for the following:

1. DEMS: Advanced Search Fetch Size (Rows): Specifies the number of rows the 
Advanced Search Query will return at any one time. Valid Values: an 
integer that divides evenly into Advanced Search Maximum rows.

2. DEMS: Advanced SearchKeep Results (Minutes): Specifies the number of 
minutes to keep previously cached query results for users. Valid Values: an 
integer
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3. DEMS: Advanced Search Maximum number of Criteria: Specifies the maximum 
number of search criteria for an Advanced Search. Valid Values: an integer 
greater than Minimum number of Criteria.

4. DEMS: Advanced Search Max Returned Size (Rows): Specifies the maximum 
number of rows the Advanced Search query is allowed to return. Valid 
Values: An integer.

5. DEMS: Advanced Search Minimum number of Criteria: Specifies the minimum 
number of search criteria for an Advanced Search. Valid Values: an integer, 
less than Maximum number of Criteria.

6. DEMS: Defect Default Note Type: Specifies default Note Type for defect 
creation. 

7. DEMS: Enhancement Default Note Type: Specifies default Note Type for 
enhancement creation.

8. DEMS: Override Revision Control Flag of Component: Specifies whether 
Revision Control Flag of Component will be used to validate Component 
Revision. If set to No, Revision will NOT be stored in DEMS tables locally 
and user must either select from the valid version LOV or if there is no LOV 
no version can be entered. If set to Yes, Revision will be stored in DEMS 
tables locally and user can enter free format data. 

Note: Data migration will be required if this is changed once there are Defects 
and/or Enhancements in the system. 
9. DEMS: Override Revision Control Flag of Platform: Profile to indicate whether 

Revision Control Flag of Platform will be used to validate Platform 
Revision or not. If set to No, Revision will NOT be stored in DEMS tables 
locally and user must either select from the valid version LOV or if there is 
no LOV no version can be entered. If set to Yes, Revision will be stored in 
DEMS tables locally and user can enter free format data.   

Note: Data migration will be required if this is changed once there are Defects 
and/or Enhancements in the system. 
10. DEMS: Override Revision Control Flag of Product:Profile to indicate whether 

Revision Control Flag of Product will be used to validate Product Revision 
or not. If set to No, Revision will NOT be stored in DEMS tables locally and 
user must either select from the valid version LOV or if there is no LOV no 
version can be entered. If set to Yes, Revision will be stored in DEMS tables 
locally and user can enter free format data.

Note: Data migration will be required if this is changed once there are Defects 
and/or Enhancements in the system.
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11. DEMS: Override Revision Control Flag of Subcomponent: Profile to indicate 
whether Revision Control Flag of Subcomponent will be used to validate 
Subcomponent Revision or not. If set to No, Revision will NOT be stored in 
DEMS tables locally and user must either select from the valid version LOV 
or if there is no LOV no version can be entered. If set to Yes, Revision will be 
stored in DEMS tables locally and user can enter free format data.

Note: Data migration will be required if this is changed once there are Defects 
and/or Enhancements in the system.
12. DEMS: Platform Required for Defect: This Profile indicates whether or not a 

Platform is required for Defect creation. If set to Yes, a Platform is required. 
If set to No, a Platform is required only if the Platform Specific Flag is 
checked.

Note: Data migration will be required if this is changed once there are Defects 
and/or Enhancements in the system.
13. DEMS: Severity for Defect Alert: If the Defect is logged, or moved to this 

Severity an Alert will be sent to the assignee.

14. DEMS: Time Unit of Measure Class: Profile to indicate Unit of Measure Class 
for the Resolution and Closure Time UOM. Base UOM for this Class must 
be equivalent to one hour.

15. DEMS: Channel for System Alerts on Homepage: Specifies the MES channel for 
system alerts for the Homepage. Valid Values: any active and public 
regular group.

16. DEMS: Note More Information Allowed: Provides user with the ability to enter 
additional information into Note CLOB.

17. DEMS: Note Summary Size for Note Summarized View: Specifies the number of 
characters allowed in the Notes Summary View.

6.4 Setting Other Profile Values
There are additional profile values that must be set for Oracle Quality Online to 
function correctly.

1. Service: Default Platform Category Set: All the items assigned to this Category Set 
will be identified as Platforms.

2. Service: Default Category Set: All the Categories of this Category Set will be used 
for the purpose of executive reporting.
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3. Service: Inventory Validation Organization: Maps Inventory/Product 
Organization.

6.4.1  Setting JTF Application-Level Profile Options
First you must set application-level profile options:

1. Log on to Oracle Forms as sysadmin by using the link provided by your System 
Administrator: http://<hostname>:<Port_number>/dev60cgi/f60cgi.

2. Select the System Administrator Responsibility.

3. Navigate to Profile > System. The Find System Profile Values form opens.

4. Check Application only, uncheck Site if necessary and enter Support.

5. In the Profile field, enter JTF_PROFILE%, and select Find.

6. Verify and/or set the following JTF profile option at application level for Oracle 
Support:

� JTF_PROFILE_DEFAULT_APPLICATION - This is the default application 
ID. Set it to 514.

7. On the same screen, verify and/or set the following profile option at 
application level for Oracle Support:

JTF_PROFILE_DEFAULT_RESPONSIBILITY - This is the default user responsibility 
ID and determines the menu structure the user sees when logging onto the HTML 
tech stack.

To determine the Responsibility ID:

1. Log on to Oracle Forms by opening http://<host>:<web port>/, then selecting 
Apps Logon Links > VIS Logon through the Forms cartridge (UNIX).

2. Log on as sysadmin.

3. Select the System Administrator Responsibility.

4. Navigate to Security > Responsibility > Define

5. Enter query mode by selecting F11. Enter DEMS User in the Responsibility field. 
Select Control F11 to execute query. 

6. From the main menu, go to Help > Diagnostics > Examine. The Enable 
Diagnostics window opens. Enter password assigned to you.

7. From the Field LOV, choose RESPONSIBILITY_ID.
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Note the value of the Value Field.

6.4.2 Setting up the Service Profile Options
Use the following steps to set the Service profile options. 

1. Log into Oracle Forms as sysadmin. From the Responsibilities menu, navigate 
to System Administrator > Profile > System.

2. In the Find System Profile Values form, check the Site and Profiles with No 
Values Boxes only. Enter Service% in the Profile text box and hit Return. 

� To map your Inventory/Product Organization: In the Profile column locate 
Service: Inventory Validation Organization. Enter the name of your 
Inventory/Product organization in the Site column.

� To facilitate executive reporting: In the Profile column locate Service: 
Default Category Set.

� To identify assigned items as Platforms: In the Profile column locate 
Service: Default Platform Category Set.

3. Click diskette icon in menu bar to save. Close form.

6.5 Oracle Quality Online Profile and Internal Names
The table below lists Profile names and the corresponding internal names.

Profile Name Internal Name

DEMS: Advanced Search - Fetch Size 
(Rows

CSS_DEF_ADV_SEARCH_FETCH_SIZE

DEMS: Advanced Search - Keep Results 
(Minutes)

CSS_DEF_ADV_SEARCH_CACHE_TIME_
LIMIT

DEMS: Advanced Search - Max Number of 
Criteria

CSS_DEF_ADV_SEARCH_MAX_FILTERS

DEMS: Advanced Search - Max Returned 
Size (Rows 

CSS_DEF_ADV_SEARCH_MAX_ROWS

DEMS: Advanced Search - Min Number of 
Criteria

CSS_DEF_ADV_SEARCH_MIN_FILTERS

DEMS: Defect Default Note Type CSS_DEF_DEFAULT_NOTE_TYPE

DEMS: Note More Information Allowed CSS_DEF_NOTE_MORE_INFO_
ENABLED
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6.6 Concurrent Programs
Oracle Quality Online requires that you run specific Concurrent Programs in order 
to update data when it is modified. These can be run from Oracle Forms in the 
System Administrator responsibility at the Requests node or in the relevant 
administration responsibility for the application being updated. 

DEMS: Note Summary Size for Note 
Summarized View

CSS_DEF_NOTE_SUMMARY_SIZE

DEMS: Enhancement Default Note Type CSS_ENH_DEFAULT_NOTE_TYPE

DEMS: Override Revision Control Flag of 
Component

CSS_DEF_COMP_REV_VALDN_RULE

DEMS: Override Revision Control Flag of 
Platform

CSS_DEF_PLAT_REV_VALDN_RULE

DEMS: Override Revision Control Flag of 
Product

CSS_DEF_PROD_REV_VALDN_RULE

DEMS: Override Revision Control Flag of 
Subcomponent

CSS_DEF_SUBCOMP_REV_VALDN_
RULE

Service: Default Platform Category Set CS_SR_PLATFORM_CATEGORY_SET

DEMS: Platform Required for Defect CSS_DEF_PLATFORM_REQUIRED

DEMS: Product Certification Category Set CSS_DEF_PROD_CERTN_CAT_SET

Service: Default Category Set CS_SR_PRODUCT_CATEGORY_SET

DEMS: Channel for System Alerts on 
Homepage

CSS_DEF_SYSTEM_ALERT_CHANNEL

DEMS: Severity for Defect Alert CSS_DEF_DEFAULT_SEVERITY1_ID

DEMS: Time Unit of Measure Class CSS_DEF_UOM_CLASS

Service: Inventory Validation Organization CS_INV_VALIDATION_ORG

Profile Name Internal Name
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The table below lists the concurrent programs for DEMS and their descriptions.

Program Name Description

Generate Territory Packages Changes to Territories will not take effect 
until this request has been run.

Warning: Running this request will 
re-create a database package used in all 
defect creates and updates. Avoid 
scheduling this during peak hours.

Synchronize Employee Changes to Human Resources will not be 
affected in Resources until this request has 
been run.

Notification Mailer Enables workflow email notification. To set 
parameters, you must know the location of 
the configuration file on the environment 
where you will start the workflow 
notification mailer.

DEMS InterMedia Index Optimization Performs an interMedia OPTIMIZE on 
CSS_DEF_DEFECT_TL_C1 index.

DEMS InterMedia Index Synchronization Performs an interMedia SYNC on CSS_
DEF_DEFECT_TL_C1 index. 

Knowledge Base Sync Indexes Updates Knowledge Base with defects 
submitted from DEMS. Must be run before 
defects can be searched for in Knowledge 
Base. 
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Appendix A User Permissions

This Appendix provides detailed information about the Oracle Quality Online User 
Permissions. 

� User Permissions

� User Role to Permission Mapping

A.1 User Permissions

A.1.1 User Role to Permission Mapping
The following tables summarize Oracle Quality Online Role to Permission 
Mapping.

A.1.1.1 DEMS Administrator
Note that the DEMS administrator should have all available DEMS roles. The table 
below lists only those roles and permissions specific to Oracle Quality Online 
administrative tasks. 
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The following table lists the Roles and Permissions for the DEMS Administrator 

Role/Description Permission/Description 

CSS_DEF_ADMIN

DEMS Administration  

 

CSS_DEF_ADMIN_ENV_VARIABLE_MODIFY

View/Create/Update Environment Variables

CSS_DEF_ADMIN_TRACKING_GROUP_MODIFY

View/Create/Update Tracking Groups
CSS_DEF_ADMIN_PROCESS_MODIFY
View/Create/Update Processes
CSS_DEF_ADMIN_LOOKUP_MODIFY
View/Create/Update Lookups
CSS_DEF_RESOLUTION_MODIFY
View/Create/Update Response Times
CSS_DEF_TEMPLATE_MODIFY
View/Create/Update Templates
CSS_DEF_LOV_VIEW
View List of Values

CSS_DEF_DEFECT_MASS_ 
UPDATE_ADMIN

Admin Defect Mass Update 

CSS_DEF_DEFECT_MASSUPDATE_ADMIN
Perform Mass Update Defects

CSS_DEF_ENH_MASS_UPDATE_
ADMIN
Admin Enhancement Mass Update

CSS_DEF_ENH_MASSUPDATE_ADMIN 

Perform Mass Update Defects

CSS_DEF_NOTE_TOKEN_
SUMMARY

CSS_DEF_NOTE_TOKEN_SUMMARY

Note Token Rule Summary

CSS_DEF_NOTE_TOKEN_
MODIFY

CSS_DEF_NOTE_TOKEN_MODIFY

Note Token Rule Setup
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A.1.1.2 DEMS User
  The following table lists the Roles and Permissions for the DEMS User.

Role/Description Permission/Description

Defects:

CSS_DEF_DEFECT_MODIFY_USER

Comprehensive User Defect Handling

CSS_DEF_DEFECT_ADD

Create Defect

CSS_DEF_DEFECT_MODIFY

View/Update Defect

CSS_DEF_DEFECT_NOTE_READONLY

View Defect Note

CSS_DEF_DEFECT_ATTACH_MODIFY

Download/Upload Defect Attachments

CSS_DEF_DEFECT_CUST_PREVIEW_VIEW

View Customer View of a Defect

CSS_DEF_DEFECT_PRINT_PREVIEW_VIEW

Printer Friendly Format of Defect Detail

CSS_DEF_DEFECT_ESC_MODIFY

View/Search/Edit/Create Escalation

CSS_DEF_DEFECT_REPORT

View/Update/Create Defect Reports

CSS_DEF_DEFECT_SERVICE_REQUEST_VIEW

View Defect Related Service Requests

CSS_DEF_DEFECT_SOURCE_MODIFY

View/Search/Create/Edit Source Code

CSS_DEF_DEFECT_SUMMARYVIEW_VIEW

View Defect Summary

CSS_DEF_DEFECT_SUMMARY_PRINT_VIEW

Print Preview Defect Summary

CSS_DEF_DEFECT_TASK_MODIFY

View/Edit/Search/Defect Tasks

CSS_DEF_HOME_PAGE_VIEW

View the Homepage

CSS_DEF_DEFECT_VIEW

View Defects

CSS_DEF_LOV_VIEW

View List of Values
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Defects (Optional)

CSS_DEF_DEFECT_KB_SUBMIT 

Submit Defect to Knowledge Base

CSS_DEF_DEFECT_MASS_UPDATE_REG

User Mass Update

CSS_DEF_DEFECT_RESOLUTION 

Defect Resolution Handling

CSS_DEF_DEFECT_NOTE_MODIFY

Defect Note Handling 

CSS_DEF_DEFECT_KB_SUBMIT 

Submit Defect to Knowledge Base

CSS_DEF_DEFECT_MASSUPDATE_REGULAR

 Mass Update Defects

CSS_DEF_DEFECT_RESOLUTION 

Change any field in Defect Resolution Section

CSS_DEF_DEFECT_NOTE_MODIFY 

Change any Defect Note

Role/Description Permission/Description
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Enhancements:

CSS_DEF_ENH_MODIFY_USER 

Comprehensive User Enhancement Handling

CSS_DEF_ENH_ADD

Create Enhancement

CSS_DEF_ENH_MODIFY

View/Update Enhancement

CSS_DEF_ENH_NOTE_READONLY

View Enhancement Note

CSS_DEF_ENH_ATTACH_MODIFY

Download/Upload Enhancement Attachments

 CSS_DEF_ENH_CUST_PREVIEW_VIEW

View Customer View of Enhancements

 CSS_DEF_ENH_PRINT_PREVIEW_VIEW

Printer Friendly Format of Enhancement

CSS_DEF_ENH_REPORT

View/Update/Create Enhancement Reports

CSS_DEF_ENH_SERVICE_REQUEST_VIEW

View Enhancement Related Service Requests

CSS_DEF_ENH_SUMMARYVIEW_VIEW

View Enhancement Summary

 CSS_DEF_ENH_SUMMARY_PRINT_VIEW

Print Preview Enhancement Summary
 CSS_DEF_ENH_TASK_MODIFY

View/Edit/Search Enhancement Tasks
CSS_DEF_HOME_PAGE_VIEW

View Homepage

CSS_DEF_ENH_VIEW

View Defects

 CSS_DEF_LOV_VIEW

View List of Values

Enhancements (Optional)

CSS_DEF_ENH_MASS_UPDATE_REG

Mass Update Enhancement

CSS_DEF_ENH_RESOLUTION

Enhancement Resolution Handling

CSS_DEF_ENH_NOTE_MODIFY

 Enhancement Note Handling

CSS_DEF_ENH_MASSUPDATE_REGULAR

Perform Mass Update Enhancements

CSS_DEF_ENH_RESOLUTION

Change any field in Enhancement Engineering 
Resolution section

CSS_DEF_ENH_NOTE_MODIFY

Change any Enhancement Note

Role/Description Permission/Description
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Appendix B Seeded Data

This Appendix contains information about seeded data in Oracle Quality Online.

B.1 Seeded Data
The seeded data in Oracle Quality Online allows the user to leverage out of the box 
attributes and predefined parameters. Oracle Quality Online can accommodate 
additional attributes to fit your business processes. The following is a 
comprehensive list of the seeded data currently included in the application.

B.1.1 Types
The following table lists the Seeded Types for Defects and Enhancements.

Category Types

Defect Performance

User Interface

Integration

Stability

Installation

Data Corruption

Documentation

Translation
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B.1.2 Phases and Phase Statuses
The following table lists seeded Phases and Phase Statuses for Defects.

Enhancement Strategic

Functional

Integration

User Interface

Documentation

Performance

Phase Phase Status

Combination Valid 
when Open?

Combination Valid 
when Closed?

Definition Need more Information

Could not Reproduce

Open, Closed

Open, Closed

Response Under Review Open

Resolution Under Diagnosis

Work In Progress

Awaiting Dependent Fix (Base Defect 
Required)

Open

Open

Open

Quality Assurance Defect Resolved (Resolved, Fix Details 
Required)

Open

Documentation Defect Resolved (Resolved, Fix Details 
Required)

Open

Customer Verification Obsolete Configuration (Resolved)

Third Party Problem (Resolved)

Environment Problem (Resolved)

Not Feasible to Fix (Resolved)

Not a Defect (Resolved)

Duplicate Defect (Resolved, Base Defect 
Required)

Defect Resolved (Resolved, Fix Details 
Required)

Open, Closed 

Open, Closed

Open, Closed

Open, Closed 

Open, Closed 

Open, Closed

Open, Closed 

Category Types
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The following table lists seeded Phases and Phase Statuses for Enhancements

B.1.3 Seeded Territory Qualifiers
The following table lists Seeded Territory Qualifiers.

Phase Phase Status

Combination Valid 
when Open?

Combination Valid 
when Closed?

Request Need more Information Open, Closed

Functional Review Request Rejected (Resolved)

Duplicate Request (Resolved, Base 
Defect Required)

Closed

Closed

Technical Review Request Rejected (Resolved)

Duplicate Request (Resolved, Base 
Defect Required)

Closed

Closed

External Review none

Approved none

Scheduled Request Implemented (Resolved, Fix 
Details Required)

Closed

Seeded Territory Qualifiers:

Product Customer

Product Version Type

Component Internal Priority

Component Version Lifecycle

Sub-component Platform Specific Flag

Sub-component Version Phase Status

Platform Language

Platform Version Category

Customer Type Severity/Desirability
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B.1.4 Other Seeded Data
The following table lists additional Seeded Data

Classification Seeded Data

Severity Complete Service Loss

Severe Service Loss

Minimal Service Loss

No Service Loss

Desirability Extremely Desirable

Very Desirable

Somewhat Desirable

Minor Improvement

Priority Critical

High 

Medium 

Low 

Not Scheduled

Production Status Production 

Beta

Alpha

Development 

Reproducibility Always

Intermittent

Once

Languages All Languages

Defect Note Types Problem Statement

Normal Statement

Workaround

Action

Symptom

Cause

Fact

Objective
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Enhancement Note Types Enhancement Request

Business Justification

Response

Relationship Types Base

Related

Source Modification Types Functional

User Interface

Documentation

Enhancement Templates Enhancement Request and Business Need

Defect Task Types General

Enhancement Task Types General

Defect Task Priorities Critical

High

Medium

Low

Enhancement Task Priorities Critical

High

Medium

Low

Classification Seeded Data
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Appendix C Territory Setup

This appendix provides an example of a Territory Setup.

C.1 Example of Territory Setup
Example: Presuming that the territories are set up based on Products

Territory 1 --> No. of Winners = 1, Product = Oracle Quality Online

Territory 2 --> No. of Winners = 1, Product = TeleService

In the above case, ranks do not make sense as the two parents have distinct qualifier 
values (One defect can never have two products). However, rank cannot be a 
negative integer.

Territory 1 has the following children:

� Territory 3 --> Rank = 1, Phase = Definition

� Territory 4 --> Rank = 2, Type = Functional

Territory 2 has the following children:

� Territory 5 --> Rank = 1, Phase = Definition

� Territory 6 --> Rank = 2, Type = Functional

If a defect is logged against Oracle Quality Online with Type as Functional and 
Phase as Definition, then Territory 3 is selected as it has the lowest Rank. If a defect 
is logged against Oracle Quality Online with Type as Functional and Phase as QA, 
Territory 4 is selected and if defect is logged against Oracle Quality Online with 
Type as Performance and Phase as QA then Territory 1 is selected. In this case, 
Territory 1 is acting as a placeholder (aka Catch All for Product Oracle Quality 
Online).
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If you create another territory with Product as Oracle Quality Online and log a 
defect against Oracle Quality Online, you will get Defect falls in multiple territories 
error as two territories are based on Product Oracle Quality Online. The same error 
occurs when you have two territories under Territory 1 with Phase as Definition. If 
a defect is logged against a Product, which is neither Oracle Quality Online nor 
TeleService, then you will get No Resources Found error.
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