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Preface

This manual describes the administration and use of Oracle Quality Online. 

Topics include:

� Intended Audience

� Structure

� Related Documentation and Training

� Recommended Browser

� Documentation Accessibility

� Do Not Use Database Tools to Modify Oracle Applications Data

� About Oracle

Intended Audience
This guide is aimed at the following users:

� Technical Service Representatives (TSR)

� Customer Service Representatives (CSR)

� System Administrators, Database Administrators (DBA), Oracle Quality Online 
Administrators, and other IT professionals who are responsible for 
implementing and maintaining Oracle Quality Online. 

This guide assumes you have the following prerequisites: 

� Understanding of the company business processes.

� Knowledge of products and services as defined by your marketing policies.
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� Basic understanding of Oracle applications and Developer/2000.

� Basic understanding of SQL, PL/SQL, SQL* Plus programming.

Structure
This guide is organized into three main sections:

� Understanding Oracle Quality Online provides an overview of the application 
and its functions, key terms, its relationship to other Oracle applications. 

� Administering Oracle Quality Online provides explanations and task-based 
details for the person responsible for administering Oracle Quality Online. 

� Using Oracle Quality Online provides step-by-step instructions for using 
Oracle Quality Online.

Related Documentation and Training
Oracle Quality Online shares business and setup information with other Oracle 
Applications products. Therefore, you may want to refer to other user guides when 
you set up and use Oracle Quality Online. You can read the guides online by 
choosing Library from the expandable menu on your HTML help window, by 
reading from the Oracle Applications Document Library CD included in your 
media pack, or by using a Web browser with the following URL: 
http://docs.oracle.com. A list of suggested guides follows: 

Customer Relationship Management (CRM) Foundation
� Oracle Quality Online Implementation Guide Release 11i

� Oracle CRM Foundation Implementation Guide Release 11i

� Oracle CRM Foundation Concepts and Procedures Release 11i

� Oracle CRM Technology Foundation Implementation Guide, Release 11i

� Oracle CRM Technology Foundation Concepts and Procedures, Release 11i

� Implementing Oracle CRM: ERP Functional Checklist Release 11i

� Implementing Oracle CRM: Foundation Functional Checklist Release 11i

� Implementing CRM Applications Release 11i

� Oracle Marketing Encyclopedia System Release 11i

� Installing Oracle Applications Release 11i
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� Oracle Applications Concepts Release 11i

� Oracle Applications System Administrator’s Guide

� Supplemental CRM Installation Steps Release 11.5.1-11.5.3 

Enterprise Resource Planning (ERP)
� Implementing Oracle HRMS Release 11i

� Oracle Inventory User’s Guide Release 11i

� Oracle Bills of Material User’s Guide Release 11i

� Oracle Receivables User Guide Release 11i

Oracle Service Request
� Oracle Support Concepts and Procedures Release 11i

� Oracle Support Implementation Guide Release 11i

Training and Support

Training
Oracle offers training courses to help you and your staff master Oracle Quality 
Online and reach full productivity quickly. You have a choice of educational 
environments. You can attend courses offered by Oracle University at any one of 
our many Education Centers, you can arrange for our trainers to teach at your 
facility, or you can use Oracle Learning Network (OLN), Oracle University’s online 
education utility. In addition, Oracle training professionals can tailor standard 
courses or develop custom courses to meet your needs. For example, you may want 
to use your organization’s structure, terminology, and data as examples in a 
customized training session delivered at your own facility.

Support
From on-site support to central support, our team of experienced professionals 
provides the help and information you need to keep Oracle Quality Online working 
for you. This team includes your Technical Representative, Account Manager, and 
Oracle’s large staff of consultants and support specialists with expertise in your 
business area, managing an Oracle8i server, and your hardware and software 
environment.
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OracleMetaLink
OracleMetaLink is your self-service support connection with web, telephone menu, 
and e-mail alternatives. Oracle supplies these technologies for your convenience, 
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain 
information and advice from technical libraries and forums, download patches, 
download the latest documentation, look at bug details, and create or update TARs. 
To use MetaLink, register at (http://metalink.oracle.com).

Alerts: You should check OracleMetaLink alerts before you begin to install or 
upgrade any of your Oracle Applications. Navigate to the Alerts page as follows: 
Technical Libraries/ERP Applications/Applications Installation and 
Upgrade/Alerts.

Self-Service Toolkit: You may also find information by navigating to the 
Self-Service Toolkit page as follows: Technical Libraries/ERP 
Applications/Applications Installation and Upgrade.

Recommended Browser
Oracle recommends the use of Microsoft Internet Explorer 5.5 or later for use with 
its CRM applications.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle Corporation is actively engaged with other 
market-leading technology vendors to address technical obstacles so that our 
documentation can be accessible to all of our customers. For additional information, 
visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
JAWS, a Windows screen reader, may not always correctly read the Java and 
SQL*Plus code examples in this document. The conventions for writing Java and 
SQL*Plus code require that closing braces should appear on an otherwise empty 
line; however, JAWS may not always read a line of text that consists solely of a 
bracket or brace.
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Accessibility of Links to External Web Sites in Documentation 
This documentation may contain links to Web sites of other companies or 
organizations that Oracle Corporation does not own or control. Oracle Corporation 
neither evaluates nor makes any representations regarding the accessibility of these 
Web sites. 

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
Browser, database triggers, or any other tool to modify Oracle Applications data 
unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of 
your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using 
Oracle Applications can update many tables at once. But when you modify Oracle 
Applications data using anything other than Oracle Applications, you may change a 
row in one table without making corresponding changes in related tables. If your 
tables get out of synchronization with each other, you risk retrieving erroneous 
information and you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications 
automatically checks that your changes are valid. Oracle Applications also keeps 
track of who changes information. If you enter information into database tables 
using database tools, you may store invalid information. You also lose the ability to 
track who has changed your information because SQL*Plus and other database 
tools do not keep a record of changes.

About Oracle
Oracle Corporation develops and markets an integrated line of software products 
for database management, applications development, decision support, and office 
automation, as well as Oracle Applications, an integrated suite of more than 160 
software modules for financial management, supply chain management, 
manufacturing, project systems, human resources and customer relationship 
management.

Oracle products are available for mainframes, minicomputers, personal computers, 
network computers and personal digital assistants, allowing organizations to 
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integrate different computers, different operating systems, different networks, and 
even different database management systems, into a single, unified computing and 
information resource.

Oracle is the world’s leading supplier of software for information management, and 
the world’s second largest software company. Oracle offers its database, tools, and 
applications products, along with related consulting, education, and support 
services, in over 145 countries around the world.
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                                          Understanding Oracle Quality O
1

Understanding Oracle Quality Online

This chapter provides an overview of the features and benefits of Oracle Quality 
Online. Topics include:

� What is Oracle Quality Online?

� Mandatory Dependencies

� Conditional Dependencies

� New in this Release

� Key Terms and Functionality

1.1 What is Oracle Quality Online?
Oracle Quality Online is a comprehensive, web based product that allows 
companies to manage the internal application development process by tracking 
product defects and enhancements. Defects are primarily identified by customer 
support representatives, developers, and/or quality assurance engineers. Allowing 
users to log new and review existing enhancements , the company gathers strategic 
information for user oriented functionality that helps them remain competitive.

Key features and benefits of Oracle Quality Online include the following:

� Configurable process management: Organizations can configure the software to 
mirror their own defect and enhancement management processes. 

� Build better products: Product quality metrics are classified, gathered, and 
reported within defects, and functional suggestions are tracked within 
enhancements. 

� Flexible prioritization: Each organization can configure prioritization criteria to 
ensure compliance with their service level goals. 
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What is Oracle Quality Online?
� Close the service process loop: Organizations can achieve high levels of 
efficiency through the integration of their defect management process with 
other products in the Oracle CRM suite. 

� Personalization: A powerful search and save mechanism allows users to create 
saved searches, saved creates, and saved reports that provide relevant 
information on demand. 

An overview of the functionalities of these modules is presented here. The 
remaining chapters of this guide detail the steps for administering and using Oracle 
Quality Online

1.1.1 Creating Defects Process Flow
In order to ensure quick and accurate resolution, it is critical to enter as much 
information as possible when filing a defect:

� Provide a concise description of the observed behavior.

� Detail any workarounds and note any possible causes.

� Provide environment specific steps for reproducing the problem.

� Detail steps to provide a stand alone test case.

The following diagram illustrates a high level Creating Defects process workflow.

Figure 1–1   Creating Defects Process Flow
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Mandatory Dependencies
1.1.2 Creating Enhancements Process Flow
Enhancements are requests for additional functionality. It is important to clearly 
describe your requested change to the product. For example:

� Abstract what is required instead of providing an actual design

� Use business scenarios to explain how the requested change would be used.

� Provide an estimate of how useful the requested change will be

The following diagram illustrates a high level Creating Enhancements process 
workflow.

Figure 1–2  Creating Enhancements Process Flow 
                                                                                                      

1.2 Mandatory Dependencies
Oracle Quality Online relies on several Customer Relationship Management (CRM) 
Oracle and Enterprise Resource Planning (ERP) modules for its data and 
functionality. 

1.2.1 Oracle Customer Relationship Management (CRM) Foundation
Oracle CRM Foundation provides the core application components, functionality, 
and data for Oracle Quality Online. 
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Mandatory Dependencies
For information on CRM Foundation usage, please see the Other Sources of 
Information section in the Preface of this guide. 

� Notes: Notes record descriptive, textual information generated by users about 
defects and enhancements.

� Resource Manager: Resource Manager: Resources are the employees required 
to accomplish objectives. Resource Manager is used to import and view 
resources, define resources and roles, create teams and groups, and organize 
resources within those teams and groups. Note the following:  

� It is necessary to import employees who will be Primary Contacts or 
owners into Resource Manager to enable Owner and Primary Contact 
assignments.

� The user functioning as the Oracle Quality Online Administrator must be 
imported as a resource with the MES Administrator Resource role in order 
to be able to set up MES.  

� A Defect and/or Enhancement Owner must have the Defect and 
Enhancement Owner role  (usually a developer or someone involved in the 
solution process).

�  A Primary Contact must have the Defect and Enhancement Primary 
Contact role (a primary contact not involved in the resolution process). 

�  It is necessary to run the Synchronize Employee concurrent request in 
order for changes to an existing resource to become effective.

�  Territory Manager: Territory Manager is a tool allowing you to define the rules 
for automatic assignment of defects and enhancements.

� Assignment Manager: Assignment Manager is the assignment engine. The 
assignment process uses criteria based on preferred Resources, qualifiers and 
Territories. It is necessary to set up Assignment Manager to automatically 
assign all Defects and Enhancements.

� Task Manager: Task Manager provides a single model for all tasks processed by 
the CRM suite. Tasks are created and assigned to groups or individuals. 

� Escalation Manager: Escalation Manager allows identification, tracking, and 
monitoring of situations that require increased attention and quick action.

1.2.2 Oracle Enterprise Resource Planning (ERP)
� Oracle Inventory: Oracle Inventory is used to define and maintain product, 

component, subcomponent, platform, and associated version information. 
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New in this Release
� Oracle Bills of Material (BOM): A product structure tool that defines product 
relationships. BOM allows the creation of products containing multiple 
components and subcomponents.

� Oracle Human Resources Management System (HRMS): HRMS is used to 
define and maintain employee information used for assignments.

� Oracle Receivables: Customers are set up in Oracle Receivables.

1.3 Conditional Dependencies
The following are optional but highly recommended modules that allow Oracle 
Quality Online to utilize additional data and improve functionality:

1.3.1 Service Request/Oracle TeleService
Integration with Service Request, included with Oracle TeleService, facilitates an 
efficient support process for customers and internal employees. Support agents can 
create defects or enhancement requests in response to a Service Request.

1.3.2 Knowledge Base Submit for Defects
While all defects can be submitted to the Knowledge Base, it is a business process 
decision to determine whether all or only closed defects should be submitted. 
Entries submitted to Knowledge Base are published to agents and customers. This 
enables users to search for previous solutions.

1.3.3 Oracle Marketing Encyclopedia System (MES) 
Oracle MES must be set up to use the Alerts bin on the Homepage. Alerts are short 
messages sent to subscribers from the system administrator regarding scheduled 
outages or other system issues. For more information see the Oracle Marketing 
Encyclopedia System Concepts and Procedures, Release 11i.

1.4 New in this Release
Oracle Quality Online contains the following new functionality in this release.

� Customer search by name and number: Users are able to enter and search by 
either the customer name or number in the Create Defect, Defect Details, Quick 
Create, and Advanced Search screens. Additionally, Customer Name and 
Number can be entered in the main user fields.
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New in this Release
� Group workload management:  There are two additional key summary views, 
Open Defects my Groups Own and Open Enhancements my Groups Own.         
This allows resources to see the number of open defects and enhancements 
assigned to their group(s). Also, the key summary views Defects with Open          
Tasks I Own, and Enhancements with Open Tasks I Own  have been changed to 
Defects with My Open Tasks and Enhancements with My Open Tasks, 
respectively. The new summary view lists all the defects. enhancements that 
have an Open Task for which the person logged in is the owner or the        
assignee. 

� Expanded default views: Users are able to set default note detail viewing level 
when opening a defect or enhancement.

� Advanced Search Improvements: 

� Context-enabled keyword search functionality added for enhancements. 
Also, the ability to search by Service Request, Escalation or Task Number.

� The ability in  both Advanced Search and Reports to search on component 
and subcomponent without specifying a product. 

� Hyperlinks in Notes:  Extended hyperlink functionality has been added to 
improve usability. Users are able to define what should be parsed and rendered 
as a hyperlink in Note Details. 

� Associate external objects to defects and enhancements:  Third party objects, 
such as patches, external service requests or any other object can be associated 
with defects or enhancements.

� Option to make Phase Status mandatory:  Organizations can make phase 
status optional or mandatory for both open and closed defects and 
enhancements.

� Resolution Time for Enhancements has been removed.

� Setting up Alerts: the steps for administering and sending alerts has changed. 

Note: Please review Chapter 6: Profile Options and Concurrent Programs, and Appendix 
A: User Permissions in the Oracle Quality Online Implementation Guide, Release 11i for 
updated profile and permission information.
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Key Terms and Functionality
1.5 Key Terms and Functionality
The following table contains the Oracle Quality Online Key Terms and definitions. 

Term Definition

Alerts Alerts are optional short messages about scheduled outages or 
system issues sent from the system administrator. The Alerts 
bin is viewable from the Homepage.

Base Defect/Enhancement When there are dependencies between defects and 
enhancements, a Base link is created to show the dependency. 
This is important for understanding the order in which defects 
must be handled. The link is visible on the Tree hyperlink on 
the Defect or Enhancement Details page. 

Category There are two Categories in Oracle Quality Online, Defects and 
Enhancements.

Defect Defects are logged when errors, unexpected behavior, or any 
other issues are found that require development intervention.

Defect/Enhancement 
Owner

In most cases, the user responsible for the Defect or 
Enhancement at a specific phase. Ownership can be assigned 
automatically or manually.

Enhancement Enhancement are requests to add new functionality.

Environment Variables Environment Variables are used for tracking additional, 
user-defined environment information such as database 
version, browser version, etc.

Escalation Escalations provide the means to identify, track, monitor, and 
manage situations requiring increased awareness and 
immediate action.

Homepage The Homepage is the application’s landing page. The 
Homepage provides an overview of work assigned to 
individuals and/or groups, alerts and information about the 
system, and quick navigation to other key areas of the 
application.

Key Audits/Audits Records showing who has accessed Oracle Quality Online, and 
what operations they have performed. Key Audits are a subset 
of Audits, hard coded in Oracle Quality Online, available in 
Notes Display Options. 

Lifecycle In Oracle Quality Online, the product lifecycle stages are used 
with product versions to further refine the defect definition. 
Seeded Lifecycle stages are Alpha, Beta, Development, and 
Production. They appear in the Product Status drop down list 
in Defect Details.
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Key Terms and Functionality
Link Type Link Types in Oracle Quality Online reflect relationships 
between objects. Link Types are configurable and allow 
relationship definitions to include dependencies.

List of Values (LOV) The LOV is the list of choices that appears when you click Go 
next to a text box. The GO button indicates that the user must 
choose from the associated, predefined list. The LOV differs 
from a drop down box, which displays a limited selection of 
data while the LOV is more extensive. 

Note Templates Configurable templates are designed to guide users in the 
creation of Defects and Enhancements through a sequence of 
questions. Questions and responses are saved in Note format. 
Templates are configurable and are displayed based on usage.

Note Tokens Note Tokens allow any text, e.g. http://, bug 123, patch 123, to be 
hyperlinked according to specific rules . Users often type 
references directly into note text. Setting hyperlinks in the text 
provides future users with an easy way to navigate directly to 
these references.

Notification Users can request email notification at key points in the Defect 
and Enhancement management process, for example, when the 
Status or Phase of a Defect changes or when a Defect is closed. 

Phase Configurable phases are intended to reflect the business 
process steps for handling defects and enhancements and 
tracking progress from one stage to another. If desired, 
changing the phase can trigger assignment to the team or 
individual responsible for the next phase. 

Phase Status Each phase may go through many states, and the phase status 
reflects the current state of this phase. 

Primary Contact The Primary Contact is the filer or the designated liaison for 
the filer, responsible for problem definition and 
communication. The Primary Contact may default to the user 
logging a defect or may be manually assigned at creation. 
There is only one Primary Contact. All other contacts are 
displayed on the Notifications tab.

Profile An ongoing, individual administrative function for setting up 
and maintaining personal user roles, responsibilities, and 
information.

Quick Create Quick Creates are user profiles, set up for frequently recurring 
criteria, e.g. product, platform, version, etc.These speed up the 
creation of defects and enhancements by providing relevant 
default information automatically. 

Term Definition
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Key Terms and Functionality
Resolution/Closure Times Resolution Times allows organizations to define the levels of 
service required to complete the defect lifecycle. 

Resource Group A Resource Group in Oracle Quality Online is used for 
assignment to a virtual entity.

Source Files Files that were modified during the defect management 
process.

Tasks Tasks are a basic unit of work within Oracle Quality Online, 
and contain information relating to assigned activities. Tasks 
can be used for activities that are pertinent to  defects and 
enhancement but whose details do not add to the resolution of, 
or knowledge within, the defect or enhancement. For example, 
a request to check documentation, or a note to follow up with 
someone else.

Templates Configurable templates are designed to guide users in the 
creation of Defects and Enhancements through a sequence of 
questions. Questions and responses are saved in note format. 
Templates are configurable and are displayed based on usage.

Territory Configurable Territories consist of qualifiers and their values. 
The Territory Qualifiers (see below) determine the automatic 
assignment of defects and enhancements. For enhancements, 
Territories may be mapped to the product management 
organization. Territories and their associated Qualifiers are 
application specific.

Territory Qualifiers Qualifiers are the criteria used to delineate a territory. There are 
two types of qualifiers: transaction qualifiers and resource 
qualifiers. Use transaction qualifiers to specify how the 
territory module assigns transactions. This includes accounts, 
leads, opportunities, and service requests. Examples of 
transaction qualifiers include: customer name, postal code, 
state, and product interest. Resource qualifiers specify what 
attributes are used to select the individuals responsible for 
those transactions. Examples include job title, competence, and 
language.

Territory Type Use territory types to group transaction qualifiers used for 
creating territories. This saves you time when you are creating 
similar territories. Suppose you want to create territories by 
geographical area. In this case you can create a territory type 
with the Country and Postal Code qualifiers. 

Tracking Groups Configurable list of group specific keywords. For example, if 
the User Interface group needs to report on the types of UI 
exceptions, a UI Tracking Group can be created.

Term Definition
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Key Terms and Functionality
Type A configurable list that classifies the defect or enhancement. 
Examples are Performance, User Interface, and Translation. 
Type can be used to determine phase and template usage. 
Types are also useful for reporting purposes. 

Term Definition
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Administering Oracle Quality Online

2.1 Administering Oracle Quality Online
During the implementation of Oracle Quality Online and throughout the 
application lifespan, the Oracle Quality Online administrator may configure and 
modify the processes, standards, lookups and alerts. Topics include:

� Before You Begin

� Setting up Processes

� Setting up Standards

� Setting up Lookups

� Setting up Alerts

� Other Administrative Tasks

2.2 Before You Begin
Please note the following.

2.2.1 Understanding Sort Order
� Seeded data comes in a default sort order. Removing, adding, or changing sort 

order indicators will cause the resulting drop down list to present the items 
with assigned sort order first. Those items- custom or seeded- without a sort 
order indicated will be listed in ASCII alphabetical order based on the Name 
field.

� All custom entry Names must be unique to allow for the above sort listing.
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2.2.2 Understanding Start and End Effective Dates
Start and End Effective dates are not mandatory. They can be used to disable seeded 
data (see below) and for custom settings if desired.

2.2.3 Understanding Seeded Data
� If you disable seeded data, after having used it, but want to allow searches on 

the earlier information, set an Effective Date in the past for those seeded data 
items to make it visible in the LOV for searches.

� Changes made to seeded data will not be affected by future patches.

� To disable seeded (or custom) data, set an Effective Date for the value far into 
the future so that it does not show up in the LOV for searches. 

2.3 Setting up Processes
You can configure the Defect and Enhancement processes.

Topics include:

� Changing Responsibility within Oracle Quality Online

� Setting up Category Workflow Options

� Associating Types with Categories

� Setting up Phases

� Setting up Phase Statuses

� Associating Phase Status with Existing Phase

� Associating Phases with Types

2.3.1 Changing Responsibility within Oracle Quality Online
A user with multiple responsibilities, for example the Oracle Quality Administrator, 
can switch Default Responsibility.

To change responsibility:  

1. Navigate to Profile > Preferences. 

2. From the Default Responsibility drop down box, select the desired 
responsibility. Note that you must have a Responsibility for it to appear in the 
drop down box.
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3. Click Update and Sign Out.

4. At the JTF login screen, click Go to log in with your changed Responsibility. 

2.3.2 Setting up Category Workflow Options
There are two Categories in Oracle Quality Online, Defects and Enhancements. 
There is one seeded workflow associated with both Categories. The Oracle Quality 
Online System Administrator assigns workflow parameters by category. 

To set up category workflow options:

1. Log in to the JTF login page as the Oracle Quality Online Administrator.

2. Navigate to Process > Categories.

3. The seeded workflow NOTIFICATION_EMAIL is visible in the drop-down 
boxes associated with the Categories, Defect and Enhancement.

4. To automatically launch the workflow when a defect or enhancement is created, 
check Auto Launch Workflow for the desired category.

5. To end workflow when the defect or enhancement is closed, check Abort 
Workflow on Close.

6. Click Update to set the new values, or Restore to return to the previous values.

2.3.3 Associating Types with Categories
Both defects and enhancements must be associated with Types. Types serve to 
classify the nature of the defect or enhancement and are useful for reporting 
purposes, template creation, and listing phases. They allow high level 
understanding of the kinds of problems users are experiencing and the changes 
they want in future releases. It is recommended that you share phases for as many 
Types as possible to avoid confusion.

Seeded Defect Types include: 

� Data Corruption

� Documentation

� Installation

Note: For a complete list of Seeded Data, see the Oracle Quality Online 
Implementation Guide, Appendix B. 

To associate Types with Categories:
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1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Categories. 

2. Click the Types link in the Associate column. A list of all Types will be visible. 

3. To add a new Type enter a Name in the Name Field. Selecting a Sort Order will 
determine the placement of the new Type in the drop-down list. 

4. Enter a Description in the Description Field.

5. You may set Start and End Dates if desired.

6. Alternately, if you want to allow a base defect to be associated with this 
transaction, check Base Defect Required. 

7. If you need to clear the row for any reason click the eraser icon. 

8. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a type once it is created.

9. To add additional rows click the More Rows link or the down arrow.

2.3.4 Setting up Phases
Configurable phases are intended to reflect the high level business process steps for 
handling defects and enhancements and tracking progress from one stage to 
another. If desired, changing the phase can trigger assignment to the team or 
individual responsible for the next phase. Seeded Phases include:

� Definition

� Resolution

� Customer Verification

Note: Phases should be kept to a minimum and reflect the actual processes involved 
in resolving defects and enhancements.

To set up Phases:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Phases. A list of all Phases will be visible. 

2. To add a new Phase, enter a name in the Name Field. Enter a description in the 
Description field.

3. You can configure Phase Statuses to that the status is mandatory or optional 
when either open or close. Select an option from the Phase Status Options 
column drop-down box to enforce the entry of a Phase Status.
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4. You may set Start and End Dates if desired. 

5. If you need to clear the row for any reason click the eraser icon. 

6. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a Phase once it is created.

7. To add additional rows click the More Rows link or the down arrow.

2.3.5 Setting up Phase Statuses
Phase Statuses provide detailed Phase information. Phase Status should contain 
meaningful information about the associated Phase.  The relationship between 
Phase and Phase Status determines the valid defect statuses - open or closed. This 
allows you to enforce the capture resolution information. 

Seeded Defect Phase Statuses include:

� Awaiting Dependent Fix

� Could not Reproduce

� Defect Resolved 

To set up Phase Statuses:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Phases > Phase Statuses. A list of all Phase Statuses is 
visible. 

2. To add a Phase Status, enter a name in the Name field (e.g. Defect Resolved).

3. Enter a description in the Description field. 

4. Check Base Defect Required and/or Fix Details Required if needed for this 
Phase Status.

5. If the Phase Status is equivalent to Resolved, check the Resolved checkbox. 

6. You may set Start and End Dates if desired. 

7. If you need to clear the row for any reason click the eraser icon. 

8. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a Phase Status once it is updated.

9. To add additional rows click the More Rows link or the down arrow.

Note: For a complete list of Seeded Data, see Appendix B
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2.3.6 Associating Phase Status with Existing Phase
After a Phase Status is created, it can then be associated with a Phase. To associate a 
Phase Status with a Phase:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Phases. A list of all Phases will be visible. 

2. Click the Phase Status link in the Associated column for the Phase needing the 
association.

3. From the Phase Status column select a status from the drop-down list. Select a 
sort order if desired.

4. If you want the status to be Viewable While Open, or Viewable While Closed, 
check the relevant boxes. 

5. You may set Start and End Dates if desired.

6. If you need to clear the row for any reason click the eraser icon. 

7. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete a Phase Status association once it has been created.

8. To add additional rows click the More Rows link or the down arrow.

2.3.7 Associating Phases with Types
Types serve to classify the nature of the defect or enhancement. Types can be 
associated with a unique set of phases. To associate Phases with Types:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Process > Categories. 

2. Click the Types link in the Associate column for a Category. A list of the 
Category Types will be visible.

3. Select a Type from the list by clicking on the Phases link in the Associate 
column. 

4. Select a Phase from the Phase Name column drop-down list. Select a Sort Order 
if desired.

5. Check Primary Contact Owns Phase if you want the primary contact to be 
phase owner. Otherwise Assignment Manager will assign owner based on 
defect attributes.

6. To set any phase as the default, check Default Phase. 
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7. You may set Start and End Dates if desired.

8. If you need to clear the row for any reason click the eraser icon. 

9. Click Update to set the new values, or Restore to return to the previous values. 
You cannot delete an association once it has been entered.

10. To add additional rows click the More Rows link or the down arrow.

Note: For a complete list of Seeded Data, see the Oracle Quality Online 
Implementation Guide, Appendix B

2.4 Setting up Standards
The Oracle Quality Online Administrator sets up and manages Templates,  
Resolution Times, and Note Token Rules.  

� Templates are set up to ensure that users provide required information when 
creating defects and enhancements. 

� Template Usage allows the administrator to designate where the template is 
enforced. 

� Template Prompts, which may be product specific, improve defect and 
enhancement information gathering. The administrator creates text prompts to 
appear in the template and sets a sort order if needed. 

� Resolution Times are set for defects based on internal product priorities and 
severity levels. 

� Setting Note Token Rules allows you to define parsing rules and destinations 
for  hyperlinking keywords in the Note Details display.

Topics include:

� Creating Templates

� Setting Template Usages

� Setting Template Prompts

� Setting Process Resolution Time

� Setting Note Token Rules

2.4.1 Creating Templates
Templates ensure that users create well-formed defects and enhancements.
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To create templates:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Templates. A list of Templates will be visible. 

2. To create a new Template, enter a name in the Name field.

3. Enter a description in the Description field.

4. You may set Start and End Dates if desired.

5. If you need to clear the row for any reason click the eraser icon. 

6. Click Update to set the new values, or Restore to return to the previous values.

7. Once a Template has been created, edits to Usage and Prompts can be made. 
You cannot delete a Template once it has been created, but you can inactivate it 
by end-dating. 

8. To add additional rows click the More Rows link or the down arrow.

2.4.2 Setting Template Usages
Template Usage allows the administrator to designate where the template is 
mandated.

To set up template usage:

1. Navigate to Standards > Templates. A list of Templates will be visible. 

2. Click the Usages link in the Edit column for the Template. The Template Usages 
page will be visible.

3. Select either Defect or Enhancement from the Category drop-down list. If you 
want the template applicable to the selected category only, proceed to step 8.

4. To associate the category specific template with a Type, select from the Type 
drop-down list. If you want the template applicable to the selected category and 
type only, proceed to step 8.

5. To associate the template with a specific product, click Go in the Product Name 
column. A product number and description LOV will be visible. 

6. Select the product by clicking on the link in the Number column. This populates 
the Number and Description fields in the Product Name column. 

7. You may clear the row before updating by clicking on the eraser icon.

8. Click Update to set the new values, or Restore to return to the previous values.
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9. To remove an entry, check the Remove column.

2.4.3 Setting Template Prompts
Template prompts should be consistent and useful as all questions are mandatory.

A non-mandatory prompt can be added to the end of all Templates with an 
indication that it be used for critical severity defects only. Template prompt and 
response combined cannot exceed 2000 characters.

You may wish to devise a visual format for entering prompts so as to distinguish 
between questions and answers.

To set up template prompts:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Templates.

2. Click the Prompts link in the Edit column for the Template. The Template 
Prompts page will be visible.

3. Enter your prompt text in the Prompt field. Select a Sort Order if desired.

4. In the Response Type column, select a text line variable, or the Yes/No Question 
option from the drop-down box. 

5. Check Response Required if a response is mandatory.

6. Check More Information Allowed if you want to provide users with the option 
of being able to add additional information.

7. You may clear the row before updating by clicking on the eraser icon.

8. Click Update to set the new values, or Restore to return to the previous values.

9. To remove an entry, check in the Remove column.

2.4.4 Setting Process Resolution Time
Resolution Times are set for defects based on internal product priorities and 
severity levels. 

To set resolution times:  

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Resolution Time.

2. Click Go next to the Number field in the Product column. A product number 
and description LOV will be visible 
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3. Select the product by clicking on the link in the Number column. This populates 
the Number and Description fields in the Product column. 

4. In the Severity column, select a Severity from the drop-down list. 

5. In the Resolution column, select a desired increment in the Time field, then set a 
desired Unit of Measure (UOM).

6. Repeat the above step in the Closure column.

7. You may set Start and End Dates if desired.

8. Click Update to set the new values, or Restore to return to the previous values.

9. To add additional rows click the More Rows link or the down arrow.

2.4.5 Setting Note Token Rules
Setting Note Token Rules allows you to define parsing rules and destinations for  
hyperlinking keywords in the Note Details display.

To set Note Token Rules:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Standards > Note Token Rules.

2. Click Create Note Token Rule.

3. Enter a unique Sequence number in the Sequence text field. It does not have to 
be consecutive.  Sequences prioritize the rules that set token precedence.

4. Enter a description in the Description text field.

5. Set Start and End Dates, if desired, using the Calendar icon tool.

6. In the Token section, enter the  keyword to hyperlink in the Value field. (a name 
for the linked text, e.g. Bug, http://, etc.).

7. Set Preceding and Following Delimiting Characters. The Preceding Delimiting 
Characters distinguish your token value from identical text values, and the 
Following Delimiting Characters determine where the hyperlink stops. For 
instance, if your bug link always begins after a colon and must end with a 
period, your Preceding Delimiting Character is a colon and your Following 
Delimiting Character is a period. Any combination of Following Characters are 
allowed between Token Value and Parameter, if any.

8. Check the appropriate checkboxes for the characters. These distinguish the 
Token and/or the Parameter from the rest of the text. For example, if you have a 
token bug with the Preceding Delimiting Character Space checked, then a note 
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with the word debug in it will not be hyperlinked because the word bug is not 
preceded by a space.

9. In the Parameter section, use the Type drop-down box to select a Parameter 
type.

10. Enter the Following Delimiting Characters for the parameter, if desired, and/or 
check the appropriate delimiting checkboxes. If No Parameter is selected, then 
the Following Characters, Minimum Length, and Maximum Length options are 
not allowed.

11. Enter your minimum and maximum length parameters.

12. In the Destination section, select a Type using the drop-down box. If your type 
is Function, select a User Function Name using the LOV.  If your type is URL, 
enter the base url in the Base URL text field.

13. Click Create.

2.5 Setting up Lookups
The Oracle Quality Online Administrator can configure site specific content for 
drop-down lists (lookups) several areas of the application. Topics include:

� Setting Priorities

� Setting Severities

� Setting Languages

� Setting Tracking Groups

� Setting Environment Variables

� Setting Miscellaneous Lookups 

2.5.1 Setting Priorities
Priorities allow identification and tracking of defect and enhancement significance 
based on internal priorities.

To add to the seeded Priorities: 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Priorities. A list of the seeded Priorities appears

2. To add a new Priority, enter a name in the Name Field.
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3. Select a Sort Order if desired. 

4. Enter a description in the Description field.

5. You may clear the row before updating by clicking on the eraser icon.

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

2.5.2 Setting Severities
Severities are configurable codes that describe the seriousness of a Defect. In 
Enhancements, Severity equals Desirability. Severities are external standards chosen 
by users, as opposed to Priorities which are internally set.

To add to the seeded Severities:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Severities.

2. Enter a name in the Name field. 

3. Select a Sort Order if desired. 

4. Enter a description in the Description field.

5. Select either Defect or Enhancement from the Category column drop-down list.

6. You may clear the row before updating by clicking on the eraser icon.

7. You may set Start and End Dates if desired. 

8. Click Update to set the new values, or Restore to return to the previous values.

9. To add additional rows click the More Rows link or the down arrow

2.5.3 Setting Languages
Defects and Enhancements can be logged for products available in multiple 
languages. To add a product language: 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Languages.

2. Enter the Language name in the Name field. 

3. Select a Sort Order if desired.
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4. Enter a description for the Language in the Description field.

5. Select the language in the Oracle Application Language drop-down list.

6. You may clear the row before updating by clicking on the eraser icon.

7. You may set Start and End Dates if desired.

8. Click Update to set the new values, or Restore to return to the previous values.

9. To add additional rows click the More Rows link or the down arrow.

Note: For all languages, enter All Languages in the Name and Description fields. 
Leave Oracle Application Language field blank. 

2.5.4 Setting Tracking Groups
Tracking Groups allow development organizations to track particular defects. They 
can be used for case by case searching, and for special reporting requirements. This 
is useful for reporting requirements that do not cross the entire organization, or are 
group specific.

To set tracking groups: 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Tracking Groups.

2. Enter a name for the Tracking Group in the Name field. 

3. Select a Sort Order if desired.

4. Enter a description for the Tracking Group in the Description field.

5. You may set Start and End Dates if desired.

6. Click Update to set the new values, or Restore to return to the previous values.

7. To add additional rows click the More Rows link or the down arrow.

2.5.5 Setting Environment Variables
Environment Variables are used for tracking additional environment information 
such as database and browser version.

To set up your Environment Variables: 

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Environment Variables.

2. Enter a name in the Name field. 
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3. Select a Sort Order if desired. 

4. Enter a description for the Environment Variable in the Description field.

5. You may set Start and End Dates if desired.

6. Click Update to set the new values, or Restore to return to the previous values.

7. To add additional rows click the More Rows link or the down arrow.

2.5.6 Setting Miscellaneous Lookups

2.5.6.1 Setting Reproducibility
Oracle Quality Online allows you to configure lists for determining how frequently 
a Defect can be reproduced. 

To set Reproducibility:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous.

2. Select Reproducibility from the Attribute drop-down list.

3. Enter a term for the Code in the Code field.

4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

2.5.6.2 Setting Lifecycle
In Oracle Quality Online, the product lifecycle stages are used with product 
versions to further refine the defect definition. Seeded Lifecycle stages are Alpha, 
Beta, Development, and Production. They appear in the Product Status drop down 
list in Defect Details. 

To set Lifecyles:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous.

2. Select Lifecycle from the Attribute drop-down list.
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3. Enter a term for the Code in the Code field.

4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

2.5.6.3 Setting Source Modification Types
This step allows you to set Lookups for types of modifications. For example, Code, 
User Interface, or Documentation modifications. 

To set Source Modification Types:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous

2. Select Source Modification Types from the Attribute drop-down list

3. Enter a term for the Code in the Code field.

4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

2.5.6.4 Setting Link Type
Defects and Enhancements can be related and linked. Link Types reflect 
relationships between objects, are configurable, and allow relationship definitions to 
include dependencies. 

To set link types:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Lookups > Miscellaneous.

2. Select Link Types from the Attribute drop-down list

3. Enter a term for the Code in the Code field.
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4. Enter a Meaning, in the Meaning field.

5. Optionally, enter a Description in the Description field. 

6. You may set Start and End Dates if desired.

7. Click Update to set the new values, or Restore to return to the previous values.

8. To add additional rows click the More Rows link or the down arrow.

2.6 Setting up Alerts
Alerts are short messages from the system administrator reporting scheduled 
outages or system issues. The Alerts bin is viewable from the Homepage. The 
Oracle Quality Online Administrator must be imported as a Resource with the MES 
Administrator Resource role assigned in order to create categories or groups, 
publish messages, and approve publishing items to a particular group. See the 
Oracle Quality Online Implementation Guide for more information.

Topics include:

� Creating Groups

� Sending Alerts

2.6.1 Creating Groups
In order for Alerts to work, it is necessary to create and manage groups. Group is the 
relevant link on the Alert Administration page.

Groups are used to distribute content to users, and to classify content in the 
repository. If the group has been assigned to the profile, DEMS: Channel for System 
Alerts, all users in this group will receive alerts. Please see the Oracle Quality 
Online Implementation Guide for more information.

To create new groups:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Alerts > Alert Administration. Click Group from the Access and 
Managers bullet list. The Group Manager page appears.

2. Enter a name in the Group Name column.

3. Check the Administrator, Publish Content, and Approval checkboxes.

4. Click Update.
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2.6.2 Sending Alerts
To send Alerts:

1. Log in to the JTF login page as the Oracle Quality Online Administrator. 
Navigate to Alerts > Send Alert. The Publish page will be visible.

2. From the Select an Item Type drop-down box, select Message.

3. Enter a title for the Alert in the Title field, then enter the author name in the 
Author name field. 

4. Enter the text message in the Message field.

5. Enter the Effective Start Date for the message.

6. Select either the Permanent radio button if the Alert is to be displayed 
indefinitely, or the Duration radio button if you want it to display for only a set 
time. If selecting the Duration radio button, set duration values with the 
drop-down boxes.

7. Select a priority from the Priority drop-down list.

8. From the Available column in the Groups section, select the group and click 
Assign (>) to move your selection over to the Selected column.

9. Click Publish to Publish the Alert, or Clear to set the new values. 

2.7 Other Administrative Tasks
Frequently recurring tasks for the Oracle Quality Online Administrator include the 
following:

� Finding a Platform

� Editing a Platform

� Adding New Product Information

2.7.1 Finding a Platform
To find a platform:

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 
Manufacturing and Distribution Manager responsibility. Navigate to Inventory 
> Items > Item Search. Select the appropriate organization. The Find Items form 
opens.
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2. Select Item Categories from the Show LOV.

3. In the Category Set LOV, select the appropriate platform Category Set. In the 
Category LOV select the appropriate category. 

4. In the Platform Group query form, enter % and your search delimiters. Execute 
the query using Control F11. Select from the resulting list.

5. Click Find. Note the item number or description. 

2.7.2 Editing a Platform
To edit a platform:

1. Log on to Oracle Forms as sysadmin. In the Responsibility window, select the 
Manufacturing and Distribution Manager responsibility. Navigate to Inventory 
> Items > Master Items. Select the appropriate organization.

2. Select the Find icon on the menu bar to display the Find Master Items form. 
Enter the item number 

3. Edit the Item record as needed.

4. From File, select Save and Proceed.

2.7.3 Adding New Product Information
To add new product, component, platform, and version information, please see the 
Oracle Quality Online Implementation Guide Release 11i.
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Using Oracle Quality Online

This chapter provides process-oriented, task-based procedures for using Oracle 
Quality Online to perform essential business functions.

3.1 User Interface Basics
Using the List of Values (LOV): The Go button next to a text box indicates that you 
can only enter specified values in this field. If you do not know the exact value, click 
Go with a partial value entered, or with the text box left blank, to access an LOV 
associated with the field. Click the entry of your choice.

Drop-down Box: A text box with a down arrow next to it indicates that you select 
an entry from a drop-down box. Click on the down arrow and make your selection. 

Text Box Field: A plain text box indicates a field where you can type free text.

Required Fields: A red asterisk next to any field indicates that entry is mandatory.

Calendar icon: This button is used to set Start/End Dates. Click to view a calendar 
in the Select a Date pop-up window. Select dates to populate the Start or End Date 
fields.

Using the Tabs: There are three main tabs in Oracle Quality Online, each with a set 
of subtabs:

� Home: Accesses the application Homepage. Homepage subtabs are Home, 
Create Defect, and Create Enhancement. The Homepage is where you view 
your Key Summary Displays, and System Alerts. The Create  Defect and Create 
Enhancement subtabs allow one-click access to the defect and enhancement 
creation processes.

� Defects: Accesses the Defects page where you can view defect summaries, 
create defects and reports, and submit defects to the Knowledge Base.
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� Enhancements: Accesses the Enhancements page, where you can view 
enhancements summaries, and create enhancements and reports.

3.2 Using the Homepage
 This topic group includes information on:

� Accessing Functionality from the Homepage

� System Alerts

3.2.1 Accessing Functionality from the Homepage
Access functionality from the Homepage that allows you to manage your work 
queue:

� Using Quick Find

� Using Key Summary Views

3.2.1.1 Using Quick Find
Quick Find is a search tool with two values: Defects and Enhancements. Using 
Quick Find to manage your work queue, locate the defect or enhancement you are 
working on or interested in reviewing. 

To use Quick Find:

1. From the Homepage navigate to Quick Find.

2. Select Defect or Enhancement Number from the drop-down box. 

3. Enter the number, or a partial value in the text box and click Go.  To access 
the entire list of defects or enhancements, leave the text box blank then 
select a number from the resulting list to view details. 

3.2.1.2 Using Key Summary Views
These summaries show defects, enhancements and associated objects assigned to 
you or to groups to which you belong. When setting up your profile, you may chose 
and/or create the views most useful in managing your work queue.

The seeded Key Summary Views are:

� Open Defects I Own

� Open Enhancements I Own
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� Defects with Open Tasks I Own

� Defects with Open Escalations I Own

� Enhancements with Open Tasks I Own

� Open Defects My Groups Own

� Open Enhancements My Groups Own

To view Key Summary Views:

1. Access the Homepage (Home is the default tab).

2. In the Key Summary Views section, click Count (x) to view a list of defects or 
enhancements.

3. Select the defect or enhancement number to view details.

To modify your Key Summary Views options, see Setting Homepage Content 
Options.

3.2.2 System Alerts
System Alerts are short messages about system issues. The System Alerts bin is 
viewable from the Homepage. See Setting up Alerts in Chapter 2.

3.3 Using the Profile Page
This topic group provides instructions for the following procedures:

� Changing Your Password

� Setting Homepage Content Options

� Setting Defects Profile Page Options

� Setting Enhancements Profile Page Options

� Personalizing General Preferences

3.3.1 Changing Your Password
To change your password:

1. Select Profile. The Personal Profile page appears.

2. In the Current Password field, enter your password. In the New Password field, 
enter a new password. Confirm by re-entry in the designated text box.
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3. Click Update.

3.3.2 Setting Homepage Content Options
To choose the Key Defect and/or Enhancement Summary Views for your 
Homepage 

1. Navigate to Profile > DEMS Profile > Home.

2. Select Defect and Enhancement Key Summary views using the checkboxes.

3. Click Update to set the new values or Restore to return to the previous values.

3.3.3 Setting Defects Profile Page Options
This topic group covers the following procedures:

� Customizing Note Details Display

� Customizing Defect Summary Views

� Setting Defect Quick Creates Defaults

3.3.3.1 Customizing Note Details Display
To customize your Note Details displays on the Defect Details page:

1. Navigate to Profile > DEMS Profile > Defects. 

2. Select a display option from the Show As Default LOV in the Details section. 
This determines the level of Note Details displayed in the Details section of a 
defect. 

3. Click Update or Restore.

3.3.3.2 Customizing Defect Summary Views
To customize your pulldown display list on the Defect Summary page:

1. Navigate to Profile > DEMS Profile > Defects.

2. In the View Name table, enable the seeded Defect Summary Views options as 
desired.

3. To add custom Defect Summary Views:

a. Click New Search. Input search criteria.

b. Apply Summary Display Options if desired.
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c. Name your search in the Save Search As section.

d. To save the resulting search as a Defect Summary View, and view the search 
results immediately, click Save and Apply Search, otherwise click Save.

e. To save as the Summary Default View, select checkbox.

4. To remove custom Defect Summary Views, check the appropriate box in the 
Remove column. Select Update to save changes or Restore to return to the 
previous values.

5. Using the Show As Default drop-down box, select a default display option for 
the Defects page (unless you did this already in Step 3).

Note: Unless the Key Summary Views are enabled on the Profile page, they will not 
appear on the Homepage, even if enabled from the Homepage setup options.

3.3.3.3 Setting Defect Quick Creates Defaults
To set a Quick Create default display for the Defects page 

1. Navigate to Profile > DEMS Profile > Defects.

2. To create a new Quick Create, click New Create to access the Create Page. After 
setting new Quick Create parameters, select Create to save the selection, Restore 
to return to the previous values, or Back to return to the Defects page.

3. Using the Show As Default drop-down box in the Quick Creates section, select 
a default Quick Create for the Create Defects page.

4. Click Update or Restore.

5. To remove Quick Creates, check the Remove checkbox, then click Update.

Quick Create modifications can also be made by navigating to Defects > Create.

3.3.4 Setting Enhancements Profile Page Options
This topic group includes instructions for:

� Customizing Enhancement Note Details Display

� Customizing Enhancement Summary Views

� Setting Enhancement Quick Creates Defaults

3.3.4.1 Customizing Enhancement Note Details Display
To customize your Note Details displays on the Enhancement Details page:
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1. Navigate to Profile > DEMS Profile > Enhancements.

2. Select a display option from the Show As Default LOV in the Details section. 
This determines the level of Note Details displayed in the Details section of an 
enhancement. 

3. Click Update or Restore. 

3.3.4.2 Customizing Enhancement Summary Views
To customize your pulldown display list on the Defect Summary page:

1. Navigate to Profile > DEMS Profile > Enhancements 

2. In the View Name table, enable the seeded Enhancement Summary Views 
options as desired.

3. To add custom Enhancement Summary Views:

a. Click New Search. Input search criteria.

b. Apply Summary Display Options if desired.

c. Name your search in the Save Search As section.

d. To save the resulting search as an Enhancement Summary View and view 
the search results immediately, click Save and Apply Search, otherwise click  
Save.

e. To save as the Summary Default View, select checkbox.

4. To remove custom Summary Views, check the appropriate checkbox. Select 
Update or Restore.

5. Using the Show As Default drop-down box, select a default display option for 
the Enhancements page (unless you did this already in Step 3).

Note: Unless the Key Summary Views are enabled on the Profile page, they will not 
appear on the Homepage, even if enabled from the Homepage setup options.

3.3.4.3 Setting Enhancement Quick Creates Defaults
To set a Quick Create default display for the Enhancements page: 

1. Navigate to Profile > DEMS Profile > Enhancements. 

2. To create new Quick Create, click New Create to access the Create Page. After 
setting new Quick Create parameters, select Create to save the selection, Restore 
to return to the previous values, or Back to return to the Defects page. 
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3. Using the Show As Default drop-down box in the Quick Creates section, select 
the default Quick Create for the Enhancements page.

4. Click Update or Restore.

5. To remove Quick Creates check the Remove checkbox. 

Quick Create modifications can also be made by navigating to Enhancements > 
Create.

3.3.5 Personalizing General Preferences
To personalize your general preferences:

1. Navigate to Profile > Personalization > Preferences. 

2. In the Responsibility Management section, select a default responsibility using 
the Default Responsibility drop-down box. 

3. In the General Display section, set  interface display options as follows:

f. Select a preset display style from the Display Style drop-down box.

g. Select standard operating language for the application from the Language 
drop-down box. 

h. Select currency from the User Currency drop-down box.

i. Select date display format from the Date Format drop-down box.

j. Click Update.

4. In the Table Display section, use the drop-down boxes to select the number of 
rows  to view on each page and the number of blank rows to view in each table.

3.4 Performing Searches
 This topic group includes instructions for the following search types:

� Quick Find

� Advanced Search

� Search Types 

� Saved Searches

� Summary Views for Defects and Enhancements
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3.4.1 Quick Find
 See Using Quick Find.

3.4.2 Advanced Search
Advanced Search allows you to perform complex searches. It is available from all 
tabs and subtabs but Home. 

To perform an Advanced Search:

1. Navigate to the Defects or Enhancements tab, then click the Advanced Search 
link next to the Quick Find fields. The Defect or Enhancement Search page 
appears. 

2. Select from the Search Type drop-down box, which determines the level of 
complexity for your search. Quick Search is the default search screen and Quick 
Search fields are what are visible unless you select Complete or Expanded.

3. Enter as many search terms and values as possible using the text boxes, 
drop-down boxes and LOVs. See Search Types for more information on Search 
Type options. You can also search by defect or enhancement number.

4. Click Search.

3.4.2.1 Search Types
There are three search screens in Advanced Search:

� Quick: Displays the most commonly searched fields. 

� Complete: Displays all possible search fields, and allows for keyword searches.

� Expanded: Displays all possible search fields with expanded drop down boxes 
allowing you to select multiple values, and allows for keyword searches

1. Select a screen option from the Search Type drop-down box and click Go.

2. When using Expanded Search, click in the pulldowns while pressing Control to 
select multiple values from each field.

3. Any field with a 1 next to its title allows entry of multiple values. A blank field 
allows additional search entries for that value.

4. Enter as many values as possible using the text-fields,drop-down boxes, and 
LOVs. You must enter a minimum of two search conditions.

5. Click Search. The search results will display.
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6. To print the search results, click either Printer Friendly Summary or 
Printer-Friendly Expanded.

3.4.3 Saved Searches
Saved Searches allow you to capture dynamic search results. Saved Searches appear 
on your Summary page.

To create Saved Searches:

1. Click Advanced Search. 

2. Select a search type from the Search Type drop-down box and click Go.

3. Enter as many values as possible in the search fields. You must enter a 
minimum of two search conditions.

4. In the Display Options section, select Displayed Columns from the Available 
Columns list using the (>) button.

5. Select Sort Row order:

a. Select row sorting options with the Sort Rows by drop-down box. 

b. Select Ascending or Descending radio button.

c. Select additional display options using the Then By and Finally By 
drop-down boxes and radio buttons.

6. In the Save Search As section, enter a saved search name in the Name field. 
Check the Use as Summary Default View box if applicable. 

7. Click Save to save the entered values, or click Save and Apply Search to save 
and perform the search.

3.4.4 Summary Views for Defects and Enhancements
To access a list of Defect and Enhancement Summary Views:

1. Navigate to Defects or Enhancements > Summary. A list of Defects or 
Enhancements may appear, depending on your setup default.

2. Locate the defect or enhancement link in the display list, or search for a defect 
or enhancement using either the Saved Searches LOV or Advanced Search.

3. Click the Next link to move to the next page, or click the Last link to get to the 
last page if searching using the Summary page display list. Click Expanded 
View to view all defects or enhancements. 
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4. Click the numbered hyperlink to access the Details page.

5. To view Saved Searches from the Summary page:

a. Select an option from the Saved Searched drop-down box.

b. Click Go. 

c. Alternately, click Modify to make changes to Saved Searches options.

6. To print all defects or enhancements in the Summary, click Printer-Friendly 
Summary, or Printer-Friendly Expanded, then print the page.

3.5 Creating Defects
This topic group provides information on:

� Checking for Duplicate Defects

� Creating Defects 

� Creating a Defect Entering all Original Data

� Using Quick Create

� Based on an Existing Defect

� Based on an Existing Enhancement

� Based on a Service Request

3.5.1 Checking for Duplicate Defects
To check for duplicate defects, perform a detailed search. See Performing Searches.

3.5.2 Creating Defects
Creating a defect is a two-page process involving data collection and notes input. 
Starred fields are mandatory. The Notes templates on page 2 of the process vary 
based on the Type, Category, and product, and are optional based on setup.

3.5.2.1 Creating a Defect Entering all Original Data
To create a defect entering all original data:

1. Navigate to Create Defect. 

2.  The Create Defect Page- Step 1 of 2 appears. Starred fields are mandatory:
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a. Using the Type drop-down box, select defect type.

b. Using the Phase drop-down box, select a phase. The phase defaults are 
based on preset business roles. If you are not sure of the phase, leave the 
default phase as it displays. 

c. Select a phase status from the Phase Status drop-down box if your setup 
options require a phase status.

d. Select a severity from the Customer Severity drop-down box. 

e. Select the customer type using the Customer Type radio buttons.

f. Select customer information using the Customer Number LOV or Customer 
Name LOV.

g. Check the Published checkbox if the defect is to be viewed by external 
customers.

h. Associate defect with a Base Defect or Enhancement, if required, using the 
Base LOV.

3. In the Product/Platform section, enter as much information as possible. 

a. Using the Product LOV, select product. 

b. Select a version using the Version LOV. Required if the version is validated.

c. Using the Product Status drop-down box, select a product status. 

d. In the Earliest Version Broken in LOV, select the earliest version of the 
product containing the defect.

e. For products that have components and subcomponents, enter a 
component, subcomponent, and version using the relevant LOVs.

f. If the defect is platform specific, check the Platform Specific checkbox.

g. Using the Platform LOV, select a platform, and, if relevant, a version.

4. Click Continue after entering all values. The Create Defect page Step 2 of 2 
appears.

5. Enter a brief, one line summary of the problem in the Summary text box. This 
will appear in the Defect Summary List.

6. Enter Notes as indicated in the Note Template section. It is important to enter as 
much information as possible to expedite the analysis and resolution processes. 
The Note Template varies based on Category, Type, and Product.
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7. If you are prompted to answer any Yes/No questions, enter your responses 
using the Yes/No drop-down boxes.

8. To capture Error Codes, Environment Variables (useful for searching) and/or 
Tracking Groups information in the Miscellaneous section of  Defect Details, 
follow the directions below, otherwise proceed to Step 9:

a. In the Error Codes table, enter the Error Codes you received with any 
additional information. To add rows, click the down arrow or More Rows. 
The page refreshes with additional rows. 

b. In the Environment Variables table, select Environment Variables from the 
drop-down box and input additional information if needed. To add rows, 
click the down arrow or More Rows. The page refreshes with additional 
rows.

c. In the Tracking Groups table, select relevant Tracking Groups from the 
drop- down box. Ask your manager what tracking groups are relevant. To 
add rows, click the down arrow or More Rows. The page refreshes with 
additional rows.

d. Select Create to create your defect now including this information. 
Alternately, select Clear or Cancel.

9. At the bottom of the Notes input area, select Create to create your defect. 
Alternately, select Clear to re enter information or Cancel to cancel defect 
creation.

10. The defect details screen for the new defect appears after clicking Create.  Make 
any needed changes, then click Update.

3.5.2.2 Using Quick Create
Quick Creates are user templates for frequently recurring criteria.

To create a defect using Quick Create:

1. Navigate to Create Defect. 

2. Using the Quick Create drop-down box, select the appropriate Quick Create 
template. Click Auto Fill to populate the defect create fields. Verify that the 
Auto Fill information is correct for this defect. Update if necessary.

3. Alternatively, click Personalize to update the template, or New to create a new 
template. 

4. Using the Base LOV, associate defect with a Base Defect or Enhancement, if 
necessary.
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5. Fill in any remaining Product/Platform fields wherever possible. Although 
only certain fields will be required based on your setup, your entries in the 
other fields affect how the defect is handled and assigned, and how it will be 
used for reporting on product quality.

a. In the Version field, enter a version. Required if the version is validated.

b. Using the Product Status drop-down box, select a product status if desired. 

c. In the Earliest Version Broken in field, use the LOV to select the earliest 
version of the product containing the defect.

d. For products that have components and subcomponents, enter a 
component, subcomponent, and version value using the relevant LOVs.

e. If the defect is platform specific, check the Platform Specific checkbox.

f. Using the Platform LOV, select a platform, and, if relevant, a version.

6. In the Miscellaneous section:

a. If desired, modify the Primary Contact information using the LOV. Only 
those users with the Primary Contact resource role, assigned at user setup, 
will be displayed. The primary contact defaults to filer or may be manually 
assigned.

b. Using the Email When drop-down box, select an email notification option.

c.  Make a selection using the Reproducibility drop-down box. 

d. Using the Language drop-down box, make a selection of product language. 

7. See Section Creating a Defect Entering all Original Data, Steps 4-10 to complete 
process.

3.5.2.3 Based on an Existing Defect
To create a defect based on an existing defect:

1. Navigate to Create Defect.Using the Create based on drop-down box, select 
Defect. Input the defect number or click Go to access the defect LOV. Select a 
defect. Click Auto Fill to populate the defect create fields. Verify that the Auto 
Fill information is correct for this defect.

2. Fill in any remaining Product/Platform fields wherever possible. Although 
only certain fields may be required, based on your setup, your entries in other 
fields affect how the defect is handled and assigned, and how it will be used for 
reporting on product quality.
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3. See Section Creating a Defect Entering all Original Data, Steps 4-10 to complete 
process. 

3.5.2.4 Based on an Existing Enhancement
To create a defect based on an existing enhancement:

1. Navigate to Create Defect.

2. Using the Create based on drop-down box, select Enhancement. Input the 
enhancement number or click Go to access the enhancement LOV. Select an 
enhancement. Click Auto Fill to populate the defect create fields. Verify that the 
Auto Fill information is correct for this defect.

3. Fill in any remaining Product/Platform fields wherever possible. Although 
only certain fields may be required based on your setup, your entries in the 
other fields affect how the defect is handled and assigned, and how it will be 
used for reporting on product quality. 

4. See Section Creating a Defect Entering all Original Data, Steps 4-10 to complete 
process.

3.5.2.5 Based on a Service Request
Defects can be created from Service Requests only if the product is shared between 
Service Request and Oracle Quality Online.

To create a defect based on a Service Request:

1. Navigate to Create Defect.

2. Using the Create based on drop-down box, select Service Request. Input the 
Service Request number.

3. Click Auto Fill to populate the defect create fields. Verify that the Auto Fill 
information is correct for this defect. Note in particular that the Summary field 
on Page 2 will display the summary for the Service Request.  You may delete 
and enter a new summary if desired.

4. If you don’t know the number, click Go to access the Service Request LOV, 
select a Service Request, then repeat Step 3 above. You can also enter a partial 
value to limit the search.

5. Fill in any remaining Product/Platform fields wherever possible. Although 
only certain fields may be required based on your setup, your entries in the 
other fields affect how the defect is handled and assigned, and how it will be 
used for reporting on product quality.
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6. See Section Creating a Defect Entering all Original Data, Steps 4-9 to complete 
process.

3.6 Managing Defects
This topic group includes instructions for:

� Responding to Newly Filed Defects

� Changing Notification

� Adding Notes to Defects

� Moving Defect to Another Phase

� Reassigning Defect Ownership

� Prioritizing Defects

� Resolving Defects

� Closing Defects

� Viewing Defect History Details

� Navigating Through Defects

� Viewing the Dependency Tree

� Updating Multiple Defects

� Mass Updating Defects

� Reviewing a Defect

� Submitting Defects to Knowledge Base

� Printing Defects

3.6.1 Responding to Newly Filed Defects
To respond to new defects:

1. Navigate to the Defect Details page.

2. Verify that all information is correct, makes sense, and that the defect meets 
with your internal requirements.

3. Verify that the defect is not a duplicate. (See Section Checking for Duplicate 
Defects). If you determine that the defect is a duplicate:
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a. Using the Base Defect LOV, select the original defect.

b. Select an appropriate phase using the Phase drop-down box.

c. Select Duplicate Defect using the Phase Status drop-down box. 

d. Change the status to Closed using the Status radio buttons.

e. Click Update. 

4. If you require more information about the defect:

a. Set the defect to an appropriate phase, and the phase status to Need More 
Information.

b. Add a Note. See Section Adding Notes to Defects.

c. Verify that all contact information is correct in the Miscellaneous section.

d. Click Update.

5. Use any of the relevant steps in this Section and in Defect Details for further 
defect management.

6. If you have determined that the filed defect is not a defect, close it.

3.6.2 Changing Notification
To change notification:

1. Navigate to the Defect Details page. Click Notifications.

2. Using the Employee LOV, select a new employee contact. Using the Email 
When drop-down list, select a notification condition for the Primary Contact.

3. Select Add Myself as a Contact if desired. Select an Email When notification 
option. Click Update.

4. To delete a contact, check the Remove column. Click Update.

3.6.3 Adding Notes to Defects
To add Notes to a defect:

1. Navigate to the Defect Details page. Scroll  to the Add a Note Section.

2. Select a Note Type from the Type Drop Down Box. If you want this Note visible 
to external customers, select the Publish check box.

3. In the Note Field, type the note. Click Update.
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4. To add detailed notes, click More and enter the detailed information. Click 
Close when finished.

5. View your notes in the Details section. There are four Note View options:

� Notes

� Notes - Summarized

� Notes with key updates

� Notes with all updates

To view Note details:

a. In the Details section, select a viewing option from the View drop-down list. 
Click Go. 

b. Scroll to the Details section to view Note details. Click on any hyperlinks 
for details. 

c. Click the Edit icon to view the entire note. Click the More button to see any 
additional Note information you may have added.

3.6.4 Moving Defect to Another Phase
Depending on setup, defect ownership may change when the defect is moved to 
another phase. 

To move a defect to another phase:

1. Navigate to the Defect Details page.

2. In the Phase Drop down box, select a new phase for the defect. 

3. Click Update or Restore.

3.6.5 Reassigning Defect Ownership
Based on assignment rules set up to reflect skill sets and business processes, a defect 
may be reassigned automatically. Note also that if the Territory changes, the owner 
changes as well. 

To reassign defect ownership:

1. Navigate to the Defect Details page.

2. To manually assign defect ownership, uncheck the Automatically Reassign 
checkbox. Using the Owner LOV, select a new owner.
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3. To automatically reassign this owner, check the Automatically Reassign check 
box. Normal assignment rules, based on your Territory setup, will apply (See 
Chapter 1, Understanding Oracle Quality Online for details).

4. Click Update.

3.6.6 Prioritizing Defects
Prioritizing defects allows you to set an internal priority that differs from the 
severity logged by the filer. 

To prioritize defects:

1. Navigate to the Defect Details page. 

2. Using the Internal Priority drop-down box, select a priority level. 

3. Click Update.

3.6.7 Resolving Defects
To resolve defects:

1. Navigate to the Defect Details page.

2. Using the Phase drop-down box, select a phase that has been flagged by your 
organization to indicate a resolved phase.

3. Select an appropriate Phase Status, using the Phase Status drop-down box. 

4. In the Resolution section, select an appropriate option from the Fixed In 
drop-down box. 

5. If the product is setup as version controlled, enter a version number in the Fixed 
Version text box, or click Go to use the LOV.

6. Click Update. This will populate the Actual Resolution date field on the Defect 
Details page. 

3.6.8 Closing Defects
To close defects:

1. Navigate to Defect Details.

2. Select Closed using the Status radio button.

3. Verify that the defect is in the appropriate Phase and Phase Status.
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4. Click Update.

3.6.9 Viewing Defect History Details 
To view defect history:

1. Navigate to Defect Details. Scroll to the Details section. 

2. Select a viewing option from the View drop-down list, then click  Go. The page 
refreshes with the defect history in the Details section. 

3.6.10 Navigating Through Defects
You can update defects continuously directly from the Defect Details page. Searches 
can also return lists that are navigable using this feature. 

To navigate through defects:

1. Navigate to Defect Details. After making changes to a defect, click Update and 
Next to access the next defect on your Summary list. 

2. Alternately, click Update and Previous to access the previous defect on the 
Summary list. 

3.6.11 Viewing the Dependency Tree
To view the dependency tree for a selected defect:

1. Navigate to Defect Details. 

2. Click the Tree hyperlink next to the Base Defect LOV. The Base Defect and 
Enhancement Tree page appears, displaying related dependencies. Links added 
on the Links page will not display in the Tree.

3. Click Back to return to the Defect Details page. 

3.6.12 Updating Multiple Defects
To update multiple defects at one time, changing field values and adding note 
information:

1. Navigate to Defects > Summary. 

2. Click Deselect All to clear all checkboxes. This deselects all defects in the 
summary, including those not visible on the screen but listed on the next 
page(s).
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3. Using the checkboxes, select only those defects that you want to update. 
Navigate through all necessary pages. 

4. Click Update. A red-text note appears at the top of the page, indicating how 
many defects will be affected by this update. Verify that this number is correct. 

5. Make updates as needed using the LOVs, text and drop-down boxes.

6. Add a Note if desired.

7. Click Update (x) Defects. Confirm your update in the confirmation box. Review 
your Mass Update Status Report.

8. Alternately, click Restore to clear input and start over. 

3.6.13 Mass Updating Defects
To update all defects in the Summary simultaneously and enter note information:

1. Navigate to Defects > Summary. 

2. Click Select All to select all defects in the Summary.

3. Click Update. A red-text note appears at the top of the page, noting how many 
defects will be affected by this update. 

4. Make updates as needed using the LOVs, text and drop-down boxes.

5. Add a Note if desired.

6. Click Update (x) Defects. Confirm your update in the confirmation box. Review 
your Mass Update Status Report. 

3.6.14 Reviewing a Defect
Before a publishable defect can be submitted to the Knowledge Base, you may 
remove company sensitive information and other data from the defect details. You 
can also use this procedure for a general review.

To review a defect:

1. Navigate to Defect Details. Scroll to the bottom section of the page.

2. Click Customer Preview. The current defect displays, with sensitive fields 
hidden, as a customer would see it. 

3. If you want to hide any of the Note information that displays in the History 
section, click the Defect Details link at the top of the page to go back to the 
Defect Details page. 
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4. Click on the Note Summary link in the Details section. Deselect the Published 
checkbox.

5. Click Update.

3.6.15 Submitting Defects to Knowledge Base
It is recommended that only resolved and closed defects be submitted as knowledge 
resources.

To submit defects to the Knowledge Base:

1. Navigate to the Defect Details page.

2. Review the defect (see Reviewing a Defect).

3. In the Add a Note section of the Defect Details page, check Publish, and select a 
Type from the drop down box. Verify that the Notes you wish to submit to the 
Knowledge Base are publishable.

4. Click Knowledge Base. The Submit Defect to Knowledge Base page appears.

5. Select the Status using the Status drop-down box. 

6. Verify that the Summary is correct.

7. Select the Notes to submit to the Knowledge Base.

8. If needed, add an additional Note. 

9. Click Submit.

3.6.16 Printing Defects
Oracle Quality Online can format the defect details page to print within the width 
of a page.

To print defects:

1. Navigate to the Defect Details page.

2. After verifying all the information on the Defect Details page, click Printer 
Friendly Format. The defect details display in page-width format for clear 
printing. 

3.7 Defect Details
This topic group includes instructions for:
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� Adding Attachments to Defects

� Escalating a Defect

� Adding Links to Defects

� Submitting and Adding Notification Contacts to Defects

� Adding Source Files to Defects

� Adding Tasks to Defects

3.7.1 Adding Attachments to Defects
To add attachments to a defect:

1. Navigate to Defects > Summary > Defect Number> Defect Details > 
Attachments.   

2. Click Add Attachment. The Add Attachment page appears.

3. Enter a description in the description field. 

4. Using the Browse button, browse to the file and select it. Click Add Attachment.

5. To remove an Attachment, check the box in the Remove column. Click Update. 

3.7.2 Escalating a Defect
To escalate a defect:

1. Navigate to Defects > Summary > Defect Number> Defect Details > Escalation. 

2. Select an Escalation level from the Escalation Level drop-down box. 

3. Enter a summary in the Summary field. 

4. Select a reason for the escalation from the Reason drop-down box. 

5. Select a Status from the Status drop-down box, and an Owner from the Owner 
LOV.

6. You may Update or Restore at this point.

7. If desired, set a target date using the Calendar tool next to the Target Date field. 

8. Add a Note, if needed, in the Add a Note section:

a. Select a Note type from the Note Type drop-down box.

b. Enter the note in the Note Summary field.
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c. Enter a description of the Escalation, or Escalation reason, in the Note Text 
box. 

9. To add or remove a contact in the Escalations contact section:

a. Click Go to access the Employee LOV.

b. Select an employee contact.

c. Select contact type from the Contact Type drop-down box. Select a contact 
number from the Number drop-down box. 

d. Check the Notify box.

e. If you are on the contact list and wish to be notified, select the Requester 
radio button. 

10. Click Update. 

3.7.3 Adding Links to Defects
Links allow you to view, create, update and remove relationships between defects 
and enhancements, service requests, and other objects such as patches.

To add a link to a Defect/Enhancements:

1. Navigate to Defects > Summary > Defect Number> Defect Details > Links. 

2. To link related Defects:

a. Select a relationship from the Relationship drop-down box. 

a. Enter the defect or enhancement number in the Number field, or search 
using the Number LOV in the Related Defects section. 

b. To remove a link, use the eraser icon tool in the Unlink column.

c. Click Update or Restore. 

3. To link related Service Requests:

a. Enter the Service Request number in the Number field, or search using the 
Number LOV in the Related Service Requests section. 

b. To remove a link, use the eraser icon tool in the Unlink column. 

c. Click Update or Restore.

4. To link other objects:
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a. Select a document type from the Document drop-down box in the Related 
Documents section.

b. Enter the object number in the Number field, or search for it using the 
Number LOV.

c. To remove a link, use the eraser icon tool in the Unlink column.

d. Click Update or Restore.

3.7.4 Submitting and Adding Notification Contacts to Defects
Notifications allow you to view, create, update and remove notification contacts for 
a defect. 

To submit notifications:

1. Navigate to Defects > Summary > Defect Number> Defect Details > 
Notifications. 

2. Using the Employee LOV, select a contact. This may populate the Email address 
field, depending on your setup.

3. Select an option from the Email When drop-down box. 

4. Click Add Myself as a Contact if desired. Select Email When option from the 
drop-down box.

5. To remove a contact, use the eraser icon tool.

6. Click Update or Restore.

3.7.5 Adding Source Files to Defects
Source Files allow you to view, create, update and remove source file references that 
were altered in order to resolve a defect.

To add source files to a defect:

1. Navigate to Defects > Summary > Defect Number> Defect Details > Source File. 

2. Enter the file name in the Filename field.

3. Enter the file version in the File Version field.

4. Select a modification type from the Modification Type drop-down box. 

5. Add any comments in the Comments field.

6. To remove an entry, use the eraser icon tool.
3-24 Oracle Quality Online Concepts and Procedures                             



Creating Enhancements
7. Click Update or Restore.

3.7.6 Adding Tasks to Defects
Tasks manage activities requiring the coordination of multiple employees. Task 
Templates auto fill the create template screen. These can be configured by an 
administrator to create multiple tasks.

To add Tasks to a defect:

1. Navigate to Defects > Summary > Defect Number> Defect Details > Tasks. 

2. Click Create Task.

3. Creating a Task using a template:

a. In the Template Information section, select a template group from the 
Template Group Name drop-down box. Select a template from the Task 
Template drop-down box.  Click Go. The page refreshes with the template 
values.

b. Enter the Task Owner and End Date information manually if the template 
does not auto fill these fields. 

c. Click Create.

4. Creating a Task without using a template:

a. In the Task Information section, select a Task owner using the LOV. 

b. Select a task type from the Task Type drop-down box.

c. Enter a name for the task in the Task Name field. Enter a description in the 
Task Description field. 

d. Select a priority and a status from the drop-down boxes. Set Start and End 
Dates. End Date is mandatory.

e. Click Create or Restore. Select Back to return to the Defect Details page.

3.8 Creating Enhancements
This topic group provides information on:

� Creating Enhancements

� Creating an Enhancement Entering all Original Data

� Using Quick Create:
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� Based on an Existing Enhancement

� Based on an Existing Defect

� Based on a Service Request

3.8.1 Creating Enhancements
Creating an enhancement is a two-page process involving data collection and notes 
input. Starred fields are mandatory. The Notes templates on page 2 of the process 
vary based on the Type, Category, and product.

3.8.1.1 Creating an Enhancement Entering all Original Data
To create an enhancement entering all original data:

1. Navigate to Create Enhancement. 

2. The Create Enhancement Page- Step 1 of 2 appears. Starred fields are 
mandatory:

a. Using the Type drop-down box, select enhancement type.

b. Using the Phase drop-down box, select phase. Select phase status from the 
Phase Status drop-down box.

c. Select desirability from the Customer Desirability drop-down box. 

d. Select the customer type using the Customer Type radio buttons.

e. Select customer information using the Customer Number LOV or Customer 
Name LOV.

f. Check the Published checkbox if external customers will view the 
enhancement.

g. Associate enhancement with a Base Enhancement or Defect using the Base 
LOV, if required.

3. In the Product section, enter as much information as possible. Although only 
certain fields may be required, based on your setup, your entries in the other 
fields affect how the enhancement is handled:

a. Using the Product LOV, select a product. 

b. Using the Component LOV, select a component.

c. Enter a valid version number in the Version field, or use the LOV to select 
one.
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4. Click Continue after entering all values. The Create Enhancements Page- Step 2 
of 2 appears.

5. Enter a one line summary in the Summary text box. This will appear in the 
Enhancement Summary List. 

6. Enter Notes as indicated in the Note Template section. It is important to share as 
much information as possible to expedite the analysis process.

7. If you are prompted to answer any Yes/No questions, enter your responses 
using the Yes/No drop-down boxes.

8. At the bottom of the Notes input area, select Create to create your enhancement. 
Alternately select Clear or Cancel.

9. The enhancement details screen for the new enhancement appears after clicking 
Create. Make any needed changes, then click Update.

3.8.1.2 Using Quick Create:
Quick Creates are user templates for frequently recurring criteria. To create an 
enhancement using Quick Create:

1. Navigate to Create Enhancement. 

2. Using the Quick Create drop-down box, select the appropriate Quick Create 
template. Click Auto Fill to populate the enhancement create fields. Verify that 
the Auto Fill information is correct for the current enhancement.

3. Alternately, click Personalize to update the template or New to create a new 
template. 

4. Using the Base LOV, associate with a Base Enhancement or Defect if desired. 

5. Fill in any remaining fields wherever possible. Although only certain fields may 
be required based on your setup, your entries in the other fields affect how the 
enhancement is handled.

a. Using the Product LOV, select a product. 

b. For products that have components enter a component, and version value 
using the Component LOV and Version field if Auto Fill has not populated 
these fields already.

c. Enter a valid version number in the Version field, or use the LOV to select 
one. Required if the version is validated
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6. See Creating an Enhancement Entering all Original Data, Steps 4-9 to complete 
process.

3.8.1.3 Based on an Existing Enhancement
To create an enhancement based on an existing enhancement:

1. Navigate to Create Enhancement.

2. Using the Create based on drop-down box, select Enhancement. Enter the 
enhancement number or click Go to access the enhancement LOV. Select an 
enhancement. Click Auto Fill to populate the enhancement create fields. 

3. Fill in any remaining Product fields wherever possible. Although only certain 
fields may be required, based on your system setup, your entries in the other 
fields affect how the enhancement is handled.

4. See Creating an Enhancement Entering all Original Data, Steps 4-8 to complete 
process. 

3.8.1.4 Based on an Existing Defect
To create an enhancement based on an existing defect:

1. Navigate to Create Enhancement from Home or Enhancements page.

2. Using the Create based on drop-down box, select Defect. Input the defect 
number or click Go to access the defect LOV. Select a defect. Click Auto Fill to 
populate the defect create fields. Verify that the Auto Fill information is correct 
for the current enhancement

3. Fill in any remaining Product fields wherever possible. Although only certain 
fields may be required, based on your setup, your entries in the other fields 
affect how the enhancement is handled. 

4. See Creating an Enhancement Entering all Original Data, Steps 4-8 to complete 
process.

3.8.1.5 Based on a Service Request
To create an enhancement based on a Service Request:

1. Navigate to Create Enhancement.

2. Using the Create based on drop-down box, select Service Request. Input the 
Service Request number.
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3. Click Auto Fill to populate the enhancement create fields. Verify that the Auto 
Fill information is correct for the current enhancement. The Summary field on 
the second Create page will Auto Fill with the  Service Request summary. You 
can delete this and enter a unique summary if desired.

4. If you don’t know the number, click Go to access the Service Request LOV, 
select a Service Request, then repeat Step 3 above.

5. Fill in any remaining Product fields wherever possible. Although only certain 
fields may be required, based on your setup, your entries in the other fields 
affect how the enhancement is handled.

6. See Creating an Enhancement Entering all Original Data, Steps 4-8 to complete 
process.

3.9 Managing Enhancements
This topic group includes instructions for:

� Responding to Newly Filed Enhancements

� Changing Notifications in Enhancements

� Adding Notes to an Enhancement

� Moving Enhancement to Another Phase

� Closing Enhancements

� Reassigning Enhancement Ownership

� Prioritizing Enhancements

� Viewing Enhancements History Details

� Navigating Through Enhancements

� Viewing the Enhancement Dependency Tree

� Updating Multiple Enhancements

� Mass Updating Enhancements

� Printing Enhancements

3.9.1 Responding to Newly Filed Enhancements
To respond to newly filed enhancements:
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1. Navigate to the Enhancement Details page.

2. Verify that all information is correct, makes sense, and that the enhancement 
request meets with your internal requirements.

3. Verify that the enhancement is not a duplicate. If you determine that the 
enhancement is a duplicate:

a. Using the Base Enhancement LOV, select the original enhancement.

b. Select an appropriate phase using the Phase drop-down box.

c. Select Duplicate Request using the Phase Status drop-down box. 

d. Change the status to Closed using the Status radio buttons.

e. Click Update.

4. If you require more information about the enhancement:

a. Set an appropriate phase and phase status.

b. Add a Note (See Section Adding Notes to an Enhancement.)

c. Verify that all contact information is correct in the Miscellaneous section.

d. Click Update.

5. Use any of the relevant steps in this Section and in Enhancement Details for 
further enhancement management. 

3.9.2 Changing Notifications in Enhancements
To change notification:

1. Navigate to the Enhancements Details page. Click Notifications.

2. Using the Employee LOV, select a new employee contact. Using the Email 
When drop-down list, select a notification option.

3. Select Add Myself as a Contact if desired. Select an Email When notification 
option. Click Update.

4. To delete a contact, check the Remove column. Click Update.

3.9.3 Adding Notes to an Enhancement
To add Notes to an enhancement:
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1. Navigate to the Enhancement Details page. Scroll down to the Add a Note 
Section.

2. Select a note type from the Type drop-down box. If you want this Note visible 
to external customers, select the Publish check box.

3. In the Note Field, enter the note. Click Update.

4. To add detailed notes, click More and enter the detailed information. Click 
Close when finished.

5. Review notes in the Details section. There are four Note View options:

� Notes

� Notes - Summarized

� Notes with key updates

� Notes with all updates 

To view Note details:

a. In the Details section, select a viewing option from the View drop-down list. 

b. Click Go. 

c. Scroll down to the Details section to view Note details. Click on any 
hyperlinks for details.

d. Click the Edit icon to view the entire note. Click the More button to see any 
additional Note information you added.

3.9.4 Moving Enhancement to Another Phase
 Enhancement ownership may change when moving an enhancement to a new 
phase. To move an enhancement to its next phase:

1. Navigate to the Enhancement Details page.

2. In the Phase drop-down box, select a new phase for the enhancement. 

3. Click Update or Restore.

3.9.5 Reassigning Enhancement Ownership
To reassign enhancement ownership:

1. Navigate to the Enhancement Details page. 
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2. To manually assign enhancement ownership. uncheck the Automatically 
Reassign checkbox. Using the Owner LOV, select a new owner.

3. To automatically reassign this owner, check the Automatically Reassign check 
box. Normal assignment rules, based on your Territory setup, will apply (See 
Chapter 1, Understanding Oracle Quality Online for details).

4. Click Update.

3.9.6 Prioritizing Enhancements
Prioritizing enhancements allows you to set an internal priority that differs from the 
severity logged by the filer. To prioritize enhancements:

1. Navigate to Enhancement Details. 

2. Using the Internal Priority drop-down box, select a priority level. 

3. Click Update.

3.9.7 Closing Enhancements
To close an enhancement:

1. Navigate to Enhancement Details.

2. Select Closed using the Status radio button.

3. Select an appropriate Phase and, if applicable, an appropriate Phase Status, 
using the drop-down boxes.

4. Click Update.

3.9.8 Viewing Enhancements History Details
To view enhancement history:

1. Navigate to Enhancement Details. Scroll to the Details section. 

2. Select a viewing option from the View drop-down list, then click Go. The page 
refreshes with the enhancement history visible in the Details section.

3.9.9 Navigating Through Enhancements
You can continuously update enhancements directly from the Enhancement Details 
page. Searches can also return lists that are navigable using this feature. 
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To navigate through enhancements:

1. Navigate to Enhancement Details. After making changes, click Update and 
Next. This takes you to the next enhancement on your Summary list. 

2. Alternately, click Update and Previous, to access the previous enhancement. 

3.9.10 Viewing the Enhancement Dependency Tree
To view the dependency tree for a specified enhancement:

1. Navigate to Enhancement Details.

2. Click the Tree hyperlink next to the Base Enhancement LOV. The Base Defect 
and Enhancement Tree page appears, displaying related dependencies. Links 
added from the Links page will not be visible from the Tree.

3. Click Back to return to the Enhancement Details page. 

3.9.11 Updating Multiple Enhancements
To update multiple enhancements at one time, changing field values and adding 
note information:

1. Navigate to Enhancements > Summary. 

2. Click Deselect All to clear all checkboxes.

3. Using the checkboxes, select only those enhancements that you want to update. 

4. Click Update. A red-text note appears at the top of the page, indicating how 
many enhancements will be affected by this update. Verify that this number is 
correct. 

5. Make updates as needed using the LOVs, text- and drop-down boxes.

6. Add a Note if desired.

7. Click Update (x) Enhancements. Confirm your update in the confirmation box. 
Review your Mass Update Status Report.

8. Alternately, click Restore to clear input and start over. 

3.9.12 Mass Updating Enhancements
To update all enhancements in the Summary at one time and enter note 
information:
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1. Navigate to Enhancements > Summary. 

2. Click Select All to select all enhancements in the Summary.

3. Click Update. A red-text note appears at the top of the page, noting how many 
enhancements will be affected by this update. 

4. Make updates as needed using the LOVs, text- and drop-down boxes.

5. Add a Note if desired.

6. Click Update (x) Enhancements. Confirm your update in the confirmation box. 
Review your Mass Update Status Report. 

3.9.13 Printing Enhancements
Oracle Quality Online can format the enhancement details page to print within the 
width of a page. To print enhancements:

1. Navigate to the Enhancement Details page.

2. After verifying all the information on the Enhancement Details page, click 
Printer Friendly Format. The enhancement details display in page-width format 
for clear printing. 

3.10 Enhancement Details
This topic group includes instructions for:

� Adding Attachments to Enhancements

� Adding Links to Enhancements

� Submitting Notifications to Enhancements

� Adding Tasks to Enhancements

3.10.1 Adding Attachments to Enhancements
To add attachments to enhancements:

1. Navigate to Enhancements > Summary > Enhancement Number> Enhancement 
Details > Attachments   

2. Click Add Attachment. The Add Attachment page appears.

3. Enter a description in the description field. 
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4. Using the Browse button, browse to the file and select it. 

5. Click Add Attachment. The file name appears in the Attachments column.

6. To remove an Attachment, check the box in the Remove column. Click Update. 

3.10.2 Adding Links to Enhancements
Links allow you to view, create, update and remove relationships between 
enhancements, and relationships between enhancements, service requests, or other 
objects such as patches.

To add a link to enhancements:

1. Navigate to Enhancements > Summary > Enhancement Number> Enhancement 
Details > Links. 

2. To link related enhancements and/or defects:

a. Select a relationship from the Relationship drop-down box.

b. Enter the enhancement number in the Number field, or search using the 
Number LOV in the Related Enhancements section. 

c. To remove a link, use the eraser icon tool in the Unlink column. 

d. Click Update to save the data, or Restore to clear the field. 

3. To link related Service Requests:

a. Enter the Service Request number in the Number field, or search using the 
Number LOV in the Related Service Requests section. 

b. To remove a link, use the eraser icon tool in the Unlink column. 

c. Click Update or Restore.

4. To link to other objects:

a. Select a document type from the Document drop-down box in the Related 
Documents section.

b. Enter the object number in the Number field, or search using the Number 
LOV.

c. To remove a link, use the eraser icon tool in the Unlink column.

d. Click Update or Restore.
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3.10.3 Submitting Notifications to Enhancements
Notifications allow you to view, create, update and remove notification contacts for 
an enhancement.

To submit notifications:

1. Navigate to Enhancements > Summary > Enhancement Number> Enhancement 
Details > Notifications.

2. Using the Employee LOV, select a contact from Select a Contact page that 
appears. 

3. Select an option from the Email When drop-down box.

4. Click Add Myself as a Contact if desired.

5. To remove a contact, use the eraser icon tool.

6. Click Update or Restore.

3.10.4 Adding Tasks to Enhancements
Tasks manage activities requiring the coordination of multiple employees. Task 
Templates auto fill the create template screen. These can be configured by an 
administrator to create multiple tasks.

To add Tasks to an enhancement:

1. Navigate to Enhancements > Summary > Enhancement Number> Enhancement 
Details > Tasks.

2. Click Create Task

3. Creating a Task using a template:

a. In the Template Information section, select a template group from the 
Template Group Name drop-down box. Select a template from the Task 
Template drop-down box. Click Go. The page refreshes with the template 
values.

b. Enter the Task Owner and End Date information manually if the template 
does not auto fill these fields.

c. Click Create.

4. Creating a Task without using a template:

a. In the Task Information section, select a Task owner using the LOV.
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b. Select a task type from the Task Type drop-down box.

c. Enter a name for the task in the Task Name field. Enter a description in the 
Task Description field.

d. Select a priority and a status from the drop-down boxes. Set Start and End 
Dates. End Date is mandatory.

e. Click Create or Restore. Select Back to return to the Enhancement Details 
page.

3.11 Creating and Running Reports
This topic group includes:

� Creating Count Reports

� Creating Ratio Reports

� Running/Viewing/Updating My Reports

3.11.1 Creating Count Reports
Count reports record the count of specific defects or enhancements, over a specified 
time period, grouped by a chosen attribute.

To create Count Reports:

1. Navigate to Defects or Enhancements > Reports > Count Report.

2. Enter a title for the report in the Report Title field. 

3. Select a time period from the Period Type drop-down box. Using the calendar 
icon select a Period End Date.

4. Select a grouping option from the Group By drop-down box.

5. Complete the Filter sections to add Product Category, Product, Component, 
Version(s), Resolution and Ownership parameters. 

6. Enter a report name in the Report Name field. 

7. Select Always run for current period or Always run for indicated period using 
the radio buttons. 

8. Click Save. 
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3.11.2 Creating Ratio Reports
Ratio reports record the ratio of specific defects or enhancements over a specified 
time period, grouped by Severity for Defects and Desirability for Enhancements.

To create Ratio Reports:

1. Navigate to Defects or Enhancements > Reports > Ratio Report.

2. Enter a title for the report in the Report Title field. 

3. Select a time period option from the Period Type drop-down box. Using the 
calendar icon, select a Period End.

4. In the Group Filter section, select a product category using the Product 
Category drop-down box.  For defects, select a tracking group using the 
Tracking Group drop-down box. 

5. In the Product, Product/Platform Filter section, add any additional values.

6. In the Save Report section, enter a report name in the Report Name field. 

7. Select  Always run for current period or Always run for indicated period using 
the radio buttons. 

8. Click Save.

3.11.3 Running/Viewing/Updating My Reports
To run, view and/or update My Reports:

1. Navigate to Defects or Enhancements > Reports. The My Reports section of the 
Reports Screen lists saved reports.

2. To remove a report, check the box in the Remove column, then click Update.

3. To run a report, click on the report title link in the Report Name column.

4. If necessary, make any changes to the report parameters then click Save.

5. Click Run Report to view the report.
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