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Preface

Audience for This Guide
Welcome to Release 11i of the Oracle HTML Quoting Implementation Guide.

This guide assumes you have a working knowledge of the following:

� The principles and customary practices of your business area.

� Oracle HTML Quoting

If you have never used Oracle HTML Quoting, Oracle suggests you attend one 
or more of the Oracle HTML Quoting training classes available through Oracle 
University.

� The Oracle Applications graphical user interface. 

To learn more about the Oracle Applications graphical user interface, read the 
Oracle Applications User’s Guide.

See Other Information Sources for more information about Oracle Applications 
product information.

How To Use This Guide
This guide contains the information you need to understand and use Oracle HTML 
Quoting.

� Chapter 1 provides an overview of Oracle HTML Quoting’s features and a list 
of new functionality.

� Chapter 2 describes Oracle HTML Quoting’s architecture and lists the 
minimum software and hardware requirements.
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� Chapter 3 lists the mandatory and conditional dependencies of Oracle HTML 
Quoting.

� Chapter 4 provides an overview of the implementation process.

� Chapter 5 lists the specific tasks involved in the implementation of Oracle 
HTML Quoting.

� Chapter 6 contains a list of tasks for verifying the implementation.

� Appendix A provides a complete list of the profile options users must set for 
Oracle HTML Quoting.

Typographic Conventions
This manual uses the typographic conventions listed in the following table:

Documentation Accessibility 
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 
markup to facilitate access by the disabled community. Standards will continue to 
evolve over time, and Oracle Corporation is actively engaged with other 
market-leading technology vendors to address technical obstacles so that our 
documentation can be accessible to all of our customers. For additional information, 
visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/.

Convention Meaning

italic text Book titles

Courier text User commands, file content examples, directory names

UPPERCASE Structured Query Language (SQL) commands, initialization 
parameters, profile options, responsibilities, or environment 
variables

boldface text Menu, button, keyboard, and form options

< >  Angle brackets enclose user-supplied names.

Note: Do not type the angle brackets.
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Accessibility of Code Examples in Documentation JAWS, a Windows screen 
reader, may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, JAWS may not always read a line of text that 
consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation This 
documentation may contain links to Web sites of other companies or organizations 
that Oracle Corporation does not own or control. Oracle Corporation neither 
evaluates nor makes any representations regarding the accessibility of these Web 
sites. 

Other Information Sources
You can choose from many sources of information, including online documentation, 
training, and support services, to increase your knowledge and understanding of 
Oracle HTML Quoting.

If this guide refers you to other Oracle Applications documentation, use only the 
Release 11i versions of those guides.

Online Documentation
All Oracle Applications documentation is available online (HTML or PDF). Online 
help patches are available on MetaLink.

Related Documentation
Oracle HTML Quoting shares business and setup information with other Oracle 
Applications products. Therefore, you may want to refer to other product 
documentation when you set up and use Oracle HTML Quoting.

You can read the documents online by choosing Library from the expandable menu 
on your HTML help window, by reading from the Oracle Applications Document 
Library CD included in your media pack, or by using a Web browser with a URL 
that your system administrator provides.

If you require printed guides, you can purchase them from the Oracle Store at 
http://oraclestore.oracle.com.
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Documents Related to All Products

Oracle Applications User’s Guide
This guide explains how to enter data, query, run reports, and navigate using the 
graphical user interface (GUI) available with this release of Oracle HTML Quoting 
(and any other Oracle Applications products). This guide also includes information 
on setting user profiles, as well as running and reviewing reports and concurrent 
processes.

You can access this user’s guide online by choosing “Getting Started with Oracle 
Applications” from any Oracle Applications help file.

Documents Related to This Product
See the manuals listed below for more information relevant to implementing Oracle 
HTML Quoting:

Oracle HTML Quoting Concepts and Procedures, Release 11i
This document provides users with information on using Oracle HTML Quoting to 
create, manage, and personalize quotes for customers in a secure Web-based 
environment.

Oracle iStore API Reference Guide, Release 11i
This document provides users with information about the APIs used by Oracle 
HTML Quoting.

Oracle iStore Implementation Guide, Release 11i 
This document provides users with information on implementing Oracle iStore, 
including procedures for setting up and customizing Oracle iStore, profile option 
descriptions, and API documentation.

Oracle iStore Concepts and Procedures, Release 11i 
This document provides users with information on general principles and 
procedures for maintaining Web stores using Oracle iStore.

Oracle Inventory User’s Guide, Release 11i 
This document provides users with information on setting up products in Oracle 
Inventory.
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Oracle Quoting - Forms Implementation Guide, Release 11i 
This document provides users with information on implementing Oracle Quoting - 
Forms, including procedures for setting up quote statuses and status transitions. 
This document also contains the Oracle Order Capture Foundation APIs used by 
Oracle HTML Quoting.

Oracle Pricing User’s Guide, Release 11i 
This document provides information on setting up promotion codes, pricing 
agreements, and price lists in Oracle Pricing.

Oracle Sales Online Concepts and Procedures, Release 11i
This document provides information on using Oracle Sales Online, including 
procedures for using Notes and Tasks.

Oracle Sales Online Implementation Guide, Release 11i
This document provides information on implementing Oracle Sales Online, 
including procedures for integrating Oracle Sales Online with Oracle HTML 
Quoting.

Oracle Applications System Administrator’s Guide, Release 11i 
This document provides information on creating responsibilities and other system 
administrator tasks in Oracle Applications.

Oracle CRM Foundation Implementation Guide, Release 11i 
This document provides information on implementing Oracle CRM Foundation, 
including procedures for creating user roles and details about CRM resources.

Implementing Oracle CRM: ERP Functional Checklist
This document provides information on the functional flows of other Oracle 
Enterprise Resource Planning (ERP) Applications when integrated with Oracle 
Customer Relationship Management products.

Implementing Oracle CRM: Foundation Functional Checklist
This document provides information on the functional flows of other Oracle 
Foundation Applications when integrated with Oracle Customer Relationship 
Management products.
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Installation and System Administration

Oracle Applications Concepts
This guide provides an introduction to the concepts, features, technology stack, 
architecture, and terminology for Oracle Applications Release 11i. It provides a 
useful first book to read before an installation of Oracle Applications. This guide 
also introduces the concepts behind Applications-wide features such as Business 
Intelligence (BIS), languages and character sets, and Self-Service Web Applications.

Installing Oracle Applications
This guide provides instructions for managing the installation of Oracle 
Applications products. In Release 11i, much of the installation process is handled 
using Oracle Rapid Install, which minimizes the time to install Oracle Applications, 
the Oracle8 technology stack, and the Oracle8i Server technology stack by 
automating many of the required steps. This guide contains instructions for using 
Oracle Rapid Install and lists the tasks you need to perform to finish your 
installation. You should use this guide in conjunction with individual product 
user’s guides and implementation guides.

Upgrading Oracle Applications
Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or 
Release 11.0 products to Release 11i. This guide describes the upgrade process and 
lists database and product-specific upgrade tasks. You must be either at Release 10.7 
(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 11i. 
You cannot upgrade to Release 11i directly from releases prior to 10.7.

Maintaining Oracle Applications
Use this guide to help you run the various AD utilities, such as AutoUpgrade, 
AutoPatch, AD Administration, AD Controller, AD Relink, License Manager, and 
others. It contains how-to steps, screenshots, and other information that you need to 
run the AD utilities. This guide also provides information on maintaining the 
Oracle applications file system and database.

Oracle Applications System Administrator’s Guide
This guide provides planning and reference information for the Oracle Applications 
System Administrator. It contains information on how to define security, customize 
menus and online help, and manage concurrent processing.
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Other Implementation Documentation

Oracle eTechnical Reference Manuals
Each eTechnical Reference Manual (eTRM) contains database diagrams and a 
detailed description of database tables, forms, reports, and programs for a specific 
Oracle Applications product. This information helps you convert data from your 
existing applications, integrate Oracle Applications data with non-Oracle 
applications, and write custom reports for Oracle Applications products. Oracle 
eTRM is available on Metalink

Oracle CRM Application Foundation Implementation Guide
Many CRM products use components from CRM Application Foundation. Use this 
guide to correctly implement CRM Application Foundation.

Training and Support

Training
Oracle offers training courses to help you and your staff master Oracle HTML 
Quoting and reach full productivity quickly. You have a choice of educational 
environments. You can attend courses offered by Oracle University at any one of 
our many Education Centers, you can arrange for our trainers to teach at your 
facility, or you can use Oracle Learning Network (OLN), Oracle University’s online 
education utility. In addition, Oracle training professionals can tailor standard 
courses or develop custom courses to meet your needs. For example, you may want 
to use your organization’s structure, terminology, and data as examples in a 
customized training session delivered at your own facility.

Support
From on-site support to central support, our team of experienced professionals 
provides the help and information you need to keep Oracle HTML Quoting 
working for you. This team includes your Technical Representative, Account 
Manager, and Oracle’s large staff of consultants and support specialists with 
expertise in your business area, managing an Oracle8i server, and your hardware 
and software environment.

OracleMetaLink
OracleMetaLink is your self-service support connection with web, telephone menu, 
and e-mail alternatives. Oracle supplies these technologies for your convenience, 
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain 
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information and advice from technical libraries and forums, download patches, 
download the latest documentation, look at bug details, and create or update TARs. 
To use MetaLink, register at (http://metalink.oracle.com).

Alerts: You should check OracleMetaLink alerts before you begin to install or 
upgrade any of your Oracle Applications. Navigate to the Alerts page as follows: 
Technical Libraries/ERP Applications/Applications Installation and 
Upgrade/Alerts.

Self-Service Toolkit: You may also find information by navigating to the 
Self-Service Toolkit page as follows: Technical Libraries/ERP 
Applications/Applications Installation and Upgrade.

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
Browser, database triggers, or any other tool to modify Oracle Applications 
data unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity 
of your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using 
Oracle Applications can update many tables at once. But when you modify 
Oracle Applications data using anything other than Oracle Applications, you 
may change a row in one table without making corresponding changes in 
related tables. If your tables get out of synchronization with each other, you risk 
retrieving erroneous information and you risk unpredictable results throughout 
Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications 
automatically checks that your changes are valid. Oracle Applications also keeps 
track of who changes information. If you enter information into database tables 
using database tools, you may store invalid information. You also lose the ability 
to track who has changed your information because SQL*Plus and other 
database tools do not keep a record of changes.

About Oracle
Oracle Corporation develops and markets an integrated line of software 
products for database management, applications development, decision 
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support, and office automation, as well as Oracle Applications, an integrated 
suite of more than 160 software modules for financial management, supply 
chain management, manufacturing, project systems, human resources and 
customer relationship management.

Oracle products are available for mainframes, minicomputers, personal 
computers, network computers and personal digital assistants, allowing 
organizations to integrate different computers, different operating systems, 
different networks, and even different database management systems, into a 
single, unified computing and information resource.

Oracle is the world’s leading supplier of software for information management, and 
the world’s second largest software company. Oracle offers its database, tools, and 
applications products, along with related consulting, education, and support 
services, in over 145 countries around the world.
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1
Introduction

This topic group provides an overview of the Oracle HTML Quoting application 
and its components and lists functionality new in this release.

� Oracle HTML Quoting Overview

� Oracle HTML Quoting Features

� New in this Release
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1.1 Oracle HTML Quoting Overview
Oracle HTML Quoting is an electronic commerce application which provides a 
Web-based interface for assisted selling of products and services to customers and 
business partners. Oracle HTML Quoting enables the easy creation, management 
and personalization of customer quotes in a secure environment. With seamless 
integration to Oracle Enterprise Resource Planning (ERP) applications and other 
Oracle Customer Relationship Management (CRM) applications, Oracle HTML 
Quoting enables companies to provide optimum customer service during the 
campaign and sales processes. 

1.1.1 Oracle HTML Quoting Features
Oracle HTML Quoting includes the following key functionality:

� Create and administer quotes

� Configure complex products

� Manually adjust quote prices

� Perform real time global availability checks

� Accept product trade-ins

� Assign sales credits

� Convert quotes to orders

1.2 New in this Release
Oracle HTML Quoting contains the following new functionality in this release:

� General Services Administration (GSA) Pricing

GSA is a customer classification that indicates that the customer is a U.S. 
government customer. Specific GSA price lists for the customers must be set up 
in Pricing. Items listed on the GSA price list cannot be sold to commercial 
customers for the same price or less than the government. You can now enable 
HTML Quoting to respond to GSA pricing violations.

� Ability to add service items

HTML quoting supports the use of warranties, services included in the 
purchase of the product, and extended warranties, services that you can 
purchase in addition to the product, in 11.5.6. 
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� Ability to multi-select items to add to a quote

From the product search results, you can now multi-select items to add to a 
quote.
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2
Technology, Requirements, and

Performance

This topic group contains an overview of the Oracle HTML Quoting’s architecture 
and a description of the minimum software and hardware requirements.

� Architectural Overview

� Minimum Software Requirements

� Minimum Hardware Requirements
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2.1 Architectural Overview
Oracle Applications run on a three-tiered framework known as Internet Computing 
Architecture. 

� The desktop tier provides the user interface display. In Internet Computing 
Architecture, only the presentation layer of the application is on this tier, in the 
form of a plug-in to a standard Internet browser.

� The middle tier, or application tier, manages Oracle applications and other 
tools.

� The database tier manages the Oracle8i database, which provides centralized 
storage and schema.

HTML-based products, such as Oracle HTML Quoting, rely on HTTP-based servers 
on the application tier and a Java-enabled Web browser on the desktop.

Oracle HTML Quoting operates by direct connection to the Apache HTTP server. 
Logic is controlled through stored procedures performed by the PL/SQL cartridge 
and by Java servlets and JavaServer Pages (JSP), executed by the Apache JServ 
module. Apache communicates with the database using JDBC (Java Data Base 
Connectivity).

2.2 Minimum Software Requirements
The following table lists the minimum software requirements for Oracle HTML 
Quoting:

2.3 Minimum Hardware Requirements
The following table lists the minimum hardware requirements for Oracle HTML 
Quoting implementation.

Table 2–1 Minimum Software Requirements

Tier Software Required

Middle tier/application 
tier

Apache HTTP Server

Apache JServ module

Oracle Forms Server

Database tier Oracle8i Enterprise Edition (8.1.7)
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Table 2–2 Minimum Hardware Requirements for Oracle HTML Quoting

Requirement Minimum value

CPU 70 users per CPU.

Memory 8 MB per user.

Disk Space 22 GB
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3
Dependency Requirements and Verification

This topic group provides information on the applications and modules that 
integrate with Oracle HTML Quoting.

� Mandatory Dependencies

� Conditional Dependencies

� Installation and Dependency Verification
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3.1 Mandatory Dependencies
Oracle HTML Quoting depends on Oracle iStore, Oracle Inventory, Oracle Quoting 
- Forms, Oracle Order Management, and Oracle Pricing.

3.1.1 Oracle iStore
You must install Oracle iStore before using Oracle HTML Quoting. Oracle HTML 
Quoting uses the Oracle iStore permissions, specialty stores, and shopping cart, as 
well as some Oracle iStore (IBE) profile options.

Permissions
A Sales Representative role in Oracle HTML Quoting uses Oracle iStore 
permissions. See Oracle iStore Implementation Guide for more information about 
Oracle iStore permissions.

Specialty Stores
You must set up at least one Oracle iStore specialty store with the products that you 
want the sales representatives to sell.

You can set up multiple specialty stores for your sales representatives with different 
listings of products, which allows additional flexibility and control for you to do the 
following:

� Organize products to help your sales representatives find specific products 
easily

� Restrict which products a given sales representative can sell, by providing 
access to some specialty stores and restricting access to others.

See Oracle iStore Implementation Guide and Oracle iStore Concepts and Procedures for 
more information about setting up specialty stores.

Shopping Cart
The sales representative builds quotes for customers by leveraging the Oracle iStore 
shopping cart functionality. A shopping cart and a quote are essentially the same. 
The same object is referred to as a shopping cart with respect to B2B and B2C 
customers in Oracle iStore, and as a quote with respect to the sales representatives 

Note: Specialty stores are also called "minisites."
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in Oracle HTML Quoting. See Oracle iStore Concepts and Procedures for more 
information about the Oracle iStore shopping cart.

Profile Options
See Appendix A, "Profile Options" for more information about the Oracle iStore 
profile options that you need to set when implementing Oracle HTML Quoting.

3.1.2 Oracle Inventory
The setup of Oracle iStore is dependent on product item setup in Oracle Inventory. 
See Oracle iStore Implementation Guide and Oracle Inventory User’s Guide for more 
information.

This section addresses the setup of items to allow trade-ins, a specific Oracle HTML 
Quoting functionality.

If your merchant organization provides credit to customers for returning or 
decommissioning existing products when they purchase new products, you can set 
up Oracle HTML Quoting to allow a sales representative to add a customer’s 
trade-in items to a quote.

Sales representatives add trade-in items to a quote by performing a product search 
for the items, adding the items to the quote, and marking their line type as a Line 
Category of Return. When the application  calculates the order total, it treats the 
prices of trade-in items as credits, and subtracts them from the order total. 

All items on a quote, including trade-in items, must exist in Oracle Inventory. All 
items that are eligible for trade-in must have their Returnable flags set to Yes.

Any obsolete items that are eligible for trade-in must still exist in Oracle Inventory.

If your merchant organization allows trade-ins of other merchants’ products that 
would not exist in your instance of Oracle Inventory, you must set up dummy items 
in Oracle Inventory to represent these trade-in items for the quotes.

For obsolete or dummy items, set the Customer Orderable flag to No.

Use the following procedure to set the Returnable flag for an item that is eligible for 
trade-in.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/
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and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the Inventory responsibility.

3. Choose Items > Master Items.

The Organizations window opens.

4. In the Organizations window, search for and highlight the organization that has 
the trade-in item, and click OK.

The Master Item form opens.

5. Choose View > Find.

The Find Master Items window opens.

6. In the Find Master Items window, enter your search criteria for the trade-in 
item, and click Find.

The Master Items Summary window opens.

7. Highlight the trade-in item and click Open.

The Master Item form for the trade-in item opens.

8. In the Order Management tab, select the Returnable checkbox.

9. Optional: In the Order Management tab, uncheck the Customer Orders Enabled 
checkbox for obsolete or dummy trade-in items.

10. Click the Save icon in the toolbar to save the record.

You must also set the profile option IBE: Use Line Types to Yes to allow sales 
representatives to mark items as trade-ins by changing their line types to Return. 
See Appendix A, "Profile Options" for more information.

3.1.3 Oracle Quoting - Forms
Oracle iStore is dependent on the setup of Oracle Quoting - Forms. See Oracle iStore 
Implementation Guide and Oracle Quoting - Forms Implementation Guide for more 
information.

3.1.3.1 Setting Up Payment Types
Oracle HTML Quoting displays payment types during checkout from the FND_
LOOKUP_VALUES table for the Quoting- Forms lookup type ASO_PAYMENT_
TYPE. The seeded values for ASO_PAYMENT_TYPE are credit card, cash, check, 
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purchase order, faxed credit card, and invoice. Oracle HTML Quoting displays all of 
the payment types that are in the lookup table.

See Oracle Quoting - Forms Implementation Guide for instructions on setting up the 
ASO_PAYMENT_TYPE lookup values.

3.1.3.2 Setting Up Quote Status Transitions
Sales representatives can create multiple versions of a quote for a customer. To 
enable the versioning functionality, you must set up Oracle Quoting - Forms to 
allow the quote status to transition from Drafted to Drafted.

Use the following procedure to set up the Drafted-to-Drafted status transition.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the Order Capture Sales Manager responsibility.

3. Choose Quote Status Setup.

The Quote Status Setup window opens.

4. In the Quote Statuses region, select Drafted.

The Allowed Transition to Status region is populated with the quote statuses 
that can be assigned to a quote of Drafted status.

5. In the Allowed Transition to Status region, select Drafted from a Code field’s 
list of values (LOV) if it is not already listed in the region.

6. Click the Save icon in the toolbar to save the record.

You can also use the Oracle Quoting Quote Status Setup window to modify other 
quote status transitions. See Oracle Quoting - Forms Implementation Guide for more 
information.

3.1.4 Oracle Order Management and Oracle Pricing
Oracle HTML Quoting allows sales representatives to use pricing agreements to 
price quotes.
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Pricing agreements are created in Oracle Order Management or Oracle Pricing. 
They set up the billing specifications that allow a quote to be priced. The attributes 
of a pricing agreement are price list, purchase order number, bill-to address, bill-to 
contact, invoicing terms, payment terms, and shipment terms. These attributes set 
up and apply default pricing rules in Oracle Order Management.

Each pricing agreement can have only one price list assigned to it, but one list can 
be linked to multiple agreements. You can create universal and customer-specific 
pricing agreements.

You can also set up promotion codes (also known as "offer codes") in Oracle Pricing. 
Sales representatives using Oracle HTML Quoting can enter these promotion codes 
to capture automatic discounts set up in the Oracle Pricing engine as available to 
request.

See Oracle Pricing User’s Guide for more information.

3.2 Conditional Dependencies
You can integrate Oracle HTML Quoting with Oracle Sales Online to extend its 
functionality.

3.2.1 Oracle Sales Online
Integrating Oracle HTML Quoting with Oracle Sales Online (OSO) provides Notes 
and Tasks functionality for Oracle HTML Quoting sales representatives. It also 
allows sales representatives to create quotes in a campaign-to-order work flow.

See Oracle Sales Online Implementation Guide for instructions on implementing OSO 
and setting up the Oracle HTML Quoting UI as part of OSO.

Set the IBE: Use Notes profile option to Yes to activate Notes functionality after 
OSO implementation.

Set the IBE: Use Tasks profile option to Yes to activate tasks functionality after OSO 
implementation.

See Appendix A, "Profile Options" for more information on profile options.

3.3 Installation and Dependency Verification
It is necessary to refer to the following documentation to ensure that all mandatory 
dependencies are installed, implemented, and set up correctly.

� ERP Functional Checklist
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� Implementing Oracle CRM: Foundation Functional Checklist
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4
Implementation Overview

This chapter provides general descriptions of the setup and configuration tasks 
required to successfully implement Oracle HTML Quoting. Topics include:

� Process Description

� Implementation Task Sequence
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4.1 Process Description
Sales representatives and other organization personnel can use Oracle HTML 
Quoting to create and manage quotes on a customer’s behalf. 

Implementing Oracle HTML Quoting involves the following tasks:

� Setting up the mandatory and optional Oracle application modules on which 
Oracle HTML Quoting depends

� Creating sales representative responsibilities and users

� Limiting ship-to and bill-to countries if necessary

� Setting profile options

� Set up GSA Pricing

4.2 Implementation Task Sequence
In order to fully implement Oracle HTML Quoting, you must perform the following 
steps:

1. Define a Sales Representative responsibility.

Before you can approve employees or other personnel as sales representatives, 
you must define at least one responsibility to assign to them. 

2. Set up sales representatives.

You must set sales representatives up as Oracle HTML Quoting users who have 
Sales Representative roles. A Sales Representative role’s permissions determine 
whether the user can submit quotes as orders, and to what extent the user can 
modify a quote.

3. Create an employee record.

There must be a record of your employee in Oracle Human Resources before 
you set him or her up as a sales representative.

4. Create a user name for a sales representative.

For each sales representative, you must create an Oracle HTML Quoting user 
name and password, assign responsibilities to the user name, and set up its 
profile options.

5. Assign a sales representative role.
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You must assign a Sales Representative role to the sales representative’s user 
name.

6. Import a CRM resource.

You must set up a sales representative as a CRM Resource, with a salesperson 
number and sales credit type, after assigning to him or her an Oracle HTML 
Quoting user name and a Sales Representative role.

7. Limit the available countries (bill-to or ship-to).

Sales representatives use the Country pull-down menu to select the country of 
the customer, contact or address, when searching for and creating customers, 
contacts, and addresses. You can limit this menu if necessary.

8. Set up GSA Pricing.

GSA is a customer classification that indicates that the customer is a U.S. 
government customer. If you want HTML Quoting to detect GSA violations, 
you must set the necessary profile options.

9. Set up Automatic Site Numbering.

Automatic Site Numbering must be turned on for the create customer 
functionality to perform properly.
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5
Implementation Tasks

This topic group provides you with the steps necessary to implement Oracle HTML 
Quoting.

� Creating Oracle HTML Quoting Sales Representatives

� Setting Profile Options

� Limiting the Available Countries

� GSA (General Services Administration) Pricing

� Set up Automatic Site Numbering
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5.1 Creating Oracle HTML Quoting Sales Representatives
The seeded Sales Representative role for Oracle HTML Quoting is IBE_SALESREP_
ROLE. Yet, you can also create new Sales Representative roles for your sales 
representatives with any set of quote creation permissions that you specify. 

Use the following procedures to create sales representatives for Oracle HTML 
Quoting.

5.1.1 Process Flow for Required Sales Representative Setups
Follow the overall process flow illustrated in the following diagram to perform the 
required setups that are related to creating Oracle HTML Quoting sales 
representatives.
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5.1.2 Defining a Sales Representative Responsibility
Before you can approve employees or other personnel as sales representatives, you 
must define at least one responsibility to assign to them. You can set up a structure 
of sales representative responsibilities that meets your business needs.

If you want some of your sales representatives to be able to sell all of your products, 
you can create a specialty store that contains every product listed in Oracle 
Inventory, then give them a responsibility that is supported by this specialty store 
and associated with the Master Inventory Organization.

You can associate different responsibilities with various operating units and 
specialty stores. For example, you can set up specific sales representative 
responsibilities that allow a sales representative to create quotes only against a 
certain operating unit or within certain specialty stores.

For more information about creating responsibilities, see Oracle Applications System 
Administrator’s Guide, Release 11i.

Use the following procedure to create a responsibility for sales representatives and 
associate it with an operating unit and at least one specialty store.

Login
Login to Oracle Forms.

Responsibility
To perform this task, you must use the System Administrator responsibility.

Prerequisites
None

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the System Administrator responsibility.

3. Choose Security > Responsibility > Define.

The Responsibilities form opens.
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4. Create a responsibility for an application, setting Data Group Name to 
Standard, Data Group Application to iStore, and Menu to iStore Quotes Root 
Menu.

5. Click the Save icon in the toolbar to save the record.

6. With your cursor in any field of the record, choose Help > Diagnostics > 
Examine.

The Examine Field and Variable Values window opens.

7. In the Examine Field and Variable Values window, choose APPLICATION_ID 
in the Field LOV. 

The Value field in the Examine Field and Variable Values window is populated 
with the value of APPLICATION_ID. Note this value.

8. In the Examine Field and Variable Values window, choose RESPONSIBILITY_
ID in the Field LOV. 

The Value field in the Examine Field and Variable Values window is populated 
with the value of RESPONSIBILITY_ID. Note this value.

9. From the Navigator - System Administrator window, choose Profile > System.

The Find System Profile Values window opens.

10. Check Site, Application, and Responsibility. Use the Application LOV to 
choose CRM Foundation. Use the Responsibility LOV to choose CRM 
Resource Manager.

11. In the Profile field, enter MO: Operating Unit.

12. Click Find.

The System Profile Values form opens with the results of your search.

13. Note the value of the profile MO: Operating Unit at the CRM Resource 
Manager responsibility level. Optionally, you can change it.

If the profile is not set at this level, note its value at the CRM Foundation 
application level. Optionally, you can change it.

If the profile is not set at this level, note its value at the site level. Optionally, 
you can change it.

Note: Choose a clearly identifiable responsibility name. 
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14. Choose View > Find.

The Find System Profile Values window opens.

15. Check Responsibility, and use the Responsibility LOV to search for and enter 
the name of the sales representative responsibility.

16. In the Profile field, enter MO: Operating Unit.

17. Click Find.

The System Profile Values form opens with the results of your search.

18. Set the profile MO: Operating Unit at the responsibility level to the operating 
unit that is the value of the profile MO: Operating Unit at the CRM Resource 
Manager responsibility/CRM Foundation application/site level.

19. Click the Save icon in the toolbar to save the record.

20. Launch the Oracle iStore Merchant UI by logging in to the Oracle CRM 
Applications login page at: 

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

with a user name that has the default responsibility IBE_ADMINISTRATOR 
and the default application iStore. (In other words, the user’s JTF_PROFILE_
DEFAULT_RESPONSIBILITY profile option is set to 21819, and the user’s JTF_
PROFILE_DEFAULT_APPLICATION profile option is set to 671).

21. In the Setup tab, click on the name link of the specialty store to which you want 
to assign the responsibility.

The Specialty Store Detail page opens.

22. Click Supported Responsibilities.

The Supported Responsibilities page opens.

23. Click Add Responsibility. 

The Select Responsibility pop-up window opens.

24. In the Select Responsibility pop-up window, search for the sales representative 
responsibility that you want this specialty store to support by application and 
responsibility name, key, or description. Check the Select checkbox next to the 
responsibility, and click Add. When you are finished, click Done. 

25. In the Supported Responsibilities page, click Update to save your changes.
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You can now assign this responsibility to employees and other personnel so that 
they can create quotes against the operating unit in the specialty stores that support 
the responsibility.

5.1.3 Setting Up Sales Representatives
You must set up sales representatives as Oracle HTML Quoting users who have 
Sales Representative roles. A Sales Representative role’s permissions determine 
whether the user can submit quotes as orders, and to what extent the user can 
modify a quote. You must also set up Oracle HTML Quoting users as CRM 
Resources.

You can set up sales personnel within your organization, value-added distributors 
and partners (VAD/Partner) of your organization, and anyone else who should be 
authorized to create quotes for your customers, as sales representatives.

You must perform the following tasks to set up each of your sales representatives:

Login
Login to Oracle Forms.

Responsibility
Each task below requires a different responsibility. Refer to the specific task for 
information on the responsibility.

Prerequisites
None

Steps
1. Creating a User Name for a Sales Representative

2. Assigning a Sales Representative Role

3. Importing a CRM Resource

If you are setting up an employee as a sales representative, you must first create a 
record of the employee before proceeding with these tasks. See Section 5.1.4, 
"Creating an Employee Record" for more information.
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5.1.4 Creating an Employee Record
Use the following procedure to verify or create a record of your employee.

Login
Login to Oracle Forms.

Responsibility
To perform this task, you must use the Human Resources responsibility.

Prerequisites
There must be a record of your employee in Oracle Human Resources before you 
set him or her up as a sales representative.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the Human Resources responsibility.

3. Choose People > Enter and Maintain.

The Find Person window opens.

4. In the Find Person window, enter the search criteria for the employee and click 
Find.

5. If a record of the employee exists, the People form opens with the record. 

Note the employee’s number.

6. If a record of the employee does not exist, perform the following  steps to create 
a record:

a. In the Find Person window, click New to create an employee record.

A blank People form opens.

b. In the People form, enter at least the employee’s last name, social security 
number, and birth date.

c. Place your cursor in the Type field and click the LOV button. 
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The Person Types window opens.

d. Highlight Employee and click OK.

e. Click the Save icon in the toolbar to save this employee’s record.

f. Note the employee’s number.

5.1.5 Creating a User Name for a Sales Representative
For each sales representative, you must create an Oracle HTML Quoting user name 
and password, assign responsibilities to the user name, and set up its profile 
options.

Use the following procedure to set up an Oracle HTML Quoting user name for a 
sales representative.

Login
Log in to Oracle Forms.

Responsibility
To perform this task, you must use the System Administrator responsibility.

Prerequisites
You have defined a responsibility for sales representatives and noted its 
APPLICATION_ID and RESPONSIBILITY_ID. See Section 5.1.2, "Defining a Sales 
Representative Responsibility" for more information.

If you are setting up an Oracle HTML Quoting user name for an employee, a record 
of the employee must exist in Oracle Human Resources. See Section 5.1.4, "Creating 
an Employee Record" for more information.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the System Administrator responsibility.

3. Choose Security > User > Define.
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The Users window opens.

4. In the User Name field, enter the user name that the sales representative will 
use to log in to Oracle HTML Quoting.

5. In the Password field, enter the sales representative’s password.

6. Place your cursor in the Person field or Customer field, depending on the 
resource category of the sales representative:

� If the sales representative is an employee, choose the Person field.

� If the sales representative is not an employee, choose the Customer field.

7. Use the LOV to search for and select the sales representative.

8. In the Responsibilities block, use the LOV button in a Responsibility field to 
assign a sales representative responsibility to the user name. 

9. Click the Save icon in the toolbar to save this user record.

10. From the Navigator - System Administrator window, choose Profile > System.

The Find System Profile Values window opens.

11. Check the checkbox next to the User field, and use the LOV to search for and 
enter the sales representative’s user name.

12. In the Profile field, enter JTF_PROFILE%.

13. Click Find.

The System Profile Values form opens with the results of your search.

14. Set the profile option JTF_PROFILE_DEFAULT_APPLICATION at the user level 
to the APPLICATION_ID value of the user name’s sales representative 
responsibility.

15. Set the profile option JTF_PROFILE_DEFAULT_RESPONSIBILITY at the user 
level to the RESPONSIBILITY_ID value of the user name’s sales representative 
responsibility.

16. Click the Save icon in the toolbar to save the records.

Guidelines
When assigning responsibilities to a sales representative, choose responsibilities that 
are associated with the operating units and specialty stores for which he or she 
should create quotes. If you want the sales representative to create quotes for all 
operating units, assign a responsibility that is associated with an operating unit 
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linked to the Master Inventory Organization. See Oracle iStore Implementation Guide 
for more information about defining the Master Inventory Organization in Oracle 
Inventory and associating responsibilities with operating units.

5.1.6 Assigning a Sales Representative Role
You must assign a Sales Representative role to the sales representative’s user name.

Use the following procedure to assign a Sales Representative role to a sales 
representative’s user name.

Login
Log in to Oracle CRM Applications.

Responsibility
To perform this task, you must use the System Administrator responsibility.

Prerequisites
A user name for the sales representative exists. See Section 5.1.5, "Creating a User 
Name for a Sales Representative" for more information.

Steps
1. Log in as SYSADMIN to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. In the Users tab, choose User Name from the Find Users pull-down menu, enter 
the sales representative’s user name in the adjacent text field, and click Go.

The Users page displays the sales representative’s user name in the search 
results.

3. Click on the user name link.

The User Details page for the user name opens.

4. Click Roles.

The User Role Mapping page opens.

5. Highlight IBE_SALESREP_ROLE (or another Sales Representative role that 
you have created) in the Available Roles list and click the ">" button to move it 
to the Assigned Roles list.
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6. Click Update to save this role assignment.

5.1.7 Importing a CRM Resource
You must set up a sales representative as a CRM Resource, with a salesperson 
number and sales credit type, after assigning to him or her an Oracle HTML 
Quoting user name and a Sales Representative role.

You can import a resource into the Oracle Resource Manager from different 
application databases depending on the resource type you choose. After selecting a 
resource based on its type, you identify its role and eligibility dates before saving it 
to Resource Manager as a CRM Resource.

Use the following procedure to set up a sales representative as a CRM Resource.

Login
Log in to Oracle Forms.

Responsibility
To perform this task, you must use the CRM Resource Manager responsibility.

Prerequisites
If you are importing an employee as a resource, a record of the employee must exist 
in Oracle Human Resources, and you should know the employee’s number. See 
Section 5.1.4, "Creating an Employee Record" for more information.

A user name for the sales representative exists, and you have assigned a Sales 
Representative role to it. See Section 5.1.5, "Creating a User Name for a Sales 
Representative" and Section 5.1.6, "Assigning a Sales Representative Role" for more 
information.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the CRM Resource Manager responsibility.

3. Choose Maintain Resources > Import Resources.
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The Selection Criterion window opens.

4. Choose Employee, Partner, Supplier Contact, Party, or another category from 
the Resource Category pull-down menu, as appropriate to the sales 
representative.

5. Optionally, you can enter other search criteria.

6. Optionally, if you are importing an employee resource, in the Number field, 
enter the employee number you noted when viewing or creating the 
employee’s record. 

7. Click Search.

The search results appear in the Search Results region of the Selection Criterion 
window.

8. Check the Select checkbox next to the person or organization that you are 
setting up as a sales representative. 

9. Click Create Resource.

The Default Values window opens.

10. Optionally, you can enter active dates, manager’s name, and role information in 
this window.

11. Click OK.

The Selected Resources window opens, showing the sales representative as a 
resource.

12. Check the Select checkbox next to the sales representative’s resource record and 
click Save Resource.

The sales representative is now saved as a CRM Resource.

13. Click Details.

The Resource form for the sales representative opens.

14. In the Salesperson Number field, enter an identifying number for the sales 
representative.

15. Click on the Receivables tab.

16. In the Sales Credit type field, use the LOV to assign a sales credit type to the 
sales representative.

17. Click the Save icon in the toolbar to save the record.
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The sales representative can now log in to Oracle HTML Quoting with his or 
her user name and create quotes.

5.2 Setting Profile Options
You must set certain Oracle iStore, Oracle Quoting - Forms, and Multi Organization 
profile options when implementing Oracle HTML Quoting. These profile option 
values affect the look and functionality of the application.

5.2.1 Setting Oracle iStore Profile Options
When implementing Oracle HTML Quoting, you must set certain Oracle iStore 
(IBE) profile options.

For a list of the Oracle Quoting - Forms profile options that you must set for Oracle 
HTML Quoting, see Section A.1, "Oracle iStore (IBE) Profile Options".

Use the following procedure to set IBE profile options. See Oracle iStore 
Implementation Guide for more information about these profile options.

Login
Log in to Oracle Forms.

Responsibility
To perform this task, you must use the System administrator responsibility.

Prerequisites
None

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

Note: The settings of the IBE profile options affect both 
the Oracle HTML Quoting user interface and the Oracle 
iStore customer user interface.
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and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in as SYSADMIN.

3. Choose the System Administrator responsibility.

4. Go to Profile > System.

The Find System Profile Values window opens.

5. Check Application and Responsibility. Select iStore as the application and a 
sales representative responsibility as the responsibility.

6. In the Profile field, enter IBE%, and click Find.

7. Verify or set the iStore (IBE) profile options at the application level only, unless 
another level is specified.

5.2.2 Setting Multi Organization Profile Options
Use the following procedure to set up multi-organization profile options.

Login
Log in to Oracle Forms.

Responsibility
To perform this task, you must use the System Administrator responsibility.

Prerequisites
None

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in as SYSADMIN.

3. Choose the System Administrator responsibility.

4. Go to Profile > System.
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The Find System Profile Values window opens.

5. Check Site and Responsibility. Select a sales representative responsibility from 
the Responsibility LOV.

6. In the Profile field, enter MO%, and click Find.

7. Verify or set the MO: Operating Unit profile option to the appropriate operating 
unit at the responsibility level or the value set at the site level is used.

5.3 Limiting the Available Countries
When sales representatives search for and create customers, contacts, and 
addresses, they use a Country pull-down menu to select the country of the 
customer, contact, or address.

By default, all countries are available in the Country pull-down menus.

If necessary, you can limit the countries that appear in these menus.

5.3.1 Limiting Bill-To Countries
You can limit which countries appear in the Country pull-down menus for bill-to 
information, using the following procedure.

Login
Login to Oracle Forms.

Responsibility
To perform this task, you must use the Human Resources responsibility.

Prerequisites
None

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the Human Resources responsibility.
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3. Choose Work Structures > Organization > Description.

The Find Organization window opens.

4. In the Find Organization window, enter the search criteria for your merchant 
organization and click Find.

The Organization form opens with the organization’s record.

5. In the Organization Classifications region, select Operating Unit in the Name 
fields.

6. Click Others.

The Additional Organization Information window opens.

7. In the Additional Organization Information window, enter %Country in the 
Find field and click Find.

8. In the search results, choose Bill to Country and click OK.

The Additional Organization Information window for Bill to Country opens.

9. Place your cursor in a Bill to Country field.

The Bill to Country window opens.

10. Add countries to the Additional Organization Information window for Bill to 
Country as follows:

a. In the Bill to Country window, click the Bill to Country LOV button.

The Bill to Country search window opens.

b. Search for a country, highlight it, and click OK.

The Bill to Country field in the Bill to Country window is populated with 
the value of this country.

c. Click OK to add the country to the Additional Organization Information 
window for Bill to Country.

d. Repeat for each country that you want to add to the sales representatives’ 
bill-to Country pull-down menus.

11. When you are finished adding countries, click OK in the Additional 
Organization Information window for Bill to Country.

You return to the Organization form with the organization’s record.



Limiting the Available Countries

Implementation Tasks 5-17

5.3.2 Limiting Ship-To Countries
You can limit which countries appear in the Country pull-down menus for ship-to 
information, using the following procedure.

Steps
1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in with the Human Resources responsibility.

3. Choose Work Structures > Organization > Description.

The Find Organization window opens.

4. In the Find Organization window, enter the search criteria for your merchant 
organization and click Find.

The Organization form opens with the organization’s record.

5. In the Organization Classifications region, select Operating Unit in the Name 
fields.

6. Click Others.

The Additional Organization Information window opens.

7. In the Additional Organization Information window, enter %Country in the 
Find field and click Find.

8. In the search results, choose Ship to Country and click OK.

The Additional Organization Information window for Ship to Country opens.

9. Place your cursor in a Ship to Country field.

The Ship to Country window opens.

10. Add countries to the Additional Organization Information window for Ship to 
Country as follows:

a. In the Ship to Country window, click the Ship to Country LOV button.

The Ship to Country search window opens.

b. Search for a country, highlight it, and click OK.
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The Ship to Country field in the Ship to Country window is populated with 
the value of this country.

c. Click OK to add the country to the Additional Organization Information 
window for Ship to Country.

d. Repeat for each country that you want to add to the sales representatives’ 
ship-to Country pull-down menus.

11. When you are finished adding countries, click OK in the Additional 
Organization Information window for Ship to Country.

You return to the Organization form with the organization’s record.

5.4 GSA (General Services Administration) Pricing
GSA is a customer classification that indicates that the customer is a U.S. 
government customer. Specific GSA price lists for the customers must be set up in 
Pricing. Items listed on the GSA price list cannot be sold to commercial customers 
for the same price or less than the government.

HTML Quoting responds to GSA violations based on the application level profile 
option ASO: GSA Pricing. As a default, the profile option is set to Null, which 
means that the application is not performing GSA violation checks. If the profile 
option is set to Warning and a non-GSA customer receives a unit net price that is 
lower than the GSA price, a violation warning appears stating that there is a GSA 
violation. If the profile option is set to Error, the user will be prevented from 
updating or saving the quote. In either case, if a GSA violation occurs, an error 
message appears identifying the quote lines in which the violation occurred.

Refer to the Oracle Pricing User’s Guide for more information.

Note: To enable GSA validation, you must set the Pricing profile 
option QP: Verify GSA to yes.
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5.5 Set up Automatic Site Numbering
The ability to create addresses in Oracle HTML Quoting relies on the setting of 
Automatic Site Numbering in Oracle Receivables. Automatic Site Numbering must 
be turned on for the user to create addresses.

Login
Log in to Oracle Forms.

Responsibility
To perform this task, you must use the Receivables Manager responsibility.

Prerequisites
None

Steps

1. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

and clicking on Apps Logon Links > VIS Logon through the Forms cartridge 
(UNIX).

2. Log in using the Receivables Manager responsibility.

3. Choose Setup > System > System Options.

The System Options form opens.

4. Click on the Trans and Customers tab.

5. Make sure the Automatic Site Numbering box, located in the Customers 
section, is checked.

6. Click save and close the form.
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6
Verifying the Implementation

This topic group provides you with steps necessary to verify implementation of 
Oracle HTML Quoting.

� Oracle HTML Quoting Implementation Verification Tasks
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6.1 Oracle HTML Quoting Implementation Verification Tasks
To verify that you properly implemented Oracle HTML Quoting, perform the 
following tasks.

For information on the procedures necessary to perform these tasks, see Oracle 
HTML Quoting Concepts and Procedures.

1. Create a complex quote.

� Create a new customer for your quote.

� Add and configure a model item.

� During the checkout process, create a new contact for the customer.

� During the checkout process, create a shipping or billing address for the 
customer.

2. Submit the order.

If the submission process was a success, you receive confirmation from Oracle 
Order Management.
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7
Diagnostics and Troubleshooting

This topic group provides troubleshooting information for the implementation and 
use of Oracle HTML Quoting.

� Order Feedback Queue Frequently Asked Questions
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7.1 Order Feedback Queue Frequently Asked Questions
Question: The queue table ASO_ORDER_FEEDBACK_T is growing in size. How 
do I stop it from growing?

Answer: Log in to Oracle Forms using the Oracle Order Capture Sales Manager 
responsibility and navigate to QuickCodes. Delete or disable all the lookup entries 
for lookup ‘ASO_ORDER_FEEDBACK_CRM_APPS’.

Question: The install base concurrent program is reading the rows from the queue 
table. Why are the rows read by the concurrent program still there?

Answer: The messages are being removed by the Installed Base program, but new 
messages that are queuing for different consumers are not being dequeued or 
inspected at all. This happens if there is a registered consumer in the ASO lookup 
(ASO_ORDER_FEEDBACK_CRM_APPS) for which there  is no dequeueing 
program. Delete or disable all the lookup entries except for Install Base for lookup 
‘ASO_ORDER_FEEDBACK_CRM_APPS’ in the QuickCodes form.

Question: The queue table is growing in size. I do not need the queue table because 
I do not have any CRM applications that depend on it. How can I remove all the 
rows in the table?

Answer: Perform the following tasks:

� Log in to Oracle Forms using the Oracle Order Capture Sales Manager 
responsibility and navigate to QuickCodes. Delete or disable all the lookup 
entries for lookup ‘ASO_ORDER_FEEDBACK_CRM_APPS’.

� Apply ARU bug 1449198 which drops the queue table and recreates it.

Question: The Installed Base Interface Concurrent Program completes with  an 
error status with a fatal exception from the ASO_ORDER_FEEDBACK_GET_PVT 
API. FND_AS_UNEXPECTED_ERROR (PKG_NAME=ASO_ORDER_FEEDBACK_
GET_PVT) (PROCEDURE_NAME=GET_NOTICE) (ERROR_TEXT=ORA-00600: 
internal error code, arguments: [koxsi2sz1], [13], [], [], [], [], [], []). What does this 
mean?

Answer: This error occurs because of bug 1424051 in RDBMS. Customers have to 
apply a patch to avoid this problem. The only workaround is to drop the rows in 
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the table. For this, a standalone ARU 1449198 needs to be applied which will drop 
and recreate the queue.

Question: Bug 1816891: Placing an order in OM or OC throws the error: FND_AS_
UNEXPECTED_ERROR (PKG_NAME=ASO_ORDER_FEEDBACK_UPDATE_PVT) 
(PROCEDURE_NAME =UPDATE_NOTICE) (ERROR_TEXT=ORA-25207: enqueue 
failed, queue ASO.ASO_OF_Q is disabled from enqueueing). Why does this 
happen?

Answer: This error occurs because the queue is not enabled for enqueuing.  The 
following SQL commands need to be run as APPS user to enable the queue for 
enqueuing and dequeuing:

execute dbms_aqadm.start_queue(’ASO.ASO_OF_Q’, TRUE, TRUE); 
execute dbms_aqadm.start_queue(’ASO.ASO_OF_Q_E’, FALSE,TRUE); 
execute dbms_aqadm.start_queue(’ASO.ASO_OF_EXCP_Q’, TRUE, TRUE); 
execute dbms_aqadm.start_queue(’ASO.ASO_OF_EXCP_Q_E’, FALSE,TRUE);

Question: Bug 1897375: Placing an order in OM or OC throws an error: 100501 - 
non-Oracle Exception. The debug file shows the error. FND_AS_UNEXPECTED_
ERROR (PKG_NAME=ASO_ORDER_FEEDBACK_UPDATE_PVT) (PROCEDURE_
NAME=UPDATE_NOTICE) (ERROR_TEXT=ORA-06502: PL/SQL: numeric or 
value error: character to number conversion error). Why does this happen?

Answer: The error occurs when the profile value ASO: Order Feedback Queue 
Retention Time was set to a character string.

The profile value ASO: Order Feedback Queue Retention Time  is used to determine 
how long the message is retained in the Order Feedback Queue. Either the value 
should be null (the message never expires) or a number measured in seconds. Set 
the profile value to null or a large number.
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A
Profile Options

This appendix describes the profile options that you need to set when 
implementing Oracle HTML Quoting.

� Oracle iStore (IBE) Profile Options

� Multi Organization (MO) Profile Options
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A.1 Oracle iStore (IBE) Profile Options
When implementing Oracle HTML Quoting, you must set certain Oracle iStore 
(IBE) profile options.

Verify or set the HTML Quoting specific iStore (IBE) profile options listed below at 
the application level only, unless another level is specified.

Note: The settings of the IBE profile options affect both 
the Oracle HTML Quoting user interface and the Oracle 
iStore customer user interface.

Table A–1 IBE Profile Options for Oracle HTML Quoting 

Name Description

IBE: Attachment 
Document Category

This profile option specifies the default attachment category ID, to 
make Oracle HTML Quoting quote attachments accessible in 
Oracle Order Management and Oracle Quoting - Forms. This 
attachment category ID must also be enabled in Oracle Order 
Management and Oracle Quoting - Forms.

IBE: Search Operator This profile option specifies the operator for search keywords in 
Oracle HTML Quoting. If the profile option is set to AND, 
product searches return results that include all of the keywords. If 
the profile option is set to OR, product searches return results that 
include any of the keywords. The default value is OR.

IBE: Use Line Types This profile specifies whether sales representatives can modify 
line types for items in quotes. A sales representative marks an 
item as a trade-in by setting its line type to the Line Category 
Return, so this profile value determines whether Oracle HTML 
Quoting’s trade-in functionality is available. Yes enables line type 
changes and consequently trade-in functionality. No disables line 
type changes and trade-in functionality. If the profile is not set, it 
defaults to No.

Note: If you want to enable this profile option, make sure the 
profile option ASO: Default Order Type is set to Mixed.

IBE: Use Notes This profile specifies whether to turn on the Notes functionality in 
Oracle HTML Quoting. Yes activates the Notes functionality. No 
deactivates it. The default value is No.

OSO must be installed before the Notes functionality can be 
activated.
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The following iStore profile options must also be set during implementation. Refer 
to Oracle iStore Implementation Guide for more information.

� IBE: Authorize Payment Offline during normal Checkout

� IBE: Create Order in Entered State, if it has errors while booking

� IBE: Enable Debug

� IBE: Enable Fuzzy Search

� IBE: Merge Shopping Cart Lines

� IBE: No of Results in Search

� IBE: Pricing Event — Before Shopping Cart

� IBE: Pricing Event for Shopping Cart

� IBE: Recalculate Price in Order Management

� IBE: Request Type to get a Price

� IBE: Search Lines Per Page

IBE: Use Quote 
Publishing

This profile option enables the publishing functionality in Oracle 
HTML Quoting. The default value is No.

This profile option is not used for HTML Quoting in this release.

IBE: Use Support This profile option determines whether service items are 
supported. If the profile option is set to Yes, user of service items 
is supported. If it is set to No, service items are not supported. The 
default value is No.

IBE: Use Support Cart 
Level

This profile option allows users to choose a service support level 
for the entire cart, rather than by item. This profile option cannot 
be activated unless IBE: Use Support is also set to Yes.

The default value is No.

IBE: Use Tasks This profile specifies whether to turn on the Tasks functionality in 
Oracle HTML Quoting. Yes activates the Tasks functionality. No 
deactivates it. The default value is No.

OSO must be installed before the Tasks functionality can be 
activated.

IBE: View Custom 
Quote Line Details

This profile option enables the Custom link on each quote line in 
Oracle HTML Quoting. The default value is No.

Table A–1 IBE Profile Options for Oracle HTML Quoting 

Name Description
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� IBE: Shopping Cart Expiration Duration

� IBE: Use Category Search

� IBE: Use Price list associated with Specialty Store

A.2 Multi Organization (MO) Profile Options
Verify or set the MO: Operating Unit profile option to the appropriate operating 
unit at the responsibility level.
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B
Seeded Roles

This appendix describes the seeded roles and permissions included in Oracle 
HTML Quoting.

� The Sales Representative Role and Permissions
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B.1 The Sales Representative Role and Permissions
The seeded Sales Representative role for Oracle HTML Quoting is IBE_SALESREP_
ROLE. You can also create new Sales Representative roles for your sales 
representatives with any set of quote creation permissions that you specify. 

See Oracle CRM Foundation Implementation Guide for more information about 
creating roles. See Oracle iStore Implementation Guide and Oracle iStore Concepts and 
Procedures for more information about the Oracle iStore quote creation permissions.

The Sales Representative role IBE_SALESREP_ROLE has all available quote creation 
permissions. It is appropriate for assignment to sales representatives and other 
employees of your organization. The following table describes the permissions for 
IBE_SALESREP_ROLE.

Table 7–1 Permissions for IBE_SALESREP_ROLE 

Name Description

IBE_ALLOW_PRICE_OVERRIDE Override prices manually.

IBE_ASSIGN_SALES_CREDITS Assign sales credits.

IBE_BILLTO_ANY_ACCOUNT Search on and retrieve all existing 
customers rather than only those with an 
existing billing relationship with the 
sold-to customer.

IBE_CHANGE_BILLTO_CONTACT Change the bill-to contact from the default 
(if any) bill-to contact.

IBE_CHANGE_BILLTO_CUSTOMER Change the bill-to customer from the 
default bill-to customer.

IBE_CHANGE_SHIPTO_CONTACT Change the ship-to contact from the 
default (if any) ship-to contact.

IBE_CHANGE_SHIPTO_CUSTOMER Change the ship-to customer from the 
default ship-to customer.

IBE_CREATE_BILLTO_CONTACT Create a new contact for the bill-to 
customer who will have a bill-to 
relationship with the bill-to customer.

IBE_CREATE_BILLTO_CONTACT_
ADDRESS

Create a new address associated with the 
bill-to contact which will have a bill-to 
relationship with the bill-to contact.

IBE_CREATE_BILLTO_CUSTOMER Create a new customer with a billing 
relationship to the sold-to customer.
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IBE_CREATE_BILLTO_CUSTOMER_
ADDRESS

Create a new address associated with the 
bill-to customer which will have a bill-to 
relationship with the bill-to customer.

IBE_CREATE_ORDER Submit a quote or cart as an order.

IBE_MODIFY_CART Not used in Release 11i.

IBE_MODIFY_ORDER Not used in Release 11i.

IBE_CREATE_SHIPTO_CONTACT Create a new contact for the ship-to 
customer who will have a ship-to 
relationship with the ship-to customer.

IBE_CREATE_SHIPTO_CONTACT_
ADDRESS

Create a new address associated with the 
ship-to contact which will have a ship-to 
relationship with the ship-to contact.

IBE_CREATE_SHIPTO_CUSTOMER Create a new customer with a shipping 
relationship to the sold-to customer.

IBE_CREATE_SHIPTO_CUSTOMER_
ADDRESS

Create a new address associated with the 
ship-to customer which will have a ship-to 
relationship with the ship-to customer.

IBE_CREATE_SOLDTO_CUSTOMER Create a new customer in the context of 
assigning a sold-to customer during quote 
creation.

IBE_SHIPTO_ANY_ACCOUNT Search on and retrieve all existing 
customers rather than only those with an 
existing shipping relationship with the 
sold-to customer.

IBE_USE_ATTACHMENT Use attachments.

IBE_USE_PRICING_AGREEMENT Use pricing agreements.

IBE_VIEW_CUST_WITHOUT_
ACCOUNT

Search on and retrieve existing customers 
without an account.

Table 7–1 Permissions for IBE_SALESREP_ROLE (Cont.)

Name Description
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B2B customer

A representative of a corporate customer, who is set up in Oracle HTML Quoting 
and related applications as an employee of that customer organization.

B2C customer

An individual customer who represents only himself or herself.

blueprint phase

A phase of a project in which the business plan around the solution is developed, 
the solution is defined, business and system integration requirements are modeled, 
and the partitions of tasks are defined.

complementary sell

Complementary sells persuade customers to buy a product that complements a 
product in which they are interested.

construction phase

The construction phase of a project is where the solution is built. It involves refining 
the data and functional models, the physical application modules, and the system 
interfaces until they meet the business requirements.

cookie

Cookies are general mechanisms which server-side connections use both to store 
and to retrieve information on the client side of the connection. 

cross-sell

See Complementary sell.
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Demilitarized zone (DMZ)

Derived from the term demilitarized zone, it is the area between two firewalls 
which is isolated from both untrusted and trusted networks.

drafted

This quote status allows sales representatives to modify the quote. It is 
automatically assigned to every new quote created in Oracle HTML Quoting.

firewall

A firewall controls the type of traffic entering a site. Internet traffic should be 
limited to connections originating from browser-based HTTP sessions, that is, from 
Telnet and FTP.

flexfields

Flexfields allow merchants to store additional information in the databases that 
support Oracle HTML Quoting, according to their specific needs.

inactive

Sales representatives can assign this quote status to a quote with a Drafted status if 
they expect no further action on the quote. Sales representatives cannot modify a 
quote that has an Inactive status. However, they can copy or append a quote that 
has this status.

launch phase

During this phase, the project team prepares for and executes the launch of the store 
including production installation, validation, documentation, and training. 

During this time, the implementation team may perform additional incremental 
development to provide more functionality or address non-functional requirements, 
such as enhancing performance and reliability.

ordered

Oracle HTML Quoting automatically assigns this quote status to all quotes placed 
as orders. Sales representatives cannot modify a quote that has an Ordered status. 
However, they can copy or append a quote that has this status.

OSO

Acronym for Oracle Sales Online.
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quote

A collection of items with pricing that a sales representative with a Sales 
Representative role creates on behalf of a customer in Oracle HTML Quoting.

quote status

The quote status indicates the stage of preparation that a quote is in. Possible quote 
statuses include drafted, ordered, and inactive.

Sales Representative Role

A role that allows the creation and subsequent modification of a quote for 
customers in Oracle HTML Quoting by the merchant organization personnel. This 
role is typically assigned to sales representatives of the merchant organization. A 
Sales Representative role can have a variety of permissions, such as the ability to 
submit a quote as an order and permission to create new customers.

Secure Electronic Transaction

Secure Electronic Transaction (SET) 1.0 protocol is an open standard developed 
jointly by Visa and MasterCard to ensure the privacy and security of credit card 
transactions over open networks such as the Internet. 

settling transactions

Settling transactions includes capturing authorized transactions, processing voids 
and returns, and batch administration. 

transactional data

Transactional data refers to information that is the result of customer interaction 
with the store. 

upsell

Upsells aim to persuade customers to buy more expensive types of the same 
product.

VAD/Partner

A user type with a role that is a variation of a B2B customer. The entity 
(organization or individual) with which the user is associated has a partner 
relationship with the merchant owning the Oracle HTML Quoting installation.

wildcard

A special character within a search parameter that tells the application to search for 
all records that are similar to the search parameter. In Oracle HTML Quoting, % is 
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the wildcard character. For example, if you enter "renew%" as a quote name search 
parameter, the application returns all quotes with names that begin with "renew."
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