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usefulness of this document. Your input is an important part of the information
used for revision.

Did you find any errors?

Is the information clearly presented?

Do you need more information? If so, where?

Are the examples correct? Do you need more examples?

What features did you like most?

If you find any errors or have any other suggestions for improvement, please
indicate the document title and part number, and the chapter, section, and page
number (if available). You can send comments to us at:

Oracle Corporation

CRM Application Foundation Content Development Manager
500 Oracle Parkway

Redwood Shores, CA 94065, USA

If you would like a reply, please give your name, address, telephone number, and
(optionally) electronic mail address.

If you have problems with the software, please contact your local Oracle Support
Services.
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Preface

Audience for This Guide

Welcome to Release 11i of the Oracle CRM Application Foundation
Implemenatation Guide.

This guide assumes you have a working knowledge of the following:
« The principles and customary practices of your business area
» Oracle CRM Application Foundation

If you have never used Oracle CRM Application Foundation, Oracle suggests you
attend one or more of the Oracle CRM Application Foundation training classes
available through Oracle University.

» The Oracle Applications graphical user interface

To learn more about the Oracle Applications graphical user interface, read the
Oracle Applications User’s Guide.

See Other Information Sources for more information about Oracle Applications
product information.

How to Use This Guide

This document contains the information you need to understand and use Oracle
CRM Application Foundation. It is divided into sections, with each section
containing material on an Application Foundation module.

» Chapter 1 describes the CRM E-Commerce Suite overview, the Oracle
Foundation overview, and what is new in this release.

« Chapter 2 describes the architectural overview.

XV



» Chapter 3 describes the mandatory dependencies for the Foundation modules.
» Chapter 4 describes the implementation overview of each Foundation module.

« Chapter 5 describes the specific implementation task for each Foundation
module.

« Chapter 6 describes the verification tasks needed to ensure the set up of each
module is correctly executed and stable.

« Chapter 7 describes common implementation errors and the solutions.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation
accessible, with good usability, to the disabled community. To that end, our
documentation includes features that make information available to users of
assistive technology. This documentation is available in HTML format, and contains
markup to facilitate access by the disabled community. Standards will continue to
evolve over time, and Oracle Corporation is actively engaged with other
market-leading technology vendors to address technical obstacles so that our
documentation can be accessible to all of our customers. For additional information,
visit the Oracle Accessibility Program Web site at
http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation

JAWS, a Windows screen reader, may not always correctly read the code examples
in this document. The conventions for writing code require that closing braces
should appear on an otherwise empty line; however, JAWS may not always read a
line of text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or
organizations that Oracle Corporation does not own or control. Oracle Corporation
neither evaluates nor makes any representations regarding the accessibility of these
Web sites.

Other Information Sources

You can choose from many sources of information, including online documentation,
training, and support services, to increase your knowledge and understanding of
Oracle CRM Application Foundation.
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If this guide refers you to other Oracle Applications documentation, use only the
Release 11i versions of those guides.

Online Documentation

All Oracle Applications documentation is available online (HTML or PDF). Online
help patches are available on MetalLink.

Related Documentation

Oracle CRM Application Foundation shares business and setup information with other
Oracle Applications products. Therefore, you may want to refer to other product
documentation when you set up and use Oracle CRM Application Foundation.

Oracle CRM Technology Foundation Implementation Guide contains information
relating to User Management including user registration and management
performed through the System Administrator’s Console.

You can read the documents online by choosing Library from the expandable menu
on your HTML help window, by reading from the Oracle Applications Document
Library CD included in your media pack, or by using a Web browser with a URL
that your system administrator provides.

If you require printed guides, you can purchase them from the Oracle Store at
http://oraclestore.oracle.com.

Documents Related to All Products

Oracle Applications User’s Guide

This guide explains how to enter data, query, run reports, and navigate using the
graphical user interface (GUI) available with this release of Oracle CRM Application
Foundation (and any other Oracle Applications products). This guide also includes
information on setting user profiles, as well as running and reviewing reports and
concurrent processes.

You can access this user’s guide online by choosing ”Getting Started with Oracle
Applications” from any Oracle Applications help file.

Documents Related to This Product
Oracle CRM Application Foundation Concepts and Procedures

The Concepts and Procedures manual contains important reference and
background information on each of the CRM Application Foundation modules. In
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addition, it contains procedures and using information that describe the common
User and System Administration tasks that are necessary to perform in each of the
modules.

Oracle CRM Application Foundation API Reference Guide

This manual describes the public, supported Application Foundation APIs. It
includes API information for the following Application modules:

» Interaction History
« Resource Manager
« Task Manager

«  Fulfillment

« Notes
Installation and System Administration

Oracle Applications Concepts

This guide provides an introduction to the concepts, features, technology stack,
architecture, and terminology for Oracle Applications Release 11i. It provides a
useful first book to read before an installation of Oracle Applications. This guide
also introduces the concepts behind Applications-wide features such as Business
Intelligence (BIS), languages and character sets, and Self-Service Web Applications.

Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle
Applications products. In Release 11i, much of the installation process is handled
using Oracle Rapid Install, which minimizes the time to install Oracle Applications,
the Oracle8 technology stack, and the Oracle8i Server technology stack by
automating many of the required steps. This guide contains instructions for using
Oracle Rapid Install and lists the tasks you need to perform to finish your
installation. You should use this guide in conjunction with individual product
user’s guides and implementation guides.

Oracle Applications Supplemental CRM Installation Steps

This guide contains specific steps needed to complete installation of a few of the
CRM products. The steps should be done immediately following the tasks given in
the Installing Oracle Applications guide.



Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or
Release 11.0 products to Release 11i. This guide describes the upgrade process and
lists database and product-specific upgrade tasks. You must be either at Release 10.7
(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 11i.
You cannot upgrade to Release 11i directly from releases prior to 10.7.

Maintaining Oracle Applications

Use this guide to help you run the various AD utilities, such as AutoUpgrade,
AutoPatch, AD Administration, AD Controller, AD Relink, License Manager, and
others. It contains how-to steps, screenshots, and other information that you need to
run the AD utilities. This guide also provides information on maintaining the
Oracle applications file system and database.

Oracle Applications System Administrator’'s Guide

This guide provides planning and reference information for the Oracle Applications
System Administrator. It contains information on how to define security, customize
menus and online help, and manage concurrent processing.

Oracle Alert User’'s Guide

This guide explains how to define periodic and event alerts to monitor the status of
your Oracle Applications data.

Oracle Applications Developer’s Guide

This guide contains the coding standards followed by the Oracle Applications
development staff. It describes the Oracle Application Object Library components
needed to implement the Oracle Applications user interface described in the Oracle
Applications User Interface Standards for Forms-Based Products. It also provides
information to help you build your custom Oracle Forms Developer 6i forms so that
they integrate with Oracle Applications.

Oracle Applications User Interface Standards for Forms-Based Products
This guide contains the user interface (Ul) standards followed by the Oracle
Applications development staff. It describes the Ul for the Oracle Applications
products and how to apply this Ul to the design of an application built by using
Oracle Forms.
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Other Implementation Documentation

Multiple Reporting Currencies in Oracle Applications

If you use the Multiple Reporting Currencies feature to record transactions in more
than one currency, use this manual before implementing Oracle CRM Application
Foundation. This manual details additional steps and setup considerations for
implementing Oracle CRM Application Foundation with this feature.

Multiple Organizations in Oracle Applications

This guide describes how to set up and use Oracle CRM Application Foundation with
Oracle Applications’ Multiple Organization support feature, so you can define and
support different organization structures when running a single installation of
Oracle CRM Application Foundation.

Oracle Workflow Guide

This guide explains how to define new workflow business processes as well as
customize existing Oracle Applications-embedded workflow processes. You also
use this guide to complete the setup steps necessary for any Oracle Applications
product that includes workflow-enabled processes.

Oracle Applications Flexfields Guide

This guide provides flexfields planning, setup and reference information for the
Oracle CRM Application Foundation implementation team, as well as for users
responsible for the ongoing maintenance of Oracle Applications product data. This
manual also provides information on creating custom reports on flexfields data.

Oracle eTechnical Reference Manuals

Each eTechnical Reference Manual (eTRM) contains database diagrams and a
detailed description of database tables, forms, reports, and programs for a specific
Oracle Applications product. This information helps you convert data from your
existing applications, integrate Oracle Applications data with non-Oracle
applications, and write custom reports for Oracle Applications products. Oracle
eTRM is available on Metalink

Oracle Manufacturing APIs and Open Interfaces Manual

This manual contains up-to-date information about integrating with other Oracle
Manufacturing applications and with your other systems. This documentation
includes APIs and open interfaces found in Oracle Manufacturing.



Oracle Order Management Suite APIs and Open Interfaces Manual

This manual contains up-to-date information about integrating with other Oracle
Manufacturing applications and with your other systems. This documentation
includes APIs and open interfaces found in Oracle Order Management Suite.

Oracle Applications Message Reference Manual

This manual describes Oracle Applications messages. This manual is available in
HTML format on the documentation CD-ROM for Release 11i.

Oracle CRM Application Foundation Implementation Guide

Many CRM products use components from CRM Application Foundation. Use this
guide to correctly implement CRM Application Foundation.

Training and Support

Training

Oracle offers training courses to help you and your staff master Oracle CRM
Application Foundation and reach full productivity quickly. You have a choice of
educational environments. You can attend courses offered by Oracle University at
any one of our many Education Centers, you can arrange for our trainers to teach at
your facility, or you can use Oracle Learning Network (OLN), Oracle University’s
online education utility. In addition, Oracle training professionals can tailor
standard courses or develop custom courses to meet your needs. For example, you
may want to use your organization’s structure, terminology, and data as examples
in a customized training session delivered at your own facility.

Support

From on-site support to central support, our team of experienced professionals
provides the help and information you need to keep Oracle CRM Application
Foundation working for you. This team includes your Technical Representative,
Account Manager, and Oracle’s large staff of consultants and support specialists
with expertise in your business area, managing an Oracle8i server, and your
hardware and software environment.

OracleMetaLink

OracleMetaLink is your self-service support connection with web, telephone menu,
and e-mail alternatives. Oracle supplies these technologies for your convenience,
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain
information and advice from technical libraries and forums, download patches,
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download the latest documentation, look at bug details, and create or update TARs.
To use MetaL ink, register at (http://metalink.oracle.com).

Alerts: You should check OracleMetalLink alerts before you begin to install or
upgrade any of your Oracle Applications. Navigate to the Alerts page as follows:
Technical Libraries/ERP Applications/Applications Installation and
Upgrade/Alerts.

Self-Service Toolkit: You may also find information by navigating to the
Self-Service Toolkit page as follows: Technical Libraries/ERP
Applications/Applications Installation and Upgrade.

Do Not Use Database Tools to Modify Oracle Applications Data

Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data
Browser, database triggers, or any other tool to modify Oracle Applications data
unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and
maintain information in an Oracle database. But if you use Oracle tools such as
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of
your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using
Oracle Applications can update many tables at once. But when you modify Oracle
Applications data using anything other than Oracle Applications, you may change a
row in one table without making corresponding changes in related tables. If your
tables get out of synchronization with each other, you risk retrieving erroneous
information and you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications
automatically checks that your changes are valid. Oracle Applications also keeps
track of who changes information. If you enter information into database tables
using database tools, you may store invalid information. You also lose the ability to
track who has changed your information because SQL*Plus and other database
tools do not keep a record of changes.

About Oracle
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Oracle Corporation develops and markets an integrated line of software products
for database management, applications development, decision support, and office
automation, as well as Oracle Applications, an integrated suite of more than 160
software modules for financial management, supply chain management,



manufacturing, project systems, human resources and customer relationship
management.

Oracle products are available for mainframes, minicomputers, personal computers,
network computers and personal digital assistants, allowing organizations to
integrate different computers, different operating systems, different networks, and
even different database management systems, into a single, unified computing and
information resource.

Oracle is the world’s leading supplier of software for information management, and
the world’s second largest software company. Oracle offers its database, tools, and
applications products, along with related consulting, education, and support
services, in over 145 countries around the world.
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1

Introduction

This chapter provides information on the following topics:

Oracle CRM Application Foundation Overview
Oracle CRM Application Foundation Modules Overview

New in this Release

1.1 Oracle CRM Application Foundation Overview

1.1.1 The Oracle CRM E-Commerce Suite

Oracle CRM E-Commerce Suite, Release 11i, is a comprehensive Web-based solution
for unassisted business to business (B2B) and business to consumer (B2C) selling,
marketing, and servicing through the internet. It covers the entire spectrum of the
e-commerce value cycle, from managing effective marketing campaigns to
providing customer self-service. The Oracle CRM E-Commerce Suite encompasses
the following:

Merchant administration

Affiliate linking

Sophisticated catalog management
Guided selling

Merchandising

Order management

Payment processing

Intelligence reporting
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Oracle CRM Application Foundation Modules Overview

» Foundation components that allow for integration without redundancy

1.1.2 Oracle CRM Application Foundation
Oracle CRM Foundation is:
« A common infrastructure upon which CRM modules are built
« Asetofapplication components that can be used by all CRM modules

Oracle CRM Foundation divides into the Application Foundation modules and the
Technical Foundation modules.

The key to the CRM products is that they are architected, designed, and built as an
integrated suite of applications using the CRM Foundation components. This
layered architecture approach ensures that all CRM applications can interact with
key business objects in a consistent manner.

One of the most important components of the CRM Foundation is the customer
data model known as the Trading Community Architecture or the TCA. This
powerful model permits us to capture complex customer relationships and enables
us to support flexible business models across industries.

CRM Application Foundation provides standard APIs for accessing and
manipulating business objects such as Customers, Resources, and Tasks. In addition
to these APIs, they also provide robust processing engines such as Territory
Management and Fulfillment.

The CRM Application Foundation business APIs facilitate the integration of the
CRM suite in heterogeneous IT environments where integration with legacy or third
party applications is essential.

1.1.3 Oracle CRM Application Foundation Goal

The goal of Oracle CRM Application Foundation is to provide the CRM suite with a
robust architecture, a stable and performing technology stack, and reusable
application components.

1.2 Oracle CRM Application Foundation Modules Overview
The following CRM Application Foundation modules are included:
« Resource Manager

. Notes
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Oracle CRM Application Foundation Modules Overview

» Development Tools

« Territory Manager

« Assignment Manager
« Task Manager

« Calendar

» Interaction History

«  Fulfillment

» Escalation Manager

= Business Rule Monitor

Note: User registration and management is performed through
the System Administrator’s Console. See the Oracle CRM
Technology Foundation Implementation Guide for information
relating to User Management.

Resource Manager

Resource Manager is a single repository for defining teams and groups of people or
any other type of resources such as equipment and venues. Once an entity is
defined as a resource, it becomes visible to the entire CRM suite, and tasks and
calendars can be associated to this entity.

Notes

The notes infrastructure enables the entire CRM suite to create, maintain, and share
notes related to customers, opportunities, service requests, and other business
objects.

Development Tools

CRM Application Foundation includes several user interface components that can
be embedded in an Oracle form and used by the other CRM modules. These
components are referred to as development or infrastructure tools. They are:

» Gantt chart, a graphical tool that typically uses a bar chart to show the start
date, end date and duration of tasks within the project

= Spreadtable, an object that contains rows, columns, and column headers set in a
grid
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Oracle CRM Application Foundation Modules Overview

Territory Manager

Territory Manager provides an infrastructure to define territories based on flexible
criteria, such as geography, zip code, area code, and so forth. This engine enables
automatic assignment of transactions across the entire CRM suite. For instance,
leads and opportunities are routed through this engine to the right sales
professionals.

Assignment Manager

The Assignment engine determines the best resource to be assigned to tasks based
on availability and skill set. This engine is used by the various CRM modules to
automatically assign tasks to a resource or a group of people.

Task Manager

This is the universal model, which is used by the entire CRM suite. Tasks are
created and assigned to groups or individuals and are created and shared across
CRM either through forms or HTML.

Calendar

The Forms based calendar is a scheduling tool used to define and view available
times for a resource or a group of resources. Other CRM modules use the calendar
functionality to schedule resources. The HTML based calendar allows employees to
effectively manage daily activities, appointments, and tasks.

Interaction History

This module provides the CRM suite with a common framework for capturing and
accessing all interaction data associated with customer contacts. Interaction History
acts as a central repository and provides a consistent API for tracking all customer
interactions, whether automatic or involving an agent.

Fulfillment

The fulfillment engine supports high volume electronic fulfillment of documents.
Amongst others, it is used by the Sales and Marketing modules for outbound sales
and marketing activities.

Escalation Manager

Escalation Manager provides a user interface which allows you to manage
situations either by creating an escalation document, assigning an escalation owner,
or defining the necessary actions needed to resolve the escalation. This module is
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New in this Release

used extensively by the service applications to ensure that Service Level
Agreements are met.

Business Rule Monitor

The Business Rule Monitor provides a user interface and functionality that an
organization can use to proactively manage escalations. It consists of:

= Business Rule Workbench: this is used to define a business rule

» Business Rule Monitor: this is the engine that monitors documents over time
against the user-defined business rules.

1.3 New in this Release

This release of the Application Foundation has several new features. These features
are listed by module in the following section.

1.3.1 Resource Manager

New HTML Interface

An HTML version of Resource Manager has been created. This new HTML version
maintains some of the functionality of forms-based Resource Manager module
including maintaining personal information, viewing and creating employee
resources, and viewing and creating group information. The HTML version also
contains an additional new feature known as managing a resource’s skill level,
which is not available in the Forms version.

1.3.2 Assignment Manager

Viewing Web Availability in the Gantt Chart

Web availability allows you to view a resource who has the immediate ability to
attend to a service request that is assigned online. This functionality is only used in
the Oracle Support Services (OSS) for a service request assignment with Territory
Assisted assignment option. This feature supports all types of individual resources
(employee, party, partner, supplier contact and other) in the Resource Manager.

« Ifaresource is web available, then this resource selected by the territory
assisted option has the additional symbol "***" next to the name. The resource
can accept web service requests.

Introduction 1-5



New in this Release

« Ifthe resource is not web available, then no symbol appears next to the
resource name. The purpose of seeing whether a resource is web available is to
allow a manager to view and immediately assign a service request online.

Support Site Name

When a resource is selected in the Assignment Manager, the support site name to
which the selected resource belongs to appears automatically in the Support Site
Name field at the bottom of the window.

1.3.3 Territory Manager

Creating Customer Name Range Groups

Define, maintain, or delete a Customer Name Range Group in the Customer Name
Range Group window. This feature is used by Sales and Telesales only.

Customer Name Range Group as a Transaction Qualifier

You can choose Customer Name Range Group as a transaction qualifier and define
the group as well as add its values.

Setting the Start and End Dates in Mass Change Territory Resources

You can set start and end dates in the Assignee region. The previous release allowed
only the current date. This gives you greater control in reassigning your territories.

Copying an Entire Territory Hierarchy

Copy an entire territory hierarchy including all associated children by selecting the
Copy button on the Overview tab in the Territory Details window. Once an entire
territory is copied, the children can be individually selected and renamed.

Search Enhancements

The Search window from the Administration menu features multiple tabs and
fields. You can filter your territory search based on various criteria such as usage,
boundary (postal code range), customer name, territory type, resource name, and
territory property or qualifier.
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1.3.4 Escalation Manager

Escalation of a Document Whose Owner is a Group

Formerly, automated escalation assumed that the document it was escalating was
owned by a resource of type "Employee Resource." However other types of
resources can now own documents that are escalated.

1.3.5 Calendar

1.3.6 Tasks

1.3.7 Notes

New HTML Interface

This new HTML version contains similar functionality to the existing Forms version
of Calendar with the exception of the integration of tasks and notes. The HTML
version does not allow calendar to function as a scheduling tool used to define and
view available times for a resource or a group of resources.

New HTML Interface

This new HTML version which contains nearly identical functionality to the
existing Forms version with the exception of task dependencies, audits, and
templates. The HTML version also contains an additional new feature known as
Mass Create, which is not available in the Forms version. It is accessed through a
subtab on the Calendar tab.

Note: Tasks created in the Forms version of Task Manager are
editable in the HTML version. The same is true for tasks created in

HTML.

New HTML Interface

This new HTML version of Notes contains nearly identical functionality to the
existing Forms version of Notes module. It is accessed through a subtab on the
Calendar tab.
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1.3.8 Fulfillment

Faxing a Fulfillment Request

Another output method, other than email, to send a fulfillment request has been
added. Fulfillment has open Java interface APIs that allow integration to other
custom fax solutions so you can now fax fulfillment requests.

Previewing and Printing a Fulfillment Request
= View previewed Fulfillment requests before they are sent to the customers

»  Print previewed Fulfillment requests and save the requests as an HTML file

Redirecting the Finish Button

In the Fulfililment Agent tabs in the Oracle Sales Online application, the Fulfillment
administrator can redirect the Finish button on the confirmation window to any
page that is considered optimal for the group’s procedure.

Using the Fetch SMTP Identifier

This feature requires the calling application to provide set up folders and login
information. Fulfillment then uses a Java Mail API to create email messages. Each
message has an identifier which is called a SMTP ID. The SMTP ID can be retrieved
and stored as part of an interaction activity in the Interaction History module. The
Fulfillment server will fetch the SMTP ID for outgoing emails that are sent directly
through the SMTP connection.

1.3.9 Interaction History

Viewing Migrated 3i Attachments

This release allows you to view attachments that were created with the Oracle 3i
Interaction Manager. View Oracle Sales Online documentation for procedures on
how to migrate the documents in order to view them.

Importing Mass Data

Interaction History can mass import data from third parties by accepting multiple
interactions, activities, or media items and upload them into the Interaction History
table. Staging tables are created where the calling application can upload their data.
Upon completion, the data is handled and viewed the same way that other
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interactions from Interaction History are recorded and once it has been imported, it
can be viewed through Forms or HTML.

Viewing Open or Closed Activities

An Active Status column on both the HTML and Forms-based module appears in
the Interaction History window on the Interactions and Activities tabs. In Forms,
the column has a red "X" for closed interactions and a green check mark for
interactions that are still open. In HTML, the check box is checked if it has an active
status.

SMTP Email Identifier Available

Fulfillment uses a Java Mail API to create email messages. Each message has an
identifier which is called the SMTP ID. The SMTP ID can be retrieved and stored as
part of an interaction activity in the Interaction History module. The Fulfillment
server will fetch the SMTP ID for outgoing emails that are sent directly through the
SMTP connection. Interaction History exposes the SMTP ID in the table for calling
applications to use.

Integration With Scripting

Interaction History records customer touch points and the script transaction
identifier is associated with the activity resulting from the interaction. For example,
if the activity of service request is created and a script was used during the touch
point then the scripting identifier is written to Interaction History and associated
with the activity. Recording the script transaction identifier allows you to determine
what script was used in the touch point and gain insights into what was actually
communicated to the customer.
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2

Architecture and Technology

This chapter provides an overview of the architecture and technology of Oracle
CRM Application Foundation. Topics include:

=« Architectural Overview

. System Requirements

2.1 Architectural Overview

The following section describes the overview of the Oracle CRM suite and how the
CRM Application Foundation functions within it.

2.1.1 Oracle CRM Suite

By using the Oracle CRM E-Business suite, companies can manage marketing, sales,
and service activities over the Web, phone, email, or in person. They can improve
efforts to acquire, maintain, and enhance customer relationships, assisting
companies with marketing automation, sales force automation, customer service
and support, field service, spares management, depot repair, and business
intelligence, in a multi-channel environment.

Oracle CRM Foundation provides a single centralized repository for all customer
interactions, across all channels, and provides a single definition of business objects
across the enterprise, enabling you to create and update key information in a
consistent manner.

Foundation is generally divided into two broad areas:

« Technology Foundation (JTT): The underlying HTML technology base for the
CRM suite.
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Architectural Overview

= Application Foundation: A suite of specific application components that can be
used and customized by the other modules in the CRM suite.

The following graphic depicts how CRM Application Foundation modules are
layered within the Oracle CRM suite.

Figure 2-1 Oracle CRM Suite of Applications Featuring CRM Application Foundation Modules

Analytical ) )
Applications Business Intelligence
Business . .
Applications | Marketing Sales Contracts Service
Task Manager Calendar Notes User .
Management
CRM
Application Territory Assignment Resource Escalation
Foundation Manager Manager Manager Manager
Development Interaction Fulfiliment Business Rule
Tools History Monitor
Interaction : .
chamnels | Call Center Web Mobile WAP E-Mail
Common Application Architecture and Schema
E-Business
E-Business Platform
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Architectural Overview

The following table provides a description of each layer in the Oracle CRM
E-Business Suite.

Table 2-1 Description of Oracle CRM E-Business Suite of Applications

Function

Description

Analytical Applications

Business Intelligence: These applications integrate data from all of the E-Business
Suite applications to provide key performance measurements, operating alerts, and
management reports to every decision maker across the enterprise. These
applications include:

«  Customer Intelligence
«  Marketing Intelligence
«  Sales Intelligence

«  Service Intelligence

. Call Center Intelligence

Business Applications

The Business Applications consists of the following modules:

Marketing: This suite of applications provides marketing professionals with a
comprehensive set of analytical and campaigh management tools. The suite
leverages leading technologies to help companies plan, execute, and analyze
marketing programs.

Sales: This suite of applications provides sales professionals with a comprehensive
set of tools to maximize sales, increase selling effectiveness, and align sales behavior
to corporate objectives. It also helps sales executives understand and analyze the
performance of various sales channels; the field sales force, inside sales, distributors,
and the Internet by market segment or account.

Contracts: This suite of applications allows you to create and manage contracts,
warranties, and extended warranties; providing visibility to contract entitlements
and proactively acting upon contractual commitments within the contract. Oracle
Contracts Core and Oracle Contracts for Service allow your company to define and
price new service offerings quickly to take advantage of market opportunities, while
ensuring that the offerings conform to the company’s unique business practices.

Service: This suite of applications is promotes profitable end-to-end service delivery
and customer care. It provides full business process management, with functionality
in support, scheduling and dispatching, spare parts, logistics, service billing, contract
management, and mobile field service.

Architecture and Technology 2-3



Architectural Overview

Table 2-1 Description of Oracle CRM E-Business Suite of Applications

that can be used by the entire CRM suite. These are:
«  Resource Manager

. Notes

«  Development Tools

. Territory Manager

«  Assignment Manager
«  Task Manager

. Calendar

« Interaction History

«  Fulfillment

«  Escalation Manager

«  Business Rule Monitor

Function Description
CRM Application CRM Foundation is divided into two areas: the Application Foundation, and the
Foundation Technical Foundation. The Application Foundation consists of a number of modules

*The Technical Foundation provides the underlying technology stack for use by
HTML applications and includes the User Management module.
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Table 2-1 Description of Oracle CRM E-Business Suite of Applications

Function

Description

Interaction Channels

Interaction Channels enable the organization and the enterprise applications to
support interactions with customers, partners, and others. A set of products,
including those of the Call Center suite, provide support for multiple communication
channels and deliver advanced functionality. Products included are:

Multimedia Telephony Manager: Oracle Telephony Manager is the platform for all
Oracle call center and telephony applications.

Predictive Dialer: The Oracle Predictive module that uses Computer Telephony
Integration (CTI) technology to predictively dial numbers. Oracle Predictive allows
companies to have one enterprise-wide dialing system that can be centrally
managed.

Scripting: Oracle Scripting is an authoring tool and execution engine for interaction
scripting used for productivity, consistency, and training.

Call Center Connectors: This component enables Oracle Advanced Inbound and
desktop applications to support screen pops generated on the basis of the caller’s
billing number identification (ANI), the number that was called by the customer
(DNIS), or information entered into the IVR.

eMail Center: Oracle eMail Center is an inbound and outbound e-mail solution for
providing Internet-based customer service and direct marketing. Oracle’s eMail
Center is a key component in transforming traditional telephone-based call centers
into multi-channel customer interaction centers.

Web: Web-based self-service solutions give customers access to the same information
resources available through telephone-based interactions.

Mobile: Mobile access (laptop, hand-held device, WAP) to information is provided to
remote sales or customer service personnel.

Interaction Blending: This functionality provides sophisticated service-level
management capabilities across interaction channels.

E-Business

Common Application Architecture and Schema: These components are provided
for the applications to leverage, including: Forms, Reports, J-Developer, AOL, JTF
and Discoverer development tools, coding and Ul standards, and other functionality
used by the applications.

E-Business Platform: The Oracle database drives enterprise e-business applications,
online transaction processing applications (OLTP), query-intensive data warehouses,
and high capacity Web sites.
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2.2 System Requirements

Technology Stack

For information on Oracle E-business Suite Release 11i system requirements and
technology stack, consult the Oracle Applications Installing Oracle Applications
Release 11i manual, especially the section entitled "Release 11i System
Requirements."

You may also wish to consult the following Oracle web site for information relating
to certification of the various technology stack components:

http://certify.us.oracle.com/

HTML Technology Stack

The architecture for the HTML based applications in CRM use the Java Server Page
(JSP1.0), Servlets 2.0, Apache Webserver and the HTML Technology Stack
application infrastructure.

For additional information, please visit the below mentioned URLs
« JSPs
http://java.sun.com/products/jsp/techinfo.html
« Servlets
http://java.sun.com/products/serviet/index.html
= Apache Server

http://www.apache.org/httpd.html
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Dependency Requirements and Verification

This chapter provides an overview of the mandatory dependencies and the
installation and dependency verification checklist and procedures. Topics include:

« Mandatory Dependencies
— Mandatory Dependencies by Module

« Installation and Dependency Verification

3.1 Mandatory Dependencies

Oracle Foundation integrates with other Oracle application modules to provide and
extend its functionality. You must set up the mandatory modules before the
Foundation modules can run. Setting up the optional modules is not required;
however, if they are not set up, then the additional functionality provided by these
modules will not be available.

Many of these modules are included in your general installation. For information on
Oracle E-business Suite Release 11i system requirements and dependencies, consult
the Oracle Applications Installing Oracle Applications Release 11i manual.

Ensure that the following modules are set up for CRM Application Foundation to
function properly.

Oracle HTML Stack

Oracle HTML Stack is a prerequisite for implementation of any Oracle CRM
module. You set up properties in Oracle HTML Stack for debug logging trails and
cookie encryption. You also specify default roles and responsibilities for users in
this module.
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Oracle Human Resources

Oracle Human Resources stores information related to your organizations or
employees.

Oracle Application Object Library

Oracle Application Object Library (AOL) is a required dependency of all Oracle
applications modules. Foundation uses AOL to manage responsibilities that are
used in various modules.

Oracle Workflow

Oracle Workflow allows you to automate and continuously improve business
processes and route information of any type according to defined business rules.
Many modules use Workflow in sending out notifications and approvals.

Trading Community Architecture Component

Oracle Trading Community models and manages an electronic representation of the
commercial community in which you do business.

Oracle Trading Community includes:

« A comprehensive database schema also referred to as the Community Registry
« Asetof PL SQL API’s for custom development

« Access integration with content providers

« A sophisticated set of data management utilities

3.1.1 Mandatory Dependencies by Module

In addition to the mandatory dependencies for Oracle CRM Application
Foundation that must be installed, there are additional mandatory dependencies
that are required for the individual module. These additional dependencies are as
follows:

3.1.1.1 Resource Manager
None

3.1.1.2 Notes
None
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3.1.1.3 Territory Manager
None

3.1.1.4 Assignment Manager

For correct operation of the Assignment Manager module, you must have the
following components:

TCF Server: It must be running and correctly configured to connect to
Scheduler and for Gantt charts to display and render properly.

Oracle Scheduler: It is used to show the lowest cost resources and travel time
information for a resource while using the Intelligent and Window to Promise
assignment options. These two resource assignment options are used primarily
for service requests in Field Service.

Territory Manager: It is used to retrieve qualified resources identified in a
territory.

Calendar: It is used to provide the availability of qualified resources. The
Calendar module provides the work shift information for a resource.

Oracle Contracts: It is used to retrieve preferred engineers defined in Contract.

Service Request: It is used primarily to have a resource assigned by the
Intelligent and Window to Promise assignment options.

Install Base: It is used to retrieve preferred engineers defined in Install Base.

3.1.1.5 Task Manager

For correct operation of the Task Manager module, you must have the following
components:

Territory Manager: The Task Manager queries the Territory Manager to
determine the owner of a task.

Resource Manager: The Task Manager queries the Resource Manager to
determine the owner of a resource.

Assignment Manager: The Task Manager uses the Assignment Manager to
assign qualified resources to a task.

Calendar: The Task Manager uses the Calendar module to find available
resources.
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« Escalation Manager: The Task Manager uses the Escalation Manager to escalate
a task.

« Universal Work Queue (UWQ): UWQ displays tasks.

3.1.1.6 Calendar

For correct operation of the Calendar module, you must have the following
component:

Task Manager: It used to find a task for a resource.

3.1.1.7 Interaction History

For correct operation of the Interaction History module, you must have the
following components:

» Task Manager: It is used for interactions between customers and agents for
certain tasks.

« Notes: Notes can be attached to an object or a task as part of the interaction
records.

3.1.1.8 Fulfillment

For correct operation of the Fulfillment module, you must have the following
components:

« Interaction History: It is used to record the fulfillments that have been sent out
to customers.

» Foundation Marketing Encyclopedia Foundation Component (JMES): It is
used to upload and download documents and attachments.

3.1.1.9 Escalation Manager

For correct operation of the Escalation Manager module, you must have the
following component:

« Territory Manager: The Escalation Manager queries the Territory Manager to
determine the owner of an escalation.

» Task Manager: Tasks can be escalated.

= Notes: Notes can be attached to an object, a task, or a service request which is
escalated.
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3.1.1.10 Business Rule Monitor

For correct operation of the Escalation Manager module, you must have the

following component:

« Territory Manager: BRM uses Territory Manager in automatic assignment and

notifications of escalations.

» Task Manager: Tasks can be escalated.

= Notes: Notes can be attached to an object, a task, or a service request which is

escalated.

3.2 Installation and Dependency Verification

Before attempting to run the CRM applications, first verify that you can perform the
tasks outlined in the following table. The listed tasks are generic tasks that are
typical of all users of the Oracle E-business Suite. Depending on your business
processes, and the modules that are installed, not every listed task is applicable to

your installation.

Table 3-1 ERP Verification List

ERP Application

Task

Application Object Library

Create a FND user.

Human Resources

Create an employee.

Accounts Receivable

Create a customer.

Workflow Create a workflow with notifications.
Inventory Verify item setup in Oracle Inventory.
Pricing Verify price list setup in Oracle Pricing.

Advanced Planning and Scheduling

Verify ATP check.

Oracle Receivables

Verify Oracle Receivables setup.

Order Management

Verify Oracle Order Management setup.

Order Management

Verify address setup.

Order Management

Create an order.

If you are unable to complete a task successfully, then correct the problem before

continuing.
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3.2.1 Create a FND User (AOL)

Perform the following steps to create a FND user in the Application Object Library.

Steps
1. Login to your personal Home page as a system administrator.

2. Choose the system administrator responsibility.

3. Inthe Navigator, choose Security > Users > Define.
The Define User form window opens.

Enter a new user name in the User Name field.
Enter a password in the Password field.

Re-enter the password for verification.

N oo u &

In the Responsibilities sub-tab, select the CRM HTML Administration
responsibility from the drop-down list of values.

8. Save the new user.

To verify that the user has been correctly set up, perform the following steps:
1. Login to your personal Home page as the newly created user.
2. Enter a new password when prompted.

You should now be able to access the personal Home page for this user.

Note: For this user to have access to HTML applications, you
must set additional profile options as detailed in the Implementing
Oracle CRM Foundation manual.

3.2.2 Create an Employee

To successfully run most of CRM products, you must first create resources within
the ERP Human Resources application. Perform the following steps to define an
employee for minimal functionality.

Steps

1. Login to your personal Home page as a super user with access to all
responsibilities.
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2. Choose the responsibility of your business unit’'s HRMS manager.
For example, this could be HRMS Manager US.
3. Inthe Navigator, select People > Enter and Maintain.
A find window opens.
4. Click New on the find window.
5. Enter the following employee information in the appropriate form fields:
« Last Name
» First Name
« Title
6. For Type, chose Employee.

7. Save the employee.

3.2.3 Create a Customer

Perform the following steps to create an new customer, with an address and contact
information in Oracle ERP Accounts Receivables application.

Steps
1. Login to your personal Home page as a super user with access to all
responsibilities.

2. Choose the Receivable Manager responsibility.
3. From the Navigator, choose Customers > Standard.

The Standard Screen displays.
4. Enter the name of a test corporation in the Name column.
5. Click Find to ascertain if the customer already exists.

As this customer does not exist, the New button is enabled.
6. Click New.

A new form window opens, also named Customer-Standard, but showing
detailed information for the address, and other information.

7. On the Address tab, click New to create a new address.
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A new form opens, displaying the same business purpose table as on the first
tab.

8. Fill in this form to create a new address.
Yellow fields are mandatory.
9. On the Business Purpose sub-tab, fill in the Usage, Location and check Primary.
For example:
« Usage: Marketing
« Location: 60p9
« Primary: Yes
10. On the Contacts: Telephone sub-tab, enter a new contact and phone number.
11. Close the window

12. When prompted to save your changes, answer Yes.

Verify the Information
To verify that the process worked properly, perform the following steps.

Open the 'Customer-Standard’ form again.

Enter the company name you entered above.

Click Search to query for the record you created.

If the record is found, click the 'Contacts: Telephone’ tab.
Place the cursor in the "Last Name’ field

From the menu, select View> Query by Example.

Enter the contacts last name as the search criteria.

© N o o > w N B

Click View > Query by Example > Run.

If the record for your contact name displays in the form, then you have
successfully created a customer with an address and a contact person for the
customer.

3.2.4 Create a Workflow with Notifications
To create and run a workflow with notifications, perform the following steps.
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Steps

1.
2.

Login to your personal Home page.

In the list of Self Service Applications, choose the Workflow Administrator
responsibility.

In the Navigator, choose Workflow >Launch Processes.
The Launch Processes page opens.
In the Item Type column, click Document Management.

If you have renamed the item types, this option appears in the Internal Name
column as WFDM.

The Initiate Workflow-WFDM page opens.
Enter values in the following fields:

« Item Key — Enter your name plus a sequence number (for example,
jdoel001)

« User Key - You may copy the value in the Item Key field
» Process Name — Enter Document Review

« Send Document — Leave blank

» Document Reviewer — Choose one from the list of values
« Comments — Enter Workflow Verification

» Response Document — Leave blank

Click OK.

The Activities List page opens to show Workflow statuses. The status of the
Workflow you just initiated should be Complete.

If the status of the Workflow is Error, click Exception in the Result column to
see an explanation of the error. Refer to the Oracle Workflow Guide 2.5 (A75397)
for assistance.

Click View Diagram to see a graphical representation of the Workflow process.

Leave the View Diagram window open as you continue to check the Workflow.

To Review the Progress of a Workflow
Use the following procedure to verify that the Workflow notification has been sent.
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Steps
1. Login to your personal Home page.

2. Inthe list of Self Service Applications, choose the Workflow Administrator
responsibility.

3. Inthe Navigator, choose Workflow >Find Notifications.
The Find Notifications page opens.

4. Inthe Type field, enter Document Management. In the To field, enter the
document reviewer.

5. Click Find.
The Worklist window opens.
6. Click Subject to open the notification.
If you see the notification, then workflow is set up correctly.

7. Click Approve to return to the Worklist window.

Further Verification

You may go back to the View Diagram window that you opened earlier. Click
Reload in the browser window to refresh the contents of the window.

When the Workflow process is successfully completed, you can see a green line
from the Start icon to the End (Approve) icon.

3.2.5 Verify Item Setup In Oracle Inventory

Perform the following steps to verify that there exists items in Oracle Inventory that
can be selected for sale on the web.

Steps
1. Loginto your personal Home page as a super user (for example, SYSADMIN)
with access to all responsibilities.

2. Choose the Inventory responsibility.

3. From the Functions menu, select Items > Master Items.

4. Inthe pop-up window, select the appropriate organization.
For example, this could be Vision Operations.

5. On the Master Item form, search for the inventory item in question:
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10.

11.

12.

a. Choose View > Query By Example > Enter (or hit F11).
b. Inthe Item text field, enter the part number (using wildcards if necessary).

c. Choose View > Query By Example > Run (or hit Ctrl-F11) to execute the
query.

If the item is found, click on the drop-down list to the right of the tabs (meaning
the small button with the two triangles).

Select the Order Management tab.

Ensure that the boxes next to Customer Ordered and Customer Orders Enabled
are checked.

Click on the drop-down list to the right of the tabs (meaning the small button
with the two triangles) again, and select the Web Option tab.

Ensure one of the following:
= Web Status is Published to display the item in the customer UI.

= Web Status is Unpublished if you do not want the item to display in the
customer Ul, but would like to be able to access it via the merchant Ul.

= Items with a Web Status of Disabled are not visible in either the customer or
the merchant Ul.

Ensure that the box next to Orderable On The Web is checked.
If it is not checked, check the box to ensure that item is orderable over the web.

If you made any changes, save the form by going to File > Save.

3.2.6 Verify Price List Setup In Oracle Pricing

Perform the following steps to verify that a given price list exists, and to view the
associated inventory items and their prices.

Steps

1.

Log in to your personal Home page as a super user (for example, SYSADMIN)
with access to all responsibilities.

Choose the Oracle Pricing Manager responsibility.
From the Functions menu, select Price Lists > Price List Setup.

Search for the desired price list by name (for example, Corporate):
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a. HitF11 to enter query mode.
b. Enter the price list name in the Name field, using wildcards if appropriate.
c. Hit Ctrl-F11 to execute the query.
If the named price list exists, the details display.
On the List Lines tab, search for the item(s) to verify. For each item in question:
«  Ensure the unit of measure (UOM) is correct.
« Ensure that Application Method is Unit Price.
« Ensure that the Value field is set to the correct price.

Refer to the Oracle Pricing User’s Guide (Part #A77032-01) for further price list
setup details.

3.2.7 Verify ATP Check

Perform the following steps to verify that ATP works for a given inventory item:

Steps

1.

Login to your personal Home page as a super user (for example, SYSADMIN)
with access to all responsibilities.

Choose the Advanced Supply Chain Planner responsibility.
From the Functions menu, select ATP > ATP Inquiry.

In the pop-up window, select the appropriate organization.
For example, this could be Vision Operations.

On the ATP Criteria form, enter the query criteria.

Refer to the Oracle Advanced Supply Chain Planning And Oracle Global ATP
Server User’s Guide (Part #A81011-01) for details on how to specify ATP
criteria.

You must enter the following values, at a minimum:

« Organization: Enter the inventory organization to be considered for the
ATP query.

« Item: Enter the part number of the item for which you want to check
availability.
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» UOM: Ensure that the unit of measure is correct; change it using the LOV if
necessary.

« Quantity: Enter the requested quantity.
» Request Date: Enter the need-by date for the quantity requested.
7. Click ATP Results to run the ATP query.

8. On the ATP Workbench form, scroll right to see the ship date, available
guantity, the quantity available on the requested date, and similar information.
Scroll all the way to the right to see any error messages.

If there was an error performing the ATP query, refer to the Oracle Advanced
Supply Chain Planning And Oracle Global ATP Server User’s Guide on how to set
up ATP for the desired item.

3.2.8 Verify Oracle Receivables Setup

Perform these steps to verify that the tax system in Oracle Receivables is set up
properly for correct operation with iStore.

Steps
1. Log into your personal Home page as a super user (for example, as
SYSADMIN) with access to all responsibilities.

2. Choose the Receivables Manager responsibility.
3. From the Functions menu, choose Setup > System > System Options.
4. On the System Options form, select the Tax tab:

« Ensure that Address Validation is set correctly. (If set to No Validation, the
application does not raise an error even if an address cannot be validated.)

« Ensure that the Postal Code range is set appropriately (for example, 00000
through 99999-9999).

Refer to the Oracle Receivables User’s Guide (Part #A80837-01) and the Oracle
Receivables Tax Manual (Part #A80828-01) for further details.

3.2.9 Verify Oracle Order Management Setup

Perform the following steps to verify the transaction type setup in Oracle Order
Management.
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Steps

1.

7.

Log in to your personal Home page as a super user (for example, as
SYSADMIN) with access to all responsibilities.

Choose the Order Management Super User responsibility.
From the Functions menu, choose Setup > Transaction Types > Define.

On the Transaction Types form, search for the appropriate transaction type (for
example, Standard):

a. HitF11 to enter query mode.

b. Enter the transaction type name in the Transaction Type field, using
wildcards if appropriate.

c. Hit Ctrl-F11 to execute the query.

If the transaction type in question exists, the details display.

« Ensure that the current date falls between the Effective Dates.

« Ensure that the Transaction Type Code is valid (for example, ORDER).
« Ensure that the Order Category is defined (for example, Mixed).

« Ensure that the Order Workflow defines a valid header flow (for example,
Order Flow - Generic).

Click Assign Line Flows.
The Line Flow Assignments window opens.

Ensure that a valid line flow is associated with all item types.

Refer to the Oracle Order Management User’s Guide (Part #A77028-01) for further
details.

3.2.10 Verify Address Setup in Oracle Order Management

Perform the following steps to verify address setup in Oracle Order Management.

Steps

1. Loginto your personal Home page as a super user (for example, SYSADMIN)
with access to all responsibilities.

2. Choose the Order Management Super User responsibility.

3. From the Functions menu, choose Setup > Tax > Locations.
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The Tax Locations And Rates form opens.
4. Select State, and click Find.

5. Ensure that the desired state code exists, that the desired postal code is within
the valid range, and that the effective date is valid.

6. Repeat the above steps for County and City if necessary.
Refer to the Oracle Receivables Tax Manual (Part #A80828-01) for further details.

3.2.11 Create an Order

Perform the following steps to create an order in the Oracle Order Management
application.

Steps
1. Login to your personal Home page as a super user with access to all
responsibilities.

Choose the Order Management Super User responsibility.

From the Navigator, choose Orders, Returns > Sales Orders.
Select a customer using a customer name or a customer number.
Choose an order type form the list of values.

Choose a price list from the list of values.
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Click on the line item tab.
The line items view displays.
7. Select an item on the main sub tab.
8. Enter the quantity for that item.
The price displays in the Unit Selling Price field.
9. Click Book Order and verify that there are no error messages.

10. On the main sub tab verify that the status of the order displays as Booked.
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Implementation Overview

Oracle strongly recommends that you implement the CRM Application Foundation
modules in the order listed:

« Resource Manager

« Notes

« Spreadtable

« Territory Manager

« Assignment Manager
« Task Manager

» Calendar

« Interaction History

«  Fulfillment

« Escalation Manager

= Business Rule Monitor

Note: User registration and management is performed through
the System Administrator’s Console. See the Oracle CRM
Technology Foundation Implementation Guide for information
relating to user management.
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4.1 Resource Manager

4.1.1 Process

Description

The Resource Manager provides lists of resources, as individuals, groups, and
teams, for applications to access and manage their resources. Resources are defined
as the employees, supplier contacts, parties and partners that are used by the
different CRM components to accomplish business objectives.

Use Resource Manager to import and view resources, define resources, define roles
and role types, create teams and groups, and organize resources within those teams
and groups. Defining and organizing your resource information makes your
resources available to the connected application modules for work action. Resources
can be organized into groups and teams. Each group or team can be defined in one
of two ways, a role or a role type.

4.1.2 Implementation Task Sequence

The following table describes the order and process of implementing the Task
Manager.

Table 4-1 Resource Manager Process

Profile Options

Steps Description Required | Performed By
Defining Role Use the Resource Manager to define role types for | Yes Implementor
Types resources.

Defining Resource | Use the Resource Manager to define resource Yes Implementor
Roles roles.

Setting System Use the Resource Manager to set profile options Optional | Implementor

for the system.

Workflows in Set up the workflow to send notifications to Yes Implementor
Resource Manager | employee resources who update their information

in HTML.
Importing Use the Resource Manager to import resources. Yes System Administrator
Resources
Defining a Use the Resource Manager to define a salesperson | Yes System Administrator
Salesperson
Defining Resource | Use the Resource Manager to define resource Yes System Administrator
Groups groups.
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Table 4-1 Resource Manager Process

Steps Description Required | Performed By
Defining Dynamic | Use the Resource Manager to define dynamic Yes System Administrator
Groups groups.
Defining Resource | Use the Resource Manager to define resource Yes System Administrator
Teams teams.
Running Use the Resource Manager to run concurrent Optional | System Administrator
Concurrent programs.
Programs
Running a Group | Use the Resource Manager to run a group audit Optional | System Administrator
Audit Report report.
Running a Group | Use the Resource Manager to run a group Optional | System Administrator
Structure Report structure report.
Create an Use the HTML Resource Manager to create an Yes System Administrator
Employee employee resource.
Resource
Creating a Group | Use the HTML Resource Manager to create a Yes System Administrator
Resource group resource.
Defining Resource | Use the HTML Resource Manager to define Optional | System Administrator
Fields for Update | whether a notification is sent to the employee

resource if their personal information is modified.

4.2 Notes

4.2.1 Process

Description

A note is a record of descriptive information that has been generated by users and
can be referenced. Notes can be used from different applications in the E-Business
suite to access the comment log that relates to a specific transaction.

You can only view notes that are not specified as private. A note can also have one
to multiple attachments. As a default, all notes created by the resource appear on
the Notes Summary window. If the Note module is accessed from other
applications, all notes for that source ID and source hame are shown.

In various business transactions, such as service requests, customer orders, sales,
and marketing transactions, an agent or customer support representative needs to
record information about the transactions performed. Notes help to categorize these
business transactions.
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4.2.2 Implementation Task Sequence

The following table describes the order and process of implementing Notes.

Table 4-2 Notes Process

Options

implementation needs.

Steps Description Required | Performed By

Set up Note Types You can use either the seeded types or create Yes Implementor
additional customized types.

Map Note Types to a Mapping notes limits the visible note types for Yes Implementor

Source that source to the defined subset of note types.

Set up the Source Object | When you define a new document, you must Yes Implementor

Code and Context associate Notes usage to the new document.

Set up System Profile Set up system profile options specific to your Yes Implementor

4.3 Spreadtable

4.3.1 Process Descri

ption

WARNING: Oracle does not support custom development of new

forms using the spreadtable interface.

Do not delete currently existing columns when modifying an existing
spreadtable. Instead, use the Freeze Visible State property in the Display

tab to make the column invisible to the user.

Do not delete any existing metadata definitions.

If you modify existing metadata definitions, these changes may be

overwritten by subsequent patches.

An optional implementation step is to customize an existing spreadtable to meet
your business needs. You may change column headings, modify which columns
display information, and change the sort order for that information. Any

modifications to a spreadtable should be well thought out before proceeding due to

the consequences that might occur if performed incorrectly.

4-4 Oracle CRM Application Foundation Implementation Guide




Territory Manager

4.3.2 Implementation Task Sequence

Table 4-3 Spreadtabl

The following table describes the order and process of creating a spreadtable.

e Process

Steps

Description Required

Define the spreadtable

Use the Spreadtable Meta Data Administration window to define Yes
the spreadtable layout.

Define column properties Use the Database tab to define and label the individual columns. Yes

Define column display Use the Display tab to define how each column displays Yes
information

Set formatting Use the Alignment and Formatting tab to set the cell formatting Yes

Set sort key Use the Sort Order tab to define the information is sorted Yes

4.4 Territory Manager

4.4.1 Process Description

Before using the Territory Manager, your territory planning team must analyze
your business and organization needs for better territory planning and future
management. This step should be in place before implementing the Territory
Manager.

The implementation team enables seeded qualifiers used in your territories
based on the planning decisions.

The territory administrator then begins the territory creation process, according
to the territory plan, using the concept of basic territory building blocks. This
territory creation process may use different ways to create territories either with
or without using templates or types. It can include the use of escalation
territories to help manage future escalations.

After territories have been created, you can search and view territory
hierarchies through either the Administration menu or the Navigator tree. The
territory administrator must run the “Generate Territory Package” concurrent
program to generate correct territories with changes reflected before calling
modules assign resources defined in your territories.
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Note: Auto Assign Resources is functional only if the resource
qualifiers and their values are entered in the Resource Qualifiers
tab.

4.4.2 Implementation Task Sequence

The following table describes the order and process of implementing Territory
Manager.

Table 4-4 Territory Manager Process

Steps Description Required
Territory Planning Analyze the territory setup in your organization before utilizing Yes
Territory Manager. You need enterprise-wide cooperation and
feedback.

You must expect to make multiple territory revisions in the early
months of operation as your enterprise discovers omitted
information or territories that do not work on a day-to-day basis.

Enable Qualifiers Use qualifiers as the criteria to delineate a territory. Yes

Create Territories Create territories for a variety of transactions. For example: Yes
account, lead, opportunity, and service requests.

Create Templates Use a territory template to create many similar territories at the No
same time.

Create Types Create territory types to form a grouping of transaction qualifiers No
that can be used to simplify and systematize the territory creation
process.

Create Escalation Territories | Use escalation territory to create alternate territories where No

transactions such as a sales lead or service call is automatically
reassigned when certain conditions are not met. It defines the
teams that handle escalations. It is limited to identifying resources.
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Table 4-4 Territory Manager Process

creating or modifying your territories.

This allows the system to compile the business rules defined
during territory creation. If this step is not completed, the
territories will not work correctly.

Steps Description Required
Create Customer Name Create, modify, or delete an existing name of a group and it’s No
Range Group children. You must first create this transaction qualifier, before

enabling it.
Create Mass Change Use to mass transfer territory allocations from one resource to No
Territory Resources another.
Run Concurrent Program Run the concurrent program "Generate Territory Package" after Yes

4.5 Assignment Manager

4.5.1 Process Description

The Assignment Manager is a tool used to select and designate qualified resources
to a document or a task. Accessed from other modules and applications, it is not a
stand-alone module. It supports all resource categories defined in the Resource

Manager module.

Note:

Documents can be leads, opportunities, service requests,
defects, or escalations. Once a document is created, it can require
multiple tasks to fulfill the requirements.

Using the Assignment Manager, you can designate resources for a task or document
as well as assign ownership.

4.5.2 Implementation Task Sequence

The following table describes the order and process of implementing

Assignment Manager.

Implementation Overview 4-7



Task Manager

Table 4-5 Assignment Manager Process

retrieve the preferred resource information.

Steps Description Required
Verify installation and The Thin Client Framework Server connects to Scheduler and | Yes
functioning of TCF Server aids the Gantt chart to display and render.
Verify installation and It is used to show the lowest cost resources and travel time No
functioning of Scheduler information for a resource while using the Intelligent and

Window to Promise assignment options.
Verify installation and Territory Manager ensures transaction qualifiers are set up Yes
functioning of Territory Manager | correctly and qualified resources are specified in a territory.
Verify installation and Calendar provides the work shift information for a resource. Yes
functioning of Calendar
Verify installation and Assignment Manager retrieves preferred engineers or groups | Yes
functioning of Oracle Contracts defined in Oracle Contracts.
Verify installation and Service Request uses Assignment Manager to assign a resource | Yes
functioning of Service Request through the Intelligent and Window to Promise assignment

options.
Verify installation and Assignment Manager can assign preferred engineers or groups | Yes
functioning of Install Base defined in Install Base.
Set up system profile options Setting up profile options allows Assignment Manager to Yes

4.6 Task Manager

4.6.1 Process Description

All Oracle CRM products use the Task Manager for task management capabilities. It
provides an effective mechanism for organizations to use to respond to customer’s
needs in a timely manner. Use the Task Manager to create, assign, schedule,
prioritize, and manage all your tasks. Typically, you access the Task Manager
directly to create personal tasks or view tasks assigned to you.

Using Task Manager, you can create new tasks, update tasks, or assign tasks. You
can accept an assigned task, finish the task, and create a new task. If you refuse or
reassign a task to another employee, the task can generate a series of notifications
for other users or managers. Tasks not performed in a specified amount of time, can
be set up to go through an escalation process.
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4.6.2 Implementation Task Sequence

The following table describes the order and process of implementing the Task
Manager.

Table 4-6 Task Manager Process Flow

Steps Description Required Performed By
Defining Task Status | Use Task Manager to create new task statuses. | Optional Implementor
Determining Task Use Task Manager to create new task Optional Implementor
Priority priorities.
Defining Task Types | Use Task Manager to create new task types. Optional Implementor
Defining a Status Use task transition model to restrict the status | Optional Implementor
Transition and assigned to a task depending on the
Assigning Rules responsibility.
Designing Task Use Task Manager to create templates if the Optional Implementor
Templates same task is defined repeatedly.
Setting System Use Task Manager to set profile options. Optional Implementor
Profile Options
Workflows Use Task Manager to send notifications to Optional Implementor
employee type resources.
4.7 Calendar

4.7.1 Process Description

Use Calendar to effectively manage your daily activities, appointments, and tasks.
Calendar provides other Oracle products with the ability to create appointments
and show specific campaigns in a calendar view format.

You can click any hyperlink for a task, appointment, or event and access the details
for that specific object. The key functionality of the Calendar includes viewing your
tasks, subscribing yourself to a group calendar, viewing public calendars, creating
and managing appointments, and inviting individuals to those appointments.

4.7.2 Implementation Task Sequence

The following table describes the order and process of implementing the Calendar.
The implementation for Calendar is done in the Forms version.
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Table 4-7 Calendar Process Flow

Requests

grant or deny a group or public calendar
request.

Steps Description Required Performed By
Calendar Use Calendar as an integrated solution for Yes Implementor
Integration with scheduling with other Oracle E-Business suite

other Modules applications.

Setting System Use Calendar Forms to set your profile Yes Implementor

Profile Options options.

Creating a Calendar | Use Calendar Forms to set your calendar Yes Implementor

System System Administrator

Administrator

Creating a Calendar | Use the Resource Manager to create a Yes Calendar Administrator
User resource type employee.

Defining a Role for | Use the HTML calendar to define the calendar | Yes Calendar Administrator
a Calendar User users role.

Processing Calendar | Use the workflow notification window to Yes Calendar Administrator

4.8 Interaction History

4.8.1 Process Description

Interaction History tracks all customer-agent interactions and serves as a repository
for the interaction data. By tracking all contacts between human or automated
agents and existing or potential customers and customer systems, Interaction
History supports the development of the 360 degree customer view for the user
organization. Interaction data provides the agent with a detailed history of the
business’s relationship with the customer, enabling agents to serve clients more
effectively. Types of interactions and activity data tracked include customer, account
number, agent, campaign, date and time, activity type, outcome and result of
interaction or activity, along with duration, and notes. All records kept in
Interaction History are a historical record.

4.8.2 Implementation Task Sequence
The following table describes the order and process of implementing Interaction

History.
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Table 4-8 Interaction History Process

Steps Description Required

Install Release Dependencies The following modules must be installed and stable: Yes
«  Resource Manager
«  Task Manager
«  Fulfillment
«  Technical Architecture Customer Model

Define Additional Outcome Codes These codes are required by the application in additionto | No
the initial seeded values. Modify or delete existing
Outcome codes.

Define Additional Result Codes These codes are required by the application in additionto | No
the initial seeded values. Modify or delete existing Result
codes.

Define Additional Reason Codes These codes are required by the application in additionto | No
the initial seeded values. Modify or delete existing Reason
codes.

Define Additional Action Item Codes | These codes are required by the application in additionto | No
the initial seeded values. Modify or delete existing Action
codes.

Define Additional Action Codes These codes are required by the application in additionto | No
the initial seeded values. Modify or delete existing Action
codes.

Define the Outcome, Result, and These codes are required for specific campaigns and No

Reason Codes promotions.

Define Unique Pairs of Outcome Define them from existing codes in the Outcome and No

Results Result tables. These codes are required for specific
campaigns and promotions.

Define Unique Pairs of Result Reasons | Define them from existing codes in the Result and Reason | No
tables. These codes are required for specific campaigns
and promotions.

Define a Wrap Up A wrap-up is a summary of a transaction that an agent No
enters after completing a transaction.

Importing Mass Data Importing mass data from a legacy system allows you to No

view interactions in Interaction History.
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4.9 Fulfillment

4.9.1 Process Description

Fulfillment is defined as an automated way to send information to customers. It
provides the ability to immediately satisfy a customer’s requests for information,
literature, and other correspondence. Customer Service Representatives handle a
variety of requests ranging from product and service inquiries, pricing questions,
billing inquiries, and general customer care issues. Many of these requests will
result in some dissemination of literature, collateral, forms of application, letters, or
correspondence to the customer. Fulfillment provides the ability for call center
administrators, mobile field representatives, marketing managers, customer care
representatives, and other service agents to respond to different customer needs
quickly and easily using email.

4.9.2 Implementation Task Sequence

The following table describes the order and process of implementing

Fulfillment.

Table 4-9 Fulfillment Process

Servers.

Steps Description Required

Install Release Dependencies HTML Tech Stack, Interaction History, and Marketing Yes
Encyclopedia must be installed and stable.

Set up the Fulfillment Administrative | This process creates the Fulfillment Administrator. The Yes

User FM Admin user is responsible for configuring the
fulfillment product.

Assign Role The Fulfillment Administrator (FM Admin) must have a Yes
seeded role assigned to her.

Assign Responsibility The FM Admin user must have the JTF_FM_ Yes
ADMINISTRATOR responsibility assigned to it.

Define and Configure the Fulfillment | The server calls on database tables to supply collateral, Yes

Server and sends the collateral to specified output devices.

Define Fulfillment Groups and Assign | Each fulfillment group must be assigned to a server. Yes

Groups to Servers

Configure Email Servers You must associate the email servers with the Fulfillment | Yes
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Table 4-9 Fulfillment Process

template.

Steps Description Required
Create, Modify, and Add Groups to You can create groups and add them to the Fulfillment Yes
the Servers Servers.
Add or Remove Agents to a Group You must associate agent groups with the Fulfillment Yes
server, and associate output devices with the groups.
Archive Sent Emails If calling applications send an archived request, then the No
email has a message identifier called the SMTP ID which
is retrieved and stored as part of an interaction activity in
the Interaction History module.
Configure Fax Servers This is a customized set up and requires you to directly No
contact Oracle Support for set up directions.
Create a New Template A template can contain either a Master Document or No
collateral.
Add a Master Document to a Master Documents contain dynamic information or in No
Template some cases can be static documents. Master Documents
are usually referred to as cover letters.
Insert or Remove Collateral into a Collateral is a static fulfillment document that does not No
Template contain merged data. It can be a marketing brochure or
some other document. It is sent in an email as an
attachment.
Set up and Start the Fulfillment Server | Start the server so it can begin to process your incoming Yes
requests.
Set up and Send the Remote This allows you to control the server from a remote No
Command of the Server command, basically pausing the server, resuming it, and
viewing it.
Modify Startup Scripts for Remote Modify startup scripts so that the server will listen to No
Commands remote commands.
System Profile Options Set the profile options that are needed specifically for your | No
implementation. These options are default settings used
for the fulfillment server. These parameters can be set
directly in the fulfillment server start up script.
Preview and Print a Request You can preview and print a Fulfillment Request before No
sending it out.
Update a Template You can change the name, status, or description of a No
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Table 4-9 Fulfillment Process

Document to a Template

which Master Documents are associated to a template.

Steps Description Required
Create a Query Use a SQL statement that directs Fulfillment to collect No
specific types of data from the database when fulfilling a
request.
Create, Update, and Download a This is a text file that contains tab-separated merge fields | No
Datasource File that are obtained by a query. They are used as merge
fields.
Upload a Master Document Uploading a Master Document makes it available for No
Fulfillment requests. It is stored in the Marketing
Encyclopedia System (MES). This step is required if you
want to send Master Document requests.
Associate or Remove a Master You can specifically respond to a request by choosing No

4.10 Escalation Manager

4.10.1 Process Description

An escalation is a process used to highlight or flag certain issues within an

organization, so that the appropriate personnel can react to these situations and
monitor the resolutions. In a reactive escalation, something has happened or did not
happen and the customer complained. Necessary action must be taken in response
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to the situation. Manually assigning escalation resources can be done through the
Escalation Manager. A reactive escalation is in response to a customer complaint.

4.10.2 Implementation Task Sequence

The following table describes the order and process of implementing the
Escalation Manager.

Table 4-10 Escalation Manager Process

severity.

Steps Description Required

Set Profile Options You can identify and set the specific profile options and Yes
the corresponding values.

Start the Background Workflow Notifications are generated to the designated contact Yes
when the escalation is created and the owner, escalation
level, target date, or status is changed.

Define a New Customized Escalation | Escalation statuses are used to define the state of the No

Status escalation document.

Define New Escalation Reference Use reference types to determine if a document is goingto | No

Types be escalated. Examples are open, closed or working.

Define New Escalation Reason Codes | Escalation reasons are used to specify why a source No
document is escalated.

Define the New Escalation Contact Escalation contact types are used to classify the category No

Types for contacts. For example, contacts can be employees or
customers.

Define the Escalation Level Use escalation levels to specify the levels of escalation No

4.11 Business Rule Monitor

4.11.1 Process Description

In a proactive escalation, again something has happened or did not happen and
necessary action is taken to take care of it before the customer complains. The
Business Rule Monitor (BRM) is used to raise awareness. It provides a centralized
place to define and also monitor business rules on a regular basis. Proactive
escalation is used not just in response to problems but can be set up as a follow-up

action.
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4.11.2 Implementation Task Sequence

Use the Business Rule Monitor to check the active business rules. This sets up an
Oracle Workflow process which continuously loops and checks at a specified
interval for all defined business rules. The following table describes the order and
process of implementing the Business Rule Monitor.

Table 4-11 Business Rule Monitor Process

either follow prompts or directly write the code. This is
done from the Business Rule Workbench.

Steps Description Required
Define the owner of the workflow The owner of the workflow process is assigned to an Yes
process. existing user. This is typically the system administrator or

the workflow administrator.

Set the Business Rule Monitor system | The option is Business Rule Monitor Workflow Yes

profile option. Administrator.

Start the background Business Rule These attributes are maintained within the Business Rule | Yes

Monitor workflow processes. Workbench and ensure proper operation of the BRM.

Start the Business Rule Monitor. Once the Business Rule Monitor is started, there is no Yes
need to start it again, even after defining new business
rules.

Define new, customized, business You can define new rules to reflect your business logic. No

rules

Verify Escalation Territory creation. Ensure that you have a resource assigned to an Escalation | Yes
territory. The Escalation territory can be a catch all for all
escalations

Access the BRM Access the workbench to define, enable, or search for a Yes
business rule.

Manage the BRM Monitoring Process | Define, view, or adjust the BRM process from the Business | Yes
Rule Monitor control panel. This includes setting the time
interval and using the Workflow Monitor to view the
status of the main BRM process. Link the workflow to a
business rule.

Access the Workbench Access the workbench to define, search, validate, and Yes
generate a business rule.

Link the Workflow to a Business Rule | This is done from the Business Rule Workbench. Yes

Create a Business Rule When you set the conditions in SQL, you can choose to Yes
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Table 4-11 Business Rule Monitor Process

Steps Description Required

Enable a Business Rule Enable the rule by setting the Start Date in the Workbench. | Yes

Start and Stop monitoring the rules This is done from the Business Rule Monitor control Yes
panel.

View Workflow Logging Information | Use the Workflow monitor to view workflow logging Yes
information. This is a Java based tool.
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Implementation Tasks

The following Oracle CRM Application Foundation modules have implementation
tasks:

Resource Manager
Notes

Spreadtable

Territory Manager
Assignment Manager
Task Manager
Calendar

Interaction History
Fulfillment
Escalation Manager

Business Rule Monitor

Note: The tasks in this chapter are considered critical to
successfully implement each module. Some of the tasks may be
repeated for administrative purposes and therefore, may be
duplicated again in the Administrative section of the Oracle CRM
Application Foundation Concepts and Procedure Guide.
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5.1 Resource Manager

5.1.1 Defining Role Types

Note: You must save the Resource first before defining a Role
Type.

A Role Type is a category of roles associated with a particular CRM module.
Resource Manager is delivered with pre-defined Role Types for all CRM modules.
Perform the following steps to define additional custom Role Types for your
enterprise. Make sure that a role type exists with which you can associate the new
role.

Steps
1. Inthe CRM Administrator responsibility, navigate to Resource Manager >
Setup > Role Types.

The Application Object Library: JTF_RS ROLE_TYPES Lookups window
displays existing Role Types.

Use the down arrow to scroll to the bottom of the list of Role Types.

Select the last entry in the record and choose File > New to add a blank field.
Enter the name of the new Role Type in the blank field at the bottom of the list.
In the Meaning field, enter the CRM module for which this Role Type is created.

o o M W N

Choose File > Save to complete the Role Type definition.

5.1.2 Defining Resource Roles

A Role may encompass one or more job descriptions and job titles. Use Roles to
assign responsibilities to resources, resource groups and resource teams. Resource
Manager is delivered with pre-defined Roles for all CRM modules. Perform the
following steps to define additional custom Roles for your enterprise.

Prerequisites
Make sure that a Role Type exists with which you can associate the new Role.
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Steps

1. Inthe CRM Administrator responsibility, navigate to Resource Manager >

Setup > Roles.

The Roles window opens and displays fields you can use to define a role.

2. Enter your values in the Code and Name fields. Choose a Role Type from the
list of values (LOV).

3. Select the Active box to make the Role active. Select one or more of the role
attribute check boxes—-Member, Lead, Admin, Manager-to associate the Role to
a responsibility. See the Resource Roles Attributes table in the Guidelines
section for descriptions of these role attributes.

4. Use one or more Job names in the job region to describe jobs associated with the

Role.

5. Select File > Save to complete the Role definition.

The new role name registers in the Role Name field in Resource Manager. The
following table describes resource role attributes.

Guidelines

The following table describes resource role attributes used in the Resource Manager.

Table 5-1 Resource Role Attributes

Check Box Action

Member This check box identifies the role name as a member of the
role.

Lead This check box identifies the role name as a lead for the role.

Active This check box identifies the role as active.

Admin This check box identifies the role as administrative.

Manager This check box identifies the role as managerial.

Seeded (Read-only) | This check box identifies the role as seeded.

5.1.3 Workflows in Resource Manager

Resource Manager uses Workflow processes to send notifications for any of the
attributes selected in the Define Resource Fields for Update window.
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5.1.4 Importing Resources

Use Resource Manager to import a resource from a different application databases
depending on the resource category you select. After selecting a resource based on
its category, identify its role and eligibility dates before saving it to Resource
Manager.

Employees, Parties, Partners, and Supplier Contacts can be imported into the
Resource Manager from Oracle HRMS, Purchasing and Accounts Receivables,
depending on the resource category you select. The only resources that you can
create, but not import through the Resource window, is a salesperson with the
resource category of OTHER, or TBH (to be hired). Perform the following steps to
import a resource.

Prerequisites
None

Steps
1. Inthe CRM Administrator responsibility, navigate to Resource Manager >
Maintain Resources > Import Resources.

The Selection Criterion window opens.
2. Select from the list of values (LOV) in the Resource Category field.

3. (Optional) Refine your resource search by selecting from the LOV in the
available fields.

Different resource categories have different search field options.
4. Click Search.

The application populates the Category and Name fields in the Search Results
region.

5. Choose a resource by deselecting the Select check boxes for the undesired
resources and click Create Resource.

The Default Values window opens, and the application populates the Start Date
field with the current date.

6. (Optional) Select an end date, managing employee, role, and role effective
dates.

7. Click OK.

The Selected Resources window opens displaying the resource selections.
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8. Deselect the undesired resource check boxes and click Save Resource if you
want to save a resource to Resource Manager.

Resource importation and definition is complete.

9. If you want to further define the resource roles, groups, teams, or other details

use this procedure.

a. Click Details.

The Resource window opens.

b. Define the resource information from the tab options.

c. Choose File > Save.

Guidelines

The Comments field in the Selected Resources window indicates whether the
resource entry is a new record, duplicate record, or has a new role definition.

5.1.5 Defining a Salesperson

You can designate a resource as a salesperson in the Receivables tab. A resource
designated as a salesperson in this manner is organization specific, although in

general, resources are not.

Note: You can only create a resource of category Other, or TBH (to
be hired), through the Resource window. If your resource is of
another category, it must be imported.

If a salesperson is defined with category TBH, then this salesperson
is not visible within Accounts Receivable. A Salesperson defined in
this manner can be viewed only within CRM.

The following table describes the types of tasks that you can perform in the

Resource window.

Table 5-2 Tasks Available through the Resource Window

Task

Performing the Task

Create (define) a new salesperson of
type Other or TBH

Use the following steps outlined after the table.

Update a resource definition

Modify the resource definition as desired.
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Table 5-2 Tasks Available through the Resource Window

Task Performing the Task

View resource details View the resource details as desired.

Prerequisites
None

Steps
Perform the following steps to create a salesperson.
1. Click New in the Find Resource window.
The Resource window opens.
2. Select either TBH or Other for the Category.

3. You must enter a valid value for the Salesperson Number for the Salespersons
to be created.

4. Enter the new salespersons name in the Name field.
5. Enter a Start Date for the new salesperson.

You must enter at least a start date here. The end date defaults to an open end
data and is optional.

6. Select the Receivables tab.
For an explanation of each tab, see the Guideline following.
a. Enter the range of dates that this salesperson is to be active.

The Date Active (start date) is a required field and defaults as the current
date. However, you can change it by accessing the calendar through the list
of values (LOV). If you do not enter a Date Active (end date), this
salesperson is active indefinitely. The Date Active cannot precede the Start
Date.

If the salesperson’s status is Active but the transaction date that you enter is
not within this date range, Receivables does not display this salesperson in
the LOV in the Transactions window.

b. (Optional) Enter the new salespersons Email address.

c. (Optional) Enter a Geo Override value for this salesperson. This value
associates the salesperson with a unique tax jurisdiction.
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The Geo Override and Inside City Limits fields are available only if you
have installed a sales tax vendor of type Taxware Sales/Use Tax System or
Vertex Quantum.

If you entered a value in the Geo Override field and the tax jurisdiction for
this address is within city limits, select the Inside City Limits check box.
This check box is enabled only if your sales tax vendor is Vertex Quantum.

For additional information, see the following:
Integrating Oracle Receivables with Taxware Sales/Use Tax System, Release 11i.
Integrating Oracle Receivables with Vertex Quantum, Release 11i.

d. Check the Active for Receivables check box to indicate that this resource is
a salesperson.

e. Enter a quota Sales Credit Type.

Oracle Order Management uses this information to determine if the sales
credit for an order is a quota or non-quota amount. You can define
additional sales credit types in Oracle Order Management. However, you
can only assign Sales Credit Types that are of type 'Quota’ to salespersons in
Receivables.

f.  (Optional) Enter the Accounting Flexfield for your Revenue, Freight, and
Receivable Accounts.

Receivables can use this information, along with your AutoAccounting
rules, to determine the revenue, freight, and receivable accounts for
invoices you assign to this salesperson.

g. (Optional) Assign a territory to this salesperson.
The Territory Flexfield must be set up before an assignment is made.

h. (Optional) If you assigned a territory to this salesperson, then enter the
range of dates that this territory is to be assigned to this salesperson.

The Start Date defaults as the current date, but you can change it. If you do
not enter an End Date, this salesperson is active indefinitely, or as long as
the territory is active.

(Optional) Enter more information in the other tabs to further specify the
resource.

Choose File > Save to save your work.
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This action populates the Resource Number field with the automatically
generated resource tracking number.

Guidelines

The following table describes the tabs available in the Resource window, and
describes how the tabs are used.

Table 5-3 Resource Tab Descriptions

Tab

Description

Roles

Use this tab to view, assign, and modify information about roles and role types. The role
type is the actual role a resource plays, for example, Administrator or Contractor. These
roles, role types, and role attributes check boxes are defined in the Setup window. The
Start Date default is the current date, and it can be modified.

Groups

Use this tab to view, assign, and modify information about groups. Groups are not
necessarily one person, and a resource can belong to more than one group. The Groups
tab reveals in detail which groups the resource belongs to, and the role in the group.
Resources can play multiple roles in a group. Click the group name to display the group
member roles if this resource has group member roles assigned.

See Defining Resource Groups for details.

Teams

Use this tab to view, assign, and modify information about teams. Teams can comprise
multiple groups and combinations of groups and individuals. Click the team name to
view the Team Member Roles.

See Defining Resource Teams for details.

Service

Use this tab to define the Cost per Hour and Time Zone information. The Support Site
field is not operational, and not used at this time. You define the currency type in the
Compensation tab.

Interaction Center

Use this tab to view, assign, and modify the email addresses and the Agent ID numbers
of resources associated with the eMail Center or Call Center modules. This tab is used
primarily by the Call Center and eMail Center modules. All fields are read-only. If the
resource is not associated with either center, these fields are blank.

(Optional) Enter the Scripting Agent Login if the employee uses Oracle Scripting. Use
the Telephony Parameters region to enter middleware configuration, parameters, and
values for the agent. Which telephony parameters are required and which values to
specify depend on the types of switch and CTI middleware used in the Call Center.

Compensation

Use this tab to view or define the Currency Type corresponding to the Cost per Hour
listed on the Service tab.

Receivables

Use this tab to define a salesperson.

Miscellaneous

Use this tab to view personal information about the resource. The fields in this tab are
read-only.
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The following table describes fields located in the Receivables tab, in the Resource
window, which are used to define a salesperson.

Table 5-4 Field Descriptions for the Receivables tab in the Resource Window

Field

Description

Date Active

Enter the range of dates that this salesperson is to be active.
Date Active (start date) is a required field, the Date Active
(end date) is optional. If you do not enter an end date, this
salesperson is active indefinitely.

Geo Override and Inside
City Limits

The Geo Override value associates the salesperson with a
unique tax jurisdiction. Both fields are available only if you
have installed a sales tax vendor of type Taxware Sales. Oracle
recommends you use Tax System or Vertex Quantu.

Accounting Flexfield

The accounting flexfield includes Revenue, Freight, and
Receivable Accounts. Receivables can use this information,
along with your AutoAccounting rules, to determine the
revenue, freight, and receivable accounts for invoices that you
assign to this salesperson.

Territory Flexfield

If you want to assign a territory to this salesperson, then enter
the range of dates that this territory is to be assigned to this
salesperson. The Start Date defaults as the current date, but
you can change it. If you do not enter an End Date, this
territory is active for this salesperson infinitely.

5.1.6 Defining Resource Groups

An individual or group resource can belong to more than one group. Choose to
search for an existing group or create a new group; then define the group’s
members, roles, usages, and relations. Perform the following steps to define a

resource group.

Prerequisites
None

Steps

1. Inthe CRM Administrator responsibility, navigate to Resource Manager >
Maintain Resources > Groups.

The Define Groups window opens.

2. (Optional) To find an existing resource group, use this procedure.

Implementation Tasks 5-9



Resource Manager

a. On the application tool bar, click View > Find.
The Find Group window opens.

b. Select a group name from the list of values (LOV) in the Group Name field
and click Find.

The application populates the Results region with the group name search
results.

c. Selectagroup name in the Results table and click OK.

The application populates the Define Groups window with the group
information.

3. To create a new resource group, then use this procedure.
a. Enter a group name in the Name field.
b. Enter a brief description of the group in the Description field.
c. Enter the effective dates for the team in the Start and End fields.

4. (Optional) Select the Exclusive Flag check box to assign resources to this group
with a particular member role and usage that is not assigned to any other
exclusive group with the same member role and usage, in the same time frame.

5. Inthe Members tab, select a resource category and member number from the
LOV in the Category and Number fields.

The application populates the Name field with the member’s name and
affiliated organization.

6. (Optional) Select a member name and click one of the available buttons.

For a detailed description of the group member button options, see the
Resource Group Member Buttons table in the Guidelines section.

7. Inthe Roles tab, select a role type and role name from the LOV in the Role Type
and Role fields.

The roles relationship to its category is indicated by the role attributes check
box selections.

8. Inthe Usages tab, select one or more usage descriptions from the LOV in the
Usage field.

9. Choose File > Save.

10. Select either the Parent Group or Child Group tab depending on the relation
type.
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11. Select a group number from the LOV in the Group Number field of the selected
tab.

The application populates the Group Name field of the Parent Group or Child
Group tab.

12. Select effective dates for the relation from the LOV in the Start and End Date
fields.

13. Choose File > Save to save the group definition.

The new group is accessible from the Group tab in the Resource window.

Note: If the reporting hierarchy needs to be changed, it is better to
delete a group member role rather than end dating it.

Guidelines
The following table describes the Resource Group member buttons.

Table 5-5 Resource Group Member Buttons

Button Action
Member This button opens the main Resource window and record of
Details the member.

Move Member | This button opens the Move Member window, where you can
assign the member to another group.

Member Roles | This button opens the Member Roles window, where you can
define the member role type, name, and effective dates.

The following table describes the Define Group tabs.

Table 5-6 Define Group Tab Descriptions

Tab Description

Members Use this tab to define the member category and member
number of the group.You can also view a members details,
assign the member to another group, and view a members role
type in this tab.

Roles Use this tab to define roles and role types for the group.

Usages Use this tab to determine what CRM modules use the group.
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Table 5-6 Define Group Tab Descriptions

Tab Description
Parent Group Use this tab to define a group as a parent group.
Child Group Use this tab to define a group as a child group.

5.1.7 Defining Dynamic Groups

Determine the group values available to the user in Resource Manager. By defining
the name, usage values, and effective dates of a group. Perform the following steps
to define a dynamic group.

Prerequisites
None

Steps

1.

»

© N o u

In the CRM Administrator responsibility, navigate to Resource Manager >
Maintain Resources > Dynamic Groups.

The Dynamic Groups window opens.
Enter a group name in the Name field.
Select a group usage from the Usage field.

Select the effective dates for the group from the list of values (LOV) in the Start
and End fields.

Enter a brief description of the group name and usage in the Description field.
Enter the SQL statement to define a group.

Click Check Syntax to check the code for syntax errors.

Choose File > Save to save the group.

The new group name registers in the Group Name field in Resource Manager.

5.1.8 Defining Resource Teams
Team members represent a resource group, and are chosen for their availability and

qua
proj
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lifications. Teams consist of people that work together to efficiently complete a
ect. Perform the following steps to define a team.
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Prerequisites
You must define a resource group.

Steps

1.

In the CRM Administrator responsibility, navigate to Resource Manager >
Maintain Resources > Teams.

The Define Teams window opens.
(Optional) To find an existing resource team, use this procedure.
a. On the application tool bar, click View > Find.

The Find Team window opens.

b. Select a team name from the list of values (LOV) in the Name field and click
Find.

The application populates the Results region with the team name search
results.

c. Select ateam name in the Results table and click OK.

The application populates the Define Teams window with the group
information.

Enter a team name in the Name field.

(Optional) Select the Exclusive Flag check box to assign resources to this team
with a particular member role and team usage that is not assigned to any other
exclusive team with the same role and usage, in the same time frame.

Enter a brief description of the team in the Description field.
Enter the effective dates for the team in the Start and End fields.

In the Members tab, select a category and member from the LOV in Category,
and Number fields. For a detailed description of the group member button
options, see the Resource Group Member Buttons table in the Guidelines
section.

The application populates the Name field with the member’s name.
(Optional) Click Member Roles to assign team member roles to a team.

(Optional) Select a member name and click Member Details to view specific
member information.

10. In the Roles tab, select from the LOV in the Role Type and Role fields.
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The roles relationship to its category is indicated by the role attributes check
box selections.

11. In the Usages tab, select from the LOV in the Name field.
12. Choose File > Save to save the team definition.

The new team is accessible from the Team tab in the Resource window.

Guidelines

The following table gives a description of the tabs located in the Define Team
window.

Table 5-7 Define Team Tab Descriptions

Tab Description

Members Use this tab to define members of a team.

Roles Use this tab to define the team roles and role types.

Usages Use this tab to determine what CRM modules use the team.

5.1.9 Viewing Group Hierarchy

Use group hierarchy to view both the subordinates and a direct manager for a
specific resource. For example, you can view only those resources that report
directly, or you can view all resources that report to a particular person. This feature
does not identify who the manager is and who the subordinates are for this
resource. You can restrict your view by resource category. Perform the following
steps to view the hierarchy of a group.

Prerequisites
None

Steps
1. Inthe CRM Administrator responsibility, navigate to Resource Manager >
Maintain Resources > Group Hierarchy.

The Group Hierarchy window opens.

2. Select a resource from the list of values (LOV) in the Name field and click View
to view the groups of a particular resource member.
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The application populates the Groups region with the member’s groups and
effective enrollment dates.

3. Select a resource category from the Category LOV and click View to view the
groups and members of a resource category.

The application populates the Groups and Members regions with the group and
member names and effective enrollment dates.

4. Select All from the Category LOV and click View if you want to view all the
resource groups and members in the database.

The application populates the Groups and Members regions with all the groups

and their members and their effective enrollment dates.

Guidelines

Selecting Reports Directly from the LOV in the View By field searches the database
for members that report directly to a specific resource.

5.1.10 Running Concurrent Programs

Oracle recommends that the system administrator run the concurrent programs,
listed in the following table, on a regular basis, to synchronize data between the
Resource Manager and following applications and maintain data integrity.

Table 5-8 Resource Manager Concurrent Programs

username

Name Parameters Oracle Applications
Build Repeating Manager None N/A

Flatten Employee Hierarchy None Human Resources
Flatten Group Hierarchy None N/A

Populate Reporting Manager None N/A

Synchronize Application None FND

Synchronize Employees

No: Synchronize only the employees that currently
exist in Resource Manager.

Yes: Synchronize all the employees that currently
exist in Resource Manager plus all new active
employees in Human Resources that have not been
imported yet.

Human Resources

Synchronize Group Denorm

None

N/A
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Table 5-8 Resource Manager Concurrent Programs

Name Parameters Oracle Applications
Synchronize Parties and None Accounts Receivable
Partners

Synchronize Repeating None N/A

Manager

Synchronize Supplier Contacts | None Purchasing

Note: Oracle strongly recommends that an employee, or party, or
supplier contact not have more than one application user.

If a resource (employee, party, or supplier contact) is linked to two
or more application users, and imported into Resource Manager,
then one application user is selected at random and associated with
that resource.

5.1.11 Running an Audit Report

Resource Manager supports the ability to run an audit report detailing changes to
resources and resource groups created within a defined date. For example, any
changes made to new members of a group are defined, but role change information
is not. This provides an audit trail of the actions taken for specific groups, and
resources. Perform the following steps to run an Audit Report.

Note: Only the movement of a resource from a given group to
another group is tracked. Resources changing roles within the same
group are not reported in the Audit Report.

Prerequisites
You must have System Administrator responsibility.

Steps
1. Inthe CRM Administrator responsibility, navigate to Resource Manager >
Others > Requests > Run.

The Submit a New Request window opens.

2. Select the Single Request option button and click OK.
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The Submit Request window open.

3. Use the Name list of values (LOV) to select a report.
The Reports window opens.

4. Select Group Audit Report from the list of reports and click OK.
The Parameter window opens.

5. Enter parameters for the report.

In order for an Audit Report to run successfully, it is necessary to define both
Report Based On and Date Range/No. of Days for the report. The report runs
based on the information you enter for the following criteria.

» Report Based On

« Group

« Resource

« Updated By

» Date Range/No. of Days
« Start Date

« End Date

«  Number of Days for

6. (Optional) Change the time frame the report is suppose to run by clicking
Schedule.

The Schedule window opens.
7. Select the time frame when you want the report to run:
« Assoon as possible
« Once
« Periodically
« On specific days
8. Click OK.

9. (Optional) Click Options to determine who should be notified when the report
is complete and where you want to print the output to.

10. Click Submit.
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11. A dialog opens confirming your request was submitted.

5.1.12 Viewing an Audit Report

You can monitor the status of an audit report to see when it has been completed,
and if it completed successfully. Perform the following steps to view an Audit
report.

Prerequisites
A Group Audit Report must run successfully.

Steps

1. Inthe CRM Administrator responsibility, navigate to Resource Manager >
Others > Requests > View.

The Find Requests window opens.
2. Select the All My Requests option button.
3. Click Find.
The Requests window opens.
4. Select a Group Audit Report to view.
5. Click View Log to display the results of the report.

The report details opens in an HTML window along with a log file for the
report.

5.1.13 Running a Group Structure Report

Resource Manager supports the ability to run a Group Structure report detailing
any changes made to a specific the Parent or Child relationship of a resource group.
This ability provides you with a reliable audit trail of the actions taken for a specific
group. Group name changes, or any resource changes within the same group, are
not detailed in this report. Perform the following steps to run a Group Structure
report.

Prerequisites
You must have System Administrator responsibility.
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Steps

1.

10.

In the CRM Administrator responsibility, navigate to Resource Manager >
Others > Requests > Run.

The Submit a New Request window opens.

Select the Single Request option button and click OK.

The Submit Request window open.

Use the Name list of values (LOV) to select a report.

The Reports window opens.

Select Group Structure Report from the list of reports and click OK.
The Parameter window opens.

Select the group you want to run the report on from the list of values (LOV) and
click OK.

(Optional) Change the time frame the report runs by clicking Schedule.
The Schedule window opens.

Select the time frame when you want the report to run:

« Assoon as possible

« Once

« Periodically

« On specific days

Click OK.

(Optional) Click Options to determine who should be notified when the report
is complete and where you want to print the output.

Click Submit.

A dialog opens confirming your request was submitted.

5.1.14 Viewing a Group Structure Report

You can monitor the status of an audit report to see when it has been completed,
and if it completed successfully. Perform the following steps to view your Group
Structure report.
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Prerequisites
You must first run a Group Structure Report successfully.

Steps

1.

In the CRM Administrator responsibility, navigate to Resource Manager >
Others > Requests > View.

The Find Requests window opens.

Select the All My Requests option button.

Click Find.

The Requests window opens.

Select the Group Structure Report.

Click View Log to display the results of the report.

The report details opens in an HTML window along with a log file for the
report.

5.1.15 Creating an Employee Resource

When you create an employee resource, the information is recorded in human
resources. Perform the following steps to create an employee resource.

Prerequisites

You must have the Resource Self Service Administrator responsibility.

The JTFRS: Employee Update Access profile must be set to "None."

Steps
1. Log in asthe administrator.
2. The Employees window opens.
3. Click Create.
The Create An Employee Resource window opens.
4. Enter the employee’s last, first, and middle name in the specified fields.
5. Use the drop-down list to select the employee’s title, for example, Miss.
6. Enter a username for the new employee.
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7. Enter personal information for the employee:

a. Enter your work phone number in any format, for example 555.5555 or
555-5555.

b. Enter search criteria for your Job Title (at least three characters) and click
Go to search for matching titles.

The Select a Job Title window opens.
c. Click your job title to populate the field.
d. Enter your email address.

No validation is made to determine if the email address is correct or even
exists.

e. Enter your salesperson number.
f.  Use the drop-down list to select a sales credit type.

The category (Employee), employee number, and resource number are
automatically displayed.

8. Enter your location information.
a. Use the drop-down to select their work address.
b. Enter your mailstop.
c. Enter your office number.
d. Enter your office location.

9. Enter search criteria for your manager’s name (at least three character’s) and
click Go.

The Select a Manager window opens.
10. Click your Manager’s name to populate the field.
11. Click Create.

The employee resource is created.

5.1.16 Creating a Group

Perform the following steps to create an Group resource.
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Note: If the row contains a Remove check box, you can select the
check box and update the window to delete the record. If the row
contains a Remove icon, you can click it to clear the row.

Note: Only one parent record can be specified for a specific period
of time. However, several child records can be active at once.

Prerequisites

You must have the Resource Self Service Administrator responsibility.

The JTFRS: Group Update Access profile must be set to "None."

Steps
1. Log in asthe administrator.
2. The Employees window opens.
3. Click Groups on the main navigation bar.
The Groups window opens.
4. Click Create.
The Create Groups window opens.
5. Enter the Group name.
6. Enter a description for the group.
7. Enter an email address for the group.
No validation is made to determine if the email address is correct or even exists.
8. Enter the start (which defaults to the current date) and the end dates in the
specified field or click the Date Picker icon to select a date. The date format
must be in the following format: 28-Jul-2001.
9. Use the drop-down list to select the group usage.

10. Define the group membership information.

a. Use the drop-down list to select a resource category. Options include:
Employee, Other, Partner, Party, Supplier Contact, and To Be Hired.

b. Enter at least three characters or enter "%%%" to search all resources.
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The Select a Resource window opens.
c. Click the resource to populate the field.
d. Use the drop-down list to select a Role Type.
e. Enter at least three characters or enter "%%%" to search all roles.

The Select a Role window opens. The roles that appear in the window
correspond with the role type you selected. Check marks in the table cells
define role responsibility. If you select a role with the role type of Admin or
manager, the resource can edit their group hierarchy as well as the group
structure of the child groups of the parent group that they are a member.

f.  Click the role to populate the field.

g. Enter the start (which defaults to the current date) and the end dates in the
specified field or click the Date Picker icon to select a date. The date format
must be in the following format: 28-Jul-2001.

11. Click Create.

The Group Detail window opens with the new group information.

5.1.17 Setting System Profile Options

Resource Manager uses the following profile options.

Employee Update Status

Use the Employee Update Status profile option to set the security around updating
an employee’s information in the Resource Manager. If set to Self, only the
employee can update their own information. If set to Any, a system administrator
with the appropriate responsibilities is able to update an employees information.

Group Update Status

Use the Group Update Status profile option to set the security around updating a
Resource Group in the Resource Manager. If set to Self, only an employee of a group
can update their group information. If set to Any, a system administrator or
manager of a group can create and update all information under the group
hierarchy.
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5.2 Notes

5.2.1 Setting Up Note Types in Forms

Notes comes with a set of predefined note types. You can create additional
customized note types. You may also choose to not use the predefined note types
Perform the following steps to create new note types.

Note: To delete an existing note type, assign an end date to that
note type.

Prerequisite
You must have the CRM Administrator responsibility to perform this task.

Steps
1. Select CRM Administrator from the list of responsibilities.

The CRM Administrator Navigator opens.
2. Expand the Notes Setup node.
3. Select Note Type Setup.

The Application Object Library: Note Type Lookups window opens.
4. Define the code, meaning, and description as desired.

You only need to define a tag for a new, customized note type.

5. Chose File > Save to save your work.

5.2.2 Mapping Note Types to a Source in Forms

When you map a note type to a source object, you limit the visible note types for
that source to the defined subset of note types. Perform the following steps to map
note types to source code.

Prerequisite
You must have the CRM Administrator responsibility to perform this task.

Steps
1. Select the CRM Administrator from the list of responsibilities.
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The CRM Administrator Navigator opens.

Expand the Notes Setup node.

Select Source and Note Type Mapping.

The Mapping Objects window opens.

Place your cursor in the Source Obiject field and select File > New.
A new entry opens.

Select a source to map from the Source list of values (LOV).

Select a note type to map to it from the Note Type LOV.

Save this record when you have finished.

5.2.3 Setting Up the Source Object Code and Context in Forms

Notes provides predefined documents or source objects. When you define a new
document, you must associate Notes usage to the new document. On the Notes
form, the document name appears in the Source list. Each item in the Source list has
an associated related object, which appears in the Related To list. Perform the
following steps to define the source code usage as NOTES.

Prerequisite
You must have the CRM Administrator responsibility to perform this task.

Steps

1.

Select CRM Administrator from the list of responsibilities.
The CRM Administrator Navigator opens.

Expand the Task and Escalation Manager node.

Expand the Setup node.

Double-click Objects Meta-data.

The Tasks Setup: Object Type window opens.

Perform one of the following tasks:

a. If the source object code you want to seed already exists, then define the
usage as NOTES.
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b. If the source object code is not defined, then you must define the source
object code, the name, and select its details and usage. (Usage should be
NOTES.)

6. Choose File > Save to save your work.

5.2.4 Setting System Profile Options

The following profile option is used by Notes.

Default Note Status
The Default Note Status profile option sets the default note status.

5.3 Spreadtable

5.3.1 Creating a New Spreadtable

Use the Spreadtable Meta Data Administration window to design spreadtables that
plug into an Oracle Forms bean area container.

« A spreadtable is the user interface component that contains rows, columns, and
column headers set in a grid that can be embedded into an Oracle form.

» Oracle Forms-based CRM modules use the spreadtable to display and format
dynamically retrieved data at run time. This is accomplished by predefined
metadata definitions.

= Metadata is information that defines what data is retrieved at run time and how
that information is presented.

The following table describes the Spreadtable Meta Data Administration tabs.

Table 5-9 Spreadtable Meta Data Administration Tab Descriptions

Tab Description
Database Use to set column type and order, datatype, sequence, and default sort order.
Display Use to set column label, visibility, display sequence, and display width.

Alignment and Formatting | Use to set type of header and cell alignment, as well as display type and format.

Custom Format Masks and | Use to set how data displays. This applies only to columns with datatype of
Mappings Number. For example, it would display the values as a percent.
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Table 5-9 Spreadtable Meta Data Administration Tab Descriptions

Tab Description

Query Used exclusively by Universal Work Queue. It is for internal use only.

Sort Order Use to set the overall sort order of the columns for the spreadtable. For example,
you may set the primary sort order to be alphabetical based on column A, and
set a secondary sort order to be numerical based on column B.

Test Use to test the spreadtable that you are defining.

WARNING: Oracle does not support custom development of new
forms using the spreadtable interface.

Do not delete currently existing columns when modifying an existing
spreadtable. Instead, use the Freeze Visible State property in the Display
tab to make the column invisible to the user.

Do not delete any existing metadata definitions.

If you modify existing metadata definitions, these changes may be
overwritten by subsequent patches.

Perform the following steps to create a hew spreadtable.

Prerequisites
None

Steps
1. Inthe CRM Administrator responsibility, navigate to Spreadtable
Administration.

The Spreadtable Meta Data Administration window opens.
2. Define a new datasource (a set of metadata) by entering the following:

» Datasource Name: The unique name that identifies a set a metadata. It
must always be <Application Prefix>_<Name>.

= Application: The name of your product.
« Title: A descriptive name for this set of metadata.

» Relational View Name: Select from the LOVs the name of the view from
which information is to be retrieved to populate the spreadtable.
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Lines/Rows: Enter how many lines of text are to display per row.

WHERE Clause: (Optional) Enter a SQL statement here if desired. Use this
field to enter filtering criteria. NEVER start with the keyword WHERE, as
this is automatically prepended to the statement. Always use bindvariables
if the value changes at runtime.

3. Select the Database tab, if it is not already selected, and enter the following for
each column that you wish to display in the spreadtable:

Column Alias: The column alias becomes part of the primary key, therefore
it must be a unique name. For example, the names, "currency" and
"currency_code" will generate an error stating there is an ambiguous
column in SELECT list. Column alias hames cannot contain SQL reserved
words or an error generates stating the keyword was not found where
expected.

View Column/ Function: Select from the LOVs the desired name of the
View Column.

Datatype: Select from the LOVs either character, number, or date.

Query Sequence: The sequence value determines the order in which
columns are extracted from the database. You could start with 1, but in
actual practice, it is a good idea to leave gaps in the sequence for ease of
row insertion later. To improve performance, begin with the columns that
you will refer to in your code, typically the primary key columns to execute
a query in a detail block.

Sortable: Selecting this box allows the user to sort on this column.

Default Sort Order: Sort in ascending or descending default order.

4. Select the Display tab, and enter the following for each column that you defined
previously:

Visible: Select to make this column visible in the spreadtable.

Freeze Visible Property: Select if you want the end user to be able to
change the visible properties (show/hide) at run time for this column.

Display Sequence: The value determines the order in which the columns
display in the spreadtable.

Display Width: Sets the width (in pixels) of the displayed column. This
value depends on the data that is displayed in the column.
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« The Column Alias and Label fields are supplied automatically. However,
you may change these values, if desired.

Select the Alignment and Formatting tab, and enter the following:

« Header Alignment: Select from the LOVs either Center, End, Right, or Start.
« Cell Alignment: Select from the LOVs either Center, End, Right, or Start.

« Display Type: Select from the LOVs either check box, Hyperlink, or Text.

« Display Format: (Optional) Select from the LOVs either Currency, Date, or
Date Time.

Select the Custom Format Masks and Mappings tab.
» Column Alias: The column alias field is filled automatically.

» Check box Mappings: These options apply only if the display type field in
the Alignments and Formatting tab is set to check box.

*  Checked: Sets whether or not a column value is represented as a
checked check box or as its corresponding image.

*  Unchecked: Sets whether or not a column value is represented as an
unchecked check box or as its corresponding image.

*  Other: Sets how values other than those specified as either checked or
unchecked are represented.

» Format Mask: Use to set how columns with datatype Number display data.
For example, it would display the values as a percent. Use this only in rare
cases.

» Currency Column: Points to the database view column where the currency
code for the current column is stored. This applies only if the display format
is set to Currency.

Select the Sort Order tab, and perform the following:

» Choose the Primary Sort key from the LOVs.

= You can optionally select a second or third Sort key from the LOV.
Click the Save icon on the toolbar. (The icon looks like a floppy disk.)
Select the Test tab, and click Test.

Your table appears.

Implementation Tasks 5-29



Territory Manager

5.4 Territory Manager

5.4.1 Planning your Territories

Before using the Escalation Management module, you must analyze the territory
setup in your organization. This is typically done by a planning team comprised of
but not limited to: management, consultants, and other key players. You need
enterprise-wide cooperation and feedback and you must expect to make multiple
territory revisions in the first months of operation as your enterprise discovers
omitted information or territories that do not work on a day-to-day basis. The
following are the typical steps to follow in the planning process.

Steps
1. Review your existing territories.

You need the following types of information:

« How your territories are currently assigned (by state, by industry, by zip
code, by account, and so on)

« The names and current territory assignments for your sales or service
personnel

« The names of employees in other organizations who receive account, lead,
and opportunity information and how that information is accessed and
used

= Your products and how they are differentiated

2. Decide what qualifiers you want to use to assign to territories and create
territory types (optional) to restrict your territory restrictions.

Decide on the hierarchy of territories.
Decide if escalation territories are needed and how they fit in the hierarchy.

Decide what qualifier values to use for assigning territories.

o 0~ w

Identify any overlapping territories and decide the order in which the
application chooses them.

Rank any overlapping territories from 1 to n to determine the order. A territory
with a smaller rank wins over a territory with a higher rank. In case of a tie, the
assignment is made randomly:.
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7. Test the strategy before implementing territories throughout the company and
consider any future territory maintenance efforts.

Note: Remember that the first territory setup is not necessarily the
one that works best. You achieve optimum territory definition only
gradually after much fine-tuning to accommodate user reactions
and various interests in your organization.

In general, there is no limitation on territory creation. Create as many territories as
you want for your business. However, in considering the purpose of future territory
maintenance, for example, you need to modify territories due to sales, service, or
support people changes or relocations, as well as organizational changes. You need
to have a reasonable size of territories to minimize the efforts of territory
management.

5.4.2 Enabling Existing Qualifiers

Territory Manager has predefined qualifiers for:

« Defect Management

« Sales and Marketing

= Service

= Service Contracts

» Trade Management

Before using any of the transaction qualifier, you need to enable them.

Unlike the transaction qualifiers classified by the territory usage, resource qualifiers
are shared throughout the application regardless of territory usage except for
Service Contracts. Therefore, you do not need to enable them. Perform the
following steps to enable the existing transaction qualifiers.

Prerequisites
None

Steps

1. Inthe CRM Administrator responsibility, navigate to Territory Manager >
Territory Administration.
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The Navigator window opens.

Select Administration from the drop down menu and choose Setup Qualifiers.
The Setup Qualifier window opens.

Select the Usage drop-down list.

The Select Usage window opens.

Highlight your selection and click OK.

The Setup Qualifier window opens and the Usage Field is populated with your
selection.

Select Find.

You can also select appropriate qualifier status (Enabled, Disabled or All) before
finding them. Note that all resource qualifiers are not listed here.

Check (or uncheck) the targeted qualifiers and select Update Qualifiers.

5.4.3 Creating Individual Territories

Perform the following steps to create individual territories with or without using
territory types:

1.

2
3
4.
5

Create territory overview information with the Overview tab.

Select transaction qualifiers using the Transaction Qualifiers tab.
(Optional) Select resource qualifiers using the Resource Qualifiers tab.
Select resources using the Resources tab.

(Optional) Create subterritories using the Subterritories tab.

Prerequisites
There must be a territory plan in place.

Steps

1.

From the CRM Administrator responsibility, select Territory Manager >
Territory Administration.

Select Define Territory from the Administration pull-down menu.

The Territory Details window opens.
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Note: You can also use the Select the Territory from the Tree
Navigator that serves as a parent to the new territory and
right-click to select New from the pop-up menu.

Select the Overview tab.

a.

Use the list of values (LOV) in the Usage field to select the type of
application you want to use in this territory. Your selection limits the types
of qualifiers that can be used in the territory definition.

Enter a name and description for the territory.

To limit the time the territory is effective, enter the Start and End Dates. By
default the territory become effective on the date that you create it.

(Optional) Verify that the parent territory is the territory you selected in the
Navigator. If this is not the parent territory, then use the LOV to select the
appropriate parent territory.

(Optional) If you have created an escalation territory for this territory, then
enter it using the LOV in the Escalation field.

(Optional) If you want to use an existing territory type to create this
territory, then use the LOV to enter it in the Type field.

WARNING: If you use a territory type, then you are restricted to
using the qualifiers set up in that territory type.

Use the Transaction Types LOV to select one or more types of transactions
based on the territory usage. Available values include account, lead,
opportunity, and service request. Note that some application types allow
you only one transaction type.
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WARNING: Be cautious while using the freeze check box. It is
suggested that you leave this freeze box unchecked at all times
unless it is necessary. You cannot undo changes once the freeze
box is checked.

4. Select the Transaction Qualifiers tab.

a.

e.

(Optional) If this territory is part of a hierarchy of territories, then click
Show Inherited Qualifiers to examine which qualifiers this territory has
inherited from its parent territory or territories.

(Optional) If you have used a territory type to create this territory then the
qualifiers are already prefilled.

If you are creating a new territory without a territory type, enter the
qualifiers you are going to use in the Transaction Qualifiers region.

If you want to enter overlapping values for a qualifier, then check the
Overlap Allowed check box.

Enter the values and operators for each qualifier.

5. (Optional) Select the Resource Qualifiers tab.

a.

Use the LOV in the Name field to choose the type of resources for the
territory.

Use the LOV in the Operator field and Value field to make the appropriate
selections.

Note: Use Mass Create Templates only when creating territories
with a territory template. Specify the template name in the
Overview tab before clicking this button.

6. Select the Resources tab.

a.
b.
C.

d.

Select the resources for the territory using the LOV in the Name field.
Enter the Group level from the LOV in the Group field.

Enter Role from the LOV in the Role field.

Select Access Type from the LOV in the Access Type field.

7. (Optional) Select the Subterritories tab.
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Use this tab if your territory hierarchy includes territories below the current
territory.

a. Click New Subterritory and repeat the territory creation procedure for the
new sub-territory.

b. Click Save from the menu.

5.4.4 Using the Territory Details Window

Use the Territory Details window to perform the following.
« Create Territories
« Create Escalation Territories

« Create Territory Templates

5.4.5 Creating Territory Types

Perform the following steps to create territory types.

Prerequisites
« There must be a territory plan in place.

= You must enable your qualifiers.

Steps
1. From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The territory tree Navigator window opens.
2. From the Administration menu, select Create Territory Type.
The Territory Type window opens.
3. Ifasimilar territory type already exists, then you can save time by copying it.
a. Search for a similar territory type.
b. Ifasimilar territory type is found, then click Copy Type.

The application creates a copy of the existing territory type that can be
modified.
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In the Usage field, use the list of values (LOV) to select the type of application
using this territory type.

Enter a name for the territory type and a description.
Enter a date range to limit the use of the territory type by date.

Use the LOV to select one or more transaction qualifiers based on the territory
usage field.

Click OK to save your work and exit.

5.4.6 Selecting the Resources for a Territory
Perform the following steps to select the resources to staff a territory.

Note: It is not mandatory to enter resource qualifier information if
you know exactly which resources you want to use in a territory.

Prerequisites

The Territory Details window is active with the territory you want to staff
displayed.

Steps

1.

From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The territory tree Navigator window opens.

Navigate to the chosen territory and double-click the territory.
The Territory Details window opens.

Select the Resource Qualifiers tab.

a. Inthe Name fields of the Resource Qualifier region, use the LOV to enter
the qualifiers related to the skill set of the employees assigned to this
territory.

b. Enter the values for each qualifier.

Select the Resources tab.
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h.

Use the list of values (LOV) to enter the resources in the Name fields if you
want to assign them to this territory or you have a small pool of people to
work with.

If you do not know the people you want assigned to this territory and have
a large pool of potential names, then click Auto Assign Resources.

The Qualifying Resources window displays a list of people that fit the
resource qualifiers values you have entered.

If no people or the wrong people are found, then go back to the Resource
Quialifiers tab and enter a different set of resource qualifier values, or select
resources manually in the Resources tab.

Select the people you want to assign to this territory by checking the Assign
check box next to their name.

Click OK when you are finished.

Check the Primary Contact check box next to the name of the person
designated to become the primary contact for the territory.

For each resource you can add a Start and End Date to limit their
participation.

For each resource, enter the transactions you want them to access.

For example, you want some resources to access account and contact
information, but not lead information.

To enter access for an individual select the resource in the Resources region.

Select the access type in the Access region below.

5. Click Save on the toolbar.

5.4.7 Creating Escalation Territories

Perform the following steps to create escalation territories. Escalation Territories are
alternate territories in which transactions such as a service call are automatically
reassigned when certain conditions are not met. Escalation Territories define the
resources that handle the escalations.

Prerequisites
There must be a territory plan in place.

Implementation Tasks 5-37



Territory Manager

Steps

1.

From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The territory tree Navigator window opens.
From the Administration menu, select Escalation Territories.
The Escalation Territory Details window appears.

In the Overview tab, use the list of values (LOV) in the Usage field to select the
type of application you want to use in this territory. Your selection limits the
types of qualifiers used in the territory definition.

Enter a name and description for the territory.

Enter the Start and End Dates to limit the time the territory is effective.
By default the territory become effective on the date created.

Select the resource qualifier for the escalation territory

Click Save on the toolbar.

5.4.8 Entering Qualifier Values

Perform the following steps to enter qualifier values while creating individual
territories. You cannot use this procedure for entering qualifier values in territory
templates.

Prerequisites
The Transaction Qualifiers or Resource Qualifiers tab is selected.

Steps

1.

From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The territory tree Navigator window opens.

Navigate to the chosen territory and double-click the territory.
The Territory Details window opens.

Select either the Transaction Qualifiers or Resource Qualifiers tab.

Select the qualifier in the Qualifiers region.
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You will see the possible value types. For example, if you are entering values for
the Customer Name qualifier used in Sales applications, then enter a value.

Select an operator using the list of values (LOV).

The list of operators varies depending on the type of qualifier selected. For
example, some qualifiers allow only the "=" symbol.

Enter the values in the appropriate fields.

Some operators limit the range of values. The field names change depending on
the qualifier.

5.4.9 Copying an Entire Territory Hierarchy

Perform the following steps to copy an entire territory including all the
subterritories (children.)

Prerequisites
You must first have a territory that you want to duplicate.

Steps

1.

© © N o O

From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The Territory Tree Navigator window opens.

Navigate to the chosen parent territory and double-click the territory.
The Territory Details window opens.

In the Overview tab, click the Copy Territory button.

The Copy Territory window opens.

Select the Copy Hierarchy check box if you want to copy the entire territory
hierarchy.

In the Assignee area, enter a new name and description.
(Optional) Enter a new rank.

(Optional) Enter a new start and end date.

Save your work.

Verify your new territory by refreshing the tree.
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Note: The names of the new child territories are the same as the
originals. You must open each one individually to make any
changes.

5.4.10 Using a Template to Create a Large Number of Territories

Perform the following steps to create a territory template that automates the process
of creating a large number of territories. After you create the territories, then open
up each individual territory and select the resources you want assigned to each
territory. The following procedure consists of two separate tasks:

« Creating a template

» Creating a large number of territories from that template

5.4.11 Creating a Template

Prerequisites

« If you want to use territory types to create territories, then create the territory
types first.

« There must be a territory plan in place.

Steps

1. From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The territory tree Navigator window opens.

2. Inthe Navigator, select the territory that serves as a parent to the new territory.
If this is the first territory you are creating, then select Catch All.

3. Right-click and select New from the drop-down menu.
The Template Territory Details window appears.

If you selected an existing territory as the parent, then the Usage and Parent
fields are pre-filled. If Catch All is the parent territory, then use the list of values
(LOV) in the Usage field to select the type of application you want to use for
this territory. Your selection limits the types of transaction qualifiers you can
use in the territory definition.

4. In Transaction Types fields, use the LOV to enter one or more transactions.
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You can create territories for a variety of transactions. These include account,
lead, opportunity, and service request. CRM applications restrict the types of
transactions that can be used for territory creation. For example, you cannot
create a territory for leads for a service application.

If you want to use an existing territory type to create this territory template,
then use the LOV to enter it in the Type field.

If you use a territory type, then you are restricted to using the qualifiers set up
in the territory type.

Select the Transaction Qualifiers tab.
a. Usethe LOV to enter the qualifiers in Qualifier Type.

If you are using a territory type to create the territory template, then some
of the Qualifier names are already prefilled.

b. Select either Static or Dynamic from the Qualifier Mode drop-down list for
each qualifier.

c. Enter values for each transaction qualifier.
d. Select the qualifier in the Transaction Qualifiers region.
e. If the qualifier you have selected is a static qualifier, then enter the values.

f.  If the qualifier is a dynamic qualifier, then enter the values or value sets,
clicking Next Value Set between each entry or set of entries.

g. Ifyou do not want to add resource qualifiers for this template, then go
directly to the Creating Mass Territories step.

(Optional) Select the Resource Qualifiers tab.
a. Use the list of values (LOV) to enter the qualifiers in the Name fields.

b. Select either Static or Dynamic from the Mode drop-down list for each
qualifier.

c. Enter values for each resource qualifier:
*  Select the qualifier.
* If the qualifier selected is a static qualifier, then enter the values.

* If the qualifier is a dynamic qualifier, then enter the values or value sets,
clicking Next Value Set between each entry or set of entries.

Save your work.
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5.4.12 Creating Mass Territories with a Template

Prerequisites
= You must have created a template.

« There must be a territory plan in place.

Steps
1. From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The territory tree Navigator window opens.

2. Navigate to the chosen territory and double-click the territory.
The Territory Details window opens.

3. Open the Transaction Qualifier tab or the Resource Qualifier tab.
The chosen tab window opens.

4. Click Mass Create Territories.
The system creates territories with generated names in the form:

<template name> - GENERATED TERRITORY #<number>

For example, the territory template named "US Time Zones" generates three
territories with the following names:

— US Time Zones - GENERATED TERRITORY #1
— US Time Zones - GENERATED TERRITORY #2
— US Time Zones - GENERATED TERRITORY #3

5.4.13 Entering Static Qualifier Values for Templates

Perform the following steps while creating territory templates to enter values for
static qualifiers. Static qualifiers values exist in all the territories you are mass
creating.

Prerequisites
Perform the following steps as you create territory templates.
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Steps
1. Open the Transaction Qualifier tab or the Resource Qualifier tab.

The chosen tab window opens.
2. Select the name of the qualifier at the top of the window.
The possible value types appear below.

For example, if you are entering values for the Name of Customer transaction
qualifier, then you can enter one value: the name of the customer.

If you are entering values for the Interest Type qualifier used in sales
applications, then you can enter three values: for the interest type, for the
primary and for the secondary interest.

Resource Qualifiers can consist of static qualifiers.
3. Use the Operator list of values (LOV) to select an operator.

The list of operators varies depending on the type of qualifier used. Some
gualifiers, such as Name of Customer, allow only the "=" or "<>" operators.

4. Enter the values in the fields provided. Some operators allow a range of values
to be entered; others only a single value.

The number of fields and field names change depending on the qualifier.

5.4.14 Entering Dynamic Qualifier Values for Templates

Perform the following steps while creating territory templates to enter values for
dynamic qualifiers. Dynamic qualifiers have a different value in each territory
created. Both transaction qualifiers and resource qualifiers are shown in the
following steps.

Prerequisites
Perform the following steps as you create territory templates.

Steps
1. Choose the Transaction Qualifier tab or the Resource Qualifier tab.

The selected tab window opens.

2. Choose the name of the qualifier at the top of the window.
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For example, if you are entering Customer Name as the transaction qualifier,
then you can enter only one value: the name of the customer.

If you are entering values for the Language Type resource qualifier used in sales
applications, then you can enter two values: English and French.

Use the Operator list of values (LOV) to select an operator.

The list of operators varies depending on the type of qualifier used. Some
qualifiers, such as Name of Customer, allow only the "=" or "<>" operators.

Enter the value(s) in the fields provided. Some operators allow you to enter a
range of values; others only a single value.

The number of fields and field names change depending on the qualifier.
Click Next Value Set.

A new entry line opens.

Enter the next value or set of values in the same manner.

Repeat this procedure for all the values for this qualifier.

Each time you click Next, the Value Set number increases by one.

For example, if you want to enter all the states of the United States as values for
the dynamic qualifier State, then:

a. Enter the first state in the Value field and click Next.
You can manually enter "1" in the Value Set field.

b. Enter the second state in the Value field and click Next.
You can manually enter "2" in the Value Set field.

c. Repeat the procedure for each of the remaining states.

When you have entered all of the values, complete the procedure for creating
territory templates.

5.4.15 Creating Customer Name Range Groups

The Customer Name Range Group allows you to create a new group, or modify or
delete an existing group name. Deletion can only occur when it has not been
associated with Customer Name Range transaction qualifier value.
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Note: The Customer Name Range Group applies only to Sales
and Telesales. It has a customer name range transaction qualifier
associated with it which is of account type.

Perform the following steps to create a hew group.

Prerequisites
None

Steps

1. From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The Navigator window opens.

2. Select Define Customer Name Range Group from the Administration drop
down menu.

The Define Customer Name Range Group window opens.
3. Enter a name and description in the appropriate fields.
4. Select an Operator from the list of values (LOV).
5. Enter your criteria in the Value From field.
If the Operator is "BETWEEN", then you must fill in the Value To field.
6. Enter the Value From field and Value To field when the operator is BETWEEN.
Repeat the process for any other detail records you want to add.
7. Save your work.
Now that it has been defined, you can use it to create or modify a territory.
8. Either create a new Sales and Telesales Territory or open an existing one.

The Territory Details window opens.

Note: An Account Transaction Type must exist.

9. Select the Transaction Qualifier tab.
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« Inthe Name field, select the LOV list. The Select Transaction Qualifiers
window opens. Select Customer Name Range and click OK.

« Inthe Operator field, the default is "=".
« Inthe Group field, select your Customer Name Range group from the LOV.
« Inthe Value From field, enter all applicable customer names.

10. Save your work.

5.4.16 Creating Mass Change Territory Resources

Use Mass Change Territory Resource to add or replace resources assigned to
territories. An example of using this would be if salesperson A was leaving the
company and wanted to transfer his territories to the incoming salesperson B.
Perform the following steps to make mass changes in Territory Resources.

Prerequisites
None

Steps

1. From CRM Administrator responsibility, select Territory Manager > Territory
Administration.

The Navigator window opens.

2. Select Mass Change Territory Resources from the Administration drop down
menu.

The Mass Change Territory Resource window opens.

3. Inthe Resource field in the Find Territories region, select from the List of Values
(LOV).

If the resource field is left blank and you click Find, then a list of all the
territories that do not have any resources attached appears.

4. Click Find to find all territories assigned to that resource.
5. Inthe Operation region select either the Replace or Add button.
6. Inthe Scope region, Click either the All or Selected button.
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Note: If you choose to select certain resources, hold down the
control key on your keyboard as you use your mouse to select.

7. Inthe Resource field in the Assignee region, select the new resource from the

LOV and click OK.

8. (Optional) Select a start and end date. The default is the current date.

9. Select Update Territories to save.

Note: Resources that have territories "replaced" are not associated
with these territories again.

5.4.17 Running Concurrent Programs

After defining territories using the Escalation Management, you must run the
Generate Territory Package concurrent program. This builds the Territory
Assignment Engine. After the concurrent program runs successfully, the Escalation
Management module is automatically updated. Run this program every time a
territory is added or changed. The following table describes the function of the

seeded Concurrent program.

Table 5-10 Seeded Concurrent Programs

Name

Function

Generate Territory Packages

Builds the API that returns the winning
territories, which are defined in territory setup.

Returns the winning territories and resources.

Creates search index for faster performance.

Prerequisites
None

Steps

1. From the CRM Administrator responsibility, select Requests > Run.

2. Select the Single Request.
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3. Inthe Parameters pop-up window of the Submit Request, select each
transaction type in the Qualifier Type field that you defined in your territories,
one at a time, based on the territory usage.

For example, if you created a territory with two transaction types, Task and
Service Request, then run Task as well as Service Request each time in the
Parameter window.

4. Use the Schedule button in the Submit Request window to run concurrent
programs periodically.

5.5 Assignment Manager

5.5.1 Setting System Profile Options

Use the following list to identify the profile options that you need to set for your
specific implementation. You can set these options in any sequence.

» Activate Auto Selection of Resources

« Activate Contracts Preferred Resources

« Activate Installed Based Preferred Resources
« Activate Workflow Name

To change profile options, use the standard procedure outlined in the Oracle
Applications Users Guide.

Profile Option Activate Auto Selection of Resources

The profile option Auto Selection of Resources is set to activate the auto-selection of
resources by the Assignment Manager engine. The Assignment Manager engine
uses this profile option setting to determine whether the user needs to make a
selection from the provided list of resources, or if this task is performed
automatically by the Assignment Manager engine itself.

Profile Option Activate Contracts Preferred Resources

The profile option Activate Contracts Preferred Resources is set to retrieve the
preferred resource information from the Contracts module. The Assignment
Manager engine uses this profile option setting to determine whether the Contracts
Preferred Engineers are picked automatically by the Assignment Manager engine or
not. If you set this profile option to No, (default value) it will uncheck the Contracts
in the Assignment Manager.
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Profile Option Activate Installed Based Preferred Resources

The profile option Activate Installed Based Preferred Resources is set to retrieve the
preferred resource information from the Installed Base module. The Assignment
Manager engine uses this profile option setting to determine whether the Installed
Base Preferred Engineers are picked automatically by the Assignment Manager
engine or not. If you set this profile option to No, (default value) it will uncheck
Territories in the Assignment Manager.

Profile Option Activate Workflow Name

The profile option Activate Workflow Name is set to a user-defined workflow
procedure name. This workflow procedure is user-programmed code for further
filtering the resources. The Assignment Manager engine retrieves the procedure
name from this profile option and uses it to process the user’s request.

5.5.2 Setting Up the TCF Servers for Gantt

5.5.2.1 What is a Gantt Chart?

A Gantt chart displays tasks or some other time bound entities in relation to their
owners and assignees. As such, it is typically used for scheduling purposes, where a
manager can view the team’s current workload and make real-time decisions on
who should be assigned a new task, or alternatively, make adjustments and reassign
tasks between members of the team.

Gantt charts are used by the following CRM modules:
« Field Service (Control Tower)
« Assignment Manager

The Gantt chart is designed as a Java Bean that can be plugged into any Oracle
Forms-based application.

5.5.2.2 Whatis TCF?

TCF is the acronym for Thin Client Framework. The Thin Client Framework server
is a middle tier process that enables certain Java components of the Oracle
Applications user interface to communicate with the middle tier and database tier.
Within CRM, these components are:

= Field Service Scheduler

« JTF Gantt Chart

Implementation Tasks 5-49



Assignment Manager

« JTF Assignment Manager

The TCF server process should always be running in a production installation.

The SocketServer Class

The TCF server uses the SocketServer class (in the oracle.apps.fnd.tcf package) to
handle incoming connections. Administration of the TCF server is typically handled
through the ServerControl class (in the same package), which basically provides a
clean interface around all the different TCF server functions that an administrator
might perform (for example, starting, stopping, updating, and other similar tasks).
Oracle recommends using the ServerControl class for most purposes.

Note: The order and list of parameters for the ServerControl class,
and the SocketServer class are not the same. Refer to the
Administering the TCF Server (11i) documentation for a complete list.
You can access this document on Metalink (Note 123689.1).

Proxy Objects and Dispatchers
TCF comprises the following:
« A pair of Dispatcher classes which own the network connection

= Aninterface called Proxy which enables an object to use the TCF network
connection

= An Item class which serializes data for transmission

Generally, the client application or applet creates a number of Proxy objects at the
same time, then asks the Dispatchers to connect these objects to peer objects on the
middle tier.

« Proxies are implemented in pairs, one for the client, and one for the middle tier.

» The Dispatchers maintain a list of connected proxy pairs and handles the
routing of messages.

« Proxies communicate by writing messages to a buffer maintained by a
Dispatcher, and then instructing the Dispatcher to send these messages.

= Several proxies can share a round trip by waiting to call "send" until after each
has had an opportunity to write its messages.

» The Dispatchers deliver these messages by invoking the readltem method of
Proxy.
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5.5.2.3 Configuring the TCF Servers

WARNING: These instructions for implementing the TCF servers
are NOT valid if the AOL TCF Server patch (bug # 1699404) has
been installed.

This patch is owned by the Oracle Applications Object Library
(AOL). Contact AOL support for issues with this patch.

Gantt charts are used extensively by the various modules of the Oracle E-Business
Suite. However, for a Gantt chart to display and render properly, the TCF server
must be running and correctly configured.

The following tables describes the configuration steps that you must perform in
setting up and configuring the TCF server.

Table 5-11 TCF Configuration Steps

Step | Description

1. Apply any necessary patches.

2 Perform the necessary post-install steps.
3 Configure the servers.

4. Verify the server configuration.

5 Troubleshoot any problems that arise.

Step 5, troubleshooting problems that might arise with the TCF server configuration
and setup is covered extensively in Troubleshooting the TCF Servers.

5.5.2.4 Step 1: Installing any Required Patches

The first step in setting up and configuring the TCF server is to install any patches
that are necessary for the correct performance of your particular system.

Patch 135908

You must apply patch 135908 if you have set up the Oracle Applications to use
HTTP protocol for communicating between a client browser and Oracle Forms and
TCF servers.
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135908 HTTP mode fails with: "java.io.|OException: Invalid HTTP Packet
received" when using TCF APIs.

Patch 1473057
You must apply patch 1473067 if you created the database using a non-US7ASCII
and non-WE8ISO8859P1 character set.

1473057 NLS enabled JDBC drivers. This is required for non-US7ASCII and
non-WE8ISO8859P1 character sets.

5.5.2.5 Step 2: Performing Post Install Steps

There are several post install steps that you need to perform after installing the
patches listed in Step 1:Installing any Required Patches. These steps are described in
this section.

WARNING: If you have installed the TCF server on an IBM AIX
machine, then you MUST perform the steps listed in the AIX Port
Instructions section.

Post Install Steps

The patches described in section Step 1: Installing any Required Patches contain
both client and midtier Java code. After applying any of these patches, perform the
following steps:

1. Stop and start the TCF server.

The TCF server does not pick up the latest code until it is bounced.
2. Close the browsers on the client machines.
3. Clear out the Jinitiator jcache directory on the client machines.

4. Restart the client browsers. You must do this to force the regenerated JAR files
to be downloaded after you apply the patch.

AIX Port Instructions

If the TCF server is installed on an IBM AlX machine, then you must also do the
following:

1. Perform the port specific instructions provided in the JDBC 8.1.6 Release notes.
These Release Notes can be found on Metalink, note 114464.1.
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In addition to the environment variables specified in the JDBC release notes,
you must update adovars.env with the following environment variable:

<JAVA COMVP LER>
set to:
<NONE>

Omitting this step causes the problem described in bug 1510941 to occur,
thereby causing the Gantt chart to fail.

2. Shut down the TCF server and restart it to force the changes to take effect.

5.5.2.6 Step 3: Configuring the Servers

WARNING: Setting the communication protocol correctly is
extremely critical. If this step is performed incorrectly, the
client/server communication will not work.

In order for the TCF server and client to establish a connection over the network,
you should set up the following using the same communication protocol.

« Formsservers
« File appsweb.cfg
« TCFservers

The following table lists the valid communication protocols that you can use in
setting up and starting the Forms and TCF servers.

Communication Protocols

Forms Mode TCF Protocol
http HTTP

https SSL

socket SOCKETS

Forms Servers

If starting the Forms server from the command line (on UNIX), then you must
include the Forms "mode" argument:
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fe0ctl { start | stop } port=port_num pool =pool _num| og=l og_file
node={ htt p| htt ps| socket} exe=exe_nane

Valid Forms modes are:

« http
« https
= socket

File appsweb.cfg

Modify the appsweb.cfg file (usually found under $APPL_TOP/html/bin) so that it
includes the following:

connect Mbde=<pr ot ocol >

The connect mode parameter must indicate the same protocol as that which you set
for the Forms server. Again, valid protocols are:

« http
« https
= socket

TCF Servers

Configure the TCF servers to start and run in the same communication protocol
mode as that which you set for the Forms servers and indicated in the appsweb.cfg
file.

Configuring the TCF Server Protocol

For details on configuring TCF servers, refer to the Administering the TCF Server (11i)
documentation for a complete list of the configuration settings. It is available on
Metalink (Note 123689.1).

Starting the TCF Servers

Note: Oracle Applications provides a script to start and stop a
TCF server. Refer to the Installing Oracle Applications guide, section
"Review Server Process Control Scripts” for the name and location
of this file.
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Start the TCF server from the command line (on UNIX) using the following
arguments:

jre oracl e.apps.fnd.tcf. ServerControl [START| STGP STATUS| UPDATE]
<por t nunber | def aul t =10021> [ <par an¥val ue>]

Valid parameters are listed and described in the previously mentioned
Administering the TCF Server (11i) documentation.

Note the following:

1. Oracle strongly recommends that you start the TCF server with the PROTOCOL
parameter set to the same value that you set for the Forms mode argument, as
described in the Forms Servers section.

2. The DBC file parameter is required.

3. Atserver start up, the TCF:HOST and TCF:PORT profile options are updated
with the information passed into ServerControl.

a. Ifthe TCF server is started using HTTP protocol, then the TCF:HOST
profile is prefixed with "http://".

b. Ifthe TCF server is started using SOCKETS protocol, then the TCF:HOST
profile is set without the "http://" prefix.

5.5.2.7 Verifying the Server Configurations

The following table lists the steps involved in verifying that the servers are
configured correctly.

Table 5-12 Steps to Verify Server Configuration

Step Action

4a. Verify that the mandatory setup steps were performed correctly.
4b. Verify the TCF Host Name and Port Number.

4c. Verify the TCF connection.

4d. Verify that resources exist in the system.

de. Verify that the Assignment Manager is set up correctly.

Each of these steps is described in detail in the following sections.

Implementation Tasks 5-55



Assignment Manager

Step 4a: Verify Mandatory Setups
Verify that you have correctly performed all the steps listed in the previous sections:

« Step 1: Installing any Required Patches
« Step 2: Performing the Post Install Steps
« Step 3: Configuring the Servers

If necessary, repeat any steps that were not performed correctly.

Step 4b: Verify TCF Host Name and Port Number

Perform the following steps to verify that the TCF host name and port number have
been set correctly.

1. Log into your Personal Home Page (PHP) and select the System Administrator
responsibility.

2. Inthe Navigator, select Application > Menu.
The Menus window opens.

3. Select Diagnostics > Examine from the Help menu.
A password protect dialog box opens.

4. Enter a valid password.

If necessary, contact your system administrator for a valid password. After the
password is authenticated, the Examine Field and Variable Values window
opens.

5. Enter the following search parameters:
= Block: $SPROFILESS
« Field: TCF:HOST
The Value field should now display the host name of the TCF server.

a. Ifthe TCF server is started using HTTP protocol, then the host name must
be prefixed with "http://." If this is not the case, then one of the following
has occurred:

— The TCF server was not started in HTTP mode.

— The SocketServer class was used instead of ServerControl class to start the
TCF server.
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— The system level TCF:HOST profile has been overridden at the application
or user level.

— The system level TCF:HOST profile has been manually changed on the
system level.

b. Ifthe TCF server is started using the SOCKETS protocol, then the host
name must not be prefixed with "http://."

If the ServerControl class (not the SocketServer class) is used to start the TCF
server, then it automatically sets the system level profile options. These profile
option values can also be set manually at the system/application/user level in
Forms through the Profile menu, using the System Administrator responsibility.

WARNING: Exercise extreme caution if you manually change
these values. Setting these values incorrectly may cause the
Oracle Applications client code to not be able to establish a
connection to the TCF server.

6. Perform a new search, changing the value of Field to TCF:PORT.

The Value field should reflect the number of the port on which the TCF was
started.

Step 4c: Verify the TCF Connection

Using the Menu Tree Viewer, perform the following steps to verify that the TCF
connection is working properly:

1. Log onto your Personal Home Page (PHP), if you are not already there, and
select the Application Developer responsibility.

2. Select Application > Menu.
3. Query up the JTF_NAVIGATE Menu item.
a. Select View > Query by Example > Enter.
b. Enter JTF_NAVIGATE in the Menu field.
c. Select View > Query by Example > Run.
The Menus window populates with the information.

4. Click View Tree.
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You should see a tree like structure that corresponds to the Navigator hierarchy
for the CRM Administrator responsibility.

Step 4d: Verify Resources Exist
Perform the following to verify that resources are available in the system.

Note: Refer to the Oracle CRM Application Foundation Concepts and
Procedures, and the Oracle CRM Application Foundation
Implementation Guide for details on setting up and configuring the
Resource Manager.

Log on as the APPS user using SQL*Plus and run the following SQL statement. This
returns resources that you can use to query in the Assignment Manager: UnAssisted
mode:

SHECT jtf_task utl.get_owner(r.resource_type ,r.resource_id)
r esour ce_nane

,r.resource id

,r.resource_type

,0.name -- This is a descriptive nane of the resource type
FRCM ( sel ect resource_id

, decode( cat egory, ' EMPLOYEE , ' RS BEMPLOYEE

," PARTNER ,’ RS_PARTNER

, " SUPPLI ER OQONTACT , ’ RS_SUPPLI ER

,"PARTY ,’ RS_PARTY

,"OTHER ," RS_OTHER ) resource_type
FROMjtf_rs_resource_extns) r

,jtf_objects vl o

,jtf_object _usages u
WHERE r.resource_type = o.object_code
AND 0. obj ect _code = u. obj ect _cod
AND u. obj ect _user_code = ' RESORCES ;

The result of running this query is a list of the defined resources that you can use to
verify that the Gantt chart is set up correctly.

Step 4e: Verify the Assignment Manager Setup

Perform the following steps to verify that all the installation and setup steps for the
Oracle CRM Application Foundation Assighment Manager have been performed
correctly.
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Note: Refer to the Oracle CRM Application Foundation Concepts and
Procedures, and the Oracle CRM Application Foundation
Implementation Guide for details on setting up and configuring the
Assignment Manager.

Log onto your Personal Home Page (PHP) and select the CRM Administrator
responsibility.

In the Navigator menu, select Task and Escalation Manager > Manage
Escalations.

Enter sample text into the Escalation Summary field.
Click Assign.

The Assignment Manager window opens.

Select the UnAssisted option button.

In the Resource Partial Name field, enter the first few letters from one of the
names returned by the SQL statement in the previous section (Step 4d: Verify
Resources Exist) and suffix the name with a percent "%" character.

Click Search.

» Ifthe Gantt and TCF servers are working and have been set up correctly,
then you will see the resource name at the left side of the Gantt chart. If the
Calendar is defined correctly, then you also see Shifts (yellow background
color) and Tasks (blue and red bars).

For a task to be visible, it must exist, and have a scheduled start date and
end date that fall within the visible time range, and be assigned to a
resource.

« Ifan"APP-JTF-210807: No Resources Found. Please Try Again." message is
returned, then you have entered a name that does not exist, or alternatively
there may be a problem in Assignment Manager.

« If nothing is returned, check the Jinitiator Console Window for exceptions.
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5.6 Task Manager

5.6.1 Defining Task Status

Limit the user’s choices of task status by defining the list of status options and
determining the employee type that has access to each status type. When you
provide a LOV for the Task Status field, task creators choose from a pre-defined
template of status options. Use this procedure to define types of task status for your
users.

Prerequisites

None

Steps

1. Inthe Tasks window, click Navigator on the Task toolbar.

2. Inthe Task Manager Navigator, double-click Setup to expand the node.

3. Select Task Status and click Open.
The Task Status window opens.

4. Define a type name and enter it in the Status field.

5. Enter a brief description of the status type in the Description field.

6. Enter the effective dates in the From and To fields.

7. Select task status flags.
For a detailed description of flag options, see the Task Status Flag Definitions
table in the References section.

8. Optionally, define transition values that determine the user privilege for each

status type.
Use this procedure to define transition values.
a. Click Define Transition.

The Status Transition window opens.

b. Inthe Rules tab, enter a name for the user privilege relationship in the Rule
Name field.

c. Enter an initial and final status type for the user.
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Use the initial and final status values to determine the user’s range for
selecting task status.

d. Inthe Responsibility tab, enter the pre-determined rule name.

e. Enter a user type in Responsibility Name field and click OK.

A transition value stipulating user status privilege now exists.

9. Save your task status type.

The new task status and corresponding privileges register as lists of values for
their fields in the application.

References

The following table defines each task status flag.

Table 5-13 Task Status Flag Definitions

Flag Description

Assigned Assigned to an individual

Working In progress

Schedulable Scheduled or re-schedulable

Accepted Accepted by owner

Rejected Rejected by owner

On Hold Temporarily not active

Approved Approved by management

Completed Completed by owner

Cancelled Cancelled by owner, creator, or
management

Delete Delete acceptable without cancellation

Allowed

Closed Completed and closed

Seeded Pre-defined task status
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5.6.2 Determining Task Priority

Determine task priority by choosing terms for varying levels of priority and setting
an importance rating that corresponds with each term. Use this procedure to
determine task priority for your users.

Prerequisites
None

Steps
1. Inthe Tasks window, click Navigator on the Task toolbar.

2. Inthe Task Manager Navigator, double-click Setup to expand the node.
3. Select Task Priority and click OK.
The Task Priority window opens.
4. Define a name and enter it in the Priority field.
5. Enter a numerical value in the Importance field.
Choose an importance value from a larger defined scale of priority.
Enter a brief description of the priority value.
Enter the effective dates in the From and To fields.

Select Seeded to restrict the edit of task priority from future users.

© © N o

Save your task type.

The new task priority registers as a lists of value for the Priority field in the
application.

5.6.3 Defining Task Types

You can configure Task Manager to limit the user’s selection of task types. When
you provide a LOV for the Task Type field, the task creators cannot enter an
incorrect value. Instead they choose from a pre-defined menu of task options. Use
this procedure to define task types.

Prerequisites
None
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Steps

1.
2.
3.

10.

11.

In the Tasks window, click Navigator on the Task toolbar.

In the Task Manager Navigator, double-click Setup to expand the node.
Select Task Types and click OK.

The Task Types window opens.

Define a name and enter it in the Type field.

Select from the LOV in the Workflow field.

The corresponding workflow path information populates the Task Workflow
and Description fields.

Enter the effective dates in the From and To fields.

Enter a unit of measurement for effort in the UOM field.
Use a measure of time to determine the UOM value.
Enter a number for the quantity of effort in the Qty field.
Select task type flags.

For a detailed description of flag options, see the Task Type Flag Definitions
table in the References section.

If you want to define resource requirements from the Task Types window, then
use this procedure.

a. Click Resource Requirement.

The Resource Requirements window opens.
b. Enter a resource name in the Name field.
c. Enter a number in the Required Units field.

Selecting the Enabled Flag activates the resource type for the corresponding
task type.

d. Click OK.

The complete set of resource types now exists and register as lists of values
for their task types when enabled.

Save your task type.

The new task type and corresponding resource types register as lists of values
for their fields in the application.
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References
The following table defines each task type flag.

Table 5-14 Task Type Flag Definitions

Flag Description/Action

Notification | Launch notification workflow automatically.

Schedulable | Reserve the resource through the Scheduler.

Billable Signify a task as a service that requires
billing.
Seeded Lock edit of task type from future users.

5.6.4 Defining a Status Transition and Assigning Rules

In Tasks, you can define a group of tasks that must be performed and impose a
sequence of statuses to the tasks. A status transition is the imposed sequence of
statuses.

For example, one status transition may dictate the following status sequence:

« Open

» Assigned
= Working
» Closed

As each status in the sequence is completed, the subsequent status appears on the
agent’s list.

In addition, you can define rules for each status transition. A status transition rule
defines access and read-write privileges for the status transition. Rules can be
associated to responsibilities, so that a manager may have more privileges than an
agent.

Use the following procedure to define a status transition and assign it to a
responsibility.

Prerequisites

Responsibilities must be created for the applications to which you are assigning
Task Status and Task Status Transitions.
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Steps

1.
2.

Log in to the CRM Administrator responsibility.
Navigate to Task Manager > Setup > Task Status.
The Task Status window opens.

Click Define Transition.

The Status Transition window opens.

Click the Rules tab and click the Rule Name field.
Select View > Find All to populate the Rules tab.

The Rules tab displays two lists: Current State and Next State. On any line, the
task in the Next State list defines the task that immediately follows the task in
the Current State list. Use this window to define the sequence of tasks in a rule.

To define a new rule, enter a value in the Rule Name field.
Click the Responsibilities tab to assign a Rule to a Responsibility.

Click OK to complete the association of rule to responsibility.

5.6.5 Designing Task Templates

Design a task template to assist the application user in creating tasks. Creating a
template eliminates the user’s interaction with the specific properties of a task and
makes task creation a simple and quick process when creating redundant task
types. Use this procedure to design task templates.

Prerequisites

None
Steps
1. In the Tasks window, click Navigator on the Task toolbar.
2. Inthe Task Manager Navigator, double-click Tasks to expand the node.
3. Select Task Template Group and click OK.
The Task Template Group window opens.
4. Define and enter a template group name, description and effective dates.
5. Enter a document type by selecting from the LOV.
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Define and enter a template name, number, and description.
Select from the LOV in the Type, Status, and Priority fields.
Select flags.

© © N o

Optionally, click Dependencies and Recurrences.
The Task Details window opens.
10. Save your template.

A task template now exists and task creation from a template is possible.

Guidelines

Create task templates within groups. Each task template group contains related task
templates with full property descriptions.

5.6.6 Workflows

Task Manager contains one pre-defined workflow:
JTFTASK

This workflow can only send notifications to employee resources. It does not send
any notification to any other type of resources like such as groups or teams. If you
want to send notifications to other type of resources, you have to write your own

workflow. JTFTASK is automatically launched under the following circumstances.

» If the auto-notification flag for the task type is set to Y (Yes).

« If certain pre-defined conditions are met.

5.6.7 Setting System Profile Options

The following profile options are used in Task Manager.

Default Task Status
Use the Default Task Status profile option to set the default task status.

Default Priority
Use the Default Priority profile option to set the default task priority.

Default Task Owner
Use the Default Task Owner profile option to set the default task owner.
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Owner Type for Task
Use the Owner Type for Task profile option to set the default owner type.

Default Assignee Status
Use the Default Assignee Status profile option to set the default assignee status.

JTF Tasks default date selected

Use this profile option to set the default date selected (Planned, Scheduled, or
Actual).

Used by Task API's to determine if security is implemented
This profile option is reserved for future use.

WARNING: The value of this profile option should always be set
to No.

Time Unit of Measure Class

The Time Unit of measure class must be defined in the inventory module. The user
must define the Unit of Measure codes, for example, hours or minutes, defined in
the Time Unit of measure class in the inventory module.

5.7 Calender

5.7.1 Calendar Integration with Other Modules

This optional procedure allows you to embed Calendar in an existing Oracle
E-Business CRM module. Performing these steps adds Calendar to your existing
CRM module. For example, following this procedure adds a Calendar tab to Oracle
Sales Online user interface. Perform the following steps to embed Calendar into an
existing Oracle CRM Module.

Prerequisites
= You must have system administrator responsibility.

= You must be a resource of type employee.

Steps
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1. Log in as the System Administrator.
2. Query up your root menu structure.

3. Attach menu JTF HTML Calendar Main Menu to your Main node along with
profiles node.

4. AddJTF HTML Calendar Profile Preferences for the preferences structure.
5. Bounce the server to view your changes.

The Calendar module is embedded and the tab is added to your user interface
in the location you specified.

5.7.2 Creating a Calendar System Administrator

Perform the following steps to create a calendar workflow administrator to respond
to group and public calendar requests.

Prerequisites

= You must set up your Personal Home Page (PHP) and create a worklist to
receive notifications.

= You must have System Administrator responsibility to create a Calendar
workflow administrator.

Steps

Log in as the System Administrator.

Select the system administrator responsibility.
Navigate to Security > User > Define.

The User window opens.

Enter a username for the administrator.

o o M w N B

Enter the administrator’s name in the person text field or click the LOV and
enter characters to search for the user. You can also enter "%" to search all users
in the system.

7. Enter a password in the Password text field.
8. Enter your password again to verify it.
9. Add the following responsibilities:

=  Workflow (web application)
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« Preferences
« JTF HTML Calendar Administrator

10. Choose File > Save to save your changes.

5.7.3 Creating a Calendar User

Every resource of type employee can use calendar. Perform the following steps to
create a calendar user.

Prerequisites

You must set up your Personal Home Page (PHP) and create a worklist to receive
notifications.

Steps

Log in as the System Administrator.

Select the system administrator responsibility.
Navigate to Security > User > Define.

The User window opens.

Enter a username.

o o M w N B

Enter the name in the person text field or click the LOV and enter characters to
search for the employee’s name. You can also enter "%" to search all users in the
system.

7. Enter a password in the Password text field.
8. Enter your password again to verify it.
9. Add the following responsibilities:
= Workflow (web application)
« Preferences
«» JTF HTML Calendar Administrator
10. Choose File > Save to save your changes.

Make sure that the employee is a resource. If not, you must import the employee
from HR. See Importing Resources in the Resource Manager documentation to
import the user as an Employee resource.
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5.7.4 Viewing and Approving Group Calendar Requests

Note: The following procedure must be done in the Calendar
Forms-based module.

The Calendar Administrator can approve or reject a group calendar request.
Whether the group calendar request is granted or rejected, the group calendar
requestor gets a notification. If the request is approved, the requestor is
automatically subscribed to the calendar. Perform the following steps to approve a
group calendar request.

Prerequisites

You must set up your Personal Home Page (PHP) and create a worklist to receive
notifications.

Steps

1. Login as the Calendar Administrator

2. Set up your PHP to show workflow notifications.

3. Navigate to Self Service > Workflow > View Notifications.

Now you can decide if you want to approve or deny a group calendar request.

5.7.5 Viewing and Approving Subscription Requests

Note: The following procedure must be done in the Calendar
Forms-based module.

If the user places a request to subscribe to an existing private group calendar
through the Subscribe to Group Calendar page, the owner of the group calendar
gets a notification through workflow. Perform the following steps to add a Calendar
tab to the window.

Prerequisites

You must set up your Personal Home Page (PHP) and create a worklist to receive
notifications.
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Steps

1. Login as the Calendar Administrator

2. Navigate to Self Service > Workflow > View Notifications.

3. Grant the user either Full or Read Only access to the group calendar.

The user receives notification in the Personal Home Page (PHP).

5.7.6 Setting System Profile Options

The following profile options are used in Calendar.

Profile Option JTF_PROFILE_DEFAULT_RESPONSIBILITY

The JTF_PROFILE_DEFAULT_RESPONSIBILITY profile option sets the default
responsibility when using calendar as a stand-alone application.

Profile Option JTF_PROFILE_DEFAULT_APPLICATION

The JTF_PROFILE_DEFAULT_APPLICATION profile option sets the default
application when using calendar as a stand-alone application.

Profile Option JTF HTML Calendar Administrator

The JTF HTML Calendar Administrator profile option sets the Calendar system
administrator who grants approval and subscription requests for group and public
calendars.

Profile Option Client Timezone
The Client Timezone profile option sets the default time zone for the user.

5.8 Interaction History

Although you can do set ups in either Forms or HTML, you first begin
implementing by creating the JSP Interaction History Administrator using the
Forms interface.

5.8.1 Setting Up the Interaction History Administration

Create a JSP Interaction History Administrator using the Forms interface. Perform
the following steps to create the JSP Interaction History Administrator.
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Prerequisites
The Interaction History administrator must be defined as a user.

Steps in Forms

1.
2.

Navigate using the System Administrator responsibility.
Select Security > User > Define.

The Users window opens.

Enter the following required information:

=« User Name

«» Password

«  Verify Password

Click on the list of values (LOV) in the Responsibility field and select
Interaction History JSP Administrator.

Click OK.

Save your work and exit Forms.

Steps in HTML

1.
2.

Navigate to the JSP login page.

Enter your user ID and password in the appropriate fields.

The User Setup window opens. The Interaction History JSP Administrator

shows in the Default Responsibility field.
Click Update.
Sign out by clicking the Sign Out icon in the upper corner.

Sign in again using your new user ID.

5.8.2 Setting Up Interaction History

Overview

Interaction History is a collection of tables and business logic that records touch
points between customers and resources for Oracle Applications. Whether the touch
point occurs between two computers, a face-to-face conversation, or over various

media channels (such as telephony), the following patterns are true:
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« Atouch point is recorded as an interaction.
« Aninteraction is composed of a set of one or more business activities.
» Aninteraction is historical record, once closed it cannot be altered or modified.

» Business activities can be related to a media item (such as phone, e-mail, or fax).

Prerequisites

Interaction History is part of the Oracle CRM Foundation product suite. After CRM
Foundation is installed, clients can access the Interaction History graphical
interface, Administration set ups, and public APIs to test and use Interaction
History functionality. The following table defines the procedure for setting up
Interaction History.

Table 5-15 Interaction History Set Up Procedures
Interaction History Setup Window
Step | Required | Step Description Name(s) AIW Reference
1 Optional Define additional Outcome Codes required by the | Outcome Tab | CRM Administrator
application in addition to the initial seeded values. Interaction Histor
Modify or delete existing Outcome Codes. L y
Administrator
2 Optional Define additional Result Codes required by the Result Tab CRM Administrator
application in addition to the initial seeded values. Interaction Histor
Modify or delete existing Result codes. L y
Administrator
3 Optional Define additional Reason Codes required by the Reason Tab CRM Administrator
application in addition to the initial seeded values. Interaction Histor
Modify or delete existing Reason Codes L y
Administrator
4 Optional Define additional Activity Type Codes required by | Action Item CRM Administrator
the application in addition to the initial seeded Tab Interaction Histor
values. Modify or delete existing Action Item L y
Administrator
Codes.
5 Optional Define additional Action Codes required by the Action Tab CRM Administrator
application in addition to the initial seeded values. Interaction Histor
Modify or delete existing Action codes. L y
Administrator
6 Optional Define the Outcome, Result, or Reason codes as Wrap Up Tab | CRM Administrator
required for specific campaigns and promotions. Interaction History
Administrator
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Table 5-15 Interaction History Set Up Procedures

Interaction History Setup Window
Step | Required | Step Description Name(s) AIW Reference
7 Optional Define unique pairs of Outcome-Results from Outcome CRM Administrator

existing Codes in the Outcome and Result tables. Result . .
Interaction History

Administrator

8 Optional Define unique pairs of Result-Reason from existing | Result Reason | CRM Administrator

Codes in the Result and Reason tables. . .
Interaction History

Administrator

Guidelines

All applications that have a touch point between a customer and resource must
record this event as an interaction through Interaction History or another
application serving as a proxy that uses Interaction History (for example, Universal
Work Queue). Interaction History records can be browsed and retrieved by directly
using its graphical interface, integrating its graphical interface into an application,
or using its views. Use the Administration tool to modify setup data; do not modify
Interaction History tables directly.

Interaction History does not have any organizational constraints on operations or
relationships. Interaction History does not have any multi-organizational tables.

Interaction History schema does not contain any table columns that are related to
currency. Interaction History does have five translated tables which are used by
applications for creating interactions and activities:

. JTF_IH_OUTCOMES

. JTF_IH_RESULTS

. JTF_IH_REASONS

. JTF_IH_ACTION_ITEMS
. JTF_IH_ACTIONS

5.8.3 Setting System Profile Options

Interaction History does not use profiles.

5.8.4 Workflows in Interaction History
Interaction History does not use Workflow processes.
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5.8.5 Setting Up Interaction History Administration in HTML

Use the Interaction History Administration window to define attributes that users
can assign to interaction records. Defining attributes in either Forms or HTML will
equally affect the Interaction History module.

5.8.6 Defining Outcomes

The outcome is the immediate response to an agent’s call, such as Contact, No
Answer, or Busy. One outcome can be used by more than one campaign. To close an
interaction the agent must report an outcome. Perform the following steps to define
outcomes that the agent can use.

Prerequisites
None

Steps

1.

To open the jtflogin.jsp page, enter the URL:
http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
Enter your user ID and password in the appropriate fields.
Select the Outcome tab.

The Outcome window opens.

(Optional) Update an existing code by entering the appropriate information,
select the appropriate check box, and click Update.

a. The Outcome code and Short Description fields must be defined.
b. Enter along description.

c. Choose whether the outcome requires a positive outcome, a result, or a
Private or Public callback.

d. Select the appropriate check box, and click Update to save.
Click Create to create a new outcome.

The Create Outcome window opens.

Enter the required information.

Click Save to save your work.
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5.8.7 Defining Results

A result of a transaction is the business-related consequence of the agent’s call, such
as Sale, No Sale, or Complaint. While all transactions must have an outcome, a
result is not mandatory. Perform the following steps to define a result.

Prerequisites
None

Steps
1. To open the jtflogin.jsp page, enter the URL:

http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
2. Enter your user ID and password in the appropriate fields.
3. Select the Result tab.

The Result window opens.

4. (Optional) Update an existing code by selecting the appropriate check box,
entering the appropriate information, and clicking Update.

a. Select your Result code.
b. Enter along description.

c. Choose whether the outcome requires a positive outcome or whether a
result is required.

d. Select the appropriate check box, and click Update to save.
5. Click Create to create a new result.

The Create Result window opens.
6. Enter the required information.

7. Click Save to save your work.

5.8.8 Defining a Reason
Perform the following steps to define a reason.

Prerequisites
None
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Steps

1.

To open the jtflogin.jsp page, enter the URL:
http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
Enter your user ID and password in the appropriate fields.
Select the Reason tab.

The Reason window opens.

(Optional) Update an existing code by entering the appropriate information and
click Update.

a. Select your Reason code.

b. Enter along description.

c. Click Update to save.

Click Create to create a new reason.
The Create Reason window opens.
Enter the required information.

Click Save to save your work.

5.8.9 Pairing an Outcome with a Result

You can create a new option by pairing an Outcome with a Result. Any Outcome
may be paired with more than one Result. Each pair appears as one option on the
agent’s screen. Perform the following steps to pair an outcome with a result.

Note: Each Outcome-Result pair must be unique.

Prerequisites
None

Steps

1.

To open the jtflogin.jsp page, enter the URL:
http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
Enter your user ID and password in the appropriate fields.

Select the Outcome-Result tab.
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The Outcome-Result window opens.
4. Click Create to create a new Outcome-Result.
The Create Outcome-Result window opens.
5. Choose your required information from the drop-down menus.

6. Click Save to save your work.

5.8.10 Pairing a Result with a Reason

You can create a new option by pairing a Result with a Reason. Any Result may be
paired with more than one Reason. Each pair appears as one option on the agent’s
window.

Perform the following steps to pair a result with a reason.

Note: Each Result-Reason pair must be unique.

Prerequisites
None

Steps
1. To open the jtflogin.jsp page, enter the URL:

http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
2. Enter your user ID and password in the appropriate fields.
3. Select the Result-Reason tab.
The Result-Reason window opens.
4. Click Create to create a new Result-Reason.
The Create Result-Reason window opens.
5. Choose your required information from the drop down menus.

6. Click Save to save your work.

5.8.11 Defining an Action Item

Perform the following steps to define an action item.
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Prerequisites
None

Steps
1. To open the jtflogin.jsp page, enter the URL:

http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
2. Enter your user ID and password in the appropriate fields.
3. Select the Action Item tab.

The Activity Type window opens.
4. Click Create to create a new action item.

The Create Action Item window opens.
5. Enter a code and short description.

6. Click Save to save your work.

5.8.12 Defining an Action

Perform the following steps to define an action.

Prerequisites
None

Steps
1. To open the jtflogin.jsp page, enter its URL:

http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
2. Enter your user ID and password in the appropriate fields.
3. Select the Action tab.

The Actions window opens.
4. Click Create to create a new action.

The Create Action window opens.
5. Enter a code and short description.

6. Click Save to save your work.
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5.8.13 Defining a Wrap-Up

A wrap-up is a summary of a transaction that an agent enters after completing a
transaction. A Promotion code and Campaign Type are essential elements in the
definition of a wrap-up. When an agent is working on a specific promotion, the
wrap-ups defined for that promotion become available on the agent’s window.

Business rules determine whether or not to include the Outcome Code, Result Code
and Reason Code in the definition of the wrap-up. Perform the following steps to
define a wrap-up for an interaction.

Prerequisites
None

Steps
1. To open the jtflogin.jsp page, enter the URL:

http://<host.domain_name>:<port>/<docroot>/jtflogin.jsp
2. Enter your user ID and password in the appropriate fields.
3. Select the Wrap Ups tab.

The Wrap Ups window opens.
4. Click Create to create a new Wrap Up.

The Create Wrap Up window opens.
5. Enter the required information.

6. Click Save to save your work.

5.8.14 Overview of Interaction History Administration in Forms

Use Interaction History setup windows to define outcomes, results, and reason
codes. These attributes are defined so that users can assign them to interaction
records.

Outcome: The outcome is the immediate response to an agents call. To close an
interaction, the agent must report an outcome. Examples of outcomes include
contact busy, no answer, sale customer complaint, bad phone number, answering
machine, or need to call back. Interactions and activities must have a valid outcome
code.
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Result: A result of an interaction or activity. A result of a transaction is the business
related consequence of the agent’s call such as Sale or No Sale, or Complaint. For
example, the interaction resulted in a sale. While all transactions must have an
outcome, a result is not mandatory.

Reason: A reason for the result of an interaction or activity. For example, the reason
the interaction resulted in a no sale was that the customer thought the product was
too expensive. In this case, the reason is “too expensive”. Other reasons of why the

interaction resulted in a no sale can include no money, already gave at the office or

out of work.

Use the Interaction History Administration window to define attributes that users
can assign to interaction records. This section covers the following tabs in the
Interaction History Administration window:

5.8.15 Defining Outcomes

The outcome is the immediate response to an agent’s call, such as Contact, No
Answer, or Busy. One outcome can be used by more than one campaign. To close an
interaction, the agent must report an outcome. Perform the following steps to define
the outcomes that the agent can use.

Steps
1. Inthe CRM Administrator responsibility, navigate to Interaction History
Administration.

2. Select the Outcomes tab.

The Outcome Code and Short Description fields must be defined. Some
pre-defined values are available for these fields.

3. Click the Outcome Code field and choose View > Find All.

The pre-defined values are now visible in the Outcome Code and the Short
Description fields.

4. Select the Up or Down arrow keys to review all the pre-defined values. You can
also enter your own values in either field.

5. If you need to use Numeric Values, select the Telephony Related check box.

6. Select either Success option-Yes or No-and enter the appropriate Numeric
Value.

Yes has a range of 1 to 100; No has a range of 101 to 255.

Implementation Tasks 5-81



Interaction History

7. Choose whether the outcome requires a Private or Public callback.

8. Choose File >Save and Proceed to save the outcome definition.

Guidelines

Some telephony-related applications use Numeric Values, which are recorded as the
Versatility Code in database tables. Versatility Codes are used by version 3i of the
following applications: Oracle TeleBusiness for Telecom/Utilities, Oracle
TeleBusiness for Financial Services, Oracle Integration Manager, and Oracle
Campaign Plus. If you do not use these earlier applications, you do not need to use
Numeric Values.

5.8.16 Defining Results

A result of a transaction is the business-related consequence of the agent’s call, such
as Sale, No Sale, or Complaint. While all transactions must have an outcome, a
result is not mandatory. Perform the following steps to define a result.

Prerequisites
None

Steps
1. Inthe CRM Administrator responsibility, navigate to Interaction History
Administration.

2. Select the Results tab.

The Results Code and Short Description fields must be defined. Some
pre-defined values are available for these fields.

3. Click the Results Code field and choose View > Find All.

The pre-defined values are now visible in the Results Code and the Short
Description fields.

4. Click the Up or Down arrow keys to review all the pre-defined values. You can
also enter your own values in either field.

5. If the business rules of the enterprise require a Reason for every Result, select
the Reason Required check box.

You may also define Result-Reason pairs.

6. Choose File > Save and Proceed to save the result definition.
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5.8.17 Pairing an Outcome with a Result

You can create a new option by pairing an Outcome with a Result. Any Outcome
may be paired with more than one Result. Each pair appears as one option on the
agent’s screen. Perform the following steps to pair an outcome with a result.

Note: Each Outcome-Result pair must be unique.

Prerequisites
None

Steps

1. Inthe CRM Administrator responsibility, navigate to Interaction History
Administration.

2. Select the Outcome-Results tab.

3. Select a value from the Outcomes list.

4. Select a value from the Results list.

5. Choose File > Save and Proceed to save the Outcome-Result pair.
Guidelines

The values on the Outcomes list are defined on the Outcomes tab. The values on the
Results list are defined on the Results tab.

5.8.18 Pairing a Result with a Reason

You can create a new option by pairing a Result with a Reason. Any Result may be
paired with more than one Reason. Each pair appears as one option on the agent’s
screen. Perform the following steps to pair a result with a reason.

Note: Each Result-Reason pair must be unique.

Prerequisites
None
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Steps

1. Inthe CRM Administrator responsibility, navigate to Interaction History
Administration.

2. Select the Result-Reasons tab.

3. Select a value from the Result list.

4. Select a value from the Reason list.

5. Choose File > Save and Proceed to save the Result-Reason pair.
Guidelines

The values on the Results list are defined on the Result tab. The values on the
Reasons list are defined on the Reason tab.

5.8.19 Defining a Wrap-Up

A wrap-up is a summary of a transaction that an agent enters after completing a
transaction. A Promotion code and Campaign Type are essential elements in the
definition of a wrap-up. When an agent is working on a specific promotion, the
wrap-ups defined for that promotion become available on the agent’s window.

Business rules determine whether or not to include the Outcome Code, Result Code
and Reason Code in the definition of the wrap-up.

Perform the following steps to define a wrap-up for an interaction.

Prerequisites
None

Steps

1. Inthe CRM Administrator responsibility, navigate to Interaction History
Administration.

2. Select the Wrap-Up tab.

3. Choose values for Promotion Code and Campaign Type. Choose values for the
remaining codes when required.

4. Choose File > Save and Proceed to save the wrap-up definition.
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5.8.20 Importing Mass Data

Interaction History can mass import data from third parties and legacy systems.
Use the concurrent manager to schedule regular mass imports. Interaction History
Mass Import is a new responsibility. The system administrator can define the
concurrent program to reference the PL/SQL procedure JTF_IH_IMPORT_GO_
IMPORT.

Importing mass data consists of four sections:
a. Loading your data into the staging tables
b. Setting up the menu item for Interaction History Import

c. Running the concurrent manager to actually move your files from the
staging tables to the IH tables

d. \Verifying that the procedure was correctly executed
e. Deleting the rows from the staging tables when you are finished

Perform the following steps to mass import data your data. There are many tools to
load the data into the staging table. This procedure can be deferred to off-peak
hours.

Prerequisites
= You must first prepare the data to be transferred to the staging tables.

» You must have the Interaction History Mass Import responsibility.

= You must load your data into the three staging tables which mirror the IH
tables:

- JTF_IH_INTERACTIONS_STG
- JTF_IH_ACTIVITIES_STG
- JTF_IH_MEDIA_ITEMS_STG

Guidelines for Uploading Your Data to the Staging Tables

The staging tables have a similar structure to the IH tables with the addition of three
columns:

» SESSION_NO: The Session number, which counts through a sequence

« STATE_FL: This is the flag of state of record after the import. The flag can only
have three values, 0 error, or 1 passes referential integrity checks, 2 successfully
uploaded.
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«» SESSION_DATE: The date that the import is run.
The following table describes the required fields for JTF_IH_INTERACTIONS_STG.

Table 5-16 Required Fields for JTF_IH_INTERACTIONS_STG

Field Notes if Applicable
INTERACTION_ID Primary key
CREATION_DATE None
CREATED_BY None
LAST_UPDATE_DATE None
LAST_UPDATED_BY None

OUTCOME_ID Foreign key to the table JTF_IH_OUTCOMES_STC
HANDLER_ID Foreign key to the table FND_APPLICATION
PARTY_ID Foreign key to the table HZ_PARTIES
TOUCHPOINT1_TYPE None

TOUCHPOINT2_TYPE None

ACTIVE None

The following table describes the required fields for JTF_IH_ACTIVITIES_STG.

Note:

If JTF_IH_ACTIVITIES_STG has a value for MEDIA_ID,

then MEDIA_ID must exist in JTF_IH_MEDIA_ITEMS_STG or in

JTF_IH_MEDIA_ITEMS.

Table 5-17 Required Fields for JTF_IH_ACTIVITIES_STG

Field Notes if Applicable
ACTIVITY_ID Primary key
CREATION_DATE None
CREATED_BY None
LAST_UPDATED_BY None
LAST_UPDATED_DATE None

INTERACTION_ID

Foreign key to the table JTF_IH_INTERACTIONS
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Table 5-17 Required Fields for JTF_IH_ACTIVITIES_STG

Field Notes if Applicable
ACTION_ITEM_ID None
ACTIVE None
OUTCOME_ID None

The following table describes the required fields for JTF_IH_MEDIA_ITEMS_STG.

Table 5-18 Required Fields for JTF_IH_MEDIA_INTEMS_STG

Field Notes if Applicable
MEDIA_ID None
ACTIVE None
CREATED_BY None
LAST_UPDATED_BY None
CREATION_DATE None
LAST_UPDATE_DATE None
MEDIA_ITEM_TYPE None

Steps for Setting Up the Menu Item for Interaction History Import
1. From the System Administrator responsibility, select System Administrator.

The Navigator - System Administrator window opens.

2. Select Security > User > Define.

The Users window opens.

3. From the menu, select View > Find.

The Users Dialog window opens.

4. Type "Sys" with a wildcard and click Find.

The System Administrator name is highlighted.

5. Click OK.

The Users window is populated and reopens.
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6. Inthe Responsibility area, place your cursor in the Responsibility field and go
to the menu and select File > New.

A new row is vacant.
7. Click the List of Values (LOVSs).

The Responsibilities window opens with a list of responsibilities for the System
Administrator.

8. Select Interaction History Import and click OK.
The Users window opens with your selection.

9. Save and exit.

Steps for Running the Concurrent Manager

1. From the System Administrator responsibility, select Interaction History
Import.

The Navigator - Interaction History window opens.
2. Select Requests.
The Find Requests window opens.
3. Click Submit a New Request.
The Submit a New Request window opens.
4. Select the Single Request and click OK.
The Submit Request window opens.
5. Click the LOV in the Name field.
The Interaction History Data Import populates in the Name field.
6. Click Submit.

A Decision window opens stating that the request was submitted and giving
you a Request ID. It asks if you want to submit another request.

7. Click No.
Deleting Staging Table Rows

If you decide to reload or load additional data into the staging tables you must first
delete the current data before adding new data.
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Troubleshooting

If you encounter problems running the Concurrent Manager, you can start the IH
mass import procedure from SQL*Plus by calling the stored procedure JTF_IH_
IMPORT.GO_IMPORT.

Optional parameter to this procedure is:

NCntTransRows (NUMBER): Number of interactions in one database transaction.

Testing

For testing purposes, stored procedure JTF_IH_IMPORT.GO_TEST can be called.
This procedure tests the data in stage tables that is intended for mass import
without writing it into the IH tables.

5.9 Fulfillment

5.9.1 Setting Up the Fulfillment Administrative User

The Foundation HTML Stack provides the interface for Fulfillment administration.
The following table describes the basic steps for setting up Fulfillment.

Table 5-19 Setting Up Steps

Step | Required Description Navigation Path

1 Yes Create an administrative user.
Assign the JTF_FM_Admin role to the application | System Administrator:
administrator user. Security > User
Assign the JTF_FM_Administrator responsibility to | System Administrator:
the same user. Security > User > Define

2 Yes Identify the agents and the output devices that you | N/A
will use with Fulfillment.

3 Yes Define the Fulfillment servers. Fulfillment Administrator:

Server

4 Yes Define the groups for each output device and Fulfillment Administrator: Groups
assign groups to servers.

5 Optional Add a Master Document. Fulfillment Administrator:

Master Document > Upload
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Table 5-19 Setting Up Steps

Step | Required Description Navigation Path

6 Optional Associate a Master Document with template. Fulfillment Administrator: >
Template > Master Document

7 Yes Set up and start the Fulfillment server. Oracle Applications

5.9.2 Assigning the JTF_FM_ADMIN Role to the Administrator

The JTF_FM_ADMIN role for the Fulfillment administrator has been pre-defined.
Perform the following steps to assign the role to the appropriate user.

Prerequisites

The Fulfillment administrator must be defined as a user and have a password. The
administrator must have the JTF_FM_ADMINISTRATOR responsibility assignment.

Steps

1.
2.

Log into the System Administrator Console as the system administrator.
Select the Users tab and click Create.

The User Registration window opens.

Enter the following required information:

» First Name

« Last Name

« UserName

«» Password

«  Verify Password

« Email

Use the drop-down list to select an account type:

« An End user is an individual that does not represent an organization.
Click Submit.

In the System Administrator Console, select the Users tab.

Enter the Last Name of the Fulfillment administrator in the Search field and
click Go.
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8. Inthe username column, click the username.
The User Details window opens with the particular user’s details.
9. Click Roles.

The User Role Mapping window opens displaying two lists: Available Roles
and Assigned Roles.

10. Select the JTF_ADMIN role from the Available Roles list and click > to move it
to the Assigned Roles list.

11. Click Update to complete the task of assigning the Administrator role to the
Fulfillment administrator.

5.9.3 Assigning the JTF_FM_Administrator Responsibility to the Application
Administrator

When Oracle CRM Applications are first installed, the sysadmin user is the only
defined user. The JTF_FM_Administrator responsibility has been predefined. You
must assign this responsibility to the user who is the administrator for Fulfillment.

You must know the responsibility_id and the application_id to perform this task. To
determine this information, log into SQL*Plus using the apps user ID and execute
the commands listed in the following table.

Table 5-20 Necessary SQL*Plus Commands

Information Retrieval Command

responsibility_id SELECT RESPONSIBILITY_ID FROM FND_RESPONSIBILITY
WHERE RESPONSIBILITY_KEY ="JTF_FM_ADMINISTRATOR’;
application_id SELECT APPLICATION_ID FROM FND_APPLICATION
WHERE APPLICATION__SHORT_NAME = "JTF’;

Use the following procedure to assign the JTF_FM_Administrator responsibility to
the appropriate user.

Prerequisites

The Fulfillment administrator user must be a registered user with a password.
Execute SQL*Plus commands to determine two values in your database:
responsibility_id for the jtf_fm_administrator key, and application_id for JTF.
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Steps

1.

10.
11.
12.
13.

Use Oracle Forms to login as the System Administrator and navigate to
Security > User > Define.

Enter the Fulfillment administrator’s user ID in the Username field.
Enter the Fulfillment administrator’s password in the Password field.

Choose JTF_FM_ADMINISTRATOR from the Responsibility list of values
(LOV).

Select File > Save and Proceed, then close this window.
In the System Administrator window, navigate to Profile > System.

In the Find System Profiles window, select the User box and enter the
Fulfillment administrator’s username.

In the Profile field, enter JTF% and click Find.

The System Profile Values window displays all the profiles that begin with JTF.
The Fulfillment administrator’s username appears at the top of the User column
on the right.

Modify the following profiles by entering values in the User column:

« JTF_PROFILE_DEFAULT_APPLICATION: enter the value of the
application_id used in your database

« JTF_PROFILE_DEFAULT_RESPONSIBILITY: enter the value of the
responsibility_id used in your database

«» JTF_PROFILE_DEFAULT_LANG: enter US

Select File > Save and Proceed and return to the Find System Profiles window.
In the Profile LOV, enter ICX% and click Find.

Select ICX: LANGUAGE and set the language to your language.

Select File > Save.

The Fulfillment administrator now has been assigned the appropriate
responsibility.

5.9.4 Defining and Configuring the Fulfillment Server

The Fulfillment server calls on database tables to supply the Fulfillment collateral,
and sends the collateral to specified output devices. You need to configure the
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Fulfillment server with specific output devices and associate the output devices
with specific agent groups.

When creating a new Fulfillment server, follow the procedures that are listed on the
window in the Servers column. The procedures are listed in sequence, from top to
bottom.

If you set Start Up and Shut Down times, define the Time format as yyyy-MM-dd
HH:mm:ss.S, where:

= Yyyyy isthe year in four digits
« MM is the month in two digits (06)
« dd is the day in two digits (04)
(Enter a space between dd and HH)
« HHisthe hour, in two digits (from 01-24)
« mm is the minutes in two digits
» ssisthe seconds in two digits

« Sismilliseconds in one digit

Prerequisites
None

Steps
1. Select the Server tab.

2. Click Create.
The General window opens.
3. Enter the Server Name and other information as necessary.

4. (Optional) Enter the current date and the time of day that Fulfillment can begin
operations in the Start Time field. The Start Time can occur after the date and
time that the server is created.

5. (Optional) Enter a date and the time of day that Fulfillment can end operations
in the Shut Down Time field. The Start Time and Shut Down Time cannot be
specified if the Fulfillment server runs 24 hours a day.

6. Enter a unique name for the Request Queue.

7. Enter a unigue name for the Response Queue.
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(Optional) Enter a description for the server.
Click Continue.

Once the Request Queue and the Response Queue are created, JTF_FM_is
added to the front of the unique names you entered.

5.9.5 Defining Groups and Assigning Groups to Servers

A group is a group of people. Each group must be assigned to a Fulfillment server.
Perform the following steps to define a group and assign it to a server.

Prerequisites
A Fulfillment server must be defined and configured. Agents must be registered

users.

Steps

1. Inthe Fulfillment Administrator Console, select the Server tab and click Groups
> Create.
The Create Group window displays the fields you need to create a group.

2. Enter the Group Name and Description. Select the appropriate Server from the
list.

3. Inthe list of Agents, click Go to begin a search of Agents.
The Select Agent window opens.

4. Inthe Select Agent window, enter the initial letter of the agent’s name with %
and click Search.

5. Click the agent name to add the agent to the group. Repeat steps 3 and 4 for
each of the agents you want to include in the group.

6. When the list of agents is complete, click Create.

5.9.6 Configuring Email Servers

After configuring the main server, the second step in configuring the Fulfillment
server is to associate the email servers with the Fulfillment server.

Prerequisites
You must have already created the server.
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Steps
1. Inthe Email Servers window, choose the Add button to add a new email server.

The Create Email Server window opens.

2. Inthe fields on the Create Email Server window, enter the information required
to describe the email server that you are adding.

3. Inthe Outgoing server fields, enter the IMAP or SMTP server names.
The Incoming server field is not a required field.

4. Click Save.
The Email Servers window appears.

5. To add more Email servers, repeat steps 1, 2, and 3.

5.9.7 Archiving Sent Emails

If the calling application sends an archived fulfillment request, then the SMTP ID
associated with the outgoing email is written to Interaction History. The message
identifier is retrieved and stored as part of an interaction activity in Interaction
History. The Fulfillment server fetches SMTP ID for outgoing emails that are sent
through direct SMTP connection. The server makes a connection to the email server
with a login account.

The following information is required for the Fulfillment server to store emails on
an IMAP Server.

= imap_server
« imap_user
« imap_pass
« imap_folder

The extended header tag was designed for Fulfillment to be a simple name-value
pair consisting of header name and header value. The information of IMAP Server,
IMAP User Id, IMAP Password, and IMAP Folder is passed in as part of the
extended header as follows:

<ext ended_header >
<header nane>

| MAP Server
</ header nane>
<header val ue>
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i map0l. conpanynane. com
</ header val ue>
</ ext ended header >
<ext ended_header >
<header nane>
| MAP Wser Id
</ header nane>
<header val ue>
Scot t
</ header val ue>
</ ext ended header >
<ext ended_header >
<header nane>
| MAP Passwor d
</ header nane>
<header val ue>
Ti ger
</ header val ue>
</ ext ended header >
<ext ended_header >
<header nane>
| MAP Fol der
</ header nane>
<header val ue>
Sent Ful fill nent
</ header val ue>
</ ext ended header >

An Example

A Fulfillment request is created to email collateral to a customer. Fulfililment sends
the automated response and makes a copy of the email message sent out for
archiving in the Sent folder. Fulfillment captures the SMTP ID of the copy of the
outgoing email message and creates a media item for the response and inserts the
SMTP ID in the MEDIA_ITEM_REF column. Fulfillment records the interaction by
creating the interaction history record.

5.9.8 Configuring Fax Servers

In Fulfillment, provides a second output method, other than email, to send a
fulfillment request. The fulfillment engine has open Java interface APlIs that
facilitates integration to other custom fax solutions, to enable you fax fulfillment
requests.
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Customization

To make the interface vendor independent, there is a certain amount of integration
required between the Fulfillment interface and an independent fax solution
provider’s APIs. The integration includes writing Java code that complements the
Fulfillment code with another vendor’s APIs.

If the Fulfillment Server receives a fax request and a fax solution is not
implemented, the Server logs an error in the Server’s error log and writes to the
database that it was unable to fulfill the request.

Note: Contact Oracle Support directly if you are interested in
adding fax capabilities to your E-business suite.

5.9.9 Configuring File Servers

WARNING: Windows relating to file server functionality or
capability are not supported at this time, and should not be used.

5.9.10 Configuring Printers

WARNING: Windows relating to print functionality or capability
are not supported at this time, and should not be used.

5.9.11 Creating Groups for Servers

The final step in configuring the Fulfillment server is to associate agent groups with
the Fulfillment server, and associate output devices with the groups. By associating
a group to an output device, you indicate that the group will use that device. You
must create an association for each agent group to each output device for which the
group needs access. Perform the following steps to associate an agent group to one
or more output devices.
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Note: When a group is associated to a Fulfillment server, that
server’s file server is automatically available for the group. You do
not need to associate a file server to a group or its agents.

Prerequisites
You must have already created the Fulfillment server.

Steps
1. To add a group, in the Groups window, choose the Add button.
The Select Group window opens.

2. From the Group Name drop-down list, choose a group to associate with the
Fulfillment server.

3. Choose Go.

The Output Devices window opens to display a list of output device types.
Create an association with each output device to which the group needs access.

4. From the list of values (LOV) for one type of output device, choose one or more
devices to be associated to the group.

5. Click Create to create the association or click Clear to clear associations that you
have selected but have not yet created.

6. Repeat steps 4 and 5 for each type of output device to be associated to the
group.
7. Click Save to complete the association of the group to output devices.

5.9.12 Creating a New Template

A template is a pre-defined package of brochures, newsletters, or other
customer-oriented information that an agent can direct to customers in response to
a Fulfillment request. Text found in a template is associated to one or more Master
Documents. Perform the following steps to create a new template.

Prerequisites
None
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Steps

1.
2.

Select the Template tab.

Click Create.

The General window opens.

Enter a Template Name.

In the Status drop-down list, choose either:

« Active to make the template available to requests.

« Inactive to make the template unavailable to requests.

(Optional) In the Description field you may enter a description of the template.

(Optional) Enter the name of the marketing campaign you want to associate
with the template.

Click Save.

The Template Master Document window opens.

5.9.13 Adding a Master Document to a Template

Perform the following steps to add a Master Document to a template.

Prerequisites
The template must already exist.

Steps

1.

Choose the Template tab.

The View Template window opens.

Choose the name of the template that you want to add.
The template details window opens.

Choose the Master Document link in the left frame.
The View Template, Master Documents window opens.
Choose Go to add more Master Documents.

Choose Update to save.

Implementation Tasks 5-99



Fulfillment

5.9.14 Inserting Collateral into a Template
Perform the following steps to add collateral to a template.

Prerequisites
None

Steps
1. Choose the Template tab.

The View Template window opens.

2. Choose the name of the template that you want to update.
The template details window opens.

3. Choose the Collateral link in the left frame.
The View Template, Collateral window opens.

4. Click Go to add collateral.

5. Click Update to save.

5.9.15 Setting Up and Starting the Fulfillment Server

Perform the following steps to set up the server.

Note: Perform the following procedure in either a UNIX or
Windows-NT environment.

Prerequisites

You must be able to log into the System Administration Console as
JTF_FM_ADMIN, or in a similar role, to perform the following steps.

Steps For Creating a Fulfillment Server Using the SysAdmin Console

1. Log into the System Administration Console as an administrative user. (For
example, log in as JTF_FM_ADMIN.)

2. Select the Server tab.
a. Create a new Fulfillment server.

b. Note the ID number of the server.
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This number is needed in the start-up script for the server. Usually, the first
time a server is created, its ID is 10000. After that, it increments by one with
each new server.

Create an email server to associate with the Fulfillment server that was
created in step 3.

This is an email server associate mailed with the Fulfillment server, not any
other email server. This email server will need to have the outgoing email
server set.

For many UNIX environments, give the name of the UNIX box that is to run
the Fulfillment server. For example, this could be similar to your UNIX
server.company.com.

Select the Group tab.

a.

g.
h.

Create a group and associate a Fulfillment server to that group. (This
should preferably be the same one that was just created.)

Assign a user to that group.

The ID of the user, since you may be submitting requests with that user.
Return to the Server tab and find the server that you created in step 2.
Double-click the server name to open the general information window.
Select Groups at the left hand side of the window.

The Select Group window opens.

Associate the group you created with this server, and select Go.

The Output Devices window opens.

Associate an email server with this server, and select Create.

Select Save.

Select the Template tab.

a.
b.

C.

Click Master Document.
Click Upload.

Follow the upload steps to upload Master Documents to the server.
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Steps for Setting Up the Shell or Batch Script

Note: When using "jre" instead of "java" add the "-nojit" option so
that logged errors will display error line numbers. These line
numbers are useful when tracking potential issues within the
environment.

Replace "####" with the appropriate server ID.

1. Verify the classpath so that it points to apps.zip.

2. Create a simple batch file, or UNIX shell script, from which the server can be
configured and executed. For UNIX shell script, add exec to the beginning of
the line. There should not be any carriage returns in the script.

Here is a UNIX shell script example:

java - ns32m - mx64m

- Dengi ne. CormandPr onpt Enabl ed=t r ue\

- Dengi ne. Ser ver | DA

- Dengi ne. ACLJ. conf i g=${ FND TCP}/ secur e/ <narme of dat abase connection
configuration file>\

oracl e. apps. j tf.fmengi ne. processor. Processor\

Here is a batch file example:

java -ns32m - nx64m
- Dengi ne. CormandPr onpt Enabl ed=t r ue
- Bengi ne. Ser ver | D=
-Dengi ne. AQALJ. config= d:\lib\<nane of database connection configuration
file>
oracl e. apps. j tf.fmengi ne. processor . Processor
Parameters

a. engi ne. CommandPr onpt Enabl ed

This parameter must be set to true if you want to interact with the
Fulfillment server via the command prompt. The most current versions of
the Fulfillment Server default this value to true. In older versions of the
Fulfillment Server the default was false.

b. engine. ConmandPor t

This parameter must be set in order for the Fulfillment Processor to receive
commands remotely.
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engi ne. Server | D

This parameter specifies the ID of the server that the Fulfillment Server uses
to configure itself with information stored in the database.

engi ne. Server Pat h

This parameter specifies the base directory from which "tmp" and "logs" are
created in the absence of having the log path and temp directory defined. It
overrides the default of the directory from which the Fulfillment server is
started.

engi ne. AOLJ. config

This parameter is the location of the dbc file. This is a mechanism of AOL
that java uses to establish a connection to the database. It provides details
such as connect string, user name, and password. AOL/J uses this
information to allocated database connections through the use of
connection pooling.

engi ne. LogPat h

This parameter can be used to specify the location of the log files that the
Fulfillment Server writes to. The default is a directory called "logs" off of the
directory where the Fulfillment Server is started.

engi ne. TenpDi r

This parameter can be used to specify a temporary directory where the
Fulfillment Server can swap files to and from the local disk. This value can
be used to override the obsoleted profile option value of JTF_FM_TEMP_
DIR.

engi ne. Event Log

This parameter can be used to specify an alternative name for the Events
log. This value may be set in the absence of the profile option JTF_FM_
EVENTS_LOG. It can also be used to override the value of JTF_FM _
EVENTS_LOG. This value will default to "Events.log" if not set.

engi ne. ErrorlLog

This parameter can be used to specify an alternative name for the Error log.
This value can be set in the absence of the profile option JTF_FM_ERROR_
LOG. It can also be used to override the value of JTF_FM_ERROR_LOG.
This value will default to 'Error.log’ if not set.

engi ne. LogLevel

Implementation Tasks 5-103



Fulfillment

This parameter can be used to specify the level of detail recorded in the
Error log. This value can be set in the absence of the profile option JTF_FM_
LOG_LEVEL. It can also be used to override the value of JTF_FM_LOG _
LEVEL. The lowest value of zero should never really be used because it
means that no errors will be recorded.

engi ne. LogRequest s

This parameter is a Boolean property that can be used to specify that
Fulfillment Requests are to be saved before processing. The request is saved
with the request ID in the name. For request id 10010, the logged request
will be 10010.xml and can be found in the "requests" directory within the
log directory. This value defaults to false.

engi ne. LogDi spat ches

This parameter is a Boolean property that can be used to specify that
Fulfillment Requests are to be saved after processing and before
dispatching. The request is saved with the request ID in the name. For
request ID 10010 the logged request will be 10010.xml and can be found in
the "dispatches" directory within the log directory. In the case of batch
requests, this function should be turned off unless performance is not a
concern. This value defaults to false.

engi ne. Request St or eMax

This parameter is specifies the maximum number of requests that get
de-queued and stored internally within the Fulfillment server before the
de-queue temporarily halts while internal processes deplete the internal
pool of de-queued requests.

engi ne. Def Processes
This profile option sets the number of processes at startup.
engi ne. M nProcesses

This profile option sets the minimum number of processes that will run in
the Fulfillment server.

engi ne. MaxProcesses

This profile option sets the maximum number of processes that will run in
the Fulfillment server.

engi ne. Processl dl e
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This profile option defines the number of milliseconds a process is allowed
to remain idle before the Fulfillment server reevaluates it’s need and adjusts
the number of active processes.

engi ne. MaxProcessl dl e

This profile option sets the maximum number of processes that will run in
the Fulfillment server.

engi ne. RefreshRat e

(Optional) This parameter specifies the time in milliseconds between the
status checks that the fulfillment server performs.

engi ne. FaxEnabl er

(Optional) This parameter specifies is used to specify the name of the class
that enables fax requests to be fulfilled.

engi ne. Print Enabl er

(Optional) This parameter specifies the name of the class that enables print
requests to be fulfilled.

3. Execute the batch file or UNIX shell script to start the Fulfillment server.

Guidelines:

The following Fulfillment server commands can be used one the fulfillment server
is running.

stat: prints statistics on the current state of the Fulfillment server

mstat: prints statistics on the Fulfillment server’s monitors

pstat: prints statistics on the Fulfillment server’s processes

tstat: prints statistics on the java thread activity in the Fulfillment server

stop: stops the Fulfillment server including all processing within the
Fulfillment server. It can resume processing with the start command. This is
similar to pausing the server

start: starts the Fulfillment server and should only be executed after a stop
has been issued.

restart: stops and restarts the Fulfillment server. This is similar to a soft
reboot of a Personal Computer

help: displays all valid commands for the Fulfillment server
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« kill: completely stops the server. To restart, you must rerun the script
» flush logs: forces the log buffers to write to disk

« listerror <n>: lists error log entry <n>. N can be a single number, a range,
or the word count to list the number of entries in the log

« listevents <n>: lists events log entry <n>. N can be a single number, a
range, or the word count to list the number of entries in the log

Testing Your Setup

Test your server setup by submitting a request and verifying that it shows up as
successful in the logs.

5.9.16 Setting up Remote Command of the Fulfillment Server

The Fulfillment server has the ability to receive remote commands through a
command port. These remote commands are sent through a remote command script
that runs on the same machine as the running Fulfillment server you want to
command. The script interacts with the server without the need of maintaining the
original command prompt used to start the server.

When a command is sent through this script, the command is sent, a response is
waited for, and the script ends. A connection to the Fulfillment server is not
maintained between issued commands. It is designed this way for the benefit of not
adding to the overhead of the Fulfillment server.

Prerequisites

You must be able to log on to the System Administration Console as
JTF_FM_ADMIN, or in a similar role, to perform the following steps.

Steps for Setting up a remote command script

For the purpose of sending commands to a running Fulfillment server, you create a
new script that executes every time a remote command is sent. To create a script to
send commands to port 99999, the body of the script should appear as:

For UNIX:

#/bi n/ csh
java oracl e. apps.jtf.fmengi ne. renot e. Renot eConmand- port 99999 / - host <r enot e
host nane>/  $*
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For DOS:
java oracl e. apps.jtf.fmengi ne. renot e. Renot eConmand- port 99999 / - host <r enot e
host nane>/ %

Note: If you are using an older version of the Fulfillment Server,
you may be using a version of the Fulfillment Server in which the
Remote Command class is found under the
"oracle.apps.jtf.fm.engine.processor" package as in
"oracle.apps.jtf.fm.engine.processor.RemoteCommand" instead of
"oracle.apps.jtf.engine.remote.RemoteCommand". It is also possible
that the version of the server you are running predates the use of
remote commands, in which case you need to update your version
with a patch.

In both cases, the value for the port must be set to match the value of
engine.CommandPort for the Fulfillment Server that you want to command. The
host can also be set for machines that exist on the same network if the Fulfillment
server is running on a different host.

The remote command also works from the command prompt with the following
command:

java oracl e. apps.jtf.fmengi ne. renot e. Renot eConmand- port 99999 / - host <r enot e
host nane>/ <comand>

5.9.17 Modifying Startup Scripts for Remote Commands

Perform the following steps to modify the startup scripts for remote commands.

Prerequisites
Set up the Remote Command of the Fulfillment Server.

Steps for Modifying the Startup Scripts

1. To set up the Fulfillment server so that it will listen to remote commands, add
the text -Dengine.CommandPort=##### to the Fulfillment server Startup Script.

2. To listen to port 99999 add the following text:
- Dengi ne. CormandPor t =99999
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5.9.18 Sending Remote Commands through a Script File

Perform the following steps to send remote commands through a script file.

Prerequisites

Set up the Remote Command of the Fulfillment Server
Modify Startup Scripts
Create a Script file

Steps

1.

Once you have created a script file (see Setting up a remote command script)
you can run it with any of the recognized Fulfillment server commands as
follows:

[script nane] [server command]

where [script name] is the name of the script file and [server command] is the
command you want to execute. Some of the commands received by the server
issues a response such as:

stat
the command that gets the Server statistics. If you have a script named
remote.script and you want to run

stat
against a Fulfillment server that is listening to port 99999 for remote commands
you would type:

remote. script stat

Data appears at the command prompt just as if you were to type stat from the
Fulfillment servers’ command prompt. Notice the following are the results of
sending a remote ‘stat’ command:

SEND NG>st at

RESPONSE>- -  PROCESSCR STATI STICS - -

>--Menory Use: 599.39Kb of 32767.99Kb -- 1.83%
>PROCESS MN TCR : Mnitor Started

>SREMOTE MN TCR : Monitor Sarted

>SAOMWAND MNTCR : Monitor Started

>SREQEST MN TCR : Mnitor Started

>fiprocesses: 5; running:5; idle:5; processing:0; dead:0
>Max | dl e Ti ne: 14 seconds; 59 ml|iseconds

>Bvent Log: Event s24.1 og
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>Eror Log:Errors24.1og
>ACTI VE THREAD( ) : 11

5.9.19 Troubleshooting Remote Commands

If you are having problems sending remote commands to the Fulfillment server,
verify the following questions:

Does your classpath include the apps.zip file?
Are you using an older version of the Fulfillment server?

You could be using a version of the Fulfillment server in which the
RemoteCommand class is found under "oracle.apps.jtf.fm.engine.processor"
package as in "oracle.apps.jtf.fm.engine.processor.RemoteCommand" instead of
"oracle.apps.jtf.engine.remote.RemoteCommand" as it is in its current form.

It is also possible that the version of the server you are running predates the use
of remote commands, in which case you need to update your version with a
patch.

Is the Fulfillment server you are trying to command currently running?

Is the Fulfillment server you are trying to command listening to the same port
that you are sending to?

5.9.20 Setting System Profile Options

Identify the profile options which you need to set for your specific implementation.
To change profile options, use the standard procedure outlined in the Oracle
Applications Users Guide. Set these profile options in any order.

JTF_FM_TEMP_DIR

This profile option sets the temporary directory for the Fulfillment engine. (This is
not a full path.)

JTF_FM_EVENTS_LOG
This profile option sets the events log name for the Fulfillment engine.

JTF_FM_ERROR_LOG
This profile option sets the error log name for the Fulfillment engine.
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JTF_FM_LOG_LEVEL
This profile option sets the level of logging detail.

JTF_FM_NUM_PROCESSES
This profile option sets the number of engine processes at start up.

JTF_FM_MIN_PROCESSES

This profile option sets the minimum number of processes that will run in the
Fulfillment server.

JTF_FM_MAX_PROCESSES

This profile option sets the maximum number of processes that will run in the
Fulfillment server.

JTF_FM_PROCESS_IDLE

This profile option defines the number of milliseconds a process is allowed to
remain idle before the Fulfillment server reevaluates it’s need and adjusts the
number of active processes.

JTF_FM_MAX_PROCESS_IDLE

This profile option may still be used in previous versions of the Fulfillment server. It
defines the maximum number of milliseconds a process is allowed to remain idle
before the processor starts reducing to the minimum.

JTF_FM_REFRESH_RATE

This profile option defines the time in milliseconds between the status checks that
the fulfillment server performs.

JTF_FM_DONE_DEST

This profile option redirects the "Finish" button to a predefined by Oracle Sales
Online targeted jsp page.

JTF_FM_CREATE_DEST

This profile option redirects the "Create" button to a predefined by Oracle Sales
Online targeted jsp page.
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5.10 Escalation Manager

5.10.1 Setting System Profile Options

Use the following table to identify the profile options that you need to set for your

specific implementation. You can set these profile options in any order you like.

To change profile options, use the standard procedure outlined in the Oracle
Applications Users Guide.

Table 5-21 Escalation Manager Profile Settings

Profile Option Value
Escalation: Close Only When De-escalated Yes
Escalation: Default Contact Type Employee
Escalation: Default Escalation Owner N/A
Escalation: Default Customer Contact Point Phone
Escalation: Default Document Type Task
Escalation: Default Employee Contact Point Work
Escalation: Default Escalation Level Level 1
Escalation: Default Status Open

Escalation: Default New Note Type

General Note

Escalation: Default Notify

Yes

Escalation: Default Reason Code

Slow Progress

Escalation: Default Reference Type

Escalation

5.10.2 Setting the Escalation Lookup Codes

Another required task in implementing the Escalation Manager is to set the
following lookup codes. The codes define the level, reason, contact type, and
reference of an escalation.

JTF_TASK_ESC_LEVEL
JTF_TASK_REASON_CODE
JTF_TASK_CONTACT_TYPE
JTF_TASK_REFERENCE_CODES
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Lookup Code JTF_TASK_ESC_LEVEL

The following table describes look up code JTF_TASK_ESC_LEVEL, which
describes escalation levels.

Code | Meaning

DE De-escalated

L1 Level 1

L2 Level 2

NE Never escalated

Lookup Code JTF_TASK_REASON_CODE

The following table describes look up code JTF_TASK_REASON_CODE, which
describes escalation reasons.

Code Meaning

SLOW-PROG Slow Progress
Unacceptable_Solution Unacceptable Solution
UNRES_OWN Unresponsive Owner
IMP_FAILING Implementation Failing

Lookup Code JTF_TASK_CONTACT_TYPE

The following table describes look up code JTF_TASK_CONTACT_TYPE, which
describes contract types.

Code | Meaning
CUST | Customer

EMP Employee

Lookup Code JTF_TASK_REFERENCE_CODES

The following table describes look up code JTF_TASK_REFERENCE_CODES,
which describes reference codes for the task.
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Code | Meaning

ESC Escalation

FYI

For Your Information

5.10.3 Starting the Background Workflow Process

Start the workflow process listed in the following table to ensure proper operation
of the Escalation Manager.

Table 5-22 Escalation Manager Workflow

Workflow Name | Description User

JTFEC Reactive Escalation Notification Escalation Manager

Use the following procedure to start the required background process.

Prerequisites
None

Steps

1.

In the System Administrator responsibility, navigate to Requests > Run.
The Submit a New Request window opens.
Select Single Request and click OK.

In the Submit Requests window, type W in the Name field and select Enter on
the keyboard.

The Reports window opens and displays report names that begin with w.

Select Workflow Background Process and click OK.

The Parameters window opens.

Type re in the Item Type field and select Enter on the keyboard.

The Item Type window opens and displays items that begin with the letters "re."
Select Reactive Escalation Notification and click OK.

Leave the Minimum Threshold and Maximum Threshold fields empty.
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7. Select Yes for both the Process Deferred and the Process Timeout fields and
click OK.

The Submit Request window appears in front.

8. Click Schedule on the Submit Request window.
The Schedule window appears in front.

9. Select Run the Job...Periodically.
More options appear for defining the time period.

10. Define the Start Time and the End Time.

WARNING: Be sure to define an end time. If the end time field is
blank, then the process runs indefinitely and cannot be shut off.

11. In the Rerun Every fields, enter the number of minutes that defines the interval
between job runs.

12. Select the From the Completion of the prior run box and click OK.

Guidelines

Set up Notifications in Oracle Workflow to ensure that notifications are sent to
e-mail.

5.10.4 Setting Up Escalation Status

There are three pre-defined Escalation Statuses:

« Open
= Working
» Closed

You may add your own user-defined statuses to these available statuses. Perform
the following steps to add user-defined statuses.

Prerequisites
None
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Steps

1. Inthe CRM Administrator responsibility, navigate to Task and Escalation
Manager > Setup > Define Escalation Status.

o o > W N

References

Enter the effective dates in the From and To fields.

Select escalation status flags.

The following table describes flags and definitions.

Table 5-23 Escalation Status Flag Definitions

Flag

Description

Assigned

Assigned to an individual

Working

In progress

Schedulable

Scheduled or re-schedulable

Accepted

Accepted by owner

Rejected

Rejected by owner

On Hold

Temporarily not active

Approved

Approved by management

Completed

Completed by owner

Cancelled

Cancelled by owner, creator, or
management

Delete
Allowed

Delete acceptable without cancellation

Closed

Completed and closed

Seeded

Pre-defined task status

5.10.5 Defining Escalation Reference Codes

A document or task may be combined with several other documents or tasks, such
as when fulfilling a service request requires a series of tasks to be performed and

Enter a user-defined status in a blank field in the Status column.

Enter a brief description of the status type in the Description field.

Click the Save icon to finish defining the Escalation status.
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related documents to be completed. In such a scenario, if one particular document
or task needs to be escalated, the escalation might not apply to the other related
items.

When you associate an Escalation Reference to the escalated item, you point to the
other related items and indicate their relation. There are two pre-defined Escalation
Reference types: FYI and Escalation.

« Use FYI (for your information) to indicate the task or document is related to the
escalated item, but is not escalated.

= Use Escalation to indicate the task or document is related to the escalated item
and also is escalated.

You can add other Escalation Reference types to customize your escalation
references. Use the following procedure to define customized reference types.

Prerequisites
None

Steps
1. Inthe CRM Administrator responsibility, navigate to Task and Escalation
Manager > Setup > Define Reference Type.

The Application Object Library: Reference Codes for the Task Lookups window
opens.

2. Enter the name of the new reference type in the first available row in the Code
column.

3. Continue entering information in the remaining cells of the row to describe the
escalation reference type and the effectivity dates.

4. Select the Enabled Check Box to make the escalation reference type available.

5. Save the new Escalation Reference and close the form.

5.10.6 Defining Escalation Reason Codes

You can add other escalation Reason Codes to customize your escalation reasons.
Use the following procedure to define customized reason types.

Prerequisites
None
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Steps
1. Inthe CRM Administrator responsibility, navigate to Task and Escalation
Manager > Setup > Define Escalation Reason.

The Application Object Library: Escalation Reasons Lookup window opens.
Select the first blank line.

Enter a code, meaning, and description.

Enter the effective dates in the From and To fields.

Select the Enabled flag.

o o M W N

Click the Save icon to finish defining the Escalation reason.

5.11 Business Rule Monitor

5.11.1 Setting Up the Business Rule Monitor

The Business Rule Monitor is a Workflow process which periodically checks the
defined business rules. The user that owns this workflow process receives
notifications when the process starts and stops, and also when errors are detected.
You must be defined to ensure that an owner of the workflow process exists and
that the notifications can be sent successfully. Usually, the workflow owner is the
system administrator. The BRM workflow administrator receives notifications when
the monitoring process starts and stops, and also when errors are detected. This is
to ensure that an owner of the workflow process exists and that notifications can be
sent successfully.

The BRM workflow administrator needs to have the following responsibilities in
order to start the Business Rule Monitor and receive workflow notifications.

« CRM Administrator responsibility: The workflow administrator can access the
Business Rule Monitor module through this responsibility. The administrator
can start the BRM and monitor the workflow process.

«  Workflow (Oracle Self-Service Web Applications): The workflow
administrator can check the workflow processes, and view workflow
notifications from the customize link Worklist region, if it is correctly set up in
your personal homepage.

« Preferences (Oracle Self-Service Web Applications): This is used to set up user
preferences, for example, whether to send or not send email notifications.
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There are two types of notifications that can be sent through the BRM:

Workflow Notification: This type of notification can be viewed from the
Worklist region if it is correctly set up in your personal homepage. They are the
BRM start and stop notification, and also any detected business rule.

Email Notification: This notification requires correct workflow and email
server setup and is usually done by your system administrator or workflow
administrator. To receive email notifications, select the Preferences
responsibility. Select General Preferences and select the right value in the "Send
me electronic mail notifications" field.

Note: You can assign Workflow and Preferences responsibilities to
many users, so that they can view workflow notifications if a
business rule is violated and they are responsible for taking care of
this automated escalation. There is only ONE BRM workflow
administrator who receives the notifications when the monitoring
process starts and stops, and also when errors are detected.

5.11.2 Defining the Owner of the Workflow Process

The owner of the workflow process is assigned to an existing user. This is typically
the system administrator or the workflow administrator.

Prerequisites

The designated workflow owner must already exist in order to assign the workflow
process. If no workflow owner exists, then the account must first be created.

Steps

1.

In the System Administrator responsibility, navigate to Security > User >
Define.

The Users window opens.

Enter an existing username in the Name field.

Enter a password in the Password field.

Do not press Enter to move to the next field, you must move your cursor.
Enter the password again.

Select the Workflow Administrator responsibility from the LOV in the
Responsibility field. This grants the responsibilities to the user.
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6. Select File > Save.

5.11.3 Setting System Profile Options

Perform the following steps to set the system profile option: Business Rule Monitor
Workflow Administrator.

Prerequisites
None

Steps
1. Inthe System Administrator responsibility, navigate to Profile > System.

The Find System Profile Values window opens.
2. Enter the following in the Profile field:

Busi ness Rul e Moni tor Vrkfl ow Admini strator
3. Click Find to open the System Profile Values window.

4. Enter the name of the workflow administrator in the Site field.

This user is the one that you previously named in Defining the Owner of the
Workflow Process.

5. Select File > Save.

5.11.4 Starting the Background Workflow Processes

There are four predefined workflow item types. One item type, JTFBRM, is internal
to the Business Rule Monitor and has no user-defined attributes. The three item
types have specific attributes defined for each process. These attributes are
maintained within the Business Rule Workbench, and can be viewed by clicking the
button next to the workflow field. The following table describes the preseeded
workflow processes.

Table 5-24 Preseeded Workflow Processes

Iltem Types Description

JTFBRM Business Rule Monitor Main Process
JTFBRMDF Business Rule Monitor Defect Process
JTFBRMPR Business Rule Monitor Task Process
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Table 5-24 Preseeded Workflow Processes

Iltem Types Description

JTFBRMSR Business Rule Monitor Service Request Process

Proper operation of the Business Rule Monitor requires that these four background
workflow processes be started before starting the Business Rule Monitor. Use the
following procedure to start these background processes.

Prerequisites
None

Steps

1.

In the System Administrator responsibility, navigate to Requests > Run.
The Submit a New Request window opens.
Select Single Request and click OK.

In the Submit Requests window, type W in the Name field and select Enter on
the keyboard.

The Reports window opens and displays report names that begin with w.
Select Workflow Background Process and click OK.

The Parameters window opens.

Type bu in the Item Type field and select Enter on the keyboard.

The Item Type window opens and displays the four Workflow background
processes required by the Business Rule Monitor.

Select one of the four Business Rule Monitor processes and click OK.
Leave the Minimum Threshold and Maximum Threshold fields empty.

Enter Yes in the Process Deferred field, and in the Process Timeout field and
click OK.

The Submit Request window appears in front.
Click Schedule on the Submit Request window.
The Schedule window appears in front.

Select Run the Job...Periodically.
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More options appear for defining the time period.

10. Define the Start time and the End time.

WARNING: Be sure to define an end time. If the end time field is
blank, then the process runs indefinitely and cannot be shut off.

11. Inthe Rerun Every field, enter the number of minutes that defines the interval
between job runs.

12. Select the From the Completion of the prior run box and click OK.

13. Repeat this entire procedure for each of the four workflow background
processes.

Guidelines

Set up Notifications in Oracle Workflow to ensure that notifications are sent to
e-mail.

5.11.5 Starting the Business Rule Monitor

The Business Rule Monitor monitors the active business rules. In the Business Rule
Monitor, you must indicate how often the monitor checks the rules. Once the
Business Rule Monitor is started, there is no need to start it again, even after
defining new business rules. Perform the following steps to start the Business Rule
Monitor.

Prerequisites

The four Workflow background processes for the Business Rule Monitor must be
started before starting the Business Rule Monitor. If you have designed customized
workflow background processes, then the background processes for these
workflows must also be started. In addition, the Business Rule Monitor Administrator
profile option must be set.

Steps

1. Inthe CRM Administrator responsibility, navigate to Business Rule Monitor >
Business Rule Monitor.

The Business Rule Monitor opens.
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2. Enter the time period in the Interval field. Enter a time unit (minutes or hours)
in the UOM field.

3. Click Save.
4. Click Start to activate the Business Rule Monitor.
A dialog box confirms that the Business Rule Monitor started successfully.

Click Workflow Monitor to view details of this process.

Guidelines
After the monitor is started, the Stop button appears. Click Stop to stop the monitor.

Click Refresh Status to get an immediate status on the BRM main process.

5.11.6 Defining a Business Rule

In addition to the pre-defined business rules provided with the Business Rule
Monitor, you can define your own business rules. Use the following procedure to
define a business rule.

Prerequisites
None

Steps
1. Inthe CRM Administrator responsibility, navigate to Business Rule Monitor >
Business Rule Workbench.

The Business Rule Workbench window opens.
2. Enter values for the following:
« Name: The name of the new business rule.
» Object: The object for which the rule will operate.
» Check Rule Every: The time interval that you want.
« Effective: Use the LOV to select the date to start the rule.
Only put an end date to stop the rule.
« Owner: Mandatory field.

«  Workflow: Chose a workflow from the drop down menu.
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Attributes can be defined for the Workflow and an Owner for the business rule.

3. Use the fields in the Simple tab to define conditions when the business rule is
triggered.

4. Click Validate to check the syntax of the PL/SQL statement defined in the
Simple tab. The syntax check verifies whether or not the syntax is correct.

A dialog box confirms that the syntax validation was successful.
5. Click OK.
6. Click Generate.

A dialog box confirms that your business rule has been generated.

7. Select File > Save.
Guidelines

You can define a rule but until you add the effective date, it will not run. Adding the
effective date mandates that you select an owner for the business rule.
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Verify the Implementation

6.1 Oracle CRM Application Foundation Implementation Verification

Tasks

This chapter contains material useful in verifying the implementation of the Oracle
CRM Application Foundation modules.

6.1.1 Use the Diagnostic Tests

After completing the implementation steps of the Application CRM Foundation
module, run the entire suite of diagnostic tests available through the HTML
Administrator Console. Implementors would most likely either verify using the
Basic tab or the Advanced tab. In the Basic tab, you can run the following tests:

RunAll

UserTest
AOLTests
PropertyManager
UserProfile
AKData

Security Manager

In the Advanced tab, you can modify the parameters used in the previously
mentioned tests.

Each test generates a report if a problem is encountered. The report identifies the
problem and provides a suggested resolution to the problem.
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6.1.2 Verification Task List per Module

Table 6-1 CRM Application Foundation Verification List

After you complete the configuration and setup of all the Oracle CRM Application
Foundation modules, verify that you can perform the tasks outlined in the
following table.

JTF Module

Task

Reference

HTML Tech Stack

Login to HTML Applications as System
Administrator

Oracle CRM Technology Foundation
Concepts and Procedures

User Management

Register and approve a new user

Oracle CRM Technology Foundation
Concepts and Procedures

Resource Manager

Creating an employee resource

Oracle CRM Application
Foundation Implementation Guide

Resource Manager

Creating a group resource

Oracle CRM Application
Foundation Implementation Guide

Resource Manager

Importing resources

Oracle CRM Application
Foundation Implementation Guide

Resource Manager

Defining a resource group

Oracle CRM Application
Foundation Implementation Guide

Resource Manager

Defining a resource team

Oracle CRM Application
Foundation Implementation Guide

Territory Manager

Creating an individual territory

Oracle CRM Application
Foundation Implementation Guide

Territory Manager

Using the Lookup Tool to find a salesperson

Oracle CRM Application
Foundation Concepts and
Procedures

Task Manager

Creating a task

Oracle CRM Application
Foundation Concepts and
Procedures

Notes

Creating a note for a task

Oracle CRM Application
Foundation Concepts and
Procedures
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Table 6-1 CRM Application Foundation Verification List

JTF Module Task Reference

Assignment Manager Assign a resource to a task Oracle CRM Application
Foundation Concepts and
Procedures

Assignment Manager Assign a resource to an escalated task Oracle CRM Application
Foundation Concepts and
Procedures

Escalations Escalate a task Oracle CRM Application
Foundation Concepts and
Procedures

You must be able to complete each task successfully, or your Oracle CRM
Application Foundation modules will not work properly. If you are unable to
complete a task successfully, then correct the problem before continuing.
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Diagnostics and Troubleshooting

This chapter contains material useful in diagnosing and troubleshooting the
implementation of the Oracle CRM Application Foundation modules.

7.1 Common Implementation Errors

Note: The Oracle CRM Diagnostic Tool is useful in pinpointing
problems with the setup and configuration of the many CRM
modules. It is available through the CRM System Administration

Console.

This section contains information on some of the common implementation errors
associated with implementing each of the following CRM Foundation modules:

Resource Manager
Notes

Territory Manager
Assignment Manager
— Gantt Chart

Task Manager
Interaction History
Fulfillment
Escalation Manager

Business Rule Monitor
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7.1.1 Resource Manager

7.1.1.1 Unable to Import a Resource
If you entcounter this problem, try performing the following procedures:

1.

Run the concurrent program "Resource Manager Diagnostics" available under
CRM Administrator Responsibility. If it is not available, then perform the the
following:

a. Log on using the System Administrator responsibility.

b. Inthe "Executable" option, under "Concurrent Program", query for
"Resource Manager Diagnostics."

c. Enable it by checking the checkbox.

After the concurrent program completes, view the log file generated by pressing
the "View Log" button. See if any errors are reported.

Correct any errors as reported in the concurrent program log. Then, try to
import again.

7.1.1.2 Unable to Save a Resource
If you encounter this problem, try performing the following checks:

1.

In SQL*Plus, connecting as apps/apps, enter the following:
SQL> desc xni gen

If this returns the statement that object xmlgen does not exist, then ensure that "apps"
has execute privilege on "xmlgen."

In SQL*Plus, connecting as apps/apps, enter the following:
SQL> select status fromall_objects where object_name = 'JTF_USR HKS' ;

If this returns a status of 'INVALID,’ then alter package JTF_USR_HKS and compile
the body. Repeat this check until the status becomes 'VALID.’

In SQL*Plus, connecting as apps/apps, enter the following:
SQL> select status fromall _objects where object_name = 'JTF_RESOURCE_UTL';

If this returns a status of 'INVALID,’ then create this view in the apps schema
and compile the JTF_RESOURCE_UTL package body.

Create or replace view IEM_EMAIL_ACCOUNTS_V as:
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SQL> select b.server_group_id interaction_center_id,
a.account _name config_nane,
to_char(a.emil _account _id) value_type
fromiemiememail _accounts a, iemiememail _icntr_maps b
where a. emai|l _account i d=b. emai| _account id;

7.1.1.3 Unable to See Resource Name

This problem may occur in the CRM or Application Foundation modules, the LOVSs,
and similar items.

In SQL*Plus, connecting as apps/apps, enter the following:
SQL> select count(*) fromjtf_rs_resource_extns where source_nane is null;

If count(*) is non-zero then run the concurrent program "Synchronize Employees"
which is available under the CRM Administrator responsibility.

7.1.1.4 Cannot Invoke Salesperson Form from AR Menu

This problem occurs when invoking the Salesperson form from the Accounts
Receivables menu. It occurs under the following circumstances:

(Navigation path: Setup -> Transactions -> Salesperson)

» Double click from the navigator menu and a small blue window with a red
bar(row) is received with no legible fields or label markings.

« Press the Tab or Enter key and a calendar window appears also with no legible
fields/label markings.

In either case the user is unable to close the form or application unless the File ->
Close or Exit toolbar menu option is used.

To solve this problem apply patch 1799597. Ensure that you read the README
mentioned in the patch.

7.1.1.5 Accounting Flexfield LOVs Display Parent Values
Follow the following steps to define the accounting flexfield:

1. Navigate to the General Ledger module: GL -> Setup -> Financials ->
Flexfields -> Key -> Values.

In this Find form, check for find values by Key flexfield, and in the Title Field
choose from the list of values 'accounting flexfield’ and then press Find. You
will see a long list of values. At the right, you have a box with an "Effective"
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5.

title, check for its other title "Hierarchy, Qualifiers." A parent check box is
checked for some of the values and not checked for others.

You can add values and check them as parent but this is not necessary, it is
enough for you to write down few values that are checked as parents. (For
example, the first value 1000- Total asset is checked as one).)

Navigate to Accounts Receivables: Setup -> Transactions -> Autoinvoice ->
Salespersons.

Receivables uses the general ledger accounts that you enter here in combination
with your AutoAccounting rules to determine the default revenue, freight, and
receivable accounts for your invoices.

Create a new salesperson: Enter a name and a sales credit type from the list. In
the next three fields enter the Accounting Flexfield for your Revenue, Freight,
and Receivables Accounts.

If you open the list and see account aliases, then click OK. You will get a form in
which you can enter a department value and an account value.

In the account values list, you can see the parent values observed in step 2. (For
example, the first value might be 1000- Total asset.)

You can choose this value and save the transaction.

It must be emphasized again that these parent values should not appear in the list
and you should not be able to select them. These are only summary accounts and
not accounts you can use for regular processes, which means that you cannot enter
amounts to accounts which are checked as parents.

7.1.1.6 Same Resource Showing Twice in Define Resource Form

In this case, both resources have the same transaction number, but one record
displays the salesperson number, and the other does not.

To verify this problem, perform the following steps:

1.
2.

In the Define Resource form, note the resource number for both the records.

If the resource number is the same (for example, 10015), then run the following
query below:

SQL> select res.resource_id,sr.salesrep_id,sr.org_id
fromjtf_rs_resource_extns res,jtf_rs_sal esreps sr
where res.resource id = sr.resource_id
and res. resource_nunber = 10015;
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If the output of this query results in two or more records with the same
resource_id, and the same org_id, but, different salesrep_id then it is bad data.
For example, the sample output following would be considered bad data;

RESOURCE_| D SALESREP_I D ORG_ID
100000016 100000019 2
100000016 100000054 2

This kind of data can never be created using the Define Resource form, or, any
of the resource manager public APIs.

To clean up this data, perform the following steps:

1.

There are two records, one, for example, with a salesrep humber non NULL
value and other with a NULL value. Identify which is the one you want to
remove. To Identify the IDs, run the statement below.

SQL> select res.resource_id,sr.salesrep_id,sr.org_id,
sr.sal esrep_nunber
fromjtf_rs_resource_extns res,jtf_rs_sal esreps sr
where res.resource id = sr.resource_id
and res. resource_nunber = 10015;

This will return two records. Note down the resource_id,salesrep_id and the
org_id of the record which you want to delete.

Run the delete statement below. Assuming, you decided to delete record with
salesrep_id 100000019, org_id 2, it would look like:

SQL> delete fromjtf_rs_sal esreps
where sal esrep_id = 100000019
and org_id = 2
and resource_id = 100000016;

This should cleanup all bad data.

WARNING: You are actually deleting physical records from the
database. This has the RISK of leaving behind dangling foreign
keys in other tables in other applications. Confirm the check for
FOREIGN KEYS before deleting records as suggested above.
Otherwise, you may end up corrupting your database.

Contact Oracle Support in case of any doubt.
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7.1.1.7 Salesperson Migration Issues
There are several issues that can affect migration of salesperson data.

ERROR ORA-20002 Errors may occur when accessing the following Accounts
Receivables forms:
«  ARXTWMAI

Transaction Entry: FRM-40735 Pre-form trigger raised unhandled exception
ORA-20002.

«  ARXRWMAI

Receipt Entry: FRM-40735 New form instance trigger raised unhandled
exception ORA-20002.

«  ARXCWMAI

Account Detail: FRM-40735 WHEN-NEW-FORM-INSTANCE trigger raised
unhandled exception ORA-20002.

To diagnose and resolve, perform the following checks:
1. In SQL*Plus, connecting as apps/apps, enter the following:

SQL> set pages 999
SQL> set long 9999
SQL> select text fromdba_views where view nane = ' RA SALESREPS' ;

Check to see if the results of the FROM clause in the view definition list any of
the following tables or views:

« RA_SALESREPS _ALL RA
« AS_SALESFORCE ASF
« RA_CUSTOMERS RACUS
. PER_PEOPLE_X HR
« AS_LOOKUPS ASL
If so, then log a bug against Accounts Receivable.
2. In SQL*Plus, connecting as apps/apps, enter the following:

SQ>sel ect table_nane
fromall_synonyms
where synonym nanme ='RA SALESREPS ALL' and owner = 'APPS';
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If the result of this query is RA_SALESREPS_ALL, then the salesperson
migration has not happened. If you do want the migration to happen, then you
must apply the following patches:

= 1638958
« 1757827.

Else, log a bug against Accounts Receivable.

ERROR ORA-01422 This error also occurs when invoking the Accounts
Receivables Forms.

FRM-40735: PRE-FORM Trigger Raised Unhandled Exception ORA-01422.
ORA-01422: Exact fetch returns more than requested number of rows.

To resolve, perform the following procedures:

1.

In SQL*Plus, connecting as apps/apps, enter the following:

SQL> set pages 999
SQL> set long 9999
SQL> select text fromdba_views where view nane = ' RA SALESREPS' ;

Check to see if the results of the FROM clause in the view definition list any of
the following tables or views:

« RA_SALESREPS ALL RA

« AS_SALESFORCE ASF

« RA_CUSTOMERS RACUS

. PER_PEOPLE_X HR

« AS_LOOKUPS ASL

If so, then log a bug against Accounts Receivable.

In SQL*Plus, connecting as apps/apps, enter the following:

SQL> sel ect tabl e nane
fromall_synonyns
wher e synonym name = RA_SALESREPS ALL’' and owner = 'APPS ;

« If the result of this query returns RA_SALESREPS_ALL, then Salesperson
migration has not happened. If you do want the migration to happen, then
apply the following patches:

— 1638958
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- 1757827
Else, log a bug against Accounts Receivable.

« If the result of this query returns JTF_RS_SALESREPS, then the salesperson
migration has occurred. In this case, run the following in SQL*Plus
connected as apps/apps:

SQL> delete fromjtf_rs_sal esreps
where salesrep_id=-3 and org_id is null;

If the above command deletes one record, then perform a COMMIT,
otherwise, perform a ROLLBACK operation.

WARNING: You are actually deleting physical records from the
database. This has the RISK of leaving behing dangling foreign
keys in other tables in other applications. Confirm the check for
FOREIGN KEYS before deleting records as suggested above.
Otherwise, you may end up corrupting your database.

Contact Oracle Support in case of any doubt.

7.1.1.8 APP-PER-50022 Error
This error occurs when pressing the "View" Button in Define Resource Form.

APP-PER-50022: Oracle HR could not retrieve a value for the User Type profile
option. Please ensure it is set properly for your responsibility.

First ensure that the resource currently being shown in the screen is of type
"Employee."

To resolve this issue, you need to update the profile "HR:User Type" at the
application level by selecting a valid value from the LOV. If you select "HR User",
then make sure that the user currently logged in has the "US HRMS Manager"
responsibility attached to it.

7.1.1.9 JTF- Post Vertical User Hook Error
This error occurs while attaching a role type of Sales Compensation to a resource.

First determine whether of not the resource has been saved. If the result is:
. No

Save the resource, then try again.
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«  Yes

Try to assign a different role type such as Service, or, Sales and Telesales to the
resource, and confirm whether or not you are able to save. If you are able to
assign a role other than Sales Compensation to a "saved" resource, but, are
unable to assign the Sales Compensation role, then you need to log a bug
against the Oracle Sales Compensation product.

7.1.1.10 ORA-01422 Error
ORA-01422: Exact fetch returns more than requested numbers of rows.

This error occurs while adding a group role to a resource in Define Resource Form,.
and indicates that an unexpected error was encountered in INSERT_REP_
MANAGER.

To resolve this, please contact your system administrator.

Causes This problem is very likely caused when there is more than one snapshot
view log on JTF_RS REP_MANAGERS table. To confirm, run the following query
in SQL*Plus, connected as apps/apps:

SQL> insert into rep_tenp
(denorm mgr _i d,
resource_id,
person_id, category,
manager _per son_i d,
group_i d,
hi erarchy_t ype,
creat ed_by,
creation_date,
| ast _updat ed_by,
| ast _updat e_dat e,
| ast _update_| ogin,
reports_to_flag,
start _date_active,
end_date_active,
par_role_relate_id,
child role relate_id,
obj ect _versi on_nunber)
val ues
(-9, 1, 1, "enployee', null, 1, "x', -1, sysdate, -1, sysdate,

-1, 'y', sysdate, null, -1, -1, 1);

If the result is:
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ORA-01422: Exact fetch returns more than requested numbers of rows.
then more than one snapshot log exists.

There should be only one snapshot log on the table MLOG$_JTF_RS_REP_
MANAGERS. Check to see if there are any more, and drop them. If after ensuring
that there is only one snaphot log MLOG$_JTF_RS_REP_MANAGERS, the error
still occurs, please log a bug against Oracle Sales

7.1.1.11 JTF_RS_TERR_EDDT_GRTR_SRP_EDDT Error

This error occurs when the territory Start and End dates are out of range with
salesperson dates.

This is a data problem. To fix it, perform the following steps:

1. Find out the maximum Start_date_active value and minimum End_date_active
value for a salesrep_id across all org_id from JTF_RS_SALESREPS table. (Be
aware that the end_date_active value can be NULL.)

2. Forthe salesrep_id in step 1, find the Start_date_active and End_Date_active
from RA_SALESREP_TERRITORIES table. (Be aware that the Start_date_active
and end_date_active values can be NULL.) You may get multiple records.

3. Forevery record in step 2, verify whether or not the dates fall within the dates
in Step 1.

» Ifyes, then no further action required.
« If no, then proceed to step 4.

4. Update the Start_date_active, End Date_active in RA_SALESREP_
TERRITORIES Table with the Dates from Stepl.

5. Repeat Steps 1 through 4 for all the salesrep_id in JTF_RS_SALESREPS table.

7.1.1.12 HTTP 404 Error

This error occurs while trying to log in to an HTML application. It is an
environment issue. Perform the following steps to correct the problem.

1. Shutdown Netscape.

2. Remove fat.db, netscape.hst, and cookies.txt.
3. Clear disk cache and memory cache.
4

Try logging in again.
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7.1.2 Notes

7.1.1.13 Invalid User Error
The following error may occur.

Invalid User- Resource link, Contact Your System Administrator

This problem has been observed in the Service Request form. But, it could occur
other places too. While creating or updating a Service Request in the "Owner" field,
it is possible to pick a resource from the LOV, and get the "Invalid User - Resource
link" error.

This problem occurs if the currently logged in user (as defined in FND_USER), is
not mapped to a proper resource who you are trying to update the SR with.

Ensure that the user ID of the resource that you pick in the LOV matches the one
with which the user is currently logged in. This restriction is due to the fact that in
trying to create interactions, there is a validation that the user must be a resource.

7.1.2.1 Script Failed Error
The following error message may occur:

ORA-29856: error occurred in the execution of ODCIINDEXDROP routine.

ORA-20000: interMedia Text error: ORA-01722: invalid number ORA-06512: at
"CTXSYS.DRUE", line 126 ORA-06512: at "CTXSYS.TEXTINDEXMETHODS",
line 226 ORA-06512: at line 1.

To resolve this issue, configure your environment to include Intermedia text. For
more information, refer to the Oracle 8i Intermedia Text Installation Manuals FAQ or
contact Oracle Support.

7.1.3 Territory Manager

7.1.3.1 Troubleshooting Tips
The following tips can be useful:

« Set up territories in hierarchical fashion for easy maintenance.

« Make the territories as generic as possible.
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« If you create a territory and do not assign resources to it, then the Territory
Manager does not return this territory as a qualifying territory.

= You can create your own module specific "Catch All"

7.1.4 Assignment Manager

7.1.4.1 Troubleshooting Tips
The following tips may help you in the use of Assignment Manager.

1. Assignment Manager supports the following resource categories used in
Resource Manager:

«» Employees

» Parties

« Partners
« Groups
« Teams

« Supplier Contacts
Refer to Resource Manager for detailed information on resource categories.

2. Ifthe Unassisted assignment option is selected, predefined selection criteria will
not be available.

3. Shift schedules, which are used in the Gantt Chart, are defined in Foundation
Calendar.

4. You can use the profile option in the Task Manager > Default Task Owner to
set the default to a specific owner for a stand-alone task or a task associated to a
service request.

7.1.5 Gantt Chart

In many cases, if the Gantt chart in the Assignment Manager window does not
work properly, the problem stems from an incorrect configuration of the TCF
Servers.
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7.1.5.1 Common Issues

In general, problems with the configuration and setup of the Gantt chart fall into the
following categories. They are:

« Gantt Chart Does Not Appear

« Cannot Connect To TCF Server

= No Resources Are Visible

Resolution If you are experiencing problems with the Gantt chart, then do the
following:

1. First perform the steps listed under General Advice.

2. If this does not clear up the problem, then see the individual sections for the
listed problems.

WARNING: These instructions for implementing the TCF servers
are NOT valid if the AOL TCF Server patch (bug # 1699404) has
been installed.

This patch is owned by the Oracle Applications Object Library
(AOL). Contact AOL support for issues with this patch.

7.1.5.2 General Advice

The following items are general suggestions to follow in troubleshooting problems
relating to the Gantt chart.

1. Clear out the JInitiator jcache directory, close and restart the browser, and try
again. Old, cached JAR files could be causing the problem.

2. Shut down and restart the TCF server. If a patch is applied, then the new code is
not picked up by the runtime engine until the TCF server is restarted.

3. Check the Jinitiator Console Window for exceptions or informational messages.
You can activate the Console Window by selecting the “Show Console” check
box in the JInitiator Control Panel. You must then close and restart the browser.

4. Ensure that there are no invalid objects in the database. You can use the
adadmin utility for this purpose.

5. Ifaninvalid object is found, correct the problem, then make sure that the
offending form is recompiled (along with its libraries). This can be done
through the adadmin utility.
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6. If problems continue, then perform the steps listed in the following sections as
appropriate:

« Gantt Chart Does Not Appear
« Cannot Connect To TCF Server

= No Resources Are Visible

7.1.5.3 Gantt Chart Does Not Appear

One of the most common problems is that a Form does not display the Gantt chart
properly. One, or both, of the following symptoms can occur:

1. The Form displays an empty blue or gray area where the Gantt chart should
reside.

2. ThelJInitiator console window throws a ClassNotFoundException, referring to
classes in oracle.apps.jtf.gantt.
Causes The following are some of the possible causes for this condition:

1. Thejtfgantt.jar file has not been downloaded onto the client machine. The
JInitiator console window must include a line similar to the following:

Qpeni ng http://<serverHost > QA JAVA oracl e/ apps/jtf/jar/jtfgantt.jar no
pr oxy

It should not read:

Uhabl e to contact http://<serverHost> QA JAVA <sone path>/jtfgantt.jar
2. Class files are missing from jtfgantt.jar or fndlist.jar.
3. Anold version of jtfgantt.jar resides in the JInitiator jcache directory.

4. The appsweb.cfg file is customized and does not include an entry for /OA _
JAVA/ oracle/apps/jtf/jar/jtfgantt.jar.

5. The appsbase.html file, or the HTML page used to launch applications, is
customized and does not pick up the archive tag from appsweb.cfg.

7.1.5.4 Actions to Take
1. Clear out the JInitiator jcache directory on the client and restart browser.

2. \Vrify that jtfgantt.Ist is included in fndlist.jar.

a. First take a copy of fndlist.jar, then rename it to fndlist.zip, and use Win Zip
to open the file.

7-14 Oracle CRM Application Foundation Implementation Guide



Common Implementation Errors

b. Verify that jtfgantt.Ist in fndlist.jar lists approximately 26 class files.

3. Perform the actions described in step 2, but for jtfgantt.jar and verify that it
contains the files listed in jtfgantt.lst.

4. Ensure that the JInitiator console window does not list any class files as being
individually downloaded.

If this is the case something is wrong in the installation. Class files should be
downloaded within JAR files and nowhere else.

5. If Actions 2 through 5 do not verify properly, then perform the following
additional actions:

a. Force the regeneration of the FND and JTF JAR files through the adadmin
utility.

b. Restart the Forms (web) listener and the Forms server. Clear out the
JInitiator cache directory, and restart the browser.

c. Try Actions 2 through 5 again.

6. Critical! Verify that all high priority FND (AOL) patches as listed in Metalink
are applied.

7. For the items listed as 4 and 5 under Causes in this section, launch the
applications. In Netscape Navigator, select "View Source" and verify that /OA _
JAVA/ oracle/apps/jtf/jar/jtfgantt.jar is included in the archive tag.

If it is not included, then add the entry to files appsweb.cfg and appsbase.html.

7.1.5.5 Cannot Connect to TCF Server

Note: If you are unable to establish a TCF connection, then a
generic TCF setup problem could exist. Contact your System
Administrator or Oracle Support representative to resolve the issue.
Until this issue is resolved, Gantt will not work properly.

The Menu and View Tree forms are owned by the Oracle
Application Object Library (AOL). It could be that this is an issue
that needs to be resolved within that context.

There are several different errors that you could encounter when attempting to
connect to the TCF server, and several different reasons each error could occur.
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In general, there are three basic types of errors that can affect server connection:

The client application is unable to connect to the TCF server.
The TCF server is unable to connect to the database.

The application hangs upon connecting to the TCF server.

Each type of error is discussed in the following sections.

Unable to Connect to the TCF Server The standard error message for this is:

"The application was unable to establish a network connection with the TCF
SocketServer listening on port: <port> on host: <host>. Please contact your
system administrator."

The exact message may vary slightly between versions and products.
You may also see the following:
"Unable to connect to dispatcher."
Items to check:
«  Was the TCF server ever started?
The system administrator should be able to check if the process is running.
» What host and port names were used to start the server?

Verify that the profiles TCF:HOST and TCF:PORT on the client point to the TCF
server to which you are trying to connect. The best way to check them is to use
the Help > Diagnostics > Examine utility to check profiles just before launching
the TCF application. Verify the user-level profiles, also, as well as the site-level
profile options. See Step 4b: Verify the TCF Host Name and Port Number for
details of this process.

=« Isthe TCF server host machine accessible from the client?

Open a TELNET to the host to see if it is reachable.

7.1.5.6 Unable to Connect to the Database

The standard error message for this is:

"The TCF SocketServer running at <host>:<port> was unable to make a JDBC
connection to database <dbname>. This may reflect heavy load on the system, or

a problem with the indicated database. If this problem persists, please contact
your system administrator."
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You may also see the following:

"Unable to set context."”

Items to check:

Is there a ClassNotFoundException or OutOfMemoryError raised?

Check the server logs to see if either of these errors occurred. Sometimes a
ClassNotFoundException or a OutOfMemoryError is raised while the server is
attempting to connect will result in this error. The former are usually
configuration issues, the latter suggests that it is advisable to start your TCF
server with more memory.

Is the database actually up and running?
Try connecting from SQL*Plus to verify.
Are you connecting using DBC files?

For release 11.5 versions and above, it is now required that DBC files be used to
connect to the database. The TCF server must be started with a new argument
"DBC=", pointing to a .dbc file that should be located under $FND_TOP/secure.
This command should read:

jre oracl e. apps. fnd. t cf. Socket Server <port#> DBC=$FND TCP secur e/ xxx. dbc

It is important that the path to the .dbc file be specified. Because the TCF server
can connect to multiple databases, it does not depend on the specific .dbc file
you pass in, rather it relies on the path where those .dbc files are located to look
up multiple .dbc files.

If the TCF server is not started with the DBC argument or it cannot find the .dbc
file in the specified directory, this type of error might occur. Remember that the
TCF server could be looking for a different .dbc file than that with which you
started it. Check the server logs and see if it reports any errors while trying to
load the .dbc file.

Are the .dbc files properly formatted?
A similar type of error can also occur if the .dbc file was improperly formatted.
A very common error to see on the server when this happens is:

Id.so.1: ... libocijdbc8.so: open failed: No such file or directory
(11 boci j dbc8. so)
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This indicates that the server is attempting to use the THICK JDBC drivers to
connect to the database, which is not supported. Verify that the .dbc file
specifies that the THIN drivers be used. The .dbc file must contain the line:

APPS JDBC [R VER TYPE=TH N

The .dbc file also needs to contain the following variables that identify the
database to use:

DB _HOBT=
DB_PCRT=
DB _NAMVE=

These variables correspond to the database information in the tnsnames files.
The THIN drivers cannot use the TWO_TASK to resolve the database name,
you must provide this information explicitly. (The DB_NAME is actually
optional if the TWO_TASK variable and database SID are the same, but it’s
good practice to use it, in any case.)

7.1.5.7 Application Hangs Upon Connecting to the TCF Server

Try connecting using the ServerControl class if hanging problems are reported. If it
still hangs, then typically this indicates one of the following:

1. There is abug in the code, or that there is an environment setup problem.

Check the debug output on the server to see if there is anything obvious that
needs to be corrected, and check the bug database to see if this type of problem
has been previously reported.

2. The wrong protocol was used to establish the connection.

Ensure the TCF server is speaking the same protocol as the client. Supported
protocols are SOCKETS, HTTP, and SSL. The client must use the same protocol
as the Forms server.

3. The TCF server attempts to exit the loop in which it accepts connections from
the client, but does not really do so.

This type of error is probably the most common. In release 11.5.2 and beyond, if
the TCF server stops accepting connections from the client, then it closes the
socket and exits immediately.

Unfortunately, this does not explain why the TCF server stopped accepting
connections in the first place. Determining the reason is a more involved
process. One very possible reason is the TCF server ran out of memory. The
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most useful thing to do in this case is to check the debug output and see if any
errors are logged.

7.1.5.8 No Resources Are Visible

If you experience problems with the proper display of resources in the Gantt chart,
then perform the steps listed in the following table.

Table 7-1 Trouble Shooting the TCF Server

Tip Description

View the JInitiator console window | View the JInitiator console window error messages
error messages. and the exceptions thrown.

Consult the TCF server log file. View the TCF server log file for relevant information.
Verify the TCF server status. Use the ServerControl class to check whether or not

the TCF server is accepting connections on the host
and port on which it was started.

7.1.5.9 View the Jinitiator Console Window Error Messages

The single most useful thing that you can do to do to troubleshoot server problems
is check the JInitiator Console window on the client machine. Some debug
information is output by default, and errors raised here are often very descriptive
and give a good indication of what the problem is.

If that window is no longer available, then restart the browser, set the "Show
Console" check box in the JInitiator control panel, and restart the application.

The items listed below are a few of the exceptions that can be thrown, and reported
in the JInitiator Console window.

1. java.net.ConnectException: Connection refused

Usually this means that the TCF server is not running, or that the TCF:HOST /
TCF:PORT profile options are pointing to a wrong server or port.

2. Gantt TCF HOST:<http://hosthame> PORT:<port#>
This refers to the TCF:HOST/PORT settings passed into the Gantt chart.
As described in Step 4b: Verify the TCF Hostname and Port Number:

« If the host name is prefixed with "http://", then the client attempts to
connect to the TCF server using the HTTP protocol.
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« If this prefix is missing, then the client attempts to contact the server using
the SOCKETS protocol.

WARNING: If the TCF server and client do not use the same
mode, then the client cannot establish a connection.

3. gantt: tcfSetAppsContext <filename>.dbc

The <filename> listed in the error must exactly match the filename that was
specified in the DBC parameter when starting the TCF server. If this is not the
case, then rename the file to match that specified in the DBC parameter.

4. java.lang.ClassNotFoundException:javax.net.ssl.SSLSocket

The client side SSL libraries are meant to be included with Jinitiator. However,
in some older versions of JInitiator, this did not happen due to US export
restrictions that have since been lifted.

If this exception occurs, then you must install the latest version of Jinitiator
(1.1.7.32 or higher). If necessary, contact Oracle Support for help with this step.

5. java.io.EOFException
... <3-5lines of text>  at
oracle.apps.fnd.tcf.net.SocketServerConnection.readBigUTF(
SocketServerConnection.java)

This exception usually occurs after the client tries to connect to the TCF server
using the wrong communication protocol. The message indicates that the
TCF:HOST profile is not set correctly. Refer to Step 4b: Verify the TCF Hostname
and Port Number for details.

6. gantt: addbar failed, resource not found (<Resource Type> - <Resource 1d>)

One common cause for this exception is described in bug 1414546, which is
dependant on Calendar bug 1415863 for resolution. If this is the case, then
ensure that the resource does not have a Calendar Exception assigned that
spans the entire duration of a shift.

7. java.net.UnknownHostException: <host>

This exception is thrown when the TCF:HOST profile is set to a server that is
not recognized by the client.

Verify that the TCF:HOST profile is set correctly, and that the client machine can
access the server using the <host> displayed in the exception.
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One way to check is to open a DOS window (on a Microsoft Windows machine)
and type in "ping <host>." If the host is inaccessible from the client, then the
response returns a "Bad IP address <host>" message.

7.1.5.10 Consult the TCF Server Log

You can view the TCF server log to obtain further information. To set up the log file
for automatic logging, perform the following steps:

1. Add the following to the command line:

QUTPUTH LE=/ tnp/ <l ogfi | e>.1 og LOQEVEL=STATEMENT

2. Bounce (stop and restart) the TCF server.

3. Run the application again.

4. Check the log file to see if there is anything in the log file that may indicate
what the problem may be.

Errors of the following type can be due to bug 1510941. View the AlIX Port
Instructions, in the Step 2: Performing the Post Install Steps section for details
on how to correct this problem.

java.l ang. Nul | Poi nt er Excepti on

at
at
at
at
at
at
at
at
at
at

oracl e. j dbc.
oracl e. j dbc.
oracl e. j dbc.
oracl e. j dbc.
oracl e. j dbc.
oracl e. j dbc.

oracore. O acl eTypeNUMBER unpi ckl er ec(Conpi | ed Code)
oracore. O acl eType. unpi ckl er ec( Conpi | ed Code)

oracore. O acl eTypeGALLECTI QN unpi ckl er ec( Conpi | ed Gode
oracore. O acl eTypeCALECTI QN unpi ckl e( Conpi | ed Code)
oracore. O acl eTypeCALECTI QN unpi ckl e( Conpi | ed Code)
oracore. O acl eTypeADT. unl i neari ze( Conpi | ed Code)

oracl e. sql . ArrayDescri ptor. | engt h( Conpi | ed Code)

oracl e. sql . ARRAY. | engt h( Conpi | ed Code)

oracl e. sql . ARRAY. get Array( Conpi | ed Code)
oracle.apps.jtf.gantt. server. Gantt Dat aServer. get Shifts

7.1.5.11 Verify the TCF Server Status

You can also use the ServerControl class to check whether or not the TCF server is
accepting connections on the host and port on which it was started.

To do this, log onto the machine where it was started and run:

jre oracl e.apps.fnd.tcf. ServerControl STATUS <port #>

One of the following can occur:
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« Ifthe result is some variant of "Unable to connect," the server most likely was
not started properly. See: Unable to Connect to the TCF Server and Unable to
Connect to the Database for details of how to solve this problem.

« If the application hangs upon connecting, the server has stopped accepting
connections for some reason and must be bounced. See: Application Hangs
Upon Connecting to the TCF Server.

« Ifyou are able to connect from the ServerControl but not from an application, it
might be an application-specific problem, or it may be that the client JAR files
are not set up correctly.

7.1.6 Task Manager

7.1.6.1 Task Search On Name Does Not Return Results

If the Quick Find or the personalized search on task names does not return results,
then rebuild the Intermedia index.

This can be done in two ways :
« Manually rebuilding the Intermedia index using the alter index command.

«  Starting the ctxsrv server daemon for background DML processing. For more
information, consult the Oracle8i interMedia Text Reference.

7.1.6.2 UOM is Invalid or Disabled
If you experience this problem, perform the following:

1. The Time Unit of measure class must be defined in the Inventory module. For
this Time Unit of measure class, define the Unit of Measure codes ( such as
Hours, Minutes, etc.)

For details on defining the Unit of Measure class, refer to the Inventory User’s
Guide.

2. The profile "Time Unit Of Measure Class" must be set to Time Unit of measure
class defined above in the inventory module.
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7.1.7 Interaction History
The following problems may result in incorrect behavior for Interaction History:

7.1.7.1 Cannot Create An Interaction

Mandatory parameters must be validated. To create an interaction, a valid party_id
(customer), resource_id (agent), outcome_id, and handler_id (application) are
required. If any of these parameters are invalid or missing, the create interaction
APIs will fail.

7.1.7.2 Cannot Create an Interaction

Optional parameters must be validated. To create an interaction, the following
optional parameters must be valid: result_id, reason_id, and campaign.

7.1.7.3 Cannot Create an Activity

Mandatory parameters must be validated. To create an activity, a valid interaction_
id, action_item (business activity type) and outcome_id are required. If any of these
parameters are invalid or missing, the create activity APIs will fail.

7.1.7.4 Cannot Create an Activity

Optional parameters must be validated. To create an activity, the following optional
parameters must be valid:

« RESULT_ID

. REASON_ID

« ACTION_ID (sub-level detail related to business activity)
. MEDIA_ID

. TASK_ID

. CUST_ACCOUNT_ID

. SOURCE_CODE_ID

7.1.7.5 Cannot Create a Media Item

Mandatory parameters must be validated. To create a media item, a valid media
item type and media data are required. If any of these parameters are invalid or
missing, the create interaction APIs will fail.
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7.1.7.6 Cannot Create an Interaction, Activity, or Media Item

There can be a failure to load mandatory parameter seed data. It is impossible to
create an interaction if one of the following tables does not cannot seed data:
outcomes and action items. These parameters must be validated.

7.1.8 Fulfillment

7.1.8.1 Troubleshooting Remote Commands

If you are having problems sending remote commands to the Fulfillment server,
verify the following questions:

« Does your classpath include the apps.zip file?
= Are you using an older version of the Fulfillment server?

You could be using a version of the Fulfillment server in which the
RemoteCommand class is found under "oracle.apps.jtf.fm.engine.processor"
package as in "oracle.apps.jtf.fm.engine.processor.RemoteCommand" instead of
"oracle.apps.jtf.engine.remote.RemoteCommand" as it is in its current form.

It is also possible that the version of the server you are running predates the use
of remote commands, in which case you need to update your version with a
patch.

« Isthe Fulfillment server you are trying to command currently running?

« Isthe Fulfillment server you are trying to command listening to the same port
that you are sending to?

7.1.8.2 Error Logs

The Fulfillment Server can log a variable amount of detail in an error log whenever
error conditions are reached. The error logging capability was initially set up to
capture errors specific to Java exceptions and database connectivity problems that
would prevent error logging in the database. This error logging capability grew to
also include entries describing the reasons for failed Fulfillment requests. This
functionality extends into an event log as well that simply lists events as they occur
within the Server.

The Server Logs are written to a log directory that can be specified in one of two
ways:

« Do nothing and a log directory will be created within the directory from where
the Server is launched.
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<1>Ti ne:

<1>oracl e.

at
at
at
at
at
at

oracle.
oracle.
oracle.
oracle.
oracle.
oracle.

apps.
apps.
apps.
apps.
apps.
apps.
apps.

« Set the startup script property -Dengine.LogPath=<user defined log path>
where <user defined log path> is a place on the file system that the Server has
write permission to (same as the user account that launches the Server).

The Server Logs by default are named 'Events<n>.log’ for the events log and
‘Error<n>.log’ for the error log where <n> is a unique number that is assigned by
the Server every time it is launched. The names of these logs can be overridden by
setting the startup script properties -Dengine.EventLog=’for the events log and
-Dengine.ErrorLog="for the error log. Whatever name you give to these log files
will be appended to the value for engine.LogPath. You may notice another file
called logprop.sav in the log directory. This file is automatically generated and reset
every time the Server launches. It is to be left alone if you wish to maintain any
rhyme or reason to the files in the log directory.

7.1.8.3 Reading the Event Log

The following event log depicts the normal startup of a Fulfillment Server. The first
line of the Event log will always be the Start Time in which the Event Log was first
used. Each entry after that is separated by a solid line and has associated with it an
unique event ID and time stamp for when the entry was logged.

Start Time --- -- Tue Nov 07 19:42:34 EST 2000- - 0- -
<1>Tine . --Tue Nov 07 19:42:34 EST 2000--0--
<1>Message : <PROCESSOR [server 10021] >LOGGER CREATED, GETTI NG LOG LEVEL ...

7.1.8.4 Reading the Error Log

Like the Event log, the Error log also has associated with it a unique error ID and
time stamp for when an entry is logged. The Error log has sub-error IDs as well
which identifies a continuation of the same error. The way to read this is error <1>
was caused by error <1.1> which was caused by error <1.2> etc. Each of these
sub-entries is a java exception. They are read in the opposite way where the first
line is the source of the error and each following line is a progression through a Java
Virtual Machine call stack.

Below is a sample of an error log:

--Tue Nov 07 19:43:38 EST 2000--1 mnute; 3 seconds; 351 m!liseconds--
jtf.fmengine. di sp. FFMException: Delivery Error:

jtf.fmengine. di sp. Mai | Request. sendMessage( Conpi | ed Code)

jtf.fmengine. disp. Mai | Request. mai | (Mai | Request . j ava: 882)

jtf.fmengine. di sp. Mai | Request. send( Mai | Request . j ava: 140)
jtf.fmengine.request.Request Handl er $Request . di spat ch( Conpi | ed Code)
jtf.fmengine. request. Request Handl er $Request . pr ocessRequest ( Conpi | ed Code)
jtf.fmengine.request.Request Handl er $Request . pr ocess(Request Handl er . j ava: 965)
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at
at
at
at

oracl e. apps.jtf.fmengine.request. Request Handl er. processRequest (Request Handl er . j ava: 495)
oracl e. apps.jtf.fmengine.request. Request Handl er. processRequest (Request Handl er. j ava: 421)
oracl e. apps.jtf.fmengine. processor. Process. run(Conpiled Code)

java.lang. Thread. run(Thread. j ava: 466)

<1.1>j avax. mai |l . SendFai | edException: Sending fail ed;

nested exception is:

javax. mail . Messagi ngException: Could not connect to SMIP host: SMIP02, port: 25;

nested exception is:

j ava. net. NoRout eToHost Exception: Operation timed out
javax. mail . Transport.send0( Conpil ed Code)
javax.mail . Transport.send(Transport.java: 73)

at
at
at
at
at
at
at
at
at
at
at
at

oracl e. apps.
oracl e. apps.
oracl e. apps.
oracl e. apps.
oracl e. apps.
oracl e. apps.
oracl e. apps.
oracl e. apps.
oracl e. apps.

jtf.fmengine. di sp. Mai | Request. sendMessage( Conpi | ed Code)

jtf.fmengine. disp. Mai | Request. mai | (Mai | Request . j ava: 882)

jtf.fmengine. di sp. Mai | Request. send( Mai | Request . j ava: 140)
jtf.fmengine.request.Request Handl er $Request . di spat ch( Conpi | ed Code)
jtf.fmengine. request. Request Handl er $Request . pr ocessRequest ( Conpi | ed Code)
jtf.fmengine.request.Request Handl er $Request . pr ocess(Request Handl er . j ava: 965)
jtf.fmengine. request. Request Handl er. processRequest ( Request Handl er. j ava: 495)
jtf.fmengine. request. Request Handl er. processRequest ( Request Handl er. j ava: 421)
jtf.fmengine. processor. Process. run(Conpiled Code)

java.lang. Thread. run(Thread. j ava: 466)

You can tell from this error is that there was a Delivery Error associated with
sending an email <1>. Dig a little deeper and we see that the send failed <1.1>. and
deeper still <1.2> because it could not connect to the SMTP host 'SMTP02, port 25".
The depth of these sub-error listings is limited by the startup property
engine.LogLevel which is usually set to 4. This is usually sufficient as these nested
errors rarely go beyond three levels deep. One way to set this is to set it in the
Server startup script -Dengine.LogLevel=<n>’ where <n> is a number between 1
and 999 though it is not recommended setting it above 10.

Sometimes an error log entry can be accompanied by a 'Note:’ giving a little more
detail as to why the error occurred or what the error means. The latest versions of
the Fulfillment Server will almost always include a request ID in the Note section of
the error when the error is associated with a request and the request ID is available.

7.1.8.5 oracle.apps.jtf.fm.engine.disp.FFMException

The FFMException occurs whenever there is a problem with delivering a fulfililment
request based on the requested format (email, faxing, printing, etc.). Types of
FFMExceptions include:

« oracle.apps.jtf.fm.engine.disp.FFMException: Delivery Error indicating that
the request failed because it cannot be delivered to its destination. It is usually
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followed by javax.mail.SendFailedException: Sending failed indicating that it
was an email request that was unable to be sent. The further down you drill
into the error message the greater level of detail you get.

» Javax.mail.MessagingException: Could not connect to SMTP host: SMTP02,
port: 25 tells you that the reason the email was unable to be sent is because it
could not connect to the SMTP host 'SMTP02’ on port 25.

« Java.net.NoRouteToHostException: Operation timed out finally tells us that the
server could not find a route to connect to 'SMTP02’ and gave up after a certain
amount of time trying.

« oracle.apps.jtf.fm.engine.disp.FFMException: Property 'engine.FaxEnabler’ not
found - check the properties file indicates that a fax request was received but no
FaxEnabler was specified in the Fulfillment Server startup script to handle it.
See the document 'Faxing with the Fulfillment Server.doc’ for more details.

« oracle.apps.jtf.fm.engine.disp.FFMException: Property ’engine.PrintEnabler’
not found - check the properties file indicates that a print request was received
but no PrintEnabler was specified in the Fulfillment Server startup script to
handle it. See the document 'Printing with the Fulfillment Server.doc’ for more
details.

7.1.8.6 oracle.apps.jtf.fm.engine.logging.HistoryException

The HistoryException occurs whenever there is a problem in writing historical
information about the request to the database. Types of HistoryExceptions include:

oracle.apps.jtf.fm.engine.logging.HistoryException: ORA-01006: bind variable
does not exist

This indicates that an error occurred while interacting with the database. Following,
provided that your log level is set higher than the minimum ’1’ should always be
java.sgl.SQLException: ORA-01006: bind variable does not exist’. SQLExceptions
will also include Error Code and SQL State which are 1006 and 72000 for this
example. Whenever a HistoryException is followed by the characters 'ORA-XXxxx’,
it indicates a bug in the Fulfillment Server that either already exists in bug db
(hopefully, already, with a patch) or should be created in bugdb.

7.1.8.7 java.sql.SQLException

Whenever an exception that is part of the Java Development Kit (JDK) occurs as the
primary exception (not as a subscripted exception as in 1.1, 1.2, etc.) it means bad
news. Most exceptions in the Fulfililment Server are custom defined for expected
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error conditions that wrap around subscripted java exceptions. Some of the
common reasons for a SQLException to occur as a primary exception include:

« java.sql.SQLException: No more data to read from socket usually indicates that
a connection to the database has been lost. This will occur either because of a
network outage or the database going down (crash, shutdown, etc.)

« java.sql.SQLException: lo exception: Socket write failed will usually occur
whenever there is either a network outage or a lost connection to the database.
This occurs when a write to the database was attempted through the failed
connection.

7.1.9 Escalation Manager

7.1.9.1 Troubleshooting Tips

If you are having difficulties using Escalation Manager after implementing it, verify
the following:

= Workflow is installed and working correctly.
« Territories have been defined and contain valid resources.
« System Profile Options starting with "Escalation..." are set to valid values.

If Assisted Assignment through the Assignment Manager does not return any
resources, then check whether the Escalated object itself has a resource.

7.1.9.2 APP-JTF-210807 Error

The APP-JTF-210807 No Resources Found message is often reported as a problem
with the Escalation Manager component. This error may occur when assigning an
escalation territory.

= You can define the territory, with the appropriate resources, then associate an
escalation territory with that territory, and still the No Resources Found
message appears.

« This happens most often because the object that is being escalated does not
contain a territory itself.

« Ifno territory is available in the escalated object, then there is no way to locate
the appropriate escalation territory, so that the resources cannot be found.

Refer to bug #1617608 for further details on debugging steps for this error in the
Escalation Manager.
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7.1.10 Business Rule Monitor

7.1.10.1 Troubleshooting Tips

If you are having difficulties using the Business Rule Monitor after implementing it,
verify the following:

Concurrent Manager is running.

Workflow background processes for all Escalation Workflows are running
periodically.

Workflow is installed and correctly running.

System Profile Option "Businesfs Rule Monitor Workflow Administrator" is set
to the Apps user ID of a valid user with the Workflow responsibility.

System Profile Option "Escalation: Default Level" is set to a value which exists
in the Define Escalation Level form.

7.1.10.2 General Tips for Defining Rules
The following suggestions are helpful when defining rules in the BRM:

The condition should not reflect an absolute state. Otherwise, the monitor will
keep detecting the same objects and acting upon them; you may have repeated
notifications sent.

Use reasonable check intervals. The check interval also determines the
notification interval. So, if you check a rule every two minutes, notifications are
sent every two minutes.

Take loop time into consideration. If the main scan cycle is set to run every ten
minutes, then there is no point in setting the check frequency to two minutes.

Even in a simple rule, SQL syntax applies. You can use SQL functions, but you
also have to use quotes around your character values. Also use IS NULL and IS
NOT NULL instead of =NULL and <>NULL.

Verify that the view does what you intended for it to do. The simplest way to
do this is to cut and paste the view definition from the Complex tab into a SQL+
session.

Check the performance of the view. Do a Select from your view. If it takes a
long time to return the values, then ask a SQL expert for assistance.
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7.1.10.3 Stopping the Business Rule Monitor

Some patches for CRM Foundation require the Business Rule Monitor to be stopped
before the patch can continue. You can tell if the Business Rule Monitor is running
by entering the CRM Administrator responsibility and navigating to Business Rule
Monitor > Business Rule Monitor - this invokes the Control Panel. The Status field
will show "Active’ or 'Stopping’ if the Business Rule Monitor is in a running state.

To stop the Business Rule Monitor press the 'Stop’ button on the Business Rule
Monitor Control Panel. Note that the workflow background process for the
‘Business Rule Monitor Main Process’ workflow should be running in order for the
'Stop’ command to be processed.

If the Business Rule Monitor Control Panel shows a status of 'Stopping’ for an
unusually long period of time, this is normally caused by the workflow background
process not being running at the time the 'Stop’ button is pressed. To start the
workflow background process perform the following steps:

Steps

1. Select System Administrator responsibility from the Requests menu option.
2. Select Run.

3. Run a Single Request.

a. The name is Workflow Background Process.

b. The item type is Business Rule Monitor Main Process

c. Leave minand max threshold blank.

d. Process deferred to Yes.

e. Process timeout to Yes.

Click OK.

Select the Schedule button.

Select Periodically.

Enter an end date and time of 15 minutes later.

Re-run every three minutes.

© © N o g >

From Completion of the prior run, click OK.

10. Select Submit.

7-30 Oracle CRM Application Foundation Implementation Guide



Common Implementation Errors

Note that if your Business Rule Monitor main process is running every 30
minutes, for example, then you will need to extend the end time of the
background process so that it is still running the next time the BRM process
checks for instructions.

You then need to wait for the BRM to do its next run so that it will process the
'STOP’ command, then the status should show 'Complete’ and you can continue
with the patch.

You should not comment out this script and continue with the patch - this will
leave your system in an undefined state.

If for some reason the main BRM workflow will not process the 'STOP’
command then you will need to abort the process from within the Workflow
Monitor. To do this:

a. Find the error notification for itemkey JTFBRM and the process ID that is
shown on the BRM control screen - these notifications are usually sent to
the SYSADMIN user.

b. View the notification for this process.

c. Atthe bottom of the screen there is a poplist from where you choose what
you want to happen next - select 'Abort’.

d. After a short while the process should stop.

7.1.10.4 Answers to Frequently Asked Questions

The following are frequently asked questions. Answers to these questions may help
you in troublehoosting problems with the Business Rule Monitor.

1.

What is the relationship between the following "Time Related Features"?

Answer: In Business Rule Monitor (BRM), you have the option to select how
often (in <<Interval>> Field) you want the BRM to check the rules noted in
Business Rule Workbench (BRW).

In BRW, you have option to select how often (in <<Check Rule Every>>,
<<Tolerate Condition For>> Fields) you want the BRM to check the rule noted
here.

And in Workflow background process (WBP), you have option to select how
often you want to run the workflow background process.
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2. How are the parameters discussed in step 1 related?

For example, you can set 5 MINUTES as the Interval in BRM, set 1 MINUTE in
Check Rule Every in BRW for one of the rules AND only run the Workflow
background process every DAY, then what will happen?

Where is the point of reference for the time? Let’s say we run WBP at 12:00 PM,
start the BRM at 12:05 PM, then will the BRM continue to check every 5
MINUTES until ... when 1:00 PM, or 5:00 PM or until whenever.

Answer: The important point here is that you need to be sensible when setting
these time intervals as there is no cross-referencing between them, so all times
are independent of each other.

In the example of having the BRM run every 5 minutes, the BR check every
minute and the WBP run once a day - what will happen is that the BRM will
run once when the WBP 24-hour anniversary occurs each day. The checking of
the actual BR will depend on when its WBP is next run after the BRM has run.
The Workflow processes cannot do anything unless the WBP associated with
that process is executed, so the timing of the BRM is dependant on when its
WBP runs.

The point of reference for the BRM is from when the 'Start' button was pressed
in the Control screen, so if it is started at 12.00 PM to run every five minutes
then it will check at 12.00 PM, then at 12.05 PM etc until the 'Stop' button is
pressed OR until the WBP stops repeating. However, this is dependent on when
the WBP is run for the BRM Main Process. If the WBP is run from 12.00 PM
every one minute then the above will hold true. However, if it is run every two
minutes then it will only check at 12.02 PM, 12.04 PM, 12.06 PM, and so forth, so
the 12.05 PM run of the BRM will be delayed by a minute.

For each BR the timing is taken from when the last iteration of that BR occurred.
This is affected also by the timing of the WBP for that individual BR Process, in
the same way as the main BRM as explained above, plus the timing of the main
BRM run and how it coincides with the timing of each BR check.

3. Canyou stop the notifications from repeating?

Once the conditions set in a Business Rule are met, then the notifications are
sent continuously. Is this the intended functionality? Do you have the option to
have a flag to indicate that only one notification should be sent?

Answer: If you choose to send a notification or create a Task, then that will
happen each time the BR is checked if the condition is still true. This is as
designed - you should set the BR interval to how often you want the
notification to be sent. If you want to send the notification only once then you
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can either customize the Escalation Activity code to do that, or raise it as an
Enhancement Request which will be considered for a future release.

Can you expand the fields available from the 3D view?

In the BRW, you are limited to fields in the CS_BRM_3D_SERVICE_REQUEST _
V view. For example, there is nho problem code field in CS_BRM_3D_SERVICE _
REQUEST_V. Is there an option to use fields from other tables or views?

Answer: The seeded 3D view makes available the fields that you see on the
Service Request Ul that are audited. You only use the fields that are audited
because this is how you are able to detect how the values have changed over
time. If you need additional fields then you can use the '‘Complex’ style of rule
definition to specify these in standard SQL format.

How do you control who receives the workflow notifications?

When defining business rules, you have the ability to associate a Workflow
process with each business rule. It is the Workflow process that generates the
notifications.

The client can view the definition of these seeded workflow processes in the
Workflow builder, however, it is not clear as to how the process determines
whom the notifications should be sent to. For example, in the Workflow Builder,
viewing the process definition of "Escalate a Service Request (notification
only)", it has a notification activity called "Object Conformed to a Rule" which
sends a notification to a role defined in the "Notification Person" item attribute.

What is the default behavior of this workflow process? What is the hierarchy of
criteria that the system uses to determine who to notify?

Answer: You need to press the button labelled "...” which is next to the Workflow
LOV. This brings up the Workflow Attributes window, and from there you can
select a value for each of the attributes for that specific Workflow process. For
example, for the notification workflow you can choose the Notification Role,
which is the role of the (in relation to the object, i.e. Service Request) who you
want the notification to go to. The options are:

=« Business Owner
« Document Owner
« Document Owner’s HR Manager

» Escalation Territory Primary Contact
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The default setting is Business Owner, which is the owner of the Business Rule.
If an individual resource cannot be identified programmatically for any reason
then the notification will always default to Business Owner.

6. Isthere a place you can go to see if the BRM has launched a workflow
process?

For example, you want to see if anything is happening for the rule you have
created which has six records in the database that match the criteria. You think
you’ve completed all the necessary preliminary set-up to get the BRM up and
running.

Answer: The first thing to check is that the rule will actually return the records
that you think it should. You can do this by going to the Complex tab in the rule
definition and copying the text from there into SQLPIus - if it returns rows then
the rule is OK, if not then you need to re-examine your rule. Start with
something simple, like 'Task Number' = '12345".

If rows are returned, then the next step is to look at the Workflow processes
using the Workflow Monitor. Make sure the SYSADMIN user has "Workflow'
responsibility, then connect to Applications as SYSADMIN via the PHP login
for the instance that you are using. Under the heading 'Self Service' click on
‘Workflow'. At the next page click on 'View Progress'. In 'Item Type' choose the
name of the Workflow process that you believe should be invoked for your rule,
for example any of the Task seeded Workflow processes would use '‘Business
Rule Monitor Task Process'. Click on 'Find' - this will show you all of the
Workflow processes that have been started in that instance. From there you can
drill down into the details of each process.

If there are none, then maybe there has been a problem with the main BRM
Workflow. You can look at its progress using the same method, but selecting
‘Business Rule Monitor Main Process'.

It could be that there is a problem with the Workflow you are using, so again it
is suggested that you try the simplest case first so that you can see it working -
try using the 'Escalate a Task - send a Notification' seeded Workflow and choose
to have the notification sent to the '‘Business Rule Owner' or the 'Document
Owner'.
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