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Preface

Welcome to the Oracle Customer Relationship Management, Release 11i, suite of
applications. This documentation is intended to accompany the 11.5.6 code release.

This Oracle CRM Technology Foundation Concepts and Procedures guide provides
information and instructions to help you work effectively with the System
Administrator Console, which is the Web-based interface to the CRM Technology
Foundation.

This preface explains how the guide is organized and introduces other sources of
information that can help you.

Intended Audience

Structure

This guide is aimed at the following users:
= System Administrators
= Customer Service Representatives

= Implementation Engineers

This guide is a compilation of the topics in the online help for the Oracle CRM
Technology Foundation. It contains the following topic sections:

"Understanding" topics provide overviews of the application and its components,
explanations of key concepts, features, and functions, as well as the application’s
relationships to other Oracle or third-party applications.

xi



"Using" topics provide process-oriented, task-based procedures for using the
application to perform essential business tasks.

Related Documents

For more information on the Oracle CRM Technology Foundation, see the Oracle
CRM Technology Foundation Implementation Guide.

Other Sources of Information

Xii

For additional information regarding the Oracle E-Business Suite, consult the
following:

= Oracle Applications Product Update Notes

» Installing Oracle Applications

»  Oracle Applications Supplemental CRM Installation Steps
»  Oracle Application Concepts

»  Oracle Applications System Administrator’s Guide
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Understanding the System Administrator
Console

This topic group provides overviews of the System Administrator Console and its
components as well as explanations of key concepts, features, and functions.

1.1 System Administrator Console Overview

The System Administrator Console is a Web-based interface that allows you to use
the components of the CRM Technology Foundation. In it, you run diagnostics,
design page flows, customize Ul components, manage security, and perform other
administrative tasks.

The System Administrator Console has an organizational structure consisting of
tabs, subtabs, and links in the left navigation bar. Additionally, you can click the
global navigation buttons at the top right of each screen to access online help, sign
out, or set profile options.

See the following help topics for overviews of the features of the System
Administrator Console:

Understanding User Management
Understanding Security
Understanding Site Preferences
Understanding the System Subtab
Understanding Configuration
Understanding Diagnostics

Understanding Cache

Understanding the System Administrator Console 1-1



Understanding User Management

Understanding XML Services
Understanding Declarative Page Flows

Understanding Declarative Components

1.2 Understanding User Management
This section covers the following topics:
s User Management Overview
- Whatis an Approval Definition?
- Who Can Be an Approver?
—  What are Responsibilities?
— What are Roles?
= What’s New in This Release
= Terms and Definitions

= User Management Process Flow

1.3 User Management Overview

User Management is the process of registering a user and thereafter maintaining the
user in the system by granting or revoking privileges, accounts, customer profile
information, and party relationships based on a set of business requirements
set-forth by the organization where the process is deployed.

With User Management, you can register new users, modify existing users, approve
or reject user approval requests, and assign users to business accounts. You can also
customize the user registration process by configuring templates, enrollments, user
types, and approval processes.

1.3.1 What is an Approval Definition?

The User Management Approval definition uses workflow to track and route the
request to the approvers. An approval definition can deliver an e-mail notice to the
approvers. Both user types and enrollments can share the same approval definition.
The e-mail notifies what types of requests are being requested (user type or
enrollment) and what action the approver needs to take.
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User Management Overview

If the approval definition has more than one approver, the e-mail notification is sent
to the next approver when the previous approver has approved. For the user to be
granted access, all approvers in the chain need to approve the request. The request
is granted after the last approver from the list accepts it. Whereas to reject, only one
rejection is needed from an approver. A request times out if it is left in an approvers
queue for a specified amount of time.

If the order of the approvers change, all pending requests are transferred back to the
top of the new approver list. If the user type or enrollment is changed to use
another approval definition, all pending request's workflow processes end and you
create and launch a new workflow process. If a user type or enrollment is modified
so it no longer needs approval, then all pending requests are automatically
approved.

1.3.2 Who Can Be an Approver?

Approvers are application user, who one of the following permission:

= JTF_REG_APPROVAL or JTF_SECURITY_ASSIGN_ROLE (System
Administrator) permission

= JTF_APPROVER (Request Owner) permission
= JTF_PRIMARY_USER_SUMMARY permission (Primary user).

The Primary user must also have the JTF_PRIMARY_USER responsibility to access
the approval page. The system administrator can define a global or default list of
approvers for each user type and enrollment. Any approver can be overridden at
the organization level by the system administrator.

For business users, account assignment is provided with the approval process. New
accounts can be created for an organization and assigned to the user during the
approval process. Individual users may not require approval to register. If no
approval is necessary for this type of user, new accounts are created and assigned
automatically. If a customer determines that individual users require an approval,
then they should the auto account creation for this user. Primary users require
approval. However, a merchant administrator can disable this prerequisite.
Merchant Administrators have the option of requiring registration approval for all
user types.

When a Primary User register’s a company for the first time, the approver must

create a new account and associates that account with the user. If approval is not
required, then a new account is automatically created for the user’s organization
and associated with the first user to register for that company. If they are not the
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first person to register for the organization, then it is up to the primary user to
assign the newly created account to that new user.

1.3.3 What are Responsibilities?

Responsibilities refer to application user responsibilities which are a representation
of the menu hierarchy available to a particular user type. During the registration
process, users are granted access to one or more responsibilities depending on the
services they enroll in and the merchant policy. Typically, individual users are given
access only to one responsibility.

1.3.4 What are Roles?

Roles are groupings of permissions, which are page level or function level granular
privileges used to maintain application security. A single user can be granted
several roles and each separately determines access rights to Ul details, ability to
perform certain transactions and ability to access certain data sets. During the
registration process users are granted the appropriate set of roles that maps to their
job function.

1.4 What’s New in This Release

This release of the 11.5.6 Oracle E-Business Suite has the following new features and
functions for User Management:

»  HTML user interface

= Primary user type

= Customizing enrollment
= Self-service enrollment

s Account administration for Business to Business (B2B) and Business to
Customer (B2C) users

= User disablement
= User profile windows

s User maintenance windows
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1.5 Terms and Definitions

The following table describes terms and definitions associated with User
Management.

Table 1-1 User Management Terms and Definitions

Term Description

Approval An optional feature where approvers can reject or approve
new user accounts. In the User tab, the System Administrator
Console provides windows so you can view, create, modify,
delete, enable, and disable approvals, including those for
specific organizations.

Approval Flow The approval flow is a predefined flow of steps required to
approve user registration or service enrollment requests.

Business User A business user is a typical B2B user, associated with an
organization. Generally, the Primary user(s) of the same
organization approves these users.

Customer Customers are typically primary users, B2B users, and B2C
(individual) users.

Enrollment Enrollment is a set of add-on services that you can receive
during or after registration. One enrollment corresponds to
zero or one responsibility, zero or one template, zero or one
approval and zero or more roles. Enrollments are application
specific and can be tied to user types.

Explicit Enrollment These are enrollments that you manually register for during
the registration process from the "Register Here" link.

Implicit Enrollment These are enrollments that a user is automatically signed up
for during the registration process from the "Register Here"
link. The user is not asked to register for these enrollments.
Instead, they are automatically attached to the user upon
registration.

Individual User An individual user is an individual with no relationship to
an organization. Generally, no approval is required for this
type of user.

JSP Java server pages are an extension to the Java servlet
technology that was developed by Sun as an alternative to
Microsoft's ASPs (Active Server Pages). JSPs have dynamic
scripting capability that works in tandem with HTML code,
separating the page logic from the static elements -- the
actual design and display of the page.
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Table 1-1 User Management Terms and Definitions

Term Description

JTF_APPROVER If you have this responsibility, you can only view requests
Permission assigned to you.

JTF_PRIMARY_USER A Primary User must have the JTF_PRIMARY_USER
Responsibility responsibility to access this page and approve requests.
JTF_PRIMARY_USER_ If you have this permission, which is part of the JTF_
SUMMARY Permission PRIMARY_USER role you can only view requests assigned to

you and the Universal Primary User Approver for your
organization.

JTF_REG_APPROVAL
Permission

The user, who has “JTF_REG_APPROVAL” permission, is
considered to be a system administrator. With this
permission, you can view and respond all requests in the
system.

JTF_SECURITY_ASSIGN_

The user, who has the JTF_SECURITY_ASSIGN_ROLE

ROLE Permission permission is considered to be a system administrator. With
this permission, you can view and respond to all requests in
the system.

Merchants Merchants refer to the implementor of the Oracle e-Business

Suite. This term is used to clear up any confusion with the
term “customers”, which refers to customers of a business
using Oracle products as opposed to those implementing the
product.

Merchant Administrator
(System Administrator)

The merchant or system administrator is the main
administrator of a company who approves requests for
primary, business, and individual users. This administrator,
who has the JTF_REG_APPROVAL permission, sees all the
pending requests to be approved and is able to approve
them.

Primary User

A designated person of an external organization, like a
business partner, who is responsible for some administrative
functions on behalf of the external organization. In the case of
registration the Primary user is responsible for managing the
registration and maintenance of users, accounts, and
enrollments. Primary users of different parties may have
access to different responsibilities and they may be granted
different access rights.

Registration

Registration is the process by which any user gains some
access to the application’s functionality.
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Table 1-1 User Management Terms and Definitions

Term

Description

Registration Self-service
Administration Ul

The Registration Self-service Admin Ul is used by system
administrators, and at times Primary users, to maintain
external organization or internal group, users, parties, and
accounts.

Registration Self-service
user Ul

The Registration Self-service user Ul is used by the Primary,
Individual, or Business users to register themselves.

Registration Templates

Applications require varying pieces of information to register
different types of users. Registration Templates refer to JSP
files that are used to capture the registration information that
is special to a particular User Type or Enrollment.

Request Owner

The request owner is the current approver based on the
approver list and current state of workflow defined for given
approval. The request owner is only able to approve the
requests which they currently own. This user should have
“JTF_APPROVER” permission. The request owner is tied to
the JTF_UM_APPROVAL_OWNER profile option.

Responsibilities Responsibilities are groupings of application menus that
determine the user interface accessible to a particular user.
Roles Roles are groupings of permissions, which are page level and

function level granular privileges used to maintain
application security.

Self-service Registration

Rather than asking an administrator to register users
manually, users can register themselves through a self-service
UL Self-service registration includes that UI and the
background processes used to complete the registration
process. This involves assigning users the correct data and Ul
access privileges.

Template Handler

Template handlers refers to how the data flow built by other
application teams occur among registration and how they are
associated with enrollments and user types in the User
Management framework.

Universal Primary User
Approver

Create a Universal Primary User Approver if you want
to have multiple primary users.

User

A user is any person who needs access to any application,
including various types of customers, partners, suppliers,
and employees.
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Table 1-1 User Management Terms and Definitions

Term Description

User Profile User Profiles, which are associated with responsibilities, are
set of user interfaces that give users access to their personal
data and preferences.

User Profile Menus User Profile menus are groupings of user profile pages
(options), which are relevant to a particular responsibility.
User Profiles are user interfaces to user’s personal data and
preferences. A number of responsibilities can share the same
User Profile menu.

User Type A User Type is a category of users that caters to the specific
needs of an application’s business requirements. User types
allow flexible and extensible ways for defining, categorizing
and implementing behavior of users. A user type is
associated to only one template, one responsibility, zero or
one approval and zero or more roles.

Workflow Oracle Workflow automates and continuously improves
business processes, routing information of any type
according to business rules you can change. Oracle Workflow
manages business processes according to rules that you
define. The rules, which we call a workflow process
definition, include the activities that occur in the process and
the relationship between those activities. An activity in a
process definition can be an automated function defined by:

= aPL/SQL stored procedure or an external function

= anotification to a user or role that they may request a
response

= abusiness event

= asubflow that itself is made up of many activities.

1.6 User Management Registration Process Flow
There are three different types of users currently available in User Management:
= Business User
= Individual User
s Primary User

When a user registers, depending on the user type, an approval task is generated
and assigned to an approver. The approver is notified through Workflow that there
are pending requests in the queue. The request is reviewed and possibly modified,
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and either rejected or approved. Upon approval, the request is forwarded to the
next approver. Once all approvals are granted, the user is notified through e-mail
and given access to the system.

Business User

A business user is a typical B2B user, associated with an organization. Generally, the
Primary user of an organization approves these users. The following table describes

the process flow of a Business User in User Management.

Table 1-2 Business User Approval Process Flow

Steps Description Required Performed By
Click the Register This link accesses the User Registration Yes All Users
Here link window.

Select the Business | Select this option if you are a current Yes All Users
User option button | customer and B2B user.

Enter your This number is assigned to your company Yes All Users
company’s when it is registered as a customer. The

organization Primary User of a company has access to this

number information.

Enter your personal | Enter your personal information in the Yes All Users
information associating text field.

Select enrollments Register for any available enrollments that Optional All Users
for your registration | interest you.

Fill out any Some enrollments may have separate Yes All Users
templatesassociated | windows to capture key information about

with the enrollment | the enrollment that you selected.

that you selected

Review and This window gives you detailed information | Optional All Users

maintain your
confirmation
information

about your registration including:

= A confirmation number

= The date the registration began
= Your name

= The user type

= Your organization number

= Your username

= Any enrollment information
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Table 1-2 Business User Approval Process Flow

Steps Description Required Performed By
Anemail/workflow | The workflow sends out a notification to the | Yes Workflow
notification is sent | approver. If the workflow mailer is set up, the
approver also receives an email.
Approver signs in The approver must have the following Yes System Administrator or
and goes to the responsibilities and permissions to approve Primary User
pending approval requests:
window = JTF_APPROVER (permission)
= JTF_PRIMARY_USER (permission)
= JTF_PRIMARY_USER (responsibility)
Approver clicks on | This link accesses the User Details window Optional System Administrator or
the Username link | where the approver can review the user’s Primary User
personal information. This step is required if
the user request must be approved.
Assign an account | All users must have an account associated Optional System Administrator or
or creates a new with them in order to access their company’s Primary User
account and assign | or individual information and create financial
it to the user transactions.This step is required if the user
request must be approved.
Enter a comment for | Enter a comment about the users approval or | Optional System Administrator or
the user enter a reason why you accepted or rejected Primary User
their request.
Click accept to Whether or not the request is accepted or Yes System Administrator or
approve the request | rejected, the user receives a notification. Primary User
or reject to refuse it
Notification is sent | The requestor receives a notification, as well Yes Workflow
to the requestor as an email (workflow mailer is set up),
confirming or rejecting their approval.
Login with your Depending on your user type and pending Optional All Users

new username and
password

approval, you are logged in. What you see is
associated with the roles and responsibilities
the approver assigned to you, which depends
on the user type and enrollment selections.

Individual User
An individual user is an individual person having no relationship to an
organization. Generally, no approval is required for this type of user. The following
table describes the process flow of a Individual User in User Management.
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Table 1-3 Individual User Approval Process Flow

Steps Description Required Performed By
Click the Register This link accesses the User Registration Yes All Users
Here link window.
Select the Individual | Select this option if you a new or existing Yes All Users
User option button | store user.
Enter your personal | Enter your personal information in the Yes All Users
information associating text field.
Select enrollments Register for any available enrollments that Optional All Users
for your registration | interest you.
Fill out any Some enrollments may have separate Yes All Users
templatesassociated | windows to capture key information about
with the enrollment | the enrollment that you selected.
that you selected
Review and This window gives you detailed information | Optional All Users
maintain your about your registration including:
confirmation . .
: - = A confirmation number
information
= The date the registration began
= Your name
= The user type
= Your username
= Any enrollment information
Approver clicks on | This link accesses the User Details window Yes System Administrator or
the Username link | where the approver can review the user’s Primary User
personal information.
Assign an account | All users must have an account associated Yes System Administrator or
or creates a new with them in order to access their company’s Primary User
account and assign | or individual information and create financial
it to the user transactions.
Enter a comment for | Enter a comment about the users approval or | Optional System Administrator or

the user

enter a reason why you accepted or rejected
their request.

Primary User
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Table 1-3 Individual User Approval Process Flow

Steps Description Required Performed By
Click accept to Whether or not the request is accepted or Yes System Administrator or
approve the request | rejected, the user receives a workflow Primary User
or reject to refuse it | notification.
Notification is sent | The requestor receives a workflow Yes System Administrator or
to the requestor notification, as well as an email (if the email Primary User
workflow is set up), confirming or rejecting
their approval.
Login with your Depending on your user type and pending Optional All Users

new username and
password

approval, you are logged in. What you see is
associated with the roles and responsibilities
the approver assigned to you.

Primary User
A Primary user is also known as the customer administrator and is responsible for
managing all users of the same organization. Generally, the system or merchant
administrator approves these users. Your organization can have multiple Primary
Users. The following table describes the process flow of a Primary user in User
Management.
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Table 1-4 Primary User Approval Process Flow

Steps Description Required Performed By
Click the Register This link accesses the User Registration Yes All Users
Here link window.
Select the Primary Select this option if you are Registering your | Yes All Users
User option button | company here. Primary Users are Point of
Contacts for Customers.
As a Primary User, your permissions and
responsibility are almost identical to Business
Users except that your are responsible for
validating and approving Business Users for
your company.
If you are an This number is assigned to your company Yes All Users
existing customer, when it is registered as a customer.
select the first
option button and
enter your
company’s
organization
number
If you are a new
customer registering
as the first primary
user for your
organization, select
the second option
button and enter
your company’s
information
Enter your personal | Enter your personal information in the Yes All Users
information associating text field.
Select enrollments Register for any available enrollments that Optional All Users
for your registration | interest you.
Fill out any Some enrollments may have separate Yes All Users
templatesassociated | windows to capture key information about

with the enrollment
that you selected

the enrollment that you selected.
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Table 1-4 Primary User Approval Process Flow

Steps Description Required Performed By
Review and This window gives you detailed information | Optional All Users
maintain your about your registration including:
confirmation . .
. - = A confirmation number
information
= The date the registration began
=  Your name
= The user type
= Your organization number
= Your username
= Any enrollment information
Approver signs in The approver must have the following Yes System Administrator or
and goes to the responsibilities and permissions to approve Primary User
pending approval requests:
window = JTF_APPROVER (permission)
= JTF_PRIMARY_USER (permission)
= JTF_PRIMARY_USER (responsibility)
Approver clicks on | This link accesses the User Details window Yes System Administrator or
the Username link | where the approver can review the user’s Primary User
personal information.
Assign an account | All users must have an account associated Yes System Administrator or
or creates a new with them in order to access their company’s Primary User
account and assigns | or individual information and create financial
it to the user transactions.
Enter a comment for | Enter a comment about the users approval or | Optional System Administrator or
the user enter a reason why you accepted or rejected Primary User
their request.
Click accept to Whether or not the request is accepted or Yes System Administrator or
approve the request | rejected, the user receives a workflow Primary User
or reject to refuse it | notification.
Notification is sent | The requestor receives a workflow Yes Workflow
to the requestor notification, as well as an email (if the
workflow mailer is set up), confirming or
rejecting their approval.
Login with your Depending on your user type and pending Optional All Users

new username and
password

approval, you are logged in. What you see is
associated with the roles and responsibilities
the approver assigned to you.
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1.7 Understanding Security

The interface for the CRM Technology Foundation Security framework is the
Security subtab of the System Administrator Console. The Security subtab displays
under the Settings tab. The Security screens allow you to control access to

application resources.

Read this section to understand the basic concepts involved in setting up and using
the Security framework. For detailed instructions, see Managing Security.

1.7.1 Key Security Concepts and Features

The following table describes the key concepts and features of the Security

framework.

Term

Definition

Permission

A unit of privilege that is granted to a user. It usually serves to
grant a certain type of access to a resource. Resources are
application elements such as objects or methods of objects. A
resource can have unique permissions for each way that it can
be accessed.

In the Security subtab, you can view, create, and delete
permissions as well as map them to roles.

Role

A group of permissions.

In the Security subtab, you can view, create, and delete roles, as
well as set which permissions are mapped to each role.

Alerts Monitor

A display of important security-related tests, run on each
registered host. The Security Alerts Monitor is a customized
view of the System Alerts page that appears under the
Deployment tab.

1.8 Understanding Site Preferences

The Site Preferences subtab displays under the Settings tab. The Site Preferences
screens allow you to personalize the Interapplication Bar.

Read this section to understand the basic concepts involved in setting up and using
Site Preferences. For detailed instructions, see Using Site Preferences.

1.8.1 Key Site Preferences Concepts and Features

The following table describes the key concepts and features of Site Preferences.
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Term Definition

Interapplication Bar A group of customizable links that displays at the top of every
page in HTML-based CRM applications.

Navigation Group A customizable set of applications with defined responsibilities.

In the Site Preferences subtab, you can map CRM applications
into Navigation Groups. Additionally, from the Navigation
Group Setup screen, you can create, delete, activate, and
deactivate Navigation Groups.

1.9 Understanding the System Subtab

The System subtab displays under the Settings tab. The System screens allow you to
configure the system level properties that you need to set up during the
deployment process: the self service user (AKA guest user), branding, cookies,
sessions, loggings, property categories, and properties.

Read this section to understand the basic concepts involved in setting up and using
system level properties. For detailed instructions, see Using the System Subtab.

1.9.1 Key System Subtab Concepts and Features
The following table describes the key concepts and features of the System Subtab.

Term Definition

Sessions A system property that carries user identity and credentials
throughout the duration of a user’s activity.

In the System subtab, you can set up both User Sessions and
Sticky Sessions.

When using Sticky Sessions, all requests from the same user
session will attempt to go to the same JVM, regardless of
whether the application is in stateless mode or stateful mode.
Sticky Sessions allow for several performance enhancements. In
particular, the hit ratio of middle tier caching is improved
because all cached data for a particular user resides on a single
JVM rather than being scattered across different JVM instances.
In addition, session attributes and resources will not have to be
recreated and duplicated across different JVMs, but can be
reused in the JVM associated with the session.
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Term Definition

Cookies A system property that stores information about users and
systems as users log in to applications.
In the System subtab, you can define cookie names, types,
encryption, and expiration times.

Branding The wording that displays at the top left of every page,

depending upon responsibility.

The branding can be defined at both application level and
responsibility level. A responsibility can only belong to one
application and an application can have multiple
responsibilities. If the branding for a particular responsibility is
not set, the branding for all responsibilities within the
application (application level) will be used. If the branding for a
particular responsibility is set, the branding will take
precedence and override the branding set at application level.

In the System subtab, you can personalize and preview
Branding.

Self Service User

Also known as Guest User. An internal user who is granted
certain responsibilities and permissions so that the self
registration process offers new users the appropriate
responsibilities and permissions.

In the System subtab, you can set up the name and password of
the Self Service User.

Logging Trails

A system property that helps you debug system-related codes.

In the System subtab, you can configure both Framework
Logging Options and Service Logging Options.

Framework Logging is used by the CRM Technology
Foundation, while Service Logging is used by all applications.

Property Categories
Setup

In the System subtab, you can set up the applications that you
want to register in the system properties framework. A property
is a key/value pair that is application-specific.

Password Expiration

In the System subtab, you can specify the time interval for
which a password is valid.

Advanced

In the System subtab, you can view, create, modify, delete, and
copy properties (application-specific key/value pairs). A key is
what is used by an application to retrieve data. Keys are unique,
but can have multiple values. Values are the content or data that
binds to a particular key.
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1.10 Understanding Configuration

The Configuration subtab displays under the Deployment tab. The Configuration
screens allow you to manage a system’s hosts and resource settings.

Read this section to understand the basic concepts involved in using the
Configuration screens. For detailed instructions, see Managing Configuration.

1.10.1 Key Configuration Concepts and Features

The following table describes the key concepts and features of the Configuration

subtab.

Term

Definition

Host

Synonym for computer, machine, box, or node. For example, a
generic host name is computer_name.company_name.com.

In the Configuration subtab, you can view, register, modify, and
remove the hosts in your system.

Resource Settings

Settings that allocate system resources in order to optimize
application performance.

Cache

A data structure that holds frequently used Java objects. It is
composed of component caches. Component caches hold the
objects of application modules that pertain to specific
application functionality.

In the Resource Settings subtab, you can set the maximum size
of the cache (in megabytes). This is used to prevent the JVM
memory from bloating because of caching. When the JVM's
memory usage reaches this limit, the cache stops growing in
size.

Elsewhere, in the Cache subtab, you can manage cache policies,
manage component caches, and view cache statistics.

For more information, see Understanding Cache.

Concurrent

Occurring at the same time.

In the Resource Settings subtab, you can set the maximum
number of concurrent users.

Load Balancer

The host that manages user requests across all the mid-tier
hosts.

1-18 Oracle CRM Technology Foundation Concepts and Procedures




Understanding Diagnostics

1.11 Understanding Diagnostics

The interface for the Oracle CRM Technology Foundation Diagnostics framework is
launched when you click the Diagnostics tab of the System Administrator Console.
It allows you to troubleshoot any setup and installation problems of the technology
foundation and certain participating applications. Additionally, it allows you to
register and employ new diagnostic tests. The Diagnostics screens allow you to run
test groups, run individual tests, manage test groups, manage tests, set default test
input values, and register applications.

Read this section to understand the basic concepts involved in setting up and using
the Diagnostics framework. For detailed instructions, see Using Diagnostics.

Note:

The following URL can also be used to access the

Diagnostics screens:

http:/ / <hostname>:<portnumber>/OA_HTML/jtfqalgn.htm

1.11.1 Key Diagnostics Concepts and Features

The following table describes the key concepts and features of the Diagnostics

framework.

Term

Definition

Applications

You must register the applications that you want to run tests on.

In the Diagnostics screens, you can register applications and if
necessary, define application prerequisites.

Test

A Java test that verifies the correct behavior of a particular
feature or function.

In the Diagnostics screens, you can run, register, delete, and set
default input values for tests.

Test Group

A set of related tests. A test group may have other test groups
defined as prerequisites.

In the Diagnostics screens, you can run, create, modify, and
remove test groups.
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Term Definition

Prerequisite A concept that applies to both applications and test groups.
Setting prerequisites is sometimes necessary for procedures to
execute correctly.

For example, the DBConnections test group has the
Environment Setup test group set as its prerequisite, because the
Environment Setup test group contains the DBC Parameter test
which checks the DBC file. If the DBC Parameter test fails, no
tests in the DBConnections test group will be successful.

In addition, the CRM Technology Foundation application has
the HTML Platform application set as its prerequisite. If some
tests in the CRM Technology Foundation fail, it is likely due to
an error in the HTML Platform. Therefore you can run the
HTML Platform tests to trace the problem.

The Diagnostics interface offers screens that allow you to define
prerequisites for applications as well as test groups.

1.12 Understanding Cache

The interface for the CRM Technology Foundation Java Objects Cache is the Cache
subtab of the System Administrator Console. The Cache subtab displays under the
Performance tab. The Cache screens allow you to clear or reload the Cache, manage
Cache Policies, manage Component Caches, and view Cache statistics.

Read this section to understand the basic concepts involved in setting up and using
the Cache. For detailed instructions, see Using Cache.

1.12.1 Key Cache Concepts and Features

The following table describes the key concepts and features of the Cache.

Term Definition

Cache A data structure that holds frequently used Java objects. It is
composed of Component Caches. A Component Cache holds all
the Java objects belonging to an application component. An
application component pertains to specific application
functionality.

In the Cache subtab, you can clear or reload the Cache, manage
Cache Policies, manage Component Caches, and view Cache
statistics. Elsewhere in the Resource Settings subtab, you can set
the maximum size of the Cache.
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Term Definition

Policy A setting that applies to an application running on a host. The
policy types are Cache Only, Cache and Priming, Disabled, and
Custom.
In the Cache subtab, you can set Cache Policies.

Filter An application-specific component that indicates what

responsibility IDs and language codes to prime for.

Component Cache

A data structure that holds the Java objects of an application
module pertaining to a specific application functionality. For
example, Catalog and MenuRenderer are components that have
component caches.

In the Cache subtab, you can view, create, modify, and remove
Component Caches.

Statistics

A display of Component Cache performance metrics.

1.13 Understanding XML Services

The interface for CRM Technology Foundation XML Services is the XML Services
subtab of the System Administrator Console. The XML Services subtab displays
under the Integration tab. The XML Services screens allow you to manage Service
Groups, Authentication Profiles, Invocations, and Events.

Read this section to understand the basic concepts involved in setting up and using
XML Services. For detailed instructions, see Using XML Services.

1.13.1 Key XML Services Concepts and Features

The following table describes the key concepts and features of XML Services.

Term

Definition

XML Services

A framework that allows you to manage interapplication Web
service sharing. In other words, you can use XML Services to
send and receive business logic over the Internet from one
application to another.

In the XML Services subtab, you can manage Service Groups,
Authentications, Invocations, and Events.
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Term

Definition

Services

The logical names of function calls with defined inputs and
outputs. They are implemented as methods of Java classes.
Services are application specific and usually represent a unit of
business logic.

In the XML Services subtab, you can enable and disable Services
within Service Groups.

Service Group

The logical name of a Java class that contains methods exposed
as services.

In the XML Services subtab, you can view, create, modify, and
delete Service Groups.

Authentication Profile

Tells an invocation what host, user name, and password to use.

In the XML Services subtab, you can view, create, modify, and
delete Authentication Profiles.

Invocation The logical name of a connection that calls a service on a remote
host.
In the XML Services subtab, you can view, create, modify, and
delete Invocations.

Event Outputs an object of a predefined input type to a set of

subscribers.

In the XML Services subtab, you can view, create, modify, and
delete Events.

Event Subscribers

Invocations that are registered to an event.

In the XML Services subtab, you can set the Event Subscribers
for an Event.

1.14 Understanding Declarative Page Flows

The interface for the CRM Technology Foundation Declarative Page Flows
framework is the Declarative Flows subtab of the System Administrator Console.
The Declarative Flows subtab displays under the Design tab. The Declarative Flows
screens allow you to manage Physical Pages, Rules, Logical Pages, and Business

Flows.

Read this section to understand the basic concepts involved in setting up and using
Declarative Page Flows. For detailed instructions, see Using Declarative Page

Flows.
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1.14.1 Declarative Page Flows Overview

The Declarative Page Flows framework enables you to customize, upgrade, and
troubleshoot the content and flow of JSPs within an application without making any
modifications to actual code. The Declarative Page Flows framework is based on the
abstraction of JSPs into named logical entities. Consequently, you can achieve
efficient management of content and flows by utilizing the screens provided in the
System Administrator Console.

1.14.2 Key Declarative Page Flows Concepts and Features

The following table describes the key concepts and features of Declarative Page

Flows.

Term

Definition

Physical Page

The name of a JavaServer Page (JSP).

In the Declarative Flows subtab, you can view, register, and
modify Physical Pages.

Rule

A rule is defined by parameters and conditions and determines
which Physical Page needs to be rendered or which Logical
Page needs to display next. Rules evaluate to true when all of
their conditions evaluate to true.

In the Declarative Flows subtab, you can view, create, and
modify Rules.

Logical Page

A named logical entity that has one or more Physical Pages
mapped to it. Usually, each Logical Page represents a node
within a Business Flow.

In the Declarative Flows subtab, you can view, create, and
modify Logical Pages.

Business Flow

A sequential set of linked Logical Pages that usually
corresponds to a business task. Business Flows can be linear or
nonlinear, depending on whether or not there are
context-sensitive conditions. Branching conditions are evaluated
at each node.

In the Declarative Flows subtab, you can view, create, modify,
clone, and preview Business Flows.
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Term Definition

Flow Cloning In order to facilitate the easy upgrade of business flows which
have been customized by a customer, a business flow can be
cloned, thus creating a Flow Family of related business flows.

In the Declarative Flows subtab, the Clone Flow screen allows
you to generate duplicates of a given flow.

Flow Families A flow family consists of an original business flow, a clone of
the original business flow, and any customized clones which
have been made.

In the Declarative Flows subtab, the Flow Families screen allows
you to view the contents of a Flow Family and select which flow
is active.

1.15 Understanding Declarative Components

The interface for the CRM Technology Foundation Declarative Components
framework is the Declarative Components subtab of the System Administrator
Console. The Declarative Components subtab displays under the Design tab. The
Declarative Components screens allow you to create and manage components (Bins,
Graphs, Reports, Graph/Report combinations, and LOVs) as well as component
security settings.

Read this section to understand the basic concepts involved in setting up and using
Declarative Components. For detailed instructions, see Using Declarative
Components.

1.15.1 Declarative Components Overview

The Declarative Components framework allows you to quickly build Ul
components that display application-specific data in personalizable Bins, Graphs,
Reports, Graph/Reports, or LOVs. The coding requirements are minimal to
nonexistent and the components can be published on Oracle applications.

1.15.2 Key Declarative Components Concepts and Features

The following table describes the key concepts and features of Declarative
Components.
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Term

Definition

Metadata

The Declarative Components framework relies on the accurate
definition of metadata. The framework uses the metadata to
capture information about component headers, footers,
columns, and other attributes.

In the Declarative Components subtab, you can define the
metadata for bins, reports, graphs, graph/report combinations,
LOVs, and parameters.

Bin

Bins are small reports which display high level summary
information in a tabular format. They generally display
information regarding a single metric, such as "time period." If
enabled and the appropriate security features are assigned, you
can choose which bins to display on the home page and also
choose the order in which multiple bins are displayed.

In the Declarative Components subtab, you can view, create,
modify, and remove Bins.

Report

Reports are similar to bins. They display information in a
tabular format.

In the Declarative Components subtab, you can view, create,
modify, and remove Reports. Optionally, you can do the same
for Report/Graph combinations.

Graph

A graph is a diagram that represents data pictorially.

In the Declarative Components subtab, you can view, create,
modify, and remove Graphs. Optionally, you can do the same
for Report/Graph combinations.

LOV

The LOVs that you create can be used across applications.

LOV means "list of values." It is a Ul component that facilitates
the completion of a text entry field when there are numerous
values that may be assigned. LOVs are a useful alternative to
drop-down lists, particularly in cases where displaying a long
list of selections in a drop-down list would require excessive
scrolling.

In short, when using a LOV to complete a text entry field, you
type a query into the field and then click a button labeled "Go."
This opens a screen where you view a list of values that match
the query you submitted. You can then select the value that you
desire and return to the original screen, where what you
selected will populate the original text entry field.

In the Declarative Components subtab, you can view, create,
modify, and remove LOVs.
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Using the System Administrator Console

This topic group provides process-oriented, task-based procedures for using the
System Administrator Console.

The following tabs and subtabs are described in this topic group:

Administering User Management
Managing Security

Using Site Preferences

Using the System Subtab
Managing Configuration

Using Diagnostics

Using Cache

Using XML Services

Using Declarative Page Flows

Using Declarative Components

For information on User Management, please see CRM Foundation Concepts and
Procedures.

2.1 Administering User Management

This topic group provides task-based procedures required for ongoing system
maintenance and includes information on administration tools and utilities. This
section covers the following topics:

Logging into User Management
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= Approving Pending User Requests
= Viewing Your Notifications
= Approving Requests from the Notification Window
s User Maintenance
- Viewing All Users
- Searching for a User
— Creating a New User
- Editing a User’s Details
— Deleting a User
— Defining a User’s Roles
— Defining a User’s Account
—  Defining a User’s Enrollment
= Setting up Approval Types
- Creating a New Approval Type
- Removing an Approval Type
— Searching for an Approval Type
- Editing an Approval Type’s Details
— Enabling and Disabling Approval Types
- Searching for an Organization
- Viewing Approval Preferences
- Updating Approval Preferences
= Setting up Enrollments
— Creating an Enrollment
- Removing an Enrollment
— Enabling and Disabling Enrollments
- Editing an Enrollment’s Details
= Setting up User Types
— Creating a User Type
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— Removing a User Type
— Activating and Deactivating User Types
— Searching for a User Type
- Editing a User Type’s Details
= Setting up Templates
— Creating a Template
- Removing a Template
— Enabling and Disabling Templates
- Editing a Template’s Details

— Searching for a Template

2.2 Logging into User Management
The following modules use User Management to register users:
= Oracle iStore
= Oracle iSupport
= Oracle Partners Online

Perform the following steps to log into the System Administrator Console.

Note: All fields marked with an asterisk are required.

Prerequisites
= You must have a valid username and password.

= You must have the CRM HTML Administration responsibility.

Steps

1. Navigate to the Login window.
2. Enter your username.

3. Enter your password and click Go.
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2.3 Approving Pending User Requests

When a user requests a user account, in many cases, it must be approved by a
system administrator. Perform the following steps to accept or reject user approval
requests, edit user information, and assign accounts to the user.

Note: Any pending user requests submitted before User
Management was applied do not appear in the Pending Request
window. Instead, you must click on the link in the window to
respond to these requests.

Prerequisites

You must be the system administrator or the primary user of a company with the
appropriate permissions, to approve a request.

Steps

1.
2,
3.

Log in as the system administrator.

Select the Users tab.

Click Pending Approvals on the side navigation bar.
The Request Summary window opens.

To answer the request from this window, select the check box next to the user
and click Accept or Reject.

Click a username in the Username column.
The User Details window opens.

Review or edit the user's details.

Click Next.

The Accounts window opens.

Select any accounts you want to assign to the user or enter a new account name
and click Create.

The new account is added to the table.
Select the account and click Next.

The Approval Outcome for Applicant window opens.

10. Click Accept to approve the request or click Reject to deny the request.
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Approving Requests from the Notification Window

A notification is sent to the user when the last approver from the approval
definition approves it.

2.4 Viewing Your Notifications

A merchant administrator, system administrator, or a primary user for an
organization can approve or reject a users request. Whether the request is granted
or rejected, the user receives a notification. Perform the following steps to view your
user requests.

Prerequisites

You must set up your Personal Home Page (PHP) and have the workflow and self
service responsibilities to receive notifications.

Steps
1. Log in as the System Administrator.
2. Set up your Personal Homepage (PHP) to show workflow notifications.
3. Select the Main Menu tab.
4. Click Workflow.
5. Click View Notifications.
Your notifications appear in the Worklist window.
See Also

Approving Requests from the Notification Window

2.5 Approving Requests from the Notification Window

Note: When an approver receives a registration request in their
Notifications, they have the option to reassign it. However, it is the
approvers responsibility to confirm that the person you are
reassigning the request to has the correct approver responsibilities
and permissions. The list provided includes application users that
may or may not have the appropriate responsibilities to approve
user requests.
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For user types, the system administrator receives a URL in their notifications. The
approver follows the URL to approve or reject the request. Perform the following
steps to approve or reject a user requests.

Prerequisites

You must set up your Personal Home Page (PHP) and have the workflow and self
service responsibilities to receive notifications.

Steps

1.

2
3
4.
5

Log in as the System Administrator.

Set up your Personal Homepage (PHP) to show workflow notifications.
Select the Main Menu tab.

Click Workflow.

Click View Notifications.

Your notifications appear in the Worklist window.

Click the link to respond to the request.

The Notification Details window opens.

Review the users details and click Approve to accept the request or click Reject
to deny the request.

To reassign the request:
a. Click Reassign.

b. Enter the Approvers name or click the Up arrow icon to search for an
approver.

You are responsible for verifying

c. Select the Delegate Authority for responding to this notification option
button to send the request to an approver w to Transfer Ownership of this
notification

d. Enter any comments you want the new approver to view.
e. Click OK.

The request is Reassigned.
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See Also
= Viewing Your Notifications

2.6 Viewing All Users

Perform the following steps to view all users in the system.

Note: If you are the Primary user for your organization, you will
only be able to view users for your company.

Prerequisites

You must be the merchant administrator, system administrator, or the primary user
of a company with the appropriate permissions, to view all users.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click User Maintenance on the side navigation bar.
The Users window opens.
4. Enter a minimum of three characters into to the search field.
The "%" and "_" (underscore) symbols are wildcards.
5. Click Go.
A list of all users displays.

See Also
= Searching for a User

s Creating a User

= Editing a User’s Details

= Deleting a User

= Defining a User’s Roles

= Defining a User’s Account

= Defining a User’s Enrollment
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2.7 Searching for a User

Perform the following steps to search for a user.

Note: If you are the Primary user for your organization, you are
only able to query users for your company.

Prerequisites

You must be the system administrator or the primary user of a company with the
appropriate permissions to search for a user.

Steps
1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click User Maintenance on the side navigation bar.
The Users window opens.
4. Select Last Name, First Name, or Username from the Enter Search Criterion
drop-down list.
5. Enter a minimum of three characters into to the search field.
The "%" and "_" (underscore) symbols are wildcards.
6. Click Go.
A list of search results appears in the window.
Note: To search for all users in the system, enter three spaces
followed by "%". This search may take a long time.
See Also

Viewing All Users
Creating a User
Editing a User’s Details
Deleting a User

Defining a User’s Roles
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Creating a New User

Defining a User’s Account

Defining a User’s

2.8 Creating a New User

Certain types of users may only be created by a system administrator. For example,
a system administrator creates primary users or other system administrators.
Perform the following steps to create a new user.

Prerequisites

You must be the system administrator or the primary user of a company with the
appropriate permissions to create a new user.

Steps
1. iog in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click User Maintenance on the side navigation bar.
The Users window opens.
4. Click Create.
The User Registration window opens.
5. Select the type of user you want to create. Options include: Business User,
Individual User, or Primary User.
6. Enter the user's information into the fields provided and click Next.
7. Select available enrollments as appropriate.
8. (Optional) Click Clear to clear the fields.
9. Click Submit to save.
See Also

Viewing All Users
Searching for a User
Editing a User’s Details
Deleting a User
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= Defining a User’s Roles
= Defining a User’s Account

= Defining a User’s Enrollment

2.9 Editing a User's Details

Perform the following steps to edit a user's information.

Prerequisites

You must be the system administrator or the primary user of a company with the
appropriate permissions to edit a user’s details.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click User Maintenance on the side navigation bar.
The Users window opens.
4. If you do not need to search for the user, then skip to step 6.
5. If you need to search for the user, then:

a. Select Last Name, First Name, or Username from the Enter Search Criterion
drop-down list.

b. Enter a minimum of three characters into to the search field.
The "%" and "_" (underscore) symbols are wildcards.
c. Click Go.
A list of search results appear in the window.
6. Click the username
The User Details window opens.
7. Edit fields as desire.
Fields marked with an asterisk are mandatory.
8. View the following links for information regarding:

= Defining a User’s Roles
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Deleting a User

= Defining a User’s Account

= Defining a User’s Enrollment

9. Edit the information in the window and click Update to modify the information
or click Restore to reset the original values in the window.
See Also

Viewing All Users
Searching for a User
Creating a User

Deleting a User

2.10 Deleting a User

Perform the following steps to delete a user.

Prerequisites

You must be the system administrator or the primary user of a company with the
appropriate permissions to delete a user.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click User Maintenance on the side navigation bar.

The Users window opens.

If you do not need to search for the user, then skip to step 6.

If you need to search for the user, then:

a. Select Last Name, First Name, or Username from the Enter Search Criterion
drop-down list.

b. Enter a minimum of three characters into to the search field.
The "%" and "_" (underscore) symbols are wildcards.
c. Click Go.

A list of search results appear in the window.
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6. Select the check box which corresponds to the user you want to delete.
7. Click Delete User.
The Delete User window opens.
8. Click Delete.
The user is deleted from the system.
See Also

Viewing All Users
Searching for a User
Creating a User

Editing a User’s Details
Defining a User’s Roles
Defining a User’s Account

Defining a User’s Enrollment

2.11 Defining a User’s Roles

Perform the following steps to define a user's role information.

Note: If you are the primary user of an organization, you are not
able to define their role from this window.

Prerequisites

You must be the merchant administrator or a system administrator, of a company
with the JTF_SECURITY_ASSIGN_ROLE permission to define a user’s roles.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.

Select the Users tab.
Click User Maintenance on the side navigation bar.
The Users window opens.

Find the user who’s role you want to define.
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5. Click the username.
The User Details window opens.

6. Click Roles to edit the user’s role information.
The User- Role Mapping window opens.

7. Select the name of a role in one list and click > or < to move it to the other list.
You can hold down the [CTRL] key and use your mouse to select multiple roles.
The administrator can only assign roles that they are assigned themselves.

8. Repeat step 11 as desired.

9. If you want to move all Available Roles to the Assigned Roles list, then click >>
or to move all Assigned Roles to the Available Roles list, then click <<.

10. Click Update to modify the information or click Restore to reset the original
values in the window.

See Also

Viewing All Users
Searching for a User
Creating a User

Editing a User’s Details
Deleting a User

Defining a User’s Account

Defining a User’s Enrollment

2.12 Defining a User’s Account

Perform the following steps to define a user's account information.

Note: If the user is not defined as a user type in the user
management framework, you are not able to define their account
from this window.
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Prerequisites

You must be the system administrator or the primary user of a company with the
appropriate permissions to define a user’s account.

Steps
1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click User Maintenance on the side navigation bar.
The Users window opens.
4. Find the user who’s role you want to define.
5. Click the username.
The User Details window opens.
6. Click Assign Account to edit the user’s account information.
The Accounts window opens.
7. Select any accounts you want to assign to the user or enter a new account name
in the account description field and click Create.
The new account is added to the table.
8. Select the account and click Update.
See Also

Viewing All Users
Searching for a User
Creating a User
Editing a User’s Details
Deleting a User
Defining a User’s Roles

Defining a User’s Enrollment

2.13 Defining a User’s Enroliment

Perform the following steps to define a user’s enrollment.
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Note: If the user is not defined as a user type in the user
management framework you are not able to define their
enrollments from this window.

Note: If you are viewing your own enrollments, you have access
to available enrollments, that you can register for, depending on
your roles and responsibilities.

Prerequisites

You must be the system administrator or the primary user of a company with the
appropriate permissions to define a user’s enrollment.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.

2. Select the Users tab.

3. Click User Maintenance on the side navigation bar.

The Users window opens.
4. Find the user who’s role you want to define.
5. Click the username.

The User Details window opens.

6. To edit the user's enrollments, click Enrollments.
The User Enrollment Details window opens.

7. Select from the list of available enrollments and click Enroll. Only an individual
user can sign up for enrollments. The administrator can only remove a user’s
enrollments.

The enrollment appears in the enrollment column.
8. To unenroll, select from the list of enrollments and click Unenroll.
See Also

Viewing All Users

Searching for a User
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Creating a User
Editing a User’s Details
Deleting a User
Defining a User’s Roles

Defining a User’s Account

2.14 Creating a New Approval Type

An approval type is an optional component of the user registration process. Perform
the following steps to create a new approval process.

Prerequisites

You must be the system administrator with the appropriate permissions to create a
new approval type.

WARNING: The Use Pending Request Page check box should
only be unchecked if your organization does not plan to use our
pending approval window and intends to respond to all
approvals through e-mails and the workflow notification
window.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click Approval Setup.

The Available Approvals window opens.

Click Create New Approval.

The Create Approval window opens.

Enter the approval information.

a. Enter an Approval Key.

b. Enter a name for the approval.
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(Optional) Enter a description for the approval type.

Select a Workflow Item Type from the drop-down list. This list contains all
workflows in the system, however, only those workflows coded to our
standards will work with User Management.

Select an Application from the drop-down list.

(Optional) Select the Use Pending Request Page check box if you want the
approval type to display during the registration process from the "Register
Here" link.

Click Next.

The Approver Selection Order window opens.

7. Enter the Approver Selection information.

a.

b.

g-
h.

Enter a number to define the order that each approver gets the request.

Enter the name of the first approver into the Approverl field or click Go to
search for an approvers name.

A look up window opens.

Enter your search criteria and click Go.

The Search Results appear in the window.

Select the option button for the user that you want to be the approver.
Click Add User.

The user’s name appears in the text field.

(Optional) Enter the name of additional approvers into the other Approver
fields (repeat steps a-e).

(Optional) Click Cancel to clear the fields.
(Optional) Click add 5 more rows to add five empty approver fields.

8. Click Submit to save.

See Also
= Removing an Approval Type

= Searching for an Approval Type

= Editing an Approval Type’s Details
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Enabling and Disabling Approval Types
Searching for an Organization
Viewing Approval Preferences

Updating Approval Preferences

2.15 Removing an Approval Type

Prerequisites

You must be the system administrator with the appropriate permissions to remove
an approval type.

Steps

1.

Log in to the CRM System Administrator Console as a system administrator.

2. Select the Users tab.

3. Click Setup on the main navigation bar.

4. Click Approval Setup in the side navigation bar.
The Available Approvals window opens.

5. Select the check box in the Remove column that corresponds to the Approval
that you plan to delete.

6. Click Update to delete the Approval or click Restore to reset the original values
in the window.
A confirmation window opens.

7. Click Confirm and Update Now to delete the Approval or click Cancel to
cancel the deletion.

See Also

Creating a New Approval Type
Searching for an Approval Type

Editing an Approval Type’s Details
Enabling and Disabling Approval Types

Searching for an Organization
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= Viewing Approval Preferences

= Updating Approval Preferences

2.16 Searching for an Approval Type

An approval type is an optional component of the user registration process. Perform
the following steps to search for an approval type.

Prerequisites

You must be the system administrator with the appropriate permissions to search
for an approval type.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click Setup on the main navigation bar.
4. Click Approval Setup.
The Available Approvals window opens.
5. If you want to search by approval name, then:

a. Select Approval Name from the drop-down list in the Search Approval
area.

b. Enter your search phrase into the text input field.
c. Click Go.
d. View your search results.
6. If you want to search by approval key, then:
a. Select Approval Key from the drop-down list in the Search Approval area.
b. Enter your search phrase into the text input field.
c. Click Go.

d. View your search results.

See Also
= Creating a New Approval Type
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= Removing an Approval Type

= Editing an Approval Type’s Details

= Enabling and Disabling Approval Types
= Searching for an Organization

= Viewing Approval Preferences

= Updating Approval Preferences

2.17 Editing an Approval Type's Details

An approval type is an optional component of the user registration process. Perform
the following steps to edit an approval type's details.

Prerequisites

You must be the system administrator or the primary user with the appropriate
permissions to edit an approval type’s details.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click Setup on the main navigation bar.
4. Click Approval Setup.
The Available Approvals window opens.
5. Click the name of the approval in the Approval Name column.
The Update Approval window opens.
6. Edit the fields as desired and click Next.
7. Edit the information in the Update Approval window and click Next.
8. Edit the information in the approver selection order window and click Submit.

The information is updated.

See Also
= Creating a New Approval Type

= Removing an Approval Type
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Searching for an Approval Type
Enabling and Disabling Approval Types
Searching for an Organization

Viewing Approval Preferences

Updating Approval Preferences

2.18 Enabling and Disabling Approval Types

Approval Types can be enabled or disabled at any time. Perform the following steps
to enable or disable an approval.

Prerequisites

You must be the system administrator of a company with the appropriate
permissions to change to status of an approval type.

Steps

1.

Log in to the CRM System Administrator Console as a system administrator.

2. Select the Users tab.

3. Click Setup on the main navigation bar.

4. Click Approval Setup.
The Available Approvals window opens.

5. If you want to enable an approval, select Enabled from the drop-down list in
the corresponding Status column.

6. If you want to disable an approval, select Disabled from the drop-down list in
the corresponding Status column.

7. Click Update to modify the status of the approval type or click Restore to reset
the original values in the window.
A confirmation window opens.

8. Click Confirm and Update All to modify the status.

See Also

Creating a New Approval Type
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= Removing an Approval Type

= Searching for an Approval Type

= Editing an Approval Type’s Details
= Searching for an Organization

= Viewing Approval Preferences

= Updating Approval Preferences

2.19 Searching for an Organization

Perform the following steps to search for an organization.

Prerequisites

You must be the system administrator with the appropriate permissions to search
for an organization.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click Setup on the main navigation bar.
4. Click Approval Setup.
The Available Approvals window opens.
5. Click Organization in the side navigation bar.
The Organization window opens.

6. Select Organization Name, Company Number, or DUNS Number from the
Enter Search Criterion drop-down list.

7. Enter a minimum of three characters into to the search field.
The "%" and "_" (underscore) symbols are wildcards.

8. C(lick Go.
A list of search results appears in the window.

9. Click the column heading to sort the row.

2-22 Oracle CRM Technology Foundation Concepts and Procedures



Viewing Approval Preferences

See Also

Creating a New Approval Type
Removing an Approval Type

Searching for an Approval Type

Editing an Approval Type’s Details
Enabling and Disabling Approval Types
Viewing Approval Preferences

Updating Approval Preferences

2.20 Viewing Approval Preferences

Use the approval preferences window to define an approval list for a specific
organization. Perform the following steps to enable or disable an approval.

Prerequisites

You must be the system administrator with the appropriate permissions to view
approval preferences.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click Approval Setup.

The Available Approvals window opens.

Click Organization in the side navigation bar.

The Organization window opens.

Search for an organization.

a. Select Organization Name, Company Number, or DUNS Number from the
Enter Search Criterion drop-down list.

b. Enter a minimum of three characters into to the search field.

The "%" and "_" (underscore) symbols are wildcards.
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c. Click Go.

A list of search results appears in the window.

7. Click the Organization Name.
The Approval Preferences window opens with a list of approval definitions for
the specified organization.

See Also

Creating a New Approval Type
Removing an Approval Type

Searching for an Approval Type

Editing an Approval Type’s Details
Enabling and Disabling Approval Types
Searching for an Organization

Updating Approval Preferences

2.21 Updating Approval Preferences

Perform the following steps to update the organization’s approval list.

Prerequisites

You must be the system administrator or the primary user with the appropriate
permissions to update approval preferences for an organization.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.
Click Setup on the main navigation bar.
Click Approval Setup.
The Available Approvals window opens.
Click Organization in the side navigation bar.
The Organization window opens.

Search for an organization.
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Select Organization Name, Company Number, or DUNS Number from the
Enter Search Criterion drop-down list.

Enter a minimum of three characters into to the search field.
The "%" and "_" (underscore) symbols are wildcards.
Click Go.

A list of search results appear in the window.

7. Click the Organization Name.

The Approval Preferences window opens.

8. Click the approval list that you want to update.

The Approver Selection Order window for the organization opens.

9. Enter the Approver Selection information.

a.

b.

g.
h.

Enter a number to define the order that each approver gets the request.

Enter the name of the first approver into the Approverl field or click Go to
search for an approvers name.

Enter your search criteria and click Go.

The Search Results appear in the window.

Select the option button for the user that you want to be the approver.
Click Add User.

The user’s name appears in the text field.

(Optional) Enter the name of additional approvers into the other Approver
fields (repeat steps a-e).

(Optional) Click Cancel to clear the fields.
(Optional) Click add 5 more rows to add five empty approver fields.

10. Click Submit to save.

See Also
= Creating a New Approval Type

= Removing an Approval Type

= Searching for an Approval Type
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Editing an Approval Type’s Details
Enabling and Disabling Approval Types
Searching for an Organization

Viewing Approval Preferences

2.22 Creating an Enroliment

An enrollment is an optional step in the user registration process. From the Create
Enrollment window, you can define enrollments and approvals for enrollments.
Each enrollment may or may not have a role associated with it. Perform the
following steps to create an enrollment.

Prerequisites

You must be the system administrator or the primary user with the appropriate
permissions to create an enrollment.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click Enrollments in the side navigation bar.

The Available Enrollments window opens.

Click Create New Enrollment.

The Create Enrollment window opens.

Define the following information:

a. Enter an Enrollment Key.

b. Enter a name for the new enrollment.

c. (Optional) Enter a description for the new enrollment. This description can
include HTML tags for style. There is a 2000 character limit in the field that
includes all HTML tags.

Select roles and responsibilities.

a. Select a responsibility from the Responsibility drop-down list. If no
responsibility is required, choose No Responsibility is Required.
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b. Select the name of a role in the Available list and click > to move it to the
Assigned list. You can hold down the [CTRL] key and use your mouse to
select multiple roles.

c. Repeat the previous step to add more roles to the list.

d. To move all Available Roles to the Assigned Roles list, then click >> or to
move all Assigned Roles to the Available Roles list, then click <<.

e. Select an application from the drop-down list.

f. Select an approval from the drop-down list. If no approvals are required for
the user to subscribe to the service, choose No Approval Required.

g. Select an enrollment template from the drop-down list.
8. (Optional) Click Reset to clear the fields.
9. Click Create to save your changes.

A confirmation appears stating the enrollment was created successfully.

See Also
= Defining a User’s Enrollment

= Removing an Enrollment
= Enabling and Disabling Enrollments

» Editing an Enrollment’s Details

2.23 Removing an Enrollment

Perform the following steps to delete an enrollment.

Prerequisites

You must be the system administrator with the appropriate permissions to delete an
enrollment.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.

3. Click Setup on the main navigation bar.
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4. Click Enrollments in the side navigation bar.
The Available Enrollments window opens.

5. Select the check box in the Remove column that corresponds to the enrollment
that you plan to delete.

6. Click Update to remove the enrollment or click Restore to reset the original
values in the window.
A confirmation window opens.

7. If you are sure you want to delete the enrollment, click Confirm and Update
Now.

See Also

Defining a User’s Enrollment
Creating an Enrollment
Enabling and Disabling Enrollments

Editing an Enrollment’s Details

2.24 Enabling and Disabling Enroliments

An enrollment is an optional step in the user registration process. Perform the
following steps to enable or disable an enrollment.

Prerequisites

You must be the system administrator with the appropriate permissions to modify
the status of an enrollment.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click Enrollments in the side navigation bar.

The Available Enrollments window opens.

If you want to enable an enrollment, select Enabled from the drop-down list in
the corresponding Status column.
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6. If you want to disable an enrollment, select Disabled from the drop-down list
in the corresponding Status column.

7. Click Update to modify the information or click Restore to reset the original
values in the window.
A confirmation window opens.

8. Click Confirmed and Update Now.
The enrollment status is modified.

See Also

Defining a User’s Enrollment
Creating an Enrollment
Removing an Enrollment

Editing an Enrollment’s Details

2.25 Editing an Enroliment's Details

An enrollment is an optional step in the user registration process. Perform the
following steps to edit an enrollment's details.

Prerequisites

You must be the system administrator with the appropriate permissions to edit an
enrollment’s details.

Steps

1.
2.
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click Enrollments in the side navigation bar.

The Available Enrollments window opens.

Click the name of the enrollment.

The Update Enrollment window opens.

Edit the fields as desired and click Next.
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7. Select the Assign the changed role to existing users of this Enrollment check
box if you want previously registered users to be granted the specified role.

8. Assign new roles as needed.

9. Select the Assign the changed responsibility to existing users of this
Enrollment check box if you want previously registered users to be granted the
specified responsibility.

10. (Optional) Click Reset to reset the fields to their original settings or click
Update to save your changes.

A confirmation window opens.

See Also
= Defining a User’s Enrollment

= Creating an Enrollment
= Removing an Enrollment

= Enabling and Disabling Enrollments

2.26 Creating a User Type

2-30 Oracle CRM

A user type is a category of users based on common responsibilities and roles.
Oracle is shipping predefined user types in the 11.5.6 release (Primary, Business,
and Individual users) and defined enrollments attached to these user types
out-of-the-box. These enrollments include different roles and responsibilities. If you
are a legacy user uptaking the new user management framework, you no longer
have access to the default roles and responsibilities windows. The user type
definition replaces these windows. Roles and responsibilities defined at the user
level are the default. Perform the following steps to create a new user type.

Prerequisites

You must be the system administrator with the appropriate permissions to create a
new user type.
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Note: If you deselect the Enabled Self-service Registration check
box when you create a new user type, the user type does not appear
in the self-service registration window when you click the "Register
Here" link unless the user has the JTF_SECURITY_ASSIGN_ROLE
permission. At runtime, the system validates that the user has this
permission, if not, it confirms if the check box is selected and only
show the user types that are available for self-service.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click User Types in the side navigation bar.

The Available User Types window opens.

Click Create New User Type.

The User Type Details window opens.

Define the following information:

a. Enter a user type name.

b. Enter a user type key.

c. (Optional) Enter a description into the Description field. This description
can include HTML tags for style. There is a 2000 character limit in the field
that includes all HTML tags.

d. (Optional) Select Enable Self-service Registration to display the new user
type during the registration process from the "Register Here" link.

e. Use the drop-down list to select the registration template default. Options
include: Business, Individual, or Primary user.

f. Use the drop-down list to select the approval by information. For example,
JTE User Approval or No approval is required.

Click Next to save and go on to the next form.
The Roles and Responsibilities window opens.

Define the following information:
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a. Use the drop-down list to select a user type responsibility.

b. (Optional) Select the Assign the changed responsibility to existing users
of this user type check box if you want other users registered under this
user type to be granted the responsibility specified. If no change is made to
the responsibility, no update occurs.

c. To assign roles, select the name of a role in one list and then click > or < to
move it to the other list. Repeat this step for as many roles you want to
assign.

d. If you want to move all Available Roles to the Assigned Roles list, then click
>>.

e. If you want to move all Assigned Roles to the Available Roles list, then click
<<.

f. (Optional) Select the Assign the changed role to existing users of this user
type check box if you want other users registered under this user type to be
granted the role specified. If no change is made to the roles, no update
occurs.

9. Click Next to save and go on to the next form or click Restore to revert back to
the original values in the window.

The Enrollments window opens.
10. Define the following information:

a. If you want to activate an enrollment for a user type, select Yes from the
drop-down list in the Enroll column.

b. If you do not want to enroll the user type in an enrollment, select No from
the drop-down list in the Enroll column.

c. Select Implicit or Explicit from the drop-down lists to define the activation
mode.

d. Enter a number into the fields in the Order column to set enrollment order.

e. If you want to edit an enrollment's details, then click the name of the
enrollment.

11. Click Next to save and go on to the next form or click Restore to revert back to
the original values in the window.

The User Types window opens with the newly created user type added to the
table.
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See Also

Removing a User Type

Activating and Deactivating User Types
Searching for a User Type

Editing a User Type’s Details

2.27 Removing a User Type

A user type is a category of users based on common responsibilities and roles. A
user type can be removed as long as it is not enabled (in use). Perform the following
steps to remove a user type.

Prerequisites
You must be the system administrator with the appropriate permissions to remove a

user type.
Steps
1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click Setup on the main navigation bar.
4. Click User Types in the side navigation bar.
The Available User Types window opens.
5. Select the check box in the Remove column that corresponds to the user type
that you want to delete.
6. Click Update to delete the User Type or click Restore to reset the original values
in the window.
A confirmation window opens.
7. Click Confirm to delete the User Type or click Cancel to cancel the deletion.
See Also

Creating a User Type
Activating and Deactivating User Types
Searching for a User Type
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Editing a User Type’s Details

2.28 Activating and Deactivating User Types

A user type is a category of users based on common responsibilities and roles.
Perform the following steps to activate or deactivate a user type.

Prerequisites

You must be the system administrator with the appropriate permissions to modify
the status of a user type.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.

2. Select the Users tab.

3. Click Setup on the main navigation bar.

4. Click User Types in the side navigation bar.
The Available User Types window opens.

5. If you want to activate an enrollment, select Active from the drop-down list in
the corresponding Status column.

6. If you want to deactivate an enrollment, select Inactive from the drop-down list
in the corresponding Status column.

7. Click Update to modify the status of the user type or click Restore to reset the
original values in the window.

See Also

s Creating a User Type

= Removing a User Type

Searching for a User Type
Editing a User Type’s Details

2.29 Searching for a User Type

A user type is a category of users based on common responsibilities and roles.
Perform the following steps to search for a user type.
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Prerequisites

You must be the system administrator with the appropriate permissions to search
for a new user type.

Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.
Click Setup on the main navigation bar.
Click User Types in the side navigation bar.
The Available User Types window opens.
If you want to search by the User Type Name, then:
a. Enter your search phrase into the text input field.
b. Click Go.

The results appear in the window.
If you want to search by the User Type Key, then:
a. Enter your search phrase into the text input field.
b. Click Go.

The results appear in the window.

See Also

Creating a User Type

Removing a User Type

Activating and Deactivating User Types
Editing a User Type’s Details

2.30 Editing a User Type's Details

A user type is a category of users based on common responsibilities and roles.
Perform the following steps to edit a user type's details.
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Prerequisites

You must be the system administrator with the appropriate permissions to modify
the user type’s details.

Steps

1.
2.
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click User Types in the side navigation bar.

The Available User Types window opens.

Click the name of the user type in the User Type Name column.
The User Type Details window opens.

Edit the fields as desired.

(Optional) Click Clear to reset the fields to their original settings.
Click Next to save and go on to the next form.

The Roles and Responsibilities window opens.

Edit the information as needed.

a. Use the drop-down list to select a user type responsibility.

b. (Optional) Select the Assign the changed responsibility to existing users
of this user type check box if you want other users registered under this
user type to be granted the responsibility specified.

c. To assign roles, select the name of a role in one list and then click > or < to
move it to the other list. Repeat this step for as many roles you want to
assign.

d. If you want to move all Available Roles to the Assigned Roles list, then click
>>.

e. If you want to move all Assigned Roles to the Available Roles list, then click
<<.

f. (Optional) Select the Assign the changed role to existing users of this user
type check box if you want other users registered under this user type to be
granted the role specified.

2-36 Oracle CRM Technology Foundation Concepts and Procedures



Creating a Template

10. Click Next to save and go on to the next form or click Restore to revert back to
the original values in the window.

The Enrollments window opens.

11. Edit the information as needed.

a.

If you want to enroll the user type in an enrollment, select Yes from the
drop-down list in the Enroll column.

If you do not want to enroll the user type in an enrollment, select No from
the drop-down list in the Enroll column.

Select Implicit or Explicit from the drop-down lists to define the type.
Enter a number into the fields in the Order column to set enrollment order.

If you want to edit an enrollment's details, then click the name of the
enrollment.

12. Click Next to save and go on to the next form or click Restore to revert back to
the original values in the window.

The User Types window opens with the newly updated user type information.

See Also
»  Creating a User Type

= Removing a User Type

= Activating and Deactivating User Types

= Searching for a User Type

2.31 Creating a Template

A template is an application-specific set of JSPs that you can use to customize the
user registration process. There are two template categories, user types and
enrollments. Perform the following steps to create a template.

Prerequisites

You must be the system administrator with the appropriate permissions to create a
new template.
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Steps

1.
2,
3.

Log in to the CRM System Administrator Console as a system administrator.
Select the Users tab.

Click Setup on the main navigation bar.

Click Templates on the side navigation bar.

The Available Templates window opens.

Click Create New Template.

The Create Template window opens.

Enter the following required information.

a. Enter the template key.

b. Enter a name for the template.

c. (Optional) Enter a description for the template.

d. Select a template type from the drop-down list. Options include user type
template or enrollment template.

e. Enter the name of the template handler. The template handler is a java class
implemented by the application to handle the registration data at runtime.

f. Enter the name of JSP page that is the first window of the template flow
into the Page Name field. The extension of the window must be " jsp".

g. Select an application from the drop-down list.
(Optional) Click Reset to clear the fields.

Click Create to save your information.

See Also

Removing a Template
Enabling and Disabling Templates
Editing a Template’s Details

Searching for a Template
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2.32 Removing a Template

A template is an application-specific set of JSPs that you can use to customize the
user registration process. Perform the following steps to delete a template.

Prerequisites
You must be the system administrator with the appropriate permissions to remove a

template.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.

2. Select the Users tab.

3. Click Setup on the main navigation bar.

4. Click Templates on the side navigation bar.
The Available Templates window opens.

5. Select the check box in the Remove column that corresponds to the template
that you want to delete.

6. Click Update to delete the template or click Restore to reset the original values
in the window.
A confirmation window opens.

7. Click Confirm Update to delete the template or click Cancel to return to the
Available Templates window.

See Also

Creating a Template
Enabling and Disabling Templates
Editing a Template’s Details

Searching for a Template

2.33 Enabling and Disabling Templates

A template is an application-specific set of JSPs that you can use to customize the
user registration process. A template can be assigned to many enrollments and user
types. Perform the following steps to enable or disable a template.
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Prerequisites

You must be the system administrator with the appropriate permissions to modify
the status of a template.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.

2. Select the Users tab.

3. Click Setup on the main navigation bar.

4. Click Templates on the side navigation bar.
The Available Templates window opens.

5. If you want to enable a template, select Enabled from the drop-down list in the
corresponding Status column.

6. If you want to disable a template, select Disabled from the drop-down list in
the corresponding Status column.

7. Click Update to modify the template’s status or click Restore to reset the
original values in the window.
A confirmation window opens.

8. Click Confirm Update to modify the template’s status or click Cancel to return
to the Available Templates window.

See Also

Creating a Template
Removing a Template
Editing a Template’s Details

Searching for a Template

2.34 Editing a Template's Details

A template is an application-specific set of JSPs that you can use to customize the
user registration process. Perform the following steps to edit a template's details.
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Prerequisites

You must be the system administrator with the appropriate permissions to modify a
template’s details.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
2. Select the Users tab.
3. Click Setup on the main navigation bar.
4. Click Templates on the side navigation bar.
The Available Templates window opens.
5. Click the name of the template in the Template Name column.
The User Management: Update Template window opens.
6. Edit the fields as desired.
7. (Optional) Click Clear to reset the fields to their original settings.
8. Click Update to save your changes.

See Also
= Creating a Template

= Removing a Template
= Enabling and Disabling Templates

= Searching for a Template

2.35 Searching for a Template

A template is an application-specific set of JSPs that you can use to customize the
user registration process. Perform the following steps to search for a template.

Prerequisites

You must be the system administrator with the appropriate permissions to search
for a template.

Steps

1. Log in to the CRM System Administrator Console as a system administrator.
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2. Select the Users tab.

3. Click Setup on the main navigation bar.

4. Click Templates on the side navigation bar.
The Available Templates window opens.

5. Select how you want to search for the template. Options include Template
Name or Template Key from the drop-down list.

6. Enter your search criteria into the text field.

7. Click Go.
Your search results appear in the window.

See Also

Creating a Template

Removing a Template

Enabling and Disabling Templates
Editing a Template’s Details

2.36 Managing Security

You can perform the following tasks from the Security subtab:

Viewing Security Alerts

Managing Roles

— Creating Roles

- Mapping Permissions to a Role
Managing Permissions

— Creating Permissions

— Assigning a Permission to Roles

For information on Security concepts, see Understanding Security.
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2.37 Managing Roles

A role is a grouping of one or more permissions. Use this procedure to manage
roles.

Prerequisites

Read Understanding Security

Navigate to Settings > Security > Access Controls > Roles

Steps

1.

If you want to create a new role, then click Create.
This opens the page where you edit the details of a new role.
If you want to use the search for a role, then:
a. Type your search phrase into the Find Roles field.
b. Click Go.
The search results display.

Optionally, click First, Previous, Next, Last, or an option from the drop-down
list to navigate within the table.

If you want to map permissions to a particular role, then click the name of a role
in the Role column of the table.

This opens the page where you map permissions to a role.
If you want to delete a role, then:

a. Select the appropriate check box in the Remove column of the table. If the
check box is disabled, then you cannot remove the role.

b. Optionally, click Restore to reset the fields to their original settings.

c. A new screen displays, asking you to confirm that you want to delete the
role. To cancel, click Cancel. To delete the role, click Update.

The role is removed and revoked from all users who are assigned to the
role.

2.38 Creating Roles

Use this procedure to create a new role.
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Prerequisites
= Read Understanding Security

= Navigate to Settings > Security > Access Controls > Roles, then click Create

Steps

1. Type a new role name into the Name field.

The first two or three letters of a role name correspond to the module shortcode.
Role names can be similar but not identical.

Type a description of the role into the Description field.

Select the Data check box, if applicable.

Optionally, click Clear to clear the content of the fields.

Optionally, click Back to Summary Page to return to the main Roles page.

@ o » w N

Click Update to save.

The new role is filed in alphabetical order.

2.39 Mapping Permissions to a Role

A role is a grouping of one or more permissions. Use this procedure to map
permissions to a role.

Prerequisites
= Read Understanding Security

= Navigate to Settings > Security > Access Controls > Roles, then click the name
of arole in the table

Steps
1. Choose the name of a permission in one list and click > or < to move it to the
other list.

2. Repeat step 1 as desired.

3. If you want to move all Available Permissions to the Assigned Permissions list,
then click >>.

4. If you want to move all Assigned Permissions to the Available Permissions list,
then click <<.
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5.
6.

Optionally, click Restore to reset the fields to their original values.

Click Update to save.

2.40 Managing Permissions

A permission has a name and a description. Use this procedure to manage
permissions.

WARNING! Do not remove the pre-defined permissions that are
built into the System Administrator Console. These pre-defined
permissions are essential for stable and reliable performance of
all Oracle CRM modules. Removal of these permissions could
cause serious or fatal performance problems.

Prerequisites

Read Understanding Security

Navigate to Settings > Security > Access Controls > Permissions

Steps

1.

If you want to create a new permission, then click Create.
This opens the page where you edit the details of a new permission.
If you want to search for a permission, then:
a. Type your search phrase into the text input field.
b. Click Go.
The search results display.

Optionally, click First, Previous, Next, Last, or an option from the drop-down
list to navigate within the table.

If you want to assign a permission to roles, then click the name of a permission
in the table.

This opens the page where you assign a permission to roles.
If you want to delete a permission, then:

a. Select the appropriate check box in the Remove column of the table.
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b. Optionally, click Restore to reset the fields to their original settings.
c. Click Update to save.

The permission is removed.

2.41 Creating Permissions

Use this procedure to create a new permission.

Prerequisites
= Read Understanding Security

= Navigate to Settings > Security > Access Controls > Permissions, then click
Create

Steps

1. Type a new permission name into the Name field.

The first two or three letters of a role name correspond to the module shortcode.
Role names can be similar but not identical.

Type a description of the permission into the Description field.
Select the Data check box, if applicable.
Optionally, click Clear to clear the content of the fields.
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Optionally, click Back to Summary Page to return to the main Permissions
page.
6. Click Update to save.

The new permission is filed in alphabetical order.

2.42 Assigning a Permission to Roles

Use this procedure to assign a permission to roles.

Prerequisites
= Read Understanding Security

= Navigate to Settings > Security > Access Controls > Permissions, then click
the name of a permission in the table
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Steps

1. Choose the name of a role in one list and click > or < to move it to the other list.
Repeat step 1 as desired.
If you want to move all Available Roles to the Assigned Roles list, then click >>.

2
3
4. If you want to move all Assigned Roles to the Available Roles list, then click <<.
5. Optionally, click Restore to reset the fields to their original values.

6

Click Update to save.

2.43 Using Site Preferences

Site Preferences are features that allow you to personalize your deployment of CRM
applications.

You can perform the following tasks from the Site Preferences subtab:
= Setting Up Navigation Groups
» Editing Navigation Group Details

For information on Site Preferences concepts, see Understanding Site Preferences.

2.44 Setting Up Navigation Groups

Use the following procedure to set up Navigation Groups, which are the links in the
Interapplication Bar that represent customizable sets of applications with defined
responsibility settings. The Interapplication Bar is the group of links that display at
the top of every page in HTML-based CRM applications.

Prerequisites
= Read Understanding Site Preferences

= Navigate to Settings > Site Preferences > Interapplication Bar > Navigation
Group Setup

Steps

1. Type Navigation Group names and descriptions into the Group Name and
Description fields.

2. For each Navigation Group, choose Active or Inactive from the drop-down list
in the Status column.
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Only active groups display on the Interapplication Bar.

3. Type numbers into the Display Order fields to set the order of the Navigation
Groups within the Interapplication Bar (from left to right).

4. Optionally, click the icon in the Detail column.
This opens the page where you map CRM applications to a Navigation Group.

5. If you want to remove an application group, then select the appropriate check
box in the Remove column of the table.

6. Click Update to save.

2.45 Editing Navigation Group Details

Use this procedure to map CRM applications to Navigation Groups. A Navigation
Group is a customizable set of applications with defined responsibility settings that
is launched when you click its link in the Interapplication Bar. The Interapplication
Bar displays at the top of every page in HTML-based CRM applications.

Prerequisites
= Read Understanding Site Preferences.

= Navigate to Settings > Site Preferences > Interapplication Bar > Navigation
Group Details

Steps

1. Choose a Navigation Group from the drop-down list.
The page refreshes to display additional fields.

2. Choose the name of an application in one list and click > or < to move it to the
other list.

3. Repeat step 2 as desired.

4. If you want to move all Available Applications to the Selected Applications list,
then click >>.

5. If you want to move all Assigned Applications to the Selected Applications list,
then click <<.

6. Optionally, click Restore to reset the fields to their original values.

7. Click Update to save.
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2.46 Using the System Subtab

In the System subtab, you can define the system level properties that you need to
set up during deployment. You can reconfigure the properties later as necessary.

You can perform the following tasks from the System subtab:
= Setting Up the Self Service User

= Setting Up Branding

= Setting Up Cookies

= Setting Up Sessions

= Setting Up Logging Trails

= Setting Up Categories

= Managing Properties

= Editing the Details of Keys

= Setting Up Password Expiration

For information on System subtab concepts, see Understanding the System Subtab.

2.47 Setting Up the Self Service User

You must set up a self service user (guest user) after deploying applications. This
procedure allows you to grant privileges to new users during self registration. Use
the following procedure to set up the self service user.

Prerequisites
= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Self Service User

Steps

1. Type a name into the Name field.

2. Type a password with at least six characters into the Password field.
3. Confirm the password by retyping it into the Retype Password field.
4. Optionally, click Restore to reset the fields to their original settings.
5. Click Update to save.
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2.48 Setting Up Branding

Branding is the wording that displays at the top left of every application page. You
can customize the branding once the application has been deployed at a customer
site.

The branding can be defined at both application level and responsibility level. A
responsibility can only belong to one application and an application can have
multiple responsibilities. If the branding for a particular responsibility is not set, the
branding for all responsibilities within the application (application level) will be
used. If the branding for a particular responsibility is set, the branding will take
precedence and override the branding set at application level.

For example, for the application CRM Foundation, you could set the branding to
"Admin Console" at application level (the default for all responsibilities). Given two
CRM Foundation users, one with the CRM Administrator responsibility and the
other with the HTML Foundation User responsibility, when they log in, both will
see "Admin Console."

However, if you customize the branding for the HTML Foundation User
responsibility to "HTML User," then when those users log in they will see "HTML
User." Users having the responsibility CRM Administrator will still see "Admin
Console."

Use this procedure to set up branding.

Prerequisites
= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Branding

Steps

1. Choose an application from the Application Name drop-down list.

2. Choose which responsibility applies to the branding from the Responsibility
Name drop-down list. In some cases, you may only have one option, Default
Branding for this Application.

3. Type into the Branding Name field to set the branding.
4. Optionally, click Restore to reset the fields to their original settings.
5. Click Update to save.

The page refreshes to display a preview of the new branding.
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2.49 Setting Up Cookies

Cookies store information about users and systems as users log in to applications.
Use this procedure to set up cookies.

Prerequisites
= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Cookies

Steps
1. Type the name of the cookie into the Name field.

The name will be given the database ID as a prefix.
2. Choose browser or URL from the Type drop-down list.

This sets whether browser cookies or URL rewriting is used.
3. Type the encryption key into the Encryption Key field.
4. Type a number into the Expiration Time field.

This is the number of expiration units (time intervals) that pass before the
cookie expires. Set the expiration unit below.

5. Choose Day, Hour, or Minute from the Expiration Unit drop-down list.
6. Optionally, click Restore to reset the fields to their original settings.
7. Click Update to save.

2.50 Setting Up Sessions

Sessions are system properties that track the activity of users and whether or not
users have left the domain. Use this procedure to set up sessions.

Prerequisites
= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Sessions

Steps

1. Complete the Applications Sessions section.
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a. Type a number of hours into the ICX Time Limit field.
b. Type a maximum number of requests into the ICX Connection Limit field.
c. Type a number of minutes into the Inactive Session Timeout field.

2. Complete the Sticky Sessions section.

When using Sticky Sessions, all requests from the same user session will
attempt to go to the same JVM, regardless of whether the application is in
stateless mode or stateful mode. Sticky Sessions allow for several performance
enhancements. In particular, the hit ratio of middle tier caching is improved
because all cached data for a particular user resides on a single JVM rather than
being scattered across different JVM instances. In addition, session attributes
and resources will not have to be recreated and duplicated across different
JVMs, but can be reused in the JVM associated with the session.

a. Choose True or False from the Sticky Session Flag drop-down list.
b. Type a number of milliseconds into the Cleanup Time Interval field.

c. Type a number of minutes into the Session Context Inactive Time Limit
field.

d. Choose True or False from the Connection Reuse Flag drop-down list.
3. Optionally, click Restore to reset the fields to their original settings.
4. Click Update to save.

2.51 Setting Up Logging Trails

Loggings are system properties that you set up to debug any system-related codes.
Framework Logging is used by the CRM Technology Foundation, while Service Logging is
used by all applications. They are particularly useful during early deployment. Use
this procedure to set up loggings.

Prerequisites
= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Logging Trails

Steps

1. Complete the Framework Logging Options section.

a. Type the name of the file to be used for logging into the File Name field.
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b. Choose Debug, Fatal, or None from the Level drop-down list.
2. Complete the Service Logging Options section.
a. Type the name of the file to be used for logging into the File Name field.
b. Choose Debug, Fatal, or None from the Level drop-down list.
c. Choose File from the Mode field.
d. Choose FIFO or LIFO from the Pool field.
3. Optionally, click Restore to reset the fields to their original settings.
4. Click Update to save.

2.52 Setting Up Property Categories

Use this procedure to set up applications in the system properties framework
during the development phase.

Prerequisites
= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Category

Steps

1. Choose an application from the Application Name drop-down list.
2. Choose Read or Update from the READ/UPDATE drop-down list.
3. Optionally, click Restore to reset the fields to their original settings.
4. Click Next.

This opens the page where you can map this permission to one or more roles.

2.53 Managing Properties

A property is a key/value pair that is application-specific. A key is what is used by
an application to retrieve data. Keys are unique, but can have multiple values.
Values are the content or data that binds to a particular key. Use this procedure to
create and manage properties.
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Prerequisites
= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Advanced

Steps

1. Choose a module shortcode from the View drop-down list.
The page refreshes to display the properties registered for that module.
2. If you want to create a key, then click Create.
This opens the page where you specify the details of a new key.
3. Optionally, click First, Previous, Next, and Last to navigate within the table.

4. If you want to view or modify the details of a key, then click a key name in the
table.

This opens the page where you view or edit the details of an existing key.

5. If you want to remove a key, then select the appropriate check box in the
Remove column of the table.

6. Optionally, click Restore to reset the fields to their original settings.
7. Click Update to save.

2.54 Editing the Details of Keys

A property is a key/value pair that is application-specific. A key is what is used by
an application to retrieve data. Keys are unique, but can have multiple values.
Values are the content or data that binds to a particular key. Use this procedure to
edit the details of new or existing keys.

Prerequisites

= Read Understanding the System Subtab

= Navigate to Settings > System > Properties > Advanced, then either click
Create or click the name of a key in the table.

Steps
1. Type a key name into the Key field.

2. Edit the table.
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a. Type values into the Value fields as desired.
b. Type sequence numbers into the Sequence fields as desired.

c. If you want to remove a value, then select the appropriate check box in the
Remove column.

d. Optionally, click More Rows to add empty rows to the table.

If you want to resequence the key, then click Resequence.

If you want to copy the key, then click Copy Key.

If you are creating a new key and want to clear the fields, then click Clear.

If you are editing an existing key and want to restore the fields to their original
settings, then click Restore.

Click Update to save.

2.55 Setting Up Password Expiration

Use this procedure to define for how many days a password is valid.

Prerequisites
None

Steps

1.

Type a non-negative integer into the field. This is the number of days after
which passwords will expire.

Optionally, click Restore to reset the field to its original setting.

Click Update to save. Upon saving, the value saved is only effective for
passwords created or updated from this moment on.

2.56 Managing Configuration

You can perform the following tasks from the Configuration subtab:

Setting Up Hosts
Editing Host Details
Editing Resource Settings

For information on Configuration concepts, see Understanding Configuration.
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2.57 Setting Up Hosts

The Hosts Setup page is the starting point for viewing, creating, updating, and
removing hosts. Use this procedure to manage hosts.

Prerequisites
= Read Understanding Configuration

= Navigate to Deployment > Configuration > Hosts

Steps

1. If you want to register a host, then click Create.

This opens the page where you edit the details of a new host. You must register
all mid-tier hosts.

2. If you want to modify the attributes of a host, then click a name in the Host
Name column.

This opens the page where you edit the details of an existing host.
3. If you want to remove a host, then:
a. Select a check box in the Remove column.
b. Optionally, click Restore to reset the fields to their original settings.
c. Click Update to save.

2.58 Editing Host Details

Use this procedure to edit the details of new or existing hosts.

Prerequisites
= Read Understanding Configuration

= Navigate to Deployment > Configuration > Hosts, then either click Create or
click the name of a host in the table

Steps
1. Edit the Hostname field:

a. If you are creating a new host, then type the name of the mid-tier URL into
the Hostname field.
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For example, "computer.us.oracle.com."
b. If you are updating an existing host, then you cannot edit this field.
Type a description into the Description field.
Ignore the Utilize Look-ahead Cache check box.
Edit port numbers:

a. Type the port number where the Apache in this mid-tier host runs into the
first Port field.

For example, "9999"

b. If there are multiple Apache instances running on the same mid-tier host,
then type additional port numbers into the Port column.

For example, "9999" and "8080"

c. If you want to remove a port, then select the appropriate check box in the
Remove column.

Edit application deployment:

This information is used by the caching framework to cache and prime only the
data for the configured set of applications.

a. Choose the name of an application in one list and click > or < to move it to
the other list.

b. Repeat step a as desired.

c. If you want to move all Available Applications to the Deployed
Applications list, then click >>.

d. If you want to move all Deployed Applications to the Available
Applications list, then click <<.

Optionally, if you are creating a new host and want to clear the fields, then click
Clear.

Optionally, if you are updating an existing host and want to reset the fields to
their original settings, then click Restore.

If you are creating a new host, then click Create to save.

If you are updating an existing host, then click Update to save.
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2.59 Editing Resource Settings

Use this procedure to manage resource settings for the cache.

Prerequisites
= Read Understanding Configuration

= Navigate to Deployment > Configuration > Resource Settings

Steps

1. Define cache resource settings:

a. Type a number of megabytes into the Disable Cache if Total Memory
Exceeds field.

Typically this represents a percentage of the maximum memory of the JVM.
2. Ignore the Define Look-ahead Cache Resource Settings section.
3. Optionally, click Restore to reset the fields to their original settings.
4. Click Update to save.

2.60 Viewing System Alerts

The System Alerts page displays statistics regarding the health of a deployed
system. It complements the Diagnostics framework to guide you when
troubleshooting failures or misconfigurations. Use this procedure to view system
diagnostics data.

Prerequisites

= Navigate to Deployment > System Statistics > System Alerts, or to see
Security-related alerts, navigate to Settings > Security > Alerts Monitor

Steps
1. If you are in the Deployment tab, then:

a. Choose "All Applications" or a specific application from the Application
drop-down list.

b. Choose "All Nodes" or a specific node (host) from the Node drop-down list.

c. Choose which statuses you want to display (All Status, Succeeded, Failed,
or Warning) from the Status drop-down list. Click Go to run the filter.
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d. Optionally, click the calendar icons next to the From and To fields to select a
date range. Click Go to run the filter.

e. View the data displayed on the Monitor board.
2. Ifyou are in the Settings tab, then you see only security-related tests:

a. If you want to run the test group on a specific host, then choose the host
name from the drop-down list.

The page refreshes to display an additional drop-down list.
b. Choose alaunch type from the second drop-down list.
c. Click Launch to run the tests.

d. View the results in the colored table below.

2.61 Viewing Jserv Statistics

Use this procedure to view the Jserv statistics of a particular host.

Prerequisites
= Navigate to Deployment > System Statistics > Jserv Statistics

= Have the full host name ready to type in (for example,
computer.companyname.oracle.com:8888)

= Optionally, have the Jserv ID ready to type in (for example, test.js1)

Steps

1. Type a host name into the Hostname field.
2. Optionally, type a Jserv ID into the Jserv ID field.
3. Click Submit.
A new page displays.
4. View memory, thread, connection pool, session, and services statistics.

5. Optionally, click Back to go to the previous page.
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2.62 Using Diagnostics

Note: You can also navigate to the CRM Diagnostics page by
typing the following URL into a Web browser:
http:/ /hostname:portnumber / OA_HTML/jtfqalgn.htm

This is particularly useful if the deployment is having startup
problems.

You can perform the following tasks from CRM Diagnostics:
Running Test Groups

In the Basic tab, you can run groups of tests either all at once or individually.
Running Tests

In the Advanced tab, you can run tests one at a time. If desired, you can specify
input values that are different from the defaults.

Managing Test Groups

Creating Test Groups

Updating Test Groups
Managing Tests

Registering Tests

Setting Default Test Input Values
Managing Applications

In the Configuration tab, you can set up the applications, test groups, and tests
that are used in Diagnostics.

For information on Diagnostics framework concepts, see Understanding
Diagnostics.

2.63 Running Test Groups

You can perform the following tasks from the Basic tab:
Running All Test Groups
Running One Test Group
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For information on Diagnostics framework concepts, see Understanding
Diagnostics.

2.64 Running All Test Groups

Test groups are logical sets of one or more related tests. Tests verify the correct
behavior of a particular feature or function. Use this procedure to run all test groups
on an application.

Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Basic tab

Steps

1. Choose an application from the Application drop-down list.
2. Click Run All Groups.
3. View the test results.

4. If you want to view a detailed summary of a test, then click the icon in the
Report column.

2.65 Running One Test Group

Test groups are logical sets of one or more related tests. Tests verify the correct
behavior of a particular feature or function. A group can have one or more other
groups as prerequisites. Use this procedure to run a specific test group on an
application.

Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Basic tab

Steps

1. Choose an application from the Application drop-down list.

2. Click the name of the test group.
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3. If you want to run the test group’s prerequisite group or groups, then click Run
With Prerequisite.

You can view the names of the prerequisite group or groups in the Prerequisites
drop-down list.

4. If you want to run the test group alone, then click Run Without Prerequisite.
5. View the test results.

6. If you want to view a detailed summary of a test, then click the icon in the
Report column.

2.66 Running Tests

Tests verify the correct behavior of a particular feature or function. Use this
procedure to run a test on an application.

Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Advanced tab

Steps
1. Choose an application from the Application drop-down list.

2. C(lick the name of the test.

3. If you want to specify your own input values, then type them into the
appropriate fields. Otherwise, the test runs using default values.

4. Click Run Test.
5. View the test results.

6. If you want to view a detailed summary of a test, then click either the icon in
the Report column or View Report.

2.67 Managing Test Groups

The main page for test groups is the starting point for viewing, creating, updating,
prioritizing, and removing test groups. Test groups are logical sets of one or more
related tests. Tests verify the correct behavior of a particular feature or function. Use
this procedure to manage test groups. This procedure is not applicable to the
application "HTML Platform."
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Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Configuration tab, choose an application from the drop-down
list, then choose Groups.

Steps

1. If you want to create a new test group, then click Create.
This opens the page where you edit the details of a new test group.

2. If you want to update an existing test group, then click the Group Name.
This opens the page where you edit the details of an existing test group.

3. If you want to change the test group sequence, then choose the appropriate
numbers from the drop-down lists in the Sequence column.

4. If you want to remove a test group, then select the appropriate check box in the
Remove column.

5. Optionally, click Restore to reset the fields to their original settings.
6. Click Update to save.

2.68 Creating Test Groups

Test groups are logical sets of one or more related tests. Tests verify the correct
behavior of a particular feature or function. A test group can have one or more other
groups as prerequisites. Use this procedure to create test groups. This procedure is
not applicable to the application "HTML Platform."

Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Configuration tab, choose an application from the drop-down
list, choose Groups, then click Create

Steps
1. Type the name of the test group into the Group Name field.

2. If you want to set Group Prerequisites, then choose from the drop-down lists in
the Group Name column.

3. Optionally, click More Prerequisites to add more rows to the table.
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4. Optionally, click Restore to reset the fields to their original settings.

5. Click Create to save.

2.69 Updating Test Groups

Test groups are logical sets of one or more related tests. Tests verify the correct
behavior of a particular feature or function. A test group can have one or more other
test groups as prerequisites. Use this procedure to view or edit the name and
prerequisites of an existing test group. This procedure is not applicable to the
application "HTML Platform."

Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Configuration tab, choose an application from the drop-down
list, choose Groups, then click the name of a group in the table

Steps

1. If you want to rename the group, then type into the Group Name field.

2. If you want to remove a prerequisite, then select the appropriate check box in
the Remove column.

3. If you want to add a prerequisite, then choose from the drop-down lists in the
Group Name column.

4. If you want to view the individual tests that belong to that test group, then click
View Tests.

This opens the page where you manage how tests are organized into test
groups.

5. Optionally, click Restore to reset the fields to their original settings.
6. Click Update to save.

2.70 Managing Tests

The Tests Administration page is the starting point for viewing, creating, updating,
prioritizing, and removing individual tests. Tests verify the correct behavior of a
particular feature or function. Use this procedure to manage tests. This procedure is
not applicable to the application "HTML Platform."
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Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Configuration tab, choose an application from the drop-down
list, then choose Tests

Steps
1. Choose a group from the Group drop-down list.

2. View test names and class names display in the table.
3. If you want to create a test, then click Create.
This opens the page where you specify the details of a new test.

4. If you want to change the test sequence, then choose the appropriate numbers
from the drop-down lists in the Sequence column.

5. If you want to remove a test, then select the check box in the Remove column.
6. Optionally, click Restore to reset the fields to their original settings.
7. Click Update to save.

2.71 Registering Tests

Tests verify the correct behavior of a particular feature or function. Use this
procedure to register a test.

Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Configuration tab, choose an application from the drop-down
list, choose Tests, then click Create

Steps
1. Type the fully qualified name of the Java class into the Test Class Name field.

2. View the class names of any existing tests in the Existing Tests field.
3. Choose a sequence number from the Sequence drop-down list.

4. Optionally, click Restore to reset the fields to their original settings.
5

Click Create to save.
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2.72 Setting Default Test Input Values

Tests verify the correct behavior of a particular feature or function. Use this
procedure to set the default input values for a test. This procedure is not applicable
to the application "HTML Platform."

Prerequisites for This Procedure
= Read Understanding Diagnostics

= Navigate to the Configuration tab, choose an application from the drop-down
list, then choose Inputs

Steps

1. Click the name of a test.
Type default input values into the appropriate fields.
Click Update to save.

2
3
4. Optionally, type an additional set of default values and click Update.
5. Repeat step 4 as desired.

6. Optionally, click Restore to reset the fields to their original values.

7

If you want to delete an input value, then select the check box in the Remove
column and click Update.

2.73 Managing Applications

Applications must be registered to be included in CRM Diagnostics. Applications
can have other applications as prerequisites.

You can perform the following tasks to manage applications:
Registering Applications
Editing Application Prerequisites

For information on Diagnostics framework concepts, see Understanding
Diagnostics

2-66 Oracle CRM Technology Foundation Concepts and Procedures



Editing Application Prerequisites

2.74 Registering Applications

Prerequisites for This Procedure

Read Understanding Diagnostics

Navigate to Configuration > Applications, then click Create

Steps

1.
2,

Choose an application from the Choose an Application drop-down list.

If you want to set Application Prerequisites, then choose from the drop-down
lists in the Application Name column.

Optionally, click Restore to clear the Application Prerequisites fields.
Click Register to register the application.

View the new application display in the Application drop-down list at the top
of the page.

2.75 Editing Application Prerequisites

Applications can have other applications as prerequisites. Use this procedure to edit
application prerequisites.

Prerequisites for This Procedure

Read Understanding Diagnostics

Navigate to Configuration > Applications

Steps

1.
2.

Choose an application from the Application drop-down list.

If you want to remove an Application Prerequisite, then select the appropriate
check box in the Remove column.

If you want to add an Application Prerequisite, then choose from the
drop-down lists in the Application Name column.

Optionally, click Restore to reset the fields to their original settings.

Click Update to save.
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6. If you want to register an application to include it in CRM Diagnostics, then
click Create.

This opens the page where you register a new application and its prerequisites.

2.76 Using Cache

You can perform the following tasks from the Cache subtab:
= Managing Cache Policies
- Editing Cache Policy Details
= Managing Cache Filters
- Viewing Cache Filter Details
— Creating and Editing Cache Filters
= Managing Component Cache
- Editing Component Cache Details
= Viewing Cache Statistics

For information on Cache concepts, see Understanding Cache.

2.77 Managing Cache Policies

The Cache Policies table lists the Cache Policy of each application on each host. Use
this procedure to manage Cache Policies.

Prerequisites
= Read Understanding Cache

= Navigate to Performance > Cache > Applications > Policies

Steps
1. Choose a host name or All Hosts from the drop-down list labeled View to
choose which Cache Policies display in the table.

2. If you want to sort the table alphabetically by host name or application, then
click the appropriate link in the top row of the table.

3. If you want to edit the details of a Cache Policy, then click a policy name in the
table.
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This opens the page where you edit the details of a Cache Policy.

4. If you want to modify a row in the table, then select the check box in the Select
column.

5. If you want to set a Cache Policy, then choose Cache Only, Cache and Priming,
Disabled, or Custom from the drop-down lists in the Policy column.

If you enable caching, then all components of the application use the caching. If
you enable priming, then the components read some initial cache data when the
Jserv process begins. Priming can improve the performance for the first set of
users because the data that they need is already available in the cache.
However, priming can increase the size of the Java Virtual Machine. Disable the
cache if the size of the Java Virtual Machine grows too large.

6. If you want to set filters, then choose Enabled, Disabled or Custom from the
drop-down lists in the Filters column.

7. If you want to clear a cache, then click Clear Cache.

8. If you want to reload a cache, then click Reload Cache.

9. Optionally, click Restore to reset the fields to their original settings.
10. Click Update to save.

2.78 Editing Cache Policy Details

The Cache Policy Detail page displays the cache policy types for components of
applications running on a particular host. It also displays cache filters. Use this
procedure to edit the details of cache policies and cache filters.

Prerequisites
= Read Understanding Cache

= Navigate to Performance > Cache > Applications > Policies, then click the
name of a policy in the table

Steps
1. Edit the Component Cache Policy section:

a. If you want to modify a policy, then select the check box in the appropriate
row in the table.
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b. If you want to modify a cache policy, then choose Cache Only, Cache and
Priming, or Disabled from the drop-down list in the Policy column of the
table.

c. If you want to reload a cache, then choose it by selecting the appropriate
check box and then click Reload Cache.

d. If you want to clear a cache, then choose it by selecting the appropriate
check box and then click Clear Cache.

e. Optionally, click Restore to reset the fields to their original settings.
f. Click Update to save.

2. Edit the Cache Filters section:
a. Select or deselect check boxes in the Enabled column as desired.
b. Optionally, click Restore to reset the fields to their original settings.
c. Click Update to save.

2.79 Managing Cache Filters

The main page for cache filters is the starting point for viewing, creating, updating
and removing cache filters. Cache filters are application-specific components that
indicate the responsibility IDs and language codes for priming. Use this procedure
to manage cache filters.

Prerequisites
= Read Understanding Cache

= Navigate to Performance > Cache > Applications > Filters

Steps

1. Choose an application name from the drop-down list labeled View to choose
which Cache Filters display in the table.

2. Optionally, click First, Previous, Next, Last, or an option from the drop-down
list to navigate within the table.

3. If you want to create a new Cache Filter, then click Create.
This opens the page where you begin editing the details of a new Cache Filter.

4. If you want to view the details of a Cache Filter, then click a filter name in the
table.
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This opens the page where you view the details of a Cache Filter.
5. If you want to remove a filter, then:
a. Select the appropriate check box in the Remove column.
b. Optionally, click Restore to reset the fields to their original settings.
c. Click Update.

This removes the filter from the table.

2.80 Viewing Cache Filter Details

Use this procedure to view the details of a Cache Filter.

Prerequisites
= Read Understanding Cache

= Navigate to Performance > Cache >Applications > Filters, then click a filter
name in the table.

Steps

1. View the information displayed on the page.
2. If you want to edit the details of the Cache Filter, then click Edit.
This opens the page where you edit the details of an existing Cache Filter.

2.81 Creating and Editing Cache Filters

When you create a new Cache Filter or modify an existing Cache Filter, you
complete three different screens. The following procedures guide you through each
screen:

Step 1: Editing Basic Information
Step 2: Choosing Responsibilities
Step 3: Choosing Languages

After you finish creating or editing a Cache Filter, you return to the main Cache
Filters page.

For information on related concepts, see Understanding Cache.
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2.82 Step 1: Editing Basic Information

Use this procedure to enter basic information about a Cache Filter.

Prerequisites
= Read Understanding Cache

= Navigate to Performance > Cache >Applications > Filters. If you are creating a
new filter, then click Create. If you are modifying an existing filter, then click a
policy name in the table and click Edit after the new page displays.

Steps
1. Type a filter name into the Filter Name field.

2. Type a description into the Description field.
3. Choose an application from the Application drop-down list.

4. Optionally, if you are creating a new Cache Filter and want to clear the fields,
then click Clear.

5. Optionally, if you are editing an existing Cache Filter and want to reset the
fields to their original settings, then click Restore.

6. Click Continue to save and move on to the next screen.

2.83 Step 2: Choosing Responsibilities

Use this procedure to choose which responsibilities apply to a particular Cache
Filter.

Prerequisites
= Read Understanding Cache

Steps
1. Select the name of a responsibility in one list and click > or < to move it to the
other list.

2. Repeat step 1 as desired.

3. If you want to move all Available Responsibilities to the Configured
Responsibilities list, then click >>.
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If you want to move all Configured Responsibilities to the Available
Responsibilities list, then click <<.

Optionally, if you are creating a new Cache Filter and want to clear the fields,
then click Clear.

Optionally, if you are updating an existing Cache Filter and want to reset the
fields to their original settings, then click Restore.

Click Continue to save and move on to the next page.

2.84 Step 3: Choosing Languages

Use this procedure to choose which languages apply to a particular Cache Filter.

Prerequisites

Read Understanding Cache

Steps

1.
2,
3.

Select a language in one list and click > or < to move it to the other list.
Repeat step 1 as desired.

If you want to move all Available Languages to the Configured Languages list,
then click >>.

If you want to move all Configured Languages to the Available Languages list,
then click <<.

Optionally, if you are creating a new Cache Filter and want to clear the fields,
then click Clear.

Optionally, if you are updating an existing Cache Filter and want to reset the
fields to their original settings, then click Restore.

If you are creating a new Cache Filter, then click Create to save.

If you are updating an existing Cache Filter, then click Update to save.

2.85 Managing Component Caches

The main page for component caches is the starting point for viewing, creating,
updating, and removing component caches. Each application uses one or more
component caches. Use this procedure to manage component caches.

Using the System Administrator Console 2-73



Editing Component Cache Details

Prerequisites

Read Understanding Cache
Navigate to Performance > Cache > Components

Modify the corresponding code before modifying a component cache

Steps

1.

Choose an application from the drop-down list labeled View to choose which
component caches display.

If you want to create a component cache, then click Create.

This opens the page where you edit the details of a new component cache.

If you want to update a component cache, then click its name.

This opens the page where you edit the details of an existing component cache.

If you want to remove a component cache, then select the check box in the
Remove column.

Optionally, click Restore to reset the fields to their original settings.

Click Update to save.

2.86 Editing Component Cache Details

Use this procedure to edit the details of new or existing component caches.

Prerequisites

Read Understanding Cache

Navigate to Performance > Cache > Components, then either click Create or
click the name of a component cache in the table

Modify the corresponding code before modifying a component cache

Steps

1.

If you are creating a new component cache, then choose an application from the
Application drop-down list.

If you are updating an existing component cache, then you cannot edit this
field.
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2. If you are creating a new component cache, then type a component identifier
into the Component Identifier field.

The component identifier should start with the appropriate application
shortcode.

If you are updating an existing component cache, then you cannot edit this
field.

3. Type a component name into the Component Name field.
4. Type a description into the Description field.
5. Type into a loader class name into the Loader Class Name field.

Each component cache has an associated loader class that is used by the caching
framework to load the corresponding object into the cache, if it is not already in
the cache.

6. Choose Time to Live or Idle Time from the drop-down list.

The Time to Live is the maximum length of time for a cache to be considered
valid. The Idle Time is the maximum length of time for an object to go unused
before it is flushed from the cache.

a. Type a number of seconds, minutes, or hours into the text input field to edit
the Time to Live or Idle Time.

b. Choose seconds, minutes, or hours from the drop-down list.

7. If you are creating a new component cache, then select or deselect the check box
labeled Enable Security Group ID.

The Security Group ID is used in the hosting environments.

If you are updating an existing component cache, then you cannot edit this
field.

8. Select or deselect the check box labeled Enable Statistics Collection.

Enabling statistics collection can slow the cache down. Use it if there are
problems with using the cache or if you need to check the cache efficiency.

9. Select or deselect the check box labeled Distributed Mode.

Distributed Mode means that object updates are propagated across computers
and across Java VMs.

10. Select or deselect the check box labeled HTML Platform Component.
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HTML Platform Components are generic caches that are common to all
applications. Usually, you only select this check box for JTF component caches.
It is merely a logical grouping that does not change the assigned application.

11. Optionally, if you are creating a new component cache and want to clear the
fields, then click Clear.

12. Optionally, if you are updating an existing component cache and want to reset
the fields to their original settings, then click Restore.

13. If you are creating a new component cache, then click Create to save.

14. If you are updating an existing component cache, then click Update to save.

2.87 Viewing Cache Statistics

Use this procedure to view statistics about caches.

Prerequisites
= Read Understanding Cache

= Navigate to Performance > Cache > Statistics

Steps

1. Choose from the drop-down lists next labeled View to select which hosts and
applications have data about them displayed below.

2. View the data.

You can use these statistics to configure the component caches based on how
each component cache is performing. You can interpret the data to decide how
effective the component caches are and whether or not they should be disabled.
For example, if the cache has a high hit ratio, then the cache is useful and
should not be disabled.

2.88 Using XML Services

In the XML Services subtab, you manage inter-application Web service sharing. You
can perform the following tasks from the XML Services subtab:

= Managing Service Groups
- Editing the General Settings of New Service Groups

- Editing the Services of New Service Groups
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- Editing the Type Mappings of New Service Groups
- Updating the General Settings of Service Groups
— Updating the Services of Service Groups
- Updating the Type Mappings of Service Groups
= Managing Invocations
— Creating Invocations
- Updating Invocations
= Managing Authentication Profiles
— Creating Authentication Profiles
- Updating Authentication Profiles
= Managing Events
— Creating Events
- Updating Events

For information on XML Services concepts, see Understanding XML Services.

2.89 Managing Service Groups

The main page for Service Groups is the starting point for viewing, creating,
updating, and removing service groups. A Service Group is the logical name for a
Java class that contains functions for loading services into a system. Services are
function calls with defined inputs and outputs that are implemented as methods of
the Java class. Use this procedure to manage service groups.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Services

Steps

1. If you want to modify the service group prefix, then:

a. Type into the Service Group Prefix field at the top of the page.
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The service group prefix is the first part of a service group full name. The
format of service group full names is the following: <service group
prefix>.<application shortname>.<service group name>

b. Optionally, click Restore to reset the field to its original setting.
c. Click Update to save.
2. If you want to create a new service group, then click Create.
This opens the page where you start to edit the details of a new service group.

3. If you want to view the service groups of a particular application, then choose
an application name from the drop-down list at the top of the table. Optionally,
choose ALL to view all service groups.

The page refreshes to display the choice that you made.

4. Optionally, click First, Previous, Next, Last, or an option from the drop-down
list to navigate within the table.

5. If you want to update a service group, then click its name in the table.

This opens the page where you start to edit the details of an existing service
group.

6. If you want to remove a service group, then:
a. Select the corresponding check box in the Remove column of the table.

b. Optionally, click Restore to reset the fields to their original settings.
c. Click Update to save.

2.90 Editing the General Settings of New Service Groups

A Service Group is the logical name for a Java class that contains methods that are
exposed as services. Services are function calls with defined inputs and outputs that
are implemented as methods of the Java class. Creating a new service group
requires completing three screens. Use this procedure to complete the first screen.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Services, then click Create

= Have the Java Class name of the service group ready.
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Steps

1.
2,

Choose an application from the drop-down list.
Type the Service Group name into the Service Group field.

If you type "TestService" as your service group name while your prefix is
"oracle.apps" and your application short name is "JTE," then the service group’s
full name is oracle.apps.JTF.TestService

Type the Java Class name into the Java Class field.

For example, "samples.test. TestServiceGroup"
Optionally, type a description into the Description field.
Optionally, click Clear to clear the fields.

Click Continue.

The page automatically navigates to the second step of the procedure, Editing
Services.

2.91 Editing the Services of New Service Groups

A Service Group is the logical name for a Java class that contains methods that are
exposed as services. Services are function calls with defined inputs and outputs that
are implemented as methods of the Java class. Creating a new service group
requires completing three screens. Use this procedure to complete the second
screen.

Prerequisites

Read Understanding XML Services

Steps

1.

View a table that lists the services defined in the class that you set up on the
previous screen.

Select check boxes in the Enable column to enable services, or click Enable All
to enable all services.

Optionally, type descriptions into the Description column.
Optionally, click Clear to clear the fields.

Optionally, click Back to go back to the previous screen without saving changes.
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6. Click Continue.

The page automatically navigates to the third and final step of the procedure,
Editing Type Mappings.

2.92 Editing the Type Mappings of New Service Groups

A Service Group is the logical name for a Java class that contains methods that are
exposed as services. Services are function calls with defined inputs and outputs that
are implemented as methods of the Java class. Creating a new service group
requires completing three screens. Use this procedure to complete the third screen.

Prerequisites
= Read Understanding XML Services

Steps

1. If you want to use your own settings, then type them into the Data Type,
Encoding, Namespace, Serializer, and Deserializer columns.

2. If you want to use default settings, then select the check box in the Use Default
column.

3. Optionally, click Clear to clear the fields.
4. Optionally, click Back to go back to the previous screen without saving changes.

5. Click Create to save the new service group.

2.93 Updating the General Settings of Service Groups

A Service Group is the logical name for a Java class that contains methods that are
exposed as services. Services are function calls with defined inputs and outputs that
are implemented as methods of the Java class. Updating an existing service group
requires completing three screens. Use this procedure to complete the first screen.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Services, then click a service group
name in the table
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Steps
1. Optionally, type into the Description field to edit the service group description.

2. Optionally, click Clear to clear the field.
3. Click Continue.

The page automatically navigates to the second step of the procedure, Editing
Services.

2.94 Updating the Services of Service Groups

A Service Group is the logical name for a Java class that contains methods that are
exposed as services. Services are function calls with defined inputs and outputs that
are implemented as methods of the Java class. Updating an existing service group
requires completing three screens. Use this procedure to complete the second
screen.

Prerequisites
= Read Understanding XML Services

Steps

1. Edit the Previously Existing Services section:
a. Select or deselect the check boxes in the Enable column as desired.
b. Optionally, click Disable All to disable all previously existing services.
c. Optionally, type descriptions into the Description fields.
2. Edit the Added Services section:
If there are no added services for this service group, the fields will be empty.
a. Select or deselect the check boxes in the Enable column as desired.
b. Optionally, click Disable All to disable all added services.
c. Optionally, type descriptions into the Description fields.
3. Optionally, click Restore to reset the fields to their original settings.
4. Optionally, click Back to go back to the previous screen without saving changes.

5. Click Continue.
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The page automatically navigates to the third and final step of the procedure,
Editing Type Mappings.

2.95 Updating the Type Mappings of Service Groups

A Service Group is the logical name for a Java class that contains methods that are
exposed as services. Services are function calls with defined inputs and outputs that
are implemented as methods of the Java class. Updating an existing service group
requires completing three screens. Use this procedure to complete the third screen

Prerequisites
= Read Understanding XML Services

Steps

1. If you want to use your own settings, then type them into the Data Type,
Encoding, Namespace, Serializer, and Deserializer columns.

2. If you want to use default settings, then select the check box in the Use Default
column.

3. If you want to remove a type mapping, then select the appropriate check box in
the Remove column of the table.

4. Optionally, click Restore to reset the fields to their original settings.
5. Optionally, click Back to go back to the previous screen without saving changes.

6. Click Update to save.

2.96 Managing Invocations

The main page for invocations is the starting point for viewing, creating, updating,
and removing invocations. An invocation is the logical name for a record that
contains all information about a service on a remote machine. Use this procedure to
manage invocations.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Invocations
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Steps

1. If you want to create a new invocation, then click Create.
This opens the page where you edit the details of a new invocation.

2. If you want to view the invocations of a particular application, then choose an
application name from the drop-down list at the top of the table. Optionally,
choose ALL to view all invocations.

3. Optionally, click First, Previous, Next, Last, or an option from the drop-down
list to navigate within the table.

4. If you want to update the details of a particular invocation, then click its name
in the table.

This opens the page where you edit the details of an existing invocation.
5. If you want to remove an invocation, then:
a. Select the corresponding check box in the Remove column of the table.

b. Click Update to save.

2.97 Creating Invocations

An invocation is the logical name for a record that contains all information about a
service on a remote machine. Use this procedure to create invocations.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Invocations, then click Create
= Confirm that the following are true:

- Service group is created

- Service in service croup is enabled

— Authentication is created

Steps

1. Complete the General Settings section.
a. Choose an application from the drop-down list.

b. Type an invocation name into the Invocation Name field.
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Optionally, type a description into the Description field.

Type the full name of the service group into the Service Group Full Name
field.

For example, "oracle.apps.JTE. TestService"

Type the name of the service into the Service field.
This is a Java method.

Type a number into the Timeout field.

This is the number of milliseconds to wait before a response. A timeout of
zero means it will wait forever.

2. Complete the Authentication Profile section.

a.

b.

Choose a URL from the URL drop-down list.

Choose a User from the User drop-down list. If you are not setting a user,
then choose No_Authentication.

You can change the list of available users by editing the authentication
profile.

3. Complete the Target Service Signature section.

This is the format of the method that you are calling.

a.

Type a data type into the Return Data Type field.
If the data type is a string, then you must type java.lang.string

If you want to set your own return data type encoding, then type it into the
Encoding field.

If you want to use the default return data type encoding, then select the Use
Default check box.

Type a parameter name into the Parameter Name column.
Type a data type into the Data Type column.

Instead of using primitive object types like java.lang.Integer, enter the
actual primitive, such as "int" or "float."

If you want to use the default encoding, then select the Use Default check
box.

If you want to set your own encoding, then type it into the Encoding field.
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4. Complete the Type Mappings section.

This section is for user defined types.

a.

b.

Type the name of a fully qualified Java class into the Data Type column.

If you want to set your own parameters, then type them into the Encoding,
Name Space, Serializer and Deserializer columns.

If you want to use defaults (recommended), then select the Use Default
check box.

5. Optionally, click Clear to clear the fields.

6. Click Create to save.

2.98 Updating Invocations

An invocation is the logical name for a a record that contains all information about a
service on a remote machine. Use this procedure to modify the details of existing
invocations.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Invocations, then click an invocation
name in the table

Steps

1. Edit the General Settings section.

a.

b.

Optionally, type a description into the Description field.

Type the full name of the service group into the Service Group Full Name
field.

For example, "oracle.apps.JTE. TestService"

Type the name of the service into the Service field.
This is a Java method.

Type a number into the Timeout field.

This is the number of milliseconds to wait before a response. A timeout of
zero means it will wait forever.
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2. Complete the Authentication Profile section.

a.

b.

Choose a URL from the URL drop-down list.

Choose a User from the User drop-down list. If you are not setting a user,
then choose No_Authentication.

You can change the list of available users by editing the authentication
profile.

3. Complete the Target Service Signature section.

This is the format of the method that you are calling.

a.

Type a data type into the Return Data Type field.
If the data type is a string, then you must type java.lang.string

If you want to set your own return data type encoding, then type it into the
Encoding field.

If you want to use the default return data type encoding, then select the Use
Default check box.

Type a parameter name into the Parameter Name column.
Type a data type into the Data Type column.

Instead of using primitive object types like java.lang.Integer, enter the
actual primitive, such as "int" or "float."

If you want to set your own encoding, then type it into the Encoding field.

If you want to use the default encoding, then select the Use Default check
box.

If you want to delete an entry in the table, then select the appropriate
Remove check box.

4. Complete the Type Mappings section.

This section is for user defined types.

a.

b.

Type the name of a fully qualified Java class into the Data Type column.

If you want to set your own parameters, then type them into the Encoding,
Name Space, Serializer and Deserializer columns.

If you want to use defaults (recommended), then select the Use Default
check box.
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d. If you want to delete an entry in the table, then select the appropriate
Remove check box.

5. Optionally, click Restore to reset the fields to their original settings.
6. Click Update to save.

2.99 Managing Authentication Profiles

The main page for authentication profiles is the starting point for viewing, creating,
updating, and removing authentication profiles. Authentication profiles tell an
invocation what machine, user name and password to use. Use this procedure to
manage authentication profiles.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Authentications

Steps

1. If you want to create a new authentication profile, then click Create.
This opens the page where you edit the details of a new authentication profile.
2. If you want to update an authentication profile, then click its name in the table.

This opens the page where you edit the details of an existing authentication
profile.

3. Optionally, click First, Previous, Next, and Last to navigate within the table.
4. If you want to remove an authentication profile, then:
a. Select the corresponding check box in the Remove column of the table.

b. Click Update to save.

2.100 Creating Authentication Profiles

Authentications tell an invocation what machine, user name and password to use.
Use this procedure to create authentications.

Prerequisites
= Read Understanding XML Services
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Navigate to Integration > XML Services > Authentications, then click Create

Have the URL of the SOAP server of the target machine ready

Steps

1.
2,

Type the URL of the SOAP server of the target machine into the URL field.
If you want to enter a username and password combination, then:

a. Type a username into the Username column.

b. Type a password into the Password column.

c. Retype the password into the Retype Password column.

Repeat step 2 as desired.

Optionally, click Clear to clear the fields.

Click Create to save.

2.101 Updating Authentication Profiles

Authentications tell an invocation what machine, user name and password to use.
Use this procedure to view or modify the details of an authentication.

Prerequisites

Read Understanding XML Services

Navigate to Integration > XML Services > Authentications, then click a URL in
the table

Steps

1.

If you want to modify the URL of the target machine, then:

a. Type the URL of the SOAP server of the target machine into the URL field.
b. Optionally, click Restore to reset the field to its original setting.

c. Click Update to save.

If you want to reset a password, then:

a. Type a password into the Password column.

b. Retype the password into the Retype Password column.

If you want to add a username and password combination, then:

2-88 Oracle CRM Technology Foundation Concepts and Procedures



Managing Events

a. Type a username into the Username column.
b. Type a password into the Password column.
c. Retype the password into the Retype Password column.

If you want to remove a username and password combination, then select the
appropriate check box in the Remove column.

Click Update to save.

2.102 Managing Events

The main page for events is the starting point for viewing, creating, updating, and
removing events. An event outputs an object of a pre-defined type to a set of
subscribers. Subscribers are invocations that share an input type. Use this procedure
to manage events.

Prerequisites

= Read Understanding XML Services

= Navigate to Integration > XML Services > Events

Steps

1.

If you want to create a new event, then click Create.
This opens the page where you edit the details of a new event.

If you want to view the events of a particular application, then choose an
application name from the drop-down list. Optionally, choose ALL to view all
events.

Optionally, click First, Previous, Next, Last, or an option from the drop-down
list to navigate within the table.

If you want to update details of an event, then click its name in the table.
This opens the page where you edit the details of an existing event.

If you want to remove an event, then:

a. Select the corresponding check box in the Remove column of the table.

b. Click Update to save.
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2.103 Creating Events

An event outputs an object of a pre-defined type to a set of subscribers. Subscribers
are invocations that share an input type. Creating an event requires you to complete
two screens, both of which are described below. Use this procedure to create events.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Events, then click Create

s Confirm that the relevant invocations are created

Steps
1. Edit the General Settings page:

a. Choose an application from the drop-down list.
b. Type an event name into the Event Name field.

Type the relevant object type into the Object Type field.

a o

Optionally, type a description into the Description field.
e. Optionally, click Clear to clear the fields.

=h

Click Continue to move on to the next page, where you set up event
subscribers.

2. Edit the Event Subscribers page:

a. Choose the name of a subscriber in one list and click > or < to move it to the
other list.

b. Repeat step a as desired.

c. If you want to move all Available Subscribers to the Assigned Subscribers
list, then click >>.

d. If you want to move all Assigned Subscribers to the Available Subscribers
list, then click <<.

e. Optionally, click the up and down arrows to change the sequence of
subscribers.

f. Optionally, click Back to go back to the previous page without saving
changes.

g. Click Create to save.
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2.104 Updating Events

An event outputs an object of a predefined type to a set of subscribers. Subscribers
are invocations that share an input type. Use this procedure to view or modify the
details of existing events.

Prerequisites
= Read Understanding XML Services

= Navigate to Integration > XML Services > Events, then click an event name in
the table

Steps
1. Optionally, type a description into the Description field.

2. Set event subscribers.

a. Choose the name of a subscriber in one list and click > or < to move it to the
other list.

b. Repeat step a as desired.

c. If you want to move all Available Subscribers to the Assigned Subscribers
list, then click >>.

d. If you want to move all Assigned Subscribers to the Available Subscribers
list, then click <<.

e. Optionally, click the up and down arrows to change the sequence of
subscribers.

3. Optionally, click Restore to reset the fields to their original settings.
Click Update to save.

2.105 Using Declarative Page Flows

The Introduction page for Declarative Flows is the starting point for using
Declarative Flows. You can use Declarative Flows to set up and manage the flow of
pages within an application. A key benefit of Declarative Flows is that the
procedures for linking pages to each other do not require changing the code of
JavaServer Pages. The key concepts of Declarative Flows are Rules, Physical Pages,
Logical Pages and Business Flows.

You can perform the following tasks from the Declarative Page Flows subtab:
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= Managing Physical Pages

- Editing Physical Page Details
= Managing Logical Pages

- Editing Logical Page Details
=  Managing Rules

- Editing Rule Details
= Managing Business Flows

- Editing Business Flow Details

- Mapping Flows

— Cloning Flows

- Viewing Flow Families

For information on Declarative Page Flows concepts, see Understanding
Declarative Page Flows.

2.106 Managing Physical Pages

The main page for Physical Pages is the starting point for viewing, registering, and
updating Physical Pages. Physical Pages are JavaServer Pages (JSPs). Use this
procedure to manage Physical Pages.

Prerequisites
= Read Understanding Declarative Page Flows

= Navigate to Design > Declarative Page Flows > Physical Pages

Steps
1. If you want to change which Physical Pages display in the table, then:

a. If you want Physical Pages from all applications to display in the table, then
choose All from the drop-down list at the top of the table.

b. If you want to filter the table by application, then choose a module prefix
from the drop-down list at the top of the table.

c. If you want to search the table of Physical Pages, then type the name of a
Physical Page or part of the name of a Physical Page into the text input
field.
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Optionally, use the percent sign (%) as a wild card in your search phrase.
For example, the search phrase "sales%" returns the Physical Pages whose
names begin with "sales." Alternatively, the search phrase "%sales" returns
the Physical Pages whose names end with "sales." The search phrase "sales"
returns the Physical Page named "sales."

d. Click Go.
The results display in the table.
If you want to register a Physical Page, then click Create.
This opens the page where you edit the details of a new Physical Page.
If you want to update an existing Physical Page, then click its name in the table.

This opens the page where you edit the details of an existing Physical Page.

2.107 Editing Physical Page Details

On the details page for Physical Pages, you complete the procedures of either
registering or updating Physical Pages. Use this procedure to edit the details of new
or existing Physical Pages.

Prerequisites

Read Understanding Declarative Page Flows

Navigate to Design > Declarative Page Flows > Physical Pages, then either
click Create to register a new page or click the name of a JSP to modify its
details

Steps

1.
2.

Type into the Name field to edit the name of the Physical Page.
Type into the Description field to edit the description of the Physical Page.
This field is optional.

If you are registering a new Physical Page, then choose an application from the
Application drop-down list.

If you are updating an existing Physical Page, then you cannot edit this field. It
is permanently set when you create the Physical Page.

Optionally, if you are registering a new Physical Page and want to clear the
fields, then click Clear.
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5. Optionally, if you are updating an existing Physical Page and want to reset the
fields to their original settings, then click Restore.

6. If you are registering a new Physical Page, then click Create to save.

7. If you are updating an existing Physical Page, then click Update to save.

2.108 Managing Logical Pages

The main page for Logical Pages is the starting point for viewing, creating, and
updating Logical Pages. Logical Pages can be utilized either stand-alone or to
represent nodes in a Business Flow. One or more Physical Pages map to each
Logical Page. Use this procedure to manage Logical Pages.

Prerequisites
= Read Understanding Declarative Page Flows

= Navigate to Design > Declarative Page Flows > Logical Pages

Steps
1. If you want to change which Logical Pages display in the table, then:

a. If you want to allow Physical Pages from all applications to display in the
table, then choose All from the drop-down list at the top of the table.

b. If you want to filter the table by application, then choose a module prefix
from the drop-down list at the top of the table.

c. If you want to search the table of Physical Pages, then type the name of a
Physical Page or part of the name of a Physical Page into the text input
field.

Optionally, use the percent sign (%) as a wild card in your search phrase.
For example, the search phrase "sales%" returns the Physical Pages whose
names begin with "sales." Alternatively, the search phrase "%sales" returns
the Physical Pages whose names end with "sales." The search phrase "sales"
returns the Physical Page named "sales."

d. Click Go.
The results display in the table.

2. If you want to alphabetize the table by Logical Page name, then click Logical
Names.

3. If you want to alphabetize the table by description, then click Description.
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4. If you want to create a Logical Page, then click Create.
This opens the page where you edit the details of a new Logical Page.
5. If you want to update an existing Logical Page, then click its name in the table.

This opens the page where you edit the details of an existing Logical Page.

2.109 Editing Logical Page Details

On the details page for Logical Pages, you complete the procedures of either
creating or updating Logical Pages. Use this procedure to edit the details of new or
existing Logical Pages.

Prerequisites
= Read Understanding Declarative Page Flows

= Navigate to Design > Declarative Page Flows > Logical Pages, then either click
Create or click a page name in the table

Steps
1. Type into the Name field to edit the name of the Logical Page.

2. Type into the Description field to edit the description of the Logical Page.
This field is optional.

3. Ifyou are creating a new Logical Page, then choose an application from the
Application drop-down list.

If you are updating an existing Logical Page, then you cannot edit this field. It is
permanently set when you create the Rule.

4. Type into the Page Controller field to edit the name of the Page Controller.

This is the fully qualified name of a Java class. The class implements the Logical
Page Controller interface and provides values to evaluate Rules.

5. Type into the Default Physical Page field to edit the name of the Physical Page
that displays when none of the Rules evaluate to true. Optionally, click Go to
choose from a list of values.

6. Edit the Page Display Rules table.

One row in the table represents one Rule.
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a. Type into the Sequence column to edit the order in which the Rules are
evaluated.

b. Type into the Rule Name column to edit the name of the Rule. Optionally,
click Go to choose from a list of values.

c. Type into the Description column to edit the description of the Rule.

d. Type into the Physical column to edit the name of the Physical Page that is
associated with the Rule. Optionally, click Go to choose from a list of
values.

7. Repeat step 6 as desired.
8. Optionally, click Add Rows to add empty rows to the table.

9. Optionally, if you are creating a new Logical Page and want to clear the fields,
then click Clear.

10. Optionally, if you are updating an existing Logical Page and want to reset the
fields to their original settings, then click Restore.

11. If you are creating a new Logical Page, then click Create to save.

12. If you are updating an existing Logical Page, then click Update to save.

2.110 Managing Rules

The main page for Rules is the starting point for viewing, creating, and updating
Rules. In the context of a Logical Page, Rules determine either what Physical Page
needs to be rendered or what Logical Page displays next. Use this procedure to
manage Rules.

Prerequisites
= Read Understanding Declarative Page Flows

= Navigate to Design > Declarative Page Flows > Rules

Steps
1. If you want to change which Rules display in the table, then:

a. If you want Rules from all applications to display in the table, then choose
All from the drop-down list at the top of the table.

b. If you want to filter the table by application, then choose a module prefix
from the drop-down list at the top of the table.

2-96 Oracle CRM Technology Foundation Concepts and Procedures



Editing Rule Details

c. If you want to search the table of Rules, then type the name of a Rule or
part of the name of a Rule into the text input field.

Optionally, use the percent sign (%) as a wild card in your search phrase.
For example, the search phrase "sales%" returns the Rules whose names
begin with "sales." Alternatively, the search phrase "%sales" returns the
Rules whose names end with "sales." The search phrase "sales" returns the
Rule named "sales."

d. Click Go.
The results display in the table.
If you want to create a Physical Page, then click Create.
This opens the page where you edit the details of a new Rule.
If you want to update an existing Rule, then click its name in the table.

This opens the page where you edit the details of an existing Rule.

2.111 Editing Rule Details

On the details page for Rules, you complete the procedures of either creating or
updating Rules. Use this procedure to edit the details of new or existing Rules.

Prerequisites

Read Understanding Declarative Page Flows

Navigate to Design > Declarative Page Flows > Rules, then either click Create
or click a Rule name in the table

Steps

1.
2,

Type into the Name field to edit the name of the Rule.
Type into the Description field to edit the description of the Rule.
This field is optional.

If you are creating a new Rule, then choose an application from the Application
drop-down list.

If you are updating an existing Rule, then you cannot edit this field. It is
permanently set when you create the Rule.

Edit the Rule Conditions table.
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One row in the table represents one Rule Condition.
a. Type a parameter into the Parameter column.
b. Choose an operator from the drop-down list in the Condition column.
c. Type a value into the Value column.
5. Repeat step 4 as desired.
6. Optionally, click Add Rows to add empty rows to the table.

7. Optionally, if you are creating a new Rule and want to clear the fields, then click
Clear.

8. Optionally, if you are updating an existing Rule and want to reset the fields to
their original settings, then click Restore.

9. If you are creating a new Rule, then click Create to save.

10. If you are updating an existing Rule, then click Update to save.

2.112 Managing Business Flows

The main page for Business Flows is the starting point for viewing, creating,
updating, previewing, and cloning Business Flows. Business Flows are page display
sequences that address specific business processes. For example, you can create a
Business Flow for the process of purchasing an item from an online store, or you
can create a Business Flow for the process of resolving a user’s service request.
Business Flows can be either linear or branched in structure. Use this procedure to
manage Business Flows.

Prerequisites

Read Understanding Declarative Page Flows

Navigate to Design > Declarative Page Flows > Business Flows

Steps

1.

If you want to change which Business Flows display in the table, then:

a. If you want Business Flows from all applications to display in the table,
then choose All from the drop-down list at the top of the table.

b. If you want to filter the table by application, then choose a module prefix
from the drop-down list at the top of the table.
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c. If you want to search the table of Business Flows, then type the name of a
Business Flow or part of the name of a Business Flow into the text input
field.

Optionally, use the percent sign (%) as a wild card in your search phrase.
For example, the search phrase "sales%" returns the Business Flows whose
names begin with "sales." Alternatively, the search phrase "%sales" returns
the Business Flows whose names end with "sales." The search phrase "sales"
returns the Business Flow named "sales."

d. Click Go.
The results display in the table.
2. If you want to update an existing Business Flow, then click its name in the table.
This opens the page where you edit the details of an existing Business Flow.

3. If you want to preview an existing Business Flow, then click the icon in the
Preview column.

This opens the page where you preview a Business Flow.

4. If you want to view the Flow Family of a flow, then click the icon in the Flow
Family column.

This opens the page where you view a flow’s Flow Family.
5. If you want to create a Business Flow, then click Create Flow.

This opens the page where you edit the details of a new Business Flow.
6. If you want to create a duplicate of a flow, then click Clone Flow.

This opens the page where you clone a flow.

2.113 Editing Business Flow Details

On the details page for Business Flows, you can edit the basic settings of new or
existing Business Flows. After using this page, you can open the Map Flows page to
define the conditional branches in the Business Flow. Use one of the following
procedures:

Creating a New Business Flow
Updating an Existing Business Flow

For information on Declarative Page Flows concepts, see Understanding
Declarative Page Flows.
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2.114 Creating a New Business Flow

Use this procedure to edit the basic settings of a new business flow.

Prerequisites

Read Understanding Declarative Page Flows

Navigate to Design > Declarative Page Flows > Business Flows, then click
Create

Steps

1.

2
3
4.
5

Type a flow name into the Name field.

Choose an application from the Application drop-down list.
Optionally, type a description into the Description field.

Optionally, select the Secure check box if the flow is to use HTTPS.
Type the name of the Finalization Class into the Finalization Class field.

This is the name of a Java class. The class implements the FlowFinalizer
interface and executes at the end of the Business Flow.

Type the name of the Logical Page that should be invoked after the completion
of the flow into the Return to Logical field. Optionally, click Go to choose from
a list of values.

Type the name of the first Logical Page in the flow into the Root Logical field.
Optionally, click Go to choose from a list of values.

Optionally, edit the Default Flow Sequence table:

If the flow you are creating is linear, then complete this table. If the flow you are
creating has conditional branches, then proceed to step 9.

a. Type numbers into the Sequence fields to indicate the page order within the
flow.

b. Click Go to choose a Logical Page to set as the Next Logical.

When you make your choice, the Next Logical and Description fields will
automatically fill.

c. Repeat step b as desired. If needed, click Add Rows to add additional rows
to the table.

Click Create to save.
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10.

11.
12.

Click Map Flow.

This opens the page where you define the conditional branches of a nonlinear
flow.

Optionally, click Clear to clear the content of the fields on the page.
Optionally, click View Flow Family.

This opens the page where you view the flow family of a particular flow.

2.115 Updating an Existing Business Flow

Use this procedure to edit the basic settings of an existing business flow.

Prerequisites

Read Understanding Declarative Page Flows

Navigate to Design > Declarative Page Flows > Business Flows, then click a
flow name in the table

Steps

1.
2,
3.

Optionally, type a flow description into the Description field.
Optionally, select the Secure check box if the flow is to use HTTPS.
Type the name of the Finalization Class into the Finalization Class field.

This is the name of a Java class. The class implements the FlowFinalizer
interface and executes at the end of the Business Flow.

Type the name of the Logical Page that should be invoked after the completion
of the flow into the Return to Logical field. Optionally, click Go to choose from
a list of values.

Type the name of the first Logical Page in the flow into the Root Logical field.
Optionally, click Go to choose from a list of values.

Click Update to save.
Click Map Flow.

This opens the page where you define the conditional branches of a nonlinear
flow.

Optionally, click Restore to reset the fields to their original settings.
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9. Optionally, click View Flow Family.

This opens the page where you view the flow family of a particular flow.

2.116 Mapping Business Flows

Business Flows are page display sequences that address specific business processes.
The Map Flow page allows you to define conditional branches within nonlinear
business flows. Use this procedure to set the sequences of Logical Pages within
Business Flows.

Prerequisites
= Read Understanding Declarative Page Flows

Steps
1. Choose a Logical Page from the Current Logical Page drop-down list.

The Current Logical Page is the name of the Logical Page that you are setting
up on this screen. After you save your work, you can repeat this entire
procedure with another Logical Page within the Business Flow.

2. In the Default Next Logical field, type the name of the Logical Page that
displays if there are no Rules in the table below, or if none of the Rules in the
table below evaluate to "true." Optionally, click Go to choose from a list of
values.

3. Edit the table.

a. Type numbers into the Sequence fields to set the order in which the Rules
are evaluated.

b. Inthe Next Logical fields, type the name of the Logical Page that you want
to display after the Current Logical Page, only if the Rule in the next
column evaluates to "true.” Optionally, click Go to choose from a list of
values.

c. Inthe Rule Name fields, type name of the Rule that controls whether or not
the Logical Page in the previous column displays. Optionally, click Go to
choose from a list of values.

4. Optionally, click Add Rows to add empty rows to the table.

5. Optionally, if you are creating a new Current Logical Page setup and want to
clear the fields, then click Clear.
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Optionally, if you are updating an existing Current Logical Page setup and
want to reset the fields to their original settings, then click Restore.

If you are creating a new Current Logical Page setup, then click Create to save.

This opens another Map Flow page where you can repeat this entire procedure
with another Current Logical Page.

If you are updating an existing Current Logical Page setup, then click Update to
save.

This opens another Map Flow page where you can repeat this entire procedure
with another Current Logical Page.

If you have no more Current Logical Pages to set up, then click Finish.

This completes the procedures of either creating or updating Business Flows.

2.117 Cloning Business Flows

Use this procedure to clone business flows.

Prerequisites

Read Understanding Declarative Page Flows

Navigate to Design > Declarative Page Flows > Business Flows, then click
Clone Flow

Steps

1.

Click Go to choose the flow from a list of values. Edit the name of the flow if
desired.

Optionally, click Restore to reset the fields to their original settings.
Click Clone to generate a duplicate of the flow.

The Flow Details page automatically opens, where you can edit the details of
the cloned flow.

2.118 Viewing Flow Families

Use this procedure to view flow families.
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Prerequisites
= Read Understanding Declarative Page Flows

Steps
1. Choose one of the flows to be active by selecting the appropriate radio button in
the table.

2. Optionally, click Restore to reset the fields to their original settings.
3. Click Update to save.
4. Optionally, click a flow name in the table.

This opens the page where you can edit the basic details of an existing flow.

2.119 Using Declarative Components

The Declarative Components framework enables you to quickly develop bins,
graphs, reports, graph/report combinations, and LOVs that can be personalized by
end users. Key features of the Declarative Components framework include the
uniform look and feel of all Ul components, compatibility with multiple data
sources, and built in security.

You can perform the following tasks from the Declarative Components subtab:
= Managing Components
- Previewing Components
- Registering Components
*  Editing Component Metadata
= Defining Bin or Report Columns
- Editing Bin or Report Column Details
= Managing LOV Columns
- Editing LOV Column Details
= Defining Graph Metadata
- Managing Graph Columns
*  Editing Graph Column Details

= Managing Parameters
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- Editing Parameter Metadata
= Managing Component Security
— Assigning a Responsibility to Components
*  Selecting Components
- Assigning a Component to Responsibilities
*  Selecting Responsibilities

For information on Declarative Components concepts, see Understanding
Declarative Components.

2.120 Managing Components

The main page for Declarative Components is the starting point for viewing,
creating, modifying, and previewing bins, graphs, reports, graph/report
combinations and LOVs. Use this procedure to manage Declarative Components.

Prerequisites
= Read Understanding Declarative Components

= Navigate to Design > Declarative Components > Components

Steps

1. If you want to create a component, then click Create.
This opens the page where you register a new component.
2. If you want to preview a component, then click Preview.
This opens the page where you preview a component.
3. If you want to change the contents of the table, then:

a. If you want to filter the table by application, then choose an application
from the Application drop-down list at the top of the page.

The page refreshes to display the components that belong to that
application.

b. If you want to filter the table by component type, then choose All or a
component type from the drop-down list at the top of the page.
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d.

The page refreshes to display the components belonging to the component
type that you selected.

If you want to search by component code, then type the component code
into the text entry field and click Go.

The wild card character (%) is allowed. The search is case sensitive.

Click First, Previous, Next, and Last to navigate within the table.

If you want to update or modify a component, then click its component code in
the table.

This opens the page where you update the registration of a component.

If you want to set the status of a component, then:

a.

In the Action column, choose Remove, Enabled, or Disabled.

Removing a component deletes it. You cannot delete a LOV component if it
is being used by other components. Enabling a component makes it
available for display. Disabling a component makes it unavailable for
display or for selection from the homepage.

Click Update to save.

2.121 Previewing Components

Use this procedure to preview a declarative component.

Steps

1.

Read Understanding Declarative Components

Navigate to Design > Declarative Components > Components, then click
Preview

View the preview.

In the case of a LOV component, the Preview does not have validations. Use the
wildcard character (%) in the text entry field.

When you are finished, click OK to return to the main components page.

2.122 Registering Components

Use this procedure to edit the registration details of a new or existing component.
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Prerequisites

Read Understanding Declarative Components

Navigate to Design > Declarative Components > Components, then either
click Create or click a component code in the table

Steps

1.

If you are creating a new component, then choose an application from the
Application drop-down list at the top of the page. If you are updating an
existing component, then this field is not editable.

If you are creating a new component, then choose Bin, Report, Graph, Graph
Report, or LOV from the drop-down list. If you are updating an existing
component, then this field is not editable.

If you are creating a new component, then type a component code into the
Component Code field. If you are updating an existing component, then this
field is not editable.

The maximum length of a component code is 26 characters. A component code
must be unique and it cannot contain any spaces or nonalphanumeric
characters except underscore (_). It is recommended to prefix the component
code with the application short name. For example, "JTF_component_code"

Type a descriptive component name into the Component Name field.
Optionally, type a description into the Description field.

If you want to enable the component, then select the Enable check box. If you
want to disable the component, then deselect the Enable check box.

If you want to allow the component to be a candidate for display as a Portlet in
Oracle Portal, then select the Show as Portal check box. If you deselect this
check box, then the component will not be shown in the list of available
components for Portlet enabling.

Optionally, type an image filename into the Image Filename field.

If defined, this image is displayed with the Bin Title. The image that you specify
must exist in the image file location (/OA_MEDIA/).

Ignore the Metadata Source section.
The only choice for the Type field is AK.

The Declarative Components framework uses the AK Runtime Dictionary to
store metadata.
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10. Optionally, click Restore to restore the fields to their original settings.
11. Click Update to save.
12. Click Next.

This opens the page where you can begin editing the metadata associated with
this component.

2.123 Editing Component Metadata

Use this procedure to edit the Pre-Process type, Data Source, Title, and other general
settings (such as headers and footers) of a new or existing Declarative Component.

Prerequisites
= Read Understanding Declarative Components

= Complete the Registering Components procedure

Steps

1. [Edit the Pre-Process section:

a. If you want to execute a PL/SQL procedure or Java method before the
Declarative Components framework extracts the data content for this
component, then choose Java Class Name or PL/SQL Procedure from the
Type drop-down list.

If you do not require a preprocessing event, then leave this field blank and
skip to step 2.

b. Type the preprocessing PL/SQL procedure or Java method into the Name
field. The procedure name should be of the format procedure_name.package_
name, where the package name is the fully qualified package name.

2. Edit the Data Source Provider section:

a. Ifyou are editing a Bin, Report, Graph, or Graph Report, then choose
HTML, Class Name or SQL Query from the Type drop-down list.

If you are editing a LOV component, then choose Class Name or SQL
Query from the drop-down list, as the valid data source types for LOV
components are Java and SQL.

b. Type HTML code, a SQL query, or the name of a Java class that implements
the DataSource interface into the Name field. If you use a SQL query, then
the SELECT statement must not end with a semicolon (;).
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If you are editing a Bin, Report, Graph, or Graph Report, then edit the Custom
Edit link section. This feature is not available for LOVs.

a.

If you do not want a Custom Edit Link, then leave this section blank and
skip to step 4. This generates the default Edit link that navigates you to the
Personalization and Runtime Parameter section.

If you want the Custom Edit Link to have a constant value, then choose
Constant from the Type drop-down list.

If you want the Custom Edit Link to be dynamically generated by a
PL/SQL procedure or Java method, then choose PL/SQL or Java from the
Type drop-down list.

If the Custom Edit Link is constant, then type the name of the JSP file into
the Name field. If the Custom Edit Link is dynamically generated, then type
the name of the PL/SQL package.procedure or Java Class.method into the
Name field.

The PL/SQL procedure must take in a single DEFAULT NULL VARCHAR?2
argument and return a VARCHAR?2. The Java method should take in a
ParameterList and return a String.

If you do not want the Edit link to be generated, then choose Constant from
in the Type drop-down list and leave the Name field blank.

Edit the Title section:

a.

If you want the component title to have a constant value, then choose
Constant from the Type drop-down list.

If you want the component title to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Type
drop-down list.

If the component title is constant, then type the title text into the Name
field. If the component title is dynamically generated, then type the name of
the PL/SQL procedure or Java method into the Name field.

The PL/SQL procedure must return a value of the type VARCHAR?2.

Choose Left, Right, or Center from the Alignment drop-down list to set
how the component title is aligned.

If you are editing a Bin, Report, Graph, or Graph Report and want to allow
the end user to personalize the component title, then select the check box
labeled Personalizable.
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5. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Header
section. This feature is not available for LOVs.

a. If you want the header to have a constant value, then choose Constant from
the Type drop-down list.

If you want the header to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Type
drop-down list.

b. If the header is constant, then type the text into the Name field. If the
header is dynamically generated, then type the name of the PL/SQL
procedure or Java method into the Name field.

The PL/SQL procedure must return a value of the type VARCHAR?2.

c. Choose Left, Right, or Center from the Alignment drop-down list to set
how the header is aligned.

d. If you want to allow the end user to personalize the header, then select the
check box labeled Personalizable.

6. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Footer
section. This feature is not available for LOVs:

a. If you want the footer to have a constant value, then choose Constant from
the Type drop-down list.

If you want the footer to be dynamically generated by a PL/SQL procedure
or Java method, then choose PL/SQL or Java from the Type drop-down list.

b. If the footer is constant, then type the text into the Name field. If the footer
is dynamically generated, then type the name of the PL/SQL procedure or
Java method into the Name field.

The PL/SQL procedure must return a value of the type VARCHAR?2.

c. Choose Left, Right, or Center from the Alignment drop-down list to set
how the footer is aligned.

d. If you want to allow the end user to personalize the footer, then select the
check box labeled Personalizable.

7. Click Update to save.

8. Optionally, click Next to save and move on to screens where you can further
define the columns and settings of the component.
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2.124 Defining Bin or Report Columns

Use this procedure to manage the columns in a new or existing bin or report
component. This does not apply to components with a HTML Data Source Type.

Prerequisites

Read Understanding Declarative Components

Complete the Editing Component Metadata procedure.

Steps

1.

Select or deselect the check box labeled Number Of Rows to enable or disable
allowing the end user to personalize the number of rows displayed.

Select or deselect the check box labeled Number Of Columns to enable or
disable allowing the end user to personalize the number of columns displayed.

Optionally, click First, Previous, Next, and Last to navigate within the table.

If you want to set the status of a column, then choose Enabled or Disabled
from the Action column.

Enabling a component makes it available for display. Disabling a component
makes it unavailable for display.

Type integers into the Display Order column to set the display order (from left
to right) of the columns in the Bin or Report. Make sure that the values of this
field are sequential.

Click Update to save.

Optionally, click Next.

This opens the page where you manage the parameters of the component.
If you want to edit the details of a column, then click its name in the table.

This opens the page where you edit the details of a column.

2.125 Editing Bin or Report Column Details

Use this procedure to edit the details of columns in bin or report components.

Prerequisites

Read Understanding Declarative Components
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= Complete the Defining Bin or Report Columns procedure

Steps

1. Optionally, type a brief description of the column into the Description field.

2. Type an integer into the Display Order field to set the display order of the
column.

3. Edit the Label section:

a.

If you want the column label to have a constant value, then choose
Constant from the Type drop-down list.

If you want the column label to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Type
drop-down list.

If the column label is constant, then type the text into the Method field. If
the column label is dynamically generated, then type the name of the
PL/SQL procedure or Java method into the Method field.

The PL/SQL procedure must return a value of the type VARCHAR?2. The
Java method must be of the format ClassName.MethodName.

Choose Left, Right, or Center from the Horizontal Alignment drop-down
list to set how the column label is aligned.

Select the check box labeled Hyperlink if you want to display the column as
a hyperlink.

If you selected the Hyperlink check box, then type the appropriate URL into
the URL field.

Choose the name of the ID column associated with the hyperlink from the
ID column drop-down list.

Type a value into the Low Watermark field.

When the component is displayed, any values below the Low Watermark
value will display in a negative color.

Type a value into the High Watermark field.

When the component is displayed, any values above the High Watermark
value will display in a positive color.

4. Click Update to save.
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5. Click Component Columns to return to the page that lists the component’s
columns.

2.126 Managing LOV Columns

Use this procedure to manage the columns in a new or existing LOV component.
The LOVs that you create can be used across applications. LOV means "list of
values." It is a Ul component that facilitates the completion of a text entry field
when there are numerous values that may be assigned. LOVs are a useful
alternative to drop-down lists, particularly in cases where displaying a long list of
selections in a drop-down list would require excessive scrolling.

In short, when using a LOV to complete a text entry field, you type a query into the
field and then click a button labeled "Go." This opens a screen where you view a list
of values that match the query you submitted. You can then select the value that
you desire and return to the original screen, where what you selected will populate
the original text entry field.

Prerequisites
= Read Understanding Declarative Components

= Complete the Editing Component Metadata procedure.

Steps
1. Select a radio button in the Select column of the table to specify that column as
searchable.

2. Choose Enabled or Disabled from the Action column in the table to make the
column available or unavailable for display.

3. Type an integer into the Display Order field to set the display order of the
column. Make sure that the values of this field are sequential.

4. Click Update to save.
Note that you do not define parameters for LOV components.
5. If you want to edit the details of a column, then click its name in the table.

This opens the page where you edit the details of a column.
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2.127 Editing LOV Column Details

Use this procedure to edit the details of columns in a new or existing LOV
component. The LOVs that you create can be used across applications. LOV means
"list of values." It is a UI component that facilitates the completion of a text entry
field when there are numerous values that may be assigned. LOVs are a useful
alternative to drop-down lists, particularly in cases where displaying a long list of
selections in a drop-down list would require excessive scrolling.

In short, when using a LOV to complete a text entry field, you type a query into the
field and then click a button labeled "Go." This opens a screen where you view a list
of values that match the query you submitted. You can then select the value that
you desire and return to the original screen, where what you selected will populate
the original text entry field.

Prerequisites
= Read Understanding Declarative Components

= Complete the Managing LOV Columns procedure.

Steps
1. Optionally, type a brief description of the column into the Description field.

2. Type an integer into the Display Order field to set the display order of the
column.

3. Choose a column type of Date, Number, or Varchar2 from the Column Type
drop-down list.

4. If the column is searchable on the main LOV columns page, then the check box
fields for Display and Carry Over are automatically selected and cannot be
deselected. If the column is not searchable on the main LOV columns page, then
you can select or deselect these two check boxes.

5. Edit the Label section:

a. If you want the column label to have a constant value, then choose
Constant from the Type drop-down list.

If you want the column label to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Type
drop-down list.
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b.

If the column label is constant, then type the text into the Method field. If
the column label is dynamically generated, then type the name of the
PL/SQL procedure or Java method into the Method field.

The PL/SQL procedure must return a value of the type VARCHAR?2. The
Java method must be of the format ClassName.MethodName.

6. If the column is searchable on the main LOV columns page, then you will see a
section for Validation Rules. If the column is not searchable on the main LOV
columns page, then this feature is not available.

a.

If you want to choose a Javascript Validation Type, then select Error or
Warning from the drop-down list. Otherwise, leave the field blank.

In the Min. Characters field, type an integer representing the minimum
number of characters the user is required to submit when using the LOV
component.

In the Min. Characters before % field, type an integer representing the
minimum number of characters the user is required to submit before the
wildcard character (%) when using the LOV component.

Select or deselect the Auto Append % check box to choose whether or not to
automatically append any queries submitted by the user with the wildcard
character (%).

If you want to specify the case of the value when it populates the original
text entry field, then choose Lowercase or Uppercase from the Change Case
drop-down list.

7. Click Update to save.

Note that you do not define parameters for LOV components.

8. Optionally, click LOV Column List to return to the page that lists the
component’s columns.

2.128 Defining Graph Metadata

Use this procedure to edit the X-axis, Y-axis, and other basic settings of a new or
existing graph component.

Prerequisites
= Read Understanding Declarative Components

= Complete the Editing Component Metadata procedure.
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Steps

1.
2,

Optionally, type a description of the graph into the Description field.

If you want the graph title to have a constant value, then choose Constant from
the Type drop-down list.

If you want the graph title to be dynamically generated by a PL/SQL procedure
or Java method, then choose PL/SQL or Java from the Type drop-down list.

If the graph title is constant, then type the text into the Method field. If the
column label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into the Method field.

The PL/SQL procedure must return a value of the type VARCHAR?2. The Java
method must be of the format ClassName.MethodName.

Choose a graph type from the Graph Type drop-down list. The options are:
= Absolute Area

» Horizontal Clustered Bar

» Horizontal Stacked Bar

= Vertical Clustered Bar

= Vertical Stacked Bar

= Absolute Line

= Pie Graph

= 3-DBar

If you want to allow the end user to personalize the graph type, then select the
check box labeled Personalizable.

Type pixel values for the X and Y axes of the graph into the XY Size fields.

If you want a legend to display with the graph, then select the check box
labeled Show Legend.

Edit the X-axis section:

a. If you want the X-axis label to have a constant value, then choose Constant
Value from the Label Type drop-down list.

If you want the X-axis label to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Label Type
drop-down list.
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b.

a.

If the X-axis label is constant, then type the text into the Method field. If the
X-axis label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into the Method field.

The PL/SQL procedure must return a value of the type VARCHAR?2. The
Java method must be of the format ClassName.MethodName.

Choose Vertical, Horizontal or Slanting from the Tick Label Orientation
drop-down list.

Vertical orientation tilts the tick label 90 degrees. Horizontal orientation tilts
the tick label 180 degrees. Slanted orientation tilts the tick label 270 degrees.

Edit the Y-axis section:

If you want the Y-axis label to have a constant value, then choose Constant
Value from the Label Type drop-down list.

If you want the Y-axis label to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Label Type
drop-down list.

If the Y-axis label is constant, then type the text into the Method field. If the
Y-axis label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into the Method field.

The PL/SQL procedure must return a value of the type VARCHAR?2. Java
method must be of the format ClassName.MethodName.

Choose Vertical, Horizontal or Slanting from the Tick Label Orientation
drop-down list.

Vertical orientation tilts the tick label 90 degrees. Horizontal orientation tilts
the tick label 180 degrees. Slanted orientation tilts the tick label 270 degrees.

Choose Yes or No from the Auto Scale drop-down list.

If you choose Yes, then the minimum and maximum values displayed on
the Y-axis are determined by BI Beans, depending on the graph data. If you
choose No, then the minimum and maximum values displayed on the
Y-axis are specified manually.

If you chose No in step d, then type an integer into the Tick Size field to
specify the interval on the Y-axis scale.

If you chose No in step d, then enter integers into the Min. Scale and Max.
Scale fields.

10. Click Update to save.
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11. Click Next to open the page where you manage the columns of the graph
component.

2.129 Managing Graph Columns

Use this procedure to view, update, and remove columns in a graph component.

Prerequisites
= Read Understanding Declarative Components

= Complete the Defining Graph Metadata procedure.

Steps
1. If you want to set the status of a column, then choose Enabled or Disabled
from the Action column.

Enabling a component makes it available for display. Disabling a component
makes it unavailable for display.

2. For each column, choose X-axis, Y-axis, or SubX-axis from the Axis drop-down
list.

3. Type integers into the Sequence fields to set the sequence of the columns.
4. Click Update to save.
5. Optionally, click Next.

This opens the page where you manage the parameters of the component.
6. If you want to edit the details of a column, then click its name in the table.

This opens the page where you edit the details of a column.

2.130 Editing Graph Column Details

Use this procedure to edit the details of new or existing columns in graph
components.

Prerequisites
= Read Understanding Declarative Components

= Complete the Managing Graph Columns procedure
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Steps
1. Optionally, type a description into the Description field.
2. Edit the Label section:

a. If you want the column label to have a constant value, then choose
Constant Value from the Type drop-down list.

If you want the column label to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Type
drop-down list.

b. If the column label is constant, then type the text into the Method field. If
the column label is dynamically generated, then type the name of the
PL/SQL procedure or Java method into the Method field.

The PL/SQL procedure must return a value of the type VARCHAR?2. The
Java method must be of the format ClassName.MethodName.

3. Edit the Axis section:
a. Choose X-axis, Y-axis, or SubX-axis from the Plot drop-down list.
b. Type the appropriate integer into the Sequence field.

The sequence number is with respect to axis information. It is the indexing
information for columns mapped on the same axis. For example, if COL1
and COLS3 are plotted on the Y-axis, then they should have the sequence
numbers 1 and 2, respectively. COL2 plotted on the X-axis should have the
sequence number 1.

4. Click Update to save.

5. Click Graph Columns to return to the page that lists the component’s columns.

2.131 Managing Parameters

Use this procedure to create, update, and remove component parameters. You can
define date pickers (calendars), text input fields, drop-down lists, multi-select lists,
and hidden fields.

Prerequisites
= Read Understanding Declarative Components

Using the System Administrator Console 2-119



Editing Parameter Metadata

= You reach this page by clicking Next from the column summary page of a
component. See Defining Bin or Report Columns and Managing Graph
Columns.

Steps

1. Optionally, click First, Previous, Next, and Last to navigate within the table.
2. If you want to create a parameter, then click Create Parameter.
This opens the page where you edit the details of a new parameter.

3. If you want to delete a parameter, then select the appropriate check box in the
Remove column of the table.

4. Type integers into the Sequence fields to set the order in which the parameters
will be rendered. This order is also used in parameter value resolution.

5. Click Update to save.
6. If you want to edit the details of a parameter, then click its name in the table.

This opens the page where you edit the details of an existing parameter.

2.132 Editing Parameter Metadata

Use this procedure to edit the details of a new or existing component parameter.

Prerequisites
= Read Understanding Declarative Components

= Complete the Managing Parameters procedure

Steps

1. Type a unique parameter name into the Parameter Name field.
2. Optionally, type a brief description into the Description field.

3. If you want the parameter to be rendered on the parameter page, then select the
check box labeled Enable.

4. If you want to allow the end user to personalize the parameter, then select the
check box labeled Personalizable.

5. Choose VARCHAR2, Number, or Date from the Parameter Data Type
drop-down list.
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6. Choose Calendar, Drop Down, Hidden, LOV, Multiselect, or Text from the
Item Style drop-down list.

For drop-down lists, you are responsible for writing a well-tuned query that
will return the number of rows as recommended by the UI team. For hidden
fields, the end user will not see the parameter, but you can use the value as
needed (for example, passing ID columns).

7. If you chose the Item Style Drop Down in step 6, then type the appropriate
source SQL query into the SQL for Dropdown field.

8. If you chose the Item Style LOV in step 6, then the screen refreshes to display a
section about LOV details. This section includes fields for LOV App Id, LOV
Component Code, and Mapped LOV Column:

a. Choose an LOV App Id from the drop-down list. This is the application that
owns the LOV component. When you have chosen the application, the
screen refreshes to display a list of LOV components specific to that
application.

b. Choose a LOV component from the list of available choices. The screen
refreshes to display the list of searchable columns that can be mapped to the
current parameter.

c. Choose the Searchable LOV column and map it to this parameter.

d. You may need to create additional parameters if you want to carry over ID
Columns.

9. If you chose the Item Style LOV in step 6 and there is a LOV parameter already
defined for this component, then the screen refreshes to display a drop-down
list called Related LOV Parameter. The drop-down list contains all the LOV
parameters that have been defined for this component:

a. Choose a LOV parameter as the Related LOV parameter. The screen
refreshes to display a list of the Carried Over Column(s) of the chosen LOV
parameter.

b. The Mapped LOV Column drop-down list displays the LOV Columns that
have been defined to be carried over. Therefore, you can use the value of
this Mapped LOV Column, for example, in a Data Source Query.

10. Edit the Default Value Setting section:
a. Choose Constant, PL/SQL, or Java from the Type drop-down list.

b. If you chose Constant in step a, then type the text of the default value into
the Name field.
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If you chose PL/SQL in step a, then type the complete signature of a
PL/SQL function, including any package name, into the Name field. This
function must return a Varchar2. For example, My_Package.Get_Default_
Value(?P_Context). Optionally, the function can take a p_context as an
argument.

If you chose Java in step a, then type the signature of a Java method into the
Name field, in the format package_name.function_name. This method must
return a string.

11. Click Update to save.

12. Optionally, click Component Parameter to return to the page that lists the
component’s parameters.

2.133 Managing Component Security

Use this procedure to manage component security assignments.

Prerequisites
= Read Understanding Declarative Components

= Navigate to Design > Declarative Components > Component Security

Steps
1. Choose a radio button, Component to Responsibilities or Responsibility to
Components.

2. Click Next.

This opens the page where you choose either the component that you will be
mapping to responsibilities or the responsibility that you will be assigning to
components.

2.134 Assigning a Component to Responsibilities

Use this procedure to assign a component to one or more responsibilities.

Prerequisites
= Read Understanding Declarative Components

= Navigate to Design > Declarative Components > Component Security, then
select the radio button labeled Component to Responsibilities
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Steps

1.
2,
3.

Choose an application from the Application Code drop-down list.
Choose a component code from the Component Code drop-down list.

Click Next to continue.

2.135 Selecting Responsibilities

Use this procedure to select which responsibilities will apply to the component that
you have chosen.

Prerequisites

Read Understanding Declarative Components

Complete the Assigning a Component to Responsibilities procedure

Steps

1.

Choose the name of a responsibility in one list and click > or < to move it to the
other list.

Repeat step 1 as desired.

If you want to move all Available Responsibilities to the Selected
Responsibilities list, then click >>.

If you want to move all Selected Responsibilities to the Available
Responsibilities list, then click <<.

Optionally, choose an application short code from the Responsibility App Code
drop-down list.

Optionally, click Restore to reset the fields to their original settings.

Click Update to save.

2.136 Assigning a Responsibility to Components

Use this procedure to assign a responsibility to one or more components.

Prerequisites

Read Understanding Declarative Components
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= Navigate to Design > Declarative Components > Component Security, then
select the radio button labeled Responsibility to Components

Steps
1. Choose an application from the Responsibility App Code drop-down list.

2. Choose a responsibility from the Responsibility drop-down list.

3. Click Next to continue.

2.137 Selecting Components

Use this procedure to select which components will apply to the responsibility that
you have chosen.

Prerequisites
= Read Understanding Declarative Components

= Complete the Assigning a Responsibility to Components procedure

Steps
1. Choose the name of a component in one list and click > or < to move it to the
other list.

2. Repeat step 1 as desired.

3. If you want to move all Available Components to the Selected Components list,
then click >>.

4. If you want to move all Selected Components to the Available Components list,
then click <<.

5. Optionally, choose an application from the Component App Code drop-down
list.

6. Optionally, click Restore to reset the fields to their original settings.
7. Click Update to save.

2.138 Setting Navigation Preferences

Use this procedure to set navigation preferences.
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Prerequisites

Navigate to Profile > Navigation Preferences

Steps

1.

If you want to change your current responsibility, then choose an option from
the Current Responsibility drop-down list.

If you want to set default responsibilities for registered Navigation Groups,
then choose from the drop-down lists in the Set Default Responsibility table.

For information on Navigation Groups, see Understanding Site Preferences and
Using Site Preferences.

Optionally, click Restore to reset the fields to their original settings.

Click Update to save.

2.139 Setting Display Preferences

Use this procedure to set display preferences.

Prerequisites

Navigate to Profile > Display Preferences

Steps

1.

Choose options from the drop-down lists in the General Display section to
select language, currency, date format, and display style settings.

Choose numbers from the drop-down lists in the Table Display section to select
how many table to display per page and how many blank rows to display per

page.
Choose the radio button that suits how you want the Quick Find to return
result.

Optionally, click Restore to reset the fields to their original settings.

Click Update to save.
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2.140 Setting Up the Quick Menu

The Quick Menu is a feature that allows you to display links to your most
frequently visited pages on the Introduction pages of every subtab of the System
Administrator Console.

Use this procedure to choose which pages have links in the Quick Menu and also
turn the Quick Menu on or off.

Prerequisites

Navigate to Profile > Quick Menu

Steps

1.
2,

Select the check box at the top of the page if you want to use the Quick Menu.

Choose the name of a menu in one list and click > or < to move it to the other
list.

Repeat step 2 as desired.

If you want to move all Available Menus to the Favorite Menus list, then click
>>.

If you want to move all Favorite Menus to the Available Menus list, then click
<<.

Optionally, click the up and down arrows to change the sequence of menus in
the Favorite Menus list.

Optionally, click Restore to reset the fields to their original settings.

Click Update to save.

2.141 Changing Your Password

Use this procedure to change your password.

Prerequisites

Navigate to Profile > Change Password

Steps

1.
2,

Type your current password into the Current Password field.

Type your new password into the New Password field.
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Passwords must be at least six characters long.
3. Retype your new password into the Re-Enter New Password field.
4. Optionally, click Restore to reset the fields to their original settings.
5. Click Update to save.

2.142 Setting Personal Information

Use this procedure to edit your personal information.

Prerequisites
= Navigate to Profile > Personal Information

Steps
1. [Edit the fields as desired.

2. Optionally, click Restore to reset the fields to their original settings.
3. Click Update to save.

2.143 Setting Address Information

Use this procedure to edit your address information.

Prerequisites
= Navigate to Profile > Address Information

Steps
1. [Edit the fields as desired.

2. Optionally, click Restore to reset the fields to their original settings.
3. Click Update to save.
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