Configuring, Reporting and System Administration in Oracle® HRMS

RELEASE 11i
October 2001
Contents

Preface

Audience for This Guide  x
How To Use This Guide  x
Do Not Use Database Tools to Modify Oracle Applications Data  xviii
About Oracle  xix
Your Feedback  xx

Chapter 1

Extending Oracle HRMS  1–1
Extend Oracle HRMS Overview  1–3
Flexfields  1–5
User Definable Key Flexfields  1–6
Creating Key Flexfield Database Items  1–11
User Definable Descriptive Flexfields  1–12
Descriptive Flexfield List  1–14
Creating Descriptive Flexfield Database Items  1–19
Descriptive Flexfields and Address Styles  1–20
Changing Default National Address Styles  1–22
Developer Flexfields  1–24
Extra Information Types (EITs)  1–27
EITs and Security  1–29
Example Script to Register EITs  1–30
Setting Up Extra Information Types (Excluding Organization EITs)  1–36
Chapter 2

Configuring Oracle HRMS .................................................. 2–1
Configuring Oracle HRMS Overview ............................... 2–4
  Key Concepts ......................................................... 2–4
Task Flow ................................................................. 2–7
  Task Flow Windows ................................................. 2–10
  Creating Task Flows Using Forms ................................ 2–14
  Defining Task Flow Nodes ........................................ 2–15
  Defining Task Flows ................................................ 2–16
  Copying an Existing Task Flow .................................... 2–18
  Adding a New Window to an Existing Task Flow .............. 2–19
  Amending the Navigation of a Task Flow ...................... 2–20
  Task Flow (Oracle Workflow) ..................................... 2–21
  Creating Task Flows Using Workflow ............................ 2–23
  Creating a Top Level Process ...................................... 2–24
  Creating Sub Processes ............................................. 2–26
  Creating Button Labels ............................................. 2–27
  Positioning Button Display ....................................... 2–28
  Identifying Windows or Blocks to Display ..................... 2–29
  Identifying Configured Forms to Include in the Task Flow . 2–30
  Verifying and Saving the Workflow .............................. 2–31
  Generating a Task Flow From Oracle Workflow ............... 2–32
  Transferring Taskflows Between Databases ................... 2–33
CustomForm ............................................................... 2–34
  Using CustomForm .................................................. 2–39
# Table of Contents

## Chapter 4: AuditTrail

- AuditTrail Overview ........................................... 4-1
- Audit Information Reports ................................. 4-4
- Custom Audit Reports ..................................... 4-6
- Setting Up AuditTrail ........................................ 4-8
- Disabling AuditTrail .......................................... 4-10
- Running the Predefined Audit Report ................... 4-11

## Chapter 5: Information Access

- Information Access Overview .............................. 5-1
- Using Attachments ............................................ 5-4
- Using Inquiry Windows and Folders ...................... 5-7
- Using the Process Log ...................................... 5-9
- Running Predefined and User Defined Reports .......... 5-11

vi Configuring, Reporting and System Administration in Oracle HRMS
Chapter 6

Letter Generation ................................. 6–1
Letter Generation Overview ....................... 6–3
Concurrent Processing ......................... 6–4
PERWPOUK Template .......................... 6–7
PERWPWUK Template ........................... 6–11
OTA SQL*Plus Script ......................... 6–13
Creating Standard Letters ..................... 6–17
Using Oracle Reports to Set Up Standard Letters ... 6–18
Planning Standard Letter Requirements .......... 6–19
Writing a SQL*Plus Script for MultiMate or WordPerfect 6–20
Writing a SQL*Plus Script for Microsoft Word ........ 6–21
Registering the SQL*Plus Script .................. 6–22
Linking the SQL*Plus Script With a Letter ........ 6–23
Writing a Skeleton Letter ....................... 6–24
Requesting Letters/Running the Report .......... 6–25
Merging the Data File with the Standard Letter .... 6–27
Writing and Registering the Report .............. 6–28
Linking the Report With a Letter ............... 6–29

Appendix A

Default Menus, Windows, Reports and Processes .......... A–1
Default Navigation Menu for SuperHRMS Responsibility .... A–2
Windows and their Navigation Paths ................. A–17
Reports and Processes in Oracle HRMS ............. A–88
Reports ............................................. A–88
Processes ......................................... A–101

Glossary

Index
Reader’s Comment Form

Configuring, Reporting and System Administration in Oracle HRMS, Release 11i
A95418–01

Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this publication. Your input is an important part of the information we use for revision.

• Did you find any errors?
• Is the information clearly presented?
• Do you need more information? If so, where?
• Are the examples correct? Do you need more examples?
• What features did you like most about this manual? What did you like least about it?

If you find any errors or have any other suggestions for improvement, please indicate the topic, chapter, and page number below:

__________________________________________________________________________
__________________________________________________________________________
__________________________________________________________________________
__________________________________________________________________________
__________________________________________________________________________

Please send your comments to:

Oracle Applications Documentation Manager
Oracle Corporation
500 Oracle Parkway
Redwood Shores, CA 94065
Phone: (650) 506–7000 Fax: (650) 506–7200

If you would like a reply, please give your name, address, and telephone number below:

__________________________________________________________________________
__________________________________________________________________________

Thank you for helping us improve our documentation.
Preface
Audience for This Guide

Welcome to Release 11i of Configuring, Reporting and System Administration in Oracle HRMS

This guide assumes you have a working knowledge of the following:

- The principles and customary practices of your business area.
- Oracle HRMS
  If you have never used Oracle HRMS, Oracle suggests you attend one or more of the Oracle HRMS training classes available through Oracle University.
- The Oracle Applications graphical user interface.
  To learn more about the Oracle Applications graphical user interface, read the Oracle Applications User’s Guide.

See Other Information Sources for more information about Oracle Applications product information.

How To Use This Guide

This guide contains the information you need to understand and use Oracle HRMS.

- Chapter 1 explains how to extend Oracle HRMS, for example, by adding fields, tables and lookup values.
- Chapter 2 explains how to configure Oracle HRMS, so that it works exactly as your enterprise does.
- Chapter 3 explains how you set up security in Oracle HRMS. Security is a major concern of all payroll and human resource departments. Oracle HRMS includes security models for keeping information secure and preventing unauthorized access.
- Chapter 4 explains how you can track and record changes to your data using AuditTrail. AuditTrail provides a flexible approach to tracking the changes to your data. It enables you keep a history of changes to your important data: what changed, who changed it, and when.
- Chapter 5 explains how you can access information within Oracle HRMS. You can use the same information in a variety of different ways depending on your business purpose.
• Chapter 6 explains how you can create standard letters to manage your enterprise’s recruitment or enrollment activities more easily.

• Appendix A lists the default navigation paths for all the windows and reports in Oracle HRMS, as they are supplied. It also list the default menus that give you access to all the windows on the system.

  Note: HRMS Implementation Steps are included in Implementing Oracle HRMS, rather than in this User Guide.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation accessible, with good usability, to the disabled community. To that end, our documentation includes features that make information available to users of assistive technology. This documentation is available in HTML format, and contains markup to facilitate access by the disabled community. Standards will continue to evolve over time, and Oracle Corporation is actively engaged with other market–leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. For additional information, visit the Oracle Accessibility Program web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation

JAWS, a Windows screen reader, may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, JAWS may not always read a line of text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to web sites of other companies or organizations that Oracle Corporation does not own or control. Oracle Corporation neither evaluates nor makes any representations regarding the accessibility of these web sites.

Other Information Sources

You can choose from many sources of information, including online documentation, training, and support services, to increase your knowledge and understanding of Oracle HRMS.
If this guide refers you to other Oracle Applications documentation, use only the Release 11i versions of those guides.

Online Documentation

All Oracle Applications documentation is available online (HTML and PDF).

- **Online Help** – The new features section in the HTML help describes new features in 11i. This information is updated for each new release of Oracle HRMS. The new features section also includes information about any features that were not yet available when this guide was printed. For example, if your administrator has installed software from a mini-pack as an upgrade, this document describes the new features. Online help patches are available on Metalink.

- **11i Features Matrix** – This document lists new features available by patch and identifies any associated new documentation. The new features matrix document is available on Metalink.

- **Readme File** – Refer to the readme file for patches that you have installed to learn about new documentation or documentation patches that you can download.

Related User’s Guides

Oracle HRMS shares business and setup information with other Oracle Applications products. Therefore, you may want to refer to other user guides when you set up and use Oracle HRMS.

You can read the guides online by choosing Library from the expandable menu on your HTML help window, by reading from the Oracle Applications Document Library CD included in your media pack, or by using a Web browser with a URL that your system administrator provides.

If you require printed guides, you can purchase them from the Oracle store at http://oraclestore.oracle.com.

Guides Related to All Products

**Oracle Applications User’s Guide**

This guide explains how to enter data, query, run reports, and navigate using the graphical user interface (GUI) available with this release of
Oracle HRMS (and any other Oracle Applications products). This guide also includes information on setting user profiles, as well as running and reviewing reports and concurrent processes.

You can access this user’s guide online by choosing “Getting started with Oracle Applications” from any Oracle Applications help file.

**Oracle Alert User’s Guide**

This guide explains how to define periodic and event alerts to monitor the status of your Oracle Applications data.

**Oracle Applications Developer’s Guide**

This guide contains the coding standards followed by the Oracle Applications development staff. It describes the Oracle Application Object Library components needed to implement the Oracle Applications user interface described in the *Oracle Applications User Interface Standards for Forms–Based Products*. It also provides information to help you build your custom Oracle Forms Developer 6i forms so that they integrate with Oracle Applications.

**Oracle Applications User Interface Standards for Forms–Based Products**

This guide contains the user interface (UI) standards followed by the Oracle Applications development staff. It describes the UI for the Oracle Applications products and how to apply this UI to the design of an application built by using Oracle Forms.

**Guides Related to This Product**

**Using Oracle HRMS – The Fundamentals**

Use this guide to learn about representing your enterprise on your application. This includes setting up your organization hierarchy, recording details about jobs and positions within your enterprise, defining a payroll, and also how to manage your costs.

**Managing Your Workforce Using Oracle HRMS**

Use this guide to learn about all aspects of managing your workforce. This includes how to represent your workforce on your application, recruiting new employees and developing their careers, and also defining and managing budgets.
Running Your Payroll Using Oracle HRMS
This user guide provides information about wage attachments, taxes and social insurance, the payroll run, and other processes.

Managing Total Compensation Using Oracle HRMS
Use this guide to learn about setting up the application to store and process information on your total compensation package, including salary administration, other earnings, deductions, benefits, absence management and PTO accrual plans. For US users, standard and advanced benefits is covered in a separate guide called Managing Total Compensation Using Oracle HRMS.

Configuring, Reporting and System Administration in Oracle HRMS
This guide provides information about extending and configuring Oracle HRMS, managing security, auditing, information access, and letter generation.

Implementing Oracle HRMS
This guide explains the setup procedures you need to carry out in order to successfully implement Oracle HRMS in your enterprise.

Implementing Oracle Self-Service Human Resources (SSHR)
This guide provides information about setting up the self-service human resources management functions for managers and employees. Managers and employees can then use an intranet and Web browser to have easy and intuitive access to personal information and career management functionality.

Using Oracle FastFormula
This guide provides information about writing, editing, and using formulas to configure your system. Oracle FastFormula provides a simple way to write formulas using English words and basic mathematical functions. For example, Oracle FastFormula enables you to specify elements in payroll runs or create rules for PTO and accrual plans.
### Using Oracle Training Administration (OTA)

This guide provides information about how to set up and use Oracle Training Administration to facilitate your training and certification business.

### Using Oracle SSP/SMP

This guide provides information about setting up and using Oracle SSP/SMP to meet your statutory sick pay and statutory maternity pay obligations.

### Using Application Data Exchange

This guide provides information about using Application Data Exchange to view HRMS data with desktop tools, and upload revised data to your application.

### Oracle Business Intelligence System Implementation Guide

This guide provides information about implementing Oracle Business Intelligence (BIS) in your environment.

### BIS User Guide 11i

This guide is provided as online help only from the BIS application and includes information about intelligence reports, Discoverer workbooks, and the Performance Management Framework.

### Using Oracle Time Management

This guide provides information about capturing work patterns such as shift hours so that this information can be used by other applications such as General Ledger.

### Installation and System Administration

### Oracle Applications Concepts

This guide provides an introduction to the concepts, features, technology stack, architecture, and terminology for Oracle Applications Release 11i. It provides a useful first book to read before an installation of Oracle Applications. This guide also introduces the concepts behind Applications–wide features such as Business Intelligence (BIS), languages and character sets, and Self–Service Web Applications.
Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle Applications products. In Release 11i, much of the installation process is handled using Oracle Rapid Install, which minimizes the time to install Oracle Applications and the Oracle8 technology stack, and the Oracle8i Server technology stack by automating many of the required steps. This guide contains instructions for using Oracle Rapid Install and lists the tasks you need to perform to finish your installation. You should use this guide in conjunction with individual product user’s guides and implementation guides.

Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or Release 11.0 products to Release 11i. This guide describes the upgrade process and lists database and product–specific upgrade tasks. You must be either at Release 10.7 (NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 11i. You cannot upgrade to Release 11i directly from releases prior to 10.7.

Maintaining Oracle Applications

Use this guide to help you run the various AD utilities, such as AutoUpgrade, AutoPatch, AD Administration, AD Controller, AD Relink, License Manager, and others. It contains how–to steps, screenshots, and other information that you need to run the AD utilities. This guide also provides information on maintaining the applications file system and database.

Oracle Applications System Administrator’s Guide

This guide provides planning and reference information for the Oracle Applications System Administrator. It contains information on how to define security, customize menus and online help, and manage concurrent processing.

Other Implementation Documentation

Oracle Applications Product Update Notes

Use this guide as a reference for upgrading an installation of Oracle Applications. It provides a history of the changes to individual Oracle Applications products between Release 11.0 and Release 11i. It includes
new features, enhancements, and changes made to database objects, profile options, and seed data for this interval.

**Multiple Reporting Currencies in Oracle Applications**

If you use the Multiple Reporting Currencies feature to record transactions in more than one currency, use this manual before implementing Oracle HRMS. This manual details additional steps and setup considerations for implementing Oracle HRMS with this feature.

**Multiple Organizations in Oracle Applications**

If you use the Oracle Applications Multiple Organization Support feature to use multiple sets of books for one Oracle HRMS installation, this guide describes all you need to know about setting up and using Oracle HRMS with this feature.

**Oracle Workflow Guide**

This guide explains how to define new workflow business processes as well as customize existing Oracle Applications–embedded workflow processes. You also use this guide to complete the setup steps necessary for any Oracle Applications product that includes workflow–enabled processes.

**Oracle Applications Flexfields Guide**

This guide provides flexfields planning, setup, and reference information for the Oracle HRMS implementation team, as well as for users responsible for the ongoing maintenance of Oracle Applications product data. This manual also provides information on creating custom reports on flexfields data.

**Oracle Technical Reference Manuals**

The technical reference guides are now available in electronic format only. You can now access technical reference manuals for any Oracle Applications product you have licensed.

**Oracle Manufacturing and Distribution Open Interfaces Manual**

This manual contains up-to-date information about integrating with other Oracle Manufacturing applications and with your other systems. This documentation includes open interfaces found in Oracle Manufacturing.
Training and Support

Training

Oracle offers a complete set of training courses to help you and your staff master Oracle HRMS and reach full productivity quickly. These courses are organized into functional learning paths, so you take only those courses appropriate to your job or area of responsibility.

You have a choice of educational environments. You can attend courses offered by Oracle University at any one of our many Education Centers, you can arrange for our trainers to teach at your facility, or you can use Oracle Learning Network, Oracle University’s online education utility. In addition, Oracle Training professionals can tailor standard courses or develop custom courses to meet your needs. For example, you may want to use your organization structure, terminology, and data as examples in a customized training session delivered at your own facility.

Support

From on-site support to central support, our team of experienced professionals provides the help and information you need to keep Oracle HRMS working for you. This team includes your Technical Representative, Account Manager, and Oracle’s large staff of consultants and support specialists with expertise in your business area, managing an Oracle8i server, and your hardware and software environment.

Do Not Use Database Tools to Modify Oracle Applications Data

Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser, database triggers, or any other tool to modify Oracle Applications data unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus to modify Oracle Applications data, you
risk destroying the integrity of your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using an Oracle Applications form can update many tables at once. But when you modify Oracle Applications data using anything other than Oracle Applications, you may change a row in one table without making corresponding changes in related tables. If your tables get out of synchronization with each other, you risk retrieving erroneous information and you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications automatically checks that your changes are valid. Oracle Applications also keeps track of who changes information. If you enter information into database tables using database tools, you may store invalid information. You also lose the ability to track who has changed your information because SQL*Plus and other database tools do not keep a record of changes.

About Oracle

Oracle Corporation develops and markets an integrated line of software products for database management, applications development, decision support and office automation, as well as Oracle Applications, an integrated suite of more than 160 software modules for financial management, supply chain management, manufacturing, project systems, human resources and customer relationship management.

Oracle products are available for mainframes, minicomputers, personal computers, network computers and personal digital assistants, allowing organizations to integrate different computers, different operating systems, different networks, and even different database management systems, into a single, unified computing and information resource.

Oracle is the world’s leading supplier of software for information management, and the world’s second largest software company. Oracle offers its database, tools, and application products, along with related consulting, education and support services, in over 145 countries around the world.
Your Feedback

Thank you for using Oracle HRMS and this user’s guide.

Oracle values your comments and feedback. This guide contains a Reader’s Comment Form you can use to explain what you like or dislike about Oracle HRMS or this user’s guide. Mail your comments to the following address or call us directly at (650) 506-7000.

Oracle Applications Documentation Manager
Oracle Corporation
500 Oracle Parkway
Redwood Shores, CA 94065
U.S.A.

Or, send electronic mail to appsdoc_us@oracle.com.
Extending Oracle HRMS
Extend Oracle HRMS

You can extend Oracle HRMS to meet the needs of your enterprise.

How can you hold additional information?

You can add data fields to windows to hold any additional information you require. Flexfields are flexible fields that enable you to do this. Then, when you click in a flexfield you have set up, a window opens, displaying segments into which you can enter data.

You can also set up your own tables to hold data such as wage codes, shift differentials, or the amounts of certain deductions.

How can you ensure the same terminology is used and speed up data entry?

Oracle provides lists of values called lookups for certain items of information. Lookups ensure that all users use the same terminology, making it easier to inquire and report on information. Lookups also speed up data entry because you can enter just enough to identify the value, and the system completes the entry.
Extend Oracle HRMS Overview

This section summarizes the key components that Oracle HRMS provides to extend the application. Once you have identified whether to define additional information or to add your own lookups, you are ready to set up the data that all users share across the application.

Key Components

Flexfields
You can add data fields to windows to hold any additional information you require. Flexfields are flexible fields that enable you to do this.

- **Key flexfields** enable you to configure some of the most important parts of the system, including the names of jobs, positions and grades, details of how payroll costs are allocated, and analysis information for employees and other people.

- **Descriptive flexfields** enable you to add fields to windows to record additional information.

- **Extra Information Types** enable you to set up multiple categories of information for the most important entities in Oracle HRMS. For example, you might use EITs to add details to assignment records in special circumstances, such as information about a leave of absence or extra information about a temporary assignment to a project.

- **Protected Flexfields** are predefined and protected flexfields supplied with Oracle HRMS. There are two key protected flexfields and three descriptive protected flexfields. Your localization team defines these flexfields to meet the specific legislative and reporting needs of your country.

User–Defined Tables
You can set up user tables to provide matrixes of valid values that vary according to a factor such as age, or job, or number of years service. You can access these values from formulas, or your own forms or reports. The GET_TABLE_VALUE function is supplied for use in your formulas. Some user tables are predefined in certain legislations, for example to hold values for payroll calculations.

Lookups
Lookups provide lists of valid values on certain fields throughout the system. For many types of lookup you can add your own values and change the values that are predefined. Lookups not only ensure that all users use the same terminology, but also speed up data entry.
CUSTOM Library Events
You can use CUSTOM Library Events to configure the logic that is executed at defined points within a window. Generic events are available to all Oracle Applications and Product Specific Events are also available to help you to apply business rules specific to Oracle HRMS.

APIs
Oracle HRMS provides a set of PL/SQL packaged procedures and functions that together provide an open interface to the database. Each packaged procedure is known as an API.
Flexfields

Flexfields are flexible fields that enable you to configure and extend Oracle Applications by adding fields to windows. There are two types of flexfield:

- **Key flexfields** enable you to define additional information you want to record in existing fields.
- **Descriptive flexfields** enable you to add fields to windows to record additional information.

Extra Information Types (EITs) are a type of descriptive flexfield that enable you to set up unlimited amounts of extra information for eight of the most important entities in Oracle HRMS.

You can set up each flexfield to contain a number of segments, which act like separate fields.

When a user clicks in a flexfield you have set up, a window opens, displaying the segments that you have defined. For each segment, you can define:

- Its prompt
- The type of data it can contain
- The values a user can enter

You can provide a list or range of valid values. You also control the size and display characteristics of each segment and the sequence in which the segments appear.
User Definable Key Flexfields

In Oracle HRMS there are eight user definable key flexfields:

- Job
- Position
- Grade
- Competence
- People Group
- Personal Analysis
- Cost Allocation
- Collective Agreement Grades

The Personal Analysis and Collective Agreement Grades key flexfields can have an unlimited number of structures. All other flexfields can have only one structure each.

You can define up to 30 segments for each structure in all key flexfields except for the Collective Agreement Grades key flexfield. This can have up to 20 segments for each structure.

How Oracle HRMS Uses Key Flexfields

Oracle HRMS uses key flexfields in a number of distinct ways:

Unique Identifiers

The Job, Position, Grade Name, and Competence flexfields enable you to create a unique name, which is a combination of separate components or segments. You can use these flexfields when you are defining the work structures and competencies that exist in your enterprise.

**Suggestion:** When you are defining your requirements for these key flexfields you should consider the following points:

- The task of defining the segment combinations is normally restricted to one or two users only. Therefore, you may not need to use value sets, or cross validation rule options to control the values that can be entered.
- The names that users see are made up of a combination of segment values. The segment values are displayed, not the meanings.
- Avoid segments containing information that may change regularly. There is no history of changes to the combinations.
you create. For example, do not define minimum and maximum values for grades as segments of the Grade flexfield.

Analysis Information

The People Group and Personal Analysis flexfields enable you to add key information to records of employee assignments and people. You can use the individual segments of these flexfields to identify or report on specific groups of people.

Payroll Costing

The Cost Allocation key flexfield is used to collect and to accumulate costs associated with running a payroll.

Collective Agreement Grade Structures

The Collective Agreement Grades key flexfield enables you to create an unlimited number of grade structures. You use the individual segments of each grade structure to record the grade factors that are defined within a collective agreement.

Once the grade structure is recorded you can link it to a collective agreement and enter the required factor values for each reference grade in the Agreement Grades window.

What You Must Set Up

The key flexfields are central to Oracle HRMS, therefore you must create certain definitions before you can set up your business group.

Position and Grade Key Flexfields

- You can only define one structure per business group for each of these flexfields.
- Use of these flexfields is optional, but almost all Oracle HRMS installations use the Grade flexfield. Positions are used most often in large, highly structured enterprises, such as those in the areas of government, education, and health care.
- You must define a structure name for these two flexfields before you can define a business group.
- You associate these structures with a business group in the Business Group Information window, which opens from the Organization window.
- It is essential to run the Create Key Flexfield DB Items process whenever you create or change the Grade or Position key
flexfield definitions. See: Creating Key Flexfield Database Items: page 1 – 11

Job Key Flexfields

- Use of this flexfield is optional.
- You must define at least one structure name for the job key flexfield before you can define a business group.
- You associate this structure with a business group in the Business Group Information window, which opens from the Organization window. This defines the key flexfield that is used for the Default HR Job Group.
- You can create a number of different structures for the job key flexfield and then associate them with user defined job groups.
- It is essential to run the Create Key Flexfield DB Items process whenever you create or change the Job key flexfield definitions. See: Creating Key Flexfield Database Items: page 1 – 11

Competence Key Flexfield

- You must define a structure name for this flexfield before you can define a business group.
- You can only define one structure per business group for this flexfield.
- You associate this structure with a business group in the Business Group Information window, which opens from the Organization window. This defines the key flexfield that is used when creating competencies specific to the business group.
- You can create an additional key flexfield that can be used to create global competencies that are available across all business groups. You can, however, use the same key flexfield you have defined for the business group if you want. You define this key flexfield in the HR: Global Competence Flex Structure profile option.
- You must specify one of the segments as the Default Attribute using the flexfield qualifier. You must also attach the Others flexfield qualifier to all other segments in the structure.
- It is essential to run the Create Key Flexfield DB Items process whenever you create or change the Competence key flexfield definitions. See: Creating Key Flexfield Database Items: page 1 – 11

People Group Key Flexfield

- You can only define one structure per business group for this flexfield.
• You do not create separate combinations of segments for the People Group flexfield. You enter values for each employee as part of the employee assignment.

• You must define a structure name for this flexfield before you can define a business group.

• You must define at least one segment for the People Group flexfield in order to be able to use the Assignment window.

• It is essential to run the Create Key Flexfield DB Items process whenever you create or change the People Group key flexfield definition. See: Creating Key Flexfield Database Items: page 1 – 11

Personal Analysis Key Flexfield

• You can create any number of structures per business group for this flexfield. Each one represents a Special Information Type.

• You do not need to define any structures for the Personal Analysis flexfield before you can use Oracle HRMS.

• You link each structure to a business group in the Special Information Types window while you are logged on to that business group.

• You can configure windows to restrict access to specific Information Types, such as medical or disciplinary information.

Cost Allocation Key Flexfield

• You can only define one structure per business group for this flexfield.

• You can control the levels at which users can enter cost information by using the flexfield qualifiers.

• You must define a structure name for this flexfield before you can define a business group.

• A number of windows in Oracle HRMS check for the existence of a valid flexfield structure for Cost Allocation. You must define at least one segment for your Cost Allocation flexfield.

Collective Agreement Grades (CAGR) Key Flexfield

• You can create any number of structures for this flexfield.

Attention: If you are using the Italian legislation, do not create new structures for this flexfield. You must use the predefined structure, IT_CAGR, and you must not make changes to it. Otherwise, you may be unable to enter collective agreement grades for your assignments.
• You can define up to 20 segments within each structure. Each segment refers to a grade factor that is available as part of the grade structure.

• You must check the Allow Dynamic Inserts check box when defining the structure of this flexfield.

• You do not need to define any structures for the Collective Agreement Grades flexfield before you can use Oracle HRMS.

• You link each structure to a collective agreement in the Agreement Grades window. The reference grades entered in this window are recorded against this combination.

• You can enter values for each of the defined grade factors as part of each reference grade in the Agreement Grades window.

See: Oracle Applications Flexfields Guide
Creating Key Flexfield Database Items

The Create Key Flexfield DB Items process turns data in key flexfields into database items that Oracle FastFormula can access. It is essential to run this process whenever you create or change the Grade, Job, Position, or People Group key flexfield definitions.

Submit the process from the Submit Requests window.

► To create key flexfield database items:

- Run the Create Key Flexfield DB Items process.
  
  Run this process whenever you create or change these key flexfield definitions.
  
  See: Submitting a Request, Oracle Applications User’s Guide.
User Definable Descriptive Flexfields

The predefined fields in Oracle HRMS windows are designed to meet your core information requirements. However, like all enterprises, you may have special requirements that are best met by fields that you design yourself. Oracle HRMS provides a flexible mechanism called descriptive flexfields to enable you to add fields to windows.

All window blocks in which you can enter information contain a user definable descriptive flexfield. You decide in which blocks you want to record additional information. Each user definable descriptive flexfield has 20 segments that you can define. After you define a descriptive flexfield, Oracle HRMS treats the segments as part of the window.

The following figure illustrates the distinctive appearance of descriptive flexfields. When users click in a flexfield that you have set up, a window opens, displaying up to 20 segments that you have defined.

Figure 1 – 1
Recognizing a Descriptive Flexfield

Segments

For each segment, you can define:

- Its prompt
- The type of data it can contain
- The values a user can enter

You can provide a list or range of valid values. You also control the size and display characteristics of each segment and the order in which the segments appear.

Types of Descriptive Flexfield

You can define two types of descriptive flexfield segments:

- Global segments, which always appear in the window.
- Context–sensitive segments, that appear only when a defined context exists. You can prompt the user to provide the context, or you can provide the context automatically from a reference field in the same block.

For example, a segment holding information about an employee’s disability might appear only when the Disabled field is checked.
**Attention:** Some descriptive flexfields appear in more than one window. For example, the *Additional Evaluation Details* flexfield appears in the Job Evaluation window and the Position Evaluation window.

Check all of the windows that use a descriptive flexfield before you define any of the segments. This is especially important if you intend to make the flexfield context sensitive to another field. You must ensure that the reference field is present in all of the windows that use the flexfield.

See: Descriptive Flexfield List: page 1 – 14 for a full list of user definable descriptive flexfields in Oracle HRMS.
## Descriptive Flexfield List

The following table lists all the user definable descriptive flexfields in Oracle HRMS.

<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Absence Details</td>
<td>Absence Detail, View Absence History</td>
<td>ABSENCES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Absence Type Details</td>
<td>Absence Attendance Type</td>
<td>ABSENCE_TYPES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Address Details</td>
<td>Address, Applicant Entry Contact</td>
<td>PERSON_ADDRESSES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Application Details</td>
<td>Applicant Entry, Application, Terminate Applicant</td>
<td>APPLICATIONS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Appraisal Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Appraisal Template Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Assessment Group Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Assessment Type Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Assessment Details</td>
<td>Medical Assessment</td>
<td></td>
</tr>
<tr>
<td>Additional Assignment Details</td>
<td>Applicant Entry, Application, Assignment, Assignment History</td>
<td>ASSIGNMENTS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Assignment Status Details</td>
<td>Secondary Statuses</td>
<td></td>
</tr>
<tr>
<td>Additional Balance Type Details</td>
<td>Balance (Oracle Payroll only)</td>
<td></td>
</tr>
<tr>
<td>Additional Benefit Contribution Details</td>
<td>Benefit Contributions (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional Booking Details</td>
<td>Applicant Interview, Book Events, Employee Review, Event Bookings</td>
<td></td>
</tr>
<tr>
<td>Additional Budget Details</td>
<td>Budget</td>
<td></td>
</tr>
<tr>
<td>Additional Budget Values Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Budget Version Details</td>
<td>Budget</td>
<td></td>
</tr>
<tr>
<td>Additional Calendar Information</td>
<td>Budgetary Calendar (Oracle Payroll)</td>
<td></td>
</tr>
</tbody>
</table>

### User Definable Descriptive Flexfields

1 – 14 Configuring, Reporting and System Administration in Oracle HRMS
<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Candidate Information</td>
<td>Election</td>
<td></td>
</tr>
<tr>
<td>Additional Career Path Details</td>
<td>Career Path Names</td>
<td></td>
</tr>
<tr>
<td>Additional Checklist Item Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Benefit Details</td>
<td>COBRA Benefits (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Coverage Details</td>
<td>COBRA Coverage (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Payment Details</td>
<td>COBRA Payment (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Status Details</td>
<td>COBRA Status (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional Collective Agreement Details</td>
<td>Collective Agreements</td>
<td></td>
</tr>
<tr>
<td>Additional Coll. Agreed Grades Details</td>
<td>Agreement Grades</td>
<td></td>
</tr>
<tr>
<td>Additional Competence Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Competence Element Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Constituency Details</td>
<td>Election</td>
<td></td>
</tr>
<tr>
<td>Additional Contact Relationship Details</td>
<td>Contact</td>
<td>CONTACTS_(&lt;SEGMENT_NAME&gt;)</td>
</tr>
<tr>
<td>Additional Contract Details</td>
<td>Contract</td>
<td></td>
</tr>
<tr>
<td>Additional Delivery Method Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Deployment Factor Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Disability Information</td>
<td>Disabilities</td>
<td></td>
</tr>
<tr>
<td>Additional Election Details</td>
<td>Election</td>
<td></td>
</tr>
<tr>
<td>Additional Element Entry Information</td>
<td>Adjust Balance (Oracle Payroll</td>
<td>Element Entries, View Element Entry History for</td>
</tr>
<tr>
<td></td>
<td>only),</td>
<td>Employee</td>
</tr>
<tr>
<td></td>
<td>Element Entries,</td>
<td></td>
</tr>
<tr>
<td>Additional Element Link Information</td>
<td>Element Link (Oracle Payroll)</td>
<td></td>
</tr>
<tr>
<td>Additional Element Type Details</td>
<td>Element (Oracle Payroll)</td>
<td></td>
</tr>
<tr>
<td>Additional Establishment Att Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Establishment Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Evaluation Details</td>
<td>Job,</td>
<td>Position</td>
</tr>
</tbody>
</table>

**User Definable Descriptive Flexfields**
<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Event Details</td>
<td>Applicant Interview, Employee Review, Event Bookings</td>
<td>EVENTS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Grade Details</td>
<td>Grade</td>
<td>GRADES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Hierarchy Details</td>
<td>Generic Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Additional Incident Details</td>
<td>Work Incident</td>
<td></td>
</tr>
<tr>
<td>Additional Job Details</td>
<td>Job</td>
<td>JOBS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Letter Details</td>
<td>Letter</td>
<td></td>
</tr>
<tr>
<td>Additional Location Details</td>
<td>Location</td>
<td></td>
</tr>
<tr>
<td>Additional Node Details</td>
<td>Generic Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Additional Objectives Details</td>
<td>Organization</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Information</td>
<td>Organization</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Payment Method</td>
<td>Organizational Payment Method</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(Oracle Payroll)</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Structure Details</td>
<td>Organization Structure</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Unit Details</td>
<td>Organization</td>
<td>ORGANIZATION_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Participants Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Pay Scale Information</td>
<td>Pay Scale</td>
<td></td>
</tr>
<tr>
<td>Additional Pay Rate Details</td>
<td>Grade Rate, Scale Rate</td>
<td></td>
</tr>
<tr>
<td>Additional Payroll Action Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>(Oracle Payroll)</td>
<td></td>
</tr>
<tr>
<td>Additional Payroll Details</td>
<td>Payroll</td>
<td>PAYROLLS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Performance Ratings Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Period Information</td>
<td>Budgetary Calendar, Period Dates (Payroll form)</td>
<td></td>
</tr>
<tr>
<td>Additional Period of Service Details</td>
<td>Terminate</td>
<td>PERIODS_OF_SERVICE_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Period Type Information</td>
<td>Period Types</td>
<td></td>
</tr>
<tr>
<td>Additional Person Analysis Details</td>
<td>Special Information, List People By Special Information</td>
<td></td>
</tr>
</tbody>
</table>

**User Definable Descriptive Flexfields**
<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Personal Details</td>
<td>Applicant Entry, Contact, People, People Folder</td>
<td>PEOPLE_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional PPM Details</td>
<td>Personal Payment Method</td>
<td></td>
</tr>
<tr>
<td>Add’l Person Type Usage Details</td>
<td>Person Type Usage</td>
<td></td>
</tr>
<tr>
<td>Additional Position Details</td>
<td>Position, Find Positions (Mass Move form)</td>
<td>POSITION_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Position Structure Details</td>
<td>Position Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Additional Qualification Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Qualification Types</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Rating Level Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Rating Scale Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Recruitment Activity Details</td>
<td>Recruitment Activity</td>
<td>RECRUITMENT_ACTIVITIES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Requirement Details</td>
<td>Job, Position</td>
<td></td>
</tr>
<tr>
<td>Additional Requisition Details</td>
<td>Requisition and Vacancy</td>
<td></td>
</tr>
<tr>
<td>Additional Role Details</td>
<td>Supplementary Roles</td>
<td></td>
</tr>
<tr>
<td>Additional Salary Administration Details</td>
<td>Salary Administration</td>
<td></td>
</tr>
<tr>
<td>Additional Salary Basis Details</td>
<td>Salary Basis</td>
<td></td>
</tr>
<tr>
<td>Additional Standard Holiday Absence Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Subjects Taken Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Succession Planning Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Additional Telephone Number Details</td>
<td>Phone Numbers</td>
<td></td>
</tr>
<tr>
<td>Additional Template Details</td>
<td>Forms Configurator (Template Object)</td>
<td></td>
</tr>
<tr>
<td>Additional Vacancy Details</td>
<td>Requisition and Vacancy</td>
<td></td>
</tr>
<tr>
<td>Additional Valid Grade Details</td>
<td>Job, Position</td>
<td></td>
</tr>
</tbody>
</table>

**User Definable Descriptive Flexfields**
<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Version Details</td>
<td>Generic Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Additional Year Information</td>
<td>Budgetary Calendar</td>
<td></td>
</tr>
<tr>
<td>Assignment Extra Information</td>
<td>Extra Assignment Information</td>
<td></td>
</tr>
<tr>
<td>Extra Job Info Details</td>
<td>Extra Job Information</td>
<td></td>
</tr>
<tr>
<td>Extra Location Info Details</td>
<td>Extra Location Information</td>
<td></td>
</tr>
<tr>
<td>Extra Person Info Details</td>
<td>Extra Person Information</td>
<td></td>
</tr>
<tr>
<td>Extra Position Info Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Further Candidate Information</td>
<td>Election</td>
<td></td>
</tr>
<tr>
<td>Further Election Information</td>
<td>Election</td>
<td></td>
</tr>
<tr>
<td>Proposal Component Addl Info</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Review Addl Information</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Salary Survey Additional Information</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Survey Line Addnl Information</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Survey Mapping Add Info</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

User Definable Descriptive Flexfields
Creating Descriptive Flexfield Database Items

You can use descriptive flexfield segments in QuickPaint reports and formulas if there are database items for these segments.

See Descriptive Flexfield List: page 1 – 14 for a list of flexfields for which you can create database items.

Submit the process from the Submit Requests window.

To create descriptive flexfield database items:

1. Run the Create Descriptive Flexfield DB Items process.

   Run this process whenever you create or change these descriptive flexfield definitions.

   See: Submitting a Request, Oracle Applications User’s Guide.

   Note: The process can only create database items for global segments. It does not create database items for context-sensitive segments.
Descriptive Flexfields and Address Styles

Oracle HRMS supplies two predefined descriptive flexfields to hold address information in different styles for different countries. These are:

- the **Personal Address Information** descriptive flexfield: This holds the address information of your employee or applicant.
- the **Location Address** descriptive flexfield: This holds the address information of your locations.

Oracle HRMS holds the addresses of people and locations separately to enable you to record different information for tax reporting.

You can use these descriptive flexfields to add new address styles or to change the styles included in Oracle HRMS.

**Attention:** If you change the predefined styles, your changes will be overwritten when you upgrade Oracle HRMS. If you add new styles, your changes may be overwritten if new startup data contains address styles for these countries.

Address Styles

Address styles vary between countries, so Oracle HRMS provides descriptive flexfields that use context-sensitive segments to hold each line of an address. The Address Styles Flexfields table below details the title of the flexfield, its location and where it is used.

### Address Style Flexfields in Oracle HRMS

<table>
<thead>
<tr>
<th>Title</th>
<th>Table Name</th>
<th>Window Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personal Address Information</td>
<td>PER_ADDRESSES</td>
<td>Address, Applicant Entry</td>
</tr>
<tr>
<td>Location Address</td>
<td>HR_LOCATIONS</td>
<td>Location, Organization</td>
</tr>
</tbody>
</table>

The available address styles are defined as the contexts for these flexfields. There are two types of address style:

- International
- Local

Address styles are provided as startup data in these flexfields. If you require additional address styles, you need to define a new context and segments.

**International Address Style**

This style provides basic validation of address data. Oracle HRMS provides international address styles for many countries. This style can...
be used for both location and personal addresses. International address styles are named territory_code_GLB. For example, the Australian international address style is AU_GLB.

Territory codes can be found in the FND_TERRITORIES table.

**Local Address Style**

This style provides full validation of address data and is set up by a localization team. Where a local address style exists, it can usually be used for both location and personal addresses. Local address styles are named territory_code. For example, the Australian local address style is AU.

Where a local address style exists and the Business Group uses the legislation code for that country, the local address style is displayed as the default in the appropriate address entry window. Where no local address exists, the international style is the default.

**North American users:** the local address style for the US or Canada is only available when you have Vertex geocodes data installed.
Changing Default National Address Styles

National address styles, both international and local, are held and configured in the Personal Address Information and the Location Address descriptive flexfields. You can configure these styles using the Descriptive Flexfield Segments window.

You cannot construct any flexfield segment value sets with:

- Profile options, $PROFILE$
- Previous segment values, $FLEX$
- Block.field references
- Security rules

**Note:** You must ensure the Personal_Address or Location_Address protected flag is off.

To change the address style for any country, redefine those segments you do not want to use. Then define new segments to record your own information. However, these changes will be overwritten when you upgrade Oracle HRMS.

**To alter an existing address style:**

1. Enter Oracle Human Resources in the application field.
2. Enter Personal Address Information or Location Address in the title field as appropriate.
3. Run the query.
4. Uncheck the Freeze Flexfield Definition check box.
   **Note:** Read the warning.
5. Select the address style for your country.
   **Note:** Both international and local address styles are included in the list of context field values.
6. Click the segments button.
   This opens a new window with the segment and value set information for the selected address style.
7. Update the segments.
   **Note:** You must make the Country segment mandatory. Do not change the validation on any segment as this may invalidate existing data.
8. Save your work, and open the Descriptive Flexfield Segments window. Make sure any new segments are enabled, and displayed.
9. Check the Freeze Flexfield Definition check box.
10. Choose the Compile button.

   When compilation is complete, exit your current login session, then
   log in again to see your updated styles.

To add an address style:
1. Enter Oracle Human Resources in the application field.
2. Enter Personal Address Information or Location Address in the
title field as appropriate.
3. Run the query.
4. Uncheck the Freeze Flexfield Definition check box.
   **Note:** Read the warning.
5. Choose New from the File menu.
6. Enter the country code in the code and name fields.
7. Enter a description and select the Segments button.
8. Define the segments.
   **Note:** You can only use the columns provided by Oracle HR
   for your segments.
9. Save your work.
   **Note:** Make sure any new segments are enabled. You can
   choose whether segments are displayed or not.
10. Check the Freeze Flexfield Definition check box.
11. Choose the Compile button.
   When compilation is complete, exit your current login session.
   Then log in again to see your updated styles.
**Developer Flexfields**

Oracle HRMS supplies developer key flexfields and developer descriptive flexfields. Your localization team has defined these flexfields, as required, to meet the specific legislative and reporting needs of your country.

The protected developer key flexfields are the Soft Coded Legislation key flexfield and the Bank Details key flexfield.

Of the developer descriptive flexfields, all except six are protected and cannot be amended. The remaining six have Extra Information Types that you can use to configure your application.

See: Extra Information Types (EITs): page 1 – 27

The following table lists the developer descriptive flexfields, including EITs.

**Developer Descriptive Flexfields in Oracle HRMS**

<table>
<thead>
<tr>
<th>Title</th>
<th>Table Name</th>
<th>Window Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extra Job Information (EIT)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Extra Location Information (EIT)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Extra Person Information (EIT)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Extra Position Information (EIT)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Further Absence Information (Additional Absence Detail Information)</td>
<td>PER_ABSENCE_ATTENDANCES</td>
<td>Absence Detail</td>
</tr>
<tr>
<td>Further Assignment Information (EIT)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Further Budget Values Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Further Candidate Information</td>
<td>PER_ELECTION_CANDIDATES</td>
<td>Election</td>
</tr>
<tr>
<td>Further Canvas Properties</td>
<td>HR_CANVAS_PROPERTIES_B</td>
<td>Forms Configurator (Canvas Object)</td>
</tr>
<tr>
<td>Further Collective Agreement Information</td>
<td>PER_COLLECTIVE_AGREEMENTS</td>
<td>Collective Agreements</td>
</tr>
<tr>
<td>Further Contract Information (Datetracked)</td>
<td>PER_CONTRACTS_F</td>
<td>Contracts</td>
</tr>
<tr>
<td>Further Contribution History Information</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Further Disability Information (Datetracked)</td>
<td>PER_DISABILITIES_F</td>
<td>Disabilities</td>
</tr>
<tr>
<td>Title</td>
<td>Table Name</td>
<td>Window Title</td>
</tr>
<tr>
<td>--------------------------------------------------------------</td>
<td>----------------------------------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>Further Election Information</td>
<td>PER_ELECTIONS</td>
<td>Election</td>
</tr>
<tr>
<td>Further Element Information (Datetracked)</td>
<td>PAY_ELEMENT_TYPES_F</td>
<td>Element</td>
</tr>
<tr>
<td>Further Element Entry Information (Datetracked)</td>
<td>PAY_ELEMENT_ENTRIES_F</td>
<td>Element EntryForms Configurator (Form Object)</td>
</tr>
<tr>
<td>Further Establishment Information</td>
<td>PER_ESTABLISHMENTS</td>
<td>Schools/Colleges</td>
</tr>
<tr>
<td>Further Form Properties</td>
<td>HR_FORM_PROPERTIES</td>
<td>Forms Configurator (Form Object)</td>
</tr>
<tr>
<td>Further Item Properties</td>
<td>HR_ITEM_PROPERTIES</td>
<td>Forms Configurator (Item Object)</td>
</tr>
<tr>
<td>Further Job Information</td>
<td>PER_JOBS</td>
<td>Job</td>
</tr>
<tr>
<td>Further Medical Assessment Information</td>
<td>PER_MEDICAL_ASSESSMENTS</td>
<td>Medical Assessment</td>
</tr>
<tr>
<td>Further Payment Method Information (Datetracked)</td>
<td>PAY_ORG_PAYMENT_METHODS_F</td>
<td>Organizational Payment Method</td>
</tr>
<tr>
<td>Further Payroll Information (Datetracked)</td>
<td>PAY_ALL_PAYROLLS_F</td>
<td>Payroll</td>
</tr>
<tr>
<td>Further Period Details</td>
<td>PER_TIME_PERIODS</td>
<td>Payroll Periods</td>
</tr>
<tr>
<td>Further Period of Service Information (Add’l Periods of Service Information)</td>
<td>PER_PERIOD_OF_SERVICE</td>
<td>Terminate</td>
</tr>
<tr>
<td>Further Person Information (Datetracked)</td>
<td>PER_PEOPLE_F</td>
<td>People, Applicant Entry</td>
</tr>
<tr>
<td>Further Qualification Information</td>
<td>PER_QUALIFICATIONS</td>
<td>Qualifications</td>
</tr>
<tr>
<td>Further Role Information</td>
<td>PER_ROLES</td>
<td>Supplementary Roles</td>
</tr>
<tr>
<td>Further Subject Information</td>
<td>PER_SUBJECTS_TAKEN</td>
<td>Qualifications</td>
</tr>
<tr>
<td>Further Tab Page Properties</td>
<td>HR_TAB_PAGE_PROPERTIES_B</td>
<td>Forms Configurator (Tab Page Object)</td>
</tr>
<tr>
<td>Further Template Properties</td>
<td></td>
<td>Forms Configurator</td>
</tr>
<tr>
<td>Further Window Properties</td>
<td>HR_WINDOW_PROPERTIES_B</td>
<td>Forms Configurator (Window Object)</td>
</tr>
<tr>
<td>Further Work Incident Information</td>
<td>PER_WORK_INCIDENTS</td>
<td>Work Incidents</td>
</tr>
<tr>
<td>Org Developer DF</td>
<td></td>
<td></td>
</tr>
<tr>
<td>State Tax Limit Rate Information</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Your localization team determines which of these flexfields are required for your legislation, and what segments they should contain. The legislation of your business group determines which developer descriptive flexfields are displayed. This means that if your enterprise uses multiple business groups that have different legislations, different developer descriptive flexfields are displayed for business groups of each legislation.

⚠️ **Warning:** Do not attempt to alter the definitions of the protected flexfields. These definitions are a fundamental part of Oracle HRMS. Any change to them may lead to errors in the operating of the system.

It is possible that Oracle HRMS will use other segments of these flexfields in the future. Therefore, do not add segments to any protected flexfield, as this may affect your ability to upgrade your system in the future.

### Soft Coded Legislation Key Flexfield

This key flexfield holds legislation-specific information. The legislation of your business group determines the flexfield structure that you see.

Each localization team defines a flexfield structure, if required, which enables you to enter information specific to your legislation at the employee assignment level.

### Bank Details Key Flexfield

This flexfield holds legislation-specific bank account information. The legislation of your business group determines the flexfield structure that you see. Each localization team defines a flexfield structure that allows you to record the bank account information relevant to your legislation. You enter this information in the Organizational Payment Method window and Personal Payment Method window.
Extra Information Types (EITs)

Extra Information Types are defined using descriptive flexfields. You can set up any number of different EITs for:

- Location
- Job
- Position
- Person
- Assignment
- Organization
- Element types

**Note:** EITs for Organization are different because you can define which organization classification the EIT is available for.

For each EIT you can define up to 30 fully validated segments of information (or 20 for organizations).

**Note:** Oracle HRMS provides some predefined EITs. You may add your own information types, but you must **not** change the definitions of the delivered EITs.

For information about predefined EITs for positions, see "Position Extra Information Types" in *Using Oracle HRMS – The Fundamentals.*

Unlike the usual descriptive flexfields, EITs are child entities with separate tables to hold the information you enter. This means that you can have multiple instances of an EIT for each main record. When you define the EIT, you can specify whether you want to allow multiple instances. With the exception of organizations, EIT data is viewed and entered in a separate window which you can task flow.

The windows for all the EITs have the common look and feel of all the descriptive flexfield windows. This means that you can use your new EITs as soon as you save your definitions. Since flexfield definitions are preserved through upgrades, EITs do not require expensive recoding of configured forms with each new release.

**Key Flexfield Combinations**

EITs are very similar to Special Information Types (SITs). For analyzing people’s attributes and job requirements, Oracle enables you to choose whether to set up extra or special information types, or both. Both types of information use flexfields to define the structure and validation of their segments.
However, SITs are stored in a key flexfield combination table where the combination of segments must be unique – a feature of all key flexfields. EITs are stored in a descriptive flexfield table where the combination of segment values do not need to form a unique key. This means that EITs have performance advantages in large scale, or global implementations where you may want to transfer large volumes of information between separate installations.

**Dates and EITs**

EITs are not datetracked. Even if the parent entity, for example People, is datetracked, the extra information is not. However, if you want to track changes to specific EITs you can define date segments for Start and End Dates and use multiple rows of the EIT to track changes.
EITs and Security

Both special and extra information types use CustomForm and task flow security to restrict access to information. This means that you can restrict access to the information types as part of a specific user process. For example, in a “Transfer to the UK” process you might want to enter additional UK specific information. You could design your user process to include a “UK Info” window as part of the task flow and restrict the window to display only the UK information type.

To provide extra security for EITs, you must associate each EIT with the responsibilities that should have access to the information. For example, you might record details of an extended leave of absence in an EIT for an assignment and provide access only to managers who need to know.

Restricting Access to Extra Information

You can restrict access to EITs using a combination of the following:

- **Menus and task flows**: Without the EIT window a user cannot see or change any extra information for the entity.

- **CustomForm and task flows**: This restricts EITs to specific user processes.

  For example, at the person level you might define EITs to hold medical details, security information and information required for working in other countries. In this situation you might want to create two task flows, the first with a button for entering only medical details and the second with a button for entering the other types of extra information

- **Responsibility level security**: For each responsibility, you must select the EITs to be viewed. CustomForm and task flow restrictions provide additional security. You might specify that a responsibility can access an EIT, but users of this responsibility will not be able to view the extra information unless they have access to a window that displays it.

  **Note**: This security does not apply to extra information on organizations.
Example Script to Register EITs

WHENEVER SQLERROR EXIT FAILURE ROLLBACK
REM /* $Header: example.sql $ */
REM =========================================================
REM SQL Script File Name : example.sql
REM Description : This sql script inserts information
REM types into the following tables:
REM 1) PER_ASSIGNMENT_INFO_TYPES
REM 2) HR_LOCATION_INFO_TYPES
REM 3) PER_PEOPLE_INFO_TYPES
REM 4) PER_POSITION_INFO_TYPES
REM 5) PER_JOB_INFO_TYPES
REM 6) HR_ORG_INFORMATION_TYPES
REM 7) HR_ORG_INFO_TYPES_BY_CLASS
REM ==============================================================
REM 1) Insert into PER_ASSIGNMENT_INFO_TYPES:
REM
INSERT INTO PER_ASSIGNMENT_INFO_TYPES
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECCT_VERSION_NUMBER
)
SELECT
'Info Type Name'
,'Y'
,'<Y for multi-row – N for single>'
,'<Description>
,'<legislation code US/GB/etc>'
Extending Oracle HRMS

1
FROM sys.dual
WHERE not exists (SELECT 1
    FROM PER_ASSIGNMENT_INFO_TYPES
    WHERE INFORMATION_TYPE = '<Info Type Name>');

2) Insert into HR_LOCATION_INFO_TYPES:

INSERT INTO HR_LOCATION_INFO_TYPES
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECT_VERSION_NUMBER
)
SELECT
    '<Location EIT Name>',
    'Y',
    '<Y for multi-row – N for single>',
    '<Description>',
    '<legislation code US/GB/etc>',
    1
FROM sys.dual
WHERE not exists (SELECT 1
    FROM HR_LOCATION_INFO_TYPES
    WHERE INFORMATION_TYPE = '<Location EIT Name>');

3) Insert into PER_PEOPLE_INFO_TYPES:

INSERT INTO PER_PEOPLE_INFO_TYPES
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECT_VERSION_NUMBER
)
SELECT
    '<Person EIT Name>',
    'Y',
    '<Y for multi-row – N for single>',
    '<Description>',
    '<legislation code US/GB/etc>',
    1
FROM sys.dual
WHERE not exists (SELECT 1
    FROM HR_LOCATION_INFO_TYPES
    WHERE INFORMATION_TYPE = '<Location EIT Name>');
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECT_VERSION_NUMBER
)
)
SELECT
'Person EIT Name'
,'Y'
,'<Y for multi-row – N for single>'
,'<Description>'
,'<legislation code US/GB/etc>'
,1
FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_PEOPLE_INFO_TYPES
WHERE INFORMATION_TYPE = 'Person EIT Name');
—
— 4) Insert into PER_POSITION_INFO_TYPES:
—
—
INSERT INTO PER_POSITION_INFO_TYPES
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECT_VERSION_NUMBER
)
)
SELECT
'Position EIT Name'
1

FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_POSITION_INFO_TYPES
WHERE INFORMATION_TYPE = 'Position EIT Name');

5) Insert into PER_JOB_INFO_TYPES:

INSERT INTO PER_JOB_INFO_TYPES
(INFORMATION_TYPE,
ACTIVE_INACTIVE_FLAG,
MULTIPLE_OCCURENCES_FLAG,
DESCRIPTION,
LEGISLATION_CODE,
OBJECT_VERSION_NUMBER)

SELECT
'<Job EIT Name>',
'Y',
'<Y for multi-row – N for single>',
'<Description>',
'<legislation code US/GB/etc>',
,1
FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_POSITION_INFO_TYPES
WHERE INFORMATION_TYPE = 'Job EIT Name');

6) Insert into HR_ORG_INFORMATION_TYPES:

SELECT
'<Job EIT Name>',
'Y',
'<Y for multi-row – N for single>',
'<Description>',
'<legislation code US/GB/etc>',
,1
FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_POSITION_INFO_TYPES
WHERE INFORMATION_TYPE = 'Job EIT Name');
— Note different parameter value for single and multi-row
— Note different parameters for this EIT

```
INSERT INTO HR_ORG_INFORMATION_TYPES
(ORG_INFORMATION_TYPE
 ,DESCRIPTION
 ,DESTINATION
 ,DISPLAYED_ORG_INFORMATION_TYPE
 ,FND_APPLICATION_ID
 ,LEGISLATION_CODE
 ,NAVIGATION_METHOD
 )
SELECT
 ' <Organization EIT Name> '
 ,'<Description>'
 ,NULL
 ,'<Display value on the Organization form>'
 ,NULL
 ,'<legislation code US/GB/etc>'
 ,'<GM for multi-row – GS for single>'
 FROM sys.dual
 WHERE not exists (SELECT 1
 FROM HR_ORG_INFORMATION_TYPES
 WHERE ORG_INFORMATION_TYPE = '<Organization EIT Name>');
 INSERT INTO HR_ORG_INFO_TYPES_BY_CLASS
(ORG_CLASSIFICATION
 ,ORG_INFORMATION_TYPE
 ,MANDATORY FLAG)
SELECT
 ' <Check lookup value for classification HR_BG for Business Group>'
 ,'<Organization EIT Name>'
 ,' N'
```
FROM sys.dual
WHERE not exists (SELECT 1
FROM HR_ORG_INFO_TYPES_BY_CLASS
WHERE ORG_INFORMATION_TYPE = '<Organization EIT Name>'
and
ORG_CLASSIFICATION = '<HR_BG for Business Group>')
;
/
COMMIT;
EXIT;
Setting Up Extra Information Types (Excluding Organization EITs)

The following steps explain how to set up Extra Information Types (EITs) to use in Oracle HRMS.

Note: EITs for organizations are set up differently. See: Setting Up Extra Information Types for an Organization Classification: page 1 – 39.

1. In the Descriptive Flexfield Segments window, select the relevant descriptive flexfield by title (for example, Extra Job Information). The descriptive flexfields available are:
   - Extra Location Information (30 Segments)
   - Extra Job Information (30 Segments)
   - Extra Position Information (30 Segments)
   - Extra Person Information (30 Segments)
   - Extra Element Information (30 Segments)
   - Further Assignment Information (30 Segments)

2. Unprotect the relevant extra information type using the Register Descriptive Flexfield window. You must do this before you can query the flexfield in the Descriptive Flexfield window.

3. Create a new record in the Context Field Values region of the Descriptive Flexfield window and enter the name of your new Information Type in the Code field. As these are context–sensitive descriptive flexfields, enter INFORMATION_TYPE in the Reference Field.

4. Enter the segment values and compile in the same way as a standard descriptive flexfield.

See: Defining Descriptive Flexfield Structures, Oracle Applications Flexfields Guide

Attention: There are some predefined EITs in Oracle HRMS. These definitions are a fundamental part of your Oracle HRMS installation and any change to them may lead to errors in the operation of the system. Do not attempt to alter the definitions of these developer flexfields or to add other segments to them. It is possible that Oracle will use other segments of these flexfields in the future. Any changes you make may affect your ability to upgrade your system in the future.

5. Reset the protection in the Register Descriptive Flexfield window so the flexfield remains a protected descriptive flexfield.

6. Use SQL to insert a row for each EIT into the relevant Information Type table. In this release there is no window to register your new
EITs with their parent entities. The following table lists the tables for each EIT.

**Extra Information Type Tables**

<table>
<thead>
<tr>
<th>EIT</th>
<th>Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>HR_LOCATION_INFO_TYPES</td>
</tr>
<tr>
<td>Job</td>
<td>PER_JOB_INFO_TYPES</td>
</tr>
<tr>
<td>Position</td>
<td>PER_POSITION_INFO_TYPES</td>
</tr>
<tr>
<td>Person</td>
<td>PER_PEOPLE_INFO_TYPES</td>
</tr>
<tr>
<td>Assignment</td>
<td>PER_ASSIGNMENT_INFO_TYPES</td>
</tr>
<tr>
<td>Element type</td>
<td>PAY_ELEMENT_TYPE_INFO_TYPES</td>
</tr>
</tbody>
</table>

For an example of a script that can be used to register your EIT see: Example Script to Register EITs: page 1 – 30.

**Attention:** Oracle applications use a standard 2– or 3–character product prefix followed by an underscore to name the predefined EITs. To avoid current and future naming conflicts, you should adopt a different naming convention for your Extra Information Types; for example CUSTOM_EXPAT_TAXABILITY.

7. Use the Information Types Security window to set up responsibility level access to EITs.

   See: Setting Up Extra Information Types Against a Responsibility: page 1 – 41.

   Your EIT will now be available anyone using the specified responsibilities. If you want to set up further security using CustomForm and task flow, continue with the next step.

8. Use the Form Customization window to restrict access to specific EITs within the appropriate windows.

   See: Configuring a Window using CustomForm: page 2 – 40

9. Use the Define Taskflow Nodes window to define new nodes for any CustomForm restrictions you have set up.

   See: Defining Task Flow Nodes: page 2 – 15

10. Use the Define Taskflow window, or use Oracle Workflow, to define and change task flows to include any new nodes you have set up.
Setting Up Extra Information Types for an Organization Classification

To add Extra Information Types (EITs) to an organization classification:

1. Define a new organization classification. You do not need to do this if you are setting up an EIT for a classification that already exists.

   **Note:** To define a new classification, enter a new value for the Lookup type ORG_CLASS in the Lookup Values window.

2. Define the new EIT. See Entering Table Values: page 1 – 49.
   - Unprotect the Org Developer DF using the Register Descriptive Flexfield window. You must do this before you can query the flexfield on the Descriptive Flexfield window.
   - Add the new structure for the EIT to the Org Developer DF descriptive flexfield using the Descriptive Flexfield Segments window. The structure must have as its context the name of the extra information type, and as this is a context sensitive descriptive flexfield you must enter C_ORG_INFORMATION_CONTEXT in the Reference Field. Compile in the same way as a standard descriptive flexfield.
   - Reset the protection, so the flexfield remains a protected descriptive flexfield.

3. Enter a row into HR_ORG_INFORMATION_TYPES. The columns you need to enter are shown in the following table:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORG_INFORMATION</td>
<td>Name of the type (same as DDF context).</td>
</tr>
<tr>
<td>DESCRIPTION</td>
<td>Description of the extra information type.</td>
</tr>
<tr>
<td>DISPLAYED_ORG_INFORMATION_TYPE</td>
<td>The Name of the Extra Information Type displayed in the Organization window.</td>
</tr>
<tr>
<td>NAVIGATION_METHOD</td>
<td>&quot;GS&quot; for single row, a user can only enter one extra information row for each organization. Alternatively, &quot;GM&quot; for multi row, a user can enter more than one row for each organization.</td>
</tr>
<tr>
<td>LEGISLATION_CODE</td>
<td>Optionally, you can enter a legislation code to restrict to which business groups the EIT is available. If you do not enter a legislation code it will be valid for all business groups.</td>
</tr>
</tbody>
</table>
4. Specify for which organization classifications this EIT should be available.

To do this, enter a row into HR_ORG_INFO_TYPES_BY_CLASS as shown in the following table:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORG_CLASSIFICATION</td>
<td>ORG_CLASS lookup code</td>
</tr>
<tr>
<td>ORG_INFORMATION_TYPE</td>
<td>Org extra information type</td>
</tr>
<tr>
<td>MANDATORY_FLAG</td>
<td>Y (for Yes) or N (for No)</td>
</tr>
</tbody>
</table>
Setting Up Extra Information Types For a Responsibility

Extra Information Types (EITs) must be added to a responsibility before a user can access the information type using that responsibility. By not adding information types to a responsibility, you restrict the information types that a user can access.

Use the Information Type Security window to link EITs to a responsibility.

► **To set up EITs for a responsibility:**

1. Select the name of the responsibility for the EIT.
   
   Oracle HRMS displays a list of EITs already associated with the responsibility you have chosen.

2. Enter the new EIT you want to link to the responsibility.

3. Save the responsibility and EITs.

► **To copy EITs between responsibilities:**

1. Query the responsibility from which you want to copy.

2. Select the Copy Responsibility button.

3. Enter the responsibility to which you want to copy.
   
   This responsibility is then displayed with the new EITs.

4. Save the responsibility and EITs.
Entering Extra Information

You enter extra information in one or more windows available from the main window (such as the Job window). Your system administrator may have created configured versions of the extra information windows so that you can use each version for one information type only.

Your implementation team may have defined one or more types of extra information for you to record for:

- Locations
- Jobs
- Positions
- People
- Assignments
- Organization
- Element types

**To enter extra information:**

1. Enter the type of extra information, for example Job Category.

   **Note:** To access extra information in the Organization window select the Others button in the Organization Classifications region.

2. Click in the Details field to display the extra information fields you can enter.

3. Enter your extra information.

4. Save your work.
User–Defined Tables

You may need to set up your own tables in your Oracle HRMS system, to hold data such as wage codes, shift differentials, or the amounts of certain deductions. You can set up all the tables you require using the Table Structure window. Using Oracle FastFormula, you can write simple formulas for validating entries made in table columns.

Notice that the Oracle HRMS user–defined tables are different from the database tables of the Oracle Relational Database Management System. When you set up a user table, you define the rows as well as the columns, like a matrix. For example, you could set up a table showing bonus amounts (the column) against years of service (the rows).

Entering and Accessing Table Values

To enter values in tables, you use the Table Values window. Table entries and rows are both datetracked, so you can delete existing entries or rows, and add new ones, as of an effective date.

Oracle HRMS provides the GET_TABLE_VALUE function to access table values. You can write formulas that include calls to this function, perhaps for QuickPaint inquiries. Also, MIS personnel can write PL/SQL statements that call this function, to include in the code for a form or report process, for example.
US User-Defined Tables

Oracle HRMS startup data includes some predefined US–specific user tables that are either ready to receive entries, or that already have some entries. Other legislations’ startup data includes some predefined user tables that are maintained by your Oracle localization team.

**Attention:** You *do not* use the Table Structure window to set up tables holding information on medical, dental or vision benefit plans (benefits with the benefits classification Medical, Dental or Vision).

The Oracle HRMS database includes a special table, the Benefits Table, already set up to hold information on benefit plans with coverage levels, and the employee and employer contributions at each level. To enter information into this table you use the Benefit Contributions window.

See: Establishing Health Care Benefit Coverage and Default Contributions, *Managing Total Compensation Using Oracle HRMS*

See: Setting Up Benefit Plans for Health Care Coverage, *Managing Total Compensation Using Oracle HRMS*

Entering and Accessing Table Values

The formulas for the predefined earnings types Regular Wages, Overtime, Shift Pay and GTL Imputed Income all include calls to the GET_TABLE_VALUE function, as do the formulas the system generates for deductions with the amount rule Payroll Table.

Row Types for Payroll Tables

Tables set up to hold deduction amounts are called *payroll tables*. You need a payroll table when the amount of a deduction varies in accordance with a factor such as employee age, pay or job class.

To initiate a deduction with the amount rule Payroll Table, you must establish a *row type*. The formula for the deduction uses the row type to help determine which row of the table to go to for each employee’s deduction amount. Your startup data includes three predefined row types: Age Range, Salary Range and Job Class. You can set up any additional types you require.
US Pre-defined User Tables

Oracle HRMS supplies the following tables, already defined using the Table Structure window:

COMPANY WORK SCHEDULES Table

This table has several commonly-used work schedules already entered in it, and you can add more. A work schedule shows the hours employees normally work each day from Monday through Sunday. For example, employees with the schedule 10–10–10–10–0–0–0 work 10 hours each day Monday through Thursday, and have Friday, Saturday and Sunday off.

Each column in this table holds a separate schedule, with each row holding the hours worked each day of the week for the schedule. For convenience, each column header names the schedule held in the column. For example, the header for the column holding the first schedule is 1 Schedule: 8–8–8–8–8–0–0.

GTL PREMIUMS Table

For use in Oracle Payroll, this table holds the cost of Group Term Life insurance premiums per $1,000 of coverage by age range, as maintained in the IRS Uniform Premiums table. The table rows hold age ranges, and its single column holds the premium for each $1,000 of coverage for each age range.

Oracle Corporation provides you with updates to the GTL Premiums table, which your system administrator applies.

The predefined imputed earnings GTL Imputed Income references this table in its processing.

SHIFT DIFFERENTIALS Table

This table has no data already in it, but is ready for your data entry. Its rows hold the shift designators Day, Eve, Night and Split, representing the normal shifts employees work, and its columns have the same headings, for entry of differentials. You can add to or change the shift designators as necessary.

To look at examples of differentials entries, suppose day shift employees receive one and one-half times their regular pay when temporarily working the evening shift, twice their regular pay for the night shift, and three times their regular pay for the split shift. You enter 1.5, 2.0 and 3.0 as the differentials for day shift workers.
Example Shift Differentials Table

<table>
<thead>
<tr>
<th>Day</th>
<th>D</th>
<th>E</th>
<th>N</th>
<th>S</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>—</td>
<td>1.5</td>
<td>2.0</td>
<td>3.0</td>
</tr>
</tbody>
</table>

The predefined earnings types Regular Wages and Shift Pay reference this table in their processing in Oracle Payroll.

**WAGE RATES Table**

This table has no data in it when you receive your system, but is ready for your data entry. Its rows hold rate codes, and its single column holds the rate matching each code. This example holds codes for rates associated with the operation of different types of equipment:

**Example Wage Rates Table**

<table>
<thead>
<tr>
<th>Rate Code</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>FL (forklift)</td>
<td>6.80</td>
</tr>
<tr>
<td>A3 (crane A3)</td>
<td>8.20</td>
</tr>
<tr>
<td>A7 (crane A7)</td>
<td>9.00</td>
</tr>
</tbody>
</table>

Oracle Payroll’s predefined earnings types Regular Wages, Overtime, and Shift Pay reference this table in their processing.
Setting Up User Tables, Columns and Rows

You set up user tables in the Table Structure window.

► To set up the structure of a table:

1. Set your effective date to the date from which you want the table’s row labels to take effect.
2. Enter the table name.
3. For the table’s match type, select Match or Range. Select Match if each row is for one item, such as one job or one code. Select Range if each row is for a range of numeric values, such as an age range or a pay range.
4. If the match type is Match, select Date, Number or Text as the Key Units of Measure, depending on whether entries in the rows are dates, numbers, or alphanumeric text.
   If the table’s match type is Range, the Key Units of Measure automatically becomes Number.
5. Enter the row label as the Row Title.
   For example, if the table rows refer to rate codes, an appropriate row title would be Rate Code. If the rows refer to age ranges, you might use the title Age Range.
6. Save your work, and choose the Columns button to go to the Columns window.

► To set up columns:

1. Enter labels for the table columns in the Name field.
   Note: To add a new column to a table that already exists, place the cursor on the name of the column after which you want to enter the new column name, and choose Insert Record from the Edit menu to obtain a clear field.
2. If you are using formula validation for a column’s entries, select the name of the validation formula for the column.
3. Save your work and close the window.

► To set up rows:

1. In the Table Structure window, choose the Rows button to go to the Rows window.
2. If the match type of the table is Match, enter the label for each table row in the fields under the heading Exact.
If the match type of the table is Range, enter numbers representing the lower and upper boundary of each row’s range.

3. In the Sequence fields, you can optionally enter a number for each row label to determine the order in which it appears on a list in the Table Values window. Logical sequencing of row labels helps users enter table values rapidly and accurately.

4. When you are finished, save your work and close the window. Your table is now set up and ready to receive entries into its columns.
Entering Table Values

If you have set up user-defined tables, you can enter and maintain values in the Table Values window.

You can access table values from any formula used for input-value validation, payroll calculation or definition of skip-rules, assignment sets or QuickPaint reports. You can access this information using the GET_TABLE_VALUE function.

Note: The system administrator can create configured versions of the Table Values window so that you use each version for one user table only.

To enter values into table columns:

1. Set your effective date to the date from which you want the entries to take effect.
2. Query the table name.
3. With the cursor in the Column Name field, use the up and down arrows to locate the name of the column in which you want to make entries.
4. In the Values region, select each row for which you want to make an entry. You select rows in the Exact field or the Lower Bound field, depending on the match type of the table.
5. For each row, make the appropriate entry in the Value field.
6. Save your work.
Lookups

Lookups provide lists of valid values for certain items of information. This has two key advantages:

- It ensures that all users use the same terminology, which makes it easier to inquire and report on the information.
- It speeds up data entry because you can enter just enough to identify the value, and the system completes the entry.

In Oracle HRMS, a list of values is called a lookup type. Each value comprises a code, a meaning, and sometimes, a legislative tag. For example:

<table>
<thead>
<tr>
<th>Lookup Type</th>
<th>Code</th>
<th>Meaning</th>
<th>Tag</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAR_STATUS</td>
<td>M</td>
<td>Married</td>
<td></td>
</tr>
<tr>
<td></td>
<td>S</td>
<td>Single</td>
<td></td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>Registered Partner</td>
<td>+NL</td>
</tr>
<tr>
<td></td>
<td>DP</td>
<td>Domestic Partner</td>
<td>−FR, AU</td>
</tr>
</tbody>
</table>

The codes are used internally; users do not see them. There is a maximum of 250 lookups for each lookup type.

Your localization team uses the Tag column to define the lookup codes that are used by each localization. In this example, the Married and Single codes are visible to all legislations. The Registered Partner code is visible to the Dutch legislation only. The code for Domestic Partner, however, is visible to all legislations except France and Australia.

Predefined Lookup Types

A number of lookup types are included in Oracle HRMS. Some contain codes as startup data. You can never delete these codes, but you can change their meaning. For some lookup types, you can also disable the codes that are supplied. Your ability to disable codes and add new codes is determined by the access level of the lookup type:

- **User**: You can add codes and you can disable supplied codes.
- **Extensible**: You can add new codes, but you cannot disable supplied codes because the system uses them.
- **System**: You can neither add codes nor disable supplied codes. You can only change the meaning or description of supplied codes.
See User and Extensible Lookups: page 1 – 52 for a list of the predefined lookup types with an access level of User or Extensible.

You can also create your own lookup types in the lookup type window. These all have an access level of User.

Global and Local Lookup Types

If you are using Security Groups Enabled security, lookup types may be either global or local:

- Global lookup types are available to all business groups
- Local lookup types are only available to the business group/security group in which they are created.

Local lookups can be implemented in either of the following ways:

- You can create an override. This means that you retain the global name for the lookup type, but supply local values appropriate for your business group. The extent to which you can do this is determined by the access level for the lookup type.
- You can create an entirely new lookup type with lookup values that are only applicable to your local business group.

When you connect to any business group you will therefore have access to each of the following:

- The global lookup types and values
- Local overrides to the global lookup values
- Local lookup types and values
## User and Extensible Lookups

The following table shows the field and legislation for user extensible lookups.

<table>
<thead>
<tr>
<th>Field</th>
<th>Lookup</th>
<th>Legislation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category (absence)</td>
<td>ABSENCE_CATEGORY</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for absence)</td>
<td>ABSENCE_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Account Type (for bank details)</td>
<td>ACC_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Categories (for activities, programs, packages)</td>
<td>ACTIVITY_CATEGORY</td>
<td>All</td>
</tr>
<tr>
<td>Successful attendance (for activity based events)</td>
<td>ACTIVITY_SUCCESS_CRITERIA</td>
<td>All</td>
</tr>
<tr>
<td>User Status (for an activity)</td>
<td>ACTIVITY_USER_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Address Type</td>
<td>ADDRESS_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>AK Web Region Codes</td>
<td>AK_WEB_REGION_CODES</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for application assignment status)</td>
<td>APL_ASSIGN_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Type (event type for applicant)</td>
<td>APL_EVENT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Type (interview type for applicant)</td>
<td>APL_INTERVIEW_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for secondary assignment status)</td>
<td>APL_SEC_ASSIGN_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Appraisal and Assessment Status (appraisal and assessment on SSHR)</td>
<td>APPRAISAL_ASSESSMENT_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Types of appraisal processed by appraisal functionality</td>
<td>APPRAISAL_SYSTEM_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Appraisal and Assessment Type (appraisal and assessment on SSHR)</td>
<td>APPRAISAL_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Australian Tax Office Codes</td>
<td>AU_ATO_OFF</td>
<td>Australia</td>
</tr>
<tr>
<td>Australian Direct Entry Indicator</td>
<td>AU_DE_IND</td>
<td>Australia</td>
</tr>
<tr>
<td>Australian Direct Entry Transaction Code</td>
<td>AU_DE_TRN_CDE</td>
<td>Australia</td>
</tr>
<tr>
<td>State (Australian addresses)</td>
<td>AU_STATE</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-----------------------------------------------------------------------</td>
<td>--------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Years until eligible for long service leave on termination</td>
<td>AU_TERM_LSL_ELIGIBILITY_YEARS</td>
<td>Australia</td>
</tr>
<tr>
<td>Balance Type Category</td>
<td>BACKFEED_BT_CATEGORY</td>
<td>All</td>
</tr>
<tr>
<td>Check Type Category</td>
<td>BACKFEED_PD_CHECK_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Bank account name</td>
<td>BANK_ACCOUNT_NAME</td>
<td>All</td>
</tr>
<tr>
<td>Bank account number</td>
<td>BANK_ACCOUNT_NUMBER</td>
<td>All</td>
</tr>
<tr>
<td>Bank account type</td>
<td>BANK_ACCOUNT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Bank branch</td>
<td>BANK_BRANCH</td>
<td>All</td>
</tr>
<tr>
<td>Bank name</td>
<td>BANK_NAME</td>
<td>All</td>
</tr>
<tr>
<td>Bargaining Unit (for assignment)</td>
<td>BARGAINING_UNIT_CODE</td>
<td>All</td>
</tr>
<tr>
<td>Bank name (for assignment)</td>
<td>BE_BANK</td>
<td>Belgium</td>
</tr>
<tr>
<td>City (Belgian addresses)</td>
<td>BE_CITY</td>
<td>Belgium</td>
</tr>
<tr>
<td>Contract Category</td>
<td>BE_CONTRACT_CATEGORY</td>
<td>Belgium</td>
</tr>
<tr>
<td>Disciplinary Action</td>
<td>BE_DISCIPLINARY_ACTION</td>
<td>Belgium</td>
</tr>
<tr>
<td>Disciplinary Body</td>
<td>BE_DISCIPLINARY_BODY</td>
<td>Belgium</td>
</tr>
<tr>
<td>Employee Coding</td>
<td>BE_EMPLOYEE_CODING</td>
<td>Belgium</td>
</tr>
<tr>
<td>Employee Type</td>
<td>BE_EMPLOYEE_TYPE</td>
<td>Belgium</td>
</tr>
<tr>
<td>Ending Reason</td>
<td>BE_ENDING_REASON</td>
<td>Belgium</td>
</tr>
<tr>
<td>Misdemeanour Type</td>
<td>BE_MISDEMEANOUR_TYPE</td>
<td>Belgium</td>
</tr>
<tr>
<td>Organization Language</td>
<td>BE_ORGANIZATION_LANGUAGE</td>
<td>Belgium</td>
</tr>
<tr>
<td>Reduced Charges Category</td>
<td>BE_REduced_CHARGES_CATEGORY</td>
<td>Belgium</td>
</tr>
<tr>
<td>RSZ Category</td>
<td>BE_RSZ_CATEGORY</td>
<td>Belgium</td>
</tr>
<tr>
<td>Starting Reason</td>
<td>BE_STARTING_REASON</td>
<td>Belgium</td>
</tr>
<tr>
<td>Yes/No</td>
<td>BE_YES_NO</td>
<td>Belgium</td>
</tr>
<tr>
<td>Action Status</td>
<td>BEN_ACTN_STAT</td>
<td>All</td>
</tr>
<tr>
<td>Action Type</td>
<td>BEN_ACTN_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Action Type Due Date</td>
<td>BEN_ACTN_TYP_DUE_DATE</td>
<td>All</td>
</tr>
<tr>
<td>Activity Reference Period</td>
<td>BEN_ACTY_REF_PERD</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>----------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Activity Type</td>
<td>BEN_ACTY_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Age to Use</td>
<td>BEN_AGE_TO_USE_CD</td>
<td>All</td>
</tr>
<tr>
<td>All or Any</td>
<td>BEN_ALL_R_ANY</td>
<td>All</td>
</tr>
<tr>
<td>Assignment Type</td>
<td>BEN_ASMT_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_BENMNGLE_MD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_BENTMPCM_MD</td>
<td>All</td>
</tr>
<tr>
<td>Block</td>
<td>BEN_BLOCK</td>
<td>All</td>
</tr>
<tr>
<td>Boundary Period</td>
<td>BEN_BNDRY_PERD</td>
<td>All</td>
</tr>
<tr>
<td>Benefits Balance Usage</td>
<td>BEN_BNFTS_BAL_USG</td>
<td>All</td>
</tr>
<tr>
<td>Operation</td>
<td>BEN_BNFT_RT_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Restrict Change Based On</td>
<td>BEN_BNFT_R_OPT_RSTRN</td>
<td>All</td>
</tr>
<tr>
<td>Certification Type</td>
<td>BEN_BNF_CTFN_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Default Beneficiary Code</td>
<td>BEN_BNF_DFLT</td>
<td>All</td>
</tr>
<tr>
<td>Plan Beneficiary Designation Code</td>
<td>BEN_BNF_DSGN</td>
<td>All</td>
</tr>
<tr>
<td>Measures Allowed</td>
<td>BEN_BNF_PCT_AMT_ALWD</td>
<td>All</td>
</tr>
<tr>
<td>Benefit Type</td>
<td>BEN_BNF_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Expression</td>
<td>BEN_BOOL</td>
<td>All</td>
</tr>
<tr>
<td>Close Enrollment Date to Use</td>
<td>BEN_CLS_ENRT_DT_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_CMCD_REF_PERD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_CMPNT_REF</td>
<td>All</td>
</tr>
<tr>
<td>Claims to Coverage or Balance</td>
<td>BEN_CMPR_CLMS_TO_CVG_OR_BAL</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_CMP_ENRT_ACTN_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_CM_TRGR_SRC</td>
<td>All</td>
</tr>
<tr>
<td>Type of Trigger</td>
<td>BEN_CM_TRGR_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Usage</td>
<td>BEN_CM_USG</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_CM_USG_ARA</td>
<td>All</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_COMP_ALT_VAL_T0_USE</td>
<td>All</td>
</tr>
<tr>
<td>Compensation Category</td>
<td>BEN_COMP_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_CRT_ORDR_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_CTL_TTL_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Value Calculation Rule</td>
<td>BEN_CVG_CALC_MTHD_RL</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_CVG_DET_DT</td>
<td>All</td>
</tr>
<tr>
<td>Validate</td>
<td>BEN_DB_UPD_MD</td>
<td>All</td>
</tr>
<tr>
<td>Deduction Schedule</td>
<td>BEN_DED_SCHED</td>
<td>All</td>
</tr>
<tr>
<td>Default Enrollment Code</td>
<td>BEN_DFLT_ENRT</td>
<td>All</td>
</tr>
<tr>
<td>Default Enrollment Method Code</td>
<td>BEN_DFLT_ENRT_MTHD</td>
<td>All</td>
</tr>
<tr>
<td>Default Excess Treatment</td>
<td>BEN_DFLT_EXCS_TRMT</td>
<td>All</td>
</tr>
<tr>
<td>Assign Code</td>
<td>BEN_DFLT_TO ASN_PNDG_CTFN</td>
<td>All</td>
</tr>
<tr>
<td>Delivery Medium</td>
<td>BEN_DLVRY_MED</td>
<td>All</td>
</tr>
<tr>
<td>Delivery Method</td>
<td>BEN_DLVRY_MTHD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_DLVRY_SCHED_INFO</td>
<td>All</td>
</tr>
<tr>
<td>Dependent Coverage Certification Type</td>
<td>BEN_DPNT_CVG_CTFN_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Dependent Coverage End Date</td>
<td>BEN_DPNT_CVG_END</td>
<td>All</td>
</tr>
<tr>
<td>Dependent Coverage Start Date</td>
<td>BEN_DPNT_CVG_STRT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_DRVBL_FCTR_PRPS</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_DRVBL_FCTR_UOM_PRPS</td>
<td>All</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_DSGN_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_DTA_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_DY_NAME</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_ELIG_ENRL</td>
<td>All</td>
</tr>
<tr>
<td>Eligible/Ineligible</td>
<td>BEN_ELIG_INELIG</td>
<td>All</td>
</tr>
<tr>
<td>Enrollment Certification Type</td>
<td>BEN_ENRT_CTFN_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Enrollment Coverage End Date Code</td>
<td>BEN_ENRT_CVG_END</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>---------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Enrollment Coverage Start Date Code</td>
<td>BEN_ENRT_CVG_STRT</td>
<td>All</td>
</tr>
<tr>
<td>Enrollment Period End Dates Code</td>
<td>BEN_ENRT_PERD_END</td>
<td>All</td>
</tr>
<tr>
<td>Enrollment Period Start Dates Code</td>
<td>BEN_ENRT_PERD_STRT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_ENRT_RSLT_MTHD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_ENRT_R_BNFT_CTFN</td>
<td>All</td>
</tr>
<tr>
<td>Enrollment Type</td>
<td>BEN_ENRT_TYP_CYCL</td>
<td>All</td>
</tr>
<tr>
<td>Foreign Earning/Deduction Type</td>
<td>BEN_ERG_DED</td>
<td>All</td>
</tr>
<tr>
<td>Collapsing Logic Code</td>
<td>BEN_EVAL</td>
<td>All</td>
</tr>
<tr>
<td>Life Event Occurred Date Code</td>
<td>BEN_EVAL_DET</td>
<td>All</td>
</tr>
<tr>
<td>Event</td>
<td>BEN_EVENT</td>
<td>All</td>
</tr>
<tr>
<td>Excess Treatment</td>
<td>BEN_EXCS_TRTMT</td>
<td>All</td>
</tr>
<tr>
<td>Change Event</td>
<td>BEN_EXT_CHG_EVT</td>
<td>All</td>
</tr>
<tr>
<td>Format Mask</td>
<td>BEN_EXT_FRMT_MASK</td>
<td>All</td>
</tr>
<tr>
<td>Operator</td>
<td>BEN_EXT_OPER</td>
<td>All</td>
</tr>
<tr>
<td>Run Status</td>
<td>BEN_EXT_STAT</td>
<td>All</td>
</tr>
<tr>
<td>Condition (Optional) Where</td>
<td>BEN_EXT_TTL_COND_OPER</td>
<td>All</td>
</tr>
<tr>
<td>Total Information Function</td>
<td>BEN_EXT_TTL_FNCTN</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>BEN_FIELD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_FILE_CTL_TTL_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_FILE_DTA_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_FILE_RCRD_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_FILE_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_FILE_UPDT_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_FL_TM_PT_TM</td>
<td>All</td>
</tr>
<tr>
<td>Family Member Code</td>
<td>BEN_FMLY_MMBR</td>
<td>All</td>
</tr>
<tr>
<td>Frequency</td>
<td>BEN_FREQ</td>
<td>All</td>
</tr>
<tr>
<td>Usage</td>
<td>BEN_GD_OR_SVC_USG</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_GD_R_SVC_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_GNDR</td>
<td>All</td>
</tr>
<tr>
<td>Group Relationship</td>
<td>BEN_GRP_RLSHP</td>
<td>All</td>
</tr>
<tr>
<td>Health Service</td>
<td>BEN_HLTH_CARE_SVC_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_HRS_ALT_VAL_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td>Determination Code</td>
<td>BEN_HRS_WKD_DET</td>
<td>All</td>
</tr>
<tr>
<td>Source</td>
<td>BEN_HRS_WKD_SRC</td>
<td>All</td>
</tr>
<tr>
<td>Subject to Imputed Income</td>
<td>BEN_IMPTD_INCM_CALC</td>
<td>All</td>
</tr>
<tr>
<td>Imputed Income Type</td>
<td>BEN_IMPTD_INCM_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_INELG_RSN</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_INFO_SRC</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_INTRFC_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_LER_CHG_DPNT_CVG</td>
<td>All</td>
</tr>
<tr>
<td>Timeliness Evaluation</td>
<td>BEN_LER_TMLNS_EVAL</td>
<td>All</td>
</tr>
<tr>
<td>Timeliness Period</td>
<td>BEN_LER_TMLNS_PERD</td>
<td>All</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_LER_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Determination</td>
<td>BEN_LMT_DET</td>
<td>All</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_LOS_ALT_VAL_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td>Determination Code</td>
<td>BEN_LOS_DET</td>
<td>All</td>
</tr>
<tr>
<td>Date to Use Code</td>
<td>BEN_LOS_DT_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_MED_CNTNT_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_MED_FMT_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_MOLY_PYMT_DUE DY_NUM</td>
<td>All</td>
</tr>
<tr>
<td>Applies to</td>
<td>BEN_MX_POE_APLS</td>
<td>All</td>
</tr>
<tr>
<td>Maximum Enrollment Determination Date Code</td>
<td>BEN_MX_POE_DET_DT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_MX_WTG_DT_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_MX_WTG_PERD_PRTE_DET</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Non-Monetary UOM</td>
<td>BEN_NNMNTRY_UOM</td>
<td>All</td>
</tr>
<tr>
<td>Occurred Date Determination</td>
<td>BEN_OCRD_DT_DET</td>
<td>All</td>
</tr>
<tr>
<td>Once or Continuing</td>
<td>BEN_ONCE_R_CNTNG</td>
<td>All</td>
</tr>
<tr>
<td>Desktop Activities</td>
<td>BEN_ON_LINE_ACT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_ONE_ANP_PYMT_CD</td>
<td>All</td>
</tr>
<tr>
<td>Self Service Display</td>
<td>BEN_OPT_DISP_FMT</td>
<td>All</td>
</tr>
<tr>
<td>Option Type</td>
<td>BEN_OPT_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Organization Roles</td>
<td>BEN_ORG_ROLE_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Reason</td>
<td>BEN_OVRID_RSN</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PCP_CD</td>
<td>All</td>
</tr>
<tr>
<td>Designation code</td>
<td>BEN_PCP_DSGN</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PCT_AMT_ALWD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PCT_PL_TM_DET</td>
<td>All</td>
</tr>
<tr>
<td>Part of Kit</td>
<td>BEN_PC_KIT</td>
<td>All</td>
</tr>
<tr>
<td>Period Type</td>
<td>BEN_PERD_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PER_CM_PRVDD_STAT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PER_CVRD</td>
<td>All</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_PER_IN_LER_STAT</td>
<td>All</td>
</tr>
<tr>
<td>Program Group</td>
<td>BEN_PGM_GRP</td>
<td>All</td>
</tr>
<tr>
<td>Program Type</td>
<td>BEN_PGM_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PIN_PRPS</td>
<td>All</td>
</tr>
<tr>
<td>Plan Usage</td>
<td>BEN_PL</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PL_YR_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Product</td>
<td>BEN_PRDCT</td>
<td>All</td>
</tr>
<tr>
<td>Assignment</td>
<td>BEN_PREM ASNMT</td>
<td>All</td>
</tr>
<tr>
<td>Assignment Level</td>
<td>BEN_PREM ASNMT_LVL</td>
<td>All</td>
</tr>
<tr>
<td>Payer</td>
<td>BEN_PREM PYR</td>
<td>All</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_PREM_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------</td>
<td>------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_PRMRY_CARE_PRVDR_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_PRMRY_CNTNGNT</td>
<td>All</td>
</tr>
<tr>
<td>Primary Funding Method</td>
<td>BEN_PRMRY_FNDG_MTHD</td>
<td>All</td>
</tr>
<tr>
<td>Parent/Child</td>
<td>BEN_PRNT_CHLD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PROC</td>
<td>All</td>
</tr>
<tr>
<td>Processing Source</td>
<td>BEN_PROCG_SRC</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRONT_PRTL_YR_CVG_RSTRN</td>
<td>All</td>
</tr>
<tr>
<td>Prospective/Retrospective</td>
<td>BEN_PRSPCTV_R_RTPSPCTV</td>
<td>All</td>
</tr>
<tr>
<td>Partial Month Determination Code</td>
<td>BEN_PRTL_MO_DET_MTHD</td>
<td>All</td>
</tr>
<tr>
<td>Partial Month Determination Effective Date Code</td>
<td>BEN_PRTL_MO_EFF_DT_DET</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTL_YR_CVG_RSTRN</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTN_CTFN_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTN_ELIG_END</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTN_ELIG_STRT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTT_DET</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTT_DPNT_CVRD_STAT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTT_EPNT_RSLT_STAT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PTD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PTNL.Lerp_for_per_SRC</td>
<td>All</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_PTNL.Lerp_for_per_STAT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PYMT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PYMT_DET_MTHD</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_PYMT_MUST_BE_RECD</td>
<td>All</td>
</tr>
<tr>
<td>Payment Schedule</td>
<td>BEN_PYMT_SCHED</td>
<td>All</td>
</tr>
<tr>
<td>QDRO Payment Distribution</td>
<td>BEN_QDRO_DSTR_MTHD</td>
<td>All</td>
</tr>
<tr>
<td>Recipient Code</td>
<td>BEN_RCPENT</td>
<td>All</td>
</tr>
<tr>
<td>Recurring</td>
<td>BEN_RCRRG</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Administrative Code</td>
<td>BEN_REGN_ADMIN</td>
<td>All</td>
</tr>
<tr>
<td>Regulatory Plan Type</td>
<td>BEN_REGY_PL_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Regulatory Purpose</td>
<td>BEN_REGY_PRPS</td>
<td>All</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_REIMBMT_CTFN_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_REIMBRT_RQST_RCRG</td>
<td>All</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_REIMBRT_RQST_STAT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_REP_TYP</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_RESND_RSN</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_RLOVR_RSTRN</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_RMBT_CTFN_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Purpose</td>
<td>BEN_RPTG_PRPS</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_RQD_ENRL_PERD_TCO</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_RQD_PERD_ENRT_NENRT_TM_UOM</td>
<td>All</td>
</tr>
<tr>
<td>Rate End Date Code</td>
<td>BEN_RT_END</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_RT_RL_IMPCT</td>
<td>All</td>
</tr>
<tr>
<td>Rate Start Date Code</td>
<td>BEN_RT_STRT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_SCHED_INFO</td>
<td>All</td>
</tr>
<tr>
<td>Costing Method Code</td>
<td>BEN_SGMT_CSTG_MTHD</td>
<td>All</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_STAT</td>
<td>All</td>
</tr>
<tr>
<td>Start/Stop Coverage Code</td>
<td>BEN_STRT_R_STP_CVG</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_SVC_DT_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_TCO_CHG_ENRT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_TM_UOM</td>
<td>All</td>
</tr>
<tr>
<td>To Be Sent</td>
<td>BEN_TO_BE_SENT_DT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_TRNSMSN_CALCS</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>--------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Tax Type</td>
<td>BEN_TX_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Unsuspend Code</td>
<td>BEN_UNSSPND_ENRT</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_UPDT_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Usage</td>
<td>BEN_USG</td>
<td>All</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_VAL_TO_USE</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_WHIN_TO_PRCS_LER</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>BEN_WTG_PERD_DET</td>
<td>All</td>
</tr>
<tr>
<td>Date to use code</td>
<td>BEN_WTG_PERD_DT</td>
<td>All</td>
</tr>
<tr>
<td>Waiting Period UOM</td>
<td>BEN_WTG_PERD_UOM</td>
<td>All</td>
</tr>
<tr>
<td>Waive Coverage Reason</td>
<td>BEN_WV_CVG_RSN</td>
<td>All</td>
</tr>
<tr>
<td>Waive Participation Certification Type</td>
<td>BEN_WV_PRTN_CTFN_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Waiving Participation Reason</td>
<td>BEN_WV_PRTN_RSN</td>
<td>All</td>
</tr>
<tr>
<td>Waive Type</td>
<td>BEN_WV_TYP</td>
<td>All</td>
</tr>
<tr>
<td>Blood Type</td>
<td>BLOOD_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Source of student</td>
<td>BOOKING_SOURCE</td>
<td>All</td>
</tr>
<tr>
<td>Measurement Type (for budget)</td>
<td>BUDGET_MEASUREMENT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Cash Analysis (for a cash payment)</td>
<td>CASH_ANALYSIS</td>
<td>All</td>
</tr>
<tr>
<td>Census Metropolitan Area (Canada)</td>
<td>CA_CMA</td>
<td>Canada</td>
</tr>
<tr>
<td>Canadian Payment Association Codes</td>
<td>CA_DD_CPA_CODES</td>
<td>Canada</td>
</tr>
<tr>
<td>Select Form to be printed (Canada)</td>
<td>CA_FORM_NAME</td>
<td>Canada</td>
</tr>
<tr>
<td></td>
<td>CA_INVOLUNTARY_DEDUCTIONS</td>
<td>Canada</td>
</tr>
<tr>
<td></td>
<td>CA_PAYMENT</td>
<td>Canada</td>
</tr>
<tr>
<td>Province (Canadian addresses)</td>
<td>CA_PROVINCE</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>CA_REGULAR_EARNINGS</td>
<td>Canada</td>
</tr>
<tr>
<td></td>
<td>CA_SUPPLEMENTAL_EARNINGS</td>
<td>Canada</td>
</tr>
<tr>
<td></td>
<td>CA_TAXABLE_BENEFITS</td>
<td>Canada</td>
</tr>
<tr>
<td></td>
<td>CA_VOLUNTARY_DEDUCTIONS</td>
<td>Canada</td>
</tr>
<tr>
<td>Method</td>
<td>CERTIFICATION_METHOD</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>--------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>List of Swiss Cantons</td>
<td>CH_CANTON</td>
<td>All</td>
</tr>
<tr>
<td></td>
<td>CHECKBOX</td>
<td>All</td>
</tr>
<tr>
<td>Check item (on a checklist)</td>
<td>CHECKLIST_ITEM</td>
<td>All</td>
</tr>
<tr>
<td>Status (of an item on a checklist)</td>
<td>CHECKLIST_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>User friendly names for cheque/check-ordering SQL statement</td>
<td>CHEQUE_PROCEDURE</td>
<td>All</td>
</tr>
<tr>
<td>User friendly names for cheque/check-writing SRW2 reports.</td>
<td>CHEQUE_REPORT</td>
<td>All</td>
</tr>
<tr>
<td>Company Age (for salary surveys mappings)</td>
<td>COMPANY_AGE</td>
<td>All</td>
</tr>
<tr>
<td>Company Size (for salary surveys)</td>
<td>COMPANY_SIZE</td>
<td>All</td>
</tr>
<tr>
<td>Primary Evaluation Method</td>
<td>COMPETENCE_EVAL_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Consultation Type</td>
<td>CONSULTATION_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Consultation Result</td>
<td>CONSULTATION_RESULT</td>
<td>All</td>
</tr>
<tr>
<td>Competence Type</td>
<td>COMPETENCE_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Type (relationship of one person to another)</td>
<td>CONTACT</td>
<td>All</td>
</tr>
<tr>
<td>Contract End Reason</td>
<td>CONTRACT_END_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Contract Start Reason</td>
<td>CONTRACT_START_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Contract Status</td>
<td>CONTRACT_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Contract Status Reason</td>
<td>CONTRACT_STATUS_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Contract Types</td>
<td>CONTRACT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Contract Types (Belgium)</td>
<td>CONTRACT_TYPE_BE</td>
<td>Belgium</td>
</tr>
<tr>
<td>Type (of MIX batch control total)</td>
<td>CONTROL_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Reason a student failed to successfully complete an event.</td>
<td>DELEGATE_FAILURE_REASON</td>
<td>All</td>
</tr>
<tr>
<td>User defined Type to categorize development events.</td>
<td>DEV_EVENT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Category (of disability)</td>
<td>DISABILITY_CATEGORY</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Reason (for disability)</td>
<td>DISABILITY_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Status (of disability)</td>
<td>DISABILITY_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Disease Type</td>
<td>DISEASE_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Document Status (contract)</td>
<td>DOCUMENT_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for element entry)</td>
<td>ELE_ENTRY_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for employee assignment)</td>
<td>EMP_ASSIGN_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Employment Category</td>
<td>EMP_CAT</td>
<td>All</td>
</tr>
<tr>
<td>Type (of employee event)</td>
<td>EMP_EVENT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Type (of interview for employee)</td>
<td>EMP_INTERVIEW_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for secondary assignment status)</td>
<td>EMP_SEC_ASSIGN_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for change in enrollment status)</td>
<td>ENROLLMENT_STATUS_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Ethnic Origin</td>
<td>ETH_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>System (job or position evaluation system)</td>
<td>EVAL_SYSTEM</td>
<td>All</td>
</tr>
<tr>
<td>Measurement In (type for EVAL SYSTEM)</td>
<td>EVAL_SYSTEM_MEAS</td>
<td>All</td>
</tr>
<tr>
<td>User defined status for an event</td>
<td>EVENT_USER_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Type (of work pattern exception)</td>
<td>EXCEPTIONCATEGORY</td>
<td>All</td>
</tr>
<tr>
<td>Type (of finance line)</td>
<td>FINANCE_LINE_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Type (of formula)</td>
<td>FORMULA_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Activity Type</td>
<td>FR_ACTIVITY_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Address Suffix</td>
<td>FR_ADDRESS_SUFFIX</td>
<td>France</td>
</tr>
<tr>
<td>AGIRC/ARRCO</td>
<td>FR_AGIRC_ARRCO</td>
<td>France</td>
</tr>
<tr>
<td>Bank</td>
<td>FR_BANK</td>
<td>France</td>
</tr>
<tr>
<td>Contract Category</td>
<td>FR_CONTRACT_CATEGORY</td>
<td>France</td>
</tr>
<tr>
<td>Disability/COTOREP Code</td>
<td>FR_COTOREP_CODE</td>
<td>France</td>
</tr>
<tr>
<td>DADS Type</td>
<td>FR_DADS_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Department</td>
<td>FR_DEPARTMENT</td>
<td>France</td>
</tr>
<tr>
<td>Disciplinary Actions</td>
<td>FR_DISCIPLINARY_ACTION</td>
<td>France</td>
</tr>
<tr>
<td>Education Status</td>
<td>FR_EDUCATION_STATUS</td>
<td>France</td>
</tr>
<tr>
<td>Employee Category</td>
<td>FR_EMPLOYEE_CATEGORY</td>
<td>France</td>
</tr>
<tr>
<td>Employee Status</td>
<td>FR_EMPLOYEE_STATUS</td>
<td>France</td>
</tr>
<tr>
<td>Employer Type</td>
<td>FR_EMPLOYER_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Employment Type</td>
<td>FR_EMPLOYMENT_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Ending Reason</td>
<td>FR_ENDING_REASON</td>
<td>France</td>
</tr>
<tr>
<td>Class of Illness</td>
<td>FR_ILLNESS_CLASS</td>
<td>France</td>
</tr>
<tr>
<td>Type of Illness</td>
<td>FR_ILLNESS_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Invalidity Category</td>
<td>FR_INVALIDITY_CLASS</td>
<td>France</td>
</tr>
<tr>
<td>Qualification Level</td>
<td>FR_LEVEL_OF_WORKER</td>
<td>France</td>
</tr>
<tr>
<td>Mandate Type</td>
<td>FR_MANDATE_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Type of Medical Examination</td>
<td>FR_MEDICAL_EXAMINATION_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Result of Medical Examination</td>
<td>FR_MEDICAL_RESULT</td>
<td>France</td>
</tr>
<tr>
<td>Military Service Status</td>
<td>FR_MILITARY_SERVICE_STATUS</td>
<td>France</td>
</tr>
<tr>
<td>Military Service Types</td>
<td>FR_MILITARY_SERVICE_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Misdemeanor Type</td>
<td>FR_MISDEMEANOUR_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>NAF/APE Code</td>
<td>FR_NAF_CODE</td>
<td>France</td>
</tr>
<tr>
<td>PCS Code</td>
<td>FR_PCS_CODE</td>
<td>France</td>
</tr>
<tr>
<td>Pension Code</td>
<td>FR_PENSION_CODE</td>
<td>France</td>
</tr>
<tr>
<td>Previous Employer COTOREP Type</td>
<td>FR_PREVIOUS_COTOREP</td>
<td>France</td>
</tr>
<tr>
<td>Department</td>
<td>FR_REGION</td>
<td>France</td>
</tr>
<tr>
<td>Representative Type</td>
<td>FR_REPRESENTATIVE_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Starting Reason</td>
<td>FR_STARTING_REASON</td>
<td>France</td>
</tr>
<tr>
<td>Types of French Training</td>
<td>FR_TRAINING_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Type of Worker</td>
<td>FR_TYPE_OF_WORKER</td>
<td>France</td>
</tr>
<tr>
<td>URSSAF Code</td>
<td>FR_URSSAF_CODE</td>
<td>France</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>---------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Visa Status</td>
<td>FR_VISA_STATUS</td>
<td>France</td>
</tr>
<tr>
<td>Visa Type</td>
<td>FR_VISA_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Work Accident Code</td>
<td>FR_WORK_ACCIDENT_CODE</td>
<td>France</td>
</tr>
<tr>
<td>Work Accident Result</td>
<td>FR_WORK_ACCIDENT_RESULT</td>
<td>France</td>
</tr>
<tr>
<td>Type of Work Accident</td>
<td>FR_WORK_ACCIDENT_TYPE</td>
<td>France</td>
</tr>
<tr>
<td>Work Pattern</td>
<td>FR_WORK_PATTERN</td>
<td>France</td>
</tr>
<tr>
<td>Medical Service</td>
<td>FR_WORK_MEDICAL_SERVICE</td>
<td>France</td>
</tr>
<tr>
<td>Representative Body’s method of funding</td>
<td>FUNDING_METHOD</td>
<td>All</td>
</tr>
<tr>
<td>Authority (for PAYE details)</td>
<td>GB_AUTHORITY</td>
<td>GB</td>
</tr>
<tr>
<td>Bank Name</td>
<td>GB_BANKS</td>
<td>GB</td>
</tr>
<tr>
<td>Certificate (for element NI)</td>
<td>GB_CERTIFICATE</td>
<td>GB</td>
</tr>
<tr>
<td>Cheque/Check Style</td>
<td>GB_CHEQUE_REPORT</td>
<td>GB</td>
</tr>
<tr>
<td>County (UK addresses)</td>
<td>GB_COUNTY</td>
<td>GB</td>
</tr>
<tr>
<td>Pay day type</td>
<td>GB_PAY_DAY_TYPE</td>
<td>GB</td>
</tr>
<tr>
<td>Pension</td>
<td>GB_PENSION</td>
<td>GB</td>
</tr>
<tr>
<td>Allows users to to define valid SCON number for NI SCON input</td>
<td>GB_SCON</td>
<td>GB</td>
</tr>
<tr>
<td>Sequence (for the BACS process)</td>
<td>GB_SORT_SEQUENCE</td>
<td>GB</td>
</tr>
<tr>
<td>Names of Item Types for HR Summary Process</td>
<td>GSP_ITEM_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Names of Key Types for HR Summary Process</td>
<td>GSP_KEY_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Names of Restriction Types for HR Summary Process</td>
<td>GSP_RESTRICTION_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Hazard</td>
<td>HAZARD_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Date Posted</td>
<td>HR_APPLICATION_DATE</td>
<td>All</td>
</tr>
<tr>
<td>Hire Date</td>
<td>HR_HIRE_DATE</td>
<td>All</td>
</tr>
<tr>
<td>Banks in Ireland</td>
<td>HR_IE_BANK</td>
<td>Ireland</td>
</tr>
<tr>
<td>Date Posted</td>
<td>HR_JOB_POSTED_DATE</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>--------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Academic Title</td>
<td>HR_NL_ACADEMIC_TITLE</td>
<td>NL</td>
</tr>
<tr>
<td>Dutch Bank Details</td>
<td>HR_NL_BANK</td>
<td>NL</td>
</tr>
<tr>
<td>Dutch Cities</td>
<td>HR_NL_CITY</td>
<td>NL</td>
</tr>
<tr>
<td>Correspondence Language</td>
<td>HR_CORR_LANGUAGE</td>
<td>NL</td>
</tr>
<tr>
<td>Dutch HR WAO Disability</td>
<td>HR_NL_DI_WAO</td>
<td>NL</td>
</tr>
<tr>
<td>Full Name Format</td>
<td>HR_NL_FULL_NAME_FORMAT</td>
<td>NL</td>
</tr>
<tr>
<td>Identification Certificate</td>
<td>HR_NL_ID_CERTIFICATE</td>
<td>NL</td>
</tr>
<tr>
<td>Job Level</td>
<td>HR_NL_JOB_LEVEL</td>
<td>NL</td>
</tr>
<tr>
<td>Nationality</td>
<td>HR_NL_NATIONALITY</td>
<td>NL</td>
</tr>
<tr>
<td>Province</td>
<td>HR_NL_PROVINCE</td>
<td>NL</td>
</tr>
<tr>
<td>Dutch Regions</td>
<td>HR_NL_REGIONS</td>
<td>NL</td>
</tr>
<tr>
<td>Royal Title</td>
<td>HR_NL_ROTAL_TITLE</td>
<td>NL</td>
</tr>
<tr>
<td>End Reasons for Social Health Insurance Report</td>
<td>HR_NL_SHI_END</td>
<td>NL</td>
</tr>
<tr>
<td>Special Title</td>
<td>HR_NL_SPECIAL_TITLE</td>
<td>NL</td>
</tr>
<tr>
<td>Field Labels</td>
<td>HR_FORM_LABELS</td>
<td>NL</td>
</tr>
<tr>
<td>Batch process used by OTM</td>
<td>HXT_BATCH_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Days of the week</td>
<td>HXT_DAY_OF_WEEK</td>
<td>All</td>
</tr>
<tr>
<td>Process modes used by OTM</td>
<td>HXT_PROCESS_MODE</td>
<td>All</td>
</tr>
<tr>
<td>Ireland Colleges</td>
<td>IE_COLLEGE</td>
<td>Ireland</td>
</tr>
<tr>
<td>Ireland County</td>
<td>IE_COUNTY</td>
<td>Ireland</td>
</tr>
<tr>
<td>Irish Qualification Types</td>
<td>IE_QUAL_TYPES</td>
<td>Ireland</td>
</tr>
<tr>
<td>Incident Type</td>
<td>INCIDENT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Industry (for salary survey)</td>
<td>INDUSTRY</td>
<td>All</td>
</tr>
<tr>
<td>Injury</td>
<td>INJURY_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Bank Name</td>
<td>IT_BANK</td>
<td>Italy</td>
</tr>
<tr>
<td>City (Italian addresses)</td>
<td>IT_CITY</td>
<td>Italy</td>
</tr>
<tr>
<td>Collective Agreement</td>
<td>IT_COLLECTIVE AGREEMENTS</td>
<td>Italy</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Contract Type</td>
<td>IT_CONTRACT_TYPE</td>
<td>Italy</td>
</tr>
<tr>
<td>Text to be displayed on Italian specific field prompts</td>
<td>IT_FORM_LABELS</td>
<td>Italy</td>
</tr>
<tr>
<td>Employment Category</td>
<td>IT_EMP_CAT</td>
<td>Italy</td>
</tr>
<tr>
<td>Province (Italian addresses)</td>
<td>IT_PROVINCE</td>
<td>All</td>
</tr>
<tr>
<td>Trade Unions</td>
<td>IT_TRADE_UNIONS</td>
<td>Italy</td>
</tr>
<tr>
<td>Unemployment Insurance Codes</td>
<td>IT_UNEMPLOYMENT_INSURANCE_CODE</td>
<td>Italy</td>
</tr>
<tr>
<td>Unemployment Insurance Sub Codes</td>
<td>IT_UNEMPLOYMENT_INS_SUB_CODE</td>
<td>Italy</td>
</tr>
<tr>
<td>Extra Job Information</td>
<td>JOB_CATEGORY</td>
<td>All</td>
</tr>
<tr>
<td>Categories of Jobs</td>
<td>JOB_CATEGORIES</td>
<td>All</td>
</tr>
<tr>
<td>Representative Body’s Jurisdiction</td>
<td>JURISDICTION</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for leaving)</td>
<td>LEAV_REAS</td>
<td>All</td>
</tr>
<tr>
<td>Marital Status</td>
<td>MAR_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Marital Status (Belgium)</td>
<td>MAR_STATUS_BE</td>
<td>Belgium</td>
</tr>
<tr>
<td>North American Industry Code for Canada</td>
<td>NAIC</td>
<td>All</td>
</tr>
<tr>
<td>Nationality</td>
<td>NATIONALITY</td>
<td>All</td>
</tr>
<tr>
<td>NI Unique Error or Warning</td>
<td>NI_UNIQUE_ERROR_WARNING</td>
<td>All</td>
</tr>
<tr>
<td>Region (New Zealand addresses)</td>
<td>NZ_COUNTIES</td>
<td>All</td>
</tr>
<tr>
<td>District of Origin</td>
<td>NZ_DISTRICT_OF_ORIGIN</td>
<td>New Zealand</td>
</tr>
<tr>
<td>Ethnic Origin</td>
<td>NZ_ETHNIC_ORIGIN</td>
<td>New Zealand</td>
</tr>
<tr>
<td>Tribal Group</td>
<td>NZ_TRIBAL_GROUP</td>
<td>New Zealand</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Organization Type</td>
<td>ORG_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Class Begins</td>
<td>OTA_ENROLL_CLASS_DATE</td>
<td>All</td>
</tr>
<tr>
<td>Use to which a work pattern is or may be put</td>
<td>PATTERN_PURPOSE</td>
<td>All</td>
</tr>
<tr>
<td>Type of checksum used for deductions batches</td>
<td>PAY_PDT_DED_CKSUM</td>
<td>All</td>
</tr>
<tr>
<td>Type of checksum used for earnings deductions batches</td>
<td>PAY_PDT_EARN_CKSUM</td>
<td>All</td>
</tr>
<tr>
<td>Type of checksum used for time entry batches</td>
<td>PAY_PDT_TIME_CKSUM</td>
<td>All</td>
</tr>
<tr>
<td>Category</td>
<td>PER_CATEGORIES</td>
<td>All</td>
</tr>
<tr>
<td>Communication delivery method, Report Method</td>
<td>PER_CM_MTHD</td>
<td>All</td>
</tr>
<tr>
<td>FTE Capacity</td>
<td>PER_FTE_CAPACITY</td>
<td>All</td>
</tr>
<tr>
<td>Minimum Service</td>
<td>PER_LENGTHS_OF_SERVICE</td>
<td>All</td>
</tr>
<tr>
<td>Relocation</td>
<td>PER_RELOCATION_PREFERENCES</td>
<td>All</td>
</tr>
<tr>
<td>Status</td>
<td>PER_SUBJECT_STATUSES</td>
<td>All</td>
</tr>
<tr>
<td>Subject</td>
<td>PER_SUBJECTS</td>
<td>All</td>
</tr>
<tr>
<td>Work Duration</td>
<td>PER_TIME_SCALES</td>
<td>All</td>
</tr>
<tr>
<td>Tuition Method</td>
<td>PER_TUITION_METHODS</td>
<td>All</td>
</tr>
<tr>
<td>US Country Code</td>
<td>PER_US_COUNTRY_CODE</td>
<td>USA</td>
</tr>
<tr>
<td>I9 Status</td>
<td>PER_US_I9_STATE</td>
<td>USA</td>
</tr>
<tr>
<td>US Income Types</td>
<td>PER_US_INCOME_TYPES</td>
<td>USA</td>
</tr>
<tr>
<td>US Process Type</td>
<td>PER_US_PROCESS_TYPE</td>
<td>USA</td>
</tr>
<tr>
<td>US Residency Status</td>
<td>PER_US_RES_STATUS</td>
<td>USA</td>
</tr>
<tr>
<td>US Visa Categories</td>
<td>PER_US_VISA_CATEGORIES</td>
<td>USA</td>
</tr>
<tr>
<td>US Visa Types</td>
<td>PER_US_VISA_TYPES</td>
<td>USA</td>
</tr>
<tr>
<td>US Visit Code</td>
<td>PER_US_VISIT_CODE</td>
<td>USA</td>
</tr>
<tr>
<td>Work Hours</td>
<td>PER_WORK_HOURS</td>
<td>All</td>
</tr>
<tr>
<td>Work Schedule</td>
<td>PER_WORK_SCHEDULE</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Rating</td>
<td>PERFORMANCE_RATING</td>
<td>All</td>
</tr>
<tr>
<td>Type</td>
<td>PHONE_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for grade step placement)</td>
<td>PLACEMENT_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Position Family</td>
<td>POSITION_FAMILY</td>
<td>All</td>
</tr>
<tr>
<td>Status (of reserved position)</td>
<td>POSITION_RESERVED_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Status (of position)</td>
<td>POSITION_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Academic Rank</td>
<td>PQH_ACADEMIC_RANK</td>
<td>USA</td>
</tr>
<tr>
<td>Tenure Status</td>
<td>PQH_TENURE_STATUS</td>
<td>USA</td>
</tr>
<tr>
<td>Element Extra Information (rate type name)</td>
<td>PQP_RATE_TYPE</td>
<td>UK</td>
</tr>
<tr>
<td>Student Enrollments Priority</td>
<td>PRIORITY_LEVEL</td>
<td>All</td>
</tr>
<tr>
<td>Type (of Professional Credits)</td>
<td>PROFESSIONAL_CREDIT_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Source of Proficiency Rating</td>
<td>PROFICIENCY_SOURCE</td>
<td>All</td>
</tr>
<tr>
<td>A label given to group events within a program</td>
<td>PROGRAM_MEMBERSHIP_GROUP</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for salary proposal)</td>
<td>PROPOSAL_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Units (qualifying units for probation period)</td>
<td>QUALIFYING_UNITS</td>
<td>All</td>
</tr>
<tr>
<td>Type (of recruitment activity, also used in application source)</td>
<td>REC_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Report Method</td>
<td>REPORT_METHOD</td>
<td>All</td>
</tr>
<tr>
<td>Type (of resource)</td>
<td>RESOURCE_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Reason (a resource is used by an activity)</td>
<td>RESOURCE_USAGE_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Account Type</td>
<td>SG_ACCOUNT_TYPE</td>
<td>Singapore</td>
</tr>
<tr>
<td>Bank Code</td>
<td>SG_BANK_CODE</td>
<td>Singapore</td>
</tr>
<tr>
<td>Employer IRAS Category</td>
<td>SG_EMPLOYER_IRAS_CATEGORY</td>
<td>Singapore</td>
</tr>
<tr>
<td>Permit Category</td>
<td>SG_PERMIT_CATEGORY</td>
<td>Singapore</td>
</tr>
<tr>
<td>Race</td>
<td>SG_RACE</td>
<td>Singapore</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Religion</td>
<td>SG_RELIGION</td>
<td>Singapore</td>
</tr>
<tr>
<td>Survey Age (for salary surveys)</td>
<td>SURVEY_AGE</td>
<td>All</td>
</tr>
<tr>
<td>Survey Company (for salary surveys)</td>
<td>SURVEY_COMPANY</td>
<td>All</td>
</tr>
<tr>
<td>Job Name (for salary surveys)</td>
<td>SURVEY_JOB_NAME</td>
<td>All</td>
</tr>
<tr>
<td>Region (for salary surveys)</td>
<td>SURVEY_REGION</td>
<td>All</td>
</tr>
<tr>
<td>Seniority (for salary surveys)</td>
<td>SURVEY_SENIORITY</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for terminating application)</td>
<td>TERM_APL_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Prefix</td>
<td>TITLE</td>
<td>All</td>
</tr>
<tr>
<td>Uses Tobacco (for benefits)</td>
<td>TOBACCO_USER</td>
<td>All</td>
</tr>
<tr>
<td>Role (of trainer in event)</td>
<td>TRAINER_PARTICIPATION</td>
<td>All</td>
</tr>
<tr>
<td>Center (where event takes place)</td>
<td>TRAINING_CENTRE</td>
<td>All</td>
</tr>
<tr>
<td>Type (of unit for event pricing)</td>
<td>TRAINING_UNIT</td>
<td>All</td>
</tr>
<tr>
<td>Accrual Start</td>
<td>US_ACCRUAL_START_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>Status of request for accommodation</td>
<td>US_ADA_STATUSES</td>
<td>All</td>
</tr>
<tr>
<td>Coverage Level (for medical, dental and vision benefit plans)</td>
<td>US_BENEFIT_COVERAGE</td>
<td>All</td>
</tr>
<tr>
<td>Status (of continued coverage)</td>
<td>US_COBRA_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Reason (for COBRA Termination)</td>
<td>US_COBRA_TERM_REASON</td>
<td>All</td>
</tr>
<tr>
<td>Category (within Earnings classification)</td>
<td>US_EARNINGS</td>
<td>All</td>
</tr>
<tr>
<td>Category (within Imputed Earnings classification)</td>
<td>US_IMPUTED_EARNINGS</td>
<td>All</td>
</tr>
<tr>
<td>Category (within Information classification)</td>
<td>US_INFORMATION</td>
<td>All</td>
</tr>
<tr>
<td>Category (within Involuntary Deductions classification)</td>
<td>US_INVOLUNTARY_DEDUCTIONS</td>
<td>All</td>
</tr>
<tr>
<td>Job Groups</td>
<td>US_JOB_GROUPS</td>
<td>All</td>
</tr>
<tr>
<td>Filing Status for local income tax</td>
<td>US_LIT_FILING_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Exemption Reason (for excluding employee from New Hire report)</td>
<td>US_NEW_HIRE_EXCEPTIONS</td>
<td>All</td>
</tr>
<tr>
<td>Field</td>
<td>Lookup</td>
<td>Legislation</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>---------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Category (within Nonpayroll Payments classification)</td>
<td>USPAYMENT</td>
<td>All</td>
</tr>
<tr>
<td>Category (of accrual plan)</td>
<td>US_PTO_ACCRUAL</td>
<td>All</td>
</tr>
<tr>
<td>Filing Status for state income tax</td>
<td>US_SIT_FILING_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>State (US addresses)</td>
<td>US_STATE</td>
<td>All</td>
</tr>
<tr>
<td>Category (within Supplemental Earnings classification)</td>
<td>US_SUPPLEMENTAL_EARNINGS</td>
<td>All</td>
</tr>
<tr>
<td>Row Type (for Payroll Tables)</td>
<td>US_TABLE_ROW_TYPES</td>
<td>All</td>
</tr>
<tr>
<td>List of different instances of US Payroll Tax Balance reports</td>
<td>US_TAX_REPORT</td>
<td>All</td>
</tr>
<tr>
<td>Category (within Voluntary Deductions classification)</td>
<td>US_VOLUNTARY_DEDUCTIONS</td>
<td>All</td>
</tr>
<tr>
<td>Position of WC surcharge (after experience modifications and after premium discount)</td>
<td>US_WC_SURCHARGE_POSITION</td>
<td>All</td>
</tr>
<tr>
<td>Category (of a vacancy, for use in HR Direct Access)</td>
<td>VACANCY_CATEGORY</td>
<td>All</td>
</tr>
<tr>
<td>Status (of a vacancy)</td>
<td>VACANCY_STATUS</td>
<td>All</td>
</tr>
<tr>
<td>Type of Reporting Organization</td>
<td>VETS_ORG_TYPE</td>
<td>All</td>
</tr>
<tr>
<td>User friendly names for cheque writing SRW2 reports</td>
<td>W2_BOX-14_USER_DEFINED</td>
<td>All</td>
</tr>
<tr>
<td>Name (of global used in workflow)</td>
<td>WF_GLOBAL</td>
<td>All</td>
</tr>
<tr>
<td>Availability Schedule</td>
<td>WORK_SCHEDULE</td>
<td>All</td>
</tr>
</tbody>
</table>
Canadian Lookup Types

Lookup types are categories of information that have a defined list of valid values. Examples of lookup types are Nationality or Title. The lookup types listed here are system lookup types specific to Canadian HRMS.

<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template type</td>
<td>ELEMENT_TEMPLATE_TYPE</td>
</tr>
<tr>
<td>Type of object generated by the template engine</td>
<td>CORE_OBJECT_TYPE</td>
</tr>
<tr>
<td>ROE Reason</td>
<td>CA_ROE_REASON</td>
</tr>
</tbody>
</table>
Adding Lookup Types and Values

To create a new lookup type, add values to an existing lookup type, or prevent existing values from appearing in a lookup type, use the Application Utilities Lookups window.

Note: You must log out and log in again to see the effect of your changes.

Defining Lookup Types

You can create your own lookup types to provide lists of values, for example to validate element entries.

To define a new lookup type and lookup values:
1. Choose the access level for the lookup type.
2. Enter the lookup type.
3. Enter the user name of the lookup. This is the name that users will see from within the application.
4. Select the application in which the lookup will be used.
5. Optionally, add a description of the lookup type.
6. If you want to add lookup values specific to the security group/business group linked to your current responsibility, un–check the Global Security Group check box. Existing lookup values are available to all business groups.

Attention: The Global Security Group check box only displays if you are using Security Group Enabled Security with a non–default security group. If you use Standard HRMS security, or the default (Standard) security group in Security Group Enabled Security, all lookup types are global.

See: Categorizing Information By Security Groups: page 3 – 39

7. Enter the code, meaning and optionally a description for each value. Leave the Tag column blank.

If you do not enter a start date, the new lookup is valid immediately. If you do not enter an end date, the new lookup is valid indefinitely.

8. Save your work.

Defining Lookup Values

To add lookup values to an existing lookup type:
1. Query the lookup type to which you want to add a value.
You cannot add values if the access level is System.

2. If you want to add lookup values specific to the security group/business group linked to your current responsibility, un–check the Global Security Group check box. Existing lookup values are available to all business groups.

   **Attention:** The Global Security Group check box only displays if you are using Security Group Enabled Security with a non–default security group. If you use Standard HRMS security, or the default (Standard) security group in Security Group Enabled Security, all lookup types are global.

3. Enter the code, meaning and optionally a description for each value. Leave the Tag column blank.

   **Warning:** Do not change or remove any legislation codes that are shown in the Tag column for existing lookup values. This may have implications elsewhere in your HRMS system.

   If you do not enter a start date, the new lookup is valid immediately. If you do not enter an end date, the new lookup is valid indefinitely.

4. Save your work.
Removing Lookup Values

You can only remove lookup values if they are set up for a specific security group. However, you can stop all lookups appearing in lists of values.

Note: You must be using Security Group Enabled security to categorize lookups by security groups. See: Categorizing Information By Security Groups: page 3 – 39

To remove a user defined lookup:

In the Application Utilities Lookups window, do one of the following:

• Enter an end date if you want to prevent users selecting this value after a certain date.

• Disable the code by un-checking the Enabled check box if you want to prevent users selecting this value with immediate effect from the current date.

• Change the meaning and description to create a replacement lookup.

If you add, disable, or change the meaning of a lookup, users must log out and log back in again for your changes to take effect.

To remove a lookup set up for a security group:

1. In the Application Utilities Lookups window, select the lookup type which has lookups for a specific security group.

2. Check the Global Security Group check box.

This removes all lookups which have been set up for the security group linked to your current responsibility. Predefined lookups are not removed.

If you add, disable, or change the meaning of a lookup, users must log out and log back in again for your changes to take effect.
CUSTOM Library Events

Generic Events

An event is a point within the processing of a form at which you can call custom code from the CUSTOM library. For example, the event WHEN–FORM–NAVIGATE enables you to code a sequence of logic that will fire after any existing logic for the form, block or item. WHEN–FORM–NAVIGATE is an example of a generic event available to all the windows in Oracle Applications. For a complete list of generic events see: Events Passed to the CUSTOM Library, Oracle Applications Developer’s Guide.

Product Specific Events

In addition to generic events, Oracle HRMS provides a range of product specific events that enable you to make CUSTOM library calls to support your business rules. The product-specific events for HRMS are available for most HRMS windows. The following table details the purpose of each event and shows when the events occur.

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Purpose</th>
<th>When Occurs</th>
</tr>
</thead>
<tbody>
<tr>
<td>WHEN–CREATE–RECORD</td>
<td>Enables you to specify values that will appear by default when you create a new record.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>POST–QUERY</td>
<td>Enables you to add additional derivation or validation on completion of a query.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>KEY–DELREC</td>
<td>Enables you to add an extra level of validation before users are allowed to delete a record from the database.</td>
<td>Immediately before the user is asked to confirm the deletion of the record.</td>
</tr>
<tr>
<td>PRE–UPDATE, PRE–INSERT and PRE–DELETE</td>
<td>Enable you to add additional validation before the update, insert or delete action is performed. We do not recommend using these events for validation.</td>
<td>After any data validation. Before DateTrack manipulation if the block contains DateTrack features.</td>
</tr>
<tr>
<td>POST–INSERT, POST–UPDATE and POST–DELETE</td>
<td>Enable you to add additional insert, update, or delete actions to user tables.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>POST–FORMS–COMMIT</td>
<td>Enables you to specify an action to occur as the last action in a sequence of commit actions.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>Event Name</td>
<td>Purpose</td>
<td>When Occurs</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>WHEN–BUTTON–PRESSED</td>
<td>Enables you to perform custom validation</td>
<td>After any data validation. Before any action (for example, display new window) has been performed.</td>
</tr>
<tr>
<td></td>
<td>before a button action is performed.</td>
<td></td>
</tr>
<tr>
<td>DT_CALL_HISTORY</td>
<td>Enables you to change which database view</td>
<td>After the user has requested to use DateTrack History and the form has</td>
</tr>
<tr>
<td></td>
<td>is used by DateTrack History.</td>
<td>derived the standard details. Before the DateTrack History window is</td>
</tr>
<tr>
<td></td>
<td></td>
<td>visible.</td>
</tr>
<tr>
<td>DT_SELECT_MODE</td>
<td>Enables you to restrict the DateTrack</td>
<td>After the form has derived which DateTrack modes are available but before</td>
</tr>
<tr>
<td></td>
<td>modes that a user can select.</td>
<td>the mode selection window is visible.</td>
</tr>
</tbody>
</table>

Additionally, there is the NAVIGATE product specific event. This is passed to the CUSTOM library whenever a user selects a task flow navigation option and prior to opening the new window. The following field values are set for the duration of this event:

- CTL_GLOBALS.DESTINATION_FORM
- CTL_GLOBALS.DESTINATION_BLOCK

You can use this event to supplement the validation that takes place when a task flow navigation option is selected.
Publicly Callable Business Process APIs

Application Programmatic Interfaces (APIs) are a logical grouping of all external process routines. The Oracle HRMS API strategy delivers a set of PL/SQL packages procedures and functions that provide an open interface to the database.

See: APIs in Oracle HRMS, Implementing Oracle HRMS. See also the Oracle Applications System Administrator’s Guide.

The following table shows the APIs delivered with Oracle HRMS.

### Business Process APIs in HRMS

<table>
<thead>
<tr>
<th>Package Name</th>
<th>File Name</th>
<th>Business Process</th>
<th>Supported by Data Pump</th>
<th>Legislation</th>
</tr>
</thead>
<tbody>
<tr>
<td>ghr_assignment_api</td>
<td>ghasngapi.pkh</td>
<td>accept_apl_asg</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_complaint_actions_api</td>
<td>ghcmqapi.pkh</td>
<td>create_complaint_actions, delete_complaint_actions, update_complaint_actions</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_complaint_bases_api</td>
<td>ghcbpapi.pkh</td>
<td>create_complaint_bases, delete_complaint_bases, update_complaint_bases</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_complaint_costs_api</td>
<td>ghccapi.pkh</td>
<td>create_complaint_costs, delete_complaint_costs, update_complaint_costs</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_complaint_issues_api</td>
<td>ghciapi.pkh</td>
<td>create_complaint_issues, delete_complaint_issues, update_complaint_issues</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_complaint_people_api</td>
<td>ghcppapi.pkh</td>
<td>create_complaint_people, delete_complaint_people, update_complaint_people</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_complaints_api</td>
<td>ghcmpapi.pkh</td>
<td>create_complaints, delete_complaints, update_complaints</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_element_api</td>
<td>gheloopkg.pkh</td>
<td>process_sfl2_element</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_noac_las_api</td>
<td>ghlaapi.pkh</td>
<td>create_noac_las, delete_noac_las, update_noac_las</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_noac_remarks_api</td>
<td>ghnraapi.pkh</td>
<td>create_noac_remarks, delete_noac_remarks, update_noac_remarks</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_pa_remarks_api</td>
<td>ghpreapi.pkh</td>
<td>create_pa_remarks, delete_pa_remarks, update_pa_remarks</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_par_extra_info_api</td>
<td>ghrlapi.pkh</td>
<td>create_pa_request_extra_info, delete_pa_request_extra_info, update_pa_request_extra_info</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_pdc_api</td>
<td>ghpdapi.pkh</td>
<td>create_pdc, delete_pdc, update_pdc</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
<td>---------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>ghr_pdi_api</td>
<td>ghpdiapi.pkh</td>
<td>create_pdi, update_pdi</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_position_api</td>
<td>ghpdiapi.pkh</td>
<td>create_position, update_position</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>ghr_sf52_api</td>
<td>ghpdiapi.pkh</td>
<td>create_sf52, end_sf52, update_sf52</td>
<td>No</td>
<td>US Federal</td>
</tr>
<tr>
<td>hr_api_hook_call_api</td>
<td>peahcapi.pkh</td>
<td>create_api_hook_call</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_api_hook_call_api</td>
<td>peahcapi.pkh</td>
<td>update_api_hook_call</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_api_hook_call_api</td>
<td>peahcapi.pkh</td>
<td>delete_api_hook_call</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_applicant_api</td>
<td>peappapi.pkh</td>
<td>create_gb_applicant</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_applicant_api</td>
<td>peappapi.pkh</td>
<td>create_gb_applicant</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_applicant_api</td>
<td>peappapi.pkh</td>
<td>create_us_applicant</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_application_api</td>
<td>peaplapi.pkh</td>
<td>update_apl_details</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assessment_groups_api</td>
<td>peasgapi.pkh</td>
<td>create_assessment_group,</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assessment_types_api</td>
<td>peastapi.pkh</td>
<td>delete_assessment_group,</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assessments_api</td>
<td>peasnapi.pkh</td>
<td>create_assessment, delete_assessment,</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>accept_apl_asg, activate_apl_asg</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>activate_emp_asg</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>actual_termination_emp_asg</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>create_gb_secondary_emp_asg</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>create_secondary_emp_asg</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>create_us_secondary_emp_asg</td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-------------------</td>
<td>-----------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>final_process_emp_asg</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>offer_apl_asg</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>set_new_primary_asg</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>suspend_emp_asg</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>terminate_apl_asg</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>update_apl_asg</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>update_emp_asg</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>update_emp_asg, update_emp_asg</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>update_gb_emp_asg</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_assignment_api</td>
<td>peasgapi.pkh</td>
<td>update_us_emp_asg</td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>hr_assignment_extra_info_api</td>
<td>peasiapi.pkh</td>
<td>create_assignment_extra_info, delete_assignment_extra_info</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_au_applicant_api</td>
<td>hrauwraa.pkh</td>
<td>create_au_applicant</td>
<td>Yes</td>
<td>AU</td>
</tr>
<tr>
<td>hr_au_assignment_api</td>
<td>hrauwrsa.pkh</td>
<td>create_au_secondary_emp_asg, update_au_emp_asg</td>
<td>Yes</td>
<td>AU</td>
</tr>
<tr>
<td>hr_au_employee_api</td>
<td>hrauwree.pkh</td>
<td>create_au_employee</td>
<td>Yes</td>
<td>AU</td>
</tr>
<tr>
<td>hr_au_person_api</td>
<td>hrauwrepe.pkh</td>
<td>update_au_person</td>
<td>Yes</td>
<td>AU</td>
</tr>
<tr>
<td>hr_au_personal_pay_method_api</td>
<td>hrauwrpm.pkh</td>
<td>create_au_personal_pay_method, update_au_personal_pay_method</td>
<td>Yes</td>
<td>AU</td>
</tr>
<tr>
<td>hr_au_super_api</td>
<td>hrauwsu.pkh</td>
<td>create_super_contribution, update_super_contribution</td>
<td>Yes</td>
<td>AU</td>
</tr>
<tr>
<td>hr_au_tax_api</td>
<td>hrauwrtx.pkh</td>
<td>maintain_paye_tax_info, maintain_super_info</td>
<td>Yes</td>
<td>AU</td>
</tr>
<tr>
<td>hr_batch_message_line_api</td>
<td>hrabmapi.pkh</td>
<td>create_message_line</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_batch_message_line_api</td>
<td>hrabmapi.pkh</td>
<td>delete_message_line</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_be_contract_api</td>
<td>hrctchei.pkh</td>
<td>create_be_contract, update_be_contract_</td>
<td>No</td>
<td>BE</td>
</tr>
<tr>
<td>hr_be_employee_api</td>
<td>peempbei.pkh</td>
<td>create_be_employee</td>
<td>No</td>
<td>BE</td>
</tr>
<tr>
<td>hr_ca_applicant_api</td>
<td>peappcaii.pkh</td>
<td>create_ca_applicant</td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>hr_ca_assignment_api</td>
<td>peasccai.pkh</td>
<td>create_ca_secondary_emp_asg, update_ca_emp_asg</td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>hr_ca_employee_api</td>
<td>peempcrai.pkh</td>
<td>create_ca_employee</td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>hr_cagr_grade_structures_api</td>
<td>pegrsapi.pkh</td>
<td>create_cagr_grade_structures, delete_cagr_grade_structures</td>
<td>No</td>
<td>WW</td>
</tr>
</tbody>
</table>

1 – 80 Configuring, Reporting and System Administration in Oracle HRMS
<table>
<thead>
<tr>
<th>Package Name</th>
<th>File Name</th>
<th>Business Process</th>
<th>Supported by Data Pump</th>
<th>Legislation</th>
</tr>
</thead>
<tbody>
<tr>
<td>hr_cagr_grades_api</td>
<td>pegraapi.phk</td>
<td>create_cagr_grades, delete_cagr_grades, update_cagr_grade_structures, update_cagr_grades</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_collective_agreement_api</td>
<td>hrcagapi.phk</td>
<td>create_collective_agreement, delete_collective_agreement, update_collective_agreement</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competence_element_api</td>
<td>pecelapi.phk</td>
<td>copy_competencies</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competence_element_api</td>
<td>pecelapi.phk</td>
<td>create_competence_element</td>
<td>Yes*</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competence_element_api</td>
<td>pecelapi.phk</td>
<td>delete_competence_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competence_element_api</td>
<td>pecelapi.phk</td>
<td>maintain_student_comp_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competence_element_api</td>
<td>pecelapi.phk</td>
<td>update_competence_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competence_element_api</td>
<td>pecelapi.phk</td>
<td>update_delivered_dates</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competence_element_api</td>
<td>pecelapi.phk</td>
<td>update_personal_comp_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competences_api</td>
<td>pecpnapi.phk</td>
<td>create_competence</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_competences_api</td>
<td>pecpnapi.phk</td>
<td>delete_competence</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_contact_api</td>
<td>peconapi.phk</td>
<td>create_person</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_contact_rel_api</td>
<td>pecrlapi.phk</td>
<td>create_contact</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_contact_rel_api</td>
<td>pecrlapi.phk</td>
<td>delete_contact_relationship</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_contact_rel_api</td>
<td>pecrlapi.phk</td>
<td>update_contact_relationship</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_contract_api</td>
<td>hrcctapi.phk</td>
<td>create_contract</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_contract_api</td>
<td>hrcctapi.phk</td>
<td>delete_contract</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_contract_api</td>
<td>hrcctapi.phk</td>
<td>update_contract</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_delivery_methods_api</td>
<td>pepdmapi.phk</td>
<td>create_delivery_method, delete_delivery_method, update_delivery_method</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_deployment_factor_api</td>
<td>pedpdfapi.phk</td>
<td>create_person_dpmt_factor, update_person_dpmt_factor, create_position_dpmt_factor, update_position_dpmt_factor, create_job_dpmt_factor, update_job_dpmt_factor</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_elec_candidate_api</td>
<td>peecaapi.phk</td>
<td>create_election_candidate, update_election_candidate, delete_election_candidate</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_elec_constituencies_api</td>
<td>peecoapi.phk</td>
<td>create_election_constituency, update_election_constituency, delete_election_constituency</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_elec_result_api</td>
<td>peersapi.phk</td>
<td>create_election_result, update_election_result</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>hr_elections_api</td>
<td>peelcapi.pkh</td>
<td>create_election_information, update_election_information, delete_election_information</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_employee_api</td>
<td>peempapi.pkh</td>
<td>create_employee</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_employee_api</td>
<td>peempapi.pkh</td>
<td>create_gb_employee</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_employee_api</td>
<td>peempapi.pkh</td>
<td>create_us_employee</td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>hr_employee_api</td>
<td>peempapi.pkh</td>
<td>hire_into_job</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_employee_api</td>
<td>peempapi.pkh</td>
<td>re_hire_ex_employee</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_employee_api</td>
<td>peempapi.pkh</td>
<td>hire_employee_applicant</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_employee_api</td>
<td>peempapi.pkh</td>
<td>hire_to_employee_applicant</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_ex_employee_api</td>
<td>peexeapi.pkh</td>
<td>actual_termination_emp</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_ex_employee_api</td>
<td>peexeapi.pkh</td>
<td>final_process_emp</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_ex_employee_api</td>
<td>peexeapi.pkh</td>
<td>update_term_details_emp</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_grade_api</td>
<td>pygrrapi.pkh</td>
<td>create_grade_rate_value</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_grade_api</td>
<td>pygrrapi.pkh</td>
<td>delete_grade_rate_value</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_grade_api</td>
<td>pygrrapi.pkh</td>
<td>update_grade_rate_value</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_hierarchy_element_api</td>
<td>peoseapi.pkh</td>
<td>create_hierarchy_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_hierarchy_element_api</td>
<td>peoseapi.pkh</td>
<td>delete_hierarchy_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_hierarchy_element_api</td>
<td>peoseapi.pkh</td>
<td>update_hierarchy_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_hk_applicant_api</td>
<td>hrhkwrzaa.pkh</td>
<td>create_hk_applicant</td>
<td>Yes</td>
<td>HK</td>
</tr>
<tr>
<td>hr_hk_assignment_api</td>
<td>hrhkwrzas.pkh</td>
<td>create_hk_secondary_emp_asg, update_hk_emp_asg</td>
<td>Yes</td>
<td>HK</td>
</tr>
<tr>
<td>hr_hk_employee_api</td>
<td>hrhkwrpe.pkh</td>
<td>create_hk_employee</td>
<td>Yes</td>
<td>HK</td>
</tr>
<tr>
<td>hr_hk_person_api</td>
<td>hrhkwrpe.pkh</td>
<td>update_hk_person</td>
<td>Yes</td>
<td>HK</td>
</tr>
<tr>
<td>hr_hk_personal_pay_method_api</td>
<td>hrhkwrpm.pkh</td>
<td>create_hk_personal_pay_method, update_hk_personal_pay_method</td>
<td>Yes</td>
<td>HK</td>
</tr>
<tr>
<td>hr_hk_person_address_api</td>
<td>hrhkwrpa.pkh</td>
<td>create_hk_person_address, update_hk_person_address</td>
<td>Yes</td>
<td>HK</td>
</tr>
<tr>
<td>hr_it_employee_api</td>
<td>hrempiti.pkh</td>
<td>create_it_employee</td>
<td>No</td>
<td>IT</td>
</tr>
<tr>
<td>hr_job_api</td>
<td>pejobapi.pkh</td>
<td>create_job</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_job_requirement_api</td>
<td>pejbrapi.pkh</td>
<td>create_job_requirement</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_jp_person_api</td>
<td>pejppapi.pkh</td>
<td>update_jp_person</td>
<td>No</td>
<td>JP</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>hr_jpbp_api</td>
<td>pejpapi.pkh</td>
<td>create_jp_appl_with_educ_add, create_jp_applicant_with_sit, create_jp_emp_with_educ_add, create_jp_employee_with_sit</td>
<td>No</td>
<td>JP</td>
</tr>
<tr>
<td>hr_location_api</td>
<td>hrlocapi.pkh</td>
<td>create_location</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_location_api</td>
<td>hrlocapi.pkh</td>
<td>delete_location</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_location_api</td>
<td>hrlocapi.pkh</td>
<td>update_location</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_location_extra_info_api</td>
<td>hrleapi.pkh</td>
<td>create_location_extra_info, delete_location_extra_info, update_location_extra_info</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_maintain_proposal_api</td>
<td>hrpypapi.pkh</td>
<td>approve_salary_proposal</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_maintain_proposal_api</td>
<td>hrpypapi.pkh</td>
<td>delete_proposal_component</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_maintain_proposal_api</td>
<td>hrpypapi.pkh</td>
<td>delete_salary_proposal</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_maintain_proposal_api</td>
<td>hrpypapi.pkh</td>
<td>insert_proposal_component</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_maintain_proposal_api</td>
<td>hrpypapi.pkh</td>
<td>insert_salary_proposal</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_maintain_proposal_api</td>
<td>hrpypapi.pkh</td>
<td>update_proposal_component</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_maintain_proposal_api</td>
<td>hrpypapi.pkh</td>
<td>update_salary_proposal</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_mass_move_api</td>
<td>pemmvapi.pkh</td>
<td>mass_move</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_nz_applicant_api</td>
<td>hrnzwrap.pkh</td>
<td>create_nz_applicant</td>
<td>Yes</td>
<td>NZ</td>
</tr>
<tr>
<td>hr_nz_assignment_api</td>
<td>hrnzwrea.pkh</td>
<td>create_nz_secondary_emp_asg, update_nz_emp_asg</td>
<td>Yes</td>
<td>NZ</td>
</tr>
<tr>
<td>hr_nz_employee_api</td>
<td>hrnzwree.pkh</td>
<td>create_nz_employee</td>
<td>Yes</td>
<td>NZ</td>
</tr>
<tr>
<td>hr_nz_person_address_api</td>
<td>hrnzwrpapi.pkh</td>
<td>create_nz_person_address, update_nz_person_address</td>
<td>Yes</td>
<td>NZ</td>
</tr>
<tr>
<td>hr_nz_person_api</td>
<td>hrnzwrup.pkh</td>
<td>update_nz_person</td>
<td>Yes</td>
<td>NZ</td>
</tr>
<tr>
<td>hr_nz_personal_pay_method_api</td>
<td>hrnzwrpp.pkh</td>
<td>create_nz_personal_pay_method, update_nz_personal_pay_method</td>
<td>Yes</td>
<td>NZ</td>
</tr>
<tr>
<td>hr_nz_tax_api</td>
<td>hrnzwrtx.pkh</td>
<td>maintain_tax_info</td>
<td>Yes</td>
<td>NZ</td>
</tr>
<tr>
<td>hr_objectives_api</td>
<td>peobjapi.pkh</td>
<td>create_objective, delete_objective, update_objective</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>hr_organization_api</td>
<td>bregapi.pkh</td>
<td>create_bgr_classif, create_business_group, create_legal_entity, create_oper_unit_classif, create_operating_unit, create_org_classification, create_org_information, create_organization, disable_org_classification, enable_org_classification, enable_operating_unit, update_org_information, update_organization</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_participants_api</td>
<td>parapi.pkh</td>
<td>create_participant</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_participants_api</td>
<td>parapi.pkh</td>
<td>update_participant</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_participants_api</td>
<td>parapi.pkh</td>
<td>delete_participant</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_pay_scale_api</td>
<td>pypsrapi.pkh</td>
<td>create_pay_scale_value</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_pay_scale_api</td>
<td>pypsrapi.pkh</td>
<td>delete_pay_scale_value</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_pay_scale_api</td>
<td>pypsrapi.pkh</td>
<td>update_pay_scale_value</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_perf_review_api</td>
<td>prrvapi.pkh</td>
<td>create_perf_review</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_perf_review_api</td>
<td>prrvapi.pkh</td>
<td>delete_perf_review</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_perf_review_api</td>
<td>prrvapi.pkh</td>
<td>update_perf_review</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_performance_ratings_api</td>
<td>prprtapi.pkh</td>
<td>create_performance_rating</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_performance_ratings_api</td>
<td>prprtapi.pkh</td>
<td>delete_performance_rating</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_performance_ratings_api</td>
<td>prprtapi.pkh</td>
<td>update_performance_rating</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_periods_of_service_api</td>
<td>pedsapi.pkh</td>
<td>update_pds_details</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_person_absence_api</td>
<td>peabsapi.pkh</td>
<td>create_person_absence</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_person_address_api</td>
<td>peaddapi.pkh</td>
<td>create_gb_person_address</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_person_address_api</td>
<td>peaddapi.pkh</td>
<td>create_person_address</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_person_address_api</td>
<td>peaddapi.pkh</td>
<td>create_us_person_address</td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>hr_person_address_api</td>
<td>peaddapi.pkh</td>
<td>update_gb_person_address</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_person_address_api</td>
<td>peaddapi.pkh</td>
<td>update_person_address</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_person_address_api</td>
<td>peaddapi.pkh</td>
<td>update_us_person_address</td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>hr_person_api</td>
<td>peperapi.pkh</td>
<td>update_gb_person</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_person_api</td>
<td>peperapi.pkh</td>
<td>update_person</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_person_api</td>
<td>peperapi.pkh</td>
<td>update_us_person</td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>--------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>hr_person_extra_info_api</td>
<td>peposapi.pkh</td>
<td>create_person_extra_info, delete_person_extra_info, update_person_extra_info</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_person_type_usage_api</td>
<td>peptaapi.pkh</td>
<td>create_person_type_usage, delete_person_type_usage, update_person_type_usage</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_personal_pay_method_api</td>
<td>pyppnapi.pkh</td>
<td>create_gb_personal_pay_method, create_personal_pay_method, delete_personal_pay_method, update_personal_pay_method</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_personal_pay_method_api</td>
<td>pyppnapi.pkh</td>
<td>create_us_personal_pay_method, delete_personal_pay_method</td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>hr_personal_pay_method_api</td>
<td>pyppnapi.pkh</td>
<td>create_gb_personal_pay_method, delete_personal_pay_method</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_personal_pay_method_api</td>
<td>pyppnapi.pkh</td>
<td>create_us_personal_pay_method, delete_personal_pay_method</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_personal_pay_method_api</td>
<td>pyppnapi.pkh</td>
<td>create_gb_personal_pay_method, delete_personal_pay_method</td>
<td>Yes</td>
<td>UK</td>
</tr>
<tr>
<td>hr_personal_pay_method_api</td>
<td>pyppnapi.pkh</td>
<td>create_us_personal_pay_method, delete_personal_pay_method</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_phone_api</td>
<td>pepnapi.pkh</td>
<td>create_phone, update_phone</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_phone_api</td>
<td>pepnapi.pkh</td>
<td>create_phone, delete_phone</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_pos_hierarchy_ele_api</td>
<td>pepseapi.pkh</td>
<td>create_pos_hierarchy_ele</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_pos_hierarchy_ele_api</td>
<td>pepseapi.pkh</td>
<td>create_pos_hierarchy_ele</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_pos_hierarchy_ele_api</td>
<td>pepseapi.pkh</td>
<td>create_pos_hierarchy_ele</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_position_api</td>
<td>peposapi.pkh</td>
<td>create_position, delete_position</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_position_api</td>
<td>peposapi.pkh</td>
<td>create_position, delete_position</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_position_extra_info_api</td>
<td>pepoiapi.pkh</td>
<td>create_position_extra_info, delete_position_extra_info, update_position_extra_info</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_position_requirement_api</td>
<td>peprrapi.pkh</td>
<td>create_position_requirement</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_rating_levels_api</td>
<td>pertlapi.pkh</td>
<td>create_rating_level, delete_rating_level</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_rating_levels_api</td>
<td>pertlapi.pkh</td>
<td>create_rating_level, delete_rating_level</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_rating_levels_api</td>
<td>pertlapi.pkh</td>
<td>update_rating_level</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_rating_scales_api</td>
<td>perscapi.pkh</td>
<td>create_rating_scale</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_rating_scales_api</td>
<td>perscapi.pkh</td>
<td>delete_rating_scale</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_rating_scales_api</td>
<td>perscapi.pkh</td>
<td>update_rating_scale</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_salary_survey_api</td>
<td>pepssapi.pkh</td>
<td>create_salary_survey, create_salary_survey_line, delete_salary_survey, update_salary_survey</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>---------------</td>
<td>-------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>hr_salary_survey_line_api</td>
<td>pesslapi.pkh</td>
<td>update_salary_survey_line</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_salary_survey_mapping_api</td>
<td>pessmapi.pkh</td>
<td>create_mapping, delete_mapping, mass_update, update_mapping</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_sg_applicant_api</td>
<td>hrsgwraa.pkh</td>
<td>create_sg_applicant</td>
<td>Yes</td>
<td>SG</td>
</tr>
<tr>
<td>hr_sg_assignment_api</td>
<td>hrsgwras.pkh</td>
<td>create_sg_secondary_emp_asg, update_sg_emp_asg</td>
<td>Yes</td>
<td>SG</td>
</tr>
<tr>
<td>hr_sg_employee_api</td>
<td>hrsgwree.pkh</td>
<td>create_sg_employee</td>
<td>Yes</td>
<td>SG</td>
</tr>
<tr>
<td>hr_sg_person_api</td>
<td>hrsgwrpe.pkh</td>
<td>update_sg_person</td>
<td>Yes</td>
<td>SG</td>
</tr>
<tr>
<td>hr_sg_personal_pay_method_api</td>
<td>hrsgwrpm.pkh</td>
<td>create_sg_personal_pay_method</td>
<td>Yes</td>
<td>SG</td>
</tr>
<tr>
<td>hr_sit_api</td>
<td>pestapi.pkh</td>
<td>create_sit</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_sit_api</td>
<td>pestapi.pkh</td>
<td>delete_sit</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_sit_api</td>
<td>pestapi.pkh</td>
<td>update_sit</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_std_hol_abs_api</td>
<td>peshaapi.pkh</td>
<td>create_std_hol_abs, delete_std_hol_abs, update_std_hol_abs</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_tcp_api</td>
<td>hrtcpapi.pkh</td>
<td>create_tcp, delete_tcp</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>hr_upload_proposal_api</td>
<td>hryppapi.pkh</td>
<td>upload_salary_proposal</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_user_acct_api</td>
<td>hrusrapi.pkh</td>
<td>create_user_acct, update_user_acct</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>hr_valid_grade_api</td>
<td>pevgrapi.pkh</td>
<td>create_valid_grade</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>pay_action_information_api</td>
<td>pyaifapi.pkh</td>
<td>create_action_information, delete_action_information, update_action_information</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_balance_adjustment_api</td>
<td>pybadapi.pkh</td>
<td>create_adjustment</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_balance_adjustment_api</td>
<td>pybadapi.pkh</td>
<td>create_tax_balance_adjustment</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>pay_balance_adjustment_api</td>
<td>pybadapi.pkh</td>
<td>delete_adjustment</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_batch_element_entry_api</td>
<td>pybthapi.pkh</td>
<td>create_batch_header, create_batch_line, create_batch_total, update_batch_header, update_batch_line, delete_batch_header, delete_batch_line, delete_batch_total</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_ca_emp_fedtax_inf_api</td>
<td>pycatapi.pkh</td>
<td>create_ca_emp_fedtax_inf, update_ca_emp_fedtax_inf, delete_ca_emp_fedtax_inf</td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>pay_ca_emp_prvtax_inf_api</td>
<td>pycprapi.pkh</td>
<td>create_ca_emp_prvtax_inf, update_ca_emp_prvtax_inf, delete_ca_emp_prvtax_inf</td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>pay_ca_person_address_api</td>
<td>pwaddcai.pkh</td>
<td>create_ca_person_address, update_ca_person_address</td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>--------------</td>
<td>------------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>pay_city_tax_rule_api</td>
<td>pyctyapi.pkh</td>
<td><code>create_city_tax_rule</code>, <code>update_city_tax_rule</code></td>
<td>No</td>
<td>US</td>
</tr>
<tr>
<td>pay_contribution_history_api</td>
<td>pyconapi.pkh</td>
<td><code>create_contribution_history</code>, <code>delete_contribution_history</code>, <code>update_contribution_history</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_county_tax_rule_api</td>
<td>pycntapi.pkh</td>
<td><code>create_county_tax_rule</code>, <code>update_county_tax_rule</code></td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>pay_datetracked_events_api</td>
<td>pydteapi.pkh</td>
<td><code>create_datetracked_event</code>, <code>delete_datetracked_event</code>, <code>update_datetracked_event</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_element_extra_info_api</td>
<td>pyeeiapi.pkh</td>
<td><code>create_element_extra_info</code>, <code>delete_element_extra_info</code>, <code>update_element_extra_info</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_event_groups_api</td>
<td>pyevgapi.pkh</td>
<td><code>create_event_group</code>, <code>delete_event_group</code>, <code>update_event_group</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_event_procedures_api</td>
<td>pyevpapi.pkh</td>
<td><code>create_event_proc</code>, <code>delete_event_proc</code>, <code>update_event_proc</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_event_updates_api</td>
<td>pyevuapi.pkh</td>
<td><code>create_event_update</code>, <code>delete_event_update</code>, <code>update_event_update</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_federal_tax_rule_api</td>
<td>pyfedapi.pkh</td>
<td><code>update_fed_tax_rule</code></td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>pay_nrc_api</td>
<td>pyncrapi.pkh</td>
<td><code>create_pay_net_calc_rule</code>, <code>delete_pay_net_calc_rule</code>, <code>update_pay_net_calc_rule</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_org_payment_method_api</td>
<td>pyopmapi.pkh</td>
<td><code>create_org_payment_method</code>, <code>delete_org_payment_method</code>, <code>update_org_payment_method</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_pap_api</td>
<td>pypapapi.pkh</td>
<td><code>create_pay_accrual_plan</code>, <code>delete_pay_accrual_plan</code>, <code>update_pay_accrual_plan</code></td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pay_pmed_accounts_api</td>
<td>pypmaapi.pkh</td>
<td><code>create_pmed_accounts</code>, <code>delete_pmed_accounts</code>, <code>update_pmed_accounts</code></td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>pay_state_tax_rule_api</td>
<td>pystaapi.pkh</td>
<td><code>create_state_tax_rule</code>, <code>update_state_tax_rule</code></td>
<td>Yes</td>
<td>US</td>
</tr>
<tr>
<td>pay_us_tax_api</td>
<td>pytaxapi.pkh</td>
<td><code>delete_tax_rule</code></td>
<td>No</td>
<td>US</td>
</tr>
<tr>
<td>pay_wci_accounts_api</td>
<td>pypwcaapi.pkh</td>
<td><code>create_wci_accounts</code>, <code>update_wci_accounts</code>, <code>delete_wci_accounts</code></td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>pay_wci_occupations_api</td>
<td>pypwoapi.pkh</td>
<td><code>create_wci_occupation</code>, <code>update_wci_occupation</code>, <code>delete_wci_occupation</code></td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>pay_wci_rates_api</td>
<td>pypwzapi.pkh</td>
<td><code>create_wci_rate</code>, <code>update_wci_rate</code>, <code>delete_wci_rate</code></td>
<td>No</td>
<td>CA</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------------------------------------------</td>
<td>--------------------</td>
<td>-------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>per_bf_balance_amounts_api</td>
<td>pebbapi.pkh</td>
<td>create_balance_amount, delete_balance_amount, update_balance_amount</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_bf_balance_types_api</td>
<td>pebbtapi.pkh</td>
<td>create_balance_type, delete_balance_type, update_balance_type</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_bf_payment_details_api</td>
<td>pebpdapi.pkh</td>
<td>create_payment_detail, delete_payment_detail, update_payment_detail</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_bf_payroll_runs_api</td>
<td>pebprapi.pkh</td>
<td>create_payroll_run</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>per_bf_payroll_runs_api</td>
<td>pebprapi.pkh</td>
<td>delete_payroll_run, update_payroll_run</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_cancel_application_api</td>
<td>pecapapi.pkh</td>
<td>cancel an applicant record</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_checklist_items_api</td>
<td>pechkapi.pkh</td>
<td>create_checklist_items, update_checklist_items, delete_checklist_items</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_disability_api</td>
<td>pedisapi.pkh</td>
<td>create_disability, update_disability, delete_disability</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_hierarchy_api</td>
<td>pepghapi.pkh</td>
<td>create_hierarchy, update_hierarchy, delete_hierarchy</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_hierarchy_nodes_api</td>
<td>pepgnapi.pkh</td>
<td>create_hierarchy_nodes, update_hierarchy_nodes, delete_hierarchy_nodes</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_hierarchy_versions_api</td>
<td>pepgvapi.pkh</td>
<td>create_hierarchy_versions, update_hierarchy_versions, delete_hierarchy_versions</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_job_extra_info_api</td>
<td>pejeiapi.pkh</td>
<td>create_job_extra_info, delete_job_extra_info, update_job_extra_info</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_job_group_api</td>
<td>pejgrapi.pkh</td>
<td>create_job_group</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>per_job_group_api</td>
<td>pejgrapi.pkh</td>
<td>delete_job_group</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_job_group_api</td>
<td>pejgrapi.pkh</td>
<td>update_job_group</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>per_medical_assessment_api</td>
<td>pemaeapi.pkh</td>
<td>create_medical_assessment, update_medical_assessment, delete_medical_assessment</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_shared_types_api</td>
<td>peshtapi.pkh</td>
<td>create_shared_types</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_shared_types_api</td>
<td>peshtapi.pkh</td>
<td>delete_shared_types</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_shared_types_api</td>
<td>peshtapi.pkh</td>
<td>update_shared_types</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_supplementary_role_api</td>
<td>perolapi.pkh</td>
<td>create_supplementary_role</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>per_supplementary_role_api</td>
<td>perolapi.pkh</td>
<td>delete_supplementary_role</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>per_supplementary_role_api</td>
<td>perolapi.pkh</td>
<td>update_supplementary_role</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>-------------</td>
<td>-------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>per_work_incident_api</td>
<td>perincapi.pkh</td>
<td>create_work_incident, update_work_incident, delete_work_incident</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_attribute_ranges_api</td>
<td>pqrngapi.pkh</td>
<td>create_attribute_range, update_attribute_range, delete_attribute_range</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_cmmtmnt_elements_api</td>
<td>pqhcapi.pkh</td>
<td>create_bdgt_cmmtmnt_elmnt, update_bdgt_cmmtmnt_elmnt, delete_bdgt_cmmtmnt_elmnt</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_pool_reallocations_api</td>
<td>pqhbpapi.pkh</td>
<td>create_bdgt_pool_reallocation, update_bdgt_pool_reallocation, delete_bdgt_pool_reallocation</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_details_api</td>
<td>pqhbdapi.pkh</td>
<td>create_budget_detail, update_budget_detail, delete_budget_detail</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_elements_api</td>
<td>pqhbelapi.pkh</td>
<td>create_budget_element, update_budget_element, delete_budget_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_fund_srcs_api</td>
<td>pqhbfapi.pkh</td>
<td>create_budget_fund_src, update_budget_fund_src, delete_budget_fund_src</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_gl_flex_maps_api</td>
<td>pqhbgapi.pkh</td>
<td>create_budget_gl_flex_map, update_budget_gl_flex_map, delete_budget_gl_flex_map</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_periods_api</td>
<td>pqhbapi.pkh</td>
<td>create_budget_period, update_budget_period, delete_budget_period</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_pools_api</td>
<td>pqhbpapi.pkh</td>
<td>create_budget_pool, update_budget_pool, delete_budget_pool</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_sets_api</td>
<td>pqhbsapi.pkh</td>
<td>create_budget_set, update_budget_set, delete_budget_set</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budget_versions_api</td>
<td>pqhbrapi.pkh</td>
<td>create_budget_version, update_budget_version, delete_budget_version</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_budgets_api</td>
<td>pqhgtapi.pkh</td>
<td>create_budget, update_budget, delete_budget</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_dflt_budget_elements_api</td>
<td>pqhdelapi.pkh</td>
<td>create_dflt_budget_element, update_dflt_budget_element, delete_dflt_budget_element</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_dflt_budget_sets_api</td>
<td>pqhdsapi.pkh</td>
<td>create_dflt_budget_set, update_dflt_budget_set, delete_dflt_budget_set</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_dflt_fund_srcs_api</td>
<td>pqhdfsapi.pkh</td>
<td>create_dflt_fund_src, update_dflt_fund_src, delete_dflt_fund_src</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_ref_templates_api</td>
<td>pqhrtapi.pkh</td>
<td>create_ref_template, update_ref_template, delete_ref_template</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>Package Name</td>
<td>File Name</td>
<td>Business Process</td>
<td>Supported by Data Pump</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>----------------</td>
<td>----------------------------------------------------------------------------------</td>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>pqh_role_templates_api</td>
<td>pqrtmplapi.pkh</td>
<td>create_role_template, update_role_template, delete_role_template</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_roles_api</td>
<td>pqrslapi.pkh</td>
<td>create_role, update_role, delete_role</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_routing_categories_api</td>
<td>pqrctapi.pkh</td>
<td>create_routing_category, update_routing_category, delete_routing_category</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_routing_list_members_api</td>
<td>pqrltapi.pkh</td>
<td>create_routing_list_member, update_routing_list_member, delete_routing_list_member</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_routing_lists_api</td>
<td>pqraltapi.pkh</td>
<td>create_routing_list, update_routing_list, delete_routing_list</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_rule_sets_api</td>
<td>pqrstapi.pkh</td>
<td>create_rule_set, update_rule_set, delete_rule_set</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_template_attributes_api</td>
<td>pqtatapi.pkh</td>
<td>create_template_attribute, update_template_attribute, delete_template_attribute</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_templates_api</td>
<td>pqtemapi.pkh</td>
<td>create_generic_template, update_generic_template, delete_generic_template</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_tran_category_api</td>
<td>pqtctapi.pkh</td>
<td>update_tran_category</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqh_tran_cat_attributes_api</td>
<td>pqtcatapi.pkh</td>
<td>update_tran_cat_attribute</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqp_sat_api</td>
<td>pqsatapi.pkh</td>
<td>create_assignment_attribute, delete_assignment_attribute, update_assignment_attribute</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqp_shp_api</td>
<td>pqshpapi.pkh</td>
<td>create_service_history_period, delete_service_history_period, update_service_history_period</td>
<td>No</td>
<td>WW</td>
</tr>
<tr>
<td>pqp_vehicle_details_api</td>
<td>pqpvdapi.pkh</td>
<td>create_vehicle_details, delete_vehicle_details, update_vehicle_details</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>py_element_entry_api</td>
<td>pyeleapi.pkh</td>
<td>create_element_entry</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>py_element_entry_api</td>
<td>pyeleapi.pkh</td>
<td>delete_element_entry</td>
<td>Yes</td>
<td>WW</td>
</tr>
<tr>
<td>py_element_entry_api</td>
<td>pyeleapi.pkh</td>
<td>update_element_entry</td>
<td>Yes</td>
<td>WW</td>
</tr>
</tbody>
</table>

*CREATE_COMPETENCE_ELEMENT* is supported by Data Pump only when the type = COMPETENCE_USAGE; that is, when categorizing competences under the relevant competence categories.

**Key to Localization Codes**

- AU – Australia
- BE – Belgium

1 – 90 Configuring, Reporting and System Administration in Oracle HRMS
• CA – Canada
• FD – US Federal
• FR – France
• HK – Hong Kong
• IE – Ireland
• IT – Italy
• JP – Japan
• NL – Netherlands
• NZ – New Zealand
• SG – Singapore
• UK – United Kingdom
• US – United States
• WW – All Legislations
CHAPTER 2

Configuring Oracle HRMS
Configuring Oracle HRMS

You can configure Oracle HRMS by designing windows to match your specific business processes. You can also link windows together to form any number of task flows required by your users. Configuring windows and task flows enables your users to perform their tasks more efficiently.

Can you configure windows to match the business needs of your enterprise?

Yes. For the core employee management information you can use the Forms Configurator tool to design your own windows to match the tasks performed in your enterprise. A set of predefined templates are provided as examples of how you can design new windows.

Can you link windows together?

Yes. Oracle recognizes that to complete many tasks, you need to use more than one window. You can link these windows together in a task flow so that you can choose a button to bring up each window in turn without returning to the menu.

How is security affected by configuring windows?

Any windows that you configure behave in the same way as existing windows. Security is set by the user’s security profile option and responsibility. However, you can configure the Find results window to enable users to see information for people outside of their security profile. They cannot change this information.

In addition, you can create windows that:

- Restrict the list of values on certain fields or limit access to certain types of information
- Use workflow so that any data changes must be approved before the changes are applied to the database. This applies to the windows that are based on templates.

Can you restrict the amount of data that users have to enter?

Yes. If you design windows using the templates, they offer greater flexibility for defaulting values in fields. You can also hide fields where you require no input from users, and you can restrict the list of values on other fields that are displayed in the windows.
What happens to the online help when you design new windows?

Online help is provided for the windows that have been created using the predefined templates. If you make changes to the windows or create new windows, you can edit the online help to make it match the new way of performing the tasks.

Can you define the formats for currency?

Yes. You can define the formats for displaying currency amounts.
Configuring Oracle HRMS Overview

There are many ways you can configure Oracle HRMS to meet the needs of your business processes:

- Linking windows together in a task flow
- Designing your own windows
- Restricting data access on windows

You can configure Oracle HRMS using one or any combination of these.

Before configuring any part of Oracle HRMS, it is advisable to plan ahead and decide which parts of the system you want to configure. For example, if you know that your users typically perform a task in a certain way, you can design windows to help them enter information more efficiently. You can also link windows together to help users move from one window to the next. If necessary, you can also restrict what information appears in lists of values and restrict access to certain types of information.

Key Concepts

This section describes some of the key concepts required to enable you to configure Oracle HRMS for your enterprise.

Task Flow

You often need to use more than one window to complete many tasks. For example, to hire an employee, you typically go from the People window, to the Address window, to the Special Information window, to the Assignment window, and so on. You can link these windows together using a task flow so that users can choose a button to bring up each window in turn without returning to the menu.


Restricting Information

You can restrict the data available on certain windows. For example, you could restrict the information on a People Management template to applicants only or employees only.

Restricting the type of information available on a window might also be a security measure. For example, you can create versions of some windows that display compensation and benefits information to restrict the types of compensation that can be viewed.
You can restrict information to applicants only or employees only on People Management templates using Forms Configurator. See Forms Configurator: page 2 – 43.

You can restrict data using a wider range of criteria on the People Management form and a number of other forms using CustomForm. See: Windows You Can Configure Using CustomForm: 2 – 34.

**Configuration Template Forms**

You can design forms to match the business processes of your enterprise to enable users to perform their tasks quickly and efficiently. Predefined templates are provided for you to use as a guideline when designing forms for the core People Management processes in your enterprise.

A template form can consist of up to three separate windows:

- **A Find window** to enable queries to be performed
- **A Summary window** to display people and assignment information
- **A Maintenance window** to enable the entry and update of information

You can design the new windows to complete a whole process such as hiring an applicant. For example, users can use the Maintenance window to enter and maintain an applicant’s details and the Find window to find groups of applicants to work with. You add the new template forms to the menu so that users can access them from the navigator in the same way as all the other windows.

See: People Management Templates: page 2 – 45

You configure the predefined templates to create your own windows using the Forms Configurator tool.

See: Forms Configurator: page 2 – 43.

**Transaction Templates**

Transaction templates serve as filters that overlay a window. They make it easier for you to accomplish tasks by displaying only the information required for the task that is appropriate for your workflow role.

**Note:** In this release, templates are used only for position transactions.
The predefined transaction templates include task templates and a workflow role template. Task templates set view and edit attributes based on the attributes required to accomplish a specific task. Workflow templates set the attributes based on the level of access your role permits.

The predefined templates have the maximum permissions set for task and role templates. If your organization needs to restrict the fields that users can view and edit, you can define new templates by copying the existing ones and changing the attribute settings.

See: Transaction Templates: page 2–95

WorkFlow

Users of the People Management template forms can use WorkFlow to notify other users of changes or actions required. Some notification messages are predefined, and you can create others using Oracle WorkFlow.

See: Notification Messages Issued From Template Forms: page 2–57.

You can also use Oracle WorkFlow to create and maintain task flows.

See: Task Flow (Workflow): page 2–21

Users of the position transactions and budget worksheets use Oracle WorkFlow to route transactions for data entry, review, and approval.

When setting up workflow for transactions, you can decide which type of routing to use for routing position transactions and budget worksheets. You can base routing on user-defined routing lists, position hierarchies, or supervisory hierarchies. The approval mechanism gives you control over who authorizes transactions and under what circumstances. You restrict which users process transactions by defining routing and authorization rules.

When routing a transaction, you can decide whom to notify when a specific event occurs, such as the successful update to the database. You can also expedite routing by skipping people in the routing sequence, or by sending the transaction directly to an override approver.

To ensure that transactions are processed in a timely manner, you can set timeouts that return a notification to the sender if there is no response when the timeout interval elapses.

See: Workflow for Position Management: page 2–100

Currencies

You will also need to define the formats for displaying currency amounts.
Task Flow

You can link windows used to complete tasks in a task flow. Then, you can choose a button to bring up each window in turn without returning to the menu.

The first window in the task flow defines the context of the subsequent windows. For example, if the task flow begins with the People window, all subsequent information is entered for the person you enter or query in the People window.

You can include configured windows in task flows. For example, you might create a version of the People window that handles applicants only. You could then use this window in a recruitment task flow. Or you might configure a People Management template and add task flow buttons to provide access to other windows.

Using Forms or Workflow

There are two methods you can use to create and maintain your task flows:

- Using Forms: page 2 – 14
- Using Oracle Workflow: page 2 – 21

You can model your task flows using Oracle Workflow (version 2.0.3.8.1 or higher) then generate a task flow. This method of creating task flows has the advantage of using a diagrammer to help you design the sequence of windows.

⚠️ Warning: Do not use apostrophes or "%" symbols in task flow names or task flow node names.

Sequential or Branched Structure

Task flows can follow a sequential or a branched structure, as shown in the following two figures. You can choose how many navigation options users have from each window in the task flow. You can also choose the labels that appear on the navigation buttons, and you can define access keys.
Predefined Task Flows

Oracle HRMS supplies several predefined task flows that include all the windows that you can use in task flows. They are designed as a simple structure to use during implementation, not as a recommended structure for users.

Predefined task flows are translated into your base language when you install Oracle HRMS. However, if you install an additional language, you need to create new versions of your task flows in that language. You can then link these to the correct menu for the language.
When you install a new version of Oracle HRMS, any changes you have made to the standard task flows supplied by Oracle are removed.

**Attention:** If you have made any changes to standard task flows, you will need to recreate them in each new version of the software. It is therefore recommended that if you wish to make changes to task flows, you do so by copying a standard task flow and making changes to the copy.

**Transferring Task Flows Between Databases**

You can transfer a task flow you have created using Forms or Workflow from one database to another; for example, to add new task flows you have created in a test database into your production database. You do this by saving the task flow from the first database to a file, then importing the file to the second database. See Transferring Task Flows: page 2 – 33.

**Legislation-specific Task Flows**

When installing Oracle HRMS, you can install only global task flows and task flows specific to the legislation you have installed.

**Note:** This does not include US- and UK-specific task flows, which are installed with all legislations.

When defining a new task flow, you must specify that the task flow is global or that it is specific to a legislation you have installed.

See Defining Task Flows: page 2 – 16

**Note:** Task flows created by converting from Oracle Workflow are always global.

When downloading task flows, you can download only global task flows and task flows specific to the legislation(s) you have installed.

See Transferring Task Flows Between Databases: page 2 – 33
Task Flow Windows

You can create your own task flows by referencing the windows listed in the table below, or configured versions of them. Some of these windows require the context of an assignment. This means that one of the following windows must appear above them in the task flow:

- Assignment window
- Assignments Folder window
- Application window (for applicant assignments)
- a People Management template window that identifies assignments

All task flows must begin with one of the following windows:

- A Maintenance window created from a People Management template
- People and Assignment (PERWSHRG)
- People (PERWSEPI)
- People Folder (PERWSFPE)
- Assignments Folder (PERWSFAS)
- Assignment (PERWSEMA)
- Job (PERWSDJT)
- Position (HRWSPOS)
- Position (non HRMS users) (PERWSDPO)
- Location (PERWSLOC)
- Tax Balance (PAYUSTBA)

**Note:** If you are not using People Management templates, use the combined People and Assignment form (PERWSHRG), rather than the separate forms (PERWSEPI and PERWSEMA), to allow the Assignment window to open more quickly from the People window. We recommend that you use the combined form in any task flow that requires both windows. The predefined task flows use the combined form.

### Windows You Can Use in Task Flows

<table>
<thead>
<tr>
<th>Window</th>
<th>Context Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absence Detail</td>
<td>Person (employee)</td>
</tr>
<tr>
<td>Address</td>
<td>Person</td>
</tr>
<tr>
<td>Window</td>
<td>Context Required</td>
</tr>
<tr>
<td>-------------------------------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>Adjust Balances (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Applicant Interview</td>
<td>Assignment (applicant)</td>
</tr>
<tr>
<td>Application</td>
<td>Person (applicant)</td>
</tr>
<tr>
<td>Assignment</td>
<td>Person (employee)</td>
</tr>
<tr>
<td>Assignment Budget Values</td>
<td>Assignment</td>
</tr>
<tr>
<td>Assignments Folder</td>
<td>None</td>
</tr>
<tr>
<td>Belgian Tax Information (Belgian legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Beneficiaries (US legislation only)</td>
<td>Element entry</td>
</tr>
<tr>
<td>Book Events</td>
<td>Person (employee or applicant)</td>
</tr>
<tr>
<td>COBRA (US legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Competence Profile</td>
<td>Person</td>
</tr>
<tr>
<td>Contact</td>
<td>Person</td>
</tr>
<tr>
<td>Contract</td>
<td>Person</td>
</tr>
<tr>
<td>Costing</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Covered Dependents (US legislation only)</td>
<td>Element entry</td>
</tr>
<tr>
<td>Disability (global and selected legislations)</td>
<td>Person</td>
</tr>
<tr>
<td>Element Entries</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Employee Review</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Employee Tax Rules (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Employment Declaration (Australian legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>External/Manual Payments (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Extra Assignment Information</td>
<td>Assignment (employee or applicant)</td>
</tr>
<tr>
<td>Extra Job Information</td>
<td>Job</td>
</tr>
<tr>
<td>Extra Location Information</td>
<td>Location</td>
</tr>
<tr>
<td>Extra Person Information</td>
<td>Person (employee or applicant)</td>
</tr>
<tr>
<td>Window</td>
<td>Context Required</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Extra Position Information</td>
<td>Position</td>
</tr>
<tr>
<td>Grade Step Placement</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Medical Assessment (global and selected legislations)</td>
<td>Person</td>
</tr>
<tr>
<td>P45 (UK Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>People Folder</td>
<td>None</td>
</tr>
<tr>
<td>People</td>
<td>None</td>
</tr>
<tr>
<td>People Management template Maintenance window</td>
<td>None</td>
</tr>
<tr>
<td>Performance</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Personal Payment Method</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Phone Numbers</td>
<td>Person</td>
</tr>
<tr>
<td>Picture</td>
<td>Person</td>
</tr>
<tr>
<td>Position</td>
<td>None</td>
</tr>
<tr>
<td>Position Occupancy</td>
<td>Position</td>
</tr>
<tr>
<td>Qualifications</td>
<td>Person</td>
</tr>
<tr>
<td>QuickPay (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Reverse Payroll Run (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Salary Administration</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Salary History</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Schools and Colleges (Establishment Attendances)</td>
<td>Person</td>
</tr>
<tr>
<td>Secondary Statuses</td>
<td>Assignment</td>
</tr>
<tr>
<td>SOE Report (UK Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Special Information</td>
<td>Person</td>
</tr>
<tr>
<td>Statement of Earnings (Australian and New Zealand legislations)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Statutory Details (UK Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Terminate</td>
<td>Person (employee)</td>
</tr>
<tr>
<td>Window</td>
<td>Context Required</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Terminate Applicant</td>
<td>Person (applicant)</td>
</tr>
<tr>
<td>View Element Entry History</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View Employee Accruals (US legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View Employee Benefits (US legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View Employee Earnings &amp; Deduction Balances (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View Employee Tax Balances (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View SOE (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Work Choices (Job or Position)</td>
<td>Job or Position</td>
</tr>
<tr>
<td>Work Choices (Person)</td>
<td>Person</td>
</tr>
<tr>
<td>Work Incident (global and selected legislations)</td>
<td>Person</td>
</tr>
</tbody>
</table>

**Including the Assignment Window**

When users move down a task flow from the combined People and Assignment form, the Assignment window remains visible in the background. They can return to the Assignment window by closing their current window. Therefore you should not define a button to call the Assignment window.

However, if you are defining a task flow to the Assignment window from any window except the People window, you should use the Assignment form (PERWSEMA). In this case you can add an Assignment button to any forms below the Assignment window in the task flow. This enables users to return to the Assignment window without going back to the top window.
Creating Task Flows Using Forms

Complete the following steps to create task flows using forms:

1. Define Task Flow Nodes: page 2 – 15
2. Define Task Flows: page 2 – 16

You can also complete these optional steps, if required:

3. Copy an Existing Task Flow: page 2 – 18
4. Add a New Window to an Existing Task Flow: page 2 – 19
5. Amend the Navigation of a Task Flow: page 2 – 20
Defining Task Flow Nodes

Each form in a task flow is a node. There are predefined nodes for every form that you can include in a task flow. However, if you create a configured version of one of these forms, you must create a node for the configured version before you can include it in a task flow.

**Suggestion:** If you want to use a configured form as the first node in a task flow you should define this as a new node.

You could add both the task flow and the configured form as arguments to a single menu function but this may be more difficult to maintain.

You create nodes in the Define Task Flow Nodes window.

► **To create a task flow node:**

1. Enter a name for the node. You select this name when you create a task flow containing the node. It is not visible to users.

   **Warning:** Do not use apostrophes or "%

   symbols in the node name.

2. Select the name of the form that you configured. Leave the Block field blank.

3. Select the name of the configured version of the form that you created.

4. Save the new node.
Defining Task Flows

You define task flows in the Define Task Flow window. If there is a similar existing task flow, you can copy it to form the basis of your new flow.

**Suggestion:** When defining the navigation buttons in your task flows:
- Do not define long sequences where you cannot go back to the previous step
- Use the same button names for the same nodes
- Use different button names for configured nodes

Before you can include the task flow in a menu, you must define a new menu function for the first form in the task flow with the following argument in the Parameters field:

WORKFLOW_NAME = "task flow name"

**To define a new task flow:**

1. Enter a name for the task flow and save it.

   **Warning:** Do not use apostrophes or "%" symbols in task flow names.

   **Note:** Do not choose the Convert button. This is provided only for converting task flows you created in Oracle Workflow. See Creating Task Flows Using Workflow: page 2 – 23.

2. Select a legislation for the task flow from the list of values, or leave the legislation field blank to create a global task flow.

3. In the Node block, select the name of the node that you want to be the first form in the task flow.

4. For this node, select the Top Node check box.

5. Create a new record in the Node block and select another node. You must create all the nodes for the task flow before you can begin entering the navigation paths between them.

6. In the Navigation Options region, for each node, select the other nodes to which you can navigate.

7. Enter a sequence number to determine the order in which the navigation options appear as buttons (from left to right) along the base of the window or as options in a navigation list.

8. Select the Button check box for the navigation options that should appear as buttons. There is a limit on the number of buttons that can appear on each form. This number varies from form to form.
The other options are displayed in a navigation list when the user chooses a button labelled Others. Or, if there is only one other option, this form displays when the user chooses a button labelled Next.

9. There is a default label that appears on buttons or in the navigation list for every form. You can override this with your own label. If the label in the Define Taskflow window appears blue, this is the default value. It is a dynamic default: if the seeded value changes (for example, as the result of an upgrade), the label will be updated automatically in all task flows where it has not been overridden.

If the label appears black, the default value has been overridden. To re-inherit the default label, clear the field.

10. To define an access key (or keyboard shortcut) for a navigation option, precede the appropriate letter in the label with an ampersand (&). For example, to use ALT+P (in the Microsoft Windows environment) as the access key for the Picture window, enter the label &Picture.

Note: Do not use the following letters, as they are used on the Oracle Applications menu: A, E, F, G, H, Q, S, W.

There is no validation to prevent the same letter being used more than once for a group of buttons.

11. Save the task flow.
Copying an Existing Task Flow

To copy an existing task flow:

1. Query the existing flow and choose the Copy To button.
2. Enter the name of the new task flow and choose OK.
3. Query your new task flow and edit it as required.
Adding a New Window to an Existing Task Flow

You can use the Define Task Flow window to add a new window, using its node name, to an existing task flow. If you have already used the window in the task flow you only have to amend the navigation, see: Amending the Navigation of a Task Flow: page 2 – 20

Note: If you have created a task flow using Oracle Workflow, you must continue to maintain it using Oracle Workflow. You cannot edit a generated task flow using the Define Task Flow window.

To add a new window to an existing task flow

1. Query the task flow you want to amend in the Name field.
2. In the Node block, enter the window’s node name.
3. Save your changes.
   You must now include the node in the navigation path for the task flow.
4. Select the existing node you want the new node to be accessed from in the Node block.
5. Enter the new node’s details in the Navigation Options region and edit the existing navigation path as required. For information about how to set up the Navigation Options region refer to steps 5 to 9 in “To define a new task flow”: page 2 – 16.
Amending the Navigation of a Task Flow

Use the Define Task Flow window to amend the navigation of a task flow.

To amend the navigation of a task flow:

1. Query the task flow for which you want to amend the navigation in the Name field.
2. Select the node name in the Node block.
3. Edit the existing navigation path in the Navigation Options region, as required. For information on the Navigation Options refer to steps 5 to 9 in To define a new task flow: page 2 – 16.
Task Flow (Oracle Workflow)

As an alternative to using forms to set up and maintain task flows, you can model your task flows using Oracle Workflow (version 2.0.3.8.1 or higher) then generate a task flow. This method of creating task flows has the advantage of using a diagrammer to help you design the sequence of windows.

Note: When you create a task flow using Oracle Workflow, you must continue to maintain it using Oracle Workflow. You cannot edit a generated task flow using the Define Task Flow form.

Oracle HRMS supplies the HR Task Flow item type and a function activity for every window that can be task flowed. You model these into a workflow process for each task flow. By setting activity attributes, you create button labels and the position of buttons on each window.

Key Rules

There are two key rules in defining task flows:

- Only certain windows are valid first windows (or top nodes) in a task flow. To check which windows are valid first windows, check the lookup types using Oracle Workflow Designer.
  
  When you create a workflow process to model your task flow, your Start activity must connect to the Top Node Selector activity. This activity ensures that your first window is valid.

- Each window in a task flow can only be connected to a window that supplies the correct context.
  
  For example, the Position Occupancy window requires the context of a position, while the Qualifications window requires the context of a person. Each workflow activity supplied for a window has its Result Type set to a lookup type that defines the context that must be passed to it. For example, the F4 Enter Address window has the Result Type set to Person Context Windows. This means it must be given the context of a person.

Task flows are associated with one of the following contexts:

- Assignment
- Element Entry
- Job
- Location
- PA Request (Govt HR)
- People
- Position Description (Govt HR)
- Position
- Top node HRMS windows
Creating Task Flows Using Workflow

Complete the following steps to create task flows using Oracle Workflow:

1. Create a Top Level Process: page 2 – 24
2. Create Sub Processes: page 2 – 26
3. Create Button Labels: page 2 – 27

Combined People and Assignment Form Only

If you are creating task flows using the combined People and Assignment form, you have an additional step to perform:

5. Identify Windows or Blocks to Display: page 2 – 29

Configured Versions of Forms Only

If you have created a configured version of a form, you have an additional step to perform:

6. Identify Configured Forms to Include in the Task Flow: page 2 – 30

All Forms

7. Verify and Save the Workflow: page 2 – 31
8. Generate a Task Flow From Oracle Workflow: page 2 – 32
Creating a Top Level Process

You must define a top level process for each task flow. The top level process can contain sub processes, but not any other top level processes.

A top level process must have a Top Node Selector activity. This ensures that the first window in a task flow is a valid top node window. All windows that can be a top node are defined within the Top Node HRMS Context Windows lookup type.

The Top Node Selector must have two transitions. The first transition must go to the Top Node activity and its value must be the window activity name. The second transition must be <Default> and go to the end activity.

You use the Process Diagrammers within Oracle Workflow to create your task flows. You do this by adding and connecting the windows you want to appear.

To create a top level process:

1. Enter a unique internal and display name for the new process for the HR Task flow item type.
   
   **Suggestion:** Use a naming convention for Internal and Display names. For example, a good internal name might be POSITION_DETAILS_TL with a Display name of Position Details (Top Level).

2. Define the process as runnable.

3. Open the Process Diagrammer window and add one Start activity and at least one End activity.


5. Connect the Top Node Selector to the End activity with a <Default> transition result value.

6. Add the Top Node window.

7. Connect the Top Node Selector to the Top Node window, specifying the name of this window activity as the transition result value.

8. Connect the Top Node window to the End Activity with a <Default> transition result value.

9. Add other windows to the process, noting the following rules:
   
   - A window can only connect to another window where the result type is the same (such as, both Person Context windows).
• The transition result value must be the name of the window activity you are connecting to (for example, F4 Enter Assignment).

• Each window can only connect once to any other window.

• Each window must be connected to the Top Node window with a <Default> transition result value.

• You can connect a window back to its parent using the <Parent> transition result value, rather than the name of the parent window.
Creating Sub Processes

You can group a logical set of task flow windows into a sub process, which can then be used by several top level processes. This simplifies process modelling. Each sub process can contain other sub processes. There are two rules to note regarding sub processes:

- A sub process cannot be defined as runnable.
- When you use a sub process in another process, you must connect the sub process to the Top Node window.

To create sub processes:

1. Enter a unique internal and display name for the new process for the HR Task flow item type.
   
   **Suggestion:** Use a naming convention for Internal and Display names. For example, a good Internal name might be ASSIGNMENTDETAILS_SL with a Display name of Assignment Details (Sub Level)

2. Define the process as NOT runnable.

3. Specify a user defined result set as a Process Result Type if the sub process requires more than one result value.

4. Open the Process Diagrammer window and add one Start activity and at least one End activity.

   Because a process can have more than one result value, many End activities may be required. At least one End activity is required to indicate that the process must connect back to the Top Level node window.

5. Connect the Start activity to another window.
   
   **Note:** The Start activity can connect to one window only.

6. Add other windows to the process, noting the following rules:

   - A window can only connect to another window where the result type is the same (such as, both Person Context windows).
   - The transition result value must be the name of the window activity you are connecting to (for example, F4 Enter Assignment).
   - Each window can only connect once to any other window.
   - Each window must connect to an End Activity with a <Default> transition result value.
   - You can connect a window back to its parent using the <Parent> transition result value, rather than the name of the parent window.
Creating Button Labels

You can enter the label you want to appear on the task flowed forms, for example, Photo (for the Picture window). Each task flow window activity has an attribute called Button Label. Use this attribute to override the default button label for a window and to define an access key (or keyboard shortcut).

**To create button labels:**

1. Display the process in the Oracle Workflow Process Diagrammer.
2. Select the activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the label you want to appear on the forms.
   
   Precede the appropriate letter in the label with an ampersand (&) to define an access key. For example, to use ALT+P (in the Microsoft Windows environment) as the access key for the Picture window, you could enter the label &Photo.
Positioning Button Display

You can position the display order of buttons on the form. For example, you might want the first button to display the Picture window.

The number of task flow navigation buttons that can be displayed on a window varies from window to window. If there are too many navigation options for them all to appear as buttons, the last button on the window is called Other and it displays a list of values containing the other navigation options.

You determine the navigation options available from a window by defining transitions to other windows in the Process Diagrammer. Now you can use the activity attributes Display Button 1..4 to specify which navigation options should display as buttons and the order in which they should appear.

To position buttons:

1. Display the process in the Oracle Workflow Process Diagrammer.
2. Select the activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the name of the window you want to display on the button for the Display Button 1 attribute.
   For example, if you want the first button to display the Picture window, enter F4 Enter Picture. If the window is the parent window then you can specify the <Parent> special connection value.
5. Repeat step 4 for the attributes Display Button 2 .. 4. If you do not want a button to appear on the window, enter the value <Null>.
   For example, if you only want three buttons to be displayed, enter <Null> as the value for Display Button 4.
Identifying Windows or Blocks to Display

For most task flow forms, you must display the first block of the form on entry. However, when you use the Combined People and Assignment form in a task flow, you must specify whether to display the People window (or block) or the Assignment window on entry.

To identify windows or blocks to display:

1. Display the process in the Oracle Workflow Process Diagrammer,
2. Select the window activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the name of the block you want to display on entry for the Block Name attribute.
Identifying Configured Forms to Include in the Task Flow

If you have created a configured version of a window, you can use it in a task flow.

To identify configured forms to include in the task flow:

1. Display the process in the Oracle Workflow Process Diagrammer.
2. Select the window activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the name of your Form Customization for the Customization attribute.
Verifying and Saving the Workflow

When you have completed the task flow definition within Oracle Workflow, use the Workflow Verify function to check that your workflow conforms to Oracle Workflow modeling rules.

When you have successfully verified the Workflow, save it to the HRMS database.

To verify and save the Workflow:

   
   **Note:** This process does not check that you have created a valid task flow. This check is done when you generate the task flow.

2. Choose File – Save.
Generating a Task Flow From Oracle Workflow

After modeling a task flow in Oracle Workflow and saving it to the database, you must generate task flow definitions.

Use the Define Task Flow window from the HRMS application.

> **To generate a task flow from Oracle Workflow:**

1. Query the task flow(s) you have created and choose the Convert button.

2. Choose OK to convert the task flows from Oracle Workflow.

   Oracle HRMS indicates how many task flows have been successfully converted. If any task flows have not been converted, these are identified and are not saved to the database. You must correct the errors then verify, save and regenerate the task flows again.

   **Note:** Having modeled a task flow in Oracle Workflow, you cannot edit it using the Define Task Flow window. You must make any edits using Oracle Workflow, save it and then regenerate the task flow definitions.
Transferring Taskflows Between Databases

You can transfer a task flow you have created in one database (using either Forms or Workflow) into another database; for example, to add a task flow created in a test database to a live database. You do this by exporting the task flow information from the first database to a flat file which you can then import to the second database.

You do this using the Submit Request window.

**Attention:** Before transferring task flows into a database, you must ensure that all windows used by the task flow are present in the database. This includes any versions of windows that you have configured using CustomForm or Forms Configurator.

**To export a task flow to a file:**

1. Log in to the source database.
2. In the Submit Request window, choose Download HRMS Taskflows from the list of values in the Name field.
3. Enter a name for the file in which to save the task flow in the Data File parameter field. The recommended file extension is .ldt.
   
   **Suggestion:** To avoid having to move the file before importing it to the target database, include the full file path of a location that is accessible to both the source and target databases.
4. To download a single task flow, select the task flow name from the list of values (you can download all task flows for a legislation, or all global task flows, by leaving the task flow field blank).
5. To download task flows for a particular legislation, select the legislation from the list of values. To download global task flows, leave the legislation field blank.
6. Choose OK, then choose Submit, to save the task flow to a flat file.

**To import a task flow from a file:**

1. Log in to the target database.
2. In the Submit Request window, choose Upload HRMS Taskflows from the list of values in the Name field.
3. Enter the name of the file containing the task flow in the Data File parameter field.
4. Choose OK, then choose Submit, to import the task flow to the database.
5. You can now use the task flow in the same way as in your original database.
CustomForm

Many of the standard Oracle HRMS windows are multipurpose. For example, in the People window, you can enter or view details of employees, applicants, contacts, or other person types that you have defined. In the Element Entries window, you can make entries for all the elements you have defined.

You might prefer to have multiple versions of these windows, each version being used for just one purpose. This approach restricts the list of values on certain fields and therefore provides for faster data entry. It also enables you to limit access to certain types of information.

For example, you might create a version of the View Element Entry History for Employee window that does not display the earnings elements representing salary, bonus, and commission. Most users’ menus would only give them access to this version of the window. For the small group of people authorized to view salary, bonus, and commission figures, your system administrator can define a menu function to allow access to the standard form.

You can do this using CustomForm.

Configuring People Management Templates

When you configure a people management template using Forms Configurator (see Forms Configurator: page 2 – 43), you can specify whether the template handles employees, applicants, or both. This is a quick way to restrict your template windows by system person type. If you need to restrict the template windows by user person type, you can use CustomForm to create a configured version of your template.

Attention: Make sure that the criteria you enter in the Form Customization window do not conflict with any restrictions you put on the template using Forms Configurator. For example, if you restrict the template to Applicants Only in Forms Configurator then create a configured version that only handles the user person type Graduate Intake (a type of employee), users will not be able to query any people using the template.

You can also use CustomForm to restrict people management templates in other ways. You can restrict the special information types, extra information types, actions, and notifications that are available from your templates. You can also control the fields available for searching and the new records (applicant, employee, assignment or application) that can be created using the templates.
Windows you can Configure using CustomForm

You can use CustomForm to restrict the information available in the windows listed in the table below. We also identify the criteria you can use to restrict access to information.

### Configurable Windows

<table>
<thead>
<tr>
<th>Form</th>
<th>Restrict By</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust Balance (Oracle Payroll form)</td>
<td>Element Set</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Element Processing Type</td>
<td>Recurring, Nonrecurring</td>
</tr>
<tr>
<td>Assignment Folder</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Element Entries</td>
<td>Element Set</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Element Processing Type</td>
<td>Recurring, Nonrecurring</td>
</tr>
<tr>
<td>Element Entries</td>
<td>Entry Type</td>
<td>Override</td>
</tr>
<tr>
<td>Event Bookings</td>
<td>Employee or Applicant</td>
<td>Employee, Applicant</td>
</tr>
<tr>
<td>Extra Assignment Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra Element Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra Job Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra Location Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra People Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra Position Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>List Employees by Element</td>
<td>Element Set</td>
<td>User defined</td>
</tr>
<tr>
<td>List Employees by Element</td>
<td>Element Processing Type</td>
<td>Recurring, Nonrecurring</td>
</tr>
<tr>
<td>List People by Special Information</td>
<td>Employee or Applicant</td>
<td>Employee, Applicant</td>
</tr>
<tr>
<td>List People by Special Information</td>
<td>Special Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>List People by Special Information</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Organization</td>
<td>Organization Classification</td>
<td>List of Organization Classifications</td>
</tr>
<tr>
<td>Form</td>
<td>Restrict By</td>
<td>Values</td>
</tr>
<tr>
<td>----------------------------------------------------</td>
<td>------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Payroll and Assignment Processes</td>
<td>Action Type</td>
<td>List of Action Types (e.g. Run, Pre-payments, Reversal)</td>
</tr>
<tr>
<td>People Folder</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>People (PERWSEPI), People and Assignment (PERWSHRG)</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>(Enter Personal Information)</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>People Management</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>People Management</td>
<td>Special Information Type</td>
<td>User defined, and some may be predefined</td>
</tr>
<tr>
<td>People Management</td>
<td>People Extra Information Type</td>
<td>User defined, and some may be predefined</td>
</tr>
<tr>
<td>People Management</td>
<td>Assignment Extra Information Type</td>
<td>User defined, and some may be predefined</td>
</tr>
<tr>
<td>People Management</td>
<td>Actions</td>
<td>List of available actions such as Hire Applicant</td>
</tr>
<tr>
<td>People Management</td>
<td>Workflow Notifications</td>
<td>Notifications defined in workflow; some predefined, you can add others</td>
</tr>
<tr>
<td>People Management</td>
<td>Advanced Find Items</td>
<td>List of fields you can use for an advanced Find</td>
</tr>
<tr>
<td>People Management</td>
<td>New Objects</td>
<td>New Applicant, New Employee, New Application, New Assignment</td>
</tr>
<tr>
<td>Position Occupancy Folder</td>
<td>Employee or Applicant</td>
<td>Employee, Applicant</td>
</tr>
<tr>
<td>Run QuickPaint Report</td>
<td>QuickPaint Inquiry</td>
<td>User defined</td>
</tr>
</tbody>
</table>
### Types of Data Restrictions

You can restrict the information that appears in a configured window by the following sorts of criteria:

- Element processing type (recurring or nonrecurring)
- Element set (user defined)
- Person function (enter employee, enter applicant, hire someone on system)
- Person type (user defined)
- Special information type (user defined)
- Organization classification
- Employee or applicant
- QuickPaint report (user defined)
- Extra Information Type (user defined)
- Action for People Management
- Workflow notification (user defined)
- New objects that you can create using the People Management form
- Fields you can search on using Advanced Find in the People Management form. The fields you select are excluded from the Advanced Find.

**Attention:** When you use a standard form, all types of information are available. When you use a configured version,
you can only see the types of information that were selected on the Form Customization window. However, there is one exception. When you restrict the People Management form by Advanced Find Item, you can search in the configured version of the form on all Find items except the ones you selected on the Form Customization window.

If you want to restrict the data by a user defined information type, you must create it first:

- To restrict by element set, create the set in the Element and Distribution Set window.
- See Defining an Element or Distribution Set: page 2 – 42
- To restrict by QuickPaint Report, create the report in the Define QuickPaint Report window.
  
  See: Defining QuickPaint Reports: page 5 – 13
- To restrict by Special Information Type, define your information type as an instance of the Personal Analysis key flexfield.
  
  See: Setting Up Special Information, Managing People Using Oracle HRMS
- To restrict by person types, define your user person types in the Person Types window.
  
  See: Defining Person Types, Managing People Using Oracle HRMS
- To restrict by Extra Information Type, define your information type as an instance of the appropriate extra information flexfield.
  
  See: Setting Up Extra Information Types (Excluding Organization EITs): page 1 – 36
- To restrict by workflow notification, create your notifications using Oracle Workflow.
Using CustomForm

Use CustomForm to configure a certain set of windows by setting restrictions in them. For example, you can use CustomForm to restrict the elements that users can enter using the Element Entries window.

You can also use Forms Configurator to modify predefined templates and create windows that match your business processes.

See: Using Forms Configurator: page 2 – 81

To configure a window using CustomForm:

1. If you are restricting the information that appears in the configured window by a user defined entity (such as an element set, person type, special information type, or QuickPaint report), ensure that this entity is already defined.

   See: Types of Data Restriction: page 2 – 37

2. Define a configured version of the window using the Form Customization window.

   See: Configuring a Window With CustomForm: page 2 – 40

3. Add the new window to a menu or task flow.

   See: Adding a Configured Window to a Menu or Task Flow: page 2 – 41
Configuring a Window With CustomForm

You can define your own versions of templates and some standard windows in the Form Customization window.

See: List of Configurable Windows: page 2 – 35

**Note:** If you want to restrict access to query–only for a window, you do not need to create a separate version. Instead you create a new form function, setting the QUERYONLY parameter to YES.

See: Restricting Access to Query–only Mode: page 3 – 61

**To define restrictions for a window:**

1. Select the name of the window in the Form to be customized field.
2. Enter the name of your new version in the Name field. This name is used when defining menus but it is not seen by users.
3. Select Enabled if you want the restrictions to come into effect. If you do not select this option, the configured version of the window behaves the same way as the standard version.
4. Enter the titles to appear in the new version of the window:
   - In the Standard Title field, enter the window title to be seen by users who can use the window for data entry and editing.
   - In the Query Title field, enter the window title to be seen by users who have view–only access to the window.

**Note:** If you are configuring a template, the titles entered for the template in the Forms Configurator window override those entered here.

5. Save your new version.
6. In the Restrictions block, select the Type and Value of the restrictions you want to define. The types and values available depend on the window you are configuring.
Adding the Configured Window to a Menu or Task Flow

You can add your configured windows to a menu or a task flow:

- **Adding configured windows:**

  1. If you want to add the configured window to a task flow, you must create a Task Flow Node for it.

  2. If the configured window is called directly from the Navigator window, you must define a menu function to call the window with the configuration. You can add this function to any menu.

     For a description of the HRMS parameters you can use when you define functions, see: Using Parameters for HRMS Form Functions: page 3 – 62.

     **Note:** If you want to use a configured version of the People window, People Folder, or Assignment Folder to start a task flow, you should define a new task flow node and then define a menu function to call the task flow.

     For more information about adding your configured window to a menu see: Menus Window, Oracle Applications System Administrator’s Guide.
Defining an Element or Distribution Set

In the Element and Distribution Set window, you can select element classifications or individual elements to define a set. There are three types of set:

- **Customization set**: You can use a Customization set to restrict the elements that can be entered or viewed on a configured version of the Element Entries window. You can also select a customization set for element entry using BEE in the Batch Assignment Entry window.

- **Run set**: Oracle Payroll users can use a Run set to specify the elements to be processed in a payroll run. If you are creating a Run set for US payroll, you must include the VERTEX recurring element (see step 4).

- **Distribution set**: Oracle Payroll users can use a Distribution set to define the elements over which the costs of other elements are to be distributed.

**To define an element or distribution set:**

1. Enter a unique name for the set and select the type: Distribution, Run, or Customization.
2. Save your new set.
3. If you want to include all elements in a classification, choose the Classification Rules button.
   - In the Classification Rules window, select one or more classifications to include. Save the set and close this window. The elements in the classifications you choose are now listed in the Elements region.
   - If you want to exclude individual elements, place your cursor in the element’s row and choose the Exclude Element button.
4. If you want to include particular elements from other classifications, choose the Include Element button.
5. Select the element you want to include in the Elements window, and choose the OK button.
   - **Note**: After you include a particular element, you cannot go to the Classification Rules window and include the classification to which this element belongs.
6. Save your set.
7. If you want to see a list of the individual elements you have included or excluded from the set, choose the Element Rules button. The Element Rules window is view-only.
Forms Configurator

You can use the Forms Configurator tool to design forms that closely meet the business processes of your enterprise. For example, you can design forms to contain the essential information you need to hire a new person. This saves time, reduces errors, and makes data entry and maintenance easier.

Predefined templates are provided with Oracle HRMS. These are examples of forms that have already been designed with specific processes in mind. The People Management set of templates has been created using the People Management form. The example templates use selected items from this form. However, you can select any item from the People Management form when modifying the example templates to create your configured forms.

See People Management Templates: page 2 – 45.

Why Use a Predefined Template?

You can create new forms without using a predefined template but we recommend that you use one as a guide for the following reasons:

- The templates have been carefully designed to represent typical business processes and show a good implementation of window design.
- It makes it easier to upgrade to new predefined templates when they become available. When you upgrade a predefined template the system makes the necessary core updates but leaves any changes you have made to the template in place.

What Can I Change On a Template?

When you design a new form using a template, you can:

- Choose which windows of the form to display, and where they are positioned.
- Choose which window displays first when a user chooses the form from the navigator.
- Select which tabs, fields, and buttons you want displayed on each window.
- Choose where fields are positioned, on which tabs they appear, and the field tabbing order.
- Choose to default values in fields.
• Use formulas to supply additional details about a field or button to be displayed when a user right-clicks on the item.
• Set up context-sensitive fields such as address styles so that the appropriate fields are displayed depending on a value chosen.
• Enable display of DateTrack History on datetracked fields.
• Define data restrictions such as Employees only or Applicants only.
• Set up checklists for users to record the progress of actions. You can add values to the predefined lookups: CHECKLIST_ITEM and CHECKLIST_STATUS.
• Create notification messages for users to send workflow notifications to other people. Some messages are predefined.

Note: The online help reflects the predefined templates. If you configure the forms, you might need to edit the help to reflect the changes you make.

Setting Up Task Flows To Other Windows

You can add task flow buttons to access other windows from the Maintenance window of your configured form. Create the task flow using Oracle Workflow or the Task Flow windows, then view the window with the buttons within Forms Configurator.

If you want to reposition or resize the buttons on the window, you need to add the button items to your template using Forms Configurator, place them in the appropriate positions, set their size, and enter labels for them.

Forms Configurator User Interface

The Forms Configurator tool contains a graphical navigation tree and a set of properties. The navigation tree has been set up in a logical order so that if you follow the tree down from the top, that is the order in which you should complete your tasks. Expand the template name to see the information associated with the template.

You can see what your windows look like on the screen as you make edits to them. You can also preview the windows in your template to test out the fields and tabbing and see how they will appear to the user.
People Management Templates

The predefined People Management templates have been designed to help you create forms that match your business processes. These templates were created from the People Management form using Forms Configurator. You can use the predefined template forms without making changes. Alternatively, you can modify the predefined templates to create your own forms, or you can create entirely new templates.

What Information Is Included In the Templates?

The People Management form contains all the personal and assignment information, such as LAST_NAME, and VACANCY. You use the templates to control what the user can see by only including what you need.

The predefined templates have been designed for generic business processes, such as hiring a person or creating a new applicant. For example, when you go through the hiring process, you typically have to open lots of windows to complete the task. With a template form, all the data can be put together and grouped into logical sections using the tabbed regions.

When an applicant is hired, assignment information from the application is automatically entered on the employee assignment. See People Management Form Fields: page 2 – 66 for a complete list of all the fields available for you to use when creating People Management templates.

How Many Windows and Tabs Can I Design?

A template can consist of a Find window, Summary window, and Maintenance window. You can modify each of these windows to suit your requirements.

You can design as many templates as you require, targeted at different tasks or user groups. For example, for users who only need to review information, you design a template that provides a Summary window. For users who need to update information, you can provide a Maintenance window too.

When you have created a new template, you add it to the Navigator so that your users can access the new windows. For each template, you can set up which window is displayed first. For example, you can specify that choosing People Maintenance from the Navigator displays the Find window first to enable users to find a person. Then they can
navigate to the Maintenance window by choosing the Show Details button.

The Find window can contain up to six tabs. One tab has been defined as the Advanced tab but you can use this for another purpose if you want.

The Summary window can contain up to ten tabs. One tab has been defined as the Checklist tab but you can use this for another purpose if you want.

The Maintenance window can contain up to ten tabs, including the Extra Information Types, and Special Information Types tabs. One tab has been defined as the Checklist tab but you can use this for another purpose if you want.

Figure 2 – 3 Using Templates to Design Process Based Windows

How Do I Control What Users Can Do With a Template?

Some restrictions are made using Forms Configurator, and others using CustomForm. For example, you use Forms Configurator to determine the fields, buttons, tabs, and windows available. You can also restrict a template to the Employee or Applicant system person types using Forms Configurator.

You can use CustomForm to:

- Specify the user person types, special information types, and extra information types that can be viewed or entered
- Specify the actions that can be performed, and the notifications that can be sent
• Remove fields from the list available for searching on the Advanced Find tab
• Restrict what can be created using the template: new applicants, employees, applications, or employee assignments.

Attention: You must be careful to create consistent restrictions. For example, it would not be consistent to restrict a template to Applicants Only using Forms Configurator, then add a CustomForm restrictions that only allows users to enter new employees or employee assignments.

Benefits of Using Template Windows

Templates provide the following advantages for your users:

• They can find information using the basic and advanced queries on the configurable Find window. You specify which fields appear in this window and in what order.
• They can save result sets to folders for repeated use in future work sessions.
• They can work more quickly if you use the templates to:
  – Hide information they do not need
  – Provide defaults where possible
  – Position fields in logical groups and on tabbed regions
• They can use the checklists to track the status of actions that you have defined as relevant to the template.

Using templates is only one part of making Oracle HRMS specific to your enterprise. You can also sequence windows together in task flows. You can define a Maintenance window to be the top window and provide buttons for navigating directly to other windows while the Maintenance window remains in the background.

People and Assignments in the Data Organizer

The Summary window of the people management templates includes the Data Organizer, which helps you find and organize information about people and assignments.

The Data Organizer can display people organized alphabetically by name, organization, or job. When you expand a person’s node in the Data Organizer, you see a list of their employee and applicant
assignments. Assignments do not have names, so you can choose what information appears in this list to help users identify the assignment they want to work with.

By default, assignments are identified as `<job>.<organization>`, such as Senior Manager.Engineering. However, you can choose any other database items to display in the Data Organizer. The same information appears in the Assignment field that you can display on the Maintenance window.

If you want to override the default, write a formula to return the text to be displayed. See: Writing Formulas for Templates, Using Oracle FastFormula.
Predefined People Management Templates

Oracle supplies a number of predefined People Management templates. We recommend that you base any new window design on one of these templates.

**Note:** You can create an entirely new template but there are many issues to be aware of such as upgrading and setting up context–sensitive address styles. We recommend that you copy a predefined template for your localization and make any changes to that.

Templates are provided for specific localizations. There are also generic templates for you to use if none of the predefined localization-specific templates meet your requirements.

Hiring Applicants Template

This template enables you to create windows for entering an applicant, tracking the applicant up to the point of hire, and hiring the applicant. You can use the Hiring Applicants window for the complete hiring process. You can access both employees and applicants in this template. This enables you to hire applicants and to process internal applicants.

Entering Employees Template

This template enables you to create a Maintenance window for quickly entering details of employees, and their primary assignment. It is restricted to employees only. This window is designed for users who have lots of employees to enter who do not need any applicant history, for example, a one day casual hire.

You can enter basic personal details such as name, date of birth and address as well as assignment details such as job, grade, and salary. The Notify button enables you to send notifications about actions to other people.

Maintaining Employees Template

Use this template to create windows for entering or maintaining full employee details. It is restricted to employees only. This is very similar to the tasks you would perform using the People window and associated windows.

Visa Admin

This template enables you to create windows for entering information about foreign workers. You can record details about an employee’s addresses, contacts and visa details.
Find Window Configuration

There are two parts to a Find window, and you can choose the fields that appear on each:

- Find tabs where users enter their search criteria
- Find Folder where the results of the search are summarized in a one-row-per-record format

Find Folder

In the Find Folder, include fields that will enable users to uniquely identify the records they need. Typically these fields are Full Name, Employee or Applicant Number, National Identifier (such as Social Security Number) and Date of Birth.

Find Tab

Put the fields in which you expect users to search most frequently on the Details Find tab (the tab to display first). To provide fast search results, we recommend that some of the following fields are available for searching:

- Last Name
- Employee Number
- Applicant Number
- National Identifier
- Full Name

Fields that have lists of values also provide good search performance.

The predefined templates include the Effective Date field on the Details tab. You can use this field to change your effective date without using the calendar icon from the toolbar. The effective date determines the lists of values available on fields in the Find window and which records will be returned. If you are going to include this field on the Find window, it is best to place it at the top of the window. This encourages users to set their effective date first, and then select from the appropriate lists of values in the other Find fields. You can include up to six Find tabs.

Advanced Find Tab

You can provide an Advanced Find tab (as one of the six Find tabs) for more complex searches, such as matching ranges of values. To construct an advanced tab you need to include the following fields, where $n = 1$ to 5:
- **Field Name**
  This field enables you to select a field on which to perform an advanced search.

- **Field Condition Code**
  This field defines the operator for the search, for example, not equal to, less than, greater than.

- **Field Value**
  This field is the value you want to search on.

For example, you could set up the following query, find me all people whose hire date (field name) is less than (condition code) 1–Jan–1999 (value).

You can restrict the fields that users can select in the Field Name fields using CustomForm. You can therefore remove the ability to search on sensitive or confidential fields.

**Security Check Box on Find Window**

There is a Security check box on the Find window that defines which people are included in a user’s search. To find people from outside your Security profile, you must ensure that the Security check box is enabled and is unchecked. However, they will not be able to view full information for people outside their security profile, and they will not be able to update these records.

If you leave this box unchecked, you must be careful that no confidential information is included in the Results of the Find. We recommend that you always check this check box.

If you do not want users to be able to change the security profile set for the template then you should set the Security check box to the required setting and then hide it, thus preventing users from updating it.

Although the Security check box defines which people are included in a search, it does not define what can be saved from the Find window into the Data Organizer, as this is controlled by the user’s security profile. This means that if you have the check box unchecked, your user may find that they cannot save some data that is returned in a query into a folder as it is outside their security access. The Data Organizer is also limited depending on the person type restrictions set up at template level.

If you delete the check box from the search criteria, the results will only display those people from within your Security profile.
SITs, EITs and Other Flexfields in Templates

Maintenance windows in your people management templates can include tabs for entering Special Information Types (SITs) and person and assignment Extra Information Types (EITs).

These tabs must contain a drop down list to enable the user to select the appropriate SIT or EIT to enter. This poplist controls the segments of the flexfield that display. In Forms Configurator, you select the item Special Information Type List (Special Information), or Extra Information Type List (Extra Info).

You select which segments of the flexfield are displayed. Each segment is displayed as a folder form column. At run time, the form displays the appropriate columns with no gaps where segments are not displayed.

**Note:** You can control which SITs or EITs a user can select in the template by creating a CustomForm restriction that you associate with the template when you add it to a menu.

Segments Using Value Sets

When selecting a flexfield item you will see each segment item has two entries, one called *meaning* and one called *value*. The value item is always required as this is where the user would enter or select the information. The meaning item is only used where the user selects a value from a value set. If the value set uses a short meaning and a longer description, you can include the meaning item to display this longer description when the user selects a value.

For example, you may have a segment in a flexfield that records a country of residence. In the value field the user may select a country short code, USA, and in the meaning field the longer description, United States of America, would be displayed.

How Segment Properties Are Derived From Template and Flexfield Definitions

When a user selects an SIT or an EIT type from the list, the item properties for each segment depend on the settings defined for the template and the flexfield:

- **Case Restriction, Default Value, Prompt Text, Width**
  If these properties are set in the template, these values are used. If not, the values set for the flexfield are used.
- **Enabled, Insert Allowed, Update Allowed, Visible**
  If the value for these properties is set to Yes on the flexfield, and is set to Yes or blank on the template, then these properties are set to Yes. Otherwise these properties are set to No.
• Required

This property is set to Yes if it is set to Yes on either the template or the flexfield. Otherwise it is set to No.

Some of the properties rely on other properties being set to appropriate values for them to take effect. For example, if the Required, Insert Allowed, or Update Allowed value are set to Yes, this will only take effect if the item is enabled and visible.

Note: These rules apply to all flexfields, not just SITs and EITs.

Positioning Columns in the SIT Folder

We recommend that you place the items Date from (Special info) and Date to (Special info) first in the folder. Then place all of the Special Information Segment n Value items (where n is 1 to 30) onto the tab in consecutive order.

As it is a folder form, you must also include the record indicator for the multi row block. This item is called Current Record Indicator (special info). Make its width 0.1", and make it appear just before the first Date field.

Positioning Columns in the EIT Folder

We recommend that you place all Extra Information segments onto the tab in consecutive order. Assignment EITs are called Assignment Extra Information n Value items (where n is 1 to 30), and person EITs are called Person Extra Information n Value items (where n is 1 to 30).

The actually positioning of the EIT segments on the tab is not important as when the window is accessed by a user the first populated EIT segment is displayed flush against the current record indicator and all others are lined up against it.

As with the SIT folder, you must include the record indicator for the multi row block. This item is called Current record indicator (Extra info). Make its width 0.1", and make it appear just before the first EIT segment field.

Other Flexfields

You can include user-defined descriptive flexfields (DFs) and developer descriptive flexfields (DDFs) in both the Summary and Maintenance template windows. You can include flexfield segments directly in the template window in the same way that you would add normal fields (segment properties will be the same as those described
for EITs and SITs); alternatively you can include the whole flexfield as a flexfield popup window. If you want to include multiple flexfields in your templates, you can include segments from some directly within the template, and add flexfield popup windows for others; however, you cannot include flexfield segments and a popup window for the same DF or DDF structure.

We recommend that you do not add too many flexfield segments directly to the template as this will impact performance. It is better to include whole flexfields as popup flexfield windows.
Context–Sensitive Fields In Templates

You can set up fields that are context–sensitive in your templates using the Forms Configurator tool. For example, you might want to display the Employee Number field when the selected person is an employee, and the Applicant Number field for an applicant.

You can also use this feature to display the appropriate segments of a flexfield. For example, you set the context to display the appropriate structure of the Personal Analysis Key Flexfield for the selected Special Information Type. You do not have to display the full structure defined in the flexfield. You can hide segments to save space on the template, or for security reasons.

You set up each context as a ‘child’ item under the main item in the Forms Configurator navigator. For example, if you want Post Code to display in three address style contexts, you define three context items under the Post Code item. If you hide the ‘parent’ items, there will be a blank area of the window when it opens. This area is populated by the context sensitive fields (such as address lines) when the user selects the appropriate context (such as an address style). The fields that are displayed, their position, size, defaults, and all other properties can vary with the context.

If one context is more common than the others, you can set that context as the default in the field where the context is chosen. Then there is no blank area when the window opens, because it contains the fields appropriate to this default context. For example, you might set your local address style as the default so that the appropriate address lines for local addresses are displayed by default.
Online Help Targets for Templates

When you are defining your template you can add your own help target to display a particular help topic in the online help. This will override the default context-sensitive help call of the form.window name.

If you enter a help target for the template this will override the form section of the default help target. The window name will still be appended to this target depending on from which window the user accesses help.

**Note:** If you define a new help target for your template none of the supplied online help for the template will work. You will have to update your help files to include your new help target.

The window names that can make up the People Management templates are:

- SUMMARY_WINDOW
- FIND_WINDOW
- MAINTAIN_WINDOW
- ACTION_WINDOW
- CREATE_WINDOW
- NOTIFY_WINDOW

For example, the default target that is generated when a user calls help from the Summary window of the Hiring Applicants template is PERWSQHM.SUMMARY_WINDOW. If you have defined a help target of “HIREAPP” for the Hire Applicants template, then when a user calls help from the Summary window the target that is generated is HIREAPP.SUMMARY_WINDOW.
Notification Messages Issued From Template Forms

When users choose the Notify button on a template form, they can select a message and a person or role to send it to.

Predefined Messages

The following table shows predefined notification messages. You can create additional messages using Oracle Workflow or delete any that are not relevant to your enterprise.

<table>
<thead>
<tr>
<th>Display Name</th>
<th>Internal Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change of employment for supervisor</td>
<td>SUPERVISOR_JOB_CHANGE</td>
</tr>
<tr>
<td>Change of Supervisor</td>
<td>CHANGE_SUPERVISOR</td>
</tr>
<tr>
<td>Employee Transfer</td>
<td>EMPLOYEE_TRANSFER</td>
</tr>
<tr>
<td>Employee Transfer – Notify Payroll</td>
<td>PAYROLL_INT_HIRE</td>
</tr>
<tr>
<td>New Hire Notification</td>
<td>NEW_STARTER</td>
</tr>
<tr>
<td>Notify Payroll with New Hire Details</td>
<td>PAYROLL_NEW_STARTER</td>
</tr>
<tr>
<td>Probation Period is close to expiry</td>
<td>PROBATION_PERIOD_EXP</td>
</tr>
<tr>
<td>Relocation Notification</td>
<td>RELOCATION_NOTIFICATION</td>
</tr>
<tr>
<td>Request Security Card</td>
<td>SECURITY</td>
</tr>
<tr>
<td>Employee Transfer (US)</td>
<td>US_EMPLOYEE_TRANSFER</td>
</tr>
<tr>
<td>Notify Payroll with New Hire Details (US)</td>
<td>US_PAYROLL_NEW_STARTER</td>
</tr>
<tr>
<td>Payroll Change for Employee Transfer (US)</td>
<td>US_PAYROLL_INT_HIRE</td>
</tr>
<tr>
<td>Relocation Notification (US)</td>
<td>US_RELOCATION_NOTIFICATION</td>
</tr>
<tr>
<td>Visa Expiry Notification to Supervisor</td>
<td>SUPERVISOR_VISA_EXPIRY_WARN_GENERIC</td>
</tr>
<tr>
<td>Visa Expiry Notification to Employee</td>
<td>EMPLOYEE_VISA_EXPIRY_WARN_GENERIC</td>
</tr>
<tr>
<td>Visa Expiry Notification to Employee (US)</td>
<td>US_EMP_VISA_EXP_WARN</td>
</tr>
<tr>
<td>Visa Expiry Notification to Supervisor (US)</td>
<td>US_SUP_VISA_EXP_WARN</td>
</tr>
</tbody>
</table>
Message Tokens

Notification messages can include the following tokens:

- HIRE_DATE
- FULL_NAME
- PER_EFFECTIVE_START_DATE
- TITLE
- FIRST_NAME
- LAST_NAME
- EMPLOYEE_NUMBER
- APPLICANT_NUMBER
- NATIONAL_IDENTIFIER
- ORGANIZATION
- GRADE
- JOB
- POSITION
- PAYROLL
- VACANCY
- SUPERVISOR
- ASG_EFFECTIVE_START_DATE
- LOCATION
- SALARY
- SALARY_CURRENCY
- PAY_BASIS
- DATE_PROBATION_END

Creating Additional Tokens

If your messages require additional tokens, you can create a formula that returns up to five outputs that you can use as tokens in your message text. You create the formula using Oracle FastFormula.

Forms Configurator Options

This section describes the configuration options you can use when designing your template. The options are shown in the order that they appear on the Forms Configurator tool.

Template Properties

Template Code
Displays the internal name for the template. This code in combination with the Legislation uniquely identifies the template. You use this name when adding the window to the user’s menu.

Template Name
Specifies the descriptive name of the template.

Enabled
A template can be enabled or disabled. You can only choose the Run Template option from the Tools menu for a template that is enabled and linked to a menu. Disable a template when it is no longer in use.

Legislation
Specifies the legislation of the template. Leave the legislation option blank to create a generic template. The system automatically displays the appropriate legislative version of a template for a user, or the generic version if there is no legislative version that matches the legislation of the user’s Business Group.

Description
You can provide a longer description of the template.

Help Target
You can add your own help target to display a particular help topic. This will override the default context-sensitive help call of the form.window name.

Note: The target you enter here will have the name of the window from which you have called help appended to it to form the complete target. For example, if you have defined a help target called HIREPER for your template and you call help from the Summary window, then the help target generated will be HIREPER.SUMMARY_WINDOW.

Further Information
Use this flexfield to enter additional configuration information for the template. For example, for the People Management templates this
flexfield enables you to specify which window is displayed first and which person types are allowed.

**Window Properties**

**Window Name**
Specifies the name of the selected window. There are three windows available: Summary, Find, and Maintenance

**Title**
Specifies the title of the window. This name will be displayed at the top left of the window.

**Height**
Sets the height of the window in inches.

**Width**
Sets the width of the window in inches.

**X Position and Y Position**
Sets the position of the window using coordinates. X sets the horizontal position and y sets the vertical position. Alternatively, you can use the arrow keys to move the window around.

**Canvas Properties**

**Canvas Name**
Specifies the name of the selected canvas. The canvases available depend on the window you are creating:

- **Background Canvases**
  The Maintain, Summary, and Find canvases fill in the background of the window. You cannot amend the properties of these canvases.

- **Tab Canvases**
  The Maintain Tabs, Summary Tabs, and Find Tabs canvases define the area of the window in which you will be able to define tabs.

- **Find Results Canvas**
  The Find Results canvas defines the area of the window in which you will be able to define the Find Results region.

**Visible**
Set this to Yes if you want the canvas to be displayed to the user.
Height
Sets the height of the canvas in inches.

Width
Sets the width of the canvas in inches.

X Position and Y Position
Sets the position of the canvas using co-ordinates. X sets the horizontal position and y sets the vertical position. Alternatively, you can use the arrow keys to move the canvas around.

Tab Page Properties

Tab Page Name
Displays the name of the tab. The tabs available to you depend on the window you are editing:

- Find – The find window has six tabs you can set up for any use.
- Maintain – The Maintain window has ten tabs available. Three tabs have been set up to be used specifically for Extra Information Types (EIT), Special Information Types (SIT), and the checklist.
- Summary – The Summary window has ten tabs available. One tab has been set up to be used specifically for the checklist.

Visible
Set this to Yes if you want the tab to be displayed to the user.

Label
This only applies to buttons or check box items. The label describes the button or individual check box.

If the item is a check box or button you can define an access key (or keyboard shortcut) by preceding the appropriate letter in the label with an ampersand (&). For example, to use ALT+P (in the Microsoft Windows environment) as the access key for the Picture window, enter the label &Picture.

Do not use the letters A, E, F, G, H, Q, S, or W, as they are used on the Oracle Applications menu. There is no validation to prevent the same letter being used more than once in the same window.

Navigation Direction
Sets the tabbing order for the items in the tab. This can be left to right, or top to bottom.
Item Properties

**Item Name**
The item name is the name of the data item or field, such as LAST_NAME, you have currently selected in the Forms Configurator Items branch. If you are working with a predefined template, only the fields used in that template are displayed on the Forms Configurator Items branch. You can add other fields to your template from the form.


**Window Name**
Displays the window name on which the field is used. You cannot change this property. Each field has an associated window. There are three windows available: Summary, Find, and Maintenance.

**Tab Page Name**
Displays the name of the tab or tabs in the window where the field will be positioned. You can choose a tab by clicking the button next to this field to see the available tab pages you can use.

**Visible**
Set this to Yes if you want the field to be displayed to the user. If it is set to No, the user will not see the field but the field and its value are still in use. For example, the Secure check box on the Find window is not visible but the box has been checked. The user cannot see the check box on the window but the security restriction still applies.

**Height**
Sets the height of the field in inches.

**Width**
Sets the width of the field in inches.

**X Position and Y Position**
Sets the position of the field using co-ordinates. X sets the horizontal position and y sets the vertical position. Alternatively, you can use the arrow keys to move the field around.

**Enabled**
Specifies whether the user can put their cursor into this field. If it is set to No, the user can see the field but cannot do anything to it.

**Required**
Set this to Yes if you want to make the field mandatory.

**Query Allowed**
Specifies whether the user can run a query in this field.
Note: This property is ignored in the People Management templates. You can only run queries using the Find window.

**Insert Allowed**

Specifies whether the user can insert new data in this field. If this is set to No for a field or button then it appears greyed out in the window.

**Note:** If you set this option to No for a check box then the check box will still appear in white on the window. To grey out a check box you must set the Enabled option to No.

**Update Allowed**

Specifies whether the user can enter information in the field and save it to the database. If this is set to No, the user can enter information but cannot save it.

**Note:** All fields included on a Summary window are greyed out, irrespective of the settings in the Insert Allowed and Update Allowed fields.

**Prompt Text**

Defines what text is displayed with the field. It also defines the text displayed for a group of check boxes. You enter text labels for individual check boxes using the Label property (see below).

**Prompt Display Style**

Specifies where a prompt is displayed for multi-row columns. "First Record" displays a prompt next to the first row. "All Records" displays a prompt next to each row. "Hidden" hides all prompts.

**Prompt Text Alignment**

Specifies the alignment of the prompt text as Center, Left, Right, End, or Start within the prompt box. Generally has no visible effect.

**Prompt Edge**

Specifies which edge of the field the prompt is attached to, either Start, End, Top, or Bottom.

**Prompt Edge Alignment**

Specifies how the prompt is aligned along the selected field edge, either Start, End or Center.

**Prompt Edge Offset**

Specifies the distance between the field and its prompt, measured in inches.

**Prompt Alignment Offset**
Use this property to adjust the prompt edge alignment. For example, if the Prompt Edge is Top, the Prompt Edge Alignment is Center and the Prompt Alignment Offset is 0.1, the prompt will be centered 0.1 inches from the center of the top edge of the field.

Label

This only applies to buttons or check box items. The label describes the button or individual check box.

You can define an access key (or keyboard shortcut) by preceding the appropriate letter in the label with an ampersand (&). For example, to use ALT+P (in the Microsoft Windows environment) as the access key for the Picture window, enter the label &Picture.

Do not use the letters A, E, F, G, H, Q, S, or W, as they are used on the Oracle Applications menu. There is no validation to prevent the same letter being used more than once in the same window.

Tooltip Text

You can enter text here that displays when the user has the mouse pointer over the field. Use this to provide additional quick help.

Previous Item

Specifies which field will be tabbed to next if you tab backwards. This overrides the default tabbing order.

Next Item

Specifies which field will be tabbed to next. This overrides the default tabbing order.

Default Value

You can set the default value for the field here. Setting defaults can help save time, provide better control, and reduce errors for the user.

Format Mask

You can apply a format style to number and date type fields so that the format is correct for your users.

Validation Formula

You can set up additional validation using formulas. For example, if you need to validate that an entry has been entered correctly, you can create a validation formula to check the format. Up to five inputs can be passed to the formula but only one message can be returned.

See: Writing Formulas for Templates, Using Oracle FastFormula

Formula Parameters 1–5
Enter the parameters you want to pass to the formula specified in the Validation Formula field.

**Information Formula**

You can set up additional information for fields using a formula. For example, on the Job field, the user can right click and choose More Information to see related information such as supervisor. Up to five inputs can be passed to the formula but only three outputs can be returned.

See: Writing Formulas for Templates, *Using Oracle FastFormula*

**Information Prompt**

Specifies the prompt displayed on the right mouse menu which the user will select to view the information you have defined in the Information Formula.

**Formula Parameters (1–5)**

Enter the parameters you want to pass to the formula specified in the Information Formula field.

**Alignment**

Defines the alignment of text within the item (left, center, or right).

**Case Restriction**

Defines what case the text will be defaulted to. For example, you can set it to upper case so that all the text entered in the field is upper case.

**Bevel**

Specifies the appearance of the field border, either RAISED, LOWERED, INSET, OUTSET, or NONE.

**Further Information**

Opens the developer descriptive flexfield, where you can enter additional configuration options. For example, for the People Management templates, you can select whether DateTrack History is enabled for datetracked fields.
### People Management Form Fields

The following table lists all the available fields on the People Management form. You can choose which of these fields are displayed on your users’ windows by adding them to, or removing them from, the predefined People Management templates using the Forms Configurator tool.

<table>
<thead>
<tr>
<th>Item Title</th>
<th>Windows</th>
<th>Additional Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action</td>
<td>Maintain</td>
<td>Button</td>
</tr>
<tr>
<td>Address Attribute 1–20</td>
<td>Maintain</td>
<td>Segments from the Additional Address Details descriptive flexfield</td>
</tr>
<tr>
<td>Address Attribute Category</td>
<td>Maintain</td>
<td>Context for the Additional Address Details descriptive flexfield</td>
</tr>
<tr>
<td>Address Date From</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Address Date To</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Address Information 13–20</td>
<td>Maintain</td>
<td>Segments from the Address developer flexfields that may have been defined by localization teams</td>
</tr>
<tr>
<td>Address Line 1–3</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Address Type</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Adjusted Service Date</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Age</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Application Attribute 1–20</td>
<td>Maintain</td>
<td>Segments from the Additional Application Details descriptive flexfield</td>
</tr>
<tr>
<td>Application Attribute Category</td>
<td>Maintain</td>
<td>Context for the Additional Application Details descriptive flexfield</td>
</tr>
<tr>
<td>Application Date End</td>
<td>Summary</td>
<td>None</td>
</tr>
<tr>
<td>Application Date Received</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Approved</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Assignment Attribute 1–30</td>
<td>Maintain</td>
<td>Segments from the Additional Assignment Details descriptive flexfield</td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------</td>
<td>----------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Assignment Attribute Category</td>
<td>Maintain Summary</td>
<td>Context for the Additional Assignment Details descriptive flexfield</td>
</tr>
<tr>
<td>Assignment Effective End Date</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Assignment Effective Start Date</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Assignment Extra Information 1–30</td>
<td>Maintain</td>
<td>Assignment extra information types</td>
</tr>
<tr>
<td>Assignment List</td>
<td>Maintain</td>
<td>Drop-down list displaying person’s assignments</td>
</tr>
<tr>
<td>Assignment Number</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Assignment Sequence</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Assignment Status Type</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Assignment Title</td>
<td>Summary</td>
<td>None</td>
</tr>
<tr>
<td>Assignment Type</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Attribute 1–30</td>
<td>Maintain Summary</td>
<td>Segments from the Additional Person Details descriptive flexfield</td>
</tr>
<tr>
<td>Attribute Category</td>
<td>Maintain Summary</td>
<td>Context for the Additional Person Details descriptive flexfield</td>
</tr>
<tr>
<td>Available For Transfer</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Background Check Date</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Background Check Status</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Background Date Check</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-----------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Bargaining Unit Code</td>
<td>Find Results Find</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Benefit Group</td>
<td>Find Results Find</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Benefit Medical Plan Number</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Blood Type</td>
<td>Find Results Find</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Button 1–5</td>
<td>Maintain</td>
<td>Taskflow buttons</td>
</tr>
<tr>
<td>Cancel</td>
<td>Find</td>
<td>Button</td>
</tr>
<tr>
<td>Change Date</td>
<td>Maintain</td>
<td>Assignment change date</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Change Reason</td>
<td>Find Results Find</td>
<td>Assignment change reason</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
<tr>
<td>Checklist 1–10 Date Done</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Checklist 1–10 Date Due</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Checklist 1–10 Item Code</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Checklist 1–10 Notes</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Checklist 1–10 Status</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Clear</td>
<td>Find</td>
<td>Button</td>
</tr>
<tr>
<td>Collective Agreement</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Collectively Agreed Grades Id Flex Num</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Collectively Agreed Grades Name</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Contract</td>
<td>Find Results Find</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
</tbody>
</table>

2 – 68 Configuring, Reporting and System Administration in Oracle HRMS
<table>
<thead>
<tr>
<th>Item Title</th>
<th>Windows</th>
<th>Additional Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coordinated Benefits Medical Plan Number</td>
<td>Find Results Summary</td>
<td>None</td>
</tr>
<tr>
<td>Coordinated Benefits No Coverage</td>
<td>Find Results Summary</td>
<td>None</td>
</tr>
<tr>
<td>Correspondence Language</td>
<td>Find Results Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Country</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Country 1–3</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Currency Code</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Current Employer</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Current Record Indicator</td>
<td>Find Results Maintain</td>
<td>Current Record Indicator must be included in multi-block records. It shows the currently selected record. There are separate versions of this item for special information types and extra information types.</td>
</tr>
<tr>
<td>Date Employee Data Verified</td>
<td>Find Results Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Date From</td>
<td>Maintain</td>
<td>Special information type</td>
</tr>
<tr>
<td>Date Of Birth</td>
<td>Find Results Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Date Of Death</td>
<td>Find Results Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Date Of Receipt Of Death Certificate</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Date Probation End</td>
<td>Find Results Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Date To</td>
<td>Maintain</td>
<td>Special information</td>
</tr>
<tr>
<td>Datetrack Correction</td>
<td>Maintain</td>
<td>Datetrack radio button</td>
</tr>
<tr>
<td>Datetrack Update</td>
<td>Maintain</td>
<td>Datetrack radio button</td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>--------------------------</td>
<td>----------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Default Code Combination Identifier</td>
<td>Find Results</td>
<td>Internal identifier for the assignment’s default expense account</td>
</tr>
</tbody>
</table>
| Dependant Voluntary Service        | Find Results
Maintain
Summary                      | None                      |
| Deployment Factor Attribute 1–20  | Maintain
Summary              | Segments from the Additional Deployment Factor Details descriptive flexfield (Work Choices) |
| Deployment Factor Attribute Category | Maintain
Summary          | Context for the Additional Deployment Factor Details descriptive flexfield (Work Choices) |
| Dpf Fte Capacity                   | Maintain
Summary              | Deployment factor FTE capacity                                                        |
| Dpf Work Duration                  | Maintain
Summary              | Deployment factor work duration                                                        |
| Dpf Work Hours                     | Maintain
Summary              | Deployment factor work hours                                                          |
| Dpf Work Schedule                  | Maintain
Summary              | Deployment factor work schedule                                                        |
| Duplicate Check                    | Maintain
Maintain Tabs     | Button. This can be placed on the main window or the tabs in the Maintain window. If you include this button you must ensure that you have set up a Find window in your template. |
| Earliest Available Date            | Maintain
Summary              | None                                     |
| Education Establishment 1–4 Attended End Date | Summary | Schools information                      |
| Education Establishment 1–4 Attended Start Date | Summary | Schools information                      |
| Education Establishment 1–4 Full Time | Summary | Schools information                      |
| Education Establishment 1–4 Name   | Summary                  | Schools information                      |
| Effective Date                     | Find
Maintain                 | There are separate versions of this element for the Find window and the timeline on the Maintain window |
| Email Address                      | Find Results
Find
Maintain
Summary     | None                      |
<table>
<thead>
<tr>
<th>Item Title</th>
<th>Windows</th>
<th>Additional Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Number</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Employment Category</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Establishment</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Expense Check Send Address</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Extra Information Type List</td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td>Field 1–5 Condition</td>
<td>Find</td>
<td>Advanced search items</td>
</tr>
<tr>
<td>Field 1–5 Name</td>
<td>Find</td>
<td>Advanced search items</td>
</tr>
<tr>
<td>Field 1–5 Value</td>
<td>Find</td>
<td>Advanced search items</td>
</tr>
<tr>
<td>Find</td>
<td>Find</td>
<td>Button</td>
</tr>
<tr>
<td>First Name</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Frequency</td>
<td>Find Results</td>
<td>Used with normal working hours</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Full Name</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Full Name Title</td>
<td>Summary</td>
<td>None</td>
</tr>
<tr>
<td>Full Time Equivalent Capacity</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Gender</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Go</td>
<td>Maintain</td>
<td>Button used on timeline to show details as of the effective date entered</td>
</tr>
</tbody>
</table>

Configuring Oracle HRMS 2 – 71
<table>
<thead>
<tr>
<th>Item Title</th>
<th>Windows</th>
<th>Additional Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grade</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Hire Date</td>
<td>Maintain</td>
<td>Date of latest hire</td>
</tr>
<tr>
<td>Hold Applicant Date Until</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Honors</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Hourly Salaried</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Internal Address Line</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Internal Location</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Job</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td>Known As</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Labour Union Member</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Last Medical Test By</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Last Medical Test Date</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Last Name</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td>Load Picture</td>
<td>Maintain</td>
<td>Button that enables you to load a digitized picture of the person</td>
</tr>
<tr>
<td>Location</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Mailstop</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Manager</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Marital Status</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Middle Names</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Multiple Components</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>National Identifier</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Nationality</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>No Benefit Coverage</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>No Country 1–3</td>
<td>Maintain</td>
<td>Countries in which the person does not want to work</td>
</tr>
<tr>
<td>Normal Hours</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Notify</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Office Number</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>On Military Service</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Only Current Location</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Original Date Of Hire</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Pay Basis</td>
<td>Find Results</td>
<td>Salary frequency</td>
</tr>
<tr>
<td>Pay Proposal Attribute 1–20</td>
<td>Maintain</td>
<td>Segments from the Additional Salary Administration Details descriptive flexfield</td>
</tr>
<tr>
<td>Pay Proposal Attribute Category</td>
<td>Maintain</td>
<td>Context for the Additional Salary Administration Details descriptive flexfield</td>
</tr>
<tr>
<td>Payroll</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td>People Group</td>
<td>Find</td>
<td>None</td>
</tr>
<tr>
<td>People Group Segment 1–30</td>
<td>Find Results</td>
<td>Segments from the People Group key flexfield</td>
</tr>
<tr>
<td>Performance Review Period</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td>Person Effective End Date</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td>Person Extra Information 1–30</td>
<td>Maintain</td>
<td>Person extra information type</td>
</tr>
<tr>
<td>Person Information 1–30</td>
<td>Find Results</td>
<td>Person developer descriptive flexfield. This will only contain records if they have been set up for your legislation.</td>
</tr>
<tr>
<td>Person Information Category</td>
<td>Find Results</td>
<td>Context for the Person developer descriptive flexfield.</td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Person Referred By</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Person Type</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Home Date From</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Home Date To</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Home Fax Date From</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Home Fax Date To</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Home Fax Number</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Home Number</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Mobile Date From</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Mobile Date To</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Mobile Number</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Work Date From</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Work Date To</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Work Fax Date From</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Work Fax Date To</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Work Fax Number</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Phone Work Number</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Picture</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------------------------------------------</td>
<td>----------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Position</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Postal Code</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Pre Name Adjunct</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Previous Last Name</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Primary Address</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Primary Assignment</td>
<td>Find Results</td>
<td>This check box should always be set to display only when included in a template. When a user wants to change a secondary assignment to a primary they must use the Make Primary Assignment action.</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Probation Period</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Probation Unit</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Projected Hire Date</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Proposed Salary</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Receipt Of Death Certificate Date</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Recruiter</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Recruitment Activity</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Region 1–3</td>
<td>Maintain</td>
<td>Address regions</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>----------------------------</td>
<td>--------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Registered Disabled</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Rehire Recommendation</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Relocate Domestically</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Relocate Internationally</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Relocation Preference</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Requisition</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Resume Exists</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Resume Last Updated</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Salary Basis</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Find</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Salary Review Period</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Salary Review Period Frequency</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Save As</td>
<td>Find</td>
<td>Button</td>
</tr>
<tr>
<td>Second Passport Exists</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
</tr>
<tr>
<td>Secure</td>
<td>Find</td>
<td>Check box</td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>--------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Show Details</td>
<td>Find Summary</td>
<td>Button</td>
</tr>
<tr>
<td>Soft Coded Segment 1-30</td>
<td>Find Results Maintain Summary</td>
<td>The soft coded legislation key flexfield holds legislation specific information at the assignment level. The legislation of your Business Group determines which flexfield structure you see.</td>
</tr>
<tr>
<td>Source Organization</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Source Type</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Special Ceiling Point</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Special Ceiling Step</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Special Information Segment 1-30</td>
<td>Maintain</td>
<td>None</td>
</tr>
<tr>
<td>Start Date</td>
<td>Find Results Find Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Student Status</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Style</td>
<td>Maintain Summary</td>
<td>Address style</td>
</tr>
<tr>
<td>Successful</td>
<td>Maintain Summary</td>
<td>Flag indicating whether an application was successful</td>
</tr>
<tr>
<td>Suffix</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Supervisor</td>
<td>Find Results Find Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>System Person Type</td>
<td>Find Results Maintain</td>
<td>None</td>
</tr>
<tr>
<td>System Status</td>
<td>Find Results Summary</td>
<td>None</td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------------------------------</td>
<td>----------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Tax Effective End Date</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Tax Effective Start Date</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Tax Field 1–150</td>
<td>Maintain Summary</td>
<td>Empty items to enable localization teams to configure legislation specific information, such as tax information.</td>
</tr>
<tr>
<td>Telephone Number 1–3</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Termination Reason</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Time Normal Finish</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Time Normal Start</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Timeline Field</td>
<td>Maintain</td>
<td>Drop-down list that enables you to select what data is shown in the timeline</td>
</tr>
<tr>
<td>Title</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Town Or City</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Travel Required</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Uses Tobacco</td>
<td>Find Results Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Visit Internationally</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Work Any Country</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Item Title</td>
<td>Windows</td>
<td>Additional Information</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>Work Any Location</td>
<td>Maintain Summary</td>
<td>None</td>
</tr>
<tr>
<td>Work Schedule</td>
<td>Find Results</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Maintain Summary</td>
<td></td>
</tr>
</tbody>
</table>
Using Forms Configurator

Use Forms Configurator to modify predefined templates and create windows that match your business processes. There are predefined templates that you should use as a basis for creating your own templates.

You can also configure a certain set of windows using CustomForm.
See: Using CustomForm: page 2 – 39

To configure a template form using Forms Configurator:

1. Write any formulas you require for the template. You can write formulas to:
   - Change the name used to identify assignments.
   - Validate user entries in a field.
   - Provide more information on a field, which the user can access from the right mouse menu when they right-click on the field.
   - Create additional tokens for notification messages.
See: Writing Formulas for Templates, Using Oracle FastFormula.

2. Open and make a copy of a predefined template using Forms Configurator or import an existing template.
See: Opening and Copying a Template: page 2 – 83
See: Importing a Template: page 2 – 84

3. Modify the template to your requirements. You can perform as many of the following tasks as you require to complete your template.
See: Editing a Template: page 2 – 85
See: Adding and Removing Fields on a Template: page 2 – 87
See: Defining Checklists: page 2 – 89
See: Setting Defaults for Fields in Templates: page 2 – 91
See: Setting Up Context-Sensitive Fields in Templates: page 2 – 92
See: Setting Up DateTrack History on Fields in Templates: page 2 – 93

4. Review the predefined notifications and create any required new ones using Oracle Workflow.
See: Notification Messages Issued from Template Forms: page 2 – 57

5. If appropriate, use CustomForm to restrict the information that appears in the template window, and the actions that users can perform.

See: Configure a Window With CustomForm: page 2 – 40

6. Add the new form to a menu and/or task flow. When you define the form function, use parameters to specify the template name, and, if necessary, the customization name and task flow name. For example:

Function: PERWSQHM_CUSTOM_MAINTAIN_EMPS
Parameters: TEMPLATE_NAME="PER_MAINTAIN_EMPS"
            HR_CUSTOMIZATION="MedicalSIT"
            WORKFLOW_NAME="EMP_DEVELOPMENT"

See: Using Parameters for HRMS Form Functions: page 3 – 62
See: Adding a Configured Window to a Menu or Task Flow: page 2 – 41

7. Preview the form in Forms Configurator to check properties such as field tabbing sequence and defaults. You can also check whether you are happy with the default position of task flow buttons. If not, you can reposition them in Forms Configurator.
Opening and Copying a Template

We provide example templates for you to use as a basis for designing your own windows. We advise you to make a copy of a template and make changes to the copy. You can then always return to the original template if necessary.

**Note:** We also recommend that you set up templates in a test area. This avoids any security infringements when you run a template to view the windows you are designing. If the Security check box on the Find window is not selected, you can view summary information in the search results about all the people who meet your search criteria. This may include people outside your security profile.

To open and copy a template:

1. In the Navigator, open the Forms Configurator.
2. In the Find Templates window, select the template you want to copy.
3. Choose the Copy button.
4. In the Copy Templates window, enter the details for your new template in the Copy To section:
   - Enter a template code and, optionally, a legislation. These must form a unique combination, but you can create several legislative variations using one template code.
     You use the template code when you add the template form to a menu.
   - Enter a descriptive name
   - Choose to enable or disable the template. While designing a window, you can choose No so that users cannot display the window.
5. Choose OK.

The Forms Configurator tool is displayed along with a representation of the form template.

To make changes to the template, see Editing a Template: page 2 – 85.
Importing a Template

You can import a template from another database provided that it is for the same legislation as your Business Group. For example, you should not import a UK template for a US Business Group.

You might want to import a template from a test database to your production environment. You can also use this procedure to make backups of templates.

This procedure involves downloading the template to a data file then uploading to your target database.

To import a template:

1. Run the Forms Configurator – Download Template process. You do this in the Submit Requests window for a system administration responsibility.

2. In the Parameters window, enter a filename and full directory path for the data file. The template will be saved to this data file. You will use this data file to import the template later.

3. Select the name of the template you want to download and choose OK.

4. Go to the database where you want to upload and use the template.

5. Run the Forms Configurator – Upload Template process.

6. In the Parameters window, enter the name and path of the data file you created when you downloaded the template.

   The template is now available for you to add to a menu or modify using Forms Configurator.
Editing a Template

You can edit an existing template to design the layout and content of a new configured form. Use the Forms Configurator window.

To see a full list of the properties you can set for templates, windows, canvases, tab pages, and items, see: Forms Configurator Options: page 2 – 59.

To edit a template:

1. In the Find Template window, select the template you want to edit and choose Edit.
   The Forms Configurator tool is displayed along with the template form.

2. Review the template properties and edit any as required. Click in the last field (a predefined descriptive flexfield) if you want to:
   - Restrict the template to handling applicants only or employees only.
   - Specify which windows (Summary, Maintenance and Find) are included in the template, and which one displays first.

3. Expand the template name (top node in the Forms Configurator navigator) to display Windows and Items. When you select something in the navigator, its properties are shown in the bottom half of the window.

4. Expand Windows to display details of the windows in the template.

5. Expand each window, then the canvases and tab pages to specify the properties of each.
   For example, you can specify the title, size, and position of each window. You can choose which tab pages appear on a window and specify the label and navigational direction (top to bottom or left to right) in the tab.

   Note: If you make any changes to the properties of a window, canvas, tab, or item and do not want to save them, you can select Clear Record from the toolbar to reset the changes.
   To set up a checklist tab, see Defining Checklists: page 2 – 89.

6. Expand Items to display all the fields and buttons that are used in the template.

7. Select an item to view and update its properties. For example, you can move a field or change its prompt.
8. Right-click on Items and choose New from the right mouse menu to add an item that does not currently appear on the template. See: Adding and Removing Fields on a Template: page 2 – 87.

9. To remove a field or button from a template, right-click on the item in the navigator and choose Delete from the right mouse menu.

10. Save your work.

**Previewing Your New Form**

11. Choose Run Template from the Tools menu to see how the window will appear to your users, and to test task flow and right mouse menus.

**Attention:** The form must be added to a menu before you can preview it. The template must also be enabled. We recommend that you preview your forms on a test database only, to avoid security infringements.
Adding and Removing Fields on a Template

For windows that have been designed using a template, you can choose to remove fields from the window if your users do not need them and you can add new fields if required.

There is a distinction between removing a field from the template and removing a field from a window. If the field is in the template but hidden in the window, the field data is still active. Hidden fields will however, slow your performance so you should remove fields wherever possible. This procedure describes removing a field from the template so that its data is not used.

To add or remove a field from a template:

1. Open the template using the Forms Configurator tool.
   
   See: Editing a Template: page 2 – 85.
   
   The template windows are displayed along with the Forms Configurator tool.

Adding A Field

2. To add a new field that is not already in the template, right-click on Items and choose New from the right mouse menu.

   **Suggestion:** Add all your new fields in a consistent location, such as the top of the branch, to help you keep track of them. Choose Refresh from the right mouse menu when you want the system to place your new fields in their correct alphabetical position.

3. Click on the Item Name list of values icon to open the Item Names Find window. Search for the field you want to add or choose Find to see the complete list.

4. Select the field you want to add and choose OK.

   You will see your new field under Items in the navigator.

5. Set the following properties:
   
   - Tab Page Name
   - Visible
   - Height and width of the field
   - Position – Either use the arrow buttons to move the field around or enter a new position in the X and Y Position fields. As you move a field, you can view how it will appear on the window by looking at the template window.
Note: If you make any changes to the properties of an item and do not want to save them, you can select Clear Record from the toolbar to reset the changes.

You can choose to set other properties for the field. Refer to Forms Configurator Options: page 2 – 59 for a complete description of all the properties.

Removing a Field

6. To remove a field or button from a template, right-click on the item in the navigator and choose Delete from the right mouse menu.

7. Save your work.
Defining Checklists

A checklist is a list of user actions related to people management and recruitment, such as “Check References” and “Reimburse Expenses”. Against each check item, users can record a status, date due, date achieved, and any notes. The checklists are for user reference only; they do not perform any actions.

Checklists can appear on tabs of template forms: on the Summary window, Maintenance window, or both. These tabs are configurable. You specify which check items are displayed, and which fields are available for entry. There is a limit of ten check items on a tab.

There is also a Checklist window, which you can include in task flows from other windows, such as the People window. The Checklist window is not configurable. On this window, users can select any checklist item that you have defined.

To define checklist items and statuses:
1. Open the Application Utilities Lookups window.
2. Query the lookup CHECKLIST_ITEM.
3. Enter the code, meaning, and optionally a description for each checklist item you want to define.
4. Save your work.
5. Query the lookup CHECKLIST_STATUS.
6. Enter the code, meaning, and optionally a description for each checklist status you want to define.
7. Save your work.

To define a checklist:
1. Open your template using Forms Configurator.
   See: Editing a Template: page 2–85.
2. Expand Windows, expand the window on which you want to place the checklist, expand the Tab Pages node, and select the Checklist tab.
3. Enter properties for the Checklist tab, including the tab label.
   For a list of the properties you can change for a tab page, see Forms Configurator Options: page 2–59.
4. Expand Items and find Checklist 1 Item Code (Maintain) or Checklist 1 Item Code (Summary), depending which window is to
include the checklist. If this item does not appear in the items list, you need to add it.


5. Enter properties for this item.

   To provide a default check item in this field, enter the appropriate lookup meaning in the Default Value property. You must enter the meaning exactly as you typed it in the Application Utilities Lookups window. If you want to prevent users from selecting other check items in this field, set the Insert Allowed property to No.

6. Save your work.

7. To specify the fields that accompany this check item in the checklist, find the following items. If they do not appear under Items, you can add them. If they appear and you do not want them on your checklist, you can remove them.

   • Checklist 1 Status
   • Checklist 1 Date Due
   • Checklist 1 Date Done
   • Checklist 1 Notes

8. Repeat steps 4 to 7 to add up to ten checklist items to your template, using the items Checklist 2 Item Code through Checklist 10 Item Code.
Setting Defaults for Fields in Templates

The templates enable you to default values in as many fields as you want. You can make data entry easier for users by defaulting items that frequently take the same value. Where the value is constant, you might set a default and then hide the field from users.

There are some fields that are automatically defaulted by the system when the user selects a value in another field. For example, selecting a Business Group can populate the fields for Location, Working Hours, Frequency, Start Time and End Time. Do not set your own defaults for these fields since they will be overridden by the automatic defaults.

When an applicant is hired, assignment information from the application is automatically entered on the employee assignment.

To set a default for a field:

1. Open the template using the Forms Configurator tool.
   See: Editing a Template: page 2 – 85.
2. In the Forms Configurator navigator, expand Items and select the field for which you want to set a default.
   See: People Management Form Fields: page 2 – 66 for a full list of all the available fields.
3. In the Properties section, enter a default value for the field in the Default Value field. There is no list of values available, so you must be careful to type the value exactly as it should appear.
   You can also choose not to display the field on the window even though you have set a default value.
4. If you want to hide the field set the Visible Field to No.
5. Save your work.
Setting Up Context-Sensitive Fields In Templates

You can set up fields that are context-sensitive in your templates using the Forms Configurator tool. You can use the following contexts:

- Person type – for example, to hide the Employee Number field when an applicant is selected.
- Descriptive flexfield context – for example, to display address lines in the appropriate sequence for each address style.
- Key flexfield structure – for example, to display the appropriate structure of the Personal Analysis Key Flexfield for each Special Information Type.

**Note:** If a segment is not defined for a particular structure or context in the flexfield definition, it does not appear on the form even if you set it up for that context in Forms Configurator.

**To set up a context-sensitive field:**

1. Open your template using Forms Configurator.
   See: Editing a Template: page 2 – 85.
2. In the navigator, expand Items and find the field that you want to make context-sensitive.
3. Set the properties for the default field. You may want to hide the default field so that it only appears in the contexts that you define.
4. Expand the field, right click on Contexts, and choose New from the right mouse menu. You set up a ‘child’ context field for each context in which you want the field displayed.
5. In the Properties section, select a value in the Context Type field: Descriptive Flexfield, Key Flexfield, or QuickHire Person Type.
6. In the window that displays, enter the context in which this field should display and choose OK.
   For a descriptive flexfield, select the Application, Title, and Context. For example, this could be Oracle Human Resources, Personal Address Details, and United Kingdom respectively. For a key flexfield, select the Application, Title, and Structure. For a QuickHire Person Type, select the person type.
7. Choose the tab you want the field displayed on for this context and set any other properties, such as position or tool tip text.
8. Repeat steps 4 to 7 for each context in which this field should display.
9. Save your work.
Setting Up DateTrack History on Fields in Templates

You can set up DateTrack History for datetracked and dated fields on a template. This has two effects:

- Users can then right-click in the field and choose DateTrack History to see a history of changes that have been made to that field.
- The field appears in the drop down list by the timeline bar. If you select the field in the drop down list, the timeline shows the dates of changes to this field.

To set up DateTrack History on a field:

1. Open your template using Forms Configurator.
   See: Editing a Template: page 2 – 85.
2. Expand Items and find the field.
3. Select the flexfield [ ] at the bottom of the Properties section.
4. Enter Yes in the DateTrack History field.
5. Save your work.
Setting Up More Information on Fields in Templates

You can set up more information to be available to users on each of the fields you include in a template using Oracle FastFormula. The user can right-click in a field and choose a prompt that you specify. For example, you might want to enable the display of a supervisor’s email address from the Supervisor field. From the Job field, you might show the normal working conditions for the job.

For examples of how you can set up more information see the Supervisor and Position fields in the predefined Hiring Applicants and Maintaining Employees templates.

To set up more information on a field:

1. Open your template using Forms Configurator.
   See: Editing a Template: page 2 – 85.
2. Expand Items and select the field for which you want to set up more information.
3. Enter a formula name in the Information Formula field.
   You create the formula using Oracle FastFormula.
   See: Writing Formulas for Templates, Using Oracle FastFormula.
4. Enter a label explaining the information available in the Information Prompt field. This prompt is displayed in the right mouse menu when a user right-clicks on the field.
5. Enter up to five inputs for the formula in the Information Formula Parameter Fields.
6. Save your work.
Transaction Templates

Transaction templates serve as filters that overlay a window. They make it easier for you to accomplish tasks by displaying only the information required for the task that is appropriate for your workflow role.

Note: In this release, you use template for position transactions only.

The product provides two task templates and a workflow role template. These predefined templates have maximum permission levels set to view and edit attribute values.

Most organizations can use the predefined templates that come with the application. If your organization needs to restrict the fields that users can view and edit, you can copy the predefined templates and make the necessary changes.

Task Templates

You set up task templates to enable users to view and edit the attributes required to accomplish a specific task, such as update the Full Time Equivalent (FTE) for an existing position.

The application comes with two task templates, the Create and Update templates, but you can set up as many task templates as your enterprise requires to represent the tasks involved in creating and updating position definitions.

For example, you might define three task templates, one for proposing a position, one for classifying it, and one for approving it. As initiator, you can select one or more templates. Users later in the routing sequence can apply additional ones. The combined permissions established by the role and applied task templates define your access.

To prevent users from processing simultaneous transactions against the same position, you can mark an update template as under review. When a user initiates a position transaction with a Mark Under Review template, the application filters the list of positions to exclude those positions specified in pending or approved transactions.

Workflow Role Templates

Workflow templates establish your view and edit permissions based on your role.

- If the routing type is Position hierarchy, the application applies the role template associated to your position (primary assignment).
- If the routing type is Supervisory hierarchy, the application applies the default role assigned to you as a user.
• If the routing type is Routing List and you initiate a transaction, the application applies your default role template. If you open a routed transaction, the application applies the role template that corresponds to your role in the routing sequence. For example, if you have a default role template of line manager and initiate a transaction, the application applies the line manager template. If you open a routed transaction and your assigned role in the routing list is reviewer, the application applies the reviewer role template.

A predefined workflow role template supplied with the product (Basic Role template) has the maximum set of permissions defined. If your organization’s roles permit different levels of access, you can set up different role templates. In the example above, you might assign the line manager role view and edit access, but restrict the reviewer role to view access.

**Copied Templates**

You can create your own templates by copying the predefined ones. For example, you might create a task template to simplify freezing a position, by copying the update template and then hiding the fields that the user does not need to view.

You might create a role template to change users’ access to information by restricting that user’s role permissions. For example, you might define a role template for reviewers where all fields are view only.

**Permissions**

The overlay of workflow role and task templates may produce conflicting attributes. When the attributes do not match, the resulting permission is the one that represents the most restricted access. If the user applies more than one task template, such as two update templates, the application determines the resulting task template permissions, and then determines the net task and role template permissions.

For example, a classifier might apply a template for updating a position’s work schedule to a template that a previous manager initiated to update a position’s definition. The application compares and resolves the permissions between the two task templates and then applies the role template.

The following table shows the possible permission combinations.

<table>
<thead>
<tr>
<th>Role Template</th>
<th>Task Template</th>
<th>Permissions</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Edit</td>
<td>View</td>
</tr>
<tr>
<td>View</td>
<td>View</td>
<td>View</td>
</tr>
<tr>
<td>Role Template</td>
<td>Task Template</td>
<td>Permissions</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>None</td>
<td>View/Edit/None</td>
<td>None</td>
</tr>
<tr>
<td>Edit</td>
<td>Edit</td>
<td>Edit</td>
</tr>
<tr>
<td>Edit</td>
<td>View</td>
<td>View</td>
</tr>
<tr>
<td>View/Edit/None</td>
<td>None</td>
<td>None</td>
</tr>
</tbody>
</table>
Setting Up Transaction Templates

Transaction templates overlay a transaction window that define the permissions that apply to tasks and roles. Templates establish the fields on the form you can view and change and the fields you must complete.

You can set up a new template or base a template on existing templates. For example, you might define two task templates, and then discover that it is more practical to use one. You can combine the two templates, and then change the resulting attribution.

Use the Template window to define transaction templates.

To define a template

1. Name your template as you want it to appear in the Apply Templates window.
2. Enter a Short Name that the application then uses as a database key.
3. Select a Template Type:
   - Task templates define the view and edit permissions that you are going to establish for a specific task.
   - Role templates define the view and edit permissions that accompany the role.
4. For task templates, select a Type:
   - Create to initiate tasks, such as defining positions
   - Update to change data for existing records
     For Update task templates, choose Mark Under Review to require users to update a pending transaction before starting a new one.
5. Enter a Transaction Type.

   The Templates Attributes tab displays the attributes defined in the Transaction Type window.

   The application automatically selects the Enabled check box to make this template available for use.
6. If you wish to base the new template on an existing one:
   - Choose the Copied Templates tab.
   - In the Templates field, choose a template from the list of values.
     Repeat this step to add as many templates as you wish to copy.
   - Choose Apply Copy to copy the attributes from the template(s) to the Templates Attribute tab.
7. Choose the Template Attributes tab to review or edit the attributes and their permissions.
8. Choose Freeze Template to prevent further changes.
9. Save your work.

Making Changes to Templates

You can continue editing your template definition until you process a transaction that uses the template. From then on, the only permitted changes to template definitions include:

- Changing its attributes
- If it is an update task template, making it an under review template
- Disabling the template
Workflow for Position Management

You use Oracle Workflow to route and approve position transactions and budget worksheets. For organizations selected for position control, you route position transactions and budget worksheets. For all other organizations, you route only budget worksheets. If you do not wish to route budgets, you can use the Budget Detail window.

For information about selecting organizations for position control, refer to Creating Organization Hierarchies, Using Oracle HRMS – The Fundamentals.

Types of Routing

Your organization may route transactions for data entry and approval using different chains of authority. When using workflow for routing transactions, you have a choice of defining a routing sequence based on routing lists, supervisory hierarchy, or position hierarchy.

• When routing by Routing list, the application determines the next destination on the routing list.
  
  A routing list is a sequence of destinations that you define. A destination is a workflow role or a specific user who has that workflow role assigned to him or her.

• When routing by Position hierarchy, the application determines the occupant of the next position in the position hierarchy, using the current user’s position (primary assignment) as the starting point.

• When routing by Supervisory hierarchy, the application determines the current user’s supervisor (the supervisor listed on the user’s primary assignment) and routes to that person.

You can choose a different type of routing for each transaction type. For example, you can route budget worksheets using routing lists, position transaction for Global using position hierarchies and position transactions using supervisory hierarchies for your business group only.

The application routes all transactions that belong to a transaction type the same way. For example, if you choose routing list as the transaction type for budget worksheets, the application routes all budget worksheets using routing lists.

If you decide to change the routing type later, you can make that change after the application updates any pending transactions. The Transaction Status window shows you which transactions are pending.

You can reflect the different approval levels in your organization by defining multiple routing types, such as several routing lists, and then
defining routing and approval rules that instruct the application on what basis to select a routing list or an approver.

When a user initiates a transaction, such as a budget worksheet, the application compares the values contained in the transaction with the routing and approval rules to determine which user can next receive and/or approve the transaction. The application performs this step at each routing destination.

**Workflow Roles**

Workflow roles reflect the different types of responsibilities users perform in the routing sequence, such as requestor, classifier, or approver.

If you are setting up routing based on *routing lists or supervisory hierarchies*, you assign workflow role(s) to users, specifying one role as the user’s default role. When initiating transactions, the default role applies. Otherwise, when opening a routed transaction, if the routing type is:

- routing list, the routing list workflow role applies
- supervisory hierarchy, the default role applies

If you are setting up routing based on *position hierarchies*, you assign a workflow role to a user’s primary position.

For position transactions, you assign each workflow role a role template, assigning the basic role template supplied with the product or one that you define. When initiating or opening a routed position transaction, the application automatically applies the workflow role template.

**Global and Business Group Roles**

You can assign roles as global or business group. Business group roles apply to only one business group, while global roles enable workflow roles to extend into all your business groups. Thus a user assigned to a global role may view, approve, or forward transactions created in another business group. Those assigned to business group roles can view and act upon transactions only within their own business group.

*Note:* You can use global roles with routing lists and supervisory hierarchies but not with position hierarchies.

**Forwarding Transactions**

During the routing process, you have a choice of actions that you can take on the transaction:
• Save and Continue – Saves the transaction information while you continue working on it
• Save – Saves and stores the transaction in your inbox
• Forward – Sends the transaction to another user for further action
• Send Back – Returns the transaction to a previous destination
• Reject – Sends the transaction back to the initiator who can then reject it
• Override Approver – Sends the notification directly to a user previously designated as override approver for approval.

At any point in the routing sequence, you can expedite the approval process by routing the transaction directly to the override approver. The application automatically determines the next destination on the routing sequence. However, you may skip a destination and send the transaction to someone else in the routing sequence.

You can also make sure that the transaction does not sit in someone’s inbox unattended by setting a response time (in days). If the interval elapses with no response, the application returns the transaction to the previous approver.

Routing Notifications

During the routing process, you can choose to notify yourself or other users when a specific event occurs, such as the successful update to the database. You can also have the notification sent to someone else in the routing sequence. For example, when the application updates a future–effective position, you can have a notification sent to a manager to alert the manager that the position is now updated and available.

The application stores a history of all the actions taken in routing a transaction in the Transaction Status window. You can view the routing history to determine the chain of events—what action a user took and when, as well as prior and subsequent routing destinations.

Approvals and Updates

The first approver who receives the transaction can approve and apply it to the HR database. For example, in a position hierarchy several positions might be listed as approvers, but the first approver on the routing sequence to receive the transaction can approve it. The person who updates the transaction does not have to be an approver. The approver can forward the notification to someone else for update to the database.
You can apply and post transactions immediately or later. If you are updating current and retroactive actions, immediate posting updates the data as soon as you submit it, but you may have to suspend work for a moment while the update is performed. Posting later frees you to continue working while the Background Workflow Engine performs the update.

See: Oracle Workflow Guide

If you are updating future-dated actions, your access to the new records depends on whether you choose Today or On Effective Date. If you choose:

- Today, when you submit the transaction the application posts the transaction as of the effective date and creates a record for that future effective date. You can then access, edit, and use the new records to prepare other future-dated transactions.
- On Effective Date, the application waits until the effective date to validate the transaction, at which point you can access and use the records.

For future-dated transactions, the choice of today or on effective date may depend on how your enterprise validates actions processed in the interval between the date on which you submit the immediate update and the action’s effective date.

With posting today, the application uses the updated data to validate the actions processed in the interval. With on effective date posting, the application doesn’t use the data until the effective date is reached and the posting performed.

For example, if you set the option to post today and process an action on January 15 that eliminates a position on February 15, and a few days later process an action that freezes the position on February 1, the application displays an error, because you cannot freeze a position that you are eliminating.

If you set the option to on effective date posting, and process the same actions, you freeze the position on February 1, and on February 15 the application displays an error, because you cannot eliminate a frozen position.
The Transaction Type Wizard guides you step by step through the process of defining the posting and routing behavior for a selected Transaction Type. A Transaction Type is a group of like transactions to be routed and approved in the same manner.

The Transaction Type Wizard is divided into two separate setups, Standard and Advanced.

**Standard Setup:**

The Standard Setup is where you create the minimum information required for routing transactions. You define a default routing destination that will be used regardless of the values in the created transaction.

You use the Standard setup to:

- Choose how your setup will be applied.
  - You may apply it to your individual business group or to Global. Global will apply the setup to all business groups, not individually setup within the same transaction type.
- Determine when to post and update transactions
  - Post transactions with future effective dates
    - Today: On the date you submit the transaction, the system validates the transaction as of the effective date. The system then updates the database, creating a database record for that future effective date.
    - On Effective Date: The system waits until the future effective date, validates the transaction on that date, and updates the data to the database.
- Designate Approvers
  - The default Override Approver takes precedence over the default approvers selected in the standard setup.
- Define transaction routing using already defined routing list, position hierarchy or supervisory hierarchy


**Advanced Setup:**

The Advanced Setup is used to refine the transaction routing by defining rules based upon data in the transaction and replaces the standard setup.
Using the Advanced Setup, you can:

- Select attributes for routing and approval
- Define rules based upon the selected attributes

When you route a transaction, the system compares the values entered in the transaction with the attribute values defined in the routing and approval rules. The system identifies the appropriate routing list or hierarchy and the next qualified user in the routing sequence. You can define multiple routing lists based upon different rule selections, but rules must not overlap.

- Select final approvers
- Select Override Approver
Defining Workflow Roles for Transactions

Workflow roles identify users’ workflow activities. Workflow roles help determine who can enter and approve data on transactions. You assign workflow roles based on the routing type you define for each transaction category. If the routing type is:

- Routing list or supervisory hierarchy, you assign roles to users
- Position hierarchy, you assign roles to a user’s primary position

Global and Business Group Roles

You can create either business group roles (interacting with one business group) or global roles (interacting with multiple business groups). Once you have saved a role as business group or global, you cannot change it to the other option.

Note: You can use global roles with routing lists and supervisory hierarchies but not with position hierarchies.

See Global and Business Group Roles: page 2 – 101

Use the Maintain Roles window to define business group roles.

Use the Maintain Global Roles window to define global roles.

⇒ To define workflow roles:

1. To define a business group role, choose Roles under Transaction Maintenance in the Navigator.
   To define a global role, choose Global Roles under Transaction Maintenance in the Navigator.

2. Enter a Role Name.

3. Select a Role Type.
   The application automatically enables this role so that you can begin using it.

4. Save your work.
Associating Transaction Workflow Roles to Users

You can assign a user more than one role to accommodate the different types of roles a user may have when processing transactions, such as initiator, reviewer, and approver. You associate workflow roles to users if you route transactions using a routing list or supervisory hierarchy.

**Note:** You can create either business group roles (interacting with one business group) or global roles (interacting with multiple business groups). *Once you have saved a role as business group or global, you cannot change it to the other option.*

See Global and Business Group Roles: page 2–101

Use the Maintain Roles window to assign users business group roles.

Use the Maintain Global Roles window to assign users global roles.

**To associate workflow roles to users:**

1. Select an existing role or define a new one.
   
   For information on defining a new role, see Define Workflow Roles for Transactions: page 2–106

2. Choose the Users tab.

3. In the Person field, select a person’s name.
   
   The application automatically enters his or her user name. The application also selects the Enabled check box so that you can include this person when defining routing list destinations, override approvers, or transaction category authorization rules.

4. Select the Default Role check box to have this role selected as the person’s default role.

5. Repeat the above steps until you have added all the roles you require and associated the users to those roles.

6. Save your work.
Associating Transaction Workflow Roles to Positions

Workflow roles are associated to positions when the transaction routing type is position hierarchy. A position can only have one workflow role assigned to it.

Note: You cannot assign positions to global roles. See Global and Business Group Roles: page 2 – 101

Use the Maintain Roles window to assign positions to roles.

To assign workflow roles to positions:

1. Select an existing workflow role or define a new one.
   To define a new role, see Defining Workflow Roles for Transactions: page 2 – 106

2. Choose the Positions tab.

3. With the workflow role selected, select the position that corresponds to each user’s primary assignment position.
   The list of positions consists of those defined for the current business group.

4. Repeat the above steps until you have added the workflow roles you require, and have associated positions to those roles.

5. Save your work.
Associating Workflow Roles to Role Templates

For position transactions, you set up role templates that establish the maximum set of permissions for each role you define. Once you complete this setup, the application automatically applies the appropriate role template when users initiate a transaction or open a routed transaction.

Global and Business Group Roles

You can create either business group roles (interacting with one business group) or global roles (interacting with multiple business groups). Once you have saved a role as business group or global, you cannot change it to the other option.

See Global and Business Group Roles: page 2 – 101

From the Maintain Global Roles window, you can update or create only global roles. From the Maintain Roles window, you can update or create only business group roles.

To assign a role to a role template:

1. Select an existing role or define a new one.
   
   To define a new role, enter a Role Name, choose a Role Type, and choose Enabled to use this role.

2. Choose the Templates tab.

3. With the role selected, select a transaction type.

4. In the Template field, select a role template from the list of values.
   
   The application automatically selects the Enabled check box to make this template available.

5. For each transaction type, repeat the above steps until you have assigned a template to each role that requires one.

6. Save your work.
Deleting or Changing Transaction Workflow Roles

As your organization changes, you may find that the roles have also changed. You can reflect those changes in your setup.

Deleting or Disabling Roles

If you have routed a transaction based on a role, the application captures the history of the transaction, so you can only disable the role and not delete it.

Use the Maintain Roles window to delete and disable business group roles (choose Roles under Transaction Maintenance in the Navigator).

Use the Maintain Global Roles window to delete and disable global roles (choose Global Roles under Transaction Maintenance in the Navigator).

► To disable a role:

1. Select the role that you wish to disable.
2. Deselect the Enabled check box.
   Disabling the role disables its associated items, such as role templates, routing lists destinations, override approvers, and routing and approval rules.
   
   **Note:** If you wish to retain a routing and approval rule and change the role assigned to it, use the Transaction Type Wizard: page 2 – 104.

3. Save your work.

► To delete a role:

1. Select the role that you wish to delete.
   You can delete a role only if you have not routed a transaction that includes the role.

2. Choose the delete icon from the toolbar.
   Deleting the role also deletes its associated items, such as role templates, routing lists destinations, override approvers, and routing and approval rules.

3. Save your work.

► To rename a role:

1. Select the role that you wish to rename.
2. Place your cursor in the field, backspace to delete the current role name, and enter a different one.

3. Save your work.

Changing the role name changes all its occurrences, such as the override approver, routing and approval rules, and routing history in the transaction status window.

Changing User and Position Information Associated to a Role

You can change the role and the user information to reflect changes in your enterprise.

For example, if you need to add a user to a role because its occupant left the organization, you can disable the previous user, enable the new user, and then change the role and the user information.

Use the Maintain Roles window to change user and position information about a business group role (choose Roles under Transaction Maintenance in the Navigator).

Use the Maintain Global Roles window to change user and position information about a global role (choose Global Roles under Transaction Maintenance in the Navigator).

To add a user or position associated to a role:

1. Select the role.
2. Select the user or position from the User or Position tab.
3. Insert a new row and add the new user or position.
4. Save your work.

To disable a user or position associated to a role:

1. Select the role.
2. Select the user or position from the User or Position tab.
3. Deselect the Enabled check box.
   The application warns you if there are any pending transactions or routing and approval rules that include this user or position.
4. Save your work.

To delete a user or position associated to a role:

1. Select the role.
2. Select the user or position from the User or Position tab.

3. Delete this user or position from the list.
   
   You can delete this user or position from the list only if you have not processed a transaction that includes that person or position.

4. Save your work.
Defining Routing Lists For Transactions

A routing list establishes the sequence of destinations for routing a transaction. You can specify a group of people or a specific person as a routing destination. If you choose:

- A workflow role, users assigned to that role receive the routed transaction

  For example, if you define a workflow role HR–Compensation and then assign it to users in the Finances department, anyone assigned the HR–Compensation role may process a transaction routed to HR–Compensation.

- A workflow role and a user name, only the designated user receives the routed transaction

See: Transaction Type Wizard: page 2 – 104

Use the Routing Lists window to set up routing lists.

To define a routing list:

1. In the Routing List field, enter a name for the routing list.
   
   The application automatically checks the Enabled check box so that you can choose this routing list when setting up workflow routing in the Transaction Type Wizard.

2. Select a Role from the list of values. The list includes global roles and local roles attached to your business group. If you have set the HR: Cross Business Group profile to Yes, the list displays all of your business group’s roles, all global roles, and all roles across all business groups.
   
   The application automatically enters a routing sequence number.

3. Several users may be assigned to the same role. To identify a specific person, select a user name from the User list of values.
   
   The application automatically enables the Enabled check box to include this role and user combination.

4. Select the Approver check box to give this role and user approval rights.
   
   The role/user can approve any transaction unless you restrict the role/user’s approval rights with routing and approval rules.

5. Repeat these steps to complete the list of destinations for the routing list.

6. Save your work.
Changing Routing List Destinations

You can change a routing list, for example, by adding or changing a destination.

Use the Routing List window to change routing destinations.

To change routing destinations:

1. Query the routing list.
2. In the Routing List window, query the routing list you wish to change.
3. Select the destination that you wish to change.
4. Select a different role and user from the list of values.
5. Save your work.

Disabling Routing Lists and Routing List Destinations

If you make a change in policy that results in a different routing sequence, you can disable the unnecessary destinations and add new ones. If you make extensive changes, you might disable the routing list and define a new one.

You cannot disable a routing list or a destination on it until you update pending transactions routed using that list. Use the Transactions Status window to confirm that you have no pending or approved transactions routed using the list.


Use the Transaction Type Wizard and the Routing List window to disable routing lists and routing list destinations.
Routing Budget Worksheets and Position Transactions

When you save Position Transactions and Budget Worksheets, the application displays a routing window. Use this window to route, approve, and apply transactions as well as request notification for yourself or someone else when an event such as the transaction's update to the database occurs.

Use the Routing window for routing transactions.

To route a transaction:
1. Save the current transaction.

Routing Choices
2. On the Routing To tab, choose an action:
   • To save your transaction without routing it:
     Choose Save in Inbox to save the transaction and wait until later to resume work on it.
     Choose Save and Continue to save your work and continue entering data in the transaction.
   • To route the action to other users for further action, choose Forward.
     The application displays the next qualified destination, but you can choose a different one from the list of values.
   • To skip the next destination in the routing sequence, choose the arrow button. Continue choosing this button until you see the desired destination.
   • To return the transaction to a previous destination, choose Send Back and select the destination.
   • To refuse the transaction, choose Reject to send it back to the initiator.
     If you are the initiator, choosing Reject terminates the transaction.
   • To expedite the approval process, choose Override Approver to send the transaction directly to that user.

FYI Notifications
3. To have a notification sent to yourself or someone else, choose the FYI Notification tab.
4. Choose an Event to specify the circumstances for the notification.
   Choose:
• Approval to notify user(s) when an approver approves the transaction
• Completion when the application applies the transaction or a user terminates the transaction
• Database Failure when the transaction fails to be applied to the database due to an error
• Database success when the transaction is successfully applied to the database
• Immediate to send a notification to the selected user when you route the transaction by forwarding it or sending it back
• Override to send a notification when an override approver approves the transaction
• Rejection to send a notification when the initiator rejects (terminates) the transaction

5. Choose Type to identify the user(s) to notify. Choose:
• Approver to send the notification to the last person who approved the transaction
• Last User to send a notification to the last person who worked on the transaction
• Others to select a position, user, or role that is not part of the routing sequence
  In the dialog, enter the user name of the person who should receive the notification. The application displays the user name in the Notify column.
• Requestor to send a notification to the person who initiated the transaction

6. Choose OK.

**Approvals and Updates to the Database**

7. To approve the transaction, select the Approver check box.
   In position and supervisory hierarchies, if the transaction reaches the top of the hierarchy without anyone approving it, you can route the transaction to a subordinate for approval and update to the database.

8. To update the transaction to the database, choose Apply Transaction.
   If someone else in your organization updates transactions, you can route the transaction to that person after you approve it.
**Terminate a Transaction**

If you have approved a transaction and wish to terminate it, you can reject the transaction before updating it to the database. Rejecting the transaction returns it to the Initiator who can then reject and thus terminate it. Alternatively, you can terminate the transaction from the Transaction Status window.

Configuring Business Rules for Position Control

Predefined business rules perform validations using the information stored for position-controlled organizations and budgets. Each rule set contains one rule so that you can configure the rules separately. You can configure the business rules, but not add or delete rules. Configuring the rules involves changing the predefined status level from Warning to Ignore (allow the transaction) or Error (do not allow the transaction).

When you process a transaction for a position-controlled organization, the application determines the rule’s status level. A rule defined for an organization takes precedence over one defined at the organization hierarchy level. If the application finds no configuration rule for the organization or its organization hierarchy, the application uses the predefined status level.

The application applies business rules when certain events occur as shown in the following table. For example, when hiring someone into a position, the business rules confirm that the position is active and funded.
<table>
<thead>
<tr>
<th>Event</th>
<th>Applicable Business Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create/Modify Assignment</td>
<td>Assignment Grade Rule</td>
</tr>
<tr>
<td>Hire Applicant</td>
<td>Assignment Hire Date Rule</td>
</tr>
<tr>
<td></td>
<td>Budgeted FTE Rule</td>
</tr>
<tr>
<td></td>
<td>Filled Position Overlap Rule</td>
</tr>
<tr>
<td></td>
<td>Position Layoff Date Rule</td>
</tr>
<tr>
<td></td>
<td>Pooled Position Rule</td>
</tr>
<tr>
<td></td>
<td>Position Reservation Rule</td>
</tr>
<tr>
<td></td>
<td>Seasonal Dates Rule</td>
</tr>
<tr>
<td>Create/Modify Assignment</td>
<td>Assignment Hire Date Rule</td>
</tr>
<tr>
<td>Budget Values</td>
<td>Position Layoff date Rule</td>
</tr>
<tr>
<td>Create/Modify Assignment</td>
<td>Assignments/Positions Budget Rule</td>
</tr>
<tr>
<td>Budget Values</td>
<td>Budgeted FTE Rule</td>
</tr>
<tr>
<td>Create/Modify Budget</td>
<td>Position FTE Capacity Rule</td>
</tr>
<tr>
<td>Worksheet</td>
<td>Budget Period Rule</td>
</tr>
<tr>
<td></td>
<td>Budget Set Rule</td>
</tr>
<tr>
<td></td>
<td>Element Sum Exceeds 100</td>
</tr>
<tr>
<td></td>
<td>Element Sum Less than 100</td>
</tr>
<tr>
<td></td>
<td>Funding Source Sum Exceeds 100</td>
</tr>
<tr>
<td></td>
<td>Funding Source Less than 100</td>
</tr>
<tr>
<td></td>
<td>Under Budgeted Positions Rule</td>
</tr>
</tbody>
</table>

Use the Configuring Business Rules window to configure the business rules.

> **To configure business rules:**

1. Enter a Name for the rule set.
2. Select the Business Group.
3. Select the Referenced Rule Set to use as a basis for this rule set.
4. Enter a Short name that is unique.
   The Short name is a database key and is not translated when localizing the application.
5. Optionally, select an Organization hierarchy.
   Subordinate organizations inherit the same rule, but you can configure separate rules for organizations in the hierarchy.
6. Select an Organization to configure a separate rule for this organization.
7. Select a Level.

The level applies to all the rules included in the rule set.

- Warning warns you about an action but allows the action to proceed if you choose to continue.
  
  The system displays the warnings when you update the transaction as a series of alerts or as a list. If the transaction is deferred, the application sends an FYI Notification to the person who updated the transaction.

- Ignore allows the action to proceed and you do not see a message.

- Error displays an error message when the application runs the business rules. You cannot proceed until you correct the error.

8. Save your work.
Enabling Currencies

Oracle HRMS enables you to use multiple currencies for entering information about employee compensation and benefits. You can also record your payment methods to employees in different currencies.

For example, if you have employees living and working temporarily in other countries, you might want to record specific earnings or deductions for these employees in local currencies. You might also want to pay these employees a fixed amount into a bank account in their home currency. The remainder you would pay in a local currency.

Your startup data includes the definitions of all world currencies. These definitions are shared by all Oracle Applications and are controlled by the system administrator responsibility. You enable those currencies you want to use in the Currencies window.

Note: You must enable at least one currency as the default currency for all information related to money in your system. This default is known as the Base Currency for your Business Group.

► To enable a currency:
  - Query the currency you want to enable and check the Enabled check box. Save your choice to enable the currency.
  
  You can never delete a currency, but you can disable it.

► To disable a currency:
  - Uncheck Enabled, or enter an End Date for the currency.
Configuring, Reporting and System Administration in Oracle HRMS
Chapter 3

Security
Security

You can set up and maintain security of access for different classes of users. Once you have identified who will use Oracle HRMS, what information they require, and how they will use it, you can group together users with similar requirements and give them the same view of the system.

In what ways can you use security of access for different users?

You can set up menus using structures and names that make sense to the users. You can also restrict the data users can view and edit in certain windows, so they only see what they need to see.

This provides security for your data and an efficient interface designed for your users’ needs.

How does Oracle HRMS allow data restriction for display in a window?

If you want different users to view the same window for different purposes, you can restrict their views in different ways. For example, you can:

- Limit access to list of values for faster data entry
- Limit access to certain types of information

For example, you might create a configured version of the View Element Entry History for Employee form that does not display the earnings elements representing salary, bonus and commission. Most users’ menus would only give them access to this configured version of the form. Those authorized to view salary, bonus and commission figures can have a menu function defined to allow access to the standard version of the form.

How does Oracle HRMS enable users to view multiple Business Groups?

Oracle HRMS is installed with two security models, each enabling you to set up security for an enterprise which uses multiple business groups. Using either model you can only view records for one business group at any one time, except in cases where the HR:Cross Business Group user profile allows access to specific fields across all business groups. See: User Profiles: page 3 – 15.

The difference between the models is as follows:

- Using Standard HRMS Security you can only link one business group to one responsibility. You must set up different responsibilities for each business group.
Using Security Groups Enabled Security you can set up more than one business group for a single responsibility. However, you still only view records for one business group at a time.
Security Overview

As part of your implementation plan, you identify who will use Oracle HRMS, what information they require and how they use it.

Defining which records users are able to see and what information they see within a business group is fundamental to HRMS security.

Note: In general, a user can only view the records for one business group at a time. However, depending on the value of the HR:Cross Business Group Profile option, you can view specific information across business groups. See User Profiles: page 3 – 15 for more information.

Within a business group you can control:

- **Who** the user can access. You do this using security profiles. You can restrict access by:
  - organization hierarchy
  - position hierarchy
  - supervisor hierarchy
  - payroll
  You can also create your own custom restrictions and combine them with the standard restrictions.

- **What** the user can access. You do this using menus, windows, configurations and taskflows. You can control exactly what a user can see about the people they can access.

Key Concepts

The following definitions describe the key concepts in Oracle HRMS security.

Menu Structures

Using *menu structures*, you can limit the functions a user can access. You can also restrict access to *information types* by choosing which information types a user can view.

You can also create multiple versions of the same form, each one used for just one task. This approach restricts the list of values on certain fields and therefore provides for faster data entry. It also enables you to limit access to certain types of information.
Reporting Access

You can set up access restrictions for employees who never use the product’s windows and do not change database information, but do access the database.

Request Groups

You can specify which processes and reports a reporting user can run by setting up request groups. Within the request group, you use security profiles to restrict the records accessed by the reporting user, who may run reports against the system without having online access through the system’s forms.

Responsibility

The responsibility is your primary means of defining security. Business groups, menu structures, task flows, and information types are linked to a responsibility.

Security Groups

Security groups are a method of partitioning data. If you are using the Security Groups Enabled security model, you can manage information for multiple business groups using one responsibility. This is particularly useful if you are a Service Center. Security Groups Enabled security is also useful for organizations using Oracle Self Service HR and organizations with employees that must access and manage records from different business groups.

Security Models

The two security models, Standard HRMS Security (Security Groups Disabled) and Security Groups Enabled security (formerly called Cross Business Group Responsibility Security), both control security by restricting who and what the user can see. What differs is how you set up security, menus and how users log in. For more detailed information about each of the security models, see Security Models: page 3 – 7.

Security Processes

System security processes enable you to:

- Grant permissions to a new reporting user.
• Maintain the lists of organizations, positions, payrolls, employees and applicants that security profile holders can access.
• Set up and update your system to use the Security Groups Enabled security model.

Security Profiles

By defining security profiles, you can control access to records of employees at or above a certain level in an organization. For example, you can give a department’s administrator access to all department employee records except those of the manager and assistant manager.

User Profiles

A user profile is a set of changeable options that affects the way your application runs. You can set user profile options at site level, application level, responsibility level and user level.

You can restrict access to query—only for all or a selection of your HR and Payroll forms using a user profile option and the parameter QUERY_ONLY=YES at form function level.
Security Models

Oracle HRMS provides two different security models which enable you to set up security specifically for your enterprise: Standard HRMS security and Security Groups Enabled security (formerly called Cross Business Group Responsibility Security).

**Note:** If you want to set up security for employees who can access the database, but do not change database information, see: Reporting Access: page 3 – 40 and Setting Up Reporting Users: page 3 – 57.

A further option exists which enables users to simultaneously view selected fields from all business groups in your organization regardless of the security model. For more information see HR: Cross Business Group Profile option: page 3 – 15.

**Standard Security Model**

Standard HRMS security restricts access to your enterprise’s records and data. To set up Standard HRMS Security, you first create responsibilities and then define the windows, menus items, workflows, data and records the user can access. The System Administrator then assigns users to as many of these responsibilities as is required to complete their business tasks.

If you are using Standard HRMS Security, you must ensure that the Enable Multiple Security Groups profile option is set to the default value No. You must then create a security profile for each distinct security grouping of employees your enterprise requires.

You then create a responsibility for each user type you require, for example HR Manager, Branch Manager and Salesperson, and link the security profile and responsibility to a business group. These three elements create a security grouping to which you assign employees.
**Note:** Each security grouping you create restricts access to the business group to which the security profile and responsibility are assigned.

By assigning users to the security grouping, you grant them access to the records, menus and data defined in the security profile and responsibility. You can add further users to this security component, but you cannot re-use the security profile and responsibility within another business group.

Your enterprise can also set up request groups to restrict user access to reports and processes. The request group is associated with a security profile which defines the data a user can view, and is then assigned to a responsibility. It is also possible to set up reporting only request groups for users who access the database, but who are not permitted to change any of the records within the system.

For more information, see Setting up Standard Security: page 3 – 46.

**Access to Multiple Business Groups using Standard Security**

In Standard HRMS Security, you can grant users access to more than one business group within your enterprise. To do this, you must create security profiles and responsibilities and assign them to each additional business group. If a user’s responsibility is assigned to more than one business group, they will not be able to view data from more than one business group at any time.
Note: The HR: Cross Business Group Profile option enables users to view some limited information across all business groups within an enterprise. For more information, see HR: Cross Business Group Profile option: page 3 – 15.

Standard HRMS Security (Security Groups Disabled) is commonly used in organizations which operate within a single legislation and a single business group.

Attention: After setting up Standard HRMS Security, you can switch to the Security Groups Enabled security model. You cannot, however, revert back to Standard HRMS Security after this change has been made.

Figure 3 – 2 The Completed Standard HRMS Security Model
Security Groups Enabled Model

The main difference between the two security models is that the Security Groups Enabled model enables your enterprise to share security profiles and responsibilities between users and business groups. This reduces the set up time, and also increases the flexibility of this security model. The key to re-usability is the relationship between the security elements and the users that you create during the set up process.

Attention: Once you have set up Security Groups Enabled security, you cannot revert to Standard HRMS Security.

Access to Multiple Security Groups using Security Groups Enabled Model

The Security Groups Enabled security model enables you to assign a single responsibility to more than one business group, and hence enable users to access records from numerous business groups, although users cannot view information from different business groups simultaneously.

To set up Security Groups Enabled security, you set the Enable Security Groups Profile option to Yes, and run the Enable Multiple Security Groups process. These steps in combination create a Security Group which has the same name as the business group from which it was created. For more information, see Security Groups: page 3 – 37.

Note: To make the administration of your security setup easy to maintain, it is recommended that you leave the names of the Security Groups the same as your business groups.

Like Standard HRMS Security, your enterprise must create Security Profiles for each distinct security grouping within your enterprise. Security Profiles function slightly differently in the Security Groups Enabled model than they do in Standard HRMS security. Rather than one security profile being assigned to one responsibility, Security Groups Enabled security enables your enterprise to assign numerous security profiles to a responsibility. For example, an HR Manager and an Assistant HR Manager may be able to access the same menus and windows, but may be able to view different data. The following example illustrates the benefits of this function.
Figure 3 – 3 Assigning Multiple Security Profiles to a Responsibility

Note: The limitation of this is that a user can only be assigned one Security Profile per responsibility.

The functionality of responsibilities is also enhanced in the Security Groups Enabled security model. Increasingly, users require access to the records in more than one business group. To accomplish this, you can assign a responsibility to multiple business groups when you use Security Groups Enabled. The records, forms and type of data a user can access will be the same in each of the business groups to which they have access.

Note: When a responsibility is assigned to more than one business group, the user can only view records from one business group at any time.

The ability to assign one responsibility to multiple business groups makes the set up of security quicker and more efficient.

Note: The HR: Cross Business Group Profile Option enables users to view some information across all business groups within an enterprise. For more information, see HR: Cross Business Group Profile option: page 3 – 15.
As with Standard HRMS Security, you can set up a request group to restrict user access to reports and processes. The request group is associated with a responsibility which defines the data a user can view. It is also possible to set up reporting only request groups for users who access the database, but who are not permitted to change any of the records within the system.

Once your enterprise has defined the security profiles and responsibilities, you must assign them to the relevant security groups. The final stage is to assign users to this group of information. The example below illustrates how the final security set up may look within your enterprise.

Three distinct enterprise types can benefit from the functionality offered by the Security Groups Enabled model; Service Centers, Multinationals and SSHR enterprises. Of course, the simplified set up and maintenance is of benefit to any enterprise.

Typically, Service Centers create a new business group for each customer they serve. Furthermore, Service Centers only require one responsibility and security profile to enable users to access and change data within the system. As the Security Groups Enabled model enables sharing of security profiles and responsibilities, the security set up process for Service Centers becomes quicker and more efficient.

In the case of Multinational enterprises, it is common to create a business group for each country in which the enterprise operates, and for each legislation the enterprise uses. Using the Security Groups Enabled model enables users to share records and data across business groups and countries.
For enterprises that use SSHR within a global implementation, the advantages of using Security Groups Enabled include quicker set up and easier maintenance. An additional benefit is that transferring employees or employee information between business groups is simplified.
User Profiles

A user profile is a set of changeable options that affects the way your application runs. You can set user profiles at different levels:

**Site level**
These settings apply to all users at an installation site.

**Application level**
These settings apply to all users of any responsibility associated with the application.

**Responsibility level**
These settings apply to all users currently signed on under the responsibility.

**User level**
These settings apply to individual users, identified by their application usernames.

Values set at a higher level cascade as defaults to the lower levels. Values set at a lower level override any default from a higher level.

**Figure 3 – 6 Levels For Setting User Profile Options**

*Suggestion:* Set site-level options first to ensure that all options have a default. If a profile option does not have a default value, it might cause errors when you use windows, run reports, or run concurrent requests.

You use the System Profile Values window to set profile options at each level for your user community. If you change a user profile option value, your change takes effect as soon as your users log on again or change responsibilities.
Application users can use the Personal Profile Values window to set their own profile options at the user level. Not all profile options are visible to users, and some profile options, while visible, cannot be updated by end users. Any changes users make to their personal profile options take effect immediately.


---

### Profile Options Summary

The table below indicates whether users of the system can view or update the profile option, and at which System Administrator levels (either user, responsibility, application, or site) the profile options can be updated. These System Administrator levels are included in the table as SA User, SA Resp, SA Admin, and SA Site, respectively.

For the User column and each of the SA level columns in the table, "Yes" indicates that you can update the profile and "V" indicates that you can view the profile but you cannot update it.

A "Required" profile option requires you to provide a value. An "Optional" profile option already provides a default value, so you only need to change it if you do not want to accept the default.

### Summary of Profile Options

<table>
<thead>
<tr>
<th>Profile Option</th>
<th>User</th>
<th>SA User</th>
<th>SA Resp</th>
<th>SA App</th>
<th>SA Site</th>
<th>Required</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>AuditTrail:Activate</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>DateTrack:Date Security</td>
<td>V</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>DateTrack:Enabled</td>
<td>V</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>V</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>DateTrack:Login Date</td>
<td>V</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>DateTrack:Reminder</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Enable Security Groups</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>V</td>
<td>Yes</td>
<td>Security groups are not enabled</td>
</tr>
<tr>
<td>Help Localization Code</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>NA</td>
<td>NA</td>
<td>Yes, by HRMS</td>
<td>The Responsibility is associated with the Global set of help files rather than a localized or verticalized set.</td>
</tr>
<tr>
<td>Profile Option</td>
<td>User</td>
<td>SA User</td>
<td>SA Resp</td>
<td>SA App</td>
<td>SA Site</td>
<td>Required</td>
<td>Default Value</td>
</tr>
<tr>
<td>----------------------------------------------------</td>
<td>------</td>
<td>---------</td>
<td>---------</td>
<td>--------</td>
<td>---------</td>
<td>-----------</td>
<td>---------------</td>
</tr>
<tr>
<td>HR: Absence Duration Auto Overwrite</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>HR: Cancel Application</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Default is No.</td>
</tr>
<tr>
<td>HR: Copy period details for budget</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Default is No.</td>
</tr>
<tr>
<td>HR: Cross Business Group</td>
<td>V</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
<td>Default is No.</td>
</tr>
<tr>
<td>HR: Data Migrator Business Group Lockout</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>HR: Default Correspondence Language</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No default.</td>
</tr>
<tr>
<td>HR: Default Nationality</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR: Display Person Search</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>HR: Display Skills/Competencies</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>HR: Execute Legislative Check Formula within Run</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR: FastFormula Debug Level</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>HR: Global Competence Flex Structure</td>
<td>V</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>NA (if you want to create global competencies)</td>
</tr>
<tr>
<td>HR: Grade Key Flex–Identify 1st Segment</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR: Grade Key Flex–Identify 2nd Segment</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No default</td>
</tr>
<tr>
<td>HR: HR/Payroll Representative Source</td>
<td>V</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>No</td>
<td>No default</td>
</tr>
<tr>
<td>HR: Job Key Flex–Identify 1st Segment</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>Profile Option</td>
<td>User</td>
<td>SA User</td>
<td>SA Resp</td>
<td>SA App</td>
<td>SA Site</td>
<td>Required</td>
<td>Default Value</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>------</td>
<td>---------</td>
<td>---------</td>
<td>--------</td>
<td>---------</td>
<td>----------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td>HR:Job Key Flex–Identify 2nd Segment</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR:Job Level</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR:NI Unique Error or Warning</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR:National Identifier Validation</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Error on Fail</td>
</tr>
<tr>
<td>HR:Online Tax Forms Update Method</td>
<td>V</td>
<td>Yes</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>No</td>
<td>All</td>
</tr>
<tr>
<td>HR:OAB New Benefits Model</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR:Position Key Flex–Identify 1st Segment</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR:Position Key Flex–Identify 2nd Segment</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR:Purge Element Entry Permission</td>
<td>V</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
</tr>
<tr>
<td>HR:Query Only Mode</td>
<td>V</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>NA</td>
</tr>
<tr>
<td>HR:Security Profile</td>
<td>NA</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Default view—all security profile at Site level</td>
</tr>
<tr>
<td>HR:Use Standard Attachments</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes at Site Level, No at Seeded Responsibility Level</td>
</tr>
<tr>
<td>HR:User Type</td>
<td>V</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>NA</td>
</tr>
<tr>
<td>HR:View Payslip From Date for WEB (MM/DD/YY)</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>01/01/1997</td>
</tr>
<tr>
<td>HR:View Unpublished Employee 360 Self Appraisal</td>
<td>Yes</td>
<td>NA</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>Default value is Null</td>
</tr>
<tr>
<td>HR:Webapps Tips Test Mode</td>
<td>Yes</td>
<td>Yes</td>
<td>NA</td>
<td>NA</td>
<td>NA</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>HR:Absence View Layout</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>FORM or TABLE</td>
</tr>
<tr>
<td>HR:Applications View Layout</td>
<td>V</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>FORM or TABLE</td>
</tr>
<tr>
<td>HR:Employment View Layout</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>FORM or TABLE</td>
</tr>
</tbody>
</table>
### Profile Options

**AuditTrail:Activate**

When you enter or update data in your forms, you change the database tables underlying the forms you see and use.

AuditTrail tracks which rows in a database table were updated at what time and which user was logged in using the form(s).

You can turn AuditTrail on or off (Yes or No). The default setting is No. You must set this option to Yes before you can audit any Oracle Applications table.

**DateTrack:Date Security**

Controls the way users can change their effective date:

- **All** (users can change to any date)
- **Past** (users can change to dates in the past only)
- **Present** (users cannot change their effective date)
- **Future** (users can change to dates in the future only)

The meaning of Past and Future here is with respect to the user’s login date, which is usually today’s date, but may be set to another value by the DateTrack:Login Date profile option.

**DateTrack:Enabled**

Set to Yes at Application level for Oracle HRMS.

**DateTrack:Login Date**

Normally a user logs onto the system with an effective date of today’s date. Use this profile option to change a user’s default date to another
date. This profile option works in conjunction with DateTrack:Date Security. For example, if a user has DateTrack:Date Security set to Future and DateTrack:Login Date set to 1900/01/01, they can change their effective date to any date after January 1 1900, but not before.

**DateTrack:Reminder**

Determines whether the Decision window appears when you open a window in which you can enter, update, or delete datetracked information. Notice that the Decision window never appears on windows where you can query datetracked information but not update it. There are three possible values:

- **Always** (the window always appears)
- **Never** (the window never appears)
- **Not Today** (the window appears only if the effective date is not the system date)

**Enable Security Groups**

Controls whether you use security groups within security. Only change the default Yes at application level if your enterprise is using Security Groups Enabled security. If you change the default to Yes, you must run the Enable Multiple Security Groups process.

**Note:** Non HRMS applications do not support multiple security groups in Release 11i.

**Help Localization Code**

Controls which set of help files are linked to each responsibility. If you accept the default, then the set of help files for Global HRMS will be associated with the responsibility. However, if you want to specify a legislative or vertical variant of HRMS you must set the Help Localization Code as follows:

- AU for Australia HRMS Help
- BE for Belgian HR Help
- CA for Canadian HRMS Help
- FD for US Federal HR Help
- FR for French HR Help
- IE for Irish HRMS Help
- IT for Italian HR Help
• JP for Japanese HRMS Help
• NL for Netherlands HR Help
• NZ for New Zealand HRMS Help
• SG for Singapore HRMS Help
• UK for UK HRMS Help
• US for US HRMS Help

These entries must be in upper case.

**HR: Absence Duration Auto Overwrite**

Controls whether the absence duration formula automatically recalculates the duration of an absence when the date or time of the absence is changed. Set to Yes if you have created an absence duration formula (or one is supplied by your localization team) and you want absence durations to be recalculated automatically.

**HR: Business Group**

This is view only. Determines the business group linked to a responsibility. The Setup Business Group is defaulted at Site level.

If you use Security Groups Enabled security this option is automatically set up when you create a security profile assignment.

If you use Standard HRMS security this option is automatically set up when you enter the HR:Security Profile profile option.

**HR: Cancel Application**

This profile option enables you to delete an applicant’s record that has been entered in error. The default value is set to Null, this is interpreted as No and the function will not work.

**HR: Copy Period Details for Budget**

You use this user profile option for HRMS budgets. When you set the profile option to Yes, the application copies all budget details (budget periods, budget sets, and funding sources) to a new budget worksheet when the worksheet is a copy of an existing budget version.

**HR: Cross Business Group**

This user profile option:
- Enables benchmark jobs to be selected from other business groups
- Issues an error about the uniqueness of job names across all business groups
- Enforces that there can only be one master job group
- Enables global competencies and rating scales to be created.
- Controls whether users can select people from other business groups in the following fields:
  - Absence: authorizing person, replacement person
  - Applicant Assignment: recruiter, supervisor, referred by
  - Assignment: supervisor
  - Requisitions and Vacancies: requisition raised by, recruiter
  - Recruitment Activity: authorized by, internal contact
  - Events: event participants, internal contact person
  - Employee review: reviewers
  - Termination: accepted by

**Note:** If the HR: Cross Business Group option is set to No, HRMS Secure views accessed through a view—all security profile will automatically restrict the data you can see according to your HR: Business Group profile option setting.

Set to Yes if users need to share this information across all business groups. Set to No if users only work with the information defined for one business group. The default is No.

**HR:Data Migrator Business Group Lockout**

This profile option is for a future release.

**HR:Default Correspondence Language**

Specifies a default language for the Correspondence Language field. This profile option is for users of the Italian legislation only.

**HR:Default Nationality**

Defines the default nationality for a user. When a new person is entered in the People window, the nationality entered here is automatically displayed in the Nationality field.
**HR:Display Skills/Competencies**

Controls the display of competencies in an Advanced Search. It is used to control the display of skill categories in:

- Apply for a Job
- Enroll in a Class

This User Profile Option is used in SSHR.

---

**HR:Execute Legislative Check Formula within Run**

Determines whether the legislation–specific check is performed during a payroll run.

---

**HR:FastFormula Debug Level**

Enables debugging information to be output from the FastFormula compiler and execution engine.

---

**HR:Global Competence Flex Structure**

Defines the competence key flexfield structure to be used when creating global competencies. If you do not have a value in this field then you will not be able to create global competencies.

---

**HR:Grade Key Flex–Identify 1st and 2nd Segments**

These options are used to control which two segments of the key flexfields appear in Person Search.

This User Profile Option is used in SSHR.

---

**HR:HR/Payroll Representative Source**

SSHR offers three methods for determining an organization’s default payroll representative:

- From Payroll (Additional Information).
- From GRE (Organization Information).
- From custom (PL/SQL) code.

---

**HR:Job Key Flex–Identify 1st and 2nd Segments**

These options are used to control which two segments of the key flexfields appear in Person Search.
This User Profile Option is used in SSHR.

**HR:Job Level**

The job level options are used to determine the seniority of a person’s job. You can set a default for the job level at Site, Application and Responsibility level.

**HR:NI Unique Error or Warning**

Enables you to change the default warning to an error message.

If you want to warn users that the national identifier they have entered already exists, leave the default as warning. If you want to prevent a user entering the same national identifier more than once, you can change the message to an error. This stops the user entering the same national identifier.

**HR:National Identifier Validation**

Enables you to define the validation that is used for a national identifier. There are three possible values:

- **Error on Fail** (default value). If a user enters an invalid national identifier, an error message is displayed and the user cannot save the national identifier until they have entered it in the correct format.

- **Warning on Fail**. If a user enters an invalid national identifier, a warning is displayed, but the user can save the national identifier.

- **No Validation**. A user can enter and save the national identifier in any format. No validation is performed and no message is displayed.

**HR:Online Tax Forms Update Method**

SSHR supports multiple assignments per person, and keeps tax information per assignment. Since a person can file only one withholding form, however, SSHR offers three options to handle multiple assignments:

- **Primary**. Updates primary assignments only.

- **All** (default value). Updates all assignments.

- **None**. Disables self-service updates.
HR:OAB New Benefits Model

Enables you to set up whether you are using the new benefits model, that is, Standard or Advanced Benefits. Enter Yes, if you are using the new benefits model. Enter No, if you are using the compensation and benefit models from previous releases.

HR:Position Key Flex–Identify 1st and 2nd Segments

These options are used to control which two segments of the key flexfields appear in Person Search.

This User Profile Option is used in SSHR.

HR:Purge Element Entry Permission

Controls whether users can purge element entries (irrespective of whether those entries have been processed by a payroll run). It does not affect a user’s ability to perform datetracked deletions or updates. The possible values are:

- **All** (the user can purge all element entries)
- **Information** (the user can purge only informational (non-payment) element entries)
- **None** (the user cannot purge any element entries)

**Note:** If you have installed a third party payroll interface, you cannot purge any element entries attached to the interface. If you are using a setting of **All** or **Information**, an error message to this effect appears when you attempt to purge an element entry.

HR:Query Only Mode

Set to Yes to restrict access to view–only for all HR and Payroll forms on a menu.

You can set this profile for individual responsibilities or users, or at the site or application level.

If you want to give query–only access to some forms and full access to other forms, set the HR:Query Only Mode profile to No and use the parameter QUERY_ONLY=YES at form function level to restrict access to individual forms.

**Note:** You can set the parameter QUERY_ONLY=YES for a form function that also launches a task flow. In this case, specify two parameters in the Form Function window:
QUERY_ONLY=YES
WORKFLOW_NAME="task flow name"

The entire task flow will be query–only, not just the first form.


**HR:Security Profile**

Restricts access to the organization, positions and payrolls defined in the security profile. This option is predefined at Site Level with the view–all security profile created for the Startup Business Group.

If you use Standard HRMS security you must set up the HR:Security Profile profile option for each responsibility.

If you use Security Groups Enabled security you must **not** set up the HR:Security Profile profile option. This is set up automatically when you assign security profiles using the Assign Security Profile window. You must only change the HR:Security Profile option by assigning a different security profile to a responsibility using the Assign Security Profile window.

**HR:Use Standard Attachments**

Disables the facility to attach short text comments to records. Enables the attachment of multiple items of various types including OLE objects, Web pages, images, and word processed documents.

**HR:User Type**

Limits field access on windows shared between Oracle Human Resources and Oracle Payroll. If you do not use Oracle Payroll, it must be set to HR User for all responsibilities.

If you do use Oracle Payroll, you can give each Responsibility one of the following user types, depending on the work role of the holders of the responsibility:

- HR User
- HR with Payroll User
- Payroll User

**HR:View Unpublished Employee 360 Degree Self Appraisal**

Enables a manager to view their employee’s unpublished 360 Degree self appraisals. Set the profile option to Yes to view an employee’s unpublished 360 Degree self appraisals. The default value is Null.
This User Profile Option is used in SSHR.

**HR: Webapps Tips Test Mode**

Forces all tip icons in SSHR to be displayed whether tip text is defined or not.

This User Profile Option is used in SSHR.

**HR: View Payslip From Date for WEB**

Limits the number of pay periods an employee can view.

This User Profile Option is used in SSHR.

**HR: Absence View Layout**

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.

**HR: Applications View Layout**

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.

**HR: Employment View Layout**

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.

**HR: Performance View Layout**

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This Profile Option is used in SSHR.

**HR: Salary View Layout**

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.
HR:Training View Layout

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.

HR:Views Layer Size

Enables you to set the width of the Employee Name and Employee Number floating layer to the longest name and number you have.

This User Profile Option is used in SSHR.
Security Profiles

The security profile determines which applicant and employee records are available to holders of the responsibility it is linked to.

Using HRMS Standard security, you set up a security profile for one responsibility using the HR:Security Profile profile option.

Using Security Groups Enabled security, you link a security profile to the user’s responsibility and business group using the Assign Security Profile window. You can also link more than one security profile to a responsibility, as long as the user is different. This saves you setting up a new responsibility for each security profile you use.

Note: If you are using the Security Groups Enabled security model you must not use the HR:Security Profile profile option. This is automatically set up when you assign security profiles using the Assign Security Profile window.

You set up a security profile by identifying records of employees and applicants in the system which you want users to be able to access. You identify the records by selecting work structures or other categories in the system to which employees or applicants are attached. For example, you could give users access only to the records of employees or applicants in a single organization.

You can combine different types of restriction to create a set of rules giving exactly the security access permissions you require.

When you create a business group a view—all security profile is automatically created. The security profile provides access to all employee records, and all applicant records in the business group. The system administrator links this view—all profile to users who are setting up the system. They in turn can set up security for other users.

The criteria you can use to identify records are:

Internal Organizations and Organization Hierarchies

Organizations include structures like departments, sections, groups and teams.

Positions and Position Hierarchies

Positions are jobs performed within specified organizations.

Payrolls

You can restrict access to employee records by payroll. For example, you can give payroll staff who work on the payroll at a particular location access to records of employees on this payroll only.
Controlling security by payroll assignment limits the employee records users can see and update on employee–related windows, such as those for employee information, and element entry.

Of course, if an employee assignment does not include a payroll, payroll security cannot apply to this assignment. Payroll security also applies to applicants if they are assigned to a payroll.

The windows for compensation definition are unrelated to any particular employee records or payroll assignments. Therefore limiting access by payroll does not affect users’ access to these windows.

**Supervisors and Supervisor Hierarchies**

The supervisor for an employee or applicant is the person identified in the Supervisor tab of the Assignment window. Supervisor profiles are dynamic, in that they do not have to specify a particular person or hierarchy level. You can therefore set up a single security profile and use it for multiple users, who will each be able to access a different set of records depending on their own location in the hierarchy.

*Note:* When you set up security based on supervisor hierarchies, the list of employees visible to a user is generated at the start of the session. For supervisors with a large number of subordinates (for example, at higher management levels) this may result in a delay in generating the list. You can improve performance by limiting the number of hierarchy levels a supervisor can access. Alternatively, for the highest levels of management, consider setting up security using organization hierarchies.

**Custom Restrictions**

You can set up your own restrictions using SQL statements (for example, you might want to create a restriction allowing users access only to temporary part–time employees). Your custom restriction statements are automatically validated by the system. Valid restrictions are incorporated in the security profile, further restricting the list of employees and applicants specified using any of the other methods mentioned above.

*Attention:* Custom restrictions further restrict employees and applicants only; they have no effect on people with a system person type of Other.
Global Security Profile

If you use an application other than Oracle HRMS, for example, Oracle CRM, then you can create global security profiles that enable users to work on organizations in multiple business groups.

You do this by setting up a global hierarchy, which can contain organizations from any business group on your database, and associating it with a global security profile. This enables you to create a security hierarchy that gives users access to organizations across business groups.

If you want to read more information about organization hierarchies, see Organization Hierarchies, *Using Oracle HRMS – The Fundamentals*.

If you use the Oracle HRMS Professional Forms Interface, then you cannot access data across business groups using one responsibility, even if you associate a global security profile to your responsibility. Your access is limited to organizations in the business group defined in the HR:Business Group profile option.
Responsibilities

You can control users’ access to human resources information by record, window and function.

The responsibility is your primary means of defining security. To define what a user can access you link a user, responsibility and Business Group to a security profile. Other important components of the responsibility are the menu structures, task flows and information types. These also help you limit the employee records a user can access.

Users can sign on to the system only through the responsibilities you give them. So their responsibilities control what they can see and do in the system.

Responsibility

A responsibility is linked to a security profile and composed of:

- A menu structure
- A request group for reporting users (optional)
- Extra information types available to the user

Responsibilities are also linked to business groups. However, depending on which security model you use, you link responsibilities differently.

- Standard HRMS Security
  You can only link one business group to one responsibility using Standard HRMS security. You must set up different responsibilities for each business group.

- Security Groups Enabled Security
  You can enable more than one business group for a single responsibility. However, you still only view records for one business group at a time.

Each model enables you to set up multiple responsibilities. You can assign multiple responsibilities to users who need to:

- Access applicant and employee records from two or more security profiles.
- Use more than one menu structure to view or make changes to the records they can access.
- Access records for more than one business group if you use Standard HRMS security. For example, an enterprise with
international operations may have a US–Based business group and a UK–Based business group. A few of your employees might need to access both.

Access Control Through Responsibility

The following key components help control user access to Oracle HRMS:

- **Security profiles** determine the organizations, positions and payrolls whose applicant and employee records responsibility holders can access.

- **Business Groups** determine the set of records a user can access. Using Security Groups Enabled security you can enable one responsibility for many business groups. Using Standard HRMS security you must set up a new responsibility for each business group.

- **Menu structures** and functions control:
  - The particular windows a responsibility holder can access
  - Whether he or she can perform data entry, change or deletion on these windows

You can produce configured versions of some windows. Each configured version enables access to a subset of certain types of information, such as person types, special information types, or elements. You define additional menu functions to call configured windows or task flows, and then you add these functions to a menu structure, which is linked to a responsibility.

- **Request groups** determine the group of processes and reports a responsibility holder can initiate. A request group is an optional component of a responsibility. If holders of a responsibility should not initiate any reports or processes, you do not include a request group in the responsibility.

- **Extra Information types** are an optional component of a responsibility. By defining which extra information types are included in a responsibility, you effectively create a configured version of a window for users who are assigned the responsibility.

  **Attention:** If you do not associate any extra information types with a responsibility, a person assigned to this responsibility will not have access to any extra information types in the product.

For each responsibility, you must also define the user profile option HR:User Type.
Menu Structure

Users access standard windows, configured windows, and the first window in a task flow through the menu structure displayed in the Navigator window. Each responsibility includes a menu structure to restrict the windows users can access, and what they can do on these windows.

A function is a part of an application’s functionality that is registered under a unique name for the purpose of assigning it to, or excluding it from, a responsibility. There are two types of functions: form functions, and non-form functions. For clarity, we refer to a form function as a form, and a non-form function as a subfunction, even though both are just instances of functions in the database.

Using Function Security system administrators can further restrict access to individual menu options. You can include:

- Standard windows, displayed in edit or view–only mode
- Configured windows, on which you have restricted the range of data that can be displayed
- The first window in task flows that link a number of windows that are used in sequence to complete a task

By defining menus with function security for groups of users, you can:

- Limit the range of information users can access for the applicant and employee records available to them
- Improve users’ efficiency in using the system by reducing menu choices
- Restrict users to query–only access to some or all windows

Each responsibility you define must be linked to a root menu. The root menu lists the menu options when the Navigator window first opens.

The Default Menu Structure

The AutoInstall program creates a default menu structure for your HRMS product. This menu structure lets you access all of the windows for your system. Normally, only a system administrator has access to the full default menu structure.

The supplied menus give you access to all of the available submenus. However, a number of predefined functions are not enabled on these menus. You need to add them for the responsibilities that should have access to these functions.
• HR View Medical
  This causes the Medical Information tabbed region to display in the People window.

• HR View Background
  This causes the Background Information tabbed region to display in the People window.

• HR View Benefits
  This causes the Benefits tabbed region to display in the People window.

• HR View Rehire
  This causes the Rehire Information tabbed region to display in the People window.

• Salary Administration: Approve
  This enables the user to approve salary proposals in the Salary Administration window and the Salary Management folder.

• HR View Projects Information
  This causes the Projects Information tabbed region to display in the Assignment window. You must have Oracle Projects installed to display this region.

⚠️ **Warning:** Oracle HRMS with DateTrack and task flows does not fully support multiple active windows. When you define a new menu for use with Oracle HRMS the top menu must include the following function as a separate menu option:

Disable Multiform
Request Groups

When you build a responsibility for employees who must initiate reports or processes, you can attach a request group to the responsibility. The request group lists a group of processes and reports its holders can run. Holders of responsibilities with no request groups cannot run any processes or reports.

The group Reports and Processes gives access to all predefined reports and processes.
Security Groups (Security Groups Enabled Model Only)

When you use the Security Groups Enabled security model (formerly called Cross Business Group Responsibility security), a security group is automatically created for each business group when you run the Enable Multiple Security Group Process. Because security groups are tied to business groups by set up, partitioning data using this method is the same as partitioning data by business group. See: Setting Up Security Groups Enabled security: page 3 – 48.

**Attention:** Security groups are only used if you have set up your enterprise using the Security Groups Enabled security model.

Security groups are the key component in Security Groups Enabled security. They enable you to set up one responsibility and link this to a number of different business groups.

Before you can start using this security model you ensure that HRMS is set up to use security groups. To do this you set the Enable Security Groups profile option to Yes and run the Enable Multiple Security Group process.


Once you have set up your enterprise to use security groups, Oracle HRMS automatically creates a security group when you set up a business group. The security group has the same name as the business group. For example, if you create a business group called UK Headquarters, Oracle HRMS automatically creates a security group called UK Headquarters. The Setup Business Group, however, uses the predefined security group Standard.

**Note:** If you change the name of your business group, the security group name is not updated. To make the maintenance of your security setup easier, Oracle recommends that you leave the names of the security groups the same as the business groups from which they are created.

Using the Assign Security Profile window you link the user, responsibility and business group to a security profile. By entering a business group you are automatically linking the responsibility to the security group.

You then log on using the responsibility and security group pairing. As security groups are automatically linked to a business group, you can then view and manage the records for that business group.
When you log on, Oracle HRMS displays all the pairings you have created between business groups and responsibilities. You could have the same responsibility listed twice with different security groups and therefore business groups. By looking at the security group you can select the correct responsibility for the business group you want to access.

To ensure the integrity of your business data, you can only view records for one business group at any time. To view records from a different business group you must switch to an alternative responsibility and business group pairing.

**Attention:** Security groups are automatically created for you when you use Oracle HRMS. Do not use the System Administrator’s Security Groups window to add security groups as these will not be linked to your business groups.

**Example**

If your user is set up with a responsibility called HRMS Manager you could link this to:

- UK Headquarters (business group)
- Scotland Operations (Security Profile)

Using the same responsibility (HRMS Manager), you could also link to a different business group:

- Canadian Headquarters (business group)
- Vancouver Operations (Security Profile)

Therefore, you only need to set up one responsibility (HRMS Manager) but you can enable two business groups (UK Headquarters and Canadian Headquarters).

When the business group UK Headquarters was set up, a security group UK Headquarters was automatically created. When you linked the business group to the user’s responsibility, the security group UK Headquarters would also be linked.

To view the records for business group UK headquarters you would select the HRMS Manager responsibility and the UK Headquarters security group.

If you then wanted to view the records for the Canadian Headquarters business group you would switch responsibility and security group pairing, selecting the same responsibility (HRMS Manager) and the Canadian Headquarters security group.
Categorizing Information By Security Groups

**Attention:** You can only categorize information by security groups if you are using Security Groups Enabled security.

You can categorize the following information within your enterprise using security groups:

- **Lookups**
  
  Using the Application Utilities Lookups window you can set up lookups specifically for a security group. These lookups are only available to users who access the business group associated with the security group.

  See: Adding Lookup Types and Values: page 1 – 73.

- **Concurrent Programs**
  
  Using the Concurrent Parameters Program window you can enter a security group against a concurrent program, this creates a specific list of concurrent programs for a security group and therefore business group. When a user selects a concurrent program using the Submit Request window, they can select from the concurrent programs for their business group.

  **Note:** You do not have to enter a security group against all the concurrent programs. Concurrent programs which are not linked to a security group display for all security groups/business groups.

Reporting Access

Oracle HRMS enables you to set up reporting users who can query and report on the information in the database, but cannot insert, update or delete information. Reporting users can use Oracle tools, or other tools connected to the Oracle database, to report on information. Regardless of the tools used to access the database, reporting users can only read information, they cannot update information.

Using Oracle HRMS you can set up similar security restrictions to users who can update, insert or delete information. This ensures reporting users can only query and report on appropriate records.

All secure users connect to the APPS ORACLE ID. This is created when the system is installed. However, for reporting users, you should create one or more new reporting user ORACLE IDs. By associating these with a restricted security profile you can control whose records a reporting user can access.

You can make any of your restricted security profiles available not only for regular users, but also for reporting users. The security profile restricts a reporting user’s access to employee records in exactly the same way as it limits regular users’ access.

Reporting users can see all the details about the records they can access. To restrict the access of what a reporting user can view you must use view–based accesses. To support this need of reporting users you can use third party reporting tools to create business views.

For information about how to set up database access without on-line access, see: Setting Up Reporting Users: page 3 – 57.
Security Processes

There are four system security processes:

- **Enable Multiple Security Groups**
  Run this process when you first set up Security Groups Enabled security.

- **Generate Secure User**
  Run this process when you create a new security profile that references a reporting user.

- **Security List Maintenance**
  Run this process every night.

You run these processes using a system administrator responsibility from the Submit Requests window.

- **Grant Permissions to Roles**
  This process is run automatically as part of the autoinstall process.

**Enable Multiple Security Groups Process**

You must run the Enable Multiple Security Groups process if you set the Enable Security Groups profile to Yes. This process must be run when:

- You set up Security Groups Enabled security for the first time to ensure HRMS is enabled to use security groups and all the Security Groups Enabled security features.
- You change from Standard HRMS security to Security Groups Enabled security. This ensures that all your existing business groups have security groups and all the Security Groups Enabled security features are enabled.

**Generate Secure User Process (SECGEN)**

This process grants permissions to new reporting users. It grants the "hr_reporting_user" role to the REPORTING_ORACLE_USERNAME specified in the security profile.

Run this process when you have created a new security profile that references a reporting user. In the Submit Requests window, select the name of the new security profile. This is the only parameter for the process.
Security List Maintenance Process (LISTGEN)

This process maintains the lists of organizations, positions, employees and applicants that security profile holders can access. You should schedule it to run every night to take account of changes made during the day. If a disruption, such as a power cut, occurs while the process is running, you can manually restart it from the Submit Requests window.

There are no required parameters for this process. If you do not enter a date it defaults to the effective date. You can enter a security profile name to generate list entries for that security profile only.

**Attention:** LISTGEN should normally run when there are no users logged on to the system. Users attached while LISTGEN is running may experience unexpected results; for example, additional employees may become visible or previously visible employees may disappear from view.

Grant Permissions To Roles Process (ROLEGEN)

All reporting users in the system share access to a set of public synonyms for tables and views. Reporting users are granted permissions to make them usable. The Grant Permissions To Roles process creates these public synonyms and grants permissions to them.

**Attention:** The Grant Permissions to Roles process is unrelated to setting up workflow roles for Oracle products that support security by workflow.

This process is automatically run as part of the autoinstall process when you install HR, or when you upgrade the system.

The process creates public synonyms for each of the required HR objects and then grants SELECT permissions to the role ‘hr_reporting_user’. Permissions are not granted on the secured tables, but only on the secure views of those tables. All permissions previously granted to the role are revoked before the new grants are made. This ensures that the correct grants exist for the valid HR objects.
Security Profiles by Organization and Organization Hierarchy

To set up a security profile that permits access to employee records of certain organizations only, you make use of organization hierarchies. You can build any number of additional hierarchies to meet your security requirements.

For example, suppose you build this Sales Organization hierarchy:

![Sales Organization Hierarchy Diagram](image)

You can create a security profile that permits access to employee records throughout the sales organization. This profile references the Sales Organization hierarchy. It names the Sales Department as the highest organization in the hierarchy through which profile holders have access to employee records.

Next, you want the directors of the two sales regions to have access to all employee records in their region only. You create Eastern and Western Sales Director security profiles. These profiles also reference the Sales hierarchy. But, they name the Eastern and Western Regions, respectively, as the top organizations for these profiles’ access to employee records.

When you name an organization as the top organization, you specify whether it is inclusive or not. You must include the top organization if you want holders of the profile to access records of people assigned to the top organization.
Security Profiles By Position and Position Hierarchies

After establishing limits on record access using organization hierarchies, you can further restrict access by means of position hierarchies.

Suppose, for example, within the Sales Department, you want to give the Sales Research Director access to her subordinates’ records only. You can start by building the following Sales Positions Hierarchy:

Figure 3 – 8 Sales Positions Hierarchy

Now you create the Sales Research Director security profile. This profile references the Sales Positions hierarchy and names the Sales Research Director as the top position for access to employee records.

<table>
<thead>
<tr>
<th>Security Profile:</th>
<th>SALES RESEARCH DIRECTOR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organization Hierarchy:</td>
<td>Sales Organization</td>
</tr>
<tr>
<td>Top Organization:</td>
<td>Sales Department</td>
</tr>
<tr>
<td>Position Hierarchy:</td>
<td>Sales Positions</td>
</tr>
<tr>
<td>Top Position:</td>
<td>Sales Research Director</td>
</tr>
<tr>
<td>Include Top Position:</td>
<td>Yes</td>
</tr>
</tbody>
</table>

When you give the Sales Research Director a responsibility including this security profile, she can access the records of her subordinates. But, she cannot access records of the:

- VP or Associate VP of Sales
• Regional Sales Director
• Regional Sales Director’s subordinates

As with organization hierarchies, you can specify that profiles do not include access to the top position.
Setting Up Standard HRMS Security

Use the following setup steps if your enterprise sets up a different responsibility for each business group.

1. Ensure that the Enable Security Groups profile option is set to No at site and application level, using the System Profile Values window.
   
   If this option is set to Yes then you are not using Standard HRMS security.
   

2. Define a Security Profile: page 3 – 50
   
   **Note:** For each restricted security profile you create that references a reporting user, you must run the Generate Secure User (SECGEN) process. This is a one-off process that is not required for view–all security profiles.

3. Ensure required functions or menus are set up.
   
   This is required for the responsibility. For menu functions calling configured forms or task flows, you must enter a parameter in the Parameter field of the Form Functions window.
   
   See: Defining Menus: page 3 – 60

4. Ensure required request group is set up.
   
   You can define the groups of standard reports and processes that a user can run from the Submit a New Request window. Every responsibility can have access to one request group.
   
   Use the Request Groups window.
   

5. Define a responsibility using the Responsibility window.
   

6. Set the HR User Profile Options for the new responsibility using the System Profile Values window. You must set up the:
   
   • HR: User Type
   
   Use this profile option to limit field access on windows shared between Oracle Human Resources and Oracle Payroll.
• **HR:Security Profile**

  Enter the security profile for the responsibility. This must be set up at responsibility level, otherwise the default view—all security profile is used. Using Standard HRMS security you can only set up one security profile for a responsibility.

• **HR:Cross Business Group Profile**

  This option enables you to view some information across all business groups within your enterprise.

You can set also set up other User Profile Options.

See: System Profile Value Window, *Oracle Applications System Administrator’s Guide*

7. Create the username and password using the User window.

   Link the user to as many responsibilities as they need using the User window.

   **Attention:** Do not use the HRMS Assign Security Profile window if you are setting up Standard HRMS security.

   See: Users Window, *Oracle Applications System Administrator’s Guide*

8. Run system security process using the Submit Request window:

   • **Security List Maintenance**

     Ensure this process is run every night.

   See: Submitting a Request, *Oracle Applications User’s Guide*
Setting Up Security Groups Enabled Security

Use the following setup steps if your enterprise wants to enable many business groups for one responsibility. This type of security is most commonly used by Service Centers.

**Note:** You only only need to perform steps 1 and 2 when you first implement Oracle HRMS security. You can perform the other steps at any time.

You can update your security model from Standard HRMS Security to Security Groups Enabled security by following these steps.

**Attention:** Once you have changed to Security Groups Enabled Security you *cannot* revert to the Standard Security model.

To set up users for Security Groups Enabled Security:

1. Set the Enable Security Groups Profile Option using the System Profile Values window.
   
   Ensure the Enable Security Groups profile option is set to Yes at the application level.
   
   **Note:** If this option is set to No then you are not using Security Groups Enabled security.
   

2. Run the Enable Multiple Security Group Process using the Submit Request window.

   You must run the Enable Multiple Security Group process to set up Oracle HRMS to use security groups.


3. Define a Security Profile: page 3 – 50

   **Note:** For each restricted security profile you create that references a reporting user, you must run the Generate Secure User (SECGEN) process. This is a one off process that is not required for view all security profiles.

4. Ensure that the functions or menus you require are set up.

   This is required for the responsibility. For menu functions calling configured forms or task flows, you must enter a parameter in the Parameter field of the Form Functions window.

   See: Defining Menus: page 3 – 60

5. Ensure that the request group you require is set up.

   You can define the groups of standard reports and processes that a user can run from the Submit a New Request window. Every responsibility can have access to one request group.
Use the Request Group window.
See: Request Group window, Oracle Applications System Administrator’s User’s Guide.


7. Set the HR User Profile Options for the new responsibility using the System Profile Values window. You must set up the HR: User Type option.
You can also set the HR:Cross Business Group Profile option. This enables you to view some information across all business groups within your enterprise. See HR:Cross Business Group Profile for more information.

**Note:** For Security Groups Enabled security do *not* set up or amend the HR:Security Profile profile option using the System Profile Values window. To set up or change this profile option use the Assign Security Profile window.
You can set also set up other User Profile Options.
See: System Profile Value Window, Oracle Applications System Administrator’s Guide

8. Create usernames and passwords using the User window.

**Attention:** Do not link responsibilities and security groups (business groups) to users in this window, use the Assign Security Profile window. If you do enter a responsibility and security group in this window, you still need to use the Assign Security Profile window, to link your user to a responsibility and security profile. If you do not use the Assign Security Profile window, the default view—all security profile is used and your user will be able to see all records in the business group.
See: Users Window, Oracle Applications System Administrator’s Guide

Associate a security profile with a user, responsibility and business group using the Assign Security Profile window.

10. Run system security process using the Submit Request window:
• Security List Maintenance
  Ensure this process is run every night.
See: Submitting a Request, Oracle Applications User’s Guide
Defining a Security Profile

You can define security profiles in the Security Profile window (to give access to a single business group) or the Global Security Profile window (to allow users to access records from more than one business group).

Note: Using the Global Security Profile window does not give Oracle HRMS users access to records from multiple business groups within the same responsibility; users must still switch responsibilities to see records from different business groups. However, HRMS users can see a restricted set of information in records from more than one business group within a single responsibility if the HR:Cross Business Profile profile option is set to Yes.

If you want to associate a reporting user with the new security profile, the ORACLE database administrator must create a new reporting user ORACLE ID. The system administrator must register the new ORACLE IDs as restricted privilege users with the Application Object Library.

To define a security profile:

1. Enter a name for the security profile.
2. If you are using the Security Profile window, select a business group. Users will have access only to records within this business group. This does not need to be the business group associated with your responsibility.
   If you are using the Global Security Profile window, users will have security access to records from all business groups, subject to other restrictions.
3. If you want reporting users to be able to use this security profile, select the Reporting User name for the ID set up by the database administrator (this option is not available when setting up Global Security).
4. You can choose to apply the security restrictions you set up only to employees, only to applicants, or to both. For example:
   • If you want the security restrictions to apply to employees, select Restricted from the View Employees box.
   • To ignore the security restrictions for employees and allow access to all employees, select All from the View Employees box.
   • To prevent access to any employee records, even if the other security restrictions allow access, select None from the View Employees box.
You can set the View Applicants options independently, giving different security access to employees and applicants using the same security profile.

**Allowing Access to Granted User Records (SSHR only)**

5. Check the Allow Granted Users box to allow a self-service user with this security profile to access the records of other self-service users, provided that the other users grant them access using the self-service application.

   **Note:** This setting applies to the self-service application only and has no effect on users of Oracle HRMS.

**Restricting Access by Organization**

6. In the Organization Security tabbed region, uncheck the View All Organizations check box. Select an organization hierarchy, and a top organization. Check the Include Top Organization check box if you want to allow access to this organization.

7. By default, the Exclude Business Groups check box is unchecked, giving users access to the business groups themselves, and therefore to employees or applicants who have the business group(s) as their organization. Check the box to prevent access to the business group(s) and the employees or applicants attached to them (for example, to prevent users from seeing new starters and other employees who have been assigned to the business group by default).

**Restricting Access by Position (not Global Security)**

8. In the Position Security tabbed region, uncheck the View All Positions check box. Select a position hierarchy, and a top position. Check the Include Top Position check box if you want to allow access to this position.

**Restricting Access by Payroll (not Global Security)**

9. In the Payroll Security tabbed region:
   - To give access to all payrolls, check the View All Payrolls check box.
   - To give access to many payrolls, uncheck the View All Payrolls check box, and uncheck the Include check box. Select the payrolls you want to exclude.
   - To give access to a small number of payrolls, uncheck the View All Payrolls check box, and check the Include check box. Select the payrolls to include.
Restricting Access by Supervisor

10. In the User–Based Security tabbed region, check the Restrict by Supervisor check box, and enter the number of levels of access you want to allow the supervisor to see in the Maximum Hierarchy Levels box (or leave the field blank to allow access to all levels).

   **Note:** When you set up security based on supervisor hierarchies, the list of employees visible to a user is generated at the start of the session. For supervisors with a large number of subordinates (for example, at higher management levels) leaving the Maximum Hierarchy Levels box blank may result in a delay in generating the list. You can improve performance by limiting the number of hierarchy levels a supervisor can access. Alternatively, for the highest levels of management, consider setting up security using organization hierarchies.

11. By default, the Primary Assignments Only check box is unchecked, giving users access to people who report to them in any assignment. If you only want to give users access to people who report to them in their primary assignment, check this box.

12. By default, the list of people whose records are accessible using supervisor–based security changes with the user name of the person who logs in. If you want the supervisor hierarchy to be based on a specific person (and not vary depending on the user name of the person who logs in) enter a name in the Named User field. For example, to set up supervisor–based security for reporting users who do not have any association with employees, enter the name of a person at the required supervisory level.

Restricting Access to a User’s Own Records

13. To prevent users from seeing their own records, check the Exclude User check box (if you have entered a name in the Named User box, users will be prevented from seeing the records of the named user rather than their own records).

Restricting Access by Custom Restriction

14. In the Custom Security tabbed region, check the Custom Restriction box, and enter a valid SQL WHERE clause fragment to select a group of records. For example, to add a restriction that employee assignments must be based in either London or Paris, add the following SQL fragment:

   ```sql
   ASSIGNMENT.location_id in (select LOC.location_id
                               from hr_locations_all LOC
                               where LOC.location_code
                               in ('London','Paris'))
   ```
If the clause is valid, it is automatically incorporated in an SQL select statement that the system generates to restrict access to records, based on the restrictions you have set up in the other tabbed regions. The list of employees and applicants specified by these other restrictions is therefore further restricted by the custom restriction.

The clause fits into the system–generated statement in the following way (this statement is not visible on screen):

```sql
SELECT PERSON.person_id
FROM per_all_people_f PERSON,
     per_all_assignments_f ASSIGNMENT
WHERE PERSON.person_id=ASSIGNMENT.person_id
AND {your custom where clause fragment goes here}
/
```

**Attention:** Custom restrictions further restrict employees and applicants only; they have no effect on people with a system person type of Other.

15. Choose the Verify button to check that the clause you have entered is valid. If it is invalid, an error message appears explaining the reasons.

16. Save your work.
Assigning Security Profiles

Use the Assign Security Profile window to link user names, and security profiles to responsibilities. Only use this window if you are using Security Groups Enabled security (formerly called Cross Business Group Responsibility security).

Attention: When using Security Groups Enabled security even if you have linked a user to a responsibility using the User window, you must still link your user to responsibility and security profile using the HRMS Assign Security Profile window. If you do not use the Assign Security Profile window, HRMS uses the default view—all security profile for the Business Group and the user will see all records for the Business Group.

The Assign Security Profile window is an essential part of setting up and maintaining HRMS security for Security Groups Enabled security. You must use this window to update your security profile assignment. Any changes entered for the security profile assignment are also shown on the User window. However, if you end date a user’s responsibility using the User window, this is not shown on the Assign Security Profile window.

When you navigate to the Assign Security Profile window, the Find Security Profile Assignments window displays automatically. Select New to create a new assignment. For information about querying existing security profile assignments, see Using the Find Security Profile Assignment window: page 3 – 56.

To assign a new security profile:

1. Enter the user name you want to link to a responsibility.
2. Enter the application and responsibility you want to link to the user.
3. Assign a Business Group to the user’s responsibility.
4. Assign a security profile to the user’s responsibility.
   You can link more than one security profile to a responsibility as long as the user is different.
5. Enter the time period of security profile assignment.
   You must enter a start date. Optionally, enter an end date if you want the security profile assignment to end on a particular date.
6. Save the security profile assignment.
To end a security profile assignment:

You cannot delete security profile assignments. If a user no longer needs an assignment you must enter an end date.

1. Query the security profile assignment you want to end.
2. Enter an end date. The user cannot use this responsibility, Business Group and security profile from this date.
Using the Find Security Profile Assignment window

This window enables you to search for security profile assignments that have already been set up. You only use security profile assignments if you are setting up Security Groups Enabled security.

If you want to set up a new security profile assignment select the New button. For more information on setting up new security profile assignments, see Assigning Security Profiles: page 3 – 54.

Note: When you navigate to the Assign Security Profiles window, the Find Security Profile Assignment window automatically displays.

To query a security profile assignment:

1. Enter a full or partial query on one, a selection or all of the following:
   - User name
   - Application
   - Responsibility
   - Business Group
   - Security profile

2. Check the Retrieve Only Active Assignments check box if you want to query security profile assignments that are active as of today’s date. Uncheck the Retrieve Only Active Assignments check box if you want to query security profile assignments which are no longer active or assignments which will be available in the future.

3. Choose the Find button.
   The security profile assignments found by the query are displayed in the Assign Security Profile window.
Setting Up Reporting Users

Reporting users do not have online access to the database through system forms. They use reporting tools to prepare reports on the information their security profiles grant.

All secure users connect to the APPS ORACLE ID. This is created when the system is installed. However, for reporting users, you should create one or more new reporting user ORACLE IDs and associate each with a restricted security profile. Only users that have been registered as Restricted Oracle Users are available for selection as reporting users in the Security Profile windows.

The first step in this procedure is the job of the ORACLE database administrator. The other steps are normally completed by the system administrator.

To set up a new reporting user:

1. Create a new reporting user ORACLE ID.
2. Register the new ORACLE ID with Application Object Library using the Oracle Users window, selecting Restricted in the Privilege field.
3. Define a security profile for the new ORACLE ID.
   See: Defining a Security Profile: page 3 – 50
4. Run the HR security processes using the Generate Secure User Process.
   See: Submitting a New Request, Oracle Applications User’s Guide.
STRUCTURING MENUS

Using function security and the Menus window, you can use the default menu for any number of responsibilities and restrict access to the default menu options. You can also define any number of new functions and menus to restrict the access of other users. To view the hierarchy of menus you have defined, you can run the Menu Structures report.

⚠️ **Warning:** You should not modify the default functions and menus supplied with the system. On upgrade, these defaults will be overwritten.

If you want to add window configuration options or task flows you should define your own menus.

The supplied menus give you access to all of the available submenus. However, a number of predefined functions are not enabled on these menus. You need to add them for the responsibilities that should have access to these functions.

**Structuring Menus:**

1. Start by drawing it out on paper. This helps you to decide the best structure and the best prompts and descriptions.
2. Decide how to structure your menus. Menus can be structured in different ways:
   - Following a Sequence of Tasks.
     For example:
     1. Define a Requisition and Vacancy
     2. Define a Recruitment Activity
     3. Enter Applicant Information
   - By Type:
     For example, all inquiry windows grouped together. If you structure the menu by type, the grouping is important but the sequence is not.
3. Work from the lowest level of sub-menu to the highest and define the root menu as the last step in the sequence.
4. Define as many submenus as you require under each menu option. We recommend that you restrict the number of menu levels to three because a menu structure with more levels is cumbersome to use.
Defining Menu Functions

Use the Form Functions window to define your menu functions.

Function Security helps you to control the menu options you make available to each responsibility. When you define a responsibility you can restrict the submenus or functions for that responsibility.

⚠️ Warning: You should not modify the default functions and menus supplied with the system. On upgrade, these defaults will be overwritten.

If you want to add window configuration options or task flows you should define your own menus.

- Define Menu Functions
  - Define your menu function using the Form Functions window.
  
  See: Form Functions Window, Oracle Applications User’s Guide.
Defining Menus

Use the Menus window to add predefined functions to a menu.

⚠️ **Warning**: Oracle HRMS with DateTrack and task flows does not fully support multiple active windows. When you define a new menu for use with Oracle HRMS the top menu must include the following function as a separate menu option:

```
Disable Multiform
```

A number of predefined functions are not provided on the supplied menus. You can add them to your own menus. See: Menu Structure: page for a list of these functions.

To define a menu:

1. Query the menu onto which to add the function.
2. Add a new line and select the function.
   For example, select Salary Administration: Approve to enable users to approve salary proposals.
3. Save your changes.


---

3 – 60 Configuring, Reporting and System Administration in Oracle HRMS
Restricting Access to Query–Only Mode

To restrict access to query–only mode for an individual form:

1. In the Form Functions window, select the form and specify the parameter QUERY_ONLY=YES. If you want to specify other parameters for this form function, separate them with a space.

2. Enter a user function name to identify your new function, and save it.

3. In the Menus window, select your new function instead of the supplied form function.
Using Parameters for HRMS Form Functions

For certain options you must define menu functions that include a parameter in the Parameters field of the Form Functions window, as follows:

- If the menu entry calls a configured form, use the following parameter:
  
  \[ \text{HR\_CUSTOMIZATION = "customization name"} \]

- If the menu entry calls the first form in a task flow, use the following parameter:
  
  \[ \text{WORKFLOW\_NAME = "task flow name"} \]

- If the menu entry calls a form in query–only mode, use the following parameter:
  
  \[ \text{QUERY\_ONLY=YES} \]

- If the menu entry calls a people management template, use the following parameter:
  
  \[ \text{TEMPLATE\_NAME="name of your template"} \]

- If the menu entry calls the Define Rate form (PAYWSGEV), use the following parameter:
  
  \[ \text{FORM\_MODE = "grade" (for the Grade Rate window)} \]
  \[ \text{FORM\_MODE = "spine" (for the Scale Rate window)} \]

- If the menu entry calls the Payroll and Assignment Processes form (PAYWSACT – used in Oracle Payroll), use the following parameter:
  
  \[ \text{FORM\_MODE = "assignment" (for the Assignment Processes window)} \]
  \[ \text{FORM\_MODE = "payroll" (for the Payroll Processes window)} \]

If you need to specify more than one parameter for a form function, separate the parameters with a space.

For more information about using the Form Functions window see: Form Functions Window, Oracle Applications System Administrator’s Guide.
Disabling Multiple Windows

In most Oracle Applications, you can open multiple windows from the Navigator window without closing the window you already have open. HRMS, however, does not support Multiform functionality.

**Attention:** You must disable this feature on menu structures that accesses Oracle HRMS windows.

To disable the Multiple Open Window feature:

1. Add a Function type menu entry to the top-level menu referenced by your new responsibility.
2. Select the function whose User Function Name and Function Name are:
   - Navigator: Disable Multiform
   - FND_FNDSCSGN_DISABLE_MULTIFORM
3. Save your changes.
Defining a Context for Mass Actions

The Contexts window determines what information the user can view, enter, and change based on the Application, Legislation, and Responsibility.

A predefined global Context contains the default attribution that appear on the forms. When you create a new Context, these attributes serve as a basis for selecting which attributes to include as display, change, and criteria attributes.

The predefined global Context does not specify values for Application, Legislation, or Responsibility. You can restrict who can process mass actions by specifying these attributes. The system always applies the most defined Context, so as soon as you define these fields, the system applies the new Context instead of the global one.

You define a new context in the Contexts window.

To define a Context:

1. Choose New from the File menu.
2. In the Context field, enter a name.
3. In the Transaction Name field, choose the Transaction Category to affect.
4. In the Application field, select an application.
5. Optionally, choose one or more of the following fields to restrict a user’s ability to view and change data:
   - In the Legislation field, select a Legislation
   - In the Responsibility field, select a Responsibility
6. Choose the Find Attributes button.
   The system displays the attributes from the global Context window on the Display and Change List tabbed regions.
7. Choose the Display tab and select those items to display on the Columns portion of the transaction template.
8. Choose the Change List tab and select those items to display for the Change List values.
9. Choose the Criteria tab and select the items you want to have appear on the Other Criteria list of values in Selection Criteria block on the Original tab.
10. Choose the Compile button to save your work and compile the flexfield definitions.
11. Save your work.
AuditTrail
AuditTrail

AuditTrail is an Oracle HRMS system administration task which enables you to track and record changes to your data.

What does AuditTrail provide?

AuditTrail provides a flexible approach to tracking the changes to your data. It enables you keep a history of changes to your important data: what changed, who changed it, and when. With AuditTrail, you can easily determine how any data row or element obtained its current value. You can track information on most types of fields, including character, number and date fields.
AuditTrail Overview

The system administrator is responsible for performing AuditTrail on Oracle HRMS data.

Performing AuditTrail

AuditTrail provides a flexible approach to tracking the changes to your data. It enables you keep a history of changes to your important data: what changed, who changed it, and when. With AuditTrail, you can easily determine how any data row or element obtained its current value. You can track information on most types of fields, including character, number and date fields.

You enable auditing for audit groups. These are groups of tables and columns you want to audit, where you do not necessarily need to include all the columns in a given table. You typically group together those tables that belong to the same business process, such as employee compensation tables.

During your AuditTrail implementation, you need to decide your audit requirements:

- Which tables and columns you want to audit
- How you plan to report on the audit data
- How long you want to keep the audit data active
  - Audit information reports
  - Custom audit reports

See: Oracle Applications System Administrator’s Guide
Audit Information Reports

The AuditTrail process creates a shadow table for each audited table, to hold the audit information.

For tables that are not datetracked, you can write a report that uses the views on the shadow tables to access the audit data. However, for datetracked tables, the information from the shadow tables must be extracted and written to the HR_AUDITS table and the HR_AUDIT_COLUMNS table before you can report on it.

The system’s audit report performs this additional processing. You can use it as supplied or as an example of how to report on audit information. It can report on both datetracked and non-datetracked tables that have a numeric primary key.

Note: It can report on up to approximately 90 columns in datetracked tables and 80 columns in non-datetracked tables.

The report lists every change made to the table you select in the time period you specify when you run the report. You can restrict the reported changes to those made by a specified username. The changes are listed by date and time of the change. For each change, the report shows:

- The date and time of the change
- The user ID who made the change
- The type of change
- The fields that changed and either their old values, or their new values, or both, depending on the type of change

The following table lists the 12 types of change and the information shown in the audit report for each type.

<table>
<thead>
<tr>
<th>Type of Change</th>
<th>Field Values Shown in the Report</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal Insert</td>
<td>The non-null values in the new record.</td>
</tr>
<tr>
<td>Normal Update</td>
<td>The old and new values for all fields that changed.</td>
</tr>
<tr>
<td>Normal Delete</td>
<td>The non-null values in the record that was deleted.</td>
</tr>
<tr>
<td>DT First Insert</td>
<td>The non-null values in the new record.</td>
</tr>
<tr>
<td>Type of Change</td>
<td>Field Values Shown in the Report</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DT Update</td>
<td>The old and new values of all fields that changed, and the new effective end date on the old row.</td>
</tr>
<tr>
<td>(date-effectively ends the last row on a datetracked record and creates a new row)</td>
<td></td>
</tr>
<tr>
<td>DT Correction</td>
<td>The old and new values of all fields that changed, and the effective dates of the corrected row.</td>
</tr>
<tr>
<td>(corrects a row of a datetracked record and does not change the effective dates)</td>
<td></td>
</tr>
<tr>
<td>DT Replace</td>
<td>The non-null values in the rows that were deleted, the new effective end date on the row preceding the new row, and the old and new values of all fields that changed.</td>
</tr>
<tr>
<td>(creates a new row on a datetracked record that replaces all rows that start after its start date)</td>
<td></td>
</tr>
<tr>
<td>DT Insert</td>
<td>The old and new values of all fields that changed, and the new effective end date on the row preceding the new row.</td>
</tr>
<tr>
<td>(creates a new row on a datetracked record that ends on the old effective end date of the preceding row)</td>
<td></td>
</tr>
<tr>
<td>DT Purge</td>
<td>The non-null values in all rows of the record that was deleted.</td>
</tr>
<tr>
<td>(deletes all rows of a datetracked record)</td>
<td></td>
</tr>
<tr>
<td>DT End Date</td>
<td>The new effective end date of the row.</td>
</tr>
<tr>
<td>(adds an effective end date to the last row of a datetracked record)</td>
<td></td>
</tr>
<tr>
<td>DT All</td>
<td>The non-null values in the rows that were deleted, and the new effective end date on the last row.</td>
</tr>
<tr>
<td>(sets a new effective end date on a row of a datetracked record and deletes all following rows)</td>
<td></td>
</tr>
<tr>
<td>DT Next</td>
<td>The non-null values in the row that was deleted, and the old and new effective end dates on the preceding row.</td>
</tr>
<tr>
<td>(deletes a row of a datetracked record and uses its effective end date to set an new end date on the preceding row)</td>
<td></td>
</tr>
</tbody>
</table>
Custom Audit Reports

If you want to design your own audit report, you can copy the supplied report and use it as the basis of your own version. The supplied report uses a dynamic SQL structure to retrieve information for the report, and an Oracle Report to format it.

Dynamic SQL Structure

For a non-datetracked table, the dynamic SQL structure retrieves information and uses a private procedure to retrieve the new values for an update.

For a datetracked table, the dynamic SQL structure retrieves information from the function and procedure created for each datetracked table by the Audit Trail Update Datetracked Tables process:

- The <tablename>_TT function identifies the type of datetracked transaction represented by each row of the shadow table.
- The <tablename>_VP procedure gets new values from the shadow table for update and insert transactions. It writes these to the HR_AUDITS and HR_AUDIT_COLUMNS tables.

The dynamic SQL structure comprises several character strings, which are concatenated into one long string, then parsed and executed using the dynamic SQL generator. If you change a string, you must ensure that you do not exceed the text space allocated to it, as listed in the package header.

The structure is built up by identifying the audited table column information, which is retrieved from the FND_AUDIT_COLUMNS table. The logic varies depending on the data type being audited.

The package for the dynamic SQL is called py_audit_report_pkg. It is found in the script pyadyn.pkh/pyadyn.pkb.

HR Audit Tables

The HR_AUDITS table holds audit information about the transaction. The HR_AUDIT_COLUMNS table holds the changed column information for that transaction. The following tables show the structure of the HR_AUDIT and HR_AUDIT_COLUMNS tables:

**HR_AUDITS Table**

<table>
<thead>
<tr>
<th>COLUMN</th>
<th>TYPE</th>
<th>NULL</th>
</tr>
</thead>
<tbody>
<tr>
<td>audit_id</td>
<td>number(15)</td>
<td>not null</td>
</tr>
<tr>
<td>commit_id</td>
<td>number(9)</td>
<td>not null</td>
</tr>
<tr>
<td>COLUMN</td>
<td>TYPE</td>
<td>NULL</td>
</tr>
<tr>
<td>------------------</td>
<td>------------------</td>
<td>-------</td>
</tr>
<tr>
<td>current_session_id</td>
<td>number</td>
<td>not null</td>
</tr>
<tr>
<td>primary_key</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>primary_key_value</td>
<td>number(15)</td>
<td>not null</td>
</tr>
<tr>
<td>sequence_id</td>
<td>number(9)</td>
<td>not null</td>
</tr>
<tr>
<td>session_id</td>
<td>number</td>
<td>not null</td>
</tr>
<tr>
<td>table_name</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>timestamp</td>
<td>date</td>
<td>not null</td>
</tr>
<tr>
<td>transaction</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>transaction_type</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>user_name</td>
<td>varchar2(100)</td>
<td>not null</td>
</tr>
<tr>
<td>effective_end_date</td>
<td>date</td>
<td>null</td>
</tr>
<tr>
<td>effective_start_date</td>
<td>date</td>
<td>null</td>
</tr>
</tbody>
</table>

**HR_AUDIT_COLUMNS Table**

<table>
<thead>
<tr>
<th>COLUMN</th>
<th>TYPE</th>
<th>NULL</th>
</tr>
</thead>
<tbody>
<tr>
<td>audit_id</td>
<td>number(15)</td>
<td>not null</td>
</tr>
<tr>
<td>column_id</td>
<td>number(9)</td>
<td>not null</td>
</tr>
<tr>
<td>column_name</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>new_value</td>
<td>varchar2(240)</td>
<td>null</td>
</tr>
<tr>
<td>old_value</td>
<td>varchar2(240)</td>
<td>null</td>
</tr>
</tbody>
</table>
Setting up AuditTrail is usually a task for the system administrator.

The first six steps are required to enable auditing of any Oracle Applications table. They are explained in more detail in the Oracle Applications System Administrator’s Guide. The final step is required only for tables in the HR application.

**To set up AuditTrail:**

1. Have your database administrator grant SELECT privileges on SYS.DBA_TABLES to the APPLSYS account. Normally this step will already have been done as part of your installation or upgrade.

**Using a System Administrator responsibility:**

2. In the System Profile Values window, set the AuditTrail:Activate profile option to Yes at Site or Application level.

3. In the Audit Installations window, query the application(s) you want to audit, and check the Audit Enabled box next to the Oracle Username.

4. In the Audit Groups window, query the application and enter a name for the audit group, then select the tables you want to audit (using the User Table name). For a new audit group, select Enable Requested in the Group State field.

5. In the Audit Tables window, query each table you want to audit, and select which columns in these tables you want to audit.

   **Note:** You cannot audit LONG, RAW, or LONG RAW columns.

6. In the Submit Request window, run the AuditTrail Update Tables process. This process:
   - Creates database triggers on your audited tables
   - Creates one shadow table for each audited table, to contain the audit information
   - Builds special views on non-datetracked tables, which you can use to retrieve your audit data for reporting

**Using an HR Manager responsibility:**

7. In the Submit Request window, run the AuditTrail Update Datetracked Tables process. For each datetracked table, this process:
   - Creates an index on the shadow table
• Creates the function <tablesname>_TT and the procedure <tablename>_VP, which extracts information from the shadow table when you run the predefined audit report.

**Attention:** You must re-run the AuditTrail Update Tables process and the AuditTrail Update Datetracked Tables process if you make any changes in the Audit Groups or Audit Tables windows.
Disabling AuditTrail

You can disable the auditing of an audit group at any time by selecting a Disable state in the Audit Groups window.

**Suggestion:** If you are planning high volume transactions on an audited table, such as loading a batch of information from another system, consider disabling auditing for the table’s audit group. This will enable the batch loading to complete more quickly.

Before you restart auditing, you should archive your audit data, according to your business needs, and purge the shadow tables. You purge the tables by setting the audit group to Disable – Purge Table and running the Audit Trail Update Tables report. To restart auditing, you set the audit group to Enable Requested and rerun the Audit Trail Update Tables process and the Audit Trail Update Datetracked Tables process.
Running the Predefined Audit Report

You can run an audit report using the system’s predefined structure, or you can design your own audit report.

To run the predefined audit report:

1. Using an HR Manager responsibility, open the Submit Request window and select Audit Report in the Name field.
2. Enter the Parameters field to open the Parameters window.
3. Select an audited table (that is, one in an audit group) using the Table name.
4. Select a value for the Initialization parameter:
   - Yes means that the report removes any existing data related to your selected table from the HR_AUDITS table and the HR_AUDIT_COLUMNS table. It then populates these tables with the current values from your selected table and reports on these.
   - No means that the report runs on the existing data in the HR_AUDITS table and the HR_AUDIT_COLUMNS table.
   - Refresh means that the report removes existing data for all tables from the HR_AUDITS table and the HR_AUDIT_COLUMNS table. It then populates these tables with the current values for your selected table and reports on these.
5. If you only want to report on the changes made by one user, enter the username.
6. Enter start and end dates to limit the time period for reporting audit information.
7. Choose the Submit button.

You can use the View Requests window to check the progress of the report.
CHAPTER

5

Information Access
Information Access

Does Oracle HRMS provide flexible access to information?

The information held in Oracle HRMS is an extremely valuable resource for your enterprise. You can use the same information in a variety of different ways depending on your business purpose. For example, you can use Oracle HRMS information in support of each of the following business activities:

- Performing a full range of HR functions on a day–to–day basis
- Reporting on HR activities
- Performing what–if exercises to determine the viability of alternatives scenarios
- Performing strategic planning with the Business Intelligence System

How can you use Oracle HRMS to support typical HR activities?

You can extract details about a single employee or a group of employees. Particular examples are:

- Selecting an employee or a set of employees for HR processing
- Extracting HRMS information to produce standard letters
- Viewing organization hierarchies and position hierarchies
- Viewing a historical record of previous changes

What range of reporting options are available in Oracle HRMS?

When you are reporting on activities using HRMS you may want to use each of the following reporting options depending on your business purpose:

- Define a report using parameters that you supply
- Run a predefined report
- Specify the intervals at which a report should run
- Combine several reports into a set so that they can be run at the same time

Can you pose “what–if” scenarios?

There will be occasions when you want to see the effect of a proposed change before deciding whether to implement it. For example, you
may want to calculate the effect of a salary change for a range of employees. In these circumstances it would not be appropriate to change the data in HRMS until you have assessed the implications. Oracle HRMS allows you to transfer a copy of current data to your desktop so that you can test a succession of modifications before uploading the data to HRMS.

**Can you use Oracle HRMS information for strategic planning?**

Using the Business Intelligence System you can:

- Establish a set of Key Performance Indicators to provide measures of compliance for each of your business activities
- Produce reports to illustrate trends and identify future business strategy
- Make integrated use of individual reporting tools to solve complex enquiries

**Can you run multilingual reports?**

Yes, you can run HRMS in more than one language on a single database. This means that you can enter and report on information using more than one language. For example, your base, or source, language could be French, but you could also install German and English. You would then be able to enter and produce reports in German and English.
Information Access Overview

Oracle HRMS provides a range of inquiry and reporting mechanisms to meet the needs of different users:

- Inquiry windows (including folders)
- Predefined reports that can be scheduled and grouped for periodic processing
- QuickPaint, to create your own online inquiries and reports about people and assignments
- Multilingual reporting for some reports
- Use of desktop tools for reporting or editing HRMS data. For example, you can use Application Data Exchange (ADE) to download information to a spreadsheet, and then upload the modified data to HRMS.

Inquiry Windows

Oracle HRMS includes some inquiry windows to meet the most common online reporting requirements. In these windows, you typically enter selection criteria in the first block then choose the Find button to view a list of people, assignments, or other entities that match your criteria. Some of these windows use folders to display the information retrieved by your criteria.

Folders are online views that you can configure. By default, the folder block in an inquiry window displays all records matching your inquiry and all fields available within the folder. However, you can create your own folders to display a subset of these records and fields. You can also choose the field labels, their size and order, and the sort sequence of the retrieved records.

For example, in the Assignment Folder window, you could create a folder called Sales Employees by Grade. This folder has the query criteria Organization = "Sales", and it is sorted by grade.

Predefined Reports

There are a number of predefined reports that you can use immediately without any further set up. They have a predefined format but you can choose which records to view by entering a set of parameters when you submit the report.

You can also create your own reports using Oracle Reports or SQL*Plus or another tool of your choice. You can register them with Application...
Object Library. This means you can run them from the standard Submit Requests window, and you can schedule them in report sets with other reports and processes.

**Multilingual Reporting**

Oracle HRMS enables you to print reports in the language of your choice.

**HR Reports**

You can select in which language the following reports are printed:
- Full Person Details
- Full Applicant Details
- Full Assignment Details
- Full Work Details

See: Submitting a Request, *Oracle Applications User’s Guide*

**Payroll Reports**

Payroll reports are usually submitted in the language of your Business Group, for example the US Check writer can only be printed in American English and the GB Deposit Advice can only be printed in English. However, you may be able to print payroll reports in multiple languages if your localization team has created legislation specific reports for you to use.

**Note:** The default HRMS payrolls for the US and UK can only be run in English.

**Using Oracle HRMS with Spreadsheets**

You can use Oracle Application Data Exchange (ADE) to download information from the HRMS database to a spreadsheet for analysis and manipulation. For example, you can download data on current and proposed salaries for a group of employees. You can adjust the salary proposals in the spreadsheet, or enter new ones, and upload the revised data to the database. The ADE upload process reports any errors and ensures that only valid data is saved in the database.

To download information from a form to a spreadsheet using ADE, your system administrator needs to create a style in ADE. The style defines the form it is used for, the responsibilities that can use it, and the columns (or fields) to be downloaded. You determine which records are downloaded by running a query in the form before launching ADE.
A style for downloading salary proposals is predefined.
See Using Application Data Exchange.

QuickPaint

QuickPaint is a powerful and flexible tool to design reports about assignments in the format you require. You can include the following sorts of information in a QuickPaint report:

- Personal information
- Contact information
- Assignment information
- Application information
- Compensation and benefit information
- Descriptive flexfield information

Once you have designed a QuickPaint report, you and other users can run the report online for any assignment or set of assignments. You can view the results online or print them.

Configuring the Run QuickPaint Report Window

Using the standard QuickPaint Report window, you can run the report for an assignment or an assignment set. The assignments can be held by current employees or applicants.

Your system administrator can create configured versions of this window to restrict the reports you can run and the people you can report on. A configured version might be subject to one or more of the following restrictions:

- Report on one person type only (employees OR applicants).
- Run one report only.
- Report on single assignments only, or report on assignment sets only.

If the window is subject to the third type of restriction, it will look different to the standard version since it will contain either the assignment region or the assignment set region, but not both.

Attachments

You can add attachments to a large number of HRMS records. Examples of attachments are word processed documents, Web pages or video images.
Using Attachments

You can attach short comments, word processed documents, images, video, OLE objects, or Web pages to many records in Oracle HRMS. For example, you could attach a resume to an applicant record and a position description to a position record.

Each record can have one or more attachments, and you can copy attachments from one record to another. You can store the attachments in the database or in your file system.

To view attachments or add new attachments

Click the Attachments icon. By default, clicking the attachments icon displays a Comments window where you can enter text up to 2000 characters. This is the Comments facility available in earlier releases of Oracle HRMS. If you want to replace this facility with the ability to attach multiple items, ask your system administrator to set your user profile option HR:Use Standard Attachments to Yes.

The HRMS entities that support attachments are:

- Absence
- Absence Type
- Address
- Application
- Assignment
- Balance (Oracle Payroll)
- Batch Header
- Booking
- Budgets
- Budget Version
- Calendar
- Career Path
- Collective Agreements
- Consolidation Set (Oracle Payroll)
- Contact Relationship
- Contracts
- Customization
- Element
• Element Entry
• Element Link
• Element Set
• Event
• Grade
• Grade Rate
• Job
• Job Evaluation
• Job Requirement
• Letter Type
• Monetary Unit (Oracle Payroll)
• Organization
• Organization Payment Method
• Organization Hierarchy
• Pay Scale
• Payroll Process (Oracle Payroll)
• Period of Service
• Person
• Person Analysis/Special Information
• Personal Payment Method
• Position
• Position Hierarchy
• Recruitment Activity
• Requisition
• Salary Basis
• Salary Proposal
• Salary Proposal Component
• Secondary Assignment Status
• Special Information Type
• Status Processing Rules (Oracle Payroll)
• Vacancy
• Valid Grade
Using Inquiry Windows and Folders

You can define public folders, which all users can view, as well as private folders for your own use.

Inquiry Windows in Oracle HRMS

See: Customizing the Presentation of Data in a Folder: *Oracle Applications User’s Guide*

<table>
<thead>
<tr>
<th>Inquiry Window</th>
<th>Information Provided</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assignments Folder</td>
<td>Lists of assignments in a folder</td>
</tr>
<tr>
<td>Employee Assignment Processes (Oracle Payroll – UK and US legislations only)</td>
<td>All the assignment processes for one employee assignment, which you can view, retry or roll back, with further information on run messages, run results, balances, payment details and costing</td>
</tr>
<tr>
<td>Payroll Processes (Oracle Payroll – UK and US legislations only)</td>
<td>All the payroll processes for one payroll for a specified period, which you can view, retry or roll back, with further details on assignment processes, run messages and costing</td>
</tr>
<tr>
<td>People Folder</td>
<td>Lists of people in a folder</td>
</tr>
<tr>
<td>Salary Management Folder</td>
<td>List of assignments with their current approved salary and proposed new salary</td>
</tr>
<tr>
<td>Position Occupancy Folder</td>
<td>Lists of people who have held a selected position, or are applying for it, and the dates of their occupancy</td>
</tr>
<tr>
<td>List Assignments</td>
<td>Assignments that match the assignment components you specify for current applicants, employees, or both</td>
</tr>
<tr>
<td>List People by Assignment</td>
<td>People whose assignments match the assignment components you specify for current or former applicants, employees, or both</td>
</tr>
<tr>
<td>List Employees by Organization</td>
<td>All employees assigned to one organization and, optionally, to all organizations below it in a specified hierarchy</td>
</tr>
<tr>
<td>Assignment History</td>
<td>The dates of assignments and periods of service for an employee who has had more than one assignment. NOTE: use DateTrack History on the Assignment window to see historical changes to one assignment</td>
</tr>
<tr>
<td>List Employees by Position</td>
<td>All employees assigned to a specified position or organization and job</td>
</tr>
<tr>
<td>List Employees by Position Hierarchy</td>
<td>Current holders of positions at and below a specified position in a position hierarchy</td>
</tr>
<tr>
<td>View Employee Grade Comparatio</td>
<td>The amount employees receive for a specified element as a percentage of the mid–value of their grade rate range</td>
</tr>
<tr>
<td>Inquiry Window</td>
<td>Information Provided</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>List Employees by Absence Type</td>
<td>All absences of a particular absence type or category within, optionally, a specified time period</td>
</tr>
<tr>
<td>View Employee Absence History</td>
<td>Periods of absence for a specified employee</td>
</tr>
<tr>
<td>List People by Special Information</td>
<td>All people for whom you have entered details about a specified special information type</td>
</tr>
<tr>
<td>List Employees by Element</td>
<td>All employee assignments receiving a specified compensation element within a given time period</td>
</tr>
<tr>
<td>View Element Entry History for Employee</td>
<td>The history of entries of one or more elements for an employee assignment</td>
</tr>
<tr>
<td>List Position Budget Variance</td>
<td>Variances between the number of actual position holders and the values entered in a specified budget for positions below a chosen position in a hierarchy</td>
</tr>
<tr>
<td>List Budget Variance by Organization</td>
<td>Variances between the number of actual position holders and the values entered in a specified budget for all positions in organizations at and below a chosen organization in a hierarchy</td>
</tr>
<tr>
<td>View Employee Benefits (US only)</td>
<td>View benefit plans on which an employee is enrolled and the coverage level and contributions for each plan</td>
</tr>
<tr>
<td>View Vacancies</td>
<td>Vacancies matching assignment components and other criteria you select</td>
</tr>
</tbody>
</table>
Using the Process Log

The process log displays information that can help you correct errors. For example, you can refer to the log for errors encountered when:

- Creating a budget from a worksheet
- Applying budget information to a general ledger
- Migrating budget data
- Identifying positions that are under budget
- Undertaking a position transaction
- Copying or updating positions
- Updating assignments
- Calculating commitments

Use the Process Log window to learn more about an error.

To display error information:

1. From the View list, select a data set such as Position Copy.
2. Locate the folder for the records you want to view.
   
   A Summary View describes the status of the records listed in the containing folder.
3. If necessary, continue navigating the records to the one that contains the error (designated by a red stop light icon).
   
   If the window where you originally entered the data contained tabbed regions, a separate entry shows the status of the records contained in each tabbed region.
   
   The Detail View helps you further identify a record and correct the error contained in it. For example, if the system validates data for a newly copied position and encounters invalid data in Work Choices, the Detail View displays the Work Choices flexfield so that you can review the data and then correct it.
4. If necessary, return to the window where you originally entered the data and correct the error. After correcting the error, you can apply the data or resubmit the process.
Running Predefined and User Defined Reports

These reports run in batch mode. You submit them for processing in the Submit Requests window, and you can view their progress using the View Requests window. The requests are handled by a concurrent manager so you can continue working online while your request is processed.

See: Submitting a Request, Oracle Applications User’s Guide

You can schedule the reports to run regularly and you can group them with other reports and processes to run as a set. You can also control access to the reports and control their printing. For example, the system administrator may want to ensure that users in one location always print their reports on a local printer.

See: Reports and Processes in Oracle HRMS: page A – 88 for a list of predefined reports and processes.

You can create your own reports using Oracle Reports or SQL*Plus or another tool of your choice. You can register them with Application Object Library. This means you can run them from the standard Submit Requests window, and you can schedule them in report sets with other reports and processes.
Defining QuickPaint Reports

You can design QuickPaint reports in the Define QuickPaint Report window.

In the Report Definition area, you can enter free text to introduce the report and to label the information that the report extracts from the database. You can also select database items, which are tags representing the information to be extracted from the database. When you run the report, the database item names are replaced by the appropriate data for the assignment or set of assignments for which the report is run.

You must be careful how you position the database items so that QuickPaint interprets them correctly and formats the report in the layout you require.

To define a QuickPaint Report:

1. Enter a name, and optionally a description, of the report.
   The Protected field is display only; some reports provided by localization teams are protected against edits.
2. In the Report Definition area, enter free text exactly as you want it to appear on the report.
3. To select database items, choose the Show Items button and run a query to display a list of database items, then select and copy items to the Report Definition area.
   Notice that the database item name must begin with an ampersand (&). Names without an ampersand are treated as free text.
4. Save the report definition.

Positioning Items

If you want to add free text immediately after a database item, you must separate it from the database item with at least one space. Otherwise QuickPaint reads the database item as free text.

Both free text and database items appear in the report results on the line on which you painted them in the Report Definition area. They also generally appear in the column in which you painted them. However, it might be that the data replacing a database item name is long enough to push later items on the same line to the right.

For example, if you paint database items and free text like this:

$ASG_JOB       in $ASG_ORG

the report results print like this:

Technician     in Biochemistry
Scientific Officer in Biochemistry
Notice that, in the second result, the free text ‘in’ is pushed to the right and one space is entered before it.

If you know the number of the column in which you want text or a database item to appear, you can enter it like this:

```
&ASG_JOB   &32in &ASG_ORG
```

However, the text ‘in’ will still be pushed to the right if the preceding database item (&ASG_JOB) extends beyond column 32. If you would prefer the preceding database item to be truncated, paint the line as follows:

```
&ASG_JOB   &632in &ASG_ORG
```

The report results will look like this:

```
Technician     in Biochemistry
Scientific Off in Biochemistry
```

If you want one space between two database items or between a database item and text, then paint them separated by a single space. The single space is always preserved. For example, this definition:

```
&EMP_FIRST_NAME &EMP_LAST_NAME
```

gives the following report results:

```
Alice Hollister
Ray Garcia
```

### Adding Conditions or Calculations to QuickPaint Reports

When you save a report definition, QuickPaint generates a formula to extract the information required by the report. You can view this formula in the Formulas window. To query the formula, enter the name of your QuickPaint report.

Formulas generated from QuickPaint definitions do not contain conditional logic or mathematical computations. If you need these features, query the formula in the Formulas window and copy it. Edit the copy to add the logic you require.

**Attention:** You should not edit the original QuickPaint formula. Always edit a copy. Any edits of the original formula are overwritten if you change the report definition in the QuickPaint Report window.
Running QuickPaint Reports

You run QuickPaint reports from the Run QuickPaint Report window. You can run a report for one assignment or for a group of assignments.

► To run a report for one assignment:

1. Select the type Assignment.
2. In the Assignment region, select the assignment for which you want to run the report.
3. In the Report field, select the report you want to run.
4. Choose the Run Report button.
   The message line tells you when the report is complete.
5. Choose the View Report button to see the report results.
   When you run a QuickPaint report, the system runs the formula associated with the report. The first time you run a report, the system may take several seconds to identify all of the related data and bring it back to the screen. All subsequent inquiries for other employees or applicants will run very quickly.

► To run a report for an assignment set:

1. Select the type Assignment Set.
2. In the Assignment Set region, select the assignment set for which you want to run the report.
3. In the Report field, select the report you want to run.
4. Choose the Run Report button.
   The message line tells you when the report is complete.
5. Choose the View Report button to see the report results.
Creating an Assignment Set

There are three uses of assignment sets in Oracle HRMS:

- You can run a QuickPaint report for a set of assignments, rather than individual assignments.
- You can process subsets of the employees assigned to a payroll. Normally you initiate payroll runs and other post-run processes for one or more payrolls at a time. However, if you need to process smaller groups within a single payroll, you define an assignment set.
- You can use a BEE concurrent process to create an identical batch line for each assignment in an assignment set.

There are three ways to define the set:

- You can enter selection criteria, which the system generates into a formula. When you use the assignment set, Oracle FastFormula runs the formula to find the assignments that match the criteria. It checks all the assignments in the business group or, if you select a payroll when you define the set, all the assignments to that payroll. When you define the set you can also include or exclude individual assignments to modify the set created by the formula.

  See: Defining an Assignment Set Using Formula Criteria: page 5 – 17

- You can select individually all the assignments you want to include in the set.

- You can start from a full set of all the employees in the Business Group or all the employees assigned to a selected payroll. Then you can exclude individual assignments from the set.

  See: Defining an Assignment Set by Including or Excluding Assignments: page 5 – 20
Defining an Assignment Set Using Formula Criteria

Use the Assignment Set window to define your set.

To define an assignment set using criteria for a formula:

1. Enter a unique name for the set.
2. Do one of the following:
   • If you are defining an assignment set for payroll processing, select a payroll. You cannot process an assignment set drawn from more than one payroll.
   • If you are defining an assignment set for other purposes, selecting a payroll is optional. If you select a payroll, the formula generated from your selection criteria will select assignments from this payroll only. If you do not select a payroll, the formula will select assignments from the whole business group.
3. Save the new set and choose the Criteria button.
4. In the Assignment Criteria window, enter one criterion in each row, and join the criteria with AND or OR in the Condition field. Field details are as follows:
   - **No.**: The sequence number of each condition in your rule. If you use sequence numbers that are multiples of 10, it will be easier to insert new conditions later.
   - **Condition**: Leave the first row blank. Enter AND or OR for second and subsequent rows.
   - **Database Item**: Select database items as variables for your definition. All database items are prefixed by an ampersand [&].
   - **Operator**: Select operators to determine relationships between database items or values. The list of operators is shown in the Values in Operator Field table.
   - **Value/Database Item**: Select database items for the second variable. Alternatively, you can enter a fixed value of the same type as the database item.

As an example, here is a definition for an assignment set of employees with salaries between 16,000 and 24,000:
Assigns Set Criteria

5. Save your criteria and choose the Generate button to generate the formula.

You can view and edit the formula in the Formula window. Its name is the same as the assignment set name.

6. If you want to include or exclude individual assignments from the set defined by your criteria, choose the Amendment button. Select the assignments you want to include or exclude from the set.

**Note:** The list of assignments you see in this window is either all the assignments in the business group or, if you selected a payroll, all the assignments to that payroll. It does not show the assignments matching your criteria since these are identified dynamically each time the formula runs.

7. Save the set.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Symbols</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals</td>
<td>=</td>
<td>The condition is true if both expressions have exactly the same value. For text, the case of the expression must be the same. So, for example, ‘Smith’ is not equal to ‘SMITH’.</td>
</tr>
<tr>
<td>Not Equal</td>
<td>!=</td>
<td>The condition is true if the result of the first expression does NOT have the same value as the result of the second expression.</td>
</tr>
<tr>
<td>Greater than</td>
<td>&gt;</td>
<td>The condition is true if the first expression is alphabetically after, or has a numerically greater value, or a later date than the second expression.</td>
</tr>
<tr>
<td>Less than</td>
<td>&lt;</td>
<td>The condition is true if the first expression is alphabetically before, or has a numerically smaller value, or an earlier date than the second expression.</td>
</tr>
</tbody>
</table>

**Values in Operator Field**
<table>
<thead>
<tr>
<th>Operator</th>
<th>Symbols</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Greater than or equal to</td>
<td>&gt;=</td>
<td>The condition is true if either the greater than OR the equal to operator returns a true result.</td>
</tr>
<tr>
<td>Less than or equal to</td>
<td>&lt;=</td>
<td>The condition is true if either the less than OR the equal to operator returns a true result.</td>
</tr>
</tbody>
</table>
Defining an Assignment Set by Including or Excluding Assignments

Use the Assignment Set window to define your set.

To define a set by including or excluding assignments:

1. Enter a unique name for the set.
2. If you are defining a set for payroll processing, select a Payroll.
3. Save the new set.
4. Choose the Amendment button.
5. Do one of the following:
   • If you want to create a small set of assignments, select Include in the Inc/Exc field and select all the assignments for the set.
   • If you want to start from the full set of assignments for the payroll or business group, select Exclude in the Inc/Exc field and select assignments to remove from the set.

Attention: Do not create a mixture of Include and Exclude rows if you have not entered criteria and generated a formula.
6. Save your set.
Defining Custom Reports

The Custom Reports function provides a generic reporting capability that makes use of a single report to print out a custom definition. This report is called PERGENRP.

The report is registered as a concurrent process and prints, in landscape format, the contents of the temporary table PER_GENERIC_OUTPUT_REPORT.

This table contains the individual components of a custom report and is populated by the PL/SQL package PERGENRP.pkb, stored in $PER_TOP/admin/sql. This package is executed when you select the Generate Report button on the Custom Reports window.

► To submit a Custom Report:

1. Navigate to the Custom Reports window.
2. Select the report by name.
3. Enter any parameters for this report.
4. Choose the Generate Report button

Attention: Parameter values are not validated until you choose the Generate Report button.

The default for the report is to print the output automatically. It is a System Administrator task to set default printers for all users, or to reset this option on the Concurrent Program window.

Creating New Report Formats

A special feature of Custom Reports is that you do not need to create multiple reports. You modify the generic package (PERGENRP.pkb) and report to provide additional formats and parameters.

Three sample report formats are provided, each with a different set of parameters:

• PERCS001 – Custom Report 1
  There is one parameter: Vacancy. The format in PERGENRP is Full Name of Applicant and Gender.

• PERCS002 – Custom Report 2
  Parameters are Vacancy and Gender. The format in PERGENRP is Full Name of Applicant in uppercase.

• PERCS003 – Custom Report 3
Parameters are Vacancy, Gender and Marital Status. The format in PERGENRP is Full Name of Applicant, Gender and then Full Name in uppercase.

You can edit the generic package to change:

- Report Title Page
- Header
- Footer
- Body Text

After you have modified the package, you need to register a new custom report, with the parameter set for that report. This is a task for the System Administrator.

▶ To register a new Custom Report with parameters:

1. Navigate to the Concurrent Programs window.
2. Enter the name of the Custom Report as the Program.
3. Enter a short name for the Custom Report.

   **Attention**: You must start the short name with PERCS. This will limit the list of values available to users in the Custom Report window.
CHAPTER 6

Letter Generation
Letter Generation

Standard letters enable you to manage your enterprise’s recruitment or enrollment activities more easily. Using Oracle Human Resources or Oracle Training Administration, you can issue standard letters to applicants and students respectively, triggered by changes in assignment or enrollment status. For example, you can set up a standard enrollment confirmation letter that is triggered when a student’s enrollment status is set to Placed or you can set up a rejection letter that is triggered when an applicant’s assignment status is set to Rejected.

Here are a few examples of letters you can set up to help you to manage recruitment or enrollment activities:

<table>
<thead>
<tr>
<th>Oracle Human Resources</th>
<th>Oracle Training Administration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acknowledgement letters (for all active applications)</td>
<td>Acknowledgement letters (for all requested enrollments)</td>
</tr>
<tr>
<td>Confirmation letters (for interviews)</td>
<td>Confirmation letters (for placed enrollments, including event joining instructions based on the date, venue, and trainers)</td>
</tr>
<tr>
<td>Reports for interviewers and schedules</td>
<td>Reports for trainers (listing the students to attend an event)</td>
</tr>
<tr>
<td>Offer and Rejection letters (for applicants)</td>
<td>Chase-up letters (for non-response or non-payment)</td>
</tr>
<tr>
<td></td>
<td>Acknowledgement letters (for cancellations)</td>
</tr>
<tr>
<td></td>
<td>Certificates (of successful course completion)</td>
</tr>
</tbody>
</table>
Letter Generation Overview

There are three different methods provided to create standard letters:

- Concurrent processing using Word Processors: page 6 – 4
- Concurrent processing using Oracle Reports: page 6 – 4
- Online using Application Data Exchange (ADE).

Which Method Should You Use?

Use the online method (ADE), if you want to generate and review your letters immediately.

ADE enables you to generate standard letters and reports by retrieving data and exporting it to a data file that is merged with a standard word processed document. The word processed document includes all the merge fields required to merge the data and the standard text for the letter. ADE is fully compatible with Microsoft Word 6.

You can use ADE to generate standard letters for recruitment or enrollment by performing a mail merge from the Request Letter window in your application.

See Using Application Data Exchange.

Alternatively, you can use the concurrent processing method to set up your standard letters. With concurrent processing, you generate and review your letters without interrupting other work you perform at your computer. You can control when a concurrent process runs and schedule long-running processes to run at times when the system is lightly loaded. Another advantage of using concurrent processing is that you do not need to have Windows 95 or 98, Excel or Lotus 123 installed.
Concurrent Processing

There are two methods of using concurrent processing to set up your standard letters:

- Using word processors
- Using Oracle Reports

Using Word Processors

You can use any word processor to produce standard letters from Oracle HRMS. If you use a word processor, you can submit a concurrent request in the Letter Request window to generate the mail merge file. When the concurrent request is complete, you can use your word processor’s mail merge facilities to create the merged letters.

To create standard letters using a word processor, you need to extract the data you want to include in the letters from the Oracle HRMS database. To do this, create a program, such as a SQL*Plus script, to extract the data, which is then stored in a data file. You also write skeleton standard letters using your word processor.

**Note:** Oracle HRMS supplies SQL*Plus script templates for use with MultiMate, WordPerfect and Microsoft Word. You can copy the SQL*Plus script templates and modify them to create the standard letters you require.

Each time you run your SQL*Plus script, it extracts data to the data file. You then use the mail merge features of your word processor to merge this data with the skeleton standard letters you previously prepared. This merging process creates the actual letters that you send out to students and applicants.

An overview of creating standard letters using a word processor is shown in the following figure.
If you want to set up standard letters using the concurrent processing method with MultiMate, WordPerfect Microsoft Word, see: Method 1 – Concurrent Processing: page 6 – 17.

If you use Microsoft Word as your word processor, not only can you use the concurrent processing method to produce your standard letters, but you can also generate letters online using Oracle Application Data Exchange (ADE).

See: Application Data Exchange (ADE) Overview, Using Application Data Exchange.
Using Oracle Reports

As an alternative to using a word processor to produce standard letters, you can use the Standard Letter and Label features of Oracle Reports. Use this method if you do not want to use word processors to print your letters (or if you do not have word processors).

See: Using Oracle Reports: page 6 – 18 to set up your standard letters.
PERWPOUK Template

Template SQL*Plus script for mail merge letter. See Writing a SQL*Plus Script for Microsoft Word: page 6 – 21.

<table>
<thead>
<tr>
<th>PERWPOUK.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>WHENEVER SQLERROR EXIT FAILURE ROLLBACK</td>
<td></td>
</tr>
<tr>
<td>REM Define the MS Word mail merge record separator</td>
<td></td>
</tr>
<tr>
<td>DEFINE ch=&quot;'&quot;</td>
<td></td>
</tr>
<tr>
<td>REM Define the column width for returning query results</td>
<td></td>
</tr>
<tr>
<td>COLUMN L1 FORMAT A2000</td>
<td></td>
</tr>
<tr>
<td>SET PAUSE OFF</td>
<td></td>
</tr>
<tr>
<td>SET FEEDBACK OFF</td>
<td></td>
</tr>
<tr>
<td>SET RECSEP OFF</td>
<td></td>
</tr>
<tr>
<td>SET HEADING OFF</td>
<td></td>
</tr>
<tr>
<td>SET VERIFY OFF</td>
<td></td>
</tr>
<tr>
<td>SET TERMOUT OFF</td>
<td></td>
</tr>
<tr>
<td>SET PAGESIZE 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>This section defines the required SQL*Plus environment settings. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>REM Insert session row</td>
<td></td>
</tr>
<tr>
<td>insert into fnd_sessions(session_id,effective_date)</td>
<td></td>
</tr>
<tr>
<td>select userenv('SESSIONID'),</td>
<td></td>
</tr>
<tr>
<td>to_date('&amp;2', 'DD-MON-YYYY')</td>
<td></td>
</tr>
<tr>
<td>from sys.dual</td>
<td></td>
</tr>
<tr>
<td></td>
<td>This section creates a row in the Application Object Library table (AOL) FND_SESSIONS. This enables the datetrack security views to be accessed for the session. The &amp;2 argument contains the current SQL*Forms session date. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>/REM Set length of the header</td>
<td></td>
</tr>
<tr>
<td>SET LINESIZE 220</td>
<td></td>
</tr>
<tr>
<td>REM Create the mail merge 'header' record for MS Word</td>
<td></td>
</tr>
<tr>
<td>REM Note: SPOOL command commented out for concurrent manager.</td>
<td></td>
</tr>
<tr>
<td>REM PC based solution required the SPOOL command.</td>
<td></td>
</tr>
<tr>
<td>REM spool perwpouk.txt</td>
<td></td>
</tr>
<tr>
<td></td>
<td>This section has two functions: 1) To set the mail merge header linesize. This is dependent on the character length of all the mail merge items you want to use. In the example, the header linesize equates approximately to 220 characters. 2) To enable the spooling of the SQL results. You must remove the REM keyword from the line that spools output to a file for the Microsoft Mailmerge. If you use concurrent processing to generate the data source file, Concurrent Manager creates the output file.</td>
</tr>
</tbody>
</table>
### PERWPOUK.sql

<table>
<thead>
<tr>
<th>Comment</th>
<th>SQL Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>This section defines the mail merge header information. These are the mail merge fields you integrate with your word processed letter. Each mail merge field is delimited by the pre-defined &amp;ch character. Ensure that the field size does not exceed 40 characters and that the field name does not include white spaces. Do not forget that the length in characters of this selected row from sys.dual is the LINESIZE value you specified above.</td>
<td><code>select 'address_line1' &amp;ch 'address_line2' &amp;ch 'address_line3' &amp;ch 'town_or_city' &amp;ch 'country' &amp;ch 'postal_code' &amp;ch 'applicant_title' &amp;ch 'applicant_last_name' &amp;ch 'position_name' &amp;ch 'organization_name' &amp;ch 'grade_name' &amp;ch 'projected_hire_date' &amp;ch 'recruiter_title' &amp;ch 'recruiter_last_name' &amp;ch from sys.dual /</code></td>
</tr>
</tbody>
</table>

| After selecting your mail merge header information, you must re-set the LINESIZE to the maximum to VARCHAR2 size which is 2000. | `REM re-initialise the linesize to the maximum 2000 varchar2 length SET LINESIZE 2000` |

| This section is the main SQL*Plus query that generates the mail merge field information. Note that the columns are merged together using the &ch character as the field delimiter. The RPAD function pads out the row of information with # for all white spaces. Without this function, mail merge cannot distinguish when a row/record has ended. The SQL*Plus query in this example is generated from letter requests. Therefore the &1 argument is used to identify which letter_request_id is being generated. | `REM Mail merge interview query select rpad( nvl(pa.address_line1, ' ') ||&ch| nvl(pa.address_line2, ' ') ||&ch| nvl(pa.address_line3, ' ') ||&ch| nvl(pa.town_or_city, ' ') ||&ch| nvl(ft.territory_short_name, ' ') ||&ch| nvl(pa.postal_code, ' ') ||&ch| nvl(hl1.meaning, ' ') ||&ch| nvl(pp1.last_name, ' ') ||&ch| nvl(pos.name, ' ') ||&ch| pou.name ||&ch| nvl(pg.name, ' ') ||&ch| nvl(to_char(pappl.projected_hire_date, 'fmDay fmddth "of" fmMonth YYYY'), ' ') ||&ch| nvl(hl2.meaning, ' ') ||&ch| nvl(pp2.last_name, ' ') ||&ch| 2000, '#') L1` |
### PERWPOUK.sql

<table>
<thead>
<tr>
<th>from</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>per_addresses pa,</td>
<td></td>
</tr>
<tr>
<td>fnd_territories ft,</td>
<td></td>
</tr>
<tr>
<td>hr_lookups h1,</td>
<td></td>
</tr>
<tr>
<td>hr_lookups h2,</td>
<td></td>
</tr>
<tr>
<td>hr_all_organization_units pou,</td>
<td></td>
</tr>
<tr>
<td>per_positions pos,</td>
<td></td>
</tr>
<tr>
<td>per_grades pg,</td>
<td></td>
</tr>
<tr>
<td>per_applications pappl,</td>
<td></td>
</tr>
<tr>
<td>per_all_people ppl,</td>
<td></td>
</tr>
<tr>
<td>per_all_people pp2,</td>
<td></td>
</tr>
<tr>
<td>per_all_assignments pasg1,</td>
<td></td>
</tr>
<tr>
<td>per_letter_request_lines plr</td>
<td></td>
</tr>
<tr>
<td>where plr.letter_request_id = &amp;1</td>
<td></td>
</tr>
<tr>
<td>and ppl.person_id =</td>
<td></td>
</tr>
<tr>
<td>plr.person_id</td>
<td></td>
</tr>
<tr>
<td>and pa.primary_flag (+) = 'Y'</td>
<td></td>
</tr>
<tr>
<td>and pa.person_id (+) =</td>
<td></td>
</tr>
<tr>
<td>ppl.person_id</td>
<td></td>
</tr>
<tr>
<td>and ft.territory_code (+) =</td>
<td></td>
</tr>
<tr>
<td>pa.country</td>
<td></td>
</tr>
<tr>
<td>and h11.lookup_code (+) =</td>
<td></td>
</tr>
<tr>
<td>ppl.title</td>
<td></td>
</tr>
<tr>
<td>and h11.lookup_type (+) = 'TITLE'</td>
<td></td>
</tr>
<tr>
<td>and pasg1.assignment_id (+) =</td>
<td></td>
</tr>
<tr>
<td>plr.assignment_id</td>
<td></td>
</tr>
<tr>
<td>and pos.position_id (+) =</td>
<td></td>
</tr>
<tr>
<td>pasg1.position_id</td>
<td></td>
</tr>
<tr>
<td>and pou.organization_id (+) =</td>
<td></td>
</tr>
<tr>
<td>pasg1.organization_id</td>
<td></td>
</tr>
<tr>
<td>and pg.grade_id (+) =</td>
<td></td>
</tr>
<tr>
<td>pasg1.grade_id</td>
<td></td>
</tr>
<tr>
<td>and pappl.application_id (+) =</td>
<td></td>
</tr>
<tr>
<td>pasg1.application_id</td>
<td></td>
</tr>
<tr>
<td>and pp2.person_id (+) =</td>
<td></td>
</tr>
<tr>
<td>pasg1.recruiter_id</td>
<td></td>
</tr>
<tr>
<td>and h12.lookup_code (+) =</td>
<td></td>
</tr>
<tr>
<td>pp2.title</td>
<td></td>
</tr>
<tr>
<td>and h12.lookup_type (+) = 'TITLE'</td>
<td></td>
</tr>
</tbody>
</table>

REM Note: SPOOL command commented out for concurrent manager.
REM update the letter request_status from PENDING to COMPLETE
REM update per_letter_requests plr
set plr.request_status = 'COMPLETE'
where plr.letter_request_id = &1
and plr.request_status = 'PENDING'

This section updates the letter request from Pending to Complete (as the example is for letter requests).
<table>
<thead>
<tr>
<th>PERWPOUK.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>REM delete the session row created</td>
<td>This section deletes the row inserted into FND_SESSIONS.</td>
</tr>
<tr>
<td>delete from fnd_sessions fs</td>
<td></td>
</tr>
<tr>
<td>where  fs.session_id = userenv('sessionid')</td>
<td></td>
</tr>
<tr>
<td>and    fs.effective_date = to_date('&amp;2','DD-MON-YYYY')</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>REM commit the changes</td>
<td>This section commits the changes and exits the SQL*Plus session.</td>
</tr>
<tr>
<td>commit</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>exit</td>
<td></td>
</tr>
</tbody>
</table>
### PERWPWUK Template

Template SQL*Plus script for mail merge letter. See Writing a SQL*Plus script for MultiMate or WordPerfect: page 6 – 20.

<table>
<thead>
<tr>
<th>PERWPWUK.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>REM</td>
<td>This section defines the required SQL*Plus environment settings.</td>
</tr>
<tr>
<td>DEFINE line_size=80</td>
<td>You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>DEFINE field_size= &amp;line_size-1</td>
<td></td>
</tr>
<tr>
<td>DEFINE ch='%'</td>
<td></td>
</tr>
<tr>
<td>SET PAGESIZE 0</td>
<td></td>
</tr>
<tr>
<td>SET LINESIZE &amp;line_size</td>
<td></td>
</tr>
<tr>
<td>BREAK ON L1 SKIP PAGE</td>
<td></td>
</tr>
<tr>
<td>COLUMN L1 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L2 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L3 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L4 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L5 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L6 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L7 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L8 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L9 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>SET FEEDBACK OFF</td>
<td></td>
</tr>
<tr>
<td>SET RECSEP OFF</td>
<td></td>
</tr>
<tr>
<td>SET HEADING OFF</td>
<td></td>
</tr>
<tr>
<td>SET VERIFY OFF</td>
<td></td>
</tr>
<tr>
<td>SET TERMOUT OFF</td>
<td></td>
</tr>
<tr>
<td>insert into fnd_sessions</td>
<td>This section creates a row in the Application Object Library table (AOL) FND_SESSIONS. The &amp;2 argument contains the current SQL*Forms session date. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>(session_id ,effective_date)</td>
<td></td>
</tr>
<tr>
<td>select userenv('SESSIONID')</td>
<td></td>
</tr>
<tr>
<td>, to_date('&amp;2','DD-MON-YYYY')</td>
<td></td>
</tr>
<tr>
<td>from sys.dual</td>
<td></td>
</tr>
<tr>
<td>REM re-initialise the linesize to the maximum 2000 varchar2 length</td>
<td>After selecting your mail merge header information, you must re-set the LINESIZE to the maximum to VARCHAR2 size which is 2000.</td>
</tr>
<tr>
<td>SET LINESIZE 2000</td>
<td></td>
</tr>
</tbody>
</table>
This section is the main SQL*Plus query that generates the mail merge field information. Note that the columns are merged together using the &ch character as the field delimiter.

The SQL*Plus query in this example is generated from letter requests. Therefore the &1 argument is used to identify which letter_request_id is being generated.

This section updates the letter request from Pending to Complete (as the example is for letter requests).

This section commits the changes and exits the SQL*Plus session.
### OTA SQL*Plus Script

Example SQL mail merge file. See Writing a SQL*Plus Script for MultiMate or WordPerfect: page 6 – 20 and Writing a SQL*Plus Script for Microsoft Word: page 6 – 21.

#### Produce Confirmation Letters

<table>
<thead>
<tr>
<th>OTA.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>WHENEVER SQLERROR EXIT FAILURE ROLLBACK REM Define the MS Word mail merge record separator</td>
<td>This section defines the required SQL*Plus environment settings. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>DEFINE ch=&quot;%'&quot; REM Define the column width for returning query results</td>
<td></td>
</tr>
<tr>
<td>COLUMN L1 FORMAT A2000 SET PAUSE OFF SET FEEDBACK OFF SET RECSEP OFF SET HEADING OFF SET VERIFY OFF SET TERMOUT OFF SET PAGESIZE 0</td>
<td></td>
</tr>
<tr>
<td>REM Insert session row</td>
<td>This section creates a row in the Application Object Library table (AOL) FND_SESSIONS. This enables the datetrack security views to be accessed for the session. The &amp;2 argument contains the current SQL*Forms session date. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>insert into fnd_sessions(session_id,effective_date)</td>
<td></td>
</tr>
<tr>
<td>select userenv('SESSIONID'),</td>
<td></td>
</tr>
<tr>
<td>to_date('&amp;2','DD-MON-YYYY')</td>
<td></td>
</tr>
<tr>
<td>from sys.dual /</td>
<td></td>
</tr>
<tr>
<td>REM Set length of the header</td>
<td>This section has two functions: 1) To set the mail merge header line size. This is dependent on the character length of all the mail merge items you want to use. In the example, the header line size equates approximately to 220 characters. 2) To enable the spooling of the SQL results. The spool file should match the name of the SQL file you are writing, but with a text file extension. 2.2</td>
</tr>
<tr>
<td>SET LINESIZE 200 REM Create the mail merge 'header' record for MS Word</td>
<td></td>
</tr>
<tr>
<td>REM Note: SPOOL command commented out for concurrent manager.</td>
<td></td>
</tr>
<tr>
<td>REM PC based solution required the SPOOL command.spool xxxxx.txt</td>
<td></td>
</tr>
<tr>
<td>OTA.sql</td>
<td>Comment</td>
</tr>
<tr>
<td>---------</td>
<td>---------</td>
</tr>
<tr>
<td>select 'student_title'</td>
<td></td>
</tr>
</tbody>
</table>

This section defines the mail merge header information. These are the mail merge fields you integrate with your word processed letter. Each mail merge field is delimited by the pre-defined &ch character. Ensure that the field size does not exceed 40 characters and that the field name does not include white spaces. Do not forget that the length in characters of this selected row from sys.dual is the line size value you specified above.

REM re-initialise the linesize to the maximum 2000 varchar2 length
SET LINESIZE 2000

After selecting your mail merge header information, you must re-set the line size to the maximum VARCHAR2 size, which is 2000.
<table>
<thead>
<tr>
<th>OTA.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>REM Mail merge confirmation query</td>
<td>This section is the main SQL<em>Plus query that generates the mail merge field information. Note that the columns are merged together using the &amp;ch character as the field delimiter. The RPAD function pads out the row of information with # for all white spaces. Without this function, mail merge cannot distinguish when a row/record has ended. The SQL</em>Plus query in this example is generated from letter requests. Therefore the &amp;1 argument is used to identify which letter_request_id is being generated.</td>
</tr>
<tr>
<td>select rpad(</td>
<td></td>
</tr>
<tr>
<td>initcap(nvl(d.delegate_title_meaning,''))</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>nvl(d.delegate_first_name,'')</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>nvl(d.delegate_last_name,'')</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>nvl(v.description,'')</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>nvl(d.event_activity_version_name,'')</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>to_char(d.course_end_date, 'DD fmMonth YYYY')</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>L1</td>
<td></td>
</tr>
<tr>
<td>from ota_delegate_bookings_v</td>
<td></td>
</tr>
<tr>
<td>d,</td>
<td></td>
</tr>
<tr>
<td>ota_activity_versions</td>
<td></td>
</tr>
<tr>
<td>v,</td>
<td></td>
</tr>
<tr>
<td>per_letter_request_lines</td>
<td></td>
</tr>
<tr>
<td>plr</td>
<td></td>
</tr>
<tr>
<td>where plr.letter_request_id = &amp;1</td>
<td></td>
</tr>
<tr>
<td>and (plr.ota_booking_id = d.booking_id</td>
<td></td>
</tr>
<tr>
<td>or plr.ota_event_id = d.event_id</td>
<td></td>
</tr>
<tr>
<td>and d.activity_version_id = v.activity_version_id</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>REM Note: SPOOL command commented out for concurrent manager.</td>
<td></td>
</tr>
<tr>
<td>REM PC based solution required the SPOOL command.</td>
<td></td>
</tr>
<tr>
<td>spool off</td>
<td></td>
</tr>
<tr>
<td>OTA.sql</td>
<td>Comment</td>
</tr>
<tr>
<td>---------</td>
<td>---------</td>
</tr>
<tr>
<td>REM Update the letter request_status from PENDING to COMPLETE update per_letter_requests plr set plr.request_status = 'COMPLETE' where plr.letter_request_id = &amp;1 and plr.request_status = 'PENDING' /</td>
<td>This section updates the letter request from Pending to Complete (as the example is for letter requests).</td>
</tr>
<tr>
<td>REM delete the session row created delete from fnd_sessions fs where fs.session_id = userenv('sessionid') and fs.effective_date = to_date('&amp;2', 'DD-MON-YYYY') /</td>
<td>This section deletes the row inserted into FND_SESSIONS.</td>
</tr>
<tr>
<td>REM commit the changes commit / exit /</td>
<td>This section commits the changes and exits the SQL*Plus session</td>
</tr>
</tbody>
</table>
Creating Standard Letters

Oracle HRMS provides you with three different methods to create standard letters using Word Processors:

- Online, using Application Data Exchange (ADE), Using Application Data Exchange.

Concurrent Processing using Word Processors

If you are setting up standard letters using MultiMate, WordPerfect or Microsoft Word, follow these steps:

<table>
<thead>
<tr>
<th>Task</th>
<th>Performed By</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planning Standard Letter Requirements: page 6 – 19</td>
<td>System Administrator</td>
</tr>
<tr>
<td>Writing a SQL<em>Plus Script for Multi-Mate or WordPerfect: page 6 – 20 or Writing a SQL</em>Plus Script for Microsoft Word: page 6 – 21</td>
<td>Yes</td>
</tr>
<tr>
<td>Registering the SQL*Plus Script: page 6 – 22</td>
<td>HRMS Manager (or HR Assistant)</td>
</tr>
<tr>
<td>Linking the SQL*Plus Script With a Letter: page 6 – 23</td>
<td>Yes</td>
</tr>
<tr>
<td>Writing a Skeleton Letter: page 6 – 24</td>
<td>Yes</td>
</tr>
<tr>
<td>Requesting Letters/Running the Report: page 6 – 25</td>
<td>Yes</td>
</tr>
<tr>
<td>Merging the Data Files with the Standard Letter: page 6 – 27</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Using Oracle Reports to Set Up Standard Letters

You can create a report for each letter using Oracle Reports, or another tool of your choice. The report contains the skeleton letter text and Select statements specifying the data to be extracted from the Oracle database.

The sequence in which you set up standard letters using Oracle Reports is identified below.

<table>
<thead>
<tr>
<th>Task</th>
<th>Performed By:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planning Standard Letter Requirements: page 6 – 19</td>
<td>Yes</td>
</tr>
<tr>
<td>Writing and Registering the Report: page 6 – 28</td>
<td>Yes</td>
</tr>
<tr>
<td>Linking the Report With a Letter: page 6 – 29</td>
<td>Yes</td>
</tr>
<tr>
<td>Requesting Letters/Running the Report: page 6 – 25</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Planning Standard Letter Requirements

Before creating standard letters, you need to identify several things.

To plan standard letter requirements:

1. Identify the database information to include in the letters.
   You need to identify the select statements to provide you with the data as the content of your letters. Oracle HRMS supplies you with SQL*Plus scripts as templates to help you do this.

2. Identify the text that you want to include as the body of your letters.

3. Decide whether to associate your standard letters with student enrollment or applicant assignment statuses.

4. Identify which statuses you want to trigger your standard letters (if you do want to link your standard letters to student enrollment or applicant assignment statuses).
   For example, do you want to link your standard enrollment confirmation letter to the status Placed so that the letter is triggered when you set a student’s enrollment status to Placed? Do you want to link your standard rejection letter to the status Rejected so that it is triggered when an applicant’s assignment status is set to Rejected?
Writing a SQL*Plus Script for MultiMate or WordPerfect

Oracle HRMS supplies you with SQL*Plus scripts as templates for extracting database information for standard letters. You can copy the SQL*Plus script templates and modify them to create the standard letters you require.

The template scripts Oracle HRMS provides are:

<table>
<thead>
<tr>
<th>Scripts</th>
<th>Purpose</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>PERWPMUK.sql</td>
<td>Example UK SQL*Plus script for MultiMate</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPMUS.sql</td>
<td>Example US SQL*Plus script for MultiMate</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPWUK.sql</td>
<td>Example US SQL*Plus script for WordPerfect</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPWUS.sql</td>
<td>Example US SQL*Plus script for WordPerfect</td>
<td>HR</td>
</tr>
</tbody>
</table>

One of the template SQL*Plus scripts (PERWPWUK.sql) is provided as an example. See PERWPWUK Template: page 6 – 11.

Oracle Training Administration does not provide template scripts, but we provide an example of a Confirmation letter SQL mail merge file. See OTA SQL*Plus Script: page 6 – 13

To write a SQL*Plus script for MultiMate or WordPerfect:

1. Copy the appropriate SQL*Plus script from the server side sql directory of the HR product tree (consult your installation guide for details).

2. Edit (or write) a SQL*Plus script to select data from the database in a format your word processor can read and that is compatible with the standard letter.

3. Save the file with the name PERWP*** (or OTAWP*** for OTA).

   You must use this prefix for the system to recognize it as a type of letter. See your Oracle Applications installation server guides for details of where the concurrent manager places the files.
Writing a SQL*Plus Script for Microsoft Word

Oracle HRMS supplies four SQL*Plus script templates.

You can run the scripts on the server side and make them accessible to other users across the network, or you must copy them to a directory which is accessible from the PC, such as a network drive.

The template scripts that Oracle HRMS provides are:

<table>
<thead>
<tr>
<th>Scripts</th>
<th>Purpose</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>PERWPOUS.sql</td>
<td>Example US Offer letter SQL mail merge file</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPOUK.sql</td>
<td>Example UK Offer letter SQL mail merge file</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPIUS.sql</td>
<td>Example US Interview letter SQL mail merge file</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPIUK.sql</td>
<td>Example UK Interview letter SQL mail merge file</td>
<td>HR</td>
</tr>
</tbody>
</table>

One of the template SQL*Plus scripts is provided as an example. See Template SQL*Plus Script PERWPOUK: page 6 – 7

Oracle Training Administration does not provide template scripts, but we provide an example of a Confirmation letter SQL mail merge file. See OTA SQL*Plus Script: page 6 – 13

To write a SQL*Plus script for Microsoft Word:

1. Copy the SQL*Plus scripts from the server side sql directory of the HR product tree. (Consult your installation guide for details).

2. Edit (or write) a SQL*Plus script to select data from the database in a format your word processor can read and is compatible with the standard letter.

3. Save the file with the name PERWP*** (or OTAWP*** for OTA).

You must use this prefix for the system to recognize it as a type of letter. See your Oracle Applications installation server guides for details of where the concurrent manager places the files.
Registering the SQL*Plus Script

Register your SQL*Plus program with Oracle HRMS. You register your program so that you can run it as a concurrent program. Name the file PERWP*** (or OTA WP***). You must use this prefix for the system to recognize it as a type of letter.

You use the Concurrent Programs window to register your program (using a system administrator responsibility).

See: Concurrent Programs Window, Oracle Applications System Administrator’s Guide
Linking the SQL*Plus Script With a Letter

You need to link your SQL*Plus script with a letter and one or more statuses. In Oracle Human Resources, you can link one or more applicant assignment statuses with each recruitment letter. A request for the letter is then created automatically when an applicant is given an associated assignment status. For example, you can link your standard recruitment rejection letter to the status Rejected so that the letter is triggered when you set an applicant’s assignment status to Rejected.

In Oracle Training Administration, you can link one or more enrollment statuses with each enrollment letter. A request for the letter is then created automatically when an enrollment is given an associated status.

Define your standard letter types in the Letter window.

► To define a standard letter type:

1. Enter a name for the letter in the Name field.

2. Select the Concurrent Program Name assigned by your System Administrator to the SQL*Plus script.

For Oracle Human Resources:

3. Select one or more applicant assignment statuses to create letter requests automatically for applicants, and check the Enabled box.

   When an applicant is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the applicant is added to the list of people to receive the letter when you submit the request.

For Oracle Training Administration:

4. Select one or more enrollment statuses to create letter requests automatically for enrollments, and check the Enabled box.

   When an enrollment is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the enrollment is added to the list of people to receive the letter when you submit the request.
Writing a Skeleton Letter

Write a skeleton letter using your word processor. Include the appropriate merge codes from the data source for the word processor you are using.

Figure 6 – 2 Merging Data with Standard Letters

The mail merge feature of any word processor enables you to merge text from the data file you create into a standard letter. Each line in the data file contains the text to merge into one standard letter for one recipient.

Within the program, you can format the data and include the characters that are recognized as separators by your word processor.

A standard letter comprises standard text with a number of embedded variables in it. When you print the letter, the variables are replaced with specific items of data, such as name and address details for different people.
Requesting Letters/Running the Report

When you, or other users, set the status for an applicant or enrollment that triggers your standard letters, Oracle HRMS creates a letter request automatically, with the status of Pending. It also adds the applicant’s or student’s name to the request. You can view the pending request and names through the Request Letter window.

Then, when you change the letter request from Pending to Requested, Oracle HRMS runs the report or SQL*Plus script for this type of letter. You can add further names to the list manually, if required. For example, you might have a last minute acknowledgement letter to send.

You can also create manual letter requests. You do this by entering the status of Pending yourself, then entering all the recipients of the letter before changing the status of the letter to Requested.

► To submit an automatic letter request:
1. Query the letter you require in the Letter Name field.
2. Ensure that the method is Automatic.
3. Move to the Requested For block to query the applicants, events or students that have been entered automatically on this request, according to their status. You can add further names manually.
4. Update the status from Pending to Requested.
5. Save your changes.
6. You can query the request ID in the Concurrent Requests window and monitor its progress.

   **Note:** Consult your installation guide for details of the location Concurrent Manager places the output or data file.

► To create a manual letter request:
1. Select the Letter Name for the letter type you want to request.
2. Ensure that the method is Manual.
3. Leave the status of the request as Pending.
4. Save the changes.
Adding the Names

5. Select the names to add:

- Select employees or applicants (for Oracle Human Resources) to receive the letter in the Requested For region.
  The Assignment field displays the organization to which the person is assigned. You can view the other components of the assignment by choosing List of Values from the Edit menu.
- Select events or students or both (for Oracle Training Administration) in the Requested For region.
  This depends on how the letter has been set up on your system. For example, an enrollment confirmation letter might be defined so that it is sent to all students with the status Confirmed who are enrolled on the event selected in the Requested For region.

6. Save the changes.

Changing the Status

7. Update the status from Pending to Requested.

8. Save the changes.

A concurrent request ID number appears in the Concurrent Request field. When the Concurrent Manager has processed the request it changes the status to Completed.

9. You can query the request ID in the Concurrent Requests window and monitor its progress.

  Note: Consult your installation guide for details of the location Concurrent Manager places the output file.
Merging the Data File with the Standard Letter

When the concurrent manager has finished processing a letter request, you can merge the data in the Data File with your skeleton letters.

To merge the data file with the standard letter:

1. Merge the data in the Data File with your skeleton letters to create your standard letters. The merging of text and data files is normally carried out using the mail merge features of your word processor.

   If you do not have access to the directory where the Data File resides (consult your installation guide for details of the location Concurrent Manager places the file), you need to transfer the mail merge files created by the concurrent process to your word processor before you can merge the data file with the skeleton letters.

2. If you are using a word processor to merge the data file, you need to save the merged letters you generate.

   If you do not save the merged letters, when you exit the word processor you lose the letters. You do not lose the data file or the skeleton letter, however.
Writing and Registering the Report

You need to write and register the report.

**To write and register the report:**

1. Identify which data you want to extract from the database. Write your skeleton letter text and Select statements specifying the data to be extracted from the Oracle database.

2. Register your report with Oracle HRMS. You register your report so that you can run it as a concurrent program. Name the file PERWP*** (or OTAWP*** for OTA). You must use this prefix for the system to recognize it.

   You use the Concurrent Programs window to register your report (using a system administrator responsibility).

See: Concurrent Programs Window, *Oracle Applications System Administrator’s Guide*
Linking the Report With a Letter

You need to link your report with a letter and one or more statuses. In Oracle Human Resources, you can link one or more applicant assignment statuses with each recruitment letter. A request for the letter is then created automatically when an applicant is given an associated assignment status. In Oracle Training Administration, you can link one or more enrollment statuses with each enrollment letter. A request for the letter is then created automatically when an enrollment is given an associated status.

For example, you can link your standard recruitment rejection letter to the status Rejected so that the letter is triggered when you set an applicant’s assignment status to Rejected.

Define your standard letter types in the Letter window.

► To define a standard letter type:

1. Enter a name for the letter in the Name field.
2. Select the concurrent program name assigned by your system administrator to the report.
3. Select one or more applicant assignment statuses to create letter requests automatically for applicants, and check the Enabled box.
   When an applicant is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the applicant is added to the list of people to receive the letter when you submit the request.
4. Select one or more enrollment statuses to create letter requests automatically for enrollments, and check the Enabled box.
   When an enrollment is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the enrollment is added to the list of people to receive the letter when you submit the request.
Default Menus, Windows, Reports and Processes
Default Navigation Menu for SuperHRMS Responsibility

This appendix shows the default menu path for each window in Oracle HRMS. Your system administrator can define new menus to incorporate the Oracle HRMS options to the existing responsibilities at your site.

The second section shows the default navigation paths for all the windows in Oracle HRMS, which are arranged alphabetically by window title. The windows for optional Oracle HRMS applications (such as Oracle SSP/SMP) are shown with their default responsibilities.

<table>
<thead>
<tr>
<th>MENU ENTRY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>People</td>
<td></td>
</tr>
<tr>
<td>Enter and Maintain</td>
<td>Enter personal and assignment information</td>
</tr>
<tr>
<td>Maintain Using Templates</td>
<td></td>
</tr>
<tr>
<td>Hire Applicants</td>
<td>Enter and Hire Applicants</td>
</tr>
<tr>
<td>Enter Employees</td>
<td>Enter employees quickly</td>
</tr>
<tr>
<td>Maintain Employees</td>
<td>Enter and maintain full employee details</td>
</tr>
<tr>
<td>Maintain Visa Details</td>
<td>Enter and maintain visa details</td>
</tr>
<tr>
<td>Salary Management</td>
<td>Manage salary details</td>
</tr>
<tr>
<td>Benefits Service Center</td>
<td>Enter changes to a person record and process elections</td>
</tr>
<tr>
<td>Total Comp Participation</td>
<td></td>
</tr>
<tr>
<td>Person Benefit Balances</td>
<td>Enter benefit balances for a person</td>
</tr>
<tr>
<td>Person Benefits Assignment</td>
<td>Maintain person benefits assignment</td>
</tr>
<tr>
<td>View Participation Information</td>
<td>View eligible plans and options for a person</td>
</tr>
<tr>
<td>Participation Overrides</td>
<td>Override plan eligibility criteria for a person</td>
</tr>
<tr>
<td>What–if Eligibility</td>
<td>Modify benefits eligibility based on potential changes</td>
</tr>
<tr>
<td>COBRA Qualified Beneficiaries</td>
<td>Maintain COBRA Qualified beneficiary information</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------</td>
</tr>
<tr>
<td><strong>Benefits</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Enrollment</strong></td>
<td></td>
</tr>
<tr>
<td>View Enrollment</td>
<td>View current enrollments</td>
</tr>
<tr>
<td>Results</td>
<td></td>
</tr>
<tr>
<td>Flex Program</td>
<td>Enter flex credit program enrollments</td>
</tr>
<tr>
<td>Non-flex</td>
<td></td>
</tr>
<tr>
<td>Program</td>
<td>Enter non-flex program enrollments</td>
</tr>
<tr>
<td>Savings Plan</td>
<td>Enter savings plan enrollments</td>
</tr>
<tr>
<td>Miscellaneous Plan</td>
<td>Enter enrollments for plans that are not in a program</td>
</tr>
<tr>
<td>Enrollment Override</td>
<td>Plan enrollment override</td>
</tr>
<tr>
<td>Dependent/Beneficiary</td>
<td>Record dependents and beneficiaries for a benefit plan</td>
</tr>
<tr>
<td>Designation</td>
<td></td>
</tr>
<tr>
<td>Person Primary Care Provider</td>
<td>Record a participant’s primary care provider</td>
</tr>
<tr>
<td>Court Orders</td>
<td>Record court orders for participants</td>
</tr>
<tr>
<td><strong>Enrollment Process</strong></td>
<td></td>
</tr>
<tr>
<td>Person Life Event</td>
<td>View a person’s active life event</td>
</tr>
<tr>
<td>Person Enrollment</td>
<td>Record the completion of an action item</td>
</tr>
<tr>
<td>Action Items</td>
<td></td>
</tr>
<tr>
<td>Person Enrollment</td>
<td>Record receipt of a certification</td>
</tr>
<tr>
<td>Certifications</td>
<td></td>
</tr>
<tr>
<td>Person Communications</td>
<td>Send a communication</td>
</tr>
<tr>
<td><strong>Total Comp</strong></td>
<td></td>
</tr>
<tr>
<td>Distribution</td>
<td></td>
</tr>
<tr>
<td>Reimbursement</td>
<td>Record a request for expense reimbursement</td>
</tr>
<tr>
<td>Requests</td>
<td></td>
</tr>
<tr>
<td><strong>Total Comp</strong></td>
<td></td>
</tr>
<tr>
<td>Contribution</td>
<td></td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td><em>Record</em></td>
<td>Record amount paid for a continuing benefit</td>
</tr>
<tr>
<td><em>Continuing Benefits</em></td>
<td></td>
</tr>
<tr>
<td><em>Payment</em></td>
<td></td>
</tr>
<tr>
<td><em>Monthly Participant Premium</em></td>
<td>Monitor monthly participant premium information</td>
</tr>
<tr>
<td><em>Monthly Premiums</em></td>
<td>Maintain monthly plans and option premium information</td>
</tr>
<tr>
<td><em>Manual Payments</em></td>
<td>Maintain participant contribution/distribution</td>
</tr>
<tr>
<td><em>Events and Bookings</em></td>
<td>Enter events and bookings</td>
</tr>
<tr>
<td><em>Delete Personal Records</em></td>
<td>Remove all records for any person</td>
</tr>
<tr>
<td><em>Manage Contracts</em></td>
<td>Find and manage contracts</td>
</tr>
<tr>
<td><em>Mass Updates for Person</em></td>
<td></td>
</tr>
<tr>
<td>Mass Update of Applicant Assignments</td>
<td>Update full applicant details for selected assignments</td>
</tr>
<tr>
<td>Mass Update of Employee Assignments</td>
<td>Update full employee details for selected assignments</td>
</tr>
<tr>
<td><em>FastPath</em></td>
<td>Navigate directly to personal and assignment</td>
</tr>
<tr>
<td><em>Absence</em></td>
<td>Enter absence information</td>
</tr>
<tr>
<td><em>Accruals</em></td>
<td>View net accruals to date</td>
</tr>
<tr>
<td><em>Address</em></td>
<td>Enter address details</td>
</tr>
<tr>
<td><em>Adjust Balances</em></td>
<td>Adjust balances</td>
</tr>
<tr>
<td><em>Application</em></td>
<td>Enter application details</td>
</tr>
<tr>
<td><em>Assignment</em></td>
<td>Enter assignment details</td>
</tr>
<tr>
<td><em>Assignment Budget</em></td>
<td>Enter budget values for an assignment</td>
</tr>
<tr>
<td><em>Assignment Extra Information</em></td>
<td>Enter Extra Information Types for an assignment</td>
</tr>
<tr>
<td><em>Basic Benefits</em></td>
<td>View basic benefit details</td>
</tr>
<tr>
<td><em>Competence Profile</em></td>
<td>Define a competence profile</td>
</tr>
<tr>
<td><em>Contact</em></td>
<td>Enter contact information</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>---------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Costing</td>
<td>Enter cost details for an assignment</td>
</tr>
<tr>
<td>Disabilities</td>
<td>Enter disabilities for a person</td>
</tr>
<tr>
<td>Employee Balances</td>
<td>View employee balances</td>
</tr>
<tr>
<td>Employee Review</td>
<td>Perform an employee review</td>
</tr>
<tr>
<td>End Application</td>
<td>End an application</td>
</tr>
<tr>
<td>End Employment</td>
<td>Enter termination details for an employee</td>
</tr>
<tr>
<td>Entries</td>
<td>Maintain element entries and values for an assignment</td>
</tr>
<tr>
<td>Event</td>
<td>Book an event for a person</td>
</tr>
<tr>
<td>External/Manual</td>
<td>Enter external or manual payments for an employee</td>
</tr>
<tr>
<td>Payments</td>
<td></td>
</tr>
<tr>
<td>Grade Step</td>
<td>Enter grade step placement for an assignment</td>
</tr>
<tr>
<td>Pay Method</td>
<td>Enter personal payment methods for an assignment</td>
</tr>
<tr>
<td>Person Extra</td>
<td>Enter Extra Information Types for a person</td>
</tr>
<tr>
<td>Information</td>
<td></td>
</tr>
<tr>
<td>Person Type Usage</td>
<td>Enter person types</td>
</tr>
<tr>
<td>Person Delivery</td>
<td>Enter delivery method for personal communications</td>
</tr>
<tr>
<td>Method</td>
<td></td>
</tr>
<tr>
<td>Phones</td>
<td>Enter phone numbers</td>
</tr>
<tr>
<td>Picture</td>
<td>Enter a picture for a person</td>
</tr>
<tr>
<td>Qualifications</td>
<td>Define qualifications</td>
</tr>
<tr>
<td>Quickpay</td>
<td>Run QuickPay for one employee</td>
</tr>
<tr>
<td>Reverse Payroll Run</td>
<td>Reverse payroll run results for one employee</td>
</tr>
<tr>
<td>Salary</td>
<td>Maintain salary for an employee</td>
</tr>
<tr>
<td>Salary History</td>
<td>View salary history</td>
</tr>
<tr>
<td>Secondary Status</td>
<td>Enter secondary status for an assignment</td>
</tr>
<tr>
<td>Service History</td>
<td>Enter service history details</td>
</tr>
<tr>
<td>Special Information</td>
<td>Enter Special Information Types for a person</td>
</tr>
<tr>
<td>Tax Balances</td>
<td>View tax balances</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Termination Payments</td>
<td>Maintain termination payments.</td>
</tr>
<tr>
<td>(Australia)</td>
<td></td>
</tr>
<tr>
<td>UK P45 Form</td>
<td>View and print a P45 form.</td>
</tr>
<tr>
<td>UK Statement of Earnings</td>
<td>View statement of earnings.</td>
</tr>
<tr>
<td>UK Tax</td>
<td>Enter UK tax details.</td>
</tr>
<tr>
<td>US Tax Information</td>
<td>Enter US tax details.</td>
</tr>
<tr>
<td>Adjust Tax Balances</td>
<td>Adjust US tax balances.</td>
</tr>
<tr>
<td>US/CA Address</td>
<td>Enter US or Canadian address details.</td>
</tr>
<tr>
<td>Tax Balance Summary</td>
<td>View tax balance summary information.</td>
</tr>
<tr>
<td>Work Incidents</td>
<td>Enter work incidents for a person.</td>
</tr>
<tr>
<td>Recruitment</td>
<td>Manage recruiting</td>
</tr>
<tr>
<td>Requisition and Vacancy</td>
<td>Enter a requisition and any vacancies.</td>
</tr>
<tr>
<td>Recruitment Activity</td>
<td>Enter a recruitment activity</td>
</tr>
<tr>
<td>Applicant Quick Entry</td>
<td>Quick entry of personal and application information</td>
</tr>
<tr>
<td>Mass Update of Applicants</td>
<td>Update status of all applicants</td>
</tr>
<tr>
<td>Request Recruitment Letter</td>
<td>Request a mailmerge file or a standard letter</td>
</tr>
<tr>
<td>Career Management</td>
<td>Career Management</td>
</tr>
<tr>
<td>Rating Scales</td>
<td>Define general methods of measuring competencies</td>
</tr>
<tr>
<td>Competencies</td>
<td>Define competencies</td>
</tr>
<tr>
<td>Competence Types</td>
<td>Group competencies into types</td>
</tr>
<tr>
<td>Competence Requirements</td>
<td>Define requirements for enterprise, organizations, jobs and positions</td>
</tr>
<tr>
<td>Schools &amp; Colleges</td>
<td>Define name and location of training establishments</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Qualification Types</td>
<td>Define, categorize and rank qualifications</td>
</tr>
<tr>
<td>Assessment Template</td>
<td>Select competencies and rating scale for an assessment</td>
</tr>
<tr>
<td>Appraisal Template</td>
<td>Select questionnaire and rating scale for an appraisal</td>
</tr>
<tr>
<td><strong>Work Structures</strong></td>
<td></td>
</tr>
<tr>
<td>Location</td>
<td>Enter work structures</td>
</tr>
<tr>
<td>2. Extra Information</td>
<td></td>
</tr>
<tr>
<td>Collective Agreements</td>
<td>Define and handle collective agreements</td>
</tr>
<tr>
<td>Collective Agreements and Grade Structure</td>
<td>Define and handle collective agreement grades</td>
</tr>
<tr>
<td>Organization</td>
<td>Enter organizational information</td>
</tr>
<tr>
<td>Description</td>
<td>Enter information for an organization</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Structure organizations into hierarchies</td>
</tr>
<tr>
<td>Diagrammer</td>
<td>Arrange and view organization hierarchies</td>
</tr>
<tr>
<td><strong>Job</strong></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Enter job–related information</td>
</tr>
<tr>
<td>Path Name</td>
<td>Enter job names</td>
</tr>
<tr>
<td>Career Path</td>
<td>Enter career paths for jobs</td>
</tr>
<tr>
<td>Workers Compensation Rates</td>
<td>Enter rates for WC codes</td>
</tr>
<tr>
<td>Workers Compensation Codes</td>
<td>Enter WC codes for jobs</td>
</tr>
<tr>
<td>Salary Survey</td>
<td></td>
</tr>
<tr>
<td>Extra Information</td>
<td></td>
</tr>
<tr>
<td>Job Groups</td>
<td>Enter Job Groups</td>
</tr>
<tr>
<td><strong>Position</strong></td>
<td></td>
</tr>
<tr>
<td>Description</td>
<td>Enter position names</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Structure positions into hierarchies</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td>Diagrammer</td>
<td>Arrange and view position hierarchies</td>
</tr>
<tr>
<td>Mass Move</td>
<td>Enter details of a mass move</td>
</tr>
<tr>
<td>Position Transaction</td>
<td>Define a position for a position-controlled organization</td>
</tr>
<tr>
<td>Position Copy</td>
<td>Copy positions</td>
</tr>
<tr>
<td>Mass Position Update</td>
<td>Mass update positions</td>
</tr>
<tr>
<td>Grade</td>
<td>Enter grade–related information</td>
</tr>
<tr>
<td>Description</td>
<td>Enter grade names</td>
</tr>
<tr>
<td>Grade Rate</td>
<td>Enter rates and values for grades</td>
</tr>
<tr>
<td>Pay Scale</td>
<td>Create a pay scale of fixed progression points</td>
</tr>
<tr>
<td>Point Values</td>
<td>Enter values for progression points</td>
</tr>
<tr>
<td>Grade Steps and Points</td>
<td>Enter grade steps and fixed point values for each step</td>
</tr>
<tr>
<td>Budget</td>
<td>Define and maintain budget information</td>
</tr>
<tr>
<td>Budget Worksheet</td>
<td>Enter values for a budget worksheet</td>
</tr>
<tr>
<td>Budget Details</td>
<td>Enter values for a non–workflow routed budget</td>
</tr>
<tr>
<td>Budget Reallocation</td>
<td>Reallocate budget amounts</td>
</tr>
<tr>
<td>Budget Calendar</td>
<td>Define calendars for headcount and position budgets</td>
</tr>
<tr>
<td>Budget Set</td>
<td>Define the elements in a budget set</td>
</tr>
<tr>
<td>Budget Characteristics</td>
<td>Define the properties of a budget</td>
</tr>
<tr>
<td>Elections</td>
<td>Enter election information</td>
</tr>
<tr>
<td>Status</td>
<td>Define employee and applicant assignment statuses</td>
</tr>
<tr>
<td>Recruitment Letter Type</td>
<td>Associate letter types with applicant statuses</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Contract Letter</td>
<td>Define letter types for contracts</td>
</tr>
<tr>
<td>Type</td>
<td>Enter information types for payrolls</td>
</tr>
<tr>
<td>Payroll</td>
<td>Define payroll groups</td>
</tr>
<tr>
<td>Description</td>
<td>Define consolidation sets for payroll run results</td>
</tr>
<tr>
<td>Consolidation</td>
<td>Define available payment methods</td>
</tr>
<tr>
<td>Payment Methods</td>
<td>Map payroll costing to Oracle GL flexfield segments</td>
</tr>
<tr>
<td>GL Flexfield Map</td>
<td>Update consolidation set or pay advice date</td>
</tr>
<tr>
<td>Update Payroll Run</td>
<td>Define employee assignment sets</td>
</tr>
<tr>
<td>Assignment Set</td>
<td>Define element and distribution sets</td>
</tr>
<tr>
<td>Element Set</td>
<td>Define retropay sets using balances and elements</td>
</tr>
<tr>
<td>RetroPay Set</td>
<td>Enter currency exchange rates for reporting and processing</td>
</tr>
<tr>
<td>GL Daily Rates</td>
<td>Define conversion rate types for multiple exchange rates</td>
</tr>
<tr>
<td>Conversion Rate</td>
<td>Enter monetary units for cash analysis and distribution</td>
</tr>
<tr>
<td>Types</td>
<td>Enter information on compensation and benefits</td>
</tr>
<tr>
<td>Monetary Units</td>
<td>Basic</td>
</tr>
<tr>
<td>Element Description</td>
<td>Enter compensation and benefit information</td>
</tr>
<tr>
<td>Link</td>
<td>Enter eligibility rules for compensation and benefits</td>
</tr>
<tr>
<td>Earnings</td>
<td>Activate and review earnings types</td>
</tr>
<tr>
<td>Tax Withholding</td>
<td>Enter withholding rules for earnings</td>
</tr>
<tr>
<td>Rules</td>
<td>Enter available salary bases for salary administration</td>
</tr>
<tr>
<td>Salary Basis</td>
<td>Enter salary survey information</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td>Deductions</td>
<td>Activate and review deductions</td>
</tr>
<tr>
<td>Benefit</td>
<td>Enter benefit contribution levels and values</td>
</tr>
<tr>
<td>Contributions</td>
<td></td>
</tr>
<tr>
<td>Absence Types</td>
<td>Define absence types</td>
</tr>
<tr>
<td>Accrual Plans</td>
<td>Enter accrual plans</td>
</tr>
<tr>
<td>Write Formulas</td>
<td>Enter and modify formulas</td>
</tr>
<tr>
<td>Formula Results</td>
<td>Define what happens to formula results</td>
</tr>
<tr>
<td>Global Values</td>
<td>Enter global values for use in formulas</td>
</tr>
<tr>
<td>Balance</td>
<td>Enter balances with feeds and dimensions</td>
</tr>
<tr>
<td>Classification</td>
<td>Define additional element classifications</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>Definitions</td>
<td></td>
</tr>
<tr>
<td>Eligibility/Rate</td>
<td></td>
</tr>
<tr>
<td>Factors</td>
<td></td>
</tr>
<tr>
<td>Benefits Groups</td>
<td>Define a benefits group</td>
</tr>
<tr>
<td>Benefits Balances</td>
<td>Define benefit balance types</td>
</tr>
<tr>
<td>Derived Factors</td>
<td>Define derived factors used to determine eligibility and activity rates</td>
</tr>
<tr>
<td>Postal/Zip</td>
<td>Define numeric postal ranges for eligibility and activity rates</td>
</tr>
<tr>
<td>Service Areas</td>
<td>Define a geographical service area by postal code ranges</td>
</tr>
<tr>
<td>Eligibility</td>
<td></td>
</tr>
<tr>
<td>Profiles</td>
<td></td>
</tr>
<tr>
<td>Participant</td>
<td>Define eligibility profiles for participants</td>
</tr>
<tr>
<td>Dependent</td>
<td>Define eligibility profiles for dependents</td>
</tr>
<tr>
<td>Coverage</td>
<td></td>
</tr>
<tr>
<td>Additional Setup</td>
<td></td>
</tr>
<tr>
<td>Program/Plan</td>
<td>Define periods for benefit programs and plans</td>
</tr>
<tr>
<td>Years</td>
<td></td>
</tr>
<tr>
<td>Regulations</td>
<td>Record policies that govern plan administration</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Reporting Groups</td>
<td>Group programs and plans</td>
</tr>
<tr>
<td>Benefits Balances</td>
<td>Define benefit balance types</td>
</tr>
<tr>
<td>Goods and Services</td>
<td>Define reimbursable goods and services</td>
</tr>
<tr>
<td>Life Event Reasons</td>
<td>Define life events</td>
</tr>
<tr>
<td>Collapse Life Events</td>
<td>Define collapsible life events</td>
</tr>
<tr>
<td>Communication Types</td>
<td>Define communications</td>
</tr>
<tr>
<td>Enrollment Action Types</td>
<td>Define action items</td>
</tr>
<tr>
<td>Programs and Plans</td>
<td></td>
</tr>
<tr>
<td>View Program Structure</td>
<td>View the benefits program hierarchy</td>
</tr>
<tr>
<td>Plan Types</td>
<td>Define benefit plan types</td>
</tr>
<tr>
<td>Options</td>
<td>Define benefit options</td>
</tr>
<tr>
<td>Plans</td>
<td>Define benefit plans</td>
</tr>
<tr>
<td>Plan Enrollment Requirements</td>
<td>Define benefit plan enrollment requirements</td>
</tr>
<tr>
<td>Plan Reimbursements</td>
<td>Define reimbursement plans</td>
</tr>
<tr>
<td>Programs</td>
<td>Define benefit programs</td>
</tr>
<tr>
<td>Program Enrollment Requirements</td>
<td>Define benefit program enrollment requirements</td>
</tr>
<tr>
<td>Rates/Coverage Definitions</td>
<td></td>
</tr>
<tr>
<td>Variable Rate Profiles</td>
<td>Define variable activity rate profiles</td>
</tr>
<tr>
<td>Standard Rates</td>
<td>Define activity rate calculations</td>
</tr>
<tr>
<td>Period-to-Date Limits</td>
<td>Define period-to-date limits</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-------------------</td>
<td>--------------------------------------------------------------------</td>
</tr>
<tr>
<td>Coverage</td>
<td>Define benefit coverage calculations</td>
</tr>
<tr>
<td>Calculations</td>
<td></td>
</tr>
<tr>
<td>Coverage Across</td>
<td>Define coverage across plan types</td>
</tr>
<tr>
<td>Plan Types</td>
<td></td>
</tr>
<tr>
<td>Actual Premiums</td>
<td>Define actual premium costs</td>
</tr>
<tr>
<td>Imputed Income</td>
<td>Define imputed income calculations</td>
</tr>
<tr>
<td>Combinations</td>
<td>Define combinations of plans, plan types and options and plan types</td>
</tr>
<tr>
<td>Flex Credits</td>
<td>Define flex credit calculations</td>
</tr>
<tr>
<td>Benefits Pools</td>
<td>Define flex credit benefit pools</td>
</tr>
<tr>
<td>Combinations</td>
<td>Define combinations of plans, plan types and options and plan types</td>
</tr>
<tr>
<td>Flex Credits</td>
<td>Define flex credit calculations</td>
</tr>
<tr>
<td>Monthly Premiums</td>
<td>Monthly premium information</td>
</tr>
<tr>
<td>Wage Attachment</td>
<td>View Wage Attachment</td>
</tr>
<tr>
<td>Earnings Rules</td>
<td>Define wage Attachments Earnings Rules</td>
</tr>
<tr>
<td>Exemption Rules</td>
<td>Define Wage Attachments Exemption Rules</td>
</tr>
<tr>
<td>Fee Rules</td>
<td>Define Wage Attachments Fee Rules</td>
</tr>
<tr>
<td>Limit Rules</td>
<td>Define Wage Attachments Limit Rules</td>
</tr>
<tr>
<td>View Histories</td>
<td>View HRMS information</td>
</tr>
<tr>
<td>Employee Assignment</td>
<td>Employee assignment history</td>
</tr>
<tr>
<td>Absence</td>
<td>Employee absence history folder</td>
</tr>
<tr>
<td>Run Results</td>
<td>Employee run result history</td>
</tr>
<tr>
<td>Salary</td>
<td>Salary history for an employee assignment</td>
</tr>
<tr>
<td>1 Assignment</td>
<td>2 Salary History</td>
</tr>
<tr>
<td>1 Assignment</td>
<td>2 Entry History</td>
</tr>
<tr>
<td>Density</td>
<td>Entry history for an employee assignment</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Contribution Histories (Def Comp 457)</td>
<td>Employee Contribution History (Deferred Compensation 457)</td>
</tr>
<tr>
<td>Lists</td>
<td></td>
</tr>
<tr>
<td>People Folder</td>
<td>People folder</td>
</tr>
<tr>
<td>Assignment Folder</td>
<td>Assignment folder</td>
</tr>
<tr>
<td>People by Assignment</td>
<td>List people by assignment folder</td>
</tr>
<tr>
<td>Assignments</td>
<td>List assignments folder</td>
</tr>
<tr>
<td>Employees by Organization</td>
<td>List employees by organization folder</td>
</tr>
<tr>
<td>Employees by Position</td>
<td>List employees by position folder</td>
</tr>
<tr>
<td>Emps by Position Hierarchy</td>
<td>List employees by position hierarchy folder</td>
</tr>
<tr>
<td>Employees by Element</td>
<td>List employees by element</td>
</tr>
<tr>
<td>Employees by Absence Type</td>
<td>List employees by absence type folder</td>
</tr>
<tr>
<td>People by Special Information</td>
<td>List people by special information folder</td>
</tr>
<tr>
<td>Vacancies</td>
<td>View vacancies folder</td>
</tr>
<tr>
<td>Organization Budgets</td>
<td>View organization budget variance folder</td>
</tr>
<tr>
<td>Position Budgets</td>
<td>View position budget variance folder</td>
</tr>
<tr>
<td>Grade Comparatio</td>
<td>View employee grade comparatio folder</td>
</tr>
<tr>
<td>Employee Benefits</td>
<td>View benefits for an employee assignment</td>
</tr>
<tr>
<td>Employee Accruals</td>
<td>View net accruals to date</td>
</tr>
<tr>
<td>Employee Balances</td>
<td>View employee balances for earnings and deductions</td>
</tr>
<tr>
<td>Tax Balances</td>
<td>View Employee Tax Balances</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>Payroll Process Results</td>
<td>View process results for a payroll</td>
</tr>
<tr>
<td>Assignment Process Results</td>
<td>View process results for an employee assignment</td>
</tr>
<tr>
<td>System Messages</td>
<td>View system level messages</td>
</tr>
<tr>
<td>Processes and Reports</td>
<td></td>
</tr>
<tr>
<td>Submit Processes and Reports</td>
<td>Submit processes or run standard reports</td>
</tr>
<tr>
<td>View Requests</td>
<td>View any requests submitted for processing</td>
</tr>
<tr>
<td>View Reports</td>
<td>View reports online</td>
</tr>
<tr>
<td>Workflow Notifications</td>
<td>Workflow Notifications In–Box</td>
</tr>
<tr>
<td>Batch Process Parameters</td>
<td>Define batch process parameters for benefits</td>
</tr>
<tr>
<td>Action Parameters</td>
<td>Maintain process parameters</td>
</tr>
<tr>
<td>Monitor Batch Processes</td>
<td>View batch process results</td>
</tr>
<tr>
<td>Define a QuickPaint Report</td>
<td>Set up the report layout</td>
</tr>
<tr>
<td>Run a QuickPaint Report</td>
<td>View or print the report for a set of people</td>
</tr>
<tr>
<td>Submit Custom Reports</td>
<td>Submit custom reports</td>
</tr>
<tr>
<td>Process Log</td>
<td>View error and status messages</td>
</tr>
<tr>
<td>Transaction Maintenance Forms</td>
<td>Maintain transaction workflow and transaction template definitions</td>
</tr>
<tr>
<td>Roles</td>
<td>Assign roles</td>
</tr>
<tr>
<td>Routing Lists</td>
<td>Define routing lists</td>
</tr>
<tr>
<td>Configurable Business Rules</td>
<td>Configure rules for position control</td>
</tr>
<tr>
<td>Templates</td>
<td>Create transaction templates</td>
</tr>
<tr>
<td>Transaction Type Wizard</td>
<td>Transaction Type Wizard</td>
</tr>
<tr>
<td>Global Roles</td>
<td>Maintain global roles</td>
</tr>
<tr>
<td>Mass Information eXchange: MIX</td>
<td>Interfaces and Batch Entry Options</td>
</tr>
<tr>
<td>Batch Element Entry</td>
<td>Enter, validate, and transfer element entry batches.</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>BEE Summary</td>
<td>View batch summary details</td>
</tr>
<tr>
<td>System Extract</td>
<td></td>
</tr>
<tr>
<td>Layout Definition</td>
<td>Define system extract formatting</td>
</tr>
<tr>
<td>Criteria Definition</td>
<td>Define system extract parameters</td>
</tr>
<tr>
<td>Extract Definition</td>
<td>Define system extracts</td>
</tr>
<tr>
<td>Extract Results</td>
<td>View system extract output</td>
</tr>
<tr>
<td>Change Event Log</td>
<td>View Change Event Log</td>
</tr>
<tr>
<td>Other Definitions</td>
<td>Other Definitions</td>
</tr>
<tr>
<td>Person Types</td>
<td>Enter names for types of employees, applicants and other people</td>
</tr>
<tr>
<td>Application Utilities Lookups</td>
<td>Enter lookup types and values</td>
</tr>
<tr>
<td>Special Information Types</td>
<td>Join special information types to the current business group</td>
</tr>
<tr>
<td>Define Cities</td>
<td>Define cities</td>
</tr>
<tr>
<td>Table Structure</td>
<td>Set up tables you require</td>
</tr>
<tr>
<td>Table Values</td>
<td>Enter table values</td>
</tr>
<tr>
<td>Time Periods</td>
<td>Define time period types for use in budget calendars</td>
</tr>
<tr>
<td>User Profile Options</td>
<td>Review your personal profile options</td>
</tr>
<tr>
<td>Formula Functions</td>
<td>Register your user defined functions</td>
</tr>
<tr>
<td>User Types and Statuses</td>
<td>Define user names for system types or statuses</td>
</tr>
<tr>
<td>Summary Process Setup</td>
<td>Summary process setup</td>
</tr>
<tr>
<td>Dynamic Trigger Definition</td>
<td>Maintain triggers and generate dynamic triggers</td>
</tr>
<tr>
<td>Dynamic Trigger</td>
<td>Group dynamic triggers</td>
</tr>
<tr>
<td>Functional Area Grouping</td>
<td>Group legislative functional areas</td>
</tr>
<tr>
<td>Third Party Payroll Balance Types</td>
<td>Enter third party payroll balance types</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Third Party Payroll</td>
<td>View third party payroll organization run results.</td>
</tr>
<tr>
<td>Organization Run Results</td>
<td></td>
</tr>
<tr>
<td>Third Party Payroll</td>
<td>View third party payroll run results.</td>
</tr>
<tr>
<td>Employee Run Results</td>
<td></td>
</tr>
<tr>
<td>Security</td>
<td>Define security restrictions</td>
</tr>
<tr>
<td>Profile</td>
<td>Define security profiles to restrict record access</td>
</tr>
<tr>
<td>Assign Security Profiles</td>
<td>Assign an existing security profile to a user/responsibility/security group combination.</td>
</tr>
<tr>
<td>CustomForm</td>
<td>Define customizations to restrict information access in windows</td>
</tr>
<tr>
<td>Information Types</td>
<td>Define information types security</td>
</tr>
<tr>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>Report Sets</td>
<td>Define sets to restrict report and process access</td>
</tr>
<tr>
<td>Task Flow Nodes</td>
<td>Define task flow nodes and customizations</td>
</tr>
<tr>
<td>Task Flow Definitions</td>
<td>Define task flows</td>
</tr>
<tr>
<td>Forms Configurator</td>
<td>Design form templates</td>
</tr>
<tr>
<td>Contexts</td>
<td>Configure options for mass update of employee and applicant statuses</td>
</tr>
<tr>
<td>Transaction Status</td>
<td>View transaction status and routing history</td>
</tr>
</tbody>
</table>

A – 16   Configuring, Reporting and System Administration in Oracle HRMS
Windows and their Navigation Paths

The following list shows the default navigation paths for all the windows in Oracle HRMS, in English speaking countries as they are supplied. You can use taskflow windows directly from the menu, or from the People and Assignment windows.

The responsibility that you use determines which of these windows you can use and how you access them. Your system administrator sets up navigation menus and task flows for your responsibility. They may also create configured versions of some of these windows using different window titles.

AAP Organization (US)

2. Enter or query an AAP Organization.
3. Choose the Others button and select AAP Organization.

Absence Detail

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Choose the Others button and select Absence.
Or:
1. Choose Fastpath -> Absence in the Navigator.
2. In the resulting Find window, query the person.

Absence Attendance Type

- Choose Total Compensation -> Basic -> Absence Types in the Navigator.

Accrual Bands

2. Enter or query an accrual plan name.
3. Choose the Accrual Bands button.
Accrual Plans
- Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

Accruals
Do one of the following:
1. Choose View -> Employee Accruals in the Navigator.
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the Accruals button.
Or:
1. Choose Fastpath -> Accruals in the Navigator.
2. In the resulting Find window, query the person.

Action Parameters

Action Types
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query or enter a plan.
3. Choose the Actions button.

Activity Rate
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the Navigator.
2. Query a compensation object.
3. Choose the Activity Rate button.

Activity Variable Rates and Rules
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the Navigator.
2. Query a compensation object.
3. Choose the Variable Rates button.
Actual Premiums

- Choose Total Compensation -> Rates/Coverage Definitions -> Actual Premiums in the Navigator.

Address

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Address button.

Or:
1. Choose Fastpath -> Address in the Navigator.
2. In the resulting Find window, query the person.

Adjust Balance (Payroll)

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Adjust Balance.

Or:
2. In the resulting Find window, query the person.

Advanced Criteria
1. Choose Benefits Extract -> Criteria Definition in the Navigator.
2. Query or enter a criteria definition and choose the Advanced tab.
3. Select a Criteria Type and choose the Details button.

Additional Absence Detail Information <Employee> (CA)

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button.
4. Select Absence.

Or:
1. Choose People → Fastpath → Absence Information in the Navigator.

**Agreement Grades**
- Choose Work Structures → Collective Agreements and Grade Structures in the Navigator.

**Alien Data Window (US)**
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Tax Information button.
5. Choose the Alien Data button.

**Alter Effective Date**
- Choose Tools → Alter Effective Date from the Tools menu.

**Applicant Entry**
- Choose Recruitment → Applicant Quick Entry in the Navigator.

**Applicant Interview**
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an applicant.
3. Choose the Others button and select Application.
4. Choose the Interview button.

**Application**
Do one of the following:
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an applicant.
3. Choose the Others button and select Application.

Or:
1. Choose Fastpath → Application in the Navigator.
2. In the resulting Find window, query the person.

**Application Utilities Lookups**
1. Choose Other Definitions -> Application Utilities Lookups in the Navigator.
2. Enter or query a user–defined Type.

**Appraisal Template**
- Choose Career Management -> Appraisal Template in the Navigator.

**Assessment Template**
- Choose Career Management -> Assessment Template in the Navigator.

**Assign Security Profiles**

**Assignment**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
Or:
1. Choose Fastpath -> Assignment in the Navigator.
2. In the resulting Find window, query the person.

**Assignment Budget Values**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an applicant or an employee.
3. Do one of the following:
   - For an applicant:
     - Choose the Others button and select Application.
     - Choose the Budgets button.
   - For an employee:
• Choose the Assignment button.
• Choose the Others button and select Budget Values.

Or:
1. Choose Fastpath \rightarrow Assignment Budget in the Navigator.
2. In the resulting Find window, query the person.

Assignment Criteria
1. Choose Payroll \rightarrow Assignment Set in the Navigator.
2. Enter or query an assignment set.
3. Choose the Criteria button.

Assignment Folder
■ Choose View \rightarrow Lists \rightarrow Assignment Folder in the Navigator.

Assignment History
■ Choose View \rightarrow Histories \rightarrow Employee Assignment in the Navigator.

Assignment Processes
1. Choose View \rightarrow Payroll Process Results in the Navigator.
2. Enter or query a payroll process.
3. Choose the Assignment Process button.

Assignment Set
■ Choose Payroll \rightarrow Assignment Set in the Navigator.

Assignment Statuses
■ Choose Work Structures \rightarrow Status in the Navigator.

Australian Information (AU)
1. Choose People \rightarrow Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Australian Information tabbed region.

Authentication Activities (Advanced Benefits)
■ Choose Total Compensation \rightarrow General Definitions \rightarrow Authentication Activities in the Navigator.
**Balance** (Payroll)
- Choose Total Compensation → Basic → Balance in the Navigator.

**Balance Classifications** (Payroll)
1. Choose Total Compensation → Basic → Balance in the Navigator.
2. Enter or query a balance.
3. Choose the Classifications button.

**Balance Dimensions** (Payroll)
1. Choose Total Compensation → Basic → Balance in the Navigator.
2. Enter or query a balance.
3. Choose the Dimensions button.

**Balance Feed Control**
1. Choose Total Compensation → Basic → Element Description in the Navigator.
2. Enter or query an element.
3. Choose the Balance Feed Control button.

**Balance Feeds** (Payroll)
- **Note:** This instance of the Balance Feeds window lets you select more than one balance for the element to feed.
1. Choose Total Compensation → Basic → Element Description in the Navigator.
2. Enter or query an element.
3. Choose the Balance Feeds button.

**Bargaining Unit (for a Constituency)**
2. Enter or query a constituency.
3. Choose the Others button and select Bargaining Unit.

**Batch Assignment Entry**
2. Enter or query a batch header.
3. Choose the Assignment Lines button.

**Batch Header**
- Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

**Batch Lines**
2. Enter or query a batch header.
3. Choose the Element Lines button.

**Batch Process Parameters** (Advanced Benefits)
- Choose Processes and Reports -> Batch Process Parameters in the Navigator.

**Batch Summary**
- Choose Mass Information eXchange: MIX -> BEE Summary in the Navigator.

**Beneficiaries** (US, CA)
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Contact.
4. Choose the Entries button.
5. Select the element representing the benefit for which you are entering a beneficiary.
6. Choose the Others button and select Beneficiary.

**Beneficiary Certifications**
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query a plan.
3. Choose the Designations tab.
4. Choose the Beneficiary tab.
5. Choose the Certifications button.
Benefits Authentication Form (Advanced Benefits) (US, UK, CA)
- Choose People -> Total Comp Contribution -> Benefits Authentication Form in the Navigator.

Benefits Balances
- Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors -> Benefits Balances in the Navigator.

Benefit Contributions (US, CA)
- Choose Total Compensation -> Basic -> Benefit Contributions in the Navigator.

Benefits Group
- Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors -> Benefits Group in the Navigator.

Benefits Pools (Advanced Benefits)
- Choose Total Compensation -> Rate/Coverage Definitions -> Benefits Pools in the Navigator.

Benefits Service Center (Advanced Benefits)
- Choose People -> Benefits Service Center in the Navigator.

Book Events
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Bookings.

Budget
1. Choose Work Structures -> Budget -> Budget Details in the Navigator.
2. In the resulting Find window, query the budget.
3. Select a budget version.
4. Choose the Open button.

Budget Characteristics
- Choose Work Structures -> Budget -> Budget Characteristics in the Navigator.
Budget Details

Follow these steps if you are entering a budget that is not routed for approval.

1. Choose Work Structures → Budget → Budget Details in the Navigator.
2. In the resulting Find window, query the budget.
3. Select a budget version.
4. Choose the Open button.
5. Select a line item in the budget and choose the Periods button.

Follow these steps if you are routing a budget for approval through a hierarchy of approvers.

2. Define the properties of the worksheet.
3. Choose the Create Worksheet button.
4. Edit the worksheet by entering values for budget line items.
5. Choose the Periods button.

Budget Reallocation

- Choose Work Structures → Budget → Budget Reallocation in the Navigator.

Budget Set

- Choose Work Structures → Budget → Budget Set in the Navigator.

Budget Value Defaults

2. Enter or query a Business Group.
3. Choose the Others button and select Budget Value Defaults.

Budgetary Calendar

- Choose Work Structures → Budget → Budget Calendar in the Navigator.
**Budgets**
1. Choose Work Structures -> Budget -> Budget Details in the Navigator.
2. In the resulting Find window, query the budget.

**Business Group Information**
2. Enter or query a Business Group.
3. Choose the Others button and select Business Group Information.

**Career Path Names**
- Choose Work Structures -> Job -> Path Name in the Navigator.

**Calendars (SSP/SMP)**
1. Choose SSP -> SSP Qualifying Patterns in the Navigator.
2. Enter or query a pattern.
3. Choose the Calendars button.

**Calendar Usages (SSP/SMP)**
1. Choose SSP -> SSP Qualifying Patterns in the Navigator.
2. Enter or query a pattern.
3. Choose the Calendars button.
4. Choose the Calendar Usages button.

**Certifications**
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query or enter a plan.
3. Choose the General tab.
4. Choose the Plan or Option tab.
5. Choose the Certifications button.

**Change Event Log**
- Choose Mass Information eXchange -> System Extract -> Change Event Log in the Navigator.
Cities (US, CA)
- Choose Other Definitions -> Cities in the Navigator.

City Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Tax Information button.
5. Choose the Tax information button from the State Tax Rules <Employee> window.
6. Choose the Tax information button from the County Tax Rules <Employee> window.

COBRA Benefits (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.
5. Enter or query a qualifying event.
6. Choose the Benefits button.

COBRA Coverage (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.

COBRA Payments (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.
5. Enter or query a qualifying event.
6. Choose the Payments button.

**COBRA Statuses** (Basic Benefits) (US)
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.
5. Enter or query a qualifying event.
6. Choose the Statuses button.

**Collapse Life Events**
- Choose Total Compensation –> General Definitions –> Additional Setup –> Collapse Life Events in the Navigator.

**Collective Agreements**
- Choose Work Structures –> Collective Agreements in the Navigator.

**Collective Agreement Grades (for a Constituency)**
2. Enter or query a constituency.
3. Choose the Others button and select Collective Agreement Grades.

**Columns**
1. Choose Other Definitions –> Table Structure in the Navigator.
2. Enter or query a table.
3. Choose the Columns button.

**Communication Delivery Methods**
- Choose Fastpath –> Personal Delivery Method in the Navigator.

**Communication Types**
- Choose Total Compensation –> General Definitions –> Additional Setup –> Communication Types in the Navigator.
Communication Type Children
1. Choose Total Compensation –> General Definitions –> Additional Setup –> Communication Types in the Navigator.
2. Query a communication type kit.
3. Choose the View Children button.

Communication Type Delivery Methods
1. Choose Total Compensation –> General Definitions –> Additional Setup –> Communication Types in the Navigator.
2. Query or enter a communication type.
3. Choose the Delivery button.

Communication Type Triggers
1. Choose Total Compensation –> General Definitions –> Additional Setup –> Communication Types in the Navigator.
2. Query or enter a communication type.
3. Choose the Triggers button.

Communication Type Usages
1. Choose Total Compensation –> General Definitions –> Additional Setup –> Communication Types in the Navigator.
2. Query or enter a communication type.
3. Choose the Usages button.

Competence Profile
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Competence Profile.
Or:
1. Choose Fastpath –> Competence Profile in the Navigator.

Competence Requirements
- Choose Career Management –> Competence Requirements in the Navigator.
**Competence Types**
- Choose Career Management -> Competence Types in the Navigator.

**Competencies**
- Choose Career Management -> Competencies in the Navigator.

**Concurrent Requests**
- Choose Processes and Reports -> View Requests in the Navigator.

**Consolidation Sets (Payroll)**
- Choose Payroll -> Consolidation in the Navigator.

**Constituency Information (for a Representative Body)**
2. Enter or query a representative body.
3. Choose the Others button and select Constituency.

**Contact**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Contact.
Or:
1. Choose Fastpath -> Contact in the Navigator.
2. In the resulting Find window, query the person.

**Configurable Business Rules**

**Contexts**
- Choose Security -> Contexts in the Navigator.

**Contract**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button.
Or:
1. Choose Fastpath \(\rightarrow\) Contracts in the Navigator.
2. In the resulting Find window, query the person.

**Contribution History (Def Comp 457) (US)**
- Choose View \(\rightarrow\) Histories \(\rightarrow\) Entries \(\rightarrow\) Contribution History

**Control Totals**
1. Choose Mass Information eXchange: MIX \(\rightarrow\) Batch Element Entry in the Navigator.
2. Choose the Totals button.

**Conversion Rate Types**
- Choose Payroll \(\rightarrow\) Conversion Rate Types in the Navigator.

**Costing**
Do one of the following:
1. Choose People \(\rightarrow\) Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Costing.
Or:
1. Choose Fastpath \(\rightarrow\) Costing in the Navigator.
2. In the resulting Find window, query the person.

**Costing Information**
1. Choose Work Structures \(\rightarrow\) Organization \(\rightarrow\) Description in the Navigator.
2. Enter or query an organization.
3. Choose the Others button and select Costing.
County Tax Rules <Employee> (US)
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Tax Information button.
5. Choose the Tax information button from the State Tax Rules <Employee> window.

Court Orders
■ Choose People –> Total Comp Enrollment –> Court Orders in the Navigator.

Coverage Across Plan Types
■ Choose Total Compensation –> Rates/Coverage Definitions –> Coverage Across Plan Types in the Navigator.

Coverage Calculations
■ Choose Total Compensation –> Rate/Coverage Definitions –> Coverage Calculations in the Navigator.

Covered Dependents (US)
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Contact.
4. Chose the Entries button.
5. Select the element representing the benefit for which you are entering a dependent.
6. Choose the Others button and select Dependents.

Covered Dependents (CA)
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Contact.
4. Chose the Entries button.
Create Batch Lines
2. Enter or query a batch header.
3. Choose the Assignment Set button.

Criteria Definition
- Choose Mass Information eXchange: MIX -> System Extract -> Criteria Definition in the Navigator.

Custom Reports
- Choose Processes and Reports -> Submit Custom Reports in the Navigator.

Database Items
1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.
2. Enter or query a formula.
3. Choose the Show Items button.

DateTrack History Change Field Summary
- Choose Tools -> Datetrack History from the Tools menu.

Deduction (Payroll) (US, CA)
- Choose Total Compensation -> Basic -> Deductions in the Navigator.

Define Combinations
- Choose Total Compensation -> Rate/Coverage Definitions -> Combinations in the Navigator.

Define Extract
- Choose Benefits Extract -> Extract Definition in the Navigator.

Define Function
- Choose Other Definitions -> Formula Functions in the Navigator.
Define QuickPaint Report
- Choose Processes and Reports -> Define a QuickPaint Report in the Navigator.

Define Task Flow

Define Task Flow Nodes
- Choose Security -> Task Flow Nodes in the Navigator.

Delete Person
- Choose People -> Delete Personal Records in the Navigator.

Dependent/Beneficiary Designation
Do one of the following:
- Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Dependent/Beneficiary Designation in the Navigator.

Or:
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program in the Navigator.
2. Query a person.
3. Choose the Designees button.

Dependent Certifications
Do one of the following:
1. Choose Total Compensation -> Programs and Plans -> Program Enrollment Requirements in the Navigator.
2. Query a program.
3. Choose the Dependent Coverage tabbed region
4. Choose the Certifications button.

Or:
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query a plan.
3. Choose the Designations tab.
4. Choose the Dependent tab.
5. Choose the Certifications button.

**Dependent Change of Life Event**
Do one of the following:

1. Choose Choose Total Compensation → Programs and Plans → Program Enrollment Requirements in the Navigator.
2. Query a program and choose the Dependent Coverage tabbed region.
3. Choose the Dependent Change of Life Event button.

Or:

1. Choose Choose Total Compensation → Programs and Plans → Plan Enrollment Requirements in the Navigator.
2. Query a plan and choose the Designations tabbed region.
3. Choose the Dependent tab.
4. Choose the Dependent Change of Life Event button.

**Dependent Change of Life Event Certification**
Do one of the following:

1. Choose Choose Total Compensation → Programs and Plans → Program Enrollment Requirements in the Navigator.
2. Query a program and choose the Dependent Coverage tabbed region.
3. Choose the Dependent Change of Life Event button.
4. Select a life event and choose the Dependent Change of Life Event Certifications button.

Or:

1. Choose Choose Total Compensation → Programs and Plans → Plan Enrollment Requirements in the Navigator.
2. Query a plan and choose the Designations tabbed region.
3. Choose the Dependent tab.
4. Choose the Dependent Change of Life Event button.
5. Select a life event and choose the Dependent Change of Life Event Certifications button.
Dependent Coverage Eligibility Profiles

- Choose Total Compensation -> General Definitions -> Eligibility Profiles -> Dependent Coverage in the Navigator.

Dependent Eligibility Profiles

Do one of the following:

1. Choose Choose Total Compensation -> Programs and Plans -> Program Enrollment Requirements in the Navigator.
2. Query a program and choose the Dependent Coverage tabbed region.
3. Choose the Eligibility Profiles button.

Or:

1. Choose Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query a plan and choose the Designations tabbed region.
3. Choose the Dependent tab.
4. Choose the Eligibility Profiles button.

Derived Factors

- Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors -> Derived Factors in the Navigator.

Designation Requirements

Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Options in the Navigator.
2. Query or enter an option.
3. Choose the Designation Requirements button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query a plan.
3. Choose the General tab.
4. Choose the Plan or Option tab.
5. Choose the Designations button.
Disability (Not US, CA)

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Disabilities.

Or:
1. Choose Fastpath -> Disabilities in the Navigator.
2. In the resulting Find window, query the person.

Dynamic Trigger Definition

- Choose Other Definitions -> Dynamic Trigger Definition in the Navigator.

Dynamic Trigger Functional Area Grouping

- Choose Other Definitions -> Dynamic Trigger Functional Area Grouping in the Navigator.

Earnings (Payroll) (US, CA)

- Choose Total Compensation -> Basic -> Earnings in the Navigator.

Edit Formula

1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.
2. Enter or query a formula.
3. Choose the Edit button.

EEO-1 Filing (US)

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select EEO-1 Filing.

Electable Choices

1. Choose People -> Total Comp Participation
2. Choose the Enrollment Opportunities button
3. Choose the Electable Choices button.
Elections
- Choose Work Structures -> Elections

Element
- Choose Total Compensation -> Basic -> Element Description in the Navigator.

Element and Distribution Set
- Choose Payroll -> Element Set in the Navigator.

Element Classifications (Payroll)
- Choose Total Compensation -> Basic -> Classification in the Navigator.

Element Entries
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Entries button.
Or:
1. Choose Fastpath -> Entries in the Navigator.
2. In the resulting Find window, query the person.

Element Link
- Choose Total Compensation -> Basic -> Link in the Navigator.

Element Withholding Reasons (SSP/SMP)
- Choose SSP/SMP -> Element Withholding Reasons in the Navigator.

Eligibility
Do one of the following:
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Plan Eligibility button.
4. Choose the Eligibility button.

Or:

1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Options button.
4. Choose the Option Eligibility button.
5. Choose the Eligibility button.

Or:

1. Choose Total Compensation → Programs and Plans → Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plans and Plan Types button.
4. Choose the Plans tab or the Plan Types tab.
5. Choose the Participation Eligibility button.
6. Choose the Eligibility button.

Or:

1. Choose Total Compensation → Programs and Plans → Programs in the Navigator.
2. Query or enter a program.
3. Choose the Participation Eligibility button.
4. Choose the Eligibility button.

Employee Assignment Processes (Payroll)

- Choose View → Assignment Process Results in the Navigator.

Employee Review

Do one of the following:
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Reviews.

Or:
2. In the resulting Find window, query the person.

**Employee Run Result History** (Payroll)
- Choose View → Histories → Run Results in the Navigator.

Or:
1. Choose Fastpath → End Employment in the Navigator.
2. In the resulting Find window, query the person.

**Employer Identification** (US, CA)
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Employer Identification

**Employment Declaration** (AU)
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Declaration button.

**Employment Equity Information**
2. Enter or query an Organization.
3. Position the cursor in the Organization Classifications Name field.
4. Select the Business Group from the List of Values.
5. Position the cursor in the Field with the entry Business Group.
6. Choose the Others button.
7. Select Employment Equity Information and click OK.
8. Double-click in the FlexField to display the window.

**Employment History** (UK)
- Choose FastPath → Employment History in the Navigator.
**End Application**
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button and select End Application.
   Or:
   1. Choose Fastpath -> End Application in the Navigator.
   2. In the resulting Find window, query the person.

**End Employment**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button and select End Employment.
   Or:

**Enrollment Action** (Advanced Benefits)
- Choose Total Compensation -> General Definitions -> Additional Setup -> Enrollment Action Types in the Navigator.

**Enrollment Opportunities**
1. Choose People -> Total Comp Participation
2. Choose the Enrollment Opportunities button.

**Enrollment Override**
- Choose People -> Total Comp Enrollment -> Enrollment Override in the Navigator.

**Enrollment Rules**
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query or enter a plan.
3. Choose the Timing tab.
4. Choose the Scheduled tab or the Life Event tab.
5. Choose the Enrollment Rules button.
Enter Employees
- Choose People -> Maintain Using Templates -> Enter Employees in the Navigator.

Entry Values
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Entries button.
5. Select an entry and choose the Entry Values button.

Establishment EEO-1 Filing (US)
2. Enter or query a Reporting Establishment.
3. Choose the Others button and select Establishment EEO-1 Filing.

Establishment VETS-100 Filing (US)
2. Enter or query a Reporting Establishment.
3. Choose the Others button and select Establishment VETS-100 Filing.

Event Bookings
Do one of the following:
- Choose People -> Events and Bookings in the Navigator.
Or:
1. Choose Fastpath -> Event in the Navigator.
2. In the resulting Find window, query the person.

Event Groups
- Choose Total Compensation -> Basic -> Event Groups in the Navigator.

External/Manual Payments (Payroll)
Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select External Pay.
   Or:
2. In the resulting Find window, query the person.

**Extra Details of Service**

Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Extra Details of Service.
   Or:
1. Choose Fastpath –> Extra Details of Service.
2. In the resulting Find window, query the person.

**Extra Element Information**

1. Choose Total Compensation –> Basic –> Element Description in the Navigator.
2. Enter or query an element.
3. Choose the Extra Information button.

**Extra Person Information Window (US)**

1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button.
4. Choose Extra Information.
5. Choose a Type.
6. Choose Details.
Extract Definition
- Choose Mass Information Exchange -> System Extract -> Extract Definition in the Navigator.

Extract Results
- Choose Mass Information eXchange -> System Extract -> Extract Results in the Navigator.

Extract Results Errors
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the Navigator.
2. Query an extract run result and choose the Errors and Warnings button.

Extract Results Details
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the Navigator.
2. Query an extract run result and choose the Details button.

Extract Results Header and Trailer
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the Navigator.
2. Query an extract run result and choose the Header and Trailer button.

Federal Tax Information <Employee> (CA)
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Tax Information button.
5. Select the Federal Tax Information region (if not already selected).
Or:
1. Choose People -> Fastpath -> Tax Sign-up in the Navigator.
2. In the resulting Find window, query an employee.
**Federal Tax Rules** (US)
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Federal Tax Rules

**Federal Tax Rules <Employee>** (US)
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Chose the Tax Information button.

**File Layout Advanced Conditions** (US, UK, CA)
1. Choose Benefits Extract → Layout Definition in the Navigator.
2. Choose the File Layout tab and query or enter a file layout.
3. Select a record and choose the Advanced Conditions button.

**File Layout Include Conditions**
1. Choose Mass Information eXchange → System Extract → Layout Definition in the Navigator.
2. Choose the File Layout tab and query or enter a file layout.
3. Select a record and choose the Include Conditions button.

**Flex Credits** (Advanced Benefits)
   - Choose Total Compensation → Rate/Coverage Definitions → Flex Credits in the Navigator.

**Flex Program** (Advance Benefits)
   - Choose People → Total Comp Enrollment → Flex Program in the Navigator.

**Form 941 Information** (US)
   - Choose View → Tax Information → Form 941 Information in the Navigator.

**Form Customization**
   - Choose Security → CustomForm in the Navigator.
**Forms Configurator**
- Choose Security -> Forms Configurator in the Navigator.

**Formula**
- Choose Total Compensation -> Basic -> Write Formulas in the Navigator.

**Formula Result Rules (Payroll)**
- Choose Total Compensation -> Basic -> Formula Results in the Navigator.

**Frequency Rules (Payroll)**
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.
2. Enter or query an element.
3. Choose the Frequency Rules button.

**Funding Distribution**
2. Choose the Periods button to open the Budget Details window.
3. Choose the Budget Sets tab.
4. Choose the Budget Set Distribution button.

**GL Map (Payroll)**
- Choose Payroll -> GL Flexfield Map in the Navigator.

**GL Daily Rates**
- Choose Payroll -> GL Daily Rates in the Navigator.

**GL Daily Rates (US, CA)**
- Choose Total Compensation -> Basic -> Global Values in the Navigator.

**Globals**
- Choose Total Compensation -> Basic -> Global Values in the Navigator.
Goods and Services

- Choose Total Compensation -> General Definitions -> Additional Setup -> Goods and Services in the Navigator.

Grade Rate

- Choose Work Structures -> Grade -> Grade Rate in the Navigator.

Grades (for a Constituency)

2. Enter or query a constituency.
3. Choose the Others button and select Grades.

Grade Scale

- Choose Work Structures -> Grade -> Grade Steps and Points in the Navigator.

Grade Step Placement

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Grade Step.
Or:
1. Choose Fastpath -> Grade Step in the Navigator.
2. In the resulting Find window, query the person.

Grades

- Choose Work Structures -> Grade -> Description in the Navigator.

GREs and other information <Employee> (CA)

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Select the GREs and other information region.
Hiring Applicants
- Choose People -> Maintain Using Templates -> Hire Applicants in the Navigator.

Imputed Income
- Choose Total Compensation -> Rate/Coverage Definitions -> Imputed Income in the Navigator.

Information Type Security (US, UK, CA)
- Choose Security -> Information Types Security in the Navigator.

Input Values
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.
2. Enter or query an element.
3. Choose the Input Values button.

Investment Options
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Savings Plan in the Navigator.
2. Query a person.
3. Choose the Investment Options button.

Job
- Choose Work Structures -> Job -> Description in the Navigator.

Jobs (for a Constituency)
2. Enter or query a constituency.
3. Choose the Others button and select Jobs.

Job Evaluation
1. Choose Work Structures -> Job -> Description in the Navigator.
2. Enter or query a job.
3. Choose the Evaluation button.
Job Groups
- Choose Work Structures -> Job -> Job Groups in the Navigator.

Job Requirements
1. Choose Work Structures -> Job -> Description in the Navigator.
2. Enter or query a job.
3. Choose the Requirements button.

Layout Definition
- Choose Benefits Extract -> Layout Definition in the Navigator.

Legal Employer Information (AU)
2. Enter or query an organization.
3. Select GRE/Legal Entity and choose the Others button.
4. Select Legal Employer.
5. Click in the blank field.

Letter (for letters)
- Choose Work Structures -> Recruitment Letter Type in the Navigator.

Letter (for contracts)
- Choose Work Structures -> Contract Letter Type in the Navigator.

Life Event
Do one of the following:
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plans tab or the Plan Types tab.
5. Choose the Life Event button.

Or:
1. Choose Total Compensation → Programs and Plans → Programs in the Navigator.

2. Query or enter a program.

3. Choose the Life Event button.

**Life Event Certifications**

1. Choose Total Compensation → Programs and Plans → Plan Enrollment Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the General tab.

4. Choose the Plan or Option tab.

5. Choose the Life Event Certifications button.

**Life Event Reason Impact on Eligibility** (Advanced Benefits)

1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Options button.

4. Choose the Life Event Eligibility button.

**Life Event Reasons** (Advanced Benefits)

- Choose Total Compensation → General Definitions → Additional Setup → Life Event Reasons in the Navigator.

**Limit Rules** (Payroll) (US)

- Choose View → Wage Attachments → Limit Rules in the Navigator.

**Link Input Values**

1. Choose Total Compensation → Basic → Link in the Navigator.

2. Enter or query an element.

3. Choose the Input Values button.

**List Assignments**

- Choose View → Lists → Assignments in the Navigator.

**List Budget Variance by Organization** (AU)

- Choose View → Organization Budgets in the Navigator.
List Employees by Absence Type
- Choose View -> Lists -> Employees by Absence Type in the Navigator.

List Employees by Element
- Choose View -> Lists -> Employees by Element in the Navigator.

List Employees by Organization
- Choose View -> Lists -> Employees by Organization in the Navigator.

List Employees by Position
- Choose View -> Lists -> Employees by Position in the Navigator.

List Employees by Position Hierarchy
- Choose View -> Lists -> Emps by Position Hierarchy in the Navigator.

List People by Assignment
- Choose View -> Lists -> People by Assignment in the Navigator.

List People by Special Information
- Choose View -> Lists -> People by Special Information in the Navigator.

List Position Budget Variance (AU)
- Choose View -> Position Budgets in the Navigator.

Local Tax Rules (US)
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Local Tax Rules.

Location
- Choose Work Structures -> Location in the Navigator.
Locations (for a Constituency)
2. Enter or query a constituency.
3. Choose the Others button and select Locations.

Lookups
- Choose Other Definitions → Application Utilities Lookups in the Navigator.

Maintain Employees
- Choose People → Maintain Using Templates → Maintain Employees in the Navigator.

Maintain On Line Activities (Advanced Benefits)
- Choose Total Compensation → General Definitions → Authentication Activities in the Navigator.

Maintain Options Eligibility
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Options button.
4. Choose the Option Eligibility button.

Maintain Plan Eligibility
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Plan Eligibility button.

Maintain Plan Options
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Options button.
Maintain Plan Related Details
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Details button.

Maintain Pop Up Messages (Advanced Benefits)
- Choose Total Compensation -> General Definitions -> Message Configuration in the Navigator.

Manual Payments

Maintain Visa (US)

Maintain Visa Window
2. Choose an employee.

Map Salary Survey (US, UK, CA)
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Complete the Position window and save your work.
3. Choose the Define Survey Map button.
Or:
1. Choose Work Structures -> Job -> Description in the Navigator.
2. Complete the Job window and save your work.
3. Choose the Define Salary Map button.

Map Career Path
- Choose Work Structures -> Job -> Career Path in the Navigator.

Mass Move
Mass Move – Assignments
2. Complete the Mass Move window and save your work.
3. Choose the Positions button.
4. Complete the Find Positions window.
5. Choose the Find button.
7. Choose the Assignments button.

Mass Move – Messages
2. Complete the Mass Move window and save your work.
3. Choose the Positions button.
4. Complete the Find Positions window and choose the Find button.
5. Complete the Mass Move – Positions window and choose the Assignments button.
6. Complete the Mass Move – Assignments window and close it.
7. From the Mass Move – Positions window, choose the Valid Grades button.
8. Complete the Valid Grades window and close it.
10. From the Mass Move window, choose the Execute button.
11. If the Status field shows In Error or Complete with Warnings, a Message button appears.
12. If the Message button appears, choose it to view messages in the Mass Move – Messages window.

Note: Alternatively, you can view messages for saved (but not yet successfully executed) mass moves as follows:
2. Enter the name of the saved mass move in the Description field.
3. When the Mass Move window is populated with data and the Message button appears, choose the Message button.
Mass Move – Positions
2. Complete the Mass Move window.
3. Save your work.
4. Choose the Positions button.
5. In the resulting Find Positions window, select or enter a Source Job and Source Position.
6. Choose the Find button.

Mass Move – Valid Grades
2. Complete the Mass Move window and save your work.
3. Choose the Positions button.
4. Complete the Find Positions window.
5. Choose the Find button.
7. Choose the Valid Grades button.

Mass Position Update

Mass Update of Applicants
- Choose Recruitment -> Mass Update of Applicants in the Navigator.

Mass Update of Applicant Assignments
- Choose People -> Mass Updates for Person -> Mass Update of Applicant Assignments in the Navigator.

Mass Update of Employee Assignments
- Choose People -> Mass Updates for Person -> Mass Update of Employee Assignments in the Navigator.

Maternity (SSP/SMP)
1. Choose SSP/SMP -> Person Details in the Navigator.
2. Enter or query a person.
3. Choose the Maternity button.

**Maternity Evidence (SSP/SMP)**
1. Choose SSP/SMP -> Person Details in the Navigator.
2. Enter or query a person.
3. Choose the Absence button.
4. Enter or query a maternity absence.
5. Choose the Evidence button.

**Maternity Pay (SSP/SMP only) (UK)**
1. Choose SSP/SMP -> Person Details in the Navigator.
2. Enter or query a person.
3. Choose the Absence button.
4. Enter or query a maternity absence.
5. Choose the SSP/SMP button.

**Medical Assessments**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Medical Assessments.
   Or:
   2. In the resulting Find window, query the person.

**Messages**
2. Choose the Messages button.

**Message Configuration (Advanced Benefits)**
- Choose Total Compensation -> General Definitions -> Message Configuration in the Navigator.
Mileage Element Template (UK)
- Choose Total Compensation → Basic → Mileage Element Template in the Navigator.

Miscellaneous Plan
- Choose People → Total Comp Enrollment → Benefits Enrollment → Miscellaneous Plan in the Navigator.

MIX Batch Header
- Choose Mass Information eXchange: MIX → Batch Element Entry in the Navigator.

Monitor Batch Processes (Advanced Benefits)
- Choose Processes and Reports → Monitor Batch Processes in the Navigator.

Monthly Participant Premium
- Choose People → Total Comp Contribution → Monthly Participant Premium in the Navigator.

Monthly Plan or Option Premium
- Choose → People → Total Comp Contribution → Monthly Premium in the Navigator.

Multiple Worksite Reporting (US)
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Multiple Worksite Reporting

NACHA Rules (US)
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select NACHA Rules

Net Calculation Rules
1. Choose Total Compensation → Basic → Accrual Plans in the Navigator.
2. Enter or query an accrual plan name.
3. Choose the Net Calculation Rules button.

New Hire Reporting (US)
2. Enter or query a GRE.
3. Choose the Others button.
4. Select New Hire Reporting

New Zealand Information (NZ)
1. Choose People → Enter and Maintain.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the New Zealand Information tab.

Non–Flex Program
- Choose People → Total Comp Enrollment → Non–Flex Program in the Navigator.

Options
- Choose Total Compensation → Programs and Plans → Options in the Navigator.

Organization
- Choose Work Structures → Organization → Description in the Navigator.

Organizations (for a Constituency)
2. Enter or query a constituency.
3. Choose the Others button and select Organizations.

Organization Hierarchy
- Choose Work Structures → Organization → Hierarchy in the Navigator.
Organization Hierarchy Diagrammer
- Choose Work Structures -> Organization -> Diagrammer in the Navigator.

Organization Hierarchies (for a Constituency)
2. Enter or query a constituency.
3. Choose the Others button and select Organization Hierarchies.

Organizational Payment Method
- Choose Payroll -> Payment Methods in the Navigator.

Other Rates
1. Choose People -> Total Comp Enrollment -> Non-Flex Program in the Navigator.
2. Query a person.
3. Choose the Others button and select Other Rates.

P45 (Payroll)
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Tax Information.
Or:
1. Choose FastPath -> UK P45 Form in the Navigator.
2. In the resulting Find window, query the person.

Participant
- Choose Total Compensation -> General Definitions -> Eligibility Profiles -> Participant in the Navigator.

Participation Eligibility Profiles
- Choose Total Compensation -> General Definitions -> Eligibility Profiles -> Participation Eligibility Profiles
**Participation Overrides** (Advanced Benefits)

- Choose People -> Total Comp Participation -> Participation Overrides in the Navigator.

**Parent Organization**

2. Enter or query an organization.
3. Choose the Others button and select Parent Organization.

**Pattern (SSP/SMP)**

- Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

**Pattern Time Units (SSP/SMP)**

- Choose SSP/SMP -> Pattern Time Units in the Navigator.

**Pay Advice Report** (Payroll)

Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Statement of Earnings.

Or:

2. In the resulting Find window, query the person.

**Payment Schedule**

1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the Navigator.
2. Query or enter a flex credit definition and choose the Processing tabbed region.
3. Choose the Payment Schedule button.

**Payments**

1. Choose People -> Total Comp Contribution -> Record Contribution or Distribution
2. Choose the View Payments window.

**Payroll**
- Choose Payroll –> Description in the Navigator.

**Payroll Processes** (Payroll)
- Choose View –> Payroll Process Results in the Navigator.

**Pay Scale**
- Choose Work Structures –> Grade –> Pay Scale in the Navigator.

**People**
- Choose People –> Enter and Maintain in the Navigator.

**People Folder**
- Choose View –> Lists –> People Folder in the Navigator.

**Performance**
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee, and choose the Assignment button.
3. Choose the Salary button.
4. Choose the Performance button.
Or:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee, and choose the Assignment button.
3. Choose the Others button and select Performance.

**Period Dates**
1. Choose Payroll –> Description in the Navigator.
2. Enter or query a payroll.
3. Choose the Period Dates button.

**Period–to–Date Limits**
Do one of the following:
- Choose Total Compensation –> General Definitions –> Rate/Coverage Definitions –> Period–to–Date Limits in the Navigator.
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the Navigator.
2. Query a compensation object.
3. Choose the Activity Rate button.
4. Choose the Period to Date Limit button.

**Period Types**
- Choose Other Definitions -> Time Periods in the Navigator.

**Person Benefits Assignment**
- Choose People -> Total Comp Participation -> Person Benefits Assignment

**Person Benefits Balances**
- Choose People -> Total Comp Participation -> Person Benefits Balances in the Navigator.

**Person Changes (Advanced Benefits)**
2. Query or enter a life event.
3. Choose the Person Changes button.
4. Choose the Add Person Change button.

**Person Changes Cause Life Events (Advanced Benefits)**
2. Query or enter a life event.
3. Choose the Person Changes button.

**Person Communications (Advanced Benefits)**
- Choose People -> Total Comp Enrollment -> Enrollment Process -> Person Communications in the Navigator.

**Person Enrollment Action Items (Advanced Benefits)**
Do one of the following:
Choose People — Total Comp Enrollment — Enrollment Process — Person Enrollment Action Items in the Navigator.

Or:

1. Choose People — Total Comp Enrollment — Benefits Enrollment — Flex Program in the Navigator.
2. Query a person.
3. Choose the Action Items button.

**Person Enrollment Certifications** (Advanced Benefits)

Do one of the following:

- Choose People — Total Comp Enrollment — Enrollment Process — Person Enrollment Certifications in the Navigator.

Or:

1. Choose People — Total Comp Enrollment — Benefits Enrollment — Flex Program in the Navigator.
2. Query a person.
3. Choose the Certifications button.

**Person Enrollment Certificates** (Advanced Benefits) (CA)

- Choose People — Enrollment Process — Person Enrollment Certificates in the Navigator.

**Person Primary Care Provider**

- Choose People — Total Comp Enrollment — Benefits Enrollment — Person Primary Care Provider in the Navigator.

**Person Types**

- Choose Other Definitions — Person Types in the Navigator.

**Person Type Usage**

- Choose Fastpath — Person Type Usage in the Navigator.

**Personal Payment Method**

Do one of the following:

1. Choose People — Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Pay Method button, or choose the Others button and select Pay Method.

Or:
2. In the resulting Find window, query the person.

**Phone Numbers**
Do one of the following:
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button.
4. Choose Phones.

Or:
1. Choose Fastpath → Phones in the Navigator.
2. In the resulting Find window, query the person.

**Picture**
Do one of the following:
1. Choose People → Enter and Maintain in the Navigator
2. Enter or query a person.
3. Choose the Picture button.

Or:
1. Choose Fastpath → Picture in the Navigator.
2. In the resulting Find window, query the person.

**Plan and Plan Type**
1. Choose Total Compensation → Programs and Plans → Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
Plan Enrollment Requirements

- Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.

4. Query or enter a program.
5. Choose the Plan and Plan Types button.

Plan in Program Participation Eligibility

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plans tab.
5. Choose the Participation Eligibility button.

Plan Reimbursement

- Choose Total Compensation -> General Definitions -> Programs and Plans -> Plan Reimbursement in the Navigator.

Plans

- Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

Plan Type Participation Eligibility

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plan Type tab.
5. Choose the Participation Eligibility button.

Plan Types

- Choose Total Compensation -> Programs and Plans -> Plan Types in the Navigator.

Position

- Choose Work Structures -> Position -> Description in the Navigator.
Position Copy
- Choose Work Structures -> Position -> Position Copy in the Navigator.

Position Evaluation
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Enter or query a position.
3. Choose the Evaluation button.

Position Hierarchy
- Choose Work Structures -> Position -> Hierarchy in the Navigator.

Position Hierarchy Diagrammer
- Choose Work Structures -> Position -> Diagrammer in the Navigator.

Position Occupancy Folder
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Query a position.
3. Choose the Occupancy button.

Position Reporting To
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Enter or query a position.
3. Choose the Reporting To button.

Position Requirements
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Enter or query a position.
3. Choose the Requirements button.

Position Transaction
Choose Work Structures -> Position -> Position Transaction in the Navigator.
Postal/Zip
- Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors -> Postal/Zip in the Navigator.

Possible Certifications
1. Choose People -> Total Comp Participation
2. Choose the Enrollment Opportunities button.
3. Choose the Electable Choices button
4. Choose the Possible Certifications button

Primary Care Providers
Do one of the following:
- Choose People -> Total Comp Enrollment -> Person Primary Care Provider

Or:
1. Choose People -> Total Comp Enrollment -> Flex Program in the Navigator.
2. Query a person.
3. Choose the Care Providers button.

Process Log
Choose Processes and Reports -> Process Log in the Navigator.

Program/Plan Years
- Choose Total Compensation -> General Definitions -> Additional Setup -> Program/Plan Years in the Navigator.

Programs
- Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

Program Enrollment Requirements
- Choose Total Compensation -> General Definitions -> Programs and Plans -> Program Enrollment Requirements in the Navigator.

Program Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Participation Eligibility button.

**Program Waive Certifications**
1. Choose Total Compensation \(\rightarrow\) Programs and Plans \(\rightarrow\) Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plan Types tab.
5. Choose the Waive button.
6. Choose the Waive Certification button.

**Program Waive Reasons**
1. Choose Total Compensation \(\rightarrow\) Programs and Plans \(\rightarrow\) Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plan Types tab.
5. Choose the Waive button.

**Provincial Employment Standard** (CA)
1. Choose Work Structures \(\rightarrow\) Organization \(\rightarrow\) Description in the Navigator.
2. Enter or query an Organization.
3. Position the cursor in the Organization Classifications Name field.
4. Select the Business Group from the List of Values.
5. Position the cursor in the field with the entry Business Group.
6. Choose the Others button.
7. Select Provincial Employment Standard and click OK.
8. Double-click in the FlexField to display the window.

**Provincial Reporting Info.** (CA)
1. Choose Work Structures \(\rightarrow\) Organization \(\rightarrow\) Description in the Navigator.
2. Enter or query an Organization.
3. Position the cursor in the Organization Classifications Name field.
4. Select GRE/Legal Entity from the List of Values.
5. Position the cursor in the field with the entry GRE/Legal Entity.
6. Choose the Others button.
7. Select Provincial Reporting Info and click OK.
8. Double-click in the FlexField to display the window.

**Provincial Tax Information <Employee> (CA)**

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Tax Information button.
5. Select the Provincial Tax Information region.

Or:
1. Choose People -> Fastpath -> Tax Sign-up in the Navigator.
2. In the resulting Find window, query an employee.
3. Select the Provincial Tax Information region.

**Prior Employment SSP (SSP1L) (SSP/SMP)**

1. Choose SSP/SMP -> Person Details in the Navigator.
2. Enter or query a person.
3. Choose the SSP1L button.

**Qualifications**

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Qualifications.

Or:
Qualification Types

- Choose Career Management -> Qualification Types in the Navigator.

QuickPaint Inquiry

2. Query a report that has been run.
3. Choose the View Report button.

QuickPay (Payroll)

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select QuickPay.

Or:
1. Choose Fastpath -> QuickPay in the Navigator.
2. In the resulting Find window, query the person.

Rating Scales

- Choose Career Management -> Rating Scales in the Navigator.

Record Continuing Benefits Payments

- Choose People -> Total Comp Contribution -> Record Continuing Benefits Payments in the Navigator.

Record Layout Advanced Conditions (US, UK)

1. Choose Benefits Extract -> Layout Definition in the Navigator.
2. Choose the Record Layout tab and query or enter a record layout.
3. Select a Data Element and choose the Advanced Conditions button.

Record Layout Include Conditions

2. Choose the Record Layout tab and query or enter a record layout.
3. Select a Data Element and choose the Include Conditions button.

**Recruiting For**
2. Enter or query a recruitment activity.
3. Choose the Recruiting For button.

**Recruitment Activity**
- Choose Recruitment -> Recruitment Activity in the Navigator.

**Registered Employer Information** (NZ)
2. Enter or query an organization.
3. Select GRE/Legal Entity in the Organization Classification region.
4. Choose Others -> Registered Employer.

**Regulations**
- Choose Total Compensation -> General Definitions -> Additional Setup -> Regulations in the Navigator.

**Regulatory Bodies and Regulations**
2. Query or enter a reporting group.
3. Choose the Plan Regulatory Bodies and Regulations button.

**Reimbursements Requests** (Advanced Benefits)
- Choose People -> Total Comp Distribution -> Reimbursements Requests in the Navigator.

**Related Person Changes** (Advanced Benefits)
2. Query or enter a life event.
3. Choose the Related Person Changes button.
4. Choose the Add Related Person Change button.
**Related Person Changes Cause Life Events** (Advanced Benefits)

2. Query or enter a life event.
3. Choose the Related Person Changes button.

**Reporting Groups**

- Choose Total Compensation → General Definitions → Additional Setup → Reporting Groups in the Navigator.

**Reporting Statuses** (CA)

2. Enter or query a Business Group.
3. Choose the Others button and select Reporting Statuses.

**Representative Body Information**

2. Enter or query a representative body.
3. Choose the Others button and select Representative Body.

**Request Letter**

- Choose Recruitment → Request Recruitment Letter in the Navigator.

**Request Set**


**Requisition and Vacancy**

- Choose Recruitment → Requisition and Vacancy in the Navigator.

**RetroPay Set** (Payroll)

- Choose Payroll → RetroPay Set in the Navigator.

**Reverse Payroll Run** (Payroll)

Do one of the following:

1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Reverse Run.

Or:
1. Choose Fastpath -> Reverse Payroll Run in the Navigator.
2. In the resulting Find window, query the person.

**Roles**
- Choose Transaction Maintenance Forms -> Roles in the Navigator.

**Routing**
2. Choose Save from the File menu.

Or:
2. Choose Save from the File menu.
3. Choose Save from the File menu.

**Routing Lists**
- Choose Transaction Maintenance Forms -> Routing Lists in the Navigator.

**Rows**
1. Choose Other Definitions -> Table Structure in the Navigator.
2. Enter or query a table.
3. Choose the Rows button.

**Run QuickPaint Report**
- Choose Processes and Reports -> Run a QuickPaint Report in the Navigator.

**Salary Administration**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Salary button.

Or:
1. Choose Fastpath → Salary in the Navigator.
2. In the resulting Find window, query the person.

**Salary Basis**
- Choose Total Compensation → Basic → Salary Basis in the Navigator.

**Salary History**
Do one of the following:
1. Choose View → Histories → Salary in the Navigator.
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the Salary History button.

Or:
1. Choose Fastpath → Salary History in the Navigator.
2. In the resulting Find window, query the person.

**Salary Management Folder**
- Choose People → Salary Management in the Navigator.

**Salary Surveys**
- Choose Total Compensation → Basic → Salary Survey in the Navigator.

**Saving Plan**
- Choose People → Total Comp Enrollment → Benefits Enrollment → Savings Plan in the Navigator.

**Savings Plan (UK)**
1. Choose People → Total Comp Enrollment → Benefits Enrollment → Savings Plan in the Navigator.
2. Choose the Record Layout tab and query or enter a record layout.
3. Select a Data Element and choose the Include Conditions button.

**Scale Rate**
- Choose Work Structures -> Grade -> Point Values in the Navigator.

**Schedules (SSP/SMP)**
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.
2. Enter or query a pattern.
3. Choose the Calendars button.
4. Choose the Schedules button.

**Schools and Colleges**
- Choose Career Management -> Schools and Colleges in the Navigator.

**Schools and Colleges Attended**
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Schools/Colleges.

**Secondary Statuses**
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an applicant or employee.
3. Do one of the following:
   - For an applicant:
     - Choose the Others button and select Application.
     - Choose the Secondary Status button.
   - For an employee:
     - Choose the Assignment button.
     - Choose the Others button and select Secondary Status.

Or:
2. In the resulting Find window, query the person.
Security Groups (UK)

Security Profile
- Choose Security -> Profile in the Navigator.

Service Areas
- Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors -> Service Areas in the Navigator.

Sickness Control Rules (SSP/SMP)
2. Enter or query a Business Group
3. Choose the Others button and select Sickness Control Rules.

Sickness Evidence (SSP/SMP)
1. Choose SSP/SMP -> Person Details in the Navigator.
2. Enter or query a person.
3. Choose the Absence button.
4. Enter or query a sickness absence.
5. Choose the Evidence button.

Sickness Pay (SSP/SMP)
1. Choose SSP/SMP -> Person Details in the Navigator.
2. Enter or query a person.
3. Choose the Absence button.
4. Enter or query a sickness absence.
5. Choose the SSP/SMP button.

Sort
2. Choose the File Layout tab and select a Record Name.
3. Choose the Sort button.
Special Information

Do one of the following:

1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Special Info button.

Or:
1. Choose Fastpath → Special Information in the Navigator.
2. In the resulting Find window, query the person.

Special Information Types

- Choose Other Definitions → Special Information Types in the Navigator.

Special Rates

1. Choose People → Total Comp Enrollment → Benefits Enrollment → Flex Program in the Navigator.
2. Query a person.
3. Choose the Special Rates button.

SQWL Employer Rules (1) (Payroll) (US)

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL Employer Rules (1)

SQWL Employer Rules (2) (Payroll) (US)

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL Employer Rules (2)

SQWL Generic Transmitter Rules (Payroll) (US)

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL Generic Transmitter Rules

**Standard Distributions/Contributions (US)**

- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Standard Distributions/Contributions in the Navigator.

**SQWL State-Specific Transmitter Rules (Payroll) (US)**

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL State Transmitter Rules

**State Tax Rules (US)**

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select State Tax Rules.

**State Tax Rules <Employee> (US)**

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Tax Information button.

**Statement of Earnings (Payroll) (US)**

Do one of the following:

1. Choose View -> Assignment Process Results
2. Choose the SOE Report button.

Or:

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Statement of Earnings.
Or:
2. In the resulting Find window, query the person.

**Statement of Earnings (New Zealand) (NZ)**
1. Choose People –> Enter and Maintain.
2. Query a person.
Or:
1. Choose People –> Enter and Maintain.
2. Query a person.
Or:
2. Enter employee details.

**Standard Rates**
- Choose Total Compensation –> General Definitions –> Rate/Coverage Definitions –> Standard Rates in the Navigator.

**Statement of Earnings (AU)**
1. Choose People –> Enter and Maintain.
2. Query a person.
Or:
1. Choose People –> Enter and Maintain.
2. Query a person.
Or:
2. Enter employee details.
**Superannuation Fund Information (AU)**

1. Choose Work Structures -> Organization -> Description.
2. Enter or query an organization.
3. Select Payee Organization and choose the Others button.
4. Click in the blank field.

**Standard Holiday Absences <Employee> (CA)**

Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button.

Or:

1. Choose People -> Fastpath -> Statutory Holidays in the Navigator.
2. In the resulting Find window, query an employee.

**Submit a New Request**

1. Choose Processes and Reports -> Submit Processes and Reports in the Navigator.
2. Select Single Request or a Request Set.

**Supplementary Roles**

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button and select Supplementary Roles.

**Table Event Updates**

- Choose Other Definitions -> Table Event Updates in the Navigator.

**Table Structure**

- Choose Other Definitions -> Table Structure in the Navigator.

**Table Values**

- Choose Other Definitions -> Table Values in the Navigator.
**Taxation Information (New Zealand)**

1. Choose People -> Enter and Maintain.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Entries button.
5. Select PAYE Information in the Element Name column.
6. Click on the Entry Values button.

**Terminate**

Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button and select End Employment.

**Terminate Applicant**

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button and select End Application.

Or:

1. Choose Fastpath -> End Application in the Navigator.
2. In the resulting Find window, query the person.

**Termination Payments (AU)**

- Choose FastPath -> Termination Payments.

**Transaction Categories**

- Choose Transaction Maintenance Forms -> Transaction Categories in the Navigator.

**Transaction Status**

- Choose Security -> Transaction Status in the Navigator

**Transaction Category Wizard**

Transaction Templates

- Choose Transaction Maintenance Forms -> Transaction Templates in the Navigator.
- Choose Total Compensation -> Basic -> Union Element Creation Template.

Update Payroll Run (Payroll)

- Choose Payroll -> Update Payroll Run in the Navigator.

Valid Grades (for jobs)

2. Choose either Job -> Description or Position -> Description.
3. Enter or query a job or position.
4. Choose the Valid Grades button.

User Types and Statuses

- Choose Other Definitions -> User Types and Statuses

Valid Payment Methods

1. Choose Payroll -> Description in the Navigator.
2. Enter or query a payroll.
3. Choose the Valid Payment Methods button.

Variable Rate Profiles

- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Variable Rate Profiles in the Navigator.

VETS–100 Filing (US)

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select VETS–100 Filing.

Vehicle Data Entry (UK)

- Choose Total Compensation -> Basic -> Vehicle Data Entry in the Navigator.
View Absence History
- Choose View -> Histories -> Absence in the Navigator.

View Earnings and Deductions Balances (US, CA)
Do one of the following:
1. Choose View -> Employee Balances in the Navigator.
2. Select an employee assignment and choose the Balances button.
Or:
1. Choose Fastpath -> Employee Balances in the Navigator.
2. In the resulting Find window, query the person.

View Element Entry History for Employee
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the Entry History button.

View Employee Dental, Medical and Vision Benefits (US)
1. Choose View -> Employee Benefits in the Navigator.
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the View Benefits button.

View Employee Grade Comparatio
- Choose View -> Grade Comparatio in the Navigator.

View Enrollment Results
- Choose People -> Total Comp Enrollment -> Benefits Enrollment -> View Enrollment Results in the Navigator.

View Participation Information (Advanced Benefits)
- Choose People -> Total Comp Participation -> View Participation Information in the Navigator.

View Program Structure
- Choose Total Compensation -> Programs and Plans -> View Program Structure in the Navigator.
**View Run Messages** (Payroll)
- Choose View -> System Messages in the Navigator.

**View Tax Balances** (US)
Do one of the following:
2. Select an employee assignment and choose the Balances button.
Or:
2. In the resulting Find window, query the person.

**View Vacancies**
- Choose View -> Vacancies in the Navigator.

**Visa Data Template**
- Choose People -> Maintain Using Templates -> Maintain Visa Information

**W2 Reporting Rules** (US)
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select W2 Reporting Rules.

**W941** (Payroll) (US)
- Choose View -> Tax Information-> Form 941 Information in the Navigator

**WC Codes and Rates** (US)
- Choose Work Structures -> Job -> Workers Compensation Rates in the Navigator

**Wage Attachment Earnings Rules** (US)
- Choose Total Compensation -> Wage Attachment -> Earnings Rules in the Navigator.
Wage Attachment Exemption Rules (US)
- Choose Total Compensation -> Wage Attachment -> Exemption Rules in the Navigator.

Wage Attachment Limit Rules (US)
- Choose Total Compensation -> Wage Attachment -> Limit Rules in the Navigator.

Waive Participation (Advanced Benefits)
- Choose People -> Total Comp Participation -> Waive Participation in the Navigator.

Waiving
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Waiving button.

What-if Eligibility (Advanced Benefits)
- Choose People -> Total Comp Participation -> What-if Eligibility in the Navigator.

Work Choices (Job and Position)
1. Choose Work Structures -> Job or Position -> Description in the Navigator.
2. Enter or query a job or position.
3. Choose the Work Choices button.

Work Choices (Person)
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Work Choices.

Work Day Information
2. Enter or query an organization.
3. Choose the Others button and select Work Day Information.
Work Incident
Do one of the following:
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Work Incidents.
Or:
2. In the resulting Find window, query the person.
2. Enter or query an organization.
3. Choose the Others button and select Work Schedule.

Work Site Filing (US)
2. Enter or query a Reporting Establishment.
3. Choose the Others button and select Work Site Filing.

Worker’s Compensation (US)
  ● Choose Work Structures → Job → Workers Compensation Codes in the Navigator

Worksheet
2. Define the properties of the worksheet.
3. Choose the Create Worksheet button.

Worksheet Characteristics
  ● Choose Work Structures → Budget → Worksheet in the Navigator.
Reports and Processes in Oracle HRMS

Reports

AAP Reports (US)
- Provides Job group analysis and workflow analysis reports.

Absence Report
- Absence details for an employee or organization, for some or all absence types.
See: Managing Total Compensation Using Oracle HRMS.

ADA Reports (US)
- Shows how your enterprise is responding to the requests of employees with disabilities.

Advance Pay Listing (Payroll) (UK)
- Details of the advance pay periods for employees due to receive advance pay.
See: Running Your Payroll Using Oracle HRMS (UK).

Annual Unemployment Insurance (Form 940) Information (Payroll) (US)
- Provides numbers for annual 940 filing.

Assignment Status Report
- All employees, applicants or both assigned to selected work structures.
See: Managing Your Workforce Using Oracle HRMS.

Assignments Unavailable for Processing Report (Payroll) (UK)
- Assignments that will not be processed by particular payroll runs and reasons for their exclusion.
See: Running Your Payroll Using Oracle HRMS (UK)
Audit Report (Payroll)

- Selects person, employee or applicant, assignment, element, recurring or non-recurring status. Shows Business Group, GRE (US only), assignment details, person entering data (responsibility), input date, effective change date, details of person affected. Lists all fields changed, with input date and effective date, old value and new value, responsibility, workstation address.

See: Configuring, Reporting and System Administration in Oracle HRMS.

Budget Position Detail Report

- Lists the status of all Positions that are part of a specific Budget.


Calculate Commitment (AUS) (UK)

- Run this process to calculate the projected expenditures for a budget over a given period. You can calculate commitments for an entire budget or for a single position in a budget.

See: Using Oracle HRMS – The Fundamentals

COBRA Reports (US)

- Coverage of payments report and publish standard COBRA letter.

See: Managing Total Compensation Using Oracle HRMS.

Cost Breakdown Report (Payroll)

- Summarized costing totals for a specified costing process and summarized costing totals for a particular consolidation set or payroll over a specified interval.

Cost Breakdown Summary Report (Payroll only) (US & Can)

- Lists costing details by date range, payroll, consolidation set, GRE and segment values.


Current and Projected Progression Point Values Report

- The expected results of running the Increment Progression Points process, that is the projected point and value changes for a group of employees.

Earnings Audit (Payroll) (US)
- Report detailing all employees with a particular element being processed in a given pay period.
See: Running Your Payroll Using Oracle HRMS.

EEO–1 Reports (US)
- EEO individual establishment and headquarters report and EEO consolidated report.

EEO4 Reports (US)
- Run this report for state and local governments.

EEO5 Reports (US)
- Run this report for the school system or district.

Element Link Details Report
- The eligibility criteria for an element or group of elements.
See: Managing Total Compensation Using Oracle HRMS.

Element Result Listing
- Run results processed for a particular element over a defined period, and run results for selected input values of each employee’s last assignment process.
See: Running Your Payroll Using Oracle HRMS.

Employee Increment Results Report
- The actual results of running the Increment Progression Points process, that is progression point and value changes for a group of employees.

Employee Organization Movement Report
- New hires, terminations, transfers in and transfer out of a selected organization, or organization hierarchy.
See: Managing Your Workforce Using Oracle HRMS.
Employee Payroll Movement Report (Payroll)
- New hires, terminations, transfers in and transfer out of a selected payroll.

See: Managing Your Workforce Using Oracle HRMS.

Employee Run Results (Payroll) (Can & US)
- Users may select various elements for the various time frames, assignment of GREs. The report shows the run results for selected information by pay period.

See: Running Your Payroll Using Oracle HRMS.

Employee Run Results Summary Report (GB) (Payroll) (UK)
- Includes all assignments, gross pay, PAYE, employee’s NI contribution, employer’s NI contribution, other deductions, total deductions, net pay and total pay for the payroll.

See: Running Your Payroll Using Oracle HRMS (UK).

Employee Summary Report
- Addresses, contacts, periods of service, assignments, special information, personal payment methods and element entries for a selected employee.

See: Managing Your Workforce Using Oracle HRMS.

Employer Monthly Schedule Report (New Zealand)
- Lists the details of all employees and is submitted to Inland Revenue.

See: Oracle HRMS for New Zealand User Supplement.

FBT Report (Australia)
- Displays Fringe Benefits Tax information for a cost center.

See: Running Your Payroll Using Oracle HRMS.

Federal 1099–R Forms (Payroll) (US)
- Provides for printing of retiree 1099–R at an individual level as well as all employees in a GRE.

See: Running Your Payroll Using Oracle HRMS.
Federal 1099–R (magnetic media) (Payroll) (US)
- Creation of Federal 10999R magnetic media.
See: Running Your Payroll Using Oracle HRMS.

Federal W–2 Forms (Payroll) (US)
- Prints employee W–2s at an individual level, thus allowing W–2s to be created as employees terminate, or for an entire GRE.
See: Running Your Payroll Using Oracle HRMS.

Federal W–2 (magnetic media) (Payroll) (US)
- Creation of Federal W–2 magnetic media and summary totals.
See: Running Your Payroll Using Oracle HRMS.

Full Applicant Details
- Applications and applicant interviews for one applicant.
See: Managing Your Workforce Using Oracle HRMS.

Full Assignment Details
- Assignment information including periods of service, payment methods, and element entries for one employee.
See: Managing Your Workforce Using Oracle HRMS.

Full Person Details
- Addresses and information entered in the Person window such as name, date of birth, nationality and work telephone number for one employee.
See: Managing Your Workforce Using Oracle HRMS.

Full Personal Details Report Set
- Person details, applicant details, assignment details and work details for one employee.
See: Managing Your Workforce Using Oracle HRMS.

Full Work Details
- Miscellaneous work information including special information, absences, recruitment activities and contacts for one employee.
See: Managing Your Workforce Using Oracle HRMS.
GRE Totals (Payroll) (US)
- Reconciliation report to be used to assist in period end processing balancing purposes. This report shows Federal and State level taxable balances and withholdings.
See: Running Your Payroll Using Oracle HRMS.

Gross to Net Summary Report (UK) (Payroll) (UK)
- Details of total earnings and deductions summarized for a specified payroll and payroll period.
See: Running Your Payroll Using Oracle HRMS (UK)

Gross to Net Summary US (Payroll) (US)
- Details of total earnings and deductions summarized for a specified payroll and payroll period.
See: Running Your Payroll Using Oracle HRMS.

Inland Revenue Arrears Payment Report (New Zealand)
- Lists employees who are required to pay student loans or child support arrears to Inland Revenue.
See: Oracle HRMS for New Zealand User Supplement.

Inland Revenue Remittance Certificate Report (New Zealand)
- Submitted to Inland Revenue by employers who are required to make PAYE payments, or employers who are Specified Superannuation Contribution Withholding Tax (SSCWT) payers.
See: Oracle HRMS for New Zealand User Supplement.

Invalid Address Report (Payroll) (US)
- Lists any address information inconsistencies.
See: Running Your Payroll Using Oracle HRMS.

Job and Position Skills Matching Report
- Lists of employees, applicants or both that meet some or all skill requirements of a job or position.
See: Managing Your Workforce Using Oracle HRMS.
Leave Liability Report (Australia)
- Displays leave balances for employees.
See: Running Your Payroll Using Oracle HRMS.

Leave Liability Report (New Zealand)
- Displays the accrued debt owed by an organization for the leave balances of their employees.
See: Oracle HRMS for New Zealand User Supplement.

Multiple Assignments Report (Payroll) (UK)
- Lists employees who have been marked for multiple assignment processing and indicates where Priority Processing Type is not set and cannot be defaulted.
See: Running Your Payroll Using Oracle HRMS (UK).

Multiple Worksite Report (US)
- Reports on wages and locations of employees in all the multiple locations across all SUIs and other GREs.
See: Managing People Using Oracle HRMS.

NACHA (magnetic media) (Payroll) (US)
- Provides for creation of employee NACHA information to be submitted.
See: Running Your Payroll Using Oracle HRMS.

NACHA Report (Payroll) (US)
- Detail of employee NACHA information.
See: Running Your Payroll Using Oracle HRMS.

Negative Balance Reports (Payroll) (US)
- Report listing any negative balances found due to user adjustments or conversion issues.
See: Running Your Payroll Using Oracle HRMS.

New Hire Reports (US)
- Report on newly hired or rehired employees.
NI Car Detail Report (Payroll) (UK)
- All the NI Y amounts due from employees on a given payroll who have company car benefits.
See: Running Your Payroll Using Oracle HRMS.

NI Cable Benefits Summary Report (Payroll) (UK)
- Lists the employee benefits for which the employer is liable for NI contributions.
See: Running Your Payroll Using Oracle HRMS (UK).

Organization Hierarchy Report
- The organizations and optionally their managers below a selected position in a particular hierarchy.

Organizational Position Summary Report (UK, US & Can)
- Lists the budget status for all positions within a Position Control Organization.
See: Managing Your Workforce Using Oracle HRMS.

OSHA Reports (US)
- Report on work related injuries or illness.

P45 Alignment Report (UK)
- Draft printer alignment for P45 reports.
See: Running Your Payroll Using Oracle HRMS.

P45 Report (Payroll) (UK)
- P45 details for terminated employees for issue to the tax office and the leaver; P45 details for current employees for issue to different tax offices.
See: Running Your Payroll Using Oracle HRMS.

Pay Advice (Australia)
- Generates pay advice for all employees for a specified payroll and period.
See: Running Your Payroll Using Oracle HRMS.
Pay Advice Report (New Zealand)
- Generates pay advice for all employees for a specified payroll and period.

See: Oracle HRMS for New Zealand User Supplement.

Pay Advice Alignment Report (Payroll) (UK)
- Draft printer alignment for your sample pay advice.

See: Running Your Payroll Using Oracle HRMS.

Pay Advice Report (Payroll) (UK)
- Pay advice details in a customizable format, either for single assignments or for all assignments on a payroll after Pre-payments is complete for the payroll.

See: Running Your Payroll Using Oracle HRMS.

Payments Register (Payroll) (US)
- Reports listing payments made to employees, listing payment method, check number, and amount.

See: Running Your Payroll Using Oracle HRMS.

Payments Summary Report (GB) (Payroll) (UK)
- Payments totalled by payment method type and organizational payment method for a specified payroll and payroll period. Account details for each organizational payment method are also listed.

See: Running Your Payroll Using Oracle HRMS.

Payroll Message Report (Payroll)
- Display messages for processes connected to specified payrolls.

See: Running Your Payroll Using Oracle HRMS.

Payroll Reconciliation Report (Australia)
- Generates payroll reconciliation for a specified payroll period.

See: Running Your Payroll Using Oracle HRMS.

Payroll Reconciliation Report (New Zealand)
- Generates a payroll reconciliation for a specified payroll period.

See: Oracle HRMS for New Zealand User Supplement.
Payroll Statutory Calendar Report (Payroll) (UK)

- The sequence of regular payment dates for each payroll and the numbers of assignments completed, pre-paid and paid within a run.

See: Running Your Payroll Using Oracle HRMS.

Position Element Detail Report

- Lists the budget status for all budgeted elements for a specific Position and Organization.


Position Element Summary Report

- Lists the budget status for an element for all positions in the Business Group.


Position Hierarchy Report

- The positions and optionally their holders below a selected position in a particular hierarchy.


Position Summary Report

- Lists the budget status of all Positions in a specific Organization.


Quarterly Employment Survey (New Zealand)

- Extracts information to enable the Statistics New Zealand quarterly employment survey to be completed.

See: Oracle HRMS for New Zealand User Supplement.


- Run this report if you administer position control budgets. The report lists the positions that are under budgeted for the selected organization and all subordinate organizations in the organization hierarchy.

See: Using Oracle HRMS – The Fundamentals
Requisition Summary Report
- Applicants and their interview schedules for a selection of vacancies.

See: Managing Your Workforce Using Oracle HRMS.

Retro Notifications Report
- Retroactive changes applying to a period for which payroll processing has already taken place.

See: Running Your Payroll Using Oracle HRMS.

Running the P45(3) & P46 Exceptions Report (UK)
- Enables you to identify those employees for whom a P45(3) or P56 has not been created, yet have been paid since their initial hire date.

See: Running Your Payroll Using Oracle HRMS.

Running the P46 (P160) Pension Notification (UK)
- Enables you to provide information on recipients of taxable pensions, and those gaining extra income while collecting a pension.

See: Running Your Payroll Using Oracle HRMS.

Salary Review Report
- Current, past and proposed salaries for a selected list of employees.

See: Managing Total Compensation Using Oracle HRMS.

Series EE Bond Purchase Report (US)
- Compares actual staffing level with budgeted levels over a specific period.

Staffing Budget Details Report
- Actual staffing level with budgeted levels over a specified period.

See: Managing Your Workforce Using Oracle HRMS.

Start of Year: Unprocessed P9 Records Report (Payroll) (UK)
- Valid records on the Inland Revenue P9 tape that do not fully match your database records after running the Start of Year process.

See: Running Your Payroll Using Oracle HRMS.
Statement of Earnings (Payroll) (US)
- Check writer process produces paychecks with statement of earnings.
See: Running Your Payroll Using Oracle HRMS.

Superannuation Contribution Report (AUS)
- Identifies monthly figures for superannuation salary and employer superannuation guarantee contributions.

Tax Payments Listing (Payroll) (UK)
- Details of employees’ PAYE and National Insurance deductions.
See: Running Your Payroll Using Oracle HRMS.

Terminations Report
- The number of employees from selected organizations leaving your enterprise within a particular period, and the reason for leaving.
See: Managing Your Workforce Using Oracle HRMS.

Union Deductions Report (Payroll) (UK)
- Total deductions that your employees pay to unions.
See: Running Your Payroll Using Oracle HRMS.

VETS–100 Reports (US)
- Shows number of special disabled and Vietnam era veterans you employ in each of nine job categories. Also, show total number of new hires in each job category and number of new hires in each category who qualify as special disabled veterans and Vietnam era veterans.

Void Payments Report (Payroll)
- Details of cancelled cheque payments
See: Running Your Payroll Using Oracle HRMS.
Workforce Headcount Report

- The number and type of employees within an organization, as well as employee attrition rate data.

See: Managing Your Workforce Using Oracle HRMS.
Processes

**Advance Pay Process** (Payroll) (UK)
- Allows you to pay employees in advance for holidays or other events.

See: *Running Your Payroll Using Oracle HRMS*.

**Annual and Long Service Leave Liability Process (Australia)**
- Extracts information used in the Leave Liability Report.

See: *Running Your Payroll Using Oracle HRMS*.

**ASB CSV Direct Credit Process (New Zealand)**
- Details of all employees that use the direct credit as the payment method.

See: *Oracle HRMS for New Zealand User Supplement*.

**Audit Trail Update Tables Process**
- This process is used to set up audit trail on selected tables.

See: *Configuring, Reporting and System Administration in Oracle HRMS*.

**Audit Trail Update Datetracked Tables Process**
- This process is used to set up audit trail on selected datetracked tables.

See: *Configuring, Reporting and System Administration in Oracle HRMS*.

**BACS Process** (Payroll) (UK)
- Summarized totals for BACS tape amounts including consolidated totals for multi-day and multi-file formats.

See: *Running Your Payroll Using Oracle HRMS*.

**Bee Batch Process (Purge)**
- This process is used to delete a batch from the BEE tables on completion of the concurrent request.

See: *Managing Total Compensation Using Oracle HRMS*.
BEE Batch Process (Rollback)
- This process is used to completely remove a BEE transfer, provided you have not purged the batch from the BEE tables.
See: Managing Total Compensation Using Oracle HRMS.

BEE Batch Process (Transfer)
- This process is used to create element entries in the Oracle HRMS Entries table from the existing entries in the BEE temporary tables.
See: Managing Total Compensation Using Oracle HRMS.

Bee Batch Process (Validate)
- This process is used to test each batch line against predefined rules about element entries, and against any additional validation procedures that you have created.
See: Managing Total Compensation Using Oracle HRMS.

Bulk Compile Formulas
- Run this process to compile all of your formulas.
See Using Oracle FastFormula.

Calculate Commitment
- Run this process to calculate the projected expenditures for a budget over a given period. You can calculate commitments for an entire budget or for a single position in a budget.
See: Using Oracle HRMS – The Fundamentals

Calculate FTE for Assignments (UK)
- This process is used to populate the Assignment Budget Window with FTE values.

Cash Process (Payroll only) (UK)
- Enables you to use cash as a payment method and record cash payments to employee assignments.
See: Running Your Payroll Using Oracle HRMS.
Cheque Writer Process (Payroll)
■ This process is used to write sequences of cheques for your payroll run.
See: Running Your Payroll Using Oracle HRMS.
■ This process is used to populate the Assignment Budget Window with FTE values.

Check Writer Process (Payroll) (US)
■ This process is used to write sequences of checks for your payroll run.

Close Action Items Process (Advanced Benefits)
■ Run this process before the Close Enrollments Process to close any open action items that are required or optional for the persons you select.
See: Managing Total Compensation Using Oracle HRMS.

Close Enrollments Process (Advanced Benefits)
■ Run this process to close a person’s enrollment after elections have been made.
See: Managing Total Compensation Using Oracle HRMS.

Commitment GL Posting
■ You run the Commitment GL Posting batch process to transfer budget commitments from Oracle HRMS to Oracle General Ledger.
See: Using Oracle HRMS – The Fundamentals

Communications Triggers Process (Advanced Benefits)
■ Use the communications triggers process to generate communications for persons who meet the selection criteria that you specify.
See: Managing Total Compensation Using Oracle HRMS.

Costing Process (Payroll)
■ Generates journal entries for your ledgers and costing information relating to labor costs.
Default Enrollment Process (Advanced Benefits)
- Run this process to enroll participants into the default benefit plan when participants have not made an election.
See: Managing Total Compensation Using Oracle HRMS.

Dependent Eligibility Process (Advanced Benefits)
- Run this process for those benefit plans that include an age factor in determining dependent eligibility.
See: Managing Total Compensation Using Oracle HRMS.

Direct Entry (Australian BECS Format) Process (AUS)
- Produces a payment file for all employees.
See: Running Your Payroll Using Oracle HRMS.

Download HRMS Taskflows Process
- Run this process to export a task flow from your database to a flat file that you can then import to another database.
See: Configuring, Reporting and System Administration in Oracle HRMS.

Extract Process (Advanced Benefits)
- Run the extract process to save the output of your system extract to the directory and file that you specified in your extract definition.
See: Managing Total Compensation Using Oracle HRMS.

Enable Multiple Security Groups Process
- Run this process when you first set up security groups enabled security.
See: Configuring, Reporting and System Administration in Oracle HRMS.

End of Year Process (Payroll) (UK)
- Produces statutory End of Year return to the Inland Revenue for employees in your enterprise.
See: Running Your Payroll Using Oracle HRMS.

Forms Configurator – Download Template
- Run this process to download one or more templates to a data file.
See: Configuring, Reporting and System Administration in Oracle HRMS.
Forms Configurator – Upload Template
- Run this process to upload a template to enable you to use it with the Forms Configurator tool.

See: Configuring, Reporting and System Administration in Oracle HRMS.

Grant Permissions to Roles Process (ROLEGEN)
- Dynamically grants select permissions on Oracle HRMS tables and views to the HR_REPORTING_USER role.

See: Configuring, Reporting and System Administration in Oracle HRMS.

Generate Secure User Process (SECGEN)
- Run this process when you create a new security profile that references a reporting user.

See: Configuring, Reporting and System Administration in Oracle HRMS.

Maintain Participant Eligibility Process (Standard Benefits)
- Run this process if you license Standard Benefits and you want to determine benefits eligibility for a segment of your employee population. This process also de-enrolls currently enrolled participants who lose benefits eligibility and ends their associated benefits coverage and activity rate.

See: Managing Total Compensation Using Oracle HRMS.

NACHA Process (Payroll) (US)
- Produces files that you load on magnetic tape and despatch to banks for direct deposit payments.

See: Running Your Payroll Using Oracle HRMS.

Organizational Position Summary Report
- Lists the budget status for all positions within a Position Control Organization.


Participation Batch Process: Life Event (Advanced Benefits)
- Run this process to determine eligibility and electable choices for benefits participants based on a life event you select.

See: Managing Total Compensation Using Oracle HRMS.
Participation Batch Process: Scheduled (Advanced Benefits)
- Run this process to determine eligibility and electable choices for benefits participants based on a scheduled enrollment event.
See: Managing Total Compensation Using Oracle HRMS.

Participation Batch Process: Selection (Advanced Benefits)
- Run this process to determine eligibility for benefits participants. This process does not create electable choices.
See: Managing Total Compensation Using Oracle HRMS.

PrePayments Process (Payroll)
- Use this process to distribute employee pay over more than one payment method using either a percentage or monetary split.
See: Running Your Payroll Using Oracle HRMS.

Relieve Commitments
- Run the Relieve Commitments request set to calculate budget commitments and post the results to Oracle General Ledger. The request set combines the Calculate Commitments process and the Commitment GL Posting process.
See: Using Oracle HRMS – The Fundamentals

Report Under Budgeted Positions (Salary)
- Run this report if you administer position control budgets. The report lists the positions that are under budgeted for the selected organization and all subordinate organizations in the organization hierarchy.
See: Using Oracle HRMS – The Fundamentals

Retro Notifications Report (AUS)
- Retroactive changes applying to a period for which payroll processing has already taken place.
See: Running Your Payroll Using Oracle HRMS.

Retry Payroll Process
- Retry a payroll process again.
See: Running Your Payroll Using Oracle HRMS.
RetroPay Process
- Enables you to make back pay adjustments.
See: Running Your Payroll Using Oracle HRMS.

Running the P45 Process (UK)
- Enables you to print and archive, or just archive specified P45’s.
See: Running Your Payroll Using Oracle HRMS.

Running the P45 EDI Process (UK)
- Enables you to notify the Inland Revenue about employees who leave your employment.
See: Running Your Payroll Using Oracle HRMS.

Running the P45(3) EDI Process (UK)
- Enables you to notify the Inland Revenue about a new starters information, or someone receiving a pension.
See: Running Your Payroll Using Oracle HRMS.

Running the P46 EDI Process (UK)
- Enables you to provide information on new employees who cannot produce, or have never had a P45.
See: Running Your Payroll Using Oracle HRMS.

Running the P6 and P9 Upload Process (UK)
- Run the process to upload the details about changes to an employee’s tax code, or coding changes from the Inland Revenue.
See: Running Your Payroll Using Oracle HRMS.

Running the Works Number Update (UK)
- Run to provide information on updated and new employee works numbers.
See: Running Your Payroll Using Oracle HRMS.

Security List Maintenance Process (LISTGEN)
- This process is usually run every night to maintain the lists of organizations, positions, payrolls, employees, and applicants that security profile holders can access.
See: Configuring, Reporting and System Administration in Oracle HRMS.
Start of Year Process  (Payroll) (UK)
- Usually performed at the start of the tax year to update tax information for each employee.

See: Running Your Payroll Using Oracle HRMS.

Synchronize Positions Process
- This process updates the non-datetracked Positions table (PER_ALL_POSITIONS_F) with changes made to the datetracked table (HR_ALLPOSITIONS_F). When you run the process, any datetracked changes with an effective date on or before today are applied to the non-datetracked table.

Tenure Notifications
- These notification reports are available for you to send to faculty members and their academic manager during the Tenure process.

Tenure Reports
- The following reports are available to assist you with the administration of Tenure tracking.

Transfer to GL Process
- Transfers the results of the costing process to the Accounting flexfield of Oracle General Ledger.

See: Managing Your Workforce Using Oracle HRMS.

Upload HRMS Taskflows Process
- Run this process to import a task flow to your database from a flat file exported from another database.

See: Configuring, Reporting and System Administration in Oracle HRMS.

Void Payments Process  (Payroll) (UK & US)
- Allows you to void cheques that have been printed but need to be cancelled.

See: Running Your Payroll Using Oracle HRMS.
Workforce Headcount Report (US)

- The number and type of employees within an organization, as well as employee attrition rate data.

See: Managing People Using Oracle HRMS.

See: Running Your Payroll Using Oracle HRMS.
Glossary

360 Degree Appraisal  Part of the SSHR Appraisal function and also known as a Group Appraisal. This is an employee appraisal undertaken by managers with participation by reviewers.

360 Degree Self Appraisal  Part of the SSHR Appraisal function and also known as a Group Appraisal. This is a 360 Degree appraisal initiated by an employee. The employee (initiator) can add managers and reviewers to the appraisal.

A

Absence Types  Categories of absence, such as medical leave or vacation leave, that you define for use in absence windows.

Accrual  The recognized amount of leave credited to an employee which is accumulated for a particular period.

Accrual Band  A range of values that determines how much paid time off an employee accrues. The values may be years of service, grades, hours worked, or any other factor.

Accrual Plan  See: PTO Accrual Plan

Accrual Period  The unit of time, within an accrual term, in which PTO is accrued. In many plans, the same amount of time is accrued in each accrual period, such as two days per month. In other plans, the amount accrued varies from period to period, or the entitlement for the full accrual term is given as an up front amount at the beginning of the accrual term.

Accrual Term  The period, such as one year, for which accruals are calculated. In most accrual plans, unused PTO accruals must be carried over or lost at the end of the accrual term. Other plans have a rolling accrual term which is of a certain duration but has no fixed start and end dates.

Activity Rate  The monetary amount or percentage associated with an activity, such as $12.35 per pay period as an employee payroll contribution for medical coverage. Activity rates can apply to participation, eligibility, coverages, contributions, and distributions.

Actual Premium  The per-participant premium an insurance carrier charges the plan sponsor for a given benefit.
Administrative Enrollment  A type of scheduled enrollment caused by a change in plan terms or conditions and resulting in a re-enrollment.

Applicant  A candidate for employment in a Business Group.

Appraisee  A person being appraised by an appraiser.

Appraiser  A person, usually a manager, who appraises an employee.

Appraisal  An appraisal is a process where an employee’s work performance is rated and future objectives set.  See also:  Assessment.

Appraising Manager  The person who initiates and performs an Employee–Manager or 360 Degree Appraisal. An appraising manager can create appraisal objectives.

Apply for a Job  An SSHR function that enables an employee to, apply, search and prepare applications for an internally advertised vacancy.

Arrestment  Scottish court order made out for unpaid debts or maintenance payments.  See also:  Court Order

Assessment  An information gathering exercise, from one or many sources, to evaluate a person’s ability to do a job.  See also:  Appraisal.

Assignment  An employee’s assignment identifies his or her role and payroll within a Business Group. The assignment is made up of a number of assignment components. Of these, organization is mandatory, and payroll is a required component for payment purposes.

Assignment Number  A number that uniquely identifies an employee’s assignment. An employee with multiple assignments has multiple assignment numbers.

Assignment Set  A grouping of employees and/or applicants that you define for running QuickPaint reports and processing payrolls.  See also:  QuickPaint Report

Assignment Status  For employees, used to track their permanent or temporary departures from your enterprise, and to control the remuneration they receive. For applicants, used to track the progress of their applications.

B

BACS  Banks Automated Clearing System. This is the UK system for making direct deposit payments to employees.

Balances  Positive or negative accumulations of values over periods of time normally generated by payroll runs. A balance can sum pay values, time periods or numbers.  See also:  Predefined Components

Balance Adjustment  A correction you make to a balance. You can adjust user balances and assignment level predefined balances only.

Balance Dimension  The period for which a balance sums its balance feeds, or the set of assignments/transactions for which it sums them. There are five time dimensions: Run, Period, Quarter, Year and User. You can choose any reset point for user balances.

Balance Feeds  These are the input values of matching units of measure of any elements defined to feed the balance.
**Bargaining Unit** A bargaining unit is a legally organized group of people which have the right to negotiate on all aspects of terms and conditions with employers or employer federations. A bargaining unit is generally a trade union or a branch of a trade union.

**Base Currency** The currency in which Oracle Payroll performs all payroll calculations for your Business Group. If you pay employees in different currencies to this, Oracle Payroll calculates the amounts based on exchange rates defined in the system.

**Behavioral Indicators** Characteristics that identify how a competence is exhibited in the work context. See also: Proficiency Level

**Benefit** Any part of an employee’s remuneration package that is not pay. Vacation time, employer-paid medical insurance and stock options are all examples of benefits. See also: Elements

**Beneficiary** A person or organization designated to receive the benefits from a benefit plan upon the death of the insured.

**Block** The largest subordinate unit of a window, containing information for a specific business function or entity. Every window consists of at least one block. Blocks contain fields and, optionally, regions. They are delineated by a bevelled edge. You must save your entries in one block before navigating to the next. See also: Region, Field

**Budget Value** In Oracle Human Resources you can enter staffing budget values and actual values for each assignment to measure variances between actual and planned staffing levels in an organization or hierarchy.

**Business Group** The highest level organization in the Oracle HRMS system. A Business Group may correspond to the whole of your enterprise or to a major grouping such as a subsidiary or operating division. Each Business Group must correspond to a separate implementation of Oracle HRMS.

**Business Number (BN)** In Canada, this is the employer’s account number with Revenue Canada. Consisting of 15 digits, the first 9 identify the employer, the next 2 identify the type of tax account involved (payroll vs. corporate tax), and the last 4 identify the particular account for that tax.

**Cafeteria Benefits Plan** See: Flexible Benefits Program

**Calendars** In Oracle Human Resources you define calendars that determine the start and end dates for budgetary years, quarters and periods. For each calendar you select a basic period type. In Oracle SSP/SMP you define calendars to determine the start date and time for SSP qualifying patterns.

**Calendar Exceptions** In Oracle SSP/SMP you define calendar exceptions for an SSP qualifying pattern, to override the pattern on given days. Each calendar exception is another pattern which overrides the usual pattern.

**Canada/Quebec Pension Plan (CPP/QPP) Contributions** Contributions paid by employers and employees to each of these plans provide income benefits upon retirement.
**Candidate Offers** An SSHR function used by a line manager to offer a job to a candidate. This function is supplied with its own responsibility.

**Career Path** This shows a possible progression from one job or position from any number of other jobs or positions within the Business Group. A career path must be based on either job progression or position progression; you cannot mix the two.

**Carry Over** The amount of unused paid time off entitlement an employee brings forward from one accrual term to the next. It may be subject to an expiry date i.e. a date by which it must be used or lost. See also: [Residual](#)

**Cash Analysis** A specification of the different currency denominations required for paying your employees in cash. Union contracts may require you to follow certain cash analysis rules.

**Certification** Documentation required to enroll or change elections in a benefits plan as the result of a life event, to waive participation in a plan, to designate dependents for coverage, or to receive reimbursement for goods or services under an FSA.

**Ceiling** The maximum amount of unused paid time off an employee can have in an accrual plan. When an employee reaches this maximum, he or she must use some accrued time before any more time will accrue.

**Child/Family Support payments** In Canada, these are payments withheld from an employee’s compensation to satisfy a child or family support order from a Provincial Court. The employer is responsible for withholding and remitting the payments to the court named in the order.

**Collective Agreement** A collective agreement is a form of contract between an employer or employer representative, for example, an employer federation, and a bargaining unit for example, a union or a union branch.

**Collective Agreement Grade** Combination of information that allows you to determine how an employee is ranked or graded in a collective agreement.

**Communications** Benefits plan information that is presented in some form to participants. Examples include a pre-enrollment package, an enrollment confirmation statement, or a notice of default enrollment.

**Compensation** The pay you give to employees, including wages or salary, and bonuses. See also: [Elements](#)

**Compensation Object** For Standard and Advanced Benefits, compensation objects define, categorize, and help to manage the benefit plans that are offered to eligible participants. Compensation objects include programs, plan types, plans, options, and combinations of these entities.

**Competence** Any measurable behavior required by an organization, job or position that a person may demonstrate in the work context. A competence can be a piece of knowledge, a skill, an attitude or an attribute.

**Competence Evaluation** A method used to measure an employees ability to do a defined job.

**Competence Profile** Where you record applicant and employee accomplishments, for example, proficiency in a competence.

**Competence Requirements** Competencies required by an organization, job or position. See also: [Competence, Core Competencies](#)
**Competence Type**  A group of related competencies.

**Configurable Forms**  Forms that your system administrator can modify for ease of use or security purposes by means of Custom Form restrictions. The Form Customization window lists the forms and their methods of configuration.

**Consolidation Set**  A grouping of payroll runs within the same time period for which you can schedule reporting, costing, and post-run processing.

**Contact**  A person who has a relationship to an employee that you want to record. Contacts can be dependents, relatives, partners or persons to contact in an emergency.

**Contract**  A contract of employment is an agreement between an employer and employee or potential employee that defines the fundamental legal relationship between an employing organization and a person who offers his or her services for hire. The employment contract defines the terms and conditions to which both parties agree and those that are covered by local laws.

**Contribution**  An employer's or employee's monetary or other contribution to a benefits plan.

**Core Competencies**  Also known as Leadership Competencies or Management Competencies. The competencies required by every person to enable the enterprise to meet its goals. See also: Competence

**Costable Type**  A feature that determines the processing an element receives for accounting and costing purposes. There are four costable types in Oracle HRMS: costed, distributed costing, fixed costing, and not costed.

**Costing**  Recording the costs of an assignment for accounting or reporting purposes. Using Oracle Payroll, you can calculate and transfer costing information to your general ledger and into systems for project management or labor distribution.

**Court Order**  A ruling from a court that requires an employer to make deductions from an employee's salary for maintenance payments or debts, and to pay the sums deducted to a court or local authority. See also: Arrestment

**Database Item**  An item of information in Oracle HRMS that has special programming attached, enabling Oracle FastFormula to locate and retrieve it for use in formulas.

**Date To and Date From**  These fields are used in windows not subject to DateTrack. The period you enter in these fields remains fixed until you change the values in either field. See also: DateTrack, Effective Date

**DateTrack**  When you change your effective date (either to past or future), DateTrack enables you to enter information that takes effect on your new effective date, and to review information as of the new date. See also: Effective Date

**Dependent**  In a benefit plan, a person with a proven relationship to the primary participant whom the participant designates to receive coverage based on the terms of the plan.

**Deployment Factors**  See: Work Choices
Derived Factor  A factor (such as age, percent of fulltime employment, length of service, compensation level, or the number of hours worked per period) that is used in calculations to determine Participation Eligibility or Activity Rates for one or more benefits.

Descriptive Flexfield  A field that your organization can configure to capture additional information required by your business but not otherwise tracked by Oracle Applications. See also: Key Flexfield

Developer Descriptive Flexfield  A flexfield defined by your localization team to meet the specific legislative and reporting needs of your country. See also: Extra Information Types

Direct Deposit  The electronic transfer of an employee’s net pay directly into the account(s) designated by the employee.

Distribution  Monetary payments made from, or hours off from work as allowed by, a compensation or benefits plan.

Effective Date  The date for which you are entering and viewing information. You set your effective date in the Alter Effective Date window. See also: DateTrack

EIT  See: Extra Information Type

Electability  The process which determines whether a potential benefits participant, who has satisfied the eligibility rules governing a program, plan, or option in a plan, is able to elect benefits. Participants who are eligible for benefits do not always have electable benefit choices based on the rules established in a benefit plan design.

Elements  Components in the calculation of employee pay. Each element represents a compensation or benefit type, such as salary, wages, stock purchase plans, and pension contributions.

Element Classifications  These control the order in which elements are processed and the balances they feed. Primary element classifications and some secondary classifications are predefined by Oracle Payroll. Other secondary classifications can be created by users.

Element Entry  The record controlling an employee’s receipt of an element, including the period of time for which the employee receives the element and its value. See also: Recurring Elements, Nonrecurring Elements

Element Link  The association of an element to one or more components of an employee assignment. The link establishes employee eligibility for that element. Employees whose assignment components match the components of the link are eligible for the element. See also: Standard Link

Element Set  A group of elements that you define to process in a payroll run, or to control access to compensation information from a configured form, or for distributing costs.

Eligibility  The process by which a potential benefits participant satisfies the rules governing whether a person can ever enroll in a program, plan, or option in a plan. A participant who is eligible for benefits must also satisfy electability requirements.
Employee Histories  An SSHR function for an employee to view their, Training History, Job Application History, Employment History, Absence History, or Salary History. A manager can also use this function to view information on their direct reports.


Employment Insurance (EI)  Benefit plan run by the federal government to which the majority of Canadian employers and employees must contribute.

Employment Insurance Rate  In Canada, this is the rate at which the employer contributes to the EI fund. The rate is expressed as a percentage of the employee’s contribution. If the employer maintains an approved wage loss replacement program, they can reduce their share of EI premiums by obtaining a reduced contribution rate. Employers would remit payroll deductions under a different employer account number for employees covered by the plan.

Employment Equity Occupational Groups (EEOG)  In Canada, the Employment Equity Occupational Groups (EEOG) consist of 14 classifications of work used in the Employment Equity Report. The EEOGs were derived from the National Occupational Classification system.

Enroll in a Class  An SSHR function which enables an employee to search and enroll in an internally published class. An employee can also use this function to maintain their competencies.

Enrollment Action Type  Any action required to complete enrollment or de-enrollment in a benefit.

Entitlement  In Australia, this is all unused leave from the previous year that remains to the credit of the employee.

ESS  Employee Self Service. A predefined SSHR responsibility.

Event  An activity such as a training day, review, or meeting, for employees or applicants.

Expected Week of Confinement (EWC)  In the UK, this is the week in which an employee’s baby is due. The Sunday of the expected week of confinement is used in the calculations for Statutory Maternity Pay (SMP).

Extra Information Type (EIT)  A type of developer descriptive flexfield that enables you to create an unlimited number of information types for six key areas in Oracle HRMS. Localization teams may also predefine some EITs to meet the specific legislative requirements of your country. See also: Developer Descriptive Flexfield

Field  A view or entry area in a window where you enter, view, update, or delete information. See also: Block, Region

Flex Credit  A unit of “purchasing power” in a flexible benefits program. An employee uses flex credits, typically expressed in monetary terms, to “purchase” benefits plans and/or levels of coverage within these plans.
**Flexible Benefits Program**  A benefits program that offers employees choices among benefits plans and/or levels of coverage. Typically, employees are given a certain amount of flex credits or moneys with which to "purchase" these benefits plans and/or coverage levels.

**Flexible Spending Account (FSA)** Under US Internal Revenue Code Section 125, employees can set aside money on a pretax basis to pay for eligible unreimbursed health and dependent care expenses. Annual monetary limits and use–it–or–lose it provisions exist. Accounts are subject to annual maximums and forfeiture rules.

**Form**  A predefined grouping of functions, called from a menu and displayed, if necessary, on several windows. Forms have blocks, regions and fields as their components. See also: *Block, Region, Field*

G

**Global Value**  A value you define for any formula to use. Global values can be dates, numbers or text.

**Goods or Service Type**  A list of goods or services a benefit plan sponsor has approved for reimbursement.

**Grade**  A component of an employee’s assignment that defines their level and can be used to control the value of their salary and other compensation elements.

**Grade Comparison**  A comparison of the amount of compensation an employee receives with the mid-point of the valid values defined for his or her grade.

**Grade Rate**  A value or range of values defined as valid for a given grade. Used for validating employee compensation entries.

**Grade Scale**  A sequence of steps valid for a grade, where each step corresponds to one point on a pay scale. You can place each employee on a point of their grade scale and automatically increment all placements each year, or as required. See also: *Pay Scale*

**Grade Step**  An increment on a grade scale. Each grade step corresponds to one point on a pay scale. See also: *Grade Scale*

**Grandfathered**  A term used in Benefits Administration. A person’s benefits are said to be grandfathered when a plan changes but they retain the benefits accrued.

**Group**  A component that you define, using the People Group key flexfield, to assign employees to special groups such as pension plans or unions. You can use groups to determine employees’ eligibility for certain elements, and to regulate access to payrolls.

**Group Certificate**  In Australia, this is a statement from a legal employer showing employment income of an employee for the financial year.

H

**Hierarchy**  An organization or position structure showing reporting lines or other relationships. You can use hierarchies for reporting and for controlling access to Oracle HRMS information.
**Imputed Income**  Certain forms of indirect compensation that US Internal Revenue Service Section 79 defines as fringe benefits and taxes the recipient accordingly. Examples include employer payment of group term life insurance premiums over a certain monetary amount, personal use of a company car, and other non-cash awards.

**Initiator**  In SSHR a person who starts a 360 Degree appraisal (Employee or Self) on an individual. An initiator and the appraisee are the only people who can see all appraisal information.

**Input Values**  Values you define to hold information about elements. In Oracle Payroll, input values are processed by formulas to calculate the element’s run result. You can define up to fifteen input values for an element.

**Instructions**  An SSHR user assistance component displayed on a web page to describe page functionality.

**Key Flexfield**  A flexible data field made up of segments. Each segment has a name you define and a set of valid values you specify. Used as the key to uniquely identify an entity, such as jobs, positions, grades, cost codes, and employee groups. See also: Descriptive Flexfield

**Leave Loading**  In Australia, an additional percentage amount of the annual leave paid that is paid to the employee.

**Leaver’s Statement**  In the UK, this Records details of Statutory Sick Pay (SSP) paid during a previous employment (issued as form SSP1L) which is used to calculate a new employee’s entitlement to SSP. If a new employee falls sick, and the last date that SSP was paid for under the previous employment is less than eight calendar weeks before the first day of the PIW for the current sickness, the maximum liability for SSP is reduced by the number of weeks of SSP shown on the statement.

**Legal Employer**  A business in Australia that employs people and has registered with the Australian Tax Office as a Group Employer.

**Life Event**  A significant change in a person’s life that results in a change in eligibility or ineligibility for a benefit.

**Life Event Collision**  A situation in which the impacts from multiple life events on participation eligibility, enrollability, level of coverage or activity rates conflict with each other.

**Life Event Enrollment**  A benefits plan enrollment that is prompted by a life event occurring at any time during the plan year.

**Linking Interval**  In the UK, this is the number of days that separate two periods of incapacity for work. If a period of incapacity for work (PIW) is separated from a previous PIW by less than the linking interval, they are treated as one PIW according to the legislation for entitlement to Statutory Sick Pay (SSP). An employee can only receive SSP for the maximum number of weeks defined in the legislation for one PIW.
**Linked PIWs** In the UK, these are linked periods of incapacity for work that are treated as one to calculate an employee’s entitlement to Statutory Sick Pay (SSP). A period of incapacity for work (PIW) links to an earlier PIW if it is separated by less than the linking interval. A linked PIW can be up to three years long.

**LMSS** Line Manager Self Service. A predefined S SHR responsibility.

**Long Service Leave** Leave with pay granted to employees of a particular employer after a prescribed period of service or employment with that employer.

**Lookup Types** Categories of information, such as nationality, address type and tax type, that have a limited list of valid values. You can define your own Lookup Types, and you can add values to some predefined Lookup Types.

**Lower Earnings Limit (LEL)** In the UK, this is the minimum average weekly amount an employee must earn to pay National Insurance contributions. Employees who do not earn enough to pay National Insurance cannot receive Statutory Sick Pay (SSP) or Statutory Maternity Pay (SMP).

**Maternity Pay Period** In the UK, this is the period for which Statutory Maternity Pay (SMP) is paid. It may start at any time from the start of the 11th week before the expected week of confinement and can continue for up to 18 weeks. The start date is usually agreed with the employee, but can start at any time up to the birth. An employee is not eligible to SMP for any week in which she works or for any other reason for ineligibility, defined by the legislation for SMP.

**Menus** You set up your own navigation menus, to suit the needs of different users.

**Medicare Levy** An amount payable by most taxpayers in Australia to cover some of the cost of the public health system.

**N**

**NACHA** National Automated Clearing House Association. This is the US system for making direct deposit payments to employees.

**National Identifier** This is the alphanumeric code that is used to uniquely identify a person within their country. It is often used for taxation purposes. For example, in the US it is the Social Security Number, in Italy it is the Fiscal Code, and in New Zealand it is the IRD Number.

---

**Manager–Employee Appraisal** Part of the S SHR Appraisal function. A manager appraisal of an employee. However, an appraising manager does not have to be a manager.
National Occupational Classification (NOC) code In Canada, the National Occupational Classification (NOC) System was developed to best reflect the type of work performed by employees. Occupations are grouped in terms of particular tasks, duties and responsibilities. The use of this standardized system ensures consistency of data from year to year within the same company as well as between companies. These codes are used in the Employment Equity Report.

Net Accrual Calculation The rule that defines which element entries add to or subtract from a plan’s accrual amount to give net entitlement.

Net Entitlement The amount of unused paid time off an employee has available in an accrual plan at any given point in time.

Nonrecurring Elements Elements that process for one payroll period only unless you make a new entry for an employee. See also: Recurring Elements

North American Industrial Classification (NAIC) code The North American Industrial Classification system (NAICs) was developed jointly by the US, Canada and Mexico to provide comparability in statistics regarding business activity across North America. The NAIC replaces the US Standard Industrial Classification (SIC) system, and is used in the Employment Equity Report.

Not in Program Plan A benefit plan that you define outside of a program.

Open Enrollment A type of scheduled enrollment in which participants can enroll in or alter elections in one or more benefits plans.

Oracle FastFormula An Oracle tool that allows you to write Oracle HRMS formulas without using a programming language.

Organization A required component of employee assignments. You can define as many organizations as you want within your Business Group. Organizations can be internal, such as departments, or external, such as recruitment agencies. You can structure your organizations into organizational hierarchies for reporting purposes and for system access control.

OSSWA Oracle Self Service Web Applications.

OTM Oracle Training Management.

P

Pattern A pattern comprises a sequence of time units that are repeated at a specified frequency. Oracle SSP/SMP uses SSP qualifying patterns to determine employees entitlement to Statutory Sick Pay (SSP).

Pattern Time Units A sequence of time units specifies a repeating pattern. Each time unit specifies a time period of hours, days or weeks.

Pay Scale A set of progression points that can be related to one or more rates of pay. Employee’s are placed on a particular point on the scale according to their grade and, usually, work experience. See also: Grade Scale

Payment Type There are three standard payment types for paying employees: check, cash and direct deposit. You can define your own payment methods corresponding to these types.
**Payroll** A group of employees that Oracle Payroll processes together with the same processing frequency, for example, weekly, monthly or bi-monthly. Within a Business Group, you can set up as many payrolls as you need.

**People List** An SSHR line manager utility used to locate an employee.

**Performance (within Assessment)** An expectation of “normal” performance of a competence over a given period. For example, a person may exceed performance expectation in the communication competence. See also: Proficiency (within Assessment), Competence, Assessment

**Period of Incapacity for Work (PIW)** In the UK, this is a period of sickness that lasts four or more days in a row, and is the minimum amount of sickness for which Statutory Sick Pay can be paid. If a PIW is separated by less then the linking interval, a linked PIW is formed and the two PIWs are treated as one.

**Period Type** A time division in a budgetary calendar, such as week, month, or quarter.

**Person Search** An SSHR function which enables a manager to search for a person. There are two types of search, Simple and Advanced.

**Person Type** There are eight system person types in Oracle HRMS. Seven of these are combinations of employees, ex-employees, applicants, and ex-applicants. The eighth category is ‘External’. You can create your own user person types based on the eight system types.

**Personal Public Service Number (PPS)** The Irish equivalent to National Insurance number in the UK, or the Social Security number in the US.

**Personal Tax Credits Return (TD1)** A Revenue Canada form which each employee must complete. Used by the employee to reduce his or her taxable income at source by claiming eligible credits and also provides payroll with such important information as current address, birth date, and SIN. These credits determine the amount to withhold from the employee’s wages for federal/provincial taxes.

**Plan Design** The functional area that allows you to set up your benefits programs and plans. This process involves defining the rules which govern eligibility, available options, pricing, plan years, third party administrators, tax impacts, plan assets, distribution options, required reporting, and communications.

**Plan Sponsor** The legal entity or business responsible for funding and administering a benefits plan. Generally synonymous with employer.

**Position** A specific role within the Business Group derived from an organization and a job. For example, you may have a position of Shipping Clerk associated with the organization Shipping and the job Clerk.

**Predefined Components** Some elements and balances, all primary element classifications and some secondary classifications are defined by Oracle Payroll to meet legislative requirements, and are supplied to users with the product. You cannot delete these predefined components.

**Professional Information** An SSHR function which allows an employee to maintain their own professional details or a line manager to maintain their direct reports professional details.
Glossary

Proficiency (within Assessment) The perceived level of expertise of a person in a competence, in the opinion of the assessor, over a given period. For example, a person may demonstrate the communication competence at Expert level. See also: Performance (within Assessment), Competence, Assessment

Proficiency Level A system for expressing and measuring how a competence is exhibited in the work context. See also: Behavioral Indicators.

Progression Point A pay scale is calibrated in progression points, which form a sequence for the progression of employees up the pay scale. See also: Pay Scale.

Provincial/Territorial Employment Standards Acts In Canada, these are laws covering minimum wages, hours of work, overtime, child labour, maternity, vacation, public/general holidays, parental and adoption leave, etc., for employees regulated by provincial/territorial legislation.

Provincial Health Number In Canada, this is the account number of the provincially administered health care plan that the employer would use to make remittances. There would be a unique number for each of the provincially controlled plans i.e. EHT, Quebec HSF, etc.

PTO Accrual Plan A benefit in which employees enroll to entitle them to accrue and take paid time off. The purpose of absences allowed under the plan, who can enroll, how much time accrues, when the time must be used, and other rules are defined for the plan.

Q

QPP (See Canada/Quebec Pension Plan)

Qualification Type An identified qualification method of achieving proficiency in a competence, such as an award, educational qualification, a license or a test. See also: Competence.

Qualifying Days In the UK, these are days on which Statutory Sick Pay (SSP) can be paid, and the only days that count as waiting days. Qualifying days are normally work days, but other days may be agreed.

Qualifying Pattern See: SSP Qualifying Pattern.

Qualifying Week In the UK, this is the week during pregnancy that is used as the basis for the qualifying rules for Statutory Maternity Pay (SMP). The date of the qualifying week is fifteen weeks before the expected week of confinement and an employee must have been continuously employed for at least 26 weeks continuing into the qualifying week to be entitled to SMP.

Quebec Business Number In Canada, this is the employer’s account number with the Ministere du Revenu du Quebec, also known as the Quebec Identification number. It consists of 15 digits, the first 9 identify the employer, the next 2 identify the type of tax account involved (payroll vs. corporate tax), and the last 4 identify the particular account for that tax.

Questionnaire An SSHR function which records the results of an appraisal.
QuickPaint Report A method of reporting on employee and applicant assignment information. You can select items of information, paint them on a report layout, add explanatory text, and save the report definition to run whenever you want. See also: Assignment Set

R

Rates A set of values for employee grades or progression points. For example, you can define salary rates and overtime rates.

Rating Scale Used to describe an enterprise’s competencies in a general way. You do not hold the proficiency level at the competence level. See also: Proficiency Level

Record of Employment (ROE) A Human Resources Development Canada form that must be completed by an employer whenever an interruption of earnings occurs for any employee. This form is necessary to claim Employment Insurance benefits.

Recruitment Activity An event or program to attract applications for employment. Newspaper advertisements, career fairs and recruitment evenings are all examples of recruitment activities. You can group several recruitment activities together within an overall activity.

Recurring Elements Elements that process regularly at a predefined frequency. Recurring element entries exist from the time you create them until you delete them, or the employee ceases to be eligible for the element. Recurring elements can have standard links. See also: Nonrecurring Elements, Standard Link

Region A collection of logically related fields in a window, set apart from other fields by a rectangular box or a horizontal line across the window. See also: Block, Field

Registered Pension Plan (RPP) This is a pension plan that has been registered with Revenue Canada. It is a plan where funds are set aside by an employer, an employee, or both to provide a pension to employees when they retire. Employee contributions are generally exempt from tax.

Registered Retirement Savings Plan (RRSP) This is an individual retirement savings plan that has been registered with Revenue Canada. Usually, contributions to the RRSP, and any income earned within the RRSP, is exempt from tax.

Report Parameters Inputs you make when submitting a report to control the sorting, formatting, selection, and summarizing of information in the report.

Report Set A group of reports and concurrent processes that you specify to run together.

Requisition The statement of a requirement for a vacancy or group of vacancies.

Request Groups A list of reports and processes that can be submitted by holders of a particular responsibility. See also: Responsibility

Residual The amount of unused paid time off entitlement an employee loses at the end of an accrual term. Typically employees can carry over unused time, up to a maximum, but they lose any residual time that exceeds this limit. See also: Carry Over
Responsibility  A level of authority in an application. Each responsibility lets you access a specific set of Oracle Applications forms, menus, reports, and data to fulfill your business role. Several users can share a responsibility, and a single user can have multiple responsibilities. See also: Security Profile, User Profile Options, Request Groups, Security Groups.

Retry  Method of correcting a payroll run or other process before any post-run processing takes place. The original run results are deleted and the process is run again.

Revenue Canada  Department of the Government of Canada which, amongst other responsibilities, administers, adjudicates, and receives remittances for all taxation in Canada including income tax, Employment Insurance premiums, Canada Pension Plan contributions, and the Goods and Services Tax (legislation is currently proposed to revise the name to the Canada Customs and Revenue Agency). In the province of Quebec the equivalent is the Ministere du Revenu du Quebec.

Reviewer (SSHR)  A person invited by an appraising manager to add review comments to an appraisal.

Reversal  Method of correcting payroll runs or QuickPay runs after post-run processing has taken place. The system replaces positive run result values with negative ones, and negative run result values with positive ones. Both old and new values remain on the database.

Rollback  Method of removing a payroll run or other process before any post-run processing takes place. All assignments and run results are deleted.

S

Search by Date  An SSHR sub-function used to search for a Person by Hire date, Application date, Job posting date or search by a Training event date.

Salary Basis  The period of time for which an employee’s salary is quoted, such as hourly or annually. Defines a group of employees assigned to the same salary basis and receiving the same salary element.

Scheduled Enrollment  A benefits plan enrollment that takes place during a predefined enrollment period, such as an open enrollment. Scheduled enrollments can be administrative, open, or unrestricted.

Security Group  Security groups enable HRMS users to partition data by Business Group. Only used for Security Groups Enabled security. See also: Responsibility, Security Profile, User Profile Options.

Security Groups Enabled  Formerly known as Cross Business Group Responsibility security. This security model uses security groups and enables you to link one responsibility to many Business Groups.

Security Profile  Security profiles control access to organizations, positions and employee and applicant records within the Business Group. System administrators use them in defining users’ responsibilities. See also: Responsibility.

Self Appraisal  Part of the SSHR Appraisal function. This is an appraisal undertaken by an employee to rate their own performance and competencies.

SMP  See: Statutory Maternity Pay
Social Insurance Number (SIN) A unique number provided by Human Resources Development Canada (HRDC) to each person commencing employment in Canada. The number consists of 9 digits in the following format (###–###–###).

Source Deductions Return (TP 1015.3) A Ministere du Revenu du Quebec form which each employee must complete. This form is used by the employee to reduce his or her taxable income at source by claiming eligible credits and also provides payroll with such important information as current address, birth date, and SIN. These credits determine the amount of provincial tax to withhold from the employee’s wages.

Special Information Types Categories of personal information, such as skills, that you define in the Personal Analysis key flexfield.

SSHR Oracle Self-Service Human Resources. An HR management system using an intranet and web browser to deliver functionality to employees and their managers.

SSP See: Statutory Sick Pay

SSP Qualifying Pattern In the UK, an SSP qualifying pattern is a series of qualifying days that may be repeated weekly, monthly or some other frequency. Each week in a pattern must include at least one qualifying day. Qualifying days are the only days for which Statutory Sick Pay (SSP) can be paid, and you define SSP qualifying patterns for all the employees in your organization so that their entitlement to SSP can be calculated.

Standard Link Recurring elements with standard links have their element entries automatically created for all employees whose assignment components match the link. See also: Element Link, Recurring Elements

Statement of Commissions and Expenses for Source Deduction Purposes (TP 1015.R.13.1) A Ministere du Revenu du Quebec form which allows an employee who is paid partly or entirely by commissions to pay a constant percentage of income tax based on his or her estimated commissions for the year, less allowable business expenses.

Statement of Remuneration and Expenses (TD1X) In Canada, the Statement of Remuneration and Expenses allows an employee who is paid partly or entirely by commission to pay a constant percentage of income tax, based on his or her estimated income for the year, less business-related expenses.

Statutory Maternity Pay In the UK, you pay Statutory Maternity Pay (SMP) to female employees who take time off work to have a baby, providing they meet the statutory requirements set out in the legislation for SMP.

Standard HRMS Security The standard security model. Using this security model you must log on as a different user to see a different Business Group.
**Statutory Sick Pay**  In the UK, you pay Statutory Sick Pay (SSP) to employees who are off work for four or more days because they are sick, providing they meet the statutory requirements set out in the legislation for SSP.

**Succession Planning**  An SSHR function which enables a manager to prepare a succession plan.

**Suitability Matching**  An SSHR function which enables a manager to compare and rank a persons competencies.

**Superannuation Guarantee**  An Australian system whereby employers are required to contribute a percentage of an eligible employee’s earnings to a superannuation fund to provide for their retirement.

**Tips**  An SSHR user assistance component that provides information about a field.

**U**

**User Assistance Components**  SSHR online help comprising tips and instructions.

**User Balances**  Users can create, update and delete their own balances, including dimensions and balance feeds. See also: Balances

**User Profile Options**  Features that allow system administrators and users to tailor Oracle HRMS to their exact requirements. See also: Responsibility, Security Profile

**V**

**Viewer (SSHR)**  A person with view only access to an appraisal. An appraising manager or an employee in a 360 Degree Self appraisal can appoint view only access to an appraisal.

**W**

**WCB Account Number**  In Canada, this is the account number of the provincially administered Worker’s Compensation Board that the employer would use to make remittances. There would be a unique number for each of the provincially controlled boards i.e. Workplace Safety & Insurance Board of Ontario, CSST, etc.
Waiting Days In the UK, statutory Sick Pay is not payable for the first three qualifying days in period of incapacity for work (PIW), which are called waiting days. They are not necessarily the same as the first three days of sickness, as waiting days can be carried forward from a previous PIW if the linking interval between the two PIWs is less than 56 days.

Work Choices Also known as Work Preferences, Deployment Factors, or Work Factors. These can affect a person’s capacity to be deployed within an enterprise, such willingness to travel or relocate. You can hold work choices at both job and position level, or at person level.

Worker’s Compensation Board In Canada, this is a provincially governed legislative body which provides benefits to employees upon injury, disability, or death while performing the duties of the employer. Worker’s Compensation Board premiums are paid entirely by the employer.

Workflow An Oracle application which uses charts to manage approval processes and in addition is used in SSHR to configure display values of sections within a web page and instructions.

Work Structures The fundamental definitions of organizations, jobs, positions, grades, payrolls and other employee groups within your enterprise that provide the framework for defining the work assignments of your employees.
Index

A
Address styles, 1–20
APIs, 1–78
Application Data Export, downloading information to spreadsheets, 5–5
Assignment sets
creating, 5–16
defining, 5–17 to 5–21
Attachments
attaching comments or objects to records, 5–7
Oracle HRMS entities that support, 5–7
Audit groups, 4–8
AuditTrail, 4–2
custom reports, 4–6
disabling, 4–10
information reports, 4–4
overview, 4–3
predefined report, 4–11
setting up audit groups, 4–8
Update Datetracked Tables process, 4–8

B
Bank account information, 1–26
Base currency, 2–121
Budget worksheets, routing, 2–100, 2–115
Business Groups
enabling one responsibility for many Business Groups, 3–33
ways of linking to responsibilities, 3–32
Business rules, position control, 2–118

C
Checklists, 2–89
Comments, attaching to records, 5–7
Concurrent managers, 5–12
Configuring
menu structures, 3–34 to 3–36
QuickPaint Report window, 5–6
Configuring windows
HR_CUSTOMIZATION parameter, 3–62
list of windows, 2–35
overview, 2–34 to 2–38
types of data restrictions, 2–37
using CustomForm, 2–39
Confirmation letters, OTA SQL*Plus script, 6–13
Context, mass actions, defining, 3–64
Country–specific requirements
address styles, 1–20
predefined developer flexfields, 1–24
Currencies, enabling, 2–121
CUSTOM library events, 1–76
Custom Reports, 5–21
Custom security restrictions, 3–30
CustomForm, 2–39

D
Database items, in QuickPaint reports, 5–13
Descriptive flexfields, 1–5
creating database items, 1–19
defining segments of, 1–12 to 1–14
enabling users to add fields to windows, 1–12
for address styles, 1–20
list of user definable, 1–14 to 1–17
Developer descriptive flexfields, 1–24 to 1–26
Developer key flexfields, 1–24 to 1–26
Distribution sets, 2–42

E
Element sets, 2–42
Events, 1–76
Extra Information types, 1–5
entering, 1–42
tag column, 1–50
optional components of a responsibility, 3–33
security, 1–29
setting up, 1–36
setting up for an organization classification, 1–39
setting up responsibilities, 1–41

F
Find window configuration, 2–50
Folders, description of, 5–4 to 5–6
Form functions, defining parameters for different form types, 3–62
Forms Configurator, 2–43, 2–81

G
Group Term Life premiums, predefined table for, 1–45

I
Information access overview, 5–4
Inquiry windows, list of, 5–9

K
Key flexfield setup, 1–6 to 1–10
creating database items, 1–11
Key flexfields, 1–5
Bank Details, 1–26
Cost Allocation, 1–9
Grade Name, 1–7
Job Name, 1–8
People Group, 1–8
Personal Analysis, 1–9
Position Name, 1–7
Soft Coded Legislation, 1–26

L
Letter generation
ADE and concurrent processing compared, 6–3
confirmation letters, OTA SQL*Plus script, 6–13
linking a report with a letter, 6–29
PERPWOUK template, 6–7
PERWPWUK template, 6–11
requesting letters, 6–25
skeleton letters, 6–24
standard letter overview, 6–2 to 6–6
using Oracle Reports, 6–4
using SQL*Plus script, 6–20 to 6–24
using word processors, 6–4
writing and registering a report, 6–28
LISTGEN, 3–42
Lookup Types, 1–72
Lookup types, Tag column, 1–50
Lookups
access levels, 1–50
defining new lookup types, 1–73 to 1–75
defining new lookup values, 1–73 to 1–75
global and local types, 1–51
list of user and extensible types, 1–52 to 1–71
overview, 1–50 to 1–52
removing lookup values, 1–75
M
Mail merge, 6–2 to 6–6, 6–27
Mass actions, defining a context, 3–64
Menu Structures report, 3–58
Menus
default menu paths, A–2
defining, 3–34 to 3–35, 3–60
defining functions, 3–59
for security, 3–33, 3–34
query–only access, 3–25

N
National address styles, changing default styles, 1–22

O
Oracle HRMS, using with spreadsheets, 5–5 to 5–6
ORACLE IDs, 3–57
Organization hierarchies, in security profiles, 3–43
OTA, SQL*Plus script, 6–13 to 6–16

P
Payroll tables, row types for, 1–44
Payrolls, in security profiles, 3–29
People Management form fields, 2–66
People Management templates, 2–45 to 2–50
predefined, 2–49
SITs, EITs, and flexfields, 2–52
PERWPOUK, SQL*Plus script, 6–7 to 6–10
PERWPWUK, SQL*Plus script, 6–11 to 6–14
Position
transactions, routing, 2–115
workflow routing for transactions, about, 2–100
Position control, business rules, configuring, 2–118
Position hierarchies, in security profiles, 3–44
Predefined user tables, 1–45
Company Work Schedules, 1–45
GTL Premiums, 1–45
Shift Differentials, 1–45
Wage Rates, 1–46
Process log
transaction errors, 5–11
using, 5–11
Process security, 3–36
Processes
Create Descriptive Flexfield DB Items, 1–19
Create Key Flexfield DB Items, 1–11

Q
Query–only access to windows, 3–25
QuickPaint reports, 5–6
configuring, 5–6
defining, 5–13 to 5–14
running, 5–15

R
Report security, 3–36
Reporting users, 3–40
setting up, 3–57
Reports
defining, 5–4, 5–12
list of, 5–12 to 5–14
Menu Structure, 3–58
QuickPaint, 5–13 to 5–14
Request groups, 3–33, 3–36
Responsibilities, 3–32, 3–34
defining, 3–46, 3–49
Restricting access to records
by menu structures, 3–34
by organization hierarchy, 3–43
by payroll, 3–29
by position hierarchy, 3–44
by responsibilities, 3–32 to 3–33
by security profiles, 3–29
by supervisor, 3–30
custom restrictions, 3–30
from other tools, 3–40
Index – 4

Configuring, Reporting and System Administration in Oracle HRMS

ROLEGEN, 3–42
Roles, 3–32
workflow transaction, defining, 2–106
workflow transaction, editing, 2–110
workflow, associating to positions, 2–108
workflow, associating to templates, 2–109
workflow, associating to users, 2–107
Routing lists, defining, 2–113

S

SECGEN, 3–41
Security
creating Oracle IDs, 3–57
enabling currencies, 2–121
extra information types, 3–33
Find Security Profile Assignment window, 3–56
of reports and processes, 3–33, 3–36
overview, 3–4
responsibilities, 3–32
running HR security processes, 3–41
setting user profile options, 3–15
using menus, 3–58 to 3–63
Security groups, 3–37
Security Groups Enabled Security, setting up, 3–48
Security models, 3–7
Security processes
Enable Multiple Security Groups, 3–41
Generate Secure User (SECGEN), 3–41
Grant Permissions To Roles (ROLEGEN), 3–42
Security List Maintenance (LISTGEN), 3–42
Security profiles, 3–29 to 3–30, 3–33
assigning, 3–54
defining, 3–50 to 3–53
Shift differentials, predefined table for, 1–45
Soft coded legislation, 1–26
Spreadsheets, using with ADE, 5–5 to 5–6
SQL*Plus script
OTA—for confirmation letters, 6–13 to 6–16
PERWPOUK, 6–7 to 6–10
PERWPWUK, 6–11 to 6–14
Standard HRMS security, setting up, 3–46
Standard letters, 6–2
Supervisor hierarchies, in security profiles, 3–30

T

Tables, user–defined, 1–43, 1–44
accessing values in, 1–43, 1–44
entering values into, 1–49
payroll tables for deduction amounts, 1–44
setting up, 1–47 to 1–48
Task flows, 2–7 to 2–9
adding a new form/node, 2–19
adding to a menu, 3–62
amending the navigation, 2–20
button labels, 2–27
copying an existing task flow, 2–18
creating a sub process, 2–26
creating a top level process, 2–24
creating using forms, 2–14
creating using Oracle Workflow, 2–23
defining nodes, 2–15
defining task flows, 2–16
Oracle Workflow, 2–21
transferring between databases, 2–33
using windows, 2–10
verifying and saving, 2–31
WORKFLOW_NAME parameter, 3–62
Templates
adding and removing fields, 2–87
context-sensitive fields, 2–55, 2–92
defining checklists, 2–89
ingoing, 2–85
field datetrack history, 2–93
importing, 2–84
increasing field information, 2–94
online help targets, 2–56
opening and copying, 2–83
options, 2–59 to 2–66
People Management, 2–45 to 2–50
PERWPOUK, 6–7 to 6–10
PERWPWUK, 6–11 to 6–14
setting field defaults, 2–91
SITs, EITs, and flexfields, 2–52
transaction, about, 2–95
transaction, defining, 2–98
Transaction
errors reported in log, 5–11
templates, defining, 2–98
workflow roles, associating to positions, 2–108
workflow roles, associating to templates, 2–109
workflow roles, associating to users, 2–107
Transaction type wizard, 2–104
Transactions, templates, about, 2–95

U
User profile options, 3–49
overview, 3–15 to 3–17
profile options listing, 3–16 to 3–28
User tables, 1–43, 1–44
Users, creating, 3–47, 3–49

V
Views, list of, 5–9

W
Wage rates, predefined table for, 1–46
Windows
Application Utilities Lookups, 1–73, 1–75
Assignment Criteria, 5–17
Assignment Set, 5–17, 5–20
Columns, 1–47
Configurable Business Rules, 2–118
configurable windows list, 2–35
Context, 3–64
default navigation paths, A–17
Define Task Flow, 2–16
Define Task Flow Nodes, 2–15
Element and Distribution Set, 2–42
Extra Information, 1–42
Find Security Profile Assignment, 3–56
Form Customization, 2–40
Grade Rate, 3–62
Information Type Security, 1–41
Letter, 6–23
Maintain Roles, 2–106
Menu, 3–58
Personal Profile Values, 3–16
Process Log, 5–11
QuickPaint Inquiry, 5–15
QuickPaint Report, 5–13
Request Letter, 6–25
Routing, 2–115
Routing lists, 2–113
Rows, 1–47
Scale Rate, 3–62
Security Profile, 3–50
Submit Requests, 5–12
System Profile Values, 3–15
Table Structure, 1–47
Table Values, 1–49
Templates, 2–98
View Requests, 5–12
Word processors, supported makes for letter generation, 6–4 to 6–6
Work schedules, predefined table for, 1–45
Workflow
position and budget transactions, about, 2–100
roles, defining, 2–106
roles, editing, 2–110
transaction routing, 2–115
transaction routing lists, defining, 2–113