Contents

Preface ................. Preface ix
   Audience for This Guide ........................................ x
   How To Use This Guide .......................................... x
   Finding Out What’s New ........................................ xi
   Other Information Sources ..................................... xi
      Online Documentation ...................................... xii
      Related User Guides ....................................... xii
      User Guides Related to All Products ................... xiii
      User Guides Related to This Product ................... xiv
   Do Not Use Database Tools to Modify Oracle Applications  xviii
   About Oracle ...................................................... xix
   Your Feedback ...................................................... xix

Chapter 1

Extend and Customize Oracle HRMS ............................. 1 – 1
   Extend and Customize Oracle HRMS .......................... 1 – 2
      Can you link associated windows together? ............ 1 – 2
      How can you hold additional information? ............... 1 – 2
      How can you ensure the same terminology is used and
      speed up data entry? ........................................... 1 – 2
      Can you define the formats for currency? ................. 1 – 2
   Extend and Customize Oracle HRMS Overview ............ 1 – 3
   Key Components .................................................. 1 – 3
   Task Flow .......................................................... 1 – 5
   Using Forms or Workflow ........................................ 1 – 5
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequential or Branched Structure</td>
<td>1–5</td>
</tr>
<tr>
<td>Predefined Task Flows</td>
<td>1–5</td>
</tr>
<tr>
<td>Task Flow Windows</td>
<td>1–7</td>
</tr>
<tr>
<td>Including the Assignment Window</td>
<td>1–9</td>
</tr>
<tr>
<td>Task Flow (Oracle Workflow)</td>
<td>1–11</td>
</tr>
<tr>
<td>Key Rules</td>
<td>1–11</td>
</tr>
<tr>
<td>Windows You Can Customize</td>
<td>1–13</td>
</tr>
<tr>
<td>List of Customizable Windows</td>
<td>1–13</td>
</tr>
<tr>
<td>Types of Data Restrictions</td>
<td>1–14</td>
</tr>
<tr>
<td>Flexfields</td>
<td>1–16</td>
</tr>
<tr>
<td>User Definable Key Flexfields</td>
<td>1–17</td>
</tr>
<tr>
<td>How Oracle HRMS Uses Key Flexfields</td>
<td>1–17</td>
</tr>
<tr>
<td>What You Must Set Up</td>
<td>1–18</td>
</tr>
<tr>
<td>User Definable Descriptive Flexfields</td>
<td>1–20</td>
</tr>
<tr>
<td>Segments</td>
<td>1–20</td>
</tr>
<tr>
<td>Types of Descriptive Flexfield</td>
<td>1–20</td>
</tr>
<tr>
<td>Descriptive Flexfield List</td>
<td>1–22</td>
</tr>
<tr>
<td>Descriptive Flexfields and Address Styles</td>
<td>1–25</td>
</tr>
<tr>
<td>Address Styles</td>
<td>1–25</td>
</tr>
<tr>
<td>Extra Information Types (EITs)</td>
<td>1–26</td>
</tr>
<tr>
<td>Key Flexfield Combinations</td>
<td>1–26</td>
</tr>
<tr>
<td>Dates and EITs</td>
<td>1–27</td>
</tr>
<tr>
<td>EITs and Security</td>
<td>1–28</td>
</tr>
<tr>
<td>Restricting Access to Extra Information</td>
<td>1–28</td>
</tr>
<tr>
<td>Developer Flexfields</td>
<td>1–29</td>
</tr>
<tr>
<td>Soft Coded Legislation Key Flexfield</td>
<td>1–30</td>
</tr>
<tr>
<td>Bank Details Key Flexfield</td>
<td>1–30</td>
</tr>
<tr>
<td>User–Defined Tables</td>
<td>1–31</td>
</tr>
<tr>
<td>Entering and Accessing Table Values</td>
<td>1–31</td>
</tr>
<tr>
<td>Row Types for Payroll Tables</td>
<td>1–32</td>
</tr>
<tr>
<td>US Pre-defined User Tables</td>
<td>1–33</td>
</tr>
<tr>
<td>COMPANY WORK SCHEDULES Table</td>
<td>1–33</td>
</tr>
<tr>
<td>GTL PREMIUMS Table</td>
<td>1–33</td>
</tr>
<tr>
<td>SHIFT DIFFERENTIALS Table</td>
<td>1–33</td>
</tr>
<tr>
<td>WAGE RATES Table</td>
<td>1–34</td>
</tr>
<tr>
<td>Lookups</td>
<td>1–35</td>
</tr>
<tr>
<td>Predefined Lookup Types</td>
<td>1–35</td>
</tr>
<tr>
<td>Global and Local Lookup Types</td>
<td>1–35</td>
</tr>
<tr>
<td>User and Extensible Lookups</td>
<td>1–37</td>
</tr>
<tr>
<td>CUSTOM Library Events</td>
<td>1–52</td>
</tr>
<tr>
<td>Generic Events</td>
<td>1–52</td>
</tr>
<tr>
<td>Product Specific Events</td>
<td>1–52</td>
</tr>
</tbody>
</table>
In what ways can you use security of access for different users? ................................. 2 – 2
How does Oracle HRMS allow data restriction for display in a window? ...................... 2 – 2
How does Oracle HRMS enable users to view multiple Business Groups? ..................... 2 – 2

Security Overview ............................................................... 2 – 3
Security in your Enterprise ................................................... 2 – 3
Standard HRMS Security ..................................................... 2 – 4
Cross Business Group Responsibility Security ............................. 2 – 5
Security Components .......................................................... 2 – 6

Security Models ................................................................. 2 – 8
Standard HRMS Security ..................................................... 2 – 8
Cross Business Group Responsibility Security ............................. 2 – 8

User Profiles ................................................................. 2 – 10
Query–Only Access to Forms ................................................... 2 – 11
Profile Options Summary ..................................................... 2 – 11
Profile Options ................................................................. 2 – 13

Security Profiles ................................................................. 2 – 17
Responsibilities ................................................................. 2 – 19
Responsibility ................................................................. 2 – 19
Access Control Through Responsibility .................................. 2 – 20

Menu Structure ................................................................. 2 – 21
The Default Menu Structure ................................................... 2 – 21

Request Groups ................................................................. 2 – 23
Security Groups (Cross Business Group Responsibility Security Only) ....................... 2 – 24
Example ................................................................. 2 – 25
Categorizing Information By Security Groups ........................................... 2 – 25

Reporting Access ................................................................. 2 – 27

Security Processes ................................................................. 2 – 28
Generate Secure User Process (SECGEN) .................................... 2 – 28
Security List Maintenance Process (LISTGEN) ................................ 2 – 28
Grant Permissions To Roles Process (ROLEGEN) ............................ 2 – 29
Enable Multiple Security Groups .............................................. 2 – 29

Security Profiles by Organization and Organization Hierarchy ............................. 2 – 30
Security Profiles By Position and Position Hierarchies ......................... 2 – 31
Setting Up Standard HRMS Security ........................................ 2 – 33
Defining a Security Profile ................................................... 2 – 35
Using the Find Security Profile Assignment window .......................... 2 – 38
Assigning Security Profiles ................................................... 2 – 39
Chapter 3

AuditTrail .................................................. 3 – 1
   AuditTrail .............................................. 3 – 2
      What does AuditTrail provide? ................. 3 – 2
   AuditTrail Overview .................................. 3 – 3
      Performing AuditTrail ............................... 3 – 3
   Audit Information Reports ......................... 3 – 4
   Custom Audit Reports ............................... 3 – 6
      Dynamic SQL Structure ............................ 3 – 6
      HR Audit Tables .................................... 3 – 6
   Setting Up AuditTrail ................................ 3 – 8
   Disabling AuditTrail .................................. 3 – 9
   Running the Predefined Audit Report ............. 3 – 10

Chapter 4

Information Access ................................. 4 – 1
   Information Access ................................ 4 – 2
      Does Oracle HRMS provide flexible access to
      information? ....................................... 4 – 2
      How can you use Oracle HRMS to support typical hr
      activities? ......................................... 4 – 2
      What range of reporting options are available in Oracle
      HRMS? ............................................... 4 – 2
      Can you pose “what-if” scenarios? .............. 4 – 2
      Can you use Oracle HRMS information for strategic
      planning? .......................................... 4 – 3
      Can you run multilingual reports? .............. 4 – 3
   Information Access Overview ....................... 4 – 4
      Inquiry Windows .................................. 4 – 4
      Predefined Reports ............................... 4 – 4
      Multilingual Reporting ......................... 4 – 5
      Using Oracle HRMS with Spreadsheets ........ 4 – 5
      QuickPaint ........................................ 4 – 5
      Attachments ....................................... 4 – 6
      Using Attachments ................................. 4 – 7
      Using Inquiry Windows and Folders .......... 4 – 10
      Defining QuickPaint Reports ....................... 4 – 12
Reader’s Comment Form

Customizing, Reporting, and System Administration in Oracle® HRMS (US) A73296–01

Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this publication. Your input is an important part of the information we use for revision.

- Did you find any errors?
- Is the information clearly presented?
- Do you need more information? If so, where?
- Are the examples correct? Do you need more examples?
- What features did you like most about this manual? What did you like least about it?

If you find any errors or have any other suggestions for improvement, please indicate the topic, chapter, and page number below:

___________________________________________________________________________
___________________________________________________________________________
___________________________________________________________________________
___________________________________________________________________________
___________________________________________________________________________

Please send your comments to:
Oracle Applications Documentation Manager
Oracle Corporation
500 Oracle Parkway
Redwood Shores, CA 94065
Phone: (650) 506–7000 Fax: (650) 506–7200

If you would like a reply, please give your name, address, and telephone number below:

___________________________________________________________________________
___________________________________________________________________________
___________________________________________________________________________

Thank you for helping us improve our documentation.
Preface
Audience for This Guide

Welcome to Release 11i of the Customizing, Reporting, and System Administration in Oracle HRMS (US) user guide.

This guide assumes you have a working knowledge of the following:

- The principles and customary practices of your business area.
- Oracle® HRMS
  
  If you have never used Oracle® HRMS, we suggest you attend one or more of the Oracle® HRMS training classes available through Oracle University.
- The Oracle Applications graphical user interface.
  
  To learn more about the Oracle Applications graphical user interface, read the Oracle Applications User Guide.

See Other Information Sources for more information about Oracle Applications product information.

How To Use This Guide

This guide contains the information you need to understand and use Oracle® HRMS.

This preface explains how this user guide is organized and introduces other sources of information that can help you. This guide contains the following chapters:

- Chapter 1 explains how to extend and customize Oracle HRMS so it works exactly how your enterprise does.
- Chapter 2 explains how you set up security in Oracle HRMS. Security is a major concern of all payroll and human resource departments. Oracle HRMS includes security models for keeping information secure and preventing unauthorized access.
- Chapter 3 explains how you can track and record changes to your data. AuditTrail provides a flexible approach to tracking the changes to your data. It enables you keep a history of changes to your important data: what changed, who changed it, and when.
- Chapter 4 explains how you can access information within Oracle HRMS. You can use the same information in a variety of different ways depending on your business purpose.
• Chapter 5 explains how you can create standard letters to manage your enterprise’s recruitment or enrollment activities more easily.

• Appendix A lists the default navigation paths for all the windows and reports in Oracle HRMS for the US, as they are supplied. It also lists the default menus that give you access to all the windows on the system.

• Appendix B lists the publicly callable business process APIs.

• Appendix C provides a template SQL*Plus script for use with standard letters.

Note: HRMS Implementation Steps are included in Implementing Oracle HRMS, rather than in this User Guide.

Finding Out What’s New

From the HTML help window for Oracle® HRMS, choose the section that describes new features or what’s new from the expandable menu. This section describes:

• New features in 11i. This information is updated for each new release of Oracle® HRMS.

• Information about any features that were not yet available when this user guide was printed. For example, if your system administrator has installed software from a mini pack as an upgrade, this document describes the new features.

Other Information Sources

You can choose from many sources of information, including online documentation, training, and support services, to increase your knowledge and understanding of Oracle® HRMS.

If this guide refers you to other Oracle Applications documentation, use only the Release 11i versions of those guides unless we specify otherwise.
Online Documentation

All Oracle Applications documentation is available online (HTML and PDF). The technical reference guides are available in paper format only. Note that the HTML documentation is translated into over twenty languages.

The HTML version of this guide is optimized for onscreen reading, and you can use it to follow hypertext links for easy access to other HTML guides in the library. When you have an HTML window open, you can use the features on the left side of the window to navigate freely throughout all Oracle Applications documentation.

- You can use the Search feature to search by words or phrases.
- You can use the expandable menu to search for topics in the menu structure we provide. The Library option on the menu expands to show all Oracle Applications HTML documentation.

You can view HTML help in the following ways:

- From an application window, use the help icon or the help menu to open a new Web browser and display help about that window.
- Use the documentation CD.
- Use a URL provided by your system administrator.

Your HTML help may contain information that was not available when this guide was printed.

Related User Guides

Oracle® HRMS shares business and setup information with other Oracle Applications products. Therefore, you may want to refer to other user guides when you set up and use Oracle® HRMS.

If you do not have the hardcopy versions of these guides, you can read them online by choosing Library from the expandable menu on your HTML help window, by reading from the Oracle Applications Document Library CD, or by using a Web browser with a URL that your system administrator provides.
User Guides Related to All Products

**Oracle Applications User Guide**

This guide explains how to navigate the system, enter data, and query information, and introduces other basic features of the GUI available with this release of Oracle® HRMS (and any other Oracle Applications product).

You can also access this user guide online by choosing “Getting Started and Using Oracle Applications” from the Oracle Applications help system.

**Oracle Alert User Guide**

Use this guide to define periodic and event alerts that monitor the status of your Oracle Applications data.

**Oracle Applications Implementation Wizard User Guide**

If you are implementing more than one Oracle product, you can use the Oracle Applications Implementation Wizard to coordinate your setup activities. This guide describes how to use the wizard.

**Oracle Applications Developer’s Guide**

This guide contains the coding standards followed by the Oracle Applications development staff. It describes the Oracle Application Object Library components needed to implement the Oracle Applications user interface described in the *Oracle Applications User Interface Standards*. It also provides information to help you build your custom Developer/2000 forms so that they integrate with Oracle Applications.

**Oracle Applications User Interface Standards**

This guide contains the user interface (UI) standards followed by the Oracle Applications development staff. It describes the UI for the Oracle Applications products and how to apply this UI to the design of an application built by using Oracle Forms.
User Guides Related to This Product

**Using Oracle HRMS – The Fundamentals**
This user guide explains how to setup and use enterprise modeling, organization management, and cost analysis. It also includes information about defining payrolls.

**Managing People Using Oracle HRMS**
Use this guide to find out about using employee management, recruitment activities, career management, and budgeting.

**Running Your Payroll Using Oracle HRMS**
This user guide provides information about wage attachments, taxes and social insurance, the payroll run, and other processes.

**Managing Compensation and Benefits Using Oracle HRMS**
Use this guide to learn about compensation setup, entry and analysis, setting up basic, standard and advanced benefits, salary administration, and absence management and PTO accruals.

**Customizing, Reporting and System Administration**
This guide provides information about extending and customizing Oracle HRMS, managing security, auditing, information access, and letter generation.

**Implementing Oracle HRMS**
This user guide explains the setup procedures you need to do in order to successfully implement Oracle HRMS in your enterprise.

**Implementing Oracle Self–Service Human Resources (SSHR)**
This guide provides information about setting up the self–service human resources management functions for managers and employees. Managers and employees can then use an intranet and Web browser to have easy and intuitive access to personal and career management functionality.
Using Oracle FastFormula

This guide provides information about writing, editing, and using formulas to customize your system. Oracle FastFormula provides a simple way to write formulas using English words and basic mathematical functions. For example, Oracle FastFormula enables you to specify elements in payroll runs or create rules for PTO and accrual plans.

Using Oracle Training Administration (OTA)

This guide provides information about how to set up and use Oracle Training Administration to facilitate your training and certification business.

Using Oracle SSP/SMP

This guide provides information about setting up and using Oracle SSP/SMP to meet your statutory sick pay and statutory maternity pay obligations.

Using Application Data Exchange and Hierarchy Diagrammers

This guide provides information about using Application Data Exchange to view HRMS data with desktop tools, and upload revised data to your application. This guide also provides information about using Hierarchy Diagrammers to view hierarchy diagrams for organizations and positions.

Oracle Business Intelligence System Implementation Guide

This guide provides information about implementing Oracle Business Intelligence (BIS) in your environment.

BIS 11i User Guide Online Help

This guide is provided as online help only from the BIS application and includes information about intelligence reports, Discoverer workbooks, and the Performance Management Framework.

Using Oracle Time Management

This guide provides information about capturing work patterns such as shift hours so that this information can be used by other applications such as General Ledger.
Oracle Applications Flexfields Guide

This guide provides flexfields planning, setup, and reference information for the Oracle® HRMS implementation team, as well as for users responsible for the ongoing maintenance of Oracle Applications product data. This guide also provides information on creating custom reports on flexfields data.

Installation and System Administration Guides

Oracle Applications Concepts

This guide provides an introduction to the concepts, features, technology stack, architecture, and terminology for Oracle Applications Release 11i. It provides a useful first book to read before an installation of Oracle Applications. This guide also introduces the concepts behind, and major issues, for Applications–wide features such as Business Intelligence (BIS), languages and character sets, and self–service applications.

Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle Applications products. In Release 11i, much of the installation process is handled using Oracle One–Hour Install, which minimizes the time it takes to install Oracle Applications and the Oracle 8i Server technology stack by automating many of the required steps. This guide contains instructions for using Oracle One–Hour Install and lists the tasks you need to perform to finish your installation. You should use this guide in conjunction with individual product user guides and implementation guides.

Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or Release 11.0 products to Release 11i. This guide describes the upgrade process in general and lists database upgrade and product–specific upgrade tasks. You must be at either Release 10.7 (NCA, SmartClient, or character mode) or Release 11.0 to upgrade to Release 11i. You cannot upgrade to Release 11i directly from releases prior to 10.7.
Using the AD Utilities

Use this guide to help you run the various AD utilities, such as AutoInstall, AutoPatch, AD Administration, AD Controller, Relink, and others. It contains how-to steps, screenshots, and other information that you need to run the AD utilities.

Oracle Applications Product Update Notes

Use this guide as a reference if you are responsible for upgrading an installation of Oracle Applications. It provides a history of the changes to individual Oracle Applications products between Release 11.0 and Release 11i. It includes new features and enhancements and changes made to database objects, profile options, and seed data for this interval.

Oracle Applications System Administrator’s Guide

This guide provides planning and reference information for the Oracle Applications System Administrator. It contains information on how to define security, customize menus and online help, and manage processing.

Oracle HRMS Applications Technical Reference Guide

This reference guide contains database diagrams and a detailed description of database tables, forms, reports, and programs for Oracle HRMS, including Oracle® HRMS and related applications. This information helps you convert data from your existing applications, integrate Oracle® HRMS with non-Oracle applications, and write custom reports for Oracle® HRMS.

You can order a technical reference guide for any product you have licensed. Technical reference guides are available in paper format only.

Oracle Workflow Guide

This guide explains how to define new workflow business processes as well as customize existing Oracle Applications-embedded workflow processes. You also use this guide to complete the setup steps necessary for any Oracle Applications product that includes workflow-enabled processes.
Training and Support

Training

We offer a complete set of training courses to help you and your staff master Oracle Applications. We can help you develop a training plan that provides thorough training for both your project team and your end users. We will work with you to organize courses appropriate to your job or area of responsibility.

Training professionals can show you how to plan your training throughout the implementation process so that the right amount of information is delivered to key people when they need it the most. You can attend courses at any one of our many Educational Centers, or you can arrange for our trainers to teach at your facility. We also offer Net classes, where training is delivered over the Internet, and many CD multimedia–based courses. In addition, we can tailor standard courses or develop custom courses to meet your needs.

Support

From on–site support to central support, our team of experienced professionals provides the help and information you need to keep Oracle® HRMS working for you. This team includes your Technical Representative, Account Manager, and Oracle’s large staff of consultants and support specialists with expertise in your business area, managing an Oracle server, and your hardware and software environment.

Do Not Use Database Tools to Modify Oracle Applications Data

We STRONGLY RECOMMEND that you never use SQL*Plus, Oracle Data Browser, database triggers, or any other tool to modify Oracle Applications tables, unless we tell you to do so in our guides.

Oracle provides powerful tools you can use to create, store, change, retrieve, and maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using an Oracle Applications form can update many tables at once. But when you modify Oracle Applications data using anything
other than Oracle Applications forms, you might change a row in one table without making corresponding changes in related tables. If your tables get out of synchronization with each other, you risk retrieving erroneous information and you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications forms to modify your data, Oracle Applications automatically checks that your changes are valid. Oracle Applications also keeps track of who changes information. But, if you enter information into database tables using database tools, you may store invalid information. You also lose the ability to track who has changed your information because SQL*Plus and other database tools do not keep a record of changes.

About Oracle

Oracle Corporation develops and markets an integrated line of software products for database management, applications development, decision support and office automation, as well as Oracle Applications, an integrated suite of more than 45 software modules for financial management, supply chain management, manufacturing, project systems, human resources and sales and service management.

Oracle products are available for mainframes, minicomputers, personal computers, network computers, and personal digital assistants, enabling organizations to integrate different computers, different operating systems, different networks, and even different database management systems, into a single, unified computing and information resource.

Oracle is the world’s leading supplier of software for information management, and the world’s second largest independent software company. Oracle offers its database, tools, and application products, along with related consulting, education and support services, in over 145 countries around the world.

Your Feedback

Thank you for using Oracle® HRMS and this user guide.

We value your comments and feedback. At the back of this guide is a Reader’s Comment Form you can use to explain what you like or
dislike about Oracle® HRMS or this user guide. Mail your comments to the following address or call us directly at (650) 506–7000.

Oracle Applications Documentation Manager
Oracle Corporation
500 Oracle Parkway
Redwood Shores, CA 94065
U.S.A.

Or, send electronic mail to appsdoc@us.oracle.com.
Extend and Customize Oracle HRMS
Extend and Customize Oracle HRMS

You can extend and customize Oracle HRMS to meet the needs of your enterprise.

Can you link associated windows together?

Yes. Oracle recognizes that to complete many tasks, you need to use more than one window. You can link these windows together in a task flow so that you can choose a button to bring up each window in turn without returning to the menu.

How can you hold additional information?

You can add data fields to windows to hold any additional information you require. Flexfields are flexible fields that enable you to do this.

Then, when you click in a flexfield you have set up, a window opens, displaying segments into which you can enter data.

You can also set up your own tables to hold data such as wage codes, shift differentials, or the amounts of certain deductions.

How can you ensure the same terminology is used and speed up data entry?

Oracle provides lists of values called Lookups for certain items of information. Lookups ensure that all users use the same terminology, making it easier to inquire and report on information. Lookups also speed up data entry because you can enter just enough to identify the value, and the system completes the entry.

Can you define the formats for currency?

Yes. You can define the formats for displaying currency amounts.
Extend and Customize Oracle HRMS Overview

You need to understand the key components Oracle HRMS provides to extend and customize the application. Once you have identified whether to customize parts of the system, define additional information or to add your own Lookups, you are ready to set up the data that all users share across the application.

Key Components

- Task Flows

You often need to use more than one window to complete many tasks. For example, to hire a new employee, you typically go from the People window, to the Address window, to the Special Information window, to the Assignment window, and so on. You can link these windows together in a task flow so that you can choose a button to bring up each window in turn without returning to the menu.

There are two methods you can use to set up and maintain your task flows:

- Using Forms
- Using Oracle Workflow

- Windows

You can create customized versions of standard windows, if required. This approach restricts the list of values on certain fields and therefore provides for faster data entry. It also enables you to limit access to certain types of information.

- Flexfields

You can add data fields to windows to hold any additional information you require. Flexfields are flexible fields that enable you to do this.

- Key flexfields enable you customize some of the most important parts of the system, including the names of jobs, positions and grades, how payroll costs are allocated, and analysis information for employees and other people.

- Descriptive flexfields enable you to add fields to windows to record additional information.

- Extra Information Types enable you to set up multiple categories of information for the most important entities in Oracle HRMS. For example, you might use EITs to add
details to assignment records in special circumstances such as, information about a leave of absence or extra information about a temporary assignment to a project.

- Protected Flexfields

Oracle HRMS supplies two key flexfields and three descriptive flexfields that are predefined and protected. Your localization team defines these flexfields to meet the specific legislative and reporting needs of your country.

- User–Defined Tables

You can set up user tables to provide matrixes of valid values that vary according to a factor such as age, or job, or number of years service. You can access these values from formulas, or your own forms or reports. The GET_TABLE_VALUE function is supplied for using in your formulas. Some user tables are predefined in certain legislations, for example to hold values for payroll calculations.

- Lookups

Lookups provide lists of valid values on certain fields throughout the system. For many types of lookup you can add your own values and change the values that are predefined. Lookups not only ensure that all users use the same terminology, but they also speed up data entry.

- Currencies

You will also need to define the formats for displaying currency amounts.

- CUSTOM Library Events

CUSTOM Library Events enable you to customize the logic that is executed at defined points within a window. Generic events are available to all Oracle Applications and Product Specific Events are also available to help you to apply business rules specific to Oracle HRMS.

- APIs

See: *Oracle Applications System Administrator’s Guide*
Task Flow

You can link windows used to complete tasks in a task flow. Then, you can choose a button to bring up each window in turn without returning to the menu.

The first window in the task flow defines the context of the subsequent windows. For example, if the task flow begins with the People window, all subsequent information is entered for the person you enter or query in the People window.

You can include customized forms in task flows. For example, you might create a customized version of the People window that handles applicants only. Then you could use this customization in a recruitment task flow.

Using Forms or Workflow

There are two methods you can use to set up and maintain your task flows:

- Creating Task Flows Using Forms: page 1 – 64
- Task Flow (Oracle Workflow): page 1 – 11

You can model your task flows using Oracle Workflow (version 2.0.3.8.1 or higher) then generate a task flow. This method of creating task flows has the advantage of using a diagrammer to help you design the sequence of windows.

Sequential or Branched Structure

Task flows can follow a sequential or a branched structure, as shown in the following two figures. You can choose how many navigation options users have from each window in the task flow. You can also choose the labels that appear on the navigation buttons, and you can define access keys.

Predefined Task Flows

Oracle HRMS supplies several predefined task flows that include all the windows that you can use in task flows. They are designed as a simple structure to use during implementation, not as a recommended structure for users.

Predefined task flows are translated into your base language when you install Oracle HRMS. However, if you install an additional language, you need to create new versions of your task flows in that language. These can then be linked to the correct menu for the language.
Figure 1 – 1 Sequential Task Flow

Figure 1 – 2 Branched Task Flow
Task Flow Windows

You can create your own task flows by referencing the windows listed in the table below, or customized versions of them. Some of these windows require the context of an assignment. This means that either the Assignment window or the Assignments Folder window or the Application window (for applicant assignments) must appear above them in the task flow.

All task flows must begin with one of the following forms:

- People and Assignment (PERWSHRG)
- People (PERWSEPI)
- People Folder (PERWSFPE)
- Assignments Folder (PERWSFAS)
- Job (PERWSDJT)
- Position (HRWSPSF)
- Location (PERWSLOC)

Attention: Using the combined People and Assignment form (PERWSHRG), rather than the separate forms (PERWSEPI and PERWSEMA), the Assignment window opens more quickly from the People window. We therefore recommend that you use the combined form in any taskflow that requires both windows. The predefined taskflows use the combined form.

<table>
<thead>
<tr>
<th>Window</th>
<th>Context Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absence Detail</td>
<td>Person (employee)</td>
</tr>
<tr>
<td>Address</td>
<td>Person</td>
</tr>
<tr>
<td>Adjust Balances (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Applicant Interview</td>
<td>Assignment (applicant)</td>
</tr>
<tr>
<td>Application</td>
<td>Person (applicant)</td>
</tr>
<tr>
<td>Assignment</td>
<td>Person (employee)</td>
</tr>
<tr>
<td>Assignment Budget Values</td>
<td>Assignment</td>
</tr>
<tr>
<td>Assignments Folder</td>
<td>None</td>
</tr>
<tr>
<td>Beneficiaries (US Legislation Only)</td>
<td>Element entry</td>
</tr>
<tr>
<td>Book Events</td>
<td>Person (employee or applicant)</td>
</tr>
</tbody>
</table>

Windows You Can Use in Task Flows
<table>
<thead>
<tr>
<th><strong>Window</strong></th>
<th><strong>Context Required</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>COBRA (US legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Competence Profile</td>
<td>Person</td>
</tr>
<tr>
<td>Contact</td>
<td>Person</td>
</tr>
<tr>
<td>Contract</td>
<td>Person</td>
</tr>
<tr>
<td>Costing</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Covered Dependents (US legislation only)</td>
<td>Element entry</td>
</tr>
<tr>
<td>Element Entries</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Employee Review</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Employee Tax Rules (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>External/Manual Payments (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Extra Assignment Information</td>
<td>Assignment (employee or applicant)</td>
</tr>
<tr>
<td>Extra Job Information</td>
<td>Job</td>
</tr>
<tr>
<td>Extra Location Information</td>
<td>Location</td>
</tr>
<tr>
<td>Extra Person Information</td>
<td>Person (employee or applicant)</td>
</tr>
<tr>
<td>Extra Position Information</td>
<td>Position</td>
</tr>
<tr>
<td>Grade Step Placement</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>P45 (UK Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>People Folder</td>
<td>None</td>
</tr>
<tr>
<td>People</td>
<td>None</td>
</tr>
<tr>
<td>Performance</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Personal Payment Method</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Phone Numbers</td>
<td>Person</td>
</tr>
<tr>
<td>Picture</td>
<td>Person</td>
</tr>
<tr>
<td>Position</td>
<td>None</td>
</tr>
<tr>
<td>Position Occupancy</td>
<td>Position</td>
</tr>
<tr>
<td>Qualifications</td>
<td>Person</td>
</tr>
</tbody>
</table>

*Windows You Can Use in Task Flows*
<table>
<thead>
<tr>
<th>Window</th>
<th>Context Required</th>
</tr>
</thead>
<tbody>
<tr>
<td>QuickPay (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Reverse Payroll Run (Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Salary Administration</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Salary History</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Schools and Colleges (Establishment Attendances)</td>
<td>Person</td>
</tr>
<tr>
<td>Secondary Statuses</td>
<td>Assignment</td>
</tr>
<tr>
<td>SOE Report (UK Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Special Information</td>
<td>Person</td>
</tr>
<tr>
<td>Statutory Details (UK Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Terminate</td>
<td>Person (employee)</td>
</tr>
<tr>
<td>Terminate Applicant</td>
<td>Person (applicant)</td>
</tr>
<tr>
<td>View Element Entry History</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>Work Choices (Job or Position)</td>
<td>Job or Position</td>
</tr>
<tr>
<td>Work Choices (Person)</td>
<td>Person</td>
</tr>
<tr>
<td>View Employee Accruals (US legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View Employee Benefits (US legislation only)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View Employee Earnings &amp; Deduction Balances (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View Employee Tax Balances (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
<tr>
<td>View SOE (US Oracle Payroll)</td>
<td>Assignment (employee)</td>
</tr>
</tbody>
</table>

**Windows You Can Use in Task Flows**

**Including the Assignment Window**

When users move down a task flow from the combined People and Assignment form, the Assignment window remains visible in the background. They can return to the Assignment window by closing their current window. Therefore you should not define a button to call the Assignment window.

However, if you are defining a task flow to the Assignment window from any window except the People window, you should use the
Assignment form (PERWSEMA). In this case you can add an Assignment button to any forms below the Assignment window in the taskflow. This enables users to return to the Assignment window without going back to the top window.
Task Flow (Oracle Workflow)

As an alternative to using forms to set up and maintain task flows, you can model your task flows using Oracle Workflow (version 2.0.3.8.1 or higher) then generate a task flow. This method of creating task flows has the advantage of using a diagrammer to help you design the sequence of windows.

Note: When you create a task flow using Oracle Workflow, you must continue to maintain it using Oracle Workflow. You cannot edit a generated task flow using the Define Task Flow form.

Oracle HRMS supplies the HR Task Flow item type and a function activity for every window that can be task flowed. You model these into a workflow process for each task flow. By setting activity attributes, you create button labels and the position of buttons on each window.

Key Rules

There are two key rules in defining task flows:

- Only certain windows are valid first windows (or top nodes) in a task flow. To check which windows are valid first windows, check the Lookup Types using Oracle Workflow Designer.

  When you create a workflow process to model your task flow, your Start activity must connect to the Top Node Selector activity. This activity ensures that your first window is valid.

- Each window in a task flow can only be connected to a window that supplies the correct context.

  For example, the Position Occupancy window requires the context of a position, while the Qualifications window requires the context of a person. Each workflow activity supplied for a window has its Result Type set to a lookup type that defines the context that must be passed to it. For example, the F4 Enter Address window has the Result Type set to Person Context Windows. This means it must be given the context of a person.

Task flows are associated with one of the following contexts:

- Assignment
- Element Entry
- Job
- Location
- PA Request (Govt HR)
- People
- Position Description (Govt HR)
- Position
- Top node HRMS windows
Windows You Can Customize

Many of the standard Oracle HRMS windows are multipurpose. For example, in the People windows, you can enter or view details of employees, applicants, contacts, or other person types that you have defined. In the Element Entries window, you can make entries for all the elements you have defined.

You might prefer to have multiple versions of these windows, each version being used for just one purpose. This approach restricts the list of values on certain fields and therefore provides for faster data entry. It also enables you to limit access to certain types of information.

For example, you might create a customized version of the View Element Entry History for Employee window that does not display the earnings elements representing salary, bonus, and commission. Most users’ menus would only give them access to this customized version of the window. For the small group of people authorized to view salary, bonus, and commission figures, your system administrator can define a menu function to allow access to the uncustomized form.

List of Customizable Windows

You can customize the windows identified below. We also identify the criteria you can use to restrict access to information.

<table>
<thead>
<tr>
<th>Form</th>
<th>Restrict By</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adjust Balance</td>
<td>Element Set</td>
<td>User defined</td>
</tr>
<tr>
<td>(Oracle Payroll form)</td>
<td>Element Processing Type</td>
<td>Recurring, Nonrecurring</td>
</tr>
<tr>
<td>Assignment Folder</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Table Values</td>
<td>Table Name</td>
<td>User defined</td>
</tr>
<tr>
<td>(Define User Values)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Element Entries</td>
<td>Element Set</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Element Processing Type</td>
<td>Recurring, Nonrecurring</td>
</tr>
<tr>
<td></td>
<td>Entry Type</td>
<td>Override</td>
</tr>
<tr>
<td>Event Bookings</td>
<td>Employee or Applicant</td>
<td>Employee, Applicant</td>
</tr>
<tr>
<td>List Employees by Element</td>
<td>Element Set</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Element Processing Type</td>
<td>Recurring, Nonrecurring</td>
</tr>
<tr>
<td>Form</td>
<td>Restrict By</td>
<td>Values</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>--------------------------------------</td>
<td>---------------------------------------------</td>
</tr>
<tr>
<td>List People by Special Information</td>
<td>Employee or Applicant</td>
<td>Employee, Applicant</td>
</tr>
<tr>
<td></td>
<td>Special Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Organization</td>
<td>Organization Classification</td>
<td>List of Organization Classifications</td>
</tr>
<tr>
<td>Payroll and Assignment Processes</td>
<td>Action Type</td>
<td>List of Action Types</td>
</tr>
<tr>
<td>(Oracle Payroll form)</td>
<td></td>
<td>(e.g. Run, Pre-payments, Reversal)</td>
</tr>
<tr>
<td>People Folder</td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>People (PERWSEPI), People and Assignment</td>
<td>Person Function</td>
<td>Enter Employee, Enter Applicant, Hire</td>
</tr>
<tr>
<td>(PERWSHRG)</td>
<td></td>
<td>people already on system</td>
</tr>
<tr>
<td></td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Position Occupancy Folder</td>
<td>Employee or Applicant</td>
<td>Employee, Applicant</td>
</tr>
<tr>
<td>Run QuickPaint Report</td>
<td>QuickPaint Inquiry</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Person Type</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Assignments</td>
<td>Assignment Sets, Assignments</td>
</tr>
<tr>
<td>Special Information</td>
<td>Special Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>View Element Entry History for Employee</td>
<td>Element Set</td>
<td>User defined</td>
</tr>
<tr>
<td></td>
<td>Element Processing Type</td>
<td>Recurring, Nonrecurring</td>
</tr>
<tr>
<td>Extra Assignment Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra Job Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra Location Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra People Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
<tr>
<td>Extra Position Information</td>
<td>Extra Information Type</td>
<td>User defined</td>
</tr>
</tbody>
</table>

**Types of Data Restrictions**

You can restrict the information that appears in a customized window by the following sorts of criteria:
• Element processing type (recurring or nonrecurring)
• Element set (user defined)
• Person function (enter employee, enter applicant, hire someone on system)
• Person type (user defined)
• Special information type (user defined)
• Organization classification
• Employee or applicant
• QuickPaint report (user defined)
• Extra Information Type (user defined)

If you want to restrict the data by a user defined information type, you must create it first:

• To restrict by element set, create the set in the Element and Distribution Set window.

• To restrict by QuickPaint Report, create the report in the Define QuickPaint Report window.

See: Defining QuickPaint Reports: page 4 – 12

• To restrict by Special Information Type, define your information type as an instance of the Personal Analysis key flexfield.

See: Setting Up Special Information, Managing People Using Oracle HRMS

• To restrict by person types, define your user person types in the Person Types window.

See: Defining Person Types, Managing People Using Oracle HRMS

• To restrict by Extra Information Type, define your information type as an instance of the appropriate extra information flexfield.

See: Setting Up Extra Information Types (Excluding Organization EITs): page 1 – 87
Flexfields

Flexfields are flexible fields that enable you to customize and extend Oracle Applications by adding fields to windows. There are two types of flexfield:

- Key flexfields enable you to define additional information you want to record in existing fields.
- Descriptive flexfields enable you to add fields to windows to record additional information.

Extra Information Types (EITs) are a type of descriptive flexfield that enable you to set up unlimited amounts of extra information for six of the most important entities in Oracle HRMS:

You can set up each flexfield to contain a number of segments, which act like separate fields.

When a user clicks in a flexfield you have set up, a window opens, displaying the segments that you have defined. For each segment, you can define:

- Its prompt
- The type of data it can contain
- The values a user can enter

You can provide a list or range of valid values. You also control the size and display characteristics of each segment and the sequence in which the segments appear.
User Definable Key Flexfields

In Oracle HRMS there are six user definable key flexfields, for each of which you can define up to 30 segments:

- Job
- Position
- Grade
- People Group
- Personal Analysis
- Cost Allocation

The Personal Analysis key flexfield is different from the others. You can set up an unlimited number of structures for this flexfield.

Note: Each separate structure can have up to 30 segments.

How Oracle HRMS Uses Key Flexfields

Oracle HRMS uses key flexfields in a number of distinct ways:

Unique Identifiers

The Job, Position, and Grade Name flexfields let you create a unique name, which is a combination of separate components or segments. You use these flexfields when you are defining the work structures that exist in your enterprise.

Suggestion: When you are defining your requirements for these key flexfields you should consider the following points.

- The task of defining the segment combinations is normally restricted to one or two users only. Therefore, you may not need to use value sets, or cross validation rule options to control the values that can be entered.

- The names that users see are made up of a combination of segment values. The segment values are displayed, not the meanings.

- Avoid segments containing information that may change regularly. There is no history of changes to the combinations you create. For example, do not define minimum and maximum values for grades as segments of the Grade flexfield.
Analysis Information

The People Group and Personal Analysis flexfields let you add key information to records of employee assignments and people. You can use the individual segments of these flexfields to identify or report on specific groups of people.

Payroll Costing

The Cost Allocation key flexfield is used to collect and to accumulate costs associated with running a payroll.

What You Must Set Up

The key flexfields are central to Oracle HRMS, therefore you must create certain definitions before you can set up your Business Group.

Job, Position, And Grade Key Flexfields

• You can only define one structure per Business Group for each of these flexfields.

• Use of these flexfields is optional, but almost all Oracle HRMS installations use job and grade. Positions are used most often in large, highly structured enterprises, such as those in the areas of government, education, and health care.

• You must define a structure name for these three flexfields before you can define a Business Group.

• You associate these structures with a Business Group in the Business Group Information window, which opens from the Organization window.

People Group Key Flexfield

• You can only define one structure per Business Group for this flexfield.

• You do not create separate combinations of segments for the People Group flexfield. You enter values for each employee as part of the employee assignment.

• You must define a structure name for this flexfield before you can define a Business Group.

• You must define at least one segment for the People Group flexfield in order to be able to use the Assignment window.

Personal Analysis Key Flexfield

• You can create any number of structures per Business Group for this flexfield. Each one represents a Special Information Type.
• You do not need to define any structures for the Personal Analysis flexfield before you can use Oracle HRMS.

• You link each structure to a Business Group in the Special Information Types window while you are logged on to that Business Group.

• You can customize windows to restrict access to specific Information Types, such as medical or disciplinary information.

Cost Allocation Key Flexfield

• You can only define one structure per Business Group for this flexfield.

• You can control the levels at which users can enter cost information by using the flexfield qualifiers.

• You must define a structure name for this flexfield before you can define a Business Group.

• A number of windows in Oracle HRMS check for the existence of a valid flexfield structure for Cost Allocation. You must define at least one segment for your Cost Allocation flexfield.

See: Oracle Applications Flexfields Guide
User Definable Descriptive Flexfields

The predefined fields in Oracle HRMS windows are designed to meet your core information requirements. However, like all enterprises, you may have special requirements that are best met by fields that you design yourself. Oracle HRMS provides a flexible mechanism called descriptive flexfields to enable you to add fields to windows.

All window blocks in which you can enter information contain a user definable descriptive flexfield. You decide in which blocks you want to record additional information. Each user definable descriptive flexfield has 20 segments that you can define. After you define a descriptive flexfield, Oracle HRMS treats the segments as part of the window.

The following figure illustrates the distinctive appearance of descriptive flexfields. When users click in a flexfield that you have set up, a window opens, displaying up to 20 segments that you have defined.

Figure 1 – 3
Recognizing a Descriptive Flexfield

Segments

For each segment, you can define:

- Its prompt
- The type of data it can contain
- The values a user can enter

You can provide a list or range of valid values. You also control the size and display characteristics of each segment and the order in which the segments appear.

Types of Descriptive Flexfield

You can define two types of descriptive flexfield segments:

- Global segments, which always appear in the window.
- Context sensitive segments, that appear only when a defined context exists. You can prompt the user to provide the context, or you can provide the context automatically from a reference field in the same block.
For example, a segment to hold information about an employee’s disability might appear only when the Disabled field is checked.

**Attention:** Some descriptive flexfields appear in more than one window. For example, the *Additional Evaluation Details* flexfield appears in the Job Evaluation window and the Position Evaluation window.

Check all of the windows that use a descriptive flexfield before you define any of the segments. This is especially important if you intend to make the flexfield context sensitive to another field. You must ensure that the reference field is present in all of the windows that use the flexfield.

See: Descriptive Flexfield List: page 1 – 22 for a full list of user definable descriptive flexfields in Oracle HRMS.
# Descriptive Flexfield List

The following table lists all the descriptive flexfields in Oracle HRMS.

<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Absence Details</td>
<td>Absence Detail, View Absence History</td>
<td>ABSENCES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Absence Type Details</td>
<td>Absence Attendance Type</td>
<td>ABSENCE_TYPES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Address Details</td>
<td>Address, Applicant Entry Contact</td>
<td>PERSON_ADDRESSES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Application Details</td>
<td>Applicant Entry, Application, Terminate Applicant</td>
<td>APPLICATIONS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Assignment Details</td>
<td>Applicant Entry, Application, Assignment, Assignment History</td>
<td>ASSIGNMENTS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Assignment Status Details</td>
<td>Secondary Statuses</td>
<td></td>
</tr>
<tr>
<td>Additional Balance Type Information</td>
<td>Balance (Oracle Payroll only)</td>
<td></td>
</tr>
<tr>
<td>Additional Benefit Contribution Details</td>
<td>Benefit Contributions (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional Booking Details</td>
<td>Applicant Interview, Book Events, Employee Review, Event Bookings</td>
<td></td>
</tr>
<tr>
<td>Additional Budget Details</td>
<td>Budget</td>
<td></td>
</tr>
<tr>
<td>Additional Budget Version Details</td>
<td>Budget</td>
<td></td>
</tr>
<tr>
<td>Additional Calendar Information</td>
<td>Budgetary Calendar</td>
<td></td>
</tr>
<tr>
<td>Additional Career Path Details</td>
<td>Career Path Names</td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Benefit Details</td>
<td>COBRA Benefits (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Coverage Details</td>
<td>COBRA Coverage (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Payment Details</td>
<td>COBRA Payment (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional COBRA Status Details</td>
<td>COBRA Status (US only)</td>
<td></td>
</tr>
<tr>
<td>Additional Collective Agreement Details</td>
<td>Collective Agreements</td>
<td></td>
</tr>
<tr>
<td>Additional Contact Relationship Details</td>
<td>Contact</td>
<td>CONTACTS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Contract Details</td>
<td>Contact</td>
<td></td>
</tr>
</tbody>
</table>

**User Definable Descriptive Flexfields**
<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Element Entry Information</td>
<td>Adjust Balance (Oracle Payroll only), Element Entries, View Element Entry History for Employee</td>
<td>EVENTS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Element Link Information</td>
<td>Element Link</td>
<td>GRADES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Element Type Details</td>
<td>Element</td>
<td>JOBS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Evaluation Details</td>
<td>Job, Position</td>
<td></td>
</tr>
<tr>
<td>Additional Event Details</td>
<td>Applicant Interview, Employee Review, Event Bookings</td>
<td></td>
</tr>
<tr>
<td>Additional Grade Details</td>
<td>Grade</td>
<td></td>
</tr>
<tr>
<td>Additional Job Details</td>
<td>Job</td>
<td></td>
</tr>
<tr>
<td>Additional Letter Details</td>
<td>Letter</td>
<td></td>
</tr>
<tr>
<td>Additional Location Details</td>
<td>Location</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Information</td>
<td>Organization</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Payment Method Details</td>
<td>Organizational Payment Method</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Structure Details</td>
<td>Organization Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Additional Organization Unit Details</td>
<td>Organization</td>
<td>ORGANIZATION_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Pay Scale Information</td>
<td>Pay Scale</td>
<td></td>
</tr>
<tr>
<td>Additional Pay Rate Details</td>
<td>Grade Rate, Scale Rate</td>
<td></td>
</tr>
<tr>
<td>Additional Payroll Details</td>
<td>Payroll</td>
<td>PAYROLLS_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Period Information</td>
<td>Budgetary Calendar, Period Dates (Payroll form)</td>
<td></td>
</tr>
<tr>
<td>Additional Period of Service Details</td>
<td>Terminate</td>
<td>PERIODS_OF_SERVICE_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Period Type Information</td>
<td>Period Types</td>
<td></td>
</tr>
<tr>
<td>Additional Person Analysis Details</td>
<td>Special Information, List People By Special Information</td>
<td></td>
</tr>
</tbody>
</table>

**User Definable Descriptive Flexfields**
<table>
<thead>
<tr>
<th>Descriptive Flexfield Title</th>
<th>Window Title</th>
<th>Database Items</th>
</tr>
</thead>
<tbody>
<tr>
<td>Additional Personal Details</td>
<td>Applicant Entry, Contact, People, People Folder</td>
<td>PEOPLE_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Personal Payment Method Details</td>
<td>Personal Payment Method</td>
<td></td>
</tr>
<tr>
<td>Additional Position Details</td>
<td>Position, Find Positions (Mass Move form)</td>
<td>POSITION_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Position Structure Details</td>
<td>Position Hierarchy</td>
<td></td>
</tr>
<tr>
<td>Additional Recruitment Activity Details</td>
<td>Recruitment Activity</td>
<td>RECRUITMENT_ACTIVITIES_&lt;SEGMENT_NAME&gt;</td>
</tr>
<tr>
<td>Additional Requirement Details</td>
<td>Job, Position</td>
<td></td>
</tr>
<tr>
<td>Additional Requisition Details</td>
<td>Requisition and Vacancy</td>
<td></td>
</tr>
<tr>
<td>Additional Salary Administration Details</td>
<td>Salary Administration</td>
<td></td>
</tr>
<tr>
<td>Additional Salary Basis Information</td>
<td>Salary Basis</td>
<td></td>
</tr>
<tr>
<td>Additional Telephone Number Details</td>
<td>Phone Numbers</td>
<td></td>
</tr>
<tr>
<td>Additional Vacancy Details</td>
<td>Requisition and Vacancy</td>
<td></td>
</tr>
<tr>
<td>Additional Valid Grade Details</td>
<td>Job, Position</td>
<td></td>
</tr>
<tr>
<td>Additional Year Information</td>
<td>Budgetary Calendar</td>
<td></td>
</tr>
<tr>
<td>Assignment Extra Information</td>
<td>Extra Assignment Information</td>
<td></td>
</tr>
<tr>
<td>Extra Job Info Details</td>
<td>Extra Job Information</td>
<td></td>
</tr>
<tr>
<td>Extra Location Info Details</td>
<td>Extra Location Information</td>
<td></td>
</tr>
<tr>
<td>Extra Person Info Details</td>
<td>Extra Person Information</td>
<td></td>
</tr>
</tbody>
</table>

**User Definable Descriptive Flexfields**
Descriptive Flexfields and Address Styles

Oracle HRMS supplies two predefined descriptive flexfields to hold address information in different styles for different countries. These are the:

- **Personal Address Information descriptive flexfield**: This holds the address information of your employee or applicant.
- **Location Address descriptive flexfield**: This holds the address information of your locations.

Oracle HRMS holds the addresses of people and location separately to enable you to record different information for tax reporting.

You can use these descriptive flexfields to add new address styles or to change the styles included in Oracle HRMS.

**Attention**: If you change the predefined styles, your changes will be overwritten when you upgrade Oracle HRMS. If you add new styles, your changes may be overwritten if new startup data contains address styles for these countries.

Address Styles

Address styles vary between countries, so Oracle HRMS provides descriptive flexfields that use *context sensitive* segments to hold each line of an address.

<table>
<thead>
<tr>
<th>Title</th>
<th>Table Name</th>
<th>Window Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personal Address Information</td>
<td>PER_ADDRESSES</td>
<td>Address, Applicant Entry</td>
</tr>
<tr>
<td>Location Address</td>
<td>HR_LOCATIONS</td>
<td>Location, Organization</td>
</tr>
</tbody>
</table>

Address Styles in Oracle HRMS

The available address styles are defined as the contexts for these flexfields. The values used are the territory codes. These codes can be found in the FND_TERRITORIES table. You can have only one Address Style for each Territory in the FND_TERRITORIES table.

Address styles are provided as startup data in these flexfields. If you require additional address styles, you need to define a new context and segments.
Extra Information Types (EITs)

Extra Information Types are defined using descriptive flexfields. You can set up any number of different EITs for:

- Location
- Job
- Position
- Person
- Assignment
- Organization

Note: EITs for organization are different because you can define which organization classification the EIT is available for.

For each EIT you can define up to 30 fully validated segments of information (or 20 for organizations).

Note: Oracle HRMS provides some predefined EITs. You may add your own information types, but you must not change the definitions of the delivered EITs.

Unlike the usual descriptive flexfields, EITs are child entities with separate tables to hold the information you enter. This means that you can have multiple instances of an EIT for each main record. When you define the EIT, you can specify whether you want to allow multiple instances. With the exception of organizations, EIT data is viewed and entered in a separate window which you can task flow.

The windows for all the EITs have the common look and feel of all the descriptive flexfield windows. This means that you can use your new EITs as soon as you save your definitions. Since flexfield definitions are preserved through upgrades, EITs do not require expensive recoding of custom forms with each new release.

Key Flexfield Combinations

EITs are very similar to Special Information Types (SITs). For analyzing people’s attributes and job requirements, Oracle enables you to choose whether to set up extra or special information types, or both. Both types of information use flexfields to define the structure and validation of their segments.

However, SITs are stored in a key flexfield combination table where the combination of segments must be unique – a feature of all key flexfields. Whereas, EITs are stored in a descriptive flexfield table where the combination of segment values do not need to form a unique key.
This means that EITs have performance advantages in large scale, or global implementations where you may want to transfer large volumes of information between separate installations.

**Dates and EITs**

EITs are not datetracked. Even if the parent entity, for example People, is datetracked, the extra information is not. However, if you want to track changes to specific EITs you can define date segments for Start and End Dates and use multiple rows of the EIT to track changes.
EITs and Security

Both special and extra information types use CustomForm and task flow security to restrict access to information. This means that you can restrict access to the information types as part of a specific user process. For example, in a ‘Transfer to the UK’ process you might want to enter additional UK specific information. You could design your user process to include a ‘UK Info’ window as part of the task flow and restrict the window to display only the UK information type.

To provide extra security for EITs, you must associate each EIT with the responsibilities that should have access to the information. For example, you might record details of an extended leave of absence in an EIT for an assignment and provide access only to managers who need to know.

Restricting Access to Extra Information

You can restrict access to EITs using a combination of the following:

- **Using menus and task flows**: Without the EIT window a user cannot see or change any extra information for the entity.

- **Using CustomForm and task flows**: This restricts EITs to specific user processes.

  For example, at the person level you might define EITs to hold medical details, security information and information required for working in other countries. In this situation you might want to create two custom task flows. The first with a button for entering only medical details and the second with a button for entering the other types of extra information.

- **Using responsibility level security**: For each responsibility, you must select the EITs to be viewed. CustomForm and task flow restrictions provide additional security. You might define that a responsibility can access an EIT, but users of this responsibility won’t be able to view the extra information unless they have access to a window that displays it.

  **Note**: This security does not apply to extra information on organizations.
Developer Flexfields

Oracle HRMS supplies two developer key flexfields and 16 developer descriptive flexfields. Your localization team has defined these flexfields, as required, to meet the specific legislative and reporting needs of your country.

The protected developer key flexfields are the Soft Coded Legislation key flexfield and the Bank Details key flexfield.

Of these 16 developer descriptive flexfields, 10 are protected and cannot be amended. The remaining six have Extra Information Types that you can use to customize your application.

See: Extra Information Types (EITs): page 1 – 26

The following table lists the protected developer descriptive flexfields.

<table>
<thead>
<tr>
<th>Title</th>
<th>Table Name</th>
<th>Window Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Further Absence Information</td>
<td>PER_ABSENCE_ATTENDANCES</td>
<td>Absence Detail</td>
</tr>
<tr>
<td>Further Collective Agreement Information</td>
<td>PER_COLLECTIVE_AGREEMENTS</td>
<td>Collective Agreements</td>
</tr>
<tr>
<td>Further Contract Information (Datetracked)</td>
<td>PER_CONTRACTS_F</td>
<td>Contracts</td>
</tr>
<tr>
<td>Further Element Information (Datetracked)</td>
<td>PAY_ELEMENT_TYPES_F</td>
<td>Element</td>
</tr>
<tr>
<td>Further Job Information</td>
<td>PER_JOBS</td>
<td>Job</td>
</tr>
<tr>
<td>Further Payment Method Information (Datetracked)</td>
<td>PAY_ORG_PAYMENT_METHODS_F</td>
<td>Organizational Payment Method</td>
</tr>
<tr>
<td>Further Payroll Information (Datetracked)</td>
<td>PAY_ALL_PAYROLLS_F</td>
<td>Payroll</td>
</tr>
<tr>
<td>Further Period Details</td>
<td>PER_TIME_PERIODS</td>
<td>Payroll Periods</td>
</tr>
<tr>
<td>Further Period of Service Information</td>
<td>PER_PERIOD_OF_SERVICE</td>
<td>Terminate</td>
</tr>
<tr>
<td>Further Person Information (Datetracked)</td>
<td>PER_PEOPLE_F</td>
<td>People, Applicant Entry</td>
</tr>
</tbody>
</table>

Protected Developer Descriptive Flexfields in Oracle HRMS

Your localization team determines which of these flexfields are required for your legislation, and what segments they should contain. The legislation of your Business Group determines which developer descriptive flexfields will be displayed. This means that if your enterprise uses multiple Business Groups that have different
legislations, different developer descriptive flexfields will be displayed for Business Groups of each legislation.

⚠️ **Warning:** Do not attempt to alter the definitions of these protected flexfields. These definitions are a fundamental part of Oracle HRMS. Any change to them may lead to errors in the operating of the system.

It is possible that Oracle HRMS will use other segments of these flexfields in the future. Therefore, do not add segments to any protected flexfield. This can affect your ability to upgrade your system in the future.

### Soft Coded Legislation Key Flexfield

This key flexfield holds legislation–specific information. The legislation of your Business Group determines the flexfield structure that you see.

Each localization team will define a flexfield structure, if required, which will enable you to enter information specific to your legislation at the employee assignment level.

### Bank Details Key Flexfield

This flexfield holds legislation–specific bank account information. The legislation of your Business Group determines the flexfield structure that you see. Each localization team defines a flexfield structure that allows you to record the bank account information relevant to your legislation. You enter this information in the Organizational Payment Method window and Personal Payment Method window.
User-Defined Tables

You may need to set up your own tables in your Oracle HRMS system, to hold data such as wage codes, shift differentials, or the amounts of certain deductions. You can set up all the tables you require using the Table Structure window. Using Oracle FastFormula, you can write simple formulas for validating entries made in table columns.

Your Oracle HRMS startup data includes some predefined user tables that are either ready to receive entries, or that already have some entries. Other legislations’ startup data includes some predefined user tables that are maintained by your Oracle localization team.

**Attention:** You do not use the Table Structure window to set up tables holding information on medical, dental or vision benefit plans (benefits with the benefits classification Medical, Dental or Vision).

The Oracle HRMS database includes a special table, the Benefits Table, already set up to hold information on benefit plans with coverage levels, and the employee and employer contributions at each level. To enter information into this table you use the Benefit Contributions window.

See: Establishing Health Care Benefit Coverage and Default Contributions, *Managing Compensation and Benefits Using Oracle HRMS*


Notice that the Oracle HRMS user-defined tables are different from the database tables of the Oracle Relational Database Management System. When you set up a user table, you define the rows as well as the columns, like a matrix. For example, you could set up a table showing bonus amounts (the column) against years of service (the rows).

**Entering and Accessing Table Values**

To enter values in tables, you use the Table Values window. Table entries and rows are both datetracked, so you can delete existing entries or rows, and add new ones, as of an effective date.

Oracle HRMS provides the GET_TABLE_VALUE function to access table values. You can yourself write formulas that include calls to this function, perhaps for QuickPaint inquiries. Also, it is easy for MIS personnel to write PL/SQL statements that call this function, to include in the code for a form or report process, for example.

The formulas for the predefined earnings types Regular Wages, Overtime, Shift Pay and GTL Imputed Income all include calls to this
function, as do the formulas the system generates for deductions with the amount rule Payroll Table.

Row Types for Payroll Tables

Tables set up to hold deduction amounts are called payroll tables. You need a payroll table when the amount of a deduction varies in accordance with a factor such as employee age, pay or job class.

To initiate a deduction with the amount rule Payroll Table, you must establish a row type. The formula for the deduction uses the row type to help determine which row of the table to go to for each employee’s deduction amount. Your startup data includes three predefined row types: Age Range, Salary Range and Job Class. You can set up any additional types you require.
US Pre-defined User Tables

Oracle HRMS supplies the following tables, already defined using the Table Structure window:

COMPANY WORK SCHEDULES Table

This table has several commonly-used work schedules already entered in it, and you can add more. A work schedule shows the hours employees normally work each day from Monday through Sunday. For example, employees with the schedule 10–10–10–10–0–0–0 work 10 hours each day Monday through Thursday, and have Friday, Saturday and Sunday off.

Each column in this table holds a separate schedule, with each row holding the hours worked each day of the week for the schedule. For convenience, each column header names the schedule held in the column. For example, the header for the column holding the first schedule is 1 Schedule: 8–8–8–8–8–0–0.

GTL PREMIUMS Table

For use in Oracle Payroll, this table holds the cost of Group Term Life insurance premiums per $1,000 of coverage by age range, as maintained in the IRS Uniform Premiums table. The table rows hold age ranges, and its single column holds the premium for each $1,000 of coverage for each age range.

Oracle Corporation provides you with updates to the GTL Premiums table, which your system administrator applies.

The predefined imputed earnings GTL Imputed Income references this table in its processing.

SHIFT DIFFERENTIALS Table

This table has no data already in it, but is ready for your data entry. Its rows hold the shift designators Day, Eve, Night and Split, representing the normal shifts employees work, and its columns have the same headings, for entry of differentials. You can add to or change the shift designators as necessary.

To look at examples of differentials entries, suppose day shift employees receive one and one-half times their regular pay when temporarily working the evening shift, twice their regular pay for the night shift, and three times their regular pay for the split shift. You enter 1.5, 2.0 and 3.0 as the differentials for day shift workers.
Example Shift Differentials Table

<table>
<thead>
<tr>
<th>Day</th>
<th>D</th>
<th>E</th>
<th>N</th>
<th>S</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>—</td>
<td>1.5</td>
<td>2.0</td>
<td>3.0</td>
</tr>
</tbody>
</table>

The predefined earnings types Regular Wages and Shift Pay reference this table in their processing in Oracle Payroll.

WAGE RATES Table

This table has no data in it when you receive your system, but is ready for your data entry. Its rows hold rate codes, and its single column holds the rate matching each code. This example holds codes for rates associated with the operation of different types of equipment:

**Example Wage Rates Table**

<table>
<thead>
<tr>
<th>Rate Code</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>FL (forklift)</td>
<td>6.80</td>
</tr>
<tr>
<td>A3 (crane A3)</td>
<td>8.20</td>
</tr>
<tr>
<td>A7 (crane A7)</td>
<td>9.00</td>
</tr>
</tbody>
</table>

Oracle Payroll’s predefined earnings types Regular Wages, Overtime, and Shift Pay reference this table in their processing.
Lookups

Providing lists of valid values for certain items of information has two key advantages:

- It ensures that all users use the same terminology, which makes it easier to inquire and report on the information.
- It speeds up data entry because you can enter just enough to identify the value, and the system completes the entry.

In Oracle HRMS, a list of values is called a Lookup type. Each value comprises a code and a meaning. For example:

<table>
<thead>
<tr>
<th>Lookup Type</th>
<th>Code</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>YES_NO</td>
<td>Y</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>N</td>
<td>No</td>
</tr>
</tbody>
</table>

The codes are used internally; users do not see them. There is a maximum of 250 Lookups for each Lookup type.

Predefined Lookup Types

A number of Lookup types are included in Oracle HRMS. Some contain codes as startup data. You can never delete these codes, but you can change their meaning. For some Lookup types, you can also disable the codes that are supplied. Your ability to disable codes and add new codes is determined by the access level of the Lookup type:

- **User**: You can add codes and you can disable supplied codes.
- **Extensible**: You can add new codes, but you cannot disable supplied codes because the system uses them.
- **System**: You can neither add codes nor disable supplied codes. You can only change the meaning or description of supplied codes.

See User and Extensible Lookups: page 1 – 37 for a list of the predefined Lookup types with an access level of User or Extensible.

You can also create your own Lookup Types in the Lookup type window. These all have an access level of User.

Global and Local Lookup Types

If you are using Cross Business Group Responsibility security Lookup types may be either global or local:
• Global lookup types are available to all Business Groups
• Local lookup types are only available to the Business Group/Security Group in which they are created.

Local lookups can be implemented in each of the following ways:

• You can create an override. This means that you retain the global name for the lookup type, but supply local values appropriate for your business group. The extent to which you can do this is determined by the access level for the lookup type.

• You can create an entirely new lookup type with lookup values that are only applicable to your local business group.

When you connect to any Business Group you will therefore have access to each of the following:

• The global lookup types and values
• Local overrides to the global lookup values
• Local lookup types and values
## User and Extensible Lookups

<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category (absence)</td>
<td>ABSENCE_CATEGORY</td>
</tr>
<tr>
<td>Reason (for absence)</td>
<td>ABSENCE_REASON</td>
</tr>
<tr>
<td>Account Type (for bank details)</td>
<td>ACC_TYPE</td>
</tr>
<tr>
<td>Categories (for activities, programs, packages)</td>
<td>ACTIVITY_CATEGORY</td>
</tr>
<tr>
<td>Successful attendance (for activity based events)</td>
<td>ACTIVITY_SUCCESS_CRITERIA</td>
</tr>
<tr>
<td>User Status (for an activity)</td>
<td>ACTIVITY_USER_STATUS</td>
</tr>
<tr>
<td>Address Type</td>
<td>ADDRESS_TYPE</td>
</tr>
<tr>
<td>Reason (for application assignment status)</td>
<td>APL_ASSIGN_REASON</td>
</tr>
<tr>
<td>Type (event type for applicant)</td>
<td>APL_EVENT_TYPE</td>
</tr>
<tr>
<td>Type (interview type for applicant)</td>
<td>APL_INTERVIEW_TYPE</td>
</tr>
<tr>
<td>Reason (for secondary assignment status)</td>
<td>APL_SEC_ASSIGN_REASON</td>
</tr>
<tr>
<td>Appraisal and Assessment Status (appraisal and assessment on SSHR)</td>
<td>APPRAISAL_ASSESSMENT_STATUS</td>
</tr>
<tr>
<td></td>
<td>APPRAISAL_SYSTEM_TYPE</td>
</tr>
<tr>
<td>Appraisal and Assessment Type (appraisal and assessment on SSHR)</td>
<td>APPRAISAL_TYPE</td>
</tr>
<tr>
<td>State (Australian addresses)</td>
<td>AU_STATE</td>
</tr>
<tr>
<td>Bank Account Branch</td>
<td>BANK_ACCOUNT_BRANCH</td>
</tr>
<tr>
<td>Bank Account Name</td>
<td>BANK_ACCOUNT_NAME</td>
</tr>
<tr>
<td>Bank Account Number</td>
<td>BANK_ACCOUNT_NUMBER</td>
</tr>
<tr>
<td>Bank Account Type</td>
<td>BANK_ACCOUNT_TYPE</td>
</tr>
<tr>
<td>Bargaining Unit (for assignment)</td>
<td>BARGAINING_UNIT_CODE</td>
</tr>
<tr>
<td>Action Status</td>
<td>BEN_ACTN_STAT</td>
</tr>
<tr>
<td>Action Type</td>
<td>BEN_ACTN_TYP</td>
</tr>
<tr>
<td>Field</td>
<td>Lookups</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>----------------------------------------------</td>
</tr>
<tr>
<td>Action Type Due Date</td>
<td>BEN_ACTN_TYP_DUE_DT</td>
</tr>
<tr>
<td>Activity Reference Period</td>
<td>BEN_ACTY_REF_PERD</td>
</tr>
<tr>
<td>Activity Type</td>
<td>BEN_ACTY_TYP</td>
</tr>
<tr>
<td>Age to Use</td>
<td>BEN_AGE_TO_USE_CD</td>
</tr>
<tr>
<td></td>
<td>BEN_BENMINGLE_MD</td>
</tr>
<tr>
<td></td>
<td>BEN_BENTMPCM_MD</td>
</tr>
<tr>
<td>Block</td>
<td>BEN_BLOCK</td>
</tr>
<tr>
<td>Boundary Period</td>
<td>BEN_BNDRY_PERD</td>
</tr>
<tr>
<td>Benefits Balance Usage</td>
<td>BEN_BNFTS_BAL_USG</td>
</tr>
<tr>
<td>Operation</td>
<td>BEN_BNFT_RT_TYP</td>
</tr>
<tr>
<td>Restrict Change Based On</td>
<td>BEN_BNFT_R_OPT_RSTRN</td>
</tr>
<tr>
<td>Certification Type</td>
<td>BEN_BNF_CTFN_TYP</td>
</tr>
<tr>
<td>Default Beneficiary Code</td>
<td>BEN_BNF_DFLT</td>
</tr>
<tr>
<td>Plan Beneficiary Designation Code</td>
<td>BEN_BNF_DSGN</td>
</tr>
<tr>
<td>Measures Allowed</td>
<td>BEN_BNF_PCT_AMT_ALWD</td>
</tr>
<tr>
<td>Benefit Type</td>
<td>BEN_BNF_TYP</td>
</tr>
<tr>
<td>Expression</td>
<td>BEN_BOOL</td>
</tr>
<tr>
<td>Close Enrollment Date to Use</td>
<td>BEN_CLS_ENRT_DT_TO_USE</td>
</tr>
<tr>
<td></td>
<td>BEN_CMCD_REF_PERD</td>
</tr>
<tr>
<td></td>
<td>BEN_CMPNT_REF</td>
</tr>
<tr>
<td>Claims to Coverage or Balance</td>
<td>BEN_CMPR_CLMS_TO_CVG_OR_BAL</td>
</tr>
<tr>
<td></td>
<td>BEN_CMP_ENRT_ACTN_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_CM_TRGR_SRC</td>
</tr>
<tr>
<td>Type of Trigger</td>
<td>BEN_CM_TRGR_TYP</td>
</tr>
<tr>
<td>Usage</td>
<td>BEN_CM_USG</td>
</tr>
<tr>
<td></td>
<td>BEN_CM_USG_ARA</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_COMP_ALT_VAL_T0_USE</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compensation Category</td>
<td>BEN_COMP_TYP</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_CRT_ORDR_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_CTL_TTL_TYP</td>
</tr>
<tr>
<td>Value Calculation Rule</td>
<td>BEN_CVG_CALC_MTHD_RL</td>
</tr>
<tr>
<td></td>
<td>BEN_CVG_DET_DT</td>
</tr>
<tr>
<td>Validate</td>
<td>BEN_DB_UPD_MD</td>
</tr>
<tr>
<td>Deduction Schedule</td>
<td>BENDED_SCHED</td>
</tr>
<tr>
<td>Default Enrollment Code</td>
<td>BEN_DFLT_ENRT</td>
</tr>
<tr>
<td>Default Enrollment Method Code</td>
<td>BEN_DFLT_ENRT_MTHD</td>
</tr>
<tr>
<td>Default Excess Treatment</td>
<td>BEN_DFLT_EXCS_TRMT</td>
</tr>
<tr>
<td>Assign Code</td>
<td>BEN_DFLT_TO_ASN_PNDG_CTFN</td>
</tr>
<tr>
<td>Delivery Medium</td>
<td>BEN_DLVRY_MED</td>
</tr>
<tr>
<td>Delivery Method</td>
<td>BEN_DLVRY_MTHD</td>
</tr>
<tr>
<td></td>
<td>BEN_DLVRY_SCHED_INFO</td>
</tr>
<tr>
<td>Dependent Coverage Certification Type</td>
<td>BEN_DPNT_CVG_CTFN_TYP</td>
</tr>
<tr>
<td>Dependent Coverage End Date</td>
<td>BEN_DPNT_CVG_END</td>
</tr>
<tr>
<td>Dependent Coverage Start Date</td>
<td>BEN_DPNT_CVG_STRT</td>
</tr>
<tr>
<td></td>
<td>BEN_DRVBL_FCTR_PRPS</td>
</tr>
<tr>
<td></td>
<td>BEN_DRVBL_FCTR_UOM_PRPS</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_DSGN_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_DTA_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_DY_NAME</td>
</tr>
<tr>
<td></td>
<td>BEN_ELIG_ENRL</td>
</tr>
<tr>
<td>Eligible/Ineligible</td>
<td>BEN_ELIG_INELIG</td>
</tr>
<tr>
<td></td>
<td>BEN_ENRL_DET_DT</td>
</tr>
<tr>
<td></td>
<td>BEN_ENRT</td>
</tr>
<tr>
<td>Enrollment Certification Type</td>
<td>BEN_ENRT_CTFN_TYP</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enrollment Coverage End Date Code</td>
<td>BEN_ENRT_CVG_END</td>
</tr>
<tr>
<td>Enrollment Coverage Start Date Code</td>
<td>BEN_ENRT_CVG_STRT</td>
</tr>
<tr>
<td>Enrollment Period End Dates Code</td>
<td>BEN_ENRT_PERD_END</td>
</tr>
<tr>
<td>Enrollment Period Start Dates Code</td>
<td>BEN_ENRT_PERD_STRT</td>
</tr>
<tr>
<td>Enrollment Period End Dates Code</td>
<td>BEN_ENRT_RSLT_MTHD</td>
</tr>
<tr>
<td>Enrollment Period Start Dates Code</td>
<td>BEN_ENRT_R_BNFT_CTFN</td>
</tr>
<tr>
<td>Enrollment Type</td>
<td>BEN_ENRT_TYP_CYCL</td>
</tr>
<tr>
<td>Foreign Earning/Deduction Type</td>
<td>BEN_ERG_DED</td>
</tr>
<tr>
<td>Collapsing Logic Code</td>
<td>BEN_EVAL</td>
</tr>
<tr>
<td>Life Event Occurred Date Code</td>
<td>BEN_EVAL_DET</td>
</tr>
<tr>
<td>Event</td>
<td>BEN_EVENT</td>
</tr>
<tr>
<td>Excess Treatment</td>
<td>BEN_EXCS_TRTMT</td>
</tr>
<tr>
<td>Change Event</td>
<td>BEN_EXT_CHG_EVT</td>
</tr>
<tr>
<td>Format Mask</td>
<td>BEN_EXT_FRMT_MASK</td>
</tr>
<tr>
<td>Run Status</td>
<td>BEN_EXT_STAT</td>
</tr>
<tr>
<td>Condition (Optional) Where</td>
<td>BEN_EXT_TTL_COND_OPER</td>
</tr>
<tr>
<td>Total Information Function</td>
<td>BEN_EXT_TTL_FNCTN</td>
</tr>
<tr>
<td>Field</td>
<td>BEN_FIELD</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_FILEigrate</td>
</tr>
<tr>
<td>Frequency</td>
<td>BEN_FREQ</td>
</tr>
<tr>
<td>Family Member Code</td>
<td>BEN_FMLY_MMBR</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Usage</td>
<td>BEN_GD_OR_SVC_USG</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_GD_R_SVC_TYP</td>
</tr>
<tr>
<td>Group Relationship</td>
<td>BEN_GRP_RLSHP</td>
</tr>
<tr>
<td>Health Service</td>
<td>BEN_HLTH_CARE_SVC_TYP</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_HRS_ALT_VAL_TO_USE</td>
</tr>
<tr>
<td>Determination Code</td>
<td>BEN_HRS_WKD_DET</td>
</tr>
<tr>
<td>Source</td>
<td>BEN_HRS_WKD_SRC</td>
</tr>
<tr>
<td>Subject to Imputed Income</td>
<td>BEN_IMPTD_INCM_CALC</td>
</tr>
<tr>
<td>Imputed Income Type</td>
<td>BEN_IMPTD_INCM_TYP</td>
</tr>
<tr>
<td>Timeliness Evaluation</td>
<td>BEN_LER_TMLNS_EVAL</td>
</tr>
<tr>
<td>Timeliness Period</td>
<td>BEN_LER_TMLNS_PERD</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_LER_TYP</td>
</tr>
<tr>
<td>Determination</td>
<td>BEN_LMT_DET</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_LOS_ALT_VAL_TO_USE</td>
</tr>
<tr>
<td>Determination Code</td>
<td>BEN_LOS_DET</td>
</tr>
<tr>
<td>Date to Use Code</td>
<td>BEN_LOS_DT_TO_USE</td>
</tr>
<tr>
<td>Maximum Enrollment Determination Date Code</td>
<td>BEN_MX_POE_DET_DT</td>
</tr>
<tr>
<td></td>
<td>BEN_MX_WTG_DT_TO_USE</td>
</tr>
<tr>
<td></td>
<td>BEN_MX_WTG_PERD_PRTE_DET</td>
</tr>
</tbody>
</table>

User and Extensible Lookups
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Non–Monetary UOM</td>
<td>BEN_NNMTRTRY_UOM</td>
</tr>
<tr>
<td>Occurred Date Determination</td>
<td>BEN_OCRD_DT_DET</td>
</tr>
<tr>
<td>Self Service Display</td>
<td>BEN_OPT_DSPLY_FMT</td>
</tr>
<tr>
<td>Organization Roles</td>
<td>BEN_ORG_ROLE_TYP</td>
</tr>
<tr>
<td>Once or Continuing</td>
<td>BEN_ONCE_R_CNTNG</td>
</tr>
<tr>
<td>Desktop Activities</td>
<td>BEN_ON_LINE_ACT</td>
</tr>
<tr>
<td>Option Type</td>
<td>BEN_OPT_TYP</td>
</tr>
<tr>
<td>Reason</td>
<td>BEN_OVRID_RSN</td>
</tr>
<tr>
<td></td>
<td>BEN_PCP_CD</td>
</tr>
<tr>
<td></td>
<td>BEN_PCT_AMT_ALWD</td>
</tr>
<tr>
<td></td>
<td>BEN_PCT_FL_TM_DET</td>
</tr>
<tr>
<td>Part of Kit</td>
<td>BEN_PC_KIT</td>
</tr>
<tr>
<td>Period Type</td>
<td>BEN_PERD_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_PER_CM_PRVDD_STAT</td>
</tr>
<tr>
<td></td>
<td>BEN_PER_CVRD</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_PER_IN_LER_STAT</td>
</tr>
<tr>
<td>Program Group</td>
<td>BEN_PGM_GRP</td>
</tr>
<tr>
<td>Program Type</td>
<td>BEN_PGM_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_PIN_PRPS</td>
</tr>
<tr>
<td>Plan Usage</td>
<td>BEN_PL</td>
</tr>
<tr>
<td></td>
<td>BEN_PL_YR_TYP</td>
</tr>
<tr>
<td>Assignment</td>
<td>BEN_PREM ASNMT</td>
</tr>
<tr>
<td>Assignment Level</td>
<td>BEN_PREM ASNMT_LVL</td>
</tr>
<tr>
<td>Payer</td>
<td>BEN_PREM_PYR</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_PREM_TYP</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_PRMRY_CARE_PRVDR_TYP</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_PRMRY_CNTNGNT</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary Funding Method</td>
<td>BEN_PRMRY_FNDG_MTHD</td>
</tr>
<tr>
<td>Parent/Child</td>
<td>BEN_PRNT_CHLD</td>
</tr>
<tr>
<td></td>
<td>BEN_PROC</td>
</tr>
<tr>
<td>Processing Source</td>
<td>BEN_PROCG_SRC</td>
</tr>
<tr>
<td></td>
<td>BEN_PRORT_PRTL_YR_CVG_RSTRN</td>
</tr>
<tr>
<td>Prospective/Retrospective</td>
<td>BEN_PRSPCTV_R_RTSPCTV</td>
</tr>
<tr>
<td>Partial Month Determination Code</td>
<td>BEN_PRTL_MO_DET_MTHD</td>
</tr>
<tr>
<td>Partial Month Determination Effective Date Code</td>
<td>BEN_PRTL_MO_EFFECT_DT_DET</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTL_YR_CVG_RSTN</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTN_CTFN_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTN_ELIG_END</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTN_ELIG_STRT</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTT_DET</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTT_DPNT_CVRD_STAT</td>
</tr>
<tr>
<td></td>
<td>BEN_PRTT_EPNT_RSLT_STAT</td>
</tr>
<tr>
<td></td>
<td>BEN_PTD</td>
</tr>
<tr>
<td></td>
<td>BEN_PTNL_LER_FOR_PER_SRC</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_PTNL_LER_FOR_PER_STAT</td>
</tr>
<tr>
<td></td>
<td>BEN_PYMT</td>
</tr>
<tr>
<td></td>
<td>BEN_PYMT_DET_MTHD</td>
</tr>
<tr>
<td></td>
<td>BEN_PYMT_MUST_BE_RECD</td>
</tr>
<tr>
<td>Payment Schedule</td>
<td>BEN_PYMT_SCHED</td>
</tr>
<tr>
<td>QDRO Payment Distribution</td>
<td>BEN_QDRO_DSTR_MTHD</td>
</tr>
<tr>
<td>Recipient Code</td>
<td>BEN_RCPENT</td>
</tr>
<tr>
<td>Recurring</td>
<td>BEN_RCRRG</td>
</tr>
<tr>
<td></td>
<td>BEN_RECON_PLCY</td>
</tr>
<tr>
<td></td>
<td>BEN_REF_PERD</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrative Code</td>
<td>BEN_REGN_ADMIN</td>
</tr>
<tr>
<td>Regulatory Plan Type</td>
<td>BEN_REGY_PL_TYP</td>
</tr>
<tr>
<td>Regulatory Purpose</td>
<td>BEN_REGY_PRPS</td>
</tr>
<tr>
<td>Type</td>
<td>BEN_REIMBMT_CTFN_TYP</td>
</tr>
<tr>
<td></td>
<td>BEN_REIMBT_RQST_RCRG</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_REIMBT_RQST_STAT</td>
</tr>
<tr>
<td>Purpose</td>
<td>BEN_RPTG_PRPS</td>
</tr>
<tr>
<td></td>
<td>BEN_RQD_ENRL_PERD_TOC</td>
</tr>
<tr>
<td></td>
<td>BEN_RQD_PERD_ENRT_NENRT_TM_UOM</td>
</tr>
<tr>
<td>Rate End Date Code</td>
<td>BEN_RT_END</td>
</tr>
<tr>
<td></td>
<td>BEN_RT_RL_IMPCT</td>
</tr>
<tr>
<td>Rate Start Date Code</td>
<td>BEN_RT_STRT</td>
</tr>
<tr>
<td></td>
<td>BEN_SCHED_INFO</td>
</tr>
<tr>
<td>Costing Method Code</td>
<td>BEN_SGMT_CSTG_MTHD</td>
</tr>
<tr>
<td>Status</td>
<td>BEN_STAT</td>
</tr>
<tr>
<td>Start/Stop Coverage Code</td>
<td>BEN_STRT_R_STP_CVG</td>
</tr>
<tr>
<td></td>
<td>BEN_SVC_DT_TO_USE</td>
</tr>
<tr>
<td></td>
<td>BEN_TCO_CHG_ENRT</td>
</tr>
<tr>
<td></td>
<td>BEN_TM_UOM</td>
</tr>
<tr>
<td>To Be Sent</td>
<td>BEN_TO_BE_SENT_DT</td>
</tr>
<tr>
<td></td>
<td>BEN_TRNSMSN_CALCS</td>
</tr>
<tr>
<td>Tax Type</td>
<td>BEN_TX_TYP</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unsuspend Code</td>
<td>BEN_UNSSPND_ENRT</td>
</tr>
<tr>
<td></td>
<td>BEN_UPDT_TYP</td>
</tr>
<tr>
<td>Usage</td>
<td>BEN_USG</td>
</tr>
<tr>
<td>Alternate Value</td>
<td>BEN_VAL_TO_USE</td>
</tr>
<tr>
<td></td>
<td>BEN_WHN_TO_PRCS_LER</td>
</tr>
<tr>
<td></td>
<td>BEN_WTG_PERD_DT</td>
</tr>
<tr>
<td>Waiting Period UOM</td>
<td>BEN_WTG_PERD_UOM</td>
</tr>
<tr>
<td>Waive Coverage Reason</td>
<td>BEN_WV_CVG_RSN</td>
</tr>
<tr>
<td>Waive Participation Certification Type</td>
<td>BEN_WV_PRTN_CTFN_TYP</td>
</tr>
<tr>
<td>Waiving Participation Reason</td>
<td>BEN_WV_PRTN_RSN</td>
</tr>
<tr>
<td>Waive Type</td>
<td>BEN_WV_TYP</td>
</tr>
<tr>
<td>Blood Type</td>
<td>BLOOD_TYPE</td>
</tr>
<tr>
<td>Source of student</td>
<td>BOOKING_SOURCE</td>
</tr>
<tr>
<td>Measurement Type (for budget)</td>
<td>BUDGET_MEASUREMENT_TYPE</td>
</tr>
<tr>
<td>Cash Analysis (for a cash payment)</td>
<td>CASH_ANALYSIS</td>
</tr>
<tr>
<td>Census Metropolitan Area (Canada)</td>
<td>CA_CMA</td>
</tr>
<tr>
<td>Select Form to be printed (Canada)</td>
<td>CA_FORM_NAME</td>
</tr>
<tr>
<td></td>
<td>CA_INVOlutARY_DEDUCTIONS</td>
</tr>
<tr>
<td></td>
<td>CA_PAYMENT</td>
</tr>
<tr>
<td>Province (Canadian addresses)</td>
<td>CA_PROVINCE</td>
</tr>
<tr>
<td></td>
<td>CA_REGULAR_EARNINGS</td>
</tr>
<tr>
<td></td>
<td>CA_TAXABLE_BENEFITS</td>
</tr>
<tr>
<td></td>
<td>CA_SUPPLEMENTAL_EARNINGS</td>
</tr>
<tr>
<td></td>
<td>CA_VOLUNTARY_DEDUCTIONS</td>
</tr>
<tr>
<td>Method</td>
<td>CERTIFICATION_METHOD</td>
</tr>
<tr>
<td>List of Swiss Cantons</td>
<td>CH_CANTON</td>
</tr>
<tr>
<td></td>
<td>CHECKBOX</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>User friendly names for cheque/check–ordering SQL statement</td>
<td>CHEQUE_PROCEDURE</td>
</tr>
<tr>
<td>User friendly names for cheque/check–writing SRW2 reports.</td>
<td>CHEQUE_REPORT</td>
</tr>
<tr>
<td>Company Age (for salary surveys mappings)</td>
<td>COMPANY_AGE</td>
</tr>
<tr>
<td>Company Size (for salary surveys)</td>
<td>COMPANY_SIZE</td>
</tr>
<tr>
<td>Primary Evaluation Method</td>
<td>COMPETENCE_EVAL_TYPE</td>
</tr>
<tr>
<td>Competence Type</td>
<td>COMPETENCE_TYPE</td>
</tr>
<tr>
<td>Type (relationship of one person to another)</td>
<td>CONTACT</td>
</tr>
<tr>
<td>Contract End Reason</td>
<td>CONTRACT_END_REASON</td>
</tr>
<tr>
<td>Contract Start Reason</td>
<td>CONTRACT_START_REASON</td>
</tr>
<tr>
<td>Contract Status</td>
<td>CONTRACT_STATUS</td>
</tr>
<tr>
<td>Contract Status Reason</td>
<td>CONTRACT_STATUS_REASON</td>
</tr>
<tr>
<td>Contract Types</td>
<td>CONTRACT_TYPE</td>
</tr>
<tr>
<td>Type (of MIX batch control total)</td>
<td>CONTROL_TYPE</td>
</tr>
<tr>
<td>Reason a student failed to successfully complete an event.</td>
<td>DELEGATE_FAILURE_REASON</td>
</tr>
<tr>
<td>User defined Type to categorize development events.</td>
<td>DEV_EVENT_TYPE</td>
</tr>
<tr>
<td></td>
<td>DE_REGION</td>
</tr>
<tr>
<td>Reason (for element entry)</td>
<td>ELE_ENTRY_REASON</td>
</tr>
<tr>
<td>Reason (for employee assignment)</td>
<td>EMP_ASSIGN_REASON</td>
</tr>
<tr>
<td>Employment Category</td>
<td>EMP_CAT</td>
</tr>
<tr>
<td>Type (of employee event)</td>
<td>EMP_EVENT_TYPE</td>
</tr>
<tr>
<td>Type (of interview for employee)</td>
<td>EMP_INTERVIEW_TYPE</td>
</tr>
<tr>
<td>Reason (for secondary assignment status)</td>
<td>EMP_SEC_ASSIGN_REASON</td>
</tr>
<tr>
<td>Reason (for change in enrollment status)</td>
<td>ENROLLMENT_STATUS_REASON</td>
</tr>
<tr>
<td>Ethnic Origin</td>
<td>ETH_TYPE</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>System (job or position evaluation system)</td>
<td>EVAL_SYSTEM</td>
</tr>
<tr>
<td>Measurement In (type for EVAL.SYSTEM)</td>
<td>EVAL_SYSTEM_MEAS</td>
</tr>
<tr>
<td>User defined status for an event</td>
<td>EVENT_USER_STATUS</td>
</tr>
<tr>
<td>Type (of work pattern exception)</td>
<td>EXCEPTIONCATEGORY</td>
</tr>
<tr>
<td>Type (of finance line)</td>
<td>FINANCE_LINE_TYPE</td>
</tr>
<tr>
<td>Type (of formula)</td>
<td>FORMULA_TYPE</td>
</tr>
<tr>
<td>FR_REGION</td>
<td></td>
</tr>
<tr>
<td>Frequency (eg per week, per month)</td>
<td>FREQUENCY</td>
</tr>
<tr>
<td>Authority (for PAYE details)</td>
<td>GB_Authority</td>
</tr>
<tr>
<td>Bank Name</td>
<td>GB_BANKS</td>
</tr>
<tr>
<td>Certificate (for element NI)</td>
<td>GB_CERTIFICATE</td>
</tr>
<tr>
<td>Cheque/Check Style</td>
<td>GB_CHEQUE_REPORT</td>
</tr>
<tr>
<td>County (UK addresses)</td>
<td>GB_COUNTY</td>
</tr>
<tr>
<td>Pay day type</td>
<td>GB_PAY_DAY_TYPE</td>
</tr>
<tr>
<td>Pension</td>
<td>GB_PENSION</td>
</tr>
<tr>
<td>Allows users to define valid SCON number for NI SCON input</td>
<td>GB_SCON</td>
</tr>
<tr>
<td>Sequence (for the BACS process)</td>
<td>GB_SORT_SEQUENCE</td>
</tr>
<tr>
<td>Date Posted</td>
<td>HR_APPLICATION_DATE</td>
</tr>
<tr>
<td>Hire Date</td>
<td>HR_HIRE_DATE</td>
</tr>
<tr>
<td>Date Posted</td>
<td>HR_JOB_POSTED_DATE</td>
</tr>
<tr>
<td>Batch process used by OTM</td>
<td>HXT_BATCH_STATUS</td>
</tr>
<tr>
<td>Days of the week</td>
<td>HXT_DAY_OF_WEEK</td>
</tr>
<tr>
<td>Process modes used by OTM</td>
<td>HXT_PROCESS_MODE</td>
</tr>
<tr>
<td>IE_COUNTY</td>
<td></td>
</tr>
<tr>
<td>Industry (for salary survey)</td>
<td>INDUSTRY</td>
</tr>
<tr>
<td>Extra Job Information</td>
<td>JOB_CATEGORY</td>
</tr>
</tbody>
</table>

User and Extensible Lookups
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Categories of Jobs</td>
<td>JOB_CATEGORIES</td>
</tr>
<tr>
<td>Reason (for leaving)</td>
<td>LEAV_REAS</td>
</tr>
<tr>
<td></td>
<td>LOCAL_BAL_FORM_NAME</td>
</tr>
<tr>
<td>Marital Status</td>
<td>MAR_STATUS</td>
</tr>
<tr>
<td></td>
<td>MX_STATE</td>
</tr>
<tr>
<td></td>
<td>MY_STATE</td>
</tr>
<tr>
<td>North American Industry Code for Canada</td>
<td>NAIC</td>
</tr>
<tr>
<td>Nationality</td>
<td>NATIONALITY</td>
</tr>
<tr>
<td>NI Unique Error or Warning</td>
<td>NI_UNIQUE_ERROR_WARNING</td>
</tr>
<tr>
<td></td>
<td>NL_REGION</td>
</tr>
<tr>
<td></td>
<td>NZ_COUNTIES</td>
</tr>
<tr>
<td>Name (of organization classification)</td>
<td>ORG_CLASS</td>
</tr>
<tr>
<td>Organization Type</td>
<td>ORG_TYPE</td>
</tr>
<tr>
<td>Class Begins</td>
<td>OTA_ENROLL_CLASS_DATE</td>
</tr>
<tr>
<td>Use to which a work pattern is or may be put</td>
<td>PATTERN_PURPOSE</td>
</tr>
<tr>
<td>Type of checksum used for deductions batches</td>
<td>PAY_PDT_DED_CKSUM</td>
</tr>
<tr>
<td>Type of checksum used for earnings deductions batches</td>
<td>PAY_PDT_EARN_CKSUM</td>
</tr>
<tr>
<td>Type of checksum used for time entry batches</td>
<td>PAY_PDT_TIME_CKSUM</td>
</tr>
<tr>
<td>Category</td>
<td>PER_CATEGORIES</td>
</tr>
<tr>
<td>Communication delivery method</td>
<td>PER_CM_MTHD</td>
</tr>
<tr>
<td>FTE Capacity</td>
<td>PER_FTE_CAPACITY</td>
</tr>
<tr>
<td>Minimum Service</td>
<td>PER_LENGTHS_OF_SERVICE</td>
</tr>
<tr>
<td>Relocation</td>
<td>PER_RELOCATION_PREFERENCES</td>
</tr>
<tr>
<td>Status</td>
<td>PER_SUBJECT_STATUSES</td>
</tr>
<tr>
<td>Subject</td>
<td>PER_SUBJECTS</td>
</tr>
<tr>
<td>Work Duration</td>
<td>PER_TIME_SCALES</td>
</tr>
</tbody>
</table>

User and Extensible Lookups
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tuition Method</td>
<td>PER_TUITION_METHODS</td>
</tr>
<tr>
<td>I9 Status</td>
<td>PER_US_I9_STATE</td>
</tr>
<tr>
<td>Work Hours</td>
<td>PER_WORK_HOURS</td>
</tr>
<tr>
<td>Work Schedule</td>
<td>PER_WORK_SCHEDULE</td>
</tr>
<tr>
<td>Rating</td>
<td>PERFORMANCE_RATING</td>
</tr>
<tr>
<td>Type</td>
<td>PHONE_TYPE</td>
</tr>
<tr>
<td>Reason (for grade step placement)</td>
<td>PLACEMENT_REASON</td>
</tr>
<tr>
<td>Position Family</td>
<td>POSITION_FAMILY</td>
</tr>
<tr>
<td>Status (of reserved position)</td>
<td>POSITION_RESERVED_STATUS</td>
</tr>
<tr>
<td>Status (of position)</td>
<td>POSITION_STATUS</td>
</tr>
<tr>
<td>Student Enrollments Priority</td>
<td>PRIORITY_LEVEL</td>
</tr>
<tr>
<td>Type (of Professional Credits)</td>
<td>PROFESSIONAL_CREDIT_TYPE</td>
</tr>
<tr>
<td>Source of Proficiency Rating</td>
<td>PROFICIENCY_SOURCE</td>
</tr>
<tr>
<td>A label given to group events within a program</td>
<td>PROGRAM_MEMBERSHIP_GROUP</td>
</tr>
<tr>
<td>Reason (for salary proposal)</td>
<td>PROPOSAL_REASON</td>
</tr>
<tr>
<td>Units (qualifying units for probation period)</td>
<td>QUALIFYING_UNITS</td>
</tr>
<tr>
<td>Type (of recruitment activity, also used in application source)</td>
<td>REC_TYPE</td>
</tr>
<tr>
<td>Type (of resource)</td>
<td>RESOURCE_TYPE</td>
</tr>
<tr>
<td>Reason (a resource is used by an activity)</td>
<td>RESOURCE_USAGE_REASON</td>
</tr>
<tr>
<td>Survey Age (for salary surveys)</td>
<td>SURVEY_AGE</td>
</tr>
<tr>
<td>Survey Company (for salary surveys)</td>
<td>SURVEY_COMPANY</td>
</tr>
<tr>
<td>Job Name (for salary surveys)</td>
<td>SURVEY_JOB_NAME</td>
</tr>
<tr>
<td>Region (for salary surveys)</td>
<td>SURVEY_REGION</td>
</tr>
<tr>
<td>Seniority (for salary surveys)</td>
<td>SURVEY_SENIORITY</td>
</tr>
<tr>
<td>Reason (for terminating application)</td>
<td>TERM_APL_REASON</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prefix</td>
<td>TITLE</td>
</tr>
<tr>
<td>Uses Tobacco (for benefits)</td>
<td>TOBACCO_USER</td>
</tr>
<tr>
<td>Role (of trainer in event)</td>
<td>TRAINER_PARTICIPATION</td>
</tr>
<tr>
<td>Center (where event takes place)</td>
<td>TRAINING_CENTRE</td>
</tr>
<tr>
<td>Type (of unit for event pricing)</td>
<td>TRAINING_UNIT</td>
</tr>
<tr>
<td>Accrual Start</td>
<td>US_ACCRUAL_START_TYPE</td>
</tr>
<tr>
<td>Status of request for accommodation</td>
<td>US_ADA_STATUSES</td>
</tr>
<tr>
<td>Coverage Level (for medical, dental and vision benefit plans)</td>
<td>US_BENEFIT_COVERAGE</td>
</tr>
<tr>
<td>Status (of continued coverage)</td>
<td>US_COBRA_STATUS</td>
</tr>
<tr>
<td>Reason (for COBRA Termination)</td>
<td>US_COBRA_TERM_REASON</td>
</tr>
<tr>
<td>Category (within Earnings classification)</td>
<td>US_EARNINGS</td>
</tr>
<tr>
<td>Category (within Imputed Earnings classification)</td>
<td>US_IMPUTED_EARNINGS</td>
</tr>
<tr>
<td>Category (within Information classification)</td>
<td>US_INFORMATION</td>
</tr>
<tr>
<td>Category (within Involuntary Deductions classification)</td>
<td>US_INVOLUNTARY_DEDUCTIONS</td>
</tr>
<tr>
<td>Job Groups</td>
<td>US_JOB_GROUPS</td>
</tr>
<tr>
<td>Filing Status for local income tax</td>
<td>US_LIT_FILING_STATUS</td>
</tr>
<tr>
<td>Exemption Reason (for excluding employee from New Hire report)</td>
<td>US_NEW_HIRE_EXCEPTIONS</td>
</tr>
<tr>
<td>Category (within Nonpayroll Payments classification)</td>
<td>US_PAYMENT</td>
</tr>
<tr>
<td>Category (of accrual plan)</td>
<td>US_PTO_ACCRUAL</td>
</tr>
<tr>
<td>Filing Status for state income tax</td>
<td>US_SIT_FILING_STATUS</td>
</tr>
<tr>
<td>State (US addresses)</td>
<td>US_STATE</td>
</tr>
<tr>
<td>Category (within Supplemental Earnings classification)</td>
<td>US_SUPPLEMENTAL_EARNINGS</td>
</tr>
<tr>
<td>Row Type (for Payroll Tables)</td>
<td>US_TABLE_ROW_TYPES</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**

US_TAX_REPORT
<table>
<thead>
<tr>
<th>Field</th>
<th>Lookups</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category (within Voluntary Deductions classification)</td>
<td>US_VOLUNTARY_DEDUCTIONS</td>
</tr>
<tr>
<td>Position of WC surcharge (after experience modifications and after premium discount)</td>
<td>US_WC_SURCHARGE_POSITION</td>
</tr>
<tr>
<td>Status (of a vacancy)</td>
<td>VACANCY_STATUS</td>
</tr>
<tr>
<td>Category (of a vacancy, for use in HR Direct Access)</td>
<td>VACANCY_CATEGORY</td>
</tr>
<tr>
<td>User friendly names for cheque writing SRW2 reports</td>
<td>W2_BOX-14_USER_DEFINED</td>
</tr>
<tr>
<td>Name (of global used in workflow)</td>
<td>WF_GLOBAL</td>
</tr>
<tr>
<td>Availability Schedule</td>
<td>WORK_SCHEDULE</td>
</tr>
</tbody>
</table>

**User and Extensible Lookups**
CUSTOM Library Events

Generic Events

An event is a point within the processing of a form at which you can call custom code from the CUSTOM library. For example, the event WHEN–FORM–NAVIGATE enables you to code a sequence of logic that will fire after any existing logic for the form, block or item. WHEN–FORM–NAVIGATE is an example of a generic event available to all the windows in Oracle Applications. For a complete list of generic events see: Events Passed to the CUSTOM Library, Oracle Applications Developer’s Guide.

Product Specific Events

In addition to generic events, Oracle HRMS provides a range of product specific events that enable you to make CUSTOM library calls to support your business rules. The product specific events for HRMS are available for most HRMS windows.

<table>
<thead>
<tr>
<th>Event Name</th>
<th>Purpose</th>
<th>When Occurs</th>
</tr>
</thead>
<tbody>
<tr>
<td>WHEN–CREATE–RECORD</td>
<td>Enables you to specify values that will appear by default when you create a new record.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>POST–QUERY</td>
<td>Enables you to add additional derivation or validation on completion of a query.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>KEY–DELREC</td>
<td>Enables you to add an extra level of validation before users are allowed to delete a record from the database.</td>
<td>Immediately before the user is asked to confirm the deletion of the record.</td>
</tr>
<tr>
<td>PRE–UPDATE, PRE–INSERT and PRE–DELETE</td>
<td>Enable you to add additional validation before the update, insert or delete action is performed. We do not recommend using these events for validation.</td>
<td>After any data validation. Before DateTrack manipulation if the block contains DateTrack features.</td>
</tr>
<tr>
<td>POST–INSERT, POST–UPDATE and POST–DELETE</td>
<td>Enable you to add additional insert, update, or delete actions to user tables.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>POST–FORMS–COMMIT</td>
<td>Enables you to specify an action to occur as the last action in a sequence of commit actions.</td>
<td>After the form has processed.</td>
</tr>
<tr>
<td>Event Name</td>
<td>Purpose</td>
<td>When Occurs</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>WHEN–BUTTON–PRESSED</td>
<td>Enables you to perform custom validation before a button action is performed.</td>
<td>After any data validation. Before any action (for example, display new window) has been performed.</td>
</tr>
<tr>
<td>DT_CALL_HISTORY</td>
<td>Enables you to change which database view is used by DateTrack History.</td>
<td>After the user has requested to use DateTrack History and the form has derived the standard details. Before the DateTrack History window is visible.</td>
</tr>
<tr>
<td>DT_SELECT_MODE</td>
<td>Enables you to restrict the DateTrack modes that a user can select.</td>
<td>After the form has derived which DateTrack modes are available but before the mode selection window is visible.</td>
</tr>
</tbody>
</table>

Additionally, there is the NAVIGATE product specific event. This is passed to the CUSTOM library whenever a user selects a task flow navigation option and prior to opening the new window. The following field values are set for the duration of this event:

- CTL_GLOBALS.DESTINATION_FORM
- CTL_GLOBALS.DESTINATION_BLOCK

You can use this event to supplement the validation that takes place when a task flow navigation option is selected.
Example Script to Register EITs

WHENEVER SQLERROR EXIT FAILURE ROLLBACK
REM /* $Header: example.sql */
REM==============================================
REM SQL Script File Name : example.sql
REM Description : This sql script inserts information
REM types into the following tables:
REM 1) PER_ASSIGNMENT_INFO_TYPES
REM 2) HR_LOCATION_INFO_TYPES
REM 3) PER_PEOPLE_INFO_TYPES
REM 4) PER_POSITION_INFO_TYPES
REM 5) PER_JOB_INFO_TYPES
REM 6) HR_ORG_INFORMATION_TYPES
REM 7) HR_ORG_INFO_TYPES_BY_CLASS
REM==============================================

— 1) Insert into PER_ASSIGNMENT_INFO_TYPES:
—

INSERT INTO PER_ASSIGNMENT_INFO_TYPES
(INFORMATION_TYPE,
ACTIVE_INACTIVE_FLAG,
MULTIPLE_OCCURRENCES_FLAG,
DESCRIPTION,
LEGISLATION_CODE,
OBJECT_VERSION_NUMBER )
SELECT
'<Info Type Name>','Y','<Y for multi-row – N for single>','<Description>','<legislation code US/GB/etc>'
1
FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_ASSIGNMENT_INFO_TYPES
WHERE INFORMATION_TYPE = '<Info Type Name>');
2) Insert into HR_LOCATION_INFO_TYPES:

INSERT INTO HR_LOCATION_INFO_TYPES
(INFORMATION_TYPE ,ACTIVE_INACTIVE_FLAG ,MULTIPLE_OCCURRENCES_FLAG ,DESCRIPTION ,LEGISLATION_CODE ,OBJECT_VERSION_NUMBER )
SELECT
'<Location EIT Name>' , 'Y' , '<Y for multi-row – N for single>' , '<Description>' , '<legislation code US/GB/etc>' , 1
FROM sys.dual
WHERE not exists (SELECT 1
FROM HR_LOCATION_INFO_TYPES
WHERE INFORMATION_TYPE = '<Location EIT Name>');
3) Insert into PER_PEOPLE_INFO_TYPES:

INSERT INTO PER_PEOPLE_INFO_TYPES
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECT_VERSION_NUMBER
)
)
SELECT
‘<Person EIT Name>’
,’Y’
,’<Y for multi–row – N for single>’
,’<Description>’
,’<legislation code US/GB/etc>’
,1
FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_PEOPLE_INFO_TYPES
WHERE INFORMATION_TYPE = ’<Person EIT Name>’);
—
—4) Insert into PER_POSITION_INFO_TYPES:—

INSERT INTO PER_POSITION_INFO_TYPES
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECT_VERSION_NUMBER
)
)
SELECT
’<Position EIT Name>’
1 – 57

Extend and Customize Oracle HRMS

,'Y'
,'<Y for multi-row – N for single>'
,'<Description>'
,'<legislation code US/GB/etc>'
,1
FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_POSITION_INFO_TYPES
WHERE INFORMATION_TYPE = '<Position EIT Name>');

—5) Insert into PER_JOB_INFO_TYPES:

–

INSERT INTO PER_JOB_INFO_TYPES
(INFORMATION_TYPE
,ACTIVE_INACTIVE_FLAG
,MULTIPLE_OCCURENCES_FLAG
,DESCRIPTION
,LEGISLATION_CODE
,OBJECT_VERSION_NUMBER
)
SELECT
'<Job EIT Name>'
,'Y'
,'<Y for multi-row – N for single>'
,'<Description>'
,'<legislation code US/GB/etc>'
,1
FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_POSITION_INFO_TYPES
WHERE INFORMATION_TYPE = '<Job EIT Name>');

—6) Insert into HR_ORG_INFORMATION_TYPES:

–

FROM sys.dual
WHERE not exists (SELECT 1
FROM PER_POSITION_INFO_TYPES
WHERE INFORMATION_TYPE = '<Job EIT Name>');
— Note different parameter value for single and multi-row
— Note different parameters for this EIT

INSERT INTO HR_ORG_INFORMATION_TYPES
(ORG_INFORMATION_TYPE,
DESCRIPTION,
DESTINATION,
DISPLAYED_ORG_INFORMATION_TYPE,
FND_APPLICATION_ID,
LEGISLATION_CODE,
NAVIGATION_METHOD)
)
SELECT
’<Organization EIT Name>’
,’<Description>’
,NULL
,’<Display value on the Organization form>’
,NULL
,’<legislation code US/GB/etc>’
,’<GM for multi-row – GS for single>’
FROM sys.dual
WHERE not exists (SELECT 1
FROM HR_ORG_INFORMATION_TYPES
WHERE ORG_INFORMATION_TYPE = ’<Organization EIT Name>’);

INSERT INTO HR_ORG_INFO_TYPES_BY_CLASS
(ORG_CLASSIFICATION,
ORG_INFORMATION_TYPE,
MANDATORY FLAG)
SELECT
’<Check lookup value for classification HR_BG for Business Group>’
,’<Organization EIT Name>’
,’N’
FROM sys.dual
WHERE not exists (SELECT 1
FROM HR_ORG_INFO_TYPES_BY_CLASS
WHERE ORG_INFORMATION_TYPE = '<Organization EIT Name>'
and
ORG_CLASSIFICATION = '< HR_BG for Business Group>');
/
COMMIT;
EXIT;
Defining an Element or Distribution Set

In the Element and Distribution Set window, you can select element classifications or individual elements to define a set. There are three types of set:

- **Customization set**: You can use a Customization set to restrict the elements that can be entered or viewed on a customized version of the Element Entries window. You can also select a customization set for element entry using BEE in the Batch Assignment Entry window.

- **Run set**: Oracle Payroll users can use a Run set to specify the elements to be processed in a payroll run. If you are creating a Run set for US payroll, you must include the VERTEX recurring element (see step 4).

- **Distribution set**: Oracle Payroll users can use a Distribution set to define the elements over which the costs of other elements are to be distributed.

► To define an element or distribution set:

1. Enter a unique name for the set and select the type: Distribution, Run, or Customization.
2. Save your new set.
3. If you want to include all elements in a classification, choose the Classification Rules button.
   - In the Classification Rules window, select one or more classifications to include. Save the set and close this window. The elements in the classifications you choose are now listed in the Elements region.
   - If you want to exclude individual elements, place your cursor in the element’s row and choose the Exclude Element button.
4. If you want to include particular elements from other classifications, choose the Include Element button.
5. Select the element you want to include in the Elements window, and choose the OK button.
   - **Note**: After you include a particular element, you cannot go to the Classification Rules window and include the classification to which this element belongs.
6. Save your set.
7. If you want to see a list of the individual elements you have included or excluded from the set, choose the Element Rules button. The Element Rules window is view-only.
Defining a Customized Version of a Window

You can define customized versions of certain windows in the Form Customization window.

See: List of Customizable Windows: page 1 – 13

Note: If you want to restrict access to query–only for a window, you do not need to create a customized version. Instead you create a new form function, setting the QUERY_ONLY parameter to YES.

See: Restricting Access to Query–only Mode: page 1 – 63

To define a customized version of a window:

1. Select the name of the standard window in the Form to be customized field. The names of all forms used in this release are prefixed by F4.

2. Enter the name of your new version in the Name field. This name is used when defining menus but it is not seen by users.

3. Select Enabled if you want the restrictions to come into effect. If you do not select this option, the customized version of the window behaves the same way as the standard version.

4. Enter the titles to appear in the new version of the window:
   • In the Standard Title field, enter the window title to be seen by users who can use the window for data entry and editing.
   • In the Query Title field, enter the window title to be seen by users who have view–only access to the window.

5. Save your new version.

6. In the Restrictions block, select the Type and Value of the restriction you want to define. The types and values available depend on the window you are customizing.
Adding the Customized Window to a Menu or Task Flow

You can add your customized windows to a menu or a task flow:

- **Adding customized windows:**
  1. If you want to add the customized window to a task flow, you must create a Task Flow Node for it.
  2. If the customized window is called directly from the Navigator window, you must define a menu function to call the window with the customization. You can add this function to any menu.

    **Note:** If you want to use a customized version of the People window, People Folder, or Assignment Folder to start a task flow, you should define a new customized task flow node and then define a menu function to call the task flow.

Restricting Access to Query–Only Mode

To restrict access to query–only mode for an individual form:

1. In the Form Functions window, select the form and specify the parameter QUERY_ONLY=YES. If you want to specify other parameters for this form function, separate them with a space.

2. Enter a user function name to identify your new function, and save it.

3. In the Menus window, select your new function instead of the supplied form function.
Creating Task Flows Using Forms

Complete the following steps to create task flows using forms:

1. Define Task Flow Nodes: page 1 – 65
2. Define Task Flows: page 1 – 66

You can also complete these optional steps, if required:

3. Copy an Existing Task Flow: page 1 – 68
4. Add a New Window to an Existing Task Flow: page 1 – 69
5. Amend the Navigation of a Task Flow: page 1 – 70
Defining Task Flow Nodes

Each form in a task flow is a node. There are predefined nodes for every form that you can include in a task flow. However, if you create a customization of one of these forms, you must create a node for the customization before you can include it in a task flow.

**Suggestion:** If you want to use a customized form as the first node in a task flow you should define this as a new node.

You could add both the task flow and the customization as arguments to a single menu function but this may be more difficult to maintain.

You create nodes in the Define Task Flow Nodes window.

► **To create a task flow node:**

1. Enter a name for the node. You select this name when you create a task flow containing the node. It is not visible to users.
2. Select the form that you customized. Leave the Block field blank.
3. Select the customization that you created.
4. Save the new node.
Defining Task Flows

You define task flows in the Define Task Flow window. If there is a similar existing task flow, you can copy it to form the basis of your new flow.

**Suggestion:** When defining the navigation buttons in your task flows:
- Don’t have long sequences where you cannot go back to the previous step
- Use the same button names for the same nodes
- Use different button names for customized nodes

Before you can include the task flow in a menu, you must define a new menu function for the first form in the task flow with the following argument in the Parameters field:

```
WORKFLOW_NAME = "task flow name"
```

► **To define a new task flow:**

1. Enter a name for the task flow and save it.
   
   **Note:** Do not choose the Convert button. This is provided only for converting task flows you created in Oracle Workflow. See Creating Task Flows Using Workflow: page 1 – 71.

2. In the Node block, select the name of the node that you want to be the first form in the task flow.

3. For this node, select the Top Node check box.

4. Create a new record in the Node block and select another node. You must create all the nodes for the task flow before you can begin entering the navigation paths between them.

5. In the Navigation Options region, for each node, select the other nodes to which you can navigate.

6. Enter a sequence number to determine the order in which the navigation options appear as buttons (from left to right) along the base of the window or as options in a navigation list.

7. Select the Button check box for the navigation options that should appear as buttons. There is a limit on the number of buttons that can appear on each form. This number varies from form to form. The other options are displayed in a navigation list when the user chooses a button labelled Others. Or, if there is only one other option, this form displays when the user chooses a button labelled Next.
8. There is a default label that appears on buttons or in the navigation list for every form. You can override this with your own label.

If the label in the Define Taskflow window appears blue, this is the default value. It is a dynamic default: if the seeded value changes (for example, as the result of an upgrade), the label will be updated automatically in all task flows where it has not been overridden.

If the label appears black, the default value has been overridden. To re-inherit the default label, clear the field.

9. To define an access key (or keyboard shortcut) for a navigation option, precede the appropriate letter in the label with an ampersand (&). For example, to use ALT+P (in the Microsoft Windows environment) as the access key for the Picture window, enter the label &Picture.

**Note:** Do not use the following letters since they are used on the Oracle Applications menu: A, E, F, G, H, Q, S, W.

There is no validation to prevent the same letter being used more than once for a group of buttons.

10. Save the task flow.
Copying an Existing Task Flow

To copy an existing task flow:

1. Query the existing flow and choose the Copy To button.
2. Enter the name of the new task flow and choose OK.
3. Query your new task flow and edit it as required.
Adding a New Window to an Existing Task Flow

You can use the Define Task Flow window to add a new window, using its node name, to an existing task flow. If you have already used the window in the task flow you only have to amend the navigation, see: Amending the Navigation of a Task Flow: page 1 – 70

**Note:** If you have created a task flow using Oracle Workflow, you must continue to maintain it using Oracle Workflow. You cannot edit a generated task flow using the Define Task Flow window.

To add a new window to an existing task flow

1. Query the task flow you want to amend in the Name field.
2. In the Node block, enter the window’s node name.
3. Save your changes.
   
   You must now include the node in the navigation path for the task flow.
4. Select the existing node you want the new node to be accessed from in the Node block.
5. Enter the new node’s details in the Navigation Options region and edit the existing navigation path as required. For information about how to set up the Navigation Options region refer to steps 5 to 9 in ‘To define a new task flow’: page 1 – 66.
Amending the Navigation of a Task Flow

Use the Define Task Flow window to amend the navigation of a task flow.

To amend the navigation of a task flow:

1. Query the task flow for which you want to amend the navigation in the Name field.
2. Select the node name in the Node block.
3. Edit the existing navigation path in the Navigation Options region, as required. For information on the Navigation Options refer to steps 5 to 9 in To define a new task flow: page 1 – 66.
Creating Task Flows Using Workflow

Complete the following steps to create task flows using Oracle Workflow:

1. Create a Top Level Process: page 1 – 72
2. Create Sub Processes: page 1 – 74
3. Create Button Labels: page 1 – 75
4. Position Button Display: page 1 – 76

**Combined People and Assignment Form Only**

If you are creating task flows using the combined People and Assignment form, you have an additional step to perform:

5. Identify Windows or Blocks to Display: page 1 – 77

**Customized Versions of Forms Only**

If you have created a customized version of a form, you have an additional step to perform:

6. Identify Customized Forms to Include in the Task Flow: page 1 – 78

**All Forms**

7. Verify and Save the Workflow: page 1 – 79
Creating a Top Level Process

You must define a top level process for each task flow. The top level process can contain sub processes, but not any other top level processes.

A top level process must have a Top Node Selector activity. This ensures that the first window in a task flow is a valid top node window. All windows that can be a top node are defined within the Top Node HRMS Context Windows lookup type.

The Top Node Selector must have two transitions. The first transition must go to the Top Node activity and its value must be the window activity name. The second transaction must be <Default> and go to the end activity.

You use the Process Diagrammers within Oracle Workflow to create your task flows. You do this by adding and connecting the windows you want to appear.

To create a top level process:

1. Enter a unique internal and display name for the new process for the HR Task flow item type.
   
   Suggestion: Use a naming convention for Internal and Display names. For example, a good internal name might be POSITION_DETAILS_TL with a Display name of Position Details (Top Level).

2. Define the process as runnable.

3. Open the Process Diagrammer window and add one Start activity and at least one End activity.


5. Connect the Top Node Selector to the End activity with a <Default> transition result value.

6. Add the Top Node window.

7. Connect the Top Node Selector to the Top Node window, specifying the name of this window activity as the transition result value.

8. Connect the Top Node window to the End Activity with a <Default> transition result value.

9. Add other windows to the process, noting the following rules:
   - A window can only connect to another window where the result type is the same (such as, both Person Context windows).
• The transition result value must be the name of the window activity you are connecting to (for example, F4 Enter Assignment).

• Each window can only connect once to any other window.

• Each window must be connected to the Top Node window with a <Default> transition result value.

• You can connect a window back to its parent using the <Parent> transition result value, rather than the name of the parent window.
Creating Sub Processes

You can group a logical set of task flow windows into a sub process, which can then be used by several top level processes. This simplifies process modelling. Each sub process can contain other sub processes. There are two rules to note regarding sub processes:

- A sub process cannot be defined as runnable.
- When you use a sub process in another process, you must connect the sub process to the Top Node window.

**To create sub processes:**

1. Enter a unique internal and display name for the new process for the HR Task flow item type.
   - **Suggestion:** Use a naming convention for Internal and Display names. For example, a good Internal name might be ASSIGNMENT_DETAILS_SL with a Display name of Assignment Details (Sub Level)
2. Define the process as NOT runnable.
3. Specify a user defined result set as a Process Result Type if the sub process requires more than one result value.
4. Open the Process Diagrammer window and add one Start activity and at least one End activity
   - Because a process can have more than one result value, many End activities may be required. At least one End activity is required to indicate that the process must connect back to the Top Level node window.
5. Connect the Start activity to another window.
   - **Note:** The Start activity can connect to one window only.
6. Add other windows to the process, noting the following rules:
   - A window can only connect to another window where the result type is the same (such as, both Person Context windows).
   - The transition result value must be the name of the window activity you are connecting to (for example, F4 Enter Assignment).
   - Each window can only connect once to any other window.
   - Each window must connect to an End Activity with a <Default> transition result value.
   - You can connect a window back to its parent using the <Parent> transition result value, rather than the name of the parent window.
Creating Button Labels

You can enter the label you want to appear on the task flowed forms, such as Photo (for the Picture window), and such. Each task flow window activity has an attribute called Button Label. Use this attribute to override the default button label for a window and to define an access key (or keyboard shortcut).

To create button labels:

1. Display the process in the Oracle Workflow Process Diagrammer.
2. Select the activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the label you want to appear on the forms.
   Precede the appropriate letter in the label with an ampersand (&) to define an access key. For example, to use ALT+P (in the Microsoft Windows environment) as the access key for the Picture window, you could enter the label &Photo.
Positioning Button Display

You can position the display order of buttons on the form. For example, you might want the first button to display the Picture window.

The number of task flow navigation buttons that can be displayed on a window varies from window to window. If there are too many navigation options for them all to appear as buttons, the last button on the window is called Other and it displays a list of values containing the other navigation options.

You determine the navigation options available from a window by defining transitions to other windows in the Process Diagrammer. Now you can use the activity attributes Display Button 1..4 to specify which navigation options should display as buttons and the order in which they should appear.

To position buttons:

1. Display the process in the Oracle Workflow Process Diagrammer.
2. Select the activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the name of the window you want displaying on the button for the Display Button 1 attribute.
   
   For example, if you want the first button to display the Picture window, enter F4 Enter Picture. If the window is the parent window then you can specify the <Parent> special connection value.

5. Repeat step 4 for the attributes Display Button 2 .. 4. If you do not want a button to appear on the window, enter the value <Null>.
   
   For example, if you only want three buttons to be displayed, enter <Null> as the value for Display Button 4.
Identifying Windows or Blocks to Display

For most task flow forms, you must display the first block of the form on entry. However, when you use the Combined People and Assignment form in a task flow, you must specify whether to display the People window (or block) or the Assignment window on entry.

To identify windows or blocks to display:

1. Display the process in the Oracle Workflow Process Diagrammer,
2. Select the window activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the name of the block you want to display on entry for the Block Name attribute.
Identifying Customized Forms to Include in the Task Flow

If you have created a customized version of a window, you can use the customized version of the form in the task flow.

To identify customized forms to include in the task flow:

1. Display the process in the Oracle Workflow Process Diagrammer.
2. Select the window activity by choosing Edit – Properties. (You can also double click on Edit – Properties to select it).
3. Select the Attribute Values tab frame.
4. Enter the name of your Form Customization for the Customization attribute.
Verifying and Saving the Workflow

When you have completed the task flow definition within Oracle Workflow, use the Workflow Verify function to check that your workflow conforms to Oracle Workflow modeling rules.

When you have successfully verified the Workflow, save it to the HRMS database.

To verify and save the Workflow:


   **Note:** This process does not check that you have created a valid task flow. This check is done when you generate the task flow.

2. Choose File – Save.
Generating a Task Flow From Oracle Workflow

After modeling a task flow in Oracle Workflow and saving it to the database, you must generate task flow definitions.

Use the Define Task Flow window from the HRMS application.

▶ To generate a task flow from Oracle Workflow:

1. Query the task flow(s) you have created and choose the Convert button.

2. Choose OK to convert the task flows from Oracle Workflow.

Oracle HRMS indicates how many task flows have been successfully converted. If any task flows have not been converted, these are identified and are not saved to the database. You must correct the errors then verify, save and regenerate the task flows again.

Note: Having modeled a task flow in Oracle Workflow, you cannot edit it using the Define Task Flow window. You must make any edits using Oracle Workflow, save it and then regenerate the task flow definitions.
Using Parameters for HRMS Form Functions

For certain options you must define menu functions that include a parameter in the Parameters field of the Form Functions window, as follows:

- If the menu entry calls a customized form, use the following parameter:
  
  HR_CUSTOMIZATION = "customization name"

- If the menu entry calls the first form in a task flow, use the following parameter:
  
  WORKFLOW_NAME = "task flow name"

- If the menu entry calls a form in query-only mode, use the following parameter:
  
  QUERY_ONLY=YES

- If the menu entry calls the Define Rate form (PAYWSGEV), use the following parameter:
  
  FORM_MODE = "grade" (for the Grade Rate window)
  FORM_MODE = "spine" (for the Scale Rate window)

- If the menu entry calls the Payroll and Assignment Processes form (PAYWSACT – used in Oracle Payroll), use the following parameter:
  
  FORM_MODE = "assignment" (for the Assignment Processes window)
  FORM_MODE = "payroll" (for the Payroll Processes window)

If you need to specify more than one parameter for a form function, separate the parameters with a space.
Changing Default National Address Styles

The different national address styles are held and configured in the Personal Address Information, and the Location Address descriptive flexfield. You can configure them using the Descriptive Flexfield Segments window.

You cannot construct any flexfield segment value sets with:

- Profile options, $PROFILE$
- Previous segment values, $FLEX$
- Block.field references
- Security rules

Note: You must ensure the Personal_Address, or Location_Address protected flag is off.

To change the address style for any country, redefine those segments you do not want to use. Then define new segments to record your own information. However, these changes will be overwritten when you upgrade Oracle HRMS.

To alter an existing style:

1. Enter Oracle Human Resources in the application field.
2. Enter Personal Address Information, or Location Address in the title field.
3. Run the query.
4. Uncheck the Freeze Flexfield Definition check box.
   Note: Read the warning.
5. Select the country code.
6. Click the segments button.
   This will open a new window with the segment and value set information of the selected country.
7. Update the segments.
   Note: You must make country segment mandatory. Do not change the validation on any segment as this may invalidate existing data.
8. Save your work, and open the Descriptive Flexfield Segments window. Make sure any new segments are enabled, and displayed.
9. Check the Freeze Flexfield Definition check box.
10. Click the compile button.
   When compilation is complete, exit your current login session.
   Then log in again to see your updated styles.

➤ **To add a style:**

1. Enter Oracle Human Resources in the application field.
2. Enter Personal Address Information, or Location Address in the title field.
3. Run the query.
4. Un–check the Freeze Flexfield Definition check box
   *Note:* Read the warning.
5. Choose New from the File menu
6. Enter the country code in the code and name fields.
7. Enter a description and select the Segments button.
8. Define the segments.
   *Note:* You can only use the columns provided by Oracle HR for your segments.
9. Save your work.
   *Note:* Make sure any new segments are enabled. You can choose whether segments are displayed or not.
10. Check the Freeze Flexfield Definition check box.
11. Choose the Compile button.

When compilation is complete, exit your current login session. Then log in again to see your updated styles.
Disabling Multiple Windows

In most Oracle Applications, you can open multiple windows from the Navigator window without closing the window you already have open. HRMS, however, does not support Multiform functionality.

**Attention:** You must disable this feature on menu structures that accesses Oracle HRMS windows.

▲ To disable the Multiple Open Window feature:

1. Add a Function type menu entry to the top–level menu referenced by your new responsibility.
2. Select the function whose User Function Name and Function Name are:
   - Navigator: Disable Multiform
   - FND_FNDSCSGN_DISABLE_MULTIFORM
3. Save your changes.
Creating Descriptive Flexfield Database Items

You can use descriptive flexfield segments in QuickPaint reports and formulas if there are database items for these segments.

You can see the descriptive flexfields: page 1 – 22 for which you can create database items.

Submit the process from the Submit Requests window.

To create descriptive flexfield database items

1. Run the *Create Descriptive Flexfield DB Items* process.

   Run this process whenever you create or change these descriptive flexfield definitions.


   **Note:** The process can only create database items for global segments. It does not create database items for context–sensitive segments.
Creating Key Flexfield Database Items

The Create Key Flexfield DB Items process turns data in key flexfields into database items that Oracle FastFormula can access. It is essential to run this process whenever you create or change the Grade, Job, Position, or People Group key flexfield definitions.

Submit the process from the Submit Requests window.

► To create key flexfield database items

- Run the Create Key Flexfield DB Items process.
  
  Run this process whenever you create or change these key flexfield definitions.

  See: Submitting a Request, Oracle Applications User’s Guide.
Setting Up Extra Information Types (Excluding Organization EITs)

The following steps explain how to set up Extra Information Types (EITs) to use in Oracle HRMS.

**Note:** EITs for organizations are set up differently. See: Setting Up Extra Information Types for an Organization Classification: page 1 – 89.

1. In the Descriptive Flexfield Segments window, select the relevant descriptive flexfield by title (such as, Extra Job Information) The descriptive flexfields available are:
   - Extra Location Information (30 Segments)
   - Extra Job Information (30 Segments)
   - Extra Position Information (30 Segments)
   - Extra Person Information (30 Segments)
   - Further Assignment Information (30 Segments)

2. Unprotect the relevant extra information type using the Register Descriptive Flexfield window. You must do this before you can query the flexfield in the Descriptive Flexfield window.

3. Create a new record in the Context Field Values region of the Descriptive Flexfield window and enter the name of your new Information Type in the Code field. As these are context sensitive descriptive flexfields, enter INFORMATION_TYPE in the Reference Field.

4. Enter the segment values and compile in the same way as a standard descriptive flexfield.

   See: Defining Descriptive Flexfield Structures, *Oracle Applications Flexfields Guide*

**Attention:** There are some predefined EITs in Oracle HRMS. These definitions are a fundamental part of your Oracle HRMS installation and any change to them may lead to errors in the operation of the system. Do not attempt to alter the definitions of these developer flexfields or to add other segments to them. It is possible that Oracle will use other segments of these flexfields in the future. Any changes you make can affect your ability to upgrade your system in the future.

5. Reset the protection in the Register Descriptive Flexfield window so the flexfield remains a protected descriptive flexfield.

6. Use SQL to insert a row for each EIT into the relevant Information Type table. In this release there is no window to register your new
EITs with their parent entities. The following table lists the tables for each EIT.

<table>
<thead>
<tr>
<th>EIT</th>
<th>Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Location</td>
<td>HR_LOCATION_INFO_TYPES</td>
</tr>
<tr>
<td>Job</td>
<td>PER_JOB_INFO_TYPES</td>
</tr>
<tr>
<td>Position</td>
<td>PER_POSITION_INFO_TYPES</td>
</tr>
<tr>
<td>Person</td>
<td>PER_PEOPLE_INFO_TYPES</td>
</tr>
<tr>
<td>Assignment</td>
<td>PER_ASSIGNMENT_INFO_TYPES</td>
</tr>
</tbody>
</table>

For an example of a script that can be used to register your EIT see: Example Script to Register EITs: page 1 – 54.

**Attention:** Oracle applications use a standard of a 2 or 3 character product prefix followed by an underscore to name the predefined EITs. To avoid current and future naming conflicts, you should adopt any other naming convention for your Extra Information Types. For example CUSTOM_EXPAT_TAXABILITY.

7. Use the Information Types Security window to set up responsibility level access to EITs.


   Your EIT will now be available anyone using the specified responsibilities. If you want to set up further security using CustomForm and Taskflow, continue with the next step.

8. Use the Form Customization window to restrict access to specific EITs within the appropriate windows.

   See: Defining a Customized Version of a Window: page 1 – 61

9. Use the Define Taskflow Nodes window to define new nodes for any CustomForm restrictions you have set up.

   See: Defining Task Flow Nodes: page 1 – 65

10. Use the Define Taskflow window, or use Oracle Workflow, to define and change task flows to include any new nodes you have set up.

    See: Creating Task Flows Using Forms: page 1 – 64

    See: Creating Task Flows Using Workflow: page 1 – 71
Setting Up Extra Information Types for an Organization Classification

To add Extra Information Types (EITs) to an organization classification:

1. Define a new organization classification. You do not need to do this if you are setting up an EIT for a classification that already exists.
   
   **Note:** To define a new classification, enter a new value for the Lookup type ORG_CLASS in the Lookup Values window.

2. Define the new EIT.
   
   - Unprotect the Org Developer DF using the Register Descriptive Flexfield window. You must do this before you can query the flexfield on the Descriptive Flexfield window.
   
   - Add the new structure for the EIT to the Org Developer DF descriptive flexfield using the Descriptive Flexfield Segments window. The structure must have as its context the name of the extra information type, and as this is a context sensitive descriptive flexfield you must enter C_ORG_INFORMATION_CONTEXT in the Reference Field. Compile in the same way as a standard descriptive flexfield.
   
   - Reset the protection, so the flexfield remains a protected descriptive flexfield.

3. Enter a row into HR_ORG_INFORMATION_TYPES. The columns you should enter are:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORG_INFORMATION</td>
<td>Name of the type (same as DDF context).</td>
</tr>
<tr>
<td>DESCRIPTION</td>
<td>Description of the extra information type.</td>
</tr>
<tr>
<td>DISPLAYED_ORG_INFORMATION_TYPE</td>
<td>The Name of the Extra Information Type displayed in the Organization window.</td>
</tr>
<tr>
<td>NAVIGATION_METHOD</td>
<td>‘GS’ for single row, a user can only enter one extra information row for each organization. Alternatively, ‘GM’ for multi row, a user can enter more than one row for each organization.</td>
</tr>
<tr>
<td>LEGISLATION_CODE</td>
<td>Optionally, you can enter a legislation code to restrict to which Business Groups the EIT is available. If you do not enter a legislation code it will be valid for all Business Groups.</td>
</tr>
</tbody>
</table>
4. Specify for which organization classifications this EIT should be available.

To do this, enter a row into `HR_ORG_INFO_TYPES_BY_CLASS`.

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ORG_CLASSIFICATION</td>
<td>ORG_CLASS lookup code</td>
</tr>
<tr>
<td>ORG_INFORMATION_TYPE</td>
<td>Org extra information type</td>
</tr>
<tr>
<td>MANDATORY_FLAG</td>
<td>Y (for Yes) or N (for No)</td>
</tr>
</tbody>
</table>
Setting Up Extra Information Types Against a Responsibility

Extra Information Types (EITs) must be added to a responsibility before a user can access the information type using that responsibility. By not adding information types to a responsibility, you restrict the information types that a user can access.

Use the Information Type Security window to link EITs to a responsibility.

► **To set up EITs for a responsibility:**

1. Select the name of the responsibility for the EIT.
   
   Oracle HRMS displays a list of EITs already associated with the responsibility you have chosen.

2. Enter the new EIT you want to link to the responsibility.

3. Save the responsibility and EITs.

► **To copy EITs between responsibilities:**

1. Query the responsibility from which you want to copy.

2. Select the Copy Responsibility button.

3. Enter the responsibility to which you want to copy.
   
   This responsibility is then displayed with the new EITs.

4. Save the responsibility and EITs.
Entering Extra Information

You enter extra information in one or more windows available from the main window (such as job). Your system administrator may have created customized versions of the extra information windows so that you can use each version for one information type only.

Your implementation team may have defined one or more types of extra information for you to record for:

- Locations
- Jobs
- Positions
- People
- Assignments
- Organizations

To enter extra information:

1. Enter the type of extra information, for example job category.
   
   **Note:** To access extra information in the Organization window select the Others button in the Organization Classifications region.

2. Click in the Details field to display the extra information fields you can enter.

3. Enter your extra information.

4. Save your extra information details.
Enabling Currencies

Oracle HRMS enables you to use multiple currencies for entering information about employee compensation and benefits. You can also record your payment methods to employees in different currencies.

For example, if you have employees living and working temporarily in other countries, you might want to record specific earnings or deductions for these employees in local currencies. You might also want to pay these employees a fixed amount into a bank account in their home currency. The remainder you would pay in a local currency.

Your startup data includes the definitions of all world currencies. These definitions are shared by all Oracle Applications and are controlled by the system administrator responsibility. You enable those currencies you want to use in the Currencies window.

**Note:** You must enable at least one currency as the default currency for all information related to money in your system. This default is known as the *Base Currency* for your Business Group.

- **To enable a currency:**
  - Query the currency you want to enable and check the Enabled check box. Save your choice to enable the currency.

You can never delete a currency, but you can disable it.

- **To disable a currency:**
  - Uncheck Enabled, or enter an End Date for the currency.
Adding Lookup Types and Values

To create a new Lookup type, add values to an existing Lookup type, or prevent existing values from appearing in a Lookup type, use the Application Utilities Lookups window.

**Note:** You must log out and log in again to see the effect of your changes.

Defining Lookup Types

You can create your own Lookup Types to provide lists of values, for example to validate element entries.

**To define a new Lookup type and the Lookup values:**

1. Choose the access level for the lookup type.
2. Enter the lookup type.
3. Enter the user name of the lookup. This is the name that users will see from within the application.
4. Select the application in which the lookup will be used.
5. Optionally, add a description of the Lookup type.
6. Select whether Lookup type and values you add are global to all Security Groups/Business Groups or specific to your current Security Group/Business Group.

**Attention:** The Global checkbox only displays if you are using Cross Business Group Responsibility Security. If you use Standard HRMS security all Lookup types are global.

If you uncheck the Global checkbox any lookup values you add are only be available in the Security Group/Business Group linked to your current responsibility. However, predefined Lookup values are available to all Business Groups.

See: Categorizing Information By Security Groups: page 2 – 25

7. Uncheck the Standard Security Group checkbox to set up lookup values for the Security Group, and therefore Business Group, linked to your current responsibility. Otherwise, the lookups values are available to all Business Groups.
8. Enter the code, meaning and optionally a description for each value.

If you do not enter a start date, the new Lookup is valid immediately. If you do not enter an end date, the new Lookup is valid indefinitely.
9. Save your work.

Defining Lookup Values

To add Lookup values to an existing Lookup type:

1. Query the Lookup Type to which you want add a value.
   You cannot add values if the Access Level is System.

2. Enter the code, meaning and optionally a description for each value.
   If you do not enter a start date, the new Lookup is valid immediately. If you do not enter an end date, the new Lookup is valid indefinitely.

3. Save your work.
Removing Lookup Values

You can only remove Lookup values if they are set up for a specific security group. However, you can stop all lookups appearing in lists of values.

**Note:** You must be using Cross Business Group Responsibility security to categorize lookups by Security Groups. See: Categorizing Information By Security Groups: page 2 – 25

► **To remove a user defined Lookup:**

- In the Application Utilities Lookups window, do one of the following:
  - Enter an end date if you want to prevent users selecting this value after a certain date.
  - Disable the code by unchecking the Enabled check box if you want to prevent users selecting this value with immediate effect from the current date.
  - Change the meaning and description to create a replacement Lookup.

If you add, disable, or change the meaning of a Lookup, users must log out and log back in again for your changes to take effect.

► **To remove a Lookup set up for a Security Group:**

1. In the Application Utilities Lookups window, select the Lookup type which has lookups for a specific security group.

2. Check the Global checkbox.

   This removes all lookups which have been set up for the security group linked to your current responsibility. Predefined lookups are not removed.

If you add, disable, or change the meaning of a Lookup, users must log out and log back in again for your changes to take effect.
Setting Up User Tables, Columns and Rows

You set up user tables in the Table Structure window.

► To set up the structure of a table:

1. Set your effective date to the date from which you want the table’s row labels to take effect.
2. Enter the table name.
3. For the table’s match type, select Match or Range. Select Match if each row is for one item, such as one job or one code. Select Range if each row is for a range of numeric values, such as an age range or a pay range.
4. If the match type is Match, select Date, Number or Text as the Key Units of Measure, depending on whether entries in the rows are dates, numbers, or alphanumeric text.
   If the table’s match type is Range, the Key Units of Measure automatically becomes Number.
5. Enter the row label as the Row Title.
   For example, if the table rows refer to rate codes, an appropriate row title would be Rate Code. If the rows refer to age ranges, you might use the title Age Range.
6. Save your work, and choose the Columns button to go to the Columns window.

► To set up columns:

1. Enter labels for the table columns in the Name field.
   Note: To add a new column to a table that already exists, place the cursor on the name of the column after which you want to enter the new column name, and choose Insert Record from the Edit menu to obtain a clear field.
2. If you are using formula validation for a column’s entries, select the name of the validation formula for the column.
3. Save your work and close the window.

► To set up rows:

1. In the Table Structure window, choose the Rows button to go to the Rows window.
2. If the match type of the table is Match, enter the label for each table row in the fields under the heading Exact.
If the match type of the table is Range, enter numbers representing the lower and upper boundary of each row’s range.

3. In the Sequence fields, you can optionally enter a number for each row label to determine the order in which it appears on a list in the Table Values window. Logical sequencing of row labels helps users enter table values rapidly and accurately.

4. When you are finished, save your work and close the window. Your table is now set up and ready to receive entries into its columns.
Entering Table Values

If you have set up user–defined tables, you can enter and maintain values in the Table Values window.

You can access table values from any formula used for input–value validation, payroll calculation or definition of skip–rules, assignment sets or QuickPaint reports. You can access this information using the GET_TABLE_VALUE function.

**Note:** The system administrator can create customized versions of the Table Values window so that you use each version for one user table only.

**To enter values into table columns:**

1. Set your effective date to the date from which you want the entries to take effect.

2. Query the table name.

3. With the cursor in the Column Name field, use the up and down arrows to locate the name of the column in which you want to make entries.

4. In the Values region, select each row for which you want to make an entry. You select rows in the Exact field or the Lower Bound field, depending on the match type of the table.

5. For each row, make the appropriate entry in the Value field.

6. Save your work.
Security
Security

You can set up and maintain security of access for different classes of users. Once you have identified who will use Oracle HRMS, what information they require, and how they will use it, you can group together users with similar requirements and give them the same view of the system.

In what ways can you use security of access for different users?

You can set up menus using structures and names that make sense to the users. You can also restrict the data users can view and edit in certain windows, so they only see what they need to see.

This provides security for your data and an efficient interface designed for your users’ needs.

How does Oracle HRMS allow data restriction for display in a window?

If you want different users to view the same window for different purposes, you can restrict their views in different ways. For example:

- Limiting access to list of values for faster data entry
- Limiting access to certain types of information

For example, you might create a customized version of the View Element Entry History for Employee form that does not display the earnings elements representing salary, bonus and commission. Most users’ menus would only give them access to this customized version of the form. Those authorized to view salary, bonus and commission figures, can have a menu function defined to allow access to the uncustomized form.

How does Oracle HRMS enable users to view multiple Business Groups?

Oracle HRMS is installed with two security models, each enabling you to set up security for an enterprise which uses multiple Business Groups. Using both models you can only view records for one business group at any one time. The difference between the models is as follows:

- Using Cross Business Group Responsibility security you can set up the same responsibility for different Business Groups. This means you switch responsibility and security groups to view a different Business Group.
- Using Standard HRMS security you can only link one Business Group to a single responsibility. This means you must change your user identification to view a different Business Group.
Security Overview

As part of your implementation plan, you identify who will use Oracle HRMS, what information they require and how they use it.

Defining who users see and what information they see about people within a Business Group is fundamental to HRMS security.

**Note:** It is important to remember that a user can only view the records for one Business Group at any one time.

Within a Business Group you can control:

- Who the user can access using security profiles. You can restricted access by organizations, position, position hierarchies and payrolls.

- What the user can access using menus, windows, customizations and taskflows. You can control exactly what a user can see about the people they can access.

Security in your Enterprise

Oracle HRMS understands that different enterprises have different security needs. Because of this there are different methods for setting up who and what users can access. The first and most important decision you need to make is which security model should be used by your enterprise.

The two security models, Standard HRMS security and Cross Business Group Responsibility security, both control security by restricting who and what the user can see. What differs is how you can set up security, menus and how users log in.

The following diagrams provide an overview of each of model, highlighting the relationship between the different security components. For more detailed information about each of the security models, see Security Models: page 2 – 8.
Standard HRMS Security

Using Standard HRMS security you log in using a username and password. You then select a responsibility. Your user name and responsibility are linked to a Business Group. You can only access records for this Business Group. The responsibility is also linked to a request group, this restricts the reports and processes you can access. Who you can access is restricted by the security profile. What details you can access is restricted by the menus, taskflows, windows and form customization. This restricts the who and what you can see in the Business Group.
Cross Business Group Responsibility Security

Figure 2 – 2 Cross Business Group Responsibility Security Components

Using Cross Business Group Responsibility security you log in using a username and password. You then select a responsibility and security group.

In Oracle HRMS a security group has a one to one relationship with a Business Group. As with Standard HRMS security you cannot view records for more than one Business Group at any one time. However, because you select a responsibility and security group (therefore, Business Group) you switch responsibilities to change the Business Group rather than logging in as a different user.

Who the user can access in the Business Group is restricted using the security profile set up for the user. What the user can access is defined by the responsibility, this is linked to a request group and the menu, taskflow, window and form customization restrictions.
Security Components

To set up security for your users you also need to have a detailed understanding of the following security components:

User Profiles

A user profile is a set of changeable options that affects the way your application runs. You can set user profile options at site level, application level, responsibility level and user level.

You can restrict access to query–only for all or a selection of your HR and Payroll forms using a user profile option and the parameter QUERY_ONLY=YES at form function level.

Security Profiles

By defining security profiles, you can control access to records of employees at or above a certain level in an organization. For example, you can give a department’s administrator access to all department employee records except those of the manager and assistant manager.

Responsibility

The responsibility is your primary means of defining security. Business Groups, menu structures, task flows, and information types are linked to a responsibility.

Menu Structures

Using menu structures, you can limit the functions a user can access. You can also restrict access to information types by choosing which information types a user can view.

You can also create multiple version of the same form, each one used for just one task. This approach restricts the list of values on certain fields and therefore provides for faster data entry. It also enables you to limit access to certain types of information.

Request Groups

You can specify which processes and reports a reporting user can run by setting up request groups. Within the request group, you use security profiles to restrict the records accessed by the reporting user, who may run reports against the system without having online access through the system’s forms.

Security Groups (Cross Business Group Responsibility only)

If you are using the Cross Business Group Responsibility model you also need to understand the concept of security groups. Security groups
are a method of partitioning data. This is particularly useful if you are a Service Center because you can manage information for multiple Business Groups using one responsibility.

**Reporting Access**

You can set up access restrictions for employees who never use the product’s windows and do not change database information, but do access the database.

**Security Processes**

There are system security processes that enable you to:

- Grant permissions to a new reporting user.
- Maintain the lists of organizations, positions, payrolls, employees and applicants that security profile holders can access.
- Set up and update your system to use Cross Business Group Responsibility security.
Security Models

Oracle HRMS provides two different security models which enable you to set up security specifically for your enterprise: Standard HRMS security and Cross Business Group Responsibility security.

Note: If you want to set up security for employees who can access the database, but do not change database information, see: Reporting Access: page 2 – 27 and Setting Up Reporting Users: page 2 – 42

Standard HRMS Security

Standard HRMS security is used by most enterprises and enables you to link one responsibility to one Business Group. You cannot enable more than one Business Group for a Responsibility. If you use multiple Business Groups you set up a separate responsibility for each Business Group. Using this model, you must log on as a different user to view and manage records in a different Business Group.

When you use Standard HRMS security each responsibility is assigned to one security profile, and therefore one Business Group. This is different to the Cross Business Group Responsibility security where you use the Assign Security Profile window to enable one responsibility for a number Business Groups and security profiles.

Using the Standard HRMS security model you do **not** use security groups or the Assign Security Profile window. The Enable Security Groups profile is defaulted to No at site level. You should not override this default at Application level.

If the business needs of your enterprise change you can move from Standard HRMS security to Cross Business Group Responsibility security. To do this, you must follow the steps in Updating the Security Model: page 2 – 41. These ensure you have the correct profile options set up and security groups are created for all your existing Business Groups.

Cross Business Group Responsibility Security

You should use Cross Business Group Responsibility security if you have multiple Business Groups set up on a single database install and you want one responsibility to be enabled for more than one Business Group.

This method saves you time when setting up security as you do not have to set up a new responsibility for each Business Group. You can also link more than one security profile to a responsibility, as long as
the user is different. This saves you setting up a new responsibility for each security profile you use.

However, using Cross Business Group Responsibility security you must not set up HRMS and non HRMS windows and functions on the same menu. For example, you should not have Oracle HRMS and Oracle Financial windows on one super menu. Instead you must set up separate menus and responsibilities for each Oracle application. However, you can set up HRMS and System Administrator windows (forms with names that begin with FND) on the same menu.

From a user’s perspective you only have to change the responsibility and security group combination to view records for a different Business Group, rather than logging on as a different user.

Note: Using this model you still log on using one responsibility and Business Group. You cannot view multiple Business Group records at the same time. This ensures the integrity of your Business Group records.

This model of security is particularly useful if your enterprise is a Service Center.

Security Groups
The key concept used in this model is Security Groups. Oracle HRMS uses Security Groups to enable one responsibility to use multiple Business Groups.

Attention: You must be sure you need to use Cross Business Group Responsibility security. Once you have set up Oracle HRMS to use this model you cannot change to Standard HRMS security.

To set up Oracle HRMS to use security groups you must set the user profile option Enable Security Groups to Yes and run the Multiple Security Groups process.

Note: If you want to enable the Enable Security Groups profile option you must set it to Yes at Application level.

Oracle HRMS then:
- Creates a security group when you create a Business Group
- Enables you to link a responsibility, user and Business Group to a security profile using the Assign Security Profile window

Using this model you do not need to enter the HR: Security Profile profile option as it is automatically set up. If you do enter a security profile in the HR: Security Profile profile option it is ignored.

For more information on how Security Groups and Business Groups are used in security see: Security Groups (Cross Business Group Responsibility Only): page 2 – 24.
User Profiles

A user profile is a set of changeable options that affects the way your application runs. You can set user profiles at different levels:

- **Site level**: These settings apply to all users at an installation site.
- **Application level**: These settings apply to all users of any responsibility associated with the application.
- **Responsibility level**: These settings apply to all users currently signed on under the responsibility.
- **User level**: These settings apply to individual users, identified by their application usernames.

Values set at a higher level cascade as defaults to the lower levels. Values set at a lower level override any default from a higher level.

**Figure 2 – 3 Levels For Setting User Profile Options**

**Suggestion**: Set site-level options first to ensure that all options have a default. If a profile option does not have a default value, it might cause errors when you use windows, run reports, or run concurrent requests.

You use the System Profile Values window to set profile options at each level for your user community. If you change a user profile option value, your change takes effect as soon as your users log on again or change responsibilities.
Application users can use the Personal Profile Values window to set their own profile options at the user level. Not all profile options are visible to users, and some profile options, while visible, cannot be updated by end users. Any changes users make to their personal profile options take effect immediately.

See: Personal Profile Values Window, Oracle System Administration Guide.

Query–Only Access to Forms

You can restrict access to query–only for all HR and Payroll forms on a menu by setting the user profile option HR:Query Only Mode to Yes. You can set this profile for individual responsibilities or users, or at the site or application level.

If you want to give query–only access to some forms and full access to other forms, set the HR:Query Only Mode profile to No and use the parameter QUERY_ONLY=YES at form function level to restrict access to individual forms.

**Note:** You can set the parameter QUERY_ONLY=YES for a form function that also launches a task flow. In this case, specify two parameters in the Form Function window:

 QUERY_ONLY=YES
 WORKFLOW_NAME="task flow name"

The entire task flow will be query–only, not just the first form.


Profile Options Summary

The table below indicates whether you (the “User”) can view or update the profile option and at which System Administrator levels the profile options can be updated: at the user, responsibility, application, or site levels.

A ”Required” profile option requires you to provide a value. An ”Optional” profile option already provides a default value, so you only need to change it if you do not want to accept the default.

**Note:** The only option that a user can change is DateTrack:Reminder.
<table>
<thead>
<tr>
<th>Profile Option</th>
<th>User</th>
<th>System Administrator</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>DateTrack:Date Security</td>
<td></td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>DateTrack:Reminder</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>Enable Security Groups</td>
<td></td>
<td></td>
<td>Yes, Security groups are not enabled</td>
</tr>
<tr>
<td>Help Localization Code</td>
<td></td>
<td></td>
<td>Yes, by HRMS</td>
</tr>
<tr>
<td>HR:Business Group</td>
<td></td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>HR:Default Nationality</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:Display Skills/Competencies</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:Grade Key Flex–Identify 1st Segment</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:Execute Legislative Check Formula within Run</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:Grade Key Flex–Identify 2nd Segment</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:Job Key Flex–Identify 1st Segment</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:NI Unique Error or Warning</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:OAB New Benefits Model</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>HR:Position Key Flex–Identify 2nd Segment</td>
<td></td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>Profile Option</td>
<td>User</td>
<td>System Administrator</td>
<td>Requirements</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>------</td>
<td>----------------------</td>
<td>---------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>User</td>
<td>Resp</td>
<td>App</td>
</tr>
<tr>
<td>HR:Position Key Identify</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>1st Segment</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>HR:Query Only Mode</td>
<td>–</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>HR: Security Profile</td>
<td>–</td>
<td>–</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>HR:Use Standard Attachments</td>
<td>–</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>–</td>
<td>–</td>
<td>–</td>
</tr>
<tr>
<td>HR:User Type</td>
<td>–</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>View Unpublished 360 Self Appraisal</td>
<td>–</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

**Key**

✓ You can update the profile option.

- You can view the profile option value but you cannot change it.

---

**Profile Options**

**DateTrack:Date Security**

Controls the way users can change their effective date:

- **All** (users can change to any date)
- **Past** (users can change to dates in the past only)
- **Present** (users cannot change their effective date)
- **Future** (users can change to dates in the future only)

**DateTrack:Reminder**

Determines whether the Decision window appears when you open a window in which you can enter, update, or delete datetracked information. Notice that the Decision window never appears on windows where you can query datetracked information but not update it. There are three possible values:

- **Always** (the window always appears)
• **Never** (the window never appears)
• **Not Today** (the window appears only if the effective date is not the system date)

### Enable Security Groups
Controls whether you use security groups within security. Only change the default Yes at application level if your enterprise is using Cross Business Group Responsibility security. If you change the default to Yes, you must run the Enable Multiple Security Groups process.

**Note:** Non HRMS applications do not support multiple security groups in Release 11i.

### Help Localization Code
Controls which set of help files are linked to each responsibility. If you accept the default, then the set of help files for Global HRMS will be associated with the responsibility. However, if you want to specify a legislative or vertical variant of HRMS you must set the Help Localization Code as follows:

- CA for Canadian HR Help
- FD for US Federal HR Help
- JP for Japanese HRMS Help
- UK for UK HRMS Help
- US for US HRMS Help

These entries must be in upper case.

### HR:Business Group
This is view only. Determines the Business Group linked to a responsibility. The Setup Business Group is defaulted at Site level.

If you use Cross Business Group Responsibility security this option is automatically set up when you create a security profile assignment.

If you use Standard HRMS security this option is automatically set up when you enter the HR:Security Profile profile option.

### HR:Default Nationality
Defines the default nationality for a user. When a new person is entered in the People window, the nationality entered here is automatically displayed in the Nationality field.
HR:Display Skills/Profile Options

Controls the display of competencies in an Advanced Search. It is used to control the display of skill categories in:

- Apply for a Job
- Enroll in a Class

HR:Execute Legislative Check Formula within Run

Determines whether the legislation–specific check is performed during a payroll run.

HR:Grade Key Flex–Identify 1st and 2nd Segments

These options are used to control which two segments of the key flexfields appear in Person Search.

HR:Job Flex–Identify 1st and 2nd Segments

These options are used to control which two segments of the key flexfields appear in Person Search.

HR:NI Unique Error or Warning

Enables you to change the default warning to an error message.

If you want to warn users that the national identifier they have entered already exists, leave the default as warning. If you want to prevent a user entering the same national identifier more than once, you can change the message to an error. This stops the user entering the same national identifier.

HR:OAB New Benefits Model

Enables you to set up whether you are using the new benefits model, that is, Standard or Advanced Benefits. Enter Yes, if you are using the new benefits model. Enter No, if you are using the compensation and benefit models from previous releases.

HR:Position Flex–Identify 1st and 2nd Segments

These options are used to control which two segments of the key flexfields appear in Person Search.

HR:Query Only Mode

Restricts access to view–only for all HR and Payroll forms on a menu.
HR:Security Profile

Restricts access to the organization, positions and payrolls defined in the security profile. This option is predefined at Site Level with the view—all security profile created for the Startup Business Group.

If you use Standard HRMS security you must set up the HR:Security Profile profile option for each responsibility.

If you use Cross Business Group Responsibility security you must **not** set up the HR:Security Profile profile option. This is set up automatically when you assign security profiles using the Assign Security Profile window. You must only change the HR:Security Profile option by assigning a different security profile to a responsibility using the Assign Security Profile window.

HR:Use Standard Attachments

Disables the facility to attach short text comments to records. Enables the attachment of multiple items of various types including OLE objects, Web pages, images, and word processed documents.

HR:User Type

Limits field access on windows shared between Oracle Human Resources and Oracle Payroll. If you do not use Oracle Payroll, it must be set to HR User for all responsibilities.

If you do use Oracle Payroll, you can give each Responsibility one of the following user types, depending on the work role of the holders of the responsibility:

- HR User
- HR with Payroll User
- Payroll User

View Unpublished Employee 360 Degree Self Appraisal

Enables a manager to view their employee’s unpublished 360 Degree self appraisals. Set the profile option to Yes to view an employee’s unpublished 360 Degree self appraisals. The default value is Null.
Security Profiles

The *security profile* linked to the user’s responsibility and Business Group determines which applicant and employee records are available to holders of that responsibility.

Using HRMS Standard security the security profile is set up for one responsibility using the HR:Security Profile profile option.

Using Cross Business Group Responsibility security you link a security profile to the user’s responsibility and Business group using the Assign Security Profile window. You can also link more than one security profile to a responsibility, as long as the user is different. This save you setting up a new responsibility for each security profile you use.

**Note:** Using Cross Business Group Responsibility security you must not use the HR:Security Profile profile option. This is automatically set up when you assign security profiles using the Assign Security Profile window.

You associate a security profile with work structures. The records of employees and applicants assigned to these work structures are then accessible to holders of the responsibility.

The work structures you can name in security profiles are:

- *Internal organizations* and *organization hierarchies*. Organizations include structures like departments, sections, groups and teams. Each security profile allows access to one Business Group only.

- *Positions* and *position hierarchies*. Positions are jobs performed within specified organizations.

- *Payrolls*. Restrict access to employee records by *payroll*. For example, you can give payroll staff who work on the payroll at a particular location access to records of employees on this payroll only.

Controlling security by payroll assignment limits the employee records users can see and update on employee–related windows, such as those for employee information, and element entry.

Of course, if an employee assignment does not include a payroll, payroll security cannot apply to this assignment. Payroll security never applies to applicant records since applicants are not assigned to payrolls.

The windows for compensation definition are unrelated to any particular employee records or payroll assignments. Therefore limiting access by payroll does not affect users’ access to these windows.
When you create a Business Group a view–all security profile is automatically created. The security profile provides access to *all* employee records, and *all* applicant records in the Business Group. The system administrator links this view–all profile to users who are setting up the system. They in turn can set up security for other users.
Responsibilities

You can control users’ access to human resources information by record, window and function.

The responsibility is your primary means of defining security. To define what a user can access you link a user, responsibility and Business Group to a security profile. Other important components of the responsibility are the menu structures, task flows and information types. These also help you limit the employee records a user can access.

Users can sign on to the system only through the responsibilities you give them. So their responsibilities control what they can see and do in the system.

Responsibility

A responsibility is linked to a security profile and composed of:

- A menu structure
- A request group for reporting users (optional)
- Extra information types available to the user

Responsibilities are also linked to Business Groups. However, depending on which security model you use, you link responsibilities differently.

- Standard HRMS Security
  You can only link one Business Group to one responsibility using Standard HRMS security. You must set up different responsibilities for each Business Group.

- Cross Business Group Responsibility Security
  You can enable more than one Business Group for a single responsibility. However, you still only view records for one Business Group at a time.

Each model enables you to set up multiple responsibilities. You can assign multiple responsibilities to users who need to:

- Access applicant and employee records from two or more security profiles.
- Use more than one menu structure to view or make changes to the records they can access.
- Access records for more than one Business Group if you use Standard HRMS security. For example, an enterprise with
international operations may have a US-Based Business Group and a UK-Based Business Group. A few of your employees might need to access both.

Access Control Through Responsibility

The following key components help control user access to Oracle HRMS:

- **Security profiles** determine the organizations, positions and payrolls whose applicant and employee records responsibility holders can access.

- **Business Groups** determine the set of records a user can access. Using Cross Business Group Responsibility security you can enable one responsibility for many Business Groups. Using Standard HRMS security you must set up a new responsibility for each Business Group.

- **Menu structures** and functions control:
  - The particular *windows* a responsibility holder can access
  - Whether he or she can perform data entry, change or deletion on these windows

You can produce customized versions of some windows. Each customized version enables access to a subset of certain types of information, such as person types, special information types, or elements. You define additional menu functions to call customized windows or task flows, and then you add these functions to a menu structure, which is linked to a responsibility.

- **Request groups** determine the group of *processes and reports* a responsibility holder can initiate. A request group is an optional component of a responsibility. If holders of a responsibility should not initiate any reports or processes, you do not include a request group in the responsibility.

- **Extra Information types** are an optional component of a responsibility. By defining which extra information types are included in a responsibility, you effectively create a customized version of a window for users who are assigned the responsibility.

**Attention:** If you do not associate any extra information types with a responsibility, a person assigned to this responsibility will *not* have access to any extra information types in the product.

For each responsibility, you must also define the user profile option HR:User Type.
Menu Structure

Users access standard windows, customized windows, and the first window in a task flow through the menu structure displayed in the Navigator window. Each responsibility includes a menu structure to restrict the windows users can access, and what they can do on these windows.

A function is a part of an application’s functionality that is registered under a unique name for the purpose of assigning it to, or excluding it from, a responsibility. There are two types of functions: form functions, and non–form functions. For clarity, we refer to a form function as a form, and a non–form function as a subfunction, even though both are just instances of functions in the database.

Using Function Security system administrators can further restrict access to individual menu options. You can include:

- Standard windows, displayed in edit or view–only mode
- Customized windows, on which you have restricted the range of data that can be displayed
- The first window in task flows that link a number of windows that are used in sequence to complete a task

By defining menus with function security for groups of users, you can:

- Limit the range of information users can access for the applicant and employee records available to them
- Improve users’ efficiency in using the system by reducing menu choices
- Restrict users to query–only access to some or all windows

Each responsibility you define must be linked to a root menu. The root menu lists the menu options when the Navigator window first opens.

The Default Menu Structure

The AutoInstall program creates a default menu structure for your HRMS product. This menu structure lets you access all of the windows for your system. Normally, only a system administrator has access to the full default menu structure.

The supplied menus give you access to all of the available submenus. However, a number of predefined functions are not enabled on these menus. You need to add them for the responsibilities that should have access to these functions.
- **HR View Medical**  
  This causes the Medical Information tabbed region to display in the People window.

- **HR View Background**  
  This causes the Background Information tabbed region to display in the People window.

- **HR View Benefits**  
  This causes the Benefits tabbed region to display in the People window.

- **HR View Rehire**  
  This causes the Rehire Information tabbed region to display in the People window.

- **Salary Administration: Approve**  
  This enables the user to approve salary proposals in the Salary Administration window and the Salary Management folder.

- **HR View Projects Information**  
  This causes the Projects Information tabbed region to display in the Assignment window. You must have Oracle Projects installed to display this region.

⚠️ **Warning:** Oracle HRMS with DateTrack and task flows does not fully support multiple active windows. When you define a new menu for use with Oracle HRMS the top menu must include the following function as a separate menu option:  

Disable Multiform
Request Groups

When you build a responsibility for employees who must initiate reports or processes, you can attach a request group to the responsibility. The request group lists a group of processes and reports its holders can run. Holders of responsibilities with no request groups cannot run any processes or reports.

The group Reports and Processes gives access to all predefined reports and processes.
Security Groups (Cross Business Group Responsibility Security Only)

When you use Cross Business Group Responsibility security, data is partitioned using Business Groups. Therefore, with Oracle HRMS, when data is partitioned by Security Group, it is the same as partitioning by Business Group.

**Attention:** Security groups are only used if you have set up your enterprise using the Cross Business Group Responsibility security model. Standard HRMS security only partitions data using Business Groups.

Security Groups are the key component in Cross Business Group Responsibility security. They enable you to set up one responsibility and link this to a number of different Business Groups.

Before you can start using this security model you must set up HRMS to use Security Groups. To do this you set the Enable Security Groups profile option to Yes and run the Enable Multiple Security Group process. See: Setting Up Cross Business Group Responsibility Security: page 2 – 36.

**Note:** You can also change from Standard HRMS security to Cross Business Group Responsibility security. See: Updating the Security Model: page 2 – 41

Once you have set up your enterprise to use security groups, Oracle HRMS automatically creates a security group when you set up a Business Group. The security group has the same name as the Business Group. For example, if you create a Business Group called UK Headquarters, Oracle HRMS automatically creates a security group called UK Headquarters. The Setup Business Group is an exception, it uses the predefined security group called Standard.

**Note:** If you change the name of your Business Group, the security group name is not updated. You must select the responsibility linked to the Business Group’s original name.

Using the Assign Security Profile window you link the user, responsibility and Business Group to a security profile. By entering a Business Group you are automatically linking the responsibility to the security group.

You then log on using the Responsibility and Security Group pairing. As security groups are automatically linked to a Business Group, you can then view and manage the records for that Business Group.

When you log on, Oracle HRMS displays all the pairings you have created between Business Groups and responsibilities. You could have the same responsibility listed twice with different security groups and therefore Business Groups. By looking at the security group you can
select the correct responsibility for the Business Group you want to access.

Using this model you cannot view multiple Business Group records at the same time. To change Business Group you must switch to an alternative responsibility and Business Group pairing. This ensures the integrity of your Business Group records.

**Attention:** Security groups are automatically created for you when you use Oracle HRMS. Do not use the System Administrator’s Security Groups window to add security groups as these will not be linked to your Business Groups.

**Example**

If your user is set up with a responsibility called HRMS Manager you could link this to:

- UK Headquarters (Business Group)
- Scotland Operations (Security Profile)

Using the same responsibility (HRMS Manager), you could also link to a different Business Group:

- Canadian Headquarters (Business Group)
- Vancouver Operations (Security Profile)

Therefore, you only need to set up one responsibility (HRMS Manager) but you can enable two Business Groups (UK Headquarters and Canadian Headquarters).

When the Business Group UK Headquarters was set up, a security group UK Headquarters would automatically have been created. When you linked the Business Group to the user’s responsibility, the security group UK Headquarters would also be linked.

To view the records for Business Group UK headquarters you would select the HRMS Manager responsibility and the UK Headquarters security group.

If you then wanted to view the records for the Canadian Headquarters Business Group you would switch responsibility and security group pairing, selecting the same responsibility (HRMS Manager) and the different security group Canadian Headquarters.

**Categorizing Information By Security Groups**

**Attention:** You can only categorize information by Security Groups if you are using Cross Business Group Responsibility security.
You can categorize the following information within your enterprise using security groups:

- **Lookups**
  
  Using the Application Utilities Lookups window you can set up lookups specifically for a security group. These lookups are only available to users who access the Business Group associated with the security group.
  
  See: Adding Lookup Types and Values: page 1 – 94

- **Concurrent Programs**

  Using the Concurrent Parameters Program window you can enter a security group against a concurrent program, this creates a specific list of concurrent programs for a Security Group and therefore Business Group. When a user selects a concurrent program using the Submit Request window, they can select from the concurrent programs for their Business Group.

  **Note:** You do not have to enter a security group against all the concurrent programs. Concurrent programs which are not linked to a security group display for all Security Groups/Business Groups.

  See: Concurrent Parameters Program window, Applications System Administrator’s Guide.
Oracle HRMS enables you to set up reporting users who can query and report on the information in the database, but cannot insert, update or delete information. Reporting users can use Oracle tools, or other tools connected to the Oracle database, to report on information. Regardless of the tools used to access the database, reporting users can only read information, they cannot update information.

Using Oracle HRMS you can set up similar security restrictions to users who can update, insert or delete information. This ensures reporting users can only query and report on appropriate records.

All secure users connect to the APPS ORACLE ID. This is created when the system is installed. However, for reporting users, you should create one or more new reporting user ORACLE IDs. By associating these with a restricted security profile you can control whose records a reporting user can access.

You can make any of your restricted security profiles available not only for regular users, but also for reporting users. The security profile restricts a reporting user’s access to employee records in exactly the same way as it limits regular users’ access.

Reporting users can see all the details about the records they can access. To restrict the access of what a reporting user can view you must use view–based accesses. To support this need of reporting users you can use third party reporting tools to create business views.

For information about how to set up database access without on-line access, see: Setting Up Reporting Users: page 2 – 42.
Security Processes

There are three system security processes:

- **Generate Secure User**
  Run this process when you create a new security profile that references a reporting user.

- **Security List Maintenance**
  Run this process every night.

- **Enable Multiple Security Groups**
  Run this process when you first set up Cross Business Group Responsibility security.

You run these processes using a system administrator responsibility from the Submit Requests window.

There is also another security process – Grant Permissions To Roles. However, this is run automatically as part of the autoinstall process.

**Generate Secure User Process (SECGEN)**

This process grants permissions to new reporting users. It grants the "hr_reporting_user" role to the REPORTING_ORACLE_USERNAME specified in the security profile.

Run this process when you have created a new security profile that references a reporting user. In the Submit Requests window, select the name of the new security profile. This is the only parameter for the process.

**Security List Maintenance Process (LISTGEN)**

This process maintains the lists of organizations, positions, employees and applicants that security profile holders can access. You should schedule it to run every night to take account of changes made during the day. If a disruption, such as a power cut, occurs while the process is running, you can manually restart it from the Submit Requests window.

There is one required parameter for this process: Effective Date, which should normally be set to SYSDATE. You can also enter a security profile name to generate list entries for that security profile only.

**Attention**: LISTGEN should normally run when there are no users logged on to the system. Users attached while LISTGEN is running may experience unexpected results; for example,
additional employees may become visible or previously visible employees may disappear from view.

Grant Permissions To Roles Process (ROLEGEN)

All reporting users in the system share access to a set of public synonyms for tables and views. Reporting users are granted permissions to make them usable. The Grant Permissions To Roles process creates these public synonyms and grants permissions on them.

⚠️ **Attention:** The Grant Permissions to Roles process is unrelated to setting up workflow roles for Oracle products that support security by workflow.

This process is automatically run as part of the autoinstall process when you install HR, or when you upgrade the system.

The process creates public synonyms for each of the required HR objects and then grants SELECT permissions to the role ‘hr_reporting_user’. Permissions are not granted on the secured tables, but only on the secure views of those tables. All permissions previously granted to the role are revoked before the new grants are made. This ensures that the correct grants exist for the valid HR objects.

Enable Multiple Security Groups

You must run the Enable Multiple Security Groups process if you set the Enable Security Groups profile to Yes. This process must be run when:

- You set up Cross Business Group Responsibility security for the first time to ensure HRMS is enabled to use security groups and all the Cross Business Group Responsibility security features.

- You change from Standard HRMS security to Cross Business Group Responsibility security. This ensures that all your existing Business Groups have security groups and all the Cross Business Group Responsibility security features are enabled.
Security Profiles by Organization and Organization Hierarchy

To set up a security profile that permits access to employee records of certain organizations only, you make use of organization hierarchies. You can build any number of additional hierarchies to meet your security requirements.

For example, suppose you build this Sales Organization hierarchy:

Figure 2 – 4 Sales Organization Hierarchy

You can create a security profile that permits access to employee records throughout the sales organization. This profile references the Sales Organization hierarchy. It names the Sales Department as the highest organization in the hierarchy through which profile holders have access to employee records.

Next, you want the directors of the two sales regions to have access to all employee records in their region only. You create Eastern and Western Sales Director security profiles. These profiles also reference the Sales hierarchy. But, they name the Eastern and Western Regions, respectively, as the top organizations for these profiles’ access to employee records.

When you name an organization as the top organization, you specify whether it is inclusive or not. You must include the top organization if you want holders of the profile to access records of people assigned to the top organization.
Security Profiles By Position and Position Hierarchies

After establishing limits on record access using organization hierarchies, you can further restrict access by means of position hierarchies.

Suppose, for example, within the Sales Department, you want to give the Sales Research Director access to her subordinates’ records only. You can start by building the following Sales Positions Hierarchy:

![Sales Positions Hierarchy Diagram]

Now you create the Sales Research Director security profile. This profile references the Sales Positions hierarchy and names the Sales Research Director as the top position for access to employee records.

<table>
<thead>
<tr>
<th>Security Profile:</th>
<th>SALES RESEARCH DIRECTOR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organization Hierarchy:</td>
<td>Sales Organization</td>
</tr>
<tr>
<td>Top Organization:</td>
<td>Sales Department</td>
</tr>
<tr>
<td>Position Hierarchy:</td>
<td>Sales Positions</td>
</tr>
<tr>
<td>Top Position:</td>
<td>Sales Research Director</td>
</tr>
<tr>
<td>Include Top Position:</td>
<td>Yes</td>
</tr>
</tbody>
</table>

When you give the Sales Research Director a responsibility including this security profile, she can access the records of her subordinates. But, she cannot access records of the:

- VP or Associate VP of Sales
• Regional Sales Director
• Regional Sales Director’s subordinates

As with organization hierarchies, you can specify that profiles do not include access to the top position.
Setting Up Standard HRMS Security

Use the following setup steps if your enterprise sets up a different responsibility for each Business Group.

To set up users for Standard HRMS security:

1. Ensure that the Enable Security Groups profile option is set to No at site and application level.
   
   If this option is set to Yes then you are not using Standard HRMS security.
   
   See: System Profile Values, Oracle Applications User’s Guide.

2. Define a Security Profile: page 2 – 35

3. Ensure required functions or menus are set up.
   
   This is required for the responsibility. For menu functions calling customized forms or task flows, you must enter a parameter in the Parameter field of the Form Functions window.
   
   See: Defining Menus: page 2 – 43

4. Ensure required request group is set up.
   
   You can define the groups of standard reports and processes that a user can run from the Submit a New Request window. Every responsibility can have access to one request group.
   
   Use the Request Groups window.
   
   See: Request Groups window, Oracle Applications System Administrator’s User’s Guide.

5. Define a responsibility using the Responsibility window.
   
   See: Responsibilities Window, Oracle Applications System Administrator’s Guide.

6. Set the HR User Profile Options for the new responsibility using the System Profile Values window. You must set up the:
   
   - HR: User Type
     
     Use this profile option to limit field access on windows shared between Oracle Human Resources and Oracle Payroll.
   
   - HR:Security Profile
     
     Enter the security profile for the responsibility. This must be set up at responsibility level, otherwise the default view–all security profile is used. Using Standard HRMS security you can only set up one security profile for a responsibility.
You can set also set up other User Profile Options.

See: System Profile Value Window, Oracle Applications System Administrator’s Guide

7. Create the username and password using the User window.
   Link the user to as many responsibilities as they need using the User window.

   **Attention:** Do not use the HRMS Assign Security Profile window if you are setting up Standard HRMS security.

   See: Users Window, Oracle Applications System Administrator’s Guide

8. Run system security process using the Submit Request window:
   • Security List Maintenance

   Ensure this process is run every night.

   See: Submitting a Request, Oracle Applications User’s Guide
Defining a Security Profile

Using a view–all responsibility, you can define security profiles in the Security Profile window.

If you want to associate a reporting user with the new security profile, the ORACLE database administrator must create a new reporting user ORACLE ID. The system administrator must register the new ORACLE IDs with the Application Object Library.

To define a security profile:

1. Enter a name for the security profile and select a Business Group. This does not need to be the Business Group associated with your responsibility.

2. If you want reporting users to be able to use this security profile, select the Reporting User name for the ID set up by the database administrator.

3. Uncheck the View All Employees and View All Applicants check boxes if you want to restrict access to these person types by organizations, positions, or payrolls.

4. To restrict access by organization, uncheck the View All Organizations check box. Select an organization hierarchy, and a top organization. Check the Include Top Organization check box if you want to allow access to this organization.

5. To restrict access by position, uncheck the View All Positions check box. Select a position hierarchy, and a top position. Check the Include Top Position check box if you want to allow access to this position.

6. In the Payroll Security tabbed region:
   - To give access to many payrolls, check the View All Payrolls check box, and uncheck the Include check box. Select the payrolls you want to exclude.
   - To give access to a small number of payrolls, uncheck the View All Payrolls check box, and check the Include check box. Select the payrolls to include.

7. Save your work.
Setting Up Cross Business Group Responsibility Security

Use the following setup steps if your enterprise wants to enable many Business Groups for one responsibility. This type of security is most commonly used by Service Centers.

**Note:** You only need to perform steps 1 and 2 when you first implement Oracle HRMS security. You can perform the other steps at any time.

**To set up users for Cross Business Group Responsibility security:**

1. **Set the Enable Security Groups Profile Option.**
   
   Ensure the Enable Security Groups profile option is set to Yes at the application level.
   
   **Note:** If this option is set to No then you are not using Cross Business Group Responsibility security.
   

2. **Run the Enable Multiple Security Group Process.**
   
   You must run the Enable Multiple Security Group process to set up Oracle HRMS to use security groups.
   

3. **Define a Security Profile:** page 2 – 35

4. **Ensure that the functions or menus you require are set up.**
   
   This is required for the responsibility. For menu functions calling customized forms or task flows, you must enter a parameter in the Parameter field of the Form Functions window.
   
   See: Defining Menus: page 2 – 43

5. **Ensure that the request group you require is set up.**
   
   You can define the groups of standard reports and processes that a user can run from the Submit a New Request window. Every responsibility can have access to one request group.
   
   Use the Request Group window.
   

6. **Define a responsibility using the Responsibility window.**
   

7. **Set the HR User Profile Options for the new responsibility using the System Profile Values window.** You must set up the HR: User Type option.
Note: For Cross Business Group Responsibility security do not set up or amend the HR:Security Profile profile option using the System Profile Values window. To set up or change this profile option use the Assign Security Profile window.

You can set also set up other User Profile Options.

See: System Profile Value Window, Oracle Applications System Administrator’s Guide

8. Create usernames and passwords using the User window.

Attention: Do not link responsibilities and security groups (Business Groups) to users in this window, use the Assign Security Profile window. If you do enter a responsibility and security group in this window, you still need to use the Assign Security Profile window, to link your user to a responsibility and security profile. If you do not use the Assign Security Profile window, the default view–all security profile is used and your user will be able to see all records in the Business Group.

See: Users Window, Oracle Applications System Administrator’s Guide


Associate a security profile with a user, responsibility and Business Group using the Assign Security Profile window.

10. Run system security process using the Submit Request window:

- Security List Maintenance

  Ensure this process is run every night.

See: Submitting a Request, Oracle Applications User’s Guide
Using the Find Security Profile Assignment window

This window enables you to search for security profile assignments that have already been set up. You only use security profile assignments if you are setting up Cross Business Group Responsibility security.

If you want to set up a new security profile assignment select the New button. For more information on setting up new security profile assignments, see Assigning Security Profiles: page 2 – 39.

Note: When you navigate to the Assign Security Profiles window, the Find Security Profile Assignment window automatically displays.

To query a security profile assignment:

1. Enter a full or partial query on one, a selection or all of the following:
   - User name
   - Application
   - Responsibility
   - Business Group
   - Security profile

2. Check the Retrieve Only Active Assignments check box if you want to query security profile assignments that are active as of today’s date. Uncheck the Retrieve Only Active Assignments check box if you want to query security profile assignments which are no longer active or assignments which will be available in the future.

3. Choose the Find button.

The security profile assignments found by the query are displayed in the Assign Security Profile window.
Assigning Security Profiles

Use the Assign Security Profile window to link user names, and security profiles to responsibilities. Only use this window if you are using Cross Business Group Responsibility security.

**Attention:** When using Cross Business Group Responsibility security even if you have linked a user to a responsibility using the User window, you must still link your user to responsibility and security profile using the HRMS Assign Security Profile window. If you do not use the Assign Security Profile window, HRMS uses the default view–all security profile for the Business Group and the user will see all records for the Business Group.

The Assign Security Profile window is an essential part of setting up and maintaining HRMS security for Cross Business Group Responsibility security. You must use this window to update your security profile assignment. Any changes entered for the security profile assignment are also shown on the User window. However, if you end date a user’s responsibility using the User window, this is not shown on the Assign Security Profile window.

When you navigate to the Assign Security Profile window, the Find Security Profile Assignments window displays automatically. Select New to create a new assignment. For information about querying existing security profile assignments, see Using the Find Security Profile Assignment window: page 2 – 38.

**To assign a new security profile:**

1. Enter the user name you want to link to a responsibility.
2. Enter the application and responsibility you want to link to the user.
3. Assign a Business Group to the user’s responsibility.
4. Assign a security profile to the user’s responsibility.
   You can link more than one security profile to a responsibility as long as the user is different.
5. Enter the time period of security profile assignment.
   You must enter a start date. Optionally, enter an end date if you want the security profile assignment to end on a particular date.
6. Save the security profile assignment.

**To end a security profile assignment:**

You cannot delete security profile assignments. If a user no longer needs an assignment you must enter an end date.
1. Query the security profile assignment you want to end.
2. Enter an end date. The user cannot use this responsibility, Business Group and security profile from this date.
Updating the Security Model

If the business needs of your enterprise change you can update your security model from Standard HRMS security to Cross Business Group responsibility.

**Attention:** Ensure that you definitely need to use Cross Business Group Responsibility security. Once you are using this security model you cannot change to Standard HRMS security.

**To change to Cross Business Group Responsibility security:**

1. Change the HR: Enable Security Profile option to Yes at application level using the System Profiles Values window.
   
   See: User Profiles: page 2 – 10

2. Run the Enable Multiple Security Groups process from the Submit a Request window. This creates security groups for all your existing Business Groups.
   
   See: Submitting a Request, Oracle Applications User’s Guide.

3. Set up your Cross Business Group Responsibility security.

Setting Up Reporting Users

Reporting users do not have online access to the database through system forms. They use reporting tools to prepare reports on the information their security profiles grant.

All secure users connect to the APPS ORACLE ID. This is created when the system is installed. However, for reporting users, you should create one or more new reporting user ORACLE IDs and associate each with a restricted security profile.

The first step in this procedure is the job of the ORACLE database administrator. The other steps are normally completed by the system administrator.

To set up a new reporting user:

1. Create a new reporting user ORACLE ID.
2. Register the new ORACLE ID with Application Object Library using the Register window.
3. Using a ‘view–all responsibility’, define a security profile in the Security Profile window for the new ORACLE ID.
   See: Defining a Security Profile: page 2 – 35
4. Run the HR security processes using the Generate Secure User Process.
   See: Submitting a New Request, Oracle Applications User’s Guide.
Defining Menus

Use the Menus window to add predefined functions to a menu.

⚠️ **Warning:** Oracle HRMS with DateTrack and task flows does not fully support multiple active windows. When you define a new menu for use with Oracle HRMS the top menu must include the following function as a separate menu option:

**Disable Multiform**

A number of predefined functions are not provided on the supplied menus. You can add them to your own menus. See: Menu Structure: page 2 – 21 for a list of these functions.

► **To define a menu:**

1. Query the menu onto which to add the function.
2. Add a new line and select the function.
   
   For example, select Salary Administration: Approve to enable users to approve salary proposals.
3. Save your changes.

See: Menus Window, Oracle Applications System Administrator’s Guide.
Structuring Menus

Using function security and the Menus window, you can use the default menu for any number of responsibilities and restrict access to the default menu options. You can also define any number of new functions and menus to restrict the access of other users. To view the hierarchy of menus you have defined, you can run the Menu Structures report.

⚠️ Warning: You should not modify the default functions and menus supplied with the system. On upgrade, these defaults will be overwritten.

If you want to add window customization options or task flows you should define your own menus.

The supplied menus give you access to all of the available submenus. However, a number of predefined functions are not enabled on these menus. You need to add them for the responsibilities that should have access to these functions.

► Structuring Menus:

1. Start by drawing it out on paper. This helps you to decide the best structure and the best prompts and descriptions.

2. Decide how to structure your menus. Menus can be structured in different ways:
   - Following a Sequence of Tasks.
     
     For example:
     1. Define a Requisition and Vacancy
     2. Define a Recruitment Activity
     3. Enter Applicant Information
   - By Type:
     
     For example, all inquiry windows grouped together. If you structure the menu by type, the grouping is important but the sequence is not.

4. Work from the lowest level of sub-menu to the highest and define the root menu as the last step in the sequence.

5. Define as many submenus as you require under each menu option. We recommend that you restrict the number of menu levels to three because a menu structure with more levels is cumbersome to use.
Defining Menu Functions

Use the Form Functions window to define your menu functions.

*Function Security* helps you to control the menu options you make available to each responsibility. When you define a responsibility you can restrict the submenus or functions for that responsibility.

**Warning:** You should not modify the default functions and menus supplied with the system. On upgrade, these defaults will be overwritten.

If you want to add window customization options or task flows you should define your own menus.

- Define Menu Functions
  - Define your menu function using the Form Functions window.
CHAPTER 3

AuditTrail
AuditTrail

AuditTrail is an Oracle HRMS system administration task which enables you to track and record changes to your data.

What does AuditTrail provide?

AuditTrail provides a flexible approach to tracking the changes to your data. It enables you keep a history of changes to your important data: what changed, who changed it, and when. With AuditTrail, you can easily determine how any data row or element obtained its current value. You can track information on most types of fields, including character, number and date fields.
AuditTrail Overview

The system administrator is responsible for performing AuditTrail on Oracle HRMS data.

Performing AuditTrail

AuditTrail provides a flexible approach to tracking the changes to your data. It enables you keep a history of changes to your important data: what changed, who changed it, and when. With AuditTrail, you can easily determine how any data row or element obtained its current value. You can track information on most types of fields, including character, number and date fields.

You enable auditing for audit groups. These are groups of tables and columns you want to audit, where you do not necessarily need to include all the columns in a given table. You typically group together those tables that belong to the same business process, such as employee compensation tables.

During your AuditTrail implementation, you need to decide your audit requirements:

- Which tables and columns you want to audit
- How you plan to report on the audit data
- How long you want to keep the audit data active
  - Audit information reports
  - Custom audit reports

See: Oracle Applications System Administrator’s Guide
Audit Information Reports

The Audit Trail process creates a shadow table for each audited table, to hold the audit information.

For tables that are not datetracked, you can write a report that uses the views on the shadow tables to access the audit data. However, for datetracked tables, the information from the shadow tables must be extracted and written to the HR_AUDITS table and the HR_AUDIT_COLUMNS table before you can report on it.

The system’s audit report performs this additional processing. You can use it as supplied or as an example of how to report on audit information. It can report on both datetracked and non–datetracked tables that have a numeric primary key.

**Note:** It can report on up to approximately 90 columns in datetracked tables and 80 columns in non–datetracked tables.

The report lists every change made to the table you select in the time period you specify when you run the report. You can restrict the reported changes to those made by a specified username. The changes are listed by date and time of the change. For each change, the report shows:

- The date and time of the change
- The user ID who made the change
- The type of change
- The fields that changed and either their old values, or their new values, or both, depending on the type of change

The following table lists the 12 types of change and the information shown in the audit report for each type.

<table>
<thead>
<tr>
<th>Type of Change</th>
<th>Field Values Shown in the Report</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal Insert</td>
<td>The non–null values in the new record.</td>
</tr>
<tr>
<td>(creates a non–datetracked record)</td>
<td></td>
</tr>
<tr>
<td>Normal Update</td>
<td>The old and new values for all fields that changed.</td>
</tr>
<tr>
<td>(updates a non–datetracked record)</td>
<td></td>
</tr>
<tr>
<td>Normal Delete</td>
<td>The non–null values in the record that was deleted.</td>
</tr>
<tr>
<td>(deletes a non–datatracked record)</td>
<td></td>
</tr>
<tr>
<td>DT First Insert</td>
<td>The non–null values in the new record.</td>
</tr>
<tr>
<td>(creates a datetracked record)</td>
<td></td>
</tr>
</tbody>
</table>

Transaction Types in the Audit Report
<table>
<thead>
<tr>
<th>Type of Change</th>
<th>Field Values Shown in the Report</th>
</tr>
</thead>
<tbody>
<tr>
<td>DT Update</td>
<td>The old and new values of all fields that changed, and the new effective end date on the old row.</td>
</tr>
<tr>
<td>(date—effectively ends the last row on a datetracked record and creates a new row)</td>
<td></td>
</tr>
<tr>
<td>DT Correction</td>
<td>The old and new values of all fields that changed, and the effective dates of the corrected row.</td>
</tr>
<tr>
<td>(corrects a row of a datetracked record and does not change the effective dates)</td>
<td></td>
</tr>
<tr>
<td>DT Replace</td>
<td>The non–null values in the rows that were deleted, the new effective end date on the row preceding the new row, and the old and new values of all fields that changed.</td>
</tr>
<tr>
<td>(creates a new row on a datetracked record that replaces all rows that start after its start date)</td>
<td></td>
</tr>
<tr>
<td>DT Insert</td>
<td>The old and new values of all fields that changed, and the new effective end date on the row preceding the new row.</td>
</tr>
<tr>
<td>(creates a new row on a datetracked record that ends on the old effective end date of the preceding row)</td>
<td></td>
</tr>
<tr>
<td>DT Purge</td>
<td>The non–null values in all rows of the record that was deleted.</td>
</tr>
<tr>
<td>(deletes all rows of a datetracked record)</td>
<td></td>
</tr>
<tr>
<td>DT End Date</td>
<td>The new effective end date of the row.</td>
</tr>
<tr>
<td>(adds an effective end date to the last row of a datetracked record)</td>
<td></td>
</tr>
<tr>
<td>DT All</td>
<td>The non–null values in the rows that were deleted, and the new effective end date on the last row.</td>
</tr>
<tr>
<td>(sets a new effective end date on a row of a datetracked record and deletes all following rows)</td>
<td></td>
</tr>
<tr>
<td>DT Next</td>
<td>The non–null values in the row that was deleted, and the old and new effective end dates on the preceding row.</td>
</tr>
<tr>
<td>(deletes a row of a datetracked record and uses its effective end date to set a new end date on the preceding row)</td>
<td></td>
</tr>
</tbody>
</table>

Transaction Types in the Audit Report
Custom Audit Reports

If you want to design your own audit report, you can copy the supplied report and use it as the basis of your own version. The supplied report uses a dynamic SQL structure to retrieve information for the report, and an Oracle Report to format it.

Dynamic SQL Structure

For a non-datetracked table, the dynamic SQL structure retrieves information and uses a private procedure to retrieve the new values for an update.

For a datetracked table, the dynamic SQL structure retrieves information from the function and procedure created for each datetracked table by the Audit Trail Update Datetracked Tables process:

- The <tablename>_TT function identifies the type of datetracked transaction represented by each row of the shadow table.
- The <tablename>_VP procedure gets new values from the shadow table for update and insert transactions. It writes these to the HR_AUDITS and HR_AUDIT_COLUMNS tables.

The dynamic SQL structure comprises several character strings, which are concatenated into one long string, then parsed and executed using the dynamic SQL generator. If you change a string, you must ensure that you do not exceed the text space allocated to it, as listed in the package header.

The structure is built up by identifying the audited table column information, which is retrieved from the FND_AUDIT_COLUMNS table. The logic varies depending on the data type being audited.

The package for the dynamic SQL is called py_audit_report_pkg. It is found in the script pyadyn.pkh/pyadyn.pkb.

HR Audit Tables

The HR_AUDITS table holds audit information about the transaction. The HR_AUDIT_COLUMNS table holds the changed column
information for that transaction. The structure of these tables is as follows:

**HR_AUDITS Table**

<table>
<thead>
<tr>
<th>COLUMN</th>
<th>TYPE</th>
<th>NULL</th>
</tr>
</thead>
<tbody>
<tr>
<td>audit_id</td>
<td>number(15)</td>
<td>not null</td>
</tr>
<tr>
<td>commit_id</td>
<td>number(9)</td>
<td>not null</td>
</tr>
<tr>
<td>current_session_id</td>
<td>number</td>
<td>not null</td>
</tr>
<tr>
<td>primary_key</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>primary_key_value</td>
<td>number(15)</td>
<td>not null</td>
</tr>
<tr>
<td>sequence_id</td>
<td>number</td>
<td>not null</td>
</tr>
<tr>
<td>session_id</td>
<td>number</td>
<td>not null</td>
</tr>
<tr>
<td>table_name</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>timestamp</td>
<td>date</td>
<td>not null</td>
</tr>
<tr>
<td>transaction</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>transaction_type</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>user_name</td>
<td>varchar2(100)</td>
<td>null</td>
</tr>
<tr>
<td>effective_end_date</td>
<td>date</td>
<td>null</td>
</tr>
<tr>
<td>effective_start_date</td>
<td>date</td>
<td>null</td>
</tr>
</tbody>
</table>

**HR_AUDIT_COLUMNS Table**

<table>
<thead>
<tr>
<th>COLUMN</th>
<th>TYPE</th>
<th>NULL</th>
</tr>
</thead>
<tbody>
<tr>
<td>audit_id</td>
<td>number(15)</td>
<td>not null</td>
</tr>
<tr>
<td>column_id</td>
<td>number(9)</td>
<td>not null</td>
</tr>
<tr>
<td>column_name</td>
<td>varchar2(30)</td>
<td>not null</td>
</tr>
<tr>
<td>new_value</td>
<td>varchar2(240)</td>
<td>null</td>
</tr>
<tr>
<td>old_value</td>
<td>varchar2(240)</td>
<td>null</td>
</tr>
</tbody>
</table>
Setting Up AuditTrail

Setting up AuditTrail is normally a task for the system administrator.

The first four steps must be done to enable auditing of any Oracle Applications table. They are explained in more detail in the Oracle Applications System Administrator’s Guide. The fifth step is required only for tables in the HR account.

To set up AuditTrail:

1. Have your database administrator grant SELECT privileges on SYS.DBA_TABLES to the APPLSYS account. Normally this step would already have been done as part of your installation or upgrade.

2. Select the tables you want to audit in the Audit Groups window, and select which columns in these tables you want to audit in the Audit Tables window.
   
   **Note:** You cannot audit LONG, RAW, or LONG RAW columns.

3. Select the registered ORACLE IDs you want to audit in the Audit Installations window.

4. Run the Audit Trail Update Tables process. You do this in the Submit Requests window for a System Administrator responsibility. This process:
   - Creates database triggers on your audited tables
   - Creates one shadow table for each audited table, to contain the audit information
   - Builds special views on non-datetracked tables, which you can use to retrieve your audit data for reporting

5. Run the Audit Trail Update Datetracked Tables process. You do this in the Submit Requests window for an HR responsibility. For each datetracked table, this process:
   - Creates an index on the shadow table
   - Creates the function `<tablespace>_TT` and the procedure `<tablename>_VP`, which extracts information from the shadow table when you run the predefined audit report

**Attention:** Re-run these processes whenever you update any of your audit definitions.
Disabling AuditTrail

You can disable the auditing of an audit group at any time by selecting a Disable state in the Audit Groups window.

**Suggestion:** If you are planning high volume transactions on an audited table, such as loading a batch of information from another system, consider disabling auditing for the table’s audit group. This will enable the batch loading to complete more quickly.

Before you restart auditing, you should archive your audit data, according to your business needs, and purge the shadow tables. You purge the tables by setting the audit group to Disable – Purge Table and running the Audit Trail Update Tables report. To restart auditing, you set the audit group to Enable Requested and rerun the Audit Trail Update Tables process and the Audit Trail Update Datetracked Tables process.
Running the Predefined Audit Report

You can run an audit report using the system’s predefined structure, or you can design your own audit report.

To run the predefined audit report:

1. In the Submit Requests window, select Audit Report in the Name field.
2. Enter the Parameters field to open the Parameters window.
3. Select an audited table (that is, one in an audit group).
4. Select a value for the Initialization parameter:
   - **Yes** means that the report removes obsolete data related to your selected table from the HR_AUDITS table and the HR_AUDIT_COLUMNS table. It populate the tables with new values, then reports on these.
   - **No** means that the report runs on the existing data in the HR_AUDITS table and the HR_AUDIT_COLUMNS table.
   - **Refresh** means that the report removes all obsolete data from the HR_AUDITS table and the HR_AUDIT_COLUMNS table. It populate the tables with new values, then reports on these.
5. If you only want to report on the changes made by one user, enter the username.
6. Enter start and end dates to limit the time period for reporting audit information.
7. Choose the Submit button.

You can use the View Requests window to check the progress of the report.
CHAPTER 4

Information Access
Information Access

Does Oracle HRMS provide flexible access to information?

The information held in Oracle HRMS is an extremely valuable resource for your enterprise. You can use the same information in a variety of different ways depending on your business purpose. For example, you can use Oracle HRMS information in support of each of the following business activities:

- Performing a full range of HR functions on a day-to-day basis
- Reporting on HR activities
- Performing what-if exercises to determine the viability of alternatives scenarios
- Performing strategic planning with the Business Intelligence System

How can you use Oracle HRMS to support typical hr activities?

You can extract details about a single employee or a group of employees. Particular examples are:

- Selecting an employee or a set of employees for HR processing
- Extracting HRMS information in to produce standard letters
- Viewing organization hierarchies and position hierarchies
- Viewing a historical record of previous changes

What range of reporting options are available in Oracle HRMS?

When you are reporting on activities using HRMS you may want to use each of the following reporting options depending on your business purpose:

- Define a report using parameters that you supply
- Run a predefined report
- Specify the intervals at which a report should run
- Combine several reports into a set so that they can be run at the same time

Can you pose “what-if” scenarios?

There will be occasions when you want to see the effect of a proposed change before deciding whether to implement it. For example, you
may want to calculate the effect of a salary change for a range of employees. In these circumstances it would not be appropriate to change the data in HRMS until you have assessed the implications. Oracle HRMS allows you to transfer a copy of current data to your desktop so that you can test a succession of modifications before uploading the data to HRMS.

### Can you use Oracle HRMS information for strategic planning?

Using the Business Intelligence System you can:

- Establish a set of Key Performance Indicators to provide measures of compliance for each of your business activities
- Produce reports to illustrate trends and identify future business strategy
- Make integrated use of individual reporting tools to solve complex enquiries

### Can you run multilingual reports?

Yes, you can run HRMS in more than one language on a single database. This means that you can enter and report on information using more than one language. For example, your base, or source, language could be French, but you could also install German and English. You would then be able to enter and produce reports in German and English.
Information Access Overview

Oracle HRMS provides a range of inquiry and reporting mechanisms to meet the needs of different users:

- Inquiry windows (including folders)
- Predefined reports that can be scheduled and grouped for periodic processing
- QuickPaint, to create your own online inquiries and reports about people and assignments
- Multilingual reporting for some reports
- Use of desktop tools for reporting or editing HRMS data. For example, you can use Application Data Exchange (ADE) to download information to a spreadsheet, and then upload the modified data to HRMS.

Inquiry Windows

Oracle HRMS includes some inquiry windows to meet the most common online reporting requirements. In these windows, you typically enter selection criteria in the first block then choose the Find button to view a list of people, assignments, or other entities that match your criteria. Some of these windows use folders to display the information retrieved by your criteria.

Folders are online views that you can customize. By default, the folder block in an inquiry window displays all records matching your inquiry and all fields available within the folder. However, you can create your own folders to display a subset of these records and fields. You can also choose the field labels, their size and order, and the sort sequence of the retrieved records.

For example, in the Assignment Folder window, you could create a folder called Sales Employees by Grade. This folder has the query criteria Organization = ‘Sales’, and it is sorted by grade.

Predefined Reports

There are a number of predefined reports that you can use immediately without any further set up. They have a predefined format but you can choose which records to view by entering a set of parameters when you submit the report.

You can also create your own reports using Oracle Reports or SQL*Plus or another tool of your choice. You can register them with Application
Object Library. This means you can run them from the standard Submit Requests window, and you can schedule them in report sets with other reports and processes.

**Multilingual Reporting**

Oracle HRMS enables you to print reports in the language of your choice.

**HR Reports**

You can select in which language the following reports are printed:

- Full Person Details
- Full Applicant Details
- Full Assignment Details
- Full Work Details

See: Submitting a Request, *Oracle Applications User’s Guide*

**Payroll Reports**

Payroll reports are usually submitted in the language of your Business Group, for example the US Check writer can only be printed in American English and the GB Deposit Advice can only be printed in English. However, you may be able to print payroll reports in multiple languages if your localization team has created legislation specific reports for you to use.

**Note:** The default HRMS payrolls for the US and UK can only be run in English. They are not multilingual.

**Using Oracle HRMS with Spreadsheets**

You can use Oracle Application Data Exchange (ADE) to download information from the HRMS database to a spreadsheet for analysis and manipulation. For example, you can download data on current and proposed salaries for a group of employees. You can adjust the salary proposals in the spreadsheet, or enter new ones, and upload the revised data to the database. The ADE upload process reports any errors and ensures that only valid data is saved in the database.

To download information from a form to a spreadsheet using ADE, your system administrator needs to create a style in ADE. The style defines the form it is used for, the responsibilities that can use it, and the columns (or fields) to be downloaded. You determine which records are downloaded by running a query in the form before launching ADE.
A style for downloading salary proposals is predefined.

QuickPaint

QuickPaint is a powerful and flexible tool to design reports about assignments in the format you require. You can include the following sorts of information in a QuickPaint report:

- Personal information
- Contact information
- Assignment information
- Application information
- Compensation and benefit information
- Descriptive flexfield information

Once you have designed a QuickPaint report, you and other users can run the report online for any assignment or set of assignments. You can view the results online or print them.

Customization of the Run QuickPaint Report Window

Using the standard QuickPaint Report window, you can run the report for an assignment or an assignment set. The assignments can be held by current employees or applicants.

Your system administrator can create customized versions of this window to restrict the reports you can run and the people you can report on. A customized version might be subject to one or more of the following restrictions:

- Report on one person type only (employees OR applicants).
- Run one report only.
- Report on single assignments only, or report on assignment sets only.

If the window is subject to the third type of restriction, it will look different to the standard version since it will contain either the assignment region or the assignment set region, but not both.

Attachments

You can add attachments to a large number of HRMS records. Examples of attachments are word processed documents, Web pages or video images.
Using Attachments

You can attach short comments, word processed documents, images, video, OLE objects, or Web pages to many records in Oracle HRMS. For example, you could attach a resume to an applicant record and a position description to a position record.

Each record can have one or more attachments, and you can copy attachments from one record to another. You can store the attachments in the database or in your file system.

To view attachments or add new attachments

Click the Attachments icon. By default, clicking the attachments icon displays a Comments window where you can enter text up to 2000 characters. This is the Comments facility available in earlier releases of Oracle HRMS. If you want to replace this facility with the ability to attach multiple items, ask your system administrator to set your user profile option HR:Use Standard Attachments to Yes.

The HRMS entities that support attachments are:

- Absence
- Absence Type
- Address
- Application
- Assignment
- Balance (Oracle Payroll)
- Batch Header
- Benefit
- Booking
- Budgets
- Budget Version
- Calendar
- Career Path
- Cobra Coverage Status
- Cobra Enrollment
- Cobra Payment
- Consolidation Set (Oracle Payroll)
- Contact Relationship
• Customization
• Element
• Element Entry
• Element Link
• Element Set
• Event
• Grade
• Grade Rate
• Job
• Job Evaluation
• Job Requirement
• Letter Type
• Monetary Unit (Oracle Payroll)
• Organization
• Organization Payment Method
• Organization Hierarchy
• Pay Scale
• Payroll Process (Oracle Payroll)
• Period of Service
• Person
• Person Analysis/Special Information
• Personal Payment Method
• Position
• Position Hierarchy
• Recruitment Activity
• Requisition
• Salary Basis
• Salary Proposal
• Salary Proposal Component
• Secondary Assignment Status
• Special Information Type
• Status Processing Rules (Oracle Payroll)
• Vacancy
• Valid Grade
• WC Fund
Using Inquiry Windows and Folders

You can define public folders, which all users can view, as well as private folders for your own use.

See: Customizing the Presentation of Data in a Folder: *(Oracle Applications User’s Guide)*

<table>
<thead>
<tr>
<th>Inquiry Window</th>
<th>Information Provided</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assignments Folder</td>
<td>Lists of assignments in a folder</td>
</tr>
<tr>
<td>Employee Assignment Processes (Oracle Payroll – UK and US legislations only)</td>
<td>All the assignment processes for one employee assignment, which you can view, retry or roll back, with further information on run messages, run results, balances, payment details and costing</td>
</tr>
<tr>
<td>Payroll Processes (Oracle Payroll – UK and US legislations only)</td>
<td>All the payroll processes for one payroll for a specified period, which you can view, retry or roll back, with further details on assignment processes, run messages and costing</td>
</tr>
<tr>
<td>People Folder</td>
<td>Lists of people in a folder</td>
</tr>
<tr>
<td>Salary Management Folder</td>
<td>List of assignments with their current approved salary and proposed new salary</td>
</tr>
<tr>
<td>Position Occupancy Folder</td>
<td>Lists of people who have held a selected position, or are applying for it, and the dates of their occupancy</td>
</tr>
<tr>
<td>List Assignments</td>
<td>Assignments that match the assignment components you specify for current applicants, employees, or both</td>
</tr>
<tr>
<td>List People by Assignment</td>
<td>People whose assignments match the assignment components you specify for current or former applicants, employees, or both</td>
</tr>
<tr>
<td>List Employees by Organization</td>
<td>All employees assigned to one organization and, optionally, to all organizations below it in a specified hierarchy</td>
</tr>
<tr>
<td>Assignment History</td>
<td>The dates of assignments and periods of service for an employee who has had more than one assignment..</td>
</tr>
<tr>
<td>List Employees by Position</td>
<td>All employees assigned to a specified position or organization and job</td>
</tr>
<tr>
<td>List Employees by Position Hierarchy</td>
<td>Current holders of positions at and below a specified position in a position hierarchy</td>
</tr>
<tr>
<td>View Employee Grade Comparatio</td>
<td>The amount employees receive for a specified element as a percentage of the mid–value of their grade rate range</td>
</tr>
</tbody>
</table>

Inquiry Windows in Oracle HRMS
<table>
<thead>
<tr>
<th>Inquiry Window</th>
<th>Information Provided</th>
</tr>
</thead>
<tbody>
<tr>
<td>List Employees by Absence Type</td>
<td>All absences of a particular absence type or category within, optionally, a specified time period</td>
</tr>
<tr>
<td>View Employee Absence History</td>
<td>Periods of absence for a specified employee</td>
</tr>
<tr>
<td>List People by Special Information</td>
<td>All people for whom you have entered details about a specified special information type</td>
</tr>
<tr>
<td>List Employees by Element</td>
<td>All employee assignments receiving a specified compensation element within a given time period</td>
</tr>
<tr>
<td>View Element Entry History for Employee</td>
<td>The history of entries of one or more elements for an employee assignment</td>
</tr>
<tr>
<td>List Position Budget Variance</td>
<td>Variances between the number of actual position holders and the values entered in a specified budget for positions below a chosen position in a hierarchy</td>
</tr>
<tr>
<td>List Budget Variance by Organization</td>
<td>Variances between the number of actual position holders and the values entered in a specified budget for all positions in organizations at and below a chosen organization in a hierarchy</td>
</tr>
<tr>
<td>View Employee Benefits (US only)</td>
<td>View benefit plans on which an employee is enrolled and the coverage level and contributions for each plan</td>
</tr>
<tr>
<td>View Vacancies</td>
<td>Vacancies matching assignment components and other criteria you select</td>
</tr>
</tbody>
</table>

**Inquiry Windows in Oracle HRMS**
Defining QuickPaint Reports

You can design QuickPaint reports in the Define QuickPaint Report window.

In the Report Definition area, you can enter free text to introduce the report and to label the information that the report extracts from the database. You can also select database items, which are tags representing the information to be extracted from the database. When you run the report, the database item names are replaced by the appropriate data for the assignment or set of assignments for which the report is run.

You must be careful how you position the database items so that QuickPaint interprets them correctly and formats the report in the layout you require.

To define a QuickPaint Report:

1. Enter a name, and optionally a description, of the report.
   The Protected field is display only; some reports provided by localization teams are protected against edits.
2. In the Report Definition area, enter free text exactly as you want it to appear on the report.
3. To select database items, choose the Show Items button and run a query to display a list of database items, then select and copy items to the Report Definition area.
   Notice that the database item name must begin with an ampersand (&). Names without an ampersand are treated as free text.
4. Save the report definition.

Positioning Items

If you want to add free text immediately after a database item, you must separate it from the database item with at least one space. Otherwise QuickPaint reads the database item as free text.

Both free text and database items appear in the report results on the line on which you painted them in the Report Definition area. They also generally appear in the column in which you painted them. However, it might be that the data replacing a database item name is long enough to push later items on the same line to the right.

For example, if you paint database items and free text like this:

```
&ASG_JOB      in &ASG_ORG
```

the report results print like this:

```
Technician    in Biochemistry
Scientific Officer in Biochemistry
```
Notice that, in the second result, the free text ‘in’ is pushed to the right and one space is entered before it.

If you know the number of the column in which you want text or a database item to appear, you can enter it like this:

\[
\&\text{ASG\_JOB} \quad \&32\text{in} \quad \&\text{ASG\_ORG}
\]

However, the text ‘in’ will still be pushed to the right if the preceding database item (\&ASG\_JOB) extends beyond column 32. If you would prefer the preceding database item to be truncated, paint the line as follows:

\[
\&\text{ASG\_JOB} \quad \&\&32\text{in} \quad \&\text{ASG\_ORG}
\]

The report results will look like this:

Technician in Biochemistry
Scientific Off in Biochemistry

If you want one space between two database items or between a database item and text, then paint them separated by a single space. The single space is always preserved. For example, this definition:

\[
\&\text{EMP\_FIRST\_NAME} \quad \&\text{EMP\_LAST\_NAME}
\]

gives the following report results:

Alice Hollister
Ray Garcia

Adding Conditions or Calculations to QuickPaint Reports

When you save a report definition, QuickPaint generates a formula to extract the information required by the report. You can view this formula in the Formulas window. To query the formula, enter the name of your QuickPaint report.

Formulas generated from QuickPaint definitions do not contain conditional logic or mathematical computations. If you need these features, query the formula in the Formulas window and copy it. Edit the copy to add the logic you require.

\[\text{Attention:}\quad\text{You should not edit the original QuickPaint formula. Always edit a copy. Any edits of the original formula are overwritten if you change the report definition in the QuickPaint Report window.}\]
Running QuickPaint Reports

You run QuickPaint reports from the Run QuickPaint Report window. You can run a report for one assignment or for a group of assignments.

► To run a report for one assignment:

1. Select the type Assignment.
2. In the Assignment region, select the assignment for which you want to run the report.
3. In the Report field, select the report you want to run.
4. Choose the Run Report button.
   The message line tells you when the report is complete.
5. Choose the View Report button to see the report results.

   When you run a QuickPaint report, the system runs the formula associated with the report. The first time you run a report, the system may take several seconds to identify all of the related data and bring it back to the screen. All subsequent inquiries for other employees or applicants will run very quickly.

► To run a report for an assignment set:

1. Select the type Assignment Set.
2. In the Assignment Set region, select the assignment set for which you want to run the report.
3. In the Report field, select the report you want to run.
4. Choose the Run Report button.
   The message line tells you when the report is complete.
5. Choose the View Report button to see the report results.
Running Pre-defined and User Defined Reports

These reports run in batch mode. You submit them for processing in the Submit Requests window, and you can view their progress using the View Requests window. The requests are handled by a *concurrent manager* so you can continue working online while your request is processed.

You can schedule the reports to run regularly and you can group them with other reports and processes to run as a set. You can also control access to the reports and control their printing. For example, the system administrator may want to ensure that users in one location always print their reports on a local printer.

<table>
<thead>
<tr>
<th>Report Name</th>
<th>Information Provided</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absences</td>
<td>Absence details for an employee or organization, for some or all absence types.</td>
</tr>
<tr>
<td>Annual Unemployment Insurance (Form 940) Information (Oracle Payroll)</td>
<td>Provides numbers for annual 940 filing.</td>
</tr>
<tr>
<td>Assignment Status</td>
<td>All employees, applicants or both assigned to selected work structures.</td>
</tr>
<tr>
<td>Audit Report (Oracle Payroll)</td>
<td>Selects person, employee or applicant, assignment, element, recurring or non-recurring status. Shows Business Group, GRE, assignment details, person entering data (responsibility), input date, effective change date, details of person affected. Lists all fields changed, with input date and effective date, old value and new value, responsibility, workstation address.</td>
</tr>
<tr>
<td>Costing Breakdown (Oracle Payroll)</td>
<td>Lists costing details by date range, payroll, consolidation set, GRE and segment values.</td>
</tr>
<tr>
<td>Current and Projected Progression Point Values</td>
<td>The <em>expected</em> results of running the Increment Progression Points process, that is the projected point and value changes for a group of employees.</td>
</tr>
<tr>
<td>Earnings Audit (Oracle Payroll)</td>
<td>Report detailing all employees with a particular element being processed in a given pay period.</td>
</tr>
<tr>
<td>Element Link Details</td>
<td>The eligibility criteria for an element or group of elements.</td>
</tr>
<tr>
<td>Element Result Listing (Oracle Payroll)</td>
<td>Run results processed for a particular element over a defined period, and run results for selected input values of each employee’s last assignment process.</td>
</tr>
<tr>
<td>Employee Deductions Not Taken (Oracle Payroll)</td>
<td>Listing of employees and deductions that may not have been taken due to insufficient net and whether the amount was arreared or not.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Information Provided</td>
</tr>
<tr>
<td>-------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Employee Deductions Taken (Oracle Payroll)</td>
<td>Listing of employees that had each deduction taken during a given payroll run.</td>
</tr>
<tr>
<td>Employee Increment Results</td>
<td>The <em>actual</em> results of running the Increment Progression Points process, that is progression point and value changes for a group of employees.</td>
</tr>
<tr>
<td>Employee Organization Movements</td>
<td>New hires, terminations, transfers in and transfer out of a selected organization, or organization hierarchy.</td>
</tr>
<tr>
<td>Employee Payroll Movements</td>
<td>New hires, terminations, transfers in and transfer out of a selected payroll.</td>
</tr>
<tr>
<td>Employee Run Results (Oracle Payroll)</td>
<td>Users may select various elements for the various time frames, assignments of GRES. The report shows the run results for selected information by pay period.</td>
</tr>
<tr>
<td>Employee Summary</td>
<td>Addresses, contacts, periods of service, assignments, special information, personal payment methods and element entries for a selected employee.</td>
</tr>
<tr>
<td>Federal W-2 (magnetic media) (Oracle Payroll)</td>
<td>Creation of Federal W-2 magnetic media and summary totals.</td>
</tr>
<tr>
<td>Federal W-2 Forms (Oracle Payroll)</td>
<td>Prints employee W-2s at an individual level, thus allowing W-2s to be created as employees terminate, or for an entire GRE.</td>
</tr>
<tr>
<td>Federal 1099-R (magnetic media) (Oracle Payroll)</td>
<td>Creation of Federal 1099-R magnetic media</td>
</tr>
<tr>
<td>Federal 1099-R Forms (Oracle Payroll)</td>
<td>Provides for printing of retiree 1099-R at an individual level as well as all employees in a GRE.</td>
</tr>
<tr>
<td>Full Applicant Details</td>
<td>Applications and applicant interviews for one applicant.</td>
</tr>
<tr>
<td>Full Assignment Details</td>
<td>Assignment information including periods of service, payment methods, and element entries for one employee.</td>
</tr>
<tr>
<td>Full Personal Details Report Set</td>
<td>Person details, applicant details, assignment details and work details for one employee.</td>
</tr>
<tr>
<td>Full Person Details</td>
<td>Addresses and information entered in the Person window such as name, date of birth, nationality and work telephone number for one employee.</td>
</tr>
<tr>
<td>Full Work Details</td>
<td>Miscellaneous work information including special information, absences, recruitment activities and contacts for one employee.</td>
</tr>
<tr>
<td>GRE Totals (Oracle Payroll)</td>
<td>Reconciliation report to be used to assist in period end processing balancing purposes. This report shows Federal and State level taxable balances and withholdings.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Information Provided</td>
</tr>
<tr>
<td>---------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Invalid Address Information (Oracle Payroll)</td>
<td>Lists any address information inconsistencies.</td>
</tr>
<tr>
<td>Job and Position Skills Matching</td>
<td>Lists of employees, applicants or both that meet some or all skill requirements of a job or position.</td>
</tr>
<tr>
<td>NACHA (magnetic media) (Oracle Payroll)</td>
<td>Provides for creation of employee NACHA information to be submitted.</td>
</tr>
<tr>
<td>NACHA Report (Oracle Payroll)</td>
<td>Detail of employee NACHA information.</td>
</tr>
<tr>
<td>Negative Balance Report (Oracle Payroll)</td>
<td>Report listing any negative balances found due to user adjustments or conversion issues.</td>
</tr>
<tr>
<td>Organization Hierarchy</td>
<td>The organizations and optionally their managers below a selected organization in a particular hierarchy.</td>
</tr>
<tr>
<td>Payment Register (Checks and Direct Deposits) (Oracle Payroll)</td>
<td>Report listing payments made to employees, listing payment method, check number, and amount.</td>
</tr>
<tr>
<td>Position Hierarchy</td>
<td>The positions and optionally their holders below a selected position in a particular hierarchy.</td>
</tr>
<tr>
<td>Report of Income and Employment (Form 941) Information (Oracle Payroll)</td>
<td>Provides total figures to do annual 941 reporting.</td>
</tr>
<tr>
<td>Requisition Summary</td>
<td>Applicants and their interview schedules for a selection of vacancies.</td>
</tr>
<tr>
<td>Salary Review</td>
<td>Current, past and proposed salaries for a selected list of employees.</td>
</tr>
<tr>
<td>Series EE Bond Purchase Report (Oracle Payroll)</td>
<td>Compares actual staffing level with budgeted levels over a specific period.</td>
</tr>
<tr>
<td>Staffing Budget Details</td>
<td>Actual staffing level with budgeted levels over a specified period.</td>
</tr>
<tr>
<td>Statement of Earnings with Check attached (Oracle Payroll)</td>
<td>Statement showing employee information, filing status, vacation and sick balances along with Earnings and Deductions (both current and year–to–date).</td>
</tr>
<tr>
<td>Statement of Earnings with Direct Deposit Advice attached (Oracle Payroll)</td>
<td>Statement showing employee information, filing status, vacation and sick balances along with Earnings and Deductions (both current and year–to–date).</td>
</tr>
<tr>
<td>State Quarterly Wage Listing (magnetic media) (Oracle Payroll)</td>
<td>Creation of magnetic media for state quarterly wage filing, along with a detailed audit report.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Information Provided</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>State 1099-R (magnetic media) (Oracle Payroll)</td>
<td>Creation of State 1099-R magnetic media.</td>
</tr>
<tr>
<td>Tax Summary Listing (Oracle Payroll)</td>
<td>Report giving figures needed for tax remittance filings.</td>
</tr>
<tr>
<td>Taxable Balance Verification (Oracle Payroll)</td>
<td>Reconciliation report identifying any conversion or adjustment discrepancies, by comparing calculated withholdings against withheld balances in the system.</td>
</tr>
<tr>
<td>Terminations</td>
<td>The number of employees from selected organizations leaving your enterprise within a particular period, and the reason for leaving.</td>
</tr>
<tr>
<td>Third Party Payment Register (Oracle Payroll)</td>
<td>Listing of third parties for which checks were generated with amounts and employees that are being represented by this amount.</td>
</tr>
</tbody>
</table>

You can create your own reports using Oracle Reports or SQL*Plus or another tool of your choice. You can register them with Application Object Library. This means you can run them from the standard Submit Requests window, and you can schedule them in report sets with other reports and processes.
Defining Custom Reports

The Custom Reports function provides a generic reporting capability that makes use of a single report to print out a custom definition. This report is called PERGENRP.

The report is registered as a concurrent process and prints, in landscape format, the contents of the temporary table PER_GENERIC_OUTPUT_REPORT.

This table contains the individual components of a custom report and is populated by the PL/SQL package PERGENRP.pkb, stored in $PER_TOP/admin/sql. This package is executed when you select the Generate Report button on the Custom Reports window.

To submit a Custom Report:

1. Navigate to the Custom Reports window.
2. Select the report by name.
3. Enter any parameters for this report.
4. Choose the Generate Report button

Attention: Parameter values are not validated until you choose the Generate Report button.

The default for the report is to print the output automatically. It is a System Administrator task to set default printers for all users, or to reset this option on the Concurrent Program window.

Creating New Report Formats

A special feature of Custom Reports is that you do not need to create multiple reports. You modify the generic package (PERGENRP.pkb) and report to provide additional formats and parameters.

Three sample report formats are provided, each with a different set of parameters:

- PERCS001 – Custom Report 1
  There is one parameter: Vacancy. The format in PERGENRP is Full Name of Applicant and Gender.

- PERCS002 – Custom Report 2
  Parameters are Vacancy and Gender. The format in PERGENRP is Full Name of Applicant in uppercase.

- PERCS003 Custom Report 3
Parameters are Vacancy, Gender and Marital Status. The format in PERGENRP is *Full Name of Applicant, Gender and then Full Name* in uppercase.

You can edit the generic package to change:

- Report Title Page
- Header
- Footer
- Body Text

After you have modified the package, you need to register a new custom report, with the parameter set for that report. This is a task for the System Administrator.

**To register a new Custom Report with parameters:**

1. Navigate to the Concurrent Programs window.
2. Enter the name of the Custom Report as the Program.
3. Enter a short name for the Custom Report.

   **Attention:** You must start the short name with PERCS. This will limit the list of values available to users in the Custom Report window.
Creating an Assignment Set

There are three uses of assignment sets in Oracle HRMS:

- You can run a QuickPaint report for a set of assignments, rather than individual assignments.

- You can process subsets of the employees assigned to a payroll. Normally you initiate payroll runs and other post-run processes for one or more payrolls at a time. However, if you need to process smaller groups within a single payroll, you define an assignment set.

- You can use a BEE concurrent process to create an identical batch line for each assignment in an assignment set.

There are three ways to define the set:

- You can enter selection criteria, which the system generates into a formula. When you use the assignment set, Oracle FastFormula runs the formula to find the assignments that match the criteria. It checks all the assignments in the Business Group or, if you select a payroll when you define the set, all the assignments to that payroll. When you define the set you can also include or exclude individual assignments to modify the set created by the formula.

  See: Defining an Assignment Set Using Formula Criteria: page 4 – 22

- You can select individually all the assignments you want to include in the set.

- You can start from a full set of all the employees in the Business Group or all the employees assigned to a selected payroll. Then you can exclude individual assignments from the set.

  See: Defining an Assignment Set by Including or Excluding Assignments: page 4 – 25
Defining an Assignment Set Using Formula Criteria

Use the Assignment Set window to define your set.

To define an assignment set using criteria for a formula:

1. Enter a unique name for the set.
2. Do one of the following:
   - If you are defining an assignment set for payroll processing, select a payroll. You cannot process an assignment set drawn from more than one payroll.
   - If you are defining an assignment set for other purposes, selecting a payroll is optional. If you select a payroll, the formula generated from your selection criteria will select assignments from this payroll only. If you do not select a payroll, the formula will select assignments from the whole Business Group.
3. Save the new set and choose the Criteria button.
4. In the Assignment Criteria window, enter one criterion in each row, and join the criteria with AND or OR in the Condition field. Field details are as follows:

   No.: The sequence number of each condition in your rule. If you use sequence numbers that are multiples of 10, it will be easier to insert new conditions later.

   Condition: Leave the first row blank. Enter AND or OR for second and subsequent rows.

   Database Item: Select database items as variables for your definition. All database items are prefixed by an ampersand [&].

   Operator: Select operators to determine relationships between database items or values. The list of operators is shown in the Values in Operator Field table.

   Value/Database Item: Select database items for the second variable. Alternatively, you can enter a fixed value of the same type as the database item.

As an example, here is a definition for an assignment set of employees with salaries between 16,000 and 24,000:
<table>
<thead>
<tr>
<th>No.</th>
<th>Condition</th>
<th>Database Item</th>
<th>Operator</th>
<th>Value/Database Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td></td>
<td>&amp;SALARY_PAY_VALUE_ENTRY_VALUE</td>
<td>&gt;=</td>
<td>16000</td>
</tr>
<tr>
<td>20</td>
<td>AND</td>
<td>&amp;SALARY_PAY_VALUE_ENTRY_VALUE</td>
<td>&lt;=</td>
<td>24000</td>
</tr>
</tbody>
</table>

Assignment Set Criteria

5. Save your criteria and choose the Generate button to generate the formula.

You can view and edit the formula in the Formula window. Its name is the same as the assignment set name.

6. If you want to include or exclude individual assignments from the set defined by your criteria, choose the Amendment button. Select the assignments you want to include or exclude from the set.

**Note:** The list of assignments you see in this window is either all the assignments in the Business Group or, if you selected a payroll, all the assignments to that payroll. It does not show the assignments matching your criteria since these are identified dynamically each time the formula runs.

7. Save the set.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Symbols</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equals</td>
<td>=</td>
<td>The condition is true if both expressions have exactly the same value. For text, the case of the expression must be the same. So, for example, 'Smith' is not equal to 'SMITH'.</td>
</tr>
<tr>
<td>Not Equal</td>
<td>!=</td>
<td>The condition is true if the result of the first expression does NOT have the same value as the result of the second expression.</td>
</tr>
<tr>
<td>Greater than</td>
<td>&gt;</td>
<td>The condition is true if the first expression is alphabetically after, or has a numerically greater value, or a later date than the second expression.</td>
</tr>
<tr>
<td>Less than</td>
<td>&lt;</td>
<td>The condition is true if the first expression is alphabetically before, or has a numerically smaller value, or an earlier date than the second expression.</td>
</tr>
<tr>
<td>Operator</td>
<td>Symbols</td>
<td>Meaning</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Greater than or equal to</td>
<td>&gt;=</td>
<td>The condition is true if either the greater than OR the equal to operator returns a true result.</td>
</tr>
<tr>
<td>Less than or equal to</td>
<td>&lt;=</td>
<td>The condition is true if either the less than OR the equal to operator returns a true result.</td>
</tr>
</tbody>
</table>

Values in Operator Field
Defining an Assignment Set by Including or Excluding Assignments

Use the Assignment Set window to define your set.

To define a set by including or excluding assignments:

1. Enter a unique name for the set.
2. If you are defining a set for payroll processing, select a Payroll.
3. Save the new set.
4. Choose the Amendment button.
5. Do one of the following:
   - If you want to create a small set of assignments, select Include in the Inc/Exc field and select all the assignments for the set.
   - If you want to start from the full set of assignments for the payroll or Business Group, select Exclude in the Inc/Exc field and select assignments to remove from the set.

Attention: Do not create a mixture of Include and Exclude rows if you have not entered criteria and generated a formula.
6. Save your set.
Letter Generation
Letter Generation

Standard letters enable you to manage your enterprise’s recruitment or enrollment activities more easily. Using Oracle Human Resources or Oracle Training Administration, you can issue standard letters to applicants and students respectively, triggered by changes in assignment or enrollment status. For example, you can set up a standard enrollment confirmation letter that is triggered when a student’s enrollment status is set to Placed or you can set up a rejection letter that is triggered when an applicant’s assignment status is set to Rejected.

Here are a few examples of letters you can set up to help you to manage recruitment or enrollment activities:

<table>
<thead>
<tr>
<th>Oracle Human Resources</th>
<th>Oracle Training Administration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acknowledgement letters (for all active applications)</td>
<td>Acknowledgement letters (for all requested enrollments)</td>
</tr>
<tr>
<td>Confirmation letters (for interviews)</td>
<td>Confirmation letters (for placed enrollments, including event joining instructions based on the date, venue, and trainers)</td>
</tr>
<tr>
<td>Reports for interviewers and schedules</td>
<td>Reports for trainers (listing the students to attend an event)</td>
</tr>
<tr>
<td>Offer and Rejection letters (for applicants)</td>
<td>Chase–up letters (for non–response or non–payment)</td>
</tr>
<tr>
<td></td>
<td>Acknowledgement letters (for cancellations)</td>
</tr>
<tr>
<td></td>
<td>Certificates (of successful course completion)</td>
</tr>
</tbody>
</table>
Letter Generation Overview

There are two different methods provided to create standard letters:

- Online using Application Data Exchange (ADE), Application Data Exchange and Hierarchy Diagrammers User’s Guide.
- Concurrent processing: page 5 – 4

Which Method Should You Use?

Use the online method (ADE), if you want to generate and review your letters immediately.

ADE enables you to generate standard letters and reports by retrieving data and exporting it to a data file that is merged with a standard word processed document. The word processed document includes all the merge fields required to merge the data and the standard text for the letter. ADE is fully compatible with Microsoft Word 6.

You can use ADE to generate standard letters for recruitment or enrollment by performing a mail merge from the Request Letter window in your application.

Alternatively, you can use the concurrent processing method to set up your standard letters. With concurrent processing, you generate and review your letters without interrupting other work you perform at your computer. You can control when a concurrent process runs and schedule long–running processes to run at times when the system is lightly loaded. Another advantage of using concurrent processing is that you do not need to have Windows 95 or 98, Excel or Lotus 123 installed.
Concurrent Processing

There are two methods of using concurrent processing to set up your standard letters:

- Using Oracle Reports
- Using word processors

Using Oracle Reports

As an alternative to using a word processor to produce standard letters, you can use the Standard Letter and Label features of Oracle Reports. Use this method if you do not want to use word processors to print your letters (or if you do not have word processors).

See: Using Oracle Reports: page 5 – 7 to set up your standard letters.

Using Word Processors

You can use any word processor to produce standard letters from Oracle HRMS. If you use a word processor, you can submit a concurrent request in the Letter Request window to generate the mail merge file. When the concurrent request is complete, you can use your word processor’s mail merge facilities to create the merged letters.

To create standard letters using a word processor, you need to extract the data you want to include in the letters from the Oracle HRMS database. To do this, create a program, such as a SQL*Plus script, to extract the data, which is then stored in a data file. You also write skeleton standard letters using your word processor.

**Note:** Oracle HRMS supplies SQL*Plus script templates for use with MultiMate, WordPerfect and Microsoft Word. It also supplies two sample Microsoft Word documents containing merge codes for the SQL*Plus scripts. You can copy the SQL*Plus script templates (or Word documents) and modify them to create the standard letters you require.

Each time you run your SQL*Plus script, it extracts data to the data file. You then use the mail merge features of your word processor to merge this data with the skeleton standard letters you previously prepared. This merging process creates the actual letters that you send out to students and applicants.

An overview of creating standard letters using a word processor is shown in the following figure.
If you want to set up standard letters using the concurrent processing method with MultiMate, WordPerfect Microsoft Word, see: Method 1 – Concurrent Processing: page 5 – 6

If you use Microsoft Word as your word processor, not only can you use the concurrent processing method to produce your standard letters, but you can also generate letters online using Oracle Application Data Exchange (ADE).

See: Application Data Exchange (ADE) Overview, Using Application Data Exchange and Hierarchy Diagrammers.
Creating Standard Letters

Oracle HRMS provides you with two different methods to create standard letters:

- Method 1 – Concurrent Processing: page 5 – 6

Method 1 – Concurrent Processing

There are two methods of using concurrent processing to set up your standard letters:

- Using word processors: page 5 – 6 (MultiMate, WordPerfect or Microsoft Word)
- Using Oracle Reports: page 5 – 7

Word Processors

If you are setting up standard letters using MultiMate, WordPerfect or Microsoft Word, follow these steps:

<table>
<thead>
<tr>
<th>Task</th>
<th>Performed By:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planning Standard Letter Requirements: page 5 – 8</td>
<td>System Administrator</td>
</tr>
<tr>
<td>Writing a SQL<em>Plus Script for Multi-Mate or WordPerfect: page 5 – 9 or Writing a SQL</em>Plus Script for Microsoft Word: page 5 – 16</td>
<td>Yes</td>
</tr>
<tr>
<td>Registering the SQL*Plus Script: page 5 – 10</td>
<td>Yes</td>
</tr>
<tr>
<td>Linking the SQL*Plus Script With a Letter: page 5 – 11</td>
<td>Yes</td>
</tr>
<tr>
<td>Writing a Skeleton Letter: page 5 – 12</td>
<td>Yes</td>
</tr>
<tr>
<td>Requesting Letters/Running the Report: page 5 – 13</td>
<td>Yes</td>
</tr>
<tr>
<td>Merging the Data Files with the Standard Letter: page 5 – 15</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Using Oracle Reports to Set Up Standard Letters

You can create a report for each letter using Oracle Reports, or another tool of your choice. The report contains the skeleton letter text and Select statements specifying the data to be extracted from the Oracle database.

The sequence in which you set up standard letters using Oracle Reports is identified below.

<table>
<thead>
<tr>
<th>Task</th>
<th>Performed By:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planning Standard Letter Requirements: page 5 – 8</td>
<td>System Administrator</td>
</tr>
<tr>
<td>Writing and Registering the Report: page 5 – 18</td>
<td>HRMS Manager</td>
</tr>
<tr>
<td>Linking the Report With a Letter: page 5 – 19</td>
<td>Yes</td>
</tr>
<tr>
<td>Requesting Letters/Running the Report: page 5 – 13</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Planning Standard Letter Requirements

Before creating standard letters, you need to identify several things.

**To plan standard letter requirements:**

1. Identify the database information to include in the letters.
   
   You need to identify the select statements to provide you with the data as the *content* of your letters. Oracle HRMS supplies you with SQL*Plus scripts as templates to help you do this.

2. Identify the text that you want to include as the *body* of your letters.

3. Decide whether to associate your standard letters with student enrollment or applicant assignment statuses.

4. Identify which statuses you want to trigger your standard letters (if you do want to link your standard letters to student enrollment or applicant assignment statuses).

   For example, do you want to link your standard enrollment confirmation letter to the status Placed so that the letter is triggered when you set a student’s enrollment status to Placed? Do you want to link your standard rejection letter to the status Rejected so that it is triggered when an applicant’s assignment status is set to Rejected?
Writing a SQL*Plus Script for MultiMate or WordPerfect

Oracle HRMS supplies you with SQL*Plus scripts as templates for extracting database information for standard letters. You can copy the SQL*Plus script templates and modify them to create the standard letters you require.

The template scripts Oracle HRMS provides are:

<table>
<thead>
<tr>
<th>Scripts</th>
<th>Purpose</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>PERWPMUK.sql</td>
<td>Example UK SQL*Plus script for MultiMate</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPMUS.sql</td>
<td>Example US SQL*Plus script for MultiMate</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPWUK.sql</td>
<td>Example US SQL*Plus script for WordPerfect</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPWUS.sql</td>
<td>Example US SQL*Plus script for WordPerfect</td>
<td>HR</td>
</tr>
</tbody>
</table>

One of the template SQL*Plus scripts (PERWPWUK.sql) is provided as an example. See PERWPWUK Template: page C – 5.

Oracle Training Administration does not provide template scripts, but we provide an example of a Confirmation letter SQL mail merge file. See OTA SQL*Plus Script: page C – 7

To write a SQL*Plus script for MultiMate or WordPerfect:

1. Copy the appropriate SQL*Plus script from the server side sql directory of the HR product tree (consult your installation guide for details).

2. Edit (or write) a SQL*Plus script to select data from the database in a format your word processor can read and that is compatible with the standard letter.

3. Save the file with the name PERWP*** (or OTAWP*** for OTA).

You must use this prefix for the system to recognize it as a type of letter. See your Oracle Applications installation server guides for details of where the concurrent manager places the files.
Registering the SQL*Plus Script

Register your SQL*Plus program with Oracle HRMS. You register your program so that you can run it as a concurrent program. Name the file PERWP*** (or OTAWP***). You must use this prefix for the system to recognize it as a type of letter.

You use the Concurrent Programs window to register your program (using a system administrator responsibility).

See: Concurrent Programs Window, Oracle Applications System Administrator’s Guide
Linking the SQL*Plus Script With a Letter

You need to link your SQL*Plus script with a letter and one or more statuses. In Oracle Human Resources, you can link one or more applicant assignment statuses with each recruitment letter. A request for the letter is then created automatically when an applicant is given an associated assignment status. For example, you can link your standard recruitment rejection letter to the status Rejected so that the letter is triggered when you set an applicant’s assignment status to Rejected.

In Oracle Training Administration, you can link one or more enrollment statuses with each enrollment letter. A request for the letter is then created automatically when an enrollment is given an associated status.

Define your standard letter types in the Letter window.

To define a standard letter type:

1. Enter a name for the letter in the Name field.
2. Select the Concurrent Program Name assigned by your System Administrator to the SQL*Plus script.

For Oracle Human Resources:

3. Select one or more applicant assignment statuses to create letter requests automatically for applicants, and check the Enabled box.

   When an applicant is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the applicant is added to the list of people to receive the letter when you submit the request.

For Oracle Training Administration:

4. Select one or more enrollment statuses to create letter requests automatically for enrollments, and check the Enabled box.

   When an enrollment is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the enrollment is added to the list of people to receive the letter when you submit the request.
Writing a Skeleton Letter

Write a skeleton letter using your word processor. Include the appropriate merge codes from the data source for the word processor you are using.

Figure 5–2 Merging Data with Standard Letters

The mail merge feature of any word processor enables you to merge text from the data file you create into a standard letter. Each line in the data file contains the text to merge into one standard letter for one recipient.

Within the program, you can format the data and include the characters that are recognized as separators by your word processor.

A standard letter comprises standard text with a number of embedded variables in it. When you print the letter, the variables are replaced with specific items of data, such as name and address details for different people.
Requesting Letters/Running the Report

When you, or other users, set the status for an applicant or enrollment that triggers your standard letters, Oracle HRMS creates a letter request automatically, with the status of Pending. It also adds the applicant’s or student’s name to the request. You can view the pending request and names through the Request Letter window.

Then, when you change the letter request from Pending to Requested, Oracle HRMS runs the report or SQL*Plus script for this type of letter.

You can add further names to the list manually, if required. For example, you might have a last minute acknowledgement letter to send.

You can also create manual letter requests. You do this by entering the status of Pending yourself, then entering all the recipients of the letter before changing the status of the letter to Requested.

➤ To submit an automatic letter request:

1. Query the letter you require in the Letter Name field.
2. Ensure that the method is Automatic.
3. Move to the Requested For block to query the applicants, events or students that have been entered automatically on this request, according to their status. You can add further names manually.
4. Update the status from Pending to Requested.
5. Save your changes.

A concurrent request ID number appears in the Concurrent Request field. When the Concurrent Manager has processed the request it changes the status to Completed.

6. You can query the request ID in the Concurrent Requests window and monitor its progress.

Note: Consult your installation guide for details of the location Concurrent Manager places the output or data file.

➤ To create a manual letter request:

1. Select the Letter Name for the letter type you want to request.
2. Ensure that the method is Manual.
3. Leave the status of the request as Pending.
4. Save the changes.
Adding the Names

5. Select the names to add:

- Select employees or applicants (for Oracle Human Resources) to receive the letter in the Requested For region.

  The Assignment field displays the organization to which the person is assigned. You can view the other components of the assignment by choosing List of Values from the Edit menu.

- Select events or students or both (for Oracle Training Administration) in the Requested For region.

  This depends on how the letter has been set up on your system. For example, an enrollment confirmation letter might be defined so that it is sent to all students with the status Confirmed who are enrolled on the event selected in the Requested For region.

6. Save the changes.

Changing the Status

7. Update the status from Pending to Requested.

8. Save the changes.

  A concurrent request ID number appears in the Concurrent Request field. When the Concurrent Manager has processed the request it changes the status to Completed.

9. You can query the request ID in the Concurrent Requests window and monitor its progress.

  Note: Consult your installation guide for details of the location Concurrent Manager places the output file.
Merging the Data File with the Standard Letter

When the concurrent manager has finished processing a letter request, you can merge the data in the Data File with your skeleton letters.

To merge the data file with the standard letter:

1. Merge the data in the Data File with your skeleton letters to create your standard letters. The merging of text and data files is normally carried out using the mail merge features of your word processor.

   If you do not have access to the directory where the Data File resides (consult your installation guide for details of the location Concurrent Manager places the file), you need to transfer the mail merge files created by the concurrent process to your word processor before you can merge the data file with the skeleton letters.

2. If you are using a word processor to merge the data file, you need to save the merged letters you generate.

   If you do not save the merged letters, when you exit the word processor you lose the letters. You do not lose the data file or the skeleton letter, however.
Writing a SQL*Plus Script for Microsoft Word

Oracle HRMS supplies SQL*Plus script templates. It also supplies two sample Microsoft Word documents containing merge codes for the SQL*Plus scripts.

You can run the scripts on the server side and make them accessible to other users across the network, or you must copy them to a directory which is accessible from the PC, such as a network drive. You must also make the Microsoft Word documents accessible to other users across the network, or you must copy them to each PC.

The template scripts and Microsoft Word documents Oracle HRMS provides are:

<table>
<thead>
<tr>
<th>Scripts</th>
<th>Purpose</th>
<th>Used By</th>
</tr>
</thead>
<tbody>
<tr>
<td>PERWPOUS.sql</td>
<td>Example US Offer letter SQL mail merge file</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPOUK.sql</td>
<td>Example UK Offer letter SQL mail merge file</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPIUS.sql</td>
<td>Example US Interview letter SQL mail merge file</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPIUK.sql</td>
<td>Example UK Interview letter SQL mail merge file</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPOUS.doc</td>
<td>Example US Offer MS Word document</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPOUK.doc</td>
<td>Example UK Offer MS Word document</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPIUS.doc</td>
<td>Example US Interview MS Word document</td>
<td>HR</td>
</tr>
<tr>
<td>PERWPIUK.doc</td>
<td>Example UK Interview MS Word document</td>
<td>HR</td>
</tr>
</tbody>
</table>

One of the template SQL*Plus scripts is provided as an example. See Template SQL*Plus Script PERWPOUK: page C – 2

Oracle Training Administration does not provide template scripts, but we provide an example of a Confirmation letter SQL mail merge file. See OTA SQL*Plus Script: page C – 7

To write a SQL*Plus script for Microsoft Word:

1. Copy the SQL*Plus scripts from the server side sql directory of the HR product tree. (Consult your installation guide for details).

You can copy the word documents from the client–side directory [APPL_TOP]\PER76\LETGEN.
2. Edit (or write) a SQL*Plus script to select data from the database in a format your word processor can read and is compatible with the standard letter.

3. Save the file with the name PERWP*** (or OTAWP*** for OTA).
   You must use this prefix for the system to recognize it as a type of letter. See your Oracle Applications installation server guides for details of where the concurrent manager places the files.
Writing and Registering the Report

You need to write and register the report.

To write and register the report:

1. Identify which data you want to extract from the database. Write your skeleton letter text and Select statements specifying the data to be extracted from the Oracle database.

2. Register your report with Oracle HRMS. You register your report so that you can run it as a concurrent program. Name the file PERWP*** (or OTAWP*** for OTA). You must use this prefix for the system to recognize it.

   You use the Concurrent Programs window to register your report (using a system administrator responsibility).

See: Concurrent Programs Window, Oracle Applications System Administrator’s Guide
Linking the Report With a Letter

You need to link your report with a letter and one or more statuses. In Oracle Human Resources, you can link one or more applicant assignment statuses with each recruitment letter. A request for the letter is then created automatically when an applicant is given an associated assignment status. In Oracle Training Administration, you can link one or more enrollment statuses with each enrollment letter. A request for the letter is then created automatically when an enrollment is given an associated status.

For example, you can link your standard recruitment rejection letter to the status Rejected so that the letter is triggered when you set an applicant’s assignment status to Rejected.

Define your standard letter types in the Letter window.

To define a standard letter type:

1. Enter a name for the letter in the Name field.
2. Select the concurrent program name assigned by your system administrator to the report.
3. Select one or more applicant assignment statuses to create letter requests automatically for applicants, and check the Enabled box.

   When an applicant is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the applicant is added to the list of people to receive the letter when you submit the request.

4. Select one or more enrollment statuses to create letter requests automatically for enrollments, and check the Enabled box.

   When an enrollment is given one of these statuses, a pending request for this letter type is created automatically. If a pending letter request already exists, the enrollment is added to the list of people to receive the letter when you submit the request.
This appendix includes information about:

- Default navigation menu for SuperHRMS responsibility
- Windows and their navigation paths
- Reports and process in Oracle HRMS
Default Navigation Menu for SuperHRMS Responsibility

This appendix shows the default menu path for each window in Oracle HRMS. Your system administrator can define new menus to incorporate the Oracle HRMS options to the existing responsibilities at your site.

The second section shows the default navigation paths for all the windows in Oracle HRMS, which are arranged alphabetically by window title. The windows for optional Oracle HRMS applications (such as Oracle SSP/SMP) are shown with their default responsibilities.

<table>
<thead>
<tr>
<th>MENU ENTRY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>People</td>
<td>Enter personal and assignment information</td>
</tr>
<tr>
<td>Enter and Maintain</td>
<td>Enter people, assignments, and applications</td>
</tr>
<tr>
<td>Salary Management</td>
<td>Manage salary details</td>
</tr>
<tr>
<td>Benefits Service Center</td>
<td>Enter changes to a person record and process elections</td>
</tr>
<tr>
<td>Total Comp Participation</td>
<td></td>
</tr>
<tr>
<td>Person Benefit Balances</td>
<td>Enter benefit balances for a person</td>
</tr>
<tr>
<td>Person Benefits Assignment</td>
<td>Maintain person benefits assignment</td>
</tr>
<tr>
<td>View Participation Information</td>
<td>View eligible plans and options for a person</td>
</tr>
<tr>
<td>What–if Eligibility</td>
<td>Modify benefits eligibility based on potential changes</td>
</tr>
<tr>
<td>COBRA Qualified Beneficiaries</td>
<td>Maintain COBRA Qualified beneficiary information</td>
</tr>
<tr>
<td>Total Comp Enrollment</td>
<td></td>
</tr>
<tr>
<td>View Enrollment Results</td>
<td>View current enrollments</td>
</tr>
<tr>
<td>Flex Program</td>
<td>Enter flex credit program enrollments</td>
</tr>
<tr>
<td>Non–flex Program</td>
<td>Enter non–flex program enrollments</td>
</tr>
<tr>
<td>Savings Plan</td>
<td>Enter savings plan enrollments</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Miscellaneous Plan</td>
<td>Enter enrollments for plans that are not in a program</td>
</tr>
<tr>
<td>Enrollment Override</td>
<td>Plan enrollment override</td>
</tr>
<tr>
<td>Dependent/Beneficiary Designation</td>
<td>Record dependents and beneficiaries for a benefit plan</td>
</tr>
<tr>
<td>Person Primary Care Provider</td>
<td>Record a participant’s primary care provider</td>
</tr>
<tr>
<td>Court Orders</td>
<td>Record court orders for participants</td>
</tr>
</tbody>
</table>

**Enrollment Process**

<table>
<thead>
<tr>
<th>Menu Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Person Life Event</td>
<td>View a person’s active life event</td>
</tr>
<tr>
<td>Person Enrollment Action Items</td>
<td>Record the completion of an action item</td>
</tr>
<tr>
<td>Person Enrollment Certifications</td>
<td>Record receipt of a certification</td>
</tr>
<tr>
<td>Person Communications</td>
<td>Send a communication</td>
</tr>
</tbody>
</table>

**Total Comp Distribution**

<table>
<thead>
<tr>
<th>Menu Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reimbursement Requests</td>
<td>Record a request for expense reimbursement</td>
</tr>
</tbody>
</table>

**Total Comp Contribution**

<table>
<thead>
<tr>
<th>Menu Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record Continuing Benefits Payment</td>
<td>Record amount paid for a continuing benefit</td>
</tr>
<tr>
<td>Monthly Participant Premium</td>
<td>Monitor monthly participant premium information</td>
</tr>
<tr>
<td>Manual Payments</td>
<td>Maintain participant contribution/distribution information</td>
</tr>
</tbody>
</table>

**Events and Bookings**

<table>
<thead>
<tr>
<th>Menu Entry</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete Personal Records</td>
<td>Remove all records for any person</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>--------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>FastPath</td>
<td>Enter personal and assignment information quickly</td>
</tr>
<tr>
<td>Absence</td>
<td>Enter absence information</td>
</tr>
<tr>
<td>Accruals</td>
<td>View net accruals to date</td>
</tr>
<tr>
<td>Address</td>
<td>Enter address details</td>
</tr>
<tr>
<td>Adjust Balances</td>
<td>Adjust balances</td>
</tr>
<tr>
<td>Application</td>
<td>Enter application details</td>
</tr>
<tr>
<td>Assignment</td>
<td>Enter assignment details</td>
</tr>
<tr>
<td>Assignment Budget</td>
<td>Enter budget values for an assignment</td>
</tr>
<tr>
<td>Assignment Extra Information</td>
<td>Enter Extra Information Types for an assignment</td>
</tr>
<tr>
<td>Basic Benefits</td>
<td>View basic benefit details</td>
</tr>
<tr>
<td>Competence Profile</td>
<td>Define a competence profile</td>
</tr>
<tr>
<td>Contact</td>
<td>Enter contact information</td>
</tr>
<tr>
<td>Costing</td>
<td>Enter cost information</td>
</tr>
<tr>
<td>Employee Balances</td>
<td>View employee balances</td>
</tr>
<tr>
<td>Employee Review</td>
<td>Perform an employee review</td>
</tr>
<tr>
<td>End Application</td>
<td>End an application</td>
</tr>
<tr>
<td>End Employment</td>
<td>Enter termination details for an employee</td>
</tr>
<tr>
<td>Entries</td>
<td>Maintain element entries and values for an assignment</td>
</tr>
<tr>
<td>Event</td>
<td>Book an event for a person</td>
</tr>
<tr>
<td>External/Manual Payments</td>
<td>Enter external or manual payments for an employee</td>
</tr>
<tr>
<td>Grade Step</td>
<td>Enter grade step placement for an assignment</td>
</tr>
<tr>
<td>Pay Method</td>
<td>Enter personal payment methods for an assignment</td>
</tr>
<tr>
<td>Picture</td>
<td>Enter pictures for a person</td>
</tr>
<tr>
<td>Person Extra Information</td>
<td>Enter Extra Information Types for a person</td>
</tr>
<tr>
<td>Person Type Usage</td>
<td>Enter person types</td>
</tr>
<tr>
<td>Personal Delivery Method</td>
<td>Enter delivery method for personal communications</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td>Phones</td>
<td>Enter phone numbers</td>
</tr>
<tr>
<td>Picture</td>
<td>Enter a picture for a person</td>
</tr>
<tr>
<td>Qualifications</td>
<td>Define qualifications</td>
</tr>
<tr>
<td>QuickPay</td>
<td>Run QuickPay for one employee</td>
</tr>
<tr>
<td>Reverse Payroll Run</td>
<td>Reverse payroll run results for one employee</td>
</tr>
<tr>
<td>Salary</td>
<td>Maintain salary for an employee</td>
</tr>
<tr>
<td>Salary History</td>
<td>View salary history</td>
</tr>
<tr>
<td>Secondary Status</td>
<td>Enter secondary status for an assignment</td>
</tr>
<tr>
<td>Special Information</td>
<td>Enter Special Information Types for a person</td>
</tr>
<tr>
<td>Adjust Tax Balances</td>
<td>Adjust US tax balances</td>
</tr>
<tr>
<td>Tax Balances</td>
<td>View tax balances</td>
</tr>
<tr>
<td>Tax Balance Summary</td>
<td>View tax balance summary information</td>
</tr>
<tr>
<td>US Statement of Earnings</td>
<td>View statement of earnings</td>
</tr>
<tr>
<td>US Tax Information</td>
<td>Enter US tax details</td>
</tr>
<tr>
<td>US/CA Address</td>
<td>Enter US or Canadian address details</td>
</tr>
</tbody>
</table>

**Recruitment**
- **Requisition and Vacancy**
  - Enter a requisition and any vacancies
- **Recruitment Activity**
  - Enter a recruitment activity
- **Applicant Quick Entry**
  - Quick entry of personal and application information
- **Mass Update of Applicants**
  - Mass Update of Applicants
- **Request Recruitment Letter**
  - Request a mailmerge file or a standard letter

**Career Management**
- **Rating Scales**
  - Define general methods of measuring competencies
- **Competencies**
  - Define competencies
- **Competence Types**
  - Group competencies into types
<table>
<thead>
<tr>
<th>MENU ENTRY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Competence Requirements</td>
<td>Define requirements for enterprise, organizations, jobs and positions</td>
</tr>
<tr>
<td>Schools &amp; Colleges</td>
<td>Define name and location of training establishments</td>
</tr>
<tr>
<td>Qualification Types</td>
<td>Define, categorize and rank qualifications</td>
</tr>
<tr>
<td>Assessment Template</td>
<td>Select competencies and rating scale for an assessment</td>
</tr>
<tr>
<td>Appraisal Template</td>
<td>Select questionnaire and rating scale for an appraisal</td>
</tr>
<tr>
<td>Work Structures</td>
<td>Enter work structures</td>
</tr>
<tr>
<td>Location</td>
<td>Enter locations</td>
</tr>
<tr>
<td>Collective Agreements</td>
<td>Set up collective agreements</td>
</tr>
<tr>
<td>Organization</td>
<td>Enter organizational information</td>
</tr>
<tr>
<td>Description</td>
<td>Enter information for an organization</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Structure organizations into hierarchies</td>
</tr>
<tr>
<td>Job</td>
<td>Enter job–related information</td>
</tr>
<tr>
<td>Description</td>
<td>Enter job names</td>
</tr>
<tr>
<td>Path Name</td>
<td>Enter names for job career paths</td>
</tr>
<tr>
<td>Career Path</td>
<td>Enter career paths for jobs</td>
</tr>
<tr>
<td>Workers Compensation Codes</td>
<td>Enter WC codes for jobs</td>
</tr>
<tr>
<td>Workers Compensation Rates</td>
<td>Enter rates for WC codes</td>
</tr>
<tr>
<td>Position</td>
<td>Enter position–related information</td>
</tr>
<tr>
<td>Description</td>
<td>Enter position names</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Structure positions into hierarchies</td>
</tr>
<tr>
<td>Mass Move</td>
<td>Enter details of a mass move</td>
</tr>
<tr>
<td>Grade</td>
<td>Enter grade–related information</td>
</tr>
<tr>
<td>Description</td>
<td>Enter grade names</td>
</tr>
<tr>
<td>Grade Rate</td>
<td>Enter rates and values for grades</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pay Scale</td>
<td>Create a pay scale of fixed progression points</td>
</tr>
<tr>
<td>Point Values</td>
<td>Enter values for progression points</td>
</tr>
<tr>
<td>Grade Steps and Points</td>
<td>Enter grade steps and fixed point values for each step</td>
</tr>
<tr>
<td>Budget Calendar</td>
<td>Define calendars for headcount and position budgets</td>
</tr>
<tr>
<td>Budget</td>
<td>Enter headcount and position budgets</td>
</tr>
<tr>
<td>Status</td>
<td>Define employee and applicant assignment statuses</td>
</tr>
<tr>
<td>Recruitment Letter Type</td>
<td>Associate letter types with applicant statuses</td>
</tr>
<tr>
<td>Payroll</td>
<td>Enter information for payrolls</td>
</tr>
<tr>
<td>Description</td>
<td>Enter payroll groups</td>
</tr>
<tr>
<td>Consolidation</td>
<td>Define consolidation sets for payroll run results</td>
</tr>
<tr>
<td>Payment Methods</td>
<td>Define available payment methods</td>
</tr>
<tr>
<td>GL Flexfield Map</td>
<td>Map payroll costing to Oracle GL flexfield segments</td>
</tr>
<tr>
<td>Update Payroll Run</td>
<td>Update consolidation set or pay advice date</td>
</tr>
<tr>
<td>Assignment Set</td>
<td>Define employee assignment sets</td>
</tr>
<tr>
<td>Element Set</td>
<td>Define element and distribution sets</td>
</tr>
<tr>
<td>RetroPay Set</td>
<td>Define retropay sets using balances and elements</td>
</tr>
<tr>
<td>GL Daily Rates</td>
<td>Enter currency exchange rates for reporting and processing</td>
</tr>
<tr>
<td>Conversion Rate Types</td>
<td>Define conversion rate types for multiple exchange rates</td>
</tr>
<tr>
<td>Monetary Units</td>
<td>Enter monetary units for cash analysis and distribution</td>
</tr>
<tr>
<td>Total Compensation</td>
<td>Enter information on compensation and benefits</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Basic</td>
<td></td>
</tr>
<tr>
<td>Element Description</td>
<td>Enter compensation and benefit information</td>
</tr>
<tr>
<td>Earnings</td>
<td>Activate and review earnings types</td>
</tr>
<tr>
<td>Tax Withholding Rules</td>
<td>Enter withholding rules for earnings</td>
</tr>
<tr>
<td>Link</td>
<td>Enter eligibility rules for compensations and benefits</td>
</tr>
<tr>
<td>Salary Basis</td>
<td>Enter available salary bases for salary administration</td>
</tr>
<tr>
<td>Salary Survey</td>
<td>Enter salary survey information</td>
</tr>
<tr>
<td>Deductions</td>
<td>Activate and review deductions</td>
</tr>
<tr>
<td>Benefit Contributions</td>
<td>Enter benefit contribution levels and values</td>
</tr>
<tr>
<td>Absence Types</td>
<td>Define absence types</td>
</tr>
<tr>
<td>Accrual Plans</td>
<td>Enter accrual plans</td>
</tr>
<tr>
<td>Write Formulas</td>
<td>Enter and modify formulas</td>
</tr>
<tr>
<td>Formula Results</td>
<td>Define what happens to formula results</td>
</tr>
<tr>
<td>Global Values</td>
<td>Enter global values for use in formulas</td>
</tr>
<tr>
<td>Balance</td>
<td>Enter balances with feeds and dimensions</td>
</tr>
<tr>
<td>Classification</td>
<td>Define additional element classifications</td>
</tr>
<tr>
<td>General Definitions</td>
<td></td>
</tr>
<tr>
<td>Eligibility/Rate Factors</td>
<td></td>
</tr>
<tr>
<td>Benefits Groups</td>
<td>Define a benefits group</td>
</tr>
<tr>
<td>Derived Factors</td>
<td>Define derived factors used to determine eligibility and activity rates</td>
</tr>
<tr>
<td>Postal/Zip</td>
<td>Define numeric postal ranges for eligibility and activity rates</td>
</tr>
<tr>
<td>Service Areas</td>
<td>Define a geographical service area by postal code ranges</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Eligibility Profiles</td>
<td></td>
</tr>
<tr>
<td>Participant</td>
<td>Define eligibility profiles for participants</td>
</tr>
<tr>
<td>Dependent Coverage</td>
<td>Define eligibility profiles for dependents</td>
</tr>
<tr>
<td>Additional Setup</td>
<td></td>
</tr>
<tr>
<td>Program/Plan Years</td>
<td>Define periods for benefit programs and plans</td>
</tr>
<tr>
<td>Regulations</td>
<td>Record policies that govern plan administration</td>
</tr>
<tr>
<td>Reporting Groups</td>
<td>Group programs and plans</td>
</tr>
<tr>
<td>Benefits Balances</td>
<td>Define benefit balance types</td>
</tr>
<tr>
<td>Goods and Services</td>
<td>Define reimbursable goods and services</td>
</tr>
<tr>
<td>Life Event Reasons</td>
<td>Define life events</td>
</tr>
<tr>
<td>Collapse Life Events</td>
<td>Define collapsible life events</td>
</tr>
<tr>
<td>Communication Types</td>
<td>Define communications</td>
</tr>
<tr>
<td>Enrollment Action Types</td>
<td>Define action items</td>
</tr>
<tr>
<td>Message Configuration</td>
<td>Define messages to display in Benefits Service Center</td>
</tr>
<tr>
<td>Authentication Activities</td>
<td>Define forms to display in Benefits Service Center</td>
</tr>
<tr>
<td>Programs and Plans</td>
<td></td>
</tr>
<tr>
<td>View Program Structure</td>
<td>View the benefits program hierarchy</td>
</tr>
<tr>
<td>Plan Types</td>
<td>Define benefit plan types</td>
</tr>
<tr>
<td>Options</td>
<td>Define benefit options</td>
</tr>
<tr>
<td>Plans</td>
<td>Define benefit plans</td>
</tr>
<tr>
<td>Plan Enrollment Requirements</td>
<td>Define benefit plan enrollment requirements</td>
</tr>
<tr>
<td>Plan Reimbursements Programs</td>
<td>Define reimbursement plans</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>----------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Program</td>
<td>Define benefit program</td>
</tr>
<tr>
<td>Enrollment</td>
<td>enrollment requirements</td>
</tr>
<tr>
<td>Requirements</td>
<td></td>
</tr>
<tr>
<td>Rates/Coverage Definitions</td>
<td></td>
</tr>
<tr>
<td>Variable Rate Profiles</td>
<td>Define variable activity rate profiles</td>
</tr>
<tr>
<td>Standard Rates</td>
<td>Define activity rate calculations</td>
</tr>
<tr>
<td>Period–to–Date Limits</td>
<td>Define period–to–date limits</td>
</tr>
<tr>
<td>Coverage Calculations</td>
<td>Define benefit coverage calculations</td>
</tr>
<tr>
<td>Coverage Across Plan Types</td>
<td>Define coverage across plan types</td>
</tr>
<tr>
<td>Actual Premiums</td>
<td>Define actual premium costs</td>
</tr>
<tr>
<td>Imputed Income</td>
<td>Define imputed income calculations</td>
</tr>
<tr>
<td>Benefits Pools</td>
<td>Define flex credit benefit pools</td>
</tr>
<tr>
<td>Combinations</td>
<td>Define combinations of plans, plan types, and options and plan types</td>
</tr>
<tr>
<td>Flex Credits</td>
<td>Define flex credit calculations</td>
</tr>
<tr>
<td>Monthly Premiums</td>
<td>Monthly premium information</td>
</tr>
<tr>
<td>Wage Attachment</td>
<td>View Wage Attachment</td>
</tr>
<tr>
<td>Earnings Rules</td>
<td>Define Wage Attachments Earnings Rules</td>
</tr>
<tr>
<td>Exemption Rules</td>
<td>Define Wage Attachments Exemption Rules</td>
</tr>
<tr>
<td>Fee Rules</td>
<td>Define Wage Attachments Fee Rules</td>
</tr>
<tr>
<td>Limit Rules</td>
<td>Define Wage Attachments Limit Rules</td>
</tr>
<tr>
<td>View</td>
<td>View HRMS information</td>
</tr>
<tr>
<td>Histories</td>
<td></td>
</tr>
<tr>
<td>Employee Assignment</td>
<td>Employee assignment history</td>
</tr>
<tr>
<td>Absence</td>
<td>Employee absence history folder</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------------------------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>Run Results</td>
<td>Employee run result history</td>
</tr>
<tr>
<td>Salary</td>
<td>Salary history for an employee assignment</td>
</tr>
<tr>
<td>1 Assignment Folder</td>
<td></td>
</tr>
<tr>
<td>--&gt; 2 Salary History</td>
<td></td>
</tr>
<tr>
<td>Entries</td>
<td>Entry history for an employee assignment</td>
</tr>
<tr>
<td>1 Assignment Folder</td>
<td></td>
</tr>
<tr>
<td>--&gt; 2 Entry History</td>
<td></td>
</tr>
<tr>
<td>Contribution Histories (Def Comp 457)</td>
<td>Employee Contribution History (Deferred Compensation 457)</td>
</tr>
</tbody>
</table>

Lists

| People Folder                               | People folder                             |
| Assignment Folder                          | Assignment folder                         |
| People by Assignment                       | List people by assignment folder          |
| Assignments                                 | List assignments folder                   |
| Employees by Organization                   | List employees by organization folder     |
| Employees by Position                       | List employees by position folder         |
| Emps by Position Hierarchy                 | List employees by position hierarchy folder |
| Employees by Element                        | List employees by element                 |
| Employees by Absence Type                   | List employees by absence type folder     |
| People by Special Information              | List people by special information folder |

Vacancies

| Organization Budgets                       | View organization budget variance folder |

Position Budgets

| Position Budgets                           | View position budget variance folder     |

Grade Comparatio

<p>| Grade Comparatio                           | View employee grade comparatio folder    |</p>
<table>
<thead>
<tr>
<th>MENU ENTRY</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employee Benefits</td>
<td>View benefits for an employee assignment</td>
</tr>
<tr>
<td>Employee Accruals</td>
<td>View net accruals to date</td>
</tr>
<tr>
<td>Employee Balances</td>
<td>View employee balances for earnings and deductions</td>
</tr>
<tr>
<td>Tax Balances</td>
<td>View Employee Tax Balances</td>
</tr>
<tr>
<td>Payroll Process Results</td>
<td>View process results for a payroll</td>
</tr>
<tr>
<td>Assignment Process Results</td>
<td>View process results for an employee assignment</td>
</tr>
<tr>
<td>System Messages</td>
<td>View system level messages</td>
</tr>
<tr>
<td>Processes and Reports</td>
<td></td>
</tr>
<tr>
<td>Submit Processes and Reports</td>
<td>Submit processes or run standard reports</td>
</tr>
<tr>
<td>View Requests</td>
<td>View any requests submitted for processing</td>
</tr>
<tr>
<td>View Reports</td>
<td>View reports online</td>
</tr>
<tr>
<td>Workflow Notifications</td>
<td>Workflow Notifications In–Box</td>
</tr>
<tr>
<td>Batch Process Parameters</td>
<td>Define batch process parameters for benefits</td>
</tr>
<tr>
<td>Monitor Batch Processes</td>
<td>View batch process results for benefits</td>
</tr>
<tr>
<td>Define a QuickPaint Report</td>
<td>Set up the report layout</td>
</tr>
<tr>
<td>Run a QuickPaint Report</td>
<td>View or print the report for a set of people</td>
</tr>
<tr>
<td>Submit Custom Reports</td>
<td>Submit custom reports</td>
</tr>
<tr>
<td>Mass Information eXchange: MIX</td>
<td>Enter timecard and other information batches</td>
</tr>
<tr>
<td>Batch Element Entry</td>
<td>Enter, validate, and transfer element entry batches.</td>
</tr>
<tr>
<td>BEE Summary</td>
<td>View batch summary details</td>
</tr>
<tr>
<td>System Extract</td>
<td></td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Define system extract</td>
<td>Define system extract formatting</td>
</tr>
<tr>
<td>system extract</td>
<td>parameters</td>
</tr>
<tr>
<td>formatting</td>
<td></td>
</tr>
<tr>
<td>Define system extracts</td>
<td>Define system extracts</td>
</tr>
<tr>
<td>parameters</td>
<td></td>
</tr>
<tr>
<td>Define system extract</td>
<td>View system extract output</td>
</tr>
<tr>
<td>output</td>
<td></td>
</tr>
<tr>
<td>Change Event Log</td>
<td>Other Definitions</td>
</tr>
<tr>
<td>Other Definitions</td>
<td></td>
</tr>
<tr>
<td>Person Types</td>
<td>Enter names for types of employees, applicants and other people</td>
</tr>
<tr>
<td>Application Utilities</td>
<td>Enter lookup types and values</td>
</tr>
<tr>
<td>Lookups</td>
<td></td>
</tr>
<tr>
<td>Special Information</td>
<td>Join special information types to the current business group</td>
</tr>
<tr>
<td>Types</td>
<td></td>
</tr>
<tr>
<td>Define Cities</td>
<td>Define cities</td>
</tr>
<tr>
<td>Table Structure</td>
<td>Set up tables you require</td>
</tr>
<tr>
<td>Table Values</td>
<td>Enter table values</td>
</tr>
<tr>
<td>Time Periods</td>
<td>Define time period types for use in budget calendars</td>
</tr>
<tr>
<td>User Profile Options</td>
<td>Review your personal profile options</td>
</tr>
<tr>
<td>Formula Functions</td>
<td>Register your user defined functions</td>
</tr>
<tr>
<td>User Types and Statuses</td>
<td>Define user names for system types or statuses</td>
</tr>
<tr>
<td>Security</td>
<td>Define security restrictions</td>
</tr>
<tr>
<td>Profile</td>
<td>Define security profiles to restrict record access</td>
</tr>
<tr>
<td>Assign Security</td>
<td>Assign an existing security profile to a user responsibility/security group combination. (Cross Business Group responsibility/security only)</td>
</tr>
<tr>
<td>Profiles</td>
<td></td>
</tr>
<tr>
<td>Information Types</td>
<td>Define information types security</td>
</tr>
<tr>
<td>Security</td>
<td></td>
</tr>
<tr>
<td>CustomForm</td>
<td>Define customizations to restrict information access in windows</td>
</tr>
<tr>
<td>MENU ENTRY</td>
<td>DESCRIPTION</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Report Sets</td>
<td>Define sets to restrict report and process access</td>
</tr>
<tr>
<td>Task Flow Nodes</td>
<td>Define task flow nodes and customizations</td>
</tr>
<tr>
<td>Task Flow Definitions</td>
<td>Define task flows</td>
</tr>
</tbody>
</table>
Windows and their Navigation Paths

The following list shows the default navigation paths for all the windows in Oracle HRMS for the US, as they are supplied. You can use taskflow windows directly from the menu, or from the People and Assignment windows.

The responsibility that you use determines which of these windows you can use and how you access them. Your system administrator sets up navigation menus and task flows for your responsibility. They may also create customized versions of some of these windows using different window titles.

**AAP Organization**
2. Enter or query an AAP Organization.
3. Choose the Others button and select AAP Organization.

**Absence Detail**
Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Choose the Others button and select Absence.
Or:
1. Choose Fastpath –> Absence in the Navigator.
2. In the resulting Find window, query the person.

**Absence Attendance Type**
- Choose Total Compensation –> Basic –> Absence Types in the Navigator.

**Accrual Bands**
1. Choose Total Compensation –> Basic –> Accrual Plans in the Navigator.
2. Enter or query an accrual plan name.
3. Choose the Accrual Bands button.
Accrual Plans
- Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

Accruals
Do one of the following:
1. Choose View -> Employee Accruals in the Navigator.
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the Accruals button.
Or:
1. Choose Fastpath -> Accruals in the Navigator.
2. In the resulting Find window, query the person.

Action Types
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query or enter a plan.
3. Choose the Actions button.

Activity Rate
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the Navigator.
2. Query a compensation object.
3. Choose the Activity Rate button.

Activity Variable Rates and Rules
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the Navigator.
2. Query a compensation object.
3. Choose the Variable Rates button.

Actual Premiums
- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Actual Premiums in the Navigator.
**Address**

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Address button.

Or:
1. Choose Fastpath -> Address in the Navigator.
2. In the resulting Find window, query the person.

**Adjust Balance (Payroll only)**

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Adjust Balance.

Or:
2. In the resulting Find window, query the person.

**Adjust Tax Balances (Payroll only)**

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Adjust Tax Balances.

**Advanced Criteria**

1. Choose Benefits Extract -> Criteria Definition in the Navigator.
2. Query or enter a criteria definition and choose the Advanced tab.
3. Select a Criteria Type and choose the Details button.

**Alter Effective Date**

- Choose Tools -> Alter Effective Date from the Tools menu.
Applicant Entry
- Choose Recruitment -> Applicant Quick Entry in the Navigator.

Applicant Interview
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an applicant.
3. Choose the Others button and select Application.
4. Choose the Interview button.

Application
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an applicant.
3. Choose the Others button and select Application.
Or:
1. Choose Fastpath -> Application in the Navigator.
2. In the resulting Find window, query the person.

Application Utilities Lookups
1. Choose Other Definitions -> Lookup Tables in the Navigator.
2. Enter or query a user–defined Type.

Appraisal Template
- Choose Career Management -> Appraisal Template in the Navigator.

Assessment Template
- Choose Career Management -> Assessment Template in the Navigator.

Assign Security Profiles

Assignment
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.

Or:
1. Choose Fastpath –> Assignment in the Navigator.
2. In the resulting Find window, query the person.

**Assignment Budget Values**

Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an applicant or an employee.
3. Do one of the following:
   For an applicant:
   • Choose the Others button and select Application.
   • Choose the Budgets button.
   For an employee:
   • Choose the Assignment button.
   • Choose the Others button and select Budget Values.

Or:
1. Choose Fastpath –> Assignment Budget in the Navigator.
2. In the resulting Find window, query the person.

**Assignment Criteria**

1. Choose Payroll –> Assignment Set in the Navigator.
2. Enter or query an assignment set.
3. Choose the Criteria button.

**Assignment History**

- Choose View –> Histories –> Employee Assignment in the Navigator.

**Assignment Processes**

1. Choose View –> Payroll Process Results in the Navigator.
2. Enter or query a payroll process.
3. Choose the Assignment Process button.

**Assignment Set**
- Choose Payroll -> Assignment Set in the Navigator.

**Assignment Statuses**
- Choose Work Structures -> Status in the Navigator.

**Assignment Folder**
- Choose View -> Lists -> Assignment Folder in the Navigator.

**Authentication Activities (Advanced Benefits Only)**
- Choose Total Compensation -> General Definitions -> Authentication Activities in the Navigator.

**Balance (Payroll only)**
- Choose Total Compensation -> Basic -> Balance in the Navigator.

**Balance Classifications (Payroll only)**
1. Choose Total Compensation -> Basic -> Balance in the Navigator.
2. Enter or query a balance.
3. Choose the Classifications button.

**Balance Dimensions (Payroll only)**
1. Choose Total Compensation -> Basic -> Balance in the Navigator.
2. Enter or query a balance.
3. Choose the Dimensions button.

**Balance Feed Control (Payroll only)**
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.
2. Enter or query an element.
3. Choose the Balance Feed Control button.

**Balance Feeds (Payroll only)**

*Note:* This instance of the Balance Feeds window lets you select more than one balance for the element to feed.
1. Choose Total Compensation → Basic → Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Balance Feeds button.

**Batch Header**

- Choose Mass Information eXchange: MIX → Batch Element Entry in the Navigator.

**Batch Process Parameters (Advanced Benefits only)**

- Choose Processes and Reports → Batch Process Parameters in the Navigator.

**Batch Summary**

- Choose Mass Information eXchange: MIX → BEE Summary in the Navigator.

**Beneficiaries**

1. Choose People → Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

4. Choose the Entries button.

5. Select the element representing the benefit for which you are entering a beneficiary.

6. Choose the Others button and select Beneficiary.

**Beneficiary Certifications**

1. Choose Total Compensation → Programs and Plans → Plan Enrollment Requirements in the Navigator.

2. Query a plan.

3. Choose the Designations tab.

4. Choose the Beneficiary tab.

5. Choose the Certifications button.

**Benefits Authentication Form (Advanced Benefits only)**

- Choose People → Total Comp Contribution → Benefits Authentication Form in the Navigator.
Benefits Balances
- Choose Total Compensation -> General Definitions -> Additional Setup -> Benefits Balances in the Navigator.

Benefit Contributions
- Choose Total Compensation -> Basic -> Benefit Contributions in the Navigator.

Benefits Group
- Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors -> Benefits Group in the Navigator.

Benefits Pools (Advanced Benefits only)
- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Benefits Pools in the Navigator.

Benefits Authentication Form (Advanced Benefits only)
- Choose People -> Total Comp Contribution -> Benefits Authentication Form in the Navigator.

Benefits Service Center (Advanced Benefits Only)
- Choose People -> Benefits Service Center in the Navigator.

Book Events
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Bookings.

Budget
- Choose Work Structures -> Budget in the Navigator.

Budget Value Defaults
2. Enter or query a Business Group.
3. Choose the Others button and select Budget Value Defaults.

Budgetary Calendar
- Choose Work Structures -> Budget Calendar in the Navigator.
Business Group Information
2. Enter or query a Business Group.
3. Choose the Others button and select Business Group Information.

Career Path Names
- Choose Work Structures -> Job -> Path Name in the Navigator.

Certifications
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query or enter a plan.
3. Choose the General tab.
4. Choose the Plan or Option tab.
5. Choose the Certifications button.

Change Event Log

Cities
- Choose Other Definitions -> Cities in the Navigator.

City Tax Rules <Employee>
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Chose the Tax Information button.
5. Choose the Tax information button from the State Tax Rules <Employee> window.
6. Choose the Tax information button from the County Tax Rules <Employee> window.

COBRA Benefits (Basic Benefits)
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.
5. Enter or query a qualifying event.
6. Choose the Benefits button.

**COBRA Coverage (Basic Benefits)**
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.

**COBRA Payments (Basic Benefits)**
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.
5. Enter or query a qualifying event.
6. Choose the Payments button.

**COBRA Statuses (Basic Benefits)**
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select COBRA.
5. Enter or query a qualifying event.
6. Choose the Statuses button.

**Collective Agreements**
- Choose Work Structures -> Collective Agreements in the Navigator.

**Columns**
1. Choose Other Definitions -> Table Structure in the Navigator.
2. Enter or query a table.
3. Choose the Columns button.

**Communication Delivery Methods**

- Choose Fastpath -> Personal Delivery Method in the Navigator.

**Communication Types (Advanced Benefits only)**

- Choose Total Compensation -> General Definitions -> Additional Setup -> Communication Types in the Navigator.

**CommunicationType Children**

1. Choose Total Compensation -> General Definitions -> Additional Setup -> Communication Types in the Navigator.
2. Query a communication type kit.
3. Choose the View Children button.

**Communication Type Delivery Methods**

1. Choose Total Compensation -> General Definitions -> Additional Setup -> Communication Types in the Navigator.
2. Query or enter a communication type.
3. Choose the Delivery button.

**Communication Type Triggers**

1. Choose Total Compensation -> General Definitions -> Additional Setup -> Communication Types in the Navigator.
2. Query or enter a communication type.
3. Choose the Triggers button.

**Communication Type Usages**

1. Choose Total Compensation -> General Definitions -> Additional Setup -> Communication Types in the Navigator.
2. Query or enter a communication type.
3. Choose the Usages button.

**Competence Profile**

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Competence Profile.
Competence Requirements
- Choose Career Management \(\rightarrow\) Competence Requirements in the Navigator.

Competence Types
- Choose Career Management \(\rightarrow\) Competence Types in the Navigator.

Competencies
- Choose Career Management \(\rightarrow\) Competencies in the Navigator.

Consolidation Sets (Payroll only)
- Choose Payroll \(\rightarrow\) Consolidation in the Navigator.

Contacts
Do one of the following:
1. Choose People \(\rightarrow\) Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Contact.

Or:
1. Choose Fastpath \(\rightarrow\) Contact in the Navigator.
2. In the resulting Find window, query the person.

Do one of the following:
1. Choose People \(\rightarrow\) Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button.

Or:
1. Choose Fastpath \(\rightarrow\) Contracts in the Navigator.
2. In the resulting Find window, query the person.

Contribution History (Def Comp 457)
- Choose View \(\rightarrow\) Histories \(\rightarrow\) Entries \(\rightarrow\) Contribution History

1. Choose Mass Information eXchange: MIX \(\rightarrow\) Batch Element Entry in the Navigator.
2. Choose the Totals button.

**Conversion Rate Types**
- Choose Payroll –> Currency Types in the Navigator.

**Costing**
Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Costing.

Or:
2. In the resulting Find window, query the person.

**Costing Information**
2. Enter or query an organization.
3. Choose the Others button and select Costing.

**County Tax Rules <Employee>**
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Tax Information button.
5. Choose the Tax information button from the State Tax Rules <Employee> window.

**Court Orders**
- Choose People –> Total Comp Enrollment –> Court Orders in the Navigator.
Coverage Across Plan Types

- Choose Total Compensation -> Rates/Coverage Definitions -> Coverage Across Plan Types in the Navigator.

Coverage Calculations

- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Coverage Calculations in the Navigator.

Covered Dependents

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Others button and select Contact.
4. Choose the Entries button.
5. Select the element representing the benefit for which you are entering a dependent.
6. Choose the Others button and select Dependents.

Criteria Definition

- Choose Benefits Extract -> Criteria Definition in the Navigator.

Custom Reports

- Choose Processes and Reports -> Submit Custom Reports in the Navigator.

Database Items

1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.
2. Enter or query a formula.
3. Choose the Show Items button.

DateTrack History Change Field Summary

- Choose Tools -> DateTrack History from the Tools menu.

Deduction (Payroll only)

- Choose Total Compensation -> Basic -> Deductions in the Navigator.
Define Combinations
- Choose Total Compensation \(\rightarrow\) Programs and Plans \(\rightarrow\) Combinations in the Navigator.

Define Extract
- Choose Benefits Extract \(\rightarrow\) Extract Definition in the Navigator.

Define Function
- Choose Other Definitions \(\rightarrow\) Formula Functions in the Navigator.

Define QuickPaint Report
- Choose Processes and Reports \(\rightarrow\) Define a QuickPaint Report in the Navigator.

Define Task Flow
- Choose Security \(\rightarrow\) Task Flow Definitions in the Navigator.

Define Task Flow Nodes
- Choose Security \(\rightarrow\) Task Flow Nodes in the Navigator.

Delete Person
- Choose People \(\rightarrow\) Delete Personal Records in the Navigator.

Dependent/Beneficiary Designation (Advanced Benefits Only)
- Choose People \(\rightarrow\) Total Comp Enrollment \(\rightarrow\) Dependent/Beneficiary Designation in the Navigator.

Dependent Certifications
Do one of the following:
1. Choose Total Compensation \(\rightarrow\) Programs and Plans \(\rightarrow\) Program Enrollment Requirements in the Navigator.
2. Query a program.
3. Choose the Dependent Coverage tabbed region
4. Choose the Certifications button.
Or:
1. Choose Total Compensation \(\rightarrow\) Programs and Plans \(\rightarrow\) Plan Enrollment Requirements in the Navigator.
2. Query a plan.
3. Choose the Designations tab.
4. Choose the Dependent tab.
5. Choose the Certifications button.

**Dependent Change of Life Event**

Do one of the following:

1. Choose Choose Total Compensation –> Programs and Plans –> Program Enrollment Requirements in the Navigator.
2. Query a program and choose the Dependent Coverage tabbed region.
3. Choose the Dependent Change of Life Event button.

Or:

1. Choose Choose Total Compensation –> Programs and Plans –> Plan Enrollment Requirements in the Navigator.
2. Query a plan and choose the Designations tabbed region.
3. Choose the Dependent tab.
4. Choose the Dependent Change of Life Event button.

**Dependent Change of Life Event Certification**

Do one of the following:

1. Choose Choose Total Compensation –> Programs and Plans –> Program Enrollment Requirements in the Navigator.
2. Query a program and choose the Dependent Coverage tabbed region.
3. Choose the Dependent Change of Life Event button.
4. Select a life event and choose the Dependent Change of Life Event Certifications button.

Or:

1. Choose Choose Total Compensation –> Programs and Plans –> Plan Enrollment Requirements in the Navigator.
2. Query a plan and choose the Designations tabbed region.
3. Choose the Dependent tab.
4. Choose the Dependent Change of Life Event button.
5. Select a life event and choose the Dependent Change of Life Event Certifications button.

**Dependent Coverage Eligibility Profiles**

- Choose Total Compensation → General Definitions → Eligibility Profiles → Dependent Coverage in the Navigator.

**Dependent Eligibility Profiles**

Do one of the following:

1. Choose Choose Total Compensation → Programs and Plans → Program Enrollment Requirements in the Navigator.
2. Query a program and choose the Dependent Coverage tabbed region.
3. Choose the Eligibility Profiles button.
   
   Or:
   
   1. Choose Choose Total Compensation → Programs and Plans → Plan Enrollment Requirements in the Navigator.
   2. Query a plan and choose the Designations tabbed region.
   3. Choose the Dependent tab.
   4. Choose the Eligibility Profiles button.

**Derived Factors**

- Choose Total Compensation → General Definitions → Eligibility/Rate Factors → Derived Factors in the Navigator.

**Designation Requirements**

Do one of the following:

1. Choose Total Compensation → Programs and Plans → Options in the Navigator.
2. Query or enter an option.
3. Choose the Designation Requirements button.
   
   Or:
   
   1. Choose Total Compensation → Programs and Plans → Plan Enrollment Requirements in the Navigator.
   2. Query a plan.
   3. Choose the General tab.
4. Choose the Plan or Option tab.
5. Choose the Designations button.

**Earnings** (Payroll only)
- Choose Total Compensation –> Basic –> Earnings in the Navigator.

**Edit Formula**
1. Choose Total Compensation –> Basic –> Write Formulas in the Navigator.
2. Enter or query a formula.
3. Choose the Edit button.

**EEO–1 Filing**
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select EEO–1 Filing.

**Electable Choices**
1. Choose People –> Total Comp Participation
2. Choose the Enrollment Opportunities button
3. Choose the Electable Choices button.

**Element**
- Choose Total Compensation –> Basic –> Element Description in the Navigator.

**Element and Distribution Set**
- Choose Payroll –> Element Set in the Navigator.

**Element Classifications** (Payroll only)
- Choose Total Compensation –> Basic –> Classification in the Navigator.

**Element Entries**
Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Entries button.

Or:
2. In the resulting Find window, query the person.

**Element Link**
- Choose Total Compensation –> Basic –> Link in the Navigator.

**Eligibility**
Do one of the following:
2. Query or enter a plan.
3. Choose the Plan Eligibility button.
4. Choose the Eligibility button.

Or:
2. Query or enter a plan.
3. Choose the Options button.
4. Choose the Option Eligibility button.
5. Choose the Eligibility button.

Or:
1. Choose Total Compensation –> Programs and Plans –> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plans and Plan Types button.
4. Choose the Plans tab or the Plan Types tab.
5. Choose the Participation Eligibility button.
6. Choose the Eligibility button.

Or:
1. Choose Total Compensation – Programs and Plans – Programs in the Navigator.
2. Query or enter a program.
3. Choose the Participation Eligibility button.
4. Choose the Eligibility button.

**Employee Assignment Processes**
- Choose View – Assignment Process Results in the Navigator.

**Employee Review**
Do one of the following:
1. Choose People – Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Reviews.
Or:
2. In the resulting Find window, query the person.

**Employee Run Result History** (Payroll only)
- Choose View – Histories – Run Results in the Navigator.

**Employer Identification**
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Employer Identification

**End Application**
1. Choose People – Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button and select End Application.
Or:
1. Choose Fastpath – End Application in the Navigator.
2. In the resulting Find window, query the person.
End Employment
Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button and select End Employment.
Or:
2. In the resulting Find window, query the person.

Enrollment Action (Advanced Benefits only)
- Choose Total Compensation –> General Definitions –> Additional Setup –> Enrollment Action in the Navigator.

Enrollment Opportunities
1. Choose People –> Total Comp Participation
2. Choose the Enrollment Opportunities button.

Enrollment Override
- Choose People –> Total Comp Enrollment –> Enrollment Override in the Navigator.

Enrollment Rules
1. Choose Total Compensation –> Programs and Plans –> Plan Enrollment Requirements in the Navigator.
2. Query or enter a plan.
3. Choose the Timing tab.
4. Choose the Scheduled tab or the Life Event tab.
5. Choose the Enrollment Rules button.

Entry Values
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Entries button.
5. Select an entry and choose the Entry Values button.
Establishment EEO–1 Filing
2. Enter or query a Reporting Establishment.
3. Choose the Others button and select Establishment EEO–1 Filing.

Establishment VETS–100 Filing
2. Enter or query a Reporting Establishment.
3. Choose the Others button and select Establishment VETS–100 Filing.

Event Bookings
Do one of the following:
- Choose People –> Events and Bookings in the Navigator.

Or:
2. In the resulting Find window, query the person.

Exemption Rules (Payroll only)
- Choose View –> Wage Attachments –> Exemption Rules

External/Manual Payments (Payroll only)
Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select External Pay.

Or:
2. In the resulting Find window, query the person.

Extract Definition
Extract Results

- Choose Benefits Extract -> Extract Results in the Navigator.

Extract Results Errors

1. Choose Benefits Extract -> Extract Results in the Navigator.

Extract Results Detail

1. Choose Benefits Extract -> Extract Results in the Navigator.
2. Query an extract run result and choose the Details button.

Extract Results Header and Trailer

1. Choose Benefits Extract -> Extract Results in the Navigator.
2. Query an extract run result and choose the Header and Trailer button.
3. Query an extract run result and choose the Errors and Warnings button.

Federal Tax Rules

2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Federal Tax Rules

Federal Tax Rules <Employee>

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Tax Information button.

File Layout Advanced Conditions

1. Choose Benefits Extract -> Layout Definition in the Navigator.
2. Choose the File Layout tab and query or enter a file layout.
3. Select a record and choose the Advanced Conditions button.

Flex Credits (Advanced Benefits only)

- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Flex Credits in the Navigator.
**Flex Program** (Advanced Benefits only)

- Choose People → Total Comp Enrollment → Flex Program in the Navigator.

**Form 941 Information**

- Choose View → Tax Information → Form 941 Information in the Navigator.

**Form Customization**

- Choose Security → CustomForm in the Navigator.

**Formula**

- Choose Total Compensation → Basic → Write Formulas in the Navigator.

**Formula Result Rules** (Payroll only)

- Choose Total Compensation → Basic → Formula Results in the Navigator.

**Frequency Rules**

1. Choose Total Compensation → Basic → Deductions in the Navigator.
2. Enter or query a deduction.
3. Choose the Frequency Rules button.

**GL Map** (Payroll only)

- Choose Payroll → GL Flexfield Map in the Navigator.

**Globals**

- Choose Total Compensation → Basic → Global Values in the Navigator.

**GL Daily Rates**

- Choose Total Compensation → Basic → Global Values in the Navigator.

**Goods and Services**

- Choose Total Compensation → General Definitions → Additional Setup → Goods and Services in the Navigator.
Grade Rate

- Choose Work Structures -> Grade -> Grade Rate in the Navigator.

Grade Scale

- Choose Work Structures -> Grade -> Grade Steps and Points in the Navigator.

Grade Step Placement

Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Grade Step.
Or:
1. Choose Fastpath -> Grade Step in the Navigator.
2. In the resulting Find window, query the person.

Grades

- Choose Work Structures -> Grade -> Description in the Navigator.

Imputed Income

- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Imputed Income in the Navigator.

Information Type Security

- Choose Security -> Information Types Security in the Navigator.

Input Values

1. Choose Total Compensation -> Basic -> Element Description in the Navigator.
2. Enter or query an element.
3. Choose the Input Values button.

Investment Options

1. Choose People -> Total Comp Enrollment -> Savings Plan in the Navigator.
2. Query a person.
3. Choose the Investment Options button.

**Job**
- Choose Work Structures -> Job -> Description in the Navigator.

**Job Evaluation**
1. Choose Work Structures -> Job -> Description in the Navigator.
2. Enter or query a job.
3. Choose the Evaluation button.

**Job Requirements**
1. Choose Work Structures -> Job -> Description in the Navigator.
2. Enter or query a job.
3. Choose the Requirements button.

**Layout Definition**
- Choose Benefits Extract -> Layout Definition in the Navigator.

**Life Event**
Do one of the following:
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plans tab or the Plan Types tab.
5. Choose the Life Event button.
Or:
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Life Event button.

**Life Event Certifications**
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment Requirements in the Navigator.
2. Query or enter a plan.
3. Choose the General tab.
4. Choose the Plan or Option tab.
5. Choose the Life Event Certifications button.

**Life Event Reason Impact on Eligibility** (Advanced Benefits)
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Options button.
4. Choose the Life Event Eligibility button.

**Life Event Reasons** (Advanced Benefits only)
- Choose Total Compensation → General Definitions → Additional Setup → Life Event Reasons in the Navigator.

**Limit Rules** (Payroll only)
- Choose View → Wage Attachments → Limit Rules in the Navigator.

**Link Input Values**
1. Choose Total Compensation → Basic → Link in the Navigator.
2. Enter or query an element.
3. Choose the Input Values button.

**List Assignments**
- Choose View → Lists → Assignments in the Navigator.

**List Budget Variance by Organization**
- Choose View → Organization Budgets in the Navigator.

**List Employees by Absence Type**
- Choose View → Lists → Employees by Absence Type in the Navigator.

**List Employees by Element**
- Choose View → Lists → Employees by Element in the Navigator.
List Employees by Organization
- Choose View -> Lists -> Employees by Organization in the Navigator.

List Employees by Position
- Choose View -> Lists -> Employees by Position in the Navigator.

List Employees by Position Hierarchy
- Choose View -> Lists -> Emps by Position Hierarchy in the Navigator.

List People by Assignment
- Choose View -> Lists -> People by Assignment in the Navigator.

List People by Special Information
- Choose View -> Lists -> People by Special Information in the Navigator.

List Position Budget Variance
- Choose View -> Position Budgets in the Navigator.

Local Tax Rules
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Local Tax Rules.

Location
- Choose Work Structures -> Location in the Navigator.

Lookups
- Choose Other Definitions -> Lookup Tables in the Navigator.

Maintain On Line Activities (Advanced Benefits)
- Choose Total Compensation -> General Definitions -> On-line Activities for Authentication in the Navigator.
Maintain Options Eligibility
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Options button.
4. Choose the Option Eligibility button.

Maintain Plan Eligibility
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Plan Eligibility button.

Maintain Plan Options
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Options button.

Maintain Plan Related Details
1. Choose Total Compensation → Programs and Plans → Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Details button.

Maintain Pop Up Messages (Advanced Benefits only)
- Choose Total Compensation → General Definitions → Define Messages in the Navigator.

Map Career Path
- Choose Work Structures → Job → Career Path in the Navigator.

Map Salary Survey
2. Complete the Position window and save your work.
3. Choose the Define Survey Map button.
Or:
2. Complete the Job window and save your work.
3. Choose the Define Salary Map button.

Mass Move


Mass Move – Assignments

2. Complete the Mass Move window and save your work.
3. Choose the Positions button.
4. Complete the Find Positions window.
5. Choose the Find button.
7. Choose the Assignments button.

Mass Move – Messages

2. Complete the Mass Move window and save your work.
3. Choose the Positions button.
4. Complete the Find Positions window and choose the Find button.
5. Complete the Mass Move – Positions window and choose the Assignments button.
6. Complete the Mass Move – Assignments window and close it.
7. From the Mass Move – Positions window, choose the Valid Grades button.
8. Complete the Valid Grades window and close it.
10. From the Mass Move window, choose the Execute button.
11. If the Status field shows In Error or Complete with Warnings, a Message button appears.
12. If the Message button appears, choose it to view messages in the Mass Move – Messages window.
Note: Alternatively, you can view messages for saved (but not yet successfully executed) mass moves as follows:

2. Enter the name of the saved mass move in the Description field.
3. When the Mass Move window is populated with data and the Message button appears, choose the Message button.

Mass Move – Positions
2. Complete the Mass Move window.
3. Save your work.
4. Choose the Positions button.
5. In the resulting Find Positions window, select or enter a Source Job and Source Position.
6. Choose the Find button.

Mass Move – Valid Grades
2. Complete the Mass Move window and save your work.
3. Choose the Positions button.
4. Complete the Find Positions window.
5. Choose the Find button.
7. Choose the Valid Grades button.

Mass Update of Applicants
- Choose Recruitment –> Mass Update of Applicants in the Navigator.

Messages
2. Choose the Messages button.
Message Configuration (Advanced Benefits only)
- Choose Total Compensation –> General Definitions –> Message Configuration in the Navigator.

Miscellaneous Plan
- Choose People –> Total Comp Enrollment –> Miscellaneous Plan in the Navigator.

MIX Batch Header
- Choose Mass Information eXchange: MIX –> Batch Element Entry in the Navigator.

Monitor Batch Processes (Advanced Benefits only)
- Choose Processes and Reports –> Monitor Batch Processes in the Navigator.

Monthly Participant Premium

Monthly Plan or Option Premium
- Choose Total Compensation –> Monthly Premium in the Navigator.

Multiple Worksite Reporting
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select Multiple Worksite Reporting

NACHA Rules
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select NACHA Rules

Net Calculation Rules
1. Choose Total Compensation –> Basic –> Accrual Plans in the Navigator.
2. Enter or query an accrual plan name.
3. Choose the Net Calculation Rules button.

**New Hire Reporting**

2. Enter or query a GRE.
3. Choose the Others button.
4. Select New Hire Reporting

**Non–Flex Program**

- Choose People –> Total Comp Enrollment –> Non–Flex Program in the Navigator.
5. Click in the Additional Organization Information field.

**Options**

- Choose Total Compensation –> General Definitions –> Programs and Plans –> Options in the Navigator.

**Organization**

- Choose Work Structures –> Organization –> Description in the Navigator.

**Organization Hierarchy**


**Organizational Payment Method**

- Choose Payroll –> Payment Methods in the Navigator.

**Other Rates**

1. Choose People –> Total Comp Enrollment –> Non–Flex Program in the Navigator.
2. Query a person.
3. Choose the Others button and select Other Rates.

**Parent Organization**

2. Enter or query an organization.
3. Choose the Others button and select Parent Organization.

**Participant**
- Choose Total Compensation -> General Definitions -> Eligibility Profiles -> Participant in the Navigator.

**Participation Eligibility Profiles**
- Choose Total Compensation -> General Definitions -> Eligibility Profiles -> Participation Eligibility Profiles

**Participation Overrides** (Advanced Benefits only)
- Choose People -> Total Comp Participation -> Participation Overrides in the Navigator.

**Payment Schedule**
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the Navigator.
2. Query or enter a flex credit definition and choose the Processing tabbed region.
3. Choose the Payment Schedule button.

**Payments**
1. Choose People -> Total Comp Contribution -> Record Contribution or Distribution
2. Choose the View Payments window.

**Pay Scale**
- Choose Work Structures -> Grade -> Pay Scale in the Navigator.

**Payroll**
- Choose Payroll -> Description in the Navigator.

**Payroll Processes** (Payroll only)
- Choose View -> Payroll Process Results in the Navigator.

**People**
- Choose People -> Enter and Maintain in the Navigator.
People Folder
- Choose View –> Lists –> People Folder in the Navigator.
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee, and choose the Assignment button.
3. Choose the Tax Information button.
4. Choose the Percentage button.

Performance
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee, and choose the Assignment button.
3. Choose the Salary button.
4. Choose the Performance button.
Or:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee, and choose the Assignment button.
3. Choose the Others button and select Performance.

Period Dates
1. Choose Payroll –> Description in the Navigator.
2. Enter or query a payroll.
3. Choose the Period Dates button.

Period–to–Date Limits
Do one of the following:
- Choose Total Compensation –> General Definitions –> Rate/Coverage Definitions –> Period–to–Date Limits in the Navigator.

Or:
1. Choose Total Compensation –> Rates/Coverage Definitions –> Flex Credits in the Navigator.
2. Query a compensation object.
3. Choose the Activity Rate button.
4. Choose the Period to Date Limit button.
Period Types
- Choose Other Definitions -> Time Periods in the Navigator.

Person Benefits Assignment
- Choose People -> Total Comp Participation -> Person Benefits Assignment

Person Benefits Balances
- Choose People -> Total Comp Participation -> Person Benefits Balances in the Navigator.

Person Changes (Advanced Benefits only)
2. Query or enter a life event.
3. Choose the Person Changes button.
4. Choose the Add Person Change button.

Person Changes Cause Life Events (Advanced Benefits only)
2. Query or enter a life event.
3. Choose the Person Changes button.

Person Communications (Advanced Benefits only)
- Choose People -> Enrollment Process -> Person Communications in the Navigator.

Person Enrollment Action Items (Advanced Benefits only)
- Choose People -> Enrollment Process -> Person Enrollment Action Items in the Navigator.

Person Enrollment Certificates (Advanced Benefits only)
- Choose People -> Enrollment Process -> Person Enrollment Certificates in the Navigator.

Person Primary Care Provider
- Choose People -> Total Comp Enrollment -> Person Primary Care Provider in the Navigator.
Person Types
- Choose Other Definitions -> Person Types in the Navigator.

Person Type Usage
- Choose Fastpath -> Person Type Usage in the Navigator.

Personal Payment Method
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Pay Method button, or choose the Others button and select Pay Method.

Or:
1. Choose Fastpath -> Pay Method in the Navigator.
2. In the resulting Find window, query the person.

Phone Numbers
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Others button.
4. Choose Phones.

Or:
1. Choose Fastpath -> Phones in the Navigator.
2. In the resulting Find window, query the person.

Picture
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Picture button.

Or:
1. Choose Fastpath  → Picture in the Navigator.

2. In the resulting Find window, query the person.

**Plan and Plan Type**

1. Choose Total Compensation → Programs and Plans → Programs in the Navigator.

**Plan Enrollment Requirements**

- Choose Total Compensation → General Definitions → Programs and Plans → Plan Enrollment Requirements in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

**Plan in Program Participation Eligibility**

1. Choose Total Compensation → Programs and Plans → Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plans tab.

5. Choose the Participation Eligibility button.

**Plan Reimbursement**

- Choose Total Compensation → General Definitions → Programs and Plans → Plan Reimbursement in the Navigator.

**Plans**

- Choose Total Compensation → General Definitions → Programs and Plans → Plans in the Navigator.

**Plan Type Participation Eligibility**

1. Choose Total Compensation → Programs and Plans → Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plan Type tab.

5. Choose the Participation Eligibility button.
Plan Types
- Choose Total Compensation -> General Definitions -> Programs and Plans -> Plan Types in the Navigator.

Position
- Choose Work Structures -> Position -> Description in the Navigator.

Position Evaluation
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Enter or query a position.
3. Choose the Evaluation button.

Position Hierarchy
- Choose Work Structures -> Position -> Hierarchy in the Navigator.

Position Occupancy Folder
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Query a position.
3. Choose the Occupancy button.

Position Reporting To
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Enter or query a position.
3. Choose the Reporting To button.

Position Requirements
1. Choose Work Structures -> Position -> Description in the Navigator.
2. Enter or query a position.
3. Choose the Requirements button.

Possible Certifications
1. Choose People -> Total Comp Participation
2. Choose the Enrollment Opportunities button.
3. Choose the Electable Choices button
4. Choose the Possible Certifications button

Postal/Zip
- Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors -> Postal/Zip in the Navigator.

Primary Care Providers
Do one of the following:
- Choose People -> Total Comp Enrollment -> Person Primary Care Provider

Or:
1. Choose People -> Total Comp Enrollment -> Flex Program in the Navigator.
2. Query a person.
3. Choose the Care Providers button.

Program/Plan Years
- Choose Total Compensation -> General Definitions -> Additional Setup -> Program/Plan Years in the Navigator.

Programs
- Choose Total Compensation -> General Definitions -> Programs and Plans -> Programs in the Navigator.

Program Enrollment Requirements
- Choose Total Compensation -> General Definitions -> Programs and Plans -> Program Enrollment Requirements in the Navigator.

Program Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Participation Eligibility button.
Program Waive Certifications
1. Choose Total Compensation –> Programs and Plans –> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plan Types tab.
5. Choose the Waive button.
6. Choose the Waive Certification button.

Program Waive Reasons
1. Choose Total Compensation –> Programs and Plans –> Programs in the Navigator.
2. Query or enter a program.
3. Choose the Plan and Plan Types button.
4. Choose the Plan Types tab.
5. Choose the Waive button.

Qualifications
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Qualifications.

Qualification Types
- Choose Career Management –> Qualification Types in the Navigator.

QuickPaint Inquiry
2. Query a report that has been run.
3. Choose the View Report button.

QuickPay (Payroll only)
Do one of the following:
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select QuickPay.
   
   Or:
2. In the resulting Find window, query the person.

Rating Scales
- Choose Career Management –> Rating Scales in the Navigator.

Record Continuing Benefits Payments
- Choose People –> Total Comp Contribution –> Record Continuing Benefits Payments in the Navigator.

Record Layout Advanced Conditions
2. Choose the Record Layout tab and query or enter a record layout.
3. Select a Data Element and choose the Advanced Conditions button.

Recruiting For
2. Enter or query a recruitment activity.
3. Choose the Recruiting For button.

Recruitment Activity
- Choose Recruitment –> Recruitment Activity in the Navigator.

Regulations
- Choose Total Compensation –> General Definitions –> Additional Setup –> Regulations in the Navigator.

Regulatory Bodies and Regulations
2. Query or enter a reporting group.
3. Choose the Plan Regulatory Bodies and Regulations button.
**Reimbursements Requests** (Advanced Benefits only)

- Choose People -> Total Comp Distribution -> Reimbursements Requests in the Navigator.

**Related Person Changes** (Advanced Benefits only)

2. Query or enter a life event.
3. Choose the Related Person Changes button.
4. Choose the Add Related Person Change button.

**Related Person Changes Cause Life Events** (Advanced Benefits only)

2. Query or enter a life event.
3. Choose the Related Person Changes button.
2. Enter or query a Business Group.
3. Choose the Others button and select Reporting Categories.

**Reporting Groups**

- Choose Total Compensation -> General Definitions -> Additional Setup -> Reporting Groups in the Navigator.

**Reporting Statuses**

2. Enter or query a Business Group.
3. Choose the Others button and select Reporting Statuses.

**Request Letter**

- Choose Recruitment -> Request Recruitment Letter in the Navigator.

**Request Set**

Requisition and Vacancy
- Choose Recruitment -> Requisition and Vacancy in the Navigator.

RetroPay Set (Payroll only)
- Choose Payroll -> RetroPay Set in the Navigator.

Reverse Payroll Run (Payroll only)
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Others button and select Reverse Run.
Or:
1. Choose Fastpath -> Reverse Payroll Run in the Navigator.
2. In the resulting Find window, query the person.

Rows
1. Choose Other Definitions -> Table Structure in the Navigator.
2. Enter or query a table.
3. Choose the Rows button.

Run QuickPaint Report
- Choose Processes and Reports -> Run a QuickPaint Report in the Navigator.

Salary Administration
Do one of the following:
1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query an employee.
3. Choose the Assignment button.
4. Choose the Salary button.
Or:
1. Choose Fastpath -> Salary in the Navigator.
2. In the resulting Find window, query the person.
Salary Basis
- Choose Total Compensation → Basic → Salary Basis in the Navigator.

Salary History
Do one of the following:
1. Choose View → Histories → Salary in the Navigator.
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the Salary History button.

Or:
1. Choose Fastpath → Salary History in the Navigator.
2. In the resulting Find window, query the person.

Salary Management Folder
- Choose People → Salary Management in the Navigator.

Salary Surveys
- Choose Total Compensation → Basic → Salary Survey in the Navigator.

Savings Plan
- Choose People → Total Comp Enrollment → Savings Plan in the Navigator.

Scale Rate
- Choose Work Structures → Grade → Point Values in the Navigator.

Schools and Colleges
- Choose Career Management → Schools and Colleges in the Navigator.

Schools and Colleges Attended
1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Schools/Colleges.
**Secondary Statuses**

Do one of the following:

1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query an applicant or employee.
3. Do one of the following:
   - For an applicant:
     - Choose the Others button and select Application.
     - Choose the Secondary Status button.
   - For an employee:
     - Choose the Assignment button.
     - Choose the Others button and select Secondary Status.

Or:

2. In the resulting Find window, query the person.

**Security Profile**

- Choose Security → Profile in the Navigator.

**Service Areas**

- Choose Total Compensation → General Definitions → Eligibility/Rate Factors → Service Areas in the Navigator.

**Sort**

1. Choose Benefits Extract → Layout Definition in the Navigator.
2. Choose the File Layout tab and select a Record Name.
3. Choose the Sort button.

**Special Information**

Do one of the following:

1. Choose People → Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Special Info button.

Or:
1. Choose Fastpath –> Special Information in the Navigator.
2. In the resulting Find window, query the person.

**Special Rates**
1. Choose People –> Total Comp Enrollment –> Flex Program in the Navigator.
2. Query a person.
3. Choose the Special Rates button.

**Special Information Types**
- Choose Other Definitions –> Special Information Types in the Navigator.

**SQWL Employer Rules (1) (Payroll only)**
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL Employer Rules (1)

**SQWL Employer Rules (2) (Payroll only)**
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL Employer Rules (2)

**SQWL Generic Transmitter Rules (Payroll only)**
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL Generic Transmitter Rules

**Standard Distributions/Contributions**
- Choose Total Compensation –> General Definitions –> Rate/Coverage Definitions –> Standard Distributions/Contributions in the Navigator.
**SQWL State-Specific Transmitter Rules** (Payroll only)
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select SQWL State Transmitter Rules.

**State Tax Rules**
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select State Tax Rules.

**State Tax Rules <Employee>**
1. Choose People –> Enter and Maintain in the Navigator.
2. Enter or query an employee or applicant.
3. Choose the Tax Information button.

**Statement of Earnings** (Payroll only)
Do one of the following:
1. Choose View –> Assignment Process Results
2. Choose the SOE Report button.
   Or:
   1. Choose People –> Enter and Maintain in the Navigator.
   2. Enter or query an employee.
   3. Choose the Assignment button.
   4. Choose the Others button and select Statement of Earnings.
   Or:
   2. In the resulting Find window, query the person.
Standard Rates
- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Standard Rates in the Navigator.

Submit a New Request
1. Choose Processes and Reports -> Submit Processes and Reports in the Navigator.
2. Select Single Request or a Request Set.

Table Structure
- Choose Other Definitions -> Table Structure in the Navigator.

Table Values
- Choose Other Definitions -> Table Values in the Navigator.

Update Payroll Run (Payroll only)
- Choose Payroll -> Update Payroll Run in the Navigator.

User Types and Statuses
- Choose Other Definitions -> User Types and Statuses

Valid Grades (for jobs)
2. Choose either Job -> Description or Position -> Description.
3. Enter or query a job or position.
4. Choose the Valid Grades button.

Valid Payment Methods
1. Choose Payroll -> Description in the Navigator.
2. Enter or query a payroll.
3. Choose the Valid Payment Methods button.

Variable Rate Profiles
- Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions -> Variable Rate Profiles in the Navigator.
VETS–100 Filing
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select VETS–100 Filing.

View Absence History
- Choose View –> Histories –> Absence in the Navigator.

View Earnings and Deductions Balances
Do one of the following:
2. Select an employee assignment and choose the Balances button. 
Or:
2. In the resulting Find window, query the person.

View Element Entry History for Employee
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the Entry History button.

View Employee Dental, Medical and Vision Benefits
2. Run a query in the Assignments Folder window.
3. Select an employee assignment and choose the View Benefits button.

View Employee Grade Comparatio
- Choose View –> Grade Comparatio in the Navigator.

View Enrollment Results
- Choose People –> Total Comp Enrollment –> View Enrollment Results in the Navigator.
**View Participation Information** (Advanced Benefits only)
- Choose People –> Total Comp Participation –> View Participation Information in the Navigator.

**View Program Structure**
- Choose Total Compensation –> Programs and Plans –> View Program Structure in the Navigator.

**View Run Messages** (Payroll only)
- Choose View –> System Messages in the Navigator.

**View Tax Balances**
Do one of the following:
2. Select an employee assignment and choose the Balances button.
   Or:
2. In the resulting Find window, query the person.

**View Vacancies**
- Choose View –> Vacancies in the Navigator.

**W2 Reporting Rules**
2. Enter or query a Government Reporting Entity (GRE).
3. Choose the Others button and select W2 Reporting Rules.

**W941** (Payroll only)
- Choose View –> Tax Information –> Form 941 Information in the Navigator

**WC Codes and Rates**
- Choose Work Structures –> Job –> Workers Compensation Rates in the Navigator
Wage Attachment Earnings Rules

- Choose Total Compensation -> Wage Attachment -> Earnings Rules in the Navigator.

Wage Attachment Exemption Rules

- Choose Total Compensation -> Wage Attachment -> Exemption Rules in the Navigator.

Wage Attachment Limit Rules

- Choose Total Compensation -> Wage Attachment -> Limit Rules in the Navigator.

Waive Participation (Advanced Benefits only)

- Choose People -> Total Comp Participation -> Waive Participation in the Navigator.

1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.
2. Query or enter a plan.
3. Choose the Waiving button.

What–if Eligibility (Advanced Benefits only)

- Choose People -> Total Comp Participation -> What–if Eligibility in the Navigator.

Work Choices (Job and Position)

1. Choose Work Structures -> Job or Position -> Description in the Navigator.
2. Enter or query a job or position.
3. Choose the Work Choices button.

Work Choices (Person)

1. Choose People -> Enter and Maintain in the Navigator.
2. Enter or query a person.
3. Choose the Others button and select Work Choices.

Work Day Information

2. Enter or query an organization.
3. Choose the Others button and select Work Day Information.

**Work Schedule**
2. Enter or query an organization.
3. Choose the Others button and select Work Schedule.

**Work Site Filing**
2. Enter or query a Reporting Establishment.
3. Choose the Others button and select Work Site Filing.

**Worker’s Compensation**
- Choose Work Structures → Job → Workers Compensation Codes in the Navigator
Reports and Processes in Oracle HRMS

AAP Reports
- Provides Job group analysis and workflow analysis reports.
See: *Using Oracle HRMS – The Fundamentals*.

Absences Report
- Absence details for an employee or organization, for some or all absence types.
See: *Managing Compensation and Benefits Using Oracle HRMS*.

ADA Reports
- Shows how your enterprise is responding to the requests of employees with disabilities.

Annual Unemployment Insurance (Form 940) Information (Payroll only)
- Provides numbers for annual 940 filing.

Assignment Status Report
- All employees, applicants or both assigned to selected work structures.
See: *Managing People Using Oracle HRMS*.

Audit Report (Payroll only)
- Selects person, employee or applicant, assignment, element, recurring or non-recurring status. Shows Business Group, GRE, assignment details, person entering data (responsibility), input date, effective change date, details of person affected. Lists all fields changed, with input date and effective date, old value and new value, responsibility, workstation address.
See: *Customizing, Reporting and System Administration in Oracle HRMS*.

COBRA Reports
- Coverage of payments report and publish standard COBRA letter.
See: *Managing Compensation and Benefits Using Oracle HRMS*.
Cost Breakdown Report (Payroll only)
- Summarized costing totals for a specified costing process and summarized costing totals for a particular consolidation set or payroll and payroll period.


Cost Breakdown Summary Report (Payroll only)
- Lists costing details by date range, payroll, consolidation set, GRE and segment values.


Current and Projected Progression Point Values Report
- The expected results of running the Increment Progression Points process, that is the projected point and value changes for a group of employees.


Earnings Audit (Payroll only)
- Report detailing all employees with a particular element being processed in a given pay period.

See: Running Your Payroll Using Oracle HRMS.

EEO–1 Reports
- EEO individual establishment and headquarters report and EEO consolidated report.


Element Link Details Report
- The eligibility criteria for an element or group of elements.

See: Managing Compensation and Benefits Using Oracle HRMS.

Element Result Listing
- Run results processed for a particular element over a defined period, and run results for selected input values of each employee’s last assignment process.

See: Running Your Payroll Using Oracle HRMS.
Employee Increment Results Report
- The actual results of running the Increment Progression Points process, that is progression point and value changes for a group of employees.


Employee Organization Movements Report
- New hires, terminations, transfers in and transfer out of a selected organization, or organization hierarchy.

See: Managing People Using Oracle HRMS.

Employee Payroll Movements Report (Payroll only)
- New hires, terminations, transfers in and transfer out of a selected payroll.

See: Managing People Using Oracle HRMS.

Employee Run Results (Payroll only)
- Users may select various elements for the various time frames, assignment of GREs. The report shows the run results for selected information by pay period.

See: Running Your Payroll Using Oracle HRMS.

Employee Summary Report
- Addresses, contacts, periods of service, assignments, special information, personal payment methods and element entries for a selected employee.

See: Managing People Using Oracle HRMS.

Federal W–2 (magnetic media) (Payroll only)
- Creation of Federal W–2 magnetic media and summary totals.

See: Running Your Payroll Using Oracle HRMS.

Federal W–2 Forms (Payroll only)
- Prints employee W–2s at an individual level, thus allowing W–2s to be created as employees terminate, or for an entire GRE.

See: Running Your Payroll Using Oracle HRMS.
**Federal 1099–R (magnetic media)** (Payroll only)
- Creation of Federal 10999R magnetic media.

See: *Running Your Payroll Using Oracle HRMS*.

**Federal 1099–R Forms** (Payroll only)
- Provides for printing of retiree 1099–R at an individual level as well as all employees in a GRE.

See: *Running Your Payroll Using Oracle HRMS*.

**Full Personal Details Report Set**
- Person details, applicant details, assignment details and work details for one employee.

See: *Managing People Using Oracle HRMS*.

**GRE Totals** (Payroll only)
- Reconciliation report to be used to assist in period end processing balancing purposes. This report shows Federal and State level taxable balances and withholdings.

See: *Running Your Payroll Using Oracle HRMS*.

**Gross to Net Summary US** (Payroll only)
- Details of total earnings and deductions summarized for a specified payroll and payroll period.

See: *Running Your Payroll Using Oracle HRMS*.

**Invalid Address Report** (Payroll only)
- Lists any address information inconsistencies.

See: *Running Your Payroll Using Oracle HRMS*.

**Job and Position Skills Matching Report**
- Lists of employees, applicants or both that meet some or all skill requirements of a job or position.

See: *Managing People Using Oracle HRMS*.

**Multiple Worksite Report**
- Reports on wages and locations of employees in all the multiple locations across all SUIs and other GREs.

See: *Managing People Using Oracle HRMS*.
NACHA (magnetic media) (Payroll only)
- Provides for creation of employee NACHA information to be submitted.
See: Running Your Payroll Using Oracle HRMS.

NACHA Report (Payroll only)
- Detail of employee NACHA information.
See: Running Your Payroll Using Oracle HRMS.

Negative Balance Reports (Payroll only)
- Report listing any negative balances found due to user adjustments or conversion issues.
See: Running Your Payroll Using Oracle HRMS.

New Hire Reports
- Report on newly hired or rehired employees.

Organization Hierarchy Report
- The organizations and optionally their managers below a selected position in a particular hierarchy.

OSHA Reports
- Report on work related injuries or illness.

Payments Register (Payroll only)
- Reports listing payments made to employees, listing payment method, check number, and amount.
See: Running Your Payroll Using Oracle HRMS.

Payroll Message Report (Payroll only)
- Display messages for processes connected to specified payrolls.
See: Running Your Payroll Using Oracle HRMS.
Position Hierarchy Report
- The positions and optionally their holders below a selected position in a particular hierarchy.

See: *Using Oracle HRMS – The Fundamentals*.

Requisition Summary Report
- Applicants and their interview schedules for a selection of vacancies.

See: *Managing People Using Oracle HRMS*.

Salary Review Report
- Current, past and proposed salaries for a selected list of employees.

See: *Managing Compensation and Benefits Using Oracle HRMS*.

Series EE Bond Purchase Report
- Compares actual staffing level with budgeted levels over a specific period.

Staffing Budget Details Report
- Actual staffing level with budgeted levels over a specified period.

See: *Managing People Using Oracle HRMS*.

Statement of Earnings (Payroll only)
- Check writer process produces paychecks with statement of earnings.

See: *Running Your Payroll Using Oracle HRMS*.

Terminations Report
- The number of employees from selected organizations leaving your enterprise within a particular period, and the reason for leaving.

See: *Managing People Using Oracle HRMS*.

VETS–100 Reports
- Shows number of special disabled and Vietnam era veterans you employ in each of nine job categories. Also, show total number of new hires in each job category and number of new hires in each category who qualify as special disabled veterans and Vietnam era veterans.
See: *Using Oracle HRMS – The Fundamentals*.

**Void Payments** (Payroll only)
- Details of cancelled check payments.
See: *Running Your Payroll Using Oracle HRMS*.

### Processes

**Audit Trail Update Tables Process**
- This process is used to set up audit trail on selected windows.
See: *Customizing, Reporting and System Administration in Oracle HRMS*.

**Audit Trail Update Datetracked Tables Process**
- This process is used to set up audit trail on selected windows.
See: *Customizing, Reporting and System Administration in Oracle HRMS*.

**BEE Batch Process (Purge)**
- This process is used to delete a batch from the BEE tables on completion of the concurrent request.
See: *Managing Compensation and Benefits Using Oracle HRMS*.

**BEE Batch Process (Validate)**
- This process is used to test each batch line against predefined rules about element entries, and against any additional validation procedures that you have created.
See: *Managing Compensation and Benefits Using Oracle HRMS*.

**BEE Batch Process (Transfer)**
- This process is used to create element entries in the Oracle HRMS Entries table from the existing entries in the BEE temporary tables.
See: *Managing Compensation and Benefits Using Oracle HRMS*.

**BEE Batch Process (Rollback)**
- This process is used to completely remove a BEE transfer, provided you have not purged the batch from the BEE tables
See: *Managing Compensation and Benefits Using Oracle HRMS*.
**Bulk Compile Formulas**
- Run this process to compile all your formulas.
See: *Using Oracle FastFormula*.

**Check Writer Process** (Payroll only)
- This process is used to write sequences of checks for your payroll run.
See: *Running Your Payroll Using Oracle HRMS*.

**Close Action Items Process** (Advanced Benefits Only)
- Run this process before the Close Enrollments Process to close any open action items that are required or optional for the persons you select.
See: *Managing Compensation and Benefits Using Oracle HRMS*.

**Close Enrollments Process** (Advanced Benefits Only)
- Run this process to close a person’s enrollment after elections have been made.
See: *Managing Compensation and Benefits Using Oracle HRMS*.

**Communications Triggers Process** (Advanced Benefits Only)
- Use the communications triggers process to generate communications for persons who meet the selection criteria that you specify.
See: *Managing Compensation and Benefits Using Oracle HRMS*.

**Costing Process**
- Generates journal entries for your ledgers and costing information relating to labor costs.
See: *Using Oracle HRMS – The Fundamentals*.

**Default Enrollment Process** (Advanced Benefits Only)
- Run this process to enroll participants into the default benefit plan when participants have not made an election.
See: *Managing Compensation and Benefits Using Oracle HRMS*. 
**Dependent Eligibility Process** (Advanced Benefits Only)
- Run this process for those benefit plans that include an age factor in determining dependent eligibility.

See: *Managing Compensation and Benefits Using Oracle HRMS*.

**Extract Process** (Advanced Benefits Only)
- Run the extract process to save the output of your system extract to the directory and file that you specified in your extract definition.

See: *Managing Compensation and Benefits Using Oracle HRMS*.

**Enable Multiple Security Groups Process**
- Run this process when you first set up single responsibility security.

See: *Customizing, Reporting and System Administration in Oracle HRMS*.

**Grant Permissions to Roles Process** (ROLEGEN)
- Dynamically grants select permissions on Oracle HRMS tables and views to the HR_REPORTING_USER role.

See: *Customizing, Reporting and System Administration in Oracle HRMS*.

**Generate Secure User Process** (SECGEN)
- Run this process when you create a new security profile that references a reporting user.

See: *Customizing, Reporting and System Administration in Oracle HRMS*.

**NACHA Process** (Payroll only)
- Produces files that you load on magnetic tape and despatch to banks for direct deposit payments.

See: *Running Your Payroll Using Oracle HRMS*.

**Participation Batch Process: Life Event** (Advanced Benefits Only)
- Run this process to determine eligibility and electable choices for benefits participants based on a life event you select.

See: *Managing Compensation and Benefits Using Oracle HRMS*.

**Participation Batch Process: Scheduled** (Advanced Benefits Only)
- Run this process to determine eligibility and electable choices for benefits participants based on a scheduled enrollment event.

See: *Managing Compensation and Benefits Using Oracle HRMS*.
Participation Batch Process: Selection (Advanced Benefits Only)

- Run this process to determine eligibility for benefits participants. This process does not create electable choices.

See: Managing Compensation and Benefits Using Oracle HRMS.

PrePayments Process (Payroll only)

- Use this process to distribute employee pay over more than one payment method using either a percentage or monetary split.

See: Running Your Payroll Using Oracle HRMS.

Retry Payroll Process (Payroll only)

- Retry a payroll process again.

See: Running Your Payroll Using Oracle HRMS.

RetroPay Process (Payroll only)

- Enables you to make back pay adjustments.

See: Running Your Payroll Using Oracle HRMS.

Security List Maintenance Process (LISTGEN)

- This process is usually run every night to maintain the lists of organizations, positions, payrolls, employees, and applicants that security profile holders can access.

See: Customizing, Reporting and System Administration in Oracle HRMS.

Synchronize Positions Process

- This process updates the non-datetracked Positions table (PER_ALL_POSITIONS_F) with changes made to the datetracked table (HR_ALL_POSITIONS_F). When you run the process, any datetracked changes with an effective date on or before today are applied to the non-datetracked table.

Void Payments Process (Payroll only)

- Allows you to void checks that have been printed but need to be cancelled.

See: Running Your Payroll Using Oracle HRMS.
This appendix provides template SQL*Plus scripts to extract data to include in standard letters.
Publicly Callable Business Process APIs

Application Programmatic Interfaces (APIs) are a logical grouping of all external process routines. The Oracle HRMS API strategy delivers a set of PL/SQL packages procedures and functions that provide an open interface to the database.

See: APIs in Oracle HRMS, *Oracle HRMS Implementation Guide*.

<table>
<thead>
<tr>
<th>File Name</th>
<th>Package Name</th>
<th>Business Process</th>
<th>Legislation</th>
</tr>
</thead>
<tbody>
<tr>
<td>peempapi.pkh</td>
<td>hr_employee_api</td>
<td>create_employee</td>
<td>WW</td>
</tr>
<tr>
<td>peempapi.pkh</td>
<td>hr_employee_api</td>
<td>create_gb_employee</td>
<td>UK</td>
</tr>
<tr>
<td>peempapi.pkh</td>
<td>hr_employee_api</td>
<td>create_us_employee</td>
<td>US</td>
</tr>
<tr>
<td>peempapi.pkh</td>
<td>hr_employee_api</td>
<td>re_hire_ex_employee</td>
<td>WW</td>
</tr>
<tr>
<td>peexeapi.pkh</td>
<td>hr_ex_employee_api</td>
<td>actual_termination_emp</td>
<td>WW</td>
</tr>
<tr>
<td>peexeapi.pkh</td>
<td>hr_ex_employee_api</td>
<td>final_process_emp</td>
<td>WW</td>
</tr>
<tr>
<td>peexeapi.pkh</td>
<td>hr_ex_employee_api</td>
<td>update_term_details_emp</td>
<td>WW</td>
</tr>
<tr>
<td>peappapi.pkh</td>
<td>hr_applicant_api</td>
<td>create_applicant</td>
<td>WW</td>
</tr>
<tr>
<td>peappapi.pkh</td>
<td>hr_applicant_api</td>
<td>create_us_applicant</td>
<td>US</td>
</tr>
<tr>
<td>peappapi.pkh</td>
<td>hr_applicant_api</td>
<td>create_gb_applicant</td>
<td>UK</td>
</tr>
<tr>
<td>peappapi.pkh</td>
<td>hr_applicant_api</td>
<td>hire_applicant</td>
<td>WW</td>
</tr>
<tr>
<td>peperapi.pkh</td>
<td>hr_person_api</td>
<td>update_person</td>
<td>WW</td>
</tr>
<tr>
<td>peperapi.pkh</td>
<td>hr_person_api</td>
<td>update_gb_person</td>
<td>UK</td>
</tr>
<tr>
<td>peperapi.pkh</td>
<td>hr_person_api</td>
<td>update_us_person</td>
<td>US</td>
</tr>
<tr>
<td>peconapi.pkh</td>
<td>hr_contact_api</td>
<td>create_person</td>
<td>WW</td>
</tr>
<tr>
<td>pecrlapi.pkh</td>
<td>hr_contact_rel_api</td>
<td>create_contact</td>
<td>WW</td>
</tr>
<tr>
<td>pecrlapi.pkh</td>
<td>hr_contact_rel_api</td>
<td>update_contact_relationship</td>
<td>WW</td>
</tr>
<tr>
<td>pecrlapi.pkh</td>
<td>hr_contact_rel_api</td>
<td>delete_contact_relationship</td>
<td>WW</td>
</tr>
<tr>
<td>pephnapi.pkh</td>
<td>hr_phone_api</td>
<td>create_phone</td>
<td>WW</td>
</tr>
<tr>
<td>pephnapi.pkh</td>
<td>hr_phone_api</td>
<td>update_phone</td>
<td>WW</td>
</tr>
<tr>
<td>pephnapi.pkh</td>
<td>hr_phone_api</td>
<td>delete_phone</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>activate_emp_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>create_secondary_emp_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>create_us_secondary_emp_asg</td>
<td>US</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>create_gb_secondary_emp_asg</td>
<td>UK</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>suspend_emp_asg</td>
<td>WW</td>
</tr>
<tr>
<td>File Name</td>
<td>Package Name</td>
<td>Business Process</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------</td>
<td>-----------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>hrpyapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>insert_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>hrpyapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>approve_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>hrpyapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>delete_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>hrpyapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>insert_proposal_component</td>
<td>WW</td>
</tr>
<tr>
<td>hrpyapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>update_proposal_component</td>
<td>WW</td>
</tr>
<tr>
<td>hrpyapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>delete_proposal_component</td>
<td>WW</td>
</tr>
<tr>
<td>hrpyapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>upload_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>pedsapi.pkh</td>
<td>hr_periods_of_service_api</td>
<td>update_pds_detail</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>update_emp_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>update_us_emp_asg</td>
<td>US</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>update_gb_emp_asg</td>
<td>UK</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>update_emp_asg_criteria</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>update_apl_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>createSecondaryapl_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>offer_apl_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>actual_termination_emp_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peasgapi.pkh</td>
<td>hr_assignment_api</td>
<td>final_process_emp_asg</td>
<td>WW</td>
</tr>
<tr>
<td>peaaplapi.pkh</td>
<td>hr_application_api</td>
<td>update_apl_details</td>
<td>WW</td>
</tr>
<tr>
<td>peaddapi.pkh</td>
<td>hr_person_address_api</td>
<td>create_person_address</td>
<td>WW</td>
</tr>
<tr>
<td>peaddapi.pkh</td>
<td>hr_person_address_api</td>
<td>create_gb_person_address</td>
<td>UK</td>
</tr>
<tr>
<td>peaddapi.pkh</td>
<td>hr_person_address_api</td>
<td>create_us_person_address</td>
<td>US</td>
</tr>
<tr>
<td>peaddapi.pkh</td>
<td>hr_person_address_api</td>
<td>update_person_address</td>
<td>WW</td>
</tr>
<tr>
<td>peaddapi.pkh</td>
<td>hr_person_address_api</td>
<td>update_gb_person_address</td>
<td>UK</td>
</tr>
<tr>
<td>peaddapi.pkh</td>
<td>hr_person_address_api</td>
<td>update_us_person_address</td>
<td>US</td>
</tr>
<tr>
<td>pesitapi.pkh</td>
<td>hr_sit_api</td>
<td>create_sit</td>
<td>WW</td>
</tr>
<tr>
<td>pesitapi.pkh</td>
<td>hr_sit_api</td>
<td>update_sit</td>
<td>WW</td>
</tr>
<tr>
<td>pyppmapi.pkh</td>
<td>hr_personal_pay_method_api</td>
<td>create_personal_pay_method</td>
<td>WW</td>
</tr>
<tr>
<td>pyppmapi.pkh</td>
<td>hr_personal_pay_method_api</td>
<td>create_us_personal_pay_method</td>
<td>US</td>
</tr>
<tr>
<td>pyppmapi.pkh</td>
<td>hr_personal_pay_method_api</td>
<td>create_gb_personal_pay_method</td>
<td>UK</td>
</tr>
<tr>
<td>pyppmapi.pkh</td>
<td>hr_personal_pay_method_api</td>
<td>update_personal_pay_method</td>
<td>WW</td>
</tr>
<tr>
<td>pyppmapi.pkh</td>
<td>hr_personal_pay_method_api</td>
<td>update_us_personal_pay_method</td>
<td>US</td>
</tr>
<tr>
<td>pyppmapi.pkh</td>
<td>hr_personal_pay_method_api</td>
<td>update_gb_personal_pay_method</td>
<td>UK</td>
</tr>
<tr>
<td>File Name</td>
<td>Package Name</td>
<td>Business Process</td>
<td>Legislation</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------------------------</td>
<td>-------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>pyppmapi.pkh</td>
<td>hr_personal_pay_method_api</td>
<td>delete_personal_pay_method</td>
<td>WW</td>
</tr>
<tr>
<td>hrpyppapi.pkh</td>
<td>hr_upload_proposal_api</td>
<td>upload_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>pyeleapi.pkh</td>
<td>py_element_entry_api</td>
<td>create_element_entry</td>
<td>WW</td>
</tr>
<tr>
<td>pyeleapi.pkh</td>
<td>py_element_entry_api</td>
<td>delete_element_entry</td>
<td>WW</td>
</tr>
<tr>
<td>pyeleapi.pkh</td>
<td>py_element_entry_api</td>
<td>update_element_entry</td>
<td>WW</td>
</tr>
<tr>
<td>pygrrapi.pkh</td>
<td>hr_grade_api</td>
<td>create_grade_rate_value</td>
<td>WW</td>
</tr>
<tr>
<td>pygrrapi.pkh</td>
<td>hr_grade_api</td>
<td>delete_grade_rate_value</td>
<td>WW</td>
</tr>
<tr>
<td>pygrrapi.pkh</td>
<td>hr_grade_api</td>
<td>update_grade_rate_value</td>
<td>WW</td>
</tr>
<tr>
<td>pypsrapi.pkh</td>
<td>hr_pay_scale_api</td>
<td>create_pay_scale_value</td>
<td>WW</td>
</tr>
<tr>
<td>pypsrapi.pkh</td>
<td>hr_pay_scale_api</td>
<td>delete_pay_scale_value</td>
<td>WW</td>
</tr>
<tr>
<td>pypsrapi.pkh</td>
<td>hr_pay_scale_api</td>
<td>update_pay_scale_value</td>
<td>WW</td>
</tr>
<tr>
<td>peposapi.pkh</td>
<td>hr_position_api</td>
<td>create_position</td>
<td>WW</td>
</tr>
<tr>
<td>pepfsrapi.pkh</td>
<td>hr_position_api</td>
<td>update_position</td>
<td>WW</td>
</tr>
<tr>
<td>pepfsrapi.pkh</td>
<td>hr_position_requirement_api</td>
<td>create_position_requirement</td>
<td>WW</td>
</tr>
<tr>
<td>pejobapi.pkh</td>
<td>hr_job_api</td>
<td>create_job</td>
<td>WW</td>
</tr>
<tr>
<td>pejobapi.pkh</td>
<td>hr_job_requirement_api</td>
<td>create_job_requirement</td>
<td>WW</td>
</tr>
<tr>
<td>pemmvapi.pkh</td>
<td>hr_mass_move_api</td>
<td>mass_move</td>
<td>WW</td>
</tr>
<tr>
<td>pevgrapi.pkh</td>
<td>hr_valid_grade_api</td>
<td>create_valid_grade</td>
<td>WW</td>
</tr>
<tr>
<td>hrabmapi.pkh</td>
<td>hr_batch_message_line_api</td>
<td>create_message_line</td>
<td>WW</td>
</tr>
<tr>
<td>hrabmapi.pkh</td>
<td>hr_batch_message_line_api</td>
<td>delete_message_line</td>
<td>WW</td>
</tr>
<tr>
<td>hrabmapi.pkh</td>
<td>hr_batch_message_line_api</td>
<td>delete_batch_lines</td>
<td>WW</td>
</tr>
<tr>
<td>peaprapip.pkh</td>
<td>hr_appraisals_api</td>
<td>create_appraisal</td>
<td>WW</td>
</tr>
<tr>
<td>peaprapip.pkh</td>
<td>hr_appraisals_api</td>
<td>update_appraisal</td>
<td>WW</td>
</tr>
<tr>
<td>peaprapip.pkh</td>
<td>hr_appraisals_api</td>
<td>delete_appraisal</td>
<td>WW</td>
</tr>
<tr>
<td>peaprapip.pkh</td>
<td>hr_appraisal_templates_api</td>
<td>create_appraisal_template</td>
<td>WW</td>
</tr>
<tr>
<td>peaprapip.pkh</td>
<td>hr_appraisal_templates_api</td>
<td>update_appraisal_template</td>
<td>WW</td>
</tr>
<tr>
<td>peaprapip.pkh</td>
<td>hr_appraisal_templates_api</td>
<td>delete_appraisal_template</td>
<td>WW</td>
</tr>
<tr>
<td>peasrapi.pkh</td>
<td>hr_assessments_api</td>
<td>create_assessment</td>
<td>WW</td>
</tr>
<tr>
<td>peasrapi.pkh</td>
<td>hr_assessments_api</td>
<td>update_assessment</td>
<td>WW</td>
</tr>
<tr>
<td>peasrapi.pkh</td>
<td>hr_assessments_api</td>
<td>delete_assessment</td>
<td>WW</td>
</tr>
<tr>
<td>peasrapi.pkh</td>
<td>hr_assessment_groups_api</td>
<td>create_assessment_group</td>
<td>WW</td>
</tr>
<tr>
<td>peasrapi.pkh</td>
<td>hr_assessment_groups_api</td>
<td>update_assessment_group</td>
<td>WW</td>
</tr>
<tr>
<td>File Name</td>
<td>Package Name</td>
<td>Business Process</td>
<td>Legislation</td>
</tr>
<tr>
<td>-----------</td>
<td>----------------------------------------</td>
<td>-----------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>peasrapi.pkh</td>
<td>hr_assessment_groups_api</td>
<td>delete_assessment_group</td>
<td>WW</td>
</tr>
<tr>
<td>peastapi.pkh</td>
<td>hr_assessment_types_api</td>
<td>create_assessment_type</td>
<td>WW</td>
</tr>
<tr>
<td>peastapi.pkh</td>
<td>hr_assessment_types_api</td>
<td>update_assessment_type</td>
<td>WW</td>
</tr>
<tr>
<td>peastapi.pkh</td>
<td>hr_assessment_types_api</td>
<td>delete_assessment_type</td>
<td>WW</td>
</tr>
<tr>
<td>pecelapi.pkh</td>
<td>hr_competence_element_api</td>
<td>create_competence_element</td>
<td>WW</td>
</tr>
<tr>
<td>pecelapi.pkh</td>
<td>hr_competence_element_api</td>
<td>update_competence_element</td>
<td>WW</td>
</tr>
<tr>
<td>pecelapi.pkh</td>
<td>hr_competence_element_api</td>
<td>update_personal_comp_element</td>
<td>WW</td>
</tr>
<tr>
<td>pecelapi.pkh</td>
<td>hr_competence_element_api</td>
<td>delete_competence_element</td>
<td>WW</td>
</tr>
<tr>
<td>pecelapi.pkh</td>
<td>hr_competence_element_api</td>
<td>maintain_student_comp_element</td>
<td>WW</td>
</tr>
<tr>
<td>pecelapi.pkh</td>
<td>hr_competence_element_api</td>
<td>copy_competencies</td>
<td>WW</td>
</tr>
<tr>
<td>pecelapi.pkh</td>
<td>hr_competence_element_api</td>
<td>update_delivered_dates</td>
<td>WW</td>
</tr>
<tr>
<td>pecnapi.pkh</td>
<td>hr_competences_api</td>
<td>create_competence</td>
<td>WW</td>
</tr>
<tr>
<td>pecnapi.pkh</td>
<td>hr_competences_api</td>
<td>update_competence</td>
<td>WW</td>
</tr>
<tr>
<td>pecnapi.pkh</td>
<td>hr_competences_api</td>
<td>delete_competence</td>
<td>WW</td>
</tr>
<tr>
<td>parapi.pkh</td>
<td>hr_participants_api</td>
<td>create_participant</td>
<td>WW</td>
</tr>
<tr>
<td>parapi.pkh</td>
<td>hr_participants_api</td>
<td>update_participant</td>
<td>WW</td>
</tr>
<tr>
<td>parapi.pkh</td>
<td>hr_participants_api</td>
<td>delete_participant</td>
<td>WW</td>
</tr>
<tr>
<td>peprtapi.pkh</td>
<td>hr_performance_ratings_api</td>
<td>create_performance_rating</td>
<td>WW</td>
</tr>
<tr>
<td>peprtapi.pkh</td>
<td>hr_performance_ratings_api</td>
<td>update_performance_rating</td>
<td>WW</td>
</tr>
<tr>
<td>peprtapi.pkh</td>
<td>hr_performance_ratings_api</td>
<td>delete_performance_rating</td>
<td>WW</td>
</tr>
<tr>
<td>perscapi.pkh</td>
<td>hr_rating_scales_api</td>
<td>create_rating_scale</td>
<td>WW</td>
</tr>
<tr>
<td>perscapi.pkh</td>
<td>hr_rating_scales_api</td>
<td>update_rating_scale</td>
<td>WW</td>
</tr>
<tr>
<td>perscapi.pkh</td>
<td>hr_rating_scales_api</td>
<td>delete_rating_scale</td>
<td>WW</td>
</tr>
<tr>
<td>pertlapi.pkh</td>
<td>hr_rating_levels_api</td>
<td>create_rating_level</td>
<td>WW</td>
</tr>
<tr>
<td>pertlapi.pkh</td>
<td>hr_rating_levels_api</td>
<td>update_rating_level</td>
<td>WW</td>
</tr>
<tr>
<td>pertlapi.pkh</td>
<td>hr_rating_levels_api</td>
<td>delete_rating_level</td>
<td>WW</td>
</tr>
<tr>
<td>peahcapi.pkh</td>
<td>hr_api_hook_call_api</td>
<td>create_api_hook_call</td>
<td>WW</td>
</tr>
<tr>
<td>peahcapi.pkh</td>
<td>hr_api_hook_call_api</td>
<td>update_api_hook_call</td>
<td>WW</td>
</tr>
<tr>
<td>peahcapi.pkh</td>
<td>hr_api_hook_call_api</td>
<td>delete_api_hook_call</td>
<td>WW</td>
</tr>
<tr>
<td>peprvapi.pkh</td>
<td>hr_perf_review_api</td>
<td>create_perf_review</td>
<td>WW</td>
</tr>
<tr>
<td>peprvapi.pkh</td>
<td>hr_perf_review_api</td>
<td>update_perf_review</td>
<td>WW</td>
</tr>
<tr>
<td>peprvapi.pkh</td>
<td>hr_perf_review_api</td>
<td>delete_perf_review</td>
<td>WW</td>
</tr>
<tr>
<td>File Name</td>
<td>Package Name</td>
<td>Business Process</td>
<td>Legislation</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------</td>
<td>----------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>pepypapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>insert_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>pepypapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>update_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>pepypapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>approve_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>pepypapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>delete_salary_proposal</td>
<td>WW</td>
</tr>
<tr>
<td>pepypapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>insert_proposal_component</td>
<td>WW</td>
</tr>
<tr>
<td>pepypapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>update_proposal_component</td>
<td>WW</td>
</tr>
<tr>
<td>pepypapi.pkh</td>
<td>hr_maintain_proposal_api</td>
<td>delete_proposal_component</td>
<td>WW</td>
</tr>
<tr>
<td>hrtcapi.pkh</td>
<td>hr_contract_api</td>
<td>create_contract</td>
<td>WW</td>
</tr>
<tr>
<td>hrtcapi.pkh</td>
<td>hr_contract_api</td>
<td>update_contract</td>
<td>WW</td>
</tr>
<tr>
<td>hrtcapi.pkh</td>
<td>hr_contract_api</td>
<td>delete_contract</td>
<td>WW</td>
</tr>
<tr>
<td>pedsapi.pkh</td>
<td>hr_periods_of_service_api</td>
<td>update_pds_detail</td>
<td>WW</td>
</tr>
</tbody>
</table>
This appendix provides template SQL*Plus scripts to extract data to include in standard letters.
## PERWPOUK Template

<table>
<thead>
<tr>
<th>PERWPOUK.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>WHENEVER SQLERROR EXIT FAILURE ROLLBACK</td>
<td>This section defines the required SQL*Plus environment settings. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>REM Define the MS Word mail merge record separator</td>
<td></td>
</tr>
<tr>
<td>DEFINE ch=&quot;%'&quot;</td>
<td></td>
</tr>
<tr>
<td>REM Define the column width for returning query results</td>
<td></td>
</tr>
<tr>
<td>COLUMN L1 FORMAT A2000</td>
<td></td>
</tr>
<tr>
<td>SET PAUSE OFF</td>
<td></td>
</tr>
<tr>
<td>SET FEEDBACK OFF</td>
<td></td>
</tr>
<tr>
<td>SET RECSEP OFF</td>
<td></td>
</tr>
<tr>
<td>SET HEADING OFF</td>
<td></td>
</tr>
<tr>
<td>SET VERIFY OFF</td>
<td></td>
</tr>
<tr>
<td>SET TERMOUT OFF</td>
<td></td>
</tr>
<tr>
<td>SET PAGESIZE 0</td>
<td></td>
</tr>
<tr>
<td>REM Insert session row</td>
<td>This section creates a row in the Application Object Library table (AOL) FND_SESSIONS. This enables the datetrack security views to be accessed for the session. The &amp;2 argument contains the current SQL*Forms session date. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>insert into fnd_sessions(session_id ,effective_date)</td>
<td></td>
</tr>
<tr>
<td>select userenv('SESSIONID'),</td>
<td></td>
</tr>
<tr>
<td>to_date('&amp;2','DD–MON–YYYY')</td>
<td></td>
</tr>
<tr>
<td>from sys.dual</td>
<td></td>
</tr>
<tr>
<td>/REM Set length of the header</td>
<td>This section has two functions: 1) To set the mail merge header linesize. This is dependent on the character length of all the mail merge items you want to use. In the example, the header linesize equates approximately to 220 characters. 2) To enable the spooling of the SQL results. You must remove the REM keyword from the line that spools output to a file for the Microsoft Mailmerge. If you use concurrent processing to generate the data source file, Concurrent Manager creates the output file.</td>
</tr>
<tr>
<td>SET LINESIZE 220</td>
<td></td>
</tr>
<tr>
<td>REM Create the mail merge 'header' record for MS Word</td>
<td></td>
</tr>
<tr>
<td>REM Note: SPOOL command commented out for concurrent manager.</td>
<td></td>
</tr>
<tr>
<td>REM PC based solution required the SPOOL command.</td>
<td></td>
</tr>
<tr>
<td>REM spool perwpouk.txt</td>
<td></td>
</tr>
<tr>
<td>select 'address_line1'           &amp;ch</td>
<td>This section defines the mail merge header information. These are the mail merge fields you integrate with your word processed letter. Each mail merge field is delimited by the pre-defined &amp;ch character. Ensure that the field size does not exceed 40 characters and that the field name does not include white spaces. Do not forget that the length in characters of this selected row from sys.dual is the LINESIZE value you specified above.</td>
</tr>
<tr>
<td>'address_line2'                &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'address_line3'                &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'town_or_city'                 &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'country'                      &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'postal_code'                  &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'applicant_title'              &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'applicant_last_name'          &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'position_name'                &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'organization_name'            &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'grade_name'                   &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'projected_hire_date'          &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'recruiter_title'              &amp;ch</td>
<td></td>
</tr>
<tr>
<td>'recruiter_last_name'          &amp;ch</td>
<td></td>
</tr>
<tr>
<td>from sys.dual</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>PERWPOUK.sql</td>
</tr>
<tr>
<td>---------</td>
<td>--------------</td>
</tr>
<tr>
<td>After selecting your mail merge header information, you must re-set the LINESIZE to the maximum to VARCHAR2 size which is 2000.</td>
<td>REM re-initialise the linesize to the maximum 2000 varchar2 length SET LINESIZE 2000</td>
</tr>
<tr>
<td>This section is the main SQL<em>Plus query that generates the mail merge field information. Note that the columns are merged together using the &amp;ch character as the field delimiter. The RPAD function pads out the row of information with # for all white spaces. Without this function, mail merge cannot distinguish when a row/record has ended. The SQL</em>Plus query in this example is generated from letter requests. Therefore the &amp;1 argument is used to identify which letter_request_id is being generated.</td>
<td>REM Mail merge interview query select rpad( nvl(pa.address_line1,' ')</td>
</tr>
</tbody>
</table>
```sql
where plr.letter_request_id = &1
and plr.person_id = ppl1.person_id
and plr.person_id = pa.primary_flag (+) = 'Y'
and plr.person_id = pa.person_id (+) =
ppl1.person_id
and ft.territory_code (+) = pa.country
and h11.lookup_code (+) =
ppl1.title
and h11.lookup_type (+) = 'TITLE'
and pasg1.assignment_id (+) =
plr.assignment_id
and pos.position_id (+) =
pasg1.position_id
and pou.organization_id (+) =
pasg1.organization_id
and pg.grade_id (+) =
pasg1.grade_id
and pappl.application_id (+) =
pasg1.application_id
and pp2.person_id (+) =
pasg1.recruiter_id
and h12.lookup_code (+) =
pp2.title
and h12.lookup_type (+) = 'TITLE'
/
REM Note: SPOOL command commented out for concurrent manager.
REM spool off
REM update the letter request_status from PENDING to COMPLETE
update per_letter_requests plr
set plr.request_status = 'COMPLETE'
where plr.letter_request_id = &1
and plr.request_status = 'PENDING'
/
REM delete the session row created
delete from fnd_sessions fs
where fs.session_id = userenv('sessionid')
and fs.effective_date = to_date('&2','DD–MON–YYYY')
/
REM commit the changes
commit
/
exit
```

This section updates the letter request from Pending to Complete (as the example is for letter requests).

This section deletes the row inserted into FND_SESSIONS.

This section commits the changes and exits the SQL*Plus session.
### PERWPWUK Template

<table>
<thead>
<tr>
<th>PERWPWUK.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>REM</td>
<td>This section defines the required SQL*Plus environment settings. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>DEFINE line_size=80</td>
<td></td>
</tr>
<tr>
<td>DEFINE field_size= &amp;line_size-1</td>
<td></td>
</tr>
<tr>
<td>DEFINE ch='%'</td>
<td></td>
</tr>
<tr>
<td>SET PAGESIZE 0</td>
<td></td>
</tr>
<tr>
<td>SET LINESIZE &amp;line_size</td>
<td></td>
</tr>
<tr>
<td>BREAK ON L1 SKIP PAGE</td>
<td></td>
</tr>
<tr>
<td>COLUMN L1 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L2 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L3 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L4 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L5 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L6 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L7 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L8 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>COLUMN L9 FORMAT A&amp;line_size</td>
<td></td>
</tr>
<tr>
<td>SET FEEDBACK OFF</td>
<td></td>
</tr>
<tr>
<td>SET RECSEP OFF</td>
<td></td>
</tr>
<tr>
<td>SET HEADING OFF</td>
<td></td>
</tr>
<tr>
<td>SET VERIFY OFF</td>
<td></td>
</tr>
<tr>
<td>SET TERMOUT OFF</td>
<td></td>
</tr>
<tr>
<td>insert into fnd_sessions</td>
<td>This section creates a row in the Application Object Library table (AOL) FND_SESSIONS. The &amp;2 argument contains the current SQL*Forms session date. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>(session_id ,effective_date)</td>
<td></td>
</tr>
<tr>
<td>select userenv('SESSIONID')</td>
<td></td>
</tr>
<tr>
<td>, to_date('&amp;2','DD-MON-YYYY')</td>
<td></td>
</tr>
<tr>
<td>from sys.dual</td>
<td></td>
</tr>
<tr>
<td>REM re-initialise the linesize to the maximum 2000</td>
<td>After selecting your mail merge header information, you must re-set the LINESIZE to the maximum to VARCHAR2 size which is 2000.</td>
</tr>
<tr>
<td>varchar2 length</td>
<td></td>
</tr>
<tr>
<td>SET LINESIZE 2000</td>
<td></td>
</tr>
<tr>
<td>Comment</td>
<td>PERWPWUK.sql</td>
</tr>
<tr>
<td>---------</td>
<td>--------------</td>
</tr>
<tr>
<td>This section is the main SQL<em>Plus query that generates the mail merge field information. Note that the columns are merged together using the &amp;ch character as the field delimiter. The SQL</em>Plus query in this example is generated from letter requests. Therefore the &amp;1 argument is used to identify which letter_request_id is being generated.</td>
<td>/*select nvl(t.meaning</td>
</tr>
<tr>
<td>This section updates the letter request from Pending to Complete (as the example is for letter requests).</td>
<td>update per_letter_requests r set r.letter_request_id = &amp;1 where r.letter_request_id = &amp;1</td>
</tr>
<tr>
<td>This section commits the changes and exits the SQL*Plus session.</td>
<td>/<em>commit</em>/</td>
</tr>
</tbody>
</table>
OTA SQL*Plus Script

Produce Confirmation Letters

<table>
<thead>
<tr>
<th>OTA.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>WHENEVER SQLERROR EXIT FAILURE ROLLBACK</td>
<td>This section defines the required SQL*Plus environment settings. You should produce this section exactly as you see it when you define your mail merge file.</td>
</tr>
<tr>
<td>DEFINE ch=&quot;%'&quot;</td>
<td></td>
</tr>
<tr>
<td>REM Define the column width for returning query results</td>
<td></td>
</tr>
<tr>
<td>COLUMN L1 FORMAT A2000</td>
<td></td>
</tr>
<tr>
<td>SET PAUSE OFF</td>
<td></td>
</tr>
<tr>
<td>SET FEEDBACK OFF</td>
<td></td>
</tr>
<tr>
<td>SET RECSEP OFF</td>
<td></td>
</tr>
<tr>
<td>SET HEADING OFF</td>
<td></td>
</tr>
<tr>
<td>SET VERIFY OFF</td>
<td></td>
</tr>
<tr>
<td>SET TERMOUT OFF</td>
<td></td>
</tr>
<tr>
<td>SET PAGESIZE 0</td>
<td></td>
</tr>
<tr>
<td>This section creates the required SQL*Plus environment settings. You should produce this section exactly as you see it when you define your mail merge file.</td>
<td></td>
</tr>
<tr>
<td>REM Insert session row</td>
<td></td>
</tr>
<tr>
<td>insert into fnd_sessions(session_id ,effective_date)</td>
<td></td>
</tr>
<tr>
<td>select userenv('SESSIONID'),</td>
<td></td>
</tr>
<tr>
<td>to_date('&amp;2','DD-MON-YYYY')</td>
<td></td>
</tr>
<tr>
<td>from sys.dual</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>This section creates a row in the Application Object Library table (AOL) FND_SESSIONS. This enables the datetrack security views to be accessed for the session. The &amp;2 argument contains the current SQL*Forms session date. You should produce this section exactly as you see it when you define your mail merge file.</td>
<td></td>
</tr>
<tr>
<td>REM Set length of the header</td>
<td></td>
</tr>
<tr>
<td>SET LINESIZE 200</td>
<td></td>
</tr>
<tr>
<td>REM Create the mail merge ‘header’ record for MS Word</td>
<td></td>
</tr>
<tr>
<td>REM Note: SPOOL command commented out for concurrent manager.</td>
<td></td>
</tr>
<tr>
<td>REM PC based solution required the SPOOL command.spool xxxxx.txt</td>
<td></td>
</tr>
<tr>
<td>This section has two functions:</td>
<td></td>
</tr>
<tr>
<td>1) To set the mail merge header line size. This is dependent on the character length of all the mail merge items you want to use. In the example, the header line size equates approximately to 220 characters.</td>
<td></td>
</tr>
<tr>
<td>2) To enable the spooling of the SQL results. The spool file should match the name of the SQL file you are writing, but with a text file extension. 2.2</td>
<td></td>
</tr>
<tr>
<td>OTA.sql</td>
<td>Comment</td>
</tr>
<tr>
<td>---------</td>
<td>---------</td>
</tr>
<tr>
<td>select 'student_title'</td>
<td></td>
</tr>
<tr>
<td>REM re-initialise the linesize to the maximum 2000 var-char2 length</td>
<td>After selecting your mail merge header information, you must re-set the line size to the maximum VARCHAR2 size, which is 2000.</td>
</tr>
<tr>
<td>SET LINESIZE 2000</td>
<td></td>
</tr>
</tbody>
</table>

C – 8    Customizing, Reporting, and System Administration in Oracle HRMS (US)
**OTA.sql**

| select rpad( | Comment |
| initcap(nvl(d.delegate_title_meaning, ' ')) | This section is the main SQL*Plus query that generates the mail merge field information. Note that the columns are merged together using the &ch character as the field delimiter. The RXAD function pads out the row of information with # for all white spaces. Without this function, mail merge cannot distinguish when a row/record has ended. The SQL*Plus query in this example is generated from letter requests. Therefore the &1 argument is used to identify which letter_request_id is being generated. |
| ||&ch|| |  |
| nvl(d.delegate_first_name, ' ') |  |
| ||&ch|| |  |
| nvl(d.delegate_last_name, ' ') |  |
| ||&ch|| |  |
| nvl(v.description, ' ') |  |
| ||&ch|| |  |
| nvl(d.event_activity_version_name, ' ') |  |
| ||&ch|| |  |
| to_char(d.course_end_date, 'DD fmMonth YYYY') | |
| ||&ch, |  |
| 2000, '#' |  |
| from ota_delegate_bookings_v |  |
| d, |  |
| ota_activity_versions |  |
| v, |  |
| per_letter_request_lines |  |
| plr |  |
| where plr.letter_request_id |  |
| = &1 |  |
| and (plr.ota_booking_id |  |
| = d.booking_id |  |
| or plr.ota_event_id |  |
| = d.event_id) |  |
| and d.activity_version_id |  |
| = v.activity_version_id |  |
| / |  |

REM Note: SPOOL command commented out for concurrent manager. REM PC based solution required the SPOOL command. spool off
<table>
<thead>
<tr>
<th>OTA.sql</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>REM Update the letter request_status from PENDING to COMPLETE</td>
<td>This section updates the letter request from Pending to Complete (as the example is for letter requests).</td>
</tr>
<tr>
<td>update per_letter_requests</td>
<td></td>
</tr>
<tr>
<td>plr</td>
<td></td>
</tr>
<tr>
<td>set plr.request_status = 'COMPLETE'</td>
<td></td>
</tr>
<tr>
<td>where plr.letter_request_id = &amp;1</td>
<td></td>
</tr>
<tr>
<td>and plr.request_status = 'PENDING'</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>REM delete the session row created</td>
<td>This section deletes the row inserted into FND_SESSIONS.</td>
</tr>
<tr>
<td>delete from fnd_sessions</td>
<td></td>
</tr>
<tr>
<td>fs</td>
<td></td>
</tr>
<tr>
<td>where fs.session_id = userenv('sessionid')</td>
<td></td>
</tr>
<tr>
<td>and fs.effective_date = to_date('&amp;2','DD-MON-YYYY')</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>REM commit the changes</td>
<td>This section commits the changes and exits the SQL*Plus session</td>
</tr>
<tr>
<td>commit</td>
<td></td>
</tr>
<tr>
<td>/</td>
<td></td>
</tr>
<tr>
<td>exit</td>
<td></td>
</tr>
</tbody>
</table>
Glossary

360 Degree Appraisal  Part of the SSHR Appraisal function and also known as a Group Appraisal. This is an employee appraisal undertaken by managers with participation by reviewers.

360 Degree Self Appraisal Part of the SSHR Appraisal function and also known as a Group Appraisal. This is a 360 Degree appraisal initiated by an employee. The employee (initiator) can add managers and reviewers to the appraisal.

A

Absence Types Categories of absence, such as medical leave or vacation leave, that you define for use in absence windows.

Accrual Band A range of values that determines how much paid time off an employee accrues. The values may be years of service, grades, hours worked, or any other factor.

Accrual Plan See: PTO Accrual Plan

Accrual Period The unit of time, within an accrual term, in which PTO is accrued. In many plans, the same amount of time is accrued in each accrual period, such as two days per month. In other plans, the amount accrued varies from period to period, or the entitlement for the full accrual term is given as an up front amount at the beginning of the accrual term.

Accrual Term The period, such as one year, for which accruals are calculated. In most accrual plans, unused PTO accruals must be carried over or lost at the end of the accrual term. Other plans have a rolling accrual term which is of a certain duration but has no fixed start and end dates.

Activity Rate The monetary amount or percentage associated with an activity, such as $12.35 per pay period as an employee payroll contribution for medical coverage. Activity rates can apply to participation, eligibility, coverages, contributions, and distributions.
Actual Premium  The per–participant premium an insurance carrier charges the plan sponsor for a given benefit.

Administrative Enrollment  A type of scheduled enrollment caused by a change in plan terms or conditions and resulting in a re–enrollment.

Applicant  A candidate for employment in a Business Group.

Appraisee  A person being appraised by an appraiser.

Appraiser  A person, usually a manager, who appraises an employee.

Appraisal  An appraisal is a process where an employee’s work performance is rated and future objectives set. See also: Assessment.

Appraising Manager  The person who initiates and performs an Employee–Manager or 360 Degree Appraisal. An appraising manager can create appraisal objectives.

Apply for a Job  An SSHR function that enables an employee to, apply, search and prepare applications for an internally advertised vacancy.

Arrestment  Scottish court order made out for unpaid debts or maintenance payments. See also: Court Order

Assessment  An information gathering exercise, from one or many sources, to evaluate a person’s ability to do a job. See also: Appraisal.

Assignment  An employee’s assignment identifies his or her role and payroll within a Business Group. The assignment is made up of a number of assignment components. Of these, organization is mandatory, and payroll is a required component for payment purposes.

Assignment Number  A number that uniquely identifies an employee’s assignment. An employee with multiple assignments has multiple assignment numbers.

Assignment Set  A grouping of employees and/or applicants that you define for running QuickPaint reports and processing payrolls. See also: QuickPaint Report

Assignment Status  For employees, used to track their permanent or temporary departures from your enterprise, and to control the remuneration they receive. For applicants, used to track the progress of their applications.

B

BACS  Banks Automated Clearing System. This is the UK system for making direct deposit payments to employees.

Balances  Positive or negative accumulations of values over periods of time normally generated by payroll runs. A balance can sum pay values, time periods or numbers. See also: Predefined Components

Balance Adjustment  A correction you make to a balance. You can adjust user balances and assignment level predefined balances only.

Balance Dimension  The period for which a balance sums its balance feeds, or the set of assignments/transactions for which it sums them. There are five time dimensions: Run, Period, Quarter, Year and User. You can choose any reset point for user balances.

Balance Feeds  These are the input values of matching units of measure of any elements defined to feed the balance.
**Bargaining Unit**  A bargaining unit is a legally organized group of people which have the right to negotiate on all aspects of terms and conditions with employers or employer federations. A bargaining unit is generally a trade union or a branch of a trade union.

**Base Currency**  The currency in which Oracle Payroll performs all payroll calculations for your Business Group. If you pay employees in different currencies to this, Oracle Payroll calculates the amounts based on exchange rates defined in the system.

**Behavioral Indicators**  Characteristics that identify how a competence is exhibited in the work context. See also: Proficiency Level

**Benefit**  Any part of an employee’s remuneration package that is not pay. Vacation time, employer–paid medical insurance and stock options are all examples of benefits. See also: Elements

**Block**  The largest subordinate unit of a window, containing information for a specific business function or entity. Every window consists of at least one block. Blocks contain fields and, optionally, regions. They are delineated by a bevelled edge. You must save your entries in one block before navigating to the next. See also: Region, Field

**Budget Value**  In Oracle Human Resources you can enter staffing budget values and actual values for each assignment to measure variances between actual and planned staffing levels in an organization or hierarchy.

**Business Group**  The highest level organization in the Oracle HRMS system. A Business Group may correspond to the whole of your enterprise or to a major grouping such as a subsidiary or operating division. Each Business Group must correspond to a separate implementation of Oracle HRMS.

**Business Number (BN)**  In Canada, this is the employer’s account number with Revenue Canada. Consisting of 15 digits, the first 9 identify the employer, the next 2 identify the type of tax account involved (payroll vs. corporate tax), and the last 4 identify the particular account for that tax.

**Cafeteria Benefits Plan**  See: Flexible Benefits Program

**Calendars**  In Oracle Human Resources you define calendars that determine the start and end dates for budgetary years, quarters and periods. For each calendar you select a basic period type. In Oracle SSP/SMP you define calendars to determine the start date and time for SSP qualifying patterns.

**Calendar Exceptions**  In Oracle SSP/SMP you define calendar exceptions for an SSP qualifying pattern, to override the pattern on given days. Each calendar exception is another pattern which overrides the usual pattern.
Canada/Quebec Pension Plan (CPP/QPP)

**Contributions** Contributions paid by employers and employees to each of these plans provide income benefits upon retirement.

**Candidate Offers** An SSHR function used by a line manager to offer a job to a candidate. This function is supplied with its own responsibility.

**Career Path** This shows a possible progression from one job or position from any number of other jobs or positions within the Business Group. A career path must be based on either job progression or position progression; you cannot mix the two.

**Carry Over** The amount of unused paid time off entitlement an employee brings forward from one accrual term to the next. It may be subject to an expiry date i.e. a date by which it must be used or lost. See also: Residual

**Cash Analysis** A specification of the different currency denominations required for paying your employees in cash. Union contracts may require you to follow certain cash analysis rules.

**Certification** Documentation required to enroll or change elections in a benefits plan as the result of a life event, to waive participation in a plan, to designate dependents for coverage, or to receive reimbursement for goods or services under an FSA.

**Ceiling** The maximum amount of unused paid time off an employee can have in an accrual plan. When an employee reaches this maximum, he or she must use some accrued time before any more time will accrue.

**Child/Family Support payments** In Canada, these are payments withheld from an employee’s compensation to satisfy a child or family support order from a Provincial Court. The employer is responsible for withholding and remitting the payments to the court named in the order.

**Collective Agreement** A collective agreement is a form of contract between an employer or employer representative, for example, an employer federation, and a bargaining unit for example, a union or a union branch.

**Communications** Benefits plan information that is presented in some form to participants. Examples include a pre-enrollment package, an enrollment confirmation statement, or a notice of default enrollment.

**Compensation** The pay you give to employees, including wages or salary, and bonuses. See also: Elements

**Competence** Any measurable behavior required by an organization, job or position that a person may demonstrate in the work context. A competence can be a piece of knowledge, a skill, an attitude or an attribute.

**Competence Evaluation** A method used to measure an employees ability to do a defined job.

**Competence Profile** Where you record applicant and employee accomplishments, for example, proficiency in a competence.

**Competence Requirements** Competencies required by an organization, job or position. See also: Competence, Core Competencies

**Competence Type** A group of related competencies.
**Consolidation Set**  A grouping of payroll runs within the same time period for which you can schedule reporting, costing, and post-run processing.

**Contact**  A person who has a relationship to an employee that you want to record. Contacts can be dependents, relatives, partners or persons to contact in an emergency.

**Contract**  A contract of employment is an agreement between an employer and employee or potential employee that defines the fundamental legal relationship between an employing organization and a person who offers his or her services for hire. The employment contract defines the terms and conditions to which both parties agree and those that are covered by local laws.

**Contribution**  An employer’s or employee’s monetary or other contribution to a benefits plan.

**Core Competencies**  Also known as *Leadership Competencies* or *Management Competencies*. The competencies required by every person to enable the enterprise to meet its goals. See also: *Competence*

**Costable Type**  A feature that determines the processing an element receives for accounting and costing purposes. There are four costable types in Oracle HRMS: costed, distributed costing, fixed costing, and not costed.

**Costing**  Recording the costs of an assignment for accounting or reporting purposes. Using Oracle Payroll, you can calculate and transfer costing information to your general ledger and into systems for project management or labor distribution.

**Court Order**  A ruling from a court that requires an employer to make deductions from an employee’s salary for maintenance payments or debts, and to pay the sums deducted to a court or local authority. See also: *Arrestment*

**Cross Business Group Responsibility Security**  This security model uses security groups and enables you to link one responsibility to many Business Groups.

**Customizable Forms**  Forms that your system administrator can modify for ease of use or security purposes by means of Custom Form restrictions. The Form Customization window lists the forms and their methods of customization.

**D**

**Database Item**  An item of information in Oracle HRMS that has special programming attached, enabling Oracle FastFormula to locate and retrieve it for use in formulas.

**Date To and Date From**  These fields are used in windows not subject to DateTrack. The period you enter in these fields remains fixed until you change the values in either field. See also: *DateTrack*, *Effective Date*

**DateTrack**  When you change your effective date (either to past or future), DateTrack enables you to enter information that takes effect on your new effective date, and to review information as of the new date. See also: *Effective Date*

**Deployment Factors**  See: *Work Choices*
**Derived Factor**  A factor (such as age, percent of fulltime employment, length of service, compensation level, or the number of hours worked per period) that is used in calculations to determine Participation Eligibility or Activity Rates for one or more benefits.

**Descriptive Flexfield**  A field that your organization can customize to capture additional information required by your business but not otherwise tracked by Oracle Applications. See also: Key Flexfield

**Developer Descriptive Flexfield**  A flexfield defined by your localization team to meet the specific legislative and reporting needs of your country. See also: Extra Information Types

**Direct Deposit**  The electronic transfer of an employee’s net pay directly into the account(s) designated by the employee.

**Distribution**  Monetary payments made from, or hours off from work as allowed by, a compensation or benefits plan.

**Element Entry**  The record controlling an employee’s receipt of an element, including the period of time for which the employee receives the element and its value. See also: Recurring Elements, Nonrecurring Elements

**Element Link**  The association of an element to one or more components of an employee assignment. The link establishes employee eligibility for that element. Employees whose assignment components match the components of the link are eligible for the element. See also: Standard Link

**Element Set**  A group of elements that you define to process in a payroll run, or to control access to compensation information from a customized form, or for distributing costs.

**Employee Histories**  An SSHR function for an employee to view their, Training History, Job Application History, Employment History, Absence History, or Salary History. A manager can also use this function to view information on their direct reports.


**Employment Insurance (EI)**  Benefit plan run by the federal government to which the majority of Canadian employers and employees must contribute.

**Employment Insurance Rate**  In Canada, this is the rate at which the employer contributes to the EI fund. The rate is expressed as a percentage of the employee’s contribution. If the employer maintains an approved wage loss replacement program, they can reduce their share of EI premiums by obtaining a reduced contribution rate. Employers would remit payroll deductions under a different employer account number for employees covered by the plan.
Employment Equity Occupational Groups (EEOG) In Canada, the Employment Equity Occupational Groups (EEOG) consist of 14 classifications of work used in the Employment Equity Report. The EEOGs were derived from the National Occupational Classification system.

Enroll in a Class An SSHR function which enables an employee to search and enroll in an internally published class. An employee can also use this function to maintain their competencies.

Enrollment Action Type Any action required to complete enrollment or de-enrollment in a benefit.

ESS Employee Self Service. A predefined SSHR responsibility.

Event An activity such as a training day, review, or meeting, for employees or applicants.

Expected Week of Confinement (EWC) In the UK, this is the week in which an employee’s baby is due. The Sunday of the expected week of confinement is used in the calculations for Statutory Maternity Pay (SMP).

Extra Information Type (EIT) A type of developer descriptive flexfield that enables you to create an unlimited number of information types for six key areas in Oracle HRMS. Localization teams may also predefine some EITs to meet the specific legislative requirements of your country. See also: Developer Descriptive Flexfield

Flex Credit A unit of "purchasing power" in a flexible benefits program. An employee uses flex credits, typically expressed in monetary terms, to "purchase" benefits plans and/or levels of coverage within these plans.

Flexible Benefits Program A benefits program that offers employees choices among benefits plans and/or levels of coverage. Typically, employees are given a certain amount of flex credits or moneys with which to "purchase" these benefits plans and/or coverage levels.

Flexible Spending Account (FSA) Under US Internal Revenue Code Section 125, employees can set aside money on a pretax basis to pay for eligible unreimbursed health and dependent care expenses. Annual monetary limits and use-it-or-lose it provisions exist. Accounts are subject to annual maximums and forfeiture rules.

Form A predefined grouping of functions, called from a menu and displayed, if necessary, on several windows. Forms have blocks, regions and fields as their components. See also: Block, Region, Field

G

Global Value A value you define for any formula to use. Global values can be dates, numbers or text.

Goods or Service Type A list of goods or services a benefit plan sponsor has approved for reimbursement.

Grade A component of an employee’s assignment that defines their level and can be used to control the value of their salary and other compensation elements.
Grade Comparison  A comparison of the amount of compensation an employee receives with the mid-point of the valid values defined for his or her grade.

Grade Rate  A value or range of values defined as valid for a given grade. Used for validating employee compensation entries.

Grade Scale  A sequence of steps valid for a grade, where each step corresponds to one point on a pay scale. You can place each employee on a point of their grade scale and automatically increment all placements each year, or as required. See also: Pay Scale

Grade Step  An increment on a grade scale. Each grade step corresponds to one point on a pay scale. See also: Grade Scale

Grandfathered  A term used in Benefits Administration. A person’s benefits are said to be grandfathered when a plan changes but they retain the benefits accrued.

Group  A component that you define, using the People Group key flexfield, to assign employees to special groups such as pension plans or unions. You can use groups to determine employees’ eligibility for certain elements, and to regulate access to payrolls.

H

Hierarchy  An organization or position structure showing reporting lines or other relationships. You can use hierarchies for reporting and for controlling access to Oracle HRMS information.

I

Imputed Income  Certain forms of indirect compensation that US Internal Revenue Service Section 79 defines as fringe benefits and taxes the recipient accordingly. Examples include employer payment of group term life insurance premiums over a certain monetary amount, personal use of a company car, and other non-cash awards.

Initiator  In SSHR a person who starts a 360 Degree appraisal (Employee or Self) on an individual. An initiator and the appraisee are the only people who can see all appraisal information.

Input Values  Values you define to hold information about elements. In Oracle Payroll, input values are processed by formulas to calculate the element’s run result. You can define up to fifteen input values for an element.

Instructions  An SSHR user assistance component displayed on a web page to describe page functionality.

K

Key Flexfield  A flexible data field made up of segments. Each segment has a name you define and a set of valid values you specify. Used as the key to uniquely identify an entity, such as jobs, positions, grades, cost codes, and employee groups. See also: Descriptive Flexfield
**Leaver’s Statement** In the UK, this records details of Statutory Sick Pay (SSP) paid during a previous employment (issued as form SSP1L) which is used to calculate a new employee’s entitlement to SSP. If a new employee falls sick, and the last date that SSP was paid for under the previous employment is less than eight calendar weeks before the first day of the PIW for the current sickness, the maximum liability for SSP is reduced by the number of weeks of SSP shown on the statement.

**Life Event** A significant change in a person’s life that results in a change in eligibility or ineligibility for a benefit.

**Life Event Collision** A situation in which the impacts from multiple life events on participation eligibility, enrollability, level of coverage or activity rates conflict with each other.

**Life Event Enrollment** A benefits plan enrollment that is prompted by a life event occurring at any time during the plan year.

**Linking Interval** In the UK, this is the number of days that separate two periods of incapacity for work. If a period of incapacity for work (PIW) is separated from a previous PIW by less than the linking interval, they are treated as one PIW according to the legislation for entitlement to Statutory Sick Pay (SSP). An employee can only receive SSP for the maximum number of weeks defined in the legislation for one PIW.

**Linked PIWs** In the UK, these are linked periods of incapacity for work that are treated as one to calculate an employee’s entitlement to Statutory Sick Pay (SSP). A period of incapacity for work (PIW) links to an earlier PIW if it is separated by less than the linking interval. A linked PIW can be up to three years long.

**LMSS** Line Manager Self Service. A predefined SSHR responsibility.

**Lookup Types** Categories of information, such as nationality, address type and tax type, that have a limited list of valid values. You can define your own Lookup Types, and you can add values to some predefined Lookup Types.

**Lower Earnings Limit (LEL)** In the UK, this is the minimum average weekly amount an employee must earn to pay National Insurance contributions. Employees who do not earn enough to pay National Insurance cannot receive Statutory Sick Pay (SSP) or Statutory Maternity Pay (SMP).

**Manager–Employee Appraisal** Part of the SSHR Appraisal function. A manager appraisal of an employee. However, an appraising manager does not have to be a manager.
Maternity Pay Period  In the UK, this is the period for which Statutory Maternity Pay (SMP) is paid. It may start at any time from the start of the 11th week before the expected week of confinement and can continue for up to 18 weeks. The start date is usually agreed with the employee, but can start at any time up to the birth. An employee is not eligible to SMP for any week in which she works or for any other reason for ineligibility, defined by the legislation for SMP.

Menus You set up your own navigation menus, to suit the needs of different users.

National Occupational Classification (NOC) code In Canada, the National Occupational Classification (NOC) System was developed to best reflect the type of work performed by employees. Occupations are grouped in terms of particular tasks, duties and responsibilities. The use of this standardized system ensures consistency of data from year to year within the same company as well as between companies. These codes are used in the Employment Equity Report.

Not in Program Plan A benefit plan that you define outside of a program.

O

Open Enrollment A type of scheduled enrollment in which participants can enroll in or alter elections in one or more benefits plans.

Oracle FastFormula An Oracle tool that allows you to write Oracle HRMS formulas without using a programming language.

Organization A required component of employee assignments. You can define as many organizations as you want within your Business Group. Organizations can be internal, such as departments, or external, such as recruitment agencies. You can structure your organizations into organizational hierarchies for reporting purposes and for system access control.

OSSWA Oracle Self Service Web Applications.

OTM Oracle Training Management.

P

Pattern A pattern comprises a sequence of time units that are repeated at a specified frequency. Oracle SSP/SMP uses SSP qualifying patterns to determine employees entitlement to Statutory Sick Pay (SSP).
**Pattern Time Units**  A sequence of time units specifies a repeating pattern. Each time unit specifies a time period of hours, days or weeks.

**Pay Scale**  A set of progression points that can be related to one or more rates of pay. Employee’s are placed on a particular point on the scale according to their grade and, usually, work experience. See also: *Grade Scale*

**Payment Type**  There are three standard payment types for paying employees: check, cash and direct deposit. You can define your own payment methods corresponding to these types.

**Payroll**  A group of employees that Oracle Payroll processes together with the same processing frequency, for example, weekly, monthly or bimonthly. Within a Business Group, you can set up as many payrolls as you need.

**People List**  An SSHR line manager utility used to locate an employee.

**Performance (within Assessment)**  An expectation of “normal” performance of a competence over a given period. For example, a person may exceed performance expectation in the communication competence. See also: *Proficiency (within Assessment), Competence, Assessment*

**Period of Incapacity for Work (PIW)**  In the UK, this is a period of sickness that lasts four or more days in a row, and is the minimum amount of sickness for which Statutory Sick Pay can be paid. If a PIW is separated by less then the linking interval, a linked PIW is formed and the two PIWs are treated as one.

**Period Type**  A time division in a budgetary calendar, such as week, month, or quarter.

**Person Search**  An SSHR function which enables a manager to search for a person. There are two types of search, Simple and Advanced.

**Person Type**  There are eight system person types in Oracle HRMS. Seven of these are combinations of employees, ex–employees, applicants, and ex–applicants. The eighth category is ‘External’. You can create your own user person types based on the eight system types.

**Personal Tax Credits Return (TD1)**  A Revenue Canada form which each employee must complete. Used by the employee to reduce his or her taxable income at source by claiming eligible credits and also provides payroll with such important information as current address, birth date, and SIN. These credits determine the amount to withhold from the employee’s wages for federal/provincial taxes.

**Plan Design**  The functional area that allows you to set up your benefits programs and plans. This process involves defining the rules which govern eligibility, available options, pricing, plan years, third party administrators, tax impacts, plan assets, distribution options, required reporting, and communications.

**Plan Sponsor**  The legal entity or business responsible for funding and administering a benefits plan. Generally synonymous with employer.

**Position**  A specific role within the Business Group derived from an organization and a job. For example, you may have a position of Shipping Clerk associated with the organization Shipping and the job Clerk.
Predefined Components Some elements and balances, all primary element classifications and some secondary classifications are defined by Oracle Payroll to meet legislative requirements, and are supplied to users with the product. You cannot delete these predefined components.

Professional Information An SSHR function which allows an employee to maintain their own professional details or a line manager to maintain their direct reports professional details.

Proficiency (within Assessment) The perceived level of expertise of a person in a competence, in the opinion of the assessor, over a given period. For example, a person may demonstrate the communication competence at Expert level. See also: Performance (within Assessment), Competence, Assessment

Proficiency Level A system for expressing and measuring how a competence is exhibited in the work context. See also: Behavioral Indicators.

Progression Point A pay scale is calibrated in progression points, which form a sequence for the progression of employees up the pay scale. See also: Pay Scale

Provincial/Territorial Employment Standards Acts In Canada, these are laws covering minimum wages, hours of work, overtime, child labour, maternity, vacation, public/general holidays, parental and adoption leave, etc., for employees regulated by provincial/territorial legislation.

Provincial Health Number In Canada, this is the account number of the provincially administered health care plan that the employer would use to make remittances. There would be a unique number for each of the provincially controlled plans i.e. EHT, Quebec HSF, etc.

PTO Accrual Plan A benefit in which employees enroll to entitle them to accrue and take paid time off. The purpose of absences allowed under the plan, who can enroll, how much time accrues, when the time must be used, and other rules are defined for the plan.

Q

QPP (See Canada/Quebec Pension Plan)

Qualification Type An identified qualification method of achieving proficiency in a competence, such as an award, educational qualification, a license or a test. See also: Competence

Qualifying Days In the UK, these are days on which Statutory Sick Pay (SSP) can be paid, and the only days that count as waiting days. Qualifying days are normally work days, but other days may be agreed.

Qualifying Pattern See: SSP Qualifying Pattern

Qualifying Week In the UK, this is the week during pregnancy that is used as the basis for the qualifying rules for Statutory Maternity Pay (SMP). The date of the qualifying week is fifteen weeks before the expected week of confinement and an employee must have been continuously employed for at least 26 weeks continuing into the qualifying week to be entitled to SMP.

Quebec Business Number In Canada, this is the employer’s account number with the Ministere du Revenu du Quebec, also known as the Quebec Identification number. It consists of 15 digits, the first 9 identify the employer, the next 2 identify the type of tax account involved (payroll vs. corporate tax), and the last 4 identify the particular account for that tax.
Questionnaire  An SSHR function which records the results of an appraisal.

QuickPaint Report  A method of reporting on employee and applicant assignment information. You can select items of information, paint them on a report layout, add explanatory text, and save the report definition to run whenever you want. See also: Assignment Set

R

Rates  A set of values for employee grades or progression points. For example, you can define salary rates and overtime rates.

Rating Scale  Used to describe an enterprise’s competencies in a general way. You do not hold the proficiency level at the competence level. See also: Proficiency Level

Record of Employment (ROE)  A Human Resources Development Canada form that must be completed by an employer whenever an interruption of earnings occurs for any employee. This form is necessary to claim Employment Insurance benefits.

Recruitment Activity  An event or program to attract applications for employment. Newspaper advertisements, career fairs and recruitment evenings are all examples of recruitment activities. You can group several recruitment activities together within an overall activity.

Recurring Elements  Elements that process regularly at a predefined frequency. Recurring element entries exist from the time you create them until you delete them, or the employee ceases to be eligible for the element. Recurring elements can have standard links. See also: Nonrecurring Elements, Standard Link

Region  A collection of logically related fields in a window, set apart from other fields by a rectangular box or a horizontal line across the window. See also: Block, Field

Registered Pension Plan (RPP)  This is a pension plan that has been registered with Revenue Canada. It is a plan where funds are set aside by an employer, an employee, or both to provide a pension to employees when they retire. Employee contributions are generally exempt from tax.

Registered Retirement Savings Plan (RRSP)  This is an individual retirement savings plan that has been registered with Revenue Canada. Usually, contributions to the RRSP, and any income earned within the RRSP, is exempt from tax.

Report Parameters  Inputs you make when submitting a report to control the sorting, formatting, selection, and summarizing of information in the report.

Report Set  A group of reports and concurrent processes that you specify to run together.

Requisition  The statement of a requirement for a vacancy or group of vacancies.

Request Groups  A list of reports and processes that can be submitted by holders of a particular responsibility. See also: Responsibility

Residual  The amount of unused paid time off entitlement an employee loses at the end of an accrual term. Typically employees can carry over unused time, up to a maximum, but they lose any residual time that exceeds this limit. See also: Carry Over
Responsibility  A level of authority in an application. Each responsibility lets you access a specific set of Oracle Applications forms, menus, reports, and data to fulfill your business role. Several users can share a responsibility, and a single user can have multiple responsibilities. See also: Security Profile, User Profile Options, Request Groups, Security Groups

Retry  Method of correcting a payroll run or other process before any post–run processing takes place. The original run results are deleted and the process is run again.

Revenue Canada  Department of the Government of Canada which, amongst other responsibilities, administers, adjudicates, and receives remittances for all taxation in Canada including income tax, Employment Insurance premiums, Canada Pension Plan contributions, and the Goods and Services Tax (legislation is currently proposed to revise the name to the Canada Customs and Revenue Agency). In the province of Quebec the equivalent is the Ministere du Revenu du Quebec.

Reviewer (SSHR)  A person invited by an appraising manager to add review comments to an appraisal.

Reversal  Method of correcting payroll runs or QuickPay runs after post–run processing has taken place. The system replaces positive run result values with negative ones, and negative run result values with positive ones. Both old and new values remain on the database.

Rollback  Method of removing a payroll run or other process before any post–run processing takes place. All assignments and run results are deleted.

S

Search by Date  An SSHR sub–function used to search for a Person by Hire date, Application date, Job posting date or search by a Training event date.

Salary Basis  The period of time for which an employee’s salary is quoted, such as hourly or annually. Defines a group of employees assigned to the same salary basis and receiving the same salary element.

Scheduled Enrollment  A benefits plan enrollment that takes place during a predefined enrollment period, such as an open enrollment. Scheduled enrollments can be administrative, open, or unrestricted.

Security Group  Security groups enable HRMS users to partition data by Business Group. Only used for Cross Business Group Responsibility security. See also: Responsibility, Security Profile, User Profile Options

Security Profile  Security profiles control access to organizations, positions and employee and applicant records within the Business Group. System administrators use them in defining users’ responsibilities. See also: Responsibility

Self Appraisal  Part of the SSHR Appraisal function. This is an appraisal undertaken by an employee to rate their own performance and competencies.

SMP  See: Statutory Maternity Pay

Social Insurance Number (SIN)  A unique number provided by Human Resources Development Canada (HRDC) to each person commencing employment in Canada. The number consists of 9 digits in the following format (###–###–###).
**Source Deductions Return (TP 1015.3)** A Ministere du Revenu du Quebec form which each employee must complete. This form is used by the employee to reduce his or her taxable income at source by claiming eligible credits and also provides payroll with such important information as current address, birth date, and SIN. These credits determine the amount of provincial tax to withhold from the employee’s wages.

**Special Information Types** Categories of personal information, such as skills, that you define in the Personal Analysis key flexfield.

**SSHR** Oracle Self–Service Human Resources. An HR management system using an intranet and web browser to deliver functionality to employees and their managers.

**SSP** See: *Statutory Sick Pay*

**SSP Qualifying Pattern** In the UK, an SSP qualifying pattern is a series of qualifying days that may be repeated weekly, monthly or some other frequency. Each week in a pattern must include at least one qualifying day. Qualifying days are the only days for which Statutory Sick Pay (SSP) can be paid, and you define SSP qualifying patterns for all the employees in your organization so that their entitlement to SSP can be calculated.

**Standard Link** Recurring elements with standard links have their element entries automatically created for all employees whose assignment components match the link. See also: *Element Link, Recurring Elements*

**Statement of Commissions and Expenses for Source Deduction Purposes (TP 1015.R.13.1)** A Ministere du Revenu du Quebec form which allows an employee who is paid partly or entirely by commissions to pay a constant percentage of income tax based on his or her estimated commissions for the year, less allowable business expenses.

**Statement of Remuneration and Expenses (TD1X)** In Canada, the Statement of Remuneration and Expenses allows an employee who is paid partly or entirely by commission to pay a constant percentage of income tax, based on his or her estimated income for the year, less business-related expenses.

**Statutory Maternity Pay** In the UK, you pay Statutory Maternity Pay (SMP) to female employees who take time off work to have a baby, providing they meet the statutory requirements set out in the legislation for SMP.

**Statutory Sick Pay** In the UK, you pay Statutory Sick Pay (SSP) to employees who are off work for four or more days because they are sick, providing they meet the statutory requirements set out in the legislation for SSP.

**Succession Planning** An SSHR function which enables a manager to prepare a succession plan.
Suitability Matching  An SSHR function which enables a manager to compare and rank a person's competencies.

Tabbed Regions  Parts of a window that appear in a stack so that only one is visible at any time. You click on the tab of the required region to bring it to the top of the stack.

Task Flows  A sequence of windows linked by buttons to take you through the steps required to complete a task, such as hiring a new recruit. System administrators can create task flows to meet the needs of groups of users.

Terminating Employees  You terminate an employee when he or she leaves your organization. Information about the employee remains on the system but all current assignments are ended.

Termination Rule  Specifies when entries of an element should close down for an employee who leaves your enterprise. You can define that entries end on the employee's actual termination date or remain open until a final processing date.

Tips  An SSHR user assistance component that provides information about a field.

User Assistance Components  SSHR online help comprising tips and instructions.

User Balances  Users can create, update and delete their own balances, including dimensions and balance feeds. See also: Balances

User Profile Options  Features that allow system administrators and users to tailor Oracle HRMS to their exact requirements. See also: Responsibility, Security Profile

Viewer (SSHR)  A person with view only access to an appraisal. An appraising manager or an employee in a 360 Degree Self appraisal can appoint view only access to an appraisal.

WCB Account Number  In Canada, this is the account number of the provincially administered Worker’s Compensation Board that the employer would use to make remittances. There would be a unique number for each of the provincially controlled boards i.e. Workplace Safety & Insurance Board of Ontario, CSST, etc.

Waiting Days  In the UK, statutory Sick Pay is not payable for the first three qualifying days in period of incapacity for work (PIW), which are called waiting days. They are not necessarily the same as the first three days of sickness, as waiting days can be carried forward from a previous PIW if the linking interval between the two PIWs is less than 56 days.

Work Choices  Also known as Work Preferences, Deployment Factors, or Work Factors. These can affect a person’s capacity to be deployed within an enterprise, such willingness to travel or relocate. You can hold work choices at both job and position level, or at person level.
**Worker’s Compensation Board** In Canada, this is a provincially governed legislative body which provides benefits to employees upon injury, disability, or death while performing the duties of the employer. Worker’s Compensation Board premiums are paid entirely by the employer.

**Workflow** An Oracle application which uses charts to manage approval processes and in addition is used in SSHR to configure display values of sections within a web page and instructions.

**Work Structures** The fundamental definitions of organizations, jobs, positions, grades, payrolls and other employee groups within your enterprise that provide the framework for defining the work assignments of your employees.
Index

A
Address styles, 1 – 25
Application Data Export, downloading information to spreadsheets, 4 – 5
Assignment sets, overview, 4 – 21
Attachments, 4 – 7
Audit groups, 3 – 8
AuditTrail, 3 – 2
  overview, 3 – 3
  setting up audit groups, 3 – 8
  Update Datetracked Tables process, 3 – 8

B
Bank account information, 1 – 30
Base currency, 1 – 93
Business Groups
  enabling one responsibility for many Business Groups, 2 – 20
  ways of linking to responsibilities, 2 – 19

C
Comments, 4 – 7
Concurrent managers, 4 – 15
Country-specific requirements
  address styles, 1 – 25
  predefined developer flexfields, 1 – 29
  Cross Business Group Responsibility Security, 2 – 8
    setting up, 2 – 36
  Currencies, enabling, 1 – 93
  CUSTOM library events, 1 – 52
    generic events, 1 – 52
    product specific events, 1 – 52
  Customizing
    menu structures, 2 – 21 to 2 – 23
    QuickPaint Report window, 4 – 6
  Customizing windows
    HR_CUSTOMIZATION parameter, 1 – 81
    list of customizable windows, 1 – 13
    overview, 1 – 13 to 1 – 15
    types of data restrictions, 1 – 14

D
Database items, in QuickPaint reports, 4 – 12
Descriptive flexfields, 1 – 16
  creating database items, 1 – 85
  defining segments of, 1 – 20 to 1 – 22
  enabling users to add fields to windows, 1 – 20
  for address styles, 1 – 25
  list of user definable, 1 – 22 to 1 – 25
  Developer descriptive flexfields, 1 – 29 to 1 – 31
  Developer key flexfields, 1 – 29 to 1 – 31
  Distribution sets, 1 – 60
Element sets, 1 – 60

Events
  generic, 1 – 52
  product specific, 1 – 52

Extra Information types, 1 – 16
  entering, 1 – 92
  example script, 1 – 54
  optional components of a responsibility, 2 – 20
  setting up, 1 – 87
  setting up for an organization classification, 1 – 89
  setting up responsibilities, 1 – 91

Folders, description of, 4 – 4 to 4 – 6

Form functions, defining parameters for different form types, 1 – 81

Group Term Life premiums, predefined table for, 1 – 33

Inquiry windows, list of, 4 – 10

Key flexfield setup, 1 – 17 to 1 – 19
  creating database items, 1 – 86
  uses of key flexfields, 1 – 17

Key flexfields, 1 – 16
  Bank Details, 1 – 30
  Cost Allocation, 1 – 19
  Grade Name, 1 – 18
  Job Name, 1 – 18
  People Group, 1 – 18
  Personal Analysis, 1 – 18
  Position Name, 1 – 18

Soft Coded Legislation, 1 – 30

Letter generation
  ADE and concurrent processing compared, 5 – 3
  standard letter overview, 5 – 2 to 5 – 6
  using Oracle Reports, 5 – 4
  using word processors, 5 – 4

LISTGEN, 2 – 28

Lookups
  access levels, 1 – 35
  defining new lookup types, 1 – 94 to 1 – 96
  defining new lookup values, 1 – 95 to 1 – 97
  global and local types, 1 – 35
  list of user and extensible types, 1 – 37 to 1 – 51
  overview, 1 – 35 to 1 – 37
  removing lookup values, 1 – 96

Mail merge, 5 – 2 to 5 – 6, 5 – 15

Menu Structures report, 2 – 44

Menus
  default menu paths, A – 2
  defining, 2 – 21 to 2 – 22, 2 – 43
  defining functions, 2 – 45
  for security, 2 – 20, 2 – 21
  query–only access, 2 – 11

National address styles, changing default styles, 1 – 82

Oracle HRMS, using with spreadsheets, 4 – 5 to 4 – 6

ORACLE IDs, 2 – 42
Organization hierarchies, in security profiles, 2 – 30
OTA, SQL*Plus script, C – 7 to C – 10

P
Payroll tables, row types for, 1 – 32
Payrolls, in security profiles, 2 – 17
PERWPOUK, SQL*Plus script, C – 2 to C – 5
PERWPWUK, SQL*Plus script, C – 5 to C – 8
Position hierarchies, in security profiles, 2 – 31
Predefined user tables, 1 – 33
Company Work Schedules, 1 – 33
GTL Premiums, 1 – 33
Shift Differentials, 1 – 33
Wage Rates, 1 – 34
Process security, 2 – 23
Processes
Create Descriptive Flexfield DB Items, 1 – 85
Create Key Flexfield DB Items, 1 – 86

Q
Query–only access to windows, 2 – 11
QuickPaint reports, 4 – 6
customizing, 4 – 6
defining, 4 – 12 to 4 – 13
running, 4 – 14

R
Report security, 2 – 23
Reporting users, 2 – 27
setting up, 2 – 42
Reports
defining, 4 – 4, 4 – 18
list of, 4 – 15 to 4 – 17
Menu Structure, 2 – 44
QuickPaint, 4 – 12 to 4 – 13
Request groups, 2 – 20, 2 – 23
Responsibilities, 2 – 19, 2 – 21
defining, 2 – 33, 2 – 36
Restricting access to records
by menu structures, 2 – 21
by organization hierarchy, 2 – 30
by payroll, 2 – 17
by position hierarchy, 2 – 31
by responsibilities, 2 – 19 to 2 – 20
by security profiles, 2 – 17
from other tools, 2 – 27
ROLEGEN, 2 – 29
Roles, 2 – 19

S
SECGEN, 2 – 28
Security
creating Oracle IDs, 2 – 42
enabling currencies, 1 – 93
extra information types, 2 – 20
of reports and processes, 2 – 20, 2 – 23
running HR security processes, 2 – 28
setting user profile options, 2 – 10
Security groups, 2 – 24
Security models, 2 – 8
cross business group responsibility security, 2 – 8
standard HRMS security, 2 – 8
Security processes
Enable Multiple Security Groups, 2 – 29
Generate Secure User (SECGEN), 2 – 28
Grant Permissions To Roles (ROLEGEN), 2 – 29
Security List Maintenance (LISTGEN), 2 – 28
Security profiles, 2 – 17 to 2 – 18, 2 – 20
defining, 2 – 35
Shift differentials, predefined table for, 1 – 33
Soft coded legislation, 1 – 30
Spreadsheets, using with ADE, 4 – 5 to 4 – 6
SQL*Plus script
OTA – for confirmation letters, C – 7 to C – 10
PERWPOUK, C – 2 to C – 5
PERWPWUK, C – 5 to C – 8
Standard HRMS security, 2 – 8
setting up, 2 – 33
Standard letters, 5–2

T
Tables, user–defined, 1–31
   accessing values in, 1–31
   entering values into, 1–99
   payroll tables for deduction amounts, 1–32
   setting up, 1–97 to 1–98
Task flows, 1–5 to 1–6
   adding a new form/node, 1–69
   adding to a menu, 1–81
   amending the navigation, 1–70
   copying an existing task flow, 1–68
   creating using forms, 1–64
   creating using Oracle Workflow, 1–71
   defining nodes, 1–65
   defining task flows, 1–66
   Oracle Workflow, 1–11
   WORKFLOW_NAME parameter, 1–81
Template
   PERWPOUK, C–2 to C–5
   PERWPWUK, C–5 to C–8

U
User profile options, 2–36
   overview, 2–10 to 2–12
   profile options listing, 2–11 to 2–16
User tables, 1–31 to 1–32
Users, creating, 2–34, 2–37

V
Views, list of, 4–10

W
Wage rates, predefined table for, 1–34
Windows
   Application Utilities Lookups, 1–94, 1–96
   Assignment Criteria, 4–22
   Assignment Set, 4–22, 4–25
   Columns, 1–97
   default navigation paths, A–15
   Define Task Flow, 1–66
   Define Task Flow Nodes, 1–65
   Element and Distribution Set, 1–60
   Extra Information, 1–92
   Find Security Profile Assignment, 2–38
   Form Customization, 1–61
   Grade Rate, 1–81
   Information Type Security, 1–91
   Letter, 5–11
   Menu, 2–44
   Personal Profile Values, 2–11
   QuickPaint Inquiry, 4–14
   QuickPaint Report, 4–12
   Request Letter, 5–13
   Rows, 1–97
   Scale Rate, 1–81
   Security Profile, 2–35
   Submit Requests, 4–15
   System Profile Values, 2–10
   Table Structure, 1–97
   Table Values, 1–99
   View Requests, 4–15
Word processors, supported makes for letter generation, 5–4 to 5–5
Work schedules, predefined table for, 1–33