Oracle® Financial Data Manager

Balance & Control Reference Guide

Release 4.5

July 2000
Part No. A82947-01
Contents

Send Us Your Comments .................................................................................................................................................. xiii

Preface ........................................................................................................................................................................ xv

1 Introduction
   Oracle Financial Services Overview ............................................................................................................................. 1-2
   OFS Applications ...................................................................................................................................................... 1-2
   Logging into OFS ..................................................................................................................................................... 1-4
   Menus and Toolbars ................................................................................................................................................ 1-4
      Menus ...................................................................................................................................................................... 1-4
         File Menu ......................................................................................................................................................... 1-4
         Edit Menu ......................................................................................................................................................... 1-6
         Process Menu .................................................................................................................................................. 1-7
         Setup Menu .................................................................................................................................................... 1-7
         Options Menu ................................................................................................................................................. 1-7
         Tools Menu .................................................................................................................................................... 1-8
      Window and Help Menus ...................................................................................................................................... 1-9
         Status Bar ....................................................................................................................................................... 1-9
      Toolbars ............................................................................................................................................................. 1-9
         Horizontal Toolbar ........................................................................................................................................... 1-9
         Vertical Toolbar ............................................................................................................................................. 1-11

2 Overview of the Process
   Reconciliation Reports ................................................................................................................................................. 2-1
Scrubbing the Data ............................................................................................................................ 2-2
  Uncorrected Data .......................................................................................................................... 2-2
Assigning Account Classifications ............................................................................................... 2-3
Balancing the Data .......................................................................................................................... 2-3
  Correcting the Extract Process .................................................................................................... 2-3
  Creating Plug Balances .............................................................................................................. 2-3
  Using a Gross-Up Approach ....................................................................................................... 2-4
Aggregating the Data ..................................................................................................................... 2-4
Stratification Reports .................................................................................................................... 2-4
  Stratification Report Flexibility ............................................................................................... 2-5
    Defining Stratification Ranges ............................................................................................... 2-5
    Defining the Report Columns ................................................................................................. 2-5
    Defining a Subset of the Portfolio ......................................................................................... 2-6
Using Data Filters .......................................................................................................................... 2-6
Using Relationship Filters ............................................................................................................ 2-6
Multi-User Problems and Solutions ............................................................................................ 2-7
Multi-Processing ............................................................................................................................ 2-7
Client/Server Processing ................................................................................................................ 2-8

3  Overview of IDs

Creating an ID ................................................................................................................................. 3-2
Opening an Existing ID .................................................................................................................... 3-4
Closing an ID .................................................................................................................................... 3-4
Saving an ID ..................................................................................................................................... 3-4
  Save As ........................................................................................................................................ 3-5
  Rename ..................................................................................................................................... 3-5
Deleting an ID ................................................................................................................................. 3-5
  Delete a Group of IDs ................................................................................................................. 3-6
Leaf Setup ....................................................................................................................................... 3-7
  Creating a Leaf Setup Dialog Box ............................................................................................. 3-8
Aggregation Methods for Financial Elements .............................................................................. 3-11
  Average Method ....................................................................................................................... 3-12
  Accrual Method ......................................................................................................................... 3-12
  Sum ......................................................................................................................................... 3-13
  First ......................................................................................................................................... 3-13
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last</td>
<td>3-13</td>
</tr>
<tr>
<td>Selecting an Aggregation Method</td>
<td>3-13</td>
</tr>
<tr>
<td>Tree-Related IDs</td>
<td>3-14</td>
</tr>
<tr>
<td>Hints on Editing Tree-related IDs</td>
<td>3-14</td>
</tr>
<tr>
<td>Importing and Exporting Data</td>
<td>3-15</td>
</tr>
<tr>
<td>Importing and Exporting IDs</td>
<td>3-15</td>
</tr>
<tr>
<td>Individual ID Import/Export</td>
<td>3-15</td>
</tr>
<tr>
<td>Dependent ID Import/Export</td>
<td>3-17</td>
</tr>
<tr>
<td>Group Import/Export</td>
<td>3-18</td>
</tr>
<tr>
<td>Export an ID with Group Import/Export</td>
<td>3-19</td>
</tr>
<tr>
<td>Export an ID from the File Menu</td>
<td>3-20</td>
</tr>
<tr>
<td>Rules, Limitations, and Hints</td>
<td>3-24</td>
</tr>
<tr>
<td>OFSA ID Dependencies</td>
<td>3-25</td>
</tr>
<tr>
<td>Processing an ID</td>
<td>3-25</td>
</tr>
<tr>
<td>Server Status</td>
<td>3-26</td>
</tr>
<tr>
<td>Using the Server Status Update Dialog Box</td>
<td>3-26</td>
</tr>
<tr>
<td>View your jobs or all</td>
<td>3-26</td>
</tr>
<tr>
<td>Stop Job</td>
<td>3-27</td>
</tr>
<tr>
<td>Insert Test Request</td>
<td>3-27</td>
</tr>
<tr>
<td>Remove YOUR Finished Jobs</td>
<td>3-27</td>
</tr>
<tr>
<td>Server Polling Indicator</td>
<td>3-27</td>
</tr>
<tr>
<td>The Status Display</td>
<td>3-28</td>
</tr>
<tr>
<td>Changing a Password</td>
<td>3-30</td>
</tr>
<tr>
<td>Spreadsheet Control Bar</td>
<td>3-30</td>
</tr>
<tr>
<td>Increment Methods</td>
<td>3-30</td>
</tr>
<tr>
<td>Interpolation in Auto Increment</td>
<td>3-32</td>
</tr>
<tr>
<td>Increment a Range of Values</td>
<td>3-32</td>
</tr>
<tr>
<td>4 Data Verification ID</td>
<td>4-1</td>
</tr>
<tr>
<td>Creating and Defining a Data Verification ID</td>
<td>4-1</td>
</tr>
<tr>
<td>Running a Data Verification ID</td>
<td>4-4</td>
</tr>
<tr>
<td>Edit Spreadsheet On/Off</td>
<td>4-4</td>
</tr>
<tr>
<td>What the Results Show</td>
<td>4-4</td>
</tr>
<tr>
<td>Editing a Data Verification ID</td>
<td>4-5</td>
</tr>
<tr>
<td>Reviewing a Data Verification ID Example</td>
<td>4-5</td>
</tr>
</tbody>
</table>
5 Correction Rule ID

The Logical Hierarchy ................................................................................................................. 5-1
  The Otherwise Branch .............................................................................................................. 5-2
  Levels of Indentation (Branches) ............................................................................................ 5-2
  Removing Levels .................................................................................................................... 5-3
  Directional Arrows .................................................................................................................. 5-3

Data Filtering and Column Assignments ................................................................................. 5-3
  Data Filter ................................................................................................................................ 5-4
  Column Assignment ................................................................................................................ 5-5
    Assignment Type .................................................................................................................. 5-6
    Error Assignments ................................................................................................................ 5-7

Running the Correction Rule ID .............................................................................................. 5-8

Defining a Correction Rule: An Example .................................................................................... 5-8
  Creating a New Correction Rule ID .......................................................................................... 5-9
  Defining the First Level .......................................................................................................... 5-9
  Defining the Second Level ...................................................................................................... 5-10
  Defining the Data Filters ......................................................................................................... 5-10
  Defining the Column Assignments .......................................................................................... 5-11
  The Correction Rule Completed .............................................................................................. 5-12

6 Data Correction Processing ID

Components of the Correction Processing ID ........................................................................... 6-1
  Ordering the Selected Rules ...................................................................................................... 6-3
  Updating Records Individually or In Bulk ................................................................................ 6-4

Processing Considerations ........................................................................................................... 6-4
  Dependency Checking ............................................................................................................. 6-5

Defining a Correction Processing ID: An Example .................................................................... 6-5
  Creating a New Data Correction Processing ID ...................................................................... 6-6
  Setting Up and Running the Data Correction Processing ID .................................................... 6-6

Editing a Data Correction Processing ID ................................................................................... 6-6

7 Data Filter ID

Creating and Defining a Data Filter ID ....................................................................................... 7-1
  Defining Filter Types and Criteria ............................................................................................ 7-4
Filter Type ................................................................. 7-4
Filter Criteria .......................................................... 7-5
Filter Criteria Rules .................................................. 7-6
Implied Filter Criteria ............................................... 7-7
Null Values in the Database ...................................... 7-7
Running a Data Filter ID ............................................ 7-8
Editing a Data Filter ID ............................................. 7-8
Using Data Filters on Multiple Tables ....................... 7-9
Reviewing a Data Filter ID Example ......................... 7-10

8 Group Filter ID
Creating and Defining a Group Filter ID ..................... 8-1
Editing a Group Filter ID ............................................ 8-3

9 Tree Rollup ID
Creating a New Tree Rollup ID ................................. 9-1
Using the Tree Rollup ID Window ......................... 9-3
  Rollup Tree Pane .................................................. 9-3
  Display Level Pane .............................................. 9-3
  Edit Menu ........................................................ 9-3
  Options Menu .................................................... 9-5
  Tree Menu ........................................................ 9-7
  Save the ID ....................................................... 9-12
Editing a Tree Rollup ID ........................................... 9-12
Example: Building a Product Tree ......................... 9-13
  Set the Levels of a Tree ...................................... 9-14
  Build a Tree .................................................... 9-15

10 Tree Filter ID
Creating a New Tree Filter ID ................................. 10-1
Using the Tree Filter ID Window ......................... 10-3
  Rollup Tree Pane .................................................. 10-3
  Display Level Pane .............................................. 10-3
  Edit Menu ........................................................ 10-4
Creating Stored Procedures ...................................................................................................... 13-3

Limitations to the Spreadsheet Display and Processing Time ................................. 13-3
  Maximum Number of Rows and Columns Displayed .............................................. 13-3
    Maximum Number of Rows ............................................................................... 13-3
    Maximum Number of Columns ...................................................................... 13-3
  Optimizing Processing Time .............................................................................. 13-3

14 Transformation ID

The Transformation Process ......................................................................................... 14-2
Pivoting ....................................................................................................................... 14-2
  Financial Element Pivot ...................................................................................... 14-2
  Time Bucket Pivot ............................................................................................... 14-2
Non-Pivot Transformations ....................................................................................... 14-3
  Dimension Filtering ............................................................................................. 14-3
  Data Filtering ....................................................................................................... 14-3
  Rates ..................................................................................................................... 14-3
  Tree Rollup .......................................................................................................... 14-4
Metadata and System Information Table ................................................................... 14-4

Creating a Transformation ID ..................................................................................... 14-4

Defining a Transformation ID ..................................................................................... 14-5
  Defining a Ledger Stat Transformation ................................................................. 14-6
Risk Manager Result Detail Table ........................................................................... 14-9
Tree Rollup Table ...................................................................................................... 14-10

15 SQL ID

SQL Compatibility ....................................................................................................... 15-1
SQL User Requirements ............................................................................................. 15-1
Define an SQL ID ........................................................................................................ 15-2
  SQL Type ............................................................................................................. 15-2
    The Input Window ............................................................................................ 15-2
Process an SQL ID ...................................................................................................... 15-2
Edit an SQL ID ......................................................................................................... 15-2
  Group ..................................................................................................................... 15-3
  SQL ID .................................................................................................................. 15-3
Notes on SQL Block .................................................................................................. 15-3
Year-To-Date Calculations Affected by a Fiscal Year Configuration........................................ C-3
Viewing the Start_Month and Fiscal_Period Values in the FISCAL_YEAR_INFO Table.... C-3
Examples of Calendar and Fiscal Year Configurations ............................................................ C-4
    Using a Calendar Year Configuration.................................................................................... C-5
    Using a Fiscal Year Configuration with a 12-Month Duration.............................................. C-6
    Using a Fiscal Year Configuration with a 6-Month Duration................................................ C-6
Using the Undo Function with a Fiscal Year Configuration ..................................................... C-7

D  Transformation ID Error Messages

Glossary

Index
Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this document. Your input is an important part of the information used for revision.

- Did you find any errors?
- Is the information clearly presented?
- Do you need more information? If so, where?
- Are the examples correct? Do you need more examples?
- What features did you like most?

If you find any errors or have any other suggestions for improvement, please indicate the document title and part number, and the chapter, section, and page number (if available). You can send comments to us in the following ways:

- Electronic mail - fsdocmail@us.oracle.com
- FAX - (650) 506-7200  Attn: Oracle Financials Documentation Manager
- Postal service:
  Oracle Corporation
  Oracle Financials Documentation Manager
  500 Oracle Parkway
  Redwood Shores, CA  94065
  USA

If you would like a reply, please give your name, address, telephone number, and (optionally) electronic mail address.

If you have problems with the software, please contact your local Oracle Support Services.
Oracle Financial Data Manager Balance & Control is part of Oracle Financial Data Manager (FDM). FDM is a standalone data warehouse for the financial services industry and the foundation of Oracle Financial Services (OFS) applications. You use Balance & Control to maintain and manage the Oracle Financial Data Model.

This reference guide describes how to use Balance & Control for data scrubbing, validation, and reconciliation.

This preface describes the following information about the reference guide:

- Intended Audience
- Organization
- Report-Related Changes
- Related Documents
- Conventions
- Customer Support Information

### Intended Audience

This manual is written for anyone who is responsible for validating and correcting database content.
Organization

This manual is organized into the following chapters:

**Chapter 1**  Introduces Balance & Control and provides setup, format, and menu descriptions.

**Chapter 2**  Provides an overview of the processes used in Balance & Control, with explanations of scrubbing, balancing, and aggregating data.

**Chapter 3**  Explains the ID concept, functions associated with IDs (such as importing and exporting), tree-related IDs, and dependencies.

**Chapter 4**  Describes how to process and edit a Data Verification ID.

**Chapter 5**  Explains how to use a Correction Rule ID to change fields in the database. An example is provided.

**Chapter 6**  Explains how to process and edit a Data Correction Processing ID.

**Chapter 7**  Describes the Data Filter ID, filter types, and multiple tables.

**Chapter 8**  Explains how to create and edit a Group Filter ID.

**Chapter 9**  Describes the Tree Rollup ID and how to use it.

**Chapter 10**  Describes the Tree Filter ID, branch expansion, node inclusion, and order.

**Chapter 11**  Defines the Formula ID and types of functions.

**Chapter 12**  Explains how to process and edit a Batch ID.

**Chapter 13**  Describes using SQL Talk to interface with the database and explains how to call subprograms.

**Chapter 14**  Defines the Transformation ID concept and provides step-by-step procedures for transforming data.

**Chapter 15**  Explains how to use the SQL ID and its relationship to SQL Talk.

**Appendix A**  Describes Cash Flow Correction Rules and Cash Flow Edit Logic.

**Appendix B**  Lists all Financial Elements by number and by element description.

**Appendix C**  Explains how to change the fiscal year of the LEDGER_STAT table from a calendar year to a fiscal period setup.

**Appendix D**  Lists Transformation ID error messages.

This manual also contains a glossary and an index.
Report-Related Changes

Release 4.5 of Oracle Financial Services Applications (OFSA) fully integrates Oracle Discoverer with the following OFSA products:

- Oracle Financial Data Manager Balance & Control
- Oracle Performance Analyzer
- Oracle Risk Manager
- Oracle Transfer Pricing

With Release 4.5, Oracle Discoverer becomes the recommended reporting tool for OFSA.

This release supports Oracle Reports, Oracle Discoverer, and the reporting tool used in prior OFSA releases. You can find information about these reporting tools in the following documents:

<table>
<thead>
<tr>
<th>Reporting Tool</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oracle Reports</td>
<td>Oracle Financial Data Manager Reporting Administration Guide</td>
</tr>
<tr>
<td>Oracle Discoverer</td>
<td>Oracle Discoverer 3.1 User Guide</td>
</tr>
<tr>
<td></td>
<td>Oracle Discoverer 3.1 Administrator Guide</td>
</tr>
<tr>
<td></td>
<td>Oracle Financial Data Manager Reporting Administration Guide</td>
</tr>
<tr>
<td>OFSA reporting tool</td>
<td>Oracle Portfolio Analyzer Reference Guide</td>
</tr>
</tbody>
</table>

Report-related chapters and appendixes have been removed from all OFSA reference guides and moved to the Oracle Portfolio Analyzer Reference Guide.

The specific chapters and appendixes include the following:

- Report ID
- Report Macros
- Report Runner Dialog
- Report Stratification ID
- Standard Reports
- Subtotal ID
Related Documents

For more information, see the following manual:

- Oracle Financial Data Manager Administration Guide
- Oracle Risk Manager Reference Guide

Conventions

This reference guide uses the following conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>. . .</td>
<td>Vertical ellipsis points in an example mean that information not directly related to the example has been omitted.</td>
</tr>
<tr>
<td>. . .</td>
<td>Horizontal ellipsis points in statements or commands mean that parts of the statement or command not directly related to the example have been omitted.</td>
</tr>
<tr>
<td>boldface text</td>
<td>Boldface type in text indicates a term defined in the text, the glossary, or in both locations.</td>
</tr>
<tr>
<td>bold monospace</td>
<td>Bold monospace type in text indicates information that you type in.</td>
</tr>
<tr>
<td>Italics</td>
<td>Italics emphasize a word or phrase.</td>
</tr>
<tr>
<td>&lt; &gt;</td>
<td>Angle brackets enclose user-supplied names (for example, &lt;Branch Name&gt;).</td>
</tr>
<tr>
<td>[ ]</td>
<td>Brackets enclose function and terminal keys. In common syntax, brackets denote one or more optional items.</td>
</tr>
<tr>
<td>{ }</td>
<td>Braces are used to denote variables, and in command syntax, a choice within a mandatory item.</td>
</tr>
<tr>
<td>Example of command syntax:</td>
<td></td>
</tr>
<tr>
<td>Example of choices:</td>
<td></td>
</tr>
<tr>
<td>{EXIT</td>
<td>QUIT}</td>
</tr>
<tr>
<td>-&gt;</td>
<td>This arrow indicates a menu path.</td>
</tr>
</tbody>
</table>
Symbols

- Bullets indicate a list of items or topics.

1. Numbered lists are used for sequential steps in completing a procedure.

Orientation of Procedures

Procedures in OFSA reference guides are generally menu-driven rather than command- or icon-driven. Only occasionally is a reference to a toolbar or mouse action necessary because the action has no menu equivalent. If you prefer to use the toolbar icons, refer to Chapter 1, “Introduction.”

Notes, Cautions, and Warnings

Certain information may be set off in boxes for purposes of emphasis:

- Note refers to interesting but incidental information about the product or information that may be important but of lesser degree than a Caution or Warning.
- Caution indicates the possibility of damage to a product, system, or data.
- Warning refers to a situation that is potentially hazardous to people.

Customer Support Information

Product support is available through Oracle Support Services. Contact your project manager for information about using the support options offered in your geographic region. These options may include the following:

- MetaLink (which provides online access to information about Technical Libraries, Patches, TARs, and Bugs and is available at metalink.oracle.com)
- Telephone support
Accessing relevant financial information from your application systems is essential for performing useful analysis and modeling. The challenge is establishing a method for validating data from various sources such as:

- Ledger Data
- Mortgage Loan Data
- Deposit Data

The transaction data must be validated, reconciled to your general ledger, and in some cases aggregated for analytical purposes.

With Oracle Financial Data Manager Balance & Control (hereafter referred to as Balance & Control), you easily perform such processing. Balance & Control provides structured mechanisms to create, save, modify, and execute correction rules against data in the Oracle Financial Data Manager (FDM) database.

Balance and Control also provides mechanisms to reconcile and balance the General Ledger data to the instrument data. Tools to aggregate detail level data are also included.
Oracle Financial Services Overview

You can use Balance & Control as part of FDM in standalone mode or as part of the Oracle Financial Services (OFS) group of applications. As with all the other OFS applications, however, FDM provides the foundation for Balance & Control.

OFS Applications

OFS applications form a comprehensive decision support solution that significantly enhances transfer pricing, budgeting and planning, risk management, and performance measurement functions across a financial institution.

Oracle Financial Data Manager
Oracle Financial Data Manager (FDM) is a standalone data warehouse with prepackaged data elements for the financial services industry. FDM is also the
foundation for the OFS applications. It provides the database structures necessary to support the individual business applications.

FDM includes Oracle Financial Data Manager Balance & Control, Oracle Financial Data Manager Administration, Oracle Financial Data Manager/Discoverer Integrator, and Oracle Rate Manager.

**Oracle Financial Data Manager Balance & Control** Balance & Control validates, corrects, and aggregates data from the FDM.

**Oracle Financial Data Manager Administration** FDM Administration manages the FDM, providing security and maintenance capabilities.

**Oracle Financial Data Manager/Discoverer Integrator** Discoverer Integrator integrates the FDM database with Oracle Discoverer, which provides ad hoc reporting, analysis, and Web publishing capabilities.

**Oracle Rate Manager** Rate Manager manages interest rate and exchange rate information for the FDM, improving upon and replacing Historical Rates ID.

**Oracle Budgeting & Planning**
Budgeting & Planning provides performance-based planning. It integrates cash flow balance sheet and net income forecasting capabilities with the scalability and customizable framework of Oracle Financial Analyzer, part of the Oracle Express group of data access and analysis tools.

**Oracle Transfer Pricing**
Transfer Pricing calculates a transfer rate for each account and a charge or credit for funds for each asset or liability.

**Oracle Performance Analyzer**
Performance Analyzer provides comprehensive and flexible cost and equity allocations. It measures product, business unit, and customer profitability.

**Oracle Risk Manager**
Risk Manager forecasts cash flows, interest income, and market value in order to manage rate risk.
Oracle Customer Householding
Customer Householding provides a fully scalable parallel-processing engine for customer data loading and cleansing, customer relationship linking, customerization, householding, and data aggregation within FDM.

Logging into OFS
To log into any OFS application, double click on the appropriate OFS icon from Windows. The OFS Login dialog appears.
In Windows NT or Windows 95, multiple OFS applications can be run, but each application should run in its own memory space.

Menus and Toolbars
You can use menus or the toolbar icons to activate (individual product name) options.

Menus
A typical OFS menu bar consists of the following menu options:
- File
- Edit
- Process
- Setup
- Options
- Tools
- Window
- Help

File Menu
The options of the File menu are used primarily for file management. This includes creating new files, opening existing files, saving, deleting, and renaming files. This menu also contains commands for printing IDs and dialogs, and for exiting the application.
**Save** select Save to save IDs as you are creating or modifying them. You are prompted to confirm the save.

You should save your work every few minutes. From the File menu, you can select Save, or you can click on the Save icon (the floppy disk) on the toolbar.

**Delete** Select Delete to remove the open and active ID from the disk. You are prompted to confirm the deletion.

If you want to delete more than one open ID, make each ID active by clicking anywhere within the dialog window and delete it.

**Delete Group** To delete a group of IDs, complete the following steps. Each ID does not need to be open and active for you to delete the entire group.

1. From the file menu, select Delete Group. The Delete Group window appears.
2. From the ID Type list, select the type of ID that you want to delete. All IDs of this type appear in the list below the ID Type list.
3. Select the IDs you want to delete, and select the Add button to list them in the ID Type/ID Name box.
4. Repeat steps 1 and 2 for as many ID types as required. You can select and delete multiple IDs of multiple types all at once. The following table describes other features of the Delete Group window.

<table>
<thead>
<tr>
<th>Selection Buttons</th>
<th>Four buttons control the movement of IDs between the ID list box and the Selected IDs box.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Select Add to add the ID to the Selected IDs box. Select Select All to select all the IDs of the chosen type.</td>
</tr>
<tr>
<td></td>
<td>Select Remove to remove an ID from the list you have made in the Selected IDs box.</td>
</tr>
<tr>
<td></td>
<td>Select Remove All to remove all of them from the Selected IDs list.</td>
</tr>
<tr>
<td>Order Buttons</td>
<td>To change the order of IDs in the Selected IDs box, select an ID and click the up or down Order arrows located below the list box.</td>
</tr>
<tr>
<td>ID Information</td>
<td>You can view various data about each ID before you delete it. Select any ID name in the ID list box, and click the right mouse button. An information box for that ID appears.</td>
</tr>
</tbody>
</table>
5. When your list of IDs is complete, select Remove All to delete the group of IDs.

**Import/Export Group** Refer to “Importing and Exporting IDs” in (chapter number) in “Overview of IDs” for a full discussion of this menu option.

**Dependencies** Refer to “Dependencies” in (chapter number) “Overview of IDs” for a full discussion of this menu option.

**Print** Select Print to print the open and active ID or dialog. Select Yes to proceed, or No to cancel the print job.

**Print Group** To print a group of IDs, complete the following steps. It is not required that each ID in the group is open in order to print the entire group.

1. From the File menu, select Print Group.
2. Select the type of ID you want to print from the ID Type list. All IDs of this type appear in the list below the ID Type list.
3. Select the IDs that you want to print, and select the Add button to list them in the Selected IDs box.
4. Repeat steps 2 and 3 for as many ID types as required. You can select multiple IDs of multiple types.
5. To change the order of the listed IDs in the Selected IDs list box, select an ID and click the up or down Order arrows below the list.
6. When your list of IDs is complete, click OK to proceed with the group print.
7. Click Yes to proceed or No to cancel the print job.

**Edit Menu**
Use the Edit menu options to copy and move material from place to place, and to delete spreadsheet rows.

**Search** Use the Search option to locate a specific leaf value. There are three search options:

- **Search Field** Specify Leaf Value or Description.
- **Search String** Type in the Leaf Value or Description.
**Search Options**  
Select Case Sensitive if you want your search to match the string exactly as you entered it. Select Continue Searching... if your search begins part way down the tree (at the cursor location) but you also want to search above.  
Click OK to begin the search. When the search is complete and successful, the search dialog closes and the found leaf ID is highlighted. If the search string is not found, an error message appears.

**Process Menu**  
The Process menu contains the following options:

- **Run**  
  Select this option to begin any process.

- **Server Status**  
  Use this option to check the status of the processes running on the server.

- **SQL Talk**  
  For information regarding the SQL Talk option, refer to (chapter number), “SQL Talk.”

**Setup Menu**  
The Setup menu contains one option: Leaves.

- **Leaves**  
  To access the Leaf Setup dialog, select Leaves from the Setup menu.  
  With Leaf Setup, you can view, edit, insert, renumber, or delete any Leaf Value from any Leaf Type in the database. For further information about the Leaf Setup dialog, refer to “Leaf Setup”, in (chapter number), “Overview of IDs.”

**Options Menu**  
Use the Options menu to set up preferred screen displays, and to change users' passwords.
Menus and Toolbars

**Tool Bar**  This is a “toggle” option, that is, it turns the display of the toolbar on and off. When the option is “on,” a check mark is displayed.

**Status Bar**  This is a “toggle” option, that is, it turns the display of the status bar on and off. When the option is “on,” a check mark is displayed.

**Customize ID Toolbar**  You can customize the vertical toolbar using this option. For more information, see the section “Toolbars” later in this chapter.

**Change Password**  Use this option to change the password for the Current User of this OFS application. When you select Change Password, the Change User Password dialog appears.

- **Login name**  The name of the current user appears here.
- **Current password**  This box appears blank. Enter the current password for the current user. Asterisks appear as you type, for security reasons.
- **New password**  This box appears blank. Enter the new password for the current user. Asterisks appear as you type, for security reasons. Click OK to execute the change. Click Cancel to cancel the operation and close the dialog.

**Tree Bar**  This is a dialog box with a listing of accounts. When you open certain IDs, the dialog appears with the Floating Tree Bar:

On the Floating Tree Bar, select the account (or product) for which you would like to define a method. After you have selected an account you can close the Floating Tree Bar.

**Control Bar**  For information about the Control Bar, refer to “Spreadsheet Control Bar in Chapter 3, "Overview of IDs”.

**Tools Menu**

Use the Tools menu to start the Discoverer applications: Oracle Discoverer User Edition, Oracle Discoverer Administration Edition, and Discoverer Integrator. The Tools menu is always present. If an application is not installed, however, its name is grayed out and it is not available for use.
Window and Help Menus
The Window menu options are for managing windows and icons, and for moving the cursor between windows.

The Help menu options are the topics for Help information for this OFS application. Both of these options operate under standard Windows guidelines.

Status Bar
Across the bottom of the screen is the Status Bar, where information about current operations is displayed. Position the pointer on any Toolbar icon to display the name of the icon on the Status Bar.

Toolbars
The horizontal and vertical toolbars are panels of icons that support shortcuts for menu commands and IDs.

Horizontal Toolbar
The horizontal toolbar provides shortcuts to menu commands. Following is the horizontal toolbar and the function each icon activates. You cannot customize this toolbar.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>New</td>
</tr>
<tr>
<td>2</td>
<td>Open</td>
</tr>
<tr>
<td>3</td>
<td>Save</td>
</tr>
<tr>
<td>4</td>
<td>Print</td>
</tr>
<tr>
<td>5</td>
<td>Delete</td>
</tr>
</tbody>
</table>

1. Create a new ID or pattern
2. Open an existing ID or pattern
3. Save an ID or pattern
4. Print results
5. Delete an ID or pattern
## Menus and Toolbars

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>Close</td>
</tr>
<tr>
<td>7</td>
<td>Print Group</td>
</tr>
<tr>
<td>8</td>
<td>Delete Group</td>
</tr>
<tr>
<td>9</td>
<td>Group Import/Export</td>
</tr>
<tr>
<td>10</td>
<td>Run</td>
</tr>
<tr>
<td>11</td>
<td>Report Runner</td>
</tr>
<tr>
<td>12</td>
<td>Transform Data</td>
</tr>
<tr>
<td>13</td>
<td>Set Up Leaves</td>
</tr>
<tr>
<td>14</td>
<td>Discoverer User Edition</td>
</tr>
<tr>
<td>15</td>
<td>Discoverer Administration Edition</td>
</tr>
<tr>
<td>16</td>
<td>Discoverer Integrator</td>
</tr>
<tr>
<td>17</td>
<td>Leaf Tree Bar</td>
</tr>
<tr>
<td>18</td>
<td>Spreadsheet Control Bar</td>
</tr>
<tr>
<td>19</td>
<td>Help</td>
</tr>
<tr>
<td>20</td>
<td>Exit</td>
</tr>
</tbody>
</table>

**Note:** The Discoverer icons (14, 15, and 16) are always present. If an application is not installed, however, its icon is grayed out and it is not available for use.
Vertical Toolbar

The Vertical toolbar provides shortcuts to the IDs to which you have access in the application. Space limitations may restrict the icons that you see on the screen. However, you can customize the toolbar for your specific needs.

To customize the vertical toolbar, complete the following steps:

1. From the Options menu, select Customize ID Toolbar.
   The Customize ID Toolbar window appears.

2. Locate the icon you want to add, delete, or move.
   Use the scroll bar on the Customize ID Toolbar window to find the icon that you want to add to the vertical toolbar. Or, find the icon on the vertical toolbar you want to delete or move.

3. Add, delete, or move the icon.
   To add an icon to the toolbar, select and then drag the icon from the Customize ID Toolbar window to the vertical toolbar.
   To delete an icon, drag the icon from the toolbar to the Customize ID Toolbar window.
   To change the order of your icons, drag them individually from one location on the toolbar to another.
Overview of the Process

Reconciliation is the process of comparing the information carried in the instrument table to a data source which defines the financial reality, usually the general ledger.

Reconciliation Reports

The reconciliation process involves defining a level at which some piece of information is to be compared between the instrument data and the general ledger data carried in the LEDGER_STAT table. That level can be one dimension (for example, reconcile for each general ledger account number) or multiple dimensions (for example, reconcile for each general ledger account number within each business unit).

The most common type of reconciliation is to compare the ending balance of instrument data to the general ledger ending balances. The data carried in the database is a snapshot of the portfolio as of a given date (As_of_Date). Consequently, comparing the ending balances from the instrument table versus the general ledger ending balances measures the degree to which the extracted data is in balance with, or reconciles to, the general ledger. Once the variances between the instrument table information and the Ledger Stat information are known, they should be corrected to validate the data.

See the Oracle Financial Data Manager/Discoverer Integrator Guide for detailed steps on creating reconciliation reports.
Scrubbing the Data

Scrubbing the data means validating the relevant columns in the database in isolation (for example, is the current rate valid?) and in relation to the other columns (for example, is the origination date plus the original term equal to the maturity date?) for each row in a database.

Scrubbing the data is necessary to correct errors that have affected the data. Bad data can provide an incorrect picture of your current portfolio breakout or, when data is used for simulation purposes, an incorrect view of future performance. There are several potential sources for data errors:

**Input Error:** Data was input incorrectly into the source system.

**Missing Data:** Data is not carried on the source system.

**Extract Error:** Data from the source system has been mapped incorrectly in the database, that is, assigned incorrect location or value.

Data is scrubbed by using the Data Correction Processing ID. This ID lets you process standard cash flow corrections and customized correction rules against the data.

Uncorrected Data

Although bad data may provide a misleading answer and should be corrected, there is some value to maintaining the data in its raw, or unedited state. By reporting on the raw data, an institution can identify which data is bad, and correct the errors.

It is vital to correct the cash flow columns in the database that are used for simulation purposes. Cash flow columns are those that impact the cash flow behavior of an instrument, such as rates, terms, payment frequency, caps, or floors. These are the most commonly corrected columns.

Due to the infeasibility of storing all columns in two states (a process that doubles the required disk space), all columns can be corrected, but the columns will only exist in the corrected state. You must set up separate user-defined columns to store the bad data. Any time a column is corrected, however, the change information is logged in an error log file.
Assigning Account Classifications

Account classifications are distinctions used for segmenting your portfolio. The most common account classifications are product classifications, organizational unit classifications, and customer segmentation classifications.

Classifications are assigned to both the instrument and Ledger Stat data for two purposes:

- The classifications are a convenient way of thinking about your portfolio for analysis or modeling.
- The account classifications define the relationship between the instrument data and the Ledger Stat data. By matching instrument data with Ledger Stat data that has the same product classification, for example, we can define the Ledger Stat balances that relate to the instrument balances.

Account classifications may be assigned using the Data Correction Processing ID, exactly the same procedure as scrubbing data. The Data Correction Processing ID lets you define a series of correction rules to apply to each row within a defined filter. Whether the account classifications are made in the data extract process or assigned through Balance and Control, account classification assignments are another common use of Balance and Control.

Balancing the Data

Balancing the data means eliminating all the variances between the instrument tables and the Ledger Stat data. The data stored in the FDM database should reflect reality to the extent possible to produce reliable analyses.

There are several methods for balancing the instrument data to the Ledger Stat data: correcting the extract process, creating plug balances, or using a gross-up approach.

Correcting the Extract Process

If the extract data is so far off that it is not salvageable, the extracts may need to be corrected and regenerated. Even if an alternative method is taken to balance the data, the long-run goal should be to keep the extract logic as accurate as possible.

Creating Plug Balances

The variances can be eliminated by creating one or many pseudo-transactions whose balances equals the variance amount. The decision to take this approach is a judgment call, made when variances are within a reasonable threshold.
Using a Gross-Up Approach

The variances can be eliminated by multiplying the balances of each instrument row by a factor that ensures reconciliation. This approach distorts the corrected balance of every row in the database but ensures that the available instrument data defines the balance distribution of product characteristics.

Aggregating the Data

Data aggregation means grouping similar rows together to form a set of fewer rows of data that represents the same portfolio. Data aggregation is performed for processing efficiency, since many of the processing steps in an analytical process are time consuming. However, because many assumptions are made when defining an aggregation, there may be a loss of accuracy when operating against an aggregate portfolio. The degree of lost accuracy is a function of the aggregation assumptions and the analytical purpose for which the data is aggregated.

Stratification Reports

A stratification report stratifies (segments) a portfolio into groups (tiers) based upon like ranges of one or many database columns. By defining appropriate stratification reports, you can get a complete understanding of your portfolio composition. For example, you may want to generate a report that groups all mortgage loans into 100 basis point rate tiers starting at 5.00%.

<table>
<thead>
<tr>
<th>Rate Tier</th>
<th>Balance</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00%-4.99%</td>
<td>$1,000,000</td>
</tr>
<tr>
<td>5.00%-5.99%</td>
<td>$15,000,000</td>
</tr>
<tr>
<td>6.00%-6.99%</td>
<td>$350,000,000</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

This is a one-dimensional stratification report (for example, a stratification by rate tier).
Alternatively, you may wish to see repricing frequency information within each of the rate tiers.

<table>
<thead>
<tr>
<th>Rate Tier</th>
<th>Repricing Freq</th>
<th>Balance</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00%-4.99%</td>
<td>Fixed</td>
<td>$500,000</td>
</tr>
<tr>
<td>6 Month</td>
<td></td>
<td>$250,000</td>
</tr>
<tr>
<td>12 Month</td>
<td></td>
<td>$250,000</td>
</tr>
<tr>
<td>5.00%-5.99%</td>
<td>Fixed</td>
<td>$1,000,000</td>
</tr>
<tr>
<td>6 Month</td>
<td></td>
<td>$9,000,000</td>
</tr>
<tr>
<td>12 Month</td>
<td></td>
<td>$5,000,000</td>
</tr>
<tr>
<td>6.00%-6.99%</td>
<td>Fixed</td>
<td>$200,000,000</td>
</tr>
<tr>
<td>6 Month</td>
<td></td>
<td>$25,000,000</td>
</tr>
<tr>
<td>12 Month</td>
<td></td>
<td>$125,000,000</td>
</tr>
<tr>
<td>...</td>
<td>...</td>
<td>...</td>
</tr>
</tbody>
</table>

This is a two-dimensional stratification report (for example, stratification by repricing frequency within rate tiers).

**Stratification Report Flexibility**

Balance and Control provides three dimensions of flexibility in stratification reporting: flexibility in defining stratification ranges, flexibility in defining the report columns, and flexibility in defining a subset of the portfolio. Stratification reporting is ideal for drilling down into your portfolio to perform ad hoc analyses and for generating standard reports that segment portfolios at a high level.

**Defining Stratification Ranges**

Not only can you define a multi-dimensional stratification report, but you have complete flexibility in defining the specific tier definitions for each stratification column.

**Defining the Report Columns**

You can define the columns in stratification reports. This includes defining formulas, formats, justification, and fonts.
Defining a Subset of the Portfolio

Balance and Control allows you to generate any stratification report with several types of filters to narrow the focus of the report.

Using Data Filters

A data filter lists criteria that focus on a particular subset of your portfolio. Data filters are created using Data Filter IDs. A Data Filter ID is one of several types of filters that can be used in any report or process.

Data filters are used any time you want to narrow the focus of your portfolio for processing of any type. For example, you may want to process all adjustable rate mortgage loans originated in the Western Region in the past two months. Similarly, you may want to perform market value analysis on only your Time Deposit portfolio. Each of these subsets of your portfolio can be defined by using a Data Filter ID.

Using Relationship Filters

A relationship filter allows you to define a filter that can be evaluated at an aggregate (or relationship) level. For example, you may want to make an evaluation at a branch level, a customer level, or a loan officer level. Each of these relationships is made up of many transaction records in the database. Consequently, to evaluate a filter at such a relationship level, the relevant underlying transaction records must be aggregated to the relationship level before the filter can be evaluated to determine which relationships pass the filter.

Relationship filters are created using Relationship Filter IDs. A Relationship Filter ID is one of several types of filters that can be used in any Process ID.

Relationship filters allow you to perform analysis at a level of data not commonly stored in a database. By storing data at the lowest possible level, the transaction level, the database can be aggregated to any appropriate level for analysis purposes.

With a relationship filter you can perform analyses such as:

- Customer profitability analysis
- Organization level profitability analysis
- Account officer analysis
Multi-User Problems and Solutions

When an ID is created, a unique system number (sys_id_num) is assigned to the ID to distinguish it from other IDs. However, if User A creates a new ID at the same time as User B, there is a chance the same system number will be assigned to both IDs. If this occurs, and User A saves the newly created ID before User B, User B receives a Unique Constraint Error. User B now should select Save As from the File menu, and save the ID under a new name.

If User A and User B are in the same existing ID but on different workstations, and User A makes changes to that ID and saves the changes, User B receives the following message:
TEMPDAVE2 has changed since you loaded it. Select File|Save As from the main menu to save your id under a new name, or press Cancel to Escape without saving.

User B should select Save As from the File menu and save the ID under a new name, or click Cancel to exit without saving. If User B chooses to save the ID under a new name, the original ID before User A made changes is saved to a new name. If User B cancels, the ID closes. Only User A’s changes are saved.

When a user tries to process an ID (for example, a Batch ID), the ID is automatically saved again to the database before it is processed. If User A and User B are trying to process the same ID at the same time, and User A clicks the Run icon before User B, User B will get the previously mentioned error when trying to process the ID.

Multi-Processing

In client/server architecture, processing tasks are performed by the computer that is best suited to do the job. Client/server technology allows multiple users to process at one time. The number of processes a user can run is a function of the server configuration implemented at a specific site.

Each configuration has a specific and unique amount of processing capacity. However, it is important to address the issue of scalability when implementing client/server. As the number of users increase, the processing load on the server increases. It is vital to be able to add additional CPUs and memory to facilitate the increased loads.
Following are the variables that determine platform configuration when implementing a client/server system:

- The number of users accessing the server concurrently
- The number of user processes being initiated on the server concurrently
- The memory requirements of each user and the user processes
- The total amount of memory to which the server can expand
- The amount of data volumes being processed on the server

**Client/Server Processing**

In client/server architecture, application processing can occur on both the client PD and the server. The database resides on the server. Allocation IDs, Correction Processing IDs, Mass Delete IDs, Relationship Filter IDs, Transfer Pricing Processing IDs, and Risk Manager Processing IDs can all be processed on the server as well as the client PC. Since there are more processing resources on the server than on individual PCs and the server processes are multi-threaded, server-based processing will generally be faster. However, if multiple server-based processes are running at the same time, database performance may diminish.
All Oracle Financial Services applications have a Server Status window that displays server activity. Select Server Status from the Process for the following:

**Job Description**  
Name of the ID being processed

**Table Name**  
Name of the table being processed against

**Number**  
Record number being processed

**Host**  
Not currently implemented

**Record**  
Number of records being processed

**User**  
User’s login name

**Title**  
Description of the process

**Status**  
Indicates whether or not the job has completed

**Job Return Status**  
Indicates successful process or an error code

**Request Date**  
Date on which request is inserted into OFSA Request Queue

**Request Time**  
Time at which request is inserted into OFSA Request Queue

**Start Date**  
Date on which OFSA Request Queue launches process

**Start Time**  
Time at which OFSA Request Queue launches process

**End Date**  
Date on which process completes

**End Time**  
Time at which process completes

**Priority**  
Not currently implemented
An Oracle Financial Services Application identification (OFSA ID) is a type of dialog box that supports the set up of assumptions information, reporting specifications, or processing specifications. With OFSA IDs, you have the flexibility to define as many types of assumptions, report specifications, or processing specifications as needed.

You can use an ID immediately after creating it and then discard it without saving it. You can also save it and then modify and resave it under another name for use in other OFS applications.

This chapter presents the following topics:

- Creating an ID
- Opening an Existing ID
- Closing an ID
- Saving an ID
- Deleting an ID
- Leaf Setup
- Tree-Related IDs
- Importing and Exporting Data
- OFSA ID Dependencies
- Processing an ID
- Server Status
- Spreadsheet Control Bar
Creating an ID

To create an ID, perform the following steps:

1. From the File menu, select New.
   
   A list of the IDs available for the product you are using appears.

2. From the list, select the ID you want to create and define.
   
   The New ID dialog box appears.

3. Select or type in each field, as required, using the following descriptions as a reference:
Creating an ID

Overview of IDs

4. Click OK to continue, or click Cancel at any time to cancel the operation and exit the dialog box.
Opening an Existing ID

To open an existing ID, perform the following steps:

1. From the File menu, select Open.
   
   A list of IDs available for the product you are using appears.

2. From the list, select the type of ID you want to open.
   
   The Select ID dialog box appears.

3. Select or type in each field, as required, using the following descriptions:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder</td>
<td>Click the arrow to view a list of folders. Select the name of the folder under which this predefined ID was created. The folder you select determines which ID choices are listed.</td>
</tr>
<tr>
<td>Additional criteria information</td>
<td>Before opening some types of IDs, you must provide additional information, such as a leaf type or a Tree Rollup ID. This data determines the list of previously defined IDs that appear for your selection.</td>
</tr>
<tr>
<td>Variable ID</td>
<td>Use the list to select the ID you want to open. (If you know the name of the ID, you can type the first letter of the ID to reach that portion of the alphabetized list, scroll down and select it.)</td>
</tr>
</tbody>
</table>

4. Click OK to continue, or click Cancel at any time to cancel the operation and exit the dialog box.

Closing an ID

From the File menu, select Close to close an open ID.

Saving an ID

From the File menu, select Save to save your ID.
**Save As**

You can copy IDs by saving them under a new name. Perform the following steps to copy an ID:

1. Select the ID that you want to copy.
2. From the File menu, select Save As....
   
   The New ID dialog box appears.
3. Type a folder name and description for the ID and any other data required, and click OK.
   
   The ID is copied and saved under the new name. The original ID remains unaltered.

**Rename**

To rename an ID, perform the following steps:

1. Open the ID that you want to rename.
2. From the File menu, select Rename.
   
   The Rename ID dialog box appears.
3. Type a new name and description for the ID and any other data required, and click OK.
   
   The ID is saved under the new name.

You can change the folder using this function, but only if the ID is actually renamed. This function does not perform a check for duplicate ID names in the folder.

You can also use Rename to change the Read/Write status for an ID.

**Deleting an ID**

To delete an ID, perform the following steps:

1. Open the ID that you want to delete.
2. From the File menu, select Delete.
   
   A Delete Confirmation dialog box appears.
3. Click Yes to confirm your decision, or click No to cancel the operation.
Delete a Group of IDs

To delete a group of IDs, perform the following steps:

1. From the File menu, select Delete Group.
   The Delete Group dialog box appears.

2. From the ID Type list, select the Type of ID.
   All IDs of that type appear in the large dialog box below it.

3. Select the IDs that you want to delete, and select Add to display them in the
   selected IDs list.
   You can continue to select different ID types and add them to the selected IDs
   list for deletion.

   Caution: Do not delete the active Configuration ID.

   When you create an ID, it has a set of assumptions. These assumptions are based on a specific modeling horizon, which is defined in the active Configuration ID.

   If the assumptions are based on a Configuration ID that does not exist, the data produced is inaccurate.

   a. To select multiple IDs of any type, hold down the Shift key while you click
      on them.

   b. To select all IDs of a chosen type, click Select All.

   c. To remove all IDs from the selected IDs list, click Remove All.

   d. Use the arrow buttons to change the position of an ID in the selected IDs
      list.

   e. Select the ID you want to move, and use the up or down arrow to move it
      up or down one position. IDs are deleted in the order that they appear in
      the list.

4. When you have selected all IDs for deletion, select Run from the Process menu.
   The Confirm Group Delete dialog box appears.
5. Click Yes to delete the IDs, or click No to cancel the operation.

**Note:** You cannot import or export IDs while Group Delete is open.

---

**Leaf Setup**

With Leaf Setup you can view, edit, insert (or, in other words, create), renumber, or delete any leaf value from any leaf type in the database.

*Leaf type* and *leaf column* are synonymous. A leaf type is any column registered in the database as a leaf column. For example, GL Account ID, Org Unit ID, Common COA ID, and Financial Element ID are all leaf types.

Leaf values compose the next highest level of categorization above detail account level. This level is known as the leaf level and provides the foundation for the structure of a Tree Rollup ID.

Leaf capacity is 200,000 leaves. This increased capacity enables institutions to model increasingly complex profitability scenarios.

**Note:** You can display as many as 16,000 leaves at a time.
Creating a Leaf Setup Dialog Box

To create a Leaf Setup dialog box, perform the following steps:

1. From the Setup menu, select Leaves.
   The Leaf Setup dialog box appears.

2. To view, edit, renumber, delete, or add any leaf value, select the leaf type that you want from the Leaf Type list.

3. Search for the leaf value that you want.
   You can search for a leaf value either by using Leaf Value or Leaf Description. Leaf Value is the default. Because you can display a maximum of 16,000 leaves at a time, Leaf Value is recommended when you do not know the exact leaf value or description.
   a. If you select Leaf Value, type the From and To Leaf Values in the Range of Leaf Values and then select Display.

   **Note:** To search for an exact match, type the value in both the From and To fields.

   The Leaf Value and Leaf Description lists for the range that you specified appear.
b. If you select Leaf Description, type the description in the Search String field and select a Search Option, if appropriate.

The Leaf Value and Leaf Description lists for the description that you specified appear.

4. To edit a Leaf Value or Leaf Description, select the Leaf Value that you want to edit and then click the Edit button.

The Edit Leaf Info dialog box appears.
5. To edit leaf information, select the appropriate Check to Edit options, make your changes, and click OK.

### Field Name | Field Description
--- | ---
Description | Leaf description, such as Average Net Rate
Account Type | Such as Dividends or Equity
Aggregation Method | Such as Average by Days Weighted or Beginning
Column Name | Physical column name, such as AVERAGE_NET_RATE
Display Name | Can be same or more detailed name as Description or Column name
Weighting Element | Balance used to weight the financial element. For example, Average Transfer Rate has a Weighting Element Average Balance.
Column Property | Values (Balance, Balance Weighted Object, Standard Rate, or Statistic) that determine whether the element requires currency conversion in processing or rate aggregation for reporting

**Note:** All non-common Chart of Accounts (COA) leaves need to be tied to the detail leaf. The detail leaf determines the account type and accrual basis.
6. To renumber a leaf value, select the leaf value that you want to renumber and then click the Renumber button. The Renumber Leaf Value dialog box appears.

7. Type the new number in the New Leaf Value field and then click OK.

8. To delete a leaf value, select the leaf value that you want to delete and then click the Delete button. The Confirm Leaf Delete dialog box appears.

9. Click Yes to delete the leaf value, or click No to cancel the operation.

10. To add a new leaf value, select the leaf type to which you want to add and then click the Insert button. The Enter New Values dialog box appears.

11. Type in the Leaf Value and Description and, depending on the leaf type, any other information about the new leaf.

12. Click OK to add the leaf value, or click No to cancel the operation.

**Aggregation Methods for Financial Elements**

Aggregation methods are applied to the summary financial information calculated at each event in order to generate financial element data for each modeling period. The five different aggregation methods are:

- Average
- Accrual
- Sum
- First
- Last

Following are descriptions of the five aggregation methods.
Average Method

The average method calculates an average value (for example, Average Balance, Average Net Rate) over a modeling period. The calculation sums up the daily values and divides by the number of days in the modeling period.

\[
\text{Daily Average Balance} = \frac{\sum (\text{Daily Balance})}{\text{days in modeling period}}
\]

All simulated events (originations, payments, prepayments, and repricings) are assumed to occur at the end of the event date. This implies that the balance and rate on the day of an event is counted as the value prior to any changes made by the event. Changes made influence the value of the next day.

Accrual Method

The accrual method determines how much accrual has occurred over the modeling period. The accrual method is determined by the code value in the detail record. Interest-in-advance instruments calculate interest accruals from the current payment date to the next payment date. Interest-in-arrears instruments calculate interest accruals from the current payment date to the previous payment date.

The interest cash flow is divided by the number of days between these two dates to determine a daily accrual for each day within the modeling term. Daily interest accruals are summed by modeling period.

\[
\text{Daily Interest Accrual} = \frac{\text{Interest Cash Flow}}{\text{number of days in payment}}
\]

The example below demonstrates an interest accrual for an arrears record:

\[
\begin{array}{|c|c|c|c|}
\hline
\text{Payment Date} & \text{Interest Cash Flow} & \text{Days in Payment} & \text{Daily Accrual} \\
\hline
\text{January 15} & 950 & 31 & 30.64 \\
\text{February 15} & 900 & 31 & 29.03 \\
\text{March 15} & 850 & 28 & 30.36 \\
\hline
\end{array}
\]

Modeling Start Date = January 1

\[
\begin{array}{|c|c|c|}
\hline
\text{Modeling Period End Date} & \text{Accrual Calculation} & \text{Interest Accrual} \\
\hline
\text{January 31} & 15 \text{ days @ 30.64} + 16 \text{ days @ 29.03} & 924.08 \\
\hline
\end{array}
\]
Sum
The sum method adds together all financial element values associated with events occurring during the modeling period.

\[ \text{Principal Runoff} = \sum (\text{Principal Runoff}) \]

First
The first aggregation method determines the value from the first event within a modeling period (for example, Beginning Balance).

Last
The last aggregation method determines the value from the last event within a modeling period (for example, Ending Balance).

Selecting an Aggregation Method
To select an Aggregation Method, perform the following steps:

1. From the Setup menu, select Leaves.
   The Leaf Setup dialog box appears.
2. From the Leaf Type list, select the leaf type you want.
3. Search for the leaf value that you want.
   You can search for a leaf value either by using Leaf Value or Leaf Description.
   a. If you select Leaf Value, type the From and To Leaf Values in the Range of Leaf Values and then select Display.

Note: To search for an exact match, type the value in both the From and To fields.
The Leaf Value and Leaf Description lists for the range that you specified appear.

b. If you select Leaf Description, type the description in the Search String, field and select a Search Option, if appropriate.

The Leaf Value and Leaf Description lists for the description that you specified appear.

4. From the Leaf Value and Leaf Description lists, select a leaf value and then click the Edit button.

The Edit Leaf Info dialog box appears.

5. From the Check to Edit list, select Aggregation Method if it is not already selected.

6. Select an Aggregation Method and then click OK.

Tree-Related IDs

Many OFSA IDs function in the context of leaf columns. An example is the definition of modeling assumptions (such as Transfer Pricing methods or prepayments) on the basis of a Product ID (or product segmentation.).

Examples of tree-or leaf-related IDs include the Tree Rollup ID, Tree Filter ID, Transfer Pricing ID, and Prepayment ID. Tree Rollup IDs, for example, enable the user to *drill-down* to an appropriate level before making an assumption. The user can drill-down to the level of detail needed for the particular purpose.

The OFS applications in which these and similar IDs function include Performance Analyzer, Risk Manager, Transfer Pricing, and Balance & Control.

Hints on Editing Tree-related IDs

When editing Tree Rollup ID and Tree Filter ID, you can use the Options and Tree menus to format the appearance of your ID. For example, you can change typeface or specify which branches are to be included in the rollup. You can use the Edit menu to search for a specific node within the tree structure. For more information about these menus, see Chapter 9, "Tree Rollup ID" and Chapter 10, "Tree Filter ID".
Importing and Exporting Data

You can use IDs for importing and exporting data in Performance Analyzer:

**Note:** You can load Ledger Stat records using the server side process only. For information about loading Ledger Stat records using the server side process, see the *Oracle Financial Services Installation and Configuration Guide*.

**Note:** You must configure the ODBC drivers before you can import and export IDs. For information about configuring the ODBC drivers, see the *Oracle Financial Services Installation and Configuration Guide*.

### Importing and Exporting IDs

You can use import/export functionality of OFSA to:

- Transport IDs from one FDM database to another
- Maintain external backup copies of key IDs
- Load data into FDM from an external database (.DBF) source

OFSA provides two methods of importing and exporting IDs:

- Individual ID import/export
- Dependent ID import/export

### Individual ID Import/Export

IDs that do not contain other embedded IDs, such as Leaf Characteristics ID and Transfer Pricing ID, are imported and exported using the Individual ID method. These IDs are exported into a dBase file with the .DBF extension and can be imported only from a dBase file with the .DBF extension.
Individual ID import/export is available for the following IDs:

- Table ID
- Allocation ID
- Leaf Characteristics ID
- Transfer Pricing ID
- Historical Rates ID
- Discount Rates ID
- Maturity Strategy ID
- Pricing Margin ID
- Forecast Rates ID
- Result Detail ID
- Transaction Strategy ID
- Forecast Balance ID
- Prepayment ID

The Individual ID method of import replaces an existing ID of that type in the import database. You cannot import an ID using the Individual ID method without replacing an existing ID.

**Caution:** If you do not want to lose any existing IDs, create a new ID of the type being imported or use Save As from the File menu to create a copy of the existing ID before import.

To import an ID, open the ID that you want to overwrite and select File -> Import.
Dependent ID Import/Export

IDs that contain other embedded IDs, such as Correction Processing ID, are imported and exported using the Dependent ID method. This method ensures that any dependent IDs required for correct operation of the exported ID are included in the export process.

Dependent ID import/export is available for the following IDs:

- Data Filter ID
- Tree Rollup ID
- Tree Filter ID
- Formula ID
- Correction Rule ID
- Correction Processing ID
- Group Filter ID

Any ID that is exported using the Dependent ID method creates a dBase file with the .CAT extension and one or more dBase files with extensions listed in the table below. Although the extensions differ from the standard .DBF, these files all use the dBase format. Importing these IDs requires that all files created in the export process reside in the same directory. Dependent ID import/export uses the following file extensions:

<table>
<thead>
<tr>
<th>ID or Data Type</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Catalog of IDs</td>
<td>.CAT</td>
</tr>
<tr>
<td>Filter ID</td>
<td>.FLT</td>
</tr>
<tr>
<td>Report Leaves</td>
<td>.LF</td>
</tr>
<tr>
<td>Level Description</td>
<td>.LEV</td>
</tr>
<tr>
<td>Node Description</td>
<td>.NOD</td>
</tr>
<tr>
<td>Report Columns</td>
<td>.RCL</td>
</tr>
<tr>
<td>Correction Rule ID</td>
<td>.COR</td>
</tr>
<tr>
<td>Error Assignments</td>
<td>.ASS</td>
</tr>
<tr>
<td>Correction Processing ID</td>
<td>.PRC</td>
</tr>
<tr>
<td>Tree Filter ID</td>
<td>.TFT</td>
</tr>
<tr>
<td>Tree Rollup ID</td>
<td>.ROL</td>
</tr>
</tbody>
</table>
If a tree rollup ID that contains leaves not in leaf setup is imported, you receive a warning. If you elect to continue, the ID is imported but the leaves are not added to the leaf setup. You can use the Synchronize Instruments function to synchronize the Rollup ID with the leaf setup.

**Group Import/Export**

Use the Group Import/Export dialog box to import or export multiple IDs of various types. To import or export a batch of IDs, perform the following steps:

1. From the File menu, select Group Import/Export.

   The Group Import/Export dialog box appears. The Group Import/Export dialog box resembles a spreadsheet, where each row represents one import or export operation.

2. Click Insert Rows without highlighting any rows to add a row to the top of the spreadsheet.

   If any rows are highlighted, selecting Insert Rows adds an equivalent number of rows immediately before the highlighted section.

3. Click Delete Rows to remove any highlighted rows from the spreadsheet.

   If no rows are highlighted, selecting Delete Rows removes the first row from the spreadsheet.

You can use the Group Import/Export columns as follows:

<table>
<thead>
<tr>
<th>ID or Data Type</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formula ID</td>
<td>.FOR</td>
</tr>
<tr>
<td>Group Filter ID</td>
<td>.FGL</td>
</tr>
</tbody>
</table>

**Note:** If a dependent ID import fails during processing, change the file name extension from .DBF to its original form and extension and reprocess.
Importing and Exporting Data

Overview of IDs

From the Process menu, select Run to run Group Import/Export.

OFSA processes the rows on your spreadsheet in sequential order, starting with the first row.

Export an ID with Group Import/Export

To export an ID using the Group Import/Export dialog box, perform the following steps:

1. Select Export in the Action list.
2. Select the ID Type and ID Name you want to export.
3. Double-click in the PC File Name cell to display the Select Export File dialog box.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Column Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Done</td>
<td>As IDs are imported or exported, a red check mark appears in the dialog box indicating that the job is complete.</td>
</tr>
<tr>
<td>Action</td>
<td>Click Import or Export for each ID on your list.</td>
</tr>
<tr>
<td>File Type</td>
<td>The only file type that you can select for Import or Export is dBase.</td>
</tr>
<tr>
<td>ID Type</td>
<td>Use the list to select ID types available for import or export.</td>
</tr>
<tr>
<td>ID Name</td>
<td>Use the list to view previously selected ID types. This field is active when exporting an ID or when importing an ID with the Individual ID method. When importing with the Dependent ID method, &lt;not required&gt; appears in the dialog box.</td>
</tr>
<tr>
<td>PC File Name</td>
<td>Double click in this field to open Select Import File if you are importing an ID or Select Export File if you are exporting an ID.</td>
</tr>
</tbody>
</table>
4. Type a valid file name for the export and click OK.
   Individual ID exports must use .DBF as their file extension. Dependent ID exports must use .CAT as their file extension. If the file name that you have selected is not valid, you must select a new file name.

5. From the Process menu, select Run to run Group Import/Export.
   OFSA processes the rows on your spreadsheet in sequential order, starting with the first row.
   If the export file name that you have chosen already exists and the file is not read-only, you are asked if you want to overwrite the existing file.

6. Click Yes to replace the existing file with your export file.

7. Click No to cancel the export process and select a different name for your export file.

Export an ID from the File Menu
To export an ID using the Export option in the File menu, perform the following steps:

1. Open the ID that you want to export.
2. From the File menu, select Export.
   The Export ID dialog box appears.
3. Click Browse to bring up the same Select Export File dialog box used for exporting with Group Import/Export.

4. Type a valid file name in the export data File Name dialog box.

5. Click OK to export your ID.

**Import an ID with Group Import/Export**

To import an ID using the Group Import/Export dialog box, perform the following steps:

1. From the File menu, select Import/Export Group.
   
   The Group Import/Export dialog box appears.

2. Click Import in the Action dialog box.

3. Select the ID Type of the ID that you want to import.

4. If the ID Type that you select relies on the Individual ID import method, select an existing ID to overwrite in the ID Name dialog box.

   If the ID Type you select relies on the Dependent ID import method, <not required> appears in the ID Name dialog box.

5. Double-click in the PC File Name dialog box.

   The Select Import File dialog box appears.

---

**Caution:** Individual ID import overwrites the ID listed in ID Name with the contents of the imported ID. As a result, you lose any information contained in the ID being overwritten. If you do not want to lose any existing IDs, create a new ID of the type being imported or use Save As from the File menu to create a copy of the existing ID before import.
The Select Import File dialog box looks and functions almost the same as the Select Export File dialog box. The primary difference is in the file name validity check that is performed before you are returned to the Group Import/Export dialog box. A file name is valid only if it has the necessary file extension, .DBF for Individual ID imports and .CAT for Dependent ID imports, and if it is found in the designated directory. If a file does not have the necessary file extension, or if it is not found, you must select a new file name.

If you import an ID that uses the Dependent ID method, you are importing the original ID along with any embedded IDs used in its functionality. You import these IDs with the same <Name>/<Group> combination that they had in the original database.

6. From the Process menu, select Run to process all the rows on your Group Import/Export spreadsheet.

If any of the <Name>/<Group> combinations for the IDs you are importing (or for any IDs embedded in your imported IDs) are already being used in your import database, the Import Warning dialog box appears. The Import Warning dialog box offers you three options of how to proceed when the ID you are importing or one of its dependent IDs already exists in your import database:

- Rename
  To change the <Name>/<Group> combination of the ID that you are importing so it does not conflict with any IDs already present in the import database. After typing a new <Name>/<Group> combination for the ID that you are importing, click OK to continue with the import.

- Use Existing
To use the existing ID in the database with the same <Name>/ <Group> combination as the ID that you are importing. You can use Use Existing when you need to import multiple IDs that share one dependency ID.

- **Cancel**

To cancel the import process. Selecting Cancel before all the rows in the Group Import/Export dialog box have been processed generates the Import Warning dialog box.

Click Yes to stop the Group Import/Export process. Click No to skip the current row on the Group Import/Export dialog box and continue processing the subsequent rows in sequential order.

In either case, all IDs imported prior to your clicking Cancel remain in the import database.

**Import an ID from the File Menu**

To import an ID using the Import option in the File menu, perform the following steps:

1. Open the ID that you want to import.

2. From the File menu, select Import.

   The Import ID dialog box appears.

3. Click Browse to bring up the same Select Import File dialog box used for importing with Group Import/Export.

4. Type a valid file name in the import data File Name dialog box.

5. Click OK to import your ID.

---

**Caution:** Individual ID import overwrites the ID listed in ID Name with the contents of the imported ID. As a result, you lose any information contained in the ID being overwritten. If you do not want to lose any existing IDs, create a new ID of the type being imported or use Save As from the File menu to create a copy of the existing ID before import.
If your import uses the Individual ID method, you overwrite the open ID with the contents of the ID you are importing. As a result, you lose any information contained in the ID being overwritten.

6. If you encounter the Import ID dialog box, refer to the end of the previous section, "Export an ID with Group Import/Export", for instructions on how to proceed.

Rules, Limitations, and Hints

The Import/Export function is limited in scope. Keep in mind the following rules and limitations:

- If an ID is imported and the <Group> it was created in does not exist in the import database, the ID is placed in the default <Group> specified in the Configuration ID.

- Group Import/Export works only between databases that have identical structures. Different versions of the applications may use different database structures.

- Correction Processing IDs using the OFSA Cash Flow Edits cannot be imported. When importing an ID of a given type, at least one ID of that type must already exist in the database or the import fails. No error message is displayed.

Note: Some .DBF files may require structural changes to import correctly into your FDM database. Before importing a non-OFSA .DBF into a particular database, export a similar type of ID to .DBF from that database. In your external database application, compare its structure to the non-OFSA file you want to import. Correct any structural differences in the non-OFSA file, and try the import it. If you experience problems, contact Oracle Support Services.
OFSA ID Dependencies

OFSA IDs often depend on other IDs for some or all of their data or usefulness. For example, a Transformation ID may depend on a particular Filter ID to select and focus data in a meaningful way. The Filter ID may have been created especially for that transformation and named in the transformation set up dialog box when the Transformation ID was created. If that Filter ID is deleted, then the transformation becomes unusable.

Caution: Consider OFSA ID Dependencies when you delete an ID. Deleting an ID may deprive a dependent ID of its meaning.

OFSA provides a Dependencies option in the File menu that enables you to view the dependencies factors of any active ID. This option shows both primary and secondary dependencies. For example, a Data Filter ID dependency may include a Processing ID as a primary dependency and a Batch ID as secondary dependency (depending on the Processing ID).

Also, when you click Delete ID or Delete Group of IDs, OFSA automatically checks for any dependencies, and enables you to review them before the deletion takes place. When you attempt to delete an ID, however, note that only primary dependencies are listed in the warning.

Note: Click Dependencies from the File menu if you plan to delete unfamiliar IDs.

Processing an ID

To process an ID, select Run from the Process menu. In most cases, the process proceeds immediately, without further prompting from the system.
Server Status

Most OFS applications can launch calculation-intensive software processes on a server. The server runs the process in the background, freeing the client PC to do other activities. Also, the server is often more powerful and can finish the process more quickly than the client PC.

When a server process is launched by an OFS application, the job request first is processed by RQ, the special OFS application that monitors OFSA server processing. RQ enters the job in a special table, and sends the job to the server. RQ then monitors the progress of the job on the server until it has completed, logging that information in its table.

When an OFS application launches a server job, the Server Status Update dialog box appears. Getting its data from RQ, the dialog box displays the progress of your server jobs or, optionally, displays all jobs on the server. Also, you can terminate any of your processes that are running on the server.

In Oracle Financial Data Manager (FDM) Administration, the capabilities of the Server Status Update dialog box have been expanded. The Server Status Update dialog box:

- enables you to terminate any job running on the server, not just those jobs you have launched yourself
- incorporates a test function to validate the ADMN - RQ - SERVER links
- provides a housekeeping capability, enabling you to delete completed jobs from the RQ table

Using the Server Status Update Dialog Box

To open the Server Status Update dialog box, select Server Status from the Process menu. The Server Status Update dialog box appears.

View your jobs or all

- See your jobs
  Select this option to view the status of your own server jobs.

- See all jobs
  Select this option to view the status of all jobs running on the server.
Stop Job
Select any of your own server jobs, and click this option to stop it. This function is not a Pause. Once stopped, the job cannot be continued. You must restart it from its source application. This option does not cancel jobs that have not begun execution.

**Note:** In this OFS application, the Server Status Update dialog box enables you to stop your own server jobs only. In Oracle Financial Data Manager (FDM) Administration, the dialog box enables you to cancel any job running on the server.

Insert Test Request
This option starts a simple job to ping the server, testing network connections and protocols. Click Stop Job to halt the test, and click Remove YOUR Finished Jobs to delete the job from the display. If the test fails, the Cannot Launch Request error message appears.

Remove YOUR Finished Jobs
Select this option to delete all finished jobs from the display. The Request Clean Up verification box appears when the jobs have been removed. You click OK to close it.

**Caution:** Selecting Remove YOUR Finished Jobs does not halt processing of a server job in progress. The job is deleted from the display (and from the RQ table) but continues to run to completion on the server.

Server Polling Indicator
At the left side of the dialog box is a blue wheel that moves up and down the dialog box. The wheel indicates that OFSA is polling the database.
The Status Display

Through this interface you can monitor active server jobs.

<table>
<thead>
<tr>
<th>Interface</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Description</td>
<td>Name of the ID being processed</td>
</tr>
<tr>
<td>Table Name</td>
<td>Name of the table being processed against</td>
</tr>
<tr>
<td>Step/Page</td>
<td>Step or Page being processed</td>
</tr>
<tr>
<td>Host</td>
<td>Not currently implemented</td>
</tr>
<tr>
<td>Record</td>
<td>Number of records being processed</td>
</tr>
<tr>
<td>User</td>
<td>User’s login name</td>
</tr>
<tr>
<td>Title</td>
<td>Description or status of the process</td>
</tr>
<tr>
<td>Status</td>
<td>Indicates whether or not the job has completed</td>
</tr>
<tr>
<td>Job Return Status</td>
<td>Indicates successful process or an error code. Possible return codes include:</td>
</tr>
<tr>
<td></td>
<td>- Making request (Indicates that the client has made a request to the server, but it has not yet been acted upon)</td>
</tr>
<tr>
<td></td>
<td>- No INI found (Indicates that, on startup, the server process could not find the server ini file. This file should be located in the same directory as RQ (usually /bin/rq under the OFSA install directory). Either the file does not exist (being deleted or moved after RQ started) or it is not readable (someone changed the modes on the file)</td>
</tr>
<tr>
<td></td>
<td>- None: Running (Job is currently running)</td>
</tr>
<tr>
<td></td>
<td>- Failed on Fork (Normally indicates that RQ was unable to execute the requested application. This can occur if the path in the server ini file is incorrect (for example, the OFSA software suite is not installed normally or is moved after it is installed). This message could also indicate that the permissions on the executable are incorrect.)</td>
</tr>
<tr>
<td></td>
<td>- None: Canceled (Indicates the process has been canceled, either from the client or from the server, with signal 1, 2, or 15 (SIGHUP, SIGHUPTR, or SIGTERM, respectively).)</td>
</tr>
<tr>
<td></td>
<td>- Job Return Number (Job returned an unrecognized status)</td>
</tr>
<tr>
<td></td>
<td>- Normal (Indicates the job terminated normally)</td>
</tr>
</tbody>
</table>
Server Status

<table>
<thead>
<tr>
<th>Interface</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bad Usage</td>
<td>(Indicates that the subprocess failed to start because the parameters were not passed correctly. With the current releases of OFSA, this should not happen.)</td>
</tr>
<tr>
<td>Session Failure</td>
<td>(Indicates that the application was not able to create a session. Check the server log file for additional information.)</td>
</tr>
<tr>
<td>No memory</td>
<td>(Indicates that the server application ran out of memory)</td>
</tr>
<tr>
<td>Internal Error</td>
<td>(Indicates that some error occurred within the server application. This is normally a database error. Check the server log file for additional information.)</td>
</tr>
<tr>
<td>Connect Failure</td>
<td>(Indicates that the server process was unable to connect to the database. An incorrect user/password is probably the reason. Check the log file for more information. This can occur if the password is changed after starting up the application but before running a server process.)</td>
</tr>
<tr>
<td>Rights Violation</td>
<td>(Indicates that the specified user does not have the proper rights to run the program. This can occur if an administrator changes the rights for a user after the user started a client application but before the server application is launched.)</td>
</tr>
<tr>
<td>Signaled: &lt;number&gt;</td>
<td>(Indicates that the process stopped running due to a signal. Check the log file for additional information. The number shown is the negative of the number that caused the process to halt. The most common number is -11.)</td>
</tr>
</tbody>
</table>

Request Date: Date and time when request is inserted into OFSA Request Queue. The date and time are from the client PC.

Start Date: Date when OFSA Request Queue launches process.

Start Time: Time when OFSA Request Queue launches process.

End Date: Date and time when process completes.

Priority: Processing priority in order of importance or urgency.
Changing a Password

To change your password, perform the following steps:

1. From the Options menu, select Change Password.
   The Change Password dialog box appears, with your login name (such as the name of the current Oracle Financial Data Manager (FDM) Administration user) at the top.

2. Type your current password.
   For security reasons, asterisks appear instead of the characters you type.

3. Type your new password, and then click OK.
   You are prompted to confirm the new password.

4. Retype the password exactly as you did the first time.

5. Click OK when you are done, or click Cancel at any time to close the Change Password dialog box and return to the main window.

**Note:** OFSA passwords are case-sensitive. When you log on to the database via any OFS application, you must type your password exactly as you typed it here.

Spreadsheet Control Bar

The Spreadsheet Control Bar, available through the Stratification ID, automatically calculates and enters incremental ranges of data into your spreadsheets, such as for interest rates or amounts. The Spreadsheet Control Bar offers five incremental methods for automatically calculating ranges of data.

Increment Methods

Following are descriptions of the five Increment Methods and their uses:

**Increment by Value**

The increment is applied as a constant value amount (such as 1.00 or -1.50) that is cumulatively added to the value of the Start Value. Type an Increment Value and then click Run.
**Increment by Percent**

The increment is calculated as a cumulative percentage increase over the Start Value (with 100 percent specified by the value 100). Type an Increment Value and then click Run.

**Add to by Value**

A constant amount is added to the current value of each of the values in the ID. (For example a value of 1.5 adds 1.500 percent to each value.) This increment does not accumulate. Type an Increment Value and then click Run.

**Add to by Percent**

Each value is increased by a constant percentage over its current value (with a 100 percent increase specified by the value 100). This increment does not accumulate. Type an Increment Value and then click Run.

**Interpolate**

Interpolate inserts into the **From/To** columns an evenly-divided series of values calculated between a Start and End value, leaving the selected first and last row values intact. Type a **Start Value** and an **End Value** and then click **Run**.

When the interpolation is Run, the results are as follows:

<table>
<thead>
<tr>
<th>From</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>-9999999999.99</td>
</tr>
<tr>
<td>2</td>
<td>0.00</td>
</tr>
<tr>
<td>3</td>
<td>16.67</td>
</tr>
<tr>
<td>4</td>
<td>23.33</td>
</tr>
<tr>
<td>5</td>
<td>30.00</td>
</tr>
</tbody>
</table>
The interpolated values from the 10-to-30 range are evenly distributed between the original values of 0 (selected row 2) and 30 (selected row 5). The To column values also have been correctly interpolated.

Interpolation in Auto Increment

Interpolation enables you to create interpolated buckets based on a start- and end-value. This method does not update the end value specified in the Auto Increment dialog box, however. You must manually enter that value.

Increment a Range of Values

To automatically increment a range of values, perform the following steps:

1. From the horizontal tool bar, click the Spreadsheet Control Bar icon to open the Control Bar.

   Note: You can move the dialog box to another, perhaps more convenient, location on your window. Place your mouse pointer in the Control Bar’s title bar, and hold the left mouse button while you drag the dialog box to a new location.

2. Select a range of values in the spreadsheet.

   In the Control Bar, the value from the first row in your selected column is transferred to the Control Bar’s Start Value dialog box:
The Method list is at the top of the Control Bar. It displays Inc by Value when it becomes active. From the Method list, you can open a list of five increment Methods.

3. Select the increment method that you want to use and then click Run from the Process menu.
When you need to edit or verify the data in a database, you often need to view that data at the lowest level possible: the row and column level. The Data Verification ID enables you to define the specific table, columns, and rows you want to view.

The results of the Data Verification ID appear in the form of a virtual spreadsheet that displays a maximum of 32,000 records. Because databases may be much larger than this, you should use predefined Data Filter IDs to narrow your focus on the database. Refer to Chapter 7, "Data Filter ID" for instructions on how to create a Data Filter ID.

This chapter discusses the following topics:

- Creating and Defining a Data Verification ID
- Running a Data Verification ID
- Editing a Data Verification ID
- Reviewing a Data Verification ID Example

Creating and Defining a Data Verification ID

Use the following instructions to create and define a Data Filter ID. See Chapter 3, "Overview of IDs" for further explanation about ID creation and maintenance.

To create a Data Verification ID, perform the following steps:

1. From the File menu, select New -> Data Verification ID to display the New Data Verification ID dialog box.
2. Type name for the ID in the Data Verification ID field.
3. Type a description for the ID in the Description field.
4. Select the permissions for the ID.
5. Click OK to continue or Cancel to exit.

The Data Verification ID dialog box appears.

6. From the Table Types list, select the type of table with which you want to work.
   Your selection determines which tables are available in the Tables list.
7. From the Table list, select the table with which you want to work.

   **Note:** The Data Verification ID does not support Risk Manager result detail tables.

8. From the Filter ID list, select the Data Filter ID or Group Filter ID for the subset of data you want to view.

   **Note:** The virtual spreadsheet displays up to 32,000 records. If the records you want to view are outside this range, you must refine your filter (Data Filter ID or Group Filter ID) to narrow the focus of your view.

9. Select up to three columns in the Sort By box to define the sort order you want.
10. In the Columns box, select the columns you want to include in your view and click Add.
The columns move to the Defined View box.

- To add all the columns to the Defined View box, click Select All and then click Add.
- To delete a column from the Defined View, select the column and click Remove.
- To remove all the columns from the Defined View, click Remove All.

**Note:** If a column name contains a substring that includes the name of another column (such as, Remaining Term and Remaining Term Multiplier), then you must add the column with the shorter name to the defined view first.

11. Use the arrows next to the Defined View box to organize the columns in the order you want to see them.

   Each click of an arrow moves the selected columns one position. Raising a column in the list moves it to the left in the spreadsheet.

12. Save the ID.
Running a Data Verification ID

To view the results of your Data Verification ID definitions, complete the following steps:

1. Select the Run option from the Process menu.
2. Review the results.

Edit Spreadsheet On/Off

The Edit spreadsheet On/Off option is available only in Oracle Financial Data Manager Balance and Control. If this feature is on, you can edit the data at row level. The yellow pencil icon with the red X over it indicates that the Oracle Financial Services (OFS) application does not allow editing.

What the Results Show

In the View window, all values display as they are stored in the database. For example, the view displays code values numerically, not with the code value translation. This is essential for quality control of the data. If you have invalid codes, simply displaying an invalid code description is not sufficient. The actual code value is necessary for determining the source of the problem.
Editing a Data Verification ID

To edit a Data Verification ID, perform the following steps:

1. From the File menu, select Open -> Data Verification ID.
   The Select Data Verification ID dialog box appears.
2. Select the Folder and Data Verification ID you want to edit.
3. Make your desired changes.
4. Save the ID.

Reviewing a Data Verification ID Example

This example creates a Data Verification ID to verify the margins on adjustable rate mortgages. To include only adjustable rate mortgages in the table view, you must first create a Data Filter ID (MTG_ARM) that meets these characteristics. See "Data Filter ID" in Chapter , "Reviewing a Data Filter ID Example" for instructions on creating the Data Filter ID for this example.

To create the Data Verification ID, perform the following steps:

1. Select New -> Data Verification ID.
2. Select <ALL> for Folder.
3. Type ADJ_RT_MTG_MAR in the Data Verification ID field.
4. Type Verify Adj Rt Mtg Margins as the description.
5. Select Read/Write for Security.
6. Click OK.
   The Data Verification ID dialog box appears.
7. Select Client Data Tables Table type.
8. Select the Mortgages table.
9. Select Interest Rate Code, Product Type Code, Margin, and Current Gross Rate from the Columns box.
10. Click Add to include these columns in the Defined View box.
11. In the Filter box, select MTG_ARM.
12. Select Interest Rate Code from the first Sort By box to view the margins based on the interest rate code.

13. Run the Data Verification ID to view and verify the results.
With the Correction Rule ID, you define rules to correct data or assign values to columns within instrument tables. You select the instrument table and columns targeted for changes, filter out (select) the targeted records, and specify what the correct data should be.

A Correction Rule ID is processed through the Data Correction Processing ID, which can process multiple Correction Rule IDs in a batch. See Chapter 6, "Data Correction Processing ID" for more information.

The Logical Hierarchy

When defining a correction rule, you organize the components of the rule into a logical hierarchy. Think of the logical hierarchy as a tree structure, where rule components at the same level are branches off the same node, and rule components at the next level of indentation are lower nodes in the tree.

In the Logical Hierarchy pane of the Correction ID window, you may start with a product such as all commercial loans, for which you want to assign new values for fixed loans and loans pegged to the LIBOR and Prime rates. You type these
descriptive labels in the box above the Add button and add each label into the hierarchy. The labels may describe the correction you are making, for example, “Bad Current Rate” or “Maturity Date in the Past.” The directional arrows above the Logical Hierarchy area reorder the sequence and create levels in the hierarchy. You can add up to 100 nodes in a hierarchy.

The Otherwise Branch

When you add a new level, an Otherwise branch is automatically added to catch records that do not fall into one of the sibling branches. As you define the Correction Rule ID, you are creating If...Then...Otherwise sequences.

Levels of Indentation (Branches)

The level of indentation in a data correction rule affects how the rule is processed:

- Branches in the decision tree at the same level (siblings) are separated by an implied OR condition; however, the first rule that is true is the only rule executed.
- A branch in the tree assumes all of the filter criteria specified for its parent. In other words, an indented branch is joined to its parent by an implied AND condition.

Removing Levels

With the exception of the first level, levels can be removed from the hierarchy without deleting the levels defined below. All levels below move up one level. However, removing the first level deletes everything below it.

Directional Arrows

Click the directional arrows to reorder, indent, and outdent entries in the list of branch labels in the Logical Hierarchy area, subject to the following rules:

<table>
<thead>
<tr>
<th>Direction</th>
<th>Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up</td>
<td>You can move a node up if it is not the first sibling at any level. All children of the selected level also move up.</td>
</tr>
<tr>
<td>Down</td>
<td>You can move a node down if it is not the last sibling at any level. All children of the selected level also move down.</td>
</tr>
<tr>
<td>Left</td>
<td>You can move a node to the left if it has a parent and is the last child. All children of the selected level also move left.</td>
</tr>
<tr>
<td>Right</td>
<td>You can move a node to the right if it has a sibling directly above it. All children of the selected level also move left. You cannot move a branch underneath a leaf level without erasing the column assignment.</td>
</tr>
</tbody>
</table>

Data Filtering and Column Assignments

For each level in the hierarchy, the Filter and Assignment pane of the Correction Rule ID window shows the following:

1. The tables you select for data correction
2. The columns you select for data correction
3. The correct data you want to write to the database (for the last level only)

Data Filter

Clicking the Data Filter button produces the Filter ID window, where you select the table and columns to filter on.
For each branch in the hierarchy, you define filter criteria in the Filter ID window. Blank nodes in the correction hierarchy are assumed to be false, except for the last Otherwise node in a logical hierarchy, which defaults to true. See Chapter 7, "Data Filter ID" for more information about defining filter criteria.

After a correction rule finds a true condition and updates a row, the rule moves to the next row in the table (that is, the rule does not look for another true condition in the same row). You are not restricted from changing key fields such as org units and product leaves. Balance and Control does not provide an audit trail when key fields are changed. Exercise caution when changing key fields in the database.

**Column Assignment**

From the Column Assignment button on the Correction Rule ID window, you select the tables and columns you want to make changes to. You specify assignment criteria for the lowest nodes only (that is, nodes with no children) in the Column Assignments window.
Data Filtering and Column Assignments

For each column name in the Edit Columns list, you must specify what the column value should be changed to, in the Assignment Type pane, and how the error log should be updated, in the Error Assignments pane.

**Assignment Type**
The Assignment Type list offers five methods for changing values in the database.

<table>
<thead>
<tr>
<th>Assignment Method</th>
<th>Description</th>
<th>User Input</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Assignment</td>
<td>Column is not replaced. This selection allows writing a message only.</td>
<td>Select an appropriate error message (codes greater than or equal to zero).</td>
</tr>
<tr>
<td>Direct Input</td>
<td>Column is replaced with a constant value defined in the interface.</td>
<td>Type the new value in the box below the assignment type.</td>
</tr>
<tr>
<td>Set to Column</td>
<td>Column is replaced with the value from another selected column of the same data type.</td>
<td>Select the database column from the list.</td>
</tr>
</tbody>
</table>
There are two boxes under the Assignment Type box. The upper box displays “Set” and then the table and column name. For example, if you are changing the Current Net Rate column of the Mortgages table, you see “Set Mortgages_Current Net Rate.” The lower box displays different information depending on the assignment method. If you selected Formula, a list of all the Formula IDs appears. If you selected Direct Input, type a value in the lower box.

**Error Assignments**

You have the option of assigning an error message to any column assignment, thereby logging an entry into an error message table named OFSA_PROCESS_ERRORS. For severity codes 1 or 2, select the appropriate error message from the list of messages.

The maximum number of error messages written to OFSA_PROCESS_ERRORS is determined by a Configuration ID setting. If you are planning to run the correction rule using the Bulk Update option, only the number of times a specific error occurs (as opposed to a complete audit trail) is written to OFSA_PROCESS_ERRORS.

Every time a correction is made, the OFSA_PROCESS_ERRORS table is updated with information such as the table and fields updated, the corrected values, and the assigned severity code.

When Assignment Columns from a Correction Rule are written to the OFSA_PROCESS_ERRORS table, the ID_NUMBER field holds ID_NUMBER if it is part of the unique index for that table. Otherwise, it holds the value from the first field of the unique index (for example, for MORTGAGES this is Identity_Code).
The error assignment function has three possible values: 0, 1, and 2. Values 1 and 2 are assignable in the Column Assignments window. Zero is not assignable. Error values greater than 0 are written to the OFSA_PROCESS_ERRORS table. If the error value is equal to 0, the correction is made, but no notation is recorded in the OFSA_PROCESS_ERRORS table. The assignable messages are stored in the table OFSA_CORRECTION_PROCESS_MSG_DSC. The OFSA_CORRECTION_PROCESS_MSG_DSC table contains the following columns:

<table>
<thead>
<tr>
<th>Column</th>
<th>Holds</th>
</tr>
</thead>
<tbody>
<tr>
<td>ERROR_CODE</td>
<td>a unique error code number for each message</td>
</tr>
<tr>
<td>ERROR_MESSAGE</td>
<td>the text message listed for each error code</td>
</tr>
<tr>
<td>ERROR_SEVERITY</td>
<td>the severity levels 1 and 2</td>
</tr>
</tbody>
</table>

Using SQL, you can insert a row with a new error message if you want.

**Running the Correction Rule ID**

When you run the Correction Rule ID, statistical information is displayed, but the database is not changed unless you run the rule in a Data Processing Correction ID.

![Data Correction Rule Statistics](image)

**Defining a Correction Rule: An Example**

Assume your database contains commercial loan records with a current net rate of zero. These records should be corrected so that they are correctly assigned to either
the Prime rate or the 3 Month Treasury rate, which is determined by the interest rate code value.

**Creating a New Correction Rule ID**

To define a new Correction Rule ID, do the following:

1. From the File menu, select New -> Correction Rule ID.
2. In the New Correction Rule ID window, do the following:
   - For Group, select All.
   - In Correction Rule ID (name), type **COMM_ZERO_RT**.
   - In Description, type **Chg net rt=0 to IRC**.
   - Click Read/Write and click OK.

**Defining the First Level**

To define the first level, commercial loans, do the following:

1. Click in the box above the Add button, type **Coml Loans w/0 Int Rt**, and click Add.
   
   An Otherwise branch is automatically created to catch records that do not meet the logic of the Coml Loans branch.

2. Click Data Filter.
3. In the Filter ID window, select Commercial Loan from the Table list.
4. From the Columns list, select Current Net Rate and click Add.
5. In the Defined Filter list, click Commercial Loan.Current Net Rate.
6. From Filter Type, select Specific_Values.
7. In the Values box, type **0.0000**.
8. Click Include These Values.

Your window should look like this:
Defining the Second Level

To define the second level, consisting of two branches—Prime and 3 Month Treasury—do the following:

1. In the box above the Add button, type Int Rt Code=Prime and click Add.
2. Click the right arrow.
3. In the box above the Add button, type Int Rt Code=3moTreas and click Add.

Defining the Data Filters

To define the data filters for the Prime and 3 Month Treasury branches, do the following.

1. Click Int Rt Code=Prime.
2. Click Data Filter.
3. In the Filter ID window, do the following:
   - From Table, select Commercial Loan
   - From Columns, select Interest Rate Code and click Add
   - Click Commercial Loan.Interest Rate Code in the Defined Filter list
   - For Filter Type, select Code_Values
   - In Unselected Codes, select Prime and click Add
   - Click Include These Codes
4. Click OK to return to the Correction Rule ID window.
5. Click Int Rt Code=3moTreas.
6. Click Data Filter.
7. In the Filter ID window, do the following:
   - From Table, select Commerical Loan
   - From Columns, select Interest Rate Code and click Add
   - Click Commercial Loan.Interest Rate Code in the Defined Filter list
   - For Filter Type, select Code_Values
   - In Unselected Codes, select 3 Month Treasury and click Add
   - Click Include These Codes and click OK

Defining the Column Assignments

To define the column assignments for the Prime and 3 Month Treasury branches, do the following.
1. Click Int Rate Code=Prime.
2. Click Column Assignment.
3. In the Column Assignments window, do the following:
   - From Instrument (Table), select Commercial Loan
   - From Columns, select Current Net Rate and click Add
   - From Assignment Type, select Direct Input
   - In the box below Set Commercial Loan.Current Net Rate, type 6.0000
Defining a Correction Rule: An Example

I. Skip the Error Assignments area for this example (leave Severity at zero)

4. Click OK to return to the Correction Rule ID window.

5. Click Int Rt Code=3mo Treas.

6. Click Column Assignment.

7. In the Column Assignment window, do the following:
   - From Instrument (Table), select Commercial Loan
   - From Columns, select Current Net Rate and click Add
   - From Assignment Type, select Direct Input
   - In the box below Set Commercial Loan.Current Net Rate, type 4.0000
   - Skip the Error Assignments area and click OK

8. From the File menu, select Save.

The Correction Rule Completed

Your correction rule is now saved and ready to run, either alone or with other correction rules, from a Data Correction Processing ID. See Chapter 6, "Data Correction Processing ID" for more information.
The Data Correction Processing ID enables you to simultaneously correct multiple columns in a user-specified instrument table, using previously defined Correction Rule IDs. Think of a Data Correction Processing ID as a data edit routine, with the edit rules defined in the selected Correction Rule IDs.

Components of the Correction Processing ID

The Correction Processing ID window contains the following components:

- **Table**: From the list, select the instrument table affected by the ID.
- **Description**: If a description of the ID was entered when the ID was created, it is displayed here. Use this edit box to create or change the description of the purpose of the ID.
- **Filter Type**: If you want to apply the correction rules to selected rows in a table, select the type of filter—Data, Group, or Tree—from the list. Select None if you want to edit all rows in the selected table.
- **Filter**: From the list, select previously defined Filter IDs.
- **Rule Base**: All previously defined Correction Rule IDs are displayed. Select and add one or more rules to the Selected Rules box.
- **Selected Rules**: These are the rules selected for processing. The rules are processed in the order listed. You can change the order with the up and down arrows.
Run Process On  Smaller jobs can be processed on your local workstation (the client). However, larger jobs can tie up the workstation for long periods. For larger jobs, choose the server. Processing takes place on the server, freeing your workstation for other tasks.

Update Records  You have the option of processing correction rules individually or in bulk. Most of the time, processing individually is preferable. See “Updating Records Individually or In Bulk” in this chapter for more information.

Preview  When you click Update Log Only, the ID is executed without changing the client data. You can preview the changes, assuming the severity code is greater than zero, in PROCESS_ERRORS. After you preview the changes, rerun the ID the Preview option unchecked. See "Error Assignments" in Chapter 5, "Correction Rule ID" for more information about the messages logged in PROCESS_ERRORS.
Ordering the Selected Rules

Within the Data Correction Processing ID, correction rules are processed in the order shown in the Selected Rules box. Calculations embedded in correction rules (by selecting a Formula ID during column assignment) are processed in the order of the correction rules also. See "Assignment Type" in Chapter 5, "Correction Rule ID" for more information on using Formula IDs within correction rules. An example depicting the importance of rule order follows:

Example:

**Rule A**: Replace Column A with Column B * 100

**Rule B**: Replace Column C with Column A * 100

**Initial Values**:

- Column A = 0
- Column B = 5.00
- Column C = 0

**Values if Rule A is Processed before Rule B**:

- Column A = Column B * 100 = 500
- Column C = Column A * 100 = 500 * 100 = 50,000

**Values if Rule B is Processed before Rule A**:

- Column C = Column A * 100 = 0 * 100 = 0
- Column A = Column B * 100 = 500

As evidenced by the example, different results are obtained depending on rule order. Therefore, if there is interdependency of database columns in any of your correction rules, order is crucial to ensuring accurate results.
Updating Records Individually or In Bulk

You have the option of processing correction rules individually or in bulk. Most of the time, processing individually is preferable: it applies to individual correction rules, checking each row against the rule hierarchy and making corrections. Processing individually is an efficient choice for correction rules with two or more nodes and for running multiple correction rules in one Data Correction Processing ID.

When you choose the In Bulk option, SQL code performs a full table update rather than a row-by-row update. Processing in bulk generates update statements for each assignment column in the tree hierarchy and runs them against the specified instrument table. Processing in bulk is an efficient choice for simple correction rules, that is, rules with only one or two nodes where the same columns are corrected.

Processing correction rules through tables with large amounts of data takes several hours.

**Note:** If multiple columns are updated in a large table by one correction processing ID run in bulk, rollback space may be exceeded. This causes a processing error. To proceed, reduce the size of the correction rules or contact your system administrator to increase the rollback space. Then reprocess the correction rules.

Processing Considerations

When you run a Data Correction Processing ID, the following information is displayed:

- **Instrument:** Name of the instrument table being processed
- **Record:** Number of records changed and processed
- **# of Rules:** Number of rules being processed
- **Correction Time:** Time elapsed
- **Status:** Current status of processing

Press Cancel at any time to cancel the processing.
Dependency Checking

When you process a Data Correction Processing ID, you are prompted to check for interdependencies between correction rules. Choose Yes to check for dependencies or No to run the Data Correction Processing ID without checking for dependencies. If there are no dependencies, the following message appears:

There are No Dependencies in These Correction Rules.

It is a good idea to check IDs before running, but dependency checking is not necessary if the Data Correction Processing ID or the underlying Correction Rule IDs have not changed.

Defining a Correction Processing ID: An Example

In this example, you will run the correction rule, Comm_Zero_Rt, defined in the Chapter 5, “Correction Rule ID” exercise. This rule corrects commercial loans with erroneous current net rates of zero. The rule assigns either the Prime rate or the 3 Month Treasure rate, depending on the value of the interest rate code.
Creating a New Data Correction Processing ID
To define a new Data Correction Processing ID, do the following:
1. From the File menu, select New -> Data Correction Processing ID.
2. In the New Correction Processing ID window, do the following:
   - Select a Group
   - For the Correction Processing ID name, type Comm_Zero_Rate
   - Type a description
   - Click Read/Write
   - Click OK

Setting Up and Running the Data Correction Processing ID
1. In the Correction Processing ID window, select Commercial Loan from the Table list.
2. Select None for the Filter Type and Filter.
4. Click Add to move it to the Selected Rules box.
5. Click Client to process the ID on your PC.
6. From the File menu, select Save.
7. From the Process menu, select Run.

Editing a Data Correction Processing ID
To edit a Data Correction Processing ID, do the following:
1. From the File menu, select Open -> Data Correction Processing ID.
2. Select the ID you want to edit.
3. With the ID open, make your changes.
4. From the File menu, select Save. You can use the Save As option in the File menu to save the edited ID under a new name.
A Data Filter ID enables you to narrow the focus of your data for processing. It specifically targets the data you want to include or exclude for processing by another ID.

This chapter discusses the following topics:

- Creating and Defining a Data Filter ID
- Running a Data Filter ID
- Editing a Data Filter ID
- Using Data Filters on Multiple Tables
- Reviewing a Data Filter ID Example

Creating and Defining a Data Filter ID

To create a Data Filter ID, do the following:

1. From the File menu, select New -> Data Filter ID to display the New Data Filter ID dialog box.
2. Type the name for the ID in the Data Filter ID field.
3. Type a description for the ID in the Description field.
4. Select the permissions for the ID.
5. Click OK to continue, or click Cancel to exit.
6. Select the instrument to include in your Data Filter ID from the list of instruments. The instrument types are specific to your particular database. The three types of instruments are:

**Portfolio**

The Portfolio instrument type enables you to create a cross-instrument data filter. Portfolio fields are common to all instruments. All other instrument selections automatically narrow your focus to just that instrument type. If the filter criteria are the same for all instrument tables (for example, As of Date or Branch Code), you can use Portfolio as the instrument.

If the filter criteria are different for all applicable instrument tables (such as Current Net Book Balance), define the filter criteria for the first instrument table, and then select the next instrument table from the instrument list and define its criteria, and so on.

**Multiple tables**

The Multiple Tables type instrument enables you to create a single data filter on multiple instrument tables. You must define the filter criteria for each instrument.

**Formula**

The Formula instrument type enables you to filter data against a selection derived from a predefined Formula ID.
7. Type or change the description of the purpose of the Data Filter ID.

8. Select one or more columns from the Columns box, and click Add to copy your selections to the Defined Filter box.

The Defined Filter box displays the columns that you use to define filter criteria. To remove a column from the Defined Filter box, select it and click Remove. To remove all the columns, click Remove All.

9. Click on the first column in the Defined Filters box and select the Filter Type appropriate for that column. Then, enter the criteria appropriate for that column in the lower part of the dialog box. Repeat this step for each column in the Defined Filter box. See "Defining Filter Types and Criteria" in the following section for an explanation of the different types of filters and criteria that you can use with Data Filter IDs.

10. Save the ID.
Defining Filter Types and Criteria

The filter criteria options appear on the lower half of the dialog box when you select a column in the Defined Filter box and select a Filter Type. The criteria options change depending on the column and the type of filter that you select.

Filter Type

The five filter types differ based on the type of column you select. If the column represents a code, you can select a filter type of Code Values, Another Column, or For-
mula ID. If the column represents a numeric field or date field (a non-code field), you can select a filter type of Ranges, Specific Values, Another Column, or Formula.

**Specific Values**
This filter type presents the Values column. You can enter up to 60 specific values.

**Ranges**
This filter type offers From and To columns to enter ranges. You can enter the number of ranges that you want directly or use the spinner arrows to change the number of ranges dynamically. You can enter a maximum of 60 ranges.

**Another Column**
This filter type compares the selected column to another column.

**Formula**
This filter type compares a column to a value derived from a Formula ID.

**Code Values**
This filter type enables you to define specific code values for selection.

The filter type determines what criteria characteristics appear for the column that you select.

**Filter Criteria**
Criteria options change depending on the Filter Type that you select. The data must meet the definitions that you define in the filter criteria for each selected column. Otherwise, the data cannot pass the filter. For example, you may have two columns defined as follows:

<table>
<thead>
<tr>
<th>Column</th>
<th>Filter Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Balance</td>
<td>&gt; 100,000</td>
</tr>
<tr>
<td>Current Rate</td>
<td>&gt; 8.00</td>
</tr>
</tbody>
</table>

These columns indicate that a record must have a Current Balance greater than 100,000 and a Current Rate greater than 8.00 in order to pass the filter.
Include/Exclude  After defining the specific Ranges or Values, you must choose whether you want to include or exclude the data that meets the defined criteria.

Operators  You use operators for the filter types Another Column and Formula. The choices are:
- =
- <>
- <
- >
- >=

After you have selected the operator, select the column or Formula ID as appropriate to complete the equation.

Code Values  When you select Code Values as the filter type, the codes for the selected column appear in the Unselected Codes box. You can use the buttons to identify the codes you want to include or exclude in the filter.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Moves the highlighted codes to the Selected Codes box</td>
</tr>
<tr>
<td>Remove</td>
<td>Moves the highlighted codes in the Selected Codes box to the Unselected Codes box</td>
</tr>
<tr>
<td>Select All</td>
<td>Moves all the codes to the Selected Codes box</td>
</tr>
<tr>
<td>Remove All</td>
<td>Moves all selected codes to the Unselected Codes box</td>
</tr>
</tbody>
</table>

Filter Criteria Rules
In order to get the results you want, you must define complete information in the Data Filter IDs. Complete information requires the following:
- Thorough Definitions

You must thoroughly define the criteria for each column that you include in the data filter. All values, ranges, other column names, and formulas must be complete. If you specify that you want to filter on five specific values and then complete only the criteria for the first one, you can still save that Filter ID. However, an error message appears if you try to run an ID that uses the incomplete Filter ID.
Order of Processing

You can control the order of the application of the filter criteria (such as the order of the Columns in the Defined Filter box) by using the directional arrow buttons to the right of the Defined Filter box.

---

**Note:** The end result of the filter is not dependent on the order of the application of the filter criteria. Each row must pass all criteria.

---

**Implied Filter Criteria**

Besides the filter criteria that you have defined, the following filter criteria may be automatically included in a process that you generate:

- **As of Date**

  Although the Oracle Financial Data Manager (FDM) database can contain data from an unlimited number of as-of-dates, most OFS applications automatically filter only those rows from the as-of-date that you define in the active Configuration ID.

- **Row Level Security**

  Your system administrator may limit the rows to which you have access.

---

**Null Values in the Database**

A null value in a column in the database is a column that has no data. You should take all necessary steps to avoid having null columns in the database for the following reasons:

- **Any null value accessed in a formula results in a null value.** For example:

<table>
<thead>
<tr>
<th>Column X</th>
<th>Column Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>150</td>
<td>null</td>
</tr>
</tbody>
</table>

  If we define a formula as X + Y, the answer is 150 + null = null. All operations (such as +, -, /, *, ^) are handled in this same manner.
You cannot define a filter to recognize null values. The Data Filter ID assumes that the database does not have any null values. Consequently, you cannot define a Data Filter ID to isolate all rows with a null value in a given column.

**Note:** Null <> 0, so filtering on 0 does not return rows with null values.

You can identify null values by using an SQL statement to select all rows WHERE <Column> IS NULL.

---

**Running a Data Filter ID**

Running the Data Filter ID generates an SQL statement but does not execute the statement. The application executes the SQL statement when you run an ID using the Data Filter ID.

To process a Data Filter ID, complete the following steps:

1. From the Process menu, select Run.
   
   The SQL statement that your Data Filter ID generates displays in a window.

2. Review the SQL statement to check the results of your Data Filter ID.

3. Click OK to close the SQL statement window.

---

**Editing a Data Filter ID**

To edit a Data Filter ID, do the following:

1. From the File menu, select Open -> Data Filter ID.
   
   The Select Filter ID dialog box appears.

2. Select the ID you want to edit.

3. Make your desired changes.

4. Save the ID.
Using Data Filters on Multiple Tables

A Data Filter ID can contain criteria from different tables. Each line in the Defined Filter box is a part of the filter that can stand alone as its own filter. Also, each line or part of the defined filter can reference a different table.

A part of the filter can reference Portfolio as the table name. Portfolio is a proxy for whatever table the current ID is referencing. For example, if the ID using the Filter ID is a Data Correction ID, the application replaces Portfolio with the name of whatever table the Data Correction ID is correcting. The application may or may not apply each line of the filter to the data in a table.

The application applies the filter line if either of the following conditions is true:

- The table you name explicitly in the filter is the same as the table that the application is processing
- The table in the filter is Portfolio and the table the application is processing contains the referenced Portfolio field

The application does not apply the filter line if either of the following conditions is true:

- The table explicitly named in the filter is different from the table that the application is processing
- The table in the Data Filter ID is Portfolio and the table the application is processing does not contain the referenced Portfolio column
Reviewing a Data Filter ID Example

The examples in the following table demonstrate these rules. The Table and Column combination represents the filter. An X indicates that the application applies the filter to the table during processing.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Commercial Loans Table</th>
<th>Ledger Stat Table</th>
</tr>
</thead>
</table>
| Table: Commercial Loans  
Column: Current Gross Book Balance | X |  |
| Table: Ledger Stat  
Column: Month 1 |  | X |
| Table: Portfolio  
Column: Original Term to Maturity | X |  |
| Table: Portfolio  
Column: Organizational Unit ID | X | X |

Reviewing a Data Filter ID Example

This example demonstrates how to create a data filter that includes only adjustable rate mortgages. You can create a Data Verification ID using the new Data Filter ID that verifies the margins on your adjustable rate mortgages. See Chapter 4, "Data Verification ID" for more information.

To create the data filter, do the following:

1. From the File menu, select New -> Data Filter ID.
   The New Data Filter ID dialog box appears.
2. Type **MTG_ARM** in the Data Filter ID field.
3. Type **Adjustable Rate Mortgages** in the Description field.
4. Click Read/Write as the permissions.
5. Click OK.
   The Data Filter ID dialog box appears.
6. Select Mortgages from the instrument list.
7. In the Columns box, select Interest Rate Code, and click Add.
   The Interest Rate Code column appears in the Defined Filter box.
8. Select Interest Rate Code in the Defined Filter box. This activates the Filter Type options. Code Values appears as the first choice because you have selected a code-type column.

9. Select No Index from the Unselected Codes box, and then click Add. The selection appears in the Selected Codes box.

10. Click Exclude These Codes in the Codes options box. Your window should look like this:

11. Select Process -> Run to verify the SQL statement.

12. Save and close the ID.

When you create the Data Verification ID and apply this Data Filter ID, it limits the view to adjustable rate mortgages only.
The Group Filter ID enables you to group multiple data filters into a single ID. Using this ID, you can combine complex data groups in a single operation.

This chapter presents the following topics:
- Creating and Defining a Group Filter ID
- Editing a Group Filter ID

Creating and Defining a Group Filter ID

To create a Group Filter ID, complete the following steps:

1. From the menu bar select File -> New -> Group Filter ID to display the New Group Filter dialog box.
2. From the Group list, select a group.
3. In the Group Filter ID field, type a descriptive title for the ID.
4. (Optional step) In the Description field, type a description that informs the user of the purpose of the ID.
5. In the Permission box, click either the Read/Write or Read Only button.
6. Click OK.

The Group Filter dialog box appears.
Creating and Defining a Group Filter ID

7. From the Filter Type list, select Data Filter.

8. From the Filter ID list, select a predefined Filter ID and click Add. The selected Filter ID appears in the Group Filter List box.

9. Repeat step 8 until you have selected all the Filter IDs that this Group Filter ID requires. When you finish, all the selected Filter IDs appear in the Group Filter List box.

10. Save the Group Filter ID.
Editing a Group Filter ID

To edit a Group Filter ID, complete the following steps:

1. From the menu bar, select File -> Open -> Group Filter ID to display the Select Group Filter ID dialog box.

2. From the Group Filter ID list, select the filter you want to edit and click OK. The selected Group Filter ID appears.

3. Edit the Group Filter ID using the Add, Remove, Replace, and Clear buttons. Use these buttons to perform the following functions:

<table>
<thead>
<tr>
<th>If you want to...</th>
<th>then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a Filter ID from the Filter ID list to the Group Filter List</td>
<td>select the desired Filter ID from the Filter ID list and click Add.</td>
</tr>
<tr>
<td>Remove a Filter ID from the Group Filter List</td>
<td>select the Filter ID you want to remove and click Remove.</td>
</tr>
</tbody>
</table>
| Replace a Filter ID in the Group Filter List with a new Filter ID | 1. Select a new Filter ID from the Filter ID list  
2. Select the Filter ID in the Group Filter List that you want to replace and  
3. Click Update. |
| Clear all Filter IDs from the Group Filter List        | click Clear List.                           |

4. Save your edits.
Editing a Group Filter ID
Tree Rollup IDs define a hierarchical structure of detailed data in the Oracle Financial Data Manager (FDM) database. For example, you can build a model of the various levels into which products roll up and use cost centers as the base level of the institution. You use a Tree Rollup ID to define these hierarchical structures.

With a Tree Rollup ID, you can define multiple organizational, product, account, and other hierarchies by using leaves as the lowest level of detail in the hierarchical structure. Each row in the FDM database contains a leaf value for each dimension of profitability. These leaves serve as the lowest level in constructing Tree Rollup IDs.

For more information about Tree Rollup IDs and IDs in general, see Chapter 3, "Overview of IDs".

This chapter presents the following topics:

- Creating a New Tree Rollup ID
- Using the Tree Rollup ID Window
- Editing a Tree Rollup ID
- Example: Building a Product Tree

Creating a New Tree Rollup ID

To create a Tree Rollup ID, perform the following steps:

1. From the File menu, click New.
   
   A list of the IDs that are available for the product you are using appears.

2. Select the Tree Rollup ID.
   
   The New Tree Rollup ID dialog box appears.
Creating a New Tree Rollup ID

3. Select Folder and Leaf Type.
4. Type in the Tree Rollup ID and Description fields, as required.
5. Select the permission level of the ID, as required.
   Read/Write is the default.
6. Click OK to continue.
   The Tree Rollup ID window appears.
Using the Tree Rollup ID Window

The Tree Rollup ID window comprises the Rollup Tree and Display Level panes. It also provides access to the Edit, Options, and Tree menus.

Rollup Tree Pane

The Rollup Tree pane enables you to see and manipulate the tree structure at any level of the hierarchy.

Branch Expansion Indicators

Each node is represented by a description and an Indicator that indicates whether or not a branch can be expanded. The Expansion Indicator is a + (plus sign) if the branch can be expanded to display nodes at the next lower level, a - (minus sign) if the branch has already been expanded and all lower nodes are displayed, and blank if no lower nodes are attached.

Current Level Name

The name of the level currently selected in the Rollup Tree pane appears after Rollup Tree in the menu bar. The level name changes as different levels are selected.

Display Level Pane

The Display Level pane enables you to see all the nodes attached to the selected node in the Rollup Tree at a specific level below the selected node. To set the level of the hierarchy that you want to display, select the Tree menu -> Set Display Level.

Edit Menu

Search

If you want to locate a specific node within a Tree structure, you can use the Search option in the Edit menu. The Tree Rollup Search dialog box appears:
### Using the Tree Rollup ID Window

#### Field Name | Field Description
---|---
Search Field | Select the Node Number or Description for which you are searching.
Search String | Type the Node Number or Description.
Level | Select the Level of the node in the Tree. If you do not know the level, leave the default entry of All Levels.
Search Options
- **Case Sensitive** | Provides exact string matches when searching on descriptions only
- **Wrap Search** | Performs the search of both node numbers and descriptions starting from the current cursor location on the Tree structure and continuing at the top of the Tree structure
Match
- **Beginning** | Searches node numbers or descriptions beginning with the string entered in the Search String field
- **Contains** | Searches node numbers or descriptions containing the string entered in the Search String field

**Note:** Trees can show as many as 16,000 leaves and nodes at a time.
Using the Tree Rollup ID Window

Search fails if the value you want is not within the 16,000 leaves range. The following message appears: “The tree is too large to show entirely. Collapse branches or use Search and Focus to view more.” See the Tree Menu for more information about Collapse Branch.

**Search Again**
The Search Again option is available in the Edit menu and enables you to continue your search using the same criteria that you defined in Search.

---
**Note:** Search and Focus and Search and Focus Again are specifically for use on trees having more than 16,000 leaves.

---

**Search and Focus**
The Search and Focus option is available in the Edit menu. It uses the same dialog box as the Search option and takes you to the value itself.

**Search and Focus Again**
Like the Search and Focus option, the Search and Focus Again option is available in the Edit menu. It uses the same dialog box as the Search option and takes you to the value itself.

Search and Focus Again shows only the node or leaf for which you are searching. It does not show context or hierarchy. It is the only option that you can use with a large tree, that is, one containing more than 16,000 leaves.

**Options Menu**
You can use the Options menu to format the appearance of your Tree Rollup ID. The Options menu provides the following functions:

- Select Font
- Show Node Numbers on Left
- Show Node Numbers on Right

**Select Font**
You can change the typeface in which your tree is displayed on your window. To try a new font:
1. Click Set Font.
   The default font is Font: System, Font Style: Bold, Size: 10. Each font is previewed in the Sample window at the bottom of the dialog box.

2. Select an appropriate Font, Font Style, Size, and Script, and then click OK.
   You select a smaller font to view more information within one window or a larger font to display less information per window but to view it more clearly.

Show Node Numbers on Left
You can select Show Node Numbers on Left if you are familiar with your Node Numbers and want to view them. This option displays the Node Numbers before the Node Descriptions.

This option is a toggle. To turn off the Node Numbers, select the option again.

Show Node Numbers on Right
You can select Show Node Numbers on Right if you are familiar with your Node Numbers and want to view them. This option displays the Node Numbers after the Node Descriptions.

This option is a toggle. To turn off the Node Numbers, select the option again.
Tree Menu

To change how the structure of a tree is viewed and to specify which branches are to be included in the rollup, you select Tree from the menu bar.

---

**Note:** Focus on Branch, Undo Focus, and Focus to Top are specifically for use on trees having more than 16,000 leaves.

---

**Expand One Level**

Expand One Level displays the branch and nodes attached one level below the selected node. You can also expand a branch by one level by selecting a node in the Tree Rollup and typing + (plus sign) or by double clicking the Branch Expansion Indicator when the indicator displays a + (plus sign).

**Expand Branch**

Expand Branch displays all levels of nodes attached under the node selected in the Tree Rollup. You can also expand a branch to show all lower levels of attached nodes by selecting a node in the Tree Rollup and typing Shift + * (plus sign and asterisk). This option is available only when the Branch Expansion Indicator displays a + (plus sign).

**Expand All**

Expand All displays every level of the entire Tree Rollup above and below the selected node. This option is available only when the Branch Expansion Indicator displays a + (plus sign).

---

**Note:** Expand All expands only the first 16,000 leaves and nodes. A Rollup ID can display a maximum of 16,000 leaves and nodes at a time.

---

**Collapse Branch**

Collapse Branch hides all levels of nodes attached under the selected node from the Rollup Tree pane. You can also collapse a branch by one level by selecting a node in the Rollup Tree pane and typing - (minus sign), or by double clicking the Branch Expansion Indicator when the indicator displays a - (minus sign).
Focus on Branch
Focus on Branch changes the Rollup Tree pane from displaying the whole tree to displaying only the tree structure below the selected node.

Undo Focus
Undo Focus turns off the focus on a branch. This enables you to display all branches of the total Tree Rollup when you no longer want to focus on an individual branch.

Focus to Top
Focus to Top returns you directly to the top of the Rollup Tree pane. You do not need to return level by level.

Levels Maintenance
Levels Maintenance enables you to manipulate the level structure of a tree. Using this option, you can add, subtract, and rename levels of the Tree Rollup. Selecting this option opens the Rollup Level Maintenance dialog box.

- **Insert Level** enables you to insert a level into the hierarchy. To insert a new level, select the level in the Level Description box above which you want to add a level, and click Insert Level.
Enter the name of the new level in the New Level Name box, and click OK. For more information, refer to the *Oracle Financial Services Installation and Configuration Guide*.

- **Delete Level** enables you to remove a level from the hierarchy. To remove a level, select the level you want to remove in the Level Description box and click Delete Level. You are prompted to confirm your decision to delete the level.

- **Rename Level** enables you to rename an already existing level. To rename a level, select the level you want to rename in the Level Description box and click Rename Level.

Enter the new name in the New Level Name box, and click OK.

When you have finished with Levels Maintenance, click OK to return to the main ID window. Click Cancel at any time to exit without changes.

**Set Display Level**

Set Display Level enables you to change the level displayed in the Display Level pane. Click this option to open the display level dialog box.

To change the Display Level, from the menu, select the level you want displayed.

**Set Tree Level**

Set Tree Level enables you to change the level that is displayed in the Rollup Tree pane. Click this option to open the display level dialog box.

**Insert Node**

Insert Node enables you to add an additional node to the Tree Rollup. To insert a node, select a node in the Tree Rollup under which you want to add a node, and click Insert Node. You can place new nodes anywhere in the Rollup Tree except below the leaf level or orphan node.

The Insert Node dialog box appears:

- **Parent Level** is the level of the parent node under which the new node is being added.

- **Parent Name** is the name of the parent node under which the new node is being added.

- **New Node Level** is the level at which the new node is being added.

- **New Node Name** enables you to enter the name of the new node.
If you leave the New Node Name field blank, the new node appears in the Tree Rollup display, without a descriptive tag.

- **New Node ID** enables you to define the ID number that will be associated with the new node. This field does not require input because a unique default ID number is supplied by the system. If you decide to enter an ID number for the new node manually, however, this number must be unique.

Click OK when you have finished. Click Cancel at any time to exit without saving changes.

**Rename Node**

Rename Node enables you to rename or renumber an existing node. Select the desired node from the Tree Rollup, and select this option. The Rename/Renumber dialog box opens.

- **Name**
  
  Enter the new name in the Name box.

- **Number**
  
  Enter the new number in the Number box.

Click OK when you have finished. Click Cancel at any time to exit without changes.

**Delete**

Delete enables you to delete a node from the Tree Rollup. To delete a node, select the node you want to delete from the Tree Rollup and click Delete. The selected node and all nodes below it are deleted. The Leaves that are attached below the deleted node become orphan leaves in the orphan branch of the tree.

**Copy**

Copy enables you to copy an orphan leaf or group of orphan leaves from the orphan branch into another node in the Tree Rollup. To copy a single orphan leaf from the orphan branch, select the orphan leaf in the Tree Rollup or set the Display Level to Orphan Leaves and select the desired Orphan Leaf. Next, click Copy. Now select the node to which the orphan leaf is to be copied in the Tree Rollup, and use Paste to attach the leaf to the new node.

To copy several orphan nodes at one time to a single node in the Tree Rollup, hold the Shift key while selecting successive nodes. Then use Copy and Paste to attach the block of nodes at the new location.
Using the Tree Rollup ID Window

**Cut**

Cut enables you to cut a leaf, a group of leaves, or a branch from the Tree Rollup.

To cut a portion of a Tree Rollup, select the leaf or node from the Tree Rollup, or set the Display Level. Next, click Cut. To reattach the cut portion of the tree to a different part of the tree, select the node to which the portion is to be copied in the Tree Rollup, and click Paste to attach it to the new node.

To cut several orphan nodes at one time, hold the Shift key while selecting successive nodes. Then click Cut if you want to reattach the nodes at a new location. Click Delete to cut the block of nodes permanently.

If a node that has leaves attached at a lower level is cut, or if leaves from the Tree Rollup are cut, the leaves are automatically placed at the end of the orphan leaves. If the leaves are reattached, or the node to which the leaves were attached are moved to a different part of the tree, the leaves that were placed at the end of the orphan branch are automatically moved.

**Paste**

Paste enables you to attach cut or copied orphan leaves, leaves, nodes, and branches to new nodes in the Tree Rollup. After you Cut or Copy, select the node to which you want to attach the data, and click Paste.

You can only perform a Paste after a Cut or Copy action has been performed. Paste can only be performed on the leaves or nodes copied or cut in the immediately previous cut or copy. If cuts are performed without a paste the node information from the first cut is lost and the leaves are placed at the end of the orphan leaves.

You can perform a Paste only after a Cut or Copy has been performed. Paste can be performed only on the leaves or nodes copied or cut in the immediately previous cut or copy. If you cut without a paste, the node information from the first cut is lost and the leaves are placed at the end of the orphan leaves.

**Node Up**

Node Up enables you to move a node up the list of nodes if more than one node is attached to a parent node. In order move a node above another node in the Tree Rollup window, select the node to move and click Node Up.

**Node Down**

Node Down enables you to move a node down the list of nodes if more than one node is attached to a parent node. In order move a node below another node in the Tree Rollup window, select the node to move and click Node Down.
Transform Rollup

Transform Rollup transforms the current Tree Rollup ID into a hierarchy table within the Oracle Financial Data Manager Reporting Data Mart. The new hierarchy table has the same name as the Tree Rollup ID. This table makes information available to the Reporting Data Mart user and for reporting purposes through Oracle Discoverer and other reporting tools. For more information, refer to Chapter 14, "Transformation ID".

Save the ID

Save the ID by clicking the Save icon on the horizontal toolbar, or choose Save from the File menu.

Editing a Tree Rollup ID

To open an existing Tree Rollup ID, perform the following steps:

1. From the File menu, click Open.
   A list of the IDs that are available for the product you are using appears.
2. Select Tree Rollup ID.
   The Select Tree Rollup ID dialog box appears.
3. Select Folder, Leaf Type, and Tree Rollup ID, as required.
4. Click OK.
   The Tree Rollup ID window appears.
5. Click in the pane that you want to search, either Rollup Tree or Display Level.
   If you select the Rollup Tree pane, you see the leaves in the context of the tree. If you select the Display Level pane, you see only the leaves.
6. From the Edit menu, click Search to search for the Tree Rollup ID you want to edit.
   The Tree Rollup Search dialog box appears.

---

**Note:** Trees can show as many as 16,000 leaves and nodes at a time.
7. Select either Node Number or Description in Search Field.
8. Type the Search String, such as Corporate.
9. Select Level, Search Options, and Match, as appropriate.
10. Click OK.

The Tree Rollup ID appears if your search is within 16,000 leaves. Search fails if the value you want is not within the 16,000 leaves range. The following message appears: “The tree is too large to show entirely. Collapse branches or use Search and Focus to view more.”

11. Click on the Tree Rollup ID.
12. With the Tree Rollup ID selected, copy or paste it as appropriate.

For example, you want to cut one leaf, Regional Corporate, from Wholesale and move it to Branch Administration.

13. When your cutting or pasting is complete, select File -> Save to save your Tree Rollup ID, or select File -> Save As to save your edited Tree Rollup ID under a new name.

Example: Building a Product Tree

In this example, you use the Tree Rollup ID to build a product tree with five hierarchy levels. The tree structure is as follows:

<table>
<thead>
<tr>
<th>Levels</th>
<th>Product Categories</th>
</tr>
</thead>
<tbody>
<tr>
<td>LEVEL I</td>
<td></td>
</tr>
<tr>
<td>Business Type</td>
<td>Personal</td>
</tr>
<tr>
<td>LEVEL II</td>
<td></td>
</tr>
<tr>
<td>Market Family</td>
<td>Checking, Savings, Retirement</td>
</tr>
<tr>
<td>LEVEL III</td>
<td></td>
</tr>
<tr>
<td>Market Type</td>
<td>Interest, Non-Int., Liquid, Time, IRAs</td>
</tr>
<tr>
<td>LEVEL IV</td>
<td></td>
</tr>
<tr>
<td>Market Product</td>
<td>Regular, Money Market</td>
</tr>
<tr>
<td>LEVEL V</td>
<td></td>
</tr>
<tr>
<td>Star Checking, Super Checking,</td>
<td></td>
</tr>
<tr>
<td>Product Description</td>
<td>Money Mkt I, Money Mkt II</td>
</tr>
</tbody>
</table>

Tree Rollup ID  9-13
Example: Building a Product Tree

You must set the levels of the tree before you can build it.

**Set the Levels of a Tree**

To set the levels of a tree, perform the following steps:

1. Click New on the horizontal toolbar.
   A list of the IDs that are available for the product you are using appears.

2. Select the Tree Rollup ID.
   The New Tree Rollup ID dialog box appears.

3. Select All for Folder.
   Now everyone in the folder has access.

4. Select Common COA ID for Leaf Type.
   This is the Leaf Type that contains the information for products.

5. Type **PRODUCT** as the Tree Rollup ID name.

6. In Description, type **This Product Tree is for Deposits Only.**

7. Select Read/Write for Security.

8. Click OK.
   The Tree Rollup ID window appears.

9. Select Levels Maintenance from the Tree menu.
   The Levels Maintenance dialog box appears: The default names are the level numbers.
10. Set the tree levels to define the structure of the tree.

11. To change the numbers to names, select each level, click Rename Level, and type the new name.

   The default number of levels for a new tree is set at five. You can add or subtract levels by clicking the Insert Level or Delete Level buttons. For this example, the number of levels is left at five. The maximum number of levels available is 15.

12. When you have finished naming the levels, click OK.

13. After setting the levels, build the tree.

**Build a Tree**

To build a tree, perform the following steps:

1. Highlight the parent branch into which you are going to insert the new branch.

2. Insert a new branch.

   You insert the first level of the sample, Business Type, by highlighting Total Rollup.

3. Click Insert Level (or select Insert Node from Tree menu).

   The Insert Node dialog box appears.

4. In the New Node Name box, type the description for this example, \textit{Personal}, and click OK.
5. Repeat procedures 1 and 2 to insert all Level Two, Three, and Four branches.

6. The lowest level, Level Five, is the leaf level.
   For new trees, Leaves are under the Orphan branch.

7. Attach the leaves to each branch by one of two methods:
   - Use Copy and Paste from the Tree menu to copy the leaf from the Orphan branch to the target branch.
   - Use the mouse to drag the selected leaf from the Orphan branch and drop it on the appropriate branch.
   After the leaves are attached, the Tree Rollup ID window appears.

8. Save the new Tree Rollup ID.

9. Click the Exit icon at on the horizontal toolbar to exit the new ID.
In Oracle Financial Services (OFS) applications, a Tree Filter ID narrows the focus of the tree hierarchy for processing and reporting. For example, if you want to report on only the products that roll up to the commercial loans portion of a product tree, you identify them with the Tree Filter ID.

A Tree Filter ID must have a predefined Tree Rollup ID as part of its definition, and it must be in the same group as the Tree Rollup ID. Tree Filter IDs are available only for data correction, transfer pricing, performance analyzer processing, and risk management processing.

For more information about Tree Filter IDs and IDs in general, see Chapter 3, "Overview of IDs".

This chapter presents the following topics:

- Creating a New Tree Filter ID
- Using the Tree Filter ID Window
- Editing a Tree Filter ID
- Example: Creating and Defining a New Tree Filter ID

Creating a New Tree Filter ID

To create a new Tree Filter ID, perform the following steps:

1. From the File menu, click New.
   
   A list of the IDs that are available for the product you are using appears.

2. Select Tree Filter ID.
   
   The New Tree Filter ID dialog box appears.
Creating a New Tree Filter ID

3. Select Folder, Leaf Type, and Tree Rollup ID.
4. Type in the Tree Filter ID and Description fields, as required.
5. Select the permission level of the ID, as required.
   
   Read/Write is the default.

6. Click OK to continue.
   
   The Tree Filter ID window appears.
Using the Tree Filter ID Window

Like the Tree Rollup ID window, the Tree Filter ID window comprises the Rollup Tree and Display Level panes. Also like the Tree Rollup ID window, it provides access to the Edit, Options, and Tree menus. Unlike the Tree Rollup ID window, the Tree Filter ID window has red and green flags that indicate nodes excluded from or included in the definition of the Tree Filter ID.

Rollup Tree Pane

The Rollup Tree pane enables you to see and manipulate the tree structure at any level of the hierarchy.

Branch Expansion Indicators

Each node is represented by a description and an Indicator that indicates whether or not a branch can be expanded. The Expansion Indicator is a + (plus sign) if the branch can be expanded to display nodes at the next lower level, a - (minus sign) if the branch has already been expanded and all lower nodes are displayed. It is blank if no lower nodes are attached.

Node Inclusion Indicator

Node Inclusion Indicators appear as green or red flags. If any nodes at lower levels of the branch are included in the Tree Filter ID, the Node Inclusion Indicator is green. If no nodes at lower levels of the branch are included in the Tree Filter, it is red.

Current Level Name

The name of the level currently selected in the Rollup Tree pane appears after Rollup Tree in the menu bar. The level name changes as different levels are selected.

Display Level Pane

The Display Level pane enables you to see all the nodes attached to the selected node in the Rollup Tree at a specific level below the selected node. To set the level of the hierarchy that you want to display, select the Tree menu -> Set Display Level.
Edit Menu

Search
If you want to locate a specific node within a Tree structure, you can use the Search option in the Edit menu. The Tree Rollup Search dialog box appears:

![Tree Rollup Search Dialog Box]

Field Name | Field Description
---|---
Search Field | Select the Node Number or Description for which you are searching.
Search String | Type the Node Number or Description.
Level | Select the Level of the node in the Tree. If you do not know the level, leave the default entry of All Levels.
Search Options
  - Case Sensitive | This option provides exact string matches when searching on descriptions only.
  - Wrap Search | This option performs the search of both node numbers and descriptions starting from the current cursor location on the Tree structure and continuing at the top of the Tree structure.

Match
Using the Tree Filter ID Window

Search fails if the value you want is not within the 16,000 leaves range. The following message appears: “The tree is too large to show entirely. Collapse branches or use Search and Focus to view more.” See the Tree Menu for more information about Collapse Branch.

**Search Again**
The Search Again option is available in the Edit menu and enables you to continue your search using the same criteria that you defined in Search.

**Note:** Search and Focus and Search and Focus Again are specifically for use on trees having more than 16,000 leaves.

**Search and Focus**
The Search and Focus option is available in the Edit menu. It uses the same dialog box as the Search option and takes you to the value itself.

**Search and Focus Again**
Like the Search and Focus option, the Search and Focus Again option is available in the Edit menu. It uses the same dialog box as the Search option and takes you to the value itself.

Search and Focus Again shows only the node or leaf for which you are searching. It does not show context or hierarchy. It is the only option that you can use with a large tree, that is, one containing more than 16,000 leaves.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beginning</td>
<td>This option searches node numbers or descriptions beginning with the string entered in the Search String field.</td>
</tr>
<tr>
<td>Contains</td>
<td>This option searches node numbers or descriptions containing the string entered in the Search String field.</td>
</tr>
</tbody>
</table>

Note: Trees can show as many as 16,000 leaves and nodes at a time.
Options Menu

You can use the Options menu to format the appearance of your Tree Rollup ID. The Options menu provides the following functions:

- Select Font
- Show Node Numbers on Left
- Show Node Numbers on Right
- Show Include Attribute

Select Font

You can change the typeface in which your tree is displayed on your window. To try a new font:

1. Click Set Font.

   The default font is Font: System, Font Style: Bold, Size: 10. Each font is previewed in the Sample window at the bottom of the dialog box.

2. Select an appropriate Font, Font Style, Size, and Script, and then click OK.

   You select a smaller font to view more information within one window or a larger font to display less information per window but to view it more clearly.
Show Node Numbers on Left
You can select Show Node Numbers on Left if you are familiar with your Node Numbers and want to view them. This option displays the Node Numbers before the Node Descriptions.

This option is a toggle. To turn off the Node Numbers, select the option again.

Show Node Numbers on Right
You can select Show Node Numbers on Right if you are familiar with your Node Numbers and want to view them. This option displays the Node Numbers after the Node Descriptions.

This option is a toggle. To turn off the Node Numbers, select the option again.

Show Include Attribute
You can select Show Include Attribute to activate the Node Inclusion Indicators and display the filter status of a node as you navigate through the hierarchy. A red flag indicates that the node has not been filtered. A green flag indicates that the node has been filtered.

Show Include Attribute is the default.

Tree Menu
To change how the tree structure is viewed and to specify which branches are to be included in the filter, select an option from the Tree menu.
Using the Tree Filter ID Window

Expand One Level
Expand One Level displays the branch and nodes attached one level below the selected node. You can also expand a branch by one level by selecting a node in the Tree Rollup and typing + (plus sign) or by double clicking the Branch Expansion Indicator when the indicator displays a + (plus sign).

Expand Branch
Expand Branch displays all levels of nodes attached under the node selected in the Tree Rollup. You can also expand a branch to show all lower levels of attached nodes by selecting a node in the Tree Rollup and typing Shift + * (plus sign and asterisk). This option is available only when the Branch Expansion Indicator displays a + (plus sign).

Expand All
Expand All displays every level of the entire Tree Rollup above and below the selected node. This option is available only when the Branch Expansion Indicator displays a + (plus sign).
Using the Tree Filter ID Window

Note: Expand All expands only the first 16,000 leaves and nodes. A Rollup ID can display a maximum of 16,000 leaves and nodes at a time.

Collapse Branch
Collapse Branch hides all levels of nodes attached under the selected node from the Rollup Tree pane. You can also collapse a branch by one level by selecting a node in the Tree Rollup and typing - (minus sign), or by double clicking the Branch Expansion Indicator when the indicator displays a - (minus sign).

Note: Focus on Branch, Focus to Top, and Undo Focus are specifically for use on trees having more than 16,000 leaves.

Focus on Branch
Focus on Branch changes the Rollup Tree pane from displaying the whole tree to displaying only the tree structure below the selected node.

Focus to Top
Focus to Top returns you directly to the top of the Rollup Tree pane. You do not need to return level by level.

Undo Focus
Undo Focus turns off the focus on a branch. This enables you to display all branches of the total Tree Rollup when you no longer want to focus on an individual branch.

Set Display Level
Set Display Level enables you to change the level that is displayed in the Display Level pane. Click this option to open the display level dialog box:
To change the Display Level, select the level you want to be displayed from the menu.
Set Tree Level
Set Tree Level enables you to change the level that is displayed in the Rollup Tree pane. Click this option to open the display level dialog box.

Include Branch in Filter
Include Branch in Filter selects an entire branch for inclusion in the Tree Filter ID window. To include an entire branch of a Rollup in the Tree Filter ID window, select the node at the top of the desired branch, and then select Include Branch in Filter.

If a node is included in the Tree Filter, then the Node Description is displayed in bold print. Otherwise, it is displayed in gray print.

Exclude Branch from Filter
Exclude Branch from Filter selects an entire branch to be excluded from the Tree Filter ID window if it has already been selected. To exclude an entire branch of a Rollup in the Tree Filter ID window, select the node at the top of the desired branch, and then select Exclude Branch from Filter.

Toggle In/Out of Filter
Toggle In/Out of Filter enables you to select or deselect a single node from an entire branch without changing the selection status of any other nodes in the branch. To include an individual node in a branch that is excluded or to exclude an individual node in a branch that is included, select the node to be toggled, and then select Toggle In/Out of Filter.

Save the ID
Save the ID by clicking the Save icon on the horizontal toolbar, or choose Save from the File menu.

Editing a Tree Filter ID
To edit a Tree Filter ID, complete the following steps:
1. From the File menu, click Open.
   A list of the IDs that are available for the product you are using appears.
2. Select Tree Filter ID.
   The Select Tree Filter ID dialog box appears.
3. Select Folder, Leaf Type, Tree Rollup, and Tree Filter IDs, as required.
4. Click OK.
   The Tree Filter ID window appears.
5. Click in the pane that you want to search, either Rollup Tree or Display Level.
6. From the Edit menu, click Search to search for the Tree Filter ID that you want to edit.
   The Tree Rollup Search dialog box appears.
7. Select either Node Number or Description in Search Field.
8. Type the Search String.
9. Select Level, Search Options, and Match, as appropriate.
10. Click OK.
    The Tree Filter ID appears if your search is within 16,000 leaves. Search fails if the value you want is not within the 16,000 leaves range. The following message appears: “The tree is too large to show entirely. Collapse branches or use Search and Focus to view more.”
11. Click on the Tree Filter ID.
12. With the Tree Filter ID selected, edit it as appropriate.
13. When your editing is complete, select File -> Save to save your Tree Filter ID, or select File -> Save As to save your edited Tree Filter ID under a new name.

**Example: Creating and Defining a New Tree Filter ID**

This example explains how to create and define a new Tree Filter ID named Checking. The example uses the Rollup Tree ID named Product that was created in the Chapter 9, “Tree Rollup ID” chapter. To create the Tree Filter ID, perform the following steps:
1. From the File menu, select New.
A list of the IDs that are available for the product you are using appears.

2. Select Tree Filter ID.
   The New Tree Filter ID dialog box appears.

3. Select All for Folder.
   Now everyone in the folder has access.

4. Select Common COA ID for Leaf Type.

5. Select Product for Tree Rollup ID.

6. Type **CHECKING** in the Tree Filter ID name box.

7. Type *This filter is for checking profitability analysis* in the Description box.

8. Select Read/Write for Security.

9. Click OK.
   The Tree Filter ID window appears.

10. Click Checking at level 2.

11. Select Include Branch in Filter from the Tree menu.
   The Node(s) Inclusion Indicators turn green for all the Level 2 Checking branches.

12. Save the Tree Filter ID.
A Formula ID is a user-defined tool that supplements other IDs and enables you to further and more flexibly manipulate data. Formula IDs have three different uses:

- To specify a calculated column that the Oracle Financial Services (OFS) application derives from other columns in the database
- To calculate assignments in data correction
- To create calculated conditions in data and relationship filters.

For example, you want to calculate a weighted average rate that requires a calculation involving total net balance and the current rate on each individual account. You can use a Formula ID to define this calculation.

The OFS applications handle a Formula ID like any database column. The applications display all Formula IDs under the Formula selection in the instrument table lists, however.

This chapter discusses the following topics:

- Using the Formula ID Window
- Creating a Formula ID
- Editing a Formula ID
- Reviewing Formula ID Examples
Using the Formula ID Window

The Formula ID window comprises elements that you use to build formulas.

The formula elements are:

- Operators and Operands
- Function Types and Functions
- Constants
- Tables and Output Columns

Only those formula elements that you can add logically at the next point of a formula are available for use. The OFS application disables or hides the formula elements that are not applicable.
You use the formula elements as you need them. For example, you may need a formula to calculate the weighted average of your commercial loans. You must first select Mathematical as the function type and WAvg as the function before you select the columns under the Commercial Loans table. However, you can build a formula that does not require a function. It may need only operators and operands.

The following sections describe the formula elements and provide basic information on how to use them.

**Operators and Operands**

Operators and Operands are displayed as buttons across the top of the Formula ID window.

The operands available are left parenthesis, right parenthesis, and comma. Parentheses group segments of a formula to make logical sense. The comma separates statements of a function.

The mathematical operators available are:

- +
- -
- *
- /
- /
- =
- >
- <
- <>
- >=
- <=

You can use these operators to apply mathematical operators to the formula.

Add enables you to add the currently highlighted database column or operator to build the formula.
Function Types and Functions

You select the type of function for your formula from the Type list. The choices are:

- Mathematical Functions
- Date Functions
- String Functions
- Other Functions

The type of function you select determines the choices available in the Function box. These unique functions of the Formula ID enable you to perform various operations on the data. The following tables list each available function. Detail on the operations of each function follows the table in which it appears.

Mathematical Functions

When you select Mathematical as the function type, you can use the following 11 functions from the Functions box:

<table>
<thead>
<tr>
<th>Function</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute Value</td>
<td>ABS()</td>
</tr>
<tr>
<td>Ceiling</td>
<td>CEILING()</td>
</tr>
<tr>
<td>Greatest</td>
<td>GREATEST(column or expression, column or expression)</td>
</tr>
<tr>
<td>Least</td>
<td>LEAST(column or expression, column or expression)</td>
</tr>
<tr>
<td>Maximum</td>
<td>MAX()</td>
</tr>
<tr>
<td>Minimum</td>
<td>MIN()</td>
</tr>
<tr>
<td>Natural Log</td>
<td>LN(number)</td>
</tr>
<tr>
<td>Power</td>
<td>POWER(coefficient, exponent)</td>
</tr>
<tr>
<td>Round</td>
<td>ROUND (number, precision)</td>
</tr>
<tr>
<td>Sum</td>
<td>SUM()</td>
</tr>
<tr>
<td>Weighted Average</td>
<td>WAvg (column being averaged, weight column)</td>
</tr>
</tbody>
</table>

The following descriptions provide detailed information about the mathematical functions, including examples.
Absolute Value: Returns the positive value of the database column
Example: ABS (-3.5) = 3.5.

ABS function syntax:
{ABS( } followed by {EXPR1 without any embedded or outermost left-right parentheses pair} followed by { )}

For example, ABS(F), ABS(F + C), ABS(F + C * R + F) are possible. However, ABS((F + C + R)), ABS((F + (MAX * CEILING))) are not possible.

Ceiling: Rounds a value to the next highest integer
Example: 3.1 becomes 4.0, 3.0 stays the same
Syntax: Ceiling(column or expression)

Greatest: Returns the greater of 2 numbers, formulas, or columns
Syntax: Greatest(column or expression, column, or expression)

Least: Returns the lesser of 2 numbers, formulas, or columns
Syntax: Least(column or expression, column or expression)

Maximum: Returns the maximum value of a -database column
Syntax: Max(Column)

Minimum: Returns the minimum value of a -database column
Syntax: Min(Column)

Note: You cannot use the Maximum and Minimum functions as calculated columns or in Data Correction Rules. The Maximum, Minimum, Sum, and Weighted Average functions are multi-row formulas. They use multiple rows in calculating the results.

Natural Log: Returns the natural logarithm of a number
Natural logarithms are based on the constant e (2.71828182845904).

Syntax: LN(number) where number is the positive real number for which you want the natural logarithm
Examples:
LN(86) equals 4.454347
LN(2.7182818) equals 1

**Power**: Raises one value to the power of a second
Syntax: Power(x, y) returns x raised to the power of y
POWER function syntax:
{POWER(} followed by {EXPR1 without any embedded or outermost left-right parentheses pair followed by {,} followed by {EXPR1 without any embedded or outermost left-right parentheses pair} followed by { })

Valid examples:
- POWER(F, R)
- POWER(F + C * R, F / R)

Invalid examples:
- POWER((F/R), F + R)
- POWER((F + C), (C * R))
- POWER(F + POWER, R)
- POWER( MAX, C)

**Round**: Rounds a value to a number of decimal places
Syntax: Round(x, n) returns x rounded to n decimal places

**Sum**: Sums the total value of a database column. Sum is a multi-row function, in contrast to +, which adds 2 or more values in a given row (not column)
Syntax: Sum(Column).

**Weighted Average**: Takes a weighted average of one database column by a second column
Syntax: WAvg(Column A, Column B)
Example:
WAvg(DEPOSITS.CUR_NET_RATE,DEPOSITS.CUR_BOOK_BAL)
WAvg cannot appear in any expression.
If you have two formulas called F1 and F2, both of which are WAvg functions, then you can form a third formula F3 as F1 + F2. If F3 is chosen as a calculated column, then an error message appears and the SQL code is not generated for
that column. This is similar for nested WAvg functions if F3 is WAvg and it has
F1 or F2 or both as its parameters.

Date Functions
Four functions are available when you select Date as the function type:

<table>
<thead>
<tr>
<th>Function</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build Date</td>
<td>BUILDDATE(CCYY,MM,DD)</td>
</tr>
<tr>
<td>Go Month</td>
<td>GOMONTH(date, number of months)</td>
</tr>
<tr>
<td>Month</td>
<td>MONTH(number)</td>
</tr>
<tr>
<td>Year</td>
<td>YEAR(date)</td>
</tr>
</tbody>
</table>

The following descriptions provide detailed information about the date functions,
including examples.

Build Date: Requires three parameters, (CCYY,MM,DD) (century and year, month,
day). It returns a valid data and enables you to build a date from components.

**CAUTION:** If the parameters are entered incorrectly, the date is invalid.

Example: BuildDate(95,11,30) is invalid (invalid century). BuildDate(1995,11,30)
is valid.

Go Month: Advances a date by x number of months.

Syntax: GOMONTH(Date column, Number of months to advance)

Example:

GOMONTH(DEPOSITS.ORIGINATION_DATE, DEPOSITS.ORG_TERM)

Go Month does not know the calendar. For example, it cannot predict the last
day of a month. Typical functionality is illustrated in the following table:

<table>
<thead>
<tr>
<th>Date Column</th>
<th># of Months</th>
<th>GOMONTH</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/31/94</td>
<td>1</td>
<td>2/28/94</td>
<td>Because 2/31/94 does not exist</td>
</tr>
<tr>
<td>1/15/94</td>
<td>2</td>
<td>3/15/94</td>
<td>Exactly 2 months:15th to 15th</td>
</tr>
</tbody>
</table>
Using the Formula ID Window

GOMONTH function syntax:

{GOMONTH( } followed by {F | C | R} followed by {,} followed by {EXPR1 without any embedded or outermost left-right parentheses pair} followed by {)}

Valid examples:

GOMONTH(F, F + R + C)
GOMONTH(F, R)

Invalid examples:

GOMONTH(F + (R + C), MAX)
GOMONTH((F * C), F)

GOMONTH followed by {+ | -} followed by {F | C | R} is the only expression possible with GOMONTH.

Month: Month(x) returns the month in x, where x is a numbered month.

Month(Column) returns the month in the column, where the column is a date column.

Examples:

Month(9) returns September.

Month(Origination Date) returns the month of the origination date.

Year: Year(x) returns the data for year x.

Year(Column) returns the year in the column, where the column is a date column.

Example: Year(Origination Date) returns the year of the origination date.
Using the Formula ID Window

String Functions
Only one function is available when you select String as the function type:

<table>
<thead>
<tr>
<th>Function</th>
<th>Notation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trim All</td>
<td>ALLTRIM()</td>
<td>Trims leading and following spaces, enabling the software to recognize numbers (entered in All Trim) as a numeric value, which can then be used in calculating</td>
</tr>
</tbody>
</table>

Other Functions
Two functions are available when you select Other as the function type:

<table>
<thead>
<tr>
<th>Function</th>
<th>Notation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If statement</td>
<td>IF(logical_test, value_if_true, value_if_false)</td>
<td>Use If, then logic in a formula. The syntax for the If function is: If(Condition, Value if True, Value if False). Example: If(LEDGER_STAT.Financial= 110, LEDGER_STAT.Month 1 Entry,0)</td>
</tr>
<tr>
<td>Lookup</td>
<td>LOOKUP(original table column,lookup table column, return column)</td>
<td></td>
</tr>
</tbody>
</table>

The following descriptions provide detailed information about the other functions, including examples.

If: Use If, then logic in a formula. The syntax for the If function is:

If(Condition, Value if True, Value if False).

Example:

If(LEDGER_STAT.Financial= 110, LEDGER_STAT.Month 1 Entry,0)

IF function syntax:

{IF( {EXPR2} followed by {>|<|<>|=|>=|<=} followed by EXPR2 followed by {[,] followed by EXPR followed by }},n followed by )} where n = 1, 2, 3, ....

The IF function should always have odd number of parameters separated by commas. The first parameter is an expression followed by a relational operator, which is in turn followed by an expression.

For example, IF(((MAX + SUM) >= 30), F, POWER) is valid.

Note: Avoid embedding multiple individual formulas in subsequent formulas. This can create an invalid formula.
Lookup: Enables you to assign values equal to values in another table for data correction.

LOOKUP function syntax:

Lookup(O1,L1,O2,L2,..OnLn,R) where

O=Column from Original table
L=Column from Lookup table
R=Column to be Returned
So the previous statement would read:

where O1=L1 and O2=L2... Returned value R

LOOKUP function should always have an odd number of parameters separated by commas and with a minimum of 3 parameters.

**Valid examples:**
- LOOKUP(F, R, R)
- LOOKUP(F, R, F, F, F)

**Invalid examples:**
- LOOKUP(F)
- LOOKUP(F, R)
- LOOKUP(F + R, (F + R), MAX)

**Note:** Lookup is used exclusively for data correction.

**Constants**

The Constant box enables you to apply a constant value to the formula. You type a value into the box and click Insert Constant to insert the value of a constant into the formula.

**Tables and Output Columns**

The Tables box enables you to select the table that holds a specific database column you want to include in a formula. Once you select a table, the application displays the columns associated with that table in the Output Columns box.

You can use the Formula table to access any previously defined formulas.
Output Columns (Data Elements)
To use a column (a data element) in the formula, select that column and then click Add in the Operand box, or double-click on the column name to add it to the formula.

Formula Box
The Formula box displays the formula as you create it.

Edit Options
The Edit box and option buttons provide full control of formula editing.

Clear
The Clear option clears the entire formula box of all logic.

Delete
The Delete option deletes the parts of the formula that you select. Select the formula element that you want to delete and click Delete.

Note: You cannot delete any portion of a formula if the deletion results in leaving an invalid formula.

Insert
The Insert option inserts operators, operands, or constants into the formula at the cursor position. To insert an element, complete the following steps:
1. Place your cursor in the formula where you want to insert an element, and click Insert.
2. Select the item you want to insert. Double-click a column or function, or click the operator button and then click Add.
   Your insertion element appears in the Edit box for verification.
3. Press Insert again.
A warning dialog appears.

4. Click Yes to insert, or click No to reselect your insertion element. You can click Cancel to cancel the operation.

---

**Note:** You cannot insert expressions, operators, or constants that result in leaving an invalid formula.

---

**Replace**

The Replace option replaces a formula element that you select. To replace a formula element, complete the following steps:

1. Select the formula element that you want to replace, and click Replace.

2. Select the replacement item. Double-click a column or function, or click the operator button and then click Add.

   Your replacement element appears in the Edit box for verification.

3. Click Replace again.

   A warning dialog appears.

4. Click Yes to confirm the replacement, or click No, and reselect your replacement element.

5. Click Cancel to cancel the operation.

---

**Note:** You cannot replace a selected element that results in leaving an invalid formula.

---

**Null Values in the Database**

A null value in a column in the database is a column that has no data. You should take all necessary steps to avoid having null columns in the database for the following reasons:

- Any null value accessed in a formula results in a null value. For example:

<table>
<thead>
<tr>
<th>Column X</th>
<th>Column Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>150</td>
<td>null</td>
</tr>
</tbody>
</table>
If we define a formula as \( X + Y \), the answer is \( 150 + \text{null} = \text{null} \). All operations (such as +, -, /, *, ^) are handled in this same manner.

- You cannot define a filter to recognize null values. The Data Filter ID assumes that the database does not have any null values. Consequently, you cannot define a Data Filter ID to isolate all rows with a null value in a given column.

  **Note:** Null \( <> \) 0, so filtering on 0 does not return rows with null values.

You can identify null values by using an SQL statement to select all rows
WHERE `<Column>` IS NULL.

**Formula ID Creation Hints**

The Formula ID is a flexible method for creating formulas. Consequently, you have the potential to define a formula that does not make sense. Consider the following recommendations when creating a Formula ID:

- Do not use a column out of context. For example, do not use a character field in a numeric calculation.

- Each formula should contain only columns from the same database table (except for certain Ledger_Stat table columns).

- An implied filter exists when creating a Formula ID with columns in the LEDGER_STAT table. LEDGER_STAT table formulas include if/else decode logic based on the Configuration ID as of date.

  Example: If the formula is Month_01 - 100, a filter includes Year_S equal to the as of date/year. This formula works as follows:

  Year_S = 1994, then Month_01 - 100, else 0.
Creating a Formula ID

Use the following instructions to create and define a Formula ID. See Chapter 3, "Overview of IDs" for further explanation about ID creation and maintenance.

To create a Formula ID, perform the following steps:

1. From the File menu, click New.
   A list of the IDs that are available for the product you are using appears.
2. Select the Formula ID.
   The New Formula ID dialog box appears.
3. Type the name for the ID in the Formula ID field.
   
   **Note:** Formula ID Names cannot contain spaces or special characters, such as dash (-) or slash (/).

4. Select Folder.
5. Type in the Formula ID and Description fields, as required.
6. Select the permission level of the ID, as required.
   Read/Write is the default.
7. Click OK to continue.
   The Formula ID window appears.
8. Build the formula using the formula elements.
   See "Using the Formula ID Window" in this chapter for information on using the formula elements in the Formula ID window.
9. Save the ID.
Editing a Formula ID

To edit a Formula ID, perform the following steps:

1. From the File menu, click Open.
   A list of the IDs that are available for the product you are using appears.

2. Select the Formula ID.
   The Select Formula ID dialog box appears.

3. Type the name of or select the ID and Formula ID that you want to edit.

4. Click OK to continue.
   The Formula ID window appears.

5. Make the editorial changes.

6. When you finish the editing, save the ID.
Reviewing Formula ID Examples

The following four examples demonstrate how you can use the Formula ID to achieve various results.

Example 1 Use If, Then Logic to Determine Average Daily Balance
The following steps create a Formula ID that calculates the Average Daily Balance for January from the Ledger Stat table.

1. From the File menu, click New.
   A list of the IDs that are available for the product you are using appears.
2. Select the Formula ID.
   The New Formula ID dialog box appears.
3. Select All from the Folder.
4. Type JAN_ADB in the Formula ID field.
5. Type Avg Dly Bal–Jan in the Description field.
6. Click Read/Write.
7. Click OK to continue.
   The Formula ID window appears.
8. Select Ledger Stat from the Tables box.
9. Select Other from the Type box.
10. Double-click If from the Functions box.
11. Select Financial Element ID from the Output Columns box and click Add in the Operand box.
12. Click the = (equal operator) from the Operand box.
13. Type 140 in the Constant box, and then click Insert Constant.
14. Click the , (comma operand) from the Operand box.
15. Select Month_01 from the Output Columns box and click Add in the Operand box.
16. Click the , (comma operand) from the Operand box.
17. Type 0 in the Constant box, and then click Insert Constant.
18. Click the ) (close parenthesis operand) from the Operand box.

**Example 2 Current Net Book Balance**
The following steps create a Formula ID that calculates the current net book balance for Commercial Loans. This ID multiplies the current gross book balance by the percent owned (Gross Book Balance * Percent Owned):  

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>From the File menu, click New. A list of the IDs that are available for the product you are using appears.</td>
</tr>
<tr>
<td>2.</td>
<td>Select the Formula ID. The New Formula ID dialog box appears.</td>
</tr>
<tr>
<td>3.</td>
<td>Select All from the Folder.</td>
</tr>
<tr>
<td>4.</td>
<td>Type <strong>CL_NETBKBA</strong>L in the Formula ID field.</td>
</tr>
<tr>
<td>5.</td>
<td>Type <strong>CL Net Book Bal</strong> in the Description field.</td>
</tr>
<tr>
<td>6.</td>
<td>Click Read/Write.</td>
</tr>
<tr>
<td>7.</td>
<td>Click OK to continue. The Formula ID window appears.</td>
</tr>
<tr>
<td>8.</td>
<td>Select Commercial Loan from the Tables box.</td>
</tr>
<tr>
<td>9.</td>
<td>Select Current Gross Book Balance from the Output Columns box, and then click Add in the Operand box.</td>
</tr>
<tr>
<td>10.</td>
<td>Click the * (multiply operator) from the Operand box.</td>
</tr>
<tr>
<td>11.</td>
<td>Click the ( (open parenthesis operand) from the Operand box.</td>
</tr>
<tr>
<td>12.</td>
<td>Type <strong>100</strong> in the Constant box and then click Insert Constant.</td>
</tr>
<tr>
<td>13.</td>
<td>Click the – (minus operator) from the Operand box.</td>
</tr>
<tr>
<td>14.</td>
<td>Select Percent Sold from the Output Columns box, and then click Add in the Operand box.</td>
</tr>
<tr>
<td>15.</td>
<td>Click the ) (close parenthesis operand) from the Operand box.</td>
</tr>
<tr>
<td>16.</td>
<td>Click the / (divide operator) from the Operand box.</td>
</tr>
</tbody>
</table>

---

Note: The Oracle Financial Data Manager (FDM) database carries the percent sold, so the percent owned must be calculated.
17. Type 100 in the Constant box, and then click Insert Constant.
18. Click the ) (close parenthesis operand) from the Operand box.

**Example 3 Average Current Net Book Balance**
The following steps create a Formula ID that calculates the average current net book balance for each row in a Commercial Loan Stratification Report:

1. From the File menu, click New.
   - A list of the IDs that are available for the product you are using appears.
2. Select the Formula ID.
   - The New Formula ID dialog box appears.
3. Select All from the Folder.
4. Type **CL_AVGNETBK** in the Formula ID field.
5. Type **CL Avg Net Bk Bal** in the Description field.
6. Click Read/Write.
7. Click OK to continue.
   - The Formula ID window appears.
8. Select Commercial Loan from the Tables box.
9. Select Mathematical from the Type box.
10. Double-click WAvg in the Functions box.
11. Select Current Net Book Balance from the Output Columns box, and then click Add in the Operand box.
12. Click the , (comma operand) from the Operand box.
13. Select Record Count from the Output Columns box, and then click Add in the Operand box.
14. Click the ) (close parenthesis operand) from the Operand box.
Example 4  Weighted Average Current Net Rate

The following steps create a Formula ID that calculates the weighted average current net rate for each row in a Commercial Loan Stratification Report.

1. From the File menu, click New.
   A list of the IDs that are available for the product you are using appears.
2. Select the Formula ID.
   The New Formula ID dialog box appears.
3. Select All from the Folder.
4. Type CL_AVGNETRATE in the Formula ID field.
5. Type CL Avg Cur Net Rate in the Description field.
6. Click Read/Write.
7. Click OK to continue.
   The Formula ID window appears.
8. Select Commercial Loan from the Tables box.
9. Select Mathematical from the Type box.
10. Double-click WAvg in the Functions box.
11. Select Current Net Rate from the Output Columns box, and then click Add in the Operand box.
12. Click the , (comma operand) from the Operand box.
13. Select Current Net Book Balance from the Output Columns box, and then click Add in the Operand box.
14. Click the ) (close parenthesis operand) from the Operand box.
15. Save and close the ID.
A Batch ID enables you to perform batch processing of multiple IDs such as Processing ID or Transformation ID. With a Batch ID, you can group time-consuming tasks for processing after hours or on weekends.

This chapter presents the following topics:

- Defining a Batch ID
- To process a Batch ID, perform the following steps:
- Editing a Batch ID

### Defining a Batch ID

To define a Batch ID, perform the following steps:

1. From the File menu, select New -> Batch ID.
   The New Batch ID dialog box appears.
2. Complete each field, as required.

---

**Note:** For security reasons, Batch IDs are application-specific. You cannot use a Batch ID defined in one Oracle Financial Services (OFS) application in another OFS application. Accordingly, Batch IDs cannot have the same name, even though they appear in different OFS applications.

3. When you are done, click OK.
The ID Type dialog box appears.

For more detailed information about defining IDs, refer to the ID Type information that follows and to the “Overview of IDs” chapter.

**ID Type**

When you select an ID type from the list, all the predefined IDs of that type are listed in the ID Type window.

**ID Information Dialog**

To locate the ID or IDs that you want, view summary information by selecting an ID and clicking the right mouse button. The ID Information dialog box opens. When you have finished viewing the data, click OK.

**Selected IDs Window**

Select the IDs you want to batch process and click Add. The ID names appear in the ID Name list. To select multiple IDs, hold the Shift key while selecting ID names. To add all of the IDs in your list, click Select All. When you have selected all the IDs you want to batch process, click Add. To remove an ID from the ID Names list, select the ID and click Remove. To remove all IDs from the ID Names list, click Remove All.

**Start Date and End Date**

These settings select the period in which you want the allocations or IDs to process. If you select Current Date, the system adopts the default As of Date. Choosing specific Start and End dates overrides the default As of Date.

**Order of Process Arrows**

The IDs are processed in the order in which they are listed in the Selected IDs window. To change the order, select an ID and use the up or down arrows to change its location in the list. When the order is correct, select Run from the Process menu.

**Processing a Batch ID**

You can process Batch IDs in serial or parallel mode.

In serial mode, each ID is processed one after another. Serial mode is the default setting.
In parallel mode, all IDs in Batch ID are run concurrently. Parallel processing may lengthen your processing time.

**Note:** If any IDs are dependent on other IDs, or if IDs access any of the same data, you cannot run parallel processing.

To enable parallel processing, you must modify your OSF.ini file. The appropriate parameter value in the [PARALLEL_BATCH_SERVER_PROCESSING] section of the .ini file must be changed to 1.

To process a Batch ID, perform the following steps:

1. Select Run from the Process menu. A spreadsheet window shows the status of each of the IDs being run.

   **Note:** Processes that run on the server may show a complete status before they have actually completed. To check the status of processes running on the server, select Server Status from the Process menu.

2. Select Save from the File menu.

**Editing a Batch ID**

To edit a Batch ID, perform the following steps:

1. From the File menu, select Open - > Batch ID.
   
The Select Batch ID dialog box appears.

2. Select the ID you want to edit.

3. With the ID open, make your changes following the principles described in “Defining a Batch ID.”

4. Select Save from the File menu.

You can use the Save As option in the File menu to save your edited ID under a new name.
Editing a Batch ID
SQL Talk enables end users to view and write to the Oracle Financial Data Manager (FDM) database using Structured Query Language (SQL) statements and procedures.

This chapter presents the following topics:

- SQL Talk Privileges
- Using SQL Talk
- Limitations to the Spreadsheet Display and Processing Time

---

**CAUTION:** SQL Talk provides an easy-to-use SQL input dialog. If you are not an expert in SQL or not familiar with your database structure it is important to remember the following:

- SQL Talk is a direct link to the database and writes changes without prior confirmation. Misuse can severely damage your database.
- SQL statements and procedures must be compatible with the FDM database.

---

**SQL Talk Privileges**

The database privileges assigned to a user also govern SQL Talk privileges, with the additional restriction that, by default, all users are restricted to select-only statements. The database owner must make changes in security levels to give a user the ability to write back to the database. See the Oracle Financial Data Manager Administration Guide for more information.
Using SQL Talk

To open the SQL Talk window, complete the following steps:

1. From the menu bar, select Process -> SQL Talk to display the SQL Talk window.
2. Type your SQL script in the top pane of the window, ending your statement with the standard SQL semi-colon.
3. Press Ctrl-Enter to run the SQL script.
   During processing a “Fetching...” dialog appears.
   If you want to interrupt the process click Cancel. The lower pane of the window displays data up to the point of interruption.
   The completed process returns data in spreadsheet format to the bottom pane of the SQL Talk window.


Using Multiple SQL Talks Simultaneously

You can have more than one SQL Talk open at a time, however, too many open SQL Talk dialogs can overtax your system’s resources, resulting in a General Protection Fault error. The point at which an individual system fails depends on the client configuration, system environment, and resources required to process the SQL statements.
Creating Stored Procedures

To create stored procedures for processing against your database, use the SQL ID.

Limitations to the Spreadsheet Display and Processing Time

The following limitations apply to SQL Talk.

Maximum Number of Rows and Columns Displayed

These limitations apply to the spreadsheet display.

Maximum Number of Rows

The maximum number of rows that you can select through SQL Talk is 16,000. If you issue a select statement that reaches or exceeds this number the following error message appears: “Only 16,000 rows can be displayed...aborting.” Only the first 16,000 rows of your select statement appear in the spreadsheet display.

Maximum Number of Columns

SQL Talk displays a maximum of 252 columns. If you issue a select statement that returns more than that number of columns, only the first 252 columns appear.

Optimizing Processing Time

Since the query you process against the database is stored in RAM, the speed at which rows are returned depends on the number of columns you select. The greater the number of columns, the longer it takes to return data. Therefore, make sure you select only the columns you want to see.
Limitations to the Spreadsheet Display and Processing Time
Most tables in the Oracle Financial Data Manager (FDM) database are formatted for processing. Using your specifications, the Transformation ID restructures data from the processing tables and creates new tables for reporting and analysis. This new set of tables is called the Oracle Financial Data Manager Reporting Data Mart.

The Reporting Data Mart is a collection of tables within a database, optimized for use with reporting and analysis tools. It is created in the same database warehouse where the FDM processing data is stored. You can use the Reporting Data Mart with any reporting tool, without having to further manipulate your data. You can create, open, and edit the Transformation ID in any of the Oracle Financial Services (OFS) applications that use the Tree Rollup ID, including:

- Balance and Control
- Risk Manager
- Performance Analyzer

This chapter discusses the following topics:

- The Transformation Process
- Creating a Transformation ID
- Defining a Transformation ID
The Transformation Process

As the transformation process extracts data from the processing tables and restructures it into the Reporting Data Mart, the Transformation ID maintains the integrity of the data. In addition, the Transformation ID stores other transformation specifications, such as:

- Which transformations are performed
- What tables are designated for transformation
- What parameters or special processing options to apply

Pivoting

The Transformation ID uses two methods of pivoting to transform data:

- Financial Element
- Time Bucket

Financial Element Pivot

For processing, financial elements are stored in the FDM database in separate rows. The Financial Element Pivot extracts the financial elements from the FDM database and pivots them into columns. Each financial element in the original table receives its own column in the reporting and analysis table.

Time Bucket Pivot

A column exists for each time period in the FDM database. Reporting and analysis tools require that time periods exist as rows. The Time Bucket Pivot extracts the time periods from the FDM database and pivots them into rows.

The following tables require both the Financial Element and Time Bucket Pivots:

- Risk Manager Result Detail table (RES_DTL_XXX)
- Ledger Stat table (LEDGER_STAT)
Non-Pivot Transformations

Some Non-Pivot transformations perform filtering functions. Others run additional transformations on selected data. The Non-Pivot Transformations are:

- Dimension Filtering
- Data Filtering
- Rates

Dimension Filtering

With Dimension Filtering, you can select dimensions to exclude. Only Leaf Type Columns are valid dimensions for exclusion. When dimensions are excluded, the Transformation ID:

1. Creates the output table without the columns for the selected dimensions, and
2. Performs a sum aggregation of the data based on the remaining leaf columns

Data Filtering

With Data Filtering, you can specify the use of a filter on the input table. A filter limits the amounts of data for processing. If a filter is specified in the financial element column, then the output table is created with only those financial elements specified in the filter.

Rates

There are two types of rates used during processing:

- Weighted Rates
  Rates weighted with their associated balances are stored in the following tables:
  - Ledger Stat
  - Risk Manager Result
  The transformation process leaves these rates weighted.

- Non-Weighted Rates
  Real rates (non-weighted) cannot be aggregated unless they are weighted against a balance. These weighted rates are then saved to the output table.
  Occasionally, non-weighted rate data is saved in the LEDGER_STAT table. This rate data is primarily used with allocations. Reports are not generally created.
from these financial rate elements. The rate data is invalid for transformations that aggregate results from these financial elements. You should filter these financial elements using a data filter prior to running the Transformation ID.

Tree Rollup

The transformation for rollups is different than for other tables. Before the transformation rollup, data is stored in different tables. One rollup is combined and stored in the output table. Each transformation creates a separate table in which only one rollup is placed. This output table is also referred to as a Hierarchy Table.

Metadata and System Information Table

For each new table and column created during the transformation process, the Transformation ID inserts the appropriate rows into the FDM metadata tables to identify the new output table. The FDM metadata tables contain information for defining and tracking tables, columns, and other objects.

Creating a Transformation ID

To create a new Transformation ID, complete the following steps:

1. Choose File -> New -> Transformation ID.
   The New Transformation ID dialog box appears.
2. Choose a Folder from the list.
3. Press the Tab key to move to the next field.
4. Enter a descriptive name in the Transformation ID field.
5. Enter a description for your ID in the Description field. This is an optional step.
6. Check the Read/Write option.
7. Choose OK.

The Transformation ID dialog box appears with the name of the ID displayed at the top.
Defining a Transformation ID

The sources from which to process the Transformation ID are:

- Ledger Stat
- Risk Manager Result Detail
- Tree Rollup

**Note:** The selection of tables available under Choose Source Types depends on which OFS products are installed.
Defining a Ledger Stat Transformation

The Ledger Stat Table stores General Ledger and statistical information.

To define a Transformation ID for a Ledger Stat table, complete the following steps:

1. Select Ledger Stat from the Choose Source Type list. Ledger Stat appears in the Choose Table field and the Ledger Stat dialog appears.

2. Modify the name of the output table in the Transform Into field to fit your requirements. This is an optional step.

   Note: The Ledger Stat Table appears as the default setting.

   You cannot use the following characters in the Transform Into field:
   - , (comma)
   - % (percent sign)
   - ” (quotes)
Defining a Transformation ID

The Transformation ID automatically calculates the storage parameters for the output table. These parameters can also be set manually by your database administrator. For more information on output tables, refer to the Transformation Output Table Creation section in the Oracle Financial Services Installation and Configuration Guide.

Note: By default, only the primary key index is created when the output table is generated. For instructions on how to automatically create additional indexes on output tables, refer to the Transformation section in the Oracle Financial Services Installation and Configuration Guide.

3. Check the The Drop Existing Table option to overwrite the existing output table.

The following tables explain processing variables, and the results of using them with the Drop Existing Table option:

<table>
<thead>
<tr>
<th>IF</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Drop Existing Table Option is <strong>checked</strong>,</td>
<td>any table with the same name that appears in the Transform Into field is dropped.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>IF</th>
<th>AND</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Drop Existing Table option is <strong>not checked</strong>, and a valid table name appears in the Transform Into field,</td>
<td>either the Current Month or the Selective Processing option is <strong>checked</strong>,</td>
<td>newly processed data is added into the existing Transform Into table.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>IF</th>
<th>AND</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Drop Existing option is <strong>not checked</strong>,</td>
<td>the Entire Table option is <strong>checked</strong>, and a table exists with the name specified in the Transform Into field,</td>
<td>the Transformation ID stops all processing.</td>
</tr>
</tbody>
</table>
4. Check the Replace Existing Data option to overwrite any previously created data. The following tables explain several processing variables and the results of using them with the Drop Existing Table option:

<table>
<thead>
<tr>
<th>IF</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Entire Table Processing Option is checked,</td>
<td>the Replace Existing Data option is not available.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>IF</th>
<th>AND</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Replace Existing Data option is checked,</td>
<td>new data is being added to an existing table,</td>
<td>any previous data that has identical dates as the new data is replaced.</td>
</tr>
<tr>
<td>the Replace Existing Data option is not checked,</td>
<td>new data is being added to an existing table, and any previous data has identical dates as the new data being added,</td>
<td>the Transformation ID stops all processing.</td>
</tr>
</tbody>
</table>

5. Select one of the following Processing Options:
   - **Current Month**
     
     This option processes the data for the Current Month. The As of Date in the Active Configuration ID specifies the Current Month.
   - **Entire Table**
     
     This option processes all records within the Ledger Stat Table.
   - **Selective Reprocessing**
     
     You can specify a range of dates for processing with this option.

6. Choose a Filtering Type from the list if you want to include a filter.

   **Note:** Filtering narrows the focus of processing to include specific assumptions you define. Three filters used by the Ledger Stat Table include: Data, Folder, and Tree. A list of previously created filter IDs is associated with each filter type.

7. Choose an ID from the Filter list if you want to include a Filter ID.
8. Select the columns you want to exclude from processing in the Leaf Columns to Exclude field. All leaf columns within the Ledger Stat Table appear in the Leaf Columns to Exclude field. After you choose which columns to exclude, at least one column remains and cannot be selected.

**Note:** Your filter cannot include any columns that are selected to be excluded during this step.

The following table explains several processing variables that disable the Leaf Columns to Exclude field:

<table>
<thead>
<tr>
<th>WHEN</th>
<th>IF</th>
<th>AND</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Transform Into Table already exists, and</td>
<td>the Drop Existing Table option is <strong>not</strong> checked,</td>
<td>the Current Month or the Selective Processing option is selected,</td>
<td>the Leaf Columns to Exclude field cannot be changed.</td>
</tr>
</tbody>
</table>

**Risk Manager Result Detail Table**

The Risk Manager Result Detail Table stores processing results from the Oracle Risk Manager product. To define a Risk Manager Result Detail Table, complete the following steps:

1. Select Risk Manager Result Detail from the Choose Source Type list. The Risk Manager Result Detail dialog appears.
2. Select a folder from the Folder list.
3. Select a leaf type from the Leaf Type list.
4. Select a Process ID from the list.
5. Modify the name of the output table in the Transform Into field to fit your requirements.
Defining a Transformation ID

Depending on the type of information in the Result_Detail Table, the output tables are appended with either of the following characters:

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>_C</td>
<td>This table contains only the cash flow information (XXX_C).</td>
</tr>
<tr>
<td>_G</td>
<td>This table contains only the GAP information (XXX_G).</td>
</tr>
<tr>
<td>$C</td>
<td>This table contains only the aggregate cash flow information (XXX$C).</td>
</tr>
<tr>
<td>$G</td>
<td>This table contains only the aggregate GAP information (XXX$G).</td>
</tr>
</tbody>
</table>

**Note:** If your results are both Cash Flow and GAP, then output tables are created as appropriate with the extensions of _C and _G. For aggregated results, output tables with the extensions $C and $G are created.

6. Check the The Drop Existing Table option to overwrite the existing output table. The following table explains a processing variable and the result of using it with the Drop Existing Table option:

<table>
<thead>
<tr>
<th>IF</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Drop Existing Table Option is checked,</td>
<td>any table with the same name that appears in the Transform Into field is dropped.</td>
</tr>
</tbody>
</table>

7. Select the names that appear in the Columns to Exclude field to exclude during processing. This field shows only valid leaf columns from the Result Detail Table. After you choose which columns to exclude, at least one column remains and cannot be selected.

Tree Rollup Table

The Transformation ID extracts data for one rollup and places the data into a customized table specific to that rollup.

To define a Tree Rollup Table, complete the following steps:

1. Select Tree Rollup from the Choose Source Type list. The Tree Rollup dialog appears.
2. Select a folder from the Folder list.
3. Select a leaf type from the Leaf Type list.
4. Select a Tree Rollup ID from the Tree Rollup ID list.

5. Modify the name of the output table in the Transform Into field to fit your requirements.

6. Check the The Drop Existing Table option to overwrite the existing output table. The following table explains a processing variable and the result of using it with the Drop Existing Table option:

<table>
<thead>
<tr>
<th>IF</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the Drop Existing Table Option is <strong>checked</strong>,</td>
<td>any table with the same name that appears in the Transform Into field is dropped.</td>
</tr>
</tbody>
</table>
The SQL ID (also referred to as the Manual Entry ID) provides a window for direct manipulation of the database using Structured Query Language (SQL) statements and procedures. You can immediately process SQL statements or create stored procedures to be executed later. Stored procedures (named and encapsulated sequences of statements) are stored on the server and can be called later from other statements.

The SQL ID offers SQL users several advantages. It is sometimes faster to type and run SQL code directly, and by using stored procedures and functions, you have tailored, logical, reusable modules.

**SQL Compatibility**

SQL ID requires SQL statements and procedures that are compatible with the database.

**SQL User Requirements**

The SQL ID provides an easy-to-use SQL input dialog. If you are not an expert in SQL or familiar with your database structure, however, contact your project manager for information about using the Oracle Customer Support options available to you. Oracle Customer Support can work with you to create and execute any necessary SQL statements and stored procedures.

---

**Note:** The SQL ID is a direct link to the database and writes changes without prior confirmation. Misuse of the SQL ID can severely damage the database.
Define an SQL ID

To define an SQL ID, click the New icon on the horizontal toolbar and then click the SQL ID icon on the vertical toolbar. As an alternative, click New From the File menu and then click SQL. Proceed as described in the Overview of IDs chapter below. The SQL ID dialog appears.

SQL Type
You have two options before processing or saving an SQL ID:

- SQL Statement(s) (This is the default for new SQL IDs. Select this option to create one or more SQL statements. A statement-type ID can be processed immediately.)

- Stored Procedure (Select this option to run an SQL block or create a stored procedure, that is, a subprogram stored on the server. A stored procedure is available for execution when it is called from another stored procedure or SQL block. (See Notes on Stored Procedures below.)

The Input Window
Once you have selected the type of SQL ID you want to create, click in the window and begin typing your command(s).

Process an SQL ID

To Process your SQL ID, you can either:

- Click the Run icon on the horizontal toolbar

- Click Run from the Process menu

Below the Input Window is the process status box. It informs you whether or not your ID execution was successful.

Edit an SQL ID

To edit an SQL ID, you have two options. You can click the Open icon on the horizontal toolbar and then click the SQL ID icon on the vertical toolbar. Or you can click Open from the File menu and then click SQL ID. The Select Manual Entry ID dialog appears.
Notes on Stored Procedures

Group
Select the name of the Group under which this predefined ID was created. Click the arrow to drop down a list of groups.

SQL ID
Click the ID Name box to drop down a list of IDs. Scroll to the ID and then click the ID. (If you know the name of the ID that you want to open, you can type the first letter of the ID to reach that portion of the alphabetized list and then click the name of the ID.) Click OK to continue. The ID dialog appears. Click Cancel at any time to cancel the Select operation before the ID is selected.

With the ID open, you can make your changes following the principles described above in Define an SQL ID. You can immediately process the ID or save it and process it later. Save the ID by clicking the Save icon on the horizontal toolbar, or click Save from the File menu.

Notes on SQL Block
An SQL Block is an encapsulated sequence of SQL statements that can be executed but not stored.

Syntax example:

```
DECLARE
  [local declarations]
BEGIN
  executable statements
  [EXCEPTION
   exception handlers]
END;
```

The SQL Block contains three parts: declarations, executables, and exception-handlers. Declarations are placed between the keyword DECLARE and BEGIN. Executables are placed between the keyword BEGIN and EXCEPTION or END. At least one statement must appear in the executable section. Exception handlers are placed between the keyword EXCEPTION and END.

Notes on Stored Procedures
A stored procedure is a named and encapsulated sequence of SQL statements. The sequence is stored on the server for execution when called from another routine.
The term procedure used in the context of stored procedure is possibly misleading. stored procedures actually consist of two SQL statement types, procedures and functions.

Procedures

A procedure is a subprogram that performs a specific action.

Syntax example:

```
PROCEDURE name [{parameter [, parameter, . . .] } ] AS
[local declarations]
BEGIN
 executable statements
 [EXCEPTION
 exception handlers]
END [name];
```

Parts of a Procedure

A procedure contains two parts, the specification and the body.

Specification  The specification begins with the keyword PROCEDURE and ends with the procedure name or optional parameters.

Body  The body begins with the keyword AS and ends with the keyword END followed by an optional procedure name.

The body contains three parts: declarations, executable statements, and exception-handlers. Declarations are placed between the keywords IS and BEGIN. Executables are placed between the keywords BEGIN and EXCEPTION or END. At least one statement must appear in the executable section. Exception handlers are placed between the keywords EXCEPTION and END. A line ends with a semicolon.

Functions

A function is a subprogram that returns a value. Functions are structured the same as procedures except that functions have a RETURN clause.

Syntax example:

```
FUNCTION name [{argument [, argument, . . .] } ] RETURN datatype IS
[local declarations]
BEGIN
 executable statements
```

15-4  Oracle Financial Data Manager Balance & Control Reference Guide
[EXCEPTION
exception handlers]
END [name];

---

**Note:** The datatype specifier must be unrestrained.

### Calling Stored Procedures or Functions

You can call stored procedures or functions from:

- Another stored procedure or function
- Within a procedural block from the Balance and Control SQL ID in Stored Procedures mode
- Other applications, such as precompilers
- Tools, such as SQL*Plus, SQL*Forms, and SQL*DBA

Before executing a stored procedure or function, the database marks a *save-point*. If any stored procedure or function fails with an unhandled exception before returning to the host environment, Balance and Control undoes any changes made to the database and rolls back the save-point. If there is a Commit (CHECK) statement in the stored procedure, however, Balance and Control undoes any changes made to the database and rolls back to the last Commit statement.

To call a procedure that was previously stored on the server from a SQL ID, use the following syntax (assuming the user name is Sam):

```sql
BEGIN sam.proc_name [ (argument [, argument, ... ]) ]; GET FORMAT FOR CODE END;
```

All arguments are optional and must be surrounded by parentheses. The SQL ID should be saved as a stored procedure and then run.

You will also need to grant execution rights on the SQL ID.

---

**SQL ID Examples**

You can use Balance and Control SQL ID to execute or create stored procedures.
Generating Aggregations Data for Instrument Tables

**Executing a Stored Procedure**

To use the Balance and Control SQL ID, click the SQL Type. Then click in the Input Window and enter the statements.

Now click the Run icon on the horizontal toolbar. The statement processes immediately. The success or failure of the process is displayed in the Process Status box directly below the window.

**Creating a Stored Procedure**

To create a stored procedure, click the SQL Type. Then click the input window and enter the code.

When you click the Run icon, the ID does not process against the database immediately. It is stored on the server, available for execution when the procedure lookup is called from another routine.

**Generating Aggregations Data for Instrument Tables**

In conjunction with the Tables and Columns ID, you can use the SQL ID to generate aggregations data for Instrument tables. When you use this aggregation data, Risk Manager processing is typically faster.

**Setting up the Aggregations Instrument Table**

To set up the table, do the following:

1. Log into Oracle Financial Data Manager Administration.
2. Create a new Tables and Columns ID.
3. Choose the Create Portfolio function.
4. Enter the following information:
   - Table Name
   - Table Display
   - Table Definition
5. Modify the Initial and Next extents, as appropriate.
6. Add any additionally required columns.
7. Modify the index, as required.
8. Run the Tables and Columns ID.

**Generating Aggregations**

To generate aggregations, do the following:

1. Log into Oracle Financial Data Manager Balance and Control.
2. Create a new SQL ID.
3. Keep the SQL Type checked as SQL Statements.
4. Enter the following SQL:

   ```sql
   INSERT INTO <aggregation table name> (identity_code, id_number, gl_account_id, org_unit_id, common_coa_id, as_of_date, interest_rate_cd, origination_date, <other columns>)
   SELECT identity_code, MAX(id_number), gl_account_id, org_unit_id, common_coa_id, as_of_date, interest_rate_cd, origination_date, <group by columns>,
   SUM(<sum column>),
   AVG(<average column>),
   DECODE(SUM(<weighting balance column>), 0, 0, SUM(<weighting balance column>*<rate column>)/SUM(<weighting balance column>))
   FROM <source table name>
   WHERE as_of_date = TO_DATE('<date>','mm/dd/yyyy'),
   <other where clause items>
   GROUP BY
   ```
Generating Aggregations Data for Instrument Tables

identity_code,
gl_account_id,
org_unit_id,
common_coa_id,
as_of_date,
interest_rate_cd,
origination_date,
<group by columns>;

5. Change <aggregation table name> to the name of the destination table.

6. For the additional columns you would like to populate, add the column names in the place of <other columns>. Make sure that all columns that are specified as NOT NULL columns are in the list. Also, make sure you have a comma (,) after each column name, except for the last column, which needs a right parenthesis.

Note: You can select from four types of columns from the source table: sums, averages, weighted averages, and group-by columns. If a column does not make sense to aggregate (such as leaves, codes, and descriptions), it should be a group-by column. All other columns are either summed, averaged, or weighted averaged.

7. Add the column names for the columns that you are adding to the group-by statement. You must add these names in both places that say <group by columns>. Make sure that you have a comma after each column name except for the one in front of the semicolon.

8. For the first summation column, replace the <sum column> with the name of the column. For each additional summation column, repeat the formula, replacing the first column name with the appropriate column name.

9. For the first average column, replace the <average column> with the name of the column. For each additional average column, repeat the formula, replacing the first column name with the appropriate column name. If you have no average columns, delete the entire AVG(<average column>), line.

10. Complete the DECODE statement for each rate column. In the <weighting balance column> fields, enter the balance field that should be used to weight each rate. Put the rate column name in the space marked <rate column>. If you are not using any rate columns, delete the entire DECODE section.

11. Replace <source table name> with the name of the source table.
12. Replace <date> with the as-of date for the month of data being aggregated. You can use this SQL statement to aggregate only one month of data at a time. Make sure that you either use the format specified or change the specified format.

13. Add any additional where clauses that you want to be placed on the source table.

14. Save the SQL ID.

15. Run the SQL ID.

**SQL Talk**

When you want quick and effective SQL communication with your database and you do not need to save your script (as in SQL ID), use the SQL Talk dialog.

**Opening SQL Talk**

To open SQL Talk, you have two options. You can either:

- Click the SQL Talk icon on the vertical toolbar
- Click SQL Talk from the Process menu

The SQL Talk dialog appears.

Enter your SQL script in the top portion of the dialog, ending your statement with the standard SQL semi-colon, and press Ctrl-Enter to run the command. The bottom portion of the dialog displays a spreadsheet of the data.

While the data is being fetched from the database, the dialog displays a “Fetching...” dialog. To interrupt the Fetch, click the Cancel button on this dialog. The data fetched up to the interruption is displayed.

**Maximum Rows**

The maximum number of rows that you can select from the database through SQL Talk is 16,000 rows. If you issue a select statement that reaches or exceeds this threshold, you receive a SQL Talk Error: “Only 16,000 rows can be displayed...abortion.”

The output window contains only the first 16,000 rows of your select statement. Since the query you process against the database is stored in RAM, performance of how fast rows are fetched depends on the number of columns you select. The more
columns you select, the slower the fetching process will be. Be sure to select only the columns you want to see in order to expedite row fetching.

Closing SQL Talk

When you have finished using SQL Talk, click the Close icon on the horizontal toolbar.
Cash Flow Correction Rules

Cash flow edits are done through a Data Correction Processing ID. The first Correction Rule ID in the Rule Base list of any Correction Processing ID will be the OFSA Cash Flow Edits.

This ‘rule’ actually contains a series of edit checks that can be applied to the cash flow columns of any Instrument Table that contains all of the cash flow columns. The purpose of the Cash Flow Edits is to prevent inconsistent and/or incomplete data from interrupting processing of cash flows in any OFSA module that uses them. Consequently, the Cash Flow Edits must be processed prior to processing with any OFSA product that utilizes cash flow modeling, including Risk Manager and Transfer Pricing. Be cautioned that these rules apply broad assumptions in order to complete inconsistent data and should not be used in place of customized data edits tailored to individual institution data. These edits should be run after all customized data edits have been run.

Processing the Cash Flow Edits

To Define a Correction Processing ID that will process the cash flow edits, follow these steps:

1. Choose an Instrument Table with cash flow columns.
   
   The cash flow edits will only process against an Instrument Table with cash flow columns. (i.e., the same list of tables that you are allowed to process in Transfer Pricing and/or Risk Manager).

2. Choose a Filter ID, if applicable.

3. Select the CASHFLOW_EDIT.<OFSA> Correction Rule.

   Choose this rule only. It will not process in combination with other Correction Rule IDs.
4. Choose Client or Server Processing
   The cash flow edits can be processed on either the server or the client.

5. Choose Update Records Individually
   The cash flow edits cannot be run in bulk, only individually. Even if the bulk flag is checked, the rules will be run individually.

6. Optional (Update Log Only)
   The Cash Flow Edits will change the value of any inconsistent data that it encounters. If you are unsure of the quality of your data, use the Update Error Log Only option.

This option warns you of the changes that the process will make, without actually changing data. Only when you are comfortable with the results of the error log (Process_Errors) should you run the cash flow edits with the Update Log Only option Off.

### Cash Flow Edit Logic

The following is a list of the edits that should be performed in the order that they should be performed:

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Condition</th>
<th>Assignment</th>
<th>Error Level</th>
<th>Warning</th>
<th>Description/Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>9106</td>
<td>AMRT_TERM_MULT not equal to D, M, or Y</td>
<td>AMRT_TERM_MULT = 'M'</td>
<td>2</td>
<td>Invalid AMRT_TERM_MULT</td>
<td>Checks for valid amortization term multipliers</td>
</tr>
<tr>
<td>9107</td>
<td>NEG_AMRT_EQ_MULT not equal to D, M, or Y</td>
<td>NEG_AMRT_EQ_MULT = 'M'</td>
<td>2</td>
<td>Invalid NEG_AMRT_EQ_MULT</td>
<td>Checks for valid Neg. Amortization Eq. Multipliers</td>
</tr>
<tr>
<td>9109</td>
<td>ORG_TERM_MULT not equal to D, M, or Y</td>
<td>ORG_TERM_MULT = 'M'</td>
<td>2</td>
<td>Invalid ORG_TERM_MULT</td>
<td>Checks for valid Original term multipliers</td>
</tr>
<tr>
<td>9112</td>
<td>PMT_FREQ_MULT not equal to D, M, or Y</td>
<td>PMT_FREQ_MULT = 'M'</td>
<td>2</td>
<td>Invalid PMT_FREQ_MULT</td>
<td>Checks for valid payment frequency multipliers</td>
</tr>
<tr>
<td>9117</td>
<td>REPRICE_FREQ_MULT not equal to D, M, or Y</td>
<td>REPRICE_FREQ_MULT = 'M'</td>
<td>2</td>
<td>Invalid REPRICE_FREQ_MULT</td>
<td>Checks for valid reprice frequency multipliers</td>
</tr>
<tr>
<td>9115</td>
<td>RATE_SET_LAG_MULT not equal to D, M, or Y</td>
<td>RATE_SET_LAG_MULT = 'M'</td>
<td>2</td>
<td>Invalid RATE_SET_LAG_MULT</td>
<td>Checks for valid rate set lag multipliers</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Condition</td>
<td>Assignment</td>
<td>Error Level</td>
<td>Warning</td>
<td>Description/Purpose</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>-------------</td>
<td>-------------</td>
<td>-------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>9111</td>
<td>PMT_CHG_FREQ_MULTI not equal to D, M, or Y</td>
<td>PMT_CHG_FREQ_MULTI equal to 'M'.</td>
<td>2</td>
<td>Invalid</td>
<td>Checks for valid payment change frequency multipliers</td>
</tr>
<tr>
<td>9105</td>
<td>AMRT_TYPE_CD (&lt;=999 and not equal to 100, 200, 400, 500, 600, 700, 710, 800, 801, 802, 820, 830, or 999) or &gt;299999</td>
<td>Set AMRT_TYPE_CD equal to 700'.</td>
<td>2</td>
<td>Invalid</td>
<td>Checks that amortization type codes are either in the user defined range or that they are a valid OFSA code.</td>
</tr>
<tr>
<td>9166</td>
<td>If REPRICE_FREQ &lt; 0</td>
<td>REPRICE_FREQ = 0</td>
<td>2</td>
<td>Reprice_Freq &lt; 0</td>
<td>Reprice frequencies must not be negative</td>
</tr>
<tr>
<td>9167</td>
<td>If AMRT_TYPE_CD = 710 and REPRICE_FREQ &lt; &gt; 0</td>
<td>REPRICE_FREQ = 0</td>
<td>2</td>
<td>Rule of 78s Reprice_Freq&lt;&gt;0</td>
<td>Rule of 78’s instruments are implicitly fixed.</td>
</tr>
<tr>
<td>9155</td>
<td>IF INTEREST_RATE_CD &lt; 0 or INTEREST_RATE_CD &gt; 999</td>
<td>INTEREST_RATE_CD = 0</td>
<td>2</td>
<td>Int Rf Code Out of Range</td>
<td>Interest rate code must be within a valid range.</td>
</tr>
<tr>
<td>9156</td>
<td>NET_MARGIN_CD &lt;&gt; 0 and NET_MARGIN_CD &lt;&gt; 1</td>
<td>NET_MARGIN_CD = 0</td>
<td>2</td>
<td>Invalid Net Margin Code</td>
<td>Valid net margin codes are 0 or 1.</td>
</tr>
<tr>
<td>9157</td>
<td>T_RATE_INT_RATE_CD &lt; 0 or T_RATE_INT_RATE_CD &gt; 999</td>
<td>T_RATE_INT_RATE_CD = 999</td>
<td>2</td>
<td>T Rate Int Rf Cd Out of Rng</td>
<td>T rate interest rate code must be within a valid range.</td>
</tr>
<tr>
<td>9104</td>
<td>ACCRUAL_BASIS_CD &lt;1 or &gt;6</td>
<td>ACCRUAL_BASIS_CD equal to '3'.</td>
<td>2</td>
<td>Invalid Accrual Basis Cd</td>
<td>Accrual basis code must be between 1 and 6 inclusively</td>
</tr>
<tr>
<td>9114</td>
<td>RATE_CHG_RDND_CD &lt;0 or &gt;4</td>
<td>RATE_CHG_RDND_CD equal to '0'.</td>
<td>2</td>
<td>Invalid Rate Chg Rnd Cd</td>
<td>Rate change round code must be between 0 and 4</td>
</tr>
<tr>
<td>9132</td>
<td>(CUR_PAYMENT &lt; 0 and CUR_PAR_BAL &gt; 0) or (CUR_PAYMENT &gt; 0 and CUR_PAR_BAL &lt; 0)</td>
<td>Set CUR_PAYMENT equal to 0.</td>
<td>2</td>
<td>Pmt, bal opposite signs</td>
<td>Current payment and current balance can not have opposite signs</td>
</tr>
<tr>
<td>9158</td>
<td>If CUR_BOOK_BAL &lt;&gt; (CUR_PAR_BAL + DEFERRED_CUR_BAL)</td>
<td>Warning Only</td>
<td>1</td>
<td>CurBkBl &lt;&gt; ParBl + DefBl</td>
<td>Current book balance should equal the current par balance plus the deferred current balance</td>
</tr>
<tr>
<td>9159</td>
<td>CUR_NET_PAR_BAL_C - CUR_PAR_BAL * (1 - PERCENT_SOLD/100) &gt;.001</td>
<td>Warning</td>
<td>1</td>
<td>NetParBl&lt;&gt;Com ptd NetParBl</td>
<td>Current net par balance should reflect the bank-owned portion of the current gross balance</td>
</tr>
<tr>
<td>9168</td>
<td>ORG_PAR_BAL = 0 and REPRICE_FREQ = 0</td>
<td>Warning</td>
<td>1</td>
<td>OrgParBal=0! Fixed Rate</td>
<td>For transfer pricing of fixed rate instruments, the original balance should be populated,</td>
</tr>
</tbody>
</table>
### Cash Flow Edit Logic

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Condition</th>
<th>Assignment</th>
<th>Error Level</th>
<th>Error Code</th>
<th>Warning</th>
<th>Description/Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>9152</td>
<td>ORG_PAR_BAL &lt; CUR_PAR_BAL and AMRT_TYPE_CD = 710</td>
<td>message only: OrgParBal &lt; CurParBal</td>
<td>1</td>
<td>Org Par Bal &lt; Cur Par Bal</td>
<td></td>
<td>Original balance on rule of 78’s instruments should not be greater than current balance</td>
</tr>
<tr>
<td>9160</td>
<td>IF AMRT_TYPE_CD = 600 and PMT_DECR_CY &lt; 0</td>
<td>PMT_DECR_CY = 0</td>
<td>2</td>
<td>Payment Decrease Cycle =0</td>
<td></td>
<td>Payment decrease cycle cannot be less than zero (Neg Am instruments only)</td>
</tr>
<tr>
<td>9127</td>
<td>ORG_PAYMENT_AMT = 0 and PMT_DECR_LIFE &gt; 0 and AMRT_TYPE_CD = 600</td>
<td>Set PMT_DECR_LIFE equal to 0.</td>
<td>2</td>
<td>Org Pmt=0, Pmt Dec Lf&lt;&gt;0</td>
<td></td>
<td>Payment decrease life is expressed as a percent of a zero original payment. (Neg Am instruments only)</td>
</tr>
<tr>
<td>9162</td>
<td>IF AMRT_TYPE_CD = 600 and PMT_DECR_LF &lt;&gt; 0 and CUR_PAYMENT &lt; ORG_PAYMENT_AMT * (1 - PMT_DECR_LF/100)</td>
<td>Warning Only</td>
<td>1</td>
<td>Cur Pmt &lt; Life Pay Floor</td>
<td></td>
<td>Current payment is less than the minimum payment amount (Neg Am instruments only)</td>
</tr>
<tr>
<td>9161</td>
<td>IF AMRT_TYPE_CD = 600 and PMT_DECR_LF &lt; 0</td>
<td>Set PMT_DECR_LIFE equal to 0.</td>
<td>2</td>
<td>PmtDecrLfé0 for Adj NegAm</td>
<td></td>
<td>Payment decrease life cannot be less than zero (Neg Am instruments only)</td>
</tr>
<tr>
<td>9136</td>
<td>AMRT_TYPE_CD = 600 and PMT_INCR_CYCLE &lt; 0</td>
<td>Set PMT_INCR_CYCLE equal to 0.</td>
<td>2</td>
<td>Pmt Incr Cycle &lt; 0</td>
<td></td>
<td>Payment increase cycle cannot be less than zero (Neg Am instruments only)</td>
</tr>
<tr>
<td>9128</td>
<td>ORG_PAYMENT_AMT = 0 and PMT_INCR_LIFE &gt; 0 and AMRT_TYPE_CD = 600</td>
<td>Set PMT_INCR_LIFE equal to 0.</td>
<td>2</td>
<td>Org Pmt=0, Pmt Incr Lf&lt;&gt;0</td>
<td></td>
<td>Payment increase life is expressed as a percent of a zero original payment. (Neg Am instruments only)</td>
</tr>
<tr>
<td>9163</td>
<td>IF AMRT_TYPE_CD = 600 and PMT_INCR_LF &lt; 0</td>
<td>Set PMT_INCR_LIFE equal to 0.</td>
<td>2</td>
<td>PmtIncrLf&lt;0 for Adj NegAm</td>
<td></td>
<td>Payment increase life cannot be less than zero (Neg Am instruments only)</td>
</tr>
<tr>
<td>9164</td>
<td>IF AMRT_TYPE_CD = 600 and PMT_INCR_LF &lt;&gt; 0 and CUR_PAYMENT &gt; ORG_PAYMENT_AMT * (1 + PMT_INCR_LF/100)</td>
<td>Warning Only</td>
<td>1</td>
<td>Cur Pmt &gt; Life Pay Cap</td>
<td></td>
<td>Current payment is greater than the maximum payment amount (Neg Am instruments only)</td>
</tr>
<tr>
<td>9141</td>
<td>RATE_DECR_CYCLE &lt; 0</td>
<td>RATE_DECR_CYCLE equal to 0.</td>
<td>2</td>
<td>Rate Decr Cycle &lt; 0</td>
<td></td>
<td>Rate decrease cycle must not be negative</td>
</tr>
<tr>
<td>9144</td>
<td>RATE_FLOOR_LIFE &gt; CUR_NET_RATE</td>
<td>message only: Rt Floor Lf &gt; Cur Net Rt</td>
<td>1</td>
<td>Rt Floor Lf &gt; Cur Net Rt</td>
<td></td>
<td>Rate floor life must not be greater than the current net rate</td>
</tr>
</tbody>
</table>

---

A-4 Oracle Financial Data Manager Balance & Control Reference Guide
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Condition</th>
<th>Assignment</th>
<th>Error Level</th>
<th>Warning</th>
<th>Description/Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>9145</td>
<td>RATE_INCR_CYCLE &lt; 0</td>
<td>RATE_INCR_CYCLE equal to 0.</td>
<td>2</td>
<td>Rate Incr Cycle &lt; 0</td>
<td>Rate increase cycle can not be less than 0</td>
</tr>
<tr>
<td>9103</td>
<td>CUR_NET_RATE &lt; 0</td>
<td>message only: Current Net Rate &lt; 0</td>
<td>1</td>
<td>Current Net Rate &lt; 0</td>
<td>Current net rate must not be negative</td>
</tr>
<tr>
<td>9102</td>
<td>CUR_GROSS_RATE &lt; 0</td>
<td>message only: Current Gross Rate &lt; 0</td>
<td>1</td>
<td>Current Gross Rate &lt; 0</td>
<td>Current gross rate must not be negative</td>
</tr>
<tr>
<td>9108</td>
<td>(NEG_AMRT_LIMIT &gt;= 200) or (NEG_AMRT_LIMIT &lt; 0) and AMRT_TYPE_CD = 600</td>
<td>Set NEG_AMRT_LIMIT equal to 0.</td>
<td>2</td>
<td>Invalid NgAm Limit</td>
<td>Neg Am limit value does not fall in a valid range. (Neg Am instruments only)</td>
</tr>
<tr>
<td>9140</td>
<td>RATE_CHG_MIN &lt; 0</td>
<td>Set RATE_CHG_MIN equal to 0.</td>
<td>2</td>
<td>Rate Chg Min &lt; 0</td>
<td>Minimum rate change can not be negative</td>
</tr>
<tr>
<td>9139</td>
<td>RATE_CAP_LIFE &lt; CUR_NET_RATE and RATE_CAP_LIFE &lt;&gt; 0</td>
<td>message only: Rt Cap Life &lt; Cur Net Rt</td>
<td>1</td>
<td>Rt Cap Life &lt; Cur Net Rt</td>
<td>Current net rate is greater than the rate cap</td>
</tr>
<tr>
<td>9118</td>
<td>RATE_CHG_RND_FAC &lt; 0 or RATE_CHG_RND_FAC &gt; 1</td>
<td>Set RATE_CHG_RND_FAC equal to 0.</td>
<td>2</td>
<td>Invalid Rt Chg Rnd Fact</td>
<td>Rate change round factor must be a percentage</td>
</tr>
<tr>
<td>9138</td>
<td>RATE_CAP_LIFE &lt; CUR_GROSS_RATE and RATE_CAP_LIFE &lt;&gt; 0 and CUR_GROSS_RATE &lt;= CUR_GROSS_RATE</td>
<td>Set RATE_CAP_LIFE equal to CUR_GROSS_RATE.</td>
<td>1</td>
<td>Rt Cap Lf &lt; Cur Gross Rt</td>
<td>Current gross rate is greater than the rate cap life</td>
</tr>
<tr>
<td>9143</td>
<td>RATE_FLOOR_LIFE &gt; CUR_GROSS_RATE and CUR_GROSS_RATE &lt;&gt; 0 and TEASER_END_DATE &lt; AS_OF_DATE</td>
<td>Set RATE_FLOOR_LIFE equal to CUR_GROSS_RATE.</td>
<td>1</td>
<td>Rt Floor Lf &gt; Cur Gross Rt</td>
<td>Current gross rate is less than the rate floor</td>
</tr>
<tr>
<td>9130</td>
<td>(ORIGINATION_DATE &lt; 01/01/1950) or (ORIGINATION_DATE &gt; 01/01/2099)</td>
<td>Set ORIGINATION_DATE = 01/01/1950.</td>
<td>2</td>
<td>Orig. Dt &lt; 01/01/1950</td>
<td>Origination date must be acceptable</td>
</tr>
<tr>
<td>9165</td>
<td>IF ISSUE_DATE &gt; ORIGINATION_DATE</td>
<td>Set ISSUE_DATE = ORIGINATION_DATE</td>
<td>2</td>
<td>Issue Date &gt; Orig Date</td>
<td>Issue date can not be greater than origination date</td>
</tr>
<tr>
<td>9124</td>
<td>ORIGINATION_DATE &gt;= AS_OF_DATE and ORIGINATION_DATE &gt;= NEXT_PAYMENT_DATE</td>
<td>NEXT_PAYMENT_DATE = ORIGINATION_DATE + 1 day</td>
<td>2</td>
<td>Next Pmt Dt &lt; Org Dt</td>
<td>Next payment date is less than origination date (future origination case)</td>
</tr>
</tbody>
</table>
### Cash Flow Edit Logic

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Condition</th>
<th>Assignment</th>
<th>Error Level</th>
<th>Warning</th>
<th>Description/Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>9123</td>
<td>( \text{AS_OF_DATE} &gt; \text{ORIGINATION_DATE} ) and ( \text{AS_OF_DATE} &gt;= \text{NEXT_PAYMENT_DATE} )</td>
<td>( \text{NEXT_PAYMENT_DATE} ) equal to ( \text{AS_OF_DATE} + 1 ) day.</td>
<td>2</td>
<td>( \text{Next Pmt Dt} &lt; \text{As of Dt} )</td>
<td>Next payment date is less than as-of-date (past origination case) As of Date can not be greater than the origination date and greater than the next payment date.</td>
</tr>
<tr>
<td>9125</td>
<td>( \text{ORIGINATION_DATE} &lt;= \text{AS_OF_DATE} ) and ( \text{NEXT_REPRICE_DATE} &lt;= \text{AS_OF_DATE} ) and ( \text{REPRICE_FREQ} &gt; 0 )</td>
<td>( \text{NEXT_REPRICE_DATE} ) equal to ( \text{AS_OF_DATE} + 1 ) day.</td>
<td>2</td>
<td>( \text{Next Repr Dt} &lt; \text{As of Dt} )</td>
<td>Next reprice date is less than as-of-date (past origination case)</td>
</tr>
<tr>
<td>9126</td>
<td>( \text{ORIGINATION_DATE} &gt; \text{AS_OF_DATE} ) and ( \text{NEXT_REPRICE_DATE} &lt; \text{ORIGINATION_DATE} ) and ( \text{REPRICE_FREQ} &gt; 0 )</td>
<td>Set ( \text{NEXT_REPRICE_DATE} ) equal to ( \text{ORIGINATION_DATE} + 1 ) day.</td>
<td>2</td>
<td>( \text{Next Repr Dt} &lt; \text{Org Dt} )</td>
<td>Next reprice date is less than the origination date (future origination case)</td>
</tr>
<tr>
<td>9169</td>
<td>If ( \text{REPRICE_FREQ} &lt;&gt; 0 ) and ( \text{TEASER_END_DATE} &gt; \text{ORIGINATION_DATE} ) and ( \text{TEASER_END_DATE} &gt; \text{AS_OF_DATE} ) and ( \text{NEXT_REPRICE_DATE} &gt; \text{TEASER_END_DATE} )</td>
<td>Set ( \text{NEXT_REPRICE_DATE} ) equal to ( \text{TEASER_END_DATE} )</td>
<td>2</td>
<td>( \text{Next Repr Dt} &gt; \text{Ts End Dt} )</td>
<td>Next reprice date is greater than tease end date.</td>
</tr>
<tr>
<td>9121</td>
<td>If ( \text{AMRT_TYPE_CD} = \text{600} ) and ( \text{NEG_AMRT_EQ_FREQ} &gt; 0 ) and ( \text{NEG_AMRT_EQ_DATE} &lt;= \text{MAX(ORIGINATION_DATE, AS_OF_DATE)} )</td>
<td>Set ( \text{NEG_AMRT_EQ_DATE} ) equal to ( \text{NEXT_REPRICE_DATE} )</td>
<td>2</td>
<td>( \text{NgAm Eq Dt} &lt; \text{Org Dt} )</td>
<td>Neg Am equalization date is less than origination date (future origination) or less than the as-of-date (past origination) (Neg am instruments only)</td>
</tr>
<tr>
<td>9147</td>
<td>( \text{REMAIN_NO_PMTS_C} &lt; 1 )</td>
<td>( \text{REMAIN_NO_PMTS_C} = 1 )</td>
<td>2</td>
<td>( \text{Rem No Pmts} &lt; 1 )</td>
<td>There has to be at least 1 payment left</td>
</tr>
<tr>
<td>9119</td>
<td>( \text{MATURITY_DATE} &lt; \text{NEXT_PAYMENT_DATE} )</td>
<td>( \text{MATURITY_DATE} = \text{NEXT_PAYMENT_DATE} + ((\text{REMAIN_NO_PMTS_C} -1)/\text{PMT_FREQ}) )</td>
<td>2</td>
<td>( \text{Mat Dt} &lt; \text{Next Pmt Dt} )</td>
<td>Maturity date can not be before the next payment date</td>
</tr>
<tr>
<td>9134</td>
<td>If ( \text{AMRT_TYPE_CD} = \text{600} ) and ( \text{PMT_CHG_FREQ} &gt; 0 ) and ( \text{AS_OF_DATE} &lt; \text{PMT_ADJUST_DATE} ) and ( \text{PMT_ADJUST_DATE} &lt; \text{ORIGINATION_DATE} )</td>
<td>( \text{PMT_ADJUST_DATE} = \text{NEXT_REPRICE_DATE} )</td>
<td>2</td>
<td>( \text{Pmt Adj Dt} &lt; \text{Org Dt} )</td>
<td>Payment adjustment date is less than origination date (future origination) (Neg am instruments only)</td>
</tr>
<tr>
<td>9133</td>
<td>If ( \text{AMRT_TYPE_CD} = \text{600} ) and ( \text{PMT_CHG_FREQ} &gt; 0 ) and ( \text{AS_OF_DATE} &lt; \text{PMT_ADJUST_DATE} )</td>
<td>( \text{PMT_ADJUST_DATE} = \text{NEXT_REPRICE_DATE} )</td>
<td>2</td>
<td>( \text{Pmt Adj Dt} &lt; \text{As of Dt} )</td>
<td>Neg Am equalization date is less than the as-of-date (past origination) (Neg am instruments only)</td>
</tr>
</tbody>
</table>
Cash Flow Edit Logic

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Condition</th>
<th>Assignment</th>
<th>Error Level</th>
<th>Warning</th>
<th>Description/Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>9154</td>
<td>REPRICE_FREQ &lt;&gt; 0 and LAST_REPRICE_DATE &gt; NEXT_REPRICE_DATE</td>
<td>LAST_REPRICE_DATE = NEXT_REPRICE_DATE minus REPRICE_FREQ</td>
<td>2</td>
<td>LastReprDt&gt;NexReprDt</td>
<td>Last reprice date is greater than next reprice date</td>
</tr>
<tr>
<td>9148</td>
<td>RATE_SET_LAG &lt; 0</td>
<td>RATE_SET_LAG = 0</td>
<td>2</td>
<td>Set Lag &lt; 0</td>
<td>Rate set lag can not be negative</td>
</tr>
<tr>
<td>9120</td>
<td>NEG_AMRT_EQ_FREQ &lt; 0 and AMRT_TYPE_CD = 600</td>
<td>NEG_AMRT_EQ_FREQ equal to 0.</td>
<td>2</td>
<td>NegAmEqFrq &lt; 0</td>
<td>Neg Am Equalization frequency cannot be negative (Neg Am instruments only)</td>
</tr>
<tr>
<td>9153</td>
<td>REPRICE_FREQ = 0 and (AMRT_TYPE_CD = 500 or AMRT_TYPE_CD = 600)</td>
<td>message only: AdjAmrtType, ReprFrq=0</td>
<td>1</td>
<td>AdjAmrtType, ReprFrq=0</td>
<td>Reprice frequency denotes fixed on adjustable amortization types (Conventional Adjustable oand Adjustable Neg Am)</td>
</tr>
<tr>
<td>9110</td>
<td>If AMRT_TYPE_CD = 600 and PMT_CHG_FREQ &lt; 0</td>
<td>PMT_CHG_FREQ equal to 0</td>
<td>2</td>
<td>Invalid Pmt Chg Freq</td>
<td>Payment change frequency cannot be negative (Neg Am instrument only)</td>
</tr>
<tr>
<td>9131</td>
<td>PMT_FREQ &gt; calculated original term</td>
<td>PMT_FREQ equal to calculated original term</td>
<td>2</td>
<td>Payment Freq &gt; Org Term</td>
<td>Payment frequency cannot be greater than original term.</td>
</tr>
<tr>
<td>9129</td>
<td>ORG_TERM &lt;&gt; calculated original term within 45 days or ORG_TERM = 0</td>
<td>Set ORG_TRM = calculated original term</td>
<td>2</td>
<td>Org Term&lt;&gt;MatDt - Mat Dt</td>
<td>Original term should equal the time between the origination date and the maturity date.</td>
</tr>
<tr>
<td>9135</td>
<td>PMT_FREQ &lt;= 0 and ORIGINATION_DATE &lt;= AS_OF_DATE and MATURITY_DATE &gt; AS_OF_DATE</td>
<td>NEXT_PAYMENT_DATE = MATURITY_DATE and ORG_TERM = calculated original term and PMT_FREQ = calculated original term and REMAIN_NO_PMTS_C = 1</td>
<td>2</td>
<td>Pmt Freq &lt;= 0, Trm Assumed</td>
<td>Payment frequency is less than or equal to zero, and both maturity date and origination date are valid dates and can be used to calculate payment frequency.</td>
</tr>
<tr>
<td>9135</td>
<td>PMT_FREQ &lt;= 0 and ORIGINATION_DATE &lt;= AS_OF_DATE but NEXT_PAYMENT_DATE &gt; AS_OF_DATE or ORIGINATION_DATE &gt; AS_OF_DATE, MATUREITY_DATE &gt; ORIGINATION_DATE, but NEXT_PAYMENT_DATE &gt; ORIGINATION_DATE</td>
<td>MATURITY_DATE = NEXT_PAYMENT_DATE and ORG_TERM = calculated original term and PMT_FREQ = calculated original term and REMAIN_NO_PMTS_C = 1</td>
<td>2</td>
<td>Pmt Freq &lt;= 0, Trm Assumed</td>
<td>Payment frequency is less than or equal to zero and maturity date is invalid, but next payment date can be used to calculate a valid payment frequency.</td>
</tr>
</tbody>
</table>

Cash Flow Correction Rules  A-7
### Cash Flow Edit Logic

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Condition</th>
<th>Assignment</th>
<th>Error Level</th>
<th>Warning</th>
<th>Description/Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>9135</td>
<td>PMT_FREQ &lt;= 0 and ORIGINATION_DATE &lt;= AS_OF_DATE, MATURITY_DATE &lt;= AS_OF_DATE, and NEXT_PAYMENT_DATE &lt;= AS_OF_DATE or ORIGINATION_DATE &gt; AS_OF_DATE, and both MATURITY_DATE and NEXT_PAYMENT_DATE less than ORIGINATION_DATE</td>
<td>MATURITY_DATE = AS OF DATE + 1 day and NEXT PAYMENT DATE = AS OF DATE + 1 day and ORG TERM = calculated original term and PMT_FREQ = calculated original term and REMAIN_NO_PMTS_C = 1.</td>
<td>2</td>
<td>Pmt Freq &lt;= 0, Trm Assumed</td>
<td>Payment frequency less than or equal to zero and all dates which can be used to calculate payment frequency are in the past.</td>
</tr>
<tr>
<td>9100</td>
<td>If (AMRT_TYPE_CD &lt;&gt; 700 or (AMRT_TYPE_CD = 700 and AMRT_TERM &lt;&gt; 0)) and AMRT_TERM (in days) &lt; ORG TERM (in days)</td>
<td>Set AMRT_TERM equal to ORG_TERM, AMRT_TERM_MULT = ORG_TERM_MULT</td>
<td>2</td>
<td>Org Term &gt; Amrt Term</td>
<td>Amortization term can only be equal to zero on Non/Amortizing instruments.</td>
</tr>
<tr>
<td>9170</td>
<td>If REMAIN_NO_PMTS_C + (REMAIN_TERM_C (in days) / REPRICE_FREQ (in days)) &gt; 2000</td>
<td>Warning</td>
<td>1</td>
<td>&gt;2000 Events for Record</td>
<td>The maximum number of events that can be modeled has been exceeded.</td>
</tr>
<tr>
<td>9171</td>
<td>LRD_BALANCE=0</td>
<td>LRD_BALANCE = CUR PAR_BAL</td>
<td>2</td>
<td>LRDBalance=0</td>
<td>The balance as of the last reprice date cannot be equal to 0</td>
</tr>
<tr>
<td>9172</td>
<td>ADJUSTABLE_TYPE_CD &lt;&gt; 0 and LAST_REPRICE_DATE &lt; ISSUE_DATE</td>
<td>Message Only</td>
<td>1</td>
<td>LastRepriceDate &lt;IssueDate</td>
<td>When the last reprice date is less than the issue date, transfer pricing will not occur.</td>
</tr>
<tr>
<td>9174</td>
<td>REPRICE_FREQ &gt; 0 and ADJUSTABLE_TYPE_CD = 0</td>
<td>Message Only</td>
<td>1</td>
<td>AdjType=0 &amp; ReprFreq&gt;0</td>
<td>Reprice frequency and adjustable type code are inconsistent</td>
</tr>
<tr>
<td>9175</td>
<td>REPRICE_FREQ = 0 and ADJUSTABLE_TYPE_CD &lt;&gt; 0</td>
<td>Message Only</td>
<td>1</td>
<td>AdjType&lt;&gt;0 &amp; ReprFreq=0</td>
<td>Reprice frequency and adjustable type code are inconsistent</td>
</tr>
<tr>
<td>9176</td>
<td>AMRT_TYPE_CD = 100 and ADJUSTABLE_TYPE_CD &lt;&gt; 0</td>
<td>Message Only</td>
<td>1</td>
<td>AdjType&lt;&gt;0 &amp; AmrtType=100</td>
<td>Variable adjustable type on Conventional Fixed instrument.</td>
</tr>
<tr>
<td>9177</td>
<td>AMRT_TYPE_CD = 710 and ADJUSTABLE_TYPE_CD &lt;&gt; 0</td>
<td>ADJUSTABLE_TYPE_CD = 0</td>
<td>2</td>
<td>AdjType&lt;&gt;0 &amp; AmrtType=710</td>
<td>Rule of 78’s instrument should only have a fixed adjustable type code.</td>
</tr>
<tr>
<td>9178</td>
<td>(AMRT_TYPE_CD = 500 or AMRT_TYPE_CD = 600) and ADJUSTABLE_TYPE_CD = 0</td>
<td>Message Only</td>
<td>1</td>
<td>AdjType=0 &amp; Amrt(500,600)</td>
<td>Fixed adjustable type code on adjustable amortization codes (Conventional Adjustable and Adjustable Neg Am)</td>
</tr>
</tbody>
</table>
### Cash Flow Edit Logic

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Condition</th>
<th>Assignment</th>
<th>Error Level</th>
<th>Warning</th>
<th>Description/Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>9179</td>
<td>LAST_PAYMENT_DATE &gt; NEXT_PAYMENT_DATE and PAYMENT_FREQ &gt; 0</td>
<td>LAST_PAYMENT_DATE = NEXT_PAYMENT_DATE - PMT_FREQ</td>
<td>2</td>
<td>LastPayDate&gt;=ExtPayDate</td>
<td>Last payment date is greater than next payment date and can be calculated using payment frequency.</td>
</tr>
<tr>
<td>9179</td>
<td>LAST_PAYMENT_DATE &gt; NEXT_PAYMENT_DATE and PAYMENT_FREQ &lt;= 0</td>
<td>LAST_PAYMENT_DATE = ORIGINATION_DATE</td>
<td>2</td>
<td>LastPayDate&gt;=ExtPayDate</td>
<td>Last payment date is greater than next payment date, but cannot be calculated using payment frequency.</td>
</tr>
<tr>
<td>9180</td>
<td>LAST_PAYMENT_DATE &lt; ORIGINATION_DATE</td>
<td>LAST_PAYMENT_DATE = ORIGINATION_DATE</td>
<td>2</td>
<td>LastPayDate&lt;OrigDate</td>
<td>Last payment date can not be less than the origination date</td>
</tr>
<tr>
<td>9181</td>
<td>LAST_PAYMENT_DATE &gt; AS_OF_DATE and ORIGINATION_DATE &lt;= AS_OF_DATE</td>
<td>LAST_PAYMENT_DATE = AS_OF_DATE</td>
<td>2</td>
<td>LastPayDate&gt;AsOfDate</td>
<td>Last payment date cannot be greater than the as-of-date if the instrument originated in the past.</td>
</tr>
<tr>
<td>9182</td>
<td>INT_TYPE = 2 and AMRT_TYPE_CD = 100, 400, 500, 600 or 800</td>
<td>INT_TYPE = 1</td>
<td>2</td>
<td>IntType&lt;&gt;1,2 / Amrt Type</td>
<td>Interest type can only be arrears for conventionally amortizing instruments.</td>
</tr>
<tr>
<td>9182</td>
<td>INT_TYPE &lt;&gt; 1 or 2</td>
<td>INT_TYPE = 1</td>
<td>2</td>
<td>IntType&lt;&gt;1,2 / Amrt Type</td>
<td>Interest type must be a valid OFSA code.</td>
</tr>
<tr>
<td>9183</td>
<td>COMPOUND_BASIS_CD &lt;&gt; 110, 120, 130, 140, 150, 160, 170 or 200</td>
<td>COMPOUND_BASIS_CD = 160</td>
<td>2</td>
<td>Invalid CompBasisCode</td>
<td>Compounding basis code must be a valid OFSA code.</td>
</tr>
<tr>
<td>9184</td>
<td>(ACCRUAL_BASIS_CD = 1, 4 or 5) and (PMT_FREQ_MULT = D or AMRT_TYPE_CD = 800, 801, or 802)</td>
<td>ACCRUAL_BASIS_CD = 3</td>
<td>2</td>
<td>AmrtType/Accr Basis Error</td>
<td>Accrual basis code cannot have a 30 day month assumption on instruments defined by a payment schedule</td>
</tr>
</tbody>
</table>
There are two Financial Element listings in this appendix. The first lists all elements by element number, the second, by element description.

### Financial Elements Listed by Number

<table>
<thead>
<tr>
<th>Financial Element Description</th>
<th>Financial Element Number</th>
<th>Averaging Type</th>
<th>Weighting Factor</th>
<th>Output Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>Beginning Balance</td>
<td>60</td>
<td>At first</td>
<td>Weighting Standard</td>
<td>Standard</td>
</tr>
<tr>
<td>Beginning Gross Rate</td>
<td>70</td>
<td>At first</td>
<td>By Beginning Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Beginning Net Rate</td>
<td>80</td>
<td>At first</td>
<td>By Beginning Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Beginning Transfer Rate</td>
<td>90</td>
<td>At first</td>
<td>By Beginning Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Ending Balance</td>
<td>100</td>
<td>At last</td>
<td>Weighting Standard</td>
<td>Standard</td>
</tr>
<tr>
<td>Ending Gross Rate</td>
<td>110</td>
<td>At last</td>
<td>By Ending Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Ending Net Rate</td>
<td>120</td>
<td>At last</td>
<td>By Ending Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Ending Transfer Rate</td>
<td>130</td>
<td>At last</td>
<td>By Ending Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Average Balance</td>
<td>140</td>
<td>Daily average</td>
<td>Weighting Standard</td>
<td>Standard</td>
</tr>
<tr>
<td>Average Gross Rate</td>
<td>150</td>
<td>Daily average</td>
<td>By Average Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Average Net Rate</td>
<td>160</td>
<td>Daily average</td>
<td>By Average Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Average Transfer Rate</td>
<td>170</td>
<td>Daily average</td>
<td>By Average Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Prepay Runoff - Positive</td>
<td>180</td>
<td>Sum</td>
<td>Weighting Standard</td>
<td>Standard</td>
</tr>
</tbody>
</table>
## Financial Elements Listed by Number

<table>
<thead>
<tr>
<th>Financial Element Description</th>
<th>Financial Element Number</th>
<th>Averaging Type</th>
<th>Weighting Factor</th>
<th>Output Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>Timing of Prepay Runoff - positive</td>
<td>181</td>
<td>Sum</td>
<td>By Prepay Runoff (positive)</td>
<td>Prepay Detail</td>
</tr>
<tr>
<td>Prepay Runoff - negative</td>
<td>182</td>
<td>Sum</td>
<td></td>
<td>Prepay Detail</td>
</tr>
<tr>
<td>Timing of Prepay Runoff - negative</td>
<td>183</td>
<td>Sum</td>
<td>By Prepay Runoff (negative)</td>
<td>Prepay Detail</td>
</tr>
<tr>
<td>Payment Runoff - positive</td>
<td>190</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Timing of Payment Runoff - positive</td>
<td>191</td>
<td>Sum</td>
<td>By Principal Runoff (positive)</td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Payment Runoff - negative</td>
<td>192</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Timing of Payment Runoff - negative</td>
<td>193</td>
<td>Sum</td>
<td>By Principal Runoff (negative)</td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Maturity Runoff - positive</td>
<td>195</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Timing of Maturity Runoff - positive</td>
<td>196</td>
<td>Sum</td>
<td>By Principal at Maturity (positive)</td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Maturity Runoff - negative</td>
<td>197</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Timing of Maturity Runoff - negative</td>
<td>198</td>
<td>Sum</td>
<td>By Principal at Maturity (negative)</td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Total Runoff - positive</td>
<td>210</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Timing of Total Runoff - positive</td>
<td>211</td>
<td>Sum</td>
<td>By Total Runoff (positive)</td>
<td>Standard</td>
</tr>
<tr>
<td>Total Runoff - negative</td>
<td>212</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Timing of Total Runoff - negative</td>
<td>213</td>
<td>Sum</td>
<td>By Total Runoff (negative)</td>
<td>Standard</td>
</tr>
<tr>
<td>Total Runoff Gross Rate</td>
<td>220</td>
<td>Sum</td>
<td>By Total Runoff</td>
<td>Standard</td>
</tr>
<tr>
<td>Total Runoff Net Rate</td>
<td>230</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Total Runoff Transfer Rate</td>
<td>240</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Before Reprice Balance</td>
<td>250</td>
<td>At First</td>
<td></td>
<td>Repricing</td>
</tr>
<tr>
<td>After Reprice Balance</td>
<td>255</td>
<td>At Last</td>
<td></td>
<td>Repricing</td>
</tr>
<tr>
<td>Before Reprice Gross Rate</td>
<td>260</td>
<td>At First</td>
<td>Before Reprice Balance</td>
<td>Repricing</td>
</tr>
<tr>
<td>Before Reprice Net Rate</td>
<td>270</td>
<td>At First</td>
<td>Before Reprice Balance</td>
<td>Repricing</td>
</tr>
</tbody>
</table>

**B-2** Oracle Financial Data Manager Balance & Control Reference Guide
<table>
<thead>
<tr>
<th>Financial Element Description</th>
<th>Financial Element Number</th>
<th>Averaging Type</th>
<th>Weighting Factor</th>
<th>Output Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before Reprice Transfer Rate</td>
<td>280</td>
<td>At First</td>
<td>Before Reprice Balance</td>
<td>Repricing</td>
</tr>
<tr>
<td>After Reprice Gross Rate</td>
<td>290</td>
<td>At Last</td>
<td>After Reprice Balance</td>
<td>Repricing</td>
</tr>
<tr>
<td>After Reprice Net Rate</td>
<td>300</td>
<td>At Last</td>
<td>After Reprice Balance</td>
<td>Repricing</td>
</tr>
<tr>
<td>After Reprice Transfer Rate</td>
<td>310</td>
<td>At Last</td>
<td>After Reprice Balance</td>
<td>Repricing</td>
</tr>
<tr>
<td>Fully Indexed Gross Rate</td>
<td>320</td>
<td>Sum</td>
<td></td>
<td>Repricing</td>
</tr>
<tr>
<td>Fully Indexed Net Rate</td>
<td>330</td>
<td>Sum</td>
<td></td>
<td>Repricing</td>
</tr>
<tr>
<td>New Add Balance</td>
<td>340</td>
<td>Sum</td>
<td></td>
<td>New Origination</td>
</tr>
<tr>
<td>New Add Gross Rate</td>
<td>350</td>
<td>Sum</td>
<td>New Add Balance</td>
<td>New Origination</td>
</tr>
<tr>
<td>New Add Net Rate</td>
<td>360</td>
<td>Sum</td>
<td>New Add Balance</td>
<td>New Origination</td>
</tr>
<tr>
<td>New Add Transfer Rate</td>
<td>370</td>
<td>Sum</td>
<td>New Add Balance</td>
<td>New Origination</td>
</tr>
<tr>
<td>Roll Add Balance</td>
<td>380</td>
<td>Sum</td>
<td></td>
<td>New Origination</td>
</tr>
<tr>
<td>Roll Add Gross Rate</td>
<td>390</td>
<td>Sum</td>
<td></td>
<td>New Origination</td>
</tr>
<tr>
<td>Roll Add Net Rate</td>
<td>400</td>
<td>Sum</td>
<td></td>
<td>New Origination</td>
</tr>
<tr>
<td>Roll Add Transfer Rate</td>
<td>410</td>
<td>Sum</td>
<td></td>
<td>New Origination</td>
</tr>
<tr>
<td>Interest Cash Flow Net</td>
<td>430</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Interest Cash Flow Gross</td>
<td>435</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Interest Cash Flow Transfer Rate</td>
<td>437</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Interest Accrual - Net</td>
<td>440</td>
<td>Accrual</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Interest Accrual - Gross</td>
<td>445</td>
<td>Accrual</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Interest Accrual - Transfer Rate</td>
<td>450</td>
<td>Accrual</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Non-Interest Income</td>
<td>455</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Non-Interest Expense</td>
<td>457</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Interest Credited</td>
<td>480</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Weighted Average Term</td>
<td>500</td>
<td>Sum</td>
<td>Ending Balance</td>
<td>Standard</td>
</tr>
<tr>
<td>Prepay Rate (Annual)</td>
<td>510</td>
<td>Sum</td>
<td>Prepay Balance</td>
<td>Prepay Detail</td>
</tr>
<tr>
<td>Financial Element Description</td>
<td>Financial Element Number</td>
<td>Averaging Type</td>
<td>Weighting Factor</td>
<td>Output Group</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------</td>
<td>----------------</td>
<td>-----------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Prepay Balance</td>
<td>515</td>
<td>Sum</td>
<td></td>
<td>Prepay Detail</td>
</tr>
<tr>
<td>Deferred Ending Balance</td>
<td>520</td>
<td>At last</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Deferred Average Balance</td>
<td>530</td>
<td>Daily average</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Deferred Runoff</td>
<td>540</td>
<td>Accrual</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Periodic Cap Balance</td>
<td>550</td>
<td>Daily Average</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Periodic Cap Rate</td>
<td>560</td>
<td>Daily Average</td>
<td>Periodic Cap Balance</td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Periodic Cap Effect</td>
<td>570</td>
<td>Accrual</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Lifetime Cap Balance</td>
<td>580</td>
<td>Daily Average</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Lifetime Cap Rate</td>
<td>590</td>
<td>Daily Average</td>
<td>Lifetime Cap Balance</td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Lifetime Cap Effect</td>
<td>600</td>
<td>Accrual</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Tease Balance</td>
<td>610</td>
<td>Daily Average</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Tease Rate</td>
<td>620</td>
<td>Daily Average</td>
<td>Tease Balance</td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Tease Effect</td>
<td>630</td>
<td>Accrual</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>NGAM Balance</td>
<td>640</td>
<td>Daily Average</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>NGAM Interest</td>
<td>650</td>
<td>Accrual</td>
<td></td>
<td>Cap/Floor/Tease/N GAM</td>
</tr>
<tr>
<td>Gap Runoff</td>
<td>660</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Gap Principal Runoff</td>
<td>661</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Repricing Runoff</td>
<td>662</td>
<td>Sum</td>
<td></td>
<td>Repricing</td>
</tr>
<tr>
<td>Gap Deferred Runoff</td>
<td>663</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Runoff Term</td>
<td>670</td>
<td>Sum</td>
<td>By Gap Runoff Bal</td>
<td>Standard</td>
</tr>
<tr>
<td>Financial Element Description</td>
<td>Financial Element Number</td>
<td>Averaging Type</td>
<td>Weighting Factor</td>
<td>Output Group</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>--------------------------</td>
<td>----------------</td>
<td>-----------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Gap Interest Cash Flow</td>
<td>671</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Interest Cash Flow Net Rate</td>
<td>672</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Interest Cash Flow Transfer Rate</td>
<td>673</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Accrued Interest Gross Rate</td>
<td>674</td>
<td>Accrual</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Accrued Interest Net Rate</td>
<td>675</td>
<td>Accrual</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Accrued Interest Transfer Rate</td>
<td>676</td>
<td>Accrual</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Interest Credited</td>
<td>677</td>
<td>Sum</td>
<td></td>
<td>Runoff Detail</td>
</tr>
<tr>
<td>Gap Runoff Gross Rate</td>
<td>680</td>
<td>Sum</td>
<td>By Gap Runoff Bal</td>
<td>Standard</td>
</tr>
<tr>
<td>Gap Runoff Net Rate</td>
<td>690</td>
<td>Sum</td>
<td>By Gap Runoff Bal</td>
<td>Standard</td>
</tr>
<tr>
<td>Gap Runoff Transfer Rate</td>
<td>700</td>
<td>Sum</td>
<td>By Gap Runoff Bal</td>
<td>Standard</td>
</tr>
<tr>
<td>Taxes - Federal</td>
<td>930</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Taxes - Local</td>
<td>935</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
<tr>
<td>Dividends</td>
<td>940</td>
<td>Sum</td>
<td></td>
<td>Standard</td>
</tr>
</tbody>
</table>
Element Type - Cash Flow Financial Elements: Non-Maturity Accounts

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>60 Beg Bal</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>70 Beg Gross</td>
<td></td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>80 Beg Net</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>90 Beg T-Rate</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>100 End Balance</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>110 Ending Gross Rate</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>120 Ending Net Rate</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>130 Ending Transfer Rate</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>140 Average Bal</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>150 Average Gross Rate</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>160 Average Net Rate</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>170 Average Transfer Rate</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>440 Interest Accrued</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>445 Interest Accrued Gross</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>450 Charge/Credit</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Element Type - Cash Flow: Income Statement Accounts

<table>
<thead>
<tr>
<th>Financial Element</th>
<th>Income Interest Income</th>
<th>Non-Interest Expense</th>
<th>Taxes</th>
<th>Dividends</th>
</tr>
</thead>
<tbody>
<tr>
<td>455 Non-Interest Income</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>457 Non-Interest Expense</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>930 Taxes - Federal</td>
<td></td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>935 Taxes - State</td>
<td></td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>940 Dividends</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>
## Financial Elements Listed by Number

### Element Type - Cash Flow: Simple Accounts

<table>
<thead>
<tr>
<th>Financial Element</th>
<th>Simple Acct Type (No T-Rts)</th>
<th>Simple Acct Type (No Grss Rts)</th>
<th>Simple Acct Type (Net Rts)</th>
<th>Simple Acct Type (Multi Rts)</th>
</tr>
</thead>
<tbody>
<tr>
<td>60 Beg Bal</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>70 Beg Gross</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>80 Beg Net</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>90 Beg T-Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>100 End Balance</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>110 Ending Gross Rate</td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>120 Ending Net Rate</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>130 Ending Transfer Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>140 Average Bal</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>150 Average Gross Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>160 Average Net Rate</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>170 Average Transfer Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>210 Total Runoff - positive</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>211 Timing of Total Runoff - positive</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>212 Total Runoff - negative</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>213 Timing of Total Runoff - negative</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>220 Total Runoff Gross Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>230 Total Runoff Net Rate</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>240 Total Runoff Transfer Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>340 New Add Balance</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>350 New Add Gross Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>360 New Add Net Rate</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>370 New Add Transfer Rate</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>440 Interest Accrued</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>445 Interest Accrued Gross</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>450 Charge/Credit</td>
<td></td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>
Element Type - Gap

<table>
<thead>
<tr>
<th>Element Number</th>
<th>Element Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>660</td>
<td>Gap Runoff</td>
</tr>
<tr>
<td>661</td>
<td>Gap Principal Runoff</td>
</tr>
<tr>
<td>662</td>
<td>Gap Repricing Runoff</td>
</tr>
<tr>
<td>663</td>
<td>Deferred Runoff</td>
</tr>
<tr>
<td>670</td>
<td>Gap Runoff Term</td>
</tr>
<tr>
<td>671</td>
<td>Gap Interest Cash Flow Gross</td>
</tr>
<tr>
<td>672</td>
<td>Gap Interest Cash Flow Net</td>
</tr>
<tr>
<td>673</td>
<td>Gap Interest Cash Flow Transfer</td>
</tr>
<tr>
<td>674</td>
<td>Gap Accrued Interest Gross</td>
</tr>
<tr>
<td>675</td>
<td>Gap Accrued Interest Net</td>
</tr>
<tr>
<td>676</td>
<td>Gap Accrued Interest Transfer</td>
</tr>
<tr>
<td>677</td>
<td>Gap Interest Credited</td>
</tr>
<tr>
<td>680</td>
<td>Gap Runoff Gross Rate</td>
</tr>
<tr>
<td>690</td>
<td>Gap Runoff Net Rate</td>
</tr>
<tr>
<td>700</td>
<td>Gap Runoff Transfer Rate</td>
</tr>
</tbody>
</table>
## Element Type - Market Value

<table>
<thead>
<tr>
<th>Element Number</th>
<th>Element Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>2001</td>
<td>Static Gross Par Balance</td>
</tr>
<tr>
<td>2002</td>
<td>Static Net par Balance</td>
</tr>
<tr>
<td>2003</td>
<td>Static Deferred Balance</td>
</tr>
<tr>
<td>2004</td>
<td>Static Accrued Interest Balance</td>
</tr>
<tr>
<td>2005</td>
<td>Static Net Rate</td>
</tr>
<tr>
<td>2006</td>
<td>Static Transfer Rate</td>
</tr>
<tr>
<td>2007</td>
<td>Static Remaining Term</td>
</tr>
<tr>
<td>2008</td>
<td>Static Market Value</td>
</tr>
</tbody>
</table>
Financial Element Output by Account Type

Account Types are assigned through the Leaf Set-Up interface for each Common COA ID. Product leaves other than Common COA ID are assigned the same account type as their associated Common COA ID. During Risk Manager processing, the financial elements generated are dependent on the account type associated with each instrument record’s product leaf value. The following table defines which financial elements are produced for instruments of a specific account type classification.

<table>
<thead>
<tr>
<th>Fin. Elmt. #</th>
<th>Description</th>
<th>Autobal Accts</th>
<th>Earning Asset/Interest-bearing Liability</th>
<th>Interest Income/Interest Expense</th>
<th>OBS Recv./Pay.</th>
<th>Equity</th>
<th>Other Assets/Other Liabs</th>
<th>Non-Interest Income</th>
<th>Non-Interest Expense</th>
<th>Taxes</th>
<th>Dividends</th>
</tr>
</thead>
<tbody>
<tr>
<td>60</td>
<td>Beginning Balance</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>70</td>
<td>Beginning Gross Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>80</td>
<td>Beginning Net Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>90</td>
<td>Beginning Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>100</td>
<td>Ending Balance</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>110</td>
<td>Ending Gross Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>120</td>
<td>Ending Net Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>130</td>
<td>Ending Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>140</td>
<td>Average Balance</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>150</td>
<td>Average Gross Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>160</td>
<td>Average Net Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>170</td>
<td>Average Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>180</td>
<td>Prepay Runoff</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>181</td>
<td>Timing of Prepay Runoff</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
</tbody>
</table>

Financial Element Output by Account Type
<table>
<thead>
<tr>
<th>Fin. Elmt. #</th>
<th>Description</th>
<th>Earning Asset/ Interest Income/ Interest Expense</th>
<th>OBS Recv./ Pay.</th>
<th>Other Assets/ Other Liabs</th>
<th>Non-Interest Income</th>
<th>Non-Interest Expense</th>
<th>Taxes</th>
<th>Dividends</th>
</tr>
</thead>
<tbody>
<tr>
<td>182</td>
<td>Prepay Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>183</td>
<td>Timing of Prepay Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>190</td>
<td>Schedule Principal Runoff</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>192</td>
<td>Pmnt Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>193</td>
<td>Timing of Pmnt Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>195</td>
<td>Maturity Runoff - positive</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>196</td>
<td>Timing of Mat. Runoff - positive</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>197</td>
<td>Maturity Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>198</td>
<td>Timing of Mat. Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>210</td>
<td>Total Runoff - positive</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>211</td>
<td>Timing of Total Runoff - positive</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>212</td>
<td>Total Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>213</td>
<td>Timing of Total Runoff - negative</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>220</td>
<td>Total Runoff Gross Rate</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>230</td>
<td>Total Runoff Net Rate</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>240</td>
<td>Total Runoff Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>250</td>
<td>Reprice Balance Beginning</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>255</td>
<td>Reprice Balance Ending</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Financial Element Output by Account Type

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
<th>Fin. Elmt. #</th>
<th>Autobal Accts</th>
<th>Interest Income/Expense</th>
<th>OBS Recv./Pay.</th>
<th>Equity</th>
<th>Non-Interest Income</th>
<th>Non-Interest Expense</th>
<th>Taxes</th>
<th>Dividends</th>
</tr>
</thead>
<tbody>
<tr>
<td>260</td>
<td>Before Reprice Gross Rate</td>
<td>260</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>270</td>
<td>After Reprice Gross Rate</td>
<td>270</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>280</td>
<td>Before Reprice Net Rate</td>
<td>280</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>290</td>
<td>After Reprice Net Rate</td>
<td>290</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>300</td>
<td>Before Reprice Transfer Rate</td>
<td>300</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>310</td>
<td>After Reprice Transfer Rate</td>
<td>310</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>320</td>
<td>Fully Indexed Gross Rate</td>
<td>320</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>330</td>
<td>Fully Indexed Net Rate</td>
<td>330</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>340</td>
<td>New Add Balance</td>
<td>340</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>350</td>
<td>New Add Gross Rate</td>
<td>350</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>360</td>
<td>New Add Net Rate</td>
<td>360</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>370</td>
<td>New Add Transfer Rate</td>
<td>370</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>380</td>
<td>Roll Add Balance</td>
<td>380</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>390</td>
<td>Roll Add Gross Rate</td>
<td>390</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>400</td>
<td>Roll Add Net Rate</td>
<td>400</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>410</td>
<td>Roll Add Transfer Rate</td>
<td>410</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>430</td>
<td>Interest Cash Flow Net</td>
<td>430</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>435</td>
<td>Interest Cash Flow Gross</td>
<td>435</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

B-12  **Oracle Financial Data Manager Balance & Control Reference Guide**
<table>
<thead>
<tr>
<th>Fin. Elmt. #</th>
<th>Description</th>
<th>Earning Asset/Interest-Bearing Liability</th>
<th>Interest Income/Interest Expense</th>
<th>OBS Recv./Pay. Equity</th>
<th>Other Assets/Other Liabs</th>
<th>Non-Interest Income</th>
<th>Non-Interest Expense</th>
<th>Taxes</th>
<th>Dividends</th>
</tr>
</thead>
<tbody>
<tr>
<td>437</td>
<td>Interest Cash Flow Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>440</td>
<td>Int Accrd - Net</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>445</td>
<td>Int Accrd - Gross</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>450</td>
<td>Int Accrd - Tran Rt</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>455</td>
<td>Non-Interest Income</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>457</td>
<td>Non-Interest Expense</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>480</td>
<td>Interest Credited</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>500</td>
<td>Weighted Average Remaining Term</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>510</td>
<td>Annual Prepayment Rate</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>515</td>
<td>Prepay Balance</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>520</td>
<td>Deferred Ending Balance</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>530</td>
<td>Deferred Average Balance</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>540</td>
<td>Deferred Runoff</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>550</td>
<td>Periodic Cap Balance</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>560</td>
<td>Periodic Cap Effect - Rate</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>570</td>
<td>Periodic Cap Effect - Amount</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>580</td>
<td>Lifetime Cap Balance</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>590</td>
<td>Lifetime Cap Effect - Rate</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
</tr>
</tbody>
</table>
### Financial Element Output by Account Type

<table>
<thead>
<tr>
<th>Fin. Elmt. #</th>
<th>Description</th>
<th>Autobal Accts</th>
<th>Earning Asset/ Interest-bearing Liability</th>
<th>Interest Income/ Interest Expense</th>
<th>OBS Recv./ Pay.</th>
<th>Equity</th>
<th>Other Assets/ Other Liabs</th>
<th>Non-Interest Income</th>
<th>Non-Interest Expense</th>
<th>Taxes</th>
<th>Dividends</th>
</tr>
</thead>
<tbody>
<tr>
<td>600</td>
<td>Lifetime Cap Effect - Amount</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>610</td>
<td>Tease Balance</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>620</td>
<td>Tease Effect - Rate</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>630</td>
<td>Tease effect - Amount</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>640</td>
<td>NGAM Balance</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>650</td>
<td>NGAM Interest</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>660</td>
<td>Gap Total Off</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>661</td>
<td>Gap Principal Off</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>662</td>
<td>Gap Repricing</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>663</td>
<td>Gap Deferred Off</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>670</td>
<td>Gap Runoff</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>671</td>
<td>Gap Interest Cash Flow Gross</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>672</td>
<td>Gap Interest Cash Flow Net</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>673</td>
<td>Gap Interest Cash Flow Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>674</td>
<td>Gap Accrued Interest Gross</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>675</td>
<td>Gap Accrued Interest Net</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>676</td>
<td>Gap Accrued Interest Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>677</td>
<td>Gap Interest Credited</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>680</td>
<td>Gap Runoff Gross Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Financial Element Output by Account Type

<table>
<thead>
<tr>
<th>Fin. Elmt. #</th>
<th>Description</th>
<th>Autobal Accts</th>
<th>Interest-bearing Liability</th>
<th>Interest Income/Expense</th>
<th>OBS Recv./Pay.</th>
<th>Equity</th>
<th>Other Assets/Other Liabs</th>
<th>Non-Interest Income</th>
<th>Non-Interest Expense</th>
<th>Taxes</th>
<th>Dividends</th>
</tr>
</thead>
<tbody>
<tr>
<td>690</td>
<td>Gap Runoff Net Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>700</td>
<td>Gap Runoff Transfer Rate</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>930</td>
<td>Taxes</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
<td></td>
</tr>
<tr>
<td>935</td>
<td>Taxes</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
<td></td>
</tr>
<tr>
<td>940</td>
<td>Dividends</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Y</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Financial Element Calculations

<table>
<thead>
<tr>
<th>Financial Element Description</th>
<th>Financial Element Number</th>
<th>Averaging Type</th>
<th>Weighting Factor</th>
<th>Account Type Processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>After Reprice Balance</td>
<td>255</td>
<td>At Last</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>After Reprice Gross Rate</td>
<td>290</td>
<td>At Last</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>After Reprice Net Rate</td>
<td>300</td>
<td>At Last</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>After Reprice Transfer Rate</td>
<td>310</td>
<td>At Last</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Average Balance</td>
<td>140</td>
<td>Daily average</td>
<td></td>
<td>B, DCF</td>
</tr>
<tr>
<td>Average Gross Rate</td>
<td>150</td>
<td>Daily average</td>
<td>Average Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Average Net Rate</td>
<td>160</td>
<td>Daily average</td>
<td>Average Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Average Transfer Rate</td>
<td>170</td>
<td>Daily average</td>
<td>Average Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Before Reprice Balance</td>
<td>250</td>
<td>At First</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Before Reprice Gross Rate</td>
<td>260</td>
<td>At First</td>
<td>Before Reprice Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Before Reprice Net Rate</td>
<td>270</td>
<td>At First</td>
<td>Before Reprice Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Before Reprice Transfer Rate</td>
<td>280</td>
<td>At First</td>
<td>Before Reprice Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Beginning Balance</td>
<td>60</td>
<td>At first</td>
<td></td>
<td>B, DCF</td>
</tr>
<tr>
<td>Beginning Gross Rate</td>
<td>70</td>
<td>At first</td>
<td>Beginning Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Beginning Net Rate</td>
<td>80</td>
<td>At first</td>
<td>Beginning Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Beginning Transfer Rate</td>
<td>90</td>
<td>At first</td>
<td>Beginning Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Deferred Average Balance</td>
<td>530</td>
<td>Daily average</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Deferred Ending Balance</td>
<td>520</td>
<td>At last</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Deferred Runoff</td>
<td>540</td>
<td>Accrual</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Dividends</td>
<td>940</td>
<td>Sum</td>
<td></td>
<td>A</td>
</tr>
<tr>
<td>Ending Balance</td>
<td>100</td>
<td>At last</td>
<td></td>
<td>B, DCF</td>
</tr>
<tr>
<td>Ending Gross Rate</td>
<td>110</td>
<td>At last</td>
<td>Ending Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Ending Net Rate</td>
<td>120</td>
<td>At last</td>
<td>Ending Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Ending Transfer Rate</td>
<td>130</td>
<td>At last</td>
<td>Ending Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Fully Indexed Gross Rate</td>
<td>320</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Financial Element Description</td>
<td>Financial Element Number</td>
<td>Averaging Type</td>
<td>Weighting Factor</td>
<td>Account Type Processing *</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------</td>
<td>----------------</td>
<td>-----------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Fully Indexed Net Rate</td>
<td>330</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Interest Accrual - Gross</td>
<td>445</td>
<td>Accrual</td>
<td></td>
<td>DCF, I</td>
</tr>
<tr>
<td>Interest Accrual - Net</td>
<td>440</td>
<td>Accrual</td>
<td></td>
<td>DCF, I</td>
</tr>
<tr>
<td>Interest Accrual - Transfer Rate</td>
<td>450</td>
<td>Accrual</td>
<td></td>
<td>DCF, I</td>
</tr>
<tr>
<td>Interest Cash Flow Gross</td>
<td>435</td>
<td>Sum</td>
<td></td>
<td>DCF, I</td>
</tr>
<tr>
<td>Interest Cash Flow Net</td>
<td>430</td>
<td>Sum</td>
<td></td>
<td>DCF, I</td>
</tr>
<tr>
<td>Interest Cash Flow Transfer Rate</td>
<td>437</td>
<td>Sum</td>
<td></td>
<td>DCF, I</td>
</tr>
<tr>
<td>Interest Credited</td>
<td>480</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Lifetime Cap Balance</td>
<td>580</td>
<td>Daily Average</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Lifetime Cap Effect</td>
<td>600</td>
<td>Accrual</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Lifetime Cap Rate</td>
<td>590</td>
<td>Daily Average</td>
<td>Lifetime Cap Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>New Add Balance</td>
<td>340</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>New Add Gross Rate</td>
<td>350</td>
<td>Sum</td>
<td>New Add Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>New Add Net Rate</td>
<td>360</td>
<td>Sum</td>
<td>New Add Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>New Add Transfer Rate</td>
<td>370</td>
<td>Sum</td>
<td>New Add Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>NGAM Balance</td>
<td>640</td>
<td>Daily Average</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>NGAM Interest</td>
<td>650</td>
<td>Accrual</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Non-Interest Income</td>
<td>455</td>
<td>Sum</td>
<td></td>
<td>N</td>
</tr>
<tr>
<td>Non-Interest Expense</td>
<td>457</td>
<td>Sum</td>
<td></td>
<td>N</td>
</tr>
<tr>
<td>Periodic Cap Balance</td>
<td>550</td>
<td>Daily Average</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Periodic Cap Effect</td>
<td>570</td>
<td>Accrual</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Periodic Cap Rate</td>
<td>560</td>
<td>Daily Average</td>
<td>Periodic Cap Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Prepay Balance</td>
<td>515</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Prepay Rate (Annual)</td>
<td>510</td>
<td>Sum</td>
<td>Prepay Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Prepay Runoff</td>
<td>180</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
</tbody>
</table>
## Financial Element Calculations

<table>
<thead>
<tr>
<th>Financial Element Description</th>
<th>Financial Element Number</th>
<th>Averaging Type</th>
<th>Weighting Factor</th>
<th>Account Type Processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prepay Runoff</td>
<td>182</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Roll Add Balance</td>
<td>380</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Roll Add Gross Rate</td>
<td>390</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Roll Add Net Rate</td>
<td>400</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Roll Add Transfer Rate</td>
<td>410</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Scheduled Principal Runoff</td>
<td>190</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Taxes - Federal</td>
<td>930</td>
<td>Sum</td>
<td></td>
<td>A</td>
</tr>
<tr>
<td>Taxes - Local</td>
<td>935</td>
<td>Sum</td>
<td></td>
<td>A</td>
</tr>
<tr>
<td>Tease Balance</td>
<td>610</td>
<td>Daily Average</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Tease Effect</td>
<td>630</td>
<td>Accrual</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Tease Rate</td>
<td>620</td>
<td>Daily Average</td>
<td>Tease Balance</td>
<td>DCF</td>
</tr>
<tr>
<td>Timing of Prepay Runoff (positive)</td>
<td>181</td>
<td>Sum</td>
<td>Prepay Runoff (positive)</td>
<td>DCF</td>
</tr>
<tr>
<td>Prepay Runoff (negative)</td>
<td>182</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Timing of Prepay Runoff (negative)</td>
<td>183</td>
<td>Sum</td>
<td>Prepay Runoff (negative)</td>
<td>DCF</td>
</tr>
<tr>
<td>Timing of Total Runoff (positive)</td>
<td>211</td>
<td>Sum</td>
<td>Total Runoff (positive)</td>
<td>DCF</td>
</tr>
<tr>
<td>Total Runoff (negative)</td>
<td>212</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Timing of Total Runoff (negative)</td>
<td>213</td>
<td>Sum</td>
<td>Total Runoff (negative)</td>
<td>DCF</td>
</tr>
<tr>
<td>Total Runoff</td>
<td>210</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Total Runoff (negative)</td>
<td>212</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Total Runoff Gross Rate</td>
<td>220</td>
<td>Sum</td>
<td>Total Runoff</td>
<td>DCF</td>
</tr>
<tr>
<td>Total Runoff Net Rate</td>
<td>230</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Total Runoff Transfer Rate</td>
<td>240</td>
<td>Sum</td>
<td></td>
<td>DCF</td>
</tr>
<tr>
<td>Weighted Average Term</td>
<td>500</td>
<td>Sum</td>
<td>Ending Balance</td>
<td>DCF</td>
</tr>
</tbody>
</table>

* This specifies for which account types the financial elements will be processed. The code values are B = Balance only; I = Interest only; DCF = Detail Cash Flow; A = Autobalancing; N = Non Interest
Oracle Financial Services (OFS) applications support either a calendar or fiscal year configuration. If your organization has implemented a fiscal year configuration this appendix provides technical information on how a fiscal year configuration affects the LEDGER_STAT table and as-of-date and year-to-date calculations.

Note that, in the context of this appendix, fiscal year denotes a non-calendar financial year.

This appendix presents the following topics:

- **FISCAL_YEAR_INFO Configuration for a Fiscal Year**
- Year-To-Date Calculations Affected by a Fiscal Year Configuration
- Viewing the Start_Month and Fiscal_Period Values in the FISCAL_YEAR_INFO Table
- Examples of Calendar and Fiscal Year Configurations
- Using the Undo Function with a Fiscal Year Configuration

**FISCAL_YEAR_INFO Configuration for a Fiscal Year**

In the FISCAL_YEAR_INFO table, the values in the Start_Month and Fiscal_Period columns set the beginning month and duration of your financial year, respectively, for the LEDGER_STAT table. The values in these two columns convert the Month_XX and YTD_XX columns in the LEDGER_STAT table from a calendar year to a fiscal year configuration.
FISCAL_YEAR_INFO Configuration for a Fiscal Year

Start_Month Column
This column holds the value that represents the first month of your financial year. For a calendar year, the value in this column is always 1, which equates to January. A fiscal period generally has a value between 2 and 12. For example, this column would have a value of 3 if your fiscal year began in March and a value of 7 if your fiscal year began in July.

For OFS applications, the default setting is a calendar year and the value in this column is 1.

Note that a value of less than 1 or greater than 12 in this column generates an error message.

Fiscal_Period Column
This column holds the value that represents the duration of the financial period. For a calendar year, this value is always 12 (for 12 months) and, for a fiscal year, this value is typically 12.

The fiscal year configuration also gives you the flexibility to set shorter financial periods within a 12-month period. For example, if your organization has two 6-month fiscal periods over a 12-month span, then the value in this column would be 6. The only restriction on using a period shorter than a year is that the period must be a factor of 12 (1, 2, 3, 4, or 6).

If you set your start month at 1 and the fiscal period at 6, the system automatically treats this setting as a fiscal year configuration.

For OFS applications, the default setting is a calendar year and the value in this column is 12.

Note that a value of less than 1 or greater than 12 in this column generates an error message.
Year-To-Date Calculations Affected by a Fiscal Year Configuration

Year-to-date calculations begin at the start date of the fiscal period rather than January of the year in which the calculations are performed. For example, if July is the start date for your organization’s fiscal period and you process year-to-date calculations through September, the system returns data from the three months from July through September and not from January through September.

This is an important consideration for the following calculations:

- Updating the LEDGER_STAT table when either processing or undoing an Allocation ID
- Performing calculations when ledger data is loaded through the Oracle Financial Data Manager (FDM) (see the Import Ledger subsection in the Overview of IDs chapter in this guide for load options with a fiscal year configuration)
- Performing calculations when transfer rates are migrated from instrument tables to the LEDGER_STAT table through Oracle Transfer Pricing

Viewing the Start_Month and Fiscal_Period Values in the FISCAL_YEAR_INFO Table

To view the Start_Month and Fiscal_Period values, open a SQL Talk window and complete the following steps:

1. From the menu bar, select Process -> SQL Talk to display the SQL Talk window.
2. Type the following script in the top pane of the window:
   ```sql
   Select * from fiscal_year_info;
   ```
3. Press Ctrl-Enter to run the script. The FISCAL_YEAR_INFO table appears in the bottom pane of the window.

   If your organization is using a calendar year configuration the Start_Month column displays a value of 1 and the Fiscal_Period column displays a value of 12. For a fiscal period the values in one or both columns will be different from the calendar year configuration.
Examples of Calendar and Fiscal Year Configurations

The following examples show different configurations in the FISCAL_YEAR_INFO table and how these configurations affect the LEDGER_STAT table.

Note: Oracle Portfolio Analyzer does not have SQL Talk. If you are using this product, ask your DBA or System Administrator to access the table for you.
Using a Calendar Year Configuration

In this example, the FISCAL_YEAR_INFO table holds the following values:

<table>
<thead>
<tr>
<th>Column</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start_Month</td>
<td>1</td>
</tr>
<tr>
<td>Fiscal_Period</td>
<td>12</td>
</tr>
</tbody>
</table>

This is the default setting for OFS applications.

In the LEDGER_STAT table, the calendar months correspond to the monthly buckets, as shown in the following table:

<table>
<thead>
<tr>
<th>year_s</th>
<th>month_01</th>
<th>month_02</th>
<th>month_03</th>
<th>month_04</th>
<th>month_05</th>
<th>month_06</th>
<th>month_07</th>
<th>month_08</th>
<th>month_09</th>
<th>month_10</th>
<th>month_11</th>
<th>month_12</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>JAN</td>
<td>FEB</td>
<td>MAR</td>
<td>APR</td>
<td>MAY</td>
<td>JUN</td>
<td>JUL</td>
<td>AUG</td>
<td>SEPT</td>
<td>OCT</td>
<td>NOV</td>
<td>DEC</td>
</tr>
</tbody>
</table>

If you want to process a current month Balance Sheet report and you set the as-of-date in your Configuration ID to June 30, 1999, the data for the report comes from the Month_06 bucket.

Similarly, if you want to process an Allocation ID, undo an Allocation ID, or migrate transfer rates to the LEDGER_STAT table, the system updates year-to-date buckets that are affected by the Allocation ID and the Month_06 bucket.

The YTD_XX buckets in the LEDGER_STAT table correspond to the calendar months in the same way as the monthly buckets. For example, YTD_01 contains year-to-date values for January and YTD_06 contains year-to-date values from January through June.
Examples of Calendar and Fiscal Year Configurations

Using a Fiscal Year Configuration with a 12-Month Duration

In this example, the FISCAL_YEAR_INFO table holds the following values:

<table>
<thead>
<tr>
<th>Column</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start_Month</td>
<td>7</td>
</tr>
<tr>
<td>Fiscal_Period</td>
<td>12</td>
</tr>
</tbody>
</table>

In the LEDGER_STAT table, the calendar months correspond to the monthly buckets, as shown in the following table:

<table>
<thead>
<tr>
<th>year_s</th>
<th>month_01</th>
<th>month_02</th>
<th>month_03</th>
<th>month_04</th>
<th>month_05</th>
<th>month_06</th>
<th>month_07</th>
<th>month_08</th>
<th>month_09</th>
<th>month_10</th>
<th>month_11</th>
<th>month_12</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>JUL</td>
<td>AUG</td>
<td>SEP</td>
<td>OCT</td>
<td>NOV</td>
<td>DEC</td>
<td>JAN</td>
<td>FEB</td>
<td>MAR</td>
<td>APR</td>
<td>MAY</td>
<td>JUN</td>
</tr>
</tbody>
</table>

In this example, the first month of the fiscal period is July, 1999, and January through June are in the year 2000. The OFS system determines the year of the fiscal period record by the year in which the first month occurs. Therefore, the system treats the months January through June as part of the 1999 record.

If you want to process a current month Balance Sheet report and you set the as-of-date in your Configuration ID to January 31, 2000, the data for the report comes from the Month_07 bucket.

Similarly, if you want to process an Allocation ID, undo an Allocation ID, or migrate transfer rates to the LEDGER_STAT table the system updates the year-to-date buckets that are affected by the Allocation ID and the Month_07 bucket.

Using a Fiscal Year Configuration with a 6-Month Duration

In this example, the FISCAL_YEAR_INFO table holds the following values:

<table>
<thead>
<tr>
<th>Column</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start_Month</td>
<td>4</td>
</tr>
<tr>
<td>Fiscal_Period</td>
<td>6</td>
</tr>
</tbody>
</table>
In the LEDGER_STAT table, the calendar months correspond to the monthly buckets, as shown in the following table:

<table>
<thead>
<tr>
<th>year_s</th>
<th>month_01</th>
<th>month_02</th>
<th>month_03</th>
<th>month_04</th>
<th>month_05</th>
<th>month_06</th>
<th>month_07</th>
<th>month_08</th>
<th>month_09</th>
<th>month_10</th>
<th>month_11</th>
<th>month_12</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>APR</td>
<td>MAY</td>
<td>JUN</td>
<td>JUL</td>
<td>AUG</td>
<td>SEP</td>
<td>OCT</td>
<td>NOV</td>
<td>DEC</td>
<td>JAN</td>
<td>FEB</td>
<td>MAR</td>
</tr>
</tbody>
</table>

In this example, the first month of the fiscal period is April, 1999, and January through March are in the year 2000. The OFS system determines the year of the fiscal period record by the year in which the first month occurs. Therefore, the months January through March are treated as part of the 1999 record.

If you want to process a current month Balance Sheet report and you set the as-of-date in your Configuration ID to January 31, 2000, the data for the report comes from the Month_10 bucket.

**Year-to-Date Calculations with a 6-Month Duration**

When performing year-to-date calculations and the fiscal period value is 6, the OFS system segments the financial year into two 6-month periods. Therefore, if you select August, 1999, for year-to-date calculations your data comes from the months of April, 1999, through August, 1999 (five months). If you select December for year-to-date calculations then your data comes from October, 1999 through December, 1999 (three months).

**Using the Undo Function with a Fiscal Year Configuration**

The undo function backs out records one period at a time. This is important if you have chosen a fiscal period duration that is less than 12. For a calendar year or 12-month fiscal year you can set the as-of-date anywhere within the 12-month span and undo the allocation for the entire fiscal period.

If your organization uses a fiscal period shorter than 12-months, however, then you need to set the as-of-date within the period for which you want to undo an allocation. For example, if you have set your Fiscal_Period to 6 and you want to undo an allocation that you posted in the first six-month period then you must set the Configuration ID as-of-date to a date within that period.
Transformation ID Error Messages

To determine why a Process ID has failed, consult the Process_Errors table. Transformation ID error information is obtained once you have identified the Process_Sys_ID number. To determine the Process_Sys_ID number, complete the following steps:

1. Select the Transformation ID icon. The Select Transformation ID dialog appears.
2. From the Transformation ID drop-down menu, select the Transformation ID you are working on. **Do not select OK.**
3. Right mouse click inside the Select Transformation ID dialog. The Transformation ID Information dialog appears. Make a note of the Sys_id_num (for example, 105877).
4. Select the SQL icon and execute the following SQL statement:
   ```sql
   Select * From Process_Errors
   Where Process_Sys_ID = xxxxxx;
   ```
Press Ctrl+Enter to execute the statement, then look at the results. Each error row includes an error number, as well as other context information that can help you diagnose your process error. See the remainder of this appendix for further error code descriptions.

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Error Message</th>
<th>Error Condition</th>
<th>Effect on Processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>20702</td>
<td>Error: Failed to properly receive params.</td>
<td>The parameters passed to the engine are invalid. This is either an internal error or bad command-line usage.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20704</td>
<td>Process ID or Configuration ID failed to convert ID where &lt;xxxx&gt;, &lt;yyyy&gt;.</td>
<td>Process ID or Configure ID is not recognized by Oracle Financial Services Applications (OFSA) (xxxx = Process ID System ID number, and yyyy = Configuration ID System number).</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20713</td>
<td>Unable to Process.</td>
<td>The transformation engine was unable to perform the requested processing due to an error that is either listed in the Process Errors table or is unknown.</td>
<td>This message appears anytime processing stops for any error, known or unknown.</td>
</tr>
<tr>
<td>20714</td>
<td>LoadStart Failed During Read.</td>
<td>Internal Application Logic Error. OR Database Access Layer failure.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20715</td>
<td>IoBase: Memory Allocation Failure.</td>
<td>Internal Application Logic Error.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20716</td>
<td>IoMulti: Memory Allocation Failure.</td>
<td>Internal Application Logic Error.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20717</td>
<td>Bad key allocation.</td>
<td>Internal Application Logic Error.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20718</td>
<td>BPTransform: More than one entry detected in Catalog of IDs.</td>
<td>The database is not correctly configured to run the Oracle Budgeting and Planning application. There are two entries in CATALOG_OF_IDS table where ID_TYPE=505.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20719</td>
<td>BPTransform: No Config ID exists!</td>
<td>The database is not correctly configured to run the Budgeting and Planning application. There is no entry in CATALOG_OF_IDS table where ID_TYPE=505.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Message</td>
<td>Error Condition</td>
<td>Effect on Processing</td>
</tr>
<tr>
<td>------------</td>
<td>---------------</td>
<td>-----------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>20720</td>
<td>BPTransform: No valid product leaf exists!</td>
<td>The database is not correctly configured to run the Budgeting and Planning application. Product Leaf in the BP_FINANCIAL_DATA table is not defined in CATALOG_OF_LEAVES table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20721</td>
<td>BPTransform: No valid organization leaf exists!</td>
<td>Organization Leaf(ORG_UNIT_ID) is not defined in CATALOG_OF_LEAVES table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20723</td>
<td>BPTransform: Result table has changed during Transform engine run (FE).</td>
<td>New Financial Elem ID has been added to the pivoted data, while the Transformation ID, which has Budgeting and Planning Data as source type, is running.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20724</td>
<td>BPTransform: Non Unique record found!</td>
<td>Pivot group has Non Unique Records. Non Unique Records are written to the Process Errors table if the FindNonUnique is set to 1 in Ofste.ini. Processing continues and ignores the non Unique record if SkipNonUnique is set to 1 in Ofste.ini.</td>
<td>Processing stops if SkipNonUnique is set to 0 in Ofste.ini. Processing continues and ignores the non Unique record if SkipNonUnique is set to 1 in Ofste.ini.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Message</td>
<td>Error Condition</td>
<td>Effect on Processing</td>
</tr>
<tr>
<td>------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>20728</td>
<td>LedgerTransform: Input date is not valid.</td>
<td>The Transformation ID has Ledger Stat as the source type, Processing Option is Selective and either Start date or End date &lt; 01 JAN, 1950. OR The Transformation ID has Ledger Stat as the source type, Processing Options is Selective and the Start Date is greater than the End Date. OR The Transformation ID has Ledger Stat as the source type, the Processing Options is Current Month and the activated Configuration ID has an As Of Date &lt; 01 JAN, 1950.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20729</td>
<td>BPTransform:FE from source not in DETAIL_ELEM.</td>
<td>Transformation ID has Budgeting and Planning Data as the source type and at least one Financial Element ID has not been defined in the DETAIL_ELEM table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20733</td>
<td>BPTransfer: Balance not found, possible corrupted data!</td>
<td>Records exist in the BP_FINANCIAL_DATA table for rates where no records for the corresponding balances exist. The values of the key fields of the violating records appear with this message in the Process Errors table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20734</td>
<td>LedgerTransform: Fatal Error. FE Not in DETAIL_ELEM.</td>
<td>Transformation ID has Ledger Stat as the source type and the pivoted group has at least one Financial Element ID that is not being defined in the DETAIL_ELEM table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Message</td>
<td>Error Condition</td>
<td>Effect on Processing</td>
</tr>
<tr>
<td>------------</td>
<td>---------------</td>
<td>-----------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>20735</td>
<td>LedgerTransform: Fatal Error. FE No column name defined in DETAIL_ELEM.</td>
<td>The Transformation ID has Ledger Stat as the source type, and at least one Financial Element ID that is defined in DETAIL_ELEM table does not have a corresponding COLUMN_NAME defined.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20736</td>
<td>LedgerTransform: Error- All dimensions are filtered out.</td>
<td>Transformation ID has Ledger Stat as the source type and all the Dimensions are being filtered out.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20737</td>
<td>Transformation ID does not exist in table.</td>
<td>A bad Sys_ID_Num is assigned to the Transformation ID.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20738</td>
<td>Configuration ID does not exist in table.</td>
<td>Bad Sys_ID_Num is assigned to the Configuration ID.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20739</td>
<td>Processing ID is bad.</td>
<td>There is an error in the format of the Processing ID.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20741</td>
<td>Transformation ID: Unsupported source table type.</td>
<td>Transformation ID has an Undefined SOURCE_TBL_TYPE_CD saved in IDT_TRANSFORM table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20742</td>
<td>Ledger Transform Error: Transformation would cause table overwrite.</td>
<td>Transformation ID has Ledger Stat as the source type, Processing Options is Entire Table, Drop Existing Table is unchecked, and the Transform Into table had already existed in the database.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20743</td>
<td>Filter is filtering out a financial element that already exists in the table.</td>
<td>The Transformation ID has Ledger Stat as the source type, and the Data Filter has filtered out at least one of its Financial_elem_ID which already exists in the Transform Into table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20746</td>
<td>A column for financial element is being added to the table where historic data is plugged with a zero, which causes inconsistent data.</td>
<td>A Ledger Stat Transformation ID is adding data to an existing output table. The added data causes a column to be added to the output table for a new financial element. However, the values for the new financial element column for records that already exist in the output table, are plugged with a zero. This is in error since valid values for this financial element for the existing records exist in the input table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Message</td>
<td>Error Condition</td>
<td>Effect on Processing</td>
</tr>
<tr>
<td>------------</td>
<td>---------------</td>
<td>-----------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>20749</td>
<td>BPTransform: No Records returned.</td>
<td>Either there are no records in the BP_FINANCIAL_DATA table, or the filter being used excludes all records.</td>
<td>No records processed.</td>
</tr>
<tr>
<td>20752</td>
<td>Transformation ID: Invalid processing type for BP.</td>
<td>Transformation ID has Budgeting and Planning Data as source type and the Processing Options is set to Current Month (PROCESS_SCOPE_CD=20 in IDT_TRANSFORM table). This Processing Option does not apply to this source type.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20753</td>
<td>BPTransform: Invalid date range for selective processing.</td>
<td>The Transformation ID has Budgeting and Planning as the source type and Start Date is greater than the First Bucket Date in the BP_FINANCIAL_DATA table. OR The Transformation ID has Budgeting and Planning as the source type and End Date is less than the Last Bucket Date in the BP_FINANCIAL_DATA table. OR Transformation ID has Budgeting and Planning as the source type and the Start Date is greater than the End Date.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20754</td>
<td>BPTransform Error: Transformation would cause table overwrite.</td>
<td>The Transformation ID has Budgeting and Planning as the source type, the Drop Existing Table Flag is unchecked and the Transform Into table already exists in the database.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20755</td>
<td>Fatal Error occurred loading Transformation ID.</td>
<td>Internal logic error.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20756</td>
<td>Fatal Error occurred loading dimension filter.</td>
<td>Failure in Database Layer.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20757</td>
<td>Ledger Transform: No Records returned.</td>
<td>Either there are no records in the LEDGER_STAT table, or the filter being used excludes all records.</td>
<td>No records are processed.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Message</td>
<td>Error Condition</td>
<td>Effect on Processing</td>
</tr>
<tr>
<td>------------</td>
<td>---------------</td>
<td>----------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>20762</td>
<td>BPTransform: Dimension Filter-bad leaf type.</td>
<td>The Transformation ID has Budgeting and Planning as the source type and the Dimension Filter excludes Leaf type which is neither the Product Leaf nor the Organization Leaf Type used by the pivoted data.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20764</td>
<td>RollupTransform: Transformation would cause table overwrite.</td>
<td>The Transformation ID has Tree Rollup as the source type, the Drop Existing Table Flag is unchecked and the Transform Into table already exists in the database.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20765</td>
<td>RollupTransform: Rollup Sys_ID not found in Level_Desc table.</td>
<td>For the Tree Rollup ID being transformed, no records exist in the Level_Description table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20766</td>
<td>RollupTransform: Too many levels found in Level_Desc table.</td>
<td>The value in the LEVEL_NUM COLUMN in the Level Description table exceeds the Maximum number of levels, which is 15.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20767</td>
<td>RollupTransform: Rollup Sys_ID not found in Catalog of IDs table.</td>
<td>The Tree Rollup ID (SYS_ID_NUM) cannot be found in the CATALOG_OF_IDS table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20768</td>
<td>RollupTransform: Leaf not found in Catalog of Leaves table.</td>
<td>The Leaf Type for the Tree Rollup being transformed does not exist in the Catalog_of_Leaves table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20769</td>
<td>RMTransform: Source table does not exist.</td>
<td>The Transformation ID has Risk Manager Result Detail as the source type and the table for the Process_ID does not exists in the database.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20770</td>
<td>RMTransform: Error-Unable to drop existing table(s).</td>
<td>Missing Privileges: The DBA should run Grants in the Oracle Financial Data Manager (FDM) Administration.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20771</td>
<td>RMTransform: Error: No data was found to transform.</td>
<td>The Transformation ID has Risk Manager Result Detail as the source type, the source table exists in the database but no data was found in the source table.</td>
<td>No records are processed.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Message</td>
<td>Error Condition</td>
<td>Effect on Processing</td>
</tr>
<tr>
<td>------------</td>
<td>------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>20772</td>
<td>RMTransform: Error: No information on product or organization leaf was found.</td>
<td>The Transformation ID has Risk Manager Result Detail as the source type and either Product Leaf or Organization Unit ID in the source table is not defined in the CATALOG_OF_LEAVES table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20773</td>
<td>RMTransform: Error: All dimensions are filtered out.</td>
<td>The Transformation ID has Risk Manager Result Detail as the source type and all the Dimensions are being filtered out.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20774</td>
<td>RMTransform: Inapplicable dimensions found in dimension filter.</td>
<td>The Transformation ID has Risk Manager Result Detail as the source type and the Dimension Filter excludes the Leaf type which is neither the Product Leaf nor the Organization Leaf Type that is being used by the input table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20775</td>
<td>RMTransform: Error: Required bucket information not found in RESULT_BUCKET table.</td>
<td>Transformation ID has Risk Manager Result Detail as the source type and at least one Scenario_Num in the source table cannot be found in the RESULT_BUCKET table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20776</td>
<td>RMTransform: RESULT_BUCKET has more start date indexes than result table.</td>
<td>The RESULT_BUCKET table expects more scenarios than are contained in the result detail table. Data may be missing from the result detail table.</td>
<td>Note: This is only a warning message.</td>
</tr>
<tr>
<td>20777</td>
<td>RMTransform: Error: FE in source table is not in DETAIL_ELEM.</td>
<td>The Transformation ID has Risk Manager Result as the source type, and has at least one Financial Element ID not defined in the DETAIL_ELEM table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20779</td>
<td>BPTransform: Weighting Financial Elem Missing From Pivot Group.</td>
<td>The Transformation ID has Budgeting and Planning as the source type and at least one of the needed weighting financial elements is missing from the Pivoted Group.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20780</td>
<td>LedgerTransform: Transformation data inconsistent with existing table.</td>
<td>Pivoting Data causes the existing Transform Into table data to become inconsistent.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Error Message</td>
<td>Error Condition</td>
<td>Effect on Processing</td>
</tr>
<tr>
<td>------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>20781</td>
<td>BPTransform: Column name missing from DETAIL_ELEM.</td>
<td>The Transformation ID has Budgeting and Planning as the source type and at least one Financial Element ID defined in the DETAIL_ELEM table does not have a valid column name.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20782</td>
<td>Transform: Duplicate Column Name found in DETAIL_ELEM.</td>
<td>Pivoted Data has at least two Financial Elem IDs having the same COLUMN_NAME defined in the DETAIL_ELEM table.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20783</td>
<td>LedgerTransform: Dimension filter contains a column which is used in Data Filter.</td>
<td>A leaf column is being excluded that is being used by the data filter.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20784</td>
<td>RMTransform: Error- Unable to create output table.</td>
<td>The Transformation ID was unable to create the Transform Into table or Index.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20785</td>
<td>BPTransform: Cannot Dimension Filter both product and organization.</td>
<td>The Transformation ID has Budgeting and Planning as the source type and all the Dimensions are being filtered out.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20790</td>
<td>Transform: Failed to create rollup table.</td>
<td>Run Grants in FDM Administration, or see your DBA.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20791</td>
<td>Transform: Failed to create table.</td>
<td>Run Grants in FDM Administration, or see your DBA.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20792</td>
<td>Transform: Failed to append columns to table.</td>
<td>Run Grants in FDM Administration, or see your DBA.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td>20793</td>
<td>Transform: Failed to reserve table.</td>
<td>Run Grants in FDM Administration, or see your DBA.</td>
<td>Processing stops.</td>
</tr>
<tr>
<td></td>
<td>OR</td>
<td>Transform Into table has already been reserved by other User.</td>
<td></td>
</tr>
</tbody>
</table>
As-of-Date
The date when the data is current.

Asset/Liability Management Committee
The Asset/Liability Management Committee (ALCO) is an organization within a financial institution whose charter is to manage interest rate risk.

At-Risk Period
The time period for value-at-risk. That is, the difference between the future date when portfolio loss is evaluated and the as-of-date.

Base Rates
A section in Oracle Risk Manager that stores the interest rates associated with the as-of-date of the data.

Basis Points
1/100th of a percent. Abbreviated as bp.

Breakage Charges
A charge assigned to an account whose actual cash flows are significantly different from the expected cash flows when the account funded.

Business Area
A conceptual grouping of tables or views represented as folders, items, conditions, filters, joins, and hierarchies. Each business area is grouped within the same End User Layer (EUL) that the current session is connected to.
**Cash Flow Table**
An instrument table that contains all of the Oracle Financial Services (OFS) cash flow columns.

**Cash Flow Column**
A column in an instrument table that is used by the OFS cash flow engine to perform cash flow analysis on a record.

**Configuration ID**
An ID that stores system default information that has been customized for the user and/or the institution.

**CPR (Constant Prepayment Rate)**
A method of measuring an annualized prepayment rate.

**Credit Risk**
The risk that a loan holder will not be able to repay some portion of a loan.

**Current Rate Risk Profit**
Component of funding center rate risk results attributed to current mismatches of assets and liabilities.

**Data Correction Processing ID**
An ID that enables you to simultaneously correct multiple columns in a database table in one pass through the database, using a previously defined Correction Rule ID.

**DDA (Demand Deposit Account)**
An account paying on demand, with no notice of withdrawal required, for example, a checking account.

**De-annualize**
To compute the monthly equivalent rate of an annual rate.

**Duration**
The rate of market value change with respect to discount rate changes. A measure of market value sensitivity: the lower the value, the less sensitive the market value to changes in interest rates.
**Embedded Rate Risk Profit**
A portion of funding center rate risk result attributed to prior rate bets.

**End User Layer (EUL)**
A metalayer that contains data about other tables in a database. Conceptually, the EUL shields the end user from the complexity of the database. The database tables are modified by the Oracle Discoverer Administration Edition and Oracle Financial Data Manager/Discoverer Integrator. Business areas are defined within the EUL and then used in the Oracle Discoverer End User Edition.

**Floating Tree Bar**
A window that enables you to choose the appropriate branch or leaf in the Tree ID that is currently active.

**Funding Center**
An area in a financial institution that receives the transfer pricing charge and credit for funds.

**General Ledger (GL)**
The main data source that defines the financial reality for an institution. The general ledger reflects all accounting entries.

**Historical Rates Table**
The OFS table that holds all historical actual interest rates.

**Instrument**
Legally enforceable agreements about types of financial security. See *Instrument Table*.

**Instrument Table**
A type of table in the Oracle Financial Data Manager (FDM) database that is used to store account-level information.

**Instrument Records**
Rows in the Oracle Financial Data Manager (FDM) database that contain account information for each customer. Examples are checking accounts, mortgage accounts, or installment debt accounts for a given customer.
**Interest Rate Code**
User-defined code to reference a yield curve or single rate index for historical analysis and transfer pricing and interest rate forecasting purposes.

**Last Repricing Date**
The date of the last rate change for an adjustable-rate instrument and the origination date for a fixed-rate instrument.

**Leaf Fields**
Oracle Financial Data Manager (FDM) database fields that are used to define hierarchical segmentations of data (trees). They also define the relationship between the instrument data and the general ledger data in the LEDGER_STAT table.

**Leaf ID**
A column in the Oracle Financial Data Manager (FDM) database that provides for the creation of hierarchical trees for use in assumptions and reporting. Leaf ID columns also define the relationship between instrument data and ledger data.

**Leaf Values**
Values that compose the leaf fields.

**LEDGER_STAT**
A table in the Oracle Financial Data Manager (FDM) database that stores all general ledger as well as statistical information for current and historical periods.

**Liquidity Premiums**
A charge levied on a long-term instrument to compensate for the illiquidity of the funds.

**Long Run Rate**
One of the user-defined parameters for the Vasicek (discrete-time) term structure model. It represents the equilibrium value of the one-month annually compounded rate.

**Market Price of Risk**
In financial economic theory, the market price of risk is a measure of intertemporal risk-aversion of the aggregate investor. For example, a high market price of risk during some future period means that investors will be more risk-averse, and that rates for that term should be higher to compensate for the risk. In practical terms, the market price of risk is the plug that makes the price of risk-free bonds correct.
**Market Value**
In Monte Carlo, the average of the (scenario specific) present values.

**Matched Rate Transfer Pricing**
A method of transfer pricing where all accounts have transfer rates that reflect their specific maturity and repricing characteristics.

**Matched Spread**
The interest profit margin for any account. For asset accounts, measured as the note rate minus the transfer rate and, for liability and equity accounts, the transfer rate minus the note rate.

**Monthly Rate**
The yield on a loan contracted at the beginning of the month for a period of one month, assuming a continuous compounding basis. The monthly rate is a function of time and scenario. The rate generator also computes rates for terms other than a month.

**Next Repricing Term**
The repricing frequency for an adjustable-rate instrument and the original term to maturity for a fixed-rate instrument.

**Operating Cost**
The non-interest related cost of running a business.

**Option Costs**
The costs assigned to measure the value of any customer option on an instrument. For example, prepayments on a mortgage loan.

**Portfolio Fields**
Fields in the Oracle Financial Data Manager (FDM) database that are common to multiple instrument tables. Portfolio fields are determined by the OFS system administrator.

**Prepayment**
A reduction in the principal balance of a transaction record prior to the contracted schedule date.
Present Value
In Monte Carlo, the sum of cash flows paid by a security along a particular rate scenario, discounted by the stochastic discount factor.

Processing Filter ID
Filter ID used to define which data can go into a processing run.

PSA (Public Securities Association)
A prepayment specification method established by the Public Securities Association that relates a CPR to the age of an instrument.

Reconciliation
The process of comparing information in one data source to information in another data source.

Record
Usually a single account or transaction, or aggregation of accounts, stored in the database (also called a row).

Remote User
A user who is not connected to the client/server environment. A remote user needs to transmit information to the budget administrator using computer files.

Single Rate
An interest rate code with only one point defined. For example, prime rate or LIBOR.

Speed of Mean Reversion
One of the user-defined parameters for the Vasicek and Extended Vasicek (discrete-time) term structure models. Speed of mean reversion represents the long-run drift factor.

Spreadsheet Control Bar
A dialog box that facilitates the definition of a series of input values (dates or numbers) by providing several methods for defining structured patterns in the data.

SQL (Structured Query Language)
The standard method of accessing the Oracle Financial Data Manager (FDM) database.
**Stochastic Discount Factor**
Present value (along a rate scenario) of one dollar received at some future time. It is a function of future time, option adjusted spread (OAS), and scenario.

**Transfer Pricing**
A method for valuing all sources and uses of funds for a balance sheet.

**Transfer Pricing ID**
An ID used to specify the method for transfer pricing all balance sheet accounts.

**Transfer Pricing Table**
An instrument table that contains all of the columns required to run transfer pricing.

**Tree ID**
Hierarchical structure for leaf fields in OFS products, for example, organization or product type.

**UPR (Unscheduled Principal Runoff)**
In addition to prepayments, a source of runoff in Risk Manager cash flow calculations. UPR is not applicable for Oracle Transfer Pricing.

**Volatility**
One of the user-defined term parameters of all (discrete-time) term structure models. It represents a standard deviation of the one-month annually compounded rate.

**Yield Curve**
The curve of annually compounded zero-coupon bond yield.
Index

A
Account Classification(s), 2-3
account classifications, 2-3
Accrual
   Method, 3-12
Accumulation Methods, 3-11
Add
   to by Percent, 3-31
   to by Value, 3-31
Aggregate
   Level, 2-6
   Portfolio, 2-4
Aggregating Data, 2-4
Aggregation, 2-4
Arrow(s)
   Directional, 5-3
As of Date, 7-7
Assignment, 5-5
   Column, 5-7
   Type, 5-6
Average
   Method, 3-12

B
Balancing the Data, 2-3
Batch
   Process, 12-2
Branch
   Collapse, 9-7, 10-9
   Expand, 9-7, 10-8
   Focus on, 9-8, 10-9
   Indented, 5-3
Orphan, 9-10
Build Date, 11-7
Bulk Update(s), 5-7
Bullets, xix

C
Calendar, 11-7
Cash Flow
   Columns, 2-2
   CE CodeExInd, xviii
Clear, 11-12
Client, 3-26
Client/Server
   Architecture, 2-7
   Technology, 2-7
Close an ID, 3-4
Code(s)
   Description, 4-4
   Invalid, 4-4
   Value, 4-4, 7-5
Collapse Branch, 9-7, 10-9
Column(s)
   Cash Flow, 2-2
   From/To, 3-31
   Output, 11-11, 11-12
   Report, 11-1
Configuration
   ID, 3-3, 5-7
Constant, 11-11
Control Bar, 1-8
Copy an ID, 3-5
Correction Rule ID, 5-1
correction rule processing
fiscal year (6-month duration), C-6
Fiscal_Period column, C-2
FISCAL_YEAR_INFO table, C-1 to C-2
Start_Month column, C-2
undo function, C-7
using SQL Talk, C-3
FISCAL_YEAR_INFO table, C-1 to C-2
Fiscal_Period column, C-2
Start_Month column, C-2
using SQL Talk to view, C-3
Floating Tree Bar, 1-8
Focus
  on Branch, 9-8, 10-9
  Undo, 9-8, 10-9
Font, 9-5, 10-6, 10-7
Formula, 7-2, 7-5
  ID, 11-1
  Formula ID, 6-3
foundation
  OFSA, 1-2
From/To
  Column(s), 3-31

G
Gomonth, 11-7
Gross-Up Approach, 2-4
Group, 3-3, 3-4
  Import/Export, 3-18
Group Filter ID
  creating and defining, 8-1 to 8-2
  editing, 8-3

H
Hierarchy, 10-1
Host, 2-9, 3-28

I
ID
  Close an, 3-4
  Copy an, 3-5
  Delete a Group of, 3-6
  Delete an, 3-5

J
Job
  Description, 2-9
  Return Status, 2-9, 3-28

K
Key
  Shift, 3-6, 9-10

L
Leaf
  Level, 3-7
  Setup, 3-7
  Type, 1-7, 3-7
  Value(s), 1-7, 3-7, 9-1
Ledger/Stat
  Information, 2-1
  Table(s), 2-1, 11-14

Information Dialog, 12-2
Process an, 3-25
Rename an, 3-5
Save an, 3-4
Save As..., 3-5
If, Then, 11-9
Implied
  Filter Criteria, 7-7
Increment
  by Percent, 3-31
  by Value, 3-30
Individual ID Import/Export, 3-15
Input
  Error, 2-2
  Insert, 11-12
    Constant, 11-11
    Level, 9-8
    Node, 9-9
Instrument
  Data, 2-1
    Table(s), 2-1, 2-3
Interpolate, 3-31
Invalid Code(s), 4-4
level of indentation, 5-2
Level(s), 9-4, 10-4
   Description, 9-9
Insert, 9-8
Leaf, 3-7
   Maintenance, 9-8
New Name, 9-9
Parent, 9-9
List(s)
   Numbered, xix
logical hierarchy, 5-1
Login, 1-4
Lookup, 11-10

M
Memory, 2-7
Menu(s), 1-4
   Edit, 1-6
   Options, 1-7, 1-8
   Process, 1-7
   Setup, 1-7
Missing Data, 2-2
Month, 11-8
Multiple
   IDs, 3-6
   Table(s), 7-2, 7-9
Multi-Processing, 2-7
Multi-User Problems and Solutions, 2-7

N
New
   Node ID, 9-10
   Node Level, 9-9
   Node Name, 9-9
Node(s)
   Copy, 9-10
   Cut, 9-11
   Delete, 9-10
   Description, 10-10
   Down, 9-11, 9-12
   Inclusion Indicator, 10-3
   Insert, 9-9
   Name, 9-10
   Number(s), 9-6, 9-10, 10-7
   Otherwise, 5-5
   Paste, 9-11
   Rename, 9-10
   Up, 9-11
Non-Pivot Transformations, 14-3
   Rates, 14-3
Null Values, 7-7, 11-13
Number, 2-9
Numbered Lists, xix

O
OFSA foundation, 1-2
Open
   an Existing ID, 3-4
Operand(s), 11-3
Operator(s), 11-3
Options
   Menu, 1-7, 1-8
Order
   of Process Arrows, 12-2
order of processing, 7-7
Orphan
   Branch, 9-10
   Leaf, 9-10
Output
   Column(s), 11-12

P
Parameters, 11-7
Parent
   Level, 9-9
   Name, 9-9
Parenthesis, 11-3
Password
   Change, 1-8
PC, 3-26
Permission, 3-3
Pivoting, 14-2
Platform Configuration, 2-8
Plug Balances, 2-3
Portfolio, 7-2
preface

Index-4
conventions table sample, xviii
Priority, 2-9, 3-29
Process, 3-26
an ID, 3-25
Menu, 1-7
PROCESS_ERRORS table, 6-2
Process_Errors Table, 5-7
Processing
   Server vs. Client, 2-8
processing
   order, 7-7
Processing ID, 3-25

R
Range(s), 7-5
Rate
   Tier, 2-4
Rates, 14-3
   Non-Weighted, 14-3
   Weighted, 14-3
Read Only, 3-3
Read/Write, 3-3
Reconciliation
   Report(s), 2-1
Record, 2-9, 3-28
Remove, 7-3
   All, 3-6, 7-3
Rename, 3-5
   Node, 9-10
Renumber, 1-7, 3-7, 3-11
Replace, 11-13
Report(s)
   Column, 11-1
   Macros, B-10
   Reconciliation, 2-1
Repricing Frequency, 2-5
Request
   Date, 2-9, 3-29
   Time, 2-9
Rollup
   Level Maintenance, 9-8
   Tree Window, 9-3
Row(s)
   Level Security, 7-7

RQ, 3-26

S
Save
   an ID, 3-4
   As..., 3-5
Scalability, 2-7
Scrubbing the Data, 2-2
Search, 1-6, 9-3, 9-5, 10-4, 10-5
   Field(s), 9-4, 10-4
   Option(s), 9-4, 10-4
   String, 9-4, 10-4
See
   All Jobs, 3-26
   Your Jobs, 3-26
Select
   All, 3-6
   Multiple IDs, 3-6
Selected
   IDs, 12-2
Server
   Polling Indicator, 3-27
   Status, 3-26, 12-3
   Status Window, 2-9
Set
   Display Level, 9-9, 10-9
   Tree Level, 9-9, 10-10
Setup
   Leaf, 3-7
   Menu, 1-7
Shift Key, 3-6, 9-10
Specific Value(s), 7-5
Spreadsheet, 4-1
SQL Talk
   limitations, 13-3
   columns displayed, 13-3
   processing time, 13-3
   rows displayed, 13-3
   multiple open windows, 13-2
   security (SQL Talk privileges), 13-1
   stored procedures, creating, 13-3
   using, 13-2
Start
   Date, 2-9, 3-29