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Preface

Welcome to Release 11i of the Oracle Applications User’s Guide.

This user’s guide includes the information you need to work with
Oracle Applications effectively.  It contains detailed information about
the following:

• Overview and reference information

• How to navigate through Oracle Applications Windows

• How to submit Oracle Applications programs, reports, and
listings

This preface explains how this user’s guide is organized and introduces
other sources of information that can help you.
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Audience for This Guide

This guide assumes you have a working knowledge of the following:

• The principles and customary practices of your business area

• Oracle Applications

If you have never used Oracle Applications, we suggest you
attend one or more of the Oracle Applications training classes
available through Oracle University.

See: Other Information Sources for more information about Oracle
Applications product information.

How To Use This Guide

This guide contains the information you need to understand and use
Oracle Applications.

• Chapter 1, “Getting Started,” introduces you to Oracle
Applications  and to some basic features common to all Oracle
Applications products.  It tells you how to log in, choose a
responsibility, use the menu, get Help, use keyboard shortcuts,
and exit.

• Chapter 2, “Oracle Applications User Interface Basics,”
introduces you to the Oracle Applications user interface and
teaches you a few simple concepts and functions you need to
start working.  Specifically, this chapter describes the anatomy of
the Oracle Applications user interface, how to navigate around
Oracle Applications, how to view message explanations, and
how to access linked forms.

• Chapter 3, “Entering and Querying Data,” discusses advanced
features that help you enter and query data from Oracle
Applications.  Specifically, this chapter describes how to simplify
data entry using a list of values, how to enter a date using the
Calendar, and how to search for information.

• Chapter 4, ”Customizing the Presentation of Data,” discusses
how you can customize the layout of your data in a folder.

• Chapter 5, “Using Flexfields,” contains an explanation of
flexfields and tells you how to use them.  You learn about the
features of flexfields, the differences between a key and a
descriptive flexfield, how to enter data into flexfields, and how
to query data using flexfields.
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• Chapter 6, “Running Oracle Applications Reports and
Programs,” gives you an overview of how to run reports and
programs in Oracle Applications.  Specifically, you learn about
the concurrent processing feature that allows you to run reports
and programs non–interactively, how to run reports and
programs using Standard Report Submission, and how to define
request sets.

• Chapter 7, “Monitoring Oracle Applications Reports and
Programs,” tells you how to view and monitor your requests.
Specifically, this chapter tells you how to use the Concurrent
Requests, Requests, and Completed Requests windows, how to
view the progress of a concurrent request, how to cancel a
request or change its processing options, and how concurrent
processing recovers from unforeseen system events.

• Chapter 8, “Working with Attachments,” describes attaching a
document to a data record, as well as how to view, delete, or
copy an attachment.

• Chapter 9, “Using User Profiles,” teaches you about Oracle
Applications user profiles.  User profiles give you control over
the behavior of certain Oracle Applications features.  This
chapter tells you how to set user profile options for all Oracle
Applications products.

• Appendix A, “Oracle Applications Menus,” describes the Oracle
Applications main menu bar.

• Appendix B, “Customizing the Personal Homepage,” describes
how to use and customize your personal homepage.

• Appendix C, ”Accessibility,” describes specific features in Oracle
Applications to enhance usability.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting
documentation accessible, with good usability, to the disabled
community. To that end, our documentation includes features that
make information available to users of assistive technology. This
documentation is available in HTML format, and contains markup to
facilitate access by the disabled community. Standards will continue to
evolve over time, and Oracle Corporation is actively engaged with
other market–leading technology vendors to address technical
obstacles so that our documentation can be accessible to all of our
customers. For additional information, visit the Oracle Accessibility
Program Web site at http://www.oracle.com/accessibility/.
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Accessibility of Code Examples in Documentation

JAWS, a Windows screen reader, may not always correctly read the
code examples in this document. The conventions for writing code
require that closing braces should appear on an otherwise empty line;
however, JAWS may not always read a line of text that consists solely
of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies
or organizations that Oracle Corporation does not own or control.
Oracle Corporation neither evaluates nor makes any representations
regarding the accessibility of these Web sites.

Other Information Sources

You can choose from many sources of information, including online
documentation, training, and support services, to increase your
knowledge and understanding of Oracle Applications.

If this guide refers you to other Oracle Applications documentation,
use only the Release 11i versions of those guides.

Online Documentation

All Oracle Applications documentation is available online (HTML or
PDF).

• Online Help – The new features section in the HTML help
describes new features in 11i. This information is updated for
each new release of Oracle Applications. The new features
section also includes information about any features that were
not yet available when this guide was printed. For example, if
your administrator has installed software from a mini–packs
upgrade, this document describes the new features. Online help
patches are available on MetaLink.

• 11i Features Matrix – This document lists new features available
by patch and identifies any associated new documentation. The
new features matrix document is available on MetaLink.

• Readme File – Refer to the readme file for patches that you have
installed to learn about new documentation or documentation
patches that you can download.
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Related User’s Guides

Oracle Applications shares business and setup information with other
Oracle Applications products. Therefore, you may want to refer to
other user’s guides when you set up and use Oracle Applications.

You can read the guides online by choosing Library from the
expandable menu on your HTML help window, by reading from the
Oracle Applications Document Library CD included in your media
pack, or by using a Web browser with a URL that your system
administrator provides.

If you require printed guides, you can purchase them from the Oracle
Store at http://oraclestore.oracle.com.

Installation and System Administration

Oracle Applications Concepts

This guide provides an introduction to the concepts, features,
technology stack, architecture, and terminology for Oracle Applications
Release 11i. It provides a useful first book to read before an installation
of Oracle Applications. This guide also introduces the concepts behind
Applications–wide features such as Business Intelligence (BIS),
languages and character sets, and Self–Service Web Applications.

Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle
Applications products. In Release 11i, much of the installation process
is handled using Oracle Rapid Install, which minimizes the time to
install Oracle Applications, the Oracle8 technology stack, and the
Oracle8i Server technology stack by automating many of the required
steps. This guide contains instructions for using Oracle Rapid Install
and lists the tasks you need to perform to finish your installation. You
should use this guide in conjunction with individual product user’s
guides and implementation guides.

Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications
Release 10.7 or Release 11.0 products to Release 11i. This guide
describes the upgrade process and lists database and product–specific
upgrade tasks. You must be either at Release 10.7
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(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to
Release 11i. You cannot upgrade to Release 11i directly from releases
prior to 10.7.

Maintaining Oracle Applications

Use this guide to help you run the various AD utilities, such as
AutoUpgrade, AutoPatch, AD Administration, AD Controller, AD
Relink, License Manager, and others. It contains how–to steps,
screenshots, and other information that you need to run the AD
utilities. This guide also provides information on maintaining the
Oracle applications file system and database.

Oracle Applications System Administrator’s Guide

This guide provides planning and reference information for the Oracle
Applications System Administrator. It contains information on how to
define security, customize menus and online help, and manage
concurrent processing.

Oracle Alert User’s Guide

This guide explains how to define periodic and event alerts to monitor
the status of your Oracle Applications data.

Other Implementation Documentation

Oracle Applications Product Update Notes

Use this guide as a reference for upgrading an installation of Oracle
Applications. It provides a history of the changes to individual Oracle
Applications products between Release 11.0 and Release 11i. It includes
new features, enhancements, and changes made to database objects,
profile options, and seed data for this interval.

Oracle Workflow Developer’s Guide

This guide explains how to define new workflow business processes
and customize existing Oracle Applications–embedded workflow
processes. It also describes how to define and customize business
events and event subscriptions.
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Oracle Workflow User’s Guide

This guide describes how Oracle Applications users can view and
respond to workflow notifications and monitor the progress of their
workflow processes.

Oracle Workflow API Reference

This guide describes the APIs provided for developers and
administrators to access Oracle Workflow.

Oracle Applications Flexfields Guide

This guide provides flexfields planning, setup, reference, and ongoing
maintenance information. This manual also provides information on
creating custom reports on flexfields data.

Oracle eTechnical Reference Manuals

Each eTechnical Reference Manual (eTRM) contains database diagrams
and a detailed description of database tables, forms, reports, and
programs for a specific Oracle Applications product. This information
helps you convert data from your existing applications, integrate
Oracle Applications data with non–Oracle applications, and write
custom reports for Oracle Applications.  Oracle eTRM is available on
MetaLink.

Oracle Applications Message Reference Manual

This manual describes all Oracle Applications messages. This manual is
available in HTML format on the documentation CD–ROM for Release
11i.

Training and Support

Training

Oracle offers a complete set of training courses to help you and your
staff master Oracle Applications and reach full productivity quickly.
These courses are organized into functional learning paths, so you take
only those courses appropriate to your job or area of responsibility.

You have a choice of educational environments. You can attend courses
offered by Oracle University at any one of our many Education
Centers, you can arrange for our trainers to teach at your facility, or
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you can use Oracle Learning Network (OLN), Oracle University’s
online education utility. In addition, Oracle training professionals can
tailor standard courses or develop custom courses to meet your needs.
For example, you may want to use your organization structure,
terminology, and data as examples in a customized training session
delivered at your own facility.

Support

From on–site support to central support, our team of experienced
professionals provides the help and information you need to keep
Oracle Applications working for you. This team includes your
Technical Representative, Account Manager, and

Oracle’s large staff of consultants and support specialists with expertise
in your business area, managing an Oracle8i server, and your hardware
and software environment.

Do Not Use Database Tools to Modify Oracle Applications Data

Oracle STRONGLY RECOMMENDS that you never use SQL*Plus,
Oracle Data Browser, database triggers, or any other tool to modify
Oracle Applications data unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change,
retrieve, and maintain information in an Oracle database. But if you use
Oracle tools such as SQL*Plus to modify Oracle Applications data, you
risk destroying the integrity of your data and you lose the ability to
audit changes to your data.

Because Oracle Applications tables are interrelated, any change you
make using Oracle Applications can update many tables at once. But
when you modify Oracle Applications data using anything other than
Oracle Applications, you may change a row in one table without
making corresponding changes in related tables. If your tables get out
of synchronization with each other, you risk retrieving erroneous
information and you risk unpredictable results throughout Oracle
Applications.

When you use Oracle Applications to modify your data, Oracle
Applications automatically checks that your changes are valid. Oracle
Applications also keeps track of who changes information. If you enter
information into database tables using database tools, you may store
invalid information. You also lose the ability to track who has changed
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your information because SQL*Plus and other database tools do not
keep a record of changes.

About Oracle

Oracle Corporation develops and markets an integrated line of
software products for database management, applications
development, decision support, and office automation, as well as
Oracle Applications, an integrated suite of more than 160 software
modules for financial management, supply chain management,
manufacturing, project systems, human resources and customer
relationship management.

Oracle products are available for mainframes, minicomputers, personal
computers, network computers and personal digital assistants,
allowing organizations to integrate different computers, different
operating systems, different networks, and even different database
management systems, into a single, unified computing and information
resource.

Oracle is the world’s leading supplier of software for information
management, and the world’s second largest software company. Oracle
offers its database, tools, and applications products, along with related
consulting, education, and support services, in over 145 countries
around the world.

Your Feedback

Thank you for using Oracle Applications and this user’s guide.

Oracle values your comments and feedback. At the end of this guide is
a Reader’s Comment Form you can use to explain what you like or
dislike about Oracle Applications or this user’s guide. Mail your
comments to the following address or call us directly at (650) 506–7000.

Oracle Applications Documentation Manager
Oracle Corporation
500 Oracle Parkway
Redwood Shores, CA  94065
U.S.A.

Or, send electronic mail to appsdoc_us@oracle.com.
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Getting Started

his chapter introduces you to Oracle Applications.  Specifically,
this chapter teaches you how to:

• Start Oracle Applications

• Use Oracle Applications menus

• Use keyboard shortcuts

• Get help in Oracle Applications

• Exit from Oracle Applications

In addition, this chapter also lists some basic graphical user interface
terms used throughout the guide.
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Overview of Oracle Applications

Oracle Applications is a tightly–integrated family of application
products that share a common look and feel.  Using the menus and
windows of Oracle Applications, you have access to all the functions
you need to manage your business information.

Oracle Applications is highly responsive to users, supporting a
multi–window graphical user interface (GUI) that provides you with
full point–and–click capability.  You can use your mouse or keyboard to
operate graphical controls such as pull–down menus, buttons, poplists,
and check boxes.

In addition, Oracle Applications offers many other features such as
field–to–field validation and list of values to help you simplify data
entry and maintain the integrity of the data you enter.

The best way to familiarize yourself with the common look and feel of
Oracle Applications products is to log in and use the products.  This
chapter describes how to get started with Oracle Applications and
provides you with the basic information you need to explore Oracle
Applications in greater depth.

Suggestion:  This guide teaches you how to use the Oracle
Applications GUI and other common Oracle Applications
features.  If you need specific information about a particular
Oracle Applications product, you should consult the help or
reference guide for that product.  For example, if you wish to
learn how to enter a journal, you should consult the Oracle
General Ledger User’s Guide or the Oracle Public Sector General
Ledger User’s Guide.

Basic Business Needs

Oracle Applications provides you with features you need for your
business.  With Oracle Applications you can:

• Learn how to use the system quickly.  Oracle Applications uses
familiar and easy–to–use menus so you, your staff, and your new
employees can be productive after a few minutes of coaching
from a colleague.

• Be productive even if you are a novice user.  A simple, intuitive
graphical user interface (GUI) lets you use all of the power of
Oracle Applications.
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• Increase your productivity as a power user.  When you become
familiar with Oracle Applications, you can use shortcuts in the
graphical user interface to quickly navigate and work with
multiple windows at once.

• Get help when you need it.  Context–sensitive online help is
always available whenever you need assistance.

• Secure your application data from unauthorized access.  You
can control access to your application data and customize the
windows available for each user based on that user’s level of
authority.

Basic GUI Terminology

Before using Oracle Applications, you should familiarize yourself with
the specifics of your GUI environment and how to perform basic tasks,
such as using a menu or selecting an item.  In doing so, you should
come across and become familiar with the following generic terms:

The part of your computer monitor that displays
information and where your work takes place.
This is also referred to as your screen.

A box around a set of related information on your
desktop.

A list that appears in a bar across the top of a
window that consists of commands or actions you
can perform.

Quickly press and release a mouse button while the
mouse pointer is on a particular item.

Rapidly click a mouse button twice while the
mouse pointer is on a particular item.

Move the mouse while holding down a mouse
button.

Mark an item.  Examples include highlighting text,
or clicking on a value from a list.

Select an item and initiate the action associated
with the item.  Examples include choosing a menu
item or choosing a button.

A vertical or horizontal bar that appears on a
window whose contents are not entirely visible.

desktop

window

menu

click

double–click

drag

select

choose

scroll bar
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Click on the arrows, or drag on the box of a scroll
bar to scroll through the hidden contents, or click
in the bar itself to move to either the previous or
next page.

Note:  The mouse button that we refer to in the terms above is
the mouse button that you program for selecting text and
choosing items.  (Usually the left mouse button)

Once you get started in Oracle Applications, you can refer to the Oracle
Applications User Interface section of this guide for a more
comprehensive list of user interface terms.  See: Oracle Applications
User Interface: page 2 – 2.
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Starting Oracle Applications

To start Oracle Applications, you need to:

• Start up your computer system

• Start your Web Browser

• Start the Oracle Applications program

• Log on to Oracle Applications

Starting and Logging On

The first step in starting Oracle Applications is to enter the appropriate
URL for your site in an Oracle Applications certified browser.

After starting Oracle Applications, the first window you see is the
Login window.
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You need an Oracle Applications username and password, also known
as an Oracle Applications sign–on, to log on to Oracle Applications.  It
is different from the username and password you use to log on to your
computer.  If you are not sure of your Oracle Applications sign–on,
consult your system administrator.

Oracle Applications security is based on your Oracle Applications
sign–on.  Your sign–on connects you to your responsibilities, which
control your access to applications, functions, reports, and data.

Note:  The exact appearance of your login window may vary
depending on how it is customized at your site.
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Getting Started in Oracle Applications

� To log on to Oracle Applications:

1. Enter your username in the Username field.

Attention:  Do not press [Enter] after entering each item, as [Enter]
is normally used to accept the default button.  Instead, use [Tab] or
the mouse to navigate between fields.

2. Enter your password in the Password field.

3. (Conditional) Select a language.

If multiple languages are installed at your site, choose a language
from the options presented.

4. Choose Login.

Notice your password does not appear as you type it, to prevent
others from seeing it.  Keep your password confidential to prevent
access to Oracle Applications by unauthorized users.

After you log in, you will see either the E–Business Suite Home page
(see: page 1 – 8) or the Personal Homepage (see: page 1 – 14)
depending on how your system is configured.
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Features of the E–Business Suite Home Page 

When you log in to Oracle Applications your E–Business Suite Home
is displayed.  From here you can:

• View and respond to notifications

• Access E–Business Suite Applications

• Navigate to other frequently–used functions or Web pages

• Set personal user preferences

Worklist

The Worklist portlet lists your five highest priority notifications,
ordered by priority and then by date. For each notification, the list
displays the from role, subject, and sent date. Select the From, Subject,
or Sent column heading to sort the list by that column.
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• To view and respond to a notification, select the notification
subject link in the Subject column.  For more information, see:
To View the Details of a Notification, Oracle Workflow User’s
Guide.

• To view the complete list of all your notifications in the
Advanced Worklist, select the Full List button. For more
information, see: To View Notifications from the Advanced
Worklist, Oracle Workflow User’s Guide.

Menu

From the Menu portlet you can access Oracle E–Business Suite
functions grouped by responsibility.

A responsibility is a level of authority in Oracle Applications that lets
you access only those Oracle Applications functions and data
appropriate to fulfill your role in an organization.  Each responsibility
allows access to:

• A specific application or applications, such as Oracle General
Ledger.

• A set of books, such as U.S. Operations or German Sales or an
organization, such as New York Manufacturing or New York
Distribution.

• A restricted list of windows that you can navigate to; for
example, a responsibility may allow certain Oracle Planning
users to enter forecast items, but not enter master demand
schedule items.

• A restricted list of functions you can perform.  For example, two
responsibilities may have access to the same window, but one
responsibility’s window may have additional function buttons
that the other responsibility’s window does not have.

• Reports in a specific application; your system administrator can
assign groups of reports to one or more responsibilities, so the
responsibility you choose determines the reports you can submit.

Each user has at least one responsibility and several users can share the
same responsibility.

Two Types of Responsibilities

The Menu portlet may contain links to Self–Service applications as well
as Forms–based applications.
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Select the responsibility link to view its menu of functions on the
adjacent pane.  Select the function to launch it.

If you choose a Forms–based function, the Oracle Applications
Navigator window will open.  For more information about the
Navigator window, see Opening a Form from the Navigator Window:
page 1 – 15.

Favorites

This portlet contains a customized list of frequently–used functions and
Web sites. To add or remove options from this list, select Edit Favorites
to access the Customize Favorites Portlet page.
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Customize Favorites Portlet Page

Use this window to add functions and Web sites to your Favorites
portlet.  Select individual functions from your responsibility menus.  To
add a Web site, click the Add URL button to access the Add a Favorite
Web Site page.

You can also rename the selected functions in your Favorites portlet, or
change the URL for a Web site.  Click the Rename button to access the
Update a Favorite Web Site page.
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Add a Favorite Web Site

Enter the a name and the URL for any Web site that you wish to access
from your Favorites portlet.

Update a Favorite Web Site 

Use this page to update the displayed name of any option listed on
your Favorites portlet or to update the URL for a listed Web site.

Preferences  

Select the Preferences link (displayed at both the top and bottom of the
E–Business Suite Home page) to set your personal user options.  The
Preferences page is divided into four categories: General, Notification,
Formatting, and Password Settings.

General

Set the following options in this region:

• Known As—The name displayed for your user ID.

• Language—The session language you chose when you logged in.
If there are multiple languages installed at your site, you can
update your preference here.

• Territory—Determines the value for certain
regionally–determined settings, such as numeric format (in
concurrent manager reports) and start day of the week.

• Timezone – In Oracle Applications Framework HTML–based
applications, this setting determines the timezone used when
formatting fields that show dates and times.

• Client Character Encoding – The character set that your machine
(client) uses as its native character set. This value should
correspond to your chosen language and platform.  See your
system administrator before updating this option.

• Accessibility Features – Sets the accessibility mode for Oracle
Applications Framework HTML–based applications.  Values are:

– Yes – generates HTML enhanced for accessibility.

– No – generates HTML optimized to load screens faster by
eliminating redundant content that is unnecessary for all
users.
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– Screen Reader – generates HTML optimized for the use of
screen readers.

Notification

If you have an electronic mail address defined, you can choose the
Notification Style (if any) for your notifications.

The options are:

• Do not send me mail

• HTML mail

• HTML mail with attachments

• Plain text mail

• Plain text mail with HTML attachments

• Plain text summary mail

Formatting

• Date Format—Choose a date format from the list provided.

• Number Format – Currently only the US number format is
recognized in Oracle self–service applications.

Password Settings

Change your password here.
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Accessing Oracle Applications Using the Personal Homepage

Choosing a Responsibility

For the definition of a responsibility, see: page 1 – 9.

You will see a link for each responsibility assigned to you.

Two Types of Responsibilities

The Navigate region may contain links to Self–Service applications as
well as Forms–based applications.  To choose a responsibility, select the
responsibility link.

� If you choose a Self–Service application:

The menu of functions will display in the adjacent region.  Select the
function to launch it.
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� If you choose a Forms–based responsibility:

The Oracle Applications Navigator window will open.  For more
information about the Navigator Window, see Opening a Form from
the Navigator Window: page 1 – 15.

Each user has at least one responsibility and several users can share the
same responsibility.

Note:  If your system administrator assigns you just one
Forms–based responsibility with no other options on your
homepage, your responsibility will launch when you sign on.

If you are assigned one Self–Service responsibility with many
functions, and you have no other options on your personal
homepage, your responsibility’s list of functions will display as
if you had clicked the link.

If you are assigned one Self–Service responsibility with just one
function, and you have no other options on your personal
homepage, your function will launch automatically when you
sign on.

Setting your Preferences Through the Personal Homepage

There are several choices you can make about how you want to view
information in Oracle Applications. These choices include languages,
date formats, and number formats.

To access your preferences, choose the Preferences link. For information
on your preference options, see Preferences: page 1 – 12.

Additional Personal Homepage Features

For a description of additional features you may find on your Personal
Homepage, see Personal Homepage in Oracle Applications: page B – 2.

Opening a Form from the Navigator Window

Use the Navigator window to navigate to a form that lets you perform
a specific business flow.  The Navigator window is always present
during your session of Oracle Applications Forms and displays the
name of your current responsibility in its window title.
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The Navigator consists of three regions: Functions, Documents, and
Processes.  The Functions region provides a list of forms displayed like
the files in a file system, the Documents region is a customizable region
that allows you to create links to specific documents that you use
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frequently, and the Processes region provides graphical maps of
business processes, allowing you to automate business flows across
forms.

Using the Navigator’s Functions Region

The forms that you can navigate to are displayed in a navigation list on
the left–hand side of the Navigate window.  The navigation list is
organized much like the hierarchy of a file system, where you can
expand items that begin with a plus sign (+) to further sub–levels until
you find your form of interest.  Sub–levels appear indented below the
items from which they are expanded.  Items that are expanded are
preceded by a minus sign (–).  You can expand no further when an item
displays neither a plus or minus sign.

Above the navigation list, you should see two fields that span the
width of the window.  These two fields help you identify your
selection.  The top field displays the name of the item currently
selected, while the bottom field displays a description of that item.

� To expand or collapse the navigation list:

1. Choose one of the following methods to expand an expandable
item to its next sub–level:

• Double–click on the item.

• Select the item and choose Open.

• Select the item and choose the Expand button.

2. Choose one of the following methods to collapse an expanded item:

• Double–click on the item.

• Select the item and choose the Collapse button.

3. To expand or collapse several items at once, choose one of the
following buttons:

• Expand All Children—expand all the sub–levels of the currently
selected item

• Expand All—expand all the sub–levels of all expandable items in
the navigation list

• Collapse All—collapses all currently expanded items in the
navigation list
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� To open a form from the navigation list:

1. Select your form of interest..

2. Choose Open.

Suggestion:  Alternatively, you can double–click directly on
the form of interest to open it.  However, do not double–click
on the Open button.  All buttons require only a single click to
activate; using a double click will activate the action twice.

� To open a form using an LOV window:

1. Use the keyboard shortcut (usually Ctrl L) to open the LOV (List of
Values) window.

2. Select the form from the list and choose OK or first reduce the list
by entering a partial form title.

See Also

Using Keyboard Shortcuts: page 1 – 26

Using a List of Values: page 3 – 9

Using the Top Ten List

If there are forms that you use frequently, you can copy them over to a
navigation top ten list located on the right–hand side of the Navigate
window.  The top ten list displays your forms numerically so you can
choose them instantly without having to search for them in the
navigation list.  You can add a maximum of ten forms to the top ten list
and you can create a different top ten list for each responsibility you
have access to.

Note:  A top ten list is unique for the responsibility and user
sign–on combination you use.

� To create a navigation top ten list:

1. Select a frequently used form from the navigation list.

2. Choose the arrow pointing to the Top Ten List.

The form now appears in the navigation top ten list preceded by a
top ten list number.



1 – 19Getting Started

3. If you wish to remove a form from the top ten list, select that form
in the top ten list and choose arrow pointing away from the Top
Ten List.

� To open a form from the navigation top ten list:

Type the top ten list number that precedes the form you want to
open.  You can also select the form you want and choose Open, or
double–click on the form name.

Notice that the name and description of that form also appear in
the current selection fields above the navigation list.

Using the Navigator’s Documents Region

If you have a document, such as a particular purchase order, invoice, or
sales order that you want to access later, you can create a link to the
document using the Navigator’s Document feature.  The Navigator’s
Document feature allows you to create as many links as you want and
save them in the Documents region of the Navigator window.  The
links can be represented as icons in the window or may be viewed as a
list.  Documents are defined as ”real–world” documents such as those
listed above, but may also include such documents as employees or
plans.  When you use a link to open a document, Oracle Applications
opens the document in the appropriate form window.  You can access
the Document region using the tab control.

� Adding new Documents to the Navigator

Forms that support adding documents to the Navigator enable the
Place on Navigator menu item in the File menu.  Use this menu
item to add your document to the Navigator.

� Opening the Navigator’s Document Region

Choose Documents from the tab control in the Navigation window.

Once you create a link to a document, the Document region will
open by default when you log on.

� To open a form from the Document Region

1. Select the document link you want to open.

2. Choose Open or double–click it.
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� Renaming Documents in the Navigator

1. Select the document link you want to rename.

2. Choose the Rename... button, or double–click the label.

3. Enter the new name, then press OK.

Note:  There is a limit of 80 characters for document names.

� Removing Documents from the Navigator

1. Select the document link to be discarded.

2. Choose Remove.

Removing the document link from the Navigator has no effect on
the actual document.  However, if a record such as a purchase
order is deleted in the ”Enter Purchase Orders” form, the link in
your Navigator displays a message letting you know that your link
is now invalid.

Using the Navigator’s Processes Region

The Processes region of the Navigator (the ”Process Navigator”)
automates business flows across Oracle Applications forms.  It allows
you to model and execute complex business processes through an
easy–to–use, graphical user interface.  The business processes enabled
through the Process Navigator can cross product boundaries and
include complete business cycles.

The Process Navigator guides you step–by–step through each required
function in a business process.  In addition to providing a visual map of
a business process, the Process Navigator can launch the appropriate
Oracle Applications forms or standard reports at each step.

Each time you start a business process, you create an ”instance” of that
process.  You can create as many instances as you need.  Each instance
maintains its own version of the process diagram identified by a name
you assign.  As you complete each form or ”step” within your process,
you can save the data and update your diagram to indicate that this
step is complete.  When you open a subsequent form, the information
you entered in prior forms is used to query the appropriate data.

You are not required to complete a process before closing the process
instance.  A process instance can be closed for later completion, or you
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can choose to end the instance before completion.  Ending a process
instance does not change or modify any data you have entered.

Creating and Opening a Process

When you enter the Processes region, the processes assigned to your
current responsibility are displayed in a list.  To use a process, you
create an instance of the process, and enter a name for the instance.
This instance remains ”active” until you complete or cancel the process.
Active instances are listed in the Navigator below the process from
which they were derived.  Instances are available only to the user who
created them.

� Creating a new instance

1. Select a process.

2. Choose Launch.

3. Enter the name for the new instance.  This name appears in the
Navigator Processes list.

� Open an existing process instance

Single click on the process instance you want to open in the
Navigator Processes list.

The Navigator continues to display the current process instance until
you select another.

Working in a Process Instance

The process instance displays a diagram containing various steps, with
each step represented by an icon.  The active step or steps are indicated
by green boxes drawn around the step icons.  There may be more than
one active step if your process contains multiple paths.

The diagram allows you to view a brief description of each step or to
open the form associated with a step.

� Opening a form

Click once on any step icon within a process to display a brief
description of that step.

Double–click on an icon to open the related Oracle Applications
form.
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Note:  You can open a step in a process instance regardless of
whether it is an active step.  If you open a non–active step, the
system warns you that upon step completion, you cannot use
the Next Step option from the File menu.  In addition, the
process instance diagram will not indicate that the step is
complete.

Attention:  Function Security is enabled in the Processes
region of the Navigator.  If your current responsibility does not
have access to a form, you cannot open that form.

� Completing a Step

When a step represents a transaction updated through an Oracle
Applications form, there are two ways you can complete that step:

• You can select Next Step from the File menu, or

• You can return to the Process Navigator, and with the completed
step highlighted, choose the Complete button.

Use the second method for any step that does not represent a
transaction based on an Oracle Applications Form.

� Ending a Process Instance

A process instance may be terminated at any time during the process
without affecting any data you have entered.  A process instance is
automatically terminated when the last step in the process is complete.
The system removes the process instance from the Process Navigator
list the next time you log in.  You may also choose to terminate a
process instance before all of the steps are complete.  To do this:

1. Select the process instance to be terminated.

2. Choose the Abort button.
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Changing Your Security Access

If you have several responsibilities and you want to work in Oracle
Applications under a different responsibility, you can do so without
exiting Oracle Applications.

You can also change the password to your user sign–on at any time.
Your system administrator may require all users to periodically change
their passwords to maintain better security to Oracle Applications.

� To switch your responsibility:

1. Click in the Navigate window or choose Navigator from the
Window menu to make the Navigate window active.

2. Choose Switch Responsibility from the File menu.

If there are windows still open in your current responsibility,
Oracle Applications asks you to save your changes, if there are any,
before it closes those windows.  You may cancel switching
responsibilities by choosing Cancel in the save changes window.

Note:  The save changes window only appears if there are any
changes to save.  If there are no changes to save, all open windows
other than the Navigate window close, and Oracle Applications
displays your responsibility list.

Note:  If you have only one responsibility, the Switch Responsibility
menu item is disabled.

3. Select a new responsibility from the Responsibilities window and
choose OK.

The Navigate window title and contents then update to reflect the
new responsibility you chose.

� To change your password:

1. Click in the Navigate window or choose Navigator from the
Window menu to make the Navigate window active.

2. Choose Change Password... from the Edit, Preferences menu, to
display the Password Update window.
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3. Enter your old password in the Old Password field.

4. Enter your new password in the New Password field.

5. Enter your new password again in the Re–enter New Password
field.

6. Choose OK.

If the second entry of your new password does not match your
first, Oracle Applications asks you to re–enter your new password
again, until both entries match.  Your new password takes effect
immediately.

Note:  If you change your mind and do not want to alter your
password, choose Cancel to close the Password Update window.
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Using Menus

Oracle Applications use a Multiple Document Interface (MDI).  All
windows are displayed inside a single container window, with a single
toolbar, menu, message line, and status line attached to that window.

Pulldown Menu

The pulldown menu bar includes the following menus:

• File

• Edit

• View

• Folder

• Tools

• Special A & B (only visible when active)

• Window

• Help

Use these menus to navigate through a form, to edit or retrieve data, or
to perform various other actions.

See Also

Oracle Applications Pulldown Menu Bar: page A – 2

Right Mouse Button Menus

In addition to the Pulldown menu, using the right mouse button allows
you to access the following menu items:

• Cut

• Copy

• Paste

• Folder Menu

• Help
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Using Keyboard Shortcuts

Experienced Oracle Applications users can access the menu by using a
keyboard shortcut, a specific combination of keystrokes that performs the
same function as a corresponding menu item.  Oracle Applications
assigns many commonly used functions, such as Run Query, Save, or
Clear Record to keyboard shortcuts.

You can display a list of the keyboard shortcuts that map to your
computer terminal’s keyboard at any time.

Note:  Rather than list the actual keys for a keyboard shortcut,
we refer to keyboard shortcuts in this guide using the format
[Function] where Function represents the function that the
keyboard shortcut performs.

� To display a list of keyboard shortcuts:

1. Choose Keyboard Help...  from the Help menu.
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2. When you finish scrolling through the listing, choose OK to close
the window.

Most window buttons are also mapped to keyboard shortcuts.  The
shortcut key is indicated with an underline in the button label.  For
example, in the Request Summary window, the button label Hold
Request has the ”H” underlined.  This indicates that you can use the
keyboard shortcut Alt–H to put a request on hold instead of using the
mouse.

Attention:  Depending on your GUI environment, you can also
invoke menu items using keystroke combinations that are different
from the keyboard shortcuts described above.  For example, each
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menu item is identified by a unique underlined character.  You can
press a function key that invokes the menu, and then type in the
underlined character of the menu item you want to invoke.  For
example, the function key in Windows that invokes the menu is
[Alt].  To choose Print... from the File menu, you enter [Alt] [F] [P],
where F is underlined in File and P is underlined in Print....

See Also

Toolbar: page 2 – 10
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Getting Help

Oracle Applications provides you with a complete online help facility.

Whenever you need assistance, simply choose an item from the Help
menu to pinpoint the type of information you want.

� To display help for a current window:

1. Choose Window Help from the Help menu, click the Help button
on the toolbar, or hold down the Control key and type ’h’.
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A web browser window appears, containing search and navigation
frames on the left, and a frame that displays help documents on the
right.

The document frame provides information on the window
containing the cursor.  The navigation frame displays the top–level
topics for your responsibility, arranged in a tree control.

2. If the document frame contains a list of topics associated with the
window, click on a topic of interest to display more detailed
information.

3. You can navigate to other topics of interest in the help system, or
choose Close from your web browser’s File menu to close help.

Suppose you are using Oracle General Ledger and are in the Define
Budget Organization window.  You want to know how to create a
budget organization using this window.  Choose Window Help from
the Help menu to display a help on this topic.

� To display online help for any of the Oracle Applications products:

1. Choose Oracle Applications Library from the Help menu.

A web browser window appears, containing search and navigation
frames on the left, and a document frame on the right.

2. In the navigation frame, click on the name of a product family to
display a list of products in that family.  Click on a product name to
display the list of top–level topics in that product’s online
documentation.

3. Click on a topic of interest.  Topics preceded by a plus sign (+)
expand to show subtopics.  Help on the topic displays in the
document frame.

4. To collapse sections of the tree you previously expanded, click on
topics preceded by a minus sign (–).

5. When you are finished, choose Close from the web browser’s File
menu to close help.

Note:  A topic called ”Library” and topics corresponding to
other products and product families are often included on the
navigation tree associated with a particular responsibility.
These topics function in a fashion similar to the Library tree
described here.
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� To display version information for Oracle Applications:

1. Choose About Oracle Applications from the Help menu.

2. An About Oracle Applications window appears on your screen.

The window provides details about the version of the Oracle
Applications components you are using, your login information,
and information about the current form you are using.

You can supply this information to your system administrator or to
Oracle Customer Support if you need to report a problem.

3. Choose OK to close this window.

See Also

Searching for Help: page 1 – 31

Toolbar: page 2 – 10

Using Keyboard Shortcuts: page 1 – 26

Learning About a Record: page 3 – 7

Interpreting Messages: page 2 – 21

Requests Window: page 7 – 2

Searching for Help

You can perform a search to find the Oracle Applications help
information you want.  Simply enter your query in the text field located
in the top–left frame of the browser window when viewing help, then
click the adjacent Find button.

A list of titles, ranked by relevance and linked to the documents in
question, is returned from your search in the right–hand document
frame.  Click on whichever title seems to best answer your needs to
display the complete document in this frame.  If the document doesn’t
fully answer your questions, use your browser’s Back button to return
to the list of titles and try another.

The search syntax to use in constructing your query can be any of those
shown in the following table.
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Use this syntax . . . To find files containing . . .

term the word ”term”

string* words that begin with ”string”

”words, and punctuation” the precise phrase ”words, and punctuation”

term1 OR term2 either term1 or term2

term1 term2 either term1 or term2

term1 AND term2 both term1 and term2

term1 +term2 both term1 and term2

term1 AND NOT term2 term1, but not term2

term1 –term2 term1, but not term2

Table 1 – 1 Help Search Syntax  (Page 1 of 1) 

You want to know how to create a budget organization in Oracle
General Ledger.  You enter ”budget organization” in the search
field, and click Find.  A linked list of help documents that contain this
phrase appears in the document frame. You click on one that seems
appropriate and start reading.
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Exiting Oracle Applications

When you complete your work, you can choose to save or discard any
unsaved work in your form(s) before exiting Oracle Applications.

� To exit Oracle Applications:

1. Choose Exit Oracle Applications from the File menu.

If there are no changes to save in your window or windows, Oracle
Applications asks you to confirm your exit.

2. Choose OK to exit Oracle Applications and return to your desktop.

If there are recent changes that you have not yet saved, a window
appears as shown:

3. Choose Save to save the changes before exiting.  Choose Discard to
exit without saving any changes.  Choose Cancel to close this
window and cancel the exit.

Note:  You will be asked once for each form that is currently
open and has changes pending.

See Also

Closing Multiple Windows: page 2 – 20
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Oracle Applications
User Interface Basics

his chapter introduces you to the anatomy of the Oracle
Applications user interface and teaches you a few simple concepts and
functions you need to start working with Oracle Applications.
Specifically, this chapter describes how to:

• Navigate around Oracle Applications

• Use window functions

• Interpret message explanations

• Access linked forms

• Export data to a spreadsheet
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Oracle Applications User Interface

To use Oracle Applications effectively, you need to understand the
components that make up its user interface.  The following major
components and terms will be discussed and illustrated in this chapter:

• screen

• window

• window title

• Oracle Applications window

• title bar

• modal window

• form

• block

• field

• region

• record

• current record indicator

• message line

• status line

• toolbar

• tabbed region

• master–detail relations

• drill–down indicator

• combination block

For information on features for disabled users see Oracle Applications
Accessibility Features: page C – 2.

Components of the User Interface

The following figures show Oracle Applications running in a Browser
window, displaying windows typically seen when submitting a single
request.  The various user interface components are identified on these
figures.
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1. Oracle Applications Window

2. Title Bar

3. Menu

4. Toolbar

5. Window Title

6. Required Field

7. Field (display only)

8. Region Title

9. Disabled Button
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10. Checkbox

11. Region Border

12. Button (enabled)

13. Message Line

14. Status Line

15. Option Group

16. Selected Option

17. Disabled Option

18. Poplist
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19. Current Record Indicator (If the record allows drill–down the
Current Record Indicator is twice as wide.)

20. Scroll Bar

Screen

A screen represents the part of your computer monitor that displays
information.  A screen is also referred to as a desktop.

Window

A window, is a box around a set of related information on your screen.
Many windows can appear on your screen simultaneously and can
overlap, appear adjacent to, or on top of each other.  You can move a
window to a different location on your screen.

Window Title

A window title at the top of each window indicates the name of the
window, and occasionally, context information pertinent to the contents
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of the window.  The context information, which is contained in
parentheses, can include the organization, set of books, or business
group that the window contents is associated with.

Oracle Applications Window

Every session of Oracle Applications is displayed in a special window
called the Oracle Applications window.  The Oracle Applications window
displays form windows and common elements such as the main menu
bar, toolbar, status and message lines.  The appearance of the Oracle
Applications window may vary depending on the Browser you use.

Title Bar

Across the top of the Oracle Applications window is the Title Bar.  The
title contains the Oracle Applications title and the icons for minimize,
maximize, and close.

Modal Window

Certain actions that you perform in Oracle Applications may cause a
modal window to display.  A modal window requires you to act on its
contents before you can continue, usually by choosing OK or Cancel.
Examples of modal windows include the list window, the field editor
window, or any error or message window that may appear.

Form

A form is an organized display of fields through which you can quickly
and easily access and enter information to complete a business task.
When you use the Navigate window in Oracle Applications, you
navigate to a form.  Each form displays one or more windows and
maps to a complete business or task flow.  Note that a given window
can appear in more than one form if it accomplishes a task that is part
of more than one business flow.

The forms you can navigate to depend on the responsibility you choose
when you sign on to Oracle Applications.  A form in one responsibility
may vary from the same form in another responsibility, such that
certain windows or buttons may exist in one but not the other.  This
enables your organization to maintain security at a functional level so
that only a user with a given responsibility can access a particular set of
functions (for example, windows or buttons).  Overview of Function
Security, Oracle Applications System Administrator’s Guide.
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Block

Every Oracle Applications window consists of one or more blocks.  A
block contains information pertaining to a specific business entity.  All
required fields in a block must be completed before you can move to
the next block.  Generally, the first or only block in a window assumes
the name of the window.  Otherwise, a block name appears across the
top of the block with a horizontal line marking the beginning of the
block.

Field

Each block contains fields you use to enter, view, update, or delete
information.  A field prompt describes each field by telling you what
kind of information appears in the field or what kind of information
you should enter in the field.  Fields are color coded to indicate their
type.

White Fields – allow data entry

White Fields with Green Underlined Text – indicate drill–down
capability

Yellow Fields – require data entry

Gray Fields with Black Text – are display–only

Gray Fields with Gray Text – are disabled

Blue Fields – indicate fields to use in Query–Enter mode

The term field generally refers to a text field, an area in a window that
either displays data or allows you to enter data.  However, a field can
also include the following:

button—You choose a button to initiate a predefined action.  A
button is usually labeled with text to describe its action or it can be
an icon whose image illustrates its action.

A button can be enabled or disabled.  A button is disabled when its
function is not currently available.  A disabled button is
distunguised by the lightened appearance of its label.

check box—You can indicate an on/off or yes/no state for a value
by checking or unchecking its check box.

option group—An option group is a set of option buttons.  You can
choose only one option button in an option group at a time, and the
option group takes on that button’s value after you choose it.  An
option button or option group is also referred to as a radio button or
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radio group, respectively, using the metaphor of a car radio’s station
buttons.

poplist—A poplist lets you choose a single value from a short list.
To choose a value, click on the poplist to display the list of choices,
then drag your mouse through the list to the desired value.  Release
your mouse button to choose the value you highlight and display it
in the poplist field.  A poplist is also sometimes known as a list.

Region

A region is a collection of logically–related fields set apart from other
fields by a horizontal line across the window or a rectangular box.
Each block can optionally contain one or more regions.  Regions help to
organize the information within a block.

A scrollable region is a region whose contents are not entirely visible in a
window.  A scrollable region contains a horizontal or vertical scroll bar
so that you can scroll horizontally or vertically to view additional fields
hidden in the region.  In addition, if a field is partially hidden you can
scroll the region to fully display the field by clicking on the partially
hidden field.

Record

A record is one occurrence of data stored in all the fields of a block.  A
record is also referred to as a row or a transaction, since one record
either corresponds to one row of data in a database table or one logical
transaction.

The Submit Request window is an example of a single–record block.  To
view the next record of information, use the down arrows on your
keyboard.  The up arrow takes you to the previous record.

The Requests window, by contrast, displays up to ten records of
information simultaneously, with each record representing a request
submitted from the Submit Request window.  The Requests window
contains fields arranged on the screen horizontally adjacent to each
other, leaving enough space in the window to display up to ten records
of information beneath the field headings.  The Requests window is an
example of a multi–record block.

The fields in a multi–record block appear as columns.  You can use the
vertical scroll bar located to the left of the first column to view any
additional records hidden in that block.



2 – 9Oracle Applications User Interface Basics

Current Record Indicator

Multi–record blocks often display a current record indicator to the left of
each record.  A current record indicator is a one character field that
when filled in, identifies a record as being the current or ”active”
record.

Sometimes, a current record indicator appears as a two character–wide
field, indicating that the current multi–record block supports a
capability called drill–down.  Drill–down lets you click on a current
record indicator to navigate directly to another window that displays
either details of the current record or information related to the current
record.  See: Combination Block: page 2 – 14.

Message Line

The message line near the bottom of the Oracle Applications window
displays helpful hints or messages when you encounter a minor error.
See: Interpreting Messages: page 2 – 21.

Status Line

Figure 2 – 1
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The status line appearing below the message line of a Oracle
Applications window displays status information about the current
window or field.  A status line can contain the following:

• Record: 1/3—this example indicates that the current record is one
of three records in the current block.  If an undetermined number
of records have been retrieved, the message will appear as 1/?.

• Enter–Query—this phrase indicates that the current block is in
Enter Query mode, so that you can specify search criteria for a
query.

• List of Values—this lamp appears when a list of values is
available for the current field.

See Also

Using a List of Values: page 3 – 9

Searching for Information: page 3 – 19

Toolbar

The toolbar is a collection of iconic buttons, where each button performs
a specific action when you choose it.  Each toolbar button replicates a
commonly–used menu item.  Depending on the context of the current
field or window, a toolbar button can be enabled or disabled.  You can
display help for an enabled toolbar button by holding your mouse over
the button.

The toolbar buttons and the actions they perform are as follows:

The New icon opens a new record in the active form.

The Find... icon displays the Find window to retrieve records.

The Show Navigator icon displays the Navigator window.
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The Save icon saves any pending changes in the active form.

The Next Step icon updates the Process workflow in the Navigator
by advancing to the next step in the process.

The Print... icon prints the current screen that the cursor is in.  In
some cases it may print a report associated with the current data.

The Close Form icon closes all windows of the current form.

The Cut icon cuts the current selection to the clipboard.

The Copy icon copies current selection to the clipboard.

The Paste icon pastes from the clipboard into the current field.

The Clear Record icon erases the current record from the window.

The Delete icon deletes the current record from the database.

The Edit Field... icon displays the Editor window for the current
field.

The Zoom icon invokes customer–defined Zoom (drill–down
behavior).

The Translations... icon invokes the Translations window.

The Attachments... icon invokes the Attachments window.  If one
or more attachments already exist, the icon changes to a paper clip
on a piece of paper.

The Folder Tools icon displays the folder tool palette.

The Window Help – icon displays help for the current window.
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Tabbed Regions

A tabbed region is one of a collection of regions that occupy the same
space in a window where only one region can be displayed at any time.
Each tab displayed in a window represents a different region.  You can
view a tabbed region by clicking on the tab displaying the name that
represents it.  The region updates to display the fields of the tab region
you choose.

Master–Detail Relations

A Master–Detail relation is an association between two blocks—a master
block and its detail block.  An example is the relationship between the
Batch and Journals windows in your Oracle General Ledger
application.  Each batch (master record) is associated with a set of
journal entries (detail records).

When two blocks are linked by a master–detail relation:

• the detail block displays only those records that are associated
with the current (master) record in the master block

• querying between the two blocks is always coordinated

• usually you cannot enter information in the detail window until
you have selected a master record.

For example, when you display a different record in a master block, the
detail block displays the detail record(s) that correspond to the new
master record.  Similarly, if you perform a search in a master block, the
detail block displays the detail record(s) associated with the master
record that was retrieved from the search.

Master and detail blocks can often appear in the same window or they
can each appear in separate windows.  When in separate windows an
unlabeled coordination check box appears in the upper right corner of the
detail block window.  This check box lets you decide whether to
constantly update the coordination of records between a master and a
detail window when the detail window is open in the background.
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Figure 2 – 2

For example, suppose you have a master and a detail window, and the
detail window displays records that pertain to the current record in the
master window.  If you uncheck the coordination check box and then
display another record in the master window, the detail window clears
itself and does not display any data until you move your cursor into
the detail window.  At that point, it displays the detail record(s) that
match the current master record.  If you check the coordination check
box and display another record in the master window, the detail
window automatically refreshes to display the detail record(s) that
match the current master record.

Note:  When you first open a detail window or when you
query a new record in the master window, the detail window
always updates to display the detail record that matches the
current master record regardless of whether the coordination
check box is checked or unchecked.

Drill–Down Indicators

When a record or field provides the drill–down capability, it lets you
navigate directly to another window that displays details of the current
record or field, or information related to the current record or field.

Records that provide drill–down are indicated by a wide width current
record indicator.  By double–clicking on the indicator you will navigate
to the detail window.
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Combination Blocks

Although a multi–record block shows you several records at once, it
usually does so at the expense of showing you fewer fields for each
record or only having some of the fields visible simultaneously.  A
combination block gives you the benefits of both multi–record and
single–record blocks by displaying the fields of a record in both
multi–record (summary) and single–record (detail) formats.  Each
format appears in its own separate window that you can easily
navigate between.

When you first navigate to a combination block, a summary window
appears.  You can select a record in the summary window and choose
Summary/Detail from the View menu to display the detail window for
that record.  This menu item lets you switch back and forth between
the two windows which are always coordinated to show the same
record.

You can also drill down from the summary window to the detail
window for a record by clicking on the record’s current record
indicator.  To return to the summary window, simply choose the
Summary/Detail menu item.  See: Current Record Indicator: page
2 – 9.
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Navigating in Oracle Applications

To accomplish a business task in Oracle Applications, you need to
know how to navigate around Oracle Applications.  There are several
types of navigation you can perform.  You can navigate:

• within a window

• between windows

• to another form

• to a custom form

Navigating Within a Window

� To navigate within a window:

� Choose one of the following three methods:

• move the cursor with your mouse

• choose an appropriate menu item

• enter an appropriate keyboard shortcut

The table below illustrates the default menu and keyboard shortcut
methods you can use to navigate around the records, fields, and blocks
of an Oracle Applications window.

Window Navigation Functions

Function
Type Function Menu Item Keyboard Shortcut

Record View Previous [Up Arrow]

Record View Next [Down Arrow]

Record View First View–>Record–>First

Table 2 – 1   (Page 1 of 2) 
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Keyboard ShortcutMenu ItemFunction
Function
Type

Record View Last View–>Record–>Last

Field Go to Previous [Shift]–[Tab]

Field Go to Next [Tab]

Field Go to Next (From a
Multi–Line Text Item)

[Ctrl]–[tab]

Block View Previous View–>Block–>Previous [Ctrl]–[Page Up]

Block View Next View–>Block–>Next [Ctrl]–[Page Down]

Table 2 – 1   (Page 2 of 2) 

Note:  You can navigate to a display only field using your
mouse.

Note:  The keyboard shortcuts mappings outlined in the
Window Navigation Functions table are the default mappings
and may be different if your System Administrator modifies
your Oracle Terminal Settings.

Suggestion:  You can choose Next or Previous from the
View–>Block menu to help you distinguish between the blocks
and regions in a window, since blocks and regions can have a
similar appearance.

Suggestion:  If you are working in a window and accidentally
press a wrong key or button that prevents you from further
navigation, you can choose Clear–>Record from the Edit menu,
to undo your changes in the window and begin again.

Attention:  Whereas [Tab] moves you between fields, pressing
[Enter] selects the default button in the window (if there is a
default).  If you try using [Enter] to navigate between fields,
you may unintentionally activate the default button.

Attention:  If a large number (more than 100) records are
queried, View–>Record–>Last will retrieve 100 records then
open a decision window prompting you to either:

Stop – Displays the last record of the records retrieved.

Continue to End – Retreives all records queried and displays
the last record of the query.
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Continue – Retreives the next 100 records and repeats the
decision window unless all records have been retrieved.  If all
records have been retrieved then the last record will be
displayed

Navigating Between Windows

In a GUI environment, you can navigate between the windows of an
application by simply choosing a specific window with your mouse.
This, however, can be inconvenient if you have many overlapping
windows where you have to move or close one or more windows
before you can find the window of interest.

� To navigate between the open windows of an application:

� Click on the desired window.

� Choose the name of the window you want to navigate to from the
Window menu.

The Window menu automatically lists all the titles of the windows
that are currently open in Oracle Applications.

Navigating to Another Form

To open another form in your application use the Navigate window.
The Navigate window is always available during a session.

� To navigate to another form in an application:

� If the Navigate window is hidden behind another window or is
minimized, choose Show Navigator from the View menu or
Navigator from the Window menu.

See Also

Opening a Form From the Navigate Window: page 1 – 15
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Navigating to a Custom–Defined Form

You can create a custom form to use with Oracle Applications and
define a zoom that takes you from a specific Oracle Applications form
or window to your custom form.

Note:  This entry is only enabled if you have coded a zoom for
the current form or block.

� To zoom to a custom form:

� Choose Zoom from the View menu.

See Also

Zoom: page 2 – 22
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Using Window Functions

As you use Oracle Applications, you may find a need to perform any of
the following miscellaneous window functions:

• printing a window

• saving your work

• closing multiple windows

Printing a Window

You can print an image of a current window at any time.

� To print a current window:

1. Choose Print... from the File menu.

2. A consecutive series of modal windows appear.  In general, the
windows prompt you for information such as the printer to print
to, size of image to print, orientation to print, number of copies to
print, format to save the image to if you want to save it to a file,
and so on.  Enter the necessary information in these windows.

Refer to your Microsoft Windows documentation for information
on how to install printer drivers and define printers.

3. Another window appears that tells you Oracle Applications is
about to capture the image of your window and that you should
not move or obstruct the window you want to print.  Choose OK
and wait for the image capture to complete.

4. A final window appears to confirm that the image capture is
complete.  Choose OK.

Attention:  In some screens of Oracle Applications the Print...
action may display a dialog that allows you to print specific reports
in addition to the current window.

Saving Your Work

When you save your work, Oracle Applications updates the underlying
database with the work you have done and then informs you that the
transaction is complete.  Saving your work is sometimes referred to as
saving a change or a transaction.
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Oracle Applications always validates your work upon saving it.  If any
of the data you enter is invalid or missing, Oracle Applications
provides you with a message describing the problem and does not save
your work.

� To save your work:

� Choose Save from the File menu.

� To save your work and update the process in the navigator:

� Choose Save and Proceed from the File menu to save any changes
you have made to the current window(s) and advance the current
position indicator for the process in the navigator.

Closing a Form

� To close a form:

• Choose Close Form from the File menu.

• Check Close Other Forms in the Navigate window and navigate
to another form.

• Choose Close from the control menu for that window.

• Exit the application by choosing Exit Oracle Applications from
the File menu.

Note:  When you close the initial window of a form, all of it’s
related windows close also.
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Interpreting Messages

When your application needs to give you a hint or a basic error (such
as the current field is not updatable) it displays a short message in the
message line located at the bottom of the applications window.

When your application needs to inform you of something more
significant (such as you entered fewer than five characters when
changing your password) it displays an error dialog.  Choose OK to
close the error dialog.

A Details... button may also appear in the error window if an error of a
more serious nature occurs.  Choose Details... to view more details
about the current error and about recent errors you got in other error
windows.  Your application saves a history of your five most recent
error messages and displays them when you choose Details....

Note:  After you view you error history, the next error will start
a new blank history list.  It also clears previous messages when
you change your responsibility.

Attention:  Often, messages and errors are preceded by a
message or error code.  Codes that contain the preface FRM–
arise from Oracle Forms, the underlying product that provides
Oracle Applications with its graphical user interface.  Codes
that contain the preface ORA– arise from the Oracle database.
Codes that contain the preface APP– arise from Oracle
Applications.  These codes help your system administrator or
Oracle Customer Support expert diagnose the errors you may
encounter.
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Linked Forms

In certain cases, it is useful to be able to access one form directly from
another.  For example, it may be very convenient to be able to open the
Customers form directly from the Sales Orders form, to allow entry of
a new customer while creating a new order, or to view information
about a customer that has already been defined.  From within certain
forms you can open another form directly by using the Tools menu or,
depending on how Oracle Applications has been customized at your
site, by choosing Zoom from the View menu.

Tools Menu

In some Oracle Applications windows, related inquiry or entry forms
may be available from the Tools menu.  Depending on how many of
these related forms are linked, they may be available directly as entries
on the Tools menu or by choosing the Go To... entry from the Tools
menu.  Look in the Tools menu of the window you are in or check the
Reference Guide of the product you are using to see if the above
options are available.

Zoom

In certain cases, you may be able to access one form directly from
another by choosing Zoom from the View menu.  Oracle Applications
ship with no Zooms defined, and the Zoom entry on the View menu is
disabled.  When this feature is available and how it behaves are
determined by how Oracle Applications is customized at your site.
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Export

Use the Export feature to export records in a multi–row block to a
tabbed–delimited file which you can open in the application of your
choice.  Export always uses the records and format currently queried in
the form.  Thus, you can control the data to be exported using the
query functions of the form, such as Query Find.  Additionally, if you
are exporting from a Folder form, you can reorder columns in the form
or remove unwanted columns before you export.

� To start the export process:

1. Query the records you want to export.

Note:  To reduce the time required to export your records,
reduce the number of records returned by using explicit query
criteria.

2. Make sure that your cursor is in the Multi–row block that contains
the records to be exported.

3. If you are exporting information from a Folder form, you can use
the folder tools to reorder columns, select which columns to
display, and customize column prompts.  These customizations will
be maintained when you export the data.

4. Choose Export... from the File menu.

Exporting Large Numbers of Records

Export automatically selects all records currently retrieved, as well as
the remaining records associated with the current query.  If the records
retrieved exceed 100, you will be prompted to:

Limits the records available to be exported to those
already selected by the export process.  You will
then be prompted to either cancel the export, or
export only those records already selected.  The
number of records selected is included in the
decision window.

Allows the export process to select all records
retrieved in the form.  When all records retrieved
have been selected the export process will
automatically export the records.

Note:  We recommend that you do not use the export feature
for very large numbers of records, such as numbers that exceed

Stop

Continue to End
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1000, as this is time consuming, and uses significant machine
and network resources.

Will select the next 100 records.  When all records
retrieved have been selected the export process will
automatically export the records.  Otherwise, you
will continue to be prompted until all records are
selected or you choose Stop or Continue to End.

Continue
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Hierarchy Screen

The Hierarchy Screen contains an Object Navigator that allows you to
navigate through your flow data.  The following describes the elements
of the Menu Structure and Toolbar Structure.

Menu Structure

File Menu

Exits from the Object Navigator.

Prints the current hierarchy to a printer.

Edit Menu

Allows the user to set default color, font, and icon
settings for all nodes displayed within the Object
Navigator. (Refer to Sample Screen – Preferences
for more details)

Allows the user to assign color and icons to a
specific type of node. (Refer to Sample Screen –
Type Display for more details)

View Menu

Displays hierarchy in an Organizational Chart
style.  The parent node will start in the middle of
the screen.  Child nodes will branch out from
under the parent in a root–like fashion.

Displays hierarchy in a Microsoft Windows
Explorer style. The parent node will start from the
upper left corner of the screen. Child nodes will be
displayed below the parent and slightly indented
to the right.

Displays hierarchy in a hybrid style of Horizontal
and Vertical. The parent node will start in the
upper left corner of the screen. Child nodes will be

Exit

Print...

Preferences

Type Display

Horizontal

Vertical

Column
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displayed in a column to the right of the parent
node.

Allows the user to display or hide the toolbar.

Allows the user to display or hide the type of node
information for all nodes in the Hierarchy pane.

Help Menu

Allows the user to view html help on the Object
Navigator. The first help could be a “table of
contents” type page that gives the users an
overview of all the help topics available for the
Object Navigator.

Allows the User to view node information for any
selected node.

Allows the users to turn debug information on or
off. Currently, Object Navigator supports
debugging the values returned by from the
akquery engine. These values are displayed on a
screen. Similar support will be provided by the
new Object Navigator.

Allows the user to view the current version
number of the Object Navigator as well as other
miscellaneous information.

Toolbar Structure

Use the Printer icon to print the current hierarchy.

Use the Vertical Style icon to display nodes in a vertical tree–style
hierarchy.  The parent node will start from the upper left corner of the

Toolbar

Node Type

Using Object
Navigator

Selected Node
Descriptions

Debug
Information

About Object
Navigator
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screen.  Child nodes will be displayed below the parent and slightly
indented to the right.

Use the Org–Chart Style icon to display nodes in a horizontal
Organization Chart style.  The parent node will start in the middle of
the screen.  Child nodes will branch out from under the parent in a
root–like fashion.

Use the Interleaved Style icon allows to display nodes in a hybrid style
of Horizontal and Vertical.  The parent node will start in the upper left
corner of the screen.  Child nodes will be displayed in a column to the
right of the parent node.
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Entering and Querying
Data

his chapter discusses features that help you enter and query data
from Oracle Applications.  Specifically, this chapter describes how:

• To use editing functions

• To use a list of values to simplify your data entry

• To enter a date using the Calendar

• To search for information
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Using Editing Functions

To enter or update data in a form, you can use the following field and
record editing functions:

• cutting, copying, and pasting text

• clearing data

• duplicating data from a previous record

• creating and deleting records

• displaying a list of values for a field

• invoking a field editor

• getting information about a record

Many of these editing functions are listed on the Edit menu of the main
menu bar.

See Also

Edit Menu: page A – 3

Using a List of Values: page 3 – 9

Overview of Flexfields: page 5 – 2

Entering Data into Flexfields: page 5 – 10

Cutting, Copying, and Pasting Text in a Field

You can choose Cut, Copy, or Paste from the Edit menu to manipulate
data in fields.

� To cut, copy, and paste data in a field:

1. Select the data in a field.  You can either drag your mouse over the
data or double–click on the data to highlight and select it.  When
you tab to a text field the data is automatically selected and ready
to cut or copy.

2. Choose Cut or Copy from the Edit menu to cut or copy the selected
data.  Cut is only available if the field can be updated.

Note that Cut is like Copy, except Cut also removes the data from
the field.
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3. Move your cursor to another field, then choose Paste from the Edit
menu to paste the cut or copied data into the current field.

Clearing Data

You can clear data from the screen at almost any time.  The data you
clear is simply erased from the screen and not deleted from your
database.  Note however, that if the data is new and has never been
saved to the database, it will be lost permanently when you clear it
from the screen.

� To clear selected data from a field:

� Choose Clear, Field from the Edit menu.

Note that the data you clear from the field is not available for
pasting into another field.  Choose Cut from the Edit menu if you
want to paste the data elsewhere.

The Clear Field function is not available for fields that cannot be
updated.

� To clear a record of data:

� Choose Clear, Record from the Edit menu.

This action erases the values in all the fields of your current record
and returns your cursor to the first field of the prior record.

Suggestion:  If you are in a window that you do not want to
be in or you accidentally perform an unwanted action, you can
use Clear, Record from the Edit menu to clear the current
record and begin again.

� To clear data from the current block:

� Choose Clear, Block from the Edit menu.

When completed, this action returns your cursor to the first field in
the current block.  Note that if the current block is a multi–record
block, this action erases all records displayed in the block.  If any
changes are pending you will be asked for confirmation before the
records are erased.

Attention:  If you enter data in only some of the fields in a block or
window, you must first choose Clear, Record from the Edit menu to
clear the partial record before choosing Clear Form.
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� To clear all data from a form:

� Choose Clear, Form from the Edit menu.

After this action erases the data from all the fields of the current
form, it returns your cursor to the first field of the form.

Duplicating Data From a Previous Record

To save time during data entry, you can duplicate data from a previous
record if much of the data needs to be repeated in a new record.

� To copy a field value from the previous record:

1. Enter a new record or query an existing record in your form.

2. Navigate to the field whose value you want to duplicate in the new
record.

3. Choose Duplicate, Field Above from the Edit menu to copy the
field value from the previous record to the current record.

� To copy all field values from the previous record (when available):

1. Enter a new record or query an existing record in your form.

2. Choose New from the File menu to insert a new record after the
existing record.

3. Choose Duplicate, Record Above from the Edit menu.

Attention:  If your current block requires all records to be unique,
the Duplicate Record Above menu item may not duplicate those
fields that must be unique.

Also, the Duplicate, Field Above and Duplicate, Record Above
menu items are not available if there is no previous record, that is,
if you are currently on the first record of a block.

See Also

Saving Your Work: page 2 – 19

Searching for Information: page 3 – 19
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Creating and Deleting Records

You can enter new records in the database or delete existing records
from the database.

� To create a new record:

1. Choose New from the File menu.

When you select this menu item in a multi–record block, Oracle
Applications moves the current record down and inserts a new
blank row.  You add a new record simply by filling in this blank
row.

When you choose New Record in a single–record block, Oracle
Applications displays a blank record in the current block so you
can enter data for a new record.

2. When you finish entering the data for your new record, choose
Save or Save and Proceed from the File menu to save the record to
the database.

� To delete a record from the database:

1. Choose Delete from the Edit menu.

This action initially erases the current record from your screen, and
returns your cursor to the first field of the next record.

2. To actually delete the record from the database, choose Save or
Save and Proceed from the File menu.

Attention:  If you exit Oracle Applications without saving your
work, the record does not get deleted from the database.

Creating Translations for a Record

You can enter translated values for specific records in the database or
update existing records in the database.  You can identify windows
where translations are allowed by the enabled translation icon.

� To enter a translation for a record:

1. Select the record you wish to translate.

2. Choose the Translation icon from the Toolbar.
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This action opens the Translations window.  When you open the
translations window, the fields that can be translated are displayed
in a multi–record block as columns.  You may need to use the
scrollbar to see all of the columns.  Each row represents an installed
language version of the Applications.  The source language
represents the original language version of the applications used to
enter the data record.

3. Enter the translation for the appropriate fields.

4. Choose OK

Suggestion:  The translation method described above allows
you to enter translations for multiple languages at once. An
alternative translation method may be more effective if you
need to enter translations only for the language in which you
are working.  In this case, you can type the translation directly
into the field rather than clicking on the translation icon and
working in the translation window.

If you choose to enter a translation directly into a field, you
need to be aware of which fields are allowed to be translated. If
you type into a field that was not meant to be translated, you
will overwrite the source language, and your translation will be
the only entry for that field.  All users will see the data in the
language you input, and the original language will be lost.  If
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you have any doubt about a field, click on the translation icon
to identify whether it is translatable.

Invoking an Editor for a Field

You can display an Editor window to view, enter, or update the entire
contents of a text field.  The Editor window is especially useful for
editing scrollable text fields.  A scrollable text field is a field whose
actual width is longer than its display width and whose content you
can view by scrolling through the field.

� To use the Editor window for a field:

1. Choose Edit Field... from the Edit menu.

2. Enter a new value or edit the existing value in the Editor window.

Attention:  If the current field is a display–only field, then the
Editor window does not allow changes.

3. To search for a phrase and replace it with another phrase, you can
choose Search in the Editor window to display a Search/Replace
window.

4. Enter a value in the Search for: field, and if you want to replace
that value with another value, enter a value in the Replace with:
field.

5. Choose Search to search for the value, or choose Replace or
Replace All to search for the value and replace the first occurrence
or all occurrences with your new value, respectively.

6. Choose Cancel to close the Search/Replace window.

7. When you are satisfied with the value in the Editor window, choose
OK to close the window and insert the value into the field.

Learning About a Record

You can always display information about a record that has been saved
before.  The information includes who created the record, the date of
creation, and the database table where the record resides.  You can also
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learn who last changed the record using Oracle Applications, the date
of change, and that user’s system logon and terminal information.

� To learn about the current record:

1. Choose Record History from the Help menu.

A window appears that shows you information about the current
record.

2. Choose OK to close the window.
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Using a List of Values

A list of values provides you with a powerful, easy–to–use data entry
method that increases your accuracy and productivity.  A list of values
makes data entry an easy task for novice users, and lets power users
enter correct data with a minimum number of keystrokes.

Oracle Applications tells you when a list of acceptable input values is
available for a field by displaying the LOV icon next to the current
field.  When you display a list, the values appear in a window with a
title that describes the contents.

Note:  The list that we describe here differs from the list
associated with a poplist field.  You identify a poplist field by
its special poplist icon.  You identify a text field containing a
list of values by the LOV icon displayed next to the field when
your cursor is in that text field.

Basic Business Needs

A list of values provides you with the features you need to satisfy the
following basic data entry needs:

• Enter data quickly and easily without having to memorize or
look up valid data for each field.  You can choose data from an
online list of acceptable input choices whenever you wish.

• Rely upon Oracle Applications to validate your input during
data entry.  When you enter incorrect data, you know right away
so that you can make appropriate corrections.

Major List Features

AutoSelection

A list of values offers a feature called AutoSelection that lets you
choose a valid value from the list with a single keystroke.  When you
display the list window, you can type the first character of the choice
you want in the window.  If only one choice begins with the character
you enter, AutsoSelection selects the choice, closes the list window, and
enters the value in the appropriate field.
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AutoReduction

In addition to AutoSelection, you can also use a feature called
AutoReduction to help you further simplify and accelerate your data
entry.  For example, you might want to shorten a list so that you only
have to scan a subset of values before choosing a final value.  Type in
the list window, the first character or characters of the subset you want.
If there are several values that match, AutoReduction shortens the list
to just those matching values.

To expand a reduced list of choices in a list window, simply press
[Backspace].  Just as AutoReduction incrementally reduces a list of
values as you enter additional character(s), pressing [Backspace]
incrementally expands a list.

Any time you reduce the list to a single entry, AutoSelection selects the
entry and enters it into the appropriate field for you.

List Search

You can use AutoReduction to reduce a list when you know the first
few characters of your choice.  If you do not know the initial characters
of your choice, but you do know that your choice contains a certain
word or set of characters, you can perform a list search to reduce the
list.

In the list window, enter any group of characters as search criterion in
the Find field and choose Find.  You can use wildcard characters such
as the percent sign [%], which represents any number of characters, or
an underline [_], which represents a single character, in your search
criterion.
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For example, the list window shown above lists available reports for
you to choose.  To reduce the above list to just those choices that begin
with the word “signon,” enter signon% in the Find field and click the
Find button.  A reduced list appears, displaying just those choices that
begin with the word “signon,” as shown below.
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Attention:  The phrase you enter for a list search is not
case–sensitive.

LongList

If a field has a longlist, that is, it typically has a list of more than 100
values, Oracle Applications displays the list window with no choices
listed, and includes the message ”Enter a partial value to limit the list,
% to see all values.”  An example is shown below.
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Since it takes less time to display a reduced list than a complete
longlist, Oracle Applications prompts you to enter the first few
characters that occur in your value of interest to reduce the complete
list.  The partial value you enter can also include wildcard characters.

If you have to view the entire longlist, you can enter % at the prompt to
display all the values.

Attention:  To avoid excessive network traffic and reduced
performance, try to enter criteria other than just ”%” whenever
possible.

Power List

Power list provides an even faster method of data entry.  If a field
displays a <List of Values> lamp and you know the value you want,
simply enter the first few characters of the value in the field and press



3 – 14 Oracle Applications User’s Guide

[Tab] to let Power list complete the entry for you.  You can also include
wildcard characters with the characters you enter.  You do not have to
display the list window.

If more than one value matches the characters you specify, a list
window containing those values appears.  If no values match the
characters you enter, an error message is displayed on the message line.

Choosing a Value from a List

When you display a list of values, you may notice that some list
windows display one column of information while others display
more.  All list windows, however, provide a descriptive heading at the
top of each column.  Below each heading is a list of choices.

� To choose a value from a list:

1. Click on the LOV icon next to the field to display a list of possible
values.

2. You can reduce the length of a list using one of two methods:

• Without clicking in the Find field, type the first character(s) of a
value to autoreduce the list to just those values in the first column
that match the characters you enter.  Press [Backspace] to undo
an autoreduction.  If you autoreduce the list to a single value, the
list window closes and inserts the final value in the current field.

• Search for a value in the first column of a list by clicking in the
Find field and then entering search criteria in the Find field and
choosing the Find button.  If the search finds a single value, the
list window closes and inserts the value in the field.  If the search
finds several values, you can perform a more specific search or
use one of the methods described in step 3 to choose a specific
value from the reduced list.

3. You can also choose a value directly from the list using one of three
methods:

• Use your mouse to scroll through the list and double–click on a
value to choose it.

• Use your mouse to scroll through the list and single–click on a
value and then press OK to choose it.
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• Move your cursor into the list window and press [Up Arrow] or
[Down Arrow] to select a value, and press [Return] to choose
the selected value.

4. Once you choose a value, the list window closes and inserts the
value into the current field.

5. If you want to close a list window without choosing a value, choose
Cancel.

Modifying a List

You define new values or delete existing values in a list by editing the
data in the form that stores the source of values for the list.  Consult the
reference guide for your Oracle Applications product to identify the
form that contains the source of values for a specific list.

For example, in your Oracle General Ledger application, the list of
values that appears in the Source field of the Suspense Accounts form
come from the journal source values entered in the Journal Sources
form.

Applying Standards to a List

To take full advantage of all Oracle Applications features, including a
list of values, remember the importance of standards.  For example,
you should follow consistent, helpful naming conventions when you
enter a value in a ”list source” field.  Where possible, use source values
whose initial letters are unique to best take advantage of Power list.
Similarly, develop names with memorable key words or groups of
characters to help simplify your search through a list window.
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Using the Calendar to Enter Dates

Use the calendar to enter a value.  If your date field also supports time,
you can also use the Calendar window to choose a valid time with the
date.

Basic Business Needs

The Calendar lets you satisfy the following business needs:

• Represent dates and time graphically so that you can make a
quick date and time selection without additional typing.

• Select only those dates or date ranges that are appropriate for the
current field.

Using the Calendar Window

When you navigate to a date field it displays an LOV icon. You can use
the Calendar window, as shown in Figure 3 – 1, to help you enter a
date.
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� To choose a date in the Calendar window:

1. When your cursor is in a date field, choose the List of Values... icon
to display the Calendar window.

The date value that appears below the calendar is called the selected
date.  If the current field already contains a date, that date appears
as the selected date, otherwise the selected date reflects a value
determined by the current field or by the current system date.

2. To display the next or previous month, click on the right arrow or
left arrow buttons in the upper left corner of the window,
respectively.  You can also press [Down arrow] or [Up arrow] on
your keyboard to display the next or previous month.

The days of the displayed month appear with bold text, while the
days of the previous and next months appear with light text.

3. To display the next or previous year, click on the right arrow or left
arrow button in the upper right corner of the window, respectively.
You can also press [Next Record] or [Previous Record] on your
keyboard to display the next or previous year, respectively.

Suggestion:  To quickly display the current month and year in
the calendar, click on the month and year display located above
the calendar.

4. Click on a date to choose a day.

The day you select appears in a box.

Attention:  Disabled buttons that show dimmed text represent
invalid days.  You cannot choose an invalid day.  Similarly, if a date
field is display–only, you can display the Calendar window for the
field, but you cannot change the date shown on the calendar.  The
Cancel button is only shown if you can change the date value.

5. Choose OK to accept the selected date and close the window.
Choose Cancel if you want to close the window without choosing a
date.

� To choose a date and time in the Calendar window:

1. Follow steps 1 through 4 in the section above to choose a date.  If
the current field supports both date and time, the Calendar
window includes additional time items.  Hour and Minute poplists
are displayed at the bottom of the window, with AM and PM
option buttons, as shown in Figure 3 – 2.



Figure 3 – 2
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2. Select the hour poplist icon to choose an hour between 1 and 12.

3. Select the minute poplist icon to choose a minute value.  The
minute poplist displays twelve values between 00 to 55 at 5 minute
increments.

Attention:  If a value already exists in the current date and time
field when you display the Calendar window, and the minute value
is not a 5 minute increment, then the minute poplist displays
thirteen values to include the minute value displayed in the field.

For example, if the current field displays the time 13:16:00, then the
minute poplist includes the twelve values from 00 to 55 at 5 minute
increments plus the value 16.

4. Choose AM or PM.

5. Choose OK to accept the selected date and time and close the
window.  Choose Cancel if you want to close the window without
choosing a date and time.
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Searching for Information

Oracle Applications provides you with easy–to–use search capabilities
to access application information.  You can quickly retrieve and review
all available information in your database without having to remember
the information displayed in windows, or print lengthy reports to see
the data.  Instead, you can simply run a search to obtain the
information you want and review the data online in the same window
used to enter the data.

This section describes the two methods you can use to search and
retrieve records in a window:

• Query Find

• Query–by–example

In addition, this section also describes a type of window that lets you
immediately query records for review or editing:

• Direct entry windows

Note:  We use the words search and query interchangeably to
describe the retrieval of records.

Note:  Some windows cannot be searched because they display
only run–time output or they can only be used to submit or run
specific processes.  An example is the Run Requests window.
Your application displays a helpful message in the message line
if you attempt to search in such a window.

See Also

Overview of Flexfields: page 5 – 2

Searching for Data Using Flexfield Criteria: page 5 – 21

Basic Business Needs

Oracle Applications lets you satisfy the following basic information
search needs:

• Have instant, online access to all of your application information.
You can find information quickly and easily, without having to
use a complex query language.

• Search for a specific record or for a group of records based on
criteria you enter before executing the search.  You can retrieve
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this information directly, without having to review all the
information in your application database.

• Search for information using criteria of different types or lengths,
including a single letter, a single word, a group of characters, or
anything else you wish to enter.

• Find out how much information is available that matches your
search criteria before running the search.  Otherwise, you might
waste both computer time and your time should your search for
a single piece of information yield 10,000 responses.  This feature
is available only when using query–by–example.

Using Query Find

If you want to query for records in your current block or window, the
simplest way to proceed is to use Query Find.  Query Find displays a
window that lets you specify search criteria.  Depending on the block
that you invoke Query Find from, one of two types of windows
appears:

• A Find window that contains fields for entering search criteria.
These fields are specific to the current block and often validate
the search criteria you enter against a list of valid values.

An example is the Find Requests window, shown below.  This
window gives you the option of finding your completed
requests, your requests in progress, all your requests, or specific
requests.  If you choose Specific Requests, you are given
additional selection options, such as Request ID and Name.  This
window also provides a poplist for you to select a sort order.
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• A list window, as shown in Figure 3 – 4, that shows all the
possible records that you can retrieve for the block.  The example
shows the Find Key Flexfield list window.
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Generally, a Find window appears for those blocks that display
multiple records.  A list window generally appears for those blocks that
display one record at a time.

� To use Query Find:

1. Choose Find... from the View menu.

2. If a list window appears, select the record you want to retrieve and
choose OK to retrieve the record into your current block.

3. If a Find window appears, enter your search criteria in the
appropriate fields.

If a field does not provide a list of values for you to choose from,
you may enter wildcard characters in the search phrase.  You
cannot, however, use query operators (such as >, <, etc.) in a Find
window.

4. Choose OK to find any matching records.

Performing Query–by–Example and Query Count

If you want to retrieve a group of records based on more sophisticated
search criteria than what Query Find allows, you can use a feature
called query–by–example.  As an expert user you can use
query–by–example to specify complex search criteria in any of the
queryable fields in your current block.  Queryable fields are displayed
with a green background when you envoke query–by–example.  The
search criteria can include specific values, phrases containing wildcard
characters, and/or phrases containing query operators to help you
pinpoint the data of interest.

In addition, if you do not actually need to retrieve the records from a
query–by–example search, but only want to know how many records
match your search criteria, you can perform a query count to save
yourself some time.

Matching Exact Values

In some cases you want to search for information that matches exact
values in one or more fields.  For example, suppose you want to search
for a budget named FY90 in the Define Budget window of your Oracle
General Ledger application.  Simply enter the value FY90 in the Name
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field.  You should be precise in your use of uppercase and lowercase,
since “fy90” is not always equivalent to “FY90” in query–by–example
mode (some fields may not have case–insensitive query).

Finding Patterns With Wildcards

Include wildcard characters in your search criteria to search for
particular patterns in your data.  You can use the percent ’%’ wildcard
within a field to represent any number of characters (including no
characters), or use the underline ’_’ wildcard to represent any single
character.  For example, if you want to retrieve all records that contain
the word “Central” in a specific field, you would enter the search
criterion %Central% in that field.

Using Query Operators

Use query operators in your search criteria to restrict your search to the
information you need.  The query operators you can use in most fields,
their meanings, and example expressions are shown in the following
table:

Query Operators

Operator Meaning Example Expression

= equals = ’Janet’,    = 107

!= is not != ’Bob’,     = 109

> greater than > 99.1,       > ’01–JAN–93’

>= at least >= 55

< less than < 1000.00

<= at most <= 100

#BETWEEN between two values #BETWEEN 1 AND 1000

Table 3 – 1  Query Operators (Page 1 of 1) 

Attention:  If your field contains character or date values and
you are using operators, you must enclose the character or date
value in your expression in single quotes as shown in the above
examples.

Attention:  You cannot use query operators on time fields.
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Attention:  When you use the #BETWEEN query operator, the
search criterion “#BETWEEN value1 AND value2”  retrieves all
records containing values between and including value1 and
value2.  For example, the search criterion ”#BETWEEN
’01–JAN–93’ AND ’01–MAR–93’” entered in a date field
retrieves all records with dates between and including
01–JAN–93 and 01–MAR–93.

The query operator expressions retrieve results according to character
ordering rules for character fields and numeric ordering rules for
numeric fields.  For example, suppose you have the following field
values:

002, 003, 004, 005, 078, 123,
253, 441, 576, 775, 1274, 3298,
4451, 5600, 9578, 10500, 58437, 70845

These values are shown in the order you expect for numeric values,
where 005 is between 004 and 078.  If the field is defined as a numeric
field, then the phrase “#BETWEEN 004 AND 078” would retrieve 004,
005, and 078.  However, if the field is a defined as a character field,
then the phrase “#BETWEEN 4 AND 7” would retrieve the values 441,
576, 4451, 5600, and 58437, which all start with characters between 4
and 7.  The values 775 and 005 would not appear because 775 is
lexically greater than 7, and 0 is lexically less than 4.

Some fields contain date values that are actually “Date–format”
character values.  These fields behave like character fields, such that the
value 01–FEB–92 would be lexically less than 01–JAN–92, because F
precedes J in a character set.

Sometimes you cannot instantly tell if a field containing numeric values
is defined as a character or numeric field.  To identify what the field
type is, you may have to enter and experiment with different search
criteria expressions to see what results get returned.

� To use query–by–example:

1. Choose Enter from the View, Query by Example menu.

This action switches your window from data entry mode to Enter
Query mode, as indicated by the Enter Query message that appears
in the status line.

2. Enter search criteria in any of the fields, using wildcard characters
and/or query operators as necessary.  You can also choose Show
Last Criteria from the View, Query by Example menu to display
the search criteria used in your last search if there was one.
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Attention:  In Enter Query mode, all check boxes are in a null
state; that is, they are neither checked nor unchecked, although
they may appear checked or unchecked as a default.  If you want
your search criteria to include a checked check box, you have to
explicitly check it, regardless of whether it initially appears to be
checked.  Similarly, if you want your search criteria to include an
unchecked check box, you have to explicitly uncheck it, regardless
of what it initially appears as.

3. Choose Run from the View, Query by Example menu to perform
the search.

Attention:  To retrieve all the database records for a block, you can
bypass 1 and 2 and simply choose Run from the View, Query by
Example menu.  This is referred to as a blind query.  You can also
retrieve all the records for a block by choosing Find All from the
View, Query by Example menu.

4. Choose Cancel from the View, Query by Example menu if you
want to cancel from Enter Query mode.

� To obtain a query count:

1. Perform steps 1 and 2 above.

2. Choose Count Matching Records from the View, Query by
Example menu to display on the message line the number of
records query–by–example would retrieve if you ran the search.

Attention:  If you simply choose Count Matching Records from
the View, Query by Example menu without specifying any search
criteria in a block, query count displays the total number of records
in the database for that block.

See Also

Using Query Find: page 3 – 20

Reviewing Records

After you perform a search, Oracle Applications retrieves any records
that match your search criteria.  The status line shows a count of the
number of retrieved records currently displayed in the block and may
also display a question mark (?) if there are more retrieved records not
yet shown.
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� To review retrieved records:

1. If the status line indicates that there are additional records with
either a number other that one or a question mark (?), press the
[Down arrow] key to display the next retrieved record.

2. Press the [Up arrow] key to see a previous record.

3. Use First or Last from the View, Record menu to move the cursor
to either the first or last record in the block.

4. In multi–row blocks you can use the scroll bar to view additional
records currently not visible on the screen.

Using a Direct Entry Window to Retrieve a Record

Some Oracle Applications products use special windows called direct
entry windows to help you retrieve records of interest.  A direct entry
window consists of a master block and a detail block with a Find
button on the master block.

� To retrieve records in a direct entry window:

1. Enter values in the fields of the master block by using the list of
values associated with each field.

2. Choose the Find button in that window to retrieve all the detail
records that correspond to the values you enter in the master block.

Selecting Multiple Records

Some Oracle Applications enable you to take an action on several
records at once.  These records are presented in a multi–record block
where you must specify which records will be affected.  When a record
is selected, the background color changes to pale blue.  In addition, the
number of records selected is indicated in the action buttons which act
on all selected rows.  Buttons which act only on the current row do not
display the number of records.  For example, the Open button which
only opens the current record regardless of your selections does not
include this number.

Note:  If no records are selected using the following methods
the current record is used as the selected record.  Once another
record is explicitly selected the current record is not considered
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selected unless it too is selected using one of the following
methods.

� To select multiple records:

1. While holding down the Ctrl key, click on each desired record.

� To select a range of records:

1. Click on the first record of the desired range.

2. Hold the Shift key down and click on the last record of the desired
range with your mouse to highlight the selected range.

� To select all records:

1. Choose Select All from the Edit menu.

� To deselect all records:

1. Choose Deselect All from the Edit menu.

� To deselect a single record:

1. While holding down the Ctrl key, click on each record you wish to
omit.
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Customizing the
Presentation of Data

his chapter discusses how you can customize the layout of your
data in a folder block.
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Customizing the Presentation of Data in a Folder

A folder block is a special block whose field and record layout you can
customize.  The following helps you distinguish a folder block from a
regular block:

• An Open Folder button appears in the upper left corner of a
folder block.

• An enabled Folder Tools button appears on the toolbar when
your cursor is in a folder block.

• An enabled Folder menu appears in the main menu bar when
your cursor is in a folder block.

You can customize a folder block to retrieve just a subset of records and
display those records in a different layout.  You can save your
customizations as a folder which defines the layout of your fields and
the query criteria used to retrieve your subset of records.

When you first install Oracle Applications and navigate to a folder
block, what you see is the original default folder definition or a folder
defined by your system administrator.  You can modify this default
folder definition and save your customizations to be the new default.
You can distinguish a custom default folder definition from the original
default folder definition because a custom default folder definition
always displays its name next to the Open Folder button.

Attention:  If your system administrator sets the profile option
Folders: Allow Customization to No, you cannot create or
customize folders.  The only item available from the Folder
menu is Open, to open a predefined folder.

Note:  With the addition of multi–language support, folders are
associated with specific languages.  Existing folders are
associated with the base language of the Site and new folders
are associated with the language used when the folder is
created.  Folders can only be accessed when the Applications
are running in the same language that is associated with the
folder. For example, a folder created in the French version of
Applications cannot be accessed when running the
Applications in German.

This section teaches you how to use folders to present the data you
want and in particular, shows you how to:

• use the folder tools

• query records in a folder block
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• customize the layout of a folder block

• manage folder definitions

See Also

Folder Menu: page A – 5

Basic Business Needs

A folder block lets you satisfy the following basic customization needs:

• Display only those fields that are of interest to you.

• Instantly modify the width, sequence, and prompts of the fields
you want to display.

• Display a subset of records based on your specific criteria.

• Display records in a specific order.

• Save your folder customizations for later use.

• Automatically query for a subset of records each time you open a
specific folder.

• Keep your folder customizations private or make them public for
others to access.

• Make your customizations the default layout for a folder block.

Using Folder Tools

When you navigate to a folder block, the Folder Tools button gets
enabled on the toolbar.  Choose this button to display the folder tools
palette on your screen.  The folder tools include the following buttons
that replicate the actions of some commonly used Folder menu items:

• Open Folder—open another folder.

• Save Folder—save the current folder.

• Create New Folder—create a new folder.
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• Delete Folder—delete an existing folder.

• Widen Field—increase the width of a field. 

• Shrink Field—decrease the width of a field. 

• Show Field—show a currently undisplayed field.

• Hide Field—hide a currently displayed field.

• Move Left—swap the current field with the field to its left in a
multi–record block.  In a single–record block, move the current
field one character width to the left.

• Move Right—swap the current field with the field to its right in
a multi–record block.  In a single–record block, move the current
field one character width to the right.

• Move Up—move the current field up by one character height for
a single–record display.

• Move Down—move the current field down by one character
height for a single–record display.

See Also

Folder Menu: page A – 5

Querying Records in a Folder

One advantage of a folder block is that you can customize it to display
only the records you want to see.  You can easily alter the query criteria
for a folder and save that criteria with a folder.  You can also control
the sorting order of the records you display in a multi–record folder.

� To define query criteria for a folder:

1. Run the query you want, either by using Query Find or
query–by–example.

2. Choose Save As from the Folder menu if you want to save this
query criteria in a folder.
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3. Enter a name for the folder.

4. Select Always, Never, or Ask Each Time from the Autoquery
Option Group.  If you select:

The query will be automatically performed each
time you open the folder.

The query will be saved with the folder, but will
not automatically run when you open the folder.

You will be prompted when you open the folder to
decide if you would like the query to be performed
immediately.

5. Choose OK when you are done.

Attention:  When you save a folder, the query criteria gets “locked
in” to the folder.  When you perform another query on that same
folder, your new query will only be performed on the subset of
records retrieved by the folder.  If you want to perform a new
query–by–example on the complete set of records, you need to first
reset the query for the folder definition before performing another
query.

� To view the query criteria for a folder:

� Choose View Query from the Folder menu.

A window titled Folder Contents appears.  The window may
contain a SQL WHERE clause that defines the criteria used to
retrieve the subset of records displayed in the current folder.  An
empty window indicates that there is no special query criteria and
that the current folder retrieves all records for the folder entity.

� To reset the query criteria for a folder:

1. Choose Reset Query from the Folder menu.

This clears the WHERE clause from the current folder, but retains
the current folder name and its field layout.

2. Perform another query and choose Save from the Folder menu to
save the new query to your current folder.

� To alter the sorting order of data in a multi–record folder:

1. Choose Sort Data... from the Folder menu.

This menu item displays the Sort Data window that enables you to
set the sort option for the first three fields in the block.

Always

Never

Ask Each Time
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2. Choose a sort option for the fields you wish to sort:

• Ascending—sorts the column in ascending order

• Descending—sorts the column in descending order

• Unsorted—does not sort the column

These settings determine how the folder sorts the records it
displays.  The folder applies these settings from left to right when it
retrieves and sorts the records.

3. Choose OK.

� Example

� Suppose you want to create a folder definition called Unposted
Batches in the Enter Journals folder block of your Oracle General
Ledger application.  You want this folder definition to
automatically display unposted batch records.  First choose Show
Field... from the Folder menu to show the Batch Status field, if it is
not already displayed.  Next, choose Enter from the View > Query
by Example menu to perform a query–by–example.  Enter the
value Unposted in the Batch Status field, then choose Run from the
View > Query by Example menu to retrieve all unposted batch
records.

The following illustration shows the Enter Journals window with
only the unposted batches displayed.
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Choose Save or Save As... from the Folder menu to save this query
criteria and layout.  Enter a unique name to identify the folder.  Make
sure to set the Auto Query option group to the desired behavior.  You
can also choose View Query... from the Folder menu at any time to
display the WHERE clause for this query in the Folder Contents
window.

See Also

Folder Menu: page A – 5

Customizing the Layout of a Folder

The Folder menu and folder tools provide you with many options to
help you customize your folder layout.  Some of these tasks may also
be performed using your mouse directly on the fields you wish to
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change. You can change the width, sequence, prompts and the order of
the data of a field using your mouse.  For example, to change a prompt,
position your cursor over the prompt and click your right mouse
button.  This displays a dialog box for making your change.  To toggle
the sorting of a row from ascending to decesending or vice versa use
your left mouse button and click once on the prompt.

Note:  Some Folder menu items are not available when you are
in Enter Query mode.

� To show a hidden field:

1. Choose Show Field... from the Folder menu to display a list of
currently undisplayed fields.

2. Select a value from the list and choose OK to display the field in
the folder layout.

The new field is inserted after the current field, and the cursor
moves to the new field.

� To hide a field:

� Choose Hide Field from the Folder menu to remove the current
field from the folder layout.

Your cursor moves to the field sequenced after the field that was
removed.

� To move a field to the right:

� Choose Move Right from the Folder menu.

In a multi–record block, this swaps the position of the current field
with the field to its right.  In a single–record block, this moves the
current field one character–width to the right.

� To move a field to the left:

� Choose Move Left from the Folder menu.

In a multi–record block, this swaps the position of the current field
with the field to its left.  In a single–record block, this moves the
current field one character–width to the left.

� To move a field up in a single–record block:

� Choose Move Up from the Folder menu.
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This moves the current field one character–height up.

� To move a field down in a single–record block:

� Choose Move Down from the Folder menu.

This moves the current field one character–height down.

� To widen a field:

� Choose Widen Field from the Folder menu.

This increases the width of the current field by a 0.2 inch increment,
up to a maximum width of 20 inches.

� To shrink the width of a field:

� Choose Shrink Field from the Folder menu.

This decreases the width of the current field down to a minimum
width of 0.2 inches.

� To autosize all the fields of a folder:

� Choose Autosize All from the Folder menu.

Resizes displayed fields based on a sample of values for the field in
the block, ensuring that no field is smaller than the width of it’s
prompt.  The number of records (sample of values) is determined
by selecting one of three options: 10, 50, or 100 in the decision
window.

� To rename a field prompt:

1. Choose Change Prompt from the Folder menu.

2. Enter a new prompt name in the Alter Prompt window that
appears.

If you precede a prompt name with a hyphen, ‘–’,  and you choose
to show the field in the folder, the field appears without a prompt.

3. Choose Default if you wish to recover the original prompt name
for the field.

4. Choose OK when you are done.

Attention:  Shorten or abbreviate a prompt name rather than
change it altogether.  This ensures consistency with the similar



4 – 10 Oracle Applications User’s Guide

prompt names that appear in the non–folder windows of your
application.

See Also

Folder Menu: page A – 5

Using the Folder Tool Palette: page 4 – 3

Managing Folder Definitions

Once you learn to customize a folder block’s layout and query criteria,
you need to learn to save your customizations as a folder.  You can
create and save new folders, or open and delete existing folders.  When
you open a new folder, the layout for the new folder simply replaces
the layout for the current folder.

� To create a new folder:

1. Choose New from the Folder menu.

The Create New Folder window appears.

2. Enter a new folder name.

The name must be unique for the Oracle Applications sign–on you
use and for the entity that the folder represents.  For example, if
your folder queries employees working in the sales department of
Chicago, you could title your folder similar to ’Salereps – Chicago’

3. Check an Autoquery option:

• Always – automatically queries for a subset of records each time
you open the folder definition

• Never – does not query

• Ask each time – opens the decision box when the folder is
opened.  Choose Yes to query.

4. Check Open as Default if you want this specific folder definition to
open as your default each time you navigate to this folder for the
first time after invoking the form.

5. Check Public if you want other Oracle Applications users to have
access to this folder definition.  They can even use it as their default
folder, but only you can modify it.
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6. Choose OK when you are done.

The name that you assign to this folder appears in the upper left
corner of the folder block next to the Open Folder button,
whenever you open this folder.  The original default folder
definition provided with the product does not have a folder title
unless you save it with a new name.

� To recover the original default folder definition for a folder block:

Once you create a custom folder definition and make it the default, you
can recover the original default folder definition shipped with the
product by performing these steps.

1. Select Save As from the Folder menu when you are in the custom
default folder.

2. Uncheck Open as Default in the Save As window that appears.

3. Choose OK when you are done.

4. To display the original default folder definition, close and reopen
the form.

Attention:  If you like this original default folder, you should give
it a name and save it without making any changes before you
create any new folders.  This way, you can open the original folder
by choosing it from a list of predefined folders.

� To open another folder:

1. Choose Open from the Folder menu to load a predefined folder.
You can also press the Open Folder button located in the upper left
corner of the folder block.

2. Select a private or public folder from the list window that appears
and choose OK to replace the current folder with the new folder.

� To save changes to a folder:

1. Choose Save from the Folder menu to save any layout or query
changes made to the current folder or choose Save As from the
Folder menu to save the current folder under a new name.

2. If you choose Save As, complete the information requested in the
Save Folder window that appears and choose OK.

This window prompts you for the same information as the Create
New Folder window.
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Attention:  If you save a folder to “Open as Default”, then open
another folder and save that second folder also as “Open as
Default”, the second folder becomes the new default.

Attention:  If you modify a public folder in any way, saving it
makes it a private folder.  However, if you open and save a public
folder to “Open as Default” with no other changes, you merely
save a reference of that folder as a private default.

� To delete an existing folder:

1. Choose Delete from the Folder menu.

2. Select a folder from the list that appears and choose OK to delete
the folder.  You can only delete folders you have created.

If another user is referencing that folder definition as their ”Open
as Default” folder, that reference gets deleted as well.

See Also

Folder Menu: page A – 5

Using the Folder Tool Palette: page 4 – 3
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Using Flexfields

his chapter provides you with a conceptual overview of flexfields
and how to use them.  You learn about:

• The features of flexfields

• The differences between a key and a descriptive flexfield

• How to enter data into flexfields

• How to query data using flexfields
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Overview of Flexfields

A flexfield is a flexible data field that your organization can customize
to your business needs without programming.  Oracle Applications
uses two types of flexfields, key flexfields and descriptive flexfields.  A key
flexfield is a field you can customize to enter multi–segment values
such as part numbers, account numbers, and so on.  A descriptive
flexfield is a field you customize to enter additional information for
which your Oracle Applications product has not already provided a
field.

Basic Business Needs

Oracle Applications flexfields let you satisfy the following business
needs:

• Have “intelligent fields”—fields comprised of one or more
segments, where each segment has both a value and a meaning.

• Rely upon your application to validate the values or the
combination of values that you enter in intelligent fields.

• Have the structure of an intelligent field change depending on
data in your application.

• Capture additional information if you so choose.

• Customize data fields to your meet your business needs without
programming.

• Query intelligent fields for very specific information.

Definitions

Key Flexfields

A key flexfield is a field made up of segments, where each segment has
both a value and a meaning.  You can think of a key flexfield as an
“intelligent” field that your business can use to store information
represented as “codes.”

Most organizations use “codes” to identify general ledger accounts,
part numbers, and other business entities.  Each segment in the code
represents a characteristic of the entity.  For example, your organization
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may use the part number code “PAD–NR–YEL–8 1/2x14” to represent
a notepad that is narrow–ruled, yellow, and 8 1/2” by 14”.  But another
organization may identify the same notepad with the part number code
“PD–8x14–Y–NR”.  Although both codes represent the same part, they
each have a different segment structure that is meaningful only to the
organization using that code.

A key flexfield is flexible enough to let you use any code scheme you
want to describe an entity.  When your organization initially installs an
Oracle Applications product, your organization’s implementation team
customizes all the key flexfields in that product to use meaningful code
segments to describe each key flexfield entity.  Your organization
decides for each key flexfield, how many segments an entity has, what
each segment means, what values each segment can have, and what
each segment value means.  Your organization can also define rules
that govern what combination of segment values are valid
(cross–validation rules), or define dependencies among the segments.
The result is that your organization can use the codes it needs rather
than change its codes to meet someone else’s requirements.

The Accounting Flexfield in your Oracle Purchasing application is an
example of a key flexfield that identifies a unique chart of accounts.
One organization may choose to customize the Accounting Flexfield to
have three segments called Company, Department, and Account, while
another organization may choose to customize the flexfield to have five
segments called Company, Cost Center, Account, Sub–Account, and
Product, as shown in Figure 5 – 1 in the Charge Account column.

A key flexfield looks like any other field in a block.  You can simply
type into a key flexfield, the segment values you want and separate
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each segment with a character called a segment separator.  In
Figure 5 – 1, the designated segment separator for the Accounting
Flexfield is a period “.”.  Alternatively, you can open a flexfield
window for a key flexfield to display a separate field for each of its
segments.  Figure 5 – 2, shows the Operations Accounting Flex
window.  The flexfield segments, Company, Department, Account,
Sub–Account, and Product each has a field for data entry.

Combination of Segment Values

A combination of segment values, also known as a key flexfield code
combination, uniquely describes a business entity stored in a key
flexfield.  When you change the value of one or more segments in a key
flexfield, you change the combination of segment values.

Descriptive Flexfields

A descriptive flexfield gives you room to expand your forms, since
Oracle Applications cannot predict all the possible information you
may want to track.  Your organization can use descriptive flexfields to
capture additional information that is important and unique to your
business.

A descriptive flexfield appears in a block as a two character, unnamed
field enclosed in brackets.  Figure 5 – 3 shows the Enter Person window
of the Human Resources Application.  The flexfield appears at the
bottom right of the window.
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Figure 5 – 3

A descriptive flexfield window appears when you move your cursor
into a customized descriptive flexfield.  Figure 5 – 4 shows the
Additional Personal Details descriptive flexfield window.  Your
organization’s implementation team can customize a descriptive
flexfield to include as many additional fields as your organization
needs.  These fields, also called segments, appear in the descriptive
flexfield window.

Note:  We refer to the fields that appear in a customized
descriptive flexfield as segments even though they differ from
the segments that make up a single value in a key flexfield.

Each segment in a descriptive flexfield window has a name, and can
have a set of valid values.  Your organization can define dependencies



5 – 6 Oracle Applications User’s Guide

among the segments or customize a descriptive flexfield to display
context–sensitive segments, so that different segments appear
depending on the values you enter in other fields or segments.

As shown in the Additional Personal Details flexfield window in
Figure 5 – 4, your organization might customize the descriptive
flexfield to display fields that store more information about the
employee, such as Drivers License Number and Global ID.

Figure 5 – 4

Range Flexfield

A range flexfield is a variation of a key flexfield that allows you to input
a low and a high combination of segment values so that you can
express a range of key flexfield combinations.
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Structure

A structure is a specific configuration of flexfield segments.  If your
organization’s implementation team adds or removes segments, or
rearranges the order of segments in a flexfield, you get a different
structure.

Major Features

Flexfield Window

Both key and descriptive flexfields display flexfield windows.  A
flexfield window displays the segments of a flexfield as individual
fields with field prompts.

Choose the List of Values... icon or Edit Field... from the Edit menu to
display key flexfield windows.

Note:  Single segment key flexfields and range flexfields
display all of their segments in fields on the form and are
therefore not displayed in a flexfield window.

For a descriptive flexfield, you can define whether you want the
flexfield window to automatically appear when you navigate to a
customized descriptive flexfield.  If you set a user profile option called
Flexfields: Open Descr Window to No, the window does not open unless
you choose Edit Field... from the Edit menu.  If you set the user profile
option to Yes, a flexfield window automatically opens when you
navigate into a customized descriptive flexfield except in a folder.

Automatic Segment Validation

Some flexfields can validate the segment values that you enter against a
list of valid values.  If you enter an invalid segment value, a list
window appears so that you can choose a valid value from the list.

Automatic Segment Cross–Validation

A key flexfield can perform automatic cross–validation of segment
values according to rules your organization defines when it customizes
that key flexfield.  A cross–validation rule defines whether a value of a
particular segment can be combined with specific values of other
segments.  When you finish entering segment values in your key
flexfield window, your application checks to see if it is a valid
combination of values before it updates the database.  If you enter an
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invalid combination, a modal window appears with a message telling
you to choose a combination that is already defined.

Dynamic Insertion

Dynamic insertion allows you to create a combination of segment
values for a key flexfield without using a combinations form.  During
the implementation of a key flexfield, your organization can either
explicitly define a list of valid code combinations for the key flexfield
using a combinations form, or allow you to create valid combinations
as you enter values in the key flexfield for the first time on a form other
than the combinations form.  Your organization can also specify
cross–validation rules for a key flexfield so that you can only define
specific code combinations during dynamic insertion.

Multiple Flexfield Structures

In some applications, different users may need a different arrangement
of flexfield (key or descriptive) segments.  Or, you might want different
segments to appear in a flexfield depending upon, for example, the
value of another field.

Depending on the flexfield, your organization can define multiple
segment structures for the same flexfield.  The flexfield can display
different prompts and fields for different users based on a data
condition in a form or application database.

Your Oracle General Ledger application, for example, can provide
different Accounting Flexfield structures for users of different sets of
books.  The Oracle General Ledger application determines which
flexfield structure to use based on the value of a profile option called
GL Set of Books Name.

Shorthand Flexfield Entry

Shorthand flexfield entry lets you enter key flexfield data quickly using
alias names that represent valid flexfield combinations or patterns of
valid segment values.  Your organization can specify which key
flexfields use shorthand flexfield entry, and define shorthand aliases for
those key flexfields to represent complete or partial sets of key flexfield
segment values.  Once your organization customizes a key flexfield to
use shorthand flexfield entry, you can set the user profile option
Flexfields:Shorthand Entry to take advantage of this feature.



5 – 9Using Flexfields

Flexfield Value Security

Flexfield value security allows your organization to restrict the set of
key flexfield segment values you have access to during data entry.  The
security is based on a your responsibility and the access rules your
organization defines.

See Also

Entering Data in a Range Flexfield: page 5 – 17

Setting Your Personal User Profile: page 9 – 5
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Entering Data into Flexfields

Oracle Applications provides many aids to help you enter data into
descriptive and key flexfields.  This section describes how to enter data
in a:

• descriptive flexfield window

• key flexfield

• key flexfield window

• key flexfield using a shorthand alias

• range flexfield

Entering Data in a Descriptive Flexfield Window

You enter data into a customized descriptive flexfield by using its
flexfield window.  Figure 5 – 4 displays a customized descriptive
flexfield window.  Your organization can customize a descriptive
flexfield to display default values in any of the segments.

� To enter data in a descriptive flexfield:

1. Move your cursor into a customized descriptive flexfield to display
the flexfield window.  If your profile option Flexfield:Open Descr
Window is set to No or if you are in a folder, choose Edit Field...
from the Edit menu to open the flexfield window.

When the window appears, the cursor moves to the first segment
that does not contain a default value.

2. Enter a value in each segment.

Depending on how your organization customizes a descriptive
flexfield, you can either type a value into a segment, or if the <List>
lamp appears on the status line for a particular segment, you can
display a list of values to choose from for that segment.  See: Using
a List of Values: page 3 – 9.

3. If you wish to edit a default value, simply move your cursor into
the segment you wish to edit and type over the default value.

4. You can save yourself keystrokes when you enter segment values
by automatically skipping to the next segment as soon as you enter
a complete valid value into a current segment.  Simply set the
profile option Flexfields:AutoSkip to Yes.  Set the profile option to
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No if you want to manually navigate to the next segment after
entering a value.  See: Setting Your Personal User Profile: page 9 – 5

5. Choose OK when you are done to close the flexfield window.

The segment value(s) you enter are concatenated in the two
character descriptive flexfield display.  The concatenated segment
values in the descriptive flexfield are separated by a special
character called a segment separator that is specified in the
descriptive flexfield definition.

Note:  If you display a customized descriptive flexfield in a
folder definition, you are able to move the cursor into the
flexfield so you can use folder functions.  You cannot, however,
update or insert values directly into the descriptive flexfield;
you must use the descriptive flexfield window.

See Also

Customizing the Presentation of Data in a Folder: page 4 – 2

Entering Data Directly in a Key Flexfield

� To enter a known combination into a key flexfield:

1. Move your cursor into the key flexfield.

2. If you know the exact combination of segment values you want,
enter the concatenated combination directly into the key flexfield as
shown in Figure 5 – 1.

� To display a list of existing combinations:

1. Move your cursor into the key flexfield.

2. Choose the List of Values icon to open the Flexfield window.

3. Choose Combinations in the flexfield window to display the
existing combinations.

If there are several combinations you may be asked to enter values
for the segments to shorten the list.  To see all combinations enter
’%’ in one of the segment fields and choose OK.
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� To display a reduced list of existing combinations:

1. Move your cursor into the key flexfield.

2. Enter segment values directly into the key flexfield.  To specify
search criteria for a segment or part of a segment, use wildcards or
query operators.

You can use wildcard characters or query operators to enter inexact
concatenated combinations, also known as search phrases, directly
into a key flexfield.  See: Using Query Operators: page 3 – 23.

Attention:  When you enter a search phrase for a segment directly
into a key flexfield, the search phrase length should not exceed the
actual segment length.  For example, if a segment is two characters
long, you should only enter a two character search phrase.  You can
only use the query operators <, >, and =.  You cannot use  <=, >=,
<>, !=, or #BETWEEN in this case because these operators are
already two or more characters long, and are meaningless as search
phrases when used alone.

Note, however, that if you enter a search phrase in a key flexfield
window, you do not have to limit the length of the search phrase to
the segment length.

Also note that if the segments are character fields rather than
numeric, the search may not bring up the expected values.  See:
Using Query Operators: page 3 – 23.

Attention:  Make sure you use the correct designated character for
the segment separator in your concatenated combination.  If your
key flexfield uses “.” instead of “–” to separate segments, you
would enter a concatenated combination such as
01.130.410.12%.000.000 instead of 01–130–410–12%–000–000.  If you
enter the wrong character for the segment separator, the flexfield
interprets that character literally rather than as a segment
separator, and therefore assumes the combination you enter is just
the first segment.

Similarly, if you enter a partial phrase directly into a key flexfield,
and that phrase pertains only to the third segment, make sure you
include the appropriate wildcards and segment separator in the
phrase.  For example if you want to specify a partial phrase where
the third segment is 410 and all other segments are unknown, you
enter %.%.410, assuming the key flexfield uses a period (.) as a
segment separator.  Notice that even if the flexfield has more than
three segments, the remaining segments are assumed to have %
when the combinations list appears.
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3. Press [Tab] to bring up a reduced list of values matching your
specified search criteria.

Note:  If you enter an invalid value for one or more segments, the
Reduction Criteria for Long List window is displayed with your
search criteria filled in.  The first invalid value is highlighted
allowing you to enter a different value or use LOV for a list of valid
values.  Once a valid value is entered the next invalid value is
highlighted, and so on until all values are valid.

If you enter a valid search phrase but which matches no values, the
Reduction Criteria for Long List window is displayed with your
search criteria filled in.  You can then edit the search criteria
directly in the flexfield Reduction Criteria window.   See: Data
Entry in a Key Flexfield Window: page 5 – 13.

If you enter a partial valid combination without wildcard
characters directly in a multi–segment key flexfield, the Flexfield
Edit window appears with your partial combination filled in.  You
can then use this window to fill in the rest of the segments.  See:
Data Entry in a Key Flexfield Window: page 5 – 13.

In a single segment key flexfield, you cannot enter partial values
without wildcard or query operators.  If you enter an incomplete
value, a message will appear telling you to enter a value that is
defined.

Single Segment Key Flexfields and Longlist

Single segment key flexfields behavior changes from the multi–segment
case if the flexfield definition for the single segment key flexfield has
the Longlist argument.  The Longlist argument for a flexfield definition
can indicate that the flexfield does not have a very large number of
valid values.  If so, and the flexfield does not allow dynamic insert then
when you choose List of Values a window with a list of valid values
appears like in non–flexfield fields (you do not have to go through the
key flexfield Reduction Criteria window).  You can then choose a valid
value from the list and the value appears in the flexfield.  See: Longlist:
page 3 – 12.

Data Entry in a Key Flexfield Window

If you are not familiar with a key flexfield or you are not sure of the
combination of values to enter directly into a key flexfield, you can
display a key flexfield window to assist you with your data entry.
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• Edit window—choose Edit Field... or for multi–segment
flexfields choose the List of Values icon from the Edit menu to
display a key flexfield Edit window that lets you enter or edit a
combination of segment values.

Using a Key Flexfield Edit Window

When you choose Edit Field... from the Edit menu, a key flexfield Edit
window appears.  The example below shows the Operations
Accounting Flex window.  This particular flexfield edit window
contains the segment fields Company, Department, Account,
Sub–Account, and Product.

When you display a key flexfield Edit window, the name of the key
flexfield structure appears in the window title and you may see default
values in some of the segment fields.

In a key flexfield Edit window, you can manually type values into each
segment field, or display a list of values for the current segment if a
<List of Values> lamp appears in the status line for that segment.

You can also save yourself keystrokes when you enter segment values
by having the flexfield automatically skip to the next segment as soon
as you enter a complete valid value in a current segment.  Simply set
the profile option Flexfields:AutoSkip to Yes.  Set the profile option to
No if you want to manually navigate to the next segment after entering
a value.  See: Setting Your Personal User Profile: page 9 – 5.

If the combination of segment values that you want to enter is an
existing combination, but you are not sure of its exact value, you can

Figure 5 – 5



☞

5 – 15Using Flexfields

choose Combinations to search for that combination among the list of
existing combinations.  See: Using a Key Flexfield Reduction Criteria
Window: page 5 – 15.

When you are done with the key flexfield Edit window and choose OK,
the Edit window closes and displays the concatenated combination of
segment values in the key flexfield.

Attention:  If you navigate to a key flexfield that cannot be
updated the Combinations button is disabled.  This is to
reinforce that you cannot change the value in the key flexfield.

Using a Key Flexfield Reduction Criteria Window

When you choose Combinations, the following occurs depending on
the underlying segment structure of the key flexfield:

• If the key flexfield is a multi–segment flexfield, or a
single–segment flexfield that uses the longlist feature, a key
flexfield Reduction Criteria window appears.

• If the key flexfield has only one valid value, that value
automatically appears in the key flexfield.

A key flexfield Reduction Criteria window lets you query for an
existing combination of segment values to help you complete your data
entry in a key flexfield.  This window is useful when you know that the
combination you want to enter is a valid existing combination, but you
are not sure of its exact value.  Use this window to enter criteria that
helps locate the combination of segment values that is of interest to
you.

If you know the value for a particular segment, you can enter that
value manually or you can select that value from the segment’s list of
values.  If you are not sure of a segment’s value, you can either leave it
blank or you can enter a search phrase using wild card characters or
query operators.  See: Using Query Operators: page 3 – 23.

For example, suppose the combination of segment values you want
must satisfy the following criteria:

• Segment 1—is greater than 2

• Segment 2—is less than 0020

• Segment 3 and 4—unknown

You could specify this criteria in the key flexfield Reduction Criteria
window as:

• >’2’ – for Segment 1
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• <’0020’ – for Segment 2

• Leaving Segments 3 and 4 blank.

When you choose OK, the flexfield searches through all the existing
combinations of segment values for combinations that match and
displays the matches in a list.

After you select a valid combination from the list and choose OK, the
list window closes and the segment values appear in the window from
which you invoked your key flexfield Edit window.

Using Shorthand Aliases in a Key Flexfield

If your organization enables shorthand data entry for a key flexfield
and you set the user profile option Flexfield:Shorthand Entry to Yes, a
shorthand alias window appears for a key flexfield when you choose
Edit Field... from the Edit menu.  You can do one of the following in
that window:

• Enter an alias

• Display a list of valid aliases

• Cancel the shorthand alias window

Entering an Alias

If you enter an alias to represent a complete key flexfield combination,
your application automatically closes the shorthand alias window and
displays the equivalent concatenated segment values in the flexfield
display.  See: Shorthand Flexfield Entry: page 5 – 8.

If you want to force the key flexfield window to appear after the
shorthand alias window closes, you can set your user profile option
Flexfield:Show Full Value to Yes.  When you activate this user profile
option, the key flexfield Edit window automatically appears after you
enter a valid shorthand alias.  The default for this option is No.  See:
Setting Your Personal User Profile: page 9 – 5.

If you enter an alias that represents a partial key flexfield value, your
application displays the key flexfield Edit window and inserts the
partial values into the appropriate segment fields, positioning the
cursor on the first segment field that does not have a value.
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If you enter an invalid alias, your application displays a list of valid
aliases for you to select from.

Choosing a Valid Alias from a List

If you do not know what alias to enter in a shorthand alias window,
you can display a list of valid aliases by choosing the List of Values
button.

Canceling the Shorthand Alias Window

You may bypass shorthand flexfield data entry by choosing OK or
Cancel in the shorthand alias window without entering a value.  The
key flexfield Edit window appears instead, containing separate
prompts and fields for each of the key flexfield segments.

Entering Data in a Range Flexfield

A range flexfield allows you to input a low and a high combination of
segment values to express a range of key flexfield combinations.  Your
Oracle General Ledger application illustrates how you can use a range
flexfield.  The Accounting Flexfield Ranges block of the Define Budget
Organization form contains a range flexfield called Accounting
Flexfield, as shown in Figure 5 – 6.  This range flexfield is actually
based on the Accounting Flexfield key flexfield.
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This range flexfield requires you to enter a low and a high combination
of segment values to specify the Accounting Flexfield range you want
to include in a budget organization.  To enter a value in a range
flexfield, just move your cursor into the first key flexfield of the range
flexfield.  In this example, it is the field labeled Low.  A range flexfield
window displays, as shown in Figure 5 – 7.



Figure 5 – 7
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Notice that this window displays a Low column and a High column of
fields for each segment so that you can enter a low and a high value to
express a range.  If the segment contains a list, as indicated by the
presence of the <List of Values...> lamp on the status line, you can
choose the List of Values icon in the field to display a list of valid
values.

Once you finish entering your values, choose OK to close the Range
window.  The range flexfield automatically inserts the concatenated
low and high combination of segment values that you entered in the
appropriate fields of the range flexfield display.  The Account Ranges
window with the Low and High flexfield entries is shown below.
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Figure 5 – 8

Attention:  You cannot enter values directly into a range
flexfield like you can in a key flexfield.
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Searching for Data Using Flexfield Criteria

In chapter 3, you learned how to search for records in a window using
a feature called query–by–example.  In this section you learn how you
can also enter search criteria in a flexfield when you use
query–by–example.  By entering search criteria in a flexfield, you can
retrieve records of data that satisfy criteria in the individual segments
of your key or descriptive flexfields.  For example, suppose you want
to search for all Accounting Flexfield combinations in the Accounting
Flexfields Combinations window that contain the segment value “01”
in the first segment.  With query–by–example, you can enter this
criteria in the Accounting Flexfield to accomplish this task.

When you enter search criteria for a flexfield segment, you can use
wildcard characters or any of the query operators as part of the search
phrase.  See: To Use Query–by–Example: page 3 – 23.

If your flexfield segment has a list available, you can choose the List
icon within the flexfield window to select a value from the list for your
search criteria.  Note that if you enter a value for a segment, your
application automatically enters the default value for any other
segments that depend on the value you enter.  If you do not want a
default value as part of your search criteria, you can clear the field, or
you can enter another value in that field.

Entering Search Criteria in a Key Flexfield

Recall that to initiate query–by–example, you choose Enter from the
View, Query by Example menu to switch to Enter Query mode in the
current block.  In addition to entering search criteria in any of the fields
of the block, you can choose Edit Field... (for multi–segment flexfields)
from the Edit menu or the List of Values icon to bring up a key
flexfield window.  Use the key flexfield window to specify search
criteria for any of the segments of the flexfield.  When you are done,
choose OK to close the flexfield window and then choose Run from the
View, Query by Example menu to perform the search.

Note:  If you prefer, you can also enter your concatenated
segment search criteria directly into a key flexfield display
when your block is in Enter Query mode.  The concatenated
search criteria must include the appropriate segment separator
character.  When you are done specifying the search criteria for
the block, choose Run from the View, Query by Example menu
to perform the search.
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Entering Search Criteria in a Descriptive Flexfield

To enter search criteria in a customized descriptive flexfield when your
current block is in Enter Query mode, simply navigate to the
descriptive flexfield to automatically display the descriptive flexfield
window.  When you are done entering search criteria in any or all of the
descriptive flexfield segments, choose OK to close the descriptive
flexfield window and then choose Run from the View, Query by
Example menu to perform the search.

Attention:  If you set the user profile option Flexfields:Open
Descr Window to ‘No’, you must choose Edit Field... from the
Edit menu to open the descriptive flexfield window.  See:
Setting Your Personal User Profile: page 9 – 5.
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Running Oracle
Applications Reports
and Programs

his chapter gives you an interview of how to run reports and
programs in Oracle Applications.  Specifically, you learn about:

• The concurrent processing feature that allows you to run reports
and programs noninteractively

• How to run reports and programs using Standard Request
Submission

• How to define request sets
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Overview of Reports and Programs

Every Oracle Applications product contains reports and programs that
are specific to that product.  A report generates a summary or detail
presentation of Oracle Applications information, whereas a program
can perform a function.  The reports and programs you have access to
are defined by the responsibility you use.

For example, as an Oracle Receivables user, you may be able to run a
report to create invoices.  Or in your Oracle General Ledger
application, your responsibility may allow you to run a program to
post journal entries.

Oracle Applications provides you with two features called concurrent
processing and Standard Request Submission to help you run the reports
and programs that are a part of your responsibility.

Overview of Concurrent Processing

Concurrent processing is a feature that allows you to run a
non–interactive, data–dependent function, such as a report or program,
simultaneously with online operations.  With concurrent processing,
you can complete non–interactive tasks without interfering with the
interactive work you perform at your computer.

An example of concurrent processing occurs when you use the Post
Journals window in your Oracle General Ledger application.  Once you
specify the journal batches to post and choose the Post button, your
Oracle General Ledger application uses concurrent processing to post
the journal batch entries without further involvement from you.
Meanwhile, your computer is still available for you to continue doing
other work in Oracle Applications.

Oracle Applications runs all of its reports and programs as concurrent
processes.

Overview of Standard Request Submission

Standard Request Submission is a feature that works with concurrent
processing to provide a common interface for running your Oracle
Applications reports and programs.

Standard Request Submission provides you with a set of windows for
running reports and programs and a set of windows for creating
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groups of reports and programs to run together.  These windows give
you control over the submission and output of your reports and
programs.

Attention:  Some Oracle Applications products provide, in
addition to the Standard Request Submission windows,
product–specific windows to submit certain reports and
programs.  Such a window automatically runs a report or a
program as a concurrent process when you choose a specific
button or save your work in the form.

The Post Journals window in the Oracle General Ledger
application is an example of a window that submits a
concurrent program to post journal entries when you choose
the Post button.  You should refer to the user’s guide for your
Oracle Applications product to learn if your product uses any
product–specific windows to submit reports or programs.

See Also

Using Standard Request Submission: page 6 – 10

Submitting a Request: page 6 – 10

Rerun a Prior Request: page 6 – 23

Defining Request Sets: page 6 – 28

Who Can Use a Request Set: page 6 – 41

Submitting a Request Set: page 6 – 23

Basic Business Needs

Concurrent processing helps you satisfy the following business needs.
You can:

• Keep working at your computer while running data–dependent
reports and programs.

• Fully use the capacity of your hardware by executing many
application tasks at once.

Standard Request Submission lets you satisfy a related set of business
needs.  You can:

• Use a standard interface to run your programs and reports.

• Control access to different programs and reports.
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• Pass parameters from your environment to your reports and
programs.

• View report output online.

• Create and run sets of reports and programs.

• Automatically run programs, reports, or request sets at specific
time intervals.

• Specify whether reports and programs in a request set run
sequentially or simultaneously.

• Specify whether to continue with a request set if a report or
program in a sequential set fails.

• Specify alternative requests to run based on the completion
status of previously run requests in a request set.

• View a log file that summarizes the completion information
about all the reports and programs in a request set.

Definitions

Concurrent Program

A concurrent program is a program that does not require continued
interaction on your part to perform a specific task.  In Oracle
Applications, for example, a concurrent program may be a program
written to create a report, or to post a batch of general ledger journal
entries.

Concurrent Process

A concurrent process is an instance of a running concurrent program.
Each time a concurrent manager receives a request and runs a
concurrent program, it creates a new concurrent process.  A concurrent
process can run simultaneously with other concurrent processes (and
other activities on your computer).

Concurrent Request

A concurrent request is a request that you submit to run a concurrent
program as a concurrent process.  You issue a concurrent request when
you submit a report or program to run using Standard Request
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Submission or when you choose an action button in a product–specific
submission window.

Concurrent Manager

A concurrent manager is a component of concurrent processing that
monitors and runs tasks without tying up your computer.

Report

A report is an organized presentation of specific Oracle Applications
information.  You can view a report online, or send it to a printer.  The
content of a report can range from summary information to a complete
listing of values.  Reports run as concurrent programs in Oracle
Applications.

Request Set

A request set is a collection of reports and/or programs that you group
together.  You can submit the reports and/or programs in a request set
all at once using a single transaction.

Stage

A stage is a component of a request set used to group requests within
the set.  All requests in a stage are run in parallel, while the stages
themselves are run sequentially in the request set.

Parameter

In Standard Request Submission, a parameter is a report variable
whose value you can change each time you run a report.  For example,
you might run an audit report that requires you to enter an audit date
each time you run the report.  The audit date is a parameter for the
report.

Major Features

Background Processing

You use your Oracle Applications windows to submit all your
concurrent requests.  Once your request is submitted, the concurrent
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managers immediately take over, and complete the task with no further
involvement from you.

Concurrent Processing Options

You can control and change certain run options for each of your
concurrent requests.  Not only can you control and change the number
of copies to print, what print style to use, and which printer to use, but
you can also choose to hold a request from being run, choose a specific
date or time to start a request, or choose to save the results of your
concurrent request in a standard file format.

Online Request Review

You can review the output and log files from your concurrent requests
online.  You can see the results of a concurrent request without the
delay of printing out the entire report or log file.

Automatic Error Notification

Every time you sign on, Oracle Applications informs you if any
concurrent requests completed unsuccessfully since your last session.
If so, you receive a message in a separate window when you first log
in.  You can review any failed request’s log file online to help diagnose
the problem.

Scheduling

Using Standard Request Submission, you can define schedules to
automatically resubmit your program, report, or request set.  At
submission time, you can specify:

• the starting date and time

• the time of day for resubmission

• the resubmission interval in months, days, hours, or minutes
from either the start or completion of the request

• the date and time to stop repeating the program, report, or
request set

• day or days of the week or month to resubmit

Oracle Applications automatically resubmits the program, report, or
request set until the end date.
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Produce Reports in Multiple Languages

Using Standard Request Submission for sites with Multiple Language
Support, you can choose the languages in which to have your reports
printed.  Additionally, reports can be developed that produce language
outputs based on the preferred language of the recipient.
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Concurrent Processing Options

All reports and programs in Oracle Applications run as concurrent
processes whether you submit them using the Submit Requests
window, or using a product–specific submission window.  Throughout
this guide we refer to submitted reports and programs as concurrent
requests, or simply as requests.

Each concurrent request runs according to a set of concurrent
processing options.

Default Values of Concurrent Processing Options

The default values of the concurrent processing options are determined
by the values of the following user profile options:

• Concurrent:Hold Requests—Specifies whether to hold a request
temporarily

• Concurrent:Report Access Level—Specifies who has access to
report and log files

• Concurrent:Report Copies—Specifies the number of copies of a
report to print

• Concurrent:Request Priority—Specifies the priority of a
concurrent request

• Concurrent:Request Start Time—Specifies the start date and
time for a concurrent request

• Concurrent:Save Output—Specifies whether to save report
output to a file

• Concurrent:Sequential Requests—Specifies whether to run
your requests sequentially

• Printer—Specifies the printer to print your report output

If you want to change the value of a default, you must change the value
of the corresponding user profile option using the Personal Profile
Values window in your application.  Some profile options, such as
Concurrent:Request Priority, can only be changed by your system
administrator.  See: Setting Your Personal User Profile: page 9 – 5.

If you submit your report or program using the Submit Requests
window, you can also modify most of these concurrent processing
options for the request at the time you submit your request.  If you use
a product–specific window that automatically submits a concurrent
request when you save your work or choose a button, Oracle
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Applications uses the values defined by your user profile options as the
concurrent processing options for your request.

Note:  You can modify many of your request’s concurrent
processing options up until it starts running, even if you cannot
modify the options at the time you submit the request.  The
Requests window lets you monitor and change the options for
your requests.  See: Using the Requests windows: page 7 – 2.

See Also

Who Can Use a Request Set: page 6 – 41

Submitting a Request Set: page 6 – 23
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Using Standard Request Submission

This section describes step–by–step how to run and monitor Oracle
Applications reports and programs using Standard Request
Submission.  If you want to learn more about a particular report or
program, or learn how to submit a report or program using a
product–specific submission window, you should refer to the user’s
guide for your Oracle Applications product.

To use Standard Request Submission, you must first sign on to Oracle
Applications and select a responsibility that allows you to run requests
in your application.

Note:  For simplicity, this section uses the term request to refer
either to a program or report.

Submitting a Request

 Standard Request Submission gives you control over how you run
your requests and request sets.  This section describes how you
customize and submit a request using the Submit Request window.

There are three elements to submitting a request.  Selecting the request
or request set to be submitted, defining a submission schedule, and
providing completion options.

• Selecting the request or request set may require you to provide
request parameters and the output language.

• Defining a schedule can be as simple as submitting as soon as
possible or using a more complex schedule that you define when
you first submit your request and may be used for other requests
in the future.

• Completion options allow you to deliver request output to
others and specify which printers and how many copies of the
output you want to produce for each request.

You can submit as many requests as you like from the Submit Request
window.  You can even submit a request more than once if you want to
run the same request with different parameter values.

Refer to the user’s guide of your Oracle Applications product to learn
how to access the Submit Request window from your application.

Attention:  Some applications provide access to the Submit
Request window from multiple menu choices.  However, the
list of requests that you can run and the name of the window
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itself may vary depending on the navigation path you use to
access the window.

The following flow diagram outlines the steps required to submit a
request.
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� To submit a request:

1. Navigate to the Submit a New Request window (Other –> Requests
–> Run).

2. Check the Request option to submit single requests, or choose to
submit a predefined group of requests by checking Request Set.

3. Choose OK.
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Submitting requests

4. Use the Copy... button to take advantage of previously entered
request submissions.

5. Select the Name of the request (report or program) you want to run
from the list of available requests.

Note:  Your responsibility’s request group determines which
requests appear in the list.

Defining Parameters

6. A Parameters window automatically appears if you select a request
that requires parameter values and your profile option Flexfields:
Open Descr Window is set to Yes.  The prompts in the Parameters



☞

6 – 14 Oracle Applications User’s Guide

window are specific to the request you select.   The example in the
figure below requires the parameters Application Name and
Responsibility Name.

Some requests require you to enter parameter values so that you
can specify the scope of information you want in the request
output.  Some requests don’t have parameters at all.  Some
parameter fields also have a list of values available to ensure you
choose a valid parameter value while other parameters are optional
and require no value.  Use the List of Values icon to display a list
of valid values for a parameter.

Note:  Default values may be predefined for one or more of the
parameters associated with your request.  The default values
are automatically applied to these parameters when the
parameters window is opened.  However; if you do not open
the parameters window, default values are only applied to
required parameters.

7. Once you enter the values in the required parameter fields and
choose OK, the Parameters window closes, and your parameter
values are concatenated and displayed in the Parameters field.

Determining Output Language

8. If your site supports multiple languages, you can select which
language is used for your request output.  Choose Languages... to
open the Language window.  Use the Select All button to produce
output in all languages supported at your site or check individual
languages.  If the language selection is predefined in the report, the
Language window does not open.

Attention:  Each language creates its own request, so the
number of languages determines the number of concurrent
requests created and tracked in the Requests window.

Defining a Submission Schedule

The scheduling window provides you with several scheduling options.
You can choose to re–use a schedule you previously defined and saved,
or define a new schedule.  You can define your schedule to run a
request as soon as possible, at a specific time, or repeatedly at specific
intervals, on specific days of the week or month.

9. Choose Schedule... to open the Scheduling window.
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10. Choose a type of schedule from the following:

Allows you to re–use a previously defined and
saved schedule.  You may modify the saved
schedule for this one submission or save the
modified schedule with a new name for future use.

Note:  If you intend to use the saved schedule as defined, you
can proceed to step 13.

Submits your request as soon as possible.  If you
choose this schedule type, proceed to step 13.

Apply a Saved
Schedule

As Soon as
Possible
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Submits your request once at the time and date you
specify.

Submits your request repeatedly at the interval you
specify.

Submits your request repeatedly on specific days
of the week or month.

This option is reserved for future releases.

11. Many schedule types require additional information to complete
the schedule.  Use the steps associated with your selected schedule
type:

Once

Periodically

On Specific Days

Advanced
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When you choose Once, a special time field
appears that lets you specify the time of day you
want to submit your request.  Use the calendar by
selecting the List of Values icon in the field to select
a date and time to submit your request.

When you choose Periodically, several new fields
appear that let you specify the interval of minutes,
hours, days, or months that you want to wait
before resubmitting a request.  You can also specify
whether to count your interval from the requested

Once

Periodically
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start time of the request or from the completion
time of the request.

• Use the List of Values calendar to select start and
end dates to define the period in which you
want to submit your request.

Note:  If you do not specify a start time, Oracle Applications
uses the value from your user profile option
Concurrent:Request Start Time or the current time as the
default.

Note:  Whether a request completes successfully or in error,
Oracle Applications immediately submits the next run only if
the next requested start date and time is on or before the end
date and time you specify.  If you do not specify an end date,
the request or request set repeats indefinitely until you cancel
it.  See: Cancelling Requests: page 7 – 12.

• Select the interval from the poplist and enter the
number of intervals between each submission of
your request.

• Choose to count your interval from the
beginning or completion of the prior run.

• If your request contains date parameters, you
can choose ”Increment date parameters each
run” to have the value for that parameter be
adjusted to match the resubmission interval.  For
example, if the value for the parameter is
25–JUL–1997 07:00:00 and your interval is
monthly, the parameter is adjusted to
25–AUG–1997 07:00:00 for the next submission.



6 – 19Running Oracle Applications Reports and Programs

When you choose On Specific Days, new fields
and calendars appear that let you specify which
day of the week and/or month to submit your
request.

• Use the List of Values calendar to select start and
end dates to define the period in which you
want to submit your request.

Note:  If you do not specify a start time, Oracle Applications
uses the value from your user profile option
Concurrent:Request Start Time or the current time as the
default.

On Specific Days
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Note:  Whether a request completes successfully or in error,
Oracle Applications immediately submits the next run only if
the next requested start date and time is on or before the end
date and time you specify.  If you do not specify an end date,
the request or request set repeats indefinitely until you cancel
it.  See: Cancelling Requests: page 7 – 12.

• Use the monthly calendar template to specify
dates during the month to submit your request.
You can choose the date by clicking it.  When
you select a date such as the 5th, your request is
resubmitted on the 5th of each month until the
end date is reached.

• Use the weekly template to specify which day of
the week to schedule your request.

Attention:  You can select as many dates as you require.

12. To save your schedule, check the Save this schedule check box.
You must also provide a unique name for each schedule you save.
Optionally, enter a description of your schedule.

13. Choose OK.
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Defining Completion Options

14. In the Upon Completion... region, use the Save all Output Files to
write your request output to a file.  If you wish to view your output
online, you must use this check box.

15. Choose Options...
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Note:  Oracle Applications automatically uses the default
values determined by your logon and profile options as listed
below:

Used as the default for the notification
field.

Determines the default printer.

Used as the default for the number of
copies for the printer defined in the Printer
profile option.

Determines whether to save your report
output by default.

In some cases the defaults are determined by the program
definition.

16. Specify additional people to notify, or replace your name if you do
not want to be notified.

17. Select a language for each person notified.

18. Select a print style from the poplist.

19. Use the LOV to select the printers you want used to produce a hard
copy of your report.  Each printer will produce at least one copy of
the report.  If you need more than one copy for a particular printer,
use the Copies field to enter the number of copies you want
printed.

Note:  Some requests may have a required Style or Printer that you
cannot change.

20. Choose OK.

21. When you are done specifying scheduling and completion options,
choose Submit.

Once you submit your request, the Requests window opens and
provides you with the current status of your request and the
request ID number.

Oracle Applications assigns a request ID to each request
submission so that you can identify the results of the request when
it is complete.  You can use the request ID to query for your request
output in the Requests window.  Oracle Applications also assigns a
new request ID number to each resubmission of a request and
displays the request ID in the log file of the previous request.

Logon

Printer

Concurrent:
Report Copies

Concurrent: Save
Output
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22. If you wish to submit another request, simply repeat Steps 1
through 21.  All the requests that you submit for the current session
appear in the Requests window.

See Also

Rerun a Prior Request: page 6 – 23

Using the Requests windows: page 7 – 2

Rerun a Prior Request: page 6 – 23

Rerun a Prior Request

You can resubmit any request you previously submitted that is part of
your current responsibilities request security group.  The previous
requests are displayed in a Find window when you choose the Copy...
button.  The list of requests include all of the requests you submitted
that are part of your current responsibilities request security group and
were submitted after the last time your System Administrator ran the
Purge Concurrent and/or Manager Data program

� Resubmit a request:

1. Navigate to the Submit Request window.

2. Choose the Copy... button

3. Select a request from the Find window and choose OK.

The request information such as, request name, parameters, and
schedule appear in the Submit Requests window.  You can modify
the request at this time or resubmit as is.

4. Choose the Submit button.

Submitting a Request Set

Submitting a request set is very similar to submitting a request.  You
use the same menu path for both, however, when you choose Request
Set, the Submit Request Set window is opened.
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� To submit a request set:

� The steps for submitting a request set are very similiar to those for
submitting a single request.

1. Check Request Set in the Submit a New Request window and
choose OK.

2. In the Submit Request Set window enter the name of the Request
Set.

Alternatively, choose the Copy... button to use a previously defined
request set submission.
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3. The requests assigned to the request set are displayed in the
multi–row region and may be modified for this request set
submission.

– When you move your cursor to the Parameters field for a
request, Oracle Applications displays a Parameters window
specific to that report.  If there are no parameters, then the
field is disabled.

– When you finish entering the required parameter values for
a request, choose OK to close the window.

– If you wish to define completion options, open the Upon
Completion... window for each request and enter your
completion options.  See Defining Completion Options:
page 6 – 21

Attention:  Multilingual requests can not be submitted as part
of a  request set.

Note:  If you wish to view a request’s output online, you must
check the Save all Output Files check box for that request in the
Upon Completion... window.

4. Choose the Schedule window to define a schedule for this request
set submission.  See Defining Submission Schedule: page 6 – 14
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5. When you submit a request set, Oracle Applications assigns a
request ID to the request set as well as to each request in the
request set.  The request ID for each request is displayed in the
output and log files of the request set.  Oracle Applications also
assigns a new request ID to each resubmission of a request set, and
displays the request ID of the new request set in the log file of the
previous request set.

See Also

Using Standard Request Submission: page 6 – 10
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Submitting a Request: page 6 – 10

Defining Request Sets: page 6 – 28

Who Can Use a Request Set: page 6 – 41
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Defining Request Sets 

By defining request sets, you can submit the same set of requests
regularly using a single transaction.  You use the Request Set window
to create and edit request sets.  Alternatively, you can use the Request
Set wizard to create simple request sets.  Refer to the user’s guide for
your Oracle Applications product to learn how to access the Request
Set window.

Attention:  Some Oracle Applications products do not allow
you to create request sets.  These products do not have the
Request Set window available.
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Organizing Requests with Stages

Request sets are divided into one or more ”stages” which are linked to
determine the sequence in which your requests are run.  Each stage
consists of one or more requests that you want to run in parallel (at the
same time in any order).  For example, in the simplest request set
structure, all requests are assigned to one stage.  This allows all of the
requests to run in parallel.

To run requests in sequence, you assign requests to different stages,
and then link the stages in the order you want the requests to run.

For example, if you had three requests: Request 1, Request 2, and
Request 3, that needed to run in the sequence 1, 2, 3, then you would
assign each request to a different stage and link the stages in that order,
as shown below.

The concurrent manager allows only one stage in a request set to run at
a time.  When one stage is complete the following stage is submitted.
A stage is not considered to be complete until all of the requests in the
stage are complete.  One advantage of using stages is the ability to run
several requests in parallel and then move sequentially to the next
stage.  This allows for a more versatile and efficient request set.

For example, suppose you have three requests that can run in parallel,
and a fourth request that cannot run until after all of the first three have
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completed.  Furthermore, you have a fifth request and sixth request
that can run in parallel, but are dependent on the completion of the
fourth request.  Using stages you can put requests 1, 2, and 3 in Stage 1
and link it to Stage 2, which contains only request 4.  Link Stage 2 to
Stage 3 which contains requests 5 and 6.

Using Stage Status

Like request sets and concurrent requests, stages can complete with
different statuses.  Each stage can complete with a status of Success,
Warning, or Error.  You can use these completion statuses to structure
your request set, by defining which stage will follow the current stage
based on its completion status.

For example, you could define a request set as follows: Stage 1 begins
the set.  If Stage 1 completes with status Success, Stage 2 is executed.  If
Stage 1 completes with status Warning, Stage 3 is executed.  If Stage 1
completes with status Error, Stage 4 is executed.  This setup is
illustrated in the following diagram.
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In this example, the ”Standard” function calculates the status for a
stage using the statuses of the requests within the stage.  The Standard
function sets the stage status to Success if all of the requests in a stage
complete with a status of Success.  If one or more requests complete
with a status of Error, then the status of the stage is Error.  For a stage’s
status to be Warning, one or more of the requests must have a status of
Warning and no request may have a status of Error.

Linking of Stages

There are no restrictions on linking stages within a request set.  Any
stage may be linked to any other stage, including itself.  Two or more
links can point to the same stage.  For example, Stage 1 can link to
Stage 2 if the completion status of Stage 1 is Success or Warning, and
link to Stage 3 if the status is Error.
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You determine the end of a request set by not specifying a followup
stage for each completion status.  You can end a request set after any
stage in the request set.  When any stage completes with a status that
does not link to another stage, the request set ends.

You can use the linking of stages to control your request set.  In
previous releases you had three options: run in parallel, run
sequentially, and run sequentially but abort on Error.  All of these are
easy to recreate using the request set wizard.  You can use the Request
Set Wizard button in the Request Set window to start the wizard. The
wizard takes your input and creates the request set as follows:

Creates one stage containing all of the requests you
wish to run in parallel.

Creates a separate stage containing the request or
requests for each step in the sequence and link in
the appropriate order.

Run in Parallel

Run Sequentially
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Sets up your sequence the same as it did for Run
Sequentially, but when it links the stages, it does
not enter a follow up stage as a link in the Error
completion status field.

� To create a request set:

1. Navigate to the Request Set window.

2. Enter a Name for your request set.

3. Enter a Set Code for your request set.  This name is used internally
to reference your request set.

4. Enter the Application with which you want to associate your
request set.

5. Enter a Description of your request set if you like.

6. The Owner field defaults to your username and can only be
changed by your system administrator.

7. Enter the Active Dates From and To fields to define an effective
period when you and others can run the request set.  If the current
date is outside the range you define, the request set will not be
available in the Submit Requests window.

Run Sequentially
but abort on
Error
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8. Check the Print Together check box to send all your requests to the
printer together when they complete, or uncheck the check box to
send each request one at a time to the printer as it completes.

9. Check the Allow Incompatibility check box to allow your system
administrator to specify programs that this request is incompatible
with (may not run with).  Leave Allow Incompatibility unchecked
to specify that this request set may run with all other concurrent
requests or request sets.

10. Choose Define Stages or Link Stages if you have finished defining
your stages.  See Define Stages: page 6 – 35 or Link Stages: page
6 – 40
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� Defining Stages

1. The value for the Display Sequence is defaulted in sequence as you
enter your stages.  You may change the display order of the stages
by modifying this field.

2. Enter a Name for the stage.

3. Enter a Description of your stage if you like.

4. Enter a Stage Code for the stage.  This code is used internally to
reference the stage.

5. In the Function field of the Function region, use the List of Values
to select a function.  The default value for this field is the Standard
Stage Evaluation function.  This function bases its completion
status on the normal completion status of the requests it contains.
Other functions may be provided by your Oracle product.  For a
description of these functions, refer to the user’s guide for that
product.

6. Use the ”The Return Value of this Stage Affects the Set Outcome”
check box if you want to ensure that the request set’s completion
status is equal to the completion status of this stage.

Note:  If you choose this check box for more than one stage, the
completion status of the request set will equal the completion
status of the last of these stages to run within the set.

7. Use the Allow Incompatibility check box to allow your system
administrator to specify programs that this stage is incompatible
with (may not run with).  Leave Allow Incompatibility unchecked
to specify that this stage of the request set may run with all other
concurrent requests or request sets.

8. Choose Requests.

Stage Requests window

In the Stage Requests window you define which requests you want to
include in the stage.

9. Select the report or program you want to include in your request
set.  A description of the request you choose and its associated
application appears in the Description and Application fields.

The list of requests you can choose includes the requests that your
responsibility’s request group lets you access from the Submit
Requests form.
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10. Use the Allow Stage Function to Use This Program’s Results check
box to indicate which programs or reports should be included.

11. The Print Options region reflects the options for the current
request.  Specify the number of Copies of output to print, the Style
to print, the Printer to print to, and whether to save the output to
an operating system file.

Standard Request Submission saves these options so you do not
have to specify them again when you run the request set.  If you do
not wish to specify these options for each request when you define
the set, Standard Request Submission uses the values of your
personal profile options as the default when you submit the request
set.  See: Default Values of Concurrent Processing Options: page
6 – 8.

Note:  Some requests may have a required Style or Printer that you
cannot change.

12. When you are done with the Print Options, choose Parameters to
display the Request Parameters window.
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Request Parameters Window

The Request Parameters window lets you customize the parameter
values of a specific request in a request set.  The fields at the top of the
Request Parameters window list general information about the current
request set and the request for which you can customize the parameter
values.  The multi–row portion of the window lists the parameters for
that request.

1. The Sequence field displays the order in which each request
parameter appears when you run the request in the Submit
Requests window (lower numbers appear before higher numbers).
Only your system administrator can change a parameter’s order.
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2. The Prompt field is a display–only field that shows the request
parameter’s prompt.

3. Check the Display check box to specify that you can see a request
parameter at submission time, or uncheck the check box to specify
that a parameter should not be displayed at submission time.

4. Check the Modify check box to specify that you can insert or
change the value for a request parameter at submission time, or
uncheck the check box to specify that a parameter cannot be
changed at submission time.

5. Use the Shared Parameter field to set a default value for a
parameter that occurs in more than one report or program of a
request set.  Once you enter the same parameter label in the Shared
Parameter field for each occurrence of the same parameter, the
value that you assign to the first occurrence of the parameter
becomes the default value for all subsequent occurrences of the
parameter.  The shared parameter label simply enables you to set
an initial default value for all occurrences of the same parameter so
you can avoid typing the same value all over again for every
occurrence of the parameter.

For example, suppose you define a request set that includes three
reports, and all reports include a parameter called “Set of Books”.
You want the “Set of Books” parameter to default to the same value
in all reports.  To accomplish this, enter a label called “Book” in the
Shared Parameter field for the first occurrence of this parameter.
You can also assign a value in the Default Value field of this
parameter now, or wait until you run the request set to assign a
default value when the parameter first appears.  Enter the label
“Book” in the Shared Parameter field of all other occurrences of the
“Set of Books” parameter in your request set.  When you submit
this request set from the Submit Requests window, every
parameter that you label “Book” defaults to the value you assign to
the first occurrence of the “Set of Books” parameter.

Attention:  Note that if you later change the value of a parameter
that contains a shared parameter label, you change only the value
for that instance of the parameter, and not the value for all other
occurrences of that labelled parameter.

We recommend that if you make a parameter with a shared
parameter label modifiable, that you also display the parameter so
you can always see what the parameter’s current value is.  This
helps reinforce the understanding that a later value change to one
labelled parameter cannot propagate a value change to all other
similarly labelled parameters.
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6. Optionally enter a Default Type and Value for the parameter.

7. Save your work.

8. Go back to the Stage Requests window and repeat Steps 9 through
11 to add more requests to the request set stage.

You can select a request more than once if you want to run the
same request with different default parameter values.

9. To start a new stage, return to the Stage window and choose New
Record from the File Menu.
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� Link Stages

1. Enter the Start Stage. The stage you enter here is the first stage
submitted for the request set.

2. Enter the stages you want to run following the first stage in the
Success, Warning, and Error columns.  To ensure that a particular
stage follows the preceeding stage regardless of the completion
status, enter the desired stage in all three columns.  To stop the
request set if a stage ends in Error, leave the Error column blank.
Any time you do not specifically indicate which stage should
follow for a completion status, the request set will exit on that
completion status.

In the example shown in the following table, the request set will
always exit if any stage returns a completion status of error.  In
addition, stages C and D will terminate the request set regardless
of their completion status.  If Stage A returns a status other than
Error, Stage B will be submitted.  Finally, when Stage B completes
with a status of Success, it is followed by Stage C, or if the status is
Warning, Stage D will follow.

Example:

Display
Sequence

Name Success Warning Error

1 Stage–A Stage–B Stage–B

2 Stage–B Stage–C Stage–D

3 Stage–C

4 Stage–D

3. Choose Done.
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Who Can Use a Request Set

After you define a request set, it becomes your private request set.  You
can run it as long as you have access to a standard Submit Requests
window that does not limit access to specific requests.

Other users can run the request set only if your system administrator
assigns the request set to their responsibility’s request group.  It is
possible to have a request set in your request group that contains
individual requests that are not in your request group.

You can only edit request sets that you own.  You can add any requests
in your request group to the request set.  You can delete any request
from the request set, regardless of whether that request is in your
request group.  To update information about an individual request in
the request set, however, the request must be in your request group.

Use the Request Sets window to edit a request set, and the Submit
Requests window to submit a request set to be run.

See Also

Submitting a Request Set: page 6 – 23
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Monitoring Oracle
Applications Reports
and Programs

his chapter tells you how to view and monitor your requests.
Specifically, this chapter tells you how to:

• Use the Find Requests window

• Use the Requests window

• View the progress of a concurrent request

• Cancel a request or change its processing options
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Viewing Requests

Since all reports, programs, and request sets are run as concurrent
requests in Oracle Applications, you use the Requests window to view
the status and output of your requests.

Monitoring Requests: page 7 – 9

Using the Requests Window

You can use the Requests window to view a list of all submitted
concurrent requests, check whether your request has run, change
aspects of a request’s processing options, diagnose errors, or find the
position of your request in the queues of available concurrent
managers.

You can navigate to the Requests window using the Navigate window.
Different Oracle Applications products use different menu paths in the
Navigate window to access the Requests windows.

Suggestion:  Refer to the Menu Paths appendix of your
application’s user’s guide to learn how to access this window
from your application.

Attention:  If your system administrator sets the profile option
Concurrent:Report Access Level to “User,” the Requests
window displays the concurrent requests for the current user.
If your system administrator sets the profile option to
“Responsibility,” the Requests window displays the concurrent
requests for the current responsibility in addition to requests
for the current user.

� To use the Find Requests window:

1. Upon initial navigation to the Requests window, you are directed
to the Find Requests window.

Use the Find Requests window to specify the types of requests you
want to see.  You can choose to view your completed requests,
your requests in progress, or all of your requests by selecting the
appropriate option group.

In addition, you can look for a particular request using the Specific
Requests option group.  Use the find criteria fields as you would
for any other find window to specify as many or as few details as
you need to locate the desired request information.
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Note:  You can use the Specific Requests region to view requests
that you did not submit by entering a requestor other than yourself
or using wildcards such as the ”%” to query all requests.

Note:  Depending on the value of the profile option Concurrent:
Report Access Level, some concurrent requests may not be shown.

Note:  Although you can list all submitted concurrent requests, you
can generally only view detail, report output, and request log file
information for your own concurrent requests.  However, if the
user profile Concurrent:Report Access Level is set to Responsibility, you
can review the details of all requests submitted for the current
responsibility and username.

2. Use the Order By poplist to specify the order in which you want
your requests displayed.

� To use the Requests window:

1. Move your cursor to the record that represents the request you
want to examine in detail.

Each record shows you the the request ID, request name, phase and
status of the request, as well as the parameters used by the request.
If the request is part of a request set, the request ID for the parent
request is provided in the Parent column.

From the Requests window you can Cancel a request or put it on
hold if the status of the Request is pending.  If the status is
completed, you can view the output or the logs generated by the
request.  Lastly you can always review the details of the request
submission.

2. Choose View Details...

� To review and update a request’s schedule:

The Date Started and Date Completed are displayed in
thewindow’s upper region.

1. Choose Schedule... to see more detailed information.

You can update the scheduling information for your request if it
meets all of the following criteria:

– you made the initial request.

– the request has not yet run.

– the program does not prevent request updates.



7 – 4 Oracle Applications User’s Guide

� To review and update a request’s completion options:

Choose Options... from the Upon Completion... region  to see:

• Names of people to notify

• Name of printer used

• Number of copies to print

• Print Style

You can update the completion option information for your request
if it meets all of the following criteria:

– you made the initial request.

– the request has not yet run.

– the program does not prevent request updates.

� Tracking your request in the concurrent manager’s queue:

1. With your cursor on a record of interest in the Requests window,
choose Managers from the Tools menu.

This window lets you view your request’s position within each
available concurrent manager’s queue, if the request has not run
yet.

Note:  The Manager Log entry on the Tools menu is disabled for all
users except the system administrator.  This choice lets the system
administrator open a window displaying the concurrent manager’s
log file for the request.

2. Choose the Manager Queue button to display the Concurrent
Manager Queue window.  This window displays the queue of
requests waiting to be processed by the concurrent manager you
select in the Concurrent Managers window.

� To reprint your request:

With your cursor on a record of interest in the Requests window,
choose Reprint... from the Tools menu to reprint a request’s output.
When you choose Reprint..., a window appears allowing you to
enter a printer, number of copies, and style for reprinting of the
request.  Choose OK in the Reprint window to reprint the request.

Note:  This menu entry is disabled if the request has not yet run.
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� To view Request Diagnostics:

With your cursor on a record of interest in the Requests window,
choose Diagnostics to display a window containing information
about when the request completed and if it did not complete, a
message explaining why not.

See Also

Monitoring Requests: page 7 – 9



7 – 6 Oracle Applications User’s Guide

Viewing Request Output and Log Files

Oracle Applications allows you to view your log and report output files
online with the Report File Viewer.  The viewer provides navigational
buttons that enable you to go directly to the first or last page of your
report, or to move to the next or previous page.  In addition, you can
use Go To Page button to specify the page of the report you want to
view.  You can activate the viewer from the Requests window.

Note:  Some reports have special formatting characters that
printers use to print special effects, such as boldfacing or
underlining.  If your computer does not support such special
characters, you may see these characters when you view your
report online.  However, the report still prints correctly without
displaying these characters.
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� To View Request Output:

Choose View Output

� To view requests log files:

Choose View Log to display the request’s error log file.  If your
request ends in error, you can view a log of the error messages.
The log also contains information about the print options used and
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a listing of child request IDs, if the original request is a parent
request.

� To save Request Output:

Choosing Copy File... from the Tools menu displays the Viewer Option
window which presents a poplist of output file formats for you to
select from.  Selecting one opens your browser window.  From the
browser window, you can use the native browser tools to save your
request output to a file.

Note:  When you save the file, give the file an appropriate
name and the correct extension.  You must provide the correct
extension to save and view the file properly.

Viewing Reports in HTML

Reports that produce an output other than a text file (for example
HTML or PDF) are displayed in a browser.  If you set the profile option
VIEWER: TEXT to Browser, your text files are also displayed in a
browser as opposed to the Report Viewer.  VIEWER: TEXT may also be
set to display your output in a text editor such as Microsoft Word, or in
a spreadsheet such as Microsoft Excel.

You can use the Save As functionality of your browser to save an
HTML report to your desktop. If your system supports multiple
languages, you may have trouble with the saved output. Ask your
system administrator for assistance with character set conversion from
the server to your browser.

The name of the output/report file passed to the browser is created
dynamically.  The concurrent program name and the date on which the
request was run are used to create the name of the file.  The file
extension is based on the Output Type” attribute of the concurrent
program.

For example:

Request 1234 for the ”Year End Exception Report” is run on September
27, 2001  and has an output file named o1234.out.

When you view this report online, ’Year End Exception
Report_270901.html’ is passed as the name of the file to the browser in
the content header in addition to the mime–type.  You can then save the
file locally using this name.

Monitoring Requests: page 7 – 9
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Monitoring Requests

Oracle Applications lets you monitor your concurrent requests when
you display the Requests window.  And, if your request has not yet
started running, Oracle Applications lets you cancel or change some of
the request’s parameter, scheduling, or completion options.

This section tells you how to monitor your concurrent requests and
modify their options after you submit them to run.

Concurrent Request Phase and Status

The Requests window displays a phase and status summary for each
concurrent request listed.

A concurrent request has a life cycle consisting of the following phases:
pending, running, completed, and inactive.

During each phase, a concurrent request has a specific condition or
status.  The table below lists each phase/status combination and
describes its meaning in relation to a request.

If a request is pending, you can determine when it will start by using
the Concurrent Managers For the Request window to review the
request’s position in the queues of current managers that can run that
request (see Tracking your request in the concurrent manager’s queue:
page 7 – 4).
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Concurrent Request Phase and Status

Phase Status Description

PENDING Normal Request is waiting for the next available manager.

PENDING Standby Program to run request is incompatible with other
program(s) currently running.

PENDING Scheduled Request is scheduled to start at a future time or date.

PENDING Waiting A child request is waiting for its Parent request to mark it
ready to run.  For example, a request in a request set that
runs sequentially must wait for a prior request to
complete.

RUNNING Normal Request is running normally.

RUNNING Paused Parent request pauses for all its child requests to finish
running.  For example, a request set pauses for all
requests in the set to complete.

RUNNING Resuming All requests submitted by the same parent request have
completed running.  The Parent request resumes running.

RUNNING Terminating Request is terminated by choosing the Cancel Request
button in Requests window.

COMPLETED Normal Request completed successfully.

COMPLETED Error Request failed to complete successfully.

COMPLETED Warning Request completed with warnings.  For example, a
request is generated successfully but fails to print.

COMPLETED Cancelled Pending or Inactive request is cancelled by choosing the
Cancel Request button in the Requests window.

COMPLETED Terminated Request is terminated by choosing the Cancel Request
button in the Requests window.

INACTIVE Disabled Program to run request is not enabled.  Contact your
system administrator.

INACTIVE On Hold Pending request is placed on hold by choosing the Hold
Request button in the Requests window.

INACTIVE No Manager No manager is defined to run the request.  Check with
your system administrator.  A status of No Manager is
also given when all managers are locked by run–alone
requests.

Table 7 – 1  (Page 1 of 1) 
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Individual Request Progress

Generally when you submit a request, its phase is Pending, which
means that it has not yet started running.  When it does start running,
its phase changes to Running.  Upon completion the status of the
request becomes either Success, Warning or Error.  If your request ends
in warning or error, you can use the Diagnostics button in the Requests
window to view any diagnostic messages stored in the log file.

Request Set Progress for Stages

When you submit a request set, all the requests in a stage run
simultaneously and the phase and status of the set begins as Pending
Normal until an available concurrent manager can process it.  When a
concurrent manager becomes available, the stages’s phase and status
change to Running Paused as the stage waits for all of its requests to
finish.  Then the stage changes from Running Paused to Running
Normal to write completion information in the report and log files.
Finally, the stage phase changes to Completed and its status becomes
Success, Warning, or Error.

Progress of Individual Requests in a Stage

When a stage submits its requests, all requests start as Pending
Normal, then change to Running Normal, and finally end as either
Completed Success, Completed Warning, or Completed Error.

Progress of Linked Stages

When you submit a request set with more than one stage, the request
set submits all the stages but only runs one stage at a time, ensuring
that each stage completes before submitting the next.  Each stage shows
a phase of Pending and a status of Normal while it waits for a
concurrent manager to process it.  As the next available concurrent
manager processes the stage, the request set phase and status changes
to Running and Paused, as the first stage begins to run.  After each
stage finishes, the request set temporarily changes to a Normal status
to check whether the stage ended in error and to determine whether to
stop or which stage should be processed next based on how you linked
the stages when you defined the request set.

Once the check is done for a completed stage, the set goes back to
Paused status during which the next stage runs.  The set alternates
between Normal and Paused status for each stage in the set.  The set
itself resumes running (Running Normal), after all the requests finish,
to write completion information in the report and log files.  The set
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ends in a Completed phase, either with Success, Warning or Error
status.  A request set ends when a stage ends with a completion status
that does not link to a subsequent stage.

See Also

Monitoring Requests: page 7 – 9

Cancelling Requests

Use the Requests window to cancel a request (report, program, or
request set) that has not yet completed.

� To cancel a request that has not yet completed:

1. Navigate to the Find Requests window.

2. Check My Requests in Progress.

3. Choose Find.

4. With your cursor on the request you wish to cancel, choose Cancel
Request to terminate the request.  You can only cancel a request if it
is in the Running, Pending, or Inactive phase.   You can put your
request on hold by choosing Hold Request if the request is Pending
or Inactive.

Attention:  If you cancel a request set, Oracle Applications
automatically cancels all requests in the set.

Attention:  If you terminate a request while it is in the Running
phase, the current run stops, but the resubmission does not.  While
the resubmitted request is in the Pending phase, you can go to the
Resubmission tabbed region of the Requests window and change
the Interval for the request to 0 or change the End Date to a date
that has passed to cancel the resubmission.

5. Select Save from the File menu.

See Also

Monitoring Requests: page 7 – 9
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Changing Request Options

If your request or request set has not started running, you can change
how your request or request set runs and prints its output using the
Requests window.

� To change the request options of a request or request set that has not
yet started running:

1. Navigate to the Find Requests window.

2. Check Specific Requests.

3. Enter the Request ID for the Request you want to modify.

4. Choose Find.

5. From the Requests window, you can cancel a request or request set,
put a request or request set on hold, or take a request or request set
off hold using the buttons in the window.  A request or request set
on hold does not run until you take it off hold.

Attention:  The cancel or hold action does not go into effect until
you choose Save from the File menu or the toolbar.

6. With your cursor on the request you wish change and choose View
Details.

If the request is pending or scheduled, you can change the request
parameters, language and territory of the output, and if you want
to save your output.

7. Choose Schedule to change:

• start and end dates for recurring requests

• schedule dates

8. Choose Options to change:

• people notified and the associated language.

• printers

• number of copies

Attention:  For requests in a request set, you can change the values
of the request options if the requests are in your responsibility’s
request group.
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See Also

Monitoring Requests: page 7 – 9
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Working with
Attachments

his chapter teaches you how to use the Attachments feature to link
data such as images and word processing documents to your
application data.  Specifically, this chapter tells you how to:

• Attach a document to an Oracle Applications record

• View an attachment

• Copy or delete an attachment
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About Attachments

To illustrate or clarify your application data, you can link
non–structured data such as images, word processing documents,
spreadsheets, web pages, or video to more structured application data.
For example, you could attach images to inventory items or video to
manufacturing operations.

Invoke the Attachment form to view an attachment by pressing the
Attachment toolbar button.

The toolbar Attachment icon indicates whether the Attachments feature
is enabled in a form block.  When the button is dimmed, the Attachment
feature is not available.  When the Attachment feature is enabled in a
form block, the icon becomes a solid paper clip.  The icon switches to a
paper clip holding a paper when the Attachment feature is enabled in a
form block and the current record has at least one attachment.  There is
also a profile option, Indicate Attachments, that allows you to turn off
indication of attachments when querying records for performance
reasons.

Note:  The current version of the Attachments feature supports
attachments to a restricted set of applications data.  Check your
product–specific documentation to determine if the Attachments
feature is enabled for your Oracle Applications product, and if so,
for what data.



8 – 3Working with Attachments

Attachments Window

Use the Attachments window to view or delete existing attachments,
and create new attachments.  You must provide the following
information when you create an attachment:

Category

The category controls which forms can access the document.  Each form
that enables Attachments must list which document categories it can
access.  A “Miscellaneous” category will be assigned to each form
registered for Attachments to facilitate “cross–form” visibility of
Attachments.
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Datatype

An attached document can be:

A reference to any type of document stored in a
database that is accessed through a Document
Management system.

Text stored in the database containing less than 2000
characters.

Text stored in the database containing 2000
characters or more.

A file that requires other server applications to
view, such as Microsoft Word or Microsoft Excel,
image files such as .JPG files, or other types of files.
When you attach or create a File type document, the
document is loaded into the database.  When a File
document is selected, the lower half of the
Attachments window displays an  ”Open
Document” button that invokes a web browser and
passes the file to the browser.

A URL reference to a web page that you can view
with your web browser.  You must define your web
browser in the profile option Web Browser to view a
web page attachment.

File or URL

If the document is a file, specify the location of the document.  The
document will then be loaded into the database.  If the document is a
web page, specify the web page URL, such as http://www.oracle.com.

May be Changed

The May be Changed checkbox indicates if you are able to edit the
attachment.

Document Block

The document block is the section of the window below the multi–line
attachment block.  The document block displays the current document
in the attachments block, or it displays an Open Document button that
opens your document for viewing with a browser.

Document
Reference

Short Text

Long Text

File

Web Page
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To improve performance while scrolling through lists of attachments,
uncheck the coordination checkbox.  The document block will not
update until you turn coordination on again.

Attention:  If you maximize the document block window, no
other operations can be performed until you restore the block to
its original state.

Adding an Attachment

You can attach a document to any record for which attachments are
enabled, such as a supplier definition or an Order Line.
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� To attach a new document to an Oracle Applications record:

1. In an application window, query or enter a data record.

2. Choose the Attachment toolbar icon.  The Attachments window
opens.

3. Enter a category, a description, and a data type.

4. Type in your document text, or specify a file name or web page
URL.

5. Save your work.

� To attach an existing document to an Oracle Applications record:

1. In an application window, query or enter a data record.

2. Choose the Attachment toolbar icon.  The Attachments window
opens.

3. Choose the Document Catalog... button.  The Document Catalog
window opens.

4. Query an existing document.

5. Check one or more documents.

6. Choose the Attach (number of documents) button.

7. Save your work.

Viewing an Attached Document

� To view an attached document:

1. Query a record.

2. Press the Attachment toolbar icon.

3. Move your cursor to the document you want to view.  The
attachment appears in the document block or you must press the
Open Document button to see the document in a browser.
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Deleting an Attachment

When you delete an attachment, you merely remove the association
between a record and a document.  The document itself is not removed
from your file system or database.

� To delete a record’s attachment:

1. In an application window, query a data record.

2. Choose the Attachment toolbar icon.

3. Move your cursor to the document you want to delete.

4. Choose Delete from the Edit menu.

5. Save your work.

Copying an Attachment from Another Record

Oracle Applications keeps a catalog of documents that have been
attached to applications data records so far; therefore, you can take
advantage of this catalog if you want to attach an existing document to
another data record.

� To copy an attachment from another record:

1. In an application window, query the record that you want to attach
a document to.  (Don’t query the record that already has the
attachment.)

2. Choose the Attachments toolbar icon.

3. Choose Document Catalog....

4. Enter query criteria in the Attached To: field for the application
object you want to copy attachments from.

5. Choose Find.

6. Check one or more documents.

7. Choose the Attach (number of documents) button.

8. Save your work.



8 – 8 Oracle Applications User’s Guide

Uploading and Downloading Attachment Files

� To attach an existing file to an Oracle Applications record:

1. In an application window, query or enter a data record.

2. Choose the Attachment toolbar icon.  The Attachments window
opens.

3. Use the List of Values to choose a Category.

4. Optionally enter a Description.

5. Use the List of Values to choose a Data Type.

6. Use the Tab key to open the Upload window in a separate browser
window.

7. You can either enter the path for the file you want to attach or use
the Browse button to choose a file.

8. Choose OK and follow the instructions in the browser window.

9. Click on Yes in the Decision window.

� To open an uploaded attachment:

Choose the Open Document ... button
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Documents Window

Use the Documents window to add existing documents, or create new
attachments in the Document Catalog.  These documents will then be
available for use as attachments from the Attachments window.
Creating a document in the Documents window is much like creating an
attachment in the Attachments window with the addition of security,
usage, and effective date information.

Category

The category controls which forms can access the document.  Each form
that enables Attachments must list which document categories it can
access.  A “Miscellaneous” category will be assigned to each form
registered for Attachments to facilitate “cross–form” visibility of
Attachments.

Datatype

An attached document can be:

A reference to any type of document stored in a
database that is accessed through a Document
Management system.

Text stored in the database containing less than 2000
characters.

Text stored in the database containing 2000
characters or more.

A file that requires other server applications to
view, such as Microsoft Word or Microsoft Excel,
image files such as .JPG files, or other types of files.
When you attach or create a File type document, the
document is loaded into the database.  When a File
document is selected, the lower half of the
Attachments window displays an  ”Open
Document” button that invokes a web browser and
passes the file to the browser.

A URL reference to a web page that you can view
with your web browser.  You must define your web
browser in the profile option Web Browser to view a
web page attachment.

Document
Reference

Short Text

Long Text

File

Web Page
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File or URL

If the document is a file, specify the location of the document.  The
document will then be loaded into the database.  If the document is a
web page, specify the web page URL, such as http://www.oracle.com.

Usage

Specify how this document may be used.

Allows this document to be used until its Effective
Date expires.

Use this option if you are creating a document that
is meant to be modified before use.

This option limits the use of the document to one
time.

Security Type

Your attachment may be secured, so that it may only be used as an
attachment by other users that share the same Organization ID, Set of
Books, or Business Unit as those of the Owner.

Attention:  Assigning security to an Organization ID limits the
access of the document to that Organization only.  Child
Organizations will not have access.

Security Owner

Enter the name of the Owner of the document.  You can also limit the
use of the document to a single user by entering the user’s name in the
Owner field and not selecting the Share checkbox.  If you want other
users to have access to the document you must check the Share
checkbox.

Standard

Template

One–Time
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Using User Profiles

his chapter teaches you about Oracle Applications user profiles.
User profiles give you control over the behavior of certain Oracle
Applications features.  Specifically, this chapter tells you:

• How to set user profile options

• Which user profiles are common to all Oracle Applications
products
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Overview of User Profiles

A user profile is a collection of changeable options that affect the way
your applications run.  Oracle Applications establishes a value for each
option in a user’s profile when the user logs on or changes
responsibility.   Oracle Applications provides these options so that you
can alter the behavior of your applications to suit your own
preferences.

Oracle Applications uses a set of user profile options that are common
to all the application products.  In addition, each application product
has its own unique set of user profile options.  The reference guide for
your application contains a complete list and a description of each user
profile option that is specific to your application.

User profile options can be set at one or more of four levels:  Site,
Application, Responsibility, and User.  Your system administrator can
set default option values at any of these levels.

Basic Business Needs

Oracle Applications user profiles help you satisfy the following
business needs.  You should be able to:

• Set options that affect your application’s behavior to your
preference

• Modify product–specific variables that affect the functionality of
your application to suit your business environment

Major Features

User Profile Hierarchy

Oracle Applications treats user profile levels as a hierarchy, where User
is the highest level of the hierarchy, followed by Responsibility,
Application, and at the lowest level, Site.  Each user profile option
ordinarily exists at each level.  For example, Oracle Applications
provides a Site–level Printer option, an Application–level Printer
option, and so on.  Oracle Applications enforces the level hierarchy to
ensure that a higher–level option value overrides a lower–level value.
For example, if your Site–level Printer value is “New York”, but your
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User–level Printer value is “Boston”, you can be assured that your
reports print to the Boston printer.

Definitions

User Profile Options

Changeable options that affect the way your applications run.

User Profile Levels

User profile options exist at four different levels: Site, Application,
Responsibility, and User levels.  Oracle Applications treats user profile
levels as a hierarchy, where User is the highest level of the hierarchy,
followed by Responsibility, Application, and at the lowest level, Site.
Higher–level option values override lower–level option values.

Site Level

Site is the lowest profile level.  Site–level option values affect the way
all applications run at a given installation site.

Application Level

Application is the profile level immediately above Site.
Application–level option values affect the way a given application runs.

Responsibility Level

Responsibility is the profile level immediately above Application.
Responsibility–level option values affect the way applications run for
all users of a given responsibility.

User Level

User is the highest profile level and is immediately above
Responsibility.  User–level option values affect the way applications
run for a given application user.
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Determining User Profile Option Values

Your system administrator can set values for user profile options at
each profile level.  Typically, your system administrator sets Site–level
option values after installing Oracle Applications at a site.  These
Site–level option values apply until you or your system administrator
changes them.

Oracle Applications derives a run–time value for each user’s profile
option based on the value set at the highest hierarchy level.  For
example, suppose your system administrator initially set your Printer
option only at the Site and Responsibility levels.  When you sign on to
Oracle Applications, the Printer option assumes the value set at the
Responsibility level, since it is the highest–level setting for that option.
If you are not satisfied with that setting, you can set your own
preference at the User–level, since your User–level setting overrides the
Responsibility–level setting.

Note:  Some option values can only be changed by the system
administrator.  You can view the value of such a user profile
option, but you cannot modify that value.  For example, you
can view the value of the user profile option
Concurrent:Request Priority, which is set at the User–level, but
only your system administrator can modify its value for you.

If the default value of a user profile option at any level is inappropriate,
your system administrator can change it at any time.  Any change your
system administrator makes takes effect as soon as you log on again or
change responsibilities.
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Setting Your Personal User Profile 

You can change a user profile option value using the Profile Values
window.  The Menus appendix in your product’s reference guide tells
you how to navigate to this menu.

Using this window, you can display all your options and review the
values your system administrator has set for them.  You can also
change those options that are updatable if you like.  Changes you make
to a User–level profile option take effect when you either change
responsibilities or close and re–login into the application.  If changes
are made in character mode you must follow the same steps to apply
the changes to applications running in GUI mode.  Changes you make
to your User–level options are still in force when you log in again.

If you never set your own User–level option values, your user profile
options assume the Site–, Application–, Responsibility–, or User–level
values your system administrator has set for them.
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� To change a profile option value:

1. Navigate to the Profile Values window.

This window displays all your user profile options and their
values.  If you wish to display only specific user profile options,
first choose Enter from the View, Query by Example menu to enter
search criteria in the Profile Name field, then choose Run from the
View, Query by Example menu to run the search.

The name of the user profile option appears in the Profile Name
field while the Default Value field displays the run–time value of
that option.  The System Administrator sets default values for
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many of the profile options.  Some profile options may not display
a default value.

2. Move your cursor to the User Value field of the option whose value
you wish to modify.

3. Enter a new value for the option if it is updatable, or if the <List>
lamp appears, choose a value from the list of available values.

If the profile option is not updatable, the message “Item is
protected against update,” appears on the message line when you
try to change the value.  You can change most of your user profile
options; values you enter in the User Value field override values
preset by the System Administrator.  A few profile options cannot
be changed, but are displayed for informational purposes only.

For most personal profile options, Oracle Applications
automatically checks the value you enter to ensure it is valid.

Attention:  Number or date values are not validated, therefore,
you must make sure that you enter a valid value for profile options
that require a number or date; otherwise, your personal profile
option may not work as you expect.

Though you cannot delete a profile option from your personal
profile, you can clear its value (if it is updatable) by highlighting
the field and pressing [Backspace] or by choosing Clear, Field from
the Edit menu.  If you clear the value, the change does not take
effect until you sign on again or change responsibilities.

4. Choose Save from the File menu to save your change.

Your change will take effect when you either change responsibilities
or log out and log back in.
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Common User Profile Options

The following list of user profile options affects all Oracle Applications
products.  The alphabetical list includes only those options that can be
viewed and/or changed by you at the User–level using the Personal
Profile Values window.  These user profile options affect your user
interface and the behavior of Oracle Applications features, such as
concurrent processing and flexfields.

Attachment File Upload Directory  

Provides the directory path used to upload attachment files.  Your
System Administrator sets this profile option during the install process.

Only the System Administrator can update this profile option.

Concurrent:Attach URL  

Setting this option to ”Yes” causes a URL to be attached to request
completion notifications.  When a user submits a request, and specifies
people to be notified in the Defining Completion Options region,
everyone specified is sent a notification when the request completes.  If
this profile option is set to Yes, a URL is appended to the notification
that enables them to view the request results on–line.

Only the System Administrator can update this profile option.

Concurrent:Hold Requests

You can automatically place your concurrent requests on hold when you
submit them.

The default is “No.”  The concurrent managers run your requests
according to the priority and start time specified for each.

Changing this value does not affect requests you have already
submitted.

“Yes” means your concurrent requests and reports are automatically
placed on hold.  To take requests off hold, you:

• Navigate to the Requests window to select a request

• Click on the ”Remove Hold” button
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Concurrent:Multiple Time Zones

”Yes” sets the default value to ”Sysdate–1” for the ”Scheduled Start
Date” used by request submissions.  Sysdate–1 ensures that your
request is scheduled immediately regardless of which time zone your
client session is running in.  You should use this profile option when the
client’s session is running in a different time zone than the concurrent
manager’s session.

Concurrent:Report Access Level

Determines access privileges to report output files and log files
generated by a concurrent program.  This profile option can be set by a
System Administrator to User or Responsibility.

If your Concurrent:Report Access Level profile option is set to ”User”
you may:

• View the completed report output for your requests online.

• View the diagnostic log file for those requests online (the system
administrator also has this privilege).

• Reprint your completed reports, if the Concurrent:Save Output
profile option is set to ”Yes.”

• If you change responsibilities, then the reports and log files
available for online review do not change.

If your Concurrent:Report Access Level profile option is set to
”Responsibility,” access to reports and diagnostic log files is based on
your current responsibility.

• If you change responsibilities, then the reports and log files
available for online review change to match your new
responsibility.  You can always see the output and log files from
reports you personally submit, but you also see reports and log
files submitted by any user from the current responsibility.

Only the System Administrator can update this profile option.

Concurrent:Report Copies

You can set the number of output copies that print for each concurrent
request.  The default is set to 1.

• Changing this value does not affect requests that you have
already submitted.
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Concurrent:Request Priority

This displays the default priority number for your concurrent requests.
Only a system administrator can change your request priority.

Requests normally run according to start time, on a “first–submitted,
first–run” basis.  Priority overrides request start time.  A higher priority
request starts before an earlier request.

Priorities range from 1 (highest) to 99 (lowest).  The standard default is
50.

Only the System Administrator can update this profile option.

Concurrent:Request Start Time

You can set the date and time that your requests are available to start
running.

• If the start date and time is at or before the current date and time,
requests are available to run immediately.

• If you want to start a request in the future, for example, at 3:45
pm on June 12, 1998, you enter 12–JUN–1998 15:45:00 as the
profile option value.

• You must include both a date and a time.

• Changing this value does not affect requests that you have
already submitted.

Concurrent:Save Output

The Concurrent: Save Output profile is used to determine whether the
default behavior of certain concurrent programs should be to save or to
delete their output files.  This only affects concurrent programs that
were created in the character mode versions of Oracle Applications and
that have a null value for ”Save Output.”

• ”Yes” saves request outputs.

• Some concurrent requests do not generate an output file.

• If your request output is saved, you can reprint a request.  This is
useful when requests complete with an Error status: for example,
the request runs successfully but a printer malfunctions.

• Changing this value does not affect requests you have already
submitted.
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Concurrent:Sequential Requests

You can force your requests to run one at a time (sequentially) according
to the requests’ start dates and times, or allow them to run concurrently,
when their programs are compatible.

• Concurrent programs are incompatible if simultaneously
accessing the same database tables incorrectly affects the values
each program retrieves.

• When concurrent programs are defined as incompatible with one
another, they cannot run at the same time.

“Yes” prevents your requests from running concurrently.  Requests run
sequentially in the order they are submitted.

“No” means your requests can run concurrently when their concurrent
programs are compatible.

Changing this value does not affect requests you have already
submitted.

Concurrent: Show Requests Summary After Each Request
Submission

Using this new profile option, you can choose to either have the
Requests Summary displayed each time you submit a request, or retain
the request submission screen.

The default is “Yes”.  “Yes” means the Requests Summary screen is
displayed each time you submit a request.

If you choose ”No”, a decision window is opened asking you if you
wish to submit another request.  When you choose to submit another
request you are returned to the submission window and the window is
not cleared, allowing you to easily submit copies of the same request
with minor changes.

Concurrent:Wait for Available TM

You can specify the maximum number of seconds that the client will
wait for a given transaction manager (TM) to become available before
moving on to try a different TM.

Concurrent:URL Lifetime  

The numeric value you enter for this profile option determines the
length of time in minutes a URL for a request ouput is maintained.
After this time period the URL will be deleted from the system.  This
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profile option only affects URLs created for requests where the user has
entered values in the notify field of the Submit Request or Submit
Request Set windows.

Attention:  All request ouput URLs are deleted when the Purge
Concurrent Requests and Manager... program is run even if the
URL liftime has not expired.

Currency:Negative Format

You can use different formats to identify negative currency.  The default
identifier is a hyphen ( – ) preceding the currency amount, as in ”–xxx”.
You can also select:

Angle brackets < > < xxx >

Trailing hyphen – xxx –

Parentheses ( ) ( xxx )

Square Brackets [ ] [ xxx ]

If you use the negative number formats of “(xxx)” or “[xxx],” in Oracle
Applications Release 11 and after, your negative numbers appear as
“<xxx>”.

Note:  Currency:Negative Format only affects the display
currency.  Non–currency negative numbers appear with a
preceding hyphen regardless of the option selected here.

Currency:Positive Format

You can use different formats to identify positive currency values.  The
default condition is no special identifier.

Currency:Thousands Separator

You can separate your currency amounts in thousands by placing a
thousands separator.  For example, one million appears as 1,000,000.

Default Country

This is the default source for the Country field for all address zones and
is used by the Flexible Address Formats feature, the Flexible Bank
Structures feature and the Tax Registration Number and Taxpayer ID
validation routines.
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The profile can be set to any valid country listed in the Maintain
Countries and Territories form and can be set to a different value for
each user.

Flexfields:AutoSkip

You can save keystrokes when entering data in your flexfields by
automatically skipping to the next segment as soon as you enter a
complete valid value into a segment.

• “Yes” means after entering a valid value in a segment, you
automatically move to the next segment.

• “No” means after entering a valid value in a segment, you must
press [Return] to go to the next segment.

Note:  You may still be required to use tab to leave some
segments if the valid value for the segment does not have the
same number of characters as the segment.  For example, if a
segment in the flexfield holds values up to 5 characters and a
valid value for the segment is 4 characters, AutoSkip will not
move you to the next segment.

Flexfields:BiDi Direction

This profile option controls the appearance of the flexfields window in
Applications running in Semitic languages.  Possible values are ”Left To
Right” and ”Right To Left”.  If the profile option is not defined on a
particular installation, the default value is ”Right To Left”, where the
window appears in a normal, left to right fashion, and the text and
layout are reversed to accommodate the right–to–left nature of the
Semitic language environment.

Flexfields:LOV Warning Limit

Use Flexfields:LOV Warning Limit to improve efficiency when
retrieving a list of values.

Sometimes, particularly when no reduction criteria has been specified,
an LOV can take a very long time to run if there is a very significant
amount of data in it.  Set this profile option to the number of rows to be
returned before the user is asked whether to continue retrieving the
entire list.
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Flexfields:Open Descr Window

You can control whether a descriptive flexfield window automatically
opens when you navigate to a customized descriptive flexfield.

• “Yes” means that the descriptive flexfield window automatically
opens when you navigate to a customized descriptive flexfield.

• “No” means that when you navigate to a customized descriptive
flexfield, you must choose Edit Field from the Edit menu or use
the List of Values to open the descriptive flexfield window.

Note:  This profile option does not apply to descriptive
flexfields in folders.

Flexfields:Shorthand Entry

If shorthand flexfield entry is defined for your flexfield, you can use a
shorthand alias to automatically fill in values for some or all of the
segments in a flexfield.

Shorthand Entry is not available for any flexfields
for this user, regardless of whether shorthand
aliases are defined.

Shorthand Entry is available for entering new
records in most foreign key forms.  It is not
available for combinations forms, updating existing
records, or entering queries.

Shorthand Entry is available for entering new
records or for entering queries.  It is not available
for updating existing records.

Shorthand Entry is available for entering new
records or updating old records.  It is not available
for entering queries.

Shorthand Entry is available for inserting, updating,
or querying flexfields for which shorthand aliases
are defined.

Flexfields:Show Full Value

If an alias defines valid values for all of the segments in a flexfield, and
Flexfields: Shorthand Entry is enabled, when you enter the alias the
flexfield window does not appear.

”Yes” displays the full flexfield window with the cursor resting on the
last segment.

Not Enabled

New Entries Only

Query and New
Entry

All Entries

Always
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Flexfields:Validate On Server

This profile option is set to ”Yes” to enable server side, PL/SQL
flexfields validation for Key Flexfields.  This improves performance
when using Key Flexfields over a wide area network by reducing the
number of network round trips needed to validate the entered segment
combinations.

FND: Indicator Colors

The default for this profile option is null, which means ”Yes.”  When this
profile option is set to Yes:

• Required fields are displayed in yellow.

• Queryable fields are displayed in a different color while in
enter–query mode.

• Fields that cannot be entered (read–only) are rendered in dark
gray.

Folders:Allow Customization

Your system administrator controls whether you can create or customize
a folder definition layout in folder block.

• “Yes” means that you can create or customize a folder definition,
that is, the entire Folder menu is enabled in the folder block.

• “No” means that you can only open an existing folder definition
in a folder block, that is, only the Open option is enabled in the
Folder menu.

Only the System Administrator can update this profile option.

Forms Keyboard Mapping File

Use this profile option to define the path of the Keyboard Mapping File.

The ”Keyboard Help” window displays the keystrokes to perform
standard Forms operations, such as ”Next Block” and ”Clear Record.”
This window can be viewed at anytime by pressing [Ctrl]+[K].  The
keyboard mappings can be customized as desired by your System
Administrator.
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Forms Runtime Parameters

Use this profile to specify certain runtime parameters.  The profile value
must be entered in as parameter=value with each parameter–value
pair separated by a single space. For example:

record=collect log=/tmp/frd.log debug_messages=yes

In order for the parameters updated in this profile option to take effect,
you must exit and log back in to Oracle Applications.

Indicate Attachments

This profile option allows you to turn off indication of attachments
when querying records (for performance reasons).

Only the System Administrator can update this profile option.

Java Color Scheme

If the Java Look and Feel profile option is set to Oracle, the Java Color
Scheme can be specified as one of the following:

• Teal

• Titanium

• Red

• Khaki

• Blue

• Olive

• Purple

The Java Color Scheme profile setting has no effect if the Java Look and
Feel is set to Generic.

Java Look and Feel

Your Oracle Applications Professional User Interface can be run with
either the Oracle Look and Feel or the Generic Look and Feel.  The
Oracle Look and Feel consists of a new look and feel for each item, and a
predefined set of color schemes.  The Generic Look and Feel adheres to
the native interface and color scheme of the current operating system.

To specify the look and feel set this profile to Generic or Oracle.

If the Oracle Look and Feel is used, the profile Java Color Scheme can be
set.
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MO: Operating Unit

Determines the Operating Unit the responsibility logs onto.

Printer

You can select the printer which prints your reports.  If a printer cannot
be selected, contact your system administrator.  Printers must be
registered with Oracle Applications.

Sequential Numbering

Sequential Numbering assigns numbers to documents created by forms
in Oracle financial products.  For example, when you are in a form that
creates invoices, each invoice document can be numbered sequentially.

Sequential numbering provides a method of checking whether
documents have been posted or lost.  Not all forms within an
application may be selected to support sequential numbering.

Sequential Numbering has the following profile option settings:

You may not enter a document if no sequence exists
for it.

You may always enter a document.

You will be warned, but not prevented from
entering a document, when no sequence exists.

Only system administrators can change this profile option.

Session ID

This runtime profile option contains the session ID number of the last
database session that was created.

Sign–On:Notification

”Yes” displays a message at login that indicates:

• If any concurrent requests failed since your last session,

• How many times someone tried to log on to Oracle Applications
with your username but an incorrect password, and

• When the default printer identified in your user profile is
unregistered or not specified.

Always Used

Not Used

Partially Used
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Viewer: Default Font Size

Using this new profile option, you can set the default font size used
when you display report output in the Report Viewer.

The valid values for this option are 6, 8, 10, 12, and 14.

Viewer: Text

The Viewer: Text profile option has been enhanced to allow you to send
report output directly to a browser window.  Enter ”Browser” in this
profile option to take advantage of this new feature.

See:  Profile Options in Oracle Applications Object Library: Oracle
Applications System Administrator’s Guide

Viewer: PostScript, PDF, and HTML

You can use the viewer of your choice when reviewing online the log
and output files from your concurrent requests.  In almost all cases, you
need to specify different viewers for reviewing postscript (bitmap) files,
PDF files, and HTML files.

To link the Oracle Applications concurrent processing facility with a
postscript, PDF, or HTML, with the appropriate application installed on
your computer, enter as the profile option value one of the following:

• Name of the application’s executable file, when the file can be
found in your computer’s default path (for example, write.exe).

• Full path to the application’s executable file, when the file is not
found in your computer’s default path (for example,
c:\windows\bin\write.exe).

You should also enter any required parameters that may be necessary to
invoke the application in a particular mode.

Attention:  In a client–server environment, PC clients can
access log and output files on the servers by using either a
Report Review Agent or a PC–NFS mount.

Only system administrators can change this profile option.
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Oracle Applications
Menus

his appendix provides you with a description of each menu item
listed on the menus of the main menu bar.
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Oracle Applications Pulldown Menu Bar

The Oracle Applications main menu bar includes the following menus:

• File

• Edit

• View

• Folder

• Tools;  Special A and Special B

• Window

• Help

File Menu

The File menu lets you perform several actions in Oracle Applications:

Opens a new record in the active form.

Opens the detail screen for the current selection.

Saves any pending changes in the active form.

Saves any pending changes in the active form and
advances to the next record.

Updates the Process workflow in the Navigator by
advancing to the next step in the process.

Exports information in the active block to a
tab–separated file which can be opened in a web
browser or spreadsheet.

Creates an Icon in the Documents tab of the
Navigator which can be used to recall the active
form and its current record.

Exits the application and displays the Oracle
Applications Logon window.  This feature is not
available when you sign on using the Personal
Homepage.

Closes all active windows and displays the
Responsibility window.

New

Open

Save
Save and Proceed

Place on Navigator

Switch Responsibility...

Exit Oracle Applications

File

Close Form

Print...

Log on as a Different User...

Next Step
Export

New

Open

Save

Save and
Proceed

Next Step

Export

Place on
Navigator

Log on as a
Different User

Switch
Responsibility
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Prints your current window.  An application may
override this action to allow printing of one or
more specific reports.

Closes all windows of the current form.

Quits Oracle Applications.

Edit Menu

Use the Edit menu to edit your data in Oracle Applications:

Returns the field to the value it had when it gained
focus.

Cuts the current selection to the clipboard.

Copies the current selection to the clipboard.

Pastes the contents of the clipboard into the current
field.

Copies all values from the prior record to the
current record.

Copies the value of the current field from the prior
row.

Erases the current record from the window.

Clears the data from the current field.

Erases all records from the current block.

Erases any pending changes from the current form.

Deletes the current record from the database.

Selects all records (for blocks with multi–select).

Deselects all selected records except for the current
record (for blocks with multi–select).

Displays the Editor window for the current field.

Displays the Change Password dialog box.

Displays the Profiles window.

Print...

Close Form

Exit Oracle
Applications

Clear 

Duplicate 

Delete

Edit

Edit Field...

Select All

Deselect All

Undo Typing

Preferences 

Record Above
Field Above

Field
Record

Block
Form

Profiles
Change Password...

Cut

Copy

Paste

Undo Typing

Cut

Copy

Paste

Duplicate:
Record Above

Duplicate: 
Field Above

Clear Record

Clear Field

Clear Block

Clear Form

Delete

Select All

Deselect All

Edit Field...

Preferences:
Change Password

Preferences:
Profiles
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View Menu

The View menu provides you with the following options:

Displays the Navigator window.

Invokes custom defined zooms.

Displays the Find window to retrieve records.

Retrieves all records.

Invokes ”Enter Query” mode to enter search
criteria for a query–by–example.

Executes the query–by–example.

Cancels the query–by–example by exiting from
’Enter Query’ mode.

Recovers the search criteria used in the previous
query–by–example.

Counts the number of records that would be
retrieved if you ran the current query–by–example.

Moves the cursor to the first record.

Moves the cursor to the last record.

Displays the Translations window.

Displays the Attachments window.

Switches between the summary and detail views of
a combination block.

Displays the Request window.

See Also

Searching for Information: page 3 – 22

Find...

Record 

Translations...

Attachments...

Summary/Detail

View

Find All

Show Navigator
Zoom

Query by Example 

Requests

Enter
Run
Cancel

Show Last Criteria
Count Matching Records

First
Last

Show Navigator

Zoom

Find...

Find All

Query by
Example: Enter

Query by
Example: Run

Query by
Example: Cancel

Query by
Example: Show
Last Criteria

Query by
Example: Count
Matching
Records

Record First

Record Last

Translations...

Attachments...

Summary/Detail

Requests
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Folder Menu

The Folder menu lets you customize the presentation of data in a
folder:

Creates a new folder definition.

Opens an existing folder definition.

Saves changes to the current folder definition.

Saves current folder definition to a new name.

Deletes an existing folder definition.

Displays a field that is currently hidden.

Hides the current field.

Moves the current field to the right.

Moves the current field to the left.

Moves the current field up.

Moves the current field down.

Increases the width of the current field.

Decreases the width of the current field.

Changes the prompt for the current field.

Adjusts all field widths to completely show their
data.

Specifies sort order for the first three fields by
ascending, descending and no ordering.

Displays the query criteria for the current folder
definition.

Erases the current query criteria.

Displays the folder tool palette.

See Also

Customizing the Presentation of Data in a Folder: page 4 – 2

New...

Open...

Save

Save As...

Delete...

Show Field...

Hide Field

Move Right

Folder

Move Left

Move Up

Move Down

Widen Field

Shrink Field

Change Prompt...

Autosize All...

Sort Data...

View Query...

Reset Query

Folder Tools

New...

Open...

Save

Save As...

Delete...

Show Field...

Hide Field

Move Right

Move Left

Move Up

Move Down

Widen Field

Shrink Field

Change Prompt...

Autosize All...

Sort Data...

View Query...

Reset Query

Folder Tools
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Tools and Special Menus

The Tools menu displayed on the left represents the pulldown options
available when the Navigator window is active.

Special menus A and B (default set to Reports and Actions) used in
addition to the Tools menu are user configurable to allow the addition
of application–specific commands.  These menus can be removed if
they are not needed by the application.

The menus may contain up to fifteen product–specific entries.
Examples of product–specific entries may include a list of commonly
used Inquiry windows in the application, or a commonly used window
that a user may want to display for a quick reference.

Window Menu

The Window menu displays the names of all open application windows
and window placement options.

Displays any open windows in a ”cascaded” or
stair–stepped fashion.

Displays any open windows in a horizontally
”tiled” (non–overlapping) fashion.

Displays any open windows in a vertically ”tiled”
(non–overlapping) fashion.

Displays a list of open windows titles in the order
in which they are stacked.

Tools

Expand

Collapse

Expand Branch

Expand All
Collapse All

Add to List
Remove from List

�  Close Other Forms

Special

special1

special2

special3

special4
...

Window

Cascade

Tile Horizontally

Tile Vertically

� 1  (Open Window)

� 2  (Open Window)

� 3  (Open Window)

Cascade

Tile Horizontally

Tile Vertically

1  (Open
Window)
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Help Menu

Use the Help menu to get additional information about Oracle
Applications:

Displays help for the current window.

Displays a window that lists all available Oracle
Applications help text. 

Displays the current key mappings of specific
functions and menu options.

All of the entries in these menus are used for
debugging.  You may be asked to use some of these
functions if you need to contact Oracle Support.
You may not have access to all of these functions.
See your System Administrator for additional
information.

Displays the last database
error.

Displays the underlying Oracle
Forms block and item
corresponding to a field on the
form.

Launches the generic logging
system pages.

Performs a check of the Web
Agent to determine if it is
configured properly.

Turns SQL*Trace on and off
with different parameters.
SQL*Trace provides
performance information on
individual SQL statements.

Turns on the Oracle Forms
Debugger, provided the form
you are currently in was
started in debug mode.

The Properties submenu
provides diagnostic

Window Help

Oracle
Applications
Library

Keyboard Help...

Diagnostics  

Display Database
Error

Examine

Logging

Test Web Agent

Trace

Debug

Properties  
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information for Items and
Folders.

Displays the values for
properties of the current item.

Writes diagnostic information
about the current folder to a
file in the temporary directory.

The Custom Code submenu is
an option group, allowing you
to change the mode of the
custom library.

The custom library is used.
This is the default.

Turns the custom library off,
disabling Zooms and any other
custom code.

When this option is set,
APPCORE will bypass
branching into the custom
libraries and bypass branching
into the vertical libraries.

This option will display
messages at runtime to
indicate which events are
passed to the custom library.

Displays information about the current record.

Displays information about the current application,
including version and environment information.

Menu Mapping from Release 11 to 11i

The following tables cross–refererence the Release 11 menu functions to
the new Release 11i menu functions.

Item

Folder

Custom Code  

Normal

Off

Core Code Only

Show Custom
Events

Record History

About Oracle
Applications...
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The Action Menu

Release 11 Release11i

Action > Navigate To... View > Show Navigator

Action > Zoom View > Zoom

Action > Save File > Save

Action > Save and Proceed File > Save and Proceed

Action > Print... File > Print...

Action > Export... File > Export

Action > Refresh Not Available

Action > Close Window (Other) > Use native controls

Action > Close Form File > Close Form

Action > Exit Oracle Applications File > Exit Oracle Applications

The Edit Menu

Release 11 Release11i

Edit > Cut Edit > Cut

Edit > Copy Edit > Copy

Edit > Paste Edit > Paste

Edit > Clear Field Edit > Clear > Field

Edit > Duplicate Field Above Edit > Duplicate > Field Above

Edit > List of Values... (Other) > Use LOV button next to field

Edit > Edit Field... Edit > Edit Field

Edit > New Record File > New

Edit > Delete Record Edit > Delete

Edit > Clear Record Edit > Clear > Record

Edit > Duplicate Record Above Edit > Duplicate > Record Above

Edit > Translations... View > Translations...

Edit > Attachments... View > Attachments...

Edit > Select All Edit > Select All
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Release11iRelease 11

Edit > Deselect All Edit > Deselect All

Edit > Clear Block Edit > Clear > Block

Edit > Clear Form Edit > Clear > Form

The Go Menu

Release 11 Release11i

Go > Next Field (Other) > Tab

Go > Previous Field (Other) > Shift>Tab

Go > Next Record (Other) > Down Arrow on keyboard

Go > Previous Record (Other) > Up Arrow on keyboard

Go > First Record View > Record > First

Go > Last Record View > Record > Last

Go > Next Block (Other) > Use Cntrl>K for keyboard mapping

Go > Previous Block (Other) > Use Cntrl>K for keyboard mapping

Go > Summary/Detail File > Open

The Folder Menu

Release 11 Release11i

Folder

Folder > Unchanged Folder > Unchanged

The Query Menu

Release 11 Release11i

Query > Find... View > Find...

Query > Find All View > Find All

Query > Enter View > Query by Example > Enter

Query > Run View > Query by Example > Run
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Release11iRelease 11

Query > Cancel View > Query by Example > Cancel

Query > Show Last Criteria View > Query by Example > Show Last Criteria

Query > Count Matching Records View > Query by Example > Count Matching
Records

Query > Get More Records (Other) > Use the slide control on the scroll bar

The Special Menu

Release 11 Release11i

Special > first special Tools > first tools

The Window Menu

Release 11 Release11i

Window > Cascade Window > Cascade

Window > Tile Window > Tile

Window > Arrange Icons Not Available

Window > first window Window > first window

The Help Menu

Release 11 Release11i

Help > Window Help Help > Window Help

Help > Oracle Applications Library Help > Oracle Applications Library

Help > Keyboard Help... Help > Keyboard Help...

Help > Display Database Error... Help > Diagnostics > Display Database Error...

Help > Tools Help > Diagnostics

Help > View My Requests View > Requests

Help > About This Record... Help > Record History

Help > About Oracle Applications Help > About Oracle Applications
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New for Release 11i

Release 11i provides several new menu functions. The following table
lists these menu items and their actions:

Menu Item Action

Edit > Undo Typing Undoes any typing done in a field before the field is exited and returns
the field to the most recent value.

Edit > Preferences >
Change Password

Displays the Change Password dialog box.

Edit > Preferences >
Profiles

Displays the Profiles window.

File > Next Step Saves and pending changes in the active form and updates the Process
workflow in the Navigator.

File > Place on
Navigator

Creates and icon in the Documents Tab region of the Navigator which
can be used to recall the active form and its current record.

File > Change Log On Exits the applicaitons and displays the Oracle Applications Logon
window.

File > Switch
Responsibility

Displays the Responsibility window.
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Personal Homepage in
Oracle Applications

his appendix describes features of the Personal Homepage
including:

• Using the Personal Homepage in Oracle Applications

• Customizing the Personal Homepage
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Personal Homepage in Oracle Applications

The Personal Homepage provides a customizable point of entry into
Oracle Applications.

Welcome Toolbar

The Welcome toolbar contains icons for the following functionality:

The Help icon opens the online help window

The Create and Modify Pages icon opens the Maintain Pages
window where you can create and modify tab pages within the
Personal Homepage

The Exit icon returns you to the login screen

Tab Pages

The Personal Homepage consists of one or more tab pages.  Each tab
page is laid out in regions.  The content of each region consists of
”plugs” (for example, Favorites, Navigate, and Ask Oracle).

The default tab page is called ”Main Menu” and it cannot be deleted.

To add, delete, or edit the tab pages, click on the ”Create and Modify
Pages” icon on the Welcome toolbar.

Some plugs allow customization.  These will display a Customize icon
on the title bar of the plug.  Click on the icon to view and select options
for the plug.

Navigation and Favorites

The Navigate plug provides a list of links to responsibilities either in
the Oracle Applications or the Self Service Applications.  The
Preferences link lets you set global options such as your password and
language.

The Favorites plug allows you to place links to your favorite web
destinations in a single region of the tab page.  You can place your
favorite reports, news services, corporate intranet sites, or other
systems you may need in this region.
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Worklist

The Worklist includes notifications that are of interest to you, based on
criteria you specify by customizing this feature.  Each message is time
and date stamped.  You can sort your notifications by subject, due date,
sent date, type, or priority.

Ask Oracle

Using Ask Oracle you can search for reports of interest to you, since an
important decision–making dynamic is to consider related subjects
while reviewing specific facts.  Enter keywords or questions in the Ask
Oracle text box and click on the Ask Oracle button.  A list of reports
and business questions that meet your criteria will be displayed.

The Oracle Business Intelligence System presents information from a
complete enterprise–wide perspective on an up–to–date basis without
staff spending time filtering the data and preparing one–time reports.

Business Views Catalog

Business Views Catalog allows you to search for business views of
interest to you.  Enter keywords in the Business Views Catalog text box
and click on the Search Views button.  A list of business folders and
business areas with descriptions that meet your criteria will be
displayed.

Performance Measures

The Performance Measure feature allows you to view BIS
measurements of interest to you.  The Target value and the Actual
value are displayed for each measure.

See Also

Customizing the Personal Homepage: page B – 5
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Customizing the Personal Homepage

You can configure your homepage by creating regions and specifying
the content of each region.

Use the icons provided to modify the content, location, and size of each
region.

Maintaining Tab Pages

To add, delete, or edit the tab pages, click on the ”Create and Modify
Pages” icon on the Welcome toolbar.

You then see the Maintain Pages window.  In this window you can
perform the following functions:

� To create a new page:

� Use the New button and enter in a new page name in the proper
field.

� To edit an existing page:

� Select a page from the list, and click the Edit button.  This button
opens up the Customize page window.  See Customizing a Tab
Page: page B – 5.

� To rename a page:

� Select a page from the list, and click the Rename button.

� To delete a page:

� Select a page from the list, and click the Delete button.

� To copy a page as a template for a new page:

� Use the Copy Template button.  You will then be prompted to
select which page you wish to copy and to enter a name for the
new page.
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� To change and save the ordering of your pages:

� By selecting a page name in the list and using the up and down
arrows, you can change the order of the pages.  The pages appear
in this order on your Personal Homepage.

� To save your changes, click the Save Order button.

Customizing a Tab Page

To customize a tab page, click on the Modify Page Content and
Appearance icon in the corner of the tab.  This will open the Customize
Page window.

The following icons will be displayed for each region on the tab page:

Click the Edit Content icon to open up a window listing available
plugs.  You can add one or more of these plugs to a region.

Click the Edit Appearance icon to change the width of the region
and specify whether to show a border around it.

Click the Add Row icon to add a region as a new row beneath the
selected region.  You can delete a region by using the Delete icon.

Click the Add Column icon to add a region as a new column
beside the selected region.  You can delete a region by using the
Delete icon.

Click the Delete icon to delete a plug or a region.

Click the Rename icon to rename the instance of the plug within a
region.

Preferences

There are several choices you can make about how you want to view
information in Oracle Applications. These choices include languages,
date formats, and number formats.

To access your preferences, choose the Preferences link. For information
on your preference options, see Preferences: page 1 – 12.
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Extensible Links Forms

Extensible links allow the user to customize each Related Information
section within each report with the information they choose.  When
using a particular report, the user can navigate to other related reports,
workbooks, or URL links, which can provide different perspectives.

The extensible links design is intended to externally model and
configure a web of links metaphor in Oracle Applications UI.  The
extensible links architecture uses a generic repository–based approach
to handle this.  The extensible links component has a set of tables that
stores information about the various reports and their related reports.
Parameter values can be stored in these tables as well.

Parameter Passing

Parameter Passing allows the user to enter specific parameters for a
particular report.  Those parameters are then stored in a runtime
repository, and can be passed or saved to another report or workbook.
Reports pass parameters between each other.  A drill–down report
receives all parameters that are applicable to its parameter and
dimension level.  For example, a report could receive the value USA
and know that this corresponds to the Geography dimension and
country level.  The View–By value is also passed for use by the child
report, when applicable.

When a child (drill–down) report does not receive enough values to
run, it displays the parameter form prefilled with any provided values.
If the parent report provides values that the child report does not use,
the values are ignored.  If the report needs more parameters for the
user to determine in which mode the report is running, the report may
be set not to run automatically.

At any point, the user should be able to change the set of parameters
being used.  This change will be reflected in any downstream reports.

User–Defined Links to BIS Reports

BIS Reports include links to related reports to which the user can
navigate.  The user can define these links and configure them
dynamically without rewriting the reports.
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User–Defined Links to Discoverer Workbooks

Users can define and configure links to Discoverer workbooks from a
report.

Indicators Region

The Indicators region is the management navigation area for your
business information.  From here you can monitor items of ongoing
interest and personal accountability.  From this area, you can select
from the full collection of enterprise–wide KPIs.

Authorized users define targets that are stored in the Performance
Management Framework.  They represent current performance
objectives for the overall enterprise or a specific business unit.  If the
performance deviates from the acceptable defined targets, then
notifications are sent to the manager.

Monitoring PMF Actuals on the Personal Home Page

To monitor Actuals (that is, a performance measure’s value):

1. Click on ”Customize” on the Performance Monitor region.

2. Click on ”Available Target Levels” from the ”Target Level” screen
that you want to monitor.

3. Click on ”Continue.”

4. Choose all dimension level values (from the list of values).

5. Choose the appropriate ”Business Plan.”

6. Input your personalized label in the ”Display Label Field.”

7. Click on the ”Edit” button if corrections need to be made (via
pop–up windows).

8. Click on ”Done” when finished.

This will return you to the Personal Homepage where you can see
your newly customized PM region.

9. Follow the same steps as above to customize a label on the
Performance Measure region.
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Trends Region

You can view trends of particular interest to your business.  You can
drill down into the detail of each graph simply by clicking on it.  The
graph will bring you to the corresponding report.  You can personalize
your homepage to include as many graphs as you like.
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Accessibility

his appendix discusses the features available in Oracle
Applications to enhance user accessibility.
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Oracle Applications Accessibility Features

General Features

The Look and Feel of the User Interface

The Oracle Applications Professional User Interface can be run with
either the Oracle Look and Feel or the Generic Look and Feel.  The
Oracle Look and Feel consists of a new look and feel for each item, and
a predefined set of color schemes.  The Generic Look and Feel adheres
to the native interface and color scheme of the current operating
system.  The choice of look and feel has an impact on accessibility
features.  In general, the Oracle Look and Feel is the more accessible of
the modes.  Only low–vision users should find it necessary to use the
generic look and feel.

To specify look and feel, set the profile option ”Java Look and Feel” to
either ”generic” or ”oracle”.  If the oracle look and feel is used, the
profile option ”Java Color Scheme” can be specified as follows: blue,
khaki, olive, purple, red, teal, or titanium.  The Java Color Scheme
profile option has no effect if Java Look and Feel is set to generic.

Navigating the Interface

Oracle Applications offers a feature that can render the current screen
in a compressed, text–only fashion.  By invoking the ”KEY–F9”
function, all of the prompts and values of items in the current window
(but just the current row for multi–row blocks) are displayed within a
popup window in a text–only format.  Each row can be spoken by a
screen reader.  Included in this list are the values of display items or
disabled items that otherwise would not be easily discernible with a
screen reader because they are not keyboard–navigable.

Similarly, the ”KEY–F8” function shows a list of all buttons within the
window and their access keys, which otherwise would not be
obtainable if they were not navigable.

Note:  The KEY–F8 and KEY–F9 functions may not be mapped
to the corresponding function keys in your system.  Use the
Keys window (Help > Keyboard Help... or Ctrl+k) to view the
current mappings for your system.
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Specific Accessibility Techniques

Techniques for Low–Vision Users

Low–vision users may find it necessary to control the overall colors of
the application, either to increase or decrease the contrast.  They can set
the desired colors using the operating system’s provided schemes, then
specify ”generic” in the Java Look and Feel profile option so that Oracle
Applications will use these colors.

Oracle Applications by default renders required fields in yellow,
queryable fields in a different color while in enter–query mode, and
fields that cannot be updated (read–only fields) in gray.  To turn off
these features when running Oracle Applications Professional User
Interface, set profile FND: Indicator Colors to ”No”.

Techniques for Physically Disabled Users

Tabs in Oracle Applications can be switched from the keyboard by
using the ”List Tab Pages” function (typically F2).

Oracle Applications includes a feature that renders an iconic button
next to each field that has an LOV.  The LOV can also be invoked from
the keyboard by pressing the ”List of Values” access key (typically
Ctrl+l).

The ”Keys” window displays the keystrokes to achieve normal
Applications operations, such as ”Next Block” and ”Clear Record.”
This window can be viewed any time by pressing Ctrl+k.

Oracle Applications provides the profile option ”Forms Keyboard
Mapping File” to allow a customized keyboard mapping file to be used
through the Professional User Interface.  The keyboard mappings can
be customized as follows:

1. Locate the Oracle Forms resource file on the middle tier, typically
called fmrweb.res (This step will typically be performed by a
System Administrator)

2. Copy the file, renaming it as appropriate, and locate it in the same
directory as the original.

3. Open the new file in any text editor and make the desired
keystroke mapping changes.  Comments at the top of the file
explain how the mappings are performed.

4. To run this new mapping file, specify the complete path in addition
to the filename in the profile ”Forms Keyboard Mapping File.”
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Glossary

Accounting Flexfield   The code you use to
identify a general ledger account in an
Oracle Financials application.  Each
Accounting Flexfield value corresponds to
a summary or rollup account within your
chart of accounts.

Action Set   A sequence of alert actions that
are enabled for a particular alert.  You can
assign a sequence number to each action
you include in an action set to specify the
order in which the actions are performed.

Alert   A mechanism that checks your database
for a specific exception condition.  An alert
is characterized by the SQL SELECT
statement it contains.  A SQL SELECT
statement tells your application what
database exception to identify as well as
what output to produce for that exception.

Alert Action   An action you want your alert
to perform.  An alert action can depend on
the output from the alert.  An action can
include sending an electronic mail message
to a mail ID, running an Oracle
Applications program, running a program
or script from your operating system, or
running a SQL script to modify information
in your database.  You can have more than
one action for an alert, and an action can
incorporate the output of the alert.

alternative region  An alternative region is one
of a collection of regions that occupy the
same space in a window where only one
region can be displayed at any time.  You
identify an alternative region by a poplist
icon that displays the region title, which sits
on top of a horizontal line that spans the
region.

AutoReduction  An Oracle Applications
feature in the list window that allows you
to shorten a list so that you must scan only
a subset of values before choosing a final
value.  Just as AutoReduction incrementally
reduces a list of values as you enter
additional character(s), pressing
[Backspace] incrementally expands a list.

AutoSelection  A feature in the list window
that allows you to choose a valid value
from the list with a single keystroke.  When
you display the list window, you can type
the first character of the choice you want in
the window.  If only one choice begins with
the character you enter, AutoSelection
selects the choice, closes the list window,
and enters the value in the appropriate
field.
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AutoSkip  A feature specific to flexfields
where Oracle Applications automatically
moves your cursor to the next segment as
soon as you enter a valid value into a
current flexfield segment.  You can turn this
feature on or off with the user profile
option Flexfields:AutoSkip.

balancing segment  An Accounting Flexfield
segment that you define so that Oracle
General Ledger automatically balances all
journal entries for each value of this
segment.  For example, if your company
segment is a balancing segment, Oracle
General Ledger ensures that, within every
journal entry, the total debits to company 01
equal the total credits to company 01.  

block  Every Oracle Applications window
(except root and modal windows) consists
of one or more blocks.  A block contains
information pertaining to a specific
business entity.  Generally, the first or only
block in a window assumes the name of the
window.  Otherwise, a block name appears
across the top of the block with a horizontal
line marking the beginning of the block.

business entity  A person, place, or thing that
is tracked by your business.  For example, a
business entity can be an account, a
customer, or a part.

button  You choose a button to initiate a
predefined action.  Buttons do not store
values.  A button is usually labeled with
text to describe its action or it can be an
icon whose image illustrates its action.

check box  You can indicate an on/off or
yes/no state for a value by checking or
unchecking its check box.  One or more
check boxes can be checked since each
check box is independent of other check
boxes.

child request  A concurrent request submitted
by another concurrent request (a parent
request.)  For example, each of the reports
and/or programs in a report set are child
requests of that report set.

combination block  A combination block
displays the fields of a record in both
multi–record (summary) and single–record
(detail) formats.  Each format appears in its
own separate window that you can easily
navigate between.

combination of segment values  A
combination of segment values uniquely
describes the information stored in a field
made up of segments.  A different
combination of segment values results
when you change the value of one or more
segments.  When you alter the combination
of segment values, you alter the description
of the information stored in the field.

combination query  See Existing Combinations.

concurrent manager  A unique facility that
manages many time–consuming,
non–interactive tasks within Oracle
Applications for you, so you do not have to
wait for their completion.  When you
submit a request in Oracle Applications
that does not require your interaction, such
as releasing shipments or running a report,
the Concurrent Manager does the work for
you, enabling you to complete multiple
tasks simultaneously.



Glossary – 3

concurrent process  A non–interactive task
that you request Oracle Applications to
complete.  Each time you submit a
non–interactive task, you create a new
concurrent process.  A concurrent process
runs simultaneously with other concurrent
processes (and other interactive activities
on your computer) to help you complete
multiple tasks at once.

concurrent queue  A list of concurrent
requests awaiting completion by a
concurrent manager.  Each concurrent
manager has a queue of requests waiting to
be run.  If your system administrator sets
up your Oracle Application to have
simultaneous queuing, your request can
wait to run in more than one queue.

concurrent request  A request to Oracle
Applications to complete a non–interactive
task for you.  You issue a request whenever
you submit a non–interactive task, such as
releasing a shipment, posting a journal
entry, or running a report.  Once you
submit a request, Oracle Applications
automatically takes over for you,
completing your request without further
involvement from you or interruption of
your work.

current record indicator  Multi–record blocks
often display a current record indicator to
the left of each record.  A current record
indicator is a one character field that when
filled in, identifies a record as being
currently selected.

descriptive flexfield   A field that your
organization can extend to capture extra
information not otherwise tracked by
Oracle Applications.  A descriptive flexfield
appears in your window as a single
character, unnamed field.  Your
organization can customize this field to
capture additional information unique to
your business.

Detail Action   An alert action that represents
one exception found in the database.

dynamic insertion  A feature specific to key
flexfields that allows you to enter and
define new combinations of segment values
directly into a flexfield pop–up window.
The new combination must satisfy any
cross–validation rules, before your flexfield
accepts the new combination.  Your
organization can decide if a key flexfield
supports dynamic insertion.  If a flexfield
does not support dynamic insertion, you
can only enter new combinations of
segment values using a combinations form
(a form specifically used for creating and
maintaining code combinations).

Existing Combinations  A feature specific to
key flexfields in data entry mode that
allows you to enter query criteria in the
flexfield to bring up a list of matching
predefined combinations of segment values
to select from.

field  A position on a window that you use to
enter, view, update, or delete information.
A field prompt describes each field by
telling you what kind of information
appears in the field, or alternatively, what
kind of information you should enter in the
field.

flexfield  An Oracle Applications field made
up of segments.  Each segment has an
assigned name and a set of valid values.
Oracle Applications uses flexfields to
capture information about your
organization.  There are two types of
flexfields: key flexfields and descriptive
flexfields.

folder  A flexible entry and display window in
which you can choose the fields you want
to see and where each appears in the
window.
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form  A logical collection of fields, regions,
and blocks that appear on a single screen.
Oracle Applications forms look just like the
paper forms you use to run your business.
All you need to do to enter data is type
onto the form.  See window.

function security  An Oracle Applications
feature that lets you control user access to
certain functions and windows.  By default,
access to functionality is not restricted; your
system administrator customizes each
responsibility at your site by including or
excluding functions and menus in the
Responsibilities window.

key flexfield  An intelligent key that uniquely
identifies an application entity.  Each key
flexfield segment has a name you assign,
and a set of valid values you specify.  Each
value has a meaning you also specify.  You
use this Oracle Applications feature to
build custom fields used for entering and
displaying information relating to your
business.  The Accounting Flexfield in your
Oracle General Ledger application is an
example of a key flexfield used to uniquely
identify a general ledger account.

lamp   A single word message that appears on
the message line to indicate whether a
function such as <Insert> or <List> is
available for the current field.

listing  An organized display of Oracle
Applications information, similar to a
report, but usually showing setup data as
opposed to transaction data.

lookup code  An internal name of a value
defined in a lookup type.

lookup type  A predefined list of values.  Each
value in a lookup type has an internal and a
display name.

master–detail relationship  A master–detail
relationship is an association between two
blocks—a master block and its detail block.
When two blocks are linked by a
master–detail relationship, the detail block
displays only those records that are
associated with the current (master) record
in the master block, and querying between
the two blocks is always coordinated.
Master and detail blocks can often appear
in the same window or they can each
appear in separate windows.

message line  A line on the bottom of a
window that displays helpful hints or
warning messages when you encounter an
error.

multi–org  See multiple organizations.

multiple organizations  The ability to define
multiple organizations and the
relationships among them within a single
installation of Oracle Applications.  These
organizations can be sets of books, business
groups, legal entities, operating units, or
inventory organizations.

Multiple Reporting Currencies  An Oracle
General Ledger feature that allows you to
report in your functional currency and in
one or more foreign currencies.

No Exception Action   An alert action that
represents no exceptions found in the
database.

option group  An option group is a set of
option buttons.  You can choose only one
option button in an option group at a time,
and the option group takes on that button’s
value after you choose it.  An option button
or option group is also referred to as a
radio button or radio group, respectively.
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parent request  A concurrent request that
submits other concurrent requests (child
requests).  For example, a report set is a
parent request that submits reports and/or
programs (child requests).

Periodic Alert   An alert that periodically
reports key information according to a
schedule you define.  Rather than notify
you of immediate exceptions in the
database like an event alert, a periodic alert
scans for specific database information
specified by its SQL SELECT statement at
scheduled intervals.

pop–up window  An additional window that
appears on an Oracle Applications form
when your cursor enters a particular field.

poplist  A poplist lets you choose a single
value from a predefined list.  To choose a
value, press your left mouse button while
on the poplist icon to display the list of
choices, then drag your mouse through the
list to the desired value.  Release your
mouse button to choose the value you
highlight and display it in the poplist field.
A poplist is also sometimes known as a list.

query  A search for applications information
that you initiate using an Oracle
Applications window.

record  A record is one occurrence of data
stored in all the fields of a block.  A record
is also referred to as a row or a transaction,
since one record corresponds to one row of
data in a database table or one database
transaction.

region  A collection of logically–related fields
set apart from other fields by a dashed line
that spans a block.  Regions help to
organize a block so that it is easier to
understand.

report  An organized display of Oracle
Applications information.  A report can be
viewed online or sent to a printer.  The
content of information in a report can range
from a summary to a complete listing of
values.

report security group  A feature that helps
your system administrator control your
access to reports and programs.  Your
system administrator defines a report
security group which consists of a group of
reports and/or programs and assigns a
report security group to each responsibility
that has access to run reports using
Standard Report Submission.  When you
submit reports using Standard Report
Submission, you can only choose from
those reports and programs in the report
security group assigned to your
responsibility.

report set  A group of reports that you submit
at the same time to run as one transaction.
A report set allows you to submit the same
set of reports regularly without having to
specify each report individually.  For
example, you can define a report set that
prints all of your regular month–end
management reports.

responsibility  A level of authority in an
application.  Each responsibility lets you
access a specific set of Oracle Applications
windows, menus, reports, and data to fulfill
your role in an organization.  Several users
can share the same responsibility, and a
single user can have multiple
responsibilities.
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root window  The root window displays the
main menu bar and tool bar for every
session of Oracle Applications.  In
Microsoft Windows, the root window is
titled ”Oracle Applications” and contains
all the Oracle Applications windows you
run.  In the Motif environment, the root
window is titled ”Toolbar” because it
displays just the toolbar and main menu
bar.

row  One occurrence of the information
displayed in the fields of a block.  A block
may show only one row of information at a
time, or it may display several rows of
information at once, depending on its
layout.  The term “row” is synonymous
with the term “record”.

scrollable region  A region whose contents are
not entirely visible in a window.  A
scrollable region contains a horizontal or
vertical scroll bar so that you can scroll
horizontally or vertically to view additional
fields hidden in the region.

segment  A single sub–field within a flexfield.
You define the structure and meaning of
individual segments when customizing a
flexfield.

shorthand flexfield entry  A quick way to
enter key flexfield data using shorthand
aliases (names) that represent valid flexfield
combinations or patterns of valid segment
values.  Your organization can specify
flexfields that will use shorthand flexfield
entry and define shorthand aliases for these
flexfields that represent complete or partial
sets of key flexfield segment values.

shorthand window  A single–segment
customizable field that appears in a pop–up
window when you enter a key flexfield.
The shorthand flexfield pop–up window
only appears if you enable shorthand entry
for that particular key flexfield.

sign–on  An Oracle Applications username
and password that allows you to gain
access to Oracle Applications.  Each
sign–on is assigned one or more
responsibilities.

Standard Request Submission  A standard
interface in Oracle Applications in which
you run and monitor your application’s
reports and other processes.

status line  A status line appearing below the
message line of a root window that displays
status information about the current
window or field.  A status line can contain
the following:  ^ or v symbols indicate
previous records before or additional
records following the current record in the
current block; Enter Query indicates that
the current block is in Enter Query mode,
so you can specify search criteria for a
query; Count indicates how many records
were retrieved or displayed by a query (this
number increases with each new record you
access but does not decrease when you
return to a prior record); the <Insert>
indicator or lamp informs you that the
current window is in insert character mode;
and the <List> lamp appears when a list of
values is available for the current field.
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structure  A structure is a specific combination
of segments for a key flexfield.  If you add
or remove segments, or rearrange the order
of segments in a key flexfield, you get a
different structure.

Summary Action   An alert action that
represents multiple exceptions found in the
database.

Summary Threshold   The number of
exceptions Oracle Alert can find before it
changes an alert action from a detail action
to a summary action.

toolbar  The toolbar is a collection of iconic
buttons that each perform a specific action
when you choose it.  Each toolbar button
replicates a commonly–used menu item.
Depending on the context of the current
field or window, a toolbar button can be
enabled or disabled.  You can display a hint
for an enabled toolbar button on the
message line by holding your mouse
steadily over the button.  The toolbar
generally appears below the main menu bar
in the root window.

user profile  A set of changeable options that
affect the way your applications run.  You
can change the value of a user profile
option at any time. 

window  A box around a set of related
information on your screen.  Many
windows can appear on your screen
simultaneously and can overlap or appear
adjacent to each other.  Windows can also
appear embedded in other windows.  You
can move a window to a different location
on your screen.

window title  A window title at the top of
each window indicates the name of the
window, and occasionally, context
information pertinent to the content of the
window.  The context information,
contained in parenthesis, can include the
organization, set of books, or business
group that the window contents is
associated with.
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Index
A
Accelerator keys. See Keyboard shortcuts
Add a Favorite Web Site page, 1 – 12
Adding new Documents to the 

Navigator, 1 – 19
Alias, shorthand, 5 – 8
Attachments, 8 – 2

attaching a document, 8 – 5
copying an attachment, 8 – 7
deleting an attachment, 8 – 7

Attachments window fields, 8 – 3
AutoReduction, 3 – 10, 3 – 14
AutoSelection, 3 – 9
AutoSkip, 5 – 10

B
Batch processing. See Concurrent processing
Blocks, 2 – 7

clearing, 3 – 3
combination, 2 – 14
erasing, 3 – 3

Business entity, 5 – 2
Business flows, 2 – 6
Buttons, 2 – 7

C
Cancelling requests, 7 – 12
Case–sensitivity, in a List Search, 3 – 12
Check boxes, 2 – 7

Enter Query mode, 3 – 25
Choose, 1 – 3
Clear field, 3 – 3, A – 3
Click, 1 – 3
Codes

See also Key flexfields
error and message, 2 – 21

color, of fields, 2 – 7
Combination blocks, 2 – 14
Combination of segment values, 5 – 4

creating, 5 – 8
Committing data, 2 – 20
Concurrent managers

See also Concurrent processing
viewing the queue, 7 – 4 to 7 – 5

Concurrent processing, 6 – 4
error notification, 6 – 6
online requests, 6 – 5
overview, 6 – 2
run and print options, 6 – 6, 6 – 8

Concurrent programs. See Concurrent
processing

Concurrent requests, 6 – 8
See also Concurrent processing
cancelling, 7 – 12
changing run and print 

options, 7 – 13 to 7 – 14



Index – 2 Oracle Applications User’s Guide

phase/status combinations, 7 – 9 to 7 – 10
run and print options, 6 – 8
status of, 7 – 2 to 7 – 5, 7 – 9
viewing, 7 – 2 to 7 – 6

Concurrent Requests window. See Viewing
requests

Container window, 2 – 6
Context, window title, 2 – 5
Coordination check box, 2 – 12
Copy, 3 – 2, A – 3
Counting records, 3 – 25
Cross–validation, 5 – 7

See also Key flexfields
Current record indicators

drill–down, 2 – 9, 2 – 14
multi–record block, 2 – 9

Customize Favorites Portlet page, 1 – 11
Customizing data presentation, 4 – 2
Customizing window layouts, folders, 4 – 2
Cut, 3 – 2, A – 3

D
Data

clearing, 3 – 3
committing, 2 – 20
copying, 3 – 4
deleting from database, 3 – 5
erasing from a block, 3 – 3
erasing from a form, 3 – 4
inserting, 3 – 5
querying, 3 – 19
saving, 1 – 33, 2 – 20
searching, 3 – 19

DateTrack date, window title, 2 – 5
Default parameters. See Shared parameters
Define Request Sets window. See Standard

Request Submission
Descriptive flexfields

AutoSkip, 5 – 10
definition, 5 – 4 to 5 – 5
multiple flexfield structures, 5 – 8

querying, 5 – 21
using, 5 – 10
windows, 5 – 10

Desktop, 1 – 3, 2 – 5
Detail block, 2 – 12
Detail record, 2 – 12
Detail windows, combination blocks, 2 – 14
Direct entry key flexfields, 5 – 11

using, 5 – 11 to 5 – 14
Direct entry window, retrieving records, 3 – 26
Documents window fields, 8 – 9
Double–click, 1 – 3
Drag, 1 – 3
Drill–down capabilities, 2 – 9, 2 – 14
Dynamic insertion, 5 – 8

E
E–Business Suite Home Page, 1 – 8

customizing, 1 – 11
Favorites portlet, 1 – 10
Menu portlet, 1 – 9
Worklist portlet, 1 – 8

Edit menu, 3 – 2, A – 3
clear block, 3 – 3
clear field, 3 – 3
clear form, 3 – 4
clear record, 3 – 3
delete record, 3 – 5
duplicate field above, 3 – 4
duplicate record above, 3 – 4
edit field, 3 – 7
List, 3 – 9 to 3 – 10

Editing fields, 3 – 2, 3 – 7
Error notification, 6 – 6
Exit

committing data, 1 – 33
discarding changes, 1 – 33
returning to form, 1 – 33
saving changes, 1 – 33

Exiting Oracle Applications. See Exit
Export, 2 – 23

exporting large numbers of records, 2 – 23
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F
Favorites portlet, 1 – 10
Fields, 2 – 7

buttons, 2 – 7
check boxes, 2 – 7
clearing data, 3 – 3, A – 3
color, 2 – 7
copying data, 3 – 4
editing, 3 – 7
option buttons, 2 – 7
option groups, 2 – 7

File menu, A – 2
new record, 3 – 5
Print..., 2 – 19
Save, 2 – 20
Save and proceed, 2 – 20

Find window, 3 – 20
Flexfields

See also Descriptive flexfields; Key flexfields;
Range flexfields

AutoSkip, 5 – 10
combinations, 5 – 4
descriptive, 5 – 4
dynamic insertion, 5 – 8
key, 5 – 2
multiple flexfield structures, 5 – 8
overview, 5 – 2
querying, 5 – 21 to 5 – 22
security, 5 – 9
segment validation, 5 – 7
segments, 5 – 2
shorthand entry, 5 – 8
Shorthand Entry profile option, 9 – 14
structures, 5 – 7, 5 – 8
using, 5 – 10 to 5 – 14
using a list in, 5 – 10
windows, 5 – 10

Folder menu, 4 – 2, A – 5
Folders

autosize, 4 – 9
change prompts, 4 – 9
create new, 4 – 10
customizing, 4 – 2
decrease width, 4 – 9

definitions, 4 – 2
delete, 4 – 12
hide field, 4 – 8
increase width, 4 – 9
open, 4 – 11
recovering original folder layout, 4 – 11
reset query, 4 – 5
save, 4 – 11 to 4 – 12
save as, 4 – 11
scope of default folder, 4 – 10
show field, 4 – 8
show ordering, 4 – 5
swap left, 4 – 8, 4 – 9
swap right, 4 – 8
view query, 4 – 5

Forms, 2 – 6
blocks, 2 – 7
erasing, 3 – 4
fields, 2 – 7
message lines, 2 – 9
opening

LOV, 1 – 18
Navigator, 1 – 18
top ten list, 1 – 19

record, 2 – 8
searching for data in, 3 – 19
status lines, 2 – 10
window title, 2 – 5

Function keys. See Keyboard shortcuts

G
Generic Look and Feel, C – 2
Graphical user interface. See GUI
GUI, 1 – 2

terminology, 1 – 3

H
Help

accessing online, 1 – 29
show keys, 1 – 26 to 1 – 27
System help, 1 – 30
using, 1 – 29
Window help, 1 – 29
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Help menu, A – 7
About Oracle Applications, 1 – 31
about this record, 3 – 7

Hierarchy screen, 2 – 25
menu structure, 2 – 25
toolbar structure, 2 – 26

I
Intelligent keys. See Key flexfields

K
Key flexfield Edit window, 5 – 14 to 5 – 15
Key flexfield Find window, 5 – 15 to 5 – 16
Key flexfield windows

Edit window, 5 – 14
Find mode, 5 – 15

Key flexfields
cross–validation, 5 – 7
direct entry, 5 – 11
displaying the flexfield window, 5 – 13
dynamic insertion, 5 – 8
entering data, 5 – 11
overview, 5 – 2 to 5 – 3
querying, 5 – 21 to 5 – 22
security by value, 5 – 9
shorthand alias, 5 – 16 to 5 – 17
shorthand entry, 5 – 8
specifying segment separators, 5 – 12
using a Find window, 5 – 15
using an Edit window, 5 – 14

KEY–F8 Function, C – 2
KEY–F9 Function, C – 2
Keyboard mappings, 1 – 26 to 1 – 27
Keyboard shortcuts, 1 – 26

for window navigation, 2 – 15

L
Lamps, 2 – 9 to 2 – 10
List

accessing, 2 – 8, 3 – 9, 3 – 15

AutoReduction, 3 – 10, 3 – 14
AutoSelection, 3 – 9
long, 3 – 12
multicolumn windows, 3 – 14
Power list, 3 – 13 to 3 – 14
search, 3 – 10
source, 3 – 15
standards, 3 – 15
taking advantage of, 3 – 15
using, 3 – 9 to 3 – 15

List of values
See also Lists
using, 3 – 9 to 3 – 15

Long list, 3 – 12
Long text fields, accessing editor, 3 – 7

M
Main menu, 1 – 25
Main Menu Bar, A – 2
Main window. See Root window
Master block, 2 – 12
Master record, 2 – 12
Master–detail relations, 2 – 12
Master–detail relationship, coordination check

box, 2 – 12
Menu, 1 – 3

Folder, 4 – 2
Menu bars

Oracle Applications main, A – 2
Special window, A – 6

Menu portlet, 1 – 9
Menus, A – 2

Edit, 3 – 2, A – 3
File, A – 2
Folder, A – 5
Help, A – 7
Special, A – 6
Tools, A – 6
View, A – 4
Window, A – 6

Menus, using
getting online help, 1 – 29
main menu, 1 – 25 to 1 – 28
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security, 1 – 9
selecting a responsibility, 1 – 9
using keyboard shortcuts, 1 – 26

Message lines, 2 – 9
Messages, viewing, 2 – 21
Modal windows, 2 – 6
Monitoring requests

cancelling requests, 7 – 12
changing run and print options, 7 – 13 to 

7 – 14
phase/status combinations, 7 – 9 to 7 – 10
Requests window, 7 – 2 to 7 – 5

Moving around a window, 2 – 15
Moving between forms. See Zoom
Multi–record blocks

current record indicators, 2 – 9
scroll bars, 2 – 8

multi–select, 3 – 26

N
Navigating a window, 2 – 15
Navigator

adding new documents, 1 – 19
removing documents, 1 – 20

O
Online, view requests, 7 – 6
Online help, using, 1 – 29
Online inquiries, searching for 

information, 3 – 19
Online requests. See Concurrent requests
Opening forms

LOV, 1 – 18
Navigator, 1 – 18
top ten list, 1 – 19

Opening the Navigator’s Document 
Region, 1 – 19

Option buttons, 2 – 7
Option groups, 2 – 7
Options. See Profile options; User profiles

options

Oracle Applications, overview, 1 – 2
Oracle Applications behavior

See also User profile options
customizing, 9 – 2, 9 – 5 to 9 – 7

Oracle Look and Feel, C – 2
Overview, Oracle Applications, 1 – 2

P
Passwords

changing sign–on password, 1 – 6, 1 – 23
Oracle Applications, 1 – 6
security features, 1 – 6

Paste, 3 – 2, A – 3
Poplist, 2 – 8

See also List
Power list, 3 – 13
Preferences page, 1 – 12
Print options

changing, 7 – 13 to 7 – 14
for reports, 6 – 36

Printing, active window, 2 – 19
Profile Options, Flexfields:Open Descr

Window, 5 – 7
Profile options

See also User profile options
Attachment File Upload Directory, 9 – 8
Concurrent:Attach URL, 9 – 8
Concurrent:Hold Request, 6 – 8, 9 – 8
Concurrent:Multiple Time Zones, 9 – 9
Concurrent:Report Access Level, 6 – 8, 9 – 9
Concurrent:Report Copies, 6 – 8, 6 – 22, 9 – 9
Concurrent:Request Priority, 6 – 8, 9 – 10
Concurrent:Request Start Time, 6 – 8, 6 – 18,

6 – 19, 9 – 10
Concurrent:Save Output, 6 – 8, 6 – 22, 9 – 10
Concurrent:Sequential Requests, 6 – 8, 9 – 11
Concurrent:Show Requests Summary After

Each Request Submission, 9 – 11
Concurrent:URL Lifetime, 9 – 11
Concurrent:Wait for Available TM, 9 – 11
Currency:Negative Format, 9 – 12
Currency:Positive Format, 9 – 12
Currency:Thousands Separator, 9 – 12
Default Country, 9 – 12
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Flexfield:Shorthand Entry, 5 – 16
Flexfield:Show Full Value, 5 – 16
Flexfields:AutoSkip, 5 – 10, 9 – 13
Flexfields:BiDi Direction, 9 – 13
Flexfields:LOV Warning Limit, 9 – 13
Flexfields:Open Descr Window, 9 – 14
Flexfields:Shorthand Entry, 5 – 8, 9 – 14
Flexfields:Show Full Value, 9 – 14
Flexfields:Validate On Server, 9 – 15
FND: Indicator Colors, 9 – 15
Folders:Allow Customization, 4 – 2, 9 – 15
Forms Keyboard Mapping File, 9 – 15, C – 3
Forms Runtime Parameters, 9 – 16
GL Set of Books Name, 5 – 8
Indicate Attachments, 9 – 16
Java Color Scheme, 9 – 16, C – 2
Java Look and Feel, 9 – 16, C – 2
MO: Operating Unit, 9 – 17
Printer, 6 – 8, 6 – 22, 9 – 17
Sequential Numbering, 9 – 17
Session ID, 9 – 17
Sign–On:Notification, 9 – 17
Viewer: Default Font Size, 9 – 18
Viewer: Postscript, PDF, and HTML, 9 – 18
Viewer: Text, 9 – 18

Profile Values, form description, 9 – 5 to 9 – 7
Profiles. See Profile options; User profiles

options
Programs, 6 – 2, 6 – 10

See also Concurrent requests; Standard
Request Submission

Q
Query

See also PowerSearch
entering criteria, 3 – 22
executing, 3 – 25 to 3 – 26

Query count, 3 – 25
Query criteria, use of wildcards, 3 – 23
Query Find, 3 – 20
Query menu

count matching records, 3 – 25
Enter, 3 – 22

Quit, 3 – 25
retrieve next set, 3 – 25

Query operators, 3 – 23 to 3 – 24
Query–by–example, 3 – 24 to 3 – 25, 

5 – 21 to 5 – 22
Querying data, 3 – 19 to 3 – 25
Quitting Oracle Applications. See Exit

R
Radio buttons. See Option buttons
Radio group. See Option group
Range flexfields, 5 – 17
Records, 2 – 8

adding new, 3 – 5
clearing, 3 – 3
copying, 3 – 4
current record information, 3 – 7
deleting from database, 3 – 5
erasing, 3 – 3
inserting to database, 3 – 5

Regions, 2 – 8
scrollable region, 2 – 8

Removing Documents from the 
Navigator, 1 – 20

Renaming Documents in the Navigator, 1 – 20
Report groups, access to request sets, 6 – 41
Report parameters, 6 – 5
Reports, 6 – 2, 6 – 5, 6 – 10

See also Concurrent requests; Standard
Request Submission

report parameters, 6 – 5
Request IDs, 6 – 22, 6 – 26
Request parameters, 6 – 13 to 6 – 14, 

6 – 37 to 6 – 39
Request sets, 6 – 5

access to, 6 – 41
cancelling, 7 – 12
defining, 6 – 28 to 6 – 36
print options, 6 – 36
request IDs, 6 – 22, 6 – 26
request parameters, 6 – 37 to 6 – 39
run and print options, 7 – 13 to 7 – 14
running, 6 – 23 to 6 – 25
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running reports in parallel, 6 – 34
scheduling, 6 – 6
security, 6 – 41
shared parameters, 6 – 38
status of, 7 – 2, 7 – 9

Requests
See also Concurrent requests; Request sets
cancelling, 7 – 12
request IDs, 6 – 22
request parameters, 6 – 14
resubmitting, 6 – 23
run and print options, 7 – 13 to 7 – 14
running, 6 – 10 to 6 – 15
scheduling, 6 – 6
security, 6 – 41
status of, 7 – 2, 7 – 9
submitting, 6 – 10 to 6 – 23

Requests window, accessing, 7 – 3
Responsibilities

changing, 1 – 9, 1 – 15, 1 – 23
description, 1 – 9
security, 1 – 9
standard, 1 – 9, 1 – 15
using, 1 – 9

Resubmit a Request, 6 – 23
Retrieving records, in a direct entry 

window, 3 – 26
Root window, 2 – 6
Rows. See records
Run options, changing, 7 – 13 to 7 – 14

S
Saving, before exiting, 1 – 33
Saving data, 2 – 20
Screens, 2 – 5
Scroll bar, 1 – 3, 2 – 8
Scroll bars, 2 – 8
Scrollable fields, 3 – 7
Search

See also PowerSearch
displaying records, 3 – 25
entering search criteria, 3 – 22

executing, 3 – 25 to 3 – 26
quitting, 3 – 25
through a list, 3 – 10

Search count, 3 – 25
Search criteria, use of wildcards, 3 – 23
Searching for data. See PowerSearch
Security

changing passwords, 1 – 6
flexfields, 5 – 9
Oracle Applications sign–ons, 1 – 6
requests and request sets, 6 – 41
responsibilities, 1 – 9

Segment validation, 5 – 7
Segments, 5 – 2
Select, 1 – 3
selecting, multiple records, 3 – 26
Shared parameters

changing a value, 6 – 38
request sets, 6 – 38

Sharing parameters, in request sets, 6 – 38
Shorthand flexfield entry, 5 – 8

aliases, 5 – 16 to 5 – 17
Signing on, 1 – 5
Single–record blocks, 2 – 8
Special menu, A – 6

Change Password, 1 – 23 to 1 – 24
Switch Responsibility, 1 – 23

Special window menu bar, A – 6
Standard Report Submission, access to Run

Reports form, 6 – 10
Standard Request Submission

See also Reports; Request sets; viewing
requests

access to request sets, 6 – 41
defining request sets, 6 – 28 to 6 – 36
overview, 6 – 2 to 6 – 3
print options, 6 – 36
report parameters, 6 – 5
request IDs, 6 – 22, 6 – 26
request parameters, 6 – 13 to 6 – 14, 

6 – 37 to 6 – 39
running reports and programs, 6 – 10 to 

6 – 15
running request sets, 6 – 23 to 6 – 27
scheduling, 6 – 6
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Status lines, 2 – 10
Structures, 5 – 7

multiple flexfield structures, 5 – 8
Submitting jobs. See Concurrent requests;

Standard Request Submission
Submitting reports and programs. See

Concurrent requests; Standard Request
Submission

Summary windows, combination blocks, 2 – 14

T
Tab region, 2 – 12
Task flows, 2 – 6
Toolbar, 2 – 10
Tools menu, A – 6

U
Update a Favorite Web Site page, 1 – 12
User access restrictions, 1 – 9
User interface. See Profile options
User profile hierarchy, 9 – 2 to 9 – 4
User profile levels, 9 – 3
User profile options

See also Profile options
common options, 9 – 8
concurrent processing options, 6 – 8
overview, 9 – 2
personal profile, 9 – 5
profile levels, 9 – 4 to 9 – 5
Profile Values form, 9 – 5 to 9 – 7
setting values, 9 – 4 to 9 – 6

User responsibility, 1 – 9
Usernames, 1 – 6

V
Versions, software information, 1 – 31
View menu, A – 4

Zoom, 2 – 22
View reports online, 7 – 6
Viewing messages, 2 – 21
Viewing request output and log files, 7 – 6
Viewing requests

cancelling requests, 7 – 12
changing run and print options, 7 – 13 

to 7 – 14
phase/status combinations, 7 – 9 to 7 – 10
Requests window, 7 – 2 to 7 – 5

W
Wildcard characters, in search criteria, 3 – 10,

 3 – 23
Window, 1 – 3, 2 – 5

printing, 2 – 19
saving data in, 2 – 20

Window functions, 2 – 19
Window title, context, 2 – 5
Windows

modal, 2 – 6
moving around, 2 – 15

Windows menu, A – 6
Worklist portlet, 1 – 8

Z
Zoom

accessing, 2 – 22
using, 2 – 22
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Oracle Corporation welcomes your comments and suggestions on the quality and usefulness
of this publication.  Your input is an important part of the information we use for revision.

• Did you find any errors?

• Is the information clearly presented?
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• Are the examples correct?  Do you need more examples?
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Please send your comments to:
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500 Oracle Parkway
Redwood Shores, CA  94065
Phone: (650) 506–7000     Fax: (650) 506–7200
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