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Preface

Audience for This Guide

Welcome to Release 11i of Oracle Enterprise Install Base Implementation Guide.

This guide assumes you have a working knowledge of the following:

The principles and customary practices of your business area.
Oracle Enterprise Install Base

If you have never used Oracle Enterprise Install Base, Oracle suggests you
attend one or more of the Oracle Enterprise Install Base training classes
available through Oracle University.

The Oracle Applications graphical user interface.

To learn more about the Oracle Applications graphical user interface, read the
Oracle Applications User’s Guide.

See Other Information Sources for more information about Oracle Applications
product information.

How To Use This Guide

This document contains the information you need to understand and use Oracle
Enterprise Install Base.

Chapter 1 “Overview of Oracle Enterprise Install Base” provides overviews of
the application and its components, explanations of key concepts, features, and
functions, as well as the application’s relationships to other Oracle or
third-party applications.
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s Chapter 2 “Implementation and Setup” provides detailed task based
procedures for implementing and setting up Oracle Enterprise Install Base.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation
accessible, with good usability, to the disabled community. To that end, our
documentation includes features that make information available to users of
assistive technology. This documentation is available in HTML format, and contains
markup to facilitate access by the disabled community. Standards will continue to
evolve over time, and Oracle Corporation is actively engaged with other
market-leading technology vendors to address technical obstacles so that our
documentation can be accessible to all of our customers. For additional information,
visit the Oracle Accessibility Program Web site at

http:/ /www.oracle.com/accessibility /.

Accessibility of Code Examples in Documentation

JAWS, a Windows screen reader, may not always correctly read the code examples
in this document. The conventions for writing code require that closing braces
should appear on an otherwise empty line; however, JAWS may not always read a
line of text that consists solely of a bracket or brace.

Other Information Sources

viii

You can choose from many sources of information, including online
documentation, training, and support services, to increase your knowledge and
understanding of Oracle Enterprise Install Base.

If this guide refers you to other Oracle Applications documentation, use only the
Release 11i versions of those guides.

Online Documentation

All Oracle Applications documentation is available online (HTML or PDF). Online
help patches are available on MetaLink.

Related Documentation

Oracle Enterprise Install Base shares business and setup information with other
Oracle Applications products. Therefore, you may want to refer to other product
documentation when you set up and use Oracle Enterprise Install Base.



You can read the documents online by choosing Library from the expandable menu
on your HTML help window, by reading from the Oracle Applications Document
Library CD included in your media pack, or by using a Web browser with a URL
that your system administrator provides.

If you require printed guides, you can purchase them from the Oracle Store at
http:/ /oraclestore.oracle.com.

Documents Related to All Products

Oracle Applications User’s Guide

This guide explains how to enter data, query, run reports, and navigate using

the graphical user interface (GUI) available with this release of Oracle Enterprise
Install Base (and any other Oracle Applications products). This guide also includes
information on setting user profiles, as well as running and reviewing reports and
concurrent processes.

You can access this user’s guide online by choosing “Getting Started with Oracle
Applications” from any Oracle Applications help file.

Documents Related to This Product

Oracle Enterprise Install Base Concept and Procedures

This guide provides overviews of Oracle Enterprise Install Base application and its
components, explanations of key concepts and features.

Oracle Install Base User’s Guide

This guide provides overviews of Oracle Install Base application and its
components, explanations of key concepts and features.

Oracle Inventory User’s Guide

This guide provides overviews of Oracle Inventory application and its components,
explanations of key concepts and features.

Oracle Projects User’s Guide

This guide provides overviews of Oracle Projects application and its components,
explanations of key concepts and features.



Oracle Asset User’s Guide

This guide provides overviews of Oracle Asset application and its components,
explanations of key concepts and features.

Oracle Purchasing User’s Guide

This guide provides overviews of Oracle Purchasing application and its
components and features and functions.

Oracle Payables User’s Guide

This guide provides overviews of Oracle Payables application and its components,
explanations of key concepts and features.

Oracle Service Fulfillment Manager User’s Guide

This guide provides overviews of Oracle Service Fulfillment Manager application
and its components, explanations of key concepts and features.

Oracle Applications Concepts

This guide provides an introduction to the concepts, features, technology stack,
architecture, and terminology for Oracle Applications Release 11i. It provides a
useful first book to read before an installation of Oracle Applications. This guide
also introduces the concepts behind Applications-wide features such as Business
Intelligence (BIS), languages and character sets, and Self-Service Web Applications.

Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle
Applications products. In Release 117, much of the installation process is handled
using Oracle Rapid Install, which minimizes the time to install Oracle Applications,
the Oracle8 technology stack, and the Oracle8i Server technology stack by
automating many of the required steps. This guide contains instructions for using
Oracle Rapid Install and lists the tasks you need to perform to finish your
installation. You should use this guide in conjunction with individual product
user’s guides and implementation guides.

Oracle Applications Supplemental CRM Installation Steps

This guide contains specific steps needed to complete installation of a few of the
CRM products. The steps should be done immediately following the tasks given in
the Installing Oracle Applications guide.



Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or
Release 11.0 products to Release 11i. This guide describes the upgrade process and
lists database and product-specific upgrade tasks. You must be either at Release 10.7
(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 11i.
You cannot upgrade to Release 11 directly from releases prior to 10.7.

Maintaining Oracle Applications

Use this guide to help you run the various AD utilities, such as AutoUpgrade,
AutoPatch, AD Administration, AD Controller, AD Relink, License Manager, and
others. It contains how-to steps, screenshots, and other information that you need to
run the AD utilities. This guide also provides information on maintaining the
Oracle applications file system and database.

Oracle Applications System Administrator’s Guide

This guide provides planning and reference information for the Oracle Applications
System Administrator. It contains information on how to define security, customize
menus and online help, and manage concurrent processing.

Oracle Alert User’s Guide

This guide explains how to define periodic and event alerts to monitor the status of
your Oracle Applications data.

Oracle Applications Developer’s Guide

This guide contains the coding standards followed by the Oracle Applications
development staff. It describes the Oracle Application Object Library components
needed to implement the Oracle Applications user interface described in the Oracle
Applications User Interface Standards for Forms-Based Products. It also provides
information to help you build your custom Oracle Forms Developer 6i forms so that
they integrate with Oracle Applications.

Oracle Applications User Interface Standards for Forms-Based Products
This guide contains the user interface (Ul) standards followed by the Oracle
Applications development staff. It describes the UI for the Oracle Applications
products and how to apply this Ul to the design of an application built by using
Oracle Forms.
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Xii

Other Implementation Documentation

Oracle Workflow Guide

This guide explains how to define new workflow business processes as well as
customize existing Oracle Applications-embedded workflow processes.You also use
this guide to complete the setup steps necessary for any Oracle Applications
product that includes workflow-enabled processes.

Oracle Applications Flexfields Guide

This guide provides flexfields planning, setup and reference information for the
Oracle Enterprise Install Base implementation team, as well as for users
responsible for the ongoing maintenance of Oracle Applications product data. This
manual also provides information on creating custom reports on flexfields data.

Oracle eTechnical Reference Manuals

Each eTechnical Reference Manual (eTRM) contains database diagrams and a
detailed description of database tables, forms, reports, and programs for a specific
Oracle Applications product. This information helps you convert data from your
existing applications, integrate Oracle Applications data with non-Oracle
applications, and write custom reports for Oracle Applications products. Oracle
e€TRM is available on Metalink

Oracle Manufacturing APIs and Open Interfaces Manual

This manual contains up-to-date information about integrating with other Oracle
Manufacturing applications and with your other systems. This documentation
includes APIs and open interfaces found in Oracle Manufacturing.

Oracle Order Management Suite APIs and Open Interfaces Manual

This manual contains up-to-date information about integrating with other Oracle
Manufacturing applications and with your other systems. This documentation
includes APIs and open interfaces found in Oracle Order Management Suite.

Oracle Applications Message Reference Manual

This manual describes Oracle Applications messages. This manual is available in
HTML format on the documentation CD-ROM for Release 11i.

Oracle CRM Application Foundation Implementation Guide

Many CRM products use components from CRM Application Foundation. Use this
guide to correctly implement CRM Application Foundation.



Training and Support

Training

Oracle offers training courses to help you and your staff master Oracle Enterprise
Install Base and reach full productivity quickly. You have a choice of educational
environments. You can attend courses offered by Oracle University at any one of
our many Education Centers, you can arrange for our trainers to teach at your
facility, or you can use Oracle Learning Network (OLN), Oracle University’s online
education utility. In addition, Oracle training professionals can tailor standard
courses or develop custom courses to meet your needs. For example, you may want
to use your organization’s structure, terminology, and data as examples in a
customized training session delivered at your own facility.

Support

From on-site support to central support, our team of experienced professionals
provides the help and information you need to keep Oracle Enterprise Install Base
working for you. This team includes your Technical Representative, Account
Manager, and Oracle’s large staff of consultants and support specialists with
expertise in your business area, managing an Oracle8i server, and your

hardware and software environment.

OracleMetaLink

OracleMetaLink is your self-service support connection with web, telephone menu,
and e-mail alternatives. Oracle supplies these technologies for your convenience,
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain
information and advice from technical libraries and forums, download patches,
download the latest documentation, look at bug details, and create or update TARs.
To use MetaLink, register at (http://metalink.oracle.com).

Alerts: You should check OracleMetaLink alerts before you begin to install or
upgrade any of your Oracle Applications. Navigate to the Alerts page as follows:
Technical Libraries/ERP Applications/Applications Installation and

Upgrade/ Alerts.

Self-Service Toolkit: You may also find information by navigating to the
Self-Service Toolkit page as follows: Technical Libraries/ERP
Applications/Applications Installation and Upgrade.
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Do Not Use Database Tools to Modify Oracle Applications Data

Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data
Browser, database triggers, or any other tool to modify Oracle Applications data
unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and
maintain information in an Oracle database. But if you use Oracle tools such as
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of
your data and you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using
Oracle Applications can update many tables at once. But when you modify Oracle
Applications data using anything other than Oracle Applications, you may change a
row in one table without making corresponding changes in related tables. If your
tables get out of synchronization with each other, you risk retrieving erroneous
information and you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications
automatically checks that your changes are valid. Oracle Applications also keeps
track of who changes information. If you enter information into database tables
using database tools, you may store invalid information. You also lose the ability to
track who has changed your information because SQL*Plus and other database
tools do not keep a record of changes.

About Oracle

Xiv

Oracle Corporation develops and markets an integrated line of software products
for database management, applications development, decision support, and office
automation, as well as Oracle Applications, an integrated suite of more than 160
software modules for financial management, supply chain management,
manufacturing, project systems, human resources and customer relationship
management.

Oracle products are available for mainframes, minicomputers, personal computers,
network computers and personal digital assistants, allowing organizations to
integrate different computers, different operating systems, different networks, and
even different database management systems, into a single, unified computing and
information resource.

Oracle is the world’s leading supplier of software for information management, and
the world’s second largest software company. Oracle offers its database, tools, and
applications products, along with related consulting, education, and support
services, in over 145 countries around the world.
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Overview of Oracle Enterprise Install Base

1.1 Definition of Oracle Enterprise Install Base

Oracle Enterprise Install Base (elB) is a tracking system that integrates with and
stores information collected from Inventory, Purchasing, Projects, Assets, Payables
and Install Base.

With Oracle Enterprise Install Base, you can give users access to tracking
information without allowing them access to sensitive processes related to assets
and purchasing. You can also track inventory items after they have been installed
and link financial transactions to the physical movement of equipment.

1.2 What Is New for Oracle Enterprise Install Base in This Release

Oracle Enterprise Install Base (eIB) was originally designed to track and integrates
with and stores information collected from Inventory, Purchasing, Projects, Assets,
Payables and Install Base. For this release this original concept has been expanded
to integrates with Oracle Install Base as its data repository. Every transaction that
Enterprise Install Base tracks will be recorded in the Install Base transaction table
and each record affected by such transaction will be recorded in the instance and
instance history tables.

1.3 Inventory Item and Asset Tracking

To track inventory items and assets, Oracle Enterprise Install Base (eIB) must
interact with several enterprise resource planning (ERP) applications. It sends to
and receives messages from those applications about the status and location of the
items you want to track.

Oracle Enterprise Install Base (eIB) provides an enterprise tracking and asset
management system where all inventory, project and asset-related material
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Inventory Item and Asset Tracking

information is stored, providing a 360-degree view of your assets. Users can locate
materials anywhere in the system—in warehouses, on trucks, installed in the
network, or on project sites, facilitating financial transactions using physical
movements of material and equipment. In addition, Enterprise Install Base can
provide a life-cycle history of all activity for that equipment.

An asset comprises a collection of items. The items may be trackable or not
trackable. During implementation, items are designated as NL-trackable at the item
master level in Oracle Inventory. Oracle Enterprise Install Base tracks the activity of
the trackable items through inventory, projects, and into fixed assets.

In Oracle Assets you perform the Mass Additions concurrent process to create
assets.

Figure 1-1 Overview of Message Flows in Oracle Enterprise Install Base

Work Management

Purchasing Inventory

- Transfers Install/Remove
PO Receiving Move Orders In-Service
Issues to Project Out-of-Service

Misc. Issues/Receipts
Physical lnventory/CC

Item Move

[ Enterprise Installed Base

Create Installed Base Track Location Creale Assels Process Retirements
Instances Create Project Update Asset Adjust Asset
Manage Usage Expenditures Location Cost

Depreciate Assets

Payables

Invoice Price
Variances

Manage Costs
Interface (o Assets

In the Overview of Message Flows in Oracle Enterprise Install Base diagram, for
example, when a field service technician enters a report that equipment has been
placed into service, the workforce management system may send a message to
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Features of Oracle Enterprise Install Base

Enterprise Install Base. This message updates the status of the equipment to “In
Service,” and gives its in-service date to Oracle Projects The asset is now ready to be
created in Oracle Assets.

1.3.1 Messaging Architecture in elB

The messaging architecture receives requests from external publishing systems in
eXtensible Markup Language (XML) format. Based on the input requirements, the
application updates the status and keeps a history of transactions for the tracking
unit. Subsequently, the application publishes outgoing requests to the subscribing
systems for further processing. The publishing and subscribing systems include:
Install Base, inventory, purchasing, payables, assets, projects, workforce
management, and other legacy system.

1.4 Features of Oracle Enterprise Install Base

1.4.1 Functional Overview

This application supports the standard functions found in Oracle Inventory, Oracle
Purchasing, Oracle CRL-Financials Enabled Assets, and Oracle CRL-Financials
Enabled Projects.

Oracle Enterprise Install Base supports the following functions:
s POreceipt of items into Inventory

= PO receipt of items into operating projects

= Move Orders

= Misc Issue to Project

= Misc Receipt from Project

= Installation and un-installation of equipment
= In-service/Out-of-service of equipment

= Subinventory transfers

» Inter-organization transfers

= Miscellaneous receipts and issues

= Placement of assets into or out of service

= Retirement and Reinstatement of partial or full cost of asset
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Integration Points and Dependencies for Enterprise Install Base

s Asset Item move and asset Item transfer

= Physical Inventory and Cycle Counts

1.5 Integration Points and Dependencies for Enterprise Install Base

1.5.1 ERP Integration

Oracle Enterprise Install Base has the following integration points with Oracle
Applications (ERP):

s Inventory

= Purchasing

s Order Management
= Accounts Payables
= Work in Process

= Fixed Assets

= Projects

1-4 Oracle Enterprise Install Base Implementation Guide



2

Implementation and Setup

2.1 Setup Checklist

Enterprise Install Base has an ability to track the item irrespective of the location
and also to perform the financial updates automatically. Users may use both the
functionalities or just the instance tracking capability. Your setup is dependent on
the same.

If you are not using Asset creation through Enterprise Install Base then you don’t
have to perform Oracle Project and Oracle Asset setups

The following table is a comprehensive list of all setup steps that must be
completed.

Table 2-1 Oracle Enterprise Install Base check list

Step Step Title Required

1 Define User with all required Y
Responsibilities

2 Define System Profile Options for Enterprise Y
Install Base

3 Define System Profile Options for all the Y
dependent responsibilities

4 Define Install Base Tracking Item options Y

5 Define Inventory Parameters Y

6 Define Purchasing parameters Y

7 Perform Accounts Payable setup Y

8 Define Project Parameters Optional

9 Define Asset Parameters Optional
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Define User with All Required Responsibilities

Table 2-1 Oracle Enterprise Install Base check list

Step Step Title Required
10 Perform Install Base location setup Optional
11 Service Fulfillment Manager setup Y

Note: If you are only Install Base user and want to track only customer
products, then perform steps 2 and 4 only.

2.2 Define User with All Required Responsibilities

Following modules must be installed and set up before you set up Enterprise Install
Base. Please consult the appropriate reference manuals for guidance in installing
and setting up these modules:

= Oracle Inventory

= Oracle Projects

»  Oracle Assets

s Oracle Purchasing

= Oracle Payables

s Oracle CRL-Financials

s Oracle General Ledger

= Oracle Install Base

= Oracle Service Fulfillment Manager

Note: CRL Assets and CRL Projects setup is required only if you using Projects
to accrue expenditures to projects and Assets.

2.3 Define System Profile Options for Enterprise Install Base

These profile options determine how messages are dequeued, where the history file
for debugging is located, and where event notifications are sent. Use the System
Profile Values window to make changes to your profile settings. Do not enter user
values unless you require a setting that is different from the default setting.

Use these steps to set profile options.
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Define System Profile Options for Enterprise Install Base

Steps

1. From the Navigator for the System Administrator responsibility, choose Setup

> Profiles.

2. In the Profile Name field of the Find Personal Profile Values window, enter

CSE% and click Find.

3. Select Issue to Project from the Profile Values window and click OK.

The System Profile Values window displays the following profile options that

you can define.

Table 2-2 Oracle Enterprise Install Base Module Profile Option Settings

Profile Name Default Value

Profile Option Function

Required

CSE: Debug Log Directory /sqlcom/temp/

CSE: Debug Option Y

CSE: FA Book Type Code

CSE:Issue to Projects
Transaction Type

CSE: Miscellaneous Issue
to Project

CSE: Miscellaneous
Receipt from Project

Sets the file and directory of
the debug log file. DBA can
create own path of directory
for fog file

Enter Y (yes) or N (no) to
control the debugging
function for the message
dequeuer.

This option is used to set
the default FA book type
code for creating asset from
depreciable item.

Defines which transaction
type represents the
Enterprise Install Base Issue
to Project.

This is miscellaneous
transaction type, used when
material is issued to a
project. This is user define
transaction type

This is miscellaneous
transaction type, used when
material is issued from a
project. This is user define
transaction type

Y

Optional

Optional

Optional

Optional
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Define System Profile Options for All Dependent Responsibilities

Table 2-2 Oracle Enterprise Install Base Module Profile Option Settings

Profile Name Default Value

Profile Option Function Required

CUN: PA Expenditure
Type

CSE: PA Expenditure Type

CSE: Bypass event queue N

he default expenditure type, Optional
used when material is
issued to a project.

The default expenditure Optional
type, used when material is
issued to a project.

This option is used to Y
bypass event queue

2.4 Define System Profile Options for All Dependent Responsibilities

After the modules: Inventory, Projects, Assets, Purchasing, Payables,
CRL-Financials, General Ledger, Install Base and Service Fulfillment Manager have
been installed, navigate to the System Administrator responsibility and perform the

following tasks.

Use these steps to set profile options.

Steps

1. From the Navigator for the System Administrator responsibility, choose Setup

> Profiles.

2. In the Responsibility field of the Find System Profile Values window, Enter
Proper Responsibility (e.g. Inventory, Vision Enterprises).

3. In the Profile Name field of the Find System Profile Values window, Enter
Profile Value (e.g. MO: Operating Unit) and click Find Button

4. Enter Proper Responsibility at Responsibility level.

5. Choose File > Save to save your work.

6. Repeat the above steps for different responsibilities.
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Define System Profile Options for All Dependent Responsibilities

7. Define MO: Operating Unit profile at Responsibility level:
Table 2-3 Oracle Enterprise Install Base System Profile Option Settings

Sysadmin --> Security--> Users

Oracle Inventory

Oracle Purchasing

Oracle Payables

Oracle Enterprise Install Base
CRL 11I Projects

CRL Assets Manager

Oracle General Ledger

Oracle Install Base Admin
Oracle Enterprise Install Base
Order Management Super User

Work in Process

Suggestion: A post-install step activates the responsibility for CRL Assets Manager
and CRL 11i Projects Manager - if this step has not been carried out, you may have
to enable these responsibilities beforehand.

8. For all the responsibilities defined above the following profile options
should be set:.

Table 2-4 Setting Profile Options for Responsibilities

Profile Options Profile Level

GL Set of Books Name Responsibility (All Responsibilities)
MO: Security Profile Responsibility (All Responsibilities)

HR: Business Group Responsibility (All Responsibilities)

HR: Security Profile Responsibility (All Responsibilities)

PA: Default Expenditure Site, Responsibility (All Responsibilities,
Organization Network Logistics)

FA: CRL Assets Enabled Responsibility (All Responsibilities
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Define Install Base Tracking ltem Options

Table 2-4 Setting Profile Options for Responsibilities

Profile Options Profile Level

PA: Licensed to use CRL Projects Site, Responsibility (All Responsibilities)

Service: Inventory Validation Responsibility (Enterprise Install Base, IB, OM,
Organization WIP)
QP: Item Validation Responsibility (Enterprise Install Base, IB, OM,
Organization WIP)

2.5 Define Install Base Tracking ltem Options

When an item is Enterprise Install Base tracking, any activity for that item passes a
message to Oracle Enterprise Install Base for tracking. To make an item Enterprise
Install Base tracking, check the Install Base tracking checkbox on the Service tab
when you define a master item.

The Install Base Tracking attribute must be controlled at the item master level. Items
become Install Base tracking across all organizations.

In addition, follow these restriction guidelines when setting up Oracle Inventory:

Item definition as IB tracking or depreciable has to be set at the Master
Organization level only.

Choose "Create depreciable inventory asset" from LOV of Asset Creation field
for Depreciable item.

Define all Enterprise Install Base items as inventory items.

If the Inventory Item checkbox is not marked, you cannot store or move the
item.

Enable Inventory Asset and Costing Enabled attributes for all items in
Enterprise Install Base.

These attributes let you enter and maintain costs for the items.
Designate serial number control be at the Master organization level.

This ensures that serial number control for an item is the same across all
inventory organizations.

Do not change serial control for an item after transactions have been entered.
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Define Install Base Tracking ltem Options

In Oracle Inventory, you may enter a miscellaneous issue transaction to remove
all on-hand inventory, change the serial control attribute, then enter a
miscellaneous receipt to restore the on-hand quantities. During the process of
correcting on-hand quantities, items that already have transactions are not be
effected. As a result records in Enterprise Install Base do not show the change in
the serial control attribute.

The Install Base tracking attribute of an item cannot be changed when on-hand
quantity is greater than zero.

Attribute changes are not applied to pre-existing transactions in the Enterprise
Install Base record. If you change the tracking attribute of an item from No to
Yes, transactions that occurred before the change have no record in Enterprise
Install Base. If you change the tracking attribute of an item from Yes to No,
Enterprise Install Base no longer processes the pre-existing transactions.

Note: In the Oracle Inventory patch set G, the Install Base tracking
flag is defined under the Service tab in the Item Master. Prior to
that, the same flag is called Network Logistics Trackable and
resides under the Inventory tab.
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3

Dependency Modules Setup

3.1 Oracle Inventory Setups

This section discusses the setup steps in Oracle Inventory that have a bearing on
how Enterprise Install Base functions.

3.1.1 Define Organization Classifications

Oracle Enterprise Install Base tracks those inventory items which you have defined
as Enterprise Install Base-tracking. Each module that interacts with Oracle
Enterprise Install Base passes messages that contain specific information for all
items that are marked as Enterprise Install Base-tracking. For these messages to be
sent and received successfully, the organizations you define must have these
classifications:

HR Organization

Use to associate employees, such as buyers and planners, with items within the
organization.

Inventory Organization
Use to define, maintain, transact, and have on-hand balances for item numbers.

Project Expenditure/Event Organization and Project Task Owning
Organization

Allows Oracle Inventory to associate items assigned to project and tasks to a
project clearing account, which collects the cost of that assigned material. Use to
monitor the expenditures for a project and task by reviewing the account
through Oracle Projects. You use capital projects to collect
construction-in-process (CIP) and expensed costs for assets you are building.
When you are ready to place the asset in service, you generate asset lines from
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the CIP costs in Oracle Projects. You can send these lines to Oracle Assets to
become depreciable, fixed assets. Therefore allow entry of capital project in
your organization and issue material to the Capital Projects only.

You must specify any additional classifications you need for your organization.

3.1.2 Defining Organization Parameters in Oracle Inventory

When you issue material to projects and tasks, all costs are initially charged to a
project clearing account. This account provides a convenient check point for
tracking project costs.

Project Cost Collection Enabled must be checked on the Costing Information tab.
These attributes let you enter and maintain costs for the items.

The organization parameters described below ensure that the costs associated to a
project or task are passed to the clearing account for the Inventory organization that
has been set up to own inventory items.

Use these steps to define organization parameters.

Prerequisites

You must define your organizations when you set up Oracle Inventory before you
can define the organization parameters.

Steps

1. Navigate to the Organization Parameters window.
2. Click the Inventory Parameters tab and enter:
= The Move Order Timeout Period
= The Move Order Timeout Action
3. Click the Costing Information tab and check Project Cost Collection Enabled.

4. Click the Other Accounts tab and enter the organization’s Project Clearing
Account number.

5. Choose File > Save to save your work.
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3.1.3 Define User-definable Transaction Types

Under the Inventory responsibility, you can define user-definable transaction types.
The following transactions must be defined to use Enterprise Install Base
miscellaneous. transactions.

Steps
1. Navigate to the Inventory > Setup > Transaction > Type window.

2. Click the User tab and enter name, source type, action, checkbox

3. Choose File > Save to save your work.

Table 3-1 Define Transaction Types

Name Source Type Action Check box

elB Issue to Project  Move Order Issue from Store Check on Project
Miscellaneous Issue Inventory Issue from Store Check on Project
to Project

Miscellaneous Inventory Receive into Store  Check on Project

receipt from Project

3.1.4 Define Normal ltem in Inventory

You must define an item master organization and at least one organization in
Enterprise Install Base.

Steps

1. Navigate to the Master Item window.
2. Enter the appropriate information into the header region of the window.
3. Click the Inventory tab.
4. Check Inventory Item.
Stockable and Transactable are checked by default.
5. Select Service tab and Check Install Base Tracking.
6. Enter or select information in the remaining fields of the window.

7. Choose File > Save to save your work.
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3.1.5 Define a Depreciable ltem in Inventory

You must define an item master organization and at least one organization in
Enterprise Install Base.

Steps
1. Navigate to the Master Item window.

2. Enter the appropriate information into the header region of the window.

3. Click the Inventory tab.

4. Check Inventory Item.

Stockable and Transactable are checked by default.

Select Service tab and Check Install Base Tracking.

Choose Create Depreciable Inventory Asset from LOV of Asset Creation field.

Enter or select information in the remaining fields of the window.

® N o o

Choose File > Save to save your work.

3.1.6 Sub-inventory Setup

Associate Asset Sub-inventories to a location.

= Use the Location field in the subinventory setup to link the deliver-to location
of the item with its asset location.

3.1.7 Define Inventory Period

Set the first Inventory Period, make sure you align this with the current period of
the other modules

Prerequisites
None

Steps
1. Navigate to the Accounting Close Cycle window.

2. Click on Inventory Accounting Periods

3. In the First Period region, enter the current period.
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4. Choose File > Save to save your work.

3.1.8 Additional Inventory Setup restrictions

Assigning cost to IB tracking items.

You must assign cost to each item that is IB tracking if you are using Oracle
Projects to accrue the expenditures.

Define Shipping, Inter-Organization Shipping.

Use the Inter-Organization Shipping window to define accounting information
and the relationships that exist between shipping and destination
organizations. You can specify whether an organization is a shipping
organization, a destination organization or both. For more information see
Oracle Inventory User Guide.

Note: For details on Oracle Inventory setup steps, please refer to
the Oracle Inventory Implementation Guide.

3.2 Oracle Purchasing Setups

When an organization receives an item, the subinventory material account is
debited and the AP accrual account is credited. When the item is issued to a project
and the cost collection process is run, the project clearing account is debited and the
project’s account is credited.

To ensure that Enterprise Install Base picks up the Project clearing account for the
charge account of purchase order, modify Oracle Account Generator as follows:

PO charge account = project clearing account

This modification ensures that the project clearing account used in the organization
matches the credit account generated by auto-accounting for receipt transactions.

In addition, heed the following restrictions when setting up Oracle Purchasing:

Set the match approval level to at least three-way matching.

Enterprise Install Base uses purchase order and invoice data to determine and

adjust costs. Three-way matching ensures that the purchase order quantity, the
receipt quantity, and the invoice quantity all match. You can also set the match
approval level higher, to four-way matching.
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If your organization’s default matching method is less than three-way, update

the matching level setting on the purchase order itself.

= Assign an asset category to Enterprise Install Base tracking items.

The asset category must not be an expense category and must belong to the
same Assets book as the book used by the Profile Option CSE:FA Book Type

Code. See Setting Profile Options.

Note: For details on Oracle Purchasing setup steps, please refer to
the Oracle Purchasing Implementation Guide.

3.3 Oracle Projects Setups

Following is a list of Oracle Projects setup specifications:

3.3.1 Define a Descriptive Flexfield for Expenditure ltems

The expenditure item descriptive flexfield is mandatory for asset creation. It
provides a way to view the attributes or grouping method values of an item.

1. Define this descriptive flexfield for Oracle Projects and call it Expenditure

Items.

2. Check the Displayed checkbox for all five segments in the flexfield.

3. Refer to the following table to define the five segments in the flexfield.

Table 3-2 Define segments in the flexfield

Name Window Prompt Column Value Set

Grouping Grouping Method One ~ ATTRIBUTES Enterprise Install

Method 1 Base Asset Category
(FA_CATEGORIES
table)

Grouping Grouping Method Two ~ ATTRIBUTE9 Enterprise Install

Method 2 Base Location (FA_
LOCATIONS table)

3-6 Oracle Enterprise Install Base Implementation Guide



Oracle Projects Setups

Table 3-2 Define segments in the flexfield

Name Window Prompt Column Value Set

Grouping Grouping Method Three ATTRIBUTE10 PA Product Value

Method 3 (PA_SEGMENT _
VALUE_LOOKUPS
table)

Item number Item Number ATTRIBUTE6 50 chars (no
validation)

Serial number Serial Number ATTRIBUTE? 50 chars (no
validation)

4, In addition, these restriction guidelines when setting up Oracle Projects:
= Issue Enterprise Install Base-tracking items only to Capital-type projects.

Oracle Projects cannot create assets in Oracle Assets from projects that are not
the Capital type. If items are issued to projects of either Contract or Indirect
type, then Enterprise Install Base does not have a record of the asset ID. When
you generate asset lines, no asset lines are generated for those items that do not
belong to the Capital-type project.

= Issue Enterprise Install Base-tracking items only to tasks that can be capitalized.
You can generate asset lines only on tasks that have been capitalized.

= Do not send installation and in-service messages against projects that have a
Closed status.

Enterprise Install Base does not validate whether or not the project has a Closed
status. It continues to change the item status to Installed or In Service. However,
you cannot generate asset lines against a closed project.

s CRL Projects and CRL Assets set up is required only if you use financial
management of IB tracking item.

= Asset generation will only be done for Projects with Project Types which have
USER DEFINED GROUPING METHOD as CIP method.

3.3.2 Setting Up Asset Creation Grouping Methods for Project Expenditure ltems

An asset can be created before a project is completed. The asset must be associated
to location and asset category information. CRL-Financials Enabled Projects can
send the associated information to Oracle Enterprise Install Base and
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CRL-Financials Enabled Assets. In turn, Oracle Enterprise Install Base uses this
information to update the assets and the inventory system.

Use this procedure to ensure that the assets created in CRL-Financials Enabled
Projects are associated to the required location and asset category information.

Prerequisites
None.

Steps
1. In the CRL Projects Manager Responsibility, select Project > Asset Creation.
2. Select values in the Asset Naming Convention window.

For Location and Category, the Grouping Element Number must correspond
with attribute 8, 9, or 10, depending on which attribute was chosen to indicate
location in the system-level descriptive flexfield setup.

3. Choose File > Save to save your work.

Note: For details on Oracle Projects and Oracle CRL-Financials
Enabled Projects setup steps, please refer to the Implementation
documentation for those products.

The following table shows the Asset Creation screen used to defining asset
generation in CRL Projects:

Table 3-3 Define Asset Creation

Setup / Asset Creation

Define Asset Name Task Name (from LOV)

Define Asset Description ~ Grouping Elementl =~ Grouping Element2 Task Name
Location Grouping Element2

Category Grouping Element1
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3.4 Oracle Assets Setups

The definitions of the Asset Locator and Asset Category key flexfields must be
compatible with the segments of the expenditure item descriptive flexfield defined
earlier.

If you use group depreciation and Oracle CRL- Financials, you must define the
Group Asset and Super Group key flexfields. The recommended values are shown
in the following table.

Note: For details on Oracle Assets setup steps, please refer to the
Oracle Assets Implementation Guide.

Table 3-4 Define Group Asset and Super Group key flexfields

Application Key Flexfield Suggested Segment Values
Oracle Assets Group Asset (1) City, (2) Network Element
Oracle Assets Super Group (1) Region, (2) Product Line

In addition, be aware of the following:

= Do not change or delete the link between the deliver-to and asset location once
an asset has been created.

Use the Locations form in Enterprise Install Base to initially link deliver-to and
asset location. After this initial link is created, changing or deleting the link
could corrupt the asset record.

= When assets are created through Enterprise Install Base, the asset key flexfield
value is null.

If you want need Enterprise Install Base to automatically populate this value,
you must customize the application.

= All assets must be related to an asset category. The Asset category will drive the
depreciable for the asset.

= FA book type will be used from CSE profile.
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When you define Asset Groups you are required to define the depreciation
method you will only find methods which have a calculation method of FLAT
RATE.

3.5 Related Setup Steps within Oracle Install Base

3.5.1 Oracle Enterprise Install Base Module Integration Setups

After Oracle Inventory, Oracle Projects, Oracle Assets, and Oracle Purchasing have
been installed and set up, set up Enterprise Install Base. During the integration
setup of Oracle Enterprise Install Base, you determine:

How HZ location, HR location (inventory location) map to asset location

How messages are queued in the message history log and where the log is
stored.

The method Enterprise Install Base uses to calculate invoice price variance (IPV)
requires this restriction. However, price tolerances are permitted.

Do not modify the Oracle Account Generator logic for deriving the depreciation
expense account.

The setup steps for the Oracle Install Base module are:

Set Profile Option
Associate HR Locations to Asset Location
Associate HZ Locations to Asset Location

Make sure the The Install Parameter is check.

3.5.2 Setup Asset Locations

Enterprise Install Base has ability to correlate HR locations to HZ locations.

HR locations are inventory locations used to receive material. HZ locations are used
to deploy equipment on the field. You need to establish the link between HR
locations to HZ locations in order to perform automatic financial updates when a
material movements occur.
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3.5.3 Defining HZ Locations

You need to define asset location then link HZ location to asset location. To
pre-define the HZ location, use the following steps:

Prerequisites
Item and Organizations must be defined.

Steps

1.

2
3.
4
5

From Oracle Install Base responsibility, choose Setups > Enter Locations.
Enter complete address in HZ location setup window.

Enter the description of the HZ location.

Enter HZ location code.

Choose File > Save to Save your work.

3.5.4 Defining Asset Locations
Assign HR and HZ locations to the Asset location using Asset Location Setup.

Prerequisites

HR and HZ locations must be defined.

Steps

1.

2
3
4
5.
6
7

From Oracle Install Base responsibility, choose Setups > Asset Locations Setup.
Select location source as HR or HZ.

Choose location code from LOV.

Assign Asset location.

Enter active start date.

You can disable the particular relationship by entering active end date

Choose File > Save to Save your work.

Dependency Modules Setup 3-11



Additional Setup Restrictions

3.5.5 Check Install Parameter

You need to make sure the Install Parameter is check.
Prerequisites

None.

Steps
1. Navigate to Setups/Install Parameters.

2. Check the "Freeze" option.

3.6 Additional Setup Restrictions

In addition to the restrictions discussed in the sections for Oracle Inventory, Oracle
Assets, Oracle Projects, and Oracle Purchasing, heed the following restrictions for
other related modules:

= Define the quantity tolerance in Oracle Payables as zero.

The method Enterprise Install Base uses to calculate invoice price variance (IPV)
requires this restriction. However, price tolerances are permitted.

= Do not modify the Oracle Account Generator logic for deriving the depreciation
expense account.

The depreciation expense account is derived from the book type (corporate or
tax) and the asset category. Enterprise Install Base assumes that the depreciation
expense account remains unchanged as a result of subinventory or
inter-organization transfers.

Note: Use a standard setup for Oracle Purchasing, Oracle Assets,
Oracle General Ledger, Oracle Payables, and the Oracle Human
Resource Management System (HRMS). For detailed setup
information on all of these applications, except Oracle HRMS,
consult the appropriate documentation set. For detailed setup
information on Oracle HRMS, please refer to the Oracle HRMS
implementation documentation appropriate for the country where
the application is being installed.
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3.7 Administering Enterprise Install Base

This topic group provides task-based procedures that are required for ongoing
system maintenance and includes information on administration tools and utilities.

3.7.1 Each Transaction Generates a Message

Every transaction of a trackable item generates a message to the application. When
the application receives a message, it searches the Enterprise Install Base tables for a
record of the item. If it finds the record and all the attributes have been defined in
the record, the transaction occurs without errors.

However, when a transaction results in an error, the related message is sent to the
appropriate log. For example, if a Receipt-to-Project transaction of a normal item is
missing attributes for category or location, a fatal error occurs. The message that is
sent as a result of this transaction is sent to the Error Log.

3.7.2 Understanding the Message Dequeuer

A message dequeuer is a background process that continuously polls a queue and
processes the items from the queue. The message dequeuer removes messages from
the message queue on a first-in, first-out (FIFO) basis. Message queues are
maintained by Oracle Advanced Queueing (OAQ). For information about message
queues, see also:

s The Oracle Service Fulfillment Manager Queues
= Administering the System Queues
= Managing the System Queues

You can manage the message queues in either Oracle Service Fulfillment Manager
or Oracle Number Portability. Enterprise Install Base uses the messaging system
that is maintained in Service Delivery Platform (SDP).

When you start a message queue, a controller process automatically starts the
dequeuers. For more information about starting and suspending a message queue,
see:

s Oracle SDP Start
= Oracle SDP Stop

Before starting the transaction make sure that the Service fulfillment manager queue
is running.
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To do that change the responsibility to SFM System Administrator
Navigate to Setup/ Concurrent/ Administer Manager

Make sure SFM Event Manager Queue Service is running

3.8 By Passing the Service Fulfillment Queue

Enterprise Install Base doesn’t recommend bypassing the service fulfillment queue.
Bypassing a queue may cause slower applications performance. However you have
a choice of using the queue or bypassing it. To bypass, simply set the CSE profile
option ‘CSE: Bypass Event Queue to “Y’. Once you set this option then the
transactions will be directly updated to Enterprise Install Base.

There is no change in the standard business flows except for the Asset Retirements.
If you are bypassing the queue then after asset retirement you need to run ‘Import
Asset Retirement- Reinstatement to Install Base” program. This will update the CSI_
I_ASSETS table in IB.

When you choose this option, then you may set the Inventory Transaction
Processing user profile as described below:

TP:INV Transaction Processing Mode

Indicates the processing control for transacting items. Available values are:

Table 3-5 Available values for transaction items

Processing Description

On-line processing Processes transactions while you wait, and control is
returned once transaction processing is completed.

Background Processing Upon commit, control returns immediately to you,
allowing you to processing continue working. The
transactions are executed on a periodic basis.

Immediate concurrent ~ Upon commit, Inventory spawns the concurrent
processing process and returns control immediately to you,
allowing you to continue working.

Displays the concurrent request number of the
concurrent process executing the transaction.
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Processing

Description

Form level processing

Processes transactions using the processing control
option you choose for that particular type of
transaction. You must also set the Inventory profile
options for Inter-Organization Transfer, Miscellaneous
Issue and Receipt, Receive Customer Return, Return to
Customer, and Transfer Between Subinventories. If you
are using Oracle Work—-in—Process, you must set the
WIP profile options Completion Material Processing,
Completion Transaction Form, Material Transaction
Form, Move Transaction, Operation Backflush Setup,
and Shop Floor Processing.

The value you choose for this profile overrides values you set for individual
transaction profiles unless you choose Form level processing. Inventory predefines
a value of Immediate concurrent processing for this profile for all levels upon
installation. This profile is updatable at all levels.

For more information please refer to Inventory User Guide: Inventory Profile

Options.

3.9 Considerations for Future Upgrade Paths

The following are considerations for future System-Level upgrades:

= System Profiles

s Enabled Workflows

= Employees and Security

= Multicurrency capabilities

s Customization Issues
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Enterprise Install Base API

This documents describes the Workforce Management APIs for Oracle Enterprise
Install Base.

You can use external Workforce Management System along with Enterprise Install
Base. eIB has an ability to integrate with the external WFM applications through the
APIs. Call these APIs to update eIB when the item is Installed or Un-installed, when
the item is put In-service or out of service and when the item is out of service or
item is moved.

4.1 Enterprise Install Base Public Package

The APIs provided for the new Enterprise Install Base are organized into the
following package:

CSE_WFMSG_TRX_PKG: Contains all procedures to manage item instances

for workforce management transactions.

The following table shows the Asset Creation screen used to defining asset
generation in CRL Projects:

Table 4-1 CSE_WFMSG_TRX_PKG APIs

Name Description

Proj_Item_Installed The prerequisite is that you must have an instance with
the usage code ‘In-process’ for the item you are trying
to install. This procedure creates/updates the item
instance with the usage code ‘Installed’, location type
code from ‘Project’ to “Hz_locations’. If there is an
existing instance with usage code ‘Installed’, then it
updates the same or otherwise it will create a new
instance
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Table 4-1 CSE_WFMSG_TRX_PKG APIs

Name

Description

Proj_Item_Uninstalled

Proj_Item_In_Service

In_Service

Out_Of_Service

The prerequisite is that you must have an instance with
the usage code ‘Installed’ for the item you are trying to
uninstall. This procedure updates the item instance with
usage code ‘In-Process’, location type code from "Hz_
locations’ to ‘Project’ .

The prerequisite is that you must have an instance with
the usage code ‘Installed” for the item you are trying to
put into service.This procedure creates /updates the
item instance with Usage code ‘In-service’. If there is
an existing instance with usage code ‘In-service’, then it
updates the same or otherwise it will create a new
instance.This procedure creates expenditure items in
the projects interface table.The transactions created by
this procedure will be used by ‘Create Assets for
Normal Items * program.

The prerequisite is that you must have an instance with
the usage code ‘Out of Service” for the item you are
trying to put in service.This procedure creates/updates
the item instance with Usage code ‘In-service’. If there
is an existing instance with usage code ‘In-service’, then
it updates the same or otherwise it will create a new
instance.

The prerequisite is that you must have an instance with
the usage code ‘In Service” for the item you are trying
to put out of service.This procedure creates/updates
the item instance with Usage code ‘Out of Service’. If
there is an existing instance with usage code ‘Out of
Service’, then it updates the same or otherwise it will
create a new instance.
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Table 4-1 CSE_WFMSG_TRX_PKG APIs

Name Description

Item_Move The prerequisite is that you must have an instance with
the usage code ‘Out of Service” for the item you are
trying to move.This procedure creates/updates the
network location of the item instance with Usage code
‘Out of Service’ . If there is an existing instance with
usage code ‘Out of Service’,network location as ‘From
Network Location’, then it updates the network
location with “To Network Location” or otherwise it
will create a new instance with usage code ‘Out of
Service’ network location as “To Network
Location’.The transactions created by this procedure
will be used by the ‘Interface Move Transactions to
Fixed Assets’ concurrent program.

4.2 Package CSE_WFMSG_TRX_PKG

Contains all APIs for instance management for workforce management
transactions.

s Proj_Iltem_Installed

= Proj_Item_Uninstalled
s Proj_Item_In_Service
s In_Service

s Out_Of Service

s Item_Move

4.2.1 Proj_ltem_installed
Procedure Proj_Item_Installed
(p_item_id IN NUMBER,
p_revision IN VARCHAR?2,
p_lot_number IN VARCHAR?2,
p_serial number IN VARCHAR2,
p_quantity IN NUMBER,
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p_project_id IN NUMBER,
p_task_id IN NUMBER,
p_network_loc_code IN VARCHAR?2,
p_work_order_number IN VARCHAR2
p_transaction_date IN DATE,
p_transacted_by IN NUMBER,
p_return_status OUT VARCHAR?2,
p_error_msg OUT VARCHAR?2)

Parameter Descriptions

The following table describes the IN parameters associated with this APL

1. IN Parameters :

Parameter Data Type Null Required Description and Validations
p_item_id NUMBER NOTNULL  YES Inventory item identifier
p_revision VARCHAR2 NULL YES Item revision code
p_lot_number VARCHAR2 NULL YES Lot number

p_serial_ VARCHAR?2 NULL YES Serial number

number

p_quantity =~ NUMBER NOTNULL YES

p_project_id NUMBER NOTNULL YES

p_task_id NUMBER NOTNULL YES

p_network_ VARCHAR2 NOT

loc_code NULL

p_work_ VARCHAR?2
order_number

NULL
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Parameter Data Type Null Required Description and Validations
pP_ DATE  NOT NULL YES Date of the transaction
transaction_

date

p_transacted_ NUMBER NOTNULL  YES Employee id of the person

by

performing the transaction

The following table describes the OUT parameters associated with this API.

2. OUT Paramaters :

Parameter

Data Type Description

p_return_status

p_error_msg

VARCHAR2 Returns the status of the transaction

FND_API.G_RET_STS_SUCCESS
- successful
FND_API.G_RET_STS_ERROR

- error

FND_APIL.G_RET_STS_UNEXP_
ERROR

- Unexpected error

VARCHAR?2 The error message

4.2.2 Proj_ltem_Uninstalled

Procedure Proj_Item_Uninstalled

(p_item_id
p_revision
p_lot_number
p_serial_number
p_quantity
p_project_id

IN
IN
IN
IN

IN

IN

NUMBER,
VARCHAR?,
VARCHAR?,
VARCHAR?,

NUMBER,

NUMBER,
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p_task_id IN NUMBER,
p_network_loc_code IN VARCHAR?2,
p_work_order_number IN VARCHAR?,

p_transaction_date IN DATE,

p_transacted_by IN NUMBER,
p_return_status OUT VARCHAR?2,
p_error_msg OUT VARCHAR?2)

Parameter Descriptions

The following table describes the IN parameters associated with this APL

1. IN Parameters :

Parameter Data Type Null Required Description and Validations

p_item_id NUMBER NOTNULL  YES Inventory item identifier

p_revision VARCHAR2 NULL YES Item revision code

p_lot_number VARCHAR2 NULL YES Lot number

p_serial_ VARCHAR2 NULL YES Serial number

number

p_quantity NUMBER NOTNULL YES Quantity transacted

p_project_id NUMBER NOTNULL YES The system-generated number
that uniquely identifies the
project

p_task_id NUMBER NOTNULL YES The system-generated number
that uniquely identifies the
task

p_network_ VARCHAR2 NOT CLLI code from HZ_LOCATIONS

loc_code NULL

p_work_ VARCHAR?2 NULL Work order number

order_number

p_ DATE  NOT NULL YES Date of the transaction

transaction_

date
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Parameter Data Type Null Required Description and Validations
p_transacted_ NUMBER NOTNULL YES Employee id of the person
by performing the transaction

The following table describes the OUT parameters associated with this APL
2. OUT Parameters :

Parameter Data Type Description

p_return_status VARCHAR2 Returns the status of the transaction
FND_APIL.G_RET_STS_SUCCESS
- successful

FND_API.G_RET_STS_ERROR
- error

FND_APIL.G_RET_STS_UNEXP_
ERROR

- Unexpected error

p_error_msg VARCHAR2 The error message

4.2.3 Proj_ltem_In_Service
Procedure Proj_Item_In_Service
(p_item_id IN NUMBER,
p_revision IN VARCHAR?2,
p_lot_number IN VARCHAR2,
p_serial number IN VARCHAR2,

p_quantity IN NUMBER,
p_effective_date IN DATE,

p_project_id IN NUMBER,
p_task_id IN NUMBER,

p_network_loc_code IN VARCHAR2,
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p_work_order_ number IN VARCHAR2,

p_transaction_date IN DATE,
p_transacted_by IN NUMBER,
p_return_status OUT VARCHAR?2,
p_error_msg OUT VARCHAR?2)

Parameter Descriptions

The following table describes the IN parameters associated with this APL

1. IN Parameters :

Parameter Data Type Null Required Description and Validations

p_item_id NUMBER NOTNULL  YES Inventory item identifier

p_revision VARCHAR2 NULL YES Item revision code

p_lot_number VARCHAR2 NULL YES Lot number

p_serial_ VARCHAR2 NULL YES Serial number

number

p_quantity NUMBER NOTNULL YES Quantity transacted

p_effective_ DATE NOTNULL YES Date the asset was placed in

date service

p_project_id NUMBER NOTNULL YES The system-generated number
that uniquely identifies the
project

p_task_id NUMBER NOTNULL YES The system-generated number

p_network_ VARCHAR2 NOT
loc_code NULL

p_work_ VARCHAR?2 NULL
order_number
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Parameter Data Type Null Required Description and Validations
p_ DATE  NOT NULL YES Date of the transaction
transaction_

date

p_transacted_ NUMBER NOTNULL  YES Employee id of the person
by performing the transaction

The following table describes the OUT parameters associated with this API.
2. OUT Parameters :

Parameter Data Type Description

p_return_status VARCHAR2 Returns the status of the transaction
FND_APIL.G_RET_STS_SUCCESS
- successful

FND_API.G_RET_STS_ERROR
- error

FND_APIL.G_RET_STS_UNEXP_
ERROR

- Unexpected error

p_error_msg VARCHAR2 The error message

4.2.4 In_Service

Procedure In_Service

(p_item_id IN NUMBER,
p_revision IN VARCHAR?2,
p_lot_number IN VARCHAR?2,
p_serial_number IN VARCHAR?2,
p_quantity IN NUMBER,
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p_network_loc_code IN VARCHAR2,
p_work_order_number IN VARCHAR2,

p_transaction_date IN DATE,
p_transacted_by IN NUMBER,
p_return_status OUT VARCHAR?2,
p_error_msg OUT VARCHAR?2)

Parameter Descriptions

The following table describes the IN parameters associated with this APL

1. IN Parameters :

Parameter Data Type Null Required Description and Validations
p_item_id NUMBER NOTNULL  YES Inventory item identifier
p_revision VARCHAR2 NULL YES Item revision code
p_lot_number VARCHAR2 NULL YES Lot number

p_serial_ VARCHAR?2 NULL YES Serial number

number

p_quantity NUMBER NOTNULL YES Quantity transacted
p_network_ VARCHAR2 NOT CLLI code from HZ_LOCATIONS
loc_code NULL

p_work_ VARCHAR?2 NULL Work order number
order_number

p— DATE  NOT NULL YES Date of the transaction
transaction_

date

p_transacted_ NUMBER NOTNULL YES Emp]oyee id of the person
by performing the transaction

The following table describes the OUT parameters associated with this API.
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2. OUT Parameters :

Parameter Data Type Description

p_return_status VARCHAR2 Returns the status of the transaction
FND_API.G_RET_STS_SUCCESS
- successful

FND_API.G_RET_STS_ERROR
- error

FND_API.G_RET_STS_UNEXP_
ERROR

- Unexpected error

p_error_msg VARCHAR?2 The error message

4.2.5 Out_Of Service

Procedure Out_Of Service

(p_item_id IN NUMBER,
p_revision IN VARCHAR?,
p_lot_number IN VARCHAR2,
p_serial_number IN VARCHAR2,
p_quantity IN NUMBER,

p_network_loc_code IN VARCHAR?,
p_work_order_ number IN VARCHAR2,

p_transaction_date IN DATE,
p_transacted_by IN NUMBER,
p_return_status OUT VARCHAR?2,
p_error_msg OUT VARCHAR?2)

Parameter Descriptions

The following table describes the IN parameters associated with this API.
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1. IN Parameters :

Parameter Data Type Null Required Description and Validations
p_item_id NUMBER NOTNULL  YES Inventory item identifier
p_revision VARCHAR2 NULL YES Item revision code
p_lot_number VARCHAR2 NULL YES Lot number

p_serial_ VARCHAR2 NULL YES Serial number

number

p_quantity NUMBER NOTNULL YES Quantity transacted
p_network_ VARCHAR2 NOT CLLI code from HZ_LOCATIONS
loc_code NULL

p_work_ VARCHAR2 NULL Work order number
order_number

p_ DATE NOT NULL YES Date of the transaction
transaction_

date

p_transacted_ NUMBER NOTNULL YES Employee id of the person
by performing the transaction

The following table describes the OUT parameters associated with this API.
2. OUT Parameters :

Parameter Data Type Description

p_return_status VARCHAR2 Returns the status of the transaction
FND_API.G_RET_STS_SUCCESS
- successful

FND_API.G_RET_STS_ERROR
- error

FND_API.G_RET_STS_UNEXP_
ERROR

- Unexpected error

p_error_msg VARCHAR?2 The error message
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4.2.6 Item_Move
Procedure Item_Move

(p_item_id IN NUMBER,
p_revision IN VARCHAR?2,
p_lot_number IN VARCHAR?2,
p_serial_number IN VARCHAR?,
p_quantity IN NUMBER,
p_from_network_loc_code IN VARCHAR?2,
p_to_network_loc_code IN VARCHAR?2,
p_work_order_number IN VARCHAR?2,
p_transaction_date IN DATE,
p_transacted_by IN NUMBER,
p_return_status OUT VARCHAR?2,
p_error_msg OUT VARCHAR?2)

Parameter Descriptions
The following table describes the IN parameters associated with this API.

1. IN Parameters :

Parameter Data Type Null Required Description and Validations
p_item_id NUMBER NOTNULL YES Inventory item identifier
p_revision VARCHAR2 NULL YES Item revision code
p_lot_number VARCHAR2 NULL YES Lot number

p_serial_ VARCHAR2 NULL YES Serial number

number

p_quantity NUMBER NOT NULL YES Quantity transacted
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Parameter Data Type Null Required Description and Validations
p_from_ VARCHAR2 NOT CLLI code from HZ_LOCATIONS
network_loc_ NULL

code

p_to_network_ VARCHAR2 NOT NULL YES CLLI code from HZ_LOCATIONS
loc_code

p_work_ VARCHAR?2 NULL Work order number
order_number

p_ DATE  NOT NULL YES Date of the transaction
transaction_

date

p_transacted_ NUMBER NOTNULL YES Employee id of the person

by performing the transaction

The following table describes the OUT parameters associated with this API.
2. OUT Parameters

Parameter Data Type Description

p_return_status VARCHAR2 Returns the status of the transaction
FND_APIL.G_RET_STS_SUCCESS
- successful

FND_API.G_RET_STS_ERROR
- error

FND_APIL.G_RET_STS_UNEXP_
ERROR

- Unexpected error

p_error_msg VARCHAR?2 The error message
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