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Preface

Intended Audience
This document is intended for IT professionals who are tasked with implementing 

Oracle’s Knowledge Management .

This guide assumes you have a working knowledge of the following:

�  The principles and customary practices of your business area

�  Oracle’s Knowledge Management 

If you have never used Knowledge Management, Oracle suggests you attend one or 

more of the Oracle’s Knowledge Management  training classes available through 

Oracle University.

�  The Oracle Applications graphical user interface.

To learn more about the Oracle Applications graphical user interface, read the 

Oracle Applications User’s Guide.

See the section Other Information Sources, for more information about Oracle 

Applications product information.

Typographic Conventions
This manual uses the typographic conventions listed in the following table:

Convention Meaning

italic text Book titles

Courier text User commands, file content examples, directory names
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Support Contact Information

Training and Support

Training
Oracle offers training courses to help you and your staff master Oracle’s Knowledge 

Management  and reach full productivity quickly. You have a choice of educational 
environments. You can attend courses offered by Oracle University at any one of 
our many Education Centers. You can also arrange for our trainers to teach at your 

facility, or you can use Oracle Learning Network (OLN), Oracle University’s online 

education utility. In addition, Oracle training professionals can tailor standard 

courses or develop custom courses to meet your needs. For example, you may want 
to use your organization’s structure, terminology, and data as examples in a 

customized training session delivered at your own facility.

Support
From on-site support to central support, our team of experienced professionals 

provides the help and information you need to keep Oracle’s Knowledge 

Management  working for you. This team includes your Technical Representative, 
Account Manager, and Oracle’s large staff of consultants and support specialists 

with expertise in your business area, managing an Oracle8i server, and your 

hardware and software environment.

OracleMetaLink
OracleMetaLink is your self-service support connection with web, telephone menu, 
and e-mail alternatives. Oracle supplies these technologies for your convenience, 
available 24 hours a day, 7 days a week. With OracleMetaLink, you can obtain 

information and advice from technical libraries and forums, download patches, 
download the latest documentation, look at bug details, and create or update TARs.

UPPERCASE Structured Query Language (SQL) commands, initialization 
parameters, profile options, responsibilities, or environment 
variables

boldface text Menu, button, keyboard, and form options, emphasis

< > Angle brackets enclose user-supplied names. 

Note: Do not type the angle brackets.

Convention Meaning
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To use MetaLink, register at (http://metalink.oracle.com).

Alerts: You should check OracleMetaLink alerts before you begin to install or 

upgrade any of your Oracle Applications. Navigate to the Alerts page as follows: 
Technical Libraries/ERP Applications/Applications Installation and 

Upgrade/Alerts. 

Self-Service Toolkit: You may also find information by navigating to the 

Self-Service Toolkit page as follows: Technical Libraries/ERP 

Applications/Applications Installation and Upgrade.

Oracle Support Services offers a comprehensive portfolio of focused services that 
support the IT infrastructure your organization needs to meet the demands of 
e-business. Powerful and easy to purchase, these services range from subscriptions 

for software updates to premium support that delivers flexible solutions tailored to 

specific business needs. For more information, navigate to 

http://www.oracle.com/support

Documentation Accessibility
Oracle's goal is to make our products, services, and supporting documentation 

accessible to the disabled community with good usability. To that end, our 

documentation includes features that make information available to users of 
assistive technology. This documentation is available in HTML format, and contains 

markup to facilitate access by the disabled community. Standards will continue to 

evolve over time, and Oracle is actively engaged with other market-leading 

technology vendors to address technical obstacles so that our documentation can be 

accessible to all of our customers. For additional information, visit the Oracle 

Accessibility Program web site at http://www.oracle.com/accessibility/. 

Accessibility of Code Examples in Documentation
JAWS, a Windows screen reader, may not always correctly read the Java and 

SQL*Plus code examples in this document. The conventions for writing Java and 

SQL*Plus code require that closing braces should appear on an otherwise empty 

line; however, JAWS may not always read a line of text that consists solely of a 

bracket or brace.

http://www.oracle.com/accessibility/
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Other Information Sources
You can choose from many sources of information, including online documentation, 
training, and support services, to increase your knowledge and understanding of 
Oracle’s Knowledge Management .

If this guide refers you to other Oracle Applications documentation, use only the 

Release 11i versions of those guides.

Online Documentation
All Oracle Applications documentation is available online (HTML or PDF). Online 

help patches are available on MetaLink.

Related Documentation
Oracle’s Knowledge Management shares business and setup information with other 

Oracle Applications products. Therefore, you may want to refer to other product 
documentation when you set up and use Oracle’s Knowledge Management .

You can read the documents online by choosing Library from the expandable menu 

on your HTML help window, by reading from the Oracle Applications Document 
Library CD included in your media pack, or by using a Web browser with a URL 

that your system administrator provides. 

If you require printed guides, you can purchase them from the Oracle Store at 
http://oraclestore.oracle.com.

Documents Related to All Products

Oracle Applications User’s Guide
This guide explains how to enter data, query, run reports, and navigate using the 

graphical user interface (GUI) available with this release of Oracle’s Knowledge 

Management (and any other Oracle Applications products). This guide also 

includes information on setting up user profiles, as well as running and reviewing 

reports and concurrent processes. You can access this user’s guide online by 

choosing “Getting Started with Oracle Applications” from any Oracle Applications 

help file.

Oracle Self Service Web Applications Implementation Manual
This guide contains overviews, task and reference information about Oracle 

Self–Service Web Applications.
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Oracle Applications Messages Manual
This manual contains a listing of application messages that appear across the Oracle 

Applications product families.

Documents Related to This Product

Oracle CRM Technology Foundation Concepts and Procedures
This guide explains the setup and usage of Oracle CRM Technology Foundation 

features that Knowledge Management uses.

Oracle CRM Technology Foundation Implementation Guide
This guide provides information on setting up Oracle CRM Technology Foundation, 
a mandatory dependency for Oracle’s Knowledge Management .

Oracle Inventory User’s Guide
This guide provides information on setting up Oracle Inventory.

Oracle iSupport Implementation Guide
This guide details the implementation of Oracle iSupport.

Oracle8i interMedia Text Reference
This guide explains how to set up synonym files in Oracle8i interMedia, a necessary 

step to implement synonym product search functionality in Oracle’s Knowledge 

Management .

Implementing Oracle CRM: ERP Functional Checklist, Release 11i
This document provides information on the functional flows of Oracle Enterprise 

Resource Planning (ERP) Applications when integrated with Oracle Customer 

Relationship Management products. It is available on Oracle MetaLink.

Implementing Oracle CRM: Foundation Functional Checklist, Release 11i
This document provides information on the functional flows of other Oracle 

Foundation Applications when integrated with Oracle Customer Relationship 

Management products. It is available on Oracle MetaLink.
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Installation and System Administration

Oracle Applications Concepts
This guide provides an introduction to the concepts, features, technology stack, 
architecture, and terminology for Oracle Applications Release 11i. It provides a 

useful first book to read before an installation of Oracle Applications. This guide 

also introduces the concepts behind Applications-wide features such as Business 

Intelligence (BIS), languages and character sets, and Self-Service Web Applications.

Installing Oracle Applications
This guide provides instructions for managing the installation of Oracle 

Applications products. In Release 11i, much of the installation process is handled 

using Oracle Rapid Install, which minimizes the time to install Oracle Applications, 
the Oracle8 technology stack, and the Oracle8i Server technology stack by 

automating many of the required steps. This guide contains instructions for using 

Oracle Rapid Install and lists the tasks you need to perform to finish your 

installation. You should use this guide in conjunction with individual product 
user’s guides and implementation guides.

Upgrading Oracle Applications
Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or 

Release 11.0 products to Release 11i. This guide describes the upgrade process and 

lists database and product-specific upgrade tasks. You must be either at Release 

10.7(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 

11i. 

You cannot upgrade to Release 11i directly from releases prior to 10.7.

Maintaining Oracle Applications
Use this guide to help you run the various AD utilities, such as AutoUpgrade, 
AutoPatch, AD Administration, AD Controller, AD Relink, License Manager, and 

others. It contains how-to steps, screenshots, and other information that you need to 

run the AD utilities. This guide also provides information on maintaining the 

Oracle applications file system and database.

Oracle Applications System Administrator’s Guide
This guide provides planning and reference information for the Oracle Applications 

System Administrator. It contains information on how to define security, customize 

menus and online help, and manage concurrent processing.
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Other Implementation Documentation

Oracle Workflow Guide
This guide explains how to define new workflow business processes as well as 

customize existing Oracle Applications-embedded workflow processes.You also use 

this guide to complete the setup steps necessary for any Oracle Applications 

product that includes workflow-enabled processes.

Oracle CRM Application Foundation Implementation Guide
Many CRM products use components from CRM Application Foundation. Use this 

guide to implement CRM Application Foundation correctly.

About Oracle
Oracle Corporation develops and markets an integrated line of software products 

for database management, applications development, decision support, and office 

automation, as well as Oracle Applications, an integrated suite of more than 160 

software modules for financial management, supply chain management, 
manufacturing, project systems, human resources, and customer relationship 

management.

Oracle products are available for mainframes, minicomputers, personal computers, 
network computers, and personal digital assistants, allowing organizations to 

integrate different computers, different operating systems, different networks, and 

even different database management systems, into a single, unified computing and 

information resource.

Oracle is the world’s leading supplier of software for information management, and 

the world’s second largest software company. Oracle offers its database, tools, and 

applications products, along with related consulting, education, and support 
services, in over 145 countries around the world.
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1
Introduction

This chapter provides an introduction to Oracle’s Knowledge Management. The 

topics include:

� Oracle’s Knowledge Management Overview

� New in this Release

� Obsolete in this Release

� Oracle’s Knowledge Management Architecture and Technology

1.1 Oracle’s Knowledge Management Overview
Oracle’s Knowledge Management is a comprehensive internet information 

management system that utilizes Oracle-developed knowledge capture, storage, 
and distribution tools. Implementing Oracle’s Knowledge Management provides 

the features of solution search, creation, organization, and immediate access to new 

solutions. Oracle’s Knowledge Management provides focused results that more 

directly relate to the issues being researched, thus reducing the cost of providing 

service while increasing customer satisfaction and gaining an edge over 

competitors.

Oracle’s Knowledge Management currently provides solution management 
functionality to other Oracle Applications like Oracle iSupport, Oracle Support, 
Oracle Field Service, Oracle Depot Repair, and Oracle eMail Center. The architecture 

has been designed to support diverse use, and is expected to be used by other 

Oracle products. 

All Knowledge Management users can search for published solutions in the 

Knowledge Management repository. The users can be segregated as internal and 

external or end users. External users can view and search published solutions. 
Internal users include customer service representatives (CSR), knowledge workers, 
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and Knowledge Management administrators. These users have various levels of 
setup and other process oriented permissions. To see the entire list of roles and 

permissions for internal users, navigate to Oracle’s Knowledge Management Seed 

Data.

1.1.1 Oracle’s Knowledge Management Features/Benefits
Oracle’s Knowledge Management has the following features:

1.1.1.1 Integration With Other Oracle Applications
Knowledge Management is integrated with other Oracle Applications like Oracle 

iSupport, Oracle Support, Oracle Field Service, Oracle Depot Repair, and Oracle 

eMail Center. Users of all these applications can search the same knowledge base for 

solutions and contribute new solutions to the knowledge base.

1.1.1.2 Multiple Search Methods 

Multiple search methods are available for searching in Oracle’s Knowledge 

Management.

The search methods include intermedia text, or keyword searches. A query can 

consist of a single search term or multiple search terms, the latter separated by 

spaces.

Oracle’s Knowledge Management uses InterMedia Text 8.1.7 for text searching.

1.1.1.3 Product, Platform, or Category Specific Search of Solutions
To focus search results, you can search for solutions under different products, 
platforms, or categories.

Product and platform fields on the Advanced Search screen allows a user to focus 

the search for solutions that contain the specific product and/or platform. The 

product and platform information is entered either from Oracle Support’s service 

request module or a user can select from a list of values that are taken from Oracle 

Inventory.

Category selection allows a user to select a category or a subcategory to focus the 

search to a specific information area more easily and quickly than adding additional 
query statements. 
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1.1.1.4 Finding Matching Statements/Solutions
While creating a statement, you can find matching statements or solutions in the 

database to prevent duplication.

1.1.1.5 Finding Related Statements/Solutions
You can reuse statements in more than one solution. Finding related 

solutions/statements is the process of following the statement’s reused links to 

locate other related solutions/statements. 

1.1.1.6 Creating and Searching by Multiple Solution Types
Information in Oracle’s Knowledge Management is organized into solutions, 
segmented into solution types. You can create multiple solution types and search by 

either symptom/cause/action (seeded) solution type or any custom solution type, 
such as problem/resolution, that you create. 

1.1.1.7 Solution Authoring Features
Solution authoring functionality includes creating new solutions and updating 

existing solutions. Authors can also check solutions in and out of the knowledge 

base. For source control, only one internal user can edit a solution and/or statement 
at one time. An author can set up the access level for solutions and also create new 

solutions by reusing existing statements. The Knowledge Management system 

checks and prevents the creation of duplicate solutions or statements.

1.1.1.8 Categorization of Solutions 

This allows the segregation of solutions in categories or folders for browsing or for 

performing a category specific search for solutions.

A merchant can categorize solutions for easy retrieval by its users. A user can select 
a category or a subcategory during search to focus the search to a specific 

information area.

1.1.1.9 Adding Attachments, External Links, and/or Comments to Solutions
This feature allows knowledge workers, customer service representatives, and 

Knowledge Management administrators to add supporting and related 

information, links to other objects, or comments to a solution to enhance its 

usefulness. Comments are used by solution reviewers as a communication channel.
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1.1.1.10 User Defined Search Result Order
You can select the way in which the search results for solutions will be displayed in 

the results list. A user can define the following display criteria:

� Relevancy based on percent match. For example, only display solutions that 
match the query 90% or better

� Number of rows to be displayed per screen

You can also sort by Score, Type, Number, Title, Last Update Date in either 

ascending or descending order. 

1.1.1.11 Solution Scoring 

Each solution is scored based on the text match performed by InterMedia Text. This 

score is shown to indicate the strength of the match to the query entered. The 

maximum score is 100. 

1.1.1.12 Integration with Oracle Workflow 

Oracle Workflow integration provides a workflow process in Oracle’s Knowledge 

Management to manage the solution approval and rejection process. It is a flexible 

method for Oracle’s Knowledge Management users to define solution processing 

steps that are specific to their needs.
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1.2 New in this Release
The following new features/functionality have been added in this release of 
Oracle’s Knowledge Management:

� Search and Browse Integration

� Advanced Search to Create Solution Integration

� Obsoleting Statements

� Dynamic Information Linking

� Mandatory Statements in Solution Authoring

� Solution “Get Lock” By Knowledge Management System Administrators

� Improved Search For Solutions In Progress Screen

� Statement Content Type

� New Profile Options

� New Permissions

� Enhancements to Comments

� Statement Ordering

� Solution and Statement Import/Export Functionality

� External Links and Attachments at the Solution Level

Search and Browse Integration
Search and browse functionality have been integrated on the Basic Search screen. 
You can browse through various categories that have been setup and search for 

solutions interchangeably. During search, search results replace the browsing 

section.

On the Basic Search screen, for a selected category, the solutions appear at the 

bottom of the screen in a table. You can view solutions updated in the last “N” days. 
The values for the View drop-down list are populated from the values defined in 

the Frequently Used Definition screen.

Advanced Search to Create Solution Integration
A tighter integration between the Advanced Search screen and the Solution Detail 
screen has been implemented to enable the search parameters to be passed back and 

forth. 



New in this Release

1-6 Oracle Knowledge Management Implementation Guide                              

Obsoleting Statements
The procedure to obsolete statements has been implemented in this release of 
Knowledge Management. An obsolete statement does not appear in the result list 
during the statement search process. Statements need to be obsoleted if they are 

removed from a solution in the review process and are not linked to any other 

solutions.

In previous versions of Knowledge Management, when a solution was obsoleted, 
there was no way to obsolete the associated statements. These statements remained 

active in the knowledge base without being linked to a solution. This affected the 

statement search process. The statements that had no links to any solutions were 

also displayed during statement search. It also affected the solution creation 

process. The users creating a solution could select orphan statements that may not 
have been the appropriate ones to be used in new solutions. 

Dynamic Information Linking
Dynamic information linking is the functionality that allows a solution author to 

select keywords or phrases within a solution and link them to external information. 
A user can select the word or phrase to display the information that the word or 

phrase in the solution is linked to. For example, a word or phrase may be linked to 

other bugs, other solutions, white papers, presentations, etc.

Dynamic linking functionality created in Oracle Quality Online will be used in 

Knowledge Management. To set dynamic links, see Setting Note Token Rules in 

the latest version of Oracle Quality Online Implementation Guide.

Mandatory Statements in Solution Authoring
A method to identify and add mandatory statement types in a solution type while 

creating a solution has been implemented. For this release of Knowledge 

Management, an asterix (*) is added to the left of each mandatory statement type in 

the statement type drop down list on the Statement Detail screen. The mandatory 

statements types to be included are determined by the Knowledge Management 
system from the solution type that you select. If all mandatory statement types are 

not included in a solution, then you can only save a solution that you can work on 

and complete later, but you will not be allowed to save and submit a solution to an 

authoring flow.

Note: Dynamic links in Knowledge Management are known as 

Note Token Rules in Oracle Quality Online.
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Solution “Get Lock” By Knowledge Management System Administrators
Knowledge Management administrators can get a lock for a solution, if the person 

who has locked the solution is no longer available to unlock it and complete the 

steps in an authoring flow. A Get Lock button and a Get Lock Confirmation screen 

have been added to the existing Solution Detail screen. A Get Lock button and the 

Get Lock Confirmation screen are only visible to a user who has CS_Solution_Get_
Lock permission.

In the previous release, solution locking was implemented to prevent other internal 
users from editing a solution that was being worked on by a user.

Improved Search For Solutions In Progress Screen
A new drop down box with three options has been added in the Search For 

Solutions In Progress screen. The options are: 

� Solutions I’m Currently Working On

� Solutions In Progress That I Can Check Out For Editing

� All Solutions In Progress

Statement Content Type
A procedure to display the statement detail in the same format in which a solution 

author specifies, has been implemented. You can select the content type for the 

statement detail from the Content Type drop-down list on the Statement Detail 
screen. The options are:

� Text: the content in the statement is rendered as text only. HTML tags are 

not rendered as HTML but as text.

� HTML: the content in the statement is rendered as HTML.

� HTML with Autolinks: is extensible HTML. The content in a statement is 

rendered as HTML and dynamic links are also displayed.

� Text with Autolinks: the content in a statement is rendered as text and 

dynamic links are also displayed.

Note: the statement summary field can only include text. The 

content type selection applies only to the statement detail field.
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New Profile Options
The following new profile options have been added in this release of Knowledge 

Management:

� Knowledge: Action for Positive Solution Feedback

� Knowledge: Knowledge Base Responsibility When Called From Another 

Application

� Knowledge: Default Authoring Flow Name

� Knowledge: Statement Display Order on Solutions Details Page

New Permissions
The following new permissions have been added in Knowledge Management:

Table 1–1 New Permissions and Descriptions

Permission Description

CS_USED_COUNT_UPDATE Knowledge: Search: Permission to update solution 
used count.

Permission to see the number of times the Yes button 
is selected for the question: “Can This Solution Solve 
Your Problem?”

CS_SOLUTION_GET_LOCK Knowledge: Authoring: Permission to get solution 
lock from user

A Knowledge Management system administrator 
specific permission to unlock a solution that has been 
locked by another user. The primary use for this 
permission is for a system administrator to unlock a 
solution and put it back in the authoring flow, if a 
person who has locked a solution is not available to 
unlock it.

CS_Advanced_Search Knowledge: Search: Permission to view the 
Knowledge Management Advanced Search screen.

CS_Solutions_Comments_Add Knowledge: Authoring: Permission to add solution 
comments.

CS_Personal_Profile_Update Knowledge: Other: Permission to update KNowledge 
management Personal Profile.

CS_Sol_Auth_Profile_Update Knowledge: Authoring: Permission to update 
Solution Authoring Profile

CS_Workflow_Setup_Update Knowledge: Setup: Permission to update solution 
authoring workflow setup
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Enhancements to Comments
The following enhancements to improve comment processing have been 

implemented:

� A complete list of comments, comment titles, and dates as links are available 

from the Statement Detail screen. An Expand Comments button is also available 

to display all comments with title dates and details. This helps internal users to 

easily view and update comments while reviewing a solution.

� The method of attaching comments has been changed, so that comments are not 
removed when a new solution version is created. The new comment processing 

has the following flow:

� Comments are attached to a solution through all its versions, leading to a 

new published solution.

� Any new comments added to an already published solution are added to 

the work-in-progress (WIP) copy of the solution.

� When the WIP copy of the solution is published, the original solution and 

the comments attached to it are obsoleted.

� To access the previous versions of a solution, you can write and use a SQL 

report.

Statement Ordering
This feature controls the order in which statements are displayed in a solution. The 

Knowledge: Statement Display Order on Solution Detail Page profile option (at the site 

level) is used to specify an order.

Solution and Statement Import/Export Functionality
The functionality to import and export solution and/or statements to or from 

Knowledge Management has been implemented. 

� Import/Export Statement: To Import and export statements, Import and Export 
buttons have been added on the Statement Detail screen. You can select the 

Import button to navigate and choose the source file (only text files) for the 

statement to be imported. Similarly, you can select the Export button to export 

CS_Categories_Update Knowledge: Setup: Permission to update categories

Table 1–1 New Permissions and Descriptions

Permission Description
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or download and save the statement being viewed. You can import or export 
one statement at a time in Knowledge Management.

� Import/Export Solution: Concurrent programs are used to import and export 
solutions in Knowledge Management. Knowledge Management Solution 

Export Program is used to export solutions from Knowledge Management and 

Knowledge Management Solution Import Program is used to import new 

solutions and to update existing solutions in Knowledge Management. 

External Links and Attachments at the Solution Level
The functionality of attaching external links and attachments is now available from 

the Solution Detail screen only. 

1.3  Obsolete in this Release
The following features/functionality have been obsoleted in this release of Oracle’s 

Knowledge Management:

� Forms version of Knowledge Management has been obsoleted.

� MES tab is no longer available from the Knowledge Management user interface.

� You cannot view External Links from the Statement Detail screen.

� You cannot add an attachment to a statement.

� The Relationship drop-down list on the Statement Search screen has been 

removed.

� View History on the Solution Detail screen has been obsoleted.

1.4 Oracle’s Knowledge Management Architecture and Technology
The hardware and software components required to implement Oracle’s 

Knowledge Management largely depend on your particular installation, but the 

minimum requirements include:

1.4.1 Minimum Hardware Requirements
The suggested hardware configuration for Oracle’s Knowledge Management is a 

series of Web servers in the front and a high performance database server machine 

in the back end. With global systems, the necessity for high performance database 

servers is even greater. Oracle recommends the following server requirements:
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� ERP database server machine— high throughput at fast speed (CPU)

� Web servers running Apache for external customers

� One forms server for administration

You can determine the actual sizing of the machines after completing capacity 

planning.

Specific hardware requirements depend on the particular installation that you 

perform. The hardware requirements listed in the following table are guidelines 

only, and assume a single-node environment.

1.4.2 Minimum Software Requirements
The minimum software requirements are listed in the following table.

1.4.3 Browser Requirements
It is recommended that you use Internet Explorer 5.5 as your default browser. 
Netscape Navigator 4.75 and above can also be used but you may experience some 

Java problems.

Table 1–2 Minimum Hardware Requirements

Hardware Requirement

CPU Minimum of two CPUs. Four or more are highly recommended.

Memory Minimum 256 MB. 1GB or more is highly recommended.

Disc Space 22 GB, including 1GB in /tmp (plus an additional 9GB if installing from 
a staging area)

Table 1–3 Minimum Software Requirements

Software Requirement

Database 8.1.7 version of Oracle8i

Middle Tier The middle-tier requirements are an Apache 3.0 version Web server and 
Oracle Forms 6.0 server (as a part of Oracle ERP 11i implementation). For 
faster page serving, you can also use a caching server in front of the Web 
server series. The caching server (for example, Calypso) then serves the 
static content through the cached TCP/IP packets (or cached pages). An 
invalidated cache results in service requests being directed to the Web 
servers.
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2
Before You Begin

This chapter includes the following topics:

� Related Documentation and Training

� Oracle’s Knowledge Management Dependencies

� Dependency Setup Checklist

2.1 Related Documentation and Training
Refer to the latest versions of the following manuals for more information about 
Oracle’s Knowledge Management and the related products/modules:

� Oracle’s Knowledge Management User Guide

� Implementing Oracle CRM:ERP Functional Checklist

� Oracle Applications Developer’s Guide

� Oracle CRM Application Foundation User Guide

� Oracle CRM Application Foundation Implementation Guide

� Oracle CRM Technology Foundation User Guide

� Oracle CRM Technology Foundation Implementation Guide

� Oracle iSupport User Guide

� Oracle iSupport Implementation Guide

� Oracle Support User Guide

� Oracle Support Implementation Guide

� Oracle eMail Center User Guide
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� Oracle eMail Center Implementation Guide

� Oracle Depot Repair User Guide

� Oracle Depot Repair Implementation Guide

� Oracle Quality Online User Guide

� Oracle Quality Online Implementation Guide

� Oracle Workflow Guide

� Oracle Field Service User Guide

� Oracle Field Service Implementation Guide

2.2 Oracle’s Knowledge Management Dependencies

2.2.1 Mandatory Dependencies
Oracle’s Knowledge Management integrates with other Oracle application modules 

to provide and extend its functionality. You have to set up the mandatory modules 

for Oracle’s Knowledge Management to run. The following list includes the 

mandatory modules for using Knowledge Management:

1. Access Application

2. Oracle Application Object Library

3. Oracle CRM Technology Foundation

4. Oracle InterMedia Text

5. Oracle Human Resources

6. Oracle CRM Application Foundation’s Task manager and Resource Manager

Access Application
Knowledge Management is not a stand alone application. Users can access Oracle’s 

Knowledge Management from any of the following applications:

� Oracle iSupport

� Oracle Support

� Oracle eMail Center

� Oracle Field Service
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� Oracle Quality Online

� Oracle Depot Repair

Oracle Application Object Library
Oracle Application Object Library (AOL) is a collection of pre–built application 

components and facilities for building and adding extensions to Oracle 

Applications. It is a required dependency of all Oracle Application modules. 
Knowledge Management uses AOL to access all standard application library objects 

e.g, users, menus, responsibilities, and profile options. For more information, see 

the latest version of Oracle Applications Developer’s Guide.

Oracle CRM Technology and Application Foundation
CRM Foundation 11i suite of applications supplies much of the infrastructure that 
underlies Oracle CRM applications, and hence is integral to Oracle’s Knowledge 

Management.

The Oracle CRM Foundation software suite is comprised of two distinct but 
interrelated groups: CRM Technology Foundation and CRM Application 

Foundation.

2.2.6.1 CRM Technology Foundation
Oracle’s CRM Technology Foundation (JTT) provides Java-based infrastructure 

software that is used to develop e-business solutions such as Sales, Marketing, 
Service, E-Commerce, Contracts, and Interaction Center applications. It offers a 

common platform for developing applications with HTML, XML, and Java. CRM 

Technology Foundation also provides user-friendly screens for centralized setup 

and administration. This web-based interface is called the System Administrator 

Console. The CRM User Management Framework documentation can be found 

within the documentation for this group. 

Setting Up Oracle CRM Technology Foundation Profile Options

Confirm the setup of the Oracle CRM Technology Foundation profile options. Refer 

to the latest version of Oracle CRM Technology Foundation Implementation Guide for 

more information. The CRM Technology Foundation stack is also known as the 

HTML Stack or Tech Stack.

For more information, see:

�  Oracle CRM Technology Foundation Implementation Guide

�  Oracle CRM Technology Foundation User Guide
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Oracle InterMedia Text
You must set up Intermedia Text to use Oracle’s Knowledge Management’s search 

functionality. 

InterMedia Text (iMT) provides integrated management of free text stored in the 

database, on websites, or on file systems. It extends the Oracle SQL query language 

to provide content-based search and to retrieve information from formatted 

documents and free text. This allows you to access a number of advanced text 
search capabilities from any SQL tool or interface.

InterMedia Text (iMT) 8.1.7 has features that improve index performance and 

ease-of-use. iMT also has features that are targeted in two key areas: 

� Structured documents 

� Multi-lingual databases.

For more information about InterMedia Text, navigate to:

� http://www.oracle.com/intermedia/ (external and internal users)

� http://otn.oracle.com/products/intermedia/index.htm (internal users)

Oracle Human Resources
Oracle’s Knowledge Management uses Oracle Human Resources to get employee 

data. Define or confirm the definitions of your employees in Oracle Human 

Resources Management System. For Oracle Human Resources Management System 

documentation, refer to the following titles available on MetaLink:

�  Implementing Oracle HRMS

�  Using Oracle HRMS - The Fundamentals

�  Managing People Using Oracle HRMS

�  Customizing, Reporting and System Administration in Oracle HRMS

�  Managing Total Compensation Using Oracle HRMS

Oracle CRM Application Foundation’s Task Manager
All Oracle CRM products use Oracle CRM Application Foundation’s Task Manager 

for task management capabilities. It provides an effective way for organizations to 

respond to customer’s needs in time. Use the Task Manager to create, assign, 
schedule, prioritize, and manage all your tasks. You can access the Task Manager to 

create your tasks or to view your tasks. It can be used from other Oracle modules to 

provide integrated solutions or it can be used as a stand-alone product. 
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If you refuse a task or reassign a task to another employee, the task can generate a 

series of notifications for other users or managers. Tasks not performed in a specific 

time period can be set to go through an escalation process. Refer to the latest 
version of Oracle CRM Application Foundation User Guide for more information.

Oracle CRM Application Foundation’s Resource Manager
Resource Manager module is used in Knowledge Management to set up the various 

resource groups for authoring flows. The Resource Manager provides lists of 
resources, as individuals, groups, and teams, for applications to access and manage 

their resources. Resources are defined as employees, supplier contacts, parties, and 

partners that are used by the different CRM modules to accomplish business 

objectives. You can use Resource Manager to import and view resources, define 

resources, define roles and role types, create teams and groups, and organize 

resources within those teams and groups. Defining and organizing your resource 

information makes your resources available to the connected application modules 

for work action. Resources can be organized into groups and teams. Each group or 

team can be defined in one of two ways, a role, or a role type. 

2.2.2 Conditional Dependencies
The following Oracle CRM Application Foundation modules can be set up to 

provide additional functionality:

1. Notes Module of CRM Application Foundation

2. Oracle Workflow

3. Oracle Inventory   

2.2.6.2 CRM Application Foundation
Oracle’s CRM Application Foundation (JTA) consists of the following CRM 

applications: Territory Manager, Resource Manager, Notes, Calendar, Task Manager, 
Interaction History, Fulfillment, Assignment Manager, and Escalation Management. 
Documentation for this application group also includes information on using 

Spreadtables and TCF Servers for Gantt. For more information, see:

�  CRM Application Foundation Implementation Guide

�  CRM Application Foundation User Guide
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Notes
The Notes module is used in Knowledge Management to map statement types to 

note types. The Notes module enables the entire CRM suite to create, maintain, and 

share notes related to customers, opportunities, service requests, and other business 

tasks. The Notes module allows you to capture extensive textual, project relevant 
information within Oracle CRM applications. Notes module is seeded with 

predefined Note Types. 

Oracle Workflow
Business processes today involve getting many types of information to many 

individuals. Oracle Workflow allows you to automate and continuously improve 

business processes by routing information of any type, according to easily changed 

business rules, to people both inside and outside your enterprise. See the latest 
version of the Oracle Workflow Guide for more information.

Oracle Workflow provides a workflow process to Oracle’s Knowledge Management 
for solution approval and rejection processes. It is a flexible method for Oracle’s 

Knowledge Management system administrators to define solution processing steps 

that are specific to their needs.

Oracle Inventory
Oracle’s Knowledge Management uses Oracle Inventory to get the product and 

platform lists that are used to categorize solutions during solution search or 

solution creation. For more information on Oracle Inventory, see the latest version 

of Oracle Inventory User’s Guide.

The following profile options have to be set for selecting product and platform 

items from Inventory:

� Knowledge: Default Knowledge Base Product Category Set

� Service: Default Platform Category Set- determines the default platform 

category set for a service request.

2.2.3 Dependency Setup Checklist
The following table lists the suggested steps for setting up Oracle’s Knowledge 

Management dependencies. You must perform the required steps. You need to 

perform the optional steps only if you plan to use the related features or complete 

certain business functions.
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Using the Oracle Application Implementation Wizard
Use the Oracle Application Implementation Wizard (AIW) to coordinate 

dependency setups and identify the steps required to implement Knowledge 

Management. You can use the AIW to see the graphical overview of the steps 

involved, read online help on set up, and open the appropriate forms. You can also 

document your actions for further reference and review. Refer to Oracle Application 

Implementation Wizard User’s Guide for more details.

Accessing Oracle Forms
Some setups for Oracle’s Knowledge Management and its dependencies require 

that you use Oracle Forms. Launch Oracle Forms by navigating to:

http://<host>:<apache port>/

Select Apps Logon Links > VIS Logon through the Forms cartridge. When Oracle 

Forms launches, log in with the appropriate user name and responsibility to 

perform the required tasks.

Table 2–1 Dependency Setup Checklist

Step Required/Optional

Install Software Required

Set Up Oracle Application Object Library Required

Set up Oracle Human Resources Required

Set Up Oracle Inventory Optional

Set Up Oracle Workflow Optional

Set Up Oracle Intermedia Text Required

Set Up an Access Application Required

Set Up Oracle CRM Technology Foundation Required

Set Up Task Manager Required

Set Profile Options for Knowledge Management Required

Set Up Oracle’s Knowledge Management Required
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2.3 Installation and Dependency Verification
Before you start configuring the profile options and search for solutions or create 

solutions in Knowledge Management, check that you have completed the following 

prerequisites.

1. Verify that the installation and middle tier setups have been done correctly. 
Once the Rapid Installer Wizard finishes the installation, verify the proper 

installation and configuration of the following components:

�  Apache Server: Go to http://<host>:<apache port>/apachedocs/. You should see 

the Apache Server documentation page.

�  Apache JServ: Go to http://<host>:<apache port>/servlets/IsItWorking.

You should see a message verifying that Apache JServ is working.

2. Verify that the ERP applications are installed and functioning properly. Refer to 

the latest version of Implementing Oracle CRM: ERP Functional Checklist, Release 

11i document available on Oracle MetaLink for a description of the tasks 

required. 

3. Verify that the dependency setup has been done correctly. 
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3
Implementation Overview

This chapter provides a process overview about Oracle’s Knowledge Management 
users. The topics include:

� Process Overview

3.1 Process Overview
Oracle’s Knowledge Management has both internal and external users. All users 

can search for published solutions in the Knowledge Management repository. Each 

type of user in Oracle’s Knowledge Management has a pre defined set of 
permissions.

Roles determine screen-level permissions. Responsibilities determine the menus 

that a user will be able to view. 

� External users are end users who only have view and search access to published 

solutions. 

� Internal users include Knowledge Management agents, Knowledge 

Management workers, and Knowledge Management system administrators. 

The following table lists responsibilities, menus, and tabs associated with internal 
Knowledge Management users.

Table 3–1 Responsibilities, Menus, and Tabs for Internal Knowledge Management 
Users

Responsibility Description Menus Tabs

CS_KB_
KNOWLEDGE_
WORKER

Creates, edits, and technically 
reviews information in 
Knowledge Management

CS_KB_TOP_KW_
MENU

Authoring, Search,
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CS_KB_AGENT Interfaces with customers to 
record their problems and 
provides them existing 
solutions or creates new 
solutions

CS_KB_TOP_AG_
MENU

Authoring, Search

CS_KB_SYS_
ADMIN

An administrator with all 
Knowledge Management 
specific permissions including 
setup and other process 
oriented permissions

CS_KB_TOP_
MENU

Authoring, Search, 
and Setup

Table 3–1 Responsibilities, Menus, and Tabs for Internal Knowledge Management 
Users

Responsibility Description Menus Tabs
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4
Required Implementation Tasks

This chapter includes the mandatory tasks required to set up Oracle’s Knowledge 

Management. The topics include:

� Creating an Oracle’s Knowledge Management Administrator

� Setting Knowledge Management Profile Options

� Creating a Resource Group

� Setting Knowledge Management Profile Options

� Creating a New Authoring Flow

� Viewing Authoring Flows

� Creating a Statement Type

� Viewing a Statement Type

� Updating an Existing Statement Type

� Deleting a Statement Type

� Creating a New Solution Type

� Viewing a Solution Type

� Updating a Solution Type

� Deleting a Solution Type

� Adding Solution Categories

� Editing Solution Categories

� Deleting Solution Categories

� Understanding Concurrent Programs
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� Setting Up Solution Authoring Profile

� Setting Up Recommended Solutions

� Setting Up Frequently Used Definitions for Solutions

� Creating a Solution

� Basic Search

� Advanced Search

� Searching for a Statement

� Searching Solutions in Progress

4.1 Creating an Oracle’s Knowledge Management Administrator
User access to Knowledge Management follows normal CRM user management 
rules. Access is controlled by specific responsibilities and roles given to users 

through the Oracle Forms user interface and the CRM System Administrator 

Console. 

Responsibility: The System Administrator assigns the administrator responsibility, 
Knowledge Base System Administrator, Vision Enterprises, (CS_KB_SYS_ADMIN), 
to the user who is the Knowledge Management Administrator. This user performs 

setups and maintenance for Knowledge Management. 

Role: The role assigned to the Knowledge Management Administrator is CS_
SYSTEM_ADMIN. (There is no “user friendly” name for this role; the programmatic 

name and the user-friendly name are identical.)

Import Users as Resources: The System Administrator and the Knowledge 

Management Administrator both must be imported as a resource into CRM 

Application Foundation Resources to be utilized by Knowledge Management.

4.1.1 Setting up a User as a Knowledge Management Administrator (CS_System_
Admin)

Steps
1. Log in to Oracle Forms application as system administrator. Select System 

Administrator responsibility.

2. Navigate to Security > User > Define. The Users form opens.
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3. In the Users form, enter the username for the Knowledge Management 
Administrator. 

� Example: Knowledge Management_ADMIN 

4. You must associate the user with an employee. Place your cursor in the Person 

field to enable the Person Names picklist. Search for and select the appropriate 

employee. 

5. Enter a password for the new user in the Password field. Use the Tab key to 

clear the field and re-enter the same password to validate.

6. In the Responsibilities block, search for and select CS_KB_SYS_ADMIN 

responsibility.

7. Save changes.

8. Next, set this user’s JTF profile options: Close the Users form and navigate to 

Profile > System. 

9. In the Find System Profile Values form, submit a query with the username of 
the new user in the User field and JTF%DEF% in the Profile field. The System 

Profile Values form will appear with a list of search results.

10. Find the JTF_PROFILE_DEFAULT_APPLICATION profile in the list and set it 
as follows at the user level (enter the number in the User column):

� JTF_PROFILE_DEFAULT_APPLICATION - 170

This tells the system that the default application for this user is the Oracle 

Service suite of applications (Knowledge Management, Charges, Counters, 
previously Install Base), whose application ID is 170.

11. Save changes and close the form.

12. Next, set this user’s JTF default responsibility. 

13. Follow the Finding Responsibility ID steps shown below to determine the 

Responsibility ID value. Make a note of the RESPONSIBILITY_ID.

14. Once you have the numerical value associated with the Responsibility ID, 
navigate to Profile > System. 

15. In the Find System Profile Values form, submit a query with the username of 
the new user in the User field and JTF%DEF% in the Profile field. The System 

Profile Values form will appear with a list of search results.

16. Set the JTF_PROFILE_DEFAULT_RESPONSIBILITY at the user level for the 

new administrator (enter the number in the User column):
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� JTF_PROFILE_DEFAULT_RESPONSIBILITY - <value is a dynamic 

number determined through Finding Responsibility ID steps shown 

below>

This tells the system that the default responsibility for this user is CS_KB_SYS_
ADMIN.

17. Save changes and close the form.

For more information on profile options, please see the Profile Options appendix.

Finding Responsibility ID
Use the following steps to find the RESPONSIBILITY_ID value of a 

responsibility. 

a. In Oracle Forms as System Administrator, navigate to Security > 

Responsibility > Define. The Responsibilities form opens.

b. From the top menu, select View > Find. Search for the responsibility.

c. Once found, highlight the responsibility, and click OK in the search 

window. The Responsibilities form is populated with the information for 

the responsibility.

d. With the cursor in any field of the record, select Help > Diagnostics > 

Examine. The Examine Field and Variable Values form opens.

e. In the Examine Field and Variable Values form, select RESPONSIBILITY_ID 

from the Field LOV. The Value field displays the value of 
RESPONSIBILITY_ID. 

f. Make a note of the numerical value displayed in the Value field. Use this 

number as the default responsibility ID at the user level when setting up 

new administrative users in Oracle Forms.

Assign Role(s)
Roles are collections of privileges that control access to specific pieces of 
functionality within a page; these granular access rights are known as permissions. 
A single role can have several permissions.

Follow the steps below to assign the Knowledge Management Administrator role 

(CS_SYSTEM_ADMIN) to the new Knowledge Management Administrator.

Steps
1. Log in to the JTF login screen as a system administrator. 
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2. Navigate to the Users screen:

� Users > Registration > User Maintenance

3. In the Users screen, query for the username of the user who will be the 

Knowledge Management Administrator. 

4. After the search yields the username, click the underlined hyperlink of the 

username to access the User Details screen. 

5. In the User Details screen, click the Roles button to access the User Role 

Mapping screen. A list of available roles will appear, along with a list of 
assigned roles. If this is a new user, the Assigned Roles column will be blank.

6. Highlight the CS_SYSTEM_ADMIN role in the Available Roles column, and 

use the right arrow (>) button to move it to the Assigned Roles column.

7. Click Update to save changes.

8. Sign out.

9. Verify that the new user can log in: Sign in to the JTF login screen as the newly 

created user. 

For additional information on how to assign roles in the CRM System 

Administrator Console, please consult:

� CRM Technology Foundation Concepts and Procedures

4.2 Setting Knowledge Management Profile Options
Profile options are seeded within all Oracle applications, and each module has its 

own specific set of profile options. Although all profile options are seeded, there are 

some settings that must be done by a system administrator. 

Oracle’s Knowledge Management has its own set of profile options. To see all 
Knowledge Management profile options, go to Oracle’s Knowledge Management 
Profile Options.

4.3 Creating a Resource Group
A resource group, in Knowledge Management, is a group of users who perform 

specific tasks in the solution authoring flow process. For example, a resource group 

for editorial review of solutions. 
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Login
Log on to Oracle Applications Forms.

Responsibility
System Administrator

Steps
1. Log on to Oracle Applications Forms as a system administrator. Responsibilities 

window opens.

2. Select Human Resource (HRMS Manager) responsibility for your organization.

3. Navigate to People> Enter and Maintain. People window opens. 

4. You can query for an existing user or create a new user.

5. Associate a user with an employee by following these steps:

a. Switch to System Administrator responsibility.

b. Navigate to Security > User > Define. Users window opens.

c. Query the user by entering some known value in the User name field.

d. Give the user workflow user responsibility. 

e. Save the record.

6. Create a resource for an employee or party by following these steps:

a. Switch the responsibility to the CRM Resource Manager.

b. Navigate to Maintain Resources >Import Resources. Selection Criterion 

window opens.

c. In the Resource Category field, select employee from the list.

d. Enter the employee name or employee number to narrow search criteria. 

e. Select Search. Search Results section is populated with the results.

f. Select Create Resource. Default Values window opens.

g. Enter mandatory and other information. Select OK.

h. Selected Resources window appears. Select Save Resource.

7. Create a resource group by following these steps:

a. Switch the responsibility to the CRM Resource Manager responsibility.
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b. Navigate to Maintain Resources > Groups. The Define Groups window 

opens. 

c. Enter the group name. Under the Members tab enter the names of the 

employees who will be in the group.

d. Navigate to the Usages tab. Select Oracle iSupport.

e. Save the record.

4.4 Understanding Concurrent Programs
A concurrent program runs simultaneously with other programs and/or tasks. 
Concurrent Processing is an Oracle Applications facility that lets long–running, 
data–intensive tasks run simultaneously with online operations, taking full 
advantage of multitasking and parallel processing. A System Administrator can 

monitor and control concurrent processing using a few simple forms in Oracle 

Applications Forms. For more information about Running Oracle Applications 

Reports and Programs see Oracle Applications User’s Guide.

4.4.1 Concurrent Programs for Knowledge Management
You have to run the following concurrent programs for the particular task 

associated with each:

� Knowledge Management Index Synchronization Program to synchronize the 

Intermedia index to display the solutions in the search process

� Knowledge Management Update Solution Used Count Program to update the 

solution used count for frequently used solutions/common problems. 

� Knowledge Management Solution Export Program to export solutions from 

Knowledge Management. It is a PL/SQL concurrent program that exports 

solutions from Knowledge Management using the user specified criteria. The 

results are saved in the XML format in the concurrent programs “out” file. This 

concurrent program downloads the solutions based on the following criteria:

� the category name from which the solutions have to be downloaded

� the status of all the solutions in a category, for example, Published or All

Note: If a group is not available, you must create one by entering 

a group name in the Define Groups window. Select Save.
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� Knowledge Management Solution Import Program to import new solutions 

and to update existing solutions in Knowledge Management. It is a Java 

concurrent program that can upload multiple solutions. The solutions to be 

imported can either be new solutions or existing solutions with updates. The 

Program uses the input xml file name (absolute path) and commit interval (how 

often to commit the import) parameters for running. The File has to contain the 

solutions in a XML format and have to be compliant with the Document Type 

Definition (DTD) for Knowledge Management, cskb_solution.dtd. This 

program checks the validity of the input xml document. If it is valid, the 

solutions are created, one after the other. If any data is invalid, the solutions are 

not created. If processing for any one solution fails, its changes are rolled back, 
and a log error message is written and the next solution in the file is imported. 
Each new solution to be uploaded can either have a Saved status, or it can be 

directly published, if the flow information is provided. Only published 

solutions can be updated, and have a published status after update. 
Attachments and external links are not supported but Statement Global Update 

is supported. Any statement with a statement number is globally updated 

according to the new data specified in the XML document. To see an example of 
a DTD file see Appendix D, "Sample File For Knowledge Management Solution 

Import Program"

Login
Log on to Oracle Applications Forms.

Responsibility
No responsibility is provided by default. You have to create your own 

responsibility.

Prerequisites
An assigned user with appropriate responsibility to run the above programs.

Steps
1. Log on to Oracle Applications Forms as a CRM system administrator. 

Responsibilities window appears. 

2. Select the System Administrator responsibility.

3. Navigate to Security -> Responsibility -> Define. Responsibilities window 

opens. 
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4. Query your system administrator responsibility to get the request group name 

for it. A request group is a collection of reports or concurrent programs. Your 

responsibility’s request group determines the requests that appear in the 

Submit Request window.

5. Navigate to Security -> Responsibility -> Request. Request Groups window 

opens. 

6. Query the request group name obtained for your system administrator 

responsibility.

7. Under the Requests section, add the concurrent request if it does not already 

exist.

8. Enter information in the following fields: 
Type = Program 

Name = concurrent program name

a.  To synchronize the InterMedia index:

� concurrent program name = Knowledge Management Index 

Synchronization Program

b. To update the solution used count for frequently used solutions:

� concurrent program name = Knowledge Management Update Solution 

Used Count Program

c. To export Solutions from Knowledge Management

� concurrent program name = Knowledge Management Solution Export 
Program

d. To import new solutions and/or update existing solutions within 

Knowledge Management

� concurrent program name = Knowledge Management Solution Import 
Program

9. Save the record.

4.4.2 Running a Concurrent Request
1. If required, switch the responsibility to system administrator.

2. Navigate to Concurrent ->Requests. Find Requests window opens.

3. Select Submit a New Request.
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4. Select Single Request. The Submit Request window opens.

5. Select the concurrent request (program) that you want to run.

6. Enter the required parameters. The concurrent programs can be scheduled to 

run periodically.

7. Select Submit to submit the request. You receive a confirmation that a request 
has been submitted.

4.4.3 Viewing the Concurrent Request Status
1. Navigate to Concurrent -> Requests. Find Requests screen opens.

2. You can enter the Request Id, or any other criteria to search for a request, or 

select All My Requests.

3. Select Find. The Requests screen opens.

4. Select Refresh Data to see the latest status

4.5 Setting Up Solution Authoring Profile
Authoring flows define the steps that a solution goes through in the solution 

authoring flow process. After creating a solution and submitting it to an authoring 

flow, an Knowledge Management internal user in the assigned user group can 

approve or reject a solution to the next or previous step. 

Members of a user group can set up their own profile, i.e, select one or more 

products and/ or categories in the Solution Authoring Profile screen to receive a 

notification that a solution related to that product and/or category is ready for 

review or when a solution is obsoleted or published. Members who do not 
subscribe to any product or category will not receive a notification but can search 

for all work-in-progress solutions from the Work Pending screen by selecting Search 

Work in Progress button. Refer to the Oracle Workflow Guide on how to set up and 

monitor a workflow.

Note: E-mail notifications will be sent only if the Workflow mailer 

is setup and properly configured. The PHP/Self Service Workflow 

notifications screen can also be used to view notifications. Please 

see the Workflow documentation for more information on how to 

start and configure the workflow mailer.
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Prerequisites
None

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Select Profile > Solution Authoring Profile.

4. In the Categories sub-section, select Add. The Select Solution Categories screen 

appears.

5. Check the check-box corresponding to the solution category that you want to 

select. Select OK.

6. In the Products sub-section, select Add. Select a product from the list or search 

for the product.

7. Select Update. Solution Authoring Profile is updated.

Note: Your system administrator can give you the values that 
should replace <host> and <apache port> in this URL.
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4.6 Creating a New Solution Type
Knowledge Management is seeded with the symptom/cause/action (SCA) solution 

type. Perform the following procedure to create a new solution type. For more 

information about solution types, see Oracle’s Knowledge Management User Guide. 
You cannot create duplicate solution types.

Prerequisites
Knowledge Management administrators with edit permissions (CS_Type_Edit) can 

create a new solution type.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup > Create Type. The Create Type screen appears.

4. From the Type drop-down list, select Solution.

5. Enter a name for the solution type in the Name field.

6. In the Description field, briefly describe the solution type. The description of a 

solution type is only for administrators and cannot be viewed by a customer.

7. Select Create. The Solution Type screen reappears with a Related section. You 

can associate statement types or external links to the solution type.

4.6.1 Associating a Statement Type to a Solution Type
You can associate a statement type to a solution type in the Associate Statement 
Types screen.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup > Solution Types. The Solution Types screen appears.

4. Select the Solution Type number link. The linked Solution Type screen appears.
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5. Select Add/Delete button. The Associate Statement Types screen appears.

6. To add a statement type to the existing solution type, choose the desired 

statement type from the Available Statements Types box and assign (>) it to the 

Selected Statement Types box.

7. Select Save to save the changes or Cancel to restore the original values and 

return to the previous screen.

4.6.2 Disassociating a Statement Type from a Solution Type
You can disassociate a statement type from a solution type in the Associate 

Statement Types screen.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup > Solution Types. The Solution Types screen appears.

4. Select the Solution Type Number link. The linked Solution Type screen appears.

5. Select Add/Delete button. The Associate Statement Types screen appears.

6. To delete a statement type from the existing solution, choose the desired 

statement type from the Selected Statement Types box and use the arrow key 

(<) to move it to the Available Statements Types box.

7. Select Save to save the changes or Cancel to restore the original values and 

return to the previous screen.

4.7 Viewing a Solution Type
In Knowledge Management, information is organized into solutions, segmented 

into solution types. Knowledge Management is seeded with 

symptom/cause/action (SCA) solution type.

Use this procedure to view existing solution types.

Prerequisites
All internal users can view existing solution types.
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Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup > Solution Types. The Solution Types screen displaying a list 
of existing solution types appears.

4. Select the numbered link to view details. You can also update the solution type 

and add/delete statement types or external links on this screen.

4.8 Updating a Solution Type
Use this procedure to update an existing solution type.

Prerequisites
You must have edit permissions (CS_Type_Edit) to edit a solution type.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup > Solution Types. The Solution Types screen with a list of 
existing solution types appears.

4. Select a Solution Type Number link to view the corresponding Solution Type 

screen.

5. To update the name or description of the Solution Type, enter the new 

information in the appropriate fields. 

6. Select Update.

7. To update the related statement types or external links, make the required 

selections.

8. Select Update to save the changes. Select Restore to return to original values. 
Select Delete to delete the solution type.
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4.9 Deleting a Solution Type
Use this procedure to delete a solution type. Do not delete the default solution type, 
SCA. This procedure cannot be undone.

Prerequisites
� Knowledge Management administrators must have edit permissions (CS_Type_

Edit) to delete a solution type. 

� You must delete any statement types associated with the solution type that you 

want to delete.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup> Solution Types. The Solution Type screen appears.

4. Select the solution type numbered link that you want to delete.

5. In the Solution Type screen, ensure that there are no related statement 
types/external links listed in the Related sub section.

6. To remove related statement types:

a. Select Add/Delete button. The Associate Statement Types screen appears. 
Disassociate the statement type from that solution type. 

b. Select Save. The Solution Type screen reappears with no statement types in 

the Related section.

7. Delete the associated external links.

8. Select Delete to delete the solution type.
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4.10 Creating a Statement Type
A statement is a description about any aspect of a problem, its cause, or resolution. 
Statements can be segmented into statement types. For more information about 
statement types, see Oracle’s Knowledge Management User Guide.

Prerequisite
Knowledge Management administrators with edit permissions (CS_Type_Edit) can 

create a new statement type.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup > Create Type. The Create Type screen appears.

4. In the Type drop-down list, select Statement.

5. Enter a name for the statement type in the Name field.

6. Enter a description for the statement type in the Description field.

7. Select Create. The Statement Type screen reappears with a Related section. You 

can also relate this statement type to a solution type, or external links. 

4.10.1 Relating/Mapping a Statement Type to a Note Type
Notes module in CRM Application Foundation is seeded with a set of predefined 

note types. Someone with CRM administrator responsibility can also create 

additional customized note types. 

Notes in a Service Request are used to document the description and progress made 

in resolving customer issues. Notes are used to capture details that can be used to 

search the knowledge base for solutions or to create new solutions. See Oracle 

Support User Guide for more information.

Each note type can be mapped to only one statement type, since this mapping is 

used to translate notes from other objects, especially service requests, to statement 
types in Knowledge Management.
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Prerequisite
Knowledge Management administrators with edit permissions (CS_Type_Edit) can 

relate a statement type to a JTF note type.

Steps
1. Create a new statement type or navigate to an existing statement type.

2. In the Related section, select External Links from the drop-down box.

3. Select Add. The Select an External Object screen appears. Select Note Type.

4. The Note Type screen appears. Search for the note type that you want to 

add to this statement type. Use (%) in Description field for a wildcard 

search. 

5. From the Search results select the JTF note type to add to the statement 
type. Select Update.

4.11 Viewing a Statement Type
Statement type is an identifying name associated with a particular part of the 

solution type. For example, symptom is a statement type within the 

symptom/cause/action solution type.

Prerequisites
Internal users with view permissions (CS_Statement_View) can view existing 

statement types.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup> Statement Types. The Statement Types screen appears.

4. Select the numbered link to navigate to the Statement Type screen for the 

selected statement type.
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4.12 Updating an Existing Statement Type

Prerequisites
Knowledge Management administrators with edit permissions (CS_Type_Edit) can 

edit a statement type.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup> Statement Types. The Statement Types screen appears.

4. Select the numbered link to navigate to the associated Statement Type screen.

5. Update the name or description of the statement type. 

6. Select Update.

7. In the Related section, you can add or update the solution types or external 
links.

8. Select Update.

4.13 Deleting a Statement Type
Use this procedure to delete a statement type. You cannot delete the default 
statement type. This procedure cannot be undone.

Prerequisites 

� Knowledge Management administrators with edit permissions (CS_Type_Edit) 
can delete a statement type. 

� Remove a solution type or external link in use by the statement type to be 

deleted.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.
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3. Navigate to Setup> Statement Types. The Statement Types screen appears.

4. Select on the numbered link of the statement type that you want to delete.

5. In the Statement Type screen, ensure that there are no related solutions types or 

external links listed in the Related sub section.

6. To remove a solution type or external link being used by a statement type:

a. In the Remove column, check the check boxes corresponding to the related 

solution types or external links.

b. Select Update.

7. After removing the related solution types or external links, select Delete.

4.14 Adding Solution Categories
You can add solution categories from the Managing Solution Categories screen.

Prerequisites
Administrative permissions to add solution categories.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup> Categories. The Manage Solution Categories screen 

appears.

4. Select the root category or one of the child categories to which you would like 

to add categories by selecting the corresponding radio button.

5. Select the Add button. A new field populated as New Category appears.

6. Remove New Category from the field and enter a new category name in that 
field.

7. Select Save.

4.15 Editing Solution Categories
You can edit solution categories from the Managing Solution Categories screen.
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Prerequisites
Administrative permissions to edit solution categories.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup> Categories. The Manage Solution Categories screen 

appears.

4. Select the root category or one of the child categories to edit by selecting the 

corresponding radio button.

5. Select the Edit button.

6. The selected category name appears in a field.

7. Edit the category name.

8. Select save.

4.16 Deleting Solution Categories
You can delete solution categories from the Manage Solution Categories screen.

Prerequisites
Administrative permissions to delete solution categories.

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup> Categories. The Manage Solution Categories screen 

appears.

4. Select the category you want to delete by selecting the corresponding radio 

button.

5. Select Delete.



Creating a New Authoring Flow

                                                             Required Implementation Tasks 4-21

4.17 Creating a New Authoring Flow
Authoring flows define the steps that a solution must follow in the solution 

approval or rejection process. 

Prerequisites
Administrative permissions to create a new authoring flow. 

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup >Authoring Flows. The Available Flows screen appears.

4. Select Create. The Authoring Flow Set Up screen appears.

5. Enter a flow name.

6. For each row, enter an order number, select the Step, Assigned to, and Action 

fields.

� Order: defines the sequence of steps in an authoring flow. It is a numbered 

order determining the order in which the steps will be viewed. e.g, a step 

with an order number 1 will be viewed before a step with an order number 

5.

� Step: represents the various transitions within an authoring flow. An 

authoring flow can be assigned any of the following steps: Deleted, Draft, 
Editorial Review, Public, Public Internal, Public Limited, Published, 
Technical Review, and Under Edit. You can modify these steps by 

modifying the CS_KB_STATUS lookup type.

� Assigned To: represents the resource group that has permissions to 

checkout and modify a solution in a specific step of an authoring flow. An 

authoring flow can be assigned to any of the user groups that have required 

permissions. For example, Business User Group, Editorial Reviewers, 
Technical Reviewers, etc.

� Actions: represents the action that the Knowledge Management system 

needs to take in a specific step of an authoring flow. An authoring flow can 

have Notify, Obsolete, or Publish actions. These actions imply the 

following:
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a. Notify: an E-mail is sent to the resource group assigned to the step. 

b. Obsolete: the system flag for the solution is set to Obsolete. The solution is 

still retained in the database, but it is no longer visible to any user. An 

E-mail is sent to the resource group assigned to the step

c. Publish: the system flag for the solution is set to Publish. If the distribution 

for the solution is set to External, then the solution is visible to external 
users. An E-mail is sent to the resource group assigned to the step

7. Select Update.

4.18 Viewing Authoring Flows
Authoring flows are the steps that a solution goes through in the solution approval 
or rejection process. 

Prerequisites
Administrative permissions to view (CS_Workflow_Setup_View) a new authoring 

flow. 

Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup >Authoring Flows. The Available Flows screen appears.

4. Select the Authoring Flow name to view flow details.

5. On this screen you can modify the order, step, assigned to, and action 

parameters.

6. You can also add a new row of values by selecting the More Rows arrow or 

delete a row by checking the Remove check box corresponding to the row that 
you want to remove. Select Update.

4.19 Setting Up Recommended Solutions
Use this procedure to add or delete solutions from the recommended solutions list 
and select the sort order in which the recommended solutions will appear.
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Login
http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Responsibility
� CS_KB_KNOWLEDGE_WORKER

� CS_KB_SYS_ADMIN

Prerequisites
Knowledge Management administrators and knowledge workers with view 

permissions (CS_Rec_Sol_View) can view recommended solutions 

Knowledge Management administrators with update permissions (CS_Rec_Sol_
Update) can update recommended solutions.

Steps
1. Navigate to Authoring > Top Solutions. The Recommended Solutions screen 

appears.

2. To add a solution to the list, select Add. The Add Recommended Solution 

screen appears. Enter the Solution Number. Select Done.

3. To rearrange a solution, check the check-box next to the solution to be moved 

and select Move Up or Move Down.

4. To delete a solution from the list, check the check-box next to the solution to be 

deleted.

5. Select Delete.

4.20 Setting Up Frequently Used Definitions for Solutions
You can provide your customers with a list of frequently used solutions within a 

specified time period. Use this procedure to set up frequently used definitions for 

solutions.

Prerequisites
Knowledge Management administrators with update permissions (CS_Freq_Used_
Def_Update) can add or update frequently used definitions.
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Steps
1. Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Setup > Frequently Used Definitions. The Frequently Used 

Definitions screen appears.

4. Select the time period that you want to use as a default time period.

5. Select Update.

6. To add a new time period, select Add. The Add Definition screen appears.

7. Enter the new name, description, and number of days.

8. Select Save.

4.21 Creating a Solution
In Knowledge Management, a distribution level attribute is used for solutions and 

an access level attribute for users to control the access of solutions to different users.

There are four seeded distribution levels:

� Restricted (highest security) 

� Internal

� Limited 

� External (lowest security)

When solutions are created, they are assigned a distribution level by the author. 
Users are assigned an access level. Access levels are assigned based on the user's 

assigned permissions. 

Login
Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Note: You can also remove a time period from the list.
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Responsibility
� CS_KB_KNOWLEDGE_WORKER

� CS_KB_AGENT

� CS_KB_SYS_ADMIN

Prerequisites
Internal Knowledge Management users with create permissions (CS_Solution_
Create) can create a solution.

Steps
1. Navigate to Authoring > Create Solution. Solution Detail screen opens.

2. Enter a solution title. The maximum length of a solution title can be 80 

characters.

3. Make a selection for the Distribution field. The options are Internal, Limited, 
Restricted, or External. You can view one or more of these values depending on 

your access level.

4. You can optionally select one or more categories, products, and/or platforms to 

be associated with this solution. To add a category, product, or platform, select 
Update. The Corresponding screen appears. Make the required selection.

5. Select a Solution Type from the drop-down list.

6. Select the Add button to navigate to the Statement Detail screen or select Search 

to navigate to the Advanced Search screen.

Note: You can also remove a related category, product, or 

platform from a solution.

Note: To save and submit a solution to an authoring flow, you 

have to create and save the mandatory statement types. Without 
including the mandatory statement types, you can only save a 

solution and not submit it to an authoring flow.
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a. Select a Content Type. The options are: Text, Text with Autolinks, HTML, 
and HTML with autolinks. The content type is only for statement detail 
field.

b. Select a Distribution option. The options are External, Internal, Restricted, 
and Limited. You can view one or more of these values depending on your 

access level.

c. Enter a summary for the statement. (Maximum limit is about 500 bytes).

d. Enter information about the statement in the Detail field. (Maximum limit is 

4 GB). 

e. Optionally, you can also import or export a statement from or to a local text 
file by selecting the Import or Export button. 

f. Select Save. The Solution Detail screen reappears.

7. Optionally, you can also add external links or attachments to the solution by 

choosing an option on the Add Another List and select Add. A corresponding 

screen appears. Make your selection

 

8. Either select Save Changes or Save and Submit to Authoring Flow radio button 

and click Apply. 

9. If you select Save Changes, Solution Detail screen appears with the solution 

details. The solution will have a saved status and will be listed in the Work 

Pending screen. You can update this solution. You can also view, and/or add 

comments attached to this solution by selecting Comments button. (See Adding 

Comments to a Solution). 

Note: When a solution is obsoleted, the attachment attached to it 
is not obsoleted.

Note: You can obsolete a statement from a solution, by checking 

the button corresponding to the statement that you want to 

obsolete and then select Remove. The statement that is not linked to 

any solution is obsoleted from the Knowledge Management 
database when the solution is published or obsoleted. 
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10. If you select Save& Submit to Authoring Flow radio button, and you have setup 

authoring flows, then Available Authoring Flows screen appears. Choose an 

authoring flow and select OK. 

11.  Another screen appears that prompts you to select a status. Select a status and 

select OK. Summary of the solution submitted to the authoring flow appears. 
Select OK. The Work Pending screen appears from where internal users with 

necessary permissions can search for a work- in-progress solution by selecting 

Search Work in Progress.

12. The Oracle Workflow engine determines the user group that is associated with a 

particular status of the solution. An E-mail or notification is sent to all members 

of that user group who have subscribed to a product or a category in the 

Solution Authoring Profile screen, that a solution is ready for review. The 

solution has to be related to the subscribed category/product. Any member can 

select the link in the E-mail and reply to the E-mail to accept the solution. (See 

Approving a Solution).

4.21.1 Adding Comments to a Solution
You can add comments to a solution from the Solution Detail screen. Comments are 

used to provide feedback for correcting a solution or for enhancing the solution 

value. All added comments will default to a draft status and will have an internal 
distribution option.

Login
Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Responsibility
� CS_KB_KNOWLEDGE_WORKER

� CS_KB_AGENT

� CS_KB_SYS_ADMIN

Note: To edit a solution, you must belong to the solution’s user 

group. The solution must be unlocked, and you must have 

appropriate status specific permissions. 
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Prerequisites
Internal Knowledge Management users with create permissions (CS_Solution_
Comments_Add) can add comments to a solution.

Steps
1. Navigate to Authoring >Work Pending. The Work Pending screen with all the 

solutions in progress appears.

2. Select the numbered link of the appropriate solution to navigate to the Solution 

Detail screen to view details about the selected solution in progress. 

3. Select the Comments button. The Comments on Solution screen appears.

4. Select Add Comment. The Create Comment screen appears with the Solution 

Number, Author, Distribution, and Creation Date.

5. Enter the comment summary.

6. Enter the comment detail.

7. Select Save. The Comments on Solution screen opens.

8. Select Return to navigate to the Solution Detail screen or select Add Comment 
to add another comment to this solution.

4.21.2 Approving a Solution
After creating a solution and submitting it to an authoring flow, an Knowledge 

Management internal user in the assigned user group at each step can either 

approve, or reject the solution to the next or previous step of the flow. Members of a 

user group assigned to the next step or previous step will receive an 

E-mail/notification that a solution is ready for review.

When a solution is submitted to the step that has the publish action, then the 

solution is published.

Login
Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Responsibility
� CS_KB_KNOWLEDGE_WORKER

� CS_KB_AGENT
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� CS_KB_SYS_ADMIN

Prerequisites
To publish, or obsolete a solution to the next step, you have to be a member of the 

solution’s user group to whom that step is assigned. 

You must have status specific permissions i.e, permissions to edit a solution in the 

draft status, solutions in technical review status, etc.

Steps
1. Navigate to the Oracle CRM Applications login page at: 

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

2. Enter your user name and password.

3. Navigate to Authoring >Work Pending. The Work Pending screen with all the 

solutions in progress appear. Select Search Work in Progress button. Search For 

Solutions screen appears. Search for the solution that you have to work on. 
Search Results appear.

4. Select the solution and select the numbered link to navigate to the Solution 

Detail screen for that solution.

5. Select Check Out and optionally modify the solution. The Lock Confirmation 

screen appears. Select OK.

6. The Solution Detail screen appears. Make the required edits. 

7. Select Save and Submit. A screen prompting you to select the next step appears. 
The options are: 

� Continue the current process

� Reject the solution

� Switch to another process

8. If you select Continue the current process or Reject the solution, a screen for you 

to select a status appears. If you select Switch to another process, the Available 

Work Processes screen appears. Select another work process and select OK.

Note: You can also select Comments to view any comments 

attached to the solution.
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9. Depending on your previous selection, select the solution status. Select OK. A 

message that the solution has been submitted appears. When the solution is 

submitted to a step whose action is publish, then the solution is published.

4.22 Basic Search
Perform a basic search if you want to find a solution using a simple keyword or to 

navigate through a category. Use this procedure to search for a published solution 

in Oracle Knowledge Management.

During search, solution distribution levels and a particular user's access level are 

compared to restrict the solutions that a user can see. Users having a particular 

access level can only see solutions having a distribution level with a higher numeric 

value.

Login
Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Responsibility
None

Prerequisites
None

Steps
1. Navigate to Search > Basic Search.

2. Select a search option. The available options are: All Keywords, Accumulate, 
Any Keywords, Fuzzy Match, Theme, Intermedia, and Reference Number. (For 

more information on search options, see Oracle’s Knowledge Management User 

Guide).

3. In the Search For field, enter known information to narrow down your search.

4. Optionally, you can navigate through a category tree.

5. Select Go. The results appear in the Solutions section. 

6. To focus or narrow search results, enter a search criteria in Search Within 

Results field and select Filter. To view all results, select Full List.
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4.23 Advanced Search
Advanced search allows you to search for solutions in specific categories, products, 
platforms or any combination of these. You can also select a solution type to narrow 

the search results and to choose the type of solutions that you want to find or you 

can search all solution types to get the maximum number of results. Searching by a 

statement type allows you to find an identical or similar statement to be used in 

finding all solutions that has a relationship to that statement. You can enter multiple 

queries, which can be used one at a time, or in combination to obtain the best search 

results.

The search result list displays a percent score and a color bar to indicate the 

closeness of the text match to the original query. The score is determined by 

InterMedia Text and varies based on the search option selected. Since the entire 

solution is indexed and InterMedia Text performs an analysis against all terms 

found in the solution, the title may or may not closely match the query that is 

entered. A solution ID is provided for reference with the solution or statement type. 
In addition, a description pertaining to the statement or solution and a last updated 

date is provided to indicate how current the information is.

Login
Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Responsibility
None

Prerequisites
None

Steps 

1. Navigate to Search > Basic Search. Select the Advanced Search link. Advanced 

Search screen appears.

2. In Filter Search section, you can optionally select categories, products, and/or 

platforms to narrow down the search criteria.

3. Select a search option. The available options are: All Keywords, Accumulate, 
Any Keywords, Fuzzy Match, Theme, and Intermedia. (For more information 

on search options, see Oracle’s Knowledge Management User Guide).
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4. Select a Relevancy Threshold or score to narrow the search results.

5. In Describe Your Problem section, select a solution type.

6. Select a statement type and enter any keywords to be searched in the Summary 

field.

7. Click Find Suggestions to search for statements or click Search to search for 

solutions. The results appear in the Results: Search section.

8. If you selected Find Suggestions, the statements searched appear in the Results: 
Search section. Select a statement and select one of the following options:

� Replace all statements in problem description

� Replace only selected statements in problem description

� Append to Problem description

9. Optionally, you can select one or more statements from the Search: Results 

section and navigate to the Solution Detail screen by selecting Create Solution 

button.

10. The following warning message appears: “The Statement Types identified below are 

not compatible with the Solution Type you have selected. Click on the Statement to 

modify its attributes.”

11. Select a solution title, distribution level, and solution type.

12. Select the Statement Description link to navigate to Statement Detail screen. If 
the statement has a published status, then a Copy as New button appears. 

a. Select a statement type.

b. Select Save. The Solution Detail screen appears without the warning 

message.

c. You can continue creating a solution or select Search to navigate to the 

Advanced Search screen.

4.24 Searching for a Statement
Use the Statement Search screen to search for statements in the knowledge base.You 

cannot search for statements with an obsolete status. You can only search for 

statements that have a published or a draft status.
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Login
Navigate to the Oracle CRM Applications login page at:

http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Responsibility
� CS_KB_KNOWLEDGE_WORKER

� CS_KB_SYS_ADMIN

Prerequisites
None

Steps
1. Navigate to Search > Statement Search. The Statement Search screen appears.

2. In the Search Statements screen, enter some known information to narrow your 

search:

� Statement Number: is the number assigned to a statement in Oracle 

Knowledge Management when a statement is created.

� Statement Type: is the category assigned to a statement when a statement is 

created.

� Summary: a word or sentence used in the summary of the statement.

� Sorted By: the options are, Last Updated Date, Statement Number, or Score. 

3. Select Go. Search Statements Results screen appears with the results.

4.25 Searching Solutions in Progress
Solutions appearing in the Work Pending screen are solutions that have either been 

created and saved but not submitted to an authoring flow for approval or have been 

checked out by a user but have not been submitted back to an authoring flow.

Solutions in Search For Solutions In Progress screen are solutions that have been 

submitted to an authoring flow. These solutions have not yet been published. Once 

a solution has been submitted to an authoring flow, it is no longer in the author's 

work pending queue.
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Login
http://<host>:<apache port>/OA_HTML/jtflogin.jsp

Responsibility
� CS_KB_KNOWLEDGE_WORKER

� CS_KB_AGENT

� CS_KB_SYS_ADMIN

Prerequisites
None

Steps
1. Navigate to Authoring >Work Pending. The Work Pending screen with all the 

solutions that have ben saved but not submitted to an authoring flow appear.

2. Select Search Work in Progress button. Search For Solutions In Progress screen 

appears.

3. Enter one or more search criteria to narrow down the search results.

4. Select Search. Search results appear in the Search Results sub-section.

5. Select the numbered link to view details about the selected solution. Solution 

Detail screen appears.

6. If you have CS_KB_SYS_ADMIN permissions and the solution has been locked 

by another user, then you can view the Get Lock Button. Select the Get Lock 

button to navigate to Get Lock Confirmation screen. Select OK. Solution Detail 
screen appears. As an administrator you can update a solution that had been 

locked by another user.
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5
Verifying Knowledge Management

implementation

5.1 Verification of Knowledge Management Implementation
To check that you have implemented Oracle’s Knowledge Management correctly, 
verify the following steps:

Steps
1. Verify that you have assigned CS_System_Admin role to a user and assigned 

CS_KB_SYS_Admin responsibility to a user for administrative privileges.

2. Verify that you have set up Oracle CRM Technology Foundation profile options.

3. Verify that you have set up Oracle’s Knowledge Management profile options.

4. Verify that you have created one or more resource groups for authoring flows.

5. Verify that you have set up one or more authoring flows.

6. Verify that you have permissions to run the following concurrent programs:

� Knowledge Management Solution Export Program

� Knowledge Management Solution Import Program

� Knowledge Management Index Synchronization

� Knowledge Management Update Solution Used Count

7. Verify that you have set up the solution authoring profile for one or more users 

in one or more resource groups.

8. Verify that you can perform the following steps in Knowledge Management:

1. Create, view, and update a solution type. 
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2. Create, view, and update a statement type. 

3. Associate, and disassociate a statement type to a solution type.

4. Relate statement types to external links.

5. Create and modify categories.

6. Create a new authoring flow, and edit an existing authoring flow.

7. Create a solution.

8. Create a statement.

9. Submit a solution to an authoring flow.

10. View and search work pending solutions.

11. Publish a solution.

9. Verify that you can perform the following steps:

1. Add or update frequently used definitions for solutions.

2. Set up recommended solutions.

10. Verify that you can perform the following tasks in Knowledge Management: 

1. Basic search

2. Advanced search 

3. Search for a statement
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6
Integrating Knowledge Management with

Other Oracle Products

This chapter provides an overview and a list of all products with which Oracle’s 

Knowledge Management integrates.

6.1 Overview
Oracle’s Knowledge Management is a web based information management system 

that enables a user to efficiently search, create, distribute, and manage information. 
For an end user, Knowledge Management is an easy to use self-service application 

in which they can enter natural language queries for retrieving and solving their 

own issues. A customer support agent can use Knowledge Management as a 

powerful solution management tool. Solutions created in Knowledge Management 
are immediately available to users of all applications that integrate Knowledge 

Management, based on their access level. The availability of information at all times 

in organizations means quicker response for support calls with no long phone 

queue waits for the end users. This enhances customer satisfaction while cutting the 

costs of customer support and improving the productivity of service organizations. 

The tight integration that Knowledge Management has with several Oracle 

products allows the users of these modules to easily move data between 

applications.   

Knowledge Management integrates with other Oracle modules such as Oracle 

Quality Online, Oracle Field Service, Oracle Support, and Oracle Depot Repair. This 

integration provides service agents for these modules easy access to solutions. 

Oracle Knowledge Management also integrates with Oracle iSupport. It enables 

customers of Oracle iSupport to resolve their own service issues.
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6.1.1 Oracle iSupport
Oracle iSupport is a customer service portal that allows both customer and 

employee users of a service organization to resolve their issues themselves and to 

receive assisted service over the Internet. It is designed to enhance customer 

satisfaction while cutting the costs of customer support and improving the 

productivity of service organizations.

Oracle iSupport integrates with Oracle Knowledge Management to search for 

published solutions. A service request agent using Oracle iSupport can search for 

solutions while creating a service request. Oracle iSupport customers can also 

search Knowledge Management to find solutions without waiting for a service 

agent’s assistance.

In the Create Service Request flow, an iSupport administrator can enable a 

knowledge base search by setting up Oracle iSupport: Search Knowledge Base profile 

option.

An iSupport user can view a solution by either selecting the Support tab or by 

selecting Find a solution link in How Can We Help You? bin. He can either search 

for a solution or navigate to a solution listed in the Common Problems and 

Recommended Solutions section. The Solution Details appear. A user can provide 

feedback on the solution by selecting Yes or No for “Can this solve your problem” 

question. He can also select the Add to Quick Links link or select the Create Service 

Request button to navigate to Create Service Request screen.

6.1.2 Oracle Support (Oracle Teleservice)
Oracle Support (part of the Oracle TeleService suite) is a Service Request 
Management System that integrates with Oracle Knowledge Management for 

resolving customer issues. Oracle Support uses Knowledge Management to 

leverage a knowledge base of previously reported problems and solutions. As new 

service requests are logged, agents can search the knowledge base to identify 

existing solutions that can resolve customer issues or contribute new solutions to 

the knowledge base. A user can navigate from the View Service Request Form to 

Advanced Search screen of Knowledge Management. A solution created in 

Knowledge Management can also be linked to a Service Request (based on profile 

option Knowledge: Solution Solved Action). Notes in a service request are used to 

document the description and progress made in resolving a customer issue. Notes 

are used to capture details to search the knowledge base for solutions and 

statements. Notes are also used to create new statements to contribute to the 

knowledge base. An agent has to use certain note types for searching the 
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knowledge base. Examples of note types to be used for searching are Symptom, 
Cause, Action, Problem, and Solution.

The following information from the service request is passed to the Knowledge 

Management Search screen.

� If your note was saved in the service request using a Note Type that has been 

mapped to a statement type in Knowledge Management, then the note text is 

defaulted to the search screen. 

�  Product and Platform

�  Service Request summary is defaulted into the Keywords for searching.

You can view the details of all solutions found in the search and select the solutions 

that are useful for the resolution of your service request.

You can also either link relevant solutions to your service request or make a local 
copy of a solution and make modifications to it. See the latest version of Oracle 

Support User Guide for more information.

The integration of Oracle Support’s Service Request module with Oracle 

Knowledge Management reflects the following process flow:

6.1.3 Oracle Depot Repair                                                                                                                                                                                   
Oracle Depot Repair is designed to track and manage the repair process in a service 

organization. This application reduces customer downtime and helps bridge the 

gap while the product is being repaired. 

Oracle Knowledge Management allows an agent in Oracle Depot Repair to review 

the full problem solution life span, starting from the initial diagnosis of a problem to 

problem resolution. A Depot agent can search for a solution for a repair order by 

navigating to the Advanced Search screen. Product and work summary of the repair 

order are copied to the Advanced Search screen. A solution can also be linked to a 

repair order. See the latest version of Oracle Depot Repair User Guide for more 

information.

6.1.4 Oracle eMail Center
Oracle eMail Center is the module for managing inbound email interactions with 

customers, partners, suppliers, employees, and others that interact with an 

organization. Oracle eMail Center provides an agent with tools and capabilities to 

maximize their productivity and effectiveness. See the latest version of Oracle eMail 
Center User Guide for more information. 
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Oracle Knowledge Management integrates with Oracle eMail Center during 

inbound email processing. Oracle Knowledge Management can be searched for 

appropriate solutions by Oracle eMail Center agents while responding to an email. 
The searched solutions can be sent as an e-mail message to the customer. 

6.1.5 Oracle Quality Online (OQO)
Oracle Quality Online is a web-based application that can be used by organizations 

to track and manage product defects and enhancements. The resolved defects in 

Oracle Quality Online can be submitted to Oracle Knowledge Management as 

solutions. This increases the knowledge base of solutions and allows users of both 

modules to search for existing solutions and to prevent duplicate defect entry. If an 

agent decides to submit a created defect to Knowledge Management, then an OQO 

agent can navigate to Knowledge Management. Published notes in the defect can 

also be copied to Knowledge Management, if the Defect Note Types had been 

mapped to Knowledge Management statement types.

Oracle’s Knowledge Management also uses the Token Rules or dynamic linking 

functionality developed in OQO. See the latest version of Oracle Quality Online User 

Guide for more information. 

6.1.6 Oracle Field Service
The Oracle Field Service suite supports an automated process used by service 

organizations to manage their field service operations. It assists in the entire service 

process from taking the customer call to fixing and reporting on the problem at a 

customer site.The Field Service suite offers a range of products to meet an 

organization’s business needs. 

The Field Service application assists in assigning tasks to service representatives, 
creating and dispatching daily schedules, and monitoring progress.

Service requests are analyzed by a support agent who searches Knowledge 

Management for a solution and creates a task based on the problem description and 

action needed to solve the problem.
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7
Diagnostics and Troubleshooting

7.1 Common Problems and Solutions 
This Chapter provides instructions on error corrections and workarounds for 

common problems that you may have in configuration or administration of Oracle’s 

Knowledge Management.

What factors determine the results of a solution search in Knowledge 

Management?

In Knowledge Management, a distribution level attribute is used for solutions and 

an access level attribute for users to control the access of solutions to different users.

Distribution levels are linearly arranged (low to high) and have a number 

associated with them. There are four seeded distribution levels:

� Restricted (highest security) > 900

� Internal > 1000

� Limited > 2000

� External (lowest security) > 3000

When solutions are created, they are assigned a distribution level by the author. The 

distribution levels LOV is defined in the CS_KB_ACCESS_LEVEL Lookup type.

Users are assigned a similar attribute called an access level. Access levels are 

numeric and assigned based on the user's assigned permissions. The numeric 

values associated with viewing a solution are the following:

� CS_Solution_View_Restricted > 900

� CS_Solution_View_Internal > 1000

� CS_Solution_View > 3000
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Solution distribution levels and a particular user's access level are compared, during 

searching, to filter the solutions that a user can see. Users having a particular access 

level can only see solutions having a distribution level with a higher numeric value. 
When a user searches for a solution in Knowledge Management, the search results 

are affected by the following factors: 

� user access level (internal or external) 

� solution distribution level 

� Solution versions (Published, Draft, Obsoleted, etc.) 

The following business rules apply: 

� For External Users with CS_Solution_View_Only permission (For example, 
iSupport, Customer users): Only the external solutions that are marked as 

published are shown.

� For Internal Users with CS_View_Internal and CS_View_Restrict 
permissions (For example, iSupport, Employee users): Only the internal or 

external solutions that are marked as published are shown. If no published 

version of the solution is available, then, the internal or external solutions 

that are marked as the latest draft version (saved or reviewed) are shown. 

Why can’t I find a new solution using the Advanced Search or Basic 
Search Screen?
A solution has to be indexed before it can be retrieved through a search in any of the 

search screens. To search and view new solutions, you have to first run the 

Knowledge Base Sync Index concurrent program to refresh the solutions and the 

solution count in the knowledge base.

To see the solutions, you need to make sure that you have the appropriate access 

level.

Sometimes search fails if an invalid package like CS_KNOWLEDGE_PVT is 

installed in your environment. 

When I try to do a Basic Search for a solution, I get the following error 
message: 
java.sql.SQLException: ORA-20000: interMedia Text error: DRG-10599: 
column is not indexed.
Check if InterMedia Text has been set up correctly in your environment and if the 

InterMedia listener is up.
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The other cause of the error may be that Intermedia index may not be getting built 
in your environment during the installation. You can rebuild the index by running 

the following script.

$CS_TOP/patch/115/sql/cskbctxc.sql

Read the comments on the top of the sql script for parameter information. 

I get this error:java.sql.SQLException: ORA-20000: interMedia Text error: 
DRG-10599: column is not indexed 

The intermedia index column on your environment is not indexed, or the index is 

not being rebuilt. Drop and create index and make sure it is valid. 

Index belongs to the CS schema. Log on with a CS responsibility and manually drop 

the solution index: 

CS_KB_SETS_TL_N3 force 

Run the index creation script: 

$APPL_TOP/cs/patch/115/sql/cskbctxc.sql <cs user> <cs password> apps applsys

I have javascript is enabled in my browser, yet some of the links do not 
work. 
� Bounce the apache server and clear the OA_HTML/ jsp caches

� Check NLS_LANG settings

� Remove any invalid objects

I get the following java error when I click on Find Similar Statements on 
the Solution Detail Screen: java.sql.SQLException: ORA-20000: 
interMedia Text error: DRG-10599: column is not indexed. 
The Intermedia Index is missing. You need to recreate the index. You can rebuild the 

index by running the following script.

$CS_TOP/patch/115/sql/cskbctxc.sql

On launching Oracle’s Knowledge Management HTML UI from Service 
Request, this error is encountered: 
“User does not have proper permissions” 

Please grant one or more of the following roles to your user:

� CS_Support_Agent
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� CS_Knowledge_Worker

� CS_ System_ Admin 

Why can I not see the statements attached to a solution while viewing a 
solution?
You should save a statement to your solution from the Statement Detail screen.    
When you do this, you will see a statement added under the statement section in 

your solution. The highlighted and underlined statement summary indicates that 
this has been saved to the database. 

The statement section on the Solution Detail screen is only for query and will not 
actually save a statement to your solution.

Why can’t I select a statement from search results section after doing a 
Statements Search?
The statement may be in the draft status. You can only select a statement that is in 

the published status. Only existing published statements can be linked to solutions. 

How do I publish a statement?
A newly created statement is in a draft status by default. It is published when the 

solution for which it is initially created is published. 

From the Oracle Support module, when I navigate to Knowledge 
Management and try doing a Basic or an Advanced search for a 
solution, no results are returned. If I do a search on entering a query 
from the Quick Find menu, results are returned. 
Run the Knowledge Base Sync Index concurrent program to reindex the Knowledge 

Management solutions. 

Make sure that the solutions that you have created and submitted are not in the 

draft status. The solutions have to be in the published status to be reindexed. 

Why can I not edit a statement in a published solution that I can check 
out?
Only a Knowledge Management administrator has the permissions to edit a 

statement in a solution that has been published. An administrator can search a 

statement from the Search Statement screen. 
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The CS_Statement_Global_Update permission is only given to Knowledge 

Management administrators to prevent knowledge workers from changing the 

statements that are shared between other solutions. 

Why do I as a member of a user group that was assigned all steps in an 
authoring flow, not get an E-mail for a solution that I created and 
submitted to that authoring flow? 

To get an E-mail notification for a solution, you need to make sure that: 

� In the workflow user preference setup, HTML mail has been selected 

� You have subscribed to the products/categories related to the solutions that you 

are interested in from the Solution Authoring Profile screen

� E-mail id should be attached to an employee

� System admin workflow notification is setup 

� Ensure that the mail notifier in your environment is working

When are E-mail notifications sent to users belonging to a step in an 
authoring flow?
E-mail notification is sent in the following cases:

1. When a solution is submitted to the step that you are assigned to and you have 

subscribed to the product /category to which the solution is related.

2. After completing a step in an authoring flow.

3. When the solution is published or obsoleted and you have subscribed to the 

product and/or category in the Solution Authoring Profile screen.

4. If you checkout a solution that has been locked by another user.

5. If a solution is rejected to you as an author of a solution.

Service Request (SR) is not linking to Knowledge Management, i.e, the 
problem described in a SR is not appearing in the Knowledge 
Management screen and the solution found in Knowledge Management 
is not being referenced in SR. 
Clear the IBU and CS caches and bounce the apache server.
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In the Customer Support module, after I click the Yes button for “Does 
the solution solve your problem” and after clicking Exit from Knowledge 
Management button and the Refresh button on the Workbench tab, the 
solution does not appear in the Notes and Knowledge section and the 
row is not being added to the CS_KB_SET_LINKS table. 
For the solution to appear in the Notes and Knowledge section and for a row to be 

added linking the service request and the solution in the CS_KB_SET_LINKS table, 
make sure that other_id is the same as the service request id and object_code is the 

same as the SR string.

Make sure that the profile option Knowledge: Action for Positive Solution Feedback 

is set up to link solution as solved.

Also, clear the IBU and CS caches and bounce the server. 

Why do I get no results when I use Knowledge Management from 
Service Request to search for a solution?
Check if the package cs_kb_ctx_pkg is installed in your environment’s ctxsys 

schema. If this package is not installed or is improperly installed, then the 

intermedia text indexes will not be properly populated and you will not be able to 

find anything in the knowledge base. Install the package by running the $CS_
TOP/patch/115/sql/cskbctxs.pls and cskbctxb.pls scripts. Use the parameters as 

documented in the scripts and then rebuilt the index. 

I cannot navigate to the Solution Detail screen from the Service Request 
application? 

To navigate to the Solution Detail screen, you need to be assigned either of the 

following roles:

� CS_Support_Agent

� CS_Knowledge_Worker

�  CS_ System_ Admin 

Also, you need CS_Solution_Create permission. 

How are attachments to solutions in Knowledge Management stored?
Attachments to solutions in Knowledge Management are stored in the database 

through JTF attachments. For more information on JTF Attachments, see the latest 
version of Oracle CRM Application Foundation User Guide.
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When are solutions marked for re-indexing?
When ever a solution is updated, it is marked for reindexing.

Why is the text that I enter in the Statement Summary field saved as a 
JSP file on the hard disk when I click the Export button on the Statement 
Detail screen?
It is an Internet Explorer bug. You have to download and install a patch containing 

this fix from the Microsoft website.

When are statements considered duplicate?
Statements are considered duplicate if they have the same summary, same type, 
same distribution, and same details.

Which Solutions Are Found In Work Pending status and which are found 
in Search Work In Progress status?
Authoring flows are used with resource groups to move solutions from a created 

status to a published status.

Solutions appearing in the Work Pending screen are solutions that have either been 

created and saved but not submitted to an authoring flow for approval or have been 

checked out but have not been submitted back to an authoring flow.

Solutions in Search For Solutions In Progress screen are solutions that have been 

submitted to an authoring flow. These solutions have not yet been published. Once 

a solution has been submitted to an authoring flow, it is no longer in the author's 

work pending queue. Solutions that have been submitted to an authoring flow 

move between the Work Pending screen and the Search For Solutions in Progress 

screen until they are published.

For example, an authoring flow has the following three steps:

�  Review Ready

�  Publish Ready

�  Publish

The action for step1 and step 2 is notify. The action for step 3 is publish. There are 

two resource groups: Reviewers and Publishers.

The resource group that is associated with step 1 is the Reviewers group. The 

resource group associated with step 2 and step 3 is the Publishers group.
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In step 1, an author has submitted a solution to an authoring flow and set the status 

to Review Ready. After the solution is submitted, the solution is no longer in work 

pending queue of the author. It can now be searched from the Search For Solutions 

In Progress screen.

Members of the Reviewers group can navigate to the Search For Solutions in 

Progress screen and query the solutions that are in a Review Ready status. Once a 

solution is checked out by a reviewer, the solution enters the work pending queue 

of that reviewer.

After reviewing the solution, the reviewer can save and submit the solution to the 

next step in an authoring flow, which is Publish Ready. As soon as the solution is 

sent to the next step, it is back in the Search For Solutions in Progress status. 
Members of the Publishers group can go to Search For Solutions in Progress and 

query the solutions that have been set up to Publish Ready. When a publisher 

checks out the solution, the solution enters the work pending queue of that 
publisher. The publisher can save and submit the solution to the next step in the 

authoring flow, which is Publish.

Since step 3 is the last step in the authoring flow, the solution is neither in the work 

pending queue of any reviewer/publisher nor in Search Solutions in Progress 

screen but becomes a published solution that can be searched by all users through 

Basic Search or Advanced Search screens.

Why can I not delete a solution?
Deleting solutions is not allowed in this release of Oracle’s Knowledge 

Management. You can create an authoring flow to obsolete a solution. Obsoleting is 

known as soft deleting. 

I get the following error while submitting a solution to the next step in a 
workflow: 
ORA-20160: Encountered an error while getting the ORACLE user 
account for your concurrent request to run from. Review your error 
messages (Help Error) to see the cause of the error. Contact your 
system administrator.
Navigate to Oracle Applications Forms and log in as a system administrator. 
navigate to the Alert Manager. 

Alert -> Define 

View -> Query by example -> Enter 

Table ->%WF_ITEMS% 
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View -> Query by example -> Run 

ADS Workflow Owner Assignment 

ADS Workflow User Key Assignment are displayed

Uncheck the Enable checkbox and save because these two alerts are not part of the 

business flow of Knowledge Management and should not be enabled. 

How is Multi Lingual Support (MLS) used in Knowledge Management? 

When you create a solution in one language, a copy of the solution is created in 

other languages that you have installed. If you assign the publish status to any copy 

of the solution, then, the copy of the solution for other languages also gets 

published. 

Hence, you need to make sure that the solution is ready for all the installed 

languages before you put it in the publish state.

Can the search methods in Basic and Advanced Search be configured? 

Yes. The search methods in Basic Search and Advanced Search can be configured. 
CS_KB_SEARCH_TYPE_OPTIONS Lookup Type contains a list of lookup values 

that represent the different search methods. 

Why do I See the following Warning even if I do not select any statement type or 

solution type while creating a solution: 

The statement types identified below are not compatible with the solution type you have 

selected. Click on the statement to modify its attributes.

All solutions and statements in Knowledge Management have to have a type. 
Solutions/statements without a solution type and statement type are considered as 

“not compatible”. 

You have to select a solution type and then click on the statement link to select a 

statement type and the warning will go away. 

Can we reference Image Files in the Statement? 

It is not recommended to reference image file in the body of the statement.From this 

release, for security, any hard coded file ID access is not going to work. 

The regular attachment of a solution works. If you click the link in the attachment 
section, you can see the JPG. 

JMES patch requires all file IDs be encrypted before allowing the download. 
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A
Oracle’s Knowledge Management Seed

Data

A.1 User Role to Permission Mapping
Each type of a user in Oracle’s Knowledge Management System has a set of 
permissions. The following table summarizes Oracle’s Knowledge Management 
Roles to Permissions mapping.
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A.1.1  Knowledge Management Roles 

An Oracle’s Knowledge Management Administrator has all Knowledge 

Management specific permissions including all setup and other process oriented 

permissions. 

A knowledge worker is a user who creates/edits/technically reviews information 

in Knowledge Management. 

A Knowledge Management Agent is a user who interfaces with the customers 

directly (on the phone) or indirectly (online) to record their problems and provides 

them existing solutions or creates new solutions.

The following table lists role and permissions associated with a Knowledge 

Management Administrator, Knowledge Worker and a Knowledge Management 
Agent.

Table A–1 Knowledge Management Roles and Permissions

Permissions Description

CS_
SYSTEM
_ADMIN

CS_
KNOWLEDGE
_WORKER

CS_
SUPPORT
_AGENT

CS_Advanced_
Search

Knowledge: Search: 
Permission to view the 
Knowledge Management 
Advanced Search Screen 

YES YES YES

CS_Solution_View Knowledge: Search: 
Permission to view solution

YES YES YES

CS_Solution_View_
All

Viewing all solutions YES

CS_Solution_View_
Internal

Knowledge: search: 
Permission to View Public 
and Internal Solutions

YES YES YES

CS_Solution_View_
Public

Permission to view Public 
Solutions

YES

CS_Solution_View_
Restricted

Knowledge: Search: 
Permission to view 
Restricted Solutions

YES

CS_Solution_Create Knowledge: Authoring: 
Permission to create a 
solution

YES YES YES
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CS_Assoc_Ext_
Obj_To_Sol 

Knowledge: Authoring: 
Permission to attach external 
objects to a solution

YES YES YES

CS_Solution_
Update 

Knowledge: Authoring: 
Permission to Update a 
solution

YES YES YES

CS_Solution_Delete Knowledge: Authoring: 
Permission to delete a 
solution

YES YES YES

CS_Solution_View_
Internal 

Knowledge: search: 
Permission to view public 
and internal solutions

YES YES YES

CS_Solution_
Status_Update

Update Solution Status YES

CS_Solutions_
Comments_Add

Knowledge: Authoring: 
Permission to add solution 
comments

YES YES YES

CS_Solution_Get_
Lock

Knowledge: Authoring: 
Permission to get solution 
lock from user

YES

CS_Freq_Used_
Def_View 

Knowledge: Setup: 
Permission to view 
frequently used solution 
definitions

YES

CS_Freq_Used_
Sol_View

Knowledge: Search: 
Permission to view 
frequently used solutions

YES YES YES

CS_Freq_Used_
Def_Update 

Knowledge: setup: 
Permission to update 
frequently used solution 
definitions

YES

CS_Rec_Sol_View Knowledge: Setup: 
Permission to view 
Recommended Solutions

YES YES YES

Table A–1 Knowledge Management Roles and Permissions

Permissions Description

CS_
SYSTEM
_ADMIN

CS_
KNOWLEDGE
_WORKER

CS_
SUPPORT
_AGENT
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CS_Rec_Sol_
Update

Knowledge: Setup: 
Permission to update 
Recommended Solutions

YES YES

CS_Statement_
View 

Knowledge: Search: 
Permission to view 
statement

YES YES YES

CS_Statement_
Create 

Knowledge: Authoring: 
Permission to create a 
statement

YES YES YES

CS_Statement_
Delete 

Knowledge: Authoring: 
Permission to delete a 
statement

YES YES YES

CS_Statement_
Update 

Knowledge: Authoring: 
Permission to update a 
statement

YES YES YES

CS_Statement_
Global_Update

Knowledge: Authoring: 
Permission to update 
statements globally

YES

CS_Types_View Knowledge: Setup: 
Permission to view solution 
and statement types setup 
screens

YES

CS_Types_Edit Knowledge: Setup: 
Permission to edit solution 
and statement types

YES

CS_USED_
COUNT_UPDATE 

Knowledge: search: 
Permission to update 
solution used count

YES YES YES

CS_Personal_
Profile_Update

Knowledge: Other: 
Permission to Update 
Knowledge Management 
Personal Profile

YES YES YES

CS_Sol_Auth_
Profile_Update

Knowledge: Authoring: 
Permission to Update 
solution Authoring Profile

YES YES YES

Table A–1 Knowledge Management Roles and Permissions

Permissions Description

CS_
SYSTEM
_ADMIN

CS_
KNOWLEDGE
_WORKER

CS_
SUPPORT
_AGENT
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CS_Workflow_
Setup_Update

Knowledge: Setup: 
Permission to update 
solution authoring workflow 
setup

YES

CS_Worflow_
Setup_View

Knowledge: Setup: 
permission to view solution 
authoring workflow setup 
screens

YES

CS_Categories_
Update

Knowledge: Setup: 
Permission to update 
categories

YES

CS_Categories_
View

Knowledge: Setup: 
Permission to view 
categories

YES

Table A–1 Knowledge Management Roles and Permissions

Permissions Description

CS_
SYSTEM
_ADMIN

CS_
KNOWLEDGE
_WORKER

CS_
SUPPORT
_AGENT
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B
Profile Options

This appendix describes the profile options that are required for the successful 
implementation of Oracle’s Knowledge Management. Topics Include:

Before You Begin

Overview of Setting Profile Options

Setting Profile Options

Oracle’s Knowledge Management Profile Options
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B.1 Before You Begin
Before doing Oracle Applications Forms settings, ensure that all Oracle 

Applications server processes are up and running. In particular, if you stopped 

concurrent managers before applying Oracle Applications patchsets, restart them 

by changing to $COMMON_TOP/admin/scripts, and executing adcmctl.sh <APPS 

username/APPS password> start.

B.2 Overview of Setting Profile Options
As a System Administrator, you can use the System Profile Values window in 

Oracle Applications Forms to set up profile options for your user community. If you 

change a user profile option value, your change takes effect as soon as your users 

log on again or change responsibilities, and bounce the apache server. When you set 
up a user profile, you provide Oracle Applications with standard information (such 

as printer) that describes a user, responsibility, application, or site. You can set up 

values for user profile options at each of the following profile levels.

� Site: Option settings pertain to all users at an installation site.

� Application: Option settings pertain to all users of any responsibility associated 

with the application.

� Responsibility: Option settings pertain to all users currently signed on under 

the responsibility.

� User: Option settings pertain to an individual user, identified by their 

application username.

The values you set up at each level provide run–time values for each user’s profile 

options. An option’s run–time value becomes the highest level setting for that 
option.

When a profile option may be set at more than one level, site has the lowest priority, 
superseded by application, then responsibility, with user having the highest 
priority. For example, a value entered at the site level may be overridden by values 

entered at any other level. A value entered at the user level has the highest priority, 
and overrides values entered at any other level.

For example, for a given user, assume the printer option is set only at the site and 

responsibility levels. When the user logs on, the printer option assumes the value 

set at the responsibility level, since it is the highest–level setting for that option.
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The options specified at the site–level work as defaults until the same options are 

specified at other levels. Application users may use the Personal Profile Values 

window to set their own personal profile options at the user level. Not all profile 

options are visible to users, and some profile options, while visible, may not be 

updated by end users. For more information about profile options, See Oracle 

Applications System Administrator’s Guide Release 11i.

B.3 Setting Profile Options
Use the following procedure to set up any profile option.

Steps
1. Log on to Oracle Applications Forms with the System Administrator 

responsibility. 

2. Go to Profile > System. The Find System Profile Values window opens. 

3. Check the level(s) at which you want to set the profile option. The available 

levels are listed below: 

�  Site

� Application— If you select this level, choose the application from the 

Application LOV for which you want to set the profile option.

� Responsibility— If you select this level, choose the responsibility from the 

Responsibility LOV for which you want to set the profile option.

� User— If you select this level, choose the user from the User LOV for whom 

you want to set the profile option.

4. In the Profile field, enter the profile name, such as Knowledge: Active 

Knowledge Base System, or a wildcard search criterion such as Knowledge%.

5. Click Find. The System Profile Values form opens with the results of your search.

6. Verify or set the profile option(s) at the levels that you selected.

Note:  As a System Administrator, you should set site level option 

values before specifying profile options at the other three levels 

after the installation of Oracle Applications.
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B.4 Oracle’s Knowledge Management Profile Options
The following table lists the profile options required for Oracle’s Knowledge 

Management.

Table B–1 Profile Options for Oracle’s Knowledge Management

PROFILE_OPTION Description Active/Obsoleted

Knowledge: Active 
Knowledge Base System

Selection for which 
integrated HTML based 
Knowledge Base System is 
being used.

Obsoleted

Knowledge: Allow 
Knowledge Note Update

Allow the user to update 
knowledge management 
notes saved for a service 
request.

Obsoleted

Knowledge: Default 
Knowledge Base Solution 
Type

Controls which default 
solution type should be 
when a user enters the 
agent knowledge base 
contribution screen.

Active

Knowledge: Knowledge 
Base Default Contribution 
Status

Determines the default 
status of any knowledge 
objects contributed through 
the agent knowledge base 
search module.

Obsoleted

Knowledge: Knowledge 
Base Search: Maximum 
Number of Search Results

Maximum number of 
search results.

Active

Knowledge: Event 
handler class name for 
Knowledge Management 
solved/unsolved actions 
predefined by other 
applications

Profile to determine the 
event handler class to be 
used for a specific 
integrating application.It 
can be predefined by the 
integrating application or 
can be setup as a default in 
Knowledge Management.

Active

Knowledge: Action for 
Negative Solution 
Feedback

Profile to determine which 
action to perform when Not 
Solved button in View 
Solution screen is clicked.

Active
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Knowledge: Default 
Knowledge Base Product 
Category or Service Set

Determines the product 
category set from which the 
product list of values is 
derived.

Active

Knowledge: Knowledge 
Base Responsibility when 
Called from Another 
Application

This Profile is to map 
Forms Applications 
responsibility to 
Knowledge Management 
Responsibility for the 
purpose of calling 
Knowledge Management 
UIs from Forms 
Applications. This is 
required if you need to 
make sure KM menu is 
rendered properly when 
you come to KM from a 
Forms application.

Active

Knowledge: Default 
Distribution Level

Default Distribution Level 
for both Solution and 
Statement.

Active

Knowledge: Default 
Statement Content Type

Default Content Type for a 
statement.

Active

Knowledge: Default 
Authoring Flow Name

Default Authoring Flow 
Name for Solution 
Authoring.

Active

Knowledge: Default 
Solution Priority

Default Priority Code for a 
Solution.

For Future Use 

Knowledge: Default 
Solution Type

Default Solution Type (For 
Simple Create Solution, this 
type must have at least one 
linked mandatory 
statement type).

For Future Use

Knowledge: Note Type for 
Copied Solution

This profile determines 
which note type will be 
used when a solution 
content is copied back to 
the calling application's 
source document as a JTF 
NOTE.

Obsoleted

Table B–1 Profile Options for Oracle’s Knowledge Management

PROFILE_OPTION Description Active/Obsoleted
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B.5 Oracle’s Knowledge Management System Profile Option Values
The following table lists the values for Oracle’s Knowledge Management profile 

options and the levels on which each has to be set.

Knowledge: Action for 
Positive Solution 
Feedback

Determines the action to be 
taken for positive solution 
feedback.

Active

Knowledge: Statement 
Display Order on 
Solutions Details Page

Determines if statements 
are displayed by type or 
position on the Solution 
Details screen.

Active

Table B–2 Profile Option Names, Levels and Values

Profile_Option_Name Level Level_Value Profile_Option_Value

Knowledge: Allow 
Knowledge Note Update

Site N

Knowledge: Default 
Knowledge Base Solution 
Type

Site Symptom, Cause, Action

Knowledge: Knowledge 
Base Default 
Contribution Status

Site Draft

Knowledge: Knowledge 
Base Search: Maximum 
number of search results

Site 500

Knowledge: Knowledge 
Base Search: Maximum 
number of search results

Application Oracle Service 500

Knowledge: Action for 
Negative Solution 
Feedback

Site Link Solution as Not 
Solved

Knowledge: Knowledge 
Base Responsibility when 
called from another 
application

Site Knowledge 
Agent-Oracle Service

Table B–1 Profile Options for Oracle’s Knowledge Management

PROFILE_OPTION Description Active/Obsoleted
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Knowledge: Default 
Distribution level

Site Internal

Knowledge: Default 
Statement Content Type

Site HTML

Event Handler Site Oracle.Apps.CS.Knowle
dge.Bean.DefaultKMEve
ntHandler

Knowledge: Action for 
Positive Solution 
Feedback

Site Link Solution As Solved

Knowledge: Display 
Order on Solution Details 
Page

Site Position Order

Table B–2 Profile Option Names, Levels and Values

Profile_Option_Name Level Level_Value Profile_Option_Value



Oracle’s Knowledge Management System Profile Option Values

B-8 Oracle Knowledge Management Implementation Guide                              



                                                            Knowledge Management Lookup Types and Lookup Codes C-1

C
Knowledge Management Lookup Types and

Lookup Codes

This appendix describes how to add Lookup Codes to Lookup Types in Oracle 

Applications Forms.

C.1 Viewing Lookup Types for Knowledge Management

Responsibility
Customer Support responsibility

Login
Log in to Oracle Applications Forms.

Steps
1. Log in to Oracle Applications Forms as a system administrator. Responsibilities 

form appears.

2. Switch responsibility to the Customer Support responsibility.

3. Select Others > Service: Lookup. Oracle Service Lookups Form appears.

4. From the View menu, select Find. Lookup Types pop-up window appears. 

5. Enter CS_KB in the Find field. Select OK.

C.2 Configuring the Solution Authoring Flow Status
CS_KB_STATUS lookup type is a fully customizable lookup type for Knowledge 

Management. Use the following procedure to add lookup codes to this lookup type.
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Responsibility
Customer Support responsibility

Login
Log in to Oracle Applications Forms.

Steps
1. Log in to Oracle Applications Forms as a system administrator. Responsibilities 

form appears.

2. Switch responsibility to the Customer Support responsibility.

3. Select Others > Service: Lookup. Oracle Service Lookups Form appears.

4. From the View menu, select Find. Lookup Types pop-up window appears. 
Enter CS_KB_STATUS.

5. Search results showing a list of steps for solution authoring flows appear. You 

can select the steps that you want to enable by checking the check boxes in the 

Enabled column.

6. Select Save from the File menu.

C.3 Configuring the Search Method
The search methods in Basic and Advanced Search screens can be configured. CS_
KB_SEARCH_TYPE_OPTIONS is the lookup that contains a list of lookup values 

that represent the different search options. Administrators can enable/disable the 

search values in this lookup and also rename the search options to be available in 

the Basic and Advanced Search screens. Atleast one search method has to be 

enabled.

Responsibility
Customer Support responsibility

Login
Log in to Oracle Applications Forms.

Steps
1. Log in to Oracle Applications Forms as a system administrator. Responsibilities 

form appears.
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2. Switch responsibility to the Customer Support responsibility.

3. Select Others >Service >Lookup. Oracle Service Lookups Form appears.

4. From the View menu, select Find. Lookup Types pop-up window appears. 
Enter CS_KB_SEARCH_TYPE_OPTIONS. 

5. Search results showing a list of search options appear. Check the check boxes in 

the Enabled column to enable the selected options.

6. Select Save from the File menu.
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D
Sample File For Knowledge Management

Solution Import Program

D.1 Example of a Solution File for the Solution Import Program 
Knowledge Management Solution Import Program uses the input xml file name 

(absolute path) and commit interval (time intervals for commiting the import) 
parameters for running. The File has to contain the solutions in a XML format and 

have to be compliant with the Document Type Definition (DTD) for Knowledge 

Management, cskb_solution.dtd. This program checks the validity of the input xml 
document. If it is valid, the solutions are created, one after the other. If any data is 

invalid, the solutions are not created. If processing for a solution fails, its changes 

are rolled back, and a log error message is written and the next solution in the file is 

imported. Each new solution to be uploaded can either have a Saved status, or it 
can be directly published, if the flow information is provided. Only published 

solutions can be updated, and have a published status after update. Attachments 

and external links are not supported but Statement Global Update is supported. 
Any statement with a statement number is globally updated according to the new 

data specified in the XML document.

<?xml version="1.0"?>
<!DOCTYPE solution_list SYSTEM "cskb_solution.dtd">
<solution_list>

<solution>
<solution_type> Symptom Cause Action</solution_type>
<solution_distribution>External </solution_distribution>
<title>Maria's Test Solution 1 (mchui061902b)</title>
<category>Home&gt;12 World Cup&gt;United States</category>
<product>Passport Backup Drive</product>
<product>Windows NT (wrong)</product>
<platform>Sentinel Standard Desktop</platform>
<statement>
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<statement_type>Symptom</statement_type>
<statement_distribution>External</statement_distribution>
<content_type>HTML with AutoLink</content_type>
<summary>mchui061902b - symptom 1</summary>
<detail></detail>

</statement>
<statement_links>

<statement_no>10386</statement_no>
<statement_no>34</statement_no>
<statement_no>10650</statement_no>

</statement_links>
</solution>
<solution>

<flow>
<flow_name>Bayu Flow</flow_name>
<step>Public</step>

</flow>
<solution_type> Symptom Cause Action</solution_type>
<solution_distribution>External </solution_distribution>
<title>Maria's Test Solution 2 (mchui061902c)</title>
<category>Home&gt;New Category&gt;New Category 2</category>
<product>Windows NT</product>
<product>Windows NT</product>
<platform>windOWS 95</platform>
<statement>

<statement_type>Symptom</statement_type>
<statement_distribution>External</statement_distribution>
<content_type>Text with AutoLinks</content_type>
<summary>mchui061902c - symptom 1</summary>
<detail>another imported statement - published</detail>

</statement>
<statement_links>

<statement_no>10387</statement_no>
</statement_links>
<statement_link_update>

<statement_no_upd>10386</statement_no_upd>
<statement_type_upd>Symptom</statement_type_upd>
<statement_distribution_upd>Internal</statement_distribution_upd>
<content_type_upd>HTML</content_type_upd>
<summary_upd>update existing statement summary</summary_upd>
<detail_upd>global update of statement CLOB</detail_upd>

</statement_link_update>
</solution>
<solution>

<solution_number>10419</solution_number>
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<solution_type> Symptom Cause Action</solution_type>
<solution_distribution>Limited</solution_distribution>
<title>UPDATED Solution 1000003 yes (updated on 062102)</title>
<category>Home&gt;New Category&gt;New Category 2</category>
<product>Windows NT</product>
<platform>windOWS 95</platform>
<statement>

<statement_type>Symptom</statement_type>
<statement_distribution>External</statement_distribution>
<content_type>Text</content_type>
<summary>create new statement </summary>
<detail>new statement details</detail>

</statement>
<statement_link_update>

<statement_no_upd>10386</statement_no_upd>
<statement_type_upd>Symptom</statement_type_upd>
<statement_distribution_upd>External</statement_distribution_upd>
<content_type_upd>Text with AutoLinks</content_type_upd>
<summary_upd>global update of statement</summary_upd>
<detail_upd>statement detail should be globally

updated</detail_upd>
</statement_link_update>

</solution>
</solution_list>
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Glossary

Action

An Oracle’s Knowledge Management statement type that contains the solution to 

an issue. It is a part of the Symptom/Cause/Action solution type.

Accumulate

This search finds documents that contain at least one of the query terms.

All Keywords

This search uses the AND operator. The search results must match all terms in the 

query.

Answer

A Knowledge Management statement type that contains the solution to an issue. It 
is a part of the Question/Answer solution type.

Any Keywords

This search uses the OR operator. This search can match one or more query terms. 

Attachment

A link from a solution to a supporting item of information that enhances the value 

of the solution for its users. Attachments can include graphics, scripts, or 

documents in different file formats.

Authoring Flow

An Authoring Flow in Knowledge Management defines the steps that a solution 

has to follow in the solution approval or rejection process.
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Boolean

In this search you can enter your own Intermedia operators. If you do not enter an 

operator, this search performs a phrase search.

Category

A knowledge base collection based on an information attribute such as product or 

version number.

Cause

A Knowledge Management statement type that contains the reason for the solution 

issue. It is a part of the Symptom/Cause/Action solution type.

Concurrent Manager 
A unique facility that manages many time consuming, non interactive tasks within 

Oracle Applications, so that you do not have to wait for their completion. When 

you submit a request in Oracle Applications that does not require your interaction, 
such as releasing shipments or running a report, the Concurrent Manager does the 

work for you, enabling you to complete multiple tasks simultaneously.

Concurrent Program

A program that runs concurrently (at the same time) as other programs. Concurrent 
programs run as background processes, while you continue to work at your 

terminal.

Dynamic Linking

Is the process of linking an object type or a unique identifier within a statement as a 

link to additional information related to that object type or to that unique identifier.

Fact

A Knowledge Management statement type that contains factual information. 
Examples are product, version number, operating system, etc.

Find Related Statements

The search method that finds all other statements of the same type that have been 

previously linked. The results are displayed based on the strength/weight of the 

link. 
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Find Similar Statements

A text search that finds matches that are determined by comparing keywords to the 

summary of the statements in the repository.

Fuzzy

In this search, the query keywords are expanded into a set of similarly spelled 

keywords, before a search is performed. This search is helpful if there are frequent 
misspellings of the query keyword in the repository. This search will find incorrect 
spellings and synonym matches to the query terms.

Intermedia

Oracle InterMedia is a feature that enables Oracle8i to store, manage, and retrieve 

text, documents, geographic location information, images, audio, and video in an 

integrated fashion with other enterprise information. 

It is an Oracle server option that enables text queries to be performed through SQL 

and PL/SQL.

Knowledge Base

The Knowledge Management database that contains information that can be used 

to solve issues.

Knowledge Worker

An individual that creates, edits, and technically reviews information within 

Knowledge Management.

Merchant

A company that has purchased or is using an Oracle application.

Problem

A Knowledge Management statement type that contains the issue of a solution 

type, typically part of a Problem/Resolution solution type.

Question

A Knowledge Management statement type that contains the issue. It is a part of a 

Question/Answer solution type.
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Relationship

A link between statement types indicating that they have been used together at 
some time as part of a solution. A statement can have many relationships based on 

the number of solutions that it is part of.

Resolution

A Knowledge Management statement type that contains the solution. It is a part of 
a Problem/Resolution solution type.

Responsibility

A level of authority in an application. Each responsibility allows you to access a 

specific set of Oracle Applications windows, menus, reports, and data to do your 

role in an organization. Several users can share the same responsibility, and a single 

user can have multiple responsibilities.

Role

One or more users grouped by a common responsibility or position.

Score

Is also known as relevancy threshold. The text search results match (in percentage) 
to the original text query.

Solution

Collection of information or statements to solve an issue or answer a question. 

Solution Number

Every solution in Knowledge Management is associated with a unique number. 
This search will find the solution that is associated with the number entered in the 

search query field. 

Solution Score

Each solution is scored based on the text match performed by InterMedia Text and 

the number of times it has been successfully used to solve issues. These scores are 

shown as a combined score to indicate the strength of the match to the query 

entered. The maximum score is 100. 

Solution Type

Solutions are organized in solution types to make searches more precise and the 

results more effective. 
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Statement

A statement is a description of any aspect of a problem, its cause, or its resolution. A 

statement has a summary field and a detail field. Statements can be organized into 

statement types.

Statement Type

Statements can be organized into statement types. It is an identifying name 

associated with a particular part of a solution type. For example, question is a 

statement type in a question/answer solution type.

Status

Solutions and statements have a status attribute. This attribute describes the phase 

of review that the solution or statement has gone through. Common solution 

statuses are: Draft, Under Edit, Technical Review, Editorial Review, Obsolete, and 

Published.

Symptom

An Knowledge Management statement type that contains the issue the user is 

trying to solve. It is a part of the Symptom/Cause/Action solution type.

Theme

This search is also called an about search in Intermedia. Intermedia categorizes the 

documents in its repository into themes, based on their textual content. When this 

search is performed, the query keywords are compared with the theme index. 
Documents having the same themes as the keywords appear in the result list.

User

A Knowledge Management user can be an internal or an external user. External 
users are users that can see published solutions. Internal users include Knowledge 

Management administrators, knowledge workers and knowledge agents. 

Weight

A number that indicates the number of times a statement has been used with other 

statements to solve an issue

Workflow

Oracle Workflow provides a workflow process to Knowledge Management for 

solution approval and rejection processes. It is a flexible method for Knowledge 

Management users to define an authoring flow process steps that are specific to 

their needs.
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Index
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