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Preface

Welcome to the Oracle Customer Relationship Management, Release 11i, suite of 
applications.

This Concepts and Procedures provides information and instructions to help you 
work effectively with Oracle Service for Communications.

This preface explains how Concepts and Procedures is organized and introduces 
other sources of information that can help you.

Intended Audience
This guide is aimed at the following users:

■ Technical Service Representatives (TSR)

■ Customer Service Representatives (CSR)

■ System Administrators (SA), Database Administrators (DBA), and others with 
similar responsibility.

This guide assumes you have the following pre-requisites:

■ Understanding of the company business processes.

■ Knowledge of products and Service as defined by your marketing policies.

■ Basic understanding of Oracle and Developer/2000.

■ Background in SQL, PL/SQL, SQL* Plus programming.
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Structure
This manual is a compilation of the topics in the online help for Oracle Service for 
Communications. It contains the following sections: 

“Understanding Oracle Service for Communications” provides overviews of the 
application and its components, explanations of key concepts, features, and 
functions, as well as the application’s relationships to other Oracle or third-party 
applications. 

“Using Oracle Service for Communications” provides process-oriented, task-based 
procedures for using the application to perform essential business tasks. 

Related Documents
For more information, see the following manuals:

■ Oracle Inventory User’s Guide

■ Oracle Purchasing User’s Guide

■ Oracle Assets User’s Guide

■ Oracle Projects User’s Guide

■ Oracle Payables User’s Guide
viii



 Understanding Oracle
Service for Communications

This topic group provides overviews of Oracle Service for Communications and its 
components, explanations of key concepts, features, and functions, as well as the 
application’s relationships to other Oracle or third-party applications. 

Overview of Oracle Service for Communications
Oracle Service for Communications extends the features of Oracle Support and Oracle 
Service to include the customer care processes in the communications industry. Specifically, 
it offers features that:

n Maintain a directory of products and services customers have purchased in the Installed 
Base

n Log, track, and resolve trouble reports made against installed products and services
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Integration with Other Oracle Modules
The primary area of customer care that this application supports is service request 
management. In addition, this application integrates with the customer service management 
tools found in the Oracle modules shown in the following table.

Understanding Service Request Management
Service request management begins when customers call to report trouble with installed 
products and services. Support agents receive customer trouble reports and enter the 
information into a service request window. 

After a service request is entered, agents and technicians can view the request and track its 
status. If several service requests are related to one network problem, those related requests 
can be linked and tracked together. 

Service request management includes these tasks:

n Receiving trouble reports from customers or service personnel

n Service testing through Test Centers

n Determining the cause of trouble reports

n Creating service requests

n Viewing and tracking the progress of service requests

n Entering service requests to third-party service providers

Oracle Application Functionality

Oracle Service Contracts Creates, updates, and displays service agreements for service 
contract management.

Oracle Customer Care Manages customer interaction through the Customer Care 
Contact Center.

Provides computer-telephony integration necessary for 
call-centers.

Oracle Field Service Dispatches field service personnel. 

Oracle SDP Provisioning Provides an environment for diagnostic testing of network 
elements in the Test Center.

Oracle Sales for 
Communications

Includes product catalog, order management, and diagnostic 
test definitions.
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n Confirming that a problem has been resolved and notifying the customer

n Closing service requests

For a detailed description of service requests, see Overview of Service Requests.

Service Requests are Received
Agents access Oracle Service for Communications as a stand-alone application. When 
customers call to report a problem with a product or service, the Customer Care Contact 
Center immediately displays the caller’s account information to the agent via 
computer-telephony integration. 

Agents Troubleshoot Customer Trouble Reports
When customers describe their service problems, agents can quickly perform research and 
diagnostic tests to immediately resolve simple problems. If the problem cannot be 
immediately resolved, then agents can gather information that can be relayed to the 
technician to reduce the amount of time it takes to resolve problems. The application 
provides the following methods for diagnosing the cause of a problem before the service 
request is dispatched to a technician:

n Search the Knowledge Base to find similar problems that were resolved in the past. 

The Knowledge Base is a history file of previously logged service requests. It contains 
troubleshooting information that includes which network elements have caused similar 
problems in the past. See Knowledge Base.

n Use the Test Center to determine whether the network fulfillment element, which 
provides the service, is working. 

The Test Center contains a selection of predefined diagnostic tests that can be applied to 
elements in the network. See Test Center.

Third-Party Service Providers are Notified of Problems
To provide more comprehensive products and services to their customers, communications 
service providers often engage in reselling arrangements with third-party service providers. 
If customer problems are related to faults in the third-party service provider’s network, then 
you must notify that service provider. However, your organization must be the single point 
of contact for the customer.
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You can enter a service provider request to notify the third-party provider. You can track the 
third-party service provider’s external reference number, to keep yourself and your customer 
informed on the progress of the service request. See Service Request Types.

How Customers are Notified of Problem Resolutions
When customers call to report service problems, a support agent opens a service request. As 
a result, the customer service request workflow is automatically activated. This workflow 
ensures that customers are contacted to confirm that a service problem has been resolved to 
their satisfaction before the service request can be closed. See Types of Pre-defined Service 
Requests.

About the Installed Base 
The Installed Base is a repository of information about installed products and customers. 
Agents can view Installed Base data when customers call or when they need to create 
service requests. For more information, see Viewing Product Information in the Installed 
Base.

When you use Oracle Service for Communications to review information in the Installed 
Base, you start in the Product Summary and Details window. This window has three tabs 
that are specific to Service for Communications:

n Related Products

n Parameters

n Network Configuration

Related Products Tab
Use the Related Products tab on the Product Summaries and Details window to look at 
product hierarchies in the Installed Base. This tab shows the product of interest with its 
immediate parent and child products.

Other Oracle Service applications (for example, Oracle TeleService), provide  a 
Configuration Management tab. This tab includes information on parent and child 
assemblies and can display this information graphically.  Oracle Service for 
Communications presents the same information, though not graphically, on the Related 
Products tab. Please note that the Related Products tab will be blank if  there are no parent or 
child assemblies defined for the selected Installed Base item.

Levels of Product Hierarchies
APIs are used to populate the Installed Base. These APIs can populate the values for parent 
and child assemblies.
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Parameters in the Installed Base
Use the Parameters tab in the Product Summary and Details window to review the attributes 
of a selected service or product in the Installed Base. The information on the Parameters tab 
is for viewing only and cannot be edited in the window.

Service Key. A service key is a number or string of characters that is used to identify a 
communications product or service sold to a customer. For example, a phone number or an 
email address may be a service key.

Network Configurations
Use the Network Configurations tab in the Product Summary and Details window to review 
the fulfillment elements of a selected product in the Installed Base. The information on this 
tab can be edited. Access to this tab can be restricted to knowledgeable personnel during 
implementation.

Overview of Service Requests
A service request contains details about the customer, product, and problem. Typically, 
support agents create service requests when they receive reports of network problems from 
customers, network engineers, or field service personnel.

When setting up user profiles for the application, you determine who has the necessary 
privileges to create service requests for your organization. See Default Service Request 
Owner Setup. You can also use application programming interfaces (APIs) to create service 
requests.

For procedures that describe how to create service requests, see Creating Service Requests.

The following table describes the tabs found in the Service Request main window. Each tab 
gives access to a function that contributes to the process of managing a service request. The 
support agent can use these tabs to manage customer information, problem details, problem 
resolution, service history, and task assignment to assist and sustain a support center.

Tab Name Function

Product Coverage View and edit product attributes and service coverage 
information.

Links Link two or more related service requests. 

Workbench Post a problem summary note to the Knowledge Base to review 
support recommendations or provide solution results for other 
support agents.
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Workflows Monitor the Resolution Process
The creation of a service request triggers a service request workflow, which monitors the 
resolution of the problem. When a service request needs attention, the workflow notifies 
responsible individuals. For more information about workflows, see About Service Request 
Workflows and the documentation for Oracle Workflow.

The Knowledge Base in Service for Communications
Oracle Service for Communications creates a knowledge base of previously reported 
problems and their resolutions. When responding to a service request, service personnel may 
search this knowledge base to identify solutions that have worked in the past. As new 
problems are resolved, you can update the Knowledge Base to include these problems and 
their resolutions. For more information about the Knowledge Base, see Using Knowledge 
Base Search.

Types of Service Requests
Three types of service requests that are specific to the communications industry have been 
pre-defined and configured during the setup of the application:

n Customer service request

n Network service request

n Service provider request

Log View the history of customer contact with your company across 
all service requests.

Contacts View and edit customer contact information.

Addresses View and edit customer billing, shipping, and installation address 
information.

Task View or assign tasks associated with a service request.

Interactions View or contribute to the customer contact history of the selected 
service request.

Test Center .Communicate with network elements and apply diagnostic 
tests.

Tab Name Function
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Customer Service Request 
Use this request to describe a customer problem. As you enter the customer name and 
product information on the service request form, you can validate details about the customer, 
the product, and the current service coverage against the Installed Base. If the customer is 
unknown to the Installed Base, all the information can be collected in a non-verify mode and 
verified later.

Network Service Request 
Use this request to record information about a problem with the network elements in your 
communications network. You may create a network service request as a result of customer 
reports, or second-level repair personnel may create one after troubleshooting a customer 
service request. You can also create a network service request in response to a network 
problem that may or may not impact customer service.

Service Provider Request
Use this request to record a problem related to third-party network elements. You may 
generate service provider requests based on customer service requests or on network service 
requests. Service providers are pre-defined in the Installed Base.

Optional User-Defined Service Requests 
In addition to the three types of pre-defined service requests, you can define customized 
service request types to fit your business needs. User-defined service requests are 
implemented during application setup. 

The following are examples of user-defined service request types:

n Request for Information

n Customer Complaint

n Defective Product

n Installation Request

n Preventive Maintenance Visit

n Field Service

n Bug

For information about setting up user-defined service requests, see Setting Service Request 
Type. 
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Overview of Status of Service Requests
The service request status may change at different stages in the process of resolving a 
problem. Each pre-defined service request status is described in the following table. If you 
define your own types of request status, you must use Oracle Workflow to re-design the 
workflows, or processes, that are driven by the user-defined status. 

Audit History Log
Oracle Service for Communications maintains an audit history that records all changes made 
to service requests. For example, if you change the status of a service request from Queued 
to Open/Active, then the audit history records the old and new status values, as well as the 
user who made the change and the date. 

About Service Request Linking
For information about how to link service requests to one another, see Linking Service 
Requests.

Status Propagation in Linked Service Requests
Service requests can have links with other service requests in a one-to-many, one-to-one, 
many-to-one, or many-to-many relationship. When you link several service requests together 
in a parent-child relationship, you tie the status of each child service request to the status of 
the parent.

Status propagation ensures that the status of the parent service request affects the status of 
all its child requests. When you close a service request, whether it is linked or not, the 
system automatically checks for dependencies on the closed service request according to the 
business rules discussed in About Service Request Linking.

Note: Only a customer service request can have a Clear status.

Status Definition

Open Action has been initiated to resolve a service request.

Clear The service problem is resolved but the service request is not yet closed. If a 
Clear customer service request is linked to other service requests that have 
been closed, the customer must approve of the resolution before the request 
can be closed. 

Closed The service problem resolution process is complete.
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For example, a customer service request might be logged against an email service in the 
Installed Base. If the problem is the result of a server problem, then the network service 
request for the server is the parent to the child customer service request. As long as the 
network service request is open, the child service request remains open.

When the server is repaired and the network service request is closed, the associated child 
service request for the customer is given the Clear status. Customer service requests are the 
only request that can have a status of Clear. 
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When the customer service request has a Clear status, the customer is notified of the 
problem resolution. If the customer is satisfied with the resolution, the status of the customer 
request becomes Closed. If the customer is not satisfied, the status of the customer service 
request becomes Open and a notification is sent to the owner of the request.

For information about how to link service requests, see Linking Service Requests.

Understanding the Test Center
The Test Center provides an environment for agents to communicate with network elements 
and apply diagnostic tests. Often, agents can use the Test Center to quickly resolve customer 
problems, while customers are still on the line. Or they can perform a simple test and then 
calling the customer back immediately with the test results.

Set up the tests that you need to use during implementation of this application. To set up the 
tests, you must map actions that have been defined in Service for Communications to work 
items that have been associated to parameters of network elements in Oracle SDP 
Provisioning.

To implement the Test Center, you must integrate Oracle Service for Communications with 
Oracle SDP Provisioning, which provides the service delivery platform that communicates 
with your network. In the process of setting up the Test Center, you need to define actions, 
work items and parameters. 

Actions An action is an operation performed on a service or product. When you set up 
Oracle Service for Communications, use the test type of actions to define the actions used in 
the Test Center. They should include the actions that you perform on products and those that 
comprise the services you provide. These actions are not predefined in the Test Center. See 
Defining Test Type Actions.

Work Items In Oracle SDP Provisioning, you define work items that describe the 
subprocedures that can be performed against network elements. When you set up the Test 
Center in this application, you must map these work items to actions. For more detailed 
information, see Work Items in Oracle Provisioning.

Work Item Parameters
Each work item that is defined in Oracle SDP Provisioning is associated to parameters. 
These parameters are the characteristics of the network elements. If you do not define 
unique parameters in Oracle SDP Provisioning, the parameters use the default values. For 
more detailed information, see Defining a New Work Item Parameter.
10 Oracle Service for Communications Concepts and Procedures



About Service Request Workflows 
When you enter a Customer Service Request for that customer, the application uses Oracle 
Workflow technology to drive the resolution process. A workflow routes information to 
people inside your enterprise, according to business rules that you can easily modify. 

Oracle Service for Communications provides a pre-defined workflow process for each of the 
pre-defined request types:

n Customer Service Request Workflow

n Network Service Request Workflow

n Service Provider Request Workflow

Each workflow comprises activities required to drive a service request to resolution. Each 
activity generates information that can be recorded and tracked. You can use Oracle 
Workflow to create custom workflows for user-defined service requests. Use the Service 
Request Types setup window to define relationships between request types and workflows.

Customized Response to Service Requests
You can route service requests to individuals or roles in your organization and move them 
through a workflow-based resolution process tailored to your own unique business 
requirements. You can implement procedures that:

n Select and notify service personnel

n Facilitate the transfer and automatic escalation of service requests

You can define business rules that identify actions that violate your service standards or 
response guidelines and then take corrective actions or escalate those requests to the 
appropriate person. You can analyze the exact routing of each service request to identify and 
eliminate the bottlenecks in your resolution process. See Using Field Service for more 
information about dispatching field service personnel.
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Using Oracle Service for Communications

This topic group provides process-oriented, task-based procedures for using the application 
to perform essential business tasks.

Creating Service Requests
For directions on creating service requests, select the one of the three types of pre-defined 
service requests:

n Customer Service Requests

n Network Service Requests

n Service Provider Requests

Creating Customer Service Requests
When a customer calls to report a problem, use this procedure to enter information about the 
problem and the product on a customer service request.

Prerequisites
Before creating customer service requests, you must:

n Define customer products in the Installed Base.

n Define items in Inventory.

n Define customer accounts in Accounts Receivable.
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Steps
1. In the Navigator, select Service Request > Comms Service Requests.

The fields for Date Opened, Type, Status, Urgency and Owner contain default values.

2. Under Request Information, select Customer Service Request from the Type drop-down 
menu.

3. Select the appropriate Caller Type and fill in the Last name field.

The fields for First name, Company, Phone, Ext, and Email should contain the 
appropriate information.

4. Enter Account or select the appropriate account from the drop-down menu.

5. Select the Time Zone from the drop-down menu.

6. Check the Installed Base checkbox and select the Product from the drop-down menu.

The Desc field shows the product description. If applicable, the product Revision, Serial 
Number, and System number appear. If applicable, information related to the service 
contract appears.

7. Select the Workbench tab and fill in the required fields to describe the problem and the 
date a resolution is expected.

8. Select the Test Center tab and select a test name.

The Work Items button becomes available. You may click Work Items to see a list of 
all work items and their parameters.

9. Click Submit to run the selected test.

The test name and results are displayed.

10. Click Save to save the service request.

The new Customer Service Request is now in the system.

Reference
n For more information on service requests, see Service Requests.

n See also Testing Network Elements. 
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Creating Network Service Requests
When a problem with a communication network occurs, use this procedure to enter a 
network service request.

Prerequisites
Define a fulfillment element in Oracle SDP Provisioning that corresponds to the network 
service.

Steps
1. In the Navigator, select Service Request > Comms Service Requests.

The fields for Date Opened, Type, Status, Urgency and Owner contain default values.

2. Under Request Information, select Network Service Request from the Type drop-down 
menu.

3. Select Network Source from the Source list of values.

4. Select employee from the Caller Type drop-down menu and fill in the Last name field.

The fields for First name, Company, Phone, Ext, and Email should contain the 
appropriate information.

5. Select the Time Zone from the drop-down menu.

6. Uncheck the Installed Base checkbox and select the Product from the drop-down menu.

The Desc field shows the product description. If applicable, the product Revision, Serial 
Number, and System number appear. 

7. Select the Workbench tab and fill in the required fields to describe the problem and the 
date a resolution is expected.

8. Select the Test Center tab and select a test name.

The Work Items button becomes available. You may click Work Items to see a list of 
all work items and their parameters.
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9. Click Submit to run the selected test.

The test name and results are displayed.

10. Select File > Save to save the service request.

The new Network Service Request is now in the system.

Reference
For more information on service requests, see Service Requests.

Creating Service Provider Requests
When a problem is related to a product or service provided by a third party, use this 
procedure to enter information into a service provider request.

Prerequisites
The third-party service provider must exist as an inventory entry in Purchasing. The 
third-party service provide must generate a reference number through their service request 
system.

Steps
1. In the Navigator, select Service Request > Comms Service Requests.

The fields for Date Opened, Type, Status, Urgency and Owner contain default values.

2. Under Request Information, select Service Provider Request from the Type drop-down 
menu.

3. Select the service provider from the drop-down menu and enter the service provider’s 
reference number.

4. Select employee from the Caller Type drop-down menu and fill in the Last name field.

The fields for First name, Company, Phone, Ext, and Email should contain the 
appropriate information.

5. Select the Time Zone from the drop-down menu.

6. Uncheck the Installed Base checkbox and select the Product from the drop-down menu.

The Desc field shows the product description. If applicable, the product Revision, Serial 
Number, and System number appear. 

7. Select the Workbench tab and fill in the required fields to describe the problem and the 
date a resolution is expected.
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8. Click Save to save the service request.

The new Service Provider Request is now in the system.

Reference
For more information on service requests, see Service Requests.

Viewing and Updating Service Requests
Use this procedure to view and update customer information, product information, and any 
current or previous service requests. You can search by Customer, Number, Status or other 
fields of information.

Prerequisites
None.

Steps
1. From the Navigator, select Service Request > View Comms Service Requests.

The Find Window opens.

2. Enter information about the service request of interest in one or more fields and click 
Find.

The Service Request window displays one or more lines of requests that contain the 
information you entered.

3. Click to select a particular line and view details about that associated request. 

At this point, you may update information about the request.

4. Select File > Save to save your changes.

References
n Viewing the Customer Contact Log

n Recording Customer Contact Phone Numbers

n Recording Customer Addresses

n Creating and Updating Tasks from a Service Request

n Recording and Viewing Customer Contact Interactions
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Linking Service Requests
When a service request is a direct result of another service request, use this procedure to link 
one or more service requests in a parent/child relationship.

Prerequisites
The product or network described in the requests must be in inventory.

Steps
1. From the Navigator, select Service Request > Comms Service Requests.

2. In the Service Requests window, enter a new service request and select Find > Save. 

The application inserts a number in the Request field.

3. Select the Links tab.

The lines on the Links tab display all service requests that are associated to this request 
and the type of link, either parent or child.

4. If you know the request number of the request you want to link to, enter that number on 
a line.

As an alternative, click New Association to open the Find Service Request window.

In the Find Service Request window, enter information in one or more of the fields and 
click Find. Select a service request to return to the Links tab.

5. Select the relationship you want the link to represent, either parent or child.

All other columns on the Links tab are view-only. 

6. Click Save Association to save the new link.

7. Repeat this procedure for each service request you want to link.

Guidelines
When you close a service request and change its status to cleared, the application 
automatically checks for dependencies on the cleared service request. For information about 
the business rules that apply to closing linked service requests, see About Service Request 
Linking.

References
Only customer service requests can have a Clear status. The following table lists which 
statuses can apply to the three types of service requests.
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Testing Network Elements
When customers call to report trouble with products and services, use this procedure to run 
diagnostic tests while the customer waits.

Prerequisites
Tests must be set up during implementation of this application before you can test products 
or services. For more information, see Test Center.

Steps
1. From the Navigator, select Service Request > Comms Service Requests.

2. In the Service Requests window, enter the service request information and save your 
work.

3. Choose the Test Center tab.

The Test Procedures region displays all test Actions that are associated with the 
products displayed. To view work items that are associated with a test procedure, click 
View Workitems in the Test Procedures region of the Test Center tab window.

4. Select the desired test action and click Submit to perform the test.

The Test Results are displayed in a read-only panel for each work item associated to the 
test action.

Guidelines
The Test Center tab window is active only when you have entered sufficient information to 
uniquely identify an active product or service.

Service Request Type Allowed Status

Customer Service Request n Open

n Clear

n Closed

Network Service Request n Open

n Closed

Service Provider Request n Open

n Closed
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Troubleshooting
If no work items have been associated to a test action for the product or service, then the 
View Workitems button is inactive. To activate it, contact your system administrator to 
associate work items with the test action item in Oracle SDP Provisioning.

Viewing Product Information in the Installed Base
The Installed Base contains data about products and services that have already been 
purchased by customers. Use this procedure to view product information in the Installed 
Base.

Prerequisites
None.

Steps
1. Use the Navigator to open Installed Base > Customer Products.

The Find Product window opens in front of the Product Summary and Details form.

2. Enter information in the blanks on the Find Product window to describe the product or 
account information you want to view.

Click Search Account to open the Search Account Number window for finding account 
numbers.

3. Click Find when one or more blanks in the Find Product window contain information.

One or more lines at the top of the Product Summary and Details form become 
populated with details about the related product or account.

4. Select a line to see more details about that entry appear in the bottom of the form.

5. Click tabs to review more information about a selected line.
.

References
To understand how product information may be organized in the Installed Base, see:

n About the Installed Base

n Installed Base Tabs

Note: In Service for Communications, you cannot view the Installed 
Base when the Caller Type is ‘Employee’.
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Implementing Oracle Service for Communications
This topic group provides general descriptions of the setup and configuration tasks required 
to implement the application successfully.

Implementation Overview
Before setting up Oracle Service for Communications, you must install and implement:

n Oracle Service Installed Base module

n Oracle Support Service Request module

n Oracle Field Service, if you wish to use the dispatching feature

n Oracle SDP Provisioning, if you wish to use the Test Center

n Oracle Sales for Communications

For information regarding the installation and implementation of these applications and 
components, see the appropriate documentation for each product. The implementation tasks 
described here are tasks that are necessary to use the additional functionality included with 
Oracle Service for Communications. Implementation of this application includes setting up 
these features and options:

n Service request statuses

n Linking workflow notifications to service request types

n Default service request owner

n Default service request escalation time

n Default network service request escalation time

n Default customer response time

n Test Center tests

Service Request Status Setup
Use service request status to indicate where a service request is in the resolution process. 
This application provides three pre-defined service request status: Open, Clear and Closed. 
You can define any number of additional statuses to reflect your organization’s business 
processes.

For a description of all of the pre-defined statuses, see Overview of Service Requests.
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Workflow Notifications Setup
When a service request is created, the associated Workflow launches, based on the service 
request type. A service request type may be defined to use a standard or customized 
workflow. The standard service request types used in this application and their 
corresponding workflows are listed in the following table.

Linking a Workflow to a Service Request Type
For the correct workflow to launch when a service request is created, you must link each 
workflows to the appropriate service request type. Use the following procedure to link a 
service request type to a workflow.

Prerequisites
None

Steps
1. From the Navigator, select Setup > Service Requests > Request Types.

2. Locate the appropriate Service Request Type.

3. Choose the appropriate workflow from the list of values […].

4. Select File > Save to save your work.

Profile Options Setup
During implementation, the System Administrator assigns a value for each profile option. 
The values define access privileges and how the application processes data.

The profile options are set at one or more of the following levels: site, application, 
responsibility, and user. The system administrator sets and updates profile values using the 
System Profile Options window.

The following table describes the profile options that are unique to Oracle Service for 
Communications.

Service Request Type Associated Workflow

Customer Service Request Customer Service Request Workflow

Network Service Request Network Service Request Workflow

Service Provider Request Service Provider Request Workflow
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Profile Option Description

Service: Default Workflow 
Customer Service Request 
Escalation Time

Workflow resolution uses the expected resolution 
date that is specified in the service request to 
determine the date of escalation. When no expected 
resolution date is specified, the escalation time is 3 
days. 

Use the profile to define a default escalation 
timeframe in hours. The default system profile is set 
at 72 hours.

Service: Default Workflow 
Network Service Request 
Escalation Time

A network service request is more critical than a 
customer service request because it may impact a 
significant number of customers. Network service 
requests should be resolved as quickly as possible 
and escalation should occur in a shorter 
timeframe—in a matter of hours instead of days. Use 
this profile option to define the escalation timeframe 
in hours.

The default escalation time is set at 8 hours. The time 
count begins as soon as the initial workflow 
notification is sent. If the notification is forwarded 
within the timeframe, the new escalation deadline 
does not extend an additional 8 hours. Instead, 
escalation must occur within the timeframe specified 
in the first workflow notification.

Service: Default Customer 
Response Time

When a service request is resolved, the status 
changes to cleared. At this point, the agent who 
created the service request receives a workflow 
notification to contact the customer and confirm that 
the problem is resolved. If the customer agrees that 
the problem is resolved, then the service request is 
closed.

This profile option defines how many days a service 
request can remain in the cleared state. The default 
response time is 3 days.
Using Oracle Service for Communications 23



Default Service Request Owner Setup
The person who receives a workflow notification must be defined in these areas of Oracle 
Applications:

Resetting the Default Service Request Owner
The Service Request window displays the default owner, based on the profile option that is 
defined at the system or user level. The owner may be changed when the service request is 
created. However, the default service request owner may be reset as required. Use this 
procedure to reset the default service request owner.

Prerequisites
The new default service request owner must be defined in the Oracle Human Resources 
Management System (HRMS) area of this application.

Steps
1. From the Navigator in the Oracle Service for Communications responsibility, select 

Other > Profile.

2. Query for the profile option, Service: Default Service Request Owner. 

The window displays the default value.

3. Choose the appropriate user from the list of values […].

4. Select File > Save to save your work.

Oracle Human Resources 
Management System 
(HRMS)

Individuals must be defined in Oracle HRMS before they can 
receive a workflow notification. In addition an individual’s 
Assignment, Organization, Job, Position, and their 
Supervisor must also be defined in Oracle HRMS. The 
Supervisor must be defined so a workflow escalation 
notification can be routed to the appropriate management 
contact. For information about setting up an employee in 
Oracle HRMS, see the Oracle Human Resources 
Management System user’s documentation.

Application Object 
Application User

When an application user is created, the user must be linked 
to the person defined in oracle HRMS, and the appropriate 
responsibilities must also be assigned. For information about 
how to create application users, see the Oracle System 
Administrator user’s documentation.
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Guidelines
To reset the default service request owner, submit a request to your system administrator to 
change this profile option.

Defining Test Type Actions
An action is an operation performed on a service or product. Use the test type of actions to 
define the actions used in the Test Center. The actions should include the actions that you 
perform on products as well as the services you provide. Use this procedure to define test 
type actions.

Prerequisites
None.

Steps
1. In the Service for Communications responsibility, navigate to Setup > Test Center > 

Item Action Parameters.

The Organizations window appears.

2. Select your organization from the list of organizations and click OK.

The Action Parameters window appears.

3. In the Action Type list of values, choose Test.

4. Use the Item field to describe the item being tested. Use the Description field to 
describe the action.

Leave the fields on the Main and Entity tab blank.

5. Select File > Save to save the definitions.

6. Click Map Work Items to open the form for mapping the defined action to one or a 
series of work items.

See Mapping Actions to Work Items for the Test Center
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Mapping Actions to Work Items for the Test Center
If you want to use the Test Center in Oracle Service for Communications, you must map test 
type item actions to the work items that are defined in Oracle SDP Provisioning. The 
application uses these mappings to communicate with network elements and apply 
diagnostic tests to those elements. Use this procedure to map actions to work items.

Prerequisites
Before you can map actions to work items, you must define the actions in Oracle Service for 
Communications. Then you must associate work items to network parameters in Oracle SDP 
Provisioning. For more information, see Test Center.

For detailed information about defining work items, see Work Items in Oracle Provisioning.

Steps
1. From the Navigator, select Service Request > Comms Workitems Mapping.

2. In the Mapping Action to Workitems window, select an Action Name from the list of 
values by clicking the […] in the field.

Only test-type action items will display in the list of values.

3. In the Work Items region of the window, select the work items from the list of values in 
the Name column in the appropriate sequence.

When you select a work item, the parameters that are associated to it are displayed in 
the read-only Parameters region of the window.

4. Choose File > Save to save this mapping association.
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