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Preface

Intended Audience
Welcome to Release 11i of the Oracle Applications User’s Guide.

This guide assumes you have a working knowledge of the following:

• The principles and customary practices of your business area.

• Computer desktop application usage and terminology

If you have never used Oracle Applications, we suggest you attend one or more of the
Oracle Applications training classes available through Oracle University.

See Related Documents on page viii for more Oracle Applications product information.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation accessible,
with good usability, to the disabled community. To that end, our documentation
includes features that make information available to users of assistive technology. This
documentation is available in HTML format, and contains markup to facilitate access
by the disabled community. Standards will continue to evolve over time, and Oracle is
actively engaged with other market-leading technology vendors to address technical
obstacles so that our documentation can be accessible to all of our customers. For
additional information, visit the Oracle Accessibility Program Web site at
http://www.oracle.com/accessibility/

Accessibility of Code Examples in Documentation
JAWS, a Windows screen reader, may not always correctly read the code examples in
this document. The conventions for writing code require that closing braces should
appear on an otherwise empty line; however, JAWS may not always read a line of text
that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any
representations regarding the accessibility of these Web sites.
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Structure
1 Getting Started with Oracle Applications
2 Forms-Based Applications
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Related Documents
You can choose from many sources of information, including online
documentation, training, and support services, to increase your knowledge and
understanding of Oracle Applications.

If this guide refers you to other Oracle Applications documentation, use only the Release
11i versions of those guides.

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser,
database triggers, or any other tool to modify Oracle Applications data unless otherwise
instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and
maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus
to modify Oracle Applications data, you risk destroying the integrity of your data and
you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using an
Oracle Applications form can update many tables at once. But when you modify Oracle
Applications data using anything other than Oracle Applications, you may change a row
in one table without making corresponding changes in related tables. If your tables get
out of synchronization with each other, you risk retrieving erroneous information and
you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications
automatically checks that your changes are valid. Oracle Applications also keeps track of
who changes information. If you enter information into database tables using database
tools, you may store invalid information. You also lose the ability to track who has
changed your information because SQL*Plus and other database tools do not keep a
record of changes.
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1
Getting Sta rted with Oracle Applications

Introduction
Oracle E-Business Suite is a complete set of business applications for managing and
automating processes across your enterprise. This guide describes the user interface
features that are common to Oracle E-Business Suite applications, including:

• List of Values (LOV), page 2-5

• Flexfields, page 2-6

• Search (Query) functions, page 2-8

• Folders, page 2-10

• Concurrent Requests, page 2-11

• Export, page 2-14

• Attachments, page 2-15

• User Profile Options, page 2-16

Getting Started
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The E-Business Suite Home page is your entry point to Oracle E-Business Suite. From
this page you can:

1. Access E-Business Suite functions from the Applications menu.

2. Set Preferences.

3. Navigate to frequently-used functions or Web pages from Favorites.

Access E-Business Suite Functions
Use the Applications menu to access Oracle E-Business Suite functions grouped
by responsibility.

Note: A responsibility is a level of authority in Oracle E-Business Suite. It
enables your access to those functions and data appropriate for your
enterprise role. You can have one or more responsibilities.

To access a function:
1. Select a responsibility to view its menu of functions.

2. Select the function to launch it.

Two Types of Interfaces
Oracle E-Business Suite applications are either Forms-based or HTML-based.
Forms-based applications are optimized for processing a large volume of
transactions. HTML-based applications, sometimes referred to as "self-service
applications", are optimized for ease of first-time use. For example, to enter a batch of
journals, the E-Business Suite provides a Forms-based application. To submit an expense
report, the E-Business Suite provides an HTML-based application.

Forms-based functions open the Oracle Applications Navigator. For more information
about the Navigator window, see Using Forms-Based Applications, page 2-1.

For more information about HTML-based applications, see Using HTML-Based
Applications, page 3-1.

Set Preferences
Select Preferences to set personal options. Options include language, territory, time
zone, notification style, accessibility setting, and formats for dates and numbers. You
can also reset your password from the Preferences page.

Note: The language you select here will not override the session
language you selected at log in.

Set additional preferences using user profile options. For more information, see Defining
Preferences with User Profile Options, page 2-16.

Navigate to Frequently-Used Functions
Customize your Favorites by adding links to frequently-used functions and Web sites.

To add or remove links, select Edit Favorites.
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2
Forms-Base d Applications

Using Forms-Based Applications

The Navigator

From the Navigator you can:

• Open forms from the Functions tab.

• Link to documents from the Documents tab.

• Launch business processes from the Processes tab.

Open Forms:
The Functions tab provides links to the forms accessible to your current responsibility.
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To open a form, expand the function heading and double-click the form name.

Create a Top Ten List :
Add forms that you use frequently to your Top Ten List. Create a different top ten list
for each of your responsibilities.

To add a form to the Top Ten List
1. Select the form, then select the Add to List button.

To remove a form from the Top Ten List
1. Select the form, then select the Remove from List button.

Create Links to Documents:
Create links to documents that you are working on for faster access. The Documents tab
allows you to save as many links as you want. View the saved links as a list or as icons.

To add a document that is currently open
1. Choose Place on Navigator from the File menu

Attention: The Place on Navigator command is not enabled for all
forms.

To rename a link that you have created
1. Select its name (or icon) and select the Rename button.

2. Enter the new name in the Rename Label window and click OK.

To remove a document from the Documents tab
1. Select its name (or icon) and select the Remove button.

Launch Business Processes:
The Processes tab contains interactive step-by-step maps of business processes. Each
step is a form or report that you can launch directly from the process map.

Each time you launch a business process, you create an instance of that process and
assign it a name. As you complete each step in a process, the map is updated accordingly.

To open a process
1. Select the process, then select the Launch button.

2. Enter a name for the new instance.

The instance remains active until you complete or cancel it. The Processes tab
lists your active instances.

Working in a Process Instance
The active step has a box drawn around it. More than one step can be active if
your process contains multiple paths.

• Click once on a step icon to display a description of the step.

• Double-click on a step icon to open the related form.

• Advance to the next step of a process from within a form by using the Next
Step toolbar icon.

2-2 Oracle Applications User’s Guide



The Forms Toolbar

The toolbar icons and the actions they perform are as follows:

1. The New icon opens a new record.

2. The Find... icon invokes the Find window.

3. The Show Navigator icon invokes the Navigator window.

4. The Save icon saves your data.

5. The Next Step icon advances you to the next step of a process (see Launch Business
Processes, page 2-2).

6. The Switch Responsibilities icon invokes the list of your responsibilities for you to
choose another.

7. The Print... icon prints the current screen. In some cases it may print a report
associated with the current data.

8. The Close Form icons closes all windows of the current form.

9. The Cut icon cuts the current selection to the clipboard.

10. The Copy icon copies the current selection to the clipboard.

11. The Paste icon pastes from the clipboard into the current field.

12. The Clear Record icon erases the current record from the form.

13. The Delete icon deletes the current record from the database.

14. The Edit Field... icon displays the Editor window for the current field.

15. The Zoom icon invokes customer-defined drill-down behavior.

16. The Translations... icon invokes the Translations window (see Creating Translations
for a Record, page 2-7).

17. The Attachments icon invokes the Attachments window. If attachments already
exist, the icon appears as a paperclip holding paper (see Attachments, page 2-15).

18. The Folder Tools icon invokes the Folder Tools palette window (see Customizing
the Presentation of Data, page 2-10).

19. The Window Help icon invokes online help for the current window.

Entering Data in Forms
Use the following form components to enter and query data:
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1. Single-Row Block

2. Multi-Row Block

3. Folder Indicator

4. Current Record Indicator

5. Record

6. Message Line

7. Status Line

8. Field

9. List of Values Indicator

10. Descriptive Flexfield

11. Master-Detail Coordination Box

Organization of a Form

Field
Use fields to enter, view, update, or delete information.

By default, a required field is displayed in yellow, and a read-only field is displayed
in gray. These colors can be changed or turned off using profile options. See Defining
Preferences with User Profile Options, page 2-16.

2-4 Oracle Applications User’s Guide



In some cases, the display size of a field is too small to show the entire field contents. Use
the Edit Field toolbar icon to view and update these fields.

Record
A record is a logical grouping of fields. A record is also referred to as a row or a
transaction, since one record corresponds either to a row in a database table or to a
transaction.

You must complete all required fields in a record before moving to the next record.

Note: If you unintentionally enter a record and cannot advance your
cursor, clear the record. From the Edit menu, choose Clear, then Record.

Block
A block displays a set of records either in a single-row format or a multi-row format.

To clear data at the block level: From the Edit menu, choose Clear, then Block.

Creating and Deleting Records

To create a record:
1. Choose New from the File menu, or use the New toolbar icon.

2. After entering data for your new record, choose Save or Save and Proceed from
the File menu to save the record to the database. Choosing Save and Proceed
automatically advances you to the next record.

To delete a record:
1. Choose Delete from the Edit menu.

This action erases the current record from your screen, and returns your cursor to the
first field of the next record.

2. To delete the record from the database, choose Save or Save and Proceed from the
File menu.

Using a List of Values (LOV)
A field that has a predefined list of valid values displays an LOV icon. Select this icon
to view the valid field values.

If a list contains more than 100 values, you are prompted to enter a Find string to
limit the list.

To choose a value from a list:
Select a value, or reduce the list using one of the following methods:

• Without placing your cursor in the Find field, type the initial character(s) of a
value to autoreduce the list to those items matching the characters entered. Use
the Backspace key to re-expand the list. If your entry reduces the list to a single
value, the list window closes and inserts the value into the field.

Note: Lists that require a Find string do not use the autoreduce feature.

Forms-Based Applications 2-5



• In the list window, enter any group of characters in the Find field and select the
Find button.

Note: Use the wildcard character (%) to represent any number of
characters, and the underline (_) to represent a single character. Do not
enter a wildcard character by itself. This will match all records.

Power List
Power List enables you to enter a search string or partial value in an LOV field without
opening the list window.

To use Power List
Enter the initial characters of a value in the field and press the Tab key. Power List
completes the entry for you.

Your entry can include wildcard characters.

If more than one value matches the characters you specify, a list window opens
containing those values.

Advanced Data Entry Features

Master-Detail Relations
A Master-Detail relation is an association between two records. An example is the
relationship between the Batch and Journals records in Oracle General Ledger. Each
batch (master record) is associated with a set of journal entries (detail records).

Some master-detail blocks contain a coordination check box that allows you to choose
whether detail records are queried. Select the master-detail coordination check box to
automatically coordinate the update of records between the master and detail blocks. If
you deselect the check box, the detail data is not displayed until you move your cursor
into the detail block.

Drill-Down Indicators
Some records provide additional details in separate, drill-down windows.

A wide-width current record indicator designates that a record provides drill-down
information. Double-click the indicator to open the detail window.

Flexfields
A flexfield is a flexible data field that can be customized by your enterprise. Oracle
E-Business Suite uses two types of flexfields:

• Key flexfield - a field you customize to enter multi-segment values, such as part
numbers or account numbers.

• Descriptive flexfield - a field you customize to enter additional information not
provided by Oracle E-Business Suite.
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Key Flexfields

A key flexfield is composed of segments, where each segment has both a value and a
meaning. For example, an Accounting Flexfield can be composed of segments that
represent Company, Department, and Account. The segments are delimited by a
segment separator (usually a "." or a "-").

A range flexfield is a type of key flexfield in which you can input a low and a high value
for each segment to express a range of combinations.

Entering Data in a Key Flexfield

A key flexfield looks like any other field. You can enter the segments directly or use
the Flexfield window to enter each segment separately.

To enter data directly into a key flexfield:
1. Enter the segment values, separating each with the segment separator.

To enter data using the flexfield window:
1. Select the List of Values icon to open the flexfield window, or select the Edit

Field... toolbar icon.

2. Enter a value for each segment, or use the list of values where available.

3. Select the Combinations button in the flexfield window to search the list of existing
segment combinations.

To enter data in a range flexfield:
Enter a Low and a High value for each segment, or use the list of values where available.

Descriptive Flexfields

A descriptive flexfield appears as a two-character, unnamed field enclosed in brackets.

Move your cursor into the bracketed field to open the descriptive flexfield window. The
window contains segments that make up the descriptive flexfield. Each segment can
have a list of values.

Entering Data in a Descriptive Flexfield

To enter data in a descriptive flexfield:
1. Open the descriptive flexfield window. If your profile option Flexfields:Open Descr

Window is set to "No", or if you are in a folder, select the Edit Field... toolbar icon
to open the flexfield window.

Note: For more information on profile options, see Defining Preferences
with Personal Profile Options, page 2-16.

2. Enter a value for each segment, or use the list of values where available. Default
values can be overwritten.

Creating Translations for a Record
Windows that allow the entry of records in multiple languages display the enabled
Translations... toolbar icon.
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To enter a translation for a record:
1. Select the record you wish to translate.

2. Select the Translations... icon from the toolbar.

The Translations window opens, with translatable fields displayed in columns. The
installed languages are displayed in rows.

3. Enter translations for the displayed fields.

Using Keyboard Help
Use keystroke combinations to perform many menu functions.

To view the list of functions and keystroke combinations:
1. Choose Keyboard Help... from the Help menu.

Searching for Data
To query records in your current block or window, use the Find command or Query
by Example.

The Find Command
The Find command displays a window in which you can specify search
criteria. Depending on the block that you invoke Find from, one of two types of
windows appears:

• A find window that contains fields for entering search criteria.

• A list window that shows all possible records that you can retrieve for the block.

Generally, a find window appears for a multi-record block, while a list window appears
for a single-record block.

Using the Find Command
1. Choose Find... from the View menu or select the Find toolbar icon.

• If a list window appears:

• Use a list window as you would an LOV window. SeeUsing a List of Values
(LOV), page 2-5.

• If a find window appears:

1. Enter as many search criteria as you can.

2. Select the Find button.

Query by Example
To retrieve a group of records based on more sophisticated search criteria than Find
allows, use Query by Example. Query by Example allows you to specify search criteria
in any of the queryable fields in the current block. The search criteria can include specific
values, phrases containing wildcard characters, or query operators.
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If you do not need to retrieve the records, but only want to know how many records
match your search criteria, perform a query count.

To use Query by Example:
1. From the View menu, choose Query by Example, then Enter.

This action switches your window from data entry mode to Enter Query
mode. Queryable fields are displayed in blue.

2. Enter search criteria in the queryable fields (fields may be case-sensitive). To reuse
criteria from your last search: From the View menu, choose Query by Example, then
Show Last Criteria.

Attention: In Enter Query mode, all check boxes are initially in a null
state. To use a check box as a search criterion, you must explicitly
check or uncheck it.

3. To perform the search: From the View menu, choose Query by Example, then Run.

4. To exit Enter Query mode without searching: From the View menu, choose Query
by Example, then Cancel.

To perform a query count:
1. Perform steps 1 and 2 from the previous task: "To use Query by Example."

2. From the View menu, choose Query by Example, then Count Matching
Records. The window’s message line displays the number of matching records.

Query Operators
The following table shows the query operators for most fields, their meanings, and
an example expression:

Query Operators

Operator Meaning Example Expression

= equals = ’Janet’, = 107

!= is not != ’Bob’, != 109

> greater than > 99.1, > ’01-JAN-04’

>= at least >= 55

< less than < 1000.00

<= at most <= 100

#BETWEEN between two values #BETWEEN 1 AND 1000
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Customizing the Presentation of Data
Folder blocks allow you to personalize a form. You can define a query, customize the
layout of the form columns, and then save the query and layout in a folder definition
that can be retrieved later.

Folder blocks display an Open Folder button. When you move the cursor into a folder
block, you enable the Folder Tools toolbar icon and the Folder menu.

Attention: If your system administrator sets the profile option
Folders: Allow Customization to "No", you cannot create or customize
folders. The only item available from the Folder menu is Open, to open
a predefined folder. For more information about profile options, see
Defining Preferences with User Profile Options, page 2-16.

Defining Query Criteria for a Folder

To define query criteria for a folder:
1. Run a query, either by using the Find command or Query By Example.

2. Save your query criteria by choosing Save As from the Folder menu.

3. Enter a name for the folder.

4. Select Always, Never, or Ask Each Time from the Autoquery option group to define
how frequently to perform the saved query.

5. Select the Open as Default check box to set this folder definition as the default
every time you navigate to this form.

6. Select the Public check box to allow other users to access your folder
definition. Selecting Public does not enable other users to modify your folder.

7. Select the Include Query check box to include your query in the folder definition. If
you do not select this check box, only the folder layout is saved.

To view the query criteria for a folder:
1. Choose View Query from the Folder menu.

The Folder Query window displays the query used to retrieve the records displayed
in the folder. An empty window indicates that the folder retrieves all records.

To reset the query criteria for a folder:
1. Choose Reset Query from the Folder menu.

This clears the query from the current folder, but retains the current folder name
and field layout.

2. Perform another query and choose Save from the Folder menu to save the new
query to your current folder.

Customizing the Layout of a Folder
Use the Folder menu or the Folder Tools window to customize the folder layout. Some
layout changes can be made using the mouse. For example:

• Change the width of a column by dragging the column’s border.
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• Change the sequence of a column by dragging the column’s heading to a new
position.

• Change the name of a column by using the right mouse button on the column’s
heading. A window prompts you for the new name.

To access the Folder Tools window:
1. Select the Folder Tools toolbar icon, or choose Folder Tools from the Folder menu.

Running Reports and Programs
Use Standard Request Submission to run reports and programs.

Attention: Some forms automatically submit a request when you choose
a specific button or save your work.

Request Submission

To submit a request or request set:
1. Navigate to the Submit a New Request window (navigation varies by application).

2. Select the request type (Single Request or Request Set) and select OK.

3. Enter the request Name from the list of available requests in the Submit Request
window.

If you are submitting a request set, enter the Request Set name in the Submit
Request Set window.

Note: Use the Copy... button to display a list of all requests that you
have previously submitted from this responsibility. Select a request from
the list and choose the Submit button.

Define Parameters
If a request requires parameter values, the Parameters window opens. (Note: Your user
profile option Flexfields:Open Descr Window must also be set to "Yes". See Defining
Preferences with User Profile Options, page 2-16.)

4. Enter the values in the required parameter fields and choose OK.

Determine the Output Language
If your site supports multiple languages, select the language for your request output.

5. Choose the Language Settings... button to open the Languages window. If the
language selection is predefined in the report, the Language Settings... button is
not enabled.

In the Languages window select the Language, Territory, and Numeric Character
settings appropriate for your report.

6. Select the Select All button to produce output in all languages supported at your
site or to check individual languages.

Attention: Each language creates its own request, so the number of
languages determines the number of requests created and tracked in
the Requests window.
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Define a Submission Schedule
Define a schedule to run a request as soon as possible, at a specific time, or repeatedly at
specific intervals.

7. Choose the Schedule... button to open the Schedule window.

8. Choose a type of schedule from the Run the Job... option group. Some schedule
selections require additional information.

9. To save your schedule, select the Save this schedule check box. You are prompted to
enter a unique name for your schedule.

Define Completion Options
10. To view your output online or to save your output to a file select the Save all Output

Files check box in the Upon Completion... region.

11. Select the Options... button to change the default notification and output options.

Output options include: people to notify, language for each person
notified, printer, copies, and print style.

Note: Some requests have a required Style or Printer value that you
cannot change.

12. After you have specified the scheduling and completion options, choose the
Submit button. A Decision window displays the Request ID. To submit another
request, select Yes.

If you are submitting a request set, a Request ID is assigned to the set and to each
request in the set.

Monitoring Requests
The Requests window allows you to:

• View the status of your submitted requests

• Change processing options

• Diagnose errors

• View your request output

Attention: The profile option Concurrent:Report Access Level
determines the requests displayed in the Requests window. If the
option is set to "User", only your user requests are displayed. If the
option is set to "Responsibility" all requests submitted by users of your
responsibility, in addition to the requests for your user ID, are displayed.

Request Phase and Status
A request has a life cycle consisting of the following phases: pending, running, and
completed. If a request is on hold or unable to run, the request is placed in an inactive
phase.

During each phase, a request has a specific status. Listed below are the possible statuses
for each phase:

• Pending Phase - Normal, Standby, Scheduled, Waiting
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• Running Phase - Normal, Paused, Resuming, Terminating

• Completed Phase - Normal, Error, Warning, Cancelled, Terminated

• Inactive Phase - Disabled, On Hold, No Manager

For more information about the status of your request, select the Diagnostics button in
the Requests window.

Finding Requests

To find requests:
1. Open the Requests window (navigation varies by application).

When you open the Requests window, you are directed to the Find Requests
window.

2. Define your search criteria.

Note: You can use the Specific Requests region to view a list of
requests that you did not submit by entering a requestor other than
yourself. However, you can only view details, output, and log files for
requests submitted by you or your responsibility.

3. Select Find.

Options for Requests in Progress
Hold or cancel pending requests from the Requests window using the Hold Request or
Cancel Request buttons.

View request diagnostics by selecting the Diagnostics button.

You can change completion and scheduling options for requests that meet the following
criteria:

• You made the initial request.

• The request has not yet run.

• The program does not prevent request updates.

To Change Options for a Request in Progress:
1. Select the request from the list.

2. Select the View Details... button to launch the Request Detail window.

• To update a request’s schedule, select the Schedule... button.

• To update a request’s completion options, select the Options... button from the
Upon Completion... region.

Viewing Request Output
Reports are displayed in a browser, in the Report Viewer, or in another application
registered by your system administrator. Reports that produce an output other than a
text file (for example, HTML or PDF) are displayed in a browser.
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Set the profile option Viewer: Text to "Browser" to display your text files in a browser. If
your system administrator registered other applications for viewing reports, select your
text viewer application using the profile option Viewer: Application for Text. If this
profile option is not set, you get a choice of applications when you view the report.

For more information about these profile options, see Defining Preferences with User
Profile Options., page 2-16

To View Request Output:
1. Navigate to the Requests window.

2. Select the completed request and select the View Output button.

To view request log files
1. Select the View Log button.

To save request output displayed in the Report Viewer
1. Choose Copy File... from the Tools menu to display the Viewer Option window.

2. Select an output file format. This action opens your browser window.

3. From the browser window, use your browser’s tools to save your request
output to a file.

To reprint a request
1. Select the request and choose Reprint... from the Tools menu.

2. In the Reprint Options window, enter values for Copies, Printer, and print
Style.

To Save Reports from Your Browser:
You can use the Save As functionality of your browser to save an HTML report to
your desktop. Ask your system administrator for assistance if your browser does not
display your language’s character set clearly.

Exporting Records to a File
Use the export feature to save the records in a multi-row block to a tab-delimited
file. Open the file in the application of your choice.

To start an export:
1. Query the records you want to export.

2. Place your cursor in the multi-row block that contains the records to be exported.

3. Choose Export... from the File menu.

Exporting Large Numbers of Records:
Export, by default, selects all the records retrieved by the query. If the number of records
exceeds 100, you are prompted to:

Stop - Limit the export to those records you have explicitly selected. Alternatively, cancel
the export.

Continue to End - Export all records retrieved by the query.
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Attention: Avoid exporting a very large number of records as system
performance can be affected.

Continue - Select the next 100 records for export. You are prompted every 100 records
until all records are selected, or you choose Stop or Continue to End.

Attachments
Use the Attachments feature to link text or other files to a record.

The Attachments... toolbar icon is enabled when the attachments feature is available. If
the current record already has an attachment, the icon appears to hold a piece of paper.

To open the Attachments window:
1. Click the toolbar icon, or choose Attachments... from the View menu.

To add a new attachment:
1. Select a Category from the list of values. The Category defines the purpose of an

attachment, and controls which forms or pages can access it.

2. Select the attachment Data Type from the list of values:

• Text - Enter text that is less than 2000 characters. If the text you want to attach is
more than 2000 characters, upload it in a file.

• File

Launch the Upload a File window in your browser. Select the Browse button to
locate the file in your file system, or enter the file location in the File field.

• Web Page

Your cursor advances to the File or URL field on the Source tab of the
window. Enter the URL for the Web page.

3. Select the May Be Changed check box to allow changes to the attachment.

To attach a document from the Document Catalog:
1. Choose the Document Catalog... button to open the Document Catalog window.

2. Use the Find Existing Documents region to query existing documents. Matching
documents are returned in the Documents region.

Note: To copy an attachment from another record, use the Attached
To: field to select the application object you want to copy attachments
from.

3. To view a document before attaching it, select it and choose the Preview button.

4. Select the document(s) to attach.

5. Choose the Attach (n) button (where n is the number of documents selected).
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To view an attached document:
In the Attachments window, select the attachment you want to view. If the attachment
does not automatically display in the document block, select the Open Document
button to view the document in a browser.

To delete a record’s attachment:
When you delete an attachment, you can:

• Remove the association between the record and the attached document

• Remove the attached document from the file system or database

1. In the Attachments window, select the document to delete.

2. Choose Delete from the Edit menu.

3. Select a button in the Decision window to remove either the Document and
Attachment or just the Attachment.

Defining Preferences with User Profile Options
Use profile options to modify the way your applications run.

Oracle E-Business Suite supports a set of user profile options that are common to all
applications. In addition, each application has its own set of user profile options. See
your application’s documentation for information on application-specific profile options.

Profile Hierarchy
Profile options can be set at four levels:

• Site - affects all applications installed at a site.

• Application - affects a specific application.

• Responsibility - affects the applications assigned to a specific responsibility.

• User - affects the applications run by a specific user.

A User-level setting overrides a Responsibility-level setting, which overrides an
Application-level setting, which overrides a Site-level setting.

Your system administrator sets options at all four levels. You can change options only
at the User level.

Setting Profile Options
Use the Profile Values window to display and change your user profile options.

Note: There are some profile options that you can view but not
change. For example, you can view the value for Concurrent:Request
Priority, which is set at the User level, but only your system
administrator can change its value.

If you do not set a user profile option, it assumes a default value set either by your
system or your system administrator.
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To set a profile option:
1. Navigate to the Profile Values window (navigation varies by application.)

• To view a specific profile, use Find or Query by Example.

The Profile Values window displays the Profile Name, Default Value, and
User Value.

2. Enter a value in the User Value field, or choose a value from the list of values, if
available. To accept the default setting, clear the User Value field.

Attention: Number and date values are not validated. Ensure that you
enter a valid number or date, or the associated profile option may
not work as you expect.

3. Choose Save from the File menu, or select the Save toolbar icon.

Note: Some profile option changes do not take effect until you change
responsibilities or restart your session.

Common Profile Options

Concurrent: Report Access Level
Determines access privileges to report output files and log files generated by a
concurrent request. Only a system administrator can set this option. Valid values are
"User" or "Responsibility".

Flexfields:Open Descr Window

Controls whether a descriptive flexfield window automatically opens when you navigate
to it. Valid values are "Yes" or "No".

FND: Indicator Colors

Valid values are "Yes", "No", or null (defaults to "Yes".) When this profile option is
set to "Yes":

• Required fields are displayed in yellow.

• Queryable fields are displayed in a different color while in enter-query mode.

• Read-only fields are rendered in dark gray.

Folders:Allow Customization

Determines whether you can personalize folders. Valid values are:

• "Yes" - you can create or customize folder definitions.

• "No" - you can open only existing folder definitions.

Only the system administrator can update this profile option.

Indicate Attachments

Turns off the indication of attachments when querying records (for performance). Only
the system administrator can update this option.

Forms-Based Applications 2-17



Java Color Scheme

When the Java Look and Feel profile option is set to "oracle", you can select from the
color scheme options to best enhance usability of the Forms-based interface.

Java Look and Feel

The Forms-based interface can be run with either the "Oracle look and feel" or the
"Generic look and feel." The Oracle look and feel provides a predefined set of color
schemes and display attributes. The Generic look and feel adheres to the interface and
color scheme of your operating system.

This option must be set to "oracle" to specify the Java Color Scheme.

Printer

Use this option to define your printer.

Sign-On:Notification

Valid values are "Yes" and "No". "Yes" displays a message at login that indicates:

• If any concurrent requests failed since your last session.

• How many times an incorrect password was used with your username since you
last logged on.

• If the default printer identified in your user profile is unregistered or not specified.

Viewer: Application for Text

If your system administrator has registered other applications for viewing text
output, select the application from the list of values. The option Viewer: Text must be set
to "Browser" to use this option.

Viewer: Text

Sets the display viewer for text report output. Valid values are "Browser" and "Report
Viewer".
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3
HTML-Based Applications

Using HTML-Based Applications
HTML-based applications use the following common components:

1. Process Train

2. Navigation Links

3. Date Picker

4. List of Values Icon

5. Global Buttons

Navigating
Navigate to functions in an HTML-based application using tabs, subtabs, and side
navigation elements. As you drill down through these elements, locator links display
your navigation path.

When you navigate through records in a table, use the Previous and Next links. When
you navigate through steps of a task, use the Back and Next buttons.
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Attention: Use these forward and backward navigation elements
provided by the application. Do not use your browser’s buttons.

Process Train
If you are executing a process, a process train shows the location of the current page in
the process. Some process trains are interactive. These allow you to jump one or more
steps backward in the process by selecting the step icon.

Locator Links
Locator links (sometimes called "breadcrumbs") are series of links and text that show
your navigation path through an application. Use the links to return to a previous
point in your navigation path.

Querying and Viewing Data
Pages that allow you to search for data display a Search panel that generally includes a
search region and a results region. Many search panels contain an Advanced Search
button that allows more detailed searches using additional criteria.

When you enter characters in a search field, a wildcard is implicitly added to the end
of the string.

The results region displays search results in a table. Columns that are sortable have a
highlighted heading. The currently-sorted column displays an arrow icon to indicate
whether the sort is ascending or descending.

Click the column heading of a sortable column to sort by that column. Click it again to
toggle between ascending and descending order.

Many pages allow you to save searches and personalize the display tables. See
Personalizations., page 3-5

Using a Hierarchical Grid (HGrid)
A Hierarchical Grid is a table that displays data in a hierarchical (tree) format. The
values in the table expand to display data.

1. Locator links define the position of the displayed grid in the navigation hierarchy.

2. Use the Hide/Show icon to expand and collapse the branches of the tree.

3. Use the Focus icon to display only a specific branch in the tree.
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Entering Data

Entering Data in a List of Values (LOV) Field
If you know the value for a field, enter it and press the Tab key. If you do not know the
value, choose the list of values icon to launch the Search and Select window. Enter a
partial value before launching the Search and Select window to limit the results. If the
partial value matches only a single value, the field autofills and the Search and Select
window does not launch.

Some Search and Select windows support alternate search criteria. Use the Search by
pulldown list to select a different search field. Enter the search string and select the Go
button. Select the value from the Results region and choose the Select button.

LOV Choice List
When a field has a long list of possible values from which a small subset is commonly
used, you may see an LOV choice list. The LOV choice list displays the most
commonly-used values for easier selection, and includes a More... option. Choosing
More... launches the LOV Search and Select window.

When you choose a value that is not in the LOV choice list, it is added to the list.

Personalizing an LOV Choice List
An LOV choice list may allow you to customize the list with the values that you use
most frequently.

To personalize an LOV choice list:
1. Select the Personalize button next to the LOV choice list to open the Personalize

window.

2. To add a value, select it and choose the Add button.

3. To delete a value, select the icon in the Delete column.

Note: Some values cannot be deleted.

4. To reorder the list, select the Reorder button. In the Reorder window, select a
value you want to move and use the Move icons to position in it in the list. When
finished, select the Apply button.

Entering Dates
Enter a date directly in a field using the format defined in your
Preferences. Alternatively, select the calendar icon to launch the Date Picker. When you
select a date, the window closes and inserts the date into the field.

Using Hot Keys
The following hot keys are supported in HTML-based applications. To perform the
action, press the Alt key + the key listed in the table:
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Action Key

Apply p

Back k

Cancel l

Continue c

Finish i

Next x

No n

Save s

Search r

Submit m

Yes y

Right Subtab >

Left Subtab <

Using Attachments
Use the Attachments feature to link text or other files to a record.

If the Attachments feature is available the page will display either the Attachment List
link or the Attachments icon.

The method to initiate an Attachments flow will vary, depending on how the feature
is implemented on your page.

To add a new attachment:
1. Display the Add Attachments page.

2. Using the Add poplist, select how you want to add the attachment.

From a Desktop File/Text/URL
1. Select a Category from the list of values. The Category defines the purpose of an

attachment, and controls which forms or pages can access it.

2. Select the attachment Type:

• File - specify a file name to upload. Enter the file location, or use the Browse
button to locate the file.

• URL - enter the URL for a Web page.

• Text - Enter text that is less than 2000 characters. If the text you want to
attach is more than 2000 characters, upload it in a file.
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From the Document Catalog
1. Use the Search regions to query existing documents.

2. Select the Document Name link to view a document before attaching it.

3. Select the document(s) to attach.

4. Select the Apply button.

Save your work in the application page from which you launched the attachments
flow. The attachments are not added until you save your work in the parent region.

To view an attached document:

In the Attachments page or Attachments table, select the File Name link.

• If the attachment is a URL, the Web page will launch.

• If the attachment is a file, a dialog box prompts you to open or save the file.

• If the attachment is text, the View Attachment page displays the text content.

To edit an attachment:
1. Display the Attachments page or Attachments table.

2. Select the Update icon.

3. In the Update Attachment page, edit only the information as it pertains to the
attachment. For example, you can update the URL for a Web page attachment, but
you cannot change it to a File attachment.

4. Select the Apply button.

5. Return to the application page from which you launched the attachments flow and
save your work. Attachment updates must be saved in the associated parent region.

To delete a record’s attachment:
1. In the Attachments page or Attachments table, select the Delete icon.

Personalizations
Some tables allow you to save queries and personalize the presentation of data. If a table
can be personalized, you see the Views panel or the Save Search button.

Note: Pages can have predefined personalizations available from the
View list. Some pages with no personalizations saved do not show the
Views panel until a search has been saved.

Personalizing Tables

To create a personalized view:
1. Use the search panel to query for results in the table.

2. Select the Save Search button or the Views button.

• The Save Search button launches the Create View page.
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• The Views button displays the Views panel. Select the Personalize button to
launch the Personalize Views page. This page displays existing views. Select
the Create View button to launch the Create View page.

3. On the Create View page, enter a View Name.

4. Specify the number of rows to display in the table.

5. Choose the Set as Default check box to make this view the default when you
navigate to this page.

6. Personalize other available options.

Note: Personalizable options vary by table. Some tables allow you
only to save the search criteria. Others allow you to change more
options, such as columns displayed, column order, sort order, and
headings.

7. Select the Apply button.

To duplicate, update, or delete a personalized view:
1. Select the Personalize button to launch the Personalize Views page.

2. Select the view from the list.

• Select Update to update the options for this view.

• Select Delete to delete the view.

• Select the Duplicate button to create a duplicate of the selected view. Enter a
new View Name. Make other modifications as desired and select Apply.
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