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Preface

Intended Audience
Welcome to Release 11i of the Oracle Complex Maintenance, Repair, and Overhaul
Implementation Guide.

See Related Documents on page viii for more Oracle Applications product information.

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services
within the United States of America 24 hours a day, seven days a week. For TTY support,
call 800.446.2398.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation accessible,
with good usability, to the disabled community. To that end, our documentation
includes features that make information available to users of assistive technology.
This documentation is available in HTML format, and contains markup to facilitate
access by the disabled community. Accessibility standards will continue to evolve over
time, and Oracle is actively engaged with other market-leading technology vendors to
address technical obstacles so that our documentation can be accessible to all of our
customers. For more information, visit the Oracle Accessibility Program Web site at
http://www.oracle.com/accessibility/ .

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an otherwise
empty line; however, some screen readers may not always read a line of text that consists
solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any
representations regarding the accessibility of these Web sites.

Structure
1 Oracle Complex Maintenance, Repair, and Overhaul Overview
2 Setting Up
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A Windows and Navigation Paths

Related Documents

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser,
database triggers, or any other tool to modify Oracle Applications data unless otherwise
instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and
maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus
to modify Oracle Applications data, you risk destroying the integrity of your data and
you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using an
Oracle Applications form can update many tables at once. But when you modify Oracle
Applications data using anything other than Oracle Applications, you may change a row
in one table without making corresponding changes in related tables. If your tables get
out of synchronization with each other, you risk retrieving erroneous information and
you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications
automatically checks that your changes are valid. Oracle Applications also keeps track of
who changes information. If you enter information into database tables using database
tools, you may store invalid information. You also lose the ability to track who has
changed your information because SQL*Plus and other database tools do not keep a
record of changes.

viii



1
Oracle Complex Maintenance, Repair, and

Overhaul Overview

This chapter covers the following topics:

• Overview

• Overview of Oracle Complex Maintenance, Repair, and Overhaul

• Oracle CMRO Module Overview

Overview
Oracle Complex Maintenance, Repair, and Overhaul (CMRO) enables
maintenance, repair and overhaul organizations that manage complex configurable
and regulated equipment systems, to define, plan and execute every aspect of their
maintenance operations such as configuration management, engineering, maintenance
planning, and execution. It provides maintenance organizations with the tools required
to increase asset turnover, improve response times, and increase service levels. Oracle
CMRO is a fully integrated component of Oracle’s 11i eBusiness suite.

This chapter includes the following topics:

• Overview of Oracle Complex Maintenance, Repair, and Overhaul, page 1-1

• Oracle CMRO Module Overview, page 1-3

Overview of Oracle Complex Maintenance, Repair, and Overhaul
Oracle Complex Maintenance, Repair, and Overhaul is designed to manage the entire
business process of defining, planning and executing the maintenance of complex
configurable and regulated equipment systems. Improved response times, increased
service levels, and faster asset turnaround times are critical to maintaining successful
long-term maintenance, repair, and overhaul (MRO) operations. Oracle CMRO offers
features such as maintenance-based inventory management, reliability centered
maintenance, a fully web-based architecture, and online access to repair documentation
that enable maintenance organizations to maximize efficiency and save costs. By
integrating every component of the maintenance, repair, and overhaul operation, Oracle
CMRO provides complete real-time visibility across the entire operation.

Oracle CMRO enables organizations to do the following:

• Maintain complex configurations

• Effectively plan enterprise-wide operations

Oracle Complex Maintenance, Repair, and Overhaul Overview 1-1



• Optimize maintenance execution

• Centrally manage all engineering data

Maintaining Complex Configurations
Organizations that build or maintain products with complex configurations need
to track configuration history. Oracle CMRO enables you to establish master
configurations. Requirements automatically flow to all units based on that master and
the history is updated every time changes are made to the configuration. You can
combine requirements with actual repair and usage results to provide unit-specific
maintenance and configuration history. With this configuration control, you can easily
track component history throughout the lifecycle. You can also classify units into smaller
groups based on common attributes.

Effectively planning Enterprise-wide operations
Maintenance frequency and scope continually change based on usage, new regulatory
requirements, and issues discovered during operation. Maintenance plans need to be
updated periodically to ensure high asset reliability and safety. Oracle CMRO enables
comprehensive fleet and unit-based maintenance planning and scheduling. You can
establish Fleet maintenance programs to create maintenance requirements and to
schedule maintenance activities. You can plan work across all locations to meet both
short-term and long-term requirements. By long term planning, you can optimize
capacity and resource utilization. Concurrently, you can make daily adjustments to
respond to changes based on recent activities.

Optimizing Maintenance Execution
Oracle CMRO enables you to streamline the execution process and simplify processes
such as creating work orders, deploying resources, and updating maintenance history
and configurations. Basic maintenance tasks associated with job creation and job
completion are automated to increase worker productivity and to minimize aircraft
downtime. You can capture results to ensure regulatory compliance and to guarantee
traceability. Maintenance history is updated as and when work is completed. You
can enter new service requests and work orders based on additional findings during
scheduled maintenance activities. Oracle CMRO enables component shipping to and
from third party maintenance providers. You can also charge costs associated with
maintenance activities throughout the repair cycle.

Centrally managing all Engineering data
Using Oracle CMRO, you can create, store, and manage data centrally. Oracle CMRO
enables companies to leverage electronic storage and delivery of technical documentation
for real-time access to accurate information and to ensure regulatory compliance. For
example, you can capture quality information from all sources (suppliers, original
equipment manufacturers, operators, third party maintenance providers) and store
it in this single location to ensure traceability. Oracle CMRO provides for route
management with reusable templates for individual operation instructions or a series of
operations and an integrated document index. By automatically updating all related
operations, these templates eliminate the need to perform system queries when
route information is changed. Automating these processes eliminates costly manual
labor, resulting in higher productivity and improved quality.
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Oracle CMRO Module Overview
Oracle Complex Maintenance, Repair, and Overhaul enables organizations to streamline
maintenance operations, meet the demands for transport and service, and improve
profitability. Oracle CMRO comprises the following ten modules:

Route Management
Using Route Management, you can maintain work cards in electronic form, so that they
are easily accessible. You can use these work cards to provide technicians with task
instructions and information on labor estimates, skill requirements, tools, parts, and
materials required by the job. You can also remove redundant tasks and processes by
storing each task card once in the database and then reusing it in multiple operations.

Document Index
Using Document Index, you can maintain references to paper documentation and
include links that technicians can use to access electronic documents, either in the
database or on the Web. You can keep all document references under version control to
simplify compliance with regulations. You can also link document references to part
types or individual serialized parts to eliminate searches, maintain lists of suppliers, and
automatically alert everyone on a distribution list when new documents or revisions
arrive.

Fleet Maintenance Program
You can use CMRO’s Fleet Maintenance Program to create maintenance requirements for
all planned and unplanned maintenance. You can associate work cards and maintenance
documents with maintenance requirements and define effectivity by associating these
maintenance requirements with a Master Configuration, Unit Configuration or a
Product Classification. To forecast maintenance due dates, you can designate intervals
and thresholds on maintenance requirements. The Affected Items Listing enables
maintenance personnel to view all units affected by a maintenance requirement.

Master Configuration
Using Master Configuration, you can record the as designed configuration of the
equipment that is maintained. This enables you to easily navigate through the
hierarchy, specify which parts can be used in the assembly, and provide technicians
with permissible part choices for each location. To enable technicians to easily access
the information that they need, you can link documents to part positions and work
cards. Master configurations can be used as templates for creating unit configurations.

Unit Configuration
You can use Unit Configuration to track the current as operated configuration of
the equipment and to maintain the life cycle service history of the system and all
the component parts, while considering the special conditions that affect service life
measurements. To enable easy access to information, you can record the positions in the
assembly where serialized parts are located and associate documents with them.
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Product Classification
The Product Classification module enables you to classify units into various groups for
maintenance activities and associate documentation and maintenance requirements to
these product classifications. The maintenance plans are automatically updated when
units move from one group into another.

Unit Maintenance Plan
The Unit Maintenance Plan module enables you to maintain utilization
forecasts, determine the remaining service time of units, and calculate due dates
for maintenance requirements. Material requirements associated with the forecasted
maintenance requirements are planned through Oracle Demand Planning application.

Visit Work Package
The Visit Work Package module enables you to create equipment-based maintenance
visit definitions that connect equipment with a block of tasks, location and date. You can
manage maintenance requirements, calculate costs incurred on a visit using the visit task
work breakdown structure, and define job hierarchy for all tasks in a visit.

Long Term Planning
The Long Term Planning module enables you to assess the maintenance workload
capacity for all facilities and define a maintenance visit’s resource requirements. You
can schedule maintenance visits across the organization based on resource and facility
availability, and compare resource capacities with resources required for the projected
workload. Material requirements associated with the maintenance requirements in a
visit are scheduled through Oracle’s Advanced Supply Chain Planning application.

Production
The Production module enables you to view job assignments, component and material
availability; record maintenance activities, job completion, material and component
consumption; and update maintenance compliance details. To satisfy regulatory
requirements, quality inspection results can be issued. You can initiate new service
requests for unplanned maintenance discovered during planned maintenance visits.

The Production module enables you to track all time and materials associated with jobs
throughout the repair cycle and interfaced to Oracle Costing, to provide maintenance
organizations with a real view into service costs.

Production Planning
The Production Planning module offers maintenance organizations an extensive
site-level planning tool. Production planners managing shop floor activities assign
personnel and equipment to jobs, fine tune work schedules, manage procurement
and create material requirements for unplanned maintenance. Using Production
planning, you can track components sent out for repair against the maintenance
visit. Planners and shop floor managers consider working conditions when planning
thereby ensuring a safe working environment.
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Outside Processing
Using Outside Processing (OSP) you can ship serialized parts to Independent Service
Organizations for service. Production planners assign jobs to third-party providers and
group jobs that are marked for outside servicing onto an Outside Processing Work
Order. The work order contains all the information required for executing the required
service. When the OSP Work Order is finalized, purchase orders and shipping orders
are created. After the work is completed, jobs are reassigned to internal personnel
for quality checks and parts receiving.
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2
Setting Up

Overview
This chapter discusses setting up Oracle Complex Maintenance, Repair and Overhaul
(CMRO). It includes the following topics:

• Getting Started, page 2-1

• Oracle CMRO Implementation Checklist, page 2-1

• Setting Up Oracle CMRO, page 2-5

• Setting Up Other Related Oracle Applications, page 2-5

• CMRO Specific Setups, page 2-78

Getting Started
Before setting up CMRO, you must identify all your implementation users, and the
access privileges they require. You can create additional implementation responsibilities
if you want to restrict access.

You must use the System Administrator responsibility to create the required Oracle
Applications user(s). Implementation users need access to one or more of the following
responsibilities:

• System Administrator

• AHL Super User

• Foundation Administrator

• Support Administrator

Use the Users window to define Oracle Applications users.Oracle Application user is
uniquely identified by an application user name.

For detailed instructions on creating application users, refer to Oracle Applications System
Administrator’s Guide.

Oracle CMRO Implementation Checklist
The following tables comprise a checklist of all the steps you need to follow to implement
Oracle Complex Maintenance, Repair & Overhaul. They include setup steps for data that
is shared with other Oracle Applications, but is required by Oracle CMRO.

You must set up other related Oracle applications prior to setting up CMRO.
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Setting Up an Organization, page 2-6

Description Reference

Step 1 - Set Up an Operating Unit

Step 2 - Create an Organization

Step 3 - Set Up an Inventory Organization

Release 11i Multi-Org Today; An Oracle White
Paper, December 2001

Oracle Human Resources User’s Guide

Setting Up Oracle Inventory, page 2-27

Description Reference

Step 1 - Set Up Master Items

Step 2 - Set Up Subinventory

Oracle Inventory User’s Guide

Setting Up Oracle Bills of Material (BOM), page 2-44

Description Reference

Step 1 - Set Up Departments and Resources Oracle Bills of Material User’s Guide

Setting Up Oracle Warehouse Management, page 2-47

Description Reference

Step 1 - Associate Departments with
Subinventories

Step 2 - Set Up Material Status

Step 3 - Associate Material Status with
Subinventories

Step 4 - Set up Profile Options

Oracle Warehouse Management User’s Guide

Setting Up Oracle Purchasing, page 2-51

Description Reference

Step 1 - Set Up Buyers

Step 2 - Set Up Approvals

Step 3 - Set Up Purchasing Options

Step 4 - Set Up Receiving Options

Step 5 - Set Up Financial Options

Step 6 - Set Up Open Accounting Periods

Oracle Purchasing User’s Guide
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Setting Up Oracle Advanced Planning and Scheduling, page 2-54

Description Reference

Step 1 - Setting up Oracle Advanced Supply
Chain Planning

Step 2 - Setting up Oracle Demand Planning

Step 3 - Setting up Available to Promise

Oracle Advanced Planning Implementation and
User’s Guide

Oracle Demand Planning Implementation and
User’s Guide

Oracle Global Order Promising Implementation
and User’s Guide

Setting Up Oracle Order Management, page 2-56

Description Reference

Step 1 - Set Up Security Processing Constraints

Step 2 - Set Up Customers

Oracle Order Management User’s Guide

Oracle Shipping Execution User’s Guide

Setting Up Oracle Project, page 2-57

Description Reference

Step 1 - Create Project Template

Step 2 - Assign Project Template Name to User
Profile

Oracle Projects User’s Guide

Setting Up Oracle Enterprise Asset Management, page 2-59

Description Reference

Step 1 - Set Up WIP Accounting Classes

Step 2 - Set Up EAM Parameters

Step 3 - Set Up Asset Category Code

Step 4 - Verify WIP_EAM_Activity_Priority
Lookup

Oracle Enterprise Asset Management User’s Guide

Setting Up Oracle Service, page 2-62

Description Reference

Step 1 - Define Service Request Status

Step 2 - Define Service Request Type

Step 3 - Define Service Request Severities

Step 4 - Set Up Profile Options

Oracle Customer Support Implementation Guide
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Setting Up Oracle Contracts, page 2-66

Description Reference

Step 1 - Set Up Buyer

Step 2 - Set Up Supplier

Step 3 - Set Up Standard Articles

Step 4 - Set Up Categories and Sources

Step 5 - Set Up Contract Groups

Step 6 - Set Up Contract Events

Oracle Contracts Core Concepts and Procedures
Guide

Setting Up Oracle Install Base, page 2-69

Description Reference

Step 1 - Set Up Install Parameters

Step 2 - Set Up Instance Statuses

Step 3 - Set Up Asset Locations

Oracle Install Base Implementation Guide

Setting Up Oracle Counters, page 2-70

Description Reference

Step 1 - Define Counter Groups Oracle Service Implementation Guide

Setting Up Oracle Quality, page 2-71

Description Reference

Step 1 - Set Up Route and Operation Quality
Plans

Step 2 - Set Up Deferral, MRB Disposition
Quality, Non-Routine Job Inspection and
Non-Routine Operation Inspection Plans

Step 3 - Create Counter Readings Quality Plan

Oracle Quality User’s Guide

Setting Up Oracle Content Manager, page 2-77

Description Reference

Step 1 - Setting up Interface Tables -
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Oracle Complex Maintenance, Repair, and Overhaul Standard Setup, page 2-78

Description Reference

Step 1 - Set Up Profile Options -

Oracle CMRO Approval Workflow Setup, page 2-84

Description Reference

Step 1 - Set Up Profile Options

Step 2 - Create Approval User(s) and Role

-

Oracle CMRO Module Setup, page 2-94

Description Reference

Step 1 - Set Up Document Index

Step 2 - Set Up Route Management

Step 3 - Set Up Master Configuration

Step 4 - Set Up Unit Configuration

Step 5 - Set Up Fleet Maintenance Program

Step 6 - Set Up Unit Maintenance Plan

Step 7 - Set Up Visit Work Package

Step 8 - Set Up Long Term Planning

Step 9 - Set Up Production

Step 10 - Administrative Setup

Setting Up Oracle CMRO
Setting Up Oracle CMRO includes the following sections:

• Setting Up Other Related Oracle Applications, page 2-5

• CMRO Specific Setups, page 2-78

Setting Up Other Related Oracle Applications
Oracle CMRO is integrated with other applications that are part of the Oracle E-Business
suite. This integration lends additional functionality to Oracle CMRO and enables
it to fully support the maintenance, repair and overhaul needs of Operators, Third
Party Maintainers, and Original Equipment Manufacturers. You must first set up
an Organization and then install and implement the related Oracle applications or
components.

This section covers the following topics:

• Setting Up an Organization, page 2-6

• Setting Up Oracle Inventory, page 2-27
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• Setting Up Oracle Bills of Material (BOM), page 2-44

• Setting Up Oracle Warehouse Management, page 2-47

• Setting Up Oracle Purchasing, page 2-51

• Setting Up Oracle Order Management, page 2-56

• Setting Up Oracle Project, page 2-57

• Setting Up Oracle Enterprise Asset Management, page 2-59

• Setting Up Oracle Service, page 2-62

• Setting Up Oracle Contracts, page 2-66

• Setting Up Oracle Install Base, page 2-69

• Setting Up Oracle Counters, page 2-70

• Setting Up Oracle Quality, page 2-71

• Setting Up Oracle Content Manager, page 2-77

Setting Up an Organization
In general, an organization can be a company, department, division, cost center, or
virtually any other organizational unit within a business. Organization Setup includes
the following steps:

• Setting Up an Operating Unit, page 2-6

• Creating an Organization, page 2-7

• Setting Up an Inventory Organization, page 2-8

Setting Up an Operating Unit

An Operating Unit is the organization unit, through which you create, process, report
on, and secure financial applications data.

To set up an Operating Unit, you must:

1. Develop an organization structure.

2. Define Set of Books.

3. Define locations.

4. Define Business Groups (optional).

5. Associate responsibilities with Business Group (optional).

6. Define Organizations.

7. Define Organization Relationships.

8. Define Responsibilities.

9. Set MO: Operating Unit profile option.

10. Convert to Multiorg Architecture (required only if current set up is not multiorg
enabled).

11. Verify Order Management System parameters.

12. Set Profile Options specific to Operating Unit.
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13. Define Inventory Organization security (optional).

14. Implement the application products.

Creating an Organization
To create an organization:

1. Select the Manufacturing and Distribution Manager responsibility. From the
Navigator, select Inventory > Setup > Organizations > Organizations. The Find
Organization window appears.

2. Select New (A).

3. Enter an organization Name.

4. Select the following values from the Organization Classification list of values:

• Business Group

• HR Organization

• GRE/Legal Entity

• MRP Organization

• Operating Unit

• Project Expenditure

• Project Manufacturing Organization

• Project Task Owning Organization
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Organization

5. Select the Enable check box for all the above parameters.

6. Save your work.

Organization Classifications

Business Group: The purpose of the Business Group is to partition human resource
information. The Business Group is the highest level in an organization structure
hierarchy in the E-Business Suite. You can use the Business Group to model the
consolidated enterprise or a major division of a company that is an employer.

HR Organization: The HR Organization classification is applied to the organizations to
which the user assigns employees.

Government Reporting Entities (GRE): The GRE in the Oracle Human Resources
products is the same organization as the Legal Entity that appears in the Oracle Financial
products. The GRE represents the real-world legal entity that pays employees, withholds
their taxes, and provides reports on various matters concerning them to government
agencies.

Setting Up an Inventory Organization

The Inventory Organization is an organization for which you track inventory
transactions and balances.
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To set up an Inventory Organization:

1. From the Navigator, select Inventory > Setup > Organizations > Organizations. The
Find Organization window appears.

2. Select New(A). The Organization window appears.

3. Enter an organization name in the Name field.

4. Within the Organization Classification block, select the following values from
the Name list of values (LOV):

• HR Organization

• Inventory

• MRP

• Project Expenditure

• Project Manufacturing Organization

• Project Task Owning Organization

• WIP Organization

Organization Window

5. Select the Enable check box for each of the above mentioned classification.

6. Save your work.
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7. As indicated below, set up the parameters for each of the above mentioned
Organization Classifications.

To set up HR Organization parameters:

1. In the Organizations window, select HR Organization. Click the Others button. The
Additional Organization Information window appears.

Additional Organization Information Window

2. Select Costing Information from the list. Enter a value in the Costing Information
field.

3. Save your work.

4. Navigate to the Additional Organization Information window and choose Parent
Organization from the list of values. Select Primary Reporting Hierarchy from the
Hierarchy LOV.

5. From the Name LOV, select the organization that you have defined and enabled
as a Business Group.

6. Save your work.
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Parent Organization Window

To set up Inventory Organization parameters:

1. Select Inventory Organization in the Organizations window. Click the Others
button. Choose Accounting Information from the list of values.

2. Click in the Accounting Information field. The Accounting Information descriptive
flexfields window opens.

3. Select the Set of Books, Legal entity and Operating Unit from their corresponding list
of values. Click OK.

4. Save your work.
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Accounting Information Window

5. Navigate to the Additional Organization Information window and select Inventory
Information from the list. The Organization Parameters window opens.

6. Select the Inventory Parameters tab. Enter an Organization Code.

7. Select the Item Master Organization and Calendar from their corresponding list of
values.

8. Select the EAM Enabled check box.

9. Save your work.
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Organization Parameters Window - Inventory Parameters

10. Select the Revision, Lot, Serial parameters tab. Enter the following information:

Field Value

Lot Control Uniqueness None

Lot Control Generation At Organization Level

Serial Control Uniqueness Within Inventory Items

Serial Control Generation At Item Level
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Organization Parameters Window - Revision, Lot, Serial Parameters

11. Save your work.

12. Select the Costing Tab. Select Average Costing from the Costing Method list of
values.

13. Select the Enable Project Cost Collection check box.

14. Enter the required information in the Valuable Accounts block.

15. Save your work.

2-14 Oracle Complex Maintenance, Repair, and Overhaul Implementation Guide



Organization Parameters Window - Costing Parameters

16. Click the ATP, Pick, Item-Sourcing parameters tab. Select an ATP Defaults Rule
from the Rule LOV.

17. Save your work.
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Organization Parameters Window - ATP, Pick, Item-Sourcing Parameters

To set up MRP Organization parameters:

1. In the Organization window, select MRP Organization. Click the Others button.

2. The Planning Parameters window opens. Select the Net WIP and Net Reservation
check box.

3. Save your work.
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Planning Parameters Window

To set up Work in Process (WIP) Organization parameters:

1. Select WIP Organization in the Organization window. Click the Others button.

2. Click the Backflush Defaults tab. Select Supply subinventory from the LOV. Enter a
Supply Locator (if required).
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Work In Process Parameters Window - Backflush Defaults Tab

3. Select the Move Transaction tab. Check the Allow Creation of New Operations and
the Allow Moves Over No Move Shop Floor Statuses check boxes.
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Work In Process Parameters Window - Move Transaction Tab

4. Select the Intra-operation tab. Enable the Queue Check Box. Disable other check
boxes.

5. Save your work.
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Work In Process Parameters Window - Intraoperation Tab

6. From the Navigator, select WIP > Setup > WIP Accounting Class.

7. Enter a Class and Description.

8. Select Standard Discrete from the Type drop-down list. Enter Accounts information.

9. Save your work.
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WIP Accounting Classes Window

10. Similarly, create Expense Non-Standard, Maintenance, and Asset Non-Standard
Accounting Classes. For more information about setting up Accounting classes, see
the Oracle Work in Process User’s Guide.

11. Save your work.

12. From the Navigator, select Inventory >Setup > Organizations > Organizations.Query
for your Organization.

13. Select WIP Organization within the Organization Classifications block. Click the
Others button.The Work in Process parameters window appears.

14. Select the Discrete tab. Choose a default Discrete Class from the Default Discrete
Class list of values.

15. Save your work.
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Work in Process Parameters Window - Discrete Tab

To set up Project Manufacturing parameters:

1. In the Organizations window, select Project Manufacturing Organization. Click the
Others button. The Project Manufacturing Parameters window opens.

2. Select the General tab. Check the Enable Project Reference check box.

3. Select Task from the Project Control Level drop-down list.
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Project Manufacturing Parameters Window - General Tab

4. Click the Invoice Transfer tab. Check the IPV check box to enable IPV.

5. Select Material from the Expenditure Type LOV.

6. Save your work.
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Project Manufacturing Parameters Window - Invoice Transfer Tab

To set up Project Task Owning Organization parameters:

1. In the Organizations window, select Project Task Owning Organization. Click the
Others button. The Additional Organization Information window opens.

2. Click in the Project Type Class Information field. In the Project Type Class
Information sub-window that opens, select Yes for all the following parameters:

• Allow Entry of Indirect Projects

• Allow Entry of Capital Projects

• Allow Entry of Contract Projects

3. Click Ok. Save your work.
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Project Type Class Information Window

To set up Project Expenditure/Event Organization parameters:

1. In the Organizations window, select Project Expenditure/Event Organization. Click
the Others button.

2. Click in the Exp Org Defaults field. The Exp Org Defaults sub-window appears.

3. Enter or select an Operating Unit (the same as the item master Organization).

4. Save your work.
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Exp Org Defaults Window

Additional Setup

From the Navigator, select Inventory > Accounting Close Cycle > Inventory Accounting
Periods.

Select an Inventory Accounting Period and change status to Open.

Save your work.
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Inventory Accounting Periods Window

See Also:

Release 11i Multi-Org Today; An Oracle White Paper, December 2001

Setting Up Oracle Inventory
In Oracle CMRO, you use instances of Oracle Inventory when defining the allowable
parts in a master configuration, and when describing the components in a unit
configuration. Oracle CMRO invokes Oracle Inventory methods to populate the
database with information on allowable components in a configuration, and the
components actually available to create a unit configuration. The Production module
uses predefined inventory items as reference when invoking the inventory methods that
issue and return parts, or when defining the material requirements for an organization
job. The route management module uses the predefined inventory items as material and
tool requirements used to perform a route or an operation.

Setting up Oracle Inventory includes the following steps:

• Creating Component Items

• Creating Service Items
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• Setting Up Subinventory

For every Inventory Organization, you must define Items and set up at least one
subinventory. Cost group and Locator should have been setup prior to setting up
subinventory.

To create Component Items

1. Select the Manufacturing and Distribution Manager responsibility. From the
Navigator, select Inventory > Items > Master Items.

Note: All items must be set up at the Master Inventory Organization
Level and then assigned to specific Inventory Organizations. Oracle
recommends that you define an Item Template for each type of item
that will be used in your organization.

2. Enter a name in the Item field.

3. Enter a description in the Description field.

4. Click the Main tab. Select Active from the Item Status drop-down menu.

Master Item Window - Main Tab

5. Click the Inventory tab. Select the following check boxes:

• Inventory Item

• Stockable

• Reservable
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• Transactable

6. For Lot and Lot Expiration, select No control from the Control drop-down menu.

7. Select Serial Control: At receipt (if the items are serial number trackable; otherwise
set it to non-serialized) from the Serial Generation drop-down menu.

8. Select No Control from the Locator Control drop-down menu.

Master Item Window - Inventory Tab

9. Click the Bills of Material tab. Select the BOM Allowed check box.
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Master Item Window - Bills of Material Tab

10. Click the Asset Management tab. Select Rebuildable from the Asset Item Type
drop- down menu.

2-30 Oracle Complex Maintenance, Repair, and Overhaul Implementation Guide



Master Item Window - Asset Management Tab

Note: You can select a value in the Asset Item Type field only if
Oracle Enterprise Asset Management(eAM) set up is complete. Set
up at least one item with Asset Group of Rebuildable in eAM.

11. Click the Costing tab. Select the following check boxes:

• Costing Enabled

• Inventory Asset Value

• Include in Rollup

12. Enter value for Cost of Goods Sold Account.
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Master Item Window - Costing Tab

13. Click the Purchasing tab. Select the following check boxes:

• Purchased

• Purchasable

• Allow Description Update

14. Under Invoice Matching, set Receipt Required to No.
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Master Item Window - Purchasing Tab

15. Click the Physical Attributes tab.

Note: When you enter values for Weight, Volume, and
Dimensions, you must select the Container check box to ensure that
the shipment flow works properly.

16. Click the General Planning tab. Select Min-Max from the Inventory Planning
Method drop-down menu.
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Master Item Window - General Planning Tab

17. Click the MSP/MRP Planning tab. Select MRP Planning from the Planning Method
drop-down menu.

18. Select Hard Pegging from the Pegging drop-down menu.
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Master Item WIndow - MSP/MRP Planning Tab

19. Click the Order Management tab. Select the following check boxes:

• Customer Ordered

• Internal Ordered

• Customer Orders Enabled

• Internal Orders Enabled

• Shippable

• OE Transactable

• Returnable
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Master Item Window - Order Management Tab

20. Click the Work in Process tab. Select the Build in WIP check box.

21. Select Supply Type of Push from the Supply Type drop-down menu.
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Master Item Window - Work in Process Tab

22. Click the Invoicing tab. Select the Invoiceable Item and Invoice Enabled check boxes.
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Master Item Window - Invoicing Tab

23. Click the Service tab. Select the Serviceable Product and Install Base Tracking
check boxes.

24. Save your work.

To set up Service Items

1. Set up Service Items with attributes as described below.
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Attribute Value

Item Status

Inventory Item

Stockable

Reservable

Purchased

Purchasable

Description Update

Receipt Required

OSP

Active

Disabled

Disabled

Disabled

Enabled

Enabled

Enabled

Yes

Disabled

Master Item - Purchasing Tab

2. Save your work.

To set up Subinventory

1. From the Navigator, select Inventory > Setup > Organization > Subinventories. The
Subinventories window appears.
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2. Define the Stores, MRB, and Consumable subinventories.

Note: Cost group and locators must be set up before defining
subinventories.

3. To define the Stores subinventory, type Stores in the Name field.

4. Select Active from the Status list of values.

5. Select the following check boxes:

• Quantity Tracked

• Asset Subinventory

• Include in ATP

• Allow Reservation

• Nettable

Subinventories Window (Stores Subinventory)

6. Select the Accounts tab and enter appropriate accounting values.
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Subinventories Window - Accounts Tab

7. Save your work.

8. Click the New icon to create a new subinventory. Type MRB in the Name field. Select
Active from the Status list of values.

Note: The status must be set to MRB Review. You must install Oracle
Warehouse Management (WMS) to use this status. You can set the
status to Active initially, install Warehouse Management, create
additional Transaction Types in WMS and then change subinventory
status to ’MRB Review’.

9. Select the following check boxes:

• Quantity Tracked

• Asset Subinventory

• Allow Reservation
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Subinventories Window (MRB Subinventory)

10. Select the Accounts tab and enter appropriate values. Save your work.

11. Click the New icon to create a new subinventory. Type Consumable in the Name
field. Select Active from the Status list of values.

12. Select the Quantity Tracked check box. Disable all other attributes.
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Subinventories Window (Consumable Subinventory)

13. Select the Accounts tab and enter appropriate accounting values. Save your work.

14. Define a new subinventory by clicking the New icon. Type Scrap in the Name
field. Select Unserviceable from the Status list of values. Select the Quantity Tracked
check box. Disable all other attributes.
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Subinventories Window (Scrap Subinventory)

15. Select the Accounts tab and enter appropriate accounting values. Save your work.

See Also:

Oracle Inventory User’s Guide

Setting Up Oracle Bills of Material (BOM)
Oracle CMRO uses the resources and departments that are set up in Oracle Bills of
Material as the basis for the production job resource requirements.

Before setting up Oracle Bills of Material, you must ensure that:

• Calendars and Exception templates are set up

• Employees have been set up

Setting up Oracle Bills of Material includes setting up departments and resources.

To set up Departments and Resources:

1. Select the Manufacturing and Distribution Manager responsibility. From the
Navigator, select Bills of Material > Setup > Department Classes
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2. Set up Department Classes. For Outside Processing purposes you must set up at
least one Department Class called Vendor.

Department Classes Window

3. To set up a department, navigate to Bills of Material > Routings > Department. The
Departments window appears.

4. Set up at least one Department that will be associated with the department class
Vendor (case sensitive). It is recommended that you set up a Department that the
users can easily identify as an outside department, for example, Outside Service
(OSV).

5. Associate all Departments with a location.
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Departments Window

6. Set up Resources and associate with Employees. To set up resources navigate to
Routings > Resources.

7. Define a resource of type Machine.
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Resources Window

Note: In the item master you must check ’Equipment’ flag (Physical
attributes) to see valid values.

8. Set up Standard Operations.

9. Save your work

Note: You must set up Departments and Resources at the operating
unit, as well as at the Inventory Organization level. Routes are set
up at the operating unit level. Visits (Visit Work Package - CMRO)
are set at the Inventory Organization level.

See Also:

Oracle Bills of Material User’s Guide

Setting Up Oracle Warehouse Management
Oracle Warehouse Management provides maintenance organizations, the functionality
to control their inventory by status/condition and associate subinventories with a
department. Before setting up Oracle Warehouse Management, you must ensure that:
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• Oracle Inventory setup is complete

• Supply subinventories are setup

• Departments have been set up in Oracle BOM

Setting up Oracle Warehouse Management includes:

• Associating departments with subinventories

• Defining Material status

• Associating material status with subinventories

• Setting up Profile Options

To associate departments with subinventories:

1. Change responsibility to Warehouse Management Super User. From the
Navigator, select Setup > Warehouse Configuration > Resources > Associate
Departments & Subinventories. The Department Subinventories window appears.

2. Select a department from the Department list of values and associate it with a
Subinventory.

3. Save your work.

Department Subinventories Window
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To set up Material Status:

1. Navigate to Setup > Transaction Setup > Inventory Transactions > Material
Status. The Material Status Definition window appears.

2. Set up the following statuses:

• MRB

• Unserviceable

• Serviceable

Material Status Definition Window

3. Save your work.

To associate Material Status with Subinventories:

1. Navigate to Setup > Warehouse Configuration > Warehouse > Subinventories. The
Subinventories Summary window appears.

2. Select a subinventory and associate a Material Status with it.
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Subinventories Summary Window

To set up Profile Options

1. Change responsibility to Application Developer. Navigate to Other > Profile. The
Personal Profile Values window appears.

2. Set up the Profile options as indicated in the table below.

Profile Name User Value

AHL: Material Status - Serviceable

AHL: Material Status - Unserviceable

AHL: MRB Material Status - MRB

Serviceable

Un-Serviceable

MRB
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Personal Profile Values Window

3. Save your work.

See Also:

Oracle Warehouse Management User’s Guide

Setting Up Oracle Purchasing
Before setting up Oracle Purchasing, you must ensure that:

• Oracle Inventory setup is complete

• Supply sub-inventories have been set up

• Oracle Human Resources setup is complete

To set up Oracle Purchasing:

1. Change responsibility to Manufacturing and Distribution Manager. From the
Navigator, select Purchasing.

2. Set up the following in Oracle Purchasing:

• Buyers

• Approvals
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• Purchasing Options

• Receiving Options

• Financial Options

• Open Accounting Periods

Approval Groups Window
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Buyers Window

Setting Up 2-53



Open Accounting Periods Window

3. Save your work.

See Also:

Oracle Purchasing User’s Guide

Setting Up Oracle Advanced Planning and Scheduling
Oracle Complex Maintenance, Repair, and Overhaul integrates with Oracle’s Advanced
Planning and Scheduling (APS) applications for supply chain management. Advanced
Supply Chain Planning (ASCP), is used to schedule required materials from maintenance
visits. Available to Promise (ATP), is used for material availability inquiries, as well as
scheduling through ASCP. Demand Planning (DP), is used for creating material demand
from three sources: global demand from forecasted requirements in Unit Maintenance
Plan; scheduled demand from requirements scheduled to maintenance visits; and
historical non -routine (and routine) demand from maintenance accomplished at specific
faculties. Additionally, Oracle APS’s Inventory Optimization (IO) application is required
for complete supply chain planning.

The sections below discuss the setups required:

For Advanced Supply Chain Planning
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• The APS applications employ a component architecture in which transaction
processing and planning can occur in separate database instances. The correct
instances to collect and query from must be defined. Collections from ASCP and
DP, and ATP queries from the CMRO instance must be directed to the correct
instance. For information, refer to Section 2 of the Oracle Advanced Planning
Implementation and User’s Guide.

• The user must create an ASCP plan to process the collected material
requirements. The applicable organizations, demand and supply schedules must be
defined. Additionally, the Include Sales Orders check box must be selected in the
Plan Options window. For information on defining plans, refer to Section 5 of the
Oracle Advanced Planning Implementation and User’s Guide.

Defining Plan Options - Plan Options window

For Demand Planning

• Demand planning collections must be setup. For information on setting up data
collections, refer to Section 2 of the Oracle Demand Planning Implementation and
User Guide.

• The correct application instance must be defined and the applicable organizations
for that instance must be enabled. All organizations, which will have CMRO
material requirements, must be checked.
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Defining Application Instances - Application Instances window

• Users must define a demand plan. To capture the data collected from CMRO, the
plan must include the following input parameters:

Material Requirements – Scheduled Visits (collections for all requirements in
a maintenance visit)

Material Requirements – Planned Maintenance (collections for all forecasted
requirements in Unit Maintenance Plan)

Material Usage History – Unplanned Maintenance (collections for all non- routine
requirements created during the production process, per organization)

Material Usage History – Planned Maintenance (an optional stream for all historical
planned requirements, essentially collections for Unit Maintenance Plan’s history)

For information on creating demand plans, refer to Section 7 of the Oracle Demand
Planning Implementation and User Guide.

For Available to Promise

The source and destination instance must be defined. For information, refer to Section 2
of the Oracle Global Order Promising Implementation and User’s Guide.

Setting Up Oracle Order Management
Before setting up Oracle Order Management (OM), you must ensure that:

• Oracle Inventory setup is complete

• Supply sub-inventories have been set up

• Oracle Purchasing setup is complete

Setting up Oracle Order management includes:

• Setting up Processing Constraints
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• Creating Customers

To set up Processing Constraints:

1. From the Manufacturing and Distribution Manager responsibility, navigate to Order
Management > Set Up > Rules > Security > Processing Constraints. The Processing
Constraints window appears.

2. Query for the Order Sales Credit entity using the Find icon.

3. In the Constraints field, disable Create, Update, Delete, and Cancel Operations.

4. Click the Applicable To tab. Select the Authorized Responsibilities Radio Button and
provide a list of Responsibilities that can perform the above listed actions.

5. Save your work.

6. Query for the Order Line entity.

7. Disable Create, Update, Delete, and Cancel operations for the same.

8. Click the Applicable To tab. Select the Authorized Responsibilities Radio Button
and provide a list of Responsibilities that can perform the above listed actions. Save
your work.

Note: Setting up Processing Constraints ensures that Order
Management users are not able to update Sales Orders created
within CMRO.

To define Customers:

1. Navigate to Customers > Standard. The Find/Enter Customers window opens.

2. Define your customers.

Note: For outside order processing, you must set up customers in
Order Management identical to the suppliers that you created in
Oracle Purchasing. You must do this step for only those suppliers
to whom you will be shipping out the parts for service. Oracle
recommends that you create customer names to be exactly the
same as your supplier name.

See Also:

Oracle Order Management User’s Guide

Setting Up Oracle Project
Oracle’s CMRO application uses Projects as part of its maintenance planning and
production flows. A project is created for each visit work package and project tasks are
created for each visit work package. The project tasks are used in the maintenance
planning flow to allow the required materials to be pegged to the corresponding visit
tasks through Oracle’s MRP application. A visit’s corresponding project is used in
the maintenance execution flow to collect costs associated to resource and material
transactions performed in CMRO’s Production module. Project Manufacturing’s
standard billing functionality can be used to generate the required reports for the
corresponding visit work packages.

Setting up Oracle Projects includes the following steps:
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• Creating a Project Template

• Assigning the Project Template name to an user profile

To create a Project Template:

1. Change responsibility to Project Super User. From the Navigator, select Setup >
Projects > Project Templates.

2. Click on New. Enter the required information.

3. Select the Template check box to classify the project as template.

4. Ensure that all Project Class Categories that are marked Required are included, else
you cannot approve Project Templates. Save the Project Template.

Note: This template should be created for the applicable inventory
master organization. All projects created for maintenance visits use
this project template.

5. The Project Status changes to Submitted. For more information about the creation
of project templates and the manner in which you use them to create projects and
submit for approval, refer to the Oracle Projects User’s Guide.

To assign the Project Template name to an user profile

1. Change responsibility to System Administrator. From the Navigator, select Profile >
System. The Find System profile Values window appears.

2. Find System Profile Value - AHL: Default Project Template ID.

3. Select the Project Template that you created from the Site LOV.

4. Save your work.

Note: You can change most of your user profile options; values
you enter in the User Value field overriding the values preset
by the System Administrator. A few profile options cannot be
changed, but are displayed for informational purposes only. To
change the User Profile options, from the Application Developer
Responsibility, navigate to Other > Profile. Enter the required values
in the Personal Profile Values window.

For for information on System profile options and the procedures for setting them
up, refer to the Oracle Applications System Administrator’s Guide.

Verifying/Updating the Project Created in the Visit Work Package(CMRO)

Each time the maintenance planner creates a project in Visit Work Package(CMRO), the
project’s parameters must be manually defined.

To verify/update the project created in the CMRO Visit Work Package:

1. Change responsibility to Manufacturing and Distribution Manager. From the
Navigator, select Project > Project Definitions > Project Parameters. The Project
Parameters window appears.

2. Enter the Visit Number in the Project Number field to search for the project created
in Visit Work Package.
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3. Verify the Organization name.It should be the same as the Visit Work Package
organization.

4. Optionally, change the Cost Group.

5. Optionally, change the Default WIP class.

6. Select the Invoice Transfer tab.Optionally, change the IPV.

7. Make other changes if required.

See Also:

Projects User Guide Release 11i

Setting Up Oracle Enterprise Asset Management
Oracle CMRO uses the same work order system as Oracle Enterprise Asset Management
(eAM). It also uses the Oracle eAM functionality to complete operations. Oracle CMRO
benefits from Oracle eAM’s enhanced integration with Oracle Costing.

Before setting up Oracle eAM, you must ensure that:

• Oracle Inventory setup is complete

• Oracle WIP setup is complete

• Oracle BOM setup is complete

• Oracle Purchasing setup is complete

To set up Oracle Enterprise Asset Management:

1. Change responsibility to Enterprise Asset Management.

2. Navigate to Setup > WIP > WIP Accounting Classes. Set up the following WIP
Accounting Classes:

• Standard

• Expense

• Maintenance

• Asset Non-Standard
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WIP Accounting Classes Window

3. Set up the eAM parameters.
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Enterprise Asset Management Parameters Window

4. Navigate to Setup > Category > Category Codes. Set up the Asset Category Code for
structure Asset Management.

5. To establish the Asset Category as the default category, navigate to Set up > Category
> Category Sets. The Category Sets window appears.

6. Query for Enterprise Asset Management in the Name field. Select the Category code
that you created from the Default Category list of values.

7. Save your work.

8. Navigate to Setup > Lookup. The Oracle Manufacturing Lookups window
appears. Query for WIP_EAM_ACTIVITY_PRIORITY lookup in the Type
field. Verify that the following values are setup:

Code Meaning

1 High

2 Medium

3 Low
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Oracle Manufacturing Lookups Window

See Also:

Oracle Enterprise Asset Management User Guide

Setting Up Oracle Service
Oracle Service provides Oracle CMRO with the functionality to create and update
service requirements in a maintenance organization. The association of a service request
to a visit task and production job allows the maintenance organization to track the
service difficulty (non-routine) to the associated progress or resolution performed
by the maintenance personnel.

Setting up Oracle Service includes:

• Verifying/ Defining Service Request Type, Status, and Severity

• Setting up the Profile Options

To verify/define Service Request Type, Status, and Severities:

1. Change responsibility to Customer Support. From the Navigator choose Setup >
Service Request > Request Status. The Service Request Statuses window appears.

2. You can define the following statuses:
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• New

• Open

• Working

• Assigned

• Closed

Service Request Statuses Window

3. Navigate to Setup > Service Request > Request Types. The Service Request Types
window appears.

Note: You define service Request Types to categorize your service
requests. For each service request type, you can set up related service
request statuses that correspond with each service request type

4. You can define the following Request Types:

• Pilot Log

• Cabin Log

• Mechanic Log
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• Inspection Log

• Technical Problem

Service Request Types Window

5. Navigate to Setup > Service Request > Request Severities. The Service Request
Severities window appears.

6. Select the Complex Maintenance check box.

7. Verify that the following Request Severities are defined:

• High

• Low

• Medium
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Service Request Severities Window

Select values in the Type, Status, and Severity fields, if they are different than the
default values. Default values in these fields are governed by the profiles setup. For
more information on profiles, see Setting Up Oracle Support Profiles in the Oracle
Support Implementation Guide.

You can override these defaults if necessary by changing the appropriate profile
options. For more information, see Setting Up Support Related Profile Options in
the Oracle Support Implementation Guide.

To set up the Profile Options:

1. Change responsibility to System Administrator. Navigate to Profile > System. The
Find System Profile Values window appears.

2. Find System profile value - AHL: Default SR Customer Name. Select the default
Customer Name from the Site LOV.

3. Save your work.

4. Find System profile value - AHL: Default SR Severity. Select the default Severity
Value from the Site LOV.

5. Find System profile value - AHL: Default SR Status. Select a default Status Value.

6. Find System profile value - AHL: Default SR Type. Select the default SR Type.
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7. Save your work.

System Profile Values Window

Note: You can change most of your user profile options; values you
enter in the User Value field override values preset by the System
Administrator. A few profile options are set for informational
purposes only, and cannot be changed.

See Also:

Oracle Customer Support Implementation Guide

Setting Up Oracle Contracts
CMRO’s Outside Processing module uses the Oracle Contracts’ functionality supporting
Loan and Borrow Transaction.

Before you set up Oracle Contracts, you must ensure that:

• Oracle Inventory setup is complete

• Oracle Receivables setup is complete

• Oracle Order Management setup is complete
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• Oracle Purchasing setup is complete

Setting up Oracle Contracts includes:

• Setting up Buyers

• Setting up Suppliers

• Other Setups

To set up Buyers:

1. From the Navigator, select Contract Manager > Setup > Others > Buyer > Buyer. The
Find Buyer window appears. Click the New Buyer button.

2. Select a Buyer Name from the list of values.

3. Enter other required data.

Buyers Window

Note: The buyers setup in Oracle Contract will be displayed in the
CMRO Select Buyer Name list for the user to select as the OSP Buyer.
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To set up Suppliers

1. Navigate to Contract Manager > Setup > Others > Supplier > Entry. The Suppliers
window appears.

2. Enter required information.

Suppliers Window

Note: These setup suppliers will be available in CMRO OSP Vendor
Name list for the user to select.

Other setups:

1. Navigate to Contract Manager > Setup > Contract. Verify the contract setup.

2. Set up Standard Articles and Categories and Sources.

3. Optionally, set up Customers.

4. Set up Contract Groups and Contract Events.

Note: To find the approver of the contracts, you must look at the profile
value: OKC: Contract Approver.

See Also:
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Oracle Contracts Core Concepts and Procedure Guide

Setting Up Oracle Install Base
After you define the master configuration, a framework exists that describes the general
characteristics of the system, including the engineering rules for assembly. The user can
then create a unit configuration. Oracle Complex uses the Installed Base’ methods to
populate the database with transactions representing the as operated configuration of
the system.

Before you set up Oracle Install Base, ensure that:

• Oracle Inventory setup is complete

• Oracle Counters setup is complete

• Supplier and supplier sites are set up (Purchasing)

• Customer and customer sites are set up (Receivables)

To set up Oracle Install Base:

1. Change responsibility to Oracle Installed BaseAdmin. Navigate to Setup > Install
Parameters.

2. Set up Install Parameters.

Installed Parameters Window
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3. Set up Instance Statuses.

Instance Statuses Window

4. Optionally, set up Maintain Locations.

5. Set up Asset Locations.

See Also:

Oracle Install Base Implementation Guide

Setting Up Oracle Counters

To set up Oracle Counters:

1. From the Navigator, select Field Service Manager > Field Service Set Up > Counters
> Define Counters.

2. Click the New button. Set up Counter Groups.
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Setup Counters Window

3. Associate the Counter Groups with the Install Base items.

4. Optionally, associate the Counter Groups with Maintain Locations.

See Also:

Oracle Service Implementation Guide

Setting Up Oracle Quality
Oracle CMRO uses the setup from Route Management and the system profile options
in Oracle Quality, to allow maintenance organizations to capture quality elements
for operations, jobs, deferrals, scrap management, and capturing counter value
snapshots. This gives maintenance facility the flexible integration required to maintain
reliable products.

Oracle CMRO provides seeded plan templates for routes, operations, job deferrals, MRB
dispositions and counter reading capturing. These templates can either be used as-is or
adjusted with additional quality elements, except the counter reading template which is
used by CMRO in the background and cannot be changed.

Setting up Oracle Quality includes:

• Setting-up Route and Operation Quality Plans

• Setting-up Job Deferral, MRB Disposition Quality, Non-Routine Job Inspection and
Non-Routine Operation Inspection Plans
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• Setting up Counter Readings Quality Plan

Setting Up Route and Operation Quality Plans
Creating Inspection Types:

You can create the different Inspection Types for route and/or operation quality
recording. The inspection types are maintained in a seeded collection element called
Inspection Type. Creating collection elements, collection element types and collection
plan types have no specific CMRO set up requirements.

To create Inspection Types

1. Change responsibility to Manufacturing and Distribution Manager. From the
Navigator, select Quality > Setup > Collection Elements. From the organization
list, select the Organization that you want to set-up the quality plan for. The
Collection Elements window appears.

2. Query for or find the Collection Element ‘Inspection Type’.

3. Click the Values button.

4. Define Inspection Types.

Collection Elements Window
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Note: The defined inspection types are the values that appear in the
list of values for the quality inspection type attribute in routes and
operations.

Creating Quality Plans

CMRO provides plan templates with seeded quality elements. Oracle recommends
that you use these templates and adjust them for the specific needs rather than
creating a plan from scratch, because the template contains collection elements that are
automatically populated by CMRO when quality is recorded in production. Should these
elements be missing, the procedure would still work, but these attributes would not be
recorded. The background attributes contain information about the job, maintenance
requirement, item and item instance etc., which allow for a convenient quality reporting
and analysis. The templates also contain seeded displayed items that are either
mandatory or optional. Those properties can be changed. This approach enables the user
to take full advantage of CMRO’s out-of-the-box quality functionality together with the
flexibility to create completely customized quality plans. Creating and using plan types
has no specific CMRO set up requirements.

To create Quality Plans:

1. Navigate to Quality > Setup > Collection Plans. The Collection Plans window opens.

2. Define the collection plan. Select the plan type.

3. Click the Copy Elements button. The Copy From Plan window appears.

4. Select the Plan template that you want to copy from. For CMRO, the options are:

• Advanced Service Online Operation Completion Plan

• Advanced Service Online Route Completion Plan
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Collection Plans Window

5. Click the Transactions button. The Collection Transaction window appears.

6. Select the seeded transaction for either route or operation. The options for CMRO are:

• Maintenance Route Completion (Advanced Service Online)

• Maintenance Operation Completion (Advanced Service Online)

7. Define the trigger. Select Inspection Type from the Trigger name list of values. The
trigger value is selected from the set-up in the Inspection Type collection element.

8. Save your work.
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Collection Transactions Window

Note: The Inspection Types created can be associated with a route or
operation in route management. When the route and/or operation is
going to be instantiated in production the user will have the derived
quality plan available for collecting the quality results.

Setting Up Job Deferral, MRB Disposition Quality, Non-Routine Job Inspection and Non-Routine
Operation Inspection Plans

Creating Inspection types

An Inspection Type for Deferral, MRB, Non-routine job and Non-routine operation is
defined in a system profile option. The Inspection Type will derive the existing plan
in the organization where a job is deferred in, an mrb disposition is initiated and/or a
non-routine job/operation is created. You can create the different inspection types for job
deferral, mrb disposition, and non-routine quality recording.

To create Inspection Types:

1. Navigate to the Collection Elements window. Query for the Collection Element
‘Inspection Type’.

2. Click the Values button. Define Inspection Types for Job Deferral, MRB
Disposition, and Non-Routine quality recording.
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Note: The defined inspection types appear in the list of values for
the system profile option for job deferral and mrb disposition.

To create Quality Plans:

1. Navigate to the Collection Plans window.

2. Define collection plans for Job deferral, MRB disposition and Non-Routine
job/operation using the following plan templates:

• Advanced Service Online MRB Disposition Plan

• Advanced Service Online Route Completion Plan

• Advanced Service Online Operation Completion Plan

• Advanced Service Online Job Deferral Plan

3. Add or change quality elements if necessary.

4. Click the Transactions button. Select the following seeded transaction descriptions
for job deferral, mrb disposition and non-routine job/operation:

• Maintenance Job Deferral (Advanced Service Online)

• MRB Disposition (Advanced Service Online)

• Maintenance Route Completion (Advanced Service Online)

• Maintenance Operation Completion (Advanced Service Online)

5. Define the trigger. Select Inspection Type from the Trigger name list of values. The
trigger value is selected from the set-up in the Inspection Type collection element.

6. Save your work.

System Profile Options Setup

Set up the following System Profile Options for Job Deferral, MRB disposition and
Non-Routine job/operation quality definition:

• AHL: Job Deferral Inspection Type

• AHL: MRB Disposition Inspection Type

• AHL: Non-routine Job Inspection Type

• AHL: Non-routine Operation Inspection Type

Setting Up Counter Readings Quality Plans

Whenever a maintenance requirement is completed in production, CMRO stores the
current counter values of the maintained item instance in a Counter Reading Quality
Plan. The plan will adjust itself based on the counters defined on the item instance. This
procedure is completely transparent to the end user. The user must create a Counter
Reading Quality Plan in quality and set up the system profile option to enable counter
reading capturing.

Creating Quality Plans

The Counter Readings Quality Plan is created using the template and cannot be
adjusted, since the end-user has no influence over the recording of the counter values.

Note: You need to create only one Counter Reading plan because the
same is used across all organizations.
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To create Quality Plans:

1. Navigate to the Collection Plans window. Define the collection plan.

2. Select the plan type from the Plan Type list of values.

3. Click the Copy Elements button. Select the following plan template: Advanced
Service Online Counter Readings Plan

Note: Do not adjust collection elements.

4. Do not define any Transactions.

System Profile Options Setup

For the Counter Reading Quality definition, set up System Profile Option -AHL: Counter
Reading Plan.

See Also:

Oracle Quality User’s Guide

Setting Up Oracle Content Manager
Oracle Content Manager integrates with Oracle CMRO to provide the user with the
capability to upload electronic files. The electronic file upload feature is used within the
Document Index module in Oracle CMRO.

To upload electronic files, you must ensure that the following tables are set up in Oracle
Content Manager:

ibc_content_types_b

Attribute Data

CONTENT_TYPE_CODE AHL_DOCUMENT

CONTENT_TYPE-STATUS ACTIVE

ibc_attribute_types_b

Attribute Data

ATTRIBUTE_TYPE_CODE DOCUMENT

CONTENT_TYPE_CODE AHL_DOCUMENT

DATA_TYPE_CODE ATTACHMENT

MIN_INSTANCES 1

UPDATEABLE_FLAG T

If the records are not present in ibc_content_types_b and ibc_attribute_types_b, then run
the ahlctype.ldt file. This will ensure that the records are inserted into the appropriate
tables.
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Note: To upload files, AHL_MEDIA_TYPE lookup must have the value
E-File. For more information, refer to the Document Index module setup.

CMRO Specific Setups
Oracle Complex Maintenance, Repair, and Overhaul is an integrated, web-enabled
software application suite designed to empower complex equipment maintenance
organizations. Oracle Complex Maintenance, Repair, and Overhaul supports
maintenance processes such as scheduled and unscheduled maintenance
visits, component monitoring, job scheduling and routing, labor time collection, cost
collection, inventory management, and maintenance document management. It provides
models for electromechanical systems and defines rules for assembling units. It also
records unit-specific information, allowing quick access to the maintenance history of
a product component.

Oracle Complex Maintenance, Repair, and Overhaul is organized as follows:

1. Engineering

• Fleet Maintenance Program (maintenance requirements)

• Route Management (work card authoring)

• Document Index (technical document management)

2. Configuration Management

• Master Configuration (allowable installations)

• Unit Configuration (as installed maintenance tracking)

• Product Classification (logical grouping)

3. Planning

• Unit Maintenance Plan (active maintenance requirements)

• Visit Work Package (work scope and resource)

• Long Term Plan (hangar and visit plan)

4. Execution

• Production

• Production Planning

• Outside Processing

This section includes the following:

• Oracle Complex Maintenance, Repair, and Overhaul Standard Setup, page 2-78

• Oracle CMRO Approval Workflow Setup, page 2-84

• Oracle CMRO Module Setup, page 2-94

Oracle Complex Maintenance, Repair, and Overhaul Standard Setup
CMRO Standard Setup involves assigning roles to AHL Super User, setting up advanced
properties and system profile options.

2-78 Oracle Complex Maintenance, Repair, and Overhaul Implementation Guide



To assign roles and set up advanced properties:

1. Login to JTF using the System Administrator responsibility. Click the Users link in
the Home page.

User Maintenance Page

2. Click User Maintenance. In the Users page, query for the user having AHL Super
User responsibility. Click Go. Click the user name to navigate to the User Details
page.
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User Details Page

3. Click Roles. The User-Role Mapping page appears. From the Available Roles
column, select the following roles and move them to the Assigned Roles column:

• AHL_ADMIN_ROLE

• AHL_OSP_ROLE

• AHL_USER_ROLE

• CSI_ADMIN_USER

• CSI_NORMAL_USER
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User-Role Mapping Page

4. To set up advanced properties, click the Settings secondary tab. Click the Settings
subtab. Click Advanced to navigate to the Advanced-Properties page.

Setting Up 2-81



Advanced-Properties Page

5. Select AHL from the View list. Click branding.default. Verify that the value is
Oracle Complex MRO.
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Verify Property - Advanced Properties Page

To set up the System Profile options:

1. From the Navigator, choose System Administrator. Navigate to the System Profile
Values window.

2. Set up the System Profile options as indicated in the table below.

System Profiles

Profile Site(Value) Descriptions

AHL: Application Usage
Mode

Complex Maintenance
Repair and Overhaul,
Depot Repair, Preventive
Maintenance

Set up the application usage
mode

AHL: Turn On Development
Debug

Yes/No Enable/disable debug
session

AHL: Turn on File Debug Yes/No

Note: The Fleet Maintenance Program and Route Management
modules enable users to define maintenance requirements
and routes for both CMRO and Preventive Maintenance
applications. Setting up the profile option AHL: Application Usage
Mode determines the user responsibility. Users can view only the
routes, maintenance requirements, or unit effectivities associated
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with the selected application usage mode. Users can also define
routes having the same number or maintenance requirements
having the same title across different application usage modes.

Oracle CMRO Approval Workflow Setup
You can set up an Approval Workflow to approve maintenance programs, activities
and routes. You can use the built-in Approval Workflow or you can create your own
workflow, define a specific approval rule and create a list of approvers for each CMRO
object. After setting up profile options, if you do not specify an approval rule, the
application uses the default approval rule.

CMRO Approval Workflow setup includes:

• Setting up Profile Options

• Creating Approval User(s) and Role(s)

Setting Up Profile Options

By default, Maintenance Programs, Activities and Routes are automatically approved
at the time of creation when you click the Approved button. To set up an Approval
process, you must set up the system profile options as indicated in the table below.

Profile Options

Profile Value Description

AHL: Enable approval
workflow for Routes

Yes This enables the approval
workflow for the routes

AHL: Enable approval
workflow for Maintenance
Requirement

Yes This enables the approval
workflow for maintenance
programs and activities

AHL: Workflow Loop Counter Requires a numeric value that
defines how many times the
notification will be re-sent if
the user does not respond

-

AHL: Workflow Timeout
Minutes

Requires a numeric value that
defines the period after which
a workflow times out when its
progress is halted.

-

Creating Approval User(s) and Role(s)

To activate the enabled workflow, you must set up employees in Oracle Human
Resources, create application users and define approval roles for these employees, and
create approval rules for the different CMRO objects.

Note: The following set up steps are depending on the use of the seeded
approval workflow. If you decide to create your own workflow you will
have to adjust these steps to the functionality of this workflow.
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Defining Approval Employees in Oracle Human Resources

All approval users need to be defined as employees in Oracle Human Resources.

Note: If you want to notify the approval user via e-mail, then in addition
to the application work list notification, you must also set up the e-mail
address for the employee in the Office Details window.

For more information on how to set up employees, refer to the Oracle Human Resources
Implementation guide.

Creating Application User for Approval Employees

Every approval employee needs to have an Oracle Application login. When defining
the application user you have to associate the approval employee, set up earlier in
HR, to that application user.

Creating Approval Roles

Associating the approval employees to a role is an optional step. If you have set up the
employees in Oracle HR and created application users for them, you can associate
the employee directly with an approval rule. You can set up the following two types
of approval roles:

Default Approval Role

CMRO provides a seeded default approval rule that is used when no object specific
approval rule is set up. The default approval rule is best used, when the same people
in the same hierarchy will approve every CMRO object. In this case you only have to
set up one rule with one approval sequence. The default approval rule has also one
approval hierarchy with a seeded role defined.

To set up the Role for the Default Approval Rule:

1. Login to the forms environment of Oracle Applications. Select the CRM Resource
Manager responsibility.

2. Navigate to Setup > Role Types.

3. Query for JTF_RS_ROLE_TYPE.

4. Create a role type code for the default approval role.
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Application Object Library Window - Role Type Lookups

5. Navigate to Setup > Roles.

6. Create a role with the code AHL_DEFAULT_APPROVER.

Note: The code must be defined as described above otherwise
the default rule will not recognize this role. The role name can
be user defined.

7. Associate the default approval role type code to this role.
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Roles Window

8. Create additional roles if you need more than one level of approvals. The role codes
can be user defined for every additional role used for the default approval rule.

Note: For CMRO approval, only one user can be associated with
a role, otherwise the approval workflow will fail. Therefore, you
must create as many roles as you have approvers. The sequence of
notification will be defined in the approval rule setup.

General Approval Role

Perform the following set up steps if you have specific approval rules for the different
CMRO objects:

1. Login to the forms environment of Oracle Applications. From the Navigator, select
CRM Resource Manager.

2. Navigate to Setup > Role Types.

3. Query for JTF_RS_ROLE_TYPE.

4. Create role type code(s) for the General Approval Role(s).
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Application object Library Window

Note: You can create multiple role type codes for grouping the roles
together but one is minimum.

5. Navigate to Setup > Roles. Create a role for every possible approver.

6. Associate the appropriate approval role type code to the roles.
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Roles Window

Importing resources

After you have created the employees and the roles, you must map the two together.

Note: As previously mentioned, only one employee can be assigned
as a workflow approver. However, the same employee can be the
designated approver for multiple roles.

To import resources:

1. From the CRM Resource Manager responsibility, navigate to Maintain Resources
> Import Resources.

2. Select the approval employee. Click the Search button.

3. Click Create Resource. Select the appropriate role.

4. Click OK. Click Save Resource.
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Selection Criterion Window

5. If you want to associate the same employee with an additional role click Details. Add
Roles.

6. Repeat steps 1 through 5 for every approval employee.

Creating Approval Rules in CMRO

As mentioned earlier you can either use the seeded default approval rule or specify an
object specific approval rule for the different CMRO objects. In the approval details you
can either pick a role that you have set up, or a user that has been created as an employee
in HR, and is associated with an application login. The sequence in the approval details
defines the approval hierarchy.

To adjust the Default Approval Rule:

1. Login to the jtf environment of CMRO.

2. Click on the Administration link. Click the Go button.

3. Click on the link ’Default AHL Rule’.

4. Add any additional roles or users to the approval details in the sequence you want
your objects to be approved.

Note: The first role is seeded. You can either change the hierarchy or
delete the seeded role if necessary.
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Update Approval Rule Page

5. Click Apply.

Note: Do not add any values to the operating unit
attribute. Custom values are currently not supported by Complex
Maintenance, Repair, and Overhaul and would cause the workflow
to fail. Also, you cannot change the status of the default rule once it
is set to Obsolete.

To define Object Specific Approval Rule

To define approval rules with specific approval hierarchy:

1. Login to the jtf environment of CMRO.

2. Click on the Administration link.

3. Click the Create button.

4. Enter the Approval Rule Name.

5. Select Application Usage as Complex Maintenance, Repair, and Overhaul.

6. Select the required value from the Approval Rule For list box.
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Create Approval Rule Page

7. Do not add any values to the operating unit attribute.Click Apply.

8. Add roles or users to the approval details in the sequence in which you want your
objects to be approved.

9. Select Active from the Status list of values.
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Edit Rule - Update Approval Rule Page

10. Click Apply.

Workflow Process Mapping

The final step in the approval workflow set up is to map the object with a workflow. As
previously mentioned, Oracle recommends that you use seeded workflow that is
delivered with CMRO, however a user-defined workflow can be mapped to the CMRO
object as well.

To map the workflow with the CMRO object:

1. Login to the jtf environment of CMRO.

2. Click on the Administration link.

3. Click the Workflow tab.

4. If you want to use the same workflow for all of your objects, leave the object field
empty, otherwise choose the object, which you want to add from the drop-down list.

5. Define the desired workflow in the Process Name field. The CMRO default
workflow is called ASO Generic Approval Process.
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Workflow Process Mapping Page

6. Select Complex Maintenance, Repair, and Overhaul from the Application Usage
drop-down list box.

7. Select Yes or No from the Active list box.

8. Click Apply.

The Approval Workflow

When a Maintenance Program, Activity or Route is sent for approval the user defined in
the approval role is notified by e-mail, if it has been setup at employee creation, and/or
with an entrance in the work list in Oracle Applications. From the notification, the user
can navigate to the notification details and approve the program, activity or route. The
workflow moves sequentially through all of the roles defined in the approval rules
details until the last user has sent his approval. At this point the status of the approved
object will be changed from ’Approval Pending’ to ’Complete’.

Oracle CMRO Module Setup
Oracle Complex Maintenance, Repair, and Overhaul enables maintenance organizations
to meet customer expectations, and draw maximum benefit by improving the
operational readiness of equipment.

Oracle CMRO Module setup includes:

• Setting Up Document Index, page 2-95

• Setting Up Route Management, page 2-96

• Setting Up Master Configuration, page 2-102
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• Setting Up Unit Configuration, page 2-103

• Setting Up Fleet Maintenance Program, page 2-105

• Setting Up Unit Maintenance Plan, page 2-107

• Setting Up Visit Work Package, page 2-109

• Setting Up Long Term Planning, page 2-111

• Setting Up Production, page 2-113

• Administrative Setup, page 2-116

Setting Up Document Index
The Document Index module in Oracle Complex Maintenance, Repair, and Overhaul is
the central repository for managing all maintenance documents.

Maintenance personnel can:

• Access an online catalog of documents used in maintenance, repair, and overhaul
operations

• Receive, distribute, and control revisions in technical documentation

• Search the database to quickly refer to a document

• Create new documents or document revisions

• Associate subtypes to document types for easy identification

• Upload electronic documents

Maintenance document management involves tracking documents and their
revisions, validating document references from multiple levels of maintenance
operations, and making them easily accessible to the maintenance personnel.

Setting up Document Index includes defining the lookup values as indicated below.

Note: Lookup codes fall within three categories: extensible, user
defined, and system defined. If a lookup code is extensible, the
existing lookup codes cannot be modified, but new codes can be
added to the table. If lookup codes are user defined, all codes can be
modified. If lookup codes are system defined, the existing codes cannot
be modified, and new codes cannot be added to the table.

To define lookups for Document Index:

1. Login using the Application Developer Responsibility.

2. Navigate to the lookups window and define the lookups as indicated in the
following table.
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Attribute Lookup Suggested Values Access Level

Operator AHL_OPERATOR_
TYPE

Operator,
Owner(User defined)

User

Document Type AHL_DOC_TYPE Aircraft, Engine
(User defined)

Extensible

Media Type AHL_MEDIA_TYPE E-File, CD-ROM, On-
line, Paper

Extensible

Status AHL_SUBSCRIBE_
STATUS_TYPE

Active, Not available User

Sub-Type AHL_DOC_SUB_TY
PE

Airworthiness
Directives, Service
Bulletin

User

Revision Type AHL_REVISION_TY
PE

Temporary Revision,
Full Revision

User

Frequency Type AHL_
FREQUENCY_TYPE

Quarterly, Weekly,
Yearly

User

Application Object Library Lookups Window

Setting Up Route Management
The Route Management module in Oracle Complex Maintenance, Repair, and Overhaul
provides a single interface for managing all maintenance tasks.

Maintenance personnel can:

• Prepare and maintain work instructions
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• Search the database for a specific operation for reference purposes, or for editing
purposes

• Create an operation or define instructions for carrying out a maintenance task

• Search for maintenance routes, for reference, or for editing route information

• Create a maintenance route

• Associate major and sub zones in a system to a product type to facilitate tracking of
maintenance operations on complex electromechanical systems

The intuitive user interface of Oracle Complex Maintenance, Repair, and Overhaul is
designed to enable maintenance personnel to handle operational needs as effortlessly
and quickly as possible.

Before setting up Route management, you must ensure that:

• ASO Resource is set up

• BOM Resource is set up

Setting up Route Management includes:

• Defining Lookup values

• Setting up Flexfields

To define lookups for Route Management:

1. Login using the Application Developer Responsibility.

2. Navigate to the lookups window and define the lookups as indicated in the
following table.

Attribute Lookup Suggested Values Access Level

Operation Type AHL_ROUTE_TYPE Aircraft, Engine,
Ground support

User

Major Zone AHL_ZONE Cargo Compartment,
Cockpit

User

Sub Zone AHL_SUB_ZONE AFT Fuselage, Cabin User

Status Type AHL_SUBSCRIBE_
STATUS_TYPE

Active, Available User

Sub-Type AHL_DOC_SUB_TY
PE

AD, SB User

Revision Type AHL_REVISION_TY
PE

Temporary, Full
Version

User

Process AHL_PROCESS_
CODE

Access, Cleaning,
Close

User
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Defining Lookup: AHL_PROCESS_CODE

To set up Flexfields:

Validate Existence of Route Flexfield

Note: To enable Route Management, you must set up a key flexfield
to define the System attribute.

1. Login into the forms environment with Application Developer Responsibility.

2. Navigate to Flexfield > Key > Segments.

3. Query for Flexfield Title ‘AHL Route’. Query should return the record.
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Key Flexfield Segments Window

Add segments to this flexfield

1. Click the Segments button.

2. Enter Records for System Flexfield Segment.
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Segments Summary Window

Create Value Sets to be used by Flexfield Segments

1. Click the Value Set button.

2. Define Value Set Name.

3. Define List Type as ‘List of Values’.

4. Define Security Type as ‘No Security’.

5. Define Format Type as ‘Char’.

6. Define Validation Type as ‘Independent’.
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Value Sets Window

7. Update Flexfield Segments with the Value Sets.

Create values for Value Sets

1. Navigate to Flexfield > Key > Values.

2. Find the Value Sets for the System Flexfield.
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Segment Values Window

3. Add the desired values to the value Set.

Setting Up Master Configuration
The Master Configuration module in Oracle CMRO provides models of
electromechanical system assemblies. A master configuration model will form the basis
of a unit in combination with business rules that specify the systems and subsystems
that may be included in the assembled unit.

Maintenance personnel can:

• Search the database for master configurations of electromechanical system
assemblies

• Create system assembly master configurations

• Search for alternate parts that may be used in place of specified components
in an assembly

Before setting up Master Configuration, you must ensure that:

• Inventory (Item Master) set up is complete

• Approval Workflow is set up (This step is optional if the user selects the default
approval workflow)

Setting up Master Configuration includes defining the lookup values as indicated below.

To define lookups for Master Configuration

1. Login using the Application Developer Responsibility.
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2. Navigate to the lookups window and define the lookups as indicated in the
following table.

Attribute Lookup Suggested Values Access Level

Rule code (Position
ratio list)

AHL_COUNTER_
RULE_TYPE

Bird Strike, Heavy
Landing

User

Alternate Part
Interchangeability
Type

AHL_
INTERCHANGE_
ITEM_TYPE

1-Way, 2-Way,
No Interchange,
Superseded By

Extensible

Position reference AHL_POSITION_
REFERENCE

Forward, Inboard

, Left, Lower,
Outboard, Position
1, Position 2, Position
3, Right, and Upper

User

Defining Lookup:AHL_CONfIG_STATUS

Setting Up Unit Configuration
The Unit Configuration module in Oracle Complex Maintenance, Repair, and Overhaul
enables organizations to describe the structure of an assembled electromechanical
system. The as-constructed configuration of an assembly will determine the specific
maintenance program required to ensure the operational readiness of that unit.

Maintenance personnel can:

• Initiate proper maintenance activities to resolve issues

• Create unit configurations from existing master configurations

• Search for unit configuration records that exist in the database

• Add new part information to the database
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• Search for, and update existing part information

The Unit Configuration module in Oracle CMRO is a key feature that enables
maintenance organizations to determine services required. Even if two units have
the same part number, or belong to the same product family, their configurations are
normally different due to the operation and maintenance history of each unit. Unit
Configuration provides models of individual tracked parts to support unit-specific
information.

Before setting up Unit Configuration, you must ensure that Master configuration is set
up and products are available for association at the unit level.

Setting up Unit Configuration includes setting up attributes as indicated below.

To set up attributes

1. Change responsibility to Oracle Install Base Admin.

2. From the Navigator, select Setups > Extended Attribute Template. The Extended
Attributes window appears.

3. Set up the attributes as indicated in the table below.

Extended Attributes Window

Attribute Code Attribute Name Description

AHL_MFG_DATE AHL_MFG_DATE AHL_MFG_DATE

AHL_TEMP_SERIAL_NUM AHL_TEMP_SERIAL_NUM AHL_TEMP_SERIAL_
NUM
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4. Save your work.

Setting Up Fleet Maintenance Program
The Fleet Maintenance Program module in Oracle CMRO enables maintenance
organizations to record, organize, and plan maintenance requirements. Maintenance
planners can create maintenance requirement records and attach attributes to these
records. The attributes attached to the record enables maintenance planning and
increased operational efficiency while accomplishing a requirement.

Maintenance planners can:

• Search the database for a specific maintenance requirement for reference, or for
editing purposes

• Create a maintenance requirement record in the database

• Attach documents, maintenance routes, actions, effectivities, and maintenance
requirement relationships to the record

• Create revisions for maintenance requirements that are complete

• View items that are affected by a maintenance requirement

The Oracle CMRO Fleet Maintenance Program module serves as a repository for
scheduled maintenance and associated information.

Before setting up Fleet Maintenance Program, you must ensure that:

• Lookup values are set up
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• System profile options are set up in Oracle Application: Profile system value

• Route Management is set up

• Product Classification is set up

• Master Configuration is set up

• Unit Configuration is set up

• Set up ASO Visit Work Package

Setting up Fleet Maintenance Program includes defining the lookup values as indicated
below.

To define lookups for Fleet Maintenance Program:

1. Login using the Application Developer Responsibility.

2. Navigate to the lookups window and query for the following
lookups. Optionally, you can add values to these lookups as required.

Attribute Lookup Suggested Values Access Level

Program Type AHL_FMP_MR_
PROGRAM_TYPE

Corrosion
Prevention,
Progressive
Maintenance,
Company Test, Phase
Check, etc.

Extensible

Category AHL_FMP_MR_
CATEGORY

Power plant,
airframe,
component, ground
equip., etc.

Extensible

Program Subtype AHL_FMP_MR_
PROGRAM_SUBTY
PE

A, B, C Extensible

Action AHL_FMP_MR_
ACTION

Email Test Results,
Reset Overhaul
Counter, Test

Extensible
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Defining Lookup:AHL_FMP_REVISION_STATUS

Setting Up Unit Maintenance Plan
The Unit Maintenance Plan module in Oracle Complex Maintenance, Repair, and
Overhaul ensures that all maintenance requirements are met on or prior to their due
date. It also provides demand estimates over a planning time window by forecasting
the due date of maintenance requirements associated with a unit. It searches and
displays maintenance requirements that are due for an equipment unit and provides
maintenance personnel instant access to maintenance requirements, due date
estimation, accomplishment history, and planning information for a unit configuration.

Maintenance personnel can:

• Maintain utilization forecasts

• View the serviceable time remaining of a unit

• Model repetitive maintenance requirements over a specified time period

• Calculate the due dates of maintenance requirements

• Associate maintenance requirements to a visit

Unit Maintenance Plan serves as a repository of the maintenance requirements related to
units and any related subassemblies or components. It also enables forecasting of usage
to determine due dates for fleet maintenance activities.

Before setting up Unit Maintenance Plan, you must ensure that:

• Look up value is set up in Oracle Application

• System profile is set up in Oracle Application: Profile system value

• Product Classification is set up

• Master Configuration is set up

• Unit Configuration is set up
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• Set up CMRO Visit Work Package

Setting up Unit Maintenance Plan includes:

• Setting up System Profile options

To set up the System Profile Options:

1. Login using the System Administrator responsibility. Navigate to the System Profile
Values window.

2. Set up the following System Profiles:

• AHL: Maximum Planning Window (Number)

• AHL: Maximum Planning Window (UOM)

System Profile Values Window

These profile options determine the period that is taken into account when calculating
the due date and repetitive MR in Unit Maintenance Plan. For example, the user may set
the following values for the profile options:

AHL: Maximum Planning Window (Number) = 2

AHL: Maximum Planning Window (UOM) = Years
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This means that the rolling planning windows in Unit Maintenance Plan (UMP) is two
years. The concurrent program used to calculate the due date and repetitive MR will
calculate all due dates within two years starting from calculation date (current date).

Concurrent Program Setup

Program: Building Unit Effectivities

Short Name: AHLUEFF

Application: Oracle Complex MRO

Description: Building Unit Effectivities

Setting Up Visit Work Package
The Visit Work Package module provides planning capabilities including
creation, organization, and scheduling of maintenance visits based on maintenance
requirements. It allows creation and management of visit templates based on equipment
types enabling efficient visit package creation for equipment units of a type. The Visit
Work Package permits association of tasks with visits and visit templates, and definition
of task hierarchy and cost structure.

Maintenance planners can:

• Create maintenance visit records, new, or from a template

• Search for, retrieve, and update existing visit records

• Associate tasks with visits: planned tasks, tasks that are required but not
scheduled, and ad hoc tasks that are not associated with maintenance routes

• Search for, retrieve, and update tasks associated with a visit

• Create visit templates, new, or from an existing visit record

• Search for, retrieve, and update existing visit templates

• Search for, retrieve, and update visit template tasks

• Create shift schedules for department workers based on planned visits

• Search for and retrieve existing department shifts

Visit Work Package enables maintenance planners to organize a maintenance visit
execution for an equipment unit.

Before setting up Visit Work Package (VWP), you must:

• Verify Projects (VWP exports visit objects to Oracle Projects)

• Verify HRMS (VWP uses HR’s organization information)

• Verify Installed base (VWP uses IB’s item instance information about maintainable
assets)

• Verify Inventory (VWP uses Inventory’s information to describe maintainable
asset types)

• Verify Support (VWP associates Service Requests with maintenance visit tasks)

• Verify Unit Maintenance Plan (associates UMP MR to VWP)

• Verify Fleet Maintenance Program
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• Create Project Template

Setting up Visit Work Package includes:

• Setting up System Profile Options

• Defining lookups

To set up System Profile Options:

1. Login using the System Administrator responsibility. Navigate to the System Profile
Values window.

2. Set up System Profile Option:

AHL: Default Project Template ID (Name of the Project template that will be used as
default)

System Profile Value - AHL: Default Project Template

To define lookups for Visit Work Package:

1. Change responsibility to Application Developer.

2. Navigate to the lookups window and define the lookups as indicated in the
following table.
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Attribute Lookup Suggested Values Access Level

Visit Type AHL_PLANNING_
VISIT_TYPE

A-Check, B-Check,
C-Check

User

Category AHL_LTP_SPACE_
CATEGORY

Category 1, Category
2…

Extensible

Hour List AHL_VWP_HOURS 00, 01… User

Defining Lookup: AHL_VWP_VISIT_STATUS

Setting Up Long Term Planning
The Long Term Planning module is used by a maintenance planner to plan maintenance
requirements for visits based on the optimal use of maintenance resources. Maintenance
planners using Long Term Plan make a complete assessment of the resources available at
all maintenance locations. The planner can schedule maintenance visits, assess capacity
and reserve required materials.

Maintenance personnel can:

• Assess Maintenance Workload Capacity by analysis of available labor by skill, level
and certification, available tools, materials, and location capabilities balanced against
known workloads

• Create a Visit in order to group events together for long and short term capacity
planning, and to facilitate scheduling to a maintenance base

• Define a Visit’s Resource Requirements to allow accurate scheduling and capacity
planning

• Analyze capacity versus work load requirements
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• Run simulations in order to evaluate different scheduling scenarios before
implementing actual plan changes

Long Term Plan maximizes maintenance scheduling by balancing maintenance
requirements with available maintenance capacity. The maintenance planner is able
to do this by balancing forecasted maintenance requirement information from Unit
Maintenance Plan against projected maintenance capacity.

Setting up Long Term Planning includes defining the lookup values as indicated below.

To define lookups for Long Term Planning

1. Login using the Application Developer Responsibility.

2. Navigate to the lookups window and define the lookups as indicated in the
following table.

Attribute Lookup Suggested Values Access Level

Category AHL_LTP_SPACE_
CATEGORY

Category 1, Category
2…

Extensible

Display Only AHL_LTP_VISITS_D
ISPLAY_ONLY

Scheduled,
Unscheduled

Extensible

Status AHL_LTP_SPACE_
STATUS

Inactive, Active Extensible

Visit Type AHL_PLANNING_
VISIT_TYPE

A-Check, B-Check,
C-Check

User

Defining Lookup: AHL_LTO_SPACE_CATEGORY
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Setting Up Production
The Production module enables the execution of routine and non-routine tasks and
associated with a Visit. It also supports the execution of tasks against an Install Base
Tracked Item.

Maintenance personnel can:

• Search for Routine and Non-Routine Jobs using filtered search elements

• Create Jobs from visit tasks for Scheduled, Unscheduled, and Convenience
maintenance

• Create Service Requests to track reported problems when an item has a service
difficulty

• Create Operations to Non-Routine Jobs for work definition and tracking

• Maintain jobs by adjusting the schedule, the status, completing, deferring, and
selecting the actual start and end for a job

• Maintain operations by updating the operations, adding, removing, or updating
the material and resource requirements

• Maintain Quality using Route setup from Route Management for Job and Operation
compliance

Maintenance schedulers can create jobs, initiate service for material and parts change
transactions, and perform job operation maintenance.

Setting up Production includes:

• Setting up System Profile Options

• Defining Lookups

To set up System Profile Options:

1. Login using the System Administrator responsibility. Navigate to the System Profile
Values window.

2. Set up System Profile Options as described in the table below.
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Profile Site(Value) Description

AHL: Job Deferral Inspection
Type

Deferral Approval The Quality plan inspection
type used for Production Job
deferrals

AHL: MRB Disposition
Inspection

MRB Approval Required The Quality plan inspection
type used when a tracked
item is returned an MRB
subinventory

AHL: Material Status - MRB Active/Non-Active The status that triggers
the Quality inspection
requirement for MRBand
a service request creation,
when an tracked item
is being returned inthe
condition associated with
this status to a subinventory
with the status associated

AHL: Material Status
- Serviceable

Active The status indicating a
serviceable item. This
status is used toensure that
installed items meet the
condition associated with
this status and are issued
from a subinventory with
this status associated

AHL: Material Status
- Unserviceable

Active The status that triggers the
Service Request creation,
when a tracked item is being
returned in the condition
associated with this status
to a subinventory with the
status associated

AHL: Non-routine Operation
Inspection

- Used to determine if non-
routine operation required
inspection

AHL: OE Mixed Order Type
ID

P -Mixed Order type to create a OSP
order

AHL: OE Return Line ID P- Return Line type to create a OSP
order

AHL: OE Ship Only Line
Type ID

P- Standard Line type to create a OSP
standard only ship line

AHL: Validate Alternate
Items

Yes/No Enabled/disable
organization validation
on alternate items for UC
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System Profile Values

To define lookups for Production:

1. Change responsibility to Application Developer.

2. Navigate to the lookups window and define the lookups as indicated in the
following table.

Attribute Lookup Suggested Values Access Level

Display Only AHL_LTP_VISITS_D
ISPLAY_ONLY

Scheduled,
Unscheduled

Extensible

Status AHL_LTP_SPACE_
STATUS

Inactive, Active Extensible

Visit Type AHL_PLANNING_
VISIT_TYPE

A-Check, B-Check,
C-Check

User
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Defining Lookup:AHL_JOB_STATUS

Administrative Setup
Through the Administration link, you can manage administrative functions related to
the Visit Work Package and Long Term Planning modules.

Users can:

• Create department shifts

• Define maintenance spaces and determine space unavailability

Department shifts are created to define the working hours of a maintenance
department. These shifts are used to calculate the start time of the tasks in a scheduled
visit.

To set up department shifts:

1. From the Manufacturing and Distribution Manager responsibility, navigate to
Oracle Bills of Material >Setup > Calendars. The Workday Calendar window
appears. Define a BOM calendar.
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Workday Calendar window

2. Click Shifts to define shifts for the calendar.

Defining shifts for the calendar - Shifts window

3. Click Workday Pattern to navigate to the Shift Workday Patterns window. Enter the
workdays for the shift.
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Defining Workday Patterns - Shift Workday Patterns window

The Calendar, Shift Number and Workdays defined will be available for selection in
the corresponding list of values when creating department shifts in the Oracle CMRO
application. For information on creating department shift records, refer to the Oracle
Complex Maintenance, Repair, and Overhaul User’s Guide.
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A
Windows and Navigation Paths

This appendix covers the following topics:

• Windows and Navigation Paths

• Default Navigation Paths for Standard Application Windows

Windows and Navigation Paths
This appendix provides the default navigator paths for the windows used in the Oracle
Complex Maintenance, Repair, and Overhaul(CMRO). The following table provides the
default navigation paths. Brackets [ ] indicate a button.

Default Navigation Paths for Standard Application Windows

Window Name Navigation Path

Accounting Information Manufacturing and Distribution Manager:
Inventory > Setup > Organizations >
Inventory Organization > Others > Accounting
Information

Additional Organization Information Manufacturing and Distribution Manager:
Inventory > Setup > Organizations >
Organizations > HR Organization > Others

Application Object Library Lookups Application Developer: Application > Lookups
> Application Object Library

Application Object Library: JTF_RS_ROLE_TY
PE Lookups

CRM Resource Manager: Setup > Role Types

Approval Groups Manufacturing and Distribution Manager:
Purchasing > Setup > Approvals > Approval
Groups

Buyers Manufacturing and Distribution Manager:
Purchasing > Setup > Personnel > Buyers

Category Sets Enterprise Asset Management: Set up >
Category > Category Sets
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Window Name Navigation Path

Collection Elements Manufacturing and Distribution Manager:
Quality > Setup > Collection Elements

Collection Plans Manufacturing and Distribution Manager:
Quality > Setup > Collection Plans

Department Classes Manufacturing and Distribution Manager: Bill
of Materials > Setup > Department Classes

Department Subinventories Warehouse Manager Mgmt Super User: Setup
> Warehouse Configuration > Resources >
Associate Departments & Subinventories

Departments Manufacturing and Distribution Manager: Bill
of Materials > Routings > Department

Enterprise Asset Managment Parameters Enterprise Asset Management: Setup >
Parameters

Exp Org Defaults Manufacturing and Distribution Manager:
Inventory > Setup > Organizations > Project
Expenditure/Event Organization > Others

Find Buyer Contract Manager: Setup > Others > Buyer >
Buyer

Find Categories Enterprise Asset Management: Set up >
Category > Category Codes

Find Organization window Manufacturing and Distribution Manager:
Inventory > Setup > Organizations >
Organizations

Find System Profile Values System Administrator > Profile > System

Find/Enter Customers Manufacturing and Distribution Manager:
Order Management: Customers > Standard

Installed Parameters Oracle Installed BaseAdmin > Setup > Install
Parameters

Instance Statuses Oracle Installed BaseAdmin > Setup > Instance
Statuses

Inventory Accounting Periods Manufacturing and Distribution Manager:
Inventory > Accounting Close Cycle >
Inventory Accounting Periods

Key Flexfields Segments Application Developer: Flexfield > Key >
Segments

Master Item Manufacturing and Distribution Manager:
Inventory > Items > Master Items
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Window Name Navigation Path

Material Status Definition Warehouse Manager Mgmt Super User: Setup
> Transaction Setup > Inventory Transactions
> Material Status

Open and Close Periods Manufacturing and Distribution Manager:
Purchasing > Financial > Accounting > Open
and close periods

Oracle Manufacturing Lookups Enterprise Asset Management: Setup >
Lookup

Organization Parameters Manufacturing and Distribution Manager:
Inventory > Setup > Organizations > Inventory
Organization > Others > Inventory Information

Parent Organization Manufacturing and Distribution Manager:
Inventory > Setup > Organizations >
Organizations > HR Organization > Others >
Parent organization

Personal Profile Values Application Developer > Other > Profile

Processing Constraints Manufacturing and Distribution Manager:
Order Management > Set Up > Rules > Security
> Processing Constraints

Project Manufacturing Parameters Manufacturing and Distribution Manager:
Inventory > Setup > Organizations > Project
Manufacturing Organization > Others

Project Parameters Manufacturing and Distribution Manager:
Project > Project Definitions > Project
Parameters

Project Type Class Information Manufacturing and Distribution Manager:
Inventory > Setup > Organizations > Project
Task Owning Organization > Others > Project
Type Class Information

Resources Manufacturing and Distribution Manager: Bill
of Materials > Routings > Resources

Roles CRM Resource Manager: Setup > Roles

Search Approval Rules Advanced Service Online User: Administration
> Approvals

Segment Values Application Developer: Flexfield > Key >
Values

Selection Criterion CRM Resource Manager: Maintain Resources
> Import Resources

Service Request Severities Customer Support: Setup > Service Request >
Request Severities
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Window Name Navigation Path

Service Request Statuses Customer Support: Setup > Service Request
> Request Status

Service Request Types Customer Support: Setup > Service Request
> Request Types

Setup Counters Field Service Manager : Field Service Set Up >
Counters > Define Counters

Subinventories Manufacturing and Distribution Manager:
Inventory > Setup > Organization >
Subinventories

Subinventories Summary Warehouse Manager Mgmt Super User: Setup
> Warehouse Configuration > Warehouse >
Subinventories

Suppliers Contract Manager: Setup > Others > Supplier
> Entry

WIP Accounting Classes Enterprise Asset Management: Setup > WIP >
WIP Accounting Classes

WIP Accounting Classes Manufacturing and Distribution Manager: WIP
> Setup > WIP Accounting Class

Work in Process Parameters Manufacturing and Distribution Manager:
Inventory > Setup > Organizations > WIP
Organization > Others

Workflow Process Mapping Advanced Service Online User: Administration
> Workflow
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