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Preface

Intended Audience
Welcome to Release 11i of the Oracle Human Resources Management Systems FastFormula
User Guide.

This guide assumes you have a working knowledge of the following:

• The principles and customary practices of your business area.

• Oracle HRMS.

If you have never used Oracle HRMS, Oracle suggests you attend one or more of the
Oracle HRMS training classes available through Oracle University

• Oracle Self-Service Web Applications.

To learn more about Oracle Self-Service Web Applications, read the Oracle Self-Service
Web Applications Implementation Manual.

• The Oracle Applications graphical user interface.

To learn more about the Oracle Applications graphical user interface, read the
Oracle Applications User’s Guide.

See Related Documents for more information about Oracle Applications product
information.

See Related Documents on page x for more Oracle Applications product information.

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services
within the United States of America 24 hours a day, seven days a week. For TTY support,
call 800.446.2398.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation accessible,
with good usability, to the disabled community. To that end, our documentation
includes features that make information available to users of assistive technology. This
documentation is available in HTML format, and contains markup to facilitate access by
the disabled community. Accessibility standards will continue to evolve over time, and
Oracle is actively engaged with other market-leading technology vendors to address
technical obstacles so that our documentation can be accessible to all of our customers.
For more information, visit the Oracle Accessibility Program Web site at
http://www.oracle.com/accessibility/ .
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Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an otherwise
empty line; however, some screen readers may not always read a line of text that consists
solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any
representations regarding the accessibility of these Web sites.

Structure
1 FastFormula
A Windows and their Navigation Paths

This section lists the default navigation paths for all the windows in Oracle HRMS as
they are supplied. You can use task flow windows directly from the menu, or from
the People and Assignment windows.

B Reports and Processes in Oracle HRMS

This section shows the default reports and processes in Oracle HRMS as they are
supplied. The responsibility that you use determines which reports you can use and
how you access them.

HRMS Glossary

Related Documents
Oracle HRMS shares business and setup information with other Oracle Applications
products. Therefore, you may want to refer to other user guides when you set up
and use Oracle HRMS.

You can read the guides online by choosing Library from the expandable menu on your
HTML help window, by reading from the Oracle Applications Document Library CD
included in your media pack, or by using a Web browser with a URL that your system
administrator provides.

If you require printed guides, you can purchase them from the Oracle store at
http://oraclestore.oracle.com.

Guides Related to All Products

Oracle Applications User’s Guide

This guide explains how to enter data, query, run reports, and navigate using the
graphical user interface (GUI). This guide also includes information on setting user
profiles, as well as running and reviewing reports and concurrent processes.

You can access this user’s guide online by choosing ”Getting started with Oracle
Applications” from any Oracle Applications help file.

Guides Related to This Product

OA Personalization Framework and OA Extensibility Framework

Learn about the capabilities of the 5.6 Framework technologies.
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Oracle Human Resources Management Systems Enterprise and Workforce Management
Guide

Learn how to use Oracle HRMS to represent your enterprise. This includes setting up
your organization hierarchy, recording details about jobs and positions within your
enterprise, defining person types to represent your workforce, and also how to manage
your budgets and costs.

Oracle Human Resources Management Systems Workforce Sourcing, Deployment,
and Talent Management Guide

Learn how to use Oracle HRMS to represent your workforce. This includes recruiting
new workers, developing their careers, managing contingent workers, and reporting on
your workforce.

Oracle Human Resources Management Systems Payroll Processing Management Guide

Learn about wage attachments, taxes and social insurance, the payroll run, and other
processes.

Oracle Human Resources Management Systems Compensation and Benefits
Management Guide

Learn how to use Oracle HRMS to manage your total compensation package. For
example, read how to administer salaries and benefits, set up automated grade/step
progression, and allocate salary budgets. You can also learn about setting up earnings
and deductions for payroll processing, managing leave and absences, and reporting
on compensation across your enterprise.

Oracle Human Resources Management Systems Configuring, Reporting, and System
Administration in Oracle HRMS

Learn about extending and configuring Oracle HRMS, managing
security, auditing, information access, and letter generation.

Oracle Human Resources Management Systems Implementation Guide

Learn about the setup procedures you need to carry out in order to successfully
implement Oracle HRMS in your enterprise.

Oracle Human Resources Management Systems FastFormula User Guide

Learn about the different uses of Oracle FastFormula, and understand the rules and
techniques you should employ when defining and amending formulas for use with
Oracle applications.

Oracle Human Resources Management Systems Deploy Self-Service Capability Guide

Set up and use self-service human resources (SSHR) functions for managers, HR
Professionals, and employees.

Oracle Human Resources Management Systems Deploy Strategic Reporting (HRMSi)

Implement and administer Oracle Human Resources Management Systems Intelligence
(HRMSi) in your environment.

Oracle Human Resources Management Systems Strategic Reporting (HRMSi) User Guide

Learn about the workforce intelligence reports included in the HRMSi product, including
Daily Business Intelligence reports, Discoverer workbooks, and Performance
Management Framework reports.

Implementing Oracle Approvals Management

xi



Use Oracle Approvals Management (AME) to define the approval rules that determine
the approval processes for Oracle applications. Download this guide from Oracle
MetaLink, Note: 282529.1.

Oracle iRecruitment Implementation Guide

Set up Oracle iRecruitment to manage all of your enterprise’s recruitment needs.

Oracle Learning Management User Guide

Set up and use Oracle Learning Management to accomplish your online and offline
learning goals.

Oracle Learning Management Implementation Guide

Implement Oracle Learning Management to accommodate your specific business
practices.

Oracle Time and Labor Implementation and User Guide

Learn how to capture work patterns such as shift hours so that this information can be
used by other applications such as General Ledger.

Installation and System Administration

Oracle Applications Concepts

This guide provides an introduction to the concepts, features, technology
stack, architecture, and terminology for Oracle Applications Release 11i. It provides a
useful first book to read before an installation of Oracle Applications. This guide also
introduces the concepts behind Applications-wide features such as Business Intelligence
(BIS), languages and character sets, and Self-Service Web Applications.

Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle Applications
products. In Release 11i, much of the installation process is handled using Oracle
Rapid Install, which minimizes the time to install Oracle Applications and the Oracle
technology stack by automating many of the required steps. This guide contains
instructions for using Oracle Rapid Install and lists the tasks you need to perform
to finish your installation. You should use this guide in conjunction with individual
product user guides and implementation guides.

Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or
Release 11.0 products to Release 11i. This guide describes the upgrade process and
lists database and product-specific upgrade tasks. You must be either at Release 10.7
(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 11i. You
cannot upgrade to Release 11i directly from releases prior to 10.7.

"About" Document

For information about implementation and user document, instructions for applying
patches, new and changes setup steps, and descriptions of software updates, refer
to the "About" document for your product. "About" documents are available on
OracleMetaLink for most products starting with Release 11.5.8.

Maintaining Oracle Applications

Use this guide to help you run the various AD utilities, such as
AutoUpgrade, AutoPatch, AD Administration, AD Controller, AD Relink, License
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Manager, and others. It contains how-to steps, screenshots, and other information that
you need to run the AD utilities. This guide also provides information on maintaining
the Oracle applications file system and database.

Oracle Applications System Administrator’s Guide

This guide provides planning and reference information for the Oracle Applications
System Administrator. It contains information on how to define security, customize
menus and online help, and manage concurrent processing.

Oracle Alert User’s Guide

This guide explains how to define periodic and event alerts to monitor the status of
your Oracle Applications data.

Oracle Applications Developer’s Guide

This guide contains the coding standards followed by the Oracle Applications
development staff and describes the Oracle Application Object Library components that
are needed to implement the Oracle Applications user interface described in the Oracle
Applications User Interface Standards for Forms-Based Products. This manual also provides
information to help you build your custom Oracle Forms Developer forms so that the
forms integrate with Oracle Applications.

Oracle Applications User Interface Standards for Forms-Based Products

This guide contains the user interface (UI) standards followed by the Oracle Applications
development staff. It describes the UI for the Oracle Applications products and how to
apply this UI to the design of an application built by using Oracle Forms.

Other Implementation Documentation

Oracle Applications Product Update Notes

Use this guide as a reference for upgrading an installation of Oracle Applications. It
provides a history of the changes to individual Oracle Applications products between
Release 11.0 and Release 11i. It includes new features, enhancements, and changes made
to database objects, profile options, and seed data for this interval.

Oracle Workflow Administrator’s Guide

This guide explains how to complete the setup steps necessary for any Oracle
Applications product that includes workflow-enabled processes, as well as how to
monitor the progress of runtime workflow processes.

Oracle Workflow Developer’s Guide

This guide explains how to define new workflow business processes and customize
existing Oracle Applications-embedded workflow processes. It also describes how to
define and customize business events and event subscriptions.

Oracle Workflow User’s Guide

This guide describes how Oracle Applications users can view and respond to workflow
notifications and monitor the progress of their workflow processes.

Oracle Workflow API Reference

This guide describes the APIs provided for developers and administrators to access
Oracle Workflow.

Oracle Applications Flexfields Guide

xiii



This guide provides flexfields planning, setup, and reference information for the
Oracle HRMS implementation team, as well as for users responsible for the ongoing
maintenance of Oracle Applications product data. This guide also provides information
on creating custom reports on flexfields data.

Oracle eTechnical Reference Manuals

Each eTechnical Reference Manual (eTRM) contains database diagrams and a detailed
description of database tables, forms, reports, and programs for a specific Oracle
Applications product. This information helps you convert data from your existing
applications, integrate Oracle Applications data with non-Oracle applications, and
write custom reports for Oracle Applications products. Oracle eTRM is available on
OracleMetalink.

Oracle Applications Message Manual

This manual describes all Oracle Applications messages. this manual is available in
HTML format on the documentation CD-ROM for Release 11i.

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser,
database triggers, or any other tool to modify Oracle Applications data unless otherwise
instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and
maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus
to modify Oracle Applications data, you risk destroying the integrity of your data and
you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using an
Oracle Applications form can update many tables at once. But when you modify Oracle
Applications data using anything other than Oracle Applications, you may change a row
in one table without making corresponding changes in related tables. If your tables get
out of synchronization with each other, you risk retrieving erroneous information and
you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications
automatically checks that your changes are valid. Oracle Applications also keeps track of
who changes information. If you enter information into database tables using database
tools, you may store invalid information. You also lose the ability to track who has
changed your information because SQL*Plus and other database tools do not keep a
record of changes.
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FastFormul a

Oracle FastFormula Overview
Formulas are generic expressions of calculations or comparisons you want to repeat with
different input values. They take input from a window, a database, or a process, such as
a payroll run and they return values or messages. See Uses for Oracle FastFormula, page
1-3 for a description of the different ways to use formulas.

Oracle FastFormulas are made up of a number of different components. These can include
assignment statements, different types of input and expressions.

When writing formulas there are standard formula writing techniquesyou should
use. These ensure your formulas are easy to read, use and understand, not only by
yourself but also by other people.

Finally, there are strict rules for components as to the words and punctuation you
must use in a formula. These ensure Oracle FastFormula can correctly perform the
calculations and validation you require. See Formula Reference, page 1-18 to find
out the rules for a particular component.

Oracle FastFormula

What is Oracle FastFormula?
Oracle FastFormula is a simple way to write formulas using English words and basic
mathematical functions. You can use information from your database in formulas
without learning the database structure or a programming language.

How can you use formulas?
You can use formulas to:

• Calculate element pay values and run results during payroll processing.

• Check that element entry values are valid for an assignment.

• Check that entries made to a user table are valid.

• Specify the criteria for including an assignment in an assignment set.

• Create rules for benefits administration, such as eligibility determination

• Select the database information you want to display in a QuickPaint report, and
perform calculations for the report.

• Specify the rules for skipping an element during payroll processing.
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• Prepare records in the format you require for the magnetic tape writer. For most
countries, the Oracle localization team has written the required formulas.

• Perform legislative checks during a payroll run.

• Specify the rules for Paid Time Off accrual plans, such as how much time is accrued
and over what period, when new starters are eligible to begin accruing time, and
how much time can be carried over to the next accrual term.

• Calculate the duration of an absence, given the start and end dates and times.

• Generate custom global person number sequences for employees, applicants, and
contingent workers.

• Configure the people management templates in a number of ways, including
supplying additional information to be available from fields on the template, and
validating field entries.

• Validate forms by calling formulas from the Custom Library. Calling formulas from
the Custom Library also allows you to easily create and maintain business rules.

For more information about calling formulas from PL/SQL, refer to the technical
essay Calling FastFormula from PL/SQL, Oracle HRMS Implementation Guide.

When you write a formula, you specify for which of these purposes you will use it.

Are any formulas supplied?
Yes, formulas are predefined for all the tax calculations required for Oracle Payroll. You
should not edit these formulas; you will automatically receive updates when tax rules
change.

There are also a number of formulas predefined for accrual plans. You can use these
formulas as supplied, or customize them to match the rules of your own plans.

When US and Canadian Payroll users define earnings and deductions, the system
automatically generates the formulas required to process these elements. When
necessary, you can edit these generated payroll formulas. In other legislations, some
formulas may be predefined, and you can create as many other formulas as you require
to process the elements you define.

Formulas for QuickPaint reports and assignment sets can be generated from criteria you
enter in windows. You can edit these generated formulas to add more functionality.

1-2 Oracle Human Resources Management Systems FastFormula User Guide



Uses for Oracle FastFormula

Uses for Oracle FastFormula
You can use Oracle FastFormula to:

• Calculate your payrolls

• Define the rules for PTO accrual plans

• Define custom calculations for benefits administration

• Define QuickPaint reports

• Validate element inputs or user tables

• Edit assignment sets

• Calculate absence duration

• Configure people management templates

• Set up business rules and call them from other PL/SQL applications

• Define your Oracle Business Intelligence Systems reports

• Define collective agreements

• Define custom global person number sequences

• Define employment categories for EEO reports (US only)

Payroll Calculations
You can use predefined payroll formulas. When you receive Oracle Payroll, some
formulas are predefined in your system. You cannot make any changes to these
formulas, but you can copy them and modify the copies.

US and Canadian Payroll users can use Oracle FastFormula to edit the formulas the
system generates for the earnings types, other payments and deductions you initiate
in Oracle Payroll. You make these edits directly to the generated formula (not to a
copy) using the Formula window.

All Oracle Payroll users can use FastFormula to write payroll calculations and skip rules
for elements you define yourself to represent earnings and deductions. You can associate
more than one formula with each element, to perform different processing for employee
assignments with different statuses. US and Canadian Payroll users need only define
their own elements and formulas for earnings and deductions with highly complex
calculations requiring a number of different calls to the database.

You can write Payroll Run Proration formulas to run after the usual payroll formula and
handle proration when employees start work or terminate mid-pay period, or when
rates, grades, or other values change, requiring an element to be prorated.

PTO Accrual Plans
You can use Oracle FastFormula to edit the seeded Accrual type formulas, or to write
your own. Each accrual plan needs two formulas: one to calculate gross accrual, and the
other to return information to the PTO Carry Over process. You can optionally create a
third formula if you want to use the Batch Element Entry (BEE) to make absence entries
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against accrual plans. This formula is called by BEE to check whether an employee
is eligible to use accrued PTO.

See: Accrual Formulas, Oracle HRMS Compensation and Benefits Management Guide

Benefits Administration
You can use Oracle FastFormula to augment the system’s benefits administration
features. Use formulas to configure your plan design to the requirements of your
enterprise. For example, you can write a formula to calculate benefits eligibility for those
cases where eligibility determination is most complex.

QuickPaint Reports
In the Define QuickPaint Report window, you can paste database items from a list into
the Report Definition area and enter free text to label the data. When you save your
QuickPaint Report definition, a formula is generated automatically. Formulas generated
from QuickPaint do not include conditional logic or calculations. You may want to add
these features, for example to sum up compensation elements or to report different
data for different assignments.

Validation of Element Inputs or User Tables
You can use Oracle FastFormula to validate user entries into element input values using
lookups or maximum and minimum values. However, if you need more complex
validation, you can write a formula to check the entry.

You can also use a formula to validate entries into user tables that you define.

Assignment Sets
When you define assignment sets in the Assignment Set window, Oracle FastFormula
generates a formula to define an assignment set from the criteria entered. However, you
may want to change the sequence in which the set criteria are checked for each
assignment.

Absence Duration
You can write a formula to calculate the duration of an absence from the start and end
dates and times. Your localization team may have created a default formula, but you
can override this with your own version.

Configuring People Management Templates
There are several ways you can use formulas to configure the people management
templates:

• A Template Validation formula can check values entered in a field.

• A Template Information formula can specify information to be displayed from the
right mouse menu when a user right-clicks in a field.

• A QuickPaint formula can return a text string to display in the Assignment field on
the Maintenance window and in the Data Organizer.
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• A QuickPaint formula can return message tokens that you can use in a notification
message issued from template forms.

Calling FastFormula from PL/SQL
You can call formulas from PL/SQL applications. This enables direct access to data items
and makes it possible to develop custom code for localized business rules.

More detailed information about calling FastFormula from PL/SQL can be found in the
technical essay Calling FastFormula from PL/SQL, Oracle HRMS Implementation Guide.

Oracle Business Intelligence Systems (BIS) Reports
Using formulas you can configure your HRMS BIS reports so that they answer the
business questions which are important to your enterprise. You can:

• Define how workforce should be counted within your enterprise for the Workforce
reports.

• Set up information about how you want to record and report on regular and
overtime hours for the Hours Worked Analysis report.

• Set up the standard hours for your enterprise for the Absence Analysis report.

Collective Agreements
Using formulas you can calculate whether a person is eligible to receive a collective
agreement entitlement. This can be used when defining an eligibility profile to be used
in conjunction with a collective agreement, instead of selecting criteria elements. You
select the formula as a rule when defining the eligibility profile.

Global Person Numbering
When you select automatic local numbering for employees, applicants, or contingent
workers, Oracle HRMS allocates person numbers from a sequence that is specific
to the business group. When you select global numbering, Oracle HRMS allocates
person numbers from a single sequence to workers of the relevant type throughout
the enterprise.

You can replace the default local or global person number sequence with a custom global
sequence by defining a formula for each person type, as appropriate. You may want to
use a formula to provide an alphanumeric numbering scheme, for example, or some
other variation of the default scheme for any or all person types. For example, you could
use a custom global sequence for employees but use the default local or global sequence
for applicants and contingent workers. Alternatively, you could use a custom sequence
for all three person types by defining three formulas.

Employment Categories for EEO Reports (US only)
For the EEO4 and EEO5 reports you can use Oracle FastFormula to create a formula of
employment categories. You can define a formula for each business group and the EEO
reports will pick the list of employment categories from the formula.
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Introduction to Formula Components
The following information uses a series of examples to help you understand how to
use different components to build your Oracle formulas.

To start with a simple example, suppose you wanted to calculate the pay value for the
element Wage by multiplying the number of hours an employee works each week by
hourly rate. You could write this formula:

wage = hours_worked * hourly_rate

RETURN wage

Note: If you want to know the rules which govern the use of a specific
component, refer to Formula Reference.

Assignment and Return Statements
The first line is an Assignment statement that simply assigns a value to the element
Wage. The second line is a Return statement that passes back the Wage value to the
payroll run.

Constants and Variables
In this example, the Wage value is calculated, but it could be a constant value, such
as: wage = 200 . To calculate the Wage value, Oracle FastFormula needs to get values
for the variables hours_worked and hourly_rate. They are called variables because
they can contain different values depending, in this example, on which assignment
the payroll run is processing.

Data Types
Both variables and constants can be one of three data types:

• numeric

• text

• date

The variables in the Wage example are numeric.

Types of Input
We have said that Oracle FastFormula needs to get values for the variables hours_worked
and hourly_rate. There are three ways it can do this:

• Receiving them as input when the formula is called.

• Finding the values in the database from database items.

• Using global values, which you enter in the Globals window.

To use a database item or global value in your formula, you simply refer to it by
name. You can browse through lists of database items in the Formulas window. To use a
value passed to the formula at run time, you must write an Inputs statement.
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Input Statements

In our Wage example, suppose that hours_worked is an input value to the element
Wage. To pass the element input values to the formula during a payroll run, you define
an Inputs statement, as follows:

INPUTS ARE hours_worked

wage = hours_worked * hourly_rate

RETURN wage

The name you use in the Inputs statement must be the same as the name of the element
input value, and multiple words must be joined by underscores. In this example, the
input value hours_worked is numeric. If the input value is not numeric, you must tell
Oracle FastFormula whether it is text or date. For example:

INPUTS ARE start_date (date)

Database Items

Suppose that hourly_rate is a standard rate taken from the Grade Rates table. This is an
example of a database item. A database item has a label, or special piece of code, telling
Oracle FastFormula the path to take to access the data. Oracle HRMS produces most of
the database items you need without you taking any special action. These items include
both information unique to your enterprise, which you hold in flexfield segments, and
standard information such as assignment numbers and grades.

In the Formulas window, you pick database items from a list. You will see that
the name of the database item for a grade rate called hourly_rate is actually
grade_hourly_rate_value. This is the name you must use in your formula.

By this naming convention, Oracle FastFormula knows that hourly_rate is a database
item from the Grade Rate table. But how does it know which hourly_rate to use from
this table? It works this out from the context the payroll run provides for each element
entry. The context identifies:

• the Business Group

• the element and element link

• the payroll and payroll run

• the employee and employee assignment.

Important: You should use an Inputs statement in preference to database
items where possible because this is more efficient.

See: Writing Efficient Payroll Calculation Formulas, page 1-15.

Global Variables

Use global values to store information that does not change often, but you refer to
frequently, such as Company Name, or company-wide percentages used to calculate
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certain types of bonus. You define the global value and change its value using the
Globals window.

See: Defining Global Values, page 1-227

Local Variables

Local variables exist in one formula only. You can change the value of a local variable
by assigning it a value in an Assignment statement. In the Wage example, the variable
wage itself is a local variable. It receives a value within the formula by the Assignment
statement:

wage = hours_worked * hourly_rate

Note: You cannot change the value of input values, database items, or
global values within a formula.

Functions
The Assignment statement in the wages example above uses a simple
multiplication to calculate the value of the wages element. You can also use
addition, subtraction, division, and a number of functions. For example:

bonus = GREATEST(days_at_work,163) + bonus_rate

Here the function GREATEST tells Oracle FastFormula to use the value of the variable
days_at_work, if it is greater than 163, and otherwise to use the constant 163.

The data type of variables and constants determines how operators and functions act
on the values. For example, the addition operator (+) can be used with numeric or text
data, while division can be used with numeric data only.

There are special functions that convert variables from:

• numbers to text (TO_TEXT)

• dates to text (TO_TEXT)

• text to date (TO_DATE)

• text to number (TO_NUM)

See: Functions, page 1-27

Nested Expressions
The Assignment statement can use as many arithmetic operators and functions as you
require. Each function or calculation is one expression, and you can nest expressions
to create more complex calculations. You must use brackets to make clear to Oracle
FastFormula the order in which the calculations are performed. For example:

ANNUAL_BONUS = trunc(((((salary_amount/100)*

bonus_percentage)/183)*(days_between(end_period_dat e,
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start_date) + 1)), 2)

Oracle FastFormula begins calculating inside the brackets and from left to right, in the
following steps:

1. salary_amount/100

2. 1. * bonus_percentage

3. 2. / 183

4. days_between (end_period_date, start_date)

5. 4. + 1

6. 3. * 5.

7. TRUNC(6.,2)

Notice that TRUNC is another function. It rounds a numeric value down to the number
of decimal places specified after the comma (two in this case).

Incorporating Conditions
In our simple Wage element example, only one value is returned, and it is calculated
in the same way for every assignment. However you may need to perform different
calculations depending on the particular group of employee assignments, or the time
of the year, or some other factors. You can do this by incorporating conditions in your
formula.

Simple Conditions

For example:

IF age < 20 THEN

training_allowance = 30

ELSE

training_allowance = 0

The formula checks whether the condition (age < 20) is true or false. If it is true, the
formula processes the statement that follows the word THEN. If the condition is not
true, the formula ignores this statement and processes any statement that follows the
word ELSE. The ELSE clause is optional.

Complex Conditions

In the example above, the condition compares a variable (age) to a constant (20). The
condition can be more complex, comparing expressions that contain functions and
arithmetic operators. For example:
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IF (DAYS_BETWEEN(end_period_date, start_date)+1) >= thr eshold

DAYS_BETWEEN is another function.

We have seen two comparators: less than (<) and greater than or equal to (>=). A full list
of the comparators you can use appears in the Reference section.

See: Formula Reference, page 1-18

WAS DEFAULTED

There is a special type of condition called WAS DEFAULTED. Use this to test whether a
default value has been placed in an input value or database item. Default values are
placed using the Default statement. For example:

DEFAULT FOR hourly_rate IS 3.00

X = hours_worked * hourly_rate

IF hourly_rate WAS DEFAULTED

THEN

MESG = ’Warning: hourly rate defaulted’

In this example, if the database item hourly_rate is empty (NULL), the formula uses
the default value of 3.00 and issues a warning message.

Combined Conditions

You can combine conditions using the logical operators AND, OR, NOT.

• Use AND if you want an action to occur when more than one condition is true. For
example:

IF (days_between(end_period_date, start_date) + 1) >= 183

AND employee_status = ’FULL TIME’

THEN . . .

• Use OR if you want an action to occur when any one of two or more conditions
is true. For example:

IF stock_level < 10000

OR order_size >= 1500
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THEN . . .

• Use NOT if you want an action to occur when a condition is not true. For example:

IF NOT (months_between(purchase_date, system_date) => 60

THEN . . .

As with Assignment statements, you may need to use brackets to tell Oracle FastFormula
in which order to test conditions. By default, NOT has the highest precedence, followed
by AND then OR. So the following condition:

IF X = 6 AND NOT Y = 7 OR P >= 6

is interpreted as:

IF ((X = 6) AND (NOT (Y = 7))) OR (P >= 6)

How you use brackets can change dramatically the meaning of a formula.

Tip: Use brackets whenever you create multiple conditions, so that the
meaning of the formula is clear to other readers.

Multiple Actions Based On Conditions

We have seen how to make conditions more complex. You can also make the actions
performed as complex as you like. In our simple example above, the result of the
condition was the assignment of a value to the variable training_allowance. As well as
assigning values, you can perform calculations and return values.

For example, suppose you must check whether there are sufficient funds in a bank
account before processing a withdrawal:

INPUTS ARE acct_balance,

acct (text),

debit_amt

IF acct_balance >= debit_amt

THEN

(
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new_balance = acct_balance - debit_amt

RETURN new_balance

)

ELSE

(

message = ’Account No. ’ + acct + ’ - Insufficient Funds’

message2 = ’Account Balance is ’ + TO_TEXT(acct_balance)

RETURN message, message2

)

Notice that you can return two variables in the same Return statement.

Important: The brackets following THEN and ELSE are essential when
you have multiple actions based on a condition. Without them, Oracle
FastFormula processes the first statement conditionally and the other
statements unconditionally.

Formula Writing Techniques
When writing formulas there are a number of techniques you should follow to ensure
your formulas are easy to read, use and understand.

Commenting Formula
It is good practice to include comments in your formulas to explain to other people
what the formula does.

So, for example, you can name your formula:

/* Formula: Attendance Bonus */

and write an explanation of your formula:
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/* Use this formula to calculate the annual bonus for

clerical staff. Employees receive either a percentage of

their salary (if they have been present for 183 or more

days in the last six months), or a pro rata bonus (if they

have been in attendance for less than 183 days in the last

six months). */

Oracle FastFormula ignores everything between the comment delimiters: /* and */. You
can place comments anywhere in a formula without affecting the formula’s performance.

Caution: Do not put a comment within a comment. This causes Oracle
FastFormula to return a syntax error.

You can use a comment to explain what part of your formula does. So, for example, you
might want a comment explaining who decides the bonus percentage:

INPUTS ARE salary_amount,

start_date (date),

end_period_date (date),

bonus_percentage /* decided at board level */

You can also use comments to ‘comment out’ parts of the formula you do not currently
want to use. So, for example, you can include a fifth input of employee_status, ensuring
that employees with a status of full time are awarded a bonus. However, as you do not
yet have a range of statuses, you do not currently need the fifth input.

INPUTS ARE salary_amount,

start_date (date),

end_period_date (date),

bonus_percentage /* decided at board level */

/* employee_status (text) */

Use comments and white space freely when entering formulas. This makes the formulas
easier to read and understand, and has no effect on performance or memory usage. Use
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indentation for the same reason, especially when you are using brackets to control
the order of processing.

It is good practice to include the following information in a comment at the beginning
of a formula:

• Formula title and short statement of its purpose

• Description of formula inputs

• List of variables and constants that may require updating

• Description of the input values of the element that receives the formula’s direct result

• Explanation of the formula’s calculations

• Administrative information such as the name, address and telephone number of an
office administering the earnings, deduction, or charge the formula affects

• The dates of formula modifications, the names of those entering the edits, and
possibly the reasons for change

Alias Statements
Database items are named by the system when it creates them, and sometimes these
names are too long to conveniently use in a formula. You cannot shorten the name of a
database item (or a global value) itself, but you can set up an alternative shorter name
to use within the formula. For example:

ALIAS as_overtime_qualifying_length_of_service AS ot_q ls

In the rest of the formula, you can use the alias (in this example, ot_qls) as if it were
the actual variable.

Important: Using an Alias is more efficient than assigning the database
item to a local variable with a short name.

Default Statements
Use the Default statement to set a default value for an input value or a database
item. The formula uses the default value if the database item is empty or no input value
is provided when you run the formula. For example:

DEFAULT FOR hourly_rate IS 3.00

X = hours_worked * hourly_rate

IF hourly_rate WAS DEFAULTED

THEN

MESG = ’Warning: hourly rate defaulted’
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This example sets a default of 3.00 for the database item hourly_rate. If hourly_rate is
empty (NULL) in the database, the formula uses the default value of 3.00. The formula
uses the ’WAS DEFAULTED’ test to detect when a default value is used, in which
case it issues a warning message.

Important: You must use the Default statement for database items that
can be empty. The Database Items window includes a check box labelled
Default Required. This check box is checked for database items that can
be empty. The Database Items window appears when you choose the
Show Items button on the Formulas window.

Writing Efficient Payroll Calculation Formulas
The following guidelines are generally true for typical payroll runs:

• The longer an element’s formula, the longer its processing time.

• The more elements entered for an assignment, the longer its processing time.

• One element associated with a lengthy formula usually processes faster than two
related elements each associated with a short formula.

• The overall number of elements and formulas in the system has little effect on
processing efficiency. It is the number of elements per assignment that affects
processing time.

Variable Names and Aliases

To improve readability use names that are brief yet meaningful. Name length has no
effect on performance or memory usage. Use Aliases if the names of database items or
global values are long.

Input Statements

Use Input statements rather than database items whenever possible. This improves
formula processing by as much as a factor of ten. It speeds up the running of your
payroll by eliminating the need to access the database for the input values.

Inefficient:

Salary = Salary_annual_salary / 12

RETURN Salary

Efficient:

INPUTS ARE Annual_salary

Salary = Annual_salary / 12

RETURN Salary
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Date Literals

Use the TO_DATE function only when the operand is a variable.

Inefficient:

Start_date = TO_DATE ( ’1992-01-12 00:00:00’ )

Efficient:

Start_date = ’1992-01-12 00:00:00’ (date)

Single Expressions

Use a single expression in straightforward formulas where this does not lead to
confusion.

Inefficient:

Temp = Salary / Annualizing_factor

Tax = Temp * 3

Efficient:

Tax = (Salary / Annualizing_factor) * 3

Database Items

Do not refer to database items until you need them. People sometimes list at the top
of a formula all the database items the formula might need, thinking this helps Oracle
FastFormula process more quickly. However, this in fact slows processing by causing
unnecessary database calls.

Inefficient:

S = Salary

A = Age

IF S < 20000 THEN

IF A < 20 THEN

Training_allowance = 30

ELSE
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Training_allowance = 0

Efficient:

IF Salary < 20000 THEN

IF Age < 20 THEN

Training_allowance = 30

ELSE

Training_allowance = 0

The first example always causes a database fetch for Age whereas the second only
fetches Age if Salary is less than 20000.

Balance Dimensions for UK HRMS

Wherever possible, use balance dimensions for single assignments only in
formulas. Multiple assignments require more calculation, leading to slower processing
time. The number of genuine multiple assignments in a payroll is not normally high, and
the presence of a small number does not lead to any significant increase in overall
processing time. There could be a problem, however, if you unnecessarily link balance
dimensions for multiple assignments into general formulas.

Proration Formulas for UK HRMS

You set up proration formulas to enable element values to be calculated accurately if
they change during a payroll period, for example, if an employee leaves the company or
if their pay rate changes.

For more detailed information on proration, see the Technical Essay entitled
Proration available on MetaLink (Technical Libraries/Human Resources Management
Systems/Payroll/Documentation/United Kingdom).
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Formula Reference

Formula Reference
Formulas comprise statements and comments. Statements are instructions telling Oracle
FastFormula how to process constants and variables, which are the basic information
units in a formula. The two key types of statement, which describe the formula’s
calculations, are the Assignment statement and the If statement. These statements can
include expressions, which manipulate constants and variables using arithmetic operators
and functions. The operators and functions you can use and the results they give depend
upon the data type of the constants and variables. In If statements, one expression
can be compared to another using comparators to create a condition. Conditions can be
combined using logical operators.

There are rules about how you use each of these components. Refer to the component
description for more detailed information.

An example of each of these formula components is identified in the sample formula.

Components in a Sample Formula
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Input Values in Payroll Formulas
In many formulas for calculating pay, some or all of the information you need comes
from the input values of the element.

For example, suppose you pay some salaried employees using a recurring element called
Salary. The Salary element has an input value called annual_salary. You need a formula
that divides the input value into twelve parts:

INPUTS ARE annual_salary

Salary = annual_salary/12

RETURN Salary

Important: When you use an Inputs statement, you need to make
sure that none of the input values can have a value of null because
this causes the formula to fail. You can avoid this problem by using
the Default statement.

Using an Inputs statement is the most efficient way to access the input values of the
element with which the formula is associated. However, if the formula uses the input
values of other elements, it must access the database items for them.

For example, if you want to use the input value annual_salary in the formula to calculate
the element Bonus, you use the database item as follows:

IF Salary_annual_salary > 20000

THEN

Bonus = bonus_rate * (sales_achieved - sales_threshold)

Notice that the database item name is in two parts: the input value (annual_salary) name
prefixed by the element name (Salary). This is the naming convention for the database
items of element input values.

Multiple Entries of Element Input Values
When you define an element, you can enable multiple entries of the element within
a payroll period.

For example, suppose you use the element Wages to pay some weekly-paid
employees. The Wages element has the input value hours_worked. Each week, you
regularly make five entries for the input value hours_worked.

To calculate Wages, you can multiply the hours worked each day by the employee’s
standard rate from the grade rates table, so that your formula looks like this:

INPUTS ARE hours_worked
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Wages = hours_worked * standard_rate

RETURN Wages

During the payroll run, the formula processes five times, creating five separate pay
values, one for each entry.

Now consider using the database item Wages_hours_worked instead of an Inputs
statement. The database item for an entry value sums up all the entries made in the
payroll period.

This is a great convenience when referring to input value totals for a payroll
period. However, you must be sure that it is the totals that you want to use. In this
example, using the database item produces the wrong result.

Wages_hours_worked gives a single value that is the sum of the five entries in each
weekly payroll period. When the payroll runs, the formula processes five times, each
time calculating wages using the total hours worked in the week.

Important: If multiple entries are enabled for an element, be careful
when using database items for the element’s entry values. These
database items hold the sum of all the entries. This includes entries
made as indirect formula results during the payroll run.

Database Items for Numeric Values Only
Entry value database items are not created for input values with units of
character, date, or time when multiple entries are enabled for the element. This is
because entry values of these types cannot be summed over the payroll period. Only
numeric values can be summed. Numeric input values are those with units of:

• Hours

• Integer

• Money

• Number

Notice that other database items, such as default, minimum, or maximum, may be
created for non-numeric input values.

Constants
Every piece of information that you can manipulate or use in a formula is a constant
or a variable.

The data type of a constant or variable describes what kind of data the constant or
variable holds. Generally, you use constant and variables of the same data type in an
expression.

Constants are actual values you use in a formula. Oracle FastFormula uses constants
directly rather than holding them in a variable.

There are three types of constant:

• numeric
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• text

• date

Numeric Constants
Enter numeric constants without quotes. Precede negative numbers with a minus
sign (-). Numbers may have a decimal component after a decimal point. Do not use
exponents and floating point (scientific) notations. So, for example, you cannot use 22

or 10e1.24 as numeric constants. Do not use commas or spaces in a number. So, for
example, you cannot use 10,000 or 10 000.00 numeric constants.

Examples of valid numeric constants are:

• 63

• 3.55

• -2.3

• - 0.33

• - .2

• 10000

Text Constants
Enclose text constants in single quotes. They may contain spaces. You can represent the
single quote character in a text constant by writing it twice (’’). Note that this is not the
same as the double quote ("). Examples of valid text constants are:

• ‘J. Smith’

• ‘P O’’Donnell’

• ‘1234’

• ‘Manager’

• ‘12 Union Road’

• ‘The Bonus this year is 23%’

Date Constants
Date constants contain a date. Enclose dates in single quotes and follow immediately
with the word date, in brackets. Use the format YYYY-MON-DD HH24:MI:SS or
DD-MON-YYYY. It is recommended that you use the first format if you want to compile
the formula under different language settings.

Examples of valid date constants are:

• ‘1989-03-12 00:00:00’ (date)

• ‘12-MAR-1989’ (date)

Variables
You use variables in a formula to access information. Variables can have frequently
changing values.
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The data type of a variable determines the type of information the variable holds:

• numeric

• text

• date

You do not have to specify what type you want a variable to be. Oracle FastFormula
works out the type from how you use the variable. For example, if you set a variable to
‘J. Smith’, this is interpreted as a text variable.

The system also warns you if you try to perform any inconsistent operations, such as
trying to add a number to a text string.

There are three classes of variable in Oracle FastFormula:

• Local Variable - Variables that occur in a single formula only.

• Global Value - Values that can occur in any formula.

• Database Item - Items that exist in the application’s database.

The variable class determines how a formula uses it.

Local Variables
Local variables occur in a single formula only. You can change a local variable within the
formula by assigning a value to it using an Assignment statement.

You can use local variables to store data in a formula. You might want to hold data
temporarily while you perform some other calculations, or to pass data back to the
application.

Below is an example showing the use of a local variable, annual_leave.

/* Formula: Annual Leave Formula */

IF years_service >= 10

THEN

annual_leave = 25

ELSE

annual_leave = 20 + FLOOR (years_service/2)

RETURN annual_leave
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Global Values
Global values are visible from within any formula. Use global values to store information
that does not change often, but you refer to frequently, such as company name, or
a location allowance that applies to many employees. Global values are datetracked
so you can make date effective changes ahead of time.

You can never change a global value using a formula. You alter global values using the
Globals window. The global value is the same across all formulas within a Business
Group.

See: Defining Global Values, page 1-227

Below is an example using a global value.

/* Formula: HAZARD ALLOWANCE FORMULA */

IF basic_hours > hazard_limit

THEN

hazard_allowance = 2.30

ELSE

hazard_allowance = 2.00

RETURN hazard_allowance

In this example, hazard_limit is a global value, which has been preset to reflect the point
at which workers’ hazard payment increases.

Database Items
Database items exist in the application database and have a label, hidden from users, that
the system uses to find the data.

There are two types of database item:

• Static database items are predefined. They include standard types of
information, such as the sex, birth date, and work location of an employee, or the
start and end dates of a payroll period.

• Dynamic database items are generated from your definitions of:

• elements

• balances

• absence types

• grade rates and pay scale rates

• flexfield segments
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The name of your element, pay and input values, balance, absence type, grade rate, pay
scale rate, or flexfield segment becomes part of the name of the generated database
item. This helps you identify the database item you need when you display a list of all
available items in the Formulas window.

Definitions of flexfield segments only become database items when you initiate the
Declare Descriptive Flexfield process from the Submit Requests window. The other
definitions become database items immediately when you save them to the database.

See:

Static Database Items, page 1-54

Dynamic Database Items, page 1-73.

Database items are specific to the context in which you use them. For example, using the
database item hourly_rate gives the appropriate hourly rate for the specific assignment
being processed.

Like global values, database item values cannot be changed within a formula.

Rules for Determining Variable Class and Data Type
The rules that determine the data type and class of variables in a formula are:

1. The variable can be an input you name in the Inputs statement. For example:

INPUTS ARE salary_amount,

start_date (date)

frequency (text)

If you do not specify the variable type in the statement, Oracle FastFormula assumes
it is numeric.

2. If the variable is not an input, Oracle FastFormula looks in the list of global values
the first time the variable occurs. If the variable is in the list, Oracle FastFormula
determines the data type from there.

3. If the variable is not in the list, Oracle FastFormula searches the list of database
items. Again, if it is in the list, Oracle FastFormula knows the data type.

4. Finally, if Oracle FastFormula does not find the variable in either the global values or
the database items, then it treats the variable as a local variable. It determines the
data type from the way you use the variable.

Notice that if the variable is either a global value or a database item, then any attempt in
your formula to alter the value of the variable causes an error.

If the variable is a local variable, it does not contain a value when it is first used in the
formula. Therefore you must assign a value to the variable before you try to use it in a
condition or expression. If you fail to assign a value, Oracle FastFormula fails when
you attempt to verify or run the formula.

Tip: To avoid a failure, assign values to your local variables when
they first appear in your formula.
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Naming Variables
Variables have names comprising one or more words. The words must be joined by
underscores. The words must each start with an alphabetic character (A-Z) and can
be followed by alphanumeric characters (A-Z, 0-9). The maximum size of a variable
name is 80 characters.

Oracle FastFormula is not sensitive to case. So, for example, the variable called
EMPLOYEE_NAME is the same as the variable Employee_name.

The following reserved words cannot be used as the names of variables:

ALIAS AND ARE AS

DEFAULT DEFAULTED ELSE EXECUTE

FOR IF INPUTS IS

NOT OR RETURN THEN

USING WAS

Also, any word consisting only of digits, as these could be mistaken for numbers.

You may find that the name of a database item or global value is too long to use
conveniently in your formula. You can set up an alternative, shorter name for use within
a formula. You set this up using the Alias statement.

See: Statements, page 1-45

Expressions
Expressions combine constants and variables with arithmetic operators (+, -, *, /) and
functions to return a value of a certain data type. For example, the expression (3 + 2)
returns a value of 5, and is of numeric data type.

The format of an expression is:

SUBEXPRESSION [operator SUBEXPRESSION ...]

This means that a number of ’subexpressions’ can combine in a single expression. For
example, the subexpressions (3 + 2) and MONTHS_BETWEEN(start_date, end_date) can
combine in a single expression as follows:

(3 + 2) + MONTHS_BETWEEN(start_date, end_date)

Expressions can also be used inside functions, as in the following example:

salary = GREATEST(minimum_wage, (hourly_rate * hours_wor ked))

Data Type of Expressions
The rules for determining the data type of an expression are simple. Operands in an
expression are normally of the same data type, and this is normally the data type of the
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expression as a whole. For example, in the following expression all the operands are
numeric and the expression itself is numeric:

GREATEST(minimum_wage, (hourly_rate * hours_worked))

There are some exceptions to this. For example:

DAYS_BETWEEN(date1, date2)

MONTHS_BETWEEN(date1, date2)

These have date operands, but return a numeric value.

So the expression:

4 + days_between(start_date, todays_date)

returns a numeric result.

Arithmetic Operators
An expression may contain arithmetic operators, which determine how variables and
constants are manipulated. For example, the operator "+" indicates that two items
should be added together.

The division, subtraction, and multiplication operators can only be used with numeric
operands. The operands can be variables, constants, or subexpressions. A formula
error occurs if:

• the result of subtraction is too large a negative number

• the result of multiplication is too large

• the second operand of a division evaluates to zero

In both cases, ’too large’ here is determined by the normal limits in the ORACLE
database.

The addition operator can be used with numeric or text operands. If the result is greater
than 240 characters, a formula error occurs.

Notice that you enclose text constants in single forward quotes only (’), not double
quotes ("). For example, the statements:

string1 = ’will ’

result_string = ’Pigs ’ + string1 + ’fly’

set the local variable result_string to ’Pigs will fly’.
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Functions
Oracle FastFormula provides functions that manipulate data in different ways. Some
functions work on only one type of data, some can work on two, others work on all
three data types.

The functions are described below, separated into the three data types and functions that
convert between data types. Where a function returns a different data type result than
the data type of its operands, the description explains this.

Some functions retrieve data from Oracle Applications tables. These are described in
the sections: Functions To Get Values from Tables, and Functions for Accrual Type
Formulas. Some functions enable you to set and use globals in SQL*Plus. They are
described in the section: Functions to Set and Get Globals.

The general form of a function is:

NAME OF FUNCTION(operand, operand, . .)

Notice that, as with the operators, the operands of a function can be
variables, constants, or complete expressions. If the operand is a text string, you must
enclose it in quote marks.

Text Functions

CHR

CHR(n)

The CHR function returns the character having the binary equivalent to number operand
n in the database character set.

Example

/* CHR (10) used to add a newline to the end of REPORT_TEXT2. */

REPORT_TEXT2 = ’Warning the Transaction Limit has been exce eded’

DEBUG

DEBUG(expr)

This function accepts a string and uses a DBMS_OUTPUT statement to output the
string to the console. Use this function when you are testing a new formula to track its
processing and identify where it is failing.

GREATEST

GREATEST(expr, expr [, expr] . . .)

GREATEST_OF(expr, expr [, expr] . . .)

The GREATEST function compares the values of all the text string operands. It returns
the value of the operand that is alphabetically last. If there are two or more operands
that meet the criteria, Oracle FastFormula returns the first.
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INITCAP

INITCAP(expr)

The INITCAP function returns the expression expr with the first letter of each word
in uppercase, all other letters in lowercase. Words are delimited by white space or
characters that are not alphanumeric.

INSTR

INSTR(expr1,expr2[,n[,m]])

The INSTR searches expr1 beginning with its nth character for the nth occurrence of
expr2 and returns the position of the character in expr1 that is the first character of this
occurrence. If n is negative, Oracle FastFormula counts and searches backward from the
end of expr1. The value of m must be positive. The default values of both n and m are
1, meaning Oracle FastFormula begins searching at the first character of expr1 for the first
occurrence of expr2. The return value is relative to the beginning of expr1, regardless of
the value of n, and is expressed in characters. If the search is unsuccessful (if expr2 does
not appear m times after the nth character of expr1) the return value is 0.

INSTRB

INSTRB(expr1,expr2[,n[,m]])

The same as INSTR, except that n and the return value are expressed in bytes, rather than
in characters. For a single-byte database character set, INSTRB is equivalent to INSTR.

LEAST

LEAST(expr, expr [, expr] . . .)

LEAST_OF(expr, expr [, expr] . . .)

The LEAST function compares the values of all the text string operands. It returns the
value of the operand that is alphabetically first. If there are two or more operands that
meet the criteria, Oracle FastFormula returns the first.

LENGTH

LENGTH(expr)

The LENGTH function returns the number of characters in the text string operand expr.

Note: The data type of the result of this function is numeric.

LENGTHB

LENGTHB(char)

The LENGTHB function returns the length of char in characters. If char has datatype
CHAR, the length includes all trailing blanks. If char is null, this function returns null.

LOWER

LOWER(expr)

The LOWER function returns the string operand expr with all letters lowercase. The
return value has the same datatype as the argument expr.
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LPAD

(expr, n [,pad])

The LPAD function returns the text string operand expr left-padded to length n with
the sequence of characters in pad. The default for pad is a blank. If expr is longer than
n, then LPAD returns the portion of expr that fits in n.

Examples:

/* A is set to ’XYXYXhello’ */

A = LPAD (’hello, 10, ’XY’)

/* A is set to ’hell’ */

A = LPAD (’hello’, 4 )

LTRIM

(expr [,set])

The LTRIM function returns the text string operand expr with all the leftmost characters
that appear in set removed. The default for set is a blank. If none of the leftmost
characters of expr appear in set then expr is returned

Examples:

/* A is set to ’def’ */

A = LTRIM (’abcdef’,’abc’)

/* A is set to ’abcdef’ */

A = LTRIM (’abcdef’,’bc’)

REPLACE

(expr, search_string [,replacement_string])

The REPLACE function returns the text string operand expr with every occurrence
of search_string replaced with replacement_string. If replacement_string is omitted or
null, all occurrences of search_string are removed. If search_string is NULL, expr is
returned. REPLACE allows you to substitute one string for another as well as to remove
character strings.

Example:

SELECT REPLACE (’JACK and JUE’,’J’,’BL’) "Changes"
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FROM DUAL

Changes

-------

BLACK and BLUE

RPAD

(expr, n [,pad])

The RPAD function returns the text string operand expr right-padded to length n with
the sequence of characters in pad. The default for pad is a blank. If expr is longer than
n, then RPAD returns the portion of expr that fits in n.

Examples:

/* A is set to ’helloXYXYX’ */

A = RPAD (’hello, 10, ’XY’)

/* A is set to ’hell’ */

A = RPAD (’hello’, 4 )

RTRIM

(expr [,set])

The RTRIM function returns the text string operand expr with all the rightmost characters
that appear in set removed. The default for set is a blank. If none of the rightmost
characters of expr appear in set then expr is returned

Examples:

/* A is set to ’abc’ */

A = RTRIM (’abcdef’,’def’)

/* A is set to ’abcdef’ */

A = RTRIM (’abcdef’,’de’)
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SUBSTRING

SUBSTR(expr, m [,n])

SUBSTRING(expr, m [,n])

The SUBSTRING function returns a substring of the text string operand expr of length n
characters beginning at the mth character. If you omit the third operand, the substring
starts from m and finishes at the end of expr.

Note: The first operand is a text operand. The second and third operands
are numeric operands. The resulting data type of this function is text.

Tip: Always check string length before you start to substring. For
example:

/* Check that the tax code starts with GG */

IF length(Tax_code) <= 2

THEN

(message = ’Tax code is too short’

RETURN message

)

IF substr( Tax_code, 1, 2) = ’GG’ THEN ...

Or, to check if Tax_code is a string of at least two characters starting
with ’GG’:

IF Tax_code LIKE ’GG%’ THEN ...

SUBSTRB

(expr, m [,n])

The same as SUBSTR, except that the arguments m and n are expressed in bytes, rather
than in characters. For a single-byte database character set, SUBSTRB is equivalent
to SUBSTR.

TRANSLATE

(expr, from, to)

The TRANSLATE function returns the text string operand expr with all occurrences of
each character in from replaced by its corresponding character in to. Characters in expr
that are not in from are not replaced. The argument from can contain more characters

FastFormula 1-31



than to. In this case, the extra characters at the end of from have no corresponding
characters in to. If these extra characters appear in expr, they are removed from the return
value. Oracle FastFormula interprets the empty string as null, and if this function has a
null argument, it returns null.

TRIM

TRIM(trim_character FROM trim_source)

The TRIM function allows you to trim heading or trailing characters (or both) from a
character string. If trim_character or trim_source is a character literal, you must enclose
it in single quotes. You can specify LEADING or TRAILING to remove leading or
trailing characters. If you specify none of these, both leading and trailing characters are
removed equal to trim_character.

UPPER

UPPER(expr)

The UPPER function converts a text string to upper case.

Numeric Functions

ABS

ABS(n)

The ABS function returns the magnitude of a numeric operand n as a positive numeric
value.

If the value of the operand is positive, its value returns unchanged. If the operand is
negative then the value’s sign inverts, and the value returns as a positive number.

Example:

ABS (-17) returns 17

CALCULATE_HOURS_WORKED

CALCULATE_HOURS_WORKED(n, date1, date2, standard_frequency)

The CALCULATE_HOURS_WORKED function returns the total number of hours
worked in a given date range.

The function works by calculating the total number of hours worked for an employee
between date1 and date2, taking into account that the employee works n hours in
the standard working period standard_frequency. This parameter gives the unit of
measurement for the standard working period. It can be one of:

• W (weekly)

• M (monthly)

• Y (yearly)

Example:

CALCULATE_HOURS_WORKED (40, 01-FEB-2003, 28-FEB-2003, W ) returns
160
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This indicates that the employee has worked 160 hours in the month of February
2003, based on a 40-hour week and taking into account the number of working days in
that month.

FLOOR

FLOOR(n)

The FLOOR function returns the integer part of a numeric operand n.

If the value of the operand contains information after the decimal point, Oracle
FastFormula discards that information and returns a whole number.

Example:

FLOOR(35.455) returns 35

GREATEST

GREATEST(n, n [, n] . . .)

GREATEST_OF(n, n [, n] . . .)

The GREATEST function compares all the operands and returns the largest value.

LEAST

LEAST(n, n [, n] . . .)

LEAST_OF(n, n [, n] . . .)

The LEAST function compares all the operands and returns the smallest value.

POWER

POWER(m,n)

Returns m raised to the nth power. The base m and the exponent n can be any
numbers, but if m is negative, n must be an integer.

ROUND

ROUND(n [, m])

The ROUND function rounds off a numeric value n to m decimal places and a date
depending on the format of m. For numeric values, the first operand is the value Oracle
FastFormula rounds off, the second the number of places Oracle FastFormula rounds
off to. For dates, ROUND returns n rounded to the unit specified by the format model
of m such as Year or Day. Refer to the SQL Language Reference Manual for details of the
valid formats you can specify.

Examples:

ROUND(2.3401, 2) returns 2.34

ROUND (2.3461, 2) returns 2.35

ROUND (TO_DATE(’27-OCT-1992’, ’DD-MON-YYYY’), ’YEAR’) returns 01-JAN-1993

ROUNDUP

ROUNDUP(n [, m])
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ROUND_UP(n [, m])

The ROUNDUP function rounds a numeric value n up to m decimal places. The first
operand is the value to be rounded up, the second the number of places to round to. If
the digits after the rounding point are zero, the value is unchanged. If the digits are not
zero, the value is incremented at the rounding point.

Examples:

ROUND_UP(2.3401, 2) returns 2.35

ROUND_UP(2.3400, 2) returns 2.34.

TRUNC

TRUNC(n [, m])

TRUNCATE(n [, m])

The TRUNC function rounds a numeric value n down to m decimal places. The first
operand is the value to be rounded down, the second the number of places to round
to. TRUNC also returns n with the time portion of the day truncated to the unit specified
by the format model of m. If you omit m, d is truncated to the nearest day The default
model, ’DD’, returns the date rounded or truncated to the day with a time of midnight.

Oracle FastFormula drops all digits (if any) after the specified truncation point.

Examples:

TRUNC(2.3401, 2) returns 2.34.

TRUNC(TO_DATE(’27-OCT-1992’, ’DD-MON-YYYY’), ’YEAR’) returns 01-JAN-1992

Date Functions

ADD_DAYS

ADD_DAYS(date, n)

The ADD_DAYS function adds a number of days to a date. The resulting date accords
with the calendar.

Note: Oracle FastFormula ignores any fractional part of the number n.

Example:

ADD_DAYS (’30-DEC-1990’ (date), 6) returns 5 JAN 1991

ADD_MONTHS

ADD_MONTHS(date, n)

The ADD_MONTHS function adds a number of months to a date. The resulting date
accords with the calendar.

Note: Oracle FastFormula ignores any fractional part of the number n.

ADD_YEARS

ADD_YEARS(date, n)
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The ADD_YEARS function adds a number of years to a date. The resulting date accords
with the calendar.

Note: Oracle FastFormula ignores any fractional part of the number n.

GREATEST

GREATEST(date1, date2[, date3] . . .)

The GREATEST function compares all the operands and returns the latest date.

LAST_DAY

LAST_DAY(d)

The LAST_DAY function returns the date of the last day of the month that contains
d. You might use this function to determine how many days are left in the current month.

LEAST

LEAST(date1, date2 [, date3] . . .)

The LEAST function compares all the operands and returns the earliest date.

DAYS_BETWEEN

DAYS_BETWEEN(date1, date2)

The DAYS_BETWEEN function returns the number of days between two dates. If the
later date is first, the result is a positive number. If the earlier date is first, the result is a
negative number. The number returned is also based on the real calendar.

Note: The result is a numeric data type.

Example:

DAYS_BETWEEN(’1995/06/27 00:00:00’ (date), ’1995/07/03 00:00:00’ (date)) returns -5

MONTHS_BETWEEN

MONTHS_BETWEEN(date1, date2)

The MONTHS_BETWEEN function returns the number of months between two dates. If
the later date is first, the result is a positive number. If the earlier date is first, the result is
a negative number. The number returned is also based on the real calendar.

If the result is not a whole number of months (that is, there are some days as well), the
days part is shown as a decimal.

Note: The result is a numeric data type.

NEW_TIME

NEW_TIME(d, zl, z2)

Returns the date and time in zone z2 when the date and time in zone z1 are d. The
arguments z1 and z2 can be any one of these text strings:
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AST or ADT Atlantic Standard or Daylight Time

BST or BDT Bering Standard or Daylight Time

CST or CDT Central Standard or Daylight Time

EST or EDT Eastern Standard or Daylght Time

GMT Grenwich Mean Time

HST or HDT Alaska-Hawaii Standard Time or Daylight
Time

MST or MDT Mountain Standard or Daylight Time

NST Newfoundland Standard Time

PST or PDT Pacific Standard or Daylight Time

YST or YDT Yukon Standard or Daylight Time

NEXT_DAY

NEXT_DAY(d, expr)

The NEXT_DAY function returns the date of the first weekday named by expr that is later
than the date d. The argument expr must be a day of the week in your session’s date
language. The return value has the same hours, minutes, and seconds component as
the argument d.

Data Conversion Functions
Use data conversion functions to convert from one data type to another data type. For
example, you could have an expression returning a number value for salary, which you
want to include in a printed message (that is, a character value). To print the number
as part of the message, you need to convert the value of salary from a number to a
character value, using the TO_TEXT function.

CONVERT

(expr, dest_char_set [,source_char_set])

The CONVERT function converts a character string from one character set to
another. The expr argument is the value to be converted. The dest_char_set argument is
the name of the character set to which expr is converted. The source_char_set argument
is the name of the character set in which expr is stored in the database. The default
value is the database character set.

INSTR

(expr1,expr2[,n[,m]])

The INSTR function searches expr1 beginning with its nth character for the mth
occurrence of expr2 and returns the position of the character in expr1 that is the first
character of this occurrence. If n is negative, Oracle FastFormula counts and searches
backwards.
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NUM_TO_CHAR

NUM_TO_CHAR(n, format)

Converts the number n from number data type to text data type using the specified
format. This function is equivalent to the SQL TO_CHAR function. For example:

NUM_TO_CHAR(amount, ’$9,990.99’)

This returns the amount with a leading dollar sign, commas every three digits, and two
decimal places. Refer to the SQL Language Reference Manual for a full list of the valid
number formats you can specify.

TO_DATE

TO_DATE (expr [, format])

Converts the expression expr of text data type to a date data type. The text expression
must be of the form ’YYYY/MM/DD HH24:MI:SS’ if no format is provided. The day
and year must be in numeric form. For example:

/* legal */

date_1 = TO_DATE (’12 January 89’, ’DD Month YY’)

/* illegal */

date_1 = TO_DATE (’12 January Nineteen-Eighty-Nine’,

’DD Month Year’)

Note: When assigning date variables from constants it is much more
efficient to say:

date_1 = ’1989/01/12 00:00:00’(date)

Note: The text expression must be in the format of either
YYYY/MM/DD HH24:MI:SS or DD-MON-YYYY if no format is
provided.

TO_NUMBER

TO_NUM(expr)

TO_NUMBER(expr)

Converts the expression expr of text data type to a number data type. The expression
must represent a valid number. So for example, you cannot convert an expression such
as ‘Type 24’ but you can convert the text expression ‘1234’. For decimal values, you must
always use a period as a decinal point, for example ’4.5’.
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TO_TEXT

TO_TEXT(n) TO_TEXT (date1 [, format])

TO_CHAR(n) TO_CHAR(date1 [, format])

DATE_TO_TEXT(n) (date1 [, format])

The TO_TEXT function converts:

• the number n from number data type to text data type. The default number format
has the decinal point as a period, for example ’4.5’.

• the date date1 from date data type to text data type. The optional format should
be a text string like ’DD/MM/YYYY’. The default format is ’YYYY/MM/DD
HH24:MI:SS’.

For example:

birthdate = ’21-JAN-1960’ (date)

mesg = ’Birthdate is: ’ + TO_CHAR (birthdate)

/* sets mesg to ’Birthdate is: 1960/01/21 00:00:00’ */

mesg = ’Birthdate is: ’ + TO_CHAR (birthdate,

’DD-MON-YY’)

/* sets mesg to ’Birthdate is: 21-JAN-60’ */

mesg = ’Birthdate is: ’ + TO_CHAR (birthdate,

’DD Month Year’)

/* sets mesg to ’Birthdate is: 21 January Nineteen-Sixty’ */

Functions to Get Values From Tables

GET_LOOKUP_ MEANING

GET_LOOKUP_MEANING(lookup_type , lookup_code)

The GET_LOOKUP_MEANING function enables Oracle FastFormula to translate a
lookup code into a meaning. This can be used for any descriptive flexfield items or
developer flexfield items that are based on lookups.

Example:

GET_LOOKUP_MEANING (’ETH_TYPE’, PEOPLE_GB_ETHNIC_ORIGIN)
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GET_TABLE_VALUE

GET_TABLE_VALUE(table_name, column_name, row_value [,effective date])

The GET_TABLE_VALUE function returns the value of a cell in a user-defined
table. The three text operands, which identify the cell (table_name, column_name, and
row_value), are mandatory. The date operand is optional. If it is not supplied, the
function returns the cell value as of the effective date.

You cannot use this function in formulas for user table validation or QuickPaint reports.

Example:

GET_TABLE_VALUE(’WAGE RATES’, ’Wage Rate’, Rate_Code)

RAISE_ERROR

RAISE_ERROR(application_ID, message name)

This function allows you to raise a functional error message from within a formula. It
accepts an Application ID and the message_name of an Oracle Applications error
message to raise.

Example:

ERROR = RAISE_ERROR(800, ’error_name’)

RATES_HISTORY

RATES_HISTORY(element or rate type name, date, element or rate type indicator, time
dimension)

This function uses information stored in the UK Element Attribution Information EIT
and information about the assignment’s contract type to calculate a payment rate as
of the given date and expressed for the selected time dimension (such as hourly or
annual). If the element or rate type indicator is R, the function sums the rates for all
elements classified with the given rate type (which is stored against the element in
the Rate Type Information EIT).

The time dimension parameter must be A (annual), D (daily), H (hourly), or P
(periodic). The element or rate type parameter must be R (rate type) or E (element).

The function can also adjust the returned rate for FTE and length of service, if these
factors are set to Yes in the Element Attribution Information.

Functions for Accrual Type Formulas
In addition to the standard FastFormula functions, you may find the following functions
useful for your Accrual and Carry Over formulas.
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CALCULATE_PAYROLL_PERIODS

This function takes no parameters; it uses the payroll id context. It calculates the
number of payroll periods in one year for that payroll, and sets the global variable
PAYROLL_YEAR_NUMBER_OF_PERIODS to that value. For example, the function
would set the global variable to 12 for a calendar month payroll.

Example:

E = CALCULATE_PAYROLL_PERIODS

GET_ABSENCE

GET_ABSENCE(calculation date, start date)

This function calculates the total amount of absence contributing to an accrual plan
between two dates. It counts the whole of any absence that:

• has a start date and an end date, and

• starts on or between the two dates given as inputs

Example:

TOTAL_ABSENCE = GET_ABSENCE(’01-JAN-1999’(date), ’31-D EC-1999’(da
te))

GET_CARRY_OVER

GET_CARRY_OVER(calculation date, start date)

This function returns the number of days or hours recorded on the Carry Over element
entry with an effective date on or between the two input dates. If more than one element
entry is effective between these dates, the function sums the hours or days.

Carry Over element entries may also have an expiry date, after which any unused
carry over is lost. If the calculation date is after the expiry date, the function checks the
absences taken between start and calculation date. If the person took absences totaling
the carry over, the function returns total carry over because it was all used before it
expired. If absences total less than the carry over, the function returns total absence time;
the rest of the carryover is lost.

For example, if the carry over is 10 days and 6 days absence were taken up to the expiry
date, the function returns 6. The other four days of carry over have expired and been lost.

GET_NET_ACCRUAL

GET_NET_ACCRUAL(calculation date, plan id, accrual start date, accrual latest balance)

This function calls the accrual formula defined in the accrual plan to return the net accrual
at the calculation date. The following contexts must be available to a formula calling this
function: assignment id, payroll id, business group id, and assignment action id.

GET_OTHER_NET_CONTRIBUTION

GET_OTHER_NET_CONTRIBUTION(calculation date, start date)
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This function calculates the total amount of net contribution other than absences or carry
over between two dates. It looks for element entries for all elements that have been
added in the Net Calculation Rules window. It sums the days or hours from all entries
with an effective date on or between the two input dates.

GET_PAYROLL_PERIOD

GET_PAYROLL_PERIOD(date)

This function determines the payroll period spanning the input date and sets global
variables containing the start and end date and the period number. It returns 0 if
successful, and otherwise error.

This example shows how to use this function then use the GET_DATE and
GET_NUMBER functions to retrieve the values it sets in the global variables:

E = GET_PAYROLL_PERIOD(Calculation_date)

Calculation_Period_SD = GET_DATE(’PAYROLL_PERIOD_STAR T_DATE’)

Calculation_Period_ED = GET_DATE(’PAYROLL_PERIOD_END_ DATE’)

Calculation_Period_PNUM = GET_NUMBER(’PAYROLL_PERIOD_ NUMBER’)

GET_ACCRUAL_BAND

GET_ACCRUAL_BAND(number)

This function determines the appropriate accrual band for the specified length of
service. It sets global variables containing the ANNUAL_RATE, UPPER_LIMIT and
CEILING values for the band. ANNUAL_RATE is the amount that should accrue this
accrual term. UPPER_LIMIT is the length of service that must be completed for the
employee to go to the next accrual band. CEILING is the maximum number of hours
or days the employee can accrue at any time. The function returns 0 if successful, and
otherwise error.

This example shows how to use this function then use the GET_NUMBER function to
retrieve the values it sets in the global variables:

IF (GET_ACCRUAL_BAND(Years_Service) = 0 THEN

(

Annual_Rate = GET_NUMBER(’ANNUAL_RATE’)

Upper_Limit = GET_NUMBER(’UPPER_LIMIT’)

Ceiling = GET_NUMBER(’CEILING’)

ELSE

( ... [processing for error] ....)

)
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GET_ASSIGNMENT_STATUS

GET_ASSIGNMENT_STATUS(date)

This function determine the assignment status at a given date. It populates the
globals ASSIGNMENT_EFFECTIVE_SD, ASSIGNMENT_EFFECTIVE_ED and
ASSIGNMENT_SYSTEM_STATUS. It returns 0 if successful, and otherwise error.

Example:

ERROR = GET_ASSIGNMENT_STATUS(’01-JAN-1999’(date))

GET_ASG_INACTIVE_DAYS

GET_ASG_INACTIVE_DAYS(period start date, period end date)

This function checks the assignment status on each day from period start date to period
end date. It calls the function GET_WORKING_DAYS to calculate the total number of
working days in the period (Mondays to Fridays) and subtracts the number of working
days when the assignment was inactive. It returns the number of inactive working days.

GET_PERIOD_DATES

GET_PERIOD_DATES(date1, unit, date2, number)

This function determines the start and end dates of a period of time with the duration
specified by the unit input and the number (such as 2 months). Valid units are D
(days), M, (months), and W (weeks). The period spans date1 and starts on a date that is a
multiple of the unit duration on from date2 (or backwards from date2).

The function populates the globals PERIOD_START_DATE and PERIOD_END_DATE. It
returns 0 if successful, and otherwise error.

Example:

Error = GET_PERIOD_DATES(’1-FEB-1999’(date), ’M’, ’15-D EC-1998’(d
ate), 1)

This example populates PERIOD_START_DATE with 15-JAN-1999 and
PERIOD_END_DATE with 14-FEB-1999.

An example where the period starts before date2:

Error = GET_PERIOD_DATES(’1-FEB-1999’(date), ’M’, ’15-A PR-1999’(d
ate), 2)

This example populates PERIOD_START_DATE with 15-JAN-1999 and
PERIOD_END_DATE with 14-MAR-1999.

GET_START_DATE

GET_START_DATE(accrual start date, start of accrual term)

This function returns the date at which the accrual formula should start calculating
accruals.

• If there is no payroll balance holding gross accruals, the date is always the start of
the accrual term.

1-42 Oracle Human Resources Management Systems FastFormula User Guide



• If there is a payroll balance and there are retrospective absence entries that have not
already been used in an accrual calculation, the function returns the start date of
the earliest of these entries.

• If there is a payroll balance and there are no unprocessed retrospective absence
entries, the function returns accrual start date.

This date, which is passed into the accrual formula, is the day after either the Date
Earned or the Date Paid of the last payroll period in which the assignment was
processed--depending on the PTO Balance Type set for the business group.

Note: Although GET_START_DATE returns the start date of the earliest
of any unprocessed retrospective element entries, this date is not
currently used in the seeded accrual formulas. If GET_START_DATE
finds any unprocessed retrospective element entries, the formula always
calculates accruals from the beginning of the accrual term.

GET_WORKING_DAYS

GET_WORKING_DAYS(start date, end date)

This function returns the number of working days (Mondays to Fridays) in the period
from start date to end date.

PUT_MESSAGE

PUT_MESSAGE(expr)

This function adds a message to the stack to be output at the end of the formula by
the Accruals form.

Example:

E = PUT_MESSAGE(’The assignment is not yet eligible for accr ual’)

Functions to Call a Formula
These functions allow you to call another formula, either once or in a loop. They require
all the contexts available to the Accruals formula type.

CALL_FORMULA

CALL_FORMULA(formula name)

This function runs a named formula with no inputs and no outputs.

LOOP_CONTROL

LOOP_CONTROL(formula name)

This function repeatedly calls another formula, which must have the return parameter
’CONTINUE_LOOP’. The loop continues until the function detects a value other than
’Y’ in CONTINUE_LOOP. If it detects ’N’, the function returns 0 (success); if it detects
another value, the function returns 1 (error).
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Functions to Set and Get Globals
Using the following functions, you can set and use globals in SQL*Plus from within
your formulas.

SET_TEXT, SET_NUMBER, SET_DATE

SET_TEXT(variable name, value)

SET_NUMBER(variable name, value)

SET_DATE(variable name, value)

These functions accept the name of a global variable and the value to be set. They
determine whether the global exists and, if not, create a new global. They return 0 if
successful and 1 if not successful.

Examples:

E = SET_NUMBER(’UPPER_LIMT’, 0)

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’, service_start_ date)

GET_TEXT, GET_NUMBER, GET_DATE

GET_TEXT(variable name)

GET_NUMBER(variable name)

GET_DATE(variable name)

These functions accept the name of a global variable and return its value. If they cannot
find the global, they return NULL.

Example:

Calculation_Period_SD = GET_DATE(’PAYROLL_PERIOD_STAR T_DATE’)

CLEAR_GLOBALS

This function sets to NULL the value of all global variables that were set using
SET_TEXT, SET_NUMBER, and SET_DATE. There are no inputs. It returns 0 if successful
and 1 if not successful.

REMOVE_GLOBALS

This function removes all global variables. There are no inputs. It returns 0 if successful
and 1 if not successful.

ISNULL

ISNULL(variable name)

A set of three functions that test whether a text, numeric, or date value is NULL. Returns
Y if the value is NULL and N otherwise.

Example:
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IF IS_NULL(VARIABLE_NAME) = ’Y’ THEN

ERROR = SET_NUMBER(VARIABLE_NAME, 0)

Comments
A formula may contain any number of comments, which can be placed anywhere in
the formula.

Comments start with the sequence /* (slash asterisk), and finish with */ (asterisk
slash). Oracle FastFormula ignores all text within these comment delimiters.

Caution: Do not put a comment within a comment. This causes Oracle
FastFormula to return a syntax error.

Statements
Statements are instructions that Oracle FastFormula carries out. There are six types of
statement you can use:

• Alias statement

• Assignment statement

• Default statement

• If statement

• Inputs statement

• Return statement

An If statement can have Assignment, Return, and other If statements nested within
it, enabling you to build up powerful formulas.

Order of Statements
1. Alias statements (if any)

2. Default statements (if any)

3. Input statement (if any)

4. Other statements

Alias Statement
The format of the Alias statement is:

ALIAS varname1 AS varname2

where varname1 is the name of an existing database item or global value, and varname2
is a unique name not currently known to the system nor used previously in your formula.

Use the Alias statement to define another name, or alias, for existing variables in the
system. You can declare aliases for database items and global values.
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Alias statements must appear before any other statements in a formula.

Default Statement
The format of the Default statement is:

DEFAULT FOR <varname> IS <constant>

where varname is an input value or database item, and constant is a constant value
matching the data type of varname.

Use the Default statement to set a default value for an input value or database item. The
formula uses the default value if the database item is empty or the input value is not
provided when you run the formula.

You can use the Default statement with the ’WAS DEFAULTED’ test to detect when a
default value has been used. For example:

DEFAULT FOR hourly_rate IS 3.00

X = hours_worked * hourly_rate

IF hourly_rate WAS DEFAULTED

THEN

MESG = ’Warning: hourly rate defaulted’

This example sets a default of 3.00 for the database item hourly_rate. If hourly_rate is
empty (NULL) in the database, the formula uses the default value of 3.00 and issues a
warning message.

Important: You must use the Default statement for database items that
can be empty. The Database Items window includes a check box labelled
Default Required. This check box is checked for database items that
can be empty. The Database Items window appears when you click the
Show Items button on the Formulas window.

Inputs Statement
The format of the Inputs statement is:

INPUTS ARE varname1(data type)[, varname2 (data type)] ...

Use the Inputs statement to pass input values from an element into a formula.

For example,

INPUTS ARE bonus (number),
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start_date (date)

You do not need to declare the type of number variables because this is the default data
type. You can define up to 15 input values for an element.

The Inputs statement must appear before the other formula statements except:

• any Alias statements, which must always be at the top of the formula

• any Default statements that provide default values for input values

Input Variables or Database Items

Always use the Inputs statement to retrieve the input values of the element associated
with the formula. Using a database item forces the formula to execute the code and work
out the path to retrieve the database item.

For example, the formula below:

INPUTS ARE wage_rate,

hours_worked

wage = wage_rate * hours_worked

RETURN wage

is more efficient than the second formula:

wage = wage_wage_rate * wage_hours_worked

RETURN wage

Assignment Statement
Use the Assignment statement to set a value for a local variable. The format of the
Assignment statement is:

varname = expression

For example:

rate = hourly_rate + 14

wage = hours_worked * rate

Oracle FastFormula evaluates the expression on the right hand side of the statement, and
places its result in the variable you name on the left hand side. The left side of an
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Assignment statement must always be a local variable because a formula can only
change the value of local variables.

IF Statement
Use the If statement to check a condition that controls whether a sequence of statements
is executed.

There are two clauses in the If statement: the THEN and ELSE clauses.

• The THEN clause lets you define what to do if the conditions are true.

• The ELSE clause lets you define what to do if the conditions are not true.

The If statement is the only statement that can have other statements nested within
it, including other IF statements.

Format of Statement

The format of the If statement is:

IF [NOT] condition

[logical operator] [NOT] condition

THEN

statement [statement ..]

ELSE

statement [statement ..]

The If statement can consist of a single condition, or two or more conditions combined
with logical operators. The logical operators are AND, OR and NOT. The first two
combine the conditions logically, and the third negates a condition:

• The AND operator means that if both conditions are true, then their combination
is true.

• The OR operator means that if either condition is true, then their combination is true.

• If the NOT operator precedes a condition, this inverts the truth of the condition. That
is, if condition X is true, then NOT X is false.

Format of Conditions

A condition itself has a valid format. This is:

expression comparator expression

The values represented by each expression are compared together in the way described
by the comparator. The two expressions must both return the same data type. There
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are eight comparators, and the way they work depends upon the data type of the
values they are comparing.

Comparator Symbols Data Types Meaning

Equals = All The condition is true
if both expressions
have exactly the same
value. For text, the
case of the expression
must be the same. So,
for example, ’Smith’ is
not equal to ’SMITH’.

Not Equal to !=

<>

><

All The condition is true
if the result of the first
expression does NOT
have the same value
as the result of the
second expression.

Greater than > All The condition is true if
the first expression is
alphabetically after, or
has a numerically
greater value, or a
later date than the
second expression.

Less than < All The condition is true if
the first expression is
alphabetically before,
or has a numerically
smaller value, or an
earlier date than the
second expression.

Greater than or equal
to

>=

=>

All The condition is true
if either the greater
than OR the equal to
comparator returns a
true result.

Less than or equal to <=

=<

All The condition is true if
either the less than
OR the equal to
comparator returns
a true result.
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Comparator Symbols Data Types Meaning

Like LIKE Text The condition is
true if the two text
expressions match
according to the
rules of the LIKE
syntax. You can
include Wildcards
in the text to allow
searching for text that
matches a pattern, or
words that begin with
a certain sequence of
letters.

- percent sign (%)
matches any number
of characters in that
position

- underscore (_)
matches a single
character occurrence
in that position.

Not Like NOT LIKE Text The condition is
true if the two text
expressions do NOT
match according to
the rules of the LIKE
syntax.

There is a special comparator called WAS DEFAULTED that you can use to test database
items and input values. If there is no value available for an input value or database
item, the formula uses a default value. The condition containing the WAS DEFAULTED
comparator is True if a default value was used. For example:

DEFAULT FOR employee_middle_name IS ’ ’

IF employee_middle_name WAS DEFAULTED

THEN

/* special processing */

Correct Use of Brackets

If you group more than one statement under the THEN or ELSE clauses, enclose the
group of statements within brackets, that is ( and ). In the absence of brackets, Oracle
FastFormula conditionally executes only the statement that immediately follows the
THEN or ELSE clause. Any other statements are executed unconditionally. For
example, when the following formula runs, High_salary is always set to Y:
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High_salary = ’N’

IF Salary > 20000

THEN Tax = Salary * .25

High_salary = ’Y’

To prevent this, use brackets as follows:

High_salary = ’N’

IF Salary > 20000

THEN

(

Tax = Salary * .25

High_salary = ’Y’

)

Return Statement
Use the Return statement to return values in local variables to the application. Oracle
FastFormula can pass back any number of variables. The variable does not need to
contain a value.

Example:

/* Formula: LONDON ALLOWANCE FORMULA */

INPUTS ARE this_months_extra (number)

London_allowance = (grade_pay/20 + this_months_extra)

RETURN London_allowance

Notice that you do not have to declare the data type of local variables in the Return
statement (as the formula already knows the data type).
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Oracle FastFormula stops executing the formula when it reaches the Return
statement. Any statements after the Return statement are ignored.

Formula Compilation
When you have created or edited a formula in the Formula window, you choose the
Verify button to compile it.

If you need to compile many formulas at the same time, you can run the Bulk Compile
Formulas process in the Submit Requests window. For example, you run this process
when you upgrade your legislative information, which includes formulas.

Note: If you make any changes to a function after you have compiled a
formula that uses it, you need to recompile the formula for the changes
to take effect.

Formula Errors
There are two types of error that can occur when using Oracle FastFormula:

• Verify-time errors occur in the Formulas window when you run the formula
verification. An error message explains the nature of the error.

Common verify-time errors are syntax errors resulting from typing mistakes.

• Run-time errors occur when a problem arises while a formula is running. The usual
cause is a data problem, either in the formula or in the application database.

The basic Oracle FastFormula errors that can occur at run-time are:

• Uninitialized Variables: An uninitialized local variable is one that has no value
when the formula runs. The term ’uninitialized’ means you have not assigned any
value to the variable before you try to use it. This causes an error in all statements
except the Return statement. For example:

IF (tax_band < 2000)

THEN tax = salary / 8

IF (tax_band > 2000)

THEN tax = salary / 10

IF tax > 1000

THEN ...

This formula fails with an ’Uninitialized variable’ message (for the variable tax)
if the tax band is set to 2000.
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• Divide by Zero: Dividing a number by zero is an operation that provides no logical
result. If this situation ever arises, Oracle FastFormula passes a code back to the
application indicating an error (the application then takes the appropriate action).

Always check for the possibility of a divide by zero error if there is any chance it
could occur. For example, the formula:

x = salary/contribution_proportion

produces an error if the contribution proportion is set to zero. In this formula, check
for the divide by zero condition as follows:

IF contribution_proportion = 0

THEN (message = ’The contribution proportion is not

valid.’ RETURN message)

ELSE x = salary/contribution_proportion

• No Data Found: A database item supposed to be in the database was not found. This
represents an error in the application data.

• Too Many Rows: The database item definition within the application caused more
than one value to be fetched from the database.

• Value Exceeded Allowable Range: This can occur for a variety of reasons such as:

• exceeding the maximum allowable length of a string (which is 240 characters)

• rounding up a number to an excessive number of places, for example, round
(1,100)

• using an invalid date, for example, 39-DEC-1990.

• Invalid Number: This occurs only when a database item contains an item that does
not make sense as a number.

• Null Data Found: A database item was found to have a null value when it should
have had a non-null value. Use the Default statement for database items marked
as Default Required in the Database Items window.

Database Items
This topic lists the database items available to you in Oracle HRMS for writing formulas
and defining QuickPaint reports. The database items are grouped into two listings:

• Static Database Items, page 1-54

• Dynamic Database Items, page 1-73

Static database items are shipped with the system and you cannot modify them. Dynamic
database items are created by Oracle HRMS processes whenever you define new
elements or other related entities.
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Static Database Items
Static database items are shipped with the system and you cannot modify them.

Accrual Plan Information

Database item Description

ACP_CARRIED_OVER_DATE The effective date stored in the latest Carry
Over element entry for the assignment and
accrual plan

ACP_CARRIED_OVER_PTO The amount of PTO stored for an assignment
in the latest Carry Over element entry

ACP_CATEGORY The category of accrual plan

ACP_CONTINUOUS_SERVICE_DATE An employee’s adjusted service date

ACP_ENROLLMENT_END_DATE The end date of an employee’s enrollment in
the accrual plan

ACP_ENROLLMENT_START_DATE The start date of an employee’s enrollment in
the accrual plan

ACP_INELIGIBLE_PERIOD_LENGTH The length of the plan’s ineligibility period (a
number)

ACP_INELIGIBLE_PERIOD_TYPE The units (e.g. months) for measuring the
length of the plan’s ineligibility period

ACP_NAME The name of the accrual plan

ACP_SERVICE_START_DATE The start date of an employee’s period of
service

ACP_START The rule for determining the start date for new
hires in the plan

ACP_TERMINATION_DATE The end date of an employee’s period of service

ACP_UOM The units (hours or days) for accumulating
PTO

PTO_ACCRUAL_PLAN_ID The id of the accrual plan.

PTO_DATE_PAID_CALCULATION_DATE The last day of the period for calculating
accruals in the payroll run (when the PTO
Balance Type for the business group is Date
Paid)

PTO_DATE_EARNED_CALCULATION_
DATE

The last day of the period for calculating
accruals in the payroll run (when the PTO
Balance Type for the business group is Date
Earned)
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Database item Description

PTO_DATE_PAID_START_DATE The first day of the period for calculating
accruals in the payroll run (when the PTO
Balance Type for the business group is Date
Paid)

PTO_DATE_EARNED_START_DATE The first day of the period for calculating
accruals in the payroll run (when the PTO
Balance Type for the business group is Date
Earned)

Applicant Information

Database item Description

APL_DATE_END The date the application ended

APL_DATE_RECEIVED The date the application was received

Assignment Address Detail (US/UK only)

Database item Description

PER_ADR_UK_COUNTY The assignment’s home county (UK only)

PER_ADR_US_COUNTY The assignment’s county (US only)

PER_ADR_US_STATE The assignment’s state (US only)

PER_ADR_US_STATE_CODE The assignment

FastFormula 1-55



Contact Addresses

Database item Description

CON_ADR_CITY The name of the contact’s town or city

CON_ADR_COUNTRY The name of the contact’s country

CON_ADR_DATE_FROM The first date on which the contact can be
contacted

CON_ADR_DATE_TO The last date on which the contact can be
contacted

CON_ADR_LINE_1 The first line of the contact’s address

CON_ADR_LINE_2 The second line of the contact’s address

CON_ADR_LINE_3 The third line of the contact’s address

CON_ADR_PHONE_1 The contact’s first telephone number

CON_ADR_PHONE_2 The contact’s second telephone number

CON_ADR_PHONE_3 The contact’s third telephone number

CON_ADR_POSTAL_CODE The contact’s postal code

CON_ADR_REGION_1 The first line of the contact’s region

CON_ADR_REGION_2 The second line of the contact’s region

CON_ADR_REGION_3 The third line of the contact’s region

Contact Information

Database item Description

CON_AGE The contact’s age

CON_APP_NUMBER The contact’s applicant number

CON_BENEFICIARY_FLAG The contact’s beneficiary flag

CON_CURRENT_APP Whether the contact is a current applicant
(yes/no)

CON_CURRENT_EMP Whether the contact is a current employee
(yes/no)

CON_CURRENT_CWK Whether the contact is a current contingent
worker (yes/no)

CON_CWK_NUMBER The contact’s contingent worker number

CON_DATE_END The end date of the contact’s relationship
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Database item Description

CON_DATE_START The start date of the contact’s relationship

CON_DATE_OF_BIRTH The contact’s date of birth

CON_DEPENDENT_FLAG The contact’s dependent flag

CON_DISABLED Whether the contact is disabled (yes/no)

CON_EMP_NUMBER The contact’s employee number

CON_END_DATE The date to which this contact information is
effective

CON_END_LIFE_REASON_ID ID for the reason for the end of the relationship

CON_FIRST_NAME The contact’s first name

CON_FULL_NAME The contact’s full name

CON_KNOWN_AS The contact’s preferred name

CON_LAST_NAME The contact’s last name

CON_MARITAL_STATUS The contact’s marital status

CON_MIDDLE_NAMES The contact’s middle names

CON_NATIONAL_IDENTIFIER The contact’s national identifier

CON_NATIONALITY The contact’s nationality

CON_PERSONAL_FLAG Personal relationship flag

CON_PERSON_TYPE The contact’s person type - employee or
applicant, for example

CON_RLTD_PER_RSDS_W_DSGNTR Whether the contact shares the same residence
as the employee.

CON_RELATIONSHIP The relationship of the contact to the employee

CON_SEQUENCE_NUMBER Contact’s sequence number

CON_SEX The contact’s sex

CON_START_DATE The date from which this contact information
is effective

CON_START_LIFE_REASON_ID ID for reason for the start of the relationship

CON_THIRD_PARTY_PAY_FLAG Third party payments relationship flag
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Database item Description

CON_TITLE The contact’s title

CON_WORK_PHONE The contact’s work telephone number

Contingent Worker

Database item Description

CWK_START_DATE The contingent workers’s start date

CWK_END_DATE The contingent worker’s end date

CWK_PROJ_END_DATE The contingent worker’s projected end date

CWK_LEAVING_REASON The reason the contingent worker left

CWK_LEAVING_REASON_CODE The code of the reason the contingent worker
left

Contracts Information

Database item Description

CTR_STATUS_MEANING Contract status meaning

CTR_TYPE_MEANING Contract type meaning

CTR_STATUS Contract status code

CTR_TYPE Contract type code

Date Information

Database item Description

SESSION_DATE The effective date from FND_SESSIONS

SYSDATE The system date
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Element Type Details

Database item Description

CURRENT_ELEMENT_TYPE_ID The type ID of the element being processed

ELEMENT_NAME The name of the element being processed

ENTRY_END_DATE The end date of the original entry

ENTRY_START_DATE The start date of the original entry

Employee Assignment Information

Database item Description

ASG_ASSIGNMENT_CATEGORY The category for the assignment

ASG_ASSIGNMENT_SEQUENCE This is used as a default for assignment number

ASG_BARGAINING_UNIT_CODE The employee’s bargaining unit code

ASG_CHANGE_REASON The change reason for the assignment

ASG_DATE_FROM The date from which this assignment
information is effective

ASG_DATE_TO The date to which this assignment information
is effective

ASG_EMPLOYMENT_CATEGORY The employment category for the assignment

ASG_EMPLOYMENT_CATEGORY_CODE The employment category code for the
assignment

ASG_END_TIME The standard end time for the assignment

ASG_FREQ The frequency for which the assignment
working hours are measured

ASG_FREQ_CODE The working hours frequency code for the
assignment

ASG_FTE_VALUE The full-time equivalent budget actual value
for the assignment

ASG_FULL_TIME_FREQ The full-time frequency for the assignment

ASG_FULL_TIME_HOURS The full-time working hours for the assignment

ASG_GRADE The employee’s grade

ASG_GRADE_DATE_FROM The date from which this assignment grade
information is effective
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Database item Description

ASG_GRADE_DATE_TO The date to which this assignment grade
information is effective

ASG_GROUP The employee’s group

ASG_HEAD_VALUE The head budget value for the assignment

ASG_HOURS The standard number of working hours for the
assignment

ASG_INT_ADDR_LINE The internal address of the assignment

ASG_JOB The employee’s job

ASG_JOB_DATE_FROM The date from which this assignment job
information is effective

ASG_JOB_DATE_TO The date to which this assignment job
information is effective

ASG_LABOUR_UNION_MEMBER_FLAG Whether the assignment is a union member

ASG_LAST_CHANGE_REASON The reason the salary was changed

ASG_LAST_EARNED_PAYROLL_NAME The payroll name the assignment was last
processed with as at the date earned

ASG_LAST_EARNED_PERIOD_ID The time period ID the assignment was last
processed with as at the date earned

ASG_LAST_EARNED_PERIOD_NAME The time period name the assignment was last
processed with as at the date earned

ASG_LAST_EARNED_PERIOD_NUMBER The time period number the assignment was
last processed with as at the date earned

ASG_LAST_PERFORMANCE_DATE Last performance review date

ASG_LAST_PERFORMANCE_LOCATION Last performance review location

ASG_LAST_PERFORMANCE_RATING Last performance review rating

ASG_LAST_PERFORMANCE_TYPE Last performance review type

ASG_LAST_PROC_PAYROLL_NAME The payroll name the assignment was last
processed

ASG_LAST_PROC_PERIOD_ID The time period ID the assignment was last
processed

ASG_LAST_PROC_PERIOD_NAME The period name the assignment was last
processed

ASG_LAST_PROC_PERIOD_NUMBER The period number the assignment was last
processed
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Database item Description

ASG_LAST_PROPOSED_SALARY_
CHANGE

The proposed salary change

ASG_LAST_PROPOSED_SALARY_
PERCENT

The proposed salary change as a percentage

ASG_LAST_SALARY_CHANGE_AP
PROVED

Whether the last proposed salary change has
been approved

ASG_LAST_SALARY_DATE The last salary change date

ASG_LOCATION The employee’s location

ASG_LOC_INACTIVE_DATE The date to which the location information is
effective

ASG_MANAGER Whether the assignment is a managerial
assignment (yes/no)

ASG_MONEY_VALUE The assignment’s money budget actual value

ASG_NEXT_PERFORMANCE_DATE Next performance review date

ASG_NEXT_SALARY_DATE The date of the next salary change

ASG_NUMBER The assignment number

ASG_ORG The employee’s organization

ASG_ORG_DATE_FROM The date from which assignment organization
information is effective

ASG_ORG_DATE_TO The date to which assignment organization
information is effective

ASG_ORG_INT_EXT The assignment organization internal external
flag

ASG_ORG_LOCATION The location of the assignment organization

ASG_ORG_TYPE The assignment organization type

ASG_PAYROLL The employee’s payroll

ASG_PERFORMANCE_REVIEW_
FREQUENCY

The performance review period for the
assignment

ASG_PERFORMANCE_REVIEW_PERIOD The performance review frequency for the
assignment

ASG_PER_STATUS_DP Personal status for the assignment (as of Date
Paid)

ASG_PFT_VALUE The PFT budget value for the assignment
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Database item Description

ASG_POS_HOURS The standard number of working hours for the
position

ASG_POSITION The employee’s position

ASG_POS_DATE_FROM The date from which this assignment position
information is effective

ASG_POS_DATE_TO The date to which this assignment position
information is effective

ASG_POS_END_TIME The standard end time for the assignment
position

ASG_POS_FREQ The frequency for which the assignment
position’s hours are measured

ASG_POS_FREQUENCY The frequency for which the assignment
position’s hours are measured

ASG_POS_FTE The assignment position FTE

ASG_POS_LOCATION The location of the assignment position

ASG_POS_PROB_PERIOD The probation period for the assignment
position (in numeric format)

ASG_POS_PROBATION_PERIOD The probation period for the assignment
position (formatted as text)

ASG_POS_PROBATION_PERIOD_UNITS The units used to measure the probation period

ASG_POS_START_TIME The standard start time for the assignment
position

ASG_POS_WORKING_HOURS The standard number of working hours for the
position

ASG_PRIMARY Whether this is the employee’s primary
assignment (yes/no)

ASG_PRIMARY_CODE The assignment’s primary code

ASG_PROB_END_DATE The probation period end date

ASG_PROB_PERIOD The assignment’s probation period

ASG_PROB_UNITS The units of the assignment’s probation period

ASG_REC_FULL_NAME The full name for the recruiter

ASG_RELIEF The relief position if the current position holder
is absent

ASG_SALARY The current salary for an employee
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Database item Description

ASG_SALARY_BASIS The payment basis (i.e. frequency) for the
assignment, e.g. monthly

ASG_SALARY_BASIS_ANNUALIZATION_
FACTOR

The payment basis pay annualization factor
for the assignment

ASG_SALARY_BASIS_CODE The payment basis lookup code for the
assignment

ASG_SALARY_BASIS_GRADE_ANNUAL
IZATION_FACTOR

The payment grade basis pay annualization
factor for the assignment

ASG_SALARY_BASIS_NAME The salary basis name for the assignment

ASG_SALARY_ELEMENT The display element name

ASG_SALARY_ELEMENT_VALUE_NAME The display input value name

ASG_SALARY_GRADE_RATE The display rate name

ASG_SALARY_RATE_BASIS The salary rate basis

ASG_SALARY_REVIEW_FREQUENCY The salary review frequency for the assignment

ASG_SALARY_REVIEW_PERIOD The salary review period for the assignment

ASG_START_DATE The start date of the assignment

ASG_START_TIME The standard start time for the assignment

ASG_STATUS The primary status for the assignment

ASG_SUCCESSOR The position name that will succeed into this
position

ASG_SUP_FULL_NAME The full name for the supervisor

ASG_TYPE Whether this is an employee or applicant
assignment

ASG_VACANCY The name of the vacancy applied for

ASG_WORK_AT_HOME The work at home code for an assignment

ASSIGNMENT_ACTION_END_DATE The end date of the assignment action

ASSIGNMENT_ACTION_START_DATE The start date of the assignment action

CHEQUE_UK_NUMBER The cheque number for the assignment action
(UK spelling)
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Database item Description

CHECK_US_NUMBER The check number for the assignment action
(US spelling)

GROSSUP_AMOUNT The gross up amount to be added to the net
amount

Employee Hire Information

Database item Description

EMP_HIRE_DATE The employee’s hire date

EMP_LAST_PROCESS_DATE The date the employee was last processed

EMP_LEAVING_REASON The reason the employee left

EMP_LEAVING_REASON_CODE The code for the reason the employee left

EMP_PROJ_TERM_DATE The employee’s projected termination date

EMP_TERM_ACCEPTED_BY The person who accepted the employee’s
notice

EMP_TERM_DATE The employee’s termination date

Home Address Details (UK only)

Database item Description

PER_ADR_UK_COUNTY The person’s home county (UK only)

Home Address Details (US only)

Database item Description

PER_ADR_US_COUNTY The person’s county (US only)

PER_ADR_US_STATE The person’s state (US only)

PER_ADR_US_STATE_CODE The person’s state code (US only)
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Human Resources Intelligence

Database item Description

HRI_ASG_EMPLOYMENT_CATEGORY_
CODE

The employment category code

HRI_ASG_FREQ_CODE The assignment working hours frequency code

HRI_ASG_FULL_TIME_FREQ The full-time frequency

HRI_ASG_FULL_TIME_HOURS The full-time working hours

HRI_ASG_HOURS The normal working hours of the assignment

HRI_ASG_PER_EMP_PTU Person Assignment EMP User Person Type

HRI_ASG_PER_APL_PTU Person Assignment APL User Person Type

HRI_ASG_PER_CWK_PTU Person Assignment CWK User Person Type

HRI_ASG_PRIMARY_CODE The primary assignment code

Location Details

Database item Description

LOC_ADR_LINE_1 The first line of the assignment’s work address

LOC_ADR_LINE_2 The second line of the assignment’s work
address

LOC_ADR_LINE_3 The third line of the assignment’s work address

LOC_ADR_POSTAL_CODE The postal code for the assignment’s work
address

LOC_ADR_REGION_1 The first line of the assignment’s region

LOC_ADR_REGION_2 The second line of the assignment’s region

LOC_ADR_REGION_3 The third line of the assignment’s region

LOC_ADR_PHONE_1 The assignment’s first work telephone number

LOC_ADR_PHONE_2 The assignment’s second work telephone
number

LOC_ADR_PHONE_3 The assignment’s third work telephone
number

LOC_ADR_CITY The town or city where the assignment works

LOC_ADR_COUNTRY The country where the assignment works
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Payroll Details

Database item Description

ACTION_TYPE Action type of target payroll action

LAST_REG_PAYMENT_PERIOD The last regular payment period

LAST_REG_PAYMENT_PERIOD_START_
DATE

The start date of the last regular payment
period

PAY_EARNED_CUT_OFF_DATE The cut-off date of the earned period

PAY_EARNED_DIRECT_DEPOSIT_DATE The direct deposit date of the earned period

PAY_EARNED_END_DATE The end date of the earned period

PAY_EARNED_PAY_ADVICE_DATE The pay advice date of the earned period

PAY_EARNED_PERIOD_ID The ID of the time period of the earned period

PAY_EARNED_PERIOD_NAME The period name for the earned period

PAY_EARNED_PERIOD_NUMBER The period number for the earned period

PAY_EARNED_START_DATE The start date of the earned period

PAY_NO_OF_SCHEDULED_PAYMENTS The start date of the earned period

PAY_PERIODS_PER_YEAR The number of payable periods in the year (as
of date earned)

PAY_PERIODS_PER_YEAR_DP The number of payable periods in the year (as
of date paid)

PAY_PROC_PERIOD_CUT_OFF_DATE The cut off date for the payroll period (as of
date earned)

PAY_PROC_PERIOD_CUT_OFF_DATE_DP The cut off date for the payroll period (as of
date paid)

PAY_PROC_PERIOD_DATE_PAID The date the payroll was paid

PAY_PROC_PERIOD_DIRECT_DEPOSIT_
DATE

The direct deposit date for the payroll period
(as of date earned)

PAY_PROC_PERIOD_DIRECT_DEPOSIT_
DATE_DP

The direct deposit date for the payroll period
(as of date paid)

PAY_PROC_PERIOD_END_DATE The end date of the payroll period (as of date
earned)

PAY_PROC_PERIOD_END_DATE_DP The end date of the payroll period (as of date
paid)

PAY_PROC_PERIOD_ID The ID of the time period for the payroll (as of
date earned)
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Database item Description

PAY_PROC_PERIOD_ID_DP The id of the time period for the payroll (as of
date paid)

PAY_PROC_PERIOD_NAME The period name for the payroll (as of date
earned)

PAY_PROC_PERIOD_NAME_DP The period name for the payroll (as of date
paid)

PAY_PROC_PERIOD_NUMBER The current period number for the payroll (as
of date earned)

PAY_PROC_PERIOD_NUMBER_DP The current period number for the payroll (as
of date paid)

PAY_PROC_PERIOD_PAY_ADVICE_DATE The pay advice date for the payroll period (as
of date earned)

PAY_PROC_PERIOD_PAY_ADVICE_DATE_
DP

The pay advice date for the payroll period (as
of date paid)

PAY_PROC_PERIOD_START_DATE The start date of the payroll period (as of date
earned)

PAY_PROC_PERIOD_START_DATE_DP The start date of the payroll period (as of date
paid)

PAYROLL_ARREARS_FLAG Value of arrears flag for payrolls
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People Addresses

Database item Description

PER_ADR_CITY The name of the person’s town or city

PER_ADR_COUNTRY The name of the person’s country

PER_ADR_COUNTRY_CODE The person’s country code

PER_ADR_DATE_FROM The first date on which the person can be
contacted at this address

PER_ADR_DATE_TO The last date on which the person can be
contacted at this address

PER_ADR_LINE_1 The first line of the person’s address

PER_ADR_LINE_2 The second line of the person’s address

PER_ADR_LINE_3 The third line of the person’s address

PER_ADR_PHONE_1 The person’s first contact number

PER_ADR_PHONE_2 The person’s second contact number

PER_ADR_PHONE_3 The person’s third contact number

PER_ADR_POSTAL_CODE The person’s postal code

PER_ADR_REGION_1 The first line of the person’s region

PER_ADR_REGION_2 The second line of the person’s region

PER_ADR_REGION_3 The third line of the person’s region

People Information

Database item Description

PER_1099R_NAME Employee details for 1099R

PER_AGE The person’s age

PER_APPLICANT_NUMBER The person’s applicant number

PER_BENEFIT_GROUP_ID The ID of the person’s benefit group

PER_COORD_BEN_MED_PLN_NO The benefits medical plan number for the
person

PER_COORD_BEN_NO_CVG_FLAG Whether there is any other benefits coverage

PER_CURRENT_APP Whether the person is a current applicant
(yes/no)
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Database item Description

PER_CURRENT_CWK Whether the person is a current contingent
worker (yes/no)

PER_CURRENT_EMP Whether the person is a current employee
(yes/no)

PER_CWK_NUMBER The person’s contingent worker number

PER_DATE_OF_BIRTH The person’s date of birth

PER_DATE_OF_DEATH The person’s date of death

PER_DATE_VERIFIED The date the employee last verified his or her
personal data

PER_DISABLED Whether the person is disabled (yes/no)

PER_DPNT_ADOPTION_DATE The person’s dependent’s adoption date

PER_DPNT_VLNTRY_SVCE_FLAG Whether the dependent is on voluntary service

PER_EMP_NUMBER The person’s employee number

PER_FIRST_NAME The person’s first name

PER_FULL_NAME The person’s full name

PER_KNOWN_AS The person’s preferred name

PER_LAST_NAME The person’s last name

PER_MAIL_DESTINATION The person’s mail destination

PER_MARITAL_STATUS The person’s marital status

PER_MIDDLE_NAMES The person’s middle names

PER_NATIONALITY The person’s nationality

PER_NATIONAL_IDENTIFIER The person’s national identifier

PER_ORIGINAL_DATE_OF_HIRE Date the person was first hired

PER_PERSON_TYPE Type of person (employee or applicant, for
example)

PER_PREFIX The person’s name prefix

PER_PREV_LAST_NAME The person’s previous last name

PER_RECEIPT_OF_DEATH_CERT_DATE Date of receipt of the person’s death certificate

PER_SEND_EXPENSES Where to send the person’s expenses
(home/office)
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Database item Description

PER_SEX The person’s sex

PER_SUFFIX The person’s name suffix

PER_TITLE The person’s title

PER_USES_TOBACCO_FLAG Whether the person uses tobacco

PER_WORK_PHONE The person’s work telephone number

Person Types

Database item Description

PTU_CON_PERSON_TYPE The contact’s person type, for example
employee, applicant

PTU_PER_PERSON_TYPE The type of person, for example employee,
applicant

PTU_REC_PERSON_TYPE The recruiter’s person type, for example
employee

PTU_SUP_PERSON_TYPE The supervisor’s person type, for example
employee
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Recruiter Information

Database item Description

REC_CURRENT_APP Whether the recruiter is a current applicant
(yes/no)

REC_CURRENT_CWK Whether the recruiter is a current contingent
worker (yes/no)

REC_CWK_NUMBER The recruiter’s contingent worker number

REC_CURRENT_EMP Whether the recruiter is a current employee
(yes/no)

REC_EMP_NUMBER The recruiter’s employee number

REC_GRADE The recruiter’s grade

REC_INT_ADDR_LINE The recruiter’s internal address

REC_JOB The recruiter’s job

REC_LOCATION The recruiter’s work location

REC_MANAGER Whether the assignment is a managerial
assignment (yes/no)

REC_ORG The name of the recruiter’s organization

REC_PERSON_TYPE The recruiter’s person type (employee or
applicant, for example)

REC_POSITION The recruiter’s position

REC_WORK_PHONE The recruiter’s work telephone number
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Supervisor Information

Database item Description

SUP_CURRENT_CWK Whether the supervisor is a current contingent
worker (yes/no)

SUP_CURRENT_EMP Whether the supervisor is a current employee
(yes/no)

SUP_CWK_NUMBER The contingent worker number of the
supervisor

SUP_DATE_FROM The date from which this supervisor
information is effective

SUP_DATE_TO The date to which this supervisor information
is effective

SUP_EMAIL_ADDRESS The supervisor’s email address

SUP_EMP_NUMBER The supervisor’s employee number

SUP_GRADE The supervisor’s grade

SUP_INT_ADDR_LINE The supervisor’s internal address

SUP_JOB The supervisor’s job

SUP_LOCATION The supervisor’s work location

SUP_MANAGER Whether the assignment is a managerial
assignment (yes/no)

SUP_ORG The supervisor’s organization

SUP_PERSON_TYPE The supervisor’s person type

SUP_POSITION The supervisor’s position

SUP_WORK_PHONE The supervisor’s work telephone number

Work Address Details (UK only)

Database item Description

LOC_ADR_UK_COUNTY The assignment’s work county (UK only)
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Work Address Details (US only)

Database item Description

LOC_ADR_US_COUNTY The assignment’s work county (US only)

LOC_ADR_US_STATE The assignment’s work state (US only)

LOC_ADR_US_STATE_CODE The assignment’s work state code (US only)

Static Database Items for Oracle US Federal HR
Static database items are shipped with the system and you cannot modify them. For a
list of the standard static database items, refer to Static Database Items, page 1-54.

You can use the following Oracle Federal HR data items with Fast Formula Rules.

• Location Extra Information: Duty Station ID

• Assignment Extra Information: Step or Rate, Tenure, Annuitant Indicator, Pay Rate
Determinant, Work Schedule, Part-Time Hours Biweekly, Duty Status

• Person Extra Information: Citizenship, Veterans Preference, Veterans Preference for
RIF, Veterans Status, Appointment Type, Type of Employment, Race or National
Origin, Date Last Promotion, SCD Leave, SCD Civilian, SCD RIF, SCD TSP, Date
From Retained Grade, Date To Retained Grade, Retained Grade, Retained Step
or Rate, Retained Pay Plan, Retained Pay Table ID, Retained Pay Basis, FERS
Coverage, Previous Retirement Coverage, Frozen Service, NAF Retirement Indicator

• Position Extra Information: Valid Grade, Target Grade, Pay Table ID, Pay
Basis, Employment Category Group, Occupation Category Code, FLSA
Category, Bargaining Unit Status, Supervisory Status, Position Occupied, Intelligence
Position Ind, LEO Position Indicator, Position Type

If you define agency-specific Extra Information types or segments, you can create
database items for them.

See: Setting Up Extra Information Types (Excluding Organization EITs), Oracle US
Federal HR Configuring, Reporting, and System Administration Guide

Dynamic Database Items
Dynamic database items are created by Oracle HRMS processes whenever you define
new elements or other related entities.

Element Database Items
When you define a new element, Oracle HRMS runs a process to create a number of
related database items for it. To ensure easy recognition of these items, the process adds
the element name <ENAME> to each one. It also creates further database items for each
pay and input value you use <INAME>.

Here is a list of database items created each time you define an element using the
Element window:
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Database item Description

<ENAME>_BEN_CLASS The element’s benefit classification

<ENAME>_CLASSIFICATION The element’s classification

<ENAME>_CLOSED_FOR_ENTRY Yes/no flag: translated into local language. If
Yes, new element entries cannot be created but
existing element entries can still be modified.

<ENAME>_CLOSED_FOR_ENTRY_CODE Yes/no flag: If Yes, new element entries cannot
be created but existing element entries can still
be modified.

<ENAME>_COSTABLE_TYPE The element’s costable type (from lookup table)

<ENAME>_COSTABLE_TYPE_CODE The element’s costable type (code values)

<ENAME>_COUNT The element entry count

<ENAME>_END_DATE The date to which this element is effective

<ENAME>_INPUT_CURRENCY_CODE The element’s input currency code

<ENAME>_LENGTH_OF_SERVICE The element’s qualifying length of service

<ENAME>_OUTPUT_CURRENCY_CODE The element’s output currency code

<ENAME>_PROCESSING_PRIORITY The element’s processing priority

<ENAME>_QUALIFYING_AGE The element’s qualifying age

<ENAME>_QUALIFYING_UNITS_CODE The qualifying length of service units (code
values)

<ENAME>_QUALIFYING_UNITS The qualifying length of service units (from
lookup table)

<ENAME>_REPORTING_NAME The element’s reporting name

<ENAME>_STANDARD_LINK Yes/no flag: yes = standard, no = discretionary

<ENAME>_STANDARD_LINK_CODE Yes/no flag: yes = standard, no = discretionary

<ENAME>_<INAME>_UNIT_OF_
MEASURE

The element’s unit of measure (from lookup
table)

<ENAME>_<INAME>_UNIT_OF_
MEASURE_CODE

The element’s unit of measure (code values)

<ENAME>_<INAME>_DEFAULT The element’s default input value

<ENAME>_<INAME>_MIN The element’s minimum input value

<ENAME>_<INAME>_MAX The element’s maximum input value
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In addition to the items above, Oracle HRMS creates the following four items for
elements defined with multiple entries not allowed:

Database item Description

<ENAME>_<INAME>_ENTRY_VALUE The element value

<ENAME>_<INAME>_USER_ENTERED_
CODE

Whether a value exists at the element entry
level (yes/no)

<ENAME>_<INAME>_START_DATE The element’s start date

<ENAME>_<INAME>_END_DATE The element’s end date

In addition to the common list above, Oracle HRMS creates the following item for
elements defined with multiple entries allowed whose input values are numeric (that
is, hours, integer, money or number).

Database item Description

<ENAME>_<INAME>_ENTRY_VALUE The summed element values for the multiple
entries

The units for ’<ENAME> <INAME> ENTRY VALUE’ are generated for both recurring
and nonrecurring elements and are user-definable. Oracle HRMS modifies the
definition text to retrieve the entry value in the unit of measure as specified in the
PAY_INPUT_VALUES_F table.

Grade Rate Database Items
When you define a grade rate, Oracle HRMS runs a process to create a number of related
database items for it. To ensure easy recognition of these items, the process adds the
grade rate name <NAME> to each one.

Here is a list of database items created each time you define a grade rate using the
Grade Rate window:

Database item Description

GRADE_<NAME>_VALUE The grade rate’s value

GRADE_<NAME>_MINIMUM The grade rate’s minimum value

GRADE_<NAME>_MAXIMUM The grade rate’s maximum value

Pay Scale Rate Database Items
When you define a pay scale rate, Oracle HRMS runs a process to create the following
database item for it. To ensure easy recognition of this item, the process adds the rate
name <NAME> to it.
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Database item Description

SPINE_<NAME>_VALUE The pay scale rates value

Descriptive Flexfield Database Items
When you define descriptive flexfield segments you make them available for use in
QuickPaint by running the Create Descriptive Flexfield DB Items process from the
Submit Requests window. This process creates database items for each of the descriptive
flexfields listed below.

To ensure easy recognition of these items, the process adds the descriptive flexfield
segment name <SEGMENT_NAME> to each one.

Database item Description

PEOPLE_<SEGMENT_NAME> People descriptive flexfield database items

PAYROLLS_<SEGMENT_NAME> Payroll descriptive flexfield database items

ASSIGNMENTS_<SEGMENT_NAME> Assignment descriptive flexfield database
items

GRADES_<SEGMENT_NAME> Grade descriptive flexfield database items

ABSENCES_<SEGMENT_NAME> Absence descriptive flexfield database items

ABSENCE_TYPES_<SEGMENT_NAME> Absence Type descriptive flexfield database
items

PERSON_ADDRESSES_<SEGMENT_
NAME>

Person Address descriptive flexfield database
items

EVENTS_<SEGMENT_NAME> Events descriptive flexfield database items

JOBS_<SEGMENT_NAME> Jobs descriptive flexfield database items

CONTACTS_<SEGMENT_NAME> Contacts descriptive flexfield database items

PERIODS_OF_SERVICE_<SEGMENT_
NAME>

Periods of Service descriptive flexfield
database items

RECRUITMENT_ACTIVITIES_
<SEGMENT_NAME>

Recruitment Activities descriptive flexfield
database items

POSITION_<SEGMENT_NAME> Position descriptive flexfield database items

APPLICATIONS_<SEGMENT_NAME Applications descriptive flexfield database
items

ORGANIZATION_<SEGMENT_NAME> Organization descriptive flexfield database
items
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Key Flexfield Database Items
When you define key flexfield segments you make them available for use in QuickPaint
by running the Create Key Flexfield DB Items process from the Submit Requests
window. This process creates database items for each of the key flexfields listed below.

To ensure easy recognition of these items, the process adds the key flexfield segment
name <SEGMENT_NAME> to each one.

Run this process for each of your Business Groups. If you define context-dependent
key flexfield structures using BUSINESS_GROUP_ID as the reference field, the process
creates database items for those flexfield segments as well. BUSINESS_GROUP_ID is the
only reference field that the Create Key Flexfield DB Items process supports.

Database item Description

COMP_KF_<SEGMENT_NAME> Competence key flexfield database items

GRADE_KF_<SEGMENT_NAME> Grade key flexfield database items

GROUP_KF_<SEGMENT_NAME> Group key flexfield database items

JOB_KF_<SEGMENT_NAME> Job key flexfield database items

POS_KF_<SEGMENT_NAME> Position key flexfield database items

SCL_ASG_<LEGISLATION_CODE>_
<ENAME>

Assignment soft coded legislative flexfield
database items

SCL_ORG_<LEGISLATION_CODE>_
<ENAME>

Organization soft coded legislative flexfield
database items

SCL_PAY_<LEGISLATION_CODE>_
<ENAME>

Payroll soft coded legislative flexfield database
items

Absence Database Items
When you define an absence type, Oracle HRMS runs a process to create the following
database item for it. To ensure easy recognition of this item, the process adds the absence
type name <ABSENCE_NAME> to it.

Database item Description

<ABSENCE_NAME>_CUM_BALANCE The cumulative balance for an absence type

Formulas for Payroll Legislative Checks
Oracle FastFormula contains a formula type called Legislative Check that may have been
set up by your localization team. This formula type can be set up to perform certain
checks during a payroll run. For example, you can catch errors such as negative gross
pay and cause the payroll run to fail appropriately.

Sometimes you may not want to run the legislation check in the payroll run so it
is possible that this functionality can be enabled or disabled using the HR:Execute
Legislative Check Formula within Run user profile.
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Formulas for Benefits Administration
Oracle FastFormula contains many formula types that you can use for benefits
administration. For example, grandfathered clauses and other special case scenarios
may require you to write a FastFormula rule that defines special treatment for a subset
of your benefits participants.

You can use Oracle FastFormula to calculate:

• The number of Hours Worked by a person in a given period

• A person’s length of service

• The maximum coverage amount for a life insurance plan

• Participation Eligibility

• Other benefits related functions.

After you write a formula for use with Standard or Advanced Benefits, you link that
formula to your plan design by selecting the formula in the Rule field of the appropriate
window.

Total Compensation Formula Types
The following table lists the formula types you can use in administering benefits with
Oracle HRMS.

Formula
Type

Description Contexts Input Values Return Value Sample Rule

Hours
Worked
Calculation

Used to
determine
an Hours
Worked
amount to
be used for
Eligibility,
Coverage
or Benefit,
Premium,
and Rate
calculations

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Hrs_Wkd_
Fctr_Id; Value
of the Hrs_
Wkd_Fctr.Val,
Min Val, Max
Val

Amount Determine
total number
of hours
worked
during the
person’s most
recent pay
period.

Age
Calculation

Used to
determine an
Age value to
be used for
Eligibility,
Coverage
or Benefit,
Premium,
and Rate
calculations

" Value of the
Age_Fctr.Val,
Min Val, Max
Val

Amount
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Formula
Type

Description Contexts Input Values Return Value Sample Rule

Length of
Service
Calculation

Used to
determine a
Service value
to be used
for Eligibility,
Coverage
or Benefit,
Premium,
and Rate
calculations

" LOS_Fctr_
Id; Value of
the LOS_Fctr.
Val, Min Val,
Max Val

Amount

Compensation
Calculation

Used to
determine
a Total
Compensation
amount to
be used for
Eligibility,
Coverage
or Benefit,
Premium
and Rate
calculations

" Comp_Lvl_
Fctr_Id; Value
of the Comp_
Lvl_Fctr.Val,
Min Val, Max
Val

Amount Sum the
amounts
for person’s
current
Regular
Salary
defined
balance
as of the
beginning of
the year, Prior
Year Total
Commission
benefits
balance type,
and Prior Year
Total Bonus
benefits
balance type,
and return the
total amount.

Rate Value
Calculation

Calculates a
rate amount
for a person.
May be used
to calculate
a base or
variable rate.

" Acty_Base_
Rt_Id or Vrbl_
Rt_Id; Value
of the Acty_
Base_Rt.Val,
Min Val, Max
Val; Value of
the Vrbl_Rt_
Prfl.Val, Min
Val, Max Val,

Amount If a person
is currently
enrolled in
this plan,
or has been
enrolled in
this plan
within the
past 2 years,
then the rate
is equal to the
rate person
is currently
paying.
Otherwise,
rate is equal
to X.
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Premium
Value
Calculation

Calculates
a premium
amount for a
person.

" Acty_Base_
Rt_Id or Vrbl_
Rt_Id or Actl_
Prem_Id or
Cvg_Amt_
Calc_Mthd_
Id; Value of
the Acty_
Base_Rt.Val,
Min Val, Max
Val

Amount Premium
amount is
equal to .
05 times
Coverage
amount less
50,000

Matching
Amount
Calculation

Calculates
the matching
amount.

" " Amount People that
work at
Division A
get matching
amount of 5%.
All others get
4% matching
amount.

Minimum
Coverage
Amount
Calculation

Calculates
a minimum
coverage
or benefit
amount for
a person.

" " Amount If in Benefits
Group A,
minimum
amount is
$100. If
in Benefits
Group B,
minimum
amount is
$200.

Maximum
Coverage
Amount
Calculation

Calculates a
maximum
coverage
or benefit
amount for
a person.

" " Amount Coverage
maximum
amount is
equal to
coverage
amount
for current
enrollment;
if no current
enrollment,
then
maximum is
$100,000.

Period to
Date Amount
Calculation

Determines
the maximum
period to date
amount a
person may
have for a
particular
activity rate.

" Amount
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Coverage
Amount
Calculation

Calculates
a coverage
or benefit
amount for
a person.

" Amount

Age
Determination
Date

Determines
the date
from which
age will be
calculated (e.
g., the first
day of the
next plan
year).

" Date If person is
in an Annual
Enrollment
event then
return 10/1/
99. If person
is becoming
eligible as
a result of
a new hire,
rehire, return
from leave or
a change from
part-time
to full-time
then return
the event
occurred on
date.

Hours
Worked
Determination
Date

Determines
the date from
which hours
worked will
be calculated
(e.g., the first
day of the
next plan
year).

" Date If person is
in an Annual
Enrollment
event then
return 10/1/
99. If person
is becoming
eligible as
a result of
a new hire,
rehire, return
from leave or
a change from
part-time
to full-time
then return
the event
occurred on
date.
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Length of
Service Date
to Use

Determines
the low date
from which
LOS will be
calculated (e.
g., original
hire date or
rehire date).

" Date Return Start
Date from
the person’s
Absence
Attendance
row in order
to determine
the elapsed
time that a
person has
been on a
Leave of
Absence.

Length of
Service
Determination
Date

Determines
the high date
for which
LOS will be
calculated (e.
g., the first
day of the
following
month).

" Date Return Start
Date from
the person’s
Absence
Attendance
row.

Compensation
Determination
Date

Determines
the high
date from
which hours
compensation
will be
calculated (e.
g., the first
day of the
next plan
year).

" Date

Action Type
Due Date

Determines
the date on
which the
Action Type
must be
completed (e.
g. 90 days
from the
Life Event
Creation
Date).

" Date If person
is currently
enrolled, 60
days from
life event
creation date.
If person is
not currently
enrolled, 30
days from life
event creation
date.

Participation
Eligibility
Start Date

Determines
when
eligibility
for a person
should start.

" Date Add 6 months
to the event
date and
return.
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Participation
Eligibility
End Date

Determines
when
eligibility
for a person
should end.

" Date If
Organization
on current
assignment
= A, return
date equal to
Event Date;
otherwise,
return date
equal to Start
of Following
Month after
event date.

Enrollment
Coverage
Start Date

Determines
when
enrollment
coverage for
a participant
should start.

" Date Coverage
start date
based on how
long you have
been absent
from a plan.

Enrollment
End

Determines
when
enrollment
coverage for
a participant
should end.

" Date If Calculated
LOS is less
than 5 years,
then end
of current
month. If
Calculated
LOS is greater
than or equal
to 5 years,
then end of 6
months after
event date.

Dependent
Coverage
Start Date

Determines
when
coverage for
a dependent
should start.

" Date If notified of
birth within
31 days
of event,
Coverage
Start Date is
Date of Birth.
Otherwise,
coverage start
date is date of
notification.
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Dependent
Coverage End
Date

Determines
when
coverage for
a dependent
should end.

" Date If Contact
Relationship
Type =
Spouse,
coverage
ends on date
of event;
if Contact
Relationship
Type = Child,
coverage ends
on end of
the month
following
event.

Rate Start
Date

Determines
when a
rate for an
enrollment
result for a
participant
should start.

" Date Rate starts
on the date
after the rate
end date of
the current
enrollment.

Rate End Date Determines
when a
rate for an
enrollment
result for a
participant
should end.

" Date Rate ends
on the day
before the
person’s next
pay period.

Participation
Eligibility

Determines
whether a
person is
eligible for
the associated
compensation
object. (This
is the rule
used in the
eligibility
profile rule
entities.)

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_
Id, Ler_Id,
Balance_Date

Y/N
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Dependent
Eligibility

Determines
whether a
person is
eligible to be
covered by a
participant
in a
compensation
object.

" Y/N Dependent
is eligible if
Employee
Work
Location
is 001 and
Dependent
is under
age 21 or if
Employee
Work
Location is
not 001 and
Dependent is
under age 25.

Enrollment
Opportunity

Determines
whether the
compensation
object should
be an
electable
choice for the
person.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

One of the
BEN_ENRT_
MTHD
values: A or
E; or N

As a result
of a transfer
event, the
participant
can only
enroll in
an HMO if
they were
previously
enrolled in
an HMO and
that HMO
is no longer
available to
them in their
new location.

To Be Sent
Date

Determines
the date on
which the
communication
should be
sent to the
person.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id, Cm_
Typ_Id

Date If
participant’s
organization
is equal to
{org1} or
{org2} then
return start
of enrollment
period - 14
days. If
participant’s
organization
is not equal
to {org1} or
{org2} then
return start of
enrollment
period - 7
days.

Rounding Rounds a
number to
the specified
place or
decimal.

None Amount Amount to
be rounded -
$250 rounded
to the next
$500
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Percent
Rounding

Rounds a
percent to
the specified
place or
decimal.

Amount

Automatic
Enrollment
Method

Determines
the conditions
under which
a person
should be
automatically
enrolled in a
compensation
object.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

One of the
BEN_ENRT_
MTHD
values: A or
E; or N

Reinstate
active benefits
if rehired in
the same plan
year.

Deduction
Schedule

Determines
the deduction
schedule to be
used for this
person.

" One of the
BEN_DED_
SCHED
values

If bargaining
unit code
is not null
return
"Second
Period In
Month" else
return "Every
Pay Period".

Payment
Schedule

Determines
the payment
schedule to be
used for this
person.

" One of the
BEN_PYMT_
SCHED
values

If bargaining
unit code
is not null
return
"Second
Period In
Month" else
return "Every
Pay Period".
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Default to
Assign
Pending
Action

Determines
the applicable
default option
or benefit
to assign to
the person
when his or
her choice
has been
suspended.

" One of the
BEN_DFLT_
TO_ASN_
PNDG_CTFN
values

Reinstate the
active benefits
that a person
had at the
time that the
person was
previously
active.
(NOTE:
cannot
reinstate
most recent
benefits,
as person
could have
some other
elections,
such as
COBRA).

Enrollment
Certification
Required

Determines
the conditions
under which
a person
must provide
certification
in order to
enroll or elect
a particular
plan or option
in plan, or
benefit.

" Y/N Participant
does not need
to provide
certification
if they were
enrolled in the
compensation
object and
had provided
certification
within the
past 12
months.

Dependent
Certification
Required

Determines
the conditions
under which
a person
must provide
certification
for his or her
designated
dependents.

" Y/N

Beneficiary
Certification
Required

Determines
the conditions
under which
a person
must provide
certification
for his or her
designated
beneficiaries.

" Y/N
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Waive
Certification
Required

Determines
the conditions
under which
a person
must provide
certification
when he or
she waives
participation.

" Y/N

Inspection
Required

Determines
whether
inspection
of the
communication
is required. If
so, the
"Inspection
Flag" is set
to ’yes’ for
this person’s
communication.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id, Cm_
Typ_Id

Y/N If
participant’s
division =
"Corporate"
or if
participant’s
HCE
indicator =
"Y" return
"YES".

Communication
Appropriate

Determines
for this
communication
and trigger,
whether the
communication
should be
sent; restricts
to whom to
send.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Ler_Id,
Cm_Typ_Id

Y/N If person is
in an Annual
Enrollment
event and
today’s date is
within seven
days of the
enrollment
period end
date return
"No".

Communication
Type

Determines
whether the
communication
should be
sent.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Ler_Id,
Cm_Typ_Id

Y/N
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Mandatory
Determination

Determines
whether this
option in
plan should
be assigned
to a person
(and not be
optional) as
part of the
enrollment
process.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Y/N

Postelection
Edit

Performs
edits on an
enrollment
result, e.
g. is the
spouse of the
participant
also enrolled;
does the
spouse of the
participant
work at
the same
company.

" Y/N and Text If the
participant
elects a non-
waive plan
under the
spouse life
plan type, the
participant
must elect
an equal
or greater
amount of
participant
life insurance.

Partial Month
Proration
Method

Determines
which value
to use: Date
Earned,
Pay Period
End Date,
or Payment
Date. This
tells the
proration
process
which date
to use when
determining
how many
pay periods
remain, and
when the
element entry
should start.

" One of the
Values of :
BEN_PRTL_
MO_DET_
MTHD

If the
participant is
paid monthly
and enrolls
in a medical
plan between
the 8th and
15th of the
month, then
return 75%
of the normal
monthly price
tag.
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Partial Year
Coverage
Restriction

Determines
the maximum
coverage
amount for
partial years
of coverage.
Allows
determination
of values
other than
delivered
values of: 1)
Standard
maximum as
defined in
the plan. 2)
Prorate
maximum
based on
the number
of months
remaining in
the plan year.

" Amount

Partial Month
Effective Date
Determination

Determines
which value
to use: Date
Earned,
Pay Period
End Date,
or Payment
Date. This
tells the
proration
process
which date
to use when
determining
how many
pay periods
remain, and
when the
element entry
should start.

" One of the
Values of :
BEN_PRTL_
MO_EFF_
DT_DET

Lack
Certification
Allow
Reimbursement

Identifies
cases where
certification is
waived.

" Y/N
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Compensation
Object
Selection

Determines
which
compensation
objects
are to be
included for
processing in
a concurrent
manager
process.

" Y/N Run the
default
process for
the flex
and nonflex
programs
only.
Participation
process
selection
mode:
determine
eligibility
for all
compensation
objects that
use derivable
factors.

Person
Selection

Determines
which people
are to be
included for
processing in
a concurrent
manager
process.

" Y/N Select all ex-
participants
who were
working at
a specific
organization.

Verify Family
Member

Determines
whether the
person has
one or more
contacts of a
specific type
or types, e.
g. spouse,
spouse and
one child,
more than one
child.

" Y/N

Five Percent
Owner

Determines
for this
plan and
regulation
whether the
person is a
five percent
owner as
defined in the
regulation.

" Y/N
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Highly
Compensated

Determines
for this
plan and
regulation
whether the
person is
considered
to be "highly
compensated"
as defined
in the
regulation.

" Y/N

Key
Employee

Determines
for this
plan and
regulation
whether the
person is
considered
to be a "key
employee" as
defined in the
regulation.

" Y/N

Break in
Service Value

Break in
Service Value

" Amount

Break in
Service
Determination

Determines
whether a
break in
service has
occurred and
if this break
should not be
ignored.

" Y/N

Contribution
Nondiscriminatory

Compares
individual
employee
pretax
contribution
amounts to
total pretax
contributions
for highly and
non-highly
compensated
persons.

" Y/N
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Coverage
Nondiscriminatory

Compares the
total number
of persons
eligible to
participate in
a plan minus
the persons
who are not
eligible due
to legislated
allowable
factors to
the number
actually
participating.

" Y/N

Extract
Person Data
Element

Specifies
person or
assignment
information
to be included
as a data
element item.
This rule
type can also
return the
results of a
calculation
performed
on person or
assignment
information.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment_
Id

Text

Extract
Person
Inclusion

Specifies
person or
assignment
level
inclusion or
exclusion
for system
extract.

" Y/N

Communication
Usage

Determines
whether a
Communcation
Usage
requirement
has been
satisfied. If
so, then a
communication
should be
triggered for
this usage.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Ler_Id,
Cm_Typ_Id

Y/N
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Default
Enrollment

Determines
whether this
option in plan
should be
assigned to a
person as part
of the default
enrollment
process.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Enrollment
Period Start
Date

Determines
the date on
which the
enrollment
period starts.

Date

Enrollment
Period End
Date

Determines
the date on
which the
enrollment
period ends.

" Date

Pop-Up
Message

Determines
whether
a pop-up
message
displays and
it what form.

" Y/N For a
participant
who selects
life insurance
at 10x salary,
display a
warning
message
on the
enrollment
form if the
participant’s
salary is less
than 50k.

Collapse
Life Event
Resulting
Occurred On
Date

When life
events are
collapsed
this rule
determines
the date to
use for the
resulting life
event.

" Date
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Collapse
Life Event
Evaluation

Determines
whether the
life event
should be
collapsed
and deleted,
collapsed and
voided, or
neither.

" One of the
values of:
BEN_EVAL_
DT: Collapse
or Void; or
leave as is

Vested Value Determine
the vested
percent for
a person.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_
Id, Ler_Id,
Balance_Date

Percent

Change
Dependent
Coverage

Used to
determine if
a dependent
can be
’Added
Only’,
’Removed
Only’,
Added and
Removed’, or
’Neither’.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Y/N

Evaluate Life
Event

Determines if
this life event
is valid, or if
the life event
information
needs to be
changed, e.
g. status,
voided date,
unprocessed
date.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Ler Id

Y/N,
status code,
unprocessed
date,
processed
date.
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Maximum
Waiting
Period Date
to Use

Determines
the low date
from which
the maximum
waiting
period will
be calculated
(e.g., original
hire date or
rehire date).

" Date

Waiting
Period Value
and UOM

Determines
the waiting
period and
unit of
measure to
be applied to
a person.

" Amount and
UOM

Maximum
Period of
Enrollment
Value and
UOM

Determines
the maximum
enrollment
period and
unit of
measure for a
compensation
object.

" Amount and
UOM

Person
Change
Causes Life
Event

Determines
whether this
life event is
valid for a
person based
on the data
that changed.

" Y/N

Related
Person
Change
Causes Life
Event

Determines
whether this
life event
is valid for
a related
person based
on the data
that changed.

" Y/N

1-96 Oracle Human Resources Management Systems FastFormula User Guide



Formula
Type

Description Contexts Input Values Return Value Sample Rule

Participant
Eligible to
Rollover

Determines
whether this
person may
roll over flex
credits into
a particular
compensation
object.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_
Id, Ler_Id,
Balance_Date

Y/N

Payment
Must Be
Received

Determines
whether a
payment is
missing or
late.

" Y/N

Life Event
Reason
Timeliness

Determines
whether a
life event has
been reported
in a timely
manner.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Y/N

Required
Period of
Enrollment

Determines
the earliest
deenrollment
date for a
person’s
electable
choice for a
compensation
object.

" Date
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Rate Lower
Limit

Calculates an
amount used
to determine
the lower
limit value
to which an
activity rate
or variable
rate value is
compared.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_
Id, Ler_Id,
Balance_Date

Amount

Rate Upper
Limit

Calculates an
amount used
to determine
the upper
limit value
to which an
activity rate
or variable
rate value is
compared.

" Amount

Coverage
Lower Limit

Calculates an
amount used
to determine
the lower
limit for
an activity
or variable
coverage or
benefit.

" Amount

Coverage
Upper Limit

Calculates an
amount used
to determine
the upper
limit for
an activity
or variable
coverage or
benefit.

" Amount

Premium
Lower Limit

Calculates an
amount used
to determine
the lower
limit for
an activity
or variable
premium.

" Amount
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Premium
Upper Limit

Calculates an
amount used
to determine
the upper
limit for
an activity
or variable
premium.

" Amount

Maximum
Period of
Enrollment

Period of
Enrollment
Rule
determines
whether
a person
has been
enrolled for
the maximum
length of time
allowed for a
plan or option
in a plan.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Y/N

Maximum
Period of
Enrollment
Determination
Date

Determines
the low
date to be
used when
determining
whether the
person has
been enrolled
in a plan or
option in
plan for the
maximum
period of
time.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Date

Partial Month
Proration
Value
Calculation

Calculates a
value for a
partial month
enrollment.

" Percent

Variable Rate
Add On
Calculation

Calculates a
new value
when a
variable rate
result is used.

" Result of the
Variable Rate
Calculation

Amount Multiply the
result by
102%.
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Segment
Costing
Method

Determines
how an
amount is
to be costed
based on
the segment
in the
COST KEY
ALLOCAT
ION KEY
FLEXFIELD.

" Key Cost
Allocation
Flexfield
Segment

Extract
Enrollment
Data Element

Specifies
enrollment
information
to be included
as a data
element item.
This formula
type can also
return the
results of a
calculation
performed on
enrollment
information.

Business_
Group_Id,
Effective_
Date,
Assignment
Id, Pl_Id,
Opt_Id, Ler_
Id

Text

Maximum
Credit
Rollover
Value

Determines
the maximum
amount a
person may
rollover to
another plan
or option in
plan.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Amount

Default
Excess Credit
Treatment

Determines
how any
excess credits
are to be
allocated.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

One of
the values
in BEN_
DFLT_EXCS_
TRTMT_CD
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Prorate
Annual
Election Value

Determines
how a
minimum or
maximum
annual
election value
is prorated.

Business_
Group_Id,
Effective_
Date,
Jurisdiction_
Code,
Organization_
Id,
Assignment
Id, Pgm_Id,
Pl_Typ_Id,
Pl_Id, Opt_Id,
Ler_Id

Amount

Extract Post
Process

This formula
type provides
additional
system extract
processing
and is called
after all
extraced
records are
written.

Business_
Group_Id,
Effective_
Date

EXT_RSLT_
ID (this is
found on ben_
ext_rslt and
ben_ext_rslt_
dtl tables).

Nothing. All
processing
should be
via formula
function.
Commit
will occur
in calling
program.

Allows you
to insert
intermittent
totals, delete
records,
change
sorting,
format fields,
update
values, etc.

UK Only Functions
The following functions have been registered for use in the UK only formulas.

CALCULATE_TIME_WORKED
Calculates the time worked between a start date and end date for an assignment.

CLASS1A_YTD
Calculate car benefit, year to date

COUNT_ASSIGNMENTS
Count of assignments an employee has

DIRECTOR_WEEKS
Number of weeks an employee has been a director

GET_BACS_PROCESS_DATE
Return the BACS processing date

GET_FTE_VALUE
The GET_FTE_VALUE identifies the FTE value for a given assignment on a specified
date in the past from the PER_ASSIGNMENT_BUDGET_VALUES table.
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This function uses the following Input Parameters:

• P_ASSIGNMENT_ID (number) - this is a required input and identifies which
assignment to retrieve FTE for.

• P_QUERY_DATE (date) - this is a required input and specifies the date at which
to retrieve FTE.

NI_ABLE_DIR_YTD
NIable pay for a director, year to date

NI_ABLE_PER_PTD
NIable pay for a person with multiple assignments

NI_CO_RATE_FROM_CI_RATE
Find the NI contracted out rate from the CI rate

PAYMENT_YTD
Calculate car payment, year to date

PERIOD_TYPE_CHECK
Test whether the period type is valid

PQP_GB_GET_ABSENCE_SSP_FOR_DATE_RANGE
Returns the amount of SSP payable for an absence within a date range.

PQP_GB_GET_ABSENCE_SMP_FOR_DATE_RANGE
Returns the amount of SMP payable for an absence within a date range.

PQP_GB_GAP_GET_FIRST_PAID_DAY
Returns the date on which a person starts to receive a given level of OSP payment.

PQP_GB_GAP_GET_LAST_PAID_DAY
Returns the date on which a person last received a given level of OSP payment.

PQP_GB_GAP_GET_FIRST_ENTITLED_DAY
Returns the date on which a person’s entitlement for a given level of OSP payment starts.

PQP_GB_GAP_GET_LAST_ENTITLED_DAY
Returns the date on which a person’s entitlement for a given level of OSP payment ceases.
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SESSION_DATE
Return the session date

UK_TAX_YR_END
Find the end of the tax year

UK_TAX_YR_START
Find the start of the tax year

USER_RANGE_BY_LABEL
Lower bound of range from user table using row label

USER_VALUE_BY_LABEL
Value from user table using row label

VALIDATE_BACS_DATE
Return the previous BACS process date to a given date

VALIDATE_USER_VALUE
Verify that a given value is in a user table.

Japanese Legislative Functions
The following functions have been registered for use in Japanese legislative formulas:

CHECK_FORMAT
(expr, fmt)

The CHECK_FORMAT function returns TRUE or FALSE to verify that the text string
operand expr matches the fmt type as follows:
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Format Type Validation

0:0-9 Numbers only, non-omissible

9:0-9 Numbers only, omissible

A:A-Z Capital alphabet only, non-omissible

P:A-Z Capital alphabet only, omissible

a:a-z Small alphabet only, non-omissible

p:a-z Small alphabet only, omissible

L:0-9, A-Z Numbers and capital alphabet only, non-
omissible

C:0-9, A-Z Numbers and capital alphabet only, omissible

l:0-9, a-z Numbers and small alphabet only, non-
omissible

c:0-9, a-z Numbers and small alphabet only, omissible

Example:

CHECK_FORMAT (’123456ABC’, ’999999PPL’) returns TRUE

CHECK_DATE_FORMAT
(date, date fmt)

The CHECK_DATE_FORMAT function returns TRUE or FALSE to verify that the date
operand matches a given date fmt.

Example:

CHECK_DATE_FORMAT (’19990623’, ’YYYYMMDD’) returns TRUE

GET_LAST_ASSACT
(date1, date2)

The GET_LAST_ASSACT function returns latest assignment_action_id with
’SEQUENCED’ classification_name between date1 and date2. Action_types with
’SEQUENCED’ classification_name are as follows:
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ACTION_TYPE MEANING CLASSIFICATION_NAME

B Balance Adjustment SEQUENCED

F Advance Pay SEQUENCED

I Balance Initialization SEQUENCED

O RetroPay SEQUENCED

Q QuickPay Run SEQUENCED

R Run SEQUENCED

V Reversal SEQUENCED

Z Purge SEQUENCED

ORG_EXISTS
(organization_id, org_class)

The ORG_EXISTS function returns TRUE or FALSE to verify that the organization
ID is in the organization class..

Example:

ORG_EXISTS(12345, ’JP_KENPO’)

South African Legislative Functions
Oracle HRMS for South Africa provides two prorating functions for use in formulas:

Prorate_Working_Days
• Proration is based on an average of 21.67 working days in a month. The number

of days the employee has worked is derived from Assignment start to end date or
the Payroll Period End Date. The number of working days in a month excludes
Saturdays and Sundays but includes public holidays.

Prorate_Calendar_Days
• Proration is based on the number of calendar days in a month. The number of

days the employee has worked is derived from Assignment start to end date or
the Payroll Period End Date.

See: Functions, Using Oracle FastFormula

Hungarian Legislative Functions
Oracle HRMS for Hungary provides the following functions for use in formulas:
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HU_ABS_GET_BLIND_DAYS
This formula function returns the number of days in the period for which the employee
is blind.

HU_ABS_GET_CHILD_INFO
This formula function returns the child information such child or children aged under
16 in the start of the period, child or children turning 16 in the given period and date
of birth of any children turning 16 in the given period.

HU_ABS_GET_JOB_DAYS
This formula function returns the number of days for the job with the Additional
Holiday set to Yes for the calculation year.

HU_ABS_GET_PREV_EMP_SICKNESS_LEAVE
This formula function returns the amount of sickness leave taken in the previous
employment for the calculation year.

HU_ABS_GET_WORKING_DAYS
This formula function returns the number of working days for the assignment for the
given period depending on the work pattern attached to the assignment.

HU_ENTRY_IN_ACCRUAL_PLAN
This formula function returns the valid values for the holiday entitlements such as HU1
for Base Holiday, HU2 for Additional Holiday for bringing up children, HU3 for Other
Additional Holiday, and HU4 for Sickness Holiday.

HU_PAYROLL_PERIODS
This formula function returns the number of payroll periods per year.

HU_PERSON_DOB
This formula function returns the date of birth of the employee.

Netherlands Payee Name Formulas
Oracle HRMS enables you to present the Payee Name of an employee/organization
in a specified format, in the EFT Payment File. Creating a FastFormula entitled
NL_PAYEE_REPORTING_NAME, you can decide the format the name appears on
the file.

Prior to using the FastFormula, the Payee Name of the person/organization
appearing on the EFT Payment is taken from the Payee Name field on the Personal
Payment Method form. If this field is blank, a check is carried out to find the
NL_PAYEE_REPORTING_NAME FastFormula, and use the information generated
there. The Payee Name is set to Last Name +"+ Initials of the person being paid, if
no formula has been defined.
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The Payee Address is taken from the City of the primary address of the relevant
employee/organization identified in the Payee Name record. This is left blank if it does
not exist. If the Payee Name is derived from the Payee Name field on the Personal
Payment Method form, the address used depends on whether the Payee Name specified
is a person or an organization. The Payee Address for an organization is taken from
the City on the appropriate location address, otherwise, it is taken from the City on
the employee’s address.

However, if a FastFormula is selected, or the Payee Name consists of the Last Name +"+
Initials, then the City from the employee address is used.

Netherlands EFT Payment Override Formula
Oracle HRMS enables you to override the contents of the Description field
in the Transaction Description Record 160 of the EFT Payment file and
enter your own information. You define a FastFormula with the standard
name NL_TRANSACTION_DESCRIPTION, returning a value called
Transaction_Description. The code in the formula can access any database item to derive
the Transaction Description value. This description can be up to 128 characters in
length, and spread over a maximum of 4 Transaction Description records.

Note: If you use the override, none of the derived values, such
as Employee Name and Assignment Number, is included in the
Transaction Description records unless added in the FastFormula.

Formulas for Netherlands Wage Tax Subsidies
Oracle HRMS provides you with FastFormulas for each of the following Wage Tax
Subsidies:

• Wage Tax Eligibility - NL_WAGE_TAX_SUBSIDY_ELIGIBILITY. This formula
derives the applicable wage tax subsidies for an employee assignment, and returns
values for the relevant subsidies.

• Wage Tax Subsidy for Low Wages - NL_CALC_LOW_WAGES_TAX_SUBSIDY. This
formula derives the wage tax subsidy for low wages for an employee.

• Wage Tax Subsidy for Paid Parental Leave - NL_CALC_PAID_PARENTAL_LEAVE_
TAX_SUBSIDY. This formula derives a value for the wage tax subsidy for paid
parental leave for an employee.

• Wage Tax Subsidy for Education - NL_CALC_EDUCATION_TAX_SUBSIDY. This
formula derives a value for the wage tax subsidy for education for an employee.

• Wage Tax Subsidy for the Long Term Unemployed - NL_CALC_LONG_TERM_
UNEMPLOYED_TAX_SUBSIDY. This formula derives a value for the wage tax
subsidy for long term unemployed for an employee.

Netherlands Working Hours Formula
Oracle HRMS enables you to derive the weekly working hours to appear on the
Central Bureau of Statistics (CBS) file. You define a FastFormula with the name
NL_WEEKLY_WORKING_HOURS, to return a parameter called Working_Hours with a
value for weekly working hours in the format 99.99. The formula code uses any database
items or balances to obtain a value for the weekly working hours.
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Note: If you do not define a FastFormula, the application draws
the working hours from the Individual Working Hours held on the
assignment.

Formulas to Enable Additional Part-Time Percentages for the Netherlands
Oracle HRMS enables you to create FastFormulas to calculate each of the additional
part-time percentage values for an assignment, overriding the current general part-time
percentage and assignment level information. The FastFormulas will have no input
values, returning a parameter called Part_Time_Percentage, in the format 999.9999.

If you want all part-time percentage values to be set from information at the assignment
level, you do not need to define any overriding FastFormulas.

If you want to override all the part-time percentage values using the same
calculation, you define one formula called NL_PART_TIME_PERCENTAGE.

If you need to override any of the part-time percentage values, you must create the
appropriate formula from the following:

• Standard SI part-time percentage- NL_STANDARD_SI_PART_TIME_PERCENTAGE

• Pseudo SI part-time percentage- NL_PSEUDO_SI_PART_TIME_PERCENTAGE

• Standard SI part-time percentage for reporting- NL_STANDARD_SI_REPORTING_
PART_TIME_PERCENTAGE

• Pseudo SI part-time percentage for reporting- NL_PSEUDO_SI_REPORTING_
PART_TIME_PERCENTAGE

Note: Pseudo SI Calculation uses the Pseudo SI Part-time Percentage. All
the part-time percentages are limited according to the maximum limits
set in the corresponding global values.

Examples

Sample Accrual Formula Example
This topic suggests how you can implement a whole range of accrual plan rules in your
Accrual formula. The suggestions are based on a simple formula, which is similar to
the seeded PTO_SIMPLE_MULTIPLIER formula. The sample formula is for a plan
with the following rules:

• An accrual term of one calendar year starting 01 January.

• Monthly accrual periods and a fixed accrual of 2 days per month.

• An accrual ceiling of 20 days, fixed within the formula.

• Accrual for new hires begins on whichever of these dates is the latest: hire date, plan
enrollment date, or continuous service date (which can be entered as an input value
when you enroll an employee in a plan).

The top level formula repeatedly calls another formula in a loop to calculate the accrual
for each period. Both the top level formula (PTO_ONE_YEAR_MULTIPLIER) and the
looping formula (PTO_PERIOD_ACCRUAL) are given below.
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Formula

1. /*----------------------------------------------

NAME : PTO_ONE_YEAR_MULTIPLER

This formula calculates the dates between which

an assignment is to accrue time

----------------------------------------------*/

2. DEFAULT FOR ACP_CONTINUOUS_SERVICE_DATE IS

’31-DEC-4712’ (date)

3. DEFAULT FOR ACP_TERMINATION_DATE IS

’31-DEC-4712’ (date)

4. DEFAULT FOR ACP_ENROLLMENT_START_DATE IS

’31-DEC-4712’ (date)

5. DEFAULT FOR ACP_SERVICE_START_DATE IS

’31-DEC-4712’ (date)

6. INPUTS ARE

Calculation_Date (date)

7. E = SET_NUMBER(’CEILING’, 20)

8. E = SET_NUMBER(’ACCRUAL_RATE’, 2)

9. Accruing_Frequency = ’M’ /* Month */

10. Accruing_Multiplier = 1

11. E = SET_TEXT(’ACCRUING_FREQUENCY’,

Accruing_Frequency)

12. E = SET_NUMBER(’ACCRUING_MULTIPLIER’,

Accruing_multiplier)

13. Beginning_Of_Calculation_Year = to_date

(’0101’||to_char(Calculation_Date,’YYYY’),’DDMMYYYY ’
)

14. E = SET_DATE(’BEGINNING_OF_CALCULATION_YEAR’,

Beginning_Of_Calculation_Year)
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15. /*---------------------------------------------- -

Set the start and end dates of the first accrual

period in the calculation year.

-----------------------------------------------*/

16. E = GET_PERIOD_DATES

(Beginning_of_Calculation_Year,

Accruing_Frequency,

Beginning_Of_Calculation_Year,

Accruing_Multiplier)

17. First_Period_SD = get_date(’PERIOD_START_DATE’)

18. First_Period_ED = get_date(’PERIOD_END_DATE’)

19. /*----------------------------------------------

Set the Calculation_Date to the Termination Date

if not null

--------------------------------------------- */

20. IF NOT (ACP_TERMINATION_DATE WAS DEFAULTED) THEN

(

21. IF (ACP_TERMINATION_DATE < Calculation_Date) THEN

(

22. Calculation_Date = ACP_TERMINATION_DATE

)

)

23. /* ----------------------------------------------

Get the last whole period prior to the

Calculation Date and ensure that it is within the

Year (if the Calculation Date is the End of a

Period then use that period)

---------------------------------------------- */

24. E = GET_PERIOD_DATES(Calculation_Date,
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Accruing_Frequency,

Beginning_of_Calculation_Year,

Accruing_Multiplier)

25. Calculation_Period_SD = get_date(’PERIOD_START_DAT E’)

26. Calculation_Period_ED = get_date(’PERIOD_END_DATE’ )

27. IF (Calculation_Date <> Calculation_Period_ED)

THEN

(

28. E = GET_PERIOD_DATES

(ADD_DAYS(Calculation_Period_SD,-1),

Accruing_Frequency,

Beginning_of_Calculation_Year,

Accruing_Multiplier)

29. Calculation_Period_SD = get_date(’PERIOD_START_DAT E’)

30. Calculation_Period_ED = get_date(’PERIOD_END_DATE’ )

)

31. /* ----------------------------------------------

Set the Continuous Service Global Variable using

the Continuous Service Date (if it was entered

when the employee enrolled in the plan) and

otherwise using hire date, whilst also ensuring

that the continuous service date is before the

Calculation Period.

--------------------------------------------- */

32. IF (ACP_CONTINUOUS_SERVICE_DATE WAS DEFAULTED)

THEN

33. (

E = set_date(’CONTINUOUS_SERVICE_DATE’,

ACP_SERVICE_START_DATE)
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)

34. ELSE

(

35. E = set_date(’CONTINUOUS_SERVICE_DATE’,

ACP_CONTINUOUS_SERVICE_DATE)

)

36. Continuous_Service_Date = get_date(’CONTINUOUS_SER VICE_DATE’
)

37. /* ---------------------------------------------

Determine the date on which PTO actually starts

accruing based on Continuous Service Date, the

Start Date of the Calculation Year, and plan

Enrollment Start Date. Remember, we have already

determined whether to use hire date or CSD at

lines 32 to 35 above.

---------------------------------------------- */

38. Actual_Accrual_Start_Date =

greatest(ACP_ENROLLMENT_START_DATE,

Continuous_Service_Date,

First_Period_SD)

39. /* ---------------------------------------------

Determine the start and end date of the first

accrual period to use in the accrual calculation.

Get the start and end dates of the accrual period

in which the Actual Accrual Start Date falls. If

the Actual Accrual Start Date does not fall on

the first day of this period, start accruing from

the next period.

-----------------------------------------------*/
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40. IF Actual_Accrual_Start_Date > First_Period_SD

THEN

(

41. E = GET_PERIOD_DATES(Actual_Accrual_Start_Date,

Accruing_Frequency,

Beginning_Of_Calculation_Year,

Accruing_Multiplier)

42. Accrual_Start_Period_SD = get_date(’PERIOD_START_D ATE’)

43. Accrual_Start_Period_ED = get_date(’PERIOD_END_DAT E’)

44. IF Actual_Accrual_Start_Date > Accrual_Start_Period _SD THEN

(

45. E = GET_PERIOD_DATES

(add_days(Accrual_Start_Period_ED,1),

Accruing_Frequency,

Beginning_of_Calculation_Year,

Accruing_Multiplier)

46. Accrual_Start_Period_SD = get_date(’PERIOD_START_D ATE’)

47. Accrual_Start_Period_ED = get_date(’PERIOD_END_DAT E’)

)

)

48. ELSE

(

49. Accrual_Start_Period_SD = First_Period_SD

50. Accrual_Start_Period_ED = First_Period_ED

)

51. /* --------------------------------------------

Now set up the information that will be used

when looping through the periods

--------------------------------------------- */
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52. IF Calculation_Period_ED >= Accrual_Start_Period_ED THEN

(

53. E = set_date(’PERIOD_SD’,Accrual_Start_Period_SD)

54. E = set_date(’PERIOD_ED’,Accrual_Start_Period_ED)

55. E = set_date(’LAST_PERIOD_SD’,Calculation_Period_S D)

56. E = set_date(’LAST_PERIOD_ED’,Calculation_Period_E D)

57. E = set_number(’TOTAL_ACCRUED_PTO’,0)

58. E = LOOP_CONTROL(’PTO_PERIOD_ACCRUAL’)

59. Total_Accrued_PTO = get_number(’TOTAL_ACCRUED_PTO’ )

)

60. IF Accrual_Start_Period_SD > Calculation_Period_ED T HEN

(

61. Accrual_Start_Period_SD = First_Period_SD

)

62. Effective_start_date = Accrual_Start_Period_SD

63. Effective_end_date = Calculation_Date

64. Accrual_end_date = Calculation_Period_ED

65. RETURN Total_Accrued_PTO,

66. Effective_start_date,

67. Effective_end_date,

68. Accrual_end_date

Looping Formula
1. /* ----------------------------------------------

NAME : PTO_PERIOD_ACCRUAL

This formula calculates the dates between which an

assignment is to accrue time

------------------------------------------------*/

2. /*----------------------------------------------- -
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Get the global variable to be used in this formula

------------------------------------------------*/

3. Continuous_Service_Date = get_date(’CONTINUOUS_SERV ICE_DATE’)

4. Total_Accrued_PTO = get_number(’TOTAL_ACCRUED_PTO’)

5. Period_SD = get_date(’PERIOD_SD’)

6. Period_ED = get_date(’PERIOD_ED’)

7. Last_Period_SD = get_date(’LAST_PERIOD_SD’)

8. Last_Period_ED = get_date(’LAST_PERIOD_ED’)

9. Accrual_Rate = get_number(’ACCRUAL_RATE’)

10. Accruing_Frequency = get_text(’ACCRUING_FREQUENCY’ )

11. Accruing_Multiplier = get_number(’ACCRUING_MULTIPL IER’)

12. Beginning_of_Calculation_Year =

get_date(’BEGINNING_OF_CALCULATION_YEAR
’)

13. Ceiling = get_number(’CEILING’)

14. /* ----------------------------------------------

Calculate the Amount Accrued this Period

-----------------------------------------------*/

15. Period_Accrued_PTO = Accrual_Rate

16. /*---------------------------------------------- -

Calculate any absence or bought/sold time etc. to

be accounted for in this period.

-----------------------------------------------*/

17. Absence = GET_ABSENCE(Period_ED,

Beginning_of_Calculation_Year)

18. CarryOver = GET_CARRY_OVER(Period_ED,

Beginning_of_Calculation_Year)

19. Other = GET_OTHER_NET_CONTRIBUTION(Period_ED,

Beginning_of_Calculation_Year)
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20. Period_Others = CarryOver + Other - Absence

21. /* ----------------------------------------------

Now establish whether the Accrual this period has

gone over the ceiling if one exists

-----------------------------------------------*/

22. IF (Ceiling > 0) THEN

(

23. IF (Total_Accrued_PTO + Period_Accrued_PTO +

Period_Others > Ceiling) THEN

(

24. Amount_Over_Ceiling = Total_Accrued_PTO +

Period_Accrued_PTO + Period_Others - Ceiling

25. IF (Amount_Over_Ceiling > Period_Accrued_PTO)

THEN

(

26. Period_Accrued_PTO = 0

)

27. ELSE

(

28. Period_Accrued_PTO = Period_Accrued_PTO -

Amount_Over_Ceiling

)

)

)

29. /*---------------------------------------------- -

Set the Running Total

-----------------------------------------------*/

30. E = set_number

(’TOTAL_ACCRUED_PTO’,Total_Accrued_PTO +
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Period_Accrued_PTO)

31. /* ----------------------------------------------

Establish whether the current period is the last

one, if so end the processing, otherwise get the

next period

-----------------------------------------------*/

32. IF Period_SD = Last_Period_SD THEN

(

33. Continue_Processing_Flag = ’N’

)

34. ELSE

(

35. E = GET_PERIOD_DATES(ADD_DAYS(Period_ED,1),

Accruing_Frequency,

Beginning_of_Calculation_Year,

Accruing_Multiplier)

36. E = set_date(’PERIOD_SD’, get_date(’PERIOD_START_DA TE’))

37. E = set_date(’PERIOD_ED’, get_date(’PERIOD_END_DATE ’))

38. Continue_Processing_Flag = ’Y’

)

39. Return Continue_Processing_Flag

Changing the Length of the Accrual Periods

The accrual period is determined by the variables Accruing_Frequency and
Accruing_Multiplier (lines 9 and 10 of the top level formula). You can set
Accruing_Frequency to M (month), D (day) or W (week). For example, if the frequency
is set to W and the multiplier set to 2, time is accrued every two weeks.

These examples use the calendar to measure the length of accrual periods. You
can also use payroll periods. In this case, you do not need to set the variables
Accruing_Frequency and Accruing_Multiplier. At lines 16, 24, 28, 41, and 45, replace
the call to get_period_dates with a call to get_payroll_period. For example, replace
lines 24 to 26 with:

E = GET_PAYROLL_PERIOD (ADD_DAYS(Calculation_Period_SD , -1))
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CALCULATION_PERIOD_SD = get_date(’PAYROLL_PERIOD_START_DATE’)

CALCULATION_PERIOD_ED = get_date(’PAYROLL_PERIOD_END_DATE’)

Changing the Accrual Term Start Date

The accrual term start date is set to 01 January at line 13 of the sample top level
formula. To use another fixed date (such as 01 June) replace this line with the following:

Beginning_Of_Calculation_Year = to_date

(’0106’||to_char(Calculation_Date,’YYYY’),’DDMMYYYY ’
)

If Beginning_Of_Calculation_Year > Calculation_Date the n

(

Beginning_Of_Calculation_Year =

add_months(Beginning_Of_Calculation_Year, -12)

)

To start an employee’s accrual term on his or her hire date anniversary, replace line
13 with:

Beginning_Of_Calculation_Year = to_date(

to_char(ACP_SERVICE_START_DATE,’DD-MM’) ||

to_char(Calculation_Date,’YYYY’),’DDMMYYYY’)

If Beginning_Of_Calculation_Year > Calculation_Date the n

(

Beginning_Of_Calculation_Year =

add_months(Beginning_Of_Calculation_Year, -12)

)

This example uses the ACP_SERVICE_START_DATE database item, although any
substitute may be used.

Adding Start Rules for New Hires

In this sample formula, accrual for new hires begins on whichever of these dates is the
latest: hire date, plan enrollment date, or continuous service date. However, you may
want your top level accrual formula to check whether there is a start rule defined for the
plan. The seeded PTO_PAYROLL_CALCULATION formula shows you how to do this.

In summary, the formula has to:

• Check which start rule was entered for the plan, and calculate the
First_Eligible_To_Accrue_Date accordingly.

• Get the first full accrual period following the First_Eligible_To_Accrue_Date.
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• Check whether the Actual_Accrual_Start_Date is after the First_Eligible_To_
Accrue_Date and, if not, set the Accrual_Start_Period start and end dates to the
First_Eligible_To_Accrue_Period start and end dates. This affects lines 40 to 50 of
the sample formula.

There are three seeded start rules: hire date, beginning of calendar year after hire
date, and six months after hire date. If you need a different start rule, define it as a value
for the Lookup Type US_ACCRUAL_START_TYPE.

Then add a line to your formula, of this form:

IF (ACP_START = ’<your new Lookup Value>’) THEN (First_Elig ible_T
o_Accrue_Date = <calculation for start date>)

Basing the Accrual Amount on Time or Pay Elements

You need to create database items for the element input values that determine the accrual
amount. Suppose plan participants accrue one hour for every 10 hours worked. You
could include this rule in your formula as follows:

Accrual = ACP_HOURS_WORKED / 10

where ACP_HOURS_WORKED is a database item. This kind of calculation would be
found typically in the looping formula.

Using Up Front Accruals

The sample formula assumes that plan participants accrue a certain amount of time each
month. But in some plans, participants accrue their full entitlement at the start of the
accrual term. In this case the formula does not need to loop through each accrual period.

Here is a very basic sample formula, assuming an accrual of 20 days for every calendar
year. There are no ineligibility rules or start rules in this example. It also does not
calculate the accrual for part years (for example, for employees joining the plan midway
through a year).

INPUTS ARE

Calculation_Date (date)

Total_Accrued_PTO = 20

Effective_start_date =

to_date(’0101’||to_char(calculation_date, ’YYYY’),’D DMMYYYY’
)

Effective_end_date =

to_date(’3112’||to_char(calculation_date, ’YYYY’),’D DMMYYYY’
)

Accrual_end_date =

to_date(’0101’||to_char(calculation_date, ’YYYY’),’D DMMYYYY’
)

RETURN Total_Accrued_PTO,
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Effective_start_date,

Effective_end_date,

Accrual_end_date

Changing the Ceiling

In the sample top level formula, the ceiling is set at line 7. You can change the ceiling
within the formula, or set it to zero to remove the ceiling:

E = SET_NUMBER(’CEILING’, 0)

You can also set the ceiling outside the formula, using the Accrual Bands window or
a user table.

Changing the Date Used for Continuous Service

The continuous service date is used in the formula to determine when a new hire begins
to accrue time. If your plan has accrual bands based on length of service, this date also
determines the amount the employee is eligible to accrue.

In the sample, length of service is calculated from hire date (using the database
item ACP_SERVICE_START_DATE) or the continuous service date input value, if
it was entered when the employee was enrolled in the plan (database item
ACP_CONTINUOUS_SERVICE_DATE). Alternatively, you can define and use another
database item. For example, replace lines 32 to 36 of the top level formula with:

E = set_date(’CONTINUOUS_SERVICE_DATE’, <NEW_DATABASE_ ITEM>)

Continuous_Service_Date = get_date(’CONTINUOUS_SERVIC E_DATE’)

Adding Rules for Suspended Assignments

Some accrual plans may not allow employees to accrue PTO while on certain types
of leave. such as maternity leave or study leave. In this case, your formula needs to
check the status of the assignment.

For example, suppose that assignments with the status "Suspended" cannot accrue
time. You can use the ASG_STATUS database item to get the value of the assignment
status. Replace line 8 with:

IF ASG_STATUS = ’Suspended’ THEN

(

E = SET_NUMBER(’ACCRUAL_RATE’, 0)

)

ELSE

(

E = SET_NUMBER(’ACCRUAL_RATE’, 2)

)
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Adding Rules for Part Time Employees

You can use the ASG_EMPLOYMENT_CATEGORY database item to check whether
the assignment is part time or full time.

Suppose part timers accrue at only half the rate of full timers, and have a lower
ceiling, then replace lines 7 and 8 with:

IF ASG_EMPLOYMENT_CATEGORY = ’FULL TIME’ then

(

E = SET_NUMBER(’CEILING’, 20)

E = SET_NUMBER(’ACCRUAL_RATE’, 2)

)

ELSE

(

E = SET_NUMBER(’CEILING’, 10)

E = SET_NUMBER(’ACCRUAL_RATE’, 1)

)

If part time employees accrue at different rates depending on their hours as a percentage
of full time, you could set up HR budgets to record the value of each assignment. Then
you need to define a database item for the budget value.

Adding a Long Service Leave Entitlement

If you want to see how much long service leave has been awarded to an employee in
the Accruals window, you need to set up a separate accrual plan. Otherwise, you can
include the entitlement in the standard accrual plan. The following approach adds the
long service accrual in a single accrual period, ignoring the usual accrual ceiling.

Suppose employees are entitled to a one time bonus of 10 extra days after 15 years of
service. First, in the top level formula, add the following after line 57 to set up a variable
that can be accessed in the looping formula:

e = set_number(’LONG_SERVICE_ACCRUAL’, 0)

Then, in the looping formula, calculate years service to ascertain whether the employee
is entitled to long service leave. Add the following after line 13:

years_service = floor(months_between(period_ed,

continuous_service_date)/12)

Next, set up a variable that can be used later to detect whether long service accrual has
already been added. After line 29, add:

long_service_accrual = get_number(’LONG_SERVICE_ACCRU AL’)

IF (years_service > 15) and long_service_accrual = 0 THEN
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(

long_service_accrual = 10

e = set_number(’LONG_SERVICE_ACCRUAL’, long_service_ac crual)

)

ELSE

(

long_service_accrual = 0

)

Finally, add any long service accrual to the total accrual, ignoring the ceiling. Replace
line 30 with:

E = set_number(’TOTAL_ACCRUED_PTO’,Total_Accrued_PTO +

Period_Accrued_PTO + long_service_accrual)

Using Accrual Bands Based on Length of Service

The seeded looping formulas demonstrate how to use accrual bands based on length
of service criteria (entered in the Accrual Bands window). To change the sample
formulas to use accrual bands:

In the top level formula:

• Remove lines 7 and 8

• Add the following after line 57:

E = set_number(’ANNUAL_RATE’,0)

E = set_number(’UPPER_LIMIT’,0)

E = set_number(’CEILING’,0)

In the looping formula

• Remove lines 9, 10, 11, and 13

• Add the following after line 12:

Annual_Rate = get_number(’ANNUAL_RATE’)

Upper_Limit = get_number(’UPPER_LIMIT’)

Ceiling = get_number(’CEILING’)

Years_Service = Floor(Months_Between(Period_ED,

Continuous_Service_Date)/12)
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/*----------------------------------------------

If the Upper Limit was defaulted or years service

is greater than or equal to the upper limit of

the current band reset the globals to the

appropriate band.

-----------------------------------------------*/

IF (Upper_Limit = 0 OR Years_Service >= Upper_Limit) THEN

(

If (GET_ACCRUAL_BAND(Years_Service) = 0) THEN

(

Annual_Rate = get_number(’ANNUAL_RATE’)

Upper_Limit = get_number(’UPPER_LIMIT’)

Ceiling = get_number(’CEILING’)

)

ELSE /*function returned an error */

(

Continue_Processing_Flag = ’N’

Return Continue_Processing_Flag

)

)

Accrual_Rate = Annual_Rate / 12

Changing the Length of Service Units

Normally the bands entered in the Accrual Bands window refer to years. However, you
can change the formula to interpret the bands as another unit, such as six months. In the
sample given above to change the looping formula to use accrual bands, you would
simply replace ’12’ with ’6’ in the line:

Years_Service = Floor(Months_Between(Period_ED,

Continuous_Service_Date)/12)

Using Accrual Bands Based on Other Criteria

You can set up a user table to hold the values you require. For example:
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Accrual Ceiling Max Carry Over

Grade A 20 25 5

Grade B 24 25 8

You can also base your accrual bands on a combination of criteria (such as grade and
length of service). In this case, you need to set up separate user tables for each value
you want to hold (such as accrual amount, ceiling and maximum carry over). The table
for accrual amount might look like this:

Grade A Grade B

0 to 5 years service 20 25

5 to 50 years service 24 28

To use data from a user table in a formula, use the GET_TABLE_VALUE function:

yearly_accrual = get_table_value(<table_name>, <column _name>,

<row_value>, <effective_date>)

The effective date parameter is optional. Example:

yearly_accrual = get_table_value (’MY_TABLE’, ’GRADE A’, 5)

Sample Accrual Formula (Belgium)
This topic suggests how you can implement a whole range of accrual plan rules in
your Accrual formula. The suggestions are based on the sample seeded Belgium
PTO_BE_PREVYR_MULTIPLIER formula. The sample formula is for a plan with the
following rules:

• An accrual term of one calendar year starting 01 January.

• Monthly accrual periods and a fixed accrual of 2 days per month.

• Accrual for new hires begins on their hire date.

The top level formula repeatedly calls another formula in a loop to calculate the accrual
for each period. Both the top level formula (PTO_BE_PREVYR_MULTIPLIER) and the
looping formula (PTO_BE_PREVYR_PERIOD_ACCRUAL) are given below.

1. /*----------------------------------------------

NAME : PTO_BE_PREVYR_MULTIPLER

This formula calculates the PTO accrued at a given
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point in time

----------------------------------------------*/

2. DEFAULT FOR EMP_HIRE_DATE IS

’4712/12/31 00:00:00’ (date)

3. DEFAULT FOR ACP_ENROLLMENT_START__DATE IS

’0001/01/01 00:00:00’ (date)

4. DEFAULT FOR ACP_ENROLLMENT_END_DATE IS

’4712/12/31 00:00:00’ (date)

5. DEFAULT FOR ACP_TERMINATION_DATE IS

’4712/12/31 00:00:00’ (date)

6. DEFAULT FOR PEOPLE_BE_SCHOOL_LEAVER IS

’NO’

7. /*-----------------------------------------------

The following is the date on which the number of accrued

PTO days is required.

-----------------------------------------------*/

8. INPUTS ARE

Calculation_Date (date)

9. /*-----------------------------------------------
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Get the basic dates and information used in the

calculation of the accrued PTO.

-----------------------------------------------*/

10. PrevYr = TO_CHAR(ADD_MONTHS(calculation date,-12),’ YYYY’)

11. PrevYrStartDate=TO_DATE(PrevYr||’0101’,YYYYMMDD’ )

12. PrevYrEndDate=TO_DATE(PrevYr||’1231’, ’YYYYMMDD’)

13. /*---------------------------------------------- ------

Calculate the start and end dates of the current year.

. -------------------------------------------------- ---*/

14. CurrYr=TO_CHAR(calculation_date, ’YYYY’)

15. CurrYrStartDate=TO_DATE(CurrYr||’0101’,’YYYYMMDD ’)

16. CurrYrEndDate=TO_DATE(CurrYr||’1231’,’YYYYMMDD’)

17. /*---------------------------------------------- ----

Calculate the total period over which PTO can be

accrued for the plan.

--------------------------------------------------- */

18. AccrualPeriodStartDate=ACP_ENROLLMENT_START_DATE

19. AccrualPeriodEndDate=LEAST(ACP_ENROLLMENT_END_DA TE,

ACP_TERMINATION_DATE)
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20. /*---------------------------------------------- ----

Calculate the total period over which absences can be

recorded for the plan.

--------------------------------------------------- */

21. AbsencePeriodStartDate=ACP_ENROLLMENT_START_DATE

AbsencePeriodEnd=ACP_ENROLLMENT_END_DATE

22 /*-----------------------------------------------

Get the date on which the employee was hired.

-----------------------------------------------*/

23. EmpHireDate=EMP_HIRE_DATE

24. /*---------------------------------------------- --

The next section calculates the PTO they accrued

in the previous year.

-------------------------------------------------*/

25. /*---------------------------------------------- -

School Leavers

If the school leaver joined the company and was enrolled

on the plan in the previous year, then they automatically

accrue the full entitlement for the next year i.e. 24 days.
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If this condition is not met then the general rules apply.

------------------------------------------------*/

26. IF((EmpHireDate>=PrevYrStartDate)AND

27. (EmpHireDate<=PrevYrEndDate) AND

28. (AccrualPeriodStartDate<=PrevYrEndDate) AND

29. (AccrualPeriodEndDate>=PrevYrStartDate) AND

30. (PEOPLE_BE_SCHOOL_LEAVER=’YES’)) THEN

(

31. PrevYrAccruedPTO=24

)

32. /*---------------------------------------------- -

General rule: Accrue 2 days per complete calendar month in

the previous year when they were enrolled on the plan.

If they joined the plan on or before the 15th of the month

then the month is included. If they were terminated, then

only include the month if it was the last day of the month.

--------------------------------------------------- -----*/

ELSE

33. /*---------------------------------------------- -------

1-128 Oracle Human Resources Management Systems FastFormula User Guide



They started accruing PTO after the end of the previous year

or ceased to accrue PTO before the start of the previous

year.

--------------------------------------------------- -----*/

34. IF ((AccrualPeriodStartDate>PrevYrEndDate)OR(Accr ualPeriodEn
dDate<PrevYrStartDate))

THEN

(

35. PeriodsToCount=0

)

36. /*---------------------------------------------- ---------

They were eligible for accruing PTO at some point during

the previous year.

--------------------------------------------------- -----*/

ELSE

(

37. /*---------------------------------------------- ----

Calculate the date in the previous year from which they

started accruing PTO.
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--------------------------------------------------- --*/

38. PrevYrAccrualPeriodStartDate=GREATEST(PrevYrStar tDate, Accru
alPeriodStartDate)

39. /*---------------------------------------------- -----

Calculate the date in the previous year from which they

stopped accruing PTO.

--------------------------------------------------- ---*/

40. PrevYrAccrualPeriodEndDate=LEAST(PrevYrEndDate, A ccru
alPeriodEndDate)

41. /*---------------------------------------------- ------

Their eligibility started on or before the 15th of the month
so include it as a month where they can accrue PTO.

--------------------------------------------------- --*/

42. IF(TO_NUMBER(TO_CHAR(PrevYrAccrualPeriodStartDat e, ’DD’))<=1
5)THEN

(

43. StartPeriodNum=TO_NUMBER(TO_CHAR(PrevYrAccrualPe riodStartDat
e, ’MM’))

)

44. /*---------------------------------------------- ----------

Their eligibility started after the 15th of the month so
exclude it as a month they can accrue PTO.

--------------------------------------------------- ------*/
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ELSE

(

45. StartPeriodNum=TO_NUMBER(TO_CHAR(PrevYrAccrualPe riodStartDat
e, ’MM’))+1

)

46. /*---------------------------------------------- -----------

Their eligibility ended at the end of the month so include i
t

as a month where they can accrue PTO

--------------------------------------------------- --------*
/

47. IF (TO_NUMBER(TO_CHAR(PrevYrAccrualPeriodStartDat e,’DD’))<=1
5)THEN

(

StartPeriodNum=TO_NUMBER(TO_CHAR(PrevYrAccrualPerio dStartDate,’MM
’))

)

48. /* ---------------------------------------------- ----------

Their eligibility started after the 15th of the month so

exclude it as a month where they can accrue PTO.

--------------------------------------------------- ------*/

ELSE

FastFormula 1-131



(

49. StartPeriodNum=TO_NUMBER(TO_CHAR(PrevYrAccrualPe riodStartDat
e, ’MM’))+1

)

50. /* ---------------------------------------------- ---------

Their eligibility ended at the end of the month so include i
t

as a month where they can accrue PTO.

--------------------------------------------------- ------*/

51. LastDayOfMonth=ADD_DAYS(TO_DATE(TO_CHAR(ADD_MONTHS(PrevYrAc
crualPeriodEndDate,1),’YYYYMM’)||’01’,’YYYYMMDD’),- 1)

52. IF (PrevYrAccrualPeriodEndDate=LastDayOfMonth) THE N

(

53. EndPeriodNum=TO_NUMBER(TO_CHAR(PrevYrAccrualPeri odEndDate,’M
M’))

)

54. /* ---------------------------------------------- ---------

Their eligibility ended during the month so exclude it

as a month where they can accrue PTO.

--------------------------------------------------- --------*
/

ELSE
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(

55. EndPeriodNum=TO_NUMBER(TO_CHAR(PrevYrAccrualPeri odEndDate, ’
MM’))-1

)

56. /*---------------------------------------------- ----------

There were no periods in the previous year from which to

accrue PTO.

--------------------------------------------------- ------*/

57. IF((StartPeriodNum>12)OR(EndPeriodNum<1)OR(Start PeriodNum>En
dPeriodNum))

THEN

(

58. PeriodsToCount=0

)

59. /*---------------------------------------------- --------

Calculate the number of periods in the previous year from

which to accrue PTO.

--------------------------------------------------- ----*/

ELSE

(
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60. PeriodsToCount=EndPeriodNum-StartPeriodNum+1

)

)

61. /*---------------------------------------------- ------------
-

They have at least one calendar month in which they can

accrue PTO so loop for each month and sum the total

accrued PTO.

--------------------------------------------------- ---------*
/

62. IF (PeriodsToCount>0)THEN

. (

63. /* ---------------------------------------------- ---------

Set up variables to be used by the subformula.

--------------------------------------------------- -----*/

64. E=set_number(’total_accrued_pto’,0)

65. E=set_number(’periods_to_count’,PeriodsToCount)

66. E = set_text(’prev_year’,PrevYr)

67. E = set_number(’period_count’,1)

68. E = set_number(’period_num’,StartPeriodNum)
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69. /*---------------------------------------------- ----------

Loop for each eligible period within the previous year.

--------------------------------------------------- -----*/

70. E = LOOP_CONTROL(’PTO_BE_PREVYR_PERIOD_ACCRUAL’)

71. /*---------------------------------------------- ------------
-

Get the total calculated accrued PTO.

--------------------------------------------------- --------*
/

72. PrevYrAccruedPTO=get_number(’total_accrued_pto’)

)

73. /*---------------------------------------------- ------------
-

They have no calendar months in which they can accrue PTO

--------------------------------------------------- --------*
/

Else

(

74. PrevYrAccruedPTO=0

)

(

FastFormula 1-135



75. /*---------------------------------------------- ------------
-

Calculate the adjustment to be made to the total accrued PTO f o
r

this year i.e any holidays already taken, any carryover, and

also any other extra entitlements/reductions (holidays

bought/sold).

--------------------------------------------------- ----------*/

76. /*---------------------------------------------- ------------
-

Calculate the start date in the current year over

which to count absences.

--------------------------------------------------- --------*
/

77. CurrYrAbsenceStartDate=GREATEST(CurrYrStartDate, AbsencePeri
odSTartDate)

78. /*---------------------------------------------- ------------
-

Calculate the end date in the current year over

which to count absences.

--------------------------------------------------- --------*
/

79. CurrYrAbsenceEndDate=calculation_date
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80. /*---------------------------------------------- ------------
-

Calculate the outstanding accrued PTO for the current year.

--------------------------------------------------- ---------*
/

81. total_accrued_pto=PrevYrAccruedPTO

82. effective_start_date=CurrYrAbsenceStartDate

83. effective_end_date=CurrYrAbsenceEndDate

84. effective_end_date=CurrYrAbsenceEndDate

85. RETURN total_accrued_pto, effective_start_date, eff ective_en
d_date, accrual_end_date

Looping Formula

1. /* ----------------------------------------------

NAME : PTO_BE_PREVYR_PERIOD_ACCRUAL

This formula calculates the accrued PTO for a particular

calendar month.

------------------------------------------------*/

2. TotalAccruedPTO=get_number(’total_accrued_pto’)

3. PeriodsToCount=get_number(’periods_to_count’)

4. PrevYr=get_text(’prev_year’)

5. PeriodCount=get_number(’period_count’)
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6. PeriodNum=get_number(’period_num’)

8. /*-----------------------------------------------

Calculate the start and end dates of the period.

9. Note: This is always a calendar month.

....----------------------------------------------- ------*/

11. CurrPerStartDate=TO_DATE(PrevYr||LPAD(TO_CHAR(Pe riodNum),2,’0
’)||’01’,’YYYYMMDD’)

12. CurrPerEndDate=ADD_DAYS(ADD_MONTHS(CurrPerStartD ate,1),-1)

13 /*----------------------------------------------- ------

Calculate the accrued PTO for the period. In this example 2

days are accrued per calendar month.

*/------------------------------------------------- --------

14. PeriodAccruedPTO=2

15. /* ---------------------------------------------- ----

Add the accrued PTO for the period to the running total.

--------------------------------------------------- -*/

16. E=set_number(’total_accrued_pto’,TotalAccruedPTO +PeriodAccrue
dPTO)

17. /*---------------------------------------------- -

There is at least one more period to process.
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-----------------------------------------------*/

18. IF PeriodCount+1<=PeriodsToCount THEN

(

19. E=set_number(’period_count’,PeriodCount+1)

E=set_number(’period_num’,PeriodNum+1)

20. continue_processing_flag=’Y’

)

21. ELSE

(

22. continue_processing_flag=’N’

)

23. RETURN continue_processing_flag

Changing the Accrual Term Start and End Dates

The accrual term start date is set to 01 January at line 11 of the sample top level
formula. To use another fixed date (such as 01 June) replace this line with the following:

PrevYrStartDate = to_date(PrevYr||’0601’,’YYYYMMDD’)

The end date is set to 31st December at line 12 of the sample formula. To use another
fixed date (such as 31st May) replace this line with the following:

PrevYrEndDate = to_date(PrevYr||’3105’,’YYYYMMDD’)

Changing the Ceiling

In the sample top level formula, the ceiling is set to 0, which means that no ceiling is
set. You can change the ceiling within the formula if you want to include a ceiling
amount:
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E = SET_NUMBER(’CEILING’, 20)

You can also set the ceiling outside the formula, using the Accrual Bands window or
a user table.

Changing the School Leavers PTO Entitlement

The sample formula sets the amount of accrued PTO that a school leaver can receive in
line 31. You can edit this amount to suit your business requirements. If the formula uses
the School leaver calculation, the looping formula is not called because it does not need
to loop through the eligible periods and calculate accrued PTO.

Changing the Eligibility Periods

The sample formula assumes that for an employee to be eligible to accrue PTO in a
calendar month they must have joined on or before the 15th of the month. You can
change this date in line 42. Lines 43 through 60 contain the logic to see if an employee is
eligible to accrue the PTO for a month.

Changing the Amount of Accrued Time Allowed

The sample formula specifies a fixed amount of PTO that is allowed per calendar
month. This is set in line 14 of the looping formula. You can change this to suit your
business requirements:

PeriodAccruedPTO=3

A further example of an accrual formula and suggested ways of implementing accrual
plan rules is described in Sample Accrual Formula, page 1-108.

Editing a Quick Paint Formula Example
If you want to add features to a generated QuickPaint formula, you must copy the
formula and edit the copy. If you edit the original, your edits will be overwritten if the
formula is regenerated from the QuickPaint definition.

In the following example, an automatically generated QuickPaint formula has been
edited to add Line 09, which totals the input values used in the report.
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LINE01=’’

LINE02=’ Pay Items Value this Period

LINE03=’’

LINE04=’ Salary Value : ’ + TO_TEXT(trunc((SALARY_ANNUAL/ 12),2))

LINE05=’ Item 1 Value : ’ + TO_TEXT(ITEM_1_PAY_VALUE)

LINE06=’ Item 2 Value : ’ + TO_TEXT(ITEM_2_PAY_VALUE)

LINE07=’ Bonus Value : ’ + TO_TEXT(BONUS_AMOUNT)

LINE08=’ __________________’

LINE09=’ Total : ’+ TO_TEXT(trunc((

(SALARY_ANNUAL/12)+ITEM_1_PAY_VALUE+ITEM_2_PAY_VALUE+BONUS_AMOUNT)
,2))

LINE10=’’

LINE11=’’

LINE12=’’

RETURN LINE01, LINE02, LINE03, LINE04, LINE05, LINE06, LIN E07,

LINE08, LINE09, LINE10, LINE11, LINE12,

Checking an Element Entry Example
You can use FastFormula to validate user entries in element input values. For
example, you can make sure that entries are within a specified range or do not exceed a
predefined value.

The formula below checks that the entry value of the Salary element does not exceed
200,000.
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Salary Element

hr_33a.gif

/* Formula Name: Salary Range */

/* Formula Type: Element Input Validation */

INPUTS ARE entry_value (text)

IF TO_NUM(entry_value) > 200000

THEN

(

formula_status = ’e’

formula_message = ’Too much money . . . try again!’

)

ELSE
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(

formula_status = ’s’

formula_message = ’Fine’

)

RETURN formula_status, formula_message

Checking a User Table Entry Example
You can use FastFormula to validate user entries into user tables that you define. For
example, you can make sure that entries are between a specified range or not a negative
amount.

The formula below checks that the deduction entered in the Union A column of the
Union Dues table is between 10.00 and 20.00.

/* Formula Name: Union A Dues Validation */

/* Formula Type: User Table Validation */

INPUTS ARE entry_value (text)

IF TO_NUMBER(entry_value) < 10.00 OR

TO_NUMBER(entry_value) > 20.00

THEN

(

formula_status = ’e’

formula_message = ’Error: Union A dues must be between

$10.00 and $20.00.’
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)

ELSE

(

formula_status = ’s’

formula_message = ’ ’

)

RETURN formula_status, formula_message

Sample Payroll Formulas Enabled for Proration (UK Only)
The following sample formulas show how you can create payroll formulas to be used in
different situations requiring proration.

Oracle Corporation may change or upgrade these formulas in future releases of HRMS
programs. These formulas are strictly for example or prototype purposes only, and are
not intended to provide a ready-made solution to be used in your environment. You
can make a copy of these formulas, subject to the terms of the license agreement
for the programs, but you should not change your copied version for prototyping
purposes. You should always write a new formula of your own to meet your particular
requirements. These formulas may contain certain hard-coded values to simplify the
use of formulas for proration.

A typical example of proration would be when a new employee starts work in the
middle of a monthly payroll period and your payroll department makes a pro-rata
payment to reflect the proportion of monthly pay to which the employee is entitled.

The prototype formula supplied is only designed to work for payroll calculations
involving proration and should not be used for any other purpose. Any use of the
formula is subject to the terms of the Oracle license agreement for the HRMS programs
and documentation.

FastFormula to use if Employee is Paid using Salary Administration

/************************************************** *

Formula name : FF_PRORATION_SAL_MANAGEMENT

Formula to calculate salary in proration
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DISCLAIMER: Oracle Corporation may change or upgrade this F astFor
mula in the future releases. This FastFormula is strictly fo r exam
ple or prototype purposes only. This FastFormula is not inte nded t
o provide a ready-made solution to the users. This formula ma y con
tain certain hard-coded values added to simplify the concep t of us
age of FastFormulas in proration. Users should make a copy of this

formula and not change this formula. Users need to write thei r ow
n new formula(s) to meet requirements.

*************************************************** *

default for ASG_SALARY_BASIS_GRADE_ANNUALIZATION_FACT OR is 0

default for prorate_start is ’01-JAN-1990’ (date)

default for prorate_end is ’01-JAN-1900’ (date)

default for PAY_PROC_PERIOD_START_DATE IS ’01-JAN-1950’ (date)

default for PAY_PROC_PERIOD_END_DATE IS ’01-JAN-1950’ (d ate)

default for NI_NEW_TAX_YEAR IS ’01-JAN-1950’ (date)

default for annual_salary is 0.0

inputs are annual_salary (number),

prorate_start (date),

prorate_end (date)

/**

Prorate_start and prorate_end dates are passed from the pay roll e
ngine. These dates basically represent the dates on which th e chan
ges occur in the salary amount during the pay period. annual_ salar
y is an input value created in the element to which this formul a w
ill be tied. Here the assumption is that the user enters the an nua
l salary amount through salary management.

**/
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l_amount=annual_salary

l_string = ’’

if(ASG_SALARY_BASIS_GRADE_ANNUALIZATION_FACTOR was not defaulted)
then

(

/**

This calculation makes sure that l_amount has the annual sal ary.

**/

l_amount =

amount*ASG_SALARY_BASIS_GRADE_ANNUALIZATION_FACTOR

)

/**

l_tax_year_start_date derives the value from the DBI

NI_NEW_TAX_YEAR.

The following calculation sets the start date of the tax year to
01-APR-YYYY and end date of the tax year to 31-MAR-(YYYY+1)

**/

l_tax_year_start_date = NI_NEW_TAX_YEAR

l_tax_year_start_date = TRUNC(l_tax_year_start_date,’ month’)

l_tax_year =
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TO_NUMBER(TO_CHAR(l_tax_year_start_date,’YYYY’)) + 1

l_tax_year_end_date =

TO_DATE(’31/03/’||TO_CHAR(1_tax_year),’DD/MM/YYYY’)

/**

The following calculation is for the case when no proration o ccur
s during the pay period and element entry start date and eleme nt e
ntry end date is not equal to the pay period start and end dates r
espectively.

**/

IF(prorate_start was defaulted) then

(

IF(PAY_PROC_PERIOD_END_DATE<>ENTRY_END_DATE) THEN

(

IF(PAY_PROC_PERIOD_START_DATE<>ENTRY_START_DATE) THEN

(

/**

Since prorate_start date is defaulted, it means no proratio n occu
red, therefore we simply return the annual salary amount div ided b
y 12.

**/

l_amount = ROUND(amount/12,2)

result1 = l_amount
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return result1

)

)

)

l_post_calc = ’N’

/**

l_post_calc is a flag used to do the calculation differently depe
nding on the values of this flag.

**/

/**

The following if condition takes care of the case when

Either

The element entry starts on the same day as pay period start da te

OR

Prorate start date IS EQUAL TO element entry start date AND

Prorate start date IS NOT EQUAL TO one day prior to pay period s t
art date.

For example, in a monthly payroll running for the month of Jun e 2
000.

Either

Element entry start date is )01-JUN-2000 (employee starts o n the
first day of the payroll period)
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OR

Prorate start date is 14-JUN-2000 (employee starts in the mi ddle
of the month or gets a salary change in the middle of the month)

Prorate start date IS NOT 31-MAY-2000

**/

if((prorate_start = ENRTY_START_DATE and

prorate_start <> ADD_DAYS(PAY_PROC_PERIOD_START_DATE, -1

)) or

ENTRY_START_DATE = PAY_PROC_PERIOD_START_DATE) then

(

/**

This code is executed when it is a new entry. Thus the post calc
must be performed.

**/

l_post_calc = ’Y’

)

else

(

if(prorate_end<>ENTRY_END_DATE) then

(
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if(prorate_end = PAY_PROC_PERIOD_END_DATE) then

)

/**

This code is executed when it is a normal last proration entry . T
hus the post calc must be performed.

**/

l_post_calc = ’Y’

)

)

)

/**

The following code sets the right proration start and end dat es*/

**/

if(prorate_start was defaulted) then

(

/**

Prorate start is defaulted when no proration occurs

**/

if(ENTRY_START_DATE=PAY_PROC_PERIOD_START_DATE) then

(
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/**

Element entry start date is the same as the payroll period sta rt
date

**/

prorate_start=ENTRY_START_DATE

if(ENTRY_END_DATE=PAY_PROC_PERIOD_END_DATE) then

(

prorate_end=ENTRY_END_DATE

)

else

(

prorate_end=PAY_PROC_PERIOD_END_DATE

)

r)

else if(ENTRY_END_DATE=PAY_PROC_PERIOD_END_DATE) then

(

prorate_end=ENTRY_END_DATE

prorate_start=PAY_PROC_PERIOD_START_DATE

)

)
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/*Do we have to do daily calc*/

if((prorate_start>PAY_PROC_PERIOD_START_DATE

and prorate_end<PAY_PROC_PEROD_END_DATE)

or

(prorate_start=PAY_PROC_PERIOD_START_DATE

and prorate_end<PAY_PROC_PERIOD_END_DATE

and prorate_start=ENTRY_START_DATE)) then

(

l_post_calc=’D’

)

/*Now perform the calculations*/

if(l_post_calc=’N’) then

(

/*Perform in the pre mode, i.e.start of year to current date* /

l_days=days_between(prorate_end,

l_tax_year_start_date) + 1

l_amount1=l_amount * 1_days/365

l_months=TRUNC(months_between(PAY_PROC_PERIOD_START _DATE,

l_tax_year_start_date
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))

l_amount2=1_amount * l_months/12

result1=1_amount1-l_amount2

)

else

)

if(l_postcalc+’Y’) then

)

/*perform in post mode, i.e.current date to end of year*/

l_days=days_between(l_tax_year_end_date,

prorate_start) + 1

l_amount1=l_amount*l_days/365

l_months=TRUNC(months_between(l_tax_year_end_date,

PAY_PROC_PERIOD_END_DATE

l_amount2=l_amount*l_months/12

result1=l_amount1-l_amount2

)

else

(

FastFormula 1-153



/**

This code is executed when l_post_calc=D. Perform in daily m ode.

**/

l_days=days_between(prorate_end,prorate-start) + 1

l_amount1=0

l_months=0

l_amount2=0

result1=l_amount*l_days/365

)

)

/**

The following code is just to convert all the non-character v aria
bles into the character variables, so that the values of the v aria
bles could be displayed in the messages available either in S OE fo
rm or messages.

**/

prorate_start_res=to_char(prorate_start,’DD-MON-YYY Y’)

prorate_end_res=to_char(prorate_end,’DD-MON-YYYY’)

l_days_res=TO_CHAR(l_days)

l_amount1_res=TO_CHAR(l_amount1)
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l_months_res=TO_CHAR(l_months)

l_amount2_res=TO_CHAR(l_amount2)

return result1,

l_post_calc,

l_days_res,

l_amount1_res,

l_months_res,

l_amount2_res,

prorate_start_res,

prorate_end_res

FastFormula to use if Employee is Paid using a Spinal Point/Pay Scale

/************************************************** *********

Formula Name = UK_PRORATION_SPINAL_POINT

Formula Type = Oracle Payroll

Description: This formula is executed from within the payro ll run
by processing the element UK Salary Spinal Point. It calcula tes t

he rate of pay and returns this value. It uses the version of th e
function RATES_HISTORY which requires a date input to be pas sed. T
his formula is just a prototype.
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DISCLAIMER: Oracle Corportation may change or upgrade this fast f
ormul in the future releases. This FastFormula is strictly f or exa
mple or prototype purposes. This FastFormula is not intende d to pr
ovide a ready-made solution to the users. This formula may co ntain

certain hard-coded values added to simplify the concept of u sage
of FastFormulas in proration. Users should make a copy of thi s for
mula and not change this formula. Users need to write their ow n ne
w formula(s) to meet requirements.

*************************************************** *********/

DEFAULT FOR date_worked IS ’01-JAN-1950’(date)

DEFAULT FOR PAY_PROC_PERIOD_END_DATE IS ’01-JAN-1950’(date)

DEFAULT FOR PAY_PROC_PERIOD_START_DATE IS ’01-JAN-1950’(date)

DEFAULT FOR prorate_start IS ’01-JAN-1950’(date)

DEFAULT FOR prorate_end IS ’01-JAN-1950’(date)

inputs are prorate_start(date),

prorate_end(date)

/**

Prorate_start and prorate_end dates are passed from the pay roll e
ngine. These dates basically represent the dates on which th e chan
ges occur in the pay scale/grade rate during the pay period.

**/

amount=0

message=’’

IF(prorate_start WAS DEFAULTED)then

(
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/**

prorate_start date is defaulted when no proration occurs

**/

l_date_worked=PAY_PROC_PERIOD_END_DATE

prorate_start=PAY_PROC_PERIOD_START_DATE

prorate_end=PAY_PROC_PERIOD_END_DATE

)

else

)

l_date_worked=prorate_end

)

message1=’Date defaulted to’||TO_CHAR(date_worked,’DD -MON-YYYY’)

/**

The following function returns the value of the pay scale on t he
l_date_worked which is last date of hte payroll period if no p rora
tion occurs, otherwise it is the proration end date.

**/

if rates_history(l_date_worked,

’UK Spinal Point,

’E’,
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’P’,

amount,

message)= -1 then

(

return message, message1

)

else

(

l_days = days_between(prorate_end,prorate_start)+ 1

/**

l_days stores the number of days between prorate start and pr orat
e end dates

**/

message1 = ’The value is’||TO_CHAR(ROUND(amount,2))||fo r=’||
TO_CHAR(l_days||’days from ’||TO_CHAR(prorate_start,’ DD-MON-YYYY’)
||’to’||TO_CHAR(prorate_end,’DD-MON-YYYY’)

/**

The message is just for informational purposes.

**/

l_amount=amount*(12*1_days/365)

/**
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The above calculation is hard-coded to simplify the calcula tion.
Please write your own calculation logic. The assumption was that t
he value in the pay scale is monthly. Therefore to get annual a mou
nt it is multiplied by 12. Then it is divided by 365 days to get t
he amount for a single day. Once it is multiplied by l_days, we ge
t the amount for the days we want.

**/

/**

It is another assumption that a year contains 365 days. Pleas e ch
ange this assumption to take account of the leap year. This fo rmul
a will not work properly in a leap year.

**/

return l_amount, message1

)

FastFormula to Use if Employee is Paid Using a Grade Rate

/************************************************** **************

Formula Name = UK_PRORATION_GRADE_RATE

Formula Type = Oracle Payroll

Description: This formula is executed from within the payro ll run
by processing the element UK Salary Grade Rate. It calculate s the
rate of pay and returns this value. It uses the version of the f u

nction RATES_HISTORY which requires a date input to be passe d. Thi
s formula is just a prototype.

DISCLAIMER: Oracle Corporation may change or upgrade this F astFor
mula in the future releases. This FastFormula is strictly fo r exam
ple or prototype purposes only. This FastFormula is not inte nded t
o provide a ready-made solution to the users. This formula ma y con
tain certain hard-coded values added to simplify the concep t of us
age of FastFormulas in proration. Users should make a copy of this

formula and not change this formula. Users need to write thei r ow
n new formula(s) to meet requirements.
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*************************************************** *************/

DEFAULT FOR date_worked IS ’01-JAN-1950’(date)

DEFAULT FOR PAY_PROC_PERIOD-END_DATE IS ’01-JAN-1950’(d ate)

DEFAULT FOR PAY_PROC_PERIOD-START-DATE IS ’01-JAN-1950’ (date)

DEFAULT FOR prorate_start IS ’01-JAN-1950’(date)

DEFAULT FOR prorate_end IS ’01-JAN-1950’(date)

inputs are prorate_start(date),

prorate_end(date)

/**

Prorate_start and prorate_end dates are passed from the pay roll e
ngine. These dates basically represent the dates on which th e chan
ges occur in the pay scale/grade rate during the pay period.

**/

amount = 0

message = ’’

IF(prorate_start WAS DEFAULTED)then

(

/**

prorate_start date is defaulted when no proration occurs

**/
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l_date_worked=PAY_PROC_PERIOD_END_DATE

prorate_start=PAY_PROC_PERIOD_START_DATE

prorate_end=PAY_PROC_PERIOD_END_DATE

)

else

(

l_date_worked=prorate_end

)

message1=’Date defaulted to’||TO_CHAR(date_worked,’DD -MON-YYYY’)

/**

The following function returns the value of the pay scale on t he
l_date_worked which is last date of the payroll period if no p rora
tion occurs, therwise it is the proration end date.

**/

if rates_history(l_date_worked,

’UK Grade Rate’,

’E’,

’H’,

amount,

message) = -1 then
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(

return message, message1

)

else

(

l_days = days_between(prorate_end,prorate_start) + 1

/**

l_days stores the number f days between prorate start and pro rate
end dates

**/

message1 = ’The value is’||TO_CHAR(ROUND(amount,2))||fo r=’||
TO_CHAR(1_days||’days from ’||TO_CHAR(prorate_start,’ DD-MON-YYYY’)
||’to’||TO_CHAR(prorate_end,’DD-MON-YYYY’)

/**

The message is just for informational purposes.

**/

l_amount=amount * ((l_days*1600)/365)

/**

The above calculation is hard-coded to simplify the calcuat ion. P
lease write your own calculatioin logic. The assumption was that t
he value in the grade rate is hourly. Therefore to get the annu al
amount it is multiplied by 16000 hours (assuming that there a re 16
00 hours in a year). Then it is divided by 365 days to get the amo
unt for a single day. Once it is multiplied by l_days, we get th e
amount for the days we want.
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**/

/**

It is another assumption that a year contains 365 days. Pleas e ch
ange this asusmption to take account of leap year. This formu la wi
ll not work properly in a leap year.

**/

return l-amount,message1

)

FastFormula to use for a Deduction

/************************************************** **************
*

Formula name: UK_PRORATION_DEDUCTIONS

Purpose: Formula prototype to calculate prorated deductio ns.

DISCLAIMER: Oracle Corporation may change or upgrade this F astFor
mula in future releases. This FastFormula is strictly for ex ample
or prototype purposes only. This FastFormula is ot intended to pro
vide a ready-made solution for the user. This formula may con tain
certain hard-coded values added to simplify the concept of u sage o
f FastFormulas in proration. Users should make a copy of this form
ula and not change this formula. Users need to write their own new

formula(s) to meet requirements.

*************************************************** **************
/

default for prorate_start is ’01-JAN-1900’(date)

default for prorate_end is ’01-JAN-1900’(date)

default for amount is 0.0
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inputs are

prorate_start(date),

prorate_end(date),

annual_deduction(number)

/**

Prorate-start and prorate_end dates are passed from the pay roll e
ngine. These dates basically represent the dates on which th e chan
ges occur in the deduction amount during the pay perod. annua l_ded
uction is an input value created in the element to which this f orm
ula will be tied. Here the assumption is that the user enters t he
annual deduction amount in the input value.

**/

l_amount=annual_deduction

message=’Proration Start Date’||TO_CHAR(prorate_start , ’DD-MON-YY
YY’)

IF(prorate_start was defaulted)then

(

/**

prorate_start date is defaulted when no proration occurs. T herefo
re we should just return the annual deduction amount divided by 12
.

**/

l_amount=l_amount/12

return l_amount
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)

else

(

l_days=days_between(prorate_end, prorate_start) + 1

/**

l_days stores the number of days between prorate start and pr orat
e end dates

**/

l_days_in_fiscal_year=365

/**

It is another assumption that a year contains 365 days. Pleas e ch
ange this assumption to take care of leap year. This formula w ill
not work properly in a leap year.

**/

l_amount=(l_amount*l_days)/l_days_in_fiscal_year

/**

In the above calculation, since l_amount contains the annua l dedu
ction amount, it is divided by 365 days of the year to get the de d
uction amount per day. This amount is then multiplied by the n umbe
r of days in question to get the proper deduction amount

**/

return l_amount, message

)
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Sample Rates History Formulas (UK Only)
The following sample formulas show how you can create payroll formulas to be used in
different situations requiring historic rates.

Oracle Corporation may change this formula in future releases. This formula is strictly
for example or prototype uses only, and is not intended to provide a ready-made
solution. You can make a copy of this formula but you should not change your copied
version. Always write a formula of your own to meet your own requirements. This
formula may contain certain hard-coded values for simplified use.

FastFormula to Calculate the Salary when Attached to a Grade Rate

/************************************************** *

Formula name : Grade_Rate_Formula

Description : Formula to calculate the salary when attached to a
Grade Rate

*************************************************** *

inputs are date_worked(date)

amount=0

message=’’

if rates_history (date_worked,

’Salary Element GR’,

’E’,

’P’,

amount,

message)=-1 then
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(

return message

)

else

(

return amount

)

.

FastFormula to Calculate the Salary when Attached to a Spinal Point

/************************************************** *

Formula name : Spinal_Point_Formula

Description : Formula to calculate the salary when attached to a
Spinal Point

*************************************************** *

inputs are date_worked(date)

amount=0

message=’’

if rates_history (date_worked,

’Salary Element SP’,

’E’,
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’P’,

amount,

message)=-1 then

(

return message

)

else

(

return amount

)

.

FastFormula to Calculate the Salary when Attached to a Global Value

/************************************************** *

Formula name : Global_Value_Formula

Description : Formula to calculate the salary when attached to a
Global Value

*************************************************** *

inputs are date_worked(date)

amount=0

message=’’
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if rates_history (date_worked,

’Salary Element GV’,

’E’,

’P’,

amount,

message)=-1 then

(

return message

)

else

(

return amount

)

.

FastFormula to Calculate the Salary when there is an Input Value

/************************************************** *

Formula name : Input_Value_Formula

Description : Formula to calculate the salary when there is a n in
put value

*************************************************** *
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inputs are date_worked(date)

amount=0

message=’’

if rates_history (date_worked,

’Salary Element IV’,

’E’,

’P’,

amount,

message)=-1 then

(

return message

)

else

(

return amount

)

.

FastFormula to Calculate the Overtime when there is a Rate Type

/************************************************** *
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Formula name : Overtime_Formula

Description : Formula to calculate the overtime when there i s an
rate type

*************************************************** *

inputs are date_worked(date)

amount=0

message=’’

if rates_history (date_worked,

’Overtime Element’,

’R’,

’P’,

amount,

message)=-1 then

(

return message

)

else

(

return amount

)
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.

Parameters for the Rates History Function

The sample formulas can call the Rates History function. The contexts, parameters and
return values for the Rates History function are as follows:

***************************************************

Function Rates History

*************************************************** *

(p_assignment_id IN NUMBER -- Context.

,p_calculation_date IN DATE

,p_name IN VARCHAR2

,p_rt_element IN VARCHAR2

,p_to_time_dim IN VARCHAR2

,p_rate IN OUT NUMBER

,p_error_message IN OUT VARCHAR2

)

RETURN NUMBER

CONTEXT => DESCRIPTION

-------------------------------------
-------------------------

p_assignment_id => Identifier of the assignment to p
rocess.
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PARAMETER NAME => DESCRIPTION

--------------------------------------------------- --------------
-

p_calculation_date => The effective date as of which th
e rate should be calculated.

p_name => The name of the Rate Type name or
the Element to be processed. The

actual meaning of the parameter
depends on what is passed in t

he next parameter, p_rt_element.
Note a valid Rate Type name must
match with one of the meanings o

f lookup, PQP_RATE_TYPE.

p_rt_element => Identifies what parameter, p_name
, refers to. Can be thought of as

a "mode" of operation for
rates_history. Only two value

s are possible, ’R’ or ’E’.

’R’ -> Identifies that p_name is
the name of a Rate Type.

Tells rates history to derive the
rate as the sum of all elements

which have an extra information
type," Rate Type",set to whate

ver is passed in p_name
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’E’ -> Identified p_name refers
to the name of a single element.

p_to_time_dim => The output time dimension of the
rate.

Possible values:

’H’ -> Hourly

’D’ -> Daily Rate

’P’ -> Period

(as defined by
PERIOD DIVISOR

in the contract
type table)

’O’ -> OT Annual Hours

’A’ -> Annual

’PAY’ -> Pay Period Value (a
s defined by MONTHLY/ WEEKLY PERIOD DIVISOR in the contract t ype
table)
p_rate => holds the returned rate value.

p_error_message => holds the error message. In a
payroll this can be passed on to

the formula run result for

error messages.
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RETURN values => DESCRIPTION

--------------------------------------------------- ----------

0 Successful

-1 An error occurred. Check
p_error_message for description.

Sample Deduction Formula Calling the Arrearage Function (UK Only)
The following sample formula shows how you can create payroll formulas for pre-tax or
voluntary deductions if you want to maintain an arrears balance. This formula does not
handle iterative processing for pre-tax deductions. If you are writing a formula for a
pre-tax deduction and you want it to handle iterative processing too, use the seeded
GAYE formula as the example on which to base your own formula.

Oracle Corporation may change this formula in future releases. This formula is strictly
for example or prototype uses only, and is not intended to provide a ready-made solution.

/* ================================================= =============
=============
* SECTION (1):Default values for database items
* ================================================== =============
============
*/
Default for NET_PAY_ASG_RUN Is 0
/*
Uncomment this code if your deduction has a Clear Arrears inp ut v
alue.
Default for Clear_Arrears Is ’N’
*/
/* ================================================= =============
=============
* SECTION (2): Element Input Values
* ================================================== =============
============ */
Inputs are Amount,
Percentage
/* If your deduction has a Clear Arrears input value, add Clea r_A
rrears (text) to the Inputs statement. */
/* ================================================= =============
=============
* SECTION (3): Initialize Local Variables
* ================================================== =============
============
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*/
/* ================================================= =============
===========
* SECTION (3.1): Default Iterative Arrearage Function’s Ou t Value
s
* ================================================== =============
==========
*/
l_Actual_Usercalc_Amt = 0 /* Act.Ded.Amt for the Period

*/
l_Max_Amount = 0 /* Max Amt that can be taken, on the ea
rnings */
l_Min_Amount = 0 /* Min Amt usually set to zero

*/
l_Not_Taken = 0 /* Amt that could’nt be taken due to in
suff.earnings*/
l_To_Arrears = 0 /* Amt that is added to Arrears, to be
rec.later */
l_Arrears_Taken = 0 /* Amt that was taken from the Arrears

*/
l_Error_Message = ’ ’ /* Error message from the Arrearage F
unction */
l_Warning_Message = ’ ’ /* Warning message from the Arrearag e

Function*/
l_Return_Value = 0 /* Iterative Arrearage function retur
n value */
l_mesg_1 = ’ ’ l_mesg_2 = ’ ’
/* ================================================= =============
===========
* SECTION (3.2): Default Local variables with DB items
* ================================================== =============
==========
*/
l_clr_add_amt = 0 /* Additional Amount */
l_clr_rep_amt = 0 /* Replacement Amount */
l_deduction_amount = 0 /* Actual Deduction Amount */
l_arrears_allowed = ’ ’
l_partial_allowed = ’ ’
/* ================================================= =============
=============
* SECTION (4): Formula Calulation
* ================================================== =============
============
*/
/* ================================================= =============
===========
* SECTION (4.1): Calculate the actual deduction amount
* ================================================== =============
==========
*/
l_Actual_UserCalc_Amt = Amount
l_deduction_amount = Amount
l_mesg_1 = l_mesg_1 ||’ Act.Ded.Amt=’||to_char(l_Actual _UserCalc_
Amt)
/* ================================================= =============
===========
* SECTION (4.2): Get Outstanding Arrears and calculate the r emain
ing amount
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* i.e. the Limit Amount and Guarantee Net Amount, if any.
* ================================================== =============
==========
*/
l_Return_Value = PQP_GET_ARREARAGE_OPTIONS(l_arrears_ allowed
,l_partial_allowed
,l_Error_Message)
l_Remaining_Amt = 0 /*If Voluntary deduction has limits, sp ecify

the rem. amt */
l_MaxArrears_Amt = 0 /*Out standing Arrears for the element if Ar
rears allowed */
l_Guaranteed_Net = 0
/* ================================================= =============
===========
* SECTION (4.3): Call the Arrearage Function
* ================================================== =============
==========
*/
l_temp_ToArrears = 0
l_temp_NotTaken = 0
/* Uncomment this code only if the element has a Clear Arrears
* input value that has a value Y or N.
If the deduction has a limit, set l_remaining_amt to the limi t mi
nus the YTD deduction balance.
*/
/*
If Clear_Arrears = ’N’ Then
(
l_MaxArrears_Amt = <ARREARS_BALANCE_NAME_YTD>
l_remaining_amt = l_MaxArrears_Amt
)
Else
(
l_To_Arrears = -1 * <ARREARS_BALANCE_NAME_YTD>
l_MaxArrears_Amt = 0
)
*/
l_Deduction_Amount = PQP_Arrearage
(NET_PAY_ASG_RUN /* p_net_asg_run */
,l_MaxArrears_Amt /* p_maxarrears */
,l_Deduction_Amount /* p_dedn_amt */
,l_temp_ToArrears /* p_to_arrears In Out */
,l_temp_NotTaken /* p_not_taken In Out */
,l_Arrears_Taken /* p_arrears_taken In Out */
,l_Remaining_Amt /* p_remaining_amount */
,l_Guaranteed_Net /* p_guaranteed_net */
)
If l_temp_ToArrears <> 0
/* If the deduction has a Clear Arrears input value, uncommen t th
e following line*/
/* and Clear_Arrears <> ’Y’ */
Then
l_To_Arrears = l_To_Arrears + l_temp_ToArrears
If l_temp_NotTaken <> 0 Then
l_Not_Taken = l_temp_NotTaken
l_mesg_2 = l_mesg_2 ||’Arr.Ded.Amt=’||to_char(l_Deduct ion_Amount)
l_mesg_2 = l_mesg_2 ||’ Arrs=’||to_char(l_To_Arrears)
l_mesg_2 = l_mesg_2 ||’ NotT=’||to_char(l_Not_Taken)
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/* ================================================= =============
===========
* SECTION (4.6): Formula Run Results values
* ================================================== =============
==========
*/
Return l_Deduction_Amount,
l_Not_Taken,
l_To_Arrears,
l_mesg_1,
l_mesg_2

Sample Formulas for Payment Method (Saudi)
Oracle provides sample formulas that you can use to define payment method as per
your bank’s requirement.

A payment type is required to identify the method of payment for example, SA Direct
Deposit - SAR. This payment type should reference the generic magnetic tape procedure.

Formulas: The following formulas are created for Electronic File Transfer (EFT):

FORMULAS:

Formula Description

SA_EFT_HEADER This formula is the header section of the
payment output file. It calls the formula
function SA_GET_CUSTOMER_FORMULA_
HEADER which in turn fetches the various
required fields for the header part.

SA_EFT_HEADER_CUSTOMER This formula actually formats the fields fetched
by the SA_EFT_HEADER formula as per the
requirement. This formula is a sample and you
can format the fields as per your requirement.

SA_EFT_BODY This formula is the body section of the payment
output file. It calls the formula function SA_
GET_CUSTOMER_FORMULA_BODY which
in turn fetches the various required fields for
the body part.

SA_EFT_BODY_CUSTOMER This formula actually formats the fields fetched
by the SA_EFT_BODY formula as per the
requirement. This formula is a sample and you
can format the fields as per your requirement.

SA_EFT_FOOTER This formula is the footer section of the
payment output file. It calls the formula
function SA_GET_CUSTOMER_FOOTER
which in turn fetches the various required
fields for the footer section.

SA_EFT_FOOTER_CUSTOMER This formula actually formats the fields fetched
by the SA_EFT_FOOTER formula as per the
requirement. This formula is a sample and you
can format the fields as per your requirement.
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Formula Functions:The following formula functions are also created:

FORMULA FUNCTIONS:

Formula Function Description

SA_USER_CUSTOMER_FORMULA_
HEADER

This formula function fetches the values for
the fields, which are passed to it by the calling
formula SA_EFT_HEADER.

SA_USER_CUSTOMER_FORMULA_BODY This formula function fetches the values for
the fields, which are passed to it by the calling
formula SA_EFT_BODY.

SA_USER_CUSTOMER_FORMULA_FOOTER This formula function fetches the values for
the fields, which are passed to it by the calling
formula SA_EFT_FOOTER.

Customer Formula (Sample) Oracle Payroll provides a sample formula for you, to set up
your own formulas for Header, Body and Footer. This sample is based on superset of
data that supports EFT.

The following inputs are allowed in the header/footer and the body section of the
payment file, to write your own formula:

Header/Footer:

• CREATION_DATE, this refers to the effective date on which the payment file is
created as per Hijrah calendar (YYYYMMDD).

• PROCESS_DATE, this refers to the date on which the payment file is submitted as
per Hijrah calendar (YYYYMMDD).

• COUNT 1, this refers to the total number of employees.

• SUM1, this refers to the total amount. You would multiply the total amount with
hundred (100) to display the last two decimal points in your report.

Body:

• AMOUNT, this refers to the amount for each employee. You would multiply this
amount with hundred (100) to display the last two decimal points in your report.

• FIRST_NAME, this refers to the first name of the employee.

• LAST_NAME, this refers to the last name of the employee.

• EMP_NO, this refers to the employee number.

• ASG_NO, this refers to the assignment number of the employee.

• LOCAL_NATIONALITY, this refers to the local nationality of the employee.

The formula that you have defined should return all the WRITE_TEXT, REPORT1_TEXT
and REPORT2_TEXT variables that are set up in the formulas. WRITE_TEXT, REPORT1_
TEXT, and REPORT2_TEXT are the outputs that are available for you.

At the maximum you have they can have five WRITE_TEXT, five REPORT1_TEXT and
five REPORT2_TEXT variables. Each variable should not exceed 255 characters in size.
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You use the following contexts for each section of your own formula and use database
items for these values only.

Header / Footer:

• DATE_EARNED

• ORG_PAY_METHOD_ID

• BUSINESS_GROUP_ID

• PAYROLL_ID

• PAYROLL_ACTION_ID

Body:

• ASSIGNMENT_ID

• BUSINESS_GROUP_ID

• PER_PAY_METHOD_ID

• DATE_EARNED

• PAYROLL_ID

• PAYROLL_ACTION_ID

• ASSIGNMENT_ACTION_ID

• ORGANIZATION_ID

• TAX_UNIT_ID

Oracle Corporation may change this formula in future releases. This formula is strictly
for example or prototype uses only, and is not intended to provide a ready-made
solution. You can make a copy of this formula but you should not change your copied
version. Always write your own formula to meet your bank’s requirements. This
formula may contain certain hard-coded values for simplified use.

The prototype formula supplied is only designed to work for payment method and
should not be used for any other purpose. Any use of this formula is subject to the terms
of Oracle license agreement for the HRMS programs and documentation.

Sample for the Header is as follows:

*************************************************************** */

/* Formula Name: SA_EFT_HEADER

Description : This formula formats and writes header section of the Magnetic File. It
also writes data onto the audit report.

*************************************************************** */

/* Initialise database items */
DEFAULT FOR ORG_SA_BANK_NAME IS ’ ’
DEFAULT FOR ORG_SA_ACCOUNT_NUMBER IS ’ ’
INPUTS ARE CREATION_DATE (Text)

,PROCESS_DATE (Text)
,COUNT1 (Text)

,SUM1 (Text)
TRANSFER_SUM1 = SUM1

TRANSFER_COUNT1 = COUNT1
/* Customer to modify section below this */
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/* File Header */
WRITE_TEXT1 = ’0’ + /* Header Rec */

’000000000000’ + /* Key Header */
’G’ + /* Month Type */

CREATION_DATE + /* File Creation Date */
PROCESS_DATE + /* Salary Process Date */

’10000’ + /* Total Amount for All Employees*/
’100’ + /* Total Employees*/
LPAD(ORG_SA_ACCOUNT_NUMBER,15,’0’) + /* Company Account Number */

RPAD(’ ’,68,’ ’) + /*Filler*/
CHR(10)
/* Report File Header */
REPORT1_TEXT1 = ’ ’ + ’Header Record:’ + ’0

’ + CHR(10) + ’ ’+
’Key Header :’ + LPAD(’0’,12,’0’) + ’

+ ’File Creation Date :’ + LPAD(CREATION_DATE,12,’0’) + CHR (10)
/*REPORT1_TEXT2 = ’Header Record:’ + ’0 ’ +
’Month Type :’ + LPAD(’0’,12,’0’) + ’ ’
+ ’Salary Process Date :’ + LPAD(’0’,12,’0’) + CHR(10)
REPORT1_TEXT3 = ’Header Record:’ + ’0 ’ +
’File Creation Date:’ + LPAD(’0’,12,’0’) +
CHR(10)
REPORT1_TEXT4 = ’Header Record:’ + ’0 ’ +
’Salary Process Date:’ + LPAD(’0’,12,’0’) +
CHR(10)*/
REPORT1_TEXT2 = ’ ’ + ’Month Type :’ + LPAD(’GREGORIAN’
,12,’0’) + ’ ’
+ ’Salary Process Date :’ + LPAD(PROCESS_DATE,12,’0’) + CHR (10)
REPORT1_TEXT3 = ’ ’
REPORT1_TEXT4 = ’ ’’
REPORT1_TEXT5 = ’ ’+
’Total Employees :’ + LPAD(COUNT1,12,’0’)+
CHR(10)
/*Customer to modify section above this */
RETURN WRITE_TEXT1, REPORT1_TEXT1,
REPORT1_TEXT2,REPORT1_TEXT3,REPORT1_TEXT4,REPORT1_TEXT5,TRANSFER_
COUNT1,TRANSFER_SUM1

Sample Accrual Formulas for Absence (Hungary)
This topic provides four sample accrual formulas for calculating the employee’s holiday
entitlements as required for the Hungarian Absence Report. You can record and report
the entitlement amounts for the following holiday types:

• Base Holiday

• Additional holiday for bringing up children

• Other Additional Holiday

• Sickness Holiday

The following table lists the sample accrual formulas that you can use, as supplied, or
use them as models to create your own, incorporating the rules required for your
accrual plans.
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Hungarian Sample Formulas

Holiday Type Formula Description

Base Holiday HU_BASE_HOLIDAY MULTI
PLIER

This formula calculates the
accrual rate for base holiday in
a specific period. See: Sample
Formula for Base Holiday,
page 1-182

Additional Holiday for
bringing up children

HU_ADD_CHILD_CARE_
HOLIDAY_MULTIPLIER

This formula calculates
the Additional Holiday
for bringing up children.
See: Sample Formula for
Additional Holiday, page
1-193

Other Additional Holiday HU_OTHER_ADD_HOL
IDAY_MULTIPLIER

This formula calculates the
Other Additional Holiday
such as Youthful holiday and
Additional Health Holiday.
See: Sample Formula for
Other Additional Holiday,
page 1-205

Sickness Holiday HU_SICKNESS_HOLIDAY_
MULTIPLIER

This formula calculates the
Sickness Holiday. See: Sample
Formula for Sickness Holiday,
page 1-214

You can use the Carry Over Formula, HU_ABS_CARRYOVER_FORMULA to calculate
any carry over for the above holiday entitlements. See: Sample Formula for Carry
Over Absence, page 1-224

Sample Formula for Base Holiday (Hungary)
Oracle HRMS provides the HU_BASE_HOLIDAY MULTIPLIER sample formula to
calculate the accrual rate for Base Holiday in a specific period as required for the
Hungarian Absence Report. The sample formula is for an accrual plan with the
following rules:

• Entitlement for Base Holiday depends on the employee’s age.

• Entitlement depends on the number of days worked in a week and takes in to
account any work pattern changes within the leave year.

• Base holiday for new hires begins on their hire date.

• The formula calculates proportionately if the employee’s birthday falls within
the current year.

The following table lists the Base Holiday entitlements for employees based on their
age and a five day work pattern.
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Base Holiday entitlements

Employee’s Age Base Holiday entitlement

Until age 24 20 working days holiday

From age 25 21 working days holiday

From age 28 22 working days holiday

From age 31 23 working days holiday

From age 33 24 working days holiday

From age 35 25 working days holiday

From age 37 26 working days holiday

From age 39 27 working days holiday

From age 41 28 working days holiday

From age 43 29 working days holiday

From age 45 30 working days holiday

The following formula HU_BASE_HOLIDAY MULTIPLIER considers the employee’s
age and a five-day work pattern for employees to calculate the Base Holiday
entitlement. The HU_BASE_HOLIDAY MULTIPLIER formula repeatedly calls another
formula in a loop, HU_BASE_HOLIDAY_PERIOD_ACCRUAL to calculate the accrual
for each period. You use the above formulas along with the carry over formula
HU_ABS_HOLIDAY_CARRY_OVER. See: Sample Formula for Carry Over Absence,
page 1-224

The top-level formula HU_BASE_HOLIDAY_MULTIPLIER and the looping formula
HU_BASE_HOLIDAY_PERIOD_ACCRUAL are given below.

/* ------------------------------------------------- -------------
-----

NAME : HU_BASE_HOLIDAY_MULTIPLER
This formula calculates the total accrued base holiday for a
specific period
--------------------------------------------------- -------------

--*/

DEFAULT FOR ACP_INELIGIBILITY_PERIOD_TYPE IS ’CM’
DEFAULT FOR ACP_INELIGIBILITY_PERIOD_LENGTH IS 0
DEFAULT FOR ACP_CONTINUOUS_SERVICE_DATE IS ’4712/12/31 00:00:00’ (
date)
DEFAULT FOR ACP_ENROLLMENT_END_DATE IS ’4712/12/31 00:00:00’ (date
)
DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (date)
DEFAULT FOR ACP_ENROLLMENT_START_DATE IS ’4712/12/31 00:00:00’ (da
te)
DEFAULT FOR ACP_SERVICE_START_DATE IS ’4712/12/31 00:00: 00’ (date)
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INPUTS ARE Calculation_Date (date)

Accruing_Frequency = ’ ’
Accruing_Multiplier = 0

E = SET_DATE(’CALCULATION_DATE’,Calculation_Date)

/* ------------------------------------------------- --------------
----

Set the payroll period, accruing frequency, and accruing mu ltip
lier

based on the payroll.
--------------------------------------------------- ------------

--*/
Payroll_period = HU_PAYROLL_PERIODS(Calculation_Date

,Accruing_Frequency
,Accruing_Multiplier)

E = SET_TEXT(’ACCRUING_FREQUENCY’, Accruing_Frequency)
E = SET_NUMBER(’ACCRUING_MULTIPLIER’, Accruing_Multipl ier)

Beginning_Of_Calculation_Year =
TO_DATE(’0101’||TO_CHAR(Calculation_Date,’YY

YY’)
,’DDMMYYYY’)

IF Beginning_Of_Calculation_Year > Calculation_Date THE N
(

Beginning_of_Calculation_Year =
ADD_MONTHS(Beginning_Of_Calculation_Year,

-12)
)

/* ------------------------------------------------- --------------
----

Set the start and end dates of the first accrual period in the
calculation year
--------------------------------------------------- -------------

--*/

E = SET_DATE(’BEGINNING_OF_CALCULATION_YEAR’
, Beginning_Of_Calculation_Y

ear)

E = GET_PERIOD_DATES(Beginning_of_Calculation_Year,
Accruing_Frequency,
Beginning_Of_Calculation_Year,
Accruing_Multiplier)

First_Period_SD = GET_DATE(’PERIOD_START_DATE’)
First_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

Set the Calculation_Date to the Termination Date if not null
--------------------------------------------------- ------------

--*/
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IF NOT (ACP_TERMINATION_DATE WAS DEFAULTED) OR
NOT (ACP_ENROLLMENT_END_DATE WAS DEFAULTED) THEN

(
Early_End_Date = least(ACP_TERMINATION_DATE, ACP_ENROL LMENT_END_

DATE)

IF (Early_End_Date < Calculation_Date) THEN
(

Calculation_Date = Early_End_Date
)

)

/* ------------------------------------------------- --------------
----

Get the last whole period prior to the Calculation_Date and e ns
ure

that it is within the year (if the Calculation_Date is the end
of

a period then use that period)
--------------------------------------------------- ------------

--*/

E = GET_PERIOD_DATES(Calculation_Date
,Accruing_Frequency
,Beginning_of_Calculation_Year
,Accruing_Multiplier)

Calculation_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Calculation_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

Set the Continuous Service Global Variable, whilst also
ensuring that the continuous service date is before the Calc ula

tion
Period

--------------------------------------------------- -------------
--*/

IF (ACP_CONTINUOUS_SERVICE_DATE WAS DEFAULTED) THEN
(
E = SET_DATE(’CONTINUOUS_SERVICE_DATE’, ACP_SERVICE_START_DATE

)
)

ELSE IF(ACP_CONTINUOUS_SERVICE_DATE > Calculation_Peri od_SD) THEN
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’
, ACP_CONTINUOUS_SERVICE_D

ATE)
)

ELSE
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’
, ACP_CONTINUOUS_SERVICE_D

ATE)
)

Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)
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First_Eligible_To_Accrue_Date = Continuous_Service_Da te

/*------------------------------------------------- ---------------
----

Determine the date on which accrued PTO may first be register ed
,

i.e. the date on which the Ineligibility Period expires
--------------------------------------------------- ------------

--*/

Accrual_Ineligibility_Expired_Date = First_Eligible_T o_Accrue_Date

IF (ACP_INELIGIBILITY_PERIOD_LENGTH > 0) THEN
(
IF ACP_INELIGIBILITY_PERIOD_TYPE = ’BM’ THEN

(
Accrual_Ineligibility_Expired_Date =

ADD_MONTHS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGT

H*2)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’F’ THEN
(
Accrual_Ineligibility_Expired_Date =

ADD_DAYS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGTH

*14)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’CM’ THEN
(
Accrual_Ineligibility_Expired_Date =

ADD_MONTHS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LEN

GTH)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’LM’ THEN
(
Accrual_Ineligibility_Expired_Date =

ADD_DAYS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGTH

*28)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Q’ THEN
(
Accrual_Ineligibility_Expired_Date =

ADD_MONTHS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGT

H*3)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SM’ THEN
(
Accrual_Ineligibility_Expired_Date =

ADD_MONTHS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGT

H/2)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SY’ THEN
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(
Accrual_Ineligibility_Expired_Date =

ADD_MONTHS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGT

H*6)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’W’ THEN
(
Accrual_Ineligibility_Expired_Date =

ADD_DAYS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGT

H*7)
)

ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Y’ THEN
(
Accrual_Ineligibility_Expired_Date =

ADD_MONTHS(Continuous_Service_Date,
ACP_INELIGIBILITY_PERIOD_LENGTH

*12)
)

IF Accrual_Ineligibility_Expired_Date > First_Eligible _To_Accru
e_Date

AND Calculation_Date < Accrual_Ineligibility_Expired_D ate THEN
(

First_Eligible_To_Accrue_Date = Accrual_Ineligibility _Expired
_Date

)
)

/* ------------------------------------------------- --------------
----

Get the first full period following the
First_Eligible_To_Accrue_Date
(if it falls on the beginning of the period then use that perio

d)
--------------------------------------------------- ---------------
--*/

IF First_Eligible_To_Accrue_Date > Beginning_Of_Calcul ation_Year T
HEN
(

E = GET_PERIOD_DATES(First_Eligible_To_Accrue_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

First_Eligible_To_Accrue_Period_SD = GET_DATE(’PERIOD _START_DAT
E’)

First_Eligible_To_Accrue_Period_ED = GET_DATE(’PERIOD _END_DATE’
)

IF (First_Eligible_To_Accrue_Period_SD > Calculation_P eriod_ED)
THEN

(
Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52793_PTO_FML_ASG_INELIG’)
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)
)
ELSE
(

First_Eligible_To_Accrue_Period_SD = First_Period_SD
First_Eligible_To_Accrue_Period_ED = First_Period_ED

)
/* ------------------------------------------------- --------------
----

Determine the date on which PTO actually starts accruing bas ed
on

Hire Date, Continuous Service Date and Plan Enrollment Star t Da
te.

--------------------------------------------------- -----------
-----*/

IF Continuous_Service_date = ACP_CONTINUOUS_SERVICE_DA TE THEN
(

Actual_Accrual_Start_Date = Continuous_service_Date
)
ELSE
(

Actual_Accrual_Start_Date = GREATEST(Continuous_Servi ce_Date,
ACP_ENROLLMENT_START_DATE,
First_Period_SD)

)
/* ------------------------------------------------- --------------
----

Determine the actual start date and end date of the first accr u
al

period to use in the accrual calculation. Get the start date a n
d

end dates of the accrual period in which the Actual Accrual
Start Date falls.
--------------------------------------------------- ------------

--*/
IF (Actual_Accrual_Start_Date > First_Period_SD AND

Actual_Accrual_Start_Date > First_Eligible_To_Accrue_ Period_SD
) THEN

(
E = GET_PERIOD_DATES(Actual_Accrual_Start_Date,

Accruing_Frequency,
Beginning_Of_Calculation_Year,
Accruing_Multiplier)

Accrual_Start_Period_SD = GET_DATE(’PERIOD_START_DATE ’)
Accrual_Start_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

If the Actual Accrual Period is after the Calculation Period th
en

end the processing.
--------------------------------------------------- ------------

--*/
IF (Accrual_Start_Period_SD > Calculation_Period_ED) TH EN

(
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Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52797_PTO_FML_ACT_ACCRUAL’)
)

)

ELSE IF (First_Eligible_To_Accrue_Period_SD > First_Per iod_SD) THE
N

(
Accrual_Start_Period_SD = First_Eligible_To_Accrue_Pe rio

d_SD
Accrual_Start_Period_ED = First_Eligible_To_Accrue_Pe rio

d_ED
)

ELSE
(

Accrual_Start_Period_SD = First_Period_SD
Accrual_Start_Period_ED = First_Period_ED

)

/* ------------------------------------------------- -------------
----

Now set up the information that will be used in when looping
through the periods and call the accrual sub formula.
--------------------------------------------------- -----------

--*/
IF Calculation_Period_ED >= Accrual_Start_Period_ED THE N
(

E = set_date(’PERIOD_SD’,Accrual_Start_Period_SD)
E = set_date(’PERIOD_ED’,Accrual_Start_Period_ED)
E = set_date(’LAST_PERIOD_SD’,Calculation_Period_SD)
E = set_date(’LAST_PERIOD_ED’,Calculation_Period_ED)
E = set_number(’TOTAL_ACCRUED_PTO’,0)

E = LOOP_CONTROL(’HU_BASE_HOLIDAY_PERIOD_ACCRUAL’)

Total_Accrued_PTO = ROUND(get_number(’TOTAL_ACCRUED_P TO’))
)

IF Accrual_Start_Period_SD <= Calculation_Period_SD THE N
(

Accrual_end_date = Calculation_Period_ED
)

Effective_Start_Date = Accrual_Start_Period_SD
Effective_End_Date = Calculation_Period_ED

IF Effective_Start_Date >= Effective_End_Date THEN
(

Effective_Start_Date = Effective_End_Date
)

RETURN Total_Accrued_PTO
,Effective_start_date
,Effective_end_date
,Accrual_end_date

Looping Formula
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/* ------------------------------------------------- -------------
-----

NAME : HU_BASE_HOLIDAY_PERIOD_ACCRUAL
This formula calculates the number of base holiday accrued f or a

particular period.
--------------------------------------------------- -------------

--*/

/*------------------------------------------------- ---------------
----

Get the global variable to be used in this formula
--------------------------------------------------- -------------

--*/

DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (date)
DEFAULT FOR EMP_HIRE_DATE IS ’4712/12/31 00:00:00’ (date)
DEFAULT FOR person_dob IS ’4712/12/31 00:00:00’ (date)

Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)
Total_Accrued_PTO = GET_NUMBER(’TOTAL_ACCRUED_PTO’)
Period_SD = GET_DATE(’PERIOD_SD’)
Period_ED = GET_DATE(’PERIOD_ED’)
Last_Period_SD = GET_DATE(’LAST_PERIOD_SD’)
Last_Period_ED = GET_DATE(’LAST_PERIOD_ED’)
Accruing_Frequency = GET_TEXT(’ACCRUING_FREQUENCY’)
Accruing_Multiplier = GET_NUMBER(’ACCRUING_MULTIPLIER ’)
Beginning_of_Calculation_Year

= GET_DATE(’BEGINNING_OF_CALCULATION_YEAR’
)
Calculation_Date = GET_DATE(’CALCULATION_DATE’)

Accrual_Rate = 0

/* ------------------------------------------------- --------------
----

Get the person date of birth and compute the age.
--------------------------------------------------- ------------

--*/

Person_dob = HU_PERSON_DOB(Calculation_Date)

Age = FLOOR(MONTHS_BETWEEN(Period_ED,Person_dob)/12)

/* ------------------------------------------------- --------------
----

Set the payroll period, accruing frequency and accruing mul tipl
ier

based on the payroll.
--------------------------------------------------- ------------

--*/

Payroll_period = HU_PAYROLL_PERIODS(Calculation_Date
,Accruing_Frequency

,Accruing_Multiplier)
/* ------------------------------------------------- --------------
----

Set period start date and period end date as employee hire dat e
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and
employee termination date if the hire date and termination d ate

falls with in the calculation period.
--------------------------------------------------- ------------

--*/

IF EMP_HIRE_DATE > Period_SD AND EMP_HIRE_DATE < Period_ED THEN
Period_SD = EMP_HIRE_DATE

IF ACP_TERMINATION_DATE > Period_SD
AND ACP_TERMINATION_DATE < Period_ED T

HEN
Period_ED = ACP_TERMINATION_DATE

DOB = TO_DATE(TO_CHAR(Person_dob,’DD/MM/’)
||TO_CHAR(PERIOD_SD,’YYYY’),’DD/MM/YYYY’)

/* ------------------------------------------------- --------------
----

Set the accrual rate based on the age of the employee and on fi
ve

day work pattern.
--------------------------------------------------- ------------

--*/

IF (DOB >= PERIOD_SD AND DOB <= PERIOD_ED) AND
(AGE = 25 OR AGE = 28 OR AGE = 31 OR AGE = 33 OR AGE = 35 OR

AGE = 37 OR AGE = 39 OR AGE = 41 OR AGE = 43 OR AGE = 45) TH
EN
(

X = HU_ABS_GET_WORKING_DAYS(PERIOD_SD,ADD_DAYS(DOB,-1))
Y = HU_ABS_GET_WORKING_DAYS(DOB,Period_ED)

IF Age = 25 THEN
Accrual_Rate = ((20/260)* X +(21/260)* Y)

ELSE IF Age = 28 THEN
Accrual_Rate = ((21/260)* X +(22/260)* Y)

ELSE IF Age = 31 THEN
Accrual_Rate = ((22/260)* X +(23/260)* Y)

ELSE IF Age = 33 THEN
Accrual_Rate = ((23/260)* X +(24/260)* Y)

ELSE IF Age = 35 THEN
Accrual_Rate = ((24/260)* X +(25/260)* Y)

ELSE IF Age = 37 THEN
Accrual_Rate = ((25/260)* X +(26/260)* Y)

ELSE IF Age = 39 THEN
Accrual_Rate = ((26/260)* X +(27/260)* Y)

ELSE IF Age = 41 THEN
Accrual_Rate = ((27/260)* X +(28/260)* Y)

ELSE IF Age = 43 THEN
Accrual_Rate = ((28/260)* X +(29/260)* Y)

ELSE IF Age = 45 THEN
Accrual_Rate = ((29/260)* X +(30/260)* Y)

)
ELSE
(
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X = HU_ABS_GET_WORKING_DAYS(PERIOD_SD,PERIOD_ED)

IF Age <= 24 THEN
Accrual_Rate = ((20/260)*X)

ELSE IF (Age >= 25 AND Age < 28) THEN
Accrual_Rate = ((21/260)*X)

ELSE IF (Age >= 28 AND Age < 31) THEN
Accrual_Rate = ((22/260)*X)

ELSE IF (Age >= 31 AND Age < 33) THEN
Accrual_Rate = ((23/260)*X)

ELSE IF (Age >= 33 AND Age < 35) THEN
Accrual_Rate = ((24/260)*X)

ELSE IF (Age >= 35 AND Age < 37) THEN
Accrual_Rate = ((25/260)*X)

ELSE IF (Age >= 37 AND Age < 39) THEN
Accrual_Rate = ((26/260)*X)

ELSE IF (Age >= 39 AND Age < 41) THEN
Accrual_Rate = ((27/260)*X)

ELSE IF (Age >= 41 AND Age < 43) THEN
Accrual_Rate = ((28/260)*X)

ELSE IF (Age >= 43 AND Age < 45) THEN
Accrual_Rate = ((29/260)*X)

ELSE
Accrual_Rate = ((30/260)*X)

)

Period_Accrued_PTO = Accrual_Rate

E = SET_NUMBER(’TOTAL_ACCRUED_PTO’, Total_Accrued_PTO
+Period_Accrued_PTO)

/* ------------------------------------------------- --------------
----

Establish whether the current period is the last one, if so en
d

the processing, otherwise get the next period.
--------------------------------------------------- ------------

--*/

IF Period_SD >= Last_Period_SD THEN
(
Continue_Processing_Flag = ’N’
)

ELSE
(

E = GET_PERIOD_DATES(ADD_DAYS(Period_ED,1),
Accruing_Frequency,
Beginning_of_Calculation_Year,
Accruing_Multiplier)

E = SET_DATE(’PERIOD_SD’, GET_DATE(’PERIOD_START_DATE’ ))
E = SET_DATE(’PERIOD_ED’, GET_DATE(’PERIOD_END_DATE’))

Continue_Processing_Flag = ’Y’
)

Return Continue_Processing_Flag
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Sample Formula for Additional Holiday (Hungary)
Oracle HRMS provides the HU_ADD_CHILD_CARE_HOLIDAY_MULTIPLIER sample
formula to calculate the accrual rate for Additional Holiday for bringing up children in a
specific period as required for the Hungarian Absence Report. The sample formula is for
an accrual plan with the following rules:

• Entitlement depends on the age and number of children (given in the table below)

• Both parents work and share the entitlement. This eligibility is based on the value
in the Holiday for Child Care field in the Further Contact Relationship Info on
the Contact window.

• Additional Holiday for bringing up children for new hires depends on Hire Date.

• Entitlement begins from the birth date of the child, if a child is born during the
leave year.

The following table lists the Additional Holiday entitlements for employees based on
the number of children.

Additional Holiday entitlements

Number of Children Additional Holiday entitlement

After 1 child 2 working days

After 2 children 4 working days

After more than 2 children 7 working days

The HU_ADD_CHILD_CARE_HOLIDAY_MULTIPLIER formula calls another formula
HU_ADD_CHILD_CARE_HOLIDAY_PERIOD_ACCRUALcalculate the accrual
for each period. You use the sample formulas along with the carry over formula
HU_ABS_HOLIDAY_CARRY_OVER. See: Sample Formula for Carry Over Absence,
page 1-224

The sample HU_ADD_CHILD_CARE_HOLIDAY_MULTIPLIER and the looping
HU_ADD_CHILD_CARE_HOLIDAY_PERIOD_ACCRUAL formula are given below:

/* ------------------------------------------------- -------------
-----

NAME : HU_ADD_CHILD_CARE_HOLIDAY_MULTIPLIER

This formula calculates the total accrued additional child car
e

holiday for a specific period.
--------------------------------------------------- ------------

--*/

DEFAULT FOR ACP_INELIGIBILITY_PERIOD_TYPE IS ’CM’
DEFAULT FOR ACP_INELIGIBILITY_PERIOD_LENGTH IS 0
DEFAULT FOR ACP_CONTINUOUS_SERVICE_DATE IS ’4712/12/31 00:00:00’(D
ATE)
DEFAULT FOR ACP_ENROLLMENT_END_DATE IS ’4712/12/31 00:00:00’ (DATE
)
DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (DATE)
DEFAULT FOR ACP_ENROLLMENT_START_DATE IS ’4712/12/31 00:00:00’ (DA
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TE)
DEFAULT FOR ACP_SERVICE_START_DATE IS ’4712/12/31 00:00: 00’ (DATE)

INPUTS ARE
Calculation_Date (DATE)

Accruing_Frequency = ’ ’
Accruing_Multiplier = 0

/* ------------------------------------------------- --------------
----

Set the payroll period, accruing frequency, and accruing mu ltip
lier

based on the payroll.
--------------------------------------------------- ------------

--*/

No_of_Payroll_Periods = HU_PAYROLL_PERIODS (Calculatio n_Date
,Accruing_Frequency
,Accruing_Multiplier)

E = SET_TEXT(’ACCRUING_FREQUENCY’, Accruing_Frequency)
E = SET_NUMBER(’ACCRUING_MULTIPLIER’, Accruing_Multipl ier)

/* ------------------------------------------------- --------------
----

Calculate the start and end dates of the current leave year.
--------------------------------------------------- -------------

--*/

Beginning_Of_Calculation_Year=TO_DATE(’0101’||to_ch ar(Calculation_
Date

,’YYYY’),’DDMMYYYY’)
End_Of_Calculation_Year = TO_DATE(’3112’||to_char(Cal culation_Date

,’YYYY’),’DDMMYYYY
’)

/* ------------------------------------------------- --------------
----

Set the start and end dates of the first accrual period in the
calculation year.
--------------------------------------------------- -------------

--*/

IF Beginning_Of_Calculation_Year > Calculation_Date THE N
(

Beginning_of_Calculation_Year =
ADD_MONTHS(Beginning_Of_Calculation_Year, -

12)
)

E = SET_DATE(’BEGINNING_OF_CALCULATION_YEAR’
,Beginning_Of_Calculation_Year)

E = GET_PERIOD_DATES(Beginning_of_Calculation_Year
,Accruing_Frequency
,Beginning_Of_Calculation_Year
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,Accruing_Multiplier)

First_Period_SD = GET_DATE(’PERIOD_START_DATE’)
First_Period_ED = GET_DATE(’PERIOD_END_DATE’)

E = GET_PERIOD_DATES(End_Of_Calculation_Year
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

Last_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Last_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

Set the Calculation_Date to the Termination Date if not null
--------------------------------------------------- ------------

--*/

IF NOT (ACP_TERMINATION_DATE WAS DEFAULTED) OR
NOT (ACP_ENROLLMENT_END_DATE WAS DEFAULTED) THEN

(
Early_End_Date = LEAST(ACP_TERMINATION_DATE,ACP_ENROL LMENT_END_D

ATE)

IF (Early_End_Date < First_Period_SD) THEN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52794_PTO_FML_ASG_TER’)

)
IF (Early_End_Date < Last_Period_ED) THEN
(

E = GET_PERIOD_DATES(Early_End_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

Last_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Last_Period_ED = GET_DATE(’PERIOD_END_DATE’)

)
IF (Early_End_Date < Calculation_Date) THEN
(

Calculation_Date = Early_End_Date
)

)

/* ------------------------------------------------- --------------
----

Get the last whole period prior to the Calculation Date and en s
ure

that it is within the Year (if the Calculation Date is the End
of

a Period then use that period)
--------------------------------------------------- ------------

--*/

E = GET_PERIOD_DATES(Calculation_Date
,Accruing_Frequency
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,Beginning_of_Calculation_Year
,Accruing_Multiplier)

Calculation_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Calculation_Period_ED = GET_DATE(’PERIOD_END_DATE’)

IF (Calculation_Period_ED < First_Period_SD) THEN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52795_PTO_FML_CALC_DATE’)
)

/* ------------------------------------------------- --------------
----

Set the Continuous Service Global Variable, whilst also
ensuring that the continuous service date is before the Calc ula

tion
Period

--------------------------------------------------- -------------
--*/

IF (ACP_CONTINUOUS_SERVICE_DATE WAS DEFAULTED) THEN
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’, ACP_SERVICE_START_DATE
)
)
ELSE IF(ACP_CONTINUOUS_SERVICE_DATE > Calculation_Peri od_ED) THEN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52796_PTO_FML_CSD’)
E = SET_DATE(’CONTINUOUS_SERVICE_DATE’

,ACP_CONTINUOUS_SERVICE_DATE)
)
ELSE IF(ACP_CONTINUOUS_SERVICE_DATE > First_Period_SD) THEN
(

E = GET_PERIOD_DATES(ACP_CONTINUOUS_SERVICE_DATE
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

First_Period_SD = GET_DATE(’PERIOD_START_DATE’)
First_Period_ED = GET_DATE(’PERIOD_END_DATE’)

)
ELSE
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’
, ACP_CONTINUOUS_SERVICE_DATE)

)

Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)

First_Eligible_To_Accrue_Date = Continuous_Service_Da te

/*------------------------------------------------- ---------------
----

Determine the date on which accrued PTo may first be register ed
,

i.e the date on which the Ineligibility Period expires
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--------------------------------------------------- ------------
--*/

Accrual_Ineligibility_Expired_Date = First_Eligible_T o_Accrue_Date

IF (ACP_INELIGIBILITY_PERIOD_LENGTH > 0) THEN
(

IF ACP_INELIGIBILITY_PERIOD_TYPE = ’BM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*2
)

)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’F’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*14)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’CM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’LM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*28)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Q’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*3
)

)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH/2
)

)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SY’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*6
)

)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’W’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*7)
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)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Y’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*1
2)

)

IF Accrual_Ineligibility_Expired_Date
> First_Eligible_To_Accrue_Date

AND Calculation_Date
< Accrual_Ineligibility_Expired_Date THEN

(
First_Eligible_To_Accrue_Date =

Accrual_Ineligibility_Expired_Date
)

)

/* ------------------------------------------------- --------------
----

Get the first full period following the First_Eligible_To_ Accrue_
Date

(if it falls on the beginning of the period then use that perio d)
--------------------------------------------------- ---------------
- */

IF First_Eligible_To_Accrue_Date > Beginning_Of_Calcul ation_Year T
HEN
(

E = GET_PERIOD_DATES(First_Eligible_To_Accrue_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

First_Eligible_To_Accrue_Period_SD = GET_DATE(’PERIOD _START_DA
TE’)

First_Eligible_To_Accrue_Period_ED = GET_DATE(’PERIOD _END_DATE
’)

IF (First_Eligible_To_Accrue_Period_SD > Calculation_p eriod_ED)
THEN

(
Total_Accrued_PTO = 0

E = PUT_MESSAGE(’HR_52793_PTO_FML_ASG_INELIG’)
)

)
ELSE
(

First_Eligible_To_Accrue_Period_SD = First_Period_SD
First_Eligible_To_Accrue_Period_ED = First_Period_ED

)
/* ------------------------------------------------- --------------
----

Determine the date on which PTO actually starts accruing bas ed
on

Hire Date, Continuous Service Date and plan Enrollment Star t Da
te.
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--------------------------------------------------- -----------
-----*/

IF Continuous_Service_date = ACP_CONTINUOUS_SERVICE_DA TE THEN
(

Actual_Accrual_Start_Date = Continuous_service_Date
)
ELSE
(

Actual_Accrual_Start_Date = GREATEST(Continuous_Servi ce_Date,
ACP_ENROLLMENT_START_DATE,
First_Period_SD)

)

/* ------------------------------------------------- --------------
----

Determine the actual start of the accrual calculation
--------------------------------------------------- ---------------
--*/
IF (Actual_Accrual_Start_Date > First_Period_SD AND

Actual_Accrual_Start_Date > First_Eligible_To_Accrue_ Period_SD
)
THEN
(

E = GET_PERIOD_DATES(Actual_Accrual_Start_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

Accrual_Start_Period_SD = GET_DATE(’PERIOD_START_DATE ’)
Accrual_Start_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/*------------------------------------------------- ------------
----

If the Actual Accrual Period is after the Calculation Period th
en

end the processing.
--------------------------------------------------- ------------

- */
IF (Accrual_Start_Period_SD > Calculation_period_ED) TH EN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52797_PTO_FML_ACT_ACCRUAL’)

)
)
ELSE IF (First_Eligible_To_Accrue_Period_SD > First_Per iod_SD) THE
N
(

Accrual_Start_Period_SD = First_Eligible_To_Accrue_Pe riod_SD
Accrual_Start_Period_ED = First_Eligible_To_Accrue_Pe riod_ED

)
ELSE
(

Accrual_Start_Period_SD = First_Period_SD
Accrual_Start_Period_ED = First_Period_ED

)

/*------------------------------------------------- ---------------
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----
Now set up the information that will be used in when looping th r

ough
the periods
--------------------------------------------------- -------------

- */
IF Last_period_ED >= Accrual_Start_Period_ED THEN
(

E = SET_DATE(’PERIOD_SD’,Accrual_Start_Period_SD)
E = SET_DATE(’PERIOD_ED’,Accrual_Start_Period_ED)
E = SET_DATE(’LAST_PERIOD_SD’,Calculation_period_SD)
E = SET_DATE(’LAST_PERIOD_ED’,Calculation_period_ED)
E = SET_NUMBER(’TOTAL_ACCRUED_PTO’,0)

E = LOOP_CONTROL(’HU_ADD_CHILD_CARE_HOLIDAY_PERIOD_ACCRUAL’)

Total_Accrued_PTO = ROUND(GET_NUMBER(’TOTAL_ACCRUED_PTO’))
)

IF Accrual_Start_Period_SD <= Calculation_period_ED THE N
(

Accrual_end_date = Calculation_period_ED
)

Effective_Start_Date = Accrual_Start_Period_SD
Effective_End_Date = Calculation_period_ED

IF Effective_Start_Date >= Effective_End_Date THEN
(

Effective_Start_Date = Effective_End_Date
)

RETURN Total_Accrued_PTO
,Effective_start_date
,Effective_end_date
,Accrual_end_date

Looping Formula

/* ------------------------------------------------- -------------
-----

NAME : HU_ADD_CHILD_CARE_HOLIDAY_PERIOD_ACCRUAL
This formula calculates the amount of PTO accrued for a parti c

ular
period

--------------------------------------------------- ------------
--*/

/*------------------------------------------------- ---------------
----

Get the global variable to be used in this formula
--------------------------------------------------- --------------

--*/

DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (DATE)
DEFAULT FOR ACP_SERVICE_START_DATE IS ’4712/12/31 00:00: 00’ (DATE)

Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)
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Total_Accrued_PTO = GET_NUMBER(’TOTAL_ACCRUED_PTO’)
Period_SD = GET_DATE(’PERIOD_SD’)
Period_ED = GET_DATE(’PERIOD_ED’)
Last_Period_SD = GET_DATE(’LAST_PERIOD_SD’)
Last_Period_ED = GET_DATE(’LAST_PERIOD_ED’)
Termination_date = GET_DATE(’ACP_TERMINATION_DATE’)
Hire_date = GET_DATE(’ACP_SERVICE_START_DATE’)

Accruing_Frequency = GET_TEXT(’ACCRUING_FREQUENCY’)
Accruing_Multiplier = GET_NUMBER(’ACCRUING_MULTIPLIER ’)
Beginning_of_Calculation_Year =

GET_DATE(’BEGINNING_OF_CALCULATION_YEAR
’)

First_Child_Date_of_birth = TO_DATE(’01-01-4712’,’dd- mm-yyyy’)
Second_Child_Date_of_birth = TO_DATE(’01-01-4712’,’dd -mm-yyyy’)
Third_Child_Date_of_birth = TO_DATE(’01-01-4712’,’dd- mm-yyyy’)

/* ------------------------------------------------- --------------
----

Set the payroll period, accruing frequency, and accruing mu ltip
lier

based on the payroll.
--------------------------------------------------- ------------

--*/

No_of_Payroll_Periods = HU_PAYROLL_PERIODS (Period_SD
,Accruing_Frequency
,Accruing_Multiplier)

No_Of_Children_less_16 = 0
No_Of_Children_16 = 0

/* ------------------------------------------------- --------------
----

Retrieve child information for the current employee.
--------------------------------------------------- -------------

- */

E = HU_ABS_GET_CHILD_INFO(Period_SD, Period_ED
,No_Of_Children_less_16
,No_Of_Children_16
,First_Child_Date_of_birth
,Second_Child_Date_of_birth
,Third_Child_Date_of_birth)

Total_children = No_Of_Children_less_16 + No_Of_Childre n_16
Period_Accrued_PTO = 0

Total_days = DAYS_BETWEEN(Period_ED , Period_SD)
days_valid = DAYS_BETWEEN(Period_ED , Period_SD)
Accrual_Rate = 0

/* ------------------------------------------------- --------------
----

Set accrual rate based on number of children and their age.
--------------------------------------------------- -------------

- */
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IF Total_children = 1 THEN
( Accrual_Rate = 2 )
ELSE IF Total_children = 2 THEN
( Accrual_Rate = 4 )
ELSE IF Total_children > 2 THEN
( Accrual_Rate = 7)

Accrual_rate_per_period = Accrual_Rate/No_of_Payroll_ Periods

/* ------------------------------------------------- --------------
----

Days worked prorated based on hire date and termination date of

employee.
--------------------------------------------------- -------------

--*/

IF Hire_date >= Period_SD
AND Hire_date <= Period_ED
AND Termination_date >= Period_SD
AND Termination_date <= Period_ED THEN

(
days_valid = DAYS_BETWEEN(Termination_date,Hire_date)

)
ELSE IF Hire_date >= Period_SD

AND Hire_date <= Period_ED THEN
(

days_valid = DAYS_BETWEEN(Period_ED,Hire_date)
)
ELSE IF Termination_date >= Period_SD

AND Termination_date <= Period_ED THEN
(

days_valid = DAYS_BETWEEN(Termination_date,Period_SD)

)
Accrual_rate_per_period = Accrual_rate_per_period

*(days_valid/ Total_days)

/* ------------------------------------------------- --------------
----

Calculate the Amount Accrued this Period-
--------------------------------------------------- ------------

--*/
IF No_Of_Children_16 = 0 or No_Of_Children_less_16 > 2 THEN
(

Period_Accrued_PTO = Accrual_rate_per_period
)
ELSE
(

IF No_Of_Children_16 = 1 THEN
(

days_valid = DAYS_BETWEEN(First_Child_Date_of_birth,P eriod_SD
)

Period_Accrued_PTO = Accrual_rate_per_period
*(days_valid / Total_days )
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IF No_Of_Children_less_16 = 1 THEN
(

Period_Accrued_PTO = Period_Accrued_PTO
+(2*((Total_days-days_valid)/Total_da

ys))
/No_of_Payroll_Periods

)
IF No_Of_Children_less_16 = 2 THEN
(

Period_Accrued_PTO = Period_Accrued_PTO
+(4*((Total_days-days_valid)/Total_da

ys))
/No_of_Payroll_Periods

)
)
ELSE IF No_Of_Children_16 = 2 THEN
(

IF No_Of_Children_less_16 > 1 THEN
(

days_valid = DAYS_BETWEEN(Second_Child_Date_of_birth, Period_SD)

Period_Accrued_PTO = Accrual_rate_per_period
*(days_valid / Total_days)

Period_Accrued_PTO = Period_Accrued_PTO
+(4*((Total_days-days_valid)/Total_da

ys))
/No_of_Payroll_Periods

)
ELSE IF No_Of_Children_less_16 > 0 THEN
(

days_valid = DAYS_BETWEEN(First_Child_Date_of_birth,P eriod_
SD)

Period_Accrued_PTO = Accrual_rate_per_period
* (days_valid / Total_days)

days_valid = DAYS_BETWEEN(Second_Child_Date_of_birth
,First_Child_Date_of_birth)

Period_Accrued_PTO = Period_Accrued_PTO
+(4 *(days_valid / Total_days))
/No_of_Payroll_Periods

days_valid = DAYS_BETWEEN(Period_ED
,Second_Child_Date_of_birth)

Period_Accrued_PTO = Period_Accrued_PTO
+(2 *(days_valid / Total_days))
/No_of_Payroll_Periods

)
ELSE IF No_Of_Children_less_16 = 0 THEN
(

days_valid = DAYS_BETWEEN(First_Child_Date_of_birth,P eriod_
SD)

Period_Accrued_PTO = Accrual_rate_per_period
*(days_valid / Total_days)

days_valid = DAYS_BETWEEN(Second_Child_Date_of_birth
,First_Child_Date_of_birth)
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Period_Accrued_PTO = Period_Accrued_PTO +
(2 * (days_valid / Total_days))
/No_of_Payroll_Periods

)
)
ELSE IF No_Of_Children_16 = 3 THEN
(

IF No_Of_Children_less_16 > 1 THEN
(

days_valid = DAYS_BETWEEN(Third_Child_Date_of_birth,P eriod_SD)

Period_Accrued_PTO = Accrual_rate_per_period
*(days_valid / Total_days)

Period_Accrued_PTO = Period_Accrued_PTO
+(4*((Total_days-days_valid)
/ Total_days))
/No_of_Payroll_Periods

)
ELSE IF No_Of_Children_less_16 > 0 THEN
(

days_valid = DAYS_BETWEEN(Second_Child_Date_of_birth
,Period_SD)

Period_Accrued_PTO = Accrual_rate_per_period
*(days_valid / Total_days)

days_valid = DAYS_BETWEEN(Third_Child_Date_of_birth
,Second_Child_Date_of_birth)

Period_Accrued_PTO = Period_Accrued_PTO
+(4 * (days_valid / Total_days))
/No_of_Payroll_Periods

days_valid = DAYS_BETWEEN(Period_ED,Third_Child_Date_ of_birth)

Period_Accrued_PTO = Period_Accrued_PTO
+(2 * (days_valid / Total_days))
/No_of_Payroll_Periods

)
ELSE IF No_Of_Children_less_16 = 0 THEN
(

days_valid = DAYS_BETWEEN(First_Child_Date_of_birth,P eriod_SD)

Period_Accrued_PTO = Accrual_rate_per_period
*(days_valid / Total_days)

days_valid = DAYS_BETWEEN(Second_Child_Date_of_birth
,First_Child_Date_of_birth)

Period_Accrued_PTO = Period_Accrued_PTO
+(4 * (days_valid / Total_days))
/No_of_Payroll_Periods

days_valid = DAYS_BETWEEN(Third_Child_Date_of_birth
,Second_Child_Date_of_birth)

Period_Accrued_PTO = Period_Accrued_PTO
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+(2 * (days_valid / Total_days))
/No_of_Payroll_Periods

)
)

)

/*------------------------------------------------- ---------------
----

Set the Running Total
--------------------------------------------------- -------------

--*/

E = SET_NUMBER(’TOTAL_ACCRUED_PTO’
,Total_Accrued_PTO + Period_Accrued_PTO)

/* ------------------------------------------------- --------------
----

Establish whether the current period is the last one, if so en
d

the processing, otherwise get the next period
--------------------------------------------------- ------------

--*/

IF Period_SD >= Last_Period_SD THEN
(

Continue_Processing_Flag = ’N’
)
ELSE
(

E = GET_PERIOD_DATES(ADD_DAYS(Period_ED,1)
,Accruing_Frequency
,Beginning_of_Calculation_Year
,Accruing_Multiplier)

E = SET_DATE(’PERIOD_SD’
,GET_DATE(’PERIOD_START_DATE’))

E = SET_DATE(’PERIOD_ED’
,GET_DATE(’PERIOD_END_DATE’))

Continue_Processing_Flag = ’Y’
)

RETURN Continue_Processing_Flag

Sample Formula for Other Additional Holiday (Hungary)
Oracle HRMS provides the HU_OTHER_ADD_HOLIDAY_MULTIPLIER formula
to calculate the Other Additional Holiday as required for the Hungarian Absence
Report. The Other Additional Holiday comprises of Youthful Holiday and Additional
Health Holiday. The sample formula is for an accrual plan with the following rules:

• Employee under 18 years of age entitled to an additional 5 days holiday.

• Blind employee entitled to an additional 5 days holiday. This eligibility is based on
the information recorded on the Blind field on the Disabilities window.
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• Employee working underground or exposed to radiation entitled to an additional 5
days holiday. This eligibility is based on the information recorded on the Additional
Health Holiday field on the Further Job Info in the Job window.

• Entitlement depends on the number of days worked in a week. The formula takes
into account any work pattern changes.

• Entitlement begins or ends from the date of change, if the shift or disability change
during the leave year.

• Other Additional Holiday for new hires begins on their Hire Date.

The top level formula, HU_OTHER_ADD_HOLIDAY_MULTIPLIER calls another
formula called HU_OTHER_ADD_HOLIDAY_PERIOD_ACCRUAL calculate the
accrual for each period. You use the formulas along with the carry over formula
HU_ABS_HOLIDAY_CARRY_OVER. See: Sample Formula for Carry Over Absence,
page 1-224

The top-level formula, HU_OTHER_ADD_HOLIDAY_MULTIPLIER and the looping
formula HU_OTHER_ADD_HOLIDAY_PERIOD_ACCRUAL are given below.

/* ------------------------------------------------- -------------
----

NAME : HU_OTHER_ADD_HOLIDAY_MULTIPLIER

This formula calculates the total accrued other additional holi
day

for a specific period.
--------------------------------------------------- ------------

--*/
DEFAULT FOR ACP_INELIGIBILITY_PERIOD_TYPE IS ’CM’
DEFAULT FOR ACP_INELIGIBILITY_PERIOD_LENGTH IS 0
DEFAULT FOR ACP_CONTINUOUS_SERVICE_DATE IS ’4712/12/31 00:00:00’(d
ate)
DEFAULT FOR ACP_ENROLLMENT_END_DATE IS ’4712/12/31 00:00:00’ (date
)
DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (date)
DEFAULT FOR ACP_ENROLLMENT_START_DATE IS ’4712/12/31 00:00:00’ (da
te)
DEFAULT FOR ACP_SERVICE_START_DATE IS ’4712/12/31 00:00: 00’ (date)

INPUTS ARE Calculation_Date (date)
Accruing_Frequency = ’ ’
Accruing_Multiplier = 0
E = SET_DATE(’CALCULATION_DATE’,Calculation_Date)

/* ------------------------------------------------- --------------
---

Set the payroll period, accruing frequency, and accruing mu ltip
lier

based on the payroll.
--------------------------------------------------- ------------

--*/

Payroll_period = HU_PAYROLL_PERIODS(Calculation_Date
,Accruing_Frequency

,Accruing_Multiplier)
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E = SET_TEXT(’ACCRUING_FREQUENCY’, Accruing_Frequency)
E = SET_NUMBER(’ACCRUING_MULTIPLIER’, Accruing_Multipl ier)

/* ------------------------------------------------- --------------
----

Calculate the start and end dates of the current leave year
--------------------------------------------------- -------------

--*/

Beginning_Of_Calculation_Year =
TO_DATE(’0101’||TO_CHAR(Calculation_Date,’YYY

Y’)
,’DDMMYYYY’)

IF Beginning_Of_Calculation_Year > Calculation_Date THE N
(

Beginning_of_Calculation_Year =
ADD_MONTHS(Beginning_Of_Calculation_Year, -12

)
)

E = SET_DATE(’BEGINNING_OF_CALCULATION_YEAR’
, Beginning_Of_Calculation_Year)

E = GET_PERIOD_DATES(Beginning_of_Calculation_Year
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

First_Period_SD = GET_DATE(’PERIOD_START_DATE’)
First_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

Set the Calculation_Date to the Termination Date if not null
--------------------------------------------------- ------------

--*/

IF NOT (ACP_TERMINATION_DATE WAS DEFAULTED) OR
NOT (ACP_ENROLLMENT_END_DATE WAS DEFAULTED) THEN

(
Early_End_Date = LEAST(ACP_TERMINATION_DATE

,ACP_ENROLLMENT_END_DATE)

IF (Early_End_Date < Calculation_Date) THEN
(

Calculation_Date = Early_End_Date
)

)

/* ------------------------------------------------- --------------
----

Get the last whole period prior to the Calculation Date and en s
ure

that it is within the Year (if the Calculation Date is the En
d

of a Period then use that period)
--------------------------------------------------- ------------
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--*/

E = GET_PERIOD_DATES(Calculation_Date
,Accruing_Frequency
,Beginning_of_Calculation_Year
,Accruing_Multiplier)

Calculation_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Calculation_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

Set the Continuous Service Global Variable, whilst also
ensuring that the continuous service date is before the
Calculation Period

--------------------------------------------------- -------------
--*/

IF (ACP_CONTINUOUS_SERVICE_DATE WAS DEFAULTED) THEN
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’, ACP_SERVICE_START_DATE
)
)
ELSE IF(ACP_CONTINUOUS_SERVICE_DATE > Calculation_Peri od_SD) THEN
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’
,ACP_CONTINUOUS_SERVICE_DATE)

)
ELSE
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’
,ACP_CONTINUOUS_SERVICE_DATE)

)

Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)

First_Eligible_To_Accrue_Date = Continuous_Service_Da te

/*------------------------------------------------- ---------------
----

Determine the date on which accrued PTO may first be register ed
,

i.e the date on which the Ineligibility Period expires
--------------------------------------------------- -------------

--*/

Accrual_Ineligibility_Expired_Date = First_Eligible_T o_Accrue_Date

IF (ACP_INELIGIBILITY_PERIOD_LENGTH > 0) THEN
(

IF ACP_INELIGIBILITY_PERIOD_TYPE = ’BM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*2)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’F’ THEN
(
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Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*14)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’CM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’LM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*28)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Q’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*3)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH/2)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SY’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*6)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’W’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*7)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Y’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*12)
)

IF Accrual_Ineligibility_Expired_Date >
First_Eligible_To_Accrue_

Date
AND Calculation_Date < Accrual_Ineligibility_Expired_D ate THE

N
(

First_Eligible_To_Accrue_Date =
Accrual_Ineligibility_Expired_

Date
)

)
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/* ------------------------------------------------- --------------
----

Get the first full period following the
First_Eligible_To_Accrue_Date(if it falls on the beginni ng of t

he
period then use that period)

--------------------------------------------------- --------------
--*/

IF First_Eligible_To_Accrue_Date > Beginning_Of_Calcul ation_Year T
HEN
(

E = GET_PERIOD_DATES(First_Eligible_To_Accrue_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

First_Eligible_To_Accrue_Period_SD = GET_DATE(’PERIOD _START_DAT
E’)

First_Eligible_To_Accrue_Period_ED = GET_DATE(’PERIOD _END_DATE’
)

IF (First_Eligible_To_Accrue_Period_SD > Calculation_P eriod_ED)
THEN

(
Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52793_PTO_FML_ASG_INELIG’)

)
)
ELSE
(

First_Eligible_To_Accrue_Period_SD = First_Period_SD
First_Eligible_To_Accrue_Period_ED = First_Period_ED

)
/* ------------------------------------------------- --------------
----

Determine the date on which PTO actually starts accruing bas ed
on

Hire Date, Continuous Service Date and plan Enrollment Star t Da
te.

--------------------------------------------------- ------------
----*/

IF Continuous_Service_date = ACP_CONTINUOUS_SERVICE_DA TE THEN
(

Actual_Accrual_Start_Date = Continuous_service_Date
)
ELSE
(

Actual_Accrual_Start_Date = GREATEST(Continuous_Servi ce_Date
,ACP_ENROLLMENT_START_DATE
,First_Period_SD)

)

/* ------------------------------------------------- --------------
----
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Determine the actual start of the accrual calculation
--------------------------------------------------- ------------

--*/
IF (Actual_Accrual_Start_Date > First_Period_SD AND

Actual_Accrual_Start_Date > First_Eligible_To_Accrue_ Period_SD)
THEN
(

E = GET_PERIOD_DATES(Actual_Accrual_Start_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

Accrual_Start_Period_SD = GET_DATE(’PERIOD_START_DATE ’)
Accrual_Start_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

If the Actual Accrual Period is after the Calculation Period th
en

end the processing.
--------------------------------------------------- ------------

--*/
IF (Accrual_Start_Period_SD > Calculation_Period_ED) TH EN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52797_PTO_FML_ACT_ACCRUAL’)

)
)

ELSE IF (First_Eligible_To_Accrue_Period_SD > First_Per iod_SD) THE
N
(

Accrual_Start_Period_SD = First_Eligible_To_Accrue_Pe riod_SD
Accrual_Start_Period_ED = First_Eligible_To_Accrue_Pe riod_ED

)
ELSE
(

Accrual_Start_Period_SD = First_Period_SD
Accrual_Start_Period_ED = First_Period_ED

)

/* ------------------------------------------------- --------------
----

Now set up the information that will be used in when looping
through the periods.
--------------------------------------------------- ------------

--*/
IF Calculation_Period_ED >= Accrual_Start_Period_ED THE N
(

E = SET_DATE(’PERIOD_SD’,Accrual_Start_Period_SD)
E = SET_DATE(’PERIOD_ED’,Accrual_Start_Period_ED)
E = SET_DATE(’LAST_PERIOD_SD’,Calculation_Period_SD)
E = SET_DATE(’LAST_PERIOD_ED’,Calculation_Period_ED)
E = SET_NUMBER(’TOTAL_ACCRUED_PTO’,0)

E = LOOP_CONTROL(’HU_OTHER_ADD_HOLIDAY_PERIOD_ACCRUAL’)
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Total_Accrued_PTO = ROUND(GET_NUMBER(’TOTAL_ACCRUED_PTO’))
)

IF Accrual_Start_Period_SD <= Calculation_Period_SD THE N
(

Accrual_end_date = Calculation_Period_ED
)

Effective_Start_Date = Accrual_Start_Period_SD
Effective_End_Date = Calculation_Period_ED

IF Effective_Start_Date >= Effective_End_Date THEN
(

Effective_Start_Date = Effective_End_Date
)

RETURN Total_Accrued_PTO
,Effective_start_date
,Effective_end_date
,Accrual_end_date

Looping Formula

/* ------------------------------------------------- -------------
-----

NAME : HU_OTHER_ADD_HOLIDAY_PERIOD_ACCRUAL

This formula calculates the amount of PTO accrued for a parti cul
ar

period.
--------------------------------------------------- -------------

--*/

DEFAULT FOR PER_DATE_OF_BIRTH IS ’4712/12/31 00:00:00’ (d ate)
DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (date)
DEFAULT FOR EMP_HIRE_DATE IS ’4712/12/31 00:00:00’ (date)
DEFAULT FOR Person_dob IS ’4712/12/31 00:00:00’ (date)

Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)
Total_Accrued_PTO = GET_NUMBER(’TOTAL_ACCRUED_PTO’)
Period_SD = GET_DATE(’PERIOD_SD’)
Period_ED = GET_DATE(’PERIOD_ED’)
Last_Period_SD = GET_DATE(’LAST_PERIOD_SD’)
Last_Period_ED = GET_DATE(’LAST_PERIOD_ED’)
Payroll_Year_SD = GET_DATE(’PAYROLL_YEAR_SD’)
Accruing_Frequency = GET_TEXT(’ACCRUING_FREQUENCY’)
Accruing_Multiplier = GET_NUMBER(’ACCRUING_MULTIPLIER ’)
beginining_year = GET_DATE(’BEGINNING_OF_CALCULATION_ YEAR’)
Calculation_Date=GET_DATE(’CALCULATION_DATE’)

/* ------------------------------------------------- --------------
----

Get the person date of birth and compute the age.
--------------------------------------------------- ------------

--*/

Person_dob = HU_PERSON_DOB(Calculation_Date)
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Age = FLOOR(MONTHS_BETWEEN(Period_ED, Person_dob)/12)

/* ------------------------------------------------- --------------
----

Set the payroll period, accruing frequency, and accruing mu ltip
lier

based on the payroll.
--------------------------------------------------- ------------

--*/

P= HU_PAYROLL_PERIODS(Calculation_Date
,Accruing_Frequency
,Accruing_Multiplier)

Accrual_Rate =0
st_date=beginining_year
ed_date=TO_DATE(’3112’||TO_CHAR(beginining_year,’YY YY’),’DDMMYYYY’
)

IF EMP_HIRE_DATE > Period_SD AND EMP_HIRE_DATE < Period_ED THEN
(

Period_SD= EMP_HIRE_DATE
)
IF ACP_TERMINATION_DATE > Period_SD AND

ACP_TERMINATION_DATE < Period_ED THEN
(

Period_ED=ACP_TERMINATION_DATE
)

DOB=TO_DATE(TO_CHAR(Person_dob,’DD/MM/’)||TO_CHAR(P ERIOD_SD,’YYYY’
)

,’DD/MM/YYYY’)

/* ------------------------------------------------- --------------
----

Set accrual rate based on age and working pattern.
--------------------------------------------------- -------------

--*/

IF Age = 18 and DOB>=PERIOD_SD and DOB<=PERIOD_ED THEN
(

x1 = HU_ABS_GET_WORKING_DAYS(PERIOD_SD,ADD_DAYS(DOB,-1))
Accrual_Rate = (5/260*x1)

)
ELSE IF Age<18 THEN
(

x1 = HU_ABS_GET_WORKING_DAYS(PERIOD_SD,PERIOD_ED)
Accrual_Rate =5/260*x1

)
ELSE
(

Accrual_Rate =0
)
Period_Accrued_PTO=Accrual_Rate
/* ------------------------------------------------- --------------
----

Checking for Blind Days
--------------------------------------------------- ------------

--*/

FastFormula 1-213



Accrual_Rate =0
Accrual_Rate =HU_ABS_GET_BLIND_DAYS(Period_SD,Period _ED)*5/260

Period_Accrued_PTO=Period_Accrued_PTO+Accrual_Rate

/* ------------------------------------------------- --------------
----

Checking the additional health of employees.
--------------------------------------------------- -------------

--*/

Accrual_Rate = 0
Accrual_Rate = HU_ABS_GET_JOB_DAYS(Period_SD,Period_E D)*5/260
Period_Accrued_PTO = Period_Accrued_PTO + Accrual_Rate

/*------------------------------------------------- ---------------
----

Set the Running Total for Total_Accrued_PTO
--------------------------------------------------- -------------

--*/
E = SET_NUMBER(’TOTAL_ACCRUED_PTO’,Total_Accrued_PTO

+ Period_Accrued_PTO)

/* ------------------------------------------------- --------------
----

Establish whether the current period is the last one, if so en
d

the processing, otherwise get the next period
--------------------------------------------------- ---------------
--*/
IF Period_SD >= Last_Period_SD THEN
(

Continue_Processing_Flag = ’N’
)
ELSE
(

E = GET_PAYROLL_PERIOD(ADD_DAYS(Period_ED,1))
E = SET_DATE(’PERIOD_SD’,GET_DATE(’PAYROLL_PERIOD_START_DATE’)

)
E = SET_DATE(’PERIOD_ED’,GET_DATE(’PAYROLL_PERIOD_END_DATE’))
Continue_Processing_Flag = ’Y’

)

RETURN Continue_Processing_Flag

Sample Formula for Sickness Holiday (Hungary)
Oracle HRMS provides the HU_SICKNESS_HOLIDAY_MULTIPLIER to calculate the
Sickness Holiday as required for the Hungarian Absence Report. The sickness holiday is
based on the following rules:

• Annual sickness holiday of fifteen days.

• Entitlement depends on the number of days worked in a week. The formula
calculates proportionately if the work pattern changes within the leave year.
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• Entitlement depends on the sickness holiday the employee has taken in the previous
employment.

The HU_SICKNESS_HOLIDAY_MULTIPLIER calls another formula, HU_SICKNESS_
HOLIDAY_PERIOD_ACCRUAL to calculate the accrual within a specific period. There
is no carry over formula for Sickness Holiday.

The top-level formula, HU_SICKNESS_HOLIDAY_MULTIPLIER, and the looping
formula HU_SICKNESS_HOLIDAY_PERIOD_ACCRUAL are given below.

/* ------------------------------------------------- -------------
-----
NAME : HU_SICKNESS_HOLIDAY_MULTIPLIER
This formula calculates the total accrued sickness holiday for a
specific period.
--------------------------------------------------- --------------*
/

DEFAULT FOR ACP_INELIGIBILITY_PERIOD_TYPE IS ’CM’
DEFAULT FOR ACP_INELIGIBILITY_PERIOD_LENGTH IS 0
DEFAULT FOR ACP_CONTINUOUS_SERVICE_DATE IS ’4712/12/31 00:00:00’(D
ATE)
DEFAULT FOR ACP_ENROLLMENT_END_DATE IS ’4712/12/31 00:00:00’ (DATE
)
DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (DATE)
DEFAULT FOR ACP_ENROLLMENT_START_DATE IS ’4712/12/31 00:00:00’ (DA
TE)
DEFAULT FOR ACP_SERVICE_START_DATE IS ’4712/12/31 00:00: 00’ (DATE)

INPUTS ARE Calculation_Date (DATE)

Accruing_Frequency = ’ ’
Accruing_Multiplier = 0

/* ------------------------------------------------- --------------
----
Set the payroll period, accruing frequency, and accruing mu ltiplie
r
based on the payroll.
--------------------------------------------------- --------------*
/
No_of_Payroll_Periods = HU_PAYROLL_PERIODS (Calculatio n_Date

,Accruing_Frequency
,Accruing_Multiplier)

E = SET_TEXT(’ACCRUING_FREQUENCY’, Accruing_Frequency)
E = SET_NUMBER(’ACCRUING_MULTIPLIER’, Accruing_Multipl ier)

/* ------------------------------------------------- --------------
----
Calculate the start and end Dates of the current leave year
--------------------------------------------------- ---------------
*/
Beginning_Of_Calculation_Year = TO_DATE(’0101’

||TO_CHAR(Calculation_Date
,’YYYY’)

,’DDMMYYYY’)
End_Of_Calculation_Year = to_DATE(’3112’||TO_CHAR(Cal culation_Date
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,’YYYY’)
,’DDMMYYYY’)

IF Beginning_Of_Calculation_Year > Calculation_Date THE N
(

Beginning_of_Calculation_Year = ADD_MONTHS(Beginning_ Of_Calculat
ion_Year

, -12)
)

E = SET_DATE(’BEGINNING_OF_CALCULATION_YEAR’
, Beginning_Of_Calculation_Year)

E = GET_PERIOD_DATES(Beginning_of_Calculation_Year
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

First_Period_SD = GET_DATE(’PERIOD_START_DATE’)
First_Period_ED = GET_DATE(’PERIOD_END_DATE’)

E = GET_PERIOD_DATES(End_Of_Calculation_Year
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

Last_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Last_Period_ED = GET_DATE(’PERIOD_END_DATE’)

/* ------------------------------------------------- --------------
----

Set the Calculation_Date to the Termination Date if not null
--------------------------------------------------- ---------------
--*/

IF NOT (ACP_TERMINATION_DATE WAS DEFAULTED) OR
NOT (ACP_ENROLLMENT_END_DATE WAS DEFAULTED) THEN
(

Early_End_Date = LEAST(ACP_TERMINATION_DATE
,ACP_ENROLLMENT_END_DATE)

IF (Early_End_Date < First_Period_SD) THEN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52794_PTO_FML_ASG_TER’)

)
IF (Early_End_Date < Last_Period_ED) THEN
(

E = GET_PERIOD_DATES(Early_End_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

Last_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Last_Period_ED = GET_DATE(’PERIOD_END_DATE’)

)
IF (Early_End_Date < Calculation_Date) THEN
(

Calculation_Date = Early_End_Date
)
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)

/* ------------------------------------------------- --------------
----
Get the last whole period prior to the Calculation Date and en sure

that it is within the Year (if the Calculation Date is the End o f
a
Period then use that period)
--------------------------------------------------- ---------------
-- */

E = GET_PERIOD_DATES(Calculation_Date
,Accruing_Frequency
,Beginning_of_Calculation_Year
,Accruing_Multiplier)

Calculation_Period_SD = GET_DATE(’PERIOD_START_DATE’)
Calculation_Period_ED = GET_DATE(’PERIOD_END_DATE’)

IF (Calculation_Period_ED < First_Period_SD) THEN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52795_PTO_FML_CALC_DATE’)

)
/* ------------------------------------------------- --------------
----
Set the Continuous Service Global Variable, whilst also
ensuring that the continuous service date is before the
Calculation Period
--------------------------------------------------- --------------
*/

IF (ACP_CONTINUOUS_SERVICE_DATE WAS DEFAULTED) THEN
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’, ACP_SERVICE_START_DATE)
)
ELSE IF(ACP_CONTINUOUS_SERVICE_DATE > Calculation_Peri od_ED) THEN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52796_PTO_FML_CSD’)
E = SET_DATE(’CONTINUOUS_SERVICE_DATE’

, ACP_CONTINUOUS_SERVICE_DATE)
)
ELSE IF(ACP_CONTINUOUS_SERVICE_DATE > First_Period_SD) THEN
(

E = GET_PERIOD_DATES(ACP_CONTINUOUS_SERVICE_DATE,
Accruing_Frequency,
Beginning_Of_Calculation_Year,
Accruing_Multiplier)

First_Period_SD = GET_DATE(’PERIOD_START_DATE’)
First_Period_ED = GET_DATE(’PERIOD_END_DATE’)

)
ELSE
(

E = SET_DATE(’CONTINUOUS_SERVICE_DATE’
, ACP_CONTINUOUS_SERVICE_DATE)

)
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Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)
First_Eligible_To_Accrue_Date = Continuous_Service_Da te

/*------------------------------------------------- ---------------
----
Determine the date on which accrued PTo may first be register ed,
i.e the date on which the Ineligibility Period expires

--------------------------------------------------- -------------
*/
Accrual_Ineligibility_Expired_Date = First_Eligible_T o_Accrue_Date

IF (ACP_INELIGIBILITY_PERIOD_LENGTH > 0) THEN
(

IF ACP_INELIGIBILITY_PERIOD_TYPE = ’BM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*2
)

)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’F’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*14)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’CM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’LM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_DAYS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*28)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Q’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*3)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SM’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH/2)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’SY’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*6)
)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’W’ THEN
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(
Accrual_Ineligibility_Expired_Date =

ADD_DAYS(Continuous_Service_Date
,ACP_INELIGIBILITY_PERIOD_LENGTH*7)

)
ELSE IF ACP_INELIGIBILITY_PERIOD_TYPE = ’Y’ THEN
(

Accrual_Ineligibility_Expired_Date =
ADD_MONTHS(Continuous_Service_Date

,ACP_INELIGIBILITY_PERIOD_LENGTH*12)
)
IF Accrual_Ineligibility_Expired_Date > First_Eligible _To_Accrue

_Date
AND Calculation_Date < Accrual_Ineligibility_Expired_D ate THEN
(

First_Eligible_To_Accrue_Date = Accrual_Ineligibility _Expired_
Date

)
)

/* ------------------------------------------------- --------------
----
Get the first full period following the
First_Eligible_To_Accrue_Date (if it falls on the beginni ng of the

period then use that period)
--------------------------------------------------- ------------- *
/

IF First_Eligible_To_Accrue_Date > Beginning_Of_Calcul ation_Year T
HEN
(

E = GET_PERIOD_DATES(First_Eligible_To_Accrue_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

First_Eligible_To_Accrue_Period_SD = GET_DATE(’PERIOD _START_DAT
E’)

First_Eligible_To_Accrue_Period_ED = GET_DATE(’PERIOD _END_DATE’
)

IF (First_Eligible_To_Accrue_Period_SD > Calculation_p eriod_ED)
THEN

(
Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52793_PTO_FML_ASG_INELIG’)

)
)
ELSE
(

First_Eligible_To_Accrue_Period_SD = First_Period_SD
First_Eligible_To_Accrue_Period_ED = First_Period_ED

)

/* ------------------------------------------------- --------------
----
Determine the date on which PTO actually starts accruing bas ed
on Hire Date,Continuous Service Date and plan Enrollment St art
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Date.
--------------------------------------------------- ------------- *
/

IF Continuous_Service_date = ACP_CONTINUOUS_SERVICE_DA TE THEN
(

Actual_Accrual_Start_Date = Continuous_service_Date
)
ELSE
(

Actual_Accrual_Start_Date = GREATEST(Continuous_Servi ce_Date
,ACP_ENROLLMENT_START_DATE
,First_Period_SD)

)

/* ------------------------------------------------- --------------
----

Determine the actual start of the accrual calculation
--------------------------------------------------- --------------*
/

IF (Actual_Accrual_Start_Date > First_Period_SD AND
Actual_Accrual_Start_Date > First_Eligible_To_Accrue_ Period_SD

) THEN
(

E = GET_PERIOD_DATES(Actual_Accrual_Start_Date
,Accruing_Frequency
,Beginning_Of_Calculation_Year
,Accruing_Multiplier)

Accrual_Start_Period_SD = GET_DATE(’PERIOD_START_DATE ’)
Accrual_Start_Period_ED = GET_DATE(’PERIOD_END_DATE’)
/*------------------------------------------------- -------------

--
If the Actual Accrual Period is after the Calculation Period the

n
end the processing.
--------------------------------------------------- ----------- *

/

IF (Accrual_Start_Period_SD > Calculation_period_ED) TH EN
(

Total_Accrued_PTO = 0
E = PUT_MESSAGE(’HR_52797_PTO_FML_ACT_ACCRUAL’)

)
)
ELSE IF (First_Eligible_To_Accrue_Period_SD > First_Per iod_SD) THE
N
(

Accrual_Start_Period_SD = First_Eligible_To_Accrue_Pe riod_SD
Accrual_Start_Period_ED = First_Eligible_To_Accrue_Pe riod_ED

)
ELSE
(

Accrual_Start_Period_SD = First_Period_SD
Accrual_Start_Period_ED = First_Period_ED

)

/*------------------------------------------------- ---------------
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----
Retrieve sickness information for previous employment
--------------------------------------------------- --------------
*/

Previous_employment = ’N’
Prev_Sickness_Leave = 0

IF TO_CHAR(ACP_SERVICE_START_DATE,’yyyy’) = TO_CHAR
(Calculation_Date,’yyyy’) THEN

(
Prev_Sickness_Leave = HU_ABS_GET_PREV_EMP_SICKNESS_LEAVE

(TO_CHAR(Calculation_Date,’yyyy’)
,Previous_employment)

)
Accrued_PTO = 0

/* ------------------------------------------------- --------------
----
Now set up the information that will be used in when looping
through the periods
--------------------------------------------------- ---------------
- */

IF Last_period_ED >= Accrual_Start_Period_ED THEN
(

E = SET_DATE(’PERIOD_SD’,Accrual_Start_Period_SD)
E = SET_DATE(’PERIOD_ED’,Accrual_Start_Period_ED)
E = SET_DATE(’LAST_PERIOD_SD’,Calculation_period_SD)
E = SET_DATE(’LAST_PERIOD_ED’,Calculation_period_ED)
E = SET_NUMBER(’TOTAL_ACCRUED_PTO’,Accrued_PTO)
E = LOOP_CONTROL(’HU_SICKNESS_HOLIDAY_PERIOD_ACCRUAL’)
Total_Accrued_PTO = ROUND(GET_NUMBER(’TOTAL_ACCRUED_PTO’))
IF Previous_employment = ’Y’ AND Total_Accrued_PTO >

15 - Prev_Sickness_Leave THEN
(

Total_Accrued_PTO = 15 - Prev_Sickness_Leave
E = SET_NUMBER(’TOTAL_ACCRUED_PTO’,Total_Accrued_PTO)

)
)

IF Accrual_Start_Period_SD <= Calculation_period_ED THE N
(

Accrual_end_date = Calculation_period_ED
)

Effective_Start_Date = Accrual_Start_Period_SD
Effective_End_Date = Calculation_period_ED
IF Effective_Start_Date >= Effective_End_Date THEN
(

Effective_Start_Date = Effective_End_Date
)

RETURN Total_Accrued_PTO, Effective_start_date
, Effective_end_date, Accrual_end_date
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Looping formula

/* ------------------------------------------------- --------------
----
NAME : HU_SICKNESS_HOLIDAY_PERIOD_ACCRUAL
This formula calculates the amount of PTO accrued for a parti cular
period
--------------------------------------------------- ---------------
--*/

/*------------------------------------------------- ---------------
----

Get the global variable to be used in this formula
--------------------------------------------------- ---------------
--*/

DEFAULT FOR ACP_TERMINATION_DATE IS ’4712/12/31 00:00:00 ’ (DATE)
DEFAULT FOR EMP_HIRE_DATE IS ’4712/12/31 00:00:00’ (DATE)
DEFAULT FOR ACP_SERVICE_START_DATE IS ’4712/12/31 00:00: 00’ (DATE)
Continuous_Service_Date = GET_DATE(’CONTINUOUS_SERVIC E_DATE’)
Total_Accrued_PTO = GET_NUMBER(’TOTAL_ACCRUED_PTO’)
Period_SD = GET_DATE(’PERIOD_SD’)
Period_ED = GET_DATE(’PERIOD_ED’)
Last_Period_SD = GET_DATE(’LAST_PERIOD_SD’)
Last_Period_ED = GET_DATE(’LAST_PERIOD_ED’)

/* ------------------------------------------------- --------------
----
Set the payroll period, accruing frequency, and accruing mu ltiplie
r
based on the payroll.
--------------------------------------------------- --------------*
/

Accruing_Frequency = GET_TEXT(’ACCRUING_FREQUENCY’)
Accruing_Multiplier = GET_NUMBER(’ACCRUING_MULTIPLIER ’)
Beginning_of_Calculation_Year =

GET_DATE(’BEGINNING_OF_CALCULATION_YEAR
’)

Period_Accrued_PTO = 0
IF ACP_SERVICE_START_DATE >= Period_SD

AND ACP_SERVICE_START_DATE <= Period_ED
AND ACP_TERMINATION_DATE >= Period_SD
AND ACP_TERMINATION_DATE <= Period_ED THEN

(

Days_valid = HU_ABS_GET_WORKING_DAYS(ACP_SERVICE_START_DATE
,ACP_TERMINATION_DATE)

)
ELSE IF ACP_SERVICE_START_DATE >= Period_SD AND

ACP_SERVICE_START_DATE <= Period_ED THEN
(

Days_valid = HU_ABS_GET_WORKING_DAYS(ACP_SERVICE_START_DATE
, Period_ED)

)
ELSE IF ACP_TERMINATION_DATE >= Period_SD AND

ACP_TERMINATION_DATE <= Period_ED THEN
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(
Days_valid = HU_ABS_GET_WORKING_DAYS(Period_SD

, ACP_TERMINATION_DATE)
)
ELSE
(

Days_valid = HU_ABS_GET_WORKING_DAYS(Period_SD,Period _ED)
)

/* ------------------------------------------------- --------------
----

Calculate the Amount Accrued this Period
--------------------------------------------------- --------------*
/
Period_Accrued_PTO = 15 * (Days_valid/260)

/*------------------------------------------------- ---------------
----
Calculate any absence or bought/sold time etc. to be account ed for

in
this period.
--------------------------------------------------- ---------------
--*/
Absence = GET_ABSENCE(Period_ED, Beginning_of_Calculat ion_Year)
CarryOver = GET_CARRY_OVER(Period_ED, Beginning_of_Cal culation_Yea
r)
Other = GET_OTHER_NET_CONTRIBUTION(Period_ED

,Beginning_of_Calculation_Year)
Period_Others = CarryOver + Other - Absence

/*------------------------------------------------- ---------------
----

Set the Running Total
--------------------------------------------------- ---------------
*/

E = SET_NUMBER(’TOTAL_ACCRUED_PTO’
,Total_Accrued_PTO + Period_Accrued_PTO)

/* ------------------------------------------------- --------------
----
Establish whether the current period is the last one, if so en d
the processing, otherwise get the next period
--------------------------------------------------- --------------*
/

IF Period_SD = Last_Period_SD THEN
(

Continue_Processing_Flag = ’N’
)
ELSE
(

E = GET_PERIOD_DATES(ADD_DAYS(Period_ED,1)
,Accruing_Frequency
,Beginning_of_Calculation_Year
,Accruing_Multiplier)

E = SET_DATE(’PERIOD_SD’, GET_DATE(’PERIOD_START_DATE’ ))
E = SET_DATE(’PERIOD_ED’, GET_DATE(’PERIOD_END_DATE’))
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Continue_Processing_Flag = ’Y’
)

RETURN Continue_Processing_Flag

Sample Formula for Carry Over Absence (Hungary)
Oracle HRMS provides the HU_ABS_CARRYOVER_FORMULA to calculate their
unused Base Holiday, Additional Holiday for bringing up children, and Other Additional
Holiday except Sickness Holiday. Employees can carry over these holidays up to 30th
June of the following year or, if the collective agreement permits, up to 31st December of
the following year. The formula considers 30th June as the carry over expiry date.

You can use the sample formula HU_ABS_CARRYOVER_FORMULA to calculate the
above entitlements. The sample formula is given below:
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/*================================================= ==============
=====
Formula Title : HU_ABS_HOLIDAY_CARRY_OVER
Description : This Formula carries over the holidays remain ing t
o

next period.
=================================================== ===============
*/
DEFAULT FOR ACP_CONTINUOUS_SERVICE_DATE IS ’4712/12/31 00:00:00’ (
date)
DEFAULT FOR ACP_SERVICE_START_DATE IS ’4712/12/31 00:00: 00’ (date)

INPUTS ARE Calculation_Date (date)
,Accrual_Term (text)

IF ACP_CONTINUOUS_SERVICE_DATE WAS DEFAULTED THEN
(

Continuous_Service_Date = ACP_SERVICE_START_DATE
)
ELSE
(

Continuous_Service_Date = ACP_CONTINUOUS_SERVICE_DATE
)
calculation_period_end_date =

TO_DATE(’3112’|| TO_CHAR(Calculation_Date,’YYYY’),’D DMMYY
YY’)

IF Accrual_Term = ’PREVIOUS’ THEN
(

Effective_Date = ADD_YEARS(calculation_period_end_dat e, -1)
)
ELSE
(
Effective_Date = calculation_period_end_date
)

Expiry_Date = ADD_MONTHS(effective_date, 6)
Years_service = FLOOR(MONTHS_BETWEEN(ADD_DAYS(Effecti ve_date,1)

, Continuous_Service_Date) / 1
2)

IF (GET_ACCRUAL_BAND(Years_service) = 0) THEN
(

Max_carryover = GET_NUMBER(’MAX_CARRY_OVER’)
)
ELSE

Max_carryover = 30

Process = ’YES’

RETURN Max_Carryover, Effective_date, Expiry_Date, Proc ess

Registering a Function
You register a new function by naming and defining it, then creating contexts and
parameters for it. Contexts are environment values that do not get passed to the function.
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Where a function requires a mixture of contexts (from the FF_CONTEXTS table) and
parameters, the contexts should be listed first in the function header followed by the
function parameters. Only the function parameters, however, need to be used to call
the function from FastFormula.

For example, a function requires eight values: three contexts and five parameters. All
eight values are listed in the function header but only the five parameters are used to
call the function.

You register the class of the function as external. External functions are further PL/SQL
functions in addition to the ones already delivered with FastFormula. External functions
can use contexts and parameters.

To register a new function for Oracle FastFormula:
1. Enter a unique name for the new function.

2. Select date, number or text as its data type.

3. Select external as the class of the function.

4. Enter an alias for the function name if you require an alternative name for it. You
can also enter a description to explain what the function is for. The Alias and
Description fields are both optional.

5. Enter the definition of the function. Use the format: <package name>.<function
name>.

6. Save your entries.

To enter context usage and parameter information:
1. Choose the Context Usages button.

2. In the Context Usages window, select as many context items as you require for the
function. The data type for each context displays automatically.

Note: The functionality that calls FastFormula, that is, QuickPaint
or Payroll Processing, determines what contexts FastFormula has
access to from the FF_CONTEXTS table.

3. Save your entries. The sequence number of each context is entered automatically
when you do this.

4. Close the Context Usages window and choose the Parameters button.

5. In the Parameters window, enter the parameters, or operands, you require to define
the function. Type and class display automatically.

6. Check the Optional check box if you want the corresponding parameter to be
optional.

7. Check the Continuing check box if you want the function to make more than one
call to the parameter.

Note: You cannot define a parameter as continuing unless you
also make it optional. However, an optional parameter does not
have to be continuing.

8. Save your entries.
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Defining Global Values
Use global values to store information that does not change often, but you refer to
frequently, as for example Company Name, or company-wide percentages used in the
calculation of certain bonuses. You can use global values as variables in formulas by
simply referring to the global value by name.

You can never change a global value using a formula. You change global values in
the Globals window. Global values are datetracked so you can make date effective
changes ahead of time.

Global values are available to all formulas within a Business Group.

To define a global value:
1. Set your effective date to the date when you want to begin using the global value.

2. Enter a name, data type (number, text, or date), and value. You can also enter a
description.

Bulk Compiling Formulas
Where a formula has more than one version, you can compile all the versions in one
process using the Bulk Compile Formulas process. For example, you run this process
when you upgrade your legislative information, which contains formulas. The Bulk
Compile Formulas process automatically generates the Formula Wrapper.

To bulk compile formulas:
1. Select Single Request in the Submit a New Request window.

2. In the Name field, select Bulk Compile Formulas and submit your request.

You can define when you want to run this process using the schedule options.

Note: If you make any changes to a function after you have
compiled a formula that uses it, you need to recompile the formula
for the changes to take effect.

Generating the Formula Wrapper
To get the best performance for executing formulas from PLSQL you need to generate
the Formula Wrapper. The Bulk Compile Formulas process automatically generates
the Formula Wrapper.

Note: You do not need to generate the Formula Wrapper to test a
formula.

To generate the Formula Wrapper:
1. Select Single Request in the Submit a New Request window.

2. In the Name field, select Generate Formula Wrapper and submit your request.

You can define when you want to run this process using the schedule options.
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Writing or Editing a Formula
Use the Formula window to write and edit formulas.

Note: You cannot create formulas that exceed 64K in the Formula
window. You must split longer formulas into two.

To write or edit a formula:
1. Set your effective date to the date when you want to begin using the formula.

2. To write a new formula, enter the formula’s name and select a type. To edit an
existing formula, query its name.

3. Choose the Edit button to open a blank Edit Formula window where you can write a
new formula, or modify an existing one.

4. If you want to select database items, choose the Show Items button to display the
Database Items window and run a query. Copy and paste items from this window
to the Edit Formula window.

5. When you finish writing or editing the formula, choose the Verify button to compile
it.

This process identifies any syntax errors in your formula.

Note: Once you have compiled any formula, new functions
or changes to existing functions made after the first time you
compile, are not used. You must logout of Oracle HRMS and login
again. You can now compile your formula and the new functions
and/or changes to existing functions will be included.

6. When the formula is verified successfully, save it.

7. Your next step depends on the type of formula:

• If the formula is of type Oracle Payroll, you must associate it with an element in
the Formula Result Rules window.

• If the formula is of type Element Skip, you select it in the Skip Rule field of
the Element window.

• If the formula is of type Element Input Validation, you select it in the Formula
field of the Input Values window when you are defining an element.

• If the formula is of type User Table Validation, you select it in the Formula field
of the Columns window when you are defining a user table structure.

• If the formula is of type Accrual, Accrual Carryover, or Accrual Ineligibility, you
select it in the Accrual Plan window.

• If the formula is of type Accrual Subformula, you call it from another formula
of type Accrual.

• If the formula is used for benefits administration, you select the formula in the
Rules field of the appropriate benefits window.

Test your formula in the situation you intend to use it (such as, in a test payroll run)
to ensure it contains no logical errors.
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Writing Payroll Formulas for Elements
If you have defined your own payroll elements, you can write formulas to calculate
earnings and deductions.

For guidance on writing efficient payroll calculation formulas, see: Formula Writing
Techniques, page 1-12. For important information about using element input values in
payroll formulas, see: Input Values in Payroll Formulas, page 1-19.

To define elements and their formulas:
1. Design your element and how it will be calculated.

2. Write any formulas required to validate input values (formula type = Element
Input Validation).

3. Write a formula, if required, to define the rules for skipping the element during
payroll processing (formula type = Element Skip).

4. Define the element, referencing any formulas written in steps 2, page 1-229 and 3,
page 1-229.

5. Write the formula or formulas for calculating the run results (formula type = Oracle
Payroll).

6. Associate each Oracle Payroll type formula with the element in the Formula Result
Rules window, and specify what happens to the formula results for this element.

Note: You can associate several formulas with a single element, each
one for use with a different employee assignment status. You
can also use the same formula for more than one element. In this
case, if the formula references pay or input values (through the
Inputs statement), each element must have pay and input values
with the same names.

Writing Formulas for Accrual Plans
Each accrual plan needs to be associated with two formulas: an accrual formula to
calculate gross PTO entitlement to date and a Carry Over formula to be called by the
carry over process at the end of the accrual term.

You can also associate a third formula to be called by BEE (Batch Element Entry)
validation for entries to the absence element associated with the accrual plan. This
Ineligibility formula checks whether an assignment is eligible to use accrued PTO. It
must calculate the end of the ineligibility period in the same way as the Accrual formula
for the plan. This formula is not required if you enter the ineligibility period for a
plan in the Accrual Plan window.

Some formulas are seeded, see Seeded Accrual Type Formulas, Oracle Time & Labor
Implementation and User Guide. You can use these as supplied, edit them, or write your
own formulas to provide the plan rules you require.

This topic explains:

• The formula types for formulas associated with accrual plans

• The required inputs and outputs for Accrual, Carry Over, and Ineligibility formulas

• Checks you must include in your Accrual formulas to avoid errors
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For a sample Accrual formula and suggestions on how to change it to incorporate a
whole range of plan rules, see: Sample Accrual Formula, page 1-108.

Formula Types

There are a number of formula types for formulas associated with accrual plans. You
must define your formulas as the appropriate types or they will not be available for
selection in the Accrual Plan window.

Formula Type Displays on list of values for
. . .

Use for . . .

Accrual Accrual Formula field The top level formula that
calculates PTO entitlement for
a plan

Accrual Subformula -- Any formulas called by the
top level formula, such as
formulas for calculating the
entitlement per period.

Accrual Carryover Carryover Formula field The formula to be called by
the Carry Over process.

Accrual Ineligibility Ineligibility Formula field The formula to be called by
BEE (if required) to specify
whether an assignment is
eligible to use accrued PTO.

Required Inputs and Outputs

If you write your own formulas for accrual plans, you must use the following INPUTS
and RETURN statements. Do not add extra lines to these statements. You can use
functions or database items to get extra inputs. The following values are available as
contexts for all the accrual formula types (and therefore you do not need to retrieve
them as inputs or database items):

• ASSIGNMENT_ID

• DATE_EARNED

• ACCRUAL_PLAN_ID

• BUSINESS_GROUP_ID

• PAYROLL_ID

Some formula functions have been defined specially for Accrual type formulas. They
require some or all of these contexts and they return values need for the accrual
calculation, such as total absences, accrual band, and period dates. See: Functions for
Accrual Type Formulas, page 1-39. You can define and register any other functions
you require.

Inputs and Outputs for Accrual Formulas
INPUTS ARE

Calculation_Date (date)
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ACCRUAL_START_DATE (date)

ACCRUAL_LATEST_BALANCE

/* Formula body */

RETURN total_accrued_pto, effective_start_date, effect ive_end_dat
e, accrual_end_date

Input Description

Calculation_Date The date up to which accrual will be calculated

Accrual_Start_Date The date to begin calculating accrual. If
null, accruals are calculated from beginning of
the accrual term.

Accrual_Latest_ Balance The latest balance for the accrual term up to
the day before Accrual_Start_Date. The latest
balance is held in a payroll balance.

Note: The Accrual_Start_Date and Accrual_Latest_Balance inputs
are required only if your accrual plan uses a payroll balance to store
gross accruals.

Output Description

total_accrued_pto Gross accrued PTO this term

effective_start_date Start date of accrual, which
is normally the start of this
accrual term, but may be
plan enrollment date, hire
date, adjusted service
date, or other, depending on
plan rules.

effective_end_date Normally the calculation
date, but should be
the termination date if
the employee has been
terminated, or the end date
of the plan element entry
if the employee has left the
plan.

accrual_end_date This is an optional output. In
the seeded formulas it is the
end of the last full accrual
period before the calculation
date (because these formulas
do not take account of partial
accrual periods).
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Inputs and Outputs for Carry Over Formula
INPUTS ARE

calculation_date (date),

accrual_term (text)

/* formula body */

RETURN max_carryover, effective_date, expiry_date, proc ess

Input Description

calculation_date Any date falling within an accrual term

accrual_term ’PREVIOUS’ or ’CURRENT’ indicating
whether to return the last date of the accrual
term spanning calculation_date, or the accrual
term previous to that spanning calculation
date.

Output Description

max_carryover Maximum amount the employee can carry
over, which may be dependent on an accrual
band.

effective_date The last date of an accrual term (either current
or previous, as determined by the input). For
example, this would be 31-DEC-YYYY for an
accrual plan based on calendar years.

expiry_date The date by which employees must use carried
over PTO, otherwise they lose it. This output
is optional.

process Set to Yes by default. This means that the
max_carryover amount is returned. If you set
it to No, max_carryover is set to Null by the
Carry Over process

Inputs and Outputs for Ineligibility Formula
INPUTS ARE

calculation_date (date),

/* formula body */

RETURN assignment_eligible

1-232 Oracle Human Resources Management Systems FastFormula User Guide



Input Description

calculation_date The effective date of the element entry.

Output Description

assignment_eligible ’Y’ or ’N’. If Y, BEE creates the entry to the
absence element (assuming all other validation
is successful). If N, BEE creates a warning on
the batch line for the absence entry.

Checks You Must Include In Your Accrual Formulas

You may notice that the seeded formulas contain statements to check a number of dates
to see whether an employee is eligible to accrue any PTO. Be sure to include these checks
in your formulas too.

Termination Date

Check whether there is a termination date for the assignment. If the termination date is
before the calculation date, calculate accrual as of the termination date. If your formula
does not handle partial accrual periods, check whether the termination date is before the
end of the first accrual period; if yes, set gross accrual to zero.

Enrollment End Date

Check whether there is an end date for the assignment’s enrollment in the plan. If the
end date is before the calculation date, calculate accrual as of the end date. If your
formula does not handle partial accrual periods, check whether the end date is before the
end of the first accrual period; if yes, set gross accrual to zero.

Calculation Date

If the calculation date is before the end of the first accrual period, set gross accrual to
zero (unless your formula handles partial accrual periods).

Hire Date

Check the employee’s hire date or continuous service date. If your formula handles
partial accrual periods, check that this date is before the calculation date, and if not, set
the gross accrual to zero. If your formula does not handle partial periods, check that this
date is before the start of the last full accrual period used in the current calculation. If
the employee has not worked for a full accrual period before the calculation date, set
the gross accrual to zero.

Start Date for New Plan Participants

Check when the employee should start to accrue time. This is typically the date of
enrollment in the plan or (if your formula does not handle partial accrual periods) the
first period starting on or after the date of enrollment in the plan. If this date (or period)
is after the calculation date (or period), set the accrual to zero.
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Note: The seeded and sample formulas also show how to incorporate
other start dates in your plan, such as six months after hire date, or start
of calendar year after hire date.

Ineligibility Period

Check any ineligibility period (which is a time when a new participant accrues time but
cannot use it, so it does not appear credited to him or her until the end of the period). If
the eligibility period is still in force at the calculation date (or, if your formula does not
handle partial accrual periods, on the end date of the last accrual period used in the
calculation) set the gross accrual to zero.

Inactive Assignment

Check whether the employee’s assignment has been active throughout the period for
which you are calculating accruals. Depending on your plan rules, your employees
might not accrue time when their assignments are inactive, or they might accrue time
at a reduced rate. You can use the function GET_ASG_INACTIVE_DAYS to check the
assignment status on each day from period start date to period end date and return
the number of inactive working days.

1.

Writing Formulas To Calculate Absence Duration
You can write a formula to calculate absence duration automatically when a user enters
an absence start and end date, or time. Your localization team may have written a
formula, which the system will use by default. However, if you need a configured
formula to take account of special work hours or shift patterns, you can create a new
formula that will override the supplied one. You can create one formula for each
Business Group.

Your formula must be called: BG_ABSENCE_DURATION. You must select the formula
type QuickPaint.

The formula inputs must be:

• days_or_hours (units for the duration: D or H)

• time_start, time_end

• date_start, date_end

The formula outputs must be:

• duration (the calculated value or FAILED)

• invalid_msg (optional - an error message name)

Use the supplied example formula (TEMPLATE_ABSENCE_DURATION) as the basis
for your formulas.
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1.

Writing Formulas for Element Skip Rules
If your payroll policies require conditional processing of an element, you can write a
formula to define when the run should process the element and when it should skip
it. For example, your formula could specify:

• process the Union Fees element every run unless the Union_Fees_Paid balance
is greater than 10 000.

Your skip rule formula must be consistent with other processing rules defined for the
element, such as frequency rules, which determine in which period the element is
normally processed. Notice that a skip rule cannot contravene any other processing
rules in place for the element.

You can associate only one element skip rule formula with each element. You must
write and validate the formula before you define the element so that you can select the
formula from a list on the Element window.

To write a formula defining a skip rule:
1. Select formula type Element Skip in the Formulas window.

2. Use as many input values as you require. The formula must set and return a local
variable of type text, and this variable must be called skip_flag.

If the returned value of this variable begins with the letter y (such as ’Yes’), all
processing for the element is skipped. Otherwise the element processes as normal.

The following example of a skip rule formula defines that the Union Fees element is
not processed if the Union_Fees_Paid balance is greater than 10 000:

IF Union_Fees_Paid > 10000

THEN

skip_flag = ’yes’

ELSE

skip_flag = ’no’

RETURN skip_flag

Copying and Adding Features to a QuickPaint Formula
When you save a QuickPaint Report definition, a formula is generated
automatically. Formulas generated from QuickPaint do not include conditional logic or
calculations. You may want to add these features, for example to sum up compensation
elements or to report different data for different assignments.
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Important: If you want to add features to a generated QuickPaint
formula, you must copy the formula and edit the copy. If you edit the
original, your edits will be overwritten if the formula is regenerated
from the QuickPaint definition.

To make a copy of a QuickPaint formula:
1. In the Formula window, query your QuickPaint formula. It has the same name as

your QuickPaint report.

2. Choose the Edit button. Select and copy the formula in the Edit Formula window.

3. Choose New Record from the Edit menu.

4. Enter a name for your edited copy and select the type QuickPaint.

5. Paste the text of the QuickPaint formula into the Edit Formula window.

6. Save your work.

Writing Formulas for Validation
You can use Oracle FastFormula to validate user entries into the element input
values, and to user tables that you define.

To write a formula for validation purposes:
1. Write and validate the formula.

You must do this before you define the element or table, so that you can select the
formula from a list in the Element window or Columns window.

2. Define the element or table.

3. Select formula type Element Input Validation or User Table Validation in the
Formulas window.

Rules to Observe
• There must be one input value, of type text, and it must be called entry_value.

• The formula must set and return a local variable giving the status of the
validation (success or error). This variable must be called formula_status and
have the value ’s’ (success) or ’e’ (error).

• Optionally, the formula can also return a text variable giving an explanatory
message. The returned message variable must be called formula_message and
can contain any text. It can be returned with both successful and unsuccessful
statuses.

• The formula must not return any other results.

For an element input value validation formula, you must also observe the following
rules:

• You cannot use the element’s other pay and input values in the formula.

• You cannot return a value to another pay or input value.

All entry values are stored in the database as text items. Therefore, if you want to
validate an entry value as a date or number, you must use Oracle FastFormula’s
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conversion function to convert the text into a date or number type variable. For
example:

TO_NUM (entry_value)

TO_DATE(entry_value,’DD-MON-YYYY’)

Writing Formulas to Calculate Eligibility for a Collective Agreement
Entitlement

You can write a formula to be used to calculate whether a person is eligible to receive a
collective agreement entitlement. This can be used when defining an eligibility profile
to be used in conjunction with a collective agreement, instead of selecting criteria
elements. You select the formula as a rule when defining the eligibility profile.

Your formula name can be whatever you like. You must select the formula type CAGR.

There are no formula inputs for this formula type.

The formula outputs depend on the category of the entitlement with which this formula
is to be used. If the category is Absence, Payroll, or Assignment, then the output values
are:

• Value

• Range From

• Range To

If the category is Pay Scale, then the output values are

• Parent_Spine_ID

• Step_ID

• From_Step_ID

• To_Step_ID

• Grade_Spine_ID

The contexts for this formula type are:

• BUSINESS_GROUP_ID

• PAYROLL_ID

• ASSIGNMENT_ID

• DATE_EARNED

• ORGANIZATION_ID

• TAX_UNIT_ID

• PERSON_ID

Use the supplied example formulas HR_CAGR_TEMPLATE (for Absence, Payroll, or
Assignment categories) and HR_CAGR_PYS_TEMPLATE (for Pay Scale categories)
as the basis for your formulas.
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1.

Editing Assignment Set Formulas
Assignment set formulas do not normally need to be edited. If, however, you enter
multiple criteria to define an assignment set, with conditions joined by AND or OR, you
may want to edit the formula to change the brackets in the generated conditions. This
changes the order in which the conditions are tested.

To view an assignment set formula, query it in the Formula window. The formula type is
Assignment Set and the formula name is the same as the assignment set name. To edit an
assignment set formula, make a copy, as for a QuickPaint formula.

1.

Writing Formulas for Default Assignment Costing
You can write a formula to specify the cost allocation key flexfields and their proportions
that you use for default assignment costing.

Note: As a prerequisite, you must set the profile option HR: Default
Assignment Costing to Yes.

To write a formula for default assignment costing:
1. Open the Formula window.

2. Required: enter the formula name exactly as below:

• PER_DFLT_ASG_COST_ALLOCATION

3. Select a formula Type of Element Input Validation.

4. Enter a Description of the formula.

5. Choose the Edit button.

6. Write the formula. Oracle HRMS provides the following inputs:

• assignment_id (number)

• business_group_id (number)

• position_id (number)

• effective_date (date)

Note: Because no context is set, do not use FastFormula Database
Items. Instead, use functions for complex formulas.

Use the sample code below as a guideline in writing your own formula.

USE_FORMULA = ’Y’

COST_ALLOCATION_KEYFLEX_ID1 = 101
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COST_ALLOCATION_KEYFLEX_ID2 = 102

COST_ALLOCATION_KEYFLEX_ID3 = 103

PROPORTION1 = .5

PROPORTION2 = .3

PROPORTION3 = .2

RETURN USE_FORMULA,

COST_ALLOCATION_KEYFLEX_ID1, PROPORTION1,

COST_ALLOCATION_KEYFLEX_ID2, PROPORTION2,

COST_ALLOCATION_KEYFLEX_ID3, PROPORTION3

If the application does not return a value for USE_FORMULA; or, if the value for
USE_FORMULA is not equal to ’Y’, the default assignment costing will not use the
accounts and proportions returned by the formula. Instead, default assignment
costing will be calculated based on the position control budget for the business
group, if one has been defined.

If USE_FORMULA = ’Y’,the application creates the default assignment costing with
the cost allocation flexfield id (COST_ALLOCATION_KEYFLEX_ID%) and the
related proportion (PROPORTION%).

• If the COST_ALLOCATION_KEYFLEX_ID% does not contain a valid cost
allocation id for the business group,then that entry will be ignored.

• If the PROPORTION% is greater than 1, it will be treated as 1.

• If the PROPORTION% is less than 0, the entry will be ignored.

Writing Formulas for Templates
There are several ways you can use formulas to configure the people management
templates:

• A Template Validation formula can check values entered in a field.

• A Template Information formula can specify information to be displayed from the
right mouse menu when a user right-clicks in a field.

• A People Management Message formula can return a text string to display in the
Assignment field on the Maintenance window and in the Data Organizer.

• A People Management Message formula can return message tokens that you can use
in a notification message issued from template forms.
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Template Validation Formulas

If you use a formula to validate user entries in template fields, you must observe the
following rules:

• Select the formula type Template Validation in the Formulas window.

• There can be up to five inputs, and they must be called item1, item2, item3, item4, and
item5.

• The formula can return up to three outputs, which must be named as follows:

• Status, which must have the value ’s’ if the validation was successful. Any
other value is interpreted as an error.

• Message, which is a text variable. The formula can return a message with
validation statuses of success, failure, or both.

• Item, which is the new value of the field that is being validated.

After creating the formula, you select it in the Validation Formula property for the field
when you are setting up the template in the People Management Configurator. You can
also enter up to five parameters to be passed to the formula, including the value you are
validating. For example, you might enter the name of another field on the template if
you want the formula to cross-validate the value in one field against another.

Example

Here is a formula that validates the entry in the Organization field on the Maintenance
window. It raises an error if the entry is not Corporate Finance.

/* Updateable Values Section */

/* Defaults Section */

/* Inputs Section */

INPUTS ARE item1 (text)

/* Main Body of Formula */

organization_name = item1

status = ’s’

message = ’ ’

IF organization_name <> ’Corporate Finance’ THEN

(
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message = ’Organization must be Corporate Finance’

status = ’f’

)

RETURN message, status

When you are setting up the template in the People Management Configurator, select the
Organization (Maintain) item. Select the name of your formula as the Validation Formula
property and select Organization (Maintain) as the Validation Formula Parameter
1 property. This passes and validates the value the user enters, not any codes or table
identifiers to which it may be related.

Template Information Formulas

If you write a formula to return additional information for a field, you must observe
the following rules:

• Select the formula type Template Information in the Formulas window.

• There can be up to five inputs, and they must be called item1, item2, item3, item4, and
item5.

• The formula can return one text output, which must be called Message. This is the
information that is displayed when the user right clicks in the field and selects a
prompt that you define in the right mouse menu.

After creating the formula, you select it in the Information Formula property for the field
when you are setting up the template in the People Management Configurator. You can
also enter up to five parameters to be passed to the formula. For example, if you were
specifying an information formula for the job field, you might enter the name of the
organization field so that the formula can return different additional job information
depending on the organization.

Example

Here is a formula that returns contact information to be displayed from the Supervisor
field.

/* Updateable Values Section */

/* Defaults Section */

DEFAULT FOR sup_work_phone IS ’ ’

DEFAULT FOR sup_email_address IS ’ ’

/* Inputs Section */
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/* Main Body of Formula */

message = ’Supervisor Contact Details||CHR(10)||’Teleph one:

’||sup_work_phone||CHR(10)||’Email: ’||sup_email_add ress

RETURN message

People Management Message Formula for Assignment Field

Applicant and employee assignments are listed by name in the Data Organizer in
the template Summary window and in the Assignment field on the Maintenance
window. Since assignments do not have names, you can choose what assignment
information is displayed as a name to help your users select the assignments they
want to work with.

By default, assignments are identified as <job>.<organization>, such as Senior
Manager.Engineering. However, you can choose any other database items to display.

If you want to override the default, write a formula (of type People Management
Message) called ASSIGNMENT_NAME. This formula must return a text string. If
there is no formula called ASSIGNMENT_NAME on the database, the system uses the
predefined formula QH_ASSIGNMENT_NAME.

The QH_ASSIGNMENT_NAME formula is as follows:

/* Updateable Values Section */

/* Defaults Section */

DEFAULT FOR asg_job IS ’ ’

DEFAULT FOR asg_org IS ’ ’

/* Inputs Section */

/* Main Body of Formula */

assignment_name = asg_job||’.’||asg_org

RETURN assignment_name

People Management Message Formulas for Message Tokens

If you write a formula to return messge tokens, you must observe the following rules:
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• Select the formula type People Management Message in the Formulas window.

• The formula must have the same name as the notification message that will use
the tokens.

• The formula can return up to five text outputs, which must be named
FF1, FF2, FF3, FF4 and FF5.

Example

Suppose you want to include an employee’s preferred name in a New Hire
notification. The New Hire notification is called NEW_STARTER, so you create a
formula of the same name that returns this name in the variable FF1:

/* Updateable Values Section */

/* Defaults Section */

DEFAULT FOR per_known_as IS ’ ’

/* Inputs Section */

/* Main Body of Formula */

FF1 = per_known_as

RETURN FF1

Then you edit the New Hire notification to include the FF1 variable. For example:

Please note, that we have a new employee as of &HIRE_DATE.

They are &FULL_NAME (&EMPLOYEE_NUMBER).

Known as: &FF1.

Their new job details are:

Position: &POSITION

Job: &JOB

Organization: &ORGANIZATION

Location: &LOCATION

1.

Writing Proration Formulas
When the payroll run encounters an event (such as a grade change) that you have
defined as a proration event for the element being processed, it creates two run results
for the element--one for the payroll period up to the day before the event, and one from
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the date of the event to the end of the period. You must define a formula to handle this
proration processing for the element. There are two ways to do this:

• Edit the element’s Oracle Payroll formula so that it can handle proration, or

• Create an additional formula to run after the Oracle Payroll formula only in periods
when a proration event is encountered. You select this formula in the Proration
Formula field on the Proration tab of the Element window.

Using a separate proration formula has the advantage that proration takes place even
when you enter a pay value directly on the element entry. Embedding the proration
calculation in the Oracle Payroll formula avoids the overhead of calling the second
formula in periods when proration events occur.

If you want to write a proration formula, you must follow these rules:

• Select the formula type Payroll Run Proration.

• The formula inputs can be:

• any of the element input values

• prorate_start (DATE)

• prorate_end (DATE)

• The formula outputs can be:

• any of the element input values

Your localization team may have created example formulas that you can use as the
basis for your own formulas.

1.

Writing Formulas for EEO Employment Categories
Use Oracle FastFormula to map your employment categories to the output values
required for EEO4 and EEO5 reports. The EEO reports pick the list of employment
categories from the formula.

Your formula must have the name PQH_EMPLOYMENT_CATEGORY, and the formula
type must be Element Input Validation. If you want to use this formula, you must
define it for each business group.

If you do not create a formula for employment categories, the default employment
category list is used:

• FR - Full-time regulars

• FT - Full-time temps

• PR - Part-time regulars

• PT - Part-time temps

The formula output values are:

• Full_Time_Regulars

• Full_Time_Temps

• Part_Time_Regulars

• Part_Time_Temps
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In the example below, employees with employment categories FR and FRD are treated as
full-time regulars; those with employment categories FT, FTL, and FTJ are treated as
full-time temporaries; those with PR are treated as as part-time regulars; and those with
PT are treated as part-time temporaries.

/*Comma separated list of the employment categories with no space
s in between */

full_time_regulars = ’FR,FRD’

full_time_temps = ’FT,FTL,FTJ’

part_time_regulars = ’PR’

part_time_temps = ’PT’

RETURN full_time_regulars, full_time_temps, part_time_ regulars, p
art_time_temps;

1.

Writing Formulas for Person Number Generation
When automatic local person numbering is in effect, Oracle HRMS allocates numbers
for a person type (employees, contingent workers, or applicants) from a number
sequence that is specific to the business group. When global person numbering is in
effect, Oracle HRMS allocates numbers for a person type from a single global sequence
across all business groups.

You can write a formula of type Person Number Generation to generate a global custom
number sequence in place of the default local or global sequence. Once you have defined
and validated a formula, Oracle HRMS executes the formula whenever automatic person
numbering is active and a person number is required.

Formula Names and Parameters

The formula names for the Person Number Generation type are:

• EMP_NUMBER_GENERATION (for employee numbers)

• APL_NUMBER_GENERATION (for applicant numbers)

• CWK_NUMBER_GENERATION (for contingent worker numbers)

You can define only one formula for each person type.

Important: You must define person number generation formulas in the
Setup business group, and they must have the names shown here. The
formulas have no effect if you define them in any other business group
or if you do not use the specified names.

The formula context value is Business Group ID.
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The formula inputs are:

• Legislation code

• Person type

• Person number

• Party ID

• Person ID

• Date of birth

• Start date (which is the hire date for employees, the latest start date for
applicants, and the placement start date for contingent workers)

• National identifier

The person number and person ID parameters are null when you create a new person
record and nonnull when you update an existing person record. Although you cannot
change a person number when you update a person record, Oracle HRMS checks that
the number is valid. If the number is not valid (for example, if it is null), Oracle HRMS
may execute the person number generation formula.

The formula outputs are:

• Next person number

• Completion message (for example, an error message)

The following general rules apply to person number formulas:

• Gaps in the number sequence are valid.

• Oracle HRMS checks that numbers from a custom sequence are unique in the
business group.

• A custom number sequence applies to all business groups. However, you can write a
formula that works differently in each business group.

• You can manage other business needs in the logic of the formula. For example, you
may want employees to keep their employee numbers when they transfer to
different business groups.

HR: Use Global Person Numbering Option

To use the default global person number sequence for a person type, you run the process
"Change automatic person number generation to global sequencing," for the person type
(Applicant, Contingent Worker, or Employee). This process sets the appropriate user
profile option (HR: Use Global Applicant Numbering, HR: Use Global Contingent
Worker Numbering, or HR: Use Global Employee Numbering) to Yes.

You do not need to run this process if you define a valid custom formula. The HR: Use
Global Person Numbering options control the default global person number sequences
only.

If you both define a valid formula for generating person numbers and run the process
"Change automatic person number generation to global sequencing," Oracle HRMS
writes this message to the log: "A valid custom formula for generating person numbers
exists. The default global number sequence will not be used." However, if the custom
formula becomes invalid or you delete it, Oracle HRMS switches to the default global
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person number sequence because the profile option is set to Yes. Otherwise, Oracle
HRMS switches to the default local sequence.

See Writing or Editing a Formula, page 1-228

1.
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A
Windows and their Navigation Paths

This section lists the default navigation paths for all the windows in Oracle HRMS as
they are supplied. You can use task flow windows directly from the menu, or from
the People and Assignment windows.

The responsibility that you use determines which of these windows you can use and
how you access them. Your system administrator sets up navigation menus and task
flows for your responsibility. They may also create configured versions of some of these
windows using different window titles.

AAP Organization (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an AAP Organization.

3. Choose the Others button and select AAP Organization.

Absence Attendance Type
1. Choose Total Compensation -> Basic -> Absence Types in the Navigator.

Absence Detail
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Others button and select Absence.

Or:

1. Choose Fastpath -> Absence in the Navigator.

2. In the resulting Find window, query the person.

Absence Tracking (Netherlands)
1. Choose People -> Absence Tracking in the Navigator.

Accommodation (France)
1. Choose People -> Accommodations in the Navigator.
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Accrual Bands
1. Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

2. Enter or query an accrual plan name.

3. Choose the Accrual Bands button.

Accrual Plans
1. Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

Accruals
Do one of the following:

1. Choose View -> Employee Accruals in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the Accruals button.

Or:

1. Choose Fastpath -> Accruals in the Navigator.

2. In the resulting Find window, query the person.

Action Parameters
1. Choose Processes and Reports -> Action Parameters in the Navigator.

Action Types
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the Actions button.

Activity Rate
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the

Navigator.

2. Query a compensation object.

3. Choose the Activity Rate button.

Activity Variable Rates and Rules
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the

Navigator.

2. Query a compensation object.

3. Choose the Variable Rates button.
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Actual Premiums
1. Choose Total Compensation -> Rates/Coverage Definitions -> Actual Premiums

in the Navigator.

Additional Absence Detail Information <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Select Absence.

Or:

1. Choose People -> Fastpath -> Absence Information in the Navigator.

Additional Information for German HR Organizations (Germany)
1. Choose Organization -> Define in the Navigator.

2. Choose the Others button.

3. Select German HR Organization.

Additional Information for German Tax Organizations (Germany)
1. Choose Organization -> Define in the Navigator.

2. Choose the Others button.

3. Place the cursor on the German Tax Office field.

Address
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Address button.

Or:

1. Choose Fastpath -> Address in the Navigator.

2. In the resulting Find window, query the person.

Adjust Balance (Payroll)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.
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3. Choose the Assignment button.

4. Choose the Others button and select Adjust Balance.

Or:

1. Choose Fastpath -> Adjust Balances in the Navigator.

2. In the resulting Find window, query the person.

Advanced Criteria
1. Choose Benefits Extract -> Criteria Definition in the Navigator.

2. Query or enter a criteria definition and choose the Advanced tab.

3. Select a Criteria Type and choose the Details button.

Agency Appeals (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Agency Appeals taskflow button.

Agreement Grades
1. Choose Work Structures -> Collective Agreements -> Collective Agreement Grades

in the Navigator.

Alien Data Window (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

5. Choose the Alien Data button.

Alter Effective Date
1. Choose Tools -> Alter Effective Date from the Tools menu.

Alternative Dispute Resolution (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the ADR taskflow button.

Appeals (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Appeals taskflow button.
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Applicant Entry
1. Choose Recruitment -> Applicant Quick Entry in the Navigator.

Applicant Interview
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select Application.

4. Choose the Interview button.

Application
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select Application.

Or:

1. Choose Fastpath -> Application in the Navigator.

2. In the resulting Find window, query the person.

Application Utilities Lookups
1. Choose Other Definitions -> Application Utilities Lookups in the Navigator.

2. Enter or query a user-defined Type.

Appraisal Template
1. Choose Career Management -> Appraisal Template in the Navigator.

Apprenticeship Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

Approvals: Grade / Step Progression
1. Choose Work Structures -> Grade ->Progression Approval.

Approved Requests for Personnel Action (FD)
1. Choose Request for Personnel Action -> Cancellation/Correction

ASSEDIC Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query an Establishment.

3. Choose the Others button and select ASSEDIC Information.

Assessment Template
1. Choose Career Management -> Assessment Template in the Navigator.

Assign Security Profiles
1. Choose Security -> Assign Security Profiles in the Navigator.

Assignment
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

Or:

1. Choose Fastpath -> Assignment in the Navigator.

2. In the resulting Find window, query the person.

Assignment Budget Values
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant or an employee.

3. Do one of the following:

For an applicant:

• Choose the Others button and select Application.

• Choose the Budgets button.

For an employee:

• Choose the Assignment button.

• Choose the Others button and select Budget Values.

Or:

1. Choose Fastpath -> Assignment Budget in the Navigator.

2. In the resulting Find window, query the person.

Assignment Criteria
1. Choose Payroll -> Assignment Set in the Navigator.

2. Enter or query an assignment set.
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3. Choose the Criteria button.

Assignment Folder
1. Choose View -> Lists -> Assignment Folder in the Navigator.

Assignment History
1. Choose View -> Histories -> Employee Assignment in the Navigator.

Assignment Processes
1. Choose View -> Payroll Process Results in the Navigator.

2. Enter or query a payroll process.

3. Choose the Assignment Process button.

Assignment Set
1. Choose Payroll -> Assignment Set in the Navigator.

Assignment Statuses
1. Choose Work Structures -> Status in the Navigator.

Aubry I Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Aubry I Rebate.

Aubry II Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Aubry II Rebate.

Australian Information (AU)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Australian Information tabbed region.

Authentication Activities (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Authentication Activities

in the Navigator.
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Award/One-Time Payment (FD)
1. Choose Request for Personnel Action -> Award/One-Time Payment

Awards and Decorations pages (France)
1. Choose People -> Awards and Decorations in the Navigator

Balance (Payroll)
1. Choose Total Compensation -> Basic -> Balance in the Navigator.

Balance Classifications (Payroll)
1. Choose Total Compensation -> Basic -> Balance in the Navigator.

2. Enter or query a balance.

3. Choose the Classifications button.

Balance Dimensions (Payroll)
1. Choose Total Compensation -> Basic -> Balance in the Navigator.

2. Enter or query a balance.

3. Choose the Dimensions button.

Balance Feed Control (Payroll)
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Balance Feed Control button.

Balance Feeds (Payroll)
Note: This instance of the Balance Feeds window lets you select more
than one balance for the element to feed.

1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Balance Feeds button.

Bargaining Unit (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Bargaining Unit.
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Batch Assignment Entry
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Enter or query a batch header.

3. Choose the Assignment Lines button.

Batch Header
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

Batch Lines
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Enter or query a batch header.

3. Choose the Element Lines button.

Batch Process Parameters (Advanced Benefits)
1. Choose Processes and Reports -> Batch Process Parameters in the Navigator.

Batch Summary
1. Choose Mass Information eXchange: MIX -> BEE Summary in the Navigator.

Belgian Tax Information (Belgium)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

Beneficiaries (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

4. Choose the Entries button.

5. Select the element representing the benefit for which you are entering a beneficiary.

6. Choose the Others button and select Beneficiary.

Beneficiary Certifications
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query a plan.
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3. Choose the Designations tab.

4. Choose the Beneficiary tab.

5. Choose the Certifications button.

Benefit Contributions (US, CA)
1. Choose Total Compensation -> Basic -> Benefit Contributions in the Navigator.

Benefits Assignment
1. Choose People -> Total Comp Participation -> Person Benefits Assignment in the

Navigator.

Benefits Authentication Form (Advanced Benefits) (US, UK, CA)
1. Choose People -> Total Comp Contribution -> Benefits Authentication Form in the

Navigator.

Benefits Balances
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors

-> Benefits Balances in the Navigator.

Benefits Group
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors ->

Benefits Group in the Navigator.

Benefits Pools (Advanced Benefits)
1. Choose Total Compensation -> Rate/Coverage Definitions -> Benefits Pools in the

Navigator.

Benefits Service Center (Advanced Benefits)
1. Choose People -> Benefits Service Center in the Navigator.

Book Events
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Bookings.

Budget
1. Choose Work Structures -> Budget ->Budget Details in the Navigator.

2. In the resulting Find window, query the budget.
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3. Select a budget version.

4. Choose the Open button.

Budget Characteristics
1. Choose Work Structures -> Budget -> Budget Characteristics in the Navigator.

Budget Details
Note: Follow these steps if you are entering a budget that is not routed
for approval.

1. Choose Work Structures -> Budget ->Budget Details in the Navigator.

2. In the resulting Find window, query the budget.

3. Select a budget version.

4. Choose the Open button.

5. Select a line item in the budget and choose the Periods button.

Note: Follow these steps if you are routing a budget for approval
through a hierarchy of approvers.

6. Choose Work Structures -> Budget ->Worksheet in the Navigator.

7. Define the properties of the worksheet.

8. Choose the Create Worksheet button.

9. Edit the worksheet by entering values for budget line items.

10. Choose the Periods button.

Budget Reallocation
1. Choose Work Structures -> Budget ->Budget Reallocation in the Navigator.

Budget Set
1. Choose Work Structures -> Budget ->Budget Set in the Navigator.

Budget Value Defaults
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group.

3. Choose the Others button and select Budget Value Defaults.

Budgetary Calendar
1. Choose Work Structures -> Budget -> Budget Calendar in the Navigator.
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Budgets
1. Choose Work Structures -> Budget ->Budget Details in the Navigator.

2. In the resulting Find window, query the budget.

Business Group Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group.

3. Choose the Others button and select Business Group Information.

Cadre Life Insurance TA (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Cadre Life Insurance TA.

Calendar
1. Choose Customer and Supplier Maintenance -> Calendar in the Navigator.

Calendar (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

2. Enter or query a pattern.

3. Choose the Calendars button.

Calendar Usages (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

2. Enter or query a pattern.

3. Choose the Calendars button.

4. Choose the Calendar Usages button.

Career Path Names
1. Choose Work Structures -> Job -> Path Name in the Navigator.

Certifications
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the General tab.

4. Choose the Plan or Option tab.
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5. Choose the Certifications button.

Chamber Contribution Information (Germany)
1. Choose Organization -> Define in the Navigator.

2. Choose the Others button.

3. Select German Chamber Tax.

Change Event Log
1. Choose Mass Information eXchange -> System Extract -> Change Event Log in the

Navigator.

Change in Data Element (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Data Element.

Change in Duty Station (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Duty Station.

Change in FEGLI (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in FEGLI.

Change in Hours (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Hours.

Change in Retirement Plan (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Retirement

Plan.

Change in SCD (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in SCD.

Change in Tenure (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Tenure.

Change in Veterans Preference (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Veterans

Preference.
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Change in Work Schedule (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Work

Schedule.

Change to Lower Grade (FD)
1. Choose Request for Personnel Action -> Salary Change -> Change to Lower Grade

Choose Set of Books
1. Choose Customer and Suppler Maintenance -> Choose Set of Books in the Navigator.

Cities (US, CA)
1. Choose Other Definitions -> Cities in the Navigator.

City Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Chose the Tax Information button.

4. Choose the Tax information button from the Federal Tax Rules <Employee> window.

5. Choose the Tax information button from the State Tax Rules <Employee> window.

6. Choose the Tax information button from the County Tax Rules <Employee> window.

Claims (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Claims taskflow button.

COBRA Benefits (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select COBRA.

5. Enter or query a qualifying event.

6. Choose the Benefits button.

COBRA Coverage (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.
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4. Choose the Others button and select COBRA.

COBRA Payments (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select COBRA.

5. Enter or query a qualifying event.

6. Choose the Payments button.

COBRA Statuses (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select COBRA.

5. Enter or query a qualifying event.

6. Choose the Statuses button.

Collapse Life Events
1. Choose Total Compensation -> General Definitions ->Additional Setup -> Collapse

Life Events in the Navigator.

Collective Agreements
1. Choose Work Structures -> Collective Agreements ->Define Collective Agreements

in the Navigator.

Collective Agreement Entitlements
1. Choose Work Structures -> Collective Agreements ->Define Collective Agreements

in the Navigator.

2. Query a collective agreement.

3. Choose the Entitlements button.

Collective Agreement Entitlement Items
1. Choose Work Structures -> Collective Agreements ->Define Entitlement Items

in the Navigator.

Collective Agreement Grades (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query a constituency.

3. Choose the Others button and select Collective Agreement Grades.

Collective Agreement and Grade Progression Results
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Collective Agreement and Grade Progression
Results.

Collective Agreement Retained Rights
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Review Retained Rights.

Columns
1. Choose Other Definitions -> Table Structure in the Navigator.

2. Enter or query a table.

3. Choose the Columns button.

Committees
1. Choose Work Structures ->Organization -> Maintain Committees in the Navigator

Communication Delivery Methods
1. Choose Fastpath -> Personal Delivery Method in the Navigator.

Communication Types
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

Communication Type Children
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query a communication type kit.
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3. Choose the View Children button.

Communication Type Delivery Methods
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query or enter a communication type.

3. Choose the Delivery button.

Communication Type Triggers
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query or enter a communication type.

3. Choose the Triggers button.

Communication Type Usages
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query or enter a communication type.

3. Choose the Usages button.

Competence Details
1. Choose Career Management -> Assessment Template in the Navigator.

2. Enter or query assessment details.

3. Choose the Competencies button.

Competence Profile
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Competence Profile.

Or:

1. Choose Fastpath -> Competence Profile in the Navigator.

Competence Qualifications
1. Choose Career Management -> Competencies in the Navigator.

2. Enter or query a unit standard competence.

3. Choose the Qualifications button.
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Competence Requirements
1. Choose Career Management -> Competence Requirements in the Navigator.

Competence Types
1. Choose Career Management -> Competence Types in the Navigator.

Competencies
1. Choose Career Management -> Competencies in the Navigator.

Complaint People (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Complaint People taskflow button.

Complaints(FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

Complementary Pension Tranche 2 (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Complementary Pension Tranche 2.

Concurrent Requests (UK)
1. Choose Processes and Reports -> View Requests in the Navigator.

Configurable Business Rules
1. Choose Transaction Maintenance Forms -> Configurable Business Rules in the

Navigator.

Consolidation Sets (Payroll)
1. Choose Payroll -> Consolidation in the Navigator.

Constituency Information (for a Representative Body)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a representative body.

3. Choose the Others button and select Constituency.
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Construction Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Construction Tax Info.

Contact
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

Or:

1. Choose Fastpath -> Contact in the Navigator.

2. In the resulting Find window, query the person.

Contexts
1. Choose Security -> Contexts in the Navigator.

Contract
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button.

4. Choose Contracts.

Or:

1. Choose Fastpath -> Contracts in the Navigator.

2. In the resulting Find window, query the person.

Contribution History (Def Comp 457) (US)
1. Choose View -> Histories ->Entries ->Contribution History

Control Totals
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Choose the Totals button.

Conversion Rate Types
1. Choose Payroll -> Conversion Rate Types in the Navigator.
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Conversion to Appointment (FD)
1. Choose Request for Personnel Action -> Conversion to Appointment

Corps, Grades and Pay Scales (France)
1. Choose Total Compensation -> Programs and Plans -> Plan Design Wizard in the

Navigator

2. Select the French Public Sector business area.

Corrective Actions (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

• Choose the Corrective Actions taskflow button.

Costing
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Costing.

Or:

1. Choose Fastpath -> Costing in the Navigator.

2. In the resulting Find window, query the person.

Costing Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Costing.

County Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Chose the Tax Information button.

4. Choose the Tax information button from the Federal Tax Rules <Employee> window.

5. Choose the Tax information button from the State Tax Rules <Employee> window.

Court Orders
1. Choose People -> Total Comp Enrollment -> Court Orders in the Navigator.
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Coverage Across Plan Types
1. Choose Total Compensation -> Rates/Coverage Definitions -> Coverage Across

Plan Types in the Navigator.

Coverage Calculations
1. Choose Total Compensation -> Rate/Coverage Definitions -> Coverage Calculations

in the Navigator.

Covered Dependents (CA)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

4. Choose the Entries button.

Covered Dependents (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

4. Choose the Entries button.

5. Select the element representing the benefit for which you are entering a dependent.

6. Choose the Others button and select Dependents.

Create Batch Lines
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Enter or query a batch header.

3. Choose the Assignment Set button.

Criteria Definition
1. Choose Mass Information eXchange: MIX -> System Extract -> Criteria Definition

in the Navigator.

Custom Reports
1. Choose Processes and Reports -> Submit Custom Reports in the Navigator.

Customer
1. Choose Customer and Supplier Maintenance -> Customer in the Navigator.
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DADS Files (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select DADS Files.

DADS Types (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

Database Items
1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.

2. Enter or query a formula.

3. Choose the Show Items button.

DateTrack History Change Field Summary
1. Choose Tools -> Datetrack History from the Tools menu.

Deduction (Payroll) (US, CA)
1. Choose Total Compensation -> Basic -> Deductions in the Navigator.

Define Combinations
1. Choose Total Compensation -> Rate/Coverage Definitions -> Combinations in the

Navigator.

Define Extract
1. Choose Benefits Extract -> Extract Definition in the Navigator.

Define Function
1. Choose Other Definitions -> Formula Functions in the Navigator.

Define QuickPaint Report
1. Choose Processes and Reports -> Define a QuickPaint Report in the Navigator.

Define Task Flow
1. Choose Security -> Task Flow Definitions in the Navigator.
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Define Task Flow Nodes
1. Choose Security -> Task Flow Nodes in the Navigator.

Delete Person
1. Choose People -> Delete Personal Records in the Navigator.

Denial of Within Grade Increase (FD)
1. Choose Request for Personnel Action -> Salary Change -> Denial of Within Grade

Increase

Dependent/Beneficiary Designation
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment ->
Dependent/Beneficiary Designation in the Navigator.

Or:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program
in the Navigator.

2. Query a person.

3. Choose the Designees button.

Dependent Certifications
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program.

3. Choose the Dependent Coverage tabbed region

4. Choose the Certifications button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan.

3. Choose the Designations tab.

4. Choose the Dependent tab.

5. Choose the Certifications button.

Dependent Change of Life Event
Do one of the following:
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1. Choose Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program and choose the Dependent Coverage tabbed region.

3. Choose the Dependent Change of Life Event button.

Or:

1. Choose Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan and choose the Designations tabbed region.

3. Choose the Dependent tab.

4. Choose the Dependent Change of Life Event button.

Dependent Change of Life Event Certification
Do one of the following:

1. Choose Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program and choose the Dependent Coverage tabbed region.

3. Choose the Dependent Change of Life Event button.

4. Select a life event and choose the Dependent Change of Life Event Certifications
button.

Or:

1. Choose Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan and choose the Designations tabbed region.

3. Choose the Dependent tab.

4. Choose the Dependent Change of Life Event button.

5. Select a life event and choose the Dependent Change of Life Event Certifications
button.

Dependent Coverage Eligibility Profiles
1. Choose Total Compensation -> General Definitions -> Eligibility Profiles ->

Dependent Coverage in the Navigator.

Dependent Eligibility Profiles
Do one of the following:

1. Choose Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program and choose the Dependent Coverage tabbed region.

3. Choose the Eligibility Profiles button.
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Or:

1. Choose Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan and choose the Designations tabbed region.

3. Choose the Dependent tab.

4. Choose the Eligibility Profiles button.

Derived Factors
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors

-> Derived Factors in the Navigator.

Or:

1. Choose Work Structures -> Collective Agreements -> Define Derived Factors in the
Navigator.

Derive Notice Period (Belgium)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Employment.

4. Choose Derive Notice Period.

Or

Choose FastPath -> End Employment.

5. Enter or query an employee.

6. Choose Derive Notice Period.

Designation Requirements
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Options in the Navigator.

2. Query or enter an option.

3. Choose the Designation Requirements button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan.

3. Choose the General tab.

4. Choose the Plan or Option tab.

5. Choose the Designations button.
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Disability (Not US, Not CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Disabilities.

Or:

1. Choose Fastpath -> Disabilities in the Navigator.

2. In the resulting Find window, query the person.

Dynamic Trigger Definition
1. Choose Other Definitions -> Dynamic Trigger Definition in the Navigator.

Dynamic Trigger Functional Area Grouping
1. Choose Other Definitions -> Dynamic Trigger Functional Area Grouping in the

Navigator.

Duty Stations
1. Choose Federal Maintenance Forms -> Duty Stations in the Navigator.

Earnings (Payroll) (US, CA)
1. Choose Total Compensation -> Basic -> Earnings in the Navigator.

Edit Formula
1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.

2. Enter or query a formula.

3. Choose the Edit button.

EEO-1 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select EEO-1 Filing.

Electable Choices
1. Choose People -> Total Comp Participation

2. Choose the Enrollment Opportunities button

3. Choose the Electable Choices button.
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Elections
1. Choose Work Structures -> Elections

Element
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

Element and Distribution Set
1. Choose Payroll -> Element Set in the Navigator.

Element Classifications (Payroll)
1. Choose Total Compensation -> Basic -> Classification in the Navigator.

Element Entries
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Entries button.

Or:

1. Choose Fastpath -> Entries in the Navigator.

2. In the resulting Find window, query the person.

Element Link
1. Choose Total Compensation -> Basic -> Link in the Navigator.

Element Withholding Reasons (UK)
1. Choose SSP/SMP -> Element Withholding Reasons in the Navigator.

Eligibility
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Plan Eligibility button.

4. Choose the Eligibility button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.
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2. Query or enter a plan.

3. Choose the Options button.

4. Choose the Option Eligibility button.

5. Choose the Eligibility button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plans and Plan Types button.

4. Choose the Plans tab or the Plan Types tab.

5. Choose the Participation Eligibility button.

6. Choose the Eligibility button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Participation Eligibility button.

4. Choose the Eligibility button.

Employee Assignment Processes (Payroll)
1. Choose View -> Assignment Process Results in the Navigator.

Employment Certification (Hungary)
1. Choose Hungarian Web ADI Reports > Create Document in the Navigator.

Employee Review
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Reviews.

Or:

1. Choose Fastpath -> Employee Review in the Navigator.

2. In the resulting Find window, query the person.

Employee Run Result History (Payroll)
1. Choose View -> Histories -> Run Results in the Navigator.

Or:
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1. Choose Fastpath -> End Employment in the Navigator.

2. In the resulting Find window, query the person.

Employer Identification (US, CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Employer Identification

Employment Declaration (AU)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Declaration button.

Employment Equity Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. Position the cursor in the Organization Classifications Name field.

4. Select the Business Group from the List of Values.

5. Position the cursor in the Field with the entry Business Group.

6. Choose the Others button.

7. Select Employment Equity Information and click OK.

8. Double-click in the FlexField to display the window.

Employment History (UK)
1. Choose FastPath -> Employment History in the Navigator.

End Application
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Application.

Or:

1. Choose Fastpath -> End Application in the Navigator.

2. In the resulting Find window, query the person.
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End Employment
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Employment.

Or:

1. Choose Fastpath -> End Employment in the Navigator.

Enrollment Action (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Enrollment Action Types in the Navigator.

Enrollment Opportunities
1. Choose People -> Total Comp Participation

2. Choose the Enrollment Opportunities button.

Enrollment Override
1. Choose People -> Total Comp Enrollment -> Enrollment Override in the Navigator.

Enrollment Rules
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the Timing tab.

4. Choose the Scheduled tab or the Life Event tab.

5. Choose the Enrollment Rules button.

Enter Contingent Workers
1. Choose People -> Maintain Using Templates -> Enter Contingent Workers in the

Navigator.

Enter Employees
1. Choose People -> Maintain Using Templates -> Enter Employees in the Navigator.

Entry Values
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

A-30 Oracle Human Resources Management Systems FastFormula User Guide



3. Choose the Assignment button.

4. Choose the Entries button.

5. Select an entry and choose the Entry Values button.

Establishment EEO-1 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Reporting Establishment.

3. Choose the Others button and select Establishment EEO-1 Filing.

Establishment VETS-100 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Reporting Establishment.

3. Choose the Others button and select Establishment VETS-100 Filing.

Event Bookings
Do one of the following:

1. Choose People -> Events and Bookings in the Navigator.

Or:

1. Choose Fastpath -> Event in the Navigator.

2. In the resulting Find window, query the person.

Event Groups
1. Choose Total Compensation -> Basic -> Event Groups in the Navigator.

Extension of NTE (FD)
1. Choose Request for Personnel Action -> Extension of NTE

External/Manual Payments (Payroll)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select External Pay.

Or:

1. Choose Fastpath -> External/Manual Payments in the Navigator.

2. In the resulting Find window, query the person.
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Extra Details of Service
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Extra Details of Service.

Or:

1. Choose Fastpath -> Extra Details of Service.

2. In the resulting Find window, query the person.

Extra Element Information
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Extra Information button.

Extra Person Information (FD)
1. Choose People -> Enter and Maintain

2. Enter or query a person.

3. Choose the Others button and select Extra Information.

Extra Person Information Window (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Choose Extra Information.

5. Choose a Type.

6. Choose Details.

Extract Definition
1. Choose Mass Information Exchange -> System Extract -> Extract Definition in the

Navigator.

Extract Results
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.
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Extract Results Details
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.

2. Query an extract run result and choose the Details button.

Extract Results Errors
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.

2. Query an extract run result and choose the Errors and Warnings button.

Extract Results Header and Trailer
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.

2. Query an extract run result and choose the Header and Trailer button.

Families, Nature of Action (FD)
1. Choose Federal Maintenance Forms -> Families and NOA Families.

Federal Tax Information <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

5. Select the Federal Tax Information region (if not already selected).

Or:

1. Choose People -> Fastpath -> Tax Sign-up in the Navigator.

2. In the resulting Find window, query an employee.

3. Select the Federal Tax Information region.

Federal Tax Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Federal Tax Rules

Federal Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.
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2. Enter or query an employee or applicant.

3. Chose the Tax Information button.

File Layout Advanced Conditions (US, UK, CA)
1. Choose Benefits Extract -> Layout Definition in the Navigator.

2. Choose the File Layout tab and query or enter a file layout.

3. Select a record and choose the Advanced Conditions button.

File Layout Include Conditions
1. Choose Mass Information eXchange -> System Extract -> Layout Definition in the

Navigator.

2. Choose the File Layout tab and query or enter a file layout.

3. Select a record and choose the Include Conditions button.

Financials Options
1. Choose Customer and Supplier Maintenance -> Financials Options in the Navigator.

Flex Credits (Advanced Benefits)
1. Choose Total Compensation -> Rate/Coverage Definitions -> Flex Credits in the

Navigator.

Flex Program (Advanced Benefits)
1. Choose People -> Total Comp Enrollment -> Flex Program in the Navigator.

Form 941 Information (US)
1. Choose View -> Tax Information -> Form 941 Information in the Navigator.

Form Customization
1. Choose Security -> CustomForm in the Navigator.

Forms Configurator - see People Management Configurator

Formula
1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.

Formula Result Rules (Payroll):
1. Choose Total Compensation -> Basic -> Formula Results in the Navigator.
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Forward Notification To (FD)
1. Choose Workflow Inbox

2. Choose a notification and then choose the Reroute button.

Frequency Rules (Payroll)
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Frequency Rules button.

Funding Distribution
1. Choose Work Structures -> Budget -> Worksheet in the Navigator.

2. Choose the Periods button to open the Budget Details window.

3. Choose the Budget Sets tab.

4. Choose the Budget Set Distribution button.

GL Daily Rates
1. Choose Payroll -> GL Daily Rates in the Navigator.

GL Daily Rates (US, CA)
1. Choose Total Compensation -> Basic -> Global Values in the Navigator.

GL Map (Payroll)
1. Choose Payroll -> GL Flexfield Map in the Navigator.

Globals
1. Choose Total Compensation -> Basic -> Global Values in the Navigator.

Global Pay Scale
1. Choose Work Structures -> Grade -> Global Pay Scale in the Navigator.

Global Security Profile
1. Choose Security -> Global Security Profiles in the Navigator.

Goods and Services
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Goods

and Services in the Navigator.
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Grade Rate
1. Choose Work Structures -> Grade -> Grade Rate in the Navigator.

Grade Scale
1. Choose Work Structures -> Grade -> Grade Steps and Points in the Navigator.

Grade Step Placement
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Grade Step.

Or:

1. Choose Fastpath -> Grade Step in the Navigator.

2. In the resulting Find window, query the person.

Grades
1. Choose Work Structures -> Grade -> Description in the Navigator.

Grades (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Grades.

GREs and other information <Employee> (CA)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Select the GREs and other information region.

Hiring Applicants
1. Choose People -> Maintain Using Templates -> Hire Applicants in the Navigator.

Hungarian Absence Report (Hungary)
1. Choose Hungarian Web ADI Reports > Create Document in the Navigator.
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Imputed Income
1. Choose Total Compensation -> Rate/Coverage Definitions -> Imputed Income

in the Navigator.

Information Type Security (US, UK, CA)
1. Choose Security -> Information Types Security in the Navigator.

Information Type Security (FD)
1. Choose Security -> Information Types

Input Values
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Input Values button.

Insurance Provider (for a Company) (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Insurance Provider.

Insurance Provider (for an Establishment) (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Insurance Providers.

Insurance Provider Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Pension Provider.

3. Choose the Others button and select Insurance Provider Information.

Investment Options
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Savings Plan

in the Navigator.

2. Query a person.

3. Choose the Investment Options button.

Windows and their Navigation Paths A-37



Job
1. Choose Work Structures -> Job -> Description in the Navigator.

Jobs (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Jobs.

Job Evaluation
1. Choose Work Structures -> Job -> Description in the Navigator.

2. Enter or query a job.

3. Choose the Evaluation button.

Job Grade (CA)
1. Choose Work Structures -> Job -> Job Grade in the Navigator.

Job Groups
1. Choose Work Structures -> Job -> Job Groups in the Navigator.

Job Requirements
1. Choose Work Structures -> Job -> Description in the Navigator.

2. Enter or query a job.

3. Choose the Requirements button.

KR Mass Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of CWK and Employee

Assignments in the Navigator.

KR Mass Employee Assignment Update
1. Choose People -> Mass Updates for Person -> KR Mass Update of Employee

Assignments in the Navigator.

Layout Definition
1. Choose Benefits Extract -> Layout Definition in the Navigator.

Legal Employer Information (AU)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query an organization.

3. Select GRE/Legal Entity and choose the Others button.

4. Select Legal Employer.

5. Click in the blank field.

Letter (for letters)
1. Choose Work Structures -> Recruitment Letter Type in the Navigator.

Letter (for contracts)
1. Choose Work Structures -> Contract Letter Type in the Navigator.

Life Event
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plans tab or the Plan Types tab.

5. Choose the Life Event button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Life Event button.

Life Event Certifications
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the General tab.

4. Choose the Plan or Option tab.

5. Choose the Life Event Certifications button.

Life Event Reason Impact on Eligibility (Advanced Benefits)
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Options button.

4. Choose the Life Event Eligibility button.

Windows and their Navigation Paths A-39



Life Event Reasons
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

Limit Rules (Payroll) (US)
1. Choose View -> Wage Attachments -> Limit Rules in the Navigator.

Link Input Values
1. Choose Total Compensation -> Basic -> Link in the Navigator.

2. Enter or query an element.

3. Choose the Input Values button.

List Assignments
1. Choose View -> Lists -> Assignments in the Navigator.

List Budget Variance by Organization (AU)
1. Choose View -> Organization Budgets in the Navigator.

List Employees by Absence Type
1. Choose View -> Lists -> Employees by Absence Type in the Navigator.

List Employees by Element
1. Choose View -> Lists -> Employees by Element in the Navigator.

List Employees by Organization
1. Choose View -> Lists -> Employees by Organization in the Navigator.

List Employees by Position
1. Choose View -> Lists -> Employees by Position in the Navigator.

List Employees by Position Hierarchy
1. Choose View -> Lists -> Emps by Position Hierarchy in the Navigator.

List People by Assignment
1. Choose View -> Lists -> People by Assignment in the Navigator.
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List People by Special Information
1. Choose View -> Lists -> People by Special Information in the Navigator.

Local Tax Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Local Tax Rules.

Locality Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> Locality Pay

Location
1. Choose Work Structures -> Location in the Navigator.

Locations (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Locations.

Lookups
1. Choose Other Definitions -> Application Utilities Lookups in the Navigator.

Maintain Contingent Workers
1. Choose People -> Maintain Using Templates -> Maintain Contingent Workers

in the Navigator.

Maintain Employees
1. Choose People -> Maintain Using Templates -> Maintain Employees in the

Navigator.

Maintain On Line Activities (Advanced Benefits)
1. Choose Total Compensation -> General Definitions ->Authentication Activities

in the Navigator.

Maintain Options Eligibility
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

Windows and their Navigation Paths A-41



3. Choose the Options button.

4. Choose the Option Eligibility button.

Maintain Plan Eligibility
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Plan Eligibility button.

Maintain Plan Options
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Options button.

Maintain Plan Related Details
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Details button.

Maintain Pop Up Messages (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Message Configuration

in the Navigator.

Maintain Visa Window (US)
1. Choose People -> Maintain Using Templates ->Maintain Visa in the Navigator.

2. Choose an employee.

Manual Payments
1. Choose People -> Total Comp Contribution -> Manual Payments in the Navigator.

Map Career Path
1. Choose Work Structures -> Job -> Career Path in the Navigator.

Map Salary Survey (US, UK, CA)
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Complete the Position window and save your work.

3. Choose the Define Survey Map button.

Or:
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1. Choose Work Structures -> Job -> Description in the Navigator.

2. Complete the Job window and save your work.

3. Choose the Define Salary Map button.

Mass Applicant Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Applicant

Assignments in the Navigator.

Mass Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Assignments in the

Navigator.

Mass Awards (FD)
1. Choose Mass Actions ->Mass Awards

2. Choose Preview Mass Awards

Mass Employee Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Employee

Assignments in the Navigator.

Mass Move
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

Mass Move - Assignments
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window and save your work.

3. Choose the Positions button.

4. Complete the Find Positions window.

5. Choose the Find button.

6. Complete the Mass Move - Positions window.

7. Choose the Assignments button.

Mass Move - Messages
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window and save your work.

3. Choose the Positions button.

4. Complete the Find Positions window and choose the Find button.
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5. Complete the Mass Move - Positions window and choose the Assignments button.

6. Complete the Mass Move - Assignments window and close it.

7. From the Mass Move - Positions window, choose the Valid Grades button.

8. Complete the Valid Grades window and close it.

9. Close the Mass Move - Positions window.

10. From the Mass Move window, choose the Execute button.

11. If the Status field shows In Error or Complete with Warnings, a Message button
appears.

12. If the Message button appears, choose it to view messages in the Mass Move
- Messages window.

Note: Alternatively, you can view messages for saved (but not yet
successfully executed) mass moves as follows:

13. Choose Work Structures -> Position -> Mass Move in the Navigator.

14. Enter the name of the saved mass move in the Description field.

15. When the Mass Move window is populated with data and the Message button
appears, choose the Message button .

Mass Move - Positions
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window.

3. Save your work.

4. Choose the Positions button.

5. In the resulting Find Positions window, select or enter a Source Job and Source
Position.

6. Choose the Find button.

Mass Move - Valid Grades
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window and save your work.

3. Choose the Positions button.

4. Complete the Find Positions window.

5. Choose the Find button.

6. Complete the Mass Move - Positions window.

7. Choose the Valid Grades button.

Mass Position Update
1. Choose Work Structures -> Position -> Mass Position Update
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Mass Realignment (FD)
1. Choose Mass Actions ->Mass Realignment

2. Choose Preview Mass Realignment

Mass Salary (FD)
1. Choose Mass Actions ->Mass Salary

2. Choose Preview Mass Salary

Mass Transfer In (FD)
1. Choose Mass Actions ->Mass Transfer In i

2. Choose Preview Mass Transfer In

Mass Transfer Out (FD)
1. Choose Mass Actions ->Mass Transfer Out

2. Choose Preview Mass Transfer Out

Mass UK Applicant Ass Update
1. Choose People -> Mass Updates for Person -> Mass Update of Applicant

Assignments in the Navigator.

Mass UK Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Assignments in the

Navigator.

Mass UK Employee Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Employee

Assignments in the Navigator.

Mass Update of Applicants
1. Choose Recruitment -> Mass Update of Applicants in the Navigator.

Maternity (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Maternity button.
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Maternity Evidence (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a maternity absence.

5. Choose the Evidence button.

Maternity Pay (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a maternity absence.

5. Choose the SSP/SMP button.

MD/DDS Nurse Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> MDDDS Nurse Pay

Medical Assessments
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Medical Assessments.

Or:

1. Choose Fastpath -> Medical Assessments in the Navigator.

2. In the resulting Find window, query the person.

Messages
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Choose the Messages button.

Message Configuration (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Message Configuration

in the Navigator.

Mileage Element Template (UK)
1. Choose Total Compensation -> Basic -> Mileage Element Template in the Navigator.
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Miscellaneous Plan
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Miscellaneous

Plan in the Navigator.

MIX Batch Header
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

Monitor Batch Processes (Advanced Benefits)
1. Choose Processes and Reports -> Monitor Batch Processes in the Navigator.

Monthly Participant Premium
1. Choose People -> Total Comp Contribution -> Monthly Participant Premium in the

Navigator.

Monthly Plan or Option Premium
1. Choose -> People -> Total Comp Contribution -> Monthly Premium in the Navigator.

Multiple Worksite Reporting (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Multiple Worksite Reporting

NACHA Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select NACHA Rules

Name Change (FD)
1. Choose Request for Personnel Action -> Change Actions -> Name Change i

Nature of Action Legal Authorities (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> NOA Legal

Authorities.

Net Calculation Rules
1. Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

2. Enter or query an accrual plan name.
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3. Choose the Net Calculation Rules button.

New Hire Reporting (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a GRE.

3. Choose the Others button.

4. Select New Hire Reporting

New Zealand Information (NZ)
1. Choose People -> Enter and Maintain.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the New Zealand Information tab.

NOA Codes and Remarks (FD)
1. Choose Federal Maintenance Forms -> NOA Codes and Remarks

Non-Flex Program
1. Choose People -> Total Comp Enrollment -> Non-Flex Program in the Navigator.

Non Pay / Non Duty Status (FD)
1. Choose Request for Personnel Action -> Non Pay / Non Duty Status

Notifications (FD)
1. Choose Request for Personnel Action -> Workflow Inbox

Notifications Summary (FD)
Do one of the following:

1. Choose Workflow Inbox

NQF Assessment (South Africa)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select NQF Assessment.
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NQF Learnership Agreements (South Africa)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select NQF Learnership Agreements.

NQF Qualification Titles (South Africa)

NQF Training (South Africa)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select NQF Training.

Options
1. Choose Total Compensation -> Programs and Plans -> Options in the Navigator.

Organization
1. Choose Work Structures -> Organization -> Description in the Navigator.

Organization Hierarchy
1. Choose Work Structures -> Organization -> Hierarchy in the Navigator.

Organization Hierarchy Diagrammer
1. Choose Work Structures -> Organization -> Diagrammer in the Navigator.

Organization Hierarchies (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Organization Hierarchies.

Organization Manager Relationship
1. Choose Work Structures -> Organization -> Organization Manager in the Navigator.

Organizational Payment Method
1. Choose Payroll -> Payment Methods in the Navigator.

Windows and their Navigation Paths A-49



Organizations (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Organizations.

Other Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> Other Pay

Other Rates
1. Choose People -> Total Comp Enrollment -> Non-Flex Program in the Navigator.

2. Query a person.

3. Choose the Others button and select Other Rates.

Outcomes Achieved
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Competence Profile.

4. Select a unit standard competence and choose the Outcomes Achieved button.

Or:

1. Choose Fastpath -> Competencies in the Navigator.

2. Query a person.

3. Select a unit standard competence and choose the Outcomes Achieved button.

Outcomes and Assessment Criteria
1. Choose Career Management -> Competencies in the Navigator.

2. Enter or query a unit standard competence.

3. Choose the Outcomes button.

P45 (Payroll) (UK)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Tax Information.

Or:

1. Choose FastPath -> UK P45 Form in the Navigator.
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2. In the resulting Find window, query the person.

Parent Organization
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Parent Organization.

Part Time Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Part Time Rebate.

Participant
1. Choose Total Compensation -> General Definitions -> Eligibility Profiles ->

Participant in the Navigator.

Participation Eligibility Profiles
1. Choose Total Compensation -> General Definitions -> Eligibility Profiles ->

Participation Eligibility Profiles

Or:

1. Choose Work Structures -> Collective Agreements -> Define Eligibility Profiles
in the Navigator.

Participation Overrides (Advanced Benefits)
1. Choose People -> Total Comp Participation -> Participation Overrides in the

Navigator.

Pattern (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

Pattern Time Units (UK)
1. Choose SSP/SMP -> Pattern Time Units in the Navigator.

Pay Adjustment (FD)
1. Choose Request for Personnel Action -> Salary Change -> Pay Adjustment.

Pay Advice Report (Payroll) (UK)
Do one of the following:
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1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Statement of Earnings.

Or:

1. Choose FastPath -> Statement of Earnings in the Navigator.

2. In the resulting Find window, query the person.

Pay Plans (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Pay Plans.

Pay Scale
1. Choose Work Structures -> Grade -> Pay Scale in the Navigator.

Payment Schedule
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the

Navigator.

2. Query or enter a flex credit definition and choose the Processing tabbed region.

3. Choose the Payment Schedule button.

Payments
1. Choose People -> Total Comp Contribution -> Record Contribution or Distribution

2. Choose the View Payments window.

Payroll
1. Choose Payroll -> Description in the Navigator.

Payroll Balances (UK)
1. Choose Work Structures -> Organization -> Description in the Navigator

2. Enter or query a Business Group

3. Choose the Others button and select Payroll Balances

Payroll Elements (UK)
1. Choose Work Structures -> Organization -> Description in the Navigator

2. Enter or query a Business Group

3. Choose the Others button and select Payroll Elements
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Payroll Processes (Payroll)
1. Choose View -> Payroll Process Results in the Navigator.

Pension Provider (for a Company) (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Pension Provider.

Pension Provider (for an Establishment)(France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Pension Providers.

Pension Provider Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Pension Provider.

3. Choose the Others button and select Pension Provider Information.

Pension Schemes (Hungary)
1. Choose Total Compensation -> Basic in the Navigator.

2. Choose Pension Schemes.

People
1. Choose People -> Enter and Maintain in the Navigator.

People Folder
1. Choose View -> Lists -> People Folder in the Navigator.

People Management Configurator (formerly Forms Configurator)
1. Choose Security -> People Management Configurator in the Navigator.

Performance
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee, and choose the Assignment button.

3. Choose the Salary button.

4. Choose the Performance button.
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Or:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee, and choose the Assignment button.

3. Choose the Others button and select Performance.

Period Dates
1. Choose Payroll -> Description in the Navigator.

2. Enter or query a payroll.

3. Choose the Period Dates button.

Period-to-Date Limits
Do one of the following:

1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->
Period-to-Date Limits in the Navigator.

Or:

1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the
Navigator.

2. Query a compensation object.

3. Choose the Activity Rate button.

4. Choose the Period to Date Limit button.

Period Types
1. Choose Other Definitions -> Time Periods in the Navigator.

Person Benefits Assignment
1. Choose People -> Total Comp Participation -> Person Benefits Assignment

Person Benefits Balances
1. Choose People -> Total Comp Participation -> Person Benefits Balances in the

Navigator.

Person Changes
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Person Changes button.

4. Choose the Define Person Change button.
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Person Changes Cause Life Events
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Person Changes button.

Person Communications (Advanced Benefits)
1. Choose People -> Total Comp Enrollment -> Enrollment Process -> Person

Communications in the Navigator.

Person Enrollment Action Items (Advanced Benefits)
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Enrollment Process -> Person
Enrollment Action Items in the Navigator.

Or:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program
in the Navigator.

2. Query a person.

3. Choose the Action Items button.

Person Enrollment Certificates (Advanced Benefits) (CA)
1. Choose People -> Enrollment Process -> Person Enrollment Certificates in the

Navigator.

Person Enrollment Certifications (Advanced Benefits)
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Enrollment Process -> Person
Enrollment Certifications in the Navigator.

Or:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program
in the Navigator.

2. Query a person.

3. Choose the Certifications button.

Person Life Events

Person Life Events
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Person Life

Events
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Or (Advanced Benefits):

Choose People -> Total Comp Enrollment -> Enrollment Process -> Person Life
Events

Person Primary Care Provider
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Person Primary

Care Provider in the Navigator.

Person Summary (FD)
1. Choose Person Summary

Person Types
1. Choose Other Definitions -> Person Types in the Navigator.

Person Type Usage
1. Choose Fastpath -> Person Type Usage in the Navigator.

Personal Payment Method
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Pay Method button, or choose the Others button and select Pay Method.

Or:

1. Choose Fastpath -> Pay Method in the Navigator.

2. In the resulting Find window, query the person.

Phone Numbers
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Choose Phones.

Or:

1. Choose Fastpath -> Phones in the Navigator.

2. In the resulting Find window, query the person.
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Picture
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator

2. Enter or query a person.

3. Choose the Picture button.

Or:

1. Choose Fastpath -> Picture in the Navigator.

2. In the resulting Find window, query the person.

Plan and Plan Type
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

Plan Design Copy
1. Choose Total Compensation -> Programs and Plans -> Plan Design Copy in the

Navigator.

Plan Design Wizard
1. Choose Total Compensation - > Programs and Plans -> Plan Design Wizard

Plan Enrollment Requirements
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

Plan in Program Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plans tab.

5. Choose the Participation Eligibility button.

Plan Reimbursement
1. Choose Total Compensation -> General Definitions -> Programs and Plans -> Plan

Reimbursement in the Navigator.
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Plan Type Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plan Type tab.

5. Choose the Participation Eligibility button.

Plan Types
1. Choose Total Compensation -> Programs and Plans -> Plan Types in the Navigator.

Plans
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

Position
1. Choose Work Structures -> Position -> Description in the Navigator.

Position (FD)
1. Choose Work Structures -> Position -> Description

Position Abolish (FD)
1. Choose Request for Personnel Action -> Federal Position -> Abolish

Position Change (FD)
1. Choose Request for Personnel Action -> Federal Position Change

Position Copy
1. Choose Work Structures -> Position -> Position Copy in the Navigator.

Position Copy (FD)
1. Choose Work Structures -> Position -> Description

Position Description (FD)
1. Choose Federal Position Description in the Navigator.

Position Description Routing History (FD)
1. Choose Position Description -> Reference button
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Position Establish (FD)
1. Choose Request for Personnel Action -> Federal Position -> Establish

Position Evaluation
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Enter or query a position.

3. Choose the Evaluation button.

Position Hierarchy
1. Choose Work Structures -> Position -> Hierarchy in the Navigator.

Position Hierarchy
1. Choose Work Structures -> Position -> Diagrammer in the Navigator.

Position Occupancy Folder
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Query a position.

3. Choose the Occupancy button.

Position Reporting To
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Enter or query a position.

3. Choose the Reporting To button.

Position Requirements
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Enter or query a position.

3. Choose the Requirements button.

Position Review (FD)
1. Choose Request for Personnel Action -> Federal Position -> Review

Position Transaction
1. Choose Work Structures -> Position -> Position Transaction in the Navigator.
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Possible Certifications
1. Choose People -> Total Comp Participation

2. Choose the Enrollment Opportunities button.

3. Choose the Electable Choices button

4. Choose the Possible Certifications button

Postal/Zip
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors ->

Postal/Zip in the Navigator.

Previous Employment
1. Choose People -> Enter and Maintain in the navigator

2. Query a person.

3. Choose the Others button.

4. Select Previous Employment.

Previous Services Validation pages (France)
1. Choose People ->Services Validation in the Navigator

Primary Care Providers
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Person Primary Care Provider

Or:

1. Choose People -> Total Comp Enrollment -> Flex Program in the Navigator.

2. Query a person.

3. Choose the Care Providers button.

Prior Employment SSP (SSP1L) (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the SSP1L button.

Process Log
1. Choose Processes and Reports -> Process Log in the Navigator.
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Program/Plan Years
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Program/Plan Years in the Navigator.

Programs
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

Program Enrollment Requirements
1. Choose Total Compensation -> General Definitions -> Programs and Plans ->

Program Enrollment Requirements in the Navigator.

Program Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Participation Eligibility button.

Program Waive Certifications
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plan Types tab.

5. Choose the Waive button.

6. Choose the Waive Certification button.

Program Waive Reasons
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plan Types tab.

5. Choose the Waive button.

Promotion (FD)
1. Choose Request for Personnel Action -> Salary Change -> Promotion

Provincial Employment Standard (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.
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3. Position the cursor in the Organization Classifications Name field.

4. Select the Business Group from the List of Values.

5. Position the cursor in the field with the entry Business Group.

6. Choose the Others button.

7. Select Provincial Employment Standard and click OK.

8. Double-click in the FlexField to display the window.

Provincial Reporting Info. (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. Position the cursor in the Organization Classifications Name field.

4. Select GRE/Legal Entity from the List of Values.

5. Position the cursor in the field with the entry GRE/Legal Entity.

6. Choose the Others button.

7. Select Provincial Reporting Info and click OK.

8. Double-click in the FlexField to display the window.

Provincial Tax Information <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

5. Select the Provincial Tax Information region.

Or:

1. Choose People -> Fastpath -> Tax Sign-up in the Navigator.

2. In the resulting Find window, query an employee.

3. Select the Provincial Tax Information region.

Qualification Competencies
1. Choose Career Management -> Qualification Types in the Navigator.

2. Enter or select a Qualifications Framework qualification.

3. Choose the Competencies button.

Qualification Types
1. Choose Career Management -> Qualification Types in the Navigator.
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Qualifications
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Qualifications.

Or:

1. Choose Fastpath -> Qualifications in the Navigator.

Quality Increase (FD)
1. Choose Request for Personnel Action -> Salary Change -> Quality Increase

QuickPaint Inquiry
1. Choose Processes and Reports -> Run a QuickPaint Report in the Navigator.

2. Query a report that has been run.

3. Choose the View Report button.

QuickPay (Payroll)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select QuickPay.

Or:

1. Choose Fastpath -> QuickPay in the Navigator.

2. In the resulting Find window, query the person.

Rating Scales
1. Choose Career Management -> Rating Scales in the Navigator.

Realignment (FD)
1. Choose Request for Personnel Action -> Realignment

Reassignment (FD)
1. Choose Request for Personnel Action -> Reassignment

Record Continuing Benefits Payments
1. Choose People -> Total Comp Contribution -> Record Continuing Benefits Payments

in the Navigator.
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Record Layout Advanced Conditions (US, UK)
1. Choose Benefits Extract -> Layout Definition in the Navigator.

2. Choose the Record Layout tab and query or enter a record layout.

3. Select a Data Element and choose the Advanced Conditions button.

Record Layout Include Conditions
1. Choose Mass Information eXchange -> System Extract -> Layout Definition in the

Navigator.

2. Choose the Record Layout tab and query or enter a record layout.

3. Select a Data Element and choose the Include Conditions button.

Recruit / Fill (FD)
1. Choose Request for Personnel Action -> Recruit / Fill

Recruiting For
1. Choose Recruitment -> Recruitment Activity in the Navigator.

2. Enter or query a recruitment activity.

3. Choose the Recruiting For button.

Recruitment Activity
1. Choose Recruitment -> Recruitment Activity in the Navigator.

Reduction in Force Retention Register (FD)
1. Choose Reduction in Force (RIF).

Registered Employer Information (NZ)
1. Choose Work Structures -> Organization -> Hierarchy.

2. Enter or query an organization.

3. Select GRE/Legal Entity in the Organization Classification region.

4. Choose Others -> Registered Employer.

Regulations
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Regulations in the Navigator.
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Regulatory Bodies and Regulations
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Reporting

Groups in the Navigator.

2. Query or enter a reporting group.

3. Choose the Plan Regulatory Bodies and Regulations button.

Reimbursements Requests (Advanced Benefits)
1. Choose People -> Total Comp Distribution -> Reimbursements Requests in the

Navigator.

Related Person Changes
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Related Person Changes button.

4. Choose the Define Related Person Change button.

Related Person Changes Cause Life Events (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Related Person Changes button.

Remark Codes and Descriptions (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Remark

Codes and Descriptions.

Reporting Categories (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group.

3. Choose the Others button and select Reporting Categories.

Reporting Groups
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Reporting

Groups in the Navigator.

Reporting Statuses (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query a Business Group.

3. Choose the Others button and select Reporting Statuses.

Representative Body
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a representative body.

3. Choose the Others button and select Representative Body.

Representative Body (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a representative body.

3. Choose the Others button and select Representative Body.

Request for Personnel Action (FD)
1. Choose Request for Personnel Action

Request Letter
1. Choose Recruitment -> Request Recruitment Letter in the Navigator.

Request Set
1. Choose Security -> Report Sets in the Navigator.

Requisition and Vacancy
1. Choose Recruitment -> Requisition and Vacancy in the Navigator.

Restricted Form Process Methods (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Short Form

/ Restricted Data.

RetroPay Set (Payroll)
1. Choose Payroll -> RetroPay Set in the Navigator.

Return to Duty (FD)
1. Choose Request for Personnel Action -> Return to Duty

Reverse Payroll Run (Payroll)
Do one of the following:
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1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Reverse Run.

Or:

1. Choose Fastpath -> Reverse Payroll Run in the Navigator.

2. In the resulting Find window, query the person.

RIF Exception (FD)
1. Choose Request for Personnel Action -> RIF Exception.

Robien Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Robien Rebate.

Roles
1. Choose Transaction Maintenance Forms -> Roles in the Navigator.

Routing
1. Choose Work Structures -> Position -> Position Transaction in the Navigator.

2. Choose Save from the File menu.

Or:

1. Choose Work Structures -> Budget -> Budget Worksheet in the Navigator.

2. Choose Save from the File menu.

3. Choose Save from the File menu.

Routing Group and Groupbox Details (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Routing

Groups and Groupboxes.

Routing Group and Routing List Details (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Routing Lists.

Routing History (FD)
Do one of the following:

1. Choose Request for Personnel Action -> Reference button.
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Or

Open the Workflow inbox and select a notification.

2. Choose Routing History button.

Routing Lists
1. Choose Transaction Maintenance Forms ->Routing Lists in the Navigator.

Rows
1. Choose Other Definitions -> Table Structure in the Navigator.

2. Enter or query a table.

3. Choose the Rows button.

Run QuickPaint Report
1. Choose Processes and Reports -> Run a QuickPaint Report in the Navigator.

Salary Administration
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Salary button.

Or:

1. Choose Fastpath -> Salary in the Navigator.

2. In the resulting Find window, query the person.

Salary Basis
1. Choose Total Compensation -> Basic -> Salary Basis in the Navigator.

Salary History
Do one of the following:

1. Choose View -> Histories -> Salary in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the Salary History button.

Or:

1. Choose Fastpath -> Salary History in the Navigator.

2. In the resulting Find window, query the person.
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Salary Management Folder
1. Choose People -> Salary Management in the Navigator.

Salary Surveys
1. Choose Total Compensation -> Basic -> Salary Survey in the Navigator.

Salary Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

Savings Plan
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Savings Plan

in the Navigator.

Savings Plan (UK)
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Savings Plan

in the Navigator.

2. Choose the Record Layout tab and query or enter a record layout.

3. Select a Data Element and choose the Include Conditions button.

Scale Rate
1. Choose Work Structures -> Grade -> Point Values in the Navigator.

Schedules (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

2. Enter or query a pattern.

3. Choose the Calendars button.

4. Choose the Schedules button.

Schools and Colleges
1. Choose Career Management -> Schools and Colleges in the Navigator.

Schools and Colleges Attended
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Schools/Colleges.
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Secondary Statuses
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant or employee.

3. Do one of the following:

For an applicant:

• Choose the Others button and select Application.

• Choose the Secondary Status button.

For an employee:

• Choose the Assignment button.

• Choose the Others button and select Secondary Status.

Or:

1. Choose Fastpath -> Secondary Status in the Navigator.

2. In the resulting Find window, query the person.

Security Groups (UK)
1. Choose Security -> Security Groups in the Navigator.

Security Profile
1. Choose Security -> Profile in the Navigator.

Seniority pages (France)
1. Choose Other Definitions -> Seniority in the Navigator

Separation (FD)
1. Choose Request for Personnel Action -> Separation

Service Areas
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors ->

Service Areas in the Navigator.

Set of Books
1. Choose Customer and Supplier Maintenance -> Set of Books in the Navigator.

Sickness Control Rules (UK)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group
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3. Choose the Others button and select Sickness Control Rules.

Sickness Evidence (UK)
1. Choose SSP/SMP -> Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a sickness absence.

5. Choose the Evidence button.

Sickness Pay (UK)
1. Choose SSP/SMP -> Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a sickness absence.

5. Choose the SSP/SMP button.

Social Insurance Information (Germany)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Social Insurance Information button.

Social Security Information (Spain)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Social Security Information button.

Or:

1. Choose Fastpath -> Social Security Information in the Navigator.

2. In the resulting Find window, query the person.

Social Security Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Social Security Rebate.
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Sort
1. Choose Mass Information eXchange -> System Extract -> Layout Definition in the

Navigator.

2. Choose the File Layout tab and select a Record Name.

3. Choose the Sort button.

Special Information
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Special Info button.

Or:

1. Choose Fastpath -> Special Information in the Navigator.

2. In the resulting Find window, query the person.

Special Information Types
1. Choose Other Definitions -> Special Information Types in the Navigator.

Special Rates
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program

in the Navigator.

2. Query a person.

3. Choose the Special Rates button.

SQWL Employer Rules (1) (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select SQWL Employer Rules (1)

SQWL Employer Rules (2) (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select SQWL Employer Rules (2)

SQWL Generic Transmitter Rules (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).
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3. Choose the Others button and select SQWL Generic Transmitter Rules

SQWL State-Specific Transmitter Rules (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select SQWL State Transmitter Rules

Standard Distributions/Contributions (US)
1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->

Standard Distributions/Contributions in the Navigator.

Standard Holiday Absences <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Select Standard Holiday Absences.

Or:

1. Choose People -> Fastpath -> Statutory Holidays in the Navigator.

2. In the resulting Find window, query an employee.

Standard Rates
1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->

Standard Rates in the Navigator.

Standard Holiday Absences (FR)
1. Choose FastPath -> Standard Holiday Absences

State Tax Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select State Tax Rules.

State Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Chose the Tax Information button.
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4. Choose the Tax information button from the Federal Tax Rules <Employee> window.

Statement of Earnings (Payroll) (US)
Do one of the following:

1. Choose View -> Assignment Process Results

2. Choose the SOE Report button.

Or:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Statement of Earnings.

Or:

1. Choose Fastpath -> US Statement of Earnings in the Navigator.

2. In the resulting Find window, query the person.

Statement of Earnings (AU)
1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> Statement of Earnings.

Or:

1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> QuickPay.

4. Choose View Results -> Statement of Earnings.

Or:

1. Choose FastPath -> Statement of Earnings.

2. Enter employee details.

Statement of Earnings (New Zealand) (NZ)
1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> Statement of Earnings.

Or:

1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> QuickPay.
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4. Choose View Results -> Statement of Earnings.

Or:

1. Choose FastPath -> Statement of Earnings.

2. Enter employee details.

Statutory Holiday Absences
1. Choose FastPath -> Statutory Holiday Absences in the Navigator

Statutory Situations
1. Choose Work Structures -> Statutory Situations in the Navigator.

Step Adjustment (FD)
1. Choose Request for Personnel Action -> Salary Change -> Step Adjustment

Step Increase with Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> Step Increase with Pay

Submit a New Request
1. Choose Processes and Reports -> Submit Processes and Reports in the Navigator.

2. Select Single Request or a Request Set.

Superannuation Fund Information (AU)
1. Choose Work Structures -> Organization -> Description.

2. Enter or query an organization.

3. Select Payee Organization and choose the Others button.

4. Click in the blank field.

Supplementary Roles
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select Supplementary Roles.

Supplier
1. Choose Customer and Supplier Maintenance -> Supplier in the Navigator.
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System Options
1. Choose Customer and Supplier Maintenance -> System Options in the Navigator.

Table Event Updates (UK)
1. Choose Other Definitions -> Table Event Updates in the Navigator.

Table Structure
1. Choose Other Definitions -> Table Structure in the Navigator.

Table Values
1. Choose Other Definitions -> Table Values in the Navigator.

Taxation Information (New Zealand) (NZ)
1. Choose People -> Enter and Maintain.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Entries button.

5. Select PAYE Information in the Element Name column.

6. Click on the Entry Values button.

Tax Information (Germany)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Tax Information button.

Tax Information (Ireland)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Tax Information button.

Tax Information (Spain)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Tax Information button.

Or:
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1. Choose Fastpath -> Tax Information in the Navigator.

2. In the resulting Find window, query the person.

Terminate
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Employment.

Terminate Applicant
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Application.

Or:

1. Choose Fastpath -> End Application in the Navigator.

2. In the resulting Find window, query the person.

Termination of Grade Retention (FD)
1. Choose Request for Personnel Action -> Salary Change -> Termination of Grade

Retention

Termination of Interim WGI (FD)
1. Choose Request for Personnel Action -> Salary Change -> Termination of Interim

WGI

Termination Payments (AU)
1. Choose FastPath -> Termination Payments.

Transaction Categories
1. Choose Transaction Maintenance Forms -> Transaction Categories in the Navigator.

Transaction Category Wizard
1. Choose Maintenance Forms -> Transaction Category Wizard.

Transaction Status
1. Choose Security -> Transaction Status in the Navigator
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Transaction Templates
1. Choose Transaction Maintenance Forms ->Transaction Templates in the Navigator.

Transport Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Transport Tax Info.

Unions Processing
1. Choose Total Compensation -> Basic -> Union Element Creation Template.

Update Payroll Run (Payroll)
1. Choose Payroll -> Update Payroll Run in the Navigator.

URSSAF Center Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a URSSAF Center.

3. Choose the Others button and select URSSAF Center Information.

URSSAF Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select URSSAF.

User Types and Statuses
1. Choose Other Definitions ->User Types and Statuses

Valid Grades (for jobs)
1. Choose Work Structures in the Navigator.

2. Choose either Job -> Description or Position -> Description.

3. Enter or query a job or position.

4. Choose the Valid Grades button.

Valid Payment Methods
1. Choose Payroll -> Description in the Navigator.

2. Enter or query a payroll.
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3. Choose the Valid Payment Methods button.

Variable Rate Profiles
1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->

Variable Rate Profiles in the Navigator.

VETS-100 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select VETS-100 Filing.

Vehicle Data Entry (UK)
1. Choose Total Compensation -> Basic -> Vehicle Data Entry in the Navigator.

View Absence History
1. Choose View -> Histories -> Absence in the Navigator.

View Earnings and Deductions Balances (US, CA)
Do one of the following:

1. Choose View -> Employee Balances in the Navigator.

2. Select an employee assignment and choose the Balances button.

Or:

1. Choose Fastpath -> Employee Balances in the Navigator.

2. In the resulting Find window, query the person.

View Element Entry History for Employee
1. Choose View -> Histories -> Entries in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the Entry History button.

View Employee Dental, Medical and Vision Benefits (US)
1. Choose View -> Employee Benefits in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the View Benefits button.

View Employee Grade Comparatio
1. Choose View -> Grade Comparatio in the Navigator.
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View Enrollment Results
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment Enrollment -> View

Enrollment Results in the Navigator.

View Participation Information (Advanced Benefits)
1. Choose People -> Total Comp Participation -> View Participation Information

in the Navigator.

View Program Structure
1. Choose Total Compensation -> Programs and Plans -> View Program Structure

in the Navigator.

View Run Messages (Payroll)
1. Choose View -> System Messages in the Navigator.

View Tax Balances (US, CA)
Do one of the following:

1. Choose View -> Tax Information -> Tax Balances in the Navigator.

2. Select an employee assignment and choose the Balances button.

Or:

1. Choose Fastpath -> Tax Balances in the Navigator.

2. In the resulting Find window, query the person.

View Vacancies
1. Choose View -> Vacancies in the Navigator.

Visa Data Template
1. Choose People -> Maintain Using Templates -> Maintain Visa Information

W2 Reporting Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select W2 Reporting Rules.

W941 (Payroll) (US)
1. Choose View -> Tax Information-> Form 941 Information in the Navigator
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Wage Attachment Earnings Rules (US)
1. Choose Total Compensation -> Wage Attachment -> Earnings Rules in the Navigator.

Wage Attachment Exemption Rules (US)
1. Choose Total Compensation -> Wage Attachment -> Exemption Rules in the

Navigator.

Wage Attachment Limit Rules (US)
1. Choose Total Compensation -> Wage Attachment -> Limit Rules in the Navigator.

Waive Participation (Advanced Benefits)
1. Choose People -> Total Comp Participation -> Waive Participation in the Navigator.

Waiving
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Waiving button.

WC Codes and Rates (US)
1. Choose Work Structures -> Job -> Workers Compensation Rates in the Navigator

Welfare Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Welfare Tax Info.

What-if Eligibility (Advanced Benefits)
1. Choose People -> Total Comp Participation -> What-if Eligibility in the Navigator.

Work Accident Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Work Accident Info.

Work Choices (Job and Position)
1. Choose Work Structures -> Job or Position -> Description in the Navigator.

2. Enter or query a job or position.
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3. Choose the Work Choices button.

Work Choices (Person)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Work Choices.

Work Day Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Work Day Information.

Work Incident
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Work Incidents.

Or:

1. Choose Fastpath -> Work Incidents in the Navigator.

2. In the resulting Find window, query the person.

Work Schedule (US, CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Work Schedule.

Work Site Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Reporting Establishment.

3. Choose the Others button and select Work Site Filing.

Worker’s Compensation (US)
1. Choose Work Structures -> Job -> Workers Compensation Codes in the Navigator

Worksheet
1. Choose Work Structures ->Budget ->Worksheet in the Navigator.

A-82 Oracle Human Resources Management Systems FastFormula User Guide



2. Define the properties of the worksheet.

3. Choose the Create Worksheet button.

Worksheet Characteristics
1. Choose Work Structures ->Budget ->Worksheet in the Navigator.

ZA ACB Installation Information (South Africa)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. In Organization Classification, select Business Group.

4. Choose the Others button and select ZA ACB Installation Information.

ZA Tax File Creator Information (South Africa)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. In Organization Classification, select Business Group.

4. Choose the Others button and select ZA Tax File Creator Info.

ZA Tax Information (South Africa)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. In Organization Classification, select GRE/Legal Entity.

4. Choose the Others button and select ZA Tax Information.
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B
Reports and Processes in Oracle HRMS

This section shows the default reports and processes in Oracle HRMS as they are
supplied. The responsibility that you use determines which reports you can use and
how you access them.

The reports are divided into functional areas, as follows:

• Organization Structures, page B-2

• Jobs and Positions, page B-2

• People Budgets and Costing, page B-4

• Employment Agreements and Legal Compliance, page B-6

• Recruiting and Hiring, page B-10

• People Management, page B-21

• Competencies, Qualifications and Development, page B-40

• Learning Management, page B-42

• General Compensation Structures, page B-47

• Salary and Grade Related Pay and Progression, page B-47

• Compensation and Awards Management, page B-54

• Leave and Absence Management, page B-55

• Health and Welfare Management, page B-57

• Other Payroll Earnings and Deductions, page B-58

• Payrolls, page B-58

• Payroll Payment and Distributions, page B-59

• Payroll Statutory Deductions and Reporting, page B-61

• Payroll Processing and Analysis, page B-67

• Payroll Event Rules, page B-72

• Deploy Self Service Capability, page B-72

• Workforce Intelligence, page B-72

This is followed by the list of processes, page B-72.

Reports and Processes in Oracle HRMS B-1



Reports

Organization Structures

Location Occupancy Report (FD)

Lists all employees that currently or have at one time occupied a Location from the date
you specify to the date the report is run

Organization Hierarchy Report

The organizations and optionally their managers below a selected position in a particular
hierarchy.

Organization Workforce Report (HRMSi)

This report investigates the performance of your organizations as measured by
the increase and decrease in workforce over a selected time period. Click on the
organization name in the table to investigate the workforce changes for a particular
organization, using the Workforce Summary Analysis report.

Jobs and Positions

Employee Job and Position Detail – Employee Work Choices by Job

This worksheet enables you to analyze deployment factors for jobs, people in specific
jobs, and job applicants.

Employee Job and Position Detail – Employee Work Choices by Position

This worksheet enables you to analyze deployment factors for positions, people in
specific positions, and position applicants.

Employee Job and Position Detail – Employee by Job and Position

This worksheet enables you to analyze assignment details for employees within an
organization by job and position.

Job and Position Special Information Detail – Job and Position Special Information

This worksheet enables you to analyze special information types associated with jobs
and positions.

Job and Position Skills Matching Report

Lists of employees, applicants or both that meet some or all skill requirements of a job
or position.

Mass Realignment Deselection (FD)

Lists employees deselected for realignment

Mass Realignment PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a realignment.
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Mass Realignment PA Listing for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
realignment.

Mass Realignment Preview (FD)

Lists employees selected for a realignment

Mass Transfer In Deselection (FD)

Lists employees deselected for a Transfer In action

Mass Transfer In PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a Transfer In
action

Mass Transfer In PA List for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
Transfer In action

Mass Transfer In Preview (FD)

Lists employees selected for a Transfer In action

Mass Transfer Out Deselection (FD)

Lists employees deselected for a Transfer Out action

Mass Transfer Out PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a Transfer Out
action

Mass Transfer Out PA List for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
Transfer Out action

Mass Transfer Out Preview (FD)

Lists employees selected for a Transfer Out action

Organization Separation Report (HRMSi)

This report investigates the performance of your best and worst organizations based
on the workforce separation. This can be an absolute figure or a percentage of the
workforce for the organization. If you click on the organization name in the table you
can investigate the workforce changes for an organization.

Position Description (FD)

Lists the details of an approved position classification
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Position Hierarchy Report

The positions and optionally their holders below a selected position in a particular
hierarchy.

Pre Hire Report (Payroll) (France)

This report has to be delivered to an establishment’s local URSSAF center when a person
is about to become a new employee in that establishment.

Reduction in Force Retention Register (FD)

Lists selected employees

Re-integration Actions Report (Netherlands)

Lists all re-integration actions for employees.

People Budgets and Costing

Budget Period Position Detail Report

Lists the status of all Positions that are part of a specific Budget.

Employee Budget (Non Positional Control) Status – by Grade (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different grades in your enterprise.

Employee Budget (Non Positional Control) Status – by Job (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different jobs for your enterprise.

Employee Budget (Non Positional Control) Status – by Organization (HRMSi)

This report investigates the difference between budgeted and actual workforce for
your enterprise.

Employee Budget (Non Positional Control) Status – by Position (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different positions for your enterprise.

Employee Budget Trend – by Grade (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different grades in your enterprise.

Employee Budget Trend – by Job (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different jobs for your enterprise.

Employee Budget Trend – by Organization (HRMSi)

This report investigates the difference between budgeted and actual workforce for
your enterprise.
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Employee Budget Trend – by Position (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different positions for your enterprise.

Entity Element Summary

Use this report if you administer position control budgets. The report lists the budget
status for a pay element and entity for a specified time interval.

Headcount Budget Trend (HRMSi, DBI)

This report shows changes in actual and budgeted employee headcount over time for
the selected top line manager.

Organization Budget (Non-Position Control) Report (HRMSi)

This report investigates the performance of your best and worst
organizations. Performance can be measured by a variety of indicators, but for
this report, performance is judged by the variance between the budgeted and
actual workforce in each organization. Top organizations are those with the largest
variance. Bottom organizations are those with the least variance.

Note: Non-Position Control reports are based on the budget scheme in
use prior to 11i.PER.G mini-pack.

Organization Budget (Position Control) Report (HRMSi)

This report investigates the performance of your best and worst
organizations. Performance can be measured by a variety of indicators, but for
this report, performance is judged by the variance between the budgeted and
actual workforce in each organization. Top organizations are those with the largest
variance. Bottom organizations are those with the least variance.

Note: Position Control reports are based on the budget scheme in use
since the 11i.PER.G mini-pack.

Organizational Position Summary Report

Lists the budget status for all positions within a Position Control Organization.

Position Element Detail Report

Lists the budget status for all budgeted elements for a specific Position and Organization.

Position Element Summary Report

Lists the budget status for an element for all positions in the Business Group.

Position Summary Report

Lists the budget status of all Positions in a specific Organization.

Report Under Budgeted Entities

Run this report if you administer position control budgets. The report lists the positions
that are under budgeted for the selected organization and all subordinate organizations
in the organization hierarchy.

Reports and Processes in Oracle HRMS B-5



Report Under Budgeted Positions (Salary)

HRMS still supports this report, run in previous versions for administering position
control budgets. The report lists the positions that are under budgeted for the
organization you select, and all subordinate organizations in the organization
hierarchy. Oracle recommends you use Report Under Budgeted Entities, which adds the
ability to report on organizations, jobs, and grades, as well as positions.

Social Security Affiliation Archiver (MX)

Mandatory statutory Social Security report that compiles a list of all employee status
changes for a GRE during a reporting period.

Social Security Affiliation Reports (MX)

Arranges the data generated by the Social Security Affiliation Archiver report into a
format suitable for electronic submission to the Mexican Social Security agencies.

Staffing Budget Details Report

Compares actual staffing level with budgeted levels over a specified period.

Workforce Budget (Non-Position Control) Report (HRMSi)

This report compares the amount of workforce you have budgeted for against the
amount of workforce that actually exists. The report enables you to review all the
organizations within a budget. You can select the time period you want to analyze.

Workforce Budget (Position Control) Report (HRMSi)

This report compares the amount of workforce you have budgeted for against the
amount of workforce that actually exists. The report enables you to review all the
organizations within a budget. You can select the time period you want to analyze.

Employment Agreements and Legal Compliance

AA/EEO Breakdown Report (FD)

Government required ethnicity and gender breakdown report by Occupational Category
or Pay Plan

AAP Reports (US)

Provides Job group analysis and workflow analysis reports.

ADA Reports (US)

Shows how your enterprise is responding to the requests of employees with disabilities.

Attestation ASSEDIC Report (Payroll) (FR)

A mandatory report given to an employee on leaving the company. It details specific
information about their employment.
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Bilan Social Report (Payroll) (France)

A statutory report that lists a large number of HR and Payroll related indicators in
order to provide a summary of many aspects affecting a company or establishment’s
human resources in a year.

Compliance (Person, United States Specific) Detail – Detailed Special Information (US)

This Discoverer worksheet enables you to view special employee information for
employees within your organization.

Compliance (Person, United States Specific) Detail – Disabilities (US)

This Discoverer worksheet enables you to view special information concerning
employees with disabilities within your organization.

Compliance (Person, United States Specific) Detail – Disability Accommodations (US)

This Discoverer worksheet enables you to view details about accommodations made
for employees with disabilities across your organization.

Compliance (Person, United States Specific) Detail – OSHA Incidents (US)

This Discoverer worksheet enables you to view details associated with recorded OSHA
incidents within your organization.

CPDF Dynamics Report (FD)

Record of the personnel data changes that occurred for the employee during a reporting
period

CPDF Dynamics Report Transmittal Form (FD)

Transmittal form that accompanies the CPDF Dynamics Report

CPDF OCT Report Transmittal Form (FD)

Transmittal form that accompanies the Organization Component Tracking Report

CPDF Organization Component Tracking Report (FD)

Record of the organizational codes, titles, and hierarchical relationships for organizations
within an agency as of the last day of the quarterly reporting period

CPDF Status Report (FD)

Record of each employee’s personnel data as of the ending date of a fiscal quarter

CPDF Status Report Transmittal Form (FD)

Transmittal form that accompanies the CPDF Status Report

EEO-1 Reports (US)

The Equal Employment Opportunity reports include the EEO Individual Establishment
Report, the EEO Headquarters Report, the EEO Establishment Employment Listing, the
EEO Consolidated Report, and the EEO-1 Exception Report.
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EEO4 Reports (US)

Run this report for state and local governments.

EEO5 Reports (US)

Run this report for the school system or district.

Electronic EEO-1 Report (US)

Generates Equal Employment Opportunity (EEO) reports for your establishment
hierarchy formatted for submission on magnetic media.

Electronic EVS Report (US)

Generates an Employee Verification Service (EVS) report formatted for submission to
the SSA office on diskette. The report is a list of employees showing social security
number, full name, gender, and date of birth. The SSA compares the report with its own
records and reports mismatches to the submitter.

Electronic VETS-100 Report (US)

Shows number of special disabled and Vietnam era veterans you employ in each of nine
job categories. Also, show total number of new hires in each job category and number of
new hires in each category who qualify as Vietnam era veterans.

Employee Equal Opportunity by Job (Multiple Hierarchies, United States Specific) Comparison – by
Establishment Hierarchy (HRMSi)

The Establishment Hierarchy worksheet enables you to report on the number of
employee primary assignments (male, female, total) for your reporting establishments
by ethnic origin, location, and job name.

Employee Equal Opportunity by Job (Multiple Hierarchies, United States Specific) Comparison – by
Organization Hierarchy (HRMSi)

The Organization Hierarchy worksheet enables you to report on the number of employee
primary assignments (male, female, total) for your reporting establishments by ethnic
origin, organization and job name.

Employee Equal Opportunity Exceptions (United States Specific) Detail – Employees Outside
Establishment Hierarchy (US)

The Employees Outside an Establishment Hierarchy worksheet enables you to analyze
which employees are at a location that is not in a defined Reporting Establishment
Hierarchy, on a given effective date.

Employee Equal Opportunity Exceptions (United States Specific) Detail – Employees with Missing
Equal Opportunity Data (US)

This Discoverer worksheet enables your organization to discover which employee
primary assignments have missing Ethnic Origin information on a given effective
date. For example, the report will show if an employee is missing data for employment
category or ethnic origin.
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Employee Equal Opportunity Exceptions (United States Specific) Detail – Employees Without a Location
(US)

The Employees Without a Location Worksheet enables you to analyze which employee
primary assignments are not assigned a location on a given effective date.

Employee Equal Opportunity for New Hires (Multiple Hierarchies, United States Specific) Detail – by
Establishment Hierarchy (US)

This Discoverer worksheet enables you to list employee new hires within a given
period. The workbook output includes the following employee primary assignment
details: Job Name, Employee Number, Ethnic Origin, Hire Date, Age at Hire, Date
Hired, Annual Salary, and Current Annual Salary. The list of employees is for a given
establishment hierarchy.

Employee Equal Opportunity for New Hires (Multiple Hierarchies, United States Specific) Detail – by
Organization Hierarchy (US)

This Discoverer worksheet enables you to list employee new hires within a given
period. The workbook output includes the following employee primary assignment
details: Job Name, Employee Number, Ethnic Origin, Hire Date, Age at Hire Date, Hired
Annual Salary, and Current Annual Salary. The list of employees is for a given
organization hierarchy.

Employee Equal Opportunity for Separations (Multiple Hierarchies, United States Specific) Detail – by
Establishment Hierarchy (US)

The Establishment Hierarchy workbook enables you to report on employee separations
for a given period. The workbook output includes the following employee primary
assignment details: Job Name, Employee Number, Gender, Hire Date, Actual Separation
Date, and Separation Reason. The worksheet shows a list of employees for a given
establishment hierarchy.

Employee Equal Opportunity for Separations (Multiple Hierarchies, United States Specific) Detail –
by Organization (US)

This workbook enables you to report on employee separations within a given period. The
workbook output includes the following employee primary assignment details: Job
Name, Employee Number, Gender, Hire Date, Actual Separation Date, and Separation
Reason. The worksheet shows a list of employees for a given Organization Hierarchy.

Employee Equal Opportunity with Salary (Multiple Hierarchies, United States Specific) Detail – by
Establishment Hierarchy (US)

This Discoverer worksheet enables your organization to list employee primary
assignment details including, Job Name, Employee Number, Gender, Ethnic Origin, Hire
date and Salary. The list of employees is for a given Establishment Hierarchy.

Employee Equal Opportunity with Salary (Multiple Hierarchies, United States Specific) Detail – by
Organization Hierarchy (US)

This Discoverer worksheet enables your organization to list employee primary
assignment details including, Job Name, Employee Number, Gender, Ethnic Origin, Hire
date and Salary. The list of employees is for a given Organization Hierarchy.
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EO Survey Report (US)

Generates an Equal Opportunity (EO) Survey report for the specified reporting period
and establishment hierarchy. The report shows, for full-time positions, numbers of
applicants, hires, promotions, terminations, and employees. The report also shows
annual monetary compensation and tenure data for full-time employees at the end
of the reporting period.

French D2 Report (Declaration Annuelle Obligatoire D’emploi des Travailleurs Handicapes, de Mutiles de
Guerre et Assimiles) (Payroll) (France)

A mandatory report that all establishments with more than 20 employee’s must submit
each year. It contains details about the number of people employed by the establishment
who are disabled.

IPEDS Reports (Payroll) (US)

The Integrated Post-secondary Education Data System (IPEDS) reports are submittted to
the National Center for Educational Statistics (NCES). The type of institution determines
which reports you must run.

Mouvements de Main d’Oeuvre Report (Payroll) (France)

A mandatory report that must be produced by each establishment every month. It lists
the people that have joined or left the establishment during that time.

OSHA Reports (US)

Report on work related injuries or illness.

Saudi Disabled Employee Report (SA)

The Saudi Disabled Employee Report creates a list of all the disabled employees in
your organization.

SF-113A Federal Civilian Employment Report (FD)

Summary of federal civilian employment, payroll, and turnover

VETS-100 Reports (US)

Shows number of special disabled and Vietnam era veterans you employ in each of nine
job categories. Also, show total number of new hires in each job category and number of
new hires in each category who qualify as Vietnam era veterans.

Work Incidents Report (Germany)

The Work Incidents Report enables you to print out a formatted copy of the information
entered in the Work Incidents window.

Recruiting and Hiring

Applicant Detail – Address (iRecruitment)

The Address Worksheet enables you to report on the addresses of your job applicants.
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Applicant Detail – by Grade (iRecruitment)

The By Grade Worksheet enables you to report on the applicants who have applied to a
specific grade. Grade Name is a page item on this worksheet so you can group your
results by the grades for which your applicants have applied.

Applicant Detail – by Job (iRecruitment)

The By Job Worksheet enables you to report on the applicants that have applied for a
specific job. Job Name is a page item on this worksheet so you can group your results by
the jobs for which your applicants have applied.

Applicant Detail – by Location (iRecruitment)

The By Location Worksheet enables you to report on the applicants who have applied to
a specific location. Location Name is a page item on this worksheet so you can group
your results by the locations to which applicants have applied.

Applicant Detail – by Organization (iRecruitment)

The By Organization Worksheet enables you to report on the applicants who have
applied to a specific organization. Organization Name is a page item on this worksheet
so you can group your results by organization.

Applicant Detail – by Position (iRecruitment)

The By Position Worksheet enables you to report on the applicants who have applied for
a specific position. Position Name is a page item on this worksheet so you can group
your results by the positions for which your applicants have applied.

Applicant Detail – by Source Type (iRecruitment)

The By Source Type Worksheet enables you to report where applicants have indicated
they saw the advertisement for your job. Source Type is a page item on this worksheet so
you can group your results by the source type the applicant indicated.

Applicant Detail – by Vacancy (iRecruitment)

The By Vacancy worksheet enables you to report the applicants who have applied for a
particular vacancy as of the date you select as your effective date. Vacancy Name is a
page item on this worksheet so you can group your results by the vacancy for which the
applicant has applied.

Applicant Detail – Competence (iRecruitment)

The Competence Worksheet enables you to report on the competencies your applicants
have indicated they possess. Competencies are entered by your applicants as ‘skills’
as part of their account.

Applicant Detail – Detail (iRecruitment)

The Detail worksheet enables you to report on the details of your applicants based
on the parameters you set for the report.

Applicant Detail – Phone (iRecruitment)

The Phone Worksheet enables you to report on the phone numbers of your job applicants.
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Applicant Detail – Qualification (iRecruitment)

The Qualification Worksheet enables you to report on the qualifications your applicants
have.

Applicant Detail – School College Attendance (iRecruitment)

The School College Attendance Worksheet enables you to report on the schools and
colleges your job applicants have attended.

Applicant Efficiency (Hires – Manager Hierarchy) PMV report (iRecruitment)

This PMV report measures the average amount of time it takes to fill a vacancy, and
also the average time from filling the vacancy to the employee starting, for employees
starting in the selected reporting period, for hires within a hiring manager hierarchy.

Applicant Efficiency (Hires – Organization Hierarchy) PMV report (iRecruitment)

This PMV report measures the average amount of time it takes to fill a vacancy, and
also the average time from filling the vacancy to the employee starting, for employees
starting in the selected reporting period, for hires within an organization hierarchy.

Applicant Fill to Start (Hires – Manager Hierarchy) PMV report (iRecruitment)

This PMV report measures the days between the date that the vacancy was filled and the
date on which the successful applicant becomes an employee for employees starting in
the reporting period, for hires within a hiring manager hierarchy.

Applicant Fill to Start (Hires – Organization Hierarchy) PMV report (iRecruitment)

This PMV report measures the days between the date that the vacancy was filled and the
date on which the successful applicant becomes an employee for employees starting in
the reporting period, for hires within an organization hierarchy.

Applicant Time to Fill (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start date of the vacancy and
the date upon which the vacancy is filled for employees starting in the reporting period
for vacancies that are filled in the reporting period, within a hiring manager hierarchy.

Applicant Time to Fill (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start date of the vacancy and
the date upon which the vacancy is filled for employees starting in the reporting period
for vacancies that are filled in the reporting period, within an organization hierarchy.

Applicant Time to Start (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for employees
starting in the reporting period, within a hiring manager hierarchy.

Applicant Time to Start (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for employees
starting in the reporting period, within an organization hierarchy.
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Applicant Time to Start Comparison – by Ethnic Origin (United States Specific) (HRMSi) (US)

This worksheet analyses the days required to fill vacancies within a recruitment activity
for ethnic groups in the United States.

Applicant Time to Start Comparison – by Ethnic Origin (United Kingdom Specific) (HRMSi) (UK)

This worksheet analyses the days required to fill vacancies within a recruitment activity
for ethnic groups in the United Kingdom.

Applicant Time to Start Comparison – by Gender (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by gender.

Applicant Time to Start Comparison – by Grade (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by grade.

Applicant Time to Start Comparison – by Job (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by job.

Applicant Time to Start Comparison – by Location (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by location.

Applicant Time to Start Comparison – by Organization (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by organization.

Applicant Time to Start Comparison – by Vacancy (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by vacancy.

Application Status – Age Analysis (HRMSi)

This worksheet enables you to investigate the current age of applicants for a particular
vacancy.

Application Status – Applicant Statuses (HRMSi)

This worksheet enables you to investigate the applications that exist for a Business
Group, requisition, and recruiter.

Application Status – Recruitment Activity Summary (HRMSi)

This worksheet enables you to investigate recruitment activities within your
Business Group. You can analyze the current status of recruitment activities, for
example, the number of new applicants, the number of offers made, and the number of
terminated applicants. You can view recruitment activity information for a Business
Group, requisition, vacancy, and recruitment type.
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Application Status – Vacancy Summary (HRMSi)

This worksheet enables you to investigate vacancies within your Business Group. You
can analyze the current status of vacancies, for example, the number of remaining
applicants, the number of new applicants, and the number of terminated applicants. You
can view vacancy information for a Business Group, recruitment type, and recruitment
activity.

Application Termination Detail – Termination Details

This Worksheet investigates the reasons your enterprise has terminated applications.

Application Termination Detail – Termination Reasons by Vacancy

This Worksheet investigates the reasons why job applicants have terminated applications
within your enterprise.

Candidate Detail – Address (iRecruitment)

The Address Worksheet enables you to report on the addresses of your candidates.

Candidate Detail – Competency (Skill) (iRecruitment)

The Competency (Skill) Worksheet enables you to report on the competencies of your
candidates. It also includes their level of proficiency. Competencies are entered by your
candidates as ‘skills’ as part of their account

Candidate Detail – Education (iRecruitment)

The Education Worksheet enables you to report on which schools and colleges your
candidates have attended and the qualifications they have achieved.

Candidate Detail – Employment History (iRecruitment)

The Employment History Worksheet enables you to report on the previous and current
employers of your candidates.

Candidate Detail – Job Search Views (iRecruitment)

The Job Search Views Worksheet enables you to report on the saved job searches your
candidates have set up.

Candidate Detail – Personal Detail (iRecruitment)

The Personal Detail Worksheet enables you to report on the details that your candidates
have entered as part of their iRecruitment account.

Candidate Detail – Phone (iRecruitment)

The Phone Worksheet enables you to report on the phone numbers of your candidates.

Candidate Detail – Qualification (iRecruitment)

The Qualification Worksheet enables you to report on the level of qualifications that
your candidates have.
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Job Posting Content – Posting Detail (iRecruitment)

The Posting Detail worksheet enables you to report on the details of the job postings
that have been created for your vacancies; for example, job title, job description, and
job requirements.

Recruitment by Authorizer Analysis – Average Days to Recruit by Organization (HRMSi, EDW)

The Average Days to Recruit by Organization worksheet measures both the average
number of days from the vacancy start date to hire and from the application date to hire;
average values for both measures are given for each organization and overall. This
information is reported for each recruitment authorizer within all top-level employing
organizations during a specific calendar year (the year the applicant was hired).

Recruitment by Authorizer Analysis – Average Days to Recruit by Stage and Job Category (HRMSi, EDW)

The Average Days to Recruit by Stage and Job Category worksheet measures the
average number of days from the start of the application to each recruitment stage
(end of application, first interview, second interview, offer, acceptance, and hire). This
is reported for each job category and each recruitment authorizer, during a specified
calendar year (the year the applicant was hired).

Recruitment by Authorizer Analysis – Average Days to Recruit by Stage and Job (HRMSi, EDW)

The Average Days to Recruit by Stage and Job worksheet measures the average
number of days from the start of the application to each recruitment stage (end of
application, first interview, second interview, offer, acceptance, and hire). This is
reported for each job and for a specified recruitment authorizer, during a specified
calendar year (the year the applicant was hired).

Recruitment by Authorizer Analysis – Average Days to Recruit Over Time (HRMSi, EDW)

The Average Days to Recruit Over Time worksheet measures the average number of
days from both vacancy start date to hire and application date to hire, for the past
three calendar years and the current calendar year; average values for both measures
are also given. This information is reported for each recruitment authorizer within a
specified top-level employing organization.

Recruitment by Authorizer Analysis – Average Days to Recruit (HRMSi, EDW)

The Average Days to Recruit worksheet measures the average number of days from
both the vacancy start date to hire and the application date to hire; average values for
both measures are also shown. This information is given for each recruitment authorizer
within a specified top-level employing organization during a specified calendar year in
which the applicant was hired.

Recruitment by Authorizer Analysis – Vacancy Activity (HRMSi, EDW)

The Vacancy Activity worksheet provides information for a specified authorizer on
the status of each vacancy. It reports the number of openings, vacancy start and end
dates, the number of applicants at each recruitment stage, the average days from vacancy
start and application to hire, and the number of openings remaining.

Recruitment by Recruiter Analysis – Average Days to Recruit by Organization (HRMSi, EDW)

The Average Days to Recruit by Organization worksheet measures both the average
number of days from the vacancy start date to hire and from the application date to hire;
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average values for both measures are given for each organization and overall. This
information is reported for each recruiter within all top-level employing organizations
during a specific calendar year (the year the applicant was hired).

Recruitment by Recruiter Analysis – Average Days to Recruit by Stage and Job Category (HRMSi, EDW)

The Average Days to Recruit by Stage and Job Category worksheet measures the average
number of days from the start of the application to each recruitment stage (end of
application, first interview, second interview, offer, acceptance, and hire). This is
reported for each job category and each recruiter, during a specified calendar year (the
year the applicant was hired).

Recruitment by Recruiter Analysis – Average Days to Recruit by Stage and Job (HRMSi, EDW)

The Average Days to Recruit by Stage and Job worksheet measures the average
number of days from the start of the application to each recruitment stage (end of
application, first interview, second interview, offer, acceptance, and hire). This is
reported for each job and for a specified recruiter, during a specified calendar year (the
year the applicant was hired).

Recruitment by Recruiter Analysis – Average Days to Recruit Over Time (HRMSi, EDW)

The Average Days to Recruit Over Time worksheet measures the average number of
days from both vacancy start date to hire and application date to hire, for the past three
calendar years and the current calendar year; average values for both measures are
also given. This information is reported for each recruiter within a specified top-level
employing organization.

Recruitment by Recruiter Analysis – Average Days to Recruit (HRMSi, EDW)

The Average Days to Recruit worksheet measures the average number of days from
both the application date to hire and the vacancy date to hire; average values for
both measures are also shown. This information is given for each recruiter within a
specified top-level employing organization during a specified calendar year in which
the applicant was hired.

Recruitment by Recruiter Analysis – Vacancy Activity (HRMSi, EDW)

The Vacancy Activity worksheet provides information for a specified recruiter
on the status of each vacancy within a specified period. It reports the number of
openings, vacancy start and end dates, the number of applicants at each recruitment
stage, the average days from vacancy start and application to hire, and the number
of openings remaining.

Recruitment Efficiency Comparison – Hires vs. Openings Summary (HRMSi)

This worksheet shows the rate of hires in your organization compared to job openings.

Recruitment Efficiency Comparison – Recruitment Activity Ratios (HRMSi)

This worksheet investigates the cost of your recruitment activities.

Recruitment Efficiency Comparison – Vacancy Ratios by Recruitment Activity (HRMSi)

This worksheet investigates how successful specific recruitment activities have been.
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Recruitment Efficiency Comparison – Vacancy Ratios (HRMSi)

This worksheet investigates how successful your recruitment has been.

Recruitment Success Report (HRMSi)

This report provides a trend analysis showing the changes in recruitment success over
a selected period of time. You can analyze the total number of openings recorded for
vacancies, the total number of openings that have been filled, and the Performance
Management Framework recruitment success targets.

Requisition Summary Report

Applicants and their interview schedules for a selection of vacancies.

Vacancy Ageing (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start of the vacancy and the
current date, for vacancies within a hiring manager hierarchy.

Vacancy Ageing (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start of the vacancy and the
current date, for vacancies within an organization hierarchy.

Vacancy Detail – by Grade (iRecruitment)

The By Grade worksheet enables you to report on the vacancies that exist with a
specific grade. Grade Name is a page item on this worksheet so you can group your
results by the vacancy grade.

Vacancy Detail – by Hiring Manager (iRecruitment)

The By Hiring Manager worksheet enables you to report on the vacancies associated
with each hiring manager. Hiring Manager Name is a page item on this worksheet so
you can group your results by vacancy hiring manager.

Vacancy Detail – by Job (iRecruitment)

The By Job worksheet enables you to report on the vacancies that exist for a specific
job. Job Name is a page item on this worksheet so you can group your results by the
vacancy job.

Vacancy Detail – by Location (iRecruitment)

The By Location worksheet enables you to report on the vacancies available at each
location. Location Name is a page item on this worksheet so you can group your results
by the location of the vacancy.

Vacancy Detail – by Organization (iRecruitment)

The By Organization worksheet enables you to report on the vacancies that are available
in each of your organizations.
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Vacancy Detail – by Position (iRecruitment)

The By Position worksheet enables you to report on the vacancies that exist for a specific
position. Position Name is a page item on this worksheet so you can group your results
by vacancy position.

Vacancy Detail – by Recruiter (iRecruitment)

The By Recruiter worksheet enables you to report on the vacancies associated with
each recruiter. Recruiter Name is a page item on this worksheet so you can group
your results by vacancy recruiter.

Vacancy Detail – by Vacancy Status (iRecruitment)

The By Vacancy Status worksheet enables you to report on the vacancies with each
vacancy status. Vacancy Status is a page item on this worksheet so you can group
your results by vacancy status.

Vacancy Detail – Detail (iRecruitment)

The Detail Worksheet enables you to report on the details of the vacancies in your
organization hierarchy.

Vacancy Hire Success (Organization Hierarchy) Template Analytics by Year (HRMSi)

This worksheet enables you to see vacancy success for each year. The template
worksheets provide a starting point for developers to create analytic reports.

Vacancy Hire Success (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet calculates the vacancy success rates for vacancies with the same opening
and closing dates, for each organization, location, job, grade, and position. The template
worksheets provide a starting point for developers to create analytic reports.

Vacancy Status (System Defaults – Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of vacancies at each vacancy status as of the
current date, within a hiring manager hierarchy. These reports only include the vacancy
statuses supplied with the application. Any vacancy statuses you have added will not
be taken into account by these reports.

Vacancy Status (System Defaults – Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of vacancies at each vacancy status as of the
current date, within an organization hierarchy. These reports only include the vacancy
statuses supplied with the application. Any vacancy statuses you have added will not
be taken into account by these reports.

Vacancy Success (Organization Hierarchy) Trend Analytics By Bi Month (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by bimonthlies.

Vacancy Success (Organization Hierarchy) Trend Analytics By Month (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by months.
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Vacancy Success (Organization Hierarchy) Trend Analytics By Quarter (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by quarters.

Vacancy Success (Organization Hierarchy) Trend Analytics By Semi Year (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by semi-years.

Vacancy Success (Organization Hierarchy) Trend Analytics By Year (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by years.

Vacancy Success (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success
across geographical areas.

Vacancy Success (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success
across organizations in your enterprise.

Vacancy Time from Fill to Start (Manager Hierarchy) Status (iRecruitment)

This PMV report measures the average number of days between filling a vacancy and
the employee starting, for vacancies that started in the reporting period, and vacancies
within a hiring manager hierarchy.

Vacancy Time from Fill to Start (Organization Hierarchy) Status (iRecruitment)

This PMV report measures the average number of days between filling a vacancy and
the employee starting, for vacancies that started in the reporting period, and vacancies
within an organization hierarchy.

Vacancy Time to Start (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for vacancies
that start in the reporting period, and vacancies within a hiring manager hierarchy.

Vacancy Time to Start (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for vacancies
that start in the reporting period, and vacancies within an organization hierarchy.

Workforce Recruitment Stage Analysis – Average Days to Recruit by Stage and Job Category (HRMSi,
EDW)

The Average Days to Recruit by Stage and Job Category worksheet provides recruitment
information for each job category in a top-level employing organization within a
specified calendar year. It reports the average number of days from application to
termination (the date the application was ended by the employer or applicant), first
interview, second interview, offer, acceptance, and hire.
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Workforce Recruitment Stage Analysis – Average Days to Recruit by Stage and Job (HRMSi, EDW)

The Average Days to Recruit by Stage and Job worksheet provides recruitment
information for each job (for example, Line Manager or Sales Person) in a top-level
employing organization within a specified calendar year. You can report on the average
number of days from application to termination (the date the application was ended by
the employer or applicant), first interview, second interview, offer, acceptance, and hire.

Workforce Recruitment Stage Analysis – Efficiency (Average Days) (HRMSi, EDW)

The Efficiency (Average Days) worksheet provides information concerning the
recruitment efficiency of each top-level employing organization for a specified calendar
year. It reports the average number of days from application to termination (the
date the application was ended by the employer or applicant), first interview, second
interview, offer, acceptance, and hire.

Workforce Recruitment Stage Analysis – Recruitment by Age Band (HRMSi, EDW)

The Recruitment by Age Band worksheet provides a recruitment summary by age
band for a selected top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Disability Status (HRMSi, EDW)

The Recruitment by Disability Status worksheet provides a recruitment summary by
disability status (disabled, not disabled, or undefined) for a selected top-level employing
organization. You can report on the following measures: head count, full time
equivalent, average number of days between application and hire for each assignment
by organization and year, and average number of days between vacancy start and hire
for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Gender (HRMSi, EDW)

The Recruitment by Gender worksheet provides a recruitment summary by gender
for a selected top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Location (HRMSi, EDW)

The Recruitment by Location worksheet provides a recruitment summary by location
for a selected top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Organization (HRMSi, EDW)

The Recruitment by Organization worksheet provides a recruitment summary for
a specified top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.
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Workforce Recruitment Stage Analysis – Vacancy Activity by Job (HRMSi, EDW)

The Vacancy Activity by Job worksheet provides information for a specified top-level
employing organization and job on the status of each vacancy; for example, the number
of openings, vacancy start and end dates, the number of applicants at each recruitment
stage, the average days from vacancy start and application to hire, and the number
of openings remaining.

Workforce Recruitment Stage Analysis – Vacancy Activity (HRMSi, EDW)

The Vacancy Activity worksheet provides information for a specified top-level
employing organization on the status of each vacancy; for example, the number of
openings, vacancy start and end dates, the number of applicants at each recruitment
stage, the average days from vacancy start and application to hire, and the number
of openings remaining.

People Management

Annualized Turnover (HRMSi, DBI)

This report displays the annualized employee headcount turnover for the selected
top line manager.

Annualized Turnover Status (HRMSi, DBI)

The report displays the percentage-annualized turnover for the top line manager. You
access this report from the Total column in the Annualized Turnover report.

Annualized Turnover Trend (HRMSi, DBI)

This report shows changes in the annualized employee headcount turnover over time
for the selected top line manager. The report categorizes turnover into voluntary and
involuntary separations.

Assignment Status Report

All employees, applicants or both assigned to selected work structures.

Company Certificate Report (Spain)

Contains the personal, employment, and social security information of an employee who
is terminated or on leave such as maternity leave or leave due to suspended assignment.

Employee Anniversary and Birthday (Multiple Hierarchies) Detail – by Organization Hierarchy

The Organization Hierarchy worksheet allows you to report on employee anniversaries
(total service) and birth date (in the format DD-MON). Employees are listed by
organization. Total and current service calculations are in respect of the system date
(SYSDATE).

Employee Anniversary and Birthday (Multiple Hierarchies) Detail – by Supervisor Hierarchy

The Supervisor Hierarchy worksheet enables you to report on employee anniversaries
(total service) and birth date (in the format DD-MON).
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Employee by Supervisor (Multiple Hierarchies) Status – by Organization Hierarchy

The Organization Hierarchy worksheet enables you to report on the supervisor hierarchy
and salary details for your employees, by organization.

Employee by Supervisor (Multiple Hierarchies) Status – by Supervisor Hierarchy

The Supervisor Hierarchy worksheet enables you to report on the supervisor hierarchy
and salary details for your employees by supervisor.

Employee Composition Detail – by Assignment Details

This worksheet enables you to analyze workforce assignment details by
organization, job, position, or grade.

Employee Composition Detail – by Salary Band

This worksheet enables you to analyze the distribution of employees within an
organization by length of service.

Employee Composition Detail – by Time In Service Band

This worksheet enables you to analyze the distribution of employees within an
organization by length of service.

Employee Hired or Terminated Detail for Organization Hierarchy

This worksheet enables you to report on employees who terminated or were hired
within two specified dates for a given organization and its subordinate organizations.

Employee Mailing Address (Multiple Hierarchies, United Status Specific) Detail – by Organization
Hierarchy (US)

The Organization Hierarchy worksheet enables you to report on employee current
primary addresses in a United States legislation specific address format, for a given
organization and its subordinate organizations.

Employee Mailing Address (Multiple Hierarchies, United Status Specific) Detail – by Supervisor Hierarchy
(US)

The Supervisor Hierarchy worksheet enables you to report on employee current primary
addresses in a United States legislation specific address format, for a given supervisor
and his/her subordinates.

Employee Mailing Address (Multiple Hierarchies) Detail – by Organization Hierarchy

This Worksheet enables you to report on current employee primary addresses in a
non-legislative specific address format, for a given organization and its subordinate
organizations.

Employee Mailing Address (Multiple Hierarchies) Detail – Supervisor Hierarchy

This Worksheet enables you to report on current employee primary addresses in a
non-legislative specific address format, for a given supervisor and his/her subordinates.
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Employee Movement by Organization Analysis – Hires

This worksheet displays hire information in detail. The worksheet enables you to analyze
hire information by job, position, assignment, or location. It enables you to analyze hire
trends within an organization, and analyze skills required within an organization.

Employee Movement by Organization Analysis – Hires, Terminations and Transfers by Quarter (HRMSi)

This worksheet enables you to view high-level information about the value of
hires, terminations, and transfers in all organizations within your Business Group, by
year quarter. The resulting information allows you to analyze workforce changes by
quarter, and compare workforce change across all organizations within a Business Group.

Employee Movement by Organization Analysis – Terminations

This worksheet enables you to analyze terminations within your organizations in
detail. For each termination you can: Analyze employee termination across all
organizations within a Business Group.

Employee Movement by Organization Analysis – Transfers In

This worksheet enables you to investigate the total budget value of people transferring
into different organizations in your Business Group. For each transfer you can analyze
the organization transferred from, the location transferred from, and the position/job
transferred from.

Employee Movement by Organization Analysis – Transfers Out

This worksheet investigates the total budget value of people transferring out of different
organizations in your Business Group. For each transfer out you can analyze the
organization transferred to, the location transferred to, and the position/job transferred
to.

Employee Organization Transfer (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee primary assignment organization
transfers during a given period for a given organization and its subordinate
organizations. The worksheet output includes the employee primary assignment details
before and after the transfer, including job name, organization name, and supervisor
name.

Employee Organization Transfer (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee primary assignment organization
transfers during a given period for a given supervisor and his/her subordinates. The
worksheet output includes the employee primary assignment details before and after the
transfer, including job name, organization name, and supervisor name.

Employee Primary Assignment (Multiple Hierarchies) Detail – by Organization Hierarchy

The Organization Hierarchy worksheet enables you to report on basic employee details
by employee primary assignment. Employees are listed for each organization and
for subordinate organizations.
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Employee Primary Assignment (Multiple Hierarchies) Detail – by Supervisor Hierarchy

The Supervisor Hierarchy worksheet enables you to report on basic employee details
by employee primary assignment. Employees are listed for a given Supervisor and
his/her subordinates.

Employee Primary Assignment Count (by Location and Employment Category, Multiple Hierarchies)
Comparison – by Organization Hierarchy (HRMSi)

The Organization Hierarchy worksheet enables you to calculate employee primary
assignment numbers by location for a given organization. You can use the worksheet
parameters to include specific assignment statuses or exclude particular person types to
suit your requirements.

Employee Primary Assignment Count (by Location and Employment Category, Multiple Hierarchies)
Comparison – by Supervisor Hierarchy (HRMSi)

The Supervisor Hierarchy worksheet enables you to calculate employee primary
assignment numbers by location for a given supervisor. You can use the worksheet
parameters to include specific assignment statuses or exclude particular person types to
suit your requirements.

Employee Primary Assignment Count (by Location and Employment Category, Multiple Hierarchies)
Comparison – by Without Organization Hierarchy (HRMSi)

The Without Organization Hierarchy worksheet enables you to calculate employee
primary assignment numbers by location without using organization or supervisor
hierarchies. You can use the worksheet parameters to include specific assignment
statuses or exclude particular person types to suit your requirements.

Employee Primary Assignment Count (by Organization and Employment Category, Multiple Hierarchies)
Comparison – by Organization Hierarchy (HRMSi)

The Organization Hierarchy worksheet enables you to report on employee primary
assignment numbers for a given organization. The worksheet parameters enable you
customize the worksheet output to suit your own requirements; for example, you can
choose assignment types to include or person types to exclude from the worksheet.

Employee Primary Assignment Count (by Organization and Employment Category, Multiple Hierarchies)
Comparison – by Organization Hierarchy (Rollup) (HRMSi)

The Organization Hierarchy (Rollup) worksheet allows you to report on employee
primary assignment numbers by Organization Rollup for a given organization. The
worksheet parameters enable you customize the worksheet output to suit your own
requirements; for example, you can choose assignment types to include or person types
to exclude from the worksheet.

Employee Primary Assignment Count (by Organization and Employment Category, Multiple Hierarchies)
Comparison – by Supervisor Hierarchy (HRMSi)

The Supervisor Hierarchy worksheet enables you to report on employee primary
assignment numbers by organization for a given supervisor. The worksheet parameters
enable you customize the worksheet output to suit your own requirements; for
example, you can choose assignment types to include or person types to exclude from
the worksheet.
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Employee Separation (Organization Hierarchy) Template Analytics by Year, Organization and Separation
Category (HRMSi)

This investigates separations from the workforce for different organizations and different
leaving reasons over yearly periods. The template worksheets provide a starting point
for developers to create analytic reports.

Employee Separation (Organization Hierarchy) Template Analytics Details (HRMSi)

This worksheet tells you how separations from your workforce vary across
different groups within your organization, such as organization, job, and
location. For any date, you can see how many separations have occurred within
each organization, location, job, grade, position, separation category, and separation
reason. The template worksheets provide a starting point for developers to create
analytic reports.

Employee Separation by Competence (Organization Hierarchy) Status Analytics by Geography Area
(HRMSi)

This worksheet compares employee competencies to separations across geographical
areas.

Employee Separation by Competence (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet compares employee competencies to separations across organizations.

Employee Separation by Competence (Organization Hierarchy) Status Analytics by Rank Level (HRMSi)

This worksheet enables you to see the number of people who have separated from the
workforce who hold competencies at a specific rank level.

Employee Separation by Competence (Organization Hierarchy) Status Analytics by Scale Level (HRMSi)

This worksheet enables you to see the number of people who have separated from the
workforce who hold competencies at a specific scale level.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet compares employees’ competencies, to the rate of separation, grouped
by bimonthlies.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet compares employees’ competencies to the rate of separation, grouped
by months.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet compares employees’ competencies to the rate of separation, grouped
by quarters.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet compares employees’ competencies, to the rate of separation, grouped
by semi-years.
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Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet compares employees’ competencies, to the rate of separation, grouped
by years.

Employee Separation by Length of Work (Organization Hierarchy) Status Analytics by Geography Area
(HRMSi)

This worksheet compares employees’ length of service within each geographical area.

Employee Separation by Length of Work (Organization Hierarchy) Status Analytics by Organization
(HRMSi)

This worksheet compares employees’ length of service within each organization.

Employee Separation by Length of Work (Organization Hierarchy) Status Analytics by Separation
Category & Reason (HRMSi)

This worksheet compares the length of service of employees who have separated from
your enterprise, grouped by separation category and reason.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each bimonthly.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each month.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each quarter.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each semi-year.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each year.

Employee Separation by Reason (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet investigates the different reasons for separations within geographical
areas. You can determine if employees in different areas leave your enterprise for
different reasons.

Employee Separation by Reason (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet investigates the different reasons for separations within
organizations. You can determine if employees in different organizations leave your
enterprise for different reasons.
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Employee Separation by Reason (Organization Hierarchy) Status Analytics by Separation Category
(HRMSi)

This worksheet investigates the different reasons employees leave your enterprise
within each separation category.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise
is losing workforce over time, grouped by bimonthly.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by month.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by quarter.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by semi-year.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by year.

Employee Summary Report

Addresses, contacts, periods of service, assignments, special information, personal
payment methods and element entries for a selected employee.

Employee Termination (Organization Hierarchy) Detail – Detail

This worksheet enables you to report on employees that have separated within a
specified time period. Employees are listed for a given organization and its subordinate
organizations.

Employee Termination with Comments (Organization Hierarchy) Detail – Detail

This worksheet enables you to report on the employees that have separated within a
specified time period. Employees are listed for a given organization and its subordinate
organizations.

Employment Certification Report (Hungary)

Contains the personal, job, and pension information of a terminated employee.

Employment Equity Report

Outlines the required information needed for the Employment Equity report required
by Canadian Employment Equity Act.
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Employment Equity Templates (Payroll) (South Africa)

Outlines the required information needed for Employment Equity as defined by the
Department of Labour.

Employment Equity Workforce Profile Report (Payroll) (South Africa)

Outlines the required information needed for Employment Equity as defined by the
Department of Labour.

Full Applicant Details

Applications and applicant interviews for one applicant.

Full Assignment Details

Assignment information including periods of service, payment methods, and element
entries for one employee.

Full Person Details

Addresses and information entered in the Person window such as name, date of
birth, nationality and work telephone number for one employee.

Full Personal Details Report Set

Person details, applicant details, assignment details and work details for one employee.

Full Work Details

Miscellaneous work information including special information, absences, recruitment
activities and contacts for one employee.

Head Count Detail Report

The number and type of workers within an organization, as well as attrition rate data.

Headcount (HRMSi, DBI)

This report displays the total employee headcount of the direct reports of the selected
top line manager.

Headcount by Country Trend (HRMSi, DBI)

This report shows changes in headcount over time for the four countries with the highest
head count for the selected top line manager.

Headcount Transfer (Plus) Detail (HRMSi, DBI)

The report displays the employee records that comprise the total value you drilled from
in the head count report, including transfers and reorganizations. You access this report
from the Plus-Transfer column in the parent head count report.

Headcount Hire Detail (HRMSi, DBI)

This report lists the records that comprise the Plus-Hire value you drilled from in the
Headcount report, including hires, re-hires and secondary assignment starts. You access
this report from the Plus-Hire column in the Headcount report.
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Headcount Termination Detail (HRMSi, DBI)

The report displays the employee records that make up the total value you drilled from
in the Headcount report. The report lists employees who have terminated from the
manager’s hierarchy in the given period, together with supporting details.

Headcount Transfer (Minus) Detail (HRMSi, DBI)

The report displays the employee records that comprise the total value you drilled from
the Headcount report, including transfers and reorganizations. The report provides
information about employees who have moved out of the selected manager’s hierarchy.

HRMS Profile Options Report

Use this report to list the values of the profile options for your HRMS installation. The
report also identifies which profile options have not been set for your installation.

Human Resource Setup Detail – Employee Anniversary Birthdays

This worksheet enables you to view employee birthdays and start dates. The
worksheet also enables you to view other employee information, for example, length of
service, employee number, and supervisor name.

Human Resource Setup Detail – Employee Assignment by Organization

This worksheet enables you to report on the assignments within an organization, by
choosing a top organization and including subordinates.

Human Resource Setup Detail – Employee Assignment by Organization Rollup

This worksheet enables you emulate the rollup flexibility of HRMSi Reports by using an
organization hierarchy to control the information displayed.

Human Resource Setup Detail – Employee Job History

This worksheet enables you to view employee job history across your organization.

Human Resource Setup Detail – Employee List with Length of Work

This worksheet enables you to analyze deployment factors associated with
positions, people in specific positions, and position applicants.

Human Resource Setup Detail – Employee Separation with Equal Opportunity (United States Specific)

This worksheet enables you to analyze terminations with ethnic origin over a specific
time period.

Human Resource Setup Detail – Person Home Address

This worksheet enables you to view the primary addresses of employees.

Invalid Address Report

Lists employee address information inconsistencies.
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Invalid Address Report (US)

Lists employee address information inconsistencies. In addition, identifies addresses
that do not comply with SSA MMREF-1 standards or that have address lines longer than
a user-specified length.

Law SAMEN Report (Organization Structure)and Law SAMEN Report (Dutch Region) (Netherlands)

The Law SAMEN report (Organization Structure) reports on employees within an
organization structure. The Law SAMEN Report (Dutch Region) reports on employees
within a specific Dutch region.

National Defense Report (Hungary)

Contains a list of male employees who are available to perform a national defense role.

New Hire State Magnetic Media Report (US)

Report on newly hired and rehired employees using magnetic media.

New Hire State Report (US)

Report on newly hired or rehired employees.

Period of Service Reports (Germany)

Generates reports of an employee’s periods of service using selected criteria.

Person/Assignment History Detail – Application

This worksheet enables you to analyze an applicant’s assignment record between the
start and end of an application. For each employee you can examine the total number
of applications, the number of successful applications, and the length of time between
different application stages.

Person/Assignment History Detail – Employee Separation

This worksheet enables you track termination reasons by type, date, and length of
service, allowing you to spot trends among leavers. For each termination, you can
compare termination reasons to discover trends, and compare the length of time in an
organization against time in a job.

Person/Assignment History Detail – Person Assignment

This worksheet enables you to analyze an employee’s assignment history between
specific dates. For each employee you can examine the current assignment, and details
of previous assignments.

Person Full History Report

This report lists the personal and professional details of the employees and contingent
workers in your enterprise, including assignments, salary, and contact details.

Person Synchronization Report

This report shows details of any person in your current business group who also has a
record in another business group on the specified date.
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RED System : New Hires, Leavers, and Contract Changes Report (Spain)

This report contains information about the workforce and contract changes within
an enterprise.

Saudi Contract Expiry Report (SA)

The Saudi Contract Expiry Report creates a list of all the contracts that will expire in a
user specified period of time.

Saudi Iqama Expiry Report (SA)

The Saudi Iqama Expiry Report creates a list of all the iqamas that will expire in a
user specified period of time.

Saudi Passport Expiry Report (SA)

The Saudi Passport Expiry Report creates a list of all the passports that will expire in a
user specified period of time.

Separations By Competence Report (HRMSi)

This report is run from the Separations by Leaving Reason report. When employees
leave your enterprise you lose the competencies they possess. This can become a
problem if you continue to lose people with the same abilities. This report investigates
the competencies and levels of proficiency you are losing.

Separations By Leaving Reason Report (HRMSi)

This report is run from the Workforce Losses report. This report enables you to
investigate the different reasons why your enterprise is losing workforce. It only
includes the workforce that has left your enterprise. It does not include workforce that
has transferred to a different area of your enterprise or assignments that have ended or
been suspended.

Separations By Service Bands Report (HRMSi)

This report is run from the Separations by Leaving Reason report. This report
investigates the relationship between the reasons people give for leaving and the amount
of time they have been with your enterprise.

Separations Trend by Leaving Reason Report (HRMSi)

Use this report to investigate the trends in why people are leaving your enterprise. This
report runs from the Workforce Losses report.

Separations Trend by Service Band Report (HRMSi)

Use this report to investigate the trends in the length of time employees remain with
your enterprise. This report runs from the Workforce Losses report.

Social Health Insurance Report (Netherlands)

Employees who have started and/or ended the social health insurance within a date
range.
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Tenure Notification Reports (including Tenured Status, Non-Tenured Status, Tenure Track Status and
Tenure Review) (US)

These notification reports are available for you to send to faculty members and their
academic manager during the Tenure process

Terminations Report

The number of employees from selected organizations leaving your enterprise within a
particular period, and the reason for leaving.

Terminations with Active Support Order Report (US)

Run this report to view employees with an active support order at the time of
termination.

Turnover Detail (HRMSi, DBI)

This report lists the ex-employees who comprise the value you drilled from the
Annualized Turnover Status report. The report is the sum of the headcount of
assignment ends that occur at the same time as a termination.

Worker Organization Movements Report

New starters, terminations, transfers in, and transfers out of a selected organization or
organization hierarchy.

Workforce Assignment Activity Analysis – Grade Changes (HRMSi, EDW)

The Grade Changes worksheet provides a summary of the head count or full time
equivalent, or the average number of months between grade changes, for a specified
top-level employing organization within a particular calendar year, for employees
changing grade.

Workforce Assignment Activity Analysis – Location Changes (HRMSi, EDW)

The Location Changes worksheet provides a summary of the head count or full
time equivalent for people changing locations for a specified top-level employing
organization within a specified calendar year.

Workforce Assignment Activity Analysis – Organization Changes (HRMSi, EDW)

The Organization Changes worksheet provides a summary of the head count or
full-time equivalent for employees changing organizations within a specified calendar
year. Initially only the top-level employing organizations are displayed; you need to drill
down to see transfers between organizations further down the organizational hierarchy.

Workforce Comparison Report (HRMSi)

The workforce assigned to different types of jobs can vary over time. This report
compares the workforce assigned to up to three job categories over time. For
example, you could compare the number of managers against the number of technical
staff you employed last year.

Workforce Composition Analysis – Composition by Age Band (HRMSi, EDW)

The Composition by Age Band worksheet provides a summary of person head count
or full-time equivalent by employee age band for a specified top-level employing
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organization and a specified period of time. All workforce composition data collected
in that period will be included.

Workforce Composition Analysis – Composition by Disability Status (HRMSi, EDW)

The Composition by Disability Status worksheet provides a summary of person head
count or full-time equivalent by disability status (disabled, not disabled, or undefined)
for a specified top-level employing organization within a specified period of time. All
workforce composition data collected in that period will be included.

Workforce Composition Analysis – Composition by Gender (HRMSi, EDW)

The Composition by Gender worksheet provides a summary of person head count or
full-time equivalent by gender for a specified top-level employing organization and a
specified period of time. All workforce composition data collected in that period will
be included.

Workforce Composition Analysis – Composition by Location (HRMSi, EDW)

The Composition by Location worksheet provides a summary of person head count
or full-time equivalent, by location, for a specified top-level employing organization
within a specified period of time. All workforce composition data collected in that
period will be included.

Workforce Composition Analysis – Composition by Period of Service (HRMSi, EDW)

The Composition by Period of Service worksheet provides a summary of person head
count or full-time equivalent by period of service for a specified top-level employing
organization and a specified period of time. All workforce composition data collected
in that period will be included.

Workforce Composition Analysis – Composition Summary (HRMSi, EDW)

The Composition Summary worksheet provides a summary of person head count or
full-time equivalent for top-level employing organizations and for a specified period of
time. All workforce composition data collected within that period will be included.

Workforce Count (Organization Hierarchy) Template Analytics by Year (HRMSi)

This worksheet analyses how your workforce fluctuates over time. The template
worksheets provide a starting point for developers to create analytic reports.

Workforce Count (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet tells you how your workforce fluctuates across different groups within
your organization, such as organization, job, and location. You view the detail for one
year at a time. The template worksheets provide a starting point for developers to
create analytic reports.

Workforce Count (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by bimonthlies.
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Workforce Count (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by months.

Workforce Count (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by quarters.

Workforce Count (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by semi-years.

Workforce Count (Organization Hierarchy) Trend Analytics by Year and Geography (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by year and
geography.

Workforce Count (Organization Hierarchy) Trend Analytics by Year and Organization (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by year
and organization.

Workforce Count (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by years.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, for each bimonthly within the given
date range.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE)
of your workforce, broken down by job category, for each month within the given
date range.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE)
of your workforce, broken down by job category, for each quarter within the given
date range.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, for each semi-year within the given
date range.
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Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, for each year within the given date range.

Workforce Count Change (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce grouped by geographical area.

Workforce Count Change (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce grouped by organization.

Workforce Count Change (Organization Hierarchy) Status Analytics by Separation Category (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce grouped by separation category.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Geography
Area (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by geographical area.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by grade.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by job.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Organization
(HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by organization.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by position.

Workforce Count KPI Status (HRMSi)

This Performance Management Viewer report provides you with a view of the Workforce
Full Time Equivalent and Workforce head count KPI data, including target and actual
values. The report displays table data by default; you can optionally display the data as
a chart.

Workforce Count Report

The number and type of workers within an organization, as well as attrition rate
data, in summary form.
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Workforce Count Report (Spread Sheet Version)

The number and type of workers within an organization, as well as attrition rate data, in
summary form. This version of the workforce count reports enables you to open the
report in a spreadsheet format.

Workforce Gain (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by geographical area.

Workforce Gain (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by organization.

Workforce Gain (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by job.

Workforce Gain (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by organization.

Workforce Gain (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped by
grade.

Workforce Gain (Organization Hierarchy) Template Analytics by Year and Organization (HRMSi)

This worksheet analyses how workforce gains have occurred, and compares the gains
over time and across organizations. The template worksheets provide a starting point
for developers to create analytic reports.

Workforce Gain (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet tells you how the gains occurred and how the gains have been deployed
within the workforce. The template worksheets provide a starting point for developers
to create analytic reports.

Workforce Gain (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped by
bimonthlies.

Workforce Gain (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped
by months.

Workforce Gain (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped
by quarter years.

B-36 Oracle Human Resources Management Systems FastFormula User Guide



Workforce Gain (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped by
semi-years.

Workforce Gain (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped
by years.

Workforce Gains Report (HRMSi)

Organizations within your enterprise may be gaining workforce for different
reasons. This report investigates whether your workforce is increasing because of any
of the following reasons: new employees are being hired by your enterprise, existing
employees are being given new assignments in different parts of your enterprise, existing
employees are transferring assignments to different parts of your enterprise, or
employees’ assignments are being re-activated from suspended to active.

Workforce Loss (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet lists the total losses within a given time period, grouped by geographical
area.

Workforce Loss (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet lists the total losses within a given time period, grouped by grade.

Workforce Loss (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet lists the total losses within a given time period, grouped by job.

Workforce Loss (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet lists the total losses within a given time period, grouped by organization.

Workforce Loss (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet lists the total losses within a given time period, grouped by Position.

Workforce Loss (Organization Hierarchy) Template Analytics by Year and Organization (HRMSi)

This worksheet analyses when and where workforce gains occur, and compares the gains
over time and across organizations. The template worksheets provide a starting point
for developers to create analytic reports.

Workforce Loss (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet tells you how losses occurred and where losses occurred within the
workforce. The template worksheets provide a starting point for developers to create
analytic reports.

Workforce Loss (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by bimonthly.
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Workforce Loss (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped by
month.

Workforce Loss (Organization Hierarchy) Trend Analytics by Position (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by position.

Workforce Loss (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by quarter.

Workforce Loss (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by semi-year.

Workforce Loss (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by year.

Workforce Losses Report (HRMSi)

This report investigates the different reasons you are losing workforce within your
enterprise. Are you losing workforce because the workforce is transferring to different
parts of your enterprise, because current employee assignments are ending, because
employee assignments are being suspended, or because employees are leaving your
enterprise?

Workforce Planning Summary Analysis – Composition by Location (HRMSi, EDW)

The Composition by Location worksheet provides a summary of person head count or
full-time equivalent, by location, for a specified top-level employing organization and a
specified period of time. All data collected in that period will be included.

Workforce Planning Summary Analysis – Composition Summary (HRMSi, EDW)

The Composition Summary worksheet provides a summary of workforce composition
for a top-level employing organization for a specified period of time. All data collected
within that period will be included.

Workforce Planning Summary Analysis – Organization Changes (HRMSi, EDW)

The Organization Changes worksheet provides a summary of the head count or full
time equivalent for employees changing organizations within a specified calendar
year. Initially only the top-level employing organizations are displayed; you need to drill
down to see transfers between organizations further down the organizational hierarchy.

Workforce Planning Summary Analysis – Recruitment by Organization (HRMSi, EDW)

The Recruitment by Organization worksheet gives you a recruitment summary by
top-level employing organization. You can report on the following measures: head
count, full-time equivalent, average number of days between application and hire, and
average number of days between vacancy start and hire.
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Workforce Planning Summary Analysis – Recruitment Efficiency (Average Days) (HRMSi, EDW)

The Recruitment Efficiency (Average Days) worksheet provides information concerning
efficiency of recruitment for a specified calendar year (based on the date employment
started) for each top-level employing organization. You can report on the average
number of days from application to termination (the date the application was ended by
the employer or the applicant), first interview, second interview, offer, acceptance, and
hire.

Workforce Planning Summary Analysis – Separation by Organization (HRMSi, EDW)

The Separation by Organization worksheet provides a summary of person head count or
full-time equivalent by top-level employing organization.

Workforce Planning Summary Analysis – Voluntary/Involuntary Separation (HRMSi, EDW)

The Voluntary/Involuntary Separation worksheet provides a summary of person head
count or full-time equivalent for a selected top-level employing organization by loss type
(voluntary or involuntary) for the last 3 years and the current year.

Workforce Ratio Report (HRMSi)

The workforce assigned to different types of jobs can vary over time. This report
compares the percentage of workforce assigned to up to three job categories over time. If
you want to investigate the absolute number of employees for different job categories
rather than the percentage of employees, you can run the related Workforce Comparison
report from this report.

Workforce Separation Analysis – Separation by Age Band (HRMSi, EDW)

The Separation by Age band worksheet provides a summary of person head count
or full-time equivalent by employee age band for a selected top-level employing
organization.

Workforce Separation Analysis – Separation by Disability Status (HRMSi, EDW)

The Separation by Disabled Status worksheet provides a summary of person head count
or full-time equivalent by disability status (disabled, not disabled, or undefined) for a
selected top-level employing organization.

Workforce Separation Analysis – Separation by Gender (HRMSi, EDW)

The Separation by Gender worksheet provides a summary of person head count or
full-time equivalent by gender for a selected top-level employing organization.

Workforce Separation Analysis – Separation by Organization (HRMSi, EDW)

The Separation by Organization worksheet provides a summary of the person head
count or full-time equivalent by top-level employing organization.

Workforce Separation Analysis – Separation by Period of Service (HRMSi, EDW)

The Separation by Period of Service worksheet provides a summary of person head
count or full-time equivalent by period of service for a selected top-level employing
organization.
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Workforce Separation Analysis – Separation by Period of Service and Reason (HRMSi, EDW)

The Separation by Period of Service and Reason worksheet provides a summary of
person head count or full-time equivalent by period of service and separation reason
for a selected top-level employing organization and calendar year (based on the year
separation occurred).

Workforce Separation Analysis – Separation Reasons by Age Band, Disability Status, and Gender
(HRMSi, EDW)

The Separation Reasons by Age Band, Disability Status, and Gender worksheet provides
a summary of person head count or full-time equivalent by separation reason for a
selected top-level employing organization, by age band, disability status, or gender.

Workforce Separation Analysis – Separation Reasons by Organization (HRMSi, EDW)

The Separation Reasons by Organization worksheet provides a summary of
person head count or full-time equivalent for a selected top-level employing
organization, by separation type (voluntary or involuntary) and separation reason (for
example, disability, poor performance, end of contract etc.).

Workforce Separation Analysis – Voluntary/Involuntary Separation (HRMSi, EDW)

The Voluntary/Involuntary Separation worksheet provides a summary of person head
count or full-time equivalent for a specified top-level employing organization by
voluntary or involuntary separation type.

Workforce Separation by Rolling Month – Status PMV Report (HRMSi)

This report helps you monitor monthly FTE and head count separation. It provides
a view of the Workforce FTE Separation and Workforce head count Separation Key
Performance Indicator data, including target and actual values.

Workforce Summary Analysis Report (HRMSi)

This report is the first in a suite of reports that enables you to investigate workforce in
your enterprise. You can review the losses, gains and total workforce you have in
different organizations within your enterprise.

Competencies, Qualifications and Development

Competence (Skill) Development Detail – Competence Delivered by Training Activity

This worksheet enables you to view competencies delivered by training activities and
events. The resulting information allows you to compare the competencies delivered by
training to those required, and to analyze training efficiency.

Competence (Skill) Development Detail – Competence Requirement

This worksheet displays competence requirements for all organizations within a
Business Group. The worksheet enables you to analyze competence requirements for
Business Groups, organizations, jobs, positions, and grades. For each requirement you
can investigate the competencies needed for a particular job, and the skills shortages
within an organization.
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Competence (Skill) Development Detail – Person Competence Profile

This worksheet enables you to analyze employee competency profiles by type. It allows
you to view employees with similar competencies, and compare employees of similar
grade.

Competence Levels

This report displays the proficiency levels of employees or applicants for a competence.

Competence Levels (Organization Hierarchy) Detail Analytics by Person with Rank (HRMSi)

This worksheet lists each individual that has the selected competence, and shows you
both the proficiency level they have achieved, and the proficiency level translated
into a proficiency rank.

Competence Levels (Organization Hierarchy) Detail Analytics by Person (HRMSi)

This worksheet lists the individuals who hold a selected competence and their
proficiency levels for that competence.

Competence Match (Organization Hierarchy) Status Analytics by Organization and Location (HRMSi)

This worksheet enables you to see the each person’s level of proficiency for the
competencies for their job, grouped by organization and location.

Competence Match (Organization Hierarchy) Status Analytics by Person (HRMSi)

This worksheet enables you to see individuals’ proficiency levels.

Competence Match (Organization Hierarchy) Status Analytics by Person Graph (HRMSi)

This worksheet breaks down each competence relevant to the selected job into
percentages below, within, and above the required proficiency ranges for the job. It
shows how an individual’s competencies map to the requirement range.

Competence Match (Organization Hierarchy) Status Analytics Compare to Minimum Proficiency (HRMSi)

This worksheet compares people’s proficiency levels with the minimum proficiency
requirement for each competence relevant to their job.

Competence Match (Organization Hierarchy) Status Analytics Compare to Range (HRMSi)

This worksheet compares people’s proficiency levels to the required proficiency range
for each competence relevant to their job.

Group Competencies Report (HRMSi)

For each job and grade this report displays the proficiency levels for your employees or
applicants in each required competence.

Individual Competencies Report (HRMSi)

This report is run from the Group Competencies report. This report compares an
individual’s competencies against the required competencies for the job and grade they
hold. If your employee does not have the proficiency level you require, a training course
may exist to help. By clicking on a competence, you can run the Training Classes By
Competence report to display courses that offer the selected competence.
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Learning Management

Delegate Chargeback (Training Center Hierarchy) Detail – Delegate Chargeback (OLM)

This worksheet investigates the amount transferred between two cost centers within an
enterprise for internal student enrollments.

Employee Training Attendance Success (Organization Hierarchy) Status Analytics by Geography Area
(HRMSi)

This worksheet investigates how successfully employees in different geographical areas
are attending training courses.

Employee Training Attendance Success (Organization Hierarchy) Status Analytics by Organization
(HRMSi)

This worksheet investigates how successfully employees in different organizations
are attending training courses.

Employee Training Attendance Success (Organization Hierarchy) Template Analytics by Year (HRMSi)

This worksheet enables you to see training success for each year. The template
worksheets provide a starting point for developers to create analytic reports.

Employee Training Attendance Success (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet calculates the training success rates for training events with the same start
and end dates, for attendees in each organization, location, job, grade, and position. The
template worksheets provide a starting point for developers to create analytic reports.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Bi Month (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by bimonthlies.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Month (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by months.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Quarter (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by quarters.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Semi Year (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by semi-years.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Year (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by years.
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Event Player Progress – by Player Status (OLM)

This worksheet investigates the progress of your Oracle Learning Management hosted
training events by the number of delegates at each Player Status. The Player Status
categories are Completed, Passed, Incomplete, Not Attempted, and Failed.

Event Player Progress – by Total Time Taken Status (OLM)

This worksheet investigates the progress of your Oracle Learning Management hosted
training events by the total time that delegates have been playing content of a course
within the OLM player.

Event Player Progress – Completion Summary (OLM)

This worksheet presents all relevant completion details for OLM training events.

Event Ranking Status – by Attendance (HRMSi)

This worksheet enables you to analyze the popularity of training events by ranking them
by course attendance.

Event Ranking Status – by Event Days (HRMSi)

This worksheet enables you to investigate the popularity of training events by ranking
them by event days.

Event Resource (Training Center Hierarchy) Detail – Booked Resources per Event

This worksheet enables you to analyze the resources booked for specific training events.

Event Resource (Training Center Hierarchy) Detail – Event Enrollments

This worksheet enables you to investigate the number of students who enroll on an
event, and the number of students who successfully attend the event.

Event Resource (Training Center Hierarchy) Detail – Events Without Trainer

This worksheet enables you to investigate the training events that have no associated
trainer.

Event Resource (Training Center Hierarchy) Detail – Events Without Venue

This worksheet enables you to investigate training events that have no associated venue.

Event Resource (Training Center Hierarchy) Detail – Overbooked Resources

This worksheet enables you to analyze overbooked resources.

Event Resource (Training Center Hierarchy) Detail – Required Resources Missing

This worksheet enables you to investigate the resources that are required but have not
been booked for a training event.

Event Resource (Training Center Hierarchy) Detail – Resource Checklist

This worksheet displays the list of resources required to successfully run a training
event activity.
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Event Resource (Training Center Hierarchy) Detail – Resource Schedule

This worksheet enables you to view the schedule for each training resource, to ensure
that resources are not booked for more than one event at any one time.

Event Resource (Training Center Hierarchy) Detail – Suppliable Resources

This worksheet enables you to analyze the cost and availability of suppliable resources
for your training event.

Event Resource (Training Center Hierarchy) Detail – Training Events

This worksheet enables you to investigate the location, start date, and duration of
specific training events.

Player Progress Detail – by Player Status (OLM)

This worksheet enables you to analyze the progress of delegates on your OLM hosted
training events by Player Status.

Player Progress Detail – by Total Time Taken Status (OLM)

This worksheet investigates the progress of individual delegates on your OLM hosted
training events, by the total time they have been playing content using the OLM player.

Student Attendance (Internal) Detail – Attendance Summary

This worksheet enables you to analyze the number of internal students attending
training events. You can view internal student attendance by activity type, analyze
success rates and information about failures.

Student Success (External) Status – by Company (HRMSi)

This worksheet enables you to analyze the success of training hours delivered to external
students for a company. You can investigate this for a business group and year.

Student Success (External) Status – by Company and Year (HRMSi)

This worksheet enables you to analyze the success of training hours delivered to external
students for a company, for different years. You can investigate this for a Business
group and each company.

Student Success (Internal) Trend – by Job and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to internal
students for a job by year, and the success of these hours. You can investigate student
success rates for a Business Group and organization within your enterprise.

Student Success (Internal) Trend – by Job Category and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to
internal students each year for a job by category, and the success of these hours. You
can investigate student success rates for a Business Group and organization within
you enterprise.
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Student Success (Internal) Trend – by Location and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to internal
students for a location each year, and the success of these hours. You can investigate
student success rates for a Business Group and organization within your enterprise.

Student Success (Internal) Trend – by Organization and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to internal
students each year, and the success of these hours. You can investigate student success
rates for a Business Group and organization within your enterprise.

Training Classes by Competence (HRMSi)

This report is run from the Individual Competencies report. This report enables you to
investigate training classes that provide a selected competence. The report displays the
course time, the competence level delivered, the dates the course is run , the class title
and status, the number of class places, the class venue and the cost.

Training Cost and Revenue Analysis – by Competence (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities by the
competence achieved if a student successfully completes the activity.

Training Cost and Revenue Analysis – by Sponsoring Organization (HRMSi)

This worksheet enables you to analyze the cost and revenue of training events for
different organizations, by Business group and year.

Training Cost and Revenue Analysis – by Sponsoring Organization and Year (HRMSi)

This worksheet enables you to analyze the costs and revenue associated with training
for different years. You can investigate costs and revenue for a Business Group and
sponsoring organization.

Training Cost and Revenue Analysis – by Training Activity (HRMSi)

This worksheet enables you to analyze the cost and revenue generated by training
events. You can investigate training activities for a specific Business Group, sponsoring
organization and year.

Training Cost and Revenue Analysis – by Training Activity and Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities for
different years, by Business group and sponsoring organization.

Training Cost and Revenue Analysis – by Training Category (HRMSi)

This worksheet enables you to analyze the cost and revenue of training events for a
training category. You can investigate costs and revenue for a Business group, sponsoring
organization, and year.

Training Cost and Revenue Analysis – by Training Center (HRMSi)

This worksheet enables you to analyze the costs and revenue of a training event for a
training center, by Business Group, sponsoring organization and year.
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Training Cost and Revenue Analysis – by Training Center and Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities for
different years. You can investigate by Business group, sponsoring organization, and
training center.

Training Cost and Revenue Analysis – by Training Category and Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training events in
different years. You can investigate costs and revenue for a Business Group, sponsoring
organization, and training category.

Training Cost and Revenue Analysis – Competence by Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities by
competence and year.

Training Course Ranking by Amount Status – Course Ranking by Amount (HRMSi)

This report investigates the total amount of money generated by enrollments on each
training event, and allows training events to be ranked by the enrollment amount
generated.

Training Success (HRMSi)

This report enables you to investigate how successfully employees are attending training
courses for a particular organization, location, job, and job category. You can also display
your PMF targets by selecting a business plan.

Training Success Analysis – by Competence (HRMSi)

This worksheet enables you to investigate the success rate of a training activity by
competencies. You can investigate competencies for a sponsoring organization and year.

Training Success Analysis – by Sponsoring Organization (HRMSi)

This worksheet enables you to investigate the training success rate of training events
for different sponsoring organizations.

Training Success Analysis – by Training Activity (HRMSi)

This worksheet enables you to investigate the success rate of different training
activities. You can investigate training activities by year and sponsoring organization.

Training Success Analysis – by Training Category (HRMSi)

This worksheet enables you to investigate the training success rate of events by training
category. You can investigate different training categories for a Business Group and year.

Training Success Analysis – by Training Center (HRMSi)

This worksheet enables you to investigate the training success rate of different training
centers, by Business Group and year.
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Training Success Analysis – for a Competence by Year (HRMSi)

This worksheet enables you to investigate the training success rate of training activities
for a competence over a number of years. You can investigate a competence for each
sponsoring organization.

Training Success Analysis – for a Sponsor Organization by Year (HRMSi)

This worksheet enables you to investigate the training success rate of training events for
a sponsoring organization for each year.

Training Success Analysis – for a Training Activity by Year (HRMSi)

This worksheet enables you to investigate the success rate of training activities each
year. You can investigate training activities by Business Group and activity.

Training Success Analysis – for a Training Category by Year (HRMSi)

This worksheet enables you to investigate the training success rate of a training event
in different years. You can analyze training success for a Business Group and training
category.

Training Success Analysis – for a Training Center by Year (HRMSi)

This worksheet enables you to investigate the training success rate of a training center
over a number of years. You can analyze success by Business Group and training center.

General Compensation Structures

Element Link Details Report (Payroll)

The eligibility criteria for an element or group of elements.

Salary and Grade Related Pay and Progression

Average Salary By Group Report (HRMSi)

This report enables you to investigate the average salaries for different groups of
employees. You can also select which area of your enterprise you want to investigate.

Average Salary Trend Report (HRMSi)

This report reviews salary trends in different areas of your enterprise. It displays
the average salary of all your employees who match the selection criteria. You can
investigate the trends in average salaries for different organizations, jobs, grades, and
locations. You can also choose the currency you want to view the salaries in, and include
or exclude salaries that are not paid in your chosen currency.

Current and Projected Progression Point Values Report

The expected results of running the Increment Progression Points process, that is the
projected point and value changes for a group of employees.
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Employee Increment Results Report

The actual results of running the Increment Progression Points process, that is
progression point and value changes for a group of employees.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies, United States Specific)
Detail – by Organization Hierarchy (US)

This worksheet enables you to report on employee details, based on the employee
primary assignment in the United States legislation, for a given organization and its
subordinate organizations.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies) (United States
Specific) Detail – by Supervisor Hierarchy (US)

This worksheet enables you to report on employee details based on the employee
primary assignment in the United States legislation, for a given supervisor and his/her
subordinates.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies) Detail – by
Organization Hierarchy

This worksheet enables you to report on employee details based on the employee
primary assignment (in a non-legislative specific format) for a given organization and
its subordinate organizations.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies) Detail – by Supervisor
Hierarchy

This worksheet enables you to report on employee details based on the employee
primary assignment (in a non-legislative specific format) for a given supervisor and
his/her subordinates.

Employee Primary Assignment with Salary (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee details based on employee primary
assignment, in a non-legislative specific format, for a given organization and its
subordinate organizations.

Employee Primary Assignment with Salary (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee details based on employee primary
assignment, in a non-legislative specific format, for a given supervisor and his/her
subordinates.

Employee Salary (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by bimonthly.

Employee Salary (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by month.
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Employee Salary (Organization Hierarchy) Trend Analytics by Month and Organization (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by month and organization.

Employee Salary (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by quarter.

Employee Salary (Organization Hierarchy) Trend Analytics by Quarter and Organization (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by quarter and organization.

Employee Salary (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by semi-year.

Employee Salary (Organization Hierarchy) Trend Analytics by Year and Organization (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by year and organization.

Employee Salary (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by year.

Employee Salary and Grade Range (Organization Hierarchy) Trend Analysis Full Details (HRMSi)

This worksheet compares employees’ salaries to their grade minimum, mid, and
maximum points, and displays the value required for the employee’s salary
to reach the next point in the grade. It also includes details of employees’
organization, location, job, and position.

Employee Salary and Grade Range (Organization Hierarchy) Trend Analysis Graph (HRMSi)

This worksheet displays a table and a chart that compare each employee’s salary to the
minimum, mid, and maximum points for their grade.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Age Band (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by Age Band.

Employee Salary by Group (Organization Hierarchy) Status Analytics by GB Ethnic Group (HRMSi) (UK)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by UK ethnic group.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Gender (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by gender. Employee Salary by Group (Organization Hierarchy)
Status Analytics by US Ethnic Group Worksheet (HRMSi) (US) This worksheet enables
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you to investigate the average salaries of different groups of employees, grouped by
US ethnic group.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by grade.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet enables you to investigate the average salaries of different groups
of employees, grouped by job.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Length of Work Band (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by Length of Work Band.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Location (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by location.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet enables you to investigate the average salaries of different groups
of employees, grouped by organization.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Performance Rating (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by performance rating.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by position.

Employee Salary by Group (Organization Hierarchy) Status Analytics by US Ethnic Group (HRMSi) (US)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by US ethnic group.

Employee Salary by Job and Grade (Multiple Hierarchies) Status – by Organization Hierarchy (HRMSi)

This worksheet enables you to compare employee salaries for each job and grade. For a
given organization and its subordinate organizations, the average, minimum, and
maximum employee salaries for jobs and grades are shown.

Employee Salary by Job and Grade (Multiple Hierarchies) Status – by Supervisor Hierarchy (HRMSi)

This worksheet enables you to compare employee salaries for each job and grade. For
a given supervisor and his/her subordinates, the average, minimum, and maximum
employee salaries for jobs and grades are shown.
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Employee Salary Change (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee salary change details by organization
for a given time period.

Employee Salary Change (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee salary change details by supervisor
for a given time period.

Employee Salary Change Detail – by Gender

This worksheet enables you to analyze salary change within your organization, by
gender. It allows you to analyze differences in salary changes between male and female
employees across organizations.

Employee Salary Change Detail – by Performance Rating

This worksheet enables you to investigate the effects of performance ratings on
employee salary change across organizations. It allows you to ensure employees are
rewarded for performance.

Employee Salary Change Detail – by Person

This worksheet enables you to investigate salary changes for individual employees.

Employee Salary Change Detail – by Years of Service

This worksheet displays salary change information by years of service across
organizations. The resulting information allows you to compare salary change across
Business Groups and organizations, and view salary change information by length of
service.

Employee Salary Change Detail – Summary

This worksheet enables you to view information about salary changes within your
organization. The resulting information allows you to analyze salary changes across
all organizations in a Business Group.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different bimonthlies.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Month (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different months.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different quarters.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different semi-years.
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Employee Salary Component (Organization Hierarchy) Trend Analytics by Year (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different years.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Age (HRMSi)

This worksheet investigates the spread of salaries across employee ages.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Grade (HRMSi)

This worksheet investigates the spread of salaries within grades.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Job (HRMSi)

This worksheet investigates the spread of salaries within jobs.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Length of Service (HRMSi)

This worksheet investigates the spread of salaries within Length of Service bands.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Location (HRMSi)

This worksheet investigates the spread of salaries within locations.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Organization (HRMSi)

This worksheet investigates the spread of salaries within organizations.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Performance Rating (HRMSi)

This worksheet investigates the spread of salaries across performance ratings.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Position (HRMSi)

This worksheet investigates the spread of salaries within positions.

Employee with Tenure (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee tenure details (based on the employee
primary assignment in a non-legislative specific format) for a given organization and
its subordinate organizations.

Employee with Tenure (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee tenure details (based on the employee
primary assignment in a non-legislative specific format) for a given supervisor and
his/her subordinates.

Headcount and Salary Trend (HRMSi, DBI)

This report shows changes in head count and salaries over time for the selected top
line manager.

Headcount and Salary by Country (HRMSi, DBI)

This report displays the total employee head count, percentage headcount
change, average salary and percentage average salary change for the countries with the
highest head count for the selected top line manager.
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Headcount and Salary Detail (HRMSi, DBI)

This report lists the employees and their salary that comprise the Total Salary value you
drilled from the Salary by Job Family Status report. This report displays the salaries in
both their local currency and in the DBI primary or the global currency.

Salary (HRMSi, DBI)

The Salary report displays the employee total salary, average salary, and salary change
percent of all direct reports for the selected top line manager.

Salary by Job Function Status (HRMSi, DBI)

This report is similar to the Salary report, except that it presents a view of the selected
manager’s employees by job function. You can access this report from the Total Salary
column in the parent Salary report.

Salary by Job Family Status (HRMSi, DBI)

This report is similar to the Salary report, except that it presents a view of the selected
manager’s employees by job family. You can access this report from the Job Function
names in the Salary by Job Function report.

Salary and Grade Range Report (HRMSi)

Using Oracle HRMS you can define the minimum, mid points and maximum salaries for
different grades in your enterprise. This report enables you to investigate how salaries
relate to grade rates, including which employees are paid more than the maximum for
their grade, which employees are paid below the mid point or maximum for their grade
and by how much, and what would be the cost of increasing a group of employees to the
mid point or maximum for their grade.

Salary Component Trend Report (HRMSi)

The amount your enterprise spends on salaries is likely to change over time. Oracle
HRMS enables you to record a reason for each salary increase you give to an
employee. Use the Salary Component Trend report to investigate the total cost of salary
changes for each change component you have identified.

Salary Distribution Within Grade Range PMV Report (HRMSi)

This report provides a view of the Workforce Below Grade Mid Point and Workforce
Above Grade Mid Point Key Performance Indicator data. The report displays table data
by default; you can optionally display the chart.

Salary Review Report

Current, past and proposed salaries for a selected list of employees.

Salary Spread Report (HRMSi)

Within your enterprise it is useful to know the salary ranges for different groups of
employees. This report investigates the spread of salaries by four different criteria: age
(in years), length of service (in years), grade, and Performance Rating.
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Salary Survey Comparison – Salary Survey Mappings (HRMSi)

This worksheet enables you to analyze salary surveys, which have been mapped
to particular jobs or positions.

Salary to Grade Range Mid Point Variance PMV Report (HRMSi)

This report provides a view of the Salaries Varying From Grade Mid Point Key
Performance Indicator data. The report displays table data by default; you can optionally
display the chart.

Compensation and Awards Management

Compensation Workbench Progress Report

This report checks the progress of the compensation cycle for an availability period
and plan that you select. If you run the report after the Compensation Workbench
Pre-Process, it provides information about employee eligibility. If you run the report
after the Compensation Workbench Post Process, it summarizes the rates assigned
to each employee.

Mass Awards Deselection (FD)

Lists employees deselected for a mass award

Mass Awards Listing by Employees (FD)

Notification of Personnel Action in list form for an individual employee selected for a
mass award

Mass Awards NPA Listing for All Employees (FD)

Notification of Personnel Action in list form for employees selected for a mass award

Mass Award Preview (FD)

Lists employees selected for a mass award

Mass Salary Deselection (FD)

Lists employees deselected for a salary adjustment

Mass Salary PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a salary
adjustment

Mass Salary PA Listing for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
salary adjustment

Mass Salary Preview (FD)

Lists employees selected for a salary adjustment
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Leave and Absence Management

Absence Action List Report

Details the re-integration actions to be performed for employees.

Absence Hours Report (HRMSi)

This report investigates the absence hours recorded for employees in your enterprise. You
can select the employees you want to run the report for by organization, location, job
category, job, and grade. You can also run the report for the time period of your choice.

Absence Report (FR)

Lists the details regarding the employer, absences and the salaries received by the
employee over a reference period for reporting to the French Local Social Security
(CPAM).

Absence Report (HU)

Lists the normal and sickness holiday days an employee is entitled to annually.

Absences Report

Absence details for an employee or organization, for some or all absence types.

Daily Sick and Recovery Report (Netherlands)

Details all new instances of sick employees and all employees who have recovered
from an illness.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by bimonthly.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by month.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by quarter.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by semi- year.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by year.
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Employee Hours Worked (Organization Hierarchy) Trend Analytics by Payroll Period (HRMSi)

This worksheet investigates the number of overtime and regular hours worked. The
worksheet displays the number of hours worked for each overtime band you use in your
enterprise, such as double time or time-and-a-half.

Employees on Leave (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employees who are on leave on the effective date
chosen. Employees are listed for a given organization and its subordinate organizations.

Employees on Leave (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employees who are on leave on the effective
date chosen. Employees are listed for a given supervisor and his/her subordinates.

Hours Worked Report (HRMSi)

This report investigates the number of overtime and regular hours worked. The
report displays the number of hours worked for each overtime band you use in your
enterprise, such as double time or time-and-a-half. You can run the report for a selected
time period.

Leave Details Report (Payroll) (South Africa)

This report is used for monitoring and analyzing employee absences (sample report).

Leave Liability Report (Payroll) (AU)

Displays leave balances for employees.

Leave Liability Report (NZ)

Displays the accrued debt owed by an organization for the leave balances of their
employees.

Leave Liability Report (Payroll) (South Africa)

Calculates monetary value of accrued leave (sample report).

Maximum SSP Weeks Report (UK)

Provides details of employees who have had absences for 22 weeks or longer, enabling
you to monitor long periods of incapacity for work (PIWs) which have reached, or are
approaching, the maximum number of weeks that SSP can be paid.

Open Sickness Absences Report (UK)

Provides information on current sickness absences.

SAP Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

SMP Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.
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SPP Adoption Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

SPP Birth Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

SSP Element Result Listing (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

Statutory Adoption Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Maternity Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Paternity Birth Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Paternity Adoption Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Sick Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Health and Welfare Management

COBRA Benefit Initial Information (US)

This report--typically sent to employee new hires--provides general information about
COBRA.

COBRA Benefits Notification Letter (US)

This report provides electable choice information to persons who are eligible for COBRA.

COBRA Coverage or Payments Report (US)

Coverage of payments report.

COBRA Standard Letters (including Expiration and Grace Period Expiration) (US)

Publish a standard COBRA letter.
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COIDA Report (Payroll) (South Africa)

Compensation for Occupational Injuries & Diseases Act report.

Eligibility and Enrollment List

Run this report to list the total number of eligible and enrolled participants in plans
you administer for Standard and Advanced Benefits, Individual Compensation
Distribution, and Compensation Workbench. The report also lists newly ineligible
and de-enrolled participants.

HIPAA Dependent Letter (US)

Run this report to generate a HIPAA certificate for qualified dependents only, such as for
instances where a dependent ages out of a plan.

HIPAA Letter (US)

Run this report to generate a HIPAA certificate for qualified participants and their
dependents

Life Events Summary Report

Run this report to analyze life events that occur to your compensation and benefits
participants. The report lists the total number of potential and active life events, and
their status, for a specified period.

Premium Reconciliation Report

Run this report to support the monthly benefits billing reconciliation process. This report
compares monthly premium amounts to standard rates and element entries by pay
period, for all participants enrolled during the reporting period.

Other Payroll Earnings and Deductions

Union Deductions Report (Payroll) (UK)

Total deductions that your employees pay to unions.

Payrolls

Payroll Statutory Calendar Report (Payroll) (UK)

The sequence of regular payment dates for each payroll and the numbers of assignments
completed, pre-paid and paid within a run.

Payroll Report (Check list for Unemployment Insurance) (Payroll) (Japan)

This is a list to check details of unemployment insurance insured employee

Payroll Report to Create File-Notification Change Address for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance office
when an insured employee’s address is changed.
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Payroll Report to Create File-Notification of Disqualification for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance
office when the insured employee loses qualification because of some reason
(termination, death, etc.)

Payroll Report to Create File-Notification of Geppen for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance office
when an employee’s social insurance premiums are changed without waiting for the
following regular determination because of rise in pay etc.

Payroll Report to Create File-Notification of Qualification for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance
office when the person applicable to Article 9 of Welfare Pension Insurance Law or the
10th article is employed.

Payroll Report to Create File-Notification of Santei for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance
office when an employee’s social insurance premiums in and after October of the year
are determined based on their earnings.

Payroll Payment and Distributions

Advance Pay Listing (Payroll) (UK)

Details of the advance pay periods for employees due to receive advance pay.

Cheque Listing (Payroll) (South Africa)

Cheque payments made to employees.

Coinage Analysis Report (Payroll) (South Africa)

A cash analysis which provides a breakdown of the cash required.

Credit Transfer Payments Report (Payroll) (South Africa)

Paid/unpaid cheque values per bank branch.

Deduction Register Report (Payroll) (South Africa)

Deductions per element per employee.

Deposit Schedule Report (Payroll) (South Africa)

For credit transfer payments into bank accounts.

Employment Equity Income Differential Report (Payroll) (South Africa)

Outlines the required information needed for Employment Equity as defined by the
Department of Labour.
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Gross to Net Summary (Payroll) (UK)

Details of total earnings and deductions summarized for a specified payroll and payroll
period.

Gross to Net Summary (Payroll) (US)

Details of total earnings and deductions summarized for a specified payroll and payroll
period.

Manual Payments Report (Payroll) (South Africa)

Manual payments made for selected payruns and assignments.

Pay Advice (Payroll) (AU)

Generates pay advice for all employees for a specified payroll and period.

Pay Advice (Payroll) (Singapore)

Provides pay advice details in a customizable format, either for single assignments or all
assignments on a payroll, after PrePayments process is complete for the payroll.

Pay Advice (Payroll) (South Africa)

A sample pay advice.

Pay Advice (Payroll) (France)

Presents Pay Advice details in a customizable format, either for single assignments or for
all assignments on a payroll after PrePayments process is complete for the payroll.

Pay Advice (Payroll) (NZ)

Generates pay advice for all employees for a specified payroll and period.

See: Oracle HRMS for New Zealand User Supplement.

Pay Advice (Payroll) (Hong Kong)

Details about employees’ income and deductions.

Pay Advice (Payroll) (UK)

Pay advice details in a customizable format, either for single assignments or for all
assignments on a payroll after PrePayments process is complete for the payroll.

Payment Output File (Dutch)

Run this report to initiate the creation of the EFT Payment file. Produced in the format
required by the official body Interpay, the EFT Payment file enables you to send
employee payment details to your bank on magnetic tape.

RSC Levy Report (Payroll) (South Africa)

The amount of levies to be paid per RSC region.
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Saudi Payment Output File (Payroll) (SA)

Run this report to initiate the creation of the EFT Payment file. The EFT Payment file
enables you to send employee payment details to your bank on magnetic tape.

Saudi Payslip Report (Payroll) (SA)

Use this report to generate both online and printed payslips for employees. Online
payslips enable employees to view their payslips information online, and helps reduce
overheads, administration, and maintenance costs.

Skills Development Levy Report (Payroll) (South Africa)

Skills development levy per SETA or per organization within SETA.

Statement of Earnings (Payroll) (US)

Check writer process produces paychecks with statement of earnings.

Separation Pay E-file Report (Payroll Korea)

Oracle Payroll generates a report about separation pay, based on the Separation Pay
Archive. Once generated, the employer can view, and print the report, and store it on
magnetic tape to send to National Tax Service (NTS).

Separation Pay Slip Report (Payroll Korea)

Run this report to generate a pay slip with the earnings and deductions summary for all
employees who left the enterprise, for a specified payroll and period. This generated pay
slip report is then submitted to the National Tax Service (NTS).

Separation Pay Tax Receipt Report (Payroll Korea)

Run this report to generate the separation pay tax receipt for all employees who left the
enterprise, for a specified payroll and period, and submit the generated report to the
National Tax Service (NTS). The report contains detailed information like income tax and
resident tax for received payments at the time the employee leaves the enterprise.

Additional Wages CPF Capping Report (Payroll Singapore)

The Additional Wages CPF Capping report shows whether an employee has overpaid
or underpaid their Central Provident Fund (CPF) contributions on additional
wages. Employees who have overpaid CPF are eligible to claim this amount from the
Central Provident Fund Board.

Payroll Statutory Deductions and Reporting

Archive P11D (HR and Payroll) (UK)

Runs the Legislative Report Generator to generate details of Class 1A NICs for reporting
to the Inland Revenue.

Deduction Report (Payroll) (US)

The Deductions report always shows details for each run within the selected time frame
by deduction classification, deduction type, and employee information. This information
can be sorted by GRE, Location, or Organization
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Employee Income Payment Detail Report (China)

Contains detailed information for the summarized information provided in the
Individual Income Tax Withholding report.

Employee Listing (Hong Kong)

List of current employees with information such as employee name, identity card
number, passport number, work permit number and expiry date, and the date an
employee joined the company.

Employer Monthly Schedule Report (New Zealand) (NZ)

Lists the details of all employees and is submitted to Inland Revenue.

FBT Report (Australia) (AU)

Displays Fringe Benefits Tax information for a cost center.

Individual Income Tax Withholding Report (China)

Provides summarized information for all tax group rates separately.

Inland Revenue Arrears Payment Report (NZ)

Lists employees who are required to pay student loans or child support arrears to
Inland Revenue.

Inland Revenue Form IR21 (Payroll) (Singapore)

Summarizes an employee’s organization, personal details, and earnings and benefits in
the two years prior to leaving the organization.

Inland Revenue Remittance Certificate Report (NZ)

Submitted to Inland Revenue by employers who are required to make PAYE
payments, or employers who are Specified Superannuation Contribution Withholding
Tax (SSCWT) payers.

IR56B Report (Payroll) (Hong Kong)

A statement of earnings for each employee used by the Inland Revenue to assess
individual statements and forward an account to the employee for tax payable for
the past financial year.

IR56E Report (Payroll) (Hong Kong)

Submitted for new hires, and includes information such as an employee’s personal
information, including their name, identification details, address, the employee’s legal
employer details and employment information.

IR56F Report (Payroll) (Hong Kong)

A notification by the employer about an employee who is leaving the enterprise but
intending to stay in Hong Kong.
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IR56G Report (Payroll) (Hong Kong)

A notification by the employer about an employee who is leaving the enterprise and
also departing from Hong Kong.

IRP5 Tax Certificate (Payroll) (South Africa)

Tax certificates for employees who have paid tax during this tax year.

IT3(a) Tax Certificate (Payroll) (South Africa)

Tax certificates for employees who have paid no tax during this tax year.

MPF Remittance Report (Payroll) (Hong Kong)

A contribution report submitted to the Mandatory Provident Fund (MPF) Trustee
detailing contributions for the period.

National Service In-Camp Training Computation (Payroll) (Singapore)

Calculates the pay amount that an employer can claim from the Ministry of Defence for
an employee who is attending mandatory National Service In-Camp Training.

Health Insurance Premium Adjustment Annual Earnings Archive Process (Payroll Korea)

Stores information about the employees’ previous year’s earnings and the number of
months worked in the previous year, and to produce an E-file that will be sent to the
National Health Insurance Corporation (NHIC).

Health Insurance Adjustment Report for Leaving Employees (Payroll Korea)

The Health Insurance Adjustment for Leaving Employees report is run for all the
employees leaving the enterprise and the report is then sent to National Health Insurance
Corporation (NHIC). The report contains information such as the employees’ previous
year’s income and the number of months the employee was employed in the enterprise.

NHIC uses this information to calculate and adjust the premium amount an employee
must pay before leaving the enterprise.

National Pension Adjustment Annual Earnings Archive Process (Payroll Korea)

Stores information about the employees’ earnings and the number of months worked
in the previous year, and to produce an E-file that will be sent to the National Pension
Corporation (NPC)

NPC uses this information to recalculate the pension and notify the enterprise about the
new pension due for the current year.

National Pension Adjustment Report (Payroll Korea)

The National Pension Adjustment report is run for all the employees whose status has
changed (newly hired or terminated workers) since the last report, and then send the
report to the National Pension Corporation (NPC).

The NPC uses this information to calculate and adjust a new premium for the worker.
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Statutory Deduction Adjustment Information - Upload Process (Payroll Korea)

You upload payroll adjustment information sent by the National Pension Corporation
(NPC) and the National Health Insurance Corporation (NHIC) by uploading the text file
and placing it in a directory where it can be read by the upload process. The application
reads the data and loads into the Batch Element Entry (BEE) tables. These agencies send
your enterprise these details as a text file.

NI Car Detail Report (Payroll) (UK)

All the NI Y amounts due from employees on a given payroll who have company
car benefits.

NICable Benefits Summary Report (UK)

Lists the employee benefits for which the employer is liable for NI contributions.

P30 Report (Payroll) (Ireland)

PAYE and PRSI information for issue to the tax office each calendar month.

P35 Report (UK)

PAYE and PRSI information for all employees including leavers for issue to the tax
office at the end of the tax year.

P45 Alignment Report (Payroll) (UK)

Draft printer alignment for P45 reports.

P45 Report (Payroll) (UK)

P45 details for terminated employees for issue to the tax office and the leaver; P45 details
for current employees for issue to different tax offices.

P45(3) & P46 Exceptions Report (UK)

Enables you to identify those employees for whom a P45(3) or P56 has not been
created, yet have been paid since their initial hire date.

P46 (P160) Pension Notification (UK)

Enables you to provide information on recipients of taxable pensions, and those gaining
extra income while collecting a pension.

P60 Report (Payroll) (UK)

P60 details for employees employed by the business at the end of the tax year.

Quarterly Employment Survey (NZ)

Extracts information to enable the Statistics New Zealand quarterly employment survey
to be completed.

Report on Hirings (CA)

You submit this monthly report to Human Resources Development Canada (HRDC) as
part of a government insurance program designed to deter and detect overpayments.
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Saudi Monthly Contributions Report (Payroll) (SA)

Use this report to create a list of employers’ (on behalf of employees) contributions to
GOSI for the contributory month. This enables the GOSI office to keep track of employee
head count and their contributions to GOSI.

Saudi New and Terminated Workers Report (Payroll) (SA)

Use this report to provide monthly updates to the GOSI office about new and terminated
employees for the specified month.

Saudi Workers Movement Report (Payroll) (SA)

Use this report to create a list of employees’ movement for the specified month. This
enables the GOSI office to keep track of newly hired employees, (with and without
GOSI number) and terminated employees.

Summary of Tax Certificates (Payroll) (South Africa)

Summary of totals for each SARS code per preprocess.

Superannuation Contribution Report (AU)

Identifies monthly figures for superannuation salary and employer superannuation
guarantee contributions.

Tax Certificate Number Report (Payroll) (South Africa)

Lists the generated tax certificate numbers and their assignment details, and the number
of tax certificates issued and reissued.

Tax Office Report for Manual Completion (NL)

Enables you to generate the tax office report, print it out, and manually complete the
remaining sections before sending it out to your tax office.

Tax Payments Listing (Payroll) (UK)

Details of employees’ PAYE and National Insurance deductions.

Tax Register Report (Payroll) (South Africa)

Tax-related information and balances for current employees and ex-employees.

File-Tax Withheld Report (Payroll) (Japan)

This notification file details the total income tax withheld from an employee’s
earnings. Created by the legal employer to send the relevant local government.

Final Notice of Fixed Labor Insurance Fee Report (Payroll) (Japan)

This is the total list of wages for employees with breakdown of each month, and is
submitted by the business proprietor to the relevant Labor Standards Inspection Office
in May.
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Local Tax Withheld Report (Payroll) (Japan)

This report details the total income tax withheld from an employee’s earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant local
government.

Notification Change Address for National Pension Type 3 Insured Report (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an employee’s insured dependent’s (=National Pension Type 3rd insured’s)
address is changed.

Notification to Change Address for Welfare Pension Insurance Report (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an insured employee’s address is changed.

Notification to Change Address for Welfare Pension Insurance Report (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an insured employee’s address is changed.

Payroll Report (Notification for Geppen) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an employee’s social insurance premiums are changed without waiting for the
following regular determination because of rise in pay etc.

Payroll Report (Notification for Santei) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an employee’s social insurance premiums in and after October of the year are
determined based on their earnings.

Payroll Report (Notification of Deduction for Dependents) (Payroll) (Japan)

This notification details employee’s dependents so that he/she can receive deduction
of a tax reduction for spouses, allowance for dependent, credit for handicapped
person, etc. The legal employer receives this from employees before YEA period and
must keep this in case the tax authority asks to present.

Payroll Report (Notification of Deduction for Ins Premiums, Spouse) (Payroll) (Japan)

This notification details employee’s premiums of life and nonlife insurances so that
he/she can receive insurance premium deduction and special exemption for spouse. The
legal employer receives this from employees before YEA period and must keep this
in case the tax authority asks to present.

Payroll Report (Notification of Dependents for Health Insurance / Notification of Type 3 Insured for
National Pension) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when the details of insured employee’s dependents is changed.
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Payroll Report (Notification of Disqualification for Health Ins/Welfare Pension Insurance) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance
office when the insured employee loses qualification because of some reason like
termination, and death.

Payroll Report (Notification of Qualification for Health Ins/Welfare Pension Insurance) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when the person applicable to Article 9 of Welfare Pension Insurance Law or the 10th
article is employed.

Salary Payment Summary Report (Payroll) (Japan)

This report details the total income tax withheld from all employees’ total earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant local
government.

Si FD Report (Payroll) (Japan)

This is a request set to execute line#2-#6 at once.

Tax Withheld Report (Payroll) (Japan)

This report details the total income tax withheld from an employee’s earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant Japanese
tax authority.

Total Income Tax Withheld Report (Payroll) (Japan)

This report details the total income tax withheld from all employees’ total earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant Japanese
tax authority.

Payroll Processing and Analysis

1099-R Exception Register (Payroll) (US)

Identifies employees who:have negative box 1 totals on the Form 1099-R, or have a zero
box 1 total on the Form 1099-R, but have other negative 1099-R box totals.

1099-R Forms (Payroll) (US)

Provides for printing of retiree 1099-R at an individual level as well as all employees in
a GRE.

1099-R Information Return (Payroll) (US)

Allows printing a single 1099-R or a range of 1099-Rs that you define. Sort options give
you further flexibility in 1099-R distribution.

1099-R Register (Payroll) (US)

Allows viewing the amounts reported in each box of the Form 1099-R for all employees
in a particular GRE for a given year.
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1099-R Register Totals (Payroll) (US)

You can choose to view only the box totals for all selected employees in the report;
individual employees will not be included in the report. Or you can choose to view box
totals in the report for selected individual employees, as well as the totals for these
employees.

Alien Retro Benefits Loss (Payroll) (US)

The Alien Retro Benefits Loss report identifies employees who have earned treaty
benefits that are then revoked.

Alien Retro Benefits Projection (Payroll) (US)

The Alien Retro Benefits Projection identifies employees who are earning alien tax treaty
benefits that could be subject to a retroactive loss at some point in the future.

Annual Unemployment Insurance (Form 940) Information (Payroll) (US)

Provides numbers for annual 940 filing.

Annual FUTA Tax Return (Payroll) (US)

Oracle Payroll provides certain information in the form of a work sheet that you then
transcribe to the official form 940; however, some information must be provided by you.

Audit Report (Payroll)

Selects person, employee or applicant, assignment, element, recurring or non-recurring
status. Shows Business Group, GRE (US only), assignment details, person
entering data (responsibility), input date, effective change date, details of person
affected. Lists all fields changed, with input date and effective date, old value and new
value, responsibility, workstation address.

Cost Breakdown Report for Costing Run (Payroll)

Summarized costing totals for an individual costing.

Cost Breakdown Report for Date Range (Payroll)

Summarized costing totals for all costing runs within a given date range.

Earnings Audit (Payroll) (US)

Report detailing all employees with a particular element being processed in a given
pay period.

Element Result Listing (Payroll)

Run results processed for a particular element over a defined period, and run results for
selected input values of each employee’s last assignment process.

Employee Payroll Movements Report (Payroll)

New hires, terminations, transfers in and transfer out of a selected payroll.
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Employee Run Results (Payroll) (CA, US)

Users may select various elements for the various time frames, assignment of GREs. The
report shows the run results for selected information by pay period.

Employee Run Results Summary Report (Payroll) (UK)

Includes all assignments, gross pay, PAYE, employee’s NI contribution, employer’s NI
contribution, other deductions, total deductions, net pay and total pay for the payroll.

Federal 1099-R (magnetic media) (Payroll) (US)

Creation of Federal 10999R magnetic media.

Federal and State Tax Remittance Reporting (Payroll) (US)

This report shows the federal and state balances summarized for a particular range of
check dates.

Federal W-2 (magnetic media) (Payroll) (US)

Creation of Federal W-2 magnetic media and summary totals.

GRE Totals (Payroll) (US)

Reconciliation report to be used to assist in period end processing balancing
purposes. This report shows Federal and State level taxable balances and withholdings.

Local Tax Remittance Reporting (Payroll) (US)

This report shows the local tax balances summarized for a particular range of check dates.

Multiple Assignments Report (Payroll) (UK)

Lists employees who have been marked for multiple assignment processing and
indicates where Priority Processing Type is not set and cannot be defaulted.

Multiple Worksite Report (US)

Reports on wages and locations of employees in all the multiple locations across all
SUIs and other GREs.

NACHA (magnetic media) (Payroll) (US)

Provides for creation of employee NACHA information to be submitted.

NACHA Report (Payroll) (US)

Detail of employee NACHA information.

Over Limit Reporting (Payroll) (US)

The Over Limit Report identifies employees who have had taxes withheld in excess
of the legal limit.

Pay Advice Alignment Report (Payroll) (UK)

Draft printer alignment for your sample pay advice.
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Payment Register (Payroll) (South Africa)

Payment elements per employee.

Payment Register Detail and Summary Reports (Payroll) (US)

Detail and summary reports listing payments made to employees, listing payment
method, check number, and amount.

Payments Summary Report (Payroll) (UK)

Payments totalled by payment method type and organizational payment method for a
specified payroll and payroll period. Account details for each organizational payment
method are also listed.

Payroll Activity Report (Payroll) (US)

The Payroll Activity report shows employee and group level payroll details.

Payroll Message Report (Payroll)

Display messages for processes connected to specified payrolls.

Payroll Reconciliation Payment Summary Report (Australia)(AU)

Generates payroll reconciliation or end of year processing and for all the legal employers
in that period.

Payroll Reconciliation Summary Report (Australia)(AU)

Generates payroll reconciliation summary report for a specific payroll or quick-pay
run, or for a specific period.

Payment Summary Self Printed Report (AU)

This report enables employers to self print payment summaries on plain paper. This
feature is only available to employers who submit their Payment Summary data to
the ATO electronically.

Payment Summary Validation Report (AU)

This report obtains all information from the archive tables and can be run several times
in a year, against archived data, for data validation. The report lists details that are
normally printed on the Payment Summary.

Payroll Tax Report (Australia)

Run this report to generate a payroll tax report detailing employer’s liability for payroll
tax contributions for a specified month and for a specified Australian state. You must
run your payroll before running this report.

Payroll Reconciliation Report (New Zealand) (NZ)

Generates a payroll reconciliation for a specified payroll period.

Payroll Register (Payroll) (US)

Payroll Register Reporting is used to show employee and group level payroll details
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Retro Notifications Report

Generates an assignment set containing retroactive changes applying to a period for
which payroll processing has already taken place.

Saudi Payroll Register Report (Payroll) (SA)

Use this report to create payroll information for each employee for each payroll
period, and store information for payroll verification, validation, and auditing purposes.

Start of Year: Records Unprocessed Report (Payroll) (UK)

Valid records on the Inland Revenue P9 tape that do not fully match your database
records after running the Start of Year process.

UIF Report (Payroll) (South Africa)

Employee and employer contributions made to the Unemployment Insurance Fund.

W-2 Forms (Payroll) (US)

Prints employee W-2s at an individual level, thus allowing W-2s to be created as
employees terminate, or for an entire GRE.

Year End Negative Balance Reports (Payroll) (US)

Report listing any negative balances found due to user adjustments or conversion issues.

Year End Adjustment e-File Report (Payroll) (Korea)

The generated report is about Year End Adjustment, based on the year end balance
adjustment and archive process to view, and print the report, and store it on magnetic
tape, and send the generated magnetic file to the local tax offices upon their request.

Year End Adjustment Ledger Report (Payroll) (Korea)

Generates the YEA Ledger using Oracle Reports for all three YEA types, Normal, Interim
and Re. You can generate the ledger using three different criteria:

• Business Place

• Payroll Action

• Assignment Action

Year End Adjustment Reclaim Sheet (Payroll) (Korea)

Generates a record with details about YEA tax exemptions and deductions. Oracle
Payroll bases this information on the date the employer enters in the Year End
Adjustment Information window. The enterprise uses it to claim YEA and keeps the
record as documentation for National Tax Services.

Year End Adjustment Tax Receipt Report (Payroll) (Korea)

Generates a YEA tax receipt with details like housing pre-tax deduction and insurance
exemption for a particular payroll action, business place or an assignment set.
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Year End Adjustment Tax Summary Report (Payroll) (Korea)

View the summarized YEA tax details for a business place and period in the generated
report.

IR8S Ad Hoc Printed Archive Report (Payroll) (Singapore)

Generates an IR8S report for validation purposes, before submitting the report to the
IRAS.

Payroll Event Rules

Void Payments (Payroll)

Details of cancelled cheque payments

Deploy Self Service Capability

Notification of Personnel Action (SF 50) (FD)

Prints the standard Notification of Personnel Action for an approved Request for
Personnel Action

Request for Personnel Action (SF-52) (FD)

Prints the contents of the employee’s Request for Personnel Action

Workforce Intelligence

Dutch Assignment SCL FLexfield Upgrade Report (Netherlands)

Run this report to view the information removed and moved by the Dutch Assignment
SCL Flexfield upgrade script.

Processes

A8A File (Payroll) (Singapore)

Creates a file that includes the details of any benefits-in-kind provided to your
employees, for example, car-related benefits, or the cost of running a fax machine. The
process also creates a report for you to view the contributions that are included in the file.

A8B File (Payroll) (Singapore)

Creates a file that records details of any stock options granted to an employee, and any
stock options exercised during a financial period.

ACB Process (Payroll) (South Africa)

Setting up and running ACB.

Advance Pay Batch Setup (South Africa) (Payroll) (South Africa)

Advance Pay Batch Setup.
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Advance Pay Process (Payroll) (UK)

Allows you to pay employees in advance for holidays or other events.

Annual and Long Service Leave Liability Process (Australia) (AU)

Extracts information used in the Leave Liability Report.

ASB CSV Direct Credit Process (New Zealand) (NZ)

Details of all employees that use the direct credit as the payment method.

Audit Trail Update Tables Process

This process is used to set up audit trail on selected tables.

Audit Trail Update Datetracked Tables Process

This process is used to set up audit trail on selected datetracked tables.

BACS Process (Payroll) (UK)

Summarized totals for BACS tape amounts including consolidated totals for multi-day
and multi-file formats.

Batch Print Notification of Personnel Action (FD)

Prints Notifications of Personnel Action (SF-50s) in batch mode.

BEE Batch Process (Purge)

This process is used to delete a batch from the BEE tables on completion of the
concurrent request.

BEE Batch Process (Rollback)

This process is used to completely remove a BEE transfer, provided you have not purged
the batch from the BEE tables

BEE Batch Process (Transfer)

This process is used to create element entries in the Oracle HRMS Entries table from the
existing entries in the BEE temporary tables.

BEE Batch Process (Validate)

This process is used to test each batch line against predefined rules about element
entries, and against any additional validation procedures that you have created.

Bulk Compile Formulas

Run this process to compile all of your formulas.

Calculate Commitment

Run this process to calculate the projected expenditures for a budget over a given
period. You can calculate commitments for an entire budget or for a single position
in a budget.
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Calculate FTE for Assignments page (UK)

This process is used to populate the Assignment Budget Window with FTE values.

Cash Process (Payroll only) (UK)

Enables you to use cash as a payment method and record cash payments to employee
assignments.

CDV Bank Name User Table Setup (Payroll) (South Africa)

Creates the CDV Bank Name User Table.

CDV Data Load Process (Payroll) (South Africa)

Loads CDV data.

Change Person Numbering to Automatic

Run this to process to change the method by which you identify your employees from
manual to automatic number generation

Check Writer Process

Cheque/Check Writer process to determine the generation of cheques/checks for a
specified payroll and consolidation set over a specified time period.

Check Writer Process (Payroll) (US)

This process is used to write sequences of checks for your payroll run.

Cheque Writer Process (Payroll) (South Africa)

Produces cheque payments.

Cheque Writer Process (Payroll)

This process is used to write sequences of cheques for your payroll run.

This process is used to populate the Assignment Budget Window with FTE values.

Child Sequence Generator Process (Germany)

This process generates the sequence number for children. The sequence number is used
in the calculation of the local cost-of-living allowance.

Close Action Items Process (Advanced Benefits)

Run this process before the Close Enrollments Process to close any open action items
that are required or optional for the persons you select.

Close Enrollments Process (Advanced Benefits)

Run this process to close a person’s enrollment after elections have been made.

Collective Agreement Entitlement Evaluation

Run this process to evaluate and apply collective agreement entitlements for an
employee.
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Commitment GL Posting

You run the Commitment GL Posting batch process to transfer budget commitments
from Oracle HRMS to Oracle General Ledger.

Communications Triggers Process (Advanced Benefits)

Use the communications triggers process to generate communications for persons who
meet the selection criteria that you specify.

Compensation Workbench Back-Out Life Events Process

Run this process to remove the results of the Participation Process: Compensation for
a life event associated with Compensation Workbench.

Compensation Workbench Close Enrollment Process

Run this process to close the life event for a Compensation Workbench plan.

Compensation Workbench Post Process

Run this process after all worksheet allocations have been approved.

Costing Process (Payroll)

Generates journal entries for your ledgers and costing information relating to labor costs.

CPFLine (Payroll) (Singapore)

Creates a file that you submit each month to the CPF Board for every legal entity in your
enterprise. The report that is produced enables you to view the CPF contributions that
are included in the file

Create and Maintain Company Cost Centers with Existing Organizations

This process creates company cost center organizations for each unique company cost
center combination that has been defined in GL. This process is also available as part of
the Synchronize GL Company Cost Centers with HR request set.

Create Federal HR Valid Combinations for the Grade KF (FD)

Federal Concurrent Manager process that supplies the predefined valid grade and pay
plan combinations for the grade key flexfield.

Create Federal Special Info Types (FD)

Federal Concurrent Manager process that supplies the Federal Special Information
types for the Person Special Information.

Credit Transfer Process (Payroll) (South Africa)

Marks employees with this payment method as paid.

Credit Transfer Cheque Payments Process (Payroll) (South Africa)

Produces an aggregated cheque per bank branch to be submitted with Deposit Schedules.
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Default Enrollment Process (Advanced Benefits)

Run this process to enroll participants into the default benefit plan when participants
have not made an election.

Direct Deposit (Singapore IBG Format) (Payroll) (Singapore)

Creates a payment file and report, run after PrePayments is complete for the payroll.

Direct Deposit Process (China - CCBS Format) (Payroll China)

This report produces a deposit advice in the correct format. This process generates
two outputs:

• A hard copy called "Bank Transfer Report". This output provides a list of employees
who had been processed in the Direct Deposit Process.

• A magnetic file for submission to the bank

Once the advice is transferred to the bank, the bank deposits the payments directly into
the worker’s account.

Bank Transfer Report (Payroll Korea)

This report produces a deposit advice in the correct format. This process generates two
outputs, a hard copy and a magnetic file for submission to the bank. Once you transfer
the advice to the bank, the bank deposits the payments directly into the worker’s account.

Direct Entry (Australian BECS Format) Process (AU)

Produces a payment file for all employees.

Direct Entry (Reconciliation Report) (AU)

Produces a payment file for all employees. This file is the output version of the magtape
sent to the government.

Electronic Lodgement of TFN Declaration report (.mf) (AU)

The Electronic Lodgement of TFN Declaration process allows you to produce a report for
any new or changed TFN details for the employees in an organization. This file is the
binary magtape file that is used for uploading to the government.

Electronic Lodgement of TFN Declaration report (.out) (AU)

The Electronic Lodgement of TFN Declaration process allows you to produce a report for
any new or changed TFN details for the employees in an organization. This file is the
output version of the magtape file that is sent to the government.

Download HRMS Taskflows Process

Run this process to export a task flow from your database to a flat file that you can
then import to another database.

Duty Station Conversion Process (FD)

Moves employees from an old to a new Location
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Electronic Tax File Process (Payroll) (South Africa)

Produces tax files in ASCII format.

Electronic UIF File Preprocess (South Africa)

This preprocess archives UIF information for the Electronic UIF File.

Electronic UIF File Process (South Africa)

The Electronic UIF File must be submitted on a monthly basis.

Enable Multiple Security Groups Process

Run this process when you first set up security groups enabled security.

End of Year Process (Payroll) (UK)

Produces statutory End of Year return to the Inland Revenue for employees in your
enterprise.

Export GL Company Cost Center Process

The process is run for your current business group and writes information about GL
company cost center combinations for companies that you have previously defined for
your business group to a tab delimited file. It creates a record in the file for each unique
company cost center combination that has been defined in GL.

Extract Definition Download to Data File

Copies a system extract definition to a file for upload to another business group or
Oracle HRMS database.

Extract Definition Upload to Data File

Imports a copy of a system extract definition to a new business group or Oracle HRMS
database.

Extract Process (Advanced Benefits)

Run the extract process to save the output of your system extract to the directory and file
that you specified in your extract definition.

Extract Results Data Purge

On a periodic basis, run the purge process to free table space in the system extract
results tables.

Extracting Information to Appear on the Payslip

Enables you to access the latest data relevant to the payslip, and copy it to archive tables.

Federal Benefits - TSP Conversion of Benefits (FD)

This process migrates converts the existing records for employees participating in TSP
to the Benefits model.
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Federal Benefits - TSP Catchup Conversion of Benefits (FD)

This process converts the existing records for employees participating in TSP Catch-Up
to the Benefits model.

Forms Configurator – Download Template

Run this process to download one or more people management templates to a data file.

Forms Configurator – Upload Template

Run this process to upload a template to enable you to use it with the People
Management Configurator (Forms Configurator) tool.

French PTO Accruals – Create Entitlements Process

Enables you to create entitlements from accruals, so that holidays may be spent.

French PTO Accruals – Obsolete Entitlements Process

Enables you to obsolete unspent entitlement.

Full Settlement Process (France) (Payroll)

This produces a letter in duplicate stating that the employee agrees that their termination
has been concluded correctly.

Generate Overtime Payment Mapping Process (Payroll) (France)

Allows you to associate your overtime scheme with a payroll calendar.

Generate Secure User Process (SECGEN)

Run this process when you create a new security profile that references a reporting user.

Grant Permissions to Roles Process (ROLEGEN)

Dynamically grants select permissions on Oracle HRMS tables and views to the
HR_REPORTING_USER role.

IR56B Archive Process (Payroll)(Hong Kong)

The IR56B Annual Employers Return Archive process stores employee and balance
information, which is used in the IR56B Report and the Magnetic Tape process.

IR56B Magnetic Tape Process (Payroll) (Hong Kong)

The IR56B Magnetic Tape process produces the end of year magnetic tape from the
Archived Information.

IR8A File (Payroll) (Singapore)

Creates a file that includes your includes your employees’ earnings for a specific tax year
and legal entity. The process also creates a report for you to view the contributions that
are included in the file.
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IR8S File (Payroll) (Singapore)

Creates a file that includes your employees’ and employers’ earnings for a specific tax
year and legal entity. The process also creates a report for you to view the contributions
that are included in the file.

IRAS Line Archive (Payroll) (Singapore)

Archives the data that will later be used to create the year-end magnetic tapes.

Maintain Designee Eligibility (Advanced Benefits)

Run this process for those benefit plans that include an age factor in determining
dependent eligibility.

Maintain Participant Eligibility Process (Standard Benefits)

Run this process if you license Standard Benefits and you want to determine benefits
eligibility for a segment of your employee population. This process also de-enrolls
currently enrolled participants who lose benefits eligibility and ends their associated
benefits coverage and activity rate.

Manual Credit Transfer Cheque Payments (Payroll) (South Africa)

Updates system with cheque number of manually issued cheques.

Manual Payments (Payroll) (South Africa)

Updates system with manual payments made to employees.

Manually Issued Tax Certificates (Payroll) (South Africa)

Updates system with manually issued tax certificates numbers.

NACHA Process (Payroll) (US)

Produces files that you load on magnetic tape and despatch to banks for direct deposit
payments.

P11D Benefits and Expenses Report (HR and Payroll) (UK)

Takes a P11D archive request ID and prints a selection of Class 1A benefits and expenses.

P11D Gaps and Overlaps Report (HR and Payroll) (UK)

Identifies a taxable benefit that is spread over multiple periods with a gap between
each period, and also identifies taxable benefits of the same type that overlap each
other within the same period.

P11D Magtape (HR and Payroll) (UK)

Generates a magnetic tape containing details of Class 1A NICs for reporting to the
Inland Revenue.

Partial Period Accrual Calculation Process (Core Payroll, and enabled localizations)

Run this process to calculate accruals when the end of your accounting period occurs
part way through a payroll period.
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Participation Batch Process: Grade Step

Run this process to determine eligibility and electable choices for employees whom you
want to progress using Grade/Step Progression.

Participation Batch Process: Life Event (Advanced Benefits)

Run this process to determine eligibility and electable choices for benefits participants
based on a life event you select.

Participation Batch Process: Scheduled (Advanced Benefits)

Run this process to determine eligibility and electable choices for benefits participants
based on a scheduled enrollment event.

Participation Batch Process: Selection (Advanced Benefits)

Run this process to determine eligibility for benefits participants. This process does not
create electable choices.

Participation Process: Compensation

Run this process for Compensation Workbench prior to the availability of a plan for
budget and worksheet entry.

Pay Advice Generation – Self Service (South Africa) (South Africa)

Archives balances and elements you define and other pay advice related information.

Payroll Run (Payroll) (France)

The Payroll Run is the regular method to process employee pay.

Payslip Generation – Self Service (UK)

Generate payslips for employees to view online through Oracle Self-Service.

Payslip Generator – Statement of Earnings (Payroll) (France)

This process generates pay advice data for all employees for a specified payroll and
period.

Pension Extracts

These processes enable you to extract employee pension plan-related data for transfer to
third-party providers.

Pension Extracts (Electronic Notification) (Netherlands)

This process extracts the pensions and social insurance data you require for the monthly
notification report to ABP and UWV USZO.

Periodic Tax Filing (FLS) (Payroll) (US)

The Periodic Tax Filing Interface creates a flat file (.mf) containing the archived data
from the External Process Archive in a format that can be directly submitted to Federal
Liaison Services, Inc. (FLS) for tax filing and reporting.
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Populate FEHB Program and Plan Design (FD)

This process populates the Federal Employee Health Benefits program and plan designs
for use in professional user interface forms and self-service benefits.

Populate TSP Program and Plan Design (FD)

This process populates the US Federal Thrift Savings Plan programs and plan designs
for use in professional user interface forms and self-service benefits.

Populate TSP Catchup Program and Plan Design (FD)

This process populates the Thrift Savings Plan Catch Up program and plan designs for
use in professional user interface forms and self-service benefits.

PrePayments (French) Process (Payroll) (France)

Use this process to distribute employee pay over more than one payment method
using either a percentage or monetary split. This process runs prepayments for one
calendar month only.

PrePayments Process (Payroll)

Use this process to distribute employee pay over more than one payment method
using either a percentage or monetary split.

Previous Services Validation (HR) (France)

Use this process to validate the employee’s (titulaire) services for a period in which the
employee has worked in some other public sector type organization as non-titulaires.

Printing the Payslip

Enables you to access the archived payslip information, and create a formatted file ready
for printing and distributing to your employees.

Process Forfeitures (US)

Calculates--by participant--the total unspent contributions for a spending account
benefits plan.

Process Future Dated RPAs (FD)

Set the frequency for processing future actions.

Prud’hommale (Workers Election) Declaration Process (HR) (France)

Creates a statutory declaration which enables your employees to take part in the
Industrial Tribunal elections.

Purge Backed-Out or Voided Life Events

Removes person data associated with backed-out or voided life events for Advanced
Benefits and Compensation Workbench.

Recalculate Participant Values (Standard Benefits) (US)

Updates activity rates for currently enrolled benefits participants based on plan design
changes.
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As a prerequisite, you should run the Maintain Participant Eligibility process to update
eligibility records and derived factors.

Register Extra Information Types (EITs)

Enables you to register the new Extra Information Types (EITs) that you create using the
Descriptive Flexfield window.

Note: This process cannot be used to register organizational EITs.

Relieve Commitments

Run the Relieve Commitments request set to calculate budget commitments and post the
results to Oracle General Ledger. The request set combines the Calculate Commitments
process and the Commitment GL Posting process.

Remove Title from Person’s Full Name

Run the Remove Title from Person’s Full Name concurrent process to remove title from
existing records without updating them.

RetroPay Process

Enables you to make back pay adjustments.

Retry Payroll Process

Retry a payroll process again.

Running the P45 EDI Process (UK)

Enables you to notify the Inland Revenue about employees who leave your employment.

Running the P45(3) EDI Process (UK)

Enables you to notify the Inland Revenue about a new starters information, or someone
receiving a pension.

Running the P45 Process (UK)

Enables you to print and archive, or just archive specified P45’s.

Running the P46 EDI Process (UK)

Enables you to provide information on new employees who cannot produce, or have
never had a P45.

Running the P6 and P9 Upload Process (UK)

Run the process to upload the details about changes to an employee’s tax code, or
coding changes from the Inland Revenue.

Running the Works Number Update (UK)

Run to provide information on updated and new employee works numbers.
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Saudi Payroll Archiver Process (Payroll) (SA)

Use this process to archive the payroll details for each payroll period for future
reference. This supports production of Online Payslip and Payroll Register reports.

Saudi Payroll Upgrade Process (Payroll) (SA)

Use this process to migrate data from existing payroll runs and generate group reports
for employees.

Security List Maintenance Process (PERSLM)

This process is usually run every night to maintain the lists of organizations, positions,
payrolls, employees, and applicants that security profile holders can access.

Seed French Data Process (France)

This process creates and populates user defined tables using predefined lookup types
and rows.

Start Automatic WGI (FD)

Schedule the Within Grade Increases (WGI) process to set the frequency with which
the system processes automatic WGIs.

Start of Year Process (Payroll) (UK)

Usually performed at the start of the tax year to update tax information for each
employee.

Synchronize GL Company Cost Centers with HR Request Set

This request set runs the following two processes:

• Create and Maintain Company Cost Center Organizations, page B-75

• Synchronize GL Company Cost Centers with Existing Organizations, page B-83

Synchronize GL Company Cost Centers with Existing Organizations

This process links existing and newly created company cost center organizations to GL
account combinations, where a link does not already exist..

Synchronize Positions Process (FD)

This process updates the non-datetracked Positions table (PER_ALL_POSITIONS) with
changes made to the datetracked table (HR_ALL_POSITIONS_F). When you run the
process, any datetracked changes with an effective date on or before today are applied
to the non-datetracked table.

Synchronize Salary Rates Process (France)

This process synchronizes the existing salary rates in the corps set up when you update
the indemnity rates defined for your global pay scale. This match ensures that you use
current compensation values in your pay scales.
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Tax Batch Update Process (Germany)

The Tax Batch Update Process enables you to update the tax records for employees who
have not submitted their tax cards for the current tax year. You can either run the process
in report-only mode, which identifies the employees whose records would be subject to
change, or in update mode to make the changes to the records.

Tax Credit Upload (Payroll) (Ireland)

The Tax Credit Upload process enables you to upload the tax credits of an employee from
the data file provided by the Revenue. It also specifies standard rate cut-off amounts
for each employee. The tax credit upload process validates the records provided by the
Revenue and then uploads them into the PAY_IE_PAYE DETAILS_F table.

Tax Year End Data Validation and Preprocess (Payroll) (South Africa)

Preparation for issue of tax certificates.

Tax Year Start Process (Payroll) (South Africa)

Updates employee tax information at the start of each tax year.

Tax Year Start Rollback (Payroll) (South Africa)

Rolls back the actions performed in the Tax Year Start Process.

Termination Category Setup Process (Payroll) (South Africa)

Part of setup required for storing Employment Equity and UIF information.

Transfer to GL Process

Transfers the results of the costing process to the Accounting flexfield of Oracle General
Ledger.

Upgrade from ADE to Web ADI

Run this process to convert styles used by Application Data Exchange (ADE) to
integrators in Web Applications Desktop Integrator (Web ADI).

Upload GL Company Cost Center Information Request Set

Run the Upload GL Company Cost Center Information request set to upload the
amended version of the exported file created using the Export GL Company Cost
Centers process.

Upload HRMS Taskflows Process

Run this process to import a task flow to your database from a flat file exported from
another database.

Upload Social Insurance Providers Process (Germany)

The Upload Social Insurance Providers Process enables you to upload a delivered list of
social insurance providers to your German HR system.
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Upload Tax Offices Process (Germany)

The Upload Tax Offices Process enables you to upload a delivered list of tax offices to
your German HR system.

Upload Taxable Benefits (HR and Payroll) (UK)

The Taxable Benefits process enables you to upload a flat file of P11D elements to your
P11D data repository.

Vehicle Mileage Calculation Information (Payroll) (UK)

Enters or deletes default mileage elements and rates tables for categories of vehicles
in your business group.

Void Cheque Payments (Payroll) (South Africa)

Uploads details of canceled cheque payments.

Void Credit Transfer Cheque Payments (Payroll) (South Africa)

Voids aggregated cheque payments made to banks.

Void Payments Process (Payroll) (UK, US)

Allows you to void cheques that have been printed but need to be cancelled.

Wage and Tax Statement Form (Form W-2) (Payroll) (US)

The Wage and Tax Statement (Form W-2) is used by employers to report taxable
and non-taxable income information of individual employees to the IRS and State
governments.
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Glossary

360-Degree Appraisal

Part of the SSHR Appraisal function and also known as a Group Appraisal. This is an
employee appraisal undertaken by managers with participation by reviewers.

360-Degree Self Appraisal

Part of the SSHR Appraisal function and also known as a Group Appraisal. This is
a 360-Degree appraisal initiated by an employee. The employee (initiator) can add
managers and reviewers to the appraisal.

Absence

A period of time in which an employee performs no work for the assigned organization.

Absence Types

Categories of absence, such as medical leave or vacation leave, that you define for
use in absence windows.

Accrual

The recognized amount of leave credited to an employee which is accumulated for a
particular period.

Accrual Band

A range of values that determines how much paid time off an employee accrues. The
values may be years of service, grades, hours worked, or any other factor.

Accrual Period

The unit of time, within an accrual term, in which PTO is accrued. In many plans, the
same amount of time is accrued in each accrual period, such as two days per month. In
other plans, the amount accrued varies from period to period, or the entitlement for the
full accrual term is given as an up front amount at the beginning of the accrual term.

Accrual Plan

See: PTO Accrual Plan, page Glossary-22

Accrual Term

The period, such as one year, for which accruals are calculated. In most accrual
plans, unused PTO accruals must be carried over or lost at the end of the accrual
term. Other plans have a rolling accrual term which is of a certain duration but has no
fixed start and end dates.
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Activity Rate

The monetary amount or percentage associated with an activity, such as $12.35 per pay
period as an employee payroll contribution for medical coverage. Activity rates can
apply to participation, eligibility, coverages, contributions, and distributions.

Actual Premium

The per-participant premium an insurance carrier charges the plan sponsor for a given
benefit.

Administrative Enrollment

A type of scheduled enrollment caused by a change in plan terms or conditions and
resulting in a re-enrollment.

AdvancePay

A process that recalculates the amount to pay an employee in the current period, to
make an authorized early payment of amounts that would normally be paid in future
payroll periods.

Alert

An email notification that you can set up and define to send a recipient or group of
recipients a reminder or warning to perform a certain task or simply a notification to
inform the recipient of any important information.

API

Application Programmatic Interfaces, used to upload data to the Oracle Applications
database. APIs handle error checking and ensure that invalid data is not uploaded to
the database.

Applicant

A candidate for employment in a Business Group.

Applicant/Candidate Matching Criteria

Matching functionality in the iRecruitment system that systematically identifies which
candidates and applicants possess the skills, knowledge and abilities to be considered
for a specific vacancy. The following columns are used for matching:

• Skills

• FT/PT

• Contractor/Employee

• Work at Home

• Job Category

• Distance to Location

• Key Words

• Salary

Apply for a Job

An SSHR function that enables an employee to, apply, search and prepare applications
for an internally advertised vacancy.
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Appraisal

An appraisal is a process where an employee’s work performance is rated and future
objectives set.

See also: Assessment, page Glossary-3.

Appraisee

A person being appraised by an appraiser..

Appraiser

A person, usually a manager, who appraises an employee.

Appraising Manager

The person who initiates and performs an Employee-Manager or 360 Degree
Appraisal. An appraising manager can create appraisal objectives.

Arrestment

Scottish court order made out for unpaid debts or maintenance payments.

See also: Court Order , page Glossary-8

Assessment

An information gathering exercise, from one or many sources, to evaluate a person’s
ability to do a job.

See also: Appraisal, page Glossary-3.

Assignment

A worker’s assignment identifies their role within a business group. The assignment
is made up of a number of assignment components. Of these, organization is
mandatory, and payroll is required (for employees only) for payment purposes.

Assignment Number

A number that uniquely identifies a worker’s assignment. A worker with multiple
assignments has multiple assignment numbers.

Assignment Rate

A monetary value paid to a contingent worker for a specified period of time. For
example, an assignment rate could be an hourly overtime rate of $10.50.

Assignment Set

A grouping of employees and applicants that you define for running QuickPaint reports
and processing payrolls.

See also: QuickPaint Report, page Glossary-23

Assignment Status

For workers, used to track their permanent or temporary departures from your
enterprise and, for employees only, to control the remuneration they receive. For
applicants, used to track the progress of their applications.
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Authoria

A provider of health insurance and compensation information, that provides additional
information about benefits choices.

BACS

Banks Automated Clearing System. This is the UK system for making direct deposit
payments to employees.

Balance Adjustment

A correction you make to a balance. You can adjust user balances and assignment
level predefined balances only.

Balance Dimension

The period for which a balance sums its balance feeds, or the set of
assignments/transactions for which it sums them. There are five time
dimensions: Run, Period, Quarter, Year and User. You can choose any reset point for
user balances.

Balance Feeds

These are the input values of matching units of measure of any elements defined to
feed the balance.

Balances

Positive or negative accumulations of values over periods of time normally generated by
payroll runs. A balance can sum pay values, time periods or numbers.

See also: Predefined Components , page Glossary-21

Bargaining Unit

A bargaining unit is a legally organized group of people which have the right to negotiate
on all aspects of terms and conditions with employers or employer federations. A
bargaining unit is generally a trade union or a branch of a trade union.

Base Currency

The currency in which Oracle Payroll performs all payroll calculations for your Business
Group. If you pay employees in different currencies to this, Oracle Payroll calculates the
amounts based on exchange rates defined in the system.

Base Summary

A database table that holds the lowest level of summary. Summary tables are populated
and maintained by user-written concurrent programs.

Behavioral Indicators

Characteristics that identify how a competence is exhibited in the work context.

See also: Proficiency Level , page Glossary-22

Beneficiary

A person or organization designated to receive the benefits from a benefit plan upon
the death of the insured.
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Benefit

Any part of an employee’s remuneration package that is not pay. Vacation
time, employer-paid medical insurance and stock options are all examples of benefits.

See also: Elements, page Glossary-11

Block

The largest subordinate unit of a window, containing information for a specific business
function or entity. Every window consists of at least one block. Blocks contain fields
and, optionally, regions. They are delineated by a bevelled edge. You must save your
entries in one block before navigating to the next.

See also: Region, page Glossary-24, Field, page Glossary-12

Budget Measurement Type (BMT)

A subset of Workforce Measurement Type. It consists of a number of different units
used to measure the workforce. The most common units are headcount and full time
equivalent.

Budget Value

In Oracle Human Resources you can enter staffing budget values and actual values for
each assignment to measure variances between actual and planned staffing levels in
an organization or hierarchy.

Business Group

The highest level organization in the Oracle HRMS system. A Business Group may
correspond to the whole of your enterprise or to a major grouping such as a subsidiary or
operating division. Each Business Group must correspond to a separate implementation
of Oracle HRMS.

Business Number (BN)

In Canada, this is the employer’s account number with Revenue Canada. Consisting of
15 digits, the first 9 identify the employer, the next 2 identify the type of tax account
involved (payroll vs. corporate tax), and the last 4 identify the particular account for
that tax.

Cafeteria Benefits Plan

See: Flexible Benefits Program, page Glossary-12

Calendar Exceptions

If you are using the Statutory Absence Payments (UK) feature, you define calendar
exceptions for an SSP qualifying pattern, to override the pattern on given days. Each
calendar exception is another pattern which overrides the usual pattern.

Calendars

In Oracle Human Resources you define calendars that determine the start and end
dates for budgetary years, quarters and periods. For each calendar you select a basic
period type. If you are using the Statutory Absence Payments (UK) feature, you define
calendars to determine the start date and time for SSP qualifying patterns.
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Canada/Quebec Pension Plan (CPP/QPP) Contributions

Contributions paid by employers and employees to each of these plans provide income
benefits upon retirement.

Candidate

(iRecruitment) A candidate is a person who has either directly provided their personal
and professional information to a company’s job site or provided their resume and
details to a manager or recruiter for entering in the iRecruitment system.

Candidate Offers

An SSHR function used by a line manager to offer a job to a candidate. This function
is supplied with its own responsibility.

Career Path

This shows a possible progression from one job or position from any number of other
jobs or positions within the Business Group. A career path must be based on either job
progression or position progression; you cannot mix the two.

Carry Over

The amount of unused paid time off entitlement an employee brings forward from
one accrual term to the next. It may be subject to an expiry date i.e. a date by which
it must be used or lost.

See also: Residual, page Glossary-25

Cash Analysis

A specification of the different currency denominations required for paying your
employees in cash. Union contracts may require you to follow certain cash analysis rules.

Ceiling

The maximum amount of unused paid time off an employee can have in an accrual
plan. When an employee reaches this maximum, he or she must use some accrued
time before any more time will accrue.

Certification

Documentation required to enroll or change elections in a benefits plan as the result of a
life event, to waive participation in a plan, to designate dependents for coverage, or to
receive reimbursement for goods or services under an FSA.

Child/Family Support payments

In Canada, these are payments withheld from an employee’s compensation to satisfy a
child or family support order from a Provincial Court. The employer is responsible for
withholding and remitting the payments to the court named in the order.

Collective Agreement

A collective agreement is a form of contract between an employer or employer
representative, for example, an employer federation, and a bargaining unit for example, a
union or a union branch.
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Collective Agreement Grade

Combination of information that allows you to determine how an employee is ranked or
graded in a collective agreement.

Communications

Benefits plan information that is presented in some form to participants. Examples
include a pre-enrollment package, an enrollment confirmation statement, or a notice
of default enrollment.

Compensation

The pay you give to employees, including wages or salary, and bonuses.

See also: Elements, page Glossary-11

Compensation Object

For Standard and Advanced Benefits, compensation objects define, categorize, and help
to manage the benefit plans that are offered to eligible participants. Compensation
objects include programs, plan types, plans, options, and combinations of these entities.

Competence

Any measurable behavior required by an organization, job or position that a person
may demonstrate in the work context. A competence can be a piece of knowledge, a
skill, an attitude, or an attribute.

See also: Unit Standard Competence, page Glossary-29

Competence Evaluation

A method used to measure an employees ability to do a defined job.

Competence Profile

Where you record applicant and employee accomplishments, for example, proficiency
in a competence.

Competence Requirements

Competencies required by an organization, job or position.

See also: Competence, page Glossary-7, Core Competencies, page Glossary-8

Competence Type

A group of related competencies.

Configurable Forms

Forms that your system administrator can modify for ease of use or security purposes
by means of Custom Form restrictions. The Form Customization window lists the
forms and their methods of configuration.

Consideration

(iRecruitment) Consideration means that a decision is registered about a person in
relation to a vacancy so that the person can be contacted.
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Consolidation Set

A grouping of payroll runs within the same time period for which you can schedule
reporting, costing, and post-run processing.

Contact

A person who has a relationship to an employee that you want to record. Contacts can
be dependents, relatives, partners or persons to contact in an emergency.

Content

When you create a spreadsheet or word processing document using Web ADI, the
content identifies the data in the document. Content is usually downloaded from the
Oracle application database.

Contingent Worker

A worker who does not have a direct employment relationship with an enterprise and
is typically a self-employed individual or an agency-supplied worker. The contingent
worker is not paid via Oracle Payroll.

Contract

A contract of employment is an agreement between an employer and employee
or potential employee that defines the fundamental legal relationship between an
employing organization and a person who offers his or her services for hire. The
employment contract defines the terms and conditions to which both parties agree
and those that are covered by local laws.

Contribution

An employer’s or employee’s monetary or other contribution to a benefits plan.

Core Competencies

Also known as Leadership Competencies or Management Competencies. The competencies
required by every person to enable the enterprise to meet its goals.

See also: Competence, page Glossary-7

Costable Type

A feature that determines the processing an element receives for accounting and
costing purposes. There are four costable types in Oracle HRMS: costed, distributed
costing, fixed costing, and not costed.

Costing

Recording the costs of an assignment for accounting or reporting purposes. Using Oracle
Payroll, you can calculate and transfer costing information to your general ledger and
into systems for project management or labor distribution.

Court Order

A ruling from a court that requires an employer to make deductions from an employee’s
salary for maintenance payments or debts, and to pay the sums deducted to a court
or local authority.

See also: Arrestment, page Glossary-3
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Credit

A part of the Qualifications Framework. The value a national qualifications authority
assigns to a unit standard competence or a qualification. For example, one credit may
represent 10 hours of study, a unit standard competence may equate to 5 credits, and a
qualification may equate to 30 credits.

Criteria Salary Rate

Variable rate of pay for a grade, or grade step. Used by Grade/Step Progression.

Database Item

An item of information in Oracle HRMS that has special programming attached, enabling
Oracle FastFormula to locate and retrieve it for use in formulas.

Date Earned

The date the payroll run uses to determine which element entries to process. In North
America (and typically elsewhere too) it is the last day of the payroll period being
processed.

Date Paid

The effective date of a payroll run. Date paid dictates which tax rules apply and which
tax period or tax year deductions are reported.

Date To and Date From

These fields are used in windows not subject to DateTrack. The period you enter in these
fields remains fixed until you change the values in either field.

See also: DateTrack, page Glossary-9, Effective Date, page Glossary-10

DateTrack

When you change your effective date (either to past or future), DateTrack enables
you to enter information that takes effect on your new effective date, and to review
information as of the new date.

See also: Effective Date, page Glossary-10

Default Postings

(iRecruitment) Default text stored against business groups, organizations, jobs, and/or
positions. The default postings are used to create job postings for a vacancy.

Dependent

In a benefit plan, a person with a proven relationship to the primary participant whom
the participant designates to receive coverage based on the terms of the plan.

Deployment Factors

See: Work Choices, page Glossary-30

Derived Factor

A factor (such as age, percent of fulltime employment, length of service, compensation
level, or the number of hours worked per period) that is used in calculations to
determine Participation Eligibility or Activity Rates for one or more benefits.
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Descriptive Flexfield

A field that your organization can configure to capture additional information required
by your business but not otherwise tracked by Oracle Applications.

See also: Key Flexfield , page Glossary-15

Developer Descriptive Flexfield

A flexfield defined by your localization team to meet the specific legislative and
reporting needs of your country.

See also: Extra Information Types, page Glossary-12

Direct Deposit

The electronic transfer of an employee’s net pay directly into the account(s) designated
by the employee.

Discoverer Workbook

A grouping of worksheets. Each worksheet is one report.

Discoverer Worksheet

A single report within a workbook. A report displays the values of predefined criteria
for analysis.

Distribution

Monetary payments made from, or hours off from work as allowed by, a compensation
or benefits plan.

Download

The process of transferring data from the Oracle HRMS application to your desktop
(the original data remains in the application database).

Effective Date

The date for which you are entering and viewing information. You set your effective
date in the Alter Effective Date window.

See also: DateTrack, page Glossary-9

EIT

See: Extra Information Type, page Glossary-12

Electability

The process which determines whether a potential benefits participant, who has satisfied
the eligibility rules governing a program, plan, or option in a plan, is able to elect
benefits. Participants who are eligible for benefits do not always have electable benefit
choices based on the rules established in a benefit plan design.

Element Classifications

These control the order in which elements are processed and the balances they
feed. Primary element classifications and some secondary classifications are predefined
by Oracle Payroll. Other secondary classifications can be created by users.
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Element Entry

The record controlling an employee’s receipt of an element, including the period of time
for which the employee receives the element and its value.

See also: Recurring Elements, page Glossary-24, Nonrecurring Elements, page Glossary-18

Element Link

The association of an element to one or more components of an employee
assignment. The link establishes employee eligibility for that element. Employees whose
assignment components match the components of the link are eligible for the element.

See also: Standard Link, page Glossary-27

Elements

Components in the calculation of employee pay. Each element represents a compensation
or benefit type, such as salary, wages, stock purchase plans, and pension contributions.

Element Set

A group of elements that you define to process in a payroll run, or to control access to
compensation information from a configured form, or for distributing costs.

Eligibility

The process by which a potential benefits participant satisfies the rules governing
whether a person can ever enroll in a program, plan, or option in a plan. A participant
who is eligible for benefits must also satisfy electability requirements.

Employee

A worker who has a direct employment relationship with the employer. Employees are
typically paid compensation and benefits via the employer’s payroll application.

Employee Histories

An SSHR function for an employee to view their Learning History, Job Application
History, Employment History, Absence History, or Salary History. A manager can also
use this function to view information on their direct reports.

Employment Category

A component of the employee assignment. Four categories are defined: Full Time
- Regular, Full Time - Temporary, Part Time - Regular, and Part Time - Temporary.

Employment Equity Occupational Groups (EEOG)

In Canada, the Employment Equity Occupational Groups (EEOG) consist of 14
classifications of work used in the Employment Equity Report. The EEOGs were derived
from the National Occupational Classification system.

Employment Insurance (EI)

Benefit plan run by the federal government to which the majority of Canadian employers
and employees must contribute.

Employment Insurance Rate

In Canada, this is the rate at which the employer contributes to the EI fund. The rate is
expressed as a percentage of the employee’s contribution. If the employer maintains an
approved wage loss replacement program, they can reduce their share of EI premiums
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by obtaining a reduced contribution rate. Employers would remit payroll deductions
under a different employer account number for employees covered by the plan.

Enrollment Action Type

Any action required to complete enrollment or de-enrollment in a benefit.

Entitlement

In Australia, this is all unused leave from the previous year that remains to the credit
of the employee.

ESS

Employee Self Service. A predefined SSHR responsibility.

Event

An activity such as a training day, review, or meeting, for employees or
applicants. Known as class in OLM.

Ex-Applicant

Someone who has previously applied for a vacancy or multiple vacancies, but all
applications have ended, either because the applicant has withdrawn interest or they
have been rejected. Ex-Applicants can still be registered users.

Expected Week of Childbirth (EWC)

In the UK, this is the week in which an employee’s baby is due. The Sunday of the
expected week of childbirth is used in the calculations for Statutory Maternity Pay (SMP).

Extra Information Type (EIT)

A type of developer descriptive flexfield that enables you to create an unlimited number
of information types for six key areas in Oracle HRMS. Localization teams may also
predefine some EITs to meet the specific legislative requirements of your country.

See also: Developer Descriptive Flexfield, page Glossary-10

Field

A view or entry area in a window where you enter, view, update, or delete information.

See also: Block, page Glossary-5, Region, page Glossary-24

Flex Credit

A unit of "purchasing power" in a flexible benefits program. An employee uses flex
credits, typically expressed in monetary terms, to "purchase" benefits plans and/or levels
of coverage within these plans.

Flexible Benefits Program

A benefits program that offers employees choices among benefits plans and/or levels of
coverage. Typically, employees are given a certain amount of flex credits or moneys with
which to "purchase" these benefits plans and/or coverage levels.

Flexible Spending Account

(FSA) Under US Internal Revenue Code Section 125, employees can set aside money
on a pretax basis to pay for eligible unreimbursed health and dependent care
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expenses. Annual monetary limits and use-it-or-lose it provisions exist. Accounts are
subject to annual maximums and forfeiture rules.

Form

A predefined grouping of functions, called from a menu and displayed, if necessary, on
several windows. Forms have blocks, regions and fields as their components.

See also: Block, page Glossary-5, Region, page Glossary-24, Field, page Glossary-12

Full Time Equivalent (FTE)

A Workforce Measurement Type (WMT) that measures full time equivalent. Although
the actual value and calculation may vary, this value is taken from the Assignment
Budget Value (ABV) in Oracle HRMS. If the Assignment Budget Value in Oracle HRMS
is not set up then a FastFormula is used to determine the value to be calculated.

Global Value

A value you define for any formula to use. Global values can be dates, numbers or text.

Goods or Service Type

A list of goods or services a benefit plan sponsor has approved for reimbursement.

Grade

A component of an employee’s assignment that defines their level and can be used to
control the value of their salary and other compensation elements.

Grade Comparatio

A comparison of the amount of compensation an employee receives with the mid-point
of the valid values defined for his or her grade.

Grade Ladder

The key component of Grade/Step Progression. You use a grade ladder to categorize
grades, to determine the rules for how an employee progresses from one grade (or step)
to the next, and to record the salary rates associated with each grade or step on the ladder.

Grade Rate

A value or range of values defined as valid for a given grade. Used for validating
employee compensation entries.

Grade Scale

A sequence of steps valid for a grade, where each step corresponds to one point on a pay
scale. You can place each employee on a point of their grade scale and automatically
increment all placements each year, or as required.

See also: Pay Scale, page Glossary-19

Grade Step

An increment on a grade scale. Each grade step corresponds to one point on a pay scale.

See also: Grade Scale, page Glossary-13

Grandfathered

A term used in Benefits Administration. A person’s benefits are said to be grandfathered
when a plan changes but they retain the benefits accrued.
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Group

A component that you define, using the People Group key flexfield, to assign employees
to special groups such as pension plans or unions. You can use groups to determine
employees’ eligibility for certain elements, and to regulate access to payrolls.

Group Certificate

In Australia, this is a statement from a legal employer showing employment income
of an employee for the financial year..

Headcount(HEAD)

A Workforce Measurement Type (WMT) that measures headcount. Although the actual
value and calculation may vary, this value is taken from the Assignment Budget Value
(ABV) in Oracle HRMS. If the Assignment Budget Value in Oracle HRMS is not set up
then a FastFormula is used to determine the value to be calculated.

Hierarchy

An organization or position structure showing reporting lines or other relationships. You
can use hierarchies for reporting and for controlling access to Oracle HRMS information.

Imputed Income

Certain forms of indirect compensation that US Internal Revenue Service Section
79 defines as fringe benefits and taxes the recipient accordingly. Examples include
employer payment of group term life insurance premiums over a certain monetary
amount, personal use of a company car, and other non-cash awards.

Info Online

A generic framework to integrate Oracle applications with partner applications, enabling
users to access information from third-party providers, Metalink and Learning
Management.

Initiator

In SSHR a person who starts a 360 Degree appraisal (Employee or Self) on an
individual. An initiator and the appraisee are the only people who can see all appraisal
information.

Input Values

Values you define to hold information about elements. In Oracle Payroll, input values
are processed by formulas to calculate the element’s run result. You can define up
to fifteen input values for an element.

Instructions

An SSHR user assistance component displayed on a web page to describe page
functionality.

Integrator

Defines all the information that you need to download or upload from a particular
window or database view using Web ADI.

Interface

A Web ADI term for the item that specifies the columns to be transferred from the Oracle
applications database to your desktop or vice versa.
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Involuntary

Used in turnover to describe employees who have ceased employment with the
enterprise not of their own accord, for example, through redundancy.

Job

A job is a generic role within a business group, which is independent of any single
organization. For example, the jobs "Manager" and "Consultant" can occur in many
organizations.

Job Posting

An advertisement for a specific vacancy. This is the public side of the vacancy for
which a candidate would apply.

Key Flexfield

A flexible data field made up of segments. Each segment has a name you define and a
set of valid values you specify. Used as the key to uniquely identify an entity, such as
jobs, positions, grades, cost codes, and employee groups.

See also: Descriptive Flexfield, page Glossary-10

Key Performance Indicator (KPI)

Target values that you set for the performance of your enterprise. This value comes from
the corresponding KPI Portlet/Report. You can configure the Performance Management
Framework to send a notification when actual performance falls short of, or exceeds, the
target value. For example, you may configure the Performance Management Framework
to send you a notification when workforce variance is greater than 10 percent, or when
training success is below 50 percent.

Key Performance Indicator (KPI) Portlet/Report

Displays the executive summary of key measures such as total headcount and total salary.

Layout

Indicates the columns to be displayed in a spreadsheet or Word document created
using Web ADI.

Learning Management

Oracle’s enterprise learning management system that administers online and offline
educational content.

Leave Loading

In Australia, an additional percentage amount of the annual leave paid that is paid
to the employee.

Leaver’s Statement

In the UK, this Records details of Statutory Sick Pay (SSP) paid during a previous
employment (issued as form SSP1L) which is used to calculate a new employee’s
entitlement to SSP. If a new employee falls sick, and the last date that SSP was paid for
under the previous employment is less than eight calendar weeks before the first day of
the PIW for the current sickness, the maximum liability for SSP is reduced by the number
of weeks of SSP shown on the statement.
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Legal Employer

A business in Australia that employs people and has registered with the Australian
Tax Office as a Group Employer.

Life Event

A significant change in a person’s life that results in a change in eligibility or ineligibility
for a benefit.

Life Event Collision

A situation in which the impacts from multiple life events on participation
eligibility, enrollability, level of coverage or activity rates conflict with each other.

Life Event Enrollment

A benefits plan enrollment that is prompted by a life event occurring at any time during
the plan year.

Linked PIWs

In the UK, these are linked periods of incapacity for work that are treated as one to
calculate an employee’s entitlement to Statutory Sick Pay (SSP). A period of incapacity
for work (PIW) links to an earlier PIW if it is separated by less than the linking interval. A
linked PIW can be up to three years long.

Linking Interval

In the UK, this is the number of days that separate two periods of incapacity for work. If
a period of incapacity for work (PIW) is separated from a previous PIW by less than the
linking interval, they are treated as one PIW according to the legislation for entitlement
to Statutory Sick Pay (SSP). An employee can only receive SSP for the maximum number
of weeks defined in the legislation for one PIW.

LMSS

Line Manager Self Service. A predefined SSHR responsibility.

Long Service Leave

Leave with pay granted to employees of a particular employer after a prescribed period
of service or employment with that employer.

Lookup Types

Categories of information, such as nationality, address type and tax type, that have a
limited list of valid values. You can define your own Lookup Types, and you can add
values to some predefined Lookup Types.

Lower Earnings Limit (LEL)

In the UK, this is the minimum average weekly amount an employee must earn to pay
National Insurance contributions. Employees who do not earn enough to pay National
Insurance cannot receive Statutory Sick Pay (SSP) or Statutory Maternity Pay (SMP).

Manager

(iRecruitment) A manager accesses the iRecruitment system to document their hiring
needs and conduct their recruiting activities online. Specifically, these activities include
vacancy definition, searching for candidates, and processing applicants through the
vacancy process.
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Manager-Employee Appraisal

Part of the SSHR Appraisal function. A manager appraisal of an employee. However, an
appraising manager does not have to be a manager.

Mapping

If you are bringing in data from a text file to Oracle HRMS using a spreadsheet created
in Web ADI, you need to map the columns in the text file to the application’s tables
and columns.

Maternity Pay Period

In the UK, this is the period for which Statutory Maternity Pay (SMP) is paid. It may
start at any time from the start of the 11th week before the expected week of confinement
and can continue for up to 18 weeks. The start date is usually agreed with the
employee, but can start at any time up to the birth. An employee is not eligible to SMP
for any week in which she works or for any other reason for ineligibility, defined by
the legislation for SMP.

Medicare Levy

An amount payable by most taxpayers in Australia to cover some of the cost of the
public health system.

Menus

You set up your own navigation menus, to suit the needs of different users.

My Account

(iRecruitment) My Account is the total of either a candidate or applicant’s personal
and vacancy-specific information including the information needed to manage their
progress through the recruitment process.

NACHA

National Automated Clearing House Association. This is the US system for making
direct deposit payments to employees.

National Identifier

This is the alphanumeric code that is used to uniquely identify a person within their
country. It is often used for taxation purposes. For example, in the US it is the Social
Security Number, in Italy it is the Fiscal Code, and in New Zealand it is the IRD Number.

National Occupational Classification (NOC) code

In Canada, the National Occupational Classification (NOC) System was developed to
best reflect the type of work performed by employees. Occupations are grouped in terms
of particular tasks, duties and responsibilities. The use of this standardized system
ensures consistency of data from year to year within the same company as well as
between companies. These codes are used in the Employment Equity Report.

Net Accrual Calculation

The rule that defines which element entries add to or subtract from a plan’s accrual
amount to give net entitlement.
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Net Entitlement

The amount of unused paid time off an employee has available in an accrual plan at
any given point in time.

Nonrecurring Elements

Elements that process for one payroll period only unless you make a new entry for
an employee.

See also: Recurring Elements, page Glossary-24

North American Industrial Classification (NAIC) code

The North American Industrial Classification system (NAICs) was developed jointly
by the US, Canada and Mexico to provide comparability in statistics regarding
business activity across North America. The NAIC replaces the US Standard Industrial
Classification (SIC) system, and is used in the Employment Equity Report.

Not in Program Plan

A benefit plan that you define outside of a program.

OLM

Oracle Learning Management.

Online Analytical Processing (OLAP)

Analysis of data that reveals business trends and statistics that are not immediately
visible in operational data.

Online Transactional Processing (OLTP)

The storage of data from day-to-day business transactions into the database that contains
operational data.

Open Enrollment

A type of scheduled enrollment in which participants can enroll in or alter elections
in one or more benefits plans.

Oracle FastFormula

Formulas are generic expressions of calculations or comparisons you want to repeat
with different input values. With Oracle FastFormula you can write formulas using
English words and basic mathematical functions. The output of FastFormulas is fed
back into reports.

Organization

A required component of employee assignments. You can define as many organizations
as you want within your Business Group. Organizations can be internal, such as
departments, or external, such as recruitment agencies. You can structure your
organizations into organizational hierarchies for reporting purposes and for system
access control.

OSSWA

Oracle Self Service Web Applications.

Glossary-18



Outcome

For a unit standard competence, a behavior or performance standard associated with
one or more assessment criteria. A worker achieves a unit standard competence when
they achieve all outcomes for that competence.

Overrides

You can enter overrides for an element’s pay or input values for a single payroll
period. This is useful, for example, when you want to correct errors in data entry for a
nonrecurring element before a payroll run.

Parameter Portlet

A portlet in which you select a number of parameters that may affect all your portlets on
your page. These may include an effective date, the reporting period, the comparison
type, the reporting manager, and the output currency for your reports. The parameter
portlet is usually available at the top of the portal page.

Pattern

A pattern comprises a sequence of time units that are repeated at a specified
frequency. The Statutory Absence Payments (UK) feature, uses SSP qualifying patterns
to determine employees entitlement to Statutory Sick Pay (SSP).

Pattern Time Units

A sequence of time units specifies a repeating pattern. Each time unit specifies a time
period of hours, days or weeks.

Pay Scale

A set of progression points that can be related to one or more rates of pay. Employee’s
are placed on a particular point on the scale according to their grade and, usually, work
experience.

See also: Grade Scale, page Glossary-13

Pay Value

An amount you enter for an element that becomes its run item without formula
calculations.

See also: Input Values, page Glossary-14

Payment Type

There are three standard payment types for paying employees: check, cash and direct
deposit. You can define your own payment methods corresponding to these types.

Payroll

A group of employees that Oracle Payroll processes together with the same processing
frequency, for example, weekly, monthly or bimonthly. Within a Business Group, you
can set up as many payrolls as you need.

Payroll Reversal

A payroll reversal occurs when you reverse a payroll run for a single employee, in
effect cancelling the run for this employee.
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Payroll Rollback

You can schedule a payroll rollback when you want to reverse an entire payroll
run, cancelling out all information processed in that run. To preserve data integrity, you
can roll back only one payroll at a time, starting with the one most recently run.

Payroll Run

The process that performs all the payroll calculations. You can set payrolls to run at
any interval you want.

People List

An SSHR line manager utility used to locate an employee.

Performance Management Framework (PMF)

A business intelligence tool used to alert users to exceptional circumstances, as defined
by KPIs. When a particular factor measured by HRMSi goes beyond a threshold chosen
by the user, the system sends the user a workflow notification.

Performance Management Viewer (PMV)

A reporting tool that displays the report that corresponds to one or more PMF targets.

Performance (within Assessment)

An expectation of "normal" performance of a competence over a given period. For
example, a person may exceed performance expectation in the communication
competence.

See also: Proficiency (within Assessment), page Glossary-21, Competence, page
Glossary-7, Assessment, page Glossary-3

Period of Incapacity for Work (PIW)

In the UK, this is a period of sickness that lasts four or more days in a row, and is the
minimum amount of sickness for which Statutory Sick Pay can be paid. If a PIW is
separated by less then the linking interval, a linked PIW is formed and the two PIWs
are treated as one.

Period of Placement

The period of time a contingent worker spends working for an organization. A
contingent worker can have only one period of placement at a time although they can
have multiple assignments during that time.

Period Type

A time division in a budgetary calendar, such as week, month, or quarter.

Personal Public Service Number (PPS)

The Irish equivalent to National Insurance number in the UK, or the Social Security
number in the US.

Personal Tax Credits Return (TD1)

A Revenue Canada form which each employee must complete. Used by the employee
to reduce his or her taxable income at source by claiming eligible credits and also
provides payroll with such important information as current address, birth date, and
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SIN. These credits determine the amount to withhold from the employee’s wages for
federal/provincial taxes.

Person Search

An SSHR function which enables a manager to search for a person. There are two
types of search, Simple and Advanced.

Person Type

There are eight system person types in Oracle HRMS. Seven of these are combinations
of employees, ex-employees, applicants, and ex-applicants. The eighth category is
’External’. You can create your own user person types based on the eight system types.

Personnel Actions

Personnel actions is a public sector term describing business processes that define
and document the status and conditions of employment. Examples include
hiring, training, placement, discipline, promotion, transfer, compensation, or
termination. Oracle HRMS uses the term self-service actions synonymously with this
public sector term. Oracle Self Service Human Resources (SSHR) provides a configurable
set of tools and web flows for initiating, updating, and approving self-service actions.

Plan Design

The functional area that allows you to set up your benefits programs and
plans. This process involves defining the rules which govern eligibility, available
options, pricing, plan years, third party administrators, tax impacts, plan
assets, distribution options, required reporting, and communications.

Plan Sponsor

The legal entity or business responsible for funding and administering a benefits
plan. Generally synonymous with employer.

Position

A specific role within the Business Group derived from an organization and a job. For
example, you may have a position of Shipping Clerk associated with the organization
Shipping and the job Clerk.

Predefined Components

Some elements and balances, all primary element classifications and some secondary
classifications are defined by Oracle Payroll to meet legislative requirements, and are
supplied to users with the product. You cannot delete these predefined components.

Professional Information

An SSHR function which allows an employee to maintain their own professional details
or a line manager to maintain their direct reports professional details.

Proficiency (within Assessment)

The perceived level of expertise of a person in a competence, in the opinion of
the assessor, over a given period. For example, a person may demonstrate the
communication competence at Expert level.

See also: Performance (within Assessment), page Glossary-20, Competence, page
Glossary-7, Assessment, page Glossary-3

Glossary-21



Proficiency Level

A system for expressing and measuring how a competence is exhibited in the work
context.

See also: Behavioral Indicators, page Glossary-4.

Progression Point

A pay scale is calibrated in progression points, which form a sequence for the progression
of employees up the pay scale.

See also: Pay Scale, page Glossary-19

Prospect Pool

(iRecruitment) The prospect pool contains all registered users who have given
permission for their information to be published.

Provincial/Territorial Employment Standards Acts

In Canada, these are laws covering minimum wages, hours of work, overtime, child
labour, maternity, vacation, public/general holidays, parental and adoption
leave, etc., for employees regulated by provincial/territorial legislation.

Provincial Health Number

In Canada, this is the account number of the provincially administered health care plan
that the employer would use to make remittances. There would be a unique number for
each of the provincially controlled plans i.e. EHT, Quebec HSF, etc.

PTO Accrual Plan

A benefit in which employees enroll to entitle them to accrue and take paid time off
(PTO). The purpose of absences allowed under the plan, who can enroll, how much time
accrues, when the time must be used, and other rules are defined for the plan.

QPP

(See Canada/Quebec Pension Plan)

QA Organization

Quality Assurance Organization. Providers of training that leads to Qualifications
Framework qualifications register with a QA Organization. The QA Organization is
responsible for monitoring training standards.

Qualification Type

An identified qualification method of achieving proficiency in a competence, such as
an award, educational qualification, a license or a test.

See also: Competence, page Glossary-7

Qualifications Framework

A national structure for the registration and definition of formal qualifications. It
identifies the unit standard competencies that lead to a particular qualification, the
awarding body, and the field of learning to which the qualification belongs, for example.
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Qualifying Days

In the UK, these are days on which Statutory Sick Pay (SSP) can be paid, and the only
days that count as waiting days. Qualifying days are normally work days, but other
days may be agreed.

Qualifying Pattern

See: SSP Qualifying Pattern, page Glossary-27

Qualifying Week

In the UK, this is the week during pregnancy that is used as the basis for the qualifying
rules for Statutory Maternity Pay (SMP). The date of the qualifying week is fifteen weeks
before the expected week of confinement and an employee must have been continuously
employed for at least 26 weeks continuing into the qualifying week to be entitled to SMP.

Quebec Business Number

In Canada, this is the employer’s account number with the Ministere du Revenu du
Quebec, also known as the Quebec Identification number. It consists of 15 digits, the first
9 identify the employer, the next 2 identify the type of tax account involved (payroll
vs. corporate tax), and the last 4 identify the particular account for that tax.

Questionnaire

An SSHR function which records the results of an appraisal.

QuickPaint Report

A method of reporting on employee and applicant assignment information. You can
select items of information, paint them on a report layout, add explanatory text, and save
the report definition to run whenever you want.

See also: Assignment Set, page Glossary-3

QuickPay

QuickPay allows you to run payroll processing for one employee in a few minutes’
time. It is useful for calculating pay while someone waits, or for testing payroll formulas.

Ranking

(iRecruitment) A manually entered value to indicate the quality of the applicant against
other applicants for a specific vacancy.

Rates

A set of values for employee grades or progression points. For example, you can define
salary rates and overtime rates.

Rating Scale

Used to describe an enterprise’s competencies in a general way. You do not hold the
proficiency level at the competence level.

See also: Proficiency Level, page Glossary-22

Record of Employment (ROE)

A Human Resources Development Canada form that must be completed by an employer
whenever an interruption of earnings occurs for any employee. This form is necessary to
claim Employment Insurance benefits.
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Recruitment Activity

An event or program to attract applications for employment. Newspaper
advertisements, career fairs and recruitment evenings are all examples of recruitment
activities. You can group several recruitment activities together within an overall activity.

Recurring Elements

Elements that process regularly at a predefined frequency. Recurring element entries
exist from the time you create them until you delete them, or the employee ceases to be
eligible for the element. Recurring elements can have standard links.

See also: Nonrecurring Elements, page Glossary-18, Standard Link, page Glossary-27

Region

A collection of logically related fields in a window, set apart from other fields by a
rectangular box or a horizontal line across the window.

See also: Block, page Glossary-5, Field, page Glossary-12

Registered Pension Plan (RPP)

This is a pension plan that has been registered with Revenue Canada. It is a plan where
funds are set aside by an employer, an employee, or both to provide a pension to
employees when they retire. Employee contributions are generally exempt from tax.

Registered Retirement Savings Plan (RRSP)

This is an individual retirement savings plan that has been registered with Revenue
Canada. Usually, contributions to the RRSP, and any income earned within the RRSP, is
exempt from tax.

Registered User

(iRecruitment) A person who has registered with the iRecruitment site by entering an
e-mail address and password. A registered user does not necessarily have to apply
for jobs.

Report Parameters

Inputs you make when submitting a report to control the sorting, formatting, selection,
and summarizing of information in the report.

Report Set

A group of reports and concurrent processes that you specify to run together.

Requisition

The statement of a requirement for a vacancy or group of vacancies.

Request Groups

A list of reports and processes that can be submitted by holders of a particular
responsibility.

See also: Responsibility, page Glossary-25
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Residual

The amount of unused paid time off entitlement an employee loses at the end of an
accrual term. Typically employees can carry over unused time, up to a maximum, but
they lose any residual time that exceeds this limit.

See also: Carry Over, page Glossary-6

Responsibility

A level of authority in an application. Each responsibility lets you access a specific set of
Oracle Applications forms, menus, reports, and data to fulfill your business role. Several
users can share a responsibility, and a single user can have multiple responsibilities.

See also: Security Profile, page Glossary-26, User Profile Options, page Glossary-30, Request
Groups, page Glossary-24, Security Groups, page Glossary-24

Resume

A document that describes the experience and qualifications of a candidate.

RetroPay

A process that recalculates the amount to pay an employee in the current period to
account for retrospective changes that occurred in previous payroll periods.

Retry

Method of correcting a payroll run or other process before any post-run processing takes
place. The original run results are deleted and the process is run again.

Revenue Canada

Department of the Government of Canada which, amongst other
responsibilities, administers, adjudicates, and receives remittances for all taxation in
Canada including income tax, Employment Insurance premiums, Canada Pension Plan
contributions, and the Goods and Services Tax (legislation is currently proposed to revise
the name to the Canada Customs and Revenue Agency). In the province of Quebec the
equivalent is the Ministere du Revenu du Quebec.

Reversal

Method of correcting payroll runs or QuickPay runs after post-run processing has taken
place. The system replaces positive run result values with negative ones, and negative
run result values with positive ones. Both old and new values remain on the database.

Reviewer (SSHR)

A person invited by an appraising manager to add review comments to an appraisal.

RIA

Research Institute of America (RIA), a provider of tax research, practice materials, and
compliance tools for professionals, that provides U.S. users with tax information.

Rollback

Method of removing a payroll run or other process before any post-run processing takes
place. All assignments and run results are deleted.

Rollup

An aggregate of data that includes subsidiary totals.
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Run Item

The amount an element contributes to pay or to a balance resulting from its processing
during the payroll run. The Run Item is also known as calculated pay.

Salary Basis

The period of time for which an employee’s salary is quoted, such as hourly or
annually. Defines a group of employees assigned to the same salary basis and receiving
the same salary element.

Salary Rate

The rate of pay associated with a grade or step. Used by Grade/Step Progression.

Scheduled Enrollment

A benefits plan enrollment that takes place during a predefined enrollment period, such
as an open enrollment. Scheduled enrollments can be administrative, open, or
unrestricted.

Search by Date

An SSHR sub-function used to search for a Person by Hire date, Application date, Job
posting date or search by a Training event date.

Security Group

Security groups enable HRMS users to partition data by Business Group. Only used for
Security Groups Enabled security.

See also: Responsibility, page Glossary-25, Security Profile, page Glossary-26, User Profile
Options, page Glossary-30

Security Groups Enabled

Formerly known as Cross Business Group Responsibility security. This security model
uses security groups and enables you to link one responsibility to many Business Groups.

Security Profile

Security profiles control access to organizations, positions and employee and applicant
records within the Business Group. System administrators use them in defining users’
responsibilities.

See also: Responsibility, page Glossary-25

Self Appraisal

Part of the SSHR Appraisal function. This is an appraisal undertaken by an employee to
rate their own performance and competencies.

Site Visitor

(iRecruitment) A person who navigates to the iRecruitment web site and may view
job postings. This person has not yet registered or logged in to the iRecruitment
system. This individual may search for postings on the web site and also has the ability
to log in or register with the iRecruitment site.

SMP

See: Statutory Maternity Pay, page Glossary-28
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Social Insurance Number (SIN)

A unique number provided by Human Resources Development Canada (HRDC) to each
person commencing employment in Canada. The number consists of 9 digits in the
following format (###-###-###).

Source Deductions Return (TP 1015.3)

A Ministere du Revenu du Quebec form which each employee must complete. This
form is used by the employee to reduce his or her taxable income at source by claiming
eligible credits and also provides payroll with such important information as current
address, birth date, and SIN. These credits determine the amount of provincial tax to
withhold from the employee’s wages.

Special Information Types

Categories of personal information, such as skills, that you define in the Personal
Analysis key flexfield.

Special Run

The first run of a recurring element in a payroll period is its normal run. Subsequent
runs in the same period are called special runs. When you define recurring elements you
specify Yes or No for special run processing.

SSHR

Oracle Self-Service Human Resources. An HR management system using an intranet
and web browser to deliver functionality to employees and their managers.

SSP

See: Statutory Sick Pay, page Glossary-28

SSP Qualifying Pattern

In the UK, an SSP qualifying pattern is a series of qualifying days that may be repeated
weekly, monthly or some other frequency. Each week in a pattern must include at least
one qualifying day. Qualifying days are the only days for which Statutory Sick Pay
(SSP) can be paid, and you define SSP qualifying patterns for all the employees in your
organization so that their entitlement to SSP can be calculated.

Standard HRMS Security

The standard security model. Using this security model you must log on as a different
user to see a different Business Group.

Standard Link

Recurring elements with standard links have their element entries automatically created
for all employees whose assignment components match the link.

See also: Element Link, page Glossary-11, Recurring Elements, page Glossary-24

Statement of Commissions and Expenses for Source Deduction Purposes (TP
1015.R.13.1)

A Ministere du Revenu du Quebec form which allows an employee who is paid partly or
entirely by commissions to pay a constant percentage of income tax based on his or her
estimated commissions for the year, less allowable business expenses.
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Statement of Earnings (SOE)

A summary of the calculated earnings and deductions for an assignment in a payroll
period.

Statement of Remuneration and Expenses (TD1X)

In Canada, the Statement of Remuneration and Expenses allows an employee who is
paid partly or entirely by commission to pay a constant percentage of income tax, based
on his or her estimated income for the year, less business-related expenses.

Statutory Adoption Pay

In the UK, Statutory Adoption Pay (SAP) is payable to a person of either sex with whom
a child is, or is expected to be, placed for adoption under UK law.

Statutory Maternity Pay

In the UK, you pay Statutory Maternity Pay (SMP) to female employees who take time
off work to have a baby, providing they meet the statutory requirements set out in
the legislation for SMP.

Statutory Sick Pay

In the UK, you pay Statutory Sick Pay (SSP) to employees who are off work for four or
more days because they are sick, providing they meet the statutory requirements set
out in the legislation for SSP.

Statutory Paternity Pay

In the UK, Statutory Paternity Pay Birth (SPPB) is payable to a person supporting the
mother at the time of birth. In cases of adoption, the primary carer receives Statutory
Adoption Pay, while the secondary carer receives Statutory Paternity Pay Adoption
(SPPA).

Succession Planning

An SSHR function which enables a manager to prepare a succession plan.

Suitability Matching

An SSHR function which enables a manager to compare and rank a persons
competencies.

Superannuation Guarantee

An Australian system whereby employers are required to contribute a percentage of an
eligible employee’s earnings to a superannuation fund to provide for their retirement.

Supplier

An internal or external organization providing contingent workers for an
organization. Typically suppliers are employment or recruitment agencies.

Tabbed Regions

Parts of a window that appear in a stack so that only one is visible at any time. You click
on the tab of the required region to bring it to the top of the stack.
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Task Flows

A sequence of windows linked by buttons to take you through the steps required to
complete a task, such as hiring a new recruit. System administrators can create task
flows to meet the needs of groups of users.

Tax Point

The date from which tax becomes payable.

Template Letter

Form letter or skeleton letter that acts as the basis for creating mail merge letters. The
template letter contains the standard text, and also contains field codes, which are
replaced by data from the application during the mail merge process.

Terminating Employees

You terminate an employee when he or she leaves your organization. Information about
the employee remains on the system but all current assignments are ended.

Termination Rule

Specifies when entries of an element should close down for an employee who leaves
your enterprise. You can define that entries end on the employee’s actual termination
date or remain open until a final processing date.

Tips

An SSHR user assistance component that provides information about a field.

Transcentive

A third-party compensation management solutions provider, that provides additional
information about benefits choices.

Unit Standard

A nationally registered document that describes a standard of performance. The
standard is typically defined and maintained by industry representatives.

Unit Standard Competence

A competence that is defined in a Unit Standard and linked to a Qualifications
Framework qualification.

Upload

The process of transferring the data from a spreadsheet on your desktop, created using
Web ADI, back to the Oracle HRMS application.

User Assistance Components

SSHR online help comprising tips and instructions.

User Balances

Users can create, update and delete their own balances, including dimensions and
balance feeds.

See also: Balances, page Glossary-4
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User Profile Options

Features that allow system administrators and users to tailor Oracle HRMS to their
exact requirements.

See also: Responsibility, page Glossary-25, Security Profile, page Glossary-26

User-based Security

With this type of security, the application generates the security permissions for a
current user when that user logs on to a system. The system uses the security profile
(can be position, supervisor, or organization-based, for example) to generate security
permissions for the current user, for example, based on the user’s position. An
alternative to user-based security is a security profile with defined security rules, for
example, to specify that the top-level position for a position-based security profile is
Position A, irrespective of the current user’s position.

View

An example of an interface that you can use to download data from the Oracle HRMS
application to a spreadsheet using Web ADI.

Viewer (SSHR)

A person with view only access to an appraisal. An appraising manager or an employee
in a 360 Degree Self appraisal can appoint view only access to an appraisal.

Viewer (Web ADI)

A desktop application, such as a spreadsheet or word processing tool, that you use to
view the data downloaded from Oracle HRMS via Web ADI.

Voluntary

Term used in turnover to describe employees who have ceased employment with the
enterprise of their own accord, for example, by resigning.

Waiting Days

In the UK, statutory Sick Pay is not payable for the first three qualifying days in period
of incapacity for work (PIW), which are called waiting days. They are not necessarily the
same as the first three days of sickness, as waiting days can be carried forward from a
previous PIW if the linking interval between the two PIWs is less than 56 days.

WCB Account Number

In Canada, this is the account number of the provincially administered Worker’s
Compensation Board that the employer would use to make remittances. There would be
a unique number for each of the provincially controlled boards i.e. Workplace Safety
& Insurance Board of Ontario, CSST, etc.

Work Choices

Also known as Work Preferences, Deployment Factors, or Work Factors. These can affect
a person’s capacity to be deployed within an enterprise, such willingness to travel or
relocate. You can hold work choices at both job and position level, or at person level.

Worker

An employee or a contingent worker.
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Worker’s Compensation Board

In Canada, this is a provincially governed legislative body which provides benefits
to employees upon injury, disability, or death while performing the duties of the
employer. Worker’s Compensation Board premiums are paid entirely by the employer.

Workflow

An Oracle application which uses charts to manage approval processes and in addition is
used in SSHR to configure display values of sections within a web page and instructions.

Workforce Measurement Type (WMT)

Groups of different units combined to measure the workforce. The most common units
are headcount and full time equivalent.

Workforce Measurement Value (WMV)

A WMT value, for example, headcount or FTE.

Work Structures

The fundamental definitions of organizations, jobs, positions, grades, payrolls and other
employee groups within your enterprise that provide the framework for defining the
work assignments of your employees.
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