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Preface

Intended Audience
Welcome to Release 11i of the Oracle US Federal Human Resources
Configuring, Reporting, and System Administration Guide.

This guide assumes you have a working knowledge of the following:

• The principles and customary practices of your business area.

• Oracle HRMS.

If you have never used Oracle HRMS, Oracle suggests you attend one or more of the
Oracle HRMS training classes available through Oracle University

• Oracle Self-Service Web Applications.

To learn more about Oracle Self-Service Web Applications, read the Oracle Self-Service
Web Applications Implementation Manual.

• The Oracle Applications graphical user interface.

To learn more about the Oracle Applications graphical user interface, read the
Oracle Applications User’s Guide.

See Related Documents for more information about Oracle Applications product
information.

See Related Documents on page xiv for more Oracle Applications product information.

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services
within the United States of America 24 hours a day, seven days a week. For TTY support,
call 800.446.2398.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation accessible,
with good usability, to the disabled community. To that end, our documentation
includes features that make information available to users of assistive technology. This
documentation is available in HTML format, and contains markup to facilitate access by
the disabled community. Accessibility standards will continue to evolve over time, and
Oracle is actively engaged with other market-leading technology vendors to address
technical obstacles so that our documentation can be accessible to all of our customers.
For more information, visit the Oracle Accessibility Program Web site at
http://www.oracle.com/accessibility/ .
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Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an otherwise
empty line; however, some screen readers may not always read a line of text that consists
solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any
representations regarding the accessibility of these Web sites.

Structure
1 Security Rules
2 Desktop Integration
3 Extending Oracle HRMS
4 Administering Workforce Intelligence
5 Maintenance of Federal Data
6 Federal Workflow
7 Interface Configuration
A Windows and their Navigation Paths

This section lists the default navigation paths for all the windows in Oracle HRMS as
they are supplied. You can use task flow windows directly from the menu, or from
the People and Assignment windows.

B Reports and Processes in Oracle HRMS

This section shows the default reports and processes in Oracle HRMS as they are
supplied. The responsibility that you use determines which reports you can use and
how you access them.

HRMS Glossary

Related Documents
Oracle HRMS shares business and setup information with other Oracle Applications
products. Therefore, you may want to refer to other user guides when you set up
and use Oracle HRMS.

You can read the guides online by choosing Library from the expandable menu on your
HTML help window, by reading from the Oracle Applications Document Library CD
included in your media pack, or by using a Web browser with a URL that your system
administrator provides.

If you require printed guides, you can purchase them from the Oracle store at
http://oraclestore.oracle.com.

Guides Related to All Products

Oracle Applications User’s Guide

This guide explains how to enter data, query, run reports, and navigate using the
graphical user interface (GUI). This guide also includes information on setting user
profiles, as well as running and reviewing reports and concurrent processes.

xiv



You can access this user’s guide online by choosing ”Getting started with Oracle
Applications” from any Oracle Applications help file.

Guides Related to This Product

OA Personalization Framework and OA Extensibility Framework

Learn about the capabilities of the 5.6 Framework technologies.

Oracle Human Resources Management Systems Enterprise and Workforce Management
Guide

Learn how to use Oracle HRMS to represent your agency. This includes setting up
your organization hierarchy, recording details about jobs and positions within your
agency, defining person types to represent your workforce, and also how to manage
your budgets and costs.

Oracle Human Resources Management Systems Workforce Sourcing, Deployment,
and Talent Management Guide

Learn how to use Oracle HRMS to represent your workforce. This includes recruiting
new workers, recording and managing the workforce using for example by processing
Request for Personnel Actions and mass actions, and reporting on your workforce.

Oracle Human Resources Management Systems Compensation and Benefits
Management Guide

Learn how to use Oracle HRMS to manage compensation. For example, read how to
process compensation and awards, set up automated step increases, and federal benefits
such as Federal Health Employee Benefits and Thrift Savings Plans. You can also learn
about setting up earnings and deductions for payroll processing, managing leave and
absences, and reporting on compensation.

Oracle Human Resources Management Systems Configuring, Reporting, and System
Administration in Oracle HRMS

Learn about extending and configuring Oracle HRMS, managing
security, auditing, information access, and letter generation.

Oracle Human Resources Management Systems Implementation Guide

Learn about the setup procedures you need to carry out in order to successfully
implement Oracle HRMS in your enterprise.

Oracle Human Resources Management Systems FastFormula User Guide

Learn about the different uses of Oracle FastFormula, and understand the rules and
techniques you should employ when defining and amending formulas for use with
Oracle applications.

Oracle Human Resources Management Systems Deploy Self-Service Capability Guide

Set up and use self-service human resources (SSHR) functions for managers, HR
Professionals, and employees.

Oracle Human Resources Management Systems Deploy Strategic Reporting (HRMSi)

Implement and administer Oracle Human Resources Management Systems Intelligence
(HRMSi) in your environment.

Oracle Human Resources Management Systems Strategic Reporting (HRMSi) User Guide
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Learn about the workforce intelligence reports included in the HRMSi product, including
Daily Business Intelligence reports, Discoverer workbooks, and Performance
Management Framework reports.

Implementing Oracle Approvals Management

Use Oracle Approvals Management (AME) to define the approval rules that determine
the approval processes for Oracle applications. Download this guide from Oracle
MetaLink, Note: 282529.1.

Oracle iRecruitment Implementation Guide

Set up Oracle iRecruitment to manage all of your enterprise’s recruitment needs.

Oracle Learning Management User Guide

Set up and use Oracle Learning Management to accomplish your online and offline
learning goals.

Oracle Learning Management Implementation Guide

Implement Oracle Learning Management to accommodate your specific business
practices.

Oracle Time and Labor Implementation and User Guide

Learn how to capture work patterns such as shift hours so that this information can be
used by other applications such as General Ledger.

Installation and System Administration

Oracle Applications Concepts

This guide provides an introduction to the concepts, features, technology
stack, architecture, and terminology for Oracle Applications Release 11i. It provides a
useful first book to read before an installation of Oracle Applications. This guide also
introduces the concepts behind Applications-wide features such as Business Intelligence
(BIS), languages and character sets, and Self-Service Web Applications.

Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle Applications
products. In Release 11i, much of the installation process is handled using Oracle
Rapid Install, which minimizes the time to install Oracle Applications and the Oracle
technology stack by automating many of the required steps. This guide contains
instructions for using Oracle Rapid Install and lists the tasks you need to perform
to finish your installation. You should use this guide in conjunction with individual
product user guides and implementation guides.

Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or
Release 11.0 products to Release 11i. This guide describes the upgrade process and
lists database and product-specific upgrade tasks. You must be either at Release 10.7
(NCA, SmartClient, or character mode) or Release 11.0, to upgrade to Release 11i. You
cannot upgrade to Release 11i directly from releases prior to 10.7.

"About" Document

For information about implementation and user document, instructions for applying
patches, new and changes setup steps, and descriptions of software updates, refer
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to the "About" document for your product. "About" documents are available on
OracleMetaLink for most products starting with Release 11.5.8.

Maintaining Oracle Applications

Use this guide to help you run the various AD utilities, such as
AutoUpgrade, AutoPatch, AD Administration, AD Controller, AD Relink, License
Manager, and others. It contains how-to steps, screenshots, and other information that
you need to run the AD utilities. This guide also provides information on maintaining
the Oracle applications file system and database.

Oracle Applications System Administrator’s Guide

This guide provides planning and reference information for the Oracle Applications
System Administrator. It contains information on how to define security, customize
menus and online help, and manage concurrent processing.

Oracle Alert User’s Guide

This guide explains how to define periodic and event alerts to monitor the status of
your Oracle Applications data.

Oracle Applications Developer’s Guide

This guide contains the coding standards followed by the Oracle Applications
development staff and describes the Oracle Application Object Library components that
are needed to implement the Oracle Applications user interface described in the Oracle
Applications User Interface Standards for Forms-Based Products. This manual also provides
information to help you build your custom Oracle Forms Developer forms so that the
forms integrate with Oracle Applications.

Oracle Applications User Interface Standards for Forms-Based Products

This guide contains the user interface (UI) standards followed by the Oracle Applications
development staff. It describes the UI for the Oracle Applications products and how to
apply this UI to the design of an application built by using Oracle Forms.

Other Implementation Documentation

Oracle Applications Product Update Notes

Use this guide as a reference for upgrading an installation of Oracle Applications. It
provides a history of the changes to individual Oracle Applications products between
Release 11.0 and Release 11i. It includes new features, enhancements, and changes made
to database objects, profile options, and seed data for this interval.

Oracle Workflow Administrator’s Guide

This guide explains how to complete the setup steps necessary for any Oracle
Applications product that includes workflow-enabled processes, as well as how to
monitor the progress of runtime workflow processes.

Oracle Workflow Developer’s Guide

This guide explains how to define new workflow business processes and customize
existing Oracle Applications-embedded workflow processes. It also describes how to
define and customize business events and event subscriptions.

Oracle Workflow User’s Guide

This guide describes how Oracle Applications users can view and respond to workflow
notifications and monitor the progress of their workflow processes.
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Oracle Workflow API Reference

This guide describes the APIs provided for developers and administrators to access
Oracle Workflow.

Oracle Applications Flexfields Guide

This guide provides flexfields planning, setup, and reference information for the
Oracle HRMS implementation team, as well as for users responsible for the ongoing
maintenance of Oracle Applications product data. This guide also provides information
on creating custom reports on flexfields data.

Oracle eTechnical Reference Manuals

Each eTechnical Reference Manual (eTRM) contains database diagrams and a detailed
description of database tables, forms, reports, and programs for a specific Oracle
Applications product. This information helps you convert data from your existing
applications, integrate Oracle Applications data with non-Oracle applications, and
write custom reports for Oracle Applications products. Oracle eTRM is available on
OracleMetalink.

Oracle Applications Message Manual

This manual describes all Oracle Applications messages. this manual is available in
HTML format on the documentation CD-ROM for Release 11i.

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser,
database triggers, or any other tool to modify Oracle Applications data unless otherwise
instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and
maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus
to modify Oracle Applications data, you risk destroying the integrity of your data and
you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using an
Oracle Applications form can update many tables at once. But when you modify Oracle
Applications data using anything other than Oracle Applications, you may change a row
in one table without making corresponding changes in related tables. If your tables get
out of synchronization with each other, you risk retrieving erroneous information and
you risk unpredictable results throughout Oracle Applications.

When you use Oracle Applications to modify your data, Oracle Applications
automatically checks that your changes are valid. Oracle Applications also keeps track of
who changes information. If you enter information into database tables using database
tools, you may store invalid information. You also lose the ability to track who has
changed your information because SQL*Plus and other database tools do not keep a
record of changes.
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1
Security Ru les

Security Overview
Defining which records and information users can access is fundamental to HRMS
security.

As part of your implementation plan, you identify who will use Oracle HRMS, what
information they require, and how they use it. You can control a user’s access to database
elements such as records, fields, forms, and functions, and you can also control a user’s
access to other user records and data.

All Oracle Applications users access the system through a responsibility that is linked
to a security group and a security profile. The responsibility is the primary means of
defining security. The security group determines which business group the user can
access. The security profile determines which records (related to organizations, positions
and payrolls) the user can access within the business group. For example, you can
restrict a manager’s security permissions so that the manager can only access the
person records for those employees and workers within a supervisor hierarchy. This
restriction enables secure, reliable data access and ensures that only people with the
correct permissions can access personal data.

See: Responsibilities, page 1-96

Security and Business Groups
In general, a user can only view the records for one business group at a
time. However, depending on the value of the HR:Cross Business Group Profile
option, you can view specific information across business groups. See: User Profiles,
page 1-49

See also: Single and Multiple Business Groups, Oracle HRMS Enterprise and Workforce
Management Guide

Within a business group you can control:

• Who the user can access, using security profiles. You can restrict access by:

• organization hierarchy

• position hierarchy

• supervisor hierarchy

• payroll

• supervisor assignment
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You can also create your own custom restrictions and combine them with the
standard restrictions.

Note: You can configure the above security restrictions
to be user-based. The application evaluates the security
permissions dynamically for the user currently logged on to the
system. User-based security profiles can be used by multiple
employees which reduces set-up and administration tasks.

• What the user can access. You control user access to specific functions using function
security. You attach functions to menus which you then attach to responsibilities. By
linking the functions to responsibilities, you can restrict which users can access
particular functions, and on which menus the functions appear. By modifying the
function parameter information, you can define how the function operates and
processes information.

See: Menus, page 1-97

See: Defining Menu Functions, page 1-101

Key Concepts
For more detailed information on security concepts, see:

• Security Models, page 1-5

• Security Profiles, page 1-25

• Responsibilities, page 1-96

• Security Processes, page 1-15

Security
You can set up and maintain security of access for different classes of users. Once you
have identified who will use Oracle HRMS, what information they require, and how
they will use it, you can group together users with similar requirements and give them
the same view of the system.

In what ways can you use Security of access for different users?
You can set up menus using structures and names that make sense to the users. You
can also restrict the data users can view and edit in certain windows, so they only see
what they need to see.

This provides security for your data and an efficient interface designed for your users’
needs.

How does Oracle HRMS allow data restriction for display in a window?
If you want different users to view the same window for different purposes, you can
restrict their views in different ways. For example:

• Limit access to list of values for faster data entry

• Limit access to certain types of information
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For example, you might create a customized version of the View Element Entry
History for Employee form that does not display the birth date or citizenship in
compliance with EEO regulations. Most users’ menus would only give them access
to this customized version of the form. Those personnelist authorized to view
salary, bonus, and commission figures, would have a menu function defined to
allow access to the uncustomized form.

How does Oracle HRMS enable users to view multiple Business Groups?
Oracle HRMS is installed with two security models, each enabling you to set up security
for an enterprise which uses multiple Business Groups. Using both models you can
only view records for one business group at any one time, except in cases where the
HR:Cross Business Group user profile allows access to specific fields across all Business
Groups. The difference between the models is as follows:

• Using Standard HRMS security yyou can only link one business group to one
responsibility. You must set up different responsibilities for each business group.

• Using Security Groups Enabled security you can set up more than one business
group for a single responsibility. However, you still only view records for one
business group at a time.

How does the application restrict access to workflow transactions?
The workflow role you assign an employee and that person’s assignment to routing
groups and routing lists limit the workflow activities he or she may perform, such as
initiating or approving a Request for Personnel Action or Position Description (PD).

Workflow security prevents a form from being routed outside of its routing group. The
application also maintains a complete tracking history of an RPA or PD during the
routing process.
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Security in Oracle HRMS

Key Concepts
The following definitions describe the key concepts in Oracle HRMS security.

Menu Structures
Using menu structures, you can limit the functions a user can access. You can also restrict
access to information types by choosing which information types a user can view.

You can also create multiple versions of the same form, each one used for just one
task. This approach restricts the list of values on certain fields and therefore provides for
faster data entry. It also enables you to limit access to certain types of information.

Reporting Access
You can set up access restrictions for employees who never use the product’s windows
and do not change database information, but do access the database.

Request Groups
You can specify which processes and reports a reporting user can run by setting up
request groups. Within the request group, you use security profiles to restrict the records
accessed by the reporting user, who may run reports against the system without having
online access through the system’s forms.

Responsibility
The responsibility is your primary means of defining security. Business groups, menu
structures, task flows, and information types are linked to a responsibility.

Security Groups
Security groups are a method of partitioning data. If you are using the Security Groups
Enabled security model, you can manage information for multiple business groups
using one responsibility. This is particularly useful if you are a Service Center. Security
Groups Enabled security is also useful for organizations using Oracle Self Service HR
and organizations with employees that must access and manage records from different
business groups.

Security Models
The two security models, Standard HRMS Security (Security Groups Disabled) and
Security Groups Enabled security (formerly called Cross Business Group Responsibility
Security), both control security by restricting who and what the user can see. What
differs is how you set up security, menus and how users log in. For more detailed
information about each of the security models, see Security Models, page 1-5.

Security Processes
System security processes enable you to:

• Grant permissions to a new reporting user.
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• Maintain the lists of organizations, positions, payrolls, employees and applicants
that security profile holders can access.

• Set up and update your system to use the Security Groups Enabled security model.

Security Profiles
By defining security profiles, you can control access to records of employees at or above a
certain level in an organization. For example, you can give a department’s administrator
access to all department employee records except those of the manager and assistant
manager.

User Profiles
A user profile is a set of changeable options that affects the way your application
runs. You can set user profile options at site level, application level, responsibility
level and user level.

You can restrict access to query-only for all or a selection of your HR and Payroll forms
using a user profile option and the parameter QUERY_ONLY=YES at form function level.

Security Models
Oracle HRMS provides two different security models which enable you to set up security
specifically for your enterprise: Standard HRMS security and Security Groups Enabled
security (formerly called Cross Business Group Responsibility Security).

Note: If you want to set up security for employees who can access the
database, but do not change database information, see: Reporting
Access, page 1-14 and Setting Up Reporting Users, page 1-22.

A further option exists which enables users to simultaneously view
selected fields from all business groups in your organization regardless
of the security model. For more information see HR: Cross Business
Group Profile option, page 1-49.

Standard Security Model
Standard HRMS security restricts access to your enterprise’s records and data. To
set up Standard HRMS Security, you first create responsibilities and then define the
windows, menus items, workflows, data and records the user can access. The System
Administrator then assigns users to as many of these responsibilities as is required to
complete their business tasks.

If you are using Standard HRMS Security, you must ensure that the Enable Multiple
Security Groups profile option is set to the default value No. You must then create a
security profile for each distinct security grouping of employees your enterprise requires.

You then create a responsibility for each user type you require, for example HR
Manager, Branch Manager and Salesperson, and link the security profile and
responsibility to a business group. These three elements create a security grouping to
which you assign employees.
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Assigning Users to a Responsibility, Security Profile, and Business Group

Note: Each security grouping you create restricts access to the business
group to which the security profile and responsibility are assigned.

By assigning users to the security grouping, you grant them access to the records, menus
and data defined in the security profile and responsibility. You can add further users to
this security component, but you cannot re-use the security profile and responsibility
within another business group.

Your enterprise can also set up request groups to restrict user access to reports and
processes. The request group is associated with a security profile which defines the
data a user can view, and is then assigned to a responsibility. It is also possible to set
up reporting only request groups for users who access the database, but who are not
permitted to change any of the records within the system.

For more information, see Setting up Standard Security, page 1-16.

Access to Multiple Business Groups using Standard Security

In Standard HRMS Security, you can grant users access to more than one business group
within your enterprise. To do this, you must create security profiles and responsibilities
and assign them to each additional business group. If a user’s responsibility is assigned
to more than one business group, they will not be able to view data from more than
one business group at any time.

Note: The HR: Cross Business Group Profile option enables users to
view some limited information across all business groups within an
enterprise. For more information, see HR: Cross Business Group Profile
option, page 1-49.
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Standard HRMS Security (Security Groups Disabled) is commonly used in organizations
which operate within a single legislation and a single business group.

Important: After setting up Standard HRMS Security, you can switch to
the Security Groups Enabled security model. You cannot, however, to
revert back to Standard HRMS Security after this change has been made.

The Completed Standard HRMS Security Model

Security Groups Enabled Model
The main difference between the two security models is that the Security Groups
Enabled model enables your enterprise to share security profiles and responsibilities
between users and business groups. This reduces the set up time, and also increases the
flexibility of this security model. The key to re-usability is the relationship between the
security elements and the users that you create during the set up process.

Important: Once you have set up Security Groups Enabled security, you
cannot revert to Standard HRMS Security.

Access to Multiple Security Groups using Security Groups Enabled Model

The Security Groups Enabled security model enables you to assign a single responsibility
to more than one business group, and hence enable users to access records from
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numerous business groups, although users cannot view information from different
business groups simultaneously.

To set up Security Groups Enabled security, you set the Enable Security Groups Profile
option to Yes, and run the Enable Multiple Security Groups process. These steps in
combination create a Security Group which has the same name as the business group
from which it was created. For more information, see Security Groups, page 1-11.

Note: To make the administration of your security setup easy to
maintain, it is recommended that you leave the names of the Security
Groups the same as your business groups.

Like Standard HRMS Security, your enterprise must create Security Profiles for each
distinct security grouping within your enterprise. Security Profiles function slightly
differently in the Security Groups Enabled model than they do in Standard HRMS
security. Rather than one security profile being assigned to one responsibility, Security
Groups Enabled security enables your enterprise to assign numerous security profiles to
a responsibility. For example, an HR Manager and an Assistant HR Manager may be
able to access the same menus and windows, but may be able to view different data. The
following example illustrates the benefits of this function.

Assigning Multiple Security Profiles to a Responsibility

Note: The limitation of this is that a user can only be assigned one
Security Profile per responsibility.

The functionality of responsibilities is also enhanced in the Security Groups Enabled
security model. Increasingly, users require access to the records in more than one
business group. To accomplish this, you can assign a responsibility to multiple business
groups when you use Security Groups Enabled. The records, forms and type of data a
user can access will be the same in each of the business groups to which they have access.

Note: When a responsibility is assigned to more than one business
group, the user can only view records from one business group at
any time.

The ability to assign one responsibility to multiple business groups makes the set up
of security quicker and more efficient.
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Note: The HR: Cross Business Group Profile Option enables users
to view some information across all business groups within an
enterprise. For more information, see HR: Cross Business Group Profile
option, page 1-49.

Assigning a Responsibility to Multiple Security Groups

As with Standard HRMS Security, you can set up a request group to restrict user access
to reports and processes. The request group is associated with a responsibility which
defines the data a user can view. It is also possible to set up reporting only request
groups for users who access the database, but who are not permitted to change any of
the records within the system.

Once your enterprise has defined the security profiles and responsibilities, you must
assign them to the relevant security groups. The final stage is to assign users to this
group of information. The example below illustrates how the final security set up
may look within your enterprise.

For more information see Setting Up Security Groups Enabled Security, page 1-18.
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The Completed Security Groups Enabled Model

Three distinct enterprise types can benefit from the functionality offered by the Security
Groups Enabled model; Service Centers, Multinationals and SSHR enterprises. Of
course, the simplified set up and maintenance is of benefit to any enterprise.

Typically, Service Centers create a new business group for each customer they
serve. Furthermore, Service Centers only require one responsibility and security profile
to enable users to access and change data within the system. As the Security Groups
Enabled model enables sharing of security profiles and responsibilities, the security set
up process for Service Centers becomes quicker and more efficient.

In the case of Multinational enterprises, it is common to create a business group for
each country in which the enterprise operates, and for each legislation the enterprise
uses. Using the Security Groups Enabled model enables users to share records and data
across business groups and countries.

For enterprises that use SSHR within a global implementation, the advantages of using
Security Groups Enabled include quicker set up and easier maintenance. An additional
benefit is that transferring employees or employee information between business groups
is simplified.
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Security Groups (Security Groups Enabled Model Only)
When you use the Security Groups Enabled security model (formerly called Cross
Business Group Responsibility security), a security group is automatically created for
each business group when you run the Enable Multiple Security Group Process. Because
security groups are tied to business groups by set up, partitioning data using this
method is the same as partitioning data by business group. See: Setting Up Security
Groups Enabled security, page 1-18.

Important: Security groups are only used if you have set up your
enterprise using the Security Groups Enabled security model.

Security groups are the key component in Security Groups Enabled security. They enable
you to set up one responsibility and link this to a number of different business groups.

Before you can start using this security model you ensure that HRMS is set up to use
security groups. To do this you set the Enable Security Groups profile option to Yes and
run the Enable Multiple Security Group process.

Important: You can change from Standard HRMS security to
Security Groups Enabled security, however, you cannot switch
from Security Groups Enabled security back to Standard HRMS
security. See: Updating the Security Model, page 1-18.

Once you have set up your enterprise to use security groups, Oracle HRMS automatically
creates a security group when you set up a business group. The security group has
the same name as the business group. For example, if you create a business group
called UK Headquarters, Oracle HRMS automatically creates a security group called
UK Headquarters. The Setup Business Group, however, uses the predefined security
group Standard.

Note: If you change the name of your business group, the security group
name is not updated. To make the maintenance of your security setup
easier, Oracle recommends that you leave the names of the security
groups the same as the business groups from which they are created.

Using the Assign Security Profile window you link the user, responsibility and business
group to a security profile. By entering a business group you are automatically linking
the responsibility to the security group.

You then log on using the responsibility and security group pairing. As security groups
are automatically linked to a business group, you can then view and manage the records
for that business group.

When you log on, Oracle HRMS displays all the pairings you have created between
business groups and responsibilities. You could have the same responsibility listed twice
with different security groups and therefore business groups. By looking at the security
group you can select the correct responsibility for the business group you want to access.

To ensure the integrity of your business data, you can only view records for one business
group at any time. To view records from a different business group you must switch to
an alternative responsibility and business group pairing.

Important: Security groups are automatically created for you when you
use Oracle HRMS. Do not use the System Administrator’s Security
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Groups window to add security groups as these will not be linked to
your business groups.

End-Dating Unwanted Responsibilities
When you first enable security groups and run the Enable Multiple Security Groups
concurrent process, the process creates two sets of records for existing user/responsibility
pairs:

• For each responsibility connected to a user it creates a record linking the user, the
responsibility and the Standard security group.

• For each HRMS responsibility connected to a user it creates a record linking the
user, the responsibility, the security group associated with the business group, and
the security profile.

If you are updating from Standard security, there may be many such records. For each
existing user responsibility with a security group value of ’Standard’, you need to decide
whether or not the user requires access to the responsibility. Users who may need to
update global lookup codes need access to the Standard security group.

In most cases, users will not require access to the Standard security group. In this
case, enter an end date to remove access to the responsibility. This reduces the number
of responsibilities the user sees on logging in, and prevents users from accidentally
entering data into the wrong business group.

Note: By default, the Standard security group is associated with the
Setup business group.

Example
For example, if your user is set up with a responsibility called US Federal HQ, you
could link this to:

• East Region Processing (Business Group)

• Operations Manager (Security Profile)

Using the same responsibility (US Federal HQ), you could also link to a different
Business Group:

• West Region Processing (Business Group)

• Services Manager (Security Profile)

Therefore, using just one responsibility (US Federal HQ), you can access two Business
Groups (East and West Region Processing).

When the Business Group East Region Processing was set up, a security group East
Region Processing would automatically have been created. When you linked the
Business Group to the user’s responsibility, the security group East Region Processing
would also be linked.

To view the records for Business Group East Region Processing you would select the US
Federal HQ responsibility and the East Region Processing security group.

If you then wanted to view the records for the West Region Processing Business Group
you would switch responsibility and security group pairing, selecting the same
responsibility (US Federal HQ) and the different security group West Region Processing.
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Categorizing Information By Security Groups
Warning: You can only categorize information by security groups if you
are using Security Groups Enabled security.

You can categorize the following information within your enterprise using security
groups:

• Lookups

Using the Application Utilities Lookups window you can set up lookups specifically
for a security group. These lookups are only available to users who access the
business group associated with the security group.

See: Adding Lookup Types and Values, page 3-146.

• Concurrent Programs

Using the Concurrent Parameters Program window you can enter a security group
against a concurrent program, this creates a specific list of concurrent programs for
a security group and therefore business group. When a user selects a concurrent
program using the Submit Request window, they can select from the concurrent
programs for their business group.

Note: You do not have to enter a security group against all the
concurrent programs. Concurrent programs which are not linked to a
security group display for all security groups/business groups.

See: Concurrent Parameters Program window, Oracle Applications
System's Administrator's Guide.

Secure User View Support for Oracle US Federal HR
The application supports secure user view and cross-business group functionality
for the following:

• RPA and NPA Reports

See:Printing RPA, Workforce Sourcing, Deployment, and Talent Management
Guide, Printing NPA, Workforce Sourcing, Deployment, and Talent Management Guide

• Mass Actions

See: Mass Action Overview, Workforce Sourcing, Deployment, and Talent Management
Guide

• Position Descriptions

See: Position Description Classification Overview, Enterprise and Workforce
Management Guide

• Future Dated RPAs concurrent process

See: Processing Future Actions, Workforce Sourcing, Deployment, and Talent
Management Guide

• Central Personnel Data File (CPDF) reports, including CPDF Dynamics, Status, and
OCT reports as well as the Monthly Report of Federal Civilian Employment
(SF-113A) report.
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See: Central Personnel Data File Report, Enterprise and Workforce Management
Guide, Standard Form 113-A Monthly Report of Federal Civilian Employment,
Enterprise and Workforce Management Guide

The responsibility you choose at login determines what information you can view and
update and what reports and processes you can run. If your login’s responsibility
and associated business group has a security profile assigned to it (a secure view), the
application filters the information.

For example, when you create a mass action, the application filters the Selection Criteria
list of values for organizations, positions, and hierarchies. It also filters the information
that can be displayed and updated in the Preview window and for the Final execution.

Additionally, when you save a mass action or position description, the application
stores the business group ID attached to your login’s responsibility. From then on, only
users with the same business group ID can access and retrieve the mass action, and
run reports and processes for it.

Use the following guidelines when choosing a responsibility. Choose:

• Secure view responsibility to access and update mass actions and position
descriptions, and to run only processes and reports created in that secure view
responsibility

• Non-secure responsibility to access and update mass actions and position
descriptions, and to run all processes and reports

Cross business group

If you have cross-business group functionality set up, the application includes the values
for all business groups. If you are running reports or concurrent processes, the processes
or reports run across all business groups. If you do not have cross-business group
functionality set up, the application bases your lists of values and access to reports and
processes on your current login’s business group and your associated secure view.

Reporting Access
Oracle HRMS enables you to set up reporting users who can query and report on the
information in the database, but cannot insert, update or delete information. Reporting
users can use Oracle tools, or other tools connected to the Oracle database, to report on
information. Regardless of the tools used to access the database, reporting users can
only read information, they cannot update information.

Using Oracle HRMS you can set up similar security restrictions to users who can
update, insert or delete information. This ensures reporting users can only query and
report on appropriate records.

All secure users connect to the APPS ORACLE ID. This is created when the system is
installed. However, for reporting users, you should create one or more new reporting
user ORACLE IDs. By associating these with a restricted security profile you can control
whose records a reporting user can access.

You can make any of your restricted security profiles available not only for regular
users, but also for reporting users. The security profile restricts a reporting user’s access
to employee records in exactly the same way as it limits regular users’ access.

Reporting users can see all the details about the records they can access. To restrict the
access of what a reporting user can view you must use view-based accesses. To support
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this need of reporting users you can use third party reporting tools to create business
views.

For information about how to set up database access without on-line access, see: Setting
Up Reporting Users, page 1-22.

Security Processes
There are four system security processes:

• Enable Multiple Security Groups

Run this process when you first set up Security Groups Enabled security.

• Generate Secure User

Run this process when you create a new security profile that references a reporting
user.

• Security List Maintenance

Run this process every night.

You run these processes using an HRMS responsibility from the Submit Request window.

• Grant Permissions to Roles

This process is run automatically as part of the autoinstall process.

Enable Multiple Security Groups Process (HRSECGRP)
You must run the Enable Multiple Security Groups process if you set the Enable Security
Groups profile option to Yes. This process must be run when:

• You set up Security Groups Enabled security for the first time to enable HRMS to
use multiple security group features.

• You change from Standard HRMS security to Security Groups Enabled security. This
ensures that all your existing business groups have security groups and all the
multiple security group features are enabled.

Note: To avoid errors when running the Enable Multiple Security
Groups process, make sure that you set the Enable Security Groups
profile option to Yes at the Application level.

Generate Secure User Process (SECGEN)
This process grants permissions to new reporting users. It grants the "hr_reporting_user"
role to the REPORTING_ORACLE_USERNAME specified in the security profile.

Run this process when you have created a new security profile that references a reporting
user. In the Submit Requests window, select the name of the new security profile. This is
the only parameter for the process.

Security List Maintenance Process (PERSLM)
This process maintains the lists of organizations, positions, employees, contingent
workers and applicants that security profile holders can access. You should schedule
it to run every night to take account of changes made during the day to security
profiles, organization and position structures, and person records. If a disruption, such
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as a power cut, occurs while the process is running, you can manually restart it from
the Submit Request window.

Note: The PERSLM process replaces the earlier LISTGEN and
GLISTGEN processes.

See also Running the Security List Maintenance Process, page 1-47

Important: The Security List Maintenance process should normally
run when there are no users logged on to the system. Users attached
while this process is running may experience unexpected results; for
example, additional employees may become visible or previously visible
employees may disappear from view.

Grant Permissions To Roles Process (ROLEGEN)
All reporting users in the system share access to a set of public synonyms for tables
and views. Reporting users are granted permissions to make them usable. The Grant
Permissions To Roles process creates these public synonyms and grants permissions
to them.

Important: The Grant Permissions to Roles process is unrelated to
setting up workflow roles for Oracle products that support security
by workflow.

This process runs automatically as part of the autoinstall process when you install
HR, or when you upgrade the system.

The process creates public synonyms for each of the required HR objects and then grants
SELECT permissions to the role ’hr_reporting_user’. Permissions are not granted on the
secured tables, but only on the secure views of those tables. All permissions previously
granted to the role are revoked before the new grants are made. This ensures that the
correct grants exist for the valid HR objects.

Setting Up Standard HRMS Security
Use the following setup steps if your enterprise sets up a different responsibility for
each business group.

To set up users for Standard HRMS security:

1. Ensure that the Enable Security Groups profile option is set to No at site and
application level, using the System Profile Values window.

If this option is set to Yes then you are not using Standard HRMS security.

See: System Profile Values, Oracle Applications System Administrator's Guide.

2. Define a Security Profile, page 1-40

Note: For each restricted security profile you create that references a
reporting user, you must run the Generate Secure User (SECGEN)
process. This is a one-off process that is not required for view-all
security profiles.

3. Ensure that the required functions or menus are set up.
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This is required for the responsibility. For menu functions calling configured forms
or task flows, you must enter a parameter in the Parameter field of the Form
Functions window.

See: Defining Menus, page 1-100

See: Set Up Menus, page 1-101

4. Ensure that the required request group is set up.

You can define the groups of standard reports and processes that a user can run
from the Submit a New Request window. Every responsibility can have access
to one request group.

Use the Request Groups window.

See: Request Groups window, Oracle Applications System Administrator's Guide

5. Define a responsibility using the Responsibility window.

See: Responsibilities Window, Oracle Applications System Administrator's Guide

6. Set the HR User Profile Options for the new responsibility using the System Profile
Values window. You must set up the:

• HR: User Type

Use this profile option to limit field access on windows shared between Oracle
Human Resources and Oracle Payroll.

• HR:Security Profile

Enter the security profile for the responsibility. This must be set up at
responsibility level, otherwise the default view-all security profile is used. Using
Standard HRMS security you can only set up one security profile for a
responsibility.

• HR:Cross Business Group Profile

This option enables you to view some information across all business groups
within your enterprise.

You can set also set up other User Profile Options.

See: System Profile Values Window, Oracle Applications System Administrator's Guide

7. Create the username and password using the User window.

Link the user to as many responsibilities as they need using the User window.

Important: Do not use the HRMS Assign Security Profile window if
you are setting up Standard HRMS security.

See: Users Window, Oracle Applications System Administrator's Guide

8. Run system security process using the Submit Request window:

• Security List Maintenance

Ensure this process is run every night.

See: Running the Security List Maintenance Process, page 1-47
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Setting Up Security Groups Enabled Security
Use the following setup steps if your enterprise wants to enable many business groups
for one responsibility. This type of security is most commonly used by Service Centers.

Note: You only only need to perform steps 1 and 2 when you first
implement Oracle HRMS security. You can perform the other steps
at any time.

You can update your security model from Standard HRMS Security to Security Groups
Enabled security by following these steps.

Important: Once you have changed to Security Groups Enabled Security
you cannot revert to the Standard Security model.

To set up users for Security Groups Enabled Security:

1. Set the Enable Security Groups Profile Option using the System Profile Values
window.

Ensure the Enable Security Groups profile option is set to Yes at the application level
for Oracle Human Resources.

Note: If this option is set to No then you are not using Security
Groups Enabled security.

See: System Profile Values, Oracle Applications System Administrator's
Guide.

2. Run the Enable Multiple Security Group Process using the Submit Request window.

You must run the Enable Multiple Security Group process to set up Oracle HRMS to
use security groups.

See: Submitting a Request, Oracle Applications System Administrator's Guide

Warning: The creation of security groups is more complex with
Oracle HRMS 11.i.10. For this reason, the Enable Multiple Security
Group process may appear slow, particularly if you have a large
number of business groups.

The Enable Multiple Security Group process sets the Enable Security Groups profile
option to Yes for all HRMS applications. We strongly recommend that you do not
change the value of this profile option to another value.

3. Define a Security Profile, page 1-40.

Note: For each restricted security profile you create that references a
reporting user, you must run the Generate Secure User (SECGEN)
process. This is a one off process that is not required for view all
security profiles.

4. Ensure that the functions or menus you require are set up.

This is required for the responsibility. For menu functions calling configured forms
or task flows, you must enter a parameter in the Parameter field of the Form
Functions window.
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See: Set Up Menus, page 1-101.

See: Defining Menus, page 1-100.

5. Ensure that the request group you require is set up.

You can define the groups of standard reports and processes that a user can run
from the Submit a New Request window. Every responsibility can have access
to one request group.

Use the Request Group window.

See: Request Group window, Oracle Applications System Administrator's Guide

6. Define a responsibility using the Responsibility window.

See: Responsibility Window, Oracle Applications System Administrator's Guide

7. Set the HR User Profile Options for the new responsibility using the System Profile
Values window. You must set up the HR: User Type option.

You can also set the HR:Cross Business Group Profile option. This enables you to
view some information across all business groups within your enterprise. See
HR:Cross Business Group Profile option, page 1-49 for more information.

Note: For Security Groups Enabled security donot set up or amend
the HR:Security Profile profile option using the System Profile
Values window. To set up or change this profile option use the
Assign Security Profile window.

You can set also set up other User Profile Options.

See: System Profile Values Window, Oracle Applications System Administrator's Guide

8. Create usernames and passwords using the User window.

Important: Do not link responsibilities and security groups
(business groups) to users in this window. Instead, use the Assign
Security Profile window. If you do enter a responsibility and
security group in this window, you still need to use the Assign
Security Profile window, to link your user to a responsibility and
security profile. If you do not use the Assign Security Profile
window, the default view-all security profile is used and your user
will be able to see all records in the business group.

See: Users Window, Oracle Applications System Administrator's Guide

9. End-date unwanted user responsibilities linked to Standard security group

When you first enable security groups and run the Enable Multiple Security
Groups concurrent process, the process creates two sets of records for existing
user/responsibility pairs:

• For each responsibility connected to a user it creates a record linking the user, the
responsibility and the Standard security group.

• For each HRMS responsibility connected to a user it creates a record linking
the user, the responsibility, the security group associated with the business
group, and the security profile.
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If you are updating from Standard security, there may be many such records. For
each existing user responsibility with a security group value of ’Standard’, decide
whether the user requires access to the responsibility. Users who may need to
update global lookup codes need access to the Standard security group.

In most cases, users will not require access to the Standard security group. In
this case, enter an end date to remove access to the responsibility. This reduces
the number of responsibilities the user sees on logging in, and prevents users
from accidentally entering data into the wrong business group.

Note: By default, the Standard security group is associated with the
Setup business group.

Use the Users window.

See: Users Window, Oracle Applications System Administrator's Guide

10. Assign Security Profiles, page 1-45.

Associate a security profile with a user, responsibility and business group using
the Assign Security Profile window.

11. Run system security process using the Submit Request window:

• Security List Maintenance

Ensure this process is run every night.

See: Running the Security List Maintenance Process, page 1-47

Setting Up Security for Applications Using Some HRMS Windows
If you are setting up an Oracle application that uses HRMS windows (such as
Organization or Position), you need to set up some features of HRMS security.

Note: If you have licensed Oracle HRMS, do not follow these setup
steps. Instead, follow the steps in Implementing Oracle HRMS.

Using the following procedure you can either set up a responsibility that can view all
records in the Business Group, or restrict access to the records for selected organizations
or positions. You can also set up organization security for Financials and Manufacturing
business views, page 1-20.

Organization Security for Financials and Manufacturing Business Views

You can set up security for Oracle Financials and Manufacturing applications that use
organizations and organization hierarchies in their business views.

To do this, you create a single security profile that secures data either by single operating
unit or by operating unit and inventory organizations, as required. You must also set
the MO:Security Profile profile option at site or application level, to point to this new
security profile.

To establish multi-operating unit access for some business view users, you can create
for each type of user a security profile that secures organizations by organization
hierarchy, using the security profile functionality. You can then set the MO:Security
Profile option at responsibility level for these users.
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The show_bis_record function secures data according to the definition of the security
profile that is referenced by the MO:Security Profile profile option. If this profile option
is not set, the HR:Security Profile profile option is used. This function is called by
financials and manufacturing business views.

Single Operating Unit Security

In the Organization Security tab of the Security Profile window, select the Secure
organizations by single operating unit option from the Security Type poplist. The
operating unit is determined using the operating unit specified in the MO:Operating
Unit profile option.

Single Operating Unit Plus Inventory Organizations

In the Organization Security tab of the Security Profile window, select the Secure
organizations by operating unit and inventory organizations option from the
poplist. The operating unit is determined using the operating unit specified in the
MO:Operating Unit profile option. The inventory organizations you wish to include
must exist within this operating unit.

Impact on Security Implementations

Financial and manufacturing business view users who have not created security profiles
have unrestricted access to their data.

Financial and manufacturing business view users can secure their business view data by
security profiles identified by the HR:Security Profile profile option, as long as they have
not set the MO:Security Profile profile option. If this has been set, they must modify their
security setup to reflect the fact that the financial and manufacturing business views
secure data using the MO:Security Profile profile option.

HRMS security is not affected by these options. The HRMS business views and forms
secure data according to the setting of the HR:Security Profile profile option.

To set up security

1. If you are setting up a restricted access responsibility, create a restricted security
profile to define the organizations or positions the responsibility can access.

Note: Ensure your Application supports restricted access
security. Not all Oracle Applications support this type of security.

If you are setting up a responsibility which can view all the records
in the Business Group, you do not need to set up a security profile.

Note: A view-all security profile is automatically created when you
set up a Business Group. The view-all security profile always has
the same name as the Business Group.

See: Defining a Security Profile, page 1-40

2. Define a responsibility using the Responsibility window.

See: Responsibility Window, Oracle HRMS Configuring, Reporting, and System
Administration Guide

3. Select a security profile for the new responsibility.
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In the System Profile Values window, enter a security profile at the responsibility
level for the HR:Security Profile profile option.

4. Create a new user and link the user to a responsibility using the User window.

See: Users Window, Oracle Applications System Administrator's Guide

5. If you are setting up restricted access security, run the Security List Maintenance
Process (PERSLM) from the Submit a New Request Window. If you are setting up
view-all security you do not need to run the Security List Maintenance process.

This process maintains the list of organizations, positions, employees and applicants
that security profile holders can access. You should schedule it to run every night to
take account of changes made during the day.

See: Submitting a Request, Oracle Applications User's Guide

Setting Up Reporting Users
Reporting users do not have online access to the database through system forms. They
use reporting tools to prepare reports on the information their security profiles grant.

All secure users connect to the APPS ORACLE ID. This is created when the system is
installed. However, for reporting users, you should create one or more new reporting
user ORACLE IDs and associate each with a restricted security profile. Only users that
have been registered as Restricted Oracle Users are available for selection as reporting
users in the Security Profile windows.

The first step in this procedure is the job of the ORACLE database administrator. The
other steps are normally completed by the system administrator.

To set up a new reporting user:
1. Create a new reporting user ORACLE ID.

2. Register the new ORACLE ID with Application Object Library using the Oracle
Users window, selecting Restricted in the Privilege field.

3. Define a security profile for the new ORACLE ID.

See: Defining a Security Profile, page 1-40

4. Run the HR security processes using the Generate Secure User Process.

See: Running Reports and Programs, Oracle Applications User’s Guide

Running the HRMS Profile Options Report
The HRMS Profile Options Report lists the values of the profile options set for your
HRMS installation. The report also identifies which profile options have not been set for
your installation and, consequently, acts as a trouble-shooting aid.

You run the HRMS Profile Options Report using the Oracle Diagnostic Framework. This
application is delivered free to customers with Oracle HRMS 11.5.4 or above. For more
information, see MetaLink note 167000.1.

To run the HRMS Profile Options Report:
1. Select the application for which you want to run the report.
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2. Enter your application user ID and password.

3. Select a responsibility ID.

Note: The responsibility selected usually defines which
diagnostic tests you can run based on the associated
application. However, the HRMS Profile Options Report does
not apply this restriction, therefore, you can select the System
Administrator responsibility in this field.

4. Choose Run Test.

If the report has identified missing profile option settings, the report will end with
the status Failed.

5. Choose View Report.

The report lists the profile options and settings for your application. If any profile
options have not been set, they are displayed in red.

Defining a Context for Mass Actions
The Contexts window determines what information the user can view, enter, and change
based on the Application, Legislation, and Responsibility.

A predefined global Context contains the default attribution that appear on the
forms. When you create a new Context, these attributes serve as a basis for selecting
which attributes to include as display, change, and criteria attributes.

The predefined global Context does not specify values for Application, Legislation, or
Responsibility. You can restrict who can process mass actions by specifying these
attributes. The system always applies the most defined Context, so as soon as you define
these fields, the system applies the new Context instead of the global one.

You define a new context in the Contexts window.

To define a Context:
1. Choose New from the File menu.

2. In the Context field, enter a name.

3. In the Transaction Name field, choose the Transaction Category to affect.

4. In the Application field, select an application.

5. Optionally, choose one or more of the following fields to restrict a user’s ability to
view and change data:

• In the Legislation field, select a Legislation

• In the Responsibility field, select a Responsibility

6. Choose the Find Attributes button.

The system displays the attributes from the global Context window on the Display
and Change List tabbed regions.

7. Choose the Display tab and select those items to display on the Columns portion
of the transaction template.
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8. Choose the Change List tab and select those items to display for the Change List
values.

9. Choose the Criteria tab and select the items you want to have appear on the Other
Criteria list of values in Selection Criteria block on the Original tab.

10. Choose the Compile button to save your work and compile the flexfield definitions.

11. Save your work.
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Security Profiles

Security Profiles
The security profile determines which applicant, employee, contingent worker and other
person type records are available to holders of the responsibility the profile is linked to.

If you are using HRMS Standard security, you link a security profile to one responsibility
using the HR:Security Profile profile option.

If you are using Security Groups Enabled security, you link a security profile to the
user’s responsibility and business group using the Assign Security Profile window. You
can also link more than one security profile to a responsibility, as long as the user is
different. This saves you setting up a new responsibility for each security profile you use.

Note: If you are using the Security Groups Enabled security model you
must not use the HR:Security Profile profile option. This is automatically
set up when you assign security profiles using the Assign Security
Profile window.

See also Defining a Security Profile, page 1-40

Restricting Access to Records
You set up a security profile by identifying records of employees, applicants and
contingent workers in the system which you want users to be able to access. You identify
the records by selecting work structures or other criteria in the application to which
employees, applicants or contingent workers are attached. For example, you could give
users access only to the records of employees, applicants or contingent workers in
a single organization.

You can also create restrictions on records with a person type of "Other". This includes
contacts for employees or applicants, and any other people with a person type in the
category of "Other". You do this using the "View Contacts" option.

You can combine different types of restriction to create a set of rules giving exactly the
security access permissions you require.

When you create a business group a view-all security profile is automatically
created. This has the same name as the business group. The security profile provides
access to all employee, contingent worker, and applicant records in the business
group. The system administrator links this view-all profile to users who are setting up
the system. They in turn can set up security for other users.

The criteria you can use to identify records are:

• Internal organizations and organization hierarchies

• Positions and position hierarchies

• Payrolls

• Supervisors and supervisor hierarchies

• Custom restrictions

• Assignments
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Tip: Oracle recommends that you use either a supervisor or position
hierarchy for Self-Service Human Resources (SSHR).

For more information on hierarchies in SSHR, see: Enter Process, Oracle
HRMS Deploy Self-Service Capability Guide.

Internal Organizations and Organization Hierarchies

Organizations include structures like departments, sections, groups and teams. You
can restrict access to a single organization, a list of organizations, or an organization
hierarchy. If you restrict on an organization hierarchy, you can exclude specific
organizations that are in the hierarchy, or add other organizations that are not in the
hierarchy.

Positions and Position Hierarchies

Positions are jobs performed within specified organizations. The position is derived
from an organization and a job, for example, you may have a position of Shipping Clerk
associated with the organization Shipping and the job Clerk.You can define security
restrictions based on a position hierarchy.

Payrolls

You can restrict access to employee records by payroll. For example, you can give payroll
staff who work on the payroll at a particular location access to records of employees on
this payroll only.

Controlling security by payroll assignment limits the employee records users can see and
update on employee-related windows, such as those for employee information, and
element entry.

Of course, if an employee assignment does not include a payroll, payroll security
cannot apply to this assignment. Payroll security also applies to applicants if they are
assigned to a payroll.

Note: Payroll security is not available for contingent workers since
they are not assigned to a payroll.

The windows for compensation definition are unrelated to any particular employee
records or payroll assignments. Therefore limiting access by payroll does not affect
users’ access to these windows.

Supervisors and Supervisor Hierarchies

The supervisor for an employee, applicant or contingent worker is the person identified
in the Supervisor field in HRMS applications. Supervisor profiles are dynamic, in that
they do not have to specify a particular person or hierarchy level. You can therefore set
up a single security profile and use it for multiple users, who will each be able to access a
different set of records depending on their own location in the hierarchy.

Note: If you choose to use supervisor hierarchy, you must also set the
HR: Supervisor Hierarchy Usage profile option. This profile defines
how supervisor hierarchies are built. You can choose whether to create
person-based or assignment-based supervisor hierarchies.

Person-based supervisor hierarchy
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A person-based supervisor hierarchy is a hierarchy based on a person’s supervisor
and direct reports.

Assignment-based supervisor hierarchy

As an alternative to the person hierarchy, you can choose to build a hierarchy based
on the supervisor assignment. In this case, you also specify the supervisor assignment
number for a person and the security processes use this assignment to generate an
assignment-based supervisor hierarchy. As for the other supervisor-based hierarchy, the
assignment-based hierarchy is dynamic and this security profile can be used for multiple
users.

Note: When you set up security based on supervisor hierarchies, the
list of employees visible to a user is usually generated at the start
of the session. Therefore, for profiles that only restrict access by
supervisor there is usually no need to run the Security List Maintenance
process. However, for supervisors with a large number of subordinates
(for example, at higher management levels) this may result in a delay
in generating the list. You can improve performance by limiting the
number of hierarchy levels a supervisor can access or by using the Static
Lists functionality to store the security permissions in a list.

For more information, see Static Lists, page 1-28.

Alternatively, for the highest levels of management, consider setting up
security using organization hierarchies.

Custom Restrictions

You can set up your own restrictions using SQL statements (for example, you might
want to create a restriction allowing users access only to temporary part-time
employees). Your custom restriction statements are automatically validated by the
system. Valid restrictions are incorporated in the security profile, further restricting the
list of employees, applicants and contingent workers specified using any of the other
methods mentioned above.

Since you are defining additional restrictions using SQL, you need to ensure your SQL
statements are tuned for performance. Otherwise, they will have an adverse effect on the
time it takes to execute the Security List Maintenance process.

Important: Custom restrictions directly restrict employees, applicants
and contingent workers only; you cannot create custom restrictions on
people with a system person type of Other. However, if you add custom
restrictions on employees, applicants or contingent workers, related
people with a system person type of Other are restricted according to
the setting of the "View Contacts" option.

As for other forms of security set-up, you can choose whether to enable user-based
custom security. This means that Oracle HRMS uses your custom rules to evaluate
security permissions for a user when that user logs on to the HR application. The
alternative is to use static lists to store the security information for users or to run the
Security List Maintenance process to regularly update the permissions.

Assignment-Level Security

Assignment-level security enables you to restrict security access based on individual
assignments. This means that the security processes evaluate permissions on an
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individual assignment basis, rather than displaying all assignments if a manager has
access to one assignment.

For more information, see: Assignment-Level Security, page 1-29.

User-Based Security
With user-based security, the application evaluates the security rules and permissions
for the user logged on to the application. For example, if Bob Wright logs on to
Self-Service Human Resources (SSHR), his access to organizations, positions, people, and
assignments is based on his personal assignment details. The advantage of user-based
security is that you can use one user-based security profile for multiple users. User-based
security is available for security profiles based on organizations, positions, and
supervisors, and can also be used in conjunction with custom security.

Note: If you use user-based security or assignment-level security, you
cannot display terminated or expired assignments.

For more information on user-based security, see the individual sections in Defining a
Security Profile, page 1-40.

Static Lists

Static lists enable you to choose whether to assess security permissions for a user when
that user logs on (dynamically) or whether to store the permissions in static lists. The
advantage of using static lists is that Oracle HRMS can quickly retrieve the permissions
when the user logs on as the data is already available. A typical use of static lists may
be for a senior manager who has access to many people.

When a user is in the static list, security permissions remain frozen until the next time
you run the Security List Maintenance process. You can choose how often to run the
Security List Maintenance process and schedule the process to run frequently if users’
permissions are likely to change frequently.

The choice of whether to use static lists instead of dynamic security assessments depends
on several factors, including:

• If slow system performance is unacceptable at sign-on, you can reduce the processing
requirement at sign-on by using static lists. Static lists can be particularly useful
in the case of a top manager who has a large number of subordinate employees or
organizations, for example. In this case, the process to evaluate security permissions
may be lengthy at sign-on.

• Static lists require additional maintenance to run the process. In addition, the
static lists stores details of every person that the user included in the static list can
access so if you include several users in a static list, you may experience an increase
in data for processing.

• The other factors above become more significant as the size of an organization
increases. Large numbers of users logging on to Oracle HRMS at the same time
would result in a huge processing requirement at the point of sign-on. In this case, it
may be advisable to add users most affected by sign-on issues to the static lists.
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Global Security Profiles
If you use an application other than Oracle HRMS, for example, Oracle CRM, then you
can create global security profiles that enable users to work on organizations in multiple
business groups.

You do this by setting up a global hierarchy, which can contain organizations from any
business group on your database, and associating it with a global security profile. This
enables you to create a security hierarchy that gives users access to organizations across
business groups.

If you want to read more information about organization hierarchies, see: Organization
Hierarchies, Oracle HRMS Enterprise and Workforce Management Guide

If you use the Oracle HRMS Professional Forms Interface, then you cannot access data
across business groups using one responsibility, even if you associate a global security
profile to your responsibility. Your access is limited to organizations in the business
group defined in the HR:Business Group profile option.

Related Topics
Security Processes, page 1-15

Running the Security List Maintenance Process, page 1-47

Assignment-Level Security
The security features in Oracle HRMS enable you to restrict security access based
on individual assignments. The security processes evaluate permissions on an
assignment-by-assignment basis, rather than displaying all assignments if a manager
has access to any assignment.

For example, without assignment-level security, a manager with access to an
employee’s primary assignment would also have access to the employee’s other
assignments even though the supervisor for the other assignments may be a
different manager. To allow supervisors to view only the relevant employees
and assignments, you can enable assignment-level security in the Security Profile
window. You use this functionality in conjunction with your security profile settings
(for example, organization, position, supervisor security).

The following examples show how a manager’s access to person records differs
when assignment-level security is enabled and when it is disabled for a supervisor
hierarchy, organization hierarchy, and position hierarchy.

Note: If you use assignment-level security, or any user-based security
profile, you cannot display terminated or expired assignments. This is
because the process to evaluate access to person record uses existing
assignments based on the effective date.

Supervisor Hierarchies and Assignment-Level Security

The graphic below shows the direct reports for Sam Taylor and Sally Jones. The
subsequent examples show how the managers’ access to the direct reports varies with
the different security configurations.

Security Rules 1-29



Supervisor Hierarchy

Example 1: Assignment-Based Supervisor Hierarchy (No Assignment-Level Security)

If you set up a supervisor hierarchy that is based on the supervisor assignment, Sam
can see the direct report for Bob’s first assignment (Jane). Because there is no
assignment-level security, Sam can also see Bob’s second assignment, however, Sam
cannot access the direct reports for the second assignment. Sally Jones can see Bob’s first
assignment but cannot see the direct reports for this assignment (Jane). The following
graphic illustrates the new hierarchy for Sam Taylor:
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Assignment-Based Hierarchy for Sam Taylor (No Assignment-Level Security)

Example 2: Assignment-Based Supervisor Hierarchy (Assignment-Level Security)

With assignment-level security, Sam can only see Bob’s first assignment and the direct
reports for this assignment (Jane). Sally can see Bob’s second assignment and Maria’s
assignment and the direct reports for these assignments. The following graphic
illustrates the hierarchy with assignment-level security for Sam:

Assignment-Based Hierarchy with Assignment-Level Security
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Note: If you are using an assignment-based hierarchy, it is advisable to
use assignment-level security.

Organization Hierarchies and Assignment-Level Security

The graphic below shows two organization hierarchies. Within the first hierarchy
(Eastern Region Sales) there is an employee with multiple assignments. The subsequent
examples show how the hierarchy changes with assignment-level security disabled
and enabled.

Organization Hierarchy

Organization Hierarchy (No Assignment-Level Security)

In this situation, Sam can see the people within the Accounts and Presales
organizations. He can also see the people in organizations below Presales in the
organization hierarchy (Team 1 and Team 2). Bob Wright has a second assignment in a
different organization (Western Region Sales/Presales). Because assignment-level
security is disabled, Sam can see this assignment (if a manager can access one
assignment, he can access them all). Sam cannot see the organizations below the
organization for Bob’s second assignment. The following graphic illustrates the
hierarchy without assignment-level security for Sam Taylor:
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Organization Hierarchy (No Assignment-Level Security)

Organization Hierarchy (With Assignment-Level Security)

In this situation, Sam can see all people within the Accounts and Presales
organizations. However, Sam cannot see Bob’s second assignment (Western Region
Sales/Presales) because the organization for the second assignment is not within the
organization hierarchy to which Sam has access. The following graphic illustrates the
hierarchy with assignment-level security for Sam Taylor:

Organization Hierarchy (With Assignment-Level Security)
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Position Hierarchies

The graphic above shows two position hierarchies. Within the first hierarchy (Sales
Research Director) there is an employee with multiple assignments. The following
examples show how the hierarchy changes with assignment-level security disabled
and enabled.

Position Hierarchy (No Assignment-Level Security)

In this situation, Tom can see the position below him in the hierarchy (Associate Sales
Research Director). He can also see the reporting positions (Sales Research Specialists
and Sales Research Technical Support Staff). Helen Richie has a second assignment for
a different position (Regional Sales Director). Because assignment-level security is
disabled, Tom can see this assignment (if a manager can access one assignment, he can
access them all). Tom cannot see the positions below the position for Helen’s second
assignment. The following graphic illustrates the hierarchy without assignment-level
security for Tom Yorke:

Position Hierarchy (No Assignment-Level Security)

Position Hierarchy (With Assignment-Level Security)
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In this situation, Tom can see the position below him in the hierarchy (Associate Sales
Research Director). However, Tom cannot see Helen’s second assignment (Regional
Sales Director) because the position for the second assignment is not within the position
hierarchy to which Tom has access. The following graphic illustrates the hierarchy with
assignment-level security for Tom Yorke:

Position Hierarchy (With Assignment-Level Security)

Implementing Assignment-Level Security
You specify whether to enable assignment-level security in the Security Profiles
window. To enable assignment-level security, select the Restrict on Individual
Assignments option.

For more information, see: Defining a Security Profile, page 1-40

Note: Assignment-level security is not available for all areas of Oracle
HRMS. The areas currently available for assignment-level security
include:

• Self-Service Human Resources (SSHR)

• People Management templates

For more information on enabling assignment-level security for
People Management templates, see: Adding a People Management
Template Window to a Menu or Task Flow, page 3-320

• Selected Oracle HRMS windows

Security Profiles by Supervisor Hierarchy
You can set up a security profile that permits access to a supervisor hierarchy. This
means that when a manager logs on to Oracle HRMS, the application uses assignment
or supervisor attributes to build a person tree with the manager at the top level. The
person tree shows the direct reports for the manager and also any direct reports at lower
levels of the hierarchy to which the manager has access.
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The structure of the person tree depends on whether you are using an assignment-based
or person-based supervisor security profile. The following examples highlight the
differences between the two types of supervisor security:

Supervisor Hierarchies

Person-Based Supervisor Hierarchy
This type of security uses the Supervisor field in HRMS applications to generate a
supervisor hierarchy. When a manager logs on to the HRMS application, the application
assesses security permissions for the manager (user) and builds a hierarchy showing
the manager’s direct reports and, if applicable, additional subordinate levels of
employees. In this case, a manager can see all assignments for the direct reports. In the
example, Sam Taylor can see both assignments for Bob Wright (assignments 1 and 2) and
both direct reports for these assignments (Jane Lewis and Tom Acland).

Assignment-Based Supervisor Hierarchy
This type of security also uses the Supervisor field in HRMS applications but when the
user enters the supervisor information, he or she can also select a particular assignment
for the supervisor. When the supervisor logs on to Oracle HRMS or Oracle SSHR, the
supervisor hierarchy is based on the supervisor’s assignment.

Note: You should only use an assignment-based supervisor hierarchy if
you have enabled multiple assignments in your organization.

In the example, Sam Taylor’s access to person records depends on whether
assignment-level security is enabled. If it is enabled, Sam can only access the records
for Bob Wright’s first assignment and direct report. If assignment-level security is not
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enabled, Sam can access the records for both of Bob’s assignments and also for the direct
report for the first assignment.

For more information, see Assignment-Level Security in Security Profiles, page 1-25.

HR: Supervisor Hierarchy Usage Profile Option

You use this profile option to specify the behavior of the supervisor hierarchy in
HRMS applications by specifying whether the supervisor hierarchy is assignment
or person-based.

Security Profiles by Organization and Organization Hierarchy
To set up a security profile that permits access to employee records of certain
organizations only, you make use of organization hierarchies. You can build any number
of additional hierarchies to meet your security requirements.

For example, suppose you build the agency hierarchy below:

Government Agency Hierarchy

Without User-Based Security

You can create a security profile that permits access to employee records throughout
an agency. This profile references the XYZ Agency as the highest organization in the
hierarchy through which profile holders have access to employee records.

Next, you want the directors of the two agency regions to have access to all employee
records in their region only. You create Eastern and Western Director security
profiles. These profiles also reference the XYZ Agency hierarchy. But, they name the
Eastern and Western Regions, respectively, as the top organizations for these profiles’
access to employee records.

When you name an organization as the top organization, you specify whether it is
inclusive or not. You must include the top organization if you want holders of the profile
to access records of people assigned to the top organization.

With User-Based Security
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If you are using user-based security, you can choose to use the organization linked to
the user’s assignment as the top organization. The top organization is then determined
dynamically when the user logs on or when the Security List Maintenance process is
run. To illustrate the advantage of using user-based security in this way, take the above
example. Instead of having to create two security profiles so that the two regional
directors can only access the records for the employees in their regions, you would only
need to create one security profile which would identify the top organization based
on the user’s assignment. In the example, the security process would identify that
the top organization for one director is Eastern Region and for the other director it is
Western Region.

If a user has multiple assignments, the application builds a hierarchy for each
assignment, using each assignment’s organization as the top organization. The user
can then see the people and assignments in any of their assignments’ subordinate
organizations.

Security Profiles by Position and Position Hierarchies
After establishing limits on record access using organization hierarchies, you can further
restrict access by means of position hierarchies.

Suppose, for example, within the XYZ Agency, you want to give the Chief of Personnel
Operations access to her subordinates’ records only. There are two ways of doing
this: either with or without user-based security.

You can start by building the following agency hierarchy.
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Sales Positions Hierarchy

Without User-Based Security

Create the Chief of Personnel Operation security profile. This profile references the
agency hierarchy and names the Chief of Personnel Operations as the top position
for access to employee records.

Security Profile: Chief of Personnel Operations

Organization Hierarchy: XYZ Agency

Top Organization: XYZ Agency

Position Hierarchy: Personnel Operations

Top Position: Chief of Personnel Operations

Include Top Position: Yes
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When you give the Chief of Personnel Operations a responsibility including this security
profile, she can access the records of her subordinates. But, she cannot access records of:

• the Personnel Officer or the Deputy Personnel Officer

• the Chief of Payroll Operations

• the Chief of Payroll Operations’ subordinates

As with organization hierarchies, you can specify that profiles do not include access to
the top position.

With User-Based Security

If you are using user-based security, you can choose to use the position linked to the
user’s assignment as the top position. The top position is then determined dynamically
when the user logs on or when the Security List Maintenance process is run. To illustrate
the advantage of using user-based security in this way, take the above example. Instead
of having to create a separate security profile for each position hierarchy, for example, a
Chief of Personnel Operations profile and a Chief of Payroll Operations profile, you
could create one security profile which would identify the top position based on the
user’s assignment. In the example, the security process would identify that the top
position for the Chief of Personnel Operations is different from the top position for the
Chief of Payroll Operations and build the position hierarchy accordingly.

If a user has multiple assignments, the application builds a hierarchy for each
assignment, using each assignment’s position as the top position. The user can then see
the people and assignments in any of their assignments’ subordinate position hierarchies.

Defining a Security Profile
You can define security profiles in the Security Profile window (to give access to a
single business group) or the Global Security Profile window (to allow users to access
records from more than one business group).

See also Security Profiles, page 1-25

Note: Using the Global Security Profile window does not give Oracle
HRMS users access to records from multiple business groups within
the same responsibility; users must still switch responsibilities to see
records from different business groups. However, HRMS users can see a
restricted set of information in records from more than one business
group within a single responsibility if the HR:Cross Business Profile
profile option is set to Yes.

If you want to associate a reporting user with the new security profile, the ORACLE
database administrator must create a new reporting user ORACLE ID. The system
administrator must register the new ORACLE IDs as restricted privilege users with
the Application Object Library.

See Setting up Reporting Users, Oracle HRMS Configuring, Reporting, and System
Administration Guide

To define a security profile:
1. Enter a name for the security profile.
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2. If you are using the Security Profile window, select a business group. Users will
have access only to records within this business group. This does not need to be the
business group associated with your responsibility.

If you are using the Global Security Profile window, users will have security access
to records from all business groups, subject to other restrictions you set up.

3. If you want reporting users to be able to use this security profile, select the Reporting
User name for the ID set up by the database administrator (this option is not
available when setting up Global Security).

Applying Restrictions by Person Type

4. You can choose to apply the security restrictions you set up to
employees, applicants, contingent workers, contacts, or any combination of
these. For example:

• If you want the security restrictions to apply to employees, select Restricted
from the View Employees box.

• To ignore the security restrictions for employees and allow access to all
employees, select All from the View Employees box.

• To prevent access to any employee records, even if the other security restrictions
allow access, select None from the View Employees box.

You can set the View Applicants and View Contingent Workers options
independently, giving different security access to employees, applicants, and
contingent workers using the same security profile.

For contacts, or other people of person type Other, you can choose one of two options:

• All: Access is unrestricted, so that all people of type Other are visible to the
security profile

• Restricted: The profile restricts access to contacts to those people who are
related to employees, applicants, or contingent workers who are visible within
the security profile. If you can see the record of an employee, applicant, or
contingent worker, you can also see the records of people of type Other specified
as related to them (using the Contact Relationship field). All people of type
Other who are unrelated to any employee, applicant, or contingent worker are
also visible to the security profile.

Allowing Access to Granted User Records (SSHR only)

5. Select the Allow Granted Users option to allow a self-service user with this security
profile to access the records of other self-service users, provided that the other users
grant them access using the self-service application.

Note: This setting applies to the self-service application only and
has no effect on users of Oracle HRMS.

Restricting Access by Individual Assignment

6. Select the Restrict on Individual Assignments option to build security hierarchies
based on a person’s individual assignments. Oracle HRMS builds the security
hierarchy and assesses each individual assignment. The hierarchies generated by
the security process will then only contain the particular assignments to which the
manager has access. If you do not select this option, a manager who can see one
assignment for a person can see all other assignments.
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For more information on restricting by individual assignment, see: Assignment-Level
Security, page 1-29.

Restricting Access by Organization

7. In the Organization Security tabbed region:

• To restrict by organization list, select the Secure organizations by organization
hierarchy and/or organization list option in the Security Type poplist. Select
the organizations in the Organization Name field, and choose the Include
option button.

• To restrict by organization hierarchy, select the Secure organizations by
organization hierarchy and/or organization list option. Select an organization
hierarchy, and a top organization. Select the Include Top Organization option if
you want to allow access to this organization.

If you are using user-based security, you can choose to use the organization
linked to a person’s assignment as the top organization by selecting the
corresponding option. The security process identifies the organization linked
to the user’s assignment when the user logs on (or when the Security List
Maintenance process is run).

If required, you can add organizations not in the hierarchy to the list, by
selecting the organizations in the Organization Name field and choosing the
Include option button. You can also remove specific organizations from the
selected hierarchy by selecting an organization in the Organization Name field
and choosing the Exclude option button.

Note: The Secure organizations by single operating unit and Secure
organizations by operating unit and inventory organizations options
are for use by non-HRMS users, page 1-20, and have no effect on
the HRMS application.

8. By default, the Exclude Business Groups check box is unchecked, giving users access
to the business groups themselves, and therefore to employees or applicants who
have the business group(s) as their organization. Check the box to prevent access
to the business group(s) and the employees or applicants attached to them (for
example, to prevent users from seeing new starters and other employees who have
been assigned to the business group by default).

Restricting Access by Position (not Global Security)

9. In the Position Security tabbed region, deselect the View All Positions option. Select
a position hierarchy, and a top position. Check the Include Top Position check box if
you want to allow access to this position.

If you are using user-based security, you can choose to use the position linked to a
person’s assignment as the top position by selecting the corresponding option. In
this case, the security process identifies the position linked to the user when the user
logs on (or when the Security List Maintenance process is run).

Restricting Access by Payroll (not Global Security)

10. In the Payroll Security tabbed region:

• To give access to all payrolls, check the View All Payrolls check box.
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• To give access to many payrolls, uncheck the View All Payrolls check box, and
uncheck the Include check box. Select the payrolls you want to exclude.

• To give access to a small number of payrolls, uncheck the View All Payrolls
check box, and check the Include check box. Select the payrolls to include.

Restricting Access by Supervisor

11. In the Supervisor Security tabbed region, you can further specify how to create
your supervisor hierarchy. You can either create a hierarchy based on a person’s
supervisor assignment or based on a person’s supervisor.

For more information, see: Security Profiles for Supervisor Security, page 1-35.

Select either the person-based or assignment-based option and enter the number of
levels of access you want to allow the supervisor to see in the Maximum Hierarchy
Levels box (or leave the field blank to allow access to all levels).

Note: When you set up security based on supervisor hierarchies, you
can choose to generate the list of employees visible to a user at the
start of the session (user-based security). For supervisors with a
large number of subordinates (for example, at higher management
levels) leaving the Maximum Hierarchy Levels box blank may result
in a delay in generating the list. You can improve performance by
limiting the number of hierarchy levels a supervisor can access or by
using the Static List functionality.

For more information, see: Static Lists, page 1-45.

Alternatively, for the highest levels of management, consider setting
up security using organization hierarchies.

12. If you are using person-based supervisor security, you can choose whether to
display multiple assignments in the supervisor hierarchy. By default, the Primary
Assignments Only option is not selected, which gives users access to people who
report to them in any assignment. If you only want to give users access to people
who report to them in their primary assignment, select this option.

13. By default, the list of people whose records are accessible using supervisor-based
security changes with the user name of the person who logs in (user-based
security). If you want the supervisor hierarchy to be based on a specific person (and
not vary depending on the user name of the person who logs in) enter a name in the
Named User field. For example, to set up supervisor-based security for reporting
users who do not have any association with employees, enter the name of a person
at the required supervisory level.

Restricting Access to a User’s Own Records

14. To prevent users from seeing their own records, check the Exclude User check box
(if you have entered a name in the Named User box, users will be prevented from
seeing the records of the named user rather than their own records).

Note: This functionality is not supported in Self-Service Human
Resources (SSHR).
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Restricting Access by Custom Security

15. In the Custom Security tabbed region, select the custom restriction option. The
options are as follows:

• No custom security

• Restrict the people visible to this profile

The Security List Maintenance process is the basis for this type of custom
security. The security data is held in a static list.

• Restrict the people visible to each user using this profile

Oracle HRMS assesses the custom security when the user signs on. In
addition, the custom security code can include references to user specific
variables, for example, fnd_profile.value() and fnd_global.employee_id.

16. Enter a valid SQL WHERE clause fragment to select a group of records. For
example, to add a restriction that assignments must be based in either London or
Paris, add the following SQL fragment:

ASSIGNMENT.location_id in (select LOC.location_id
from hr_locations_all LOC
where LOC.location_code
in (’London’,’Paris’))

Alternatively, you could create custom code to use user-specific variables. The
following example illustrates the use of user-specific variables:

In this example, the custom code creates a rule whereby a user can display
employees or contingent workers whose last name begins with the same letter as
their own. The security profile is called "Same first letter of last name".

substr(person.last_name,1,1) =
(select substr(i.last_name,1,1)
from per_all_people_f i
where i.person_id = fnd_global.employee_id
and trunc(sysdate) between i.effective_start_date and i.effective

_end_date)

Note: In addition, the View Employees or View Contingent Workers
option is set to Restricted, and the "Restrict the people visible to
each using this profile" option is set on the Custom Security tab.

If the clause is valid, it is automatically incorporated in an SQL select statement that
the system generates to restrict access to records, based on the restrictions you have
set up in the other tabbed regions. The list of employees, contingent workers, and
applicants specified by these other restrictions is therefore further restricted by
the custom restriction.

The clause fits into the system-generated statement in the following way (this
statement is not visible on screen):
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select 1
from per_all_assignments_f ASSIGNMENT,

per_all_people_f PERSON,
per_person_type_usages_f PERSON_TYPE
where ASSIGNMENT.assignment_id=:asg_id

and:effective_date betweeen ASSIGNMENT.effective_start_date
and ASSIGNMENT.effective_end_date

and PERSON.person_id=ASSIGNMENT.person_id
and :effective_date between PERSON.effective_start_date

and PERSON.effective_end_date
and PERSON.person_id=PERSON_TYPE.person.id

and :effective_date between PERSON_TYPE.effective_start_date
and PERSON_TYPE.effective_end_date

and {your custom where clause fragment goes here}

Important: Custom restrictions directly restrict
employees, contingent workers, and applicants only; you cannot
create custom restrictions on people with a system person
type of Other. However, if you add custom restrictions on
employees, contingent workers, or applicants, related people with a
system person type of Other are restricted according to the setting of
the "View Contacts" option.

17. Choose the Verify button to check that the clause you have entered is valid. If it is
invalid, an error message appears explaining the reasons.

Using Static Lists

18. Static lists enable you to assess security periodically and store the data. You add
users to the static list and their security permissions are evaluated when the Security
List Maintenance process is run. Oracle HRMS stores the permissions for quick
retrieval when the user logs on and freezes the permissions until you run the
Security List Maintenance process again.

To specify which users to include in a static list, enter the user ID in the field.

19. Save your work.

What's Next
When you have modified or created new security profiles, it may be necessary to run
security processes to activate your changes.

See: Security Processes, page 1-15

See: Running the Security List Maintenance Process, page 1-47

Assigning Security Profiles
Use the Assign Security Profile window to link user names, and security profiles to
responsibilities. Only use this window if you are using Security Groups Enabled security
(formerly called Cross Business Group Responsibility security).

Important: When using Security Groups Enabled security even if you
have linked a user to a responsibility using the User window, you must
still link your user to responsibility and security profile using the HRMS
Assign Security Profile window. If you do not use the Assign Security
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Profile window, HRMS uses the default view-all security profile for the
Business Group and the user will see all records for the Business Group.

The Assign Security Profile window is an essential part of setting up and maintaining
HRMS security for Security Groups Enabled security. You must use this window to
update your security profile assignment. Any changes entered for the security profile
assignment are also shown on the User window. However, if you end date a user’s
responsibility using the User window, this is not shown on the Assign Security Profile
window.

When you navigate to the Assign Security Profile window, the Find Security
Profile Assignments window displays automatically. Select New to create a new
assignment. For information about querying existing security profile assignments, see
Using the Find Security Profile Assignment window, page 1-46.

To assign a new security profile:
1. Enter the user name you want to link to a responsibility.

2. Enter the application and responsibility you want to link to the user.

3. To assign a local security profile, select a business group to assign to the user’s
responsibility. The local security profile for the business group is automatically
entered when you click in the Security Profile field.

4. To assign a global security profile, first select the security profile to assign to the
user’s responsibility, then select a business group.

Note: If you enter a value in the Business Group field first, the list of
security profiles is filtered and does not display security profiles
for any other business groups.

You can link more than one security profile to a responsibility as long as the user
is different.

5. Enter the time period of security profile assignment.

You must enter a start date. Optionally, enter an end date if you want the security
profile assignment to end on a particular date.

6. Save the security profile assignment.

To end a security profile assignment:
You cannot delete security profile assignments. If a user no longer needs an assignment
you must enter an end date.

1. Query the security profile assignment you want to end.

2. Enter an end date. The user cannot use this responsibility, Business Group and
security profile from this date.

Using the Find Security Profile Assignment window
This window enables you to search for security profile assignments that have already
been set up. You only use security profile assignments if you are setting up Security
Groups Enabled security.
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If you want to set up a new security profile assignment select the New button. For more
information on setting up new security profile assignments, see Assigning Security
Profiles, page 1-45.

Note: When you navigate to the Assign Security Profiles window, the
Find Security Profile Assignment window automatically displays.

To query a security profile assignment:
1. Enter a full or partial query on one, a selection or several of the following:

• User name

• Application

• Responsibility

• Business group

• Security profile

Note: If you enter a value in either the Business Group or the
Security Profile field, any value entered in the other field is blanked
out if it is not valid to select both. For example, you cannot select
both business group A and a security profile which is specific to
business group B.

2. Check the Retrieve Only Active Assignments check box if you want to query security
profile assignments that are active as of today’s date. Uncheck the Retrieve Only
Active Assignments check box if you want to query security profile assignments
which are no longer active or assignments which will be available in the future.

3. Choose the Find button.

The security profile assignments found by the query are displayed in the Assign
Security Profile window.

Running the Security List Maintenance Process
You run the Security List Maintenance process to update the lists of
organizations, positions, employees and applicants that security profiles can access. You
should run this process regularly, for example nightly, to take account of changes
made during the day.

See Security Processes, page 1-15

You run the Security List Maintenance process from the Submit Requests window.

To run the Security List Maintenance Process:
1. In the Name field, select Security List Maintenance.

2. In the Parameters window, enter the date for which you want to run the report in
the Effective Date field. If you do not enter a date the process runs for the current
system date.

3. In the Generate lists for field, select the range of security profiles for which you want
to run the process. You can choose to update:

Security Rules 1-47



• All Global Security Profiles (all profiles created using the Global Security
Profile window)

• All Security Profiles

• All Security Profiles in One Named Business Group

• One Named Security Profile

4. If you have selected All Security Profiles in One Named Business Group, select a
business group.

5. If you have selected One Named Security Profile, select a security profile.

6. In the Process field, select the type of people to be processed. You can choose from
the following values:

• Current people only

• Terminated people only

• Current and Terminated people

Note: If you have selected One Named Security Profile, the only
available option is Current and Terminated people.

7. Choose OK.

8. Complete the batch process details and choose the Submit button.
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User Profiles

User Profiles
A user profile is a set of changeable options that affects the way your application
runs. You can set user profiles at different levels. The levels below are used by the
standard Security hierarchy type:

• Site level - These settings apply to all users at an installation site.

• Application level - These settings apply to all users of any responsibility associated
with the application.

• Responsibility level - These settings apply to all users currently signed on under
the responsibility.

• User level - These settings apply to individual users, identified by their application
usernames.

Values set at a higher level cascade as defaults to the lower levels. Values set at a lower
level override any default from a higher level.

Levels For Setting User Profile Options

Tip: Set site-level options first to ensure that all options have a default. If
a profile option does not have a default value, it might cause errors
when you use windows, run reports, or run concurrent requests.

There are two other Hierarchy Types that are used by some profile options: Organization
hierarchy type, and Server hierarchy type. These hierarchy type values also cascade as
defaults from Site down to User level. They have the following levels:

• Organization hierarchy type

• User level
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• Organization level

• Site level

• Server hierarchy type

• User level

• Server level

• Site level

The Organization hierarchy type enables you to set profile options for users in different
operating units that are used by other applications, particularly Financials. These are not
used by HRMS at all.

The Server hierarchy type should only be used by Database Administrators. It enables
you to set values for a particular server on which you are running the application.

For more information on these hierarchy types see: Profiles Window, Oracle Applications
Developer’s Guide

You use the System Profile Values window to set profile options at each level for your
user community. If you change a user profile option value, your change takes effect as
soon as your users log on again or change responsibilities.

See: System Profile Values Window, Oracle Applications Developer’s Guide

Application users can use the Personal Profile Values window to set their own profile
options at the user level. Not all profile options are visible to users, and some profile
options, while visible, cannot be updated by end users. Any changes users make to their
personal profile options take effect immediately.

See: Defining Preferences with User Profile Options, Oracle Applications User’s Guide

Profile Options Summary
The table below indicates whether users of the system can view or update
the profile option, and at which System Administrator levels (either
user, responsibility, application, or site) the profile options can be updated. These System
Administrator levels are included in the table as SA User, SA Resp, SA Admin, and SA
Site, respectively.

For the User column and each of the SA level columns in the table, Yes indicates that you
can update the profile, V indicates that you can view the profile but you cannot update
it, and No indicates that you can neither view nor update the profile.

A "Required" profile option requires you to provide a value. Otherwise the profile
option already provides a default value, so you only need to change it if you do not
want to accept the default.

For details of profile options applicable to all Oracle Applications, see Profile Options in
Oracle Applications Object Library, Oracle Applications Developer’s Guide
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Summary of Profile Options

Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

Apply
Assessment
Competencies
to Person

Yes No No No Yes

AME:
Installed

Yes No No Yes V No NA

AuditTrail:
Activate

No No No Yes Yes No No

BEN:BEN
HOURLY
ANNUAL
IZATION
FACTOR

Yes No Yes Yes Yes No 2080

BEN:
Benefits
Preferred
Currency

Yes Yes Yes Yes Yes No NA

BEN:
Compensation
Manager

Yes Yes Yes Yes Yes No NA

BEN:
Comp
Objects
Display
Name
Basis

No No No Yes Yes No Session

BEN:
Cross
Business
Group
for Plan
Design
Copy

Yes No Yes Yes Yes No Yes

BEN:
CWB
Approval
Mode

No No No No Yes No Submission
at any
time

BEN:
CWB
History
Type
Display

Yes No Yes Yes Yes No Basic
Stock
History

Security Rules 1-51



Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

BEN:
Designation
No
Change

Yes No Yes Yes Yes No No

BEN:
Eligible
Profile
Rule

Yes No Yes Yes Yes No AND

BEN:
Enable
Absence
Plans
Functionality

Yes No Yes Yes Yes No No

BEN:
Enable
Quartile
in Grade
Life
Event

Yes No Yes Yes Yes No Yes

BEN:
Imputed
Income
Post Tax
Deduction

Yes Yes Yes Yes Yes No No

BEN:Max
Extract
Line Size

Yes Yes Yes Yes Yes No 10000

BEN:VA
PRO Rule

Yes No Yes Yes Yes No AND

DateTrack:
Date
Security

V Yes Yes Yes Yes No NA

DateTrack:
Delete
Mode

- - - - - Not in use

DateTrack:
Enabled

V No No Yes No NA NA

DateTrack:
Login
Date
(YYYY/
MM/DD)

V Yes Yes Yes Yes NA NA

DateTrack:
Override
Mode

- - - - - Not in use

1-52 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

DateTrack:
Reminder

Yes Yes Yes Yes Yes No No

DateTrack:
Update
Mode

- - - - - Not in use

Disable
Self-
Service
Personal

Yes Yes Yes Yes Yes No No

Display
Messages

Yes Yes Yes Yes Yes

Enable
Security
Groups

No No No Yes Yes Yes Security
groups
are not
enabled

Flexfields:
Open
Descr
Window

Yes Yes Yes Yes Yes Yes Yes

Flexfields:
Open Key
Window

Yes Yes Yes Yes Yes Yes Yes

Help
Localization
Code

Yes Yes Yes No No Yes, by
HRMS

The
Responsibility
is
associated
with the
Global
set of
help files
rather
than a
localized
or
verticalized
set.

HR:
Absence
Duration
Auto
Overwrite

No No Yes No Yes No No
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Absence
Start Date

No Yes Yes Yes Yes No The start
date
of the
Absence
being
recorded
on the
Absence
form

HR:
Absence
View
Layout

Yes Yes Yes Yes Yes No FORM or
TABLE

HR:
Action
Parameter
Group
Name

Yes Yes Yes Yes Yes

HR:
Actions
- Display
Others

Yes Yes Yes Yes Yes No Defaults
to No

HR:
Actions -
Validation

Yes Yes Yes Yes Yes No Validate
all
Functions

HR:
Allow
Approver
Updates
to Self
Service
Actions

No No No No Yes No No

HR:
Allow
Concurrent
Self
Service
Actions

No No No No Yes No No

HR:
Allow
Online
W-2
Viewing
as of
(MM/
DD)

Yes Yes Yes Yes Yes
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Allow
Processing
of
Ineligible
Self
Service
Actions

No No No No Yes No No

HR:
Allow
Use of
Eligibility
for Self
Service
Actions

No No No No Yes No No

HR:
Applications
View
Layout

V Yes Yes Yes Yes No FORM or
TABLE

HR:
Appraisal
Template
Lov

Yes Yes Yes Yes Yes No No

HR:
Appraisee
Can Add
Participants

No Yes Yes Yes Yes No Yes

HR:
Assignment
ID

- - - - - Internal
use only.

HR:
Authoria
Integration
Enabled

Yes Yes Yes Yes Yes Yes (if
linking to
Authoria
HR)

No

HR:
Authoria
UK URL

No No No No Yes Yes (if
linking to
Authoria
HR)

HR:
Authoria
US URL

No No No No Yes Yes (if
linking to
Authoria
HR)

HR: Auto
Apply
Collective
Agreement
Entitlements

Yes No Yes Yes Yes Yes No
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR: Auto
Evaluate
Collective
Agreement
Entitlements

No No Yes Yes Yes Yes No

HR:
Automatically
synchronize
single GL
company
cost
centers
with HR

Yes No No No Yes Yes No

HR: Base
Salary
Required

No No No No Yes No Null

HR: B
IS Job
Hierarchy
- Job
Grouping
Level 1

No No No No Yes No Null

HR: B
IS Job
Hierarchy
- Job
Grouping
Level 2

No No No No Yes No Null

HR: BIS
Reporting
Hierarchy

- - - - - Obsolete.

HR:Blank
Effective
Date

Yes Yes Yes Yes Yes No No

HR:
Business
Group

V No Yes No Yes Yes Default
Setup
Business
Group at
Site level.

HR:
Cancel
Application

V No Yes Yes Yes No Default
is Null.
This is
interpreted
by the
system as
No.
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Check
Entitlement
Cache

No No Yes Yes Yes Yes Yes

HR:
Collective
Agreement
Logging

Yes Yes Yes Yes Yes Yes Low

HR:
Contingent
Worker
Manager
Actions
Menu

Yes Yes Yes Yes Yes Yes Contingent
Worker
Manager
Actions
Menu

HR:
Contingent
Worker
Personal
Actions
Menu

Yes Yes Yes Yes Yes Yes Contingent
Worker
Personal
Actions
Menu

HR: Copy
period
details for
budget

Yes Yes Yes Yes Yes No Default is
No.

HR:Cross
Business
Group

V No No No Yes NA Default is
No.

HR: CWK
in Head
Count
Reports

Yes Yes Yes Yes Yes

HR: Data
Exchange
Directory

V No Yes Yes Yes No

HR: Data
Migrator
Business
Group
Lockout

No No No No Yes NA NA

HR:Data
Pump
Action
Parameter
Group

Yes Yes Yes Yes Yes No Null

HR: Date
From

- - - - - Internal
use only.
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Default
Assignment
Costing

Yes Yes Yes Yes Yes No .

HR:
Default
Check/
Cheque
Number
Method

Yes Yes Yes Yes Yes No Null

HR:
Default
Correspondence
Language

Yes Yes Yes Yes Yes No No
default.

HR:
Default
Full
Name
Format

V Yes Yes Yes Yes No Surname
Prefix
Initials
Prefix (
Partner)
Surname
(Partner)

HR:
Default
Nationality

Yes Yes Yes Yes Yes No NA

HR: Defer
Update
After
Approval

No Yes Yes Yes Yes Yes Yes

HR:
Disable
Ethnicity
Tab

V Yes Yes Yes Yes No Enabled

HR:
Disallow
Template
Reference

Yes Yes Yes Yes Yes

HR:
Display
All
Candidate
Offers

- - - - - Obsolete.

HR:
Display
Competencies

Yes No Yes Yes Yes
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Display
Brief
Person
Name

No No No No Yes No No

HR:
Display
Person
Name

Yes Yes Yes Yes Yes No Brief
Name

HR:
Display
Person
Search

No Yes Yes Yes Yes No Yes

HR:
Display
Position
Hierarchy

No No No No Yes No No

HR:
Employee
Directory
Global
Menu

No No No No Yes No Employee
Directory
Global
Menu

HR:
Employment
View
Layout

Yes Yes Yes Yes Yes No FORM or
TABLE

HR:
Enable
Bank
Branch
Validation

Yes Yes Yes Yes Yes No Null

HR:
Enable
DTW4
defaulting

V No No No Yes No Yes

HR:
Enable
Multiple
Assignments
in SSHR

Yes Yes Yes Yes Yes No No

HR:
Enable
Web ADI
Integration

Yes No No No Yes No No
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Enforce
Costing
Mandatory
Segment
Check
at Data
Entry

Yes Yes Yes Yes Yes Default
is Null.
This is
interpreted
by the
application
as No.

HR:
Execute
Legislative
Check
Formula
within
Run

Yes Yes Yes Yes Yes No NA

HR:
Expand
Role of
Contingent
Worker

Yes No No No Yes Yes Default
is Null.
This is
interpreted
by the
application
as No.

HR:
Extension
Agent

No Yes No No Yes No

HR:
Extension
Agent
Client
Timeout

Yes No No No No No NA

HR:
Extension
Agent
Enabled

No Yes No No Yes Yes (if
using Info
online)

No

HR:
FastFormula
Debug
Level

Yes Yes Yes Yes Yes NA NA

HR:
Free text
school
name
allowed
in Self
Service

Yes Yes Yes Yes Yes No Null
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
French
HRMS
check
mandatory
payroll
assignment
attributes
exist

Yes Yes Yes Yes Yes Yes

HR: GL
Cost
Center
Org
Classifications

V No No No Yes Yes (if
you want
to use
Auto
Orgs to
synchronize
GL cost
centers
with HR)

None

HR: GL
Cost
Center
Synchronization
Options

V No No No Yes No - This
profile
option is
obsolete.

NA

HR: GL
Organization
Name
Format

V No No No Yes Yes (if
you want
to use
Auto
Orgs to
synchronize
GL cost
centers
with HR)

NA

HR:
Global
Competence
Flex
Structure

V No No No Yes Yes (if
you want
to create
global
competencies)

NA

HR:
Grade
Key Flex-
Identify
1st
Segment

Yes No Yes Yes Yes No NA

HR:
Grade
Key Flex-
Identify
2nd
Segment

Yes No Yes Yes Yes No NA
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:HR/
Payroll
Representative
Source

V No No No Yes No No
default

HR:Hide
Work
Phone on
Person

- - - - - Obsolete.

HR:
IE P35
Reporting
Year

Yes No No No Yes Yes NA

HR: Info
Online:
Open
in New
Window

No No No No No No

HR: Info
Online:
RIA
Password

Yes Yes Yes Yes Yes

HR: Info
Online:
RIA
Username

Yes Yes Yes Yes Yes

HR: Info
Online
Toolbar
Icon

NA NA NA NA NA No

HR: Info
Online:
Use Field
Context

Yes Yes Yes Yes Yes

HR:
Informal
Name
Format

No No No No Yes No NA

HR:Job
Key Flex-
Identify
1st
Segment

Yes No Yes Yes Yes No NA

HR:Job
Key Flex-
Identify
2nd
Segment

Yes No Yes Yes Yes No NA

1-62 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR: Job
Level

No No Yes Yes Yes No NA

HR:
Localization
in SSHR

- - - - - Obsolete.

HR:
Location
ID

- - - - - Internal
use only.

HR: Local
Nationality

- - - - - - No
default
value
exists,
and the
system
administrator
can set
the value
at any
level.

HR:
Manage
Self
Service
Actions
When
Future-
Dated
Changes
Exist

No No No No Yes No Stop with
an Error

HR:
Manager
Actions
Menu

Yes Yes Yes Yes Yes Yes Manager
Actions
Menu

HR: Mask
Characters

No Yes Yes Yes Yes

HR:
Metalink
Integration
Application

Yes Yes Yes Yes Yes No Human
Resource
Management
Systems

HR:
Metalink
Integration
Enabled

Yes Yes Yes Yes Yes No Yes

HR:
Monitor
Balance
Retrieval

Yes Yes Yes Yes Yes No
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:NI
Unique
Error or
Warning

No No Yes No Yes No NA

HR:
National
Identifier
Validation

No Yes Yes Yes Yes No Error on
Fail

HR:Non-
Updateable
Element
Set

Yes Yes Yes Yes Yes No NA

HR:OAB
New
Benefits
Model

Yes Yes Yes Yes Yes No NA

HR:
Offers -
Hiring
Manager
Initiation

- - - - - Obsolete.

HR:
Online
Tax
Forms
Update
Method

V Yes Yes No Yes No All

HR:
Organization
ID

- - - - - Internal
use only.

HR:
Override
Grade
Defaults

Yes Yes Yes Yes Yes No Defaults
to Yes

HR:
Payroll
Payments
Self-
Service
Enable
Multiple
Assignments

Yes Yes Yes Yes Yes No No
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Payroll
Payments
Self-
Service
Payments
List Mode

Yes Yes Yes Yes Yes No Null

HR:
Performance
View
Layout

Yes Yes Yes Yes Yes No FORM or
TABLE

HR:
Person ID

- - - - - Internal
use only.

HR:
Personal
Actions
Menu

Yes Yes Yes Yes Yes Yes Personal
Actions
Menu

HR:
Personal
Info
Check
Pending

- - - - - Obsolete.

HR:
Position
Key Flex-
Identify
1st
Segment

Yes No Yes Yes Yes No NA

HR:
Position
Key Flex-
Identify
2nd
Segment

Yes No Yes Yes Yes No NA

HR:
Propagate
Data
Changes

Yes No No No Yes No Default
is Null.
This is
interpreted
by the
application
as No.

HR:Purge
Element
Entry
Permission

V Yes Yes Yes Yes NA NA
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:
Query
Only
Mode

V Yes Yes Yes Yes No NA

HR:
Refresh
Self
Service
Actions
with Data
from
Intervening
Actions

No No No No Yes No No

HR:
Restrict
Letter by
Vacancy
or Event

V No Yes Yes Yes No Default is
Null

HR:
Restrict
Transactions
across
Legislations
for SSHR

No No Yes No Yes No No

HR: RIA
Integration
Enabled

Yes Yes Yes Yes Yes No Yes

HR:Run
BENMNGLE
When
Processing
a Self
Service
Action

No No No No Yes No No

HR:
Salary
View
Layout

Yes Yes Yes Yes Yes No FORM or
TABLE

HR:
Security
Profile

No No Yes No Yes Yes Default
view-all
security
profile at
Site level

HR: Self
Service
HR
Licensed

No No No No Yes No Defaults
to No
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:Self
Service
Hire and
Placement
Default
Values

No Yes Yes Yes Yes Yes

HR:Self-
Service
Save for
Later

No No No No Yes No Yes

HR:
Subrogation

Yes Yes Yes Yes Yes No No

HR:
Supervisor
Hierarchy
Usage

Yes No No No Yes No

HR:TCA
Unmerge
Options

No No No No Yes No In Patch
Process

HR:
Training
View
Layout

Yes Yes Yes Yes Yes No FORM or
TABLE

HR: US
Address
line
length

No Yes Yes Yes Yes No 22

HR: Use
Fast
Formula
Based
PTO
Accruals

No No No No Yes Yes No

HR:Use
Global
Applicant
Numbering

V No No No Yes Yes No

HR:Use
Global
Contingent
Worker
Numbering

V No No No Yes Yes No

HR:Use
Global
Employee
Numbering

V No No No Yes Yes No
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HR:Use
Grade
Defaults

V Yes Yes Yes Yes Defaults
to Yes

HR:Use
Standard
Attachments

No Yes Yes Yes Yes Yes Yes at Site
Level, No
at Seeded
Responsibility
Level

HR:User
Type

V No Yes Yes No Yes NA

HR: Use
Title in
Person’s
full name

No No No No Yes NA Yes

HR: View
Payslip
From
Date for
WEB
(MM/
DD/
YYYY)

Yes Yes Yes Yes Yes Yes 01/01/
1997

HR:View
Unpublished
Employee
360 Self
Appraisal

Yes No Yes Yes Yes No Default
value is
Null

HR:
Views
Layer
Size

Yes Yes Yes Yes Yes Yes 300 pixels

HR:
Webapps
Tips Test
Mode

Yes Yes No No No No No

HR: Web
Proxy
Host

No No No No No

HR: Web
Proxy
Port

No No No No No

HR:
Worker
Appraisals
Menu

No Yes Yes Yes Yes Yes Employee
Appraisals
Menu
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

HRI:
Enable
Captured
Events
Archive

No No No No Yes Yes No

HRI:DBI
Force
Foundation
HR
Processes

No No No No Yes Yes No

HRI:
Populate
Assignment
Events
Queue

No No No No Yes Yes Yes

HRI:
Populate
Supervisor
Hierarchy
Events
Queue

No No No No Yes Yes Yes

HRI:
Populate
Supervisor
Status
History
Events
Queue

No No No No Yes Yes Yes

HRMS:
Workforce
Turnover
Calculation
Method

No No No No Yes No Null

Limit By
Persons
Organization

Yes Yes Yes Yes Yes No No

OAB:Self
Registered
User
Responsibility

Yes Yes Yes Yes Yes No Self
Registered
Employee
Default
responsibility

OAB:
User to
Organization
Link

Yes Yes Yes Yes Yes No Null
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Profile
Option

User SA User SA Resp SA App SA Site Required Default
Value

OAB:
User to
Payroll
Link

Yes Yes Yes Yes Yes No Null

PAY:
Display
Reset
Years in
Payroll

Yes Yes Yes Yes Yes No No

PAY:
Generate
Periods
for Tax
Year

Yes Yes Yes Yes Yes

PER:
Automatic
Save

Yes No No No Yes

PER:
Navigation

Yes No No No Yes

Personalize
Self-
Service
Defn

Yes Yes Yes Yes Yes No No

PO:
Services
Procurement
Enabled

V No No No Yes No No

Talent
Management
Source
Type

Yes No No No Yes Yes NA

Workforce
Measurement
Type

No No No No Yes Yes

Profile Options

AME:Installed

Indicates whether Oracle Approvals Management is installed.

AuditTrail:Activate

When you enter or update data in your forms, you change the database tables
underlying the forms you see and use.
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AuditTrail tracks which rows in a database table were updated at what time and which
user was logged in using the form(s).

You can turn AuditTrail on or off (Yes or No). The default setting is No. You must set this
option to Yes before you can audit any Oracle Applications table.

BEN:BEN HOURLY ANNUALIZATION FACTOR

If you want to use the Hourly activity reference period for Compensation Workbench
plans, enter a value for this user profile option to determine how to convert an hourly rate
to an annual rate, and vice versa. The default is 2080 hours (8 hours * 5 days * 52 weeks).

BEN:Benefits Preferred Currency

Set this profile option for Self-Service Compensation Workbench to control the
preferred currency in which a manager views and enters budget and worksheet
distributions. Actual amounts are paid in the currency of the Compensation Workbench
plan, not the preferred currency.

BEN:Compensation Manager

Set this profile option to Yes to give access to features in the Compensation Workbench
that are available only to Compensation Managers.

BEN:Comp Objects Display Name Basis

Use this profile option to determine whether compensation object names display in
various application windows (both in the professional and Self-Service user interfaces)
based on the user’s session date or the life event occurred on date.

BEN: Cross Business Group for Plan Design Copy

Set this profile option to ’N’ to restrict a user from copying plan design data between
business groups through the Plan Design Copy function. The profile option defaults to
’Y.’ If you set the value to ’N,’ the user will only be able to export a plan design or copy
the plan design within the business group attached to their responsibility.

Ben: CWB Approval Mode

Use this profile option to determine CWB Approval behavior. If you set the value to
’Y,’ then CWB Approval Mode allows you to enforce the submission and approval
of all lower-level manager worksheets before higher-level managers may submit
their worksheets for approval. The default approval mode allows the submission of
a worksheet by a higher-level manager at any time regardless of the status of the
lower-level manager worksheets.

BEN: CWB History Type Display

Set this profile option to Extended Stock Option History for use with the Employee Stock
Options Total Position Report. If you load stock history from a third party administrator
into Oracle HRMS, you can use the Grant Detail Report Style of the Total Position Report
to view details about grants held by individual employees.

BEN: Designation No Change

This profile option determines the contents of the Dependent Eligibility Audit log. When
set to No (the default value) the audit log returns information only for dependents
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with eligibility changes. When set to Yes, the audit log returns all dependents, even if
they have no eligibility change.

BEN:Eligible Profile Rule

This profile option enables you to configure how FastFormula rules are evaluated in an
eligibility profile. It is set to AND by default, meaning that a participant must satisfy all
the rules you attach to an eligibility profile. If you set the user profile option to OR, the
participant need only satisfy one of the rules.

BEN:Enable Absence Plans Functionality

Set this profile option to Yes for the users or responsibilities who will enter absences
for absence benefit plans, if you want them to run the Participation Process to process
the absence life events. This displays the Enroll Absences button on the Absence Detail
window.

BEN:Enable Quartile in Grade Life Event

Use this profile option to determine whether the system triggers the Quartile in Grade
Life Event when a change in a person’s grade, salary basis, or salary moves them into a
new quartile in grade. These conditions trigger the Quartile in Grade life event if the
BEN:Enable Quartile in Grade Life Event user profile option is set to Yes. If you set this
profile option to No, the system never creates a Quartile in Grade potential life event.

BEN:Imputed Income Post Tax Deduction

Set this profile option to Y to deduct any after tax employee contributions from the
imputed income total for a benefits plan subject to imputed income. If you leave this
profile set to N (the default) the application assumes that the employer pays 100% of
the given benefit.

BEN:Max Extract Line Size

Use this profile option to set the maximum length of a record generated by the Extract
Write Process for compensation and benefits system extracts.

BEN:VAPRO Rule

This profile option enables you to configure how FastFormula rules are evaluated in a
variable rate profile. It is set to AND by default, meaning that a participant must satisfy
all the rules you attach to a variable rate profile. If you set the user profile option to
OR, the participant need only satisfy one of the rules.

DateTrack:Date Security

Controls the way users can change their effective date:

• All (users can change to any date)

• Past (users can change to dates in the past only)

• Present (users cannot change their effective date)

• Future (users can change to dates in the future only)

The meaning of Past and Future here is with respect to the user’s login date, which is
usually today’s date, but may be set to another value by the DateTrack:Login Date
profile option.
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DateTrack:Enabled

Set to Yes at Application level for Oracle HRMS.

DateTrack:Login Date (YYYY/MM/DD)

Normally a user logs onto the system with an effective date of today’s date. Use this
profile option to change a user’s default date to another date. This profile option works
in conjunction with DateTrack:Date Security. For example, if a user has DateTrack:Date
Security set to Future and DateTrack:Login Date set to 1900/01/01, they can change their
effective date to any date after January 1 1900, but not before.

DateTrack:Reminder

Determines whether the Decision window appears when you open a window in which
you can enter, update, or delete datetracked information. Notice that the Decision
window never appears on windows where you can query datetracked information but
not update it. There are three possible values:

• Always (the window always appears)

• Never (the window never appears)

• Not Today (the window appears only if the effective date is not the system date)

Disable Self-Service Personalizations

If this profile option is set to Yes, any personalizations created for self-service functions
using the Personalization Framework will not be applied. Only the original definition of
each self-service page will be displayed.

This profile option is used in SSHR.

Enable Security Groups

Controls whether you use multiple security groups. There are three possible values:

• No - If using standard security

• Y - If using multiple security groups

• Hosted - Reserved for use by VPD Hosting implementations

Change the default to Yes at application level only if your enterprise is implementing a
Security Groups Enabled system (multiple security groups). If you change the default to
Yes, you must run the Enable Multiple Security Groups process. See Security Models,
page 1-5.

Important: Once you have changed to Security Groups Enabled Security
you cannot revert to the Standard Security model.

Note: Non HRMS applications do not support multiple security groups
in Release 11i.

Flexfields:Open Descr Window

This profile option determines whether a descriptive flexfield window automatically
opens when you navigate to the field.
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Set to Yes if you want the flexfield to pop open automatically. If this option is set to
No, you can open the flexfield by choosing Edit Field from the Edit menu or pressing
CTRL+L.

The default is Yes.

Flexfields:Open Key Window

This profile option determines whether a key flexfield window automatically opens
when you navigate to the field.

Set to Yes if you want the flexfield to pop open automatically. If the option is set to
No, you can open the flexfield by choosing Edit Field from the Edit menu or pressing
CTRL+L.

The default is Yes.

Help Localization Code

Controls which set of help files are linked to each responsibility. If you accept
the default, then the set of help files for Global HRMS will be associated with the
responsibility. However, if you want to specify a legislative or vertical variant of HRMS
you must set the Help Localization Code as follows:

• AU for Australia HRMS Help

• BE for Belgian HR Help

• CA for Canadian HRMS Help

• CN for Chinese HRMS Help

• DE for German HRMS Help

• ES for Spanish HRMS Help

• FD for US Federal HR Help

• FR for French HR Help

• GCC for SAregion HR Help

• HK for Hong Kong HR Help

• HU for Hungarian HRMS Help

• IE for Irish HRMS Help

• IN for Indian HRMS Help

• IT for Italian HR Help

• JP for Japanese HRMS Help

• KR for Korean HRMS Help

• KW for Kuwaiti HRMS Help

• MX for Mexican HRMS Help

• NL for Netherlands HR Help

• NZ for New Zealand HRMS Help

• SG for Singapore HRMS Help

1-74 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



• UK for UK HRMS Help

• US for US HRMS Help

• ZA for South African HR Help

These entries must be in upper case.

HR: Absence Duration Auto Overwrite

Controls whether the absence duration formula automatically recalculates the duration
of an absence when the date or time of the absence is changed. Set to Yes if you have
created an absence duration formula (or one is supplied by your localization team) and
you want absence durations to be recalculated automatically.

HR: Absence View Layout

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.

HR: Actions - Display Others

Controls whether the Other Available Actions region is displayed on the Actions page
when the user has preselected a different action.

This User Profile Option is used in SSHR.

HR: Actions - Validation

Controls the point at which the application runs validation checks for Pending Workflow
transactions within SSHR. The validation can be carried out using one of the following
options:

• All actions are validated

• Only the preselected action is validated. The other actions are validated after
selection.

• All actions are validated after selection

This User Profile Option is used in SSHR.

HR:Allow Approver Updates to Self Service Actions

This profile option will allow an approver to make updates to actions in Self Service.

HR:Allow Concurrent Self Service Actions

Set this profile option to Yes to allow multiple simultaneous self-service actions.

HR:Allow Processing of Ineligible Self Service Actions

If this is set to Yes managers will be able to process ineligible self service actions. They
may wish to do this if the action will become eligible by its effective date.

Note: This option depends on also enabling the profile option HR:Allow
Use of Eligibility for Self Service Actions in order to display ineligible
actions in the first instance.
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HR:Allow Use of Eligibility for Self Service Actions

If this profile option is set to yes, the Eligibility column will be displayed on the Actions
page and all eligible and ineligible actions are displayed. The Eligibility column will
distinguish between them.

If it is set to No, the default, only eligible actions are displayed and the Eligibility column
will not be displayed.

Note: Managers will not be able to process ineligible actions unless the
profile option HR:Allow Processing of Ineligible Self Service Actions
is also set to Yes.

HR:Applications View Layout

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.

HR: Appraisal Template LOV

This profile option is used in Appraisal V3.4 where you can configure the Appraisal
Template field to be an LOV or a poplist. Valid values are Yes, which will display the
field as an LOV, and No, the default, which will display the field as a poplist.

HR: Appraisee Can Add Participants

Use this profile option to control whether appraisees can add participants in an
Appraisal process. The default value of Yes enables appraisees to add participants. If
you set it to No, appraisees cannot add participants.

HR: Authoria Integration Enabled

If you are using context-sensitive links from a button on the Oracle toolbar to the third
party information product Authoria HR, set this profile option to Yes to enable the
integration, or No to disable the integration. If you set this option to No, the ’Info
Online’ toolbar button does not link to Authoria HR from the applicable windows, and
hyperlinks do not appear in the applicable self-service pages.

HR: Authoria UK URL

If you are using context-sensitive links from a button on the Oracle toolbar to the third
party information product Authoria HR, set this profile option to the URL of the
Authoria HR engine serving UK-related content.

HR: Authoria US URL

If you are using context-sensitive links from a button on the Oracle toolbar to the third
party information product Authoria HR, set this profile option to the URL of the
Authoria HR engine serving US-related content.

HR: Auto Apply Collective Agreement Entitlements

This profile option enables you to control whether the values calculated for a collective
agreement during the entitlement evaluation process are applied automatically to an
employee. For each entitlement item, the most beneficial value that the employee is
entitled to is applied. Instances where the application cannot automatically establish the
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most beneficial value are noted in the log file and you can manually make a selection
using the Collective Agreement Entitlements window.

HR: Auto Evaluate Collective Agreement Entitlements

This profile option enables you to control whether the entitlement evaluation process is
run automatically when an employee is first placed on a collective agreement.

HR:Automatically Synchronize Single GL Company Cost Centers with HR

If you have set the HR: Generate Organizations from GL profile so that organizations
are automatically created in HR based on GL cost centers, then you can use this
profile to control whether the Synchronize Single GL Company Cost Centers with HR
concurrent program is automatically run following the creation of a new GL account
code combination.

HR: Base Salary Required

When you set this profile option to Yes, if a person’s assignment has a salary basis
assigned but no pay proposal, the Description and Salary fields will be mandatory. The
user will be forced to enter values for these fields.

HR: BIS Job Hierarchy - Job Grouping Level 1

Use this profile option to select the value set that represents the first level job grouping
in the Job Hierarchy. Ensure that the value set you select is associated with a Job Key
Flexfield structure, otherwise the Job Hierarchy will not use it.

HR: BIS Job Hierarchy - Job Grouping Level 2

Use this profile option to select the value set that represents the second level job grouping
in the Job Hierarchy. Ensure that the value set you select is associated with a Job Key
Flexfield structure, otherwise the Job Hierarchy will not use it.

HR:Blank Effective Date

Use this profile option to select the default value of the effective date field on the
Effective Date page that appears at the start of a self-service action. When you set this
profile to Yes, the effective date field is blank. When you set it to No, the page displays
the default date.

The default date can differ, depending on:

• Future-dated changes for the person whose record you are updating

• The value of the profile HR:Manage Self Service actions when future-dated changes
exist

The default date is usually the system date. The default date is the effective date of the
future change if (1) you do not enable managing actions and (2) future-dated changes
exist.

HR:Business Group

This profile option determines the business group linked to a responsibility. The Setup
Business Group is defaulted at Site level.

If you use Standard HRMS security this option is automatically set up when you enter
the HR: Security Profile profile option, except in cases where you are using a global
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security profile (that is, a security profile that does not specify a business group). In this
case, you must specifically set up this option for each responsibility.

If you use Security Groups Enabled security, this option is not user-configurable. The
business group is determined when you create a security profile assignment using the
Assign Security Profile window.

HR: Cancel Application

This profile option enables you to delete an applicant’s record that has been entered
in error. The default value is set to Null, this is interpreted as No and the function
will not work.

HR: Check Entitlement Cache

This profile option is supplied primarily for Oracle Development or Third Party
Suppliers to use. It currently has no impact on delivered functionality.

This profile option enables you to control whether the entitlement evaluation process first
looks to see if a value for a particular entitlement exists in the cache before re-evaluating.

HR: Collective Agreement Logging

This profile option enables you to control whether the log file generated during
the entitlement evaluation or entitlement population processes shows high or low
detail. This profile only affects the processed that run from the Entitlement Results
window, The log generated when you run the Collective Agreement Entitlement
Evaluation process from the Submit Requests window always displays high detail
and is not affected by this profile option.

HR:Contingent Worker Manager Actions Menu

This profile option controls which Manager Actions menu SSHR displays for managers
who are also contingent workers. If you create a custom Manager Actions menu for
contingent workers, you must change this profile option to point to your custom menu.

HR:Contingent Worker Personal Actions Menu

This profile option controls which Personal Actions menu SSHR displays for users
who are also contingent workers. If you create a custom Personal Actions menu for
contingent workers, you must change this profile option to point to your custom menu.

HR: Copy Period Details for Budget

You use this user profile option for HRMS budgets. When you set the profile option to
Yes, the application copies all budget details (budget periods, budget sets, and funding
sources) to a new budget worksheet when the worksheet is a copy of an existing budget
version.

HR:Cross Business Group

This user profile option allows users of some HRMS windows to see certain information
for more than one business group. If you set this option to Yes, it:

• Enables users to select benchmark jobs from other business groups

• Checks for the uniqueness of job names across all business groups and issues a
warning if you attempt to enter a non-unique name
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• Enforces that there can only be one master job group

• Enables users to create global competencies and rating scales

• Controls whether users can select people from other business groups in the
following fields in HRMS windows:

• Absence: authorizing person, replacement person

• Applicant Assignment: recruiter, supervisor, referred by

• Assignment: supervisor

• Organization Manager Relationship: manager - also controls whether
organizations from other business groups are available.

• Events: event participants, internal contact person

• Employee review: reviewers

• Requisitions and Vacancies: requisition raised by, recruiter

• Recruitment Activity: authorized by, internal contact

• Termination: accepted by

This profile option also controls the filtering of HRMS secure views. If you set this profile
option to Yes, secure views display data across all business groups. If you set this profile
option to No, the views filter data by the business group of the current security profile.

Note: If you have built custom code that references HRMS secure
views, the setting of the HR: Cross Business Group profile option may
affect the functionality of your code.

Set to Yes if users need to see this information across all business groups. Set to No if
users only work with the information defined for one business group. The default is No.

HR: CWK in Head Count Reports

This profile option determines whether contingent workers are included in head count
reports.

HR: Data Exchange Directory

This profile option is used by Data Uploader and other areas of the system which need to
read or import files. Set this profile to the full path for a directory accessible to the Oracle
database. Files stored in this directory can then be accessed by Oracle HRMS.

HR: Data Migrator Business Group Lockout

This profile option is for a future release.

HR:Data Pump Action Parameter Group

Data pump may now be configured using action parameter groups instead of the default
action parameters. This configuration enables data pump configuration to be separate
to that of payroll processes that share action parameters (e.g. the THREADS action
parameter) with Data Pump. You can use the HR:Data Pump Action Parameter Group
profile option to specify the default action parameter group to use for Data Pump action
parameters. HRMS also provides an extra concurrent program parameter to enable the
action parameter group to be changed for the Data Pump run.
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The default value for this profile option is Null and it is treated as Null in the code (the
default action parameter group).

HR:Default Assignment Costing

Set this profile option to Yes to enable default costing for position assignments. For
position control budgets, the default value is the proportional value for the budget. You
can write a FastFormula to override the budget value with other costing segments
and proportions.

HR:Default Check/Cheque Number Method

Use this profile option to set the automatic check/cheque number process. You
can set this profile with the Organization Payment Level value to enable automatic
check/cheque numbering. This profile option is for US and Canadian Payroll only.

HR: Default Correspondence Language

Specifies a default language for the Correspondence Language field.

This profile option is for users of the Italian legislation only.

HR: Default Full Name Format

Controls the default value for the full name format.

This profile option is for users of the Dutch legislation only.

HR: Default Nationality

Defines the default nationality for a user. When a new person is entered in the People
window, the nationality entered here is automatically displayed in the Nationality field.

HR: Defer Update After Approval

Defers save of SSHR transactions after the final approval. The transaction is saved
automatically when the Workflow Background Proces runs.

This applies to Self Service.

HR: Disable Ethnicity Tab

Enables you to disable the ethnicity tab in the People window.

This profile option is for users of the Dutch legislation only.

HR:Display Competencies

Controls the display of competencies in an Advanced Search. It is used to control
the display of skill categories in:

• Apply for a Job

• Enroll in a Class

This User Profile Option is used in SSHR.
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HR:Display Brief Person Name

By default this profile option is set to Brief Name, which means that on the Enter
Process pages, employee names are displayed in brief format. If you prefer to see the
full employee name, set this profile option to Full Name.

HR: Display Position Hierarchy

If set to Yes position hierarchy will be used in the HGrid on the Enter Process page in
SSHR. By default the HGrid uses supervisor hierarchy.

HR: Employment View Layout

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.

HR:Enable Bank Branch Validation

Set this profile option to Yes to turn the Sort Code validation on and off. Sort Code
will only appear for territories, for example GB, where branch code validation is
supported. You disable the validation if you don’t set this profile option or set it to N.

Note: Note: As this profile option is a global profile option, you should
take care in a multi-territory Oracle HRMS implementation not to
set it on with too wide a scope.

HR: Enable DTW4 defaulting

This profile option is for use by US and Canadian customers who use Vertex geocodes
data to validate US and Canadian addresses. It enables or disables the defaulting of
DTW4 employee tax data when an employee primary address or work address is
changed. For example, set this option to No to prevent DTW4 data from being defaulted
when an employee address is changed to an overseas address.

The default is Yes. This option can be set at site level only.

HR:Enable Multiple Assignments in SSHR

This profile option controls whether a manager can view and update multiple
assignments for an employee in SSHR. If the profile option is set to Yes, all the
assignments of a person will be displayed on the HGrid on the Enter Process
page. Otherwise, only primary assignments will be displayed.

This profile option is used in SSHR.

HR: Enable Web ADI Integration

This profile option controls the functionality of the Data Export button on the Oracle
HRMS toolbar. Set this profile option to Yes at Site level to enable integration with Web
ADI, so that when a user chooses the Data Export button, the download process uses
Web ADI. Set to No to use Application Data Exchange (ADE).

The default is No.

HR: Enforce Costing Mandatory Segment Check at Data Entry

Set this profile option to Yes to specify that users must enter a value for a mandatory
costing segment at each costing level where it is qualified.
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HR: Execute Legislative Check Formula within Run

Determines whether the legislation-specific check is performed during a payroll run.

HR: Expand Role of Contingent Worker

This profile option enables you to select contingent workers to perform many of the roles
fulfilled by employees. For example, if you set the profile option to Yes you can select a
contingent worker to be a supervisor in the Assignment window and an authorizer in
the Absence window.

You are now able to select a contingent worker to fulfill the following roles:

• Supervisor

• Recruiter

• Interviewer

• Cost center manager

• Reviewer

• Event attendee

• Termination authority

• Manager

HR: Extension Agent

If you are using Info Online to allow users to access to information provider websites
from a button on the Oracle toolbar, use this profile option to launch dynamic content
via a web server different from the one specified by the Applications Servlet Agent.

HR: Extension Agent Client Timeout

If you are using Info Online to allow users to access information provider websites from
a button on the Oracle toolbar, this profile sets the maximum time in seconds that the
system waits to contact the web server mediating the connection to Authoria HR.

You should not set this value unless asked to do so by Support.

HR: Extension Agent Enabled

If you are using Info Online to allow users to access information provider websites from
a button on the Oracle toolbar, this profile option controls whether or not the feature is
enabled for a user or group of users. Set to Yes to enable the feature and display the Info
Online button on the Oracle toolbar. Set to No to disable the feature and hide the button.

This is similar to the way that Applications Help Web Agent acts as an override to
the default.

HR: FastFormula Debug Level

Enables debugging information to be output from the FastFormula compiler and
execution engine.
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HR: Free text school name allowed in Self Service

If this profile option is set to No, the user will not be able to enter text freely for the
school name. Instead their entry will be restricted to a list of values. If the profile option
is set to Yes they can enter free text, or choose from the list of values.

HR:French HRMS check mandatory payroll assignment attributes exist

This profile option enables you to control, where your business group is defined as
French, whether the mandatory checks for establishment, contract and employee
category attribution are performed on payroll assignments.

HR: GL Cost Center Org Classifications

This profile option defines which organization classifications are created when you
synchronize your GL cost centers with your organizations in HRMS. It has the following
settings:

• None

• Company Cost Centers

• HR Organizations and Company Cost Centers

HR: GL Cost Center Synchronization Options

This profile option is obsolete.

HR: GL Organization Name Format

This profile option enables you to define the name format for organizations created
automatically in HRMS based on a GL cost center.

HR:Global Competence Flex Structure

Defines the competence key flexfield structure to be used when creating global
competencies. If you do not have a value in this field then you will not be able to
create global competencies.

HR:Grade Key Flex-Identify 1st and 2nd Segments

These options are used to control which two segments of the key flexfields appear
in Person Search.

This profile option is used in SSHR.

HR: HR/Payroll Representative Source

SSHR offers three methods for determining an organization’s default payroll
representative:

• From Payroll (Further Payroll Information).

• From GRE (Organization Information).

• From custom (PL/SQL) code.

This profile option is used in SSHR.
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HR: Info Online: Open in New Window

If you are using Info Online to allow users to access information provider websites from
a button on the Oracle HRMS toolbar, this profile option controls whether the results
are displayed in a separate browser window each time the user follows a link. Set to
Yes to open a new window for each link followed; set to No to use the same window
for each link.

HR: Info Online: RIA Password

If you are using Info Online to allow users to access the third party information product
RIA from a button on the Oracle toolbar, this profile option controls the single sign-on
capability between Oracle and RIA. Enter a valid password at user level.

Note: If you change your password on PCP then you must also update
this user profile option.

HR: Info Online: RIA Username

If you are using Info Online to allow users to access the third party information product
RIA from a button on the Oracle toolbar, this profile option controls the single sign-on
capability between Oracle and RIA. Enter a valid username at user level.

HR: Info Online Toolbar Icon

If you are using Info Online to allow users to access information provider websites from
a button on the Oracle toolbar, you can optionally use this profile option to identify an
alternative icon for the Info Online toolbar button.

The image file should be in GIF format with the following attributes:

• Size: 18x18 pixels

• Transparent background colour RGB:192,192,192 (grey)

• 216 colour depth

Place the file in the virtual directory (relative to the web server used to start forms):

/OA_JAVA/oracle/apps/media

In most installations this would be the directory:

$JAVA_TOP/oracle/apps/media.

HR: Info Online: Use Field Context

If you are using Info Online to allow users to access information provider websites from
a button on the Oracle toolbar, this profile option narrows the search using predefined
contexts associated with your current field and window.

Set to Yes to use the predefined contexts to narrow the search; set to No to display a list
of all predefined options that are available from the selected window.

HR:Informal Name Format

Use this profile option to define the way a person’s name appears in your workflow
notifications. If you do not set the HR: Informal Name Format profile option, the
application uses the default name structure.

Use the following values:
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• $FI - First Name

• $MI - Middle Name

• $LA - Last Name

• $PR - Prefix

• $SU - Suffix

• $TI - Title

• $FU - Full Name

• $KN - Known As

• $IF - Initial First

• $IM - Initial Middle

HR:Job Key Flex-Identify 1st and 2nd Segments

These options are used to control which two segments of the key flexfields appear
in Person Search.

This profile option is used in SSHR.

HR: Job Level

The job level options are used to determine the seniority of a person’s job. You can set a
default for the job level at Site, Application and Responsibility level.

HR:Local Nationality

Use this profile to set a value for nationality. This profile option is for users of the
Saudi Arabia Payroll only.

The system administrator sets this option at any level of standard Security hierarchy
type - Site, Application, Responsibility, and User.

The system administrator must enter a nationality code, available in the user
defined-lookup_type, NATIONALITY. You cannot run the payroll until you set this
profile option. If you attempt to run payroll before setting this option, the application
will display an error message.

HR:Manage Self Service Actions When Future-Dated Changes Exist

If you have set the profile option HR:Allow Concurrent Self Service Actions to Yes, this
profile option allows you to control potential data conflicts when future-dated changes
exist.

The default setting is Stop with an Error. This will force the user to choose an effective
date subsequent to any future-dated change.

Change this to Allow Approval (Notify HR Rep) to allow the user to select a date prior to
any future-dated changes. After final approval the transaction will be forwarded to an
HR Representative for review and manual entry into the database.

Important: If you are setting this profile option to Allow Approval, and
you have enabled HR:Allow Approver Updates to Self Service
Actions, Oracle recommends that you also enable HR:Refresh Self
Service Actions with Data from Intervening Actions.
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HR:Manager Actions Menu

Controls which actions menu is displayed for managers within SSHR. If you create a
custom Manager Actions menu, you must change this profile option to point to your
custom menu.

This profile option is used in SSHR.

HR: Mask Characters

Use this profile option to set the number of characters or digits to display in numbers
such as bank account or credit card numbers. Enter a positive number of digits to
display from the back (for example, xxxx345) or a negative number of digits to display
from the front (for example, 123xxxx).

HR: Metalink Integration Application

Use this profile option to select the first MetaLink page that appears when you choose
the Info Online toolbar button in an HRMS window. You can select a page for a specific
application (for example, Human Resources or Payroll), or you can add your own choice
of pages to the list using the HR MetaLink Application lookup.

HR: Metalink Integration Enabled

Set this profile option to Yes to enable links from Oracle HRMS windows to MetaLink
via the Info Online toolbar button. Set to No to disable the links.

HR:Monitor Balance Retrieval

This profile enables the Monitor Balance Retrieval Debug Tool, which allows you
identify database items associated with the values held in the latest balance tables, in
order to reference them in the formula called by the payroll run. Set to Yes to enable
monitoring, or No to disable monitoring.

HR: NI Unique Error or Warning

Enables you to change the default warning to an error message.

If you want to warn users that the national identifier they have entered already
exists, leave the default as warning. If you want to prevent a user entering the same
national identifier more than once, you can change the message to an error. This stops
the user entering the same national identifier.

HR: National Identifier Validation

Enables you to define the validation that is used for a national identifier. There are
three possible values:

• Error on Fail (default value). If a user enters an invalid national identifier, an error
message is displayed and the user cannot save the national identifier until they
have entered it in the correct format.

• Warning on Fail. If a user enters an invalid national identifier, a warning is
displayed, but the user can save the national identifier.

• No Validation. A user can enter and save the national identifier in any format. No
validation is performed and no message is displayed.
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HR:Non-Updateable Element Set

Select a customization element set to define the element entry values that are view-only
on the Element Entries window. Typically you use this user profile option to prevent
updates to elements that are maintained using legislation-specific windows.

HR: Online Tax Forms Update Method

SSHR supports multiple assignments per person, and keeps tax information per
assignment. Since a person can file only one withholding form, however, SSHR offers
three options to handle multiple assignments:

• Primary. Updates primary assignments only.

• All (default value). Updates all assignments.

• None. Disables self-service updates.

This profile option is used in SSHR.

HR: OAB New Benefits Model

Enables you to set up whether you are using the new benefits model, that is, Standard or
Advanced Benefits. Enter Yes, if you are using the new benefits model. Enter No, if you
are using the compensation and benefit models from previous releases.

HR: Override Grade Defaults

Controls whether the end user can override the defaults in the list of values for the
grade. If the profile option is set to No, the user can only select grade values from the
defined list of values.

This User Profile Option is used in SSHR.

HR:Payroll Payments Self-Service Enable Multiple Assignments

This profile option is used by Payroll Payments Self-Service version 4. If it is set
to No, employees can only specify payroll payments for their primary payroll
assignment. If set to Yes, employees can specify payroll payments for additional payroll
assignments. The default is No.

This profile option is used in SSHR.

HR:Payroll Payments Self-Service Payments List Mode

If you set this profile option to Like, you can select the organization payment method
name on the basis of it being like an entry in the payments list configuration attribute
instead of an exact match. The setting of Like also enables you to perform an exact
match. The default of this profile option is null, which performs an exact match.

HR: Performance View Layout

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This profile option is used in SSHR.
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HR:Personal Actions Menu

Controls which actions menu is displayed for users within SSHR. If you create a custom
Personal Actions menu, you must change this profile option to point to your custom
menu.

This profile option is used in SSHR.

HR:Position Key Flex-Identify 1st and 2nd Segments

These options are used to control which two segments of the key flexfields appear
in Person Search.

This profile option is used in SSHR.

HR: Propagate Data Changes

You use this profile option to control the synchronization of your person records where
you have multiple records for one person, for example if a person has local records in
two different countries

If you want changes made in one business group to be propagated throughout all
business groups, then set this profile option to Yes.

Note: You can only propagate changes to business groups in which your
security profile allows you to make updates.

HR:Purge Element Entry Permission

Controls whether users can purge element entries (irrespective of whether those entries
have been processed by a payroll run). It does not affect a user’s ability to perform
datetracked deletions or updates. The possible values are:

• All (the user can purge all element entries)

• Information (the user can purge only informational (non-payment) element entries)

• None (the user cannot purge any element entries)

Note: If you have installed a third party payroll interface, you cannot
purge any element entries attached to the interface. If you are using a
setting of All or Information, an error message to this effect appears
when you attempt to purge an element entry.

HR:Query Only Mode

Set to Yes to restrict access to view-only for all HR and Payroll forms on a menu.

You can set this profile for individual responsibilities or users, or at the site or application
level.

If you want to give query-only access to some forms and full access to other forms, set
the HR:Query Only Mode profile to No and use the parameter QUERY_ONLY=YES at
form function level to restrict access to individual forms.

Note: You can set the parameter QUERY_ONLY=YES for a form
function that also launches a task flow. In this case, specify two
parameters in the Form Function window:

QUERY_ONLY=YES

WORKFLOW_NAME="task flow name"
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The entire task flow will be query-only, not just the first form.

See: Restricting Access to Query-Only Mode, page 1-101.

HR:Refresh Self Service Actions with Data from Intervening Actions

This profile allows you to control the effect of concurrent actions. If this profile is set
to Yes, when a pending change is approved which affects the current transaction the
application will display a warning message listing changed attributes and the data
will be refreshed. If it is set to No, the default, the application will display a warning
message and the transaction will fail.

Oracle recommends that this profile option is set to Yes if HR: Allow Approver Updates
to Self Service Actions is also set to Yes.

Note: Oracle recommends that you enable this option if you have set the
system profile HR:Manage Self Service Actions When Future-Dated
Changes Exist to Allow Approval (Notify HR Rep). Otherwise you
should disable this option.

HR: Restrict Letter by Vacancy or Event

This profile serves both HR and OTA letter requests. It enables you to generate separate
letter requests for each event (OTA) and for each vacancy (HR).

If you set the profile to Yes, it displays the Vacancy Name field on the Request Letter
window. Choosing a value in this field restricts the letter generation to applicants
associated with the vacancy you choose in the Vacancy Name field.

HR:Restrict Transactions across Legislations in SSHR

If the HR:Cross Business Group profile is set to Yes, this profile can prevent SSHR
managers from carrying out transactions on employees (within their supervisor
hierarchy) who are from different legislations.

HR: RIA Integration Enabled

Set this profile option to Yes to enable links from Oracle HRMS windows to the web
pages of third party information provider RIA via the ’Info Online’ toolbar button. Set to
No to disable the links.

HR:Run BENMNGLE When Processing a Self Service Action

In order to ensure that the list of eligible actions and sub-actions is up to date, you
must periodically run the Participation Batch Process (Run Benefits Manage Life
Events Process) for that individual. This can be set to run automatically every time a
manager initiates an action by setting the profile option, HR:Run BENMNGLE When
Processing a Self Service Action, to Yes.

HR: Salary View Layout

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This User Profile Option is used in SSHR.
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HR: Security Profile

Restricts access to the organization, positions and payrolls defined in the security
profile. This option is predefined at Site Level with the view-all security profile created
for the Setup Business Group.

If you use Standard HRMS security you must set up the HR: Security Profile profile
option for each responsibility.

If you use Security Groups Enabled security you must not set up the HR: Security Profile
profile option. This is set up automatically when you assign security profiles using the
Assign Security Profile window. You must only change the HR: Security Profile option
by assigning a different security profile to a responsibility using the Assign Security
Profile window.

HR: Self Service HR Licensed

Controls whether Self-Service HRMS (SSHR) is available. If the customer has obtained a
license for SSHR, they must set this profile option to Yes at the site level.

This profile option is used in SSHR.

HR:Self Service New Hire Default Values

Specifies whether values for the new person record should be defaulted or not.

For the New Hire function, if the profile is set to Yes, then the following values are
defaulted based on the primary assignment, as of the system date, of the person logged
in:

• Organization

• GRE (if US)

• Payroll

• Salary Basis

The supervisor for the new person defaults to the person logged in. For both New Hire
and Applicant Hire, this profile also controls whih person type is defaulted.

• If the profile is set to No and there is only one person type available, then this
person type is defaulted. If there is more than one available then the field remains
blank and you can select a value.

• If the profile is set to Yes and there is only one person type available, then this person
type is defaulted. If there is more than one available, then the field displays the
person type set as the default for the system person type of Employee.

This profile is used in SSHR.

HR:Self-Service Save for Later

This profile options allows the Save for Later button to be displayed on all transaction
pages in Self Service. Set it to No to disable this feature.

HR: Subrogation

Use this profile option to set a value for subrogation. This profile option is for users
of the French legislation only.
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HR: Supervisor Hierarchy Usage

If you are using supervisor hierarchies for security within your organization, you use
this profile option to specify whether the supervisor hierarchy is person-based or
assignment-based.

HR: Training View Layout

Enables a manager to see the Detail Summary View in a Form or Tabular Format.

This profile option is used in SSHR.

HR:TCA Unmerge Options

The Trading Community Architecture (TCA) Unmerge function, which removes the
records of people who are only contacts from the TCA party tables, is delivered in patch
3625452 and is part of the November 2003 Family Pack (PER Family Pack G). The TCA
Unmerge function uses the TCA purge parties process, which checks references to party
IDs throughout the E-Business Suite. This process can take a long time to complete. Patch
3621712 provides you with an alternative approach to the TCA Unmerge process. If
you apply patch 3621712 prior to installing PER Family Pack G you can use this profile
option to control how the unmerge process is run. Select one of the following options:

• Pre Stage ProcessIf you select this option, then, the TCA Unmerge process does
not run during auto patch. Instead, you can log in as a System Administrator and
submit the concurrent program Unmerge Contacts from TCA (HR TCA process)
at a convenient time.

• In Patch ProcessIf you select this option (which is the default option), then the
HRMS component of the unmerge process is run during auto patch. A concurrent
program is then submitted automatically during the auto patch process to run the
TCA component of the process.

• Deferred ProcessIf you select this option, then a concurrent program is submitted
automatically during the auto patch process to run both the HRMS and TCA
components of the process.

HR: Use Fast Formula Based PTO Accruals

This user profile option is disabled.

HR: Use Global Applicant Numbering

Enables the Global sequence for applicant numbering generation process. This sequence
is shared among all business groups.

To set this profile option, you run the process "Change automatic person number
generation to global sequencing". You cannot set this option in the System Profile
Values window.

HR: Use Global Contingent Worker Numbering

Enables the Global sequence for contingent worker numbering generation process. This
sequence is shared among all business groups.

To set this profile option, you run the process "Change automatic person number
generation to global sequencing". You cannot set this option in the System Profile
Values window.
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HR: Use Global Employee Numbering

Enables the Global sequence for employee numbering generation process. This sequence
is shared among all business groups.

To set this profile option, you run the process "Change automatic person number
generation to global sequencing". You cannot set this option in the System Profile
Values window.

HR:Use Grade Defaults

This profile option allows you to restrict the list of values for the grade to include only
those values permitted by the parent organization, job, or position.

This Profile Option is used in SSHR.

HR:Use Standard Attachments

Disables the facility to attach short text comments to records. Enables the attachment of
multiple items of various types including OLE objects, Web pages, images, and word
processed documents.

HR:User Type

Limits field access on windows shared between Oracle Human Resources and Oracle
Payroll. If you do not use Oracle Payroll, it must be set to HR User for all responsibilities.

Note: You must set this profile option at responsibility level.

If you do use Oracle Payroll, you can give each responsibility one of the following user
types, depending on the work role of the holders of the responsibility:

• HR User

• HR with Payroll User

• Payroll User

HR: Use Title in Person’s full name

Enables you to remove title from a person’s full name so that it does not appear in person
search lists, such as the Find window on the Person window.

This user profile option is only effective when you insert new records or update existing
records. To remove title from existing records without updating them you should run
the Remove Title from Person’s Full Name concurrent process.

HR: View Payslip From Date for WEB

Limits the number of pay periods an employee can view.

This profile option is used in SSHR.

HR: Views Layer Size

Enables you to set the width of the Employee Name and Employee Number floating
layer to the longest name and number you have.

This profile option is used in SSHR.
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HR:View Unpublished Employee 360 Degree Self Appraisal

Enables a manager to view their employee’s unpublished 360 Degree self appraisals. Set
the profile option to Yes to view an employee’s unpublished 360 Degree self
appraisals. The default value is Null.

This profile option is used in SSHR.

HR:Webapps Tips Test Mode

Forces all tip icons in SSHR to be displayed whether tip text is defined or not.

This User Profile Option is used in SSHR.

HR: Web Proxy Host

This option is used as part of the Knowledge Management which allows the Proxy Host
to be used when accessing an external site.

HR: Web Proxy Port

This option is used as part of the Knowledge Management which allows the Proxy Port
to be used when accessing an external site.

HR: Worker Appraisals Menu

This profile option determines the values that are displayed in the Create poplist in the
Worker Appraisals page. The default value is Employee Appraisals Menu.

HRI:Enable Captured Events Archive

This profile option is a debugging option that sets the archive mode for the events
capture process. If you set this option to Yes, all events that trigger incremental
processing will be archived.

HRI:DBI Force Foundation HR Processes

This profile option forces the HRI Collection Programs to run in Foundation HR mode
(on a Full HR Installation). The Foundation HR mode reduces load times, by collecting
data for the system date only. It does not maintain historical. If you are an HRI DBI
customer, you must set this profile option to No.

HRI:Populate Assignment Events Queue

This profile option determines whether the events collection process populates the
incremental update queue for the assignment events collection process. If you never run
the assignment events process, set this profile option to No to reduce the load times of
other processes. If you are an HRI DBI customer, you must set this profile option to Yes.

HRI:Populate Supervisor Hierarchy Events Queue

This profile option determines whether the events collection process populates the
incremental update queue for the supervisor hierarchy collection process. If you never
run the supervisor hierarchy process, set this profile option to No to reduce the load
times of other processes. If you are an HRI DBI customer, you must set this profile
option to Yes.
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HRI:Populate Supervisor Status History Events Queue

This profile option determines whether the events collection process populates the
incremental update queue for the supervisor status history collection process. If you
never run the supervisor status history process, set this profile option to No to reduce
the load times of other processes. If you are an HRI DBI customer, you must set this
profile option to Yes.

HRMS: Workforce Turnover Calculation Method

This profile option determines how reports calculate annualized headcount turnover. If
you select Workforce End, the annualized turnover calculation will use the headcount at
the end date of the reporting period. If you select Workforce Start + End Average, the
annualized turnover calculation will use the average of headcount at the start date and
headcount at the end date of the reporting period.

The default is null, which means that the calculation will use the headcount at the
end date of the reporting period

Limit by Persons Organization

Set this profile option to Y to limit the Compensation Objects selected by the Participation
Process to only those linked to the employee’s organization.

OAB:Self Registered User Responsibility

Identifies the responsibility to be granted to new users who successfully self-register in
SSHR using the New User Registration processes. This profile option is seeded at site
level with the seeded responsibility Self Registered Employee Default Responsibility. You
can set this profile at responsibility level if you have created several responsibilities for
different groups of users to use after initial registration.

This profile option is used in SSHR.

OAB:User to Organization Link

In the self-service New User Registration processes, links the responsibility you give to
new users to register on SSHR with the organization to which they belong.

This profile option is used in SSHR.

OAB:User to Payroll Link

In the self-service New User Registration processes, provides a default employee payroll
linked to the responsibility you give to new users to register on SSHR.

This profile option is used in SSHR.

PAY: Generate Periods for Tax Year

Since the lunar month has only 28 days, the yearly start date of a period would be
always less than the legislation specific start date. This profile option enables you to
reset the generated payroll period start date back to the legislation start date. You
should set the profile option to Yes to display Reset Years in the Payroll window. The
default value is No.
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Personalize Self-Service Defn

This profile option enables or disables the global Personalize link and Personalize Region
link that appear on self-service functions from SSHR 4.0 and above.

This profile option is used in SSHR.

PO: Services Procurement Enabled

If you use Oracle Services Procurement to provide purchase order information for
contingent worker assignments, you must set this profile option to Yes.

Talent Management Source Type

This profile option points to the user lookup "PROFICIENCY_SOURCE". In the
Appraisals process, when Competency Final ratings are applied to the user’s personal
competency profile, this profile option causes the rating value to be stored in the
PROFICIENCY_SOURCE column in the PER_COMPETENCE_ELEMENTS table.

Workforce Measurement Type

This profile option determines the workforce count measure in Daily Business
Intelligence. The values currently supported are Headcount, and Full Time
Equivalent. The recommended value for this profile option in Daily Business Intelligence
is Headcount.
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Menus, Functions, and Responsibilities

Responsibilities
You can control users’ access to human resources information by record, window and
function.

The responsibility is your primary means of defining security. To define what a user can
access you link a user, responsibility and Business Group to a security profile. Other
important components of the responsibility are the menu structures, task flows and
information types. These also help you limit the employee records a user can access.

Users can sign on to the system only through the responsibilities you give them. So their
responsibilities control what they can see and do in the system.

Responsibility
A responsibility is linked to a security profile and composed of:

• A menu structure

• A request group for reporting users (optional)

• Extra information types available to the user

Responsibilities are also linked to business groups. However, depending on which
security model you use, you link responsibilities differently.

• Standard HRMS Security

You can only link one business group to one responsibility using Standard HRMS
security. You must set up different responsibilities for each business group.

• Security Groups Enabled Security

You can enable more than one business group for a single
responsibility. However, you still only view records for one business group at a time.

Each model enables you to set up multiple responsibilities. You can assign multiple
responsibilities to users who need to:

• Access applicant and employee records from two or more security profiles.

• Use more than one menu structure to view or make changes to the records they
can access.

• Access records for more than one business group if you use Standard HRMS
security. For example, an enterprise with international operations may have a
US-Based business group and a UK-Based business group. A few of your employees
might need to access both.

Access Control Through Responsibility
The following key components help control user access to Oracle HRMS:

• Security profiles determine the organizations, positions and payrolls whose applicant
and employee records responsibility holders can access.

• Business Groups determine the set of records a user can access. Using Security
Groups Enabled security you can enable one responsibility for many business
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groups. Using Standard HRMS security you must set up a new responsibility for
each business group.

• Menu structures and functions control:

• The particular windowsand functions a responsibility holder can access

When you create a responsibility, you assign a menu structure to the
responsibility. You can assign either a delivered menu or a custom menu. If
required, you can restrict access to particular functions or menus using function
or menu exclusions.

See: Overview of Menus and Function Security, Oracle Applications Developer's
Guide

See: How Function Security Works, Oracle Applications Developer's Guide

Warning: If you exclude a function from a responsibility, a user
with the responsibility can no longer access the function from
any menu assigned to the responsibility. However, the function
may still be attached to a task flow. If this is the case, the user
will be able to access the excluded function when working
through the task flow sequence. To avoid this situation, you
may need to modify you task flows to remove the function.

See: Task Flow, page 3-250

• Whether he or she can perform data entry, change or deletion on these windows

You can produce configured versions of some windows. Each configured
version enables access to a subset of certain types of information, such as person
types, special information types, or elements. You define additional menu
functions to call configured windows or task flows, and then you add these
functions to a menu structure, which is linked to a responsibility.

• Request groups determine the group of processes and reports a responsibility holder can
initiate. A request group is an optional component of a responsibility. If holders
of a responsibility should not initiate any reports or processes, you do not include
a request group in the responsibility.

• Extra Information types are an optional component of a responsibility. By defining
which extra information types are included in a responsibility, you effectively create
a configured version of a window for users who are assigned the responsibility.

Important: If you do not associate any extra information types with
a responsibility, a person assigned to this responsibility will not have
access to any extra information types in the product.

For each responsibility, you must also define the user profile option HR:User Type.

Menu Structure
Users access standard windows, configured windows, and the first window in a
task flow through the menu structure displayed in the Navigator window. Each
responsibility includes a menu structure to restrict the windows users can access, and
what they can do on these windows.
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A function is a part of an application’s functionality that is registered under a unique
name for the purpose of assigning it to, or excluding it from, a responsibility. There are
two types of functions: form functions, and non-form functions. For clarity, we refer to a
form function as a form, and a non-form function as a subfunction, even though both are
just instances of functions in the database.

Using Function Security system administrators can further restrict access to individual
menu options. You can include:

• Standard windows, displayed in edit or view-only mode

• Configured windows, on which you have restricted the range of data that can
be displayed

• The first window in task flows that link a number of windows that are used in
sequence to complete a task

By defining menus with function security for groups of users, you can:

• Limit the range of information users can access for the applicant and employee
records available to them

• Improve users’ efficiency in using the system by reducing menu choices

• Restrict users to query-only access to some or all windows

Each responsibility you define must be linked to a root menu. The root menu lists the
menu options when the Navigator window first opens.

The Default Menu Structure
The AutoInstall program creates a default menu structure for your HRMS product. This
menu structure enables you to access all of the windows for your system. Normally, only
a system administrator has access to the full default menu structure.

The supplied menus give you access to all of the available submenus. However, a
number of predefined functions are not enabled on these menus. If your localization
requires these menus, you need to add them for the responsibilities that should have
access to these functions.

• HR View Medical

This causes the Medical Information tabbed region to display in the People window.

• HR View Background

This causes the Background Information tabbed region to display in the People
window.

• HR View Benefits

This causes the Benefits tabbed region to display in the People window.

• HR View Rehire

This causes the Rehire Information tabbed region to display in the People window.

• Salary Administration: Approve

This enables the user to approve salary proposals in the Salary Administration
window and the Salary Management folder.

• HR View Projects Information
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This causes the Projects Information tabbed region to display in the Assignment
window. You must have Oracle Projects installed to display this region.

Caution: Oracle HRMS with DateTrack and task flows does not fully
support multiple active windows. When you define a new menu for use
with Oracle HRMS the top menu must include the following function as
a separate menu option:

Disable Multiform

See: Disabling Multiple Windows, page 1-100

Request Groups
When you build a responsibility for employees who must initiate reports or
processes, you can attach a request group to the responsibility. The request group lists
a group of processes and reports its holders can run. Holders of responsibilities with
no request groups cannot run any processes or reports.

The group Reports and Processes gives access to all predefined reports and processes.

Structuring Menus
Using function security and the Menus window, you can use the default menu for any
number of responsibilities and restrict access to the default menu options. You can also
define any number of new functions and menus to restrict the access of other users. To
view the hierarchy of menus you have defined, you can run the Menu Structures report.

Caution: You should not modify the default functions and menus
supplied with the system. On upgrade, these defaults will be
overwritten.

If you want to add window configuration options or task flows you
should define your own menus.

The supplied menus give you access to all of the available submenus. However, a
number of predefined functions are not enabled on these menus. You need to add them
for the responsibilities that should have access to these functions.

Structuring Menus:
1. Start by drawing it out on paper. This helps you to decide the best structure and the

best prompts and descriptions.

2. Decide how to structure your menus. Menus can be structured in different ways:

• Following a Sequence of Tasks.

For example:

1. Define a Requisition and Vacancy

2. Define a Recruitment Activity

3. Enter Applicant Information

• By Type:
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For example, all inquiry windows grouped together. If you structure the menu
by type, the grouping is important but the sequence is not.

3. Work from the lowest level of sub-menu to the highest and define the root menu as
the last step in the sequence.

4. Define as many submenus as you require under each menu option. We recommend
that you restrict the number of menu levels to three because a menu structure
with more levels is cumbersome to use.

Defining Menus
Use the Menus window to add predefined functions to a menu.

Caution: Oracle HRMS with DateTrack and task flows does not fully
support multiple active windows. When you define a new menu for use
with Oracle HRMS the top menu must include the following function as
a separate menu option:

Disable Multiform

See: Disabling Multiple Windows, page 1-100

A number of predefined functions are not provided on the supplied menus. You can add
them to your own menus. See: Menu Structure, page 1-97 for a list of these functions.

To define a menu:
1. Query the menu onto which to add the function.

2. Add a new line and select the function.

For example, select Salary Administration: Approve to enable users to approve
salary proposals.

3. Save your changes.

See: Menus Window, Oracle Applications System Administrator’s Guide if you need
further information about using the Menus window.

Disabling Multiple Windows
In most Oracle Applications, you can open multiple windows from the Navigator
window without closing the window you already have open. HRMS, however, does not
support Multiform functionality.

Important: You must disable this feature on menu structures that
accesses Oracle HRMS windows.

To disable the Multiple Open Window feature:
1. Add a Function type menu entry to the top-level menu referenced by your new

responsibility.

2. Select the function whose User Function Name and Function Name are:

• Navigator: Disable Multiform
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• FND_FNDSCSGN_DISABLE_MULTIFORM

3. Save your changes.

Defining Menu Functions
Use the Form Functions window to define your menu functions.

Function Security helps you to control the menu options you make available to each
responsibility. When you define a responsibility you can restrict the submenus or
functions for that responsibility using exclusion rules.

See: How Function Security Works, Oracle Applications Developer's Guide

Define Menu Functions:
1. Define your menu function using the Form Functions window.

See: Form Functions Window, Oracle Applications Developer's Guide

2. When you have created your custom functions, add them to a menu.

See: Menus Window, Oracle Applications System Administrator’s Guide

Caution: You should not modify the default functions and menus
supplied with the system. On upgrade, these defaults will be
overwritten.

If you want to add window configuration options or task flows you
should define your own menus.

Restricting Access to Query-Only Mode

To restrict access to query-only mode for an individual form :
1. In the Form Functions window, select the form and specify the parameter

QUERY_ONLY=YES. If you want to specify other parameters for this form
function, separate them with a space.

2. Enter a user function name to identify your new function, and save it.

3. In the Menus window, select your new function instead of the supplied form
function.

Using Parameters for HRMS Form Functions

To use parameters in Form Functions:
For certain options you must define menu functions that include a parameter in the
Parameters field of the Form Functions window, as follows:

• If the menu entry calls a configured form, use the following parameter:

HR_CUSTOMIZATION = "customization name"

• If the menu entry calls the first form in a task flow, use the following parameter:

WORKFLOW_NAME = "task flow name"

• If the menu entry calls a form in query-only mode, use the following parameter:
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QUERY_ONLY=YES

• If the menu entry calls a people management template, use the following parameter:

TEMPLATE_NAME="name of your template"

• If the menu entry calls the Define Rate form (PAYWSGEV), use the following
parameter:

FORM_MODE = "grade" (for the Grade Rate window)

FORM_MODE = "spine" (for the Scale Rate window)

• If the menu entry calls the Payroll and Assignment Processes form (PAYWSACT
- used in Oracle Payroll), use the following parameter:

FORM_MODE = "assignment" (for the Assignment Processes window)

FORM_MODE = "payroll" (for the Payroll Processes window)

• If the menu entry calls the Organization Manager Relationship form
(PERWSCCM), use the following parameter to limit the list of organizations to those
with a particular classification. You can find the organization classification code
for a classification from the ORG_CLASS Lookup Type, for example the code for
HR Organization is HR_ORG:

RESTRICT_CLASSIFICATION = "organization classification code"

• If the menu entry calls the Enter Person window (PERWSEMP), you use the
following parameter to hide sensitive data:

HIDE_SENSITIVE_DATA = Y

• If the menu entry calls the People Management templates, you can use the following
parameter to enable assignment-level security:

SECURE_ON_INDIVIDUAL_ASG=”YES”

If you need to specify more than one parameter for a form function, separate the
parameters with a space.

For more information about using the Form Functions window see: Form Functions
Window, Oracle Applications Developer's Guide
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AuditTrail

AuditTrail Overview
The system administrator is responsible for performing AuditTrail on Oracle HRMS data.

Performing AuditTrail
AuditTrail provides a flexible approach to tracking the changes to your data. It enables
you to keep a history of changes to your important data: what changed, who changed
it, and when. With AuditTrail, you can easily determine how any data row or element
obtained its current value. You can track information on most types of fields, including
character, number and date fields.

You enable auditing for audit groups. These are groups of tables and columns you
want to audit, where you do not necessarily need to include all the columns in a given
table. You typically group together those tables that belong to the same business
process, such as employee compensation tables.

During your AuditTrail implementation, you need to decide your audit requirements:

• Which tables and columns you want to audit

• How you plan to report on the audit data

• How long you want to keep the audit data active

• Audit information reports

• Custom audit reports

See: Oracle Applications System Administrator’s Guide.

Audit Information Reports
The AuditTrail process creates a shadow table for each audited table, to hold the audit
information.

For tables that are not datetracked, you can write a report that uses the views on the
shadow tables to access the audit data. However, for datetracked tables, the information
from the shadow tables must be extracted and written to the HR_AUDITS table and the
HR_AUDIT_COLUMNS table before you can report on it.

The system’s audit report performs this additional processing. You can use it as supplied
or as an example of how to report on audit information. It can report on both datetracked
and non-datetracked tables that have a numeric primary key.

Note: It can report on up to approximately 90 columns in datetracked
tables and 80 columns in non-datetracked tables.

The report lists every change made to the table you select in the time period you
specify when you run the report. You can restrict the reported changes to those made
by a specified username. The changes are listed by date and time of the change. For
each change, the report shows:

• The date and time of the change

• The user ID who made the change
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• The type of change

• The fields that changed and either their old values, or their new values, or both,
depending on the type of change

Table of Transaction Types in the Audit Report
The following table lists the 12 types of change and the information shown in the audit
report for each type.

Type of Change Field Values Shown in the Report

Normal Insert

(creates a non-datetracked
record)

The non-null values in the new record.

Normal Update

(updates a non-datetracked
record)

The old and new values for all fields that changed.

Normal Delete

(deletes a non-datetracked
record)

The non-null values in the record that was deleted.

DT First Insert

(creates a datetracked record)

The non-null values in the new record.

DT Update

(date-effectively ends the last
row on a datetracked record
and creates a new row)

The old and new values of all fields that changed, and the new
effective end date on the old row.

DT Correction

(corrects a row of a datetracked
record and does not change
the effective dates)

The old and new values of all fields that changed, and the
effective dates of the corrected row.

DT Replace

(creates a new row on a
datetracked record that
replaces all rows that start
after its start date)

The non-null values in the rows that were deleted, the new
effective end date on the row preceding the new row, and the
old and new values of all fields that changed.

DT Insert

(creates a new row on a
datetracked record that ends
on the old effective end date
of the preceding row)

The old and new values of all fields that changed, and the new
effective end date on the row preceding the new row.

DT Purge

(deletes all rows of a
datetracked record)

The non-null values in all rows of the record that was deleted.
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Type of Change Field Values Shown in the Report

DT End Date

(adds an effective end date to
the last row of a datetracked
record)

The new effective end date of the row.

DT All

(sets a new effective end date
on a row of a datetracked
record and deletes all
following rows)

The non-null values in the rows that were deleted, and the new
effective end date on the last row.

DT Next

(deletes a row of a datetracked
record and uses its effective
end date to set an new end
date on the preceding row)

The non-null values in the row that was deleted, and the old
and new effective end dates on the preceding row.

Custom Audit Reports
If you want to design your own audit report, you can copy the supplied report and use it
as the basis of your own version. The supplied report uses a dynamic SQL structure to
retrieve information for the report, and an Oracle Report to format it.

Dynamic SQL Structure
For a non-datetracked table, the dynamic SQL structure retrieves information and uses a
private procedure to retrieve the new values for an update.

For a datetracked table, the dynamic SQL structure retrieves information from the
function and procedure created for each datetracked table by the Audit Trail Update
Datetracked Tables process:

• The tablename_TT function identifies the type of datetracked transaction represented
by each row of the shadow table.

• The tablename_VP procedure gets new values from the shadow table for update and
insert transactions. It writes these to the HR_AUDITS and HR_AUDIT_COLUMNS
tables.

The dynamic SQL structure comprises several character strings, which are concatenated
into one long string, then parsed and executed using the dynamic SQL generator. If you
change a string, you must ensure that you do not exceed the text space allocated to
it, as listed in the package header.

The structure is built up by identifying the audited table column information, which is
retrieved from the FND_AUDIT_COLUMNS table. The logic varies depending on the
data type being audited.

The package for the dynamic SQL is called py_audit_report_pkg. It is found in the
script pyadyn.pkh/pyadyn.pkb.
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HR Audit Tables
The HR_AUDITS table holds audit information about the transaction. The
HR_AUDIT_COLUMNS table holds the changed column information for that
transaction.

HR_AUDITS Table

The following table shows the structure of the HR_AUDIT table:

COLUMN TYPE NULL

audit_id number(15) not null

commit_id number(9) not null

current_session_id number not null

primary_key varchar2(30) not null

primary_key_value number(15) not null

sequence_id number(9) not null

session_id number not null

table_name varchar2(30) not null

timestamp date not null

transaction varchar2(30) not null

transaction_type varchar2(30) not null

user_name varchar2(100) not null

effective_end_date date null

effective_start_date date null

HR_AUDIT_COLUMNS Table

The following table shows the structure of the HR_AUDIT_COLUMNS table:

COLUMN TYPE NULL

audit_id number(15) not null

column_id number(9) not null

column_name varchar2(30) not null

new_value varchar2(240) null

old_value varchar2(240) null
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Setting Up AuditTrail
Setting up AuditTrail is usually a task for the system administrator.

The first six steps are required to enable auditing of any Oracle Applications table. They
are explained in more detail in the Oracle Applications System Administrator’s Guide. The
final step is required only for tables in the HR application.

To set up AuditTrail:
1. Have your database administrator grant SELECT privileges on SYS.DBA_TABLES to

the APPLSYS account. Normally this step will already have been done as part of
your installation or upgrade.

Using a System Administrator responsibility:

2. In the System Profile Values window, set the AuditTrail:Activate profile option to
Yes at Site or Application level.

3. In the Audit Installations window, query the application(s) you want to audit, and
check the Audit Enabled box next to the Oracle User Name.

4. In the Audit Groups window, query the application and enter a name for the audit
group, then select the tables you want to audit (using the User Table name). For a
new audit group, select Enable Requested in the Group State field.

5. In the Audit Tables window, query each table you want to audit, and select which
columns in these tables you want to audit.

Note: You cannot audit LONG, RAW, or LONG RAW columns.

6. In the Submit Request window, run the AuditTrail Update Tables process. This
process:

• Creates database triggers on your audited tables

• Creates one shadow table for each audited table, to contain the audit information

• Builds special views on non-datetracked tables, which you can use to retrieve
your audit data for reporting

Using an HR Manager responsibility:

7. In the Submit Request window, run the AuditTrail Update Datetracked Tables
process. For each datetracked table, this process:

• Creates an index on the shadow table

• Creates the function tablename_TT and the procedure tablename_VP, which
extracts information from the shadow table when you run the predefined
audit report

Important: You must rerun the AuditTrail Update Tables process
and the AuditTrail Update Datetracked Tables process if you make
any changes in the Audit Groups or Audit Tables windows.
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Disabling AuditTrail

To disable AuditTrail:
1. You can disable the auditing of an audit group at any time by selecting a Disable

state in the Audit Groups window.

Tip: If you are planning high volume transactions on an audited
table, such as loading a batch of information from another
system, consider disabling auditing for the table’s audit group. This
will enable the batch loading to complete more quickly.

Before you restart auditing, you should archive your audit data, according to your
business needs, and purge the shadow tables. You purge the tables by setting the
audit group to Disable - Purge Table and running the Audit Trail Update Tables
report. To restart auditing, you set the audit group to Enable Requested and rerun
the Audit Trail Update Tables process and the Audit Trail Update Datetracked
Tables process.

Running the Predefined Audit Report
You can run an audit report using the system’s predefined structure, or you can design
your own audit report.

To run the predefined audit report:
1. Using an HR Manager responsibility, open the Submit Request window and select

Audit Report in the Name field.

2. Enter the Parameters field to open the Parameters window.

3. Select an audited table (that is, one in an audit group) using the Table name.

4. Select a value for the Initialization parameter:

• Yes means that the report removes any existing data related to your selected
table from the HR_AUDITS table and the HR_AUDIT_COLUMNS table. It
then populates these tables with the current values from your selected table
and reports on these.

• No means that the report runs on the existing data in the HR_AUDITS table and
the HR_AUDIT_COLUMNS table.

• Refresh means that the report removes existing data for all tables from the
HR_AUDITS table and the HR_AUDIT_COLUMNS table. It then populates
these tables with the current values for your selected table and reports on these.

5. If you only want to report on the changes made by one user, enter the user name.

6. Enter start and end dates to limit the time period for reporting audit information.

7. Choose the Submit button.

You can use the View Requests window to check the progress of the report.
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2
Desktop Int egration

Desktop Integration Overview
Web Applications Desktop Integrator (Web ADI) is a self-service Oracle
application, accessed using a browser. The Web ADI software is not installed on
individual client machines, as the processing takes place on the server rather than on
individual client PCs.

Web ADI generates Microsoft Excel or Word documents on your desktop, and
downloads the data you have selected from the application. You can modify the data in
the Microsoft Excel or Word documents, working either online or offline, and upload
the data using Web ADI.

How Web ADI works

Configurable layouts determine the appearance of the spreadsheet or word processing
document. System administrators can restrict the fields that users access in the
spreadsheet, and can create different layouts for different users. Experienced users can
also create their own layouts to include just the fields they need.
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Web ADI is used in HRMS forms, such as Person, Assignment, People and Assignment
folders, and Salary Approvals, in letter requests, in the Rapid Implementation
Workbench, for reports in the Compensation Workbench, and for configuring links in
Knowledge Integration.

See: Data Download and Upload using Web ADI, page 2-4

Alternatively, you can use the concurrent processing method to set up your standard
letters. With concurrent processing, you generate and review your letters without
interrupting other work you perform at your computer. You can control when a
concurrent process runs and schedule long-running processes to run at times when
the system is not busy.

There are two methods of using concurrent processing to set up your standard letters:

• Using word processors

• Using Oracle Reports

See: Concurrent Processing, page 2-31

Desktop Integration
You can download data from your Oracle HRMS application to spreadsheets or word
processing documents on your desktop using Web ADI.

Can you download data from a window in Oracle HRMS?
Yes. Oracle HRMS is supplied with certain windows already set up to enable you to
download data. In addition, your system administrator can configure the system so
that you can download from other windows in the Professional User Interface (Forms
interface).

Can you modify data downloaded from Oracle HRMS windows and upload the modified
data back to the application?

Yes, provided that the system has been configured to enable upload, and that you
have the appropriate upload access rights.

Can you upload data from legacy systems using Web ADI?
Yes. By incorporating a text file into the spreadsheet you create using Web ADI, and then
uploading the data to the database, you can upload data from legacy systems.

Does Web ADI check that information is not being overwritten when you upload?
Yes. Error checking is carried out by the Application Programmatic Interfaces (APIs) used
to upload the data. If errors are found, the data is not uploaded to the Oracle database.

Can you create standard letters using data from Oracle HRMS?
You can generate standard letters by downloading employee data into a template
letter to form a mail merge letter. You can also save the template letter in the Oracle
application database.
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Do you need a separate licence for Web ADI?
No. Web ADI is available when you purchase Oracle HRMS.

Can you reuse ADE information with Web ADI?
Much of the information required by Application Data Exchange (ADE) can be converted
for use with Web ADI. Views that you have created for use with ADE can be reused, and
ADE style information can be converted to a format suitable for use by Web ADI.

Do you need to install Web ADI on individual user PCs?
No. Unlike ADE, Web ADI does not require separate installation on client PCs.

What types of standard letter can you create?
Standard letters enable you to manage your enterprise’s recruitment or enrollment
activities more easily. Using Oracle Human Resources or Oracle Learning Management
(OLM), you can issue standard letters to applicants and students respectively, triggered
by changes in assignment or enrollment status. For example, you can set up a standard
enrollment confirmation letter that is triggered when a student’s enrollment status is
set to Placed, or you can set up a rejection letter that is triggered when an applicant’s
assignment status is set to Rejected.

Here are a few examples of letters you can set up to help you to manage recruitment
or enrollment activities:

Oracle Human Resources Oracle Learning Management

Acknowledgement letters (for all active
applications)

Acknowledgement letters (for all requested
enrollments)

Confirmation letters (for interviews) Confirmation letters (for placed enrollments,
including event joining instructions based on
the date, venue, and trainers)

Reports for interviewers and schedules Reports for trainers (listing the students to
attend an event)

Offer and Rejection letters (for applicants) Chase-up letters (for non-response or
non-payment)

Acknowledgement letters (for cancellations)

Certificates (of successful course completion)
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Data Download and Upload Using Web ADI

Data Download and Upload Using Web ADI - Overview
You can download data from your Oracle HRMS application to spreadsheets or word
processing documents on your desktop using Web ADI.

You can query the data in a window, download the queried data to your desktop, and
view the data in spreadsheet format or in a word processing document.

In some cases, you can manipulate the data you have downloaded, and upload your
changes back to Oracle HRMS. Validation of the data takes place by the Application
Programmatic Interfaces (APIs) used to upload the data, and any errors are flagged. If
errors occur, no data is uploaded to the database.

You can create a mail merge by downloading the data directly into a template letter.

You can create an empty spreadsheet and enter new data into it, or bring in the data
from a text file, then upload the data into Oracle HRMS. The data is validated using the
usual HRMS validation.

Standard Oracle security is maintained.

Methods of Running Web ADI
You can invoke Web ADI from an icon in an HRMS Professional User Interface window
(including OLM windows), or you can launch it directly from a Web ADI self-service
menu option.

You cannot invoke Web ADI from the People Management templates, the Absence
Detail window, or the self-service HRMS screens. In addition, you cannot invoke Web
ADI from the Assignment window when it is accessed by task flow from the Person
window. However, you can invoke Web ADI from the Assignment window accessed
directly from the Navigator.

Your access to Web ADI depends on the access rights set up for your responsibility.

Integrators
The functionality available with Web ADI depends on the information stored in an
"integrator". Each integrator contains all relevant information about a particular data
download, upload, or create process, such as whether you are downloading data from
an HRMS window, from a Web ADI self-service window, or from the Request Letter
window. It also specifies whether you can download one-way or whether you require
the ability to upload edited data again, whether the data is being downloaded into a mail
merge, and so on. The integrator details also indicate whether you can use it to create
new data or just update existing data.

When you create your spreadsheet or word processing document using Web ADI, you
select an appropriate integrator, and Web ADI handles the transfer and validation of
data accordingly.

Predefined Integrators

Oracle HRMS supplies a number of integrators that enable you to carry out a one-way
download of data from the following windows and folders, for reporting or analysis
purposes:
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• People window - "HR People Details" integrator

• People folder - "HR People Folder Detail" integrator

• Assignment window (accessed directly from the Navigator) - "HR Assignment
Detail" integrator

• Assignments folder - "HR Assignment Folder Detail" integrator

Another supplied integrator enables you to download data, edit the data, and upload it
again to the application, from the following folder:

• Salary Management folder - "HR Update Salary Proposals" integrator

In addition to the supplied integrators, your system administrator can configure Web
ADI to download data from other HRMS windows or directly from the application
database, by setting up new integrators as required. See: Configuration of Data
Download and Upload, page 2-10

Key Concepts
An understanding of the following terms may assist you in downloading and uploading
data between Oracle HRMS and your desktop using Web ADI.

API

Application Programmatic Interfaces, used to upload data to the Oracle Applications
database. APIs handle error checking and ensure that invalid data is not uploaded to
the database.

Content

When you create a spreadsheet or word processing document, the layout defines
the columns that appear in the document and the content identifies the data in the
document. Content is usually downloaded from the Oracle application database, so
that the spreadsheet contains the data you have queried from a window in Oracle
HRMS. You can also create a spreadsheet with no content, so that you can enter new
data using the spreadsheet and upload it to the application. Another method is to bring
in the content of the spreadsheet from a text file on your desktop. This enables you to
upload the data from the text file to the application, for example to upload legacy data or
information from third-party applications to Oracle HRMS.

Download

This is the process of transferring data from the Oracle HRMS application to your
desktop (the original data remains in the application database).

Integrator

An integrator defines all the information that you need to download or upload from a
particular window or database view or for a particular purpose (the type of integrator
determines the purpose for which you can use it). Your system administrator can set up
the appropriate integrators depending on whether you want to download for reporting
or mail merge purposes, or in order to manipulate the data and upload it again.
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Interface

A Web ADI term for the item that specifies the columns to be transferred from the Oracle
applications database to your desktop or vice versa. In HRMS, interfaces can be views
(for downloading data) or APIs (for uploading data). The integrator includes all the
columns that are available in the interface, whereas the layout specifies only those that
the user needs to see.

Layout

A layout indicates the columns to be displayed in a spreadsheet or Word document. You
can have more than one layout for the same integrator, for use in different situations, or
by different people. For example, you could have several different layouts for the HR
People Details integrator (which is available from the People window), one containing
just the First Name, Last Name, and Telephone Extension fields for use in printing out a
telephone list, another containing email addresses, and so on. If more than one layout
is available for an integrator, you can choose the one you want when you create a
document. If only one is available, it is automatically selected for you.

Mapping

If you are bringing in data from a text file to Oracle HRMS using a spreadsheet created in
Web ADI, you need to map the columns in the text file to the application’s tables and
columns. When Web ADI creates the spreadsheet, it ignores any columns from the text
file not included in the mapping.

Template Letter

This is a form letter or skeleton letter that acts as the basis for creating mail merge
letters. The template letter contains the standard text, and also contains field
codes, which are replaced by data from the application during the mail merge process.

Upload

This is the process of transferring the data from a spreadsheet on your desktop back
to the Oracle HRMS application, overwriting the existing data in the application
database. This process can take place only if Web ADI created the spreadsheet.

View

A view is an example of an interface that you can use to download data from the
application to a spreadsheet. The integrator definition includes the name of the
view. Views to access many windows are already available with Oracle HRMS. System
administrators can create additional views if necessary.

Viewer

A viewer is a desktop application, such as a spreadsheet or word processing tool, that
you use to view the data downloaded from Oracle HRMS.

Data Download Using Web ADI
You can download data from your Oracle HRMS application to a spreadsheet or word
processor on your desktop. You can then use the features of your spreadsheet or word
processing tool to manipulate data for analysis and reporting purposes.
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You can download from within a window in the HRMS Professional User Interface
(including OLM windows), or directly from a Web ADI self-service page.

You can save the spreadsheet that you have created and return to it later. The spreadsheet
includes all the data you have downloaded. You can refresh the data without creating a
new spreadsheet by carrying out a new download directly from the spreadsheet, without
recreating the spreadsheet.

See: Data Upload Using Web ADI, page 2-7 and Letter Generation Using Web ADI,
page 2-8

Downloading from an HRMS Window
This method enables you to use the query you enter in the window to specify the
records to download.

Downloading from a Self Service menu Function
This method enables you to apply values at runtime so that you can specify the records
to download.

Downloading an Empty Spreadsheet
You can download an empty spreadsheet from the ADI web page (that is, containing the
columns you want, but no data), and then use the spreadsheet to enter new data.

Downloading an Empty Spreadsheet and Incorporating Data from a Text File
You can download the structure of your spreadsheet using Web ADI, but instead of
downloading the content of the spreadsheet from the applications database, you can
incorporate a text file in the spreadsheet as you create it, and then upload the data from
the text file to the database. See: Data Upload Using Web ADI, page 2-7

Format of Text files
Text files must be in delimited format, separated by commas or other standard
characters. You can use text files that include or exclude headings in the first line.

Data Upload Using Web ADI
You can use Web ADI to upload data that you have previously downloaded to a
spreadsheet, or data that you have entered in an empty spreadsheet. You can do this
only if the spreadsheet was created using an upload integrator.

Features of Data Upload
You can only upload data using an integrator that has been created for this purpose
(for example, the HR Update Salary Proposals integrator available from the Salary
Management folder). You must specify at the time you download the data that you
intend to upload it again, by unchecking the Reporting check box. You must also
have access to a responsibility that gives you access rights to upload data as well as
download it.
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Data to be uploaded is validated before the upload occurs. You must ensure that you
enter values in all mandatory fields, so that validation is successful when the data is
uploaded to the application. If you do not, the data is not uploaded, and an error message
appears in the Messages column in the spreadsheet for the record with the invalid data.

For example, if you are using the HR Update Salary Proposals integrator, you must enter
values in the Proposed_salary and Change_date fields, as a minimum, for any row you
want to upload. If your organization has created its own integrators for uploading
data, your system administrator can tell you which fields you must enter.

When you change any field in the spreadsheet, the row is flagged for upload. By
default, only flagged rows are uploaded. You can change this setting so that all rows
are uploaded.

Letter Generation Using Web ADI
You can generate mail merge letters from Oracle HRMS using Web ADI.

Web ADI retrieves the data and downloads it directly into a template letter (which you
can also store in the Oracle applications database) to form the mail merge.

When you create a document for a mail merge, ensure that you select Word as the
viewer, and check the Reporting check box.

Your system administrator must set up integrators to enable the letter generation
to take place.

In addition, the layout associated with the letter generation process must have the same
name as the letter created in the Letter window in the Oracle HRMS application. This
associates a letter with an assignment status in Oracle HRMS or an enrollment status in
OLM, and links the letter to the layout.

Implementing Web ADI for use with Oracle HRMS
The following implementation steps are required to implement Web ADI for use with
Oracle HRMS.

See also the Oracle Web Applications Desktop Integrator for Oracle Applications Release 11i
Configuration Guide, Note 177073.1, available on MetaLink.

HR: Enable Web ADI Integration Profile Option
In the System Profile Values window, the HR: Enable Web ADI Integration profile option
default is Yes. The Web ADI pages open when you choose the Export Data icon on the
toolbar of an HRMS window.

To use Application Data Exchange (ADE) instead of Web ADI, change this profile option
to No at Site level. This change enables the Export Data icon to launch Application
Data Exchange (ADE) software.

Web ADI Menu Options
1. The supplied Web ADI responsibility and self-service menu give access to the

following menu options:

• Create Document
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• Define Layout

• Define Mapping

• Manage Document Links

Give users access to this responsibility, or attach this menu to their responsibility, if
they need to access Web ADI from the self-service menu (without going through one
of the HRMS application windows), or if they need to define layouts or mappings, or
create links between template letters and layouts.

See the Oracle Web Applications Desktop Integrator for Oracle Applications Release
11i Configuration Guide, Note 177073.1, available on MetaLink, for further details
about this menu.

2. A self-service menu "HRMS ADI Document Manager Menu", is supplied for use
with Web ADI. This contains the Document Management menu option and required
functions. Add this menu to the main menu attached to the responsibilities of any
users who need access to the Document Management features.

3. The supplied function "Web ADI Create Document" gives access to Web ADI from
any HRMS window.

Important: You must add this function to the main menu attached to
the responsibilities of any users who need access to Web ADI from
an HRMS application window.

4. The Create Document menu option on the Web ADI menu includes integrators for
all applications. An alternative self-service menu, "HRMS ADI Create Document
menu" is supplied, containing the menu option "HRMS Create Document". This
restricts the list of integrators to HRMS application integrators that are not launched
from a window (that is, where the FORM_NAME parameter for the integrator
is "GENERAL").

If you create your own "GENERAL" integrators, you need to change the parameters
of this function from:

• &bne:integrator=800:GENERAL%25

to:

• &bne:integrator=800:GENERAL%25,999:GENERAL%25

replacing 999 with your own Application ID.

5. If only one option is available in Web ADI, the page automatically defaults the
option. If all the options on a screen are defaulted, the page is skipped, so that the
end user does not have to fill them in. The user only sees the final ’Review’ page. To
remove the Review page that appears at the end of the Web ADI wizard, edit the
"HRMS Create Document" or "Web ADI Create Document" function, and change the
parameters of the function, by appending:

• &bne:noreview=true

6. To restrict users to carrying out download-only operations, edit the "HRMS Create
Document" or "Web ADI Create Document" function, and change the parameters of
the function, by appending:

• &bne:reporting=Y
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7. Integrators provided by HRMS for setup purposes may be grouped by creating a
function similar to the "HRMS Create Document" by changing the following:

• &bne:integrator=800:GENERAL%25

to

• &bne:intergator=800:HR_SETUP%25

This function may be added to menus for users with privileges to create and
edit integrators.

Configuration of Data Download and Upload Using Web ADI
In addition to the Web ADI integrators supplied with Oracle HRMS, you can create your
own integrators to allow download and upload from windows in Oracle HRMS or direct
from Web ADI, create merge letters, and upload data from text files.

Views for Web ADI
Depending on the information you want to download, you may find it necessary to
create new views for use with Web ADI. You can use existing views supplied with
HRMS, if a suitable view exists.

Note: To identify a view used by a window in Oracle HRMS, display a
record in the window, and choose Help > Diagnostics > Examine... from
the menu. In the Examine Field and Variable Values dialog box, select
SYSTEM in the Block list of values and LAST_QUERY in the Field list of
values. You can then scroll through the SQL query that appears in the
Value field to obtain the view name.

APIs for Web ADI
The seeded HR Update Salary Proposals integrator, available from the Salary
Management folder, uses the HR_UPLOAD_PROPOSAL_API.

For details of APIs you can use for uploading data, see: Publicly Callable Business
Process APIs in Oracle HRMS, page 3-165

Note: HRMS APIs use IDs in their parameters rather than user-friendly
data. Therefore, when you define Upload or Update Integrators, write
wrapper packages to convert or preprocess the data before calling
the APIs.

Integrators for Web ADI
To enable users to download, create merge letters, or upload newly created or updated
data, either from within an HRMS window or direct from Web ADI, you need to create
integrators of the appropriate types.

To create new integrators, you use the Create Document menu option in Web ADI to
create an empty spreadsheet containing all the columns you need to fill in to create an
integrator. Oracle supplies an integrator for this purpose: the "HR Integrator Setup"
integrator. You then enter the relevant data into the spreadsheet and upload it to the
database.
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You can apply a restriction to a standalone integrator using the "HR Create Standalone
Query" integrator, or you can update a runtime restriction using the "HR Maintain
Standalone Query" integrator.

You can disable Integrators using the HR Disable Integrator integrator.

Note: This integrator does not disable integrators created for the HRMS
Application which are pre delivered with the application. Therefore, if
you create your own integrator, you should specify your own custom
application name when creating the new integrator, so that you can
disable it if required.

So that your users can easily identify the integrator they need to use, use a standard
naming convention for the integrators. For example, names could begin with HR, include
the name of the window or a clear indication of the type of information they contain, and
indicate whether they are for download only, download and upload, or letter generation.

For information about defining standalone queries, see: Defining Standalone Integrator
Queries, page 2-18

For information about maintaining standalone queries, see: Maintaining Standalone
Queries, page 2-19

For information about disabling queries, see: Disabling Standalone Integrator Queries,
page 2-20

Controlling Access to Integrators
You must control access to integrators using form functions with menus. You can
optionally add further access control by responsibility.

Form Functions with Menus

For each custom integrator, you decide which form functions will control access, and
create the form function. You can create a unique form function for each integrator, or
you can group integrators by form function.

After you create the form functions, you add them to the Responsibility menus to give
your users access to their custom integrators.

Each predefined integrator is associated with a form function, as shown in the following
table:
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Predefined Integrator Form Function (Internal
Name)

Form Function (User Name)

HR Assignment Detail HR_ADI_CAG_ASG_DETAIL HR Assignment Detail
Integrator

HR Assignment Folder Detail HR_ADI_CAG_ASG_
FOLDER

HR Assignment Folder
Integrator

HR People Details HR_ADI_CAG_PEOPLE_
DETAILS

HR People Details Integrator

HR People Folder Detail HR_ADI_CAG_PEOPLE_
FOLDER

HR People Folder Detail
Integrator

HR Update Salary Proposals HR_ADI_CAG_UPD_SAL_
PROP

HR Update Salary Proposals
Integrator

HR Create Standalone Query HR_ADI_CAG_SETUP_
CREATE_QRY

HR Create Standalone Query
Integrator

HR Disable Integrator HR_ADI_CAG_SETUP_D
ISABLE

HR Disable Integrator
Integrator

HR Create Integrator
Responsibility Restrictions

HR_ADI_CAG_SETUP_
INTG_RESP

HR Create Integrator
Responsibility Restrictions
Integrator

HR Maintain Standalone
Query

HR_ADI_CAG_SETUP_MA
INTAIN_QRY

HR Maintain Standalone
Query Integrator

HR Maintain Integrator Form
Function Associations

HR_ADI_CAG_SETUP_MA
INT_FUNC

HR Maintain Integrator Form
Functions Integrator

HR Maintain Integrator
Responsibility Restrictions

HR_ADI_CAG_SETUP_MA
INT_RESP

HR Maintain Integrator
Responsibility Restrictions
Integrator

HR Integrator Setup HR_ADI_CAG_SETUP_SETU
P

HR Integrator Setup Integrator

You add the form function associated with the integrator to the users’ menus. Oracle
HRMS provide an example menu, HR_ADI_CAG_FORM_FUNCTIONS (internal name)
or HR ADI Seeded Integrator Form Functions (User Name), which references all of the
predefined integrators mentioned above. You can use this menu to grant access to all
your users, or you can copy this menu and modify it as required.

Responsibilities

You can optionally restrict integrators by responsibility using the "HR Create Integrator
Responsibility Restriction" integrator. If you create a restriction for an integrator, only
users who have access via the responsibility will be able to access the integrator. You
can link integrators to multiple responsibilities. The restriction applies only when you
launch Web ADI from the Professional User Interface (PUI) window.

You can update or remove the restriction using the "HR Maintain Integrator
Responsibility Restrictions" integrator.
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Note: Oracle recommends that you control access to integrators using
the form functions and menus instead of responsibility restrictions. Use
of form functions and menus provides a greater degree of control
over user access.

For information about restricting integrators by responsibility, see: Controlling Integrator
Access, page 2-20

Layouts for Web ADI
To use the integrator, you must set up at least one layout. If there is more than one
layout, users must choose one. Ensure that the layout contains all mandatory fields
and any other fields the user will need.

You should ensure that the name of the layout gives a clear indication of its purpose.

Additional Information
For information about setting up and configuring Web ADI, see also the Oracle Web
Applications Desktop Integrator for Oracle Applications Release 11i Configuration Guide, Note
177073.1, available on MetaLink.

Upgrade Information for Converting from ADE to Web ADI
This section provides information about upgrading to Web ADI for customers who are
currently using Application Data Exchange (ADE) to transfer information between
Oracle HRMS applications and desktop tools.

Comparison of Features in ADE and Web ADI
For details of the features available in Web ADI, see: Data Download and Upload Using
Web ADI: Overview, page 2-4

The method of operation of Web ADI is different from that of ADE, and terms used in
ADE do not always have an exact equivalent. The following table lists terms used in
ADE and the equivalent functionality in Web ADI.
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Table of ADE and Web ADI Terminology

ADE Web ADI

Style Integrator

Style columns (columns set as displayed) Layout

View name Content

Style columns (queried from view) Content columns

API name Interface

Style columns (making up API parameters) Interface columns

Style columns (that are view columns and API
parameters)

Mapping

Style - Form Name HR Integrator Setup - FORM_NAME
parameter

Style - Letter Name Layout Name (for Letter Request integrators)

Note: Customers converting from older versions of Oracle HRMS and
ADE, in which ADE included hierarchy diagrammers, should note that
the hierarchy diagrammers functionality is now available from standard
windows in the HRMS Professional User Interface.

Additional Features in Web ADI

The following additional features are available in Web ADI:

• In addition to the ability to upload data that you have previously downloaded from
a spreadsheet to the Oracle application database, Web ADI enables you to upload
new data from legacy systems.

• Web ADI enables you to store your mail merge template letters in the Oracle
application database

Prerequisites for Upgrading from ADE to Web ADI
The following information may assist you when upgrading from ADE to Web ADI.

Views

When creating new integrators for use with Web ADI, you may need to create a suitable
view. If you have views that you have created for use with ADE, you can reuse these
views.

Styles

You can convert existing styles in ADE to Integrators in Web ADI. See: Converting ADE
styles to Web ADI Integrators, page 2-28
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The conversion process uses a new concurrent process called Upgrade from ADE to Web
ADI. This is available in the Global SHRMS Reports & Processes request group, attached
to the Global Super HRMS Manager responsibility.

Profile Options

HR: Data Exchange directory

Information on ADE styles is stored in an ADE.INI file located either on individual user
desktops or on a shared drive. The Upgrade from ADE to Web ADI concurrent process
uses this file to convert ADE styles to Web ADI integrators.

To use this concurrent process, you need to copy the ADE.INI file to a directory accessible
to the Oracle database. The path to this directory must be within the UTL_FILE_DIR
setting for your database, and must be specified in the HR: Data Exchange directory
profile option.

HR: Enable Web ADI Integration

A new profile option, HR: Enable Web ADI Integration controls the use of Web ADI. This
profile option’s default setting is Yes at site level, indicating that the Data Export button
on the toolbar links to Web ADI.

To use ADE instead of Web ADI, set this profile option to No at the required level. When
a user chooses the Data Export button on the toolbar, the download process uses ADE.

Downloading Data to your Desktop using Web ADI
You can download data from Oracle HRMS to a spreadsheet or word processor using
Web ADI, either from within a window in the HRMS application, or directly from a
Web ADI page without accessing HRMS.

See: Data Download Using Web ADI, page 2-6

To download data to a document from an HRMS window:
1. Navigate to the window from which you want to download the data, for

example, the People window.

2. Enter a query to return the records you want to download.

3. Choose the Export Data icon on the toolbar. The Settings page of the Web ADI
wizard appears.

Caution: When moving between Web ADI pages, do not use your
browser’s Back or Forward buttons, as this causes information to
be lost; instead, use the Back, Next and Cancel buttons displayed
on the Web ADI page.

4. Select the viewer you want to use to display the document. If you intend to edit
the data and upload it again, select a spreadsheet viewer. If several different
versions of a viewer are available, your system administrator can tell you which
version is appropriate.

5. Select the Reporting check box if you are downloading data for reporting or letter
generation purposes. If you want to edit the data in the spreadsheet and upload it to
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the application again, leave this box blank. You cannot upload data if the Reporting
check box is selected when you download the data.

Note: You can only upload data using an integrator that has been
set up to allow upload. Check with your system administrator to
ensure that an appropriate integrator is available.

6. If more than one integrator is available for the HRMS window from which you ran
the query, the Integrator page appears. Select an integrator.

7. If more than one layout is available, the Layout page appears. Select the appropriate
layout.

8. All other information is defaulted, and a Review page displays technical details of
the document that will be created. Choose the Create Document button to continue.

9. A spreadsheet or word processing document is created and displayed using the
viewer you selected, and the data from the records you queried is added to the
spreadsheet. Confirmation messages appear as the document is created.

The data downloaded to the document depends on the query you entered in the
window and the columns in your layout.

Note: You may want to save the spreadsheet on your desktop at this
stage, as otherwise the spreadsheet and the data it contains will be
lost from your desktop when you close the spreadsheet (the data
remains in the Oracle application).

To use integrators from the Web ADI self-service menu:
You can download application data to an existing spreadsheet, or download a
spreadsheet layout.

Caution: To move within the application, use the application’s
Back, Next, and Cancel buttons only.

1. Select Create Document from the Web ADI self-service menu. The Settings page of
the Web ADI wizard appears.

2. Select a viewer to display the document. If you want to upload data, then select a
spreadsheet viewer. If several different versions of a viewer are available, ask your
system administrator which version to use.

3. If you want to upload data, deselect the Reporting check box.

Note: You can only upload data using an integrator that allows
uploads. Check with your system administrator to ensure that an
appropriate integrator is available.

4. In the Integrator page, select an integrator from the list.

5. In the Layout page, select the appropriate layout.

6. In the Content page, select None to create a spreadsheet layout only, if you are not
downloading data from the database to the spreadsheet. Select the default content
to download data from the database.
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7. In the Mapping page, to download data from a text file, select the location of the
source text file and the delimiter type, and indicate the row at which to start
transferring data. If your text file has header rows, start from row 2; otherwise, use
row 1.

The Mapping page also shows you the runtime restriction applicable for your
integrator. You can enter appropriate values here to restrict your query.

8. In the Review page, review the full details of the new document. Choose the Back
button to change any of the information, or choose the Create Document button
to continue.

9. The new document displays in the selected viewer you selected. Confirmation
messages appear during this process.

10. Save the spreadsheet on your desktop.

See: Uploading Data Using Web ADI, page 2-17

Uploading Data using Web ADI
You can upload data to the Oracle applications database using a spreadsheet created in
Web ADI. See: Data Upload Using Web ADI, page 2-7

To upload data from a spreadsheet using Web ADI:
1. If you have saved the spreadsheet on your local PC, locate and open the spreadsheet

in Excel.

2. In the Upl column of the spreadsheet, each row in which you have changed data in
any field is flagged for upload. As you change data in a field, the row is flagged
for upload.

3. Select the Oracle menu on the Excel toolbar, and choose Upload.

4. If you are not already logged in to Oracle applications, a login page appears. Enter
your user name and password, then choose the Login button.

5. In the Set Responsibility page, choose your responsibility, and then choose Select.

6. In the Upload Parameters page, choose the Parameters button. If you want to upload
flagged rows only, choose the Flagged Rows option button. To upload all rows (for
example, if uploading from a text file), choose the All Rows option button.

7. Choose the Proceed to Upload button, then choose the Upload button in the page
that appears next. The upload takes place, and a series of upload messages is
displayed, indicating the success or failure of the upload.

8. If the upload fails, return to the spreadsheet and correct any errors, then retry the
upload. Further details of errors are available in the Messages column at the end of
each row of the spreadsheet. If the upload is successful, the data is uploaded to the
database. Confirmation messages indicate the success of the upload.

Note: Web ADI uploads all rows to the database if the data is
error-free. If any errors occur, no rows are uploaded.
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Uploading Data from Legacy Systems using Web ADI
Follow these steps to upload legacy data to your Oracle HRMS applications database
using Web ADI.

To upload data from legacy systems using Web ADI:
System Administrator steps

1. Set up an integrator that enables both download and upload. See: Creating
Integrators in Web ADI, page 2-25

2. Define one or more layouts for the integrator. See: Defining Layouts in Web ADI,
page 2-28. Ensure that the layout contains all the mandatory fields you will need to
create a valid record.

System Administrator or end-user steps

3. Ensure that the data to be transferred to the spreadsheet is in a text file in the
appropriate format (see: Format of Text Files, page 2-7 for further details of file
formats). Place the file in any directory you can access directly from your PC.

4. Define mappings between the columns in your text file and columns in the
database. See: Defining Mappings in Web ADI, page 2-22

End-user steps

5. Download the empty spreadsheet. See: To create an empty spreadsheet using
Web ADI, page 2-16

6. Check that the data has transferred correctly to the spreadsheet.

7. Upload the spreadsheet to the database, ensuring that you select the All Rows option
button in the Parameters page. See: Uploading Data Using Web ADI, page 2-17

Defining Standalone Integrator Queries
To define a new query, you must use an existing standalone integrator.

To define a new query:
1. Select Create Document from the Web ADI menu.

2. Select a spreadsheet viewer. Leave the reporting box unchecked to download data.

3. Select HR Create Standalone Query integrator.

4. Select the default options for layout and content.

5. Specify the application short name that you used, when you created the standalone
integrator, in the mapping window.

6. Specify the integrator username, if required.

7. Review the data entered in the review window, and select the Create Document
button.

8. Specify the query restriction to use for your integrator in the SQL WHERE clause
column.

Enter the SQL WHERE clause in the following format:
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WHERE COL_NAME
LIKE $PARAM$.app:COL_NAME

col_name = any column in the view used by the integrator

app = application shortname

You can use any SQL conditional operator in the SQL WHERE clause. For example:

WHERE first_name
LIKE $PARAM$.per:first_name

Each instance of $PARAM$ is a bind variable, and you can use a maximum of 5
within a single WHERE clause.

9. Specify the name for each bind variable in the application parameter name
column. For example: per:first_name.

10. Specify the type for each bind variable in the appropriate parameter type
columns. For example: Varchar2. You can use the list of values to display the
available options.

11. Specify the prompts for each bind variable. These prompts appear when you use the
integrator (for example: first_name LIKE).

12. Upload your spreadsheet data to the database. Your integrator is now ready to use.

Using your integrator:
1. Select Create Document from the Web ADI menu.

2. Select a spreadsheet viewer. Leave the Reporting check box unselected to download
data.

3. Select the standalone integrator you created earlier.

4. Select the default options for layout and content.

5. Enter values for each prompt for every bind variable that you defined in the
mapping window. You can also change the session date, if required, to ensure that
you obtain the latest data for your query.

6. Review the data entered in the review window, and select the Create Document
button.

7. View your results in the displayed spreadsheet.

Maintaining Standalone Integrator Queries
When you have finished defining a standalone query you can use the HR Maintain
Standalone Query integrator to update the query.

Using the Maintain Standalone Query integrator:
1. Select Create Document from the Web ADI menu.

2. Select a spreadsheet viewer. Leave the Reporting check box unselected to download
data.

3. Select HR Maintain Standalone Query Integrator.

4. Select the default options for layout and content.
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5. Enter the application short name, and optionally enter the integrator username.

6. Review the data entered in the review window, and select the Create Document
button.

7. Modify the details in the displayed spreadsheet. Upload your changes.

Disabling Standalone Integrator Queries
You can use the HR Disable Standalone integrator to remove access to an integrator.

1. Select Create Document from the Web ADI menu.

2. Select a spreadsheet viewer. Leave the Reporting check box unselected to download
data.

3. Select HR Disable Integrator integrator.

4. Select the default options for layout and content.

5. Enter the application short name, and optionally enter the integrator username.

6. Review the data entered in the review window, and select the Create Document
button.

7. Select the integrator from the list displayed, and change the value in the Disable
column to Yes.

8. Upload your changes.

Controlling Integrator Access
You now control access to integrators using form functions and menus. Before associating
the form functions with integrators you need to define your form functions and menus.

Note: When you define your form function select Subfunction in the
Type field.

Associating Form Functions with Integrators:
1. Select Create Document from the Web ADI menu.

2. Select a spreadsheet viewer. Leave the Reporting check box unselected to download
data for updating.

3. Select HR Maintain Integrator Form Functions Integrator.

4. Enter the Application Short Name (for example, your custom application
name). Optionally, enter the integrator name.

5. The displayed spreadsheet shows your selected custom integrators, and has a
column for associating form functions. Enter the form function required for
controlling access to the integrator.

Note: You can add additional form functions to the same integrator
using the comma as a delimiter.

6. Upload your changes.
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Defining responsibility restrictions:
Note: Oracle recommends that you control access to integrators using
the form functions and menus instead of responsibility restrictions. Use
of form functions and menus provides a greater degree of control
over user access.

1. Select Create Document from the Web ADI menu.

2. Select a spreadsheet viewer. Leave the Reporting check box unselected to download
data.

3. Select HR Create Integrator Responsibility Restrictions Integrator.

4. Select the default options for layout and content.

5. Review the data entered in the review window, and select the Create Document
button.

6. Select Integrator Application Shortname from the list of values.

7. Select the Integrator User Name from the list of values.

8. Select your Responsibility Application Shortname from the list of values.

9. Select the responsibility name from the list of values.

Note: The responsibility you select must be applicable to the
responsibility/application short name.

10. Upload your changes.

Maintaining Responsibility Restrictions:
You can update or remove any restrictions you created for your integrators using the HR
Maintain Integrator Responsibility Restrictions integrator.

1. Select Create Document from the Web ADI menu.

2. Select a spreadsheet viewer. Leave the Reporting check box unselected to download
data.

3. Select HR Maintain Integrator Responsibility Restrictions Integrator.

4. Select the default options for layout and content.

5. Enter the Application Shortname from the list of values, and optionally enter the
integrator username.

6. Review the data entered in the review window, and select the Create Document
button.

7. Update the Responsibility/Application Short Name and Responsibility Name
columns in your spreadsheet. You can remove the values in these two columns to
remove any restrictions.

8. Upload your changes.
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Defining Mappings in Web ADI
You need to define mappings if you want to transfer data from a text file to a spreadsheet
generated by Web ADI in order to upload it to the Oracle application database.

Define Mappings:
1. Choose Define Mapping from the Web ADI menu.

2. Select the integrator for which you want to create mappings.

3. Choose the Define Mappings button.

4. Enter a unique name for the mapping. Ensure that it clearly indicates the purpose of
the mapping. For example, include the name of the text file and the API.

5. Enter a unique key. The key can contain only uppercase English
characters, numerals, or the underscore character (_). The Web ADI application
uses this key to identify the mapping.

6. If you are mapping from a text file, enter the number of columns you want to
map. This does not have to be the same as the number of columns in the text file or
the API. However, only those columns mapped are transferred from the text file.

7. In the Define Mapping page, select a column from the text file in the source column
and a column from the API in the target column that you want to map it to.

Note: The columns you use to map the text file are not read directly
from the text file, but are simply numbered columns from 1 to the
number you specified in Step 6. To create the mapping, look at the
text file and enter the number of the column you want to map to
the API column.

8. When you have finished mapping, choose Apply.

Creating Mail Merge Letters using Web ADI
Follow these steps to create mail merge letters by downloading data from the Request
Letters window using Web ADI.

To create mail merge letters:
System Administrator steps

1. If necessary, create a new view to retrieve data for the standard letter.

Note: Any views you use for letter requests must join to the
PER_LETTER_REQUEST_LINES table, and must include the
column LETTER_REQUEST_ID. For example, the following view
returns a person’s first and last names following a letter request:
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create or replace view hrv_people_letters as
select

letter_request_id,
last_name,
first_name

from
per_letter_request_lines plrl,
per_people_f pp

where
pp.person_id = plrl.person_id
/

2. Create an integrator. Ensure that you create the integrator with a METADATA_TYPE
of DOWNLOAD, and enter LETTER in the FORM_NAME column. See: Creating
an Integrator in Web ADI, page 2-25

System Administrator or end-user steps

3. Define an integrator layout that includes all the columns you may want to include as
fields in the standard letter. See: Defining a Layout in Web ADI, page 2-28

4. In the Letter window in Oracle HRMS, define a letter by entering a name and
selecting assignment or enrollment statuses to associate with the letter.

See: To define a Standard Letter type, page 2-45

Important: The name you enter for the letter in this window must be
the same as the name of the layout you created in Step 3.

You must select a concurrent program before you can save the letter type in this
window, but you can select any concurrent program as this information is not
used by Web ADI.

5. In the Request Letter window in Oracle HRMS, select the letter name and define a
letter request, then save your work.

See: Requesting Letters, page 2-46

6. To create a data source for the creation of the template letter, in the Request
Letter window, choose the Export Data icon on the toolbar, then download the
data, selecting Word as the viewer. See: To download data to a document from
an HRMS window, page 2-15

7. Save the Word document to a temporary directory.

8. Create the template letter in Word using the file you saved in Step 7 as your data
source, so that you can select any required fields to include in the letter. Save the
template letter to a temporary directory.

9. Upload the template Word document to the database. See: Managing Template
Letters Using Web ADI, page 2-24

10. Use the Manage Layout Document Links page to create a link between the integrator
and layout and the template letter. See: Creating Links between Template Letters
and Layouts, page 2-25

11. Delete the temporary files you created in Steps 7 and 8 when you have uploaded
the template to the database.
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End-user steps

12. To create the Merge letter, in the Request Letter window, select a letter name, choose
the Export Data icon on the toolbar, and download the data, selecting Word as the
viewer. This time, as the template linked to the integrator and layout is available
in the database, the data automatically creates a merge letter. See: To download
data to a document from an HRMS window, page 2-15

13. Save the mail merge letter to your local PC if required.

Managing Template Letters Using Web ADI
You can upload template letters to the Oracle applications database, making them
available for use by anyone creating a mail merge letter. You can also overwrite an
existing template letter with an updated version, and delete unused letters from the
database.

To Upload Template Letters:
1. Select Document Management from the Web ADI menu. The Document

Management page appears.

2. Choose the Upload New Document button. The Upload New Document page
appears.

3. Select the template letter file from the temporary directory where you saved it
on your PC (see Creating Mail Merge Letters, page 2-22), and select a document
category to identify the type of letter (for example, whether it is a recruitment
letter or an offer letter).

Note: To add document categories, use the Application Utilities
Lookups window to edit the "HR ADI Document Type" extensible
lookup type. See: Adding Lookup Types and Values, page 3-146

4. Choose Apply to upload the document.

To Overwrite Template Letters:
1. Select Document Management from the Web ADI menu. The Document

Management page appears.

2. Choose the Overwrite icon next to the name of the letter you want to update.

3. In the Overwrite Existing Document page, select the new version of the template
letter file from the temporary directory where you saved it on your PC, then choose
the Apply button. The new document is uploaded to the database, replacing the
old one.

To Delete Template Letters:
1. Select Document Management from the Web ADI menu. The Document

Management page appears.

2. Choose the Delete icon next to the name of the letter you want to delete.

The document is deleted from the database.

Note: You cannot delete documents if they are in use by the Oracle
HRMS application. If a template letter is linked to a layout, you
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must first unlink the document from the layout (see: Creating Links
Between Template Letters and Layouts, page 2-25).

Creating Links between Template Letters and Layouts
You can create links between template letters in the Oracle HRMS database and the
integrator and layout that you want to use to generate mail merges using the template.

To create links between template letters and layouts:
1. Select Manage Document Links from the Web ADI menu. The Web ADI Mail

Merge page appears.

2. Select the integrator for the mail merge and choose Go.

3. A list of layouts for the integrator appears. Choose the Link icon next to the
layout you want to link to your template letter. A list of documents that have
been uploaded to the database is displayed (you can restrict the list of documents
by using the Search feature).

4. Select the template letter you want to link to the layout, then choose the Select
button. The template letter is associated with the document.

To remove links between template letters and layouts:
1. Select Manage Document Links from the Web ADI menu. The Web ADI Mail

Merge page appears.

2. Select the integrator for the mail merge and choose Go.

3. A list of layouts for the integrator appears. Choose the Unlink icon next to the
template letter you want to unlink from the layout. The link between the layout and
the template letter is removed.

Configuring Web ADI
You can configure Web ADI to use your own integrators for downloading and uploading
data between Oracle HRMS and spreadsheets or word processors.

To configure Web ADI:
System Administrator steps

1. Create new views if necessary.

2. Set up an integrator of the type required. See: Creating an Integrator in Web
ADI, page 2-25

3. Define one or more layouts for the integrator. See: Defining a Layout in Web
ADI, page 2-28

Creating Integrators in Web ADI
Creating integrators is a system administration step required to enable download or
upload of data from and to windows for which no seeded integrator exists.

Web ADI has two types of integrators:

• Application Integrators
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• Standalone Integrators

An Application Integrator links to a specific form. You typically use the form to
download HRMS data, using some form restriction, modify the data, and then upload
the data.

You use standalone integrators directly from the self-service menu function. These
integrators allow you to create new data or download and update existing data. You
can set up a query restriction to use at runtime. For Standalone Integrators the form
name is GENERAL.

For a list of predefined integrators, see: Predefined Integrators, page 2-4

To create an integrator:
1. Select HR Create Document from the menu. The Settings page of the Web ADI

wizard appears.

Caution: When moving between Web ADI pages, do not use your
browser’s Back or Forward buttons, as this causes information to
be lost; instead, use the Back, Next and Cancel buttons displayed
on the Web ADI page.

2. In the Settings page, select a spreadsheet viewer in the Viewer field.

3. Deselect the Reporting check box, as this integrator is used to upload data to the
database.

4. In the Integrator page, select the seeded integrator "HR Integrator Setup".

5. In the Layout page, select the default layout "HR Integrator Setup".

6. In the Content page, select None.

7. In the Review page, you can see full details of the document that will be
created. Choose the Back button if you want to change any of the information, or
choose the Create Document button to continue.

8. A spreadsheet document is created, containing all the fields you need to enter to
create your own integrator.

Download-only Integrators
If you are creating download-only integrators, including letter generation
integrators, enter details in the following columns:

• METADATA_TYPE - select DOWNLOAD from the list of values.

• APPLICATION_SHORT_NAME - select the Application Short Name of
your custom application from the list of values. The name appears from the
FND_APPLICATION table.

• INTEGRATOR_USER_NAME - the name that appears when the end user selects
the integrator in the Web ADI Create Document pages.

• VIEW_NAME - Web ADI uses a view to determine the tables and columns to
download. Enter the name of the view you want to use to base the download on.

• FORM_NAME - the name of the window from which you want the integrator
to be available to the user. Select GENERAL from the list of values, or select
LETTER for a letter generation integrator.
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If you are creating download-only and letter generation integrators, leave the
remaining columns blank.

Download/Upload and Create Integrators
If you are creating integrators that allow both download and upload, or integrators
that allow the creation of new data, enter details in the following columns:

• METADATA_TYPE - enter CREATE (to allow creation of new data) or UPDATE
(to allow update of existing data)

• APPLICATION_SHORT_NAME - enter the Application Short Name of your
custom application. The name appears from the FND_APPLICATION table.

• INTEGRATOR_USER_NAME - this is the name that appears when the end
user selects the integrator in the Web ADI Create Document pages. Enter a
user-friendly name.

• VIEW_NAME - Enter the name of the view you want to use to base the download
on. If creating an empty spreadsheet for upload, leave this column blank.

• FORM_NAME - Enter the name of the window from which you want the
integrator to be available to the user. To make the integrator available directly
from the Web ADI menu, enter GENERAL in this field.

• API_PACKAGE_NAME. For upload integrators, whether CREATE or
UPDATE, you must supply the name of the API that handles the upload of data.

• API_PROCEDURE_NAME. Specify the name of the API procedure to use
to upload the data.

• INTERFACE_USER_NAME. This is a name that will appear to end users in
any messages or prompts dealing with the interface (view or API). Enter a
user-friendly name.

• INTERFACE_PARAMETER_LIST_NAME. This is a name that will appear
to end users in any messages or prompts dealing with the interface (API)
parameters. Enter a user-friendly name.

• API_TYPE. - Select PROCEDURE or FUNCTION from the available list of
values, depending on the type of API you are using.

• API_RETURN_TYPE - For APIs of type FUNCTION, select the datatype of the
value returned by the function from the available list of values, for example;
VARCHAR2.

To upload the integrator:
Follow the steps for uploading a spreadsheet. See: Uploading Data using Web ADI,
page 2-17

Controlling Access to the Integrator:
You must associate at least one form function with the integrator for granting user
access. See: Controlling Integrator Access, page 2-20

Note: Your System Administrator must grant access for each new
integrator to the Web ADI responsibility. Without this, you cannot
create layouts for the integrators.

Desktop Integration 2-27



Defining Layouts in Web ADI
Each integrator must have at least one layout specifying the columns to appear in
the spreadsheet.

To define a layout:
1. Choose Define Layout from the Web ADI menu. The Layout page appears.

2. Select the integrator for which you want to define the layout, and choose Go.

3. If the integrator already contains layouts, these are displayed. Choose the Define
Layout button to define a new layout.

System Administrators should always create at least one default layout for an
integrator. End users can optionally create their own layouts to restrict the fields
displayed to those they are concerned with.

4. In the Define Layout page, enter a unique name for the layout. This appears
whenever the user is required to select the layout, so should clearly indicate the
purpose of the layout.

Note: When you create a layout for use in running mail merges, the
layout name must exactly match the Letter Name in the Letter
window of the HRMS application.

5. Enter a unique key. The key is used internally by the system to identify the mapping.

6. The Field List defaults to the complete list of columns available in the view or
API. Choose Continue. In the next page, you select a subset of these fields to include
in your layout.

Fields for a Letter Generation Layout
• Choose Select All, so that the user can choose from all fields when entering field

codes and creating their template letter.

Fields for a Download Layout
• Choose the Select check box next to any fields you want to appear in the

spreadsheet or word processing document.

Fields for a Download/Upload Layout
• Some mandatory fields are preselected. These are required to ensure that all data

necessary to create a valid record is available when the data is uploaded. Select
any optional fields you want to include in the spreadsheet. If any fields
always contain the same values (for example, business group ID) you can
select these as Header fields, and they appear in the header of the generated
spreadsheet. Header values apply to all rows in the spreadsheet.

To save the layout:
1. Choose Apply to save the layout.

Converting ADE Styles to Web ADI Integrators
Follow these steps to convert your ADE styles to Web ADI integrators.
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To convert ADE styles to Web ADI integrators:
1. Check that your HR: Data Exchange Directory profile option is set to point to a

directory accessible from your Oracle applications database.

2. Using the Global Super HRMS Manager responsibility, navigate to the Submit
Request window, and select the Upgrade from ADE to Web ADI concurrent process.

3. In the Parameters dialog box, enter the name of your ADE.INI file in the ADE ini file
name field. This file must be located in the directory referred to in the HR: Data
Exchange Directory profile option.

4. Submit the request.

Note: The request may complete with warning messages, because
information that is required by Web ADI is not available in
ADE. This is as expected, and can be corrected in Step 8.

5. Locate the output file from the concurrent process, which is placed in
the same directory as the ADE.INI file. The output file has the name
UPGDDMMYYHHMISS.CSV (where DDMMYYHHMISS represents the date and
time the file was created).

6. Copy the output file to a local directory or shared network drive that you can
access from your desktop.

You can now create integrators using this file as the content.

7. Use the Create Document menu to create an integrator spreadsheet containing
all required columns (see: Creating Integrators, page 2-25), but when selecting
the content for the spreadsheet, select Text File. In the Mapping page, select the
UPGDDMMYYHHMISS.CSV file, and enter 1 in the Start Importing at Line Number
field.

The process creates a spreadsheet containing the columns required to create an
integrator, and transfers each ADE style from the text file into a separate row in
the spreadsheet.

8. Missing information is shown in angle brackets in the appropriate column, for
example, <<VIEWNAME>>. You must supply all missing values before you can
upload the integrators.

The following columns may have information missing:

• VIEW_NAME. This information may be missing because some styles in ADE
were defined without views, whereas Web ADI requires a view. Enter the name
of the view to use to download the data.

• APPLICATION SHORT NAME. Web ADI requires the short name of your
custom application. Enter the application short name in each row.

9. When you have inserted all the missing information for each row, you can upload
the spreadsheet, selecting All Rows in the Parameters page. See: Uploading Data
using Web ADI, page 2-17. Each ADE style is converted to an integrator with
the same name as the style.

10. Set up a layout for each style. See: Defining Layouts, page 2-28. For letter generation
integrators, ensure that the layout name you use is the same as that of the letter
name in the HRMS application.
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Additional Steps for Letter Generation Integrators:
1. Upload your existing template letters to the Oracle applications

database. See: Managing Template Letters, page 2-24

2. Link the layout to a template document. See: Creating Links between Template
Letters and Layouts, page 2-25
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Letter Generation

Letter Generation Overview
There are three different methods provided to create standard letters:

• Online Using Web Applications Desktop Integrator (Web ADI), page 2-8

• Concurrent processing using Word Processors, page 2-31

• Concurrent processing using Oracle Reports, page 2-31

Which Method Should You Use?
Use the online method (Web ADI), if you want to generate and review your letters
immediately.

Web ADI enables you to generate standard letters and reports by retrieving data and
exporting it to a data file that is merged with a standard word processed document. The
word processed document includes all the merge fields required to merge the data and
the standard text for the letter. Web ADI is fully compatible with Microsoft Word 6.

You can use Web ADI to generate standard letters for recruitment or enrollment by
performing a mail merge from the Request Letter window in your application.

Alternatively, you can use the concurrent processing method to set up your standard
letters. With concurrent processing, you generate and review your letters without
interrupting other work you perform at your computer. You can control when a
concurrent process runs and schedule long-running processes to run at times when the
system is lightly loaded. Another advantage of using concurrent processing is that you
do not need to have Windows 95 or 98, Excel or Lotus 123 installed.

Concurrent Processing
There are two methods of using concurrent processing to set up your standard letters:

• Using word processors

• Using Oracle Reports

Using Word Processors
You can use any word processor to produce standard letters from Oracle HRMS. If you
use a word processor, you can submit a concurrent request in the Letter Request window
to generate the mail merge file. When the concurrent request is complete, you can use
your word processor’s mail merge facilities to create the merged letters.

To create standard letters using a word processor, you need to extract the data you
want to include in the letters from the Oracle HRMS database. To do this, create a
program, such as a SQL*Plus script, to extract the data, which is then stored in a data
file. You also write skeleton standard letters using your word processor.

Note: Oracle HRMS supplies SQL*Plus script templates for use with
MultiMate, WordPerfect and Microsoft Word. You can copy the
SQL*Plus script templates and modify them to create the standard
letters you require.
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Each time you run your SQL*Plus script, it extracts data to the data file. You then use
the mail merge features of your word processor to merge this data with the skeleton
standard letters you previously prepared. This merging process creates the actual letters
that you send out to students and applicants.

An overview of creating standard letters using a word processor is shown in the
following figure.

Using a Word Processor

If you want to set up standard letters using the concurrent processing method with
MultiMate, WordPerfect Microsoft Word, see: Method 1 - Concurrent Processing, page 2-.

If you use Microsoft Word as your word processor, not only can you use the concurrent
processing method to produce your standard letters, but you can also generate letters
online using Oracle Web Applications Desktop Integrator (Web ADI)

See: Letter Generation Using Web ADI page , page 2-8

Using Oracle Reports
As an alternative to using a word processor to produce standard letters, you can use the
Standard Letter and Label features of Oracle Reports. Use this method if you do not
want to use word processors to print your letters (or if you do not have word processors).
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See: Linking the Report with a Letter, page 2-45

Example Files

PERWPOUK Template
The template SQL*Plus script for mail merge letters for Microsoft Word is
PERWPOUK.sql. See: Writing a SQL*Plus Script for Microsoft Word, page 2-42

The following section defines the required SQL*Plus environment settings. You should
produce this section exactly as you see it when you define your mail merge file.

WHENEVER SQLERROR EXIT FAILURE ROLLBACK
REM Define the MS Word mail merge record separator
DEFINE ch="’%’"
REM Define the column width for returning query results
COLUMN L1 FORMAT A2000
SET PAUSE OFF
SET FEEDBACK OFF
SET RECSEP OFF
SET HEADING OFF
SET VERIFY OFF
SET TERMOUT OFF
SET PAGESIZE 0

The following section creates a row in the Application Object Library table (AOL)
FND_SESSIONS. This enables the datetrack security views to be accessed for the
session.The &2 argument contains the current SQL*Forms session date.You should
produce this section exactly as you see it when you define your mail merge file.

REM Insert session row
insert into fnd_sessions(session_id ,effective_date)
select userenv(’SESSIONID’),

to_date(’&2’,’DD-MON-YYYY’)
from sys.dual
/

The following section has two functions:

1. To set the mail merge header linesize. This is dependent on the character length
of all the mail merge items you want to use. In the example, the header linesize
equates approximately to 220 characters.

2. To enable the spooling of the SQL results. You must remove the REM keyword
from the line that spools output to a file for the Microsoft Mailmerge. If you use
concurrent processing to generate the data source file, Concurrent Manager creates
the output file.

REM Set length of the header
SET LINESIZE 220
REM Create the mail merge ’header’ record for MS Word
REM Note: SPOOL command commented out for concurrent manage r.
REM PC based solution required the SPOOL command.
REM spool perwpouk.txt

The following section defines the mail merge header information. These are the mail
merge fields you integrate with your word processed letter. Each mail merge field is
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delimited by the pre-defined &ch character. Ensure that the field size does not exceed 40
characters and that the field name does not include white spaces. Do not forget that
the length in characters of this selected row from sys.dual is the LINESIZE value you
specified above.

select ’address_line1’ ||&ch||
’address_line2’ ||&ch||
’address_line3’ ||&ch||
’town_or_city’ ||&ch||
’country’ ||&ch||
’postal_code’ ||&ch||
’applicant_title’ ||&ch||
’applicant_last_name’ ||&ch||
’position_name’ ||&ch||
’organization_name’ ||&ch||
’grade_name’ ||&ch||
’projected_hire_date’ ||&ch||
’recruiter_title’ ||&ch||
’recruiter_last_name’ ||&ch

from sys.dual
/

After selecting your mail merge header information, you must re-set the LINESIZE to
the maximum to VARCHAR2 size which is 2000.

REM re-initialise the linesize to the maximum 2000 varchar2 lengt
h
SET LINESIZE 2000

The following section is the main SQL*Plus query that generates the mail merge field
information. Note that the columns are merged together using the &ch character as the
field delimiter.The RPAD function pads out the row of information with # for all white
spaces. Without this function, mail merge cannot distinguish when a row/record has
ended.The SQL*Plus query in this example is generated from letter requests. Therefore
the &1 argument is used to identify which letter_request_id is being generated.
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REM Mail merge interview query
select rpad(

nvl(pa.address_line1,’ ’)
||&ch||

nvl(pa.address_line2,’ ’)
||&ch||

nvl(pa.address_line3,’ ’)
||&ch||

nvl(pa.town_or_city,’ ’)
||&ch||

nvl(ft.territory_short_name, ’ ’)
||&ch||

nvl(pa.postal_code,’ ’)
||&ch||

nvl(hl1.meaning, ’ ’)
||&ch||

nvl(pp1.last_name, ’ ’)
||&ch||

nvl(pos.name, ’ ’)
||&ch||

pou.name
||&ch||

nvl(pg.name, ’ ’)
||&ch||

nvl(to_char(pappl.projected_hire_date,
’fmDay fmddth "of" fmMonth YYYY’), ’ ’

) ||&ch||
nvl(hl2.meaning, ’ ’)

||&ch||
nvl(pp2.last_name, ’ ’)

||&ch,
2000, ’#’) L1

from per_addresses pa,
fnd_territories ft,
hr_lookups hl1,
hr_lookups hl2,
hr_all_organization_units pou,
per_positions pos,
per_grades pg,
per_applications pappl,
per_all_people pp1,
per_all_people pp2,
per_all_assignments pasg1,
per_letter_request_lines plr
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where plr.letter_request_id = &1
and pp1.person_id = plr.person_id
and pa.primary_flag (+) = ’Y’
and pa.person_id (+) = pp1.person_id
and ft.territory_code (+) = pa.country
and hl1.lookup_code (+) = pp1.title
and hl1.lookup_type (+) = ’TITLE’
and pasg1.assignment_id (+) = plr.assignment_i
d
and pos.position_id (+) = pasg1.position_i
d
and pou.organization_id (+) = pasg1.organizati
on_id
and pg.grade_id (+) = pasg1.grade_id
and pappl.application_id (+) = pasg1.applicatio
n_id
and pp2.person_id (+) = pasg1.recruiter_
id
and hl2.lookup_code (+) = pp2.title
and hl2.lookup_type (+) = ’TITLE’
/
REM Note: SPOOL command commented out for concurrent manage r.
REM PC based solution required the SPOOL command.
REM spool off

The following section updates the letter request from Pending to Complete (as the
example is for letter requests).

REM update the letter request_status from PENDING to COMPLE TE
update per_letter_requests plr
set plr.request_status = ’COMPLETE’
where plr.letter_request_id = &1
and plr.request_status = ’PENDING’
/

The following section deletes the row inserted into FND_SESSIONS.

REM delete the session row created
delete from fnd_sessions fs
where fs.session_id = userenv(’sessionid’)
and fs.effective_date = to_date(’&2’,’DD-MON-YYYY’)
/

The following section commits the changes and exits the SQL*Plus session.

REM commit the changes
commit
/
exit

PERWPWUK Template
The template SQL*Plus script for mail merge letters for MultiMate or WordPerfect is
PERWPWUK.sql. See: Writing a SQL*Plus script for MultiMate or WordPerfect, page
2-41
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The following section defines the required SQL*Plus environment settings. You should
produce this section exactly as you see it when you define your mail merge file.

REM
DEFINE line_size=80
DEFINE field_size= &line_size-1
DEFINE ch="’%’"
SET PAGESIZE 0
SET LINESIZE &line_size
BREAK ON L1 SKIP PAGE
COLUMN L1 FORMAT A&line_size
COLUMN L2 FORMAT A&line_size
COLUMN L3 FORMAT A&line_size
COLUMN L4 FORMAT A&line_size
COLUMN L5 FORMAT A&line_size
COLUMN L6 FORMAT A&line_size
COLUMN L7 FORMAT A&line_size
COLUMN L8 FORMAT A&line_size
COLUMN L9 FORMAT A&line_size
SET FEEDBACK OFF
SET RECSEP OFF
SET HEADING OFF
SET VERIFY OFF
SET TERMOUT OFF

The following section creates a row in the Application Object Library table (AOL)
FND_SESSIONS. The &2 argument contains the current SQL*Forms session date.You
should produce this section exactly as you see it when you define your mail merge file.

insert into fnd_sessions
(session_id ,effective_date)
select userenv(’SESSIONID’)
, to_date(’&2’,’DD-MON-YYYY’)
from sys.dual
/

After selecting your mail merge header information, you must re-set the LINESIZE to
the maximum to VARCHAR2 size which is 2000.

REM re-initialise the linesize to the maximum 2000 varchar2 lengt
h
SET LINESIZE 2000

The following section is the main SQL*Plus query that generates the mail merge field
information. Note that the columns are merged together using the &ch character
as the field delimiter.The SQL*Plus query in this example is generated from letter
requests. Therefore the &1 argument is used to identify which letter_request_id is
being generated.
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select nvl(t.meaning||’ ’||p.first_name||’ ’||p.last_n ame, ’ ’)||
&ch||

nvl(a.address_line1,’ ’) ||&ch||
nvl(a.address_line2,’ ’) ||&ch||
nvl(a.address_line3,’ ’) ||&ch||
nvl(a.town_or_city,’ ’) ||&ch||
nvl(a.region_1, ’ ’) ||&ch||
nvl(a.postal_code,’ ’) ||&ch||
nvl(t.meaning||’ ’||p.last_name,’ ’)

from per_addresses a,
per_people p,
per_letter_request_lines s,
hr_lookups t

where a.person_id (+) = p.person_id
and p.person_id = s.person_id
and p.title = t.lookup_code (+)
and t.lookup_type (+) = ’TITLE’
and s.letter_request_id = &1
/

The following section updates the letter request from Pending to Complete (as the
example is for letter requests).

update per_letter_requests r
set r.request_status = ’COMPLETE’
where r.letter_request_id = &1
and r.request_status = ’PENDING’
/

The following section commits the changes and exits the SQL*Plus session.

commit
/exit
/

OTA SQL*Plus Script
Example SQL mail merge file. See: Writing a SQL*Plus Script for MultiMate or
WordPerfect, page 2-41 and Writing a SQL*Plus Script for Microsoft Word, page 2-42

The template to produce confirmation letters is OTA.sql.

The following section defines the required SQL*Plus environment settings.You should
produce this section exactly as you see it when you define your mail merge file.

WHENEVER SQLERROR EXIT FAILURE ROLLBACK
REM Define the MS Word mail merge record separator
DEFINE ch="’%’"
REM Define the column width for returning query results
COLUMN L1 FORMAT A2000
SET PAUSE OFF
SET FEEDBACK OFF
SET RECSEP OFF
SET HEADING OFF
SET VERIFY OFF
SET TERMOUT OFF
SET PAGESIZE 0
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The following section creates a row in the Application Object Library table (AOL)
FND_SESSIONS. This enables the datetrack security views to be accessed for the
session. The &2 argument contains the current SQL*Forms session date.You should
produce this section exactly as you see it when you define your mail merge file.

REM Insert session row
insert into fnd_sessions(session_id ,effective_date)
select userenv(’SESSIONID’),

to_date(’&2’,’DD-MON-YYYY’)
from sys.dual
/

The following section has two functions:

1. To set the mail merge header line size. This is dependent on the character length
of all the mail merge items you want to use. In the example, the header line size
equates approximately to 220 characters.

2. To enable the spooling of the SQL results. The spool file should match the name of
the SQL file you are writing, but with a text file extension. 2.2

REM Set length of the header
SET LINESIZE 200
REM Create the mail merge ’header’ record for MS Word
REM Note: SPOOL command commented out for concurrent manage r.
REM PC based solution required the SPOOL command.
RWM spool xxxxx.txt

The following section defines the mail merge header information. These are the mail
merge fields you integrate with your word processed letter. Each mail merge field is
delimited by the pre-defined &ch character. Ensure that the field size does not exceed 40
characters and that the field name does not include white spaces. Do not forget that
the length in characters of this selected row from sys.dual is the line size value you
specified above.

select ’student_title’ ||&ch||
’student_first_name’ ||&ch||

’student_last_name’ ||&ch||
’event_name’ ||&ch||

’event_code’ ||&ch||
’event_end_date’ ||&ch

from sys.dual
/

After selecting your mail merge header information, you must re-set the line size to the
maximum VARCHAR2 size, which is 2000.

REM re-initialise the linesize to the maximum 2000 varchar2 lengt
h
SET LINESIZE 2000

The following section is the main SQL*Plus query that generates the mail merge field
information. Note that the columns are merged together using the &ch character as the
field delimiter.The RPAD function pads out the row of information with # for all white
spaces. Without this function, mail merge cannot distinguish when a row/record has
ended.The SQL*Plus query in this example is generated from letter requests. Therefore
the &1 argument is used to identify which letter_request_id is being generated.
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REM Mail merge confirmation query
select rpad(
initcap(nvl(d.delegate_title_meaning,’ ’ )) ||&ch||

nvl(d.delegate_first_name,’ ’) ||&ch||
nvl(d.delegate_last_name,’ ’ ) ||&ch||
nvl(v.description,’ ’) ||&ch||
nvl(d.event_activity_version_name,’ ’ ) ||&ch||
to_char(d.course_end_date, ’DD fmMonth YYYY’) ||&ch,
2000, ’#’) L1

from ota_delegate_bookings_v d,
ota_activity_versions v,

per_letter_request_lines plr
where plr.letter_request_id = &1
and (plr.ota_booking_id = d.booking_id
or plr.ota_event_id = d.event_id)
and d.activity_version_id = v.activity_versi

on_id
/

REM Note: SPOOL command commented out for concurrent manage r.
REM PC based solution required the SPOOL command.
REM spool off

The following section updates the letter request from Pending to Complete (as the
example is for letter requests).

REM Update the letter request_status from PENDING to COMPLE TE
update per_letter_requests plr
set plr.request_status =’COMPLETE’
where plr.letter_request_id =&1
and plr.request_status =’PENDING’
/

The following section deletes the row inserted into FND_SESSIONS.

REM delete the session row created
delete from fnd_sessions fs
where fs.session_id = userenv(’sessionid’)
and fs.effective_date = to_date(’&2’,’DD-MON-YYYY’)
/

The following section commits the changes and exits the SQL*Plus session

REM commit the changes
commit
/
exit
/

Planning Standard Letter Requirements
Before creating standard letters, you need to identify several things.

To plan standard letter requirements:
1. Identify the database information to include in the letters.
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You need to identify the select statements to provide you with the data as the content
of your letters. Oracle HRMS supplies you with SQL*Plus scripts as templates to
help you do this.

2. Identify the text that you want to include as the body of your letters.

3. Decide whether to associate your standard letters with student enrollment or
applicant assignment statuses.

4. Identify which statuses you want to trigger your standard letters (if you do want to
link your standard letters to student enrollment or applicant assignment statuses).

For example, do you want to link your standard enrollment confirmation letter to the
status Placed so that the letter is triggered when you set a student’s enrollment status to
Placed? Do you want to link your standard rejection letter to the status Rejected so that it
is triggered when an applicant’s assignment status is set to Rejected?

Writing a SQL*Plus Script for MultiMate or WordPerfect
Oracle HRMS supplies you with SQL*Plus scripts as templates for extracting database
information for standard letters. You can copy the SQL*Plus script templates and modify
them to create the standard letters you require.

The template scripts Oracle HRMS provides are:

Scripts Purpose Used By

PERWPMUK.sql Example UK SQL*Plus script
for MultiMate

HR

PERWPMUS.sql Example US SQL*Plus script
for MultiMate

HR

PERWPWUK.sql Example US SQL*Plus script
for WordPerfect

HR

PERWPWUS.sql Example US SQL*Plus script
for WordPerfect

HR

One of the template SQL*Plus scripts (PERWPWUK.sql) is provided as a
example. See: PERWPWUK Template, page 2-33

Oracle Training Administration does not provide template scripts, but we provide
an example of a Confirmation letter SQL mail merge file. See: OTA SQL*Plus Script,
page 2-33

To write a SQL*Plus script for MultiMate or WordPerfect:
1. Copy the appropriate SQL*Plus script from the server side sql directory of the HR

product tree (consult your installation guide for details).

2. Edit (or write) a SQL*Plus script to select data from the database in a format your
word processor can read and that is compatible with the standard letter.

3. Save the file with the name PERWP*** (or OTAWP*** for OTA).
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You must use this prefix for the system to recognize it as a type of letter. See your
Oracle Applications installation server guides for details of where the concurrent
manager places the files.

Writing a SQL*Plus Script for Microsoft Word
Oracle HRMS supplies four SQL*Plus script templates.

You can run the scripts on the server side and make them accessible to other users
across the network, or you must copy them to a directory which is accessible from
the PC, such as a network drive.

The template scripts that Oracle HRMS provides are:

Scripts Purpose Used By

PERWPOUS.sql Example US Offer letter SQL
mail merge file

HR

PERWPOUK.sql Example UK Offer letter SQL
mail merge file

HR

PERWPIUS.sql Example US Interview letter
SQL mail merge file

HR

PERWPIUK.sql Example UK Interview letter
SQL mail merge file

HR

One of the template SQL*Plus scripts is provided as an example. See: Template SQL*Plus
Script PERWPOUK, page 2-33

Oracle Training Administration does not provide template scripts, but we provide
an example of a Confirmation letter SQL mail merge file. See: OTA SQL*Plus Script,
page 2-33

To write a SQL*Plus script for Microsoft Word:
1. Copy the SQL*Plus scripts from the server side sql directory of the HR product

tree. (Consult your installation guide for details).

2. Edit (or write) a SQL*Plus script to select data from the database in a format your
word processor can read and is compatible with the standard letter.

3. Save the file with the name PERWP*** (or OTAWP*** for OTA).

You must use this prefix for the system to recognize it as a type of letter. See your
Oracle Applications installation server guides for details of where the concurrent
manager places the files.

Registering the SQL*Plus Script
Register your SQL*Plus program with Oracle HRMS. You register your program so that
you can run it as a concurrent program. Name the file PERWP*** (or OTAWP***). You
must use this prefix for the system to recognize it as a type of letter.

You use the Concurrent Programs window to register your program (using a system
administrator responsibility).
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See: Concurrent Programs Window, Oracle Applications System Administrator’s Guide

Linking the SQL*Plus Script With a Letter
You need to link your SQL*Plus script with a letter and one or more statuses. In Oracle
Human Resources, you can link one or more applicant assignment statuses with each
recruitment letter. A request for the letter is then created automatically when an
applicant is given an associated assignment status. For example, you can link your
standard recruitment rejection letter to the status Rejected so that the letter is triggered
when you set an applicant’s assignment status to Rejected.

In Oracle Training Administration, you can link one or more enrollment statuses with
each enrollment letter. A request for the letter is then created automatically when an
enrollment is given an associated status.

Define your standard letter types in the Letter window.

To define a standard letter type:
1. Enter a name for the letter in the Name field.

2. Select the Concurrent Program Name assigned by your System Administrator to
the SQL*Plus script.

For Oracle Human Resources:

3. Select one or more applicant assignment statuses to create letter requests
automatically for applicants, and check the Enabled box.

When an applicant is given one of these statuses, a pending request for this letter
type is created automatically. If a pending letter request already exists, the applicant
is added to the list of people to receive the letter when you submit the request.

For Oracle Training Administration:

4. Select one or more enrollment statuses to create letter requests automatically for
enrollments, and check the Enabled box.

When an enrollment is given one of these statuses, a pending request for this letter
type is created automatically. If a pending letter request already exists, the enrollment
is added to the list of people to receive the letter when you submit the request.

Writing a Skeleton Letter
Write a skeleton letter using your word processor. Include the appropriate merge codes
from the data source for the word processor you are using.

Desktop Integration 2-43



Merging Data with Standard Letters

The mail merge feature of any word processor enables you to merge text from the data
file you create into a standard letter. Each line in the data file contains the text to merge
into one standard letter for one recipient.

Within the program, you can format the data and include the characters that are
recognized as separators by your word processor.

A standard letter comprises standard text with a number of embedded variables in
it. When you print the letter, the variables are replaced with specific items of data, such
as name and address details for different people.

Merging the Data File with the Standard Letter
When the concurrent manager has finished processing a letter request, you can merge
the data in the Data File with your skeleton letters.

To merge the data file with the standard letter:
1. Merge the data in the Data File with your skeleton letters to create your standard

letters. The merging of text and data files is normally carried out using the mail
merge features of your word processor.

If you do not have access to the directory where the Data File resides (consult your
installation guide for details of the location Concurrent Manager places the file), you
need to transfer the mail merge files created by the concurrent process to your word
processor before you can merge the data file with the skeleton letters.
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2. If you are using a word processor to merge the data file, you need to save the
merged letters you generate.

If you do not save the merged letters, when you exit the word processor you lose the
letters. You do not lose the data file or the skeleton letter, however.

Linking the Report With a Letter
You need to link your report with a letter and one or more statuses. In Oracle Human
Resources, you can link one or more applicant assignment statuses with each recruitment
letter. A request for the letter is then created automatically when an applicant is given an
associated assignment status. In Oracle Training Administration, you can link one or
more enrollment statuses with each enrollment letter. A request for the letter is then
created automatically when an enrollment is given an associated status.

For example, you can link your standard recruitment rejection letter to the status Rejected
so that the letter is triggered when you set an applicant’s assignment status to Rejected.

Define your standard letter types in the Letter window.

To define a standard letter type:
1. Enter a name for the letter in the Name field.

2. Select the concurrent program name assigned by your system administrator to
the report.

For Oracle Human Resources:

3. Select one or more applicant assignment statuses to create letter requests
automatically for applicants, and check the Enabled box.

When an applicant is given one of these statuses, a pending request for this letter
type is created automatically. If a pending letter request already exists, the applicant
is added to the list of people to receive the letter when you submit the request.

For Oracle Training Administration:

4. Select one or more enrollment statuses to create letter requests automatically for
enrollments, and check the Enabled box.

When an enrollment is given one of these statuses, a pending request for this letter
type is created automatically. If a pending letter request already exists, the enrollment
is added to the list of people to receive the letter when you submit the request.

Writing and Registering the Report
You need to write and register the report.

To write and register the report:
1. Identify which data you want to extract from the database. Write your skeleton

letter text and Select statements specifying the data to be extracted from the Oracle
database.

2. Register your report with Oracle HRMS. You register your report so that you can run
it as a concurrent program. Name the file PERWP*** (or OTAWP*** for OTA). You
must use this prefix for the system to recognize it.
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You use the Concurrent Programs window to register your report (using a system
administrator responsibility).

See: Concurrent Programs Window, Oracle Applications System Administrator’s Guide

Requesting Letters/Running the Report
When you, or other users, set the status for an applicant or enrollment that triggers your
standard letters, Oracle HRMS creates a letter request automatically, with the status of
Pending. It also adds the applicant’s or student’s name to the request. You can view the
pending request and names through the Request Letter window.

Then, when you change the letter request from Pending to Requested, Oracle HRMS
runs the report or SQL*Plus script for this type of letter.

Depending on the requirements of your enterprise, you can generate letter requests for
every organization within your enterprise or you can generate separate letter requests
for each vacancy you define. If you want to generate separate letter requests by a specific
vacancy you must select Yes for the HR: Restrict Letter by Vacancy Name or Event profile.

The advantages of restricting the generation of letters to a specific vacancy is that you
can process letters for one organization without affecting another organization within
your enterprise.

See: User Profiles, page 1-49

You can add further names to the list manually, if required. For example, you might have
a last minute acknowledgement letter to send.

You can also create manual letter requests. You do this by entering the status of Pending
yourself, then entering all the recipients of the letter before changing the status of
the letter to Requested.

To submit an automatic letter request:
1. Query the letter you require in the Letter Name field.

2. Ensure that the method is Automatic.

3. Select the vacancy in the Vacancy Name field.

Note: You must set the HR: Restrict Letter by Vacancy or Event
profile to Yes to enable this field.

4. Move to the Requested For block to query the applicants, events or students that
have been entered automatically on this request, according to their status. You can
add further names manually.

5. Update the status from Pending to Requested.

6. Save your changes.

A concurrent request ID number appears in the Concurrent Request field. When the
Concurrent Manager has processed the request it changes the status to Completed.

7. You can query the request ID in the Concurrent Requests window and monitor
its progress.

Note: Consult your installation guide for details of the location
Concurrent Manager places the output or data file.
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To create a manual letter request:
1. Select the Letter Name for the letter type you want to request.

2. Ensure that the method is Manual.

3. Select the vacancy in the Vacancy Name field.

Note: You must set the HR: Restrict Letter by Vacancy or Event
profile to Yes to enable this field.

4. Leave the status of the request as Pending.

5. Save the changes.

Adding the Names

6. Select the names to add:

• Select employees or applicants (for Oracle Human Resources) to receive the
letter in the Requested For region.

The Assignment field displays the organization to which the person is
assigned. You can view the other components of the assignment by choosing
List of Values from the Edit menu.

• Select events or students or both (for Oracle Training Administration) in the
Requested For region.

This depends on how the letter has been set up on your system. For example, an
enrollment confirmation letter might be defined so that it is sent to all students
with the status Confirmed who are enrolled on the event selected in the
Requested For region.

7. Save the changes.

Changing the Status

8. Update the status from Pending to Requested.

9. Save the changes.

A concurrent request ID number appears in the Concurrent Request field. When the
Concurrent Manager has processed the request it changes the status to Completed.

10. You can query the request ID in the Concurrent Requests window and monitor
its progress.

Note: Consult your installation guide for details of the location
Concurrent Manager places the output file.

Performing the Next Step:
If your letters are produced by Oracle Reports, they are ready for printing. If you use
your word processor’s mail merge facility, you are ready to merge the data. See: Merging
the Data File With the Standard Letter, page 2-44
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3
Extending O racle HRMS

Extend Oracle HRMS Overview
This section describes how you can extend Oracle HRMS to better meet your enterprise’s
needs.

There are many ways you can configure Oracle HRMS to meet the needs of your
business processes:

• Linking windows together in a task flow to streamline data entry and processing

• Designing your own windows to create user or task-specific windows

• Restricting data access on windows to provide security and confidentiality

You can configure Oracle HRMS using one or any combination of these.

Before configuring any part of Oracle HRMS, it is advisable to plan ahead and decide
which parts of the system you want to configure. For example, if you know that your
users typically perform a task in a certain way, you can design windows to help them
enter information more efficiently. You can also link windows together to help users
move from one window to the next. If necessary, you can also restrict what information
appears in lists of values and restrict access to certain types of information.

Key Concepts
This section describes some of the tools available to configure Oracle HRMS for your
enterprise.

Alerts

Alerts enable you to inform, remind, and confirm information on your personal
information, your direct reports, and your workforce. The alert triggers an email
notification of an impending action, task, or change to information. For example, you
can set up an alert to remind you when a new hire is due to start work.

See: Oracle HRMS Predefined Alerts, Configuring, Reporting, and System Administration
Guide

Flexfields

You can add data fields called flexfields to windows to hold any additional information
you require. You can add:
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• Key flexfields to configure some of the most important parts of the system, including
the names of jobs, positions and grades, details of payroll cost allocation, and
analysis information for employees and other people.

• Descriptive flexfields to add fields to windows to record additional information.

• Extra Information Types to set up multiple categories of information for the most
important entities in Oracle HRMS. For example, you might use EITs to add details
to assignment records in special circumstances, such as information about a leave of
absence or extra information about a temporary assignment to a project.

Protected Flexfields are predefined and protected flexfields supplied with Oracle
HRMS. There are two key protected flexfields and three descriptive protected
flexfields. Your localization team defines these flexfields to meet the specific legislative
and reporting needs of your country.

User-Defined Tables

You can set up user tables to provide matrixes of valid values that vary, such as age, or
job, or number of years service. You can access these values from formulas, or your
own forms or reports. The GET_TABLE_VALUE function is supplied for use in your
formulas. Certain legislations include predefined user tables, for example, to hold
values for payroll calculations.

Lookups

Lookups provide lists of valid values on certain fields throughout the system. For many
lookups you can add your own values and change the predefined values. Lookups not
only ensure that all users use the same terminology, but also speed up data entry.

CUSTOM Library Events

You can use CUSTOM Library Events to configure the logic that is executed at defined
points within a window. Generic events are available to all Oracle Applications and
Product Specific Events are also available to help you to apply business rules specific
to Oracle HRMS.

APIs (called Application Programmatic Interfaces)

Oracle HRMS provides a set of PL/SQL packaged procedures and functions that
together provide an open interface to the database.

Task Flows

You often need to use more than one window to complete many tasks. Oracle HRMS
enables you to link these windows together using a task flow. Users can choose a button
to bring up each window in turn without returning to the menu. For example, to
enter personal information, you typically go from the People window, to the Address
window, to the Special Information window and so on. Task flows speed up processes
and reduce data entry error

See: Task Flow, page 3-250

Restricting Information

Restricting the type of information available on a window is useful as a security
measure. For example, you can create versions of RPA windows to show only
compensation information available to the logged-in user.
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See: Windows You Can Configure Using CustomForm, , Configuring, Reporting, and
System Administration GuideRestricted RPA, Workforce Sourcing, Deployment, and Talent
Management Guide

Currencies

You will also need to define the formats for displaying currency amounts. You must
enable at least one currency as the default currency for all information related to money
in your system. This default is known as the Base Currency for your Business Group.

Workflow

Workflow

You use the Oracle HRMS Workflow tool to:

• Create and maintain taskflows

See: Task Flow (Oracle Workflow), page 3-255

• Configure the approval and notification workflow process for RPAs and for Within
Grade Increases (WGIs).

See: RPA and PD Workflow Overview, page 6-1

• Configure the workflow process for budget worksheets based on user-defined
routing lists, position hierarchies, or supervisory hierarchies. You restrict which
users process transactions by defining routing and authorization rules.

Extend Oracle HRMS
You can extend Oracle HRMS to meet the needs of your enterprise.

You can configure Oracle HRMS by designing windows to match your specific business
processes. You can also link windows together to form any number of flows required by
your users. Configuring windows and taskflows enable your users to perform their
tasks more efficiently.

How can you hold additional information?
You can add data fields to windows to hold any additional information you
require. Flexfields are flexible fields that enable you to do this.

Then, when you click in a flexfield you have set up, a window opens, displaying
segments into which you can enter data.

You can also set up your own tables to hold data such as agency-specific basic and
special rate pay tables.

How can you ensure the same terminology is used and speed up data entry?
Oracle provides lists of values called QuickCodes for certain items of
information. QuickCodes ensure that all users use the same terminology, making it easier
to inquire and report on information. QuickCodes also speed up data entry because you
can enter just enough to identify the value, and the system completes the entry.
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Can you link windows together?
Oracle recognizes that to complete many tasks, you need to use more than one
window. You can link these windows together in a task flow so that you can choose a
button to bring up each window in turn without returning to the menu.

How is security affected by configuring windows?
Any windows that you configure behave in the same way as existing windows. Security
is set by the user’s security profile option and responsibility. However, you can configure
the Find results window to enable users to see information for people outside of their
security profile. They cannot change this information.

In addition, you can create windows that:

• Restrict the list of values on certain fields or limit access to certain types of
information

• Use workflow so that any data changes must be approved before the changes are
applied to the database. This applies to the windows that are based on templates.

Can you define currency formats?
You can define the formats for displaying currency amounts.
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Flexfields

Flexfields
Flexfields are flexible fields that enable you to configure and extend Oracle Applications
by adding fields to windows. There are two types of flexfield:

• Key flexfields enable you to define additional information you want to record
in existing fields.

• Descriptive flexfields enable you to add fields to windows to record additional
information.

Extra Information Types (EITs) are a type of descriptive flexfield that enable you to
set up unlimited amounts of extra information for eight of the most important
entities in Oracle HRMS.

You can set up each flexfield to contain a number of segments, which act like separate
fields.

When a user clicks in a flexfield you have set up, a window opens, displaying the
segments that you have defined. For each segment, you can define:

• Its prompt

• The type of data it can contain

• The values a user can enter

You can provide a list or range of valid values. You also control the size and display
characteristics of each segment and the sequence in which the segments appear.

User-Definable Key Flexfields
In Oracle HRMS there are six user definable key flexfields, for each of which you can
define up to 30 segments:

• Job

• Position

• Grade

• Competence

• People Group

• Personal Analysis

• Cost Allocation

• Collective Agreement Grades

The Personal Analysis and Collective Agreement Grades key flexfields can have an
unlimited number of structures. All other flexfields can have only one structure each.

You can define up to 30 segments for each structure in all key flexfields except for the
Collective Agreement Grades key flexfield. This can have up to 20 segments for each
structure.

Extending Oracle HRMS 3-5



How Oracle HRMS Uses Key Flexfields
Oracle US Federal HR product predefines the Grade Flexfield. The product requires
that you also include specific segments in the Position and Job flexfields. The Personal
Analysis Flexfield has predefined values.

The People Group, Cost Allocation, and Competence Flexfields have no minimum
requirements.

The Collective Agreement Grade flexfield is not supported for Oracle US Federal HR.

The following sections provide some general information about Oracle HRMS usage
of the key flexfields. For detailed information on key flexfield descriptions and
lookups, refer to US Federal Human Resource Key Flexfields, page 3-80.

Unique Identifiers

The Job, Position, and Grade Name flexfields let you create a unique name, which is a
combination of separate components or segments. You use these flexfields when you are
defining the work structures that exist in your enterprise.

Note: When you are defining your requirements for these key flexfields
you should consider the following points.

• The task of defining the segment combinations is normally restricted to one or two
users only. Therefore, you may not need to use value sets, or cross validation rule
options to control the values that can be entered.

• The names that users see are made up of a combination of segment values. The
segment values are displayed, not the meanings.

• Avoid segments containing information that may change regularly. There is no
history of changes to the combinations you create.

Analysis Information

The People Group and Personal Analysis flexfields let you add key information to
records of employee assignments and people. You can use the individual segments of
these flexfields to identify or report on specific groups of people.

Payroll Costing

The Cost Allocation key flexfield is used to collect and to accumulate costs associated
with running a payroll.

What You Must Set Up
The key flexfields are central to Oracle HRMS, therefore you must create certain
definitions before you can set up your Business Group.

For detailed information on key flexfield descriptions and lookups, refer to Oracle US
Federal Human Resource Key Flexfields, page 3-80.

Job Key Flexfield

• You can only define one structure per Business Group for each of these flexfields.

• You must define a segment for the occupational series using the supplied value
set. After defining the job key flexfield, you map this segment to the US Federal
Organization Information.
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• You must define a structure name for these flexfields before you can define a
Business Group.

• You associate these structures with a Business Group in the Business Group
Information window, which opens from the Organization window.

Position Key Flexfield

• You can only define one structure per Business Group for each of these flexfields.

• You must define four segments for the position title, position description
number, sequence number, and agency code using the supplied value set. The
Position Title segment must reside in the first five segments of the key flexfield. After
you define the position key flexfield, you map these four segments to the US Federal
Organization Information.

• You must define a structure name for these flexfields before you can define a
Business Group.

• You associate these structures with a Business Group in the Business Group
Information window, which opens from the Organization window.

• It is essential to run the Create Key Flexfield DB Items process whenever you create
or change the Position key flexfield definitions. See: Creating Key Flexfield Database
Items, page 3-20.

Grade Key Flexfield

• The application predefines the flexfield segments and the structure name for the
Grade Key Flexfield. You must compile the flexfield.

• You associate these structures with a Business Group in the Business Group
Information window, which opens from the Organization window.

• You run the Create Federal HR Valid Combinations for the Grade Key Flexfield
process to enter the predefined grade and pay plan combinations for each business
group you set up.

Competence Key Flexfield

• You must define a structure name for this flexfield before you can define a Business
Group.

• You can only define one structure per Business Group for this flexfield.

• You associate this structure with a Business Group in the Business Group
Information window, which opens from the Organization window. This defines the
key flexfield that is used when creating competencies specific to the Business Group.

• You can create an additional key flexfield that can be used to create global
competencies that are available across all Business Groups. You can, however, use
the same key flexfield you have defined for the Business Group if you want. You
define this key flexfield in the HR: Global Competence Flex Structure profile option.

• You must specify one of the segments as the Default Attribute using the flexfield
qualifier. You must also attach the Others flexfield qualifier to all other segments
in the structure.
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• It is essential to run the Create Key Flexfield DB Items process whenever you create
or change the Competence key flexfield definitions. See: Creating Key Flexfield
Database Items, page 3-20.

People Group Key Flexfield

• You can only define one structure per Business Group for this flexfield.

• You do not create separate combinations of segments for the People Group
flexfield. You enter values for each employee as part of the employee assignment.

• You must define a structure name for this flexfield before you can define a Business
Group.

• You must define at least one segment for the People Group flexfield in order to be
able to use the Assignment window.

• It is essential to run the Create Key Flexfield DB Items process whenever you create
or change the People Group key flexfield definition. See: Creating Key Flexfield
Database Items, page 3-20.

Personal Analysis Key Flexfield

• You can create any number of structures per Business Group for this flexfield. Each
one represents a Special Information Type.

• Each Special Information Type can have up to thirty fields (where each field is a
segment of the flexfield).

• You can set up cross-validation to ensure that users enter correct combinations of
segments. You can also speed up data entry and minimize errors by defining an
’Alias’ for common combinations of segment values.

• You do not need to define any structures for the Personal Analysis flexfield before
you can use Oracle HRMS.

• You link each structure to a Business Group in the Special Information Types
window while you are logged on to that Business Group.

• You can customize windows to restrict access to specific Information Types.

Cost Allocation Key Flexfield

• You can only define one structure per Business Group for this flexfield.

• You can control the levels at which users can enter cost information by using the
flexfield qualifiers.

• You must define a structure name for this flexfield before you can define a Business
Group.

• A number of windows in Oracle HRMS check for the existence of a valid flexfield
structure for Cost Allocation. You must define at least one segment for your Cost
Allocation flexfield.

User Definable Descriptive Flexfields
The predefined fields in Oracle HRMS windows are designed to meet your core
information requirements. However, like all enterprises, you may have special
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requirements that are best met by fields that you design yourself. Oracle HRMS provides
a flexible mechanism called descriptive flexfields to enable you to add fields to windows.

All window blocks in which you can enter information contain a user definable
descriptive flexfield. You decide in which blocks you want to record additional
information. Each user definable descriptive flexfield has 20 segments that you can
define. After you define a descriptive flexfield, Oracle HRMS treats the segments as
part of the window.

The following figure illustrates the distinctive appearance of descriptive flexfields. When
users click in a flexfield that you have set up, or choose Edit Field from the Edit menu, a
window opens, displaying up to 20 segments that you have defined.

The way in which descriptive flexfield windows open is controlled by the
Flexfields:Open Descr Window profile option. If this option is set to Yes, the flexfield
window automatically pops open when the user navigates to the field. If it is set to
No, users can open the flexfield by choosing Edit Field from the Edit menu or pressing
CTRL+L. The default is Yes.

Segments
For each segment, you can define:

• Its prompt

• The type of data it can contain

• The values a user can enter

You can provide a list or range of valid values. You also control the size and display
characteristics of each segment and the order in which the segments appear.

Types of Descriptive Flexfield Segments
You can define two types of descriptive flexfield segments:

• Global segments, which always appear in the window.

• Context-sensitive segments, that appear only when a defined context exists. You can
prompt the user to provide the context, or you can provide the context automatically
from a reference field in the same block.

For example, a segment holding information about an employee’s disability might
appear only when the Disabled field is checked.

Important: Some descriptive flexfields appear in more than one
window. For example, the Additional Evaluation Details flexfield appears
in the Job Evaluation window and the Position Evaluation window.

Check all of the windows that use a descriptive flexfield before you
define any of the segments. This is especially important if you intend
to make the flexfield context sensitive to another field. You must
ensure that the reference field is present in all of the windows that
use the flexfield.
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See: Descriptive Flexfield List, page 3-10 for a full list of user definable descriptive
flexfields in Oracle HRMS.

Descriptive Flexfield List
The following table lists all the user definable descriptive flexfields in Oracle HRMS.

Descriptive Flexfield Title Window Title Database Items

Additional Absence Details Absence Detail,

View Absence History

ABSENCES_<SEGMENT_
NAME>

Additional Absence Type
Details

Absence Attendance Type ABSENCE_TYPES_
<SEGMENT_NAME>

Additional Address Details Address,

Applicant Entry

Contact

PERSON_ADDRESSES_
<SEGMENT_NAME>

Additional Application Details Applicant Entry,

Application,

Terminate Applicant

APPLICATIONS_
<SEGMENT_NAME>

Additional Appraisal Details

Additional Appraisal
Template Details

Additional Assessment Group
Details

Additional Assessment Type
Details

Additional Assessment Details Medical Assessment

Additional Assignment
Details

Applicant Entry,

Application,

Assignment,

Assignment History

ASSIGNMENTS_
<SEGMENT_NAME>

Additional Assignment Status
Details

Secondary Statuses

Additional Balance Type
Details

Balance (Oracle Payroll only)

Additional Benefit
Contribution Details

Benefit Contributions (US
only)
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Descriptive Flexfield Title Window Title Database Items

Additional Booking Details Applicant Interview,

Book Events,

Employee Review,

Event Bookings

Additional Budget Details Budget

Additional Budget Values
Details

Additional Budget Version
Details

Budget

Additional Calendar
Information

Budgetary Calendar (Oracle
Payroll)

Additional Candidate
Information

Election

Additional Career Path Details Career Path Names

Additional Checklist Item
Details

Additional COBRA Benefit
Details

COBRA Benefits (US only)

Additional COBRA Coverage
Details

COBRA Coverage (US only)

Additional COBRA Payment
Details

COBRA Payment (US only)

Additional COBRA Status
Details

COBRA Status (US only)

Additional Collective
Agreement Details

Collective Agreements

Additional Coll. Agreed
Grades Details

Agreement Grades

Additional Competence
Details

Additional Competence
Element Details

Additional Constituency
Details

Election

Additional Contact
Relationship Details

Contact CONTACTS_<SEGMENT_
NAME>
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Descriptive Flexfield Title Window Title Database Items

Additional Contract Details Contract

Additional Delivery Method
Details

Additional Deployment Factor
Details

Work Choices, and Position
Transaction (Work Choices
tabbed region)

Additional Disability
Information

Disabilities

Additional Election Details Election

Additional Element Entry
Information

Adjust Balance (Oracle Payroll
only),

Element Entries,

View Element Entry History
for Employee

Additional Element Link
Information

Element Link (Oracle Payroll)

Additional Element Type
Details

Element (Oracle Payroll)

Additional Establishment Att
Details

Additional Establishment
Details

Additional Evaluation Details Job,

Position

Additional Event Details Applicant Interview,

Employee Review,

Event Bookings

EVENTS_<SEGMENT_
NAME>

Additional Grade Details Grade GRADES_<SEGMENT_
NAME>

Additional Hierarchy Details Generic Hierarchy

Additional Incident Details Work Incident

Additional Job Details Job JOBS_<SEGMENT_NAME>

Additional Letter Details Letter

Additional Location Details Location

Additional Node Details Generic Hierarchy
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Descriptive Flexfield Title Window Title Database Items

Additional Objectives Details

Additional Organization
Information

Organization

Additional Organization
Payment Method Details

Organizational Payment
Method (Oracle Payroll)

Additional Organization
Structure Details

Organization Hierarchy

Additional Organization Unit
Details

Organization ORGANIZATION_
<SEGMENT_NAME>

Additional Participants
Details

Additional Pay Scale
Information

Pay Scale

Additional Pay Rate Details Grade Rate,

Scale Rate

Additional Payroll Action
Details (Oracle Payroll)

Additional Payroll Details Payroll PAYROLLS_<SEGMENT_
NAME>

Additional Performance
Ratings Details

Additional Period Information Budgetary Calendar,

Period Dates (Payroll form)

Additional Period of
Placement Details

End Placement

Additional Period Type
Information

Period Types

Additional Person Analysis
Details

Special Information,

List People By Special
Information

Additional Personal Details Applicant Entry,

Contact,

People,

People Folder

PEOPLE_<SEGMENT_
NAME>

Additional PPM Details Personal Payment Method
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Descriptive Flexfield Title Window Title Database Items

Add’l Person Type Usage
Details

Person Type Usage

Additional Position Details Position,

Find Positions (Mass Move
form)

POSITION_<SEGMENT_
NAME>

Additional Position Structure
Details

Position Hierarchy

Additional Previous Employer
Details

Previous Employment

Additional Previous Job
Details

Previous Employment

Additional Previous Job Usage
Details

Previous Job

Additional Qualification
Details

Additional Qualification
Types

Additional Rating Level
Details

Additional Rating Scale
Details

Additional Recruitment
Activity Details

Recruitment Activity RECRUITMENT_ACTIVIT
IES_<SEGMENT_NAME>

Additional Requirement
Details

Job,

Position

Additional Requisition Details Requisition and Vacancy

Additional Role Details Supplementary Roles

Additional Salary
Administration Details

Salary Administration

Additional Salary Basis Details Salary Basis

Additional Standard Holiday
Absence Details

Additional Subjects Taken
Details

Additional Succession
Planning Details
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Descriptive Flexfield Title Window Title Database Items

Additional Telephone Number
Details

Phone Numbers

Additional Template Details People Management
Configurator (Template
Object)

Additional Vacancy Details Requisition and Vacancy

Additional Valid Grade
Details

Job,

Position

Additional Version Details Generic Hierarchy

Additional Year Information Budgetary Calendar

Assignment Extra Information Extra Assignment Information

Extra Job Info Details Extra Job Information

Extra Location Info Details Extra Location Information

Extra Person Info Details Extra Person Information

Extra Position Info Details

Extra Previous Job Details Previous Employment

Further Candidate
Information

Election

Further Election Information Election

Proposal Component Addl
Info

Review Addl Information

Salary Survey Additional
Information

Survey Line Addnl
Information

Survey Mapping Add Info

Descriptive Flexfields and Address Styles
Oracle HRMS supplies two predefined descriptive flexfields to hold address information
in different styles for different countries. These are:

• the Personal Address Information descriptive flexfield: This holds the address
information of your employee or applicant.
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• the Location Address descriptive flexfield: This holds the address information of
your locations.

Oracle HRMS holds the addresses of people and locations separately to enable you to
record different information for tax reporting.

You can use these descriptive flexfields to add new address styles or to change the
styles included in Oracle HRMS.

Important: If you change the predefined styles, your changes are
overwritten when you upgrade Oracle HRMS. If you add new
styles, your changes may be overwritten if new startup data contains
address styles for these countries.

Address Styles
Address styles vary between countries, so Oracle HRMS provides descriptive flexfields
that use context-sensitive segments to hold each line of an address. The Address Styles
Flexfields table below details the title of the flexfield, its location and where it is used.

Address Style Flexfields in Oracle HRMS

Title Table Name Window Title

Personal Address Information PER_ADDRESSES Address, Applicant Entry

Location Address HR_LOCATIONS Location, Organization

The available address styles are defined as the contexts for these flexfields. There are two
types of address style:

• International

• Local

Address styles are provided as startup data in these flexfields. If you require additional
address styles, you need to define a new context and segments.

International Address Style

This style provides basic validation of address data. Oracle HRMS provides international
address styles for many countries. This style can be used for both location and personal
addresses. International address styles are named territory_code_GLB. For example, the
Australian international address style is AU_GLB.

Territory codes can be found in the FND_TERRITORIES table.

Local Address Style

This style provides full validation of address data and is set up by a localization
team. Where a local address style exists, it can usually be used for both location and
personal addresses. Local address styles are named territory_code. For example, the
Australian local address style is AU.

Where a local address style exists and the Business Group uses the legislation code for
that country, the local address style is displayed as the default in the appropriate address
entry window. Where no local address exists, the international style is the default.
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US and Canadian users: the local address style for the US or Canada is only available
when you have Vertex geocodes data installed.

Developer Flexfields
Oracle HRMS supplies developer key flexfields and developer descriptive
flexfields. Your localization team has defined these flexfields, as required, to meet the
specific legislative and reporting needs of your country.

The protected developer key flexfields are the Soft Coded Legislation key flexfield and
the Bank Details key flexfield.

Of the developer descriptive flexfields, all except six are protected and cannot be
amended. The remaining six have Extra Information Types that you can use to configure
your application.

See: Extra Information Types (EITs), Oracle HRMS Configuring, Reporting, and System
Administration Guide

The following table lists the developer descriptive flexfields, including EITs.

Developer Descriptive Flexfields in Oracle HRMS

Title Table Name Window Title

Extra Job Information (EIT)

Extra Location Information
(EIT)

Extra Person Information (EIT)

Extra Position Information
(EIT)

Extra Previous Job Information PER_PREVIOUS_JOB_
EXTRA_INFO

Previous Employment

Further Absence Information
(Additional Absence Detail
Information)

PER_ABSENCE_
ATTENDANCES

Absence Detail

Further Assignment
Information (EIT)

Further Budget Values Details

Further Candidate
Information

PER_ELECTION_CAND
IDATES

Election

Further Canvas Properties HR_CANVAS_PROPERTIES_
B

People Management
Configurator (Canvas Object)

Further Collective Agreement
Information

PER_COLLECTIVE_
AGREEMENTS

Collective Agreements
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Title Table Name Window Title

Further Competence Element
Information

PER_COMPETENCE_
ELEMENTS

Further Competence Element
Outcomes Information

PER_COMP_ELEMENT_
OUTCOMES

Further Competence
Information

PER_COMPETENCES Competencies

Further Competence
Outcomes Information

PER_COMPETENCE_
OUTCOMES

Further Contact Relationship
Information

PER_CONTACT_RELAT
IONSHIPS

Contacts

Further Contract Information
(Datetracked)

PER_CONTRACTS_F Contracts

Further Contribution History
Information

Further Disability Information
(Datetracked)

PER_DISABILITIES_F Disabilities

Further Election Information PER_ELECTIONS Election

Further Element Information
(Datetracked)

PAY_ELEMENT_TYPES_F Element

Further Element Entry
Information (Datetracked)

PAY_ELEMENT_ENTRIES_F Element Entry

Further Establishment
Information

PER_ESTABLISHMENTS Schools/Colleges

Further Form Properties HR_FORM_PROPERTIES People Management
Configurator (Form Object)

Further Item Properties HR_ITEM_PROPERTIES People Management
Configurator (Item Object)

Further Job Information PER_JOBS Job

Further Medical Assessment
Information

PER_MEDICAL_
ASSESSMENTS

Medical Assessment

Further Payment Method
Information (Datetracked)

PAY_ORG_PAYMENT_
METHODS_F

Organizational Payment
Method

Further Payroll Information
(Datetracked)

PAY_ALL_PAYROLLS_F Payroll

Further Period Details PER_TIME_PERIODS Payroll Periods
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Title Table Name Window Title

Further Period of Service
Information (Add’l Periods of
Service Information)

PER_PERIOD_OF_SERVICE Terminate

Further Person Information
(Datetracked)

PER_PEOPLE_F People, Applicant Entry

Further Previous Employer
Information

PER_PREVIOUS_EM
PLOYERS

Previous Employment

Further Previous Job
Information

PER_PREVIOUS_EM
PLOYERS

Previous Employment

Further Previous Job Usage
Information

PER_PREVIOUS_JOB_
USAGES

Previous Job

Further Qualification
Information

PER_QUALIFICATIONS Qualifications

Further Role Information PER_ROLES Supplementary Roles

Further Subject Information PER_SUBJECTS_TAKEN Qualifications

Further Tab Page Properties HR_TAB_PAGE_PROPERT
IES_B

People Management
Configurator (Tab Page
Object)

Further Template Properties People Management
Configurator

Further Window Properties HR_WINDOW_PROPERT
IES_B

People Management
Configurator (Window Object)

Further Work Incident
Information

PER_WORK_INCIDENTS Work Incidents

Org Developer DF

State Tax Limit Rate
Information

Statutory Transaction
Information

Tax Signup Developer DF

Your localization team determines which of these flexfields are required for your
legislation, and what segments they should contain. The legislation of your business
group determines which developer descriptive flexfields are displayed. This means that
if your enterprise uses multiple business groups that have different legislations, different
developer descriptive flexfields are displayed for business groups of each legislation.

Caution: Do not attempt to alter the definitions of the protected
flexfields. These definitions are a fundamental part of Oracle
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HRMS. Any change to them may lead to errors in the operating of
the system.

It is possible that Oracle HRMS will use other segments of these
flexfields in the future. Therefore, do not add segments to any protected
flexfield, as this may affect your ability to upgrade your system in
the future.

Soft Coded Legislation Key Flexfield
This key flexfield holds legislation-specific information. The legislation of your business
group determines the flexfield structure that you see.

Each localization team defines a flexfield structure, if required, which enables you to
enter information specific to your legislation at the employee or contingent worker
assignment level.

Bank Details Key Flexfield
This flexfield holds legislation-specific bank account information. The legislation of your
business group determines the flexfield structure that you see. Each localization team
defines a flexfield structure that allows you to record the bank account information
relevant to your legislation. You enter this information in the Organizational Payment
Method window and Personal Payment Method window.

Creating Key Flexfield Database Items
The Create Key Flexfield DB Items process turns data in key flexfields into database items
that Oracle FastFormula can access. It is essential to run this process whenever you
create or change the Grade, Job, Position, or People Group key flexfield definitions.

Submit the process from the Submit Requests window.

To create key flexfield database items:
1. Run the Create Key Flexfield DB Items process.

Run this process whenever you create or change these key flexfield definitions.

See: Running Reports and Programs, Oracle Applications User's Guide

Setting up the Job Key Flexfield
You define the Job key flexfield to hold information about the work structure that exists
in your Business Group. The Job key flexfield stores the occupational series information.

To set up the Job key flexfield:
1. In the Key Flexfield Segments window, create a new Job Key Flexfield structure and

name it, for example, US Government Job.

2. In the Segments Summary window, define the first segment for the occupational jobs
series using the supplied value set GHR_US_OCC_SERIES.

3. Note the Name and Column fields for the occupational series segment. You refer to
this information during implementation.
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Setting up the Position Key Flexfield
You define the Position key flexfield to hold information about the work structure that
exists in your Business Group. The Position key flexfield stores the position title, agency
code, and other position-related information.

To set up the Position key flexfield:
1. In the Key Flexfield Segments window, create a new Position Key Flexfield structure

and name it, for example, US Federal Position

2. In the Segments Summary window, you must define four required US Federal
Position segments using the supplied value sets.

• Define Position Title (GHR_US_POSITION_TITLE) using one of the first five
segments (Segment 1, 2, 3, 4, or 5)

When you define the Position Key Flexfield, you must define the Position Title
as one of the first five segments of the Position Key Flexfield structure. By
restricting the location of the Position Title to one of these segments, you
improve the performance of the To Position LOV (Lookup Value) on the Request
for Personnel Action (RPA) form.

• Using the remaining segments, define Position Description Number (GHR_US_
POS_DESC_NUM), Sequence Number (GHR_US_SEQUENCE_NUM), and
Agency/Subelement Code (GHR_US_AGENCY_CODE).

3. Note the Name and Column fields for the four position segments. You refer to this
information during implementation.

4. You can define up to 30 segments within the structure.

For the segments that you add, you can define a list of valid codes or values.

See: User Definable Key Flexfields, page 3-5

Creating Descriptive Flexfield Database Items
You can use descriptive flexfield segments in QuickPaint reports and formulas if there
are database items for these segments.

See Descriptive Flexfield List, page 3-10 for a list of flexfields for which you can create
database items.

Submit the process from the Submit Requests window.

To create descriptive flexfield database items:
1. Run the Create Descriptive Flexfield DB Items process.

Run this process whenever you create or change these descriptive flexfield
definitions.

See: Running Reports and Programs, Oracle Applications User's Guide

Note: The process can only create database items for global
segments. It does not create database items for context-sensitive
segments.
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Changing Default National Address Styles
National address styles, both international and local, are held and configured in the
Personal Address Information and the Location Address descriptive flexfields. You can
configure these styles using the Descriptive Flexfield Segments window.

You cannot construct any flexfield segment value sets with:

• Profile options, $PROFILE$

• Previous segment values, $FLEX$

• Block.field references

• Security rules

Note: You must ensure the Personal_Address or Location_Address
protected flag is off.

To change the address style for any country, redefine those segments you do not want to
use. Then define new segments to record your own information.

To alter an existing address style:
1. Enter Oracle Human Resources in the application field.

2. Enter Personal Address Information or Location Address in the title field as
appropriate.

3. Run the query.

4. Uncheck the Freeze Flexfield Definition check box.

Note: Read the warning.

5. Select the address style for your country.

Note: Both international and local address styles are included in
the list of context field values.

6. Click the segments button.

This opens a new window with the segment and value set information for the
selected address style.

7. Update the segments.

Note: You must make the Country segment mandatory. Do not
change the validation on any segment as this may invalidate
existing data.

8. Save your work, and open the Descriptive Flexfield Segments window. Make sure
any new segments are enabled, and displayed.

9. Check the Freeze Flexfield Definition check box.

10. Choose the Compile button.

When compilation is complete, exit your current login session, then log in again to
see your updated styles.
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To add an address style:
1. Enter Oracle Human Resources in the application field.

2. Enter Personal Address Information or Location Address in the title field as
appropriate.

3. Run the query.

4. Uncheck the Freeze Flexfield Definition check box.

Note: Read the warning.

5. Choose New from the File menu.

6. Enter the country code in the code and name fields.

7. Enter a description and select the Segments button.

8. Define the segments.

Note: You can only use the columns provided by Oracle HR for
your segments.

9. Save your work.

Note: Make sure any new segments are enabled. You can choose
whether segments are displayed or not.

10. Check the Freeze Flexfield Definition check box.

11. Choose the Compile button.

When compilation is complete, exit your current login session. Then log in again to
see your updated styles.
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Extra Information Types

Extra Information Types (EITs)
Extra Information Types are defined using descriptive flexfields. You can set up any
number of different EITs for:

• Location

• Job

• Position

• Person

• Assignment

• Organization

• Element types

• Previous Job

• Contacts

• Role

Note: EITs for Organization are different because you can define which
organization classification the EIT is available for.

For each EIT you can define up to 30 fully validated segments of information (or
20 for organizations).

Note: Oracle HRMS provides some predefined EITs. You may add your
own information types, but you must not change the definitions of
the delivered EITs.

Unlike the usual descriptive flexfields, EITs are child entities with separate tables to hold
the information you enter. This means that you can have multiple instances of an EIT
for each main record. When you define the EIT, you can specify whether you want to
allow multiple instances. With the exception of organizations, EIT data is viewed and
entered in a separate window which you can task flow.

The windows for all the EITs have the common look and feel of all the descriptive
flexfield windows. This means that you can use your new EITs as soon as you save your
definitions. Since flexfield definitions are preserved through upgrades, EITs do not
require expensive recoding of configured forms with each new release.

For information about predefined EITs, see: Location Extra Information Types, page
3-36, Organization Extra Information Types, page 3-36, Person Extra Information Types,
page 3-38, Position Extra Information Types, page 3-47, Assignment Extra Information
Types, page 3-33.

Key Flexfield Combinations
EITs are very similar to Special Information Types (SITs). Oracle enables you to choose
whether to set up extra or special information types, or both. Both types of information
use flexfields to define the structure and validation of their segments.
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However, SITs are stored in a key flexfield combination table where the combination of
segments must be unique - a feature of all key flexfields. EITs are stored in a descriptive
flexfield table where the combination of segment values do not need to form a unique key.

This means that EITs have performance advantages in large scale, or global
implementations where you may want to transfer large volumes of information between
separate installations.

Dates and EITs
EITs are not datetracked. Even if the parent entity, for example People, is datetracked, the
extra information is not. However, if you want to track changes to specific EITs you
can define date segments for Start and End Dates and use multiple rows of the EIT
to track changes.

Extra Information Validation
The Extra Information flexfields have required data items that you must complete
boefore saving the record. The Position Extra Information flexfield contains a Validate
button, so that you can simultaneously save your changes and validate the data.

The system checks the data and notifies you in an error message if it finds any
inconsistent data. You can then make the required corrections, and then choose the
Validate button again to save and validate the data.

EITs and Security
Both special and extra information types use CustomForm and task flow security to
restrict access to information. This means that you can restrict access to the information
types as part of a specific user process. For example, in a "Transfer to the UK" process
you might want to enter additional UK specific information. You could design your user
process to include a "UK Info" window as part of the task flow and restrict the window
to display only the UK information type.

To provide extra security for EITs, you must associate each EIT with the responsibilities
that should have access to the information. For example. you might record details of
an extended leave of absence in an EIT for an assignment and provide access only to
managers who need to know.

Restricting Access to Extra Information
You can restrict access to EITs using a combination of the following:

• Menus and task flows : Without the EIT window a user cannot see or change
any extra information for the entity.

• CustomForm and task flows: This restricts EITs to specific user processes.

For example, at the person level you might define EITs to hold medical
details, security information and information required for working in other
countries. In this situation you might want to create two task flows, the first with a
button for entering only medical details and the second with a button for entering
the other types of extra information

• Responsibility level security: For each responsibility, you must select the EITs to be
viewed. CustomForm and task flow restrictions provide additional security. You
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might specify that a responsibility can access an EIT, but users of this responsibility
will not be able to view the extra information unless they have access to a window
that displays it.

Note: This security does not apply to extra information on organizations.

Example Script for Registering Extra Information Types (EITs)
If you have created new organization EITs, you must create a SQL script to insert a row
for each EIT into the relevant information type table. This is known as registering
your information type. When you create your script, you can use the sample script
provided as a guide.

Note: If you have created non-organization EITs, you use the concurrent
process Register Extra Information Types (EITs) instead.

See: Register Extra Information Types (EITs), page 3-32
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Example Script to Register EITs
WHENEVER SQLERROR EXIT FAILURE ROLLBACK
REM /* $Header: example.sql $ */
REM =============================================
REM SQL Script File Name : example.sql
REM Description : This sql script inserts information
REM 1) HR_ORG_INFORMATION_TYPES
REM 2) HR_ORG_INFO_TYPES_BY_CLASS
REM =========================================
WHERE not exists (SELECT 1
--1) Insert into HR_ORG_INFORMATION_TYPES:---
-- Note different parameter value for single and multi-row
-- Note different parameters for this EIT
INSERT INTO HR_ORG_INFORMATION_TYPES
(ORG_INFORMATION_TYPE
,DESCRIPTION
,DESTINATION
,DISPLAYED_ORG_INFORMATION_TYPE
,FND_APPLICATION_ID
,LEGISLATION_CODE
,NAVIGATION_METHOD
)
SELECT
’<Organization EIT Name>’
,’<Description>’
,NULL
,’<Display value on the Organization form>’
,NULL
,’<legislation code US/GB/etc>’
,’<GM for multi-row - GS for single>’
FROM sys.dual
WHERE not exists (SELECT 1
FROM HR_ORG_INFORMATION_TYPES
WHERE ORG_INFORMATION_TYPE = ’<Organization EIT Name>’);
INSERT INTO HR_ORG_INFO_TYPES_BY_CLASS
(ORG_CLASSIFICATION
,ORG_INFORMATION_TYPE
,MANDATORY FLAG)
SELECT
’<Check lookup value for classification HR_BG for Business Group>’
, ’<Organization EIT Name>’
,’N’
FROM sys.dual
WHERE not exists (SELECT 1
FROM HR_ORG_INFO_TYPES_BY_CLASS
WHERE ORG_INFORMATION_TYPE = ’<Organization EIT Name>’
and
ORG_CLASSIFICATION = ’< HR_BG for Business Group>’);
/
COMMIT;
EXIT;

Setting Up Extra Information Types (Excluding Organization EITs)
The following steps explain how to set up Extra Information Types (EITs) to use in
Oracle HRMS.
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Note: EITs for organizations are set up differently. See: Setting Up Extra
Information Types for an Organization Classification, page 3-29

1. In the Descriptive Flexfield Segments window, select the relevant descriptive flexfield
by title (for example, Extra Job Information). The descriptive flexfields available are:

• Extra Location Information (30 Segments)

• Extra Job Information (30 Segments)

• Extra Position Information (30 Segments)

• Extra Person Information (30 Segments)

• Extra Element Information (30 Segments)

• Further Assignment Information (30 Segments)

• Previous Extra Job Information (30 Segments)

• Contact Extra Information (30 Segments)

2. Unprotect the relevant extra information type using the Register Descriptive
Flexfield window. You must do this before you can query the flexfield in the
Descriptive Flexfield window.

3. Create a new record in the Context Field Values region of the Descriptive Flexfield
window and enter the name of your new Information Type in the Code field. As
these are context-sensitive descriptive flexfields, enter INFORMATION_TYPE
in the Reference Field.

4. Enter the segment values and compile in the same way as a standard descriptive
flexfield.

See: Defining Descriptive Flexfield Structures, Oracle Applications Flexfields Guide

Important: There are some predefined EITs in Oracle HRMS. These
definitions are a fundamental part of your Oracle HRMS installation
and any change to them may lead to errors in the operation of the
system. Do not attempt to alter the definitions of these developer
flexfields or to add other segments to them. It is possible that
Oracle will use other segments of these flexfields in the future. Any
changes you make may affect your ability to upgrade your system
in the future.

For US Federal users: Do not prefix EIT definitions with
GHR_US. This prefix is reserved for the predelivered US Federal
definitions.

5. Reset the protection in the Register Descriptive Flexfield window so the flexfield
remains a protected descriptive flexfield.

6. Run the Register Extra Information Types (EITs) concurrent program to insert
a row for each EIT into the relevant Information Type table. The following table
lists the tables for each EIT.
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Extra Information Type Tables

EIT Table

Location HR_LOCATION_INFO_TYPES

Job PER_JOB_INFO_TYPES

Position PER_POSITION_INFO_TYPES

Person PER_PEOPLE_INFO_TYPES

Assignment PER_ASSIGNMENT_INFO_TYPES

Previous Job PER_PREV_JOB_INFO_TYPES

Contact PER_CONTACT_INFO_TYPES

Important: Oracle applications use a standard 2- or 3-character
product prefix followed by an underscore to name the predefined
EITs. To avoid current and future naming conflicts, you should
adopt a different naming convention for your Extra Information
Types; for example CUSTOM_EXPAT_TAXABILITY.

7. Use the Information Types Security window to set up responsibility level access
to EITs.

See: Setting Up Extra Information Types Against a Responsibility, page 3-31

Your EIT will now be available anyone using the specified responsibilities. If you
want to set up further security using CustomForm and task flow, continue with
the next step.

8. Use the Form Customization window to restrict access to specific EITs within the
appropriate windows.

See: Configuring a Window using CustomForm, page 3-327

9. Use the Define Task Flow Nodes window to define new nodes for any CustomForm
restrictions you have set up.

See: Defining Task Flow Nodes, page 3-257

10. Use the Define Task Flow window, or use Oracle Workflow, to define and change
task flows to include any new nodes you have set up.

See: Creating Task Flows Using Forms, page 3-256

See: Creating Task Flows Using Workflow, page 3-260

Setting Up Extra Information Types for an Organization Classification

To add Extra Information Types (EITs) to an organization cla ssification:
1. Define a new organization classification. You do not need to do this if you are setting

up an EIT for a classification that already exists.

Extending Oracle HRMS 3-29



Note: To define a new classification, enter a new value for the
Lookup type ORG_CLASS in the Lookup Values window.

2. Define the new EIT. See: Entering Table Values, page 3-114

• Unprotect the Org Developer DF using the Register Descriptive Flexfield
window. You must do this before you can query the flexfield on the Descriptive
Flexfield window

• Add the new structure for the EIT to the Org Developer DF descriptive flexfield
using the Descriptive Flexfield Segments window. The structure must have as its
context the name of the extra information type, and as this is a context sensitive
descriptive flexfield you must enter C_ORG_INFORMATION_CONTEXT in the
Reference Field. Compile in the same way as a standard descriptive flexfield.

• Reset the protection, so the flexfield remains a protected descriptive flexfield.

3. Enter a row into HR_ORG_INFORMATION_TYPES. The columns you need to
enter are shown in the following table:

Column name Description

ORG_INFORMATION Name of the type (same as DDF context).

DESCRIPTION Description of the extra information type.

DISPLAYED_ORG_
INFORMATION_TYPE

The Name of the Extra Information Type displayed in the
Organization window.

NAVIGATION_METHOD "GS" for single row, a user can only enter one extra
information row for each organization. Alternatively, "GM"
for multi row, a user can enter more than one row for each
organization.

LEGISLATION_CODE Optionally, you can enter a legislation code to restrict to
which business groups the EIT is available. If you do not
enter a legislation code it will be valid for all business
groups.

4. Specify for which organization classifications this EIT should be available.

To do this, enter a row into HR_ORG_INFO_TYPES_BY_CLASS as shown in the
following table:

Column name Description

ORG_CLASSIFICATION ORG_CLASS lookup code

ORG_INFORMATION_TY
PE

Org extra information type

MANDATORY_FLAG Y (for Yes) or N (for No)
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Setting Up Extra Information Types For a Responsibility
Before a user can access an Extra Information Type (EIT), you must attach the EIT to the
user’s responsibility. By not adding information types to a responsibility, you restrict the
information types that a user can access.

Note: You can select EITs for any legislation to add to a responsibility
in this window. Users of the Oracle HRMS professional user interface
are restricted to seeing the information types for the legislation of
the business group to which they have access. Self-service users are
restricted to seeing information types for the legislation of the record
they are working with.

Use the Information Type Security window to link EITs to a responsibility.

To set up EITs for a responsibility:
1. Select the name of the responsibility to which to attach the EIT.

Oracle HRMS displays a list of EITs already associated with the responsibility
you have chosen.

2. Enter or select the new EIT you want to link to the responsibility.

3. Save your work.

To copy EITs between responsibilities:
1. Query the responsibility from which you want to copy.

2. Select the Copy Responsibility button

3. Enter the responsibility to which you want to copy.

This responsibility is then displayed with the new EITs.

4. Save your work.

Entering Extra Information
The RPA contains a taskflow button that displays Extra Information that’s required
before you update the RPA to the HR database..

From the RPA you can also taskflow to the Job, Position, Person, and Location forms
to enter or change Extra Information that does not accompany the specific personnel
action that you’re processing, such as a change in position data when processing
an appointment.

To enter Extra Information in the RPA:
1. Choose Extra Information.

2. Choose the Extra Information type that you want to display.

3. Place your cursor in the Details field and click the mouse field to view or enter
Extra Information data.

The Details field is blank unless you have previously entered data in the flexfield or
the system has entered data after updating a Request for Personnel Action.

4. Enter information in the appropriate segments.
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To access Extra Information in the People, and Assignment wi ndows:
1. Choose the Others taskflow button.

2. Choose Extra Information.

3. Choose the Extra Information type that you want to display.

4. Place your cursor in the Details field and click the mouse field to view or enter
Extra Information data.

The Details field is blank unless you have previously entered data in the flexfield or
the system has entered data after updating a Request for Personnel Action.

Running the Register Extra Information Types (EITs) Process
Use this process to register any new Extra Information Types (EITs) (excluding
Organization EITs).

You run this process from the Submit Requests window.

To run the Register Extra Information Types (EITs) process:
1. In the Name field, select Register Extra Information Types (EITs).

The Parameters window opens.

2. In the Table Name field, select the table in which the EIT will be registered.

3. In the Information Type field, select the extra information type created in the
Descriptive Flexfield Segments window. The value in the Table Name field
determines which information types are available.

4. In the Multiple Rows field, specify whether multiple occurrences of the same
infotype can exist.

5. In the Legislation Code field, select the legislation code for the information type. The
default value is the legislation code of the current business group.

Note: If the information type is global, the legislation code value
should be Null.

6. Optionally, enter a description for information type.

7. Choose the Submit button.
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US Federal InformationTables

Assignment Extra Information Types

Assignment Information Type Name: US Federal Assignment NTE Dates
(GHR_US_ASG_NTE_DATES)

Description Lookup Type
Name

Type Req. Remarks

Assignment NTE
Start Date

none D none none

Assignment NTE none D none none

LWOP NTE Start
Date

none D none none

LWOP NTE none D none none

Suspension NTE
Start Date

none D none none

Suspension NTE none D none none

Furlough NTE
Start Date

none D none none

Furlough NTE none D none none

LWP NTE Start
Date

none D none none

LWP NTE none D none none

Sabbatical NTE
Start Date

none D none none

Sabbatical NTE none D none none
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Assignment Information Type: US Federal Assignment Non-RPA (GHR_US_ASG_NON_
SF52)

Description Lookup Type
Name

Type Req. Remarks

Date Arrived
Personnel Office

none D none none

Duty Status GHR_US_
DUTY_STATUS

X none validate segment
with the Lookup
type: no values
seeded

Key Emergency
Essential Empl

GHR_US_
ASGN_KEY_
EMERG_ESSEN

X none none

Non-Disclosure
Agmt Status

GHR_US_NON_
DISCLOSURE_
AGREE

X none none

Date WTO
P Exemption
Expires

none D none none

Part-time
Indicator

GHR_US_PART_
TIME_IND
ICATOR

X none none

Qualification
Standards
Waiver

GHR_US_
QUAL_STND_
WAIVER

X none validation: none

Trainee
Promotion ID

GHR_US_TRA
INEE_PROMOT
ION_ID

X none none

Date Trainee
Promotion
Expect

none D none none
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Assignment Information Type: US Federal Assignment RPA (GHR_US_ASG_SF52)

Description Lookup Type
Name

Type Req. (R) Remarks

Step or Rate GHR_US_STEP X R Step-In-Grade-
Civ

Tenure GHR_US_
TENURE

X R none

Annuitant
Indicator

GHR_US_
ANNUITANT
INDICATOR

X R none

Pay Rate
Determinant

GHR_US_PAY_
RATE_DETERM
INANT

X R none

Work Schedule GHR_US_
WORK_
SCHEDULE

X R duplicate of
Work Schedule in
Position Group 1

Part-Time Hours
Biweekly

GHR_US_PART_
TIME_HOURS

N none min 0, max 199.99

Assignment Information Type Name: US FEDERAL ASSIGNMENT PROBATIONS
GHR_US_ASG_PROBATIONS

Description Lookup Type
Name

Type Req. Remarks

Date Initial
Probationary
Period Begins

none D none none

Date Initial
Probationary
Period Ends

none D none none
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Location Extra Information Type

Location Information Type: US Federal Location Information (GHR_US_LOC_INFORMAT
ION)

Description Lookup Type
Name

Type Req. Remarks

Duty Station ID * GHR_US_
DUTY_STAT
ION_ID

N * Duty Station
Code/Loc Area/
Loc Percent

* Duty Station ID is stored. The application retrieves and displays the Duty Station Code
and Description from the GHR_DUTY_STATIONS_F table.

Organization Extra Information Types
The following Value Sets and Lookup Types will be used in the Job and Position Key
Flexfields. See the Position Key Flexfield and Job Key Flexfield for additional details.
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Organization Information Type: US Federal Organization Information (at Business Group
level) GHR_US_ORG_INFORMATION

Description Lookup Type
Name

Type Req. Remarks

Occupational
Series (map to
Value Set GHR_
US_JOB_KFF_
SEGMENT)

sql script X X field size in Job
must be 4

Position Title
(map to Value
Set GHR_US_
POSITION_KFF_
SEGMENT)

sql script X X field size must
be 60, validation:
none

Position Descrip
Num (map to
Value Set GHR_
US_POSITION_
KFF_SEGMENT)

sql script X X field size in
Position must
be 15, validation:
none

Sequence
Number (map to
Value Set GHR_
US_POSITION_
KFF_SEGMENT)

sql script N field size in
Position must
be 15, validation:
none

Agency/
Subelement
Code (map to
Value Set GHR_
US_POSITION_
KFF_SEGMENT)

sql script X X DINs JRB and
JRC, field size
must be 4

The following is additional information about GHR_US_ORG_INFORMATION:

• Occupational Series Value Set and Lookup Type: GHR_US_OCC_SERIES and its
values are predefined (table "occcode").

• Position Title Value Set: GHR_US_POSITION_TITLE is predefined but not its values.

• Position Descrip Num Value Set: GHR_US_POS_DESC_NUM is predefined but
not its values.

• Sequence Number Value Set: GHR_US_SEQUENCE_NUM is predefined but not its
values.

• Agency/Subelement Code Value Set and Lookup Type: GHR_US_AGENCY_CODE
and its values are predefined (table "255").

Extending Oracle HRMS 3-37



Organization Information Type: US Federal Org Reporting Info (at HR Organization level)
GHR_US_ORG_REPORTING_INFO

Description Lookup Type
Name

Type Req. Remarks

Agency /
Subelement
Code

GHR_US_
AGENCY_
CODE

X

Organization
Structure ID

GHR_US_ORG_
STRUCTURE_ID

X validation: none

Org Info Line 1 X validation: none

Org Info Line 2 X validation: none

Org Info Line 3 X validation: none

Org Info Line 4 X validation: none

Org Info Line 5 X validation: none

Org Info Line 6 X validation: none

OCT
Organizational
Title

X validation: none

Person Extra Information Types

Person Information Type: US Federal Person RPA (GHR_US_PER_SF52)

Description Lookup Type
Name

Type Req. Remarks

Citizenship GHR_US_CIT
IZENSHIP

N *

Veterans
Preference

GHR_US_
VETERANS_
PREF

N *

Veterans
Preference for
RIF

GHR_US_
VETERANS_
PREF_FOR_RIF

X *

Veterans Status GHR_US_VET_
STATUS

X *
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Person Information Type Name: US Federal Person Group 1 (GHR_US_PER_GROUP1)

Description Lookup Type
Name

Type Req. Remarks

Appointment
Type

GHR_US_APPO
INTMENT_TY
PE

X

Type of
Employment

GHR_US_TYPE_
EMPLOYMENT

X

Race or National
Origin

GHR_US_
RACE_NAT
IONAL_ORIGIN

X

Date Last
Promotion

D

Agency Code
Transfer From

GHR_US_
AGENCY_
CODE

X LOV same as
Agency Code

Current
Appointment
Auth (1)

GHR_US_
LEGAL_
AUTHORITY

X

Current
Appointment
Auth (2)

GHR_US_
LEGAL_
AUTHORITY

X

Country World
Citizenship

GHR_US_
CNTRY_WRLD_
CTZN

X

Handicap Code GHR_US_
HANDICAP_
CODE

X Handicap
Reportable

Consent ID GHR_US_
CONSENT_ID

X validation: none

Date FEHB
Eligibility
Expires

D

Date Temp
Eligibility FEHB

D

Date FEHB
Dependent Cert
Expir

D
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Description Lookup Type
Name

Type Req. Remarks

Family Member
Employment
Pref

GHR_US_
FAM_MBR_EM
PLMNT_PREF

X

Family Member
Status

GHR_US_FAM
ILY_MEMBER_
STATUS

X

Person Information Type: US Federal Person Group 2 (GHR_US_PER_GROUP2)

Description Lookup Type
Name

Type Req. Remarks

Obligated
Position Number

GHR_US_OBL
IG_POSN_NUM

X display length
on screen must
not change,
validation: none

Obligated
Position Type

GHR_US_OBL
IG_POSN_TYPE

X validation: none

Date Overseas
Tour Expires

D

Date Return
Rights Expire

D

Date Statutory
Ret Rights Exp

D

Civilian Duty
Stat Contingency

GHR_US_CIV_
DTY_STATUS_
CONT

X

Date Travel
Agmt PCS
Expires

D Permanent
Change in
Station

Drawdown
Action ID

GHR_US_
DRAWDOWN_
ID

X
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Person Information Type: US Federal SCD Information (GHR_US_PER_SCD_INFORMATION)

Description Lookup Type
Name

Type Req. Remarks

SCD Leave D *

SCD Civilian D

SCD RIF D

SCD TSP D

SCD Retirement D

Person Information Type: US Federal Probations (GHR_US_PER_PROBATIONS)

Description Lookup Type
Name

Type Req. Remarks

Date Prob/Trial
Period Begins

D

Date Prob/Trial
Period Ends

D

Date Spvr/Mgr
Prob Ends

D

Spvr/Mgr Prob
Completion

GHR_US_SUPV_
MGR_PROB_
COMP

X

Date SES Prob
Expires

D

Extending Oracle HRMS 3-41



Person Information Type: US Federal Retained Grade (GHR_US_RETAINED_GRADE)

Description Lookup Type
Name

Type Req. Remarks

Date From X

Date To X

Retained Grade GHR_US_
GRADE_OR_
LEVEL

X

Retained Step or
Rate

GHR_US_STEP X

Retained Pay
Plan

GHR_US_PAY_
PLAN

X

Retained Pay
Table ID

GHR_US_PAY_
TABLE_ID

X seed partial list
of pay tables

Retained Pay
Basis

GHR_US_PAY_
BASIS

X

Temporary
Promotion Step

GHR_US_STEP X
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Person Information Type: US Federal Separation and Retirement (GHR_US_PER_SEPARATE_RETIRE)

Description Lookup Type
Name

Type Req. Remarks

FERS Coverage GHR_US_FERS_
COVERAGE

X

Previous
Retirement
Coverage

GHR_US_PREV_
RETIRE_COVER

X

Frozen Service GHR_US_
FROZEN_SERV
ICE

N validation: none

NAF Retirement
Indicator

GHR_US_NAF_
RETIRE_INDIC

X

Reason for
Separation

GHR_US_SE
PARATION_
REASON

X

Agency Code
Transfer To

GHR_US_
AGENCY_
CODE

X LOV same as
Agency Code

Date Projected
Retirement

D

Mandatory
Retirement Date

D

Separate Pkg
Status Indicator

GHR_US_SE
P_PKG_STAT_
INDCTR

X

Separate Pkg
Register Number

GHR_US_SEP_
PKG_REG_NUM

X no LOV, free
form number,
validation: none

Separate Payroll
Office Number

GHR_US_SEP_
PAYROLL_OFF
ICE_NO

X validation: none

Date Ret
Application
Received

D

Date Ret Pkg
Sent to Payroll

D

Date Ret Pkg
Received Payroll

D

Date Ret Pkg to
OPM

D
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Person Information Type: US Federal Security (GHR_US_PER_SECURITY)

Description Lookup Type
Name

Type Req. Remarks

Sec Investigation
Basis

GHR_US_SEC_
INVEST_BASIS

X validation: none

Type of Sec
Investigation

GHR_US_TYPE_
SEC_INVEST
IGATN

X validation: none

Date Sec Invest
Required

D

Date Sec Invest
Completed

D

Personnel Sec
Clearance

GHR_US_PERS_
SEC_CLEAR

X validation: none

Sec Clearance
Eligibility Date

D

PRP/SCI Status
Employment

GHR_US_PRP/
SCI_STATUS

X

Person Information Type Name: US Federal Conversions (GHR_US_PER_CONVERSIONS)

Description Lookup Type
Name

Type Req. Remarks

Date Conversion
Career Begins

D

Date Conversion
Career Due

D

Date Recmd
Conversion
Begins

D

Date VRA
Conversion Due

D

Date Recmd
Conversion Due

D display as
segment 4,
before Date VRA
Conversion Due
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Person Information Type Name: US Federal Uniformed Services (GHR_US_PER_UNIFORMED_SERVICES)

Description Lookup Type
Name

Type Req. Remarks

Reserve
Category

GHR_US_
RESERVE_
CATEGORY

X

Military Recall
Status

GHR_US_MIL
ITARY_RECALL

X

Creditable
Military Service

GHR_US_CRED
IT_MIL_SVC

N validation: none

Date Retired
Uniform Service

FND_
STANDARD_
DATE

D

Uniform Service
Component

GHR_US_UN
IFRM_SRVC_
COMPONT

X

Uniform Service
Designation

GHR_US_UN
IFRM_SRVC_
DESGNATN

X

Retirement
Grade

GHR_US_RET
IREMENT_
GRADE

X

Military
Retirement
Waiver Ind

GHR_US_MIL_
RETIREMNT_
WAIVER

X

Exception
Retirement Pay
Ind

GHR_US_EXCE
PTION_RET
IREMENT

X

Person Information Type: US Federal User Information (GHR_US_PER_USER_INFO)

Description Lookup Type
Name

Type Req. Remarks

Restricted Form GHR_US_RESTR
ICTED_FORM

X *seeding only
one item
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Person Information Type: US Federal Workflow Routing Groups (GHR_US_PER_WF_ROUTING_GROUPS)

Description Lookup Type
Name

Type Req. Remarks

Routing Group
Name

GHR_US_ROUT
ING_GROUP

N * not seeded, but
validated

Initiator YES_NO X *

Requester YES_NO X *

Authorizer YES_NO X *

Personnelist YES_NO X *

Approver YES_NO X *

Reviewer YES_NO X *

Default Routing
Group

YES_NO X *

Person Information Type Name: US Federal Mass Action (GHR_US_PER_MASS_ACTION)

Description Lookup Type
Name

Type Req. Remarks

Mass Salary
Selcetion Flag

HR_US_YES_
NO

Mass Salary
Comments

Mass Salary
Name

GHR_US_
MASS_
SALARY_NAME

Mass Transfer In
Flag

HR_US_YES_
NO

Mass Transfer In
Comments

Mass Transfer In
Name

GHR_US_
MASS_
TRANSFERS_
IN_NAME

Agency Code
Transfer To

GHR_US_
AGENCY_
CODE

display size of
four
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Position Extra Information Types

Position Information Type: US FEDERAL MASS ACTIONS (GHR_US_POS_MASS_ACT
IONS)

Description Look-up Type
Name

Type Req. Remarks

Mass
Realignment
Flag

HR_US_YES_
NO

Mass
Realignment
Comments

Personnel Office
ID

GHR_US_
PERSONNEL_
OFFICE_ID

Agency Code
/ Subelem

GHR_US_
AGENCY_
CODE

Duty Station
Code

GHR_US_
DUTY_STAT
ION_ID

Office Symbol GHR_US_OFF
ICE_SYMBOL

Payroll Office ID GHR_US_
PAYROLL_OFF
ICE

Organization
Function Code

GHR_US_ORG_
FUNC_CODE

Appropriation
Code 1

GHR_US_AP
PROPRIATION_
CODE1

Appropriation
Code 2

GHR_US_AP
PROPRIATION_
CODE2

Position’s
Organization

GHR_US_
ORGANIZAT
ION_ID

Mass
Realignment
Name

GHR_US_
MASS_REAL
IGNMENT_
NAME

Mass Transfer
Out Flag

HR_US_YES_
NO
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Description Look-up Type
Name

Type Req. Remarks

Mass Transfer
Out Comments

Mass Transfer
Out Name

GHR_US_
MASS_
TRANFERS_
OUT_NAME

Position Information Type: US FEDERAL POSITION DESCRIPTION (GHR_US_POSITION_DESCRIPTION)

Description Look-up Type
Name

Type Req. Remarks

Date From D

Date To D

Position
Description ID

GHR_US_POSIT
ION_DESCRIPT
ION

N SQL validated
from GHR_POS
ITION_DESCRI
PTION

Position Information Type: US FEDERAL POSITION GROUP 1 (GHR_US_POS_GRP1)

Description Look-up Type
Name

Type Req. Remarks

Personnel Office
ID

GHR_US_
PERSONNEL_
OFFICE_ID

X * OPM supported
codes

Office Symbol GHR_US_OFF
ICE_SYMBOL

X validation: none

OPM
Organizational
Component

GHR_US_ORG_
STRUCTURE_ID

X * required input,
validation: none

Occupation
Category Code

GHR_US_OCC_
CATEGORY_
CODE

X formerly titled
PATCOB

FLSA Category GHR_US_FLSA_
CATEGORY

X *

Bargaining Unit
Status

GHR_US_
BARG_UNIT_
STATUS

X *

Competitive
Level

GHR_US_COM
P_LEVEL

X validation: none
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Description Look-up Type
Name

Type Req. Remarks

Work Schedule GHR_US_
WORK_
SCHEDULE

X * duplicate of
Work Schedule
in Assignment
SF52

Functional Class GHR_US_
FUNCTIONAL_
CLASS

X

Position Working
Title

GHR_US_
WORKING_T
ITLE

X Duty Title
LN Psn Title,
validation: none

Position
Sensitivity

GHR_US_
POSN_SENSIT
IVITY

X

Security Access GHR_US_
SECURITY_
ACCESS

X

PRP/SCI GHR_US_
SECURITY_PR
P/SCI

X PrsnlReliability
Prgm/
SnstvComprtmntd
Info

Supervisory
Status

GHR_US_SU
PERVISORY_
STATUS

X *

Type Employee
Supervised

GHR_US_TYPE_
EMP_SUPERV
ISED

X

Payroll Office ID GHR_US_
PAYROLL_OFF
ICE

X Agency
designated
codes, validate
with GHR Look-
up type

Timekeeper GHR_US_T
IMEKEEPER

X DINs X5H, XHB,
XJE, validation:
none

Competitive
Area

GHR_US_COM
P_AREA

X display after
Competitive
Level above,
validation: none

Position’s
Organization *

GHR_US_
ORGANIZAT
ION_ID

N HR_ORGAN
IZATION_UN
ITS.ORGAN
IZATION_ID

Part-Time Hours
Bi-weekly

N min 0, max 199.99
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Description Look-up Type
Name

Type Req. Remarks

Supervisory Diff
Eligibility

GHR_US_SUPV_
DIFF_ELIG

X dislpay before
segment titled
Payroll Office ID

* The user should be presented with the HR Organization Name associated with this Org ID
(HR_ORGANIZATION_UNITS.NAME) when entering or querying.

Position Information Type: US FEDERAL POSITION GROUP 2 (GHR_US_POS_GRP2)

Description Look-up Type
Name

Type Req. Remarks

Position
Occupied

GHR_US_POS
ITION_OCCUP
IED

N * Service Type

Organization
Function Code

GHR_US_ORG_
FUNC_CODE

X validated but no
values are seeded

Date Position
Classified

D

Date Last
Position Audit

D

Classification
Official

GHR_US_
CLASSFCTN_
OFFICIAL

X

Language
Required

GHR_US_
LANGUAGE_
REQUIRED

X

Drug Test GHR_US_
DRUG_TEST

X

Financial
Statement

GHR_US_F
INANCIAL_
STATEMENT

X

Training
Program ID

GHR_US_
TRAINING_
PROGRAM_ID

X

Key Emergency
Essential

GHR_US_
KEY_EMERG_
ESSENTIAL

X

Appropriation
Code 1

GHR_US_AP
PROPRIATION_
CODE1

X
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Description Look-up Type
Name

Type Req. Remarks

Appropriation
Code 2

GHR_US_AP
PROPRIATION_
CODE2

X

Intelligence
Position Ind

GHR_US_
INTEL_POSN_
INDICATOR

X

LEO Position
Indicator

GHR_US_LEO_
POSN_IND
ICATOR

X

Position Type GHR_US_POSIT
ION_TYPE

X display as first
segment, default
value as Appr

Position Information Type: US FEDERAL POSITION OBLIGATED (GHR_US_POS_OBLIG)

Description Look-up Type
Name

Type Req. Remarks

Expiration Date D

Obligated Type GHR_US_OBL
IGATED_POSN_
TYPE

X

Obligated
Employee SSN

GHR_US_OBL
IGATED_EMPL_
SSN

X validation: none

Position Information Type: US FEDERAL VALID GRADE INFO (GHR_US_POS_VALID_GRADE)

Description Look-up Type
Name

Type Req. Remarks

Valid Grade X * seed data is value
from Grade Key
Flexfield

Target Grade X seed data is value
from Grade Key
Flexfield

Pay Table ID GHR_US_PAY_
TABLE_ID

X * seed partial list
of Pay Tables

Pay Basis GHR_US_PAY_
BASIS

X *

Employment
Category Group

GHR_US_EMP_
CAT_GRP

X
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US Federal Elements

Reporting Name: Accruals
The following tables list accrual elements.

Element Name: Home Leave

Description Input Value Units Look-up Type

Classification: PTO
Accrual

Category: Home
Leave

Type: Recurring

Multiple Occurrences:
No

Eligibility Date Eligibility Date Date

Accrual Days Per Year Accrual Days Per Year Int

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE

Number Days Home
Leave Auth

Days Authorized Num

Element Name: Hours Left to Work

Description Input Value Units Look-up Type

Classification: PTO
Accrual

Category: Balances

Type: Recurring

Multiple Occurrences:
No

Hours Left to Work Hours Left to Work Num
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Element Name: Intermittent Accrual

Description Input Value Units Look-up Type

Classification: PTO
Accrual

Category: Balances

Type: Recurring

Multiple Occurrences:
No

Days Intermittent
Worked

Days Worked Num

Days Intermittent
Worked SCD

Days Worked SCD Num

Hours Intermittent
Worked SCD

Hours SCD Num

Intermittent Work
Days Appraisal

Appraisal Days Num

Intermittent Days
Worked Career

Days Worked Career Num

Intermittent Days
Worked Probation

Days Worked
Probation

Num

Intermittent Days
Worked WGI

Days Worked WGI Num

Intermittent Days
Worked VRA

Days Worked VRA Num

Element Name: Non Pay Hours

Description Input Value Units Look-up Type

Classification: PTO
Accrual

Category: Balances

Type: Recurring

Multiple Occurrences:
No

Non Pay Hours Non Pay Hours Num
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Element Name: Non Pay Days

Description Input Value Units Look-up Type

Classification: PTO
Accrual

Category: Balances

Type: Recurring

Multiple Occurrences:
No

Non Pay Days
Probation

Probation Days Int

Non Pay Days SCD Non Pay Days for
SCD

Int

Non Pay Week Days
VRA

Non Pay Days for
VRA

Int

Element Name: Salary Left to Earn

Description Input Value Units Look-up Type

Classification: PTO
Accrual

Category: Balances

Type: Recurring

Multiple Occurrences:
No

Salary Left to Earn Salary Left to Earn Num
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Reporting Name: Awards

Element Name: Federal Awards

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Awards
& Prizes

Type: Non-recurring

Multiple Occurrences:
Yes

Award Agency Code Award Agency Char GHR_US_AGENCY_
CODE_2

Award Type Award Type Char GHR_US_AWARD_
TYPE

Amount of Incentive
Award

Amount or Hours Int

Performance Award
Percentage

Percentage Num

Date Award Earned Date Award Earned Date

Award Appropriation
Code

Appropriation Code Char GHR_US_APPROPR
IATION_CODE1

Date Ex Emp Award
Paid

Date Ex Emp Award
Paid

Date

Reporting Name: Adjusted Basic Pay

Element Name: Adjusted Basic Pay

Description Input Value Units Look-up Type

Classification:
Earnings

Category: Regular

Type: Recurring

Multiple Occurrences:
No

Adjusted Basic Pay Amount Num

Extending Oracle HRMS 3-55



Reporting Name: Basic Salary Rate

Element Name: Basic Salary Rate

Description Input Value Units Look-up Type

Classification:
Earnings

Category: Regular

Type: Recurring

Multiple Occurrences:
No

Basic Salary Rate Rate Num

Reporting Name: Entitlement

Element Name: Entitlement

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
Yes

Employee Entitlement
Code

Code Char GHR_US_ENT
ITLEMENT_CODE

Employee Entitlement
Amount or Percent

Amount or Percent Num
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Reporting Name: FEGLI

Element Name: FEGLI

Description Input Value Units Look-up Type

Classification:
Voluntary Deduction

Category: N/A

Type: Recurring

Multiple Occurrences:
No

FEGLI FEGLI Char GHR_US_FEGLI

Date Eligibility
Expiration

Eligibility Expiration Date

Reporting Name: Environmental Differential Pay

Element Name: EDP Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
Yes

Premium Pay
Indicator

Premium Pay Ind Char GHR_US_PREM_
PAY_IND

EDP Type EDP Type Char GHR_US_
HAZZARD_TYPE
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Reporting Name: Foreign Language Proficiency Pay

Element Name: Foreign Language Proficiency Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Certification Date Certification Date Date

Pay Level or Rate Pay Level or Rate Char GHR_US_PAY_
LEVEL_RATE
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Reporting Name: Foreign Transfer Allowance

Element Name: Foreign Transfer Allowance

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Non Recurring

Multiple Occurrences:
Yes

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE

Num Family
Members

Number Family
Members

Int

Miscellaneous
Expense

Miscellaneous
Expense

Num

Wardrobe Expense Wardrobe Expense Num

Pre-departure
Subsistence Expense

Pre-departure
Subsistence Expense

Num

Lease Penalty Expense Lease Penalty Expense Num

Total Authorized
Amount

Amount Num
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Reporting Name: Hazard Pay

Element Name: Hazard Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
Yes

Premium Pay
Indicator

Premium Pay Ind Char GHR_US_PREM_
PAY_IND

Hazard Type Hazard Type Char GHR_US_HAZARD_
TYPE

Reporting Name: Health Benefits

Element Name: Health Benefits

Description Input Value Units Look-up Type

Classification:
Voluntary Deduction

Category: N/A

Type: Recurring

Multiple Occurrences:
No

Health Enrollment Char

Health Plans Char

Total Cost Temp
Indicator

Int

Pre Tax Waiver Char

Premium Rate Num

LWOP Contingency
Start Date

Date

LWOP Contingency
End Date

Date
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Reporting Name: Health Benefits Pre-Tax

Element Name: Health Benefits Pre-Tax

Description Input Value Units Look-up Type

Classification: Pre-Tax
Deduction

Category: N/A

Type: Recurring

Multiple Occurrences:
No

Health Enrollment Enrollment Char GHR_US_
ENROLLMENT

Health Plans Health Plan Char GHR_US_HEALTH_
PLAN

Total Cost Temp
Indicator

Temps Total Cost Int GHR_US_TEMPS_
TOTAL_COST

LWOP Contingency
Start Date

LWOP Contingency
Start Date

Date

LWOP Contingency
End Date

LWOP Contingency
End Date

Date

Reporting Name: Intergovt Personnel Act IPA

Element Name: Intergovt Personnel Act IPA

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

IPA Local Salary
Amount

Amount Num
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Reporting Name: Locality Pay

Element Name: Locality Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Locality Adjustment Rate Int
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Reporting Name: MD/DDS Special Pay

Element Name: MD/DDS Special Pay

Description Input Value Units Look-up Type

Classification:
Earnings

Category: Regular

Type: Recurring

Multiple Occurrences:
No

Full Time Status
Amount

Full Time Status Num

Length of Service
Amount

Length of Service Num

Scarce Speciality
Amount

Scarce Speciality Num

Speciality or Board
Certification Amount

Speciality or Board
Certification

Num

Geographic Location
Amount

Geographic Location Num

Exceptional
Qualifications
Amount

Exceptional
Qualifications

Num

Executive Position
Amount

Executive Position Num

Dentist Post Graduate
Training

Amount Num

MD/DDS Total
Special Pay Amount

Amount Num

MD/DDS Special Pay
NTE Date

MD/DDS Special Pay
NTE Date

Date
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Reporting Name: Non Pay Hours WGI

Element Name: Non Pay Hours WGI

Description Input Value Units Look-up Type

Classification: PTO
Accrual

Category: Balances

Type: Recurring

Multiple Occurrences:
No

Non Pay Hours WGI Non Pay Hours WGI Num

Reporting Name: Other Pay

Element Name: AUO

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Premium Pay
Indicator

Premium Pay Ind Char GHR_US_PREM_
PAY_IND

AUO Pay Amount Int
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Element Name: Availability Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Premium Pay
Indicator

Premium Pay Ind Char *

Availability Pay Amount Int

Element Name: Supervisory Differential

Descrip tion Input Va lue Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Supervisory
Differential

Amount Int

Supervisory
Differential Percent

Percentage Num
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Element Name: Staffing Differential

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Staffing Differential Amount Int

Staffing Differential
Percent

Percent Num

Element Name: Retention Allowance

Descrip tion Input Va lue Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Retention Allowance
Percent

Percentage Num

Retention Allowance
Review Date

Date Date

Retention Allowance Amount Amt
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Element Name: Other Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Other Pay Amount Capped Amount Amt

Capped Other Pay Amount Amt

Capped Amount Yes/No Char

Reporting Name: Overseas

Element Name: Danger Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE

Location Location Char GHR_US_FOR_ALL_
LOC
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Element Name: Imminent Danger Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Non recurring

Multiple Occurrences:
No

Amount Amount Int

Location Location Char GHR_US_FOR_ALL_
LOC

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE
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Element Name: Living Quarters Allowance

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Amount Purchased Purchase Amount Int

Date Purchased Purchase Date Date

Amount Rent Rent Amount Int

Amount Utility Utility Amount Int

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE

Location Location Char GHR_US_FOR_ALL_
LOC

Quarters Type Quarters Type Char GHR_US_
QUARTERS_TYPE

Shared Percent Shared Percent Char

Number of Family
Members

Num Family
Members

Int

Summer Record
Indicator

Summer Record Ind Char

Quarters Group Quarters Group Char GHR_US_
QUARTERS_GROUP

Currency Currency Char GHR_US_
CURRENCY

Utility Currency Currency Char GHR_US_
CURRENCY

Purchase Currency Currency Char GHR_US_
CURRENCY
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Element Name: Living Quarters Allowance Paid

Description Input Value Units Look-up Type

Classification:
Information

Category:
Reconciliation

Type: Recurring

Multiple Occurrences:
No

Amount Purchase
Paid

Purchase Amount Int

Amount Rent Paid Rent Amount Int

Amount Utilities Paid Utility Amount Int

Pay Period Number Pay Period Number Char

Date Last
Reconciliation

Date Last Recon Date

Element Name: Post Differential

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Post Differential
Percent

Percentage Num

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE

Location Location Char GHR_US_FOR_ALL_
LOC
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Element Name: Post Allowance

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Allowance Amount Amount Int

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE

Location Location Char GHR_US_FOR_ALL_
LOC

Number of Family
Members

Num Family
Members

Char

Reporting Name: Premium Pay
Element Name: Premium Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Premium Pay
Indicator

Premium Pay Ind Char GHR_US_PREM_
PAY_IND

Premium Pay Salary
Flag

Amount Int
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Element Name: Separate Maintenance Allowance

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Allowance Amount Amount Int

Last Action Code Last Action Code Char GHR_US_LAST_ACT
ION_CODE

Category Category Char GHR_US_
CATEGORY

Element Name: Post Allowance

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Allowance Daily Rate Amount Int
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Element Name: Temporary Lodging Allowance

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Allowance Type Allowance Type Char

Allowance Daily Rate Daily Rate Int

Reporting Name: Panama

Element Name: Tropical Differential

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Tropical Differential
Indicator

Indicator Char

Tropical Differential
Percent

Percent Num
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Reporting Name: Part Time Hours

Element Name: Part Time Hours Worked

Description Input Value Units Look-up Type

Classification:
Information

Category: Regular
Hours

Type: Recurring

Multiple Occurrences:
No

Part Time Hours
Worked Pay Period

Hours Num

Reporting Name: Premium Pay

Element Name: Premium Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Allowance

Type: Recurring

Multiple Occurrences:
No

Premium Pay
Indicator

Premium Pay Ind Char GHR_US_PREM_
PAY_IND

Premium Pay Salary
Flag

Amount Int
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Reporting Name: Recruitment Bonus

Element Name: Recruitment Bonus

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Bonuses

Type: Non-recurring

Multiple Occurrences:
Yes

Recruitment Bonus Amount Int

Date Recruit/Reloc
Agreement Exp

Expiration Date Date

Reporting Name: Relocation Bonus

Element Name: Relocation Bonus

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Bonuses

Type: Non-recurring

Multiple Occurrences:
Yes

Relocation Bonus Amount Int

Date Recruit/Reloc
Agreement Exp

Expiration Date Date
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Reporting Name: Retirement Annuity

Element Name: Retirement Annuity

Description Input Value Units Look-up Type

Classification:
Information

Category: Retirement

Type: Recurring

Multiple Occurrences:
No

Retirement Annuity
Sum

Sum Num

Eligibility Expires Eligibility Expires Date

Reporting Name: Retirement Plan

Element Name: Retirement Plan

Description Input Value Units Look-up Type

Classification:
Voluntary Deduction

Category: Retirement

Type: Recurring

Multiple Occurrences:
No

Retirement Plan Plan Char GHR_US_RET
IREMENT_PLAN

FERS Eligibility
Expires

FERS Eligibility
Expires

Date
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Reporting Name: Severance Pay

Element Name: Severance Pay

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category: Dismissal
Payments

Type: Non-recurring

Multiple Occurrences:
Yes

Severance Pay Amount Num

Severance Pay
Number Weeks

Total Entitlement
Weeks

Int

Severance Pay Weeks
Paid

Number Weeks Paid Int

Severance Pay Weekly
Amount

Weekly Amount Num

Reporting Name: Student Loan Repayment Lump Sum

Element Name: Student Loan Repayment Lump Sum

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category:

Type: Non-recurring

Multiple Occurrences:
Yes

Lump Sum Amount Amount Int

Review Date Date Date
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Reporting Name: Student Loan Repayment

Element Name: Student Loan Repayment

Description Input Value Units Look-up Type

Classification:
Supplemental
Earnings

Category:

Type: Recurring

Multiple Occurrences:
No

Biweekly Amount Amount Int

Review Date Date Date

Reporting Name: Thrift Saving Plan

Element Name: TSP

Description Input Value Units Look-up Type

Classification: Pre-Tax
Deductions

Category: Deferred
Comp 401K

Type: Recurring

Multiple Occurrences:
No

TSP Employee
Amount

Amount Money

TSP Rate Rate Num

TSP Status Status Char GHR_US_TSP_
STATUS

TSP Status Date Status Date Date

TSP Eligibility Date Agency Contrib Elig
Date

Date

TSP Re-election Date Emp Contrib Elig Date Date
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Reporting Name: Total Pay

Element Name: Total Pay

Description Input Value Units Look-up Type

Classification:
Earnings

Category: Regular

Type: Recurring

Multiple Occurrences:
No

Total Salary Amount Num

Reporting Name: Unadjusted Basic Pay

Element Name: Unadjusted Basic Pay

Description Input Values Units Lookup Types

Classification:
Information

Category: Regular

Type: Recurring

Multiple Occurrences:
No

GM Unadjusted Basic
Pay

Amount Num
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Reporting Name: Within Grade Increase

Element Name: Within Grade Increase

Description Input Value Units Look-up Type

Classification:
Information

Category: WGI

Type: Recurring

Multiple Occurrences:
No

WGI Status Status Int GHR_US_WGI_
STATUS

Date WGI Due Date Due Date

WGI Pay Date Pay Date Date

Date Last Equivalent
Increase

Last Increase Date Date

Date WGI Postpone
Effective

Postponement
Effective

Date

Date WGI Postpone
Detail Due

Postponement Determ
Due

Date

US Federal Key Flexfields
Refer to the tables in this topic for detailed information on key flexfield descriptions
and lookups.

Position Key Flexfield
When you define the position key flexfield, you must define the following four segments
and then map these segments to the Organization Extra Information Type: US FEDERAL
ORGANIZATION INFORMATION. The Position Title segment must reside in the first
five segments of the client’s Position Key Flexfield.

Value sets and Lookup Types must be used in the Position Key Flexfield segments as
indicated in the following table. Value Sets and Lookup Types must contain the same
names as indicated in the Lookup Type column.
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Position Key Flexfield

Description Lookup Type
Name

Type Req. Remarks

Structure Name:
(determined by
client)

Position Title
(map to GHR_
US_ORG_
INFORMAT
ION)

GHR_US_POSIT
ION_TITLE

X * validation: none,
field size must be
60

Position Descrip
Num (map to
GHR_US_ORG_
INFORMAT
ION)

GHR_US_POS_
DESC_NUM

X * validation: none,
field size must be
15

Sequence
Number (map to
GHR_US_ORG_
INFORMAT
ION)

GHR_US_
SEQUENCE_
NUM

N validation: none,
field size must be
15

Agency/
Subelement
Code (map to
GHR_US_ORG_
INFORMAT
ION)

GHR_US_
AGENCY_
CODE

X * field size must be
4

See: Setting up the Position Flexfield, page 3-21

Job Key Flexfield
The Oracle Federal Human Resource product requires the following segment be
contained in the client’s Job Key Flexfield. After defining the Job Key Flexfield, you
map this segment to the Organization Extra Information Type: US FEDERAL
ORGANIZATION INFORMATION.

See the Organization Extra Information Type: US FEDERAL ORGANIZATION
INFORMATION for additional details about the Job Key Flexfield.

Value sets and Lookup Types must be used in the Job Key Flexfield segment as indicated
in the following table. Value Sets and Lookup Types must contain the same name as
indicated in the Lookup Type column.

See: Setting up the Job Flexfield, page 3-20
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Job Key Flexfield

Description Lookup Type
Name

Type Req. Remarks

Structure Name:
(determined by
client)

Occupational
Series (map to
GHR_US_ORG_
INFORMAT
ION)

GHR_US_OCC_
SERIES

X *

Grade Key Flexfield

Grade Key Flexfield: US FEDERAL GRADE

Description Lookup Type
Name

Type Req. Remarks

Pay Plan GHR_US_PAY_
PALN

X *

Grade or Level GHR_US_
GRADE_OR_
LEVEL

X *

People Group Key Flexfield
There are no minimum requirements for the People Group Key Flexfield.

Cost Allocation Key Flexfield
There are no minimum requirements for the Cost Allocation Key Flexfield.

Personal Analysis Key Flexfields
The Personal Analysis Key Flexfields include the Special Information Types listed below.
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Personal Analysis Information Type: US FEDERAL EDUCATION (US Fed Education)

Description Lookup Type
Name

Type Req. Remarks

Education Level GHR_US_
EDUCAT
IONAL_LEVEL

X none none

Academic
Discipline

GHR_US_
ACADEMIC_
DISCIPLINE

X none instructional
program

Year Degree/
Cert Attained

GHR_US_
YEAR_
DEGREE_ATTA
INED

N none validation: none

Credit Hours GHR_US_CRED
IT_HOURS

N none validation: none

Credit Type GHR_US_CRED
IT_TYPE

X none none

Type of School GHR_US_TYPE_
OF_SCHOOL

X none none

College-Major-
Minor

GHR_US_
COLLEGE_
MAJ_MIN

X none none

Academic
Institution Name

GHR_US_
ACADEMIC_
INSTITUTION

X none none

Coop Graduation
Date

FND_
STANDARD_
DATE

D none none
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Personal Analysis Information Type: US FEDERAL CONDITIONS OF EMPLOYMENT (US Fed Cndtn
of Emplmt)

Description Lookup Type
Name

Type Req. Remarks

Drug Test Date FND_
STANDARD_
DATE

D none none

Physical Exam or
Test Type

GHR_US_PHYS
ICAL_EXAM

X none none

Physical Date FND_
STANDARD_
DATE

D none none

Type of
Occupational
Cert

GHR_US_TYPE_
OCC_CERT

X none none

Date
Occupational
Cert Issued

FND_
STANDARD_
DATE

D none none
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Personal Analysis Information Type: US FEDERAL CONDUCT PERFORMANCE (US Fed Conduct Perf)

Description Lookup Type
Name

Type Req. Remarks

Cause of
Disciplinary
Action

GHR_US_
CAUSE_DISP_
ACTION

X none none

Date of Adverse
Action

FND_
STANDARD_
DATE

D none none

Days Suspended GHR_US_DAYS_
SUSPENDED

N none validation: none

Date Suspension
Over 30 Days

FND_
STANDARD_
DATE

D none none

Date Suspension
Under 30 Days

FND_
STANDARD_
DATE

D none none

PIP Action Taken GHR_US_PI
P_ACTION_
TAKEN

X none none

PIP Beginning
Date

FND_
STANDARD_
DATE

D none none

PIP Ending Date FND_
STANDARD_
DATE

D none none

PIP Extensions GHR_US_PIP_
EXTENSIONS

X none validation: none

PIP Length GHR_US_PIP_
LENGTH

X none validation: none

Adverse Action
NOAC

GHR_US_
ADVERSE_ACT
ION_NOAC

X none display as first
segment
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Personal Analysis Information Type: US FEDERAL LANGUAGE (US Fed Language)

Description Lookup Type
Name

Type Req. Remarks

Language
Identifier

GHR_US_
LANG_IDENT
IFIER

X none none

Language
Proficiency Level

GHR_US_
LANG_PROF_
LEVEL

X none none

Language
Reading
Proficiency

GHR_US_
LANG_PROF

X none none

Language
Speaking
Proficiency

GHR_US_
LANG_PROF

X none none

Language
Listening
Proficiency

GHR_US_
LANG_PROF

X none none

Language
Proficiency Test
Date

FND_
STANDARD_
DATE

D none none

Personal Analysis Information Type: US FEDERAL PERFORMANCE APPRAISAL (US Fed Perf Appraisal)

Description Lookup Type
Name

Type Req. Remarks

Appraisal Type GHR_US_AP
PRAISAL_TYPE

X none QBJ and QHJ

Rating of Record GHR_US_
RATING_OF_
RECORD

X none QBC and QHC,
validation: none

Date Effective FND_
STANDARD_
DATE

D none QBB and QHB

Rating of Record
Pattern

GHR_US_RAT
ING_PATTERN

X none none

Rating of Record
Level

GHR_US_RAT
ING_LEVEL

X none none

Date Appraisal
Period Ends

FND_
STANDARD_
DATE

D none none

Unit GHR_US_UNIT X none QBE and QHE,
validation: none
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Description Lookup Type
Name

Type Req. Remarks

Organization
Structure ID

GHR_US_ORG_
STRUCTURE_ID

X none validation: none

Office Symbol GHR_US_OFF
ICE_SYMBOL

X none QBF and QHF,
validation: none

Pay Plan GHR_US_PAY_
PLAN

X none QBH and QHH

Grade GHR_US_
GRADE_OR_
LEVEL

X none QBG and QHG

Date Due FND_
STANDARD_
DATE

D none none

Appraisal
System Identifier

GHR_US_AP
PRAISAL_SYS_
ID

X none validation: none

Date Initial
Appraisal Due

FND_
STANDARD_
DATE

D none none

Optional
Information

GHR_US_O
PTNL_APPR_
INFO

X none validatation:
none

Performance
Rating Points

GHR_US_PERF_
RATING_PO
INTS

none none none

Personal Analysis Information Type: US FEDERAL SPECIAL CONSIDERATION (US Fed Spcl Consdrtn)

Description Lookup Type
Name

Type Req. Remarks

Spcl Plcmt
Consid Reason

GHR_US_SPEC_
PLCMT_CNSID_
RSN

X none none

Date Prty Plcmt
Consid Begins

FND_
STANDARD_
DATE

D none none

Date Prty Plcmt
Consid Ends

FND_
STANDARD_
DATE

D none none

Spcl Pay Plan GHR_US_PAY_
PLAN

X none duplicate value
set to Pay Plan
under Grade
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Description Lookup Type
Name

Type Req. Remarks

Spcl Grade GHR_US_
GRADE_OR_
LEVEL

X none none

Spcl Plcmt Pay
Plan - 1

GHR_US_PAY_
PLAN

X none duplicate value
set to Pay Plan
under Grade

Acceptable
Grade - 1

GHR_US_
GRADE_OR_
LEVEL

X none none

Spcl Plcmt Pay
Plan - 2

GHR_US_PAY_
PLAN

X none duplicate value
set to Pay Plan
under Grade

Acceptable
Grade - 2

GHR_US_
GRADE_OR_
LEVEL

X none none

Spcl Plcmt Pay
Plan - 3

GHR_US_PAY_
PLAN

X none duplicate value
set to Pay Plan
under Grade

Acceptable
Grade - 3

GHR_US_
GRADE_OR_
LEVEL

X none none

Spcl Plcmt Pay
Plan - 4

GHR_US_PAY_
PLAN

X none duplicate value
set to Pay Plan
under Grade

Acceptable
Grade - 4

GHR_US_
GRADE_OR_
LEVEL

X none none

Date
Reemployment
Rights Expire

FND_
STANDARD_
DATE

D none none

NOAC Families and Request Information Types
The following table lists the NOAC family names, their related NOACs and RPA Extra
Information Types.
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Families and Request Information Types

Family Name/CODE Nature of Action Codes
(NOACs)

Request Information Type
Name/CODE

Appointment Info APPT_
INFO

100, 101, 107, 108, 112, 115, 120,
122, 124, 140, 141, 142, 143,
146, 148, 149, 150, 151, 153, 154,
155, 156, 170, 171, 190, 198, 199

US Fed Appointment
Information GHR_US_PAR_A
PPT_INFO

Appointment Transfer APPT_
TRANS

130, 132, 145, 147, 157 US Fed Appointment with
Transfer GHR_US_PAR_AP
PT_TRANSFER

Award and Bonus Info
AWARDS_BONUS

825, 872, 873, 874, 875, 876,
877, 878, 879, 885

US Fed Award and Bonus
Information GHR_US_PAR_
AWARDS_BONUS

Change in Data Element
CHG_DATA_ELEMENT

800 US Fed Change in Data
Element GHR_US_PAR_
CHG_DATA_ELEMENT

Change Schedule and Hours
CHG_SCHED_HOURS

781, 782 US Fed Change Schedule and
Hours GHR_US_PAR_CHG_
HOURS

Change in Retirement Plan
CHG_RETIRE_PLAN

803 US Fed Change in Retirement
Plan GHR_US_PAR_RETIRE_
PLAN

Change in SCD CHG_SCD 882 US Fed Change in SCD
GHR_US_PAR_CHG_SCD

Conversion to Appointment
CONV_APP

500, 501, 507, 508, 512, 515,
520, 522, 524, 540, 541, 542,
543, 546, 548, 549, 550, 551,
553, 554, 555, 570, 571, 590

US Fed Conversion to
Appointment GHR_US_
PAR_CONV_APP

Danger Pay GHR_DANGER_
PAY

100-199 (except 132) US Fed Benefit Danger Pay
GHR_US_PAR_DANGER_
PAY

EDP Pay GHR_EDP_PAY 100-199 (except 132), 500-599,
702, 703, 713, 721

US Fed Benefit EDP Pay
GHR_US_PAR_EDP_PAY

Entitlement GHR_ENT
ITLEMENT

100-199 (except 132), 500-599,
702, 703, 713, 721, 800

US Fed Benefit Entitlement
GHR_US_PAR_ENT
ITLEMENT

Foreign Lang Prof Pay GHR_
FOR_LANG_PROF_PAY

100-199 (except 132), 500-599,
702, 703, 713

US Fed Benefit Foreign Lang
Prof Pay GHR_US_PAR_FOR_
LANG_PROF_PAY

Foreign Transfer Allowance
GHR_FOR_TRANSER_
ALLOW

100-199 (except 132), 500-599,
721, 702, 703, 713, 792

US Fed Benefit Foreign
Transfer Allowance GHR_
US_PAR_FOR_TRANSER_
ALLOW
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Family Name/CODE Nature of Action Codes
(NOACs)

Request Information Type
Name/CODE

Hazard Pay GHR_HAZARD_
PAY

100-199 (except 132), 500-599,
702, 703, 713, 721

US Fed Benefit Hazard Pay
GHR_US_PAR_HAZARD_
PAY

Health Benefits GHR_
HEALTH_BENEFITS

100-199 (except 132), 500-599 US Fed Benefit Health Benefits
GHR_US_PAR_HEALTH_
BENEFITS

Imminent Danger Pay GHR_
IMMINENT_DANGER_PAY

100-199 (except 132) US Fed Benefit Imminent
Danger Pay GHR_US_PAR_
IMMNT_DANGER_PAY

Living Quarters Allowance
GHR_PAR_LIVING_
QUARTERS_ALLOW

100-199 (except 132) US Fed Benefit Living
Quarters Allowance GHR_
US_PAR_LIVING_QUART_
ALLOW

MD/DDS Special Pay GHR_
MD_DDS_PAY_INFO

850 US Fed MD/DDS Special Pay
GHR_US_PAR_MD_DDS_PA

Non Pay/Non Duty Status
NON_PAY_DUTY_STATUS

430, 450, 452, 460, 462, 480 US Fed Non Pay or Non Duty
GHR_US_PAR_NON_PAY_
DUTY_STATUS

Position Change POSN_CHG 740, 741 US Fed Position Change

Post Differential Amount
GHR_POST_DIFFERENT
IAL_AMOUNT

100-199 (except 132) US Fed Benefit Post
Differential Amount GHR_
US_PAR_POST_DIFF_
AMOUNT

Post Differential Percent
GHR_POST_DIFFERENT
IAL_PERCENT

100-199 (except 132) US Fed Benefit Post
Differential Percent GHR_US_
PAR_POST_DIFF_PERCENT

Premium Pay GHR_PREM
IUM_PAY

100-199 (except 132), 500-599,
702, 703, 713, 721

US Fed Benefit Premium Pay
GHR_US_PAR_PREMIUM_
PAY

Realignment REALIGNMENT 790 US Fed Realignment GHR_
US_PAR_REALIGNMENT

Reassignment REASS
IGNMENT

721 US Fed Reassignment GHR_
US_PAR_REASSIGNMENT

Recruitment Award and
Bonus Info AWARD_RECRU
IT_BONUS

815 US Fed Recruitment Bonus
GHR_US_PAR_RECRUIT_
BONUS

Relocation Award and Bonus
Info AWARD_RELOC_
BONUS

816 US Fed Relocation Bonus
GHR_US_PAR_RELO_
BONUS

3-90 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Family Name/CODE Nature of Action Codes
(NOACs)

Request Information Type
Name/CODE

Retention Allowance RET_
ALLOWANCE

810 US Fed Benefit Retention
Allowance GHR_US_PAR_
RET_ALLOWANCE

Retained Grade RETAINED_
GRADE

713, 740 US Fed Retained Grade GHR_
US_PAR_RETAINED_GRADE

Retirement Annuity GHR_
RETIREMENT_ANNUITY

100-199 (except 132), 500-599,
803

US Fed Benefit Retirement
Annuity GHR_US_PAR_RET
IREMENT_ANNUITY

Return to Duty RETURN_TO_
DUTY

280, 292, 293 US Fed Return to Duty
GHR_US_PAR_RETURN_
TO_DUTY

Salary Change SALARY_
CHG_INFO

702, 703, 713, 850, 855, 867,
868, 891, 892, 893, 895, 899

US Fed Salary Change GHR_
US_PAR_SALARY_CHG

Salary Change SALARY_
CHG_INFO4

892 US Fed QSI Award
Information GHR_US_PAR_
QSI_AWARD

Separate Maintenance
Allowance GHR_SEP_MA
INT_ALLOWANCE

100-199 (except 132) US Fed Benefit Separate
Maintenance Allowance
GHR_US_PAR_SEP_MAINT_
ALLOWANCE

Severance Pay GHR_
SEVERENCE_PAY

300-399 (except 352) US Fed Benefit Severance
Pay GHR_US_PAR_
SEVERANCE_PAY

Student Loan Repayment
GHR_STUDENT_LOAN_
INFO

817 US Federal Student Loan
Repayment GHR_US_PAR_
STUDENT_LOAN

Supplemental Post Allowance
GHR_SUPP_POST_
ALLOWANCE

100-199 (except 132) US Fed Benefit Supplemental
Post Allowance GHR_
US_PAR_SUP_POST_
ALLOWANCE

Temporary Lodging
Allowance GHR_TEMP_
LODGING_ALLOWANCE

100-199 (except 132) US Fed Benefit Temporary
Lodging Allowance GHR_
US_PAR_TMP_LODGE_
ALLOWANCE

Thrift Savings Plan GHR_THR
IFT_SAVINGS_PLAN

100-199 (except 132), 500-599,
803

US Fed Benefit Thirft Savings
Plan GHR_US_PAR_TSP

Transfer Information MASS_
TERM

352 US Fed Transfer Information
GHR_US_PAR_MASS_TERM

All families (all NOACs) US Fed Agency Data GHR_
US_PAR_GEN_AGENCY_
DATA
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Family Name/CODE Nature of Action Codes
(NOACs)

Request Information Type
Name/CODE

All families 471, 472, 473 US Fed Leave Without Pay
Information GHR_US_PAR_
LWOP_INFO

All families (all NOACs) US Fed Payroll Type GHR_
US_PAR_PAYROLL_TYPE

All families (all NOACs) US Fed PD Employee
Information GHR_US_PAR_
GEN_EMP

All families (all NOACs except 001) US Fed Performance Appraisal
GHR_US_PAR_PERF_APPRA
ISAL
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RPA Information Type Descriptions

Request Information Type Name: US FED APPOINTMENT INFORMATION
GHR_US_PAR_APPT_INFO

Information Type Req. R Value Set Name Element

Appointment Type R GHR_US_APPO
INTMENT_TYPE

none

Creditable Military
Service

R GHR_US_CREDIT_M
IL_SVC

none

Date Arrived
Personnel Office

none FND_STANDARD_
DATE

none

Date WGI Due none FND_STANDARD_
DATE

x

Frozen Service R GHR_US_FROZEN_
SERVICE

none

Handicap Code R GHR_US_HANDICA
P_CODE

none

Non-Disclosure Agmt
Status

none GHR_US_NON_D
ISCLOSURE_AGREE

none

Part-time Indicator none GHR_US_PART_T
IME_INDICATOR

none

Position Working Title none GHR_US_WORK
ING_TITLE

none

Previous Retirement
Coverage

R GHR_US_PREV_RET
IRE_COVER

none

Qualification
Standards Waiver

none GHR_US_QUAL_
STND_WAIVER

none

Race National Origin R GHR_US_RACE_
NATIONAL_ORIGIN

none

Type of Employment R GHR_US_TYPE_EM
PLOYMENT

none

FERS Coverage none GHR_US_FERS_
COVERAGE

none

Extending Oracle HRMS 3-93



Request Information Type Name: US FED APPOINTMENT WITH TRANSFER GHR_US_PAR_APPT_
TRANSFER

Data Item Req. Value Set Name Element

Agency Code Transfer
From

R GHR_US_AGENCY_
CODE

Appointment Type R GHR_US_APPO
INTMENT_TYPE

Creditable Military
Service

R GHR_US_CREDIT_M
IL_SVC

Date Arrived
Personnel Office

FND_STANDARD_
DATE

Date WGI Due FND_STANDARD_
DATE

x

Frozen Service RPA GHR_US_FROZEN_
SERVICE

Handicap Code R GHR_US_HANDICA
P_CODE

Non-Disclosure Agmt
Status

GHR_US_NON_D
ISCLOSURE_AGREE

Part-time Indicator GHR_US_PART_T
IME_INDICATOR

Position Working Title GHR_US_WORK
ING_TITLE

Previous Retirement
Coverage

R GHR_US_PREV_RET
IRE_COVER

Qualification
Standards Waiver

GHR_US_QUAL_
STND_WAIVER

Race National Origin R GHR_US_RACE_
NATIONAL_ORIGIN

Type of Employment R GHR_US_TYPE_EM
PLOYMENT

FERS Coverage GHR_US_FERS_
COVERAGE
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Request Information Type Name: US FED AGENCY DATA GHR_US_PAR_GEN_AGENCY_DATA

Data Item Req. Value Set Name Element

Agency Use Block 25 none none none

Agency Data Block 40 none none none

Agency Data Block 41 none none none

Agency Data Block 42 none none none

Agency Data Block 43 none none none

Agency Data Block 44 none none none

Request Information Type Name: US FED AWARD AND BONUS INFORMATION GHR_US_PAR_AWARDS_BONUS

Data Item Req. Value Set Name Element

Award Agency Code GHR_US_AGENCY_
CODE_2

Award Type GHR_US_AWARD_
TYPE

Date Award Earned

Award Appropriation
Code

GHR_US_APPROPR
IATION_CODE1

Date Ex-Emp Award
Paid

FND_STANDARD_
DATE

Request Information Type Name: US FED BENEFIT DANGER PAY GHR_US_PAR_DANGER_PAY

Data Item Req. Value Set Name Element

Last Action Code R GHR_US_LAST_ACT
ION_CODE

x

Location x

Request Information Type Name: US FED BENEFIT EDP PAY GHR_US_PAR_EDP_PAY

Data Item Req. Value Set Name Element

Premium Pay Ind GHR_US_PREM_
PAY_IND

x

EDP Type GHR_US_HAZARD_
TYPE

x

Extending Oracle HRMS 3-95



Request Information Type Name: US FED BENEFIT ENTITLEMENT GHR_US_PAR_ENTITLEMENT

Data Item Req. Value Set Name Element

Code GHR_US_ENT
ITLEMENT_CODE

x

Amount of Percent GHR_US_8_2_
NUMBER

x

Request Information Type Name: US FED BENEFIT FEGLI GHR_US_PAR_FEGLI

Data Item Req. Value Set Name Element

Eligibility Expiration GHR_US_FEGLI x

Request Information Type Name: US FED BENEFIT FOREIGN LANGUAGE PROF PAY GHR_US_PAR_FOR_LANG_

PROF_PAY

Data Item Req. Value Set Name Element

Certification Date FND_STANDARD_
DATE

x

Pay Level or Rate GHR_US_PAY_
LEVEL_RATE

x

Request Info Type Name: US FED BENEFIT FOREIGN TRANSFER ALLOWANCE GHR_US_PAR_FOR_TRANSFER_ALLOW

Data Item Req. Value Set Name Elemen t

Last Action Code R GHR_US_LAST_ACT
ION_CODE

X

Num Family
Members

X

Miscellaneous
Expense

X

Wardrobe Expense X

Pre-departure
Subsistence Expense

X

Lease Penalty Expense X

Total Authorized
Amount

X

3-96 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Request Information Type Name: US FED BENEFIT HAZARD PAY GHR_US_PAR_HAZARD_PAY

Data Item Req. Value Set Name Element

Premium Pay Ind GHR_US_PREM_
PAY_IND

x

Hazard Type GHR_US_HAZARD_
TYPE

x

Request Information Type Name: US FED BENEFIT IMMINENT DANGER PAY GHR_US_PAR_IMMNT_DANGER_PAY

Data Item Req. Value Set Name Element

Amount GHR_US_7_
NUMBER

x

Location x

Last Action Code R GHR_US_LAST_ACT
ION_CODE

x
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Request Information Type Name: US FED BENEFIT LIVING QUARTERS ALLOWANCE GHR_US_PAR_LIVING_QUART_

ALLOW

Data Item Req. Value Set Name Element

Purchase Amount HR_US_NUMBER_
LENGTH_10

x

Purchase Currency GHR_US_
CURRENCY

x

Purchase Date FND_STANDARD_
DATE

x

Rent Amount HR_US_NUMBER_
LENGTH_10

x

Rent Currency GHR_US_
CURRENCY

x

Utility Amount HR_US_NUMBER_
LENGTH_10

x

Utility Currency GHR_US_
CURRENCY

x

Last Action Code R GHR_US_LAST_ACT
ION_CODE

x

Location x

Quarters Type GHR_US_
QUARTERS_TYPE

x

Shared Percent x

Num. Family
Members

GHR_US_7_
NUMBER

x

Summer Record Ind x

Quarters Group GHR_US_
QUARTERS_GROUP

x
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Request Information Type Name: US FED BENEFIT POST DIFFERENTIAL AMOUNT GHR_US_PAR_POST_DIFF_AMOUNT

Data Item Req. Value Set Name Element

Amount GHR_US_7_
NUMBER

x

Last Action Code R GHR_US_LAST_ACT
ION_CODE

x

Location x

No. Family Members x

Request Information Type Name: US FED BENEFIT POST DIFFERENTIAL PERCENT GHR_US_PAR_POST_DIFF_

PERCENT

Data Item Req. Value Set Name Element

Percent GHR_US_6_
PERCENTAGE

x

Last Action Code R GHR_US_LAST_ACT
ION_CODE

x

Location x

Request Information Type Name: US FED BENEFIT PREMIUM PAY GHR_US_PAR_PREMIUM_PA

Data Item Req. Value Set Name Element

Premium Pay Ind GHR_US_PREM_
PAY_IND

x

Amount GHR_US_7_
NUMBER

x

Request Information Type Name: US FED BENEFIT RETENTION ALLOWANCE GHR_US_PAR_RET_ALLOWANCE

Data Item Req. Value Set Name Element

Retention Allowance
Due Date

FND_STANDARD_
DATE
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Request Information Type Name: US FED BENEFIT RETIREMENT ANNUITY GHR_US_PAR_RETIREMENT_ANNUITY

Data Item Req. Value Set Name Element

Sum GHR_US_8_2_
NUMBER

x

Eligibility Expires FND_STANDARD_
DATE

x

Request Information Type Name: US FED BENEFIT SEPARATE MAINTENANCE GHR_US_PAR_SEP_MAINT_ALLOWANCE

Data Item Req. Value Set Name Element

Allowance Amount GHR_US_7_
NUMBER

x

Last Action Code R GHR_US_LAST_ACT
ION_CODE

x

Category GHR_US_
CATEGORY

x

Request Information Type Name: US FED BENEFIT SEVERANCE PAY GHR_US_PAR_SEVERANCE_PAY

Data Item Req. Value Set Name Element

Amount GHR_US_8_2_
NUMBER

x

Total Entitlement
Weeks

GHR_US_7_
NUMBER

x

Number Weeks Paid GHR_US_7_
NUMBER

x

Weekly Amount GHR_US_8_2_
NUMBER

x

Request Information Type Name: US FED BENEFIT SUPPLEMENTAL POST ALLOWANCE GHR_US_PAR_SUP_POST_

ALLOWANCE

Data Item Req. Value Set Name Element

Amount GHR_US_7_
NUMBER

x
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Request Information Type Name: US FED BENEFIT TEMPORARY LODGING ALLOWANCE GHR_US_PAR_TMP_LODGE_

ALLOWANCE

Data Item Req. Value Set Name Element

Allowance Type x

Daily Rate GHR_US_7_
NUMBER

x

Request Information Type Name: US FED CHANGE IN DATA ELEMENT GHR_US_PAR_CHG_DATA_ELEMENT

Data Item Req. Value Set Name Element

Personnel Office ID GHR_US_
PERSONNEL_OFF
ICE_ID

Agency/Subelement
Code

GHR_US_AGENCY_
CODE

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVCR

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER
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Request Information Type Name: US FED CHANGE SCHEDULE AND HOURS GHR_US_PAR_CHG_HOURS

Data Item Req. Value Set Name Element

Date Prob/Trial
Period Begins

FND_STANDARD_
DATE

Date Prob/Trial
Period Ends

FND_STANDARD_
DATE

Date WGI Due FND_STANDARD_
DATE

x

Date WGI Postpone
Effective

FND_STANDARD_
DATE

x

Part-time Indicator GHR_US_PART_T
IME_INDICATOR

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVCR

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER

Job Change
Probationary Period
Begins

FND_STANDARD_
DATE

Job Change
Probationary Period
Ends

FND_STANDARD_
DATE

Request Information Type Name: US FED CHANGE IN RETIREMENT PLAN GHR_US_PAR_CHG_RETIRE_PLAN

Data Item Req. Value Set Name Element

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVC

FERS Coverage GHR_US_FERS_
COVERAGE

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER
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Request Information Type Name: US FED CHANGE IN SCD GHR_US_PAR_CHG_SCD

Data Item Req. Value Set Name Element

SCD RIF FND_STANDARD_
DATE

SCD Civilian FND_STANDARD_
DATE

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVC

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER

SCD TSP FND_STANDARD_
DATE

SCD Retirement FND_STANDARD_
DATE

Request Information Type Name: US FED CONVERSION TO APPOINTMENT GHR_US_PAR_CONV_APP

Data Item Req. Value Set Name Element

Appointment Type R GHR_US_APPO
INTMENT_TYPE

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVC

Date Arrived
Personnel Office

FND_STANDARD_
DATE

Frozen Service GHR_US_FROZEN_
SERVICE

Handicap Code R GHR_US_HANDICA
P_CODE

Part-time Indicator GHR_US_PART_T
IME_INDICATOR

Position Working Title GHR_US_WORK
ING_TITLE

Previous Retirement
Coverage

GHR_US_PREV_RET
IRE_COVER

Qualification
Standards Waiver

GHR_US_QUAL_
STND_WAIVER
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Data Item Req. Value Set Name Element

Race National Origin R GHR_US_RACE_
NATIONAL_ORIGIN

Type of Employment R GHR_US_TYPE_EM
PLOYMENT

Date Conversion
Career Begins

FND_STANDARD_
DATE

Date Conversion
Career Due

FND_STANDARD_
DATE

Date Recmd
Conversion Begins

FND_STANDARD_
DATE

Date Recmd
Conversion Due

FND_STANDARD_
DATE

Date VRA Conversion
Due

FND_STANDARD_
DATE

Date WGI Due FND_STANDARD_
DATE

x

FERS Coverage GHR_US_FERS_
COVERAGE

Request Information Type Name: US FED LEAVE WITHOUT PAY INFORMATION GHR_US_PAR_LWOP_INFO

Data Item Req. Value Set Name Element

Type of Employment GHR_US_TYPE_EM
PLOYMENT

Request Information Type Name: US FED TRANSFER INFORMATION GHR_US_PAR_MASS_TERM

Data Item Req. Value Set Name Element

Agency Code Transfer
To

GHR_US_AGENCY_
CODE
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Request Information Type US FED MD/DDS SPECIAL PAY GHR_US_PAR_MD_DDS_PAY

Data Item Req. Value Set Name Element

Full Time Status X

Length of Service X

Scarce Speciality X

Speciality or Board
Certification

X

Geographic Location X

Exceptional
Qualifications

X

Executive Position X

Dentist Post Graduate
Training

X

MD/DDS Total
Special Pay

X

MD/DDS Special Pay
NTE Date

X

Premium Pay
Indicator

GHR_US_PREM_
PAY_IND

X
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Request Information Type Name: US FED NON PAY OR DUTY GHR_US_PAR_NON_PAY_DUTY_STATUS

Data Item Req. Value Set Name Element

Type of Employment GHR_US_TYPE_EM
PLOYMENT

Adverse Action
NOAC

GHR_US_ADVERSE_
ACTION_NOAC

Cause of Disciplinary
Action

GHR_US_CAUSE_D
ISP_ACTION

Date of Adverse
Action

Days Suspended GHR_US_DAYS_SUS
PENDED

Date Suspension Over
30 Days

Date Suspension
Under 30 Days

PIP Action Taken GHR_US_PIP_ACT
ION_TAKEN

PIP Beginning Date

PIP Ending Date

PIP Extensions GHR_US_PIP_
EXTENSIONS

PIP Length GHR_US_PIP_
LENGTH

Request Information Type Name: US FED PAYROLL TYPE GHR_US_PAR_PAYROLL_TYPE

Data Item Req. Value Set Name Element

Payroll Type
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Request Information Type Name: US FED PD EMPLOYEE INFORMATION GHR_US_PD_GEN_EMP

Data Item Req. Value Set Name Element

Reason for
Submission

GHR_US_SUBMISS
ION_REASON

G12

Explanation

Service GHR_US_SERVICE G13

Agency Use
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Request Information Type Name: US FED PERFORMANCE APPRAISAL GHR_US_PAR_PERF_APPRAISAL

Data Item Req. Value Set Name Element

Rating of Record GHR_US_RATING_
OF_RECORD

Rating of Record
Pattern

GHR_US_RATING_
PATTERN

Rating of Record Level GHR_US_RATING_
LEVEL

Date Appraisal Period
Ends

FND_STANDARD_
DATE

Appraisal Type GHR_APPRAISAL_
TYPE

Date Initial Appraisal
Due

FND_STANDARD_
DATE

Date Effective FND_STANDARD_
DATE

Unit GHR_US_UNIT

Organization
Structure ID

GHR_US_ORG_
STRUCTURE_ID

Office Symbol GHR_US_OFFICE_
SYMBOL

Pay Plan GHR_US_PAY_PLAN

Grade GHR_US_GRADE_
OR_LEVEL

Date Due FND_STANDARD_
DATE

Appraisal System
Identifier

GHR_US_APPRA
ISAL_SYS_ID

Optional Information GHR_US_OPTNL_A
PPR_INFO
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Request Information Type Name: US FED QSI AWARD INFORMATION GHR_US_PAR_QSI_AWARD

Data Item Req. Value Set Name Element

Award Agency Code GHR_US_AGENCY_
CODE_2

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVCR

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER

Request Information Type Name: US FED REALIGNMENT GHR_US_PAR_REALIGNMENT

Data Item Req. Value Set Name Element

Date Arrived
Personnel Office

FND_STANDARD_
DATE

Payroll Office ID GHR_US_PAYROLL_
OFFICE

Personnel Office ID GHR_US_
PERSONNEL_OFF
ICE_ID

Office Symbol validation: none

Organization
Function Code

validation: none

Position’s
Organization

Target Organization
Name

x

Agency/Subelement
Code

GHR_US_AGENCY_
CODE

OPM Organizational
Component

GHR_US_ORG_
STRUCTURE_ID

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVCR

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER
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Request Information Type Name: US FED REASSIGNMENT GHR_US_PAR_REASSIGNMENT

Data Item Req. Value Set Name Element

Part-time Indicator GHR_US_PART_T
IME_INDICATOR

Position Working Title GHR_US_WORK
ING_TITLE

Qualification
Standards Waiver

GHR_US_QUAL_
STND_WAIVER

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVCR

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER

Request Information Type Name: US FED RECRUITMENT BONUS GHR_US_PAR_RECRUIT_BONUS

Data Item Req. Value Set Name Element

Date Recruitment
Agmt Expires

R FND_STANDARD_
DATE

Request Information Type Name: US FED RELOCATION BONUS GHR_US_PAR_RELOC_BONUS

Data Item Req. Value Set Name Element

Date Relocation Agmt
Expires

R FND_STANDARD_
DATE
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Request Information Type Name: US FEDERAL RETAINED GRADE GHR_US_PAR_RETAINED_GRADE

Data Item Req. Value Set Name Element

Date From

Date To R

Retained Grade GHR_US_GRADE_
OR_LEVEL

Retained Step or Rate GHR_US_STEP

Retained Pay Plan GHR_US_PAY_PLAN

Retained Pay Table ID GHR_US_PAY_
TABLE_ID

Retained Locality
Percent

GHR_US_LOCAL
ITY_PERCENT

Retained Pay Basis GHR_US_PAY_BASIS

Temporary Promotion
Step

GHR_US_STEP

Date WGI Due FND_STANDARD_
DATE

x

Request Information Type Name: US FED RETURN TO DUTY GHR_US_PAR_RETURN_TO_DUTY

Data Item Req. Value Set Name Element

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVC

Date WGI Due FND_DATE4 x

Frozen Service GHR_US_FROZEN_
SERVICE

Non-Disclosure Agmt
Status

GHR_US_NON_D
ISCLOSURE_AGREE

Part-time Indicator GHR_US_PART_T
IME_INDICATOR

Previous Retirement
Coverage

GHR_US_PREV_RET
IRE_COVER
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Request Information Type Name: US FED RPA ADDITIONAL INFO GHR_US_PAR_ADDITIONAL_INFO

Data Item Req. Value Set Name Element

SCD RIF FND_STANDARD_
DATE

SCD Retirement FND_STANDARD_
DATE

Request Information Type Name: US FED SALARY CHANGE GHR_US_PAR_SALARY_CHG

Data Item Req. Value Set Name Element

Date WGI Postpone
Effective

FND_STANDARD_
DATE

x

Date WGI Due FND_STANDARD_
DATE

x

Creditable Military
Service

GHR_US_CREDIT_M
IL_SVCR

Frozen Service GHR_US_FROZEN_
SERVICE

Previous Retirement
Coverage

GHR_PREV_RETIRE_
COVER

Request Information Type Name: US FED STUDENT LOAN REPAYMENT GHR_US_PAR_STUDENT_LOAN

Data Item Req. Value Set Name Element

Repayment Schedule GHR_US_RE
PAYMENT_
SCHEDULE

Review Date FND_STANDARD_
DATE

Request Information Type Name: US FED TERMINATION OF RETAINED GRADE GHR_US_PAR_TERM_RET_GRADE

Data Item Req. Value Set Name Element

Retained Grade Info R GHR_US_RET_
GRADE_INFO
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User-Defined Tables

User-Defined Tables
You may need to set up your own tables to hold data such as agency-specific basic and
special rate pay tables. You can set up all the tables you require using the Table Structure
window. Using Oracle FastFormula, you can write simple formulas for validating
entries made in table columns.

Notice that the Oracle HRMS user-defined tables are different from the database tables of
the Oracle Relational Database Management System. When you set up a user table, you
define the rows as well as the columns, like a matrix. For example, you could set up a
table showing bonus amounts (the column) against years of service (the rows).

Entering and Accessing Table Values
To enter values in tables, you use the Table Values window. Table entries and rows are
both datetracked, so you can delete existing entries or rows, and add new ones, as of
an effective date.

Oracle HRMS provides the GET_TABLE_VALUE function to access table values. You
can yourself write formulas that include calls to this function, perhaps for QuickPaint
inquiries. Also, it is easy for MIS personnel to write PL/SQL statements that call this
function, to include in the code for a form or report process, for example.

Predefined User Tables
Oracle HRMS supplies tables, already defined using the Table Structure window.

Oracle US Federal HR predefines the Oracle Federal Standard Pay Table and the
Oracle Federal Special Rate Pay Tables based on pay table values mandated by the
Office of Personnel Management. If you change these tables, you may compromise
the application’s functionality. As OPM updates the tables, the predefined ones are
accordingly updated. For information about the pay tables, refer to Grades and Their
Relationship to Pay, Compensation and Benefits Management Guide.

Company Work Schedules Table
This table has several commonly-used work schedules already entered in it, and you can
add more. A work schedule shows the hours employees normally work each day from
Monday through Sunday. For example, employees with the schedule 10-10-10-10-0-0-0
work 10 hours each day Monday through Thursday, and have Friday, Saturday and
Sunday off.

Each column in this table holds a separate schedule, with each row holding the hours
worked each day of the week for the schedule. For convenience, each column header
names the schedule held in the column. For example, the header for the column holding
the first schedule is 1 Schedule: 8-8-8-8-8-0-0.

Setting Up User Tables, Columns and Rows
You set up user tables in the Table Structure window.
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To set up the structure of a table:
1. Set your effective date to the date from which you want the table’s row labels to

take effect.

2. Enter the table name.

3. For the table’s match type, select Match or Range. Select Match if each row is for one
item, such as one job or one code. Select Range if each row is for a range of numeric
values, such as an age range or a pay range.

4. If the match type is Match, select Date, Number or Text as the Key Units of
Measure, depending on whether entries in the rows are dates, numbers, or
alphanumeric text.

If the table’s match type is Range, the Key Units of Measure automatically becomes
Number.

5. Enter the row label as the Row Title.

For example, if the table rows refer to rate codes, an appropriate row title would be
Rate Code. If the rows refer to age ranges, you might use the title Age Range.

6. Save your work, and choose the Columns button to go to the Columns window.

Column Setup

7. Enter labels for the table columns in the Name field.

Note: To add a new column to a table that already exists, place the
cursor on the name of the column after which you want to enter
the new column name, and choose Insert Record from the Edit
menu to obtain a clear field.

8. If you are using formula validation for a column’s entries, select the name of the
validation formula for the column.

9. Save your work and close the window.

Row Setup

10. In the Table Structure window, choose the Rows button to go to the Rows window.

11. If the match type of the table is Match, enter the label for each table row in the
fields under the heading Exact.

If the match type of the table is Range, enter numbers representing the lower and
upper boundary of each row’s range.

12. In the Sequence fields, you can optionally enter a number for each row label to
determine the order in which it appears on a list in the Table Values window. Logical
sequencing of row labels helps users enter table values rapidly and accurately.

13. When you are finished, save your work and close the window. Your table is now
set up and ready to receive entries into its columns.

Entering Table Values
If you have set up user-defined tables, you can enter and maintain values in the Table
Values window.
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You can access table values from any formula used for input-value validation, payroll
calculation or definition of skip-rules, assignment sets or QuickPaint reports. You can
access this information using the GET_TABLE_VALUE function.

Note: The system administrator can create configured versions of the
Table Values window so that you use each version for one user table
only.

To enter values into table columns:
1. Set your effective date to the date from which you want the entries to take effect.

2. Query the table name.

3. With the cursor in the Column Name field, use the up and down arrows to locate the
name of the column in which you want to make entries.

4. In the Values region, select each row for which you want to make an entry. You
select rows in the Exact field or the Lower Bound field, depending on the match
type of the table.

5. For each row, make the appropriate entry in the Value field.

6. Save your work.
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Lookups

Lookup Codes
Providing lists of valid values for certain items of information has two key advantages:

• It ensures that all users use the same terminology, which makes it easier to inquire
and report on the information.

• It speeds up data entry because you can enter just enough to identify the value, and
the system completes the entry.

In Oracle HRMS, a list of values is called a Lookup type. Each value comprises a code
and a meaning. For example:

Lookup type Code Meaning

YES_NO Y Yes

N No

The codes are used internally; users do not see them. There is a maximum of 250
Lookups for each Lookup type.

Predefined Lookup Types
A number of Lookup types are included in Oracle HRMS. For example, Lookup types
have been predefined for each segment within the Oracle US Federal Human Resources
key flexfields and Extra Information types.

Some Lookup types contain startup data. You can never delete these codes, but you can
change their meaning. However, it is recommended that you do not change the meaning
of Lookups that are specific to Oracle US Federal Human Resources.

For some Lookup types, you can also disable the codes that are supplied. Your ability
to disable codes and add new codes is determined by the access level of the Lookup
type as described in the following table:

Access Level Meaning

User You can add codes and you can disable
supplied codes

Extensible You can add new codes, but you cannot disable
supplied codes because the system uses them

System You can neither add codes nor disable supplied
codes. You can only change the meaning or
description of supplied codes.

You can also create your own Lookup Types in the Lookup type window. These all have
an access level of User.
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User and Extensible Lookups
The following table shows the field and legislation for user and extensible lookups.

Field Lookup Legislation

Category (absence) ABSENCE_CATEGORY All

Reason (for absence) ABSENCE_REASON All

Account Type (for bank
details)

ACC_TYPE All

Categories (for activities,
programs, packages)

ACTIVITY_CATEGORY All

Successful attendance (for
activity based events)

ACTIVITY_SUCCESS_CR
ITERIA

All

User Status (for an activity) ACTIVITY_USER_STATUS All

Address Type ADDRESS_TYPE All

AK Web Region Codes AK_WEB_REGION_CODES All

Reason (for application
assignment status)

APL_ASSIGN_REASON All

Type (event type for applicant) APL_EVENT_TYPE All

Type (interview type for
applicant)

APL_INTERVIEW_TYPE All

Reason (for secondary
assignment status)

APL_SEC_ASSIGN_REASON All

Appraisal and Assessment
Status (appraisal and
assessment on SSHR)

APPRAISAL_ASSESSMENT_
STATUS

All

Types of appraisal processed
by appraisal functionality

APPRAISAL_SYSTEM_TYPE All

Appraisal and Assessment
Type (appraisal and
assessment on SSHR)

APPRAISAL_TYPE All

AT_PROVINCE All

Activity (for work incident) AT_WORK_FLAG All

Australian Tax Office Codes AU_ATO_OFF Australia

Australian Direct Entry
Indicator

AU_DE_IND Australia

Australian Direct Entry
Transaction Code

AU_DE_TRN_CDE Australia
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Field Lookup Legislation

State (Australian addresses) AU_STATE All

Years until eligible for long
service leave on termination

AU_TERM_LSL_ELIGIBIL
ITY_YEARS

Australia

Balance Type Category BACKFEED_BT_CATEGORY All

Check Type Category BACKFEED_PD_CHECK_TY
PE

All

Bank account name BANK_ACCOUNT_NAME All

Bank account number BANK_ACCOUNT_
NUMBER

All

Bank account type BANK_ACCOUNT_TYPE All

Bank branch BANK_BRANCH All

Bank name BANK_NAME All

Bargaining Unit (for
assignment)

BARGAINING_UNIT_CODE All

Bank name BE_BANK Belgium

City (Belgian addresses) BE_CITY Belgium

Contract Category BE_CONTRACT_CATEGORY Belgium

Disciplinary Action BE_DISCIPLINARY_ACTION Belgium

Disciplinary Body BE_DISCIPLINARY_BODY Belgium

Employee Coding BE_EMPLOYEE_CODING Belgium

Employee Type BE_EMPLOYEE_TYPE Belgium

Ending Reason BE_ENDING_REASON Belgium

Misdemeanour Type BE_MISDEMEANOUR_TYPE Belgium

Organization Language BE_ORGANIZATION_
LANGUAGE

Belgium

Reduced Charges Category BE_REDUCED_CHARGES_
CATEGORY

Belgium

RSZ Category BE_RSZ_CATEGORY Belgium

Starting Reason BE_STARTING_REASON Belgium

Yes/No BE_YES_NO Belgium
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Field Lookup Legislation

Action Type BEN_ACTN_TYP All

Activity Type BEN_ACTY_TYP All

Benefits Balance Usage BEN_BNFTS_BAL_USG All

Certification Type BEN_BNF_CTFN_TYP All

BEN_CMP_ENRT_ACTN_TY
P

All

Compensation Category BEN_COMP_TYP All

Type BEN_CRT_ORDR_TYP All

Delivery Medium BEN_DLVRY_MED All

Delivery Method BEN_DLVRY_MTHD All

BEN_DLVRY_SCHED_INFO All

Dependent Coverage
Certification Type

BEN_DPNT_CVG_CTFN_TY
P

All

Enrollment Certification Type BEN_ENRT_CTFN_TYP All

Life Event Occurred Date
Code

BEN_EVAL_DET All

Change Event BEN_EXT_CHG_EVT All

Format Mask BEN_EXT_FRMT_MASK All

Operator BEN_EXT_OPER All

Run Status BEN_EXT_STAT All

Condition (Optional) Where BEN_EXT_TTL_COND_O
PER

All

Field BEN_FIELD All

BEN_FILE_CTL_TTL_TYP All

BEN_FILE_DTA_TYP All

Type BEN_FILE_RCRD_TYP All

BEN_FILE_TYP All

BEN_FILE_UPDT_TYP All

BEN_FL_TM_PT_TM All
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Field Lookup Legislation

Type BEN_GD_R_SVC_TYP All

BEN_GNDR All

Health Service BEN_HLTH_CARE_SVC_TYP All

BEN_INFO_SRC All

BEN_INTRFC_TYP All

BEN_MED_CNTNT_TYP All

BEN_MED_FMT_TYP All

Non-Monetary UOM BEN_NNMNTRY_UOM All

Option Type BEN_OPT_TYP All

Organization Roles BEN_ORG_ROLE_TYP All

Reason BEN_OVRID_RSN All

Designation code BEN_PCP_DSGN All

Program Group BEN_PGM_GRP All

Program Type BEN_PGM_TYP All

BEN_PIN_PRPS All

Product BEN_PRDCT All

Type BEN_PRMRY_CARE_
PRVDR_TYP

All

Primary Funding Method BEN_PRMRY_FNDG_MTHD All

BEN_PRTN_CTFN_TYP All

Payment Schedule BEN_PYMT_SCHED All

QDRO Payment Distribution BEN_QDRO_DSTR_MTHD All

Administrative Code BEN_REGN_ADMIN All

Regulatory Plan Type BEN_REGY_PL_TYP All

Regulatory Purpose BEN_REGY_PRPS All

Type BEN_REIMBMT_CTFN_TYP All

BEN_RESND_RSN All

BEN_RMBT_CTFN_TYP All
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Field Lookup Legislation

Purpose BEN_RPTG_PRPS All

Waive Coverage Reason BEN_WV_CVG_RSN All

Waive Participation
Certification Type

BEN_WV_PRTN_CTFN_TYP All

Waiving Participation Reason BEN_WV_PRTN_RSN All

Blood Type BLOOD_TYPE All

Source of student BOOKING_SOURCE All

Measurement Type (for
budget)

BUDGET_MEASUREMENT_
TYPE

All

Cash Analysis (for a cash
payment)

CASH_ANALYSIS All

Census Metropolitan Area
(Canada)

CA_CMA Canada

Canadian Payment
Association Codes

CA_DD_CPA_CODES Canada

Element categories CA_EMPLOYER_LIABILIT
IES

Canada

Select Form to be printed
(Canada)

CA_FORM_NAME Canada

Element categories CA_INVOLUNTARY_
DEDUCTIONS

Canada

Element categories CA_PAYMENT Canada

Province (Canadian addresses) CA_PROVINCE All

Element categories CA_REGULAR_EARNINGS Canada

Element categories CA_SUPPLEMENTAL_EARN
INGS

Canada

Element categories CA_TAXABLE_BENEFITS Canada

Element categories CA_VOLUNTARY_DEDUCT
IONS

Canada

Method CERTIFICATION_METHOD All

List of Swiss Cantons CH_CANTON All

CHECKBOX All

Check item (on a checklist) CHECKLIST_ITEM All
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Field Lookup Legislation

Status (of an item on a
checklist)

CHECKLIST_STATUS All

User friendly names for
cheque/check-ordering SQL
statement

CHEQUE_PROCEDURE All

User friendly names for
cheque/check-writing SRW2
reports.

CHEQUE_REPORT All

Company Age (for salary
surveys mappings)

COMPANY_AGE All

Company Size (for salary
surveys)

COMPANY_SIZE All

Primary Evaluation Method COMPETENCE_EVAL_TYPE All

Consultation Type CONSULTATION_TYPE All

Consultation Result CONSULTATION_RESULT All

Competence Type COMPETENCE_TYPE All

Type (relationship of one
person to another)

CONTACT All

Contract End Reason CONTRACT_END_REASON All

Contract Start Reason CONTRACT_START_
REASON

All

Contract Status CONTRACT_STATUS All

Contract Status Reason CONTRACT_STATUS_
REASON

All

Contract Types CONTRACT_TYPE All

Contract Types (Belgium) CONTRACT_TYPE_BE Belgium

Type (of MIX batch control
total)

CONTROL_TYPE All

Assignment Category CWK_ASG_CATEGORY All

Reason (for contingent worker
assignment)

CWK_ASSIGN_REASON All

Reason (for contingent worker
secondary assignment status)

CWK_SEC_ASSIGN_
REASON

All
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Field Lookup Legislation

Reason a student failed to
successfully complete an
event.

DELEGATE_FAILURE_
REASON

All

User defined Type to
categorize development
events.

DEV_EVENT_TYPE All

Bank Code DE_BANK_CODE Germany

Course Type (for
qualifications)

DE_COURSE_TYPE Germany

Establishment Type (for
qualifications)

DE_ESTABLISHMENT_TYPE Germany

Hereditary Title DE_HEREDITARY_TITLE Germany

Work Incident Status DE_INCIDENT_STATUS Germany

License Type (degree type) DE_LICENSE_TYPE Germany

Organization Link Type DE_LINK_TYPE Germany

Name Prefix DE_PREFIX Germany

Professional Title DE_PROF_TITLE Germany

DE_REGION All

Category (of disability) DISABILITY_CATEGORY All

Reason (for disability) DISABILITY_REASON All

Status (of disability) DISABILITY_STATUS All

Disease Type DISEASE_TYPE All

Document Status (contract) DOCUMENT_STATUS All

Reason (for element entry) ELE_ENTRY_REASON All

Reason (for employee
assignment)

EMP_ASSIGN_REASON All

Employment Category EMP_CAT All

Type (of employee event) EMP_EVENT_TYPE All

Type (of interview for
employee)

EMP_INTERVIEW_TYPE All

Reason (for secondary
assignment status)

EMP_SEC_ASSIGN_REASON All
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Employee Category EMPLOYEE_CATG Mexico

Reason (for change in
enrollment status)

ENROLLMENT_STATUS_
REASON

All

ES_PROVINCE All

Ethnic Origin ETH_TYPE All

System (job or position
evaluation system)

EVAL_SYSTEM All

Measurement In (type for
EVAL SYSTEM)

EVAL_SYSTEM_MEAS All

User defined status for an
event

EVENT_USER_STATUS All

Type (of work pattern
exception)

EXCEPTION_CATEGORY All

Type (of finance line) FINANCE_LINE_TYPE All

Type (of formula) FORMULA_TYPE All

Activity Type FR_ACTIVITY_TYPE France

Address Suffix FR_ADDRESS_SUFFIX France

AGIRC/ARRCO FR_AGIRC_ARRCO France

Bank FR_BANK France

Contract Category FR_CONTRACT_CATEGORY France

Disability/COTOREP Code FR_COTOREP_CODE France

DADS Type FR_DADS_TYPE France

Department FR_DEPARTMENT France

Disciplinary Actions FR_DISCIPLINARY_ACTION France

Education Status FR_EDUCATION_STATUS France

Employee Category FR_EMPLOYEE_CATEGORY France

Employee Status FR_EMPLOYEE_STATUS France

Employer Type FR_EMPLOYER_TYPE France

Employment Type FR_EMPLOYMENT_TYPE France

Ending Reason FR_ENDING_REASON France

3-124 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Field Lookup Legislation

Guaranteed ID FR_GI_TYPES France

Class of Illness FR_ILLNESS_CLASS France

Type of Illness FR_ILLNESS_TYPE France

Invalidity Category FR_INVALIDITY_CLASS France

Qualification Level FR_LEVEL_OF_WORKER France

Mandate Type FR_MANDATE_TYPE France

Type of Medical Examination FR_MEDICAL_EXAMINAT
ION_TYPE

France

Result of Medical Examination FR_MEDICAL_RESULT France

Military Service Status FR_MILITARY_SERVICE_
STATUS

France

Military Service Types FR_MILITARY_SERVICE_TY
PE

France

Misdemeanor Type FR_MISDEMEANOUR_TYPE France

NAF/APE Code FR_NAF_CODE France

PCS Code FR_PCS_CODE France

Pension Code FR_PENSION_CODE France

Reason (in Person EIT-French
Public Sector additional
Seniority Details)

FR_PQH_ADDL_REASON France

Activity (in Person EIT-French
Public Sector Soldier Details)

FR_PQH_ARMY_ACTIVITY France

Army Body (in Person EIT-
French Public Sector Soldier
Details)

FR_PQH_ARMY_BODY France

Hierarchy (in Person EIT-
French Public Sector Soldier
Details)

FR_PQH_ARMY_H
IERARCHY

France

Rank (in Person EIT-French
Public Sector Soldier Details)

FR_PQH_ARMY_RANK France

Bonification Type (in Person
EIT-French Public Sector
Bonification Details)

FR_PQH_BONIFICATION_
TYPE

France

Level FR_PQH_COMMITTEE_
LEVEL

France

Extending Oracle HRMS 3-125



Field Lookup Legislation

Type (Members) FR_PQH_COMMITTEE_
MEMBER_TYPE

France

Mention (in Qualification Type
DDF)

FR_PQH_DIPLOMA_MENT
ION

France

Optional (in Qualification
Type DDF)

FR_PQH_DIPLOMA_OPT
ION

France

Specialty (in Qualification
Type DDF)

FR_PQH_DIPLOMA_SPEC
IALITY

France

Sub-Specialty (in Qualification
Type DDF)

FR_PQH_DIPLOMA_SUB_S
PECIALITY

France

Relationship Type FR_PQH_EXT_ORG_TYPE France

Category (in Corps) FR_PQH_GRADE_
CATEGORY

France

Badge Name (in Ministry
Awards SIT)

FR_PQH_MINISTRY_
BADGE_NAME

France

Level (in Ministry Awards SIT) FR_PQH_MINISTRY_LEVEL France

Medal Name (in Ministry
Awards SIT)

FR_PQH_MINISTRY_
MEDAL_NAME

France

Order Name (in Ministry
Awards SIT)

FR_PQH_MINISTRY_
ORDER_NAME

France

Activity (in Organization EIT) FR_PQH_ORG_ACTIVITY France

Physical Share (in Assignment:
Statutory Information)

FR_PQH_PHYSICAL_SHARE France

Type of Service (in Person
EIT-French Public Sector
Soldier Details)

FR_PQH_TYPE_OF_ARMY_
SERVICE

France

Event FR_PQH_VALIDATION_
EVENT

France

Previous Employer COTOREP
Type

FR_PREVIOUS_COTOREP France

Department FR_REGION France

Representative Type FR_REPRESENTATIVE_TYPE France

Starting Reason FR_STARTING_REASON France

Types of French Training FR_TRAINING_TYPE France

Type of Worker FR_TYPE_OF_WORKER France
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URSSAF Code FR_URSSAF_CODE France

Visa Status FR_VISA_STATUS France

Visa Type FR_VISA_TYPE France

Work Accident Code FR_WORK_ACCIDENT_
CODE

France

Work Accident Result FR_WORK_ACCIDENT_
RESULT

France

Type of Work Accident FR_WORK_ACCIDENT_TY
PE

France

Work Pattern FR_WORK_PATTERN France

Medical Service FR_WORK_MEDICAL_SERV
ICE

France

Situation Sub Type FR_PQH_STAT_SIT_SUB_TY
PE

France

Situation Reason FR_PQH_STAT_SIT_REASON France

Type of Request FR_PQH_STAT_SIT_RQST_
TYPE

France

Representative Body’s method
of funding

FUNDING_METHOD All

Authority (for PAYE details) GB_AUTHORITY GB

Bank Name GB_BANKS GB

Certificate (for element NI) GB_CERTIFICATE GB

Cheque/Check Style GB_CHEQUE_REPORT GB

County (UK addresses) GB_COUNTY GB

Pay day type GB_PAY_DAY_TYPE GB

Pension GB_PENSION GB

Allows users to to define valid
SCON number for NI SCON
input

GB_SCON GB

Sequence (for the BACS
process)

GB_SORT_SEQUENCE GB

Names of Item Types for HR
Summary Process

GSP_ITEM_TYPE All
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Names of Key Types for HR
Summary Process

GSP_KEY_TYPE All

Names of Restriction Types for
HR Summary Process

GSP_RESTRICTION_TYPE All

Hazard HAZARD_TYPE All

Area (Hong Kong addresses) HK_AREA_CODES Hong Kong

Rental/Passage Deduction
Level

HK_DEDUCTION_LEVEL Hong Kong

Leaving Reasons HK_DEPARTURE_REASONS Hong Kong

IR56B Origin HK_IR56B_ORIGIN Hong Kong

IR56 Box Descriptions HK_IR56_BOX_DESC Hong Kong

MPF Voluntary Processing
Rules

HK_MPF_PROC_RULE Hong Kong

MPF Wage Base HK_MPF_WAGE_BASE Hong Kong

Nature of Quarters HK_NATURE_OF_
QUARTERS

Hong Kong

Overseas Payment Amount
Known

HK_OVERSEAS_PAYMENT Hong Kong

Returning to Hong Kong HK_RETURN_TO_HK Hong Kong

Tax Reporting Year HK_TAX_YEAR Hong Kong

Document Category HR_ADI_DOCUMENT_TYPE All

Date Posted HR_APPLICATION_DATE All

Hire Date HR_HIRE_DATE All

Banks in Ireland HR_IE_BANK Ireland

Date Posted HR_JOB_POSTED_DATE All

HR Metalink Application HR_METALINK_APPLICAT
ION

All

Academic Title HR_NL_ACADEMIC_TITLE NL

Dutch Bank Details HR_NL_BANK NL

Dutch Cities HR_NL_CITY NL

Correspondence Language HR_CORR_LANGUAGE NL
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Dutch HR WAO Disability HR_NL_DI_WAO NL

Full Name Format HR_NL_FULL_NAME_
FORMAT

NL

Identification Certificate HR_NL_ID_CERTIFICATE NL

Job Level HR_NL_JOB_LEVEL NL

Nationality HR_NL_NATIONALITY NL

Province HR_NL_PROVINCE NL

Dutch Regions HR_NL_REGIONS NL

Royal Title HR_NL_ROTAL_TITLE NL

End Reasons for Social Health
Insurance Report

HR_NL_SHI_END NL

Special Title HR_NL_SPECIAL_TITLE NL

Field Labels HR_FORM_LABELS NL

Batch process used by OTM HXT_BATCH_STATUS All

Days of the week HXT_DAY_OF_WEEK All

Process modes used by OTM HXT_PROCESS_MODE All

Benefit Type IE_BENEFIT_TYPE Ireland

Calculation Option IE_CALC_OPTION Ireland

Ethnic Origin, Mother’s
Maiden Name

IE_FORM_LABELS Ireland

County (Irish addresses) IE_COUNTY Ireland

Basis of Tax Assessment IE_PAYE_ASSESS_BASIS Ireland

Information Source IE_PAYE_INFO_SOURCE Ireland

Tax Basis IE_PAYE_TAX_BASIS Ireland

Postal Code IE_POSTAL_CODE Ireland

Contribution Class IE_PRSI_CONT_CLASS Ireland

Qualification Type IE_QUAL_TYPES Ireland

Incident Type INCIDENT_TYPE All

Industry (for salary survey) INDUSTRY All
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Injury INJURY_TYPE All

Bank Name IT_BANK Italy

City (Italian addresses) IT_CITY Italy

Collective Agreement IT_COLLECTIVE
AGREEMENTS

Italy

Contract Type IT_CONTRACT_TYPE Italy

Text to be displayed on Italian
specific field prompts

IT_FORM_LABELS Italy

Employment Category IT_EMP_CAT Italy

Province (Italian addresses) IT_PROVINCE All

Trade Unions IT_TRADE_UNIONS Italy

Unemployment Insurance
Codes

IT_UNEMPLOYMENT_
INSURANCE_CODE

Italy

Unemployment Insurance Sub
Codes

IT_UNEMPLOYMENT_INS_
SUB_CODE

Italy

Extra Job Information JOB_CATEGORY All

Categories of Jobs JOB_CATEGORIES All

Representative Body’s
Jurisdiction

JURISDICTION All

Reason (for leaving) LEAV_REAS All

LOCAL_BAL_FORM_NAME All

Marital Status MAR_STATUS All

Marital Status (Belgium) MAR_STATUS_BE Belgium

Government Employment
Sector

MX_HR_EMP_CAT Mexico

MX_SOCIAL_SECURITY_
SALARY_TYPE

Social Security Salary Type Mexico

MX_STATE All

MY_STATE All

North American Industry
Code for Canada

NAIC All
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Nationality NATIONALITY All

NI Unique Error or Warning NI_UNIQUE_ERROR_WARN
ING

All

NL_REGION All

Reason NPW_TERMINATION_
REASONS

All

Region (New Zealand
addresses)

NZ_COUNTIES All

District of Origin NZ_DISTRICT_OF_ORIGIN New Zealand

Ethnic Origin NZ_ETHNIC_ORIGIN New Zealand

Tribal Group NZ_TRIBAL_GROUP New Zealand

Organization Type ORG_TYPE All

Class Begins OTA_ENROLL_CLASS_
DATE

All

Use to which a work pattern is
or may be put

PATTERN_PURPOSE All

Type of checksum used for
deductions batches

PAY_PDT_DED_CKSUM All

Type of checksum used for
earnings deductions batches

PAY_PDT_EARN_CKSUM All

Type of checksum used for
time entry batches

PAY_PDT_TIME_CKSUM All

Category PER_CATEGORIES All

Communication delivery
method, Report Method

PER_CM_MTHD All

Cluster PER_COMPETENCE_
CLUSTER

All

FTE Capacity PER_FTE_CAPACITY All

Minimum Service PER_LENGTHS_OF_SERV
ICE

All

Field PER_QUAL_FWK_FIELD All

Provider PER_QUAL_FWK_PROV
IDER

All

QA Organization PER_QUAL_FWK_QA_ORG All
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Sub-Field PER_QUAL_FWK_SUB_F
IELD

All

Relocation PER_RELOCATION_
PREFERENCES

All

Status PER_SUBJECT_STATUSES All

Subject PER_SUBJECTS All

Work Duration PER_TIME_SCALES All

Tuition Method PER_TUITION_METHODS All

US Country Code PER_US_COUNTRY_CODE USA

I9 Status PER_US_I9_STATE USA

US Income Types PER_US_INCOME_TYPES USA

US Process Type PER_US_PROCESS_TYPE USA

US Residency Status PER_US_RES_STATUS USA

US Visa Categories PER_US_VISA_CATEGORIES USA

US Visa Types PER_US_VISA_TYPES USA

US Visit Code PER_US_VISIT_CODE USA

Work Hours PER_WORK_HOURS All

Work Schedule PER_WORK_SCHEDULE All

Rating PERFORMANCE_RATING All

Type PHONE_TYPE All

Reason (for grade step
placement)

PLACEMENT_REASON All

Position Family POSITION_FAMILY All

Status (of reserved position) POSITION_RESERVED_
STATUS

All

Status (of position) POSITION_STATUS All

Academic Rank PQH_ACADEMIC_RANK USA

Document Type (in Corps:
Document Details)

PQH_CORPS_DOC_TYPE FR
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Type of Exam (in Corps:
Entrance Exams)

PQH_CORPS_EXAM_TYPE FR

Filere (in Position and Corps
HGRID)

PQH_CORPS_FILERES FR

Way of Joining Corps (in
Corps: Other Details)

PQH_CORPS_WAYS FR

Requirements (in Corps: Other
Details)

PQH_CORPS_WAYS_CRITER
IA

FR

PQH_PA_HGRID_NODE_
IMAGE

All

PQH_PA_HGRID_
ROLLOVER_TEXT

All

Tenure Status PQH_TENURE_STATUS USA

Element Extra Information
(rate type name)

PQP_RATE_TYPE UK

Subtype (for previous
employer)

PREV_EMP_SUBTYPE All

Type (for previous employer) PREV_EMP_TYPE All

Student Enrollments Priority PRIORITY_LEVEL All

Type (of Professional Credits) PROFESSIONAL_CREDIT_
TYPE

All

Source of Proficiency Rating PROFICIENCY_SOURCE All

A label given to group events
within a program

PROGRAM_MEMBERSHIP_
GROUP

All

Reason (for salary proposal) PROPOSAL_REASON All

Units (qualifying units for
probation period)

QUALIFYING_UNITS All

Basis RATE_BASIS All

Type (of recruitment activity,
also used in application
source)

REC_TYPE All

Report Method REPORT_METHOD All

RECON_STATUS All

Type (of resource) RESOURCE_TYPE All
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Reason (a resource is used by
an activity)

RESOURCE_USAGE_
REASON

All

Account Type SG_ACCOUNT_TYPE Singapore

Bank Code SG_BANK_CODE Singapore

Employer IRAS Category SG_EMPLOYER_IRAS_
CATEGORY

Singapore

Permit Category SG_PERMIT_CATEGORY Singapore

Race SG_RACE Singapore

Religion SG_RELIGION Singapore

Survey Age (for salary
surveys)

SURVEY_AGE All

Survey Company (for salary
surveys)

SURVEY_COMPANY All

Job Name (for salary surveys) SURVEY_JOB_NAME All

Region (for salary surveys) SURVEY_REGION All

Seniority (for salary surveys) SURVEY_SENIORITY All

Reason (for terminating
application)

TERM_APL_REASON All

Prefix TITLE All

Uses Tobacco (for benefits) TOBACCO_USER All

Role (of trainer in event) TRAINER_PARTICIPATION All

Center (where event takes
place)

TRAINING_CENTRE All

Type (of unit for event pricing) TRAINING_UNIT All

Accrual Start US_ACCRUAL_START_TYPE All

Status of request for
accommodation

US_ADA_STATUSES All

Coverage Level (for medical,
dental and vision benefit
plans)

US_BENEFIT_COVERAGE All

Status (of continued coverage) US_COBRA_STATUS All

Reason (for COBRA
Termination)

US_COBRA_TERM_REASON All
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Category (within Earnings
classification)

US_EARNINGS All

Category (within Imputed
Earnings classification)

US_IMPUTED_EARNINGS All

Category (within Information
classification)

US_INFORMATION All

Category (within Involuntary
Deductions classification)

US_INVOLUNTARY_
DEDUCTIONS

All

Job Groups US_JOB_GROUPS All

Filing Status for local income
tax

US_LIT_FILING_STATUS All

Exemption Reason (for
excluding employee from
New Hire report)

US_NEW_HIRE_EXCEPT
IONS

All

Category (within Nonpayroll
Payments classification)

US_PAYMENT All

Category (of accrual plan) US_PTO_ACCRUAL All

Filing Status for state income
tax

US_SIT_FILING_STATUS All

State (US addresses) US_STATE All

Category (within
Supplemental Earnings
classification)

US_SUPPLEMENTAL_EARN
INGS

All

Row Type (for Payroll Tables) US_TABLE_ROW_TYPES All

List of different instances of
US Payroll Tax Balance reports

US_TAX_REPORT All

Category (within Voluntary
Deductions classification)

US_VOLUNTARY_DEDUCT
IONS

All

Position of WC surcharge
(after experience
modifications and after
premium discount)

US_WC_SURCHARGE_POS
ITION

All

Category (of a vacancy, for use
in HR Direct Access)

VACANCY_CATEGORY All

Status (of a vacancy) VACANCY_STATUS All

Type of Reporting
Organization

VETS_ORG_TYPE All
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User friendly names for
cheque writing SRW2 reports

W2_BOX-14_USER_DEFINED All

Name (of global used in
workflow)

WF_GLOBAL All

Availability Schedule WORK_SCHEDULE All

Aggregate Third Party Cheque
Types

ZA_AGG_3RD_CHEQUE_RE
PORT

S Africa

Cheque Reports ZA_CHEQUE_REPORT S Africa

Credit Transfer Cheque
Reports

ZA_CT_CHEQUE_REPORT S Africa

Employment Equity
Occupational Categories

ZA_EMP_EQ_OCCUPAT
IONAL_CAT

S Africa

Employment Equity
Occupational Levels

ZA_EMP_EQ_OCCUPAT
IONAL_LEV

S Africa

Employment Equity Reports ZA_EMP_EQ_REPORT_
VALUES

S Africa

Language Preference ZA_LANG_PREF S Africa

NQF Activity Names ZA_NQF_ACTIVITY_
NAMES

S Africa

NQF Chamber Names ZA_NQF_CHAMBER_
NAMES

S Africa

Race ZA_RACE S Africa

Religion ZA_RELIGION S Africa

RSC Regions ZA_RSC_REGIONS S Africa

Sort Order for Tax Certificates ZA_TAXCERT_SORT S Africa

Tax Area CN_TAX_AREA China

Social Insurance/PHF
Contribution Area

CN_SIC_AREA China

Notice Duration Unit CN_DURATION_UNIT China

Province/City/SAR (Personal
Address Information and
Location Address windows)

CN_PROVINCE China

Hukou Location CN_HUKOU_LOCN China

Hukou Type CN_HUKOU_TYPE China
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Health Status CN_HEALTH_STATUS China

Race/Ethnic Origin CN_RACE China

Highest Education Level CN_HIGH_EDU_LEVEL China

Enterprise Category CN_ENTRP_CATEGORY China

Archive Format CN_FILE_ARCHIVE China

Last Level CN_MILITARY_LEVEL China

Last Rank CN_MILITARY_RANK China

Type of Exception CN_PARTY_EXCEPTION China

Party Status CN_PARTY_STATUS China

Party Type CN_PARTY_TYPE China

Type CN_RDP_TYPE China

Technical Title CN_TECH_TITLE China

Way to obtain Title CN_TECH_WAY China

Religion GCC_RELIGION For all GCC countries. Saudi
Arabia, Kuwait

Employment Status SA_EMPLOYMENT_STATUS Saudi Arabia

City SA_CITY Saudi Arabia

Bank SA_BANKS Saudi Arabia

Bank HU_BANKS Hungary

County HU_COUNTY Hungary

Location Types HU_LOCATION_TYPES Hungary

Nationality HU_NATIONALITY Hungary

Form Labels HU_FORM_LABELS Hungary

Company Formation HU_COMPANY_FORMAT
ION

Hungary

Pension Provider HU_PENSION_PROVIDERS Hungary

Job Classification HU_JOB_CLASSIFICATION Hungary

Joining Reason HU_JOINING_REASON Hungary
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Military Rank HU_MILITARY_RANK Hungary

Civil Defense Organization HU_CIVIL_DEFENCE_ORG Hungary

Civil Local Department HU_CIVIL_LOCAL_DEPT Hungary

Civil Local Sub Department HU_CIVIL_LOCAL_SUB_DE
PT

Hungary

Civil Group HU_CIVIL_GROUP Hungary

Civil Sub Group HU_CIVIL_SUB_GROUP Hungary

Banks ES_BANKS Spain

Company Types ES_COMPANY_TYPES Spain

Province ES_PROVINCE Spain

Province codes ES_PROVINCE_CODES Spain

Form Labels ES_FORM_LABELS Spain

Identifier Type ES_IDENTIFIER_TYPE Spain

Epigraphs ES_EPIGRAPHS Spain

Contract Subtype ES_CONTRACT_SUBTYPE Spain

Contract Replacement Reason ES_CONTRACT_RE
PLACEMENT_REASON

Spain

Worker Status ES_WORKER_STATUS Spain

Unemployment Status ES_UNEMPLOYMENT_
STATUS

Spain

Special Relationship Type ES_SPECIAL_RELATIONSHI
P_TYPE

Spain

Contract Start Reason ES_CONTRACT_START_
REASON_UDT

Spain

Payment Key ES_PAYMENT_KEY Spain

Sub Payment Key (for
Payment Key B)

ES_SUB_PAYMENT_KEY_B Spain

Sub Payment Key (for
Payment Key F)

ES_SUB_PAYMENT_KEY_F Spain

Sub Payment Key (for
Payment Key G)

ES_SUB_PAYMENT_KEY_G Spain
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Sub Payment Key (for
Payment Key H)

ES_SUB_PAYMENT_KEY_H Spain

Sub Payment Key (for
Payment Key L)

ES_SUB_PAYMENT_KEY_L Spain

Contract Subtype ES_CONTRACT_SUB_TYPE_
UDT

Spain

State/UT IN_STATES India

Pin Code IN_PIN_CODES India

Bank Name IN_BANK India

Branch Name IN_BANK_BRANCH India

Account Type IN_ACCOUNT_TYPE India

Contribution Period IN_ESI_CONTRIB_PERIOD India

Currency Period IN_FINANCIAL_YEAR India

Remittance Month IN_CALENDAR_MONTH India

Nature of Injury IN_INJURY India

Disablement Level IN_DISABLEMENT_LEVEL India

Type (Extra Contact
Information)

IN_NOMINATION_TYPES India

Residential Status IN_RESIDENTIAL_STATUS India

Religion IN_RELIGION India

Community IN_COMMUNITY India

Employer Classification IN_ER_CLASS India

Trust Classification IN_PF_CLASSIFICATION India

Office Type IN_OFFICE_TYPES India

Industry Classification IN_IND_CLASS India

Joy Type IN_JOB_TYPE India

Governorate KW_GOVERNORATE Kuwait

Employment Status KW_EMPLOYMENT_
STATUS

Kuwait
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Banks KW_BANKS Kuwait

Company Types KW_COMPANY_TYPE Kuwait

User and Extensible Lookups for Oracle US Federal HR
This table contains user and extensible Lookups that are predefined with the Oracle US
Federal Human Resources. Lookups specific to Oracle HRMS are listed separately. See
User and Extensible Lookups, page 3-117.

Field Lookups

Academic Discipline GHR_US_ACADEMIC_DISCIPLINE

Academic Institution Name GHR_US_ACADEMIC_INSTITUTION

Adverse Action NOA Codes GHR_US_ADVERSE_ACTION_NOAC

Age Complaint Basis GHR_US_COM_AGE_BASIS

Agency Code GHR_US_AGENCY_CODE_2

Agency Code Transfer Form GHR_US_AGENCY_CODE

Agency Complaint Action GHR_US_AGENCY_ACTION

Annuitant Indicator GHR_US_ANNUITANT_INDICATOR

Appointment Type GHR_US_APPOINTMENT_TYPE

Appraisal System Identifier GHR_US_APPRAISAL_SYS_ID

Appraisal Type GHR_US_APPRAISAL_TYPE

Appropriation Code-1 GHR_US_APPROPRIATION_CODE1

Appropriation Code-2 GHR_US_APPROPRIATION_CODE2

Award Type GHR_US_AWARD_TYPE

Award Unit of Measure GHR_US_AWARD_UOM

Bargaining Unit Status GHR_US_BARG_UNIT_STATUS

Breakdown Rpt: By Clause GHR_US_BRKDWN_BY_CLAUSE

Breakdown Rpt: Within Clause GHR_US_BRKDWN_WITHIN_CLAUSE

Category GHR_US_CATEGORY

Cause of Disciplinary Action GHR_US_CAUSE_DISP_ACTION
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Citizenship GHR_US_CITIZENSHIP

Civilian Duty Stat Contingency GHR_US_CIV_DTY_STATUS_CONT

Class Graded GHR_US_CLASS_GRADE_BY

Classification Official GHR_US_CLASSFCTN_OFFICIAL

College-Major-Minor GHR_US_COLLEGE_MAJ_MIN

Complaint Accepted or Rejected GHR_US_ACCEPT_REJECT_ISSUES

Complaint Basis Category GHR_US_BASIS_CATEGORY

Complaint Closure Decision GHR_US_DEC_CLOSURE

Complaint Closure Types GHR_US_NATURE_CLOSING

Complaint Corrective Action GHR_US_CORRECT_ACTION

Complaint Cost Unit GHR_US_COST_UNIT

Complaint Individual Type GHR_US_TYPE_INDV_INVOLVED

Complaint Issues GHR_US_COM_ISSUE

Complaint Statutes GHR_US_BASIS_STATUTE

Complaint Type, Class or Indiv GHR_US_COMPLAINT_TYPE

Consent ID GHR_US_CONSENT_ID

Counselor Report Type GHR_US_COUNSELOR_RPT_TYPE

Country World Citizenship GHR_US_CNTRY_WRLD_CTZN

Credit Hours GHR_US_CREDIT_HOURS

Credit Type GHR_US_CREDIT_TYPE

Creditable Military Service GHR_US_CREDIT_MIL_SVC

Currency GHR_US_CURRENCY

Days Suspended GHR_US_DAYS_SUSPENDED

Drawdown Action ID GHR_US_DRAWDOWN_ID

Drug Test GHR_US_DRUG_TEST

Duty Station ID GHR_US_DUTY_STATION_ID

Duty Status GHR_US_DUTY_STATUS
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Education Level GHR_US_EDUCATIONAL_LEVEL

EEO Counselor Status GHR_US_COUNSELOR_STATUS

EEO Investigator Status GHR_US_INVESTIGATOR_STATUS

EEOC Complaint Recommended Dec GHR_US_EEOC_RECOM_DEC

EEOC Complaint Recommended Dec GHR_US_EEOC_RECOM_DEC_ACT

Employment Category Group GHR_US_EMP_CAT_GRP

Enrollment GHR_US_ENROLLMENT

Entitlement Code GHR_US_ENTITLEMENT_CODE

Exception Retirement Pay Ind GHR_US_EXCEPTION_RETIREMENT

Family Member Employment Pref GHR_US_FAM_MBR_EMPLMNT_PREF

Family Member Status GHR_US_FAMILY_MEMBER_STATUS

FEGLI GHR_US_FEGLI

FERS Coverage GHR_US_FERS_COVERAGE

Final Organization Decision GHR_US_FINAL_ORG_DEC

Financial Statement GHR_US_FINANCIAL_STATEMENT

FLSA Category GHR_US_FLSA_CATEGORY

Formal Complaint Recommended D GHR_US_FRM_RECOM_DEC

Formal Complaint Recommended D GHR_US_FRM_RECOM_DEC_ACT

Frozen Service GHR_US_FROZEN_SERVICE

Functional Class GHR_US_FUNCTIONAL_CLASS

GHR Event Code Categories GHR_US_EVENT_CATEGORIES

Grade or Level GHR_US_GRADE_OR_LEVEL

Handicap Code GHR_US_HANDICAP_CODE

Handicap Complaint Basis GHR_US_COM_HC_BASIS

Hazard Type GHR_US_HAZARD_TYPE

Health Plan GHR_US_HEALTH_PLAN

Hierarchy Level Names GHR_US_HIERARCHY_LEVEL
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Field Lookups

Intelligence Position Ind GHR_US_INTEL_POSN_INDICATOR

Investigator Report Type GHR_US_INVESTIGATOR_RPT_TYPE

Investigators Recommended Deci GHR_US_INV_RECOM_DEC

Key Emergency Essential GHR_US_KEY_EMERG_ESSENTIAL

Key Emergency Essential Empl GHR_US_ASGN_KEY_EMERG_ESSEN

Language Identifier GHR_US_LANG_IDENTIFIER

Language Proficiency Level GHR_US_LANG_PROF_LEVEL

Language Reading Proficiency GHR_US_LANG_PROF

Language Required GHR_US_LANGUAGE_REQUIRED

Last Action Code GHR_US_LAST_ACTION_CODE

Legal Authorities GHR_US_LEGAL_AUTHORITY

LEO Position Indicator GHR_US_LEO_POSN_INDICATOR

Mass Action Status GHR_US_MASS_ACTION_STATUS

Military Recall Status GHR_US_MILITARY_RECALL

Military Retirement Waiver Ind GHR_US_MIL_RETIREMNT_WAIVER

NAF Retirement Indicator GHR_US_NAF_RETIRE_INDIC

National Origin Complaint Basi GHR_US_COM_NO_BASIS

Non-Disclosure Agmt Status GHR_US_NON_DISCLOSURE_AGREE

Obligated Employee SSN GHR_US_OBLIGATED_EMPL_SSN

Obligated Position Number GHR_US_OBLIG_POSN_NUM

Obligated Position Type GHR_US_OBLIG_POSN_TYPE

Obligated Type GHR_US_OBLIGATED_POSN_TYPE

Occupation Category Code GHR_US_OCC_CATEGORY_CODE

Occupational Series GHR_US_OCC_SERIES

Organization Function Code GHR_US_ORG_FUNC_CODE

Organization Identifier* GHR_US_ORGANIZATION_ID

Part-time Indicator GHR_US_PART_TIME_INDICATOR
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Field Lookups

Pay Level or Rate GHR_US_PAY_LEVEL_RATE

Pay Rate Determinant GHR_US_PAY_RATE_DETERMINANT

Payroll Office ID GHR_US_PAYROLL_OFFICE

Personnel Sec Clearance GHR_US_PERS_SEC_CLEAR

Physical Exam or Test Type GHR_US_PHYSICAL_EXAM

PIP Action Taken GHR_US_PIP_ACTION_TAKEN

PIP Extensions GHR_US_PIP_EXTENSIONS

PIP Length GHR_US_PIP_LENGTH

Position Description ID GHR_US_POSITION_DESCRIPTION

Position Occupied GHR_US_POSITION_OCCUPIED

Position Sensitivity GHR_US_POSN_SENSITIVITY

Position Type GHR_US_POSITION_TYPE

Position Working Title GHR_US_WORKING_TITLE

Premium Pay Indicator GHR_US_PREM_PAY_IND

Previous Retirement Coverage GHR_US_PREV_RETIRE_COVER

Processing Methods GHR_US_PROCESS_METHODS

PRP/SCI GHR_US_SECURITY_PRP/SCI

PRP/SCI GHR_US_SECURITY_PRP_SCI

PRP/SCI Status Employment GHR_US_PRP/SCI_STATUS

Qualification Standards Waiver GHR_US_QUAL_STND_WAIVER

Quarters Group GHR_US_QUARTERS_GROUP

Quarters Type GHR_US_QUARTERS_TYPE

Race National Origin GHR_US_RACE_NATIONAL_ORIGIN

Race/Color Complaint Basis GHR_US_COM_RC_BASIS

Rating of Record GHR_US_RATING_OF_RECORD

Rating of Record Level GHR_US_RATING_LEVEL

Rating of Record Pattern GHR_US_RATING_PATTERN
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Field Lookups

Reason for Complaint Rejection GHR_US_REJECT_REASON

Reason for Separation GHR_US_SEPARATION_REASON

Religious Complaint Basis GHR_US_COM_REL_BASIS

Reprisal Complaint Basis GHR_US_COM_REP_BASIS

Reserve Category GHR_US_RESERVE_CATEGORY

Restricted Form GHR_US_RESTRICTED_FORM

Retained Locality Percent GHR_US_LOCALITY_PERCENT

Retained Pay Basis GHR_US_PAY_BASIS

Retained Pay Table ID GHR_US_PAY_TABLE_ID

Retirement Grade GHR_US_RETIREMENT_GRADE

Retirement Plan GHR_US_RETIREMENT_PLAN

Sec Investigation Basis GHR_US_SEC_INVEST_BASIS

Security Access GHR_US_SECURITY_ACCESS

Separate Payroll Office Number GHR_US_SEP_PAYROLL_OFFICE_NO

Separate Pkg Register Number GHR_US_SEP_PKG_REG_NUM

Seperate Pkg Status Indicator GHR_US_SEP_PKG_STAT_INDCTR

Service GHR_US_SERVICE

Sex Complaint Basis GHR_US_COM_SEX_BASIS

Spcl Plcmt Consid Reason GHR_US_SPEC_PLCMT_CNSID_RSN

Spvr/Mgr Prob Completion GHR_US_SUPV_MGR_PROB_COMP

Stage of Complaint GHR_US_COM_STAGE

Stage of Complaint Closing GHR_US_STAGE_CLOSING

Step or Rate GHR_US_STEP

Submission Reason GHR_US_SUBMISSION_REASON

Supervisory Diff Eligibility GHR_US_SUPV_DIFF_ELIG

Supervisory Status GHR_US_SUPERVISORY_STATUS

Temps Total Cost GHR_US_TEMPS_TOTAL_COST
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Field Lookups

Tenure GHR_US_TENURE

Tenure Group for RIF GHR_US_TENURE_GROUP

Tenure Sub Group for RIF (Veteran’s
Preferance)

GHR_US_VETERANS_PREF_SUB_GROUP

Timekeeper GHR_US_TIMEKEEPER

Trainee Promotion ID GHR_US_TRAINEE_PROMOTION_ID

Training Program ID GHR_US_TRAINING_PROGRAM_ID

TSP Status GHR_US_TSP_STATUS

Type Employee Supervised GHR_US_TYPE_EMP_SUPERVISED

Type of Complaint Cost GHR_US_COST_TYPE

Type of Complaint Official GHR_US_EEO_OFFICIAL

Type of Employment GHR_US_TYPE_EMPLOYMENT

Type of Individual Incurring C GHR_US_TYPE_INDIV_INVOLVED

Type of Occupational Cert GHR_US_TYPE_OCC_CERT

Type of School GHR_US_TYPE_OF_SCHOOL

Type of Sec Investigation GHR_US_TYPE_SEC_INVESTIGATN

Uniform Service Component GHR_US_UNIFRM_SRVC_COMPONT

Uniform Service Designation GHR_US_UNIFRM_SRVC_DESGNATN

Unit GHR_US_UNIT

Veterans Preference GHR_US_VETERANS_PREF

Veterans Preference for RIF GHR_US_VETERANS_PREF_FOR_RIF

Veterans Status GHR_US_VET_STATUS

Within Grade Increase Status GHR_US_WGI_STATUS

Work Schedule GHR_US_WORK_SCHEDULE

Year Degree / Cert Attained GHR_US_YEAR_DEGREE_ATTAINED

Adding Lookup Types and Values
To create a new lookup type, add values to an existing lookup type, or prevent existing
values from appearing in a lookup type, use the Application Utilities Lookups window.
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Note: You must log out and log in again to see the effect of your changes.

Defining Lookup Types

You can create your own lookup types to provide lists of values, for example to validate
element entries.

To define a new lookup type and lookup values:
1. Choose the access level for the lookup type.

2. Enter the lookup type.

3. Enter the user name of the lookup. This is the name that users will see from within
the application.

Note: For US Federal users: Do not prefix EIT definitions with
GHR_US. This prefix is reserved for the predelivered US Federal
definitions.

4. Select the application in which the lookup will be used.

5. Optionally, add a description of the lookup type.

6. If you want to add lookup values specific to the security group/business group
linked to your current responsibility, un-check the Global Security Group check
box. Existing lookup values are available to all business groups.

Important: The Global Security Group check box only displays if
you are using Security Group Enabled Security with a non-default
security group. If you use Standard HRMS security, or the default
(Standard) security group in Security Group Enabled Security, all
lookup types are global.

See: Categorizing Information By Security Groups, page 1-11

7. Enter the code, meaning and optionally a description for each value. Leave the
Tag column blank.

If you do not enter a start date, the new lookup is valid immediately. If you do not
enter an end date, the new lookup is valid indefinitely.

8. Save your work.

Defining Lookup Values

To add lookup values to an existing lookup type:
1. Query the lookup type to which you want to add a value.

You cannot add values if the access level is System.

2. If you want to add lookup values specific to the security group/business group
linked to your current responsibility, un-check the Global Security Group check
box. Existing lookup values are available to all business groups.

Important: The Global Security Group check box only displays if
you are using Security Group Enabled Security with a non-default
security group. If you use Standard HRMS security, or the default
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(Standard) security group in Security Group Enabled Security, all
lookup types are global.

3. Enter the code, meaning and optionally a description for each value. Leave the
Tag column blank.

Caution: Do not change or remove any legislation codes that are
shown in the Tag column for existing lookup values. This may have
implications elsewhere in your HRMS system.

If you do not enter a start date, the new lookup is valid immediately. If you do not
enter an end date, the new lookup is valid indefinitely.

4. Save your work.

Removing Lookup Values
You can only remove lookup values if they are set up for a specific security
group. However, you can stop all lookups appearing in lists of values.

Note: You must be using Security Group Enabled security to categorize
lookups by security groups. See: Categorizing Information By Security
Groups, page 1-11

To remove a user defined lookup:
In the Application Utilities Lookups window, do one of the following:

• Enter an end date if you want to prevent users selecting this value after a certain date.

• Disable the code by un-checking the Enabled check box if you want to prevent users
selecting this value with immediate effect from the current date.

• Change the meaning and description to create a replacement lookup.

If you add, disable, or change the meaning of a lookup, users must log out and log back
in again for your changes to take effect.

To remove a lookup set up for a security group:
1. In the Application Utilities Lookups window, select the lookup type which has

lookups for a specific security group.

2. Check the Global Security Group check box.

This removes all lookups which have been set up for the security group linked to
your current responsibility. Predefined lookups are not removed.

If you add, disable, or change the meaning of a lookup, users must log out and log
back in again for your changes to take effect.
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User Types and Statuses

User Types and Statuses Window
The User Types and Statuses window enables you to extend certain delivered Oracle
lookups to meet additional system requirements by creating user types and statuses
for these lookups.

Note: If you wish to use user types or statuses, you must modify your
program code to point to enable user types or statuses for the relevant
fields. However, Oracle recommends that you only use the User Types
and Statuses form as described in the examples below.

You can define user types for specific business groups if required. If you do not define
specify a business group, your user types and statuses will be available in all business
groups.

Using the User Types and Statuses Window

You would like to categorize the white collar workers in the organization according
to their function. However, the delivered Employee Category lookup type contains
only one value for white-collar worker. To further extend the possible values of this
lookup, you can create the following additional user values for the WHITE_COLLAR
lookup of the EMPLOYEE_CATG lookup type:

• Office Clerk

• Office Manager

• Administration Staff

For more information on lookups in general, see: Lookups, Oracle HRMS Configuring,
Reporting, and System Administration Guide

Specific Applications of the User Types and Statuses Window

There are additional help topics available which illustrate specific uses of the User Types
and Statuses window:

• To create position hiring statuses. Although several hiring statuses are delivered
with Oracle HRMS, you can create multiple values for each system status if required.

For more information, see: Position Hiring Statuses, Oracle HRMS Enterprise and
Workforce Management Guide)

• To create budget measurement types.

For more information, see: People Budgets and Costing Overview, Oracle HRMS
Enterprise and Workforce Management Guide

Some Oracle localizations also use the User Types and Statuses window. For
example, Oracle HRMS for France uses the User Types and Statuses window to create
additional information for contacts and collective agreements.

For more information on these applications, please see the following documentation:

• Setting Up Dependent Child Contact Relationships, Workforce Sourcing, Deployment,
and Talent Management Guide
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• Setting Up Collective Agreement Entitlement Items, Oracle HRMS Enterprise and
Workforce Management Guide

Note: Please note that the above examples are specific to the French
localization of Oracle HRMS and you should only use the User Types
and Statuses window as described in the examples above.

Creating User Types and Statuses
You use the User Types and Statuses window to create user types and statuses for
delivered standard lookups.

1. In the Name field, select the lookup type. For example, select the EMPLOYEE_CATG
lookup.

2. If applicable, select a business group. If you do not specify a business group, the
user type or status will be available globally.

3. In the System Type field, select the lookup value that you wish to extend. For
example, select the White Collar system type.

4. Enter a description of the new user type or status. For example, enter Office Clerk
as a description.

5. Enter a code for the new user type or status.

6. Save your work.

You can enter additional values for each user type or status if required. For
example, you may choose to create a further type or status for the White Collar
lookup value such as Office Manager.
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Alerts

Oracle HRMS Predefined Alerts
Use the Oracle HRMS Alerts to help you manage your enterprise and workforce more
efficiently. Use the predefined alerts to inform, remind and confirm to you information
on your personal details, your subordinate workforce and your organizations. For
example, you could run HRMS Alert - New Hire Details Missing to ensure that you have
all of the correct information for any newly hired employees.

See the Oracle Alert’s User Guide for information on using and setting up the alerts.

The recipient of the alert is the person who meets the alert’s requirements, usually a
supervisor with a subordinate workforce. The recipient is sometimes required to perform
an action based on the alert’s email message, for example, if a piece of information is
incorrect or missing and needs updating.

Configurable Options
Each of the HRMS alerts has been designed as a periodic alert with a set of predefined
and configurable conditions. To view the configurable conditions and their
descriptions, query the desired alert in the Alerts window. You can configure the
conditions and determine how often you need the alerts run to suit your organizational
needs. The alerts will check your database for these conditions according to the
frequency you define.

See: Conditions of the HRMS Alerts, page 3-160

The table below describes each predefined alert with its specific business
benefit, recommended frequency and any further information of when the alert sends
an email notification to the recipient. An email will only be sent if the recipient meets
the alert’s requirements, the fixed and configurable conditions, and has a correctly
formatted email address.

Warning: Oracle HRMS only supports the default select statement in the
Alerts window if it is unchanged.

Period Conditions
For alerts that are based on events, for example a new hire or a termination, you can
use the following configurable conditions to control whether your alerts report on
a specific day or over a range of days:

• PERIOD_EVT_IN_X_DAYS - setting this value configures alerts to detect events
that occurred X days ago or will occur in X days time. For example, if you set this to
7 for an alert that detects events in the future, when the alert is run, it will look for
events that will occur in 7 days time.

• PERIOD_RERUN_EVENT_DAYS - setting this value configures alerts to detect
events that occurred or will occur during a number of days before the value set in the
PERIOD_EVT_IN_X_DAYS condition. For example, if PERIOD_EVT_IN_X_DAYS is
set to 7, and PERIOD_RERUN_EVENT_DAYS is set to 3, then for an alert that detects
events in the future, it will look for events that will occur between 4 and 7 days from
the current date. For alerts that detect events that have already happened, the above
settings would mean an alert looks for events that occurred between 7 and 10
days before the current date.
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For a future event, a new hire that is due to start work, you can use the HRMS Alert
- New Hires (not yet started) to find out how many new hires are about to start work
and when. For example, if the current date is 01-AUG-2003, and you set the value in
the PERIOD_EVT_IN_X_DAYS condition to 14, the alert will return a list of new hires
that are due to start on the 15-AUG-2003. If you set the frequency of this alert to run
daily, it will run everyday from the 15-AUG-2003 and will send an email notification if
it finds any new hires.

If you want the alert to return a list of new hires before the 15-AUG-2003, for example
you have set the alert to run as above and you need to find out if any new hires are
due to start between the 07-AUG-2003 and the 15-AUG-2003, you can set the value in
the PERIOD_RERUN_EVENT_DAYS condition to 8. The alert will run in the period
between the value set in the PERIOD_EVT_IN_X_DAYS condition and the value set
in the PERIOD_RERUN_EVENT_DAYS condition, therefore an email notification will
be sent if the alert finds any new hires that are due to start between the 07-AUG-2003
and 15-AUG-2003.

For a past event, an employee who has recently started employment, you can
use the HRMS Alert - New Hire Details Missing to find out if they have any
important information missing from their records. For example, if the current date is
28-DEC-2002, and you set the value in the PERIOD_EVT_IN_X_DAYS condition to
10, the alert will return a list of newly hired employees with missing information that
started work on the 18-DEC-2002. If you set the frequency of this alert to run daily, it will
run everyday from the 18-DEC-2002 and will send an email notification if it finds any
newly hired employees with missing details.

If you also want the alert to return a list of newly hired employees that started
before the 18-DEC-2002, for example you need to find out if any new employees
started between the 14-DEC-2002 and the 18-DEC-2002, you can set the value in the
PERIOD_RERUN_EVENT_DAYS condition to 4. The alert will run in the period
between the value set in the PERIOD_EVT_IN_X_DAYS condition and the value set in
the PERIOD_RERUN_EVENT_DAYS condition, therefore an email notification will be
sent if the alert finds any newly hired employees with information missing from their
records between the 14-DEC-2002 and the 18-DEC-2002.

Predefined Alerts Table

Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert - Active
Direct Reports - this
alert returns a list of
subordinates and their
assignment details.

Monthly Use this alert to ensure
that the information
on your workforce is
correct.

This alert sends
an email only
if it identifies
active employees
and contingent
workers with current
assignments.
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Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert - Cost
Center Listing by
Manager - this alert
returns a list of cost
centers managed
by the recipient
and the recipient’s
subordinates.

Monthly Use this alert to ensure
that the list of cost
centers that you and
your subordinates
manage is accurate.

This alert sends
an email only
if it identifies
organizations that are
currently classified as
company cost centers
to a current cost center
manager, who is
either an employee or
contingent worker.

HRMS Alert - Ended
Cost Center Listing
by Manager - this
alert returns a list
of end-dated cost
centers managed
by the recipient
and the recipient’s
subordinates.

Monthly Use this alert to inform
you of any cost centers
that have been end-
dated that you or
your subordinates
manage. You can then
use this information to
update your records.

This alert sends
an email only
if it identifies
organizations that are
classified as company
cost centers, and that
have been end-dated
before the current
date to a current cost
center manager, who
is either an employee
or contingent worker.

HRMS Alert - New
Hires (not yet started)
- this alert returns a
list of new members
of the workforce that
are due to start work.

Daily Use this alert as a
confirmation that
new members of
your workforce have
been entered into
the Oracle HRMS
application, and as a
reminder of their start
date.

This alert sends
an email only if it
identifies employees
or contingent workers
who are due to start
between the current
date, and the number
of days ahead, which
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition.
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Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert - New
Hire Details Missing
- this alert returns
a list of missing
information for newly
hired employees, such
as salary basis and
bank details.

Daily Use this alert to inform
you of any important
information that is
missing from a newly
hired employee’s
record, and to ensure
that the information is
updated.

This alert sends
an email only
if it identifies
current employee
or contingent worker
assignments that
started between the
current date, and
the number of days
previous, which you
indicate in the PER
IOD_EVT_IN_X_
DAYS condition,
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition.

HRMS Alert - Ending
Probationary Period
- this alert returns a
list of the recipient’s
subordinates that are
near the end of a
review or probation
period.

Daily Use this alert to
remind you when
a member of your
workforce is nearing
the end of an
employment review
or probation period.

This alert sends
an email only
if it identifies
current employee
assignments that have
probation periods
that are due to end
between the current
date, and the number
of days ahead, which
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition,
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition.
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Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert
- Performance
Appraisal Due -
this alert returns a
list of the recipient’s
subordinates that
require appraisals.

Daily Use this alert to
remind you when
a member of your
workforce is due an
appraisal.

This alert sends
an email only if
it identifies active
employees that have
an appraisal due
between the current
date, and the number
of days ahead, which
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition,
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition. The
alert will not be sent
if an appraisal of the
same appraisal type
has already occurred.

HRMS Alert
- Performance
Appraisal Passed
Due - this alert returns
a list of the recipient’s
subordinates that
have appraisals
outstanding.

Daily Use this alert to
remind you when
a member of your
workforce is overdue
an appraisal.

This alert sends
an email only if
it identifies active
employees that were
due an appraisal
from the current date,
and the number of
days previous, which
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition. The
alert will not be sent
if an appraisal of the
same appraisal type
has already occurred.
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Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert -
Overlapping Position
Incumbency - this
alert returns a list
of the recipient’s
subordinates that
are in positions
where there is an
unacceptable position
incumbency overlap
due to occur.

Daily Use this alert to warn
you when members
of your workforce
are in positions
where there is an
unacceptable position
incumbency due to
occur. You can then
use this information
to correct or update
your records.

This alert sends
an email only if it
identifies employee
assignments that
occupy the same
position, that has a
maximum headcount
of one and the
maximum overlap
duration (for that
position) is due to end
between the current
date, and the number
of days ahead, which
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition. The
alert will not include
a position if it has two
or more assignments
assigned to it.

HRMS Alert - People
Terminating in the
Next Week - this
alert returns a list
of the recipient’s
terminating
workforce one week
before they leave.

Daily Use this alert
to remind you
to perform any
termination
procedures and collect
any company assets.

This alert sends
an email only if
it identifies an
employee’s or
contingent worker’s
period of service or
placement is due
to end between the
current date, and
the number of days
ahead, which you
indicate in the PER
IOD_EVT_IN_X_
DAYS condition,
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition.
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Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert - People
Returning from
Leave of Absence
- this alert returns a
list of subordinates to
the supervisor who
are due to return
from a suspended
assignment.

Daily Use this alert to
inform you of your
subordinate’s return
date.

This alert sends an
email if it identifies
active employee
assignments that
have a current status
of Suspended and
a future dated
assignment change
between the current
date, and the number
of days ahead, which
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition,
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition with
an assignment status
of active.

HRMS Alert - Open
Vacancies Listing
- this alert returns a
list of outstanding
vacancies that are
assigned to the
recipient.

None Use this alert to
provide you with
a list of outstanding
vacancies that are
assigned to you and
require an action.

This alert sends
an email only if
it identifies active
vacancies.

HRMS Alert -
Personal Details
Review - this alert
returns details of the
recipient’s important
personal information.

Bi-annually Use this alert to review
your important
personal information
to ensure it is correct.

This alert sends an
email if it identifies
active employee and
contingent worker
primary assignments.

HRMS Alert - People
Without a Supervisor
- this alert returns a
list (to a nominated
user) of all current
employees and
contingent workers
that do not have a
supervisor.

Monthly Use this alert to ensure
that all workers
are assigned to a
supervisor.

This alert sends
an email only if
it identifies active
assignments without
a direct or valid
supervisor.
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Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert - Payroll
Run Completed -
this alert returns a
confirmation (to a
nominated user) of
the latest successful
payroll run

Daily Use this alert to
confirm a successful
payroll run.

This alert sends
an email only if it
identifies payroll
actions that have a
status of complete
between the current
date, and the number
of days previous,
which you indicate
in the PERIOD_
EVT_IN_X_DAYS
condition, and the
number of days
before that, which
you indicate in the
PERIOD_RERUN_
EVENT_DAYS
condition.

HRMS Alert -
People Without
Email Addresses
- this alert returns a
list of the recipient’s
subordinates that do
not have an email
address.

Monthly Use this alert to
inform you of any
subordinates that do
not have a valid email
address. Use this
information to update
your records.

This alert sends
an email only if
it identifies active
employee and
contingent worker
primary assignments
that do not have
an email address or
have an incorrectly
formatted email
address.
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Alert Name and
Description

Recommended
Frequency

Business Benefits Further Information

HRMS Alert -
Training Attendance
Reminder - this
alert returns a list
of training events
that the recipient or
their subordinates are
due to attend or have
attended.

Daily Use this alert to
remind you of any
training events
that you or your
subordinates are due
to attend or to inform
you of any training
events that you or
your subordinates
have attended.

This alert sends
an email only
if it identifies
active employee or
contingent worker
delegate assignments
that are due to attend a
training event or have
previously attended
a training event
between the days
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition,
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition. A
training event will
only be included if it
is not a development
event and if it has not
been cancelled.

HRMS Alert
- Workers
Competencies
Expiring - this alert
returns a list of
competencies that
the recipient and their
subordinates have
that are due to expire.

Daily Use this alert to
remind you of any
competencies that you
or your subordinates
have that are due to
expire.

This alert sends
an email only
if it identifies
active employees
or contingent
workers that have
competencies that
are due to expire
between the current
date, and the number
of days ahead, which
you indicate in the
PERIOD_EVT_IN_
X_DAYS condition,
and the number of
days before that,
which you indicate
in the PERIOD_
RERUN_EVENT_
DAYS condition. An
email will not be sent
if the competence is
due to restart the day
after it expires.

Using the Alerts
For information on using the alerts see the Oracle Alert’s User Guide.

For an example of how to use a HRMS alert, see: Example of Setting up a HRMS Alert,
page 3-162.
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For information on the configurable conditions for the alerts, see: Conditions of the
HRMS Alerts, page 3-160.

Conditions of the HRMS Alerts
The conditions of the alerts enable you to control the content of the alert and who
receives them. Each alert provides you with a number of configurable options that you
can configure to provide email notifications to best suit your organizational needs. For
example, if you want to send the HRMS Alert - Training Attendance Reminder to the
supervisor of an employee that is due to attend a training course, you can set the value of
the SEND_TO_ASG_SPVSR condition to Y. When the alert is run, an email notification is
sent to the supervisor regarding the training event.

The table below describes each condition and its default value.

The HRMS Alerts Conditions Table

Condition Default Values Description

ALERT_BANK_DETAILS Y If set to Y an alert will be
raised when bank details have
not been set for a new hire.

ALERT_GRADE_
PLACEMENT_MISSING

N If set to Y an alert will be
raised when grade placements
have not been set for a new
hire.

ALERT_PAY_METHOD_MISS
ING

Y If set to Y an alert will be
raised when the pay method
has not been set for a new hire.

ALERT_PAYROLL_MISSING Y If set to Y an alert will be
raised when the payroll has
not been set for a new hire.

ALERT_SALARY_BASIS_M
ISSING

Y If set to Y an alert will be
raised when the salary basis
has not been set for a new hire.

ALERT_SALARY_MISSING Y If set to Y an alert will be
raised when the bank details
have not been set for a new
hire.

ALERT_SUPERVISOR_MISS
ING

N If set to Y an alert will be
raised when a new hire does
not have a supervisor.

DISPLAY_SALARY_
AMOUNT

N If set to Y the actual salary
amount displays on the alert.

EXCLUDE_CEO Blank If set to an employee number,
that employee will be excluded
from the alert, if blank then all
employees will be considered
within the scope of the alert.
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Condition Default Values Description

INCLUDE_ALL_NEW_
STARTS

N If set to Y an alert will be raised
for all new hires regardless of
whether they have missing
details or not.

INCLUDE_BUSINESS_GROU
P

Blank Restricts the alert to a named
business group. If not set, all
business groups will display.

INCLUDE_CONT_FLAG N Includes contingent workers
within the scope of the alert.

INCLUDE_EMP_FLAG Y Includes employees in the
scope of the alert.

INCLUDE_ORGANIZATION Blank Restricts the alert to a named
organization. If not set, all
organizations will display.

INCLUDE_SECONDARY_
ASG

N If set to Y an alert will include
information for a secondary
assignment.

PERIOD_EVT_IN_X_DAYS 7 Set the alert to X number of
days before or after an event.

PERIOD_RERUN_EVENT_
DAYS

0 Allows a rerun of the alert
and provides an additional
configuration option to run
the alert for a period of time
rather than a single day.

*SEND_TO_ASG_PSN Y Send alert to the person (with
an assignment) who is the
subject of the alert.

*SEND_TO_ASG_SPVSR Y Send alert to the supervisor
of the person (with an
assignment) who is the subject
of the alert.

*SEND_TO_NAMED_USER N Send a copy of the alert to the
specified email address.

*SEND_TO_PASG_SPVSR N Send alert to the primary
assignment supervisor of the
person who is the subject of
the alert.

*SEND_TO_PSN Y Send alert to the person who
is the subject of the alert.

*SEND_TO_SUP_PSN N Send alert to the supervisor of
the person who is the subject
of the alert.
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Warning: If you set more than one of the *Send_To condition values to
Y, the recipient of the alert may receive duplicate information in the
alert notification.

Example of Setting up a HRMS Alert
This topic is an example of the steps you perform to set up the HRMS Alert - Cost
Center Listing by Manager.

To set up the HRMS Alert - Cost Center Listing by Manager:
1. Query the HRMS Alert - Cost Center Listing by Manager in the Alerts window.

2. Choose Tools in the menu, and select the Transfer Alert option to copy the alert.

See: Transferring Alert Definitions in the Oracle Alert’s User Guide for more
information on copying an alert.

3. Ensure you rename the alert and choose the same database in the Destination Alert
region of the Transfer Alert Definition window.

Note: It is important to rename your alerts and to save them to the
same database. This ensures that any changes you make to the alert
are specific to your alert and not the predefined alert.

4. Choose the Transfer button, close the Transfer Alert Definitions window and query
your copied alert.

5. Check the Enabled button to enable your alert.

You can check your periodic alerts regardless of the frequency you
define. See: Checking a Periodic Alert in the Oracle Alert’s User Guide for information
on checking your periodic alerts and their enabled action sets.

6. Set the frequency to On Day of the Month and enter 1 as the day number for the alert
to run on the first day of every month.

See: Creating a Periodic Alert in the Oracle Alert’s User Guide for more information
on setting up the frequency.

7. Choose the Action Details button to set up the conditions of the alert. The conditions
you set up here specify the scope of the alert.

See: Specifying the Alert Details in the Oracle Alert’s User Guide for more information.

8. Enter the business group name in the Value field for the INCLUDE_BUSINESS_
GROUP optional condition for which you want the alert to run.

Warning: You must enter a valid value for the alert to run
successfully. For example, if you enter an invalid business group
name, the alert will not find any information and an email
notification will not be sent.

9. Change the INCLUDE_CONT_FLAG condition to Y in the Value field to include
contingent workers in the scope of the alert.

Warning: The Value field is case sensitive, you must ensure that you
enter the value as uppercase.
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10. Leave the INCLUDE_ORGANIZATION condition blank in the Value field, as this
example wants the alert to include all organizations within the business group in
the scope of the alert.

Note: You can restrict this condition to a specific organization if you
enter an organization name.

11. Leave all other conditions with their default values.

As an additional verification step, you can set the conditions up in the Alert Details
window with the same values as in the Action Details window, to test your alert
to find out if it returns the number of rows you expect. You use the Run button
to test and verify your alert.

See: Creating a Periodic Alert in the Oracle Alert’s User Guide for more information
on verifying your alerts.

This alert now runs on the first day of every month, and sends an email notification
to employees and contingent workers if it identifies them as current company cost
center managers within the specified business group.
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Custom Library Events and APIs

CUSTOM Library Events

Generic Events
An event is a point within the processing of a form at which you can call
custom code from the CUSTOM library. For example, you can use the event
WHEN-FORM-NAVIGATE to code a sequence of logic that occurs after any existing
logic for the form, block or item. WHEN-FORM-NAVIGATE is an example of a generic
event available to all the windows in Oracle Applications. For a complete list of generic
events see: Events Passed to the CUSTOM Library, Oracle Applications Developer’s Guide.

Product-Specific Events
In addition to generic events, Oracle HRMS provides a range of product-specific events
that you can use to make CUSTOM library calls to support your business rules. The
product-specific events for HRMS are available for most HRMS windows. The following
table details the purpose of each event and shows when the events occur.

Event Name Purpose When Occurs

WHEN-CREATE-RECORD Enables you to specify values
that will appear by default
when you create a new record.

After the form has processed.

POST-QUERY Enables you to add additional
derivation or validation on
completion of a query.

After the form has processed.

KEY-DELREC Enables you to add an extra
level of validation before users
are allowed to delete a record
from the database.

Immediately before the user is
asked to confirm the deletion
of the record.

PRE-UPDATE, PRE-INSERT
and PRE-DELETE

Enables you to add additional
validation before the update,
insert or delete action is
performed.

After any data validation.

Before DateTrack
manupulation if the block
contains DateTrack features.

POST-INSERT, POST-U
PDATE and POST-DELETE

Enables you to add additional
insert, update, or delete
actions to user tables.

We do not recommend using
these events for validation.

After the form has processed.

POST-FORMS-COMMIT Enables you to specify an
action to occur as the last
action in a sequence of commit
actions.

After the form has processed.
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Event Name Purpose When Occurs

WHEN-BUTTON-PRESSED Enables you to perform
custom validation before a
button action is performed.

After any data validation.

Before any action (for example,
display new window) has been
performed.

DT_CALL_HISTORY Enables you to change which
database view is used by
DateTrack History.

After the user has requested to
use DateTrack History and the
form has derived the standard
details. Before the DateTrack
History window is visible.

DT_SELECT_MODE Enables you to restrict the
DateTrack modes that a user
can select.

After the form has derived
which DateTrack modes are
available but before the mode
selection window is visible.

NAVIGATE Enables you to supplement
the validation that takes place
when the user selects a task
flow navigation option. The
following field values are set
for the duration of this event:

CTL_GLOBALS.DESTINAT
ION_FORM

CTL_GLOBALS.DESTINAT
ION_BLOCK

After the user selects a task
flow navigation option but
before the new window opens.

Publicly Callable Business Process APIs in Oracle HRMS
Application Programmatic Interfaces (APIs) are a logical grouping of all external process
routines. The Oracle HRMS API strategy delivers a set of PL/SQL packages procedures
and functions that provide an open interface to the database.

Further information on the purpose of each API is available in the API package
header. For information on how to call APIs, see the technical essay APIs in Oracle
HRMS, Oracle HRMS Implementation Guide. See also the Oracle Applications System
Administrator’s Guide.

See also:

• Publicly Callable Business Process APIs in iRecruitment, Oracle iRecruitment
Implementation Guide

• Publicly Callable Business Process APIs in Oracle Training Administration,
Implementing Oracle Learning Management

• Publicly Callable Business Process APIs in Oracle Time & Labor, Oracle Time & Labor
Implementation and User Guide

• HR Foundation, page 3-229 (for a list of APIs supported in HR Foundation)

The following table shows the APIs delivered with Oracle HRMS.

Important: This list includes all the supported APIs in Oracle
HRMS, including HR, Payroll, and Standard and Advanced
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Benefits. Any APIs not included in this list are for internal use only
and are not supported.

Business Process APIs in Oracle HRMS

Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

ben_cwb_
stock_optn_
dtls_api

becsoapi.pkh create_cwb_
stock_optn_
dtls

No Yes WW

ben_cwb_
stock_optn_
dtls_api

becsoapi.pkh delete_cwb_
stock_optn_
dtls

No Yes WW

ben_cwb_
stock_optn_
dtls_api

becsoapi.pkh update_cwb_
stock_optn_
dtls

No Yes WW

ghr_agency_
appeals_api

ghcaaapi.pkh create_
agency_
appeal,
update_
agency_
appeal,
delete_
agency_
appeal

No Yes FD

ghr_
assignment_
api

ghasgapi.pkh accept_apl_
asg

No No FD

ghr_
complainant_
appeals_api

ghccaapi.pkh create_
complainant_
appeal,
update_
complainant_
appeal,
delete_
complainant_
appeal

No Yes FD

ghr_
complaint_
adrs_api

ghcadapi.pkh create_
compl_adr,
update_
compl_
adr, delete_
compl_adr

No Yes FD

ghr_
complaint_
api

ghcmpapi.
pkh

create_
complaint,
update_
complaint

No Yes FD
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

ghr_
complaint_
bases_api

ghcbaapi.pkh create_
compl_basis,
update_
compl_
basis, delete_
compl_basis

No Yes FD

ghr_
complaint_
claims_api

ghcclapi.pkh create_
compl_claim,
update_
compl_
claim, delete_
compl_claim

No Yes FD

ghr_
complaint_
incidents_api

ghcinapi.pkh create_
compl_
incident,
update_
compl_
incident,
delete_
compl_
incident

No Yes FD

ghr_
complaint_
people_api

ghcplapi.pkh create_
compl_
person,
update_
compl_
person,
delete_
compl_
person

No Yes FD

ghr_
complaints_
ca_details_
api

ghcdtapi.pkh create_
ca_detail,
update_ca_
detail, delete_
ca_detail

No Yes FD

ghr_
complaints_
ca_headers_
api

ghcahapi.pkg create_ca_
header,
update_
ca_header,
delete_ca_
header

No Yes FD

ghr_duty_
station_api

ghdutapi.pkh create_duty_
station,
delete_duty_
station,
update_duty_
station

No Yes FD

ghr_element_
api

ghelepkg.pkh process_sf52_
element

No No FD

Extending Oracle HRMS 3-167



Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

ghr_noac_
las_api

ghnlaapi.pkh create_noac_
las, delete_
noac_las,
update_noac_
las

No Yes FD

ghr_noac_
remarks_api

ghnreapi.pkh create_noac_
remarks,
delete_noac_
remarks,
update_noac_
remarks

No Yes FD

ghr_pa_
remarks_api

ghpreapi.pkh create_pa_
remarks,
delete_pa_
remarks,
update_pa_
remarks

No Yes FD

ghr_par_
extra_info_
api

ghreiapi.pkh create_pa_
request_
extra_info,
delete_pa_
request_
extra_info,
update_pa_
request_
extra_info

No Yes FD

ghr_pdc_api ghpdcapi.pkh create_pdc,
delete_pdc,
update_pdc

No Yes FD

ghr_pdi_api ghpdiapi.pkh create_pdi,
update_pdi

No Yes FD

ghr_person_
address_api

ghaddapi.pkh create_us_
int_person_
address

No No FD

ghr_person_
address_api

ghaddapi.pkh update_us_
int_person_
address

No No FD

ghr_sf52_api ghparapi.pkh create_sf52,
end_sf52,
update_sf52

No Yes FD

hr_accrual_
plan_api **

hrpapapi.pkh create_
accrual_plan

No Yes WW

hr_accrual_
plan_api **

hrpapapi.pkh delete_
accrual_plan

No Yes WW
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_accrual_
plan_api **

hrpapapi.pkh update_
accrual_plan

No Yes WW

hr_api_hook_
call_api

peahcapi.pkh create_api_
hook_call

No No WW

hr_api_hook_
call_api

peahcapi.pkh update_api_
hook_call

No No WW

hr_api_hook_
call_api

peahcapi.pkh delete_api_
hook_call

No No WW

hr_applicant_
api

peappapi.pkh convert_to_
applicant

No Yes WW

hr_applicant_
api

peappapi.pkh create_
applicant

Yes Yes WW

hr_applicant_
api

peappapi.pkh create_gb_
applicant

Yes No UK

hr_applicant_
api

peappapi.pkh create_us_
applicant

Yes No FD

hr_applicant_
api

peappapi.pkh hire_
applicant

Yes Yes WW

hr_applicant_
api

peappapi.pkh terminate_
applicant

No Yes WW

hr_
application_
api

peaplapi.pkh update_apl_
details

No Yes WW

hr_appraisal_
templates_api

peaptapi.pkh create_
appraisal_
template,
delete_
appraisal_
template,
update_
appraisal_
template

No Yes WW

hr_
appraisals_
api

peaprapi.pkh create_
appraisal,
delete_
appraisal,
update_
appraisal

No Yes WW
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_asg_
budget_
value_api

peabvapi create_
assignment_
budget_
value,
update_
assignment_
budget_
value, delete_
assignment_
budget_value

No Yes WW

hr_
assessment_
groups_api

peasrapi.pkh create_
assessment_
group,
delete_
assessment_
group,
update_
assessment_
group

No Yes WW

hr_
assessment_
types_api

peastapi.pkh create_
assessment_
type, delete_
assessment_
type, update_
assessment_
type

No Yes WW

hr_
assessments_
api

peasnapi.pkh create_
assessment,
delete_
assessment,
update_
assessment

No Yes WW

hr_
assignment_
api

peasgapi.pkh accept_apl_
asg,

No Yes WW

hr_
assignment_
api

peasgapi.pkh activate_apl_
asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh activate_
cwk_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh activate_
emp_asg

Yes Yes WW

hr_
assignment_
api

peasgapi.pkh actual_
termination_
emp_asg

Yes Yes WW
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_
assignment_
api

peasgapi.pkh create_gb_
secondary_
emp_asg

Yes No UK

hr_
assignment_
api

peasgapi.pkh create_
secondary_
apl_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh create_
secondary_
cwk_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh create_
secondary_
emp_asg

Yes Yes WW

hr_
assignment_
api

peasgapi.pkh create_us_
secondary_
emp_asg

Yes No US

hr_
assignment_
api

peasgapi.pkh final_
process_
emp_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh interview1_
apl_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh interview2_
apl_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh offer_apl_asg No Yes WW

hr_
assignment_
api

peasgapi.pkh set_new_
primary_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh set_new_
primary_
cwk_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh suspend_
cwk_asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh suspend_
emp_asg

Yes Yes WW

hr_
assignment_
api

peasgapi.pkh terminate_
apl_asg

No Yes WW
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_
assignment_
api

peasgapi.pkh update_apl_
asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh update_cwk_
asg

No Yes WW

hr_
assignment_
api

peasgapi.pkh update_cwk_
asg_criteria

No Yes WW

hr_
assignment_
api

peasgapi.pkh update_emp_
asg

Yes Yes WW

hr_
assignment_
api

peasgapi.pkh update_emp_
asg_criteria

Yes Yes WW

hr_
assignment_
api

peasgapi.pkh update_gb_
emp_asg

Yes No UK

hr_
assignment_
api

peasgapi.pkh update_us_
emp_asg

Yes No US

hr_
assignment_
extra_info_
api

peaeiapi.pkh create_
assignment_
extra_info,
delete_
assignment_
extra_info,
update_
assignment_
extra_info

No Yes WW

hr_au_
applicant_api

hrauwraa.
pkh

create_au_
applicant

Yes No AU

hr_au_
assignment_
api

hrauwrsa.pkh create_au_
secondary_
emp_asg,
update_au_
emp_asg

Yes No AU

hr_au_
employee_api

hrauwree.pkh create_au_
employee

Yes No AU

hr_au_
person_api

hrauwrpe.
pkh

update_au_
person

Yes No AU
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_au_
personal_
pay_method_
api

hrauwrpm.
pkh

create_au_
personal_
pay_method,
update_au_
personal_
pay_method

Yes Yes AU

hr_au_super_
api

hrauwrsu.
pkh

create_super_
contribution,
update_
super_
contribution

Yes No AU

hr_au_tax_
api

hrauwrtx.pkh maintain_
paye_
tax_info,
maintain_
super_info

Yes No AU

hr_authoria_
mapping_api

hrammapi.
pkh

create_
authoria_
mapping

No Yes UK, US

hr_authoria_
mapping_api

hrammapi.
pkh

delete_
authoria_
mapping

No Yes UK, US

hr_authoria_
mapping_api

hrammapi.
pkh

update_
authoria_
mapping

No Yes UK, US

hr_batch_
message_
line_api

hrabmapi.
pkh

create_
message_line

No No WW

hr_batch_
message_
line_api

hrabmapi.
pkh

delete_
message_line

No No WW

hr_batch_
message_
line_api

hrabmapi.
pkh

delete_batch_
lines

No No WW

hr_be_
contract_api

hrctcbei.pkh create_be_
contract,
update_be_
contract_

No No BE

hr_be_
employee_api

peempbei.
pkh

create_be_
employee

No No BE

hr_ca_
applicant_api

peappcai.pkh create_ca_
applicant

No No CA
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_ca_
assignment_
api

peasgcai.pkh create_ca_
secondary_
emp_asg,

update_ca_
emp_asg

No No CA

hr_ca_
employee_api

peempcai.
pkh

create_ca_
employee

No No CA

hr_cagr_ent_
item_api

peceiapi.pkh create_cagr_
entitlement_
item, update_
cagr_
entitlement_
item, delete_
cagr_
entitlement_
item

No Yes WW

hr_cagr_ent_
lines_api

pepclapi.pkh create_cagr_
entitlement_
line, update_
cagr_
entitlement_
line, delete_
cagr_
entitlement_
line

No Yes WW

hr_cagr_
entitlement_
api

pepceapi.pkh create_cagr_
entitlement,
update_cagr_
entitlement,
delete_cagr_
entitlement

No Yes WW

hr_cagr_
grade_
structures_
api

pegrsapi.pkh create_
cagr_grade_
structures,
delete_
cagr_grade_
structures

No Yes WW

hr_cagr_
grade_
structures_
api

pegrsapi.pkh update_
cagr_grade_
structures

No No WW

hr_cagr_
grades_api

pegraapi.pkh create_cagr_
grades,
delete_cagr_
grades,
update_cagr_
grades

No Yes WW
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hr_cagr_
parameter_
api

pecpaapi.pkh create_cagr_
parameter

No No WW

hr_cagr_
parameter_
api

pecpaapi.pkh delete_cagr_
parameter

No No WW

hr_cagr_
parameter_
api

pecpaapi.pkh update_cagr_
parameter

No No WW

hr_cancel_
hire_api

pecahapi.pkh cancel_hire No Yes WW

hr_cancel_
placement_
api

pecplapi.pkh cancel_
placement

No No WW

hr_change_
start_date_
api

pehirapi.pkh update_start_
date

No Yes WW

hr_cn_
applicant_api

hrcnwraa.pkh create_cn_
applicant

Yes No CN

hr_cn_
assignment_
api

hrcnwras.pkh create_cn_
secondary_
emp_asg

Yes No CN

hr_cn_
assignment_
api

hrcnwras.pkh update_cn_
emp_asg

Yes No CN

hr_cn_
contact_api

hrcnwrcc.pkh create_cn_
person

No No CN

hr_cn_
employee_api

hrcnwree.pkh create_cn_
employee

Yes No CN

hr_cn_
personal_
pay_method_
api

hrcnwrpm.
pkh

create_cn_
personal_
pay_method

Yes No CN

hr_cn_
personal_
pay_method_
api

hrcnwrpm.
pkh

update_cn_
personal_
pay_method

Yes No CN

hr_cn_
person_
address_api

hrcnwrpa.
pkh

create_cn_
person_
address

Yes No CN
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hr_cn_
person_
address_api

hrcnwrpa.
pkh

update_
cn_person_
address

Yes No CN

hr_cn_
person_api

hrcnwrpe.
pkh

update_cn_
person

Yes No CN

hr_collective_
agreement_
api

hrcagapi.pkh attach_plan_
years

No No WW

hr_collective_
agreement_
api

hrcagapi.pkh create_
collective_
agreement,
delete_
collective_
agreement,
update_
collective_
agreement

No Yes WW

hr_comp_
element_
outcome_api

peceoapi.pkh create_
element_
outcome,
update_
element_
outcome

Yes Yes WW

hr_comp_
element_
outcome_api

peceoapi.pkh delete_
element_
outcome

No Yes WW

hr_
competence_
element_api

pecelapi.pkh copy_
competencies

No Yes WW

hr_
competence_
element_api

pecelapi.pkh create_
competence_
element

Yes* Yes WW

hr_
competence_
element_api

pecelapi.pkh delete_
competence_
element

No Yes WW

hr_
competence_
element_api

pecelapi.pkh maintain_
student_
comp_
element

No Yes WW

hr_
competence_
element_api

pecelapi.pkh update_
competence_
element

No Yes WW
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hr_
competence_
element_api

pecelapi.pkh update_
delivered_
dates

No Yes WW

hr_
competence_
element_api

pecelapi.pkh update_
personal_
comp_
element

No Yes WW

hr_
competence_
outcome_api

peceoapi.pkh create_
outcome,
update_
outcome

Yes Yes WW

hr_
competence_
outcome_api

peceoapi.pkh delete_
outcome

No Yes WW

hr_
competences_
api

pecpnapi.pkh create_
competence

Yes Yes WW

hr_
competences_
api

pecpnapi.pkh delete_
competence

No Yes WW

hr_
competences_
api

pecpnapi.pkh update_
competence

Yes Yes WW

hr_contact_
api

peconapi.pkh create_person Yes Yes WW

hr_contact_
extra_info_
api

pereiapi.pkh create_
contact_
extra_info

No Yes WW

hr_contact_
extra_info_
api

pereiapi.pkh delete_
contact_
extra_info

No Yes WW

hr_contact_
extra_info_
api

pereiapi.pkh update_
contact_
extra_info

No Yes WW

hr_contact_
rel_api

pecrlapi.pkh create_
contact

Yes Yes WW

hr_contact_
rel_api

pecrlapi.pkh delete_
contact_
relationship

No Yes WW

hr_contact_
rel_api

pecrlapi.pkh update_
contact_
relationship

No Yes WW
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hr_
contingent_
worker_api

pecwkapi.
pkh

apply_for_job No Yes WW

hr_
contingent_
worker_api

pecwkapi.
pkh

convert_to_
cwk

No Yes WW

hr_
contingent_
worker_api

pecwkapi.
pkh

create_cwk No Yes WW

hr_
contingent_
worker_api

pecwkapi.
pkh

reverse_
terminate_
placement

No Yes WW

hr_
contingent_
worker_api

pecwkapi.
pkh

terminate_
placement

No Yes WW

hr_contract_
api

hrctcapi.pkh create_
contract

Yes Yes WW

hr_contract_
api

hrctcapi.pkh delete_
contract

No Yes WW

hr_contract_
api

hrctcapi.pkh update_
contract

No Yes WW

hr_de_
assignment_
api

peasgdei.pkh create_de_
secondary_
emp_asg

No No DE

hr_de_
assignment_
api

peasgdei.pkh update_de_
emp_asg

No No DE

hr_de_
employee_api

peempdei.
pkh

create_de_
employee

No No DE

hr_de_
liability_
premiums_
api

hrlipapi.pkh create_
premium,
update_
premium,
delete_
premium

No Yes DE

hr_de_
organization_
links_api

hrordapi.pkh create_link,
update_link,
delete_link

No Yes DE
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hr_de_soc_
ins_cle_api

hrcleapi.pkh create_
soc_ins_
contributions,
update_
soc_ins_
contributions,
delete_
soc_ins_
contributions

No Yes DE

hr_delivery_
methods_api

pepdmapi.
pkh

create_
delivery_
method,
delete_
delivery_
method,
update_
delivery_
method

No Yes WW

hr_
deployment_
factor_api

pedpfapi.pkh create_
person_
dpmt_factor,
update_
person_
dpmt_factor,
create_
position_
dpmt_factor,
update_
position_
dpmt_factor,
create_job_
dpmt_factor,
update_job_
dpmt_factor

No Yes WW

hr_elc_
candidate_api

peecaapi.pkh create_
election_
candidate,
update_
election_
candidate,
delete_
election_
candidate

No Yes WW

hr_elc_
constituencys_
api

peecoapi.pkh create_
election_
constituency,
update_
election_
constituency,
delete_
election_
constituency

No Yes WW
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hr_elc_result_
api

peersapi.pkh create_
election_
result,
update_
election_
result

No No WW

hr_elections_
api

peelcapi.pkh create_
election_
information,
update_
election_
information,
delete_
election_
information

No Yes WW

hr_
employee_api

peempapi.
pkh

apply_for_
internal_
vacancy

No Yes WW

hr_
employee_api

peempapi.
pkh

create_
employee

Yes Yes WW

hr_
employee_api

peempapi.
pkh

create_gb_
employee

Yes No UK

hr_
employee_api

peempapi.
pkh

create_us_
employee

Yes No US

hr_
employee_api

peempapi.
pkh

hire_into_job No Yes WW

hr_
employee_api

peempapi.
pkh

re_hire_ex_
employee

Yes Yes WW

hr_
employee_api

peempapi.
pkh

hire_
employee_
applicant

No Yes WW

hr_
employee_api

peempapi.
pkh

hire_to_
employee_
applicant

No Yes WW

hr_es_
applicant_api

peappesi.pkh create_es_
applicant

No No ES

hr_es_
contact_api

peconesi.pkh create_es_
person

No No ES

hr_es_
contingent_
worker_api

pecwkesi.pkh create_es_
cwk

No No ES
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hr_es_
employee_api

peempesi.pkh create_es_
employee

No No ES

hr_es_
person_api

peperesi.pkh update_es_
person

No No ES

hr_ex_
employee_api

peexeapi.pkh actual_
termination_
emp

Yes Yes WW

hr_ex_
employee_api

peexeapi.pkh final_
process_emp

Yes Yes WW

hr_ex_
employee api

peexeapi.pkh update_term_
details_emp

Yes Yes WW

hr_fr_
applicant_api

peappfri.pkh create_fr_
applicant

No No FR

hr_fr_
assignment_
api

peasgfri.pkh create_fr_
secondary_
emp_asg

No No FR

hr_fr_
assignment_
api

peasgfri.pkh update_fr_
emp_asg

No No FR

hr_fr_
contract_api

hrctcfri.pkh create_fr_
contract

No No FR

hr_fr_
contract_api

hrctcfri.pkh update_fr_
contract

No No FR

hr_fr_
employee_api

peempfri.pkh create_fr_
employee

No No FR

hr_fr_job_api pejobfri.pkh create_fr_job No No FR

hr_fr_
periods_of_
service_api

pepdsfri.pkh update_fr_
pds_details

No No FR

hr_fr_pers_
pay_method_
api

peppmfri.pkh create_fr_
pers_pay_
method

No No FR

hr_fr_pers_
pay_method_
api

peppmfri.pkh update_fr_
pers_pay_
method

No No FR

hr_fr_person_
address_api

peaddfri.pkh create_fr_
person_
address

No No FR

Extending Oracle HRMS 3-181



Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_fr_person_
address_api

peaddfri.pkh update_
fr_person_
address

No No FR

hr_fr_person_
api

peperfri.pkh update_fr_
person

No No FR

hr_fr_pqh_
employee_api

pqhpefri.pkh create_fr_
employee

No No FR

hr_grade_api
**

pegrdapi.pkh create_grade Yes No WW

hr_grade_api
**

pegrdapi.pkh update_grade No No WW

hr_grade_api
**

pegrdapi.pkh delete_grade No No WW

hr_grade_
rate_value_
api **

pygrrapi.pkh create_grade_
rate_value

Yes No WW

hr_grade_
rate_value_
api **

pygrrapi.pkh update_
grade_rate_
value

Yes No WW

hr_grade_
rate_value_
api **

pygrrapi.pkh delete_grade_
rate_value

No No WW

hr_grade_
scale_api

pepgsapi.pkh create_grade_
scale

delete_grade_
scale

update_
grade_scale

No Yes WW

hr_grade_
step_api

pespsapi.pkh create_grade_
step

delete_grade_
step

update_
grade_step

No Yes WW

hr_hierarchy_
element_api

peoseapi.pkh create_
hierarchy_
element

Yes Yes WW

hr_hierarchy_
element_api

peoseapi.pkh delete_
hierarchy_
element

No Yes WW
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hr_hierarchy_
element_api

peoseapi.pkh update_
hierarchy_
element

No Yes WW

hr_hk_
applicant_api

hrhkwraa.
pkh

create_hk_
applicant

Yes No HK

hr_hk_
assignment_
api

hrhkwras.pkh create_hk_
secondary_
emp_asg,
update_hk_
emp_asg

Yes No HK

hr_hk_
employee_api

hrhkwree.
pkh

create_hk_
employee

Yes No HK

hr_hk_
person_api

hrhkwrpe.
pkh

update_hk_
person

Yes No HK

hr_hk_
person_
address_api

hrhkwrpa.
pkh

create_hk_
person_
address,
update_
hk_person_
address

Yes No HK

hr_hk_
personal_
pay_method_
api

hrhkwrpm.
pkh

create_hk_
personal_
pay_method,
update_hk_
personal_
pay_method

Yes No HK

hr_hu_
applicant_api

peapphui.pkh create_hu_
applicant

No No HU

hr_hu_
contact_api

peconhui.pkh create_hu_
person

No No HU

hr_hu_
contingent_
worker_api

pecwkhui.
pkh

create_hu_
cwk

No No HU

hr_hu_
employee_api

peemphui.
pkh

create_hu_
employee

No No HU

hr_hu_
person_api

peperhui.pkh update_hu_
person

No No HU

hr_in_
assignment_
api

peasgini.pkh create_in_
secondary_
cwk_asg

Yes No IN
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hr_in_
assignment_
api

peasgini.pkh create_in_
secondary_
emp_asg

Yes No IN

hr_in_
assignment_
api

peasgini.pkh update_in_
cwk_asg

Yes No IN

hr_in_
assignment_
api

peasgini.pkh update_in_
emp_asg

Yes No IN

hr_in_
contact_
extra_info_
api

pereiini.pkh create_in_
contact_
extra_info,
update_in_
contact_
extra_info

Yes No IN

hr_in_
contact_rel_
api

pecrlini.pkh create_in_
contact

Yes No IN

hr_in_
contact_rel_
api

pecrlini.pkh update_in_
contact_
relationship

Yes No IN

hr_in_
employee_api

peempini.pkh create_in_
employee

Yes No IN

hr_in_
location_api

pelocinii.pkh create_in_
location,
update_in_
location

Yes No IN

hr_in_
person_
address_api

peaddini.pkh create_in_
person_
address,
update_
in_person_
address

Yes No IN

hr_in_
person_api

peperini.pkh update_in_
person

Yes No IN

hr_in_
person_extra_
info_api

pepeiini.pkh create_in_
passport_
details,
update_in_
passport_
details

Yes No IN
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hr_in_
person_extra_
info_api

pepeiini.pkh create_in_
person_extra_
info, update_
in_person_
extra_info

Yes No IN

hr_it_
employee_api

hrempiti.pkh create_it_
employee

No No IT

hr_job_api pejobapi.pkh create_job Yes Yes WW

hr_job_api pejobapi.pkh delete_valid_
grades,
update_
valid_grades

No No WW

hr_job_
requirement_
api

pejbrapi.pkh create_job_
requirement

Yes Yes WW

hr_jp_
person_api

pejppapi.pkh update_jp_
person

No No JP

hr_jpbp_api pejpapi.pkh create_jp_
appl_with_
educ_add,
create_jp_
applicant_
with_sit,
create_jp_
educ_sit,
create_jp_
emp_with_
educ_add,
create_jp_
employee_
with_sit

No No JP

hr_ki_
hierarchies_
api

hrhrcapi.pkh create_
hierarchy_
node, delete_
hierarchy_
node,
update_
hierarchy_
node

No Yes WW

hr_ki_
hierarchies_
api

hrhrcapi.pkh create_topic_
hierarchy_
map

No Yes WW

hr_ki_
hierarchies_
api

hrhrcapi.pkh create_topic_
ui_map

No Yes WW
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hr_ki_
hierarchies_
api

hrhrcapi.pkh create_ui_
hierarchy_
map

No Yes WW

hr_ki_
hierarchies_
api

hrhrcapi.pkh delete_
hierarchy_
node_map,
update_
hierarchy_
node_map

No Yes WW

hr_ki_
integrations_
api

hrintapi.pkh create_
integration,
delete_
integration,
update_
integration

No Yes WW

hr_ki_
integrations_
api

hrintapi.pkh validate_
integration

No Yes WW

hr_ki_
options_api

hroptapi.pkh create_option,
delete_
option,
update_
option

No Yes WW

hr_ki_option_
types_api

hrotyapi.pkh create_
option_
type, delete_
option_type
update_
option_type

No Yes WW

hr_ki_topics_
api

hrtpcapi.pkh create_topic,
delete_topic
update_topic

No Yes WW

hr_ki_topic_
integrations_
api

hrtisapi.pkh create_topic_
integration,
delete_topic_
integration
update_
topic_
integration

No Yes WW

hr_ki_topic_
integrations_
api

hrtisapi.pkh create_topic_
integration_
key, update_
topic_
integration_
key

No No WW
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hr_ki_user_
interfaces_api

hritfapi.pkh create_user_
interface,
delete_user_
interface,
update_user_
interface

No Yes WW

hr_location_
api

hrlocapi.pkh create_
location

Yes Yes WW

hr_location_
api

hrlocapi.pkh delete_
location

No Yes WW

hr_location_
api

hrlocapi.pkh update_
location

Yes Yes WW

hr_location_
extra_info_
api

hrleiapi.pkh create_
location_
extra_info,
delete_
location_
extra_info,
update_
location_
extra_info

No Yes WW

hr_maintain_
proposal_api

hrpypapi.pkh approve_
salary_
proposal

No Yes WW

hr_maintain_
proposal_api

hrpypapi.pkh cre_or_
upd_salary_
proposal

No No WW

hr_maintain_
proposal_api

hrpypapi.pkh delete_
proposal_
component

No Yes WW

hr_maintain_
proposal_api

hrpypapi.pkh delete_
salary_
proposal

No Yes WW

hr_maintain_
proposal_api

hrpypapi.pkh insert_
proposal_
component

No Yes WW

hr_maintain_
proposal_api

hrpypapi.pkh insert_salary_
proposal

No Yes WW

hr_maintain_
proposal_api

hrpypapi.pkh update_
proposal_
component

No Yes WW
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hr_maintain_
proposal_api

hrpypapi.pkh update_
salary_
proposal

No Yes WW

hr_nl_
absence_
action_api

penaaapi.pkh create_
absence_
action,
delete_
absence_
action,
update_
absence_
action

No Yes NL

hr_nl_
applicant_api

peempnli.pkh create_nl_
employee

No No NL

hr_nl_
assignment_
api

peasgnli.pkh create_nl_
secondary_
emp_asg

No No NL

hr_nl_
assignment_
api

peasgnli.pkh update_nl_
emp_asg

No No NL

hr_nz_
applicant_api

hrnzwrap.
pkh

create_nz_
applicant

Yes No NZ

hr_nz_
assignment_
api

hrnzwrea.pkh create_nz_
secondary_
emp_asg,
update_nz_
emp_asg

Yes No NZ

hr_nz_
employee_api

hrnzwree.pkh create_nz_
employee

Yes No NZ

hr_nz_
person_
address_api

hrnzwrpa.
pkh

create_nz_
person_
address,
update_
nz_person_
address

Yes No NZ

hr_nz_
person_api

hrnzwrup.
pkh

update_nz_
person

Yes No NZ

hr_nz_
personal_
pay_method_
api

hrnzwrpp.
pkh

create_nz_
personal_
pay_method,
update_nz_
personal_
pay_method

Yes No NZ
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hr_nz_tax_
api

hrnzwrtx.pkh maintain_
tax_info

Yes No NZ

hr_
objectives_api

peobjapi.pkh create_
objective,
delete_
objective,
update_
objective

No Yes WW

hr_
organization_
api

hrorgapi.pkh create_bgr_
classif

No No WW

hr_
organization_
api

hrorgapi.pkh create_
business_
group

Yes No WW

hr_
organization_
api

hrorgapi.pkh create_hr_
organization

No No WW

hr_
organization_
api

hrorgapi.pkh create_legal_
entity

No No WW

hr_
organization_
api

hrorgapi.pkh create_legal_
entity_classif

No No WW

hr_
organization_
api

hrorgapi.pkh create_oper_
unit_classif

No No WW

hr_
organization_
api

hrorgapi.pkh create_
operating_
unit

No No WW

hr_
organization_
api

hrorgapi.pkh create_org_
classification

Yes Yes WW

hr_
organization_
api

hrorgapi.pkh create_org_
information

No Yes WW

hr_
organization_
api

hrorgapi.pkh create_org_
manager

No No WW

hr_
organization_
api

hrorgapi.pkh create_
organization

Yes Yes WW
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hr_
organization_
api

hrorgapi.pkh delete_org_
manager

No Yes WW

hr_
organization_
api

hrorgapi.pkh delete_
organization

No Yes WW

hr_
organization_
api

hrorgapi.pkh disable_org_
classification

No No WW

hr_
organization_
api

hrorgapi.pkh enable_org_
classification

No No WW

hr_
organization_
api

hrorgapi.pkh trans_org_
name

No No WW

hr_
organization_
api

hrorgapi.pkh update_org_
information

No Yes WW

hr_
organization_
api

hrorgapi.pkh update_org_
manager

No No WW

hr_
organization_
api

hrorgapi.pkh update_
organization

Yes Yes WW

hr_
participants_
api

peparapi.pkh create_
participant

No Yes WW

hr_
participants_
api

peparapi.pkh update_
participant

No Yes WW

hr_
participants_
api

peparapi.pkh delete_
participant

No Yes WW

hr_pay_
scale_api

peppsapi.pkh create_pay_
scale

delete_pay_
scale

update_pay_
scale

No Yes WW

hr_pay_
scale_value_
api **

pypsrapi.pkh create_pay_
scale_value

Yes No WW
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hr_pay_
scale_value_
api **

pypsrapi.pkh update_pay_
scale_value

Yes No WW

hr_pay_
scale_value_
api **

pypsrapi.pkh delete_pay_
scale_value

No No WW

hr_perf_
review_api

peprvapi.pkh create_perf_
review

No Yes WW

hr_perf_
review_api

peprvapi.pkh delete_perf_
review

No Yes WW

hr_perf_
review_api

peprvapi.pkh update_perf_
review

No Yes WW

hr_
performance_
ratings_api

peprtapi.pkh create_
performance_
rating

No Yes WW

hr_
performance_
ratings_api

peprtapi.pkh delete_
performance_
rating

No Yes WW

hr_
performance_
ratings_api

peprtapi.pkh update_
performance_
rating

No Yes WW

hr_
periods_of_
placement_
api

pepdpapi.
pkh

update_pdp_
details

No Yes WW

hr_periods_
of_service_
api

pepdsapi.pkh update_pds_
details

Yes Yes WW

hr_person_
absence_api

peabsapi.pkh create_
person_
absence

No Yes WW

hr_person_
absence_api

peabsapi.pkh delete_
absence_
element

No No WW

hr_person_
absence_api

peabsapi.pkh insert_
absence_
element

No No WW

hr_person_
absence_api

peabsapi.pkh update_
absence_
element

No No WW
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hr_person_
absence_api

peabsapi.pkh delete_
person_
absence

No Yes WW

hr_person_
absence_api

peabsapi.pkh update_
person_
absence

No Yes WW
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hr_person_
address_api

peaddapi.pkh create_at_
person_
address,
create_au_
person_
address,

create_be_
person_
address,

create_de_
person_
address,

create_dk_
person_
address,

create_es_
person_
address,

create_fi_
person_
address,
create_gr_
person_
address,

create_ie_
person_
address,
create_it_
person_
address,
create_lu_
person_
address,
create_mx_
person_
address,
create_my_
person_
address,
create_nl_
person_
address,
create_pt_
person_
address,
create_sa_
person_
address,
create_se_
person_
address,
create_sg_
person_
address

No No WW
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hr_person_
address_api

peaddapi.pkh create_gb_
person_
address

Yes No UK

hr_person_
address_api

peaddapi.pkh create_hk_
person_
address

Yes No WW

hr_person_
address_api

peaddapi.pkh create_
person_
address

Yes Yes WW

hr_person_
address_api

peaddapi.pkh create_us_
person_
address

Yes No US

3-194 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_person_
address_api

peaddapi,pkh update_
at_person_
address,
update_
au_person_
address,
update_
be_person_
address,
update_
de_person_
address,
update_
dk_person_
address,
update_
es_person_
address,
update_
fi_person_
address,
update_
gr_person_
address,
update_
ie_person_
address,
update_
it_person_
address,
update_
lu_person_
address,
update_
mx_person_
address,
update_
my_person_
address,
update_
nl_person_
address,
update_
pt_person_
address,
update_
sa_person_
address,
update_
se_person_
address,
update_
sg_person_
address

No No WW

hr_person_
address_api

peaddapi.pkh update_
gb_person_
address

Yes No WW
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hr_person_
address_api

peaddapi.pkh update_
person_
address

Yes Yes WW

hr_person_
address_api

peaddapi.pkh update_pers_
addr_with_
style

No Yes WW

hr_person_
address_api

peaddapi.pkh update_
us_person_
address

Yes No WW

hr_person_
address_api

peaddapi.pkh cre_or_upd_
person_
address

Yes No WW

hr_person_
api

peperapi.pkh update_gb_
person

Yes No UK

hr_person_
api

peperapi.pkh update_
person

Yes Yes WW

hr_person_
api

peperapi.pkh update_us_
person

Yes No US

hr_person_
extra_info_
api

pepeiapi.pkh create_
person_extra_
info, delete_
person_extra_
info, update_
person_extra_
info

No Yes WW

hr_person_
type_usage_
api

peptuapi.pkh create_
person_type_
usage, delete_
person_
type_usage,
update_
person_type_
usage

No Yes WW

hr_personal_
pay_method_
api

pyppmapi.
pkh

create_ca_
personal_
pay_method,
update_ca_
personal_
pay_method

No No CA

hr_personal_
pay_method_
api

pyppmapi.
pkh

create_gb_
personal_
pay_method

Yes No UK
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hr_personal_
pay_method_
api

pyppmapi.
pkh

create_
personal_
pay_method

Yes Yes WW

hr_personal_
pay_method_
api

pyppmapi.
pkh

create_us_
personal_
pay_method

Yes No US

hr_personal_
pay_method_
api

pyppmapi.
pkh

delete_
personal_
pay_method

Yes Yes WW

hr_personal_
pay_method_
api

pyppmapi.
pkh

update_gb_
personal_
pay_method

Yes No UK

hr_personal_
pay_method_
api

pyppmapi.
pkh

update_
personal_
pay_method

Yes Yes WW

hr_personal_
pay_method_
api

pyppmapi.
pkh

update_us_
personal_
pay_method

Yes No US

hr_phone_api pephnapi.pkh create_phone Yes Yes WW

hr_phone_api pephnapi.pkh create_or_
update_
phone

No No WW

hr_phone_api pephnapi.pkh update_
phone

No Yes WW

hr_phone_api pephnapi.pkh delete_phone Yes Yes WW

hr_pos_
hierarchy_
ele_api

pepseapi.pkh create_pos_
hierarchy_ele

No Yes WW

hr_pos_
hierarchy_
ele_api

pepseapi.pkh delete_pos_
hierarchy_ele

No Yes WW

hr_pos_
hierarchy_
ele_api

pepseapi.pkh update_pos_
hierarchy_ele

No Yes WW

hr_position_
api

peposapi.pkh create_
position

Yes Yes WW

hr_position_
api

peposapi.pkh delete_
position

Yes Yes WW
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hr_position_
api

peposapi.pkh update_
position

Yes Yes WW

hr_position_
extra_info_
api

pepoiapi.pkh create_
position_
extra_info,
delete_
position_
extra_info,
update_
position_
extra_info

No Yes WW

hr_position_
requirement_
api

pepsrapi.pkh create_
position_
requirement

Yes Yes WW

hr_previous_
employment_
api

pepemapi.
pkh

create_
previous_
employer,
update_
previous_
employer,
delete_
previous_
employer,
create_
previous_
job, update_
previous_
job, delete_
previous_job,
create_prev_
job_extra_
info, update_
prev_job_
extra_info,
delete_prev_
job_extra_
info, create_
previous_
job_usage,
update_
previous_job_
usage, delete_
previous_job_
usage

No Yes WW
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hr_
progression_
point_api

pepspapi.pkh create_
progression_
point

delete_
progression_
point

update_
progression_
point

No Yes WW

hr_
qualification_
type_api

peeqtapi.pkh create_
qualification_
type, update_
qualification_
type

Yes Yes WW

hr_
qualification_
type_api

peeqtapi.pkh delete_
qualification_
type

No Yes WW

hr_rate_api pypyrapi.pkh create_
assignment_
rate

No Yes WW

hr_rate_api pypyrapi.pkh create_rate No Yes WW

hr_rate_api pypyrapi.pkh delete_rate No Yes WW

hr_rate_api pypyrapi.pkh update_
assignment_
rate

No Yes WW

hr_rate_api pypyrapi.pkh update_rate No Yes WW

hr_rate_
values_api

pypgrapi.pkh create_
assignment_
rate_value

Yes Yes WW

hr_rate_
values_api

pypgrapi.pkh create_rate_
value, delete_
rate_value,
update_rate_
value

No Yes WW

hr_rate_
values_api

pypgrapi.pkh update_
assignment_
rate_value

Yes Yes WW

hr_rate_
values_api

pypgrapi.pkh update_rate_
value

Yes Yes WW

hr_rating_
levels_api

pertlapi.pkh create_
rating_level

No Yes WW
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hr_rating_
levels_api

pertlapi.pkh delete_
rating_level

No Yes WW

hr_rating_
levels_api

pertlapi.pkh update_
rating_level

Yes Yes WW

hr_rating_
scales_api

perscapi.pkh create_
rating_scale

Yes Yes WW

hr_rating_
scales_api

perscapi.pkh delete_
rating_scale

No Yes WW

hr_rating_
scales_api

perscapi.pkh update_
rating_scale

Yes Yes WW

hr_retained_
rights_api

peretapi.pkh create_
retained_
right, delete_
retained_
right, update_
retained_
right

No No WW

hr_sa_
applicant_api

peappsai.pkh create_sa_
applicant

No No SA

hr_sa_
assignment_
api

peasgsai.pkh create_sa_
secondary_
emp_asg

update_sa_
emp_asg

No No SA

hr_sa_
contact_api

peconsai.pkh create_sa_
person

No No SA

hr_sa_
contingent_
worker_api

pecwksai.pkh create_sa_
cwk

No No SA

hr_sa_
contract_api

pectcsai.pkh create_sa_
contract

update_sa_
contract

No No SA

hr_sa_
employee_api

peempsai.pkh create_sa_
employee

No No SA

hr_sa_
periods_of_
service_api

pepdssai.pkh update_sa_
pds_details

No No SA

hr_sa_
person_api

pepersai.pkh update_sa_
person

No No SA
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hr_sa_
previous_
employment_
api

pepemsai.pkh create_sa_
previous_
employer

update_sa_
previous_
employer

No No SA

hr_salary_
basis_api

peppbapi.pkh create_
salary_basis

No Yes WW

hr_salary_
basis_api

peppbapi.pkh delete_
salary_basis

No Yes WW

hr_salary_
basis_api

peppbapi.pkh update_
salary_basis

No Yes WW

hr_salary_
survey_api

pepssapi.pkh create_
salary_survey

No Yes WW

hr_salary_
survey_api

pepssapi.pkh delete_
salary_survey

No Yes WW

hr_salary_
survey_api

pepssapi.pkh update_
salary_survey

No Yes WW

hr_salary_
survey_line_
api

pesslapi.pkh create_
salary_
survey_line

No No WW

hr_salary_
survey_line_
api

pesslapi.pkh delete_
salary_
survey_line

No No WW

hr_salary_
survey_line_
api

pesslapi.pkh update_
salary_
survey_line

No Yes WW

hr_salary_
survey_
mapping_api

pessmapi.pkh create_
mapping,
delete_
mapping,
mass_update,
update_
mapping

No Yes WW

hr_security_
organization_
api

pepsoapi.pkh create_
security_
organization

No Yes WW

hr_security_
organization_
api

pepsoapi.pkh delete_
security_
organization

No Yes WW
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hr_security_
organization_
api

pepsoapi.pkh update_
security_
organization

No Yes WW

hr_security_
payrolls_api

hrsprapi.pkh create_pay_
security_
payroll

No Yes WW

hr_security_
payrolls_api

hrsprapi.pkh delete_pay_
security_
payroll

No Yes WW

hr_security_
user_api

hrseuapi.pkh create_
security_
user, delete_
security_
user, update_
security_user

No Yes WW

hr_sg_
applicant_api

hrsgwraa.pkh create_sg_
applicant

Yes No SG

hr_sg_
assignment_
api

hrsgwras.pkh create_sg_
secondary_
emp_asg,
update_sg_
emp_asg

Yes No SG

hr_sg_
employee_api

hrsgwree.pkh create_sg_
employee

Yes No SG

hr_sg_
person_api

hrsgwrpe.
pkh

update_sg_
person

Yes No SG

hr_sg_
personal_
pay_method_
api

hrsgwrpm.
pkh

create_sg_
personal_
pay_method,
update_sg_
personal_
pay_method

Yes No SG

hr_sit_api pesitapi.pkh create_sit Yes Yes WW

hr_sit_api pesitapi.pkh delete_sit No Yes WW

hr_sit_api pesitapi.pkh update_sit No Yes WW

hr_sp_
placement_
api

pesppapi.pkh create_spp No Yes WW

hr_sp_
placement_
api

pesppapi.pkh delete_spp No No WW
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hr_sp_
placement_
api

pesppapi.pkh update_spp No Yes WW

hr_std_hol_
abs_api

peshaapi.pkh create_std_
hol_abs,
delete_std_
hol_abs,
update_std_
hol_abs

No Yes WW

hr_tcp_api hrtcpapi.pkh create_tcp,
delete_tcp

No Yes WW

hr_upload_
proposal_api

hrpypapi.pkh upload_
salary_
proposal

Yes Yes WW

hr_user_acct_
api

hrusrapi.pkh create_user_
acct, update_
user_acct

Yes Yes WW

hr_valid_
grade_api

pevgrapi.pkh create_valid_
grade

Yes Yes WW

hxt_gen_aai hxtgenai.pkh create_otlr_
add_assign_
info

No No WW

hxt_gen_aai hxtgenai.pkh update_otlr_
add_assign_
info

No No WW

pay_action_
information_
api

pyaifapi.pkh create_
action_
information,
delete_
action_
information,
update_
action_
information

No Yes WW

pay_balance_
adjustment_
api

pybadapi.pkh create_
adjustment

No No WW

pay_balance_
adjustment_
api

pybadapi.pkh delete_
adjustment

No No WW
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pay_balance_
attribute_api

pypbaapi.pkh create_
balance_
attribute,
delete_
balance_
attribute

No Yes WW

pay_balance_
category_api

pypbcapi.pkh create_
balance_
category,
delete_
balance_
category,
update_
balance_
category

No Yes WW

pay_bal_
attribute_
default_api

pypbdapi.
pkh

create_bal_
attribute_
default,
delete_bal_
attribute_
default

No Yes WW

pay_bal_
attrib_
definition_api

pyatdapi.pkh create_
bal_attrib_
definition,
delete_
bal_attrib_
definition

No Yes WW

pay_batch_
element_
entry_api

pybthapi.pkh create_batch_
header,
create_batch_
line, create_
batch_total,
update_
batch_header,
update_
batch_line,
update_
batch_total,
delete_batch_
header,
delete_batch_
line, delete_
batch_total

No Yes WW

pay_ca_emp_
fedtax_inf_
api

pycatapi.pkh create_ca_
emp_fedtax_
inf update_
ca_emp_
fedtax_inf
delete_ca_
emp_fedtax_
inf

No Yes CA
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pay_ca_emp_
prvtax_inf_
api

pycprapi.pkh create_ca_
emp_prvtax_
inf update_
ca_emp_
prvtax_inf
delete_ca_
emp_prvtax_
inf

No Yes CA

pay_city_tax_
rule_api

pyctyapi.pkh create_city_
tax_rule,
update_city_
tax_rule

Yes Yes US

pay_cnu_apI pycnuapi.pkh create_
contribution_
usage

No Yes FR

pay_cnu_api pycnuapi.pkh delete_
contribution_
usage

No Yes FR

pay_cnu_api pycnuapi.pkh update_
contribution_
usage

No Yes FR

pay_
contribution_
history_api

pyconapi.pkh create_
contribution_
history,
delete_
contribution_
history,
update_
contribution_
history

No Yes WW

pay_cost_
allocation_api

pycalapi.pkh create_cost_
allocation

No Yes WW

pay_cost_
allocation_api

pycalapi.pkh delete_cost_
allocation

No Yes WW

pay_cost_
allocation_api

pycalapi.pkh update_cost_
allocation

No Yes WW

pay_county_
tax_rule_api

pycntapi.pkh create_
county_tax_
rule update_
county_tax_
rule

Yes Yes US
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pay_
datetracked_
events_api

pydteapi.pkh create_
datetracked_
event, delete_
datetracked_
event,
update_
datetracked_
event

No Yes WW

pay_element_
entry_api

pyeleapi.pkh create_
element_
entry

Yes No WW

pay_element_
entry_api

pyeleapi.pkh delete_
element_
entry

Yes No WW

pay_element_
entry_api

pyeleapi.pkh update_
element_
entry

Yes No WW

pay_element_
extra_info_
api

pyeeiapi.pkh create_
element_
extra_info,
delete_
element_
extra_info,
update_
element_
extra_info

No Yes WW

pay_element_
link_api

pypelapi.pkh create_
element_
link, delete_
element_
link, update_
element_link

Yes Yes WW

pay_element_
types_api

pyetpapi.pkh create_
element_
types, delete_
element_
types,
update_
element_
types

Yes Yes WW

pay_element_
type_usage_
api

pyetuapi.pkh create_
element_
type_usage

No Yes WW

pay_element_
type_usage_
api

pyetuapi.pkh delete_
element_
type_usage

No Yes WW
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pay_element_
type_usage_
api

pyetuapi.pkh update_
element_
type_usage

No Yes WW

pay_event_
groups_api

pyevgapi.pkh create_
event_group,
delete_
event_group,
update_
event_group

No Yes WW

pay_event_
procedures_
api

pyevpapi.pkh create_event_
proc, delete_
event_proc,
update_
event_proc

No Yes WW

pay_event_
qualifiers_api

pyevqapi.pkh create_event_
qualifier,
delete_event_
qualifier,
update_
event_
qualifier

No Yes WW

pay_event_
updates_api

pypeuapi.pkh create_event_
update,
delete_event_
update,
update_
event_update

No Yes WW

pay_federal_
tax_rule_api

pyfedapi.pkh update_fed_
tax_rule

Yes Yes US

pay_ie_paye_
api

pyipdapi.pkh create_ie_
paye_details,
delete_ie_
paye_details,
update_ie_
paye_details

No Yes IE

pay_ie_prsi_
api

pysidapi.pkh create_ie_
prsi_details,
delete_ie_
prsi_details,
update_ie_
prsi_details

No Yes IE

pay_ie_sb_
api

pyiebapi.pkh create_ie_
sb_details,
delete_ie_
sb_details,
update_ie_
sb_details

No Yes IE
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pay_in_org_
payment_
method_api

pyopmini.
pkh

create_
in_org_
payment_
method,
update_
in_org_
payment_
method

Yes No IN

pay_input_
value_api

pyivlapi.pkh create_input_
value, delete_
input_value,
update_
input_value

Yes No WW

pay_
iterative_
rules_api

pyitrapi.pkh create_
iterative_
rule, delete_
iterative_
rule, update_
iterative_rule,

No No WW

pay_link_
input_values

pylivapi.pkh delete_link_
input_values,
update_link_
input_values

Yes Yes WW

pay_ncr_api pyncrapi.pkh create_pay_
net_calc_rule,
delete_pay_
net_calc_rule,
update_pay_
net_calc_rule

No Yes WW

pay_org_
payment_
method_api

pyopmapi.
pkh

create_org_
payment_
method
update_org_
payment_
method
delete_org_
payment_
method

No Yes WW

pay_payroll_
api

pyprlapi.pkh create_
payroll,
delete_
payroll,
update_
payroll

No No WW
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pay_pmed_
accounts_api

pypmaapi.
pkh

create_pmed_
accounts
update_
pmed_
accounts
delete_pmed_
accounts

No Yes CA

pay_run_
type_api

pyprtapi.pkh create_run_
type

No Yes WW

pay_run_
type_api

pyprtapi.pkh delete_run_
type

No Yes WW

pay_run_
type_api

pyprtapi.pkh update_run_
type

No Yes WW

pay_run_
type_org_
method_api

pyromapi.
pkh

create_run_
type_org_
method

No Yes WW

pay_run_
type_org_
method_api

pyromapi.
pkh

delete_run_
type_org_
method

No Yes WW

pay_run_
type_org_
method_api

pyromapi.
pkh

update_run_
type_org_
method

No Yes WW

pay_run_
type_usage_
api

pyrtuapi.pkh create_run_
type_usage

No Yes WW

pay_run_
type_usage_
api

pyrtuapi.pkh delete_run_
type_usage

No Yes WW

pay_run_
type_usage_
api

pyrtuapi.pkh update_run_
type_usage

No Yes WW

pay_state_
tax_rule_api

pystaapi.pkh create_state_
tax_rule
update_state_
tax_rule

Yes Yes US

pay_status_
processing_
rule_api

pypprapi.pkh create_status_
process_
rule, delete_
status_
process_
rule, update_
status_
process_rule

Yes Yes WW
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pay_us_tax_
api

pytaxapi.pkh delete_tax_
rule

No No US

pay_us_tax_
bals_adj_api

pytbaapi.pkh create_tax_
balance_
adjustment

No No US

pay_user_
column_api

pypucapi.pkh create_user_
column

delete_user_
column

update_user_
column

Yes Yes WW

pay_user_
column_
instance_api

pyuciapi.pkh create_user_
column_
instance

delete_user_
column_
instance

update_user_
column_
instance

Yes Yes WW

pay_user_
row_api

pypurapi.pkh create_user_
row

delete_user_
row

update_user_
row

Yes Yes WW

pay_user_
table_api

pyputapi.pkh create_user_
table

delete_user_
table

update_user_
table

Yes Yes WW

pay_wci_
accounts_api

pypwaapi.
pkh

create_wci_
accounts,
update_wci_
accounts,
delete_wci_
accounts

No Yes CA

pay_wci_
occupations_
api

pypwoapi.
pkh

create_wci_
occupation
update_wci_
occupation
delete_wci_
occupation

No Yes CA
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pay_wci_
rates_api

pypwrapi.
pkh

create_wci_
rate, update_
wci_rate,
delete_wci_
rate

No Yes CA

per_bf_
balance_
amounts_api

pebbaapi.pkh create_
balance_
amount,
delete_
balance_
amount,
update_
balance_
amount

No Yes WW

per_bf_
balance_
types_api

pebbtapi.pkh create_
balance_
type, delete_
balance_
type, update_
balance_type

No Yes WW

per_bf_
payment_
details_api

pebpdapi.pkh create_
payment_
detail, delete_
payment_
detail,
update_
payment_
detail

No Yes WW

per_bf_
payroll_runs_
api

pebprapi.pkh create_
payroll_run

Yes Yes WW

per_bf_
payroll_runs_
api

pebprapi.pkh delete_
payroll_
run, update_
payroll_run

No Yes WW

per_bf_proc_
assignment_
api

pebpaapi.pkh create_
processed_
assignment

No Yes WW

per_bf_proc_
assignment_
api

pebpaapi.pkh delete_
processed_
assignment

No Yes WW

per_bf_proc_
assignment_
api

pebpaapi.pkh update_
processed_
assignment

No Yes WW

Extending Oracle HRMS 3-211



Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

per_ca_
person_
address_api

peaddcai.pkh create_ca_
person_
address,

update_
ca_person_
address

No No CA

per_cancel_
application_
api

pecapapi.pkh cancel_
application

No Yes WW

per_
checklist_
items_api

pechkapi.pkh create_
checklist_
items,
update_
checklist_
items, delete_
checklist_
items

No Yes WW

per_
disability_api

pedisapi.pkh create_
disability,
update_
disability,
delete_
disability

No Yes WW

per_estab_
attendances_
api

peesaapi.pkh create_
attended_
estab

No Yes WW

per_estab_
attendances_
api

peesaapi.pkh delete_
attended_
estab

No Yes WW

per_estab_
attendances_
api

peesaapi.pkh update_
attended_
estab

No Yes WW

per_events_
api

peevtapi.pkh create_event No Yes WW

per_events_
api

peevtapi.pkh delete_event No Yes WW

per_events_
api

peevtapi.pkh update_event No Yes WW

per_
hierarchy_api

pepghapi.pkh create_
hierarchy,
update_
hierarchy,
delete_
hierarchy

No Yes WW
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per_
hierarchy_
nodes_api

pepgnapi.pkh create_
hierarchy_
nodes,
update_
hierarchy_
nodes, delete_
hierarchy_
nodes

No Yes WW

per_
hierarchy_
versions_api

pepgvapi.pkh create_
hierarchy_
versions,
update_
hierarchy_
versions,
delete_
hierarchy_
versions

No Yes WW

per_job_
extra_info_
api

pejeiapi.pkh create_job_
extra_info,
delete_job_
extra_info,
update_job_
extra_info

No Yes WW

per_job_
group_api

pejgrapi.pkh create_job_
group

Yes Yes WW

per_job_
group_api

pejgrapi.pkh delete_job_
group

No Yes WW

per_job_
group_api

pejgrapi.pkh update_job_
group

Yes Yes WW

per_medical_
assessment_
api

pemeaapi.
pkh

create_
medical_
assessment,
update_
medical_
assessment,
delete_
medical_
assessment

No Yes WW

per_org_
structure_
version_api

peosvapi.pkh create_org_
structure_
version,
update_org_
structure_
version,

Yes Yes WW

per_org_
structure_
version_api

peosvapi.pkh delete_org_
structure_
version

No Yes WW
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per_
organization_
structure_api

peorsapi.pkh create_org_
struct_and_
def_ver

No No WW

per_
organization_
structure_api

peorsapi.pkh create_
organization_
structure,
update_
organization_
structure,

Yes Yes WW

per_
organization_
structure_api

peorsapi.pkh delete_
organization_
structure

No Yes WW

per_pos_
structure_
version_api

pepsvapi.pkh create_pos_
structure_
version,
update_pos_
structure_
version,
delete_pos_
structure_
version

No Yes WW

per_position_
structure_api

pepstapi.pkh create_pos_
struct_and_
def_ver

No No WW

per_position_
structure_api

pepstapi.pkh create_
position_
structure,
update_
position_
structure,
delete_
positiontion_
structure

No Yes WW

per_
qualifications_
api

pequaapi.pkh create_
qualification,
update_
qualification,
delete_
qualification

No Yes WW

per_rec_
activity_for_
api

percfapi.pkh create_rec_
activity_for

No Yes WW

per_rec_
activity_for_
api

percfapi.pkh delete_rec_
activity_for

No Yes WW

per_rec_
activity_for_
api

percfapi.pkh update_rec_
activity_for

No Yes WW
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per_
recruitment_
activity_api

peraaapi.pkh create_
recruitment_
activity

No Yes WW

per_
recruitment_
activity_api

peraaapi.pkh delete_
recruitment_
activity

No Yes WW

per_
recruitment_
activity_api

peraaapi.pkh update_
recruitment_
activity

No Yes WW

per_
requisitions_
api

pereqapi.pkh create_
requisition

No Yes WW

per_
requisitions_
api

pereqapi.pkh delete_
requisition

No Yes WW

per_
requisitions_
api

pereqapi.pkh update_
requisition

No Yes WW

per_sa_
disability_api

pedissai.pkh create_sa_
disability

update_sa_
disability

No No SA

per_sa_work_
incident_api

peincsai.pkh create_
sa_work_
incident

update_
sa_work_
incident

No No SA

per_shared_
types_api

peshtapi.pkh create_
shared_type

No Yes WW

per_shared_
types_api

peshtapi.pkh delete_
shared_type

No Yes WW

per_shared_
types_api

peshtapi.pkh update_
shared_type

No Yes WW

per_
supplementary_
role_api

perolapi.pkh create_
supplementary_
role

Yes Yes WW

per_
supplementary_
role_api

perolapi.pkh delete_
supplementary_
role

No Yes WW
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per_
supplementary_
role_api

perolapi.pkh update_
supplementary_
role

Yes Yes WW

per_vacancy_
api

pevacapi.pkh create_
vacancy

No Yes WW

per_vacancy_
api

pevacapi.pkh delete_
vacancy

No Yes WW

per_vacancy_
api

pevacapi.pkh update_
vacancy

No Yes WW

per_work_
incident_api

peincapi.pkh create_work_
incident,
update_
work_
incident,
delete_work_
incident

No Yes WW

pqh_
accommodations_
api

pqaccapi.pkh create_
accommodation

No Yes FR

pqh_
accommodations_
api

pqaccapi.pkh delete_
accommodation

No Yes FR

pqh_
accommodations_
api

pqaccapi.pkh update_
accommodation

No Yes FR

pqh_assign_
accommodations_
api

pqasaapi.pkh create_
assign_
accommodation

No Yes FR

pqh_assign_
accommodations_
api

pqasaapi.pkh delete_
assign_
accommodation

No Yes FR

pqh_assign_
accommodations_
api

pqasaapi.pkh update_
assign_
accommodation

No Yes FR

pqh_
attribute_
ranges_api

pqrngapi.pkh create_
attribute_
range,
update_
attribute_
range, delete_
attribute_
range

No Yes WW
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pqh_bdgt_
cmmtmnt_
elmnts_api

pqbceapi.pkh create_bdgt_
cmmtmnt_
elmnt,
update_bdgt_
cmmtmnt_
elmnt,
delete_bdgt_
cmmtmnt_
elmnt

No Yes WW

pqh_bdgt_
pool_
realloctions_
api

pqbreapi.pkh create_
realloc_txn_
dtl

No Yes WW

pqh_bdgt_
pool_
realloctions_
api

pqbreapi.pkh create_
realloc_txn_
period

No Yes WW

pqh_bdgt_
pool_
realloctions_
api

pqbreapi.pkh delete_
realloc_txn_
dtl

No Yes WW

pqh_bdgt_
pool_
realloctions_
api

pqbreapi.pkh delete_
realloc_txn_
period

No Yes WW

pqh_bdgt_
pool_
realloctions_
api

pqbreapi.pkh update_
realloc_txn_
dtl

No Yes WW

pqh_bdgt_
pool_
realloctions_
api

pqbreapi.pkh update_
realloc_txn_
period

No Yes WW

pqh_budget_
details_api

pqbdtapi.pkh create_
budget_
detail,
update_
budget_
detail, delete_
budget_detail

No Yes WW
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pqh_budget_
elements_api

pqbelapi.pkh create_
budget_
element,
update_
budget_
element,
delete_
budget_
element

No Yes WW

pqh_budget_
fund_srcs_api

pqbfsapi.pkh create_
budget_
fund_src,
update_
budget_
fund_src,
delete_
budget_
fund_src

No Yes WW

pqh_budget_
gl_flex_
maps_api

pqbgmapi.
pkh

create_
budget_gl_
flex_map,
update_
budget_
gl_flex_
map, delete_
budget_gl_
flex_map

No Yes WW

pqh_budget_
periods_api

pqbprapi.pkh create_
budget_
period,
update_
budget_
period,
delete_
budget_
period

No Yes WW

pqh_budget_
pools_api

pqbplapi.pkh create_
reallocation_
folder

No Yes WW

pqh_budget_
pools_api

pqbplapi.pkh create_
reallocation_
txn

No Yes WW

pqh_budget_
pools_api

pqbplapi.pkh delete_
reallocation_
folder

No Yes WW

pqh_budget_
pools_api

pqbplapi.pkh delete_
reallocation_
txn

No Yes WW
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pqh_budget_
pools_api

pqbplapi.pkh update_
reallocation_
folder

No Yes WW

pqh_budget_
pools_api

pqbplapi.pkh update_
reallocation_
txn

No Yes WW

pqh_budget_
sets_api

pqbstapi.pkh create_
budget_
set, update_
budget_
set, delete_
budget_set

No Yes WW

pqh_budget_
versions_api

pqbvrapi.pkh create_
budget_
version,
update_
budget_
version,
delete_
budget_
version

No Yes WW

pqh_
budgets_api

pqbgtapi.pkh create_
budget,
update_
budget,
delete_
budget

No Yes WW

pqh_corps_
definition_api

pqcpdapi.pkh create_corps_
definition

No Yes FR

pqh_corps_
definition_api

pqcpdapi.pkh delete_corps_
definition

No Yes FR

pqh_corps_
definition_api

pqcpdapi.pkh update_
corps_
definition

No Yes FR

pqh_corps_
extra_info_
api

pqceiapi.pkh create_corps_
extra_info

No Yes FR

pqh_corps_
extra_info_
api

pqceiapi.pkh delete_corps_
extra_info

No Yes FR

pqh_corps_
extra_info_
api

pqceiapi.pkh update_
corps_extra_
info

No Yes FR
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pqh_de_case_
groups_api

pqcgnapi.pkh delete_case_
groups

No Yes DE

pqh_de_case_
groups_api

pqcgnapi.pkh insert_case_
groups

No No DE

pqh_de_case_
groups_api

pqcgnapi.pkh update_case_
groups

No Yes DE

pqh_de_ent_
minutes_api

pqetmapi.pkh delete_ent_
minutes

No Yes DE

pqh_de_ent_
minutes_api

pqetmapi.pkh insert_ent_
minutes

No No DE

pqh_de_ent_
minutes_api

pqetmapi.pkh update_ent_
minutes

No Yes DE

pqh_de_ins_
end_reasons_
api

pqpreapi.pkh delete_
pension_end_
reasons

No Yes DE

pqh_de_ins_
end_reasons_
api

pqpreapi.pkh insert_
pension_end_
reasons

No No DE

pqh_de_ins_
end_reasons_
api

pqpreapi.pkh update_
pension_end_
reasons

No Yes DE

pqh_de_
level_codes_
api

pqlcdapi.pkh delete_level_
codes

No Yes DE

pqh_de_
level_codes_
api

pqlcdapi.pkh insert_level_
codes

No No DE

pqh_de_
level_codes_
api

pqlcdapi.pkh update_level_
codes

No Yes DE

pqh_de_
level_
numbers_api

pqgvnapi.pkh delete_level_
numbers

No Yes DE

pqh_de_
level_
numbers_api

pqgvnapi.pkh insert_level_
numbers

No No DE

pqh_de_
level_
numbers_api

pqgvnapi.pkh update_level_
numbers

No Yes DE
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pqh_de_
operation_
groups_api

pqopgapi.pkh delete_
operation_
groups

No Yes DE

pqh_de_
operation_
groups_api

pqopgapi.pkh insert_
operation_
groups

No No DE

pqh_de_
operation_
groups_api

pqopgapi.pkh update_
operation_
groups

No Yes DE

pqh_de_
operations_
api

pqoplapi.pkh delete_
operations

No Yes DE

pqh_de_
operations_
api

pqoplapi.pkh insert_
operations

No No DE

pqh_de_
operations_
api

pqoplapi.pkh update_
operations

No Yes DE

pqh_de_
result_sets_
api

pqrssapi.pkh delete_result_
sets

No Yes DE

pqh_de_
result_sets_
api

pqrssapi.pkh insert_result_
sets

No No DE

pqh_de_
result_sets_
api

pqrssapi.pkh update_
result_sets

No Yes DE

pqh_de_
tktdtls_api

pqtktapi.pkh delete_tkt_
dtls

No No DE

pqh_de_
tktdtls_api

pqtktapi.pkh insert_tkt_
dtls

No No DE

pqh_de_
tktdtls_api

pqtktapi.pkh update_tkt_
dtls

No No DE

pqh_de_
vlddef_api

pqdefapi.pkh delete_vldtn_
defn

No No DE

pqh_de_
vlddef_api

pqdefapi.pkh insert_vldtn_
defn

No Yes DE

pqh_de_
vlddef_api

pqdefapi.pkh update_
vldtn_defn

No Yes DE
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pqh_de_
vldjob_api

pqwvjapi.pkh delete_vldtn_
job

No Yes DE

pqh_de_
vldjob_api

pqwvjapi.pkh insert_vldtn_
job

No Yes DE

pqh_de_
vldjob_api

pqwvjapi.pkh update_
vldtn_job

No Yes DE

pqh_de_
vldjobftr_api

pqftrapi.pkh delete_vldtn_
jobftr

No Yes DE

pqh_de_
vldjobftr_api

pqftrapi.pkh insert_vldtn_
jobftr

No Yes DE

pqh_de_
vldjobftr_api

pqftrapi.pkh update_
vldtn_jobftr

No Yes DE

pqh_de_
vldlvl_api

pqlvlapi.pkh delete_vldtn_
lvl

No Yes DE

pqh_de_
vldlvl_api

pqlvlapi.pkh insert_vldtn_
lvl

No Yes DE

pqh_de_
vldlvl_api

pqlvlapi.pkh update_
vldtn_lvl

No Yes DE

pqh_de_
vldopr_api

pqopsapi.pkh delete_vldtn_
oprn

No Yes DE

pqh_de_
vldopr_api

pqopsapi.pkh insert_vldtn_
oprn

No Yes DE

pqh_de_
vldopr_api

pqopsapi.pkh update_
vldtn_oprn

No Yes DE

pqh_de_
vldver_api

pqverapi.pkh delete_vldtn_
vern

No Yes DE

pqh_de_
vldver_api

pqverapi.pkh insert_vldtn_
vern

No Yes DE

pqh_de_
vldver_api

pqverapi.pkh update_
vldtn_vern

No Yes DE

pqh_dflt_
budget_
elements_api

pqdelapi.pkh create_dflt_
budget_
element,
update_dflt_
budget_
element,
delete_dflt_
budget_
element

No Yes WW
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pqh_dflt_
budget_sets_
api

pqdstapi.pkh create_dflt_
budget_set,
update_dflt_
budget_set,
delete_dflt_
budget_set

No Yes WW

pqh_dflt_
fund_srcs_api

pqdfsapi.pkh create_dflt_
fund_src,
update_dflt_
fund_src,
delete_dflt_
fund_src

No Yes WW

pqh_fr_
global_
payscale_api

pqginapi.pkh create_
global_
index, delete_
global_index,
update_
global_index

No Yes FR

pqh_fr_
global_
payscale_api

pqginapi.pkh create_
indemnity_
rate, delete_
indemnity_
rate, update_
indemnity_
rate

No Yes FR

pqh_fr_stat_
situations_api

pqstsapi.pkh create_
statutory_
situation,
delete_
statutory_
situation,
update_
statutory_
situation

No Yes FR

pqh_fr_stat_
sit_rules_api

pqstrapi.pkh create_stat_
situation_
rule, delete_
stat_
situation_
rule, update_
stat_
situation_rule

No Yes FR

pqh_fr_
validations_
api

pqvldapi.pkh delete_
validation

No Yes FR

pqh_fr_
validations_
api

pqvldapi.pkh insert_
validation

No Yes FR
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pqh_fr_
validations_
api

pqvldapi.pkh update_
validation

No Yes FR

pqh_fr_
validation_
events_api

pqvleapi.pkh delete_
validation_
event

No Yes FR

pqh_fr_
validation_
events_api

pqvleapi.pkh insert_
validation_
event

No Yes FR

pqh_fr_
validation_
events_api

pqvleapi.pkh update_
validation_
event

No Yes FR

pqh_fr_
validation_
periods_api

pqvlpapi.pkh delete_
validation_
period

No Yes FR

pqh_fr_
validation_
periods_api

pqvlpapi.pkh insert_
validation_
period

No Yes FR

pqh_fr_
validation_
periods_api

pqvlpapi.pkh update_
validation_
period

No Yes FR

pqh_ref_
templates_api

pqrftapi.pkh create_ref_
template,
update_ref_
template
delete_ref_
template

No Yes WW

pqh_role_
extra_info_
api

pqreiapi.pkh create_role_
extra_info

No Yes WW

pqh_role_
extra_info_
api

pqreiapi.pkh delete_role_
extra_info

No Yes WW

pqh_role_
extra_info_
api

pqreiapi.pkh update_role_
extra_info

No Yes WW

pqh_role_
templates_api

pqrtmapi.pkh create_role_
template,
update_role_
template,
delete_role_
template

No Yes WW
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pqh_roles_api pqrlsapi.pkh create_role,
update_role,
delete_role

No Yes WW

pqh_routing_
categories_
api

pqrctapi.pkh create_
routing_
category,
update_
routing_
category,
delete_
routing_
category

No Yes WW

pqh_
routing_list_
members_api

pqrlmapi.pkh create_
routing_list_
member,
update_
routing_list_
member,
delete_
routing_list_
member

No Yes WW

pqh_routing_
lists_api

pqrltapi.pkh create_
routing_
list, update_
routing_
list, delete_
routing_list

No Yes WW

pqh_rule_
attributes_api

pqrlaapi.pkh delete_rule_
attribute

No Yes WW

pqh_rule_
attributes_api

pqrlaapi.pkh insert_rule_
attribute

No Yes WW

pqh_rule_
attributes_api

pqrlaapi.pkh update_rule_
attribute

No Yes WW

pqh_rule_
sets_api

pqrstapi.pkh create_rule_
set, update_
rule_set,
delete_rule_
set

No Yes WW

pqh_
situations_api

pqlosapi.pkh create_
situation

No Yes FR

pqh_
situations_api

pqlosapi.pkh delete_
situation

No Yes FR

pqh_
situations_api

pqlosapi.pkh update_
situation

No Yes FR
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pqh_
template_
attributes_api

pqtatapi.pkh create_
template_
attribute,
update_
template_
attribute,
delete_
template_
attribute

No Yes WW

pqh_
templates_api

pqtemapi.pkh create_
generic_
template,
update_
generic_
template,
delete_
generic_
template

No Yes WW

pqh_tran_
category_api

pqtctapi.pkh update_tran_
category

No Yes WW

pqh_txn_cat_
attributes_api

pqtcaapi.pkh update_txn_
cat_attribute

No Yes WW

pqh_txn_job_
requirements_
api

pqtjrapi.pkh create_
txn_job_
requirement

No Yes WW

pqh_txn_job_
requirements_
api

pqtjrapi.pkh delete_
txn_job_
requirement

No Yes WW

pqh_txn_job_
requirements_
api

pqtjrapi.pkh update_
txn_job_
requirement

No Yes WW

pqp_aat_api pqaatapi.pkh create_
assignment_
attribute,
delete_
assignment_
attribute,
update_
assignment_
attribute

No Yes WW

pqp_
pension_
types_api

pqptyapi.pkh create_
pension_type

No Yes WW

pqp_
pension_
types_api

pqptyapi.pkh delete_
pension_type

No Yes WW
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pqp_
pension_
types_api

pqptyapi.pkh update_
pension_type

No Yes WW

pqp_shp_api pqshpapi.pkh create_
service_
history_
period,
delete_
service_
history_
period,
update_
service_
history_
period

No Yes WW

pqp_vehicle_
allocations_
api

pqvalapi.pkh create_
vehicle_
allocation

No Yes WW

pqp_vehicle_
allocations_
api

pqvalapi.pkh delete_
vehicle_
allocation

No Yes WW

pqp_vehicle_
allocations_
api

pqvalapi.pkh update_
vehicle_
allocation

No Yes WW

pqp_vehicle_
details_api

pqpvdapi.
pkh

create_
vehicle_
details,
delete_
vehicle_
details,
update_
vehicle_
details

Yes No WW

pqp_vehicle_
repository_
api

pqvreapi.pkh create_vehicle Yes Yes WW

pqp_vehicle_
repository_
api

pqvreapi.pkh delete_
vehicle

Yes Yes WW

pqp_vehicle_
repository_
api

pqvreapi.pkh update_
vehicle

Yes Yes WW

* CREATE_COMPETENCE_ELEMENT is supported by Data Pump only when the type
= COMPETENCE_USAGE; that is, when categorizing competences under the relevant
competence categories.
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** Please note the following API names were changed in the March Family Pack 2003
(FP.E):

• The old hr_grade_api, pygrrapi.pkh, has been renamed to hr_grade_rate_value_api.

• A new hr_grade_api, pergrdapi.pkh, has been added.

• The old hr_pay_scale_api, pypsrapi.pkh, has been renamed to
hr_pay_scale_value_api.

• The pay_pap_api api has been withdrawn and replaced by hr_accrual_plan_api
(hrpapapi.pkh)

Key to Localization Codes

• AT - Austria

• AU - Australia

• BE - Belgium

• CA - Canada

• CN - China

• DE - Germany

• DK - Denmark

• ES - Spain

• FD - US Federal

• FI - Finland

• FR - France

• GR - Greece

• HK - Hong Kong

• IE - Ireland

• IN - India

• IT - Italy

• JP - Japan

• LU - Luxembourg

• MX - Mexico

• MY - Malaysia

• NL - Netherlands

• NZ - New Zealand

• PT - Portugal

• SA - Saudi Arabia

• SE - Sweden

• SG - Singapore

• UK - United Kingdom
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• US - United States

• WW - All Legislations

APIs Available for HR Foundation Users
Application Programmatic Interfaces (APIs) are a logical grouping of all external process
routines. The Oracle HRMS API strategy delivers a set of PL/SQL packages procedures
and functions that provide an open interface to the database.

Further information on the purpose of each API is available in the API package
header. For information on how to call APIs, see the technical essay APIs in Oracle
HRMS, Oracle HRMS Implementation Guide. See also the Oracle Applications System
Administrator’s Guide.

See also:

• Publicly Callable Business Process APIs in iRecruitment, Oracle iRecruitment
Implementation Guide

• Publicly Callable Business Process APIs in Oracle Training Administration,
Implementing Oracle Learning Management

• Publicly Callable Business Process APIs in Oracle Time & Labor, Oracle Time & Labor
Implementation and User Guide

The following table shows the APIs delivered with Oracle Foundation.

Important: This list includes all the supported APIs in Oracle
HRMS, including HR, Payroll, and Standard and Advanced
Benefits. Any APIs not included in this list are for internal use only
and are not supported.

Note: Note: Legislation WW = All Legislations

These APIs are supported for HR Foundation users:

Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_
competence_
element_api

pecelapi.pkh create_
competence_
element

Yes Yes WW

hr_
competence_
element_api

pecelapi.pkh delete_
competence_
element,
update_
competence_
element

No Yes WW

hr_
competence_
element_api

pecelapi.pkh update_
personal_
comp_
element

No Yes WW
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_
competences_
api

pecpnapi.pkh create_
competence,
update_
competence

Yes Yes WW

hr_
employee_api

peempapi.
pkh

create_
employee

Yes Yes WW

hr_
employee_api

peempapi.
pkh

re_hire_ex_
employee

Yes Yes WW

hr_hierarchy_
element_api

peoseapi.pkh create_
hierarchy_
element

Yes Yes WW

hr_hierarchy_
element_api

peoseapi.pkh delete_
hierarchy_
element,
update_
hierarchy_
element

No Yes WW

hr_job_api pejgobapi.
pkh

create_job Yes Yes WW

hr_location_
api

hrlocapi.pkh create_
location,
update_
location

Yes Yes WW

hr_location_
api

hrlocapi.pkh delete_
location

No Yes WW

hr_
organization_
api

hrorgapi.pkh create_bgr_
classif,

No No WW

hr_
organization_
api

hrorgapi.pkh create_
business_
group

Yes No WW

hr_
organization_
api

hrorgapi.pkh create_legal_
entity,

No No WW

hr_
organization_
api

hrorgapi.pkh create_legal_
entity_classif

No No WW

hr_
organization_
api

hrorgapi.pkh create_oper_
unit_classif

No No WW
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_
organization_
api

hrorgapi.pkh create_
operating_
unit

No No WW

hr_
organization_
api

hrorgapi.pkh create_org_
classification

Yes Yes WW

hr_
organization_
api

hrorgapi.pkh create_org_
information

No Yes WW

hr_
organization_
api

hrorgapi.pkh create_org_
manager

No No WW

hr_
organization_
api

hrorgapi.pkh create_
organization,
update_
organization

Yes Yes WW

hr_
organization_
api

hrorgapi.pkh delete_org_
manager

No Yes WW

hr_
organization_
api

hrorgapi.pkh delete_
organization

No Yes WW

hr_
organization_
api

hrorgapi.pkh disable_org_
classification,
enable_org_
classification

No No WW

hr_
organization_
api

hrorgapi.pkh trans_org_
name

No No WW

hr_
organization_
api

hrorgapi.pkh update_org_
information

No Yes WW

hr_
organization_
api

hrorgapi.pkh update_org_
manager

No No WW

hr_person_
address_api

peaddapi.pkh create_
person_
address,
update_
person_
address

Yes Yes WW
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Package
Name

File Name Business
Process

Supported
by Data
Pump

User Hooks Legislation

hr_phone_api pephnapi.pkh create_phone,
update_
phone

Yes Yes WW

hr_phone_api pephnapi.pkh delete_phone No Yes WW

hr_pos_
hierarchy_
ele_api

pepseapi.pkh create_pos_
hierarchy_ele,
update_pos_
hierarchy_ele,
delete_pos_
hierarchy_ele

No Yes WW

hr_position_
api

peposapi.pkh create_
position,
update_
position,
delete_
position

Yes Yes WW

hr_rating_
levels_api

pertlapi.pkh create_
rating_
level, delete_
rating_level

No Yes WW

hr_rating_
levels_api

pertlapi.pkh update_
rating_level

Yes Yes WW

hr_rating_
scales_api

perscapi.pkh create_
rating_scale,
update_
rating_scale

Yes Yes WW

hr_rating_
scales_api

perscapi.pkh delete_
rating_scale

No Yes WW

hr_valid_
grade_api

pevgrapi.pkh create_valid_
grade

Yes Yes WW

per_job_
group_api

pejgrapi.pkh create_
job_group,
update_job_
group

Yes Yes WW

per_job_
group_api

pejgrapi.pkh delete_job_
group

No Yes WW

For more information about APIs, see: APIs in Oracle HRMS, Oracle HRMS Configuring,
Reporting, and System Administration Guide

APIs to Which Restrictions Apply for HR Foundation
You can perform the following tasks using the APIs listed, however you must only use
the restricted list of parameters as shown in the following tables:
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hr_employee_api

To create an employee call the following API:

File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peempapi.pkh hr_employee_api create_employee None p_validate p_
hire_date p_
business_group_
id p_last_name
p_previous_last_
name p_mailstop
p_office_number
p_internal_
location p_
correspondence_
language p_
known_as p_sex
p_date_of_birth
p_email_address
p_employee_
number p_
expense_check_
send_to_address
p_first_name p_
middle_names
p_national_
identifier p_
title p_work_
telephone
p_attribute_
category p_
attribute1-30

To re-hire an ex-employee call the following API:

File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peempapi.pkh hr_employee_api re_hire_ex_
employee

None p_validate p_
hire_date p_
person_id p_
object_version_
number

hr_contingent_worker_api

To create a contingent worker call the following API:
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File Name Package Name Business
Process

Special
Instructions

Available
Parameters

pecwkapi.pkh hr_contingent_
worker_api

create_cwk None p_validate p_
business_group_
id p_last_name
p_email_address
p_npw_number
p_first_name p_
middle_names
p_previous_
last_name p_
mailstop p_title
p_known_as p_
work_telephone
p_start_date p_
sex p_date_of_
birth p_national_
identifier p_
office_number
p_internal_
location p_
correspondence_
language p_
attribute_
category p_
attribute1-30

To terminate a contingent worker’s placement call the following API:

File Name Package Name Business
Process

Special
Instructions

Available
Parameters

pecwkapi.pkh hr_contingent_
worker_api

terminate_
placement

p_effective_date
must be set to the
system date. p_
final_process_
date and p_
last_standard_
process_date
should be set to
the same date
as p_actual_
termination_date

p_effective_
date p_final_
process_date p_
last_standard_
date p_validate
p_person_
id p_date_
start p_object_
version_number
p_actual_
termination_date
p_projected_
termination_date

To reverse a placement termination call the following API:

3-234 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



File Name Package Name Business
Process

Special
Instructions

Available
Parameters

pecwkapi.pkh hr_contingent_
worker_api

reverse_
terminate_
placement

p_effective_date
must be set to the
system date.

p_effective_
date p_validate
p_person_
id p_actual_
termination_date
p_clear_details

hr_person_api

To update an employee or contingent worker’s personal information call the following
API:

File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peperapi.pkh hr_person_api update_person p_effective_date
must be set to
the system date.
p_datetrack_
update_mode
must be set to
CORRECTION.

p_effective_date
p_datetrack_
update_mode p_
validate p_hire_
date p_business_
group_id p_last_
name p_sex p_
date_of_birth
p_email_address
p_employee_
number p_
npw_number
p_expense_
check_send_to_
address p_title
p_first_name p_
middle_names
p_national_
identifier p_
previous_last_
name p_known_
as p_mailstop p_
office_number
p_internal_
location p_
correspondence_
language p_
work_telephone
p_attribute_
category p_
attribute1-30 p_
object_version_
number p_party_
id

hr_ex_employee_api

To terminate an employee call the following API:
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File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peexeapi.pkh hr_ex_
employee_api

actual_
termination_emp

None p_validate
p_period_
of_service_
id p_object_
version_number
p_actual_
termination_date

followed by

File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peexeapi.pkh hr_ex_
employee_api

final_process_
emp

p_final_process_
date must be
the same date
as was set for
the p_actual_
termination_date
in the actual_
termination_emp
API.

p_final_process_
date p_actual_
termination_
date p_validate
p_period_of_
service_id p_
object_version_
number

hr_assignment_api

To update an employee’s assignment or a contingent worker’s assignment, call one
of the following APIs:
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File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peasgapi.pkh hr_assignment_
api

update_emp_asg p_effective_date
must be set to
the system date.
p_datetrack_
update_mode
must be set to
CORRECTION.
When trying
to perform a
correction to
an employee’s
supervisor, the
new supervisor
must exist for the
entire duration of
the employee’s
assignment.
If you want
to assign a
supervisor who
does not exist
for the entire
duration of the
assignment, then
you can do
this using the
Enter Employee
window.

p_effective_date
p_datetrack_
update_mode
p_validate p_
assignment_id
p_supervisor_
id p_object_
version_number
p_assignment_
number p_
default_code_
comb_id p_
set_of_books_
id p_title p_
ass_attribute_
category p_ass_
attribute1-30

peasgapi.pkh hr_assignment_
api

update_emp_
asg_criteria

p_effective_date
must be set to
the system date.
p_datetrack_
update_mode
must be set to
CORRECTION.

p_effective_date
p_datetrack_
update_mode
p_validate p_
assignment_
id p_object_
version_number
p_position_id
p_job_id p_
organization_id
p_location_id
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File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peasgapi.pkh hr_assignment_
api

update_cwk_asg p_effective_date
must be set to
the system date.
p_datetrack_
update_mode
must be set to
CORRECTION.

p_effective_date
p_datetrack_
update_mode
p_validate p_
assignment_
id p_object_
version_number
p_assignment_
number p_
supervisor_
id p_title p_
set_of_books_
id p_vendor_
id p_vendor_
employee_
number p_
manager_flag
p_employment_
category p_
ass_attribute_
category p_ass_
attribute1-30

peasgapi.pkh hr_assignment_
api

update_cwk_
asg_criteria

p_effective_date
must be set to
the system date.
p_datetrack_
update_mode
must be set to
CORRECTION.

p_effective_date
p_datetrack_
update_mode
p_validate p_
assignment_
id p_object_
version_number
p_position_id
p_job_id p_
organization_id
p_location_id

hr_position_api

To update a position call the following API. Note that there are two position APIs, one
for full HRMS users and one for HR Foundation users. Refer to the comments in
peposapi.pkh for details about these APIs.

File Name Package Name Business
Process

Special
Instructions

Available
Parameters

peposapi.pkh hr_position_api create_position
update_position
delete_position

None You can use all
of the parameters
in the version of
this API that is
specifically for
HR Foundation
users.

hr_competence_element_api

To create, update and delete personal competencies call one of the following APIs:
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File Name Package Name Business
Process

Special
Instructions

Available
Parameters

pecelapi.pkh hr_competence_
element_api

create_
competence_
element

p_effective_date
must be set to the
system date. p_
type must be set
to PERSONAL.

p_effective_
date p_type
p_validate p_
business_group
p_competence_
id p_proficiency_
level p_rating_
level p_person_
id p_effective_
date_from p_
effective_date_to
p_source_of_
proficiency_
level p_
certification_date
p_certification_
method p_next_
certification_date
p_comments
p_attribute_
category p_
attribute1 - 20
p_party_id

pecelapi.pkh hr_competence_
element_api

update_
competence_
element

p_effective_date
must be set to the
system date.

p_effective_date
p_competence_
element_id p_
object_version_
number p_
validate p_
proficiency_
level p_rating_
level p_effective_
date_from p_
effective_date_to
p_source_of_
proficiency_
level p_
certification_date
p_certification_
method p_next_
certification_date
p_comments
p_attribute_
category p_
attribute1 - 20
p_party_id
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File Name Package Name Business
Process

Special
Instructions

Available
Parameters

pecelapi.pkh hr_competence_
element_api

update_
personal_comp_
element

p_effective_date
must be set
to the system
date. This API
automatically
maintains an
historical record
of the old
competence
profile entry if
the effective date
and proficiency
level have
changed. The
old competence
profile entry is
end dated and a
new competence
profile record is
created.

p_effective_date
p_competence_
element_id p_
object_version_
number p_
validate p_
proficiency_
level p_effective_
date_from p_
effective_date_to
p_source_of_
proficiency_
level p_
certification_date
p_certification_
method p_next_
certification_date
p_comments
p_attribute_
category p_
attribute1 - 20

pecelapi.pkh hr_competence_
element_api

delete_
competence_
element

None p_competence_
element_id p_
object_version_
number p_
validate
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Info Online Links to Information Provider Websites

Info Online Links to Information Provider Websites
Oracle HRMS provides the capability to enable context-sensitive links between Oracle
HRMS windows and web pages, and information provider websites. Once the links
have been enabled, users can access an information provider website directly from a
button or link on an Oracle HRMS window or self-service web page. Depending on
the level of configuration available, the link can lead directly to a page relevant to the
window or even the record on which the user is working.

For example, someone entering tax information might access a website providing
up-to-date information on tax regulations, or an administrator looking at benefit details
for an employee could open a web page providing documentation for that employee’s
benefit plan.

Note: Info Online was previously known as the Knowledge Integrator.

Accessing Information Provider Websites
There are two supported versions of Info Online. The system administrator sets the
version to use in the HR: KI Framework Version profile. The default value for this
profile is Version 1.

If the system administrator sets the profile to Version 1, users can access:

• RIA (Research Institute of America) through the user interface for some payroll forms

• Authoria, a provider of health insurance and compensation information, through
links on some Benefits self-service web pages

• Metalink, Oracle’s support website, though the Info Online button from the user
interface

If the system administrator sets the profile to Version 2, users can access:

• Metalink on self-service web pages in which the content container has been included

• Transcentive through the Tools menu from the user interface

• iLearning through the content container on Rapid Implementation Workbench
self-service web pages

In both versions, login to the information provider website is usually handled
automatically when the user logs into Oracle HRMS.

Once the system administrator has enabled the links between Oracle HRMS and the
information provider pages, users access information provider websites from the user
interface by clicking the Info Online button on the Oracle HRMS toolbar, or by selecting
Tools > Info Online from the menu (Shift+Control+F7). This button is enabled in
windows for which information provider links have been configured and enabled.

Note: Shift+Control+F7 is the key sequence currently mapped to
Function 7. Choose Help -> Keyboard on the menu to determine the
actual key combination. The Oracle Forms Deployment Guide explains
how to change this key assignment in the Oracle Terminal resource file
fmrweb.res.
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Choosing the Info Online button first opens a list of values, displaying a list of links to
any information provider websites that are enabled for the current window. When the
user selects a value from the list, a browser window opens at the appropriate page.

If the user chooses the Info Online button from a window for which no links to
information provider websites are enabled, no list of values appears.

Users can control the behavior of the Info Online button using the Open in New Window
option on the Tools menu. When this option is checked, each new search opens in a new
browser window. This option allows users to compare results from different queries side
by side, but the windows remain open until the user specifically closes them. When this
option is unchecked, the page appears in the last browser window opened.

Users access information provider websites from the self-service web pages either
through links on Benefits pages or through the content container. The list of applicable
topics and providers appear alphabetically in the content container. See: Info Online
Content Container, page 3-243

Profile Options
You must set the following profile options to set up links between Oracle HRMS and any
information provider websites:

• HR: KI Framework Version

• HR: Extension Agent Enabled

• HR: Extension Agent Client Timeout

Setting the following additional profile options is optional if you are setting up links
between Oracle HRMS and any information provider websites:

• HR: Extension Agent

• HR: Info Online: Open in New Window

• HR: Info Online: Toolbar Icon

• HR: KI Maximum Topics and Integrations

• HR: Servlet Timeout

Additional required and optional profile options exist for individual information
providers. See: User Profiles, page 1-49

Information Providers
Integration is available between Oracle HRMS and the following information providers:

Oracle MetaLink

Oracle’s MetaLink website provides access to the latest product information, discussion
forums, bug fixes, and patch information for Oracle HRMS, as well as enabling users to
contact Oracle Support. Integration is available for all Oracle HRMS windows in the
user interface in KI Framework Version 1 and for self-service web pages which include
the content container in KI Framework Version 2. This integration is available for all
legislations.

See MetaLink Note 229585.1 for details of how to set up links from Oracle HRMS to
MetaLink pages.
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Authoria HR

Integration is available between a number of Oracle Advanced Benefits windows and
self-service pages and the third-party product Authoria HR in KI Framework Version
1. This integration is available for UK and US legislations. See: Links to Authoria
HR, page 3-244

Also see MetaLink Note 215637.1 for details of how to set up links from Oracle HRMS
to Authoria HR pages.

RIA PCP on Checkpoint

Integration is available between Oracle HRMS US tax windows and third-party
information provider RIA’s Payroll Compliance Pro on Checkpoint in KI Framework
Version 1. This integration is available for US legislations.

See MetaLink Note 148468.1 for further details of how to set up links from Oracle
HRMS to RIA PCP on Checkpoint.

Transcentive

Integration is available between Oracle HRMS windows and Transcentive, a third-party
compensation management solutions provider, in KI Framework Version 2. This
integration is available for all legislations.

See MetaLink Note 276574.1 for further details of how to set up links from Oracle
HRMS to Transcentive.

iLearning

Oracle iLearning is an enterprise learning management system that prescribes, delivers
and tracks learning, and monitors and manages the learning process. Integration
is available between the Rapid Implementation Workbench web pages and Oracle
iLearning in KI Framework Version 2.

See MetaLink Note 276807.1 for further details of how to set up links from the Rapid
Implementation Workbench web pages to Oracle iLearning.

Info Online Content Container
The Info Online content container is an ancillary region that appears on self-service
web pages. Topics and providers appear as an alphabetical list of links in the content
container.

On clicking a topic, the list of providers who provide content for the topic appears in a
new window. If only one provider exists for the selected topic, the single provider’s
page opens immediately.

Users can also select a provider from the list in the content container, and view a list of
topics offered by that provider.

The More link appears when the number of topics or providers exceeds a predefined
limit. The limit of topics or providers is set in the HR: KI Maximum Topics and
Integrations profile. If no limit is set, the More link appears when the number of topics or
providers exceeds 3. On clicking the More link from the topics or providers region, the
complete set of topics or providers appears in a new page.
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Info Online Links to Authoria HR
Authoria HR uses a common knowledge repository to manage and communicate HR
and benefits information. You can configure context-sensitive access between Oracle
HRMS and Authoria HR. End users can follow links from the user interface windows
and self-service pages to display Authoria HR documentation directly related to the
record they are working with.

This feature is available for US and UK legislations.

Note: Info Online was previously known as the Knowledge Integrator.

Links from Oracle Windows and Self-Service Pages
Integration with Authoria HR is enabled for the following Oracle Standard and
Advanced Benefits windows:

• View Enrollment Results window (BENDSPER)

• View Participation Information window (BENDISPL)

• Flex Program window (BENEFXEB)

• Non-Flex Program window (BENENFEB)

• Savings Plan window (BENESPEB)

• Miscellaneous Plan window (BENEMSEB)

• Person Life Events window (BENDSPLE)

Integration is also enabled for the following self-service pages:

• Benefits Enrollment Overview page (BEN_ENRL_OVERVIEW_PAGE)

• Current Benefits page (BEN_CURR_OVW_PAGE)

• Confirmation page (BEN_ENRL_CONF_PAGE)

• Benefits Selection page (BEN_ENRT_SELECTION_PAGE)

Accessing Authoria HR
Access to Authoria HR is available in user interface windows from the Info Online
button on the toolbar or the Info Online option on the Tools menu (Shift+Control+F7).

When a user chooses the Info Online button in one of the windows in which the feature is
enabled, a list of values appears, listing the pages in the Authoria HR system applicable
to the current context. If other Information Provider links have been enabled, these are
also displayed. When the user selects an Authoria link from the list of values, a browser
window opens at the appropriate Authoria HR page.

Users can control the behavior of the Info Online button using the Open in New
Window option on the Tools menu. When this option is checked, each new search
opens in a new browser window. This allows users to compare results from different
queries side by side, but they must close each window when finished. When this
option is unchecked, the the last browser window that was opened is used to display
the Authoria HR page.

From the self-service interface, access to Authoria HR is via hypertext links in the
Oracle Standard and Advanced Benefits pages. The links appear only when there is a
mapping between the page and a page in the Authoria HR system. When a user clicks
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on a link, a new browser window opens and displays the page from the Authoria HR
system applicable to the current context.

See: Configuring Links Between Oracle HRMS and Authoria HR, page 3-247

Example SQL Script to Populate Mapping Table
This example script configures links between Oracle benefit plans and programs and
Authoria HR pages. See Configuring Mappings Between Oracle and Authoria HR, page
3-248 for information on how to configure this script for your own use.

The script assumes that there are no mappings stored in the table to begin with. The
mappings are business group-specific. Each plan/program combination results in two
mappings, one for open enrollment and the other for non-open enrollment. The open
enrollment mapping is typically to a common open enrollment page.

The script shows the following four mappings:

• A plan named ’ACME Dental NonFlex’ exists in the program ’ACME Program
NonFlex’. This is mapped to the Authoria page ’AnnEnroll’ during open
enrollment, and at other times to the page ’Dental’. This results in the procedure
call for non-open enrollment:

create_page_map(’ACME Dental NonFlex’,’ACME Program Non Flex’,
’N’,’Dental’,l_business_group_id);

• and for open enrollment:

create_page_map(’ACME Dental NonFlex’,’ACME Program Non Flex’,
’Y’,’AnnEnroll’,l_business_group_id);

• A plan ’Saving Plan’, that is not in a program, is mapped to the Authoria page
’AnnEnroll’ during open enrollment, and at other times to the page ’Sav’. This
results in the procedure call for non-open enrollment:

create_page_map(’Saving Plan’,NULL,
’N’,’Sav’,l_business_group_id);

• and for open enrollment:

create_page_map(’Saving Plan’,NULL,
’Y’,’AnnEnroll’,l_business_group_id);

Example Script

REM +=============================================== +
REM SQL Script File Name : create_page_map.sql
REM Description: Seed Authoria page mappings via APIs
REM +=============================================== +
declare
l_business_group_id number;
procedure create_page_map

(p_plan_name in varchar2
,p_program_name in varchar2

,p_open_enrollment_flag in varchar2
,p_target_page in varchar2

,p_business_group_id in number
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) is
--
l_authoria_mapping_id number;
l_object_version_number number;
l_plip_id number := null;
l_pl_id number;
l_pgm_id number := null;
-- value -924926578 represents a number unlikely to
-- exist in the database
cursor csr_exists is

select authoria_mapping_id,
object_version_number

from hr_authoria_mappings
where pl_id = l_pl_id

and nvl(plip_id,-924926578) = nvl(l_plip_id,-924926578 )
and open_enrollment_flag = p_open_enrollment_flag;

begin
-- get pl_id
select pl_id
into l_pl_id
from ben_pl_f
where sysdate between effective_start_date

and effective_end_date
and name = p_plan_name
and business_group_id = p_business_group_id;
if (p_program_name is not null) then

-- get pgm_id
select pgm_id
into l_pgm_id
from ben_pgm_f

where sysdate between effective_start_date
and effective_end_date

and name = p_program_name
and business_group_id = p_business_group_id;

select plip_id
-- get plip_id
into l_plip_id

from ben_plip_f
where sysdate between effective_start_date

and effective_end_date
and pl_id = l_pl_id
and pgm_id = l_pgm_id

and business_group_id = p_business_group_id;
end if;
-- see if there is an existing record
open csr_exists;
fetch csr_exists into l_authoria_mapping_id

,l_object_version_number;
if csr_exists%found then

-- do update
HR_AUTHORIA_MAPPING_API.update_authoria_mapping

(
p_authoria_mapping_id => l_authoria_mapping_id
,p_pl_id => l_pl_id
,p_plip_id => l_plip_id

,p_open_enrollment_flag => p_open_enrollment_flag
,p_target_page => p_target_page

,p_object_version_number => l_object_version_number
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);
else

-- do insert
HR_AUTHORIA_MAPPING_API.create_authoria_mapping

(
p_pl_id => l_pl_id

,p_plip_id => l_plip_id
,p_open_enrollment_flag => p_open_enrollment_flag
,p_target_page => p_target_page
,p_authoria_mapping_id => l_authoria_mapping_id
,p_object_version_number => l_object_version_number

end if;
);

close csr_exists;
end;
--
BEGIN
--
select business_group_id
into l_business_group_id
from per_business_groups
where name = ’SC Benefits’;
create_page_map(’ACME Dental NonFlex’,’ACME Program Non Flex’,

’N’,’Dental’,l_business_group_id);
create_page_map(’ACME Dental NonFlex’,’ACME Program Non Flex’,

’Y’,’AnnEnroll’,l_business_group_id);
create_page_map(’Saving Plan’,NULL,

’N’,’Sav’,l_business_group_id);
create_page_map(’Saving Plan’,NULL,

’Y’,’AnnEnroll’,l_business_group_id);
--
END;
/
COMMIT;
EXIT;

Configuring Links Between Oracle Standard and Advanced Benefits and
Authoria HR

You can configure links between Oracle Standard and Advanced Benefits windows and
self-service pages and Authoria HR. See: Info Online Links to Authoria HR, page 3-244

To Configure Links Between Oracle Standard and Advanced Ben efits
and Authoria HR:
1. You must first install the required versions of Oracle HRMS and Authoria HR. For

further details on installation and implementation, see Metalink Note 215637.1.

2. Ensure that the following profile options are set:

• HR: Extension Agent Enabled

• HR: Authoria Integration Enabled

• HR: Authoria US URL and/or HR: Authoria UK URL
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3. Check the following optional profile options to see whether you should set them
for your system:

• HR: Extension Agent

• HR: Info Online: Open in New Window

• HR: Info Online: Toolbar Icon

For further details of profile options, see: User Profiles, page 1-49

4. Set up your Oracle benefit plans and programs.

5. Set up your Authoria HR benefit plans. For further details, see your Authoria HR
documentation.

6. Configure mappings between Oracle and Authoria HR, page 3-248

Configuring Mappings between Oracle and Authoria HR
Before users can access Authoria HR pages from Oracle HRMS windows or self-service
web pages, you must configure the mappings between your Oracle HRMS benefits and
the pages you have set up in Authoria HR.

To Configure Mappings:
1. Identify the pages in Authoria HR that you want to link to each of your Oracle

benefit plans and programs.

2. Edit the following select statement in the example SQL script, page 3-245 to include
the appropriate business group by replacing "SC Benefits" with the required business
group name:

select business_group_id
into l_business_group_id
from per_business_groups
where name = ’SC Benefits’;

3. For each mapping, add a create_page_map procedure, replacing the example
create_page_map procedure lines. Add a separate line for each mapping.

The create_page_map procedure takes the following arguments:
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Mapping Arguments

Procedure Description

p_plan_name the name of the benefits plan

p_program_name the name of the benefits program (null if the
plan is not in a program)

p_open_enrollment_flag indicates whether the page mapped to is for
open enrollment. Allowed values are Y or N.

p_target_page the name of the target page in the Authoria
application

p_business_group_id the business group id, as determined using
the select statement

4. Run the SQL script.

The script calls the HR_AUTHORIA_MAPPING API, which saves the mappings in
the Oracle database table HR_AUTHORIA_MAPPINGS.
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Link Windows (Task Flow)

Task Flow
You can link windows used to complete tasks in a task flow. Then, you can choose a
button to bring up each window in turn without returning to the menu.

The first window in the task flow defines the context of the subsequent windows. For
example, if the task flow begins with the People window, all subsequent information is
entered for the person you enter or query in the People window.

You can include configured windows in task flows. For example, you might create a
version of the People window that handles applicants only. You could then use this
window in a recruitment task flow. Or you might configure a People Management
template and add task flow buttons to provide access to other windows.

Using Forms or Workflow
There are two methods you can use to create and maintain your task flows:

• Using Forms, page 3-256

• Using Oracle Workflow, page 3-255

You can model your task flows using Oracle Workflow (version 2.0.3.8.1 or higher) then
generate a task flow. This method of creating task flows has the advantage of using a
diagrammer to help you design the sequence of windows.

Caution: Do not use apostrophes or "%" symbols in task flow names or
task flow node names.

Sequential or Branched Structure
Task flows can follow a sequential or a branched structure, as shown in the following
two figures. You can choose how many navigation options users have from each
window in the task flow. You can also choose the labels that appear on the navigation
buttons, and you can define access keys.

Sequential Task Flow
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Branched Task Flow

Predefined Task Flows
Oracle HRMS supplies several predefined task flows that include all the windows
that you can use in task flows. They are designed as a simple structure to use during
implementation, not as a recommended structure for users.

Predefined task flows are translated into your base language when you install Oracle
HRMS. However, if you install an additional language, you need to create new versions
of your task flows in that language. You can then link these to the correct menu for
the language.

When you install a new version of Oracle HRMS, any changes you have made to the
standard task flows supplied by Oracle are removed.

Important: If you have made any changes to standard task flows, you
will need to recreate them in each new version of the software. It is
therefore recommended that if you wish to make changes to task
flows, you do so by copying a standard task flow and making changes
to the copy.

Transferring Task Flows Between Databases
You can transfer a task flow you have created using Forms or Workflow from one
database to another; for example, to add new task flows you have created in a test
database into your production database. You do this by saving the task flow from the
first database to a file, then importing the file to the second database. See Transferring
Task Flows, page 3-264.

Legislation-specific Task Flows
When installing Oracle HRMS, you can install only global task flows and task flows
specific to the legislation you have installed.

Note: This does not include US- and UK-specific task flows, which
are installed with all legislations.

When defining a new task flow, you must specify that the task flow is global or that it is
specific to a legislation you have installed.
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See Defining Task Flows, page 3-257

Note: Task flows created by converting from Oracle Workflow are
always global.

When downloading task flows, you can download only global task flows and task flows
specific to the legislation(s) you have installed.

See Transferring Task Flows Between Databases, page 3-264

Task Flow Windows
You can create your own task flows by referencing the windows listed in the table
below, or configured versions of them. Some of these windows require the context of
an assignment. This means that one of the following windows must appear above
them in the task flow:

• Assignment window

• Assignments Folder window

• Application window (for applicant assignments)

• a People Management template window that identifies assignments

All task flows must begin with one of the following windows:

• A Maintenance window created from a People Management template

• People and Assignment (PERWSHRG)

• People (PERWSEPI)

• People Folder (PERWSFPE)

• Assignments Folder (PERWSFAS)

• Assignment (PERWSEMA)

• Job (PERWSDJT)

• Position (HRWSPSF)

• Position (non HRMS users) (PERWSDPO)

• Location (PERWSLOC)

• Collective Agreements (PERWSDCA)

• Tax Balance (PAYUSTBA)

Note: If you are not using People Management templates, use the
combined People and Assignment form (PERWSHRG), rather than the
separate forms (PERWSEPI and PERWSEMA), to allow the Assignment
window to open more quickly from the People window. We recommend
that you use the combined form in any task flow that requires both
windows. The predefined task flows use the combined form.
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Windows You Can Use in Task Flows

Window Context Required

Absence Detail Person (employee)

Address Person

Adjust Balances (Oracle Payroll) Assignment (employee)

Agreement and Grade Results Assignment (employee)

Applicant Interview Assignment (applicant)

Application Person (applicant)

Assignment Person (employee)

Assignment Budget Values Assignment

Assignments Folder None

Assignment Rates Assignment (contingent worker)

Belgian Tax Information (Belgian legislation
only)

Assignment (employee)

Beneficiaries (US legislation only) Element entry

Book Events Person (employee or applicant)

COBRA (US legislation only) Assignment (employee)

Competence Profile Person

Contact Person

Contract Person

Costing Assignment (employee)

Covered Dependents (US legislation only) Element entry

Disability (global and selected legislations) Person

Element Entries Assignment (employee)

Employee Review Assignment (employee)

Employee Tax Rules (US Oracle Payroll) Assignment (employee)

Employment Declaration (Australian
legislation only)

Assignment (employee)

End Placement Person (contingent worker)
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Window Context Required

External/Manual Payments (Oracle Payroll) Assignment (employee)

Extra Assignment Information Assignment (employee or applicant)

Extra Job Information Job

Extra Location Information Location

Extra Person Information Person (employee or applicant)

Extra Position Information Position

Grade Step Placement Assignment (employee)

Medical Assessment (global and selected
legislations)

Person

P45 (UK Oracle Payroll) Assignment (employee)

People Folder None

People None

People Management template Maintenance
window

None

Performance Assignment (employee)

Personal Payment Method Assignment (employee)

Phone Numbers Person

Picture Person

Position None

Position Occupancy Position

Qualifications Person

QuickPay (Oracle Payroll) Assignment (employee)

Reverse Payroll Run (Oracle Payroll) Assignment (employee)

Salary Administration Assignment (employee)

Salary History Assignment (employee)

Schools and Colleges (Establishment
Attendances)

Person

Secondary Statuses Assignment

SOE Report (UK Oracle Payroll) Assignment (employee)
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Window Context Required

Special Information Person

Statement of Earnings (Australian and New
Zealand legislations)

Assignment (employee)

Statutory Details (UK Oracle Payroll) Assignment (employee)

Terminate Person (employee)

Terminate Applicant Person (applicant)

View Element Entry History Assignment (employee)

View Employee Accruals (US legislation only) Assignment (employee)

View Employee Benefits (US legislation only) Assignment (employee)

View Employee Earnings & Deduction
Balances (US Oracle Payroll)

Assignment (employee)

View Employee Tax Balances (US Oracle
Payroll)

Assignment (employee)

View SOE (US Oracle Payroll) Assignment (employee)

Work Choices (Job or Position) Job or Position

Work Choices (Person) Person

Work Incident (global and selected legislations) Person

Including the Assignment Window
When users move down a task flow from the combined People and Assignment
form, the Assignment window remains visible in the background. They can return to the
Assignment window by closing their current window. Therefore you should not define a
button to call the Assignment window.

However, if you are defining a task flow to the Assignment window from any window
except the People window, you should use the Assignment form (PERWSEMA). In this
case you can add an Assignment button to any forms below the Assignment window in
the task flow. This enables users to return to the Assignment window without going
back to the top window.

Task Flow (Oracle Workflow)
As an alternative to using forms to set up and maintain task flows, you can model your
task flows using Oracle Workflow (version 2.0.3.8.1 or higher) then generate a task
flow. This method of creating task flows has the advantage of using a diagrammer to
help you design the sequence of windows.
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Note: When you create a task flow using Oracle Workflow, you must
continue to maintain it using Oracle Workflow. You cannot edit a
generated task flow using the Define Task Flow form.

Oracle HRMS supplies the HR Task Flow item type and a function activity for every
window that can be task flowed. You model these into a workflow process for each task
flow. By setting activity attributes, you create button labels and the position of buttons
on each window.

Key Rules
There are two key rules in defining task flows:

• Only certain windows are valid first windows (or top nodes) in a task flow. To check
which windows are valid first windows, check the lookup types using Oracle
Workflow Designer.

When you create a workflow process to model your task flow, your Start activity
must connect to the Top Node Selector activity. This activity ensures that your
first window is valid.

• Each window in a task flow can only be connected to a window that supplies the
correct context.

For example, the Position Occupancy window requires the context of a
position, while the Qualifications window requires the context of a person. Each
workflow activity supplied for a window has its Result Type set to a lookup type
that defines the context that must be passed to it. For example, the F4 Enter Address
window has the Result Type set to Person Context Windows. This means it must be
given the context of a person.

Task flows are associated with one of the following contexts:

• Assignment

• Element Entry

• Job

• Location

• Request for Personnel Action (US Federal HR)

• People

• Position Description (US Federal HR)

• Position

• Top node HRMS windows

Creating Task Flows Using Forms
Complete the following steps to create task flows using forms:

1. Define Task Flow Nodes, page 3-257

2. Define Task Flows, page 3-257

You can also complete these optional steps, if required:
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3. Copy an Existing Task Flow, page 3-259

4. Add a New Window to an Existing Task Flow, page 3-259

5. Amend the Navigation of a Task Flow, page 3-259

Defining Task Flow Nodes
Each form in a task flow is a node. There are predefined nodes for every form that
you can include in a task flow. However, if you create a configured version of one of
these forms, you must create a node for the configured version before you can include
it in a task flow.

Tip: If you want to use a configured form as the first node in a task flow
you should define this as a new node.

You could add both the task flow and the configured form as arguments
to a single menu function but this may be more difficult to maintain.

You create nodes in the Define Task Flow Nodes window.

To create a task flow node:
1. Enter a name for the node. You select this name when you create a task flow

containing the node. It is not visible to users.

Caution: Do not use apostrophes or "%" symbols in the node name.

2. Select the name of the form that you configured. Leave the Block field blank.

3. Select the name of the configured version of the form that you created.

4. Save the new node.

Defining Task Flows
You define task flows in the Define Task Flow window. If there is a similar existing task
flow, you can copy it to form the basis of your new flow.

Tip: When defining the navigation buttons in your task flows:

• Do not define long sequences where you cannot go back to the
previous step

• Use the same button names for the same nodes

• Use different button names for configured nodes

Before you can include the task flow in a menu, you must define a new
menu function for the first form in the task flow with the following
argument in the Parameters field:

WORKFLOW_NAME = "task flow name"

To define a new task flow:
1. Enter a name for the task flow and save it.

Caution: Do not use apostrophes or "%" symbols in task flow names.

Extending Oracle HRMS 3-257



Note: Do not choose the Convert button. This is provided only for
converting task flows you created in Oracle Workflow. See: Creating
Task Flows Using Workflow, page 3-260

2. Select a legislation for the task flow from the list of values, or leave the legislation
field blank to create a global task flow.

3. In the Node block, select the name of the node that you want to be the first form
in the task flow.

4. For this node, select the Top Node check box.

5. Create a new record in the Node block and select another node. You must create
all the nodes for the task flow before you can begin entering the navigation paths
between them.

6. In the Navigation Options region, for each node, select the other nodes to which
you can navigate.

7. Enter a sequence number to determine the order in which the navigation options
appear as buttons (from left to right) along the base of the window or as options in a
navigation list.

8. Select the Button check box for the navigation options that should appear as
buttons. There is a limit on the number of buttons that can appear on each form. This
number varies from form to form.

The other options are displayed in a navigation list when the user chooses a button
labelled Others. Or, if there is only one other option, this form displays when the
user chooses a button labelled Next.

9. There is a default label that appears on buttons or in the navigation list for every
form. You can override this with your own label.

If the label in the Define Task Flow window appears blue, this is the default value. It
is a dynamic default: if the seeded value changes (for example, as the result of an
upgrade), the label will be updated automatically in all task flows where it has
not been overridden.

If the label appears black, the default value has been overridden. To re-inherit the
default label, clear the field.

10. To define an access key (or keyboard shortcut) for a navigation option, precede
the appropriate letter in the label with an ampersand (&). For example, to use
ALT+P (in the Microsoft Windows environment) as the access key for the Picture
window, enter the label &Picture.

Note: Do not use the following letters, as they are used on the
Oracle Applications menu: A, E, F, G, H, Q, S, W.

There is no validation to prevent the same letter being used more than once for a
group of buttons.

11. Save the task flow.
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Copying an Existing Task Flow

To copy an existing task flow:
1. Query the existing flow and choose the Copy To button.

2. Enter the name of the new task flow and choose OK.

3. Query your new task flow and edit it as required.

Adding a New Window to an Existing Task Flow
You can use the Define Task Flow window to add a new window, using its node name, to
an existing task flow. If you have already used the window in the task flow you only
have to amend the navigation, see: Amending the Navigation of a Task Flow, page 3-259

Note: If you have created a task flow using Oracle Workflow, you must
continue to maintain it using Oracle Workflow. You cannot edit a
generated task flow using the Define Task Flow window.

To add a new window to an existing task flow:
1. Query the task flow you want to amend in the Name field.

2. In the Node block, enter the window’s node name.

3. Save your changes.

You must now include the node in the navigation path for the task flow.

4. Select the existing node you want the new node to be accessed from in the Node
block.

5. Enter the new node‘s details in the Navigation Options region and edit the existing
navigation path as required. For information about how to set up the Navigation
Options region refer to steps 5 to 9 in "To define a new task flow", page 3-257.

Amending the Navigation of a Task Flow
Use the Define Task Flow window to amend the navigation of a task flow.

To amend the navigation of a task flow:
1. Query the task flow for which you want to amend the navigation in the Name field.

2. Select the node name in the Node block.

3. Edit the existing navigation path in the Navigation Options region, as required. For
information on the Navigation Options refer to steps 5 to 9 in To define a new
task flow, page 3-257.

Generating a Task Flow From Oracle Workflow
After modeling a task flow in Oracle Workflow and saving it to the database, you must
generate task flow definitions.

Use the Define Task Flow window from the HRMS application.
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To generate a task flow from Oracle Workflow:
1. Query the task flow(s) you have created and choose the Convert button.

2. Choose OK to convert the task flows from Oracle Workflow.

Oracle HRMS indicates how many task flows have been successfully converted. If
any task flows have not been converted, these are identified and are not saved to
the database. You must correct the errors then verify, save and regenerate the
task flows again.

Note: Having modeled a task flow in Oracle Workflow, you cannot
edit it using the Define Task Flow window. You must make any
edits using Oracle Workflow, save it and then regenerate the task
flow definitions.

Creating Task Flows Using Workflow
Complete the following steps to create task flows using Oracle Workflow:

1. Create a Top Level Process, page 3-260

2. Create Sub Processes, page 3-261

3. Create Button Labels, page 3-262

4. Position Button Display, page 3-263

Combined People and Assignment Form Only

If you are creating task flows using the combined People and Assignment form, you
have an additional step to perform:

5. Identify Windows or Blocks to Display, page 3-263

Configured Versions of Forms Only

If you have created a configured version of a form, you have an additional step
to perform:

6. Identify Configured Forms to Include in the Task Flow, page 3-264

All Forms

7. Verify and Save the Workflow, page 3-264

8. Generate a Task Flow From Oracle Workflow, page 3-259

Creating a Top Level Process
You must define a top level process for each task flow. The top level process can contain
sub processes, but not any other top level processes.

A top level process must have a Top Node Selector activity. This ensures that the first
window in a task flow is a valid top node window. All windows that can be a top node
are defined within the Top Node HRMS Context Windows lookup type.

The Top Node Selector must have two transitions. The first transition must go to the Top
Node activity and its value must be the window activity name. The second transition
must be <Default> and go to the end activity.
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You use the Process Diagrammers within Oracle Workflow to create your task flows. You
do this by adding and connecting the windows you want to appear.

To create a top level process:
1. Enter a unique internal and display name for the new process for the HR Task

flow item type.

Tip: Use a naming convention for Internal and Display names. For
example, a good internal name might be POSITION_DETAILS_TL
with a Display name of Position Details (Top Level).

2. Define the process as runnable.

3. Open the Process Diagrammer window and add one Start activity and at least
one End activity.

4. Add a Top Node Selector activity. The Start activity must connect to the Top Node
Selector activity.

5. Connect the Top Node Selector to the End activity with a <Default> transition
result value.

6. Add the Top Node window.

7. Connect the Top Node Selector to the Top Node window, specifying the name of this
window activity as the transition result value.

8. Connect the Top Node window to the End Activity with a <Default> transition
result value.

9. Add other windows to the process, noting the following rules:

• A window can only connect to another window where the result type is the
same (such as, both Person Context windows).

• The transition result value must be the name of the window activity you are
connecting to (for example, F4 Enter Assignment).

• Each window can only connect once to any other window.

• Each window must be connected to the Top Node window with a <Default>
transition result value.

• You can connect a window back to its parent using the <Parent> transition result
value, rather than the name of the parent window.

Creating Sub Processes
You can group a logical set of task flow windows into a sub process, which can then be
used by several top level processes. This simplifies process modelling. Each sub process
can contain other sub processes. There are two rules to note regarding sub processes:

• A sub process cannot be defined as runnable.

• When you use a sub process in another process, you must connect the sub process to
the Top Node window.
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To create sub processes:
1. Enter a unique internal and display name for the new process for the HR Task

flow item type.

Tip: Use a naming convention for Internal and Display
names. For example, a good Internal name might be
ASSIGNMENT_DETAILS_SL with a Display name of Assignment
Details (Sub Level)

2. Define the process as NOT runnable.

3. Specify a user defined result set as a Process Result Type if the sub process requires
more than one result value.

4. Open the Process Diagrammer window and add one Start activity and at least
one End activity

Because a process can have more than one result value, many End activities may
be required. At least one End activity is required to indicate that the process must
connect back to the Top Level node window.

5. Connect the Start activity to another window.

Note: The Start activity can connect to one window only.

6. Add other windows to the process, noting the following rules:

• A window can only connect to another window where the result type is the
same (such as, both Person Context windows).

• The transition result value must be the name of the window activity you are
connecting to (for example, F4 Enter Assignment).

• Each window can only connect once to any other window.

• Each window must connect to an End Activity with a <Default> transition
result value.

• You can connect a window back to its parent using the <Parent> transition result
value, rather than the name of the parent window.

Creating Button Labels
You can enter the label you want to appear on the task flowed forms, for example, Photo
(for the Picture window). Each task flow window activity has an attribute called Button
Label. Use this attribute to override the default button label for a window and to define
an access key (or keyboard shortcut).

To create button labels:
1. Display the process in the Oracle Workflow Process Diagrammer.

2. Select the activity by choosing Edit - Properties. (You can also double click on
Edit - Properties to select it).

3. Select the Attribute Values tab frame.

4. Enter the label you want to appear on the forms.
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Precede the appropriate letter in the label with an ampersand (&) to define an access
key. For example, to use ALT+P (in the Microsoft Windows environment) as the
access key for the Picture window, you could enter the label &Photo.

Positioning Button Display
You can position the display order of buttons on the form. For example, you might want
the first button to display the Picture window.

The number of task flow navigation buttons that can be displayed on a window varies
from window to window. If there are too many navigation options for them all to appear
as buttons, the last button on the window is called Other and it displays a list of values
containing the other navigation options.

You determine the navigation options available from a window by defining transitions
to other windows in the Process Diagrammer. Now you can use the activity attributes
Display Button 1..4 to specify which navigation options should display as buttons and
the order in which they should appear.

To position buttons:
1. Display the process in the Oracle Workflow Process Diagrammer.

2. Select the activity by choosing Edit - Properties. (You can also double click on
Edit - Properties to select it).

3. Select the Attribute Values tab frame.

4. Enter the name of the window you want to display on the button for the Display
Button 1 attribute.

For example, if you want the first button to display the Picture window, enter
F4 Enter Picture. If the window is the parent window then you can specify the
<Parent> special connection value.

5. Repeat step 4 for the attributes Display Button 2 .. 4. If you do not want a button to
appear on the window, enter the value <Null>.

For example, if you only want three buttons to be displayed, enter <Null> as the
value for Display Button 4.

Identifying Windows or Blocks to Display
For most task flow forms, you must display the first block of the form on
entry. However, when you use the Combined People and Assignment form in a
task flow, you must specify whether to display the People window (or block) or the
Assignment window on entry.

To identify windows or blocks to display:
1. Display the process in the Oracle Workflow Process Diagrammer,

2. Select the window activity by choosing Edit - Properties. (You can also double
click on Edit - Properties to select it).

3. Select the Attribute Values tab frame.

4. Enter the name of the block you want to display on entry for the Block Name
attribute.
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Identifying Configured Forms to Include in the Task Flow
If you have created a configured version of a window, you can use it in a task flow.

To identify configured forms to include in the task flow:
1. Display the process in the Oracle Workflow Process Diagrammer.

2. Select the window activity by choosing Edit - Properties. (You can also double
click on Edit - Properties to select it).

3. Select the Attribute Values tab frame.

4. Enter the name of your Form Customization for the Customization attribute.

Verifying and Saving the Workflow
When you have completed the task flow definition within Oracle Workflow, use the
Workflow Verify function to check that your workflow conforms to Oracle Workflow
modeling rules.

When you have successfully verified the Workflow, save it to the HRMS database.

To verify and save the Workflow:
1. Choose File - Verify.

Note: This process does not check that you have created a valid task
flow. This check is done when you generate the task flow.

2. Choose File - Save.

Transferring Task Flows Between Databases
You can transfer a task flow you have created in one database (using either Forms or
Workflow) into another database; for example, to add a task flow created in a test
database to a live database. You do this by exporting the task flow information from the
first database to a flat file which you can then import to the second database.

You do this using the Submit Request window.

Important: Before transferring task flows into a database, you must
ensure that all windows used by the task flow are present in the
database. This includes any versions of windows that you have
configured using CustomForm or the People Management Configurator.

To export a task flow to a file:
1. Log in to the source database.

2. In the Submit Request window, choose Download HRMS Taskflows from the list
of values in the Name field.

3. Enter a name for the file in which to save the task flow in the Data File parameter
field. The recommended file extension is .ldt.

Tip: To avoid having to move the file before importing it to the
target database, include the full file path of a location that is
accessible to both the source and target databases.
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4. To download a single task flow, select the task flow name from the list of values (you
can download all task flows for a legislation, or all global task flows, by leaving the
task flow field blank).

5. To download task flows for a particular legislation, select the legislation from the list
of values. To download global task flows, leave the legislation field blank.

6. Choose OK, then choose Submit, to save the task flow to a flat file.

To import a task flow from a file:
1. Log in to the target database.

2. In the Submit Request window, choose Upload HRMS Taskflows from the list
of values in the Name field.

3. Enter the name of the file containing the task flow in the Data File parameter field.

4. Choose OK, then choose Submit, to import the task flow to the database.

5. You can now use the task flow in the same way as in your original database.
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Configure Windows Using the People Management
Configurator

People Management Configurator
You can use the People Management Configurator tool (formerly called Forms
Configurator) to design windows that closely meet the business processes of your
enterprise. For example, you can design windows to contain the essential information
you need to hire a new person. This saves time, reduces errors, and makes data entry
and maintenance easier.

Predefined templates are provided with Oracle HRMS. These are examples of windows
that have been designed with specific processes in mind. The predefined People
Management templates have been created using the People Management window. The
example templates use selected items from this window. However, you can select any
item from the People Management window when you create your own windows.

See People Management Templates, page 3-268.

Why Use a Predefined Template?
You can create new windows without using a predefined template but we recommend
that you use one as a guide for the following reasons:

• The templates have been carefully designed to represent typical business processes
and show a good implementation of window design.

• It makes it easier to upgrade to new predefined templates when they become
available. When you upgrade a predefined template the system makes the necessary
core updates but leaves any changes you have made to the template in place.

What Can I Change On a Template?
When you design a new window using a template, you can:

• Choose which component windows (Summary, Find, Maintenance) of the main
window to display, and where they are positioned.

• Choose which window displays first when a user chooses the main window from
the navigator.

• Select which tabs, fields, and buttons you want displayed on each window.

• Choose where fields are positioned, on which tabs they appear, and the field tabbing
order.

• Choose to default values in fields.

• Use formulas to supply additional details about a field or button to be displayed
when a user right-clicks on the item.

• Set up context-sensitive fields such as address styles so that the appropriate fields
are displayed depending on a value chosen.

• Enable display of DateTrack History on datetracked fields.

• Define data restrictions such as Employees only, Applicants only or Contingent
Workers only.
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• Set up checklists for users to record the progress of actions. You can add values to
the predefined lookups: CHECKLIST_ITEM and CHECKLIST_STATUS.

• Create notification messages for users to send workflow notifications to other
people. Some messages are predefined.

Note: The online help reflects the predefined templates. If you configure
the forms, you might need to edit the help to reflect the changes you
make.

Additional Configuration Options For People Management Templates
A number of user extensible ’custom’ fields have been added to the People Management
templates which enable you to maintain any data that you cannot currently maintain
using the templates (either Oracle E-Business Suite data items or 3rd party/custom
data items that are stored within the database). These fields only apply to the People
Management window (PERWSQHM form) and are only available on the ’MAINTAIN’
block/window (not the summary or Find window).

You can add these custom fields to the People Management Configurator template
via the Forms Configurator option. There are a number of different types of fields to
accommodate different functional requirements. These fields are :

• Character

• Number

• Date

• Check Box

• List of Values

• List Item

These additional fields are referred to as items and they can be placed on to the
template using the People Management Configurator (see Fields on the People
Management Window, page 3-285 for further information).

When you have added the required custom items to the template, it is necessary to
use the Custom Library to write the required business rule code and logic for the
retrieval, update and validation of each custom item.

For further information please see the white paper Further Configuration Options For
People Management Templates on MetaLink.

Setting Up Task Flows To Other Windows
You can add task flow buttons to access other windows from the Maintenance window
of your configured window. Create the task flow using Oracle Workflow or the Task
Flow windows, then view the window with the buttons in the People Management
Configurator.

If you want to reposition or resize the buttons on the window, you need to add the
button items to your template using the People Management Configurator, place them in
the appropriate positions, set their size, and enter labels for them.
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People Management Configurator User Interface
The People Management Configurator tool contains a graphical navigation tree and a
set of properties. The navigation tree has been set up in a logical order so that if you
follow the tree down from the top, that is the order in which you should complete your
tasks. Expand the template name to see the information associated with the template.

You can see what your windows look like on the screen as you make edits to them. You
can also preview the windows in your template to test out the fields and tabbing and see
how they will appear to the user.

People Management Templates
The predefined People Management templates have been designed to help you create
windows that match your business processes. These templates were created from
the People Management window using the People Management Configurator. The
predefined template windows are available on the Navigator; you can use these without
making changes. Alternatively, you can make copies of the predefined templates and
modify them to create your own windows, or you can create entirely new templates.

For details of the predefined templates, see Predefined People Management Templates,
page 3-271

What Information Is Included In the Templates?
The predefined templates have been designed for generic business processes, such as
hiring a person or creating a new applicant. For example, when you go through the
hiring process, you typically have to open lots of windows to complete the task. With
a template window, all the data can be put together and grouped into logical sections
using the tabbed regions.

When an applicant is hired, assignment information from the application is automatically
entered on the employee assignment.

Designing Your Own Templates
The People Management window contains all the personal and assignment
information, such as LAST_NAME and VACANCY. You use the templates to control
what the user can see by only including what you need.

See Fields on the People Management Window, page 3-285 for a complete list of all the
fields available for you to use when creating People Management templates.

How Many Windows and Tabs Can I Design?
A template can consist of a Find window, Summary window, and Maintenance
window. You can modify each of these windows to suit your requirements. You can
design as many templates as you require, targeted at different tasks or user groups. For
example, for users who only need to review information, you design a template that
provides a Summary window. For users who need to update information, you can
provide a Maintenance window too.

When you have created a new template, you add it to the Navigator so that your users
can access the new windows. For each template, you can set up which window is
displayed first. For example, you can specify that choosing People Maintenance from the
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Navigator displays the Find window first to enable users to find a person. Then they can
navigate to the Maintenance window by choosing the Show Details button.

The Find window can contain up to six tabs. One tab has been defined as the Advanced
tab but you can use this for another purpose if you want.

The Summary window can contain up to ten tabs. One tab has been defined as the
Checklist tab but you can use this for another purpose if you want.

The Maintenance window can contain up to ten tabs, including the Extra Information
Types, and Special Information Types tabs. One tab has been defined as the Checklist tab
but you can use this for another purpose if you want.

Using Templates to Design Process Based Windows

How Do I Control What Users Can Do With a Template?
Some restrictions are made using the People Management Configurator tool, and others
using CustomForm. For example, you use the People Management Configurator to
determine the fields, buttons, tabs, and windows available. You can also restrict a
template to the Employee, Applicant or Contingent Worker system person types using
the People Management Configurator.

You can use CustomForm to:

• Specify the user person types, special information types, and extra information types
that users can view or enter

• Specify the actions that users can perform, and the notifications they can send

• Remove fields from the list available for searching on the Advanced Find tab

• Restrict the types of person record users can create using the template: new
applicants, employees, contingent workers, applications, employee assignments, or
contingent worker assignments.

Important: You must be careful to create consistent restrictions. For
example, it would not be consistent to restrict a template to Applicants
Only using the People Management Configurator, then add a
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CustomForm restriction that only allows users to enter new employees
or employee assignments.

Benefits of Using Template Windows
Templates provide the following advantages for your users:

• They can find information using the basic and advanced queries on the configurable
Find window. You specify which fields appear in this window and in what order.

• They can save result sets to folders for repeated use in future work sessions.

• They can work more quickly if you use the templates to:

• Hide information they do not need

• Provide defaults where possible

• Position fields in logical groups and on tabbed regions

• They can use the checklists to track the status of actions that you have defined
as relevant to the template.

Using templates is only one part of making Oracle HRMS specific to your enterprise. You
can also sequence windows together in task flows. You can define a Maintenance
window to be the top window and provide buttons for navigating directly to other
windows while the Maintenance window remains in the background.

People and Assignments in the Data Organizer
The Summary window of the people management templates includes the Data
Organizer, which helps you find and organize information about people and
assignments.

The Data Organizer can display people organized alphabetically by
name, organization, or job. When you expand a person’s node in the Data Organizer, you
see a list of their employee, applicant, and contingent worker assignments. Assignments
do not have names, so you can choose what information appears in this list to help users
identify the assignment they want to work with.

By default, assignments are identified as <job>.<organization>, such as Senior
Manager.Engineering. However, you can choose any other database items to display in
the Data Organizer. The same information appears in the Assignment field that you
can display on the Maintenance window.

If you want to override the default, write a formula to return the text to be
displayed. See: Writing Formulas for Templates, Oracle HRMS FastFormula User Guide

Defaulting Values in Template Fields
The templates enable you to default values in as many fields as you want. You can make
data entry easier for users by defaulting items that frequently take the same value. Where
the value is constant, you might set a default and then hide the field from users.

When an applicant is hired, assignment information from the application is automatically
entered on the employee assignment.
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Defaults from Other Windows

When you set up information for your implementation in Oracle HRMS windows, you
can specify that values in some fields are automatically defaulted by the system when
the user selects a value in another field. For example, you can set up default information
for business groups in the Organization window, so that selecting a business group
populates the fields for Location, Working Hours, Frequency, Start Time, and End
Time. You can also specify default information in many fields for a position or vacancy
in the Positions window and the Requisition and Vacancy window.

If you set defaults for these fields using People Management Configurator, they will be
overridden by the automatic defaults set up in these windows.

Defaults in Dependent Fields

Some fields are dependent on other fields, so that when the user enters a value in the
main field, they must always enter a value in the dependent field. For example, if the user
enters a value for Notice Period, they must enter or select a value for Notice Period Units.

You cannot set default values in the dependent fields.

Information on the fields that are dependent on other fields is included in the list of
Fields on the People Management Window, page 3-285

Predefined People Management Templates
Oracle supplies a number of predefined People Management templates. We recommend
that you base any new window design on one of these templates.

Note: You can create an entirely new template but there are many issues
to be aware of such as upgrading and setting up context-sensitive
address styles. Instead, we recommend that you copy a predefined
template for your localization and make any changes to that.

Templates are provided for specific localizations. There are also generic templates for you
to use if none of the predefined localization-specific templates meet your requirements.

Hiring Applicants Template
This template enables you to create windows for entering an applicant, tracking the
applicant up to the point of hire, and hiring the applicant. You can use the Hiring
Applicants window for the complete hiring process. You can access both employees
and applicants in this template. This enables you to hire applicants and to process
internal applicants.

Enter Employees Template
This template enables you to create a Maintenance window for quickly entering details
of employees, and their primary assignment. It is restricted to employees only. This
window is designed for users who have lots of employees to enter who do not need
any applicant history, for example, a one day casual hire.

You can enter basic personal details such as name, date of birth and address as well as
assignment details such as job, grade, and salary. The Notify button enables you to send
notifications about actions to other people.
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Maintain Employees Template
Use this template to create windows for entering or maintaining full employee details. It
is restricted to employees only. This is very similar to the tasks you would perform using
the People window and associated windows.

Enter Contingent Workers Template
This template enables you to create a Maintenance window for quickly entering
contingent worker details and their primary assignment. It is restricted to contingent
workers only. This window is designed for users who have lots of contingent workers
to enter.

You can enter basic personal details such as name, date of birth and address as well as
assignment details such as job, supplier, and worker number. The Notify button enables
you to send notifications about actions to other people.

Maintain Contingent Workers Template
Use this template to create windows for entering or maintaining contingent worker
details. It is restricted to contingent workers only. This is very similar to the tasks you
would perform using the People window and associated windows.

Visa Administration Template
This template enables you to create windows for entering information about foreign
workers. You can record details about an employee’s addresses, contacts and visa details.

HR Foundation Template
The HR Foundation template enables you enter and maintain contingent workers
using the HR Foundation responsibility. The HR Foundation template is restricted
to contingent workers only and is used for tasks very similar those tasks you would
perform using the entering and maintaining contingent workers templates.

Find Window Configuration
There are two parts to a Find window, and you can choose the fields that appear on each:

• Find tabs where users enter their search criteria

• Find Folder where the results of the search are summarized in a one-row-per-record
format

Find Folder
In the Find Folder, include fields that will enable users to uniquely identify the
records they need. Typically these fields are Full Name, Employee or Applicant
Number, National Identifier (such as Social Security Number) and Date of Birth.

Find Tab
Put the fields in which you expect users to search most frequently on the Details Find tab
(the tab to display first). To provide fast search results, we recommend that some of the
following fields are available for searching:
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• Last Name

• Employee Number

• Applicant Number

• National Identifier

• Full Name

Fields that have lists of values also provide good search performance.

The predefined templates include the Effective Date field on the Details tab. You can
use this field to change your effective date without using the calendar icon from the
toolbar. The effective date determines the lists of values available on fields in the Find
window and which records will be returned. If you are going to include this field on the
Find window, it is best to place it at the top of the window. This encourages users to
set their effective date first, and then select from the appropriate lists of values in the
other Find fields. You can include up to six Find tabs.

Advanced Find Tab
You can provide an Advanced Find tab (as one of the six Find tabs) for more complex
searches, such as matching ranges of values. To construct an advanced tab you need to
include the following fields, where n = 1 to 5:

• Field n Name

This field enables you to select a field on which to perform an advanced search.

• Field n Condition Code

This field defines the operator for the search, for example, not equal to, less
than, greater than.

• Field n Value

This field is the value you want to search on.

For example, you could set up the following query, find me all people whose hire date
(field name) is less than (condition code) 1-Jan-1999 (value).

You can restrict the fields that users can select in the Field n Name fields using
CustomForm. You can therefore remove the ability to search on sensitive or confidential
fields.

Security Check Box on Find Window
There is a Security check box on the Find window that defines which people are included
in a user’s search. To find people from outside your Security profile, you must ensure
that the Security check box is enabled and is unchecked. However, they will not be able
to view full information for people outside their security profile, and they will not
be able to update these records.

If you leave this box unchecked, you must be careful that no confidential information is
included in the Results of the Find. We recommend that you always check this check box.

If you do not want users to be able to change the security profile set for the template
then you should set the Security check box to the required setting and then hide it, thus
preventing users from updating it.
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Although the Security check box defines which people are included in a search, it does
not define what can be saved from the Find window into the Data Organizer, as this
is controlled by the user’s security profile. This means that if you have the check box
unchecked, your user may find that they cannot save some data that is returned in a
query into a folder as it is outside their security access. The Data Organizer is also
limited depending on the person type restrictions set up at template level.

If you delete the check box from the search criteria, the results will only display those
people from within your Security profile.

SITs, EITs and Other Flexfields in Templates
Maintenance windows in your people management templates can include tabs for
entering Special Information Types (SITs) and person and assignment Extra Information
Types (EITs).

These tabs must contain a drop down list to enable the user to select the appropriate SIT
or EIT to enter. This poplist controls the segments of the flexfield that display. In the
People Management Configurator, you select the item Special Information Type List
(Special Information), or Extra Information Type List (Extra Info), to enable this poplist.

You select which segments of the flexfield are displayed. Each segment is displayed as a
folder form column. At run time, the window displays the appropriate columns with no
gaps where segments are not displayed.

Note: You can control which SITs or EITs a user can select in the
template by creating a CustomForm restriction that you associate with
the template when you add it to a menu.

Segments Using Value Sets
Each segment item for a flexfield has two entries, one called meaning and one called
value. The value item is always required as this is where the user would enter or select
the information. The meaning item is only used where the user selects a value from a
value set. If the value set uses a short meaning and a longer description, you can include
the meaning item to display this longer description when the user selects a value.

For example, you may have a segment in a flexfield that records a country of
residence. In the value field the user may select a country short code, USA, and in the
meaning field the longer description, United States of America, would be displayed.

How Segment Properties Are Derived From Template and Flexfield Definitions
When a user selects an SIT or an EIT type from the list, the item properties for each
segment depend on the settings defined for the template and the flexfield:

• Case Restriction, Default Value, Prompt Text, Width

If these properties are set in the template, these values are used. If not, the values
set for the flexfield are used.

• Enabled, Insert Allowed, Update Allowed, Visible

If the value for these properties is set to Yes on the flexfield, and is set to Yes or blank
on the template, then these properties are set to Yes. Otherwise these properties
are set to No.

• Required
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This property is set to Yes if it is set to Yes on either the template or the
flexfield. Otherwise it is set to No.

Some of the properties rely on other properties being set to appropriate values for them
to take effect. For example, if the Required, Insert Allowed, or Update Allowed value are
set to Yes, this will only take effect if the item is enabled and visible.

Note: These rules apply to all flexfields, not just SITs and EITs.

Positioning Columns in the SIT Folder
We recommend that you place the items Date from (Special info) and Date to (Special
info) first in the folder. Then place all of the Special Information Segment n Value items
(where n is 1 to 30) onto the tab in consecutive order.

As it is a folder form, you must also include the record indicator for the multi row
block. This item is called Current Record Indicator (special info). Make its width
0.1", and make it appear just before the first Date field.

Positioning Columns in the EIT Folder
We recommend that you place all Extra Information segments onto the tab in consecutive
order. Assignment EITs are called Assignment Extra Information n Value items (where n
is 1 to 30), and person EITs are called Person Extra Information n Value items (where
n is 1 to 30).

The actual positioning of the EIT segments on the tab is not important as when the
window is accessed by a user the first populated EIT segment is displayed flush against
the current record indicator and all others are lined up against it.

As with the SIT folder, you must include the record indicator for the multi row
block. This item is called Current record indicator (Extra info). Make its width 0.1", and
make it appear just before the first EIT segment field.

Other Flexfields
You can include user-defined descriptive flexfields (DFs) and developer descriptive
flexfields (DDFs) in both the Summary and Maintenance template windows. You can
include individual flexfield segments directly in the template window in the same way
that you would add normal fields (segment properties are the same as those described
for EITs and SITs); alternatively you can include the whole flexfield in a flexfield popup
window, by selecting the Flexfield Name Popup item. If you want to include multiple
flexfields in your templates, you can include segments from some directly within the
template, and add flexfield popup windows for others; however, you cannot include
flexfield segments and a popup window for the same flexfield structure.

We recommend that you do not add too many flexfield segments directly to the template
as this will impact performance. It is better to include whole flexfields as popup
flexfield windows.

Context-Sensitive Fields In Templates
You can set up fields that are context-sensitive in your templates using the People
Management Configurator tool. For example, you might want to display the Employee
Number field when the selected person is an employee, and the Applicant Number
field for an applicant.
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You can also use this feature to display the appropriate segments of a flexfield. For
example, you set the context to display the appropriate structure of the Personal
Analysis Key Flexfield for the selected Special Information Type. You do not have to
display the full structure defined in the flexfield. You can hide segments to save space
on the template, or for security reasons.

You set up each context as a ’child’ item under the main item in the People Management
Configurator navigator. For example, if you want Post Code to display in three address
style contexts, you define three context items under the Post Code item If you hide the
’parent’ items, there will be a blank area of the window when it opens. This area is
populated by the context sensitive fields (such as address lines) when the user selects
the appropriate context (such as an address style). The fields that are displayed, their
position, size, defaults, and all other properties can vary with the context.

If one context is more common that the others, you can set that context as the default in
the field where the context is chosen. Then there is no blank area when the window
opens, because it contains the fields appropriate to this default context. For example, you
might set your local address style as the default so that the appropriate address lines for
local addresses are displayed by default.

Online Help Targets for Templates
When you are defining your template you can add your own help target to display a
particular help topic in the online help. This will override the default context-sensitive
help call of the form.window name.

If you enter a help target for the template this will override the form section of the default
help target. The window name will still be appended to this target depending on from
which window the user accesses help.

Note: If you define a new help target for your template none of the
supplied online help for the template will work. You will have to update
your help files to include your new help target.

The window names that can make up the People Management templates are:

• SUMMARY_WINDOW

• FIND_WINDOW

• MAINTAIN_WINDOW

• ACTION_WINDOW

• CREATE_WINDOW

• NOTIFY_WINDOW

For example, the default target that is generated when a user calls help from the Summary
window of the Hiring Applicants template is PERWSQHM.SUMMARY_WINDOW. If
you have defined a help target of "HIREAPP" for the Hire Applicants template, then
when a user calls help from the Summary window the target that is generated is
HIREAPP.SUMMARY_WINDOW.
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Notification Messages Issued From Template Window
When users choose the Notify button on a template window, they can select a message
and a person or role to send it to.

Predefined Messages
The following table shows predefined notification messages. You can create additional
messages using Oracle Workflow or delete any that are not relevant to your enterprise.

Display Name Internal Name

Change of employment for supervisor SUPERVISOR_JOB_CHANGE

Change of Supervisor CHANGE_SUPERVISOR

Employee Transfer EMPLOYEE_TRANSFER

Employee Transfer - Notify Payroll PAYROLL_INT_HIRE

New Contingent Worker Notification NEW_CWK

New Hire Notification NEW_STARTER

New Hire Notification (US) US_NEW_STARTER

Notify Payroll with New Hire Details PAYROLL_NEW_STARTER

Probation Period is close to expiry PROBATION_PERIOD_EXP

Relocation Notification RELOCATION_NOTIFICATION

Request Security Card SECURITY

Employee Transfer (US) US_EMPLOYEE_TRANSFER

Notify Payroll with New Hire Details (US) US_PAYROLL_NEW_STARTER

Employee Transfer - Notify Payroll (US) US_PAYROLL_INT_HIRE

Relocation Notification (US) US_RELOCATION_NOTIFICATION

Visa Expiry Notification to Supervisor GLB_SUP_VISA_EXP_WARN

Visa Expiry Notification to Employee GLB_EMP_VISA_EXP_WARN

Visa Expiry Notification to Employee (US) US_EMP_VISA_EXP_WARN

Visa Expiry Notification to Supervisor (US) US_SUP_VISA_EXP_WARN

Message Tokens
Notification messages can include the following tokens:

• HIRE_DATE

• FULL_NAME
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• PER_EFFECTIVE_START_DATE (Person Effective Start Date)

• TITLE

• FIRST_NAME

• LAST_NAME

• EMPLOYEE_NUMBER

• APPLICANT_NUMBER

• NATIONAL_IDENTIFIER

• ORGANIZATION

• GRADE

• JOB

• POSITION

• PAYROLL

• VACANCY

• SUPERVISOR

• ASG_EFFECTIVE_START_DATE (Assignment Effective Start Date)

• LOCATION

• SALARY

• SALARY_CURRENCY

• PAY_BASIS

• DATE_PROBATION_END

• NPW_NUMBER (Contingent Worker Number)

• START_DATE (Contingent Worker’s Start Date)

• SUPPLIER_NAME

• SUPPLIER_REFERENCE

• FF1 - FF5

Creating Additional Tokens
If your messages require additional tokens, you can create a formula that returns up
to five outputs that you can use as tokens (FF1 - FF5) in your message text. You create
the formula using Oracle FastFormula.

See: Writing Formulas for Templates, Oracle HRMS FastFormula User Guide.

People Management Configurator Options
This section describes the configuration options you can use when designing your
template. The options are shown in the order that they appear on the People
Management Configurator tool.
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Template Properties

Template Code

Displays the internal name for the template. This code in combination with the
Legislation uniquely identifies the template. You use this name when adding the
window to the user’s menu.

Template Name

Specifies the descriptive name of the template.

Enabled

A template can be enabled or disabled. You can only choose the Run Template option
from the Tools menu for a template that is enabled and linked to a menu. Disable
a template when it is no longer in use.

Legislation

Specifies the legislation of the template. Leave the legislation option blank to create a
generic template. The system automatically displays the appropriate legislative version
of a template for a user, or the generic version if there is no legislative version that
matches the legislation of the user’s Business Group.

Description

You can provide a longer description of the template.

Help Target

You can add your own help target to display a particular help topic. This overrides the
default context-sensitive help call of the form.window name.

Note: The target you enter here has the name of the window from which
you have called help appended to it to form the complete target. For
example, if you have defined a help target called HIREPER for your
template and you call help from the Summary window, then the help
target generated is HIREPER.SUMMARY_WINDOW.

Online Help Targets for Templates, page 3-276

Further Information

Use this Further Template Properties flexfield to enter additional configuration
information for the template. For example, for the People Management templates this
flexfield enables you to specify which window is displayed first and which person
types are allowed.

[ ]

Additional Template Details descriptive flexfield. You can configure this to include
additional information.
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Window Properties

Window Name

Specifies the name of the selected window. There are three windows
available: Summary, Find, and Maintenance

Title

Specifies the title of the window. This name is displayed at the top left of the window.

Height

Sets the height of the window in inches.

Width

Sets the width of the window in inches.

X Position and Y Position

Sets the position of the window using co-ordinates. X sets the horizontal position and
y sets the vertical position. Alternatively, you can use the arrow keys to move the
window around.

Further Information

Further Window Properties Developer Descriptive flexfield.

Canvas Properties

Canvas Name

Specifies the name of the selected canvas. This is the region of the window where fields
and other items appear The canvases available depend on the window you are creating:

• Background Canvases

The Maintain, Summary, and Find canvases fill in the background of the
window. You cannot amend the properties of these canvases.

• Tab Canvases

The Maintain Tabs, Summary Tabs, and Find Tabs canvases define the area of the
window in which you can define tabs.

• Find Results Canvas

The Find Results canvas defines the area of the window in which you can define the
Find Results region.

Visible

Set this to Yes if you want the canvas to be displayed to the user.

Height

Sets the height of the canvas in inches.
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Width

Sets the width of the canvas in inches.

X Position and Y Position

Sets the position of the canvas using co-ordinates. X sets the horizontal position and
y sets the vertical position. Alternatively, you can use the arrow keys to move the
canvas around.

Further Information

Developer Descriptive flexfield.

Tab Page Properties

Tab Page Name

Displays the name of the tab. The tabs available to you depend on the window you
are editing:

• Find - The find window has six tabs you can set up for any use.

• Maintain - The Maintain window has ten tabs available. Three tabs have been set
up to be used specifically for Extra Information Types (EIT), Special Information
Types (SIT), and the checklist.

• Summary - The Summary window has ten tabs available. One tab has been set up to
be used specifically for the checklist.

Visible

Set this to Yes if you want the tab to be displayed to the user.

Label

The label appears on the tab and describes the content of the tab.

You can define an access key (or keyboard shortcut) by preceding the appropriate
letter in the label with an ampersand (&). For example, to use ALT+P (in the Microsoft
Windows environment) as the access key for the Personal Details tab, enter the label
&Personal Details.

Do not use the letters A, E, F, G, H, Q, S, or W, as they are used on the Oracle Applications
menu. There is no validation to prevent the same letter being used more than once in
the same window.

Navigation Direction

Sets the tabbing order for the items in the tab. This can be left to right, or top to bottom.

Further Information

Developer Descriptive flexfield.
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Item Properties

Item Name

The item name is the name of the data item or field, such as LAST_NAME, you have
currently selected in the People Management Configurator Items branch. Items also
include buttons, such as the Actions or Notify button, and flexfield popup windows. If
you are working with a predefined template, only the fields used in that template are
displayed on the People Management Configurator Items branch. You can add other
fields to your template from the window.

See: Adding and Removing Fields on a Template, page 3-315.

Window Name

Displays the window name on which the field is used. You cannot change
this property. Each field has an associated window. There are three windows
available: Summary, Find, and Maintenance

Tab Page Name

Displays the name of the tab or tabs in the window on which the field is positioned. You
can choose a tab by clicking the button next to this field to see the available tab pages
you can use.

Visible

Set this to Yes if you want the field to be displayed to the user. If it is set to No, the user
cannot see the field but the field and its value are still in use. For example, the Secure
check box on the Find window is not visible but the box has been checked. The user
cannot see the check box on the window but the security restriction still applies.

Height

Sets the height of the field in inches.

Width

Sets the width of the field in inches.

X Position and Y Position

Sets the position of the field using co-ordinates. X sets the horizontal position and y sets
the vertical position. Alternatively, you can use the arrow keys to move the field around.

Enabled

Specifies whether the user can put their cursor into this field. If it is set to No, the user
can see the field but cannot do anything to it.

Required

Set this to Yes if you want to make the field mandatory.

Query Allowed

Specifies whether the user can run a query in this field.
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Note: This property is ignored in the People Management
templates. You can only run queries using the Find window.

Insert Allowed

Specifies whether the user can insert new data in this field. If this is set to No for a field
or button then it appears greyed out in the window.

Note: If you set this option to No for a check box then the check box
still appears in white on the window. To grey out a check box you
must set the Enabled option to No.

Update Allowed

Specifies whether the user can enter information in the field and save it to the database. If
this is set to No, the user can enter information but cannot save it.

Note: All fields included on a Summary window are greyed
out, irrespective of the settings in the Insert Allowed and Update
Allowed fields.

Prompt Text

Defines what text is displayed with the field. It also defines the text displayed for a
group of check boxes. You enter text labels for individual check boxes using the Label
property (see below).

Prompt Display Style

Specifies where a prompt is displayed for multi-row columns. "First Record" displays a
prompt next to the first row. "All Records" displays a prompt next to each row. "Hidden"
hides all prompts.

Prompt Text Alignment

Specifies the alignment of the prompt text as Center, Left, Right, End, or Start within the
prompt box. Generally has no visible effect.

Prompt Edge

Specifies which edge of the field the prompt is attached to, either Start, End, Top, or
Bottom.

Prompt Edge Alignment

Specifies how the prompt is aligned along the selected field edge, either Start, End or
Center.

Prompt Edge Offset

Specifies the distance between the field and its prompt, measured in inches.

Prompt Alignment Offset

Use this property to adjust the prompt edge alignment. For example, if the Prompt Edge
is Top, the Prompt Edge Alignment is Center and the Prompt Alignment Offset is 0.1, the
prompt is centered 0.1 inches from the center of the top edge of the field.
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Label

This only applies to buttons or check box items. The label describes the button or
individual check box.

You can define an access key (or keyboard shortcut) by preceding the appropriate letter in
the label with an ampersand (&). For example, to use ALT+P (in the Microsoft Windows
environment) as the access key for the Picture window, enter the label &Picture.

Do not use the letters A, E, F, G, H, Q, S, or W, as they are used on the Oracle Applications
menu. There is no validation to prevent the same letter being used more than once in
the same window.

Tooltip Text

You can enter text here that displays when the user has the mouse pointer over the
field. Use this to provide additional quick help.

Previous Item

Specifies which field is tabbed to next if you tab backwards. This overrides the default
tabbing order.

Next Item

Specifies which field is tabbed to next. This overrides the default tabbing order.

Default Value

You can set the default value for the field here. Setting defaults can help save
time, provide better control, and reduce errors for the user.

Format Mask

You can apply a format style to number and date type fields so that the format is
correct for your users.

Validation Formula

You can set up additional validation using formulas. For example, if you need to
validate that an entry has been entered correctly, you can create a validation formula to
check the format. Up to five inputs can be passed to the formula but only one message
can be returned.

See: Writing Formulas for Templates, Oracle HRMS FastFormula User Guide

Validation Formula Parameters 1-5

Enter the parameters you want to pass to the formula specified in the Validation
Formula field.

Information Formula

You can set up additional information for fields using a formula. For example, on the Job
field, the user can right click and choose More Information to see related information
such as supervisor. Up to five inputs can be passed to the formula but only three outputs
can be returned.

See: Writing Formulas for Templates, Oracle HRMS FastFormula User Guide
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Information Prompt

Specifies the prompt displayed on the right mouse menu which the user selects to view
the information you have defined in the Information Formula.

Information Formula Parameters (1-5)

Enter the parameters you want to pass to the formula specified in the Information
Formula field.

Alignment

Defines the alignment of text within the item (left, center, or right).

Case Restriction

Defines what case the text is defaulted to. For example, you can set it to upper case so
that all the text entered in the field is upper case.

Bevel

Specifies the appearance of the field border, either RAISED, LOWERED, INSET,
OUTSET, or NONE.

Further Information

Opens the Further Item Properties developer descriptive flexfield, where you can
enter additional configuration options. For example, for the People Management
templates, you can select whether DateTrack History is enabled for datetracked fields.

Fields on the People Management Window
The following table lists all the available fields on the People Management window. Not
all of these fields are available on the predefined People Management templates. You can
choose which of these fields are displayed on your users’ windows by making your own
copies of the People Management templates and adding or removing fields.

See Adding and Removing Fields on a Template, page 3-315

Item Title Windows Additional Information

Accounting KeyFlex Popup Maintain Popup window containing
all segments for the Default
Expense Account key flexfield

Action Maintain

Summary

Button

Address Attribute 1-20 Maintain

Summary

Segments from the Additional
Address Details descriptive
flexfield

Address Attribute Category Maintain

Summary

Context for the Additional
Address Details descriptive
flexfield
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Item Title Windows Additional Information

Address Attributes Popup Maintain

Summary

Popup window containing all
segments for the Additional
Address Details descriptive
flexfield

Address Date From Maintain

Summary

Field

Address Date To Maintain

Summary

Field

Address Information 13-20 Maintain

Summary

Segments from the Address
developer flexfields that
may have been defined by
localization teams

Address Information Popup Maintain

Summary

Popup window containing
all segments for the Address
developer flexfields

Address Line 1-3 Maintain

Summary

Field

Address Type Maintain

Summary

Field

Adjusted Service Date Maintain

Summary

Field

Age Maintain

Summary

Field

Alternate First Name Maintain Filed aviable in the
Employment Details tabbed
region.

This field is available to
Kuwaiti users only.

Alternate Family Name Maintain Field Available in the
Additional Name Details
tabbed region.

This field is available to
Kuwaiti users only.

Annuities Maintain Field

Available in the GOSI Details
tabbed region.

This field is available to Saudi
users only
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Item Title Windows Additional Information

Annuities Join Date Maintain Field

Available in the GOSI Details
tabbed region.

This field is available to Saudi
users only

Applicant Number Find Results

Find

Maintain

Summary

Field

Application Attribute 1-20 Maintain

Summary

Segments from the Additional
Application Details
descriptive flexfield

Application Attribute
Category

Maintain

Summary

Context for the Additional
Application Details
descriptive flexfield

Application Attributes Popup Maintain

Summary

Popup window containing
all segments for the
Additional Application
Details descriptive flexfield

Application Date End Summary Field

Application Date Received Maintain

Summary

Field

Approved Maintain

Summary

Field

Assignment Attribute 1-30 Maintain

Summary

Segments from the Additional
Assignment Details
descriptive flexfield

Assignment Attribute
Category

Maintain

Summary

Context for the Additional
Assignment Details
descriptive flexfield

Assignment Attributes Popup Maintain

Summary

Popup window containing
all segments for the
Additional Assignment
Details descriptive flexfield

Assignment Category Find Results

Find

Maintain

Summary

Employment or Assignment
Category
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Item Title Windows Additional Information

Assignment Effective End
Date

Find Results

Maintain

Summary

Field

Assignment Effective Start
Date

Find Results

Maintain

Summary

Field

Assignment Extra Information
1-30

Maintain Assignment extra information
types

Assignment Extra Information
Category

Maintain Context for the Assignment
extra information types

Assignment List Maintain Drop-down list displaying
person’s assignments

Assignment Number Find Results

Maintain

Summary

Field

Assignment Rate Maintain Assignment rate for
contingent workers

Assignment Rate Basis Maintain Assignment rate basis for
contingent workers

Assignment Rate Currency Maintain Assignment rate currency for
contingent workers

Assignment Rate Value Maintain Assignment rate monetary
value for contingent workers

Assignment Sequence Find Results

Maintain

Summary

Field

Assignment Status Type Find Results

Find

Maintain

Summary

Field

Assignment Title Summary Field

Assignment Type Find Results

Maintain

Summary

Field
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Item Title Windows Additional Information

Available For Transfer Maintain

Summary

Field

Background Check Date Maintain Field

Background Check Status Find Results

Maintain

Summary

Field

Background Date Check Find Results

Summary

Field

Bargaining Unit Code Find Results

Find

Maintain

Summary

Field

Benefit Group Find Results

Find

Maintain

Summary

Field

Benefit Medical Plan Number Maintain Field

Birth Name Maintain Field. Hungarian users only

Billing Title Maintain Field

Blood Type Find Results

Maintain

Summary

Field

Button 1-5 Maintain Task flow buttons

Cancel Find Button

Change Date Maintain

Summary

Assignment change date

Change Reason Find Results

Maintain

Summary

Assignment change reason

Checklist 1-10 Date Done Maintain

Summary

Field

Checklist 1-10 Date Due Maintain

Summary

Field
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Item Title Windows Additional Information

Checklist 1-10 Item Code Maintain

Summary

Field

Checklist 1-10 Notes Maintain

Summary

Field

Checklist 1-10 Status Maintain

Summary

Field

Civil Identity Number Maintain Field

This field is available to Saudi
users only

Civil Identifier Maintain Field Available in the
Employee Details tabbed
region.

This field is available to
Kuwaiti users only.

Clear Find Button

Collective Agreement Maintain

Summary

Field

Collectively Agreed Grades Id
Flex Num

Maintain

Summary

Field

Collectively Agreed Grades
Name

Maintain

Summary

Field

Command Color Maintain Field. This is available on the
Military tab. Hungarian users
only

Command Type Maintain Field. This is available on the
Military tab. Hungarian users
only

Command Number Maintain Field. This is available on the
Military tab. Hungarian users
only

Contingent Worker Number Find Results

Find

Maintain

Summary

Field

Contribution Group Maintain Field. Spanish users only.
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Item Title Windows Additional Information

Contract Find Results

Maintain

Summary

Field

Coordinated Benefits Medical
Plan Number

Find Results

Summary

Field

Coordinated Benefits No
Coverage

Find Results

Summary

Field

Correspondence Language Find Results

Maintain

Summary

Field

Country Maintain

Summary

Field

Country 1-3 Maintain

Summary

Field

Country of Birth Maintain

Summary

Field

Currency Code Maintain

Summary

Field

Current Employer Maintain

Summary

Field

Current Record Indicator Find Results

Maintain

This indicator must be
included in any multi-block
records. It shows the currently
selected record. There are
separate versions of this item
on the Maintain window for
special information types and
extra information types.

Custom Date Text Item 1-10 Maintain These fields do not correspond
to the database column.
They are used in a custom
library solution. Please
refer to the "Additional
Configuration Options For
People Management" for more
details.
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Item Title Windows Additional Information

Custom Number Item 1-10 Maintain These fields do not correspond
to the database column.
They are used in a custom
library solution. Please
refer to the "Additional
Configuration Options For
People Management" for more
details

Custom Character Text Item
1-10

Maintain These fields do not correspond
to the database column.
They are used in a custom
library solution. Please
refer to the "Additional
Configuration Options For
People Management" for more
details

Custom Checkbox Item 1-3 Maintain These fields do not correspond
to the database column.
They are used in a custom
library solution. Please
refer to the "Additional
Configuration Options For
People Management" for more
details

Custom List Item 1-3 Maintain These fields do not correspond
to the database column.
They are used in a custom
library solution. Please
refer to the "Additional
Configuration Options For
People Management" for more
details

Custom Item with List of
Values 1-5

Maintain These fields do not correspond
to the database column.
They are used in a custom
library solution. Please
refer to the "Additional
Configuration Options For
People Management" for more
details

Date Employee Data Verified Find Results

Maintain

Summary

Field

Date From Maintain Special information

Date Of Birth Find Results

Find

Maintain

Summary

Field
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Item Title Windows Additional Information

Date Of Death Find Results

Maintain

Summary

Field

Date Of Receipt Of Death
Certificate

Maintain Field

Date Probation End Find Results

Maintain

Summary

Field

Date To Maintain Special information

Datetrack Correction Maintain Datetrack radio button

Datetrack Update Maintain Datetrack radio button

Default Code Combination
Identifier

Find Results Internal identifier for the
assignment’s default expense
account

Dependant Adoption Date Find Results

Maintain

Summary

Field

Dependant Voluntary Service Find Results

Maintain

Summary

Field

Deployment Factor Attribute
1-20

MaintainSummary Segments from the Additional
Deployment Factor Details
descriptive flexfield (Work
Choices)

Deployment Factor Attribute
Category

Maintain

Summary

Context for the Additional
Deployment Factor Details
descriptive flexfield (Work
Choices)

Deployment Factors
Attributes Popup

Maintain

Summary

Popup window containing all
segments for the Additional
Deployment Factor Details
descriptive flexfield (Work
Choices)

Description of Expense
Account

Maintain Description associated with
Accounting KeyFlex popup
window

Dpf Fte Capacity Maintain

Summary

Deployment factor FTE
capacity
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Item Title Windows Additional Information

Dpf Work Duration Maintain

Summary

Deployment factor work
duration

Dpf Work Hours Maintain

Summary

Deployment factor work hours

Dpf Work Schedule Maintain

Summary

Deployment factor work
schedule

Duplicate Check Maintain

Maintain Tabs

Button. This can be placed on
the main window or the tabs
in the Maintain window. If
you include this button you
must ensure that you have
set up a Find window in your
template.

Earliest Available Date Maintain

Summary

Field

Education Establishment 1-4
Attended End Date

Summary Schools information

Education Establishment 1-4
Attended Start Date

Summary Schools information

Education Establishment 1-4
Full Time

Summary Schools information

Education Establishment 1-4
Name

Summary Schools information

Effective Date Find

Maintain

There are separate versions
of this element for the Find
window and the timeline on
the Maintain window

Email Address Find Results

Find

Maintain

Summary

Field

Employee Category Maintain

Summary

Field

Employer Maintain Field

Available in the GOSI tabbed
region

This field is available to Saudi
users only

3-294 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Item Title Windows Additional Information

Employee Number Find Results

Find

Maintain

Summary

Field

Establishment Find

Maintain

Summary

Field

Expense Check Send Address Find Results

Maintain

Summary

Field

Extra Information Type List Maintain Displays a drop-down list of
extra information types.

Family Name Maintain Field

Available in the Alternate
Names and in the Employee
Details tabbed region

This field is available to Saudi
and Kuwaiti users only

Father Name Maintain Field

Available in the Alternate
Names and in the Employee
Details tabbed region

This field is available to Saudi
and Kuwaiti users only

Father’s Alternate Name Maintain Field Available in the
Additional Name Details
tabbed region.

This field is available to
Kuwaiti users only.

Field 1-5 Condition Code Find Advanced search items

Field 1-5 Name Find Advanced search items

Field 1-5 Value Find Advanced search items

Find Find Button

First Name Find Results

Find

Maintain

Summary

Field
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Item Title Windows Additional Information

Frequency Find Results

Maintain

Summary

Dependent field. Used with
Normal Hours.

Full Name Find Results

Find

Maintain

Summary

Field

Full Name Title Summary Field

Full Time Equivalent Capacity Find Results

Maintain

Summary

Field

Gender Find Results

Find

Maintain

Summary

Field

Go Maintain Button used on timeline to
show details as of the effective
date entered

GOSI Number Maintain Field

Available in the GOSI Details
region tabbed region

This field is available to Saudi
users only

Grade Ladder Find Results

Find

Maintain

Summary

Field

Grade Find Results

Find

Maintain

Summary

Field

Grandfather Name Maintain Field

Available in the Alternate
Names and Employee Details
tabbed region

This field is available to Saudi
and Kuwaiti users only
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Item Title Windows Additional Information

Grandfather’s Alternate Name Maintain Field Available in the
Additional Name Details
tabbed region.

This field is available to
Kuwaiti users only.

Governorate Maintain Field Available in the
Employee Details tabbed
region.

This field is available to
Kuwaiti users only.

Group Maintain Field. This is available on the
Civil tab. Hungarian users
only.

Hazards Maintain Field Available in the GOSI
Details tabbed region.

Available in the GOSI Details
tabbed region

This field is available to Saudi
users only

Hazards Join Date Maintain Field

Available in the GOSI Details
tabbed region

This field is available to Saudi
users only

Hire Date Maintain

Summary

Start Date for Employee

Hold Applicant Date Until Find Results

Maintain

Summary

Field

Honors Find Results

Maintain

Summary

Field

Hourly Salaried Find Results

Maintain

Summary

Field

Identifier Type Maintain Field. Spanish users only.

Identifier Value Maintain Field. Spanish users only.
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Item Title Windows Additional Information

Internal Address Line Find Results

Maintain

Summary

Field

Internal Location Find Results

Maintain

Summary

Field

Job Find Results

Find

Maintain

Summary

Field

Known As Find Results

Maintain

Summary

Field

Labour Union Member Find Results

Maintain

Summary

Field

Last Medical Test By Find Results

Maintain

Summary

Field

Last Medical Test Date Find Results

Maintain

Summary

Field

Last Name Find Results

Find

Maintain

Summary

Field

1st Last Name Maintain Field. Spanish users only.

2nd Last Name Maintain Field. Spanish users only.

Load Picture Maintain Button that enables you to
load a digitized picture of the
person

Local Department Maintain Field. This is available on the
Civil tab. Hungarian users
only.
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Item Title Windows Additional Information

Local Sub Department Maintain Field. This is available on the
Civil tab. Hungarian users
only.

Location Find Results

Find

Maintain

Summary

Field

Legal Employer Maintain Fields Available in the
Employment Details tabbed
region.

This field is available to
Kuwaiti users only.

Mailstop Find Results

Maintain

Summary

Field

Manager Find Results

Maintain

Summary

Field

Mandate Code Maintain Field. This is available on the
Military tab. Hungarian users
only.

Mandate Date Maintain Field. This is available on the
Military tab. Hungarian users
only.

Marital Status Find Results

Maintain

Summary

Field

Middle Names Find Results

Find

Maintain

Summary

Field

Mother’s Maiden Name Maintain Field. Hungarian users only

Multiple Components Maintain Field

National Identifier Find Results

Find

Maintain

Summary

Field
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Item Title Windows Additional Information

NIF Number Maintain Field. Spanish users only

Nationality Find Results

Find

Maintain

Summary

Field

No Benefit Coverage Maintain Field

Normal Hours Find Results

Maintain

Summary

Field

Notice Period Length Maintain

Summary

Field

Notice Period Units Maintain

Summary

Dependent field. Used with
Notice Period Length.

Notify Maintain

Summary

Field

Office Number Find Results

Maintain

Summary

Field

On Military Service Find Results

Maintain

Summary

Field

Only Current Location Maintain

Summary

Field

Organization Find Results

Find

Maintain

Summary

Field

Organization Maintain Field. This is available on the
Civil tab. Hungarian users
only

Original Date Of Hire Maintain

Summary

Field
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Item Title Windows Additional Information

Pay Basis Find Results

Maintain

Summary

Salary frequency

Pay Proposal Attribute 1-20 Maintain

Summary

Segments from the Additional
Salary Administration Details
descriptive flexfield

Pay Proposal Attribute
Category

Maintain

Summary

Context for the Additional
Salary Administration Details
descriptive flexfield

Pay Proposal Attributes
Popup

Maintain

Summary

Popup window containing all
segments for the Additional
Salary Administration Details
descriptive flexfield

Payroll Find Results

Find

Maintain

Summary

Field

People Group Find Field

People Group KeyFlex Popup Find Results

Maintain

Summary

Popup window containing
all segments for the People
Group key flexfield

People Group Segment 1-30 Find Results

Maintain

Summary

Segments from the People
Group key flexfield

Performance Review Period Find Results

Maintain

Summary

Field

Performance Review Period
Frequency

Find Results

Maintain

Summary

Dependent field. Used with
Performance Review Period.

Person Attribute 1-30 Maintain

Summary

Segments from the Additional
Person Details descriptive
flexfield

Person Attribute Category Maintain

Summary

Context for the Additional
Person Details descriptive
flexfield
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Item Title Windows Additional Information

Person Attributes Popup Maintain

Summary

Popup window containing all
segments for the Additional
Person Details descriptive
flexfield

Person Effective End Date Find Results

Maintain

Summary

Field

Person Effective Start Date Find Results

Maintain

Summary

Field

Person Extra Information 1-30 Maintain Person extra information type

Person Extra Information
Category

Maintain Context for the Person extra
information type

Person Information 1-30 Find Results

Maintain

Summary

Person developer descriptive
flexfield. This will only
contain records if they
have been set up for your
legislation.

Person Information Category Find Results

Maintain

Summary

Context for the Person
developer descriptive
flexfield.

Person Information Popup Find Results

Maintain

Summary

Popup window containing all
segments for the Person
developer descriptive
flexfield.

Person Referred By Find Results

Maintain

Summary

Field

Person Type Find Results

Find

Maintain

Summary

Field

Personal Identity Number Maintain Field. This is available on the
Employment tab. Hungarian
users only

Pensioner Registration
Number

Maintain Field. This is available on the
Employment tab. Hungarian
users only
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Item Title Windows Additional Information

Phone Home Date From Maintain

Summary

Field

Phone Home Date To Maintain

Summary

Field

Phone Home Fax Date From Maintain

Summary

Field

Phone Home Fax Date To Maintain

Summary

Field

Phone Home Fax Number Maintain

Summary

Field

Phone Home Number Maintain

Summary

Field

Phone Mobile Date From Maintain

Summary

Field

Phone Mobile Date To Maintain

Summary

Field

Phone Mobile Number Maintain

Summary

Field

Phone Work Date From Maintain

Summary

Field

Phone Work Date To Maintain

Summary

Field

Phone Work Fax Date From Maintain

Summary

Field

Phone Work Fax Date To Maintain

Summary

Field

Phone Work Fax Number Maintain

Summary

Field

Phone Work Number Maintain

Summary

Field

Picture Maintain

Summary

Field
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Item Title Windows Additional Information

Placement Start Date Maintain

Summary

Start date for a contingent
worker period of placement

Place of Birth Maintain Field. Hungarian users only.

Position Find Results

Find

Maintain

Summary

Field

Position Maintain Field. This is available on the
Civil tab. Hungarian users
only

Postal Code Maintain

Summary

Field

Pre Name Adjunct Find Results

Maintain

Summary

Field

Previous Last Name Find Results

Maintain

Summary

Field

Primary Address Maintain Field

Primary Assignment Find Results

Maintain

Summary

This check box should always
be set to display only when
included in a template. When
a user wants to change a
secondary assignment to a
primary they must use the
Make Primary Assignment
action.

Probation Period Find Results

Maintain

Summary

Field

Probation Unit Find Results

Maintain

Summary

Dependent field. Used with
Probation Period.

Professional Category Maintain Field. Spanish users only.
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Item Title Windows Additional Information

Projected Hire Date Find Results

Find

Maintain

Summary

Field

Projected Placement End Date Maintain

Summary

Projected end date for a
contingent worker period of
placement

Project Title Find Results

Find

Maintain

Summary

Field

Proposed Salary Maintain

Summary

Field

Rank Maintain Field. This is available on the
Military tab. Hungarian users
only

Reason Not Completed Maintain Field. This is available on the
Military tab. Hungarian users
only

Receipt Of Death Certificate
Date

Find Results

Summary

Field

Recruiter Find Results

Maintain

Summary

Field

Recruitment Activity Find Results

Find

Maintain

Summary

Field

Region 1-3 Maintain

Summary

Address regions

Region of Birth Maintain

Summary

Field

Registered Disabled Find Results

Find

Maintain

Summary

Field
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Item Title Windows Additional Information

Rehire Reason Maintain

Summary

Field

Rehire Recommendation Find Results

Maintain

Summary

Field

Religion Maintain Field

This field is available to Saudi
users only

Relocate Domestically Maintain

Summary

Field

Relocate Internationally Maintain

Summary

Field

Relocation Preference Maintain

Summary

Field

Requisition Find Results

Find

Maintain

Summary

Field

Resume Exists Find Results

Maintain

Summary

Field

Resume Last Updated Find Results

Maintain

Summary

Field

Salary Basis Find Results

Find

Maintain

Summary

Field

Salary Change Reason Maintain

Summary

Field

Salary Review Period Find Results

Maintain

Summary

Field
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Item Title Windows Additional Information

Salary Review Period
Frequency

Find Results

Maintain

Summary

Dependent field. Used with
Salary Review Period.

Save As Find Button

Second Passport Exists Find Results

Maintain

Summary

Field

Secure Find Check box

Set of Books Maintain Field

Section Maintain Field. This is available on the
Employment tab. Spanish
users only.

Show Details Find

Summary

Button

Soft Coded KeyFlex Popup Find Results

Maintain

Summary

Popup window containing all
segments for the soft coded
legislation key flexfield.

Soft Coded Segment 1-30 Find Results

Maintain

Summary

The soft coded legislation
key flexfield holds legislation
specific information at the
assignment level. The
legislation of your Business
Group determines which
flexfield structure you see.

Social Security Code Maintain Field

Source Organization Find Results

Maintain

Summary

Field

Social Security Start Date Maintain Field. Hungarian users only

Social Security End Date Maintain Field. Hungarian users only

Service Completed Maintain Field. This is available on the
Military tab. Hungarian users
only

Service Start Date Maintain Field. This is available on the
Military tab. Hungarian users
only
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Item Title Windows Additional Information

Service End Date Maintain Field. This is available on the
Military tab. Hungarian users
only

Source Type Find Results

Maintain

Summary

Field

Social Security Number Maintain Fields available in the
Employment Details tabbed
region.

This field is available to
Kuwaiti users only.

Special Ceiling Point Find Results

Maintain

Summary

Dependent field. Used with
Special Ceiling Step.

Special Ceiling Step Find Results

Maintain

Summary

Field

Special Information Segment
1-30

Maintain Field

Special Information Type List Maintain Displays a drop-down list of
special information types.

Special Title Maintain Field

Start Date Find Results

Find

Maintain

Summary

Field

Student Status Find Results

Maintain

Summary

Field

Style Maintain

Summary

Address style

Sub Group

Successful Maintain

Summary

Flag indicating whether an
application was successful
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Item Title Windows Additional Information

Suffix Find Results

Maintain

Summary

Field

Supervisor Find Results

Find

Maintain

Summary

Field

Supplier ID For Assignment Find Results

Find

Maintain

Summary

Supplier ID information for a
contingent worker

Supplier ID For Worker Find Results

Find

Maintain

Summary

Supplier ID information for a
contingent worker

Supplier Name Find Results

Find

Maintain

Summary

Supplier name for contingent
worker

System Person Type Find Results

Maintain

Field

System Status Find Results

Summary

Field

Tax Effective End Date Maintain

Summary

Field

Tax Effective Start Date Maintain

Summary

Field

Tax Field 1-150 Maintain

Summary

Empty items to enable
localization teams to
configure legislation specific
information, such as tax
information.

Tax Identification Number Maintain Field. This is available on the
Employment tab. Hungarian
users only

Telephone Number 1-3 Maintain

Summary

Field
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Item Title Windows Additional Information

Termination Reason Maintain

Summary

Field

Time Normal Finish Find Results

Maintain

Summary

Field

Time Normal Start Find Results

Maintain

Summary

Field

Timeline Field Maintain Drop-down list that enables
you to select what data is
shown in the timeline

Timeline First Maintain Button

Timeline Last Maintain Button

Timeline Next Maintain Button

Timeline Previous Maintain Button

Title Find Results

Find

Maintain

Summary

Field

Town of Birth Maintain

Summary

Field

Town Or City Maintain

Summary

Field

Travel Required Maintain

Summary

Field

Unacceptable Country 1-3 Maintain

Summary

Countries in which the person
does not want to work

Under 18 Approved Maintain Field. Spanish users only

Uses Tobacco Find Results

Maintain

Summary

Field
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Item Title Windows Additional Information

Vacancy Find Results

Find

Maintain

Summary

Field

Visit Internationally Maintain

Summary

Field

Work Center Maintain Field. Spanish users only

Work Any Country Maintain

Summary

Field

Work Any Location Maintain

Summary

Field

Work Schedule Find Results

Maintain

Summary

Field

Using the People Management Configurator
Use the People Management Configurator to create your own versions of the predefined
People Management templates and design windows that match your business processes.

Note: You can also use CustomForm to configure certain
windows, including the People Management template windows, by
setting access restrictions.

See: Using CustomForm, page 3-326

To configure a template using the People Management Configurator:

1. Write any formulas you require for the template. You can write formulas to:

• Change the name used to identify assignments.

• Validate user entries in a field.

• Provide more information on a field, which the user can access from the right
mouse menu when they right-click on the field.

• Create additional tokens for notification messages.

See: Writing Formulas for Templates, Oracle HRMS FastFormula User Guide.

2. Open and make a copy of a predefined template using the People Management
Configurator, or import an existing template.

See: Opening and Copying a Template, page 3-312

See: Importing a Template, page 3-313
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3. Modify the template to your requirements. You can perform as many of the
following tasks as you require to complete your template.

See: Editing a Template, page 3-313

See: Adding and Removing Fields on a Template, page 3-315

See Adding Flexfields to a Template, page 3-316

See: Defining Checklists, page 3-317

See: Setting Defaults for Fields in Templates, page 3-318

See: Setting Up Context-Sensitive Fields in Templates, page 3-318

See: Setting Up DateTrack History on Fields in Templates, page 3-319

See: Setting Up More Information on Fields in Templates, page 3-320

4. Review the predefined notifications and create any required new ones using Oracle
Workflow.

See: Notification Messages Issued from Template Forms, page 3-277

5. If appropriate, use CustomForm to restrict the information that appears in the
template window, and the actions that users can perform.

See: Configure a Window With CustomForm, page 3-327

6. Create a form function for the new window, and add the window to a menu
or task flow.

See: Adding a People Management Window to a Menu or Task Flow, page 3-320

7. Preview the form in the People Management Configurator to check properties such
as field tabbing sequence and defaults. You can also check whether you are happy
with the default position of task flow buttons. If not, you can reposition them in
the People Management Configurator.

Opening and Copying a Template
You can use the predefined People Management templates as a basis for designing your
own windows. You cannot edit the predefined templates directly, but you can make
your own copy of any template and edit the copy. You can then always return to the
original template if necessary.

Note: We also recommend that you set up templates in a test area. This
avoids any security infringements when you run a template to view
the windows you are designing. If the Security check box on the Find
window is not selected, you can view summary information in the
search results about all the people who meet your search criteria. This
may include people outside your security profile.

To open and copy a template:
1. In the Navigator, open the People Management Configurator.

2. In the Find Templates window, select the template you want to copy.

3. Choose the Copy button.
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4. In the Copy Template window, enter the details for your new template in the Copy
To section:

• Enter a template code and, optionally, a legislation. These must form a unique
combination, but you can create several legislative variations using one template
code.

You use the template code when you add the template window to a menu.

• Enter a descriptive name for the template

• Choose Yes or No to enable or disable the template. While designing a
window, you can choose No so that users cannot display the window.

5. Choose OK. In the Decision window that appears next, choose Yes.

The Designer (People Management) window is displayed along with a
representation of how the template window will appear to the user.

To make changes to the template, see Editing a Template, page 3-313.

Importing a Template
You can import a template from another database provided that it is for the same
legislation as your Business Group. For example, you should not import a UK template
for a US Business Group.

You might want to import a template from a test database to your production
environment. You can also use this procedure to make backups of templates.

This procedure involves downloading the template to a data file then uploading
to your target database.

To import a template:
1. Run the Forms Configurator - Download Template process. You do this in the

Submit Requests window for a Super HRMS Manager responsibility.

2. In the Parameters window, enter a filename and full directory path for the data
file. The template will be saved to this data file. You will use this data file to import
the template later.

3. Select the name of the template you want to download and choose OK.

4. Go to the database where you want to upload and use the template.

5. Run the Forms Configurator - Upload Template process.

6. In the Parameters window, enter the name and path of the data file you created
when you downloaded the template.

The template is now available for you to add to a menu or modify using the People
Management Configurator.

Editing a Template
You can edit a copy of a predefined template to design the layout and content of a People
Management window. Use the People Management Configurator tool.

Extending Oracle HRMS 3-313



Note: You cannot edit the predefined templates directly. To make
a copy of a predefined template to edit, see Opening and Copying
a Template, page 3-312

To see a full list of the properties you can set for templates, windows, canvases, tab
pages, and items, see: People Management Configurator Options, page 3-278.

To edit a template:
1. In the Find Template window, select the template you want to edit and choose Edit.

The Designer window of the People Management Configurator tool is
displayed, showing a navigation tree for the items on the template. When you
select something in the navigator, its properties are shown in the bottom half of the
window. A representation of each window in the template form as it will appear to
the user is also displayed behind the Designer.

2. Review the template properties and edit as required. Click in the Further Information
field (a predefined descriptive flexfield) if you want to:

• Restrict the template to handling applicants, employees or contingent workers
only.

• Specify which windows (Summary, Maintenance and Find) are included in the
template, and which one displays first.

3. Click the + symbol next to the template name (top node in the navigator) to expand
the node and display Windows and Items.

4. Expand Windows to display details of the windows in the template.

5. Expand each window to display the canvases and tab pages it contains, then expand
the canvases and tab pages to specify the properties of each.

For example, you can specify the title, size, and position of the Summary
window. You can choose which tab pages appear on the Maintenance window and
specify the label and navigational direction (top to bottom or left to right) in the tabs.

Note: If you make any changes to the properties of a
window, canvas, tab, or item and do not want to save them, you can
select Clear Record from the toolbar to reset the changes.

6. To set up a checklist tab, see Defining Checklists, page 3-317.

7. Expand Items to display all the fields and buttons that are used in the template. The
window on which each item is displayed is shown in brackets.

8. Select an item to view and update its properties. For example, you can move a field
or change its prompt.

9. To add fields that do not currently appear on the template, or remove fields from the
template, see: Adding and Removing Fields on a Template, page 3-315.

10. Save your work.

Previewing Your New Window

11. Choose Run Template from the Tools menu to see how the window will appear to
your users, and to test task flow and right mouse menus.
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Important: Before you can preview your window, you must first
enable the template and add the new window to a menu. We
recommend that you preview your windows on a test database
only, to avoid security infringements.

Adding and Removing Fields on a Template
For windows that have been designed using the People Management templates, you
can choose to remove fields from the window if your users do not need them and you
can add new fields if required.

For a full list of the fields, buttons and other items you can add to a template, see: Fields
on the People Management Window, page 3-285.

Note: There is a distinction between removing a field from the template
and removing a field from a window. If the field is on the template
but hidden in the window, the field data is still active. Hidden
fields, however, slow your performance so you should remove fields
wherever possible. This procedure describes removing a field from the
template so that its data is not used.

To add or remove a field from a template:
1. Open the template using the People Management Configurator tool.

See: Editing a Template, page 3-313.

The template windows are displayed along with the People Management
Configurator tool.

Adding a Field

2. To add a field or other item that is not already in the template, expand the Items
node, then right-click on Items and choose New from the right mouse menu.

Tip: Add all your new fields in a consistent location, such as the top
of the branch, to help you keep track of them. Choose Refresh from
the right mouse menu when you want the system to place your new
fields in their correct alphabetical position.

3. Click on the list of values icon in the Item Name field to open the Item Names Find
window. Search for the field you want to add or enter % to see the complete list.

4. Select the field you want to add and choose OK.

Your new field appears under Items in the navigator.

5. Set the following properties:

• Tab Page Name

• Visible

• Height and width of the field

• Position - Either use the arrow buttons to move the field around or enter a new
position in the X and Y Position fields. As you move a field, you can view how it
will appear on the window by looking at the template window.
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Note: If you make any changes to the properties of an item and
do not want to save them, you can select Clear Record from the
toolbar to reset the changes.

You can choose to set other properties for the field. Refer to People Management
Configurator Options, page 3-278 for a complete description of all the properties.

See also Adding Flexfields to a Template, page 3-316

Removing a Field

6. To remove a field or button from a template, right-click on the item in the navigator
and choose Delete from the right mouse menu.

7. Save your work.

Adding Flexfields to a Template
You can add individual segments of a flexfield to a template you create using the People
Management Configurator, or you can add a popup window containing all the segments
in a flexfield. For reasons of performance, it is recommended that you use a popup
window if you have a large number of segments that you want to add to the window.

Note: You cannot add both individual flexfield segments and a popup
window for the same flexfield structure on the same window.

To add individual flexfield segments to a template:
1. Open your template using the People Management Configurator.

See: Editing a Template, page 3-313.

2. Expand Items and locate the flexfield segment.

3. Add the value item for the flexfield segment.

See Adding and Removing Items on a Template, page 3-315

4. If the user will be selecting the value for the segment from a value set, enter the
meaning item so that the longer description is also displayed.

Note: It is your responsibility to ensure that you enter all flexfield
segments required by your configuration. If you omit flexfields
that you have defined as mandatory, the user will be unable
to save records.

To add a popup flexfield window to a template:
1. Open your template using the People Management Configurator.

See: Editing a Template, page 3-313.

2. Expand Items and locate the flexfield items.

3. If you have previously added individual segments of the flexfield to the
template, you must first remove all of them. Right-click on each segment of the
flexfield and choose Delete from the right mouse menu.

See Adding and Removing Items on a Template, page 3-315
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4. Add the Flexfield Name Popup item to the window. This adds a popup window
containing all of the flexfield segments.

5. Save your work

Defining Checklists
A checklist is a list of user actions related to people management and recruitment, such
as "Check References" and "Reimburse Expenses". Against each check item, users can
record a status, date due, date achieved, and any notes. The checklists are for user
reference only; they do not perform any actions.

Checklists can appear on tabs of template forms: on the Summary window, Maintenance
window, or both. These tabs are configurable. You specify which check items are
displayed, and which fields are available for entry. There is a limit of ten check items
on a tab.

There is also a Checklist window, which you can include in task flows from other
windows, such as the People window. The Checklist window is not configurable. On
this window, users can select any checklist item that you have defined.

To define checklist items and statuses:
1. Open the Application Utilities Lookups window.

2. Query the lookup CHECKLIST_ITEM.

3. Enter the code, meaning, and optionally a description for each checklist item you
want to define.

4. Save your work.

5. Query the lookup CHECKLIST_STATUS.

6. Enter the code, meaning, and optionally a description for each checklist status you
want to define.

7. Save your work.

To define a checklist:
1. Open your template using the People Management Configurator.

See: Editing a Template, page 3-313.

2. Expand Windows, expand the window on which you want to place the
checklist, expand the Tab Pages node, and select the Checklist tab.

3. Enter properties for the Checklist tab, including the tab label.

For a list of the properties you can change for a tab page, see People Management
Configurator Options, page 3-278.

4. Expand Items and find Checklist 1 Item Code (Maintain) or Checklist 1 Item Code
(Summary), depending which window is to include the checklist. If this item does
not appear in the items list, you need to add it.

See: Adding and Removing Fields on a Template, page 3-315.

5. Enter properties for this item.
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To provide a default check item in this field, enter the appropriate lookup meaning
in the Default Value property. You must enter the meaning exactly as you typed it
in the Application Utilities Lookups window. If you want to prevent users from
selecting other check items in this field, set the Insert Allowed property to No.

6. Save your work.

7. To specify the fields that accompany this check item in the checklist, find the
following items. If they do not appear under Items, you can add them. If they
appear and you do not want them on your checklist, you can remove them.

• Checklist 1 Status

• Checklist 1 Date Due

• Checklist 1 Date Done

• Checklist 1 Notes

8. Repeat steps 4 to 7 to add up to ten checklist items to your template, using the items
Checklist 2 Item Code through Checklist 10 Item Code.

Setting Defaults for Fields in Templates
The templates enable you to default values in many fields.

See Default Values in Template Fields, page 3-270

To set a default for a field:
1. Open the template using the People Management Configurator tool.

See: Editing a Template, page 3-313.

2. In the People Management Configurator navigator, expand Items and select the field
for which you want to set a default.

See: Fields on the People Management Window, page 3-285 for a full list of all the
available fields.

3. In the Properties section, enter a default value for the field in the Default Value
field. There is no list of values available, so you must be careful to type the value
exactly as it should appear.

You can also choose not to display the field on the window even though you have set
a default value.

4. If you want to hide the field set the Visible Field to No.

5. Save your work.

Setting Up Context-Sensitive Fields In Templates
You can set up fields that are context-sensitive in your templates using the People
Management Configurator tool. You can use the following contexts:

• Person type - for example, to hide the Employee Number field when an applicant
is selected.

• Descriptive flexfield context - for example, to display address lines in the appropriate
sequence for each address style
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• Key flexfield structure - for example, to display the appropriate structure of the
Personal Analysis Key Flexfield for each Special Information Type.

Note: If a segment is not defined for a particular structure or context in
the flexfield definition, it does not appear on the form even if you set it
up for that context in the People Management Configurator.

To set up a context-sensitive field:
1. Open your template using the People Management Configurator.

See: Editing a Template, page 3-313.

2. In the navigator, expand Items and find the field that you want to make
context-sensitive.

3. Set the properties for the default field. You may want to hide the default field so
that it only appears in the contexts that you define.

4. Expand the field, right click on Contexts, and choose New from the right mouse
menu. You set up a ’child’ context field for each context in which you want the
field displayed.

5. In the Properties section, select a value in the Context Type field: Descriptive
Flexfield, Key Flexfield, or QuickHire Person Type.

6. In the window that displays, enter the context in which this field should display
and choose OK.

For a descriptive flexfield, select the Application, Title, and Context. For
example, this could be Oracle Human Resources, Personal Address Details, and
United Kingdom respectively. For a key flexfield, select the Application, Title, and
Structure. For a QuickHire Person Type, select the person type.

7. Choose the tab you want the field displayed on for this context and set any other
properties, such as position or tool tip text.

8. Repeat steps 4 to 7 for each context in which this field should display.

9. Save your work.

Setting Up DateTrack History on Fields in Templates
You can set up DateTrack History for datetracked and dated fields on a template. This
has two effects:

• Users can then right-click in the field and choose DateTrack History to see a history
of changes that have been made to that field.

• The field appears in the drop down list by the timeline bar. If you select the field in
the drop down list, the timeline shows the dates of changes to this field.

To set up DateTrack History on a field:
1. Open your template using the People Management Configurator.

See: Editing a Template, page 3-313.

2. Expand Items and find the field.

3. Select the flexfield [ ] at the bottom of the Properties section.
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4. Enter Yes in the DateTrack History field.

5. Save your work.

Setting Up More Information on Fields in Templates
You can set up more information to be available to users on each of the fields you
include in a template using Oracle FastFormula. The user can right-click in a field and
choose a prompt that you specify. For example, you might want to enable the display of
a supervisor’s email address from the Supervisor field. From the Job field, you might
show the normal working conditions for the job.

For examples of how you can set up more information see the Supervisor and Position
fields in the predefined Hiring Applicants and Maintaining Employees templates.

To set up more information on a field:
1. Open your template using the People Management Configurator.

See: Editing a Template, page 3-313.

2. Expand Items and select the field for which you want to set up more information.

3. Enter a formula name in the Information Formula field.

You create the formula using Oracle FastFormula.

See: Writing Formulas for Templates, Oracle HRMS FastFormula User Guide.

4. Enter a label explaining the information available in the Information Prompt
field. This prompt is displayed in the right mouse menu when a user right-clicks
on the field.

5. Enter up to five inputs for the formula in the Information Formula Parameter Fields.

6. Save your work.

Adding a People Management Template Window to a Menu or Task Flow
When you create your own version of a window using the People Management
Configurator, you need to add your new window to a menu or task flow so that users
can access it.

To create a function for a window:
1. You must define a function to call the window. When you define the form

function, use parameters to specify the template name, and, if necessary, the
customization name and task flow name (separate the parameters by spaces). For
example:

Function: PERWSQHM_CUSTOM_MAINTAIN_EMPS

Parameters: TEMPLATE_NAME="PER_MAINTAIN_EMPS" HR_CUSTOMIZAT
ION="MedicalSIT" WORKFLOW_NAME="EMP_DEVELOPMENT"

If your enterprise uses assignment-level security, you can add a function parameter
to enable this functionality.

Parameter: SECURE_ON_INDIVIDUAL_ASG=”YES”

For more information, see: Assignment-Level Security, page 1-29
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For a description of the HRMS parameters you can use when you define
functions, see: Using Parameters for HRMS Form Functions, page 1-101.

Note: Assignment-level security is currently available for the
following windows:

• People Management templates (PERWSQHM)

• Assignments (PERWSEMA)

• Combined Person and Assignments (PERWSHRG)

Adding a window to a menu:

2. You can add the function to any menu.

For more information about adding your configured window to a menu see: Menus
Window, Oracle Applications System Administrator's Guide

Adding a window to a task flow:

3. You can create a new task flow for the window. People Management windows must
always be the first window in the task flow.

See: Define Task Flows, page 3-257

Note: If you want to use a version of the People Management
window that you have restricted using CustomForm in a task
flow, you must first define a new task flow node and then define a
menu function to call the task flow.

See: Adding a Custom Window to a Menu or Task Flow, page 3-328
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Restrict Windows Using Customform

CustomForm
Many of the standard Oracle HRMS windows are multipurpose. For example, in the
People windows, you can enter or view details of employees, applicants, contingent
workers, contacts, or other person types that you have defined. In the Element Entries
window, you can make entries for all the elements you have defined.

You might prefer to have multiple versions of these windows, each version being used
for just one purpose. This approach restricts the list of values on certain fields and
therefore provides for faster data entry. It also enables you to limit access to certain
types of information.

For example, you might create a customized version of the View Element Entry History
for Employee window that does not display the earnings elements representing
salary, Thrift Savings Plan (TSP), Awards bonus, and commission. Most users’ menus
would only give them access to this customized version of the window. For the small
group of people authorized to view salary, TSP, Awards bonus, and commission
figures, your system administrator can define a menu function to allow access to the
uncustomized form.

You can do this using CustomForm.

Restricting Access to People Management Templates
When you create a people management template using the People Management
Configurator (see People Management Configurator, page 3-266), you can specify
whether the template handles employees, applicants, contingent workers or a
combination of all three. This is a quick way to restrict your template windows by
system person type. If you need to restrict the template windows by user person
type, you can use CustomForm to create a restricted version of your template.

Important: Make sure that the criteria you enter in the Form
Customization window do not conflict with any restrictions you put
on the template using the People Management Configurator. For
example, if you restrict the template to Applicants Only in the People
Management Configurator then create a version that only handles the
user person type Graduate Intake (a type of employee), users will not be
able to find any people using the template.

You can also use CustomForm to restrict People Management templates in other
ways. You can restrict the special information types, extra information types, actions, and
notifications that are available from your templates. You can also control the fields
available for searching and the new records (applicant, employee, contingent
worker, assignment or application) that users can create using the templates.

Windows you can Restrict using CustomForm
You can use CustomForm to restrict the information available in the windows listed in
the table below. We also identify the criteria you can use to restrict access to information.
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Form Restrict By Values

Adjust Balance: (Oracle
Payroll form)

Element Set User defined

Adjust Balance: (Oracle
Payroll form)

Element Processing Type Recurring, Nonrecurring

Assignment Folder Person Type User defined

Element Entries Element Set User defined

Element Entries Element Processing Type Recurring, Nonrecurring

Element Entries Entry Type Override

Event Bookings Employee or Applicant Employee, Applicant

Extra Assignment
Information

Extra Information Type User defined

Extra Element Information Extra Information Type User defined

Extra Job Information Extra Information Type User defined

Extra Location Information Extra Information Type User defined

Extra People Information Extra Information Type User defined

Extra Position Information Extra Information Type User defined

List Employees by Element Element Set User defined

List Employees by Element Element Processing Type Recurring, Nonrecurring

List People by Special
Information

Employee or Applicant Employee, Applicant

List People by Special
Information

Special Information Type User defined

List People by Special
Information

Person Type User defined

Organization Organization Classification List of Organization
Classifications

Payroll and Assignment
Processes: (Oracle Payroll
form)

Action Type List of Action Types (e.g. Run,
Pre-payments, Reversal)

People Folder Person Type User defined

People (PERWSEPI),
People and Assignment (
PERWSHRG): (Enter Personal
Information)

Person Action User defined
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Form Restrict By Values

People (PERWSEPI),
People and Assignment (
PERWSHRG): (Enter Personal
Information)

Person Function User defined

People (PERWSEPI),
People and Assignment (
PERWSHRG): (Enter Personal
Information)

Person Type User defined

People Management Person Type User defined

People Management Special Information Type User defined, and some may
be predefined

People Management People Extra Information Type User defined, and some may
be predefined

People Management Assignment Extra Information
Type

User defined, and some may
be predefined

People Management Actions List of available actions such
as Hire Applicant

People Management Workflow Notifications Notifications defined in
workflow; some predefined,
you can add others

People Management New Objects New Applicant, New
Employee, New Application,
New Assignment

Position Occupancy Folder Employee or Applicant Employee, Applicant

Run QuickPaint Report QuickPaint Inquiry User defined

Run QuickPaint Report Person Type User defined

Run QuickPaint Report Assignments Assignment Sets, Assignments

Special Information Special Information Type User defined

Table Values: (Define User
Values)

Table Name User defined

View Element Entry History
for Employee

Element Set User defined

View Element Entry History
for Employee

Element Processing Type Recurring, Nonrecurring

Types of Data Restrictions
You can restrict the information that appears in a customized window by the following
sorts of criteria:
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• Element processing type (recurring or nonrecurring)

• Element set (user defined)

• Person type (user defined)

• Special information type (user defined)

• Organization classification

• Employee, applicant, or contingent worker

Note: If you choose to restrict access to your form by person
type, you select the person type and then choose whether to include
or exclude this person type.

• QuickPaint report (user defined)

• Extra Information Type (user defined)

• Workflow notification (user defined)

• New objects that you can create using the People Management window

• Fields you can search on using Advanced Find in the People Management
window. The fields you select are excluded from the Advanced Find.

Important: When you use a standard window, all types of information
are available. When you use a configured version, you can only see
the types of information that were selected on the Form Customization
window. However, there is one exception. When you restrict the People
Management window by Advanced Find Item, you can search in the
configured version of the window on all Find items except the ones you
selected on the Form Customization window.

If you want to restrict the data by a user defined information type, you must create it first:

• To restrict by element set, create the set in the Element and Distribution Set window.

See: Defining an Element or Distribution Set, Oracle HRMS Compensation and Benefits
Management Guide

• To restrict by QuickPaint Report, create the report in the Define QuickPaint Report
window.

See: Defining QuickPaint Reports, page 4-30

• To restrict by Special Information Type, define your information type as an instance
of the Personal Analysis key flexfield.

See: Setting Up Special Information Types, Workforce Sourcing, Deployment, and
Talent Management Guide

• To restrict by person types, define your user person types in the Person Types
window.

See: Defining Person Types, Enterprise and Workforce Management Guide

• To restrict by Extra Information Type, define your Extra Information types.

See: Setting up Extra Information Types, page 3-27

• To restrict by workflow notification, create your notifications using Oracle Workflow.
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Using the Include and Exclude Restrictions
With selected restriction types, you can choose to include or exclude specific types. This
is currently only possible with the Person Type restriction. In this case, the system checks
whether any of the person types assigned to a person match any of the person types
included or excluded using the Person Type restriction.

The different scenarios are best illustrated using examples. In each case, the employee
has the person types of Employee and Applicant.

Scenario 1

Included Person Type Excluded Person Type

Employee

Result: The employee is visible in the form. In this case, all persons with the person
type of Employee are visible.

Scenario 2

Included Person Type Excluded Person Type

Employee

Result: The employee is not visible in the form. In this case, all persons with the person
type of Employee are excluded and all other persons are visible.

Scenario 3

Included Person Type Excluded Person Type

Employee Applicant

Result: The employee is not visible in the form. Even though the employee has the
Person Type of Employee, which is included according to the restriction, the Excluded
Person Type of Applicant takes priority over the Included Person Type and the employee
is not visible in the form.

Note: It is not possible to include and exclude the same person type.

Using CustomForm
Use CustomForm to configure a certain set of windows by setting restrictions in
them. For example, you can use CustomForm to restrict the elements that users can
enter using the Element Entries window.

You can also use the People Management Configurator to modify predefined templates
and create windows that match your business processes.

See: Using the People Management Configurator, page 3-311

To configure a window using CustomForm:
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1. If you are restricting the information that appears in the configured window by a
user defined entity (such as an element set, person type, special information type, or
QuickPaint report), ensure that this entity is already defined.

See: Types of Data Restriction, page 3-322

2. Define a configured version of the window using the Form Customization window.

See: Configuring a Window With CustomForm, page 3-327

3. Add the new window to a menu or task flow.

See: Adding a Configured Window to a Menu or Task Flow, page 3-328

Configuring a Window With CustomForm
You can define your own versions of templates and some standard windows in the
Form Customization window.

See: List of Configurable Windows, page 3-322

Note: If you want to restrict access to query-only for a window, you do
not need to create a separate version. Instead you create a new form
function, setting the QUERY_ONLY parameter to YES.

See: Restricting Access to Query-only Mode, page 1-101

To define restrictions for a window:
1. Select the name of the window in the Form to be customized field.

2. Enter the name of your new version in the Name field. This name is used when
defining menus but it is not seen by users.

3. Select Enabled if you want the restrictions to come into effect. If you do not select
this option, the configured version of the window behaves the same way as the
standard version.

4. Enter the titles to appear in the new version of the window:

• In the Standard Title field, enter the window title to be seen by users who can
use the window for data entry and editing.

• In the Query Title field, enter the window title to be seen by users who have
view-only access to the window.

Note: If you are configuring a template, the titles entered for the
template in the People Management Configurator window override
those entered here.

5. Save your new version.

6. In the Restrictions block, select the Type and Value of the restrictions you want to
define. The types and values available depend on the window you are configuring.

Note: If you are using the Person Type restriction, you can
choose whether to include or exclude the selected person type
using the available radio buttons. If you select any other type of
restriction, the radio button is automatically set to Include.
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Adding a Custom Window to a Menu or Task Flow
When you create a restricted version of a window using CustomForm, you need to add
your new window to a menu or task flow so that users can access it.

Adding custom windows:
1. If you want to add the custom window to a task flow, you must create a Task Flow

Node for it.

See: Define Task Flow Nodes, page 3-257

2. If the window is called directly from the Navigator window, you must define a
menu function to call the custom version of the window. You can add the function to
any menu.

For a description of the HRMS parameters you can use when you define
functions, see: Using Parameters for HRMS Form Functions, page 1-101.

Note: If you want to use a custom version of the People
window, People Folder, or Assignment Folder to start a task
flow, you should define a new task flow node and then define a
menu function to call the task flow.

For more information about adding your custom window to a menu see: Menus
Window, Oracle Applications System Administrator's Guide
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Additional Configuration Options

Additional Configuration Options
There are some additional configuration options that your organization may need to set
up, depending on the requirements of your system. These include:

• Enabling Currencies, page 3-332

• Setting up Printers, page 3-329

• Setting up International HRMS. See: What is International HRMS?, page 3-330

Setting Up Your Printers
To run reports in Oracle HRMS, you need to associate the following predefined print
styles with your printer driver:

• XX PS Portrait

• XX PS Landscape

• XX_Cheque

Note: XX represents your country code, such as ZA.

You do this using the Printer Types window.

See: Setting Up Your Printers, Oracle Applications Systems Administrator’s Guide.

Examples of Printer Driver and Printer Types

Example postscript printer driver (HP LaserJet 4000)

Driver Name: A4PS

User Driver: A4 POSTSCRIPT

SRW Driver: A

Driver Method: Command

Arguments: lp -d$PROFILES$.PRINTER -n$PROFILES$.
CONC_COPIES -t"$PROFILES$.TITLE"
$PROFILES$.FILENAME

Extending Oracle HRMS 3-329



Table 1-6 Example of the South African cheque printer driver (HP LaserJet 4000)

Driver Name: A4CHEQUE

User Driver: A4 CHEQUE

SRW Driver: HPA

Driver Method: Select Command

Arguments: lp -d$PROFILES$.PRINTER -n$PROFILES$.
CONC_COPIES -t"$PROFILES$.TITLE"
$PROFILES$.FILENAME

Initialization: /eE/e(s0P/e&l0O/e&l8D/e&l26A/e&k2S/
e(8U/e(s0p12h0s0b4099T/e&l25E

Reset: /eE/000

Example Printer Type (HP LaserJet 4000)

Style Driver Name

PS Landscape A4PS

PS Portrait A4PS

Cheque A4CHEQUE

What is International HRMS?
International HRMS is a set of standard data categories that provide the foundation for a
localized version of HRMS. You can use International HRMS to set up a localized version
of HRMS provided that your localization is not already supported.

You are not obliged to use International HRMS to set up localized data. If you prefer, you
can set your own localization by following a series of manual steps. However , the
advantages of using International HRMS to set up a localization are:

• It is quicker to install

• It is easier to install

• It is easier to support once you have installed it.

How Do You Use International HRMS to Create a Localization?
You apply hrglobal and then run the concurrent program International HRMS Setup. For
further details of the exact sequence, see Overview: Using International HRMS to
Define a Localization, page 3-331.

What is Included in International HRMS Phase 1
International HRMS Phase 1 includes all of the following data definitions:

• Business rules
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• Element Classifications

• Bank Key Flexfield and legislative rule for bank key flexfield

• Total payments balance and supported dimension, route, defined balance.

Legislation Rules

This legislation rule is supplied with International HRMS Phase 1:

legislation_rule
(p_legislation_code => p_legislation code
,p rule_type => ’E’
,p rule_mode => ’ZZ Bank Details’

Element Classifications

These element classifications are supplied with International HRMS Phase 1:

• Information

• Earnings

• Absence

• Supplemental Earnings

• Taxable Benefits

• Pre-tax Deductions

• Tax Deductions

• Direct Payment

• Employer Charges

• Involuntary Deductions

• Voluntary Deductions

Routes

The only route available with International HRMS Phase 1 is Global Payments.

Balance Dimensions

The only balance dimension available with International HRMS Phase 1 is Payments.

Balances

The only balance available with International HRMS Phase 1 is Total Payments.

Overview: Using International HRMS to Define a Localization

You apply International HRMS standard data by following this sequence:

1. Install HRMS

2. Apply patch 2574811 to provide the standard set of data categories needed in every
legislation

3. Run hrglobal
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4. Apply patch 2574861 to provide a translated set of data for the particular legislation
that you are installing

5. Run the concurrent program International HRMS Setup.

See: Running the International HRMS Setup Process, page 3-332

Enabling Currencies
Oracle HRMS enables you to use multiple currencies for entering information about
employee compensation and benefits. You can also record your payment methods to
employees in different currencies.

For example, if you have employees living and working temporarily in other
countries, you might want to record specific earnings or deductions for these employees
in local currencies. You might also want to pay these employees a fixed amount into a
bank account in their home currency. The remainder you would pay in a local currency.

Your startup data includes the definitions of all world currencies. These definitions
are shared by all Oracle Applications and are controlled by the system administrator
responsibility. You enable those currencies you want to use in the Currencies window.

Note: You must enable at least one currency as the default currency for
all information related to money in your system. This default is known
as the Base Currency for your Business Group.

To enable a currency:
1. Query the currency you want to enable and check the Enabled check box. Save your

choice to enable the currency.

You can never delete a currency, but you can disable it.

To disable a currency:
1. Uncheck Enabled, or enter an End Date for the currency.

Running the International HRMS Setup Process
Use the International HRMS Setup process to apply a standard set of data when you are
installing a legislation that is not currently supported. You do this after you have:

1. Installed HRMS

2. Applied patch 2574811

3. Run hrglobal

4. Applied patch 2574861

You run the International HRMS Setup process from the Submit Requests window.

To run the International HRMS setup process:
1. Enter your legislation. You can only do this for a legislation that is not currently

supported.

2. Enter the currency for your legislation.

3. Enter the Tax Year Start Date.
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4. Decide whether you want to use tax units.

5. Choose OK, and then submit your process.

This creates a legislation with the name, default currency, and tax year details
that you specify. When you have completed these setup steps you can then add
specific data for your legislation.

Using the Person Name Format Function
The person name format function enables you to specify how a person’s name is
returned in custom applications or reports etc. You use tokens to specify the format in
which you want to see the name. You can call the function in various ways, including
PL/SQL, SQL etc.

Note: This function cannot be used to format how names are displayed
in windows in the application.

The tokens that you can use are as follows:

• $FI - First Name

• $MI - Middle Name

• $LA - Last Name

• $PR - Prefix

• $SU - Suffix

• $TI - Title

• $FU - Full Name

• $KN - Known As

• $IF - Initial First

• $IM - Initial Middle

A series of tokens are passed into the routine and the formatted name is returned.

If the date being passed to the routine is null then the system date is used. Likewise if
the format being passed is null then the full_name is returned. If the person_id used is
not valid, then an error is raised.

SQL Example 1

You can use a profile to define the name format you required. This ensures that all
your reports or customizations to retrieve the name uniformly. If you then decide to
change the profile value, the change is reflected everywhere you use the profile value as
one of the parameters.

If you create a new profile called XX_NAME and assign the value $FI.$LA to it, you can
use the following SQL to retrieve the name of person with the ID 972:

SQL> select hr_person_name.get_person_name(972,null,f nd_profile.v
alue(’XX_NAME’)) from dual;

This returns the name in the format: Antonio.Bortoliero
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SQL Example 2

The following example shows how to use the new function to retrieve the same person’s
name as of two days before the current system date:

SQL> select hr_person_name.get_person_name(972,sysdat e-2,’$FI.$MI
.$TI’) name from dual;

This returns the name in the format: Antonio.D.Doctor

PL/SQL Example

The following shows a simple PLSQL use of the function:

declare
l_name varchar2(2000);

begin
l_name := hr_person_name.get_person_name

(p_person_id => 972,
p_date => trunc(sysdate),
p_format => ’$FI.$LA’);

end;

In this example l_name would contain the name in the format ’Antonio.Bortoliero’.
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4
Administer ing Workforce Intelligence

Information Access Overview
Oracle HRMS provides a range of inquiry and reporting mechanisms to meet the needs
of different users:

• Predefined Discoverer Workbooks that you can use directly, or edit to meet your
own reporting requirements.

• Discoverer End User Layer folders that you can use to create your own Discoverer
Workbooks.

• Inquiry windows (including folders)

• Predefined reports that can be scheduled and grouped for periodic processing

• QuickPaint, to create your own online inquiries and reports about people and
assignments

• Multilingual reporting for some reports

• Use of desktop tools for reporting or editing HRMS data. For example, you can use
Application Data Exchange (ADE) to download information to a spreadsheet, and
then upload the modified data to HRMS.

Discoverer Workbooks
Oracle Discoverer is a data query and analytical tool that enables you to perform
detailed analysis of the human resources issues that interest you. Discoverer uses an End
User Layer (EUL), which is based on a series of business views, to build worksheets
and workbooks that report on the data from the underlying HRMS application. There
are a number of predefined workbooks, which you can refine by specifying worksheet
parameters; you can also build your own workbooks.

Discoverer End User Layer
HRMS contains a predefined End User Layer where the data in the underlying database
tables is organized in Discoverer as folders. The folders are organized into Business
Areas. You can use this End User Layer to create your own Discoverer Workbooks.

See: Discoverer End User Layer Business Area Descriptions, page 4-6
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Inquiry Windows
Oracle HRMS includes some inquiry windows to meet the most common online
reporting requirements. In these windows, you typically enter selection criteria in the
first block then choose the Find button to view a list of people, assignments, or other
entities that match your criteria. Some of these windows use folders to display the
information retrieved by your criteria.

Folders are online views that you can configure. By default, the folder block in an
inquiry window displays all records matching your inquiry and all fields available
within the folder. However, you can create your own folders to display a subset of these
records and fields. You can also choose the field labels, their size and order, and the
sort sequence of the retrieved records.

For example, in the Assignment Folder window, you could create a folder called Sales
Employees by Grade. This folder has the query criteria Organization = "Sales", and it is
sorted by grade.

Predefined Reports
There are a number of predefined reports that you can use immediately without any
further set up. They have a predefined format but you can choose which records to view
by entering a set of parameters when you submit the report.

You can also create your own reports using Oracle Reports or SQL*Plus or another tool
of your choice. You can register them with Application Object Library. This means you
can run them from the standard Submit Requests window, and you can schedule them in
report sets with other reports and processes.

Multilingual Reporting
Oracle HRMS enables you to print reports in the language of your choice.

HR Reports

You can select in which language the following reports are printed:

• Full Person Details

• Full Applicant Details

• Full Assignment Details

• Full Work Details

See: Submitting a Request, Oracle Applications User's Guide

Payroll Reports

Payroll reports are usually submitted in the language of your Business Group, for
example the US Check writer can only be printed in American English and the GB
Deposit Advice can only be printed in English. However, you may be able to print
payroll reports in multiple languages if your localization team has created legislation
specific reports for you to use.

Note: The default HRMS payrolls for the US and UK can only be run in
English.
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Using Oracle HRMS with Spreadsheets
You can use Oracle Application Data Exchange (ADE) to download information from
the HRMS database to a spreadsheet for analysis and manipulation. For example, you
can download data on current and proposed salaries for a group of employees. You
can adjust the salary proposals in the spreadsheet, or enter new ones, and upload the
revised data to the database. The ADE upload process reports any errors and ensures
that only valid data is saved in the database.

To download information from a form to a spreadsheet using ADE, your system
administrator needs to create a style in ADE. The style defines the form it is used for, the
responsibilities that can use it, and the columns (or fields) to be downloaded. You
determine which records are downloaded by running a query in the form before
launching ADE.

A style for downloading salary proposals is predefined.

See Using Application Data Exchange.

QuickPaint
QuickPaint is a powerful and flexible tool to design reports about assignments in the
format you require. You can include the following sorts of information in a QuickPaint
report:

• Personal information

• Contact information

• Assignment information

• Application information

• Compensation and benefit information

• Descriptive flexfield information

Once you have designed a QuickPaint report, you and other users can run the report
online for any assignment or set of assignments. You can view the results online or
print them.

Configuring the Run QuickPaint Report Window

Using the standard QuickPaint Report window, you can run the report for an assignment
or an assignment set. The assignments can be held by current employees or applicants.

Your system administrator can create configured versions of this window to restrict the
reports you can run and the people you can report on. A configured version might be
subject to one or more of the following restrictions:

• Report on one person type only (employees OR applicants).

• Run one report only.

• Report on single assignments only, or report on assignment sets only.

If the window is subject to the third type of restriction, it will look different to the
standard version since it will contain either the assignment region or the assignment
set region, but not both.
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Attachments
You can add attachments to a large number of HRMS records. Examples of attachments
are word processed documents, Web pages or video images.

Information Access
Oracle HRMS provides a range of inquiry and reporting mechanisms to meet the needs
of different users.

Does Oracle HRMS provide flexible access to information?
The information held in Oracle HRMS is an extremely valuable resource for your
enterprise. You can use the same information in a variety of different ways depending on
your business purpose. For example, you can use Oracle HRMS information in support
of each of the following business activities:

• Performing a full range of HR functions on a day-to-day basis

• Reporting on HR activities

• Performing what-if exercises to determine the viability of alternatives scenarios

• Performing strategic planning with the Business Intelligence System

How can you use Oracle HRMS to support typical HR activities?
You can extract details about a single employee or a group of employees. Particular
examples are:

• Selecting an employee or a set of employees for HR processing

• Extracting HRMS information to produce standard letters

• Viewing organization hierarchies and position hierarchies

• Viewing a historical record of previous changes

What range of reporting options are available in Oracle HRMS?
When you are reporting on activities using HRMS you may want to use each of the
following reporting options depending on your business purpose:

• Define a report using parameters that you supply

• Run a predefined report

• Specify the intervals at which a report should run

• Combine several reports into a set so that they can be run at the same time

• Run a predefined Discoverer workbook.

• Create a Discoverer workbook based on the predefined End User Layer.

Can you run multilingual reports?
Yes, you can run HRMS in more than one language on a single database. This means
that you can enter and report on information using more than one language. For
example, your base, or source, language could be French, but you could also install
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German and English. You would then be able to enter and produce reports in German
and English.
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Administering Workforce Intelligence

Discoverer Workbooks and End User Layer
HRMSi uses Oracle Discoverer to create ad hoc workbooks containing worksheet reports
and graphs. HRMSi supplies a set of workbooks that you can amend to meet your
enterprise’s specific requirements. You can also use Discoverer User to create your own
workbooks, based on the supplied Discoverer End User Layer (EUL).

You can find full instructions on developing the Discoverer EUL and creating and
maintaining Discoverer workbooks in the Oracle Discoverer Plus User’s Guide and the
Oracle Discoverer Plus Administrator’s Guide

Discoverer Workbooks
Each workbook holds a set of related worksheets. A worksheet is simply a report that
returns data from a SQL query. The workbook may contain calculations and conditions
that can restrict the report in various ways.

You can access Discoverer workbooks from the Self-Service menu. You can use
parameters to specify the data range you want in your report. The worksheets are
displayed in Discoverer Viewer.

Discoverer End User Layer
The end user layer (EUL) comprises a set of business areas, containing folders. The
folders contain items that map to table columns. The folders can map to one or more
database table. The folders present that data in a structure that is suitable for reporting.

There are two types of business areas: administrative and functional. The administrative
business areas contain all folders. The purpose of the administrative areas is to give
report developers access to all the folders to enable them to create ad hoc reports.

The functional business areas contain folders that support reporting for a specific
business function, such as iRecruitment. Folders can exist in one or more functional
business area. Workbooks are typically based on folders from one functional business
area. You can grant users access to one or more functional business area, depending
on which reports they require.

Discoverer End User Layer Business Area Descriptions
The HRMS Discoverer End User Layer provides folders that access the data from the
HRMS transactional tables. You can use these folders to create your own Discoverer
reports. The End User Layer organizes the folders into two types of business
areas: Administrative, and Functional.

Administration Business Areas
Use the Administration business area to produce detailed ad-hoc reports specific to
the needs of your enterprise.

HRMS - Administration - Oracle Human Resources

The HRMS – Administration – Oracle Human Resources business area is a composite
set of Discoverer folders focusing on different entities of the Oracle Human Resources
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system, such as salaries, benefits, jobs, grades and assignments. The related Lists of
Values folders are in a separate business area.

Use the HRMS – Administration – Oracle Human Resources business area to produce
detailed ad-hoc reports specific to your human resources needs.

HRMS - Administration - Oracle Human Resources (Lists of Values)

The HRMS – Administration – Oracle Human Resources (Lists of Values) business
area contains all the Lists of Values folders relating to the Oracle Human Resources
system. The folders in this business area do not appear anywhere else.

This business area is for internal use only.

HRMS - Administration - Oracle Training Administration

The HRMS – Administration – Oracle Training Administration business area is a
composite set of Discoverer folders focusing on different entities of the Oracle Training
Administration system, such as training events, training activities, student enrollments
and event resources.

Use the HRMS – Administration – Oracle Training Administration business area to
produce detailed ad-hoc reports specific to your training administration needs.

HRMS - Administration - Oracle iRecruitment

The HRMS – Administration - Oracle iRecruitment business area focuses on the
vacancy and job posting details, recruitment activities, candidate details and applicant
information within your enterprise.

Functional Business Areas
These business areas are grouped by function. They enable you to restrict users to
a functional area in which they can develop or access workbooks specific to their
functional role.

HRMS - Compensation and Benefits

The HRMS – Compensation and Benefits folders focus on entities specific to employee
remuneration. From these folders you can produce ad-hoc reports summarizing and
detailing such information as salary against grades and jobs.

HRMS - General Employment Practices

The HRMS – General Employment Practices folders focus on entities specific to
employment practices. Using this functional business area you can produce ad-hoc
reports covering such issues as equal opportunities, minority employment, disability
accommodations, work related injuries, health and safety, disciplinary actions, grievances
and interpersonal conflicts.

HRMS - Implementation and Data Set-Up

The HRMS – Implementation and Data Set-up folders provide information on system
setup and data.
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HRMS - Training Management

The HRMS Training Management folders relate to the management of training, where
the enterprise is a training provider.

HRMS - Workforce Budgeting

The HRMS – Workforce Budgeting functional business area covers all aspects
relating to creating budgets. The folders contain budget information together with
assignment, job, location, organization assignment, and supervisor information.

HRMS - Workforce Composition and Activity

The HRMS – Workforce Composition and Activity folders show how employees
are spread throughout various areas such as jobs, geography, minority groups, and
business groups. Activity information is concerned with changes in the workforce (for
example, organization transfers).

HRMS - Workforce Costing

The HRMS – Workforce Costing business folders focus on costs associated with the
workforce, such as the cost of training, direct payments to employees, and assignment
costings.

HRMS - Workforce Development and Performance

The HRMS – Workforce Development and Performance folders focus on issues such as
competency information, internal training and success.

HRMS - Workforce Recruitment

The HRMS – Workforce Recruitment folders provide information on workforce
recruits, such as competencies, employment history, education, and qualifications. It also
provides analysis of employee movement within and between organizations.

HRMS - Workforce Separation

The HRMS – Workforce Separation folders provide information on staff
turnover, including categorizing the reasons people leave or move within an
organization.

HRMS - Workforce Utilization and Productivity

The HRMS – Workforce Utilization and Productivity folders focus on issues such as how
well the workforce is utilized (working hours, absence) and how productive they are.

Programs to Populate Workforce Intelligence Discoverer Reports
Many Workforce Intelligence reports rely on collected data, stored in summary tables, in
order to run efficiently. You need to collect data from your transaction tables regularly so
that the information in your reports is up to date.

You collect the data by running pre-defined concurrent programs, as described below.

For information on concurrent programs, see: Overview of Concurrent Processing,
Oracle Applications Developer's Guide
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BIS Load Organization Hierarchy Summary Table
This program creates the organization hierarchies on which HTML reports are
based. When you run this program, it collects organization hierarchy structures into
the HRI_ORG_PARAMS and HRI_ORG_PARAM_LIST tables to improve reporting
performance.

Prior to running the concurrent program, ensure you have one hierarchy marked as
the primary hierarchy. If no hierarchy is nominated as the primary hierarchy, BIS Load
Organization Hierarchy Summary Table will not pick up your hierarchies.

Add the BIS Load Organization Hierarchy Summary Table concurrent program to
a request group using the Request Group window. The request group must be used
by the responsibility that runs the concurrent program.

Schedule and run the request group using the Submit Request window.

Important: After running each BIS Load Organization Hierarchy
Summary Table request you are advised to run the system administrator
request Gather Schema Statistics for the HRI schema. This will ensure
that you gather statistics from the BIS Load Organization Hierarchies
request.

Parameters

There are no parameters for this program.

Run frequency

You must also run this program when there are changes to organization hierarchies and
you want to reflect them in your reports. Reports will not display accurate information if
you do not run this program periodically to update the summary tables.

You should therefore ensure that the concurrent program is run at regular intervals, for
example, every day or every week in order to collect any changed data.

If a system failure occurs, you must restart the program.

HRI Load All Organization Hierarchy Versions
This concurrent program collects your organization hierarchy structures into the
HRI_ORG_HRCHY_SUMMARY table to improve reporting performance. It will
perform a full refresh of all the data.

Parameters

There are no parameters for this program.

Run frequency

Run the HRI Load All Organization Hierarchy Versions concurrent program at
implementation.

You must also run this program when there are changes to organization hierarchies and
you want to reflect those changes in your reports. Reports will not display accurate
information if you do not run this program periodically to update the summary tables.

You should therefore ensure that the concurrent program is run at regular intervals, for
example, every day or every week in order to collect any changed data.
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If a system failure occurs, you must restart the program

HRI Load All Supervisor Hierarchies
The HRI Load All Supervisor Hierarchies concurrent program populates the Supervisor
Hierarchy Summary Table with current and historic supervisor hierarchy data

Note: The program only collects the relationships between primary
assignments in order to structure the supervisor hierarchy.

Parameters

HRI Load All Supervisor Hierarchies concurrent program has the following parameters:

• Full Refresh – Yes / No

If you set Full Refresh to Yes, the program will delete all information previously
held in the summary table, and will recalculate the supervisor hierarchy history
for the entire collection date range specified (see the Collect From Date / Collect
To Date parameters).

If you set Full Refresh to No, the program will delete none of the existing table
information. It will update the summary table incrementally with any supervisor
hierarchy changes that occurred within the collection date range specified (see the
Collect From Date / Collect To Date parameters).

The program runs faster if you set the Full Refresh to No.

The default value of this parameter is Yes the first time the program is run, and
No thereafter.

• Collect From Date / Collect To Date

These parameters define the start and end dates of the collection range. The program
will store any supervisor changes occurring (date effectively) between these dates
in the summary table.

This date range initially defaults to be the last five years. Thereafter the Collect
From Date defaults to the last Collect To Date and the Collect To Date defaults to
the current date

Run frequency

At implementation, run the concurrent request, HRI Load All Supervisor
Hierarchies, with the following parameter values:

Parameter Implementation Value

Collect From Date The earliest date required for supervisor
information (default is five years previous)

Collect To Date The current date (default)

Full Refresh Yes (default)

After implementation, run the HRI Load All Supervisor Hierarchies concurrent program
infrequently in full refresh mode, and frequently in incremental mode to capture and
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report on supervisor hierarchy changes in your enterprise (see the discussion on Full
Refresh, above).

If a system failure occurs, you must restart the program

Error Handling

Loops in the supervisor hierarchy will cause the program to print an error message
in the concurrent program log. A loop will occur if, for example, A supervises B, B
supervises C, and C supervises A. In this case, the program will enter the person-IDs
of the supervisors in the loop in the log.

Corrupt data may also produce error messages in the concurrent program log, for
example, where an assignment has two date-tracked records that overlap, as shown in
the table below:

Assignment With 2 Date-Tracked Records

Assignment Number Start Date End Date Organization

10 1 Jan 2000 24 Apr 2000 Organization 1

10 1 Apr 2000 31 Dec 2000 Organization 2

In this example, the assignment records overlap on 1st to 24th April. To correct this
situation, you should find the correct date of the organization transfer, and update the
assignment record. If, for example, the transfer occurred on the 25th April, the data
should be corrected to:

Corrected Assignment With 2 Date-Tracked Records

Assignment Number Start Date End Date Organization

10 1 Jan 2000 24 Apr 2000 Organization 1

10 25 Apr 2000 31 Dec 2000 Organization 2

HRI Load Workforce Measurement Value History
Many reports use Workforce Measurement Values (WMVs), for example, Workforce
Losses, Workforce Gains, and Workforce Count. WMVs include headcount and full-time
equivalent (FTE) assignment budget values. Calculation and collection of this data could
involve repeatedly running FastFormula for each assignment every time a report is
run, which is expensive and increases the time taken to display the report.

To reduce the number of times the FastFormula is run, a summary table exists which
holds a history of the FTE and headcount WMVs for all assignments over the collection
date range. The table ensures you are getting the best possible performance from your
reports.

You need to populate the summary table with the WMVs used by your reports. To
populate the table, you need to run the concurrent program HRI Load Workforce
Measurement Value History.
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The HRI Load Workforce Measurement Value History request is not used by all reports;
some reports still calculate WMV at the time of running.

Parameters

The concurrent program HRI Load Workforce Measurement History uses the following
parameters:

• Full Refresh – Yes / No

If you set Full Refresh to Yes, the program will delete all information previously held
in the summary table, and will recalculate the WMV history for all assignments over
the entire collection date range specified (see the Collect From Date / Collect To Date
parameters). Use this mode the first time you run the program.

If you set Full Refresh to No, the program will delete none of the existing table
information. It will update the summary table incrementally with any WMV
changes that occurred within the collection date range specified (see the Collect
From Date / Collect To Date parameters).

The program will run faster if you set the Full Refresh to No.

The following constraints apply:

• If WMVs are updated in the forms interface, the summary table will not reflect
this change until you re-run the program, and only if you include the effective
date of the correction (not the actual date the correction was made).

• The summary table will not reflect historical changes if you run the program in
incremental mode.

For example, if the collection date range includes today but does not include
last year, the program will not pick up changes made today that update WMVs
date-effectively last year.

• The program will only transfer corrections to WMV data (as opposed to
updates, where historical data is retained) to the summary table when you
run the program in full refresh mode.

Due to these constraints you should run the full refresh program weekly
or monthly to ensure that the WMV history table is correct. If there are no
corrections, deletions, or historical/backdated changes, (for example, if you
implement WMVs by a FastFormula only, and do not directly store values for an
assignment using the forms interface) running the incremental update at consecutive
time periods will keep the table up to date.

The default value of this parameter is Yes the first time you run the program, and
No thereafter.

• Collect From Date / Collect To Date

This parameter defines the start and end dates of the collection range. The program
stores any WMV changes occurring (date effectively) between these dates in the
WMV summary table.

This date range initially defaults to be the previous year. Thereafter the Collect
From Date defaults to the last Collect To Date and the Collect To Date defaults to
the current date.

• Collect FTE (Yes / No)
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This parameter defines whether or not you wish to collect or update the WMV
summary table with Full Time Equivalent values.

The default value for Collect FTE is Yes.

• Collect Headcount (Yes/No)

This parameter defines whether or not you wish to collect or update the WMV
summary table with Headcount values.

The default value for Collect Headcount is Yes.

Run frequency

On implementation, run the concurrent request HRI Load Workforce Measurement
Value History with the following parameters:

Parameter Implementation Value

Collect From Date The earliest date required for WMV
information.

Collect To Date The current date (default)

Full Refresh Yes (default)

Collect FTE Yes (if FTE is used in reporting)

Collect Headcount Yes (if Headcount is used in reporting)

Thereafter, Oracle recommends that you run the HRI Load Workforce Measurement
Value History concurrent program monthly or weekly to capture and report on workforce
measurement value changes in your enterprise (see discussion on Full Refresh below).

If a system failure occurs, you must restart the program.

HRI Load All Generic Hierarchy Versions
Some US specific Discoverer workbooks use a ’Vets, EEO, AAP, OSHA, Multi Work Sites’
hierarchy. They require information about the current generic hierarchy.

The concurrent program HRI Load All Generic Hierarchy Versions calculates the
required data and stores it in the Generic Hierarchy Summary table ready for use by
the workbooks. These workbooks will only work if you have set up these generic
hierarchies and run this concurrent program.

For further information on HRMS Generic Hierarchies see EEO-1 and VETS-100
Reporting in Oracle HRMS, available on Oracle Metalink.

The HRI Load All Generic Hierarchy Versions program collects all generic hierarchies of
type “Vets, EEO, AAP, OSHA, Multi Work Sites” (system code FEDREP) across all your
business groups. The program stores the data in the Generic Hierarchy Summary table.

Parameters

The HRI Load All Generic Hierarchy Versions concurrent program has no parameters.
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Run frequency

Run the HRI Load All Generic Hierarchy Versions concurrent program at
implementation.

You must also run this process when there are changes to the generic hierarchies and
you want to reflect those changes in your reports. Reports will not display accurate
information if you do not run this process periodically to update the summary tables.

You should therefore run the concurrent program at regular intervals, for example, every
day or every week in order to collect any changed data.

If a system failure occurs, you must restart the process.

Workforce Calculation
Workforce is one of the key areas of your enterprise you can investigate using the
Workforce Intelligence reports.

Workforce is not necessarily a count of the number of employees within your
enterprise. Instead, it is a count based on employee assignments and budget
measurement type.

Workforce calculation always depends on a budget measurement type. When running a
report you select the budget measurement type from a parameter. If you enter targets for
the predefined workforce performance measures they are either based on the headcount
(HEAD) or Full Time Equivalent (FTE) budget measurement type.

Some reports measure both headcount and Full Time Equivalent.

You can set budget measurement types and assignment measurement values for each
employee assignment within Oracle Human Resources. When the report or performance
measure runs, the workforce is calculated using this budget value.

If you have not entered a default budget measurement type and an assignment budget
value, and a Business Group default does not exist, then the reports count workforce
using Oracle FastFormula.

How Your Workforce is Counted
HRMSi provides two predefined formulas that reports use to calculate workforce if you
do not enter assignment budget values for assignments. They are described below.

If you want to customize how workforce is counted, use Oracle FastFormula to copy
and amend the predefined formulas. Reports will then use your customized version
instead of the predefined formula. See: Customizing Workforce Calculations using
Oracle FastFormula, page 4-16

Note: Reports only use Oracle FastFormula to calculate workforce
if you do not have an assignment budget value entered for an
assignment. Oracle recommends setting up an assignment budget value
for each employee assignment.

Predefined Formulas

HRMS provides two predefined workforce formulas:

• TEMPLATE_HEAD

• TEMPLATE_FTE
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The TEMPLATE_HEAD formula calculates the headcount value as follows:

If the assignment is a primary assignment, a default value of 1 is used. Otherwise, the
assignment is ignored.

The TEMPLATE_FTE formula uses the employment category to calculate the Full
Time Equivalent value as follows:

• If the employment category is Full Time, the value is taken as 1.

• If the employment category is Part Time, the formula uses the standard
working hours for the assignment and compares them to those on either the
position, organization, or business group to determine the value for the full–time
equivalent.

• If the employment category is not set up, the assignment is ignored.

The TEMPLATE_FTE formula uses the predefined meanings set up for the Lookup types
EMP_CAT and FREQUENCY.

The following table lists the lookup codes and meanings for EMP_CAT (Employment
Category).

Lookup Codes and Meanings for EMP_CAT (Employee Category)

Lookup Code Lookup Meaning

FR Full-time-Regular

FT Full-time-Temporary

PR Part-time-Regular

PT Part-time-Temporary

The following table lists the lookup codes and meanings for FREQUENCY.

Lookup Codes and Meanings for FREQUENCY

Lookup Code Lookup Meaning

D Day

HO Hour

W Week

If you update a lookup meaning, you must copy and amend the predefined
TEMPLATE_FTE formula.

For example, the predefined TEMPLATE_FTE has the following lines, which reference
two of the Lookup meanings for EMP_CAT:
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/* If assignment is Full Time then FTE=1 */
IF hri_asg_employment_category_code = ’FR’
OR hri_asg_employment_category_code = ’FT’ THEN
fte = 1

However, you should consider performance before customizing the TEMPLATE_HEAD
formula. The TEMPLATE_HEAD FastFormula calculates the Headcount value based on
whether the assignment is primary or not (1 if primary, 0 otherwise). In some cases, a
report can determine this value directly, and so does not need to use the formula. This
can improve report performance considerably where a large number of FastFormula
calculations would be required.

This bypass is not available if you are using a customized version of the
TEMPLATE_HEAD FastFormula as the logic may vary.

Configuring Workforce Calculations Using Oracle FastFormula
Typically you set up an assignment budget value for each employee assignment, and
reports use this value to calculate workforce numbers. However, if you do not enter an
assignment budget value for an assignment, reports use a formula to calculate workforce.

By default reports use the TEMPLATE_FTE and TEMPLATE_HEAD formulas. Copy
and amend these formula templates to change the way you calculate workforce, or to
report on other budget measurement types.

Important: If you copy and amend formulas, you must do so for all
business groups within your enterprise. If you are using the default
template formulas, this does not need to be copied to other business
groups.

To configure workforce calculations:
Use the Formula window.

1. Select either the TEMPLATE_HEAD or TEMPLATE_FTE formula.

2. Click on Edit and copy the formula body.

3. Create a new formula called either BUDGET_HEAD or BUDGET_FTE, depending
on which template you are copying.

4. Click on Edit and paste in the contents of the template you have copied.

5. Edit the formula code as required.

For further information on naming and amending these formulas, see: Workforce
Calculation, page 4-14

6. Compile the new formula.

Repeat the above steps for each business group within your enterprise.

Entering A Conversion Rate Type
Many Workforce Intelligence reports display financial information, such as salaries. To
enable the reports to convert salaries into your selected currency, you need to enter a
Conversion Rate Type.
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Set the Conversion Rate Type to whatever rate you have set for the profile option
BIS: Primary Rate Type.

Use the Table Values window.

To enter a conversion rate type:
1. Query EXCHANGE_RATE_TYPES in the Table field.

2. Enter BIS in the Exact field.

3. Enter the conversion type you want HRMS reports to use in the Value field, such
as spot type. This must match the rate used by the BIS: Primary Rate Type profile
option.

4. Save the conversion rate type.

Workforce Intelligence now uses the conversion rates set up in the General Ledger Daily
Rates window for the conversion rate type you have selected.

Amending the Default Training Hours
To ensure that reports and workbooks calculate the correct hours for your training events
you can customize the predefined formula.

Use the Formula window.

To amend the default training hours:
1. Copy the predefined template formula TEMPLATE_BIS_TRAINING_CONVERT_

DURATION.

2. Name the new formula BIS_ TRAINING_CONVERT_DURATION.

If you do not name the formula correctly, the reports and workbooks cannot use it.

3. Replace the number of hours a training event runs in a day.

Example
For example, if you record the duration of a training event in days, and within your
training organization a day is 10 hours:

In the predefined formula the number of hours are set as follows:

hours_per_day = 8

To set the number of hours to 10, change the code to:

hours_per_day = 10

4. Compile the new formula.

Adding Additional Training Time Periods
If you have defined your own time periods using the FREQUENCY Lookup you must
copy and amend the predefined formula. If you do not add your additional time
periods to the formula the hours for these events will not be included in the report
and workbooks.

Use the Formula window.

Administering Workforce Intelligence 4-17



To Add Training Time Periods:
1. Copy the predefined template formula TEMPLATE_BIS_TRAINING_CONVERT_

DURATION.

2. Name the new formula BIS_ TRAINING_CONVERT_DURATION.

If you do not name the formula correctly, reports and workbooks cannot use it.

3. Update the formula to add the code.

Example
For example, if you set up a time period called Fortnight using the Lookup code of F
(Fortnight), you need to amend the formula as follows:

/* Main Body of Formula */
hours_per_day = 8
hours_per_week = hours_per_day * 5
hours_per_fortnight = hours_per_week * 2
hours_per_month = hours_per_week * 4.225
hours_per_year = hours_per_month * 12

/* Calculate Duration in Hours */
IF (from_duration_units = ’Y’) THEN

hours = from_duration * hours_per_year
ELSE IF (from_duration_units = ’M’) THEN

hours = from_duration * hours_per_month
ELSE IF (from_duration_units = ’F’) THEN

hours = from_duration * hours_per_fortnight
ELSE IF (from_duration_units = ’W’) THEN

hours = from_duration * hours_per_week
ELSE IF (from_duration_units = ’D’) THEN

hours = from_duration * hours_per_day
ELSE IF (from_duration_units = ’H’) THEN

hours = from_duration
ELSE

hours = 0

/* Calculate Duration in desired units */
IF (to_duration_units = ’H’) THEN

to_duration = hours
ELSE IF (to_duration_units = ’D’) THEN

to_duration = hours / hours_per_day
ELSE IF (to_duration_units = ’W’) THEN

to_duration = hours / hours_per_week
ELSE IF (to_duration_units = ’F’) THEN

to_duration = hours / hours_per_fortnight
ELSE IF (to_duration_units = ’M’) THEN

to_duration = hours / hours_per_month
ELSE IF (to_duration_units = ’Y’) THEN

to_duration = hours / hours_per_year
ELSE

to_duration = 0
RETURN to_duration

4. Compile the new formula.
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Granting Business Area Access
The SYSADMIN user and users with a valid HRMS responsibility automatically have
access to all HRMS Discoverer business areas.

You can grant access to specific business areas for users or responsibilities. This enables
users to create or view workbooks only in the business areas they have access to.

Typically, you provide the majority of report users with read-only access to specific
business areas, thereby enabling them to only view workbooks in those business areas.

1. Grant access to business areas for users or responsibilities.

For a detailed explanation of how to grant access to business areas, see: Set Privileges
for the Current EUL in Oracle Discoverer Administrator Administration Guide.

Check the Vacancy Status Options
The vacancy reports only count vacancies as closed if they have the system vacancy
status of CLOSED. However, if your system was installed prior to 11.5.9, you may have
two vacancy status options that users can use to close a vacancy: Closed, and Closed
(1). The Closed option has a system vacancy status of C, whereas the Closed (1) option
has a system vacancy status of CLOSED.

To ensure the vacancy reports return accurate results, you need to obsolete the old
vacancy status option of Closed that returns the status of C. You can also update the
name of the Closed (1) option.

If you want reports to include previously closed vacancies, you may also need to update
their system vacancy status from C to CLOSED.

Use the Application Utilities Lookups window.

To update the Vacancy Status Options:
1. In Enter Query mode, enter VACANCY_STATUS in the Type field, and execute a

query.

Both Closed and Closed (1) may appear in the list of vacancy status options.

2. If both options appear, insert an end date of the current date against the Closed
option that has a code of C.

This will remove that Closed option from the list of vacancy status options, and
prevent C being used as a system vacancy status.

3. In the Meaning field, rename the Closed option to something else, for
example, Closed_old.

4. In the Meaning field, rename the Closed (1) option to Closed. Ensure is has the
code of CLOSED.

What's Next
If necessary, update the system vacancy status of previously closed vacancies from C
to CLOSED.
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Populating the Organization Hierarchy Summary Table
Reports that use organization hierarchy retrieve your organization structure from the
HRI_ORG_HRCHY_SUMMARY table. Use the HRI Load All Organization Hierarchy
Versions concurrent program to collect your organization hierarchy structures into the
summary table. The process will perform a full refresh of all the data.

Use the Submit Requests window.

To populate the Organization Hierarchy Summary table:
1. Select Single Request in the Submit a New Request window.

2. In the Name field, select HRI Load All Organization Hierarchy Versions and
submit your request.

What's Next
Define when you want to run this process using the schedule options.

For full information on this concurrent program, see HRI Load All Organization
Hierarchy Versions, page 4-9

Populating the Supervisor Hierarchy History Table
All reports that use supervisor hierarchy retrieve your current and historic supervisor
hierarchy data from the Supervisor Hierarchy Summary table. Use the HRI Load All
Supervisor Hierarchies concurrent program to collect your organization hierarchy
structures into the summary table.

Use the Submit Requests window.

To populate the Supervisor Hierarchy History table:
1. Select Single Request in the Submit a New Request window.

2. In the Name field, select HRI Load All Supervisor Hierarchies.

3. At implementation, set Full Refresh to Yes in the Parameters window.

4. Submit your request.

What's Next
Define when you want to run this process using the schedule options.

For full information on this concurrent program, see HRI Load All Supervisor
Hierarchies, page 4-10

Populating the Workforce Measurement Value History Table
Many reports use Workforce Measurement Values (WMVs), for example, Workforce
Losses, Workforce Gains, and Workforce Count. WMVs include headcount and full-time
equivalent (FTE) assignment budget values.

Populate the Workforce Measurement Value History table with the WMVs used by your
reports. To populate the table, you need to run the concurrent program HRI Load
Workforce Measurement Value History.

4-20 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Use the Submit Requests window.

To populate the Workforce Measurement Value History table:
1. Select Single Request in the Submit a New Request window.

2. In the Name field, select HRI Load Workforce Measurement Value History.

3. At implementation, use the following parameter values:

Parameter Implementation Value

Collect From Date The earliest date required for WMV
information.

Collect To Date The current date (default)

Full Refresh Yes

Collect FTE Yes (if FTE is used in reporting)

Collect Headcount Yes (if Headcount is used in reporting)

4. Submit your request.

What's Next
Define when you want to run this process using the schedule options.

For full information on this concurrent program, see HRI Load Workforce Measurement
Value History, page 4-11

Populating the Generic Hierarchy Summary Table
Some US specific Discoverer workbooks use a ’Vets, EEO, AAP, OSHA, Multi Work Sites’
hierarchy. They require information about the current generic hierarchy.

Run the concurrent program HRI Load All Generic Hierarchy Versions to calculate
the required data and store it in the Generic Hierarchy Summary table ready for use
by the workbooks. These workbooks will only work if you have set up these generic
hierarchies and run this concurrent program.

Use the Submit Requests window.

To populate the Generic Hierarchy Summary table:
1. Select Single Request in the Submit a New Request window.

2. In the Name field, select HRI Load All Generic Hierarchy Versions.

3. Submit your request.

What's Next
For a full discussion of the HRI Load All Generic Hierarchy Versions concurrent
program, see HRI Load All Generic Hierarchy Versions, page 4-13
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Collecting Organization Hierarchy Structures
The BIS Load Organization Hierarchy Summary Table concurrent program creates the
organization hierarchies on which the Discoverer End User Layer folder Organization
Rollup – Current is based. If you create any reports based on the Organization Rollup –
Current folder, you need to run this program to collect organization hierarchy structures
into the HRI_ORG_PARAMS and HRI_ORG_PARAM_LIST tables.

1. Define Primary Organization Hierarchy

Prior to running the concurrent program, ensure you have at least one organization
hierarchy marked as the primary hierarchy. If no hierarchy is nominated as the
primary hierarchy, BIS Load Organization Hierarchy Summary Table will not pick
up your hierarchies.

See: Creating Organization Hierarchies, Enterprise and Workforce Management Guide

2. Add BIS Load Organization Hierarchy Summary Table to a Reque st Group

Add the BIS Load Organization Hierarchy Summary Table concurrent program to
a request group.

See: Adding BIS Load Organization Hierarchy Summary Table to a Request Group,
page 4-22

3. Populate the Organization Hierarchy

Schedule and run your request set that contains the BIS Load Organization Hierarchy
Summary Table concurrent program using the Submit Request Set window.

See: Populating the Organization Hierarchy Tables, page 4-22

Adding BIS Load Organization Hierarchy Summary Table to a Request
Group

If you have created reports based on the Organization Rollup – Current folder in
the Discoverer End User Layer, you must run the BIS Load Organization Hierarchy
Summary Table concurrent program to populate organization hierarchy summary tables.

See: Populate the Organization Hierarchy Tables, page 4-22

Prior to running this program you must add it to a request group. The request group
should be used by the responsibility that runs the concurrent program.

Use the Request Groups window.

To add BIS Load Organization Hierarchy Summary Table to a req uest group:
1. Enter the name of the group to which you want to add the program.

2. Enter Oracle Human Resources in the Application field.

3. Select Program as the Request Type.

4. In the Name field, select BIS Load Organization Hierarchy Summary Table

5. Save the change to the request group.

Populating the Organization Hierarchy Tables
If you have created reports based on the Organization Rollup – Current folder in the
Discoverer End User Layer, you must populate organization hierarchy summary
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tables. Use the BIS Load Organization Hierarchy Summary Table concurrent program
to populate the tables.

Prior to running the concurrent program, ensure you have at least one hierarchy
marked as the primary hierarchy. See: Creating Organization Hierarchies, Oracle HRMS
Enterprise and Workforce Management Guide

Prior to running this program you must also add it to a request group. See: Adding BIS
Load Organization Hierarchy Summary Table to a Request Group, page 4-22

Use the Submit Request Set window.

To populate the Organization Hierarchy tables:
1. Select Request Set in the Submit a New Request window.

2. In the Request Set field, select the name of your request set that includes BIS Load
Organization Hierarchy Summary Table and submit your request.

What's Next
Define when you want to run this request set using the schedule options.

For further information on the BIS Load Organization Hierarchy Summary Table
concurrent program, see BIS Load Organization Hierarchy Summary Table, page 4-9

Using Attachments
You can attach short comments, word processed documents, images, video, OLE
objects, or Web pages to many records in Oracle HRMS. For example, you could attach
a resume to an applicant record, a vacancy announcement to a Request for Personnel
Action, and a position description to a position record.

Each record can have one or more attachments, and you can copy attachments from one
record to another. You can store the attachments in the database or in your file system.

To view attachments or add new attachments:
Click the Attachments icon. By default, clicking the attachments icon displays a
Comments window where you can enter text up to 2000 characters. This is the
Comments facility available in earlier releases of Oracle HRMS. If you want to replace
this facility with the ability to attach multiple items, ask your system administrator to set
your user profile option HR:Use Standard Attachments to Yes.

The Federal HR entities that support attachments are:

• Absence

• Absence Type

• Address

• Application

• Assignment

• Balance (Oracle Payroll)

• Batch Header

• Booking
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• Budgets

• Budget Version

• Calendar

• Career Path

• Collective Agreements

• Consolidation Set (Oracle Payroll)

• Contact Relationship

• Contracts

• Customization

• Element

• Element Entry

• Element Link

• Element Set

• Event

• Grade

• Grade Rate

• Job

• Job Evaluation

• Job Requirement

• Letter Type

• Monetary Unit (Oracle Payroll)

• Organization

• Organization Payment Method

• Organization Hierarchy

• Pay Scale

• Payroll Process (Oracle Payroll)

• Period of Service

• Person

• Person Analysis/Special Information

• Personal Payment Method

• Position

• Position Description

• Position Hierarchy

• Recruitment Activity

• Request for Personnel Action
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• Requisition

• Salary Basis

• Salary Proposal

• Salary Proposal Component

• Secondary Assignment Status

• Special Information Type

• Status Processing Rules (Oracle Payroll)

• Vacancy

• Valid Grade

Using Inquiry Windows and Folders
You can define public folders, which all users can view, as well as private folders for
your own use.

Inquiry Window Information Provided

Assignments Folder Lists of assignments in a folder

Breakdown Folder AA/EEO Breakdown report

People Folder Lists of people in a folder

Salary Management Folder List of assignments with their current approved
salary and proposed new salary

Position Occupancy Folder Lists of people who have held a selected
position, or are applying for it, and the dates of
their occupancy

List Assignments Assignments that match the assignment
components you specify for current
applicants, employees, or both

List People by Assignment People whose assignments match the
assignment components you specify for
current or former applicants, employees, or
both

List Employees by Organization All employees assigned to one organization
and, optionally, to all organizations below it in
a specified hierarchy

Assignment History The dates of assignments and periods of
service for an employee who has had more
than one assignment

NOTE: use DateTrack History on the
Assignment window to see historical changes
to one assignment

List Employees by Position All employees assigned to a specified position
or organization and job
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Inquiry Window Information Provided

List Employees by Position Hierarchy Current holders of positions at and below a
specified position in a position hierarchy

View Employee Grade Comparatio The amount employees receive for a specified
element as a percentage of the mid-value of
their grade rate range

List Employees by Absence Type All absences of a particular absence type or
category within, optionally, a specified time
period

View Employee Absence History Periods of absence for a specified employee

List People by Special Information All people for whom you have entered details
about a specified special information type

List Employees by Element All employee assignments receiving a specified
compensation element within a given time
period

View Element Entry History for Employee The history of entries of one or more elements
for an employee assignment

List Position Budget Variance Variances between the number of actual
position holders and the values entered in a
specified budget for positions below a chosen
position in a hierarchy

List Budget Variance by Organization Variances between the number of actual
position holders and the values entered
in a specified budget for all positions
in organizations at and below a chosen
organization in a hierarchy

View Employee Benefits View benefit plans on which an employee
is enrolled and the coverage level and
contributions for each plan

View Vacancies Vacancies matching assignment components
and other criteria you select

1.

Running Predefined and User Defined Reports
There are a number of predefined reports that you can use immediately without any
further set up. They have a predefined format but you can choose which records to view
by entering a set of parameters when you submit the report.

These reports run in batch mode: you submit them for processing in the Submit Requests
window and can view their progress using the View Requests window. The requests
are handled by a concurrent manager so you can continue working online while your
request is processed.
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You can schedule the reports to run regularly and you can group them with other reports
and processes to run as a set. You can also control access to the reports and control their
printing. For example, the system administrator might want to ensure that users in one
location always print their reports on a local printer.

Report Name Information Provided

AA/EEO Breakdown Government required ethnicity and gender
breakdown report by Occupational Category
or Pay Plan

EEOC Form 462 Government required summary of EEO
complaints

Absences Absence details for an employee or
organization, for some or all absence types

Assignment Status All employees, applicants, or both assigned to
selected work structures

Batch Print Notification of Personnel Action Prints SF-50s in batch mode

CPDF Dynamics Report Record of the personnel data changes that
occurred for the employee during a reporting
period

CPDF Organization Component Tracking
Report

Record of the organizational codes, titles, and
hierarchical relationships for organizations
within an agency as of the last day of the
quarterly reporting period

CPDF Status Report Record of each employee’s personnel data as
of the ending date of a fiscal quarter

EEOC Form 462 Government required summary of EEO
complaints

SF-113A-Federal Civilian Employment Report Summary of federal civilian employment,
payroll, and turnover

Current and Projected Progression Point Values The expected results of running the Increment
Progression Points process, that is, the
projected point and value changes for a group
of employees

Duty Station Conversion Moves employees from an old to a new
Location, updates the employes’ Assignment
records, updates Position records, both
occupied and vacant, updates Organization
Location information

Element Link Details The eligibility criteria for an element or a group
of elements

Employee Increment Results The actual results of running the Increment
Progression Points process, that is, progression
point and value changes for a group of
employees
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Report Name Information Provided

Employee Organization Movements New hires, terminations, transfers in and
transfer out of a selected organization, or
organization hierarchy

Employee Payroll Movements New hires, terminations, transfers in and
transfer out of a selected payroll

Employee Summary Addresses, contacts, period of service,
assignments, special information, personal
payment methods, and element entries for a
selected employee

Full Applicant Details Applications and applicant interviews for one
applicant

Full Assignment Details Assignment information including periods of
service, payment methods, and element entries
for one employee

Full Personal Details Report Set Person details, applicant details, assignment
details, and work details for one employee

Full Person Details Addresses and information entered in the
Person window, such as name, date of
birth, nationality, and work telephone number
for one employee

Full Work Details Miscellaneous work information, including
special information, absences, recruitment
activities, and contacts for one employee

Job and Position Skills Matching Lists of employees, applicants, or both that
meet some or all skill requirements of a job or
position

Location Occupancy Report Lists employees who currently or have at one
time been assigned to a Location

Mass Realignment De-selection Lists employees deselected in a criteria for
realignment

Mass Realignment PA Listing for All Notification of Personnel Action in list form
for employees selected for a salary adjustment

Mass Realignment Listing for Employee Notification of Personnel Action in list form for
an individual employee selected for a salary
adjustment

Mass Realignment Preview Lists employees selected in a criteria for a
salary adjustment

Mass Salary De-selection Lists employees deselected in a criteria for a
salary adjustment

Mass Salary PA Listing for All Notification of Personnel Action in list form
for employees selected for a salary adjustment
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Report Name Information Provided

Mass Salary Listing for Employee Notification of Personnel Action in list form for
an individual employee selected for a salary
adjustment

Mass Salary Preview Lists employees selected in a criteria for a
salary adjustment

Mass Transfer In De-selection Lists employees deselected in a criteria for a
Transfer In action

Mass Transfer In PA Listing for All Notification of Personnel Action in list form
for employees selected for a Transfer In action

Mass Transfer In Listing for Employee Notification of Personnel Action in list form for
an individual employee selected for a Transfer
In action

Mass Transfer In Preview Lists employees selected in a criteria for a
Transfer In action

Mass Transfer Out De-selection Lists employees deselected in a criteria for a
Transfer Out action

Mass Transfer Out PA Listing for All Notification of Personnel Action in list form for
employees selected for a Transfer Out action

Mass Transfer Out Listing for Employee Notification of Personnel Action in list form for
an individual employee selected for a Transfer
Out action

Mass Transfer Out Preview Lists employees selected in a criteria for a
Transfer Out action

Notification of Personnel Action (SF50) Prints the standard Notification of Personnel
Action for an approved Request for Personnel
Action

Position Description Lists the details of an approved position
classification

Position Hierarchy The positions (and optionally their holders)
below a selected position in a particular
hierarchy

Reduction in Force Retention Register Lists selected employees

Request for Personnel Action (SF-52) Prints the contents of the employee’s Request
for Personnel Action

Requisition Summary Applicants and their interview schedules for a
selection of vacancies

Salary Review Current, past, and proposed salaries for a
selected list of employees
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Report Name Information Provided

SF-113A-Federal Civilian Employment Report Summary of federal civilian employment,
payroll, and turnover

Staffing Budget Details Actual staffing level with budgeted levels over
a specified period

You can create your own reports using Oracle Reports or SQL*Plus or another tool of
your choice. You can register them with Application Object Library. This means you can
run them from the standard Submit Requests window, and you can schedule them in
report sets with other reports and processes.

1.

Defining QuickPaint Reports
You can design QuickPaint reports in the Define QuickPaint Report window.

In the Report Definition area, you can enter free text to introduce the report and to
label the information that the report extracts from the database. You can also select
database items, which are tags representing the information to be extracted from the
database. When you run the report, the database item names are replaced by the
appropriate data for the assignment or set of assignments for which the report is run.

You must be careful how you position the database items so that QuickPaint interprets
them correctly and formats the report in the layout you require.

To define a QuickPaint Report:
1. Enter a name, and optionally a description, of the report.

The Protected field is display only; some reports provided by localization teams are
protected against edits.

2. In the Report Definition area, enter free text exactly as you want it to appear on
the report.

3. To select database items, choose the Show Items button and run a query to display a
list of database items, then select and copy items to the Report Definition area.

Notice that the database item name must begin with an ampersand (&). Names
without an ampersand are treated as free text.

4. Save the report definition.

Positioning Items
If you want to add free text immediately after a database item, you must separate
it from the database item with at least one space. Otherwise QuickPaint reads the
database item as free text.

Both free text and database items appear in the report results on the line on which you
painted them in the Report Definition area. They also generally appear in the column in
which you painted them. However, it might be that the data replacing a database item
name is long enough to push later items on the same line to the right.

For example, if you paint database items and free text like this:
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&ASG_JOB in &ASG_ORG

the report results print like this:

Technician in Biochemistry

Scientific Officer in Biochemistry

Notice that, in the second result, the free text ’in’ is pushed to the right and one space is
entered before it.

If you know the number of the column in which you want text or a database item to
appear, you can enter it like this:

&ASG_JOB &32in &ASG_ORG

However, the text ’in’ will still be pushed to the right if the preceding database item
(&ASG_JOB) extends beyond column 32. If you would prefer the preceding database
item to be truncated, paint the line as follows:

&ASG_JOB &&32in &ASG_ORG

The report results will look like this:

Technician in Biochemistry

Scientific Off in Biochemistry

If you want one space between two database items or between a database item
and text, then paint them separated by a single space. The single space is always
preserved. For example, this definition:

&EMP_FIRST_NAME &EMP_LAST_NAME

gives the following report results:

Alice Hollister

Ray Garcia

Adding Conditions or Calculations to QuickPaint Reports
When you save a report definition, QuickPaint generates a formula to extract the
information required by the report. You can view this formula in the Formulas
window. To query the formula, enter the name of your QuickPaint report.

Formulas generated from QuickPaint definitions do not contain conditional logic or
mathematical computations. If you need these features, query the formula in the
Formulas window and copy it. Edit the copy to add the logic you require.

Important: You should not edit the original QuickPaint formula. Always
edit a copy. Any edits of the original formula are overwritten if you
change the report definition in the QuickPaint Report window.

Running QuickPaint Reports
You run QuickPaint reports from the Run QuickPaint Report window. You can run a
report for one assignment or for a group of assignments.
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To run a report for one assignment:
1. Select the type Assignment.

2. In the Assignment region, select the assignment for which you want to run the report.

3. In the Report field, select the report you want to run.

4. Choose the Run Report button.

The message line tells you when the report is complete.

5. Choose the View Report button to see the report results.

When you run a QuickPaint report, the system runs the formula associated with the
report. The first time you run a report, the system may take several seconds to identify
all of the related data and bring it back to the screen. All subsequent inquiries for other
employees or applicants will run very quickly.

To run a report for an assignment set:
1. Select the type Assignment Set.

2. In the Assignment Set region, select the assignment set for which you want to
run the report.

3. In the Report field, select the report you want to run.

4. Choose the Run Report button.

The message line tells you when the report is complete.

5. Choose the View Report button to see the report results.

Defining Concurrent Process Custom Reports
The Custom Reports function provides a generic reporting capability that makes use of a
single report to print out a custom definition. This report is called PERGENRP.

The report is registered as a concurrent process and prints, in landscape format, the
contents of the temporary table PER_GENERIC_OUTPUT_REPORT.

This table contains the individual components of a custom report and is populated by
the PL/SQL package PERGENRP.pkb, stored in $PER_TOP/admin/sql. This package is
executed when you select the Generate Report button on the Custom Reports window.

To submit a Custom Report:
1. Navigate to the Custom Reports window.

2. Select the report by name.

3. Enter any parameters for this report.

Important: Parameter values are not validated until you choose
the Generate Report button.

4. Choose the Generate Report button

The default for the report is to print the output automatically. It is a System
Administrator task to set default printers for all users, or to reset this option on the
Concurrent Program window.
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Creating New Report Formats
A special feature of Custom Reports is that you do not need to create multiple
reports. You modify the generic package (PERGENRP.pkb) and report to provide
additional formats and parameters.

Three sample report formats are provided, each with a different set of parameters:

• PERCS001 - Custom Report 1

There is one parameter: Vacancy. The format in PERGENRP is Full Name of Applicant
and Gender.

• PERCS002 - Custom Report 2

Parameters are Vacancy and Gender. The format in PERGENRP is Full Name of
Applicant in uppercase.

• PERCS003 Custom Report 3

Parameters are Vacancy, Gender and Marital Status. The format in PERGENRP is
Full Name of Applicant, Gender and then Full Name in uppercase.

You can edit the generic package to change:

• Report Title Page

• Header

• Footer

• Body Text

After you have modified the package, you need to register a new custom report, with the
parameter set for that report. This is a task for the System Administrator.

To register a new Custom Report with parameters:
1. Navigate to the Concurrent Programs window.

2. Enter the name of the Custom Report as the Program.

3. Enter a short name for the Custom Report.

Important: You must start the short name with PERCS. This will
limit the list of values available to users in the Custom Report
window.
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5
Maintenance of Federal Data

Maintenance of Federal Data Overview
The Federal Maintenance windows contain information such as Remarks and Legal
Authority Codes and process methods used by the RPA. In general, only the system
administrator defines information in these windows. Information defined in one
window is often viewable in another so that you can understand and view the
relationship of data. You can also search for information in these windows using the
application’s selective search and Find window capabilities.

The federal maintenance windows contain the following information:

• Families and NOA Familes: View Nature of Action Codes (NOACs) and their related
nature of Action (NOA) families. See: Nature of Action Families, page 5-3

• NOA Codes and Remarks: Associate Remarks to NOACs. You can associate
several Remarks to a single NOAC, as well as a single Remark to several
NOACs. See: Associating Remarks to NOACs, page 5-9

• NOA Legal Authorities: View current NOACs and each NOAC’s associated legal
authorities; associate legal authorities to your 900 NOACs. See: Maintaining Legal
Authority Codes, page 5-12

• Personnel Office Identifiers: Link the Personnel Office to the group box you defined
in the routing groups and group boxes window and enter Approving Officer’s
name. See: Maintaining Personnel Office ID Information, page 5-6

• Process Methods: Defines the data entry methods on RPA fields such as user
enterable or auto-populated and associates these fields to a specific NOA
family. See: Process Method, page 5-4

Warning: Changing the NOAC order of processing may severely
impact the database when you update records. For example, if you
assign Pay Adjustment NOAC 894 a processing number that falls
below Promotion NOAC 702, the system may incorrectly calculate
the employee’s promotion salary.

• Enter and Maintain Events: Defines productivity data by event
codes, descriptions, and standard completion times. See Setting Up Event Codes,
page 5-7
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Maintenance of Federal Data
The Federal Maintenance Forms store relevant and timely information, such as the
Nature of Action Codes (NOAC) and Remarks.

Does Oracle Federal Human Resources provide a way to manage Office of Personnel
Management (OPM) information?

The product provides maintenance forms to view and update OPM mandated Nature
of Action Codes and Descriptions, Remarks, and Legal Authority Codes (LACs). The
forms associate related NOACs with their Remarks and LACs as well as group related
information into appropriate families.

Additionally, agencies can use the forms to enter their own information, such as
agency-specific Remarks.

Is there a way to update OPM Duty Station changes as soon as OPM releases the
udpdates?

You can create new Duty Stations, update existing ones, and terminate (end-date)
Duty Stations manually using a supplied federal maintenance form. After entering the
updates, you can run a process to convert employees from an old to a new location. A
change in Duty Station may affect an employee’s Locality Pay. You can run a report to
identify the assignment records with that Duty Station, and then take appropriate
action, such as processing a Locality Pay Adjustment for those employees.
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Maintenance of Federal Data

Understanding Family Types
Some Nature of Action Codes (NOACs) have one or more family types. The family types
determine different processes. NOACs included in a NOA family share its family types.

For example, the Required family type determines which fields must be completed
before the system updates an RPA. The Conversion to Appointment family is a Required
family type. The NOACs belonging to this family share the same set of required
fields. The Change Schedule and Hours family is not a Required family type, so the
NOACs belonging to this family have different required fields. The following table
describes the family types.

Family Type The NOACs in this family...

Enabled Are valid selections and appear on the List
of Values, such as the Change Families List
of Values.Note: If you disable a family, the
family won’t appear on the List of Values, but
it continues to appear on the Navigator menu
until you remove it from the menu.

Required Have the same required fields that must be
completed before updating to HR. These fields
may include ones located on the RPA and in
the Extra Information flexfields.

Update HR Share the same code for updating the HR
database.

Process Method Control user actions in the field on the RPA
form. For example, the process method
controls whether the user enters data or views
data only.

Request Info Type Display the same Extra Information fields on
the RPA.

NOACs are associated to a NOA family in the Family, Nature of Action window. A
NOAC can belong to more than one family, but the families can’t have the same family
type. For example, a NOAC isn’t associated to more than one Process Method family
type.

Nature of Action Families
The application supports the Nature of Action Codes issued by the Office of Personnel
Management (OPM).

The Navigator menu groups Nature of Actions (NOA) into families of related
actions. The following table describes the family types.
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Family Types

Family type Purpose

Enabled Valid selections that appear on appropriate
List of Values, such as the Change Families List
of Values

Process Method A NOAC can belong to only one Process
Method family. OPM based process rules
specify the type of input for each field:

Non-Enterable (NE)

AutoPopulated (AP)

User Enterable (UE)

Autopopulated User Enterable (APUE)

Request Information Type A NOAC can belong to more than one Request
Information type family. Extra Information
accompanies a specific NOA.

Required fields A NOAC can belong to only one Required
fields family. The OPM requires data entry in
specific fields to process an action.

The application performs edit checks on these
fields before updating the data to the database.

Update HR A NOAC can belong to only one Update HR
family. Business rules run against the data
determine if the data is consistent and passes
the Central Data Personnel File edits.

A NOAC is associated to a NOA family and inherits its family types, such as process
methods. A NOAC may belong to more than one NOA family type, but only to one
family.

For example, the NOAC 815 (Recruitment Bonus) belongs to two NOA family types. It
belongs to the Award/One-Time Payment family for Process Methods, and to the
Recruitment Award and Bonus Information family for Request Information Types and
Required fields.

In this example, when a manager initiates a personnel action for a Recruitment
Bonus, the manager chooses the NOA family Award/One-Time Payment from the
Navigator menu. The application generates an RPA and applies the Award/One-Time
Payment process methods. When the Personnelist enters the specific NOAC (815), the
application applies the Recruitment Award and Bonus Information Required fields
and Request Information Types.

Process Method
The product defines process methods for each Nature of Action (NOA) family based on
the Office of Personnel Management (OPM) process rules. Process methods determine
which fields the user can enter or edit and how the system updates these fields.
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The Process Methods window defines the data entry methods such as user enterable
or auto-populated for the RPA fields and then associate these fields to a specific NOA
family.

The Process Methods window contains two regions. The upper region displays NOA
families. The Process Method region displays RPA fields and defines the process
methods for each NOA family.

Each region has several check boxes. The NOA Family Code region contains two check
boxes: Process Methods and Required. The check box displays the family type assigned
the NOA family in the Families, Nature of Action window.

The Process Method region contains three check boxes: Required, Navigable, and
Enabled that you set for each RPA field.

• Required: The Required check box is available only if the family type is set to
Required. Required means that the field must be completed before the RPA is
updated to HR.

• Navigable: The Navigable check box tells the system that users can tab into the
field. You can choose this check box regardless of the process method. You might
do this to have the users review data such as pay calculations before moving to
the next editable field on another page.

• Enabled: The Enabled check box tells the system to use the process method you
assign to a specific field, or if it’s deselected, to apply the default process method
(Auto Populate User Enterable).

Process Method Overrides
The process methods initially configure the RPA form based on the NOA family
selected. However, other processes also affect the field configuration:

• User access: The Restricted form sets the fields to display or non-display. In
addition, a user’s role may determine whether the user can enter data in a field.

• Required data: The system overrides the field level process method to populate
specific data, such as pay plan information.

• Pay calculations: Data changes in an RPA that affect pay calculation, such as a
change in PRD or grade, override process methods. In addition, API user hooks
for pay calculation permit agencies to enter data in fields usually designated as
auto populated.

• Dual actions: The system references the dual action matrix for field process
methods, not the individual NOAC methods.

Federal Process Log
Use the Federal Process Log window to view the error messages for a given process
that you’re running. As a tool for system administrators, the error log displays errors
encountered in running:

• Future actions (Initiate Future Action process)

• Automatic Within Grade Increases

• Mass Actions
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Errors encountered in Previewing eligibility run results, and reports for
Realignments, Mass Transfers, Mass Salary Adjustments, Reduction in Force
Retention Registers.

See: Using the Federal Process Log, page 5-8

Displaying NOA Families and Codes
There are two regions in the Families, Nature of Action window. The Families region
displays NOA families. The Nature of Action region displays the Nature of Action
Codes (NOACs) and Descriptions for the family you choose in the first region.

To view the NOA Families and Codes:
1. Open the Families, Nature of Action Federal Maintenance Form.

2. To display all possible families, choose Find All from the View menu.

Displaying Process Methods and NOA Families
The Process Methods window displays the NOA family information.

To display the Process Methods window:
1. Open the Process Methods Federal Maintenance Form.

2. To display all possible NOA families, choose Find All from the View menu.

The NOA Family Code region displays the NOA Family Codes and NOA Family
Names. The Process Method region displays the process methods for the selected
family.

Note: You cannot change the process methods assigned to data
fields for seeded NOA families; only for families that you add.

Maintaining Personnel Office ID Information
Use the Personnel Office Identifiers window to link the Personnel Office to the Groupbox
you set up in the Routing Groups and Groupboxes window.

You also use the Personnel Office Identifiers window to enter Approving Officer’s
name. The application enters the Approving Officer’s name, working title, and approval
date on all mass actions, including:

• Automatic Within Grade Increases

• Mass Salary Adjustment

• Mass Realignment

• Mass Transfer Out

• Mass Transfer In

If the application encounters an error when processing one of these actions, it displays
the error message in the Process Error Logs window and routes the RPA to the POI
groupbox for processing.
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To complete the Personnel Office information:
1. Create a routing group and groupbox for each Personnel Office ID, and include at

least one member (the employee you wish to name as Approving Official).

See: Setting up Routing Groups, Groupboxes, and Routing Lists, page 6-5

2. Enter the ID for the Personnel Office.

3. Enter Description text, such as the name of the Personnel Office.

4. Enter the groupbox name that you set up for the Personnel Office in the Routing
Groups and Groupboxes window.

5. Enter the full name for the employee that you want to designate as the Approving
Official.

The employee must be a member of the groupbox selected in step 3.

After entering the Personnel Office ID, you can edit it if necessary, but you cannot
delete it.

Setting up Event Codes
Use the Enter and Maintain Events codes window to:

• Set up Event Codes

• Enter Descriptions

• Enter Standard Completion Times

Note: If you need to capture more information related to a category, you
can extend GHR_US_EVENT_CATEGORIES QuickCode type by
defining other Attributes.

Event Codes have a start and end date and a corresponding description such as
Requisitioned and Cleared to describe the activities associated to those dates. Although
each Event Code belongs to an Event Category, you can set up more than one Event
Code per Category. For example, you might set up several Event Codes to closely track
the steps involved in recruiting and filling a position.

Each RPA that you initiate has an associated Event History window as does each Position
that you create. For more information about entering and reviewing productivity
data while processing and routing an RPA, see Productivity Data, Workforce Sourcing,
Deployment, and Talent Management Guide.

To enter a new event:
1. Open the Enter and Maintain Events code window.

2. Enter a unique value for the event code.

3. Enter a description.

4. Enter a descriptive context for the Start Date, such as Issued.

5. Enter a descriptive context for the End Date, such as Returned.

6. Choose a Category Code.
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7. Enter the number of days in the Standard Completion Time (STC) field that you
estimate an event should take. You can enter fractions of days using up to two
decimals.

You can use this STC metric when creating reports to show that users have
completed events in the estimated time.

8. Enter the Date From and Date To Effective Dates.

9. Choose Enabled.

Entering a Standard Completion Time for a NOAC
You can record the amount of time in days that it takes to process a specific NOAC
in the NOA Codes and Remarks window. You can then create reports that compare
that Standard Completion Time to the actual time recorded in the Routing History
for processing those NOACs.

Using the Federal Process Log
The Error Log is divided into 3 sections. It shows the:

• Request ID, program name, and the date the application entered the error in the log.

The errors are arranged by the log date followed by the program name.

Note: If you want to query the request ID and you do not know the
ID number, you can obtain it from the Concurrent Requests Summary
window.

• Message Name

The Message Name indicates either a subprogram name or an execution point in
the program. If the program does not use a message name, the application leaves
this field blank.

• Text for each message encountered

For future approved actions, the application displays the PA Request ID followed by
the message text. If the application has updated the RPA to the database, it displays
the PA Request ID only, and not the message text.

For preview errors for mass actions, the application precedes the program name
with an abbreviation (MSL for Mass Salary, MTO for Mass Transfer Out, and MTI
for Mass Transfer In) followed by the criteria name.

If you run the mass action from the Concurrent Manager, you can easily locate the
message text in the log by querying using the Concurrent Manager Request ID.

To print the US Federal process log:
1. Display the US Federal Process Log.

2. Choose the Print icon from the toolbar.

The application prints the contents of the log that is visible on the screen.
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Maintaining NOACs and Remarks
Use the NOA Codes and Remarks window to associate Remarks with NOAC. You may
associate multiple Remarks with a NOAC and associate the same Remark to different
NOACs.

This window contains two regions. The upper region displays Nature of Action Codes
and shows the order in which the NOACs are processed. The system references the order
of processing when there is more than one NOAC for an employee on the same effective
date. The system processes the NOAC with the highest priority and returns the others
for Cancellation or Correction to the person who submitted the action for Update to HR.

The Remarks region displays the Remarks for the code you’ve selected in the NOAC
region. You can add or delete Remarks in the Remarks region.

Note: Do not change the NOAC order of processing. Changing the
NOAC order of processing may severely impact the database when you
update records. For example, if you assign Pay Adjustment NOAC 894 a
processing number that falls below Promotion NOAC 702, the system
may incorrectly calculate the employee’s promotion salar.y.

For information about insertion values for NOACs and Remarks, see Insertion Data,
page 5-11.

To display information:
1. Open the NOA Codes and Remarks Federal Maintenance Forms.

2. To display all possible codes, choose Find All from the View menu.

Associating Remarks to NOACs
You associate Remarks to NOACs in the NOA Codes and Remarks window. You can
associate several Remarks to a single NOAC, as well as a single Remark to several
NOACs.

Note: Before associating remarks to NOACs, you must have entered
the Remarks in the Remarks and Description window (Remark Codes,
page 5-10), and if the Remark includes insertion data, have entered that
information as well (Insertion Data, page 5-11).

To associate a Remark to a NOAC:
1. Open the NOA Codes and Remarks Federal Maintenance Form.

2. In the Nature of Action Codes region, choose the NOAC to which you want to
associate the Remark.

3. In the Remarks region, determine where you want the Remark to appear on the
list. Choose the New Record button on the toolbar. An empty row appears below the
Remark you selected.

4. Choose the Remark from the List of Values.

5. Enter a From date that accommodates the historical records that you want to
maintain.

6. Choose Required if the Remark is required for an update to the HR database.
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7. Save your changes.

Note: To associate the Remark with more than one NOAC, enter the
Remark under each NOAC.

Remove a Remark
Use the NOA Codes and Remarks window to remove Remarks.

To remove a Remark from the NOA Codes and Remarks list:
1. Open the NOA Codes and Remarks Federal Maintenance Form.

2. In the Nature of Action Codes region, choose the NOAC associated to the Remark.

3. In the Remarks region, choose the Remark you want to remove.

4. Enter an end date in the To field when the Remark is no longer valid.

5. Save your changes.

Note: Repeat these steps for other NOACs to which you have
associated this Remark. To remove this Remark from the Remark
Codes and Descriptions window, see Adding and Deleting Remarks,
page 5-10.

Maintaining Remark Codes and Descriptions
Use the Remark Codes and Descriptions window to see a complete list of Remarks in
alphabetical order. You can add or delete Remarks as needed.

To display information:
1. Open the Remark Codes and Descriptions Federal Maintenance Form.

2. To display all possible codes, choose Query and Run or press F8. The window
displays all Remark codes and descriptions in alphabetical order.

Adding and Deleting Remarks, page 5-10

Adding and Deleting Remarks
To add a new Remark to the Remark Codes and Descriptions window, you must also
associate it in the NOA Codes and Remarks window.

To add a Remark:
1. Open the Remark Codes and Descriptions Federal Maintenance Form.

2. Choose the New Record button on the toolbar.

3. Enter a code for the Remark.

4. Enter the description. If the Remark description has insertion values, enter two
or more underscores for each insertion value. You can have up to five insertion
values in a Remark.

5. Enter a PA Notification ordering value.
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This value determines the order in which the system prints the Remarks on the
Notification of Personnel Action. The values are in ascending order, with 00 (or null)
for the Remark that appears first in the list of printed Remarks.

6. Enter an effective date.

7. Save the record.

8. Associate the Remark with the appropriate NOAC in the NOA Codes and Remarks
window, page 5-9.

Note: If you plan to associate the Remark with more than one
code, you must enter the code under each NOAC.

9. If the Remark description has insertion values, add the insertion value segments in
the Descriptive Flexfields Segment window, as explained in Setting up Insertion
Data, page 5-11.

Delete a Remark
Use the NOA Codes and Remarks window to delete Remarks.

To delete a Remark:
1. Open the Remark Codes and Descriptions Federal Maintenance Form.

2. Choose the Remark you want to delete.

Note: You can end date Remarks but not remove them.

3. Enter an end date in the Date To field.

4. Save your changes.

Caution: Do not delete Remarks seeded with the product. Before
deleting an agency-specific Remark, make sure that no actions have
been created using it.

See: Maintaining NOACs and Remarks, page 5-9

Inserting Data in NOAC, Remark, and LAC Descriptions
Many Nature of Action Codes (NOACs), Remarks, and Legal Authorities include
descriptions.

Descriptions may contain:

• No insertion data

• A combination of text and insertion data

• Only insertion data

If your agency adds agency-specific descriptions that contain insertion data, you can
capture that data. The product includes descriptive flexfields for NOAC, Remark, and
Legal Authority descriptions. These flexfields have five context-sensitive segments for
insertion values that correspond to the underscores in the descriptions.

Underscores represent insertion data only. Make sure that your Remarks, Legal
Authority Codes, or NOACs do not contain underscores unless they have corresponding
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insertion segments. The application does not validate the number of segments for
a specific description in the Descriptive Flexfield Segments window with the number
of underscore segments in the Maintenance forms. The application does not datetrack
insertion values. When the application updates the database, it only updates insertion
values associated with NTE (Not to Exceed) NOACs. Upon update, the application
does remove the underscore characters.

To add insertion values:
1. Add your Remark, or Legal Authority Code to the appropriate form.

See:Maintenance Forms, page 5-1

2. As an Application Developer, you set up segments for the descriptions in the
Descriptive Flexfield Segments window. Each group of underscores in the
description should have a corresponding segment defined to store its data.

The flexfield uses the code as context to determine what segments are displayed in
the pop-up window and the value sets (if any) to be used for each segment.

3. Each description has 5 segments that you can define. The number of characters
associated with each segment are as follows:

• Remarks: 2000 characters for the first segment; 150 characters for the remaining
segments.

• NOACS and LACS: 240 characters for the first segment; 150 characters for the
remaining segments.

4. Repeat the segment definition for NOACs twice (to accommodate dual
actions). Repeat the definition four times for Legal Authority Codes.

For example, the Legal Authority Code LAC A2M has a description CS Cert
No. ____ WTO. Because each NOAC has two possible supporting Legal Authority
Codes for each action, you need to enter the Legal Authority Code in all four
flexfields.

5. Follow the steps for freezing and compiling the flexfield segments as described in
the Oracle Applications Flexfields Guide.

Maintaining Legal Authority Codes
Use the Legal Authority Codes window to see current NOACs and each NOAC’s
associated legal authorities. You can also use this window to associate legal authorities
to your 900 NOACs.

This window contains two regions. The upper region displays Nature of Action
codes. The Legal Authorities region displays the legal authorities for the code you
have selected in the upper region.

To display information:
1. Open the NOA Legal Authorities Federal Maintenance Form.

2. A dialog box appears and asks that you enter a range of codes to display.

• To display a specific code, enter it in the Nature of Action From field. Choose
Find.
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• To display a range of codes, enter the beginning of the range in the Nature of
Action From field, and enter the end of the range in the Nature of Action To
field. Choose Find.

• To display all possible codes, choose Find.

• To select a code from a list of codes, insert a percentage symbol (%) in the Nature
of Action From field. A second dialog box appears that contains all the Legal
Authority Codes and Descriptions. Choose a code from this list. Choose OK.

Associating Legal Authority Codes to NOACs
You use the Nature of Action Legal Authorities window to associate legal authority codes
you define in the Lookup window to a NOAC. You can associate a single legal authority
code to more than one NOAC, as well as several legal authority codes to one NOAC.

To associate a legal authority code to a NOAC:
1. Open the NOA Legal Authorities Federal Maintenance Form.

2. A dialog box appears and asks that you enter a range of codes to display.

• To display a specific code, enter it in the Nature of Action From field. Choose
Find.

• To display a range of codes, enter the beginning of the range in the Nature of
Action From field, and enter the end of the range in the Nature of Action To
field. Choose Find.

• To display all possible codes, insert a "%" in the Nature of Action From field. A
second dialog box appears that contains all the Legal Authority Codes and
Descriptions. Choose a code from this list. Choose OK.

3. In the NOAC region, choose a Nature of Action code.

4. In the Legal Authority region, determine where you want the legal authority to
appear on the list. Choose the New Record button on the toolbar. An empty row
appears below the legal authority you selected.

5. Choose a Legal Authority from the List of Values.

6. Save your changes.

Defining Legal Authority Codes
You add new legal authority codes and update existing ones in the Lookup
window. After doing so, you can associate the legal authority to a NOAC in the Nature
of Action Legal Authorities window.

To add a new Legal Authority Code or revise an existing one:
1. Open the Lookups Values window.

2. Query GHR_US_LEGAL_AUTHORITY to display a list of predefined Legal
Authority Codes.

3. Choose the New Record button on the toolbar. An empty row appears below the
legal authority you selected.
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4. Enter a Code, Meaning, and Description for the legal authority. If the legal authority
has insertion values, enter two or more underscores for each insertion value. You
can have up to five insertion values in a Legal Authority Code.

Note: Underscores represent insertion data only. Make sure that
your Remarks, Legal Authority Codes, or NOACs do not contain
underscores unless they have corresponding insertion segments.

5. Choose Enabled to have the legal authority appear on the appropriate List of
Values, for example on the List of Values in the Nature of Action Legal Authorities
window.

6. Choose First Valid LAC and/or Second Valid LAC.

The NOAC determines whether the Legal Authority Code is valid as the first code
and/or second code.

Note: The list of first and second Legal Authority Codes for Within
Grade Increases (WGI) is predefined. If you change the validation
for these Legal Authority Codes by deselecting their check
boxes, when you process and update a WGI personnel action, the
system will inform you there’s an error.

7. Save your changes.

8. If the Legal Authority Description has insertion values, add the insertion value
segments in the Descriptive Flexfields Segment window, as explained in Setting
up Insertion Data, page 5-11.

To delete a Legal Authority Code:
1. Open the Lookups Values window.

2. Query GHR_US_LEGAL_AUTHORITY to display a list of predefined Legal
Authority Codes.

3. Enter an end date in the To field when the Legal Authority Code is no longer valid.

Note: If you delete a Legal Authority Code and then process an RPA
action using it, you’ll get an error upon update to the HR database.

4. Save your changes.

5. Open the NOA Legal Authorities Federal Maintenance Form.

6. A dialog box appears and asks that you enter a range of codes to display. To display
a specific code, enter it in the Nature of Action From field. Choose Find.

7. In the NOAC region, choose a Nature of Action code.

8. In the Legal Authority region, locate the Legal Authority Code. Enter an end date in
the To field when the Legal Authority Code is no longer valid.

9. Save your changes.
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6
Federal Wor kflow

RPA and PD Workflow Overview
Each individual involved in a workflow has a personal worklist. From your Workflow
worklist, you can:

• Query and view notifications

• View the routing history

• Respond to an action or form

• Reassign the action or form to another user

Workflow Notifications
Your workflow worklist displays notifications initiated by you or routed to you from
another individual, a routing list, or a groupbox. A notification is a workflow message
that accompanies HR forms that you route, such as Requests for Personnel Action
(RPA) and Position Descriptions (PD).

You can open the routed form from the notification and view its history. The notification
message includes information about the routed form, such as the request number, the
action requested, the routing group, the organization, and the current status.

The current status displays the highest level of status reached in processing an action
(not the latest). For example, if a human resource specialist approves an RPA and
then routes it to a supervisor for authorization, the current status on the workflow
notification is Approved.

FYI Notifications
An FYI Notification is a message in your worklist that informs you of an action taken by
the application. If you route or save a current or retroactive action to your worklist, the
application sends you a FYI Notification; otherwise it does not. However, you can
configure the notification process to establish who receives notifications, by specifying
the:

• Person who performs the Update to HR

• Approver as well as the person who performs the update to the HR database

Similarly, the application does not send FYI notifications upon update for Automatic
Within Grade Increases to the personnel office (POI), but you can configure the
notification process to have them sent to the POI.
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See: Within Grade Increase Workflow Decisions, Compensation and Benefits Management
Guide, Copying a Workflow Item, page 6-9, Changing a Workflow Attribute, page 6-10

Key Concepts
To use workflow to suit your agency’s requirements, you need to understand the
following key concepts and activities:

• Routing, Groupbox, Routing List, Roles, page 6-3

• Routing History, page 6-4

• Notifications, page 6-8

Workflow
Oracle Workflow allows you to route documents electronically among the members
of a work group.

What is workflow?
Each individual involved in a workflow has a Workflow inbox. From your Workflow
inbox, you can:

• View notifications (messages and actions routed to you)

• View Routing and Action History

• Respond to an action or form

• Open the action or form and reroute it to another user

What type of windows would workflow manage?
Users can route RPAs and Positions Descriptions (PDs) to a variety of destinations
including individuals, groupboxes, or routing lists.

How are messages displayed?
The Notification includes information about the routed form, such as the request
number, the action requested, the routing group, and the organization.

Is there a tracking mechanism?
You can open the Routing History from the Notification and view the history of the
action taken in processing the RPA or PD.
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Federal Workflow

Routing Documents
You can route documents electronically among the members of a work group. A
routing group consists of employees and contingent workers who participate in the
data entry, review, approval, and update of documents such as RPAs or position
descriptions. A routing group enforces security by allowing only the routing group
members access to the document.

Groupbox
A groupbox comprises a group of individuals who share a common business
function. For example, the groupbox might comprise members of an office, a branch, or
a team of individuals. Notifications that you send to a groupbox are visible to all
members of the groupbox.

Each member of the groupbox has a set of roles, which may differ from the roles that
were assigned to the user in the routing group. A user may have access to multiple
groupboxes.

Routing List
A routing list is a predefined list of routing destinations that defines the order in which
notifications are routed. The routing list expedites routing HR documents such as
personnel actions and position descriptions by automatically forwarding a document
from one routing destination to the next. The routing list can accommodate an unlimited
number of routing stops. Users may choose not to use the routing list at any time.

Roles
Roles are designations that describe each member’s workflow activities within a routing
group or groupbox. You can assign multiple roles to each user in a routing group. All
roles can route documents.

Default Routing Groups

When you assign roles, you assign the Initiator a default routing group. The application
uses the initiator’s default routing group as the routing group for the document. If
the initiator belongs to more than one routing group, before saving or routing the
document, the initiator can change the routing group. After that, however, no one can
choose a different routing group.

See: Processing an RPA Based on Role, Workforce Sourcing, Deployment, and Talent
Management Guide

Note: Roles are not the same as responsibilities. Responsibilities
are Oracle designations that describe your system privileges. A
responsibility defines the records, windows, and functions that you
can access.
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The Routing History
The routing history contains a history of all users who have participated in routing the
HR form to date and the workflow action’s taken. You can view the form’s history
from the workflow notification.

The Routing History is a scrolling, read-only window that contains an Action History
and a Routing History. You can see the progress of a form as it is routed, including the
individual user and groupbox destinations.

The Action History includes the user name, the person’s full name, a brief description
of the action taken, and the person’s role for this action.

Refer to the status column in the following table for an explanation of each action taken.

Status Action Taken

Initiated RPA is initiated

Requested Requester signed Part A

Authorized Authorizer signed Part A

Reviewed Reviewer displayed the RPA

Approved Approver signed Block C-2

Update to HR RPA has been submitted to the database for
validation and edits

Update HR complete RPA has successfully passed edits

Reassigned RPA has been routed to another user or
groupbox

Not routed RPA was saved but not routed

No action User did not initiate, sign, or cancel the RPA

Canceled RPA has been canceled

Future action The approved RPA is held by the system in a
separate file until the effective date is reached.

You can view the RPA and its history from
the Approved Requests for Personnel Action
window (the window that’s displayed when
you initiate a Correction or Cancellation
action).

The Routing History includes the user name, the groupbox name, the routing list
name, the sequence of the action, the date that the notification was sent, the NOA code
and description, and a notepad that shows free window notes authored by each user.
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Setting Up Routing Groups, Groupboxes, and Routing Lists
Use the Routing Groups and Groupboxes and Routing Lists maintenance forms to set
up your routing groups, groupboxes, and routing lists.

Before you can assign employees and contingent workers to a groupbox or
routing list, you must assign each person to a routing group. To set up routing
groups, groupboxes, and routing lists, follow this sequence of actions:

1. Define your routing groups using the Routing Group and Groupbox Details window
or the Routing Group and Routing List Details window.

See: Setting up Routing Groups, page 6-5

2. Assign users to routing groups and to roles within that routing group using People
Extra Information. See: Adding a User to a Routing Group, page 6-5

3. Set up groupboxes and add users to them. See: Setting up Groupboxes, page 6-6

4. Set up routing lists and add users to them. See: Setting up Routing Lists, page 6-7

Note: Once you initiate an RPA or Position Description from a
routing group, it stays within that routing group. You cannot
redirect it to another routing group.

Setting Up Routing Groups
You need to set up a routing group before you create groupboxes or routing lists. You
can set up and access routing groups from the Routing Group and Groupbox Details
window and the Routing Group and Routing List Details window.

To set up a new routing group:
1. Open the Routing Groups and Groupbox Details window from the Navigator.

Note: If it is more convenient, you can set up a new routing group
usingform the Routing Group and Routing List Details window.

2. Enter the Routing Group Name.

3. Enter a short description of the group. For example, you might name the group
"Personnel Office."

4. Save the new routing group information.

See: Adding a User to a Routing Group, page 6-5, Setting up Groupboxes, page
6-6, Setting up Routing Lists, page 6-7

Adding a Person to a Routing Group
Use the People Extra Information (US Federal Workflow Routing Groups) to add an
employee or contingent worker to a Routing Group and assign that person roles within
the Routing Group.

For a list of roles and their related actions, see Processing an RPA Based on Role,
Workforce Sourcing, Deployment, and Talent Management Guide
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Note: If you want an Initiator to belong to two separate routing
groups, make sure that you assign that person a default Routing Group
as an Initiator.

To add a person to a routing group:
1. In the People window, enter the person’s name and choose Find to initiate a search

for the user you want to add to the routing group.

2. Choose the Other button on the user’s People window and choose Extra Information.

3. Choose US Federal Workflow Routing Groups from the Extra Information list
and choose the Enter button.

4. Place your cursor in the Details field and click the mouse to display the US Federal
Workflow Routing Groups flexfield.

5. Place your cursor in the Routing Group Name field and choose the List of Values
button on this window. Select a routing group and choose OK.

6. In the Default Routing Group field, type Yes to assign this routing group as the
user’s default routing group.

A user can have only one default routing group. Type No, if the user has already
been assigned a default routing group.

7. Assign roles for this user by typing a yes or no for each role.

When you add a user to a Routing Group’s Groupbox, you can override the roles
you assigned that person here. (This is only true for Groupboxes, not Routing Lists.)

See: Processing an RPA Based on Role, Workforce Sourcing, Deployment, and Talent
Management Guide

8. Choose OK. Choose Validate on the Extra Information window to save and validate
the information.

9. Repeat steps 6 through 9 to assign another routing group.

See: Setting Up Routing Groups, page 6-5, Setting up Groupboxes, page 6-6, Setting
up Routing Lists, page 6-7

Setting up Groupboxes
The Routing Group and Groupboxes window creates a link between a Routing Group
and a Groupbox. Groupboxes are often convenient for dividing large departments into
groups, but you can also route forms within a Routing Group. Notifications that you
send to a groupbox are visible to all members of the groupbox.

Use the Routing Groups and Groupboxes window.

To set up a groupbox:
1. Query the Routing Group for which you want to add the Groupbox.

If you previously created a groupbox for this routing group, the system displays that
information. To create a new groupbox, choose New Record from the toolbar.

2. Enter a name for the groupbox.
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Note: Groupbox names must be unique. Do not enter the user’s
name as the groupbox name.

3. Enter a short description of the groupbox.

4. To add users to the Groupbox, enter the user names. Assign each user a role for this
groupbox.

By default, this groupbox uses the Routing Group roles assigned the user in the
People Extra Information, US Federal Workflow Routing Group. To change the
user’s role when working with notifications sent to the Groupbox, select or deselect
the applicable roles. (Selecting a role here doesn’t change the default role.)

Note: Before adding a user to a Groupbox, the user must be a
registered Oracle application user and must also belong to a
routing group.

5. Save the file.

6. To remove a user from the Groupbox, select the row, choose the Delete Record
icon on the toolbar, and save the file.

7. To add multiple Groupboxes to a Routing Group, place your cursor in the Groupbox
Name field and choose the New Record icon on the toolbar. Repeat steps 3 - 6.

Setting up Routing Lists
You set up a routing list for a routing group in sequential order in the Routing List
window. You may create multiple routing lists for a routing group, and users may
belong to more than one routing list.

You can also use the Routing List form to create, update, or delete a routing group.

Use the Routing Group and Routing List Details window.

To set up or add a user to a routing list:
1. Query the Routing Group for which you want to set up a routing list.

If you previously created a routing list for this routing group, the application displays
that information. To create a new routing list, choose New Record from the toolbar.

2. Enter the name of this routing list and check the primary routing list box if this is a
primary routing list.

3. To add users to the Routing List, enter the names of the routing list members
as follows:

• In the first column, enter the routing sequence of the user (1,2,3, and so on).

• In the second column, enter the user name.

• If you did not enter the user name in the second column, you may enter a
groupbox name in the third column. You may enter a groupbox name or a
user name in each row.

Note: Before adding a user to a Routing List, the user must be
a registered Oracle application user and must also belong to a
routing group.
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4. Save the file.

5. To remove a user from the Routing List, select the row, choose the Delete Record
icon on the toolbar, and save the file.

6. To add multiple Routing Lists to a Routing Group, place your cursor in the Routing
List Name field and choose the New Record icon on the toolbar. Repeat steps 3 - 5.

Note: If you have multiple routing lists for a routing group, you
must specify which list is the Primary list.

See: Setting Up Routing Groups, page 6-5, Adding a User to a Routing Group, page
6-5, Setting up Groupboxes, page 6-6

Reviewing the History of an Action
The application maintains a record of each action as it is routed through the workflow
process.

To review the history from the Notification:
1. From the worklist, click the notification that you want to view.

2. Click the Routing History icon in the view only area.

To review the history from the RPA:
1. From the RPA, choose the History button to open the Routing History.

Querying Notifications from Your Worklist
Your personal Workflow worklist displays notifications for actions that you
initiate, actions and forms routed to you from other users, canceled (closed) actions, and
actions updated to the database.

To view notifications:
1. From the View List, select the appropriate view filter.

2. To sort the list, click the label of the worklist column that serves as the sort
criteria. The application arranges the worklist contents in ascending or descending
order. Click the label again to reverse that order.

3. Select a notification from the worklist, and choose the Open button to see its contents.

To obtain more information about a notification or its attac hment:
1. Display the notification.

2. Choose the Request Information button.

3. Select a routing group member from the Workflow Participant list of values. If
the recipient is not included in the routing group, select Any User and enter a
user name or display name.

4. In the Information Requested text box, enter your query.

5. Choose the Submit button to send the notification and its request for information.
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Responding to an RPA from the Workflow Worklist
You can view or process the routed RPA directly from your worklist.

To respond to an RPA form:
1. Open a notification from the worklist.

2. Choose the RPA icon in the Response region.

3. Complete the fields on the RPA according to your role and agency practices.

4. Choose the Save icon on the toolbar to open a Decision dialog box that lets you route
the RPA. From the Routing dialog, you can choose to:

• Route the RPA to a Person, Routing List, or Groupbox.

• Save the Notification in your personal worklist.

• If you are an Approver, approve the RPA and route it, or approve the RPA
and choose Update to HR.

5. Choose OK to route the RPA and close the RPA window.

Rerouting a Notification
If you receive an action that a different user in your routing group should process, you
can reassign that action.

Similarly, if you have several actions, you can reassign that batch of actions to another
user in your routing group.

To reroute a notification:
1. From the worklist, click the Select box next to the notification you want to reassign.

2. Choose the Reassign button.

3. In the Reassign field, enter the destination display name or user name. If you do not
know the name, click the flashlight icon to display the Search and Select dialog.

4. Select a Search By criteria and choose the Go button.

Note: In the current release, the list of values displays the individual
users and groupbox users who comprise the routing group.

5. In Results region, select a recipient.

6. In the Comments region, add any additional comments that you want to accompany
the notification.

7. Choose the Submit button to route the notification.

The application sends the action to the requested destination.

Copying the Original Workflow Item Type
When you want to change the predefined workflow process, you copy and rename the
original process. By leaving the original process intact, you can refer to it and also use it
as a basis for future upgrades.
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To copy the original workflow item type:
1. Open WorkFlow Builder.

2. Copy the Oracle Federal HR Application Item Type from the Object Navigator.

3. Paste the Oracle Federal HR Application Item Type back into the Object Navigator.

When you paste you will be asked to change the properties of the Item type.

4. Change the Item Type:

• Internal Name

• Display Name

• Description

5. Click OK, and cancel any messages that may appear.

Changing a Workflow Attribute
You manage the flow of information using Oracle Workflow, an application included in
Oracle US Federal Human Resources. By configuring the Notification and approvals
process, you can determine who approves personnel actions and who receives
Notifications upon successful update to the HR database.

Note: Set the access level between 100 and 999 to change the default
value for the attributes. You can do this by navigating to Help and then
choosing About Oracle Workflow Builder.

Do not work with the original predefined workflow process. The original should only
be used for reference and as a basis for future upgrades.

See: Copying a Workflow Item, page 6-9

Use the Workflow Builder window to change an attribute.

To change the workflow attribute:
1. Open Workflow Builder.

2. Open the appropriate Item Type:

• GHR Personnel Action

• GHR Within Grade Increase

3. Select the attribute that you want to configure.

4. Double-click the attribute name to open a Control Properties dialog window.

5. Change the default value to one of the choices provided.
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7
Interface Configuration

Compensation Entry and Reporting Overview
To record any form of compensation, benefit, or deduction liability for an employee, you
make an element entry. There are several ways to do this:

• You can use Batch Element Entry (BEE - part of MIX) to enter or update a batch of
element entries for many employees, using defaults for fast entry. For example, you
can use BEE to enroll employees in accrual plans or allocate a single entitlement to a
group of similar employees.

• You can enter absences or accrued time taken in the Absence Detail window.

• You can make entries to elements that represent benefits which do not require a
Notification of Personnel Action using the Element Entries window such as health
care and retirement plan benefits

• You can make or update individual entries of other compensation elements for an
employee using the Element Entries window.

Some elements are defined with standard links so that eligible employees receive
an entry automatically. You don’t need to do anything to record these forms of
compensation for employees.

Compensation Entry and Analysis

How does Oracle HRMS help me reduce data entry errors?
There are three ways:

• By removing the need to make entries at all, when compensation entries are standard
for a group of employees and can be entered automatically.

• By reducing keystrokes when you use Batch Element Entry to enter batches of entries.

• By validating all entries using rules you define at setup time.

Can I make one-time changes to entries?
Yes. Some types of compensation or payment (such as expense reimbursements) need
only be entered for the period to which they apply. For others, the regular value can be
adjusted if you need a different value for one payroll run.
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I’m entering compensation details for analysis but not for payroll processing. How do
I reduce data entry work to a minimum?

If the same compensation entry applies to a group of employees, the system can enter it
automatically. You need to set up the element with standard links. Use Batch Element
Entry to start or update other entries in batches.

Can I see a history of all compensation values for an employee over time?
Yes, you can view all changes for one or more types of compensation. For salaries, you
can also see new proposed salary changes.

How do I compare compensation for groups of employees?
You can select employees by organization, job, position, or grade and view past and
current salaries. For other types of compensation, you can compare the latest values for
all employees in any period of time you choose.
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Benefit Reporting and System Extract

Reporting Groups
A reporting group is a collection of programs and plans that you group together for
reporting purposes, such as for administrative use or to meet regulatory requirements.

At the plan level, you can define the regulatory bodies and regulations that govern a
reporting group.

For each regulatory body that you link to a plan, you can define how the regulatory
body governs that plan. You can also record the date the plan was qualified by the
regulatory body and the approved termination date if the regulatory body does not
recognize a plan’s qualifications after a certain date. An approved termination date is
typically defined when a reporting group must be re-evaluated by the regulatory body
on a periodic basis.

Since US benefit plans are subject to federal nondiscrimination testing requirements, you
may define special FastFormula rules to help determine compliance with these
regulations. You can define the following rules:

Contribution Nondiscrimination is used to identify those participants who cause the
plan to be out of compliance with contribution nondiscrimination provisions.

Coverage Nondiscrimination is used to identify those participants who cause the plan
to be out of compliance with coverage nondiscrimination provisions.

Five Percent Owner is used to determine those participants who are 5% owners of
the business.

Highly Compensated Determination is used to determine those participants who are
highly compensated in the context of the plan for nondiscrimination testing purposes.

Key Employee Determination is used to determine those participants who are key in
the context of the plan for nondiscrimination testing purposes.

Benefits System Extract
Many human resource departments outsource at least some of their compensation and
benefits administration processing to third party carriers, payroll providers, or other
vendors. Thus, there is a great need for reliable data exchange between plan sponsors
and these third parties.

You can use System Extract to extract records for a variety of plans, including
compensation and benefits plans and absence plans. Additionally, you can use this
feature to extract other data, such as people and assignment information.

In order to extract records from the database for transmission to a third party, you
must define the criteria that determine which records are extracted. You also must
define the layout of the extracted records including the data elements that comprise the
extract, the date range of the records you are selecting, and the output directory and file
name of the extract file.

After you create your extract definition, you run the system extract batch process to
create your extract results using the Concurrent Manager. You can then review these
results, including any errors that occurred during the batch process. When you are
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satisfied with the results of the extract, you can transfer the extract file onto the delivery
medium by which you transmit or store the extract results.

You can think of the system extract process as consisting of these steps:

• Defining an Extract Layout

• Defining an Extract Criteria Profile

• Defining a System Extract

• Running the System Extract Batch Process

• Viewing Extract Results

• Running the extract write process

Extract Layout
You create an extract layout definition to control the data elements that are included in the
extract and the format of the extract results.

An extract layout consists of data elements and their formatting, record layouts that
define which data elements appear in the header, detail, and trailer areas of the
extract, and a file layout that specifies the order of the records.

Your extract layout also indicates the sort order of the records and any conditional
record inclusion criteria that you define.

For example, you could create an extract layout definition for the enrollment results of
the medical plans offered by your organization. You define data elements such as the
participant’s first name, middle name, last name, and the plan they elected. Then, in
your record layout, you order these data elements into their correct sequence. Lastly, you
create a file layout by ordering the various record layouts you have defined into their
appropriate sequence.

Data Elements
Data elements are individual data components which contain values that you include
in an extract. Different data element types can contain different values. You use your
data element definitions in conjunction with your extract criteria definitions to restrict
the data that is included in the extract.

Field data elements are most often data extracted from a database field, but can also
include common header and trailer totals, dates, and other filler information. You cannot
update the list of fields delivered with the system.

You use decoded field data elements when you want to display a different value in the
extract than is stored in the database. For example, if you store the values for Male and
Female as 1 and 2 in your database, you can decode this data for your extract so that the
values appear as Male and Female in the extract.

Select the Record Calculation type to calculate the total of two or more data elements in
a record. You can add, subtract, multiply, or divide extracted data.

You enter a string as a character literal that you want to include in an extract. For
example, you may include a string that is the record type that precedes each record
in the extract file.

7-4 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



You can define a rule if you want to create a data element that is not included in the
standard list of data elements.

You select the totals data element type for use in the header or trailer of a record. Using
totals, you can sum the results of any data element or include a count of the number of
records. You can also conditionalize your totals so that you only display the sum of data
elements where the value is equal to the value that you specify.

Special Formatting for Data Elements
You can format different data element types in different ways. For the data element type
of field, rule, or totals, you can select the justification as either right or left justified.

Note: The default justification is left justified. For data elements with a
number value, you typically select right justified.

You can select format masks for the data elements types of field, decoded field, record
calculation, rule, and totals. Format masks can be used for numbers, dates, phone
numbers, and social security numbers. For example, you can select a date format mask
of DD/MM/YYYY. For the field data element type, you can also set the capitalization of
all extracted records to Uppercase, Lowercase, or Initial Capitals.

If the seeded format masks are insufficient, you can add format masks to the system’s
number and date lookups. You use a lookup code that begins with ’N’ for numeric
format masks or ’D’ for date format masks. You cannot define your own format mask for
phone numbers or social security numbers.

Note: A system administrator familiar with Oracle formats should
enter this information.

You define the maximum length of a data element value to control the point at which the
value is truncated. For example, you could specify a maximum length of one for the
middle name data element to retrieve a person’s middle initial. The maximum length
does not control the starting position of the following field.

For a data element with a value of null, you can specify a when null use value as the
default value. If you do not specify a when null use value then null values appear as a
blank in a fixed column layout or as no value in a variable layout.

For the decoded field data element type only, you can define an others value to use as
the default value for undefined and null values. For example, you could decode the
value of ’M’ and ’S’ to mean married and single. For all other values, you could define
an others value of null.

Record Layout
You specify the data elements that are included in the header, detail, and trailer portions
of your record layout. Typically, the header and trailer portions of a record contain
control information, such as file identifying information, dates, and totals. Detail records
contain the content and values of an extract.

You can specify if a data element is required for the extract. If a required data element is
missing, the entire record is written to the error log during the extract process and no
extract result is created for that record.
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You can also choose to hide a data element from an extract record when you run the write
process. Hidden data elements appear in the extract result after you run the extract
process, but are hidden when you initiate the extract write process.

Extract Record Hierarchy

Levels Branches and Planes

The data elements that you can include in an extract record are controlled by the system
extract hierarchy of levels, branches, and planes.

A level is a logical grouping of data elements. For example, the Person Level contains
data elements such as person first name and person address. The lowest level in the
extract hierarchy determines the number of times that a record repeats.

For an extract record that contains data elements from the person level and the
enrollment level, the record repeats at the enrollment level. If a person enrolls in a
medical plan and a dental plan, the record repeats for each enrollment.

A plane is a grouping of levels. There are three planes in the system extract hierarchy
that you use to control data element sorting. The sorting definitions that you apply to an
extract are limited to the data elements contained in the level for that plane.

The branches of the extract hierarchy link levels from the three planes. There are six
branches:

• Person, Eligibility

• Person, Enrollment, Beneficiary

• Person, Enrollment, Dependent

• Person, Enrollment, Action Item

• Person, Element Entry

• Person, Run Result

You can only define a record with data elements from levels in the same branch. You
cannot define a record using data elements from more than one level of the same plane.

File Layout
You define a file layout to create the sequence (from right to left) in which the records
display in an extract. Sequence numbers are unique. They must start with 1 and be
between 1 and 75. It is recommended that you do not leave any gaps in your record
sequence.

Data Element Sorting
You can sort the data elements in a record by up to four levels based on any data element
you include in the extract. Sorting can occur on each record in a file layout.

For extracts with multiple records, the sorting criteria defined for the record with the
highest sequence number are inherited by records with lower sequence numbers unless
you define a separate sort order for a record with a lower sequence number.

You use record sequence numbers to order records within one level in the extract
hierarchy. System edits ensure that record sort orders conform to the plane structure of
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the extract hierarchy. For example, you cannot define an extract to include data elements
from the eligibility level between the enrollment level and the dependent level.

Extract Criteria
The extract criteria you select determine the data that is extracted by filtering the
data. Data that does not meet your extract criteria is not extracted. You can select from
several groupings of criteria that you combine to create an extract criteria profile. These
criteria groupings include:

• People

• Benefits

• Changes

• Payroll

• Communications

• Advanced

People
You select People criteria to limit your extract results to people who meet the criteria
you select, such as assignment location, organization, or benefits group. You can also
select individual people.

Benefits
You use Benefits criteria to limit your extract results to a particular plan or reporting
group. In addition, you use this criteria to define the extract processing for dependents
of primary participants.

Changes
Often in the outsourcing process, data transmissions need only record data that has
changed since the last transmission. This helps reduce the cost and complexity of an
extract by eliminating the reporting of unnecessary information. You can track these
changes for particular change events defined by the system.

Payroll
This criteria grouping is for customers who do not use Oracle Payroll. You can limit the
type of element entries and input values that are extracted.

Communications
This limits the communication types that are extracted.

Premium
If you extract data for transfer to a third party administrator or benefits provider, you
can create an extract criteria profile that includes premium criteria.

You can extract premiums for a single month or for a range of dates. Additionally, you
can restrict a premium extract to the last occurrence of a record update.
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Advanced
Use the Advanced criteria to create an extract for a change event when you have
complex criteria for selecting records.

You can select records for a change event over one or more periods of time, and you can
select record by the actual date or effective date of change.

Note: This feature is available to both Standard and Advanced
customers.

Extract Definition
You create an extract definition to set parameters specific to a particular extract by
selecting the criteria profile and the layout that you want to use for the extract.

You also define parameters for the system extract batch process that you run to create the
extract result. These parameters include the extract date range, the data sort order, and
the output directory and file name.

Extract Batch Processes
You run the Extract Process from the Concurrent Manager to create results for an extract
definition that you have defined. After you run the extract process, you can view the
results in the Extract Results window. The extract process generates a summary report
and an error report. You can run the Extract Audit Report to view a limited selection of
records from the extract results.

You run theExtract Layout Report to extract just your layout definition with no
data. This is useful for reviewing the format of the layout. Benefit carriers may also find
this information useful in helping them import the extract result into their systems.

Use the Extract Results Data Purge process to remove unwanted data from the extract
results tables. Purging unneeded data helps save table and disk space.

Extract Results
You run the Extract Summary report from the Concurrent Manager to view an extract
summary. You can view any errors that occurred during the extract process by running
the Extract Error Report.

To view detailed information about an extract, you use the Extract Results form.

Change Event Log
You can view the change events for a person using the Change Event Log window. The
window displays the name of the change event, the date on which it occurred, and the
user name of the person who entered the change.

You can delete change events from this window, but you cannot add change events.

Extract Write Process
Once you are satisfied with the results of your extract, you run the Extract Write Process
from the Concurrent Manager to save the output of the extract to the directory and file
you specified in your extract definition.
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Update the user profile option BEN: Max Extract Line Size to set the maximum length of
a record generated by the Extract Write Process.

See: User Profiles, page 1-49

See: Running the System Extract Batch Processes, page 7-20

System Extract Copy
You can copy a system extract to another business group or database instance. To
save time during implementation, build a system extract once, then copy the data
elements, record and file layouts, and extract criteria that comprise the extract definition.

Run the Extract Definition Download to Data File process from the source business
group to copy the extract definition. Then, run the Extract Definition Upload from Data
File process from the target business group to import the copied extract definition.

See: Copying a System Extract, page 7-22

XML-Enabled System Extracts
You can use System Extract to generate an XML file for data transfer. Unlike ASCII files
that rely on character ordering and spacing, XML files use tags to identify data types.

When you define the Extract Definition, you can create either a TXT or an XML formatted
file. If you select XML, the Extract Process generates the following files:

• XML file

• XSL file (style sheet)

• XSD file (schema)

The XML file contains the data along with the XML tags. The recipient of the
extract--such as a benefits provider--uses the XSL file to determine the layout of the XML
file. The XSD file allows you to view the XML file in a web browser.

Each tab in the Extract Layout and Extract Definition forms contains a field called XML
Tag. The XML tag defaults to the name you assign each record. You can change the name
of the XML tag at anytime prior to running the Extract Process. A tag can contain up to
80 characters and does not allow spaces, numbers, or special characters.

Tag names do not need to be unique. If you extract XML for an existing extract
that has no tags defined, the Extract Process uses the lookup codes contained in the
BEN_EXT_XML_TAGS Lookup Type to populate the tags in the extract results.

Defining a Reporting Group
You use the Reporting Groups window to define a reporting group and to associate
programs and plans with the reporting group. You can also define which regulatory
bodies and regulations govern the reporting group.

To define a reporting group:
1. Enter a unique Name for the reporting group.

2. Select the Global check box to include plans in the reporting group from any
business group.

Interface Configuration 7-9



Note: Create a global reporting group if you implement a
Compensation Workbench plan and you enable a manager to review
or allocate compensation for employees in different business groups.

3. Select the Purpose of the reports that will be generated for this reporting group.

Select a purpose of Compensation Plan Groupings for Compensation Workbench.

4. Enter a Description of the reporting group.

5. Select the first Program Name if the reporting group is to consist of one or more
programs.

Alternatively, select the first Plan Name in the reporting group.

Any row (record) in this table can include a Program Name or a Plan Name, but
not both simultaneously. While it is unlikely that you would want to use the same
reporting group to report at the program and plan levels, you could do so by
choosing a Program Name for one record, and then choosing a Plan Name for each
subsequent record in the reporting group.

Note: When a plan is selected, the Regulatory Bodies and
Regulations button is enabled, indicating that you can define
regulatory bodies for, and associate regulations with, that plan.

6. Save your work.

Defining Regulatory Bodies for a Plan
You use the Regulatory Bodies and Regulations window to date effectively define the
regulatory bodies that approve or govern this plan.

To define a regulatory body for a plan:
1. Choose the Plan Regulatory Bodies tab if it is not already selected.

2. Enter the Name of the regulatory body associated with this plan.

In the Dates block:

3. Enter the Approved Termination date on which this regulatory body ceases to
recognize this plan’s validity.

4. Enter the date this regulatory body qualified this plan in the Qualified field.

5. Select one or more Regulatory Purpose Codes that describe how this regulatory
body governs this plan.

6. Save your work.

Defining Regulations for a Plan
You use the Regulatory Bodies and Regulations window to date effectively define the
regulations that approve or govern this plan.

To associate regulations with a plan:
1. Choose the Plan Regulations tab if it is not already selected.
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2. Select a Regulatory Plan Type.

3. Select the name of the regulation that governs this plan in the Regulation field.

4. Select one or more rules to determine how plan regulations define:

• Contribution Nondiscrimination

• Coverage Nondiscrimination

• Five Percent Owner

• Highly Compensated Determination

• Key Employee Determination

Note: These rules reflect US non-discrimination legislation.

5. Save your work.

Defining an Extract Criteria Profile
You use the Criteria Definition window to create an extract criteria profile that limits the
results of a system extract to records that match your extract criteria.

To define an extract criteria profile:
1. Enter an extract criteria Profile Name or query an existing profile that you want

to modify.

2. Choose a tabbed region that represents a criteria category you want to include
in your profile. Choose from:

• People

• Benefits

• Changes

• Payroll

• Communications

• Premium

• Advanced

Note: If you define an extract criteria profile that uses
change events, you must enable these change events in the
Application Utilities Lookups window. Query the Lookup code
BEN_EXT_CHG_EVT and select Enable for each change event you
want to enable.

3. Select a Criteria Type that limits the records to include in this extract.

4. Select a criteria value based on the criteria type you selected.

5. Check the Exclude field if this criteria type and value is excluded from appearing
in your extract.

6. Repeat steps 2-5, page 7-11 for each criteria that you are including in this extract
criteria profile.
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7. Save your work.

To define an extra criteria profile using Advanced criteria :
1. Enter or query an extract profile in the Profile Name field.

2. Select the criteria types and values that you want to include in this extract criteria
profile.

Note: If you are defining a profile using change event criteria from
the Advanced tabbed region, do not select any change events
in the Change tabbed region.

3. Choose the Advanced tab.

4. Select the Criteria Type of Combination.

5. Navigate to the Advanced Criteria window by clicking into a Value row and
choosing the Details button.

6. Select a Criteria Type. Choose from:

• Change Actual Date

• Change Effective Date

• Change Event

7. Select an Operator to limit the criteria values.

Note: For change dates, select either equals (=) or between as the
operator. For change events, select either equals (=) or does not
equal (!=).

8. Select a change value in the Value 1 field.

Note: For change dates, select a value that specifies a period of
time, such as Last Day of Previous Month. For change events, select
a particular change event.

9. Select another value in the Value 2 field if you are adding more criteria values to this
extract profile or if you are comparing values in the Value 1 and Value 2 fields.

10. Save your work.

Defining an Extract Layout
You use the Layout Definition window to define the data elements, records, and format
of the records that are extracted by your extract definition.

Your extract layout definition consists of the data elements to include in the extract, the
record layout that controls the records that appear in the header, footer, and detail areas
of your extract, and the file layout that defines the records to include in the extract.

See: Extract Layout, page 7-4
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Data Elements

You use the Data Elements tabbed region to select the data elements to include in an
extract and to define the layout format of each data element.

To define the layout format of a data element:
1. Enter the Name of the data element you are defining.

2. Select the data Type of the data element.

Note: Depending on the data type you select, the system presents
different formatting options for that data element.

3. Enter an XML tag name if you output the system extract file in XML format.

Note: The XML tag name defaults to the name you assign the
record. When you define the Extract Definition, you can choose to
extract a text file or an XML file.

4. Enter values for the following parameters if you select the Field data element type:

• Select the Field.

• Select a Format Mask that formats the results of the value from the
field. For example, you can set the capitalization of all extracted records to
Uppercase, Lowercase, or Initial Capitals.

• Select the Justification, either left or right.

• Enter a value or character string to use when the value for the data element
is null in the When Null Use field.

• Enter the maximum number of characters to include in this data element in
the Max Length field.

5. Enter values for the following parameters if you select the Decoded Field data
element type:

• Select the Field.

• Select a value in the If Value Is field that, when met, requires a substitute value.

• Enter the substitute value in the Replace With field.

• Enter a value in the Other Values field to use when the decoded value is either
null or undefined.

6. Enter values for the following parameters if you select the Record Calculation data
element type. As a prerequisite, you must first define the corresponding record
layout and the elements in the record layout.

• Select a calculation Function, such as Add.

• Select the Record Name of the layout in which you are including the calculated
data element.

• Select the Format Mask.

• Select the Justification, either left or right.

• Enter a Sequence number for the first data element in the calculation.
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• Select the first Data Element Name in the calculation.

• Select the remaining data elements in the calculation, entering a sequence
number for each element.

7. Enter a character string in the Value field if you select the string data element type.

8. Enter values for the following parameters if you select the Total data element type:

• Select the totaling function, either count or sum.

• Select a data element.

• Select the Format Mask.

• Select the Justification, either left or right.

9. Select a Rule to define a data element if the standard data element types do not
meet your criteria.

10. Save your work.

Record layout
You use the Record Layout tabbed region to define the header, detail, and trailer
portions of your data extract.

To define the record layout of a system extract:
1. Enter a Name for the record layout definition.

2. Select the record layout Type, choose either Header, Detail, or Footer.

The Repeating Level field is populated based on the lowest level in the extract
hierarchy from which data elements are selected for this record. This is a read-only
field.

3. Enter an XML tag name if you output the system extract file in XML format.

Note: The XML tag name defaults to the name you assign the
record. When you define the Extract Definition, you can choose to
extract a text file or an XML file.

4. Enter the Seq (sequence) number in which this data element displays in the extract
report.

Note: Sequence numbers must be unique. They must start at 1 and
be between 1 and 75. It is recommended that you do not leave any
gaps in your record sequence.

5. Select a data element in the Data Element Name field.

6. Enter a Start Position number for this record if you are defining a fixed layout format.

7. Enter a Delimiter (such as an asterisk or a comma) that separates the fields of this
data element if you are defining a variable layout format.

8. Check the Required field if this data element must be included in the extract record.

If you check the Required field, you may want to enter a value to display when this
field is null. You enter this value by selecting the field name in the Data Elements
tabbed region and entering a value in the When Null Use field.
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Note: If a required data element is missing, the entire record is
written to the error log during the extract process and no extract
result is created for that record.

9. Check the Hide field if you want to hide a data element from an extract record
when you run the write process.

Note: Hidden data elements appear in the extract result after you
run the extract process, but are hidden when you initiate the
extract write process.

10. Save your work.

File layout
You use the File Layout tabbed region to define the sequence in which the records in
this extract display and any conditions that must exist for a record to be included in
the extract.

To define the file layout of a system extract:
1. Enter a Name for the file layout definition.

2. Enter an XML tag name if you output the system extract file in XML format.

Note: The XML tag name defaults to the name you assign the
record. When you define the Extract Definition, you can choose to
extract a text file or an XML file.

3. Enter the Seq (sequence) number in which the extracted records display.

4. Select a record that you have defined in the Record Name field.

5. Check the Hide field if you want to hide a record from an extract file when you
run the write process.

Note: Hidden data elements appear in the extract result after you
run the extract process, but are hidden when you initiate the
extract write process.

6. Choose the Sort button to define a data element sort order for this file layout
definition.

7. Choose the Advanced Conditions button if you only include this record when a
specific event occurs.

8. Repeat steps 2-6, page 7-15 for each record in your file layout definition.

9. Save your work.

To define the sort order of the data elements in a record:
You can use the Sort window to define up to four levels of sorting for each record in a file
layout. You can sort by any data element included in a record.

1. Select the record in the File Layout window for which you are defining the data
element sort order.
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Note: Selecting a record limits the data elements by which you can
sort to the data elements contained in that record. You can sort by a
data element that you do not want to display in a record by adding
that data element to the record and checking the Hide field.

2. Choose the Sort button to display the Sort window.

3. Select the primary data element by which you want to sort the record in the First
Sort field.

4. Select the second data element by which you want to sort the record in the Second
Sort field.

• You can further sort the record by selecting data elements in the Third and
Fourth Sort fields.

5. Save your work.

Conditions of Inclusion for File and Record Layouts
You use the Record Layout Advanced Conditions window or the File Layout Advanced
Conditions window to define the conditions that must exist for a data element to be
included in a record or for a record to be included in a file.

Note: Conditional inclusion is based on a text comparison of a data
element value with a value you supply. It is recommended that you test
your conditional inclusion criteria for accuracy on a small number of
records before creating an extract.

To define the conditions of inclusions for an extract layout :
1. From the Layout Definition window, do one of the following:

• Choose the Record Layout tabbed region. Enter or query a record for which you
are defining conditional inclusion criteria.

• Choose the File Layout tabbed region. Enter or query a file for which you are
defining conditional inclusion criteria.

2. Choose the Advanced Conditions button.

3. Enter the Seq (sequence) number in which the system checks for this condition.

4. Select a Data Element Name from the list of data elements in this layout definition.

5. Select an Operator based on your conditions of inclusion for this data element.

6. Enter a Value for the data element.

Note: When you click into the Value field, a sample entry appears
based on the operator you selected. Substitute your data element
value for the sample value. For example, if you select an operator of
Equals (=), enter the exact value surrounded by single quotation
marks.

7. Select a value of either And or Or if your inclusion criteria contains more than
one data element value.

8. Select an Action that excludes the record based on whether the conditions of
inclusion are true or false.
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9. Save your work.

Defining a System Extract
You use the Define Extract window to define and maintain the definition of a system
extract.

Your extract definition includes an extract criteria profile and an extract layout definition
that you have already defined as well as other parameters needed for the extract batch
process, such as the extract date range and the output directory and file name of the
extract file.

To define a system extract:
1. Enter an Extract Name that uniquely identifies this extract definition.

2. Select the kind of data that you want to include in the extract in the Type field.

• Choose either Full Profile, Changes Only, or Communication.

3. Enter an XML tag name if you output the system extract file in XML format.

Note: The XML tag name defaults to the name you assign the
record. When you define the Extract Definition, you can choose to
extract a text file or an XML file.

4. Select an extract criteria profile in the Inclusion Criteria field to limit the results of
the extract.

5. Select a file layout definition in the File Layout field that limits the records included
in this extract to those defined in this file layout.

6. Enter the Output Directory where you want to write the results of the extract.

System Extract validates the directory you enter against the parameter
UTL_FILE_DIR set up by your database administrator. If you want to write to
additional or different directories, your database administrator must update
UTL_FILE_DIR with the additional paths.

7. Enter the name of the output file in the Output File Name field.

8. Select an Output Type—either Flat File or XML File—to determine the format of
the extract file.

Note: Select Flat File to generate a single text file. Select XML File to
generate three files with the extensions, .xml, .xsl, and .xsd.

9. Check the Append Current Request ID field if you want to add the request ID
to the file name.

In the Options tabbed region:

10. Check the Kickoff Write Process Automatically field if you want to write the results
of this extract to a file when you run the benefits extract batch process.

Note: If you want to review the results of your extract before writing
the results to a file do not check this field. You can write the extract
results to a file by running the extract write batch process from the
Concurrent Manager.
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11. Check the Special Handling for Dependents (ANSI 834, HIPAA) field if you are
defining this extract to conform with ANSI 834 or HIPAA standards.

Note: If you check this field, you should consider selecting the data
element of Person Participation Type (ANSI) when defining the
layout for this extract to distinguish participant and dependent
enrollment records in the extract results.

12. Check the Update Communication Sent Date field if you are defining an extract
for communications.

13. Save your work.

Viewing Extract Change Events for a Person
You use the Change Event Log window to view the change events that have occurred to
a person or to delete a change event from the log.

Note: You can view change events for multiple persons by running a
system extract that includes change event criteria.

To view change events for a person:
1. Query the Name, Social Security number, or other standard identifying information

for this person.

The system displays the change events for this person.

2. Select a change event to view the Old and New Values for the event.

3. You can delete a change event from the log by selecting a Change Event row and
clicking the delete icon on the toolbar.

4. Save your work if you deleted a change event from the log.

Viewing Extract Results
You use the Extract Results window to view the output of a system extract run, including
summary information, detailed results by person, and run results errors.

To view the results of a system extract:
1. Query an extract result that you want to view in the Extract Name field. The system

displays summary information for the extract, including:

• The run Request ID and Run Status

• Extract run dates and times

• Number of records in the extract result

• Number of records, people, and errors in the extract result

• The extract output directory and file name

2. Select a Run Status of Approved by User if you want to approve an extract result
with a status of Job Failure.

Note: You cannot successfully run the extract write process for an
extract with a status of Job Failure unless you change the run status
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to Approved by User. Conversely, you can change an extract with a
status of Successful Completion to Rejected by User to prevent the
extract write process from writing out an extract file.

3. Save your work if you changed the status of this extract run result.

4. Choose the Details button to view extract results by person.

The system automatically queries all persons who were processed in this run. For
each person, the system displays:

• The run records that comprise the system extract definition

• The data elements for each record

• The value of each data element for this person

5. Choose the Header and Trailer button to view records, data elements, and values for
the header and footer regions of this system extract report.

6. Choose the Errors button to view by person any errors that occurred in the system
extract generation process.

• Select an error and choose the More button to view a description of the error.

7. Correct any errors, if necessary, and re-run the system extract process or load the
extract file onto the delivery medium by which it is sent to your third party benefits
administrator or other outside party.

Running the Benefits Enrollment and Confirmation Reports
Run the Benefits Enrollment Kit Report to view electable choices for one or more
persons. The report also displays enrollment deadlines and indicates any default plans
that will be in effect if the person makes no election.

Run the Benefits Confirmation and Summary Report to view enrollment results for one
or more benefits participants. The report displays results for participants who are
enrolled in:

• Plans in program

• Plans not in program

• Multiple programs

Use the Submit Request window to run either report. You need a postscript viewer
to see the results of the report.

To run the benefits enrollment or confirmation report:
1. Select Benefits Reports Wrapper Process in the Name field.

2. Enter the Parameters field to open the parameters window.

3. In the Report Name field, select either the Benefits Enrollment Kit Report or the
Benefits Confirmation and Summary Report.

4. Enter the Effective Date of the report.

5. Select from a variety of criteria to limit the results of the report, such as a:

• Compensation object
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• Life event

• Type of assignment

• Coverage start and end date

6. Indicate if you want to report on results such as:

• Dependents and beneficiaries

• Action items and certifications

• Flexfield data

7. Choose the OK button.

8. Complete the batch process request and choose Submit.

Running the System Extract Batch Processes
Use the Extract Process to extract records from the database for transmission to a third
party, such as a carrier, payroll provider, or other benefits vendor.

Update the user profile option BEN: Max Extract Line Size to set the maximum length of
a record generated by the Extract Write Process.

See: User Profiles, page 1-49

You use the Submit Requests window to run the system extract batch processes for an
extract definition that you have created.

See: Benefits System Extract, page 7-3.

To run the system extract batch process:
1. Select the Extract Process in the Request Name field.

2. Select the Extract Name as the parameter for this process.

3. Enter the effective date on which you want to run the report.

4. Choose the Submit Requests button to run the report when you finish defining
this batch process.

5. View the results of the Extract Process in the Extract Results window by querying
the name of the extract.

See: Viewing Extract Results, page 7-18.

The Extract Process also produces a summary report and an error report that you
can review.

6. Run the Extract Audit Report from the Concurrent Manager to view a limited
selection of records from the extract results.

7. Run the Extract Write Process from the Concurrent Manager to write the results of
the extract to the file you specified in your extract definition.

Restarting an Extract Process
If the Extract Process terminates for any reason, you can run the Extract Restart Process
to resume extracting data records from the point where the Extract Process stopped.
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You run processes from the Submit Requests window.

To restart an Extract Process:
1. Select the Extract Restart Process in the Name field.

2. Enter the Parameters field to open the Parameters window.

3. Select the Benefit Action ID number of the extract process that has stopped.

4. Choose the OK button.

5. Complete the batch process request and choose Submit.

Purging System Extract Results
When you run the Extract Process, the application writes the output to the results
tables. To free table and disk space, you should periodically purge this data.

Run the Extract Results Data Purge process to delete extract results in batch mode. If you
want to delete a specific extract record, you can do so from the Extract Results window.

Prior to purging extract results, confirm that you no longer need the results or that you
have written the output to a file using the Extract Write Process.

To purge a specific extract:
1. Open the Extract Results window.

2. Query the result that you want to delete.

3. Choose the Delete icon from the toolbar.

4. Confirm the deletion.

5. Save your work.

To purge extracts in batch mode:
1. Navigate to the Submit Requests window.

2. Select the Extract Results Data Purge process.

3. Open the parameters window.

4. In the Validate field, select whether to Commit or Rollback the results of the purge
process.

5. Optional: select an Extract Name to purge the results of a single extract.

6. Set the effective date of the process.

Note: The purge process deletes all extract results on or before
the effective date.

7. Choose Submit.
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Copying a System Extract
You can copy a system extract from one business group to another after you define
the data elements, record layouts, file layout, and selection criteria that comprise the
extract definition.

The copy process does not support seeded extract definitions. You copy seeded extracts
directly from the Extract Definition window.

Note: Any extract criteria in your source extract definition must also
exist in your target database. For example, if you filter extract records by
a change event, you must enable the change event in the target business
group. You cannot copy Advanced Criteria.

You run processes from the Submit Requests window.

To copy a system extract:
1. Select Extract Definition Download to Data File in the Name field.

Run this process from the source business group that contains the extract definition
you want to copy.

2. In the Location and File Name field, enter the directory path and file name where
you want to copy the extract.

Your database administrator should provide you with a valid directory path. If you
do not enter a path, the download process writes the file to the directory where you
store your concurrent manager log files.

3. Select the Extract File Layout Name that you want to copy from your list of extract
definitions.

4. Click OK.

5. Complete the batch process request and choose Submit.

To upload a copied system extract:
1. Select Extract Definition Upload from Data File in the Name field.

Run this process from the target business group to which you want to copy the
extract definition.

2. In the Location and File Name field, enter the directory path and file name where
you downloaded the extract definition.

If you are copying between database instances, you must physically move the
downloaded data file to a directory where you can upload the file into the target
business group.

3. Select Commit or Rollback in the Validate field.

The copy process will not update an extract that you have already copied. Run
the upload process in Rollback mode to fix errors listed in the audit log before
you commit the upload.

4. Click OK.

5. Complete the batch process request and choose Submit.
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If you copy an extract definition and any extract criteria in your target business
group do not match the source business group, you must recreate the data in the
target after you complete the upload process. You can make any other changes to
your extract definition after you complete the upload.

If you encounter any errors when uploading the extract definition, verify that you:

• Set the patching level of the target database to the same level as the source database.

• Enable any Change Event codes in the target business group that you use in the
source business group.

• Make available any applicable selection criteria or decoded values in the target
business group.
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Batch Element Entry

BEE (Batch Element Entry)
Using BEE is the fast way to enter batches of elements on a regular basis, or when
compensation policies change. For example, in each payroll period you can use BEE to:

• Record timecard data needed for regular pay processing, such as hours
worked, location or shift worked, absences, and costing or labor distribution data

• Enter special nonrecurring earnings or deductions to be processed in the period

• Enter one-time changes to recurring earnings or deductions

From time to time, you might also use BEE for:

• Enrollment in PTO Accrual Plans, perhaps for a group of newly hired employees

• Changes other types of earnings to maintain information about employee
compensation

When you enter absences in a batch, BEE creates absence records as well as element
entries.

How To Enter a Batch
Each batch has a header and as many batch lines as you require; a batch line is one
element entry for an assignment. Lines within a batch can have different effective
dates. There are three ways you can enter batches:

• Enter input values and other data for one element, and run a concurrent process to
create identical batch lines for all the assignments in an assignment set.

• Create an element set and make entries for each element in the set, one assignment at
a time.

• Select an element and create or update lines for this element using defaults to speed
entry, and changing defaults as necessary when working through the batch.

You can use any combination of these approaches in a batch.

For example, to grant Entitlement pay to all full-time employees in the Overseas
Division, you might create an assignment set for these employees and run a concurrent
process to enter the entitlement information for the set. Then, to handle part-time
employees, you might select the entitlement element in the Batch Lines window and
create a batch line individually for each part-time employee, entering a pro-rata amount.

Validation of Batch Entries
To validate a batch after saving it, you run the BEE validation process from the Batch
Header window. This process checks the header and each line of the batch. For
example, it checks that each assignment number exists in the database, and that you
have specified values for all required input values. It also runs any validation formulas
you have defined for the input values.

You can add your own validation procedures to the standard process. For example, you
can set up control totals or extra business validation.
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Control Totals

Control totals are predefined for checking the number of lines in a batch and for
summing pay values and hours. You can create control totals for other numerical
element input values by defining a lookup for the lookup type CONTROL_TYPE. If you
need other kinds of control totals, you can define lookups for them, but you must also
write a validation procedure for checking the batch against the total.

Transfer to Entries Table
When the batch is ready for transfer to the database, you run the BEE transfer process
from the Batch Header window. This process first performs the same checks as the
validation process. If it finds no errors, it transfers the element entries from the
temporary tables to the Entries table in Oracle HRMS.

You can choose whether the transfer process automatically purges the entries from the
temporary tables after transfer. You can also run a separate purge process.

You should not attempt to process concurrently batches that contain the same
assignments. If an assignment exists in more than one batch that you try to process at the
same time, the processes may fail due to assignment interlocks.

Rollback
After a successful BEE transfer, you can roll back the transfer process if you want to
completely remove it, provided you have not purged the batch from the BEE tables. You
can choose to roll back the transfer even if some of the entries have been processed.

You roll back the transfer from the Submit Requests window. Oracle Payroll users can
also roll back processes from the Payroll Processes window, or individual batch lines
from the Assignment Processes window.

Batch Statuses
The Batch Status depends on the status of the batch header, all the batch lines, and any
control totals specified for the batch. On the Batch Header window, you can see the
following status values:
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Status Meaning

Valid All of the lines, control totals, and header are
valid

Transferred All of the lines, control totals, and header have
been transferred

Transfer Incomplete The header and control totals have been
transferred, along with some of the lines

Unprocessed At least one line, control total, or the header is
unprocessed

Error At least one line, control total, or the header
is in error

Status Mismatch The combination of statuses in the
header, lines, and batch is not consistent. For
example, it is inconsistent for some, but not
all, of the lines to h ave the status Transferred

Note: A status mismatch is not possible if you always use the Batch
Header and Batch Lines windows to enter and maintain a batch.

Elements Not Updated with BEE
You can use BEE to update non-RPA enrollment elements and time capture elements. The
OFHR application maintains a history of all elements including those elements created
and updated by using BEE.

You must update some elements using an RPA only. The following is a list of elements
that you cannot update using BEE:

• Adjusted Basic Pay

• Basic Salary Rate

• Locality pay

• AUO

• Availability Pay

• Supervisory Differential

• Staffing Differential

• Retention Allowance

• Other Pay

• Recruitment Bonus

• Relocation Bonus

• Retirement Plan

• Total Pay

The following two elements have an Input Value that you cannot update using BEE:
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• FERS Eligibility Expires element: Retirement Plan

\

• FEGLI element: FEGLI

Making Batch Element Entries Using BEE
To make batch element entries using BEE, this is the overall procedure:

1. If you want to use a concurrent process to create an identical batch line for several
assignments, create an assignment set.

See: Creating an Assignment Set, Payroll Processing Management Guide

2. If you want to create several batch lines for each assignment, create one or more
customization element sets.

Note: Each element set should contain a maximum of 20 elements
since this is the limit on the number that can be viewed in the Batch
Assignment Entry window (four elements on each of the five tabs).

See: Defining an Element or Distribution Set, Compensation and
Benefits Management Guide

3. Identify the batch, supply any external totals against which to balance it, and
determine what should happen if any of the batch lines duplicate existing element
entries.

See: Entering a Batch Header, page 7-28

4. Enter the batch.

If you are using an assignment set, you enter details for one element and run a
concurrent process to create identical batch lines for each assignment.

See: Creating the Same Line for Several Assignments, page 7-30

Then, if necessary, you can edit these line by line, using defaults to help you enter
missing information.

See: Creating or Editing Individual Batch Lines, page 7-31

If you are using element sets, you select an assignment and element set, enter a line
for each element in the set, select another assignment, repeat the process, and so on.

See: Creating Several Lines for One Assignment, page 7-32

5. Validate the batch.

See: Validating a BEE Batch, page 7-33

Note: If you have several batches to validate, transfer, or purge, you
can process them in a single operation from the Batch Summary
window. See: Processing Multiple BEE Batches Together, page 7-35.

6. Review the results, correct any lines with a status of Error, then validate again.

See: Reviewing BEE Process Results, page 7-34

7. Transfer the batch to the HRMS Entries table.
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See: Transferring a BEE Batch, page 7-33

8. Purge the batch from the BEE tables if this was not done automatically on transfer.

See: Purging a Batch From the BEE Tables, page 7-34

If you have transferred a batch, but not purged it, you can roll back the transfer if
you want to remove it completely from the HRMS Entries table. See: Rolling Back a
BEE Process, page 7-35

Entering a Batch Header
You can enter batches of element entries in the Batch Header and Batch Lines
windows. The header identifies the batch and determines what happens if any of the
batch lines duplicate existing element entries.

To enter a batch header and control totals:
1. Set your effective date to the date when you want the entries to take effect.

2. Enter a name for the batch, and enter a reference number and the source of the
batch, if you require these for your own reference.

3. Select what action the process should take if one of the batch lines matches an
existing element entry for an assignment at the effective date.

• Create New Entry - The process creates a new entry if multiple entries of the
element are allowed by the element definition. If multiple entries are not
allowed, the process sets the status of the batch line to Error.

• Reject Entry - The process sets the status of the batch line to Error.

• Change Existing Entry - The process corrects or updates the existing entry. If
there is more than one existing entry, the process sets the status of the batch
line to Error.

The Undefined option is display-only (for batches created using SQL*Plus or a
similar tool).

4. If you selected Change Existing Entry, select the type of date effective change to
be made to recurring entries:

• Update - The process changes the existing entry from the effective date, but
preserves the previous information. If there are future-dated changes to the
existing entry, the process inserts the change before the next scheduled change.

• Correct - The process corrects the existing entry from its start date through to its
end date. Any future-dated changes are unaffected.

• Override - The process changes the existing entry from the effective date, but
preserves the previous information. If there are future-dated changes to the
existing entry, the process replaces all future-dated changes with the batch line.

Notice that if you select this option, you cannot check the Reject if Future
Changes check box.

The Undefined option is display-only (for batches created using SQL*Plus or a
similar tool).

5. If you want to reject batch lines that match entries that start in the future or for which
future changes are scheduled, check the Reject if Future Changes check box.
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Notice that if you check this box, you cannot select the Override option.

6. If you want the batch to be purged from the temporary tables after successful
transfer to Oracle HRMS, check the Purge After Transfer check box.

7. If you want to cancel a rollback process if the system detects run results for any of
the batch lines, check the Reject Rollback if Results Exist check box.

Note: The process interlock rule (which prevents you rolling back
a payroll process if any further processing has taken place) does
not automatically apply to BEE Rollback. If you leave this box
unchecked, you can perform a rollback even if run results from
payroll processing exist for any of the lines.

8. If you want to delete the batch automatically after a rollback, check the Purge
After Rollback check box.

9. If you are going to use the Assignment Lines window and you want the system to
display automatically any existing lines in this batch for an assignment and element
set you select, check the Auto Query box.

10. If you are going to use the Batch Lines window and you want the system to display
an error if you enter an invalid assignment number, check the Auto Validation box.

Control Totals

11. If you use control totals to validate the batch before transfer, choose the Totals button

12. Select a batch control type (such as Hours, to sum all the values in the Hours input
value, or Line Count, to check the number of lines in the batch).

13. Enter the control total for each control type.

You can enter as many types and totals as you require.

Setting Up BEE Validation Using Control Totals
You can validate a BEE batch against control totals to check for missing lines or
miskeying of amounts.

You can set up as many control types as you require. The following control type is
predefined: _COUNT_LINES_, which checks the number of lines in a batch.

You can set up control types to sum the entries in any numerical input value, using the
Application Utilities Lookups window.

To define a control type:
1. Query the lookup type CONTROL_TYPE.

2. Enter a new lookup code called _TOTAL_COLUMN_x, where x is any unique suffix
you choose to identify this control type. For example, you could define a code
called _TOTAL_COLUMN_BONUS.

3. Enter the meaning for this lookup code. The meaning must be the name of the
input value you want to sum.

The meaning is displayed to users when they select a control type for a batch.

4. Enter a description.
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5. Save your work.

Important: If your control type does not sum a numerical element
input value, do not call the lookup code _TOTAL_COLUMN_x. Use
another naming convention. In this case, you will need to write
a procedure that validates batches against your new control
type. See: Creating Control Totals for the Batch Element Entry
Process, Implementing Oracle HRMS.

Creating the Same Line for Several Assignments
Use the Create Batch Lines window to create identical lines for all assignments identified
by an assignment set. This is a quick way to create many lines for an element or
an element set. If you select a single element and the input values need to vary
between assignments, you can leave these blank and add them later using the Batch
Lines window. If you select an element set, the batch will contain blank lines for each
element. You can leave them blank to accept the default values for the input values, or
you can edit individual lines in the Batch Lines window.

To enter batch lines for an assignment set:
1. Enter or query a batch header in the Batch Header window, and choose the

Assignment Set button.

2. In the Create Batch Lines window, select the assignment set and payroll that identify
the employees you want to create lines for.

3. If you are creating blank lines for an element set, select the set and enter an effective
date for the entries. Then go to step 9.

4. If you are creating lines for a single element, select the element and enter input
values as appropriate.

5. The following fields may be available depending on your localization and the
element you selected:

• Enter Further Information for this element entry.

• For a non-recurring element, optionally select a date within the current payroll
period in the Date Earned field. The entry will not be processed until this date
(that is, the Date Earned of the Payroll Run must be on or after this date).

6. Enter a number in the Subpriority field if you want to determine the processing
sequence of multiple entries in the payroll run. Lower priority numbers process first.

7. If you selected an absence element, enter the absence start and end dates. BEE uses
these dates to create an absence record, however the absence element is entered as
of the effective date.

8. Change the effective date if required.

9. Choose the Process button to submit a concurrent process called Create
Batches. Confirm that you want the system to create the lines.

The Create Batch Lines window now closes, taking you back to the Batch Header
window.

10. Choose the Assignment Set button again if you want to add lines for another
element. Requery your batch and choose the Element Lines button if you want to
view and edit the lines created by the process.

7-30 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Creating or Editing Individual Batch Lines
In the Batch Lines window, you can enter new lines for individual assignments, and
you can view and edit lines created automatically for an assignment set. You can speed
up entry of new lines by entering default input values

Note: A batch can contain lines for as many elements as you
require. Lines within a batch can have different effective dates.

To enter individual batch lines:
1. Enter or query a batch header in the Batch Header window, and choose the Element

Lines button.

2. Select the element for which you want to make entries.

3. To enter default values to speed up the data entry, choose the Defaults button. The
Defaults window displays the input values for the selected element.

4. Enter default values in any of the fields in the Defaults window. These defaults
apply to all new entries in the batch, but not to any entries you have already
made. You can change the defaults at any time during your data entry.

Note: These defaults will override any defaults defined for the
element or element link. To use the element or link defaults, leave
the input value blank. These defaults are entered during the BEE
transfer process.

5. Uncheck the Display check box for any field that you do not want to display in the
Lines window. You can hide any fields for which the default is correct for every entry.

6. In the Lines window, enter the data required for the batch. Lists of values are
available on some fields, but no validation is enforced during data entry.

Note: You will not see any defaults defined for the input values, but
if you leave the input values blank, the defaults are entered during
the BEE transfer process.

7. The following fields may be available depending on your localization and the
element you selected:

• Enter Further Information for this element entry.

• For a non-recurring element, optionally select a date within the current payroll
period in the Date Earned field. The entry will not be processed until this date
(that is, the Date Earned of the Payroll Run must be on or after this date).

• Select a third party payment method in the Payee field to enter information
about a third party recipient of a payment resulting from a deduction.

8. Enter a number in the Subpriority field if you want to determine the processing
sequence of multiple entries in the payroll run. Lower priority numbers process first.

9. You can override the Effective Date for any line. This is the effective start date for a
new entry or the effective date of an update.

10. If you selected an absence element, enter the absence start and end dates. BEE
uses these dates to create an absence record, however the element is entered as
of the effective date.
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11. Save your entries. If you want to make entries for another element, select the
element, enter new defaults, enter the lines, then save again.

Retrieving Existing Batch Lines
Use the Batch Lines window to view existing batch lines.

To retrieve existing batch lines:
1. Do one of the following:

• Select the element in the Element field.

• Check the Unknown Elements check box if you are querying batch lines entered
for an invalid element (or no element) by SQL*Plus or another tool.

2. Choose the Find button.

Updating a Batch
You can update a batch at any time before you transfer it. If you make any changes to a
batch with the status Validated or Error, the batch status changes to Unprocessed.

Creating Several Lines for One Assignment
Use the Batch Assignment Entry window for fast entry of several batch lines for one
assignment. You can make one or more entries for each element in an element set.

To enter lines for one assignment:
1. Enter or query the batch header in the Batch Header window and choose the

Assignment Lines button.

2. Select an assignment and element set.

3. Enter the input values for the first four elements in the set. Lists of values are
available on some fields, but no validation is enforced during data entry.

Note: You will not see any defaults defined for the input values, but
if you leave the input values blank, the defaults are entered during
the BEE transfer process.

4. The following fields may be available depending on your localization and the
element you selected:

• Enter Further Information for this element entry.

• For a non-recurring element, optionally select a date within the current payroll
period in the Date Earned field. The entry will not be processed until this date
(that is, the Date Earned of the Payroll Run must be on or after this date).

• Select a third party payment method in the Payee field to enter information
about a third party recipient of a payment resulting from a deduction.

5. Enter a number in the Subpriority field if you want to determine the processing
sequence of multiple entries in the payroll run. Lower priority numbers process first.

6. You can override the effective date for any line. This is the effective start date for a
new entry or the effective date of an update.

7. For absence elements, enter the absence start and end dates. BEE uses these dates to
create an absence record, however the element is entered as of the effective date.
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8. If there are more elements in the set, click on the next tab to display them. Continue
entering input values.

9. When you have made entries to as many elements as you require from the set, save
your work.

10. If you want to make entries for another assignment, select the assignment, enter the
lines, then save again.

Note: The entry values from the previous assignment are not cleared
automatically from the form. So you can use the same values
without retyping, you can type over the existing values, or you can
use the Down Arrow key to clear the record.

Validating a BEE Batch
The validation process tests each batch line against certain predefined rules about
element entries, and also against your own rules if you have created additional
validation procedures.

You can also validate several batches together from the Batch Summary
window. See: Processing Multiple BEE Batches Together, page 7-35.

To validate a batch:
1. Query the batch in the Batch Header window, and choose the Process button.

2. Select Validate, and choose Start. The system displays the concurrent request ID so
that you can query it on the Requests window.

3. When the concurrent request is completed, query the batch in the Batch Header
window. If you have several batches to review, query them in the Batch Summary
window.

See: Reviewing BEE Process Results, page 7-34.

Transferring a BEE Batch
A batch exists in the temporary BEE tables only until you run the transfer process to
create element entries in the Oracle HRMS Entries table.

You can also transfer several batches together from the Batch Summary
window. See: Processing Multiple BEE Batches Together, page 7-35.

To transfer a batch:
1. Query the batch in the Batch Header window, and choose the Process button.

2. Select Transfer, and choose Start. The system displays the concurrent request ID so
that you can query it on the Requests window.

3. When the concurrent request is completed, query the batch in the Batch Header
window.

If the Batch Status is Transferred, there were no errors in the batch and the process
has created the element entries. The process may have issued messages associated
with the batch header, lines, or control totals.
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If the Batch Status is Error, a control total or all the batch lines have the status
Error. Check the status fields in the Batch Lines window and the Control Totals
window, and review the messages issued by the process.

If the Batch Status is Transfer Incomplete, the process has created element entries for
some of the batch lines. The other lines have the status Error. You must correct these
lines and rerun the transfer process until the Batch Status is Transferred.

Purging a Batch From the BEE Tables
If the Purge After Transfer check box on the Batch Header window is checked when you
run the transfer process, the batch is deleted from the BEE tables automatically after the
transfer. If the box is not checked, you can purge the batch by running a separate process.

You can purge a batch with any status.

Important: You cannot roll back a batch transfer if you have purged
the batch from the BEE tables.

You can also purge several batches together from the Batch Summary
window. See: Processing Multiple BEE Batches Together, page 7-35.

To purge a batch:
1. Query the batch in the Batch Header window, and choose the Process button.

2. Select Purge, and choose Start. The system displays the concurrent request ID so that
you can query it on the Requests window.

When the concurrent request is completed, the batch is purged.

Reviewing BEE Process Results
To review the results of a batch process, use the Batch Summary window. Oracle Payroll
users can also review batch results and retry or rollback batch transfers on the Payroll
Processes window.

To review batch process results:
1. Query one or more batches by name, reference, or status in the Batch Summary

window.

If a batch status is Error, at least one line, control total, or the header is in error.

2. Click on a batch to select it and choose the Errors button to identify the problem
with a batch that has the status Error or Transfer Incomplete. The Messages window
opens. You can view all messages or query them by type: Batch Header, Batch
Line Level, or Control Total.

3. To see and correct a batch, click on it in the Batch Summary window and choose
the View Batch button. The Batch Header window opens with the selected batch
displayed.

4. From the header window, you can view lines, control totals, or messages:

• To view the status of individual lines in the batch, choose the Element Lines
button. In the Batch Lines window, select an element and choose Find.
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Note: If the batch status is Transfer Incomplete, you can only
modify or delete the lines that are in error, or the control totals.

• If you entered control totals for the batch, choose the Totals button on the Batch
Header window to view the status for each control type.

• To view messages for the whole batch, or all lines, or control totals, choose the
Messages button. Use the option group at the top of the Messages window to
control which messages are displayed.

Processing Multiple BEE Batches Together
You can use the Batch Summary window to validate, transfer, or purge several batches
in a single action.

To process multiple batches:
1. Query the batches by name, status, or reference id in the Batch Summary window.

2. Use the Process check boxes to select the batches you want to process. You can use
the Select All button to check all the boxes, then uncheck some as required.

Important: Do not select multiple batches that contain the same
assignments. The batches are processed at the same time, and
interlock problems may arise if two processes try to process the
same assignment. To avoid this, ensure your batches contain
separate sets of assignments.

3. Choose the Process button and select the process you require (Transfer, Validate, or
Purge) and choose Start. The system displays the concurrent request IDs for the
batches so that you can query them on the Requests window.

4. When the concurrent requests are completed, the Batch Summary window displays
the status of each batch and you can review any errors.

See: Reviewing BEE Process Results, page 7-34.

Rolling Back a BEE Process
After a successful BEE transfer or partial transfer, you can roll back the transfer process
if you want to completely remove it. You can choose to purge the batch as part of the
rollback process.

The process interlock rule (which prevents you rolling back a payroll process if any
further processing has taken place) does not apply to BEE Rollback. You can still perform
the rollback even if run results from payroll processing exist for any of the lines.

If the batch included absence entries, the rollback removes the absence records as well
as the element entries.

You run the BEE Rollback process from the Submit Requests window.

Note: Oracle Payroll users can also roll back a batch, or individual batch
lines from the Payroll Processes window or Assignment Processes
window.
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To roll back a BEE process:
1. Select the batch header name of the process you want to roll back.

2. Enter Yes to cancel the rollback process if the system detects run results for any of
the batch lines. Enter No if you want the system to complete the rollback even
though run results exist.

3. Enter Yes to keep the batch after the rollback. Enter No to delete the batch after
the rollback.
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A
Windows and their Navigation Paths

This section lists the default navigation paths for all the windows in Oracle HRMS as
they are supplied. You can use task flow windows directly from the menu, or from
the People and Assignment windows.

The responsibility that you use determines which of these windows you can use and
how you access them. Your system administrator sets up navigation menus and task
flows for your responsibility. They may also create configured versions of some of these
windows using different window titles.

AAP Organization (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an AAP Organization.

3. Choose the Others button and select AAP Organization.

Absence Attendance Type
1. Choose Total Compensation -> Basic -> Absence Types in the Navigator.

Absence Detail
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Others button and select Absence.

Or:

1. Choose Fastpath -> Absence in the Navigator.

2. In the resulting Find window, query the person.

Absence Tracking (Netherlands)
1. Choose People -> Absence Tracking in the Navigator.

Accommodation (France)
1. Choose People -> Accommodations in the Navigator.
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Accrual Bands
1. Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

2. Enter or query an accrual plan name.

3. Choose the Accrual Bands button.

Accrual Plans
1. Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

Accruals
Do one of the following:

1. Choose View -> Employee Accruals in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the Accruals button.

Or:

1. Choose Fastpath -> Accruals in the Navigator.

2. In the resulting Find window, query the person.

Action Parameters
1. Choose Processes and Reports -> Action Parameters in the Navigator.

Action Types
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the Actions button.

Activity Rate
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the

Navigator.

2. Query a compensation object.

3. Choose the Activity Rate button.

Activity Variable Rates and Rules
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the

Navigator.

2. Query a compensation object.

3. Choose the Variable Rates button.
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Actual Premiums
1. Choose Total Compensation -> Rates/Coverage Definitions -> Actual Premiums

in the Navigator.

Additional Absence Detail Information <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Select Absence.

Or:

1. Choose People -> Fastpath -> Absence Information in the Navigator.

Additional Information for German HR Organizations (Germany)
1. Choose Organization -> Define in the Navigator.

2. Choose the Others button.

3. Select German HR Organization.

Additional Information for German Tax Organizations (Germany)
1. Choose Organization -> Define in the Navigator.

2. Choose the Others button.

3. Place the cursor on the German Tax Office field.

Address
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Address button.

Or:

1. Choose Fastpath -> Address in the Navigator.

2. In the resulting Find window, query the person.

Adjust Balance (Payroll)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.
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3. Choose the Assignment button.

4. Choose the Others button and select Adjust Balance.

Or:

1. Choose Fastpath -> Adjust Balances in the Navigator.

2. In the resulting Find window, query the person.

Advanced Criteria
1. Choose Benefits Extract -> Criteria Definition in the Navigator.

2. Query or enter a criteria definition and choose the Advanced tab.

3. Select a Criteria Type and choose the Details button.

Agency Appeals (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Agency Appeals taskflow button.

Agreement Grades
1. Choose Work Structures -> Collective Agreements -> Collective Agreement Grades

in the Navigator.

Alien Data Window (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

5. Choose the Alien Data button.

Alter Effective Date
1. Choose Tools -> Alter Effective Date from the Tools menu.

Alternative Dispute Resolution (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the ADR taskflow button.

Appeals (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Appeals taskflow button.

A-4 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Applicant Entry
1. Choose Recruitment -> Applicant Quick Entry in the Navigator.

Applicant Interview
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select Application.

4. Choose the Interview button.

Application
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select Application.

Or:

1. Choose Fastpath -> Application in the Navigator.

2. In the resulting Find window, query the person.

Application Utilities Lookups
1. Choose Other Definitions -> Application Utilities Lookups in the Navigator.

2. Enter or query a user-defined Type.

Appraisal Template
1. Choose Career Management -> Appraisal Template in the Navigator.

Apprenticeship Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

Approvals: Grade / Step Progression
1. Choose Work Structures -> Grade ->Progression Approval.

Approved Requests for Personnel Action (FD)
1. Choose Request for Personnel Action -> Cancellation/Correction

ASSEDIC Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query an Establishment.

3. Choose the Others button and select ASSEDIC Information.

Assessment Template
1. Choose Career Management -> Assessment Template in the Navigator.

Assign Security Profiles
1. Choose Security -> Assign Security Profiles in the Navigator.

Assignment
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

Or:

1. Choose Fastpath -> Assignment in the Navigator.

2. In the resulting Find window, query the person.

Assignment Budget Values
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant or an employee.

3. Do one of the following:

For an applicant:

• Choose the Others button and select Application.

• Choose the Budgets button.

For an employee:

• Choose the Assignment button.

• Choose the Others button and select Budget Values.

Or:

1. Choose Fastpath -> Assignment Budget in the Navigator.

2. In the resulting Find window, query the person.

Assignment Criteria
1. Choose Payroll -> Assignment Set in the Navigator.

2. Enter or query an assignment set.
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3. Choose the Criteria button.

Assignment Folder
1. Choose View -> Lists -> Assignment Folder in the Navigator.

Assignment History
1. Choose View -> Histories -> Employee Assignment in the Navigator.

Assignment Processes
1. Choose View -> Payroll Process Results in the Navigator.

2. Enter or query a payroll process.

3. Choose the Assignment Process button.

Assignment Set
1. Choose Payroll -> Assignment Set in the Navigator.

Assignment Statuses
1. Choose Work Structures -> Status in the Navigator.

Aubry I Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Aubry I Rebate.

Aubry II Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Aubry II Rebate.

Australian Information (AU)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Australian Information tabbed region.

Authentication Activities (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Authentication Activities

in the Navigator.
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Award/One-Time Payment (FD)
1. Choose Request for Personnel Action -> Award/One-Time Payment

Awards and Decorations pages (France)
1. Choose People -> Awards and Decorations in the Navigator

Balance (Payroll)
1. Choose Total Compensation -> Basic -> Balance in the Navigator.

Balance Classifications (Payroll)
1. Choose Total Compensation -> Basic -> Balance in the Navigator.

2. Enter or query a balance.

3. Choose the Classifications button.

Balance Dimensions (Payroll)
1. Choose Total Compensation -> Basic -> Balance in the Navigator.

2. Enter or query a balance.

3. Choose the Dimensions button.

Balance Feed Control (Payroll)
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Balance Feed Control button.

Balance Feeds (Payroll)
Note: This instance of the Balance Feeds window lets you select more
than one balance for the element to feed.

1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Balance Feeds button.

Bargaining Unit (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Bargaining Unit.
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Batch Assignment Entry
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Enter or query a batch header.

3. Choose the Assignment Lines button.

Batch Header
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

Batch Lines
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Enter or query a batch header.

3. Choose the Element Lines button.

Batch Process Parameters (Advanced Benefits)
1. Choose Processes and Reports -> Batch Process Parameters in the Navigator.

Batch Summary
1. Choose Mass Information eXchange: MIX -> BEE Summary in the Navigator.

Belgian Tax Information (Belgium)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

Beneficiaries (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

4. Choose the Entries button.

5. Select the element representing the benefit for which you are entering a beneficiary.

6. Choose the Others button and select Beneficiary.

Beneficiary Certifications
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query a plan.
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3. Choose the Designations tab.

4. Choose the Beneficiary tab.

5. Choose the Certifications button.

Benefit Contributions (US, CA)
1. Choose Total Compensation -> Basic -> Benefit Contributions in the Navigator.

Benefits Assignment
1. Choose People -> Total Comp Participation -> Person Benefits Assignment in the

Navigator.

Benefits Authentication Form (Advanced Benefits) (US, UK, CA)
1. Choose People -> Total Comp Contribution -> Benefits Authentication Form in the

Navigator.

Benefits Balances
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors

-> Benefits Balances in the Navigator.

Benefits Group
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors ->

Benefits Group in the Navigator.

Benefits Pools (Advanced Benefits)
1. Choose Total Compensation -> Rate/Coverage Definitions -> Benefits Pools in the

Navigator.

Benefits Service Center (Advanced Benefits)
1. Choose People -> Benefits Service Center in the Navigator.

Book Events
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Bookings.

Budget
1. Choose Work Structures -> Budget ->Budget Details in the Navigator.

2. In the resulting Find window, query the budget.
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3. Select a budget version.

4. Choose the Open button.

Budget Characteristics
1. Choose Work Structures -> Budget -> Budget Characteristics in the Navigator.

Budget Details
Note: Follow these steps if you are entering a budget that is not routed
for approval.

1. Choose Work Structures -> Budget ->Budget Details in the Navigator.

2. In the resulting Find window, query the budget.

3. Select a budget version.

4. Choose the Open button.

5. Select a line item in the budget and choose the Periods button.

Note: Follow these steps if you are routing a budget for approval
through a hierarchy of approvers.

6. Choose Work Structures -> Budget ->Worksheet in the Navigator.

7. Define the properties of the worksheet.

8. Choose the Create Worksheet button.

9. Edit the worksheet by entering values for budget line items.

10. Choose the Periods button.

Budget Reallocation
1. Choose Work Structures -> Budget ->Budget Reallocation in the Navigator.

Budget Set
1. Choose Work Structures -> Budget ->Budget Set in the Navigator.

Budget Value Defaults
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group.

3. Choose the Others button and select Budget Value Defaults.

Budgetary Calendar
1. Choose Work Structures -> Budget -> Budget Calendar in the Navigator.
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Budgets
1. Choose Work Structures -> Budget ->Budget Details in the Navigator.

2. In the resulting Find window, query the budget.

Business Group Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group.

3. Choose the Others button and select Business Group Information.

Cadre Life Insurance TA (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Cadre Life Insurance TA.

Calendar
1. Choose Customer and Supplier Maintenance -> Calendar in the Navigator.

Calendar (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

2. Enter or query a pattern.

3. Choose the Calendars button.

Calendar Usages (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

2. Enter or query a pattern.

3. Choose the Calendars button.

4. Choose the Calendar Usages button.

Career Path Names
1. Choose Work Structures -> Job -> Path Name in the Navigator.

Certifications
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the General tab.

4. Choose the Plan or Option tab.
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5. Choose the Certifications button.

Chamber Contribution Information (Germany)
1. Choose Organization -> Define in the Navigator.

2. Choose the Others button.

3. Select German Chamber Tax.

Change Event Log
1. Choose Mass Information eXchange -> System Extract -> Change Event Log in the

Navigator.

Change in Data Element (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Data Element.

Change in Duty Station (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Duty Station.

Change in FEGLI (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in FEGLI.

Change in Hours (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Hours.

Change in Retirement Plan (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Retirement

Plan.

Change in SCD (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in SCD.

Change in Tenure (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Tenure.

Change in Veterans Preference (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Veterans

Preference.
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Change in Work Schedule (FD)
1. Choose Request for Personnel Action -> Change Actions -> Change in Work

Schedule.

Change to Lower Grade (FD)
1. Choose Request for Personnel Action -> Salary Change -> Change to Lower Grade

Choose Set of Books
1. Choose Customer and Suppler Maintenance -> Choose Set of Books in the Navigator.

Cities (US, CA)
1. Choose Other Definitions -> Cities in the Navigator.

City Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Chose the Tax Information button.

4. Choose the Tax information button from the Federal Tax Rules <Employee> window.

5. Choose the Tax information button from the State Tax Rules <Employee> window.

6. Choose the Tax information button from the County Tax Rules <Employee> window.

Claims (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Claims taskflow button.

COBRA Benefits (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select COBRA.

5. Enter or query a qualifying event.

6. Choose the Benefits button.

COBRA Coverage (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.
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4. Choose the Others button and select COBRA.

COBRA Payments (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select COBRA.

5. Enter or query a qualifying event.

6. Choose the Payments button.

COBRA Statuses (Basic Benefits) (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select COBRA.

5. Enter or query a qualifying event.

6. Choose the Statuses button.

Collapse Life Events
1. Choose Total Compensation -> General Definitions ->Additional Setup -> Collapse

Life Events in the Navigator.

Collective Agreements
1. Choose Work Structures -> Collective Agreements ->Define Collective Agreements

in the Navigator.

Collective Agreement Entitlements
1. Choose Work Structures -> Collective Agreements ->Define Collective Agreements

in the Navigator.

2. Query a collective agreement.

3. Choose the Entitlements button.

Collective Agreement Entitlement Items
1. Choose Work Structures -> Collective Agreements ->Define Entitlement Items

in the Navigator.

Collective Agreement Grades (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query a constituency.

3. Choose the Others button and select Collective Agreement Grades.

Collective Agreement and Grade Progression Results
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Collective Agreement and Grade Progression
Results.

Collective Agreement Retained Rights
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Review Retained Rights.

Columns
1. Choose Other Definitions -> Table Structure in the Navigator.

2. Enter or query a table.

3. Choose the Columns button.

Committees
1. Choose Work Structures ->Organization -> Maintain Committees in the Navigator

Communication Delivery Methods
1. Choose Fastpath -> Personal Delivery Method in the Navigator.

Communication Types
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

Communication Type Children
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query a communication type kit.
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3. Choose the View Children button.

Communication Type Delivery Methods
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query or enter a communication type.

3. Choose the Delivery button.

Communication Type Triggers
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query or enter a communication type.

3. Choose the Triggers button.

Communication Type Usages
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Communication Types in the Navigator.

2. Query or enter a communication type.

3. Choose the Usages button.

Competence Details
1. Choose Career Management -> Assessment Template in the Navigator.

2. Enter or query assessment details.

3. Choose the Competencies button.

Competence Profile
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Competence Profile.

Or:

1. Choose Fastpath -> Competence Profile in the Navigator.

Competence Qualifications
1. Choose Career Management -> Competencies in the Navigator.

2. Enter or query a unit standard competence.

3. Choose the Qualifications button.
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Competence Requirements
1. Choose Career Management -> Competence Requirements in the Navigator.

Competence Types
1. Choose Career Management -> Competence Types in the Navigator.

Competencies
1. Choose Career Management -> Competencies in the Navigator.

Complaint People (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

2. Choose the Complaint People taskflow button.

Complaints(FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

Complementary Pension Tranche 2 (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Complementary Pension Tranche 2.

Concurrent Requests (UK)
1. Choose Processes and Reports -> View Requests in the Navigator.

Configurable Business Rules
1. Choose Transaction Maintenance Forms -> Configurable Business Rules in the

Navigator.

Consolidation Sets (Payroll)
1. Choose Payroll -> Consolidation in the Navigator.

Constituency Information (for a Representative Body)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a representative body.

3. Choose the Others button and select Constituency.
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Construction Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Construction Tax Info.

Contact
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

Or:

1. Choose Fastpath -> Contact in the Navigator.

2. In the resulting Find window, query the person.

Contexts
1. Choose Security -> Contexts in the Navigator.

Contract
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button.

4. Choose Contracts.

Or:

1. Choose Fastpath -> Contracts in the Navigator.

2. In the resulting Find window, query the person.

Contribution History (Def Comp 457) (US)
1. Choose View -> Histories ->Entries ->Contribution History

Control Totals
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Choose the Totals button.

Conversion Rate Types
1. Choose Payroll -> Conversion Rate Types in the Navigator.
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Conversion to Appointment (FD)
1. Choose Request for Personnel Action -> Conversion to Appointment

Corps, Grades and Pay Scales (France)
1. Choose Total Compensation -> Programs and Plans -> Plan Design Wizard in the

Navigator

2. Select the French Public Sector business area.

Corrective Actions (FD)
1. Choose Complaints Tracking -> EEO Complaints Tracking

• Choose the Corrective Actions taskflow button.

Costing
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Costing.

Or:

1. Choose Fastpath -> Costing in the Navigator.

2. In the resulting Find window, query the person.

Costing Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Costing.

County Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Chose the Tax Information button.

4. Choose the Tax information button from the Federal Tax Rules <Employee> window.

5. Choose the Tax information button from the State Tax Rules <Employee> window.

Court Orders
1. Choose People -> Total Comp Enrollment -> Court Orders in the Navigator.
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Coverage Across Plan Types
1. Choose Total Compensation -> Rates/Coverage Definitions -> Coverage Across

Plan Types in the Navigator.

Coverage Calculations
1. Choose Total Compensation -> Rate/Coverage Definitions -> Coverage Calculations

in the Navigator.

Covered Dependents (CA)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

4. Choose the Entries button.

Covered Dependents (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Contact.

4. Choose the Entries button.

5. Select the element representing the benefit for which you are entering a dependent.

6. Choose the Others button and select Dependents.

Create Batch Lines
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Enter or query a batch header.

3. Choose the Assignment Set button.

Criteria Definition
1. Choose Mass Information eXchange: MIX -> System Extract -> Criteria Definition

in the Navigator.

Custom Reports
1. Choose Processes and Reports -> Submit Custom Reports in the Navigator.

Customer
1. Choose Customer and Supplier Maintenance -> Customer in the Navigator.
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DADS Files (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select DADS Files.

DADS Types (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

Database Items
1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.

2. Enter or query a formula.

3. Choose the Show Items button.

DateTrack History Change Field Summary
1. Choose Tools -> Datetrack History from the Tools menu.

Deduction (Payroll) (US, CA)
1. Choose Total Compensation -> Basic -> Deductions in the Navigator.

Define Combinations
1. Choose Total Compensation -> Rate/Coverage Definitions -> Combinations in the

Navigator.

Define Extract
1. Choose Benefits Extract -> Extract Definition in the Navigator.

Define Function
1. Choose Other Definitions -> Formula Functions in the Navigator.

Define QuickPaint Report
1. Choose Processes and Reports -> Define a QuickPaint Report in the Navigator.

Define Task Flow
1. Choose Security -> Task Flow Definitions in the Navigator.
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Define Task Flow Nodes
1. Choose Security -> Task Flow Nodes in the Navigator.

Delete Person
1. Choose People -> Delete Personal Records in the Navigator.

Denial of Within Grade Increase (FD)
1. Choose Request for Personnel Action -> Salary Change -> Denial of Within Grade

Increase

Dependent/Beneficiary Designation
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment ->
Dependent/Beneficiary Designation in the Navigator.

Or:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program
in the Navigator.

2. Query a person.

3. Choose the Designees button.

Dependent Certifications
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program.

3. Choose the Dependent Coverage tabbed region

4. Choose the Certifications button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan.

3. Choose the Designations tab.

4. Choose the Dependent tab.

5. Choose the Certifications button.

Dependent Change of Life Event
Do one of the following:
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1. Choose Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program and choose the Dependent Coverage tabbed region.

3. Choose the Dependent Change of Life Event button.

Or:

1. Choose Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan and choose the Designations tabbed region.

3. Choose the Dependent tab.

4. Choose the Dependent Change of Life Event button.

Dependent Change of Life Event Certification
Do one of the following:

1. Choose Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program and choose the Dependent Coverage tabbed region.

3. Choose the Dependent Change of Life Event button.

4. Select a life event and choose the Dependent Change of Life Event Certifications
button.

Or:

1. Choose Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan and choose the Designations tabbed region.

3. Choose the Dependent tab.

4. Choose the Dependent Change of Life Event button.

5. Select a life event and choose the Dependent Change of Life Event Certifications
button.

Dependent Coverage Eligibility Profiles
1. Choose Total Compensation -> General Definitions -> Eligibility Profiles ->

Dependent Coverage in the Navigator.

Dependent Eligibility Profiles
Do one of the following:

1. Choose Choose Total Compensation -> Programs and Plans -> Program Enrollment
Requirements in the Navigator.

2. Query a program and choose the Dependent Coverage tabbed region.

3. Choose the Eligibility Profiles button.
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Or:

1. Choose Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan and choose the Designations tabbed region.

3. Choose the Dependent tab.

4. Choose the Eligibility Profiles button.

Derived Factors
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors

-> Derived Factors in the Navigator.

Or:

1. Choose Work Structures -> Collective Agreements -> Define Derived Factors in the
Navigator.

Derive Notice Period (Belgium)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Employment.

4. Choose Derive Notice Period.

Or

Choose FastPath -> End Employment.

5. Enter or query an employee.

6. Choose Derive Notice Period.

Designation Requirements
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Options in the Navigator.

2. Query or enter an option.

3. Choose the Designation Requirements button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment
Requirements in the Navigator.

2. Query a plan.

3. Choose the General tab.

4. Choose the Plan or Option tab.

5. Choose the Designations button.
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Disability (Not US, Not CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Disabilities.

Or:

1. Choose Fastpath -> Disabilities in the Navigator.

2. In the resulting Find window, query the person.

Dynamic Trigger Definition
1. Choose Other Definitions -> Dynamic Trigger Definition in the Navigator.

Dynamic Trigger Functional Area Grouping
1. Choose Other Definitions -> Dynamic Trigger Functional Area Grouping in the

Navigator.

Duty Stations
1. Choose Federal Maintenance Forms -> Duty Stations in the Navigator.

Earnings (Payroll) (US, CA)
1. Choose Total Compensation -> Basic -> Earnings in the Navigator.

Edit Formula
1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.

2. Enter or query a formula.

3. Choose the Edit button.

EEO-1 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select EEO-1 Filing.

Electable Choices
1. Choose People -> Total Comp Participation

2. Choose the Enrollment Opportunities button

3. Choose the Electable Choices button.
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Elections
1. Choose Work Structures -> Elections

Element
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

Element and Distribution Set
1. Choose Payroll -> Element Set in the Navigator.

Element Classifications (Payroll)
1. Choose Total Compensation -> Basic -> Classification in the Navigator.

Element Entries
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Entries button.

Or:

1. Choose Fastpath -> Entries in the Navigator.

2. In the resulting Find window, query the person.

Element Link
1. Choose Total Compensation -> Basic -> Link in the Navigator.

Element Withholding Reasons (UK)
1. Choose SSP/SMP -> Element Withholding Reasons in the Navigator.

Eligibility
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Plan Eligibility button.

4. Choose the Eligibility button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.
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2. Query or enter a plan.

3. Choose the Options button.

4. Choose the Option Eligibility button.

5. Choose the Eligibility button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plans and Plan Types button.

4. Choose the Plans tab or the Plan Types tab.

5. Choose the Participation Eligibility button.

6. Choose the Eligibility button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Participation Eligibility button.

4. Choose the Eligibility button.

Employee Assignment Processes (Payroll)
1. Choose View -> Assignment Process Results in the Navigator.

Employment Certification (Hungary)
1. Choose Hungarian Web ADI Reports > Create Document in the Navigator.

Employee Review
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Reviews.

Or:

1. Choose Fastpath -> Employee Review in the Navigator.

2. In the resulting Find window, query the person.

Employee Run Result History (Payroll)
1. Choose View -> Histories -> Run Results in the Navigator.

Or:
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1. Choose Fastpath -> End Employment in the Navigator.

2. In the resulting Find window, query the person.

Employer Identification (US, CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Employer Identification

Employment Declaration (AU)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Declaration button.

Employment Equity Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. Position the cursor in the Organization Classifications Name field.

4. Select the Business Group from the List of Values.

5. Position the cursor in the Field with the entry Business Group.

6. Choose the Others button.

7. Select Employment Equity Information and click OK.

8. Double-click in the FlexField to display the window.

Employment History (UK)
1. Choose FastPath -> Employment History in the Navigator.

End Application
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Application.

Or:

1. Choose Fastpath -> End Application in the Navigator.

2. In the resulting Find window, query the person.
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End Employment
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Employment.

Or:

1. Choose Fastpath -> End Employment in the Navigator.

Enrollment Action (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Enrollment Action Types in the Navigator.

Enrollment Opportunities
1. Choose People -> Total Comp Participation

2. Choose the Enrollment Opportunities button.

Enrollment Override
1. Choose People -> Total Comp Enrollment -> Enrollment Override in the Navigator.

Enrollment Rules
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the Timing tab.

4. Choose the Scheduled tab or the Life Event tab.

5. Choose the Enrollment Rules button.

Enter Contingent Workers
1. Choose People -> Maintain Using Templates -> Enter Contingent Workers in the

Navigator.

Enter Employees
1. Choose People -> Maintain Using Templates -> Enter Employees in the Navigator.

Entry Values
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.
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3. Choose the Assignment button.

4. Choose the Entries button.

5. Select an entry and choose the Entry Values button.

Establishment EEO-1 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Reporting Establishment.

3. Choose the Others button and select Establishment EEO-1 Filing.

Establishment VETS-100 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Reporting Establishment.

3. Choose the Others button and select Establishment VETS-100 Filing.

Event Bookings
Do one of the following:

1. Choose People -> Events and Bookings in the Navigator.

Or:

1. Choose Fastpath -> Event in the Navigator.

2. In the resulting Find window, query the person.

Event Groups
1. Choose Total Compensation -> Basic -> Event Groups in the Navigator.

Extension of NTE (FD)
1. Choose Request for Personnel Action -> Extension of NTE

External/Manual Payments (Payroll)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select External Pay.

Or:

1. Choose Fastpath -> External/Manual Payments in the Navigator.

2. In the resulting Find window, query the person.
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Extra Details of Service
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Extra Details of Service.

Or:

1. Choose Fastpath -> Extra Details of Service.

2. In the resulting Find window, query the person.

Extra Element Information
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Extra Information button.

Extra Person Information (FD)
1. Choose People -> Enter and Maintain

2. Enter or query a person.

3. Choose the Others button and select Extra Information.

Extra Person Information Window (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Choose Extra Information.

5. Choose a Type.

6. Choose Details.

Extract Definition
1. Choose Mass Information Exchange -> System Extract -> Extract Definition in the

Navigator.

Extract Results
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.

A-32 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Extract Results Details
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.

2. Query an extract run result and choose the Details button.

Extract Results Errors
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.

2. Query an extract run result and choose the Errors and Warnings button.

Extract Results Header and Trailer
1. Choose Mass Information eXchange -> System Extract -> Extract Results in the

Navigator.

2. Query an extract run result and choose the Header and Trailer button.

Families, Nature of Action (FD)
1. Choose Federal Maintenance Forms -> Families and NOA Families.

Federal Tax Information <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

5. Select the Federal Tax Information region (if not already selected).

Or:

1. Choose People -> Fastpath -> Tax Sign-up in the Navigator.

2. In the resulting Find window, query an employee.

3. Select the Federal Tax Information region.

Federal Tax Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Federal Tax Rules

Federal Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.
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2. Enter or query an employee or applicant.

3. Chose the Tax Information button.

File Layout Advanced Conditions (US, UK, CA)
1. Choose Benefits Extract -> Layout Definition in the Navigator.

2. Choose the File Layout tab and query or enter a file layout.

3. Select a record and choose the Advanced Conditions button.

File Layout Include Conditions
1. Choose Mass Information eXchange -> System Extract -> Layout Definition in the

Navigator.

2. Choose the File Layout tab and query or enter a file layout.

3. Select a record and choose the Include Conditions button.

Financials Options
1. Choose Customer and Supplier Maintenance -> Financials Options in the Navigator.

Flex Credits (Advanced Benefits)
1. Choose Total Compensation -> Rate/Coverage Definitions -> Flex Credits in the

Navigator.

Flex Program (Advanced Benefits)
1. Choose People -> Total Comp Enrollment -> Flex Program in the Navigator.

Form 941 Information (US)
1. Choose View -> Tax Information -> Form 941 Information in the Navigator.

Form Customization
1. Choose Security -> CustomForm in the Navigator.

Forms Configurator - see People Management Configurator

Formula
1. Choose Total Compensation -> Basic -> Write Formulas in the Navigator.

Formula Result Rules (Payroll):
1. Choose Total Compensation -> Basic -> Formula Results in the Navigator.
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Forward Notification To (FD)
1. Choose Workflow Inbox

2. Choose a notification and then choose the Reroute button.

Frequency Rules (Payroll)
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Frequency Rules button.

Funding Distribution
1. Choose Work Structures -> Budget -> Worksheet in the Navigator.

2. Choose the Periods button to open the Budget Details window.

3. Choose the Budget Sets tab.

4. Choose the Budget Set Distribution button.

GL Daily Rates
1. Choose Payroll -> GL Daily Rates in the Navigator.

GL Daily Rates (US, CA)
1. Choose Total Compensation -> Basic -> Global Values in the Navigator.

GL Map (Payroll)
1. Choose Payroll -> GL Flexfield Map in the Navigator.

Globals
1. Choose Total Compensation -> Basic -> Global Values in the Navigator.

Global Pay Scale
1. Choose Work Structures -> Grade -> Global Pay Scale in the Navigator.

Global Security Profile
1. Choose Security -> Global Security Profiles in the Navigator.

Goods and Services
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Goods

and Services in the Navigator.
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Grade Rate
1. Choose Work Structures -> Grade -> Grade Rate in the Navigator.

Grade Scale
1. Choose Work Structures -> Grade -> Grade Steps and Points in the Navigator.

Grade Step Placement
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Grade Step.

Or:

1. Choose Fastpath -> Grade Step in the Navigator.

2. In the resulting Find window, query the person.

Grades
1. Choose Work Structures -> Grade -> Description in the Navigator.

Grades (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Grades.

GREs and other information <Employee> (CA)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Select the GREs and other information region.

Hiring Applicants
1. Choose People -> Maintain Using Templates -> Hire Applicants in the Navigator.

Hungarian Absence Report (Hungary)
1. Choose Hungarian Web ADI Reports > Create Document in the Navigator.
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Imputed Income
1. Choose Total Compensation -> Rate/Coverage Definitions -> Imputed Income

in the Navigator.

Information Type Security (US, UK, CA)
1. Choose Security -> Information Types Security in the Navigator.

Information Type Security (FD)
1. Choose Security -> Information Types

Input Values
1. Choose Total Compensation -> Basic -> Element Description in the Navigator.

2. Enter or query an element.

3. Choose the Input Values button.

Insurance Provider (for a Company) (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Insurance Provider.

Insurance Provider (for an Establishment) (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Insurance Providers.

Insurance Provider Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Pension Provider.

3. Choose the Others button and select Insurance Provider Information.

Investment Options
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Savings Plan

in the Navigator.

2. Query a person.

3. Choose the Investment Options button.
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Job
1. Choose Work Structures -> Job -> Description in the Navigator.

Jobs (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Jobs.

Job Evaluation
1. Choose Work Structures -> Job -> Description in the Navigator.

2. Enter or query a job.

3. Choose the Evaluation button.

Job Grade (CA)
1. Choose Work Structures -> Job -> Job Grade in the Navigator.

Job Groups
1. Choose Work Structures -> Job -> Job Groups in the Navigator.

Job Requirements
1. Choose Work Structures -> Job -> Description in the Navigator.

2. Enter or query a job.

3. Choose the Requirements button.

KR Mass Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of CWK and Employee

Assignments in the Navigator.

KR Mass Employee Assignment Update
1. Choose People -> Mass Updates for Person -> KR Mass Update of Employee

Assignments in the Navigator.

Layout Definition
1. Choose Benefits Extract -> Layout Definition in the Navigator.

Legal Employer Information (AU)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query an organization.

3. Select GRE/Legal Entity and choose the Others button.

4. Select Legal Employer.

5. Click in the blank field.

Letter (for letters)
1. Choose Work Structures -> Recruitment Letter Type in the Navigator.

Letter (for contracts)
1. Choose Work Structures -> Contract Letter Type in the Navigator.

Life Event
Do one of the following:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plans tab or the Plan Types tab.

5. Choose the Life Event button.

Or:

1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Life Event button.

Life Event Certifications
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

2. Query or enter a plan.

3. Choose the General tab.

4. Choose the Plan or Option tab.

5. Choose the Life Event Certifications button.

Life Event Reason Impact on Eligibility (Advanced Benefits)
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Options button.

4. Choose the Life Event Eligibility button.

Windows and their Navigation Paths A-39



Life Event Reasons
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

Limit Rules (Payroll) (US)
1. Choose View -> Wage Attachments -> Limit Rules in the Navigator.

Link Input Values
1. Choose Total Compensation -> Basic -> Link in the Navigator.

2. Enter or query an element.

3. Choose the Input Values button.

List Assignments
1. Choose View -> Lists -> Assignments in the Navigator.

List Budget Variance by Organization (AU)
1. Choose View -> Organization Budgets in the Navigator.

List Employees by Absence Type
1. Choose View -> Lists -> Employees by Absence Type in the Navigator.

List Employees by Element
1. Choose View -> Lists -> Employees by Element in the Navigator.

List Employees by Organization
1. Choose View -> Lists -> Employees by Organization in the Navigator.

List Employees by Position
1. Choose View -> Lists -> Employees by Position in the Navigator.

List Employees by Position Hierarchy
1. Choose View -> Lists -> Emps by Position Hierarchy in the Navigator.

List People by Assignment
1. Choose View -> Lists -> People by Assignment in the Navigator.
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List People by Special Information
1. Choose View -> Lists -> People by Special Information in the Navigator.

Local Tax Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Local Tax Rules.

Locality Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> Locality Pay

Location
1. Choose Work Structures -> Location in the Navigator.

Locations (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Locations.

Lookups
1. Choose Other Definitions -> Application Utilities Lookups in the Navigator.

Maintain Contingent Workers
1. Choose People -> Maintain Using Templates -> Maintain Contingent Workers

in the Navigator.

Maintain Employees
1. Choose People -> Maintain Using Templates -> Maintain Employees in the

Navigator.

Maintain On Line Activities (Advanced Benefits)
1. Choose Total Compensation -> General Definitions ->Authentication Activities

in the Navigator.

Maintain Options Eligibility
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.
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3. Choose the Options button.

4. Choose the Option Eligibility button.

Maintain Plan Eligibility
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Plan Eligibility button.

Maintain Plan Options
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Options button.

Maintain Plan Related Details
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Details button.

Maintain Pop Up Messages (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Message Configuration

in the Navigator.

Maintain Visa Window (US)
1. Choose People -> Maintain Using Templates ->Maintain Visa in the Navigator.

2. Choose an employee.

Manual Payments
1. Choose People -> Total Comp Contribution -> Manual Payments in the Navigator.

Map Career Path
1. Choose Work Structures -> Job -> Career Path in the Navigator.

Map Salary Survey (US, UK, CA)
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Complete the Position window and save your work.

3. Choose the Define Survey Map button.

Or:
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1. Choose Work Structures -> Job -> Description in the Navigator.

2. Complete the Job window and save your work.

3. Choose the Define Salary Map button.

Mass Applicant Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Applicant

Assignments in the Navigator.

Mass Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Assignments in the

Navigator.

Mass Awards (FD)
1. Choose Mass Actions ->Mass Awards

2. Choose Preview Mass Awards

Mass Employee Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Employee

Assignments in the Navigator.

Mass Move
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

Mass Move - Assignments
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window and save your work.

3. Choose the Positions button.

4. Complete the Find Positions window.

5. Choose the Find button.

6. Complete the Mass Move - Positions window.

7. Choose the Assignments button.

Mass Move - Messages
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window and save your work.

3. Choose the Positions button.

4. Complete the Find Positions window and choose the Find button.
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5. Complete the Mass Move - Positions window and choose the Assignments button.

6. Complete the Mass Move - Assignments window and close it.

7. From the Mass Move - Positions window, choose the Valid Grades button.

8. Complete the Valid Grades window and close it.

9. Close the Mass Move - Positions window.

10. From the Mass Move window, choose the Execute button.

11. If the Status field shows In Error or Complete with Warnings, a Message button
appears.

12. If the Message button appears, choose it to view messages in the Mass Move
- Messages window.

Note: Alternatively, you can view messages for saved (but not yet
successfully executed) mass moves as follows:

13. Choose Work Structures -> Position -> Mass Move in the Navigator.

14. Enter the name of the saved mass move in the Description field.

15. When the Mass Move window is populated with data and the Message button
appears, choose the Message button .

Mass Move - Positions
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window.

3. Save your work.

4. Choose the Positions button.

5. In the resulting Find Positions window, select or enter a Source Job and Source
Position.

6. Choose the Find button.

Mass Move - Valid Grades
1. Choose Work Structures -> Position -> Mass Move in the Navigator.

2. Complete the Mass Move window and save your work.

3. Choose the Positions button.

4. Complete the Find Positions window.

5. Choose the Find button.

6. Complete the Mass Move - Positions window.

7. Choose the Valid Grades button.

Mass Position Update
1. Choose Work Structures -> Position -> Mass Position Update
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Mass Realignment (FD)
1. Choose Mass Actions ->Mass Realignment

2. Choose Preview Mass Realignment

Mass Salary (FD)
1. Choose Mass Actions ->Mass Salary

2. Choose Preview Mass Salary

Mass Transfer In (FD)
1. Choose Mass Actions ->Mass Transfer In i

2. Choose Preview Mass Transfer In

Mass Transfer Out (FD)
1. Choose Mass Actions ->Mass Transfer Out

2. Choose Preview Mass Transfer Out

Mass UK Applicant Ass Update
1. Choose People -> Mass Updates for Person -> Mass Update of Applicant

Assignments in the Navigator.

Mass UK Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Assignments in the

Navigator.

Mass UK Employee Assignment Update
1. Choose People -> Mass Updates for Person -> Mass Update of Employee

Assignments in the Navigator.

Mass Update of Applicants
1. Choose Recruitment -> Mass Update of Applicants in the Navigator.

Maternity (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Maternity button.
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Maternity Evidence (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a maternity absence.

5. Choose the Evidence button.

Maternity Pay (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a maternity absence.

5. Choose the SSP/SMP button.

MD/DDS Nurse Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> MDDDS Nurse Pay

Medical Assessments
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Medical Assessments.

Or:

1. Choose Fastpath -> Medical Assessments in the Navigator.

2. In the resulting Find window, query the person.

Messages
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

2. Choose the Messages button.

Message Configuration (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Message Configuration

in the Navigator.

Mileage Element Template (UK)
1. Choose Total Compensation -> Basic -> Mileage Element Template in the Navigator.
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Miscellaneous Plan
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Miscellaneous

Plan in the Navigator.

MIX Batch Header
1. Choose Mass Information eXchange: MIX -> Batch Element Entry in the Navigator.

Monitor Batch Processes (Advanced Benefits)
1. Choose Processes and Reports -> Monitor Batch Processes in the Navigator.

Monthly Participant Premium
1. Choose People -> Total Comp Contribution -> Monthly Participant Premium in the

Navigator.

Monthly Plan or Option Premium
1. Choose -> People -> Total Comp Contribution -> Monthly Premium in the Navigator.

Multiple Worksite Reporting (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select Multiple Worksite Reporting

NACHA Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select NACHA Rules

Name Change (FD)
1. Choose Request for Personnel Action -> Change Actions -> Name Change i

Nature of Action Legal Authorities (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> NOA Legal

Authorities.

Net Calculation Rules
1. Choose Total Compensation -> Basic -> Accrual Plans in the Navigator.

2. Enter or query an accrual plan name.
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3. Choose the Net Calculation Rules button.

New Hire Reporting (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a GRE.

3. Choose the Others button.

4. Select New Hire Reporting

New Zealand Information (NZ)
1. Choose People -> Enter and Maintain.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the New Zealand Information tab.

NOA Codes and Remarks (FD)
1. Choose Federal Maintenance Forms -> NOA Codes and Remarks

Non-Flex Program
1. Choose People -> Total Comp Enrollment -> Non-Flex Program in the Navigator.

Non Pay / Non Duty Status (FD)
1. Choose Request for Personnel Action -> Non Pay / Non Duty Status

Notifications (FD)
1. Choose Request for Personnel Action -> Workflow Inbox

Notifications Summary (FD)
Do one of the following:

1. Choose Workflow Inbox

NQF Assessment (South Africa)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select NQF Assessment.
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NQF Learnership Agreements (South Africa)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select NQF Learnership Agreements.

NQF Qualification Titles (South Africa)

NQF Training (South Africa)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant.

3. Choose the Others button and select NQF Training.

Options
1. Choose Total Compensation -> Programs and Plans -> Options in the Navigator.

Organization
1. Choose Work Structures -> Organization -> Description in the Navigator.

Organization Hierarchy
1. Choose Work Structures -> Organization -> Hierarchy in the Navigator.

Organization Hierarchy Diagrammer
1. Choose Work Structures -> Organization -> Diagrammer in the Navigator.

Organization Hierarchies (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Organization Hierarchies.

Organization Manager Relationship
1. Choose Work Structures -> Organization -> Organization Manager in the Navigator.

Organizational Payment Method
1. Choose Payroll -> Payment Methods in the Navigator.
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Organizations (for a Constituency)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a constituency.

3. Choose the Others button and select Organizations.

Other Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> Other Pay

Other Rates
1. Choose People -> Total Comp Enrollment -> Non-Flex Program in the Navigator.

2. Query a person.

3. Choose the Others button and select Other Rates.

Outcomes Achieved
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Competence Profile.

4. Select a unit standard competence and choose the Outcomes Achieved button.

Or:

1. Choose Fastpath -> Competencies in the Navigator.

2. Query a person.

3. Select a unit standard competence and choose the Outcomes Achieved button.

Outcomes and Assessment Criteria
1. Choose Career Management -> Competencies in the Navigator.

2. Enter or query a unit standard competence.

3. Choose the Outcomes button.

P45 (Payroll) (UK)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Tax Information.

Or:

1. Choose FastPath -> UK P45 Form in the Navigator.
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2. In the resulting Find window, query the person.

Parent Organization
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Parent Organization.

Part Time Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Part Time Rebate.

Participant
1. Choose Total Compensation -> General Definitions -> Eligibility Profiles ->

Participant in the Navigator.

Participation Eligibility Profiles
1. Choose Total Compensation -> General Definitions -> Eligibility Profiles ->

Participation Eligibility Profiles

Or:

1. Choose Work Structures -> Collective Agreements -> Define Eligibility Profiles
in the Navigator.

Participation Overrides (Advanced Benefits)
1. Choose People -> Total Comp Participation -> Participation Overrides in the

Navigator.

Pattern (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

Pattern Time Units (UK)
1. Choose SSP/SMP -> Pattern Time Units in the Navigator.

Pay Adjustment (FD)
1. Choose Request for Personnel Action -> Salary Change -> Pay Adjustment.

Pay Advice Report (Payroll) (UK)
Do one of the following:
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1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Statement of Earnings.

Or:

1. Choose FastPath -> Statement of Earnings in the Navigator.

2. In the resulting Find window, query the person.

Pay Plans (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Pay Plans.

Pay Scale
1. Choose Work Structures -> Grade -> Pay Scale in the Navigator.

Payment Schedule
1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the

Navigator.

2. Query or enter a flex credit definition and choose the Processing tabbed region.

3. Choose the Payment Schedule button.

Payments
1. Choose People -> Total Comp Contribution -> Record Contribution or Distribution

2. Choose the View Payments window.

Payroll
1. Choose Payroll -> Description in the Navigator.

Payroll Balances (UK)
1. Choose Work Structures -> Organization -> Description in the Navigator

2. Enter or query a Business Group

3. Choose the Others button and select Payroll Balances

Payroll Elements (UK)
1. Choose Work Structures -> Organization -> Description in the Navigator

2. Enter or query a Business Group

3. Choose the Others button and select Payroll Elements
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Payroll Processes (Payroll)
1. Choose View -> Payroll Process Results in the Navigator.

Pension Provider (for a Company) (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Company.

3. Choose the Others button and select Pension Provider.

Pension Provider (for an Establishment)(France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Pension Providers.

Pension Provider Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Pension Provider.

3. Choose the Others button and select Pension Provider Information.

Pension Schemes (Hungary)
1. Choose Total Compensation -> Basic in the Navigator.

2. Choose Pension Schemes.

People
1. Choose People -> Enter and Maintain in the Navigator.

People Folder
1. Choose View -> Lists -> People Folder in the Navigator.

People Management Configurator (formerly Forms Configurator)
1. Choose Security -> People Management Configurator in the Navigator.

Performance
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee, and choose the Assignment button.

3. Choose the Salary button.

4. Choose the Performance button.
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Or:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee, and choose the Assignment button.

3. Choose the Others button and select Performance.

Period Dates
1. Choose Payroll -> Description in the Navigator.

2. Enter or query a payroll.

3. Choose the Period Dates button.

Period-to-Date Limits
Do one of the following:

1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->
Period-to-Date Limits in the Navigator.

Or:

1. Choose Total Compensation -> Rates/Coverage Definitions -> Flex Credits in the
Navigator.

2. Query a compensation object.

3. Choose the Activity Rate button.

4. Choose the Period to Date Limit button.

Period Types
1. Choose Other Definitions -> Time Periods in the Navigator.

Person Benefits Assignment
1. Choose People -> Total Comp Participation -> Person Benefits Assignment

Person Benefits Balances
1. Choose People -> Total Comp Participation -> Person Benefits Balances in the

Navigator.

Person Changes
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Person Changes button.

4. Choose the Define Person Change button.
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Person Changes Cause Life Events
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Person Changes button.

Person Communications (Advanced Benefits)
1. Choose People -> Total Comp Enrollment -> Enrollment Process -> Person

Communications in the Navigator.

Person Enrollment Action Items (Advanced Benefits)
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Enrollment Process -> Person
Enrollment Action Items in the Navigator.

Or:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program
in the Navigator.

2. Query a person.

3. Choose the Action Items button.

Person Enrollment Certificates (Advanced Benefits) (CA)
1. Choose People -> Enrollment Process -> Person Enrollment Certificates in the

Navigator.

Person Enrollment Certifications (Advanced Benefits)
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Enrollment Process -> Person
Enrollment Certifications in the Navigator.

Or:

1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program
in the Navigator.

2. Query a person.

3. Choose the Certifications button.

Person Life Events

Person Life Events
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Person Life

Events
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Or (Advanced Benefits):

Choose People -> Total Comp Enrollment -> Enrollment Process -> Person Life
Events

Person Primary Care Provider
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Person Primary

Care Provider in the Navigator.

Person Summary (FD)
1. Choose Person Summary

Person Types
1. Choose Other Definitions -> Person Types in the Navigator.

Person Type Usage
1. Choose Fastpath -> Person Type Usage in the Navigator.

Personal Payment Method
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Pay Method button, or choose the Others button and select Pay Method.

Or:

1. Choose Fastpath -> Pay Method in the Navigator.

2. In the resulting Find window, query the person.

Phone Numbers
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Choose Phones.

Or:

1. Choose Fastpath -> Phones in the Navigator.

2. In the resulting Find window, query the person.
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Picture
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator

2. Enter or query a person.

3. Choose the Picture button.

Or:

1. Choose Fastpath -> Picture in the Navigator.

2. In the resulting Find window, query the person.

Plan and Plan Type
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

Plan Design Copy
1. Choose Total Compensation -> Programs and Plans -> Plan Design Copy in the

Navigator.

Plan Design Wizard
1. Choose Total Compensation - > Programs and Plans -> Plan Design Wizard

Plan Enrollment Requirements
1. Choose Total Compensation -> Programs and Plans -> Plan Enrollment

Requirements in the Navigator.

Plan in Program Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plans tab.

5. Choose the Participation Eligibility button.

Plan Reimbursement
1. Choose Total Compensation -> General Definitions -> Programs and Plans -> Plan

Reimbursement in the Navigator.
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Plan Type Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plan Type tab.

5. Choose the Participation Eligibility button.

Plan Types
1. Choose Total Compensation -> Programs and Plans -> Plan Types in the Navigator.

Plans
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

Position
1. Choose Work Structures -> Position -> Description in the Navigator.

Position (FD)
1. Choose Work Structures -> Position -> Description

Position Abolish (FD)
1. Choose Request for Personnel Action -> Federal Position -> Abolish

Position Change (FD)
1. Choose Request for Personnel Action -> Federal Position Change

Position Copy
1. Choose Work Structures -> Position -> Position Copy in the Navigator.

Position Copy (FD)
1. Choose Work Structures -> Position -> Description

Position Description (FD)
1. Choose Federal Position Description in the Navigator.

Position Description Routing History (FD)
1. Choose Position Description -> Reference button
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Position Establish (FD)
1. Choose Request for Personnel Action -> Federal Position -> Establish

Position Evaluation
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Enter or query a position.

3. Choose the Evaluation button.

Position Hierarchy
1. Choose Work Structures -> Position -> Hierarchy in the Navigator.

Position Hierarchy
1. Choose Work Structures -> Position -> Diagrammer in the Navigator.

Position Occupancy Folder
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Query a position.

3. Choose the Occupancy button.

Position Reporting To
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Enter or query a position.

3. Choose the Reporting To button.

Position Requirements
1. Choose Work Structures -> Position -> Description in the Navigator.

2. Enter or query a position.

3. Choose the Requirements button.

Position Review (FD)
1. Choose Request for Personnel Action -> Federal Position -> Review

Position Transaction
1. Choose Work Structures -> Position -> Position Transaction in the Navigator.
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Possible Certifications
1. Choose People -> Total Comp Participation

2. Choose the Enrollment Opportunities button.

3. Choose the Electable Choices button

4. Choose the Possible Certifications button

Postal/Zip
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors ->

Postal/Zip in the Navigator.

Previous Employment
1. Choose People -> Enter and Maintain in the navigator

2. Query a person.

3. Choose the Others button.

4. Select Previous Employment.

Previous Services Validation pages (France)
1. Choose People ->Services Validation in the Navigator

Primary Care Providers
Do one of the following:

1. Choose People -> Total Comp Enrollment -> Person Primary Care Provider

Or:

1. Choose People -> Total Comp Enrollment -> Flex Program in the Navigator.

2. Query a person.

3. Choose the Care Providers button.

Prior Employment SSP (SSP1L) (UK)
1. Choose SSP/SMP ->Person Details in the Navigator.

2. Enter or query a person.

3. Choose the SSP1L button.

Process Log
1. Choose Processes and Reports -> Process Log in the Navigator.
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Program/Plan Years
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Program/Plan Years in the Navigator.

Programs
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

Program Enrollment Requirements
1. Choose Total Compensation -> General Definitions -> Programs and Plans ->

Program Enrollment Requirements in the Navigator.

Program Participation Eligibility
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Participation Eligibility button.

Program Waive Certifications
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plan Types tab.

5. Choose the Waive button.

6. Choose the Waive Certification button.

Program Waive Reasons
1. Choose Total Compensation -> Programs and Plans -> Programs in the Navigator.

2. Query or enter a program.

3. Choose the Plan and Plan Types button.

4. Choose the Plan Types tab.

5. Choose the Waive button.

Promotion (FD)
1. Choose Request for Personnel Action -> Salary Change -> Promotion

Provincial Employment Standard (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.
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3. Position the cursor in the Organization Classifications Name field.

4. Select the Business Group from the List of Values.

5. Position the cursor in the field with the entry Business Group.

6. Choose the Others button.

7. Select Provincial Employment Standard and click OK.

8. Double-click in the FlexField to display the window.

Provincial Reporting Info. (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. Position the cursor in the Organization Classifications Name field.

4. Select GRE/Legal Entity from the List of Values.

5. Position the cursor in the field with the entry GRE/Legal Entity.

6. Choose the Others button.

7. Select Provincial Reporting Info and click OK.

8. Double-click in the FlexField to display the window.

Provincial Tax Information <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Tax Information button.

5. Select the Provincial Tax Information region.

Or:

1. Choose People -> Fastpath -> Tax Sign-up in the Navigator.

2. In the resulting Find window, query an employee.

3. Select the Provincial Tax Information region.

Qualification Competencies
1. Choose Career Management -> Qualification Types in the Navigator.

2. Enter or select a Qualifications Framework qualification.

3. Choose the Competencies button.

Qualification Types
1. Choose Career Management -> Qualification Types in the Navigator.
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Qualifications
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Qualifications.

Or:

1. Choose Fastpath -> Qualifications in the Navigator.

Quality Increase (FD)
1. Choose Request for Personnel Action -> Salary Change -> Quality Increase

QuickPaint Inquiry
1. Choose Processes and Reports -> Run a QuickPaint Report in the Navigator.

2. Query a report that has been run.

3. Choose the View Report button.

QuickPay (Payroll)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select QuickPay.

Or:

1. Choose Fastpath -> QuickPay in the Navigator.

2. In the resulting Find window, query the person.

Rating Scales
1. Choose Career Management -> Rating Scales in the Navigator.

Realignment (FD)
1. Choose Request for Personnel Action -> Realignment

Reassignment (FD)
1. Choose Request for Personnel Action -> Reassignment

Record Continuing Benefits Payments
1. Choose People -> Total Comp Contribution -> Record Continuing Benefits Payments

in the Navigator.
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Record Layout Advanced Conditions (US, UK)
1. Choose Benefits Extract -> Layout Definition in the Navigator.

2. Choose the Record Layout tab and query or enter a record layout.

3. Select a Data Element and choose the Advanced Conditions button.

Record Layout Include Conditions
1. Choose Mass Information eXchange -> System Extract -> Layout Definition in the

Navigator.

2. Choose the Record Layout tab and query or enter a record layout.

3. Select a Data Element and choose the Include Conditions button.

Recruit / Fill (FD)
1. Choose Request for Personnel Action -> Recruit / Fill

Recruiting For
1. Choose Recruitment -> Recruitment Activity in the Navigator.

2. Enter or query a recruitment activity.

3. Choose the Recruiting For button.

Recruitment Activity
1. Choose Recruitment -> Recruitment Activity in the Navigator.

Reduction in Force Retention Register (FD)
1. Choose Reduction in Force (RIF).

Registered Employer Information (NZ)
1. Choose Work Structures -> Organization -> Hierarchy.

2. Enter or query an organization.

3. Select GRE/Legal Entity in the Organization Classification region.

4. Choose Others -> Registered Employer.

Regulations
1. Choose Total Compensation -> General Definitions -> Additional Setup ->

Regulations in the Navigator.
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Regulatory Bodies and Regulations
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Reporting

Groups in the Navigator.

2. Query or enter a reporting group.

3. Choose the Plan Regulatory Bodies and Regulations button.

Reimbursements Requests (Advanced Benefits)
1. Choose People -> Total Comp Distribution -> Reimbursements Requests in the

Navigator.

Related Person Changes
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Related Person Changes button.

4. Choose the Define Related Person Change button.

Related Person Changes Cause Life Events (Advanced Benefits)
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Life

Event Reasons in the Navigator.

2. Query or enter a life event.

3. Choose the Related Person Changes button.

Remark Codes and Descriptions (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Remark

Codes and Descriptions.

Reporting Categories (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group.

3. Choose the Others button and select Reporting Categories.

Reporting Groups
1. Choose Total Compensation -> General Definitions -> Additional Setup -> Reporting

Groups in the Navigator.

Reporting Statuses (CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.
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2. Enter or query a Business Group.

3. Choose the Others button and select Reporting Statuses.

Representative Body
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a representative body.

3. Choose the Others button and select Representative Body.

Representative Body (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a representative body.

3. Choose the Others button and select Representative Body.

Request for Personnel Action (FD)
1. Choose Request for Personnel Action

Request Letter
1. Choose Recruitment -> Request Recruitment Letter in the Navigator.

Request Set
1. Choose Security -> Report Sets in the Navigator.

Requisition and Vacancy
1. Choose Recruitment -> Requisition and Vacancy in the Navigator.

Restricted Form Process Methods (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Short Form

/ Restricted Data.

RetroPay Set (Payroll)
1. Choose Payroll -> RetroPay Set in the Navigator.

Return to Duty (FD)
1. Choose Request for Personnel Action -> Return to Duty

Reverse Payroll Run (Payroll)
Do one of the following:
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1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Reverse Run.

Or:

1. Choose Fastpath -> Reverse Payroll Run in the Navigator.

2. In the resulting Find window, query the person.

RIF Exception (FD)
1. Choose Request for Personnel Action -> RIF Exception.

Robien Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Robien Rebate.

Roles
1. Choose Transaction Maintenance Forms -> Roles in the Navigator.

Routing
1. Choose Work Structures -> Position -> Position Transaction in the Navigator.

2. Choose Save from the File menu.

Or:

1. Choose Work Structures -> Budget -> Budget Worksheet in the Navigator.

2. Choose Save from the File menu.

3. Choose Save from the File menu.

Routing Group and Groupbox Details (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Routing

Groups and Groupboxes.

Routing Group and Routing List Details (FD)
1. Choose Request for Personnel Action -> Federal Maintenance Forms -> Routing Lists.

Routing History (FD)
Do one of the following:

1. Choose Request for Personnel Action -> Reference button.
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Or

Open the Workflow inbox and select a notification.

2. Choose Routing History button.

Routing Lists
1. Choose Transaction Maintenance Forms ->Routing Lists in the Navigator.

Rows
1. Choose Other Definitions -> Table Structure in the Navigator.

2. Enter or query a table.

3. Choose the Rows button.

Run QuickPaint Report
1. Choose Processes and Reports -> Run a QuickPaint Report in the Navigator.

Salary Administration
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Salary button.

Or:

1. Choose Fastpath -> Salary in the Navigator.

2. In the resulting Find window, query the person.

Salary Basis
1. Choose Total Compensation -> Basic -> Salary Basis in the Navigator.

Salary History
Do one of the following:

1. Choose View -> Histories -> Salary in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the Salary History button.

Or:

1. Choose Fastpath -> Salary History in the Navigator.

2. In the resulting Find window, query the person.
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Salary Management Folder
1. Choose People -> Salary Management in the Navigator.

Salary Surveys
1. Choose Total Compensation -> Basic -> Salary Survey in the Navigator.

Salary Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

Savings Plan
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Savings Plan

in the Navigator.

Savings Plan (UK)
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Savings Plan

in the Navigator.

2. Choose the Record Layout tab and query or enter a record layout.

3. Select a Data Element and choose the Include Conditions button.

Scale Rate
1. Choose Work Structures -> Grade -> Point Values in the Navigator.

Schedules (UK)
1. Choose SSP/SMP -> SSP Qualifying Patterns in the Navigator.

2. Enter or query a pattern.

3. Choose the Calendars button.

4. Choose the Schedules button.

Schools and Colleges
1. Choose Career Management -> Schools and Colleges in the Navigator.

Schools and Colleges Attended
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Schools/Colleges.
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Secondary Statuses
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an applicant or employee.

3. Do one of the following:

For an applicant:

• Choose the Others button and select Application.

• Choose the Secondary Status button.

For an employee:

• Choose the Assignment button.

• Choose the Others button and select Secondary Status.

Or:

1. Choose Fastpath -> Secondary Status in the Navigator.

2. In the resulting Find window, query the person.

Security Groups (UK)
1. Choose Security -> Security Groups in the Navigator.

Security Profile
1. Choose Security -> Profile in the Navigator.

Seniority pages (France)
1. Choose Other Definitions -> Seniority in the Navigator

Separation (FD)
1. Choose Request for Personnel Action -> Separation

Service Areas
1. Choose Total Compensation -> General Definitions -> Eligibility/Rate Factors ->

Service Areas in the Navigator.

Set of Books
1. Choose Customer and Supplier Maintenance -> Set of Books in the Navigator.

Sickness Control Rules (UK)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Business Group
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3. Choose the Others button and select Sickness Control Rules.

Sickness Evidence (UK)
1. Choose SSP/SMP -> Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a sickness absence.

5. Choose the Evidence button.

Sickness Pay (UK)
1. Choose SSP/SMP -> Person Details in the Navigator.

2. Enter or query a person.

3. Choose the Absence button.

4. Enter or query a sickness absence.

5. Choose the SSP/SMP button.

Social Insurance Information (Germany)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Social Insurance Information button.

Social Security Information (Spain)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Social Security Information button.

Or:

1. Choose Fastpath -> Social Security Information in the Navigator.

2. In the resulting Find window, query the person.

Social Security Rebate (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Social Security Rebate.
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Sort
1. Choose Mass Information eXchange -> System Extract -> Layout Definition in the

Navigator.

2. Choose the File Layout tab and select a Record Name.

3. Choose the Sort button.

Special Information
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Special Info button.

Or:

1. Choose Fastpath -> Special Information in the Navigator.

2. In the resulting Find window, query the person.

Special Information Types
1. Choose Other Definitions -> Special Information Types in the Navigator.

Special Rates
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment -> Flex Program

in the Navigator.

2. Query a person.

3. Choose the Special Rates button.

SQWL Employer Rules (1) (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select SQWL Employer Rules (1)

SQWL Employer Rules (2) (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select SQWL Employer Rules (2)

SQWL Generic Transmitter Rules (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).
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3. Choose the Others button and select SQWL Generic Transmitter Rules

SQWL State-Specific Transmitter Rules (Payroll) (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select SQWL State Transmitter Rules

Standard Distributions/Contributions (US)
1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->

Standard Distributions/Contributions in the Navigator.

Standard Holiday Absences <Employee> (CA)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button.

4. Select Standard Holiday Absences.

Or:

1. Choose People -> Fastpath -> Statutory Holidays in the Navigator.

2. In the resulting Find window, query an employee.

Standard Rates
1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->

Standard Rates in the Navigator.

Standard Holiday Absences (FR)
1. Choose FastPath -> Standard Holiday Absences

State Tax Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select State Tax Rules.

State Tax Rules <Employee> (US)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Chose the Tax Information button.
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4. Choose the Tax information button from the Federal Tax Rules <Employee> window.

Statement of Earnings (Payroll) (US)
Do one of the following:

1. Choose View -> Assignment Process Results

2. Choose the SOE Report button.

Or:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Others button and select Statement of Earnings.

Or:

1. Choose Fastpath -> US Statement of Earnings in the Navigator.

2. In the resulting Find window, query the person.

Statement of Earnings (AU)
1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> Statement of Earnings.

Or:

1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> QuickPay.

4. Choose View Results -> Statement of Earnings.

Or:

1. Choose FastPath -> Statement of Earnings.

2. Enter employee details.

Statement of Earnings (New Zealand) (NZ)
1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> Statement of Earnings.

Or:

1. Choose People -> Enter and Maintain.

2. Query a person.

3. Choose Assignment -> Others -> QuickPay.
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4. Choose View Results -> Statement of Earnings.

Or:

1. Choose FastPath -> Statement of Earnings.

2. Enter employee details.

Statutory Holiday Absences
1. Choose FastPath -> Statutory Holiday Absences in the Navigator

Statutory Situations
1. Choose Work Structures -> Statutory Situations in the Navigator.

Step Adjustment (FD)
1. Choose Request for Personnel Action -> Salary Change -> Step Adjustment

Step Increase with Pay (FD)
1. Choose Request for Personnel Action -> Salary Change -> Step Increase with Pay

Submit a New Request
1. Choose Processes and Reports -> Submit Processes and Reports in the Navigator.

2. Select Single Request or a Request Set.

Superannuation Fund Information (AU)
1. Choose Work Structures -> Organization -> Description.

2. Enter or query an organization.

3. Select Payee Organization and choose the Others button.

4. Click in the blank field.

Supplementary Roles
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select Supplementary Roles.

Supplier
1. Choose Customer and Supplier Maintenance -> Supplier in the Navigator.
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System Options
1. Choose Customer and Supplier Maintenance -> System Options in the Navigator.

Table Event Updates (UK)
1. Choose Other Definitions -> Table Event Updates in the Navigator.

Table Structure
1. Choose Other Definitions -> Table Structure in the Navigator.

Table Values
1. Choose Other Definitions -> Table Values in the Navigator.

Taxation Information (New Zealand) (NZ)
1. Choose People -> Enter and Maintain.

2. Enter or query an employee.

3. Choose the Assignment button.

4. Choose the Entries button.

5. Select PAYE Information in the Element Name column.

6. Click on the Entry Values button.

Tax Information (Germany)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Tax Information button.

Tax Information (Ireland)
1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Tax Information button.

Tax Information (Spain)
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Choose the Assignments button.

3. Choose the Tax Information button.

Or:
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1. Choose Fastpath -> Tax Information in the Navigator.

2. In the resulting Find window, query the person.

Terminate
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Employment.

Terminate Applicant
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee.

3. Choose the Others button and select End Application.

Or:

1. Choose Fastpath -> End Application in the Navigator.

2. In the resulting Find window, query the person.

Termination of Grade Retention (FD)
1. Choose Request for Personnel Action -> Salary Change -> Termination of Grade

Retention

Termination of Interim WGI (FD)
1. Choose Request for Personnel Action -> Salary Change -> Termination of Interim

WGI

Termination Payments (AU)
1. Choose FastPath -> Termination Payments.

Transaction Categories
1. Choose Transaction Maintenance Forms -> Transaction Categories in the Navigator.

Transaction Category Wizard
1. Choose Maintenance Forms -> Transaction Category Wizard.

Transaction Status
1. Choose Security -> Transaction Status in the Navigator
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Transaction Templates
1. Choose Transaction Maintenance Forms ->Transaction Templates in the Navigator.

Transport Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Transport Tax Info.

Unions Processing
1. Choose Total Compensation -> Basic -> Union Element Creation Template.

Update Payroll Run (Payroll)
1. Choose Payroll -> Update Payroll Run in the Navigator.

URSSAF Center Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a URSSAF Center.

3. Choose the Others button and select URSSAF Center Information.

URSSAF Information (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select URSSAF.

User Types and Statuses
1. Choose Other Definitions ->User Types and Statuses

Valid Grades (for jobs)
1. Choose Work Structures in the Navigator.

2. Choose either Job -> Description or Position -> Description.

3. Enter or query a job or position.

4. Choose the Valid Grades button.

Valid Payment Methods
1. Choose Payroll -> Description in the Navigator.

2. Enter or query a payroll.
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3. Choose the Valid Payment Methods button.

Variable Rate Profiles
1. Choose Total Compensation -> General Definitions -> Rate/Coverage Definitions ->

Variable Rate Profiles in the Navigator.

VETS-100 Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select VETS-100 Filing.

Vehicle Data Entry (UK)
1. Choose Total Compensation -> Basic -> Vehicle Data Entry in the Navigator.

View Absence History
1. Choose View -> Histories -> Absence in the Navigator.

View Earnings and Deductions Balances (US, CA)
Do one of the following:

1. Choose View -> Employee Balances in the Navigator.

2. Select an employee assignment and choose the Balances button.

Or:

1. Choose Fastpath -> Employee Balances in the Navigator.

2. In the resulting Find window, query the person.

View Element Entry History for Employee
1. Choose View -> Histories -> Entries in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the Entry History button.

View Employee Dental, Medical and Vision Benefits (US)
1. Choose View -> Employee Benefits in the Navigator.

2. Run a query in the Assignments Folder window.

3. Select an employee assignment and choose the View Benefits button.

View Employee Grade Comparatio
1. Choose View -> Grade Comparatio in the Navigator.
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View Enrollment Results
1. Choose People -> Total Comp Enrollment -> Benefits Enrollment Enrollment -> View

Enrollment Results in the Navigator.

View Participation Information (Advanced Benefits)
1. Choose People -> Total Comp Participation -> View Participation Information

in the Navigator.

View Program Structure
1. Choose Total Compensation -> Programs and Plans -> View Program Structure

in the Navigator.

View Run Messages (Payroll)
1. Choose View -> System Messages in the Navigator.

View Tax Balances (US, CA)
Do one of the following:

1. Choose View -> Tax Information -> Tax Balances in the Navigator.

2. Select an employee assignment and choose the Balances button.

Or:

1. Choose Fastpath -> Tax Balances in the Navigator.

2. In the resulting Find window, query the person.

View Vacancies
1. Choose View -> Vacancies in the Navigator.

Visa Data Template
1. Choose People -> Maintain Using Templates -> Maintain Visa Information

W2 Reporting Rules (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Government Reporting Entity (GRE).

3. Choose the Others button and select W2 Reporting Rules.

W941 (Payroll) (US)
1. Choose View -> Tax Information-> Form 941 Information in the Navigator
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Wage Attachment Earnings Rules (US)
1. Choose Total Compensation -> Wage Attachment -> Earnings Rules in the Navigator.

Wage Attachment Exemption Rules (US)
1. Choose Total Compensation -> Wage Attachment -> Exemption Rules in the

Navigator.

Wage Attachment Limit Rules (US)
1. Choose Total Compensation -> Wage Attachment -> Limit Rules in the Navigator.

Waive Participation (Advanced Benefits)
1. Choose People -> Total Comp Participation -> Waive Participation in the Navigator.

Waiving
1. Choose Total Compensation -> Programs and Plans -> Plans in the Navigator.

2. Query or enter a plan.

3. Choose the Waiving button.

WC Codes and Rates (US)
1. Choose Work Structures -> Job -> Workers Compensation Rates in the Navigator

Welfare Tax Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Welfare Tax Info.

What-if Eligibility (Advanced Benefits)
1. Choose People -> Total Comp Participation -> What-if Eligibility in the Navigator.

Work Accident Info (France)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Establishment.

3. Choose the Others button and select Work Accident Info.

Work Choices (Job and Position)
1. Choose Work Structures -> Job or Position -> Description in the Navigator.

2. Enter or query a job or position.
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3. Choose the Work Choices button.

Work Choices (Person)
1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query a person.

3. Choose the Others button and select Work Choices.

Work Day Information
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Work Day Information.

Work Incident
Do one of the following:

1. Choose People -> Enter and Maintain in the Navigator.

2. Enter or query an employee or applicant.

3. Choose the Others button and select Work Incidents.

Or:

1. Choose Fastpath -> Work Incidents in the Navigator.

2. In the resulting Find window, query the person.

Work Schedule (US, CA)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an organization.

3. Choose the Others button and select Work Schedule.

Work Site Filing (US)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query a Reporting Establishment.

3. Choose the Others button and select Work Site Filing.

Worker’s Compensation (US)
1. Choose Work Structures -> Job -> Workers Compensation Codes in the Navigator

Worksheet
1. Choose Work Structures ->Budget ->Worksheet in the Navigator.
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2. Define the properties of the worksheet.

3. Choose the Create Worksheet button.

Worksheet Characteristics
1. Choose Work Structures ->Budget ->Worksheet in the Navigator.

ZA ACB Installation Information (South Africa)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. In Organization Classification, select Business Group.

4. Choose the Others button and select ZA ACB Installation Information.

ZA Tax File Creator Information (South Africa)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. In Organization Classification, select Business Group.

4. Choose the Others button and select ZA Tax File Creator Info.

ZA Tax Information (South Africa)
1. Choose Work Structures -> Organization -> Description in the Navigator.

2. Enter or query an Organization.

3. In Organization Classification, select GRE/Legal Entity.

4. Choose the Others button and select ZA Tax Information.
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B
Reports and Processes in Oracle HRMS

This section shows the default reports and processes in Oracle HRMS as they are
supplied. The responsibility that you use determines which reports you can use and
how you access them.

The reports are divided into functional areas, as follows:

• Organization Structures, page B-2

• Jobs and Positions, page B-2

• People Budgets and Costing, page B-4

• Employment Agreements and Legal Compliance, page B-6

• Recruiting and Hiring, page B-10

• People Management, page B-21

• Competencies, Qualifications and Development, page B-40

• Learning Management, page B-41

• General Compensation Structures, page B-46

• Salary and Grade Related Pay and Progression, page B-47

• Compensation and Awards Management, page B-53

• Leave and Absence Management, page B-54

• Health and Welfare Management, page B-57

• Other Payroll Earnings and Deductions, page B-57

• Payrolls, page B-58

• Payroll Payment and Distributions, page B-58

• Payroll Statutory Deductions and Reporting, page B-61

• Payroll Processing and Analysis, page B-66

• Payroll Event Rules, page B-71

• Deploy Self Service Capability, page B-71

• Workforce Intelligence, page B-71

This is followed by the list of processes, page B-71.
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Reports

Organization Structures

Location Occupancy Report (FD)

Lists all employees that currently or have at one time occupied a Location from the date
you specify to the date the report is run

Organization Hierarchy Report

The organizations and optionally their managers below a selected position in a particular
hierarchy.

Organization Workforce Report (HRMSi)

This report investigates the performance of your organizations as measured by
the increase and decrease in workforce over a selected time period. Click on the
organization name in the table to investigate the workforce changes for a particular
organization, using the Workforce Summary Analysis report.

Jobs and Positions

Employee Job and Position Detail – Employee Work Choices by Job

This worksheet enables you to analyze deployment factors for jobs, people in specific
jobs, and job applicants.

Employee Job and Position Detail – Employee Work Choices by Position

This worksheet enables you to analyze deployment factors for positions, people in
specific positions, and position applicants.

Employee Job and Position Detail – Employee by Job and Position

This worksheet enables you to analyze assignment details for employees within an
organization by job and position.

Job and Position Special Information Detail – Job and Position Special Information

This worksheet enables you to analyze special information types associated with jobs
and positions.

Job and Position Skills Matching Report

Lists of employees, applicants or both that meet some or all skill requirements of a job
or position.

Mass Realignment Deselection (FD)

Lists employees deselected for realignment

Mass Realignment PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a realignment.
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Mass Realignment PA Listing for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
realignment.

Mass Realignment Preview (FD)

Lists employees selected for a realignment

Mass Transfer In Deselection (FD)

Lists employees deselected for a Transfer In action

Mass Transfer In PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a Transfer In
action

Mass Transfer In PA List for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
Transfer In action

Mass Transfer In Preview (FD)

Lists employees selected for a Transfer In action

Mass Transfer Out Deselection (FD)

Lists employees deselected for a Transfer Out action

Mass Transfer Out PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a Transfer Out
action

Mass Transfer Out PA List for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
Transfer Out action

Mass Transfer Out Preview (FD)

Lists employees selected for a Transfer Out action

Organization Separation Report (HRMSi)

This report investigates the performance of your best and worst organizations based
on the workforce separation. This can be an absolute figure or a percentage of the
workforce for the organization. If you click on the organization name in the table you
can investigate the workforce changes for an organization.

Position Description (FD)

Lists the details of an approved position classification
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Position Hierarchy Report

The positions and optionally their holders below a selected position in a particular
hierarchy.

Pre Hire Report (Payroll) (France)

This report has to be delivered to an establishment’s local URSSAF center when a person
is about to become a new employee in that establishment.

Reduction in Force Retention Register (FD)

Lists selected employees

Re-integration Actions Report (Netherlands)

Lists all re-integration actions for employees.

People Budgets and Costing

Budget Period Position Detail Report

Lists the status of all Positions that are part of a specific Budget.

Employee Budget (Non Positional Control) Status – by Grade (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different grades in your enterprise.

Employee Budget (Non Positional Control) Status – by Job (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different jobs for your enterprise.

Employee Budget (Non Positional Control) Status – by Organization (HRMSi)

This report investigates the difference between budgeted and actual workforce for
your enterprise.

Employee Budget (Non Positional Control) Status – by Position (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different positions for your enterprise.

Employee Budget Trend – by Grade (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different grades in your enterprise.

Employee Budget Trend – by Job (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different jobs for your enterprise.

Employee Budget Trend – by Organization (HRMSi)

This report investigates the difference between budgeted and actual workforce for
your enterprise.
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Employee Budget Trend – by Position (HRMSi)

This report investigates the difference between budgeted and actual workforce for
different positions for your enterprise.

Entity Element Summary

Use this report if you administer position control budgets. The report lists the budget
status for a pay element and entity for a specified time interval.

Headcount Budget Trend (HRMSi, DBI)

This report shows changes in actual and budgeted employee headcount over time for
the selected top line manager.

Organization Budget (Non-Position Control) Report (HRMSi)

This report investigates the performance of your best and worst
organizations. Performance can be measured by a variety of indicators, but for
this report, performance is judged by the variance between the budgeted and
actual workforce in each organization. Top organizations are those with the largest
variance. Bottom organizations are those with the least variance.

Note: Non-Position Control reports are based on the budget scheme in
use prior to 11i.PER.G mini-pack.

Organization Budget (Position Control) Report (HRMSi)

This report investigates the performance of your best and worst
organizations. Performance can be measured by a variety of indicators, but for
this report, performance is judged by the variance between the budgeted and
actual workforce in each organization. Top organizations are those with the largest
variance. Bottom organizations are those with the least variance.

Note: Position Control reports are based on the budget scheme in use
since the 11i.PER.G mini-pack.

Organizational Position Summary Report

Lists the budget status for all positions within a Position Control Organization.

Position Element Detail Report

Lists the budget status for all budgeted elements for a specific Position and Organization.

Position Element Summary Report

Lists the budget status for an element for all positions in the Business Group.

Position Summary Report

Lists the budget status of all Positions in a specific Organization.

Report Under Budgeted Entities

Run this report if you administer position control budgets. The report lists the positions
that are under budgeted for the selected organization and all subordinate organizations
in the organization hierarchy.
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Report Under Budgeted Positions (Salary)

HRMS still supports this report, run in previous versions for administering position
control budgets. The report lists the positions that are under budgeted for the
organization you select, and all subordinate organizations in the organization
hierarchy. Oracle recommends you use Report Under Budgeted Entities, which adds the
ability to report on organizations, jobs, and grades, as well as positions.

Social Security Affiliation Archiver (MX)

Mandatory statutory Social Security report that compiles a list of all employee status
changes for a GRE during a reporting period.

Social Security Affiliation Reports (MX)

Arranges the data generated by the Social Security Affiliation Archiver report into a
format suitable for electronic submission to the Mexican Social Security agencies.

Staffing Budget Details Report

Compares actual staffing level with budgeted levels over a specified period.

Workforce Budget (Non-Position Control) Report (HRMSi)

This report compares the amount of workforce you have budgeted for against the
amount of workforce that actually exists. The report enables you to review all the
organizations within a budget. You can select the time period you want to analyze.

Workforce Budget (Position Control) Report (HRMSi)

This report compares the amount of workforce you have budgeted for against the
amount of workforce that actually exists. The report enables you to review all the
organizations within a budget. You can select the time period you want to analyze.

Employment Agreements and Legal Compliance

AA/EEO Breakdown Report (FD)

Government required ethnicity and gender breakdown report by Occupational Category
or Pay Plan

AAP Reports (US)

Provides Job group analysis and workflow analysis reports.

ADA Reports (US)

Shows how your enterprise is responding to the requests of employees with disabilities.

Attestation ASSEDIC Report (Payroll) (FR)

A mandatory report given to an employee on leaving the company. It details specific
information about their employment.
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Bilan Social Report (Payroll) (France)

A statutory report that lists a large number of HR and Payroll related indicators in
order to provide a summary of many aspects affecting a company or establishment’s
human resources in a year.

Compliance (Person, United States Specific) Detail – Detailed Special Information (US)

This Discoverer worksheet enables you to view special employee information for
employees within your organization.

Compliance (Person, United States Specific) Detail – Disabilities (US)

This Discoverer worksheet enables you to view special information concerning
employees with disabilities within your organization.

Compliance (Person, United States Specific) Detail – Disability Accommodations (US)

This Discoverer worksheet enables you to view details about accommodations made
for employees with disabilities across your organization.

Compliance (Person, United States Specific) Detail – OSHA Incidents (US)

This Discoverer worksheet enables you to view details associated with recorded OSHA
incidents within your organization.

CPDF Dynamics Report (FD)

Record of the personnel data changes that occurred for the employee during a reporting
period

CPDF Dynamics Report Transmittal Form (FD)

Transmittal form that accompanies the CPDF Dynamics Report

CPDF OCT Report Transmittal Form (FD)

Transmittal form that accompanies the Organization Component Tracking Report

CPDF Organization Component Tracking Report (FD)

Record of the organizational codes, titles, and hierarchical relationships for organizations
within an agency as of the last day of the quarterly reporting period

CPDF Status Report (FD)

Record of each employee’s personnel data as of the ending date of a fiscal quarter

CPDF Status Report Transmittal Form (FD)

Transmittal form that accompanies the CPDF Status Report

EEO-1 Reports (US)

The Equal Employment Opportunity reports include the EEO Individual Establishment
Report, the EEO Headquarters Report, the EEO Establishment Employment Listing, the
EEO Consolidated Report, and the EEO-1 Exception Report.
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EEO4 Reports (US)

Run this report for state and local governments.

EEO5 Reports (US)

Run this report for the school system or district.

Electronic EEO-1 Report (US)

Generates Equal Employment Opportunity (EEO) reports for your establishment
hierarchy formatted for submission on magnetic media.

Electronic VETS-100 Report (US)

Shows number of special disabled and Vietnam era veterans you employ in each of nine
job categories. Also, show total number of new hires in each job category and number of
new hires in each category who qualify as Vietnam era veterans.

Employee Equal Opportunity by Job (Multiple Hierarchies, United States Specific) Comparison – by
Establishment Hierarchy (HRMSi)

The Establishment Hierarchy worksheet enables you to report on the number of
employee primary assignments (male, female, total) for your reporting establishments
by ethnic origin, location, and job name.

Employee Equal Opportunity by Job (Multiple Hierarchies, United States Specific) Comparison – by
Organization Hierarchy (HRMSi)

The Organization Hierarchy worksheet enables you to report on the number of employee
primary assignments (male, female, total) for your reporting establishments by ethnic
origin, organization and job name.

Employee Equal Opportunity Exceptions (United States Specific) Detail – Employees Outside
Establishment Hierarchy (US)

The Employees Outside an Establishment Hierarchy worksheet enables you to analyze
which employees are at a location that is not in a defined Reporting Establishment
Hierarchy, on a given effective date.

Employee Equal Opportunity Exceptions (United States Specific) Detail – Employees with Missing
Equal Opportunity Data (US)

This Discoverer worksheet enables your organization to discover which employee
primary assignments have missing Ethnic Origin information on a given effective
date. For example, the report will show if an employee is missing data for employment
category or ethnic origin.

Employee Equal Opportunity Exceptions (United States Specific) Detail – Employees Without a Location
(US)

The Employees Without a Location Worksheet enables you to analyze which employee
primary assignments are not assigned a location on a given effective date.
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Employee Equal Opportunity for New Hires (Multiple Hierarchies, United States Specific) Detail – by
Establishment Hierarchy (US)

This Discoverer worksheet enables you to list employee new hires within a given
period. The workbook output includes the following employee primary assignment
details: Job Name, Employee Number, Ethnic Origin, Hire Date, Age at Hire, Date
Hired, Annual Salary, and Current Annual Salary. The list of employees is for a given
establishment hierarchy.

Employee Equal Opportunity for New Hires (Multiple Hierarchies, United States Specific) Detail – by
Organization Hierarchy (US)

This Discoverer worksheet enables you to list employee new hires within a given
period. The workbook output includes the following employee primary assignment
details: Job Name, Employee Number, Ethnic Origin, Hire Date, Age at Hire Date, Hired
Annual Salary, and Current Annual Salary. The list of employees is for a given
organization hierarchy.

Employee Equal Opportunity for Separations (Multiple Hierarchies, United States Specific) Detail – by
Establishment Hierarchy (US)

The Establishment Hierarchy workbook enables you to report on employee separations
for a given period. The workbook output includes the following employee primary
assignment details: Job Name, Employee Number, Gender, Hire Date, Actual Separation
Date, and Separation Reason. The worksheet shows a list of employees for a given
establishment hierarchy.

Employee Equal Opportunity for Separations (Multiple Hierarchies, United States Specific) Detail –
by Organization (US)

This workbook enables you to report on employee separations within a given period. The
workbook output includes the following employee primary assignment details: Job
Name, Employee Number, Gender, Hire Date, Actual Separation Date, and Separation
Reason. The worksheet shows a list of employees for a given Organization Hierarchy.

Employee Equal Opportunity with Salary (Multiple Hierarchies, United States Specific) Detail – by
Establishment Hierarchy (US)

This Discoverer worksheet enables your organization to list employee primary
assignment details including, Job Name, Employee Number, Gender, Ethnic Origin, Hire
date and Salary. The list of employees is for a given Establishment Hierarchy.

Employee Equal Opportunity with Salary (Multiple Hierarchies, United States Specific) Detail – by
Organization Hierarchy (US)

This Discoverer worksheet enables your organization to list employee primary
assignment details including, Job Name, Employee Number, Gender, Ethnic Origin, Hire
date and Salary. The list of employees is for a given Organization Hierarchy.

French D2 Report (Declaration Annuelle Obligatoire D’emploi des Travailleurs Handicapes, de Mutiles de
Guerre et Assimiles) (Payroll) (France)

A mandatory report that all establishments with more than 20 employee’s must submit
each year. It contains details about the number of people employed by the establishment
who are disabled.
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IPEDS Reports (Payroll) (US)

The Integrated Post-secondary Education Data System (IPEDS) reports are submittted to
the National Center for Educational Statistics (NCES). The type of institution determines
which reports you must run.

Mouvements de Main d’Oeuvre Report (Payroll) (France)

A mandatory report that must be produced by each establishment every month. It lists
the people that have joined or left the establishment during that time.

OSHA Reports (US)

Report on work related injuries or illness.

Saudi Disabled Employee Report (SA)

The Saudi Disabled Employee Report creates a list of all the disabled employees in
your organization.

SF-113A Federal Civilian Employment Report (FD)

Summary of federal civilian employment, payroll, and turnover

VETS-100 Reports (US)

Shows number of special disabled and Vietnam era veterans you employ in each of nine
job categories. Also, show total number of new hires in each job category and number of
new hires in each category who qualify as Vietnam era veterans.

Work Incidents Report (Germany)

The Work Incidents Report enables you to print out a formatted copy of the information
entered in the Work Incidents window.

Recruiting and Hiring

Applicant Detail – Address (iRecruitment)

The Address Worksheet enables you to report on the addresses of your job applicants.

Applicant Detail – by Grade (iRecruitment)

The By Grade Worksheet enables you to report on the applicants who have applied to a
specific grade. Grade Name is a page item on this worksheet so you can group your
results by the grades for which your applicants have applied.

Applicant Detail – by Job (iRecruitment)

The By Job Worksheet enables you to report on the applicants that have applied for a
specific job. Job Name is a page item on this worksheet so you can group your results by
the jobs for which your applicants have applied.

Applicant Detail – by Location (iRecruitment)

The By Location Worksheet enables you to report on the applicants who have applied to
a specific location. Location Name is a page item on this worksheet so you can group
your results by the locations to which applicants have applied.
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Applicant Detail – by Organization (iRecruitment)

The By Organization Worksheet enables you to report on the applicants who have
applied to a specific organization. Organization Name is a page item on this worksheet
so you can group your results by organization.

Applicant Detail – by Position (iRecruitment)

The By Position Worksheet enables you to report on the applicants who have applied for
a specific position. Position Name is a page item on this worksheet so you can group
your results by the positions for which your applicants have applied.

Applicant Detail – by Source Type (iRecruitment)

The By Source Type Worksheet enables you to report where applicants have indicated
they saw the advertisement for your job. Source Type is a page item on this worksheet so
you can group your results by the source type the applicant indicated.

Applicant Detail – by Vacancy (iRecruitment)

The By Vacancy worksheet enables you to report the applicants who have applied for a
particular vacancy as of the date you select as your effective date. Vacancy Name is a
page item on this worksheet so you can group your results by the vacancy for which the
applicant has applied.

Applicant Detail – Competence (iRecruitment)

The Competence Worksheet enables you to report on the competencies your applicants
have indicated they possess. Competencies are entered by your applicants as ‘skills’
as part of their account.

Applicant Detail – Detail (iRecruitment)

The Detail worksheet enables you to report on the details of your applicants based
on the parameters you set for the report.

Applicant Detail – Phone (iRecruitment)

The Phone Worksheet enables you to report on the phone numbers of your job applicants.

Applicant Detail – Qualification (iRecruitment)

The Qualification Worksheet enables you to report on the qualifications your applicants
have.

Applicant Detail – School College Attendance (iRecruitment)

The School College Attendance Worksheet enables you to report on the schools and
colleges your job applicants have attended.

Applicant Efficiency (Hires – Manager Hierarchy) PMV report (iRecruitment)

This PMV report measures the average amount of time it takes to fill a vacancy, and
also the average time from filling the vacancy to the employee starting, for employees
starting in the selected reporting period, for hires within a hiring manager hierarchy.
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Applicant Efficiency (Hires – Organization Hierarchy) PMV report (iRecruitment)

This PMV report measures the average amount of time it takes to fill a vacancy, and
also the average time from filling the vacancy to the employee starting, for employees
starting in the selected reporting period, for hires within an organization hierarchy.

Applicant Fill to Start (Hires – Manager Hierarchy) PMV report (iRecruitment)

This PMV report measures the days between the date that the vacancy was filled and the
date on which the successful applicant becomes an employee for employees starting in
the reporting period, for hires within a hiring manager hierarchy.

Applicant Fill to Start (Hires – Organization Hierarchy) PMV report (iRecruitment)

This PMV report measures the days between the date that the vacancy was filled and the
date on which the successful applicant becomes an employee for employees starting in
the reporting period, for hires within an organization hierarchy.

Applicant Time to Fill (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start date of the vacancy and
the date upon which the vacancy is filled for employees starting in the reporting period
for vacancies that are filled in the reporting period, within a hiring manager hierarchy.

Applicant Time to Fill (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start date of the vacancy and
the date upon which the vacancy is filled for employees starting in the reporting period
for vacancies that are filled in the reporting period, within an organization hierarchy.

Applicant Time to Start (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for employees
starting in the reporting period, within a hiring manager hierarchy.

Applicant Time to Start (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for employees
starting in the reporting period, within an organization hierarchy.

Applicant Time to Start Comparison – by Ethnic Origin (United States Specific) (HRMSi) (US)

This worksheet analyses the days required to fill vacancies within a recruitment activity
for ethnic groups in the United States.

Applicant Time to Start Comparison – by Ethnic Origin (United Kingdom Specific) (HRMSi) (UK)

This worksheet analyses the days required to fill vacancies within a recruitment activity
for ethnic groups in the United Kingdom.

Applicant Time to Start Comparison – by Gender (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by gender.
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Applicant Time to Start Comparison – by Grade (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by grade.

Applicant Time to Start Comparison – by Job (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by job.

Applicant Time to Start Comparison – by Location (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by location.

Applicant Time to Start Comparison – by Organization (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by organization.

Applicant Time to Start Comparison – by Vacancy (HRMSi)

This worksheet analyses the days required to fill vacancies within a recruitment activity
by vacancy.

Application Status – Age Analysis (HRMSi)

This worksheet enables you to investigate the current age of applicants for a particular
vacancy.

Application Status – Applicant Statuses (HRMSi)

This worksheet enables you to investigate the applications that exist for a Business
Group, requisition, and recruiter.

Application Status – Recruitment Activity Summary (HRMSi)

This worksheet enables you to investigate recruitment activities within your
Business Group. You can analyze the current status of recruitment activities, for
example, the number of new applicants, the number of offers made, and the number of
terminated applicants. You can view recruitment activity information for a Business
Group, requisition, vacancy, and recruitment type.

Application Status – Vacancy Summary (HRMSi)

This worksheet enables you to investigate vacancies within your Business Group. You
can analyze the current status of vacancies, for example, the number of remaining
applicants, the number of new applicants, and the number of terminated applicants. You
can view vacancy information for a Business Group, recruitment type, and recruitment
activity.

Application Termination Detail – Termination Details

This Worksheet investigates the reasons your enterprise has terminated applications.
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Application Termination Detail – Termination Reasons by Vacancy

This Worksheet investigates the reasons why job applicants have terminated applications
within your enterprise.

Candidate Detail – Address (iRecruitment)

The Address Worksheet enables you to report on the addresses of your candidates.

Candidate Detail – Competency (Skill) (iRecruitment)

The Competency (Skill) Worksheet enables you to report on the competencies of your
candidates. It also includes their level of proficiency. Competencies are entered by your
candidates as ‘skills’ as part of their account

Candidate Detail – Education (iRecruitment)

The Education Worksheet enables you to report on which schools and colleges your
candidates have attended and the qualifications they have achieved.

Candidate Detail – Employment History (iRecruitment)

The Employment History Worksheet enables you to report on the previous and current
employers of your candidates.

Candidate Detail – Job Search Views (iRecruitment)

The Job Search Views Worksheet enables you to report on the saved job searches your
candidates have set up.

Candidate Detail – Personal Detail (iRecruitment)

The Personal Detail Worksheet enables you to report on the details that your candidates
have entered as part of their iRecruitment account.

Candidate Detail – Phone (iRecruitment)

The Phone Worksheet enables you to report on the phone numbers of your candidates.

Candidate Detail – Qualification (iRecruitment)

The Qualification Worksheet enables you to report on the level of qualifications that
your candidates have.

Job Posting Content – Posting Detail (iRecruitment)

The Posting Detail worksheet enables you to report on the details of the job postings
that have been created for your vacancies; for example, job title, job description, and
job requirements.

Recruitment by Authorizer Analysis – Average Days to Recruit by Organization (HRMSi, EDW)

The Average Days to Recruit by Organization worksheet measures both the average
number of days from the vacancy start date to hire and from the application date to hire;
average values for both measures are given for each organization and overall. This
information is reported for each recruitment authorizer within all top-level employing
organizations during a specific calendar year (the year the applicant was hired).
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Recruitment by Authorizer Analysis – Average Days to Recruit by Stage and Job Category (HRMSi, EDW)

The Average Days to Recruit by Stage and Job Category worksheet measures the
average number of days from the start of the application to each recruitment stage
(end of application, first interview, second interview, offer, acceptance, and hire). This
is reported for each job category and each recruitment authorizer, during a specified
calendar year (the year the applicant was hired).

Recruitment by Authorizer Analysis – Average Days to Recruit by Stage and Job (HRMSi, EDW)

The Average Days to Recruit by Stage and Job worksheet measures the average
number of days from the start of the application to each recruitment stage (end of
application, first interview, second interview, offer, acceptance, and hire). This is
reported for each job and for a specified recruitment authorizer, during a specified
calendar year (the year the applicant was hired).

Recruitment by Authorizer Analysis – Average Days to Recruit Over Time (HRMSi, EDW)

The Average Days to Recruit Over Time worksheet measures the average number of
days from both vacancy start date to hire and application date to hire, for the past
three calendar years and the current calendar year; average values for both measures
are also given. This information is reported for each recruitment authorizer within a
specified top-level employing organization.

Recruitment by Authorizer Analysis – Average Days to Recruit (HRMSi, EDW)

The Average Days to Recruit worksheet measures the average number of days from
both the vacancy start date to hire and the application date to hire; average values for
both measures are also shown. This information is given for each recruitment authorizer
within a specified top-level employing organization during a specified calendar year in
which the applicant was hired.

Recruitment by Authorizer Analysis – Vacancy Activity (HRMSi, EDW)

The Vacancy Activity worksheet provides information for a specified authorizer on
the status of each vacancy. It reports the number of openings, vacancy start and end
dates, the number of applicants at each recruitment stage, the average days from vacancy
start and application to hire, and the number of openings remaining.

Recruitment by Recruiter Analysis – Average Days to Recruit by Organization (HRMSi, EDW)

The Average Days to Recruit by Organization worksheet measures both the average
number of days from the vacancy start date to hire and from the application date to hire;
average values for both measures are given for each organization and overall. This
information is reported for each recruiter within all top-level employing organizations
during a specific calendar year (the year the applicant was hired).

Recruitment by Recruiter Analysis – Average Days to Recruit by Stage and Job Category (HRMSi, EDW)

The Average Days to Recruit by Stage and Job Category worksheet measures the average
number of days from the start of the application to each recruitment stage (end of
application, first interview, second interview, offer, acceptance, and hire). This is
reported for each job category and each recruiter, during a specified calendar year (the
year the applicant was hired).
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Recruitment by Recruiter Analysis – Average Days to Recruit by Stage and Job (HRMSi, EDW)

The Average Days to Recruit by Stage and Job worksheet measures the average
number of days from the start of the application to each recruitment stage (end of
application, first interview, second interview, offer, acceptance, and hire). This is
reported for each job and for a specified recruiter, during a specified calendar year (the
year the applicant was hired).

Recruitment by Recruiter Analysis – Average Days to Recruit Over Time (HRMSi, EDW)

The Average Days to Recruit Over Time worksheet measures the average number of
days from both vacancy start date to hire and application date to hire, for the past three
calendar years and the current calendar year; average values for both measures are
also given. This information is reported for each recruiter within a specified top-level
employing organization.

Recruitment by Recruiter Analysis – Average Days to Recruit (HRMSi, EDW)

The Average Days to Recruit worksheet measures the average number of days from
both the application date to hire and the vacancy date to hire; average values for
both measures are also shown. This information is given for each recruiter within a
specified top-level employing organization during a specified calendar year in which
the applicant was hired.

Recruitment by Recruiter Analysis – Vacancy Activity (HRMSi, EDW)

The Vacancy Activity worksheet provides information for a specified recruiter
on the status of each vacancy within a specified period. It reports the number of
openings, vacancy start and end dates, the number of applicants at each recruitment
stage, the average days from vacancy start and application to hire, and the number
of openings remaining.

Recruitment Efficiency Comparison – Hires vs. Openings Summary (HRMSi)

This worksheet shows the rate of hires in your organization compared to job openings.

Recruitment Efficiency Comparison – Recruitment Activity Ratios (HRMSi)

This worksheet investigates the cost of your recruitment activities.

Recruitment Efficiency Comparison – Vacancy Ratios by Recruitment Activity (HRMSi)

This worksheet investigates how successful specific recruitment activities have been.

Recruitment Efficiency Comparison – Vacancy Ratios (HRMSi)

This worksheet investigates how successful your recruitment has been.

Recruitment Success Report (HRMSi)

This report provides a trend analysis showing the changes in recruitment success over
a selected period of time. You can analyze the total number of openings recorded for
vacancies, the total number of openings that have been filled, and the Performance
Management Framework recruitment success targets.

Requisition Summary Report

Applicants and their interview schedules for a selection of vacancies.
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Vacancy Ageing (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start of the vacancy and the
current date, for vacancies within a hiring manager hierarchy.

Vacancy Ageing (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of days between the start of the vacancy and the
current date, for vacancies within an organization hierarchy.

Vacancy Detail – by Grade (iRecruitment)

The By Grade worksheet enables you to report on the vacancies that exist with a
specific grade. Grade Name is a page item on this worksheet so you can group your
results by the vacancy grade.

Vacancy Detail – by Hiring Manager (iRecruitment)

The By Hiring Manager worksheet enables you to report on the vacancies associated
with each hiring manager. Hiring Manager Name is a page item on this worksheet so
you can group your results by vacancy hiring manager.

Vacancy Detail – by Job (iRecruitment)

The By Job worksheet enables you to report on the vacancies that exist for a specific
job. Job Name is a page item on this worksheet so you can group your results by the
vacancy job.

Vacancy Detail – by Location (iRecruitment)

The By Location worksheet enables you to report on the vacancies available at each
location. Location Name is a page item on this worksheet so you can group your results
by the location of the vacancy.

Vacancy Detail – by Organization (iRecruitment)

The By Organization worksheet enables you to report on the vacancies that are available
in each of your organizations.

Vacancy Detail – by Position (iRecruitment)

The By Position worksheet enables you to report on the vacancies that exist for a specific
position. Position Name is a page item on this worksheet so you can group your results
by vacancy position.

Vacancy Detail – by Recruiter (iRecruitment)

The By Recruiter worksheet enables you to report on the vacancies associated with
each recruiter. Recruiter Name is a page item on this worksheet so you can group
your results by vacancy recruiter.

Vacancy Detail – by Vacancy Status (iRecruitment)

The By Vacancy Status worksheet enables you to report on the vacancies with each
vacancy status. Vacancy Status is a page item on this worksheet so you can group
your results by vacancy status.
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Vacancy Detail – Detail (iRecruitment)

The Detail Worksheet enables you to report on the details of the vacancies in your
organization hierarchy.

Vacancy Hire Success (Organization Hierarchy) Template Analytics by Year (HRMSi)

This worksheet enables you to see vacancy success for each year. The template
worksheets provide a starting point for developers to create analytic reports.

Vacancy Hire Success (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet calculates the vacancy success rates for vacancies with the same opening
and closing dates, for each organization, location, job, grade, and position. The template
worksheets provide a starting point for developers to create analytic reports.

Vacancy Status (System Defaults – Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of vacancies at each vacancy status as of the
current date, within a hiring manager hierarchy. These reports only include the vacancy
statuses supplied with the application. Any vacancy statuses you have added will not
be taken into account by these reports.

Vacancy Status (System Defaults – Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the number of vacancies at each vacancy status as of the
current date, within an organization hierarchy. These reports only include the vacancy
statuses supplied with the application. Any vacancy statuses you have added will not
be taken into account by these reports.

Vacancy Success (Organization Hierarchy) Trend Analytics By Bi Month (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by bimonthlies.

Vacancy Success (Organization Hierarchy) Trend Analytics By Month (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by months.

Vacancy Success (Organization Hierarchy) Trend Analytics By Quarter (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by quarters.

Vacancy Success (Organization Hierarchy) Trend Analytics By Semi Year (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by semi-years.

Vacancy Success (Organization Hierarchy) Trend Analytics By Year (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success over a
selected period of time group by years.
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Vacancy Success (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success
across geographical areas.

Vacancy Success (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet provides a trend analysis showing the changes in vacancy success
across organizations in your enterprise.

Vacancy Time from Fill to Start (Manager Hierarchy) Status (iRecruitment)

This PMV report measures the average number of days between filling a vacancy and
the employee starting, for vacancies that started in the reporting period, and vacancies
within a hiring manager hierarchy.

Vacancy Time from Fill to Start (Organization Hierarchy) Status (iRecruitment)

This PMV report measures the average number of days between filling a vacancy and
the employee starting, for vacancies that started in the reporting period, and vacancies
within an organization hierarchy.

Vacancy Time to Start (Manager Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for vacancies
that start in the reporting period, and vacancies within a hiring manager hierarchy.

Vacancy Time to Start (Organization Hierarchy) Status PMV report (iRecruitment)

This PMV report measures the average number of days between the start of the vacancy
and the date upon which the successful applicant becomes an employee, for vacancies
that start in the reporting period, and vacancies within an organization hierarchy.

Workforce Recruitment Stage Analysis – Average Days to Recruit by Stage and Job Category (HRMSi,
EDW)

The Average Days to Recruit by Stage and Job Category worksheet provides recruitment
information for each job category in a top-level employing organization within a
specified calendar year. It reports the average number of days from application to
termination (the date the application was ended by the employer or applicant), first
interview, second interview, offer, acceptance, and hire.

Workforce Recruitment Stage Analysis – Average Days to Recruit by Stage and Job (HRMSi, EDW)

The Average Days to Recruit by Stage and Job worksheet provides recruitment
information for each job (for example, Line Manager or Sales Person) in a top-level
employing organization within a specified calendar year. You can report on the average
number of days from application to termination (the date the application was ended by
the employer or applicant), first interview, second interview, offer, acceptance, and hire.

Workforce Recruitment Stage Analysis – Efficiency (Average Days) (HRMSi, EDW)

The Efficiency (Average Days) worksheet provides information concerning the
recruitment efficiency of each top-level employing organization for a specified calendar
year. It reports the average number of days from application to termination (the
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date the application was ended by the employer or applicant), first interview, second
interview, offer, acceptance, and hire.

Workforce Recruitment Stage Analysis – Recruitment by Age Band (HRMSi, EDW)

The Recruitment by Age Band worksheet provides a recruitment summary by age
band for a selected top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Disability Status (HRMSi, EDW)

The Recruitment by Disability Status worksheet provides a recruitment summary by
disability status (disabled, not disabled, or undefined) for a selected top-level employing
organization. You can report on the following measures: head count, full time
equivalent, average number of days between application and hire for each assignment
by organization and year, and average number of days between vacancy start and hire
for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Gender (HRMSi, EDW)

The Recruitment by Gender worksheet provides a recruitment summary by gender
for a selected top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Location (HRMSi, EDW)

The Recruitment by Location worksheet provides a recruitment summary by location
for a selected top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Recruitment by Organization (HRMSi, EDW)

The Recruitment by Organization worksheet provides a recruitment summary for
a specified top-level employing organization. You can report on the following
measures: head count, full time equivalent, average number of days between application
and hire for each assignment by organization and year, and average number of days
between vacancy start and hire for each assignment by organization and year.

Workforce Recruitment Stage Analysis – Vacancy Activity by Job (HRMSi, EDW)

The Vacancy Activity by Job worksheet provides information for a specified top-level
employing organization and job on the status of each vacancy; for example, the number
of openings, vacancy start and end dates, the number of applicants at each recruitment
stage, the average days from vacancy start and application to hire, and the number
of openings remaining.

Workforce Recruitment Stage Analysis – Vacancy Activity (HRMSi, EDW)

The Vacancy Activity worksheet provides information for a specified top-level
employing organization on the status of each vacancy; for example, the number of
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openings, vacancy start and end dates, the number of applicants at each recruitment
stage, the average days from vacancy start and application to hire, and the number
of openings remaining.

People Management

Annualized Turnover (HRMSi, DBI)

This report displays the annualized employee headcount turnover for the selected
top line manager.

Annualized Turnover Status (HRMSi, DBI)

The report displays the percentage-annualized turnover for the top line manager. You
access this report from the Total column in the Annualized Turnover report.

Annualized Turnover Trend (HRMSi, DBI)

This report shows changes in the annualized employee headcount turnover over time
for the selected top line manager. The report categorizes turnover into voluntary and
involuntary separations.

Assignment Status Report

All employees, applicants or both assigned to selected work structures.

Company Certificate Report (Spain)

Contains the personal, employment, and social security information of an employee who
is terminated or on leave such as maternity leave or leave due to suspended assignment.

Employee Anniversary and Birthday (Multiple Hierarchies) Detail – by Organization Hierarchy

The Organization Hierarchy worksheet allows you to report on employee anniversaries
(total service) and birth date (in the format DD-MON). Employees are listed by
organization. Total and current service calculations are in respect of the system date
(SYSDATE).

Employee Anniversary and Birthday (Multiple Hierarchies) Detail – by Supervisor Hierarchy

The Supervisor Hierarchy worksheet enables you to report on employee anniversaries
(total service) and birth date (in the format DD-MON).

Employee by Supervisor (Multiple Hierarchies) Status – by Organization Hierarchy

The Organization Hierarchy worksheet enables you to report on the supervisor hierarchy
and salary details for your employees, by organization.

Employee by Supervisor (Multiple Hierarchies) Status – by Supervisor Hierarchy

The Supervisor Hierarchy worksheet enables you to report on the supervisor hierarchy
and salary details for your employees by supervisor.

Employee Composition Detail – by Assignment Details

This worksheet enables you to analyze workforce assignment details by
organization, job, position, or grade.
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Employee Composition Detail – by Salary Band

This worksheet enables you to analyze the distribution of employees within an
organization by length of service.

Employee Composition Detail – by Time In Service Band

This worksheet enables you to analyze the distribution of employees within an
organization by length of service.

Employee Hired or Terminated Detail for Organization Hierarchy

This worksheet enables you to report on employees who terminated or were hired
within two specified dates for a given organization and its subordinate organizations.

Employee Mailing Address (Multiple Hierarchies, United Status Specific) Detail – by Organization
Hierarchy (US)

The Organization Hierarchy worksheet enables you to report on employee current
primary addresses in a United States legislation specific address format, for a given
organization and its subordinate organizations.

Employee Mailing Address (Multiple Hierarchies, United Status Specific) Detail – by Supervisor Hierarchy
(US)

The Supervisor Hierarchy worksheet enables you to report on employee current primary
addresses in a United States legislation specific address format, for a given supervisor
and his/her subordinates.

Employee Mailing Address (Multiple Hierarchies) Detail – by Organization Hierarchy

This Worksheet enables you to report on current employee primary addresses in a
non-legislative specific address format, for a given organization and its subordinate
organizations.

Employee Mailing Address (Multiple Hierarchies) Detail – Supervisor Hierarchy

This Worksheet enables you to report on current employee primary addresses in a
non-legislative specific address format, for a given supervisor and his/her subordinates.

Employee Movement by Organization Analysis – Hires

This worksheet displays hire information in detail. The worksheet enables you to analyze
hire information by job, position, assignment, or location. It enables you to analyze hire
trends within an organization, and analyze skills required within an organization.

Employee Movement by Organization Analysis – Hires, Terminations and Transfers by Quarter (HRMSi)

This worksheet enables you to view high-level information about the value of
hires, terminations, and transfers in all organizations within your Business Group, by
year quarter. The resulting information allows you to analyze workforce changes by
quarter, and compare workforce change across all organizations within a Business Group.

Employee Movement by Organization Analysis – Terminations

This worksheet enables you to analyze terminations within your organizations in
detail. For each termination you can: Analyze employee termination across all
organizations within a Business Group.
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Employee Movement by Organization Analysis – Transfers In

This worksheet enables you to investigate the total budget value of people transferring
into different organizations in your Business Group. For each transfer you can analyze
the organization transferred from, the location transferred from, and the position/job
transferred from.

Employee Movement by Organization Analysis – Transfers Out

This worksheet investigates the total budget value of people transferring out of different
organizations in your Business Group. For each transfer out you can analyze the
organization transferred to, the location transferred to, and the position/job transferred
to.

Employee Organization Transfer (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee primary assignment organization
transfers during a given period for a given organization and its subordinate
organizations. The worksheet output includes the employee primary assignment details
before and after the transfer, including job name, organization name, and supervisor
name.

Employee Organization Transfer (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee primary assignment organization
transfers during a given period for a given supervisor and his/her subordinates. The
worksheet output includes the employee primary assignment details before and after the
transfer, including job name, organization name, and supervisor name.

Employee Primary Assignment (Multiple Hierarchies) Detail – by Organization Hierarchy

The Organization Hierarchy worksheet enables you to report on basic employee details
by employee primary assignment. Employees are listed for each organization and
for subordinate organizations.

Employee Primary Assignment (Multiple Hierarchies) Detail – by Supervisor Hierarchy

The Supervisor Hierarchy worksheet enables you to report on basic employee details
by employee primary assignment. Employees are listed for a given Supervisor and
his/her subordinates.

Employee Primary Assignment Count (by Location and Employment Category, Multiple Hierarchies)
Comparison – by Organization Hierarchy (HRMSi)

The Organization Hierarchy worksheet enables you to calculate employee primary
assignment numbers by location for a given organization. You can use the worksheet
parameters to include specific assignment statuses or exclude particular person types to
suit your requirements.

Employee Primary Assignment Count (by Location and Employment Category, Multiple Hierarchies)
Comparison – by Supervisor Hierarchy (HRMSi)

The Supervisor Hierarchy worksheet enables you to calculate employee primary
assignment numbers by location for a given supervisor. You can use the worksheet
parameters to include specific assignment statuses or exclude particular person types to
suit your requirements.
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Employee Primary Assignment Count (by Location and Employment Category, Multiple Hierarchies)
Comparison – by Without Organization Hierarchy (HRMSi)

The Without Organization Hierarchy worksheet enables you to calculate employee
primary assignment numbers by location without using organization or supervisor
hierarchies. You can use the worksheet parameters to include specific assignment
statuses or exclude particular person types to suit your requirements.

Employee Primary Assignment Count (by Organization and Employment Category, Multiple Hierarchies)
Comparison – by Organization Hierarchy (HRMSi)

The Organization Hierarchy worksheet enables you to report on employee primary
assignment numbers for a given organization. The worksheet parameters enable you
customize the worksheet output to suit your own requirements; for example, you can
choose assignment types to include or person types to exclude from the worksheet.

Employee Primary Assignment Count (by Organization and Employment Category, Multiple Hierarchies)
Comparison – by Organization Hierarchy (Rollup) (HRMSi)

The Organization Hierarchy (Rollup) worksheet allows you to report on employee
primary assignment numbers by Organization Rollup for a given organization. The
worksheet parameters enable you customize the worksheet output to suit your own
requirements; for example, you can choose assignment types to include or person types
to exclude from the worksheet.

Employee Primary Assignment Count (by Organization and Employment Category, Multiple Hierarchies)
Comparison – by Supervisor Hierarchy (HRMSi)

The Supervisor Hierarchy worksheet enables you to report on employee primary
assignment numbers by organization for a given supervisor. The worksheet parameters
enable you customize the worksheet output to suit your own requirements; for
example, you can choose assignment types to include or person types to exclude from
the worksheet.

Employee Separation (Organization Hierarchy) Template Analytics by Year, Organization and Separation
Category (HRMSi)

This investigates separations from the workforce for different organizations and different
leaving reasons over yearly periods. The template worksheets provide a starting point
for developers to create analytic reports.

Employee Separation (Organization Hierarchy) Template Analytics Details (HRMSi)

This worksheet tells you how separations from your workforce vary across
different groups within your organization, such as organization, job, and
location. For any date, you can see how many separations have occurred within
each organization, location, job, grade, position, separation category, and separation
reason. The template worksheets provide a starting point for developers to create
analytic reports.

Employee Separation by Competence (Organization Hierarchy) Status Analytics by Geography Area
(HRMSi)

This worksheet compares employee competencies to separations across geographical
areas.
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Employee Separation by Competence (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet compares employee competencies to separations across organizations.

Employee Separation by Competence (Organization Hierarchy) Status Analytics by Rank Level (HRMSi)

This worksheet enables you to see the number of people who have separated from the
workforce who hold competencies at a specific rank level.

Employee Separation by Competence (Organization Hierarchy) Status Analytics by Scale Level (HRMSi)

This worksheet enables you to see the number of people who have separated from the
workforce who hold competencies at a specific scale level.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet compares employees’ competencies, to the rate of separation, grouped
by bimonthlies.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet compares employees’ competencies to the rate of separation, grouped
by months.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet compares employees’ competencies to the rate of separation, grouped
by quarters.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet compares employees’ competencies, to the rate of separation, grouped
by semi-years.

Employee Separation by Competence (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet compares employees’ competencies, to the rate of separation, grouped
by years.

Employee Separation by Length of Work (Organization Hierarchy) Status Analytics by Geography Area
(HRMSi)

This worksheet compares employees’ length of service within each geographical area.

Employee Separation by Length of Work (Organization Hierarchy) Status Analytics by Organization
(HRMSi)

This worksheet compares employees’ length of service within each organization.

Employee Separation by Length of Work (Organization Hierarchy) Status Analytics by Separation
Category & Reason (HRMSi)

This worksheet compares the length of service of employees who have separated from
your enterprise, grouped by separation category and reason.
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Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each bimonthly.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each month.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each quarter.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each semi-year.

Employee Separation by Length of Work (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet compares the amount of time people have been with your enterprise, to
the separation rate over time, within each year.

Employee Separation by Reason (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet investigates the different reasons for separations within geographical
areas. You can determine if employees in different areas leave your enterprise for
different reasons.

Employee Separation by Reason (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet investigates the different reasons for separations within
organizations. You can determine if employees in different organizations leave your
enterprise for different reasons.

Employee Separation by Reason (Organization Hierarchy) Status Analytics by Separation Category
(HRMSi)

This worksheet investigates the different reasons employees leave your enterprise
within each separation category.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise
is losing workforce over time, grouped by bimonthly.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by month.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by quarter.
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Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by semi-year.

Employee Separation by Reason (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet enables you to investigate the different reasons why your enterprise is
losing workforce over time, grouped by year.

Employee Summary Report

Addresses, contacts, periods of service, assignments, special information, personal
payment methods and element entries for a selected employee.

Employee Termination (Organization Hierarchy) Detail – Detail

This worksheet enables you to report on employees that have separated within a
specified time period. Employees are listed for a given organization and its subordinate
organizations.

Employee Termination with Comments (Organization Hierarchy) Detail – Detail

This worksheet enables you to report on the employees that have separated within a
specified time period. Employees are listed for a given organization and its subordinate
organizations.

Employment Certification Report (Hungary)

Contains the personal, job, and pension information of a terminated employee.

Employment Equity Report

Outlines the required information needed for the Employment Equity report required
by Canadian Employment Equity Act.

Employment Equity Templates (Payroll) (South Africa)

Outlines the required information needed for Employment Equity as defined by the
Department of Labour.

Employment Equity Workforce Profile Report (Payroll) (South Africa)

Outlines the required information needed for Employment Equity as defined by the
Department of Labour.

Full Applicant Details

Applications and applicant interviews for one applicant.

Full Assignment Details

Assignment information including periods of service, payment methods, and element
entries for one employee.

Full Person Details

Addresses and information entered in the Person window such as name, date of
birth, nationality and work telephone number for one employee.
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Full Personal Details Report Set

Person details, applicant details, assignment details and work details for one employee.

Full Work Details

Miscellaneous work information including special information, absences, recruitment
activities and contacts for one employee.

Head Count Detail Report

The number and type of workers within an organization, as well as attrition rate data.

Headcount (HRMSi, DBI)

This report displays the total employee headcount of the direct reports of the selected
top line manager.

Headcount by Country Trend (HRMSi, DBI)

This report shows changes in headcount over time for the four countries with the highest
head count for the selected top line manager.

Headcount Transfer (Plus) Detail (HRMSi, DBI)

The report displays the employee records that comprise the total value you drilled from
in the head count report, including transfers and reorganizations. You access this report
from the Plus-Transfer column in the parent head count report.

Headcount Hire Detail (HRMSi, DBI)

This report lists the records that comprise the Plus-Hire value you drilled from in the
Headcount report, including hires, re-hires and secondary assignment starts. You access
this report from the Plus-Hire column in the Headcount report.

Headcount Termination Detail (HRMSi, DBI)

The report displays the employee records that make up the total value you drilled from
in the Headcount report. The report lists employees who have terminated from the
manager’s hierarchy in the given period, together with supporting details.

Headcount Transfer (Minus) Detail (HRMSi, DBI)

The report displays the employee records that comprise the total value you drilled from
the Headcount report, including transfers and reorganizations. The report provides
information about employees who have moved out of the selected manager’s hierarchy.

HRMS Profile Options Report

Use this report to list the values of the profile options for your HRMS installation. The
report also identifies which profile options have not been set for your installation.

Human Resource Setup Detail – Employee Anniversary Birthdays

This worksheet enables you to view employee birthdays and start dates. The
worksheet also enables you to view other employee information, for example, length of
service, employee number, and supervisor name.
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Human Resource Setup Detail – Employee Assignment by Organization

This worksheet enables you to report on the assignments within an organization, by
choosing a top organization and including subordinates.

Human Resource Setup Detail – Employee Assignment by Organization Rollup

This worksheet enables you emulate the rollup flexibility of HRMSi Reports by using an
organization hierarchy to control the information displayed.

Human Resource Setup Detail – Employee Job History

This worksheet enables you to view employee job history across your organization.

Human Resource Setup Detail – Employee List with Length of Work

This worksheet enables you to analyze deployment factors associated with
positions, people in specific positions, and position applicants.

Human Resource Setup Detail – Employee Separation with Equal Opportunity (United States Specific)

This worksheet enables you to analyze terminations with ethnic origin over a specific
time period.

Human Resource Setup Detail – Person Home Address

This worksheet enables you to view the primary addresses of employees.

Invalid Address Report

Lists employee address information inconsistencies.

Law SAMEN Report (Organization Structure)and Law SAMEN Report (Dutch Region) (Netherlands)

The Law SAMEN report (Organization Structure) reports on employees within an
organization structure. The Law SAMEN Report (Dutch Region) reports on employees
within a specific Dutch region.

National Defense Report (Hungary)

Contains a list of male employees who are available to perform a national defense role.

New Hire State Magnetic Media Report (US)

Report on newly hired and rehired employees using magnetic media.

New Hire State Report (US)

Report on newly hired or rehired employees.

Period of Service Reports (Germany)

Generates reports of an employee’s periods of service using selected criteria.

Person/Assignment History Detail – Application

This worksheet enables you to analyze an applicant’s assignment record between the
start and end of an application. For each employee you can examine the total number
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of applications, the number of successful applications, and the length of time between
different application stages.

Person/Assignment History Detail – Employee Separation

This worksheet enables you track termination reasons by type, date, and length of
service, allowing you to spot trends among leavers. For each termination, you can
compare termination reasons to discover trends, and compare the length of time in an
organization against time in a job.

Person/Assignment History Detail – Person Assignment

This worksheet enables you to analyze an employee’s assignment history between
specific dates. For each employee you can examine the current assignment, and details
of previous assignments.

Person Full History Report

This report lists the personal and professional details of the employees and contingent
workers in your enterprise, including assignments, salary, and contact details.

Person Synchronization Report

This report shows details of any person in your current business group who also has a
record in another business group on the specified date.

RED System : New Hires, Leavers, and Contract Changes Report (Spain)

This report contains information about the workforce and contract changes within
an enterprise.

Saudi Contract Expiry Report (SA)

The Saudi Contract Expiry Report creates a list of all the contracts that will expire in a
user specified period of time.

Saudi Iqama Expiry Report (SA)

The Saudi Iqama Expiry Report creates a list of all the iqamas that will expire in a
user specified period of time.

Saudi Passport Expiry Report (SA)

The Saudi Passport Expiry Report creates a list of all the passports that will expire in a
user specified period of time.

Separations By Competence Report (HRMSi)

This report is run from the Separations by Leaving Reason report. When employees
leave your enterprise you lose the competencies they possess. This can become a
problem if you continue to lose people with the same abilities. This report investigates
the competencies and levels of proficiency you are losing.

Separations By Leaving Reason Report (HRMSi)

This report is run from the Workforce Losses report. This report enables you to
investigate the different reasons why your enterprise is losing workforce. It only
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includes the workforce that has left your enterprise. It does not include workforce that
has transferred to a different area of your enterprise or assignments that have ended or
been suspended.

Separations By Service Bands Report (HRMSi)

This report is run from the Separations by Leaving Reason report. This report
investigates the relationship between the reasons people give for leaving and the amount
of time they have been with your enterprise.

Separations Trend by Leaving Reason Report (HRMSi)

Use this report to investigate the trends in why people are leaving your enterprise. This
report runs from the Workforce Losses report.

Separations Trend by Service Band Report (HRMSi)

Use this report to investigate the trends in the length of time employees remain with
your enterprise. This report runs from the Workforce Losses report.

Social Health Insurance Report (Netherlands)

Employees who have started and/or ended the social health insurance within a date
range.

Tenure Notification Reports (including Tenured Status, Non-Tenured Status, Tenure Track Status and
Tenure Review) (US)

These notification reports are available for you to send to faculty members and their
academic manager during the Tenure process

Terminations Report

The number of employees from selected organizations leaving your enterprise within a
particular period, and the reason for leaving.

Terminations with Active Support Order Report (US)

Run this report to view employees with an active support order at the time of
termination.

Turnover Detail (HRMSi, DBI)

This report lists the ex-employees who comprise the value you drilled from the
Annualized Turnover Status report. The report is the sum of the headcount of
assignment ends that occur at the same time as a termination.

Worker Organization Movements Report

New starters, terminations, transfers in, and transfers out of a selected organization or
organization hierarchy.

Workforce Assignment Activity Analysis – Grade Changes (HRMSi, EDW)

The Grade Changes worksheet provides a summary of the head count or full time
equivalent, or the average number of months between grade changes, for a specified
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top-level employing organization within a particular calendar year, for employees
changing grade.

Workforce Assignment Activity Analysis – Location Changes (HRMSi, EDW)

The Location Changes worksheet provides a summary of the head count or full
time equivalent for people changing locations for a specified top-level employing
organization within a specified calendar year.

Workforce Assignment Activity Analysis – Organization Changes (HRMSi, EDW)

The Organization Changes worksheet provides a summary of the head count or
full-time equivalent for employees changing organizations within a specified calendar
year. Initially only the top-level employing organizations are displayed; you need to drill
down to see transfers between organizations further down the organizational hierarchy.

Workforce Comparison Report (HRMSi)

The workforce assigned to different types of jobs can vary over time. This report
compares the workforce assigned to up to three job categories over time. For
example, you could compare the number of managers against the number of technical
staff you employed last year.

Workforce Composition Analysis – Composition by Age Band (HRMSi, EDW)

The Composition by Age Band worksheet provides a summary of person head count
or full-time equivalent by employee age band for a specified top-level employing
organization and a specified period of time. All workforce composition data collected
in that period will be included.

Workforce Composition Analysis – Composition by Disability Status (HRMSi, EDW)

The Composition by Disability Status worksheet provides a summary of person head
count or full-time equivalent by disability status (disabled, not disabled, or undefined)
for a specified top-level employing organization within a specified period of time. All
workforce composition data collected in that period will be included.

Workforce Composition Analysis – Composition by Gender (HRMSi, EDW)

The Composition by Gender worksheet provides a summary of person head count or
full-time equivalent by gender for a specified top-level employing organization and a
specified period of time. All workforce composition data collected in that period will
be included.

Workforce Composition Analysis – Composition by Location (HRMSi, EDW)

The Composition by Location worksheet provides a summary of person head count
or full-time equivalent, by location, for a specified top-level employing organization
within a specified period of time. All workforce composition data collected in that
period will be included.

Workforce Composition Analysis – Composition by Period of Service (HRMSi, EDW)

The Composition by Period of Service worksheet provides a summary of person head
count or full-time equivalent by period of service for a specified top-level employing
organization and a specified period of time. All workforce composition data collected
in that period will be included.
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Workforce Composition Analysis – Composition Summary (HRMSi, EDW)

The Composition Summary worksheet provides a summary of person head count or
full-time equivalent for top-level employing organizations and for a specified period of
time. All workforce composition data collected within that period will be included.

Workforce Count (Organization Hierarchy) Template Analytics by Year (HRMSi)

This worksheet analyses how your workforce fluctuates over time. The template
worksheets provide a starting point for developers to create analytic reports.

Workforce Count (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet tells you how your workforce fluctuates across different groups within
your organization, such as organization, job, and location. You view the detail for one
year at a time. The template worksheets provide a starting point for developers to
create analytic reports.

Workforce Count (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by bimonthlies.

Workforce Count (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by months.

Workforce Count (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by quarters.

Workforce Count (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by semi-years.

Workforce Count (Organization Hierarchy) Trend Analytics by Year and Geography (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by year and
geography.

Workforce Count (Organization Hierarchy) Trend Analytics by Year and Organization (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by year
and organization.

Workforce Count (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce for each time period within the given date range grouped by years.
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Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, for each bimonthly within the given
date range.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE)
of your workforce, broken down by job category, for each month within the given
date range.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE)
of your workforce, broken down by job category, for each quarter within the given
date range.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, for each semi-year within the given
date range.

Workforce Count by Job Category (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, for each year within the given date range.

Workforce Count Change (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce grouped by geographical area.

Workforce Count Change (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce grouped by organization.

Workforce Count Change (Organization Hierarchy) Status Analytics by Separation Category (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce grouped by separation category.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Geography
Area (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by geographical area.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by grade.
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Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by job.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Organization
(HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by organization.

Workforce Count Change by Job Category (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet calculates the Workforce Measurement Value (Head Count or FTE) of
your workforce, broken down by job category, and grouped by position.

Workforce Count KPI Status (HRMSi)

This Performance Management Viewer report provides you with a view of the Workforce
Full Time Equivalent and Workforce head count KPI data, including target and actual
values. The report displays table data by default; you can optionally display the data as
a chart.

Workforce Count Report

The number and type of workers within an organization, as well as attrition rate
data, in summary form.

Workforce Count Report (Spread Sheet Version)

The number and type of workers within an organization, as well as attrition rate data, in
summary form. This version of the workforce count reports enables you to open the
report in a spreadsheet format.

Workforce Gain (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by geographical area.

Workforce Gain (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by organization.

Workforce Gain (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by job.

Workforce Gain (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped
by organization.

Workforce Gain (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet lists the total losses that occurred within a given time period, grouped by
grade.
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Workforce Gain (Organization Hierarchy) Template Analytics by Year and Organization (HRMSi)

This worksheet analyses how workforce gains have occurred, and compares the gains
over time and across organizations. The template worksheets provide a starting point
for developers to create analytic reports.

Workforce Gain (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet tells you how the gains occurred and how the gains have been deployed
within the workforce. The template worksheets provide a starting point for developers
to create analytic reports.

Workforce Gain (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped by
bimonthlies.

Workforce Gain (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped
by months.

Workforce Gain (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped
by quarter years.

Workforce Gain (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped by
semi-years.

Workforce Gain (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet lists the total gains that occurred within a given date range grouped
by years.

Workforce Gains Report (HRMSi)

Organizations within your enterprise may be gaining workforce for different
reasons. This report investigates whether your workforce is increasing because of any
of the following reasons: new employees are being hired by your enterprise, existing
employees are being given new assignments in different parts of your enterprise, existing
employees are transferring assignments to different parts of your enterprise, or
employees’ assignments are being re-activated from suspended to active.

Workforce Loss (Organization Hierarchy) Status Analytics by Geography Area (HRMSi)

This worksheet lists the total losses within a given time period, grouped by geographical
area.

Workforce Loss (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet lists the total losses within a given time period, grouped by grade.

Workforce Loss (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet lists the total losses within a given time period, grouped by job.
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Workforce Loss (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet lists the total losses within a given time period, grouped by organization.

Workforce Loss (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet lists the total losses within a given time period, grouped by Position.

Workforce Loss (Organization Hierarchy) Template Analytics by Year and Organization (HRMSi)

This worksheet analyses when and where workforce gains occur, and compares the gains
over time and across organizations. The template worksheets provide a starting point
for developers to create analytic reports.

Workforce Loss (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet tells you how losses occurred and where losses occurred within the
workforce. The template worksheets provide a starting point for developers to create
analytic reports.

Workforce Loss (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by bimonthly.

Workforce Loss (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped by
month.

Workforce Loss (Organization Hierarchy) Trend Analytics by Position (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by position.

Workforce Loss (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by quarter.

Workforce Loss (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by semi-year.

Workforce Loss (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet lists the total losses that occurred within a given date range, grouped
by year.

Workforce Losses Report (HRMSi)

This report investigates the different reasons you are losing workforce within your
enterprise. Are you losing workforce because the workforce is transferring to different
parts of your enterprise, because current employee assignments are ending, because
employee assignments are being suspended, or because employees are leaving your
enterprise?
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Workforce Planning Summary Analysis – Composition by Location (HRMSi, EDW)

The Composition by Location worksheet provides a summary of person head count or
full-time equivalent, by location, for a specified top-level employing organization and a
specified period of time. All data collected in that period will be included.

Workforce Planning Summary Analysis – Composition Summary (HRMSi, EDW)

The Composition Summary worksheet provides a summary of workforce composition
for a top-level employing organization for a specified period of time. All data collected
within that period will be included.

Workforce Planning Summary Analysis – Organization Changes (HRMSi, EDW)

The Organization Changes worksheet provides a summary of the head count or full
time equivalent for employees changing organizations within a specified calendar
year. Initially only the top-level employing organizations are displayed; you need to drill
down to see transfers between organizations further down the organizational hierarchy.

Workforce Planning Summary Analysis – Recruitment by Organization (HRMSi, EDW)

The Recruitment by Organization worksheet gives you a recruitment summary by
top-level employing organization. You can report on the following measures: head
count, full-time equivalent, average number of days between application and hire, and
average number of days between vacancy start and hire.

Workforce Planning Summary Analysis – Recruitment Efficiency (Average Days) (HRMSi, EDW)

The Recruitment Efficiency (Average Days) worksheet provides information concerning
efficiency of recruitment for a specified calendar year (based on the date employment
started) for each top-level employing organization. You can report on the average
number of days from application to termination (the date the application was ended by
the employer or the applicant), first interview, second interview, offer, acceptance, and
hire.

Workforce Planning Summary Analysis – Separation by Organization (HRMSi, EDW)

The Separation by Organization worksheet provides a summary of person head count or
full-time equivalent by top-level employing organization.

Workforce Planning Summary Analysis – Voluntary/Involuntary Separation (HRMSi, EDW)

The Voluntary/Involuntary Separation worksheet provides a summary of person head
count or full-time equivalent for a selected top-level employing organization by loss type
(voluntary or involuntary) for the last 3 years and the current year.

Workforce Ratio Report (HRMSi)

The workforce assigned to different types of jobs can vary over time. This report
compares the percentage of workforce assigned to up to three job categories over time. If
you want to investigate the absolute number of employees for different job categories
rather than the percentage of employees, you can run the related Workforce Comparison
report from this report.
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Workforce Separation Analysis – Separation by Age Band (HRMSi, EDW)

The Separation by Age band worksheet provides a summary of person head count
or full-time equivalent by employee age band for a selected top-level employing
organization.

Workforce Separation Analysis – Separation by Disability Status (HRMSi, EDW)

The Separation by Disabled Status worksheet provides a summary of person head count
or full-time equivalent by disability status (disabled, not disabled, or undefined) for a
selected top-level employing organization.

Workforce Separation Analysis – Separation by Gender (HRMSi, EDW)

The Separation by Gender worksheet provides a summary of person head count or
full-time equivalent by gender for a selected top-level employing organization.

Workforce Separation Analysis – Separation by Organization (HRMSi, EDW)

The Separation by Organization worksheet provides a summary of the person head
count or full-time equivalent by top-level employing organization.

Workforce Separation Analysis – Separation by Period of Service (HRMSi, EDW)

The Separation by Period of Service worksheet provides a summary of person head
count or full-time equivalent by period of service for a selected top-level employing
organization.

Workforce Separation Analysis – Separation by Period of Service and Reason (HRMSi, EDW)

The Separation by Period of Service and Reason worksheet provides a summary of
person head count or full-time equivalent by period of service and separation reason
for a selected top-level employing organization and calendar year (based on the year
separation occurred).

Workforce Separation Analysis – Separation Reasons by Age Band, Disability Status, and Gender
(HRMSi, EDW)

The Separation Reasons by Age Band, Disability Status, and Gender worksheet provides
a summary of person head count or full-time equivalent by separation reason for a
selected top-level employing organization, by age band, disability status, or gender.

Workforce Separation Analysis – Separation Reasons by Organization (HRMSi, EDW)

The Separation Reasons by Organization worksheet provides a summary of
person head count or full-time equivalent for a selected top-level employing
organization, by separation type (voluntary or involuntary) and separation reason (for
example, disability, poor performance, end of contract etc.).

Workforce Separation Analysis – Voluntary/Involuntary Separation (HRMSi, EDW)

The Voluntary/Involuntary Separation worksheet provides a summary of person head
count or full-time equivalent for a specified top-level employing organization by
voluntary or involuntary separation type.
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Workforce Separation by Rolling Month – Status PMV Report (HRMSi)

This report helps you monitor monthly FTE and head count separation. It provides
a view of the Workforce FTE Separation and Workforce head count Separation Key
Performance Indicator data, including target and actual values.

Workforce Summary Analysis Report (HRMSi)

This report is the first in a suite of reports that enables you to investigate workforce in
your enterprise. You can review the losses, gains and total workforce you have in
different organizations within your enterprise.

Competencies, Qualifications and Development

Competence (Skill) Development Detail – Competence Delivered by Training Activity

This worksheet enables you to view competencies delivered by training activities and
events. The resulting information allows you to compare the competencies delivered by
training to those required, and to analyze training efficiency.

Competence (Skill) Development Detail – Competence Requirement

This worksheet displays competence requirements for all organizations within a
Business Group. The worksheet enables you to analyze competence requirements for
Business Groups, organizations, jobs, positions, and grades. For each requirement you
can investigate the competencies needed for a particular job, and the skills shortages
within an organization.

Competence (Skill) Development Detail – Person Competence Profile

This worksheet enables you to analyze employee competency profiles by type. It allows
you to view employees with similar competencies, and compare employees of similar
grade.

Competence Levels

This report displays the proficiency levels of employees or applicants for a competence.

Competence Levels (Organization Hierarchy) Detail Analytics by Person with Rank (HRMSi)

This worksheet lists each individual that has the selected competence, and shows you
both the proficiency level they have achieved, and the proficiency level translated
into a proficiency rank.

Competence Levels (Organization Hierarchy) Detail Analytics by Person (HRMSi)

This worksheet lists the individuals who hold a selected competence and their
proficiency levels for that competence.

Competence Match (Organization Hierarchy) Status Analytics by Organization and Location (HRMSi)

This worksheet enables you to see the each person’s level of proficiency for the
competencies for their job, grouped by organization and location.

Competence Match (Organization Hierarchy) Status Analytics by Person (HRMSi)

This worksheet enables you to see individuals’ proficiency levels.
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Competence Match (Organization Hierarchy) Status Analytics by Person Graph (HRMSi)

This worksheet breaks down each competence relevant to the selected job into
percentages below, within, and above the required proficiency ranges for the job. It
shows how an individual’s competencies map to the requirement range.

Competence Match (Organization Hierarchy) Status Analytics Compare to Minimum Proficiency (HRMSi)

This worksheet compares people’s proficiency levels with the minimum proficiency
requirement for each competence relevant to their job.

Competence Match (Organization Hierarchy) Status Analytics Compare to Range (HRMSi)

This worksheet compares people’s proficiency levels to the required proficiency range
for each competence relevant to their job.

Group Competencies Report (HRMSi)

For each job and grade this report displays the proficiency levels for your employees or
applicants in each required competence.

Individual Competencies Report (HRMSi)

This report is run from the Group Competencies report. This report compares an
individual’s competencies against the required competencies for the job and grade they
hold. If your employee does not have the proficiency level you require, a training course
may exist to help. By clicking on a competence, you can run the Training Classes By
Competence report to display courses that offer the selected competence.

Learning Management

Delegate Chargeback (Training Center Hierarchy) Detail – Delegate Chargeback (OLM)

This worksheet investigates the amount transferred between two cost centers within an
enterprise for internal student enrollments.

Employee Training Attendance Success (Organization Hierarchy) Status Analytics by Geography Area
(HRMSi)

This worksheet investigates how successfully employees in different geographical areas
are attending training courses.

Employee Training Attendance Success (Organization Hierarchy) Status Analytics by Organization
(HRMSi)

This worksheet investigates how successfully employees in different organizations
are attending training courses.

Employee Training Attendance Success (Organization Hierarchy) Template Analytics by Year (HRMSi)

This worksheet enables you to see training success for each year. The template
worksheets provide a starting point for developers to create analytic reports.
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Employee Training Attendance Success (Organization Hierarchy) Template Analytics Detail (HRMSi)

This worksheet calculates the training success rates for training events with the same start
and end dates, for attendees in each organization, location, job, grade, and position. The
template worksheets provide a starting point for developers to create analytic reports.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Bi Month (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by bimonthlies.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Month (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by months.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Quarter (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by quarters.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Semi Year (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by semi-years.

Employee Training Attendance Success (Organization Hierarchy) Trend Analytics By Year (HRMSi)

This worksheet investigates how successfully employees are attending training
courses, grouped by years.

Event Player Progress – by Player Status (OLM)

This worksheet investigates the progress of your Oracle Learning Management hosted
training events by the number of delegates at each Player Status. The Player Status
categories are Completed, Passed, Incomplete, Not Attempted, and Failed.

Event Player Progress – by Total Time Taken Status (OLM)

This worksheet investigates the progress of your Oracle Learning Management hosted
training events by the total time that delegates have been playing content of a course
within the OLM player.

Event Player Progress – Completion Summary (OLM)

This worksheet presents all relevant completion details for OLM training events.

Event Ranking Status – by Attendance (HRMSi)

This worksheet enables you to analyze the popularity of training events by ranking them
by course attendance.

Event Ranking Status – by Event Days (HRMSi)

This worksheet enables you to investigate the popularity of training events by ranking
them by event days.
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Event Resource (Training Center Hierarchy) Detail – Booked Resources per Event

This worksheet enables you to analyze the resources booked for specific training events.

Event Resource (Training Center Hierarchy) Detail – Event Enrollments

This worksheet enables you to investigate the number of students who enroll on an
event, and the number of students who successfully attend the event.

Event Resource (Training Center Hierarchy) Detail – Events Without Trainer

This worksheet enables you to investigate the training events that have no associated
trainer.

Event Resource (Training Center Hierarchy) Detail – Events Without Venue

This worksheet enables you to investigate training events that have no associated venue.

Event Resource (Training Center Hierarchy) Detail – Overbooked Resources

This worksheet enables you to analyze overbooked resources.

Event Resource (Training Center Hierarchy) Detail – Required Resources Missing

This worksheet enables you to investigate the resources that are required but have not
been booked for a training event.

Event Resource (Training Center Hierarchy) Detail – Resource Checklist

This worksheet displays the list of resources required to successfully run a training
event activity.

Event Resource (Training Center Hierarchy) Detail – Resource Schedule

This worksheet enables you to view the schedule for each training resource, to ensure
that resources are not booked for more than one event at any one time.

Event Resource (Training Center Hierarchy) Detail – Suppliable Resources

This worksheet enables you to analyze the cost and availability of suppliable resources
for your training event.

Event Resource (Training Center Hierarchy) Detail – Training Events

This worksheet enables you to investigate the location, start date, and duration of
specific training events.

Player Progress Detail – by Player Status (OLM)

This worksheet enables you to analyze the progress of delegates on your OLM hosted
training events by Player Status.

Player Progress Detail – by Total Time Taken Status (OLM)

This worksheet investigates the progress of individual delegates on your OLM hosted
training events, by the total time they have been playing content using the OLM player.
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Student Attendance (Internal) Detail – Attendance Summary

This worksheet enables you to analyze the number of internal students attending
training events. You can view internal student attendance by activity type, analyze
success rates and information about failures.

Student Success (External) Status – by Company (HRMSi)

This worksheet enables you to analyze the success of training hours delivered to external
students for a company. You can investigate this for a business group and year.

Student Success (External) Status – by Company and Year (HRMSi)

This worksheet enables you to analyze the success of training hours delivered to external
students for a company, for different years. You can investigate this for a Business
group and each company.

Student Success (Internal) Trend – by Job and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to internal
students for a job by year, and the success of these hours. You can investigate student
success rates for a Business Group and organization within your enterprise.

Student Success (Internal) Trend – by Job Category and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to
internal students each year for a job by category, and the success of these hours. You
can investigate student success rates for a Business Group and organization within
you enterprise.

Student Success (Internal) Trend – by Location and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to internal
students for a location each year, and the success of these hours. You can investigate
student success rates for a Business Group and organization within your enterprise.

Student Success (Internal) Trend – by Organization and Year (HRMSi)

This worksheet enables you to analyze the number of training hours delivered to internal
students each year, and the success of these hours. You can investigate student success
rates for a Business Group and organization within your enterprise.

Training Classes by Competence (HRMSi)

This report is run from the Individual Competencies report. This report enables you to
investigate training classes that provide a selected competence. The report displays the
course time, the competence level delivered, the dates the course is run , the class title
and status, the number of class places, the class venue and the cost.

Training Cost and Revenue Analysis – by Competence (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities by the
competence achieved if a student successfully completes the activity.

Training Cost and Revenue Analysis – by Sponsoring Organization (HRMSi)

This worksheet enables you to analyze the cost and revenue of training events for
different organizations, by Business group and year.
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Training Cost and Revenue Analysis – by Sponsoring Organization and Year (HRMSi)

This worksheet enables you to analyze the costs and revenue associated with training
for different years. You can investigate costs and revenue for a Business Group and
sponsoring organization.

Training Cost and Revenue Analysis – by Training Activity (HRMSi)

This worksheet enables you to analyze the cost and revenue generated by training
events. You can investigate training activities for a specific Business Group, sponsoring
organization and year.

Training Cost and Revenue Analysis – by Training Activity and Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities for
different years, by Business group and sponsoring organization.

Training Cost and Revenue Analysis – by Training Category (HRMSi)

This worksheet enables you to analyze the cost and revenue of training events for a
training category. You can investigate costs and revenue for a Business group, sponsoring
organization, and year.

Training Cost and Revenue Analysis – by Training Center (HRMSi)

This worksheet enables you to analyze the costs and revenue of a training event for a
training center, by Business Group, sponsoring organization and year.

Training Cost and Revenue Analysis – by Training Center and Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities for
different years. You can investigate by Business group, sponsoring organization, and
training center.

Training Cost and Revenue Analysis – by Training Category and Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training events in
different years. You can investigate costs and revenue for a Business Group, sponsoring
organization, and training category.

Training Cost and Revenue Analysis – Competence by Year (HRMSi)

This worksheet enables you to analyze the cost and revenue of training activities by
competence and year.

Training Course Ranking by Amount Status – Course Ranking by Amount (HRMSi)

This report investigates the total amount of money generated by enrollments on each
training event, and allows training events to be ranked by the enrollment amount
generated.

Training Success (HRMSi)

This report enables you to investigate how successfully employees are attending training
courses for a particular organization, location, job, and job category. You can also display
your PMF targets by selecting a business plan.

Reports and Processes in Oracle HRMS B-45



Training Success Analysis – by Competence (HRMSi)

This worksheet enables you to investigate the success rate of a training activity by
competencies. You can investigate competencies for a sponsoring organization and year.

Training Success Analysis – by Sponsoring Organization (HRMSi)

This worksheet enables you to investigate the training success rate of training events
for different sponsoring organizations.

Training Success Analysis – by Training Activity (HRMSi)

This worksheet enables you to investigate the success rate of different training
activities. You can investigate training activities by year and sponsoring organization.

Training Success Analysis – by Training Category (HRMSi)

This worksheet enables you to investigate the training success rate of events by training
category. You can investigate different training categories for a Business Group and year.

Training Success Analysis – by Training Center (HRMSi)

This worksheet enables you to investigate the training success rate of different training
centers, by Business Group and year.

Training Success Analysis – for a Competence by Year (HRMSi)

This worksheet enables you to investigate the training success rate of training activities
for a competence over a number of years. You can investigate a competence for each
sponsoring organization.

Training Success Analysis – for a Sponsor Organization by Year (HRMSi)

This worksheet enables you to investigate the training success rate of training events for
a sponsoring organization for each year.

Training Success Analysis – for a Training Activity by Year (HRMSi)

This worksheet enables you to investigate the success rate of training activities each
year. You can investigate training activities by Business Group and activity.

Training Success Analysis – for a Training Category by Year (HRMSi)

This worksheet enables you to investigate the training success rate of a training event
in different years. You can analyze training success for a Business Group and training
category.

Training Success Analysis – for a Training Center by Year (HRMSi)

This worksheet enables you to investigate the training success rate of a training center
over a number of years. You can analyze success by Business Group and training center.

General Compensation Structures

Element Link Details Report (Payroll)

The eligibility criteria for an element or group of elements.
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Salary and Grade Related Pay and Progression

Average Salary By Group Report (HRMSi)

This report enables you to investigate the average salaries for different groups of
employees. You can also select which area of your enterprise you want to investigate.

Average Salary Trend Report (HRMSi)

This report reviews salary trends in different areas of your enterprise. It displays
the average salary of all your employees who match the selection criteria. You can
investigate the trends in average salaries for different organizations, jobs, grades, and
locations. You can also choose the currency you want to view the salaries in, and include
or exclude salaries that are not paid in your chosen currency.

Current and Projected Progression Point Values Report

The expected results of running the Increment Progression Points process, that is the
projected point and value changes for a group of employees.

Employee Increment Results Report

The actual results of running the Increment Progression Points process, that is
progression point and value changes for a group of employees.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies, United States Specific)
Detail – by Organization Hierarchy (US)

This worksheet enables you to report on employee details, based on the employee
primary assignment in the United States legislation, for a given organization and its
subordinate organizations.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies) (United States
Specific) Detail – by Supervisor Hierarchy (US)

This worksheet enables you to report on employee details based on the employee
primary assignment in the United States legislation, for a given supervisor and his/her
subordinates.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies) Detail – by
Organization Hierarchy

This worksheet enables you to report on employee details based on the employee
primary assignment (in a non-legislative specific format) for a given organization and
its subordinate organizations.

Employee Primary Assignment with Salary and Grade Rates (Multiple Hierarchies) Detail – by Supervisor
Hierarchy

This worksheet enables you to report on employee details based on the employee
primary assignment (in a non-legislative specific format) for a given supervisor and
his/her subordinates.
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Employee Primary Assignment with Salary (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee details based on employee primary
assignment, in a non-legislative specific format, for a given organization and its
subordinate organizations.

Employee Primary Assignment with Salary (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee details based on employee primary
assignment, in a non-legislative specific format, for a given supervisor and his/her
subordinates.

Employee Salary (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by bimonthly.

Employee Salary (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by month.

Employee Salary (Organization Hierarchy) Trend Analytics by Month and Organization (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by month and organization.

Employee Salary (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by quarter.

Employee Salary (Organization Hierarchy) Trend Analytics by Quarter and Organization (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by quarter and organization.

Employee Salary (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by semi-year.

Employee Salary (Organization Hierarchy) Trend Analytics by Year and Organization (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by year and organization.

Employee Salary (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet lists the average salaries of employees, within a given date
range, grouped by year.

Employee Salary and Grade Range (Organization Hierarchy) Trend Analysis Full Details (HRMSi)

This worksheet compares employees’ salaries to their grade minimum, mid, and
maximum points, and displays the value required for the employee’s salary
to reach the next point in the grade. It also includes details of employees’
organization, location, job, and position.
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Employee Salary and Grade Range (Organization Hierarchy) Trend Analysis Graph (HRMSi)

This worksheet displays a table and a chart that compare each employee’s salary to the
minimum, mid, and maximum points for their grade.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Age Band (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by Age Band.

Employee Salary by Group (Organization Hierarchy) Status Analytics by GB Ethnic Group (HRMSi) (UK)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by UK ethnic group.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Gender (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by gender. Employee Salary by Group (Organization Hierarchy)
Status Analytics by US Ethnic Group Worksheet (HRMSi) (US) This worksheet enables
you to investigate the average salaries of different groups of employees, grouped by
US ethnic group.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Grade (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by grade.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Job (HRMSi)

This worksheet enables you to investigate the average salaries of different groups
of employees, grouped by job.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Length of Work Band (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by Length of Work Band.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Location (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by location.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Organization (HRMSi)

This worksheet enables you to investigate the average salaries of different groups
of employees, grouped by organization.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Performance Rating (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by performance rating.

Employee Salary by Group (Organization Hierarchy) Status Analytics by Position (HRMSi)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by position.
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Employee Salary by Group (Organization Hierarchy) Status Analytics by US Ethnic Group (HRMSi) (US)

This worksheet enables you to investigate the average salaries of different groups of
employees, grouped by US ethnic group.

Employee Salary by Job and Grade (Multiple Hierarchies) Status – by Organization Hierarchy (HRMSi)

This worksheet enables you to compare employee salaries for each job and grade. For a
given organization and its subordinate organizations, the average, minimum, and
maximum employee salaries for jobs and grades are shown.

Employee Salary by Job and Grade (Multiple Hierarchies) Status – by Supervisor Hierarchy (HRMSi)

This worksheet enables you to compare employee salaries for each job and grade. For
a given supervisor and his/her subordinates, the average, minimum, and maximum
employee salaries for jobs and grades are shown.

Employee Salary Change (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee salary change details by organization
for a given time period.

Employee Salary Change (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee salary change details by supervisor
for a given time period.

Employee Salary Change Detail – by Gender

This worksheet enables you to analyze salary change within your organization, by
gender. It allows you to analyze differences in salary changes between male and female
employees across organizations.

Employee Salary Change Detail – by Performance Rating

This worksheet enables you to investigate the effects of performance ratings on
employee salary change across organizations. It allows you to ensure employees are
rewarded for performance.

Employee Salary Change Detail – by Person

This worksheet enables you to investigate salary changes for individual employees.

Employee Salary Change Detail – by Years of Service

This worksheet displays salary change information by years of service across
organizations. The resulting information allows you to compare salary change across
Business Groups and organizations, and view salary change information by length of
service.

Employee Salary Change Detail – Summary

This worksheet enables you to view information about salary changes within your
organization. The resulting information allows you to analyze salary changes across
all organizations in a Business Group.
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Employee Salary Component (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different bimonthlies.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Month (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different months.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different quarters.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different semi-years.

Employee Salary Component (Organization Hierarchy) Trend Analytics by Year (HRMSi)

Use this worksheet to investigate the cost of salary changes for each change component
across different years.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Age (HRMSi)

This worksheet investigates the spread of salaries across employee ages.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Grade (HRMSi)

This worksheet investigates the spread of salaries within grades.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Job (HRMSi)

This worksheet investigates the spread of salaries within jobs.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Length of Service (HRMSi)

This worksheet investigates the spread of salaries within Length of Service bands.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Location (HRMSi)

This worksheet investigates the spread of salaries within locations.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Organization (HRMSi)

This worksheet investigates the spread of salaries within organizations.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Performance Rating (HRMSi)

This worksheet investigates the spread of salaries across performance ratings.

Employee Salary Spread (Organization Hierarchy) Detail Analytics by Position (HRMSi)

This worksheet investigates the spread of salaries within positions.
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Employee with Tenure (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employee tenure details (based on the employee
primary assignment in a non-legislative specific format) for a given organization and
its subordinate organizations.

Employee with Tenure (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employee tenure details (based on the employee
primary assignment in a non-legislative specific format) for a given supervisor and
his/her subordinates.

Headcount and Salary Trend (HRMSi, DBI)

This report shows changes in head count and salaries over time for the selected top
line manager.

Headcount and Salary by Country (HRMSi, DBI)

This report displays the total employee head count, percentage headcount
change, average salary and percentage average salary change for the countries with the
highest head count for the selected top line manager.

Headcount and Salary Detail (HRMSi, DBI)

This report lists the employees and their salary that comprise the Total Salary value you
drilled from the Salary by Job Family Status report. This report displays the salaries in
both their local currency and in the DBI primary or the global currency.

Salary (HRMSi, DBI)

The Salary report displays the employee total salary, average salary, and salary change
percent of all direct reports for the selected top line manager.

Salary by Job Function Status (HRMSi, DBI)

This report is similar to the Salary report, except that it presents a view of the selected
manager’s employees by job function. You can access this report from the Total Salary
column in the parent Salary report.

Salary by Job Family Status (HRMSi, DBI)

This report is similar to the Salary report, except that it presents a view of the selected
manager’s employees by job family. You can access this report from the Job Function
names in the Salary by Job Function report.

Salary and Grade Range Report (HRMSi)

Using Oracle HRMS you can define the minimum, mid points and maximum salaries for
different grades in your enterprise. This report enables you to investigate how salaries
relate to grade rates, including which employees are paid more than the maximum for
their grade, which employees are paid below the mid point or maximum for their grade
and by how much, and what would be the cost of increasing a group of employees to the
mid point or maximum for their grade.
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Salary Component Trend Report (HRMSi)

The amount your enterprise spends on salaries is likely to change over time. Oracle
HRMS enables you to record a reason for each salary increase you give to an
employee. Use the Salary Component Trend report to investigate the total cost of salary
changes for each change component you have identified.

Salary Distribution Within Grade Range PMV Report (HRMSi)

This report provides a view of the Workforce Below Grade Mid Point and Workforce
Above Grade Mid Point Key Performance Indicator data. The report displays table data
by default; you can optionally display the chart.

Salary Review Report

Current, past and proposed salaries for a selected list of employees.

Salary Spread Report (HRMSi)

Within your enterprise it is useful to know the salary ranges for different groups of
employees. This report investigates the spread of salaries by four different criteria: age
(in years), length of service (in years), grade, and Performance Rating.

Salary Survey Comparison – Salary Survey Mappings (HRMSi)

This worksheet enables you to analyze salary surveys, which have been mapped
to particular jobs or positions.

Salary to Grade Range Mid Point Variance PMV Report (HRMSi)

This report provides a view of the Salaries Varying From Grade Mid Point Key
Performance Indicator data. The report displays table data by default; you can optionally
display the chart.

Compensation and Awards Management

Compensation Workbench Progress Report

This report checks the progress of the compensation cycle for an availability period
and plan that you select. If you run the report after the Compensation Workbench
Pre-Process, it provides information about employee eligibility. If you run the report
after the Compensation Workbench Post Process, it summarizes the rates assigned
to each employee.

Mass Awards Deselection (FD)

Lists employees deselected for a mass award

Mass Awards Listing by Employees (FD)

Notification of Personnel Action in list form for an individual employee selected for a
mass award

Mass Awards NPA Listing for All Employees (FD)

Notification of Personnel Action in list form for employees selected for a mass award
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Mass Award Preview (FD)

Lists employees selected for a mass award

Mass Salary Deselection (FD)

Lists employees deselected for a salary adjustment

Mass Salary PA Listing for All (FD)

Notification of Personnel Action in list form for employees selected for a salary
adjustment

Mass Salary PA Listing for Employee (FD)

Notification of Personnel Action in list form for an individual employee selected for a
salary adjustment

Mass Salary Preview (FD)

Lists employees selected for a salary adjustment

Leave and Absence Management

Absence Action List Report

Details the re-integration actions to be performed for employees.

Absence Hours Report (HRMSi)

This report investigates the absence hours recorded for employees in your enterprise. You
can select the employees you want to run the report for by organization, location, job
category, job, and grade. You can also run the report for the time period of your choice.

Absence Report (FR)

Lists the details regarding the employer, absences and the salaries received by the
employee over a reference period for reporting to the French Local Social Security
(CPAM).

Absence Report (HU)

Lists the normal and sickness holiday days an employee is entitled to annually.

Absences Report

Absence details for an employee or organization, for some or all absence types.

Daily Sick and Recovery Report (Netherlands)

Details all new instances of sick employees and all employees who have recovered
from an illness.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Bi Month (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by bimonthly.
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Employee Absence Hours (Organization Hierarchy) Trend Analytics by Month (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by month.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Quarter (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by quarter.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Semi Year (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by semi- year.

Employee Absence Hours (Organization Hierarchy) Trend Analytics by Year (HRMSi)

This worksheet investigates the absence hours recorded for employees in your enterprise
over time, grouped by year.

Employee Hours Worked (Organization Hierarchy) Trend Analytics by Payroll Period (HRMSi)

This worksheet investigates the number of overtime and regular hours worked. The
worksheet displays the number of hours worked for each overtime band you use in your
enterprise, such as double time or time-and-a-half.

Employees on Leave (Multiple Hierarchies) Detail – by Organization Hierarchy

This worksheet enables you to report on employees who are on leave on the effective date
chosen. Employees are listed for a given organization and its subordinate organizations.

Employees on Leave (Multiple Hierarchies) Detail – by Supervisor Hierarchy

This worksheet enables you to report on employees who are on leave on the effective
date chosen. Employees are listed for a given supervisor and his/her subordinates.

Hours Worked Report (HRMSi)

This report investigates the number of overtime and regular hours worked. The
report displays the number of hours worked for each overtime band you use in your
enterprise, such as double time or time-and-a-half. You can run the report for a selected
time period.

Leave Details Report (Payroll) (South Africa)

This report is used for monitoring and analyzing employee absences (sample report).

Leave Liability Report (Payroll) (AU)

Displays leave balances for employees.

Leave Liability Report (NZ)

Displays the accrued debt owed by an organization for the leave balances of their
employees.

Leave Liability Report (Payroll) (South Africa)

Calculates monetary value of accrued leave (sample report).
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Maximum SSP Weeks Report (UK)

Provides details of employees who have had absences for 22 weeks or longer, enabling
you to monitor long periods of incapacity for work (PIWs) which have reached, or are
approaching, the maximum number of weeks that SSP can be paid.

Open Sickness Absences Report (UK)

Provides information on current sickness absences.

SAP Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

SMP Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

SPP Adoption Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

SPP Birth Element Results Report (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

SSP Element Result Listing (UK)

Lists and sums all the run results processed for the statutory pay element for a specified
payroll period, and displays them by individual assignment or employee.

Statutory Adoption Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Maternity Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Paternity Birth Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Paternity Adoption Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.

Statutory Sick Pay Report (UK)

Provide information on the statutory payment history for a specified period, for each
employee included in the report.
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Health and Welfare Management

COBRA Benefit Initial Information (US)

This report--typically sent to employee new hires--provides general information about
COBRA.

COBRA Benefits Notification Letter (US)

This report provides electable choice information to persons who are eligible for COBRA.

COBRA Coverage or Payments Report (US)

Coverage of payments report.

COBRA Standard Letters (including Expiration and Grace Period Expiration) (US)

Publish a standard COBRA letter.

COIDA Report (Payroll) (South Africa)

Compensation for Occupational Injuries & Diseases Act report.

Eligibility and Enrollment List

Run this report to list the total number of eligible and enrolled participants in plans
you administer for Standard and Advanced Benefits, Individual Compensation
Distribution, and Compensation Workbench. The report also lists newly ineligible
and de-enrolled participants.

HIPAA Dependent Letter (US)

Run this report to generate a HIPAA certificate for qualified dependents only, such as for
instances where a dependent ages out of a plan.

HIPAA Letter (US)

Run this report to generate a HIPAA certificate for qualified participants and their
dependents

Life Events Summary Report

Run this report to analyze life events that occur to your compensation and benefits
participants. The report lists the total number of potential and active life events, and
their status, for a specified period.

Premium Reconciliation Report

Run this report to support the monthly benefits billing reconciliation process. This report
compares monthly premium amounts to standard rates and element entries by pay
period, for all participants enrolled during the reporting period.

Other Payroll Earnings and Deductions

Union Deductions Report (Payroll) (UK)

Total deductions that your employees pay to unions.
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Payrolls

Payroll Statutory Calendar Report (Payroll) (UK)

The sequence of regular payment dates for each payroll and the numbers of assignments
completed, pre-paid and paid within a run.

Payroll Report (Check list for Unemployment Insurance) (Payroll) (Japan)

This is a list to check details of unemployment insurance insured employee

Payroll Report to Create File-Notification Change Address for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance office
when an insured employee’s address is changed.

Payroll Report to Create File-Notification of Disqualification for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance
office when the insured employee loses qualification because of some reason
(termination, death, etc.)

Payroll Report to Create File-Notification of Geppen for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance office
when an employee’s social insurance premiums are changed without waiting for the
following regular determination because of rise in pay etc.

Payroll Report to Create File-Notification of Qualification for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance
office when the person applicable to Article 9 of Welfare Pension Insurance Law or the
10th article is employed.

Payroll Report to Create File-Notification of Santei for Welfare Pension Insurance (Payroll) (Japan)

This notification file is submitted by the business proprietor to the social insurance
office when an employee’s social insurance premiums in and after October of the year
are determined based on their earnings.

Payroll Payment and Distributions

Advance Pay Listing (Payroll) (UK)

Details of the advance pay periods for employees due to receive advance pay.

Cheque Listing (Payroll) (South Africa)

Cheque payments made to employees.

Coinage Analysis Report (Payroll) (South Africa)

A cash analysis which provides a breakdown of the cash required.

Credit Transfer Payments Report (Payroll) (South Africa)

Paid/unpaid cheque values per bank branch.

B-58 Oracle US Federal Human Resources Configuring, Reporting, and System Administration Guide



Deduction Register Report (Payroll) (South Africa)

Deductions per element per employee.

Deposit Schedule Report (Payroll) (South Africa)

For credit transfer payments into bank accounts.

Employment Equity Income Differential Report (Payroll) (South Africa)

Outlines the required information needed for Employment Equity as defined by the
Department of Labour.

Gross to Net Summary (Payroll) (UK)

Details of total earnings and deductions summarized for a specified payroll and payroll
period.

Gross to Net Summary (Payroll) (US)

Details of total earnings and deductions summarized for a specified payroll and payroll
period.

Manual Payments Report (Payroll) (South Africa)

Manual payments made for selected payruns and assignments.

Pay Advice (Payroll) (AU)

Generates pay advice for all employees for a specified payroll and period.

Pay Advice (Payroll) (Singapore)

Provides pay advice details in a customizable format, either for single assignments or all
assignments on a payroll, after PrePayments process is complete for the payroll.

Pay Advice (Payroll) (South Africa)

A sample pay advice.

Pay Advice (Payroll) (France)

Presents Pay Advice details in a customizable format, either for single assignments or for
all assignments on a payroll after PrePayments process is complete for the payroll.

Pay Advice (Payroll) (NZ)

Generates pay advice for all employees for a specified payroll and period.

See: Oracle HRMS for New Zealand User Supplement.

Pay Advice (Payroll) (Hong Kong)

Details about employees’ income and deductions.

Pay Advice (Payroll) (UK)

Pay advice details in a customizable format, either for single assignments or for all
assignments on a payroll after PrePayments process is complete for the payroll.
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Payment Output File (Dutch)

Run this report to initiate the creation of the EFT Payment file. Produced in the format
required by the official body Interpay, the EFT Payment file enables you to send
employee payment details to your bank on magnetic tape.

RSC Levy Report (Payroll) (South Africa)

The amount of levies to be paid per RSC region.

Saudi Payment Output File (Payroll) (SA)

Run this report to initiate the creation of the EFT Payment file. The EFT Payment file
enables you to send employee payment details to your bank on magnetic tape.

Saudi Payslip Report (Payroll) (SA)

Use this report to generate both online and printed payslips for employees. Online
payslips enable employees to view their payslips information online, and helps reduce
overheads, administration, and maintenance costs.

Skills Development Levy Report (Payroll) (South Africa)

Skills development levy per SETA or per organization within SETA.

Statement of Earnings (Payroll) (US)

Check writer process produces paychecks with statement of earnings.

Separation Pay E-file Report (Payroll Korea)

Oracle Payroll generates a report about separation pay, based on the Separation Pay
Archive. Once generated, the employer can view, and print the report, and store it on
magnetic tape to send to National Tax Service (NTS).

Separation Pay Slip Report (Payroll Korea)

Run this report to generate a pay slip with the earnings and deductions summary for all
employees who left the enterprise, for a specified payroll and period. This generated pay
slip report is then submitted to the National Tax Service (NTS).

Separation Pay Tax Receipt Report (Payroll Korea)

Run this report to generate the separation pay tax receipt for all employees who left the
enterprise, for a specified payroll and period, and submit the generated report to the
National Tax Service (NTS). The report contains detailed information like income tax and
resident tax for received payments at the time the employee leaves the enterprise.

Additional Wages CPF Capping Report (Payroll Singapore)

The Additional Wages CPF Capping report shows whether an employee has overpaid
or underpaid their Central Provident Fund (CPF) contributions on additional
wages. Employees who have overpaid CPF are eligible to claim this amount from the
Central Provident Fund Board.
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Payroll Statutory Deductions and Reporting

Archive P11D (HR and Payroll) (UK)

Runs the Legislative Report Generator to generate details of Class 1A NICs for reporting
to the Inland Revenue.

Deduction Report (Payroll) (US)

The Deductions report always shows details for each run within the selected time frame
by deduction classification, deduction type, and employee information. This information
can be sorted by GRE, Location, or Organization

Employee Income Payment Detail Report (China)

Contains detailed information for the summarized information provided in the
Individual Income Tax Withholding report.

Employee Listing (Hong Kong)

List of current employees with information such as employee name, identity card
number, passport number, work permit number and expiry date, and the date an
employee joined the company.

Employer Monthly Schedule Report (New Zealand) (NZ)

Lists the details of all employees and is submitted to Inland Revenue.

FBT Report (Australia) (AU)

Displays Fringe Benefits Tax information for a cost center.

Individual Income Tax Withholding Report (China)

Provides summarized information for all tax group rates separately.

Inland Revenue Arrears Payment Report (NZ)

Lists employees who are required to pay student loans or child support arrears to
Inland Revenue.

Inland Revenue Form IR21 (Payroll) (Singapore)

Summarizes an employee’s organization, personal details, and earnings and benefits in
the two years prior to leaving the organization.

Inland Revenue Remittance Certificate Report (NZ)

Submitted to Inland Revenue by employers who are required to make PAYE
payments, or employers who are Specified Superannuation Contribution Withholding
Tax (SSCWT) payers.

IR56B Report (Payroll) (Hong Kong)

A statement of earnings for each employee used by the Inland Revenue to assess
individual statements and forward an account to the employee for tax payable for
the past financial year.
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IR56E Report (Payroll) (Hong Kong)

Submitted for new hires, and includes information such as an employee’s personal
information, including their name, identification details, address, the employee’s legal
employer details and employment information.

IR56F Report (Payroll) (Hong Kong)

A notification by the employer about an employee who is leaving the enterprise but
intending to stay in Hong Kong.

IR56G Report (Payroll) (Hong Kong)

A notification by the employer about an employee who is leaving the enterprise and
also departing from Hong Kong.

IRP5 Tax Certificate (Payroll) (South Africa)

Tax certificates for employees who have paid tax during this tax year.

IT3(a) Tax Certificate (Payroll) (South Africa)

Tax certificates for employees who have paid no tax during this tax year.

MPF Remittance Report (Payroll) (Hong Kong)

A contribution report submitted to the Mandatory Provident Fund (MPF) Trustee
detailing contributions for the period.

National Service In-Camp Training Computation (Payroll) (Singapore)

Calculates the pay amount that an employer can claim from the Ministry of Defence for
an employee who is attending mandatory National Service In-Camp Training.

Health Insurance Premium Adjustment Annual Earnings Archive Process (Payroll Korea)

Stores information about the employees’ previous year’s earnings and the number of
months worked in the previous year, and to produce an E-file that will be sent to the
National Health Insurance Corporation (NHIC).

Health Insurance Adjustment Report for Leaving Employees (Payroll Korea)

The Health Insurance Adjustment for Leaving Employees report is run for all the
employees leaving the enterprise and the report is then sent to National Health Insurance
Corporation (NHIC). The report contains information such as the employees’ previous
year’s income and the number of months the employee was employed in the enterprise.

NHIC uses this information to calculate and adjust the premium amount an employee
must pay before leaving the enterprise.

National Pension Adjustment Annual Earnings Archive Process (Payroll Korea)

Stores information about the employees’ earnings and the number of months worked
in the previous year, and to produce an E-file that will be sent to the National Pension
Corporation (NPC)

NPC uses this information to recalculate the pension and notify the enterprise about the
new pension due for the current year.
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National Pension Adjustment Report (Payroll Korea)

The National Pension Adjustment report is run for all the employees whose status has
changed (newly hired or terminated workers) since the last report, and then send the
report to the National Pension Corporation (NPC).

The NPC uses this information to calculate and adjust a new premium for the worker.

Statutory Deduction Adjustment Information - Upload Process (Payroll Korea)

You upload payroll adjustment information sent by the National Pension Corporation
(NPC) and the National Health Insurance Corporation (NHIC) by uploading the text file
and placing it in a directory where it can be read by the upload process. The application
reads the data and loads into the Batch Element Entry (BEE) tables. These agencies send
your enterprise these details as a text file.

NI Car Detail Report (Payroll) (UK)

All the NI Y amounts due from employees on a given payroll who have company
car benefits.

NICable Benefits Summary Report (UK)

Lists the employee benefits for which the employer is liable for NI contributions.

P30 Report (Payroll) (Ireland)

PAYE and PRSI information for issue to the tax office each calendar month.

P35 Report (UK)

PAYE and PRSI information for all employees including leavers for issue to the tax
office at the end of the tax year.

P45 Alignment Report (Payroll) (UK)

Draft printer alignment for P45 reports.

P45 Report (Payroll) (UK)

P45 details for terminated employees for issue to the tax office and the leaver; P45 details
for current employees for issue to different tax offices.

P45(3) & P46 Exceptions Report (UK)

Enables you to identify those employees for whom a P45(3) or P56 has not been
created, yet have been paid since their initial hire date.

P46 (P160) Pension Notification (UK)

Enables you to provide information on recipients of taxable pensions, and those gaining
extra income while collecting a pension.

P60 Report (Payroll) (UK)

P60 details for employees employed by the business at the end of the tax year.
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Quarterly Employment Survey (NZ)

Extracts information to enable the Statistics New Zealand quarterly employment survey
to be completed.

Report on Hirings (CA)

You submit this monthly report to Human Resources Development Canada (HRDC) as
part of a government insurance program designed to deter and detect overpayments.

Saudi Monthly Contributions Report (Payroll) (SA)

Use this report to create a list of employers’ (on behalf of employees) contributions to
GOSI for the contributory month. This enables the GOSI office to keep track of employee
head count and their contributions to GOSI.

Saudi New and Terminated Workers Report (Payroll) (SA)

Use this report to provide monthly updates to the GOSI office about new and terminated
employees for the specified month.

Saudi Workers Movement Report (Payroll) (SA)

Use this report to create a list of employees’ movement for the specified month. This
enables the GOSI office to keep track of newly hired employees, (with and without
GOSI number) and terminated employees.

Summary of Tax Certificates (Payroll) (South Africa)

Summary of totals for each SARS code per preprocess.

Superannuation Contribution Report (AU)

Identifies monthly figures for superannuation salary and employer superannuation
guarantee contributions.

Tax Certificate Number Report (Payroll) (South Africa)

Lists the generated tax certificate numbers and their assignment details, and the number
of tax certificates issued and reissued.

Tax Office Report for Manual Completion (NL)

Enables you to generate the tax office report, print it out, and manually complete the
remaining sections before sending it out to your tax office.

Tax Payments Listing (Payroll) (UK)

Details of employees’ PAYE and National Insurance deductions.

Tax Register Report (Payroll) (South Africa)

Tax-related information and balances for current employees and ex-employees.

File-Tax Withheld Report (Payroll) (Japan)

This notification file details the total income tax withheld from an employee’s
earnings. Created by the legal employer to send the relevant local government.
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Final Notice of Fixed Labor Insurance Fee Report (Payroll) (Japan)

This is the total list of wages for employees with breakdown of each month, and is
submitted by the business proprietor to the relevant Labor Standards Inspection Office
in May.

Local Tax Withheld Report (Payroll) (Japan)

This report details the total income tax withheld from an employee’s earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant local
government.

Notification Change Address for National Pension Type 3 Insured Report (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an employee’s insured dependent’s (=National Pension Type 3rd insured’s)
address is changed.

Notification to Change Address for Welfare Pension Insurance Report (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an insured employee’s address is changed.

Notification to Change Address for Welfare Pension Insurance Report (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an insured employee’s address is changed.

Payroll Report (Notification for Geppen) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an employee’s social insurance premiums are changed without waiting for the
following regular determination because of rise in pay etc.

Payroll Report (Notification for Santei) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when an employee’s social insurance premiums in and after October of the year are
determined based on their earnings.

Payroll Report (Notification of Deduction for Dependents) (Payroll) (Japan)

This notification details employee’s dependents so that he/she can receive deduction
of a tax reduction for spouses, allowance for dependent, credit for handicapped
person, etc. The legal employer receives this from employees before YEA period and
must keep this in case the tax authority asks to present.

Payroll Report (Notification of Deduction for Ins Premiums, Spouse) (Payroll) (Japan)

This notification details employee’s premiums of life and nonlife insurances so that
he/she can receive insurance premium deduction and special exemption for spouse. The
legal employer receives this from employees before YEA period and must keep this
in case the tax authority asks to present.
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Payroll Report (Notification of Dependents for Health Insurance / Notification of Type 3 Insured for
National Pension) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when the details of insured employee’s dependents is changed.

Payroll Report (Notification of Disqualification for Health Ins/Welfare Pension Insurance) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance
office when the insured employee loses qualification because of some reason like
termination, and death.

Payroll Report (Notification of Qualification for Health Ins/Welfare Pension Insurance) (Payroll) (Japan)

This notification is submitted by the business proprietor to the social insurance office
when the person applicable to Article 9 of Welfare Pension Insurance Law or the 10th
article is employed.

Salary Payment Summary Report (Payroll) (Japan)

This report details the total income tax withheld from all employees’ total earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant local
government.

Si FD Report (Payroll) (Japan)

This is a request set to execute line#2-#6 at once.

Tax Withheld Report (Payroll) (Japan)

This report details the total income tax withheld from an employee’s earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant Japanese
tax authority.

Total Income Tax Withheld Report (Payroll) (Japan)

This report details the total income tax withheld from all employees’ total earnings. The
amount of tax withheld is forwarded by the legal employer to the relevant Japanese
tax authority.

Payroll Processing and Analysis

1099-R Exception Register (Payroll) (US)

Identifies employees who:have negative box 1 totals on the Form 1099-R, or have a zero
box 1 total on the Form 1099-R, but have other negative 1099-R box totals.

1099-R Forms (Payroll) (US)

Provides for printing of retiree 1099-R at an individual level as well as all employees in
a GRE.

1099-R Information Return (Payroll) (US)

Allows printing a single 1099-R or a range of 1099-Rs that you define. Sort options give
you further flexibility in 1099-R distribution.
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1099-R Register (Payroll) (US)

Allows viewing the amounts reported in each box of the Form 1099-R for all employees
in a particular GRE for a given year.

1099-R Register Totals (Payroll) (US)

You can choose to view only the box totals for all selected employees in the report;
individual employees will not be included in the report. Or you can choose to view box
totals in the report for selected individual employees, as well as the totals for these
employees.

Alien Retro Benefits Loss (Payroll) (US)

The Alien Retro Benefits Loss report identifies employees who have earned treaty
benefits that are then revoked.

Alien Retro Benefits Projection (Payroll) (US)

The Alien Retro Benefits Projection identifies employees who are earning alien tax treaty
benefits that could be subject to a retroactive loss at some point in the future.

Annual Unemployment Insurance (Form 940) Information (Payroll) (US)

Provides numbers for annual 940 filing.

Annual FUTA Tax Return (Payroll) (US)

Oracle Payroll provides certain information in the form of a work sheet that you then
transcribe to the official form 940; however, some information must be provided by you.

Audit Report (Payroll)

Selects person, employee or applicant, assignment, element, recurring or non-recurring
status. Shows Business Group, GRE (US only), assignment details, person
entering data (responsibility), input date, effective change date, details of person
affected. Lists all fields changed, with input date and effective date, old value and new
value, responsibility, workstation address.

Cost Breakdown Report for Costing Run (Payroll)

Summarized costing totals for an individual costing.

Cost Breakdown Report for Date Range (Payroll)

Summarized costing totals for all costing runs within a given date range.

Earnings Audit (Payroll) (US)

Report detailing all employees with a particular element being processed in a given
pay period.

Element Result Listing (Payroll)

Run results processed for a particular element over a defined period, and run results for
selected input values of each employee’s last assignment process.
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Employee Payroll Movements Report (Payroll)

New hires, terminations, transfers in and transfer out of a selected payroll.

Employee Run Results (Payroll) (CA, US)

Users may select various elements for the various time frames, assignment of GREs. The
report shows the run results for selected information by pay period.

Employee Run Results Summary Report (Payroll) (UK)

Includes all assignments, gross pay, PAYE, employee’s NI contribution, employer’s NI
contribution, other deductions, total deductions, net pay and total pay for the payroll.

Federal 1099-R (magnetic media) (Payroll) (US)

Creation of Federal 10999R magnetic media.

Federal and State Tax Remittance Reporting (Payroll) (US)

This report shows the federal and state balances summarized for a particular range of
check dates.

Federal W-2 (magnetic media) (Payroll) (US)

Creation of Federal W-2 magnetic media and summary totals.

GRE Totals (Payroll) (US)

Reconciliation report to be used to assist in period end processing balancing
purposes. This report shows Federal and State level taxable balances and withholdings.

Local Tax Remittance Reporting (Payroll) (US)

This report shows the local tax balances summarized for a particular range of check dates.

Multiple Assignments Report (Payroll) (UK)

Lists employees who have been marked for multiple assignment processing and
indicates where Priority Processing Type is not set and cannot be defaulted.

Multiple Worksite Report (US)

Reports on wages and locations of employees in all the multiple locations across all
SUIs and other GREs.

NACHA (magnetic media) (Payroll) (US)

Provides for creation of employee NACHA information to be submitted.

NACHA Report (Payroll) (US)

Detail of employee NACHA information.

Over Limit Reporting (Payroll) (US)

The Over Limit Report identifies employees who have had taxes withheld in excess
of the legal limit.
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Pay Advice Alignment Report (Payroll) (UK)

Draft printer alignment for your sample pay advice.

Payment Register (Payroll) (South Africa)

Payment elements per employee.

Payment Register Detail and Summary Reports (Payroll) (US)

Detail and summary reports listing payments made to employees, listing payment
method, check number, and amount.

Payments Summary Report (Payroll) (UK)

Payments totalled by payment method type and organizational payment method for a
specified payroll and payroll period. Account details for each organizational payment
method are also listed.

Payroll Activity Report (Payroll) (US)

The Payroll Activity report shows employee and group level payroll details.

Payroll Message Report (Payroll)

Display messages for processes connected to specified payrolls.

Payroll Reconciliation Payment Summary Report (Australia)(AU)

Generates payroll reconciliation or end of year processing and for all the legal employers
in that period.

Payroll Reconciliation Summary Report (Australia)(AU)

Generates payroll reconciliation summary report for a specific payroll or quick-pay
run, or for a specific period.

Payment Summary Self Printed Report (AU)

This report enables employers to self print payment summaries on plain paper. This
feature is only available to employers who submit their Payment Summary data to
the ATO electronically.

Payment Summary Validation Report (AU)

This report obtains all information from the archive tables and can be run several times
in a year, against archived data, for data validation. The report lists details that are
normally printed on the Payment Summary.

Payroll Tax Report (Australia)

Run this report to generate a payroll tax report detailing employer’s liability for payroll
tax contributions for a specified month and for a specified Australian state. You must
run your payroll before running this report.

Payroll Reconciliation Report (New Zealand) (NZ)

Generates a payroll reconciliation for a specified payroll period.
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Payroll Register (Payroll) (US)

Payroll Register Reporting is used to show employee and group level payroll details

Retro Notifications Report

Generates an assignment set containing retroactive changes applying to a period for
which payroll processing has already taken place.

Saudi Payroll Register Report (Payroll) (SA)

Use this report to create payroll information for each employee for each payroll
period, and store information for payroll verification, validation, and auditing purposes.

Start of Year: Records Unprocessed Report (Payroll) (UK)

Valid records on the Inland Revenue P9 tape that do not fully match your database
records after running the Start of Year process.

UIF Report (Payroll) (South Africa)

Employee and employer contributions made to the Unemployment Insurance Fund.

W-2 Forms (Payroll) (US)

Prints employee W-2s at an individual level, thus allowing W-2s to be created as
employees terminate, or for an entire GRE.

Year End Negative Balance Reports (Payroll) (US)

Report listing any negative balances found due to user adjustments or conversion issues.

Year End Adjustment e-File Report (Payroll) (Korea)

The generated report is about Year End Adjustment, based on the year end balance
adjustment and archive process to view, and print the report, and store it on magnetic
tape, and send the generated magnetic file to the local tax offices upon their request.

Year End Adjustment Ledger Report (Payroll) (Korea)

Generates the YEA Ledger using Oracle Reports for all three YEA types, Normal, Interim
and Re. You can generate the ledger using three different criteria:

• Business Place

• Payroll Action

• Assignment Action

Year End Adjustment Reclaim Sheet (Payroll) (Korea)

Generates a record with details about YEA tax exemptions and deductions. Oracle
Payroll bases this information on the date the employer enters in the Year End
Adjustment Information window. The enterprise uses it to claim YEA and keeps the
record as documentation for National Tax Services.

Year End Adjustment Tax Receipt Report (Payroll) (Korea)

Generates a YEA tax receipt with details like housing pre-tax deduction and insurance
exemption for a particular payroll action, business place or an assignment set.
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Year End Adjustment Tax Summary Report (Payroll) (Korea)

View the summarized YEA tax details for a business place and period in the generated
report.

IR8S Ad Hoc Printed Archive Report (Payroll) (Singapore)

Generates an IR8S report for validation purposes, before submitting the report to the
IRAS.

Payroll Event Rules

Void Payments (Payroll)

Details of cancelled cheque payments

Deploy Self Service Capability

Notification of Personnel Action (SF 50) (FD)

Prints the standard Notification of Personnel Action for an approved Request for
Personnel Action

Request for Personnel Action (SF-52) (FD)

Prints the contents of the employee’s Request for Personnel Action

Workforce Intelligence

Dutch Assignment SCL FLexfield Upgrade Report (Netherlands)

Run this report to view the information removed and moved by the Dutch Assignment
SCL Flexfield upgrade script.

Processes

A8A File (Payroll) (Singapore)

Creates a file that includes the details of any benefits-in-kind provided to your
employees, for example, car-related benefits, or the cost of running a fax machine. The
process also creates a report for you to view the contributions that are included in the file.

A8B File (Payroll) (Singapore)

Creates a file that records details of any stock options granted to an employee, and any
stock options exercised during a financial period.

ACB Process (Payroll) (South Africa)

Setting up and running ACB.

Advance Pay Batch Setup (South Africa) (Payroll) (South Africa)

Advance Pay Batch Setup.
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Advance Pay Process (Payroll) (UK)

Allows you to pay employees in advance for holidays or other events.

Annual and Long Service Leave Liability Process (Australia) (AU)

Extracts information used in the Leave Liability Report.

ASB CSV Direct Credit Process (New Zealand) (NZ)

Details of all employees that use the direct credit as the payment method.

Audit Trail Update Tables Process

This process is used to set up audit trail on selected tables.

Audit Trail Update Datetracked Tables Process

This process is used to set up audit trail on selected datetracked tables.

BACS Process (Payroll) (UK)

Summarized totals for BACS tape amounts including consolidated totals for multi-day
and multi-file formats.

Batch Print Notification of Personnel Action (FD)

Prints Notifications of Personnel Action (SF-50s) in batch mode.

BEE Batch Process (Purge)

This process is used to delete a batch from the BEE tables on completion of the
concurrent request.

BEE Batch Process (Rollback)

This process is used to completely remove a BEE transfer, provided you have not purged
the batch from the BEE tables

BEE Batch Process (Transfer)

This process is used to create element entries in the Oracle HRMS Entries table from the
existing entries in the BEE temporary tables.

BEE Batch Process (Validate)

This process is used to test each batch line against predefined rules about element
entries, and against any additional validation procedures that you have created.

Bulk Compile Formulas

Run this process to compile all of your formulas.

Calculate Commitment

Run this process to calculate the projected expenditures for a budget over a given
period. You can calculate commitments for an entire budget or for a single position
in a budget.
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Calculate FTE for Assignments page (UK)

This process is used to populate the Assignment Budget Window with FTE values.

Cash Process (Payroll only) (UK)

Enables you to use cash as a payment method and record cash payments to employee
assignments.

CDV Bank Name User Table Setup (Payroll) (South Africa)

Creates the CDV Bank Name User Table.

CDV Data Load Process (Payroll) (South Africa)

Loads CDV data.

Change Person Numbering to Automatic

Run this to process to change the method by which you identify your employees from
manual to automatic number generation

Check Writer Process

Cheque/Check Writer process to determine the generation of cheques/checks for a
specified payroll and consolidation set over a specified time period.

Check Writer Process (Payroll) (US)

This process is used to write sequences of checks for your payroll run.

Cheque Writer Process (Payroll) (South Africa)

Produces cheque payments.

Cheque Writer Process (Payroll)

This process is used to write sequences of cheques for your payroll run.

This process is used to populate the Assignment Budget Window with FTE values.

Child Sequence Generator Process (Germany)

This process generates the sequence number for children. The sequence number is used
in the calculation of the local cost-of-living allowance.

Close Action Items Process (Advanced Benefits)

Run this process before the Close Enrollments Process to close any open action items
that are required or optional for the persons you select.

Close Enrollments Process (Advanced Benefits)

Run this process to close a person’s enrollment after elections have been made.

Collective Agreement Entitlement Evaluation

Run this process to evaluate and apply collective agreement entitlements for an
employee.

Reports and Processes in Oracle HRMS B-73



Commitment GL Posting

You run the Commitment GL Posting batch process to transfer budget commitments
from Oracle HRMS to Oracle General Ledger.

Communications Triggers Process (Advanced Benefits)

Use the communications triggers process to generate communications for persons who
meet the selection criteria that you specify.

Compensation Workbench Back-Out Life Events Process

Run this process to remove the results of the Participation Process: Compensation for
a life event associated with Compensation Workbench.

Compensation Workbench Close Enrollment Process

Run this process to close the life event for a Compensation Workbench plan.

Compensation Workbench Post Process

Run this process after all worksheet allocations have been approved.

Costing Process (Payroll)

Generates journal entries for your ledgers and costing information relating to labor costs.

CPFLine (Payroll) (Singapore)

Creates a file that you submit each month to the CPF Board for every legal entity in your
enterprise. The report that is produced enables you to view the CPF contributions that
are included in the file

Create and Maintain Company Cost Centers with Existing Organizations

This process creates company cost center organizations for each unique company cost
center combination that has been defined in GL. This process is also available as part of
the Synchronize GL Company Cost Centers with HR request set.

Create Federal HR Valid Combinations for the Grade KF (FD)

Federal Concurrent Manager process that supplies the predefined valid grade and pay
plan combinations for the grade key flexfield.

Create Federal Special Info Types (FD)

Federal Concurrent Manager process that supplies the Federal Special Information
types for the Person Special Information.

Credit Transfer Process (Payroll) (South Africa)

Marks employees with this payment method as paid.

Credit Transfer Cheque Payments Process (Payroll) (South Africa)

Produces an aggregated cheque per bank branch to be submitted with Deposit Schedules.
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Default Enrollment Process (Advanced Benefits)

Run this process to enroll participants into the default benefit plan when participants
have not made an election.

Direct Deposit (Singapore IBG Format) (Payroll) (Singapore)

Creates a payment file and report, run after PrePayments is complete for the payroll.

Direct Deposit Process (China - CCBS Format) (Payroll China)

This report produces a deposit advice in the correct format. This process generates
two outputs:

• A hard copy called "Bank Transfer Report". This output provides a list of employees
who had been processed in the Direct Deposit Process.

• A magnetic file for submission to the bank

Once the advice is transferred to the bank, the bank deposits the payments directly into
the worker’s account.

Bank Transfer Report (Payroll Korea)

This report produces a deposit advice in the correct format. This process generates two
outputs, a hard copy and a magnetic file for submission to the bank. Once you transfer
the advice to the bank, the bank deposits the payments directly into the worker’s account.

Direct Entry (Australian BECS Format) Process (AU)

Produces a payment file for all employees.

Direct Entry (Reconciliation Report) (AU)

Produces a payment file for all employees. This file is the output version of the magtape
sent to the government.

Electronic Lodgement of TFN Declaration report (.mf) (AU)

The Electronic Lodgement of TFN Declaration process allows you to produce a report for
any new or changed TFN details for the employees in an organization. This file is the
binary magtape file that is used for uploading to the government.

Electronic Lodgement of TFN Declaration report (.out) (AU)

The Electronic Lodgement of TFN Declaration process allows you to produce a report for
any new or changed TFN details for the employees in an organization. This file is the
output version of the magtape file that is sent to the government.

Download HRMS Taskflows Process

Run this process to export a task flow from your database to a flat file that you can
then import to another database.

Duty Station Conversion Process (FD)

Moves employees from an old to a new Location
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Electronic Tax File Process (Payroll) (South Africa)

Produces tax files in ASCII format.

Electronic UIF File Preprocess (South Africa)

This preprocess archives UIF information for the Electronic UIF File.

Electronic UIF File Process (South Africa)

The Electronic UIF File must be submitted on a monthly basis.

Enable Multiple Security Groups Process

Run this process when you first set up security groups enabled security.

End of Year Process (Payroll) (UK)

Produces statutory End of Year return to the Inland Revenue for employees in your
enterprise.

Export GL Company Cost Center Process

The process is run for your current business group and writes information about GL
company cost center combinations for companies that you have previously defined for
your business group to a tab delimited file. It creates a record in the file for each unique
company cost center combination that has been defined in GL.

Extract Definition Download to Data File

Copies a system extract definition to a file for upload to another business group or
Oracle HRMS database.

Extract Definition Upload to Data File

Imports a copy of a system extract definition to a new business group or Oracle HRMS
database.

Extract Process (Advanced Benefits)

Run the extract process to save the output of your system extract to the directory and file
that you specified in your extract definition.

Extract Results Data Purge

On a periodic basis, run the purge process to free table space in the system extract
results tables.

Extracting Information to Appear on the Payslip

Enables you to access the latest data relevant to the payslip, and copy it to archive tables.

Federal Benefits - TSP Conversion of Benefits (FD)

This process migrates converts the existing records for employees participating in TSP
to the Benefits model.
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Federal Benefits - TSP Catchup Conversion of Benefits (FD)

This process converts the existing records for employees participating in TSP Catch-Up
to the Benefits model.

Forms Configurator – Download Template

Run this process to download one or more people management templates to a data file.

Forms Configurator – Upload Template

Run this process to upload a template to enable you to use it with the People
Management Configurator (Forms Configurator) tool.

French PTO Accruals – Create Entitlements Process

Enables you to create entitlements from accruals, so that holidays may be spent.

French PTO Accruals – Obsolete Entitlements Process

Enables you to obsolete unspent entitlement.

Full Settlement Process (France) (Payroll)

This produces a letter in duplicate stating that the employee agrees that their termination
has been concluded correctly.

Generate Overtime Payment Mapping Process (Payroll) (France)

Allows you to associate your overtime scheme with a payroll calendar.

Generate Secure User Process (SECGEN)

Run this process when you create a new security profile that references a reporting user.

Grant Permissions to Roles Process (ROLEGEN)

Dynamically grants select permissions on Oracle HRMS tables and views to the
HR_REPORTING_USER role.

IR56B Archive Process (Payroll)(Hong Kong)

The IR56B Annual Employers Return Archive process stores employee and balance
information, which is used in the IR56B Report and the Magnetic Tape process.

IR56B Magnetic Tape Process (Payroll) (Hong Kong)

The IR56B Magnetic Tape process produces the end of year magnetic tape from the
Archived Information.

IR8A File (Payroll) (Singapore)

Creates a file that includes your includes your employees’ earnings for a specific tax year
and legal entity. The process also creates a report for you to view the contributions that
are included in the file.
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IR8S File (Payroll) (Singapore)

Creates a file that includes your employees’ and employers’ earnings for a specific tax
year and legal entity. The process also creates a report for you to view the contributions
that are included in the file.

IRAS Line Archive (Payroll) (Singapore)

Archives the data that will later be used to create the year-end magnetic tapes.

Maintain Designee Eligibility (Advanced Benefits)

Run this process for those benefit plans that include an age factor in determining
dependent eligibility.

Maintain Participant Eligibility Process (Standard Benefits)

Run this process if you license Standard Benefits and you want to determine benefits
eligibility for a segment of your employee population. This process also de-enrolls
currently enrolled participants who lose benefits eligibility and ends their associated
benefits coverage and activity rate.

Manual Credit Transfer Cheque Payments (Payroll) (South Africa)

Updates system with cheque number of manually issued cheques.

Manual Payments (Payroll) (South Africa)

Updates system with manual payments made to employees.

Manually Issued Tax Certificates (Payroll) (South Africa)

Updates system with manually issued tax certificates numbers.

NACHA Process (Payroll) (US)

Produces files that you load on magnetic tape and despatch to banks for direct deposit
payments.

P11D Benefits and Expenses Report (HR and Payroll) (UK)

Takes a P11D archive request ID and prints a selection of Class 1A benefits and expenses.

P11D Gaps and Overlaps Report (HR and Payroll) (UK)

Identifies a taxable benefit that is spread over multiple periods with a gap between
each period, and also identifies taxable benefits of the same type that overlap each
other within the same period.

P11D Magtape (HR and Payroll) (UK)

Generates a magnetic tape containing details of Class 1A NICs for reporting to the
Inland Revenue.

Partial Period Accrual Calculation Process (Core Payroll, and enabled localizations)

Run this process to calculate accruals when the end of your accounting period occurs
part way through a payroll period.
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Participation Batch Process: Grade Step

Run this process to determine eligibility and electable choices for employees whom you
want to progress using Grade/Step Progression.

Participation Batch Process: Life Event (Advanced Benefits)

Run this process to determine eligibility and electable choices for benefits participants
based on a life event you select.

Participation Batch Process: Scheduled (Advanced Benefits)

Run this process to determine eligibility and electable choices for benefits participants
based on a scheduled enrollment event.

Participation Batch Process: Selection (Advanced Benefits)

Run this process to determine eligibility for benefits participants. This process does not
create electable choices.

Participation Process: Compensation

Run this process for Compensation Workbench prior to the availability of a plan for
budget and worksheet entry.

Pay Advice Generation – Self Service (South Africa) (South Africa)

Archives balances and elements you define and other pay advice related information.

Payroll Run (Payroll) (France)

The Payroll Run is the regular method to process employee pay.

Payslip Generation – Self Service (UK)

Generate payslips for employees to view online through Oracle Self-Service.

Payslip Generator – Statement of Earnings (Payroll) (France)

This process generates pay advice data for all employees for a specified payroll and
period.

Pension Extracts

These processes enable you to extract employee pension plan-related data for transfer to
third-party providers.

Pension Extracts (Electronic Notification) (Netherlands)

This process extracts the pensions and social insurance data you require for the monthly
notification report to ABP and UWV USZO.

Periodic Tax Filing (FLS) (Payroll) (US)

The Periodic Tax Filing Interface creates a flat file (.mf) containing the archived data
from the External Process Archive in a format that can be directly submitted to Federal
Liaison Services, Inc. (FLS) for tax filing and reporting.
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Populate FEHB Program and Plan Design (FD)

This process populates the Federal Employee Health Benefits program and plan designs
for use in professional user interface forms and self-service benefits.

Populate TSP Program and Plan Design (FD)

This process populates the US Federal Thrift Savings Plan programs and plan designs
for use in professional user interface forms and self-service benefits.

Populate TSP Catchup Program and Plan Design (FD)

This process populates the Thrift Savings Plan Catch Up program and plan designs for
use in professional user interface forms and self-service benefits.

PrePayments (French) Process (Payroll) (France)

Use this process to distribute employee pay over more than one payment method
using either a percentage or monetary split. This process runs prepayments for one
calendar month only.

PrePayments Process (Payroll)

Use this process to distribute employee pay over more than one payment method
using either a percentage or monetary split.

Previous Services Validation (HR) (France)

Use this process to validate the employee’s (titulaire) services for a period in which the
employee has worked in some other public sector type organization as non-titulaires.

Printing the Payslip

Enables you to access the archived payslip information, and create a formatted file ready
for printing and distributing to your employees.

Process Forfeitures (US)

Calculates--by participant--the total unspent contributions for a spending account
benefits plan.

Process Future Dated RPAs (FD)

Set the frequency for processing future actions.

Prud’hommale (Workers Election) Declaration Process (HR) (France)

Creates a statutory declaration which enables your employees to take part in the
Industrial Tribunal elections.

Purge Backed-Out or Voided Life Events

Removes person data associated with backed-out or voided life events for Advanced
Benefits and Compensation Workbench.

Recalculate Participant Values (Standard Benefits) (US)

Updates activity rates for currently enrolled benefits participants based on plan design
changes.
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As a prerequisite, you should run the Maintain Participant Eligibility process to update
eligibility records and derived factors.

Register Extra Information Types (EITs)

Enables you to register the new Extra Information Types (EITs) that you create using the
Descriptive Flexfield window.

Note: This process cannot be used to register organizational EITs.

Relieve Commitments

Run the Relieve Commitments request set to calculate budget commitments and post the
results to Oracle General Ledger. The request set combines the Calculate Commitments
process and the Commitment GL Posting process.

Remove Title from Person’s Full Name

Run the Remove Title from Person’s Full Name concurrent process to remove title from
existing records without updating them.

RetroPay Process

Enables you to make back pay adjustments.

Retry Payroll Process

Retry a payroll process again.

Running the P45 EDI Process (UK)

Enables you to notify the Inland Revenue about employees who leave your employment.

Running the P45(3) EDI Process (UK)

Enables you to notify the Inland Revenue about a new starters information, or someone
receiving a pension.

Running the P45 Process (UK)

Enables you to print and archive, or just archive specified P45’s.

Running the P46 EDI Process (UK)

Enables you to provide information on new employees who cannot produce, or have
never had a P45.

Running the P6 and P9 Upload Process (UK)

Run the process to upload the details about changes to an employee’s tax code, or
coding changes from the Inland Revenue.

Running the Works Number Update (UK)

Run to provide information on updated and new employee works numbers.
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Saudi Payroll Archiver Process (Payroll) (SA)

Use this process to archive the payroll details for each payroll period for future
reference. This supports production of Online Payslip and Payroll Register reports.

Saudi Payroll Upgrade Process (Payroll) (SA)

Use this process to migrate data from existing payroll runs and generate group reports
for employees.

Security List Maintenance Process (PERSLM)

This process is usually run every night to maintain the lists of organizations, positions,
payrolls, employees, and applicants that security profile holders can access.

Seed French Data Process (France)

This process creates and populates user defined tables using predefined lookup types
and rows.

Start Automatic WGI (FD)

Schedule the Within Grade Increases (WGI) process to set the frequency with which
the system processes automatic WGIs.

Start of Year Process (Payroll) (UK)

Usually performed at the start of the tax year to update tax information for each
employee.

Synchronize GL Company Cost Centers with HR Request Set

This request set runs the following two processes:

• Create and Maintain Company Cost Center Organizations, page B-74

• Synchronize GL Company Cost Centers with Existing Organizations, page B-82

Synchronize GL Company Cost Centers with Existing Organizations

This process links existing and newly created company cost center organizations to GL
account combinations, where a link does not already exist..

Synchronize Positions Process (FD)

This process updates the non-datetracked Positions table (PER_ALL_POSITIONS) with
changes made to the datetracked table (HR_ALL_POSITIONS_F). When you run the
process, any datetracked changes with an effective date on or before today are applied
to the non-datetracked table.

Synchronize Salary Rates Process (France)

This process synchronizes the existing salary rates in the corps set up when you update
the indemnity rates defined for your global pay scale. This match ensures that you use
current compensation values in your pay scales.
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Tax Batch Update Process (Germany)

The Tax Batch Update Process enables you to update the tax records for employees who
have not submitted their tax cards for the current tax year. You can either run the process
in report-only mode, which identifies the employees whose records would be subject to
change, or in update mode to make the changes to the records.

Tax Credit Upload (Payroll) (Ireland)

The Tax Credit Upload process enables you to upload the tax credits of an employee from
the data file provided by the Revenue. It also specifies standard rate cut-off amounts
for each employee. The tax credit upload process validates the records provided by the
Revenue and then uploads them into the PAY_IE_PAYE DETAILS_F table.

Tax Year End Data Validation and Preprocess (Payroll) (South Africa)

Preparation for issue of tax certificates.

Tax Year Start Process (Payroll) (South Africa)

Updates employee tax information at the start of each tax year.

Tax Year Start Rollback (Payroll) (South Africa)

Rolls back the actions performed in the Tax Year Start Process.

Termination Category Setup Process (Payroll) (South Africa)

Part of setup required for storing Employment Equity and UIF information.

Transfer to GL Process

Transfers the results of the costing process to the Accounting flexfield of Oracle General
Ledger.

Upgrade from ADE to Web ADI

Run this process to convert styles used by Application Data Exchange (ADE) to
integrators in Web Applications Desktop Integrator (Web ADI).

Upload GL Company Cost Center Information Request Set

Run the Upload GL Company Cost Center Information request set to upload the
amended version of the exported file created using the Export GL Company Cost
Centers process.

Upload HRMS Taskflows Process

Run this process to import a task flow to your database from a flat file exported from
another database.

Upload Social Insurance Providers Process (Germany)

The Upload Social Insurance Providers Process enables you to upload a delivered list of
social insurance providers to your German HR system.
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Upload Tax Offices Process (Germany)

The Upload Tax Offices Process enables you to upload a delivered list of tax offices to
your German HR system.

Upload Taxable Benefits (HR and Payroll) (UK)

The Taxable Benefits process enables you to upload a flat file of P11D elements to your
P11D data repository.

Vehicle Mileage Calculation Information (Payroll) (UK)

Enters or deletes default mileage elements and rates tables for categories of vehicles
in your business group.

Void Cheque Payments (Payroll) (South Africa)

Uploads details of canceled cheque payments.

Void Credit Transfer Cheque Payments (Payroll) (South Africa)

Voids aggregated cheque payments made to banks.

Void Payments Process (Payroll) (UK, US)

Allows you to void cheques that have been printed but need to be cancelled.

Wage and Tax Statement Form (Form W-2) (Payroll) (US)

The Wage and Tax Statement (Form W-2) is used by employers to report taxable
and non-taxable income information of individual employees to the IRS and State
governments.
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Glossary

360-Degree Appraisal

Part of the SSHR Appraisal function and also known as a Group Appraisal. This is an
employee appraisal undertaken by managers with participation by reviewers.

360-Degree Self Appraisal

Part of the SSHR Appraisal function and also known as a Group Appraisal. This is
a 360-Degree appraisal initiated by an employee. The employee (initiator) can add
managers and reviewers to the appraisal.

Absence

A period of time in which an employee performs no work for the assigned organization.

Absence Types

Categories of absence, such as medical leave or vacation leave, that you define for
use in absence windows.

Accrual

The recognized amount of leave credited to an employee which is accumulated for a
particular period.

Accrual Band

A range of values that determines how much paid time off an employee accrues. The
values may be years of service, grades, hours worked, or any other factor.

Accrual Period

The unit of time, within an accrual term, in which PTO is accrued. In many plans, the
same amount of time is accrued in each accrual period, such as two days per month. In
other plans, the amount accrued varies from period to period, or the entitlement for the
full accrual term is given as an up front amount at the beginning of the accrual term.

Accrual Plan

See: PTO Accrual Plan, page Glossary-22

Accrual Term

The period, such as one year, for which accruals are calculated. In most accrual
plans, unused PTO accruals must be carried over or lost at the end of the accrual
term. Other plans have a rolling accrual term which is of a certain duration but has no
fixed start and end dates.
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Activity Rate

The monetary amount or percentage associated with an activity, such as $12.35 per pay
period as an employee payroll contribution for medical coverage. Activity rates can
apply to participation, eligibility, coverages, contributions, and distributions.

Actual Premium

The per-participant premium an insurance carrier charges the plan sponsor for a given
benefit.

Administrative Enrollment

A type of scheduled enrollment caused by a change in plan terms or conditions and
resulting in a re-enrollment.

AdvancePay

A process that recalculates the amount to pay an employee in the current period, to
make an authorized early payment of amounts that would normally be paid in future
payroll periods.

Alert

An email notification that you can set up and define to send a recipient or group of
recipients a reminder or warning to perform a certain task or simply a notification to
inform the recipient of any important information.

API

Application Programmatic Interfaces, used to upload data to the Oracle Applications
database. APIs handle error checking and ensure that invalid data is not uploaded to
the database.

Applicant

A candidate for employment in a Business Group.

Applicant/Candidate Matching Criteria

Matching functionality in the iRecruitment system that systematically identifies which
candidates and applicants possess the skills, knowledge and abilities to be considered
for a specific vacancy. The following columns are used for matching:

• Skills

• FT/PT

• Contractor/Employee

• Work at Home

• Job Category

• Distance to Location

• Key Words

• Salary

Apply for a Job

An SSHR function that enables an employee to, apply, search and prepare applications
for an internally advertised vacancy.
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Appraisal

An appraisal is a process where an employee’s work performance is rated and future
objectives set.

See also: Assessment, page Glossary-3.

Appraisee

A person being appraised by an appraiser..

Appraiser

A person, usually a manager, who appraises an employee.

Appraising Manager

The person who initiates and performs an Employee-Manager or 360 Degree
Appraisal. An appraising manager can create appraisal objectives.

Arrestment

Scottish court order made out for unpaid debts or maintenance payments.

See also: Court Order , page Glossary-8

Assessment

An information gathering exercise, from one or many sources, to evaluate a person’s
ability to do a job.

See also: Appraisal, page Glossary-3.

Assignment

A worker’s assignment identifies their role within a business group. The assignment
is made up of a number of assignment components. Of these, organization is
mandatory, and payroll is required (for employees only) for payment purposes.

Assignment Number

A number that uniquely identifies a worker’s assignment. A worker with multiple
assignments has multiple assignment numbers.

Assignment Rate

A monetary value paid to a contingent worker for a specified period of time. For
example, an assignment rate could be an hourly overtime rate of $10.50.

Assignment Set

A grouping of employees and applicants that you define for running QuickPaint reports
and processing payrolls.

See also: QuickPaint Report, page Glossary-23

Assignment Status

For workers, used to track their permanent or temporary departures from your
enterprise and, for employees only, to control the remuneration they receive. For
applicants, used to track the progress of their applications.
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Authoria

A provider of health insurance and compensation information, that provides additional
information about benefits choices.

BACS

Banks Automated Clearing System. This is the UK system for making direct deposit
payments to employees.

Balance Adjustment

A correction you make to a balance. You can adjust user balances and assignment
level predefined balances only.

Balance Dimension

The period for which a balance sums its balance feeds, or the set of
assignments/transactions for which it sums them. There are five time
dimensions: Run, Period, Quarter, Year and User. You can choose any reset point for
user balances.

Balance Feeds

These are the input values of matching units of measure of any elements defined to
feed the balance.

Balances

Positive or negative accumulations of values over periods of time normally generated by
payroll runs. A balance can sum pay values, time periods or numbers.

See also: Predefined Components , page Glossary-21

Bargaining Unit

A bargaining unit is a legally organized group of people which have the right to negotiate
on all aspects of terms and conditions with employers or employer federations. A
bargaining unit is generally a trade union or a branch of a trade union.

Base Currency

The currency in which Oracle Payroll performs all payroll calculations for your Business
Group. If you pay employees in different currencies to this, Oracle Payroll calculates the
amounts based on exchange rates defined in the system.

Base Summary

A database table that holds the lowest level of summary. Summary tables are populated
and maintained by user-written concurrent programs.

Behavioral Indicators

Characteristics that identify how a competence is exhibited in the work context.

See also: Proficiency Level , page Glossary-22

Beneficiary

A person or organization designated to receive the benefits from a benefit plan upon
the death of the insured.
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Benefit

Any part of an employee’s remuneration package that is not pay. Vacation
time, employer-paid medical insurance and stock options are all examples of benefits.

See also: Elements, page Glossary-11

Block

The largest subordinate unit of a window, containing information for a specific business
function or entity. Every window consists of at least one block. Blocks contain fields
and, optionally, regions. They are delineated by a bevelled edge. You must save your
entries in one block before navigating to the next.

See also: Region, page Glossary-24, Field, page Glossary-12

Budget Measurement Type (BMT)

A subset of Workforce Measurement Type. It consists of a number of different units
used to measure the workforce. The most common units are headcount and full time
equivalent.

Budget Value

In Oracle Human Resources you can enter staffing budget values and actual values for
each assignment to measure variances between actual and planned staffing levels in
an organization or hierarchy.

Business Group

The highest level organization in the Oracle HRMS system. A Business Group may
correspond to the whole of your enterprise or to a major grouping such as a subsidiary or
operating division. Each Business Group must correspond to a separate implementation
of Oracle HRMS.

Business Number (BN)

In Canada, this is the employer’s account number with Revenue Canada. Consisting of
15 digits, the first 9 identify the employer, the next 2 identify the type of tax account
involved (payroll vs. corporate tax), and the last 4 identify the particular account for
that tax.

Cafeteria Benefits Plan

See: Flexible Benefits Program, page Glossary-12

Calendar Exceptions

If you are using the Statutory Absence Payments (UK) feature, you define calendar
exceptions for an SSP qualifying pattern, to override the pattern on given days. Each
calendar exception is another pattern which overrides the usual pattern.

Calendars

In Oracle Human Resources you define calendars that determine the start and end
dates for budgetary years, quarters and periods. For each calendar you select a basic
period type. If you are using the Statutory Absence Payments (UK) feature, you define
calendars to determine the start date and time for SSP qualifying patterns.
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Canada/Quebec Pension Plan (CPP/QPP) Contributions

Contributions paid by employers and employees to each of these plans provide income
benefits upon retirement.

Candidate

(iRecruitment) A candidate is a person who has either directly provided their personal
and professional information to a company’s job site or provided their resume and
details to a manager or recruiter for entering in the iRecruitment system.

Candidate Offers

An SSHR function used by a line manager to offer a job to a candidate. This function
is supplied with its own responsibility.

Career Path

This shows a possible progression from one job or position from any number of other
jobs or positions within the Business Group. A career path must be based on either job
progression or position progression; you cannot mix the two.

Carry Over

The amount of unused paid time off entitlement an employee brings forward from
one accrual term to the next. It may be subject to an expiry date i.e. a date by which
it must be used or lost.

See also: Residual, page Glossary-25

Cash Analysis

A specification of the different currency denominations required for paying your
employees in cash. Union contracts may require you to follow certain cash analysis rules.

Ceiling

The maximum amount of unused paid time off an employee can have in an accrual
plan. When an employee reaches this maximum, he or she must use some accrued
time before any more time will accrue.

Certification

Documentation required to enroll or change elections in a benefits plan as the result of a
life event, to waive participation in a plan, to designate dependents for coverage, or to
receive reimbursement for goods or services under an FSA.

Child/Family Support payments

In Canada, these are payments withheld from an employee’s compensation to satisfy a
child or family support order from a Provincial Court. The employer is responsible for
withholding and remitting the payments to the court named in the order.

Collective Agreement

A collective agreement is a form of contract between an employer or employer
representative, for example, an employer federation, and a bargaining unit for example, a
union or a union branch.
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Collective Agreement Grade

Combination of information that allows you to determine how an employee is ranked or
graded in a collective agreement.

Communications

Benefits plan information that is presented in some form to participants. Examples
include a pre-enrollment package, an enrollment confirmation statement, or a notice
of default enrollment.

Compensation

The pay you give to employees, including wages or salary, and bonuses.

See also: Elements, page Glossary-11

Compensation Object

For Standard and Advanced Benefits, compensation objects define, categorize, and help
to manage the benefit plans that are offered to eligible participants. Compensation
objects include programs, plan types, plans, options, and combinations of these entities.

Competence

Any measurable behavior required by an organization, job or position that a person
may demonstrate in the work context. A competence can be a piece of knowledge, a
skill, an attitude, or an attribute.

See also: Unit Standard Competence, page Glossary-29

Competence Evaluation

A method used to measure an employees ability to do a defined job.

Competence Profile

Where you record applicant and employee accomplishments, for example, proficiency
in a competence.

Competence Requirements

Competencies required by an organization, job or position.

See also: Competence, page Glossary-7, Core Competencies, page Glossary-8

Competence Type

A group of related competencies.

Configurable Forms

Forms that your system administrator can modify for ease of use or security purposes
by means of Custom Form restrictions. The Form Customization window lists the
forms and their methods of configuration.

Consideration

(iRecruitment) Consideration means that a decision is registered about a person in
relation to a vacancy so that the person can be contacted.
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Consolidation Set

A grouping of payroll runs within the same time period for which you can schedule
reporting, costing, and post-run processing.

Contact

A person who has a relationship to an employee that you want to record. Contacts can
be dependents, relatives, partners or persons to contact in an emergency.

Content

When you create a spreadsheet or word processing document using Web ADI, the
content identifies the data in the document. Content is usually downloaded from the
Oracle application database.

Contingent Worker

A worker who does not have a direct employment relationship with an enterprise and
is typically a self-employed individual or an agency-supplied worker. The contingent
worker is not paid via Oracle Payroll.

Contract

A contract of employment is an agreement between an employer and employee
or potential employee that defines the fundamental legal relationship between an
employing organization and a person who offers his or her services for hire. The
employment contract defines the terms and conditions to which both parties agree
and those that are covered by local laws.

Contribution

An employer’s or employee’s monetary or other contribution to a benefits plan.

Core Competencies

Also known as Leadership Competencies or Management Competencies. The competencies
required by every person to enable the enterprise to meet its goals.

See also: Competence, page Glossary-7

Costable Type

A feature that determines the processing an element receives for accounting and
costing purposes. There are four costable types in Oracle HRMS: costed, distributed
costing, fixed costing, and not costed.

Costing

Recording the costs of an assignment for accounting or reporting purposes. Using Oracle
Payroll, you can calculate and transfer costing information to your general ledger and
into systems for project management or labor distribution.

Court Order

A ruling from a court that requires an employer to make deductions from an employee’s
salary for maintenance payments or debts, and to pay the sums deducted to a court
or local authority.

See also: Arrestment, page Glossary-3
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Credit

A part of the Qualifications Framework. The value a national qualifications authority
assigns to a unit standard competence or a qualification. For example, one credit may
represent 10 hours of study, a unit standard competence may equate to 5 credits, and a
qualification may equate to 30 credits.

Criteria Salary Rate

Variable rate of pay for a grade, or grade step. Used by Grade/Step Progression.

Database Item

An item of information in Oracle HRMS that has special programming attached, enabling
Oracle FastFormula to locate and retrieve it for use in formulas.

Date Earned

The date the payroll run uses to determine which element entries to process. In North
America (and typically elsewhere too) it is the last day of the payroll period being
processed.

Date Paid

The effective date of a payroll run. Date paid dictates which tax rules apply and which
tax period or tax year deductions are reported.

Date To and Date From

These fields are used in windows not subject to DateTrack. The period you enter in these
fields remains fixed until you change the values in either field.

See also: DateTrack, page Glossary-9, Effective Date, page Glossary-10

DateTrack

When you change your effective date (either to past or future), DateTrack enables
you to enter information that takes effect on your new effective date, and to review
information as of the new date.

See also: Effective Date, page Glossary-10

Default Postings

(iRecruitment) Default text stored against business groups, organizations, jobs, and/or
positions. The default postings are used to create job postings for a vacancy.

Dependent

In a benefit plan, a person with a proven relationship to the primary participant whom
the participant designates to receive coverage based on the terms of the plan.

Deployment Factors

See: Work Choices, page Glossary-30

Derived Factor

A factor (such as age, percent of fulltime employment, length of service, compensation
level, or the number of hours worked per period) that is used in calculations to
determine Participation Eligibility or Activity Rates for one or more benefits.
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Descriptive Flexfield

A field that your organization can configure to capture additional information required
by your business but not otherwise tracked by Oracle Applications.

See also: Key Flexfield , page Glossary-15

Developer Descriptive Flexfield

A flexfield defined by your localization team to meet the specific legislative and
reporting needs of your country.

See also: Extra Information Types, page Glossary-12

Direct Deposit

The electronic transfer of an employee’s net pay directly into the account(s) designated
by the employee.

Discoverer Workbook

A grouping of worksheets. Each worksheet is one report.

Discoverer Worksheet

A single report within a workbook. A report displays the values of predefined criteria
for analysis.

Distribution

Monetary payments made from, or hours off from work as allowed by, a compensation
or benefits plan.

Download

The process of transferring data from the Oracle HRMS application to your desktop
(the original data remains in the application database).

Effective Date

The date for which you are entering and viewing information. You set your effective
date in the Alter Effective Date window.

See also: DateTrack, page Glossary-9

EIT

See: Extra Information Type, page Glossary-12

Electability

The process which determines whether a potential benefits participant, who has satisfied
the eligibility rules governing a program, plan, or option in a plan, is able to elect
benefits. Participants who are eligible for benefits do not always have electable benefit
choices based on the rules established in a benefit plan design.

Element Classifications

These control the order in which elements are processed and the balances they
feed. Primary element classifications and some secondary classifications are predefined
by Oracle Payroll. Other secondary classifications can be created by users.
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Element Entry

The record controlling an employee’s receipt of an element, including the period of time
for which the employee receives the element and its value.

See also: Recurring Elements, page Glossary-24, Nonrecurring Elements, page Glossary-18

Element Link

The association of an element to one or more components of an employee
assignment. The link establishes employee eligibility for that element. Employees whose
assignment components match the components of the link are eligible for the element.

See also: Standard Link, page Glossary-27

Elements

Components in the calculation of employee pay. Each element represents a compensation
or benefit type, such as salary, wages, stock purchase plans, and pension contributions.

Element Set

A group of elements that you define to process in a payroll run, or to control access to
compensation information from a configured form, or for distributing costs.

Eligibility

The process by which a potential benefits participant satisfies the rules governing
whether a person can ever enroll in a program, plan, or option in a plan. A participant
who is eligible for benefits must also satisfy electability requirements.

Employee

A worker who has a direct employment relationship with the employer. Employees are
typically paid compensation and benefits via the employer’s payroll application.

Employee Histories

An SSHR function for an employee to view their Learning History, Job Application
History, Employment History, Absence History, or Salary History. A manager can also
use this function to view information on their direct reports.

Employment Category

A component of the employee assignment. Four categories are defined: Full Time
- Regular, Full Time - Temporary, Part Time - Regular, and Part Time - Temporary.

Employment Equity Occupational Groups (EEOG)

In Canada, the Employment Equity Occupational Groups (EEOG) consist of 14
classifications of work used in the Employment Equity Report. The EEOGs were derived
from the National Occupational Classification system.

Employment Insurance (EI)

Benefit plan run by the federal government to which the majority of Canadian employers
and employees must contribute.

Employment Insurance Rate

In Canada, this is the rate at which the employer contributes to the EI fund. The rate is
expressed as a percentage of the employee’s contribution. If the employer maintains an
approved wage loss replacement program, they can reduce their share of EI premiums
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by obtaining a reduced contribution rate. Employers would remit payroll deductions
under a different employer account number for employees covered by the plan.

Enrollment Action Type

Any action required to complete enrollment or de-enrollment in a benefit.

Entitlement

In Australia, this is all unused leave from the previous year that remains to the credit
of the employee.

ESS

Employee Self Service. A predefined SSHR responsibility.

Event

An activity such as a training day, review, or meeting, for employees or
applicants. Known as class in OLM.

Ex-Applicant

Someone who has previously applied for a vacancy or multiple vacancies, but all
applications have ended, either because the applicant has withdrawn interest or they
have been rejected. Ex-Applicants can still be registered users.

Expected Week of Childbirth (EWC)

In the UK, this is the week in which an employee’s baby is due. The Sunday of the
expected week of childbirth is used in the calculations for Statutory Maternity Pay (SMP).

Extra Information Type (EIT)

A type of developer descriptive flexfield that enables you to create an unlimited number
of information types for six key areas in Oracle HRMS. Localization teams may also
predefine some EITs to meet the specific legislative requirements of your country.

See also: Developer Descriptive Flexfield, page Glossary-10

Field

A view or entry area in a window where you enter, view, update, or delete information.

See also: Block, page Glossary-5, Region, page Glossary-24

Flex Credit

A unit of "purchasing power" in a flexible benefits program. An employee uses flex
credits, typically expressed in monetary terms, to "purchase" benefits plans and/or levels
of coverage within these plans.

Flexible Benefits Program

A benefits program that offers employees choices among benefits plans and/or levels of
coverage. Typically, employees are given a certain amount of flex credits or moneys with
which to "purchase" these benefits plans and/or coverage levels.

Flexible Spending Account

(FSA) Under US Internal Revenue Code Section 125, employees can set aside money
on a pretax basis to pay for eligible unreimbursed health and dependent care
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expenses. Annual monetary limits and use-it-or-lose it provisions exist. Accounts are
subject to annual maximums and forfeiture rules.

Form

A predefined grouping of functions, called from a menu and displayed, if necessary, on
several windows. Forms have blocks, regions and fields as their components.

See also: Block, page Glossary-5, Region, page Glossary-24, Field, page Glossary-12

Full Time Equivalent (FTE)

A Workforce Measurement Type (WMT) that measures full time equivalent. Although
the actual value and calculation may vary, this value is taken from the Assignment
Budget Value (ABV) in Oracle HRMS. If the Assignment Budget Value in Oracle HRMS
is not set up then a FastFormula is used to determine the value to be calculated.

Global Value

A value you define for any formula to use. Global values can be dates, numbers or text.

Goods or Service Type

A list of goods or services a benefit plan sponsor has approved for reimbursement.

Grade

A component of an employee’s assignment that defines their level and can be used to
control the value of their salary and other compensation elements.

Grade Comparatio

A comparison of the amount of compensation an employee receives with the mid-point
of the valid values defined for his or her grade.

Grade Ladder

The key component of Grade/Step Progression. You use a grade ladder to categorize
grades, to determine the rules for how an employee progresses from one grade (or step)
to the next, and to record the salary rates associated with each grade or step on the ladder.

Grade Rate

A value or range of values defined as valid for a given grade. Used for validating
employee compensation entries.

Grade Scale

A sequence of steps valid for a grade, where each step corresponds to one point on a pay
scale. You can place each employee on a point of their grade scale and automatically
increment all placements each year, or as required.

See also: Pay Scale, page Glossary-19

Grade Step

An increment on a grade scale. Each grade step corresponds to one point on a pay scale.

See also: Grade Scale, page Glossary-13

Grandfathered

A term used in Benefits Administration. A person’s benefits are said to be grandfathered
when a plan changes but they retain the benefits accrued.
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Group

A component that you define, using the People Group key flexfield, to assign employees
to special groups such as pension plans or unions. You can use groups to determine
employees’ eligibility for certain elements, and to regulate access to payrolls.

Group Certificate

In Australia, this is a statement from a legal employer showing employment income
of an employee for the financial year..

Headcount(HEAD)

A Workforce Measurement Type (WMT) that measures headcount. Although the actual
value and calculation may vary, this value is taken from the Assignment Budget Value
(ABV) in Oracle HRMS. If the Assignment Budget Value in Oracle HRMS is not set up
then a FastFormula is used to determine the value to be calculated.

Hierarchy

An organization or position structure showing reporting lines or other relationships. You
can use hierarchies for reporting and for controlling access to Oracle HRMS information.

Imputed Income

Certain forms of indirect compensation that US Internal Revenue Service Section
79 defines as fringe benefits and taxes the recipient accordingly. Examples include
employer payment of group term life insurance premiums over a certain monetary
amount, personal use of a company car, and other non-cash awards.

Info Online

A generic framework to integrate Oracle applications with partner applications, enabling
users to access information from third-party providers, Metalink and Learning
Management.

Initiator

In SSHR a person who starts a 360 Degree appraisal (Employee or Self) on an
individual. An initiator and the appraisee are the only people who can see all appraisal
information.

Input Values

Values you define to hold information about elements. In Oracle Payroll, input values
are processed by formulas to calculate the element’s run result. You can define up
to fifteen input values for an element.

Instructions

An SSHR user assistance component displayed on a web page to describe page
functionality.

Integrator

Defines all the information that you need to download or upload from a particular
window or database view using Web ADI.

Interface

A Web ADI term for the item that specifies the columns to be transferred from the Oracle
applications database to your desktop or vice versa.
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Involuntary

Used in turnover to describe employees who have ceased employment with the
enterprise not of their own accord, for example, through redundancy.

Job

A job is a generic role within a business group, which is independent of any single
organization. For example, the jobs "Manager" and "Consultant" can occur in many
organizations.

Job Posting

An advertisement for a specific vacancy. This is the public side of the vacancy for
which a candidate would apply.

Key Flexfield

A flexible data field made up of segments. Each segment has a name you define and a
set of valid values you specify. Used as the key to uniquely identify an entity, such as
jobs, positions, grades, cost codes, and employee groups.

See also: Descriptive Flexfield, page Glossary-10

Key Performance Indicator (KPI)

Target values that you set for the performance of your enterprise. This value comes from
the corresponding KPI Portlet/Report. You can configure the Performance Management
Framework to send a notification when actual performance falls short of, or exceeds, the
target value. For example, you may configure the Performance Management Framework
to send you a notification when workforce variance is greater than 10 percent, or when
training success is below 50 percent.

Key Performance Indicator (KPI) Portlet/Report

Displays the executive summary of key measures such as total headcount and total salary.

Layout

Indicates the columns to be displayed in a spreadsheet or Word document created
using Web ADI.

Learning Management

Oracle’s enterprise learning management system that administers online and offline
educational content.

Leave Loading

In Australia, an additional percentage amount of the annual leave paid that is paid
to the employee.

Leaver’s Statement

In the UK, this Records details of Statutory Sick Pay (SSP) paid during a previous
employment (issued as form SSP1L) which is used to calculate a new employee’s
entitlement to SSP. If a new employee falls sick, and the last date that SSP was paid for
under the previous employment is less than eight calendar weeks before the first day of
the PIW for the current sickness, the maximum liability for SSP is reduced by the number
of weeks of SSP shown on the statement.
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Legal Employer

A business in Australia that employs people and has registered with the Australian
Tax Office as a Group Employer.

Life Event

A significant change in a person’s life that results in a change in eligibility or ineligibility
for a benefit.

Life Event Collision

A situation in which the impacts from multiple life events on participation
eligibility, enrollability, level of coverage or activity rates conflict with each other.

Life Event Enrollment

A benefits plan enrollment that is prompted by a life event occurring at any time during
the plan year.

Linked PIWs

In the UK, these are linked periods of incapacity for work that are treated as one to
calculate an employee’s entitlement to Statutory Sick Pay (SSP). A period of incapacity
for work (PIW) links to an earlier PIW if it is separated by less than the linking interval. A
linked PIW can be up to three years long.

Linking Interval

In the UK, this is the number of days that separate two periods of incapacity for work. If
a period of incapacity for work (PIW) is separated from a previous PIW by less than the
linking interval, they are treated as one PIW according to the legislation for entitlement
to Statutory Sick Pay (SSP). An employee can only receive SSP for the maximum number
of weeks defined in the legislation for one PIW.

LMSS

Line Manager Self Service. A predefined SSHR responsibility.

Long Service Leave

Leave with pay granted to employees of a particular employer after a prescribed period
of service or employment with that employer.

Lookup Types

Categories of information, such as nationality, address type and tax type, that have a
limited list of valid values. You can define your own Lookup Types, and you can add
values to some predefined Lookup Types.

Lower Earnings Limit (LEL)

In the UK, this is the minimum average weekly amount an employee must earn to pay
National Insurance contributions. Employees who do not earn enough to pay National
Insurance cannot receive Statutory Sick Pay (SSP) or Statutory Maternity Pay (SMP).

Manager

(iRecruitment) A manager accesses the iRecruitment system to document their hiring
needs and conduct their recruiting activities online. Specifically, these activities include
vacancy definition, searching for candidates, and processing applicants through the
vacancy process.
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Manager-Employee Appraisal

Part of the SSHR Appraisal function. A manager appraisal of an employee. However, an
appraising manager does not have to be a manager.

Mapping

If you are bringing in data from a text file to Oracle HRMS using a spreadsheet created
in Web ADI, you need to map the columns in the text file to the application’s tables
and columns.

Maternity Pay Period

In the UK, this is the period for which Statutory Maternity Pay (SMP) is paid. It may
start at any time from the start of the 11th week before the expected week of confinement
and can continue for up to 18 weeks. The start date is usually agreed with the
employee, but can start at any time up to the birth. An employee is not eligible to SMP
for any week in which she works or for any other reason for ineligibility, defined by
the legislation for SMP.

Medicare Levy

An amount payable by most taxpayers in Australia to cover some of the cost of the
public health system.

Menus

You set up your own navigation menus, to suit the needs of different users.

My Account

(iRecruitment) My Account is the total of either a candidate or applicant’s personal
and vacancy-specific information including the information needed to manage their
progress through the recruitment process.

NACHA

National Automated Clearing House Association. This is the US system for making
direct deposit payments to employees.

National Identifier

This is the alphanumeric code that is used to uniquely identify a person within their
country. It is often used for taxation purposes. For example, in the US it is the Social
Security Number, in Italy it is the Fiscal Code, and in New Zealand it is the IRD Number.

National Occupational Classification (NOC) code

In Canada, the National Occupational Classification (NOC) System was developed to
best reflect the type of work performed by employees. Occupations are grouped in terms
of particular tasks, duties and responsibilities. The use of this standardized system
ensures consistency of data from year to year within the same company as well as
between companies. These codes are used in the Employment Equity Report.

Net Accrual Calculation

The rule that defines which element entries add to or subtract from a plan’s accrual
amount to give net entitlement.
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Net Entitlement

The amount of unused paid time off an employee has available in an accrual plan at
any given point in time.

Nonrecurring Elements

Elements that process for one payroll period only unless you make a new entry for
an employee.

See also: Recurring Elements, page Glossary-24

North American Industrial Classification (NAIC) code

The North American Industrial Classification system (NAICs) was developed jointly
by the US, Canada and Mexico to provide comparability in statistics regarding
business activity across North America. The NAIC replaces the US Standard Industrial
Classification (SIC) system, and is used in the Employment Equity Report.

Not in Program Plan

A benefit plan that you define outside of a program.

OLM

Oracle Learning Management.

Online Analytical Processing (OLAP)

Analysis of data that reveals business trends and statistics that are not immediately
visible in operational data.

Online Transactional Processing (OLTP)

The storage of data from day-to-day business transactions into the database that contains
operational data.

Open Enrollment

A type of scheduled enrollment in which participants can enroll in or alter elections
in one or more benefits plans.

Oracle FastFormula

Formulas are generic expressions of calculations or comparisons you want to repeat
with different input values. With Oracle FastFormula you can write formulas using
English words and basic mathematical functions. The output of FastFormulas is fed
back into reports.

Organization

A required component of employee assignments. You can define as many organizations
as you want within your Business Group. Organizations can be internal, such as
departments, or external, such as recruitment agencies. You can structure your
organizations into organizational hierarchies for reporting purposes and for system
access control.

OSSWA

Oracle Self Service Web Applications.
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Outcome

For a unit standard competence, a behavior or performance standard associated with
one or more assessment criteria. A worker achieves a unit standard competence when
they achieve all outcomes for that competence.

Overrides

You can enter overrides for an element’s pay or input values for a single payroll
period. This is useful, for example, when you want to correct errors in data entry for a
nonrecurring element before a payroll run.

Parameter Portlet

A portlet in which you select a number of parameters that may affect all your portlets on
your page. These may include an effective date, the reporting period, the comparison
type, the reporting manager, and the output currency for your reports. The parameter
portlet is usually available at the top of the portal page.

Pattern

A pattern comprises a sequence of time units that are repeated at a specified
frequency. The Statutory Absence Payments (UK) feature, uses SSP qualifying patterns
to determine employees entitlement to Statutory Sick Pay (SSP).

Pattern Time Units

A sequence of time units specifies a repeating pattern. Each time unit specifies a time
period of hours, days or weeks.

Pay Scale

A set of progression points that can be related to one or more rates of pay. Employee’s
are placed on a particular point on the scale according to their grade and, usually, work
experience.

See also: Grade Scale, page Glossary-13

Pay Value

An amount you enter for an element that becomes its run item without formula
calculations.

See also: Input Values, page Glossary-14

Payment Type

There are three standard payment types for paying employees: check, cash and direct
deposit. You can define your own payment methods corresponding to these types.

Payroll

A group of employees that Oracle Payroll processes together with the same processing
frequency, for example, weekly, monthly or bimonthly. Within a Business Group, you
can set up as many payrolls as you need.

Payroll Reversal

A payroll reversal occurs when you reverse a payroll run for a single employee, in
effect cancelling the run for this employee.
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Payroll Rollback

You can schedule a payroll rollback when you want to reverse an entire payroll
run, cancelling out all information processed in that run. To preserve data integrity, you
can roll back only one payroll at a time, starting with the one most recently run.

Payroll Run

The process that performs all the payroll calculations. You can set payrolls to run at
any interval you want.

People List

An SSHR line manager utility used to locate an employee.

Performance Management Framework (PMF)

A business intelligence tool used to alert users to exceptional circumstances, as defined
by KPIs. When a particular factor measured by HRMSi goes beyond a threshold chosen
by the user, the system sends the user a workflow notification.

Performance Management Viewer (PMV)

A reporting tool that displays the report that corresponds to one or more PMF targets.

Performance (within Assessment)

An expectation of "normal" performance of a competence over a given period. For
example, a person may exceed performance expectation in the communication
competence.

See also: Proficiency (within Assessment), page Glossary-21, Competence, page
Glossary-7, Assessment, page Glossary-3

Period of Incapacity for Work (PIW)

In the UK, this is a period of sickness that lasts four or more days in a row, and is the
minimum amount of sickness for which Statutory Sick Pay can be paid. If a PIW is
separated by less then the linking interval, a linked PIW is formed and the two PIWs
are treated as one.

Period of Placement

The period of time a contingent worker spends working for an organization. A
contingent worker can have only one period of placement at a time although they can
have multiple assignments during that time.

Period Type

A time division in a budgetary calendar, such as week, month, or quarter.

Personal Public Service Number (PPS)

The Irish equivalent to National Insurance number in the UK, or the Social Security
number in the US.

Personal Tax Credits Return (TD1)

A Revenue Canada form which each employee must complete. Used by the employee
to reduce his or her taxable income at source by claiming eligible credits and also
provides payroll with such important information as current address, birth date, and
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SIN. These credits determine the amount to withhold from the employee’s wages for
federal/provincial taxes.

Person Search

An SSHR function which enables a manager to search for a person. There are two
types of search, Simple and Advanced.

Person Type

There are eight system person types in Oracle HRMS. Seven of these are combinations
of employees, ex-employees, applicants, and ex-applicants. The eighth category is
’External’. You can create your own user person types based on the eight system types.

Personnel Actions

Personnel actions is a public sector term describing business processes that define
and document the status and conditions of employment. Examples include
hiring, training, placement, discipline, promotion, transfer, compensation, or
termination. Oracle HRMS uses the term self-service actions synonymously with this
public sector term. Oracle Self Service Human Resources (SSHR) provides a configurable
set of tools and web flows for initiating, updating, and approving self-service actions.

Plan Design

The functional area that allows you to set up your benefits programs and
plans. This process involves defining the rules which govern eligibility, available
options, pricing, plan years, third party administrators, tax impacts, plan
assets, distribution options, required reporting, and communications.

Plan Sponsor

The legal entity or business responsible for funding and administering a benefits
plan. Generally synonymous with employer.

Position

A specific role within the Business Group derived from an organization and a job. For
example, you may have a position of Shipping Clerk associated with the organization
Shipping and the job Clerk.

Predefined Components

Some elements and balances, all primary element classifications and some secondary
classifications are defined by Oracle Payroll to meet legislative requirements, and are
supplied to users with the product. You cannot delete these predefined components.

Professional Information

An SSHR function which allows an employee to maintain their own professional details
or a line manager to maintain their direct reports professional details.

Proficiency (within Assessment)

The perceived level of expertise of a person in a competence, in the opinion of
the assessor, over a given period. For example, a person may demonstrate the
communication competence at Expert level.

See also: Performance (within Assessment), page Glossary-20, Competence, page
Glossary-7, Assessment, page Glossary-3
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Proficiency Level

A system for expressing and measuring how a competence is exhibited in the work
context.

See also: Behavioral Indicators, page Glossary-4.

Progression Point

A pay scale is calibrated in progression points, which form a sequence for the progression
of employees up the pay scale.

See also: Pay Scale, page Glossary-19

Prospect Pool

(iRecruitment) The prospect pool contains all registered users who have given
permission for their information to be published.

Provincial/Territorial Employment Standards Acts

In Canada, these are laws covering minimum wages, hours of work, overtime, child
labour, maternity, vacation, public/general holidays, parental and adoption
leave, etc., for employees regulated by provincial/territorial legislation.

Provincial Health Number

In Canada, this is the account number of the provincially administered health care plan
that the employer would use to make remittances. There would be a unique number for
each of the provincially controlled plans i.e. EHT, Quebec HSF, etc.

PTO Accrual Plan

A benefit in which employees enroll to entitle them to accrue and take paid time off
(PTO). The purpose of absences allowed under the plan, who can enroll, how much time
accrues, when the time must be used, and other rules are defined for the plan.

QPP

(See Canada/Quebec Pension Plan)

QA Organization

Quality Assurance Organization. Providers of training that leads to Qualifications
Framework qualifications register with a QA Organization. The QA Organization is
responsible for monitoring training standards.

Qualification Type

An identified qualification method of achieving proficiency in a competence, such as
an award, educational qualification, a license or a test.

See also: Competence, page Glossary-7

Qualifications Framework

A national structure for the registration and definition of formal qualifications. It
identifies the unit standard competencies that lead to a particular qualification, the
awarding body, and the field of learning to which the qualification belongs, for example.
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Qualifying Days

In the UK, these are days on which Statutory Sick Pay (SSP) can be paid, and the only
days that count as waiting days. Qualifying days are normally work days, but other
days may be agreed.

Qualifying Pattern

See: SSP Qualifying Pattern, page Glossary-27

Qualifying Week

In the UK, this is the week during pregnancy that is used as the basis for the qualifying
rules for Statutory Maternity Pay (SMP). The date of the qualifying week is fifteen weeks
before the expected week of confinement and an employee must have been continuously
employed for at least 26 weeks continuing into the qualifying week to be entitled to SMP.

Quebec Business Number

In Canada, this is the employer’s account number with the Ministere du Revenu du
Quebec, also known as the Quebec Identification number. It consists of 15 digits, the first
9 identify the employer, the next 2 identify the type of tax account involved (payroll
vs. corporate tax), and the last 4 identify the particular account for that tax.

Questionnaire

An SSHR function which records the results of an appraisal.

QuickPaint Report

A method of reporting on employee and applicant assignment information. You can
select items of information, paint them on a report layout, add explanatory text, and save
the report definition to run whenever you want.

See also: Assignment Set, page Glossary-3

QuickPay

QuickPay allows you to run payroll processing for one employee in a few minutes’
time. It is useful for calculating pay while someone waits, or for testing payroll formulas.

Ranking

(iRecruitment) A manually entered value to indicate the quality of the applicant against
other applicants for a specific vacancy.

Rates

A set of values for employee grades or progression points. For example, you can define
salary rates and overtime rates.

Rating Scale

Used to describe an enterprise’s competencies in a general way. You do not hold the
proficiency level at the competence level.

See also: Proficiency Level, page Glossary-22

Record of Employment (ROE)

A Human Resources Development Canada form that must be completed by an employer
whenever an interruption of earnings occurs for any employee. This form is necessary to
claim Employment Insurance benefits.
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Recruitment Activity

An event or program to attract applications for employment. Newspaper
advertisements, career fairs and recruitment evenings are all examples of recruitment
activities. You can group several recruitment activities together within an overall activity.

Recurring Elements

Elements that process regularly at a predefined frequency. Recurring element entries
exist from the time you create them until you delete them, or the employee ceases to be
eligible for the element. Recurring elements can have standard links.

See also: Nonrecurring Elements, page Glossary-18, Standard Link, page Glossary-27

Region

A collection of logically related fields in a window, set apart from other fields by a
rectangular box or a horizontal line across the window.

See also: Block, page Glossary-5, Field, page Glossary-12

Registered Pension Plan (RPP)

This is a pension plan that has been registered with Revenue Canada. It is a plan where
funds are set aside by an employer, an employee, or both to provide a pension to
employees when they retire. Employee contributions are generally exempt from tax.

Registered Retirement Savings Plan (RRSP)

This is an individual retirement savings plan that has been registered with Revenue
Canada. Usually, contributions to the RRSP, and any income earned within the RRSP, is
exempt from tax.

Registered User

(iRecruitment) A person who has registered with the iRecruitment site by entering an
e-mail address and password. A registered user does not necessarily have to apply
for jobs.

Report Parameters

Inputs you make when submitting a report to control the sorting, formatting, selection,
and summarizing of information in the report.

Report Set

A group of reports and concurrent processes that you specify to run together.

Requisition

The statement of a requirement for a vacancy or group of vacancies.

Request Groups

A list of reports and processes that can be submitted by holders of a particular
responsibility.

See also: Responsibility, page Glossary-25
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Residual

The amount of unused paid time off entitlement an employee loses at the end of an
accrual term. Typically employees can carry over unused time, up to a maximum, but
they lose any residual time that exceeds this limit.

See also: Carry Over, page Glossary-6

Responsibility

A level of authority in an application. Each responsibility lets you access a specific set of
Oracle Applications forms, menus, reports, and data to fulfill your business role. Several
users can share a responsibility, and a single user can have multiple responsibilities.

See also: Security Profile, page Glossary-26, User Profile Options, page Glossary-30, Request
Groups, page Glossary-24, Security Groups, page Glossary-24

Resume

A document that describes the experience and qualifications of a candidate.

RetroPay

A process that recalculates the amount to pay an employee in the current period to
account for retrospective changes that occurred in previous payroll periods.

Retry

Method of correcting a payroll run or other process before any post-run processing takes
place. The original run results are deleted and the process is run again.

Revenue Canada

Department of the Government of Canada which, amongst other
responsibilities, administers, adjudicates, and receives remittances for all taxation in
Canada including income tax, Employment Insurance premiums, Canada Pension Plan
contributions, and the Goods and Services Tax (legislation is currently proposed to revise
the name to the Canada Customs and Revenue Agency). In the province of Quebec the
equivalent is the Ministere du Revenu du Quebec.

Reversal

Method of correcting payroll runs or QuickPay runs after post-run processing has taken
place. The system replaces positive run result values with negative ones, and negative
run result values with positive ones. Both old and new values remain on the database.

Reviewer (SSHR)

A person invited by an appraising manager to add review comments to an appraisal.

RIA

Research Institute of America (RIA), a provider of tax research, practice materials, and
compliance tools for professionals, that provides U.S. users with tax information.

Rollback

Method of removing a payroll run or other process before any post-run processing takes
place. All assignments and run results are deleted.

Rollup

An aggregate of data that includes subsidiary totals.
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Run Item

The amount an element contributes to pay or to a balance resulting from its processing
during the payroll run. The Run Item is also known as calculated pay.

Salary Basis

The period of time for which an employee’s salary is quoted, such as hourly or
annually. Defines a group of employees assigned to the same salary basis and receiving
the same salary element.

Salary Rate

The rate of pay associated with a grade or step. Used by Grade/Step Progression.

Scheduled Enrollment

A benefits plan enrollment that takes place during a predefined enrollment period, such
as an open enrollment. Scheduled enrollments can be administrative, open, or
unrestricted.

Search by Date

An SSHR sub-function used to search for a Person by Hire date, Application date, Job
posting date or search by a Training event date.

Security Group

Security groups enable HRMS users to partition data by Business Group. Only used for
Security Groups Enabled security.

See also: Responsibility, page Glossary-25, Security Profile, page Glossary-26, User Profile
Options, page Glossary-30

Security Groups Enabled

Formerly known as Cross Business Group Responsibility security. This security model
uses security groups and enables you to link one responsibility to many Business Groups.

Security Profile

Security profiles control access to organizations, positions and employee and applicant
records within the Business Group. System administrators use them in defining users’
responsibilities.

See also: Responsibility, page Glossary-25

Self Appraisal

Part of the SSHR Appraisal function. This is an appraisal undertaken by an employee to
rate their own performance and competencies.

Site Visitor

(iRecruitment) A person who navigates to the iRecruitment web site and may view
job postings. This person has not yet registered or logged in to the iRecruitment
system. This individual may search for postings on the web site and also has the ability
to log in or register with the iRecruitment site.

SMP

See: Statutory Maternity Pay, page Glossary-28
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Social Insurance Number (SIN)

A unique number provided by Human Resources Development Canada (HRDC) to each
person commencing employment in Canada. The number consists of 9 digits in the
following format (###-###-###).

Source Deductions Return (TP 1015.3)

A Ministere du Revenu du Quebec form which each employee must complete. This
form is used by the employee to reduce his or her taxable income at source by claiming
eligible credits and also provides payroll with such important information as current
address, birth date, and SIN. These credits determine the amount of provincial tax to
withhold from the employee’s wages.

Special Information Types

Categories of personal information, such as skills, that you define in the Personal
Analysis key flexfield.

Special Run

The first run of a recurring element in a payroll period is its normal run. Subsequent
runs in the same period are called special runs. When you define recurring elements you
specify Yes or No for special run processing.

SSHR

Oracle Self-Service Human Resources. An HR management system using an intranet
and web browser to deliver functionality to employees and their managers.

SSP

See: Statutory Sick Pay, page Glossary-28

SSP Qualifying Pattern

In the UK, an SSP qualifying pattern is a series of qualifying days that may be repeated
weekly, monthly or some other frequency. Each week in a pattern must include at least
one qualifying day. Qualifying days are the only days for which Statutory Sick Pay
(SSP) can be paid, and you define SSP qualifying patterns for all the employees in your
organization so that their entitlement to SSP can be calculated.

Standard HRMS Security

The standard security model. Using this security model you must log on as a different
user to see a different Business Group.

Standard Link

Recurring elements with standard links have their element entries automatically created
for all employees whose assignment components match the link.

See also: Element Link, page Glossary-11, Recurring Elements, page Glossary-24

Statement of Commissions and Expenses for Source Deduction Purposes (TP
1015.R.13.1)

A Ministere du Revenu du Quebec form which allows an employee who is paid partly or
entirely by commissions to pay a constant percentage of income tax based on his or her
estimated commissions for the year, less allowable business expenses.
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Statement of Earnings (SOE)

A summary of the calculated earnings and deductions for an assignment in a payroll
period.

Statement of Remuneration and Expenses (TD1X)

In Canada, the Statement of Remuneration and Expenses allows an employee who is
paid partly or entirely by commission to pay a constant percentage of income tax, based
on his or her estimated income for the year, less business-related expenses.

Statutory Adoption Pay

In the UK, Statutory Adoption Pay (SAP) is payable to a person of either sex with whom
a child is, or is expected to be, placed for adoption under UK law.

Statutory Maternity Pay

In the UK, you pay Statutory Maternity Pay (SMP) to female employees who take time
off work to have a baby, providing they meet the statutory requirements set out in
the legislation for SMP.

Statutory Sick Pay

In the UK, you pay Statutory Sick Pay (SSP) to employees who are off work for four or
more days because they are sick, providing they meet the statutory requirements set
out in the legislation for SSP.

Statutory Paternity Pay

In the UK, Statutory Paternity Pay Birth (SPPB) is payable to a person supporting the
mother at the time of birth. In cases of adoption, the primary carer receives Statutory
Adoption Pay, while the secondary carer receives Statutory Paternity Pay Adoption
(SPPA).

Succession Planning

An SSHR function which enables a manager to prepare a succession plan.

Suitability Matching

An SSHR function which enables a manager to compare and rank a persons
competencies.

Superannuation Guarantee

An Australian system whereby employers are required to contribute a percentage of an
eligible employee’s earnings to a superannuation fund to provide for their retirement.

Supplier

An internal or external organization providing contingent workers for an
organization. Typically suppliers are employment or recruitment agencies.

Tabbed Regions

Parts of a window that appear in a stack so that only one is visible at any time. You click
on the tab of the required region to bring it to the top of the stack.
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Task Flows

A sequence of windows linked by buttons to take you through the steps required to
complete a task, such as hiring a new recruit. System administrators can create task
flows to meet the needs of groups of users.

Tax Point

The date from which tax becomes payable.

Template Letter

Form letter or skeleton letter that acts as the basis for creating mail merge letters. The
template letter contains the standard text, and also contains field codes, which are
replaced by data from the application during the mail merge process.

Terminating Employees

You terminate an employee when he or she leaves your organization. Information about
the employee remains on the system but all current assignments are ended.

Termination Rule

Specifies when entries of an element should close down for an employee who leaves
your enterprise. You can define that entries end on the employee’s actual termination
date or remain open until a final processing date.

Tips

An SSHR user assistance component that provides information about a field.

Transcentive

A third-party compensation management solutions provider, that provides additional
information about benefits choices.

Unit Standard

A nationally registered document that describes a standard of performance. The
standard is typically defined and maintained by industry representatives.

Unit Standard Competence

A competence that is defined in a Unit Standard and linked to a Qualifications
Framework qualification.

Upload

The process of transferring the data from a spreadsheet on your desktop, created using
Web ADI, back to the Oracle HRMS application.

User Assistance Components

SSHR online help comprising tips and instructions.

User Balances

Users can create, update and delete their own balances, including dimensions and
balance feeds.

See also: Balances, page Glossary-4
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User Profile Options

Features that allow system administrators and users to tailor Oracle HRMS to their
exact requirements.

See also: Responsibility, page Glossary-25, Security Profile, page Glossary-26

User-based Security

With this type of security, the application generates the security permissions for a
current user when that user logs on to a system. The system uses the security profile
(can be position, supervisor, or organization-based, for example) to generate security
permissions for the current user, for example, based on the user’s position. An
alternative to user-based security is a security profile with defined security rules, for
example, to specify that the top-level position for a position-based security profile is
Position A, irrespective of the current user’s position.

View

An example of an interface that you can use to download data from the Oracle HRMS
application to a spreadsheet using Web ADI.

Viewer (SSHR)

A person with view only access to an appraisal. An appraising manager or an employee
in a 360 Degree Self appraisal can appoint view only access to an appraisal.

Viewer (Web ADI)

A desktop application, such as a spreadsheet or word processing tool, that you use to
view the data downloaded from Oracle HRMS via Web ADI.

Voluntary

Term used in turnover to describe employees who have ceased employment with the
enterprise of their own accord, for example, by resigning.

Waiting Days

In the UK, statutory Sick Pay is not payable for the first three qualifying days in period
of incapacity for work (PIW), which are called waiting days. They are not necessarily the
same as the first three days of sickness, as waiting days can be carried forward from a
previous PIW if the linking interval between the two PIWs is less than 56 days.

WCB Account Number

In Canada, this is the account number of the provincially administered Worker’s
Compensation Board that the employer would use to make remittances. There would be
a unique number for each of the provincially controlled boards i.e. Workplace Safety
& Insurance Board of Ontario, CSST, etc.

Work Choices

Also known as Work Preferences, Deployment Factors, or Work Factors. These can affect
a person’s capacity to be deployed within an enterprise, such willingness to travel or
relocate. You can hold work choices at both job and position level, or at person level.

Worker

An employee or a contingent worker.
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Worker’s Compensation Board

In Canada, this is a provincially governed legislative body which provides benefits
to employees upon injury, disability, or death while performing the duties of the
employer. Worker’s Compensation Board premiums are paid entirely by the employer.

Workflow

An Oracle application which uses charts to manage approval processes and in addition is
used in SSHR to configure display values of sections within a web page and instructions.

Workforce Measurement Type (WMT)

Groups of different units combined to measure the workforce. The most common units
are headcount and full time equivalent.

Workforce Measurement Value (WMV)

A WMT value, for example, headcount or FTE.

Work Structures

The fundamental definitions of organizations, jobs, positions, grades, payrolls and other
employee groups within your enterprise that provide the framework for defining the
work assignments of your employees.
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Information Type Security window, 3-29, 3-31
Inquiry windows

list of, 4-25
integrators, 2-4

creating, 2-10, 2-25
for data upload, 2-7
for Web ADI, 2-5

interfaces
used by Web ADI, 2-6

internal organizations, 1-26
International HRMS, 3-330

balance dimensions, 3-331
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balances, 3-331
defining a localization, 3-331
element classifications, 3-331
routes, 3-331

International HRMS Setup process, 3-330, 3-331,
3-332
item properties, 3-282
item types

HR Task Flow, 3-256

J
job key flexfield, 3-20

K
key flexfields, 3-1, 3-5

Bank Details, 3-20
competence, 3-7
cost allocation, 3-8
cost allocation, lookup types, 3-82
creating database items, 3-20
developer, 3-17
grade, 3-7
grade, lookup types, 3-82
job, 3-6
job, lookup types, 3-81
job, setting up, 3-20
people group, 3-8
people, lookup types, 3-82
personal analysis, 3-8
personal analysis, lookup types, 3-82
position, 3-7
position, lookup type, 3-80
position, setting up, 3-21
setting up, 3-6
Soft Coded Legislation, 3-20
uses of, 3-6

knowledge integration
See Info Online

L
layouts, 2-6

creating, 2-13, 2-28
linking to template letters, 2-25

Legal Authority Codes
adding a 900 LAC, 5-13
associating to NOACs, 5-13
defining and maintaining, 5-13
insertion data, 5-11
maintaining , 5-12

legislation rules, 3-331
legislation-specific task flows, 3-251
legislations

See localizations
letter generation, 2-1

ADE and concurrent processing compared,
2-31
confirmation letters, OTA SQL*Plus script, 2-38
linking a report with a letter, 2-45
PERWPOUK template, 2-33
PERWPWUK template, 2-36
requesting letters, 2-46
skeleton letters, 2-43
standard letter overview, 2-2
using Oracle Reports, 2-31
using SQL*Plus script, 2-41
using Web ADI, 2-8
using word processors, 2-31
writing and registering a report, 2-45

letters
mail merge, 2-44

localizations, 3-149, 3-330
creating, 3-330
defining, 3-331

Location Address descriptive flexfield, 3-15, 3-22
lookup codes, 3-116
lookup types, 3-117
lookup values

removing, 3-148
Lookup Values window, 3-29
Lookups

user extensible, 3-140
lookups, 3-2

defining new lookup types, 3-147
defining new lookup values, 3-147
extensible, 3-117
for security groups

removing, 3-148
removing lookup values, 3-148
user, 3-117
user and extensible types

list, 3-117
user types and statuses, 3-150
User Types and Statuses window, 3-149
user-defined

removing, 3-148

M
mail merge, 2-2, 2-44

using Web ADI, 2-4, 2-8, 2-22
mappings

arguments for Authoria integration, 3-248
between Oracle HRMS and Authoria, 3-248
between Web ADI and Oracle HRMS, 2-6
defining, 2-22

mass actions
defining a context, 1-23

menu functions
See functions

menu options
for Web ADI, 2-8

menu structures, 1-4
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configuring, 1-97
default, 1-98

Menu Structures report, 1-99
menus, 1-97, 1-100

and EITs, 3-25
defining, 1-97, 1-100
defining functions, 1-101
for security, 1-97
query-only access, 1-88
structures, 1-4
structuring, 1-99

Menus window, 1-99, 1-100
message tokens, 3-277

creating, 3-278
messages

in templates, 3-277
predefined, 3-277
tokens, 3-277

MetaLink
links from HRMS, 3-241

models
See security model

Multiform functionality, 1-100
multiple business groups, 1-6
multiple security groups, 1-9
multiple windows, 1-99, 1-100

disabling, 1-100

N
national address styles, 3-22
Nature of Action Codes, 5-3

deleting a 900 code, 5-13
assigning to a Nature of Action family, 5-3
associating Legal Authority Codes, 5-13
associating Remarks, 5-9
insertion data, 5-11
Legal Authority Code descriptions, 5-11
Remark descriptions, 5-11

Nature of Action Codes and Remarks
deleting Remarks, 5-10

Nature of Action Codes and Remarks
adding Remarks, 5-10

Nature of Action families, 5-3, 5-6
associating NOACs to, 5-3
associating Process Methods, 5-6

NOA
See Nature of Action

NOAC
See Nature of Action Codes

NOAC families
list of, 3-88

nodes
See task flow nodes

notification
See workflow

notifications
querying from workflow worklist, 6-8

workflow, 6-1

O
online help

for templates, 3-276, 3-279
Oracle HRMS

business requirements, 3-3
configuring, 3-1
extending, 3-1
using with spreadsheets, 4-3

Oracle HRMS Alerts, 3-151
See alerts

ORACLE IDs, 1-22
Oracle Workflow

See workflow
Oracle Workflow Designer, 3-256
organization classifications

Extra Information Types, 3-29
Organization hierarchies

in security profiles, 1-37
organization hierarchies

and assignment-level security, 1-32
and user-based security, 1-37
in security profiles, 1-26
types, 1-49

Organization Hierarchy
collecting, 4-22

organization hierarchy types, 1-49
organizations

classifications, 3-29
hierarchy, 1-26
internal, 1-26

OTA
SQL*Plus script, 2-38

P
parameters, 1-101
payroll

in security profiles, 1-26, 1-42
People Management Configurator, 3-2, 3-266,
3-275, 3-278, 3-311, 3-313, 3-313, 3-315, 3-316,
3-318, 3-320

adding windows to menus or task flows, 3-320
Advanced Find tab, 3-273
CustomForm, 3-326
Data Organizer, 3-270
Find folder, 3-272
Find tab, 3-272
previewing windows, 3-314
tabs, 3-268
task flows, 3-267
user interface, 3-268
windows, 3-268

People Management templates, 3-2, 3-266
See templates
predefined, 3-271
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People Management window, 3-267, 3-268, 3-313
fields, 3-285

period conditions for alerts, 3-151
PERSLM, 1-15, 1-47
Person Name Format function, 3-333
person-based supervisor hierarchies, 1-26
Personal Address Information descriptive
flexfield, 3-15, 3-22
Personal Profile Values window, 1-50
Personnel Office Identifier

defining, 5-6
PERWPOUK

SQL*Plus script, 2-33
PERWPWUK

SQL*Plus script, 2-36
plans

regulations, 7-10
regulatory bodies, 7-10

POI
See Personnel Office Identifier

position hierarchies, 1-25
and assignment-level security, 1-34
in security profiles, 1-26, 1-38

position hiring statuses, 3-149
position key flexfield, 3-21
positions, 1-26
Predefined user tables, 3-113
print styles, 3-329
printer drivers, 3-329
printer types, 3-329
printers

drivers, 3-329
print styles, 3-329
setting up, 3-329
types, 3-329

Process Diagrammer, 3-263, 3-263, 3-264
Process Log

overview, 5-5
US Federal, 5-5
using the US Federal, 5-8

Process Methods
associating to NOA families, 5-6
maintaining, 5-4
overriding, 5-5

processes
Register Extra Information Types (EITs), 3-26
AuditTrail Update Datetracked Tables, 1-108
AuditTrail Update Tables, 1-107, 1-108
BEE Rollback, 7-35
Create Batches, 7-30
Create Descriptive Flexfield DB Items, 3-21
Create Key Flexfield DB Items, 3-20
Download HRMS Taskflows, 3-264
Enable Multiple Security Groups, 1-15
Forms Configurator - Download Template,
3-313
Generate Secure User, 1-15
Grant Permissions to Roles, 1-15

International HRMS Setup, 3-330, 3-332
International HRMS Setup process, 3-331
Register Extra Information Types (EITs) , 3-32
security, 1-4, 1-99
Security List Maintenance, 1-15, 1-27
Update Datetracked Tables, 1-107
Upload HRMS Taskflows, 3-265

Productivity data
setting up event codes, 5-7

profile options, 1-19, 1-22
AuditTrail:Activate, 1-107
complete listing, 1-50
Flexfields:Open Descr Window profile option,
3-9
HR: Authoria Integration Enabled, 3-247
HR: Authoria UK URL, 3-247
HR: Authoria US URL , 3-247
HR: Cross Business Group, 1-6
HR: Extension Agent, 3-242, 3-247
HR: Extension Agent Enabled, 3-242, 3-247
HR: Info Online: Open in New Window, 3-242,
3-247
HR: Info Online: Toolbar Icon, 3-242, 3-247
HR: Information Provider Integration Enabled,
3-242
HR: Supervisor Hierarchy Usage, 1-37
HR:Business Group, 1-29
HR:Cross Business Group, 1-40
HR:Security Profile, 1-25
HR:Supervisor Hierarchy Usage, 1-26
HR:User Type, 1-97
HRMS Profile Options report, 1-22
individual assignments, 1-41
organization hierarchies, 1-42
organization hierarchy type, 1-49
person types, 1-41
server hierarchy type, 1-49

profiles
security, 1-5
user, 1-5, 1-49

See also profile options
protected flexfields, 3-2

Q
Query-Only mode, 1-101
QuickCodes

access levels, 3-116
QuickPaint Report window

configuring, 4-3
QuickPaint reports, 4-3

configuring, 4-3
defining, 4-30
running, 4-31

R
records
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access to, 1-25
Register Descriptive Flexfield window, 3-28
Register Extra Information Types (EITs) process,
3-32
regulations

and benefit plans, 7-10
regulatory bodies

defining for benefit plans, 7-10
Remarks

adding and deleting, 5-9, 5-10
associating to a Nature of Action Code, 5-9
insertion data, 5-11
Nature of Action Codes and Remarks, 5-9
Remark Codes and Descriptions, 5-10

reporting access, 1-4
reporting groups

defining, 7-9
for benefits, 7-3
for Compensation Workbench, 7-9
overview, 7-3

reporting users, 1-14
setting up, 1-22

Reports
defining, 4-30
list of, 4-26

reports
Audit Report, 1-108
AuditTrail Update Tables, 1-108
Custom Report function, 4-32
defining, 4-2
Discoverer workbooks, 4-1
Menu Structure, 1-99
QuickPaint, 4-30
security, 1-99
types of, 4-1

Request for Personnel Action
Nature of Action Codes, 5-3
Nature of Action families, 5-3
responding to from worklist, 6-9
reviewing the workflow routing history, 6-8

request groups, 1-4, 1-97, 1-99
Request Groups window, 4-22
responsibilities, 1-4, 1-96, 1-97

and Extra Information types, 1-97
and security profiles, 1-96
and users, 1-6
defining, 1-17, 1-19
definition, 6-3
Extra Information types, 3-31
information type security, 3-29
security, 3-31

Responsibility window, 1-17
Restricting access to records

by organization hierarchy, 1-37
restrictions

defining, 3-327
RIA

links from HRMS, 3-241

roles, 1-96
definition, 6-3

routes, 3-331
routing

see workflow, 6-5
workflow history, 6-4

Routing Group
definition, 6-3
setting up, 6-5

Routing history
definition, 6-4

Routing List
definition, 6-3

Rows windows, 3-114
Run QuickPaint Report window, 4-31

S
Scale Rate window, 1-102
Security

business requirements, 1-2
security

access to records, 1-25
assigning users, 1-6
assignment-level, 1-27, 1-29
AuditTrail, 1-107
concepts, 1-4
creating Oracle IDs, 1-22
custom, 1-27
CustomForm, 3-25, 3-29
Discoverer business areas, 4-19
Discoverer workbooks, 4-19
Extra Information Types, 3-25
extra information types, 1-97
Find Security Profile Assignment window, 1-46
functions, 1-97
global security profiles, 1-29
groups, 1-4
HRMS Standard security, 1-25
information types, 3-29
information types , 3-31
menu structures, 1-4
menus, 1-97, 1-99
models, 1-4
multiple business groups, 1-6
multiple security groups, 1-9
organization hierarchies, 1-26
overview, 1-1
payroll, 1-26
position hierarchies, 1-26
processes, 1-4, 1-15
profiles, 1-5, 1-25
reporting access, 1-4
reports and processes, 1-99
request groups, 1-4, 1-97
responsibilities, 1-4, 1-96
Security Groups Enabled, 1-5, 1-10, 1-45, 1-96,
3-148
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Security Groups Enabled security, 1-25
standard, 1-5
static lists, 1-28
supervisor, 1-26
task flows, 1-1, 3-25, 3-29
user profiles, 1-5, 1-49
user-based, 1-28

Security groups, 1-11
security groups, 1-4

multiple, 1-9
Security Groups Enabled security, 1-5, 1-10, 1-25,
1-45, 1-96, 3-148

setting up, 1-18
Security List Maintenance process, 1-15, 1-15, 1-27
security models, 1-4, 1-5
Security processes

Security List Maintenance (PERSLM), 1-47
security processes, 1-4

Enable Multiple Security Groups, 1-15
Generate Secure User, 1-15
Grant Permissions To Roles, 1-16
Security List Maintenance (PERSLM), 1-15

Security Profile window, 1-40
security profiles, 1-5, 1-25

and position hierarchies, 1-38
and responsibilities, 1-96
and users, 1-6
assigning, 1-45
assignment-level security, 1-27
custom security, 1-44
defining, 1-40
ending assignments, 1-46
excluding users, 1-43
global, 1-29
granted access, 1-41
organization hierarchies, 1-26
payroll, 1-26, 1-42
position hierarchies, 1-26
static lists, 1-28
supervisor, 1-26, 1-35
supervisor hierarchies, 1-43
user-based, 1-28
view all, 1-25

segments, 3-22
context-sensitive, 3-9
descriptive flexfield, 3-9
global, 3-9
value sets, 3-274

Self-Service Human Resources
See SSHR

sequential task flows, 3-250
server hierarchies

types, 1-49
server hierarchy types, 1-49
skeleton letters

template letters, 2-6
Soft Coded Legislation key flexfield, 3-20
Special Information Types, 3-25

in templates, 3-274
spreadsheets

creating using Web ADI, 2-15
downloading data using Web ADI, 2-6
uploading data using Web ADI, 2-7, 2-17
using Web ADI, 2-15
using with ADE, 4-3

SQL*Plus script
OTA - for confirmation letters, 2-38
PERWPOUK, 2-33
PERWPWUK, 2-36

SSHR, 1-25
Standard Benefits

links to Authoria, 3-247
standard letters, 2-2
standard security, 1-5

setting up, 1-16
static lists, 1-28
styles

converting ADE styles to Web ADI, 2-14
Submit Request window, 3-264
supervisor hierarchies, 1-25, 1-26, 1-35

and assignment-level security, 1-29
and user-based security, 1-43
assignment-based, 1-27
in security profiles, 1-26, 1-43
person-based, 1-26

supervisors, 1-26
system administration

enabling currencies, 3-332
printers, 3-329

system extract
batch process, 7-20
change event log, 7-8
change log, 7-18
copy process, 7-9
copying, 7-22
criteria, 7-7
data elements, 7-4
defining, 7-17
defining criteria, 7-11
defining the layout, 7-12
extract batch processes, 7-8
extract record hierarchy, 7-6
extract results, 7-8
extract write process, 7-8
file layout, 7-6
formatting for data elements, 7-5
layout, 7-4
overview, 7-3
purging an extract, 7-21
record layout, 7-5
restarting an extract, 7-20
sorting data elements, 7-6
viewing results, 7-18
XML, 7-9

System Profile Values window, 1-17, 1-49
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T
tab page properties, 3-281
Table Structure window, 3-113
Table Values window, 3-114
tables

entering values, 3-114
setting up, 3-113
user-defined, 3-2

Tables, user-defined, 3-113
accessing values in, 3-113

tabs
designing, 3-268

task flow nodes, 3-260
defining, 3-257

task flow processes
sub processes, 3-261
top level processes, 3-260

Task flows
creating using Oracle Workflow, 3-260

task flows, 3-2, 3-25, 3-250
adding to a menu, 1-101
adding windows, 3-259
amending navigation, 3-259
and workflow, 3-255, 3-260
blocks, 3-263
branched, 3-250
button labels, 3-262
buttons, 3-263
contexts, 3-256
copying, 3-259
creating

using forms, 3-256
creating a sub process, 3-261
creating a top level process, 3-260
creating using forms, 3-256
custom windows, 3-328
defining, 3-257
defining nodes, 3-257
displaying blocks, 3-263
displaying windows, 3-263
Download HRMS Taskflows process, 3-264
importing, 3-265
legislation-specific, 3-251
navigation, 3-259
nodes, 3-260
People Management Configurator, 3-267
predefined, 3-251
rules, 3-256
sequential, 3-250
structure, 3-250
top level processes, 3-260
transferring between databases, 3-251, 3-264
Upload HRMS Taskflows process, 3-265
using configured forms, 3-264
using forms, 3-250
using windows, 3-252
using workflow, 3-250

verifying and saving, 3-264
windows, 3-263
workflow

generating, 3-259
WORKFLOW_NAME parameter, 1-101

template fields
default values, 3-270

template letters, 2-6
linking to Web ADI layouts, 2-25
managing using Web ADI, 2-24

TEMPLATE_FTE formula, 4-16
TEMPLATE_HEAD formula, 4-16
templates, 3-266, 3-311

adding fields, 3-315
adding flexfields, 3-316
adding window to menu or task flow, 3-320
and windows, 3-266
benefits of, 3-270
canvas properties, 3-280
configuring, 3-266
context-sensitive fields, 3-275, 3-318
copying, 3-312
custom fields, 3-267
Datetrack History, 3-319
defining checklists, 3-317
designing, 3-268
editing, 3-313
Enter Contingent Workers, 3-272
Enter Employees, 3-271
Extra Information Types, 3-274
field information, 3-320
flexfields, 3-274
Hiring Applicants, 3-271
HR Foundation, 3-272
importing, 3-313
item properties, 3-282
Maintain Contingent Workers, 3-272
Maintain Employees, 3-272
notification messages, 3-277
online help, 3-279
online help targets, 3-276
opening, 3-312
options, 3-278
People Management, 3-2, 3-268
People Management window, 3-285
PERWPOUK, 2-33
PERWPWUK, 2-36
predefined, 3-266
process-based windows, 3-269
properties, 3-279
removing fields, 3-315
setting field defaults, 3-318
Special Information Types, 3-274
tab page properties, 3-281
Visa Administration, 3-272
window properties, 3-280

text files
for data upload using Web ADI
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format, 2-7
uploading data from

using Web ADI, 2-18
third-party information providers

links from HRMS, 3-241
Top Node window, 3-261
training hours

amending, 4-17
training time periods

adding, 4-17
transaction types

in audit reports, 1-104
Transcentive

links from HRMS, 3-241
Transfer Alert Definition window, 3-162

U
upload data

using Web ADI
from legacy systems, 2-18

Upload HRMS Taskflows process, 3-265
upload template letters

for use with Web ADI, 2-24
user lookups, 3-117
user profiles, 1-5

See profile options
levels, 1-49
overview, 1-49

See also profile options
user statuses

creating, 3-150
User tables, 3-113

US Federal predefined, 3-113
work schedules, 3-113

user types
creating, 3-150

User Types and Statuses window, 3-149, 3-150
applications of, 3-149

user-based security, 1-28
and organization hierarchies, 1-37
and supervisor hierarchies, 1-43
custom, 1-27

user-definable descriptive flexfields, 3-5, 3-8, 3-10
user-defined tables, 3-2
users

and business groups, 1-6
and responsibilities, 1-6
and security profiles, 1-6
creating, 1-17, 1-19

Users window, 1-17

V
validation

BEE, 7-29
viewers

used by Web ADI, 2-6

Views
list of, 4-25

views
Web ADI usage, 2-6, 2-10

W
Web ADE styles

converting, 2-28
Web ADI, 2-1, 2-4

business purpose, 2-2
configuring, 2-25
content, 2-5
creating integrators, 2-25
creating mail merge letters, 2-22
defining layouts, 2-28
defining mappings, 2-22
documents, 2-15
downloading data, 2-5, 2-15
exporting data, 2-4
importing data, 2-4
integrators, 2-5, 2-28
interfaces, 2-6
layouts, 2-6
linking template letters and layouts, 2-25
managing template letters, 2-24
setting up, 2-8
spreadsheets, 2-15
upgrading from ADE, 2-13
uploading data, 2-6

Web ADI integrators, 2-25
Web ADI layouts, 2-28
Windows

customizing, 3-322
Submit Requests, 4-26
View Requests, 4-26

windows
adding to menu, 3-320
adding to task flows, 3-259
adding to template, 3-320
Alerts, 3-162
and templates, 3-266
Application Utilities Lookups, 3-146, 3-148
Assign Security Profile, 1-45
Assignment, 3-255
Audit Groups, 1-108
Batch Assignment Entry, 7-32
Batch Header, 7-28
Batch Lines, 7-31
Batch Summary, 7-34, 7-35
Change Event Log, 7-18
Columns, 3-114
configuring, 3-250, 3-326

with CustomForm, 3-327
context, 3-250
Contexts, 1-23
Create Batch Lines, 7-30
custom, 3-328
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Define QuickPaint Report, 4-30
Define Task Flow, 3-29, 3-257, 3-259, 3-259,
3-259
Define Task Flow Nodes, 3-29, 3-257
defining restrictions, 3-327
Descriptive Flexfield Segments, 3-22, 3-27, 3-30
designing, 3-268
Extract Definition, 7-22
Find

configuring, 3-272
Security check box, 3-273

Find Security Profile Assignment, 1-46
for task flows, 3-252
Form Customization, 3-29, 3-327
Form Functions, 1-101, 1-101
Form Functions , 1-101
Formula, 4-17, 4-17
General Ledger Daily Rates, 4-17
Global Security Profile, 1-40
Grade Rate, 1-102
Information Type Security, 3-29, 3-31
Letter, 2-43
linking, 3-250
Lookup Values, 3-29
Menus, 1-99, 1-100
multiple, 1-99, 1-100

disabling, 1-100
People Management, 3-267, 3-268, 3-313

fields, 3-285
Personal Profile Values, 1-50
Personnel Office Identifier, 5-6
previewing, 3-314
process-based, 3-269
properties, 3-280
QuickPaint Report, 4-3
Register Descriptive Flexfield, 3-28
Request Groups, 4-22
Request Letter, 2-46
Responsibility, 1-17
Rows, 3-114
Run QuickPaint Report, 4-31
Scale Rate, 1-102
Security Profile, 1-40
Submit Request, 3-264, 4-20, 4-20
Submit Request Set, 4-22, 4-23
Submit Requests, 4-21, 4-21
System Profile Values, 1-17, 1-49
Table Structure, 3-113

Table Values, 3-114, 4-17
Top Node, 3-261
Transfer Alert Definition, 3-162
US Federal Process Log, 5-5
User Types and Statuses, 3-149, 3-150
Users, 1-17

word processors
downloading data using Web ADI, 2-6
supported makes for letter generation, 2-31

Work schedules
predefined table for, 3-113

Workflow
notification status, 6-1
terms and definitions, 6-1

workflow
adding a user to a routing list, 6-7
adding users to routing groups, 6-5
and task flows, 3-255, 3-260
attributes, 3-256
business requirements, 6-2
changing attribute, 6-10
changing item type, 6-10
copying Item Type, 6-9
generating task flows, 3-259
HR Task Flow item type, 3-256
Oracle Workflow Designer, 3-256
Process Diagrammer, 3-260, 3-263, 3-263, 3-264
querying notifications, 6-8
reassigning notification, 6-9
rerouting notification, 6-9
responding to a Request for Personnel Action,
6-9
routing history, 6-4, 6-8
setting up groupboxes, 6-5, 6-6
setting up routing groups, 6-5
setting up routing lists, 6-5, 6-7
task flows, 3-250
verifying and saving, 3-264

workflow attributes
See attributes

workforce
calculation, 4-14
predefined formulas, 4-14

workforce calculations
configure, 4-16

worklist
See workflow
definition, 6-1
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