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Preface

Intended Audience
Welcome to Release 11i of the Oracle Applications CRM System Administrator’s Guide.

This guide assumes you have a working knowledge of the following:

• The principles and customary practices of your business area.

• Oracle Applications CRM System Administrator Console.

If you have never used Oracle Applications CRM System Administrator
Console, Oracle suggests you attend training classes available through Oracle
University.

• The Oracle Applications graphical user interface

To learn more about the Oracle Applications graphical user interface, read the Oracle
Applications User’s Guide.

See Related Information Sources on page x for more Oracle Applications product
information.

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services
within the United States of America 24 hours a day, seven days a week. For TTY support,
call 800.446.2398.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation accessible,
with good usability, to the disabled community. To that end, our documentation
includes features that make information available to users of assistive technology.
This documentation is available in HTML format, and contains markup to facilitate
access by the disabled community. Accessibility standards will continue to evolve over
time, and Oracle is actively engaged with other market-leading technology vendors to
address technical obstacles so that our documentation can be accessible to all of our
customers. For more information, visit the Oracle Accessibility Program Web site at
http://www.oracle.com/accessibility/ .

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an otherwise
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empty line; however, some screen readers may not always read a line of text that consists
solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any
representations regarding the accessibility of these Web sites.

Structure
1 Implementing the Oracle CRM Technology Foundation
2 Understanding the System Administrator Console
3 Using the Security Subtab
4 Using the Site Preferences Subtab
5 Using the System Subtab
6 Using the Deployment Tab
7 Using Diagnostics
8 Using the Cache Subtab
9 Using the Declarative Page Flows Subtab
10 Using the Declarative Components Subtab
11 Using the Homepage Subtab
12 Setting Prole Options

Related Information Sources
You can choose from many sources of information, including online
documentation, training, and support services, to increase your knowledge and
understanding of Oracle Applications CRM System Administrator Console.

If this guide refers you to other Oracle Applications documentation, use only the Release
11i versions of those guides.

Online Documentation
Note that all Oracle Applications documentation is available online (HTML or PDF).

• PDF Documentation - See the Oracle Applications Documentation Library CD
for current PDF documentation for your product with each release. The Oracle
Applications Documentation Library is also available on OracleMetaLink and is
updated frequently.

• Online Help - Online help patches (HTML) are available on OracleMetaLink.

• About Documents - Refer to the About document for the mini-pack or family pack
that you have installed to learn about feature updates, installation information, and
new documentation or documentation patches that you can download. About
documents are available on OracleMetaLink.

Related Guides
You may want to refer to Oracle Applications implementation documentation when you
set up and use Oracle Applications CRM System Administrator Console. You can read
the documentation online by choosing Library from the expandable menu on your
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Oracle Applications HTML help window, by reading from the Oracle Applications
Documentation Library CD included in your media pack, or by using a Web browser
with a URL that your system administrator provides.

If you require printed guides, you can purchase them from the Oracle Store at
http://oraclestore.oracle.com.

Guides Related to All Products
Oracle Applications User’s Guide

This guide explains how to enter data, query, run reports, and navigate using the
graphical user interface (GUI) available with this release of Oracle Applications CRM
System Administration (and any other Oracle Applications products). This guide also
includes information on setting user profiles, as well as running and reviewing reports
and concurrent processes.

You can access this user’s guide online by choosing ”Getting Started with Oracle
Applications” from any Oracle Applications help file.

Documents Related to This Product
Oracle e-Commerce Gateway User’s Guide

This guide describes how Oracle e-Commerce Gateway provides a means to conduct
business with trading partners via Electronic Data Interchange (EDI). Data files are
exchanged in a standard format to minimize manual effort, speed data processing and
ensure accuracy.

Installation and System Administration
Oracle Applications Concepts

This guide provides an introduction to the concepts, features, technology
stack, architecture, and terminology for Oracle Applications Release 11i. It provides a
useful first book to read before installing Oracle Applications.

Installing Oracle Applications

This guide provides instructions for managing the installation of Oracle Applications
products. In Release 11i, much of the installation process is handled using Oracle
Rapid Install, which minimizes the time to install Oracle Applications and the Oracle
technology stack by automating many of the required steps. This guide contains
instructions for using Oracle Rapid Install and lists the tasks you need to perform
to finish your installation. You should use this guide in conjunction with individual
product user’s guides and implementation guides.

Upgrading Oracle Applications

Refer to this guide if you are upgrading your Oracle Applications Release 10.7 or
Release 11.0 products to Release 11i. This guide describes the upgrade process and
lists database and product-specific upgrade tasks. You must be either at Release 10.7
(NCA, SmartClient, or character mode) or Release 11.0 to upgrade to Release 11i. You
cannot upgrade to Release 11i directly from releases prior to 10.7.

Maintaining Oracle Applications

Use this guide to help you run the various AD utilities, such as AutoUpgrade, Auto
Patch, AD Administration, AD Controller, AD Relink, License Manager, and others. It

xi

http://oraclestore.oracle.com
http://oraclestore.oracle.com
http://oraclestore.oracle.com
http://oraclestore.oracle.com
http://oraclestore.oracle.com
http://oraclestore.oracle.com
http://oraclestore.oracle.com
http://oraclestore.oracle.com
http://oraclestore.oracle.com


contains how-to steps, screenshots, and other information that you need to run the AD
utilities. This guide also provides information on maintaining the Oracle Applications
file system and database.

Oracle Applications System Administrator’s Guide

This guide provides planning and reference information for the Oracle Applications
system administrator. It contains information on how to define security, customize
menus and online help, and manage concurrent processing.

Oracle Alert User’s Guide

This guide explains how to define periodic and event alerts to monitor the status of
your Oracle Applications data.

Other Implementation Documentation
Oracle Applications Product Update Notes

Use this guide as a reference for upgrading an installation of Oracle Applications. It
provides a history of the changes to individual Oracle Applications products between
Release 11.0 and Release 11i. It includes new features, enhancements, and changes made
to database objects, profile options, and seed data for this interval.

Multiple Reporting Currencies in Oracle Applications

If you use the Multiple Reporting Currencies feature to record transactions in more than
one currency, use this manual before implementing Oracle Applications. This manual
details additional steps and setup considerations for implementing Oracle Applications
with this feature.

Multiple Organizations in Oracle Applications

This guide describes how to set up and use Oracle Applications’ Multiple Organization
support feature, so you can define and support different organization structures when
running a single installation of Oracle Applications.

Oracle Applications Flexfields Guide

This guide provides flexfields planning, setup, and reference information for the Oracle
Applications implementation team, as well as for users responsible for the ongoing
maintenance of Oracle Applications product data. This guide also provides information
on creating custom reports on flexfields data.

Oracle Applications Developer’s Guide

This guide contains the coding standards followed by the Oracle Applications
development staff. It describes the Oracle Application Object Library components
needed to implement the Oracle Applications user interface described in the Oracle
Applications User Interface Standards for Forms-Based Products. It also provides information
to help you build your custom Oracle Forms Developer forms so that they integrate
with Oracle Applications.

Oracle Applications User Interface Standards for Forms-Based Products

This guide contains the user interface (UI) standards followed by the Oracle Applications
development staff. It describes the UI for the forms-based Oracle Applications products
and how to apply this UI to the design of an application built using Oracle Forms.

Oracle eTechnical Reference Manuals
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Each eTechnical Reference Manual (eTRM) contains database diagrams and a detailed
description of database tables, forms, reports, and programs for a specific Oracle
Applications product. This information helps you convert data from your existing
applications, integrate Oracle Applications data with non-Oracle applications, and
write custom reports for Oracle Applications products. Oracle eTRM is available on
OracleMetaLink.

Oracle Applications Message Reference Manual

This manual describes Oracle Applications messages. This manual is available in HTML
format on the documentation CD-ROM for Release 11i.

Training and Support
Training

Oracle offers a complete set of training courses to help you and your staff master Oracle
Applications CRM System Administration and reach full productivity quickly. These
courses are organized into functional learning paths, so you take only those courses
appropriate to your job or area of responsibility.

You have a choice of educational environments. You can attend courses offered by
Oracle University at any one of our many Education Centers, you can arrange for our
trainers to teach at your facility, or you can use Oracle Learning Network (OLN), Oracle
University’s online education utility. In addition, Oracle training professionals can tailor
standard courses or develop custom courses to meet your needs. For example, you
may want to use your organization’s structure, terminology, and data as examples in a
customized training session delivered at your own facility.

Support

From on-site support to central support, our team of experienced professionals
provides the help and information you need to keep Oracle Applications CRM
System Administration working for you. This team includes your Technical
Representative, Account Manager, and Oracle’s large staff of consultants and support
specialists, with expertise in your business area, managing an Oracle Database, and
your hardware and software environment.

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser,
database triggers, or any other tool to modify Oracle Applications data unless otherwise
instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and
maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus
to modify Oracle Applications data, you risk destroying the integrity of your data and
you lose the ability to audit changes to your data.

Because Oracle Applications tables are interrelated, any change you make using an
Oracle Applications form can update many tables at once. But when you modify Oracle
Applications data using anything other than Oracle Applications, you may change a row
in one table without making corresponding changes in related tables. If your tables get
out of synchronization with each other, you risk retrieving erroneous information and
you risk unpredictable results throughout Oracle Applications.
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When you use Oracle Applications to modify your data, Oracle Applications
automatically checks that your changes are valid. Oracle Applications also keeps track of
who changes information. If you enter information into database tables using database
tools, you may store invalid information. You also lose the ability to track who has
changed your information because SQL*Plus and other database tools do not keep a
record of changes.
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Implementing the Oracle CRM Technology

Foundation

Implementing the Oracle CRM Technology Foundation

Introduction
The Oracle CRM Technology Foundation (JTT) provides Java-based
infrastructure software that is used to develop e-business solutions such as
Sales, Marketing, Service, e-Commerce, Contracts, and Interaction Center applications. It
offers a common platform for developing applications with HTML and Java. It also
provides user-friendly screens for centralized setup and administration. This web-based
interface is called the System Administrator Console.

This chapter describes how to successfully implement the Oracle CRM Technology
Foundation. The rest of this manual describes how to work successfully with the System
Administrator Console.

Implementation Summary
The implementation process for the Oracle CRM Technology Foundation includes the
following tasks:

• Running Diagnostics on "HTML Platform" and "CRM Foundation"

• Changing the System Administrator Password

• (Optional) Configuring System Settings

• (Optional) Configuring Display Preferences

• (Optional) Implementing Custom Style Sheets

• (Optional) Setting Branding Size

Running Diagnostics on "HTML Platform" and "CRM Foundation"
Oracle ships important diagnostic tests under the application names "HTML
Platform" and "CRM Foundation." Navigate to the Oracle Diagnostics user interface
and run all test groups for these two applications. For more information on Oracle
Diagnostics, see: Using Diagnostics, page 7-1.
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Changing the System Administrator Password
Upon shipment, the system administrator identity has "sysadmin" as both its user name
and its password. We strongly recommend that you change the password immediately
after installation is completed. For information on how to change passwords, please
see: Changing Your Password, page 12-2.

Conguring System Settings
For information on how to define system-level properties such as sessions, cookies, and
logging, please refer to

Conguring Display Preferences
For information on how to set up display preferences such as language, currency, and
time zone, please see Setting Display Preferences, page 12-1.

Implementing Custom Style Sheets
This is an optional procedure.

Style Sheet Prole Option
After a user logs in, the style sheet used for the UI is determined by the value
of the profile JTF_PROFILE_DEFAULT_CSS. This profile can have values at site
level, responsibility level or user level. The site level value is set to jtfucss.css by
default. A system administrator can set values based on site, responsibilities, or users.

Users and Style Sheets
If enabled, users can select a style sheet from the user profile page. Users reach
this page by navigating from the Profile link to Display Preferences > Display
Style. The style sheet that a user chooses is saved as a user-level value of the profile
JTF_PROFILE_DEFAULT_CSS. If a value is set at the user level, that overrides the
responsibility or site level value.

To create a list of available style sheets on the user profile page, the system
administrator creates a type of Application Object Library Lookups named
JTF_STYLE_SHEET_LOOKUP_TYPE through Oracle JInitiator. The User Name of the
type can be any name meaningful to the system administrator, but the type must exactly
be JTF_STYLE_SHEET_LOOKUP_TYPE. The application this type belongs to is usually
CRM Foundation. This look-up type may have multiple codes.

Each code of this type represents a style sheet. The meaning of the code is displayed
in the drop-down list on the user profile page. For example, say a code named
mystyle.css has the meaningMy Personal Style as its meaning, and another code named
teamstyle.css has the meaning Team Style. In this case, users will seeMy Personal Style
and Team Style in theDisplay Style drop-down list. If a certain user selects the styleMy
Personal Style, then from that point on the stylesheetmystyle.css is used.

Note that setting profile values or lookup data requires you to stop and restart the Java
server for changes to take effect. In contrast, making a style sheet choice on the user
profile page takes effect immediately.
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Setting the Branding Size
Branding refers to the images that appear at the top of Web-based application
pages. Branding includes elements such as a corporate logo, an application name, or a
product collage image.

There are three size options for branding: small, medium or regular.

The system profile FND: Branding Size controls branding size. This profile can only be
set at site level, and the default value is Small. You can use Oracle JInitiator to change
the value. Note that the setting takes effect only after you refresh the profile cache or
stop and restart the Java server.

If your installation uses customized style sheets, then you need to create additional
style sheets to support the different branding sizes. When naming style sheets, please
follow a standard naming convention. For example, if the regular size style sheet is
stylesheet.css, then create a style sheet named stylesheet_med.css to support medium
size branding.

Between different style sheets, there can be the following size variations:

• The style applicationBody can contain a different size background image.

• Some styles such as navL0TextDeslct and navL0TextSlct can contain different size
fonts.

The default style sheet for medium size branding is jtfucss_med.css. If your system
uses a customized style sheet and the corresponding medium size style sheet does not
exist, then jtfucss_med.css is used in its place. In this case, you can either make a copy of
jtfucss_med.css and customize it, or you can modify your own style sheet to include the
size differences mentioned above. Please note that the standard medium size branding
background image is jtfulnon_med.gif.

Questions and Answers about Branding
Below are some frequently asked questions about branding:

What is the relationship between FND: Branding Size and JTF_PROFILE_DEFAULT_CSS?
There is no direct connection between FND: Branding Size and JTF_PROFILE_
DEFAULT_CSS. FND: Branding Size specifies the size of the branding, while
JTF_PROFILE_DEFAULT_CSS stores a style sheet name.

If JTF_PROFILE_DEFAULT_CSS contains a value x.css, then changing the value of
FND: Branding Sizemight require the presence of x_med.css in the system.

As a developer or customer, what can I do with the branding area?
Besides changing its size by setting the profile, you can change the text:

The Branding screen in the CRM System Administrator Console allows you to set
different text for different responsibilities or applications. The default text is "Oracle
Applications".

As a customer, do I have to do something to support changing branding size?
Only if you want to support customized style sheets. The style sheets can be customized
at different levels, but they are not necessarily for branding. If a site is set at a
different branding size, then you might consider customizing the style sheets. For
example, medium size branding has no global button icons . You can’t make the icons
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appear with a customized style sheet. However, you could replace the the product logo
background, which is defined in the style sheet.
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2
Understanding the System Administrator

Console

System Administrator Console Overview
The System Administrator Console is a Web-based user interface that is
associated with the system administrator responsibility. It is used during the
development, implementation, and maintenance phases of an application or
deployment. During the development phase, developers and consultants use the
System Administrator Console to seed out-of-the-box capabilities and features. These
include, but are not limited to, users, permissions, roles, session parameters, page
flows, and diagnostic tests. During the implementation phase, consultants or
implementation engineers use the System Administrator Console to configure
out-of-the-box capabilities and features to meet the particular needs of each customer
deployment. During the maintenance phase, IT professionals use the System
Administrator Console to troubleshoot deployment problems, tune deployment
performance, and monitor system activity.

Features are divided into the following areas for the System Administrator Console:

• Security

• Site Preferences

• System

• Deployment

• Cache

• Declarative Page Flows

• Declarative Components

• Homepage

• Profile Options

Understanding Security
In the Security subtab, which is located under the Settings tab, you can control access
to application resources and view security-related alerts.

This section offers an introduction to Security Framework concepts. For step-by-step
instructions on how to use the Security screens, please see the topic Managing Security,
page 3-1.
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Terminology
The following table explains important Security concepts.

Security Terms

Term Denition

Permission A permission is a unit of privilege that is
granted to a user. It usually serves to grant a
certain type of access to a resource. Resources
are application elements such as JSP
pages, objects, or methods of objects. A
resource can have unique permissions for each
way that it can be accessed. A permission
is implemented as a string. If a resource
is protected by a permission, then any user
accessing the resourcemust have the permission
required to access it. Permission names are
case-sensitive. Permissions cannot be directly
assigned to users. Instead, permissions are
grouped into roles and roles are then assigned
to users. In the Security subtab, you can
view, create, and delete permissions. You can
also specify which permissions are mapped to
each role, and vice versa.

Roles A role is a group of permissions which can
be assigned to a user. Like permissions, roles
are implemented as strings. Role names are
not case-sensitive. For example, let’s suppose
there is a JSP page "abc.jsp" that requires the
permission "PERM_ABC." A user logs in and
tries to access abc.jsp, but he or she can’t do that
unless he or she has permission "PERM_ABC."
You want the user to be able to access the
page, so you assign the role "ROLE_ABC"
(which contains permission "PERM_ABC")
to the user. When given the appropriate
role, the user is able to access the page. In
the Security subtab, you can view, create, and
delete roles. You can also specify which roles
are mapped to each permission, and vice versa.

Understanding the Interapplication Bar
In the Site Preferences subtab, which is located under the Settings tab, you can set up
the Interapplication Bar.

This section offers an introduction to Interapplication Bar concepts. For step-by-step
instructions on how to use the Interapplication Bar screens, please see the topic Setting
Up the Interapplication Bar, page 4-1.

Terminology
The following table explains important Interapplication Bar concepts.
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Interapplication Bar Terms

Term Denition

Interapplication Bar The Interapplication Bar (also sometimes
referred to as the Application Switcher)
allows end users to seamlessly switch between
applications within the E-Business Suite. It
is a set of customizable links that displays
at the top of every page in HTML-based
CRM applications. Each customizable link is
called a "navigation group." For example, a
system administrator might want to create
a navigation group called "Sales." In the
System Administrator Console, he or she can
map sales-related applications such as Sales
Online, TeleSales, and Sales Compensation
to the navigation group called "Sales."
(Similarly, he or she could create a navigation
group called "Marketing" and map applications
such as Marketing Online, iMarketing, and
Campaign Management to it.) When an end
user logs in who has responsibilities for sales
applications, the end user will see "Sales" as a
link in the Interapplication Bar. In the Profile
screens, the end user can configure which
responsibility he or she wants to associate
with the "Sales" navigation group. From
then on, when the end user is working in the
E-Business Suite, he or she can click the "Sales"
link at any time to easily switch to his or her
sales responsibility

Navigation Group A navigation group is a customizable group
of applications with defined responsibility
settings. Each navigation group is represented
as a link within the Interapplication Bar. In
the Site Preferences subtab, you (as the system
administrator) can map CRM applications
into navigation groups. Additionally, from
the navigation group setup screen, you
can create, delete, activate, deactivate, and
specify the display order of navigation
groups. After you have set up navigation
groups for a deployment, based on their
granted responsibilities, end users will be able
to associate each navigation group with one of
their responsibilities.

Understanding Diagnostics
When you click the Diagnostics tab of the System Administrator Console, you
launch the Web-based interface of Oracle Diagnostics for Applications. These
Diagnostics screens are intended to help you identify and resolve problems related
to environment, postinstallation setup, customization, or any other functions. In
addition, Oracle Diagnostics generates reports which can be sent to Oracle Support for
further analysis and troubleshooting, if needed. Note that you must be logged in as a
system administrator (with the permission "JTF_DIAGNOSTICS_ADMIN") in order to
view any configuration-related Diagnostics screens.
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In the Diagnostics screens, you perform tasks such as registering tests, executing
tests, managing test groups, setting default test input values, registering applications
with Oracle Diagnostics, and viewing log records.

This section explains important Oracle Diagnostics concepts. For step-by-step
instructions on how to use the Diagnostics screens, please see Using Diagnostics, page
7-1.

Terminology
The following table explains important Oracle Diagnostics for Applications concepts.

Diagnostics Terms

Term Denition

Test A test, written in Java or PL/SQL, checks
the correct behavior of a particular feature
or function. In the Diagnostics screens, you
can run, register, delete, and set default input
values for tests.

Test Group A test group is a set of related tests. A test
group may have other test groups defined as
prerequisites. In the Diagnostics screens, you
can run, create, modify, and remove test groups.

Advanced Mode When running tests in advanced mode, you can
supply specific input values for a diagnostic
test. In the Diagnostics screens, you can run
tests in either Advanced Mode or Basic Mode.

Basic Mode When running tests in basic mode, you do
not supply any input values before the text
executes. This is because the test either requires
no input values or has a preconfigured set of
input values. In the Diagnostics screens, you
can run tests in either Advanced Mode or Basic
Mode.

Prerequisite Prerequisites are a concept that applies to
both applications and test groups. Setting
prerequisites is sometimes necessary
for procedures to execute correctly. For
example, the DBConnections test group has
the Environment Setup test group set as
its prerequisite, because the Environment
Setup test group contains the DBC Parameter
test which checks the DBC file. If the DBC
Parameter test fails, the no tests in the
DBConnections test group will be successful. In
addition, the CRM Foundation application
has the HTML Platform application set
as its prerequisite. If some tests for CRM
Foundation fail, it is likely due to an error
in the HTML Platform. Therefore you can
run the HTML Platform tests to trace the
problem. In the Diagnostics screens, you can
define prerequisites for applications as well as
test groups.
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Term Denition

Diagnostic Role To secure diagnostic tests which may
deal with sensitive information, you can
associate user responsibilities with Diagnostic
Roles. Currently the Diagnostic Roles available
are Super User, Application Super User, and
End User. In order to have unrestricted access
to all Diagnostic features such as configuration
and viewing test details, a user must have
the Super User Diagnostic Role. For more
details, see the section "Diagnostic Security"
below.

Test Sensitivity For security reasons, diagnostic tests are
shipped with a test sensitivity of low, medium,
or high. Diagnostic Roles (see above) can be
configured to allow only certain users to execute
tests, based on the test’s sensitivity. For more
details, see the section "Diagnostic Security"
below.

Diagnostic Security
As diagnostics tests can report on sensitive aspects of an application, such as
finance-related modules, it is necessary to limit access to sensitive data to only the users
who have been explicitly authorized. In order to address this, test developers can now
assign their tests a sensitivity rating of low, medium, or high. Furthermore, Diagnostic
Roles are provided to define which operations different types of users can perform
within Oracle Diagnostics.

The Diagnostic Roles are defined as follows:

Diagnostics Super User
Has unrestricted and global privileges for all Diagnostics operations. A user with this
role can execute, configure, view reports, and set up security for all test groups and all
applications. Prior to shipment, this role has been granted to the CRM Foundation
application responsibility CRM HTML Administration, which has been assigned to the
user sysadmin. If you are performing security setup or other configuration tasks, you
must log on as a user who has the CRM HTML Administration responsibility.

Application Super User
For the application associated with this user’s responsibility, he or she can
execute, configure, view reports, and set up security for the test groups in his or her own
application. Additionally, the user can execute tests and configure test inputs for test
groups of other applications which are of low or medium sensitivity.

End User
The only operations this user can perform are executing and configuring inputs for for
low-sensitivity test groups. He or she cannot view detailed test reports.

Anonymous User
This role is not explicitly defined, but in the case that none of a user’s responsibilities
have an association with any of the above Diagnostic Roles, then the user is considered
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an anonymous user. Such users can only access the pseudo-application HTML
Platform. They cannot work with the test groups of any other applications.

Note: Through the Diagnostics screens, you can explicitly grant any
responsibility the ability to access a particular test group. In such
cases, the user can then execute and configure inputs for tests belonging
to that test group, as well as view detailed reports.

The following table lists the different abilities of the four Diagnostic Roles.

Usage of the Four Diagnostic Roles

Task Diagnostic
Super User

Application
Super User

End User Anonymous
User

Use LogViewer
tab

Yes Yes No No

Perform security
configuration

Yes For test groups of
own application

No No

Configure
applications

Yes For own
application

No No

View detailed
reports

Yes Yes No No

Configure test
inputs

Yes For own
application and
low or medium
sensitivity test
groups of other
applications

Low sensitivity
test groups

HTML Platform
only

Send e-mail and
print detailed
reports

Yes Yes Summarized
reports

HTML Platform
only

HTML Platform Yes Yes Yes Yes

Alternative Launchpads
The System Administrator Console is one of several places where you can access the
Diagnostics screens. The other "launchpads" are described below.

URLs
The following URL can be used to access the Diagnostics screens. It is particularly useful
if a deployment is experiencing startup problems:

http://<hostname>:<portnumber>/OA_HTML/jtfqalgn.htm

Oracle Applications Manager
As of release 11.5.9, you can access Diagnostics screens through Oracle Applications
Manager. Clicking the Diagnostics dashboard subtab in Oracle Applications Manager
displays summaries of diagnostic test statistics and log data. To launch the Diagnostics
screens, click Launch Diagnostics.
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Database Failover
If the database is down (that is, cannot be read from or written to), then report entries are
stored locally on the file system. All test results for that diagnostic session go to the file
system, even if the database comes up at some point in the session. If the database stays
up, then the log entries will go to the database the next time a session is started.

Report files are only created if the database is down. In this case, they are generated in
the directory specified by the following -D parameter to the JServ:

-Dframework.Logging.system.filename=<some writeable directory>

This directory must be writable. When the database is down, there will be one file per
diagnostic session.

Command-Line Console
The Web-based Diagnostics screens are not the only interface to Oracle Diagnostics;
there is also the Command-Line Console. The Command-Line Console uses a guest user
login at a UNIX or Windows prompt. It is typically used during development or during
installation when you need to run regression tests to verify if different aspects of the
system are still functioning after a patch has been installed.

Naturally, you will not be permitted to access any configuration-related functionality
over the Command-Line Console, since you are implicitly authenticated as a guest
user. This is necessary to keep the data registered with the framework secure.

You can launch the Command-Line Console by using the command below:

java -DJTFDBCFILE=<dbc file> -Dframework.Logging.system.filename=
<framework logfile>
-Dservice.Logging.common.filename=<service logfile> oracle.apps.jt
f.regress.qatool.QAConsole

You need to do the following in this command:

• Specify the dbc file.

• Specify the locations of the framework and service log files.

• Ensure that the classpath being used has apps.zip, jdbc12.zip, and jsdk.jar.

Understanding Cache
In the Cache subtab, which is located under the Performance tab, you can manage
cache-related settings. This section offers an introduction to Cache concepts. For
step-by-step instructions on how to use the cache screens, please see Using Cache,
page 8-1.

Terminology
The following table explains important Cache concepts.
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Cache Terms

Term Denition

Cache A data structure that holds frequently used Java
objects. It is composed of component caches. A
component cache holds all the Java objects
belonging to an application component. An
application component pertains to specific
application functionality. In the Cache
subtab, you can manage cache policies, manage
cache filters, manage component caches, and
view cache statistics. Elsewhere in the Resource
Settings subtab, you can set the maximum size
of the cache.

Policy A setting that applies to an application
running on a host. The policy types are Cache
Only, Cache and Priming, Disabled, and
Custom. In the Cache subtab, you can set up
cache policies.

Filter An application-specific component that
indicates what responsibility IDs and language
codes to prime for.

Component Cache A data structure that holds the Java objects of
an application module pertaining to a specific
application functionality. For example, Catalog
andMenuRenderer are components that have
component caches. In the Cache subtab, you can
view, create, modify, and remove component
caches.

Statistics A dedicated screen under the Cache
subtab offers a display of component cache
performance metrics.

Understanding Declarative Page Flows
In the Declarative Page Flow subtab, which is located under the Design tab, you can
set up and manage the components of the Declarative Page Flows Framework: Physical
Pages, Logical Pages, Rules, and Business Flows.

This section offers an introduction to Declarative Page Flow concepts. For step-by-step
instructions on how to use the Declarative Page Flows screens, please see Using
Declarative Page Flows, page 9-1.

Overview
The Declarative Page Flows Framework enables you to customize, upgrade, and
troubleshoot the content and flow of JSPs within an application without making any
modifications to actual code. The Declarative Page Flows Framework is based on the
abstraction of JSPs into named logical entities. Consequently, you can achieve efficient
management of content and flows by utilizing the screens provided in the System
Administrator Console.
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Terminology
The following table explains important Declarative Page Flow concepts.

Declarative Page Flow Terms

Term Denition

Physical Page The name of a JavaServer Page (JSP). In
the Declarative Flows subtab, you can
view, register, and modify Physical Pages.

Logical Page A named logical entity that has one or more
Physical Pages mapped to it. Usually, each
Logical Page represents a node within a
Business Flow. In the Declarative Flows
subtab, you can view, create, and modify
Logical Pages.

Rule A rule is defined by parameters and conditions
and determines which Physical Page needs to
be rendered or which Logical Page needs to
display next. Rules evaluate to true when all of
their conditions evaluate to true. You can utilize
Rules to customize the page-to-page behavior
of a Business Flow. In the Declarative Flows
subtab, you can view, create, and modify Rules.

Business Flow A sequential set of linked Logical Pages that
usually corresponds to a business task. Business
Flows can be linear or nonlinear, depending
on whether or not there are context-sensitive
conditions. Branching conditions are evaluated
at each node. In the Declarative Flows
subtab, you can view, create, modify, clone, and
preview Business Flows.

Flow Cloning In order to facilitate the easy upgrade of
business flows which have been customized by
a customer, a business flow can be cloned, thus
creating a Flow Family of related business
flows. In the Declarative Flows subtab, the
Clone Flow screen allows you to generate
duplicates of a given flow.

Flow Families A flow family consists of an original business
flow, a clone of the original business flow, and
any customized clones which have been
made. In the Declarative Flows subtab, the
Flow Families screen allows you to view the
contents of a Flow Family and select which flow
is active.

Understanding Declarative Components
In the Declarative Components subtab, which is located under the Design tab, you can
create and manage declarative UI components (Bins, Graphs, Reports, Graph/Report
combinations, and LOVs) and their security settings.
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This section offers an introduction to Declarative Components concepts. For step-by-step
instructions on how to use the Declarative Components screens, please see Using
Declarative Components, page 10-1.

Overview
The Declarative Components Framework allows you to quickly build
UI components that display application-specific data in personalizable
Bins, Graphs, Reports, Graph/Reports, or LOVs. The coding requirements are minimal
to nonexistent and the components can be published on Oracle applications.

Terminology
The following table explains important Declarative Components concepts.
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Declarative Components Terms

Term Denition

Metadata The Declarative Components Framework relies
on the accurate definition of metadata. The
framework uses the metadata to capture
information about component headers,
footers, columns, and other attributes. In the
Declarative Components subtab, you can define
the metadata for bins, reports, graphs, graph/
report combinations, LOVs, and parameters.

Bin Bins are small reports which display high level
summary information in a tabular format. They
generally display information regarding a
single metric, such as "time period." If enabled
and the appropriate security features are
assigned, you can choose which bins to display
on the home page and also choose the order
in which multiple bins are displayed. In the
Declarative Components subtab, you can
view, create, modify, and remove Bins.

Report Reports are similar to bins. They display
information in a tabular format. In the
Declarative Components subtab, you
can view, create, modify, and remove
Reports. Optionally, you can do the same for
Graph/Report combinations.

Graph A graph is a diagram that represents data
pictorially.
In the Declarative Components subtab, you
can view, create, modify, and remove
Graphs. Optionally, you can do the same for
Graph/Report combinations.

LOV The LOVs that you create can be used across
applications. LOV means "list of values." It is a
UI component that facilitates the completion
of a text entry field when there are numerous
values that may be assigned. LOVs are a useful
alternative to drop-down lists, particularly
in cases where displaying a long list of
selections in a drop-down list would require
excessive scrolling. In short, when using
a LOV to complete a text entry field, you
type a query into the field and then click
a button labeled "Go." This opens a screen
where you view a list of values that match
the query you submitted. You can then select
the value that you desire and return to the
original screen, where what you selected will
populate the original text entry field. In the
Declarative Components subtab, you can
view, create, modify, and remove LOVs.
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3
Using the Security Subtab

Managing Security
You can perform the following tasks from the Security subtab:

• Viewing Security Alerts, page 6-1

• Managing Permissions, page 3-1

• Creating Permissions, page 3-2

• Assigning a Permission to Roles, page 3-2

• Managing Roles, page 3-3

• Creating Roles, page 3-4

• Mapping Permissions to a Role, page 3-4

For an introduction to Security concepts, please see Understanding Security, page 2-1.

Managing Permissions
Use this procedure to manage permissions. A permission has a name and a
description. For an introduction to permissions and roles, please see Understanding
Security, page 2-1.

Warning: Do not remove the predefined permissions that are built
into the System Administrator Console. These predefined permissions
are essential for stable and reliable performance of all Oracle CRM
modules. Removal of these permissions could cause serious or fatal
performance problems.

Steps:
1. In the Settings tab, navigate to Security > Access Controls > Permissions.

2. If you want to create a new permission, then click Create. This opens the page where
you edit the details of a new permission.

3. If you want to search for a permission, then:

1. Type a search phrase into the Find Permission field.

2. Click Go to display the search results.

4. To change which rows display in the table, you have the following options:

1. Click the Previous or Next buttons.
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2. Choose an entry range from the drop-down list.

5. If you want to assign a permission to roles, then click the name of a permission in the
table. This opens the page where you assign a permission to roles.

6. If you want to delete a permission, then:

1. Select the appropriate check box in the Remove column of the table.

2. Click Update to save.

The permission is removed.

Related Topics
Creating Permissions, page 3-2

Assigning a Permission to Roles, page 3-2

Managing Security, page 3-1

Creating Permissions
Use this procedure to create a new permission. For an introduction to permissions and
roles, please see Understanding Security, page 2-1.

Steps:
1. In the Settings tab, navigate toSecurity > Access Controls > Permissions, then

click Create.

2. Type a new permission name into the Name field. The first two or three letters of
a permission name correspond to the module shortcode. Permission names must
be unique.

3. Type a description of the permission into the Description field.

4. Click Create to save your work. The new permission is filed in alphabetical order.

Related Topics
Managing Permissions, page 3-1

Assigning a Permission to Roles, page 3-2

Managing Security, page 3-1

Assigning a Permission to Roles
Use this procedure to assign a permission to one or more roles. For an introduction to
permissions and roles, please see Understanding Security, page 2-1.

Steps:
1. In the Settings tab, navigate toSecurity > Access Controls > Permissions, then click

the name of a permission in the table.

2. Choose the name of a role in one list and click > or < to move it to the other list.

3. Repeat step 2 as desired.
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4. If you want to move all items in the Available Roles list to the Assigned Roles
list, then click >>. This assigns the permission to all roles.

5. If you want to move all items in the Assigned Roles list to the Available Roles
list, then click <<. This removes the permission from all roles.

6. Optionally, click Restore to reset the fields to their original values.

7. Click Update to save. The permission will be assigned to the roles specified in the
Assigned Roles list.

Related Topics
Creating Permissions, page 3-2

Managing Permissions, page 3-1

Managing Security, page 3-1

Managing Roles
Use this procedure to manage roles. A role is a grouping of one or more permissions. For
an introduction to permissions and roles, please see Understanding Security, page 2-1.

Step:
1. In the Settings tab, navigate to Security > Access Controls > Roles.

2. If you want to create a new role, then click Create. This opens the page where you
edit the details of a new role.

3. If you want to search for a role, then:

1. Type a search phrase into the Find Role field.

2. Click Go to display the search results.

4. To change which rows display in the table, you have the following options:

1. Click the Previous or Next buttons.

2. Choose an entry range from the drop-down list.

5. If you want to map permissions to a particular role, then click an entry in the Name
column of the table. This opens the page where you map permissions to a role.

6. If you want to delete a role, then:

1. Select the appropriate check box in the Remove column of the table. If the
check box is disabled, then you cannot remove the role. For example, seeded
roles are not deletable.

2. Click Update to save.

3. You will be asked to confirm that you want to delete the role. To cancel, click
Cancel. To delete the role, click Update.

The role is removed and revoked from all users who are assigned to the role.

Related Topics
Creating Roles, page 3-4
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Mapping Permissions to a Role, page 3-4

Managing Security, page 3-1

Creating Roles
Use this procedure to create a new role. For an introduction to permissions and
roles, please see Understanding Security, page 2-1.

Step:
1. In the Settings tab, navigate to Security > Access Controls > Roles, then click Create.

2. Type a new role name into the Name field.

The first two or three letters of a role name correspond to the module shortcode. Role
names must be unique.

3. Type a description of the role into the Description field.

4. Click Create to save. The new role is filed in alphabetical order.

Related Topics
Mapping Permissions to a Role, page 3-4

Managing Roles, page 3-3

Managing Security, page 3-1

Mapping Permissions to a Role
Use this procedure to map permissions to a role. A role is a grouping of one or more
permissions. For an introduction to permissions and roles, please see Understanding
Security, page 2-1.

Steps:
1. In the Settings tab, navigate to Security > Access Controls > Roles, then click the

name of a role in the table.

2. Choose the name of a permission in one list and click > or < to move it to the other list.

3. Repeat step 2 as desired.

4. If you want to move all items in the Available Permissions list to the Assigned
Permissions list, then click >>. This assigns the role to all permissions.

5. If you want to move all items in the Assigned Permissions list to the Available
Permissions list, then click <<. This removes the role from all permissions.

6. Click Update to save.

Related Topics
Creating Roles, page 3-4

Managing Roles, page 3-3

Managing Security, page 3-1
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4
Using the Site Preferences Subtab

Setting Up the Interapplication Bar
You can perform the following tasks from the Site Preferences subtab:

• Setting Up Navigation Groups, page 4-1

• Editing Navigation Group Details, page 4-2

For an introduction to the Interapplication Bar, please see the topic Understanding the
Interapplication Bar, page 2-2.

Setting Up Navigation Groups
Use the following procedure to set up navigation groups, which represent customizable
sets of applications with defined responsibility settings. They act as links in the
Interapplication Bar. The Interapplication Bar is the set of navigation groups that
displays at the top of every page in HTML-based CRM applications. For an introduction
to the Interapplication Bar, please see the topic Understanding the Interapplication
Bar, page 2-2.

Steps:
1. In the Settings tab, navigate to Site Preferences > Interapplication Bar > Navigation

Group Setup.

2. To create a new navigation group, do the following:

1. Type a name and description into an empty row in the table.

2. In the Status column, choose Active from the drop-down list if you want the
navigation group to display in the Interapplication Bar. Choose Inactive if you
do not want it to display.

3. In the Display Order column, use the drop-down list to select the navigation
group’s placement in the Interapplication Bar.

If a navigation group called "Sales" is has a display order of 0, one called
"Marketing" has a display order of 1, and another called "Service" has a display
order of 2, then the Interapplication Bar will look like the following: Sales
Marketing Service, provided the end user has responsibilities within all
three navigation groups. (For example, if the end user does not have any
responsibilities for service applications, then he or she will not see Service.)
(Note that if your deployment is in a language that reads from right to left, then
0will set the navigation group at the far right hand side of the screen, and so on.)
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4. Click Update to save your work.

5. Click the icon in the Detail column to map CRM applications to this navigation
group.

3. To edit an existing navigation group, please see steps 2b - 2e.

4. To delete a navigation group from the table, do the following:

1. Select the check box in the Remove column that corresponds to the navigation
group that you want to delete.

2. Click Update.

Related Topics
Editing Navigation Group Details, page 4-2

Editing Navigation Group Details
Use this procedure to map CRM applications to navigation groups. A navigation
group is a customizable set of applications with defined responsibility settings that is
launched when you click its link in the Interapplication Bar. The Interapplication Bar
displays at the top of every page in HTML-based CRM applications. For an introduction
to the Interapplication Bar, please see the topic Understanding the Interapplication
Bar, page 2-2.

Steps:
1. There are two ways to access this page:

• In the Settings tab, navigate to Site Preferences > Interapplication Bar >
Navigation Group Details.

• In the Settings tab, navigate to Site Preferences > Interapplication Bar
> Navigation Group Setup, then click the icon in the Detail column that
corresponds to the navigation group you are working with.

2. If you came to this page by way of the first method above, then you will need to
choose a navigation group from the drop-down list before you can begin selecting
applications.

3. Choose the name of an application in one list and click > or < to move it to the
other list.

4. Repeat step 3 as desired.

5. If you want to move all Available Applications to the Selected Applications
list, then click >>.

6. If you want to move all Assigned Applications to the Selected Applications
list, then click <<.

7. Click Update to save.

Related Topics
Setting Up Navigation Groups, page 4-1
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5
Using the System Subtab

Using the System Subtab
In the System subtab, you can define the system level properties that you need to set up
during deployment. You can reconfigure the properties later as necessary.

You can perform the following tasks from the System subtab:

• Setting Up Sessions, page 5-1

• Setting Up Cookies, page 5-2

• Setting Up Branding, page 5-3

• Setting Up the Self Service User, page 5-4

• Setting Up Property Categories, page 5-4

• Managing Properties, page 5-5

• Editing the Details of Keys, page 5-5

• Setting Up Debug Logging, page 5-6

• Viewing the Debug Log, page 5-7

• Setting Up Page Flow Logging, page 5-8

• Viewing Page Flow Logging Reports, page 5-9

Setting Up Sessions
Use this procedure to set up sessions. Sessions are a system property that carries user
identity and credentials throughout the duration of a user’s activity. For security
purposes, user sessions can be set to expire according to three rules:

• A specified number of hours has passed since the session began.

• A specified number of minutes has passed since the user’s last activity, such as
clicking a button. This setting is intended to prevent unauthorized users from taking
advantage of an unattended session.

• A specified number of "hits" have occurred during the session. A hit means a user
action such as submitting a query or clicking a link. This setting is also intended
to limit damage in case of an intrusion.

Sticky Sessions are a special kind of session. When using Sticky Sessions, all requests
from the same user session will attempt to go to the same JVM, regardless of whether
the application is in stateless mode or stateful mode. Sticky Sessions allow for several
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performance enhancements. In particular, the hit ratio of middle tier caching is improved
because all cached data for a particular user resides on a single JVM rather than being
scattered across different JVM instances. In addition, session attributes and resources
will not have to be recreated and duplicated across different JVMs, but can be reused
in the JVM associated with the session.

Connection Reuse refers to the sticky connection that is remembered in the sticky
session. Turning on connection reuse means that if the JVM finds an open connection
in the connection pool, then it can reuse the connection.

Saved Cursor Idle Time refers to the maximum time an active open cursor can be idle
before the cursor connection is closed.

Steps:
1. In the Settings tab, navigate to System > Properties > Sessions.

2. In the User Sessions area, you can specify how many hours pass before an active
session expires, how many minutes pass before an idle session expires, and the
maximum number of hits allowed per session.

3. In the Sticky Sessions area, you can turn Sticky Sessions on or off, specify how
many minutes pass before a session expires, turn Connection Reuse on or off, and
specify the saved cursor idle time.

4. Click Update to save your work.

Related Topics
Using the System Subtab, page 5-1

Setting Up Cookies
Use this procedure to set up cookies. Cookies are a system property that stores session
information about users and systems.

Steps:
1. In the Settings tab, navigate to System > Properties > Cookies.

2. Use the drop-down list labeledMode to set whether a browser cookie or URL
rewriting is used.

Browser cookies are the recommended setting, for the following reasons:

• A cookie stores up to 4K of data, while a URL can only store 2K of data.

• Using URL rewriting prohibits any customizations that rely on cookies. For
example, some customized pages in the iStore application rely upon a cookie.

3. Type the encryption key into the Encryption Key field. Encryption keys are a means
to protect the information stored in cookies. A key is usually an alphanumeric string
of twenty to thirty characters.

4. Type a number into the Expiration Time field. This is the number of expiration units
(time intervals) that pass before the cookie expires. Set the expiration unit below.

5. Choose Day(s), Hour(s), orMinute(s) from the Expiration Unit drop-down list.

6. Click Update to save.
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Related Topics
Using the System Subtab, page 5-1

Setting Up Branding
Branding refers to the images that appear at the top of Web-based application
pages. Branding includes elements such as a corporate logo, an application name, or a
product collage image.

Branding Size
There are three size options for branding: regular, medium, and small. Regular branding
is larger than the other two options, and in regular branding the global links display as
round icons rather than text-only hyperlinks. Medium branding is more compressed in
size than regular branding, and small branding is even more compact. For information
on how to set branding size, please refer to the Oracle Applications CRM System
Administrator’s Guide.

Branding Text
Optionally, you can customize the branding text once the application has been
deployed at a customer site. The branding text can be defined at both application
level and responsibility level. A responsibility can only belong to one application, and
an application can have multiple responsibilities. If the branding text for a particular
responsibility is not set, then the branding text for all responsibilities within the
application will be used. If the branding text for a particular responsibility is set, then
that branding text will take precedence and override the branding that is set at the
application level.

For example, for the application CRM Foundation, you could set the branding text to
"Admin Console" at application level (the default for all responsibilities). Given two CRM
Foundation users, one with the CRM Administrator responsibility and the other with the
HTML Foundation User responsibility, when they log in, both will see "Admin Console."

However, if you customize the branding text for the HTML Foundation User
responsibility to "HTML User," then when those users log in they will see "HTML User."
Users having the responsibility CRM Administrator will still see "Admin Console."

Use the following procedure to configure branding text.

Steps:
1. In the Settings tab, navigate to System > Properties > Branding.

2. Choose an application from the Application Name drop-down list.

3. Choose which responsibility applies to the branding from the Responsibility Name
drop-down list. In some cases, you may only have one option, Default Branding for
this Application.

4. Type into the Branding Name field to set the branding text.

5. Click Update to save.

The page refreshes to display a preview of the new branding text.
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Related Topics
Using the System Subtab, page 5-1

Setting Up the Self Service User
Use this procedure to set up the self service user. You must set up the self service user
after deploying applications. The self service user is also known as the "guest user." It
represents an internal user who is granted certain responsibilities and permissions so
that new users can be given the appropriate responsibilities and permissions during the
self-registration process.

Steps:
1. In the Settingstab, navigate to System > Properties > Self Service User.

2. Enter a name for the self service user and set a password. All three fields are required.

3. Click Update to save.

Related Topics
Using the System Subtab, page 5-1

Setting Up Logging Trails
This task has been obsoleted by the following procedure: Setting Up Debug Logging,
page 5-6

Setting Up Property Categories
Use this procedure to set up applications in the system properties framework. In this
procedure, you will assign roles to have either read or update permission for a given
application (AKA category). For an introduction to permissions and roles, please see
Understanding Security, page 2-1.

Steps:
1. In the Settingstab, navigate to System > Properties > Category.

2. Choose an application from the Application Name drop-down list.

Note: This list displays the full names of applications (for
example, "Oracle Enterprise Asset Management"). However, in the
Properties screen where you manage properties, the drop-down
list displays only the abbreviated application shortname (such as
"EAM").

3. Choose Read or Update from the READ/UPDATE drop-down list, depending on
what type of permission you will be granting.

4. Click Next. This opens the page where you can map the permission to one or more
roles.
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Related Topics
Using the System Subtab, page 5-1

Assigning a Permission to Roles, page 3-2

Setting Up Password Expiration
Note: This page no longer controls password expiration.

Managing Properties
Use this procedure to manage properties. A property is a key/value pair that is
application-specific. A key is what is used by an application to retrieve data. Keys are
unique, but can have multiple values. Values are the content or data that binds to a
particular key. You can view, create, modify, delete, and copy properties.

Steps:
1. In the Settings tab, navigate to System > Properties > Advanced.

2. Choose a application shortname from the View drop-down list. The page will
refresh to display the properties registered for that module.

If your desired application shortname does not appear in the drop-down list, you
will need to do the procedure Setting Up Property Categories. , page 5-4

3. If you want to create a key, then click Create. This opens the page where you specify
the details of a new key.

4. If you want to view or modify the details of a key, then click a key name in the
table. This opens the page where you view or edit the details of an existing key.

5. If you want to remove a key, then:

1. Select the appropriate check box in the Remove column of the table.

2. Click Update to save.

Related Topics
Using the System Subtab, page 5-1

Editing the Details of Keys, page 5-5

Editing the Details of Keys
Use this procedure to edit the details of new or existing keys. A property is a key/value
pair that is application-specific. A key is what is used by an application to retrieve
data. Keys are unique, but can have multiple values. Values are the content or data that
binds to a particular key.

Steps:
1. In the Settings tab, navigate to System > Properties > Advanced, then either click

Create or click the name of a key in the table.

2. Type a key name into the Key field.
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3. Edit the table.

1. Type values into the Value fields as desired.

2. Type sequence numbers into the Sequence fields as desired.

3. If you want to remove a value, then select the appropriate check box in the
Remove column.

4. Optionally, clickMore Rows to add empty rows to the table.

4. If you want to resequence the key, then click Resequence.

5. If you want to copy the key, then click Copy Key.

6. If you are creating a new key and want to clear the fields, then click Clear.

7. If you are editing an existing key and want to restore the fields to their original
settings, then click Restore.

8. Click Update to save.

Related Topics
Using the System Subtab, page 5-1

Managing Properties, page 5-5

Setting Up Debug Logging
Use this procedure to set up debug logging. Debug logging allows messages to be
logged to a central repository at runtime. The logged messages can be viewed for
troubleshooting purposes. The repository is shared by both the database and the
middle-tier servers.

Steps:
1. In the Settings tab, navigate to System > Properties > Debug Logging >

Configuration.

2. In the Enabled field, you can turn debug logging on or off.

3. In the Level field, you select what severity of messages will be logged. Only
messages with a level equal to or greater than the specified level will be logged. Level
1 messages have low severity, such as "Obtained Connection From Pool." Level
2 messages occur upon entry and/or exit from a method, such as "Leaving
MyClass.myMethod()." Level 3 messages are significant in the normal execution
path of an application, such as "Retrieved User Preferences Successfully." Level 4
messages occur when a lower level API is returning a failure code or exception, but
the error does not necessarily indicate a problem at the level of the calling code. For
example, "Profile not found." Level 5 messages are error messages to users, such
as "Invalid username or password." Level 6 messages occur when an unexpected
situation has occurred which is likely to indicate or cause instabilities in the
runtime behavior, and the system administrator should take action to address the
situation. For example, "Configuration error - required property not set, cannot
access configuration file."

4. In theRepository field, you can set either the database or a file as the log repository. If
you select File, you must specify a complete file path in the Filename field below.
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Note: Only messages that are logged to the database repository
are searchable in the UI. Messages that are logged to a file are not
searchable in the UI.

5. In theModule Filter field, you can set up a module filter. A module filter is an
optional comma-delimited list or strings that you can configure to permit logging for
a specific group of modules. The wildcard character (%) is permitted. An example
module filter might be: "fnd%, jtf%, %store%." Or to select all modules, use "%."

6. Click Update to save your configuration.

7. Restart your middle-tier server.

Related Topics
Using the System Subtab, page 5-1

Viewing the Debug Log, page 5-7

Viewing the Debug Log
Use this procedure to search for, view, download, and/or purge the messages generated
from debug logging.

Steps:
1. In the Settings tab, navigate to System > Properties > Debug Logging > Messages.

2. To search for messages, do one or more of the following:

1. To limit the messages displayed to a specific date range, use the date picker
widgets provided in the From and To fields.

2. To set which logging levels are displayed, choose a level from the Level
drop-down list. Check the check box next to the field to include higher (more
severe) messages as well. Please see Setting Up Debug Logging , page 5-6for
details about logging levels.

3. To limit the messages displayed to a particular node, choose a host name from
the Node drop-down list.

4. In the JVM field, you can specify the ID of the Java process where the message
was generated.

5. In the Thread field, you can specify the ID of the thread within the Java process
where the message was generated.

6. In the Module field, you can specify the source code origin of the
message. Typically in Java this is the full class name. When a class name
begins with "oracle.apps." the leading "oracle.apps." is dropped in the
logged message. For example, "oracle.apps.jtf.util.Encoder" will be logged as
"jtf.util.Encoder."

7. In the User field, you can specify the user name of the application user who was
active when the message was logged.

8. In theMessage field, you can specify a particular log message that you want
to search for.
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9. In the Session field, you can specify a session ID.

10. Optionally, you can select the View Details check box to show expanded
information in the log display below. If the box is unchecked, then the message
table on this screen will have the following columns: Seq, User, Level,
Timestamp, Module, andMessage. If View Details is checked, then the
message table on this screen will have the following columns: Seq, User, Level,
Timestamp, Session, Node, JVM, Thread,Module, andMessage.

11. Click View Log to display messages.

3. To download the logged messages as a space-delimited text file, clickDownload Log.

4. To purge logged messages, click Purge Log. This purges the log based on the criteria
you have specified in the above fields. As the system administrator, you should
periodically rotate or remove the log files as necessary.

Related Topics
Using the System Subtab, page 5-1

Setting Up Debug Logging, page 5-6

Setting Up Page Flow Logging
Use this procedure to configure page flow logging.

Steps:
1. In the Settings tab, navigate to System > Properties > Page Flow Logging >

Configuration.

2. To turn page flow logging on or off, use the Enabled drop-down list.

3. To specify which request attributes to log, check or uncheck the check boxes in the
Select Request Attributes to Log area. You can choose to log one or more of the
following request attributes for each application page that is accessed:

• Client browser information

• Application parameters

• Client language (character encoding, language, character set)

• JTF session cookie

• All other incoming HTTP headers

• All other incoming cookies

4. In the Only log these Applications area, you can specify which applications are
logged. Use the arrow buttons to move application names between the Disabled
list and the Enabled list.

5. In the Only log these Business Flows area, to specify which business flows are
logged. Use the arrow buttons to move application names between the Disabled
list and the Enabled list.

6. Click Update to save. Configuration changes will take effect when all the JVMs
that use page flow logging are restarted.
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Related Topics
Using the System Subtab, page 5-1

Viewing Page Flow Logging Reports, page 5-9

Migrating Page Flow Data, page 5-9

Setting Page Flow Buffer Size and Flush Interval, page 5-10

Viewing Page Flow Logging Reports
Use this procedure to view page flow logging reports.

Note: You must migrate the page flow data from a staging area to the
mining area before the materialized views can be refreshed for UI
reports. Please see the procedure Migrating Page Flow Data, page 5-9.

Steps:
1. To view the screen which displays the reports, in the Settings tab, navigate to

System > Properties > Page Flow Logging > Reports.

2. Consult the tables provided to view data about application usage and middle-tier
usage.

3. Optionally, to customize the dates that display in a table, click Edit. Using the date
picker widgets provided, choose your desired date range and click Update to save.

4. If desired, you can drill down into the generated report table to view detailed reports
on page hits, sessions, and users.

Related Topics
Using the System Subtab, page 5-1

Migrating Page Flow Data, page 5-9

Setting Page Flow Buffer Size and Flush Interval, page 5-10

Setting Up Page Flow Logging, page 5-8

Migrating Page Flow Data
Use this procedure to migrate page flow data. Page flow data is logged in the database in
a staging area. This data needs to be migrated to the mining area before the materialized
views can be refreshed for the UI reports.

Steps:
1. Log in to Forms (JInitiator) with the CRM Administrator, Vision Enterprises

responsibility.

2. Navigate to Concurrent > Requests.

3. Double-click Requests.

4. Click Submit a New Request or Run.

5. Select Request Set.
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6. Click OK.

7. In the Request field, enter Page Flow. Then press the Tab key on your keyboard to
select Page Flow Data Migration and Refresh.

8. Schedule and submit the request.

What's Next
After the Concurrent Request-Set completes, you should be able to view the latest data
reports and statistics in the System Administrator Console UI. To do so, please see the
procedure Viewing Page Flow Logging Reports, page 5-9.

Related Topics
Using the System Subtab, page 5-1

Viewing Page Flow Logging Reports, page 5-9

Setting Page Flow Buffer Size and Flush Interval, page 5-10

Setting Up Page Flow Logging, page 5-8

Setting Page Flow Buffer Size and Flush Interval
Use this procedure to set the buffer size and flush interval for page flow logging. Page
flow data is buffered within each JVM and periodically asynchronously flushed to the
database. The flush is triggered by two parameters: a time interval and the maximum
number of page log accesses in the buffer. The data is flushed to the database when the
specified flush interval is reached, or when the number of page log accesses exceeds
the configured buffer size.

Steps:
1. In the Settings tab, navigate to System > Advanced.

2. In the View field, select JTF.

3. In the Key column, find the property JTF_PF_BUFFER_SIZE.

4. To change the value from the default (5 page hits), click JTF_PF_BUFFER _SIZE and
modify the value as desired. Click Update to save.

5. In the Key column, find the property JTF_PF_FLUSH_INTERVAL.

6. To change the value from the default (30 seconds), click JTF_PF_FLUSH_INTERVAL
and modify the value as desired. Click Update to save.

Note: Your application JSPs must use the standard JTF JSP header
and footer includes for the page hits to be logged. If your application
does not use the JTF include JSPs, then you can still use this
feature. However, your JSPs will need to call the appropriate JTF
APIs at the start and end of the HTTP request-response.

Related Topics
Using the System Subtab, page 5-1

Viewing Page Flow Logging Reports, page 5-9
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Migrating Page Flow Data, page 5-9

Setting Up Page Flow Logging, page 5-8
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6
Using the Deployment Tab

Viewing System Alerts
Use this procedure to use the Application Alert Board. The Application Alert
Board allows you check the health of a deployed system by displaying a filterable
test summary. It complements the Diagnostics framework to guide you when
troubleshooting failures or misconfigurations.

Steps:
1. In the Deployment tab, navigate to System Statistics > System

Alerts. Alternatively, you can view only Security-related alerts in the Settings tab
by navigating to Security > Alerts Monitor. The Alerts Monitor is a summary of
security-related tests that are run on each registered host.

2. In the Filters Selection area, you can set what displays below in theMonitor Board
area. You can filter by application, node, test status, and date range. The entire page
refreshes automatically each time you make a selection from one of the drop-down
lists. To set a date range, use the date picker widgets to select the appropriate
dates and then click Go. If needed, click Restore to return the date fields to their
original values.

Note: If you are in the Security subtab and are viewing the Alerts
Monitor, then you can only filter by node.

3. TheMonitor Board area displays tests and their results. The tests are organized
by test group and application. Colored icons express whether the test has
succeeded, failed, or resulted in a warning. Refer to the Nodes Alias area below
to find out which registered node is mapped to each numbered column (labeled
0, 1, 2, etc.) in the table.

Related Topics
Viewing Jserv Statistics, page 6-1

Viewing Jserv Statistics
Use this procedure to view the Jserv statistics of a particular host.

Steps:
1. In the Deployment tab, navigate toSystem Statistics > Jserv Statistics.
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2. The contents of the drop-down list labeled Node are taken from the Hosts page
(which displays under the Configuration subtab).

3. To switch to a remote node, choose a value from the drop-down list and click Submit.

If the node is not accessible, then an "Error: Node not reachable" message will
display. If the node is accessible and JTT is installed on it, then a pop-up window
will allow you to log in. When your login is successful, Jserv statistics for that node
will display.

4. The data provided is as follows:

1. Memory: Displays the total amount of memory in the Java Virtual Machine and
amount of free memory in the system.

2. Threads: Displays the total number of active threads in the current thread’s
thread group.

3. Connection Pool: Displays the status of the database connection pool, including
the maximum connection pool size, the current connection pool size, and the
number of connections being used.

4. Session: Displays information about the servlet session, including the number
of stateful sessions, the number of concurrent user requests, the total number
of ICX sessions, and the applications installed in this middle tier (specified by
application short name).

5. Services In Use: Displays information about each application, including the
service descriptor, the maximum number of services, the number of current
services, and the number of services in use.

Related Topics
Viewing System Alerts, page 6-1

Setting Up Hosts, page 6-2

Managing Conguration
You can perform the following tasks from the Configuration subtab:

• Setting Up Hosts, page 6-2

• Editing Host Details, page 6-3

• Editing Resource Settings, page 6-4

Setting Up Hosts
Use this procedure to manage hosts. The Hosts Setup page is the starting point for
viewing, creating, updating, and removing hosts.

Steps:
1. In the Deployment tab, navigate toConfiguration > Hosts.

2. If you want to register a host, then click Create. This opens the page where you edit
the details of a new host. You must register all mid-tier hosts.
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3. If you want to modify the attributes of a host, then click a name in the Host Name
column. This opens the page where you edit the details of an existing host.

4. If you want to remove a host, then:

1. Select a check box in the Remove column.

2. Click Update to save.

Related Topics
Editing Host Details, page 6-3

Managing Configuration, page 6-2

Editing Host Details
Use this procedure to edit the details of new or existing hosts.

Steps:
1. In the Deployment tab, navigate to Configuration > Hosts, then either click Create

or click the name of a host in the table.

2. If you are creating a new host, then type the name of the mid-tier URL into the
Hostname field. For example, "computername.companyname.com.". If you are
updating an existing host, then you cannot edit this field.

3. Type a description into the Description field.

4. Edit port numbers:

1. Type the port number where the Apache in this mid-tier host runs into the first
Port field. For example, "9999."

2. If there are multiple Apache instances running on the same mid-tier host, then
type additional port numbers into the Port column. For example, "9999" and
"8080."

3. If you want to remove an existing port, then select the appropriate check box in
the Remove column.

5. Edit application deployment:

This information is used by the caching framework to cache and prime only the data
for the configured set of applications.

1. Choose the name of an application in one list and click > or < to move it to the
other list.

2. Repeat step a as desired.

3. If you want to move all Available Applications to the Deployed Applications
list, then click >>.

4. If you want to move all Deployed Applications to the Available Applications
list, then click <<.

6. If you are creating a new host, then click Create to save.

7. If you are updating an existing host, then click Update to save.
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Related Topics
Setting Up Hosts, page 6-2

Managing Configuration, page 6-2

Editing Resource Settings
Use this procedure to manage resource settings for the cache. The cache is a data
structure that holds frequently used Java objects. It is composed of component
caches. Component caches hold the objects of application modules that pertain to
specific application functionality. In the Resource Settings subtab, you can set the
maximum size of the cache (in megabytes). This is used to prevent the JVM memory
from bloating because of caching. When the JVM’s memory usage reaches this limit, the
cache stops growing in size. Elsewhere, in the Cache subtab, you can manage cache
policies, manage component caches, and view cache statistics.

Steps:
1. In the Deployment tab, navigate to Configuration > Resource Settings.

2. To define cache resource settings, type a number into the Disable Cache if Total
Memory Exceeds field. Typically this represents a percentage of the maximum
memory of the JVM (in megabytes).

3. Click Update to save.
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7
Using Diagnostics

Using Diagnostics
Note: You can also navigate to the Diagnostics screens by typing the
following URL into a Web browser:

http://hostname:portnumber/OA_HTML/jtfqalgn.htm

This is particularly useful if the deployment is having startup problems.

You can perform the following tasks from the Diagnostics screens:

• Using the Diagnostics Summary, page 7-1

• Using the LogViewer, page 7-2

• Running Test Groups, page 7-3

• Running Tests, page 7-4

• Managing Test Groups, page 7-5

• Creating Test Groups, page 7-5

• Updating Test Groups, page 7-6

• Managing Tests, page 7-6

• Registering Tests, page 7-7

• Setting Default Test Input Values, page 7-7

• Managing Applications, page 7-8

• Setting Up Security for Diagnostics, page 7-9

For information on Diagnostics concepts, see Understanding Diagnostics, page 2-3.

Using the Diagnostics Summary
Use the following procedure to use the Diagnostics Summary page, which displays data
regarding registered diagnostic tests and recent test failures. For an introduction to
Diagnostics concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Home tab, then choose the Summary subtab.
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2. Depending on your user responsibilities, one or more of the following bins may
display:

• The Test Summary table displays how many tests have been registered for
each application. To view or run tests for a particular application, click a link
in the corresponding Registered Tests column. The application specified in the
Application drop-down list will change accordingly, and you can then navigate
through the tabs and pages to view or run tests for that application.

• The Failures in Past Week table lists any tests which have failed during the
past seven days. It provides the test name, the test group name, the application
name, and the date and time when the failure occurred. Depending on your user
responsibilities, you may be able to click a link in the Date column to open a
log of the test failure.

Related Topics
Using the LogViewer, page 7-2

Using Diagnostics, page 7-1

Using the LogViewer
The LogViewer is available to users with the Diagnostic Role "Diagnostic Super User."
The Log Viewer displays log records which have been generated during diagnostic
sessions. Use the following procedure to filter the data. For an introduction to
Diagnostics concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Home tab, then click the LogViewer subtab.

2. To activate your choice of filters:

1. You can filter by date with the From field. This sets the lower boundary of the
filtering date range. To enter a value into the field, click the calendar button next
to the field and choose a date from the pop-up which displays. Make sure that
this value is earlier than the value in the To field.

2. You can filter by date with the To field. This sets the upper boundary of the
filtering date range. To enter a value into the field, click the calendar button next
to the field and choose a date from the pop-up which displays. Make sure that
this value is later than the value in the From field.

3. To filter by application, select an application name from the Application
drop-down list. Alternatively, select All Applications to include all applications
in the query.

4. To filter by group, choose a value from the Group Name drop-down list. This
field is populated based on the value in the Application drop-down list.

5. To filter by test status, choose All, Failures,Warnings, or Successes from the
Status field.

6. Optionally, select the Current Session Test Runs Only check box to only search
for log records from the current session.

3. Click Search Log Records to perform the search.
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4. If records are found, a table labeled Summary of Logs displays the search results.

5. To see a detailed view of one or more logs, select the corresponding checkbox(es)
in the Select column, then click Details. Alternatively, click a link in the table to
display the detailed log for Total Runs, Successes,Warnings, or Failures. The page
refreshes to display detailed log information.

6. To delete one or more test logs, select the select the corresponding checkbox(es)
in the Select column, then click Delete.

7. To send one or more test logs by e-mail, select the select the corresponding
checkbox(es) in the Select column, then click Email. On the next screen, you can
specify the recipient name, subject line, customer name, and problem severity before
sending the e-mail.

8. To create a report that is formatted in an easy-to-read way, select the corresponding
checkbox(es) in the Select column, then click Print. The next screen displays a
printable report which you can send to a printer.

Related Topics
Using the Diagnostics Summary, page 7-1

Using Diagnostics, page 7-1

Running Test Groups
You can perform the following tasks from the Basic tab:

• Running All Test Groups, page 7-3

• Running One Test Group, page 7-4

For information on Diagnostics framework concepts, see Understanding Diagnostics,
page 2-3.

Note: Test result information is from tests that have been executed in the
current session. Results do not persist from one session to the next.

Running All Test Groups
Use this procedure to run all test groups on an application. Test groups are logical
sets of one or more related tests. For an introduction to Diagnostics concepts, please
see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Basic tab.

2. Choose an application from the Application drop-down list.

3. Click Run All Groups.

4. View the test results.

5. If you want to view a detailed summary of a test, then click the icon in the Report
column.
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Related Topics
Running One Test Group, page 7-4

Managing Test Groups, page 7-5

Using Diagnostics, page 7-1

Running One Test Group
Use this procedure to run a specific test group on an application. Test groups are logical
sets of one or more related tests. For an introduction to Diagnostics concepts, please
see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Basic tab.

2. Choose an application from the Application drop-down list.

3. Click the name of the test group.

4. If you want to run the test group’s prerequisite group or groups, then click RunWith
Prerequisite. You can view the names of the prerequisite group or groups in the
Prerequisites drop-down list.

5. If you want to run the test group alone, then click Run Without Prerequisite.

6. View the test results.

7. If you want to view a detailed summary of a test, then click the icon in the Report
column.

Related Topics
Running All Test Groups, page 7-3

Managing Test Groups, page 7-5

Using Diagnostics, page 7-1

Running Tests
Use this procedure to run a test on an application. Tests verify the correct behavior of
a particular feature or function. For an introduction to Diagnostics concepts, please
see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Advanced tab.

2. Choose an application from the Application drop-down list.

3. Click the name of the test.

4. If you want to specify your own input values, then type them into the appropriate
fields. Otherwise, the test runs using default values.

5. Click Run Test.

6. View the test results. Note that test result information is from tests that have been
executed in the current session. Results do not persist from one session to the next
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7. If you want to view a detailed summary of a test, then click either the icon in the
Report column or View Report.

Managing Test Groups
Use this procedure to manage test groups. The main page for test groups is the starting
point for viewing, creating, updating, prioritizing, and removing test groups. Please
note that this procedure is not applicable to the application "HTML Platform." For an
introduction to Diagnostics concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Configuration tab, choose an application from

the drop-down list, then choose Groups.

2. If you want to create a new test group, then click Create.

This opens the page where you edit the details of a new test group.

3. If you want to update an existing test group, then click a link in the Group Name
column. This opens the page where you edit the details of an existing test group.

4. If you want to change the test group sequence, then choose the appropriate numbers
from the drop-down lists in the Sequence column.

5. If you want to remove a test group, then select the appropriate check box in the
Remove column.

6. Optionally, click Restore to reset the fields to their original settings.

7. Click Update to save.

Related Topics
Creating Test Groups, page 7-5

Updating Test Groups, page 7-6

Using Diagnostics, page 7-1

Creating Test Groups
Use this procedure to create test groups. Test groups are logical sets of one or more
related tests. Please note that this procedure is not applicable to the application "HTML
Platform." For an introduction to Diagnostics concepts, please see Understanding
Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Configuration tab, choose an application from

the drop-down list, choose Groups, then click Create.

2. Type the name of the test group into the Group Name field.

3. If you want to set Group Prerequisites, then choose from the drop-down lists in the
Group Name column.

4. Optionally, clickMore Prerequisites to add more rows to the table.

5. Optionally, click Restore to reset the fields to their original settings.
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6. Click Create to save.

Related Topics
Managing Test Groups, page 7-5

Updating Test Groups, page 7-6

Using Diagnostics, page 7-1

Updating Test Groups
Use this procedure to view or edit the name and prerequisites of an existing test
group. Test groups are logical sets of one or more related tests. Please note that this
procedure is not applicable to the application "HTML Platform." For an introduction to
Diagnostics concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Configuration tab, choose an application from

the drop-down list, choose Groups, then click the name of a group in the table.

2. If you want to rename the group, then type into the Group Name field.

3. If you want to remove a prerequisite, then select the appropriate check box in the
Remove column.

4. If you want to add a prerequisite, then choose from the drop-down lists in the
Group Name column.

5. If you want to view the individual tests that belong to that test group, then click
View Tests. This opens the page where you manage how tests are organized into
test groups.

6. Optionally, click Restore to reset the fields to their original settings.

7. Click Update to save.

Related Topics
Managing Test Groups, page 7-5

Creating Test Groups, page 7-5

Using Diagnostics, page 7-1

Managing Tests
Use this procedure to manage tests. The Tests Administration page is the starting point
for viewing, creating, updating, prioritizing, and removing individual tests. Please
note that this procedure is not applicable to the application "HTML Platform." For an
introduction to Diagnostics concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Configuration tab, choose an application from

the drop-down list, then choose Tests.

2. Choose a group from the Group drop-down list.
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3. View test names and class names display in the table.

4. If you want to create a test, then click Create. This opens the page where you specify
the details of a new test.

5. If you want to change the test sequence, then choose the appropriate numbers from
the drop-down lists in the Sequence column.

6. If you want to remove a test, then select the check box in the Remove column.

7. Optionally, click Restore to reset the fields to their original settings.

8. Click Update to save.

Related Topics
Registering Tests, page 7-7

Setting Default Test Input Values, page 7-7

Using Diagnostics, page 7-1

Registering Tests
Use this procedure to register a test. For an introduction to Diagnostics concepts, please
see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Configuration tab, choose an application from

the drop-down list, choose Tests, then click Create.

2. Type the fully qualified name of the Java class into the Test Class Name field.

3. View the class names of any existing tests in the Existing Tests field.

4. Choose a sequence number from the Sequence drop-down list.

5. Optionally, click Restore to reset the fields to their original settings.

6. Click Create to save.

Related Topics
Managing Tests, page 7-6

Setting Default Test Input Values, page 7-7

Using Diagnostics, page 7-1

Setting Default Test Input Values
Use this procedure to set the default input values for a test. Please note that this
procedure is not applicable to the application "HTML Platform." For an introduction to
Diagnostics concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to the Configuration tab, choose an application from

the drop-down list, then choose Input.
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2. Click the name of a test.

3. Type default input values into the appropriate fields.

4. Click Update to save.

5. Optionally, type an additional set of default values and click Update to save.

6. Repeat step 4 as desired.

7. If you want to delete an input value, then select the check box in the Remove column
and click Update to save.

Related Topics
Managing Tests, page 7-6

Registering Tests, page 7-7

Using Diagnostics, page 7-1

Managing Applications
Applications must be registered to be included in Oracle Diagnostics. Applications can
have other applications as prerequisites.

You can perform the following tasks to manage applications:

• Registering Applications, page 7-8

• Editing Application Prerequisites, page 7-9

• Purging Result Logs, page 7-9

For an introduction to Diagnostics concepts, please see Understanding Diagnostics,
page 2-3.

Registering Applications
Use this procedure to register an application in Oracle Diagnostics. For an introduction
to Diagnostics concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to Configuration > Applications, then click Create.

2. Choose an application from the Choose an Application drop-down list.

3. If you want to set Application Prerequisites, then choose from the drop-down lists in
the Application Name column.

4. Click Register to register the application.

5. View the new application display in the Application drop-down list at the top of
the page.

Related Topics
Editing Application Prerequisites, page 7-9

Using Diagnostics, page 7-1
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Editing Application Prerequisites
Use this procedure to edit application prerequisites. For an introduction to Diagnostics
concepts, please see Understanding Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to Configuration > Applications.

2. Choose an application from the Application drop-down list.

3. If you want to remove an Application Prerequisite, then select the appropriate check
box in the Remove column.

4. If you want to add an Application Prerequisite, then choose from the drop-down
lists in the Application Prerequisites table.

5. Click Update to save.

Related Topics
Registering Applications, page 7-8

Using Diagnostics, page 7-1

Purging Result Logs
Periodically, you should purge result entries from the database table, otherwise the
table will grow without bound as each test that is executed results in a new row in the
table. The results table is JTF_DIAGNOSTICS_LOG.

The statistics table does not grow very large since its size is based on the number of tests
registered, not the number of times these tests have been executed. However, since
the statistics information keeps a running record of different metrics (for example, the
number of failures), then you should refresh this information to keep the statistics
relevant to the state of the system. The statistics table is JTF_DIAGNOSTIC_STATS.

Test result and statistic entries can be removed from the database by navigating
to Configuration > Applications, then choosing the desired application from the
drop-down list provided. The bottom of the page shows all the result and statistic entries
for the application for all sessions. Deleting the result entries removes all log entries that
have been created for this application, regardless of session. Note that this includes
the current diagnostic session.

This page only shows the result entries in the database, and only deletes the log entries
in the database. If any result files have been generated by diagnostic sessions (if the
database was down), then they have to be manually deleted by going the directory
specified by the -Dframework.Logging.system.filename parameter.

Setting Up Diagnostic Security
Certain diagnostic tests may contain sensitive information, and therefore need to be
secured from unauthorized access. Use this procedure to assign user responsibilities to
different Diagnostic Roles. Diagnostic Roles determine the set of operations that can be
performed on test groups, based on the sensitivity of the test group (low, medium, or
high). The Diagnostic Roles available are as follows:
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• Super User: For all test groups of all registered applications, a Super User can
execute tests, perform configuration, view reports, and set up security.

• Application Super User: For all test groups of a given application, an Application
Super User can execute tests, perform configuration, view reports, and set
up security. For test groups of medium or low sensitivity belonging to other
applications, an Application Super User can execute tests, configure test inputs, and
view reports.

• End User: For test groups of low sensitivity belonging to any application, an End
User can execute tests and configure test inputs.

For an introduction to Diagnostics framework concepts, please see Understanding
Diagnostics, page 2-3.

Steps:
1. In the Diagnostics UI, navigate to Configuration > Security.

2. In the table, click the name of the Diagnostics Role that you wish to configure.

3. On the page which opens, make a selection from the Applications drop-down
list, which automatically populates the list of Available Responsibilities below.

4. Use the arrow buttons to move responsibilities between the Available
Responsibilities list and the Selected Responsibilities list.

5. Click Save to assign the responsibilities in the Selected Responsibilities list to the
Diagnostics Role that you are working with.

Related Topics
Using Diagnostics, page 7-1
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8
Using the Cache Subtab

Using Cache
You can perform the following tasks from the Cache subtab:

• Managing Cache Policies, page 8-1

• Editing Cache Policy Details, page 8-2

• Managing Cache Filters, page 8-2

• Viewing Cache Filter Details, page 8-3

• Creating and Editing Cache Filters, page 8-3

• Managing Component Cache, page 8-5

• Editing Component Cache Details, page 8-6

• Viewing Cache Statistics, page 8-7

For an introduction to cache concepts, please see Understanding Cache, page 2-7.

Managing Cache Policies
Use this procedure to manage cache policies. The main cache policies screen lists
the cache policy of each application on each host. For an introduction to cache
concepts, please see Understanding Cache, page 2-7.

Steps:
1. In the Performance tab, navigate to Cache > Applications > Policies.

2. Choose a host name or All Hosts from the drop-down list labeled View to select
which cache policies display in the table.

3. To sort the table alphabetically by host name or application, click the appropriate
link in the top row of the table.

4. To edit the details of a cache policy, click a link in the table. This opens the page
where you edit the details of a cache policy.

5. To set a cache policy, choose Cache Only, Cache and Priming, Disabled, or Custom
from the drop-down lists in the Policy column.

If you enable caching, then all components of the application use the caching. If
you enable priming, then the components read some initial cache data when the
Jserv process begins. Priming can improve the performance for the first set of users
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because the data that they need is already available in the cache. However, priming
can increase the size of the Java Virtual Machine. Disable the cache if the size of the
Java Virtual Machine grows too large.

6. To set filters, then choose Enabled, Disabled, or Custom from the drop-down lists in
the Filters column.

7. Click Update to save.

Related Topics
Editing Cache Policy Details, page 8-2

Using Cache, page 8-1

Editing Cache Policy Details
Use this procedure to edit the details of cache policies and cache filters. The Cache
Policy Detail page displays the cache policy types for components of applications
running on a particular host. It also displays cache filters. For an introduction to cache
concepts, please see Understanding Cache, page 2-7.

Steps:
1. In the Performance tab, navigate to Cache > Applications > Policies, then click the

name of a policy in the table.

2. To modify a cache policy, choose Cache Only, Cache and Priming, orDisabled from
the drop-down list in the Policy column of the table.

3. Click Update to save.

4. To enable or disable a cache filter, go to the Enabled column and select or deselect
the check box as desired.

5. Click Update to save.

Related Topics
Managing Cache Policies, page 8-1

Using Cache, page 8-1

Managing Cache Filters
Use this procedure to manage cache filters. The main page for cache filters is the starting
point for viewing, creating, updating and removing cache filters. Cache filters are
application-specific components that indicate the responsibility IDs and language codes
for priming. For an introduction to cache concepts, please see Understanding Cache,
page 2-7.

Steps:
1. In the Performance tab, navigate to Cache > Applications > Filters.

2. Choose an application name from the drop-down list labeled View to choose which
cache filters display in the table.
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3. If you want to create a new cache filter, then click Create. This opens the page where
you begin editing the details of a new cache filter.

4. If you want to view the details of a cache filter, then click a filter name in the
table. This opens the page where you view the details of a Cache Filter.

5. If you want to remove a filter, then:

1. Select the appropriate check box in the Remove column.

2. Click Update.

This removes the filter from the table.

Related Topics
Viewing Cache Filter Details, page 8-3

Creating and Editing Cache Filters, page 8-3

Using Cache, page 8-1

Viewing Cache Filter Details
Use this procedure to view the details of a cache filter. For an introduction to cache
concepts, please see Understanding Cache, page 2-7.

Steps:
1. In the Performance tab, navigate to Cache >Applications > Filters, then click a

filter name in the table.

2. The page displays information about the cache filter’s responsibilities and languages.

3. If you want to edit the details of the cache filter, then click Edit. This opens the page
where you edit the details of an existing cache filter.

Related Topics
Managing Cache Filters, page 8-2

Creating and Editing Cache Filters, page 8-3

Using Cache, page 8-1

Creating and Editing Cache Filters
When you create a new cache filter or modify an existing cache filter, you complete three
different screens. The following procedures guide you through each screen:

• Step 1: Editing Basic Information, page 8-4

• Step 2: Choosing Responsibilities, page 8-4

• Step 3: Choosing Languages, page 8-5

After you finish creating or editing a cache filter, you are automatically returned to the
main cache filters page.

For an introduction to cache concepts, please see Understanding Cache, page 2-7.
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Step 1: Editing Basic Information
Use this procedure to enter basic information about a cache filter. For an introduction to
cache concepts, please see Understanding Cache, page 2-7.

Steps:
1. In the Performance tab, navigate to Cache >Applications > Filters. If you are

creating a new filter, then click Create. If you are modifying an existing filter, then
click a policy name in the table and click Edit after the new page displays.

2. Type a filter name into the Filter Name field.

3. Type a description into the Description field.

4. Choose an application from the Application drop-down list.

5. Click Continue to save and move on to the next screen.

Related Topics
Step 2: Choosing Responsibilities, page 8-4

Step 3: Choosing Languages, page 8-5

Managing Cache Filters, page 8-2

Creating and Editing Cache Filters, page 8-3

Using Cache, page 8-1

Step 2: Choosing Responsibilities
Use this procedure to choose which responsibilities apply to a particular cache filter. For
an introduction to cache concepts, please see Understanding Cache, page 2-7.

Steps:
1. Select the name of a responsibility in one list and click > or < to move it to the

other list.

2. Repeat step 1 as desired.

3. If you want to move all Available Responsibilities to the Configured
Responsibilities list, then click >>.

4. If you want to move all Configured Responsibilities to the Available
Responsibilities list, then click <<.

5. Click Continue to save and move on to the next page.

Related Topics
Step 3: Choosing Languages, page 8-5

Managing Cache Filters, page 8-2

Creating and Editing Cache Filters, page 8-3

Using Cache, page 8-1
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Step 3: Choosing Languages
Use this procedure to choose which languages apply to a particular cache filter. For an
introduction to cache concepts, please see Understanding Cache, page 2-7.

Steps:
1. Select a language in one list and click > or < to move it to the other list.

2. Repeat step 1 as desired.

3. If you want to move all Available Languages to the Configured Languages list, then
click >>.

4. If you want to move all Configured Languages to the Available Languages list, then
click <<.

5. If you are creating a new Cache Filter, then click Create to save.

6. If you are updating an existing Cache Filter, then click Update to save.

Related Topics
Managing Cache Filters, page 8-2

Creating and Editing Cache Filters, page 8-3

Using Cache, page 8-1

Managing Component Caches
Use this procedure to manage component caches. The main page for component
caches is the starting point for viewing, creating, updating, and removing component
caches. Each application uses one or more component caches. For an introduction to
cache concepts, please see Understanding Cache, page 2-7.

Note: Before modifying a component cache, please ensure that the
corresponding code has already been modified.

Steps:
1. In the Performance tab, navigate to Cache > Components.

2. Choose an application from the drop-down list labeled View to choose which
component caches display.

3. If you want to create a component cache, then click Create. This opens the page
where you edit the details of a new component cache.

4. If you want to update a component cache, then click its name. This opens the page
where you edit the details of an existing component cache.

5. If you want to remove a component cache, then select the check box in the Remove
column.

6. Click Update to save.

Related Topics
Editing Component Cache Details, page 8-6
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Using Cache, page 8-1

Editing Component Cache Details
Use this procedure to edit the details of new or existing component caches. For an
introduction to cache concepts, please see Understanding Cache, page 2-7.

Note: Before modifying a component cache, please ensure that the
corresponding code has already been modified.

Steps:
1. In the Performance tab, navigate to Cache > Components, then either click Create

or click the name of a component cache in the table.

2. If you are creating a new component cache, then choose an application from the
Application drop-down list. If you are updating an existing component cache, then
you cannot edit this field.

3. If you are creating a new component cache, then type a component identifier into
the Component Identifier field. The component identifier should start with the
appropriate application shortcode. If you are updating an existing component
cache, then you cannot edit this field.

4. Type a component name into the Component Name field.

5. Type a description into the Description field.

6. Type into a loader class name into the Loader Class Name field.

Each component cache has an associated loader class that is used by the caching
framework to load the corresponding object into the cache, if it is not already in
the cache.

7. Choose Time to Live or Idle Time from the drop-down list.

The Time to Live is the maximum length of time for a cache to be considered
valid. The Idle Time is the maximum length of time for an object to go unused
before it is flushed from the cache.

1. Type a number of seconds, minutes, or hours into the text input field to edit
the Time to Live or Idle Time.

2. Choose seconds, minutes, or hours from the drop-down list.

8. If you are creating a new component cache, then select or deselect the check box
labeled Enable Security Group ID. The Security Group ID is used in the hosting
environments. If you are updating an existing component cache, then you cannot
edit this field.

9. Select or deselect the check box labeled Enable Statistics Collection. Enabling
statistics collection can slow the cache down. Use it if there are problems with using
the cache or if you need to check the cache efficiency.

10. Select or deselect the check box labeled Distributed Mode. Distributed Mode means
that object updates are propagated across computers and across Java VMs.

11. Select or deselect the check box labeled HTML Platform Component. HTML
Platform Components are generic caches that are common to all
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applications. Usually, you only select this check box for JTF component caches. It is
merely a logical grouping that does not change the assigned application.

12. If you are creating a new component cache, then click Create to save.

13. If you are updating an existing component cache, then click Update to save.

Related Topics
Managing Component Cache, page 8-5

Using Cache, page 8-1

Viewing Cache Statistics
Use this procedure to view statistics about caches. For an introduction to cache
concepts, please see Understanding Cache, page 2-7.

Steps:
1. In the Performance tab, navigate to Cache > Statistics.

2. Choose from the drop-down lists next labeled View to select which hosts and
applications have data about them displayed below.

3. You can use these statistics to configure the component caches based on how
each component cache is performing. You can interpret the data to decide how
effective the component caches are and whether or not they should be disabled. For
example, if the cache has a high hit ratio, then the cache is useful and should not be
disabled.

Related Topics
Using Cache, page 8-1

Using the Cache Subtab 8-7





9
Using the Declarative Page Flows Subtab

Using Declarative Page Flows
The Introduction page for Declarative Flows is the starting point for setting up and
using Declarative Page Flows. The Declarative Page Flows framework enables you to
customize, upgrade, and troubleshoot the content and flow of JSPs, without having to
modify code. The key concept of the framework involves the abstraction of JSPs into
named logical entities, called Logical Pages. The components of the Declarative Page
Flows framework are Physical Pages, Logical Pages, Rules, and Business Flows.

You can perform the following tasks from the Declarative Page Flows subtab:

• Managing Physical Pages, page 9-1

• Editing Physical Page Details, page 9-2

• Managing Logical Pages, page 9-3

• Editing Logical Page Details, page 9-3

• Managing Rules, page 9-4

• Editing Rule Details, page 9-5

• Managing Business Flows, page 9-6

• Editing Business Flow Details, page 9-7

• Creating Flow Branches, page 9-8

• Duplicating Flows, page 9-9

• Viewing Flow Versions, page 9-10

For an introduction to Declarative Page Flows concepts, please see Understanding
Declarative Page Flows, page 2-8.

Managing Physical Pages
The main page for Physical Pages is the starting point for viewing, registering, and
updating Physical Pages. Physical Pages are JavaServer Pages (JSPs). Use this procedure
to manage Physical Pages. For an introduction to Declarative Page Flows concepts, please
see Understanding Declarative Page Flows, page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Physical Pages.
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2. If you want to change which Physical Pages display in the table, then:

1. To make Physical Pages from all applications to display in the table, then choose
All from the drop-down list at the top of the table.

2. If you want to filter the table by application, then choose a module prefix from
the drop-down list labeled View at the top of the table.

3. If you want to search the table of Physical Pages, then type the name of a Physical
Page or part of the name of a Physical Page into the text input field.

Optionally, use the percent sign (%) as a wild card in your search phrase. For
example, the search phrase "sales%" returns the Physical Pages whose names
begin with "sales." Alternatively, the search phrase "%sales" returns the Physical
Pages whose names end with "sales." The search phrase "sales" returns the
Physical Page named "sales."

4. Click Go. The results display in the table.

3. If you want to register a Physical Page, then click Create. This opens the page where
you edit the details of a new Physical Page.

4. If you want to update an existing Physical Page, then click its name in the table. This
opens the page where you edit the details of an existing Physical Page.

Related Topics
Editing Physical Page Details, page 9-2

Using Declarative Page Flows, page 9-1

Editing Physical Page Details
On the details page for Physical Pages, you complete the procedures of either registering
or updating Physical Pages. Use this procedure to edit the details of new or existing
Physical Pages. For an introduction to Declarative Page Flows concepts, please see
Understanding Declarative Page Flows, page 2-8.

Steps :
1. In the Design tab, navigate to Declarative Page Flows > Physical Pages, then either

click Create to register a new page or click the name of a JSP to modify its details.

2. Type into the Name field to edit the name of the Physical Page.

3. Type into the Description field to edit the description of the Physical Page. This
field is optional.

4. If you are registering a new Physical Page, then choose an application from the
Application drop-down list. If you are updating an existing Physical Page, then you
cannot edit this field. It is permanently set when you create the Physical Page.

5. If you are registering a new Physical Page, then click Create to save.

6. If you are updating an existing Physical Page, then click Update to save.

Related Topics
Managing Physical Pages, page 9-1
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Using Declarative Page Flows, page 9-1

Managing Logical Pages
The main page for Logical Pages is the starting point for viewing, creating, and updating
Logical Pages. Logical Pages can be utilized either stand-alone or to represent nodes
in a Business Flow. One or more Physical Pages map to each Logical Page. Use this
procedure to manage Logical Pages. For an introduction to Declarative Page Flows
concepts, please see Understanding Declarative Page Flows, page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Logical Pages.

2. If you want to change which Logical Pages display in the table, then:

1. If you want to allow Physical Pages from all applications to display in the
table, then choose All from the drop-down list labeled View at the top of the
table.

2. If you want to filter the table by application, then choose a module prefix from
the drop-down list labeled View at the top of the table.

3. If you want to search the table of Physical Pages, then type the name of a Physical
Page or part of the name of a Physical Page into the text input field.

Optionally, use the percent sign (%) as a wild card in your search phrase. For
example, the search phrase "sales%" returns the Physical Pages whose names
begin with "sales." Alternatively, the search phrase "%sales" returns the Physical
Pages whose names end with "sales." The search phrase "sales" returns the
Physical Page named "sales."

4. Click Go. The results display in the table.

3. If you want to create a Logical Page, then click Create. This opens the page where
you edit the details of a new Logical Page.

4. If you want to update an existing Logical Page, then click its name in the table. This
opens the page where you edit the details of an existing Logical Page.

Related Topics
Editing Logical Page Details, page 9-3

Using Declarative Page Flows, page 9-1

Editing Logical Page Details
On the details page for Logical Pages, you complete the procedures of either creating or
updating Logical Pages. Use this procedure to edit the details of new or existing Logical
Pages. For an introduction to Declarative Page Flows concepts, please see Understanding
Declarative Page Flows, page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Logical Pages, then either

click Create or click a page name in the table.
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2. Type into the Name field to edit the name of the Logical Page.

3. Type into the Description field to edit the description of the Logical Page. This
field is optional.

4. If you are creating a new Logical Page, then choose an application from the
Application drop-down list. If you are updating an existing Logical Page, then you
cannot edit this field. It is permanently set when you create the Rule.

5. Edit the Page Controller field if you do not want to use the default Java class which
is prefilled in the field. The class designated here implements the Logical Page
Controller interface and provides values to evaluate Rules.

6. Type into the Default Physical Page field to edit the name of the Physical Page that
displays when none of the Rules evaluate to true. Optionally, click Go to choose
from a list of values.

7. Edit the Page Display Rules table; one row in the table represents one Rule:

1. Type into the Sequence column to edit the order in which the Rules are
evaluated.

2. Type into the Rule Name column to edit the name of the Rule. Optionally, click
Go to choose from a list of values.

3. Type into the Description column to edit the description of the Rule.

4. Type into the Physical column to edit the name of the Physical Page that is
associated with the Rule. Optionally, click Go to choose from a list of values.

8. Repeat step 7 as desired.

9. Optionally, click Add Rows to add empty rows to the table.

10. If you are creating a new Logical Page, then click Create to save.

11. If you are updating an existing Logical Page, then click Update to save.

Related Topics
Managing Logical Pages, page 9-3

Using Declarative Page Flows, page 9-1

Managing Rules
The main page for Rules is the starting point for viewing, creating, and updating
Rules. In the context of a Logical Page, Rules determine either what Physical Page needs
to be rendered or what Logical Page displays next. Use this procedure to manage
Rules. For an introduction to Declarative Page Flows concepts, please see Understanding
Declarative Page Flows, page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Rules.

2. If you want to change which Rules display in the table, then:

1. If you want Rules from all applications to display in the table, then choose All
from the drop-down list labeled View at the top of the table.
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2. If you want to filter the table by application, then choose a module prefix from
the drop-down list labeled View at the top of the table.

3. If you want to search the table of Rules, then type the name of a Rule or part of
the name of a Rule into the text input field.

Optionally, use the percent sign (%) as a wild card in your search phrase. For
example, the search phrase "sales%" returns the Rules whose names begin with
"sales." Alternatively, the search phrase "%sales" returns the Rules whose names
end with "sales." The search phrase "sales" returns the Rule named "sales."

4. Click Go. The results display in the table.

3. If you want to create a Physical Page, then click Create. This opens the page where
you edit the details of a new Rule.

4. If you want to update an existing Rule, then click its name in the table. This opens
the page where you edit the details of an existing Rule.

Related Topics
Editing Rule Details, page 9-5

Using Declarative Page Flows, page 9-1

Editing Rule Details
On the details page for Rules, you complete the procedures of either creating or
updating Rules. Use this procedure to edit the details of new or existing Rules. For an
introduction to Declarative Page Flows concepts, please see Understanding Declarative
Page Flows, page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Rules, then either click

Create or click a Rule name in the table.

2. Type into the Name field to edit the name of the Rule. If you are working with an
existing Rule, then you cannot edit this field.

3. Type into the Description field to edit the description of the Rule. This field is
optional.

4. If you are creating a new Rule, then choose an application from the Application
drop-down list. If you are updating an existing Rule, then you cannot edit this
field. It is permanently set when you create the Rule.

5. Edit the Rule Conditions table; one row in the table represents one Rule Condition:

1. Type a parameter into the Parameter column.

2. Choose an operator from the drop-down list in the Condition column.

3. Type a value into the Value column.

6. Repeat step 5 as desired.

7. Optionally, click Add Rows to add empty rows to the table.

8. If you are creating a new Rule, then click Create to save.

9. If you are updating an existing Rule, then click Update to save.
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Related Topics
Managing Rules, page 9-4

Using Declarative Page Flows, page 9-1

Managing Business Flows
The main page for Business Flows is the starting point for viewing, creating, updating,
previewing, and cloning Business Flows. Business Flows are page display sequences
that address specific business processes. For example, you can create a Business Flow
for the process of purchasing an item from an online store, or you can create a Business
Flow for the process of resolving a user’s service request. Business Flows can be either
linear or branched in structure. Use this procedure to manage Business Flows. For an
introduction to Declarative Page Flows concepts, please see Understanding Declarative
Page Flows, page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Business Flows.

2. If you want to change which Business Flows display in the table, then:

1. If you want Business Flows from all applications to display in the table, then
choose All from the drop-down list labeled View at the top of the table.

2. If you want to filter the table by application, then choose a module prefix from
the drop-down list labeled View at the top of the table.

3. If you want to search the table of Business Flows, then type the name of a
Business Flow or part of the name of a Business Flow into the text input field.

Optionally, use the percent sign (%) as a wild card in your search phrase. For
example, the search phrase "sales%" returns the Business Flows whose names
begin with "sales." Alternatively, the search phrase "%sales" returns the Business
Flows whose names end with "sales." The search phrase "sales" returns the
Business Flow named "sales."

4. Click Go. The results display in the table.

3. To update an existing Business Flow, click its name in the table.

4. To create a branch in this Business Flow, click the icon in the Create Flow Branch
column.

5. To preview an existing Business Flow, click the icon in the Preview column.

6. To view the different versions of a flow, then click the icon in the View Versions
column.

7. If you want to create a Business Flow, then click Create Flow.

8. If you want to create a duplicate of a flow, then click Duplicate Flow.

Related Topics
Editing Business Flow Details, page 9-7

Creating Flow Branches, page 9-8

Duplicating Flows, page 9-9
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Viewing Flow Versions, page 9-10

Using Declarative Page Flows, page 9-1

Editing Business Flow Details
On the details page for Business Flows, you can edit the basic settings of new or existing
Business Flows. After using this page, you can open the Map Flows page to define the
conditional branches in the Business Flow. Use one of the following procedures:

• Creating a New Business Flow, page 9-7

• Updating an Existing Business Flow, page 9-8

For an introduction to Declarative Page Flows concepts, please see Understanding
Declarative Page Flows, page 2-8.

Creating a New Business Flow
Use this procedure to edit the basic settings of a new business flow. For an introduction
to Declarative Page Flows concepts, please see Understanding Declarative Page Flows,
page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Business Flows, then

click Create.

2. Type a flow name into the Name field.

3. Choose an application from the Application drop-down list.

4. Optionally, type a description into the Description field.

5. Optionally, select the Secure check box if the flow is to use HTTPS.

6. Edit the Finalization Class field if you want use a Java class other than the default
Finalization Class (which is prefilled in the field). The class designated here
implements the FlowFinalizer interface and executes at the end of the Business Flow.

7. Type the name of the Logical Page that should be invoked after the completion of the
flow into the Page to Display After Completing the Flow field. Optionally, click Go
to choose from a list of values.

8. Type the name of the first Logical Page in the flow into the First Page of the Flow
field. Optionally, click Go to choose from a list of values.

9. Optionally, edit the Default Flow Sequence table; if the flow you are creating
is linear, then complete this table. If the flow you are creating has conditional
branches, then proceed to step 10.

1. Type numbers into the Sequence fields to indicate the page order within the flow.

2. Click Go to choose a Logical Page to set as the Next Logical. When you make
your choice, the Next Logical and Description fields will automatically fill.

3. Repeat step b as desired. If needed, click Add Rows to add additional rows
to the table.

10. Click Create to save.
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11. Click Create Flow Branch. This opens the page where you define the conditional
branches of a nonlinear flow.

12. Optionally, click View Flow Versions to view all the versions of this business flow.

Related Topics
Managing Business Flows, page 9-6

Using Declarative Page Flows, page 9-1

Updating an Existing Business Flow
Use this procedure to edit the basic settings of an existing business flow. For an
introduction to Declarative Page Flows concepts, please see Understanding Declarative
Page Flows, page 2-8.

Steps:
1. In theDesign tab, navigate toDeclarative Page Flows > Business Flows, then click a

flow name in the table.

2. Optionally, type a flow description into the Description field.

3. Optionally, select the Secure check box if the flow is to use HTTPS.

4. Type the name of the Finalization Class into the Finalization Class field. This is the
name of a Java class. The class implements the FlowFinalizer interface and executes
at the end of the Business Flow.

5. Type the name of the Logical Page that should be invoked after the completion of the
flow into the Page to Display after Completing the Flow field. Optionally, click Go
to choose from a list of values.

6. Type the name of the first Logical Page in the flow into the First Page of the Flow
field. Optionally, click Go to choose from a list of values.

7. If the flow you are working with is linear (does not contain any conditional
branches), then you can define the flow sequence in the Default Flow table.

8. Click Update to save.

9. If the flow you are working with is nonlinear (contains one or more conditional
branches), then click Create Flow Branch to begin defining the branches of the flow.

10. To view the different versions of this flow, click View Flow Versions.

Related Topics
Managing Business Flows, page 9-6

Using Declarative Page Flows, page 9-1

Creating Flow Branches
Business Flows are page display sequences that address specific business processes. The
Create Flow Branch page allows you to define conditional branches within nonlinear
business flows. Use this procedure to set the sequences of Logical Pages within
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Business Flows. For an introduction to Declarative Page Flows concepts, please see
Understanding Declarative Page Flows, page 2-8.

Steps:
1. Choose a Logical Page from the Current Logical drop-down list. The Current Logical

Page is the name of the Logical Page that you are setting up on this screen. After
you save your work, you can repeat this entire procedure with another Logical
Page within the Business Flow.

2. In the Default Next Logical field, type the name of the Logical Page that displays
if there are no Rules in the table below, or if none of the Rules in the table below
evaluate to "true." Optionally, click Go to choose from a list of values.

3. Edit the Logical Node Rules table.

1. Type numbers into the Sequence fields to set the order in which the Rules are
evaluated.

2. In the Next Logical fields, type the name of the Logical Page that you want
to display after the Current Logical Page, only if the Rule in the next column
evaluates to "true." Optionally, click Go to choose from a list of values.

3. In the Rule Name fields, type name of the Rule that controls whether or not the
Logical Page in the previous column displays. Optionally, click Go to choose
from a list of values.

4. Optionally, click Add Rows to add empty rows to the table.

5. If you are creating a new Current Logical Page setup, then click Create to save. This
opens another Create Flow Branch page where you can repeat this entire procedure
with another Current Logical Page.

6. If you are updating an existing Flow Branch setup, then click Update to save. This
opens another Create Flow Branch page where you can repeat this entire procedure
with another Current Logical Page.

7. If you have no more Current Logical Pages to set up, then click Finish. This
completes the procedures of either creating or updating Business Flows.

Related Topics
Managing Business Flows, page 9-6

Using Declarative Page Flows, page 9-1

Duplicating Business Flows
Use this procedure to duplicate business flows. For an introduction to Declarative Page
Flows concepts, please see Understanding Declarative Page Flows, page 2-8.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Business Flows, then

click Duplicate Flow.

2. ClickGo to choose the flow from a list of values. Edit the name of the flow if desired.

3. Click Duplicate to generate a duplicate of the flow. The Flow Details page
automatically opens, where you can edit the details of the duplicate flow.
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Related Topics
Managing Business Flows, page 9-6

Using Declarative Page Flows, page 9-1

Viewing Flow Versions
Use this procedure to view all of the versions of a given business flow. For an
introduction to Declarative Page Flows concepts, please see Understanding Declarative
Page Flows, page 2-8.

Steps:
1. Choose which of the flows will be "active" by selecting the appropriate radio button

in the table.

2. Click Update to save.

3. Optionally, click a flow name in the table.

This opens the page where you can edit the basic details of an existing flow.

Related Topics
Managing Business Flows, page 9-6

Using Declarative Page Flows, page 9-1
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Using the Declarative Components Subtab

Using Declarative Components
The Declarative Components framework enables you to quickly develop
bins, graphs, reports, graph/report combinations, and LOVs that can be personalized by
end users. Key features of the Declarative Components framework include the uniform
look and feel of all UI components, compatibility with multiple data sources, and built in
security.

You can perform the following tasks from the Declarative Components subtab:

• Managing Components, page 10-2

• Previewing Components, page 10-2

• Registering Components, page 10-3

• Editing Component Metadata, page 10-4

• Defining Bin or Report Columns, page 10-6

• Editing Bin or Report Column Details, page 10-7

• Managing LOV Columns, page 10-8

• Editing LOV Column Details, page 10-9

• Defining Graph Metadata, page 10-11

• Managing Graph Columns, page 10-13

• Editing Graph Column Details, page 10-13

• Managing Parameters, page 10-14

• Editing Parameter Metadata, page 10-15

• Managing Component Security, page 10-17

• Assigning a Responsibility to Components, page 10-18

• Selecting Components, page 10-18

• Assigning a Component to Responsibilities, page 10-17

• Selecting Responsibilities, page 10-17

For an introduction to Declarative Components concepts, please see the topic
Understanding Declarative Components, page 2-9.
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Managing Components
The main page for Declarative Components is the starting point for
viewing, creating, modifying, and previewing bins, graphs, reports, graph/report
combinations, and LOVs. Use this procedure to manage Declarative Components. For
an introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. In the Design tab, navigate to Declarative Components > Components.

2. If you want to change the contents of the table, then:

1. To filter the table by application, choose an application from the Application
drop-down list at the top of the page.

2. To filter the table by component type, then choose All or a component type from
the drop-down list at the top of the page.

3. If you want to search by component code, then type the component code into the
text entry field and click Go.

The wild card character (%) is allowed. The search is case sensitive.

4. Click First, Previous, Next, and Last to navigate within the table.

3. If you want to create a component, then click Create. This opens the page where
you register a new component.

4. If you want to preview a component, then click Preview. This opens the page where
you preview a component.

5. If you want to update or modify a component, then click its component code in the
table. This opens the page where you update the registration of a component.

6. If you want to set the status of a component, then:

1. In the Action column, choose Remove, Enabled, or Disabled.

Removing a component deletes it. You cannot delete a LOV component if it is
being used by other components. Enabling a component makes it available for
display. Disabling a component makes it unavailable for display or for selection
from the homepage.

2. Click Update to save.

Related Topics
Previewing Components, page 10-2

Registering Components, page 10-3

Using Declarative Components, page 10-1

Previewing Components
Use this procedure to preview a declarative component. For an introduction to
Declarative Components concepts, please see the topic Understanding Declarative
Components, page 2-9.
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Steps:
1. In the Design tab, navigate to Declarative Components > Components, then click

Preview.

2. View the preview.

In the case of a LOV component, the Preview does not have validations. Use the
wildcard character (%) in the text entry field.

3. When you are finished, click OK to return to the main components page.

Related Topics
Managing Components, page 10-2

Registering Components, page 10-3

Using Declarative Components, page 10-1

Registering Components
Use this procedure to edit the registration details of a new or existing component. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. In the Design tab, navigate to Declarative Components > Components, then either

click Create or click a component code in the table.

2. If you are creating a new component, then choose an application from the
Application drop-down list at the top of the page. If you are updating an existing
component, this field is not editable.

3. If you are creating a new component, then choose Bin, Report, Graph, Graph
Report, or LOV from the Component Type drop-down list. If you are updating an
existing component, this field is not editable.

4. If you are creating a new component, then type a component code into the
Component Code field. If you are updating an existing component, this field is
not editable.

The maximum length of a component code is 26 characters. A component code must
be unique and it cannot contain any spaces or nonalphanumeric characters except
underscore (_). It is recommended to prefix the component code with the application
short name. For example, JTF_component_code.

5. Type a descriptive component name into the Component Name field.

6. Optionally, type a description into the Description field.

If you want to enable the component, then select the Enable check box. If you want
to disable the component, then deselect the Enable check box. Enabling a component
makes it available for display. Disabling a component makes it unavailable for
display or for selection from the homepage.

7. If you want to allow the component to be a candidate for display as a Portlet in
Oracle Portal, then select the Show as Portlet check box. If you deselect this check
box, then the component will not be shown in the list of available components for
Portlet enabling.
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8. Optionally, type an image filename into the Image Filename field.

If defined, this image is displayed with the Bin Title. The image that you specify
must exist in the image file location (/OA_MEDIA/).

9. Ignore theMetadata Source area. The only choice for the Type field is AK. The
Declarative Components framework uses the AK Runtime Dictionary to store
metadata.

10. Optionally, click Restore to restore the fields to their original settings.

11. Click Update to save.

12. Click Next. This opens the page where you can begin editing the metadata
associated with this component.

Related Topics
Managing Components, page 10-2

Editing Component Metadata, page 10-4

Using Declarative Components, page 10-1

Editing Component Metadata
Use this procedure to edit the Pre-Process type, Data Source, Title, and other general
settings (such as headers and footers) of a new or existing Declarative Component. This
procedure takes place after you have completed the Registering Components, page 10-3
procedure. For an introduction to Declarative Components concepts, please see the topic
Understanding Declarative Components, page 2-9.

Steps:
1. Edit the Pre-Process area:

1. If you want to execute a PL/SQL procedure or Java method before the Declarative
Components framework extracts the data content for this component, then
choose Java Class Name or PL/SQL Procedure from the Type drop-down list.

If you do not require a preprocessing event, then leave this field blank and skip
to step 2.

2. Type the preprocessing PL/SQL procedure or Java method into the Name
field. The procedure name should be of the format procedure_name.package_name,
where the package name is the fully qualified package name.

2. Edit the Data Source Provider area:

1. If you are editing a Bin, Report, Graph, or Graph Report, then choose
HTML, Class Name, or SQL Query from the Type drop-down list.

If you are editing a LOV component, then choose Class Name or SQL Query
from the drop-down list, as the valid data source types for LOV components
are Java and SQL.

2. Type HTML code, a SQL query, or the name of a Java class that implements
the DataSource interface into the Name field. If you use a SQL query, then the
SELECT statement must not end with a semicolon (;).
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3. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Custom Edit
Link area. This feature is not available for LOVs.

1. If you do not want a Custom Edit Link, then leave this section blank and
skip to step 4. This generates the default Edit link that navigates you to the
Personalization and Runtime Parameter section.

2. If you want the Custom Edit Link to have a constant value, then choose Constant
from the Type drop-down list.

If you want the Custom Edit Link to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Type
drop-down list.

3. If the Custom Edit Link is constant, then type the name of the JSP file into the
Name field. If the Custom Edit Link is dynamically generated, then type the
name of the PL/SQL package.procedure or Java Class.method into the Name
field.

The PL/SQL procedure must take in a single DEFAULT NULL VARCHAR2
argument and return a VARCHAR2. The Java method should take in a
ParameterList and return a String.

4. If you do not want the Edit link to be generated, then choose Constant from in
the Type drop-down list and leave the Name field blank.

4. Edit the Title area:

1. If you want the component title to have a constant value, then choose Constant
from the Type drop-down list.

If you want the component title to be dynamically generated by a PL/SQL
procedure or Java method, then choose PL/SQL or Java from the Type
drop-down list.

2. If the component title is constant, then type the title text into the Name field. If
the component title is dynamically generated, then type the name of the PL/SQL
procedure or Java method into the Name field.

The PL/SQL procedure must return a value of the type VARCHAR2.

3. Choose Left, Right, or Center from the Alignment drop-down list to set how
the component title is aligned.

4. If you are editing a Bin, Report, Graph, or Graph Report and want to allow the
end user to personalize the component title, then select the check box labeled
Personalizable.

5. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Header
area. This feature is not available for LOVs.

1. If you want the header to have a constant value, then choose Constant from the
Type drop-down list.

If you want the header to be dynamically generated by a PL/SQL procedure or
Java method, then choose PL/SQL or Java from the Type drop-down list.

2. If the header is constant, then type the text into the Name field. If the header
is dynamically generated, then type the name of the PL/SQL procedure or Java
method into the Name field.

The PL/SQL procedure must return a value of the type VARCHAR2.
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3. Choose Left, Right, or Center from the Alignment drop-down list to set how
the header is aligned.

4. If you want to allow the end user to personalize the header, then select the check
box labeled Personalizable.

6. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Footer
area. This feature is not available for LOVs:

1. If you want the footer to have a constant value, then choose Constant from the
Type drop-down list.

If you want the footer to be dynamically generated by a PL/SQL procedure or
Java method, then choose PL/SQL or Java from the Type drop-down list.

2. If the footer is constant, then type the text into the Name field. If the footer is
dynamically generated, then type the name of the PL/SQL procedure or Java
method into the Name field.

The PL/SQL procedure must return a value of the type VARCHAR2.

3. Choose Left, Right, or Center from the Alignment drop-down list to set how the
footer is aligned.

4. If you want to allow the end user to personalize the footer, then select the check
box labeled Personalizable.

7. Click Update to save.

8. Optionally, click Next to save and move on to screens where you can further define
the columns and settings of the component.

Related Topics
Defining Bin or Report Columns, page 10-6

Managing LOV Columns, page 10-8

Defining Graph Metadata, page 10-11

Using Declarative Components, page 10-1

Dening Bin or Report Columns
Use this procedure to manage the columns in a new or existing bin or report
component. This does not apply to components with a HTML Data Source Type. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. To navigate to this page:

1. In the Design tab, navigate to Declarative Components > Components.

2. Locate your desired bin or report in the table. Click its component code in the
table.

3. Click the Next button, once on the Component Registration page and again on
the Component Metadata page to open the Component Columns page.
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2. Select or deselect the check box labeled Number Of Rows to enable or disable
allowing the end user to personalize the number of rows displayed.

3. Select or deselect the check box labeled Number Of Columns to enable or disable
allowing the end user to personalize the number of columns displayed.

4. If you want to set the status of a column, then choose Enabled or Disabled from the
Action column. Enabling a component makes it available for display. Disabling a
component makes it unavailable for display.

5. Type integers into the Display Order column to set the display order (from left to
right) of the columns in the Bin or Report. Make sure that the values of this field
are sequential.

6. Click Update to save.

7. Optionally, click Next. This opens the page where you manage the parameters of
the component.

8. If you want to edit the details of a column, then click its name in the table. This
opens the page where you edit the details of a column.

Related Topics
Editing Bin or Report Column Details, page 10-7

Managing Parameters, page 10-14

Using Declarative Components, page 10-1

Editing Bin or Report Column Details
Use this procedure to edit the details of columns in bin or report components. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. To navigate to this page:

1. In the Design tab, navigate to Declarative Components > Components.

2. Locate your desired bin or report in the table. Click its component code in the
table.

3. Click the Next button, once on the Component Registration page and again on
the Component Metadata page to open the Component Columns page.

4. Click a column name in the table to open the column details page.

2. Optionally, type a brief description of the column into the Description field.

3. Type an integer into the Display Order field to set the display order of the column.

4. Edit the Label area:

1. If you want the column label to have a constant value, then choose Constant
from the Type drop-down list.

If you want the column label to be dynamically generated by a PL/SQL procedure
or Java method, then choose PL/SQL or Java from the Type drop-down list.
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2. If the column label is constant, then type the text into theMethod field. If the
column label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into theMethod field.

The PL/SQL procedure must return a value of the type VARCHAR2. The Java
method must be of the format ClassName.MethodName.

3. Choose Left, Right, or Center from theHorizontal Alignment drop-down list to
set how the column label is aligned.

4. Select the check box labeled Raw Column if you want to display the column
as a raw column.

5. If you selected the Raw Column check box, then type the appropriate URL
into the URL field.

6. Choose the name of the ID column associated with the hyperlink from the ID
column drop-down list.

7. Type a value into the Low Watermark field. When the component is
displayed, any values below the LowWatermark value will display in a negative
color.

8. Type a value into the High Watermark field. When the component is
displayed, any values above the High Watermark value will display in a positive
color.

5. Click Update to save.

6. Click Component Columns to return to the page that lists the component’s columns.

Related Topics
Defining Bin or Report Columns, page 10-6

Using Declarative Components, page 10-1

Managing LOV Columns
Use this procedure to manage the columns in a new or existing LOV component. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

The LOVs that you create can be used across applications. LOV means "list of values."
It is a UI component that facilitates the completion of a text entry field when there are
numerous values that may be assigned. LOVs are a useful alternative to drop-down
lists, particularly in cases where displaying a long list of selections in a drop-down list
would require excessive scrolling.

In short, when using a LOV to complete a text entry field, you type a query into the
field and then click a button labeled Go. This opens a screen where you view a list
of values that match the query you submitted. You can then select the value that you
desire and return to the original screen, where what you selected will populate the
original text entry field.

Steps:
1. To navigate to this page:

1. In the Design tab, navigate to Declarative Components > Components.
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2. Locate your desired LOV in the table. Click its component code in the table.

3. Click the Next button, once on the Component Registration page and again on
the Component Metadata page to open the LOV Columns List page.

2. Choose a radio button in the Select column of the table to specify that column as
searchable.

3. Choose Enabled or Disabled from the Action column in the table to make the
column available or unavailable for display.

4. Type an integer into the Display Order field to set the display order of the
column. Make sure that the values of this field are sequential.

5. Click Update to save. Note that you do not define parameters for LOV components.

6. If you want to edit the details of a column, then click its name in the table. This
opens the page where you edit the details of a column.

Related Topics
Editing LOV Column Details, page 10-9

Using Declarative Components, page 10-1

Editing LOV Column Details
Use this procedure to edit the details of columns in a new or existing LOV
component. For an introduction to Declarative Components concepts, please see the
topic Understanding Declarative Components, page 2-9.

The LOVs that you create can be used across applications. LOV means "list of values."
It is a UI component that facilitates the completion of a text entry field when there are
numerous values that may be assigned. LOVs are a useful alternative to drop-down
lists, particularly in cases where displaying a long list of selections in a drop-down list
would require excessive scrolling.

In short, when using a LOV to complete a text entry field, you type a query into the
field and then click a button labeled "Go." This opens a screen where you view a list
of values that match the query you submitted. You can then select the value that you
desire and return to the original screen, where what you selected will populate the
original text entry field.

Steps:
1. To navigate to this page:

1. In the Design tab, navigate to Declarative Components > Components.

2. Locate your desired LOV in the table. Click its component code in the table.

3. Click the Next button, once on the Component Registration page and again on
the Component Metadata page to open the LOV Columns List page.

4. Click a column name in the table to open the column details page.

2. Optionally, type a brief description of the column into the Description field.

3. Type an integer into the Display Order field to set the display order of the column.

Using the Declarative Components Subtab 10-9



4. Choose a column type of Date, Number, or Varchar2 from the Column Type
drop-down list.

5. If the column is searchable on the main LOV columns page, then the check box fields
for Display and Carry Over are automatically selected and cannot be deselected. If
the column is not searchable on the main LOV columns page, then you can select or
deselect these two check boxes.

6. Edit the Label area:

1. If you want the column label to have a constant value, then choose Constant
from the Type drop-down list.

If you want the column label to be dynamically generated by a PL/SQL procedure
or Java method, then choose PL/SQL or Java from the Type drop-down list.

2. If the column label is constant, then type the text into theMethod field. If the
column label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into theMethod field.

The PL/SQL procedure must return a value of the type VARCHAR2. The Java
method must be of the format ClassName.MethodName.

7. If the column is searchable on the main LOV columns page, then you will see a
section for Validation Rules. If the column is not searchable on the main LOV
columns page, then this feature is not available.

1. If you want to choose a Javascript Validation Type, then select Error orWarning
from the drop-down list. Otherwise, leave the field blank.

2. In theMin. Characters field, type an integer representing the minimum number
of characters the user is required to submit when using the LOV component.

3. In theMin. Characters before % field, type an integer representing the
minimum number of characters the user is required to submit before the
wildcard character (%) when using the LOV component.

4. Select or deselect the Auto Append % check box to choose whether or not to
automatically append any queries submitted by the user with the wildcard
character (%).

5. If you want to specify the case of the value when it populates the original
text entry field, then choose Lowercase or Uppercase from the Change Case
drop-down list.

8. Click Update to save. Note that you do not define parameters for LOV components.

9. Optionally, click LOV Column List to return to the page that lists the component’s
columns.

Related Topics
Managing LOV Columns, page 10-8

Using Declarative Components, page 10-1
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Dening Graph Metadata
Use this procedure to edit the X-axis, Y-axis, and other basic settings of a new or existing
graph component. For an introduction to Declarative Components concepts, please see
the topic Understanding Declarative Components, page 2-9.

Steps:
1. To navigate to this page:

1. In the Design tab, navigate to Declarative Components > Components.

2. Locate your desired graph or graph-report in the table. Click its component
code in the table.

3. Click the Next button, once on the Component Registration page and again on
the Component Metadata page to open the Graph Metadata page.

2. Optionally, type a description of the graph into the Description field.

3. If you want the graph title to have a constant value, then choose Constant from
the Type drop-down list.

If you want the graph title to be dynamically generated by a PL/SQL procedure or
Java method, then choose PL/SQL or Java from the Type drop-down list.

4. If the graph title is constant, then type the text into theMethod field. If the column
label is dynamically generated, then type the name of the PL/SQL procedure or Java
method into theMethod field.

The PL/SQL procedure must return a value of the type VARCHAR2. The Java
method must be of the format ClassName.MethodName.

5. Choose a graph type from the Graph Type drop-down list.

6. If you want to allow the end user to personalize the graph type, then select the
check box labeled Allow Personalization?

7. If you want the graph to display in 2D, then select the check box labeled Display in
2-D?

8. If you want to display or not display a grid, then choose an option from the Display
Grid drop-down list.

9. To set how the graph legend displays, choose an option from the Graph Legend
drop-down list. Set the position of the graph legend in the Legend Position
drop-down list.

10. Type pixel values into the Graph Height and Graph Width fields.

11. Type a number into the Graph Color field to set the graph color.

12. Edit the X-axis section:

1. If you want the X-axis label to have a constant value, then choose Constant
Value from the Label Type drop-down list.

If you want the X-axis label to be dynamically generated by a PL/SQL procedure
or Java method, then choose PL/SQL or Java from the Label Type drop-down
list.
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2. If the X-axis label is constant, then type the text into theMethod field. If the
X-axis label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into theMethod field.

The PL/SQL procedure must return a value of the type VARCHAR2. The Java
method must be of the format ClassName.MethodName.

3. Choose Vertical, Horizontal or Slanting from the Tick Label Orientation
drop-down list.

Vertical orientation tilts the tick label 90 degrees. Horizontal orientation tilts the
tick label 180 degrees. Slanted orientation tilts the tick label 270 degrees.

4. Choose the amount of tick labels you want to display in the Tick Label Interval
drop-down list.

13. Edit the Y-axis section:

1. If you want the Y-axis label to have a constant value, then choose Constant Value
from the Label Type drop-down list.

If you want the Y-axis label to be dynamically generated by a PL/SQL procedure
or Java method, then choose PL/SQL or Java from the Label Type drop-down
list.

2. If the Y-axis label is constant, then type the text into theMethod field. If
the Y-axis label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into theMethod field.

The PL/SQL procedure must return a value of the type VARCHAR2. Java
method must be of the format ClassName.MethodName.

3. Choose Vertical, Horizontal or Slanting from the Tick Label Orientation
drop-down list.

Vertical orientation tilts the tick label 90 degrees. Horizontal orientation tilts the
tick label 180 degrees. Slanted orientation tilts the tick label 270 degrees.

4. To display the Y-axis as currency, select the Display Currency? check box.

5. Choose Yes or No from the Auto Scaling drop-down list.

If you choose Yes, then the minimum and maximum values displayed on
the Y-axis are determined by BI Beans, depending on the graph data. If you
choose No, then the minimum and maximum values displayed on the Y-axis
are specified manually.

6. If you chose No in step d, then type an integer into the Tick Interval field to
specify the interval on the Y-axis scale.

7. If you chose No in step d, then enter integers into theMinimum Value and
Maximum Value fields.

14. Click Update to save.

15. ClickNext to open the page where you manage the columns of the graph component.

Related Topics
Managing Graph Columns, page 10-13

Editing Graph Column Details, page 10-13
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Using Declarative Components, page 10-1

Managing Graph Columns
Use this procedure to view, update, and remove columns in a graph component. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. To navigate to this page:

1. In the Design tab, navigate to Declarative Components > Components.

2. Locate your desired graph or graph-report in the table. Click its component
code in the table.

3. Click the Next button, once on the Component Registration page and again on
the Component Metadata page to open the Graph Metadata page.

4. Click Next a third time to open the Graph Columns page.

2. If you want to set the status of a column, then choose Enabled or Disabled from
the Action column.

Enabling a component makes it available for display. Disabling a component makes
it unavailable for display.

3. For each column, choose X-axis, Y-axis, or SubX-axis from the Axis drop-down list.

4. Type integers into the Sequence fields to set the sequence of the columns.

5. Click Update to save.

6. Optionally, click Next.

This opens the page where you manage the parameters of the component.

7. If you want to edit the details of a column, then click its name in the table.

This opens the page where you edit the details of a column.

Related Topics
Managing Parameters, page 10-14

Editing Graph Column Details, page 10-13

Using Declarative Components, page 10-1

Editing Graph Column Details
Use this procedure to edit the details of new or existing columns in graph
components. For an introduction to Declarative Components concepts, please see the
topic Understanding Declarative Components, page 2-9.

Steps:
1. To navigate to this page:

1. In the Design tab, navigate to Declarative Components > Components.
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2. Locate your desired graph or graph-report in the table. Click its component
code in the table.

3. Click the Next button, once on the Component Registration page and again on
the Component Metadata page to open the Graph Metadata page.

4. Click Next a third time to open the Graph Columns page.

5. Click a column name in the table.

2. Optionally, type a description into the Description field.

3. Edit the Label section:

1. If you want the column label to have a constant value, then choose Constant
Value from the Type drop-down list.

If you want the column label to be dynamically generated by a PL/SQL procedure
or Java method, then choose PL/SQL or Java from the Type drop-down list.

2. If the column label is constant, then type the text into theMethod field. If the
column label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into theMethod field.

The PL/SQL procedure must return a value of the type VARCHAR2. The Java
method must be of the format ClassName.MethodName.

4. Edit the Axis section:

1. Choose X-axis, Y-axis, or SubX-axis from the Plot drop-down list.

2. Type the appropriate integer into the Sequence field.

The sequence number is with respect to axis information. It is the indexing
information for columns mapped on the same axis. For example, if COL1 and
COL3 are plotted on the Y-axis, then they should have the sequence numbers
1 and 2, respectively. COL2 plotted on the X-axis should have the sequence
number 1.

5. Click Update to save.

6. Click Graph Columns to return to the page that lists the component’s columns.

Related Topics
Managing Graph Columns, page 10-13

Using Declarative Components, page 10-1

Managing Parameters
Use this procedure to create, update, and remove component parameters. You can define
date pickers (calendars), text input fields, drop-down lists, multi-select lists, and hidden
fields. For an introduction to Declarative Components concepts, please see the topic
Understanding Declarative Components, page 2-9.

Steps:
1. You reach this page by clicking Next from the column summary page of a

component. Please see Defining Bin or Report Columns, page 10-6 and Managing
Graph Columns, page 10-13.
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2. If you want to create a parameter, then click Create Parameter.

This opens the page where you edit the details of a new parameter.

3. If you want to delete a parameter, then select the appropriate check box in the
Remove column of the table.

4. Type integers into the Sequence fields to set the order in which the parameters will
be rendered. This order is also used in parameter value resolution.

5. Click Update to save.

6. If you want to edit the details of a parameter, then click its name in the table.

This opens the page where you edit the details of an existing parameter.

Related Topics
Using Declarative Components, page 10-1

Editing Parameter Metadata
Use this procedure to edit the details of a new or existing component parameter. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. You reach this page from the Component Parameters page: Click either a parameter

name or the Create Parameters button.

2. Type a unique parameter name into the Parameter Name field (this field is not
editable if you are working with a parameter that already has been defined).

3. Type a label for the parameter in to the Label field.

4. Select the Enable? check box if you want to enable the parameter.

5. Optionally, type a brief description into the Description field.

6. If you want the parameter to be rendered on the parameter page, then select the
check box labeled Enable.

7. If you want to allow the end user to personalize the parameter, then select the check
box labeled Personalizable.

8. Choose VARCHAR2, Number, or Date from the Parameter Data Type drop-down
list.

9. Choose Calendar, Drop Down, Hidden, LOV, Multiselect, or Text from the Item
Style drop-down list.

For drop-down lists, you are responsible for writing a well-tuned query that will
return the number of rows as recommended by the UI team. For hidden fields, the
end user will not see the parameter, but you can use the value as needed (for
example, passing ID columns).

10. If you chose the Item Style Drop Down in step 6, then type the appropriate source
SQL query into the SQL for Dropdown field.
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11. If you chose the Item Style LOV in step 6, then the screen refreshes to display
a section about LOV details. This section includes fields for LOV App Id, LOV
Component Code, andMapped LOV Column:

1. Choose an LOV App Id from the drop-down list. This is the application that
owns the LOV component. When you have chosen the application, the screen
refreshes to display a list of LOV components specific to that application.

2. Choose a LOV component from the list of available choices. The screen refreshes
to display the list of searchable columns that can be mapped to the current
parameter.

3. Choose the Searchable LOV column and map it to this parameter.

4. You may need to create additional parameters if you want to carry over ID
Columns.

12. If you chose the Item Style LOV in step 6 and there is a LOV parameter already
defined for this component, then the screen refreshes to display a drop-down list
called Related LOV Parameter. The drop-down list contains all the LOV parameters
that have been defined for this component:

1. Choose a LOV parameter as the Related LOV parameter. The screen refreshes to
display a list of the Carried Over Column(s) of the chosen LOV parameter.

2. TheMapped LOV Column drop-down list displays the LOV Columns that have
been defined to be carried over. Therefore, you can use the value of this Mapped
LOV Column, for example, in a Data Source Query.

13. If available, edit the Default Value Setting section:

1. Choose Constant, PL/SQL, or Java from the Type drop-down list.

2. If you chose Constant in step a, then type the text of the default value into the
Name field.

If you chose PL/SQL in step a, then type the complete signature of a PL/SQL
function, including any package name, into the Name field. This function must
return a Varchar2. For example, My_Package.Get_Default_Value(?P_Context).
Optionally, the function can take a p_context as an argument.

If you chose Java in step a, then type the signature of a Java method into the
Name field, in the format package_name.function_name. This method must return
a string.

14. Click Update to save.

15. Optionally, click Component Parameter to return to the page that lists the
component’s parameters.

Related Topics
Managing Parameters, page 10-14

Using Declarative Components, page 10-1
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Managing Component Security
Use this procedure to manage component security assignments. For an introduction
to Declarative Components concepts, please see the topic Understanding Declarative
Components, page 2-9.

Steps:
1. In the Design tab, navigate to Declarative Components > Component Security.

2. Choose a radio button, Component to Responsibilities or Responsibility to
Components.

3. Click Next.

This opens the page where you choose either the component that you will be
mapping to responsibilities or the responsibility that you will be assigning to
components.

Related Topics
Assigning a Component to Responsibilities, page 10-17

Assigning a Responsibility to Components, page 10-18

Using Declarative Components, page 10-1

Assigning a Component to Responsibilities
Use this procedure to assign a component to one or more responsibilities. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. In theDesign tab, navigate toDeclarative Components > Component Security, then

select the radio button labeled Component to Responsibilities.

2. Choose an application from the Application Code drop-down list.

3. Choose a component code from the Component Code drop-down list.

4. Click Next to continue.

Related Topics
Selecting Responsibilities, page 10-17

Managing Component Security, page 10-17

Using Declarative Components, page 10-1

Selecting Responsibilities
Use this procedure to select which responsibilities will apply to the component that you
have chosen. This procedure takes place after you have completed the Assigning a
Component to Responsibilities, page 10-17 procedure. For an introduction to Declarative
Components concepts, please see the topic Understanding Declarative Components,
page 2-9.
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Steps:
1. Choose the name of a responsibility in one list and click > or < to move it to the

other list.

2. Repeat step 1 as desired.

3. If you want to move all Available Responsibilities to the Selected Responsibilities
list, then click>>.

4. If you want to move all Selected Responsibilities to the Available Responsibilities
list, then click <<.

5. Optionally, choose an application from theResponsibility App Code drop-down list.

6. Optionally, click Restore to reset the fields to their original settings.

7. Click Update to save.

Related Topics
Managing Component Security, page 10-17

Using Declarative Components, page 10-1

Assigning a Responsibility to Components
Use this procedure to assign a responsibility to one or more components. For an
introduction to Declarative Components concepts, please see the topic Understanding
Declarative Components, page 2-9.

Steps:
1. In theDesign tab, navigate toDeclarative Components > Component Security, then

select the radio button labeled Responsibility to Components.

2. Choose an application from the Responsibility App Code drop-down list.

3. Choose a responsibility from the Responsibility drop-down list.

4. Click Next to continue.

Related Topics
Selecting Components, page 10-18

Managing Component Security, page 10-17

Using Declarative Components, page 10-1

Selecting Components
Use this procedure to select which components will apply to the responsibility that
you have chosen. This procedure takes place after you have completed the procedure
Assigning a Responsibility to Components, page 10-18. For an introduction to
Declarative Components concepts, please see the topic Understanding Declarative
Components, page 2-9.
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Steps:
1. Choose the name of a component in one list and click > or < to move it to the other list.

2. Repeat step 1 as desired.

3. If you want to move all Available Components to the Selected Components
list, then click >>.

4. If you want to move all Selected Components to the Available Components
list, then click <<.

5. Optionally, choose an application from the Component App Code drop-down list.

6. Optionally, click Restore to reset the fields to their original settings.

7. Click Update to save.

Related Topics
Managing Component Security, page 10-17

Using Declarative Components, page 10-1
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Using the Homepage Subtab

Conguring Default Homepages
Use this procedure to set up default homepages for users who do not personalize their
homepages. If a homepage is configured for a particular responsibility, then all users
of that responsibility who have not already personalized their homepages will see this
configuration by default. As soon as a user personalizes his or her homepage, then the
default configuration will no longer be seen. A homepage has either two columns or
three columns. Components in a column are selected from an available list and laid
out vertically. For more information on UI components, please see Understanding
Declarative Components., page 2-9

Steps:
1. In the Design tab, navigate to Homepage > Configuration.

2. Choose an application name from the Select an application drop-down list.

3. Choose a responsibility from the Select a responsibility drop-down list.

4. Choose a layout, either Two Columns or Three Columns, from the Select a layout
drop-down list. Once you have set the value of this field, do not change it again
unless you are willing to lose all edits you have made to the column setup lists below.

5. Set up the bins and modules that will display in each column as follows:

1. Choose the name of a bin or module in one list and click > or < to move it to
the other list.

2. Repeat step b as desired.

3. If you want to move all bins or modules from one list to the other, then click
>> or <<.

4. In aDisplayed Bins orDisplayed Modules list, you can highlight and entry and
then click the up and down arrows to set the order in which bins or modules
displays in that column.

6. Click Update to save.
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Setting Prole Options

Setting Navigation Preferences
Use this procedure to set navigation preferences.

Steps:
1. Click the Profile button, then select Navigation Preferences.

2. If you want to change your current responsibility, then choose an option from the
Current Responsibility drop-down list.

3. If you want to set default responsibilities for registered Navigation Groups, then
choose from the drop-down lists in the Default Responsibility column.

For information on Navigation Groups, please see Understanding the
Interapplication Bar, page 2-2 and Setting Up the Interapplication Bar, page 4-1.

4. Optionally, click Restore to reset the fields to their original settings.

5. Click Update to save.

Setting Display Preferences
Use this procedure to set display preferences.

Steps:
1. Click the Profile button, then select Display Preferences.

2. Choose options from the drop-down lists in the General Display section to select
language, currency, date format, time zone, and display style settings.

3. Choose numbers from the drop-down lists in the Table Display section to select how
many rows to display per page and how many blank rows to display per table.

4. In the Search Display section, choose the radio button that suits how you want
the Quick Find to return results.

5. Optionally, click Restore to reset the fields to their original settings.

6. Click Update to save.

Setting Up the Quick Menu
The Quick Menu is a feature that allows you to display links to your most frequently
visited pages on the Introduction pages of every subtab in the System Administrator
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Console. Use this procedure to choose which pages have links in the Quick Menu and
also turn the Quick Menu on or off.

Steps:
1. Click the Profile button, then select Quick Menu.

2. Select or deselect the check box labeled Display the Quick Menu to turn the Quick
Menu on or off.

3. Choose the name of a menu in one list and click > or < to move it to the other list.

4. Repeat step 3 as desired.

5. If you want to move all Available Menus to the Favorite Menus list, then click >>.

6. If you want to move all Favorite Menus to the Available Menus list, then click <<.

7. Optionally, click the up and down arrows to change the sequence of menus in the
Favorite Menus list.

8. Optionally, click Restore to reset the fields to their original settings.

9. Click Update to save.

Changing Your Password
Use this procedure to change your password.

Steps:
1. Click the Profile button, then select Change Password.

2. Type your current password into the Current Password field.

3. Type your new password into the New Password field.

Passwords must be at least six characters long.

4. Retype your new password into the Re-Enter New Password field.

5. Optionally, click Restore to reset the fields to their original settings.

6. Click Update to save.

Setting Personal Information
Use this procedure to edit your personal information.

Steps:
1. Click the Profile button, then select Personal Information.

2. Edit the fields as desired.

3. Optionally, click Restore to reset the fields to their original settings.

4. Click Update to save.

Setting Address Information
Use this procedure to edit your address information.
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Steps:
1. Click the Profile button, then select Address Information.

2. Edit the fields as desired.

3. Optionally, click Restore to reset the fields to their original settings.

4. Click Update to save.

Viewing Quick Find Search Results
The Quick Find feature appears underneath each page’s tabs. Use this procedure to view
the results of a Quick Find search operation.

Prerequisites
1. Choose an item from the Quick Find drop-down list.

2. Type a search query into the text input field. Optionally, you can use the wildcard
character (%) as needed. For example, to find items that begin with "crm," type
"crm%" into the text input field.

3. Click Go.

Steps:
1. The search results display.

Note: If in the Display Preferences page you have selected the option
"Go to record detail when there is one result," then you will not see
this page. Instead, you will bypass this page and be automatically
redirected to the page that resulted from your search.

2. Click one of the links offered to you in the Search Results list.

You will be redirected to the associated record detail page.

Setting Prole Options 12-3




	Oracle Applications CRM System Administrator’s Guide
	Preface
	Implementing the Oracle CRM Technology Foundation
	Implementing the Oracle CRM Technology Foundation

	Understanding the System Administrator Console
	System Administrator Console Overview
	Understanding Security
	Understanding the Interapplication Bar
	Understanding Diagnostics
	Understanding Cache
	Understanding Declarative Page Flows
	Understanding Declarative Components

	Using the Security Subtab
	Managing Security
	Managing Permissions
	Creating Permissions
	Assigning a Permission to Roles
	Managing Roles
	Creating Roles
	Mapping Permissions to a Role

	Using the Site Preferences Subtab
	Setting Up the Interapplication Bar
	Setting Up Navigation Groups
	Editing Navigation Group Details

	Using the System Subtab
	Using the System Subtab
	Setting Up Sessions
	Setting Up Cookies
	Setting Up Branding
	Setting Up the Self Service User
	Setting Up Logging Trails
	Setting Up Property Categories
	Setting Up Password Expiration
	Managing Properties
	Editing the Details of Keys
	Setting Up Debug Logging
	Viewing the Debug Log
	Setting Up Page Flow Logging
	Viewing Page Flow Logging Reports
	Migrating Page Flow Data
	Setting Page Flow Buffer Size and Flush Interval

	Using the Deployment Tab
	Viewing System Alerts
	Viewing Jserv Statistics
	Managing Configuration
	Setting Up Hosts
	Editing Host Details
	Editing Resource Settings

	Using Diagnostics
	Using Diagnostics
	Using the Diagnostics Summary
	Using the LogViewer
	Running Test Groups
	Running All Test Groups
	Running One Test Group
	Running Tests 
	Managing Test Groups
	Creating Test Groups
	Updating Test Groups
	Managing Tests
	Registering Tests 
	Setting Default Test Input Values
	Managing Applications
	Registering Applications
	Editing Application Prerequisites
	Purging Result Logs
	Setting Up Diagnostic Security

	Using the Cache Subtab
	Using Cache
	Managing Cache Policies 
	Editing Cache Policy Details
	Managing Cache Filters
	Viewing Cache Filter Details
	Creating and Editing Cache Filters
	Step 1: Editing Basic Information
	Step 2: Choosing Responsibilities
	Step 3: Choosing Languages
	Managing Component Caches
	Editing Component Cache Details
	Viewing Cache Statistics 

	Using the Declarative Page Flows Subtab
	Using Declarative Page Flows
	Managing Physical Pages
	Editing Physical Page Details
	Managing Logical Pages
	Editing Logical Page Details
	Managing Rules
	Editing Rule Details
	Managing Business Flows
	Editing Business Flow Details
	Creating a New Business Flow
	Updating an Existing Business Flow
	Creating Flow Branches
	Duplicating Business Flows
	Viewing Flow Versions

	Using the Declarative Components Subtab
	Using Declarative Components
	Managing Components
	Previewing Components
	Registering Components
	Editing Component Metadata
	Defining Bin or Report Columns
	Editing Bin or Report Column Details
	Managing LOV Columns
	Editing LOV Column Details
	Defining Graph Metadata
	Managing Graph Columns
	Editing Graph Column Details
	Managing Parameters
	Editing Parameter Metadata
	Managing Component Security
	Assigning a Component to Responsibilities
	Selecting Responsibilities
	Assigning a Responsibility to Components
	Selecting Components

	Using the Homepage Subtab
	Configuring Default Homepages

	Setting Profile Options
	Setting Navigation Preferences
	Setting Display Preferences
	Setting Up the Quick Menu
	Changing Your Password
	Setting Personal Information 
	Setting Address Information
	Viewing Quick Find Search Results



