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Chapter 1 - Introduction

Overview

All Foundation-based products require setup and administration activities to be
performed.

e Domain administration

e User account management

e User and workbook template administration
e Hierarchy maintenance

e Measure analysis

e Workbook auto build maintenance

e Translation administration

System administration workbooks

Using the administration workbooks, designated employees manage other
employees’ use of the Retek Predictive Solutions. System administrators use the
administration workbooks to:

e Set up and maintain users and user groups.

e Manage users’ access to specific workbook templates and individual
measures.

¢ Modify the labels associated with users and user groups.

¢ Modify the labels associated with workbook templates and template groups.
e View logon and logoff status information for users.

e Create custom workbook templates and template groups.

¢ Edit the contents of translation tables to support multiple-language use of the
application.

o Specify the type, frequency, and format of workbooks in the automatic build
queue.
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Workbook and wizard descriptions

e User Account Management wizards, a set of wizards for setting up and
maintaining users and groups

e Security Administration Workbook, a workbook for setting up and
maintaining user/template, user/measure, and template/measure access rights

o Workbook template definition, a workbook for specifying parameters of a
custom workbook template

e Translation Administration Workbook, a workbook for managing the foreign
language translation of strings and label text throughout the application

e Workbook auto build maintenance, a workbook for managing the workbook
auto build queue

General Workbook Procedures

Change a workbook’s calculation method

When in automatic calculation mode, every change to a cell in the worksheet
causes a recalculation, which requires immediate communication from the
worksheet back to the database. In this mode, there may be a pause between one
data change and your ability to effect the next change.

To save server processing time when you are making large numbers of data
changes, you can set the system to manual (deferred) calculation mode. The
system then creates a queue of data changes to be submitted all at once to the
server, at a time that you specify.

Set the system to deferred calculation mode

Click the Edit menu and select Manual Calculation.

Return the system to automatic calculation mode

Click the Edit menu and select Automatic Calculation.

Send the queue of data changes to the server

Click the Edit menu and select Calculate Now.
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Refresh and export data
Refresh the data in a worksheet

The Refresh feature brings the most recent version of data from the master
database into the current workbook. This lets you work with the most current
data without having to rebuild the workbook.

Refresh the data for specific measures or worksheets
1 From the File menu, select Refresh.

2 On the Refresh dialog box, choose which data you want to refresh. You can
refresh data for entire worksheets, or for subsets of measures that appear on
those worksheets.

3 Click OK.

Refresh the data for all worksheets and measures in the workbook
1 From the File menu, select Refresh.

2  Click the Refresh All button.

Export the current worksheet view to an output file

1 From the File menu, select Export Sheet. The Save As dialog box is
displayed.

2 Inthe Save In field, select a directory on your computer where you want to
save the export file.

In the File Name field, type a name for the export file.

4  Click the Save As Type drop-down list and select a file type for the export
file.

5 Make a selection for each of the following:

= Delimiter: Specify the character used to separate information in the
output file. Standard choices are Tab, Comma, or Space, but you can
specify a different delimiter by selecting the Other radio button.

= Labels: Specify the format of the label headers across the top of cells in
the output file. The options are:

»= Do Not Include — no labels provided

= Include Once — one label placed across the top of each section of related
cells

= Repeat — a separate label, repeated as necessary, appears atop each cell

= Descriptions: Specify whether to identify dimensional positions in your
output file with concise system names (for example, SKU00012) or the
descriptive labels (for example, Cashmere Sweater — L — beige) assigned
to each position.

6 Select Save to export the file.
7 Click OK.
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Insert measures into an open worksheet

You can insert a new measure or group of measures into an already open
workbook. This functionality reduces the need to build new workbooks whenever
a view of currently unrepresented measures is required. The ability to insert new
measures into already open workbooks is particularly useful in the context of
establishing access to alerts.

Use the following procedure to select a measure or group of measures to be
inserted in a currently open workbook.

Note: A worksheet must be open and active for the Insert Measure menu option
to be enabled. Any measure(s) selected to be inserted in the workbook will be
placed on the currently active worksheet.

1 From the Edit menu, select Insert Measure.

2 From the Role list box, select the appropriate role attribute for the measure
you want to insert. You can select more than one role attribute by using
<Ctrl+Click>.

Note: The Role attribute is only required for products in the Retek Predictive
Planning Suite. For other applications, the system default (None) should be
used.

3 From the Version list box, select the desired version attribute for the
measure. You can select more than one version by using <Ctrl+Click>.

Note: The Version attribute is only required for products in the Retek
Predictive Planning Suite. For other applications, the system default (None)
should be used.

4 From the Units list box, select the desired units attribute for the measure.
You can select more than one units attribute by using <Ctrl+Click>.

5 From the Metric list box, select the desired metric(s). If a measure exists that
matches the combination of attribute types selected in the preceding steps, its
name/label will appear in the Measures list box. Multiple measures may
appear here if multiple selections were made in any of the preceding steps.

Note: You can right-click in the Metric window to produce a quick menu,
wherein you can toggle the display between metric name (the system name)
and metric label (as it appears in the workbook).

6 Select the desired measure(s) in the Measures list box.
7 Click OK.
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Chapter 2 — Domain administration

Overview

The RPAS DomainDaemon is a process that is used in enabling the
communication channel between RPAS clients and RPAS domains.

The DomainDaemon runs on the server side and waits for requests from RPAS
clients on a given port. Once it receives a request from a client, it starts a server
process that the client connects to. From this point on, the client and server
communicate directly. The system administrators may choose to have one single
DomainDaemon process for all the users, or they may choose to have separate
processes per domain, per enterprise etc.

The DomainDaemon is installed in the [RPASDIR]/bin directory, where
[RPASDIR] stands for the full path to the directory in which the RPAS server is
installed. The system administrators can start, stop and monitor the
DomainDaemon processes using scripts that are provided in this directory.

Starting the DomainDaemon

In order to start the DomainDaemon, execute the script called DomainDaemon in
the Acumate installation directory. The port number on which the
DomainDaemon will be running must be passed in as an argument. The port
number must be between 1025 and 65535. If auto is specified instead of a
number, the DomainDaemon is started on any available port.

Note: In the following examples, [RPASDIR] stands for the full path to the
directory in which the RPAS server is installed.

For example, issuing the following command from a UNIX shell will start a
DomainDaemon on port 55278.

([RPASDIR]/bin)$ DomainDaemon —port 55278 -start

Monitoring the DomainDaemon

The —ping argument can be used to see whether a DomainDaemon is active. The
port number must also be passed as an argument. If the DomainDaemon is active
on the port, then a message will be printed, and the script will return true.
Otherwise, the script will return false.

Example:
([RPASDIR]/bin)$ DomainDaemon —port 55277 —ping

DomainDaemon on port 55277 is alive.
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Stopping the DomainDaemon

Use the —stop argument to stop the DomainDaemon running on a given port.

Example:
([RPASDIR]/bin)$ DomainDaemon —port 55277 -stop

Other DomainDaemon commands

add

remove

deactivate

activate

Use the —add argument to add a domain to the list of domains managed by a
DomainDaemon process. You must specify the port number and the complete
path to the domain.

Example:
DomainDaemon —port 55277 —add /mydomains/domainl

Added domain /mydomains/domainl to daemon.

Use the —remove argument to remove a domain from the list of domains
managed by a DomainDaemon process. You must specify the port number and
the complete path to the domain.

Example:
DomainDaemon —port 55277 —remove /mydomains/domainl

Removed domain /mydomains/domainl from daemon.

Use the —deactivate argument to mark a domain as temporarily unavailable. You
must specify the port number and the complete path to the domain.

Example:
DomainDaemon —port 55277 —deactivate /mydomains/domainl

Use the —activate argument to reactivate a domain that you previously
deactivated. You must specify the port number and the complete path to the
domain.

Example:
DomainDaemon —port 55277 —activate /mydomains/domainl
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showActiveServers

Use the —showActiveServers argument to list all the active server processes
managed by the DomainDaemon. You must specify a port number.

For each active server, the DomainDaemon shows the process 1D, domain, and
user ID.

Example:
DomainDaemon —port 55277 —showActiveServers
Registered Servers:
15920, /mydomains/domainl, adm

showDomains

Use the —showDomains argument to list the domains managed by the
DomainDaemon. You must specify a port number. For each managed domain,
the DomainDaemon indicates whether it is active or inactive.

Example:
DomainDaemon —port 55277 —showDomains
Managed Domains:
/mydomains/domainl: Active

/mydomains/domain2: Inactive

showLockTable

Use the —showLockTable argument to display the contents of the database lock
table.

Example:
DomainDaemon —port 55277 —showLockTable
Lock Table:

releaselLocks

Use the —releaseLocks argument to release all database locks held by the
specified process. You must specify a port number and a process ID.

Example:
DomainDaemon —port 55277 —releaselLocks 15920

All locks released.
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stopServer

Use the —stopServer argument to stop a specified server process. You must
specify a port number and a process ID.

Example:
DomainDaemon —port 55277 —stopServer 15920

Stop Server succeeded.
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Chapter 3 — Security and user administration

Functional overview

This chapter describes the security model in RPAS, which includes workbook
templates, workbooks, measures and positions. The levels of security are defined
as measure level, position level and workbook level.

This chapter also describes user administration and security administration.

User Logon Security
A user account may be marked as locked out by the domain administrator.

This will prevent the user from logging in to the RPAS 11.0 client. The account
remains locked out until the administrator re-enables the account.

Account lockouts may be set or cleared by the domain administrator using the
User Management utility.

A user account may be marked as must change password.

This is useful for brand-new accounts; the user will be allowed to logon with the
current password, but will immediately be forced to select a new password.

Must change password may be set or cleared by the domain administrator using
the User Management utility.

Account Lockout may be enabled for a domain.

The domain administrator selects a number of failed logon attempts after which
the User account will be marked as locked out. The account will remain locked
out until the administrator re-enables it.

Account Lockout can be enabled through the domainprop utility using the
—lockAccount flag.

Password expiration may be enabled for a domain.

The domain administrator selects a number of days after which passwords expire.
When a user logs in, if the configured number of days have passed since this user
entered a new password, the system requires a new password to be entered.

Password expiration can be enabled through the domainprop utility using the
—expirePassword flag.

Password history may be enabled for a domain.

The domain administrator selects a number of passwords to save. When a user
attempts to change passwords, the system will not permit any password already
stored in the password history to be used again.

Password history may be enabled through the domainprop utility using the
—passwordHistory flag.
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Measure level security

Measures have access rights which are read-write, read-only or denied.
Measures which are read-write or read-only may be selected in the extra
measures and insert measure dialogs. RPAS ensures that read-only measures are
not editable by the user and the presence of read-only measures does not affect
the ability to commit a workbook.

Measure security can be specified when the measure is registered and can be
changed later using the Security Administration workbook. The Measure Rights
worksheet allows you to specify Read Only, Deny, or Read/Write access to a
measure for each user.

A workbook template can override the default security of a measure, but can only
narrow the security of the measure. For example, a measure could have default
read-write access for a user and a template could specify that all users have read-
only access to the measure when a workbook is built. However, if the default
measure security was read-only, the template could not expand the security of
that measure to read-write. Measures which are explicitly made read-only by a
workbook template will not be expanded to read-write access by RPAS.
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Position level security

Position Level Security allows access control for dimensions on a position-by-
position basis. This capability is completely optional. If position level security
is not explicitly defined and configured, all users in a domain have access to all
positions in all dimensions. Once position level security is defined, access to a
position can be granted or denied for all users, for users in a group, or for an
individual user.

Exactly one dimension in each hierarchy can be defined as the security
dimension for the hierarchy. If a security dimension is defined for the hierarchy,
all dimensions in the hierarchy have position level security enabled. To specify
the security dimension for a hierarchy, set the securitydim position in the info
dimension of the meta.dim_hier array for the hierarchy. For example,

update meta.dim_hier(hier: prod info: securitydim) with “styl”;

This should be done when the hierarchies are defined (in asetup.init_hparm, for
example). The abatch.create_wbts proc should be run after adding or removing a
security dimension in any hierarchy. This creates the administration worksheets
that are used to allow user access to positions.

After a security dimension is defined for a hierarchy, all users in the domain
default to not having access to any positions in any dimension in the hierarchy.
Worksheets in the Security Administration workbook are used to control position
access for users, groups, or default access. There are three worksheets in this
workbook for each hierarchy with a defined security dimension. One sheet
controls default access to positions (called Prod Security Default, for example);
one controls group access (Prod Security Group); and the third controls
individual user access (Prod Security User).

When a user creates a workbook in a domain with position level security enabled,
only positions that the user has access to is copied into the workbook.

Workbook security

Currently, workbook access is either granted or denied. If users have been
granted access to a workbook, then they can open, modify and commit the
workbook. No distinction is made between read-write-commit, read-write and
read-only access. Workbook access is automatically granted to the user that built
it, and may be shared with multiple groups or the world. Note, however, that a
user must have access to the workbook template in order to access the workbook,
even if the workbook has world access rights.
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User administration

Overview

User administration is the process by which administrators add and/or delete
authorized system users, create and/or delete user groups, and edit user profiles.
These tasks are performed through completion wizards on the User
Administration tab. The following procedures are discussed in this area:

Access the User Administration tab
Add a user

Add a user group

Delete a user

Delete a user group

Edit a user’s profile.

Once users and user groups are set up, you can set access permissions to
workbook templates and to measures within workbooks through Security
Administration. Additionally, you can modify the label, default workbook
template, and/or Admin status associated with individual users.
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Procedures

Access the User Administration tab
1  Select New from the File menu. The New dialog box is displayed.

2 Select the User Administration tab.

Add a user

1 From the File menu, select New.

2 Click the User Administration tab.

3 Select Add User and click OK.

4 Inthe ID field, type the ID string that the user will use for logging on.

Note: Each user ID must begin with a letter, must contain no spaces (the
underscore character is acceptable), and must not exceed eight characters
total.

5 Inthe User Label field, type a label describing the user (for example, the
user’s full name). This identifying label will appear in various locations
throughout the application. For example, labels appear on the File > Open
dialog box to identify the owner of a given workbook, and on the Forecast
Approval worksheet to specify which user approved a given forecast.

6 In the Default Group field, select the user group to which the user will
belong.

7 If auser will belong to more than one group, select the additional groups
from the list in the Other Groups field.

8 In the Password field, type a password for the user.
9 Inthe Password Verification field, type the same password.

10 If the user should have Admin status, which allows that user to create
system-wide default styles for workbook templates, check the Administrator
box.

Note: Admin status enables users to perform the Format menu option Save
Format/Admin, which creates new system-wide default styles for workbook
templates. If you are not sure whether a user should be granted this ability,
note that a user’s Admin status can later be modified on the Users worksheet
of the User & Template Administration workbook.

Note also that while granting a user Admin status gives them access to all
workbook templates, it does not automatically give them access to all
workbooks.

11 If the user must change his or her password when logging on for the first
time, check the Force Password Change box.

12 If you want to temporarily disable the user’s account, check the Lock User
Account box.

13 Click Finish to add the new user to the database.
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You can now assigh workbook template and measure access rights to the user.
To do so, access the User & Template Administration workbook.

Add a user group

User groups provide an intermediate level of security to workbooks created and
saved by specific users. When you assign new users to the system, they must be
assigned to existing user groups. User groups should consist of individuals with
similar job functions or responsibilities. In the Retek Predictive Planning Suite,

the user group corresponds to the user’s planning role.

1
2
3
4
5

6

Select New from the File menu.

Click the User Administration tab.

Select Add User Group and click OK.

In the Group Name field, type a name for the group.

In the Group Label field, type a descriptive label for the group. This label is
displayed when referring to the group throughout RPAS.

Click Finish to add the user group to the database.

Delete a user

If a user profile is no longer needed, it should be deleted from the system in order
to maintain system security.

1

2
3
4
5

From the File menu, select New.

Click the User Administration tab.

Select Delete User and click OK.

Select the name of the user you want to delete.

Click Finish to delete the user from the system.
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Delete a user group

If a user group no longer exists, you should delete the group from the system as
soon as possible to maintain system security.

Caution: Deleting a user group will delete every user in that group.
1 From the File menu, select New.

2 Click the User Administration tab.

3 Select Delete User Group and click OK.

4 Select the user group you want to delete.

5 Click Finish to delete the user group from the system.

Edit a user

1 From the File menu, select New.

2 Click the User Administration tab.

3 Select Edit User and click OK.

4 Select the user you want to edit and click Next.
5

Make the necessary changes to the user’s profile. You can change anything
except the User Name. See “Add a user” for details.

6 Click Finish to save the changes you have made.
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Security Administration Workbook

Overview

The Security Administration Workbook is only available to system
administrators. After users and user groups are created, you may set up and
maintain access permissions to workbook templates and measures within those
workbook templates. That is, you can determine which templates individual users
can access, as well as the measures that users can access while manipulating
workbooks in the system. Additionally, you can specify and restrict the measures
that are available to be added to a given workbook template. The ability to set
access permissions in this way provides a high degree of measure security, as
users can be restricted to viewing and editing only certain relevant measures.

The Security Administration workbook has several worksheets:
o Workbook Template Rights Worksheet

o Workbook Template Measure Rights Worksheet

e Measure Rights Worksheet

o Dimension Modification Rights

o Hierarchy Modification Rights

Security Template Administration also allows you to modify the label, Admin
status, and/or default workbook template associated with each user. You also
access this workbook template to modify the labels associated with user groups,
workbook templates, and workbook template groups. Using this workbook, you
can:

o Assign/modify access rights of each user to all workbook templates.
User/template permissions are set in the Workbook Template Rights
worksheet.

o Determine which optional measures are to be accessible through individual
workbook templates. Template/measure permissions are set in the
Workbook Template Measure Rights worksheet.

e Assign/restrict user access to individual measures. User/measure permissions
are established in the Measure Rights worksheet.
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Workbook Template Rights Worksheet

The Workbook Template Rights worksheet is for setting and maintaining access
permissions of each user to specific workbook templates.

The worksheet contains a checkbox for each available workbook template and
user combination. A checkmark in the cell indicates that the user has access
rights to that specific template.

To grant a user access rights to a workbook template, put a checkmark in the
checkbox in for that workbook template.

To deny a user access rights to that specific workbook template, leave the
checkbox blank or clear the checkmark.

After changing a user’s profile, the changes must be committed to the database in
order for them to take effect.

Workbook Template Measure Rights Worksheet

The Workbook Template Measure Rights worksheet allows administrators to
determine which registered measures will be available for optional inclusion in
newly built workbooks.

When a measure is initially registered as a public measure, all templates default
to having access to that measure. This means that it is possible for this measure
to be added to a workbook template, even if it is not one of the standard measures
displayed when a workbook of that type is built. New workbook wizards
typically include a dialog that prompts users to select any additional measures to
be included in the workbook build. By default, all newly registered measures are
included on this list of available additional measures.

The Workbook Template Measure Rights worksheet is used to modify
template/measure permissions, thus allowing only certain templates to optionally
include specified measures in new workbook builds.

This worksheet contains a checkbox for each available workbook template and
registered measure combination. A checkmark in the cell indicates that the
measure will appear on the additional measures list in the new workbook wizard,
and is thus available for inclusion in the initial workbook build.

To make a given measure available in a workbook template, put a checkmark in
the checkbox that represents that template/measure intersection.

To prevent a measure from appearing in a specific workbook template, clear the
checkbox located at that template/measure intersection.

After changes are made to a template’s profile, they must be committed in order
for them to take effect.

Note: Measures that are registered as private measures will not appear in this
worksheet. If there are no public measures available to be displayed in this
worksheet, the worksheet will not be built.
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Measure Rights Worksheet

The Measure Rights worksheet allows you to restrict user access to individual
measures on a user-by-measure basis. User/measure permissions are initially
determined by the system by integrating the current user/template and
template/measure settings and applying the following rule: a user cannot have
access to any measure that is not available in at least one template to which the
user has access.

Permissions can be made even more restrictive on a user by measure basis by
using the Measure Rights worksheet to deny users access to measures that they
would normally be permitted to edit.

The worksheet contains a checkbox for each available user and registered
measure combination. A checkmark in the cell indicates that the user has access
rights to and is permitted to view and edit the specified measure. More
specifically, that given user has access to at least one template that is permitted to
include the specified measure.

You can further restrict a user’s access to specific measures by removing
checkmarks that are displayed at those associated intersections. Removing the
checkmark (by clicking on it) prevents the user from accessing a given measure,
even though that measure is normally permitted to be displayed in a particular
workbook template to which the user does have access.

After changes are made to a user’s profile, they must be committed in order for
them to take effect.

Note: The Measure Rights worksheet contains only public measures; that is,
measures that can be optionally included in a worksheet, depending on choices
made in a new workbook wizard. Measures that are registered as private
measures will not appear in this worksheet. If there are no public measures
available to be displayed in this worksheet, the worksheet will not be built.

Dimension Modification Rights Worksheet

The Dimension Modification Rights worksheet allows you to determine which
dimensions, if any, a user can modify. The worksheet contains a checkbox for
each available user and dimension combination. A checkmark in the cell
indicates that the user is permitted to modify the specified dimension.

After changes are made to a user’s dimension modification rights, they must be
committed in order for them to take effect.

Hierarchy Modification Rights Worksheet

The Hierarchy Modification Rights worksheet allows you to determine which
hierarchies, if any, a user can modify. The worksheet contains a checkbox for
each available user and hierarchy combination. A checkmark in the cell indicates
that the user is permitted to modify the specified hierarchy.

After changes are made to a user’s hierarchy modification rights, they must be
committed in order for them to take effect.
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Note: These tasks are performed through the Security Administration Workbook.
This workbook is only available to system administrators.

Access User & Template Administration

1
2

3

From the main menu, select File > New. The New dialog box is displayed.

Select the Administration tab to display a list of workbook templates for
Administration.

Highlight Security Administration and click OK.

Set or modify users' access to workbook templates

1

2
3
4

6
7

From the File menu, select New.
Click the Administration tab.
Select Security Administration and click OK.

On the Workbook Template Rights worksheet, select each template for
which a user needs access rights. For templates to which the employee
should not have access rights, make sure there is no check mark.

Changes must be committed to the master database for them to take effect.
To commit your changes, select Commit Now from the File menu.

If you desire, save your workbook by selecting Save from the File menu.

To close the workbook, select Close from the File menu.

Set measure availability for workbook templates

1

2
3
4

From the File menu, select New.
Click the Administration tab.
Select Security Administration and click OK.

On the Workbook Template Measure Rights worksheet, select each
registered measure that should be available for inclusion in the associated
workbook template. For measures that should not be included in the
associated template, make sure there is no check mark.

Changes must be committed to the master database for them to take effect.
To commit your changes, select Commit Now from the File menu.

If you desire, save your workbook by selecting Save from the File menu.

To close the workbook, select Close from the File menu.



20 Retek Predictive Application Server

Assign or restrict user access to measures

1

2
3
4

6
7

From the File menu, select New.
Click the Administration tab.
Select Security Administration and click OK.

On the Measure Rights worksheet, for each measure that a user should have
access to, select either Read Only or Read/Write from the drop-down list.
For measures to which the user should not have access, make sure Denied is
selected.

Any changes made must be committed to the master database in order for
them to take effect. To commit your changes, select Commit Now from the
File menu.

If you desire, save your workbook by selecting Save from the File menu.
To close the workbook, select Close from the File menu.

Change a user’s ability to modify dimensions

1

2
3
4

6
7

From the File menu, select New.
Click the Administration tab.
Select Security Administration and click OK.

On the Dimension Modification Rights worksheet, select each dimension for
which the user needs modification rights. For dimensions that the user
should not be able to modify, make sure there is no check mark.

Any changes made must be committed to the master database in order for
them to take effect. To commit your changes, select Commit Now from the
File menu.

If you desire, save your workbook by selecting Save from the File menu.

To close the workbook, select Close from the File menu.

Change a user’s ability to modify hierarchies

1

2
3
4

From the File menu, select New.
Click the Administration tab.
Select Security Administration and click OK.

On the Hierarchy Modification Rights worksheet, select each hierarchy for
which the user needs modification rights. For hierarchies that the user should
not have be able to modify, make sure there is no check mark.

Any changes made must be committed to the master database in order for
them to take effect. To commit your changes, select Commit Now from the
File menu.

If you desire, save your workbook by selecting Save from the File menu.

To close the workbook, select Close from the File menu.
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4 — Hierarchy maintenance

Hierarchy Maintenance Workbook

Retek Predictive Solutions provide the ability to set up and maintain user-named
and user-defined dimensions within hierarchies. Hierarchy Maintenance is the
means by which custom-created dimensions within a hierarchy can be established
and maintained through the application interface to meet individual business
needs.

When Retek Predictive Solutions are installed, implementation scripts define the
dimensions and hierarchical structures specific to your organization. For
example, the system can be built to recognize that SKUs roll up into styles, that
styles roll up into product classes, and so on within the product hierarchy. On
occasion, however, you might want to group products according to some ad hoc
personal design to suit a particular business need. You can group arbitrary items
in a hierarchy to use in functions such as forecasting, replenishment, and measure
analysis. These user-defined groupings act as normal dimensional levels; that is,
they allow you to roll data up from lower levels of aggregation along the
hierarchical paths that you define.

For example, suppose that your experience has shown that the accuracy of
forecasts for your top 50 products (A products) reflects the relative accuracy of
all forecasts. Therefore, you would like to group elements within a user-defined
dimension as the top 50 products by designating them ‘A Products’. Then, when
you select products in a wizard or look at data in a worksheet, you can change the
rollup to your user-defined dimension to see your top 50 products grouped
together.

Note that your collection of 50 products may comprise elements from a wide
range of product classes or departments, and that your grouping scheme may
have little to do with the normal dimensional relationships of these items in the
product hierarchy. Note also that the group of items you designate as ‘A
Products” may change over time as consumer preferences change. From this
example, you see that user-defined dimensions can be used to create any ad hoc
groupings to provide additional support in analyzing, selecting, or summarizing
data in Demand Forecasting. Moreover, the Hierarchy Maintenance interface
allows you to change the nature of the groupings as required.

Note: The number and names of user-definable dimensions are set by your
company when Demand Forecasting is initially installed. The positions within
each dimension and their associated labels can be altered and maintained through
the hierarchy maintenance process.

Keep in mind that any hierarchy in the Retek Predictive Solutions can have user-
defined dimensions within it (if set up by your company at the time of
installation). The examples in this section refer to the Product hierarchy, but
other hierarchies could be maintained in the same way.



22 Retek Predictive Application Server

Hierarchy Maintenance Example

Suppose you wish to designate SKUs in your product hierarchy as either A, B, or
C products so that you can group these items together when you view
information such as forecasting, replenishment, or measure analysis reports.

To do this, you need to maintain a user-defined dimension that will allow you to
map the SKUs to the various positions of your classification scheme (A, B, or C).
The user-defined dimension used in the following example is named Product
Status. To maintain this user-defined dimension, you use the Hierarchy
Maintenance Wizard.

Hierarchy Maintenance Wizard

The first step in maintaining hierarchies is to access the Hierarchy Maintenance
Wizard. In this wizard, you select the SKUs that will be mapped to the various
positions of your user-defined dimension. Responses to prompts in the wizard
are used to format a new Hierarchy Maintenance Workbook.

Hierarchy Maintenance Worksheet

The Hierarchy Maintenance worksheet displays the position assignment fields for
your selected custom dimension. You can edit the cells associated with your
custom dimension as required.

Returning to the example dimension Product Status, you want to classify each
selected SKU in your workbook as an A Product, a B Product, or a C Product.
This example provides only three positions, or values, in the Product Status
dimension. However, you can enter any character string in an individual SKU’s
Product Status cell, and this new string will be treated as a separate user-defined
grouping. If this is the first time a particular SKU has been mapped to the
Product Status dimension, the label assigned to that SKU will not yet be defined,;
the Product Status field is automatically filled with ‘Unassigned’.

Assign labels to each product with regard to the Product Status dimension. In the
example below, products that were previously ‘Unassigned’ are now designated
as A, B, or C Products.
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[ Froduct Stetuz I_‘
3001 -01 Turtlenack Sweasler 205 A Prociuct —
3001.02 Turthenack Sweasbar 20.M A, Prociuct
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Note: The Retek Predictive Solutions system is case-sensitive when a new
position name (label) is entered in the Hierarchy Maintenance Workbook. After
the workbook has been committed, however, the typing of the group name is not
case-sensitive. For example, "B Product" can later be entered as "b product"
after the "B Product™ group label has been committed.

After making the A, B, or C Product designations for the selected SKUs, you
must commit the workbook for any changes to take effect.

For this example, labels have now been assigned to the various positions within
the Product Status dimension, and selected products in the product hierarchy
have been classified with regard to the custom dimension. Demand Forecasting
treats Product Status, a user-defined dimension, as a normal dimensional level
within the product hierarchy.



24 Retek Predictive Application Server

The figure below displays the results when, in a wizard, you access a quick menu
and change the rollup to the Product Status dimension. The products shown here
are classified according to the position values (A Product, B Product, or C
Product) that you assigned while maintaining the Product Status dimension.

Procedures

Selected Products | Selections I

EA Product

— ® 3001-01 Turtleneck Sweater 20-5
—— ® 3001-02 Turtleneck Sweater 20-M
— ® 3041-08 Cashmere Sweater 42-h
— ® B053-05 Sweatshirt 20-M

— # 3053-06 Sweatshirt 20-L

=B Product

— ® 3041-07 Cashmere Sweater 42-5
— # 3031-03 Sports Pigue 17-L

EIC Product

— ® 3001-03 Turtleneck Sweater 20-L
— ® 3041-09 Cashmere Sweater 42-L
— # 3031-02 Sports Pique 17-M

I arme | Action |

Access Hierarchy Maintenance

1

g B~ W DN

Select Open from the File menu to bypass the Hierarchy Maintenance wizard
and open an existing Hierarchy Maintenance workbook.

OR

Select New from the File menu.

Select the Administration tab to display the list of Administration templates.
Select Hierarchy Maintenance and click OK.

Select the hierarchy for which you want to specify a user-defined dimension
(for example, Product or Location). Only the hierarchies that have been set
up to contain user-defined dimensions are represented here. Click Next.

Select the user-defined dimension to be updated. The number and names of
available custom dimensions are set at installation. Click Next.
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7 On the Available side of the selection wizard, choose the items to be mapped
to positions within your custom dimension. Click the right arrow button to
move them to the Selected side. When you have chosen all items to appear
in your workbook, click Finish.

Maintain a user-defined dimension within a hierarchy

Use this procedure to assign product or location items to custom-defined
positions within a specialized dimension. Custom-created dimensions are
distinct from those in the standard hierarchical roll-ups established at your
system implementation. However, you can use these dimensions like normal
Demand Forecasting levels, aggregating data along these new hierarchical paths.

1 Select New from the File menu.

2  Select the Administration tab to display the list of Administration templates.
3 Select Hierarchy Maintenance and click OK.
4

Select the hierarchy for which you want to specify a user-defined dimension
(for example, Product or Location). Only the hierarchies that have been set
up to contain user-defined dimensions are represented here. Click Next.

5 Select the user-defined dimension to be updated. The number and names of
available custom dimensions are set at installation. Click Next.

6 On the Available side of the selection wizard, choose the items to be mapped
to positions within your custom dimension. Click the right arrow button to
move them to the Selected side. When you have chosen all items to appear
in your workbook, click Finish.

7 The Hierarchy Maintenance workbook is displayed. In the position
assignment field for your custom dimension, assign a value to each product
or location position in your workbook. You can enter any text string in a
cell; each unique string will be treated as a separate user-defined position
within the custom dimension.

8 Select Commit Now from the File menu to commit your changes to the
master database. If desired, you may also save your workbook by selecting
Save from the File menu.

9 To close the workbook, select Close from the File menu.
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Chapter 5 — Measure analysis
Overview

Measure Analysis Workbook

The Measure Analysis Workbook template allows you to view data associated
with any registered measure in the Retek Predictive Solutions applications, such
as actual sales data for specified product/location/calendar combinations. You
may also use the Measure Analysis workbook to edit values for read-write
measures.

Although a common use of the Measure Analysis Workbook is to view actual
sales data, the workbook is not restricted to presenting sales data alone. You can
view any data loaded into the Retek Predictive Solutions master database, such as
selling prices, shipments, orders, etc. The Measure Analysis Wizard provides you
with a list of all registered measures from which to select; you simply choose the
measures to be displayed in the new workbook.

Measure Analysis Wizard

The Measure Analysis Wizard guides you through the process of creating a new
Measure Analysis workbook, in which you can view data associated with any
registered measure(s) in Demand Forecasting.

Measure Analysis Worksheet

The Measure Analysis workbook displays data associated with selected
registered measures, and contains one type of worksheet, the Measure Analysis
worksheet. A separate worksheet will exist for each distinct product/location
intersection associated with the measures selected in the wizard.

The Measure Analysis worksheet allows you to view the chosen measure data for
the selected products, locations, and time periods. Each Measure Analysis
worksheet is displayed at a different dimensional intersection, depending on the
measure selections made in the wizard. This dimensional intersection is shown
in the worksheet title bar.



28 Retek Predictive Application Server

Ilm [Main/Pure Branch] [Unit Code/Shade] [Week] Worksheet

Product | Calendss | Measure |
101000 Pullover Sveesier - Saffron ZXL HH ||I4]11|H'|H£
Fial Level Forecast POS [
3417200 Lord & Taylor - Aflanta #14 16600 152,00 =
31730 Lord & Taylor - Dallas #213 145.00 157 .00
34174/0 Lord & Taylor - Detroit #419 179.00 16600 _
Location | 4/ | L|_I

The example above shows a Measure Analysis worksheet that displays Final
Level Forecast data and POS data for three locations. The
location/product/calendar dimensional intersection of this worksheet, as shown in
the title bar, is [Main/Pure Branch][Unit Code/Shade][Week]. The Final Level
Forecast measure, because it is registered as a read/write measure, can be edited
in this worksheet. POS values cannot be changed, as this measure is registered as
read only.

Procedures

Access Measure Analysis

1 Select Open from the File menu to bypass the Measure Analysis wizard and
open an existing Measure Analysis workbook.

OR
1 Select New from the File menu.

2 On the Analysis tab, select Measure Analysis and click OK.

Review and edit sales or other registered measure data

1 To open an existing Measure Analysis workbook, select Open from the File
menu, double-click on the workbook to be opened, and go to step 9.

OR
1 To open a new workbook, select New from the File menu.
2 On the Analysis tab, select Measure Analysis and click OK.

3 The Measure Analysis Wizard opens and prompts you to select the registered
measures to be displayed in the new workbook. Use Ctrl-Click and/or Shift-
Click to select multiple measures. Click Next.

4 Select the dimensional level at which you want to view measure data. Click
Next.

Note: This screen only appears if there is more than one level possible for
one of your selected measures. A separate wizard screen will be displayed
for every measure chosen in step 3 if multiple aggregation levels are
available.)
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Tip: Selecting a pre-aggregated level (a level other than base level) allows
you to view aggregated sales data faster than if you select the base level and
later aggregate data from within the workbook itself. Building the workbook
with pre-aggregated data can save time and lessen the need for data transfers
later.

Select all calendar periods for which you want to view data. Click Next.
Select the locations whose measure data you want to view. Click Next.
Select the products whose measure data you want to view. Click Next.
Click Finish to open the Measure Analysis workbook.

© 0O N o O

On the Measure Analysis Worksheet(s), view the stored data associated with
the measures, products, locations, and calendar periods you selected. Make
any changes as required.

10 Commit your changes to the master database by selecting Commit Now from
the File menu. If desired, save your workbook by selecting a Save option
from the File menu.

11 To close the workbook, select Close from the File menu.
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Chapter 6 — Workbook auto build maintenance

Overview

The Workbook Auto Build feature allows users to set up workbook builds to take
place on a regular basis during nightly batch runs. Workbooks to be built in this
way are added to the auto build queue. Because the workbook build process is
automated, users are spared the processing time required to regularly enter the
same wizard selections each time a new workbook is built. And because the
build process occurs overnight, users are spared the wait time associated with
constructing new workbooks.

The Workbook Auto Build feature works through the Workbook Auto Build
Maintenance Wizard.

Workbook Auto Build Maintenance Wizard

The Workbook Auto Build Maintenance wizard steps you through the processes
of adding and/or deleting workbooks from the auto build queue.

Procedures

Accessing the Workbook Auto Build Maintenance workbook
1 Select New from the File menu.

2 Select the Administration tab.

3 Highlight Auto Workbook Maintenance and click OK.

Add a workbook to the auto build queue

Workbooks in this queue are designated to be built automatically on a specified
regular basis as part of the nightly batch run.

Select New from the File menu.

Select the Administration tab.

Highlight Auto Workbook Maintenance and click OK.
From the task list, select Add Workbook and click Next.
Select a workbook template type and click Next.

Select an owner for the workbook and click Next.

~N o o A WD B

Fill in the workbook Build Label, the Build Frequency (in days) with which
the workbook should be built, and the Next Build Date.

Specify the Saved Access for the workbook: select User, Group, or World.

oo

9 Select the group that owns the workbook. You can choose from the list of
groups to which you belong.

10 Click Next to initialize the wizard for the workbook template selected in step
5 above. The choices you make are saved under the name you specified for
the Build Label.
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Delete aworkbook from the auto build queue

1
2
3
4
5
6

Select New from the File menu.

Select the Administration tab.

Highlight Auto Workbook Maintenance and click OK.

From the task list, select Delete Workbooks and click Next.

Select the workbook or workbooks to delete from the auto build queue.
Click Finish to delete the workbooks from the Auto Workbook Build queue.
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Chapter 7 — Translation administration

Overview

All of the Retek Predictive Solutions can be presented in multiple languages.
Every product, location, and calendar position can be displayed in multiple
languages, as can messages presented through the client. Translation
administration is the process by which administrators maintain the translation
tables for system text, including workbook template labels, template group
labels, user group labels, wizard instructions, pick list options, and error
messages.

The Translation Administration workbook contains worksheets for translating
text used in measure labels, workbook template names, template group names,
user group labels, and general areas (wizard instructions, pick list options, error
messages, etc.).

The worksheets contained in the Translation Administration workbook include:
e General Translations worksheet

e Measure Translations worksheet

o Template Translations worksheet

o Template Group Translations worksheet

e User Group Translations worksheet

General Translations Worksheet

The General Translations worksheet allows you to view and edit the translations
of text strings found throughout the Retek Predictive Solutions. Translations into
each of the system’s alternative languages are supported for all wizard
instructions, pick list options, system warnings and error messages, menu
options, etc.

Measure Translations Worksheet

The Measure Translations worksheet allows you to view and edit the translations
of measure labels. Translations are supported for each of the system’s allowable
alternative languages.

Template Translations Worksheet

The Template Translation worksheet allows you to view and edit the translations
of workbook template names. Translations are supported for each of the
system’s allowable alternative languages.
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Template Group Translations Worksheet

The Template Group Translations worksheet allows you to view and edit the
translations of template group names. Translations are supported for each of the
system’s allowable alternative languages. Translations in this worksheet affect
the labels on the tabs that appear in the File > New dialog; for example (in
English), Administration, Analysis, and Predict.

User Group Translations Worksheet

The User Group Translations Worksheet allows you to view and edit the
translations of user group labels. Translations are supported for each of the
system’s allowable alternative languages. The list of user groups includes the
Administration, Default, and Internal user groups, plus any other user group
names set up by the system administrator. For products in the Retek Predictive
Planning Suite, the list of user groups also includes the various planning roles.

Procedures

Accessing the Translation Administration workbook
1 Select New from the File menu.

2 Select the Administration tab.

3 Highlight Translation Administration and click OK.

Edit the foreign language translations of labels and system text
1 Select New from the File menu.
2 Select the Administration tab.
3 Highlight Translation Administration and click OK.
4 Maximize the appropriate worksheet.
= To translate measure labels, maximize the R_TRANS_MEAS worksheet.

= To translate workbook template names, maximize the R_TRANS WBT
worksheet.

= To translate template group names, maximize the R_TRANS WBTG
Translations worksheet.

= To translate user group labels, maximize the R_TRANS_GRP
worksheet.

= For all other translations, such as wizard instructions, list options, error
messages, menu choices, etc., maximize the R_TRANS_MSG
worksheet.

5 Atthe intersection of the language and the text value to be translated, enter
the correct translated text. Repeat this step as required for all text strings to
be edited.

6 On the File menu, select Commit Now.

7 On the File menu, select Close. Select a close option from the Close dialog.
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Process for using the General Translations worksheet

o Enter the correct translated text at the intersection of the language and the
string value to be translated.

Process for using the Measure Translations worksheet

e Enter the correct translated text at the intersection of the language and the
measure label to be translated.

Process for using the Template Translations worksheet

o Enter the correct translated text at the intersection of the language and the
workbook template name to be translated.

Process for using the Template Group Translations worksheet

o Enter the correct translated text at the intersection of the language and the
template group label to be translated.

Process for using the User Group Translation worksheet

o Enter the correct translated text at the intersection of the language and the
user group label to be translated.
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Chapter 8 — Batch processes and utilities
Using shell scripts to run batch processes

Running Acumate procedures written in the MSPL language is strongly
discouraged in RPAS 11. All MSPL procedures remaining in RPAS 11 should
be considered deprecated. Instead, batch processes should be written using shell
scripts that use the RPAS 11 binaries found in the SRPAS_HOME/bin/ directory
or application-specific scripts that should be located in the [DOM]/scripts/
directory. Any log files generated by shell scripts will be in the
[DOM]/scripts/err/ directory.

A sample shell script

The following is a sample shell script that loads the product and location
hierarchies into a domain. It is assumed that this script is invoked from the
[DOM]/scripts/ directory.

1 #1/bin/ksh

2 loadHier —d .. —-h prod -1 —u adm:adm >
./err/loadhier.prod.log

3 loadHier —d .. —h loc -1 —u adm:adm >>
-/err/loadhier._loc.log

Line 1 defines the shell that will execute the script. In this example, it is defined
to be the Korn shell. Therefore, this script will always be executed from the Korn
shell even if the user’s shell is different.

Lines 2 and 3 call the loadHier utility to load the latest product and location
hierarchy information. Depending on the batch process to be performed by the
shell script, lines 2 and 3 can be replaced by one or more lines to call one or more
RPAS 11 utilities.

The remainder of this chapter describes the RPAS 11 utilities that are involved in
the most commonly used batch processes.



38 Retek Predictive Application Server

Hierarchy configuration and position-level security

The inithier utility can be used to configure hierarchies and dimensions in a
domain. The primary way in which it does this is by importing data from arrays
created by the asetup.init_hparm procedure. Specify the —import flag to cause it
to import hierarchy definitions created by init_hparm. When the —import flag is
used, this utility will also set the prerange_threshold and sparse_create domain
properties that can be specified in the init_hparm procedure.

The inithier utility can also be used to enable and disable position security for a
hierarchy. To enable position security, use the —h argument with the name of the
hierarchy along with the —securityDim argument with the name of the dimension
for which position security is enabled. Specifying —noSecurity will disable
position level security for the hierarchy.

Usage:
inithier —d pathToDomain —import
OR

inithier —d pathToDomain —h hierarchyName (-securityDim dimName |
—noSecurity)

Argument Description

—d domainPath Specifies the directory in which to create the
domain. The path must be an absolute path, and it
will be created if it does not already exist.

—import Use this argument to import hierarchy definitions
created by init_hparm. Using —import also sets the
prerange_threshold and sparse_create domain
properties that can be specified in the init_hparm
procedure.

—h hierarchyName Specifies the name of the hierarchy for which
position-level security is enabled or disabled. Use —
h with either —securityDim or —noSecurity.

—securityDim Specifies the name of the dimension for which
dimName position-level security is enabled.
—noSecurity Use this argument to disable position-level security

for the hierarchy specified using the —h argument.
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Hierarchy loading process

Loading hierarchies is usually a batch process that is run from a shell script
called run_hierload. sh, which contains the following procedure calls:

loadHier —d .. —h prod —1 —u adm:adm
loadHier —d .. —h loc —1 —u adm:adm
reshapeArrays —d .. —-db ../data/sales
reshapeArrays —d .. —db ../data/salesloads

These are the steps in the hierarchy loading batch process:

1 Update the product and location hierarchies by running the loadHier utility
twice. First, the utility runs with argument prod to update the product
hierarchy and next with argument loc to update the location hierarchy..

2 Rebuild data arrays with new hierarchy contents/elements by running the
reshapeArrays utility twice. First, the utility runs on the sales database, and
then on the salesloads database. The reshapeArrays utility checks all the
arrays in the argument database against the current dimension definitions and
revises them accordingly.

The loadHier utility can be used to load or refresh a hierarchy. Usage of the
utility is:

loadHier —d domainPath —h hierName (I | -r ) {~c} {~u user:password}

Argument Description
—d domainPath The directory containing the domain.
—h hierName The name of the hierarchy to load or refresh.

- Load the named hierarchy.

—r Refresh the named hierarchy.
—C Check parents while doing the load.
-u Specify the acumate user and password, defaults to adm.

The —d and —h parameters are required. Use either the —I parameter to specify a
hierarchy load or the —r parameter to specify a hierarchy refresh. The —c
parameter is optional. If present, the structure of the hierarchy is validated
during the load. The —u parameter can be used to indicate the Acumate user and
password to use when performing the load or refresh.
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The reshapeArrays utility can be used to make arrays conform to the current
hierarchies in the domain. Any positions added to dimensions as a result of
running loadHier will be added to arrays that have this dimension. Any positions
removed from dimensions will be removed from the arrays. Usage of the utility
is:

reshapeArrays —d domainPath —db dbName {-array arrayName} {—purge}
{-version} {-debug}

OR
reshapeArrays —d domainPath —registered {-purge} {-version} {-debug}

Argument Description
—d domainPath Specifies the domain containing the arrays to be
reshaped.
—registered Use this argument to reshape all registered arrays. You

must specify either
—registered or—db, but not both.

—db dbName If you specify —db, all arrays in the specified database
are reshaped. You must specify either —registered or—db,
but not both. doName can specify either a full or
relative path to the database. If the path is relative, it is
relative to the root of the domain.

—array arrayName | Specifies which arrays in a database are to be reshaped.
This argument can be repeated to reshape multiple
arrays. If —array is not specified, all arrays in the
specified database are reshaped.

—purge If —purge is not specified, the original database will be
copied to dbName.bak.

Using —db will cause all arrays in a single database to be reshaped. dbName may
be a full or relative path. If it is relative, it must be relative to the root of the
domain. If —array is specified, a single array will be reshaped. —array can be
repeated on the same command line to reshape more than one array. Using
—registered will cause all registered arrays (currently just all measure data arrays)
to be reshaped. Either —db or —registered is required, but they are exclusive. If
—purge is not specified, the original database will be copied to dbName.bak.
Otherwise no backup copy will be made.
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Data loading process

Loading the data into a domain is usually a batch process that is run from a shell
script called run_dataload.sh. This shell script contains a series of RPAS
11 utilities, such as the following:

loadMeasure —d .. —m csal -1 —u adm:adm
loadMeasure —d .. —m psal —1 —u adm:adm
loadMeasure —d .. —m rsal —1 —u adm:adm
mace —d .. —run —group post data load

This process consists of loading the domain’s measures, one at a time, from a text
file, using each measure’s attribute. In this example, the three measures csal,
psal, and rsal are loaded from their corresponding text files. The mace utility is
then used to execute a rule group called post_data_load.

The loadMeasure utility can be used to load data into a measure or to apply any
staged data loads for the measure. Usage of the utility is:

loadMeasure —d domainPath —m measName (-1 | —a ) {-u user:password}

Argument Description
—d domainPath The directory containing the domain
—m measName The name of the measure to load (should be lowercase)

-1 Load the named measure

-a Apply any staged loads for the named measure

-u Specify the acumate user and password, defaults to adm

The —d and —m parameters are required. Use either the —| parameter to load data
into a measure or the —a parameter to apply any staged loads. The —u parameter
can be used to indicate the Acumate user that will be running the load process.

The mace utility allows you to evaluate rule groups or expressions in order to
manipulate measures. The most commonly used for batch processes will be:

mace —d path_to_domain —run —group ruleGroupName

OR
mace —d path_to_domain —run —expression ‘“temporary
expression”

The first will cause an entire rule group to be evaluated. The second will
evaluate a single expression.
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The mace utility can also be used to:

create rules and rule groups

add rules to rule groups

add expressions to rules

delete rules not contained in a rule group
remove any or all rule groups

validate expressions

print a list of rules or rule groups.

Usage:

mace —d domainPath —find string

mace —d domainPath —newGroup groupName

mace —d domainPath —newRule

mace —d domainPath —addRule groupName:ruleName

mace —d domainPath —addExpression ruleName —expression exprString
mace —d domainPath —check —expression expString

mace —d domainPath —resolve groupName —measures measureL.ist
mace —d domainPath —transit workbookName —group groupL.ist

mace —d domainPath —print (—rule ruleList | —group groupList | allGroups)
mace —d domainPath —purgeRules

mace —d domainPath —removeGroup groupName

mace —d domainPath —removeAllRuleData

Argument Description
—d domainPath Specifies the domain in which to load the
measure.
—find string Use this argument to search all expressions for

the specified string, printing all the rules and
rule groups that have these expressions.

—newGroup groupName Use this argument to create a new rule group
with the specified name.

—newRule Use this argument to create a new empty rule.

—addRule Use this argument to add the specified rule to

groupName:ruleName the specified rule group.

—addExpression ruleName | Use this argument to add an expression to the

specified rule.
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Argument

Description

—expression exprString

Use the argument to specify the expression.
This argument is used in conjunction with the —
addExpression, —check, and —run arguments.

—check Use this argument to validate the specified
expression.
—run Use this argument to evaluate the specified

expression or rule group.

—group groupName

Use this argument to specify the rule group to
evaluate using the —run argument.

—resolve groupName

—measures measureList

Use this argument to specify the measures to
resolve.

—transit workbookName

—group groupL.ist

Use this argument to specify a list of group
names, separated by commas. Use this
argument in conjunction with the —transit and —
print arguments.

—print

Use this argument to print all the specified rules
and rule groups. The ruleList is a comma-
separated list of rule names. If no ruleList is
specified, all rules are printed. The groupList is
a comma-separated list of group names. If no
groupList is specified, all rule groups are
printed.

—rule ruleList

Use this argument to specify a list of rule
names, separated by commas. Use this
argument in conjunction with the —print
argument.

allGroups

Use this argument in conjunction with the —
print argument to print all rule groups.

—removeGroup groupName

Use this argument to remove the specified rule
group. It also removes all rules within the rule
group that are not shared by other rule groups

—purgeRules

Use this argument to delete all rules that are not
contained in any rule group.

—removeAllRuleData

Use this argument to remove all rule groups and
all rules.
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Managing alerts
Use the alertmgr utility to:
o find alerts
e register and unregister alerts
e add expressions to alerts
o create and label alert categories.
Usage:

alertmgr —d pathToDomain —findAlerts | (-register | —unregister |
—addExpression) alertName {—category catName} {—categoryLabel label}
{—expression \"expr\"}

Argument Description
—d pathToDomain Specifies the directory in which to run the utility.
—findAlerts Finds all the alerts in the specified domain.
—register alertName Use this argument to register an alert. Requires —

category, —categoryLabel, and —expression.
Important: alertName must be the name of a
registered Boolean measure.

—unregister alertName | Use this argument to unregister an alert. alertName
must be the name of a registered Boolean measure.

—addExpression Use this argument to add an expression to the alert.
Use —expression to specify the expression.

—category catName Use this argument to specify a category for the alert.

—categoryLabel label Use this argument to specify a label for the alert
category.

—expression \"expr\" Use this in conjunction with —addExpression and —

register. expr can be any valid RPAS 11 expression.
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Batch workbook processes
Use the whbbatch utility to do the following:
e Run auto workbook builds
e Run deferred commits
o Refresh scheduled workbooks.
Usage:
whbbatch —d pathToDomain (-build | —-commit | —refresh)

Argument Description

—d pathToDomain | Specifies the domain containing the workbooks.

—build Runs auto workbook build.
—commit Runs all deferred commits.
—refresh Refreshes all scheduled workbooks.

Registering and unregistering measures

Use dattrmgr to register and unregister measures. Either —register or —unregister
is required. measName must be the name of a registered one-dimensional
measure.

Usage:
dattrmgr —d domainPath -register | (-unregister) measName

Argument Description
—d domainPath Specifies the domain containing the measure you
wish to register or unregister.
—register measName Use the —register argument to register the named
measure.

—unregister measName | Use the —unregister argument to unregister the
named measure.
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Changing domain properties

Use the domainprop utility to manipulate the properties of a domain. You can
specify password properties, lock user accounts, and determine whether or not a
daemon is currently managing a domain.

Usage:

domainprop —d pathToDomain {—expirePassword {days}}
{—passwordHistory {oldPasswordCount}} {—property propertyname=value}
{-lockAccount {failedLogins}} {-daemonPort}

Argument Description
—d pathToDomain Specifies the domain you wish to
manipulate.
—expirePassword Used to set or view the number of days a

password is valid. If a number follows the
argument it sets the number of days a
password is valid for; otherwise it prints the
current setting.

—passwordHistory Used to set or view the number of previous
passwords that are kept to ensure that a user
does not repeat his password too often. If a
number follows —passwordHistory, the
property is set to that number; otherwise the
current setting is printed.

—property propertyname=value | Used to specify the property to be changed.

—lockAccount Used to set or view the number of failed
login attempts that can occur before the
account is locked out. If a number follows —
lockAccount, the property is set to this
value; otherwise the current setting is
printed.

—daemonPort Prints a message indicating whether or not
the domain is currently being managed by a
domain daemon. If the domain is not
currently being managed, the port of the last
daemon to manage the domain is printed.
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Exporting data

Use exportData to export measure data from Acumate databases into text files.
Each line exported contains the position name for the exported dimension
followed by the value in the cell for each array being exported. Note that more
than one array may be exported and more than one dimension in each array can
be exported.

The utility may be invoked by specifying all parameters on the command line or
by specifying an array that contains a list of the parameters.

The parameters specify what arrays and dimensions are exported and how to
format the data. It is best to specify the arrays first. An array specification begins
with —array followed by the array information. This includes the array name,
formatting string, NA cell value, and NA cell value formatting string. The
formatting string for both the cell value and NA value is based on the C language
printf function formats. Please see the documentation on the printf function if
you are not familiar with the possible values. The —array parameter can be
repeated as needed to export more than one array into the same export file.
Remember that the order the arrays appear in the —array parameter is the order
they will appear in the export file.

After the arrays have been specified, the next thing to do is specify the
dimensions to be exported within the arrays. The —dim parameter is used to
specify a dimension in an array. The —dim parameter is followed by the
dimension name, a convert option, the formatting string (just like an array), and
the order the dimension appears in the export file. Because arrays are not
required to contain identical dimensions, it is important to list all dimensions in
all arrays with the —dim parameter. This makes it possible to track dimensions
across arrays and line the data up correctly. If a dimension in an array is not to be
in the export file, simply set the last value of this parameter to 0. The conversion
option specifies either the number of characters to be removed from the position
name or it specifies an array that contains the real position name. If an array
name is given, this array must be a vector. The function will go to this array and
use the original position name to jump to the cell of the same position name. It
will then get the cell value and use that as the position name in the export.

The —wide parameter causes the data to be exported wide meaning the innermost
dimension will go across the row instead of each cell on a separate line. This is
most useful when the innermost dimension is time. This format puts all time data
on one row of output with breaks for each of the other exported dimensions. The
—range parameter can be used in conjunction with wide format (—wide) to specify
a range along the innermost dimension. Only values in the range will be
considered for export. In future versions ranges could be expanded to include the
column format.
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The —skipNA parameter is used for the NA suppression option. This option
controls whether data is exported based on it having NA’s in the export row. The
choices for the —skipNA parameter are ANYNA, ALLNA, ALWAYS, or
ARRAYNA. The ANYNA value will cause a row of data not to be exported if
any cell contains a NA value. The ALLNA value will cause a row of data not to
be exported only if all values in the row are NA. The ALWAY'S value will export
data regardless of whether it contains NAs. The ARRAYNA value will cause a
row of data to not be exported if the value in the given array name is NA. If the
ARRAYNA value is set then the —naArray parameter must be given. This
parameter is followed by the array name to be used with the ARRAYNA value.

If all parameters are contained in an array then after the export file name and
source database name the -—params parameter is used to specify the database
name and array name that contains all the parameters needed for the export.

Usage:
exportData —version
exportData —d domainPath —out outputFile —params db array

exportData —d domainPath —out outputFile —meas \"measSpec\"
{-wb wbName} {options}

exportData —d domainPath —out outputFile —array \"arraySpec\" {options}

Argument Description
—version Prints the RPAS version, revision, and build
information.
—d domainPath Specifies the domain containing the data you

wish to export.

—out outputFile Specifies the file that will contain the exported
data. The outputFile is relative to the domain,
unless the full path is specified.

—params db array Instead of specifying all parameters on the
command line, this parameter allows the
parameters to be read from an array.

db specifies the name of a Gem file where the
array of parameters is stored. array specifies the
name of an array in the specified database that
has the above parameters

—meas Specifies the measure to export. measSpec must
be quoted, and the format is \"measName
cellFormat naValue naFormat\". The —-meas
argument can be repeated to export multiple
measure arrays to the same output file.
Measures are exported at the base intersection.
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Argument

Description

—array

Specifies the array to export. arraySpec must be
quoted, and the format is \"doName|arrayName
cellFormat naValue naFormat\". dbName can be
a path to the database (relative paths are relative
to the domain root). Both cellFormat and
naFormat use printf format commands. Please
see the documentation on the printf function if
you are not familiar with the possible values.
The —array argument can be repeated to export
multiple arrays to the same output file. The
order in which arrays are listed is the order in
which they will be exported.

Option

Description

—dim \"dimSpec\"

Specifies the dimension to be exported.
dimSpec must be quoted, and the format is
\"dimName conversion format order\".
conversion is either a count of the number of
characters to strip from the start of the position
name or the name of an array to be used to
translate the position name before writing to the
output file. format is a printf-style format for
the position names. Please see the
documentation on the printf function if you are
not familiar with the possible values. order
indicates the order the dimension is listed in the
output file. If the value is 0, then the dimension
is not exported. The —dim parameter can be
repeated.

—skipNA
always|allnajanynajarrayna

Controls whether a line of data is exported
based on having NAs in a cell. always exports
data regardless of NAs. allna does not export if
all columns are NA (default). anyna does not
export if any column is NA. arrayna does not
export if cell value in an array is NA (requires
—naArray).

—naArray arrayName

When arrayna is specified using the —skipNA
parameter, this option specifies the export array
that is checked to determine if data is exported.

—index arrayName

Controls whether arrays are indexed by looking
at a specified array. Only export the non-NA
cells in the given array and each cell in the other
arrays that have the same position names. If
another array is at a higher dimension level,
translate the given arrays cell index to the other
arrays.
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Option Description

—range start:end Used in conjunction with the —wide parameter,
specifies a range along the innermost
dimension. Only values in the range are
considered for export.

—append Specifies that output is appended at end of
output file. The default is to overwrite output
file.

—-wide Exports data in innermost dimension across
instead of down.

—time Specifies a YYYYMMDD format for dates.

List database contents
Use the listDb utility to list the contents of a database.
Usage:
listDb —db dbName

Print array contents
Use printArray to print the contents of an array.
Usage:

printArray —array admin.userinfo {-specs} {-cells
"dim1:posl,dim2:pos2,..."} {~format "formatString"}

Argument Description
—array db.array Specifies the array you want to print.
-specs
—cells Identifies a single cell or a 1-D slice. Must not contain

spaces. Specify using the format
“dim1:posl,dim2:pos2,...”

—format If —format is specified, any cells with numeric values
are interpreted as dates. formatString determines how
dates are interpreted, and can include:

%Y - 4 digit year

%m - month number (01 to 12)

%d - numeric day of month (01 to 31)
%H - 24 hour clock (00 to 23)

%M - minute (00 to 59)

%S - seconds (00 to 61)

%s — milliseconds
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Print measure information
Use the printMeasure utility to print measure information.
Usage:

printMeasure —d pathToDomain —-m measure {—wb workbookName}
{-specs} {-listDatalntersections} {—printData aggType.intersection}

Argument Description
—d pathToDomain Specifies the domain containing the measure you
want to print.
—m measure Specifies the measure you want to print.
—wb workbookName Specifies the workbook associated with the measure

you want to print. If a workbook is not specified,
the domain measure information is printed.

—Specs

—listDatalntersections

—printData
aggType.intersection

Registering a user-defined dimension

Use reguserdim to register a user-defined dimension. After you register a user-
defined dimension, you can define positions using the RPAS Hierarchy
Maintenance template.

Usage:

reguserdim —d pathToDomain {-register todimName} {-label todimLabel}
{-db dbPath}{-fromdim fromDimName} {-users accessibleUsers}

Argument Description

—d pathToDomain Specifies the domain to which the user-defined
dimension should be added.

—register todimName Use this argument to register the named
dimension. Dimension names cannot exceed four
characters in length.

—label todimLabel Specifies the dimension label.

—db dbPath Specifies in which database the user-defined
dimension is stored.

—fromdim fromDimName | Specifies the dimension to which the user-defined
dimension rolls up. Dimension name must not
exceed length of 4 characters.
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Argument

Description

—users accessibleUsers

Specifies the users who can modify the user-
defined dimension. If this argument is not
specified, all users in the domain can modify this
dimension. The user names should be separated
by spaces.

RPAS version

Use this utility to determine which version of RPAS is running in a particular

location.

Usage:

rpasversion —| pathToLibrary

Logging batch processes

RPAS batch processes may run for a long time. Therefore, it is sometimes
difficult to know the step currently being performed. Fortunately, the RPAS
server code provides a large amount of detailed output messages from its
processes, to help the system administrator troubleshoot, benchmark, and
estimate job completion times. The batch processing shell scripts direct those
messages to output files (log and error files) located in [DOM]/scripts/err. These
output files typically use the following naming convention:

batchProcess.date&timestamp.fileType

where:

BatchProcess = The name of the shell script or the corresponding batch

process.

data&timestamp = The date and time when the script is executed in the
format yyyymmddhhmmss.

fileType = The type of the file that can be “log” or “err” to indicate whether
itis a log file or an error file.
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Log files

Log files usually include a time stamped message that indicates the step being
currently executed. Here is the output from a typical RDF forecast batch process
job:
ACUMATE (TM)
Copyright Kenan Systems Corporation. 1992, 1993
ACUMATE is a trademark of Kenan Systems Corp.

WELCOME TO ACUMATE ES1.31, (ADM), AT 15:02:27 ON 29-Oct-
97

ACUMATE COMMAND?

WARNING: CHECKPOINT_ON_AT_OPEN

ACUMATE Database, THIS _WB has checkpointing active.
WARNING: PREV_LOGOFF_FAILED

ACUMATE COMMAND? 15:02:29 Open fmaint and faprv for
write access.

INFORMATION: COMPRESS_STATISTICS
During compression 3,452 bytes were moved.
INFORMATION: COMPRESS_COMPLETE

37,360 bytes (10 x 4,096 byte blocks) now in use, was
37,360.

------------- Finished Forecasting-----—--—————--

ACUMATE COMMAND? ACUMATE logged out - Goodbye JIM(ADM),
at 15:03:06 on 29-0Oct-97

Configuration tools log files

For the RPAS configuration tools, information is in logged in the files stderr.txt
and stdout.txt, which are located in the bin sub-directory of the Tools directory.
If you experience a problem with the configuration tools, you should send these
two files to Retek Customer Care along with a description of the problem.
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Error files

Error files are usually generated during data loading. These files include a list of
bad records followed by the total number of records read and related information.
Here is part of the output from a typical data loading batch job.

Loading array TEMP in nonoverlay mode. Zero values are
loaded.

Skipping cell with invalid position:
INFO 1
DAY 1996D364
SKU  SKU_00726828
STR STR_0107
Skipping cell with invalid position:
INFO 1
DAY  1996D364
SKU  SKU_00726828
STR STR_0201
Skipping cell with invalid position:
INFO 1
DAY  1996D364
SKU  SKU_00726828
STR STR_4008
Skipping cell with invalid position:
INFO 1
DAY  1996D364
SKU  SKU_00726828
STR STR_4009
Skipping cell with invalid position:
INFO 1
DAY 1997D6
SKU  SKU_00726828
STR STR_0107
Skipping cell with invalid position:
INFO 1
DAY 1997D6
SKU  SKU_00726828
STR STR_0201
Array -- TEMP. Load time: 0:02
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LoadComplete -- Records read: 4240, Total cell updates:
4240

New cells created: 4028
Cells with invalid positions: 212
Cell updates: O
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Glossary

aggregate

To summarize data at a lower hierarchy level into a single category at a higher
hierarchy level.

To roll-up worksheet data.
See also aggregation method.

aggregation method

The method used to aggregate data, or to provide a summary view of lower-level
data at a higher level of aggregation. A measure’s aggregation method
determines how the system populates aggregate level cells based on the
component values of base-level cells.

In dialogs that prompt you to specify an aggregation method, the choices and
their meanings are as follows:

e ?: Aggregate by displaying the first lower level value if they are all the
same; otherwise, display a *?.’

o ?of Populated: Aggregate by displaying the first non-NA lower level value
if they are all the same; otherwise, display a *?.’

e Avg:. Aggregate by displaying the average of all lower-level values.
e First: Aggregate by displaying the first of all lower-level values.
e Last: Aggregate by displaying the last of all lower-level values.

e Last of Populated: Aggregate by displaying the last of all non-NA lower-
level values.

e Logical Count: Aggregate by counting the logical cells at the lower level and
displaying this value in the aggregate cell.

e Logical Count of Populated: Aggregate by counting the logical cells at the
lower level if there is at least one populated cell.

e Max: Aggregate by displaying the maximum of all lower-level values.
e Min: Aggregate by displaying the minimum of all lower-level values.
e Period End Avg: Aggregate by displaying the period-ending average.

e Period End Total: Aggregate by displaying the period-ending total, or total
value present at period end.

e Period Start Avg: Aggregate by displaying the period-starting average.

e Period Start Total: Aggregate by displaying the period-starting total, or total
value present at period start.

e Pop Count: Aggregate by counting the populated cells at the lower level and
displaying this value in the aggregate cell.
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o Total: Aggregate by summing up all lower-level values.

alert

A notice displayed to system users that a forecasted value is above or below user
defined limits (an exception).

Alert Manager window
A window that displays the alerts assigned to you.

This dialog provides a list of all identified instances in which a monitored
measure’s values fall outside a set of defined limits. You may pick an alert from
this list and have RCS automatically build a workbook containing the measure
values that triggered the alert.

attribute

A piece of information associated with a given dimension that helps to further
describe the positions contained in that dimension. For example, positions in the
SKU dimension of the product hierarchy could be described by the attributes
COLOR, SIZE, and LABEL. Positions can be described by any number of
attributes; LABEL is the only required attribute. Attributes can be displayed in
the grid, if desired, and attributes can be used to sort positions within a
dimension.

auto build queue

The automatic workbook build queue that specifies the Retek Predictive
Solutions workbooks to be automatically built during user-defined batch runs.
Workbooks are added to and deleted from this queue through the Workbook
Auto Build Maintenance wizard.

axis

On a Demand Forecasting grid, a row (x-axis), column (y-axis), or slice (pages).
Each axis is used to display one dimension of an item.

chart

An alternative to displaying data in a grid. In the Retek Predictive Solutions,
available options for displaying data in chart form include pie charts, bar charts,
line charts, and others.

cloning measures

Creating copies of a selected measure’s properties and calculations for the
specified selections in a category.

commit

Transferring saved workbook data to the master database, allowing other users to
access and use the data.
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collapse

Removing from view the wizard list items displayed for a hierarchy level below
the level selected.

column

On a grid, an axis or display area that runs vertically (y-axis).

custom measure

A measure that is created and registered by system administrators. System users
can then insert the custom measure in workbooks, or use the measure in
generating alerts.

derived calculation

A calculation that defines a derived measure in terms of other dependent
measures.

derived measures

Measures that are not stored. Their values are derived from one or more other
measures.

dimension

A quality of an item (such as a product, location, or time) that can be displayed
on an axis of a grid. For example, product, location, or time.

display area

One of three portions of a worksheet that contain the measures and hierarchy
tiles.

display order

The order in which the attributes of a dimension are displayed on a specific axis
of grid. Users define which attributes to display and their display order. Display
order is independent of sort order.

exception

A forecast value that is greater than or less than a user-defined limit.

expand
To display worksheet data for a hierarchy level below the level selected.
grid

A structure used by the Retek Predictive Solutions to display multidimensional
arrays of data.
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hierarchies

Structures used to define subordinate relationships among items in a dimension,
such as product, location, time, or other.

hierarchy tile

Hierarchies are the structures used by an organization to describe the
relationships that exist between the many dimensions. Typically, any dimension
will belong to one of these hierarchies (there may be others, but these are the
most common): Product, Location, or Calendar (or Time). The Measure
hierarchy consists of the measures, or metrics on the worksheet. These
hierarchies are represented on the worksheet by hierarchy tiles, or named gray
rectangles that represent each hierarchy. The hierarchy tiles you will see in Retek
Predictive Solutions include:

| Product ” Location ” Calendar ” Measurel

imported measure

Measures that are stored and also specify import properties for loading data.

import properties

The measure attributes that specify where and how data will be imported from an
external source.

mask

A filter that allows specified combinations of workbook items (cells) to be
hidden.

master database

The main data repository where the application data for all the Retek Predictive
Solutions resides. To manipulate the data in the database, the appropriate
product, location, and time information is extracted from the database to a
workbook. The workbook is a temporary repository that you can use to
manipulate and analyze the data. The data in a workbook is committed, or
written, back to the master database through a commit function. For example,
planning data viewed on TopPlan worksheets is read from and written to the
master database.

Also referred to as the master cube.

measure

Any item of data that can be represented on a grid in worksheets. In the Retek
Planning Solutions, measures also specify exactly one role, version, metric, and
unit of measure For example, the measure for Planners Working Plan Sales
Value is expressed as Pl Wp Sales V.
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measure description

The description of the measure that can be viewed in a workbook. This
description may contain relationships and calculations.

measure function

Internal functions that can be used to simplify building calculations for a
measure.

measure identifier

The combination of role, version, metric, and units that uniquely specifies a
single measure.

measure profile

A worksheet-specific set of visible measures that is saved under a unigue name.
Measure profiles allow you to quickly change the measures and measure
attributes displayed in a workbook, by enabling you to select an entire block of
desired measures in one quick step.

measure properties

Administrator-defined properties that specify measure attributes.

metric

A measure definition with the role, version, and units omitted, such as Sales,
Markdowns, Gross Margin.

multidimensional

Capable of containing and displaying three or more dimensions of data.

new measure

A measure with undefined properties and calculations.

node

A row or column of data.

on change calculation

The calculation that is mapped to another measure. The other measure identifier
will always be on the left side of the expression.

ordering

Defining the order in which calculations should be solved.
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parent

For any cell at a given dimensional level, the cell at the next higher dimensional
level into which the original cell’s data values aggregate. Along a particular path
of aggregation, a cell’s value can only roll up into one parent.

For example, at the Month level, January, February, and March sales figures
could roll up into the parent cell Quarterl.

percent contribution

A measure attribute that specifies whether the measure displays actual data
values, or whether the measure displays the percentage of total that each measure
position represents relative to the next higher visible dimension in the grid. The
Percent Contribution attribute can take on one of two values: None or Parent.

¢ None: A measure with a percent contribution attribute value of ‘None’
displays actual numeric data values for the measure in question (such as
Sales Units).

e Parent: For the same metric, a measure with a percent contribution attribute
value of ‘Parent’ displays for each position the percentage of total that the
position represents relative to the next higher visible dimension in the grid.

Also referred to as percent of parent.

pivot

To change the locations (relative to each other) of two or more hierarchy tiles on
the same axis of a grid. This changes the display order of the data for the tiles.

point labels

Labels that display the data value corresponding to each marker (series or point)
in a chart. In bar graphs, the value of each series appears in a point label above
the bar. In line graphs, the value of each point appears in a point label above the
corresponding point marker. You can toggle the display of point markers in your
chart by selecting the Point Labels option on the Chart F/X quick menu.

quick menu

A menu that contains functions specific to the screen location where the user is
working. Clicking the right mouse button displays a quick menu. Also known as
a context menu.

ranging

To specify ranges of positions in a hierarchy over which you want to apply an
alert. For example, you might want only one subclass of products, and not the
entire product hierarchy, to be monitored by a particular alert.

register (a measure)

To store the measure in a standard way on the system server.
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role

An element in a grouping scheme that specifies a default base intersection for a
group of measures. Roles are typically defined in order to separate related
measures into groups associated with distinct user classes. The role-assignment
process allows for the partitioning of measures such that users of a particular user
class are only given visibility to measures associated with that class.

When a measure is registered, it must be associated with a valid role component.
Certain application server dialogs, such as the Show/Hide Measure dialog and the
Insert Measure dialog, require you to designate the measure you want to work
with. You do this by specifying all the component attributes (role, version, units-
of-measure, and metric) that make up a measure's complete definition.

Certain Retek applications (such as Demand Forecasting and JMI) require only
the selection of the default role value ‘None." Planning applications, such as
TopPlan and KeyPlan, require you to make a role selection from the list
provided. For more information on the options available, see the Operations
Guides for the applications, or contact your system administrator.

roll down

To move to a lower level of a hierarchy.

roll up
To move to a higher level of a hierarchy.

rotate

To change the location of one hierarchy tile and its measure from one axis (y-
column, x-row, or page-slice) to another.

row

On a grid, an axis or a display area that runs horizontally (x-axis).

scaling factor

A multiplier associated with an individual measure that is applied to each edited
data value to speed the process of data entry. Data values entered for measures
associated with a scaling factor are scaled to an internal value that is recognized
by the server (but not seen on the client display). A scaling factor can be
specified as a prefix or a suffix:

o Prefix: A character string that appears before each data value for a selected
measure. For example, the prefix ‘3’ could be specified for a measure to
indicate monetary data.

o Suffix: A character string that appears after each data value for a selected
measure. For example, the suffix ‘k’ could be specified for a measure
associated with a scaling factor of 1000; then, entering the value ‘6’ in a cell
would result in the display of “6k’.
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selection set

The set of wizard selections made when the user proceeds normally through the
workbook build process. A set of such choices can be saved and later applied
during the auto build process, thus eliminating the need for the user to be present
to enter choices on each wizard dialog when the workbook auto build is
initialized.

slice

On a grid, an axis or a display area that is shown by paging through worksheets.

sort order

On a grid, the order by which displayed dimensions are listed. Users define
which attributes to sort by and which to prioritize. Sort order is independent of
display order.

spread
To allocate data obtained from a single group at a higher hierarchy level into
groups in a lower level, in specified ratios or proportions.

stored measure

A stored measure is identical to an imported measure, except that no import
properties are specified. If the measure is read/write, the user will be able to
commit data. If read-only, the measure may be imported internally from another
source.

unhide (show)

To return to view a worksheet or a worksheet measure that was previously
hidden.
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units
The units that define how data will be processed and displayed.

In dialogs that prompt you to specify the units for measures, the choices and their
meanings are as follows:

e Check = checkbox (Boolean)

e C=cost

o C% = cost value % variance or contribution
o D=date

e Select = pick list

e Stores = number of stores

e V =retail value

o V% =retail value % variance or contribution
o Text = text

e True-False = true-false (Boolean)

e U =units

e U% = units % variance or contribution

e No Units = used within Retek TopPlan for ratios, Average Unit Retail (AUR)

e X =none

unused measure

A measure with no relationships (that is, with no measures referencing it in their
calculations).

user group

A subset of application users to which a given user belongs. Users must be
assigned to a user group. Assigning users to groups provides a level of security
into workbooks that users create and save. When users save a workbook, they
assign one of three access permissions to the workbook: allow any user to open
and edit the workbook, allow only those users in their same group to open and
edit the workbooks, or allow no other users to open and edit the workbook.

Users are typically assigned to groups based on similarities in job functions.
Users in the same group can be given access to workbooks that belong to that
group alone.

User groups are defined in the User Account Management workbook, and viewed
in the Groups Worksheet of the User & Template Administration workbook.
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version

An element in a grouping scheme that allows for partitioning of measures based
on workflow or data source. Versions are typically defined in order to allow for
the maintenance of distinct measure values along a workflow timeline. For
example, an original plan value for sales can be defined pre-season and later
compared to a current plan value for the same measure in-season.

When a measure is registered, it must be associated with a valid version
component. Certain application server dialogs, such as the Show/Hide Measure
dialog and the Insert Measure dialog, require you to designate the measure you
want to work with. You do this by specifying all the component attributes (role,
version, units-of-measure, and metric) that make up a measure's complete
definition.

Certain Retek applications (such as Demand Forecasting and JMI) require only
the selection of the default version value 'None." Planning applications, such as
TopPlan and KeyPlan, require you to make a version selection from the list
provided. For more information on the options available, see the Operations
Guides for the applications, or contact your system administrator.

watch measure

A custom measure that is used as the basis for an alert. Watch measures are
created using the Measure Maintenance dialog, and associated with alerts using
the Alert Builder wizard.

wizard

A set of screens that guide you through the process of creating a new workbook
or performing other actions in an application, by asking you various questions
and having you select values.

workbook

The framework used for displaying data and user functions. Workbooks are task-
specific and may contain one or more worksheets. Users can define the format of
their workbooks.

See also workbook template, worksheet.

workbook template

The framework for creating a workbook. You build each new workbook from an
existing workbook template, such as Pre-Season Financial Plan or Forecasting
Administration. Several workbook templates are supplied with the Retek
Predictive Solutions, and are available for selection when you choose File > New
to create a new workbook.

worksheet

A multidimensional spreadsheet used to display workbook-specific information.
Worksheet data can also be displayed in chart format.
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Zoom

When working with a grid, the zoom feature enlarges the grid contents of the
active window for easier viewing, or reduces the size of the contents in order to
fit as much data on the terminal display as possible.
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