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• Exact error message received. 
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Chapter 1 – Introduction 
The Retek Predictive Solutions are a set of products for generating forecasts and developing 
trading plans, and analyzing customer behavior. These products use predictive technology to 
examine historical data and predict future behavior.  

The Retek Predictive Solutions run from a common platform called the Retek Predictive 
Application Server that includes features such as:  

• Multidimensional databases 

• Product, time, and business location hierarchies 

• Aggregation and spreading of data 

• Workbooks and worksheets for displaying and manipulating forecast data 

• Wizards for creating and formatting workbooks and worksheets 

• Menus, quick menus, and toolbars for working with forecast and sales data 

• Exception management and user-friendly alerts  

This help system describes these common features and the procedures associated with them. 

More information 
The scope of this document and the RPAS online help system is the common user interface 
features and functions only. For specific information on the applications that run on the Retek 
Predictive Application Server, see the Operations Guides for the applications, or contact your 
system administrator. 
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Chapter 2 – Basic RPAS concepts 
Multidimensional databases 
Overview 
Applications that run on the Retek Predictive Application Server use multidimensional databases 
to store data records. The worksheets used to display data are called multidimensional 
worksheets. In both cases, multidimensional refers to the manner in which data records are stored 
in the master database. A multidimensional database provides a number of significant benefits 
over the relational database, which is the typical method of storing and presenting data. This topic 
compares multidimensional and relational databases, and it describes the fundamental aspects of 
these databases, such as dimensions and hierarchies. 

Relational databases 
The following table shows a typical relational database and compares its features to those of the 
multidimensional method of storing data. The table shows sales volumes for an athletic shirt 
retailer. The data in the relational table is stored in records, which correspond to a row of the 
table, and each record is divided into fields. The fields in a relational table are presented in 
columns. In this example, the fields are Store, Color, and Sales. In this example, Store #100 sold 
17 black athletic shirts during this sales period. 

 

By examining the fields represented in this table, you can see that there are only three possible 
values for Store — Store #100, Store #200, and Store #300. There are also only three possible 
values for Color — black, white, and red.  
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Two-dimensional data array 
Another way of presenting this same data is in the 3x3 matrix shown in the figure below. In this 
representation, the sales figures are located at the intersections of the x-axis (Color) and the y-axis 
(Store) in the matrix. 

This matrix is an example of an array that contains two dimensions — color and store. An array is 
the fundamental component of the multidimensional database, which is characterized by this 
method of storing data. 

 

Dimensions 
In an array; each axis is called a dimension, and each of the possible locations within a dimension 
is called a position. In the example, the dimension STORE contains three positions — Store #100, 
Store #200, and Store #300. The second dimension COLOR also contains three positions — 
black, white, and red. The sales information is located at the intersections of the dimension 
positions in individual cells of the matrix. 

Applications that run on the Retek Predictive Application Server identify data through 
dimensional relationships. Dimensions are specific attribute levels of closely related data. For 
example; product dimensions might include SKU, style, or class. Typical location dimensions 
might include store, city, or region. Time dimensions might include days, weeks, or months.  

Now compare the two representations of this data. It is much easier to recognize the nature of the 
data when it is in the form of an array. You can immediately determine that there are two 
dimensions (color and store), and that each dimension contains three positions. It takes longer to 
determine the same information from a relational table. The array also has the benefit of grouping 
similar information into columns and rows. For example, all sales information for shirts sold at 
Store #200 is grouped into one row and can easily be totaled. You can quickly determine how 
many red shirts were sold by adding the elements of one column.  
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The array format is a much more organized method of storing and presenting data since it gives 
immediate information about the number of dimensions in the data and the number of positions 
within each dimension. This method of organization greatly eases data analysis and retrieval by 
eliminating the need to search each individual record in a relational database.  

By storing data in an array format, systems can quickly and efficiently import and export data in a 
nightly batch process, so the essential processes of accumulating and spreading data can take 
place in a timely manner. You can also view the data in any manner. You can determine the 
dimensional levels in which to view data, as well as the specific arrangement of the dimensions 
relative to each other. 

Three-dimensional relational table 
The relational database example can be extended by adding a third dimension to the data set. 
Three possible store locations and three possible colors of shirts still exist, but the dimension Sale 
Type is now added to the table. The dimension Sale Type contains three possible positions — 
clearance item, advertised special, and regular price. The following table shows what the 
relational table looks like with the new dimension added. 
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How multidimensional databases handle additional dimensions 
Adding one more dimension to the data set has made this relational table a tremendously 
cumbersome way of presenting data. Imagine how the table would look if there were over twenty 
dimensions to define. 

A multidimensional structure easily accepts the addition of a new dimension while providing you 
with ease of analysis. There is now a three-dimensional 3x3x3 array containing 27 cells rather 
than a two-dimensional (3x3) array containing 9 data cells. The data is still sorted and presented 
in the same well-organized, easily accessible manner. The figure below shows a three-
dimensional data array. 

 

Four-dimensional data array 
The three-dimensional data array can be expanded to four dimensions by adding the dimension of 
time. Four dimensions are more difficult to understand, so imagine an array that is similar to the 
figure below for each of the twelve months of the year (twelve positions in the time dimension).   
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Advantages of multidimensional databases 
Multidimensional databases provide quick and efficient data loading and exporting while 
allowing the user to make rapid online queries of data. You can quickly and easily change the 
level that the data is viewed because data is stored in arrays. For example, you can view data at 
the SKU/Store/Week level, or it can be aggregated (rolled up) to be viewed at a 
Department/DC/Year level.  
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Hierarchies 
Overview 
Hierarchies are structures that organizations use to describe relationships between the many 
dimensions. 

If you use the Retek Predictive Solutions in conjunction with the Retek Merchandising System 
(RMS), the hierarchies will usually default to the RMS hierarchical structure. The figure below 
illustrates a sample RMS product hierarchy.  

 

When the Retek Predictive Solutions are run as standalones (as opposed to Enterprise products 
with the Retek Merchandising System), hierarchies are defined during implementation and may 
not reflect the structure established by the Retek Merchandising System. The Retek 
Merchandising System hierarchy may also be augmented to include other rollups and attributes, 
such as product status or price point.  

Dimensional level relationships in a product hierarchy 
SKU, style, and class are examples of specific dimensions that define the relationship between 
individual products. For this reason; SKU, style, and class are said to be dimensions of the 
product hierarchy. For example, consider an apparel manufacturer where shirts are one of the 
company’s many product classes. The following figure shows a possible relationship between 
dimensional levels in the company’s product hierarchy. 

 
The items at the bottom of the hierarchy can be defined at their lowest level by SKU. Items at 
each successively higher level in the hierarchy contain the elements directly beneath, so lower-
level components roll up (or aggregate) into higher ones within the hierarchy. In this product 
hierarchy, shirts at the SKU level roll up into aggregate style/color groupings (for instance, white 
crew-necks). Shirts at the style/color level can then be rolled up to the style level (for instance, 
crew-necks); and styles can be rolled up into the product class level (for instance, shirts). 
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Dimensional level relationships in a location hierarchy 
This company can represent its hierarchy of locations in a similar fashion. In the following 
location hierarchy, stores are identified at their lowest level (the Store dimension) by city/store 
number. This hierarchical level rolls up into the state dimension, and the state level can be further 
rolled up into the region. 

 

Hierarchy rules 
Hierarchies can be much more complex than those in the previous examples. An item at a 
particular level in a hierarchy can be rolled up along several hierarchical paths. However, for any 
given roll-up path, that item can only belong to one parent at any higher dimensional level. For 
example, if a given store location is rolled up to the state level, it can only belong to one state 
position (for instance, Georgia or Florida, but not both). You can view data at any level of detail 
by drilling down or rolling up through levels in the hierarchy. Hierarchies define the path of data 
aggregation and spreading. 
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Workbooks, worksheets, and wizards 
Overview 
In the Retek Predictive Solutions, planning and forecasting information is presented in a 
workbook format.  

Workbooks 
The Retek Predictive Solutions integrate and manipulate your organization’s data and present it in 
a workbook format. A workbook is the easily viewed, easily manipulated multidimensional 
framework that is used to perform specific business functions, such as generating trading 
information and reviewing availability data. To present data, a workbook can contain any number 
of multidimensional spreadsheets, called worksheets, as well as graphical charts and related 
reports. These components work together to ease the viewing and analysis of business functions. 

You define and build the workbook framework and its specific attributes. The structure is then 
saved, which allows new sets of data to be imported, manipulated, and presented as needed in a 
standardized format. This eliminates the need to redefine workbook parameters each time you 
want to view a new set of data.  

Remember that data in a workbook can be viewed at lower levels of detail or higher levels of 
aggregation with the click of a mouse. Different views are obtained by changing the path and/or 
level of data rollup. Data in a workbook can also be manipulated at any hierarchical level. If you 
modify data at an aggregate level, these changes are distributed down to the lower levels. The 
reverse is also true — if you modify data at a lower level in the hierarchy, the aggregates of the 
data reflect those changes.  

Worksheets 
Worksheets are multidimensional spreadsheets used to display workbook-specific information. 
Workbooks can include one or multiple worksheets. Worksheets can present data in the form of 
numbers in a grid. These numeric data values can also be easily converted to a graphical chart. 

You can display the information in a worksheet in a variety of formats; generally by rotating, 
pivoting, and changing the data rollup. The Retek Predictive Solutions allow you to easily change 
the presentation style of data in a worksheet.  Data sets can be moved around and their positions 
change. Data can be viewed at a very high level of detail, or data values can be quickly 
aggregated and viewed at summary levels.  Furthermore, worksheets and parts of worksheets can 
be easily changed into charts, which facilitate the graphical viewing and analysis of data. 

Worksheet components 
Worksheets used in the Retek Predictive Solutions have several common features.  
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Wizards 
A wizard is a feature that steps you through the process of building new workbooks from existing 
templates. A wizard displays successive dialogs that require you to answer a sequence of 
questions or enter selections regarding the content of your workbook. Your responses to these 
questions are used to automatically format and populate the workbook that you want to build. 

The specific information required by a wizard depends on the type of workbook being built. For 
example, the wizard might ask you to select the hierarchy level at which a source forecast should 
be run, or it may ask you to select the products and/or locations that should be included in a 
particular workbook. 

A variety of templates exist for building workbooks for each application. In addition, there are 
workbook templates for performing system administration and data maintenance on the 
Administration and Analysis tabs, respectively. Wizards are in place to walk you through the 
process of creating a new workbook from a template. 

How workbooks are built 
Workbooks can either be built automatically during nightly batch runs, or they can be built 
manually by using a wizard.  

The Workbook Auto Build feature allows users to set up workbook builds, which take place on a 
regular basis during nightly batch runs. Workbooks to be built in this way are added to the auto 
build queue. This way, users are spared the processing time required to regularly enter the same 
selections, and they are spared the wait time associated with workbook builds. 
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Menus, quick menus, and toolbars 
Menus 
Standard pull-down menus are available for performing most commands. Click on the appropriate 
menu title in the application’s menu bar to display the menu. A description of the standard menus 
and each menu option is provided in the Main Menu Options subsection of this guide. 

Quick menus 
In various areas, context-sensitive quick menus are available to access certain commands. In 
order to eliminate unnecessary screen clutter, these menus remain hidden until you access them. 
To access a quick menu, place the cursor over an appropriate screen area and click the right 
mouse button. These quick menus are context-sensitive, which means their availability, 
appearance, and options will depend on your current mode of work.   

Quick menus are essential tools for functions such as changing the level and/or path of hierarchy 
rollup, hiding positions within a dimension, switching the view of your worksheet between 
outline view and block view, sorting or resorting data in a dimension, and formatting grid and 
chart data.   

Toolbars 
The Retek Predictive Application Server toolbar contains iconic buttons that gives the user direct 
access to many common commands and actions. Without these buttons, you typically have to 
navigate through several menu levels to access the equivalent command. To see the function of a 
particular toolbar button, move your cursor to a position above it. A caption will appear in the 
status bar at the bottom of the screen that describes the button’s function.  



Chapter 3 – Menus and toolbars 
 

13 

Chapter 3 – Menus and toolbars 
Application Main Menu Bar 
File Menu 

File > Change Password 
Changes your current password for security purposes.  

Enter your current password and new password in the appropriate fields, then verify your new 
password in the Verify New Password field. Click OK to process the change. 

 Note: This menu option is disabled for Web-based users. 

File > Commit Status 
"Commit Status", a dialog window used to check the status of all commit requests submitted with 
Commit ASAP. This dialog window is available whether or not a user is in a workbook.  

 

There are four stages of commit process added to the Commit ASAP queue.  

• Pending –the commit is queued up to take place at some point in the future 

• Committing – the workbook is currently being committed. 

• Success – the commit succeeded 

• Failed – the commit failed 

You have the ability to select which status you desire to view; this is selected at the bottom of the 
Commit Status window.  

An unsaved workbook committed with Commit ASAP, will be "untitled." You can also view: 
template name, submission time, workbook owner, submitter name, commit status, and 
completion time.  
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Columns in the Commit Status box can be selected and the displayed data will be sorted in 
ascending or descending order. If you select or unselect the check box and click "refresh," the 
data will be re-displayed accordingly. 

 Notes: 

• "Commit Now" and "Commit Later" actions will not display in the Commit Status dialog 
box. 

• If you do not save a workbook before Commit ASAP, the workbook is labeled "titled" 
and might be erased in the Commit Status Queue at the next Commit ASAP for that same 
template. Saving the workbook before committing is highly recommended if multiple 
users might be committing to that same template at the same time. This will ensure that 
all data is committed correctly (there can only ever be one pending commit ASAP in the 
queue for a given workbook/user/template name combination) 

File > Commit ASAP 
Commit As Soon As Possible (Commit ASAP) allows you to schedule the commit process of the 
data in a workbook so that it executes as soon as all the system resources are available. Commit 
ASAP takes a copy of your workbook data to be committed and effectively adds it to a queue 
where the data is committed in the order the processes were submitted. Environments with a large 
number of users Commit ASAP will avoid potential issues with users trying to simultaneously 
commit data to the same measures (using Commit Now).  

After selecting Commit ASAP you have the option of saving the workbook or not (clicking yes or 
no); the system then informs you that the "Workbook has been submitted to the commit queue", 
you should select "OK." 

File > Exit 
One of two methods you can use to log off the system. The Exit option logs you off of the 
application and exits the system completely.  

If you have an unsaved workbook open at the time you select Exit, the Close dialog box will be 
opened, informing you that modifications have been made to the workbook.  

File > Export Sheet 
Exports the current view for the worksheet to an output file on the client machine. Selection of 
this item displays a Save As dialog box in which you can specify the output file name, the 
directory in which the file will be saved, and other customizable options. 

In the Save As dialog, the Save In drop-down list allows you to select the directory into which to 
export the file. When the appropriate directory is selected, enter an output file name in the File 
Name field, or select one from the list of those displayed. If you do not do so, a file extension is 
automatically attached to the name you select.  
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The Save As Type drop-down list allows you to select the format of the output file you create. 
When you type in the file name you want at the top of the dialog box, the appropriate file 
extension is attached to that name as determined by your selection in the Save As drop-down list. 
Typical Save As file types are: 

• . TXT: Text file 

• . DIF: Data interchange format 

The Delimiter option allows you to specify the character used to separate information in the 
output file. Standard choices for this character are Tab, Comma, or Space. You can, however, 
specify any character you like by selecting the Other radio button. This option is available only 
for text file exports. 

The Labels option specifies the format of the label headers across the top of every cell in the 
output file. The choices for the Labels option include: 

• Do Not Include: Labels are not provided at the top of data cells. 

• Include Once: Only one label is placed across the top of each section of cells. 

• Repeat: Labels are repeated as necessary across the top of every data cell. 

The Description option allows you to determine whether labels or names are used when 
specifying certain positions in your exported file. For example, the position name for a store in 
the RDF system might be STR_4540 and the label for that position name might be 52-4540 
GA/Atlanta. The names are more concise, but the full labels are more descriptive and 
informative. The choices for the Description option are: 

• Labels: Uses the full, descriptive label assigned to a position. 

• Names: Uses the concise, actual position name in the system. 

When you have named your output file and made the appropriate selections, click OK to export 
the file, or Cancel to return to the workbook without exporting. 

File > Logoff 
One of two methods you can use to log off the system. Selection of this option logs you off but 
redisplays the Logon dialog box, thus leaving the system ready for another user to access. 

If you have an unsaved workbook open at the time you select Logoff, the Close dialog box will 
be opened, informing you that modifications have been made to the workbook.  

 Note: This menu option is disabled for Web-based users. 

File > MRU (Most Recently Used) List 
The MRU (Most Recently Used) List is located just beneath the Exit option on the File menu. 
The MRU List is a list of the four most recently opened workbooks. When a workbook is 
displayed on the MRU List, it can be accessed quickly by selecting that workbook directly from 
the File menu. 

If you open a workbook that already exists and save it under a new name by selecting Save As 
from the File menu, then both the old and the new workbook names will appear on the MRU List.  
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File > Page Setup 
The Page Setup dialog box contains options for the format of the print output of a document. Page 
Setup options always override the settings established in the Windows Print Setup dialog box, 
and the settings only apply to the current document (worksheet or chart). 

There are five options available in this dialog box, presented in a tab format:  

Page: Allows you to specify the page orientation (portrait vs. landscape) and customize (scale) 
the size of the printed output. 

Margins: Allows you to specify and preview the page margins (expressed in inches). 

Header/Footer: Allows you to customize the header and footer information that appears on the 
pages of your output. You may select information to be displayed on the left, center, and right 
portions of your header and footer. 

Sheet: Allows you to select how you want row and column label information displayed, and 
specify the appearance of horizontal and vertical grid lines. This tab also allows you to set the 
order of page numbering (left to right, top to bottom).  

Page Breaks: Allows you to specify the placement of page breaks for printed output.  

When you have made your selections, click OK to apply the changes to the page setup. Click 
Cancel to return to the worksheet without making changes to the page setup. The Apply button is 
only functional when Page Setup is used in conjunction with the Print Preview screen. Click the 
Apply button to view your selections in Print Preview mode without closing the Page Setup 
dialog. 

File > Print 
The Print menu option accesses the Print dialog box, in which you select printing options such as 
printer, print range, and number of copies.  

Printer – Click the drop-down list in this dialog section to specify the path and name of the printer 
you wish to use.  

Print Range – Click the appropriate radio button to designate the range for the printed output. 

All – Prints every page in the workbook. The ordering of page numbers (top to bottom or left to 
right) can be specified on the Sheet tab of the Page Setup dialog. 

Pages – Allows you to specify a subset of pages to be printed. In the fields provided, enter the 
numbers of the first and last pages in the range to be printed. 

Usability Tip Use the Print Preview option on the File menu to determine the page numbers of the 
information you wish to print. It may be helpful to use the custom header/footer feature in Page 
Setup to insert page number field marker codes in your document.  

Slice – Allows you to specify a range of complete slices to be printed. The slice axis runs 
perpendicular to the plane of the computer screen; a separate slice exists for each element of the 
dimension represented by the hierarchy tile residing in the slice display area. In the boxes 
provided, enter the numbers of the first and last slice in the range to be printed. 

Copies – Enter the number of copies to be printed, or use the spin buttons to increment the copy 
total. 
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File > Print Multiple 
Produces a dialog that allows you to select multiple worksheets to submit to the print queue. Use 
<Crtl+Click> to select multiple worksheets from the list. 

Check the "Display print dialog before each window" check box to have the Print Options dialog 
displayed individually before each worksheet is printed. 

Click OK to submit your selections to the print queue. The standard Print Options dialog is 
presented to allow you to make print option selections. Selections made on this dialog will apply 
to all printed worksheets if the "Display print dialog before each window" check box was left 
unchecked. If the box was checked, this dialog will reappear before each worksheet is printed. 

File > Print Preview 
Displays a standard print preview window, so you can view the output before printing.  

Click the Previous Page or Next Page button to page backward and forward through the 
document (this can also be done by using the standard vertical scroll bar).  

Click the Zoom In or Zoom Out button to change the magnification of your document. 

Click the Page Setup button to access the Page Setup dialog. Here you can modify document 
features such as page orientation, scaling, margins, headers/footers, page numbering scheme, and 
page breaks. 

Click the Close button to close the Print Preview dialog and return to the main document view. 

File > Refresh 
The selective/partial Refresh feature is designed to allow you to refresh a portion of your 
workbook measures with original domain data while leaving other measures unchanged.  

File > Save As 
Opens a dialog box in which you can specify the name of the workbook to be saved. You can also 
specify the nature of access privileges associated with the workbook; the default access privilege 
is the creator of the workbook alone, but you can also grant group access privileges or world 
access privileges. The Save As menu item is only enabled when a workbook is open. 

In the Workbooks text field of the Save As dialog, type a name for the workbook.  

Use the Save Access As radio buttons to specify access privileges for this workbook. If User is 
selected, then only you can access and make changes to the workbook. Group allows only those 
users who are in your group (as determined by your System Administrator) to edit the workbook. 
World permits any user to update the workbook. 

When the Save As dialog box is displayed, all the workbooks that have previously been saved are 
listed. When viewing the list of previously saved workbooks, click on any column header to sort 
the workbooks by that attribute. For example, click on the Owner header to sort the workbooks 
alphabetically by owner. 

Selecting the "List all workbooks" check box displays all workbooks in the system, including 
those to which you do not have write access. Keep in mind that listing those additional 
workbooks does not give you write access to them. 

Click OK to save the workbook, or click Cancel to return to the workbook without saving. 
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File > Close 
The Close menu item is only available when a workbook is open. If the workbook has been 
previously saved and no new changes have been made, selecting Close will close the workbook. 

If the current workbook has not been saved, or if changes have been made since the last save, 
 selecting this item will display the Close dialog box with the following choices. 

• Save: If the workbook has been previously saved, selecting Save will save the workbook with 
the current name and then close it. If the workbook has not been previously saved, Save will 
display the Save As dialog box where you specify the name of the workbook before closing 
it.  

• Commit Now: This commits the changes to the master database and closes the workbook. If 
it is not necessary to immediately commit the workbook to the master database, use the 
Commit Later option. 

• Commit Later: This causes the workbook name to be placed on a list of workbooks that will 
be committed to the master database in a batch process at a later time. Whenever possible, 
use Commit Later instead of Commit Now to maximize productivity. 

• Save and Commit Now: This performs both of the functions described above. If the 
workbook has been previously saved; the system saves the workbook under its current name, 
commits the new changes to the master database, and closes the workbook. If the workbook 
has not been previously saved, the Save As dialog box is displayed, and it will prompt you for 
a workbook name. The workbook is saved under this name, the changes are committed to the 
master database, and the workbook is closed. 

• Save and Commit Later: This performs both of the functions described above. If the 
workbook has been previously saved, the system saves the workbook under its current name. 
It then places that name on a list of workbooks to be committed in a batch process at a later 
time, and closes the workbook. If the workbook has not been previously saved, the Save As 
dialog box is displayed, and it prompts you for a workbook name. The workbook is saved 
under this name, the Commit Later function is executed, and the workbook is closed. 

• Ignore Changes: This closes the workbook without saving or committing any changes. 

• Cancel: This returns you to the open workbook. 

File > Commit ASAP 
Commit As Soon As Possible (Commit ASAP) allows you to schedule the commit process of the 
data in a workbook so that it executes as soon as all the system resources are available. Commit 
ASAP takes a copy of the workbook data to be committed and effectively adds it to a queue 
where the data is committed in the order in which the processes were submitted. In environments 
with a large number of users, Commit ASAP will avoid potential issues with users who are trying 
to simultaneously commit data to the same measures by using Commit Now. 

After selecting Commit ASAP, the user has the option of saving the workbook or not by clicking 
yes or no. The system then informs the user that the “Workbook has been submitted to the 
commit queue,” after which the user should select “OK.” 
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File > Commit Status 
The Commit Status window is used to check the status of all commit requests submitted with 
Commit ASAP. This window is available whether or not a you are in a workbook.   

 

There are four states for commit processes to be added to the Commit ASAP queue.   

• Pending –the commit is queued up to take place at some point in the future 

• Committing – the workbook is currently being committed 

• Success – the commit succeeded 

• Failed – the commit failed 

You have the ability to select which status you want to view. This is selected at the bottom of the 
Commit Status window. 

If a workbook that had not been saved was committed with Commit ASAP, the workbook name 
will be “untitled.” You can also view the following:  

• template name 

• submission time 

• workbook owner 

• submitter name 

• commit status 

• completion time 
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Columns in the Commit Status box can be selected, and the displayed data will be sorted in 
ascending or descending order. If the user selects or unselects the check boxes and clicks 
“refresh,” the data will be re-displayed accordingly. 

 Note: Saving the workbook before committing is highly recommended if multiple users 
are committing to that same template at the same time. This will ensure that all data is 
committed correctly. There can only ever be one pending commit ASAP in the queue for 
a given workbook/user/template name combination. If you do not save a workbook 
before Commit ASAP, the workbook is labeled “untitled,” and it might be erased in the 
Commit Status Queue at the next Commit ASAP for that same template. 

 Note: “Commit Now” and “Commit Later” actions will not display in the Commit Status 
dialog box. 

File > Delete 
Select File > Delete to delete previously saved workbooks. Select this item to display a dialog 
box that lists all the workbooks that are available to you. You can only delete workbooks that you 
have write access privileges to. 

In the Delete dialog, highlight the workbooks that you want to delete, and click OK. If you want 
to select multiple workbooks to delete simultaneously, use <Shift+Click> and/or <Ctrl+Click>. 

When viewing the list of available workbooks, click on any column header to sort the workbooks 
by that attribute. For example, click on the Owner header to sort the workbooks alphabetically by 
owner. 

File > New 
Accesses a dialog box from which you can create a new workbook using a wizard. The workbook 
template groups (and the workbook templates listed within these groups) are available to you 
based on the user access privileges assigned by your system administrator. 

Highlight the workbook template for the type of workbook you want to build, then click OK. 
Alternatively, you may double-click on any workbook template to select it. 

Continue following the instructions on the wizard screens, selecting Next when you have made 
your selections or Back to return to a previous dialog box. 

On the final dialog box, click the Finish button to build and view your new workbook. 

 Note: You may click the Finish button at any time during the wizard process to have the 
system automatically complete the remainder of the wizard screens based on saved 
selections. The system will simply default to whatever selections were made the last time 
the wizard was used to create a new workbook. As long as a valid selection exists for 
each wizard screen, the system can build the new workbook automatically without user 
input. 
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File > Open 
Select File > Open to display a dialog box that lists all of the workbooks that you have created 
and saved, or to list workbooks that other users have saved with World Access. To open a 
workbook, highlight the selection you want to view, and click OK. 

When viewing the list of available workbooks, click on any column header to sort the workbooks 
by that attribute. For example, click on the Owner header to sort the workbooks alphabetically by 
owner. 

Select the "List all workbooks" check box to display all workbooks in the system, which includes 
those that you do not have write access to. Listing those additional workbooks does not give you 
write access to them. 

File > Save 
Select File > Save to store all of the information in the workbook, which includes the current 
layout of the worksheets and charts. If the workbook you are working on has previously been 
saved, selection of this menu item will update the stored information. If the workbook has not 
been previously saved, selection of this menu item will open the Save As dialog box, which will 
prompt you for a workbook name. The Save menu item is only enabled when a workbook has 
been created or opened. 

Saving a workbook does not commit it to the master database. You must select Commit Now or 
Commit Later from the File menu to commit your changes to the master. 

Edit menu 
The Edit menu contains the following options:  

Edit > Cut 
Copies selected worksheet data to an application clipboard and clears the data from the worksheet 
cells. Select the data cells whose contents are to be cut, then select Cut from the Edit menu. Only 
data from writable measures can be cut. 

When you use the Edit > Cut option to cut data, the function performs the cut at the current 
hierarchical level. Data can be cut from only one dimensional level at a time, so if multiple 
dimensions are represented in your grid selections, then the cut is performed at the lowest 
dimensional level actually selected.  

If data cells are selected in the grid before you invoke the Edit > Cut command, only data from 
those selected cells will be cut. Note that the Cut operation treats the currently displayed position 
on the slice axis as the only selected slice position. 

 Note: The Cut command does not copy information to your Windows clipboard. The data 
is copied to an application-specific clipboard and cannot be pasted into other programs. If 
you intend to paste the data into another application, you can choose the Edit > Copy to 
Clipboard command. 
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Performing specialized cut functions 

The Edit > Cut command is the simplest method of cutting data from your worksheet. There are 
some specialized cut functions that you can perform, however, by accessing the appropriate 
dialog. Namely, you can opt to cut the data at the base level, and/or you can opt to cut the data 
from all slices in the worksheet. If you want to perform either of these operations, you must 
choose the Edit > Cut Special function rather than Edit > Cut. For more information, see the 
following topic: 

Edit > Copy 
Copies selected worksheet data to an application clipboard. Edit > Copy is typically used with the 
Edit > Paste command to speed the process of populating data cells in a worksheet. Select the 
data cells whose contents are to be copied, then select Copy from the Edit menu.  

When you use the Edit > Copy option to copy data, the function performs the copy at the current 
hierarchical level. Data can be copied from only one dimensional level at a time, so if multiple 
dimensions are represented in your grid selections, then the copy is performed at the lowest 
dimensional level actually selected. Unlike the Cut function, Copy does not then clear the data 
from the copied cells. 

If data cells are selected in the grid before you invoke the Edit > Copy command, only data from 
those selected cells will be copied. Note that the Copy operation treats the currently displayed 
position on the slice axis as the only selected slice position. 

If there are no data cells selected in the grid at the time the Copy function is invoked, the system 
will copy the data for every cell in the worksheet.  

 Note: The Copy command does not copy information to your Windows clipboard. The 
data is copied to an application-specific clipboard and cannot be pasted into other 
programs. If you intend to paste the data into another application, you can choose the Edit 
> Copy to Clipboard command. 

Performing specialized copy functions 

The Edit > Copy command is the simplest method of copying data in your worksheet. There are 
some specialized copy functions that you can perform, however, by accessing the appropriate 
dialog. Namely, you can opt to copy the data at a lower level of aggregation not currently 
displayed in the grid, and/or you can opt to copy the data from all slices in the worksheet. If you 
want to perform either of these operations, you must choose the Edit > Copy Special function 
rather than Edit > Copy. For more information, see the Edit > Copy Special command 
description.  
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Edit > Paste 
Pastes data into measures. This menu item is only enabled after you have placed data on the 
application clipboard using either the Cut, Cut Special, Copy, or Copy Special command from the 
Edit menu. The Paste option pastes into the selected cells whatever data was last placed on the 
system clipboard using one of these commands. 

Select the data cells into which you want to paste data, then select Paste from the Edit menu. Data 
can only be pasted into writable measures. 

 Note: The Paste command does not paste data from your Windows clipboard. This 
command only pastes data from an application-specific clipboard and cannot be used to 
import data from another application. If you want to paste copied data from another 
program, you must choose the Edit > Paste from Clipboard command. 

Pasting Data from Multiple Measures 

If you used the Cut, Cut Special, Copy, or Copy Special command to cut/copy data for multiple 
measures, note that your selection can be pasted only into the exact same measures for a new 
position. 

Here is some sample data for SKU1 that is to be copied to the Regular Sales and Clearance Sales 
measures of SKU2.  

 
If Regular Sales and Clearance Sales for SKU1 are copied together, this data can only be pasted 
to the Regular Sales and Clearance Sales measures of another position. To copy the data from 
Regular Sales into a different measure, you must copy Regular Sales alone. These are the results 
after the multiple measure copy. 

 

Performing Specialized Paste Functions 

The Edit > Paste command is the simplest method of pasting clipboard data into your worksheet. 
There are some specialized paste functions that you can perform, however, by accessing the 
appropriate dialog. You can opt to paste data at a lower level of aggregation not currently 
displayed in the grid, you can opt to paste data into all worksheet slices simultaneously, and you 
can choose to exclude NA values when pasting data. Furthermore, when pasting data at an 
aggregate level, you can specify the method by which values should be spread down to lower 
level constituent cells, and/or you can choose a spread pattern measure. If you want to perform 
any of these operations, you must choose the Edit > Paste Special function rather than Edit > 
Paste. For more information, see the description of Edit > Paste Special. 
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Edit > Paste Special 
Pastes data into measures. This menu item is only enabled after you have placed data on the 
application clipboard using either the Cut, Cut Special, Copy, or Copy Special command from the 
Edit menu. Unlike the Edit > Paste operation, the Paste Special command provides a dialog in 
which you can specify options for specialized paste functions, including pasting data at base 
level, pasting to all worksheet slices, and specifying spread methods for pasted data. Select the 
data cells into which you want to paste data, then select Paste from the Edit menu. Data can only 
be pasted into writable measures. 

 

Paste All Slices 

When you make cell selections prior to pasting data, note that the system only allows for the 
selection of the currently displayed position along the slice axis. The Paste Special dialog, 
however, contains a check box that allows you to specify that data should be pasted into all 
positions (pages) in this axis. When the box is checked, the paste operation behaves as if all 
positions in the slice dimensions were selected prior to the paste. If the box is left unchecked, data 
will only be pasted into the currently displayed slice position. 

 Note: If you did NOT choose to cut/copy data from all slices prior to this paste, and then 
you choose to paste the clipboard data to all slices, the data that was cut/copied from the 
single visible slice will be replicated to all slices in the worksheet. 

Don't Paste NA Values 

If the Don't Paste NA Values check box is selected, the system will not paste cut/copied NA data 
values into the current selection. Whenever the system encounters an NA value in the clipboard 
data, that value is ignored and the data cell being pasted keeps its original value. In other words, 
when this check box is selected, current grid data is not overwritten by NA values. 
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Paste Data at Base Level 

The Paste Data At Base Level check box allows you to paste data at an applicable dimensional 
level beneath that selected in the grid. This feature allows you to view data at an aggregate level 
while pasting data at a dimensional level not currently displayed. When you select the Paste 
function at an aggregate level and you select the Paste Data At Base Level check box, all base 
level data applicable to that selected aggregate data will be pasted into the selected data cells. 

 Note: Whenever data has just been cut or copied at a base level, the Paste Data At Base 
Level check box defaults to selected. 

Specifying Spread Method for Pasted Data 

The bottom portion of the Paste dialog is enabled when you are pasting data at a level other than 
base. The options in this section control how data pasted into an aggregate level is spread down to 
lower dimensional levels. If the Paste Data at Base Level check box is selected, this portion of the 
dialog becomes disabled. 

The Spread Method radio buttons allow you to specify the way in which aggregate cell data is to 
be spread to lower dimensions: 

• Replicate – Any value pasted in an aggregate level cell will be replicated exactly to every 
base level cell that comprises the aggregate total. Note that after the spread, this method 
results in a recalculation of the aggregate cell totals. 

• Even – Any value pasted into an aggregate level cell will be spread evenly among that cell's 
lower level constituents. 

• Proportional – Any value pasted in an aggregate level cell will be spread proportionally 
among all lower level constituent cells, based on these cells' contents before the paste. 

• Delta – The difference between the value pasted in the aggregated cell level and the original 
value of the aggregate cell level will be spread evenly among all lower-level constituent cells. 

When the Don’t Spread to NA Values check box is selected, pasted aggregate data is not spread 
to lower level cells that contain NA values before the paste. The NA values are left intact, and the 
aggregate data is spread to the remaining lower level cells that comprise the aggregate total. 

Pasting Data While in Outline View 

Outline view allows you to view data for multiple dimensional levels simultaneously in the same 
worksheet. The system, however, allows the pasting of data into only one dimensional level at a 
time. Whenever multiple dimensions are displayed in outline view for a given hierarchy, the Paste 
Special dialog requires you to select the dimensional level at which you want to paste data. The 
Paste Special dialog has drop-down lists enabled for each hierarchy displayed in outline mode. 
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Pasting from One Position to Many Positions 

Multi-cell cut/copy regions containing a single position in a dimension can be pasted into a larger 
paste region containing more positions along that same dimension. In such a case, the entire 
cut/copy region is replicated across the additional positions in the paste region. For example, it is 
possible to copy data from a single store but for multiple weeks, then paste that data into multiple 
stores. The copy region would simply be replicated for each new store in the paste selection. 

The following figures provide an example of the one-to-many paste functionality. Data from four 
weeks at a single store position is copied (the copy region is shaded in the first figure), and this 
data is pasted to the other four locations. 

 

 

Edit > Cut Special 
Copies selected worksheet data to an application clipboard and clears the data from the copied 
cells. Unlike the Edit > Cut operation, the Cut Special command provides a dialog in which you 
can specify options for specialized cut functions, including cutting data at base level and cutting 
data from all worksheet slices. Select the data cells whose contents are to be cut, then select Cut 
Special from the Edit menu. Only data from writable measures can be cut. 

 
 Note: The Cut command does not copy information to your Windows clipboard. The data 

is copied to an application-specific clipboard and cannot be pasted into other programs. If 
you intend to paste the data into another application, you can choose the Edit > Copy to 
Clipboard command. 
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Cut Data at Base Level 

The Cut Data at Base Level check box allows you to cut data at an applicable dimensional level 
beneath the level selected in the grid. This feature allows you to view data at an aggregate level 
while cutting data at a dimensional level not currently displayed. When you select the Cut Special 
function at an aggregate level and you select the Cut Data at Base Level check box, all base level 
data applicable to that selected aggregate data will be cut and copied to the application clipboard. 
Although the cut function is actually performed at the base dimensional level, it seems that the 
aggregate level data has been cut (due to the process of data rollup). 

Cut All Slices 

When you make cell selections prior to cutting data, note that the system only allows for the 
selection of the currently displayed position along the slice axis. The Cut Special dialog, 
however, contains a check box that allows you to specify that data should be cut for all positions 
(pages) in this axis. When the box is checked, the cut operation behaves as if all positions in the 
slice dimensions were selected prior to the cut. If the box is left unchecked, only data from the 
currently displayed slice position will be cut. 

Cutting Data While in Outline View 

Outline view allows you to view data for multiple dimensional levels simultaneously in the same 
worksheet. The system, however, allows the cutting of data from only one dimensional level at a 
time. Whenever multiple dimensions are displayed in outline view for a given hierarchy, the Cut 
Special dialog requires you to select the dimensional level at which you want to cut data. The Cut 
Special dialog has drop-down lists enabled for each hierarchy displayed in outline mode. 

Edit > Copy Special 
Copies selected worksheet data to an application clipboard. Unlike the Edit > Copy operation, the 
Copy Special command provides a dialog in which you can specify options for specialized copy 
functions, including copying data at base level and copying data from all worksheet slices. Select 
the data cells whose contents are to be copied, then select Copy Special from the Edit menu.  

 
 Note: The Copy Special command does not copy information to your Windows 

clipboard. The data is copied to an application-specific clipboard and cannot be pasted 
into other programs. If you intend to paste the data into another application, you can 
choose the Edit > Copy to Clipboard command. 
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Copy Data at Base Level 

The Copy Data at Base Level check box allows you to copy data at an applicable dimensional 
level beneath the level selected in the grid. This feature allows you to view data at an aggregate 
level while copying data at a dimensional level not currently displayed. When you select the 
Copy Special function at an aggregate level and you select the Copy Data at Base Level check 
box, all base level data applicable to that selected aggregate data will be copied to the application 
clipboard. Although the copy function is actually performed at the base dimensional level, after 
pasting, it seems that the aggregate level data has been copied (due to the process of data rollup). 

Copy All Slices 

When you make cell selections prior to copying data, note that the system only allows for the 
selection of the currently displayed position along the slice axis. The Copy Special dialog, 
however, contains a check box that allows you to specify that data should be copied for all 
positions (pages) in this axis. When the box is checked, the copy operation behaves as if all 
positions in the slice dimensions were selected prior to the copy. If the box is left unchecked, only 
data from the currently displayed slice position will be copied. 

Copying Data While in Outline View 

Outline view allows you to view data for multiple dimensional levels simultaneously in the same 
worksheet, but the system only allows the copying of data from only one dimensional level at a 
time. Whenever multiple dimensions are displayed in outline view for a given hierarchy, the 
Copy Special dialog requires you to select the dimensional level from where you want to copy 
data. The Copy Special dialog has drop-down lists that are enabled for each hierarchy that is 
displayed in outline mode.Edit > Paste Special 

The Paste Special option pastes data into measures. This menu item is only enabled after you 
have placed data on the application clipboard using the Cut, Cut Special, Copy, or Copy Special 
command from the Edit menu. Unlike the Edit > Paste operation, the Paste Special command 
provides a dialog where you can specify options for specialized paste functions, including pasting 
data at base level, pasting to all worksheet slices, and specifying spread methods for pasted data. 
 Select the data cells into which you want to paste data. Then select Paste from the Edit menu. 
 Data can only be pasted into writable measures. 
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Paste all slices 

When you make cell selections prior to pasting data, the system only allows for the selection of 
currently displayed position along the slice axis. The Paste Special dialog contains a check box 
that allows you to specify that data should be pasted into all positions (pages) in this axis.  When 
the box is checked, the paste operation behaves as if all positions in the slice dimensions were 
selected prior to the paste. If the box is unchecked, data will only be pasted into the currently 
displayed slice position. 

 Note: If you did not choose to cut/copy data from all slices prior to this paste, and then 
you choose to paste the clipboard data to all slices, the data that was cut/copied from the 
single visible slice will be replicated to all slices in the worksheet. 

Don't Paste NA Values 

If the Don't Paste NA Values check box is selected, the system will not paste cut/copied NA data 
values into the current selection. Whenever the system encounters an NA value in the clipboard 
data, that value is ignored and the data cell being pasted keeps its original value. In other words, 
when this check box is selected, current grid data is not overwritten by NA values. 

Paste Data at Base Level 

The Paste Data at Base Level check box allows you to paste data at an applicable dimensional 
level beneath the selected cell in the grid. This feature allows you to view data at an aggregate 
level while pasting data at a dimensional level that is not currently displayed. When you select the 
Paste function at an aggregate level and you select the Paste Data at Base Level check box, all 
base-level data that is applicable to that selected aggregate data will be pasted into the selected 
data cells. 

 Note: Whenever data has just been cut or copied at a base level, the Paste Data at Base 
Level check box defaults to selected. 
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Specifying Spread Method for Pasted Data 

The bottom portion of the Paste dialog is enabled when you paste data at a level other than base. 
The options in this section control how data pasted into an aggregate level is spread down to 
lower dimensional levels. If the Paste Data at Base Level check box is selected, this portion of the 
dialog becomes disabled. 

The Spread Method radio buttons allow you to specify the way that aggregate cell data is to be 
spread to lower dimensions. The four options are as follows: 

• Replicate – Any value pasted in an aggregate level cell will be replicated exactly to every 
base level cell that comprises the aggregate total. Note that after the spread, this method 
results in a recalculation of the aggregate cell totals. 

• Even – Any value pasted into an aggregate level cell will be spread evenly among that cell's 
lower level constituents. 

• Proportional – Any value pasted in an aggregate level cell will be spread proportionally 
among all lower level constituent cells. This is based on these cells' contents before the paste. 

• Delta – The difference between the value pasted in the aggregate cell level and the original 
value of the aggregate cell level will be spread evenly among all lower-level constituent cells. 

When the Don’t Spread to NA Values check box is selected, pasted aggregate data is not spread 
to lower level cells that contain NA values before the paste. The NA values are left intact, and the 
aggregate data is spread to the remaining lower level cells that comprise the aggregate total. 

Pasting data while in outline view 

Outline view allows you to view data for multiple dimensional levels simultaneously in the same 
worksheet, but the system only allows the pasting of data into one dimensional level at a time. 
 Whenever multiple dimensions are displayed in outline view for a given hierarchy, the Paste 
Special dialog requires you to select the dimensional level where you want to paste data. The 
Paste Special dialog has drop-down lists enabled for each hierarchy displayed in outline mode. 

Pasting from one position to many positions 

Multi-cell cut/copy regions containing a single position in a dimension can be pasted into a larger 
paste region containing more positions along that same dimension. In such cases, the entire 
cut/copy region is replicated across the additional positions in the paste region. For example, it is 
possible to copy data from a single store but for multiple weeks, and then paste that data into 
multiple stores. The copy region would simply be replicated for each new store in the paste 
selection. 

Edit > Copy to Clipboard 
Copies selected worksheet data to the Windows clipboard. Use this copy operation if you want to 
copy worksheet data into another application. Select the data cells whose contents are to be 
copied to the Windows clipboard, then select Copy to Clipboard from the Edit menu.  

 Note: When using this command, the maximum number of cells that can be copied is 
limited by memory. This operation should NOT be used to export entire workbooks. 
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Edit > Paste from Clipboard 
Pastes data from the Windows clipboard into selected worksheet cells. Use this paste operation if 
you want to paste data from another application into the current worksheet. Select the data cells 
into which you want to paste clipboard data, then select Paste from Clipboard from the Edit 
menu. 

 Note: When using this command, the maximum number of cells that can be pasted is 
limited by memory. This operation should NOT be used to import data for entire 
workbooks. 

Edit > Revert 
Reverts to the most recently saved version of the workbook. This option allows you to return to a 
prior state without having to close the workbook, select Ignore Changes from the Close dialog 
box, and reopen the workbook. 

The Revert option is only enabled if the current workbook has already been saved under a 
specified name, and if changes have been made to the data since the last save. 

When you select Revert from the Edit menu, the Revert dialog box opens to inform you that all 
changes made since the last save will be lost. Click OK to abandon the current workbook and 
return to the most recently saved version, or click Cancel to keep the changes you have made and 
return to the current workbook. 

Edit > Fill 
Quickly populates the cells in a worksheet. This command fills only one measure at a time.  

If there are no data cells selected in the grid at the time the Fill dialog box is opened, the system 
will fill the data cells for the entire measure that you select in the Measure drop-down list. If 
certain data cells were selected in the grid, only those selected data cells will be filled. 

Select the measure to be filled from the Measure drop-down list. This field displays only writable 
measures. The properties of the Fill Value field change, depending on your selection in the 
Measure drop-down list. If the measure selected contains values restricted to a list, then the Fill 
Value field will change to a drop-down list in which you can select the appropriate value. If the 
measure selected is numeric or alphanumeric, the Fill Value field will allow you to enter the 
value that you want entered in the affected cells. 
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Specifying spread method for filled data 

The lower portion of the Fill dialog is enabled when you are filling data into worksheet cells at an 
aggregate level. This section allows you to specify the method by which aggregate data is to be 
spread to lower level constituent cells. 

The Spread Method radio buttons allow you to specify the way in which aggregate cell data is to 
be spread to lower dimensions. The three options are: 

• Replicate – Any value filled into an aggregate level cell will be replicated exactly to every 
base level cell that comprises the aggregate total. Note that after the spread, this method 
results in a recalculation of the aggregate cell totals. 

• Even – Any value filled into an aggregate level cell will be spread evenly among that cell's 
lower level constituents. 

• Proportional – Any value filled into an aggregate level cell will be spread proportionally 
among all lower level constituent cells based on these cells' contents before the fill. 

• Delta – The difference between the value pasted in the aggregated cell level and the original 
value of the aggregate cell level will be spread evenly among all lower-level constituent cells. 

When the Don’t Spread to NA Values check box is selected, filled aggregate data is not spread to 
lower level cells that contain NA values before the fill. The NA values are left intact, and the 
aggregate data is spread to the remaining lower level cells that comprise the aggregate total. 

Filling data while in outline view 

Outline view allows you to view data for multiple dimensional levels simultaneously in the same 
worksheet. The system, however, allows the filling of data into only one dimensional level at a 
time. Whenever multiple dimensions are displayed in outline view for a given hierarchy, the Fill 
dialog requires you to select the dimensional level at which you want to fill data. The Fill dialog 
has drop-down lists enabled for each hierarchy displayed in outline mode. 

Edit > Clear Contents 
Quickly clears the contents of the cells in a worksheet.  

Select the data cells that you want to clear, and choose Clear Contents from the Edit menu.  

If there are no data cells selected in the grid at the time the Clear Contents function is invoked, 
the system will attempt to clear the data for every cell. However, if your grid data contains any 
measures that are read-only, the system will be unable to clear data for the entire worksheet. In 
this case, a message will inform you that the system could not complete the request. 

Edit > Find 
Locates a specified position in any axis. This function allows you to perform an alphanumeric 
search for text entered in the Find What field of the dialog. This function can be useful, for 
example, when you want to move quickly to a particular SKU item in a very large worksheet. 

In the Find dialog, the Look In drop-down list allows you to narrow your search to one of the 
three available axes: Row Axis, Column Axis, or Slice Axis. 

The Match Case and Find Exact Match Only check boxes allow you to narrow your search further 
by imposing more restrictions. 

Click the Find Next button to search for the next matching occurrence. 
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Edit > Insert Measure 
Displays a dialog that allows you to select a measure or group of measures to be inserted in a 
currently open workbook. This functionality reduces the need to build new workbooks whenever 
a view of currently unrepresented measures is required. The ability to insert new measures into 
already open workbooks is particularly useful in the context of establishing access to alerts.  

A worksheet must be open and active for the Insert Measure menu option to be enabled. Any 
measure(s) selected to be inserted in the workbook will be placed on the currently active 
worksheet. 

The Insert Measure dialog allows for intelligent selection of measures based on your 
specifications of the four components (role, version, units, and metric) of a registered measure. 
Make selections for these four components by clicking on the desired items in the Role, Version, 
Units, and Metric lists. You can select more than one item in a list by using <Ctrl+Click>. 

Any measures that are constructed using some combination of component selections will appear 
in the Measures listbox. From this list, select the final measure(s) that you want to insert and click 
OK. 

Edit > Automatic Calculation 
Places the system in automatic calculation mode. In this mode, every change to a cell in the 
spreadsheet causes a recalculation, which requires immediate communication from the worksheet 
(client) back to the database (server). In this mode, there may be an appreciable pause between 
making a change and being able to effect the next change. 

A checkmark is displayed beside either the Automatic Calculation option or the Manual 
Calculation option to indicate the mode the system is currently in. To change calculation modes, 
simply select the desired menu option. 

Edit > Manual Calculation 
Places the system in deferred (manual) calculation mode. In this mode, worksheet changes are 
collected until you manually submit the queue to the server for processing. In this mode, changes 
made to data cells are shown in italic font until they are sent to the server. 

A checkmark is displayed beside either the Automatic Calculation option or the Manual 
Calculation option to indicate the mode the system is currently in. To change calculation modes, 
simply select the desired menu option. 

Edit > Calculate Now 
Submits a queue of data changes to the server for processing. Queued changes are executed in the 
order in which they were made. This menu option is only enabled when the system is in manual 
(deferred) calculation mode. 

Edit > Remove Last Deferred Entry 
Removes the last deferred data entry from the list of queued items to be sent to the server for 
processing. This option allows you to undo the last data change made and return the contents of 
the affected cell to its original value. This menu option is only enabled when the system is in 
manual (deferred) calculation mode. 
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Edit > Remove All Deferred Entries 
Removes all pending deferred data changes from the list of queued items to be sent to the server 
for processing. This option allows you to undo all data changes made since the last set of deferred 
entries was processed. When this option is selected, the original contents of the affected cells are 
restored. This menu option is only enabled when the system is in manual (deferred) calculation 
mode.  

View menu 
The View menu contains the following options:  

View > Grid 
Switches to the grid view of your worksheet when you are in Chart view.  

You may also use the Toggle toolbar button to toggle between the chart and the grid.  

View > Chart 
Switches to the chart view of your worksheet when you are in Grid view. All numeric data or 
subsets of such data in a worksheet can be easily converted to a graphical chart. 

You may also use the Toggle toolbar button to toggle between the chart and the grid.  

In the Chart view, the grid rows are displayed on the y-axis, the grid columns are displayed on the 
x-axis, and the current visible slice position is displayed on the z-axis. If there are items selected 
in the grid at the time the view is toggled to Chart, then the chart will only display those items. If 
there is no selection, the chart will display all items (for a maximum of 1000 positions). The 
Chart view is created at the current aggregate level of the grid. 

View > Alert Manager 
Displays the Alert Manager window, or hides it if it is already displayed. 

View > Full Screen 
Hides the status bar, the tool bar, and the application title. The window is enlarged to fill the 
entire screen, and a checkmark is placed next to the menu item. Click on this option again to 
remove the checkmark and return the window to its original size.  

View > Zoom 
Displays the Zoom dialog. This dialog allows you to enlarge the grid contents of the active 
window for easier viewing, or reduce the size of the contents in order to fit as much data on the 
terminal display as possible. 

A different zoom level can be specified for each worksheet in a workbook. When a workbook is 
closed, the current zoom level for each worksheet is saved. 

The grid view zoom level only affects the display of data on the computer terminal. Zooming 
does not affect the scaling value set in Page Setup and has no effect on printing. 

View > Status Bar 
Displays or hides the status bar.  
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View > Toolbar 
The Toolbar option displays or hides the toolbar. 

View > Find Previous Alert 
The Find Previous Alert option scrolls the worksheet to the previous occurrence of an alert. 
 When searching for the previous alert, the system begins in the current alert cell and scans the 
active alert measure backward by rows. When an alert is found, the worksheet is scrolled so that 
the cell containing the alert appears in the worksheet window. 

View > Find Next Alert 
The Find Next Alert option scrolls the worksheet to the next occurrence of an alert. When 
searching for the next alert, the system scans the active alert measure across the current row, and 
then moves down to the next row to continue the search. When an alert is found, the worksheet is 
scrolled so that the cell containing the alert appears in the worksheet window. 

View > Change Alert Measure 
Produces a dialog from which you choose the active alert measure for the worksheet. When more 
than one alert measure exists in a worksheet, one must be the active alert referenced when 
performing such menu commands as Find Next Alert and Find Previous Alert. 

View > Next in Flow Control 
The Next in Flow Control provides a menu-driven method of advancing to the next step in the 
business process. Each distinct step is associated with a separate worksheet or a set of 
worksheets. Choosing this option has the same effect as clicking the Next toolbar button. 

The steps in the business process are represented by the flow control tabs, which normally appear 
immediately beneath the application toolbar. To view the worksheet(s) associated with a 
particular step, you can click on the corresponding tab. 

View > Previous in Flow Control 
The Previous in Flow Control provides a menu-driven method of returning to the previous step in 
the business process. Each distinct step is associated with a separate worksheet or set of 
worksheets. Choosing this option has the same effect as clicking the Previous toolbar button. 

The steps in the business process are represented by the flow control tabs, which normally appear 
immediately beneath the application toolbar. To view the worksheet(s) associated with a 
particular step, you can click on the corresponding tab. 

View > Sort 
Produces the Create Sort Attribute dialog. This dialog allows you to create a user-named attribute 
based on selected grid data that can be used to sort and re-sort data in the attribute’s 
corresponding dimension. 

The sorting mechanism allows you to sort one dimension in a hierarchy according to current data 
values in the grid. To sort data, you must first select a one-dimensional data space (a single 
column or row of data in the grid). Once the data is selected, choose the View > Sort menu option 
to display the Create Sort Attribute dialog. 
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Format menu 

Format > Application 
Displays the Application tab of the Format Options dialog, in which you can select colors for the 
grid background, for read-only and read/write cells, and for cells in which a deferred calculation 
is pending. This tab is also the interface through which you specify the file location and cache 
size when local workbook caching is enabled. Selections made on the Application tab affect all 
worksheets in the current workbook. The Application option on the Format menu is only 
available in Grid view. 

Color Options 

The Color Options section allows you to specify application-wide colors for various types of cells 
in your workbook, and for the portion of the display beneath the grid. Select a button to display a 
color palette from which you can specify a color for the following: 

• Grid Background Color – Sets the color for the area within a worksheet window that lies 
beneath the grid display, column/row/slice axes, hierarchy tiles, and scroll bars. 

• Deferred Calculation Color – Sets the background color for cells in which a deferred 
calculation is pending. The color chosen from this color palette is only displayed if the Show 
Deferred Calculation Color check box (described below) is selected. The Deferred 
Calculation Color overrides the Read/Write Color selection for a cell. 

• Read Only Color – Sets the color for read only worksheet cells.  

• Read/Write Color – Sets the color for read/write worksheet cells.  

 Note: The Read/Write Color selection will be overridden if the Shade Colors By 
Dimension option on the Format > Axis tab is selected. Dimension shading (if toggled 
on) overrides any read/write color selection, but does not override the read only color 
selection. If it appears that your read/write color selection is not being recognized by the 
system, try toggling off the Shade Colors By Dimension option on the Format > Axis tab. 

Workbook Cache Options 

To speed various system processes, such as opening workbooks, certain information can be 
cached locally on the client machine. This section allows you to enable/disable local caching, 
specify the local directory path for cache data storage, and determine the maximum cache size. 

• Enable Workbook Cache – Allows you to enable/disable local caching. In cases where the 
application is executed from a network, local caching may not be desired. 

• Cache Directory – Allows you to enter the local file system location of the cache. Within the 
given directory location, the cache contents are organized such that a subdirectory exists for 
every domain, and within each domain subdirectory, a subdirectory for every workbook. 

• Cache Size – Specify the maximum size to which the cache will be allowed to grow. Once 
this limit is exceeded, the contents of the cache are shrunk by deleting the least recently 
accessed contents until the size constraint is met. The minimum cache size is 1 MB. 
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Application Options 

• Show Button Text – Toggles the display of toolbar button titles. If this check box is selected, 
the toolbar buttons appear large and include the button name/function. If this check box is 
cleared, the toolbar buttons appear small and contain no text. 

• Show Deferred Calculation Color – Toggles the display of a distinctive background color for 
cells in which a deferred calculation is pending. The color for such cells is specified using the 
Deferred Calculation Color option, described above. When the Show Deferred Calculation 
Color check box is selected, the selected color is displayed (whenever applicable). 

• Show Tab Control – For workbook templates that support process tab control, you have the 
option of disabling the tab control display. Check this check box to turn on the tab control 
bar. Remove the check box to turn off the display. When the tab control bar is not displayed, 
the Previous and Next buttons are still present on the application toolbar to enable you to 
advance through the workbook process flow. 

• Prompt for Deferred Calculations – Allows you to enable/disable the display of a warning 
dialog when you have a populated queue of deferred data changes that must be submitted 
before you perform another action. The system must deal with a populated queue before the 
server can be called for another reason, such as opening another minimized worksheet. When 
this box is checked, a dialog will display before the data changes are sent to the server, 
allowing you to cancel the action if desired. 

To make your changes without closing the dialog box, click the Apply button. To make the 
changes and return to your worksheet, click OK. Click Cancel to close the dialog box without 
applying any format changes. Note that Cancel does not undo any changes that have already been 
made using the Apply button. 
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Format > Axis 
Displays the Axis tab of the Format Options dialog. The changes you make on this tab affect the 
appearance of the row, column, and/or slice axes of your worksheet. The Axis option on the 
Format menu is only available in Grid view. 

Apply to Axis 

On the Axis tab, The Apply To Axis option allows you to select whether to apply your changes to 
the Row Axis, Column Axis, Slice Axis, or All Axes. If you want to apply a format to a specific 
axis, select that axis in the Apply To Axis field before you select a fill or font. 

Formatting Options 

Use the Formatting Options section to select which aspects of your worksheet to change. Select 
the corresponding button to change these formatting options: 

• Text Color – Sets the color of text in the axes of the worksheet. 

• Fill Color – Sets the background color for worksheet axes. 

• Font – Displays a standard font dialog box, in which you select the size and style of text in 
your worksheet axes. 

Axis Options 

The options available affect the axis display of axes currently in outline view. Axis options can 
only be changed for one grid axis at a time. Click the check boxes to toggle the display of the 
following axis options: 

• Show Connector Lines – Toggles the display of connector lines in the chosen axis when 
multiple dimensions are displayed in outline view. 

• Shade Colors by Dimension – Toggles the use of a shading scheme to differentiate 
dimensions in the axis and grid display. When this check box is selected, position labels and 
data cells that belong to different hierarchical levels are shaded differently. 

• Show Attribute Labels – Toggles the display of label headers that designate attributes for 
positions appearing along the chosen axis. For the column axis, these attribute labels appear 
to the left of the column axis header area. For the row axis, the labels appear directly above 
the row axis header area.  

 Note: This option turns on/off the display of attribute labels. To turn on the display of 
position attribute values, right-click over the desired axis and choose Select Display and 
Sort Attributes from the menu. 

Preview Window 

The Preview window provides a sample view of your changes. 

Clear Format 

The Clear Format button removes all formatting options from the selected axis.  

To make your changes without closing the dialog box, click the Apply button. To make the 
changes and return to your worksheet, click OK. Click Cancel to close the dialog box without 
applying any format changes. Note that Cancel does not undo any changes that have already been 
made using the Apply button. 
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Format > Chart 
The Chart option on the Format menu is only available when you are viewing data in Chart mode. 
This menu item allows you to customize a variety of chart features, including chart type, color 
scheme, title style, axis settings, and 2D/3D aspects. 

The Format button on the workbook tool bar performs the same function as selecting the Format-
Chart menu option. Click the Format button to produce the Chart F/X Properties dialog. 

Format > Chart > 3D 
The 3D tab of the Chart F/X Properties dialog allows you to customize properties of three-
dimensional charts. The features on the 3D tab are only enabled when your chart is displayed in 
3D view. To change your chart to 3D mode, select the 3D check box on the Format > Chart > 
General dialog. 

Rotated View 

Allows you to toggle between the standard three-dimensional view of your chart and your 
customized, rotated view. Select this check box to convert your chart to the rotated view specified 
by selections made on the 3D dialog. This field is only enabled when you are viewing your chart 
in 3D mode. 

X Angle 

If Rotated View is selected, the X Angle field allows you to enter the numeric value of the x-axis 
rotation angle. The rotation of the x-axis can also be performed by dragging the blue marble in 
the interactive rotation figure at the upper left of the dialog. 

Y Angle 

If Rotated View is selected, the Y Angle field allows you to enter the numeric value of the y-axis 
rotation angle. The rotation of the y-axis can also be performed by dragging the red marble in the 
interactive rotation figure at the upper left of the dialog. 

Shadows 

Allows you to specify the shadow effect for your 3D chart. There are three options available: 
None (Unlit), Fixed Angle, and Realistic. 

Depth 

Drag the pointer on the Depth slider to control the depth of your 3D view. Move the pointer to the 
right to increase depth. 

Perspective 

Drag the pointer on the Perspective slider to alter the perspective of your 3D view. Use the 
sample rotation frame at the top right of the dialog to preview your chosen perspective. 

When you have made your selections, click Apply to apply the changes and leave the Chart F/X 
Properties dialog open. Click OK to apply the changes and close the dialog, or click Cancel to 
return to your chart without implementing any changes. 
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Format > Chart > Axes 
The Axes tab of the Chart F/X Properties dialog allows you to customize axis settings, such as the 
appearance of major/minor axis units, gridlines, and tickmarks. 

Axis Selection List 

Select the axis you wish to format from the axis picklist. Any formatting changes made on the 
Axes dialog will be applied to the selected axis. 

Visible 

Toggles the display of the labels and tickmarks of the axis selected in the picklist. Uncheck this 
check box to remove tickmarks and axis values from the chart display. 

Major Unit / Minor Unit 

Allows you to set the major interval and the minor interval for the selected axis. Labels for major 
unit values are displayed alongside their respective tickmarks; minor unit values show tickmarks 
only. 

Show Gridlines 

Toggles the display of gridlines associated with the major/minor units along the selected axis. 

Tick Mark Type 

Allows you to specify the style of tickmark for the major/minor unit values along the selected 
axis. Options include: None, Outside, Inside, and Cross. 

Details 

Click the Details button to specify more options for the selected axis, including 
minimum/maximum axis values, axis titles and text orientation, and gridline color/style/weight.  

Format > Chart > Axes > Labels 
Allows you to create axis titles and manipul\ate the text orientation of labels displayed on the 
selected axis.  

Orientation 

Click the spin buttons to increase or decrease the angle of rotation for label text. As you click the 
buttons, the preview window will provide you a sample view of the selected text orientation. 

Show Labels 

Toggles the display of axis labels. Select this check box to display labels for the selected axis. 

2 Levels 

Allows you to create staggered labels such that consecutive labels are represented in different 
modes of alignment.  
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Rotate With Chart 

Allows you to specify whether text should rotate accordingly with any change in the chart’s 
three-dimensional rotation. Select this check box to have axis text rotated along with the chart’s 
3-D manipulation.  

Title 

Allows you to enter a title for the selected axis. 

Format > Chart > Axes > Scale 
Allows you to format the scale of the selected axis. 

Minimum / Maximum 

Allow you to specify a minimum value and maximum value for the chosen axis. If any chart 
value falls below this minimum or above this maximum, the chart will be clipped. 

Scale Unit 

Sets the scale unit for the axis. The default is 1.00. The chosen axis labels and values in the grid 
are scaled by any value entered in this field. For example, if you enter a scale unit of 1000, the 
default axis labels and data points in the grid are divided by 1000. Thus, you can display large 
data values in an abbreviated format.  

Format 

Sets the format of the selected axis. Choose a format type from the picklist: 

• None – Displays numeric data with no formatting. 

• Number – Displays numeric data with a comma separator every three digits. 

• Currency – Displays numeric data preceded by a dollar sign, and with a comma separator 
every three digits. 

• Scientific Notation – Displays numeric data in scientific notation (exponential format). 

• Percentage – Converts numeric data to percentage format and displays this value followed by 
a % sign. 

Decimal Places  

Allows you to set the number of digit places to follow a decimal in axis labels and chart values. 

Logarithmic Scale 

Toggles the display between logarithmic and linear scales. Select this check box to create a 
logarithmic scale with a log base of 10. 
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Zero Line 

Allows you to set the starting point for the chart at zero.  

For line charts, selecting this option simply has the effect of drawing a gridline at the zero mark 
along the selected axis. This allows you to easily see negative data values in the chart, as these 
point markers fall below the zero line.  

For bar charts, selecting this option causes bars to be drawn starting at the zero mark and 
incremented in the appropriate direction (positive or negative). If there are negative values in 
your chart, these bars will be drawn in a negative direction (below the zero line). 

Format > Chart > General 
The General tab of the Chart F/X Properties dialog allows you to select general types of 
formatting options for your chart. Use this tab to specify display effects and color schemes for 
various chart features. 

Effects 

3D – Toggles the display between 2D/3D views. When selected, the chart will be displayed in 
three-dimensional mode. 

Cluster (z-axis) – Activates/deactivates z-axis clustering. When you are viewing your chart in 3D 
mode and this feature is checked, then each charted series will appear in a separate row along the 
z-axis. 

Stacked – Allows you to stack all series in the chart. This option is only available when the chart 
type is Area, Area-Curve, Bar, or Gantt. There are three stacked-style options: 

• Side by Side (no stacking) – Series are placed alongside each other and are not stacked. 

• Stacked – At any given position, each data series is charted on top of the previous one, adding 
its value to the stacked bar. 

• Stacked 100% – Like the stacked option, each data series is positioned above the previous 
one, adding its value to the stacked bar. However, for each position, each series’ percentage 
of the total is calculated and charted, such that all series together total 100%. At any given 
position, this option allows you to compare the strength of each series relative to the whole. 

Axes Style – Allows you to change the line style of the chart axes. There are four options: None 
(no axes), 3D Frame, Math, and Flat Frame. 

Grid Lines – Allows you to specify the display of grid lines in your chart. The four options are: 
None, Horizontal, Vertical, and Both. 

Colors 

Palette – Allows you to change the entire color palette for the chart. Changing the palette will 
affect all elements of the chart. Click the arrow to produce a list of available palettes. 

Scheme – Allows you to select the pattern display for plotted data series. The options are: Solid 
(color), B/W Patterns, Color Patterns, B/W Hatched, Hatched (color). 

Background – Allows you to specify the color of the chart background and point legend. Click 
the arrow to produce a color palette, then click the desired color. 

Chart Box – Allows you to specify the color of the chart box (the area within the grid axes). Click 
the arrow to display a color palette, then click the desired color. 
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Title 

Enter a title for your chart in the Title text field. 

When you have made your selections, click Apply to apply the changes and leave the Chart F/X 
Properties dialog open. Click OK to apply the changes and close the dialog, or click Cancel to 
return to your chart without implementing any changes. 

Format > Chart > Series 
The Series tab of the Chart F/X Properties dialog allows you to set and customize settings for 
each data series independently. The changes you make on this dialog will be applied to the data 
series selected in the drop-down list at the top left of the dialog (or to all series if the <All Series> 
option is chosen). 

The options available on this tab change depending on the chart type. 

Format > Chart > Series (Bar/Gantt chart types) 

Series List 

Select a data series to modify from this drop-down list. Any changes you make on this dialog will 
be applied to the data series selected in the drop-down list at the top left of the dialog (or to all 
series if the <All Series> option is chosen). 

Fill 

Allows you to specify the fill color of the bar representing the selected series. Click the arrow to 
display a color palette, then click the desired color. 

Border 

The bars representing each series may be displayed without a border, or with a custom border 
whose color, style, and weight you define. 

• None – Click this radio button to plot the selected series without a border. 

• Custom – Click this button to specify border features for the selected series. Customizable 
features are: color, style, and weight. 

Styles 

Gallery: Allows you to change the chart type. Each series may be represented by a different chart 
type (for example, Series #1 may be plotted as a line chart, and Series #2 may be plotted as a bar 
chart). Alternatively, select the <All Series> option in the series list to change the chart type of 
each series uniformly. Click the arrow to produce a menu of available chart types. For a 
description of these types, see the following topic:  

Gap Width %: Specifies the thickness of each bar by allowing you to adjust the spacing between 
groups of series along the point axis. Increase the gap width percentage to increase the spacing 
between points, thus decreasing the thickness of each series’ bar. 
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Bar Styles 

• Square: Click this button to represent the selected series by standard rectangular bars. 

• Cylinder: Click this button to represent the selected series by shaded cylindrical bars. 

• Cone: Click this button to represent the selected series by shaded conical bars. 

 Note: For Cylinder and Cone style bar charts, you are also provided the ability to 
increase/decrease the number of cylinder/cone facets (sides). Valid values for this field 
include integers from 2-32. The greater the number of sides, the more depth and realism 
your chart will appear to have. 

Show Point Labels: Select this check box to include point values on your chart. For bar graphs, 
the value of each point will appear above the bar. 

Visible: Allows you to show/hide the selected series in the chart. Select this check box to include 
the series in the display; clear the check box to hide the series. This option is only available when 
a single series is selected in the series picklist (and not <All Series>).  

Sample: Provides you with a sample view of the fill color and border features selected for the 
chosen series. 

When you have made your selections, click Apply to apply the changes and leave the Chart F/X 
Properties dialog open. Click OK to apply the changes and close the dialog, or click Cancel to 
return to your chart without implementing any changes. 

Format > Chart > Series (Line/Curve chart types) 

Series List 

Select a data series to modify from this drop-down list. Any changes you make on this dialog will 
be applied to the data series selected in the drop-down list at the top left of the dialog (or to all 
series if the <All Series> option is chosen). 

Marker Fill 

Allows you to specify the fill color of the selected series’ point markers. Click the arrow to 
produce a color palette, then click the desired color. 

Lines 

Each series line may be displayed in the same color as the point markers, or you may specify a 
custom line color/style/weight. 

• Same color as markers – Click this radio button to have the selected series’ point markers and 
line displayed in the same color. 

• Custom – Click this radio button to specify an independent line color, line style, and line 
weight for the selected series. 
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Markers 

Gallery: Allows you to change the chart type. Each series may be represented by a different chart 
type (for example, Series #1 may be plotted as a line chart, and Series #2 may be plotted as a bar 
chart). Alternatively, select the <All Series> option in the series list to change the chart type of 
each series uniformly. Click the arrow to produce a menu of available chart types. For a 
description of these types, see the following topic:  

Shape: Allows you to specify the shape of the selected series’ point markers. Click the arrow to 
produce a menu of available shapes. 

Show Every: Allows you to specify an interval at which to display point markers. For example, 
enter 3 to have every third point marker displayed. The default value is 1, which displays every 
point marker for the series. 

Size: Increases/decreases the size of the point markers for the selected series. Increase the value 
to enlarge the markers. 

Show Point Labels: Select this check box to include point values on your chart. For line graphs, 
the value of each point will appear above the point marker. 

Visible: Allows you to show/hide the selected series in the chart. Select this check box to include 
the series in the display; clear the check box to hide the series. This option is only available when 
a single series is selected in the series picklist (and not <All Series>). 

Sample: Provides you with a sample view of the custom line style selected for the chosen series. 

When you have made your selections, click Apply to apply the changes and leave the Chart F/X 
Properties dialog open. Click OK to apply the changes and close the dialog, or click Cancel to 
return to your chart without implementing any changes. 

Format > Delete Format 
Clears any formatting changes that you have previously saved as a format. If Delete Format is 
selected, then any new workbooks created using the same workbook template will no longer 
default to this format. The Delete Format option on the Format menu is available when you are 
viewing your data in either Grid or Chart mode.  

 Note: Format changes are saved with the workbook template and thus only affect future 
workbooks created from that same template. For example, if you select Delete Format 
while viewing a Planning Workbook, the format of a new Measure Analysis Workbook 
will not be affected. 
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Format > Exceptions 
Displays the Exceptions tab of the Format Options dialog, in which you can specify the 
formatting for exceptions, or data values that fall outside an acceptable range that you define. The 
formatting options are only available for numeric measures. The Exceptions option on the Format 
menu is only available in Grid view. 

Measure List 

The Measure list allows you to select the measure whose exception values are to be formatted. 
Click on a measure in the list to select it. Make your measure selection here before specifying a 
range or any display features to be formatted. 

Minimum 

This section of the dialog allows you to set the minimum value of the acceptable range for a 
measure, as well as the text color, fill color, and font in which to display any value falling below 
that minimum. 

Maximum 

This section of the dialog allows you to set the maximum value of the acceptable range for a 
measure, as well as the text color, fill color, and font in which to display any value falling above 
that maximum. 

 Note: The amounts entered in the Minimum and Maximum fields must be within the 
valid range for an editable measure. For example, if the valid range for a measure is 1 to 
99, the system will not accept a Maximum value of 100. An error message will appear 
prompting you to re-enter this number. 

Enable Exception Display 

The Enable Exception Display check box toggles the display of your selected exception formats. 
If the check box is selected, the exception formats will be applied and displayed in your 
worksheet wherever applicable. If the check box is cleared, exception values will not be 
displayed; however, the system retains your specified exception formats for use later. 

Clear Format 

The Clear Format button removes any exception range and formatting set for the selected 
measure. 

To make your changes without closing the dialog box, click the Apply button. To make the 
changes and return to your worksheet, click OK. Click Cancel to close the dialog box without 
applying any format changes. Note that Cancel does not undo any changes that have already been 
made using the Apply button. 

Format > Grid 
Displays the Grid tab of the Format Options dialog, in which you can change the appearance of 
the grid lines in your worksheet. You may also specify the string values to be displayed when 
data in cells is NA, or when the value of aggregate-level data is ambiguous. The Grid option on 
the Format menu is only available in Grid view. 
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Formatting Options 

The Formatting Options section allows you to select the color of the grid lines in your worksheet. 
Click the Line Color Within Grid button to produce a color palette to use to specify the desired 
color. 

Grid Options 

The Grid Options section allows you to specify whether grid lines and hierarchy tiles should 
appear on your worksheet. Use this section also to specify display values for instances in which 
cell data is NA or ambiguous. The Grid options are: 

• Show Horizontal Grid Lines – If this check box is selected, the horizontal grid lines will be 
displayed on the screen. 

• Show Vertical Grid Lines – If this check box is selected, the vertical grid lines will be 
displayed on the screen. 

• Show Hierarchy Tiles – If this check box is selected, the hierarchy tiles will be displayed on 
your worksheet. Clear this check box to eliminate the hierarchy tiles from your worksheet 
view. 

• NA – In this field, you can specify a string value that you would like to appear in all cells that 
have NA as a value (for example, N/A, *, etc.). 

• Ambiguous Type – In this field, you can specify the string to be displayed when it is not clear 
how the system should aggregate certain data values. This string indicates the presence of 
lower level data that cannot be displayed at a particular level of aggregation. For example, 
picklist-type data at the SKU level would aggregate ambiguously if different SKUs in the 
same Style contained different picklist values. You can specify here what the system should 
display in a Style-level cell. 

Preview Window 

The Preview window provides a sample view of your changes. 

Clear Format 

The Clear Format button removes all grid formatting options from your worksheet.  

To make your changes without closing the dialog box, click the Apply button. To make the 
changes and return to your worksheet, click OK. Click Cancel to close the dialog box without 
applying any format changes. Note that Cancel does not undo any changes that have already been 
made using the Apply button. 

Format > Measure 
Displays the Measures tab of the Format Options dialog. The changes made on this tab affect the 
way measure labels and data appear in your worksheet. The Measure option on the Format menu 
is only available in Grid view. 

Apply To 

The Apply To option allows you to select whether to apply your changes to the Cells, to the 
Labels, or to Both.  
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Measure List 

The Measure drop-down list allows you to select one or more measures to be formatted. Click on 
a measure in the list to select it. To make multiple selections at the same time, use <Ctrl+Click> 
or <Shift+Click>. Make your measure selections here before choosing any worksheet features to 
format.  

Formatting Options 

Use the Formatting Options section to select the aspects of your worksheet to change. Any 
formatting options selected affect only the measure(s) selected in the Measure drop-down list at 
the time the changes are applied. Select the corresponding button to change these formatting 
options: 

• Text Color – Sets the color of text for the selected measure’s label and/or cells. 

• Fill Color – Sets the background color for the selected measure’s label and/or cells. 

• Font – Displays a standard font dialog box, in which you select the size and style of text for 
the selected measure’s label and/or cells. 

• Alignment – Allows you to select left, center, or right alignment for the selected measure’s 
cells. The Alignment feature can be formatted for cells only (not measure labels). 

• Border Style – Displays a dialog box containing a list of available border styles (solid line, 
dashed line, dotted line, etc.) to apply to the selected measure’s data cells. This dialog box 
permits you to apply the border to the top, bottom, right, and/or left side of the cells. The 
Border Style feature can be formatted for cells only (not measure labels). 

• Border Color – Sets the color for the border applied to the selected measure’s data cells. The 
Border Color feature can be formatted for cells only (not measure labels). 

Preview Window 

The Preview window provides a sample view of your changes. 

Clear Format 

The Clear Format button removes all formatting options from the selected measure(s).  

To make your changes without closing the dialog box, click the Apply button. To make the 
changes and return to your worksheet, click OK. Click Cancel to close the dialog box without 
applying any format changes. Note that Cancel does not undo any changes that have already been 
made using the Apply button. 
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Format > Save Format 
Allows you to save any formatting changes you have made to the workbook with the workbook 
template. In doing so, you cause any new workbook that you create using that same workbook 
template to default to your saved format. This feature prevents you from having to redefine 
formatting changes each time you recreate a workbook. The Save Format option on the Format 
menu is available when you are viewing your data in either grid or chart mode. 

Depending on your access level, you can save formats at the User level, Template level, or Group 
level. If you save a format at the User level, that format will affect subsequent workbooks created 
by you alone. If you have administrative access, you can save a format at the Template level, and 
all new workbooks created in the system by any user using that same workbook template will 
automatically default to that format. Formats saved at the User level override those saved at the 
Template level. You can also save formats at the Group level. These changes affect subsequent 
workbooks created by members of the group you specify. 

 Note: These styles are saved with the workbook template and thus only affect future 
workbooks created from that same template. For example, if you make formatting 
changes while viewing a Planning Workbook and then select Save Format, these changes 
will not be seen when you create a new Measure Analysis Workbook. They will, 
however, be seen whenever you create a new Planning Workbook. 

 Note: Saved formats do not affect previously created and saved workbooks.  

Format > Types 
Displays the Types tab of the Format Options dialog, in which you can modify the cell formatting 
options for measures. The Type option on the Format menu is only available in Grid view. 

Measure List 

The Measure drop-down list allows you to select the measure for which cell formats are to be 
modified. Click on a measure in the list to select it. Make your measure selection here before 
specifying any display options or formatting options to be changed.  

Display Options 

• Prefix – Enter any string to appear as a prefix before each data value for the selected measure. 
For example, you can enter "$" to indicate the monetary nature of a sales measure. 

• Suffix – Enter any string to appear as a suffix after each data value for the selected measure. 
For example, you can enter "%" to indicate that a given measure value is a percentage. 

• Scale Factor – Enter an integer value to act as a scaling factor for the measure. When you 
enter data for a measure that contains a scaling factor, the value you enter is multiplied by the 
measure’s scaling factor to obtain an internal value that is recognized by the server in data 
calculations.  
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Formatting Options 

The formatting options available depend on the type of measure selected. 

Floating Point type measures have the following formatting options: 

• Precision – Allows you to specify the number of digits to be displayed to the right of the 
decimal. 

• Use Separator – Allows you to specify whether a separator (a comma) should appear between 
every three digits. 

Integer type measures have the following formatting options: 

• Use Spin Button – Displays up and down arrows in the worksheet cell that allow you to 
increase or decrease the cell’s value. 

• Increment Spin By – Allows you to set the amount that the system will increase or decrease 
the cell value when you click on the spin buttons. This option is only enabled when the Use 
Spin Button check box is selected. 

• Use Separator – Allows you to specify whether a separator (a comma) should appear between 
every three digits. 

String type measures have the following formatting option: 

• Max # of Characters – Allows you to set the maximum number of characters permissible in 
an individual data cell. 

Preview Window 

The Preview window provides a sample view of your changes. 

Clear Format 

The Clear Format button removes any type formatting set for the selected measure. 

To make your changes without closing the dialog box, click the Apply button. To make the 
changes and return to your worksheet, click OK. Click Cancel to close the dialog box without 
applying any format changes. Note that Cancel does not undo any changes that have already been 
made using the Apply button. 

Format > Workbook 
Displays the Workbook tab of the Format Options dialog. This tab allows you to enable/disable 
the synchronized page scrolling feature. 

Enable Synchronized Page Scrolling 

Check this check box to enable synchronized page scrolling. Often, multiple windows exist that 
contain the same page, or slice, dimension. Slice dimensions are those that appear along the z-
axis of a window (that is, the top left of the worksheet). Positions along the slice dimension are 
viewed as pages through which you can scroll, using the slice scroll bar to the right of the 
position indicator.  

When synchronized page scrolling is enabled, all windows that contain the same slice dimension 
will scroll to a new slice position when any one window is scrolled. 

When synchronized page scrolling is disabled, scrolling through slice positions in one window 
does not affect the slice position display of other windows. 
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Window menu 
The Window menu contains options for manipulating open windows. It includes the following 
options:  

Window > New Window 
Creates a new window. This new window has the same contents as the active window, and can 
display different parts of the window or show the same parts of the window in different views. If 
the contents of the original window change, all of the other windows that contain the same 
information will reflect those changes. When you open a new window, it becomes the active 
window and is displayed on top of all other open windows. This menu item is enabled as long as 
there is at least one window open in the application.  

Copy the active window and worksheet  

Window > Delete Window 
This option deletes the current window. This menu item is only enabled when the workbook 
contains more than one window of the same type. 

If the active window is the last window of that type, you will not be able to delete it. 

Window > Rename Window 
This option allows you to specify a new name for the active window. A dialog displays where 
you can type the new name.  

Window > Hide 
This option hides, but does not delete, the active window. A hidden window is not displayed as an 
icon or on the Windows List area at the bottom of the Window menu. A window can be unhidden 
by selecting the Unhide option. 

Window > Unhide 
This option displays a dialog box that lists all currently hidden windows. Highlight one or more 
window titles, and click OK to unhide them. This menu item is only enabled when there is at least 
one hidden window. 

Window > Cascade 
Arranges all open windows so that all worksheet titles are visible, but only the window on top 
(the active window) can be viewed completely. To view any other window in the cascade, click 
on that window’s title bar to bring it to the front. 
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Window > Tile Horizontal 
This option arranges all currently open windows in a stack that stretches from the top of the 
screen to the bottom. The height of each window depends on the number of windows that must be 
displayed. This display method is useful when you want to view two or more windows 
simultaneously for comparison. 

Window > Tile Vertical 
This option arranges all currently open windows vertically from left to right across the full screen. 
The width of each window depends on the number of windows that must be displayed. This 
display method is useful when you want to view two or more windows side by side for 
comparison. 

Window > Windows List 
The bottom portion of the Windows menu contains a list of all unhidden windows. Each unhidden 
window is represented here (grid or a chart, open or minimized). A checkmark is located beside 
the active window. To activate any other window from this list, click the window name. 

Select the Unhide option from the Window menu to view a list of currently hidden windows. 

Window > Message Log 
Produces a dialog box that displays error messages. This menu option is only enabled when there 
are messages to be read. 

Help menu 

Help > About 
Displays information about the application, including client version, server version, copyright, 
and licensing information. 

Help > Contents 
Displays the contents for the Retek Predictive Solutions help system. 
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Chapter 4 – Using workbooks, 
worksheets, and wizards 
Using workbooks and worksheets 
Workbook and worksheet components 

Overview 
Worksheets have several common features. The measure labels, workbook titles, and specific 
data values contained in the figure (when you click the link below) are provided as examples and 
will probably differ from your organization’s hierarchical structure, terminology, and quantitative 
information. 

 

Workbook title bar 
The title of the workbook is displayed at the top of the screen along with the domain (name of the 
domain appears in brackets) that you are logged on to. The domain specifies the type of products 
and locations you are currently viewing. 
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Menu bar 
The menu bar is displayed under the workbook title bar. To access a particular command, left-
click once on the menu label. A pull-down menu of options that are specific to that selection is 
displayed. The choices in the menu are context-sensitive, meaning that the choices and their 
availability change depending on your current selection or mode of work. When an item is grayed 
out, it is not available in your current selection or work mode.   

Toolbar 
The toolbar contains buttons that give you direct access to many common commands and actions. 
ToolTips are available for the buttons when you move your mouse over the button. 

Worksheet title bar 
The title of the current worksheet is displayed here. 

Flow control worksheet tabs 

There is a row of flow control worksheet tabs located near the top of the application window and 
beneath the toolbar. Each tab represents a distinct step in the business process, and the tabs are 
ordered in a logical progression of necessary steps. Each tab (or step) is associated with a separate 
worksheet. Click on a flow control tab to access the worksheet that is relevant to that step in the 
planning process. 

When building a new workbook, the worksheet associated with each flow control tab may be 
minimized. When a worksheet is minimized, an icon representing that worksheet is displayed 
near the bottom of the screen. Double-click the icon to expand the worksheet to full view. 

Display worksheets from different flow control process steps 

When you click a specific tab in the flow control, only those worksheets associated with that 
process step are automatically available for view. If you want to simultaneously view two or more 
worksheets that are associated with different flow control tabs, you must display the relevant 
worksheet for one business step, and then use the Unhide option on the Window menu to display 
any of the planning workbook’s other worksheets (even those related to other flow control steps). 
The system treats all worksheets that are not associated with the currently selected flow control 
step as if they are hidden. Therefore, any worksheet is available for view in a non-standard flow 
control step when you select that worksheet from the list provided on the Unhide dialog. 

Status bar 
The status bar at the bottom of the worksheet window displays logon/logoff notifications, 
warnings, and other system messages. If a pull-down menu is currently expanded and the cursor 
is placed over any of that menu’s available command options, the status bar will display a brief 
description of that menu option’s function. 

Hierarchy tiles and display areas 
Hierarchies are the structures used by an organization to describe the relationships that exist 
between the many dimensions. Typically, any dimension will belong to one of the following four 
hierarchies: Product, Location, Calendar, or Measure. There may be others, but these are the most 
common. These hierarchies are represented on the worksheet by hierarchy tiles (named gray 
rectangles) that represent each hierarchy.  
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Hierarchy tiles 

Hierarchy tile positions designate the worksheet axis where a particular hierarchy’s information is 
displayed. To change the orientation of data in a worksheet, drag and drop the hierarchy tiles to 
reposition them. The hierarchy tiles you will see in Retek Predictive Solutions include: 

 

Display areas 
Hierarchy tiles can reside in the Row Display Area, the Column Display Area, or the Slice 
Display Area. 

The location of a hierarchy tile determines how the tile’s associated data is displayed. Data that is 
presented on the screen can be viewed in any format when you reposition the hierarchy tiles on 
the worksheet screen.  

Row display area 
A row display area, which is located at the bottom left corner of the worksheet, is one of three 
portions of the worksheet that contain the hierarchy tiles. Hierarchy tiles in this location have 
their contents and dimensions displayed in rows. The headings for these rows appear on the left 
side of the worksheet along the row axis.  

Column display area 
The column display area is located at the top right corner of the worksheet. The contents and 
dimensions of the hierarchy tiles in this location are displayed in columns. The headings for these 
columns appear across the top of the worksheet along the column axis.  

Slice display area 
The slice display area is located at the top left corner of a worksheet. Moving a hierarchy tile to 
this location controls which dimension is displayed in the slice axis. A separate page (or slice) 
exists for each element of the dimension and is represented by the hierarchy tile residing in the 
slice display area. 

Row axis 
The row axis of the worksheet displays the contents and dimensions of the hierarchy tiles that are 
currently in the row display area. Data for these dimensions are presented in rows, and the labels 
for each row position appear down the left side of the worksheet. 

Column axis 
The column axis of the worksheet displays the contents and dimensions of the hierarchy tiles that 
are currently in the column display area. Data for these dimensions are presented in columns, and 
the labels for each column position appear across the top of the worksheet. 

Slice axis and scroll bar 
The slice axis, which runs perpendicular to the plane of the computer screen, is necessary for the 
system to present multidimensional data on your two-dimensional monitor. A slice is like a page 
in a book. A separate page (or slice) exists for each element of the dimension represented by the 
hierarchy tile residing in the slice display area. 
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The slice scroll bar works as a page-turner and is available when there is a hierarchy tile 
positioned in the slice display area. Click the right double triangles to page forward through data, 
and click the left double arrows to page back. The left line-arrow button moves you to the first 
page of data, and the right arrow-line button moves you to the last page of data. 

Vertical scroll bar 
The standard vertical scroll bar is used to navigate within the grid portion of the worksheet 
window. This scroll bar allows you to scroll up and down through the displayed data. 

The thumbtack (sliding control on the scrollbar) shows the viewing position on the screen relative 
to the full body of data. 

Perform the following functions on the vertical scroll bar: 

• Click the thumbtack to press it, A pop-up caption displays the number of items along that axis 
and the item number that you are currently viewing.  

• Click the thumbtack and hold the mouse button down. Drag the thumbtack rapidly to any 
location on the scroll bar. Release the mouse button to release the thumbtack.  

• Click anywhere on the vertical scroll bar above the thumbtack to move up one page of data at 
a time. 

• Click anywhere on the vertical scroll bar below the thumbtack to move down one page of 
data at a time. 

Horizontal scroll bar 
The standard horizontal scroll bar is used to navigate within the grid portion of the worksheet 
window. This scroll bar allows you to scroll left and right through the displayed data. 

The thumbtack (sliding control on the scrollbar) shows the viewing position on the screen relative 
to the full body of data.  

Perform the following functions on the horizontal scroll bar: 

• Click the thumbtack to press it. A pop-up caption displays the number of items along that axis 
and the number that you are currently viewing.  

• Click the thumbtack and hold the mouse button down. Drag the thumbtack rapidly to any 
location on the scroll bar. Release the mouse button to release the thumbtack.  

• Click anywhere on the horizontal scroll bar to the left of the thumbtack to move one page of 
data to the left.  

• Click anywhere on the horizontal scroll bar to the right of the thumbtack to move one page of 
data to the right. 
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Workbook and worksheet procedures 

Save and delete workbook formats 

Save a workbook format 

Use this procedure to save any formatting changes you have made to the workbook with the 
workbook template. Any new workbook that is created using the workbook template will default 
to this saved format. Saved information includes tile locations, aggregate roll-ups (outline view), 
measure formatting, window position, slice selection, and block view. 

Formats are saved for the specified workbook template only, and only affect newly built 
workbooks created from that same template. Saved formats do not affect any previously created 
and saved workbooks. 

If your access level is User, you can save user-level formats for your own use. If you have been 
granted Admin status, you can save default formats for all users. If a particular workbook 
template has both a user-level style and a template-level style saved for it, the format saved at 
user level overrides the format saved at the template level. 

You can also save formats at the group level. These changes apply to all users within that group. 

1. From the Format menu, select Save Format. 

2. Select User level, Template level, or Group level depending on the level that you want to 
save the format.  

• Select User if you want to save the format for your own use. 

• Select Template if you have been granted Admin status, and you want to save the format 
for global use.  

• Select Group, and select from the list of available user groups if you want to save the 
format for a user group. 

Delete a workbook format 

Use this procedure to clear any formatting changes that you have previously saved. Format 
deletions only affect the workbook template that is associated with that format. For example, if 
you select Delete Format while viewing a Forecast Maintenance workbook, the deletion will only 
affect new Forecast Maintenance workbooks. 

If you have been granted Admin status, you can delete formats at both User level and Template 
level. If your access level is User, you can only delete formats for yourself. Deleting a format at 
Template level means that all new workbooks opened by any user using that same workbook 
template will no longer default to the deleted format. 
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You can also delete formats for a user group. These changes apply to all users within that group. 

1.  From the Format menu, select Delete Format. 

2. Select User level, Template level, or Group level depending on the level that you want to 
delete the format.  

• Select User if you want to delete a saved user format. 

• Select Template if you want to delete a global format. This affects all other users who 
build future workbooks using this template. 

• Select Group, and select from the list of available user groups if you want to delete 
formats for a user group. 

Manage multiple workbook windows 

Copy the active window and worksheet. 

1. From the Window menu, select New Window. 

2. In the New Window dialog box, type a label for the new window. 

3. Click OK. 

Rename the active window 

1. From the Window menu, select Rename Window. 

2. In the Rename Window dialog box, type a new label for the window. 

3. Click OK. 

Delete the active copy of a window and worksheet 

From the Window menu, select Delete Window. 

 Note: This menu item is only enabled when the workbook contains multiple windows of 
the same type. If the active window is the last window of its type, you will not be able to 
delete it. 

Hide an active window 

From the Window menu, select Hide. 

 Note: A hidden window does not appear on the "Windows List" part of the Window 
menu, or as an icon. Use the Window > Unhide option to unhide a hidden window. 

Show (unhide) a hidden window 

1. From the Window menu, select Unhide. 

2. On the Unhide dialog box, select the window you want to unhide. 

3. Click OK. 

Cascade windows 

From the Window menu, select Cascade. All unhidden windows are arranged so that all 
worksheet titles are visible, but only the active window (window on top) can be viewed 
completely. 
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Tile windows horizontally 

From the Window menu, select Tile Horizontal. All windows that are not minimized are arranged 
in a stack that stretches from the top of the screen to the bottom. This display method is useful 
when you want to compare two or more windows by viewing them simultaneously. 

Tile windows vertically 

From the Window menu, select Tile Vertical. All unhidden windows are arranged from left to 
right across the full screen. This display method is useful when you want to compare two or more 
windows by viewing them side by side. 

Minimize an active window 

On the active window, click the Minimize button in the upper right corner.  

Display a minimized window 

• On the minimized window icon at the bottom of the display , click 

either of these buttons:  

• Double-click on the window icon to display the window. 

Print worksheets and generate reports 

Print a worksheet 

1. From the File menu, select Print. 

2. On the Print dialog box, select a printer to use (Name), a range of workbook pages or slices to 
print (Print range), and the number of copies (Copies). 

 Note: By first viewing your worksheet in Print Preview mode, you can determine the 
page numbers where particular worksheet data is displayed. 

3. Click OK. 

Preview a printed worksheet 

1. From the File menu, select Print Preview. 

2. Perform any of the following procedures: 

• To page forward or backward through the document, click the Next Page or Previous 
Page button. You may also use the scroll bar at the right of the screen to scroll through 
the worksheet. 

• To change the magnification of the document, click the Zoom In or Zoom Out button. 

• To modify the page setup (e.g. page orientation, scaling, margins, headers/footers, page 
numbering scheme, or page breaks), click the Page Setup button. 

• To display the Print dialog box and print a copy of the document, click the Print button. 

3. Click Close. 
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Print multiple worksheets 

1. From the File menu, select Print Multiple. 

2. Use <Ctrl+Click> to select multiple worksheets from the list provided. 

3. Put a check in the "Display print dialog before each window" check box to have the Print 
Options dialog displayed individually before each worksheet is printed. This feature allows 
you to specify different printing options for individual worksheets in the print queue. Clear 
the check box if the same printing options apply to all selected worksheets in the queue. 

4. Click OK to submit your selections to the print queue. 

5. Make your print option selections on the Print Options dialog. Selections made here will 
apply to all printed worksheets if the "Display print dialog before each window" check box is 
unchecked. If the box is checked, this dialog will reappear before each worksheet is printed. 

6. Click OK. 

Format and enhance print output 

There are several tools that you can use to enhance the output and appearance of your printed 
worksheets. You can use these tools to generate custom reports from worksheets. 

Select the Page Setup option on the File menu to display printing options. Page Setup options 
always override any settings in the Windows Print Setup dialog box, and they only apply to the 
current document (worksheet or chart). 

Change the page orientation 

 Note: To change page setup settings, you must display the data in Grid view (not Chart 
view). 

1. From the File menu, select Page Setup. 

2. On the Page tab, specify your desired page orientation (portrait or landscape) 

3. Click OK. 

Scale the size of printed output 

 Note: To change page setup settings, you must display the data in Grid view (not Chart 
view). 

1. From the File menu, select Page Setup. 

2. In the Scaling portion of the Page tab, perform either one of the following procedures: 

• Click the Adjust To radio button and enter a numeric value between 10 and 400. This is 
to specify an exact size for the printed output, which is a percentage of normal size. 

• Click the Fit To radio button to specify exact page parameters for the printed output. The 
system will automatically expand or condense the view so that the current slice fills the 
designated number of pages (height x width). 

 Note: You can leave one parameter blank (either height or width) to have the system fill 
pages along that dimension. 

3. Click OK. 
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Set page margins for printed documents 

 Note: To change page setup settings, you must display the data in Grid view (not Chart 
view). 

1. From the File menu, select Page Setup. 

2. Select the Margins tab. 

3. Enter the desired values (in inches) for the top, bottom, left, and right margins.   

 Note: The combination of top and bottom margins must leave at least three inches of 
printable space per page. 

4. View the results of your selections in the Preview window. 

5. Click OK. 

Create customized headers and footers 

 Note: To change page setup settings, you must display the data in Grid view (not Chart 
view). 

1. From the File menu, select Page Setup. 

2. Select the Header/Footer tab. 

3. Click the Custom Header or Custom Footer button. 

4. Make changes to the left section, center section, and right section of the header or footer by 
entering text manually, or by selecting formatting buttons above the text window. 

• Font – Opens the Font dialog, where you specify the font, style, size, and script type for 
your header and footer text. Select the header/footer text to be formatted, and click the 
Font button. On the Font dialog, make the appropriate selections. Click OK to apply the 
changes. 

• Date – Inserts a field marker code that prints the current date at the cursor position. This 
date is automatically updated each time you print the document. To insert a specific 
(unchanging) date, enter the date manually. 

• Time – Inserts a field marker code that prints the current time at the cursor position. The 
time is automatically updated each time you print the document. To insert a specific 
(unchanging) time, enter the time manually. 

• Page – Inserts a field marker code that prints the page number on each page of your 
document. 

• Page Of – Inserts a field marker code that prints the current page number and the total 
number of pages in the document at the cursor position. For example, 2 of 14. 

• Workbook – Inserts a field marker code that prints the current workbook title at the 
cursor position. 

• Sheet – Inserts a field marker code that prints the title of the current worksheet at the 
cursor position. 
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• View – Inserts a field marker code that prints an actual worksheet view at the cursor 
position. Click this button to produce the Select Window dialog, which allows you to 
select the worksheet window to insert. The inserted window cannot be the same main 
worksheet for which you are specifying setup options. By adjusting page margins and 
scaling, you can use this functionality to effectively print several worksheet views on a 
single page. Do this by inserting smaller windows into your header/footer. 

5. Click the Save button to save this combination of header/footer options under a specified 
name. 

6. Click OK to return to the Header/Footer dialog box to preview your work. 

7. Click OK to close the Page Setup dialog. 

Display horizontal and vertical grid lines on printed output 

 Note: To change page setup settings, you must display the data in Grid view (not Chart 
view). 

1. From the File menu, select Page Setup. 

2. Select the Sheet tab. 

3. In the Print section, make the appropriate selections as necessary: 

• Select the Print Horizontal Grid Lines check box to show horizontal grid lines. 

• Select the Print Vertical Grid Lines check box to show vertical grid lines. 

4. Click OK. 

Turn on/off the display of hierarchy tiles in printed output 

 Note: To change page setup settings, display the data in Grid view (not Chart view). 

1. From the File menu, select Page Setup. 

2. Select the Sheet tab. 

3. Check the Print Hierarchy Tiles check box to turn on the display of hierarchy tiles in your 
output. Clear the check box to turn off the display. 

4. Click OK. 

Display row and column labels on printed output 

 Note: To change page setup settings, display the data in Grid view (not Chart view). 

1. From the File menu, select Page Setup. 

2. Select the Sheet tab. 

3. In the Display Pages section, choose one of the following options: 

• Select All Pages to select row and column header labels to appear across the top and left 
side of every printed page. 

• Select Top & Left Pages to select row and column header labels to appear across the 
topmost and leftmost pages only. This is how they will appear on the terminal display. 

4. Click OK. 
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Set the page-numbering order 

 Note: To change page setup settings, display the data in Grid view (not Chart view). 

1. From the File menu, select Page Setup. 

2. Select the Sheet tab. 

3. In the Page Order section, choose one of the following options: 

• Select Over, Then Down — to select page numbering across sequential rows from left to 
right (starting in the upper left of the document). 

• Select Down, Then Over — to select page numbering down sequential columns from top 
to bottom (starting in the upper left of the document). 

4. Click OK. 

Specify page breaks after each position in a selected dimension 

You can specify that page breaks should occur in your printed output after every position in a 
given dimension. This could ensure that you have a separate page of output for each month of 
data, or a separate page for each subclass in the Product hierarchy. 

1. From the File menu, select Page Setup. 

2. Select the Page Breaks tab. 

3. In the Hierarchy Breaks section of the dialog, locate the hierarchy (e.g. Product, Calendar) for 
which you want to set page breaks. 

4. In the Break By pick list that corresponds to that hierarchy, select the dimensional level 
where you want to set page breaks. For example, select Month to force a page break after 
every month-level position. Each month of data will appear on a separate page of printed 
output. 

5. Click OK. 

Specify page breaks after groups of positions in a selected dimension. 

You can control the dimensional level where position groupings are made within each hierarchy. 
 When you do this, hard page breaks will only occur at the end of complete positions within that 
dimension. A hard page break might not occur after every position (more than one full position 
may fit on a page), but only complete positions will appear together on the same page.For 
example, January data and February data may appear on one page; and March, and April may 
appear on another page. Forced page breaks will not occur until there is insufficient room on a 
page to print the next full month-level position. 

1. From the File menu, select Page Setup. 

2. Select the Page Breaks tab. 

3. In the Hierarchy Breaks section of the dialog, locate the hierarchy (e.g. Product, Calendar) for 
which you want to establish a position grouping level. 

4. In the Group By pick list that corresponds to that hierarchy, select the dimensional level 
where you want to group positions. For example, select Month to force a page break after the 
maximum number of completed month positions have been fit onto a printed page. 

5. Click OK. 
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Specify page breaks in the Measure hierarchy 

The Measure hierarchy is treated separately from the other hierarchies, such as Calendar and 
Product since there is typically not a dimension level to specify when selecting page break 
options for measures. Follow these steps to specify page breaks in the Measure hierarchy: 

1. From the File menu, select Page Setup. 

2. Select the Page Breaks tab. 

3. Click one of the following three options in the Measure Breaks section of the dialog: 

• None – There are no hard page breaks inserted in the printed output. This is the most 
economical option, because the maximum number of measures is fit onto each printed 
page. 

• Group Measures – This option inserts hard page breaks to be inserted whenever the 
maximum number of complete groups of measures has fit on a page. 

• Break Measures – This option inserts hard page breaks after every measure. Each 
measure will appear on a separate page of printed output. 

4. Click OK. 
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Using wizards 
Overview 
The basic purpose of wizards is to allow you to select specific data to be incorporated into your 
new workbook. The new workbook wizard will walk you through the process of creating a new 
workbook from a template. A wizard is an automated feature that prompts you for answers to a 
series of questions. It then uses your answers to format the workbook that you want to create. The 
specific questions depend on the type of workbook being built.  

Wizards are also used by the system to gather required information related to various 
administrative, analyses, planning, and forecasting processes. For example, wizards are in place 
to aid System Administrators in the task of adding and deleting system users, and to aid users in 
the process of defining and editing alerts. Whenever user input is required by the system to 
conduct a particular task, wizards are the interface through which the system collects the 
necessary information. 

Typical wizards encountered when using Retek Predictive Solutions  
• New workbook creation wizards – This wizard prompts you for information regarding the 

contents and layout of new workbooks. Your system may contain workbook template wizards 
for Administration workbooks, Analysis workbooks, Planning workbooks, and/or Forecasting 
workbooks. 

• Alert Builder wizard – This wizard is used to define how user-created measures are to be 
evaluated during the alert generation process. 

• User Administration wizard – This wizard is used by System Administrators to add/delete 
system users, add/delete user groups, and change user passwords and settings. 

How wizards are invoked and navigated 
To access a new workbook wizard for a template  

1. Select New from the File menu.  

2. Select a workbook template. 

3. Proceed through the wizard screens, making the appropriate selections on each and clicking 
the Next button to advance. 

4. Click the Back button to change information selected on a previous screen.. 

5. Click the Finish button when you reach the final wizard screen, which is indicated when the 
Next button is no longer enabled. The system will assimilate all wizard selections made and 
format and build your new workbook. 
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Wizard AutoFinish 
Each time you complete the required information on a wizard screen, you advance to the next 
screen by clicking the Next button. Notice that the Finish button is also enabled at most stages in 
the wizard process. As an alternative means of completing a wizard, you may click the Finish 
button to have the system automatically complete the wizard process, which is based on stored 
selection data. 

Dialog screens in wizards automatically reflect the selections made the last time the wizard was 
successfully completed. Before building a new workbook, the system creates a record of the 
choices made on each wizard screen. Since the system maintains this record of the most recent 
selections, enough "default" information is generally present for the system to build a new 
workbook without requiring you to access every dialog in the wizard process. 

The Finish button is enabled to allow you to instruct the system to build a new workbook or to 
perform a process that is based on the most recent information it has stored for a given workbook 
template. Whenever the Finish button is pressed, the system automatically processes the 
remaining wizard screens, and it accepts whatever selections are currently stored for each dialog. 
 If the system encounters a screen where a valid selection does not exist (requiring user input), the 
AutoFinish process is interrupted. At this point, the dialog in question is displayed, and you are 
required to enter the appropriate information before the Next and Finish buttons become enabled.  

Wizard two-tree selection dialogs 
The two-tree selection dialog is a very common type of wizard screen that you will encounter. On 
this type of screen, you are asked to pick items (such as products or time periods) from a list of 
Available items, and move them to a list of Selected items. Only items in the Selected items list 
will be incorporated into the new workbook. 

Selection dialogs in new workbook wizards automatically reflect the product, location, and time 
period selections that were made the last time that wizard was used to build a new workbook. For 
example, suppose that you are building a new Forecast Maintenance Workbook in Retek Demand 
Forecasting. The list of products chosen in the product selection dialog of this wizard will 
automatically appear on the Selected Products side of the product selection dialog the next time 
you build a new Forecast Maintenance Workbook. You can still select and de-select products as 
desired. The automatic pre-selection process is intended to provide you with a logical selection 
starting point, which is based on the most recent items of interest. 
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Wizard Procedures 

Single-selection wizards 
Most of the screens that you encounter in the wizard process are of the single-select or multi-
select variety. Single-select and multi-select wizard dialogs require you to make a selection or 
selections from a single list of options, and click the Next or Finish button to proceed. 

Select options from single-select dialogs 
When only one choice is allowed for a short list of options, radio buttons are employed to force a 
single selection. Click the radio button that corresponds to your preference, and click Next to 
proceed to the next screen. 

If there is a long list of available options, a selection list (rather than radio buttons) is provided. 
Click on your desired option to highlight it, and click Next to proceed. 

Multiple-selection wizards 
Most of the screens that you encounter in the wizard process are of the single-select or multi-
select variety. Single-select and multi-select wizard dialogs require you to make a selection or 
selections from a single list of options, and click the Next or Finish button to proceed. 

Select options from multi-select dialogs 
Multi-select dialogs allow you to make multiple choices from a single list of available options. If 
there are only a few items in the list, check boxes are used to allow multiple selections. Select the 
check box that corresponds to each item you want to select, and click Next to proceed to the next 
screen. 

If there is a long list of available options, a selection list is provided rather than a series of check 
boxes. Click the first option you want to select. To make additional selections, hold down the Ctrl 
key while clicking the desired items. When you have made all selections, click Next to proceed. 

Wizard two-tree selection lists 
The wizards in the Retek Predictive Solutions frequently use selection lists. Selection lists allow 
you to select values from one list and move them into another. Use these lists to assign contents 
to workbooks. 

Select or move items on a wizard two-tree selection dialog 
Use the following instructions to move hierarchy items from the Available list into the Selected 
list or to move items from the Selected list back into the Available list. Only those items in the 
Selected items list will be incorporated into the workbook. 

1. Check the boxes next to the items that you want to move to the Selected list. The 
corresponding items are displayed in the Selected list. 

2. To remove items from the Selected list, uncheck the boxes next to the corresponding items in 
the Available list. 

3. After you finish selecting items, click Next (or Finish). 
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Add all items from a wizard’s list of available items 
1. Right-click on the Available list (left side). 

2. Select Add All. 

Remove all items from a wizard’s list of selected items 
1. Right-click on the Available list (left side). 

2. Select Remove All. 

Collapse a node or expand a branch on a wizard two-tree list 
 Note: The Collapse Node and Expand Branch options are only available when you right-

click on a node that is not at base level. 

To collapse a node on a wizard list: 

1. Right-click a non-base level node in a wizard list. 

2. Left-click Collapse Node to select it. 

To expand a collapsed node: 

1. Right-click the collapsed node. 

2. Left-click Expand Branch to select it. 

Collapse or expand an entire dimension on a wizard two-tree list 
1. From a wizard two-tree selection dialog, right-click on a wizard list (Available or Selected). 

On the menu that appears, all dimensions available for display are listed beneath the Find 
option. Currently expanded dimensions are indicated by checkmarks. 

2. To expand a collapsed dimension (has no checkmark), click on its label. 

 Note: To allow dimensions that are not on the list to be expanded, select a higher level 
for hierarchy rollup. 

Collapse or expand multiple dimensions on a wizard two-tree list 
1. From a wizard two-tree selection dialog, right-click on a wizard list (Available or Selected). 

2. Left-click Select Dimensions to select it. 

3. In the Select Dimensions dialog box, highlight each dimension that you want to display in 
your worksheet. All dimensions that you want to remain collapsed in your worksheet view 
must remain unselected. 

4. Click OK. 

5. Select a higher level for hierarchy rollup if you want to allow dimensions that are not on the 
list to be expanded or collapsed. 
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Select a higher level for a hierarchy rollup 
1. From a wizard two-tree selection dialog, right-click on a wizard list (Available or Selected). 

2. From the menu that displays, choose Select Rollup and the highest dimension that you want 
to display. 

You can streamline the process of item selection in wizards by saving lists of selections so that 
the same set can be instantly applied to any applicable two-tree selection dialog. Saving and 
loading complete lists of commonly selected items reduces the time required to build new 
workbooks, because it eliminates the need to re-select combinations of items over time or across 
workbook templates. 

Find an item on a wizard two-tree list 
1. Right-click any item on a wizard two-tree selection list. 

2. Left-click Find to select it. 

3. Under Find What, type all or part of the name of the item to find. The wizard will attempt to 
find the item as you type. Only the list that you right-clicked (Available or Selected) will be 
searched. 

4. You can select the Match Case or Match Entire Description check boxes to further limit your 
search.  

5. If necessary, click Repeat Find to locate the next matching occurrence. 

Dimension labels, if displayed, are dynamic headers that appear at the top of each wizard list 
(Available or Selected). Each label indicates the dimension that appears in the column beneath it, 
and the labels can be used to quickly collapse or expand the dimension that they represent. 

Show/hide dimension labels in wizard two-tree lists 
1. On a wizard two-tree selection dialog, right-click on a list (Available or Selected). 

2. The Show Dimension Labels option toggles the display of header labels on and off at the top 
of the list. A checkmark indicates that the labels are currently shown. 

• To show hidden dimension labels, select Show Dimension Labels when this option is 
unchecked. 

• To hide shown labels, select Show Dimension Labels when this option is checked. 

3. Once the dimension labels are shown, you may click on a label to collapse the dimension that 
it represents. When you do this, the label is minimized to contain only a plus (+) sign. Click 
on this minimized label to expand the associated dimension. 

Show/hide connector lines in wizard two-tree lists 
1. On a wizard two-tree dialog, right-click a list (Available or Selected). 

2. The Show Connector Lines option toggles the connector lines on and off, which indicates 
hierarchical relationships on the list. A checkmark indicates that the lines are shown. 

• To show hidden connector lines, select Show Connector Lines when this item is 
unchecked. 

• To hide shown connector lines, select Show Connector Lines when this item is checked. 
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Saving/Loading selections as position queries 
1. On a wizard two-tree selection window, select the positions for the current hierarchy that are 

to be included in the workbook. 

 Note: If using an existing position query, proceed to the next step. 

2. Select the Position Queries Definitions tab on the right-hand side of the wizard two-tree 
selection window. 

 
3. To save the current selections as a position query, enter a name in the bar located above the 

‘Save access’ drop down list. To load an existing position query, select the desired query and 
click Load. 

4. If saving a position query, select User or World in the Save Access field.  

• User access will only allow the current user to view and use the Position Queries 
Definitions (PQD) in wizard processes. 

• World access will allow all users to view and use the PQD in wizard processes. 

5. Click Save.   

 Note: To change the name or if a mistake is made, select the position query, and click 
Delete. Retype the name and click Save. To update an existing position query, type the 
name of an existing position query and click Save. 

6. Click Next at the bottom of the wizard page to move to the next wizard page. 

 Note: Position queries are saved independently for each hierarchy in the wizard process. 

7. Continue through the wizard process as normal until complete.  

8. Click Finish to build the workbook. 

 



Chapter 5 – Changing views of data in worksheets 
 

71 

Chapter 5 – Changing views of data in 
worksheets 
Overview 
The Retek Predictive Application Server includes several tools for manipulating data displayed in 
the following worksheets:  

• Aggregation  

• Spreading  

• Rotating data  

• Pivoting data  

• Charting worksheet data  

Aggregation 
Aggregation is the process of bringing pieces of data together to form a larger group. After 
hierarchical relationships are established, data can be viewed at any level in the hierarchy. 
Aggregation allows you to view data at summary levels. 

For example, the following figure represents a simple product hierarchy for a company’s 
selection of shirts.  

 
If sales values for this same hierarchy were to appear in the form of a planning worksheet, 
quantities could be viewed at the very lowest level in the hierarchy (style/color/size, or SKU 
level). They can also be viewed at any higher level in the hierarchy. Suppose that there were 
exactly five of each SKU item in this hierarchy sold over a given period. When the SKU level 
items are aggregated to the style/color level, you would see that 15 white crew-neck shirts were 
sold (5 small + 5 medium + 5 large). Further aggregation would show that a total of 30 crew-neck 
shirts were sold (15 white crew-necks + 15 gray crew-necks). If this paradigm is extended to the 
product class level, aggregation would show that 60 shirts were sold (30 crew-necks + 30 pocket 
tees). 
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Data can be aggregated along many possible hierarchical paths. The possible paths of data 
aggregation are defined at the time of system installation. For example, SKUs can roll up into 
styles, product lines, product classes, and ultimately product divisions. These same SKUs can 
also roll up along different hierarchical paths into vendors that provide the products, or into the 
level products that are sold on commission. Whichever hierarchical path of aggregation you 
select, a particular SKU cannot roll up into more than one parent position along that path. 

The function of aggregation in the forecasting process is very important. In the forecast 
generation process, it may be necessary for the system to collect and group data from very low 
levels in order to run useful forecasts. Data is often too sparse and noisy to identify clear patterns 
at lower levels. For this reason, it may become necessary to aggregate sales data from a low level 
to a higher level in the hierarchy in order to generate a reasonable forecast. Once the forecast is 
created at the higher level, you can allocate the results to whatever lower level you want. This is 
done through the process of spreading, which is discussed in the overview of spreading. 

Aggregation is also important in the plan approval process. Typically, you would not want to 
approve sales plans at the SKU/Week level. This level of approval might be very time-consuming 
if hundreds of thousands of SKUs were involved. Sales plan figures are usually aggregated to a 
higher level, such as Style/Month, for approval. 

Data aggregation in a worksheet 
When viewing quantitative data in a worksheet, you may require a view of the information at a 
more aggregate level. The Retek Predictive Solutions use the hierarchical structure defined by 
your organization to roll up information for presentation at a higher level. Rollup is the path that 
the system follows from the root of the hierarchy to another higher dimension in the hierarchy 
during the aggregation process. 

There are several ways to obtain views of the data at these higher levels. Regardless of the 
method you choose, you must first select the highest dimension level that you want to see within 
the rollup path that you want to use. To do this, select the Select Rollup option from a hidden 
quick menu, which you access by properly positioning the cursor and clicking the right mouse 
button. The quick menu associated with a given hierarchy can be accessed when the cursor is 
positioned over that hierarchy’s axis in the grid. For example, to select the rollup for the product 
hierarchy, position the cursor over any point in the axis where the product hierarchy is displayed. 
Right-click the mouse to obtain the associated quick menu, choose Select Rollup, and select the 
highest dimension to be displayed. 

Data aggregation in outline view 
The following discussion about data aggregation options is most applicable when you view your 
worksheet data in block mode, since block mode only allows for the display of data values at one 
dimensional level at a time (the lowest level currently expanded in the grid). The following 
procedures effectively collapse lower-level dimensions, which results in the aggregation of data 
to the next higher level. 

When you view your worksheet in outline view, the display lets you see data at multiple 
dimensional levels at the same time, so you do not need to collapse lower-level dimensions to see 
aggregate totals for higher levels. The menu items described below are still useful for 
manipulating the display (collapsed vs. expanded) of various dimensional levels for the data 
hierarchies in your worksheet. 
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Aggregation options 
You can choose any of the following three methods to aggregate your data and view it at the 
higher level. To access these options, right-click any worksheet axis and a quick menu will be 
displayed. The options that enable aggregation are:  

• Dimension List Option 

• Select Dimensions Option 

• Show Dimension Labels Option 

Dimension List Option 
The Dimension List option allows you to expand or collapse the display of one dimension at a 
time. When a worksheet dimension is collapsed from the grid display, all of that dimension’s 
associated data are aggregated to the next higher level that is currently displayed. 

To aggregate data using the Dimension List option: 

1. Right-click any worksheet axis to display a quick menu of options that are relevant to that 
hierarchy. Dimensions that are currently displayed are shown in the dimension list with 
checkmarks beside them. 

 Note: If you want to aggregate data to a dimension higher than those shown in the 
dimension list, you must first use the Select Rollup option to specify the highest 
dimension that you want to see. 

2. Click any currently checked dimension to collapse that hierarchical level. All associated data 
will be aggregated to the next higher dimension that is displayed. 

 Note: Clicking any unchecked dimension in the list causes the reverse process to happen. 
The previously collapsed dimension will be displayed in the grid in its proper relative 
location in the hierarchy. 

Select Dimensions Option 
The Select Dimensions option allows you to simultaneously expand or collapse the display of 
multiple dimensions. Select this option to display a dialog box where you can select the exact 
dimensions that you want displayed in your worksheet. 

1. To aggregate data using the Select Dimensions option: 

2. Right-click any worksheet axis to display a quick menu of options that are relevant to that 
hierarchy. 

3. Click the Select Dimensions option. 

4. On the dialog that opens, select all dimensions that you want to display in your worksheet. 
Highlighted dimensions will appear in the display. Non-highlighted dimensions will be 
collapsed and data will be aggregated to the next higher level. 

5. Click OK. 
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Show Dimension Labels option 
The Show Dimension Labels option is useful when you want to expand or collapse dimensions 
repeatedly, and if you want to avoid accessing the quick menu each time you do it. This option 
toggles the display of cursor-sensitive dimension header labels in your worksheet. When you 
click on the label for a particular dimension, that dimension is collapsed in the grid, and all 
associated data is aggregated to the next higher level. Once the dimension header labels are 
activated, dimensions can be expanded or collapsed in one single click. 

1. To aggregate data using the Show Dimension Labels option: 

2. Right-click any worksheet axis to display a quick menu of options relevant to that hierarchy. 

3. Select the Show Dimension Labels option. Minimized tabs display, which is located at the 
left side of the column axis headings or at the top of the row axis headings, depending on 
your axis selection.. 

4. Place the cursor over these tabs. The tabs expand to display the dimension labels. 

5. Click any dimension label to collapse that dimension in the grid and aggregate the data to the 
next higher level. 

 Note: Labels representing collapsed dimensions contain a plus (+) sign. Click the plus 
sign to maximize the label and expand that dimension in the grid. 

Display worksheet data in chart form 
Displaying worksheet data in chart form is a useful feature in worksheets. 

What can be displayed in chart format? 

Any numeric data or subset of data in a worksheet can easily be converted to a chart format. 
Viewing data in a graphical format can enable users to subjectively assess (at a glance) how well 
system and final forecasts have predicted actual sales values. Charts can be used for many other 
purposes, such as graphically illustrating changes in sales and forecast patterns over time. 
Patterns and trends in data can be recognized much quicker when data is presented in the form of 
a chart than when that same data is shown in spreadsheet form. 

Customizing chart content 

You can place as much or as little information as necessary in charts. Select the data cells in the 
grid that you want to see charted. When you toggle your worksheet view to chart mode, only the 
selected information is extracted from the grid and plotted in your chart. Like grid-format 
worksheets, you can save and commit charts as components of the workbook. The data they 
contain can be printed and/or exported for use in other systems. Also, by using the New Window 
option on the Window menu, you can view workbook data in grid mode and chart mode 
simultaneously. 
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Customizing chart format 

In addition to customizing content, you can customize the various attributes of a chart’s format: 

• You can choose the type of the chart (for instance; bar graph, line graph, and pie chart) and 
switch between chart types with a few mouse clicks. 

• You can specify the color scheme for your chart; including selections for individual data 
series, the chart background, the legend, and the chart area. 

• You can specify the content and style of the chart title. 

• You can specify customized axis settings; such as the major and minor axis units, the axis 
scale, and the individual axis titles. 

• You can switch between a two-dimensional and three-dimensional view of your charted data. 

• You can control features; such as shadowing, depth, and perspective of your 3D chart. 

Chart styles 

Specific combinations of chart formatting options can be saved as chart styles. These saved styles 
can be applied to subsequent collections of data, which eliminates the need to manually format 
each new chart to your specifications.  

Rotating and pivoting chart data 

The charting feature supports the rotation and pivoting of data while in chart view. Hierarchy tiles 
can be dragged to different axes and repositioned in the same manner that it is performed in grid 
view. Rotating and pivoting can facilitate data analysis by providing different views of the same 
data. 

Changing data values in a chart  

You can directly change data values while in chart mode. You are not required to toggle back to 
grid view to manually key in new data values. These values can be amended by dragging and 
dropping data points in the chart. 

Pivoting Data 
Pivoting is similar to rotating, but only one axis is involved. Pivoting occurs when two or more 
hierarchy tiles that reside on the same axis change their order on the worksheet. To pivot data, 
drag and drop one hierarchy tile in front of the other. The same cursor indicators that are used in 
rotating data are also used when pivoting data. 

Suppose you are viewing a worksheet that has the Product and Calendar hierarchies displayed 
along the row axis with product positions subdivided into weeks. You want to pivot the display in 
such a way that the week positions are subdivided by products. To do this, click and hold the 
Product hierarchy tile, and drag the tile to a position to the right of the Calendar tile. When the 
cursor changes to a left arrow cursor, a right arrow cursor, or a circular cursor; drop the tile by 
releasing the mouse button.  
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Circular Cursor 

 

Right Arrow Cursor 

 

Left Arrow Cursor 

Rotating data 
While viewing quantitative data in the grid format, you may want to alter the manner that the 
information is presented. For example, you may want the product information (for instance SKU, 
color) to be presented in rows down the left side of the screen, while location information (store, 
city) appears as orthogonal columns across the top of the screen. Another user may prefer to view 
the same data with the axes reversed. This means that the location dimension data appears in rows 
and the product dimension data is presented in columns. The process of rotating allows you to 
view key business information in a variety of arrangements. Rotating is the process of moving the 
product, time, location, or other hierarchies from one axis to another. 

Multiple hierarchies can be displayed on any single axis, and each hierarchy can be rotated so that 
it appears on any of the three available axes. To rotate a hierarchy to another axis, drag the 
hierarchy tile that represents it to the display area of that axis. A hierarchy tile can reside in any of 
three locations on a worksheet:  

• Top left (slice axis)  

• Bottom left (row axis)  

• Top right (column axis)  

Try moving the hierarchy tiles on your worksheets to get a feel for how data can be rotated. 

To reposition a hierarchy tile: 
1. Position the cursor over the tile that you want to relocate. 

2. Click and hold the left mouse button. The appearance of the cursor changes to indicate the 
action that you are performing. 

3. While holding down the left mouse button, move the tile to the desired display area. The 
cursor will change when it is positioned over an available dropping point. 

4. Release the mouse button to drop the tile. 
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Cursor indicators when rotating data 
When rotating data, the cursor changes to indicate the action. 

 
The cursor is displayed as a hand that is grasping a tree diagram when you first click and hold the 
hierarchy tile that you want to relocate. The cursor changes when it is positioned over an 
available dropping point (display area). 

 
The Up Arrow cursor indicates that the tile you are dragging will be dropped above a tile that is 
already in place.  

 
The Down Arrow cursor indicates that the tile you are dragging will be dropped below a tile that 
is already in place.  

 
The Left Arrow cursor indicates that the tile you are dragging will be dropped to the left of a tile 
that is already in place.  

 
The Right Arrow cursor indicates that the tile you are dragging will be dropped to the right of a 
tile that is already in place.  

 
The Circular Arrows cursor indicates that the positions of the tile you are dragging and the tile 
above where the cursor is positioned will be swapped. 

Selecting Items 
You can select items or groups of items in the application by using the mouse, the keyboard, or a 
combination of the two. The following standard rules apply when selecting items: 

Click an item to select it. For more information on selecting data cells in your worksheet, see the 
following subtopic: 

• Click an item that has already selected to deselect it. 

• To use the mouse to select a group of contiguous items, position the mouse cursor over the 
first item in the group. Press and hold the left mouse button, drag the cursor to the last 
element in the group, and release and release the mouse button. 

 Note: This selection method is not available in the wizards. 
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• To select a group of contiguous items, select one position with the mouse and hold down the 
Shift key while choosing another position. This process selects the first item, the last item, 
and any positions in between. 

 Note: This selection method is not available in the wizards. 

• To select a group of items that are not contiguous, hold down the Ctrl key, and click on any 
required positions. 

• Use the spacebar to toggle the selection of the last active item. 

Selecting items in a wizard list 
Selection of products, locations, and time periods to be included in a workbook is often required 
when particular workbook wizards are accessed. Products, locations, and time periods on the 
Available side of the wizard must be highlighted and moved to the Selected side of the wizard for 
inclusion in a workbook. 

Selecting items in the grid 
Cells or groups of cells must be selected in the grid before certain operations can be performed on 
them. Operations like cutting and copying data, filling or clearing data cells, and displaying data 
in chart form are typically performed on a subset of worksheet cells that you must select prior to 
invoking the menu command. 

There are several ways to select cells in the grid. In general, cell selections should be made in the 
worksheet axes (where the column and row headers appear), and not in the cells. 

• To select one cell, select the corresponding positions in each axis. In other words, click the 
column header that corresponds to the cell, and click the corresponding row label. 

• When no selections exist, click on any column header in the column axis to automatically 
select that entire column. The same is true for selections made in the row axis. Selection of a 
particular row header results in the selection of the entire row. When selections exist in both 
the column axis and the row axis simultaneously, any cells located at that row/column 
intersection will be selected in the grid. The selection rules outlined above, such as using the 
Shift and Ctrl keys to select multiple items, can be applied in the axis headers to isolate 
groups of cells. 

• If you want to select a block of contiguous cells, the following method allows you to make 
your selection within the grid.  

1. Click in the topmost, leftmost cell in the block to be selected.  

2. Hold the mouse button, and drag the cursor to the bottommost, rightmost cell, and release the 
mouse button.  

3. As you drag the mouse, the corresponding column header and row header positions are 
automatically selected according to your actions. 
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Spreading 
Spreading is the opposite of aggregation, and it allows you to view data at more detailed levels. In 
spreading, totals at higher level dimensions are allocated to lower level dimensions, which are 
based on the lower level’s relationship to the total. 

Spreading Aggregate Forecast Values 
When data is too sparse to create useful forecasts at a low level, it can be aggregated to a 
summary level. The system spreads forecast totals at this higher level back down to the lower 
level, which is based on the lower level’s percent contribution to the higher. The data at the 
lowest level in the hierarchy may be too sparse to create a meaningful forecast; however, this 
same data can be very useful in determining the percent contribution that each position in the 
lower level makes toward the higher. 

For example, an aggregate-level class/store forecast predicts 50 shirts to be sold in Store #001 
over a given time period. A forecast at the lower SKU/store level also determines that red shirts 
make up 40% of the demand, blue shirts make up 30%, white shirts make up 20%, and black 
shirts make up 10%. These percentages can be used to spread the total of 50 shirts back down to 
the lower level of color. 

For example, an aggregate-level class/store forecast predicts 50 shirts to be sold in Store #001 
over a given time period. A forecast at the lower SKU/store level also determines that red shirts 
make up 40% of the demand, blue shirts 30%, white shirts 20%, and black shirts 10%. These 
percentages can be used to spread the total of 50 shirts back down to the lower level of color. 
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Shirt Color  SKU/Store 
Forecast 

% of Total, 
SKU/Store 

New SKU/Store 
Forecast, 
spread from 
Class/Store 

Red 8 40% 20 

Blue 6 30% 15 

White 4 20% 10 

Black 2 10% 5 

Total 20 100% 50 
Additional forecasts are often run at low levels in the hierarchy to determine the percentages to be 
used when spreading forecast data from higher levels. Forecast data at low levels might be 
enough to generate reliable percentage-to-whole information, but the actual forecast numbers are 
much more robust when generated at the aggregate level. 

REPD Functionality 
The Retek Predictive Solutions let you spread aggregate data into individual cells by using a 
group of methods called REPD (Replicate, Evenly, Proportionally, Delta) functionality. REPD 
functionality lets you choose from four methods of spreading data at an aggregate level down to 
lower levels in a hierarchy. You must enter a number in a data cell at an aggregate level and 
spread that number down to lower levels by one of the following methods: 

• By Replication – A value entered into a cell at an aggregate level will be replicated (copied) 
into every cell at the aggregate cell’s base level. This results in a higher aggregate cell total 
(the value entered multiplied by the number of base-level cells). 

• Evenly – A value entered into a cell at an aggregate level will be evenly distributed among all 
cells at the aggregate cell’s base level. 

• Proportionally – A value entered into a cell at an aggregate level will be distributed 
proportionally among all cells at the aggregate cell’s base level (proportional to the original 
values in the base-level cells). 

• Delta – The difference between a value entered into a cell at an aggregate level and the 
original value of that cell will be distributed evenly among all cells at the aggregate cell’s 
base level. 

 Note: Delta spreading cannot be used for measures with a recalc aggregation type, which 
is a method of recalculation at each aggregate level. 

You must be viewing and entering data at an aggregate level for this functionality to work. Enter 
a number in a data cell at an aggregate level followed by r, e, p, or d. This will apply the 
Replicate, Even, Proportional, or Delta distribution function to spread that number to the lowest 
level.  

 Note: Save information in the workbook before trying these features. If you are 
uncomfortable with the results, use the Edit > Revert command to undo the changes. 
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Example: 

The following is an example of the spreading process. Suppose there are five cells at the lowest 
level in a hierarchy. These five cells aggregate into one cell. The five lower-level cells contain the 
values 2, 4, 6, 8, and 10. When the data is rolled up to the higher level, the aggregate total is 30.  

• Replicate – If you enter 60r to replace 30 as the aggregate cell total, the number 60 will be 
replicated to all of the cells below, which replaces the original numbers with 60, 60, 60, 60, 
and 60. In this case, the aggregate total would be recalculated as the sum of the five lower-
level cells, 300. 

• Even – If you enter 60e to replace 30 as the aggregate cell total, the number 60 will be 
divided evenly among all the cells below, which replaces the original numbers (12, 12, 12, 
12, and 12). 

• Proportional – If you enter 60p to replace 30 as the aggregate cell total, the number 60 will 
be spread proportionally across the lower level cells based on their original content. Since the 
original aggregate of the numbers was 30, entering 60 in the aggregate cell doubles that total. 
The lower level cells will contain the values 4, 8, 12, 16, and 20. 

• Delta – If you enter 60d to replace 30 as the aggregate cell total, the number 30 (the 
difference between 60 and 30) will be spread evenly across the lower level cells based on 
their original content. The lower level cells will contain the values 8, 10, 12, 14, and 16. 

Worksheet Axis 
In a worksheet, the active axis is highlighted with a distinctive border called a marker. This 
marker appears as a dotted-lined rectangle that outlines the marker position’s label text. In grid 
cells that contain read-only data, the active cell can be identified in the same way. In read-write 
cells, the active cell is the one that contains the insertion point. The following keys and key 
combinations let you change the selection by moving the marker or insertion point from one 
element to another. 

Up Arrow 

In the grid, the up arrow moves the marker up one cell. In the Row Axis and Slice Axis, the up 
arrow moves the marker up one position in the same dimension. In the Column Axis, the up 
arrow moves the marker up one dimension. 

Down Arrow 

In the grid, the down arrow moves the marker down one cell. In the Row Axis and Slice Axis, the 
down arrow moves the marker down one position in the same dimension. In the Column Axis, the 
down arrow moves the marker down one dimension. 

Right Arrow 

In the grid, the right arrow moves the marker right one cell. In the Row Axis and Slice Axis, the 
right arrow moves the marker one dimension to the right. In the Column Axis, the right arrow 
moves the marker one position to the right within the same dimension. 

Left Arrow 

In the grid, the left arrow moves the marker left one cell. In the Row Axis and Slice Axis, the left 
arrow moves the marker one dimension to the left. In the Column Axis, the left arrow moves the 
marker one position to the left within the same dimension. 
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Home 

In the grid, Home moves the marker to the beginning of the row. In the Row, Column, or Slice 
Axes; Home moves the marker to the first position of the highest dimension on that axis if you 
are in outline view. If you are in block view, Home moves the marker to the first position of the 
innermost dimension on that axis. 

End 

In the grid, End moves the marker to the end of the row. In the Row, Column, or Slice Axes; End 
moves the marker to the last position of the lowest dimension on that axis. 

Tab 

Tab moves the marker forward, visiting the various axes and proceeding across cells of the grid. 
The marker moves from the Column Axis to the Slice Axis, to the Row Axis, and then into the 
first visible cell of the grid. Continued use of the Tab key moves the marker across the row, cell 
by cell, until the end of the row is reached. 

Shift+Tab 

Shift + Tab moves the marker backward across a row in the grid, and then visits the various axes. 
The marker moves backwards across a row, cell by cell, until the first cell of the row is reached. 
Continued use of the Shift+Tab combination moves the marker to the Row Axis, to the Slice 
Axis, to the Column Axis, and back to the first visible cell of the grid. 

Ctrl+Home 

In the grid, Ctrl + Home moves the marker to the upper left corner of the grid. 

Ctrl+End 

In the grid, Ctrl + End moves the marker to the bottom right corner of the grid. 

Procedures 

Log on to Retek Predictive Solutions. 
1. From the Windows Start menu, select Programs > Retek Predictive Solutions > Retek 

Predictive Solutions. 

2.  In the Domain field of the logon box, click the arrow to display a drop-down menu, and select 
the domain that you want to access. 

3. In the Name field, type your system user name. 

4. In the Password field, type your system password. 

5. If necessary, click the Server button and perform the following: 

• In the Server Name field, type the server user name. 

• In the Server Password field, type the server password. 

6. Click OK.  
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Log off and leave the logon box 
Follow this procedure to log off the system and leave the logon box open for use by another user. 

1. From the File menu, select Logoff. 

2. If changes were made to an open workbook; select a button to save, commit, or ignore 
(discard) the changes. 

Log off without leaving the logon box 
1. From the File menu, select Exit. 

2. If changes were made to an open workbook; select a button to save, commit, or ignore 
(discard) the changes. 

Change your password 
1. From the File menu, select Change Password. 

2. In the Current Password field, type your old password. 

3. In the New Password field, type the new password. 

4. In the Verify New Password field, type the new password again. 

5. Click OK. 

Create a workbook 
1. From the File menu, select New. 

2. Click the tab containing the workbook template group for the template you wish to select. 

3.  Click on the workbook template for the workbook type you wish to build. 

4. Click OK. 

5. Follow the wizard instructions to create the workbook. 

Open a workbook 
 Note: You are only allowed to open workbooks that you have created and saved and 

those workbooks created by other users and saved with World access or Group access for 
your group. 

1. From the File menu, select Open. 

2. Select the workbook to open. 

3. Click OK. 

Close a workbook 
1. From the File menu, select Close. 

2. If changes were made to the workbook; select a button to save, commit, or ignore (discard) 
the changes. 
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Delete a workbook 
1. From the File menu, select Delete. 

2.  Select the workbook or workbooks to delete. 

 Note: Deleted workbooks are permanently removed from the system. 

3. Click OK. 

4. Click OK again to confirm the deletion. 

Save a workbook 
1.  From the File menu, select Save. 

2.  If the Save As dialog box displays, type a name for the new workbook in the Workbook 
Name field and select an access level for the workbook (User, Group, or World). Click OK. 

 Note: Saving a workbook does not commit your changes to the master database. 

Save a workbook under a new name 
1. From the File menu, select Save As. 

2. Type a new name for the workbook under Workbook Name. 

3. Select an access level for the workbook (User, Group, or World).   

4. Click OK. 

Revert to the last saved version of a workbook 
1. From the Edit menu, select Revert. 

2. Click OK. 

 Note: The Revert option is only enabled if the current workbook has already been saved 
under a specified name and if changes have been made to the data since the last save. 

Commit changes to the master database 
The Commit process merges your local database with the master database, transferring your data 
to the master so all system users have access to the same data. There are two methods you can use 
to commit data to the master: Commit Now and Commit Later. 

Commit Now merges your workbook changes with the master database immediately. However, 
when you select Commit Now, all other system users are temporarily locked out of the database 
during the commit process. Because the commit process requires that the master data file be 
overwritten, during this period no other users can build new workbooks or perform functions that 
require retrieval of data from the master file. Whenever possible, you should instead select 
Commit Later to have your changes committed as part of an overnight batch process (when 
system use is minimal). 

If changes must be committed to the master database immediately: 

1. From the File menu, select Commit Now. 

2.  Click OK. 
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To commit a workbook to the master database later: 

1. From the File menu, select Commit Later. 

2.  Click OK. 

 Note: A checkmark beside the Commit Later option on the File menu indicates that the 
workbook has been flagged to be committed during the next batch process. To remove 
the workbook from the commit queue, select the Commit Later option again. 

Change the view of your display 
There are several procedures you can perform to change the online view of your system display. 
Specifically, you can switch the view between grid mode and chart mode, show/hide various 
screen components, and invoke the zooming feature to alter the size of the grid contents. 

Change a grid to a chart 
Use this procedure to display some or all of the data from a grid in a chart view. You can display 
up to 1000 positions of data in chart view. 

To select specific data to appear in chart form, highlight all cells that you want to see displayed. 

-OR- 

To display all of the grid’s data on a chart, do not select any data. 

From the View menu, select Chart; or select the  button on the toolbar. 

 Note: Many users use chart view (especially line charts) to easily identify trends and 
changes in data over periods of time. When you use a chart for this purpose, position the 
Calendar hierarchy tile along the column axis, and position the Measure hierarchy tile 
along the row axis. This will extend the time dimension along the x-axis and extend the 
measure of interest (such as Total Sales or Forecasted Demand) along the y-axis. You can 
position the Product and Location hierarchy tiles wherever you wish, such as along the 
slice-axis (z-axis) or alongside the Measure tile (row, or y-axis). 

Change a chart to a grid 
From the View menu, select Grid.  

-OR- 

Select the  button on the toolbar. 

Enlarge the screen 
1. From the View menu, select Full Screen. The screen is enlarged by hiding the Windows 

status bar and system title bar. 

2. Select this option again to return the screen to its original size. 
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Show/hide button text in the application toolbar 
Follow this procedure to turn on/off the display of toolbar button names in the application toolbar. 

1.  From the Format menu, select Application. 

2.  Under Application Options, select the Show Button Text check box to display button names 
on the application toolbar. Clear this check box to turn off the display of button titles. 

3.  To apply the change to the worksheet without closing the dialog box, click Apply. To accept 
the change and close the Format Options dialog, click OK. 

Show/hide status bar 
1. From the View menu, select Status Bar. 

2. Select Status Bar again to redisplay it. 

Show/hide toolbar 
1. From the View menu, select Toolbar. 

2. Select Toolbar again to redisplay it. 

Use the Zoom feature 
You can enlarge the contents of the active window for easier viewing, or you can reduce the size 
of the contents in order to fit as much data on the screen as possible. Use the Zoom function to 
perform either of these tasks. 

 Note: The Zoom feature is only available in grid (and not chart) mode. The grid view 
zoom level only affects the display of data on your computer terminal. Zooming does not 
affect the scaling value set in Page Setup and has no effect on printing. 

1. Click in a worksheet window to make it active. 

2. From the View menu, select Zoom. The Zoom dialog box displays. 

3. Click the radio button that corresponds to the level of magnification you want. Alternatively, 
you may specify any magnification value between 10 and 400 by entering your choice in the 
Custom field. 

4. Click OK to close the dialog and return to the resized worksheet. 

 Note: The Zoom feature only affects the working area of the grid (column, row, and slice 
headers). The size of the worksheet window and the worksheet components (for instance, 
title bar, scroll bars, hierarchy tiles) remains unchanged.  

A different zoom level can be specified for each worksheet in a workbook. When a workbook is 
closed, the zoom level for each worksheet is saved. When the workbook is opened again, each 
worksheet is initialized to its last saved zoom level. 
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Select and manipulate cells in a grid 
Cells or groups of cells must be selected in the grid before certain operations can be performed on 
them. Typically, operations such as cutting and copying data, filling or clearing data cells, 
displaying data in chart form, etc. are performed on a subset of worksheet cells that you must 
select prior to invoking the menu command. 

There are several ways to select cells in the grid. In general, you should make your selections in 
the worksheet axes (where the column and row headers appear), and not in the cells themselves. 

Select a single cell 

Click the corresponding position in each relevant axis. In other words, click the column header 
that corresponds to the cell, then click the corresponding row label. 

Select all cells in a row 

Click on the row header for that group of cells. 

Select all cells in a column 

Click on the column header for that group of cells. 

Select a group of continuous cells in the same row 

1.  Click on the row header that corresponds to that group of cells. 

2.  Click on the column header for the first item in the group. 

3. Hold down the Shift key and click on the column header corresponding to the last item in the 
group. 

Select a group of continuous cells in the same column 

1.  Click on the column header that corresponds to that group of cells. 

2.  Click on the row header for the first item in the group. 

3.  Hold down the Shift key and click on the row header corresponding to the last item in the 
group. 

Select a group of non-continuous cells 

1. Click on the column header that corresponds to the first item in the group. 

2.  Hold the Ctrl key and click on each column header that corresponds to a group item. 

3.  Click on the row header that corresponds to the first item in the group. 

4.  Hold the Ctrl key and click on each row header that corresponds to a group item. 
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Select a block of contiguous cells 

This method allows you to make your selection within the grid itself. 

1.  Click in the top-most, left-most cell in the block you wish to select. 

2.  Hold down the mouse button and drag the cursor to the bottom-most, right-most cell in the 
block you wish to select. As you drag the mouse, note that the column header and row header 
positions are automatically selected according to your actions. 

3.  Release the mouse button. 

4.  Click the row or column header to mark or unmark the last axis position selected 

5.  Press the spacebar to toggle the last axis position selection on and off. 

Change a cell's size 

1.  Place the cursor on the cell border. The appearance of the cursor changes to either double 
vertical lines or double horizontal lines.  

2.  Click the left mouse button and drag the borderline until the cell size is the desired width (or 
height). 

Change a cell's size 

1. Place the cursor on the cell border. The appearance of the cursor changes to double vertical 
lines or double horizontal lines. 

2. Click the left mouse button, and drag the borderline until the cell size is the desired height or 
width. 

Enter or change values in a cell 

Following are descriptions of actions you can take to change individual values in a grid.  

Numbers 

Enter or overwrite a numeric value. 

Alphanumeric values or plain text 

Enter or overwrite an alphanumeric value. 

Drop-down list items 

Select the desired option from the drop-down list (click on the arrow button and select an item 
from the drop-down list). 

Date items 

Select the desired date. Click on the arrow button to display the calendar, and change the year, 
month, or date by clicking on the appropriate arrow keys. 

Check box (toggle) items 

Change the status of the item (yes or no, on or off) by clicking on the check box. 
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Math operations 

To increment the value in a cell using a mathematical formula, key in the following: 

• To add, type ‘+ [desired value to add]’ 

• To subtract, type ‘+- [desired value to subtract]’ 

• To multiply, type ‘* [desired value to multiply by]’ 

• To divide, type ‘/ [desired value to divide by]’ 

• To apply a percentage, type ‘* [desired percentage increment]’ (For example, to increase a 
value by one-half, enter * 1.5.) 

Modify data with cell formulas 

Cell formulas allow you to modify the value of a data cell in the grid by applying an operator (+, -
, *, or /) to that value. With this functionality, you can make changes to data values without 
having to calculate the result manually. To perform this function, click in the data cell and type 
the operator you want to add, subtract, multiply by, or divide by. 

For example, suppose that a particular data cell contains the value 10. 

• Add – If you enter +10 in the cell, the value becomes 20. 

• Subtract – If you enter +-10 in the cell, the value becomes 0. 

• Multiply – If you enter *10 in the cell, the value becomes 100. 

• Divide – If you enter /10 in the cell, the value becomes 1. 

• Percentages – If you want to increase the value of a cell by 10%, then multiply the value by 
1.1 (enter *1.1). 

There are many applications of cell formulas in modifying data. Cell formulas can only be 
applied to one cell at a time, but changes made to aggregate level cells will be spread down to 
lower-level cells along hierarchy lines. Similarly, any changes made to lower level cells will be 
reflected in the aggregates of that data. 

Enter measure data using a scaling factor 
The scaling factor feature allows you to enter measure data that will be scaled or factored to an 
internal value that is recognized by the server in data calculations. When you enter a value for a 
measure that has a scaling factor, the value you enter will be multiplied by the scaling factor to 
arrive at this internal value. Both the display of the data and the ease of data entry can be greatly 
enhanced by use of a scaling factor. 

For example, suppose that you want to enter data in thousands of units. You might find it tedious 
to enter 1000, then 2000, then 6000, and so on. A more sensible approach would be to enter the 
values 1, 2, and 6, and have the system apply a scaling factor (in this case 1000) to the entered 
data. The internal values of the three affected cells would be 1000, 2000, and 6000, and these 
internal values would be used in required data calculations. Removing the zeros from the display 
would result in a cleaner, less cumbersome worksheet appearance. 
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The scaling factor feature is designed to be used in conjunction with the prefix/suffix feature for 
formatted measures. In the case above, you would probably want to specify a suffix (for example, 
k) for this measure to indicate that the entered data has, in fact, been scaled. The displayed data 
would thus appear as 1k, 2k, and 6k. Even though your worksheet has been "cleaned up" by 
abbreviating the numeric display, the system still understands that the internal values of the edited 
cells are 1000, 2000, and 6000, respectively. 

Specify a scaling factor for a measure 

To specify a measure’s scaling factor, perform the following steps: 

1.  From the Format menu, select the Types option. 

2.  In the Measure listbox, click on the measure that you wish to edit. 

3.  In the Display Options portion of the dialog, enter a scaling factor in the Scale Factor field.  

 Note: The scaling factor must be a non-zero integer for integer-type measures, but may 
be any non-zero value for float-type measures.  

4.  If you want, enter a prefix and/or suffix to be applied to the measure data. Ideally, the 
prefix/suffix should designate the nature of the scaling factor associated with this measure. 
For example, if your scaling factor is 1,000,000, you may wish to enter the suffix ‘m’. 

5.  Click the Apply button to apply your changes to the measure and leave the Format Options 
dialog open, or click OK to process the changes and close the dialog. 

Cut the contents (data) of worksheet cells 
Use this procedure to copy selected data to the application clipboard and to clear that data from 
the worksheet cells. Only data from writable measures can be cut. This procedure cuts data at the 
current hierarchical level, which is the lowest level that data is selected in the grid. 

1. Select all data cells in the grid that you want to cut. If you do not select any data cells before 
using the Cut command; in the next step, the system will present a dialog that states that there 
are not any positions selected for the operation. If you select specific data cells, only the data 
for those cells will be cut. 

2. From the Edit menu; select Cut, or click the Cut button on the application toolbar. 

Copy the data in worksheet cells 
Use this procedure to copy selected data to the application clipboard. Unlike the Cut function, the 
Copy function does not clear the data from the worksheet cells. This procedure copies data at the 
current hierarchical level, which is the lowest level that data is selected in the grid. 

1. Select all data cells in the grid that you want to copy. If you do not select any data cells 
before using the Copy command; in the next step, the system will present a dialog that states 
there are not any positions selected for the operation. If you select specific data cells, only the 
data for those cells will be copied. 

2. From the Edit menu; select Copy, or click the Copy button on the application toolbar. 
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Cut, copy, and paste base-level data 
You can cut, copy, and paste data at the base level in your worksheet while viewing it at any 
aggregate level. Cutting, copying, and pasting in this manner allows you to more quickly effect 
base level changes by manipulating data at an aggregate level. 

You choose whether or not to perform operations on base level data by manipulating the 
appropriate check box that appears on the Cut Special, Copy Special, and Paste Special dialog 
boxes. 

Cut base-level data 
The cut data at base level feature allows you to view data at an aggregate level in your worksheet 
while cutting that same data at its base dimensional level, which is not currently displayed. 

When you select the Cut Special function at an aggregate level and you select the Cut Data at 
Base Level check box (on the Cut Special dialog), all base level data applicable to your selected 
aggregate data will be cut and copied to the application clipboard. Although the Cut function is 
actually performed at the base dimensional level, it seems that the aggregate level data has been 
cut (due to the process of data roll-up). 

To use the cut data at base level functionality, the base dimensional level for a given hierarchy 
cannot be displayed in your worksheet, if in block view. 

1.  Select the aggregate level data to be cut. Only data from writable measures can be cut. 

 Note: If your grid data contains any measures that are read-only, the system will be 
unable to cut data for the entire worksheet. In this case, a message will inform you that 
the cut request could not be completed. 

2.  From the Edit menu, select Cut Special.  

3.  Select the Cut Data at Base Level check box. Selecting the base level cut option causes all 
base level data applicable to your aggregate selection to be cut and copied to the application 
clipboard. 

4.  Click OK. 

Copy base-level data 
The copy data at base level feature allows you to view data at an aggregate level in your 
worksheet while copying that same data at its base dimensional level, which is not currently 
displayed. 

When you select the Copy Special function at an aggregate level and you check the Copy Data at 
Base Level checkbox (on the Copy Special dialog), all base level data that is applicable to your 
selected aggregate data will be copied to the clipboard. Unlike the Cut Special function, Copy 
Special does not clear the data from the copied cells. Although the Copy Special function is 
actually performed at the base dimensional level; after pasting, it seems that the aggregate level 
data has been copied. This is due to the process of data roll-up. 
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To use the copy data at base level functionality, the base dimensional level for a given hierarchy 
cannot be displayed in your worksheet.   

1. Select the aggregate level data to be copied. 

 Note: If no data cells are selected in the grid at the time the Copy Special dialog is 
opened, the system will present a dialog that states there are not any positions selected for 
the operation. 

2. From the Edit menu, select Copy Special. 

3. Check the Copy Data at Base Level checkbox. Selecting the base level copy option causes all 
base level data applicable to your aggregate selection to be copied to the application 
clipboard. 

4. Click OK. 

Paste base-level data 
The paste data at base level feature allows you to view data at an aggregate level in your 
worksheet while pasting data into measures at the base dimensional level, which is not currently 
displayed. 

The Paste Special menu item is only enabled after you have placed information on the application 
clipboard using either the Cut, Cut Special, Copy, or Copy Special command. When you select 
the Paste Special function at an aggregate level and you select the Paste Data at Base Level 
checkbox (on the Paste Special dialog), data will be pasted into the base level cells associated 
with your aggregate level paste selection.  

To use the paste data at base level functionality, the base dimensional level for a given hierarchy 
cannot be displayed in your worksheet. To paste data at base level, ensure that you are viewing 
values at an aggregate level only and perform the following steps: 

1.  Select the aggregate level cells into which you want to paste the cut/copied data. Only those 
cells will be overwritten with pasted data. You can only paste data into writable measures. 

2.  From the Edit menu, select Paste Special.  

3.  Ensure that the Paste Data at Base Level checkbox is selected. Whenever data has just been 
cut or copied at base level, the Paste Data at Base Level checkbox defaults to selected. 

4.  Click OK. 
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Cut, copy, and paste multiple slices 
When you make cell selections prior to cutting/copying/pasting data, the system only allows for 
the selection of the currently displayed position along the slice axis. The Cut Special, Copy 
Special, and Paste Special dialogs allow you to specify that data should be manipulated for all 
positions (pages) in this axis. 

Cut data from all slices 

Use this procedure to cut data from all pages in the slice axis simultaneously. 

1.  Select the data cells to be cut. 

2.  From the Edit menu, select Cut Special. 

3.  On the Cut Special dialog, check the Cut All Slices checkbox. When the box is checked, the 
cut operation behaves as if all positions in the slice dimension were selected prior to the cut. 
If the box is left unchecked, only data from the currently displayed slice position will be cut. 

4.  Click OK. 

Copy data from all slices 

Use this procedure to copy data from all pages in the slice axis simultaneously. 

1.  Select the data cells to be copied. 

2.  From the Edit menu, select Copy Special. 

3.  On the Copy Special dialog, check the Copy All Slices checkbox. When the box is checked, 
the copy operation behaves as if all positions in the slice dimension were selected prior to the 
copy. If the box is left unchecked, only data from the currently displayed slice position will 
be copied. 

4  Click OK. 

Paste data into all slices 

Use this procedure to simultaneously paste data into all pages in the slice axis. 

1. Select the cells where you want to paste the cut/copied data. Only those cells will be 
overwritten with pasted data. You can only paste data into writable measures. 

2. From the Edit menu, select Paste Special.   

3. On the Paste Special dialog, check the Paste All Slices checkbox. When the box is checked, 
the paste operation behaves as if all positions in the slice dimension were selected prior to the 
paste. If the box is unchecked, data will only be pasted into the currently displayed slice 
position. 

 Note: If you did not choose to cut/copy data from all slices prior to this paste, and then 
you choose to paste clipboard data to all slices, the data that was cut/copied from the 
single visible slice will be replicated to all slices in the worksheet. 

4. Click OK. 
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Copy data to and paste data from the Windows clipboard 
The Cut, Cut Special, Copy, and Copy Special commands do not copy information to the 
Windows clipboard. When you use these functions, data is copied to an application-specific 
clipboard and cannot be pasted into other applications. If you intend to paste worksheet data into 
another application, or if you want to paste data from another application into your worksheet, 
you must use the following procedures. 

Copy data to the Windows clipboard 

Use this procedure if you want to copy worksheet data so that it can be used in another 
application. 

1.  Select the data cells whose contents are to be copied. 

2.  From the Edit menu, select Copy to Clipboard. 

 Note: When using this command, the maximum number of cells that can be copied is 
limited by memory. This operation should not be used to export entire workbooks. 

Paste data from the Windows clipboard into a worksheet 

Use this procedure if you want to paste data from the Windows clipboard into your worksheet. 
Data can only be pasted into writable measures. 

1. Select the data cells where you want to paste the clipboard data into. 

2. From the Edit menu, select Paste from Clipboard. 

 Note: When using this command, the maximum number of cells that can be pasted is 
limited by memory. This operation should NOT be used to import data for entire 
workbooks. 

Clear and fill cells in a worksheet 
Use the following procedures to clear data from worksheet cells, and to quickly populate the cells 
of a worksheet.  

Clear data from cells 

1. Select the data cells that you want to clear.   

 Note: If you do not select any data cells before you choose Clear Contents; in the next 
step, the system will clear the data cells for every writable measure in the currently-
displayed slice. If you select certain cells; however, only those cells will be cleared. 

2. From the Edit menu, select Clear Contents. 

 Note: You can only clear contents from one dimensional level at a time. If you are 
viewing data in Outline mode, the Clear Contents dialog will require you to specify the 
dimension that you want cleared. 

3. Click OK. 
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Fill (populate) the cells of a worksheet 

Use this procedure to quickly populate cells in a worksheet with a single value. This command 
fills cells in only one measure at a time. 

1.  Select the cells in the grid to be filled. If you select no data cells before using the Fill 
command (in the next step), the system will fill the cells for an entire measure. If you select 
certain data cells, only those selected cells will be filled. 

2. From the Edit menu, select Fill. 

3.  Select the measure to be filled from the Measure drop-down list. 

4.  Specify a fill value in the Fill Value field. 

5.  If you are filling data at a level other than base level, select a Spread Method (Replicate, 
Even, Proportional, or Delta). 

6.  If you are viewing data in Outline mode, the bottom portion of the Fill dialog requires you to 
specify the dimensional level at which to fill data. The system can only fill data for cells in 
one dimension at a time. 

7.  Click OK. 

Locate items in the worksheet 
Use the following procedures to quickly find items in a worksheet. You can find specific 
positions along a particular grid axis, and you can locate the next/previous instance of an 
identified alert within an alert measure. 

Find a position in a grid axis 

1. From the Edit menu, select Find. 

2. Under Find What, type all or part of the name of the node or position (for example; product, 
location, measure) that you want to find. 

3. Click the Look In arrow and select an axis (Row, Column, or Slice) to search. 

4. If you want, select the Match Case or Find Exact Match Only options to narrow your search. 

5. Click Find Next. 

To find the previous identified alert instance: 

From the View menu, select Find Previous Alert. 

To find the next identified alert instance: 

From the View menu, select Find Next Alert. 

Rotate or pivot an axis on a grid 
Rotating or pivoting an axis (such as product, time, or location) on a grid allows you to display 
data in different orientations. 
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To rotate a hierarchy to another axis 

1.  Left-click on and hold the hierarchy tile that represents the hierarchy you want to move. 

2.  Drag the hierarchy tile to the desired display axis. 

3.  Observe the appearance of the cursor as you move the tile. When the cursor is over an 
available dropping point (display area), its appearance will change. 

4.  To drop the tile in its new display area, release the mouse button. 

To pivot along the same axis 

1.  Left-click on and hold the hierarchy tile that represents the hierarchy you want to move. 

2.  Drag the hierarchy tile to the desired new position along the axis.  

3.  Observe the appearance of the cursor as you move the tile. When the cursor is over an 
available dropping point (display area), its appearance will change. 

4.  To drop the tile in its new display area, release the mouse button.  

To rotate a hierarchy to another axis 

1. Left-click and hold the hierarchy tile that represents the hierarchy you want to move. 

2. Drag the hierarchy tile to the desired display axis. 

3. Observe the appearance of the cursor as you move the tile. The cursor’s appearance will 
change when it is over an available dropping point (display area). 

4. Release the mouse button to drop the tile in its new display area. 
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Show and hide positions in the grid display 
Once a workbook has been createdand it contains the products, time periods, measures, and so on 
that were selected in the workbook wizard, you have the ability to hide from view any positions 
(nodes) that were initially incorporated during the workbook build. The position hiding feature 
allows you to remove undesired information from the grid display without requiring you to 
rebuild the workbook to attain the view you want. 

 Note: When you select individual positions to hide from view, any data associated with 
those hidden nodes will still be reflected in any aggregate totals.  

Hide positions using the quick menu 

To easily hide positions using the quick menu, perform the following steps: 

1.  Select an undesired node by clicking on it within the axis display. 

 Note: Multiple positions can be selected together by using <Ctrl+Click>. 

2.  Right-click the mouse within that same axis area to produce the associated quick menu. 

3.  Choose Hide Selection. 

Hide positions using the Show/Hide dialog 

One method of hiding positions in the grid display is to access the Show/Hide dialog, which is 
actually the Show/Hide tab of the Tree Options dialog. This method is useful if you have a large 
number of nodes to hide at the same time. The Show/Hide dialog also provides the means to 
return already hidden nodes to the grid display. 

 Note: The following procedure is used to show positions in hierarchies other than the 
Measure hierarchy. 

1. Right-click in a dimension’s axis area to display the quick menu relevant to that hierarchy. 

2. Select Show/Hide. When the dialog displays, all currently hidden nodes are displayed on the 
left side of the dialog, and all currently visible nodes are displayed on the right side. 

3. Click a node on the right side of the dialog to select it. Use <Ctrl+Click> to select multiple 
nodes together. 

4. Click the left arrow button to move your selection(s) to the Hidden Nodes side of the dialog. 

5. Click OK. 

When you return to the workbook, the grid display reflects the selections made on the Show/Hide 
tab. 

 Note: Any data associated with the hidden position(s) will still be reflected in any 
aggregate totals. 
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Redisplay currently hidden positions 

The Show/Hide dialog provides the means to make any hidden positions visible in the grid 
display. Perform the steps below to redisplay hidden positions in the grid. 

 Note: The following procedure is used to show positions in hierarchies other than the 
Measure hierarchy. 

1. Right-click in a dimension’s axis area to display the quick menu relevant to that hierarchy. 

2. Select Show/Hide. When the dialog displays, all currently hidden nodes are displayed on the 
left side of the screen and all currently visible nodes are displayed on the right side. 

3. Click a node on the left side of the screen to select it. Use <Ctrl+Click> to select multiple 
nodes together. 

4. Click the right arrow button to move your selection(s) to the Visible Nodes side. 

5. Click OK. 

When you return to the workbook, the grid display reflects the selections made on the Show/Hide 
tab. 

Show and hide positions in the Measure hierarchy 
Measure positions can be hidden from view in the same way as positions in other hierarchies. 
However, the Show/Hide dialog for measures appears much different. The Show/Hide Measures 
dialog has been designed to streamline the selection of measures, taking into account the 
attributes that comprise each measure’s definition. 

 Hide currently visible measures from view 

To use the Show/Hide Measures dialog to hide a visible measure from grid view, perform the 
following steps: 

1.  On a worksheet, right-click in the measure axis to produce the associated quick menu. 

2.  Select Show/Hide. 

3.  In the Visible Measures portion of the dialog (upper right), click on a measure that you want 
to hide. You may select multiple measures from this list by using <Ctrl+Click>. 

4.  Click the left arrow button. The selected measures are removed from the Visible Measures 
window. 

5.  Click OK. 
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Show hidden measures in the grid display 

To use the Show/Hide Measures dialog to return a hidden measure to the grid display, perform 
the steps below. 

 Note: For most selections made in the following steps, multiple selections can be made 
by using <Ctrl+Click>. 

1.  On a worksheet, right-click in the measure axis to produce the associated quick menu. 

2.  Select Show/Hide. 

3.  In the Hidden Measures portion of the dialog, select the measures you want to hide. 

4.  Click the right arrow button to add the measure to the Visible Measures list. 

5.  Click OK. 

Specify the display order of measures in the grid 
You can use the Show/Hide Measures dialog to specify or change the order in which measures 
are displayed in the grid. To do this, perform the following steps: 

1.  On a worksheet, right-click in the measure axis to produce the associated quick menu. 

2.  Select Show/Hide. 

3.  Click on a measure in the Visible Measures listbox. 

4.  Click the up arrow or down arrow to move the selected measure up or down in the list 
display. 

5.  Repeat these steps for measures as required until the desired display order is attained. 

6.  Click OK. 

Create a measure profile 
1. On a worksheet, right-click in the measure axis to produce the associated quick menu. 

2. Select Show/Hide. 

3. Select all of the measures that you want to include in the measure profile, and ensure that all 
desired measures appear in the Visible Measures window. In the Measure Profiles text field, 
type a name for the profile. 

4. Click the Add Profile button to save the list. 

5. Click OK. 

Edit/update a measure profile 
1. On a worksheet, right-click in the measure axis to produce the associated quick menu. 

2. Select Show/Hide. 

3. Select the measure profile that is to be updated. 

4. Add or remove measures that you want to include in the measure profile, and ensure that all 
desired measures appear in the Visible Measures window. In the Measure Profiles text field, 
type the same name for the profile that is to be updated. 

5. Click OK. 
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Apply a saved measure profile to a worksheet 
1. On a worksheet, right-click in the measure axis to produce the associated quick menu. 

2. Select Show/Hide. 

3. In the Measure Profiles section of the dialog, select the profile that you want to load from the 
drop-down list. That profile’s measures are displayed in the Visible Measures portion of the 
dialog. 

4. Click OK. 

Delete a measure profile 
1. Right-click in the measure axis to produce the associated quick menu. 

2. Select Show/Hide. 

3. In the Measure Profiles section of the dialog, select the profile you want to delete from the 
drop-down list. 

4. Click the Delete Profile button. 

5. Click OK to return to the workbook. 

Select a higher hierarchy level for data roll-up 
1.  Right-click on the desired grid axis. 

2.  Select (left-click) Select Rollup and select the highest dimension to display.  

Aggregate data using a dimension list 
The Dimension List option allows you to collapse/expand the display of one dimension at a time. 
When a worksheet dimension is collapsed from the grid display, all of that dimension’s 
associated data is aggregated to the next higher level currently displayed. 

To aggregate data using the Dimension List option: 

1. Right-click on any worksheet axis to display a quick menu of options relevant to that 
hierarchy. Note that dimensions currently displayed in the worksheet are shown in the 
dimension list with checkmarks beside them. 

 Note: If you wish to aggregate data to a dimension higher than those shown in the 
dimension list, first use the Select Rollup option to specify the highest dimension you 
want to see. 

2.  Click on any currently checked dimension to collapse that hierarchical level. All associated 
data will be aggregated to the next higher dimension displayed. 

 Note: Clicking on any unchecked dimension in the list will cause the reverse process to 
happen. That previously collapsed dimension will now be displayed in the grid in its 
proper relative location in the hierarchy. 
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Aggregate data using the Select Dimensions menu option 
The Select Dimensions option allows you to collapse/expand the display of multiple dimensions 
at one time. Select this option to display a dialog box in which you can select exactly which 
dimensions you would like displayed in your worksheet. 

To aggregate data using the Select Dimensions option: 

1.  Right-click on any worksheet axis to display a quick menu of options relevant to that 
hierarchy. 

2.  Click the Select Dimensions option.  

3.  On the dialog that opens, select all dimensions that you want to display in your worksheet. 
Highlighted dimensions will be displayed; non-highlighted dimensions will be collapsed and 
data aggregated to the next higher level. 

 Note: If you wish to select a dimension higher than those shown in the dimension list, 
first use the Select Rollup option to specify the highest dimension you want to see. 

4.  Click OK. 

Aggregate data using the dimension labels 
The Show Dimension Labels option is useful when you plan to collapse or expand dimensions 
repeatedly, and you want to avoid accessing the quick menu each time you do it. This option 
toggles on the display of cursor-sensitive dimension header labels in your worksheet. When you 
click on the label for a particular dimension, that dimension is collapsed in the grid and all 
associated data is aggregated to the next higher level. Once the dimension header labels are 
activated, dimensions can be collapsed or expanded with one single click. 

To aggregate data using the Show Dimension Labels option: 

1. Right-click on any worksheet axis to display a quick menu of options that are relevant to that 
hierarchy. 

2. Select the Show Dimension Labels option. Minimized tabs are displayed at the left side of the 
column axis headings or at the top of the row axis headings depending on your axis selection. 

3. Place the cursor over these tabs. The tabs expand to display the dimension labels. 

4. Click any dimension label to collapse that dimension in the grid and aggregate the data to the 
next higher level. 

 Note: Labels representing collapsed dimensions contain only a plus (+) sign. Click on the 
plus sign to maximize the label and expand that dimension in the grid. 

Spread aggregate data from an individual cell 
Use this procedure to spread aggregate data from one cell into each of that cell’s lower level 
constituents.  

1.  Click inside an aggregate-level cell to edit. Spreading functionality is ineffective for base-
level data. 

2.  Type a numeric value into the cell, followed by an r (replicate), e (even), p (proportional) or d 
(delta). The values will be spread to the lowest level, using your REP choice. For a 
description of the REP spreading methods, see the Spreading overview topic. 



Retek Predictive Application Server 
 

102 

Spread aggregate data from many cells 
Use this procedure to spread aggregate data into many cells at once. 

1.  Select an aggregate-level cell or a group of aggregate-level cells that you want to contain the 
same value. Spreading functionality is ineffective for base-level data. 

2.  From the Edit menu, select Fill. 

3.  Click on the arrow below Measure and select the measure that you want to fill. If you 
selected cells in the grid before selecting Fill, only the selected cells will be filled. If you 
selected no cells, all cells for the measure selected will be filled. 

4.  In the Fill Value field, type a fill value. If the measure type is numeric, make sure the value 
entered is numeric and go to step 5. If the measure type is non-numeric (can contain only 
values from a list), select the desired value from the drop-down list and go to step 6. 

 Note: If you are viewing data in Outline mode when you select the Fill command, the 
system will require you to specify the aggregate level at which you want to fill data. If the 
dimension you select is not an aggregate level, the Spread Method functions on the Fill 
dialog box will be disabled.  

5.  Select Spread Method (Replicate, Even, Proportional, or Delta). For a description of the 
spreading methods, see the Spreading overview topic. 

6.  Click OK. 

Display attributes and sort dimensions using attributes 
You can choose which of a dimension’s attributes to display in worksheets, and you can select the 
order in which a dimension’s attributes are applied to the dimension during the process of sorting. 

An attribute is simply a piece of information that further describes a position in a given 
dimension. For example, the SKU dimension of the product hierarchy could have three attributes 
associated with it: LABEL, COLOR, and PRICE. One SKU in this product hierarchy could thus 
have attribute values of ‘SKU00012: Cashmere Sweater’ for LABEL, ‘Pale Blue’ for COLOR, 
and ‘$62’ for PRICE. 

Positions in a dimension can be described with any number of attributes. LABEL is the only 
required attribute. Once established, attributes can be displayed in the grid if desired. 
Additionally, you can use a dimension’s attributes to sort positions within that dimension. For 
example, you can specify that SKUs in your product hierarchy should be sorted in ascending 
order according to their PRICE attribute. 
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Display attributes in a worksheet 
You can select any of a dimension’s attributes to be displayed in a worksheet, and you can 
display more than one attribute at a time in any specified order. Whenever multiple attributes are 
shown for a given dimension, they are separated in the axis display by dotted lines. 

1. Right-click on the worksheet axis representing the dimension for which you want to display 
attributes. 

2. On the quick menu, choose Select Display and Sort Attributes. The Attributes to Display 
section of the resulting dialog contains all available display attributes for the associated 
dimension. They will either be used (right side) or unused (left side). 

3. Click on a display attribute to highlight it, and use the left or right arrow buttons to move the 
attribute to the desired side of the dialog. Repeat this step until all attributes that you want 
displayed in the worksheet appear in the Display Attributes list. 

4. The Display Attributes list is a dragging list box. Attributes will be displayed in your 
worksheet in the order that they appear in this list. To reorder elements on the list, click on 
and hold an item. Then drag the attribute upwards until its indicator is displayed in the 
desired location. 

5. Release the mouse button. Attributes in the Display Attributes list box are reordered 
according to your actions. 

6. Click OK to return to the worksheet. 

Use attributes to sort a dimension's positions 
You can sort the positions in a dimension using any of the dimension’s attributes. You specify 
which attributes are to be used for sorting and the order that the chosen attributes are to be applied 
to the dimension during the sorting process. For example, you can sort SKUs in the product 
hierarchy primarily by PRICE, and then within those prices by LABEL. 

Selection of sort order is independent of the attribute display, so an attribute does not have to be 
displayed in the worksheet for it to be used for sorting. 

1. Right-click on the worksheet axis that represents the dimension that you want to sort using 
attributes. 

2. On the quick menu, choose Select Display and Sort Attributes. The Attributes to Sort By 
section of the resulting dialog contains all of the available sort attributes for the associated 
dimension. They will either be used (right side) or unused (left side). 

3. Click on a sort attribute to highlight it, and then use the left or right arrow buttons to move 
the attribute to the desired side of the dialog. Repeat this step until all attributes that you want 
to use for sorting appear in the Sort Attributes list. 

4. The Sort Attributes list is a dragging list box. During the sorting process, attributes will be 
applied to the dimension’s positions in the order that they appear in this list. To reorder 
elements on the list; click and hold an item, and drag the attribute upwards until its indicator 
is displayed in the desired location. 

5. Release the mouse button. Attributes in the Sort Attributes list box are reordered according to 
your actions. 

6. Click OK to return to the worksheet. 
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Sorting positions in multiple windows 
The selections for sort attributes for a single dimension may differ from worksheet window to 
worksheet window. This feature is useful when different views (provided by different sorts) of 
the data are desired at the same time. You can use the New Window command on the Window 
menu to create a copy of the current worksheet. Each copy of the worksheet is represented by a 
different window and can contain data that is sorted using a different sort method. 

• Display measure attributes and unhide related measures 

• For any hierarchy, attributes can be displayed and used to sort positions in the ways that are 
outlined in the topics on displaying attributes and sorting positions. Measure hierarchy 
attributes require a closer look because of their unique characteristics. 

• In any hierarchy, customers define (at implementation) the particular attributes to be 
associated with the various dimensions represented by their data. For example, in the Product 
hierarchy, a customer may define product attributes; such as PRICE, COLOR, and 
VENDOR, but the only required attribute for any hierarchy is LABEL. 

• The Measure hierarchy is different from the others since it contains five fixed, pre-defined 
attributes: 

• Label – The Label is the name of the measure as it appears on application worksheets (for 
instance, Sales Value, Projected Receipts). 

• Aggregation Method – Aggregation Method is the way that data for this measure is 
aggregated to higher levels (for instance, Total, Period End Average, Pop Count). The 
Aggregation Method determines how the system populates aggregate level cells, which are 
based on the component values of base-level cells. 

• Default Value – The Default Value specifies how the system should populate the cells of a 
measure when no explicit value for the cell has been entered or loaded (for instance, NA, 0). 
The default value for a measure can be any value that is valid based on a measure’s type. For 
example, a specific date can be set as the default for date-type measures — 0 can be set as the 
default for integer-type measures; a specific pick list value can be set as the default for type-
type measures. 

• Percent of Parent – Percent of Parent is an attribute that can take on one of two values — 
None or Parent. A measure with a percent-of-parent attribute value of ‘None’ displays the 
actual numeric data values for the measure in question (such as Sales Value). That same 
metric (Sales Value) with a percent-of-parent attribute value of ‘Parent’ displays for each 
position the percentage of the total that the position represents relative to the next visible 
dimensional level, or parent, in the grid. 

• Units of Measure – The units in which a measure’s values are displayed (for instance, Units, 
$ Value, Checkbox, Date). 



Chapter 5 – Changing views of data in worksheets 
 

105 

Attribute value combinations and related measures 
Any given metric may be associated with many different combinations of measure attribute 
values, which results in a large number of related measures. When you open a new workbook 
(generally only one attribute set), the default set for a given metric is displayed in the workbook. 
Other measures exist that are composed of the same metric (i.e. Sales) combined with different 
sets of attribute values. These other measures are available for display in the workbook, but they 
must be unhidden by using the Show/Hide dialog. 

For example, suppose that your workbook contains the default Sales measure — Aggregation 
Type = Total, Units of Measure = $Value, Default Value = 0, and Percent of Parent = None. You 
would like to view a related sales measure that is composed of all the same attribute values except 
one — You want to see the number of units sold rather than the $ value of those sales. You must 
choose to display the related sales measure, such that Units of Measure = Units. This related sales 
measure is available for view, but you must access the Show/Hide dialog to unhide it. 

Display measures with different attribute value combinations 
Before you begin displaying related measures that are hidden, it is a good idea to ensure that 
relevant measure attributes are actively displayed in your worksheet. This will help you 
differentiate between two related measures whose labels may appear identical. For example, if 
you want to display two variations of the Sales Value measure, one with percent-of-parent = 
‘None’ and the other with percent-of-parent = ‘Parent,” you should turn on the display of the 
Percent of Parent attribute to differentiate the two measures. 

Sort measures using the User Specified Sort Order function 
When sorting and displaying measures, the User-Specified Sort Order can be used to dictate an 
exact order that measure positions should be displayed in the grid. The User Specified Sort Order 
allows you to rearrange measures so that they display in a completely arbitrary order that you 
determine. This method allows you to select more specific sort orders that cannot be attained by 
ordering the sort attributes in the Sort Attributes list box. 

You can still sort positions in the Measure hierarchy according to any of that hierarchy’s 
attributes. This way, the Measure hierarchy is no different from any other hierarchy represented 
by your data. For instance, you can specify that all measures should be sorted in the worksheet 
according to aggregation method. In this case, all measures with an aggregation method of 
‘Period End Total’ would be grouped together and displayed before measures with an aggregation 
method of ‘Recalculated,’ which would appear before measures with a ‘Total’ aggregation 
method. The system sorts measure positions alphanumerically based on the values assigned to the 
sort attribute in question. 

It is more likely that you will want to specify a particular measure ordering scheme that cannot be 
attained by sorting the positions based on attributes. The User Specified Sort Order feature is 
designed to help you attain this specialized view. 
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When the User Specified Sort Order feature is enabled, it overrides any attribute sorting scheme 
specified on the Select Display and Sort Attributes dialog. When selected, this feature orders 
measure positions in your worksheet that are based on their current order as presented in the 
Show/Hide dialog. To change the order of the measures in your worksheet display, change the 
order of measures on the list in the Show/Hide dialog. 

1. Right-click within the Measure axis, and choose Select Display and Sort Attributes from the 
resulting quick menu. 

2. Below the Attributes to Sort By section, check the Sort By User Specified Sort Order box. 

 Note: When the box is selected, the Unused Sort Attributes list box and Sort Attributes 
list box become disabled. The User Specified Sort Order feature overrides any selections 
made in these list boxes. 

3. Click the Show/Hide Measures tab. 

4. Click on a measure in the Visible Measures list box. 

5. Click the up arrow or down arrow to move the selected measure up or down in the list 
display. 

6. Repeat steps 4-5 for measures as required until the desired display order is attained. The order 
of the measures in the Visible Measures list box will match the order of measures in your 
worksheet. 

7. Click OK. 

To return to an attribute sorting scheme 
To disable the User Specified Sort Order; and again sort your measures using attributes, return to 
the Select Display and Sort Attributes dialog, and clear the Sort By User Specified Sort Order 
check box. When you do so, the Unused Sort Attributes list box and Sort Attributes list box 
become enabled, which allows you to make sort attribute selections as desired. 

Sort measure data in multiple windows 
The selections for sort attributes for a single dimension can differ from worksheet window to 
worksheet window. This feature is useful when different views (provided by different sorts) of 
the data are desired at the same time. You can use the New Window command on the Window 
menu to create a copy of the current worksheet. Each copy of the worksheet is represented by a 
different window, and can contain measure data that is sorted using a different sort method. 

Sort a dimension by grid data values 
The sorting mechanism allows you to sort one dimension in a hierarchy according to the current 
data values in the grid. You do this by specifying a one-dimensional data space for a given 
dimension, then by creating a user-named attribute based on that selected data. That attribute can 
then be used to sort and resort data in the corresponding dimension. 

For example, suppose that you want to sort all product classes in your product hierarchy in 
ascending order, based on the total sales for each during the month of January. In this case, the 
dimension you wish to sort is product class. To define the necessary one-dimensional data space, 
you must aggregate total sales for the product class dimension to the month level and select the 
January position. The one-dimensional data space is essentially a single row or column of data 
corresponding to the dimension you wish to sort. 
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Once you have selected the data that you wish to sort, you must create a system-recognized sort 
attribute based on this data. You might choose to call this attribute "JanSales." Once an attribute 
is created, it can be used to perform the initial data sort, and can later be used for resorts of that 
same dimension should changes to the data occur. 

For step-by-step instructions on sorting dimensions based on grid data, see the following topic: 

Sort hierarchies by data values in the grid 

Use the following procedure to sort one dimension in a hierarchy according to a set of data values 
in the grid: 

1.  Select a one-dimensional data space of grid data (a single column or row of data) to be sorted. 

2.  From the View menu, select Sort. OR right-click over the axis for the dimension you are 
sorting to produce a quick menu, and select Sort. 

3.  On the Create Sort Attribute dialog, enter a label for the sort attribute. Choose a name that 
will help you identify what this particular sort accomplishes (for example, ‘JanSales’ for a 
group of products to be sorted according to their total January sales). 

 Note: If the dimension you are sorting is displayed in outline mode with other dimensions 
in that hierarchy, the Create Sort Attribute dialog will contain an additional field. This 
additional field allows you to specify the single dimension to which to apply the created 
sort attribute. 

4. Click the appropriate radio button to specify the desired sort order (ascending or descending). 

5  Click OK. The initial sort of the selected data occurs. 

Re-sort a dimension using an already-defined sort attribute 
Should changes to sorted data occur, you may wish to re-sort the dimension based on the new 
values. Follow this procedure to reapply a sort attribute to a selected dimension. 

1.  Right-click over the axis for the dimension to be resorted. A quick menu is displayed. 

2.  Select Resort. 

The data is re-sorted according to the current attribute sort order specified for that dimension. 

For information on viewing and altering a dimension’s attribute sort order, see the following 
topic: 
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Change the order of sort attributes for a dimension 

You can edit the order in which sort attributes are applied to a given dimension during the sorting 
process. You do this by accessing the Sort/Display Attributes dialog, then manually reordering 
the available sort attributes that correspond to that dimension. Follow this procedure: 

1  Right-click over the axis for the dimension whose sort attributes you want to edit. A quick 
menu is displayed. 

2.  Choose Select Display and Sort Attributes. On the dialog that is displayed, the Attributes to 
Sort By portion contains all available sort attributes for the dimension, either used (right side) 
or unused (left side). 

3.  If desired, click on a sort attribute to highlight it, then use the left or right arrow buttons to 
move the attribute to the desired side of the screen. 

4.  The Sort Attributes list is a dragging listbox. To reorder the elements on the list, click on and 
hold an item, then drag the attribute upwards until its indicator is in the desired location. 

5.  Release the mouse button. Attributes in the Sort Attributes listbox are reordered according to 
your actions. The order of attributes on this list specifies the major to minor sorting scheme 
that the system applies to the dimension each time the Sort or Resort command is invoked. 

6.  Click OK. 

Cell locking 
The cell locking feature allows you to "lock" one or more editable cells in the grid. When a grid 
cell is locked, calculations performed as a result of data manipulations do not affect the locked 
data values. This functionality allows you examine various "what-if" scenarios to determine a 
most favorable planning or forecasting course of action. 

The "locked" status of a cell is indicated by the presence of a picture of a lock in the cell’s left 
portion. Once an eligible cell is locked, the system determines whether the remaining grid cells 
are eligible or ineligible to be locked. If a cell becomes ineligible to be locked, the right-click 
menu associated with that cell will not contain the Lock option. Furthermore, any read/write cells 
that become ineligible for locking are made read-only. 

You may choose to lock a data cell at any time to protect that cell from forced recalculations due 
to data manipulations elsewhere in the worksheet. For example, you may want to see the effect of 
a change to Sales Value on Inventory levels without forcing a change to Receipts. Another 
example would be a need to change Sales Value at an aggregate level, such as Month, and spread 
the result to only three of the four weeks that comprise that month. In this case, you could 
effectively hold the second week’s Sales Value constant while spreading the aggregate-level 
increase among the remaining three weeks. 
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Locking a grid cell 

1. Right-click in the cell you want to lock. 

2. Select Lock Cell from the pop-up menu. 

3. A picture of a lock displays in the cell to indicate that the cell’s status is locked. When 
recalculations of grid values are performed, the locked cell’s value will be held constant, 
which means that data manipulations that would normally force a change to the locked cell’s 
value will now result in no change to the locked data. 

 Note: If the Lock option is not displayed on a particular cell’s right-click menu, that cell 
is ineligible to be locked. This condition occurs as a result of the placement of other locks 
elsewhere in the worksheet. Cells that exist at a different hierarchical level than a locked 
cell may be ineligible for locking if they exist along a different path of aggregation. 

Unlock a single grid cell 

1. Right-click in the cell you wish to unlock. 

2. Select Unlock Cell from the pop-up menu. 

Unlock all currently locked grid cells 

1. Right-click any grid cell. 

2. Select Unlock All Cells from the pop-up menu. 

Examples of cell locking 

The following topic describes two typical examples of cell locking usage. 

Example 1: Using cell locking to affect spreading/aggregation 

Suppose you want to change a sales value at an aggregate level (for instance, Month) and spread 
this result to three out of four underlying cells while holding the fourth constituent cell value 
constant. Without the use of the cell locking feature, a change that is made to the Month-level cell 
will force a recalculation of all underlying Week-level cells that roll up into that month. The cell 
locking feature  allows you to hold the value of one week constant while spreading the effects of 
the aggregate-level change to the remaining three weeks. 

In the following example, suppose you want to change the January sales value for clock radios 
from 2200 to 3900 while holding the week 2 sales value of 500 constant. 

Right-click in the cell that contains the sales value for clock radios in the second week of January. 
 Select Lock Cell from the resulting pop-up menu.   
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Edit the Month-level sales value for January. After the recalculation occurs, note that week 2’s 
sales value remains unchanged. The additional aggregate sales value of 1700 is spread among the 
remaining three weeks according to those weeks’ original contribution to the month’s total. 

       
Example 2: Another example of the need for the cell locking feature occurs when you want to 
evaluate the effect of a change to one measure value on another measure value without forcing 
changes to any other measures that would normally be affected during the recalculation process. 
For instance, you may want to examine the effect of a change to Sales Value on inventory levels 
without forcing a change to the Receipts value. 

A change to the Sales Value results in the recalculation of the following equation: 

End of Period Inventory = Beginning of Period Inventory + Receipts – Sales – Markdown – 
Shrinkage 

When this expression is recalculated under normal circumstances ( when cell locking is not 
implemented), EOP Inventory and BOP Inventory are held constant; therefore, a change to Sales 
Value normally forces a recalculation of the Receipts value, Markdown value, and Shrinkage 
value. The following two figures demonstrate the effect of a change to Sales Value without using 
the cell locking functionality: 
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Change the Sales Value for 01/01/00 from 860.00 to 620.00.  Note that the Markdown value and 
Shrinkage value are recalculated based on the new Sales Value.  EOP Inventory and BOP 
Inventory are held constant, and a change is forced to projected receipts: 

       
Since EOP Inventory remains the same, there is no effect of the Sales Value change on 
subsequent weeks of data. 

Now perform the same operation from the original state of the worksheet, but this time use the 
cell locking feature to hold constant the projected receipts value: 

       
When projected receipts are locked, the decrease in Sales Value must be reflected in a change 
(increase) to EOP Inventory. When the EOP Inventory changes, this effect is propagated to 
subsequent weeks because the EOP Inventory value for 01/01/00 becomes the BOP Inventory 
value for 01/08/00. 
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Measure locking 
The Measure Locking feature allows you to lock all at once all the cells associated with a given 
measure in a worksheet. As with individual cell locking, the locked status of each cell in the 
measure is indicated by the lock picture in each cell’s left portion. A locked measure is also 
indicated by the appearance of the lock image in the axis header for that measure. 

Lock a worksheet measure 

1.  Right-click over the axis label for the measure you wish to lock. 

2.  On the quick menu, select the Lock Measure option. 

Change the format of a grid 
There are several ways to change the appearance of data in a grid format.  

Change the text color, fill color, or font for worksheet axes 

1. From the Format menu, select Axis. 

2. In the Apply To Axis section, choose the axis to which you are applying the new format: 
Row, Column, Slice, or All. 

3. Under Formatting Options, choose the feature you want to modify: Text Color, Fill Color, or 
Font. 

4. Make the necessary changes on the Color or Font dialog box, and click OK. 

5. Click Apply to apply the changes to the worksheet without closing the dialog box, or click 
OK to accept the changes and close the Format Options dialog. 
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Specify a shading scheme to differentiate dimensions (outline view) 

Use this procedure to toggle on/off the use of a shading scheme to help you differentiate grid data 
from multiple dimensions. This option only has an effect when you are viewing an axis in outline 
mode. 

 Note: Using a shading scheme to differentiate dimensions overrides any selection made 
regarding the specified color for read/write cells. 

1  From the Format menu, select Axis. 

2.  In the Apply To Axis section, choose the axis to which to apply the shading scheme. The 
Shade Colors By Dimension option can only be applied to one axis at a time (Row, Column, 
or Slice). 

3.  Under Axis Options, select the Shade Colors By Dimension check box to utilize the shading 
scheme; clear this check box to display all cells of a given measure in the same manner, 
regardless of dimension. 

4.  To apply the change to the worksheet without closing the dialog box, click Apply. To accept 
the change and close the Format Options dialog, click OK. 

Specify the appearance of attribute labels in the axis display 

Use this procedure to toggle the display of label headers that designate attributes for positions 
appearing along the chosen axis. This option can only be applied to the Row Axis and the 
Column Axis. 

 Note: This option turns on/off the display of attribute labels. To turn on the display of 
position attribute values, right-click over the desired axis and choose Select Display and 
Sort Attributes from the menu. 

1.  From the Format menu, select Axis. 

2.  In the Apply to Axis section, choose either the row axis or the column axis. 

3.  Under Axis Options, select the Show Attribute Labels checkbox to display labels; clear the 
checkbox to turn off the display. 

4.  To apply the change to the worksheet without closing the dialog box, click Apply. To accept 
the change and close the Format Options dialog, click OK. 
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Format grid components 
There are several options for modifying the appearance of a grid. 

Format the display of grid lines 

Follow these procedures to specify the appearance of grid lines in your worksheet. You can turn 
on/off the display of both horizontal and vertical grid lines, and if grid lines are displayed, you 
can specify their color. 

To change the color of grid lines in your worksheet: 

1.  From the Format menu, select Grid. 

2.  Under Formatting Options, click the Line Color Within Grid button. 

3.  Make a color selection for your worksheet grid lines, then click OK. 

4.  To apply the change to the worksheet without closing the dialog box, click Apply. To accept 
the change and close the Format Options dialog, click OK. 



Chapter 5 – Changing views of data in worksheets 
 

115 

To turn on/off the display of horizontal or vertical grid lines in your worksheet: 

1.  From the Format menu, select Grid. 

2.  Under Grid Options, select the Show Horizontal Grid Lines and/or Show Vertical Grid Lines 
check boxes to turn on the display of grid lines. Clear these check boxes to turn off the 
display of grid lines. 

3.  To apply the change to the worksheet without closing the dialog box, click Apply. To accept 
the change and close the Format Options dialog, click OK. 

Specify a value to appear in NA cells 

Follow this procedure to specify the string value that should appear in all cells of your worksheet 
containing a NA value. 

1. From the Format menu, select Grid. 

2. Under Grid Options, enter a string in the NA field that should appear in all worksheet cells 
containing a NA value (for example, N/A, *, ###, ). 

3. Click Apply to apply the change to the worksheet without closing the dialog box, or click OK 
to accept the change and close the Format Options dialog. 

Specify a value to appear in ambiguous type cells 

Follow this procedure to specify the string to be displayed in an aggregate-level cell when it is not 
clear how the system should aggregate certain data values. This string indicates the presence of 
lower level data that cannot be displayed at a particular level of aggregation. For example, pick 
list-type data at the SKU level would aggregate ambiguously if different SKUs in the same Style 
contained different pick list values. Here, you can specify what the system should display in a 
Style-level cell. 

1. From the Format menu, select Grid. 

2. Under Grid Options, enter a string in the Ambiguous Type field that should appear in all 
worksheet cells containing data that aggregates ambiguously. 

3. Click Apply to apply the change to the worksheet without closing the dialog box, or click OK 
to accept the change and close the Format Options dialog. 
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Change the format of a measure 

You can modify the text color, fill color, and font of a measure’s cells and label. You can also 
specify the alignment, border style, and border color for the grid cells associated with a measure. 

Format the display of text and borders for measure cells and labels 

1.  From the Format menu, select Measure. 

2.  In the Measure box (lower right of Measures tab), select all measures whose labels or cells 
you want to reformat. 

3.  Select an Apply To option (Cells, Labels, or Both). 

4.  Select a Formatting Option (Text Color, Fill Color, Font, Alignment, Border Style, or Border 
Color).  

5.  On the dialog box you selected, make the necessary formatting changes and click OK. 

6.  To apply the changes to the worksheet without closing the dialog box, click Apply. To accept 
the changes and close the Format Options dialog, click OK. 

Set application-wide formatting options 
You can set application-wide formatting options for all workbooks viewed in the Retek Predictive 
Solutions. These formatting options include the grid display background color, the color for both 
read-only and read/write worksheet cells, the appearance of toolbar button text, and the 
appearance of the flow control tabs. You can also enable/disable workbook caching and 
determine the maximum cache size. 

Change the background color of the grid display 

Follow this procedure to modify the color of the grid background (the portion of the window 
behind the data grid, hierarchy tiles, and axes). 

1.  From the Format menu, select Application. 

2.  Under Color Options, click the Grid Background Color button. 

3.  Make a color selection for the grid background, then click OK. 

4.  To apply the change to the worksheet without closing the dialog box, click Apply. To accept 
the change and close the Format Options dialog, click OK. 

Enable/disable the display of toolbar button text 

Use this procedure to toggle the display of toolbar button names. When button text is turned on, 
the toolbar buttons appear large and include the button name/function. When button text is turned 
off, the buttons appear small and contain no text. 

1. From the Format menu, select Application. 

2. Under Application Options, check the Show Button Text checkbox. 

3. Click Apply to apply the change to the worksheet without closing the dialog box, or click OK 
to accept the change and close the Format Options dialog. 
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Set the display color for read only and read/write cells 

1. From the Format menu, select Application. 

2. Under Color Options, click either the Read Only Color button or the Read/Write Color button 
to produce a color palette for the selected cell type. 

3. Make a color selection from the color palette, and click OK. 

4. Click Apply to apply the change to the worksheet without closing the dialog box, or click OK 
to accept the change and close the Format Options dialog. 

 Note: The Read/Write Color selection will be overridden if the Shade Colors By 
Dimension option on the Format > Axis tab is selected. Dimension shading (if toggled 
on) overrides any read/write color selection, but it does not override the read only color 
selection. If your read/write color selection does not appear to be recognized by the 
system, try toggling off the Shade Colors By Dimension option on the Format > Axis tab.  

Enable/disable the display of the flow control tabs 
1. From the Format menu, select Application. 

2. Under Application Options, check the Show Tab Control checkbox to turn on the tab control 
display. Clear this checkbox to turn off the display. 

3. Click Apply to apply the change to the worksheet without closing the dialog box, or click OK 
to accept the change and close the Format Options dialog. 

Specify options for deferred calculations 
You can specify various formatting options for the deferred calculation feature. Specifically, you 
can enable the display of a distinctive background color for worksheet cells in which a deferred 
calculation is pending. Also, you can enable/disable the appearance of a warning dialog that 
appears when you have a populated queue of deferred data changes that must be submitted before 
you perform another server action. 

Specify a deferred calculation color 

Follow the procedure below to specify a particular background color for worksheet cells in which 
a deferred calculation is pending.  

 Note: The Deferred Calculation Color, if enabled, overrides the Read/Write Color 
selection for a cell. 

1.  From the Format menu, select Application. 

2.  Under Color Options, click the Deferred Calculation Color button. 

3.  Make a color selection for cells in which a deferred calculation is pending, then click OK. 

4.  To apply the change to the worksheet without closing the dialog box, click Apply. To accept 
the change and close the Format Options dialog, click OK. 



Retek Predictive Application Server 
 

118 

Enable/disable the display of the selected deferred calculation color 

1. From the Format menu, select Application. 

2. Under Application Options, check the Show Deferred Calculation Color checkbox to display 
a distinct background color in cells where a deferred calculation is pending. Clear this 
checkbox to disable the color display. 

3. Click Apply to apply the change to the worksheet without closing the dialog box, or click OK 
to accept the change and close the Format Options dialog. 

Change the format of exception values for a measure 
1. From the Format menu, select Exceptions. 

2. In the Measure box (lower right of Exceptions tab), select a measure that has exceptions that 
you want to modify. 

3. In the Minimum field, type a threshold value for the low end of the measure’s acceptable 
range. 

4. Select a formatting option for displaying values that fall below the low threshold (Text Color, 
Fill Color, or Font).  

5. Make any formatting changes in the dialog box that you selected, and click OK. 

6. In the Maximum field, type a threshold value for the high end of the measure’s acceptable 
range. 

7. Select a formatting option for displaying values that exceed the high threshold (Text Color, 
Fill Color, or Font).  

8. Make any formatting changes in the dialog box that you selected, and click OK. 

9. Check the Enable Exception Display check box to turn on the display of the exception 
formats you selected. If you leave this check box cleared, the exceptions will not be formatted 
in the grid, but the system will save your exception formatting selections, which can be 
enabled as needed. 

10. Click Apply to apply the changes to the worksheet without closing the dialog box, or click 
OK to accept the changes and close the Format Options dialog. 
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Specify type-based formatting options for measures 

Specify formatting options for a floating point type measure 

1. From the Format menu, select Types. 

2. In the Measure Types section, click the Floating Point radio button. Your choice here 
populates the Measure portion of the dialog with a list of all floating point measures that are 
currently in the worksheet. You can also retain the default type selection ‘All’ to list all 
available measures in the worksheet. 

3. In the Measure list, click the measure that you want to format. 

4. If desired, enter values for the prefix, suffix, and/or scale factor for cells that are associated 
with your selected measure. 

5. Enter a value in the Precision field to indicate the number of digits to be displayed to the right 
of the decimal. 

6. Check the Use Separator checkbox to specify the use of a separator (comma) between every 
three digits. 

7. Click Apply to apply the changes to the worksheet without closing the dialog box, or click 
OK to accept the changes and close the Format Options dialog. 

Specify formatting options for an integer type measure 

1. From the Format menu, select Types. 

2. In the Measure list, click the measure that you want to format. 

3. Check the Use Spin Button check box to display up and down arrows in the measure’s cells 
that allow you to increase or decrease the cell’s value. Leave this check box cleared to require 
direct entry of new data values. 

4. If the Use Spin Button check box is selected, click the arrows in the Increment Spin By field 
to specify the amount that the system will increase or decrease a cell value when spin buttons 
are clicked in the worksheet. 

5. Check the Use Separator check box to specify the use of a separator (comma) between every 
three digits. 

6. Click Apply to apply the changes to the worksheet without closing the dialog box, or click 
OK to accept the changes and close the Format Options dialog. 
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Specify a prefix or suffix for measure values 

Follow this procedure to specify a string to be displayed before or after each value in a selected 
measure. For example, you could specify the prefix ‘$’ to be displayed before each value in a 
monetary measure or the suffix ‘%’ to be displayed after each value in a percentage measure. 

Prefixes and suffixes are often used in conjunction with scale factors. For example, if you specify 
a scale factor of 1,000, you may wish to specify the suffix ‘k’ for all values in that measure to 
indicate the nature of the scale. 

1. From the Format menu, select Types. 

2. In the Measure list, click the measure where you want to set a prefix/suffix. 

3. Under Display Options, enter string values for the Prefix and/or Suffix. 

4. Click Apply to apply the changes to the worksheet without closing the dialog box, or click 
OK to accept the changes and close the Format Options dialog. 

Specify workbook-specific formatting options 
Currently there is only one workbook-specific formatting option available: synchronized page 
scrolling. This feature allows you to scroll the slice position of multiple windows simultaneously. 
When synchronized scrolling is enabled, all windows that contain the same slice (page) 
dimension will scroll to a new slice position when any one window is scrolled. When 
synchronized scrolling is disabled, scrolling through slice positions in one window does not affect 
the slice position display of other windows. 

Enable/disable synchronized page scrolling 

1.  From the Format menu, select Window. 

2.  Check the Enable Synchronized Page Scrolling checkbox to enable the synchronized 
scrolling feature. Clear the checkbox to disable the feature and support independent slice 
scrolling among the windows. 

Chart types 
Descriptions of chart types that are available when using the Chart F/X charting utility are as 
follows. You can select the chart type by selecting a gallery type from the Format > Chart > 
Series dialog. Different chart types can be applied to individual series in the charted data, or a 
chart type can be specified globally for the entire data set. 

When selecting a chart type from the Gallery menu, drag your cursor over the chart type images. 
 The name of each chart type will appear in the text field at the bottom of the menu. The 20 
available chart types are as follows: 

• Line – Line shows trends or changes in data over a period of time. Each data point in the 
series is connected with a line. 

• Area – Area shows the relative importance of values over a period of time. Each data point in 
the series is connected with a line, and the area beneath this line is shaded. 

• Curve – Curve is similar to a line chart, but the lines curve to pass through each point or data 
marker smoothly. 
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• Area-Curve – Area-Curve is a combination of the Area chart type and the Curve chart type. 
 Each data point in the series is connected with a smooth, curving line, and the area beneath 
the curve is shaded. 

• Step – Step is similar to a line chart, but only vertical and horizontal line segments connect 
the data points in a series. The resulting graph appears as stair steps. 

• Scatter – Scatter is a point chart that shows the relationship or degree of relationship between 
numeric values in several series, or it plots two groups of numbers as one series of x-y 
coordinates. 

• Bubble – Bubble plots a set of values with one of the values specifying the size of the bubble 
marker. If two data series are plotted, values in the first series specify the position (height) of 
the bubble marker along the y-axis, and the corresponding values in the second series specify 
the size of the bubble marker drawn at each position. If three data series are plotted, values in 
the first two series define the (x,y) coordinates of the bubble marker, and the corresponding 
values of the third series specify the bubble marker volume. 

• Bar – Bar shows variation between data sets by depicting series as bars stretching vertically 
towards the top of the chart window. 

• Gantt – Gantt is basically a horizontal version of a bar chart. This chart type shows variation 
between data sets by depicting series as bars stretching horizontally across the chart window. 
Gantt charts are commonly used to track activities over time. 

• Cube – Cube is similar to a bar chart, but a cube is displayed at the proper height instead of a 
complete bar. 

• Candlestick – Candlestick is a chart that is typically used in financial areas, as related to stock 
prices. 

• Open-High-Low-Close – Open-High-Low-Close is a chart that is typically used in financial 
areas, as related to stock prices. Four series representing a stock’s opening, high, low, and 
closing prices define each marker. 

• High-Low-Close – High-Low-Close is a chart that is typically used in financial areas, as 
related to stock prices. Three series representing a stock’s high, low, and closing prices define 
each marker. 

• Pie – Pie shows the relationship or proportions of parts to a whole. Percentages of the whole 
for each piece of the pie are calculated and displayed in the chart. 

• Doughnut – Doughnut is the same as a pie chart, but with a hole in the center. 

• Pareto – Pareto is a chart that is often used in statistical areas. Bars show a variation over a 
period of time, and a cumulative curve indicates the proportion accumulated by each column 
in the chart. 

• Pyramid – Pyramid shows the relationship of parts to a whole in the format of a pyramid. 
Different point values in the series are represented by different colors and levels in the 
pyramid. 

• Radar – Radar plots values in polar coordinates and shows the relative importance of values 
over a period of time. 

• Contour/Spectral – Contour/Spectral is basically a line chart with different colors assigned to 
different ranges beneath the plotted values, which depends on each point height (y value). 
 The contour plot is displayed in a 2D representation. 
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• Surface – Surface is basically a line chart with different colors assigned to different ranges 
beneath the plotted values, which depends on each point height (y value). The surface plot is 
usually displayed in a 3D representation. 

Change the chart type 

1. From the Format menu, select the Chart option, or click the Format button on the toolbar. 

2. On the Chart F/X Properties dialog, select the Series tab. 

3. In the Styles portion of the dialog, click the Gallery arrow to produce a menu of available 
gallery types. 

 Note: You can change the chart type for an individual data series by selecting that series’ 
name from the series pick list at the top left of the dialog. If <All Series> is selected, the 
gallery type you choose will affect the entire chart format. 

4. Click the desired chart type. To identify the chart types in the gallery menu, drag your cursor 
over the chart type images. The name of each chart type appears in the text field at the bottom 
of the menu. 

5. Click OK. 

Show/hide legends in a chart 

You can toggle the display of the series legend and the values legend in your chart. The series 
legend identifies the collection of data represented by each plotted series in your chart. The values 
legend, also called the point legend, identifies the units displayed along the x-axis of your chart. 
For example, if your chart displays the calendar hierarchy along the x-axis, the values legend 
would identify the week or month indicated at each point. 

Resize chart and legend display areas 

To resize the chart and legend display areas, position the cursor immediately over a divider line 
between the chart display and legend display area. When the appearance of the cursor changes, 
click on and hold the divider line; drag the line to any position you choose, and release. The chart 
display and the affected legend are redrawn to reflect the new boundaries. 

You can perform this same function at the edge of the chart box (the area within the chart axes). 
Drag this boundary to increase or decrease the size of the chart itself. 
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Title a chart 

You can easily create a title for the chart to appear immediately above the chart display. Choose 
one of the following two methods to create a chart title: 

1.  From the Format menu, select the Chart option, OR click the Format button on the toolbar. 

2.  On the General tab of the Chart F/X Properties dialog, enter a title for your chart in the Title 
text field. 

3.  Click OK. 

-OR- 

1.  Right-click anywhere within the main chart display to produce the Chart F/X quick menu. 

2.  Select Edit Title. 

3.  Type or edit the title for your chart in the text box. 

4.  When you have finished, click anywhere outside the title box to return to your chart. 

Change the font, font style, font size, and color of chart text 

You can change the format of text in your chart by accessing the Chart F/X right-click menu. 
Text can be changed in chart areas, such as the chart title, chart axes, axis titles, point labels, 
series legend, and point legend. 

1. Right-click on the text that you want to change. A Chart F/X quick menu of formatting 
options for that text is produced. 

2. Select Font. 

3. On the Font dialog; make the desired changes to the font, font style, font size, effects, color, 
and script type. As you make your changes, view the results in the Sample window. 

4. Click OK. 

Create titles for individual chart axes 

Your chart can contain not only a main chart title, but also a title for each axis. Follow this 
procedure to create titles for your individual chart axes: 

1.  From the Format menu, select the Chart option, OR click the Format button on the main 
toolbar. 

2.  Click the Axes tab of the Chart F/X Properties dialog. 

3.  In the axis selection list at the top left of the dialog, choose the axis for which you want to 
create a title. 

4.  Click the Details button. 

5.  Click the Labels tab of the Axis Properties dialog. 

6 . Enter an axis title in the Title textbox at the bottom of the dialog. 

7.  Click OK to return to the Chart F/X Properties dialog. 

8.  Click OK to return to your chart. 
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Rotate and pivot in chart view 

The charting feature supports rotating and pivoting data while in chart view. You can drag 
hierarchy tiles to different axes and reposition them along the same axis in the same manner that 
this function is performed in grid view. When hierarchy tiles are repositioned in chart view, the 
new arrangement of hierarchies is preserved in the grid view of that same data.  

 Tip: To view grid mode data based on one arrangement of hierarchy tiles and chart mode 
data based on a different arrangement, use the New Window feature on the Window 
menu to obtain these views simultaneously.  

Change data values within a chart 

The charting feature allows you to change data values directly while in chart mode. You are not 
required to toggle back to grid mode to manually enter new data values.   

You can amend data values by dragging and dropping data points in the chart, which is a process 
called "hot charting." As data points are repositioned, associated balloon text displays the current 
numeric value of the y-axis position most closely associated with the data point’s current 
location. 

 Note: Only writable measures can be changed in either chart mode or grid mode. Data 
points corresponding to read-only measures cannot be dragged and dropped. 

You can also manually enter exact data values while in chart mode by opening the Chart F/X 
Data Editor. The Data Editor is an editable data grid that contains the values of the elements 
plotted in your chart. You can double-click any writable data value in the grid to edit it, and the 
chart is instantly redrawn to reflect your change. 

Show/hide point labels on the chart display 

1. Right-click anywhere within the chart display to produce the Chart F/X quick menu. 

2. Select the Point Labels option to toggle the display of point values. 

 Note: For bar graphs, labels that indicate the value of each bar are displayed immediately 
above each series. For line graphs, the point labels appear above each point marker in the 
series. 

Show/hide a selected data series on the chart display 

1. From the Format menu, select Chart. 

2. Click the Series tab. 

3. In the Series List at the top left of the dialog, select an individual series to show or hide. Do 
not select <All Series>. 

4. Select the Visible check box to include the selected series in the chart display. Clear this 
check box to hide the selected series from the chart display. 

5. Click OK. 
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Display a chart in 3D view 

1. Follow this procedure to change your chart from a two-dimensional to a three-dimensional 
view. 

2. From the Format menu, select Chart. 

3. Click the General tab. 

4. In the Effects portion of the dialog, select the 3D check box to display your chart in three-
dimensional mode. Clear the check box to display your chart two-dimensionally. 

5. Click OK. 

If you switch to a three-dimensional view of your chart, the system will display your data in 
standard 3D view. You have the option to manipulate certain aspects of this 3D view (for 
instance, rotation angles, shadowing, depth, and perspective) to create a customized three-
dimensional chart.   
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Chapter 6 – Using special RPAS features 
Exception Management and Alerts 
Overview 
Because of the large volumes of data that needs to be managed by the Retek Predictive 
Application Server, the server includes an Alert Manager feature that highlights users that might 
otherwise go unnoticed. You can set up business rules to alert users about OTB opportunities, 
stock outages, sales performance against plan, margin opportunities, and many others. Each of 
these alerts has a role within a business process that demands highly accurate management of 
large amounts of business information. The Alert Manager will take you directly to the area of the 
plan that needs action, so these alerts go beyond exception reporting. 

Alerts are set up by identifying a business measure as the foundation, and then creating the alert 
by using a mathematical rule. A facility behind the scene will find the areas of a plan that fall 
outside the thresholds that is declared within the alert rules. This will create a message, or alert, 
that is flagged to the user through the Alert Manager window. 

At this point, the alerts have been identified and the user can go directly to the affected areas of 
the Workbook and take appropriate action. 

Use the alert manager 
The Alert Management feature provides user-defined and user-maintained exception reporting. 
This process allows you to define a measure that is checked daily to see if any of its values fall 
outside of an acceptable range or do not match a given value. When this happens, an alert is 
generated to let you know that a value may need to be examined and possibly amended in a 
workbook. 

The Alert Manager is the interface that the system uses to inform you of all alert conditions that 
were identified during the last execution of the Alert Finder program. The Alert Manager window 
provides a list of all identified instances where a given measure’s values falls outside of the 
established limits.  

The Alert Manager provides two methods of viewing the measures associated with identified 
alerts — loading alerts and inserting alerts. If no workbooks are currently open, you may pick an 
alert from the list to load and have the system automatically construct a workbook that contains 
that alert’s measure and any other measures that you want to display. This workbook allows you 
to examine the actual measure values involved in the generation of the alert, so you can make 
decisions about what needs to be done next. If you have an open workbook already displayed, 
you can use the Alert Manager to insert a new alert measure into the current workbook. This 
functionality enables you to view multiple alert measures simultaneously, and it allows you to 
address alert-related issues without requiring you to build a new workbook for each. 

You may also use the Alert Manager window to keep track of alerts that have been resolved. 
 Change the alert resolution status to Yes for those alerts that no longer require attention. 
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To show/open the Alert Manager window: 
From the View menu, select Alert Manager. 

To hide/close the Alert Manager window: 
Click the X in the upper-right corner of the Alert Manager window, or you can select the Alert 
Manager option on the View menu (when this item is selected) to toggle off the display of the 
Alert Manager. 

Load an alert into a new workbook 
After selecting an alert listed on the Alerts tab in the Alert Manager window, you can click the 
New Workbook button to have the system construct a workbook where you can view the 
identified alert hits. Clicking the New Workbook button places you in a wizard that prompts you 
for necessary details regarding the workbook build. 

Perform the following steps to load an alert into a new workbook. After you have made the 
necessary selections in each step below, click the Next button to advance to the next screen. If the 
Finish button is enabled, you may click it at any time to proceed with the workbook build. 

1. Click an alert listed on the Alerts tab in the Alert Manager window. 

2. Click New Workbook. 

3. Select any additional alerts that you want to include in the new workbook, and click Next. 

4. Select the workbook template that you want to use to build the workbook, and click Next. 

5. Select hierarchies that you want to range. 

 Note: If a hierarchy is chosen to be ranged, only positions in the hierarchy that triggered 
an alert will be available for selection in the new workbook wizard. For instance; if you 
choose to range the product hierarchy, the product selection screen for the new workbook 
wizard will only allow you to choose product positions for which an alert was triggered. 
This means that all non-alert-related positions will be excluded from the workbook build. 

6. Select hierarchies that you want to hide. When you select the hierarchies to hide, non-alert 
positions in the hierarchies you specify will not be shown in the workbook when it is initially 
built. If desired, these positions can later be unhidden by accessing the Show/Hide dialog. 

7. Click Next. At this time, you will be placed in the wizard for the workbook template that was 
selected in step 4. Follow the instructions on each wizard screen, and make selections as 
necessary. 

8. The measure on which the loaded alert is based will be the first measure displayed in the 
newly-built workbook. Checkmarks identify the positions associated with a recognized alert. 
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Insert an alert into an open workbook 
You can access the Alert Manager window to insert an alert measure into a workbook that is 
already open. In order to view alert information, this functionality allows you to address alert-
related issues without requiring you to build a new workbook. You can view multiple alert 
measures simultaneously in the same workbook. 

Whenever you insert an alert measure into an open workbook, the measure automatically 
becomes the active alert measure. The active alert measure for a workbook is the one that is 
referenced by the system when you choose menu options, such as Find Next Alert, Find Previous 
Alert, and Range By Alerts. Find Next Alert and Find Previous Alert will find the next or 
previous position in the worksheet within the active alert measure for which the alert condition is 
true. The Range By Alerts menu option allows you to hide all positions in a given hierarchy for 
which an alert condition was not triggered. This is evaluated with respect to the active alert 
measure. 

When you insert an alert measure into an open workbook, no check is made to determine whether 
all the positions that triggered the new alert condition are currently present in the open workbook. 
 For example, if you chose to range hierarchies during the initial workbook build, which excludes 
non-alert-related positions for the original alert measure, some of the positions identified by the 
newly inserted alert might not be present in the open workbook. If this is the case, you will be 
required to build a new workbook in order to display the excluded positions. 

Perform the following steps to insert a new alert measure into an open workbook: 

1. From the View menu, select Alert Manager to display the Alert Manager window. 

2. Click the alert that you want to insert into the open workbook. 

3. Click Insert Alert. 

Change the active alert measure in a worksheet 
When multiple alert measures exist in a worksheet, one of the measures must be treated as the 
active alert measure. When you perform menu functions, such as Find Next Alert, Find Previous 
Alert, and Range By Alerts, the currently active alert measure is the one that the system 
references and uses to conduct these tasks. 

For example, the Find Next Alert function finds the next instance within the active alert measure 
where the alert condition is true (the next position where an alert has been triggered). To search 
for alert occurrences corresponding to a different alert measure, you must designate this measure 
as the active alert measure for the worksheet. 

1. From the View menu, select Change Alert Measure. 

2. Click on the measure that you want to be the active alert measure. 

3. Click OK. 

The measure that you selected is now the worksheet’s active alert measure. Whenever you select 
the menu options Find Next Alert or Find Previous Alert, the system will search for the 
next/previous position within your chosen alert measure where an alert condition has been 
identified. If you choose to Range By Alerts, the system evaluates your chosen active alert 
measure and hides all positions in a particular hierarchy that do not represent alert hits. 
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View a measure's calculation expression and description (Show Measure 
Information) 
When viewing an open workbook, you can use the Show Measure Information feature to see the 
calculation expression and the description associated with a particular measure. This functionality 
gives you quick access to information related to the generation of an alert, which includes the 
specific threshold values that determine the alert priority (low, medium, or high). 

1. Right-click the measure’s label in the measure axis of your worksheet. 

2. On the quick menu, select Show Measure Information. 

3. View the calculation and measure description information in the Measure Info dialog.  

4. Click Close. 

Resolve an alert 
After taking the appropriate actions regarding identified alerts, you can use the Alert Manager 
window to keep track of alerts that have been resolved. Change the status of a listed alert from 
New to Resolved, which indicates that appropriate actions have been taken to address the alert 
condition. 

1. On the Alert Manager window, click the alert that has been addressed. 

2. Click the Resolve Alert button. The Resolved status of the alert changes to Resolved. 

 Note: You can reverse this action and return the alert’s Resolved status to New by 
selecting an alert that has already been resolved and clicking the Unresolve Alert button. 

Open an alert workbook 
You can use the Alert Manager window to open an alert workbook that has already been created. 

1. On the Alert Manager window, click the Alert Workbooks tab. 

2. Select the alert workbook that you want to open. 

3. Click the Open Workbook button. The selected workbook is opened. 

Resolve an alert workbook 
You can use the Alert Manager to keep track of alert workbooks that have been resolved. From 
the Alert Workbooks tab, you can change the status of a listed alert workbook from New to 
Resolved, which indicates that appropriate actions have been taken to address the alert condition. 

1. On the Alert Manager window, click the Alert Workbooks tab. 

2. Select the alert workbook that you want to resolve. 

3. Click the Resolve Alert button. The status of the alert changes to Resolved. 

 Note: You can reverse this action and return the alert workbook’s Resolved status to 
Reviewed by selecting an already resolved alert workbook and clicking the Unresolve 
Alert button. 
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Field descriptions 
Alerts are displayed as a list in the Alert window. For each alert, the following attributes are 
listed: 

Category 
The category to which the alert belongs. 

Alert Name 
The name of the identified alert. 

Priority 
The priority of the alert (High, Medium, or Low). 

Status 
Specifies whether the alert is resolved or unresolved. After you select an alert from the list, you 
can change the status of the alert by clicking the Resolve Alert or Unresolve Alert button. 

Date 
The date when the Alert was identified. 

Count 
The number of values that had this alert. 

Workbook 
The name of the workbook that contains the alert. This field is only shown on the Alert 
Workbooks tab. 

Button descriptions 

Resolve Alert 
Moves a new alert to the Resolved state, which identifies that you have addressed the alert. 

Unresolve Alert 
Moves a resolved alert to the New state, which indicates that you must readdress the alert. 

Insert Alert 
Allows you to insert the selected alert into the open workbook. See “Insert an alert into an open 
workbook” for more information. 

New Workbook 
Allows you to create a new workbook that includes the alert you selected. Clicking the New 
Workbook button places you in a wizard that will prompt you for necessary details regarding the 
workbook. See “Load an alert into a new workbook” for more information. 
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Open Workbook 
Allows you to open an alert workbook that was previously created. This button is only available 
on the Alert Workbooks tab. 

Percent-to-Parent Measures 
Overview 
A "percent to parent measure" allows a user to define, view, and edit a measure as a proportion or 
percentage of another measure for a parent that is up one or more hierarchies. These measure 
relationships are also referred to as "participation measures."  These measures can be viewed and 
edited, and can be pre-configured in the RPAS Configuration Tools or defined in the RPAS client 
in a worksheet. 

Typical uses of this functionality will be to define measures that are percentage participations of 
sales measures. Typically, these are either to a fixed level (such as class) so the participation of 
each item to the class can be viewed and manipulated, or they are to the ‘next level up’ in the 
product hierarchy. 

The following sections describe the percent to parent feature and how to create these measures in 
the RPAS client.  

Definition and usage 
To define a percent-to-parent measure: 

1. Right-click the measure axis and select “Create Percent to Parent Measure” in the quick-
menu.   

2. Select the measure where a percent to parent measure is desired. The drop-down list contains 
all measures defined for the active worksheet. 

3. Select the desired percent to parent measure type. The dialog box is context sensitive and the 
available parameters will change based on the type that is selected. The following sections 
contain detailed information about the different types and how they are defined. 

4. Once the type and the required parameters are selected, press “OK.” The new measure will 
appear in the worksheet. 

 Note: The following points are very important when using this feature: 

• When you change the percentage of the percent to parent measure, values of the 
underlying measure will change to reflect the newly set percentage. 

• Multiple percent to parent measures can be defined for the same underlying measure; 
however, only one percent to parent measure or the underlying measure can be edited 
before calculation. All other “versions” will be protected. 

• The value of a percent-to-parent measure is a fraction that will be between zero and one. 
Users must format the measure to be displayed as a percentage if desired. 
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Absolute 
The “absolute” type of percent to parent measures allows a user to explicitly define the parent 
level(s) that are used to calculate the percentage at all child levels. 

If a user sets the absolute parent level to the "class" dimension in the product hierarchy, the 
percent to parent measure will show: 

• The "SKU" as a percent of the "class" at the "SKU" level 

• The "style" as a percent of the "class" at the "style" level  

• The "subclass" as a percent of the "class" at the "subclass" level. 

This is using the previously defined sample hierarchy structure. 

After selecting the "Absolute" type and the measure in the “Create Percent to Parent Measure” 
dialog box, the user will see an "Intersection" area. This area contains drop-down lists for all 
hierarchies where the measure is dimensioned with each drop-down list containing the 
dimensions that are available for that hierarchy.  

1. Select the dimension/level for each hierarchy that is to be explicitly set.  

2. Click "OK." You will see the new percent-to-parent measure in the worksheet. 
For "absolute" relationships, cells at or above the dimension/level will be hashed out. 

Relative 
The "relative" percent to parent measure type will calculate the value for a given level, which is 
the percentage of that level and its immediate parent (meaning one level higher). This type can 
only be set for a single hierarchy. 

Using the previously defined sample hierarchy structure, the percentage displayed:  

• At the "SKU" level is the "SKU" as a percent of the "style" 

• At the "style" level is the "style" as a percent of the "subclass" 

• At the "subclass" level is the "subclass" as a percent of the "class" 

After selecting the "Relative" type and the measure in the “Create Percent to Parent Measure” 
dialog box, the user will see a drop-down list named “Hierarchy.” This drop-down list contains 
the hierarchies on which the measure is dimensioned. Select the hierarchy that will be used to 
calculate the percentage. 

Only a single hierarchy is possible with the “relative” percent to parent measure type. 

After hitting "OK," the user will see the new percent-to-parent measure in the worksheet. 

Certain dimensions will have multiple parents if there are multiple branching hierarchies. For 
relative percent to parent measures, the calculation of the percentage will always be based on the 
active roll-up in the current window. 

The calculated value is based on the actual next level up in the hierarchy, which is based on the 
hierarchy structure (not necessarily the one that is displayed). In the previous examples, imagine 
that SKU-subclass-class is displayed in the client, but the underlying structure is SKU-style-
subclass-class. When viewing the value at SKU; the percentage will be based on style (not the 
subclass even though style is not displayed). 

Cells at the top of the hierarchy will be hashed out since those values cannot be calculated. 
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Glossary 
A 

Absolute:  The “absolute” type of percent to parent measures allows a user to explicitly definethe 
parent level(s) that are used to calculate the percentage at all child levels.If a user sets the 
absolute parent level to the "class" dimension in the producthierarchy, the percent to 
parent measure will show:The "SKU" as a percent of the "class" at the "SKU" levelThe 
"style" as a percent of the "class" at the "style" level The "subclass" as a percent of the 
"class" at the "subclass" level.This is using the previously defined sample hierarchy 
structure.After selecting the "Absolute" type and the measure in the “Create Percent to 
ParentMeasure” dialog box, the user will see an "Intersection" area. This area 
containsdrop-down lists for all hierarchies where the measure is dimensioned with each 
drop-downlist containing the dimensions that are available for that hierarchy. Select the 
dimension/level for each hierarchy that is to be explicitly set. Click "OK." You will see 
the new percent-to-parent measure in the worksheet.For "absolute" relationships, cells at 
or above the dimension/level will be hashedout. 

Aggregate:  To summarize data at a lower hierarchy level into a single category at a higher 
hierarchy level. To roll-up worksheet data. See also aggregation method. 

Aggregation:  The process of bringing pieces of data together to form a larger group.After 
hierarchical relationships are established, data can be viewed at any levelin the hierarchy. 
Aggregation allows you to view data at summary levels. 

aggregation method:  The method used to aggregate data, or to provide a summary view of 
lower-level data at a higher level of aggregation. A measure’s aggregation method 
determines how the system populates aggregate level cells based on the component 
values of base-level cells. In dialogs that prompt you to specify an aggregation method, 
the choices and their meanings are as follows: ? : Aggregate by displaying the first lower 
level value if they are all the same; otherwise, display a ‘?.’ ? of Populated: Aggregate by 
displaying the first non-NA lower level value if they are all the same; otherwise, display a 
‘?.’ Avg: Aggregate by displaying the average of all lower-level values. First: Aggregate 
by displaying the first of all lower-level values. Last: Aggregate by displaying the last of 
all lower-level values. Last of Populated: Aggregate by displaying the last of all non-NA 
lower-level values. Logical Count: Aggregate by counting the logical cells at the lower 
level and displaying this value in the aggregate cell. Logical Count of Populated: 
Aggregate by counting the logical cells at the lower level if there is at least one populated 
cell. Max: Aggregate by displaying the maximum of all lower-level values. Min: 
Aggregate by displaying the minimum of all lower-level values. Period End Avg: 
Aggregate by displaying the period-ending average. Period End Total: Aggregate by 
displaying the period-ending total, or total value present at period end. Period Start Avg: 
Aggregate by displaying the period-starting average. Period Start Total: Aggregate by 
displaying the period-starting total, or total value present at period start. Pop Count: 
Aggregate by counting the populated cells at the lower level and displaying this value in 
the aggregate cell. Total: Aggregate by summing up all lower-level values. 

Alert:  A notice displayed to system users that a forecasted value is above or below user defined 
limits (an exception). 
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Alert Finder program:  The Alert Finder runs the task that checks the current data against the 
list of alerts.It builds a list of those alerts that are triggered because their conditions 
havebeen met by the existing data. It counts the number of times the alert is triggeredand 
stores this information for a particular user. The user will see this informationin the Alert 
Manager window the next time that user logs into RDF. The Alert Finder is typically run 
as part of a batch process performed when systemuse is minimal, such as overnight. The 
schedule for running Alert Finder is determinedat implementation time. Alert Finder may 
also be started manually by an Administrator.Whenever the Alert Finder runs, any 
previous alerts are discarded. This ensures thatall alerts are created based on the most 
current data. However, any alerts that arestill valid from a previous run will be 
recreated.If an alert is triggered at more than one priority (for example, medium and 
high),only the higher level will be counted, and only the high level alert will appearin the 
Alert Manager dialog. 

Alert Manager window:  A window that displays the alerts assigned to you. This dialog 
provides a list of all identified instances in which a monitored measure’s values fall 
outside a set of defined limits. You may pick an alert from this list and have RCS 
automatically build a workbook containing the measure values that triggered the alert. 

Application main menu bar:  The menu bar and the items contained in each menu are context-
sensitive, and theychange according to what you are working on and how you are 
working. Menu items thatare grayed out are not available to you in your current work 
mode.When no workbooks are open, the menu bar displays the following 
options:FileViewHelpWhen a workbook is open, the menu bar displays the following 
options:FileEditViewFormatWindowHelp 

Area:  Shows the relative importance of values over a period of time. Each data point in the 
series is connected with a line, and the area beneath this line is shaded. 

Area-Curve:  A combination of the Area chart type and the Curve chart type. Each data point in 
the series is connected with a smooth, curving line, and the area beneath the curveis 
shaded. 

Attribute:  A piece of information associated with a given dimension that helps to further 
describe the positions contained in that dimension. For example, positions in the SKU 
dimension of the product hierarchy could be described by the attributes COLOR, SIZE, 
and LABEL. Positions can be described by any number of attributes; LABEL is the only 
required attribute. Attributes can be displayed in the grid, if desired, and attributes can be 
used to sort positions within a dimension. 

auto build queue:  The automatic workbook build queue that specifies the Retek Predictive 
Solutions workbooks to be automatically built during user-defined batch runs. 
Workbooks are added to and deleted from this queue through the Workbook Auto Build 
Maintenance wizard. 

Axis:  On a Demand Forecasting grid, a row (x-axis), column (y-axis), or slice (pages). Each axis 
is used to display one dimension of an item. 
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B 
Bar:  Shows variation between data sets by depicting series as bars stretching vertically towards 

the top of the chart window. 

Block View:  The Block View option switches the display mode of a given axis to block view.In 
block view, which is the default view for a new workbook, data values in the grid are 
only displayed at one dimensional level at a time. This is the lowest dimension that is 
currently expanded in the grid. Multiple dimensions can be displayed for a hierarchy 
along a given axis, but the result is the display of labels for eachposition in the expanded 
dimensions. The data is displayed at the lowest dimensional level shown in the grid. In 
block view, collapsing the lowest dimension currently displayed will result in data values 
being aggregated to the next higher grid level.To place an axis in block view, right-click 
over the axis that you want to change (row axis or column axis), and choose the Block 
View option from the quick menu.The display modes (outline view vs. block view) for 
the row and column axes are independent of each other. You can display either axis (or 
both axes) in blockmode. The only method of display for the slice axis is block view. 

Bubble:  Plots a set of values, with one of the values specifying the size of the bubble marker.If 
two data series are plotted, values in the first series specify the position (height)of the 
bubble marker along the y-axis, and the corresponding values in the secondseries specify 
the size of the bubble marker drawn at each position. If three data series are plotted, 
values in the first two series define the (x,y) coordinates ofthe bubble marker, and the 
corresponding values of the third series specify the bubble marker volume. 

C 
Calculate button:  Submits a queue of data changes to the server for processing. Same action as 

selectingthe Edit > Calculate Now menu option. This button is only enabled when the 
system is in Manual (Deferred) Calculation mode. Queued changes are executed in the 
order in which they were made. 

Candlestick:  A chart typically used in financial areas, as related to stock prices. 

Cell locking:  The cell locking feature allows you to "lock" one or more editable cells in the grid. 
When a grid cell is locked, calculations performed as a result of data manipulations do 
not affect the locked data values. This functionality allows you examine various "what-if" 
scenarios to determine a most favorable planning or forecasting course of action.The 
"locked" status of a cell is indicated by the presence of a picture of a lockin the cell’s left 
portion. Once an eligible cell is locked, the system determinesif the remaining grid cells 
are eligible or ineligible to be locked. If a cell becomesineligible to be locked, the right-
click menu associated with that cell will notcontain the Lock option. Furthermore, any 
read/write cells that become ineligiblefor locking are also made read-only.You may 
choose to lock a data cell any time you want to protect that cell from forcedrecalculations 
due to data manipulations elsewhere in the worksheet. For example,you may wish to see 
the effect of a change to Sales Value on Inventory levels withoutforcing a change to 
Receipts. Another example would be a need to change Sales Valueat an aggregate level, 
such as Month, and spread the result to only 3 of the 4 weeksthat comprise that month. In 
this case, you could effectively hold Week 2’s SalesValue constant while spreading the 
aggregate-level increase among the remaining threeweeks. 
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Chart:  An alternative to displaying data in a grid. In the Retek Predictive Solutions, available 
options for displaying data in chart form include pie charts, bar charts, line charts, and 
others. 

cloning measures:  Creating copies of a selected measure’s properties and calculations for the 
specified selections in a category. 

Collapse:  Removing from view the wizard list items displayed for a hierarchy level below the 
level selected. 

Column:  On a grid, an axis or display area that runs vertically (y-axis). 

Column axis:  The column axis of the worksheet displays the contents/dimensions of the 
hierarchy tiles currently in the column display area. Data for these dimensions are 
presented in columns, and the labels for each column position appear across the top of the 
worksheet. 

Column display area:  The column display area is located at the top right corner of the 
worksheet. Hierarchy tiles in this location have their contents/dimensions displayed in 
columns. The headingsfor these columns appear across the top of the worksheet along the 
column axis. 

Commit:  Transferring saved workbook data to the master database, allowing other users to 
access and use the data. 

Contour/Spectral”  Basically a line chart with different colors assigned to different ranges 
beneath the plotted values, depending on each point height (y value). The contour plot is 
displayed in a 2D representation. 

Copy button:  Copies selected worksheet data to an application clipboard. Same action as 
choosing Edit > Copy. The Copy function is typically used with the Paste function to 
speed the process of populating data cells in a worksheet. When you click the Copy 
button, the system performs the copy at the current hierarchical level. Data can be copied 
from only one dimensional level at a time, so if multiple dimensions are represented in 
your grid selections, then the copy is performed atthe lowest dimensional level actually 
selected. Unlike the Cut function, Copy does not then clear the data from the copied 
cells.The Copy command does not copy information to your Windows clipboard. The 
data is copied to an application-specific clipboard and cannot be pasted into other 
programs. If you intend to paste the data into another application, you can choose the Edit 
> Copy to Clipboard command. 

Cube:  Similar to a bar chart, but a cube is displayed at the proper height instead of a complete 
bar. 

Curve:  Similar to a line chart, but the lines curve to pass through each point or data marker 
smoothly. 

custom measure:  A measure that is created and registered by system administrators. System 
users can then insert the custom measure in workbooks, or use the measure in generating 
alerts. 

Cut:  The Cut option copies selected worksheet data to an application clipboard and clears the 
data from the worksheet cells. 
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Cut base-level data feature:  The cut data at base level feature allows you to view data at an 
aggregate level in your worksheet while cutting that same data at its base dimensional 
level, which is not currently displayed.When you select the Cut Special function at an 
aggregate level, and you select the Cut Data at Base Level check box (on the Cut Special 
dialog); all base level data applicable to your selected aggregate data will be cut and 
copied to the application clipboard. Although the Cut function is actually performed at 
the base dimensionallevel, it seems that the aggregate level data has been cut (due to the 
process of data roll-up).To use the cut data at base level functionality, the base 
dimensional level for a given hierarchy cannot be displayed in your worksheet (if in 
block view). 

Cut button:  Copies selected worksheet data to an application clipboard and clears the data from 
the worksheet cells. Same action as choosing Edit > Cut. Only data from writable 
measures can be cut.When you use the Edit > Cut option to cut data, the function 
performs the cut at the current hierarchical level. Data can be cut from only one 
dimensional level at a time, so if multiple dimensions are represented in your grid 
selections, then thecut is performed at the lowest dimensional level actually selected. The 
Cut command does not copy information to your Windows clipboard. The data is copied 
to an application-specific clipboard and cannot be pasted into other programs. If you 
intend to paste the data into another application, you can choose the Edit > Copy to 
Clipboard command. 

D 
Delete workbook button:  The Delete Workbook button deletes a workbook. Clicking this 

toolbar button produces the same result as choosing File > Delete. The Delete dialog is 
displayed, and you can select a workbook or group of workbooks to be deleted from the 
system.This toolbar option is only available when a workbook is not currently open. 

derived calculation:  A calculation that defines a derived measure in terms of other dependent 
measures. 

derived measures:  Measures that are not stored. Their values are derived from one or more 
other measures. 

Dimension:  A quality of an item (such as a product, location, or time) that can be displayed on 
an axis of a grid. For example, product, location, or time. 

display area:  One of three portions of a worksheet that contain the measures and hierarchy tiles. 

display order:  The order in which the attributes of a dimension are displayed on a specific axis 
of grid. Users define which attributes to display and their display order. Display order is 
independent of sort order. 

Doughnut:  The same as a pie chart, but with a hole in the center. 
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E 
Exception:  A forecast value that is greater than or less than a user-defined limit. 

Exception management:  The Retek Predictive Application Server includes an Alert Manager 
for highlighting opportunities to users that might, because of the volume of data that 
needs to be managed, otherwise go unnoticed. You can set up business rules to alert users 
about OTB opportunities, stock outages, sales performance against plan, margin 
opportunities, etc. Each of these alerts has a role within a business process that demands 
highly accurate management of large amounts of business information. These alerts go 
beyondexception reporting, as the Alert Manager will take you directly to the area of the 
plan that needs action. Alerts are set up by identifying a business measure as the 
foundation, then creatingthe alert via a mathematical rule. A facility behind the scene 
runs and finds the areas of a plan that fall outside the thresholds declared within the alert 
rules. This will create a message, or alert, that is flagged to the user via the Alert 
Managerwindow.At this point, the alerts have been identified and the user has the ability 
to go directly to affected areas of the Workbook and take appropriate action. 

Expand:  To display worksheet data for a hierarchy level below the level selected. 

F 
Find option:  The Find option displays a dialog box that you can use to locate positions in a 

worksheet axis.This function allows you to perform an alphanumeric search for text 
entered in the Find What field of the dialog. This function can be useful when you want 
to move quickly to a particular product position in a very large worksheet.To produce the 
dialog, right-click over the axis you want to search, and choose the Find option from the 
quick menu. Enter the text you want to search for in the Find What field.The Match Case 
and Match Entire Description check boxes allow you to narrow your search further by 
imposing more restrictions. Click the Repeat Find button to search for the next matching 
occurrence. 

Format:  The Format option provides right-click access to the Format > Measure or Format > 
Axis dialog.The Format > Measure dialog allows you to make changes to the way 
measure labels and grid data appear in your worksheet. You can select text color, fill 
color, and font style for a selected measure’s label and/or data cells. You can also 
selectalignment options, border style, and border color for data cells associated with a 
chosen measure.The Format > Axis dialog allows you to make changes that affect the 
appearance of the row, column, and slice axes of your worksheet. You can select the text 
color, fill color, and font style associated with a selected axis. For an axis displayed in 
outline view, you can also choose axis options such as Show Connector Lines, and Shade 
Colors by Dimension (a shading scheme used to differentiate dimensions). Attribute 
labels for a selected axis can also be toggled on and off from this dialog. 
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G 
Gantt:  Basically a horizontal version of a bar chart. This chart type shows variation between 

data sets by depicting series as bars stretching horizontally across the chart window.Gantt 
charts are commonly used to track activities over time. 

Grid:  A structure used by the Retek Predictive Solutions to display multidimensional arrays of 
data. 

Groups Worksheet:  On the Groups Worksheet, you can view any groups to which at least one 
user has been assigned. When new users are created, they must be assigned to an existing 
group. Assigning users to groups builds an intermediate level of security into 
workbookscreated and committed by users. When users save a workbook, they assign one 
of three access rights options to it:Allow any user to open and edit the workbookAllow 
only those users in their same group to open and edit the workbookAllow no other users 
to open and edit the workbook. Users in the same group can be given access to 
workbooks that belong to that group alone.Users are typically assigned to groups based 
on similarities in job functions. In the Retek Predictive Planning Suite, the user group 
corresponds to the user’s planning role.The Groups Worksheet only lists the groups to 
which one or more users have been assigned. You can have many more groups in 
existence, all of which will be displayed in the Group drop-down list when you create a 
new user.The Groups Worksheet contains the label measure, which is a descriptive tag 
applied to each group. The label for each group is first entered when you add a user 
group, and it can be modified in this worksheet. 

H 
Hierarchies:  Structures used to define subordinate relationships among items in a dimension, 

such as product, location, time, or other. 

hierarchy tile:  Hierarchies are the structures used by an organization to describe the 
relationships that exist between the many dimensions. Typically, any dimension will 
belong to one of these hierarchies (there may be others, but these are the most common): 
Product, Location, or Calendar (or Time). The Measure hierarchy consists of the 
measures, or metrics on the worksheet. These hierarchies are represented on the 
worksheet by hierarchy tiles, or named gray rectangles that represent each hierarchy. 

Horizontal scroll bar:  The standard horizontal scroll bar to navigate within the grid portion of 
the worksheet window. This scroll bar allows you to scroll left and right through the data 
displayed.The thumbtack, or sliding control on the scrollbar, shows the viewing position 
on the screen relative to the full body of data. If you press the thumbtack by clicking on 
it, a pop-up caption displays the number of items along that axis and which number you 
are currently viewing. If you click on the thumbtack and hold the mouse button down, 
you can drag the thumbtack rapidly to any location you want on the scroll bar.Release the 
mouse button to release the thumbtack. To move one page of data to the left, click 
anywhere on the horizontal scroll bar to the left of the thumbtack. To move one page of 
data to the right, click anywhere on the horizontal scroll bar to the right of the thumbtack. 
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I 
import properties:  The measure attributes that specify where and how data will be imported 

from an external source. 

imported measure:  Measures that are stored and also specify import properties for loading data. 

Insert Alert button:  Allows you to insert the selected alert into the open workbook. See “Insert 
an alert into an open workbook” for more information. 

L 
Line:  Shows trends or changes in data over a period of time. Each data point in the series is 

connected with a line. 

Lock measure:  The Lock Measure option allows you to lock all the cells in your worksheet that 
are associated with a particular measure. When a cell is locked, calculations that are 
performed as a result of data manipulations elsewhere in the grid do not affect the locked 
data values. 

M 
Mask:  A filter that allows specified combinations of workbook items (cells) to be hidden. 

master database:  The main data repository where the application data for all the Retek 
Predictive Solutions resides. To manipulate the data in the database, the appropriate 
product, location, and time information is extracted from the database to a workbook. The 
workbook is a temporary repository that you can use to manipulate and analyze the data. 
The data in a workbook is committed, or written, back to the master database through a 
commit function. For example, planning data viewed on Retek Merchandise Financial 
Planning worksheets is read from and written to the master database. Also referred to as 
the master cube. 

Measure:  Any item of data that can be represented on a grid in worksheets. In the Retek 
Planning Solutions, measures also specify exactly one role, version, metric, and unit of 
measure For example, the measure for Planners Working Plan Sales Value is expressed 
as Pl Wp Sales V. 
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Measure Access Rights worksheet:  The Measure Access Rights worksheet allows you to 
restrict user access to individual measures on a user-by-measure basis. User/measure 
permissions are initially determined by the system by integrating the current 
user/template and template/measure settings and applying the following rule: a user 
cannot have access to any measure that is not available in at least one template to which 
the user has access. Permissions can be made even more restrictive on a user by measure 
basis by using the Measure Rights Access worksheet to deny users access to measures 
that they would normally be permitted to edit.The worksheet contains a checkbox for 
each available user and registered measure combination. A checkmark in the cell 
indicates that the user has access rights to and is permitted to view and edit the specified 
measure. More specifically, that given user has access to at least one template that is 
permitted to include the specified measure.You can further restrict a user’s access to 
specific measures by removing checkmarks that are displayed at those associated 
intersections. Removing the checkmark (by clicking on it) prevents the user from 
accessing a given measure, even though thatmeasure is normally permitted to be 
displayed in a particular workbook template to which the user does have access. After 
changes are made to a user’s profile, they must be committed in order for them to take 
effect.The Measure Access Rights worksheet contains only public measures, which are 
measures that can be optionally included in a worksheet, depending on choices made in a 
new workbook wizard. Measures that are registered as private measures will notappear in 
this worksheet. If there are no public measures available to be displayed in this 
worksheet, the worksheet will not be built. 

Measure Administration Workbook:  Using the Measure Administration Workbook, users can 
define numeric formats (suffix, prefix, scale, precision) at both metric and measure level. 
The workbook also allows controlling read-only, read-write, and denied access to 
measures. When creating a new workbook, numeric formatting defined by the Measure 
Administration workbook is copied into the workbook if user or group formatting is not 
found. The search order for format information is user, then group, then template, then 
measure,and then metric. Measure and metric formats are those defined and saved by a 
Measure Administration workbook.Measure Administration workbook has the following 
worksheetsMetric SetupMeasure SetupMeasure Security 

Measure Analysis Workbook:  The Measure Analysis Workbook template allows you to view 
data associated with any registered measure in the Retek Predictive Solutions 
applications, such as actual sales data for specified product/location/calendar 
combinations. You may also usethe Measure Analysis workbook to edit values for read-
write measures.Although a common use of the Measure Analysis Workbook is to view 
actual sales data, the workbook is not restricted to presenting sales data alone. You can 
view any data loaded into the Retek Predictive Solutions master database, such as selling 
prices,shipments, orders, etc. The Measure Analysis Wizard provides you with a list of 
all registered measures from which to select; you simply choose the measures to be 
displayed in the new workbook. 

Measure Analysis Worksheet: The Measure Analysis workbook displays data associated with 
selected registered measures, and it contains one type of worksheet, the Measure Analysis 
worksheet. A separate worksheetwill exist for each distinct product/location intersection 
associated with the measures selected in the wizard.The Measure Analysis worksheet 
allows you to view the chosen measure data for the selected products, locations, and time 
periods. Each Measure Analysis worksheet is displayed at a different dimensional 
intersection, depending on the measure selections made in the wizard. This dimensional 
intersection is shown in the worksheet title bar. 
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measure description:  The description of the measure that can be viewed in a workbook. This 
description may contain relationships and calculations. 

measure function:  Internal functions that can be used to simplify building calculations for a 
measure. 

measure identifier:  The combination of role, version, metric, and units that uniquely specifies a 
single measure. 

Measure level security:  Measures have access rights which are read-write, read-only or denied. 
Measures which are read-write or read-only may be selected in the extra measures and 
insert measure dialogs. RPAS ensures that read-only measures are not editable by the 
user and the presence of read-only measures does not affect the ability to commit a 
workbook.Measure security can be specified when the measure is registered and can be 
changed later using the Measure Administration workbook. The Measure Security sheet 
has been moved from the User and Template Administration workbook into the new 
Measure Administration workbook. When the Measure Administration workbook is 
opened, you are asked to select the set of measures you want to work with. After the 
workbook is opened, click on the Measure Security tab to see the Measure Security sheet. 
This sheet allows you to specify Read Only, Deny, or Read/Write access to a measure for 
each user.A workbook template can override the default security of a measure, but only 
narrow the security of the measure. For example, a measure could have default read-write 
access for a user and a template could specify that all users have read-only access to the 
measure when a workbook is built. However, if the default measure security was read-
only, the template could not expand the security of that measure to read-write. Measures 
which are explicitly made read-only by a workbook template will not be expanded to 
read-write access by RPAS. 

Measure locking:  The Measure Locking feature allows you to lock all at once all the cells 
associated with a given measure in a worksheet. As with individual cell locking, the 
locked status of each cell in the measure is indicated by the lock picture in each cell’s left 
portion. A locked measure is also indicated by the appearance of the lock image in the 
axis header for that measure. 

measure profile:  A worksheet-specific set of visible measures that is saved under a unique 
name. Measure profiles allow you to quickly change the measures and measure attributes 
displayed in a workbook, by enabling you to select an entire block of desired measures in 
one quick step. 

measure properties:  Administrator-defined properties that specify measure attributes. 

Measure Translations worksheet:  The Measure Translations worksheet allows you to view and 
edit the translations of measure labels. Translations are supported for each of the system’s 
allowable alternative languages. 

Menu bar:  The menu bar displays immediately under the workbook title bar. To access a 
particular command, click once on the menu label with the left mouse button. A pull-
down menu of options specific to that selection is displayed. The choices in the menu are 
context-sensitive; that is, the choices and their availability change depending on your 
current selection or mode of work. If an item is grayed out, that item is not available in 
your currentselection or work mode. For a detailed description of the menu items, see the 
topic titled Main Menu Options. 

Metric:  A measure definition with the role, version, and units omitted, such as Sales, 
Markdowns, Gross Margin. 
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Multidimensional:  Capable of containing and displaying three or more dimensions of data. 

Multidimensional databases:  Applications that run on the Retek Predictive Application Server 
use multidimensional databases to store data records. The worksheets used to display data 
are called multidimensional worksheets. In both cases, multidimensional refers to the 
manner in which data records are stored in the master database. A multidimensional 
database provides a number of significant benefits over the relational database, which is 
the typical method of storing and presenting data. This topic compares multidimensional 
and relational databases, and it describes the fundamental aspects of these databases, such 
as dimensions and hierarchies. 

N 
new measure:  A measure with undefined properties and calculations. 

New Workbook button:  Allows you to create a new workbook that includes the alert you 
selected. Clicking the New Workbook button places you in a wizard that will prompt you 
for necessary details regarding the workbook. See “Load an alert into a new workbook” 
for more information. 

Next button:  Navigates to the next step in the business process. Each distinct step is associated 
with a separate worksheet or set of worksheets. Clicking this toolbar button produces the 
same result as choosing View > Next in Flow Control.This button only appears on the 
toolbar when the open workbook template is one for which process tab control can be 
enabled. For some templates, tab control is not available.The steps in the business process 
are represented by the flow control tabs, which normally appear immediately beneath the 
application toolbar. To view the worksheet(s) associated with a particular step, you can 
simply click on the corresponding tab. 

Node:  A row or column of data. 

O 
on change calculation:  The calculation that is mapped to another measure. The other measure 

identifier will always be on the left side of the expression. 

Open-High-Low-Close:  A chart typically used in financial areas, as related to stock prices. 
Three series representing a stock’s high, low, and closing prices define each marker. 

Open Workbook button:  Allows you to open an alert workbook that was previously created. 
This button is only available on the Alert Workbooks tab. 

Ordering:  Defining the order in which calculations should be solved. 
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P 
Parent:  For any cell at a given dimensional level, the cell at the next higher dimensional level 

into which the original cell’s data values aggregate. Along a particular path of 
aggregation, a cell’s value can only roll up into one parent. For example, at the Month 
level, January, February, and March sales figures could roll up into the parent cell 
Quarter1. 

Pareto:  A chart often used in statistical areas. Bars show a variation over a period of time, and a 
cumulative curve indicates the proportion accumulated by each column in the chart. 

Percent-to-Parent Measures:  A 'percent to parent measure', or 'participation measure', is a 
measure that, fora particular measure, contains the value of the current positions as a 
proportionof the value at a 'parent' level, for example, sales as a percent of the class 
sales.These measures can be viewed and edited, and may be preconfigured through the 
RPASConfiguration Tools or dynamically defined in the RPAS client in a 
worksheet.Typical uses of this functionality will be to define measures that are 
percentage participations of sales measures. Typically these are either to a fixed level, 
such as class, so the participation of each item to the class can be viewed and 
manipulated, or are to the ‘next level up’ in the product hierarchy. 

percent contribution:  A measure attribute that specifies whether the measure displays actual 
data values, or whether the measure displays the percentage of total that each measure 
position represents relative to the next higher visible dimension in the grid. The Percent 
Contribution attribute can take on one of two values: None or Parent. None: A measure 
with a percent contribution attribute value of ‘None’ displays actual numeric data values 
for the measure in question (such as Sales Units). Parent: For the same metric, a measure 
with a percent contribution attribute value of ‘Parent’ displays for each position the 
percentage of total that the position represents relative to the next higher visible 
dimension in the grid. Also referred to as percent of parent. 

Pie:  Shows the relationship or proportions of parts to a whole. Percentages of the whole for each 
piece of the pie are calculated and displayed in the chart. 

Pivot:  To change the locations (relative to each other) of two or more hierarchy tiles on the same 
axis of a grid. This changes the display order of the data for the tiles. 

point labels:  Labels that display the data value corresponding to each marker (series or point) in 
a chart. In bar graphs, the value of each series appears in a point label above the bar. In 
line graphs, the value of each point appears in a point label above the corresponding point 
marker. You can toggle the display of point markers in your chart by selecting the Point 
Labels option on the Chart F/X quick menu. 

Pyramid:  Shows the relationship of parts to a whole in the format of a pyramid. Different point 
values in the series are represented by different colors and levels in thepyramid. 

Q 
quick menu:  A menu that contains functions specific to the screen location where the user is 

working. Clicking the right mouse button displays a quick menu. Also known as a 
context menu. 
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R 
Radar:  Plots values in polar coordinates and shows the relative importance of values over a 

period of time. 

Ranging:  To specify ranges of positions in a hierarchy over which you want to apply an alert. 
For example, you might want only one subclass of products, and not the entire product 
hierarchy, to be monitored by a particular alert. 

register (a measure):  To store the measure in a standard way on the system server. 

Resolve Alert button:  Moves a new alert to the Resolved state, which identifies that you have 
addressed the alert. 

Role:  An element in a grouping scheme that specifies a default base intersection for a group of 
measures. Roles are typically defined in order to separate related measures into groups 
associated with distinct user classes. The role-assignment process allows for the 
partitioning of measures such that users of a particular user class are only given visibility 
to measures associated with that class. When a measure is registered, it must be 
associated with a valid role component. Certain application server dialogs, such as the 
Show/Hide Measure dialog and the Insert Measure dialog, require you to designate the 
measure you want to work with. You do this by specifying all the component attributes 
(role, version, units-of-measure, and metric) that make up a measure's complete 
definition. Certain Retek applications (such as Demand Forecasting and JMI) require 
only the selection of the default role value 'None.' Planning applications, such as Retek 
Merchandise Financial Planning and Retek Item Planning, require you to make a role 
selection from the list provided. For more information on the options available, see the 
documentation for the applications, or contact your system administrator. 

roll down:  To move to a lower level of a hierarchy. 

roll up:  To move to a higher level of a hierarchy. 

Rotate:  To change the location of one hierarchy tile and its measure from one axis (y-column, x-
row, or page-slice) to another. 

Row:  On a grid, an axis or a display area that runs horizontally (x-axis). 
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S 
scaling factor:  A multiplier associated with an individual measure that is applied to each edited 

data value to speed the process of data entry. Data values entered for measures associated 
with a scaling factor are scaled to an internal value that is recognized by the server (but 
not seen on the client display). A scaling factor can be specified as a prefix or a suffix: 
Prefix: A character string that appears before each data value for a selected measure. For 
example, the prefix ‘$’ could be specified for a measure to indicate monetary data. 
Suffix: A character string that appears after each data value for a selected measure. For 
example, the suffix ‘k’ could be specified for a measure associated with a scaling factor 
of 1000; then, entering the value ‘6’ in a cell would result in the display of ‘6k’. 

Scatter:  A point chart that shows the relationship or degree of relationship between numeric 
values in several series, or plots two groups of numbers as one series of x-y coordinates. 

selection set:  The set of wizard selections made when the user proceeds normally through the 
workbook build process. A set of such choices can be saved and later applied during the 
auto build process, thus eliminating the need for the user to be present to enter choices on 
each wizard dialog when the workbook auto build is initialized. 

Slice:  On a grid, an axis or a display area that is shown by paging through worksheets. 

sort order:  On a grid, the order by which displayed dimensions are listed. Users define which 
attributes to sort by and which to prioritize. Sort order is independent of display order. 

Spread:  To allocate data obtained from a single group at a higher hierarchy level into groups in a 
lower level, in specified ratios or proportions. 

Step:  Similar to a line chart, but only vertical and horizontal line segments connect the data 
points in a series. The resulting graph appears as stairsteps. 

stored measure:  A stored measure is identical to an imported measure, except that no import 
properties are specified. If the measure is read/write, the user will be able to commit data. 
If read-only, the measure may be imported internally from another source. 

Surface:  Basically a line chart with different colors assigned to different ranges beneath the 
plotted values, depending on each point height (y value). The surface plot is usually 
displayed in a 3D representation. 
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U 
unhide (show):  To return to view a worksheet or a worksheet measure that was previously 

hidden. 

Units:  The units that define how data will be processed and displayed. In dialogs that prompt 
you to specify the units for measures, the choices and their meanings are as follows: 
Check = checkbox (Boolean) C = cost C% = cost value % variance or contribution D = 
date Select = picklist Stores = number of stores V = retail value V = retail value V% = 
retail value % variance or contribution Text = text True-False = true-false (Boolean) U = 
units U% = units % variance or contribution No Units = used within Retek Merchandise 
Financial Planning for ratios, Average Unit Retail (AUR) 

Unresolve Alert button:  Moves a resolved alert to the New state, which indicates that you must 
readdress the alert. 

unused measure:  A measure with no relationships (that is, with no measures referencing it in 
their calculations). 

user group:  A subset of application users to which a given user belongs. Users must be assigned 
to a user group. Assigning users to groups provides a level of security into workbooks 
that users create and save. When users save a workbook, they assign one of three access 
permissions to the workbook: allow any user to open and edit the workbook, allow only 
those users in their same group to open and edit the workbooks, or allow no other users to 
open and edit the workbook. Users are typically assigned to groups based on similarities 
in job functions. Users in the same group can be given access to workbooks that belong 
to that group alone. User groups are defined in the User Account Management workbook, 
and viewed in the Groups Worksheet of the User & Template Administration workbook. 

V 
Version:  An element in a grouping scheme that allows for partitioning of measures based on 

workflow or data source. Versions are typically defined in order to allow for the 
maintenance of distinct measure values along a workflow timeline. For example, an 
original plan value for sales can be defined pre-season and later compared to a current 
plan value for the same measure in-season. When a measure is registered, it must be 
associated with a valid version component. Certain application server dialogs, such as the 
Show/Hide Measure dialog and the Insert Measure dialog, require you to designate the 
measure you want to work with. You do this by specifying all the component attributes 
(role, version, units-of-measure, and metric) that make up a measure's complete 
definition. Certain Retek applications (such as Demand Forecasting and JMI) require 
only the selection of the default version value 'None.' Planning applications, such as 
Retek Merchandise Financial Planning and Retek Item Planning, require you to make a 
version selection from the list provided. For more information on the options available, 
see the documentation for the applications, or contact your system administrator. 
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W 
watch measure:  A custom measure that is used as the basis for an alert. 

Wizard:  A set of screens that guide you through the process of creating a new workbook or 
performing other actions in an application, by asking you various questions and having 
you select values. 

Workbook:  The framework used for displaying data and user functions. Workbooks are task-
specific and may contain one or more worksheets. Users can define the format of their 
workbooks. See also workbook template, worksheet. 

workbook template:  The framework for creating a workbook. You build each new workbook 
from an existing workbook template, such as Pre-Season Financial Plan or Forecasting 
Administration. Several workbook templates are supplied with the Retek Predictive 
Solutions, and are available for selection when you choose File ? New to create a new 
workbook. 

Worksheet:  A multidimensional spreadsheet used to display workbook-specific information. 
Worksheet data can also be displayed in chart format. 

Z 
Zoom:  When working with a grid, the zoom feature enlarges the grid contents of the active 

window for easier viewing, or reduces the size of the contents in order to fit as much data 
on the terminal display as possible. 
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