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Customer Support  
Customer Support hours 

Customer Support is available 7x24x365 via email, phone, and Web access.  

Depending on the Support option chosen by a particular client (Standard, Plus, or Premium), the 
times that certain services are delivered may be restricted. Severity 1 (Critical) issues are 
addressed on a 7x24 basis and receive continuous attention until resolved, for all clients on active 
maintenance. Retek customers on active maintenance agreements may contact a global Customer 
Support representative in accordance with contract terms in one of the following ways. 

Contact Method Contact Information 

E-mail     support@retek.com 

Internet (ROCS)  rocs.retek.com 
     Retek’s secure client Web site to update and view issues 

Phone    +1 612 587 5800 

Toll free alternatives are also available in various regions of the world: 

Australia   +1 800 555 923 (AU-Telstra) or +1 800 000 562 (AU-Optus) 
France    0800 90 91 66 
Hong Kong   800 96 4262 
Korea    00 308 13 1342 
United Kingdom 0800 917 2863 
United States  +1 800 61 RETEK or 800 617 3835 

Mail     Retek Customer Support 
     Retek on the Mall 
     950 Nicollet Mall 
     Minneapolis, MN 55403 

When contacting Customer Support, please provide: 

• Product version and program/module name. 

• Functional and technical description of the problem (include business impact). 

• Detailed step-by-step instructions to recreate. 

• Exact error message received. 

• Screen shots of each step you take. 

 

http://rocs.retek.com/
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Introduction 
Retek® Integrated Store Operations (ISO) - Object Library and Tools Receipt & Report 
Builder™ (Receipt & Report Builder) is a Java-based design program for visually customizing 
and building receipts. From content to design, Receipt & Report Builder allows you to format the 
content of receipts by dragging and dropping business object attributes into selected areas. By 
creating a sample of a transaction for which a receipt will be assigned to, you can graphically 
“program by example” the instructions that Receipt & Report Builder will use to format the 
transaction receipt. Also, you can store receipts in an electronic journal for auditing purposes. 
Receipt & Report Builder requires minimal programming knowledge to modify, create, and 
maintain receipt blueprints against sample transactions. 

Before you begin using Receipt & Report Builder, you should be familiar with the following 
terms: 

• Receipt blueprints—control the formatting and printing of receipts against transactions. A 
receipt blueprint can contain multiple receipt reports against a single transaction type. The 
receipt blueprint is the repository of instructions that Receipt & Report Builder will use to 
format a receipt. 

• Receipt reports—are contained within receipt blueprints. Each receipt report is associated 
with the individual printed documents or receipts. A receipt report specifies instructions that 
apply to each printed receipt as a whole and is the container for the report sections or 
line groups. 

• Receipt line groups—control the printing of iterating structure. Receipt line groups are used 
to separate header and footer information from a detail section of a receipt so the header and 
footer information is not repeated for each detail line. Receipt line groups contain receipt 
data elements. 

• Receipt data elements—are the building blocks of a receipt. There are two kinds of receipt 
data elements: static (parts of the receipt that are printed as they appear in the receipt 
blueprint) and method (parts of the receipt that the information is extracted from a business 
object after a transaction is invoked). 

• Receipt sample data object (RDO)—is the example transaction that is used to build 
a blueprint. There is no existing library or RDOs. RDOs are created real-time. 

• Receipts—are the physical pieces of paper that print when a receipt report is invoked against 
a transaction. 

• Footers—can be attached to a receipt blueprint. Footers consist of one footer line group and 
either single or multiple footer data elements. 

For example, within the Receipt & Report Builder library of receipt blueprints, there is a receipt 
blueprint for a layaway transaction. The layaway receipt blueprint contains multiple receipt 
reports. Each receipt report represents a different type of receipt that will be printed after a 
layaway transaction is completed: customer, store, layaway box, and electronic journal. Each 
receipt report is made up of different receipt line groups that contain receipt data elements that 
dictate the information that appears on each receipt. 
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In order to modify a receipt blueprint, run the application and generate the appropriate 
transactions. When generating a transaction, you must include the information that pertains to the 
part of the receipt that you are modifying. For example, you decided to modify the information 
printed on a receipt for a payment using a Mastercard. First, you must generate a sales transaction 
using a Mastercard. Afterwards, use the generated RDO sample as the example when you modify 
that receipt blueprint. 

 Note: For performance reasons, by default, RDOs are not automatically generated. To 
automatically generate RDOs, modify the PRODUCE_RDO= tag in the 
JPOS_peripherals.cfg file.  

Receipt & Report Builder has a library of over 50 receipt blueprints. The library of receipt 
blueprints serve as a design layout for receipts printed against every transaction in the system. 
You can modify and customize all receipt blueprints. 

 Note: Receipt blueprints have a .bpt extension and can be found in the 
\files\prod\receiptblueprints folder. 

Receipt & report builder workspace 
The Receipt & Report Builder workspace is a single window consisting of the following 
components: 

• Menu bar 

• Toolbar (with command buttons) 

• Panes 

 
Receipt & Report Builder workspace 
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Receipt & report builder menus 
Receipt & Report Builder contains the following menus: 

• File 

• Edit 

• View 

• Option 

• Help 

File menu 
Using the File menu, you can create, save, open, and print a receipt blueprint. page 4 lists and 
describes the menu options on the File menu. 

 
File menu 

 

File Menu Options 

Menu Option Description 

New Receipt Blueprint* Allows you to create a new receipt blueprint. 

Open Receipt Blueprint* Allows you to open an existing receipt blueprint. 

Save Receipt Blueprint* Allows you to save a receipt blueprint. 

Print Receipt Blueprint Sample* Allows you to print a sample of a receipt blueprint. 

Attach Receipt Sample Data 
Object* 

Allows you to open an RDO and attach it to a 
receipt blueprint. 

Detach Receipt Sample Data Allows you to detach an RDO from a receipt blueprint. 
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File Menu Options 

Menu Option Description 

Object* 

Close Allows you to close an open receipt blueprint. 

Exit Allows you to exit Receipt & Report Builder. 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 

 Note: The menu options will vary when working with footers.  

Edit menu 
Using the Edit menu, you can create and edit existing receipt blueprints. page 6 lists and 
describes the menu options on the Edit menu. 

 
Edit menu 
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 Edit Menu Options 

Menu Option Description 

Delete Receipt Report* Allows you to delete a receipt report from a receipt. 

Add Receipt Line Group* Allows you to add a receipt line group to a receipt report.

Delete Receipt Line Group* Allows you to delete a receipt line group from a receipt 
report. 

Move Line Group Up* Allows you to move a receipt line group up in the order 
of appearance on a receipt report. 

Move Line Group Down* Allows you to move a receipt line group down in the 
order of appearance on a receipt report. 

Add Receipt Element* Allows you to add receipt data elements to a receipt 
report. 

Delete Receipt Element* Allows you to delete receipt data elements to a receipt 
report. 

Add Receipt Report* Allows you to add a receipt report to a receipt. 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 

 Note: The menu options will vary when working with footers.  
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View menu 

 
View menu 

View Menu Options 

Menu Option Description 

Footers Allows you to open the footer workspace. 

Language 
(English, Spanish, and French) 

Allows you to maintain multiple versions of a receipt 
blueprint based on language. 

 Note: The menu options will vary when working with footers.  

Option menu 

 
Option menu 
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Option Menu Options 

Menu Option Description 

Show Toolbar Allows you to show and hide the toolbar.  

Window Skins 
(Metal, CDE/Motif, and Windows) 

Allows you to change the look and feel of the 
Receipt & Report Builder. 

 

Help menu 
The Help menu allows you to access online help topics and an online version of this user guide.  

 
Help menu 

Shortcut keys 
Receipt & Report Builder allows you to invoke certain commands or functions using a 
combination of keyboard keys or keystroke combinations. The table below lists and describes the 
shortcut keys in Receipt & Report Builder. 

Shortcut keys 

Action Result 

CTRL + N Creates a new receipt blueprint. 

CTRL + O Opens an existing receipt blueprint. 

CTRL + S Saves the active receipt blueprint. 

CTRL + P Prints the active receipt blueprint. 

CTRL + R Attaches an RDO to a receipt blueprint. 

CTRL + D Detaches an RDO to a receipt blueprint. 

CTRL + Up Moves a receipt line group up one receipt line group. 

CTRL + Down Moves a receipt line group down one receipt line group. 
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Shortcut keys 

Action Result 

CTRL + A Adds a receipt element to a receipt blueprint. 

CTRL + C Closes Receipt & Report Builder. 

CTRL + X Exits Receipt & Report Builder. 

CTRL + F Opens the Footer workspace. 

Delete Deletes a receipt data element from a receipt report. 

Toolbar and command buttons 
The Receipt & Report Builder toolbar contains command buttons that allow you to perform 
specific commands and functions with the press of a button.  

 
Toolbar and command buttons 
When opening Receipt & Report Builder, several command buttons on the toolbar are unavailable 
and appear dimmed. Only the New Receipt Blueprint and the Open Receipt Blueprint 
command buttons appear available when opening Receipt & Report Builder. To make the 
remaining command buttons available, you must either open or create a new receipt blueprint. 

 Note: To view the definition of a command button, hover the cursor over the button. 

 Receipt & Report Builder Command Buttons 

Command Button Button Description 

New Receipt Blueprint 
 

 

Allows you to create a new 
receipt blueprint. 

Open Receipt Blueprint 
 

 

Allows you to open an existing 
receipt blueprint. 

Save Receipt Blueprint 
 

 

Allows you to save a 
receipt blueprint. 
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 Receipt & Report Builder Command Buttons 

Command Button Button Description 

Print Receipt Blueprint 
 

 

Allows you to print a 
receipt blueprint. 

Attach Receipt Sample 
Data Object  

 

Allows to you attach an RDO to 
a receipt blueprint. 

Detach Receipt Sample 
Data Object  

 

Allows you to detach an RDO 
from a receipt blueprint. 

Add Receipt Report 
 

 

Allows you to add a receipt 
report to a receipt. 

Delete Receipt Report 
 

 

Allows you to delete a receipt 
report from a receipt. 

Add Receipt Line Group 
 

 

Allows you to add a receipt line 
group to a receipt report. 

Delete Receipt Line Group 
 

 

Allows you to delete a receipt 
line group from a receipt report.

Move Receipt Line Group Up 
 

 

Allows you to move a receipt 
line group up in the order of 
appearance on a receipt report. 

Move Receipt Line Group 
Down  

 

Allows you to move a receipt 
line group down in order of 
appearance on a receipt report. 
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 Receipt & Report Builder Command Buttons 

Command Button Button Description 

Add Receipt Element 
 

 

Allows you to add a receipt 
element to a receipt report. 

Delete Receipt Element 
 

 

Allows you to delete a receipt 
element from a receipt report. 

Footer 
 

 

Allows you to open the 
Footer workspace and create 
and modify footers. 

Panes 
Panes are the working area of Receipt & Report Builder. Each pane graphically displays the 
layout and attributes of receipt blueprints, RDOs, and receipt data elements. Receipt & Report 
Builder consists of the following panes: 

• Receipt Report pane—Displays the physical layout of the receipt element. 

• Receipt Attributes pane—Displays receipt properties and attributes that you can modify. 

• Receipt Data Element Attributes pane—Displays receipt data element values and attributes 
that you can modify. 

• Receipt Sample Data Objects pane—Displays data fields that are available to print on 
a receipt. 

 Note: The Report Footer pane and the Footer Data Element Attributes pane are 
displayed in the Footer workspace.  
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Receipt report pane 
The Receipt Report pane displays the layout and design of a receipt. Receipt reports are made up 
of receipt line groups and receipt data elements. The attributes of receipt data elements are 
displayed in the Receipt Data Element Attributes pane when a data element is selected. 

 Note: Method elements appear italicized in the Receipt Data Element Attributes pane. 

 

Receipt Report pane 
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Receipt attributes pane 
The Receipt Attributes pane displays the general properties and attributes of a receipt blueprint. 
The pane is tabular and divided into two columns—Attribute and Value. 

 Note: For more information on configurable receipt attributes, see “Defining 
Receipt Attributes”. 

 
Receipt Attributes pane 

Receipt data element attributes pane 
When receipt data elements in the Receipt Report pane are selected, their attributes are displayed 
in the Receipt Data Element Attributes pane. The pane is tabular and divided into two 
columns—Attribute and Value. Changes to receipt data element attributes are based on whether 
you select a static or method element.  

 
Receipt Data Element Attributes pane 
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Receipt sample data objects pane 
The Receipt Sample Data Object pane displays data fields that are available for the user to print 
on a receipt. You can drag and drop an RDO from the Receipt Sample Data Objects pane into 
the receipt data element fields on the Receipt Report pane.  

 
Receipt Sample Data Objects pane 
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Edit a receipt blueprint 
Retek® Integrated Store Operations (ISO) - Object Library and Tools Receipt & Report 
Builder™ (Receipt & Report Builder) includes over 50 receipt blueprints and sample transactions 
for you to customize and modify. You can modify the receipt layout, add receipt line groups, 
attach or detach a receipt sample data object (RDO), and place fixed data elements by using the 
menu and toolbar selections.  

 Note: Receipt blueprints have a .bpt extension and can be found in the 
\files\prod\receiptblueprints folder.  

Receipt & Report Builder has the following receipt blueprint editing features: 

• Attaching an RDO to a receipt blueprint 

• Detaching an RDO to a receipt blueprint 

• Adding receipt line groups 

• Deleting receipt line groups 

• Moving receipt line groups 

• Adding receipt data elements 

• Deleting receipt data elements 

• Defining the attributes of receipt data elements 

• Defining receipt attributes 

Open a receipt blueprint 
Before you can begin customizing or modifying a receipt blueprint, you must first open a receipt 
blueprint from the receipt blueprint and sample transaction library. 

 Note: See Appendix B for a list of receipt blueprints and sample transactions that are 
included with Receipt & Report Builder. 

To open a receipt blueprint: 

1. Select File>Open Receipt Blueprint. 
OR 
Click the Open Receipt Blueprint button. 

 
OR 
Press and hold CRTL and O (CTRL+O) at the same time. This is the shortcut key for 
opening a receipt blueprint. The Open dialog box is displayed. 
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2. Navigate to the receipt blueprint directory. 

 Note: The default path is \files\prod\receiptblueprints. 

3. Select the appropriate receipt blueprint.  

 Note: Receipt blueprints have a .bpt extension. 

4. In the Open dialog box, click the Open button. The attached RDO, receipt layout, and 
attributes of the selected receipt blueprint are displayed in the appropriate panes. 
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Print a receipt blueprint sample 
While creating or modifying a receipt blueprint, you can print the receipt blueprint to view a 
hardcopy sample of the receipt blueprint. Printing a copy of the receipt blueprint allows you to 
compare the softcopy version of the receipt blueprint to a printed copy of the receipt. 

To print a receipt blueprint sample: 

• Select File>Print Receipt Blueprint Sample. 
OR 
Click the Print Receipt Blueprint Sample button. 

 
OR 
Press and hold CRTL and P (CTRL+P) at the same time. This is the shortcut key for 
printing a receipt blueprint sample. A hardcopy sample of the selected receipt blueprint is 
printed to an attached printer. 

 Note: You must attach an RDO before printing a receipt blueprint. If you do not have an 
RDO attached to the receipt blueprint, the Print Error dialog box is displayed. To close 
the dialog box, click OK. 

 
   

Attach and detach receipt sample data objects 
The Retek® Point of Sale and Cash Management™ application overwrites an RDO (for example, 
comSCompositePOSTransaction.rdo) every time POS creates and completes a transaction. An 
RDO is similar to a serialized business object—it is an example to build a receipt against. An 
RDO is used as a sample to graphically instruct the application where to find the variable data 
elements for a receipt. In order to modify method elements in an existing receipt blueprint, you 
must attach an RDO to the receipt blueprint.  

 Note: A receipt data object is created after you complete a transaction. 

Saving a receipt blueprint with an attached RDO is convenient for frequent modification of the 
receipt blueprint. However, it is best practice to detach the RDO before saving the receipt 
blueprint at the end of the day. 

 Note: You can explore a serialized business object by clicking on the tree nodes in the 
Receipt Sample Data Object pane. 
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Attach a receipt sample data object 
To attach an RDO to a receipt blueprint: 

1. Open a receipt blueprint. 

2. Select File>Open Receipt Sample Data Object. 
OR 
Click the Open Receipt Sample Data Object button. 

 
  The Open dialog box is displayed. 

 
3. Navigate to the receipt blueprint directory.  

 Note: The default path is \files\prod\receiptblueprints. 

4. Open the appropriate RDO. The selected RDO is displayed in the Receipt Sample 
Data Object pane. 

 
 Note: You must complete a transaction before you can create an RDO. 

 Note: Receipt sample data objects files have an .rdo extension. 

5. After you find a method that returns the appropriate result, drag the method on an existing 
data element in the Receipt Report pane. The result of that method, defined in the instance 
of the object at run time, will be printed at that location. 
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Detach a receipt sample data object 
To detach an RDO: 

1. Open a receipt blueprint. 

2. Select File>Detach Receipt Sample Data Object. 
OR 
Click the Detach Receipt Sample Data Object button. 

 
   

The Detach Data Object dialog box is displayed. 

 
3. In the Detach Data Object dialog box, click OK. The selected RDO is removed from the 

Receipt Sample Data Object pane, and the RDO is detached from the receipt blueprint. 

Receipt line groups 
Receipt line groups control the printing of the iterating structure of a receipt. Receipt line groups 
are used to separate heading and footer information from a detail section of a receipt so that the 
heading and footer information is not repeated for each detail line. You can use multiple sets of 
receipt line groups for a single receipt blueprint. 

Every data element in a receipt line group is printed for every occurrence of a repeating data 
element. For instance, if you have a data element whose value is derived from a method under an 
array (for example, price of a line item) each price in the array will be printed in turn until the 
array is exhausted. As each occurrence prints, any fixed elements in the receipt line group will 
also reprint.  

Add receipt line groups 
To add a receipt line group: 

1. Open a receipt blueprint. 

2. Select Edit>Add Receipt Line Group. 
OR 
Click the Add Receipt Line Group button. 

 
The new receipt line group is displayed below the last receipt line group in the 
Receipt Report pane. 
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3. If you want to add more receipt line groups, repeat step 2. 

After adding a receipt line group, the Receipt Attributes pane allows you to add attributes to the 
receipt data elements. For more information on defining the attributes of a receipt, see “Defining 
Receipt Elements”. 

Delete receipt line groups 
To delete receipt line groups: 

1. Open a receipt blueprint. 

2. Select the receipt line group you wish to delete. The selected receipt line group is outlined 
in yellow. 
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3. Select Edit>Delete Receipt Line Group.  
OR 
Click the Delete Receipt Line Group button. 

 
The Delete Line Group dialog box is displayed. 

 
4. In the Delete Line Group dialog box, click OK. The selected receipt line group is no longer 

displayed in the Receipt Report pane. 

5. If you want to delete more receipt line groups, repeat steps 2-4. 

Reorder receipt line groups 
Receipt & Report Builder allows you to graphically move receipt line groups up and down to 
reorder and customize the appearance of a receipt report. 

Move a receipt line group up 
To move a receipt line group up: 

1. In the Receipt Report pane, select the receipt line group you want to move up. The selected 
receipt line group is outlined in yellow. 
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2. Select Edit>Move Line Group Up. 
OR 
Click the Move Line Group Up button 

 
OR 
Press and hold CTRL and ARROW UP (CTRL+ARROW UP) at the same time. This is the 
shortcut key for moving a receipt line group up. The selected receipt line group is moved up 
one receipt line group. Also, the receipt line group is renamed according to its position on the 
receipt layout. For example, the second receipt line group in a receipt report is named 
Line Group 2. 

 
3. To move the selected receipt line group up another receipt line group, repeat step 2. 
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Move a receipt line group down 
To move a receipt line group down: 

1. In the Receipt Report pane, select the receipt line group you want to move down. The 
selected receipt line group is outlined in yellow. 

 
2. Select Edit>Move Line Group Down. 

OR 
Click the Move Line Group Down button 

 
OR 
Press and hold CTRL and ARROW DOWN (CTRL+ARROW DOWN) at the same time. 
This is the shortcut key for moving a receipt line group down. The selected receipt line group 
is moved down one receipt line group. Also, the receipt line group is renamed according to its 
position on the receipt report. For example, the second receipt line group in a receipt report is 
named Line Group 2. 



Retek Point-of-Sale 
 

 

24 

 
3. To move the selected receipt line group down another receipt line group, repeat step 2. 

Add and delete receipt data elements 
Receipt data elements are the building blocks of a receipt. There are two type of receipt data 
elements: 

• Static elements—Parts of the receipt that print as they appear on the Receipt Report pane. 
Headings are an example of a static element (for example, Total Amount Due). 

• Method elements—Parts of the receipt in which information is extracted from a business 
object, and they are displayed on the printed receipt. The appearance of a method element 
varies from what you see on the Receipt Report pane and what appears on the printed 
receipt. The information that is extracted from the business object is what appears on the 
printed receipt (for example, the monetary amount that represents the total amount the 
customer owes). 

 Note: In Receipt & Report Builder, method elements are italicized. 
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Receipt data elements are added to receipt line groups in the Receipt Report pane, and they are 
modified in the Receipt Data Element Attributes pane.  

Add a receipt data element 
To add a receipt data element: 

1. Select the appropriate receipt line group. The selected receipt line group is outlined in yellow. 
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 Note: If you are creating a new receipt blueprint, you will need to add receipt line groups 
before you can add receipt elements. 

2. Select Edit>Add Receipt Element. 
OR 
Click the Add Receipt Element button. 

 
OR 
Press and hold CRTL and A (CTRL+A) at the same time. This is the shortcut key for adding 
a receipt element. The new receipt data element is added after the last receipt data element in 
the selected receipt line group. 

 
 Note: If you have not selected a receipt line group, the Indicate Line Group dialog box 

is displayed. To close the dialog box, click OK. 
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Reorder receipt data elements 
After adding a receipt data element, you can reorder the receipt data element within the receipt 
line group by dragging and dropping the receipt data element in a different location in a receipt 
line group. 

To reorder a receipt data element: 

1. Select the appropriate receipt data element. The selected receipt data element is outlined 
in yellow. 

 
2. Drag the selected receipt data element to the desired location in the Receipt Report pane. 

A green field with an arrow is displayed to indicate where the selected receipt data element 
will be placed. 
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3. Drop the selected receipt data element in the desired location. The receipt data element is 

displayed in a new location. 

 
 Note: Receipt elements can be dragged and dropped between different receipt line 

groups. 
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Delete a receipt data elements 
To delete a receipt data element: 

1. Select the appropriate receipt data element. The receipt data element is highlighted in yellow. 

 
2. Select Edit>Delete Receipt Element.  

OR 
Click the Delete Receipt Element button. 

 
OR 
Click the Delete button. This is the shortcut key for deleting a receipt data element. The 
Delete Element dialog box is displayed. 

 
3. In the Delete Element dialog box, click OK. The receipt data element is no longer displayed 

in the Receipt Report pane. 



Retek Point-of-Sale 
 

 

30 

 

Define receipt data element attributes 
Receipt & Report Builder allows you to change the attributes of static receipt elements. Because 
method elements depend on information extracted from business elements, you cannot modify 
their attributes. 

To define the attributes of a static element: 

1. Select the static element you wish to change. The selected receipt data element is highlighted 
in yellow, and the attributes of the selected receipt data element are displayed in the 
Receipt Data Element Attributes pane. 
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2. In the Receipt Data Element Attributes pane, select the appropriate attribute. The attribute 
is highlighted in blue. 

 
 Note: To change the attribute of a receipt element in the Depends on the Presence of or 

the Value to Print fields, click the Value field and select a value from the drop-down 
list. 

 
3. Define the new value for the element attributes. 
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 Note: The new attribute or value of the selected receipt data element is displayed in the 

Receipt Report pane. 
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Interpret receipt data element attributes 
The table below lists receipt data element attributes, type of elements, how attribute values are 
defined, and the printed result of the defined attribute. 

Receipt Data Element Attributes 

Attributes Static 
Element 

Method 
Element Value Description 

Depends on 
Presence of Yes  

User supplied. Click in the 
value field to display a drop-
down list of available values. 
Dependencies can include any 
method elements within the 
same receipt line group. 

Prints the attribute if the 
dependency assigned to it 
is present. 

Value to Print Yes Yes 

User supplied. Enter the value 
for this attribute or select a 
value from the drop-down 
menu. 

Prints the entered text or 
displayed value in the 
value field. 

Fixed Length Yes Yes 

System supplied for static 
elements. User supplied for 
method elements. Enter a fixed 
number of character spaces. 

Prints only the fixed number of 
characters set by the user for 
an object element. For 
example, if you fix the length 
of a customer first name object 
to five, only the first five 
letters of the customer's first 
name will print. 

Is Line Feed Yes Yes 

User supplied. Select the check 
box to apply Is Line Feed as a 
value to the receipt data 
element. 

Prints the selected receipt data 
element on the next line. 

Is Double Width 
Font Yes Yes 

User supplied. Select the check 
box to apply Is Double Width 
Font as a value to the receipt 
data element. 

The selected receipt data 
element prints double the 
width of normal printed receipt 
data elements. 

Is Printed as 
Barcode Yes Yes 

User supplied. Select the check 
box to apply Is Printed as 
Barcode as a value to the 
receipt data element. 

Prints the selected receipt data 
element as a barcode. 
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Receipt Data Element Attributes 

Attributes Static 
Element 

Method 
Element Value Description 

Justified  Yes 

User supplied. Select the value 
field to display a drop-down 
list of available values. 
Justified values include: left, 
center, and right. 

Prints the selected receipt 
data element left, center, or 
right justified. 

Is Preceded by 
Space  X 

User supplied. Select the check 
box to apply Is Preceded by 
Space as a value to the receipt 
data element. 

Prints a space before the 
selected element. 

Object Navigation 
Path  Yes System supplied. Non-printable. Shows the 

object information. 

The table below shows the additional values for the DoubleValue object element . 

Values for the double value Object 

Attribute Value Result 

Is Sign Reversed 

User supplied. Select 
the check box to 
apply Is Sign 
Reversed to the 
receipt data element.

The numeric value is multiplied by -1. 

Lead Format User supplied. Enter 
the value. 

Prints the Lead Format value in front of the number. For 
example, if you type $, and the number returned by the object is 
10, then $10 is printed. 

Trail Format User supplied. Enter 
the value. 

Prints the Trail Format value immediately after the number. For 
example, if you type $, and the number returned is 10, then 10$ 
is printed. 

Lead Format if Neg User supplied. Enter 
the value. 

Prints the lead format for a negative number in front of the 
number. For example, if you type -$, and the number returned is 
10, then -$10 is printed. 

Trail Format if Neg User supplied. Enter 
the value. 

Prints the trail format for a negative number immediately after 
the number. For example, if you type -$, and the number 
returned is 10, then 10-$ is printed. 
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Values for the double value Object 

Attribute Value Result 

Decimal Places 
Shown 

User supplied. Enter 
a numeric value. 

Prints the number with the decimal value assigned. For example 
if you type 3, and the number returned is 10.23475, then 10.234 
is printed. 

Is printed when 
zero 

User supplied. Select 
the check box to 
assign Is printed 
when zero to the 
receipt data element.

If checked, prints the values returned as zero. 
If unchecked, does not print values returned as zero. 

Define receipt attributes 
Receipt attributes are those values assigned to a receipt. The available attributes are displayed in 
the Receipt Attributes pane. 

Interpret Receipt Attributes 
The table below lists receipt attributes, how the value of an attribute is defined, and the printed 
result of each attribute. 

Status bar features 

Attribute Value Result 

Name User supplied. Enter the name of the 
receipt. Non-printable. For your reference only. 

Store Count User supplied. Enter a numeric value. Prints the defined number of receipts as 
store copies. 

Customer Count User supplied. Enter a numeric value. Prints the defined number of receipts as 
customer copies. 

Electronic 
Journal 

User supplied. Check the check box to print 
a copy of the receipt to the electronic 
journal. 

If selected, a copy of the receipt is printed 
to the electronic journal. 

Store Footer 

User supplied. Click in the value field to 
display a list of available footers. If there 
are no footers available, the NO FOOTERS 
value is displayed. 

Prints the attached receipt footer. 
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Status bar features 

Attribute Value Result 

Print Store Logo User supplied. Click to check the box and 
assign Print Store Logo as the value. Prints the store logo if the box is checked. 

Define a receipt name 
To define the name of the receipt: 

1. In the Receipt Attributes pane, select the Name value field. The selected row is highlighted 
in blue. 

 
2. Enter the receipt name and press the Enter key.  
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Define the number of receipts printed to the store 
To define the number of receipts printed to the store: 

1. In the Receipt Attributes pane, select the Store Count value field. 

 
2. Enter the number of printed store copy receipts and press the Enter key. 

 
 Note: The default value for the number of receipts printed to the store is zero. 
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Attach a footer to a receipt blueprint 
Before you can attach a footer to a receipt blueprint, you must create footers. After you have 
created footers, you can attach any footer to a receipt blueprint. 

 Note: If there are no footers, the only available option is No Footer. 

To add a footer to a receipt blueprint: 

1. In the Receipt Attributes pane, select the Store Footer drop-down value field. 

 
2. Select a value from the drop-down list. The selected value is displayed in the Store Footer 

value field. 
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Print receipts to an electronic journal 
An electronic journal stores electronic copies of printed receipts. If the Electronic Journal option 
is checked, Receipt & Report Builder will send a copy of the printed receipt in the form of a text 
file to the electronic journal. You can access and view the text files in the POS application using 
the Reports option in the Management Menu window. 

To print receipts to an electronic journal: 

• In the Receipt Attributes pane, select the check box in the Electronic Journal value field. 

 

Print a store logo on a receipt 
Receipt & Report Builder allows you to print the company or store logo on the receipts. The 
location of the image file of the logo is stored in a configuration file so you do not have to specify 
the image file or the location of the image file to print the logo. By default, the logo is printed at 
the top of the receipt in the header area. 

To print a store logo on a receipt: 

• In the Receipt Attributes pane, click the checkbox in the Print Store Logo value field. 
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Save a modified receipt blueprint 
To save a modified receipt blueprint: 

1. Select File>Save Receipt Blueprint. 
OR 
Click the Save Receipt Blueprint button. 

 
OR 
Press and hold CRTL and S (CTRL+S) at the same time. This is the shortcut key for saving 
a receipt blueprint. The Save dialog box is displayed. 

 
2. Click Save. The Replace Existing File? dialog box is displayed. 

 
3. In the Replace Existing File? dialog box, click OK. The file is updated with the new version. 

 Note: If you do not want to replace the existing file with the updated file, click the 
Cancel button in the Replace Existing File? dialog box. 
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Close a receipt blueprint 
To close a receipt blueprint: 

1. Select File>Close. 
OR 
Press and hold CRTL and C (CTRL+C) at the same time. This is the shortcut key for 
closing a receipt blueprint. The Save Changes dialog box is displayed. 

 
2. To save changes and close the receipt blueprint, click Yes. 

OR 
To close the receipt blueprint without saving changes, click No. 
OR 
To cancel closing the receipt blueprint, click the Cancel button. 

Exiting receipt/report builder 
To exit Receipt & Report Builder: 

• Select File>Exit. 
OR 
Press and hold CRTL and X (CTRL+X) at the same time. This is the shortcut key for exiting 
Receipt & Report Builder. The Receipt & Report Builder application is closed. 
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Create a new receipt blueprint 
Retek® Integrated Store Operations (ISO) - Object Library and Tools Receipt & Report 
Builder™ (Receipt & Report Builder) allows you to create receipt blueprints for the POS 
application based on transactional data. After saving a receipt blueprint, you can print receipts 
against the receipt blueprint. The following are steps to creating a new receipt: 

1. Create a receipt blueprint. 

2. Invoke the receipt. 

 Note: Before you begin creating a new receipt, see Appendix B for a library of receipt 
blueprints and sample transactions that comes with Receipt & Report Builder. 

Create a new receipt blueprint 
 Note: Before you begin creating a new receipt blueprint, you may have to serialize a 

sample of the business object you wish to report against. For more information, see 
Appendix A, “Serializing a Business Object.” 

 Note: The Java code for a POS GUI window must be modified to allow a new receipt 
blueprint file name to be called at the appropriate window. If there is an existing receipt 
that prints at the desired window, it is recommended that you modify that receipt 
blueprint rather than create a new receipt blueprint. 

 Note: Receipt blueprints have a .bpt extension and can be found in the 
\files\prod\receiptblueprints folder.  

To create a new receipt blueprint: 

1. Select File>New Receipt Blueprint. 
OR 
Click the New Receipt Blueprint button. 

 
  The Enter Blueprint Name dialog box is displayed. 

 
2. In the Enter Blueprint Name dialog box, enter the name of the receipt blueprint. 

 Note: Do not type the .bpt file extension to the filename. Receipt & Report Builder 
automatically attaches the .bpt file extension to the filename. 
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3. Click OK. The appropriate panes are displayed. 

 
4. In the Receipt Attributes pane, enter the receipt blueprint name. 
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5. Attach a receipt sample data object (RDO). The RDO is the business object you serialized 
before you created a receipt blueprint. The attached RDO is displayed in the Receipt Sample 
Data Object pane.  

 
6. Add the appropriate number of receipt line groups. Each added receipt line group contains 

one default static receipt element. The the receipt line groups are displayed in the 
Receipt Report pane. After adding a receipt line group, the Receipt Data 
Elements Attributes pane is displayed.  

 
7. In the line groups, add receipt data elements. The receipt data elements are displayed in the 

Receipt Report pane.  

 
8. Define the receipt element attributes. 
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9. Define the receipt attributes.  

10. To print and review a copy of the receipt, select File>Print Receipt Blueprint Sample. 
OR 
Click the Print Blueprint Sample button. 

 
OR 
Press and hold CRTL and P (CTRL+P) at the same time. This is the shortcut key for 
printing a receipt blueprint sample. 

11. To detach the RDO, select File>Detach Receipt Sample Data Object. 
OR 
Click the Detach Receipt Sample Data Object button 

 
12. Save the receipt.  

13. Define the name of the receipt in the ReceiptBlueprintInventory class. 

Invoke the receipt 
The final step to creating a new receipt is invoking the receipt within Receipt & Report Builder.  

To invoke the receipt within the application: 

1. Return to the section of the code where you want to print the receipt.  

2. Remove the code that serializes the sample object. 

 Note: You may want to omit this step for performance reasons and perform it only when 
testing with receipts. 

3. Instantiate a ReceiptFactory by passing the sample object as the first member of an array 
(the object you serialized in the beginning and the object you are reporting against). 
The following is an example of the code for the receipt blueprint name: 

Object[] arguments= {MyReportableObjectAppModel }; 
ReceiptFactory receiptFactory=new ReceiptFactory (arguments, 
ReceiptBlueprintInventory.MyNewReceipt); 

4. Localize the receipt so it prints in the appropriate language for the customer and the store. 
The following is an example of the code: 

ReceiptLocalSetter localeSetter=new RecieptLocaleSetter(store;customer); 

5.    Add new code that prints the receipt. The following is an example of the code: 

receiptFactory.print(iReceiptAppManager); 
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Save a new receipt blueprint 
To save a new receipt blueprint for the first time: 

1. Select File>Save Receipt Blueprint. 
OR 
Click the Save Receipt Blueprint button. 

 
OR 
Press and hold CRTL and S (CTRL+S) at the same time. This is the shortcut key to saving a 
receipt blueprint. The Save dialog box is displayed. 

 
 Note: If a receipt sample data object is attached to the receipt blueprint, the RDO 

objects should be unplugged dialog box is displayed. To continue saving the receipt 
blueprint without detaching the RDO, click OK.  

 
2. Navigate to the appropriate directory. 

3. In the File Name field, enter the receipt blueprint name. 

 Note: When entering the receipt blueprint name, you must include a .bpt extension. 
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4. Click Save. The receipt blueprint name is displayed in the window header. 

 Note: If you did not include the .bpt extension to the receipt blueprint name, the 
Not a .bpt File message box is displayed. 
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Clone a receipt report 
Cloning a receipt report allows you to create multiple versions of a receipt report without having 
to recreate the entire receipt report each time. After cloning a receipt report, you can modify the 
receipt report to fit your business practices and needs. 

Within a receipt blueprint, you can have multiple versions of a receipt report that either print or 
send to the electronic journal different information that is invoked by a transaction. For example, 
if a customer returns an item without exchange, a buy back transaction is required. The Java code 
for the POS GUI screen calls the BuyBack.bpt receipt blueprint. The buy back transaction 
invokes this receipt blueprint to print three copies of a receipt: customer, store, and electronic 
journal. After the buy back transaction is completed, the sales associate will hand the customer a 
copy of the receipt, a copy will remain for the store record, and a text copy of this receipt is sent 
to the electronic journal. Each copy of the receipt, whether printed or electronic, can contain 
either the same information or different information depending on the receipt report. 

Clone a receipt report 
Cloning a receipt report allows you to create a multiple versions of a receipt report. If you a 
creating a new receipt blueprint, the cloning feature allows you to create a receipt report and then 
clone it if needed.  

To clone a receipt report: 

1. Open a receipt blueprint. 

2. Select Edit>Add Receipt Report. 
OR 
Click the Add Receipt Report button. 

 
  The Select Report to Clone dialog box is displayed. 
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3. In the Select Report to Clone dialog box, click the drop-down menu. 

 
 Note: The drop-down menu includes all receipt reports within the selected 

receipt blueprint. 

4. Select the appropriate receipt report. 

 
5. Click OK. A copy of the selected receipt report is added to the receipt blueprint, and it 

becomes the active receipt report. 
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 Note: The system provides a default name for the cloned receipt report. The default 
naming convention is Receipt (number of receipt layouts within the selected receipt 
blueprint). For example, Layout.bpt has four receipt layouts. If you clone one of the 
receipt reports, the cloned receipt report will be named Receipt Layout5. 

6. Modify the receipt report. For more information on modifying a receipt report, see Chapter 2, 
“Editing a Receipt Blueprint.” 

Delete a receipt report 
Within a receipt blueprint, you may find that you no longer need a receipt report. If this is the 
case, you can delete this receipt report from the receipt blueprint. 

To delete a receipt report: 

1. Open a receipt blueprint. 

2. Select the appropriate receipt report. 

 
3. Select Edit>Delete Receipt Report. 

OR 
Click the Delete Receipt Report button. 

 
  The Delete Receipt Report dialog box is displayed. 

 
4. In the Delete Receipt Report dialog box, click OK. The selected receipt report is removed 

from the receipt blueprint. 
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Change the language of a receipt 
Using the internationalization feature, Retek® Integrated Store Operations (ISO) - Object Library 
and Tools Receipt & Report Builder™ (Receipt & Report Builder) allows you to create receipts 
in multiple languages. This feature will translate all method receipt elements that return a 
message bundle key. However, you will have to modify the static receipt elements. 

 Note: Dates are not formatted to be location-specific. Future versions of 
Receipt & Report Builder will support this feature. 

Receipt & Report Builder supports the following languages: 

• English (United States) 

• Spanish (Mexico) 

• French (Canada) 

• French (France) 

To change the language of a receipt: 

1. In the Receipt Report pane, select a receipt element in a receipt line group. The selected 
receipt data element is outlined in yellow. 
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2. Select the View menu and then select the appropriate language option. The the translation in 
the selected language is displayed for all static elements.  

 
 Note: If no translations for this receipt have been made, the No_Foreign_Value value is 

displayed in the Value to Print field. 

 
3. In the Value to Print field, translate the text that appears on the printed receipt and press the 

Enter key. 
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The receipt element field is updated in the Receipt Report pane to correspond with 
the translation. 

 
4. Continue translating the appropriate static elements. 
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Work with footers 
The Footer option allows you to create and modify footers that are attached to receipt blueprints 
and appear on printed receipts. Footers are similar to receipt blueprints except footers do not have 
an object attached to them. The Footer option allows you to add and modify receipt line groups 
and data elements so you can tailor the contents of a footer that will appear at the bottom of a 
printed receipt. 

Unlike receipt blueprints, Receipt & Report Builder does not a library of existing footers. You 
will have to create footers from scratch. You can attach a single footer to all receipt blueprints or 
tailor a footer for a specific receipt blueprint. Also, changes to a single footer will universally 
affect all receipt blueprints that the footer is attached to. 

 Note: Footers have an .ftr extension and can be found in the 
\files\prod\receiptblueprints directory. 

To access the Footer workspace: 

• If you are currently working with receipt blueprints, select View>Footers. 
OR 
Click the Footers button. 

 
OR 
Press and hold CTRL and F (CTRL+F) at the same time. This is the shortcut key for 
opening the Footer workspace.  

Footer workspace 
The Receipt & Report Builder workspace changes when you are working with footers. The menu 
options, toolbar, command buttons, and the panes all vary.  
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Footer workspace 

Footer menus 
While the menu names for receipt blueprints and footers are identical, some menu options are 
different. The following footer menus contain different menu options: 

• File 

• Edit 

• View 

 Note: The Option menu and the Help menu for both receipt blueprints and footers 
contain the same menu options. 

File menu 
Using the File menu, you can create, save, and open footers.  

File Menu Options 

Menu Option Description 

New Footer* Allows you to create a new footer. 

Open Footer* Allows you to open an existing footer. 

Save Footer* Allows you to save a footer. 
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File Menu Options 

Menu Option Description 

Close Allows you to close an open footer. 

Exit Allows you to exit Receipt & Report Builder. 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 

 
File menu in Footer workspace 

Edit menu 
Using the Edit menu, you can create new and edit existing footers.  

Edit Menu Options 

Menu Option Description 

Add Footer Element* Allows you to add footer data elements to a footer. 

Delete Footer Element* Allows you to delete footer data elements to a footer. 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 

 
Edit menu in Footer workspace 
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View menu 

View Menu Options 

Menu Option Description 

Receipt Blueprints* Allows you to open the footer workspace. 

Language 
(English, Spanish, and French) 

Allows you to maintain multiple versions of a receipt 
blueprint based on language. 

 
View menu in Footer workspace 

Toolbar and command buttons 
The Receipt & Report Builder toolbar contains command buttons that allow you to perform 
specific commands and functions with the press of a button. 

 
Toolbar and command buttons 

Panes 
Panes are the working area of Receipt & Report Builder. Each pane graphically displays the 
layout and attributes of receipt blueprints, RDOs, and receipt data elements. Receipt & Report 
Builder consists of the following panes: 

• Receipt Footer pane—Displays the physical layout of the footer. 

• Footer Data Element Attributes pane—Displays footer data element values and attributes 
that you can modify. 
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Receipt footer pane 
Receipt Footer pane displays the layout and design of a footer. A footer is made up of a footer 
line group and footer data elements. The attributes of receipt data elements are displayed in the 
Footer Data Element Attributes pane when a data element is selected. 

 
Receipt Footer pane 

Footer data element attributes pane 

The Receipt Data Element Attributes pane displays the general properties and attributes of a 
footer. The pane is tabular and divided into two columns—Attribute and Value. 

 
Footer Data Element Attributes pane 
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Create a new footer 
Unlike receipt blueprints, Receipt & Report Builder does not have a library of existing footers. 
You must create all your receipt footers from scratch. After creating a footer, you can use the 
footer as a template for other footers. 

To create a new footer: 

1. Open the Footer workspace. 

2. Select File>New Footer. 
OR 
Click the New Footer button. 

 
OR 
Press and hold CRTL and N (CTRL+N) at the same time. This is the shortcut key for 
creating a new footer. The Enter Footer Name dialog box is displayed. 

 
 Note: Do not type the .ftr file extension to the filename. Receipt & Report Builder 

automatically attaches the .ftr file extension. 

3. In the Enter Footer Name dialog box, enter the footer name and press the Enter key. The 
Receipt Footer pane is displayed. 
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4.  Begin adding footer elements.  

5.  Save the footer.  

Save a footer 
To save a new or modified footer: 

1. Select File>Save Footer. 
OR 
Click the Save Footer button. 

 
OR 
Press and hold CRTL and S (CTRL+S) at the same time. This is the shortcut key for saving 
a footer. The Save dialog box is displayed. 

 
2. In the Save dialog box, enter a file name in the File Name field. 

OR 
Click the Save button if the displayed file name is correct. 

 Note: Footers are saved in the \files\prod\receiptblueprints directory. 



Retek Point-of-Sale 
 

 

64 

Footer data elements 
Footer data elements are the building blocks of a footer that determine the content and appearance 
of a footer. Footers are made up of a single footer line group containing one or more footer data 
elements. Unlike receipt blueprints, a footer data element can only be a static element because 
there are no business objects attached to a footer. 

Add a footer data element 
To add a footer data element: 

• Select Edit>Add Footer Element. 
OR 
Click the Add Footer Element button. 

 
OR 
Press and hold CRTL and A (CTRL+A) at the same time. This is the shortcut key for adding 
a footer element. The new footer data element is added after the last footer data element in 
the footer line group. 

 
 Note: You do not need to select the footer line group before adding a new footer 

data element. Footers contain only a single footer line group, and that is the default and 
active footer line group. 
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Reorder footer data elements 
After adding a footer data element, you can reorder the footer data element within the footer line 
group by dragging and dropping the footer data element in a different location in a footer line 
group. 

To reorder a receipt data element: 

1. Select the appropriate footer data element. The selected footer data element is highlighted 
in yellow. 

2. Drag the selected footer data element to the desired location in the Receipt Footer pane. 
A green field with an arrow is displayed to indicate where the selected receipt data element 
will be placed. 

 
3. Drop the selected footer data element in the desired location. The footer data element is 

displayed in a new location. 

 

Delete a footer data elements 
To delete a footer data element: 

1. Select the appropriate footer data element. The footer data element is highlighted in yellow. 

2. Select Edit>Delete Footer Element.  
OR 
Click the Delete Footer Element button. 

 
OR 
Click the Delete button. This is the shortcut key for deleting a receipt data element. The 
Delete Element dialog box is displayed. 
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3. In the Delete Element dialog box, click OK. The footer data element is no longer displayed 

in the Receipt Footer pane. 

Define footer data element attributes 
Receipt & Report Builder allows you to change the attributes of footer data elements. 

To define the attributes of footer data elements: 

1. In the Receipt Footer pane, select the appropriate data element. The selected data element is 
highlighted in yellow, and the attributes of the selected data element are displayed in the 
Footer Data Element Attributes pane. 

 
2. In the Footer Data Element Attributes pane, select the appropriate value. 

 Note: To change the Value to Print value, either click the Value field and select a value 
form the drop-down list or enter the appropriate value. 

 
3. Define the new value for the element attributes. The new attribute or value of the selected 

footer data element is displayed in the Receipt Footer pane. 
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Interpret footer data elements 
The table below lists the footer data element attributes, type of elements, how attribute values are 
defined, and the printed result of the defined value. 

Footer Data Element Attributes 

Attributes Value Description 

Value to Print User supplied. Enter the value 
for this attribute. 

Prints the text typed or 
displayed in the value field. 

Fixed Length 
System supplied for static 
elements. Enter a fixed number 
of character spaces. 

Prints only the fixed number of 
characters set by the user for 
an object element. For 
example, if you fix the length 
of a customer first name object 
to five, only the first five 
letters of the customer's first 
name will print. 

Is Line Feed 

User supplied. Select the check 
box to apply Is Line Feed as a 
value to the receipt data 
element. 

Prints the selected receipt data 
element on the next line. 

Is Double Width 
Font 

User supplied. Select the check 
box to apply Is Double Width 
Font as a value to the receipt 
data element. 

The selected receipt data 
element prints double the 
width of normal printed receipt 
data elements. 
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Appendix A 
Creating a serialized business object 
The first step in creating a receipt is to serialize a sample of the business object you wish to report 
against. Serializing a sample of the business object may require working with appmodels. An 
appmodel is a decorator that provides getter methods for each complex object that you wish to 
pull data from so that a set of objects can be accessed under one main reference. Appmodels can 
also be used to provide getter methods that implement any additional intelligence that is not 
currently provided directly by Receipt & Report Builder. For example, if the sale is less than 
zero, you can provide a getter method to print “Refund” instead of “Sale.” For all sales greater 
than zero, the receipt will print as a “Sale.” 

POS provides two sample receipt data objects (RDO’s) in the \files\config\ 
receiptblueprints directory, and these files have a file extension of .rdo. An RDO is 
automatically generated and stored by POS when a user completes a POS, end-of-day, or end-of-
session transaction. POS provides the following serialized business objects: 

• Composite POS Transaction 

• Layaway Object 

• End-of-Day Object 

To serialize a sample of the business object you wish to report against: 

1. If there are multiple business objects that you will make up the data printed on the receipt or 
if there are additional directly from the business objects themselves, wrap the objects in an 
appmodel. 

2. To create the appmodel, use the object directly if your needs are simple. 
OR 
Add the following code at the point you want the receipt to be printed: 
 
MyReportableObjectAppModel myAppModel=new 
MyReportableObjectAppModel(theTransaction); 
StringfileName=“../files/prod/receiptblueprints/”+ 
“MyNewReceiptSample”+“.rdo”; 
try { 
 
      ObjectStore objectstore=new ObjectStore(fileName); 
 
objectStore.write(myAppModel); 

 Note: For Receipt & Report Builder to recognize a file as a RDO, you must save file as a 
.rdo file. 

 Note: If you want the string to be translated into a different language before the receipt is 
printed, return a ResourceBundleKey object. A ResourceBundleKey is a marker wrapper 
that indicates the string will be translated by the ReceiptFactory based on the receipt’s 
current locale preference when the receipt is printed. 

3. To serialize the object, run a transaction to invoke the printing of a receipt. 
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Appendix B 
Library of receipt blueprints and sample transactions 

Library of Receipt blueprints and Sample Transactions 

Receipt Blueprint Name Description 

CMSBuyBack.bpt Receipt or report for a buy-back transaction. 

CMSBuyBack_Cancel.bpt Receipt or report for a cancelled buy-back 
transaction. 

CMSBuyBack_Sigs.bpt Receipt or report for a buy-back transaction that 
requires a sig. 

CMSBuyBack_Suspend.bpt Receipt or report for a suspended buy-back 
transaction. 

CMSCashierSessionEvent.bpt Receipt or report for a start of cashier/sales associate 
session. 

CMSClockIn.bpt Receipt or report for an employee clock in. 

CMSClockOut.bpt Receipt or report for an employee clock out. 

CMSCollection.bpt Receipt or report for a paid-in transaction. 

CMSCollection_Cancel.bpt Receipt or report for a cancelled paid-in transaction. 

CMSCollection_sigs.bpt Receipt or report for a paid-in transaction that 
requires a sig. 

CMSCollection_Suspend.bpt Receipt or report for a suspended paid-in transaction.

CMSCompositePOSTransaction_MerchTag.bpt Receipt or report for a damaged merchandise tag. 

CMSCompositePOSTransaction_Sale.bpt Receipt or report for a sales transaction. 

CMSCompositePOSTransaction_Sale_Cancel.bpt Receipt or report for a cancelled sales transaction. 

CMSCompositePOSTransaction_Sale_Sigs.bpt Receipt or report for a sales transaction that requires 
a sig. 

CMSCompositePOSTransaction_Sale_Suspend.bpt Receipt or report for a suspended sales transaction. 
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Library of Receipt blueprints and Sample Transactions 

Receipt Blueprint Name Description 

CMSCompositePOSTransaction_Shipping.bpt Receipt or report for a shipping manifest. 

CMSDueBillIssue.bpt Receipt or report for issuing a due-bill transaction. 

CMSEmployeeAccessFinger.bpt Receipt or report for resetting the fingerprint 
detection. 

CMSEmployeeAccessMod.bpt Receipt or report for a change in an employee’s 
access. 

CMSEmployeeAccessNew.bpt Receipt or report for authorizing a new employee’s 
access. 

CMSEmployeeAccessTerm.bpt Receipt or report for terminating an employee’s 
access. 

CMSEmployeeResource.bpt Receipt or report for modifying an employee’s 
schedule resources. 

CMSEmployeeSchedule.bpt Receipt or report for modifying an employee’s 
schedule. 

CMSEODTotals.bpt Receipt or report for the end-of-day totals. 

CMSGiftReceipt.bpt Receipt or report for a gift certificate transaction. 

CMSInvalidLogonAttempt.bpt Receipt or report for a failed log-on. 

CMSLayaway.bpt Receipt or report for a layaway transaction. 

CMSLayaway_Cancel.bpt Receipt or report for a cancelled layaway transaction.

CMSLayaway_Sigs.bpt Receipt or report for a layaway transaction that 
requires a sig. 

CMSLayaway_Suspend.bpt Receipt or report for a suspended a layaway 
transaction. 

CMSLayawayOutstanding.bpt Receipt or report for an outstanding layaway 
transaction. 

CMSLayawayOverdue.bpt Receipt or report for an overdue layaway transaction.
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Library of Receipt blueprints and Sample Transactions 

Receipt Blueprint Name Description 

CMSLayawayPayment.bpt Receipt or report for a layaway payment transaction. 

CMSLayawayPayment_Cancel.bpt Receipt or report for a cancelled layaway payment 
transaction. 

CMSLayawayPayment_Sigs.bpt Receipt or report for a layaway payment transaction 
that requires a sig. 

CMSLayawayPayment_Suspend.bpt Receipt or report for a suspended layaway payment 
transaction. 

CMSLayawayRTS.bpt Receipt or report for a layaway return-to-stock 
transaction. 

CMSLayawayRTS_Cancel.bpt Receipt or report for a cancelled layaway return-to-
stock transaction. 

CMSLayawayRTS_Suspend.bpt Receipt or report for a suspended layaway return-to-
stock transaction. 

CMSNoSaleTransaction.bpt Receipt or report for a no-sale transaction. 

CMSPaidOut.bpt Receipt or report for a paid-out transaction. 

CMSPaidOut_Cancel.bpt Receipt or report for a cancelled paid-out transaction.

CMSPaidOut_sigs.bpt Receipt or report for a paid-out transaction that 
requires a sig. 

CMSPaidOut_Suspend.bpt Receipt or report for a suspended paid-out 
transaction. 

CMSRecallParkedTxn.bpt Receipt or report for recalling a suspended 
transaction. 

CMSResendBrokenTxn.bpt Receipt or report for a resent broken transaction. 

CMSSessionEnd.bpt Receipt or report for a end-of-session transaction. 

CMSSessionStart.bpt Receipt or report for a start-of-session transaction. 

CMSStartOfDay.bpt Receipt or report for a start-of-day transaction. 
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Library of Receipt blueprints and Sample Transactions 

Receipt Blueprint Name Description 

CMSStoreInfo.bpt Receipt or report for a store information transaction. 

CMSTimecardAddInOut.bpt Receipt or report for adding an in/out to a timecard. 

CMSTimecardDelInOut.bpt Receipt or report for deleting an in/out to a timecard.

CMSTimecardInsInOut.bpt Receipt or report for inserting an in/out to a timecard.

CMSTimecardModInOut.bpt Receipt or report for modifying an in/out to a 
timecard. 

CMSTransferInComplete.bpt Receipt or report for a complete transfer-in 
transaction. 

CMSTransferInPartial.bpt Receipt or report for a partial transfer-in transaction. 

CMSTransferOut.bpt Receipt or report for a transfer-out transaction. 

CMSUpdateEmployeeFile.bpt Receipt or report for downloading an employee file. 

CMSUpdateItemFile.bpt Receipt or report for downloading an item file. 

CMSVoidTransaction.bpt Receipt or report for a voided transaction. 

PrinterTest.bpt Receipt or report for testing a printer. 

SpecialOrder.bpt Receipt or report for a special-order transaction. 
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