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• Exact error message received. 

• Screen shots of each step you take. 
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Chapter 1 – Introduction  
The Retek ® RPOS™ Tools Mission Control is a Java®-based management application tool that 
allows you to manage the Retek® Point-of-Service™ (RPOS) application in a physically 
distributed system. With Mission Control, you can monitor, manage, debug, and tune multiple 
network devices simultaneously. Mission Control’s intuitive and user-friendly graphical-user 
interface (GUI) enables you to employ a simple point-and-click method to manage an entire 
network system. 

The following are features and benefits of Mission Control: 

• Identify problems quickly—Mission Control red flags exceptions and eliminates the need 
for you to page through lengthy log files. This allows you to identify problems and initiate a 
resolution quickly. 

• Optimize performance—By balancing the use of multiple components, you can tune the 
application server for optimal performance based upon your business rules. 

• Extend component lifecycle—You can quickly and easily allocate resources across a system 
to avoid overloads and extend the life of your components. Upgrades can be made 
dynamically, eliminating the need for downtime during system upgrades. 

• Point and click debugging—Mission Control’s GUI enables you to view server statistics 
and pinpoint solutions by pointing and clicking.  

• Monitor system vitals—Mission Control provides you with a window into a physically 
distributed system. This application tool enables you to proactively monitor critical system 
vitals such as hits per period, HEAP, CPU utilization, and maximum number of concurrent 
requests. These system vitals can be graphed to easily view and monitor performance trends. 

• Send messages and view network topology—The Message Monitor feature of Mission 
Control allows you to publish messages in a distributed computing environment. 

• Automated update process—Mission Control allows you to update application servers and 
clients using an automated process called a manifest. 

Logon to mission control 
Before you can begin using Mission Control, you will be prompted for a password while logging 
on. This extra security feature helps ensure only designated personnel can monitor and manage 
the RPOS system. 

To log on to Mission Control: 

1. Click the Mission Control icon on the desktop. 
Or 
If you are using a command prompt: 

a. Type cd: and then the path to the bin folder. 

b. Type javaenv to start the Java environment. 

c. Type mc. 

The Logon to RPOS Tools Mission Control dialog box is displayed. 
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2. On the Logon to RPOS Tools Mission Control dialog box, type the password in the 
Enter Password field. 

 
 Note: The default password is retek. It is recommended that you change the password to 

a user-defined password after you log on to Mission Control for the first time. 

 Note: If you type an incorrect password, the Incorrect Password dialog box is 
displayed. To close the dialog box, click OK. Retry typing the password. 

 
3. Click the Login button. Mission Control is started and displayed on the screen. 
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Change your logon password 
It is recommended you change your password after logging on to Mission Control for the first 
time. Currently there are no parameters or restrictions to a password. A password can be any 
combination of letters, numerals, spaces, and symbols. The number of characters is user-defined. 

To change your logon password: 

1. Select Options>Properties. The Properties dialog box is displayed. The Update Delay tab 
is the default tab. 

 
2. Click the Password tab. 
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 Note: To navigate through fields, select TAB or ENTER, or select the field in which you 

wish to enter the password information. 

3. In the Current Password field, type the current password. 

4. In the Change Password field, type the new password. 

5. In the Confirm Password field, re-type the new password.  

 Note: If you re-type the password incorrectly, the system displays an error message. 
Select OK, and re-type the password correctly. 

6. To change the password, click OK. The Properties dialog box is no longer displayed. 
Or 
Select the Apply button. The system is updated with the new password. The Properties 
dialog box is still displayed. 
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Mission control workspace overview 
The Mission Control workspace consists of a single window containing the following:  

• Menu bar 

• Toolbar 

• Windows 

• Tabs 

 
Mission Control workspace 

Menu bar and menus 
The menu bar contains the different menu options that you can choose from. Mission Control 
provides the following menu options: 

• File 

• Container 

• Component 

• Client 

• Graph 

• View 

• Options 

• Help 
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 Note: When starting Mission Control, all menus are active except the Containers, 
Components, and Clients menus. You must first connect to and view a node before these 
menus become active. 

 
Mission Control menu bar 

File Menu 
The File menu provides options to exit Mission Control, close windows, and select and view 
nodes that were previously connected to during a session of Mission Control. The following are 
menu options on the File menu: 

• Node—Allows you to connect to a node (Monitor*) or make all components or services 
available or unavailable on a node (Available).  

• Manifest—Allows you to create, edit, and remove a manifest. 

• Close—Allows you to close the active window. 

• Exit—Allows you to close all active windows and exit Mission Control. 

 
File menu and menu options 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 
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Container menu 
The Container menu allows you to monitor and manage the containers running on a server. This 
menu also allows you to view log files for each container. The following are menu options on the 
Container menu: 

 Note: The Container menu and menu options are not active until you connect to an 
application server and select a container. 

• Configure—Allows you to configure the properties of an existing container. 

• New*—Allows you to create a new container. 

• Delete—Allows you to delete an existing container. 

• Start—Allows you to start a new instance of a container. 

• Shutdown—Allows you to stop or shutdown an instance of a container. 

• View Logs—Allows you to view the log files of a container. 

 Note: An ellipsis (...) following a menu option signifies a new window will open if you 
select that option. 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 

 

Container menu and menu options 
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Component menu 
The Component menu allows you to monitor and manage the components running on a server. 
This menu also allows you to view log files for each instance of a component. The following are 
menu options on the Component menu: 

 Note: The Component menu and menu options are not active until you connect to a node 
and select a component. 

• Configure—Allows you to configure the properties of an existing component. 

• New*—Allows you to create a new component. 

• Delete—Allows you to delete an existing component. 

• Start—Allows you to start a new instance of a component. 

• Shutdown—Allows you to stop or shutdown an instance of a component. 

• View Logs—Allows you to view the log files of a component. 

 Note: An ellipsis (...) following a menu option signifies a new window will open if you 
select that option. 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 

 

Component menu and menu options 



Chapter 1 – Introduction 
 

 

9 

Client menu 
The Client menu allows you to manager clients on the network from a remote location. The 
following are menu options on the Client menu: 

 Note: The Client menu and menu options are not active until you connect to a client. 

•    Get Exceptions—Allows you to retrieve exceptions. 

•    Shutdown—Allows you to shutdown processes on the selected client. 

•    Get Transaction—Allows you to retrieve broken transactions. 

•    Remove Transaction—Allows you to remove broken transactions on the selected client. 

•    Clear Transaction—Allows you to clear broken transactions on the selected client. 

 Note: An ellipsis (...) following a menu option signifies a new window will open if you 
select that option. 

 

Client menu and menu options 

Graph menu 

 Note: The Graph menu and menu options are not active until you connect to a node. 

The Graph menu allows you to collect and view system and server vitals in various graphical 
formats. The following are menu options on the Graph menu: 

• Vitals*—Allows you to view system and server vitals in configurable graphical formats. 

• Percentages—Allows you to view server transaction percentages by service in configurable 
pie-chart format. 

 Note: An ellipsis (...) following a menu option signifies a new window will open if you 
select that option. 

 Note: Menu options marked with an asterisk (*) have corresponding command buttons 
available on the toolbar. 
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Graph menu and menu options 

View menu 
The View menu allows you to view the toolbar and change the look and feel of Mission Control. 
The following menu options on the View menu: 

• Show Toolbar—Allows you to hide the toolbar or make the toolbar visible. 

• Metal—A theme that changes the appearance of Mission Control. 

• CDE/Motif—A theme that changes the appearance of Mission Control. 

• Windows—A theme that changes the appearance of Mission Control. 

 Note: An ellipsis (...) following a menu option signifies a new window will open if you 
select that option. 

 Note: A check or bullet will appear by the selected menu option. 

 

View menu and menu options 

Options menu 
The Options menu allows you to set server properties, register for email notifications, export 
system and performance information into a Microsoft® Excel® file, and adjust the chart 
appearance. The following are menu option on the Options menu: 

• Export—Allows you to export system and performance information into an Excel 
spreadsheet. 

• Chart Options—Allows you to customize the look and feel of a table. 

• Properties—Allows you to update the window update delay, change, add, or remove a 
classpath, and change the logon password for Mission Control. 
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 Note: An ellipsis (...) following a menu option signifies a new window will open if you 
select that option. 

 Note: Some menu options will appear inactive depending on the task you are performing. 

 

Options menu and menu options 

Help menu 
The Help menu allows you to access the online help files for Mission Control. The help files will 
launch in a separate window. 

 Note: An ellipsis (...) following a menu option signifies a new window will open if you 
select that option. 

 
Help menu and menu options 
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Toolbar and command buttons 
Mission Control command buttons correspond with menu options. The command buttons on the 
toolbar will become active depending on the task being performed.  

 Note: See the section in this guide specific to the task you are performing for a list of 
available options. 

 
The table below lists and describes each command button that appears on the Mission Control 
toolbar. 

Mission Control Command buttons 

Command Button  Description Menu 

Monitor Server 

 

Allows you to connect to and monitor 
registered nodes. File 

New Container 

 

Allows you to add a new container to an 
existing server. Container 

New Component 

 

Allows you to add a new component to an 
existing server. Component 

Vitals Graph 

 

Allows you to view system and server 
vitals in configurable graphical formats. Graph 

Percentages Chart 

 

Allows you to view server transaction 
percentages by service in configurable pie-
chart format. 

Graph 
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 Note: To view a command button’s definition, hover the cursor over the button. 

Windows 
Mission Control’s windows are the main working area of the application. Selecting various menu 
options and command buttons opens a new working window.  

 
An example of a Mission Control window 

Opening a window makes that window the active window. Selecting another open window will 
change the active window. Also, each window can be minimized, maximized, and resized to your 
specifications. Placing the cursor on the window corner allows you to resize the window to fit 
your working preferences. 

Tabs 
Tabs allow you to navigate within windows. Tabs vary depending on the task being performed. 
Some tabs are not active when performing some tasks.  

 
An example of tabs on a window 
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Chapter 2 – Set up a node 
You must first register the node with Retek® RPOS™ Mission Control before you can begin 
viewing, monitoring, managing, debugging, or tuning your network system (for example, an 
application server, database server, or client residing in a store). You must provide the IP address 
and the port number of the node you wish to register. You only have to register a node once with 
Mission Control. After you register a node, you can connect to a node using the Monitor Node 
feature. 

Register a node 
Registering a node allows you to connect to the following nodes or server-side components: 

• Application server 

• Client 

• Naming server 

• Message Monitor 

To register a node: 

1. Select File>Node>Monitor. 
Or 
Click the Monitor Node button.  

 
The Select Node to Connect dialog box is displayed. 
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 Note: To navigate through fields, select TAB or select the field in which you wish to type 
the node or server-side component information. 

2. Type the IP address of the node you wish to register. 

3. Type the port number of the node you wish to register. The following are default 
port numbers: 

• NodeMonitorServer (application server)—3001 

• IClientManager (client)—2048 

• MessageMonitor (Message Monitor)—3000 

• NamingServer (naming server)—3000 (root naming server) or 3001 (specific node) 

4. In the drop-down list, select one of the following: 

• To register an application server, select NodeMonitorService. 

• To register a client, select IClientManage. 

• To register a naming server, select NamingServer. 

• To register the message monitor, select MessageMonitor. 

 Note: NodeMonitorService is the default value. 

 
5. Click the Connect button. The appropriate window and information for the connected node is 

displayed 

6. Repeat these steps to register additional nodes. 

After you register a node, Mission Control assigns the node a name based on the information you 
provided. The following is the naming convention for all registered nodes: node’s IP address: port 
number/type of node (for example, NodeMonitorServices for servers and IClientManage for 
clients). 

The following is an example of a registered application server and a registered client: 

•    Registered application server—10.212.128.245:3001/NodeMonitorServices 

•    Registered client—10.212.125.225:2048/IClientManage 

 Note: There are no spaces in a node name. 

 

Node name example 
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Apply an alias to a node 
While Mission Control assigns a name to a registered node, you can apply an alias to the node. 
The alias does not replace the name assigned by Mission Control, but it is a managing tool for 
you to help keep track of multiple nodes. For example, you can apply an alias to a client based on 
the location of the store, or you can apply an alias to a application server based on where it is 
located within the United States.  

To apply an alias to a node: 

1. Select File>Node>Monitor. 
OR 
Click the Monitor Node button.  

 
The Select Node to Connect dialog box is displayed. 

 
2. Select the node you wish to apply an alias to. The node is highlighted in blue. 

3. Right click on the node. A pop-up list is displayed. 
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4. In the pop-up list , select Apply Alias. The Apply Alias dialog box is displayed. 

 
5. In the Apply Alias dialog box, type an alias. 

6. To apply the alias to the selected node, click OK. 
OR 
Click the Enter button. In the Select Node to Connect dialog box, the alias is displayed on 
the right-hand side of the node name. 

 
 Note: An alias only appears in the Select Node to Connect dialog box. After connecting 

to a node, the various Mission Control windows display only the node’s name.  

Change the alias of a node 
Mission Control allows you to change a node’s alias. The steps to changing are exactly the same 
as applying an alias. For more information on changing a node’s alias, see “Applying an Alias to 
a Node”. 
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Remove an alias from a node 

 Note: Removing an alias only removes the alias from the node , not the node name 
assigned by Mission Control. 

To remove an alias from a node: 

1. Select File>Node>Monitor. 
OR 
Click the Monitor Node button.  

 
The Select Node to Connect dialog box is displayed. 

 
2. Select the node you wish to remove the alias from. The node is highlighted in blue. 

3. Right click on the node. A pop-up list is displayed. 
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4. In the pop-up list, select Remove Alias. The Remove Alias dialog box is displayed. 

 
5. In the Remove Alias dialog box, click Yes. The alias is no longer displayed in the 

Select Node to Connect dialog box.  
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Connect to a registered node 
After you have registered a node, Mission Control stores that node information. The Select Node 
To Monitor dialog box displays all the nodes that have been connected to using Mission Control.  

To connect to a registered node: 

1. Select Node>Monitor. 
OR 
Click the Monitor Node button.  

 
The Select Node to Monitor dialog box is displayed. 

 
2. In the Select Node to Monitor dialog box, select the node you wish to connect to. The 

selected node is highlighted in blue. 

3. Click the Connect button. The appropriate window and node information is displayed. 

4. To connect additional nodes, repeat steps 1-3. 



Retek Point-of-Sale 
 

 

22 

Remove a registered node 
If you no longer need to connect to a particular node or if the node no long exists, you can 
remove the node from the Select Node to Monitor dialog box. 

To remove a node from the Select Node to Monitor dialog box: 

1. Select File>Node>Monitor. 
OR 
Click the Monitor Node button.  

 
The Select Node to Connect dialog box is displayed. 

2. Select the node you wish to delete. The node is highlighted in blue. 

3. Right click on the node. A pop-up list is displayed. 

 
4. In the pop-up list, select Delete Node. The Delete Node dialog box is displayed. 

 
5. In the Delete Node dialog box, click Yes. The node is no longer displayed in the Select Node 

to Connect dialog box.  
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Chapter 3 – Working with containers 
After connecting to an application server, you can view and monitor the processes running on a 
server. The Retek® Point-of-Service™ (RPOS) platform has individual components or services 
stored in containers, and the processes are run from the containers. A container can store multiple 
components. Containers reduce the memory load by combining multiple components into one 
process so the components share the memory. Containers also increase the horizontal scalability 
of the RPOS system. 

You can perform the following tasks when working with containers: 

• Configure an existing container 

• Create a new container 

• Start and stop an instance of a container 

• Delete a container 

• View container log files 

Containers and components are configurable per the customer.  

Containers and components 

Containers Components 

CustomerContainer • CustomerServices 

EmployeeContainer 

• EmpResourceServices 
• EmployeeServices 
• RoleServices 
• ScheduleServices 
• TimecardServices 

FormContainer • FormServices 

ItemContainer 

• InventoryServices 
• ItemServices 
• MerchandiseServices 
• TransferServices 

PaymentContainer • RedeemServices 

ReadingsContainer • ReadingServices 

StoreContainer 
• GoalServices 
• RegisterServices 
• StoreServices 
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Containers and components 

Containers Components 

ThirdPartyContainer 
• CreditAuthServices 
• TaxServices 

TransactionContainer 

• EODServices 
• LayawayServices 
• SOSServices 
• TransactionPOSServices 
• TxnPosterServices 

 Note: Container and service names appear as they would in Mission Control. 
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Containers window 
The Containers window provides you with container information, server vitals, and performance 
information, such as CPU and memory allocation. You can use this information to optimize a 
server's performance to run the maximum number of concurrent processes without a decrease in 
performance. Mission Control allows you to view the Containers window for all online servers.  

When you first connect to a server, the default tab in the Containers window is the All 
Containers tab. The All Containers tab is unique because it displays information about the 
entire system and all the containers. The other container-specific tabs display information for the 
selected container. 

 
Containers window with the All Containers tab selected 

The table below lists and describes the features and information displayed on the Container 
window when the All Containers tab is selected. 

Container Window Contents (All Containers) 

Feature Description 

Tabs Tabs for containers. 

Release The release number or version of RPOS running on the 
application server. 

Logging Directory Displays the file size of the log files. 
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Container Window Contents (All Containers) 

Feature Description 

Online/Offline 

Displays the online status of the server. The status button 
provides the following information: 
• The Online/Offline button appears green if the system 
is online. 
• The Online/Offline button appears red if the system 
is offline. 

CPU Displays the total CPU usage of a server. 

Container table 

Lists and displays the following container information: 
• List of containers 
• Number of maximum services 
• Number of minimum services 
• Number of current services running 
• Total transactions per container 
• Status of exceptions—green if there are no exceptions and 

red if there exceptions logged. 

ConfigureContainer button Allows you to re-configure the selected container. 

Events button Allows you to view event logging for the connected node. 

New Container button Allows you to create and configure a new container 

View Container Logging 
button Allows you to view the log files of the selected container. 

By selecting a container tab in the Containers window, you can the view the components within 
a container. After you select a container tab, the system displays information for the selected 
container and not the entire server. The image below shows the Containers window when a 
container tab is selected. 
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Containers window with a container tab selected 

The table below lists and describes the features and information displayed on the Container 
window when the a container tab is selected. 

Container Window Contents (single container) 

Feature Description 

Container Name Displays the name of the selected container. 

Memory in Ks Displays the actual amount of memory of a container. 

CPU Percent Displays the percentage of CPU used to run a component. 

Heap Total/Free Displays the amount of heap memory used and the amount of 
available free memory. 

Memory Percentage Displays the percentage of CPU used to run a component. 

Hours Up Displays the number of hours the component has been running.
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Container Window Contents (single container) 

Feature Description 

Service table 

Lists and displays the following container information: 
• Services—List of components or services within the 

selected container. 
• UID—Displays the components unique ID (timestamp of 

when the component started) of each component. 
• Availability—Displays the availability status of a 

component. 
• Total Txns—Displays the total number of transaction 

against a component. 
• Maximum Threads/Time—Displays the maximum number 

of concurrent threads and the time and date this occurred. 
• Hours Up—Displays the total number of hours a component 

has been running. 

Configure Component button Allows you to re-configure the selected component. 

New Component button Allows you to create and configure a new instance of a 
component. 

View Component Logging 
button 

Allows you to view the log files of the selected component. 
 

All Container button 
Displays the information for all the containers. Selecting the 
All Containers button has the same function as selecting the 
All Container tab. 

UID tab Displays the unique ID (UID) of the container. 
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Configure a container 
The Configure Container feature allows you to change a container’s settings. Configuring an 
existing container offers you several ways to monitor a system’s performance so you can view 
and predict performance trends. Viewing a system’s statistics and performance allows you to re-
configure a component or add a new instance of a component or container so you can balance the 
workload of components, allocate resources across a system to avoid overloads, resolve 
exceptions, and debug the system. Mission Control allows you to re-configure the following 
information: 

• Number of instances of a component 

• Stats parameter 

• Number of default instances 

• Time between instance pauses 

• Hours of history 

• Time between vital pauses 

To re-configure the container settings: 

1. Connect to a server. 

2. In the Container table, click the container you wish to configure. 

 Note: If you do not select a container, the Select Container dialog box is displayed. To 
close the dialog box, click OK. 

 
3. Select Container>Configure. The Configure Service Container window is displayed. 

4. Re-configure the container setting. 

Add an instance of a component 
Adding a new instance of a component is discussed in greater detail in Chapter 4, “Working with 
Components.”. 
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Change the stats parameter 
The stats parameter is the class that collects performance information for each container. The 
stats parameter should not be changed unless there is an error in the initial settings. For example, 
this class may change depending on the operating system, and this will require you to make 
modifications to the configuration file on the application server.  

 Note: These steps assume you have performed the steps described in “Configuring a 
Container”. 

To change the stats parameter: 

1. In the Configure Service Container, click a stats class. The stats parameter is displayed in 
the Argument field. 

2. Highlight and delete the information after DSTATS_CLASS= 

3. Click the Class button. The Choose Class window is displayed. 

4. In the Choose Class window, drill down to com_iso_cr_node. 

5. Select the new stats parameter. Choose from the following parameter options: 

• WinProcessStats—used for Windows-based operating systems. 

• UnixProcessStats—used for most UNIX- and Linux-based operating systems. 

• UnixSparcProcessStats—used for the UNIX Sparc operating system. 

7. In the Choose Class window, click OK. The Argument field is updated with the new 
stats parameter. 

8. In the Configure Service Container window, click the Save button. 

9. To update and save the changes to the stats parameter, click OK. 

 Note: You must click OK to update the system with the new stats parameter. Selecting 
Save does not update the system with the new stats parameter. 

Modify the default number of instances of a container 
Creating a new instance of a container creates a mirror of an existing process. A new instance of a 
container allows you to manage an increase in workload and helps distribute the workload among 
multiple instances of a particular container. While increasing the number of instances of 
containers will increase the CPU used, increasing the number of services can also create a work 
overload for the container. This work overload bottlenecks the CPU used, and it slows the system. 
In this case, creating a new instance of a container balances the workload for both the container 
and components, and it extends the life of the containers and components. 

 Note: These steps assume you have performed the steps described in “Configuring a 
Container”. 

To add a new instance of a container: 

1. In the Configure Service Container window, type the number of instances of a container in 
the Default Instance Count field. 

2. Click OK. The new instance of a container are added after the next instance update. 
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View the new instance of a container 
After the you add a new instance of a container and the system updates your changes, Mission 
Control does not display a new container tab for that instance. Instead, Mission Control generates 
a new UID for that container and adds the UID to the right of the existing container UID. All 
container UID’s are found at the bottom left of the Containers window. 

To view the new instance of a container: 

1. Select the container tab of the container you created a new instance for. 

 Note: By default, the Container window displays the container information for the 
container you added a new instance of.  

2. Select the UID of the new container. The container information is displayed in the 
Containers window. 

Modify the instance pause 
Mission Control automatically updates the number of instances of a container after each instance 
pause. The value in the Instance Pause in Minutes field represents the number of minutes in 
which Mission Control updates the number of instances of each container. 

 Note: These steps assume you have performed the steps described in “Configuring a 
Container”. 

To modify the instance pause value: 

1. In the Configure Service Container window, type the new number of instances in the 
Instance Pause in Minutes field. 

2. Click OK. The instance pause is updated after the next instance pause occurs. 

Modify the history value 
Mission Control allows you to view and track system performance using the Graphing Vitals 
feature. You can modify the Hours of History value for graphing purposes only, and this value 
represents the number of hours of graphing information that is displayed on the Graphing 
Container window. 

 Note: These steps assume you have performed the steps described in “Configuring a 
Container”. 

To modify the hours of history value: 

1. In the Configure Service Container window, type the new number of instances in the 
Hours of History field. 

2. Click OK. The system updates the hours of history and displays the changes in the 
Graphing Container window. 
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Modify the vital pauses 
Mission Control automatically updates the vital pauses for graphing purposes. The value in the 
Vital Pause in Minutes field represents the time increments (in minutes) in which the 
performance statistics are recorded and displayed in the Graphing Container window. 

 Note: These steps assume you have performed the steps described in “Configuring a 
Container”. 

To modify the vital pauses: value 

1. In the Configure Service Container, type the new number of instances in the 
Vital Pause in Minutes field. 

2. Click OK. The vital pauses is updated, and the changes are displayed in the 
Graphing Container window. 

Create a new container 
Creating a new container is different than starting a new instance of an existing container. The 
Container Wizard provides step-by-step instructions to create a new container. You will need to 
provide the following information to create a new container: 

• Unique container name 

• Default settings 

• Specify process stats classname 

• Specify stats parameter 

To create a new container: 

1. Connect to a server. 

2. Select Container>New. 
OR 
Click the New Container button. 

 
The Containers Wizard is displayed. 

3. Follow the step-by-step instructions provided by the Containers Wizard to create a 
new container. 
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Start and stop an instance of a container 
Mission Control allows you to monitor CPU performance and memory allocation so you can 
document and monitor server performance limitations. Using Mission Control, you can configure 
the server to spawn a new instance of a container when the threshold for concurrent threads is 
reached. However, if the number of transactions creates a load too large to be sufficiently handled 
by the number of concurrent threads, server performance will decrease below the optimal 
performance levels. 

Start a new instance of a container 
It is recommended that you start a new instance of a container when a container cannot 
sufficiently handle the number of concurrent threads without a decrease in server performance. A 
new instance will help manage the increased workload and number of transactions. Once the 
workload has decreased to the point where the default number of containers can sufficiently 
handle the workload, Mission Control automatically stops the oldest instance of the container to 
help with CPU utilization. 

To start a new instance of a component: 

1. Connect to a server. 

2. In the Container table, click the container you wish to start a new instance of. 
OR 
Click the container tab you wish to start a new instance of. 

3. Select Container>Start. The Start Service Container dialog box is displayed. 

 
4. In the Start Service Container dialog box, click OK. The new instance the selected 

container is started and a UID is assigned to the new instance of the container.  

View the New Instance of a Container 
After the you add a new instance of a container and the system updates your changes, Mission 
Control does not display a new container tab for that instance. Instead, Mission Control generates 
a new UID for that container and adds it to the left of the existing container UID. Multiple 
instances of a container can be accessed from a single container tab. 

To view the new instance of a container: 

1. Select the container tab for the container you created a new instance for. 

2. Select the UID of the new container. The selected container’s information is displayed in the 
Containers window. 
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Stop an instance of a container 
After the workload for a component has decreased, you can stop an instance of a container to help 
allocate and better utilize CPU and system resources. Also, stopping an instance of a container 
allows developers to incorporate code changes and re-initialize the environment. 

To stop an instance of a container: 

1. Connect to a server. 

2. In the Container table, click the container you wish to stop an instance of. 
OR 
Click the container tab of the container you wish to stop an instance of. 

3. Select Container>Shutdown. The Shutdown Service Container dialog box is displayed. 

 
4. In the Shutdown Service Container dialog box, click OK. The instance the selected 

container is shut down. 

Delete a container 
Deleting a container removes the container, components within the container, and the 
configuration file for the selected container from the server. 

To delete a container: 

1. Connect to a server. 

2. In the Container table, click the container you wish to delete. 
OR 
Click the container tab of the container you wish to delete. 

3. Select Container>Delete. The system displays the Warning dialog box. 

4. In the Warning dialog box, click OK. The system shutdowns the instance the selected 
container, and displays the Shut Down dialog box. 

 Note: Clicking OK deletes the configuration file but the processes still reside on the 
server.  

   5    In the Shut Down dialog box, click Yes. The system removes the processes from the server. 

 Note: Selecting No allows the processes to reside on the server until the server is 
restarted. 
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View container log files 
Mission Control stores performance statistics and errors in log files. You can view these log files 
to monitor and manage server performance. For more information on viewing container log files, 
see Monitor Vitals and View Log Files.  
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Chapter 4 – Working with components 
Components are groupings of functionalities similar to objects in object-oriented programming. 
The components in Retek ® Point-of-Service™ (RPOS) are implemented by service classes. For 
example, the customer component is implemented by the customer service. The component, or 
services, are stored in containers, and the processes are run from the containers. You can have 
multiple instances of a component within a single container.  

You can perform the following tasks when working with components: 

• View component properties 

• Create a new component 

• Configure an existing component 

• Start and stop an instance of a component 

• Make all components available or unavailable 

• Delete a component 

• View component log files 

 

Containers and components are configurable per the customer. The table below lists the default 
components and the containers that store them within the RPOS application. 

Components and Containers 

Components Containers 

CreditAuthServices ThirdPartyContainer 

CustomerServices CustomerContainer 

EmpResourceServices EmployeeContainer 

EmployeeServices EmployeeContainer 

EODServices TransactionContainer 

FormServices FormContainer 

GoalingServices StoreContainer 

InventoryServices ItemContainer 

ItemServices ItemContainer 

LayawayServices TransactionContainer 
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Components and Containers 

Components Containers 

MerchandiseServices ItemContainer 

ReadingServices ReadingsContainer 

RedeemServices PaymentContainer 

RegisterServices ReadingsContainer 

RoleServices EmployeeContainer 

ScheduleServices EmployeeContainer 

StoreServices StoreContainer 

TaxServices ThirdPartyContainer 

TimecardServices EmployeeContainer 

TransactionPOSServices TransactionContainer 

TransferServices ItemContainer 

TxnPosterServices TransactionContainer 

 



Chapter 4 – Working with components 
 

 

39 

View the container window 
The Container window not only provides you with container information, it also provides 
information about the components or services running on the servers. When you first connect to a 
server, the default tab in the Containers window is the All Containers tab. The All Containers 
tab is unique because it displays information about the entire system and all the containers where 
the other tabs display information for the selected container. By selecting a container tab in the 
Containers window, you can the view the components within a container.  

 
Container window with a container tab selected 

The table below lists and describes the features and information displayed on the Container 
window when the a container tab is selected. 

Container Window Contents (single container) 

Feature Description 

Container Name Displays the name of the selected container. 

Memory in Ks Displays the actual amount of memory used by a container. 

CPU Percent Displays the percentage of CPU used to run a component. 

Heap Total/Free Displays the amount of heap memory used and the amount 
of available free memory. 

Memory Percentage Displays the percentage of CPU used to run a component. 

Hours Up Displays the number of hours the component has been 
running. 
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Container Window Contents (single container) 

Feature Description 

Service table 

Lists and displays the following container information: 
• Services—List of components or services within the 

selected container. 
• UID—Displays the components unique ID (timestamp of 

when the component started) of each component. 
• Availability—Displays the availability status of 

a component. 
• Total Txns—Displays the total number of transaction 

against a component. 
• Maximum Threads/Time—Displays the maximum 

number of concurrent threads and the time and date this 
occurred. 

• Hours Up—Displays the total number of hours a 
component has been running. 

Configure Component button Allows you to re-configure the selected component. 

New Component button Allows you to create and configure a new instance of 
a component. 

View Component Logging 
button 

Allows you to view the log files of the selected component. 
 

All Container button 
Displays the information for all the containers. Selecting the 
All Containers button has the same function as selecting the 
All Container tab. 

UID tab 
Displays the UID of the container. If there are multiple 
instances of a container, there will be a UID tab for each 
instance. 
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View component properties 
After connecting to a server, you can view and manage a servers performance by monitoring the 
components running on that server. 

To view components running on a server: 

1. Connect to a server. The Containers window is displayed. 

2. In the Containers window, click the container tab you wish to create the new component in. 

3. Select a component. The selected component is highlighted in blue. 

 
 Note: If you do not select a component, the Select Component dialog box is displayed. 

 
4. Select Component>Configure. The Configure Component dialog box is displayed. 

5. In the Configure Component dialog box, view the component properties. The following is a 
list of component properties displayed in the Configure Component dialog box: 

• Component name 

• Class name 

• Key-Value pairs 

• Minimum number of instances 

• Maximum number of instances 
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Create a new component 
Mission Control allows you to create a new component if the service does not already exist. 
Before you can create a new component using Mission Control, you must generate a service using 
RPOS Tools Application Builder. For more information on generating a new service, see the 
RPOS Tools Application Builder User Guide. 

To create a new component: 

1. Connect to a server. The Containers window is displayed. 

2. In the Containers window, click the container tab that you will create the new component in. 

3. Select Component>New. 
OR 
Click the New Component button.  

 
The Choose Component Config File dialog box is displayed. 

 
4. Drill down to iso_store>file>prod>config. 
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5. Select the configuration file you created using Application Builder. 

 Note: Configuration files have a .cfg extension. 

6. Click OK. The Add Component dialog box is displayed.  

 Note: When you select a configuration file, a default value is given to the component 
name and classname. 

 Note: The default value for Minimum Instance and Maximum Instance is 1.  

7. If necessary, configure the component. 

8. In the Add Component dialog box, click OK. 

Configure a component 
The Configure Component feature allows you to change the properties of a component. 
Mission Control allows you to re-configure the following component properties: 

•    Configuration file 

•    Class name 

•    Number of minimum instances 

•    Number of maximum instances 



Retek Point-of-Sale 
 

 

44 

Modify the configuration file 
You should not have to re-configure the configuration file of a component unless you are pointing 
to the wrong configuration. If any modifications need to made, they are normally made within the 
configuration file itself using Application Builder. 

To modify the configuration file of a component: 

1. Connect to a server. The Containers window is displayed. 

2. In the Containers window, click the container tab you wish to modify. 

3. Select Component>Configure. The Configure Component dialog box is displayed. 

4. In the Component Properties area, click the configuration file name. The configuration file 
is displayed in the Key-Value Pairs field. 

5. In the Key-Value Pairs field, highlight and delete the information after CONFIG_FILE=. 

6. Click the Configuration File button. The Choose Configuration File window is displayed. 

7. In the Choose Configuration File window, click the new configuration file. 

8. Click OK. The Key Value Pairs field is updated. 

9. In the Configure Component dialog box, click the Save button. 

10. To save the changes to the component and update the system, click OK. 

 Note: You must click OK to update the component with the new configuration file. 
Clicking the Save button does not update the component with the new configuration file. 

Modify the class name 
Modifying the class name modifies the service that the component runs. When modifying the 
class name, you must select a class that extends the CMS Component. 

To modify the class name of a component: 

1. Connect to a server. The Containers window is displayed. 

2. In the Containers window, click the container tab you wish to modify. 

3. Select the component you wish to change the class name of. 

4. Select Component>Configure. The Configure Component dialog box is displayed. 

 Note: If have not selected a component, the Select Component dialog box is displayed. 
To close the dialog box, click OK, and select a component before you begin modifying 
the classname. 

5. In the Component Properties group box, click the Specify Class Name button. The 
Select Class window is displayed. 

6. In the Select Class window, drill down to com_iso_cr and select the appropriate class 
name. 

7. Click OK. The system updates the Class Name field with the selected class name. 

8. To update the component with the new configuration file, click the Save button. 

9. To save the changes to the component and update the system, click OK. 
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 Note: You must click OK to update the component with the new configuration file. 
Selecting Save does not update the component with the new configuration file. 

Modify the number of component instances 
Mission Control allows you to modify the number of component instances so you can better 
manage the workload of each component and container.  

Modify the minimum number of component instances 
To modify the minimum number of component instances: 

1. Connect to a server. The Containers window is displayed 

2. In the Containers window, click the container tab you wish to modify. 

3. Select Component>Configure. The Configure Component dialog box is displayed. 

4. In the Component Instance area, type the number of minimum instances in the 
Minimum Instances field. 

5. Click OK. If current number of instances for this component is less than the minimum 
number of component instances, new instances of this component will be added after the next 
instance pause. 

Modify the maximum number of component instances 
Modifying the maximum number of component instances allows you to start new instances of a 
component when the workload is heavy. 

To modify the maximum number of component instances: 

1. Connect to a server. The Containers window is displayed. 

2. In the Containers window, click the container tab you wish to modify. 

3. Select Component>Configure. The Configure Component dialog box is displayed. 

4. In the Component Instance area, type the number of minimum instances in the 
Maximum Instances field. 

5. Click OK. 
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Start and stop an instance of a component 
Mission Control allows you to monitor CPU performance and memory allocation so server 
performance limitations can be documented. Using Mission Control, you can configure the server 
to spawn a new instance of a component when the threshold for concurrent threads is reached. 
However, if the number of transactions creates a workload too large to be sufficiently handled by 
the number of concurrent threads, server performance will decrease below the optimal 
performance levels. 

Start a new instance of a component 
It is recommended that you start a new instance of a component when the number of concurrent 
threads cannot sufficiently handle the current workload. A new instance will help manage the 
increased workload and number of transactions. 

To start a new instance of a component: 

1. Connect to a server. The system displays the Containers window. 

2. In the Containers window, click the container tab that stores the component you wish to start 
a new instance of. 

3. Select the component you wish to start a new instance of. The selected component is 
highlighted in blue. 

4. Select Component>Start. The Start Instance dialog box is displayed. 

5. In the Start Instance dialog box, click OK. The system starts a new instance of the selected 
component after the next instance pause and assigns it a UID after the next instance pause. 

Stop an instance of a component 
After the workload for a component has decreased, you can stop an instance of that component to 
help allocate memory back to the system. 

To stop an instance of a component: 

1. Connect to a server. The Containers window is displayed. 

2. In the Containers window, click the container tab that stores the component you wish to stop 
an instance of. 

3. Select the component you wish to stop an instance of. The selected component is highlighted 
in blue. 

4. Select Component>Shutdown. The Shutdown Instance dialog box is displayed. 

5. In the Shutdown Instance dialog box, click OK. The instance of the selected component is 
stopped after the next instance pause. 
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Using the availability feature 
The Available option allows you to make all services available or not available. The Available 
option can be found on the File menu or on the Containers window. During database or server 
maintenance, services must be taken offline. This option allows you to make all services not 
available without having to turn off each service one at a time. 

 Note: After connecting to a server, all services are available to the users and the 
Available option is selected. 

Making all services not available 
To make all services not available: 

 Note: The default mode in Mission Control is to have all the services running on a server.  

1. Connect to a server. The Containers window is displayed. 

2. Select File>Node>Available. 
OR 
Click the Available button on the Containers window. The All Services Not Available 
dialog box is displayed. 

3. In the All Services Available dialog box, select OK. All the service running on the server are 
now unavailable. 

Making all services available 
To make all services available: 

1. Connect to a server. The Containers window is displayed. 

2. Select File>Node>Available.  
OR 
Click the Available button on the Containers window. The All Services Available 
dialog box is displayed. 

3. In the All Services Available dialog box, select OK. The Container window is updated and 
all services become available. 

Deleting an existing component 
To delete an exiting component: 

1. Connect to a server. The Containers window is displayed. 

2. In the Containers window, click the container tab that stores the component you wish 
to delete. 

3. Select the component you wish to delete. 

4. Select Component Delete. The Warning dialog box is displayed. 

5. In the Warning dialog box, click OK. 

6. In the Components table, verify that Mission Control has deleted the component. 
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Viewing component log files 
Mission Control stores performance statistics and errors in log files. You can view these log files 
to monitor and manage server performance. For more information on viewing component log 
files, see Chapter 7, “Monitor Vitals and View Log Files”. 
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Chapter 5 – Working with clients 
Retek ® RPOS™ Tools Mission Control allows you to monitor client running the RPOS system 
from a remote location. After connecting to a client, you can perform the following tasks using 
Mission Control: 

• View client statistics 

• Get broken transactions 

• Launch RPOS Tools Object Inspector application tool to fix broken transactions 

• Remove broken transactions 

• Clear broken transactions 

• Clear all log exceptions 

• View client peers 

• Shut down client 

Client browser window 
The Client Browser window provides you with three tabs that allows you to monitor a client: 

• Current Statistics tab—allows you to view performance statistics and properties of 
the client. 

• Broken Transactions tab—allows you to view and retrieve broken transactions from 
the client. 

• Known Peers tab—allows you to view the other clients within the store or connected to the 
local area network (LAN). 

 Note: The default tab when opening a Client Browser window is the Current Statistics 
tab. 

 Note: The Current Statistics tab is the default tab when opening a Client Browser 
window. 

The table below lists and describes the features and information displayed on the Client Browser 
window. 

Client Browser Window Contents 

Feature Tab Description 

IP Address Current Statistics Displays the IP address of the selected client terminal. 

Process Type Current Statistics Displays the node type. A process type with a value of 2 
designates a client terminal. 

Store ID Current Statistics Displays the store ID number (unique for each store). 
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Client Browser Window Contents 

Feature Tab Description 

Register ID Current Statistics Displays the register ID number of the selected client 
terminal (unique for each store). 

Pending TXN Current Statistics Displays the number of pending transactions for the 
selected client terminal. 

Broken TXN Current Statistics Displays the number of broken transactions for the 
selected client terminal. 

Shutdown Client 
button Current Statistics Allows you to shutdown processes on the selected 

client terminal. 

View Client Logging 
button Current Statistics Allows you to view the log files of the selected client 

terminal. 

Broken Transactions 
display area Broken Transactions Displays the broken transactions on the selected client 

terminal. 

Directory Broken Transactions Displays the file directory for broken transactions. 

Get Txn button Broken Transactions Allows you to retrieve broken transactions. 

Remove Txn button Broken Transactions Allows you to remove broken transactions on the selected 
client terminal. 

Clear Txn button Broken Transactions Allows you to clear broken transactions on the selected 
client terminal. 

Known Peers display 
area Known Peers Allows you to view peers of the selected client terminal. 
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Broken transactions 
Mission Control allows you to work with broken transactions that reside on the clients. To fix a 
broken transaction, you will have to open Object Inspector. Mission Control allows you to 
perform the following tasks regarding broken transactions: 

• Retrieve a broken transaction 

• Save a broken transaction 

• Clear all broken transactions 

Retrieve a broken transaction 
Mission Control allows you to retrieve the details of the broken transaction from the client and 
either open Object Inspector to fix the transaction or save the transaction on your hard drive so 
you can fix it at a later time. 

To get a broken transaction: 

1. Connect to a client. The Client Browser window is displayed. 

2. Click the Broken Transaction tab. 

3. In the Broken Transaction display area, select a broken transaction. The selected transaction 
in blue is highlighted. 

4. Click the Get Txn button. 
OR 
Select Client>Get Transaction. The Get Transaction display box is displayed. 

 Note: If you do not select a broken transaction, the system displays the Please Select 
Transaction dialog box. To close the dialog box, click OK. 

5. To retrieve the broken transaction and launch Object Inspector, click Yes.  
OR 
To save the broken transaction onto your hard drive, click No. 

Remove a broken transaction 
After you retrieve details about a broken transaction, you can remove the transaction from the 
client terminal. 

To remove a broken transaction: 

1. Connect to a client. The Client Browser window is displayed. 

2. Click on the Broken Transaction tab. 

3. In the Broken Transaction display area, select a broken transaction. The selected transaction 
is highlighted in blue. 

4. Click the Remove Txn button. 
OR 
Select Client>Remove Transaction. The Remove Broken Transaction display box 
is displayed. 

5. In the Remove Broken Transaction display box, click Yes. The transaction is removed from 
the client terminal, and it is no longer displayed in the Client Browser window. 
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Clear all broken transactions 
After you retrieve details about a broken transaction, Mission Control allows you to remove all 
broken transactions from the client terminal at one time. The Clear Txn button allows you to 
clear all client errors from client terminal, and it deletes all files in the client.err folder. 

To remove all broken transactions: 

1. Connect to a client. The Client Browser window is displayed. 

2. Click on the Broken Transaction tab. 

3. In the Broken Transaction display area, select a broken transaction. The selected transaction 
is highlighted in blue. 

4. Click the Clear Txn button. 
OR 
Select Client>Get Transactions. The Clear Transactions display box is displayed. 

5. In the Clear Transactions display box, click Yes. The transaction is removed from the client 
terminal, and the transaction is longer displayed in the Client Browser window. 

View client peers 
The Client Browser window allows you to view other client terminals within the store or LAN. 
However, you cannot connect to them from this window. You will have to connect to a new 
client terminal using the Monitor Node feature. In the Known Peers tab, a display area shows 
the IP addresses of the client peers so you can use that information to connect to another client 
terminal within the store or LAN. 

To view client peers: 

1. Connect to a client. The Client Browser window is displayed. 

2. Click the Known Peers tab. The Known Peers display area is displayed with the 
IP addresses of client terminals on the same LAN. 

Clear log exceptions 
Clearing log exceptions clears all client errors and deletes items in the client.err folder. 

To clear log exceptions: 

1. Connect to a client. The Client Browser window is displayed. 

2. Select Client>Clear Exceptions. 
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Shut down a client 
Mission Control allows you to shut down a client terminal from a remote location.  

To shut down a client: 

1. Connect to a client. The Client Browser window is displayed. 

2. Click the Shutdown button. 
OR 
Select Client>Shutdown. The Shutdown Client display box is displayed. 

3. In the Shutdown Client display box, click Yes. The client is shutdown and the client is no 
longer displayed in the Known Peers display area. 

View client log files 
Mission Control stores performance statistics and errors in log files. You can view these log files 
to monitor and manage server performance. For more information on viewing container log files, 
see Chapter 7, “Monitor Vitals and View Log Files”. 
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Chapter 6 – Working with the naming 
server 
Retek ® RPOS™ Tools Mission Control allows you to view and monitor the remote naming 
server (RNS). The RNS serves as the middleware in the RPOS Platform, and it is responsible for 
storing references to remote objects. The clients will call on the RNS for references to services 
that are running on the application server. The naming service will then distribute these services 
to the clients. Basically, the RNS is a communication bridge between the clients and the 
application servers. 

Each service corresponds to a remote reference that is stored on the RNS. When the RNS 
distributes a remote reference, it is really distributing a reference to a component within a 
container. These components are the RPOS services that the application servers provide to the 
clients. 

 Note: The RNS can be a standalone server or reside on a master naming server or 
application server. 

Overview of the naming browser window 
The Naming Browser window provides you with a list of components and the properties of the 
selected naming server. The Naming Browser window consists of the following tabs: 

• Components tab—displays information about the available components. 

• Properties tab—displays properties of the naming server. 

 Note: The Components tab is the default tab. 

Components tab 
The Components tab displays information about the available components running on the 
application servers. The Components tab provides the following information: 

• Component name—displays the name of all the components registered with the RNS. 

• Version—displays the version of the components. The version number of a component is 
updated with each manifest or update. 

• Instances—displays the available number of instances of each component. 
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Properties tab 
The Properties tab displays general information of the connected naming server. The Properties 
tab provides the following information: 

• Debug—displays whether or not the additional logging output feature is selected or not. 

• Redirect Output—displays whether or not server activity will be sent to the log files or 
the console. 

• Monitor—displays that multi-thread monitoring of components registered with the RNS on. 
This option will spawn threads for each component and issue a ping. Also, the RNS will 
distribute the workload balance and requests by randomly selecting available services on the 
application server. 

• RNS Port—displays the port listening for TCP. 

• Vital Pause—displays the time between instance pauses. 

• Hours History—displays the amount of time that log files are recorded. 

• Socket Timeout—displays the amount of time before a socket times out. 
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Chapter 7 – Monitor vitals and view log 
files 
Retek ® RPOS™ Tools Mission Control gathers and saves performance statistics for all server 
processes. Mission Control also stores exceptions and errors in log files so you can view these log 
files in order to monitor and manage the performance of all the nodes on the network. Mission 
Controls has the following features that allow you to view performance statistics, exception 
errors, and log files: 

• Graphing component and container vitals 

• Percentage chart of components and containers 

• Log file with four levels of messages and exception errors 

Graph system vitals 
The Graph Component Vitals feature allows you to monitor, manage, and tune your system for 
the optimal performance levels. Mission Control allows you to view graphs for the following 
three levels: 

• Container vitals—displays container vitals in the Graphing Container window. 

• Component vitals—displays component vitals in the Graphing Component window. 

• Component performance vitals—displays performance vitals for the selected component in 
the Graphing Performance window. 

Each graphing level has its own unique window that opens within that displays system vitals 
specific to that level.  

Graphing windows overview 
There are three graphing windows that correspond to each graph level. The following is a list of 
graphing windows: 

• Graphing Container window—displays graphing information for container vitals. 

• Graphing Component window—displays graphing information for component vitals. 

• Graphing Performance window—displays graphing information for performance vitals. 

Graphing container window 
The Graphing Container window displays graphing information for container vitals. You can 
connect and view the Graphing Container window for multiple containers. Each time you wish 
to view the vitals for a container, Mission Control displays a new Graphing Container window.  

The Graphing Container workspace is made up a menu bar, toolbar, and the vitals graph. The 
following menu options are available from the Graphing Container window: 

• Container menu—allows you to connect to open the Graphing Component window for a 
specific component, and it displays the unique ID of the viewable container. 

• Series menu—allows you to select the container vitals you wish to view.  
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• Options menu—allows you to hide the toolbar and to display the JClass Chart Properties 
window to modify the properties of the graph. 

 
Graphing Container window 

Mission Control allows you to view the following container vitals using the graphing feature: 

• Free heap memory 

• Total heap memory 

• CPU percentage 

• Memory percentage 

• Actual memory 

• Component count 

• Total transaction count 

You can view multiple container vitals at one time. Each time you view a container vital, the 
vitals graph is updated with a value on the graph. Container values are color coded on the vitals 
graph. A legend on the bottom of the Graphing Containers window helps you distinguish the 
color coding for each container vital. 

The toolbar contains command buttons that display container vitals. The command buttons 
options for viewing container vitals correspond to the options on the Series menu. The table 
below lists and describes the container vitals and corresponding command buttons on the 
Graphing Containers window. 
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Container Vitals Options 

Graphing Option Name Description 

Free Heap Memory 

 

To view the free heap memory of a container: 
• Click the Free Heap Memory button. 
• Select Series>Free Heap Memory. 

Total Heap Memory 

 

To view the total heap memory of a container: 
• Click the Total Heap Memory button. 
• Select Series>Total Heap Memory. 

CPU Percentage 

 

To view the CPU percentage of a container: 
• Click the CPU Percentage button. 
• Select Series>CPU Percentage. 

Memory Percentage 

 

To view the memory percentage of a container: 
• Click the Memory Percentage button. 
• Select Series>Memory Percentage. 

Actual Percentage 

 

To view the actual percentage of memory of a container: 
• Click the Actual Percentage button. 
• Select Series>Actual Percentage. 

Component Count 

 

To view the component count of a container: 
• Click the Component Count button. 
• Select Series>Component Count. 

Total Transaction Count 

 

To view the total transaction count of a container: 
• Click the Total Txn Count button. 
• Select Series>Total Txn Count. 

 Note: A selected viewing option appears darkened.  
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Graphing components window 
The Graphing Component window displays graphing information for component vitals. You 
can view component vitals for multiple components simultaneously. From the Graphing 
Component window, you can display performance vitals for the components running on the 
application server.  

The Graphing Component workspace is made up a menu bar, toolbar, and the vitals graph. The 
following menu options are available from the Graphing Container window: 

• Component menu—lists all the components running on an application server, and it allows 
you to select which components you wish to view vitals for. Also, this menu allows you to 
open the Graphing Performance window for a specific component. 

• Series menu—allows you to select the component vitals you wish to view.  

• Options menu—allows you to hide the toolbar and to display the JClass Chart Properties 
window to modify the properties of the graph. 

 
Graphing Component window 

Mission Control allows you to view the following component vitals using the graphing feature: 

• Current connections 

• Maximum connections 

• Maximum connect time 

• Total transaction count 

• Transactions per period 

You can view multiple component vitals at one time. Each time you view a component vital, the 
vitals graph is updated with a value on the graph. Component values are color coded on the vitals 
graph. A legend on the bottom of the Graphing Components window helps you distinguish the 
color coding for each component vital. 
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The toolbar contains command buttons that display component vitals. The command buttons 
options for viewing component vitals correspond to the options on the Series menu. The table 
below lists and describes the component vitals and corresponding command buttons on the 
Graphing Components window. 

Component Vitals options 

Graphing Option 
Name Description 

Current Connections 

 

Displays the current connection statistics for the selected 
components. 
To display the current connections of a component: 
• Click the Current Connections button. 
• Select Series>Current Connections. 

Maximum Connections 

 

Displays the maximum connections statistics for the selected 
components. 
To display the maximum connections of a component: 
• Click the Maximum Connections button. 
• Select Series>Maximum Connections. 

Maximum Connect Time 

 

Displays the maximum connect time for the selected components. 
To display the maximum connect time of a component: 
• Click the Maximum Connect Time button. 
• Select Series>Maximum Connect Time. 

Total Txns Count 

 

Displays the total transaction count for the selected components. 
To display the total transaction count for a component: 
• Click the Total Txns Count button. 
• Select Series>Total Txns Count. 

Txns Per Period 

 

Displays the transactions per period for the selected components. 
To display the transactions per period on a graph: 
• Click the Txns Per Period button. 
• Select Series>Txns Per Period. 

 Note: A selected viewing option appears darkened.  
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Graphing performance window 
The Graphing Performance window displays graphing information for performance vitals. 
Performance vitals record how long methods took to execute. The Graphing Performance 
window displays performance vitals for a single component. However if the component is a 
service with multiple methods within it, you can view the performance vitals of multiple methods 
simultaneously.  

The Graphing Performance workspace is made up a menu bar and the performance graph. The 
following menu options are available from the Graphing Performance window: 

• Methods menu—allows you to connect to the methods within the service. 

• Series menu—allows you to select the performance vitals you wish to view.  

• Options menu—allows you to hide the toolbar and to display the JClass Chart Properties 
window to modify the properties of the graph. 

 
Graphing Performance window 

Mission Control allows you to view the following component vitals using the graphing feature: 

• Average time—records the average time for a method to execute. 

• Maximum time—records the maximum time for a method to execute. 

• Minimum time—records the minimum time for a method to execute. 

 Note: Unlike the Graphing Container window and Graphing Component window, the 
Graphing Performance window does not have a toolbar with command buttons that 
correspond to the Series menu. To view performance vitals for a component, select the 
Series menu and then the performance option. 
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Graph container vitals 
To graph container vitals: 

1. Connect to an application server. The Containers window for that application server 
is displayed. 

2. On the Containers window, select the container you wish to view the vitals for. The selected 
container is highlighted in blue. 

3. Click the Component Vitals Graph button. 
OR 
Select Graph>Vitals. The Graphing Container window is displayed. 

 Note: If you do not select a container before selecting the graphing feature, the 
Select Container dialog box is displayed. To close the dialog box, select OK. 

4. From the toolbar, select the appropriate command button for the vital you wish to view.  
OR 
Select Series and the appropriate menu option for the vital you wish to view. A line graph 
representing the vital is displayed on the vitals graph. 

 Note: For a list of component vitals you can view and monitor, see “Container Vitals 
Options”. 

View multiple container vitals 
You can view multiple container vitals simultaneously. Container vitals are color coded so you 
can easily distinguish between container vitals. Each time you view a container vital, the graph 
legend displays the selected container vitals and the assigned color.  

To view multiple container vitals simultaneously: 

1. Connect to an application server and view the Graphing Container window. 

2. From the toolbar, select the appropriate command button for the vital you wish to view.  
OR 
Select Series and the appropriate menu option for the vital you wish to view. A line graph 
representing the vital is displayed on the vitals graph. 

3. To display multiple container vitals simultaneously, repeat step 2. A new line graph 
representing the selected vital is displayed on the vitals graph along with previously 
selected vitals. 
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Deselect container vitals 
After you have displayed multiple container vitals for a container, you can deselect a container 
vital so it no longer is displayed on the Graphing Container window. To deselect a container 
vital:  

 Note: If a container vital has been selected and is currently displayed on the vitals graph, 
the command button is darkened and a check is displayed by the menu option on the 
Series menu. 

1. Click on the appropriate previously selected command button. 
OR 
Select Series and the appropriate previously selected menu option to deselect a 
container vital. The container vital is no longer displayed on the vitals graph. 

2. To deselect more container vitals so they no longer appear on the vitals graph, repeat Step 1. 

Show and hide graphing container window toolbar 
Mission Control allows you to show or hide the toolbar on the Graphing Container window. 
Remember, the Series menu options correspond with the command buttons that appear on the 
toolbar. When you first connect to the Graphing Container window, the toolbar is displayed.  

To hide the Graphing Container window toolbar: 

• Select Options>Show Toolbar. The checkbox is deselected , and the toolbar and command 
buttons are no longer displayed on the Graphing Container window. 

Modifying chart options 
The Chart Options menu option allows you to customize the appearance of the vitals graph. The 
Chart Options button starts Sitraka’s JClass Chart Customizer that allows you to customize and 
view the graph properties. 

To customize the graph properties: 

1. Select Options>Chart Options. 
OR 
Click the Chart Options button. The JClass Chart Properties dialog box is displayed. 

2. On the JClass Chart Properties dialog box, make the necessary changes to the appearance 
of the container vitals graph. 

 Note: Visit the Sitraka website at //www.sitraka.com for documentation on the 
JClass Chart Customizer. 
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Graph component vitals 
To graph component vitals: 

1. Connect to an application server. The Containers window for that application server 
is displayed. 

2. On the Containers window, select the container you wish to view the vitals for. The selected 
container is highlighted in blue. 

3. Select Graph>Vitals. 
OR 
Click the Component Vitals Graph button. The Graphing Container window is displayed. 

 Note: If you do not select a container before selecting the graphing feature, the 
Select Container dialog box is displayed. To close the dialog box, select OK. 

4. Click the Graph Components button.  
OR 
Select Container>Graph Components. The Graphing Component window is displayed. 

5. From the toolbar, select the appropriate command button for the component vital you wish 
to view.  
OR 
Select Series and the appropriate menu option for the component vital you wish to view. A 
line graph representing the vital is displayed on the vitals graph. 

 Note: For a list of component vitals you can view and monitor, see Table 7-2, 
“Component Vitals Options". 

 Note: By default, the vitals for all components within the selected container are 
displayed. 

Deselect a component 
By default, the vitals for all components within a container are selected when you open the 
Graphing Components window. If you graph a component vital, the results for all components 
within the selected container will be displayed. You can modify the results to display the vitals 
for only the desired components within a container by deselecting a component so it is no longer 
displayed on the vitals graph. 

To deselect a component: 

1. On the Graphing Components window, select Component>Show Component. A submenu 
with all the available components is displayed. All listed components are selected with a 
check mark. 

2. On the submenu, select the component you no longer wish to view the component vitals for. 
Component vitals for the deselected component are no longer displayed on the vitals graph. 

3. To deselect multiple components, repeat steps 1-2. 
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View multiple component vitals 
You can view multiple component vitals simultaneously. Component vitals are color coded so 
you can easily distinguish between component vitals. Each time you view a component vital, the 
graph legend displays the selected component vitals and the assigned color.  

To view multiple component vitals simultaneously: 

1. Connect to an application server and view the Graphing Component window. 

2. From the toolbar, select the appropriate command button for the vital you wish to view.  
OR 
Select Series and the appropriate menu option for the vital you wish to view. A line graph 
representing the vital is displayed on the vitals graph. 

3. To display multiple container vitals simultaneously, repeat step 2. A new line graph 
representing the selected vital is displayed on the vitals graph along with previously 
selected vitals. 

Deselect component vitals 
After you have displayed multiple vitals for a component, you can deselect a component vital so 
it is no longer displayed on the Graphing Component window.  

To deselect a component vital:  

 Note: If a component vital has been selected and is currently displayed on the vitals 
graph, the command button is darkened and a check is displayed by the menu option on 
the Series menu. 

1. Click on the appropriate previously selected command button. 
OR 
Select Series and the appropriate previously selected menu option to deselect a 
container vital. The component vital is no longer displayed on the vitals graph. 

2. To deselect more component vitals so they are no longer displayed on the vitals graph, repeat 
Step 1. 

Show and hide graphing component window toolbar 
Mission Control allows you to show or hide the toolbar on the Graphing Component window. 
Remember, the Series menu options correspond with the command buttons that appear on the 
toolbar. When you first connect to the Graphing Container window, the toolbar is displayed.  

To hide the Graphing Component window toolbar: 

• Select Options>Show Toolbar. The checkbox is deselected , and the toolbar and command 
buttons are no longer displayed on the Graphing Component window. 



Chapter 7 – Monitor vitals and view log files 
 

 

67 

Modify chart options 
The Chart Options menu option allows you to customize the appearance of the vitals graph. The 
Chart Options button starts Sitraka’s JClass Chart Customizer that allows you to customize and 
view the graph properties. 

To customize the graph properties: 

1. Select Options>Chart Options. 
OR 
Click the Chart Options button. The JClass Chart Properties dialog box is displayed. 

2. On the JClass Chart Properties dialog box, make the necessary changes to the appearance 
of the container vitals graph. 

 Note: Visit the Sitraka website at //www.sitraka.com for documentation on the 
JClass Chart Customizer. 

Graph performance vitals 
To graph performance vitals for a component: 

1. Select Component >Show Performance Vitals. 
OR 
On the Graphing Components window, click the Show Performance Vitals button. The 
Select Component to View Performance dialog box is displayed. This dialog box lists all 
the available components you can view performance vitals for. 

2. Select the component you wish to view performance vitals for. The selected component is 
highlighted in blue. 

3. Click OK. The Graphing Performance window is displayed. The performance graph 
is empty. 

4. Select Series and then the appropriate performance vital you wish to view. The performance 
graph displays the performance statistics for the selected vital.  

 Note: By default, all methods are selected when you first display the Graphing 
Performance window. The performance graph will display performance statistics for all 
methods within the selected component or service. 

View multiple performance vitals 
You can view multiple performance vitals simultaneously. Performance vitals are color coded so 
you can easily distinguish between performance vitals. Each time you view a performance vital, 
the graph legend displays the selected performance vitals and the assigned color.  

To view multiple component vitals simultaneously: 

1. On the Graphing Performance window, select Series and the appropriate menu option for 
the vital you wish to view. A bar graph representing the vital is displayed on the vitals graph. 

2. To display multiple performance vitals simultaneously, repeat step 1. A new bar graph 
representing the selected vital is displayed on the vitals graph along with the previously 
selected vitals. 
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Deselect performance vitals 
After you have displayed multiple performance vitals for a component, you can deselect a 
performance vital so it is no longer displayed on the Graphing Performance window.  

To deselect a performance vital:  

1. Select Series and the appropriate previously selected menu option to deselect a performance 
vital. The performance vital is no longer displayed on the performance graph. 

2. To deselect more performance vitals so they are no longer displayed on the performance 
graph, repeat Step 1. 

Deselect a method 
By default, the Graphing Performance window displays performance vitals for all methods 
within a component. Mission Control allows you to customize which methods will be displayed 
on the performance graph. You to deselect a method so it no longer is displayed on the 
performance graph. 

To deselect a method:  

1. On the Graphing Performance window, select Methods>Show Methods. A submenu with 
all the available methods is displayed. All listed methods are selected with a check mark. 

2. On the submenu, select the method you wish to no longer view the performance vitals for. 
Performance statistics for the selected method are no longer displayed on the 
performance graph. 

3. To deselect multiple methods, repeat steps 1-2. 
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View percentage charts 
The Percentage Chart features allows you to view and monitor the workload of each container 
and component. The percentage charts display the number of transactions per container or 
component so you can balance the workload for optimal performance levels.  

Percentages window overview 
The Percentages window shows the number of instances of a container or component compared 
to the number of transaction performed by a container or component. Each of these numbers is 
displayed in pie charts that appear side-by-side for comparison purposes. This view allows you to 
increase and decrease the percentage used by a component to match the percentages of the 
transactions performed. Ideally in a production environment, the percentages chart for 
transactions will match the percentage charts for either the containers or components. 

 
Percentages window 

The Percentages window contains one menu item, the Options menu, and it does not have a 
toolbar or command buttons. The Options menu contains the following menu options: 

• View by Container—Allows you to view the Transactions by Container chart. This is the 
default setting. 

• View by Component—Allows you to view the Transaction by Component chart. 

• Chart Options—Allows you to customize the appearance of the percentage charts. 
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Viewing options 
The viewing options on the Percentages window allow you to customize the percentages chart 
and the information displayed on the Percentages window. The table below lists and describes 
the viewing options. 

Percentages Window Viewing Options 

Viewing Option Description 

Threshold slider 

Allows you to customize the appearance of the chart by 
increasing or decreasing the threshold value. The threshold 
value is the percent of transactions a component performed 
during the time performance statistics were collected. 
Increasing or decreasing the threshold value along the slider 
will either increase or decrease the number of pieces that 
appear on the chart.  

Containers and Containers 
list 

Allows you to display a label over the corresponding piece of 
the pie chart. Multiple labels can be viewed at one time. The 
containers list displays the name of the connected container. 
The components list displays all the components within the 
connected container. 

Labels 
Displays the container name, component name, and number 
of transactions that the container or component performed 
over the corresponding piece of the pie chart.  

View percentage charts 
To view the percentage charts: 

1. Connect to an application server. The Containers window for that application server 
is displayed. 

2. On the Containers window, select the container you wish to view the vitals for. The selected 
container is highlighted in blue. 

3. Select Graph>Percentages. 
OR 
Click the Chart Percentages button. The Percentages window is displayed. 

 Note: By default, the Percentages window displays the Transaction by Container 
graph. 
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Change percentage chart 
By default, the Percentages window displays the Transaction by Container chart when you 
first connect to the Percentages window. The Percentages window allows you to view the 
following percentage charts: 

• View by Container 

• View by Component 

To change the displayed percentage chart: 

• On the Percentages window, select Options and then the appropriate menu option for the 
percentage chart you wish to view. For example, if you wish to view the percentage chart for 
a component, select Options>View by Component. The selected percentage chart is 
displayed on the Percentages window. 

Modify the threshold percentage 
The threshold slider allows you to customize the appearance of the chart by increasing or 
decreasing the threshold value. The threshold value is the percent of transactions a component 
performed during the time performance statistics were collected. Increasing or decreasing the 
threshold value along the slider will either increase or decrease the number of pieces that appear 
on the chart. 

To modify the threshold percentage: 

• Move threshold slider to the desired percentage value. If the threshold percentage is greater 
than the threshold percentage of a container or component, the corresponding piece of the 
pie chart disappears. The piece of the pie chart is added to a combined piece that represents 
all containers or components that have a threshold percentage less than the chosen 
threshold percentage. 

Display labels 
Mission Control allows you to display labels for each piece of the percentages chart. The labels 
display the following information for a container and component: 

• Name  

• Number of instances 

• Number of transactions performed by the container or component 

When you display a label, the label appears on the percentage chart for both the percentage and 
container or component, depending on which view you have displayed. This allows you to see the 
relationship between the number of transactions a container or component is performing to the 
number of instances of a container or component. With this information, you can make decisions 
regarding the workload of a container or component. Also, you can display multiple labels at one 
time.  
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To display a label: 

1. Select the name of the container or component from the container or component list. 
The selected container or component is highlighted in blue and the corresponding label 
is displayed. 
OR 
Click the desired piece of the percentage chart in the transactions chart. The corresponding 
container or component is highlighted in the container or component list. 
OR 
Click the desired piece of the percentage chart in the container or components chart. The 
corresponding container or component is highlighted in the container or component list. 

2. To display multiple labels, repeat step 1. 

Design options 
The Options button on the Percentages window allows you to customize the appearance of the 
performance charts and the Percentages window itself. The Options button starts Sitraka’s 
JClass Chart Customizer that allows you to customize and view the graph properties. 

To customize the graph properties: 

1. Select the Options button. 

2. Select from the various options. 

 Note: Visit the Sitraka website at //www.sitraka.com/ for documentation on JClass Chart 
Customizer. 

Log files overview 
Mission Control allows you to view the following log files: 

• Containers log file—Allows you to view system out files, system error files, and event logs. 

• Components log file—Allows you to view log files that can be filtered by levels. 

• Clients log file—Allows you to view log files, system out files, and system error files. 

When you connect to a application server or client to view log files, the View Log File window is 
displayed. The viewing options in the View Log File window varies for containers, components, 
and clients.  
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Container log files 
The table below provides the information and options displayed on the View Log File window 
for containers. 

View Log File Window Properties for Containers 

Window Property Description 

UID Provides the unique ID for the container you are viewing log 
files for. 

System Out radio button Allows you to view system out files. 

System Error radio button Allows you to view system error files. 

Events radio button Allows you to view event logs. 

Refresh button Allows you to refresh the View Log File window to display 
either an updated log file or a new log file. 

Clear System Error button Allows you to clear all error files from a container. 

Save button Allows you to save log files as a text file. 

Close button Allows you to close the View Log File window. 

View container log files 
To view container log files: 

1. Connect to an application server. The Containers window is displayed for the 
connected server. 

2. Select the container you view to view log files for. The selected container is highlighted 
in blue. 

3. Select Container>View Logs. 
OR 
Click the Logging button. The View Log Files window is displayed. 

 Note: If you do not select a container, the Select Container dialog box is displayed. 

4. Choose the type of log file you wish to view. By default, the Events option is selected. 

5. Click the Refresh button. The log files for the selected option is displayed. 

6. To view a different log file, repeat steps 4 and 5. 
OR 
To refresh the current log files, click the Refresh button. 
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Clear the system error files 
The Clear System Error option allows you to clear all system error files for the selected 
container. When a container contains a system error, the Exception button is displayed in red. 
After you clear all system errors, the Exception button is displayed in green. 

To clear the all system error files for a container: 

1. View the log files for the container that contains the exception error. 

2. On the View Log Files window, click the Clear System Error button. The Clear Error Log 
dialog box is displayed. 

3. On the Clear Error Log dialog box, click Yes. The Error Log Cleared dialog box 
is displayed. 

4. On the Error Log Cleared dialog box, click OK.  

Save container log files 
Mission Control allows you to save container log file as text files. You can save these files in a 
user-defined directory. 

To save container log files: 

1. View the log files for the type of log files you wish to save. 

2. Click the Save button. The Save dialog box is displayed. 

3. Select the directory you wish to save the log files in. 

4. On the Save dialog box, click the Save button. The selected log file is saved as a text file in 
the defined directory. 

Component log files 
The table below provides the information and options displayed on the View Log File window 
for components. 

View Log File Window Properties for Components 

Window Property Description 

Entries Retrieved Allows you to control the number of entries to display. 

Log File Type drop-down 
menu Allows you to view a type of log file.  

Refresh button Allows you to refresh the View Log File window to display 
either an updated log file or a new log file. 

Save button Allows you to save log files as a text file. 

Close button Allows you to close the View Log File window. 
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View component log files 
Mission Control allows you to customize your log file properties using the Log File Type drop-
down menu. The types of log files are divided into hierarchical levels of severity. There are four 
levels of log files that correspond with the information contained within them. The following are 
the four different types of log files: 

• Informational—Stores all the information logged by the system, including minor, major, and 
fatal errors and exceptions. 

• Minor—Stores all minor, major, and fatal errors and exceptions. 

• Major—Stores all major and fatal errors. 

• Fatal—Stores all fatal errors only. 

When viewing a type of log file, Mission Control displays not only the selected type of log file, 
but all types of log files above it in the hierarchy. For example, if you choose to view all Major 
execption errors, Mission Control will display both Major and Critical execption errors. 

To view component log files: 

1. Connect to an application server. The Containers window is displayed for the 
connected server. 

2. Select the component you view to view log files for. The selected component is highlighted 
in blue. 

3. Select Component>View Logs. 
OR 
Click the Logging button. The View Log Files window is displayed. 

 Note: If you do not select a component, the Select Component dialog box is displayed. 
Click OK to close the dialog box. 

 Note: If there are no log file entries, the No Log File Entries dialog box is displayed. 

4. Click the Log File Type drop-down menu and select the type of log file you wish to view. By 
default, the Info option is selected. 

5. Click the Refresh button. The log files for the selected type of log file are displayed on the 
View Log Files window. 

Modify number of entries retrieved 
Mission Control allows you to modify the number of entries retrieved and displayed on the 
View Log Files window. To modify the number of entried retrieved and displayed: 

1. On the View Log Files window, enter the maximum number o fentried you wish to retrieve. 

2. Click the Refresh button. Mission control refreshes the View Log Files window with the 
most recent error files.  
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Change the type of log file displayed 
By default, the View Log Files window displays all four types of log files. You can modify the 
type of log file displayed on the View Log Files. Remember, Mission Control displays not only 
the selected type of log file, but all types of log files above it in the hierarchy. 

To change the type of log file displayed: 

1. Click the Log File Type drop-down menu and select the type of log file you wish to view. 

2. Click the Refresh button. The log files for the selected type of log file are displayed on the 
View Log Files window. 

3. To view additional log file types, repeat steps 1-2. 

Save container log files 
Mission Control allows you to save component log file as text files. You can save these files in a 
user-defined directory. 

To save component log files: 

1. View the log files for the type of log files you wish to save. 

2. Click the Save button. The Save dialog box is displayed. 

3. Select the directory you wish to save the log files in. 

4. On the Save dialog box, click the Save button. The selected log file is saved as a text file in 
the defined directory. 
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Chapter 8 – Message monitor 
Retek® RPOS™ Tools Mission Control allows you to publish (send) messages to clients and 
server-side components using a Java Messaging Service (JMS) Server. Mission Control employs 
the publish/subscribe messaging model in which messages are published to and retrieved from 
named topics.   

Using Message Monitor, you can view your network topology. The network topology allows you 
to view representations of each RPOS process, including IP addresses, configuration ports, and 
exceptions that occur with each process. By expanding and collapsing the view of the network 
topology, you can drill down all the way to a client register running in a store. While viewing the 
network topology, Message Monitor allows you to connect to any node on the network without 
having to enter an IP address or port number. 

Message Monitor allows you to perform the following tasks: 

• View the network topology in a hierarchical view of IP addresses 

• Connect to a node (client, naming server, or application server) on the network 

• Publish messages 

• View exception errors and start RPOS Tools Object Inspector 

Connect to message monitor 
You can connect to Message Monitor the same way you would any node on the network. Before 
you can connect to Message Monitor, you will have to set up Message Monitor using the 
Monitor feature. See Chapter 2, “Set Up a Node,” for more information on setting up and 
connecting to Message Monitor. 

After you connect to Message Monitor, the Message List window and the Message Monitor 
window are displayed. The Message List window is displayed within the Mission Control 
workspace while the Message Monitor window is displayed as a separate window from the 
Mission Control workspace. 

Message list window overview 
The Message List window is displayed within the Mission Control workspace after you connect 
to Message Monitor. The Message List window displays the following information: 

• Message—Provides the names of the published messages. 

• Topic—Provides the topics of the published message. 

• Next Date—Provides the dates in which the messages were published. 

• Modify Message button—Allows you to modify published messages by opening the 
Message Wizard. 

• Delete Message button—Allows you to delete published messages. 
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Message List window 

Message monitor window overview 
The Message Monitor window is displayed as a separate window from the Mission Control 
workspace. The Message Monitor window displays the network topology that allows you to drill 
down and view the different levels and nodes on the network, connect remotely to nodes, assign 
icons to nodes, view exceptions, and launch Object Inspector.  

 
Message Monitor window 
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View network topology 
Message Monitor provides a hierarchical view of the RPOS clients and servers in your network. 
The hierarchy is based on a grouping of stores and server-side components. The grouping 
structure is configurable. The root node is generally the company name and all other nodes 
branch out from that root node. 

In the RPOS system, a store object knows which group it belongs to, and the clients or registers 
within the store are automatically grouped to that store. The message grouping is used to target 
messages to specific groups. 

Message Monitor allows you to view the network topology based on your needs. You can view 
the network from something as general as the different countries within the network or you can 
drill down to an actual store client in New York City.  

To view the network topology: 

• Connect to Message Monitor. The Message Monitor window is displayed as a separate 
window from the Mission Control workspace. 

 Note: The view of your network topology may be different each time you connect to 
Message Monitor. The viewable nodes in the Message Monitor window are all nodes on 
the same level as the node last doubled clicked during the last session of Mission Control 
and Message Monitor. For example, the last time you used Message Monitor, you viewed 
a specific client in your Houston store #115. The next time you use Message Monitor, the 
viewable nodes in the Message Monitor window will be the store level because that was 
the last node you double clicked to expand. 

Expand a node or level 
In the RPOS system, Message Monitor allows you to expand the network topology and drill 
down to the client level. Expanding a node does not expand all nodes on that level, just the 
selected node. To expand a node or level on the network topology: 

1. Connect to Message Monitor. The Message Monitor window is displayed with a view of the 
network topology. 
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2. Double click on the node or level you wish to expand. An expanded view of the network 

topology is displayed, and you can view the next level on the network. 

 
3. To drill down and expand the network topology to display more nodes or levels on the 

network, repeat Step 1. 
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Collapse a node or level 
Message Monitor also allows you to collapse a node or level on the network. Collapsing a node 
does not collapse all nodes on that level, just the selected node. To collapse a level, you must 
double click on the grandparent level of the level you wish to collapse. For example, your 
network is grouped into a state level, a store level, and a client level. You have expanded the 
network topology to view the client level but now you are ready to collapse that level and no 
longer view the client level. Double clicking on the client or the store level will not collapse the 
client level. You must double click the grandparent level, and in this case, the state level.  

To collapse a specific level on the network topology: 

1. Double click on the grandparent level of the level you wish to collapse. The network 
topology will collapse, and you can no longer view that level. 

 
2. Repeat Step 1 to collapse another level. 

To collapse the entire network topology: 

• Double click on the root node of the network topology. The network topology will collapse to 
display only the root node and the subsequent level. 

Assign icons to nodes 
You can assign icons to nodes on the network. Assigning icons to nodes helps you view and 
identify different nodes and levels on the network. The icon assigned to node can be any image 
file, such as a GIF or JPEG file. The following are two ways you can assign icons to nodes and 
levels: 

• Assign an icon to all nodes on a level 

• Assign an icon to all nodes with this name 
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Assign an icon to all nodes on a level 
Mission Control and Message Monitor allow you to assign icons to all nodes on a selected level. 
This feature allows you to create a uniform network-wide appearance for all nodes on a specific 
level. For example, you can group your network into countries, states or provinces, cities, stores, 
and client terminals. You can assign a different icon to represent city, store, and client levels. A 
separate icon for each node or level helps distinguish that level from the other levels on 
the network. 

To assign an icon to all nodes on a level: 

1. Connect to Message Monitor. The Message Monitor window is displayed with a view of the 
network topology. 

2. Right click on a node on the network level you wish to assign the icon to level-wide. A pop-
up list is displayed. 

 
3. In the pop-up list, select Assign Icon. The Choose Icon for Node dialog box is displayed. 
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4. To select an image file that is located in a directory: 

a. Click the Find Icon button. The Directory dialog box is displayed. 

b. In the Directory dialog box, locate and select the desired image file. The selected image 
file is highlighted in blue. 

 
c. Click OK. The selected image file is displayed in the Choose Icon for Node dialog box. 

OR 
To select an image file that is located in a JAR file in the classpath: 

a. In the Icon Path field, type the classpath for the image file. Begin the classpath by 
typing jar/ and then the rest of the classpath. 

b. After you have typed the classpath for the image file, press Enter. The selected 
image file is displayed in the Choose Icon for Node dialog box.  

5. In the Choose Icon for Node dialog box, verify that the correct icon has been selected. 
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6. Select the Apply to All Nodes on This Level checkbox. 

7. Click OK. The selected icon is displayed for all nodes on the selected level. 

 

Assign an Icon to Only Nodes with the Same Name 
Mission Control and Message Monitor allows you to assign icons to only nodes or levels with the 
same name. This feature allows you to localize a icon for a specific node or level. For example, 
you set up Message Monitor to group your network by countries, states or provinces, cities, 
stores, and then client terminals. If you have stores in the United States, Canada, and Mexico, you 
can use each countries’ flag to represent that particular node. Also, you can use the state flag for 
each state to help you distinguish the different nodes on that particular network level. 

To assign an icon to only nodes with the same name: 

1. Connect to Message Monitor. The Message Monitor window is displayed with a view of the 
network topology. 

2. Right click on a node on the network level you wish to assign the icon to level-wide. A pop-
up list is displayed. 
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3. In the pop-up list, select Assign Icon. The Choose Icon for Node dialog box is displayed. 

 
4. To select an image file that is located in a directory: 

a. Click the Find Icon button. The Directory dialog box is displayed. 

 
b. In the Directory dialog box, locate and select the desired image file. The selected image 

file is highlighted in blue. 

c. Click OK. The selected image file is displayed in the Choose Icon for Node dialog box. 
OR 
To select an image file that is located in a JAR file in the classpath: 

a. In the Icon Path field, type the classpath for the image file. Begin the classpath 
by typing jar/ and then the rest of the classpath. 

b. After you have typed the classpath for the image file, press Enter. The selected 
image file is displayed in the Choose Icon for Node dialog box.  
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5. In the Choose Icon for Node dialog box, verify that correct icon has been selected. 

 
6. Select the Apply Only to Nodes With This Name checkbox. 

7. Click OK. The selected icon is displayed on all nodes with the same name as the 
selected node. 
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Connect to a node 
Using Message Monitor, you can connect to any node or device on the network without having to 
enter an IP address or port number for a node. Connecting to a node allows you to view, manage, 
and monitor that node from a remote location. 

After you connect to a node using Message Monitor, the appropriate window is displayed in the 
Mission Control workspace. For example, connecting to a client using Message Monitor will 
display the Client Browser window for the selected client. You can connect to multiple nodes at 
one time. 

To connect to a node using Message Monitor: 

1. Connect to Message Monitor. The Message Monitor window is displayed with a view of the 
network topology. 

2. Drill down to the network level that contains the node you wish to connect to. 

3. Right click on a node you wish to connect to. A pop-up list is displayed. 

 
4. In the pop-up list, select Connect. In the Mission Control workspace, the appropriate 

window is displayed depending on the type of node you connected to. 
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Publish a message 
Message Monitor allows you to send messages to specific message groups. For example, you can 
send a message to the Dallas, Texas group that will be received by all nodes and devices 
subscribed to the Dallas, Texas group. This message will not be received by the Houston, Texas 
group. However, if you send a message to the entire Texas group, this message will be received 
by all nodes and devices subscribed to the Texas group, including the Dallas and Houston groups. 

Mission Control employs the Message Wizard to assist you in creating and publishing a 
message. To create a message using Message Wizard, you will need to provide the following 
information: 

• Message name—It is recommended you select a name that describes the purpose or contents 
of the message. This name will not be seen by receivers of the message, but it is used to save 
the message to be sent again later. 

• Group name—The group name is the name of the group that will receive this message. The 
default group name is the node group of the node you right clicked. However, you can change 
the group name using the Message Wizard. 

• Topic key—The topic key is the topic that subscribers will listen for to receive this message. 
Only nodes within the group name that are subscribed to this topic will receive this message. 
You select a topic from a drop-down menu. 

• Message properties—You will build the contents of the message by adding key-value pairs. 
The key-value pairs can be instructions for a subscriber to receive information or perform a 
task. For example, if you are sending a corporate message, you will need to add a key-value 
pair for the message itself and the start and stop date of the message.  

• Desired action—The message can be schedule as a one-time event, regular event, or 
schedule with a specific JavaSchedule Java object. 
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• JobSchedule classname—You may have to build a JobSchedule JavaClass by specifying 
a classname. 

After you have created the message, you will have to confirm the contents and actions of the 
message. Message Wizard allows you to view the message properties at once so you can either 
send the message or make the necessary changes. 

To publish a message: 

1. Connect to Message Monitor. The Message Monitor window is displayed with a view of the 
network topology. 

2. Right click on the parent node you wish to publish the message to. A pop-up list is displayed. 

 
3. In the pop-up list, select Publish Message. The Message Wizard is displayed. 

 
4. Follow the eight steps within the Message Wizard to successfully create and send a message 

using Message Monitor.  
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5. After you have created a new message, click the Finish button on the Message Wizard. The 
Message Posted dialog box is displayed, and the message information is displayed in the 
Message List window in the Mission Control workspace. 

 
6. In the Message Posted dialog box, click OK. The Post Message Now dialog box 

is displayed. 

 
7. If you want to post the message now, click Yes. 

OR 
If you want to post the message at another time, click No or the Cancel button. 

8. To close Message Wizard, click OK. 
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Modify a message 
Mission Control allows you to modify an existing message from the Message List window. The 
Message Wizard is displayed so you can make modifications to the properties of the message. 

To modify a message: 

1. Connect to Message Monitor. The Message List window is displayed in the Mission Control 
workspace. 

2. In the Message List window, select the message you wish to modify. The selected message is 
highlighted in blue. 

 
3. Click the Modify Message button. The Message Wizard is displayed in the 

Message Monitor window. 
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4. Using the Message Wizard, locate the message property you wish to change.  

 Note: To navigate through the Message Wizard, click the Next button. 

5. Make the necessary changes to the message. 

6. After you have made all your changes, click the Finish button. The Message Wizard is no 
longer displayed, and your changes to the message are saved. 

Delete a message 
Mission Control allows you to delete a message. To delete a message: 

1. Connect to Message Monitor. The Message List window is displayed in the Mission Control 
workspace. 

2. In the Message List window, select the message you wish to delete. The selected message is 
highlighted in blue. 

 
3. Click the Delete Message button. The Delete Message dialog box is displayed.  

 
4. Click OK. The message is no longer displayed in the Message List window. 
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View broken transactions in RPOS tools object 
inspector 
Message Monitor allows you to view the object that represents that particular node in RPOS 
Tools Object Inspector. If a node contains an exception error, the parent level is displayed with a 
red border in Message Monitor. You will have to drill down to the node and examine the 
exception in Object Inspector. 

To view a broken transaction in Object Inspector: 

1. Connect to Message Monitor. The Message Monitor window is displayed with a view of the 
network topology. 

2. Right click on the node that contains the exception. A pop-up list is displayed. 

 
3. In the pop-up list, select Launch OI. Object Inspector is started in a separate window from 

both the Mission Control workspace and the Message Monitor window. 
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 Note: For more information on how to view or fix broken transaction using 

Object Inspector, see the RPOS Tools Object Inspector User Guide. 
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Chapter 9 – Manifest process 
Software updates and data file updates are pushed out from the application server in an automated 
process called a manifest. The manifest can contain any combination of files, including the 
following: software updates, images, binary files, text files, JVMs, PLU updates, and so on. The 
process uses a combination of TCP/IP and UPD/IP for peer-to-peer (P2P) pushes of the manifest 
between client terminals. 

There are two types of manifest updates: full and incremental. A manifest is pushed out to the 
clients in a two-phase process. Each client is scheduled to check for updates at a pre-scheduled 
time determined by the system administrator. 

If there is more than one client in a store, the first client that receives the manifest will lock out all 
other clients in that location from receiving the manifest. Once the first client receives the 
manifest, it uses P2P networking to update the remaining in-store clients. The initial push sends 
the updates in a “wait-to-install” state that allows system administrators time to check the 
manifest logs and verify that all clients receive the updates and that there are no network or 
hardware outages.  

You can change the manifest status to install on the application server, or the update is 
completely removed. When each client checks in at a pre-scheduled time and sees the status as 
“install,” the client installs the new software or data files. The system administrator can now view 
the manifest logs to determine if there are any errors or clients that did not install the manifest 
properly. 

The following is the manifest process using RPOS Mission Control: 

1. Create a manifest. 

2. Add the manifest to the application servers. 

3. Push the manifest to the clients. 
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Manifest list window 
The Manifest List window is the working window for adding, modifying, and deleting manifests. 
To connect to the Manifest List window: 

• Select File>Manifest. The Manifest List window is displayed. 

 
The table below lists and describes the features and information displayed on the Manifest List 
window. 

Manifest List Window Contents 

Feature Description 

Manifest Name Displays the name of the manifest. This value is user-defined. 

Status Displays the status of the manifest. The manifest can have a status 
of remove, install, and delete. This value is user-defined. 

Activation Date Displays the activation date for the manifest. This value is user-
defined. 

Manifest Parent Directory Displays the parent directory for the manifests. 

Directory button Allows you to open or modify the parent directory of the 
manifests 

Add Manifest button Allow you to create and add a new manifest. 

Modify Manifest button Allows you to modify an existing manifest. 

Delete Manifest button Allows you to delete a manifest. 
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Change the manifest parent directory 
The manifest parent directory is the directory that stores the manifest files. To change the 
manifest parent directory: 

1. In the Manifest List window, click the Directory button.  

 
The Directory dialog box is displayed. 

 
2. Select the parent directory for the new manifest. 

3. Click OK. The Manifest Parent Directory field is updated with the parent directory for the 
new manifest. 

Create a new manifest file 
First, you have to create a new manifest in the Manifest List window. After you create the 
manifest, you must save the manifest on all the application servers by dragging and dropping the 
manifest from the Manifest List window onto the Containers window of the application servers. 

A manifest contains software updates and data file updates that are pushed out to clients in an 
automated process. A manifest also contains an activation date and manifest status that provides 
clients with instructions on when to install the update files. 

Creating a new manifest will not automatically update the application servers. The manifest must 
be saved on the application servers so the manifest files can be pushed out and installed on 
the clients. 
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To create a manifest file: 

1. In the Manifest List window, click the Add Manifest button. The Select Files Included 
in Manifest dialog box is displayed. 

 
2. In the Name field, type the manifest name. 

 Note: It is recommended that the name of the manifest be related to the information you 
are updating the clients with. This will help you better manage your manifest files. 

3. In the Activation Date field, enter the activation date for the manifest. The activation date is 
the date in which the clients will begin downloading the manifest.  

 Note: It is recommended that you set the activation date to a date prior to the actual 
installation to ensure all application servers are updated. 

4. In the Status drop-down menu, select the appropriate status type for the manifest. By default, 
the Wait status is selected. 

 Note: When you create the manifest, it is recommended that you set the value for the 
manifest status to WAIT. Also, it is recommended that you do not change the status of 
the manifest until you are ready to update the application servers and push the manifest 
out to the clients. 
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5. Click the Add File button. The Directory dialog box is displayed. 

 
6. Select the files you wish to include in the manifest. 

7. Click OK. The selected files are displayed in the Files Entries table. 

 
8. To add multiple files to a manifest, repeat steps 5-7. 

9. On the Selected Files Included in Manifest dialog box, select OK. The manifest is 
displayed on the Manifest List window. 
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Save manifest on application servers 
After you have created a manifest, you are ready to save the manifest on the application servers 
so it can be pushed out to the clients. To save the manifest on the application servers, you will 
have to drag and drop the manifest file from the Manifest List window onto the Containers 
window for each application server.  

To save a manifest file on a application server: 

1. Connect to all the application servers that require the manifest. The Containers window for 
each application server is displayed. 

 Note: All application servers must be updated with the manifest so each application 
server is running the most current and up-to-date version of the RPOS code and data files. 

2. On the Containers window for each application server, click the Manifest tab. The 
Manifest table is displayed. 

 
 Note: You must click the Manifest tab on the Containers window before you can save a 

manifest on the application server. 

3. In the Manifest List window, select the manifest you wish to update the application servers 
with. The selected manifest is highlighted in blue. 

4. Drag and drop the manifest from the Manifest List window onto the Containers window of 
all the application servers. The manifest information appears in the Manifest table, and it is 
saved on the application servers. 
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5. To save another manifest onto the application servers, repeat steps 3-4. 

Push a manifest to the clients 
After the manifest has been saved on the application servers, you are ready to push the manifest 
to the clients by updating the application servers. 

To install the manifest onto the clients: 

1. Manually update the application servers with the manifest files.  

2. Stop all the application servers. 

3. Restart the application servers with the new version of RPOS. 

4. Change the manifest status on all application servers to INSTALL. When the client checks 
the application servers for a new version of RPOS, it will see that the status as INSTALL and 
begin downloading and installing the new software files and data files.  
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To change the manifest status to INSTALL on the containers window 
To change the manifest status to INSTALL on the Containers window: 

1. In the Containers window on all the application servers, select the appropriate manifest. The 
selected manifest is highlighted in blue. 

2. Click in the Status column. The Status drop-down menu is displayed. 

 
1. In the Status drop-down menu, select INSTALL. The Select Option dialog box is displayed. 

2. In the Select Option dialog box, select OK. 

Modify a manifest 
Mission Control allows you to modify a manifest from either the Manifest List window or the 
Containers window. If you make modifications to a manifest file in the Manifest List window 
after you have saved the manifest onto the application servers, you will have to replace the 
manifest that resides on the application servers with the updated manifest. After you have saved a 
manifest on an application server, you can still make modifications to it. 

You can make the following changes to a manifest from the Manifest List window: 

• Change the activation date of the manifest 

• Change the manifest status 

• Add files to a manifest 

• Remove a file from a manifest 

• Edit a file included in a manifest 

• Copy the manifest to the training mode of RPOS 

You can make the following changes to a manifest from the Containers window: 

• Change the activation date of the manifest 

• Change the manifest status 
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Change the manifest activation date 
You can change the manifest activation date from either the Manifest List windows or the 
Containers window. If you change the activation date using the Manifest List window, it is 
recommended that you make these changes before you save the manifest onto an application 
server.  

Change the manifest activation date from the manifest list window 
To change the manifest activation date from the Manifest List window: 

1. In the Manifest List window, select the manifest you wish to change the activation date of. 
The selected manifest is highlighted in blue. 

2. Click the Modify Manifest button. The Selected Files Included in Manifest window 
is displayed. 

 
3. Click inside the Activation Date field. 
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4. To change the activation date, type the new activation information. 
OR 
Place the cursor in the desired area and click the up or down arrow. For example, if you want 
to change the month that the manifest will be activated, place the cursor inside the displayed 
month and click the up arrow to change the month. 

5. Click OK. The new activation date is displayed in the Manifest List window. 

Change the manifest activation date from the containers window 
After saving the manifest onto the application servers, you can still change the activation date of 
the manifest. To change the manifest activation date from the Containers window: 

1. In the Containers window of the application server you wish to change the manifest 
activation date of, select the appropriate manifest. The selected manifest is highlighted 
in blue. 

2. Double click in the Activation Date column. The Up and Down arrows are displayed. 

 
3. To change the activation date, type the new activation information. 

OR 
Place the cursor in the desired area and click the up or down arrow. For example, if you want 
to change the month that the manifest will be activated, place the cursor inside the displayed 
month and click the up arrow to change the month.  

Change the manifest status 
You can change the manifest status from either the Manifest List window or the 
Containers window. If you change the manifest status using the Manifest List window, it is 
recommended you make these changes before you save the manifest onto an application server.  

 Note: It is recommended that you only change the manifest status on the Containers 
window of the application servers when you are ready to push the manifest to the clients. 

To change the manifest status from the Manifest List window: 

1. In the Manifest List window, select the manifest you wish to change the activation date of. 
The selected manifest is highlighted in blue. 

2. Click the Modify Manifest button. The Selected Files Included in Manifest window 
is displayed. 
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3. In the Status drop-down menu, select the new manifest status. 

 
4. Click OK. The new manifest status is displayed in the Manifest List window. 
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Add a file to a manifest 
To add a file to a manifest: 

1. In the Manifest List window, select the manifest you wish to add a new file to. The selected 
manifest is highlighted in blue. 

2. Click the Modify Manifest button. The Selected Files Included in Manifest window 
is displayed. 

 
3. Click the Add File button. The Directory dialog box is displayed. 
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4. In the Directory dialog box, select the files you wish to add to the manifest. 

5. Click OK. The selected files are displayed in the Files Entries table. 
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Delete a file from a manifest 
To delete a file from a manifest: 

1. In the Manifest List window, select the manifest that contains the file you wish to delete. 
The selected manifest is highlighted in blue. 

2. Click the Modify Manifest button. The Selected Files Included in Manifest window 
is displayed. 

3. In the Selected Files Included in Manifest window, select the file you wish to delete. The 
selected file is highlighted in blue. 

 
4. Click the Delete File button. The Delete File dialog box is displayed. 

 Note: If you do not select a file before you click the Delete button, the Select File to 
Delete dialog box is displayed. To close the dialog box, select OK. 
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5. Click OK. The selected file is no longer displayed in the Selected Files Included in 
Manifest window. 

 
6. To delete more files from a manifest, repeat steps 3-5. 

7. On the Selected Files Included in Manifest window, click OK to return to the 
Manifest List window. 

Edit a file included in a manifest 
Mission Control allows you to open and edit a file that you are including in a manifest. To edit a 
file included in a manifest: 

1. In the Manifest List window, select the manifest that contains the file you wish to edit. 
The selected manifest is highlighted in blue. 

2. Click the Modify Manifest button. The Selected Files Included in Manifest window 
is displayed. 

3. Select the file you wish to edit. The selected file is highlighted in blue. 
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4. Click the Edit File button. The Edit File dialog box is displayed and the file is displayed in a 
text editor. 

 
5. Modify or edit the file. 

6. After you have made all your changes, click the Save button. The Save File dialog box 
is displayed. 

7. Click the Save button. The File Already Exists dialog box is displayed. 

8. To replace the existing file with the updated file, click OK. 

9. To edit more files from a manifest, repeat steps 3-8. 

10. On the Selected Files Included in Manifest window, click OK to return to the 
Manifest List window. 
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