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1 What’s New in This Release
Using Siebel Tools covers how to use the Siebel Tools application. It describes the Siebel Tools user 
interface and includes tasks such as customizing the Siebel Tools environment, working with objects, 
checking in and checking out, and compiling. 

Using Siebel Tools does not cover how to configure Oracle’s Siebel applications. For example, it does 
not cover how to extend the data model, define business logic, or build user interface objects. For 
configuration-related information, see Configuring Siebel Business Applications.

The content covered in Using Siebel Tools came from the following documents:

■ Descriptions of menus and toolbars were previously published in Siebel Developer’s Reference.

■ Descriptions of windows, editors, and most tasks were previously published in Siebel Tools 
Reference. (Siebel Tools Reference is no longer published. It has been replaced by Using Siebel 
Tools and Configuring Siebel Business Applications.)

What’s New in Using Siebel Tools, Version 7.8, Rev. B
Table 1 lists changes described in this version of the documentation to support version 7.8 of the 
software.

Table 1. New Product Features in Using Siebel Tools, Version 7.8, Rev. B

Topic Description

“About Siebel Tools” on page 15 Added statement that Siebel Tools for multiple product 
releases can be installed on the same local machine.

“Inactive Objects” on page 22 Added a note recommending how to treat obsolete objects.

“About Development Tools Options” 
on page 52

Added this topic on setting Tools UI preferences.

“Specifying Data Sources” on 
page 59

Added a note that recommends using one local database with 
Tools and the Mobile Web Client for development purposes.

“Performing a Full Get” on page 73 Added a note on ODBC requirements for a user to do a Get.

“About Projects” on page 93 Mentioned that object check-in/check-out is an alternative to 
project check-in/check-out that are in contention by many 
developers.

“Creating New Projects” on page 94 Rewrote this topic to clarify the process for creating and 
modifying new projects.

Table 26 on page 100 Corrected column headings.
Using Siebel Tools Version 7.8, Rev. B 11



What’s New in This Release ■ 
What’s New in Using Siebel Tools, Version 7.8, Rev. A
Table 2 lists changes described in this version of the documentation to support version 7.8 of the 
software.

“About Archive Files” on page 145 Added content about requirements for using archive files to 
exchange repository data between environments with 
different database platforms.

“About Exporting and Importing 
Repositories” on page 159

Added a Caution that specifies when you must use the 
Repository Migration Utility, instead of the Export/Import 
option in the Database Configuration Utility.

“Exporting and Importing 
Repositories Using the Database 
Configuration Utility” on page 159

Added instruction for exporting a repository after suspending 
the export process in the Configure DB Server, wizard.

Table 2. New Product Features in Using Siebel Tools, Version 7.8, Rev. A

Topic Description

“About the ST eScript Engine” on 
page 125

Changed setup procedure for ST Scripting Engine.

“About Repositories” on page 155 Removed erroneous information related to maintaining 
multiple SRFs compiled with different repositories. 

“Renaming Repositories” on 
page 158

Object Manager parameter changed for this procedure.

“About Exporting and Importing 
Repositories” on page 159

Added enhancement to usage of dev2prod utility.

“Conversion Batch File” on page 186 Added new information to this topic.

“About the Locale Management 
Utility” on page 191

Added new information about importing .xlf files with the 
LMU.

“Importing Text Strings and Locale-
Specific Attributes” on page 195

Added information specifying what file formats are read by 
the LMU utility.

Table 1. New Product Features in Using Siebel Tools, Version 7.8, Rev. B

Topic Description
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What’s New in This Release ■
What’s New in Using Siebel Tools, Version 7.8
Table 3 lists changes described in this version of the documentation to support version 7.8 of the 
software.

Table 3. New Product Features in Using Siebel Tools, Version 7.8

Topic Description

“Checking Out Projects from the 
Server Repository” on page 86

Added more information to this topic.

“About Object Check Out and Check 
In” on page 88

Added note to clarify check out and check in process.

Chapter 8, “Siebel Script Editors” Added new chapter which includes discussion and overview of 
Siebel ST eScript Editor, and all elements related to Script 
Editor components, including Script Assist. 

“Command-Line Interface for 
Import, Export, and Compilation” on 
page 141

Added new topic.

“About Compiling” on page 139 Added critical information to this topic.

“Strings Not Included in the 
Symbolic Strings Model” on 
page 170

Added new information to this topic.

“How Translatable String Values Are 
Calculated” on page 170

Added new information to this topic.

“Checking In and Checking Out 
Symbolic Strings” on page 171

Rewrote topic based on new information.

“To select a symbolic string 
reference by typing a value into the 
Object List Editor” on page 173

Added more information to clarify task.

“About the Symbolic String 
Conversion Process” on page 176

Added information to clarify topic.

“Running the String Conversion 
Utility” on page 178

Added new background information to topic.

“Splitting Consolidation Export Files 
into Smaller Files” on page 185

Added new introductory material to topic.

“Conversion Batch File” on page 186 Added new information to this topic.

“Exporting Text Strings and Locale-
Specific Attributes” on page 194

Added information specifying what file formats are read by 
the LMU utility.
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2 About the Siebel Tools User 
Interface
This chapter describes the Siebel Tools user interface. It contains the following topics:

■ “About Siebel Tools” on page 15

■ “About Siebel Tools Application Windows” on page 16

■ “About Object Explorer” on page 17

■ “About the Object List Editor” on page 21

■ “About the Properties Window” on page 23

■ “About the Applets Window” on page 24

■ “About the Controls/Columns Window” on page 24

■ “About the Bookmarks Window” on page 26

■ “About the Web Template Explorer Window” on page 26

■ “About the Siebel Tools Menu Bar” on page 27

■ “About Siebel Tools Toolbars” on page 40

■ “About Siebel Tools Right-Click Menus” on page 48

■ “About Layout Editors” on page 49

■ “About New Object Wizards” on page 49

■ “About the Entity Relationship Designer” on page 49

■ “About the Business Process Designer” on page 50

■ “About Script Editors” on page 50

■ “About the Command-Line Interface” on page 50

About Siebel Tools
Siebel Tools is an integrated environment for configuring Siebel applications. You use Siebel Tools to 
modify standard Siebel objects and create new objects to meet your organization’s business 
requirements. For example, you use Siebel Tools to extend the data model, modify business logic, 
and define the user interface.

NOTE: Currently, there is no support to customize Siebel Tools.
Using Siebel Tools Version 7.8, Rev. B 15



About the Siebel Tools User Interface ■ About Siebel Tools Application Windows
Siebel Tools is a declarative configuration tool, not a programming environment. You use Siebel Tools 
to create and modify the object definitions (metadata) that define Siebel applications. You do not 
modify the source code or directly write SQL. 

NOTE: In the context of Siebel applications, the terms object and object definition are not equivalent 
to the terms “object,” “object class,” or “object instance” as they are used in the context of 
programming languages such as C++.

Siebel Tools allows you to develop a single configuration that can be:

■ Deployed across multiple types of clients

■ Used to support multiple Siebel applications and languages

■ Easily maintained

■ Automatically upgraded to future Siebel product releases

You can have installations of Siebel Tools for different product releases on the same local machine.

For information about installing Siebel Tools, see the Siebel Installation Guide for the operating 
system you are using. For system requirements, such as supported versions of Microsoft Windows, 
see System Requirements and Supported Platforms on Siebel SupportWeb.

In this guide, SIEBEL_TOOLS_ROOT represents the directory into which you installed the Siebel Tools 
client. By default, this directory is C:\Program Files\Siebel\7.8\Tools.

About Siebel Tools Application Windows
You navigate in Siebel Tools primarily using the following two windows: 

■ Object Explorer, the left part of the application window shown in Figure 1

■ Object List Editor, the right part of the application window shown in Figure 1

The Object Explorer uses a hierarchical tree-structure (similar to that of the Microsoft Windows 
Explorer) that you use to browse the object types that are stored in the Siebel Repository.
Using Siebel Tools Version 7.8, Rev. B16 



About the Siebel Tools User Interface ■ About Object Explorer
Other Siebel Tools windows, like the Object List Editor and Properties windows, show you details 
about individual objects in the Siebel repository.

About Object Explorer
The Object Explorer, shown in Figure 2, appears when you start Siebel Tools. The Object Explorer 
shows a hierarchical representation of the major object types that you can use to browse the object 
types in the Siebel repository.

Figure 1. Example of Siebel Tools Application Window
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About the Siebel Tools User Interface ■ About Object Explorer
By default, the Object Explorer is visible when you start Siebel Tools. The Object Explorer has the 
following parts: the Project drop-down list, the Types tab, the Detail tab, and the Flat tab. 

Topics in This Section
“The Project Drop-Down List of the Object Explorer” on page 19

“The Types Tab of the Object Explorer” on page 19

“The Detail Tab of the Object Explorer” on page 20

“The Flat Tab of the Object Explorer” on page 21

Figure 2. Example of the Object Explorer Window
Using Siebel Tools Version 7.8, Rev. B18 



About the Siebel Tools User Interface ■ About Object Explorer
The Project Drop-Down List of the Object Explorer
Use the Project drop-down list at the top of the Object Explorer to filter objects by project. For 
example, you can set the Project filter so that only the object types associated with the Account 
project appear in the Object Explorer. An example of the values in the drop-down list is shown in 
Figure 3.

The Types Tab of the Object Explorer
The Types tab is selected in the Object Explorer shown in Figure 4 on page 20.

The Types tab shows all top-level object types, listed alphabetically. The Types tab shows the object 
hierarchy—clicking the plus sign (+) to the left of an object type displays all the child object types 
of the top-level object type. Clicking the minus sign (–) to the left of an object type collapses all its 
child object types.

NOTE: By default, not all object types are visible in the Object Explorer. For information on how to 
show and hide objects types, see “Setting Database Options” on page 68.

Some object types have a hierarchy of multiple levels. For example (as shown in Figure 4 on 
page 20):

■ One of the child object types of Applet is List and, at the next lowest level, List Column.

■ One of the child object types of Business Component is Field. 

Figure 3. The Project Drop-Down List in the Object Explorer Window
Using Siebel Tools Version 7.8, Rev. B 19



About the Siebel Tools User Interface ■ About Object Explorer
The Detail Tab of the Object Explorer
If you select the Detail tab of the Object Explorer (as shown in Figure 5) and expand an object type, 
all the objects of that type appear in the Object Explorer. If you select an object type in the Detail 
tab, the Object List Editor displays all the objects of that type.

Figure 4. The Types Tab of the Object Explorer Window

Figure 5. The Detail Tab of the Object Explorer Window
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About the Siebel Tools User Interface ■ About the Object List Editor
The Flat Tab of the Object Explorer
The Flat tab of the Object Explorer, shown in Figure 6, shows all object types (parent and child) in a 
single, alphabetically-arranged list, without displaying the parent-child relationship. 

The Flat tab view helps you:

■ Find a child object with an unknown parent.

For example, if you created a new field but do not remember what business component it is in, 
you can select the Field object type in the Flat tab and search the Name property for your field 
name. Each returned record has a parent property that provides the business component name.

■ See how objects and properties are typically used, such as how a predefault value is constructed 
or the syntax for calculated fields.

About the Object List Editor
The Object List Editor displays the objects for the object type currently selected in the Object 
Explorer. If the object selected in the Object Explorer is a second or third-level object, two Object 
List Editors are displayed—the object for the type selected in the Object Explorer is in the bottom 
window. In the example shown in Figure 7, the top-level object is Applet, the specific applet is 
Activity Prospects List Applet, and the available Web templates are Base (selected), Edit, and Edit 
List. 

Figure 6. The Flat Tab of the Object Explorer Window
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About the Siebel Tools User Interface ■ About the Object List Editor
In the same figure, the pencil icon (to the left of the applet name) indicates that the applet has been 
locked by the Siebel Tools user, so that modifications to it can be saved. 

Inactive Objects
Inactive objects have the INACTIVE property set to TRUE, which inactivates the record in the 
repository table.

NOTE: When an object definition becomes obsolete, either due to an update or to a new 
requirement, you must not delete the unused objects. Instead, check the INACTIVE flag. Then, the 
application does not reference the checked Siebel object.

Changed Flag
After you edit a record, a check mark appears in the Changed property of the object. This indicates 
that changes have been made to the contents of the corresponding record since a particular date 
and time. If there is no check mark in the Changed property, it means that the object has not been 
changed since the date and time specified in the General tab of the Development Options dialog box. 

The Changed flag cascades upwards through its parents. That is, when an object is edited or created, 
the changed flag is set for its parent object, if any, and for the parent object of that parent, and 
likewise up through the hierarchy. For more information, see “Setting Change Date Preferences” on 
page 52.

Pencil Icon
The pencil icon in the first (W) column of an object indicates that the object is locked and editable. 
In Figure 7, all visible objects are locked.

Figure 7. Example of the Object List Editor Window
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About the Siebel Tools User Interface ■ About the Properties Window
Drilldowns
Property values in the Object List Editor can appear as drilldown fields (hyperlinks) when the value 
is the name of another object. You can click the drilldown to navigate to the associated object type.

To be able to use drilldowns in the Object List Editor, you must be assigned the Developer 
responsibility. Users are assigned responsibilities in the Administration - Application > 
Responsibilities screen of Siebel applications. For more information, see Security Guide for Siebel 
Business Applications.

About the Properties Window
The Properties window (shown in Figure 8) displays the property settings for the object currently 
highlighted in the Object List Editor. The name of the active object is shown at the top of the window 
(in Figure 8, Business Component Abs Result). For each property of the object, the Properties window 
shows the name of the property in the left column, and the property’s value in the right column. By 
default, the Properties window appears with the Alphabetic tab active; you can click the Categorized 
tab to see the properties grouped by category.

NOTE: The Properties window does not display the Project and Changed properties.

Figure 8. Example of the Properties Window
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About the Siebel Tools User Interface ■ About the Applets Window
About the Applets Window
The Applets window displays the applets that are part of a given business object. Clicking one of the 
applets opens the Applet Layout Editor. In the View Layout Editor, you drag applet icons from the 
Applet Window into the view layout editor. The Applets window has two tabs: the Icons tab (shown 
on the left in Figure 9) and the List tab (shown on the right in Figure 9).

About the Controls/Columns Window
The Controls/Columns window displays controls and columns available for configuration when editing 
an applet layout in the Web Applet Editor, as shown in Figure 10. You drag the control or column icon 
into the placeholder in the Web Applet Editor.

Figure 9. Example of Applets Windows with the Icons and List Tabs
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About the Siebel Tools User Interface ■ About the Controls/Columns Window
When you select a control or a column object in the Controls/Columns window, the Properties window 
refreshes to show the properties of the selected object. If no object is selected in the Controls/
Columns window, the Properties window shows the properties of the applet. 

Figure 10. Example of the Controls/Columns Window with the Web Applet Editor

The control and 
column objects for 
this applet

The properties of the 
object selected in the 
Controls/Column window

The applet as it 
appears in the Web 
Applet Editor
Using Siebel Tools Version 7.8, Rev. B 25



About the Siebel Tools User Interface ■ About the Bookmarks Window
About the Bookmarks Window
The Bookmarks window (shown in Figure 11) lets you navigate to frequently used objects in the 
repository using shortcuts that you add using the buttons on the History toolbar.

Related Topic
“History Toolbar” on page 42

About the Web Template Explorer 
Window
The Web Template Explorer window (shown in Figure 12) is a Windows Explorer-like listing of Web 
templates. Clicking an item in the Web Template Explorer displays the HTML source code of the Siebel 
Web Template (.swt) file for review or editing in the HTML code window (shown in the right part of 
the window in Figure 12). 

Figure 11. Example of the Bookmarks Window
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About the Siebel Tools User Interface ■ About the Siebel Tools Menu Bar
The HTML code window displays both parent and child templates in a split view. The Web Template 
drop-down list in the Web Template Explorer window lets you filter the templates that are shown in 
the Web Template Explorer window. You can edit a template file by right-clicking in the HTML code 
window for that template.

About the Siebel Tools Menu Bar
The menus in the menu bar operate as standard Microsoft Windows menus. You click a menu to 
display the menu commands. Menu commands that are not available due to the current state of the 
program are disabled. 

Topics in This Section
“File Menu” on page 28

“Edit Menu” on page 29

“View Menu” on page 30

“Screens Menu” on page 32

“Go Menu” on page 33

“Query Menu” on page 34

“Reports Menu” on page 34

“Format Menu” on page 35

Figure 12. Example of Web Template Explorer Window with HTML Code Window
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About the Siebel Tools User Interface ■ About the Siebel Tools Menu Bar
“Debug Menu” on page 36

“Tools Menu” on page 37

“Window Menu” on page 39

“Help Menu” on page 40

Related Topics
“About Siebel Tools Toolbars” on page 40

File Menu
Table 4 describes the options available on the File menu for repository and object management.

Table 4. File Menu Options

Menu Option
(Shortcut) Description

Open Repository When multiple repositories are present in the development directory, the menu 
option provides the means to open a repository other than the currently open 
one. 
The repository chosen using File > Open Repository becomes the default 
repository opened each time Siebel Tools is launched.

New Object Invokes the New Object Wizard for the creation of a list applet, form applet, 
chart applet, tree applet, business component, report, table, command, pick 
list, MVG, or view. 

Close
(CTRL+F4)

Closes the Object List Editor. 

Save
(CTRL+S)

Saves changes in the current editing window when you are editing Layout, 
Menu, or Basic Scripts. 

Save All Saves changes in all open editing windows. 

Import* Imports text from an external text file into the Siebel VB Editor window. This 
text must be in an SBL file format. SBL format is generated when it is exported 
from the Siebel VB editor.

Export* Allows you to create a text file in delimited or HTML format that lists the 
property values of an objects or all objects currently displayed in the Object 
List Editor. 

Print Setup Changes the printer and printing options for printing object visualization view 
diagrams.

Print Preview Opens a print preview window for display of an object visualization view.
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Edit Menu
The Edit menu options apply to individual objects in the Object List Editor. 

You can also display a menu of edit tools by selecting a field and right-clicking while the cursor is 
positioned over the Object List Editor. For more information, see “About Siebel Tools Right-Click 
Menus” on page 48.

Table 5 describes the options available on the Edit menu.

Print
(CTRL+P)

Prints the active object visualization view diagram. 

Exit Closes Siebel Tools.

Table 5. Edit Menu Options

Menu Option
(Shortcut) Description

Undo
(CTRL+Z)

Reverses the last change to a property value in the Object List Editor or Property 
window before the object is committed.

Redo
(CTRL+Y)

Reapplies changes after the Undo command has been executed.

Undo Delete After deleting any record in Object List Editor, this menu option appears, allow 
you to undo the delete. 

Undo Record Reverses the creation of new objects or all modifications to existing objects, so 
long as the record has not yet been committed.

New Record
(CTRL+N)

Creates a new object in the Object List Editor, with the cursor positioned in the 
first required property.

Copy Record
(CTRL+B)

Creates a new object that is a copy of the currently selected object, and 
duplicates all child objects.

NOTE: Avoid using the Copy Record option, except when the reuse and extension 
of an existing object would be impractical.

Delete Record
(CTRL+D)

Deletes the currently selected object and its child objects. 

NOTE: Avoid using the Delete Record option. If you want to remove an object 
from use, set its Inactive property to TRUE.

Cut
(CTRL+X)

In a text property, copies the selected text to the clipboard and deletes the 
existing text. In the Applet Designer, copies the selected control to the clipboard 
and deletes the existing control.

Table 4. File Menu Options

Menu Option
(Shortcut) Description
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View Menu
The View menu options are used to change display environment settings, such as which windows and 
toolbars appear. It also invokes visualization views, which are diagrams showing object relationships. 
Table 6 describes the View menu options and suboptions.

Copy
(CTRL+C)

In a text property, copies the selected text to the clipboard without deleting it. 
In the Applet Designer, copies the selected control to the clipboard without 
deleting it.

Paste
(CTRL+V)

Inserts text from the clipboard into a text property at the insertion point. Inserts 
a control from the clipboard in the Applet Designer.

Delete
(DEL)

In a text property, deletes the selected text. In the Applet Designer, deletes the 
selected control.

Select All
(CTRL+A)

Selects the entire document. In the Applet Designer, selects all controls in the 
applet.

Change 
Records

Changes multiple records simultaneously.

Find
(CTRL+F)

Finds the specified text in the Siebel Script Editor window.

Replace
(CTRL+H)

Replaces the specified text with different text in the Siebel Script Editor window.

Table 6. View Menu Options

Option
(Shortcut)

Suboption
(Shortcut) Description

Windows Properties Window Shows or hides the Properties window.

Applets Window Shows or hides the Applets window. 

Controls Window Shows or hides the Controls window.

Bookmarks Window Shows or hides the Bookmarks window.

Web Templates Window Shows or hides the Web Templates Explorer window.

Refresh Windows Requeries and updates the state of dockable windows. 

Table 5. Edit Menu Options

Menu Option
(Shortcut) Description
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Editors Applet Editor Opens the selected applet in Applet Layout Editor, 
including the Controls/Columns window.

Server Script Editor Opens the Siebel Script Editor. Editor may be specifically 
defined or be set to a default.

Browser Script Editor Opens the Siebel Web Script Editor, which is used to 
access scripts that control the presentation and behavior 
of applet controls and list columns in a Web applet 
template.

Visualize View Details For more information, see “Viewing Object Relationships” 
on page 114.

View Relationships

View Descendents

View Web Hierarchy

Debug 
Windows

Calls
(CTRL+L)

Opens the Calls window for display of the call stack of the 
Siebel VB or Siebel eScript script currently being 
debugged.

Watch
(SHIFT+F9)

Opens the Watch window for display of the values of local 
variables in the Siebel VB or Siebel eScript script 
currently being debugged.

Errors Opens the Errors window for display of the run-time 
errors in the Siebel VB or Siebel eScript script currently 
being debugged.

Preview The preview of a Web view layout depicts the container 
page, screen bar, and view bar.

ActiveX 
Methods

Allows you to view the methods for the current ActiveX 
control in the Applet Designer.

Toolbars Displays or hides the various toolbars: Edit, History, List, 
Debug, Web Controls, and Configuration Context. 

Status Bar Displays or hides the Status bar at the bottom of the 
Siebel Tools window.

Table 6. View Menu Options

Option
(Shortcut)

Suboption
(Shortcut) Description
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Screens Menu
The Screens menu is empty unless you log on to Siebel Tools as a system administrator. If you have 
system administrator rights, the options described in Table 7 appear.

Object 
Explorer
(CTRL+E)

Displays or hides the Object Explorer. 

Options Opens the Development Tools Options dialog box, in 
which you can set general preferences and settings for 
language, check-in and check-out, list views, scripting, 
Web template editor, debugging, visualization, Object 
Explorer, and database.

Siebel Tools options are stored in a user preference file, 
which is located in SIEBEL_TOOLS_ROOT\BIN. The user 
preference filename is loginID&SiebelTools.spf.

Table 7. Screens Menu Options

Option Suboption Description

Application 
Upgrader

Application Upgrade Attribute List The Application Upgrades and Attribute 
Differences lists appear in the Object List 
Editor. 

Application Upgrade Database 
Version

For internal use by Siebel Systems.

Application Upgrade Object List The Application Upgrades, Object 
Differences, and Attribute Differences lists 
appear in the Object List Editor.

Table 6. View Menu Options

Option
(Shortcut)

Suboption
(Shortcut) Description
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Go Menu
The Go menu contains options for moving through a records list. Primarily, you use the Go menu to 
create and navigate to bookmarks, which flag objects for easy return navigation. Bookmarks are a 
helpful navigation aid, allowing you to move around among the objects of different types you are 
working on. Table 8 describes the Go menu options.

System 
Administration

List of Values Displays lists of values in the development 
database.

Strings Siebel Systems internal use only

System Preferences Displays system preferences in the Object 
List Editor. This information is similar to 
the System Administrator View available 
from the Administration - Application 
screen in Siebel Business Applications. 

System Preferences is used by the 
src\server\sfs\common\locate_fulfill\cssc
onfigagent.cpp file. The system preference 
is used by fulfillment and part locator 
engines for cleaning the rows in a 
temporary table that is shared by the 
client and server components. The 
parameter is only used when you want to 
clean up the temporary table. In that case, 
you must explicitly submit a CleanUp 
request to fulfillment/part locator engines.

Table 8. Go Menu Options

Option
(Shortcut) Description

Back Returns to the previously displayed screen.

Forward Returns to subsequently displayed screen.

Previous Record
(CTRL+UP)

Goes to the objects above the current selection. 

Next Record
(CTRL+DOWN)

Goes to the objects below the current selection. 

First Record
(CTRL+PGUP)

Goes to the first objects in the list. 

Table 7. Screens Menu Options

Option Suboption Description
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Query Menu
The Query menu options allow you to create and refine Object List Editor queries, which restrict the 
list of objects that appear in the current Object List Editor. An option is provided that lets you change 
the sort order of objects in the window.

Table 9 describes the Query menu options.

Reports Menu
The Reports menu may be empty or may list one or more available reports about objects and 
properties, depending on which object type is currently active in the Object Explorer. Table 35 in 
“Generating Reports About Object Relationships” on page 115 describes the different reports you can 
generate using the Reports menu.

Two additional reports become available on this menu when the Application Upgrader is active:

■ Application Upgrade Object List. Generates a report listing all object differences between 
repository versions. 

Last Record
(CTRL+PGDN)

Goes to the last objects in the list. 

Add Bookmark Invokes the Add Bookmark dialog box, for creation of a bookmark to the 
currently selected objects. 

Bookmark List Opens the Bookmarks dialog box, for selection of an existing bookmark 
to navigate to. You can also use this dialog box to rename or delete 
existing bookmarks. 

Table 9. Query Menu Options

Option
(Shortcut) Description

New Query
(CTRL+Q)

Allows you to specify restrictions on the set of objects to be displayed in the 
current Object List Editor.

Refine Query
(CTRL+R)

Allows you to add additional restrictions to the query currently in effect.

Execute Query
(ENTER)

Executes the query you have just specified, causing the restrictions to take 
effect. This has the same effect as pressing ENTER.

Sort Order Invokes the Sort Order dialog box, for specification of sort order criteria for the 
list of objects in the Object List Editor.

Table 8. Go Menu Options

Option
(Shortcut) Description
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■ Application Upgrade Attributes List. Generates a report listing all attribute differences 
between repository versions. 

Format Menu
The Format menu options in the Applet Layout Editor allow you to align, resize, and reposition 
controls; configure the snap grid; and adjust tab or list column order. Options are also provided for 
performing an Applet Designer Preview.
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Table 10 describes the Format menu options.

Debug Menu
The Debug menu options control the Siebel VB or Siebel eScript debugger, for use when a script is 
open in the Siebel Script Editor. Table 11 describes the Debug menu options.

Table 10. Format Menu Options

Option Description

Align Aligns the selected items with the selected model. 

Make Same Size Makes all selected items the same size as the selected model. 

Horizontal Spacing Adjusts horizontal spacing between items.

Vertical Spacing Adjusts vertical spacing between items.

Center in Applet Centers the selected items horizontally or vertically.

Set Label Alignment Allows you to align labels in applets based on grid layout Web templates.

Set Tab Order Allows you to set the tab order for fields in a form applet. This option is not 
available for list applets.

Table 11. Debug Menu Options

Option
(Shortcut) Description

Start
(F5)

Starts the application. A dialog box with startup parameters also appears.

Break
(CTRL+BREAK)

Stops the execution of the currently running script. If Siebel VB or Siebel 
eScript is not executing, no operation is performed.

End Stops the execution of the application and returns to the Siebel Script Editor 
window.

Restart
(SHIFT+F5)

Restarts the application if a break has occurred.

Step Into
(F8)

Executes the next line of script code. If this is a subroutine or procedure 
call, then execution continues within that procedure.

Step Over
(SHIFT+F8)

Advances the application to the script code line just after the current 
subroutine or procedure. Execution remains at the level of the current 
procedure.

Step To Cursor
(CTRL+F8)

Executes all lines of code up to the line selected by the cursor.
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Tools Menu
Table 12 describes the Tools menu options.

Toggle Breakpoint
(F9)

Sets or removes a breakpoint on a specific line of code.

Clear All 
Breakpoints
(CTRL+SHIFT+F9)

Removes all breakpoints from the current script routine.

Check Syntax Compiles the current script and verifies syntax.

Table 12. Tools Menu Options

Option
(Shortcut) Suboption Description

Compile (F7) Opens the Object Compiler dialog box to compile one or 
more projects, or all projects in the repository, into an 
SRF file. 

Compile Selected Objects
(CTRL+F7)

Opens the Object Compiler dialog box to compile the 
selected objects into an SRF file. 

Check Out
(F10)

Opens the Check Out dialog box, to copy one or more 
projects from the server to the local database.

Check In
(CTRL+F10)

Opens the Check In dialog box, to copy one or more 
projects from the local database to the server.

Lock Project
(ALT+L)

Locks the project that the currently selected object is 
assigned to.

Unlock Project
(ALT+U)

Unlocks the project that the currently selected object is 
assigned to.

Add To Archive Opens the Export To Archive dialog box, for adding the 
selected top-level objects or projects to an archive file.

Import From Archive Initiates the Import wizard for importing objects from 
an archive file.

Table 11. Debug Menu Options

Option
(Shortcut) Description
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Compare Objects Selected Compares two selected objects and graphically displays 
similarities and differences (in object type and 
instance), with a list of object properties by name and 
value.

Selected vs. 
Repository

Compares the selected object against the corresponding 
object in the selected repository and graphically 
displays similarities and differences.

Selected vs. 
Archive

Compares the selected object against the corresponding 
object in the selected archive file and graphically 
displays similarities and differences.

Archive vs. 
Archive

Compares two selected archive files and graphically 
displays similarities and differences.

Convert to Grid Layout Converts nongrid layout form applets to grid layout.

Search Repository Opens the Search Repository dialog box for performing 
a search for objects based on the text in their names (or 
other properties) and their object types.

Validate Object From the Validate dialog box, runs validation on a 
selected object. Lists any errors by severity, rule 
number, object name, and error description. Allows 
changing of options for rules, severity, and 
enforcement. 

Upgrade Prepare 
Repository

Used for upgrading from version 6.x to version 7.x. The 
Prepare Repository utility is run before performing a 
repository merge. It migrates strings from the S_MSG 
table, merges labels and fields, and merges templates 
to specified applets for selected languages.

Upgrade 
Application

Navigates to the Application Objects Upgrade List in the 
Application Upgrader screen of Siebel Tools, and opens 
the Merge Repositories dialog box. Used to merge 
standard and customized repositories.

Generate EIM 
Processing 
Columns

Opens the EIM Processing Column Generator dialog box, 
from which you create missing EIM processing columns 
and indexes after merging the repository.

Web Client 
Migration

Used when upgrading from version 6.x to version 7.x. It 
associates Web templates to a group of selected applets 
and views so that they can be used in the Web client.

Table 12. Tools Menu Options

Option
(Shortcut) Suboption Description
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Window Menu
The Window menu lists the currently open Object List Editor, Application Designer, visualization view, 
and other windows, and provides the means to navigate to windows that are currently hidden from 
view.

If one of the windows is open, the first option on the menu is Close. This closes the currently active 
window.

Utilities Check Labels Opens the Check Labels dialog box to check the labels 
in the currently selected applet for sufficient horizontal 
space when translated into a particular language. 

Generate 
Actuate Report

When a Report object is selected, this menu option 
generates a data stream file for use in the creation of an 
Actuate report.

Generate Help 
IDs

Used internally by Siebel Systems to generate the 
sshelp.hm file, containing correspondences between 
context ID numbers and text help identifiers that have 
been specified in Help ID objects. This option is used for 
Tools Online Help.

Locale 
Management

Allows you to import and export translatable text strings 
and locale-specific attributes using the Local 
Management Utility.

Map Fax 
Properties

When the business component object type is selected in 
the Object Explorer, this option opens the Map Fax 
Properties dialog box for the current business 
component object. This dialog box is used to create 
mappings between fields in the business component and 
fax software property sheet properties. These mappings 
support customization of the fax cover sheet and 
message.

Export View 
Previews

Exports view from the Preview mode of the View Layout 
Editor to an HTML file.

Build Patch Initiates the Patch Builder wizard to create a patch file.

Apply Patch Opens the Apply Patch window to initiate the patch 
application process. 

Table 12. Tools Menu Options

Option
(Shortcut) Suboption Description
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Help Menu
Table 13 describes the Help menu options.

About Siebel Tools Toolbars
There are several toolbars in Siebel Tools. The toolbars, like menu items, are active only when the 
object type or window that uses them is active. You can show and hide toolbars using the Toolbars 
option in the View menu. You can also rearrange the toolbars using drag-and-drop functionality. 

Topics in This Section
“Edit Toolbar” on page 41

“History Toolbar” on page 42

“List Toolbar” on page 42

“Debug Toolbar” on page 43

“Web Controls Toolbar” on page 44

“Format Toolbar” on page 46

“Configuration Context Toolbar” on page 48

Related Topics
“About the Siebel Tools Menu Bar” on page 27

“Showing and Hiding Toolbars” on page 72

Table 13. Help Menu Options

Option Description 

Contents Opens the Siebel Tools Online Help. 

Using Help Opens the Siebel Tools Online Help. 

Technical Support Displays the Technical Support Information dialog box, which includes 
information that Technical Support may need, such as the version number 
of your Siebel Tools installation.

About Record Opens a dialog box that displays information about the current object, 
including its creator and creation date. 

About SRF Opens a dialog box that displays information about the most recent full 
incremental compilations. 

About View Opens a dialog box that displays information about the current screen, 
business object, and view, including applet layout. 

About Visible Views Displays the list of views in the repository and whether or not they are 
visible.

About Siebel Tools Opens a dialog box identifying the version of Siebel Tools.
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Edit Toolbar
The Edit toolbar contains edit tools, the New Object wizard, and undo and redo options. 

You can also display a menu of edit tools by selecting a field and right-clicking while the cursor is 
positioned over the Object List Editor. For more information, see “About Siebel Tools Right-Click 
Menus” on page 48.

Table 14 describes the Edit toolbar buttons.

Table 14. Edit Toolbar Buttons

Button Description

New Invokes the New Object Wizard, which allows you to create applets, 
views, charts, and other objects.

Save Saves changes in the current editing window when you are editing Layout, 
Menu, or Basic Scripts.

Save All Saves changes in all open editing windows.

Cut In a text property, copies the selected text to the clipboard and deletes 
the existing text. In the Applet Designer, copies the selected control to the 
clipboard and deletes the existing control.

Copy In a text property, copies the selected text to the clipboard without 
deleting it. In the Applet Designer, copies the selected control to the 
clipboard without deleting it. 

Paste Inserts text from the clipboard into a text property at the insertion point. 
In the Applet Designer, inserts a control from the clipboard.

Undo Reverses the last change to a property value in the Object List Editor or 
Property window if the object has not been committed.

Redo Reapplies changes after the Undo command has been executed.
Using Siebel Tools Version 7.8, Rev. B 41



About the Siebel Tools User Interface ■ About Siebel Tools Toolbars
History Toolbar
The History toolbar contains buttons for retracing your steps and for creating and navigating to 
bookmarks, which flag objects for quick return navigation. Bookmarks are a helpful navigation aid, 
allowing you to move around quickly among the different object types with which you are working. 
Table 15 describes the History toolbar buttons.

List Toolbar
The List toolbar contains buttons that apply to objects in the Object List Editor. The buttons let you 
insert new records, move forward and backward, work with queries, and sort objects. Table 16 
describes the List toolbar buttons.

Table 15. History Toolbar Buttons

Button Description

Go Back Returns to the previously displayed screen.

Go Forward Returns to the subsequent displayed screen.

Add Bookmark Opens the Add Bookmark dialog box, so you can add a bookmark for 
the currently selected object.

Bookmark List Opens the Bookmarks window, so you can select a bookmark to 
navigate to. You can also use this window to rename or delete 
existing bookmarks.

Table 16. List Toolbar Buttons

Button Description

Add New Record Creates a new object in the Object List Editor, with the cursor 
positioned in the first required property.

First Record Goes to the first object in the list.

Previous Record Goes to the object above the current selection.

Next Record Goes to the object below the current selection.

Last Record Goes to the last object in the list.
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Debug Toolbar
The Debug toolbar contains buttons, described in Table 17, that let you access Siebel VB and Siebel 
eScript debugging tools.

New Query Allows you to specify one or more restrictions on the set of 
objects to be displayed in the current Object List Editor.

Execute Query Executes the query you have just specified, causing the 
restrictions to take effect. This has the same effect as pressing 
ENTER.

Sort Ascending Changes the order in which objects appear by sorting them in 
ascending order on the currently selected property column.

Sort Descending Changes the order in which objects appear by sorting them in 
descending order on the currently selected property column.

Table 17. Debug Toolbar Buttons

Button Description

Check Syntax Compiles the current script and verifies syntax.

Start Starts the application. A dialog box with startup parameters also 
appears.

Break Stops the execution of the currently running script. If Siebel VB 
or Siebel eScript is not executing, no operation is performed.

End Stops the execution of the application and returns to the Siebel 
Script Editor window.

Toggle Breakpoint Sets or removes a breakpoint on a specific line of code.

Table 16. List Toolbar Buttons

Button Description
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Web Controls Toolbar
The Web Controls toolbar allows you to create user interface controls in the Applet Layout Editor. You 
can reposition the toolbar as a floating window anywhere on the screen, or you can place it with the 
other toolbars at the top of the screen. The toolbar supports drag-and-drop behavior for the creation 
and placement of new controls. The Web Controls toolbar contains drop-down lists, fields, and 
buttons.

Drop-Down Lists and Fields
■ Mode. This drop-down list lets you select the applet mode, such as Base or Edit. Values in the 

drop-down list indicate whether a given mode is active or inactive.

■ Template. This field shows the Web template associated with the selected mode.

■ Control Type. This drop-down list lets you insert a custom control type into a template. Works 
together with the Custom Control button. 

Watch The Tools menu establishes variable watches, so you can 
monitor the contents of program variables in the Variable 
window during execution of Siebel VB and Siebel eScript 
routines.

Calls Displays the list of Siebel VB or Siebel eScript routine calls 
executed up to the point where the application was stopped.

Step Into Executes the next line of script code. If this is a subroutine or 
procedure call, then execution continues within that procedure.

Step Over Advances the application to the script code line just after the 
current subroutine or procedure. Execution remains at the level 
of the current procedure.

Table 17. Debug Toolbar Buttons

Button Description
Using Siebel Tools Version 7.8, Rev. B44 



About the Siebel Tools User Interface ■ About Siebel Tools Toolbars
Buttons
Table 18 describes the Web Controls toolbar buttons.

Table 18. Web Controls Toolbar Buttons

Button Description

Change Template. Displays the Choose Template dialog box that lets you select a 
different Web template.

Edit Template. Opens the template editor you defined as your external Web template 
editor in your options.

Select. Lets you select an object in the layout.

CheckBox. Creates a check box.

ComboBox. Creates a combo box.

Text. Creates a text box.

TextArea. Creates a text area.

Hidden. Creates hidden HTML.

Password. Creates a text box where the user enters a password during logon.

Link. Creates an HTML link control.

MailTo. Creates a mail-to link.

Button. Creates a button.

Label. Creates a label on templates.

URL. Creates a link to an external URL on templates.
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Format Toolbar
The Format toolbar contains buttons, described in Table 19, that let you apply specific formatting to 
controls for applets based on grid-layout Web templates.

ActiveX. Creates an ActiveX control on templates.

Text List Column. Creates a list column that contains HTML text. Available for list applets 
only.

Checkbox List Column. Creates a list column that contains HTML check boxes. Available 
for list applets only.

Custom Control. Creates a custom control on a template. You can select a custom control 
from the Control Type drop-down list, and then drag the Custom Control button to the 
designer to create the custom control.

Shift to previous placeholder in applets based on nongrid Web templates. Moves the 
selected control to the previous placeholder.

Shift to next placeholder in applets based on nongrid Web templates. Moves the selected 
control to the next placeholder.

Table 19. Format Toolbar Buttons

Button Description

Aligns the left edges of controls

Aligns the centers of controls along a vertical axis

Aligns the right edges of controls

Aligns the tops of controls

Aligns the middles of controls along a horizontal axis

Aligns the bottom of controls

Table 18. Web Controls Toolbar Buttons

Button Description
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Makes the controls the same width

Makes the controls the same height

Makes the controls the same size

Makes the horizontal spacing between controls equal

Increases the horizontal spacing between controls

Decreases the horizontal spacing between controls

Removes the horizontal spacing between controls

Makes the vertical spacing between controls equal

Increases the vertical spacing between controls

Decreases the vertical spacing between controls

Removes the vertical spacing between controls

Centers the controls vertically

Centers the controls horizontally

Aligns the labels to the left

Centers the labels

Aligns the labels

Table 19. Format Toolbar Buttons

Button Description
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Configuration Context Toolbar
The Configuration Context toolbar contains drop-down lists, show in Table 20, that let you define 
settings for Web browser layout and scripting.

About Siebel Tools Right-Click Menus
Right-click menus in Siebel Tools allow you navigate and perform the following actions: 

■ Launch the Web Applet editor from the applet list in the Object List Editor by right-clicking and 
choosing Edit Web Layout. If an applet Web template does not already exist, the Web Layout 
wizard appears.

■ Launch the Web View editor directly from the view list in the Object List Editor by right-clicking 
and choosing Edit Web Layout. If a view Web template does not already exist, the Web Layout 
wizard appears. In the first wizard, you need to choose a view Web template from a combo box.

■ The right-click menu in the Object List Editor for Web Template objects includes these choices:

■ View the template, which brings up the appropriate editor with no mappings.

■ Edit the template, which brings up the internal or external template editor.

■ Right-clicking a Siebel Tools toolbar displays the names and status of the toolbars (similar to 
using View > Toolbars).

Table 20. Configuration Context Toolbar Drop-Down Lists

Drop-Down List Description

Target Browser A drop-down list from which you select a target browser for layout editing 
and for scripting.

Application Allows you to configure objects for a specific application. Typically, you 
work with the All Applications selected. When this option is selected, your 
configurations are available in all applications. However, by selecting 
specific applications from the list, you can also configure the layout of 
objects such as applets and views to look or behave a differently for that 
application.

Interactivity Allows you to select High Interactivity or Standard Interactivity. This 
allows you to configure Web layouts differently, depending on the mode 
in which the application runs.

Variable Allows you to specify a given display style for an applet for previewing, 
such as parent, child, or grandchild. Applet may be rendered differently 
depending on the underlying Web template. For example, the header of 
an applet may not appear when it is rendered as a grandchild.
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About Layout Editors
There are several layout editors in Siebel Tools, Applet Layout Editor, View Layout Editor, Web Page 
Layout Editor, and the Applet Menu Layout Editor. These layout editors let you:

■ Add and map controls and list columns to applet layouts. You can preview applets as they would 
be rendered at run time.

■ Modify existing views and construct new ones by dragging and dropping applets onto the view 
layout window. You can view list and form applets and the container page in the Preview mode. 
No additional specification or code is required for defining the relationships between the applets.

■ Add and delete controls from Web page templates, modify control properties, and map controls 
to placeholders. You can also preview Web pages as they would appear at run time.

■ Visually edit Siebel application menu structures. It is accessed by right-clicking an applet in the 
Object List Editor and selecting Edit Web Menus.

You can launch the Layout Editors directly from an applet, view, or Web page in the Object List Editor 
by right-clicking and choosing Edit Web Layout or Edit Web Menus.

For more information about using layout editors, see Configuring Siebel Business Applications.

Related Topic
“Defining a Target Browser” on page 69

About New Object Wizards
Various wizards in Siebel Tools step you through the process of creating objects. They prompt you 
for the required property values and configure any dependent object types. Wizards are available for 
many objects types, including:

■ General objects, such as Applet Method Menu Items, Business Components, Tables, and Views

■ Applet objects, such as List Applets, Form Applets, MVG Applets, and Chart Applets

■ EAI objects, such as Integration Objects

You can access the New Object Wizards by choosing File > New Object.

NOTE: Use the new object wizards to create objects whenever possible. 

For more information about using new object wizards, see Configuring Siebel Business Applications.

About the Entity Relationship Designer
The Entity Relationship Designer is a visual modeling tool that allows you to diagram your business 
entities, represent the relationships between them, and then map them to Siebel objects, such as 
business components, links, and joins. 
Using Siebel Tools Version 7.8, Rev. B 49



About the Siebel Tools User Interface ■ About the Business Process Designer
The Entity Relationship Designer is typically used by both Business Analysts and Developers. 
Business analysts diagram a customer’s business and then developers or technical architects map 
the entities in the diagrams to Siebel objects in the repository.

When mapping entities and relationships in the diagram to Siebel objects, the choice of objects to 
choose includes only those that have characteristics that match the context described in the diagram.

For information on creating entity relationship diagrams and mapping them to Siebel objects, see 
Configuring Siebel Business Applications.

About the Business Process Designer
The Siebel Business Process Designer allows you to define, manage, and enforce your company's 
business processes. Defining business processes is typically a development task. The Workflow 
Designer and the Workflow Simulator are integrated with Siebel Tools, allowing you to define and 
test business processes and related repository objects in a single environment. 

For more detailed information about creating business processes and using Workflow Designer and 
Workflow Simulator, see Siebel Business Process Designer Administration Guide.

About Script Editors
Scripting is used to implement functionality that cannot be achieved declaratively (that is, by 
changing object properties). The Server Script Editor and the Browser Script Editor are used to add 
scripts to Siebel objects. Scripting is supported through three features in Siebel applications: Siebel 
VB, Siebel eScript, and Browser Script. 

For more information on Script Editors, including Script Assist, see Chapter 8, “Siebel Script Editors.”

About the Command-Line Interface
You can use the command-line interface to run various tasks, including:

■ “Command-Line Interface for Import, Export, and Compilation” on page 141

■ “Validating Objects Using the Command-Line Interface” on page 105

■ Converting to grid-layout. For more information, see Configuring Siebel Business Applications.

■ “Running the LMU Using the Command-Line Interface” on page 198

■ “Exporting Objects to an Archive File Using the Command-Line Interface” on page 146

■ “Importing Objects from an Archive File Using the Command-Line Interface” on page 153
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3 Customizing Your Siebel Tools 
Environment
This chapter describes how to customize the Siebel Tools environment. It contains the following 
topics:

■ “About Development Tools Options” on page 52

■ “Showing and Hiding Confirmation Dialog Boxes” on page 52

■ “Setting Change Date Preferences” on page 52

■ “Selecting a Language Mode” on page 53

■ “Enabling Language Overrides” on page 53

■ “Process for Integrating with Third-Party Source Control” on page 54

■ “Specifying Data Sources” on page 59

■ “Restarting Editors After Check Out” on page 60

■ “Setting Commit Options for Full Get” on page 61

■ “Defining Object List Editor Display Options” on page 61

■ “Setting Scripting Options” on page 62

■ “Defining the Web Template Editor” on page 63

■ “Setting Debug Options” on page 64

■ “Customizing Visualization Views” on page 65

■ “Showing and Hiding Object Types in the Object Explorer” on page 66

■ “Setting Database Options” on page 68

■ “Setting the Constrain Mode for Working with Symbolic Strings” on page 68

■ “Setting the Constrain Mode for Working with Symbolic Strings” on page 68

■ “Defining a Target Browser” on page 69

■ “Showing and Hiding Windows” on page 69

■ “Docking Windows” on page 70

■ “Showing and Hiding Editors” on page 71

■ “Showing Visualization Views” on page 71

■ “Showing and Hiding Debug Windows” on page 71

■ “Showing and Hiding Toolbars” on page 72

■ “Showing and Hiding the Status Bar” on page 72

■ “Showing and Hiding the Object Explorer” on page 72
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About Development Tools Options
Several customization tasks involve choosing View > Options and setting preferences in the 
Development Tools Options dialog box. Whenever you click OK to exit the Development Tools Options 
dialog box, whether you have made changes to the preferences or not, the preferences are saved in 
the devtools.prf file, located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools 
installation directory.

NOTE: If the behavior of the Tools environment is not consistent with the preferences you set, your 
devtools.prf file may be corrupted. Choose View > Options, reset preferences if necessary, then click 
OK. By doing so, the devtools file is regenerated. Alternatively, if you delete the devtools.prf file, 
then relaunch Tools, the default preferences are reset.

Showing and Hiding Confirmation Dialog 
Boxes
You can choose to show or hide dialog boxes that pop up to confirm you want to perform a given 
action, such as delete.

To show or hide confirmation dialog boxes

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the General tab.

3 Under Editing confirmation dialogs, select the check boxes for the confirmation dialog boxes you 
want to see, and clear the check boxes for the confirmation dialog boxes you do not want to see.

4 Click OK.

Setting Change Date Preferences
Records are marked as changed in the Object List Editor when they occur after the date defined under 
the General Tab of the Development Tools Options dialog box.

To set change date preferences

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the General tab.

3 Under Changed date, use the Date and Time fields to set your preferences, then click OK.
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Selecting a Language Mode
The Siebel Tools language mode allows you to work with locale-specific data for languages other than 
English. For example, setting your language mode to German (DEU) allows you to view and edit DEU-
specific data stored in Locale-Objects, such as translated strings. Language mode determines the set 
of locale-specific data that:

■ You can view and edit in the Object List Editor.

■ Is used when compiling the repository (SRF) file.

■ Is transferred during check in and check out processes.

NOTE: If additional languages (other than the language product versions shipped with Siebel 
applications) are added to the Siebel database, the language code must be in all capital letters for 
the code to appear in the Language Mode drop-down list. For more information on adding languages 
not shipped by Oracle, see Global Deployment Guide.

To set a language mode

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Language Settings tab.

3 Under Tools Language Mode, select a value from the Language drop-down list, then click OK.

NOTE: Before configuring another language, make sure that the language repository data has 
already been loaded into the repository. If not, load this data before beginning configuration on the 
language in question.

Related Topic
“Enabling Language Overrides” on page 53

Enabling Language Overrides
Language Overrides are untranslatable locale-specific attributes that may be configured differently 
for different locales. For example, you can configure an address field to appear one height in FRA 
(French) and another height in ENU (English). To be able to configure language overrides, you must 
be in Language Override mode.

NOTE: Enabling language overrides when it is not needed can create unnecessary locale records in 
the repository.

For more information about configuring UI layout, see Configuring Siebel Business Applications.

To enable language overrides

1 Choose View > Options.

The Development Tools Options dialog box appears.
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2 Click the Language Settings tab.

3 Under Language override, select the Enable and Use Language Override check box, then click OK.

NOTE: The Enable and Use Language Override check box is persistent. You must clear it to return 
to working in base mode.

Related Topics
“Selecting a Language Mode” on page 53

“Working with Untranslatable Locale-Specific Object Properties” on page 187

Process for Integrating with Third-Party 
Source Control
You can integrate your repository check in/check out mechanism in Siebel Tools with a third-party 
source code-control system such as Microsoft Visual SourceSafe. When source control integration is 
enabled, each time a project is checked into the server repository, an archive file containing all the 
objects in the project is also checked into the source control system. As a result, successive versions 
of the project are maintained in the source control system. 

To integrate your repository check in/check out with a third-party source control system, perform 
the following tasks:

1 “Setting Source Control Options” on page 54

2 “Configuring the srcctrl.bat File” on page 55

Setting Source Control Options
You enable and partly configure the interface to an external source control system using the 
Development Tools Options dialog box. 

To integrate Siebel Tools with a third-party source control product

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.
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3 Use the information in the following table to define your settings under Source control 
integration.

4 Click OK.

Configuring the srcctrl.bat File
The srcctrl.bat batch file contains the sequence of commands to be executed in order to check the 
archived projects in to the source control system. You need to modify the batch file to reflect your 
current development environment and then distribute to all developers at your site.

The name of the archive (SIF) file for the project to be checked in is specified as an argument to the 
batch file, in addition to other arguments. The syntax for the command line that executes the batch 
file is as follows:

SRCCTRL action dir comment_file project_file

The arguments for srcctrl.bat are described in Table 21.

Field/Check Box Description

Enable source control integration Select this check box and specify the location of the 
srcctrl.bat batch file in the Integration batch file text box 
if you want to generate an archive file for each project 
when performing repository check in, and at the 
conclusion of repository check in to run the batch file 
once for each project.

Show execution of the integration 
batch file

Select this check box to launch a DOS window in the 
foreground when the srcctrl.bat batch file is executed. 
This feature is for diagnosis purposes and facilitates 
debugging a customized batch file.

Integration batch file Specifies the location of the srcctrl.bat batch file used by 
Siebel applications to instruct the source control 
software to provide check in or check out of archive files.

Table 21. Arguments for the srcctrl.bat File

Argument Description

action Check in or check out.

dir Path name of the directory on your local file system where the 
items are located.
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Srcctrl.bat executes once for each project, following the completion of repository check-in. It checks 
the archive file for the project into or out of the source control system. Srcctrl.bat is executed from 
a command line that is internally generated from the Siebel application software. You do not have 
access to the command-line setup, and you cannot modify the command line or the parameters it 
passes.

The following batch file program code is taken from the standard srcctrl.bat file provided with Siebel 
applications, and is designed to work with Microsoft Visual SourceSafe. Comment lines have been 
removed. You need to customize the program code in this batch file, particularly if you are running 
source control software other than Microsoft Visual SourceSafe, or if the path is incorrect:

set PATH=C:\Program Files\DevStudio\Vss\win32\;%PATH%
set SOFTWARE=ss
set CHECKIN=%SOFTWARE% checkin
set CHECKOUT=%SOFTWARE% checkout
set ADD=%SOFTWARE% add
set SETPROJ=%SOFTWARE% cp
set PROJECT=$/PROJPOOL
set SRC_USR=
set SRC_PSWD=
set OPTIONS=-i-y -y%SRC_USR%,%SRC_PSWD%
set COMMENT=-c@
set NON_COMMENT=-c-
set FILE=
set LOGFILE=C:\Temp\xml.log
echo =======================srcctrl.bat========================== >> %LOGFILE%
set ACTION=%1
shift
set DIR=%1
shift
set COMMENT=%COMMENT%%1
shift
set FILE=%1
echo Change local directory to %DIR% >> %LOGFILE%
chdir %DIR% >> %LOGFILE% 2>&1
echo Set %PROJECT% as the working folder at Source Control System >> %LOGFILE%
%SETPROJ% %PROJECT% >> %LOGFILE% 2>&1
if errorlevel 100 goto END
if %ACTION%==checkout goto CHECK_OUT
if %ACTION%==checkin goto CHECK_IN
:CHECK_OUT
echo ============Check out file %FILE% from Source Control System============
if not exist %FILE% echo "New File" >> %FILE%
attrib +r %FILE%

comment_file Contains the comment text to be provided to the source 
control software with the project file.

project_file Name of the archive (SIF) file for one project, enclosed in 
double quotes.

Table 21. Arguments for the srcctrl.bat File

Argument Description
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echo Add %FILE% in case it doesn't exist in Source Control System >> %LOGFILE%
%ADD% %FILE% %NON_COMMENT% %OPTIONS% >> %LOGFILE% 2>&1
echo Start checking out %FILE% from Source Control System >> %LOGFILE%
%CHECKOUT% %FILE% %NON_COMMENT% %OPTIONS% >> %LOGFILE% 2>&1
goto END
:CHECK_IN
echo ============Check in file %FILE% into Source Control System============
echo Check in %FILE% into Source Control System >> %LOGFILE%
%CHECKIN% %FILE% %COMMENT% %OPTIONS% >> %LOGFILE% 2>&1
attrib -r %FILE%
goto END
:END
echo ===================End Of srcctrl.bat====================== >> %LOGFILE%
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The variables used in the srcctrl.bat batch file are described in Table 22.

NOTE: The folder that SIF files are written to is specified by the TempDir parameter in the [Siebel] 
section of the tools.cfg file. By default it is set to the SIEBEL_TOOLS_ROOT\TEMP folder of your 
Siebel Tools installation folder. Change this parameter to write the PROJECT directory to another 
location. 

For information on archive (SIF) files, see “About Archive Files” on page 145.

Table 22. Variables in srcctrl.bat

Variable Description

PATH Identifies the directory where the source code control software is installed. Modify 
this setting to reflect its actual location on your machine.

SOFTWARE Source control system’s command-line utility. The command-line utility for 
Microsoft Visual SourceSafe is “ss”. 

CHECKIN Command at the start of the command line that calls for check-in into the source 
control system.

CHECKOUT Command at the start of the command line that calls for check-out from the source 
control system. 

ADD Command at the start of the command line that calls for adding files in the source 
control system.

SETPROJ Command at the start of the command line that calls for setting the working folder 
in the source control system. 

PROJECT Project (working folder) in the source control system where the items will be 
checked in/checked out. 

COMMENT Command-line Comments clause for each of the files being checked in or out. This 
is generated from the Comment argument to the batch file.

OPTIONS Text of the Options clause to include in a command line.

SRC_USR User logon name to include in the Options clause. This is a source control software 
user name, not the user name for a Siebel application.

SRC_PSWD User password to include in the Options clause. This is a source control software 
password.

FILE Filename of the archive file, obtained from the argument list of the batch file. This 
file needs to be checked in or out.

LOGFILE Path and filename of the log file that will be generated.
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Example of Integrating with Microsoft Visual 
SourceSafe
The following sections provide you with examples for using Microsoft Visual SourceSafe.

Check In Example
You have two projects checked out that you want to simultaneously check in to the server and to the 
source control software. The projects selected are “ProjectA” and “ProjectB.” The latest version of 
ProjectA.sif in Visual SourceSafe is 6, and the latest version of ProjectB.sif is 5.

When you click the Check In button, the following sequence occurs:

1 ProjectA and ProjectB are checked in to the server repository.

2 SIEBEL_TOOLS_ROOT\BIN\srcctrl.bat is invoked. This carries out steps 3, 4, and 5.

3 ProjectA.sif and ProjectB.sif are checked out and locked in Visual SourceSafe.

4 ProjectA is exported to SIEBEL_TOOLS_ROOT\TEMP\projects\ProjectA.sif, and ProjectB is 
exported to SIEBEL_TOOLS_ROOT\TEMP\projects\ProjectB.sif.

5 ProjectA.sif and ProjectB.sif are checked in to Visual SourceSafe. The version numbers are 
increased so that the latest version of ProjectA.sif in Visual SourceSafe is version 7, while 
ProjectB.sif is version 6.

Revert to Previous Version Example
Consider the situation in which an erroneous definition of ProjectA has been checked in to the server 
repository. This is stored in Microsoft Visual Source Safe as version 5 of ProjectA.sif. You want to 
revert to version 4 of ProjectA, because it does not contain the errors:

1 Check out version 4 of ProjectA.sif from Visual SourceSafe into SIEBEL_TOOLS_ROOT\TEMP.

2 Check out ProjectA from the server repository.

3 Import ProjectA.sif into the local repository using the Overwrite option to resolve object 
definition conflicts. This replaces the existing definition of ProjectA with the archived version. 

4 Check ProjectA in to the server repository. ProjectA.sif is automatically checked in to Visual 
SourceSafe as version 6.

Specifying Data Sources
The Check In/Out tab in the Development Tools Options dialog box provides options for setting up 
server and client data sources.

NOTE: For purposes of development, you should maintain only one local database for use with Tools 
and with your Mobile Web Client, so that changes implemented in Tools can be viewed with the Mobile 
Web Client. Edit the tools.cfg file and client application cfg files (such as uagent.cfg) to point to the 
same local database.
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To specify data sources

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.

3 Change the ODBC data source of the server repository by doing the following:

a Under Data sources, in the Server field, click the Change button to change the ODBC data source 
of the server repository.

b Use the information in the following table to define the ODBC data source parameters.

c Click OK.

4 Change the ODBC data source of the local repository by doing the following:

a Under Data sources, in the Client field, click the Change button to change the ODBC data source 
of the local repository.

b Use the information in the following table to define the ODBC data source parameters.

c Click OK.

5 Click OK.

Restarting Editors After Check Out
You can set an option that automatically restarts any open editors after the check out process 
finishes.

Field Description

ODBC data source Full ODBC data source string that provides communication with the 
server repository database. 

User name User logon ID (in all uppercase) used to access the server database.

Password User password (in all uppercase) used to access the server database.

Table owner Table owner name used to access the repository on the server 
database.

Field Description

ODBC data source Full ODBC data source string that provides communication with the 
local repository database. 

User name User logon ID (in all uppercase) used to access the local database.

Password User password (in all uppercase) used to access the local database.

Table owner Table owner name used to access the repository on the local database.
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To restart editors after check out

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.

3 Select the Restart the editors after Check Out check box.

Any editors that are open at the time you begin the Check Out process are restarted when the 
Check Out process finishes.

4 Click OK.

Setting Commit Options for Full Get
By default, the Full Get process performs database commits in regular intervals during the process 
rather than a single commit at the end of the process. 

You can disable this option by choosing View > Options, selecting the Check In/Out tab, and then 
clearing the Enable incremental commit during Full Get check box. 

To set commit options for Full Get

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.

3 To request a single commit at the end of a Full Get, clear the Enable incremental commit during 
Full Get check box.

4 Click OK.

Related Topics
“About the Get Process” on page 73

“Performing a Full Get” on page 73

Defining Object List Editor Display 
Options

To define display options for the Object List Editor

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the List Views tab.
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3 Use the information in the following table to define your options.

4 Click OK.

Setting Scripting Options
Browser and Server scripts are created in the Script Editor embedded in Siebel Tools. For more 
information on the Script Editor, see Chapter 8, “Siebel Script Editors.” You can set various options for 
working in Script Editor, including setting a default scripting language, specifying a location for 
compiling browser scripts, and defining options for debugging.

To set scripting options

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Scripting tab.

3 Use the information in the following table to define your options.

Area Field Description

List fonts Small/Normal/Large The size of the font used in the list.

List spacing Tight/Normal/Loose The spacing between rows in the list.

Style Horizontal grid lines Show or hide horizontal grid lines in the list.

Vertical grid lines Show or hide vertical grid lines in the list.

Alternating row color Use different colors for every second row.

Mouse focus rectangle Show or hide dotted line that appears around the 
currently selected record.

Area Field Description

Font Name Used to select the font name for display of 
scripts.

Size Used to select the font size for display of scripts.
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4 Click OK.

Defining the Web Template Editor
The Web template editor is an external application that you define here and that you can open using 
a right-click menu in the Web template explorer. For example, in the Web template explorer, navigate 
to a given Web template, then right-click, and the application defined as the default editor opens 
with the selected Web template automatically displayed.

Script Assist Enable Method Listing Enables Script Assist to display a drop-down of all 
methods and properties available for a declared 
object.

Tab width Defines the number of spaces for a tab character. 
The default is four spaces.

Enable Auto Complete When checked, will auto complete a given term 
when the minimal number of unique characters 
have been entered. 
Additionally, this setting will auto complete 
method or property names, presenting a drop-
down list for strings that are not unique. 

Auto Indent When checked, each succeeding line is indented 
to the position set by the current line.

Engine Settings Available if you have the ST eScript Engine 
enabled. For more information on these settings, 
see “Setting the ST eScript Engine Warnings 
Preference” on page 126.

Language Default language for new 
scripts

A drop-down list allows you to choose the 
scripting language, either, eScript, or Visual 
Basic.

Browser script 
compilation folder

Specify the folder where your scripts will reside.

Debugging Adjust breakpoint to next 
valid line

When breakpoints are deleted on invalid lines, 
this option creates a breakpoint at the next valid 
line.

Make debugger window 
active when debugging

The Siebel Debugger window appears whenever 
you are in debug mode.

Always enter the 
debugger when an error 
occurs

The Siebel Debugger window appears whenever a 
script error occurs.

Area Field Description
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To define the default path for Web template files

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Web Template Editor tab.

3 In the Folder full path field, type the full path to location of your Web template files.

4 Under External Web template editor, do the following:

a Use the Browse button in the Executable full path field to navigate to and select the executable 
for the external Web editor.

b In the Optional parameters field, enter the parameters you want to pass to the executable when 
you launch the external editor.

5 Click OK.

Setting Debug Options
The debug options provide the run-time settings for opening an instance of the Siebel Web Client in 
the following situations:

■ When the Auto-start Web Client option is selected in the object compiler. 

For more information, see “Compiling Projects” on page 140.

■ When starting an instance of the Web Client by selecting Debug > Start. 

You typically use this option when debugging Siebel eScript or Siebel VB. For more information, 
see Siebel eScript Language Reference and Siebel VB Language Reference.

The settings defined the Debug tab of the Development Tools Options dialog are stored in a user 
preference file that is named loginID&SiebelTools.spf and located in SIEBEL_TOOLS_ROOT\BIN. 

To set up Tools to automatically open the Siebel Mobile Web Client

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Debug tab.
Using Siebel Tools Version 7.8, Rev. B64 



Customizing Your Siebel Tools Environment ■ Customizing Visualization Views
3 Use the information in the following table to define your options under Run-time start up 
information.

4 Use the information in the following table to define your options under Login information and then 
click OK.

Customizing Visualization Views
You can customize the font and appearance of visualization views.

To customize visualization views

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Visualization tab.

Field Example Value Description

Executable Siebel.exe Name of the executable 
that is opened in debug 
mode or automatically 
opened after the compile 
process.

CFG file D:\Program Files\Siebel\7.8\web 
client\BIN\ENU\uagent.cfg

Name and location of the 
configuration file for the 
application.

Browser C:\Program Files\Internet 
Explorer\iexplore.exe

Installation location of the 
Microsoft Internet Explorer 
browser. 

Working 
Directory

D:\Program Files\Siebel\7.8\web client\BIN The directory that contains 
the Siebel executable.

Arguments ■ /h – To enable local debugging of Server 
scripts

■ /s <filename> – To enable SQL spooling

Opens the watch window 
that allows you to trace the 
application.

Field Example Value Description

User name SADMIN User name used to log into the test application.

Password SADMIN Password to log in to the test application.

Datasource Sample Local database to which the local Mobile Web Client 
connects. Default data source. Values listed depend 
upon the configuration file you are using.
Using Siebel Tools Version 7.8, Rev. B 65



Customizing Your Siebel Tools Environment ■ Showing and Hiding Object Types in the 
Object Explorer
3 Use the information in the following table to define your options under Font.

4 Use the information in the following table to define your options under Object style, and then 
click OK.

Showing and Hiding Object Types in the 
Object Explorer
By default, not all objects appear in the Object Explorer.

To show and hide objects

1 Choose View > Options.

The Development Tools Options dialog box appears.

Option Description

Use system 
font

Select this option to let Siebel Tools use a system font for the visualization 
views.

Use a Custom 
Font

Select this option to choose your preferred font for the visualization views. 
When you select this option, you must use the Font, Size, and Zoom drop-
down lists to define your preferences.

Option Description

Boxes with 3D borders Displays boxes with a 3D border.

Icon and name only Displays object name and object icon (the same icon used in the 
Object Explorer).

Simple outline boxes Displays object names in simple boxes.

Always print outline style Prints visualization details in outline style.
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2 Click the Object Explorer tab.

The Object Explorer hierarchy appears as shown.

3 In the Object Explorer Hierarchy box, shown below, select the check boxes for the objects you 
want to show and clear the check boxes for the objects you want to hide.

When you select a top-level object such as Applet, all child objects are automatically selected. 
To hide child objects, you need to expand the parent object and remove the check marks from 
any child objects that you want to hide. The parent check box becomes shaded to indicate that 
it contains child objects that are not selected to show. 

TIP: The state of the check box provides information about the show/hide state of the child 
objects.

4 To restore default settings, click the Default button, then click OK.

Check Box State Description

Current object shown, and all child objects shown.

Current object hidden, and all child objects hidden.

Current object shown, and some child objects shown.
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Setting Database Options

To set database options

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Database tab.

3 Use the information in the following table to set your options, and then click OK.

Setting the Constrain Mode for Working 
with Symbolic Strings
Siebel Tools can run in either constrained mode or unconstrained mode:

■ When working in constrained mode, you must choose translatable text strings from the list of 
available string references. You cannot override the string reference by entering a value for a 
string override field, and you cannot create new symbolic string references.

■ When working in unconstrained mode, you are not required to choose translatable text strings 
from the list of string references. You can override the string reference by entering a value in a 
string override field. You can also create new symbolic string references.

The constrain mode is determined by the following CFG file parameter, found in the [Siebel] section 
of the tools.cfg file:

EnableToolsConstrain = FALSE

EnableToolsConstrain must be set to either TRUE or FALSE. It is set to FALSE by default.

Related Topics
“About the Symbolic Strings Model” on page 170

“Creating Symbolic Strings” on page 171

Option Description

Developing for deployment on 
DB2 for zSeries

For information about this parameter, see Implementing 
Siebel Business Applications on DB2 UDB for z/OS.

Allow to create column of type 
‘Character’ being greater than 1

Removes constraint on columns of type CHAR, so that they 
can be greater than one character in length. Note that 
defining a column as CHAR when the data being stored can 
be variable in length causes the data to be padded with 
blank spaces in the database.
Using Siebel Tools Version 7.8, Rev. B68 



Customizing Your Siebel Tools Environment ■ Defining a Target Browser
Defining a Target Browser
The target browser group determines how applets appear in the preview mode of the Applet Layout 
Editor. You can include conditional tags in Web templates that are displayed for some browsers but 
not others. Defining a target browser determines how the these conditional tags are expressed in 
the Applet Layout Editor and allows you to preview an applet layout as it would look in a specific 
browser.

To define configuration context

1 Choose View > Toolbars > Configuration Context.

The Configuration Context toolbar appears.

2 From the Target Browser drop-down list, choose Target Browser Config.

The Target Browser Configuration dialog box appears. The following table describes the parts of 
the dialog box.

3 To add a browser group to the list of selected browsers, double-click the browser in the Available 
browsers list. 

You can also use the right and left arrow buttons to move browsers between the Available and 
Selected lists.

4 Click OK.

The browser groups you added to the list of Selected browsers for layout editing now appear as 
values in the Target Browser drop-down list.

Showing and Hiding Windows
You show and hide windows using toggles on the View menu.

To show or hide a window using the View menu

1 Choose View > Windows.

A list of windows appears in a secondary pop-up menu. A visible window is identified with a check 
mark. A hidden window has no marker. 

Field Description

Available browsers List of available browser groups.

Selected browsers 
for layout editing

Specifies which browser groups are affected by subsequent layout 
editing in the Web Layout Editor. 

Capability name and 
value

Specifies what capabilities or properties the currently selected virtual 
browser group has. 
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2 Select the window you want to show or hide.

If the window was hidden, it appears. If the window was visible, it is hidden.

NOTE: To show or hide the Bookmarks window, you can also use the Go menu (Go > Bookmarks 
List).

To hide a window using a right-click menu

1 Right-click the window title of the window you want to hide.

2 From the pop-up menu that appears, choose Hide.

The window no longer appears in the Siebel Tools application window.

Related Topics
“Docking Windows” on page 70

“Showing and Hiding the Object Explorer” on page 72

Docking Windows
You can let the Object Explorer or Properties, Applets, Controls, Web Template, or Bookmarks 
windows float, moving and sizing to fit your needs, or dock the window in a corner of the main 
window. 

To dock a window
■ Drag the window to the area of the main window where you want to dock.

To undock a window
■ Right-click the window, and choose Docked.

To prevent a window from docking when it is being moved
■ Hold down the CTRL key during the move.

Related Topics
“Showing and Hiding Windows” on page 69

“Showing and Hiding the Object Explorer” on page 72
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Showing and Hiding Editors

To show or hide an editor

1 Choose View > Editors.

A list of editors appears in a secondary pop-up menu. A visible editor is identified with a check 
mark. A hidden editor has no marker. 

2 Select the editor you want to show or hide.

If the editor was hidden, it appears. If the editor was visible, it is hidden.

Showing Visualization Views
You can use the Siebel Tools Visualization views to see how objects relate to one another. 

To show a visualization view using the View menu

1 Choose View > Visualize.

A list of visualization views appears in a secondary pop-up menu. A visible view is identified with 
a check mark. A hidden view has no marker. 

2 Select the view you want to show or hide.

If the editor was hidden, it appears. If the editor was visible, it is hidden.

To show a visualization view from the Object List Editor

1 Display the relevant object type in the Object List Editor.

2 Right-click an object and choose the Visualization view you want. 

Not all Visualization views are listed for all objects.

Related Topics
“Viewing Object Relationships” on page 114

Showing and Hiding Debug Windows
You can show or hide the debug windows.

To show or hide the Calls window
■ Choose View > Debug Windows > Calls. Alternatively, press CTRL+L.
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To show or hide the Watch window
■ Choose View > Debug Windows > Watch. Alternatively, press SHIFT+F9.

To show or hide the Errors window
■ Choose View > Debug Windows > Errors.

Showing and Hiding Toolbars
You show and hide toolbars using toggles on the View menu.

To show or hide a toolbar

1 Choose View > Toolbars. Alternatively, right-click any of the toolbars.

A list of toolbars appears in a secondary pop-up menu. A visible toolbar is identified with a check 
mark. A hidden toolbar has no marker. 

2 Select the toolbar you want to show or hide.

If the toolbar was hidden, it appears. If the toolbar was visible, it is hidden.

Showing and Hiding the Status Bar

To show or hide the status bar
■ Choose View > Status Bar.

If the status bar was hidden, it appears. If the status bar was visible, it is hidden.

Showing and Hiding the Object Explorer
You can show or hide the Object Explorer.

To show or hide the Object Explorer
■ Choose View > Object Explorer. Alternatively, press CTRL+E.

If the Object Explorer was hidden, it appears. If the Object Explorer was visible, it is hidden.

Related Topics
“Showing and Hiding Windows” on page 69

“Docking Windows” on page 70
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Repository
This chapter describes how to get projects from the server repository. It contains the following 
topics:

■ “About the Get Process” on page 73

■ “Performing a Full Get” on page 73

■ “Getting Projects from the Server Repository” on page 74

■ “Getting Locale-Specific Data Only” on page 75

About the Get Process
The process of copying projects from the server database to your local database is known as 
performing a Get. The Get process differs from checking out in the following ways:

■ Getting projects does not lock them on the server database.

■ Getting projects overrides all the projects on your local database, whether they are locked or not 
locked.

NOTE: The sample database, unlike a local database, cannot receive projects from the server 
database during a Get. The sample database is intended for instructional use only.

Typically you perform a Get to initially populate your local database. This process is known as a Full 
Get. You can also get projects to override objects stored on your local database.

Related Topics
“Performing a Full Get” on page 73

“Getting Projects from the Server Repository” on page 74

“About the Check Out and Check In Process” on page 78

Performing a Full Get
For a newly initialized local database, you need to copy all objects from the server repository to your 
local repository by running a process called a Full Get. You must perform a Full Get before you 
compile, because the SRF file must be based on the comprehensive set of Siebel objects.

You use the Full Get option to synchronize the local database with the modifications done on the 
server.
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By default the Full Get process performs database commits in regular intervals, rather than a single 
commit at the end of the process. For information about changing this option, see “Setting Commit 
Options for Full Get” on page 61.

NOTE: In order to invoke the executable that performs a Get, the user must be the user who 
installed Tools on this local machine, or the ODBC driver that is used to perform the Get must be set 
to System DSN, instead of User DSN, on the operating system so that any user of the machine can 
perform the Get. 

To perform a full Get

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check Out.

3 Choose the name of your development repository from the Repository pick list.

NOTE: The repository that you select is not necessarily the one opened by Siebel Tools.

4 Select All Projects.

5 Click Options. 

6 In the Development Tools Options window, make sure your Server Data Source is pointing to your 
server development database and your Client Data Source is pointing to the local database you 
previously initialized and are currently running against. 

7 In the Check Out dialog box, click Get.

All objects from the server repository are copied to your local repository.

Getting Projects from the Server 
Repository
You can use the Get process to overwrite projects stored in your local repository with versions of the 
projects from the server repository. You may need to do this after you have changed local copies of 
projects and you want to revert back to the versions stored on the server, or after other developers 
check in changes and you need to copy those changes to your local repository.

To overwrite projects stored in your local database

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check Out.

3 Choose the name of your development repository from the Repository pick list.

NOTE: The repository that you select is not necessarily the one opened by Siebel Tools.

4 In the Projects list, select the projects you want to get.

5 Click Options. 
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6 In the Development Tools Options window, make sure your Server Data Source is pointing to your 
server development database and your Client Data Source is pointing to the local database you 
previously initialized and are currently running against. 

7 In the Check Out dialog box, click Get.

All objects associated with the projects are copied from the server repository to your local 
repository.

Related Topics
“About the Get Process” on page 73

Getting Locale-Specific Data Only
After you have performed a Full Get, you can get locale-specific data without having to get parent 
objects too. This is useful when you have been working in one language and then switch to another 
language. For example, suppose you have already populated your local repository with English (ENU) 
data, but now you want to switch to Japanese (JPN). After switching your language mode to JPN, you 
can use the Get Locale-Specific Data option to copy JPN records only from the server repository to 
your local repository.

To get locale-specific data only for projects

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check Out.

3 Choose the name of your development repository from the Repository pick list.

NOTE: The repository that you select is not necessarily the one opened by Siebel Tools.

4 Select the Projects for which you want to get locale-specific data.

5 Click Options. 

6 Make sure your Server Data Source is pointing to your server development database and your 
Client Data Source is pointing to the local database you previously initialized and are currently 
running against. 

7 Click OK to close the Development Tools Options dialog box.

8 In the Check Out dialog box, select the Get Locale Specific Data Only check box.

9 Click Get.

Data stored in child locale objects of the selected projects are copied from the server repository 
to your local repository.
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5 Checking Out and Checking In 
Projects and Objects
This chapter describes how to check out and check in projects and objects. It contains the following 
topics:

■ “About the Check Out and Check In Process” on page 78

■ “Setting Options for Check Out and Check In” on page 78

■ “Guidelines for Check Out and Check In” on page 78

■ “About the Project Check Out Dialog Box” on page 79

■ “About the Object Check Out Dialog Box” on page 82

■ “About the Check In Dialog Box” on page 84

■ “Checking Out and Checking In Projects” on page 86

■ “Checking Out Projects from the Server Repository” on page 86

■ “Checking In Projects to the Server Repository” on page 87

■ “Checking Out and Checking In Objects” on page 87

■ “About Object Check Out and Check In” on page 88

■ “Enabling Object Check Out and Check In” on page 88

■ “Setting Projects to Allow Object Locking” on page 88

■ “Checking Out Objects from the Server Repository” on page 89

■ “Checking In Objects to the Server Repository” on page 90

■ “Locking Objects Locally” on page 91

■ “Limitations of Object Check Out and Check In” on page 91

■ “Viewing Object Differences” on page 91

■ “Viewing Object Differences” on page 91

■ “Undoing Check Out” on page 91
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About the Check Out and Check In 
Process
Check Out and Check In is a source control mechanism for multiple developers working in the same 
repository. It allows you to check out objects from the server and download them to your local 
repository for editing. When you check out objects, they are locked on the server. This prevents other 
developers from checking them out and avoids conflicts that could result from multiple developers 
working on the same objects simultaneously. When you check objects back to the server, the lock is 
removed, and the objects are available for other developers to check out. 

NOTE: You can lock objects directly on your local repository, without checking them out, but changes 
you implement cannot be checked in. See “Locking Projects Directly in the Local Repository” on 
page 95.

Setting Options for Check Out and Check 
In
You use the Development Tools Options dialog box to define options related to the check in and check 
out processes. See the following topics for details about check in and check out options:

■ “Process for Integrating with Third-Party Source Control” on page 54

■ “Specifying Data Sources” on page 59

■ “Restarting Editors After Check Out” on page 60

■ “Setting Commit Options for Full Get” on page 61

Guidelines for Check Out and Check In
Before checking out or checking in projects or objects, consider the following:

■ Password encryption interferes with check out. If you are checking out projects, you need to 
disable password encryption in the client or CFG file when running Siebel Tools.

■ You check out projects and objects in the current Siebel Tools language mode only. For more 
information, see “Selecting a Language Mode” on page 53.

■ The sample database, unlike a local database, cannot receive checked-out objects, and its 
objects cannot be checked in to the server database. The sample database is strictly for 
instructional use.

■ Objects must be checked out and checked in to the server database from which the local 
database was extracted.

■ Before doing a check-in, make sure that the projects and objects you are checking in are in a 
stable state, that all dependent scripting is complete, and the configuration has been tested 
against your local repository.
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■ Check in all dependent projects and objects at the same time to be sure that the configuration 
on the server remains consistent. 

For example, if you create a new Pick List object in the Pick List project and reference that object 
in your Oppty project, check in both projects to the server at the same time.

■ Consider the timing of your check-in and its effect on the work of other developers.

CAUTION: Depending on the size of the project, the check-in process might require some time. Do 
not interrupt the process, because doing so can leave your repository in an unstable state. If for any 
reason the check-in process is interrupted, you must perform it again to complete any unfinished 
tasks and unlock the projects on the server.

About the Project Check Out Dialog Box
The Check Out dialog box lists projects available for check out. It does not list individual objects 
within projects. Figure 13 shows an example of the Project Check Out dialog box. 

Figure 13. Example Check Out Dialog Box
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Table 23 describes each user interface element of the dialog box.

Table 23. Project Check Out Dialog Box User Interface Elements

Element Description

Repository drop-down list Displays the repositories on the server. The list of projects in 
the projects list reflects the list of projects in the selected 
server repository. If you select a different server repository 
from the one currently open in Siebel Tools locally, a warning 
appears, and you must either get all projects or change the 
repository selection.

Projects list Project Displays the name of each project in the server repository.

Updated A value of Yes appears if the server Locked By and Locked 
Date are different from the client version, indicating that your 
version of the project is out of sync with the server’s version.

Server Locked By Logon ID of the developer who currently has this project 
checked out on the server.

Server Locked 
Date

Date of check out.

Client Locked By Logon ID of the developer who currently has this project 
locked locally.

Client Language The language of the project currently locked on the client. 
Only one language can be locked at one time.

Allow Object 
Locking

A value of Yes appears if the project allows object check-in/
out. The default value is Yes. If you want to restrict object 
check out, see “Enabling Object Check Out and Check In” on 
page 88.

Owner Branch Displays the owner branch for each project. If the project's 
Owner Branch is not blank, the user's assigned Repository 
Branch must match in order to check out the project or any 
of its objects.

This column is hidden in the Object List Editor by default, but 
you can display it by right-clicking the Columns Displayed 
menu option. 
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Columns Displayed can be grayed out. Modes of Applet Web templates determine the kind of actions 
available in applets to users. The mode also determines which buttons appear in Web templates. For 
example, the Edit button appears in applets set to the Edit mode, but this button does not appear in 
applets set to Base (Read Only) mode.

Option 
buttons

Selected projects When this option button is selected, you can select individual 
projects to check out or get.

All projects When this option button is checked, all projects in the 
repository are selected to check out or get.

Updated projects When this option button is active, only projects with an 
Updated value of Yes are selected. This allows you to check 
out or get only those projects on the server that are new or 
different from corresponding projects in the local repository. 
Normally you perform a Get to bring your local repository up 
to date.

Get locale 
specific data 
only check 
box

Checking this box gets string translations and locale-specific 
attributes being stored in the locale objects only. It does not 
get data stored in the locale object’s parent object.

Buttons Get Selected projects are copied to the local repository, replacing 
pre-existing versions there, but not locking them on the 
server. You can get any projects on the server, including those 
locked by others.

Check Out Copies all objects in the selected projects to the local 
repository and locks them on the server (and client). 

You cannot check out projects that are currently locked on the 
server by another user. 

Options Opens the Development Tools Options dialog box with the 
Check In/Out tab selected. This is the same dialog box that 
appears when you choose Tools > Options. 

Cancel Cancels the check out and closes the Check Out dialog box.

Table 23. Project Check Out Dialog Box User Interface Elements

Element Description
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About the Object Check Out Dialog Box
The Object Check Out Dialog Box allows you to check out individual objects from the server database. 
Figure 14 shows an example of the Object Check Out dialog box.

Table 24 describes the user interface elements of the Object Check Out Dialog Box.

Figure 14. Object Check Out Dialog Box

Table 24. Object Check Out Dialog Box User Interface Elements

Element Description

Repository Text Box Displays the name of the current repository the user is 
working on.
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Object List Type Displays the type of each new or checked out object in the 
local repository. Objects obtained by the get process are not 
listed, because these are not available for check in. (You can 
check in only projects that you have previously checked out 
or created locally.)

Name Displays the name of each object being checked out.

Updated A value of Yes appears if the server Locked By and Locked 
Date are different from the client version, indicating that your 
version of the object is out of sync with the server's version.

Object Locking A value of Yes appears if this object's parent project allows 
object check-in/out. 

Server Locked By Logon ID of the developer who currently has this object 
checked out on the server.

Server Language The language on which the object is checked out on the 
server. Only one language can be checked out at one time.

Server Locked 
Date

Date of check out.

Client Locked By Logon ID of the developer who currently has this object 
locked locally.

Client Language The language of the object currently locked on the client. 
Only one language can be locked at one time.

Project Locked By Logon ID of the developer who currently has this object's 
parent project checked out on the server.

“Get locale specific data only” 
checkbox

Checking this box gets string translations and locale-specific 
attributes being stored in the locale objects only for the 
objects selected. It does not get data stored in the locale 
object's parent object.

Table 24. Object Check Out Dialog Box User Interface Elements

Element Description
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About the Check In Dialog Box
The Check In dialog box allows you to select projects or objects to check in to the server database. 
Figure 15 shows an example of the Check In dialog box. 

Buttons Get Selected objects are copied to the local repository, replacing 
pre-existing versions there, but not locking them on the 
server. You can get any objects on the server, including those 
locked by others regardless of whether their parent projects 
have the Allow Object Locking field checked.

Check Out Copies all selected objects in the selected objects to the local 
repository and locks them on the server and client.

You cannot check out objects that are currently locked on the 
server by another user, because either their parent projects 
do not allow object locking or their parent projects are locked 
on the server.

Options Opens the Development Tools Options dialog box with the 
Check In/Out tab selected. This is the same dialog box that 
appears when you choose Tools > Options.

Cancel Cancels the check out, and closes the Object Check Out 
dialog box.

Figure 15. Example Check In Dialog Box

Table 24. Object Check Out Dialog Box User Interface Elements

Element Description
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Table 25 describes each user interface element of the dialog box.

Table 25. Check In Dialog Box User Interface Elements

Element Description

Repository drop-down list Lists repositories in the local database. The list of projects in 
the Projects list reflects the list of projects in the selected 
repository (in addition to locally created projects). 

Projects list Type Displays the type of each new or checked out project or object 
in the local repository. Projects or objects obtained by the get 
process are not listed, because these are not available for 
check in. (You can check in only projects that you have 
previously checked out or created locally.)

Name Name of the checked out object.

Status Contains the value New or Locked for each project, or object 
indicating whether you created it yourself or obtained it 
through check-out.

Lock/Creation 
Date

Displays the date and time when you created the project or 
object, or checked the project or object out from the server.

Language Displays the language in which the project or object was 
checked out.

Option 
buttons

Selected Objects When this option button is checked, you can manually select 
individual projects or objects to check in.

Locked/New 
Objects

Selects all of the projects or objects in the list—that is, all 
those you have created or obtained through check-out.

Maintain lock check box Does not remove object locks on the server or the local 
databases after check in.

Buttons Undo Check Out Does not check in objects to the server. This releases the lock 
on the server, so that another developer can work on those 
objects, but retains the locks on the local database.

Validate Validates selected projects.

Check In Initiates the check-in process.

Diff Opens the Project Differences dialog box that allows you to 
compare the objects you are checking in with the server 
versions of those objects. For more information, see “About 
Validating Objects” on page 104.

Options Opens the Developer Tools Options dialog box where you 
specify check-in/check-out settings, especially server and 
client data source names.

Cancel Closes the Check In dialog box.
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Checking Out and Checking In Projects
This topic contains the following tasks:

■ “Checking Out Projects from the Server Repository” on page 86

■ “Checking In Projects to the Server Repository” on page 87

For information on checking out individual objects, see “About the Object Check Out Dialog Box” on 
page 82.

Checking Out Projects from the Server 
Repository
When you check out projects from the server repository, the following occurs:

■ All objects associated with the projects are locked on the server, preventing other developers 
from checking them out.

■ All objects associated with the projects are copied from the server database to your local 
database.

■ All objects associated with the projects are locked on your local database, allowing you to edit 
them. 

NOTE: If the Allow Object Locking property is set to TRUE, you cannot check out a project from the 
server. You must disable object locking to check out a project from the server.

To check out projects from the server repository

1 Choose Tools > Check Out.

2 In the Check Out dialog box, make sure that the correct repository is selected. 

3 Select the projects you want to check out, then click Options.

4 In the Development Tools Options dialog box, make sure the Server and Client data sources are 
specified correctly. 

5 Click OK.

The Development Tools Options dialog box closes.

6 In the Check Out dialog box, click Check Out.

Objects are checked out of the server database and stored in your local database.

Related Topics
“Guidelines for Check Out and Check In” on page 78

“About the Project Check Out Dialog Box” on page 79

“Setting Options for Check Out and Check In” on page 78
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Checking In Projects to the Server 
Repository
When you check in projects, the following actions occur:

■ Projects and their associated objects are copied from your local repository to the server 
repository, replacing those on the server.

■ Any new objects are added to the server repository.

■ Locks on the projects and all associated objects are removed.

To check in projects to the server repository

1 Choose Tools > Check In.

2 In the Check In dialog box, make sure that the correct repository is selected.

3 Click Options. 

4 In the Development Tools Options dialog box, make sure the server and client Data Sources are 
are correct and then click OK.

5 Do one of the following:

■ To check in selected projects, click the Selected Objects option, and then select the projects 
that you want to check in.

■ To check in all locked projects (new and modified), click the Locked/New Objects option.

6 Click Check In.

The selected projects and associated objects are copied from your local repository to the server 
repository and locks are removed.

Related Topics
“Guidelines for Check Out and Check In” on page 78

“About the Check In Dialog Box” on page 84

“Setting Options for Check Out and Check In” on page 78

Checking Out and Checking In Objects
This topic contains the following tasks:

■ “About Object Check Out and Check In” on page 88

■ “Enabling Object Check Out and Check In” on page 88

■ “Setting Projects to Allow Object Locking” on page 88

■ “Checking Out Objects from the Server Repository” on page 89

■ “Checking In Objects to the Server Repository” on page 90
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Check In
■ “Viewing Locked Objects Within Projects” on page 90

■ “Locking Objects Locally” on page 91

■ “Limitations of Object Check Out and Check In” on page 91

About Object Check Out and Check In
With object check out and check in, you can check out and check in only the objects that you need; 
that is, you do not have to check out and check in entire projects.

NOTE: If the Allow Object Locking property is set to TRUE, you cannot check out a project from the 
server. You must set the Allow Object Locking property to FALSE to check out an entire project from 
the server.

Checking out and checking in selected objects:

■ Allows multiple developers to work on objects within a single project

■ Improves check-out and check-in times

■ Reduces network traffic

Enabling Object Check Out and Check In
A configuration file parameter controls whether or not object check out and check in is enabled. To 
enable object check out and check in, add the following parameter to the [Siebel] section of the 
tools.cfg file, and set it to TRUE:

EnableObjectCOCI=TRUE 

NOTE: EnableObjectCOCI is set to TRUE by default.

Setting Projects to Allow Object Locking
For each project you can specify whether or not developers are allowed to check out and check in 
individual objects within the project. To allow developers to check out and check in objects, you set 
the project's Allow Object Locking property to TRUE. To modify the Allow Object Locking property, 
you must use the SADMIN user ID to log in, and you must be logged into a server data source. You 
cannot set the Allow Object Locking property in your local repository.

To set the Allow Object Locking property

1 In the Object Explorer, choose Project.

2 In the Projects window, choose the desired Project object type, then right-click, and choose 
Toggle Allow Object Locking. 
Using Siebel Tools Version 7.8, Rev. B88 



Checking Out and Checking In Projects and Objects ■ Checking Out Objects from the
Server Repository
NOTE: You can only change the Allow Object Locking flag on the Server database using the 
SADMIN login ID.

If a project has the Allow Object Locking configuration file parameter set to TRUE, and the user 
is logged in to the server using the SADMIN user ID, the Toggle Allow Object Locking menu option 
is enabled. When the SADMIN user chooses this option for a project that is already set to allow 
object locking, a check is performed to determine whether any objects are locked on the server 
within the project. If there are objects locked within the project, SADMIN will receive an error 
message. If the project is locked on the server by someone else, the menu option for Toggle Allow 
Object Locking will not appear. 

Checking Out Objects from the Server 
Repository
When the Allow Object Locking property is set to TRUE, you can check out individual objects within 
the project. When you check out individual objects, the objects are:

■ Locked on the server, preventing other developers from checking them out

■ Copied from the server database to your local database

■ Locked on your local database, allowing you to edit them

NOTE: You can check out top-level objects only. 

To check out objects from the server repository

1 Open Siebel Tools, and connect to your local database.

2 In the Object Explorer, navigate to the object type you want to check out.

3 In the Object List Editor, select the object definition, and then right-click and choose Check Out. 

The Check Out Object dialog box appears. 

NOTE: If another developer has the objects checked out or if the parent project has the Allow 
Object Locking property set to FALSE, the Check Out button is disabled. 

4 In the Check Out Object dialog box, select the objects to check out.

5 Click Check Out. 

The object and all its child objects are locked on the server and then copied to your local 
repository.
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Checking In Objects to the Server 
Repository
You check in objects to the server repository the same way you check in projects. When you check 
in objects or projects, Siebel Tools does the following:

■ Copies object definitions from your local repository to the server repository

■ Adds any new objects to the server repository

■ Removes the locks from object definitions

To check in projects or individual objects to the server repository

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check In.

3 In the Check In dialog box, make sure that the correct repository is selected.

4 Do one of the following:

■ To check in selected projects or objects, click the Selected Objects option button and then 
select the projects and objects you want to check in.

■ To check in all locked projects and objects, click the Locked/New Objects option button.

5 Click Check In.

Siebel Tools copies the projects and objects from your local repository to the server repository 
and removes the locks.

Viewing Locked Objects Within Projects
When the Allow Object Locking property of a project is set to TRUE, you can view any objects within 
the project that are locked. You can view locked objects in either the server repository or the local 
repository. 

To view locked objects

1 In the Object Explorer, navigate to the Project object type.

2 In the Object List Editor, select the project that contains the objects to view.

3 Right-click and choose one of the following:

■ View Server Locked Objects

■ View Client Locked Objects

The Locked Objects dialog box displays any locked objects associated with the selected project.
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Locking Objects Locally
When a project's Allow Object Locking is set to TRUE, you can lock individual objects within the 
project in your local repository without having to check them out from the server.

To lock objects locally
■ Select the object, right-click, and then choose Lock Object.

Limitations of Object Check Out and 
Check In
When a project’s Allows Object Locking property is set to TRUE, you cannot perform the following 
tasks on objects checked out from the server repository:

■ Deleting objects

■ Renaming objects

■ Assigning objects to a different project

Viewing Object Differences
Before you check in objects, you can compare the copies stored in your local database to those stored 
in the server database. Siebel Tools compares the current state of the objects with the version of 
these objects at the time of checkout.

To view differences between objects

1 Choose Tools > Check In.

2 In the Check In dialog box, select the project you want to compare.

3 Click Diff.

The Object Comparison dialog box appears and displays the selected projects and any differences 
between objects in the local database and objects in the server database.

Undoing Check Out
After checking out projects you can undo the check out, which does the following:

■ Removes locks on server objects.

■ Objects in the local repository remain locked, and all changes since the objects were checked out 
are retained.
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To undo a project check out

1 Choose Tools > Check In.

2 In the Check In dialog box, select the project or objects for which you want to undo check-out, 
and click the Undo Check Out button.

The project or object is unlocked on the server, but not on your local database.

If one of the projects or objects you select is new, the Undo Check Out button is disabled.

You can also use the Get option to: 

■ Overwrite a project that you have checked out from the server database. 

■ Check that project back in to the server to remove the lock for the project.

■ Enable expected projects for Object Check-in/Check-out.

Related Topic
“Getting Projects from the Server Repository” on page 74
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This chapter describes how to work with projects. It contains the following topics:

■ “About Projects” on page 93

■ “Creating New Projects” on page 94

■ “Renaming Projects” on page 94

■ “Associating Objects with Different Projects” on page 95

■ “Locking Projects Directly in the Local Repository” on page 95

■ “Preventing Object Check In and Check Out” on page 96

■ “Unlocking Projects Directly” on page 96

About Projects
Projects are sets of objects that reside in the Siebel repository. They are used group objects based 
on functional areas. Every object is associated with a project. The names of projects that are 
delivered with a standard Siebel application indicate the functional area with which they are 
associated. For example, Account contains objects that pertain to the Account functional area.

A project named without a suffix, such as Account, usually contains business object layer objects 
that span multiple Siebel applications. Project names that have a suffix (for example, Account (SSE)) 
contain user interface or business objects that are specific to the Siebel application indicated by the 
suffix. For example, the suffix SSE in Account (SSE) indicates an entry containing Account user 
interface data for Oracle’s Siebel Sales application. Other examples of suffixes indicating user 
interface data only are SSV for Oracle’s Siebel Service and CC for Oracle’s Siebel Call Center.

The project structure supplied with the Siebel repository is usually well suited to having several 
developers work on the same repository without contention for the same objects. However, when 
developers need access to the same set of objects simultaneously, changing the standard project 
structure may be necessary.

■ Create an application development plan that includes a PERT chart showing dependencies and 
parallel activities.

■ Analyze the plan to see if the project structure interferes with developers who need access to 
objects in the same projects at the same time. If so, break out groups of objects into separate 
projects to enable concurrent development. Alternatively, for projects that are expected to be in 
contention, enable those projects for Object Check-in/Check-out.
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Creating New Projects
You typically create new projects to group related sets of new objects or to break large numbers of 
existing objects into more manageable groups.

If you intend to implement a new project on the server repository, follow this development process:

■ First create the new project on the development server repository. 

■ Perform a Get of the project to the local repository.

■ Check out the project.

■ Modify the new project on the local repository.

■ Check in the project to update the server repository. 

To create a new project

1 In the Object Explorer, select the Project object type.

2 In the Object List Editor, right-click and choose New Record.

3 Enter a Name for the project and then step off the record.

For information on performing a Get, see Chapter 4, “Getting Projects from the Server Repository.”

For information on project check in and check out, see Chapter 5, “Checking Out and Checking In 
Projects and Objects.”

NOTE: You cannot delete projects using Siebel Tools, but you can delete projects using SQL 
commands.

Renaming Projects
You can rename projects that you have created. However, you must rename the projects on the 
server, not on the local database. You cannot change the name of a top-level object that has been 
checked out.

CAUTION: Do not change the name of projects to which Siebel objects are associated.

To rename a project on the server

1 Make sure developers have checked in all checked-out projects.

2 Use Siebel Tools to log into the server database.

3 Choose File > Open Repository, and then select the repository you want to modify.

4 Navigate to the project you want to modify.

5 Lock the project, and then change the Name property.

6 Have developers perform a Get of all projects on the server repository.

7 Have developers perform a full compilation the next time they compile.
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Associating Objects with Different 
Projects
You can associate objects with different projects. This can be useful, for example, when you want to 
break a large project into smaller projects.

To associate an object with a different project

1 Check out both the source and the target project from the server database.

For instructions on how to check out projects, see “Checking Out and Checking In Projects” on 
page 86.

2 Navigate to the object you want to modify and then change the Project property to the name of 
the new project.

For instructions on how to modify objects, see “Modifying Objects” on page 102.

3 Check in the project that was originally associated with the object and then check in the project 
that is currently associated with the object.

CAUTION: Trying to check in both projects at the same time can lead to errors.

For instructions on how to check in projects, see “Checking In Projects to the Server Repository” 
on page 87.

4 Inform other developers that they must do a simultaneous get of the two projects prior to doing 
any subsequent work on the object in either project.

Locking Projects Directly in the Local 
Repository
You can lock projects directly in the local repository, without checking them out from the server. This 
is useful when:

■ You want to test configurations on your local machine, but do not want to prevent others from 
checking out the project from the server database.

■ You intend to discard your work when you are done and therefore, do not have a need to check 
modified objects back into the server.

When locking projects directly in the local repository, consider the following:

■ You cannot check in projects or objects that have been locked on the local database. Projects 
must have been checked out from the server for them to be checked in to the server.

■ Any projects you have locked locally, and all associated objects, will be overwritten the next time 
you get or check out those projects. 
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To lock projects directly

1 Log in to your local database.

2 Do one of the following:

■ Select an object, such as an applet or business component, and then choose Tools > Lock 
Project.

■ Navigate to the project that contains the objects that you want to modify, and click the 
Locked field to set it to TRUE.

All objects associated with the project become available for editing, indicated by a pencil icon 
that appears under the W field, and the Locked property of the project object is set to TRUE.

Preventing Object Check In and Check 
Out
You can prevent developers from checking out and checking in projects by locking the project directly 
on the server repository.

CAUTION: Modifying objects directly on the server repository for purposes other than preventing 
check in and check out is not recommended.

To lock projects directly

1 Log in to the server database.

2 Do one of the following:

■ Select an object, such as an applet or business component, and then choose Tools > Lock 
Project.

■ Navigate to the project that contains the objects that you want to modify, and click the 
Locked field to set it to TRUE.

The project and all objects associated with project are locked. They cannot be checked out.

Unlocking Projects Directly
After you have locked projects directly (without checking them out), you can remove the locks on all 
associated objects by unlocking the projects.

To unlock projects

1 Log in to either the local database or server database, depending on where the locked objects 
reside.
Using Siebel Tools Version 7.8, Rev. B96 



Working with Projects ■ Unlocking Projects Directly
2 Do one of the following:

■ Select the object you want to unlock, and then choose Tools > Unlock Project.

■ Navigate to the project that contains the objects that you want unlock, and then click the 
Locked field to clear the check mark (sets Locked to FALSE).

The locks are removed from the project and all objects associated with the project.
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7 Working with Objects
This chapter describes how to work with objects. It contains the following topics:

■ “Summary of Tasks for Working with Objects” on page 99

■ “Creating Objects” on page 101

■ “Modifying Objects” on page 102

■ “Copying Objects” on page 103

■ “Deleting Objects” on page 103

■ “About Validating Objects” on page 104

■ “Validating Objects Using the Object List Editor” on page 104

■ “Validating Objects Using the Command-Line Interface” on page 105

■ “About the Validate Dialog Box” on page 105

■ “About the Validation Options Dialog Box” on page 107

■ “Using Queries to List Objects” on page 110

■ “About Simple Queries” on page 111

■ “About Compound Queries” on page 111

■ “Searching the Repository for Objects” on page 112

■ “Viewing Object Relationships” on page 114

■ “Generating Reports About Object Relationships” on page 115

■ “About Object Comparison and Synchronization” on page 117

■ “Determining When Records Were Last Created and Updated” on page 121

Summary of Tasks for Working with 
Objects
The process of working with objects varies depending on whether the Allow Object Locking property 
of the parent project is set to TRUE or FALSE. When the property is set to FALSE, you must check 
out the entire project to edit any object definitions within the project. However, if the Allow Object 
Locking property is set to TRUE, you can check out some of the objects in a project, and leave other 
objects unlocked on the server, which are available for other developers to check out. For more 
information on setting this property, see “Setting Projects to Allow Object Locking” on page 88.

Table 26 summarizes the differences for processes, such as create, copy, and modify.
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Links to Tasks for Working with Objects

The following list links to the summarized tasks listed in Table 26:

Table 26. Summary of Processes for Working with Objects

Task Allow Object Locking = False Allow Object Locking = True

Create 
object

1. Check out the project.

2. Create the new object.

3. Check in the project.

1. Lock the project locally.

2. Create the new object.

3. Unlock the project.

4. Check in the object.

Modify 
object

1. Check out the project.

2. Modify the object.

3. Check in the project.

1. Check out the object.

2. Modify the object.

3. Check in the object.

Create new 
object by 
copying an 
existing one

1. Check out projects.

2. Copy the object, and create a new 
one.

3. Check in projects.

1. Check out the object to copy.

2. Lock the object’s parent project locally.

3. Copy the object and assign the project.

This refers to the same project locked in 
step 2, or to a different project that has 
the Allow Object Locking property set to 
TRUE. 

4. Unlock the project locally.

5. Lock the new object locally.

6. Check in the object to the server 
repository.

Delete 
object

1. Check out project.

2. Delete object.

3. Check in project.

Cannot perform. The Allow Object Locking 
property must be set to FALSE.

Rename 
object

1. Check out the project.

2. Rename the object.

3. Check in the project.

Cannot perform. The Allow Object Locking 
property must be set to FALSE.

Assign 
object to 
different 
project

1. Check out Project (source and 
target).

2. Associate object with target project.

3. Check in source first, and target 
second.

Cannot perform. The Allow Object Locking 
property must be set to FALSE.
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■ “Checking Out and Checking In Projects” on page 86

■ “Checking Out and Checking In Objects” on page 87

■ “Locking Projects Directly in the Local Repository” on page 95

■ “Creating Objects” on page 101

■ “Modifying Objects” on page 102

■ “Copying Objects” on page 103

■ Chapter 9, “Compiling and Testing”

■ If you checked out the projects from the server, perform the task described in “Checking In 
Projects to the Server Repository” on page 87.

■ If you locked the project directly, perform the task described in “Unlocking Projects Directly” on 
page 96.

Creating Objects
Use new object wizards to create objects whenever possible. For example, to create a new business 
component, use the Business Component Wizard. 

Wizards step you through the process of configuring a given object, prompting you for the necessary 
property values and automatically configuring any necessary child objects.

When a wizard is not available for the object type you want to create, you can create objects 
manually in the Object List Editor.

For information about using wizards and creating specific objects, see Configuring Siebel Business 
Applications.

To create objects using a new object wizard

1 Choose File > New Object.

2 Choose the appropriate wizard to create the new object.

3 Follow the instructions in the wizard.

To create a new object manually

1 In the Object Explorer, select the relevant object type.

The Object List Editor opens, listing objects of this object type.

2 To make the Object list Editor active, click it. 

3 Choose Edit > New Record, or right-click and choose New Record.

A new record appears.
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4 Enter property values in the new row in the Object List Editor.

At a minimum, you must enter the object’s Name and Project properties.
Typically, other properties are also required. Before you can save the new objects, you must 
complete the required properties.

NOTE: You cannot use punctuation characters as part of an object name.

5 Click anywhere outside the new row or move outside of the row with the UP or DOWN arrow keys.

Siebel Tools saves the new object.

Modifying Objects
You can modify objects using either the Object List Editor or the Properties window.

For guidelines about when to modify objects and when to create new objects, see Configuring Siebel 
Business Applications.

To modify objects in the Object List Editor

1 In the Object Explorer, select the object type you want to modify.

2 In the Object List Editor, select the object you want to modify.

3 Use the TAB key to move the cursor to the specific value you want to modify.

NOTE: It is recommended that you use the TAB key to move from property column to property 
column in the object—if you use the mouse you might unintentionally change the value of a 
Boolean property.

4 Type in a new value, or pick a value from the pick list (if one is provided).

5 To commit your changes, click anywhere outside the modified row or move outside the row with 
the UP or DOWN arrow.

A check mark appears in the Changed column.

To modify objects using the Properties window

1 In the Object Explorer, select the object type you want to modify.

2 In the Object List Editor, select the object you want to modify.

3 Choose View > Windows > Properties to open the Properties window.

4 In the Properties window, select the current value, and then type in a new one.

5 To commit your changes, select another property or click anywhere outside the Properties 
window.

A check mark appears in the Changed column in the Object List Editor.
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Copying Objects
One method of creating an object is to copy an existing object, and then rename and change 
properties of the copy as necessary.

For guidelines on copying objects and more information on the Upgrade Ancestor property, see 
Configuring Siebel Business Applications.

To create new objects by copying existing objects

1 In the Object Explorer, select the relevant object type.

2 In the Object List Editor, locate the object to copy, and click anywhere in the row to select it.

3 Choose Edit > Copy Record. 

A new row appears above the copied row, containing identical property values. The Changed 
column contains a check mark.

4 Enter a new value for the Name property.

5 In the Project field, click the drop-down arrow. 

The Projects pick list appears.

6 Choose the name of the project to which to assign the new object.

NOTE: Only locked projects are displayed in the Projects pick list.

7 If necessary, modify any other relevant properties and child objects.

8 To commit your changes, click anywhere outside the new row or move outside the row with the 
UP or DOWN arrow keys.

Deleting Objects
Occasionally, you will want to delete an object from a project. To delete an object, you must have 
the Allow Object Locking property set to FALSE. 

To delete objects

1 Check out the Project from the server.

2 In the Object Explorer, select the desired object.

3 From the Edit menu, select Delete Record. 
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About Validating Objects
As you modify or create objects, you must also validate their definitions. Validating objects is one of 
the first things you must do if a configuration change produces a run-time error. Although the 
validation process can be time consuming, you can continue working in Siebel Tools while the 
validation is running.

Validation is based on a set of rules that help make sure that your configuration changes are logically 
consistent with other objects. Validating a parent object validates child objects as well. 

There are many rules used to validate objects. The rule that checks for invalid object references is 
the most important. An invalid object reference occurs when one object (for example, an applet) 
references another object (for example, a business component) that has been inactivated or deleted. 
You can review all validation rules in the Validation Options dialog box.

Related Topics
“Validating Objects Using the Object List Editor” on page 104

“Validating Objects Using the Command-Line Interface” on page 105

“About the Validate Dialog Box” on page 105

“About the Validation Options Dialog Box” on page 107

Validating Objects Using the Object List 
Editor
Siebel Tools includes an option that reviews objects and validates them using a set of predefined 
rules, such as checking for invalid object references.

To validate an object

1 In the Object List Editor, select the object or objects you want to validate.

2 Right-click and then choose Validate, or choose Tools > Validate Object.

The Validate dialog box appears. 

3 Click Options.

The Validation Options dialog box appears. 

4 Select the validation rules to enforce by selecting a row and clicking Enforce or Ignore.

5 In the Time Filter area, limit the objects you want to validate by doing one of the following:

■ Select the Last validated check box. This option validates objects that have been changed 
since the last time validation was run.

■ Select the Custom check box and enter a date and time. This option validates objects that 
have been changed since the date and time were entered.
Using Siebel Tools Version 7.8, Rev. B104 



Working with Objects ■ Validating Objects Using the Command-Line Interface
6 In the Action area, use the following check boxes to define the actions to take during the 
validation process:

■ Do not report warnings. When this is selected, only errors are reported, not warnings. The 
Enforce field for warnings is set to No. 

■ Abort validation after. Use this option to abort the validation process after a specified number 
of errors.

7 Click OK.

The Validation Options dialog closes.

8 In the Validate dialog box, click Start.

The Errors list displays violations of the currently enforced rules, as shown in Figure 16 on 
page 106. 

Related Topic
“About Validating Objects” on page 104

“About the Validate Dialog Box” on page 105

“About the Validation Options Dialog Box” on page 107

Validating Objects Using the Command-
Line Interface
You can use the command-line interface to validate objects. You invoke the command-line interface 
from the siebdev executable, using the command switch /bv. The executable file siebdev.exe is 
located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation directory.

The syntax of the /bv switch is:

siebdev.exe /bv

The /bv switch runs all validation rules for the entire repository.

About the Validate Dialog Box
The Validate dialog box describes the results of validation rules applied to objects and shows the 
location of the validation log file.
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Figure 16 shows an example of the Validate dialog box. 

Table 27 describes the user interface elements of the Errors area of the Validate dialog box.

Figure 16. Example of the Validate Dialog Box

Table 27. User Interface Elements of the Errors Area of the Validate Dialog Box

Field/
Button Description

Errors list Displays the results of the validation process. Each row in the list identifies a rule 
violation for a specific object. To drill down on the object that contains the error, 
double click the error. To sort the rows, click a column heading. To resize columns, 
drag the right or left border of the heading cell. 

Severity 
column

An icon appears in this column for each violation row. It indicates whether the 
violation is a warning (yellow icon with an exclamation mark) or an error (red icon 
with a minus sign). Errors cause the compiled application to generate run-time 
errors.

Rule column An integer value appears in this column, identifying the rule that has been violated. 
Rules are listed in order of the rule number in the Validation Options dialog box 
(shown in Figure 16 on page 106).

Object 
column

The name of the object that failed validation.
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Table 28 describes the user interface elements of the Log file area of the Validate dialog box.

About the Validation Options Dialog Box
The Validation Options Dialog box appears when you click the Options button in the Validate dialog 
box.

Description 
column

The description of the error or warning.

Details text 
box

Displays additional information about the error or warning message for the 
currently selected row in the Errors list.

Go To button To navigate to the corresponding object in the Object List Editor, select an error 
message row and click Go To. Alternatively, you can double-click the error 
message.

Table 28. User Interface Elements of the Log file Area of the Validate Dialog Box

Field/
Button Description

Text box Path and filename of a log file containing the list of validation errors and warnings. 
To save a list of validation rows as a log file, click Save As, navigate to where you 
want to save the file, and then specify a filename. You can then reload the list of 
error and warning validations at a later time by using the Load button, rather than 
by repeating the validation process.

Load button Opens a previously saved log file and displays its list of validations in the Errors list.

Save As 
button

Saves the current list of validation rows as a log file. 

Table 27. User Interface Elements of the Errors Area of the Validate Dialog Box

Field/
Button Description
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Figure 17 shows an example of the Validation Options dialog box. 

Table 29 describes each user interface element of the Rules area of the Validation Options dialog box. 
The repository Validator must be used only in conjunction with the Time Filter, to avoid validating 
objects that are not being used. 

Figure 17. Validation Options Dialog Box

Table 29. User Interface Elements of the Rules Area of the Validation Options Dialog Box

Field/Button Description

Rules list Lists all rules that can be enforced during validation. Each row in the list 
identifies a rule for a specific object type (or All). You can sort the rows by 
by clicking a column heading. You can also resize columns by dragging the 
right or left border of the heading cell. 

Severity column An icon appears in this list column for each rule. It indicates whether the 
rule generates a warning (yellow icon with an exclamation point) or an error 
(red icon with a minus sign). 

Rule column The integer value that identifies this rule.

Object columns Either the single object type that this rule applies to, or All.

Description column The description of the rule. 

Enforce A Yes or No value for each rule. Yes validates all objects of the object type 
identified in the Object column. Yes/No values in this list column are 
changed using the Enforce, Ignore, Enforce All, and Ignore All buttons.
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Table 30 describes the Time Filters area of the Validation Options dialog box.

Table 31 describes the check boxes in the Action area of the Validation Options dialog box.

Save button Saves the current set of rules and their state (enforced or ignored) to a text 
file you specify. Other settings are saved to the preferences file when you 
press ENTER.

Enforce button Changes the Enforce column value in the selected row from No to Yes.

Ignore button Changes the Enforce column value in the selected row from Yes to No.

Enforce All button Changes all values in the Enforce column to Yes. 

Ignore All button Changes all values in the Enforce column to No. This has the effect in the 
next validation of not validating any objects.

Details text box The full text of the rule description for the currently selected row in the 
Rules list.

Table 30. User Interface Elements of the Time Filter Area of the Validation Options Dialog Box

Field Description

Last validated check 
box and date field

When selected, validates only objects changed since the date you enter into 
the corresponding date box.

Custom check box 
and date and time 
fields

When selected, validates only objects changed within the date range you 
enter into the corresponding date boxes.

Table 31. User Interface Elements of the Action Area of the Validation Options Dialog Box

Field Description

Do not report 
warnings check box

When selected, reports errors only, not warnings. It also changes the 
Enforced setting of all warning rules to No.

Abort validation 
after check box and 
text box

When selected and a number is entered in the text box, Siebel Tools stops 
validating after the specified number of errors is reached. By default, the 
validation process continues to run until it is completed or canceled.

Table 29. User Interface Elements of the Rules Area of the Validation Options Dialog Box

Field/Button Description
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Using Queries to List Objects
You can use query-by-example (QBE) to narrow the list of objects displayed in the Object List Editor. 
An Object List Editor query searches for objects based on values in one or more properties of the 
object. The queries can be simple, one-condition queries or compound, multiple-condition queries. 
You can create, refine, and activate queries from the Query menu or from the List toolbar. (Refine 
means to impose a further restriction on the current Object List Editor query by running it again with 
an additional constraint.)

To create and execute an Object List Editor query

1 Navigate to the list of objects that you want to query.

2 Choose Query > New Query.

In the Object List Editor, a single empty query row appears.

3 Define your search criteria in the property cells of the empty query row. 

These values may be single literal values such as Opportunity List Applet, or they may include 
wildcard symbols. In TRUE/FALSE properties, a check mark represents TRUE. 

4 Choose Query > Execute Query.

The list of objects in the Object List Editor is filtered to contain only those objects that meet your 
query criteria.

To restore the Object List Editor to its prequery state

1 Choose Query > New Query.

In the Object List Editor, a single empty query row appears.

2 Choose Query > Execute Query.

The list of objects in the Object List Editor is restored to its prequery state.

Related Topics
“About Simple Queries” on page 111

“About Compound Queries” on page 111
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About Simple Queries
A simple query finds information based on one condition. Table 32 lists the operators you can use to 
create a simple query. 

For more information on search specifications and operators and on Siebel data types, see Siebel 
Developer’s Reference.

About Compound Queries
Compound queries enable you to find information based on two or more conditions. There are three 
ways to create compound queries: 

■ Enter conditions in two or more property columns to find records that meet all the conditions. In 
other words, Siebel applications automatically connect these conditions with the operator AND. 
This method is the easiest way to create a compound query.

■ Enter a compound query within a property field using the operators OR, AND, and NOT to create 
two or more conditions for that property. 

Table 32. Simple Query Operators

Operator Description 

= Equal to 

< Less than 

> Greater than 

<> Not equal to 

<= Less than or equal to 

>= Greater than or equal to 

* Any number of characters (including none) may take the place of the asterisk (*)

? Any one character matches the question mark (?)

IS NOT NULL Searches for nonblank fields

IS NULL Searches for blank fields

LIKE Searches for values starting with the indicated string

NOT LIKE Searches for values not starting with the indicated string

“ ” Searches for strings that contain special characters, such as a comma (,) 

EXISTS ( ) Searches for values in a multi-value group

[~] Forces the case of the text string to whatever follows the tilde (~)
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■ Enter a compound query using more than one field and compound operators AND, OR, and NOT. 
You can enter this type of query in any field. You might find it convenient to use the Description 
or Comments field, because it is typically the longest on a given screen.

When you create a compound query, follow the same basic steps you use to create a simple query. 

Use parentheses to control the order in which a compound search is conducted. Expressions inside 
parentheses are searched for first (as they appear left to right). Table 33 lists the unique operators 
for compound queries. Use these operators in addition to the operators you use to create a simple 
query.

For more information about compound operators, see Siebel Developer’s Reference.

Searching the Repository for Objects
Use the search repository feature to search across all properties of multiple object types using a 
single set of search criteria. This provides a way to locate objects when you know that a given value 
appears in one or more properties. The search repository feature differs from querying in the Object 
List Editor, because when querying you can query only on a single object type and have to define 
search criteria for each property.

NOTE: Searching the repository can be time-consuming.

To find an object using search

1 Choose Tools > Search Repository.

The Search Repository dialog box appears.

2 Under Parameters, in the Search value text box, type the search criteria.

3 If you want only those objects whose property values contain the search string with the same 
capitalization, select the Case sensitive check box.

4 If you want only those objects whose property values exactly match the entire search string, 
select the Exact match check box.

Table 33. Compound Query Operators

Operator Description 

AND All the conditions connected by ANDs must be true for a search to retrieve a record. 

OR At least one of the conditions connected by the OR must be true for a search to 
retrieve a record. 

NOT The condition modified by this operator must be false for a search to retrieve a 
record.
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5 In the Types to search list box, select the object type or types to search for. 

By default, all object types in this list are selected. You can choose a single object type to search 
by selecting it. Use CTRL-click and SHIFT-click to select multiple object types. For better 
performance, search only the object type or types you need.

Use the Select All and Clear All to select or deselect all object types in the Types to search list box.

6 Click Search Now. 

Siebel Tools executes the search and lists the results in the list box at the bottom of the Search 
Repository dialog box. See Figure 18 on page 114 for an example. The list box lists all the objects 
that match your search criteria, with the following columns for each object.

7 To show it in the Object List Edit, double-click an item in the results. 

This has the same effect as running a query in the Object List Editor for the name of the object. 

8 To export the search results to a file, click the Export button.

To cancel a search
■ At any time during the execution of a search, click Cancel. 

Siebel Tools stops the search process. 

Column Description

Type Object type of the object returned by the search.

Name Name of the object returned by the search.

Property Name of the property of the object in which the search value was found.

Value Value of the property of the object in which the search value was found.
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Figure 18 shows an example of the Search Repository dialog box after a search execution.

Viewing Object Relationships
You can use the Siebel Tools Visualization views to see how objects relate to one another. 

To invoke the Visualization views using the View menu
■ Choose View > Visualize > View Details, View Relationships, View Descendents, or View Web 

Hierarchy.

To invoke the Visualization views from the Object List Editor
■ Right-click an object of the relevant object type in the Object List Editor, and choose the 

Visualization view you want. 

Not all Visualization views are listed for all objects.

Figure 18. Example of the Search Repository Dialog Box
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The Visualization views are described in Table 34.

Generating Reports About Object 
Relationships
You can generate reports about the relationships between certain object types in the repository. This 
section provides an introduction to using the reports facility; for more information, see Siebel 
Reports Administration Guide.

The list of records included in a repository report is not dependent on the currently selected object 
in the Object List Editor—for example, if you select the Contact business component in the Object 
List Editor and generate the business components and fields report, the report shows all business 
components, not just the Contact business component.

Generating Reports for a Single Object Type
To restrict a report to a single object type (that is, one business component, business object, dock 
object, table, or workflow object) run a query in the Object List Editor (for the parent object type) 
that restricts the list to the one object. 

The following example shows how to get the Tables report for S_ORG_EXT.

Table 34. Description of Visualization Views

View Description

Details Generates and displays a Details visualization view for the currently selected 
business component or business object.
The diagram displays how the business component maps to underlying tables 
(directly or through joins) and maps to other business components (through 
links).

Relationships Generates and displays a Relationships visualization view for the currently 
selected business component or table.
For business components, the diagram displays how the business component 
links to other business components using multi-value link objects. For tables, the 
diagram displays how the table joins to other tables by way of join objects.

Descendents Shows all objects which have the current object marked as their Upgrade 
Ancestor.

Web Hierarchy Generates and displays a Web Hierarchy visualization view for the currently 
selected applet, application, business component, screen, or view.
The diagram displays the parent-child relationships between the selected object 
and its parent and child objects, as well as the parents of the parent objects and 
children of the child objects, up and down the hierarchy.
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To get a Tables report for the S_ORG_EXT table (an example)

1 In the Object Explorer, select the Table object type.

2 In the Object List Editor, click anywhere to make it the active window.

3 Choose Query > New Query.

4 In the Name field, type S_ORG_EXT and press ENTER.

5 Choose Reports > Tables.

The generated report provides information only for the S_ORG_EXT table.

Generating Reports for Ranges of Objects
You can use a similar approach to restrict a report to a range of objects that have a property value 
in common. The report includes only those objects that match the current query criteria. For 
example, you can generate a Tables report of all extension tables, a business components report of 
all business components of a specific class, or any of the reports restricted to a single field.

Available Reports
The current object type in the Object Explorer determines the list of reports in the Reports menu. 
Repository reports are listed by current object type in Table 35.

Table 35. Reports Available for Each Object Type

Object Selected 
in Object 
Explorer Report Menu Option Description

Applet Applets by BusComp Lists the applets assigned to each business 
component. 

Business 
Component

Business Component and 
Fields

Lists the fields in each business component 
alphabetically. For each field, the base 
column and join table, if any, are identified.

Business Object Business Object and 
Components

Lists the business object components in 
each business object. For each business 
object component, the business component 
and link are identified.

Business Service Business Service Summary Lists a summary of all business services.

Business Service Detail Lists all business services with details.

Dock Objects Repository Dock Objects For each dock object, displays selected 
properties, and lists the member tables, 
visibility rules, and related dock objects.

Project Project List Lists all projects, and identifies the locking 
status, person locked by, and locked date for 
each.
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About Object Comparison and 
Synchronization
You can view a side-by-side comparison of any two objects of the same type. Differences are visually 
highlighted through color-coded icons. You can select and copy properties and individual child objects 
from one object to the other.

Using this feature, you can propagate a change made to an ancestor object to its descendents or 
other objects of a similar types. You can assess and adjust differences between objects. You can also 
compare properties of checked-out objects with their counterparts on the server.

For more information about ancestor objects, see Configuring Siebel Business Applications.

Topics in This Section
“About the Compare Objects Dialog Box” on page 118

“Comparing Objects” on page 119

“Synchronizing Objects” on page 121

Table Tables For each table, displays selected properties, 
and lists the columns. The name, physical 
type, length, scale, comments, and various 
other properties are identified for each 
column.

Workflow Policy 
Object

Workflow Policy Objects Lists the workflow components in each 
workflow object, and within each workflow 
component lists the columns.

Table 35. Reports Available for Each Object Type

Object Selected 
in Object 
Explorer Report Menu Option Description
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About the Compare Objects Dialog Box
To display a side-by-side comparison of any two objects of the same type, Siebel Tools uses the 
Compare Objects dialog box, shown in Figure 19.

Figure 19. Example of the Compare Objects Dialog Box
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Table 36 describes the user interface elements of the Compare Objects dialog box.

Comparing Objects
You can compare two objects of the same type. The Object Comparison dialog box displays a line-
by-line comparison between the two. You can compare objects defined in the current repository, in 
different repositories, and in archive (SIF) files.

Table 36. Compare Objects Dialog Box User Interface Elements

Field/Button/
Control Description

First Selection The explorer controls in the upper left and right area of the dialog box 
are similar to what you see after clicking the Detail tab of the Object 
Explorer. 

Both controls are always synchronized to show a line-by-line comparison 
between the objects. If you expand or collapse an object in one explorer 
control, its counterpart is automatically expanded or collapsed.

Child objects that do not exist in either object are represented with 
placeholders (a dashed line).

Second Selection

Properties By default, the properties shown in these list boxes are the properties 
that are different for the objects being compared. Which properties 
appear in these list boxes is determined by the settings in the Display 
area.

Display Determines which properties are shown in First Selection and Second 
Selection and in the Properties list boxes:

■ Show All Objects check box. Select to show all child objects in the 
First Selection. Second Selection box: select to show all user 
properties in the Properties list boxes.

■ Show System Properties check box. Select to show specific 
system properties such as Created, Created By, Updated, and 
Updated By in the Properties list boxes.

Use these two buttons to synchronize objects. See “Synchronizing 
Objects” on page 121 for more information.

Use this button to expand the entire tree in the First Selection and 
Second Selection explorer controls.

Use this button to collapse the entire tree in the First Selection and 
Second Selection explorer controls.

Delete button Use this button to delete objects after a comparison.
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To compare two objects in the same repository

1 In the Object Explorer select an object type.

2 In the Object List Editor, select two top-level objects. 

3 Choose Tools > Compare Objects > Selected. 

The Compare Objects dialog box appears.

To compare an object in the current repository with an object in another repository

1 In the Object Explorer, select an object type.

2 In the Object List Editor, select one top-level object. 

3 Choose Tools > Compare Objects > Selected vs. Repository.

The Open Repository dialog box appears.

4 Select the repository that contains the object you want to compare with the currently selected 
object.

The Object Comparison dialog box opens with the object in the current working repository 
displayed in the left applet and the corresponding object in the selected repository in the right 
applet. 

You can update the current working repository or the selected repository from the Object 
Comparison dialog box if you have the appropriate projects locked in both repositories.

To compare an object in the current repository with an object in an archive file

1 In the Object Explorer, select an object type.

2 In the Object List Editor, select one top-level object. 

3 Choose Tools > Compare Objects > Selected vs. Archive Option.

The Select Archive File to Compare Against dialog box opens.

4 Select a SIF file that to use for comparison and then click Open.

The comparison starts at the project level. If a corresponding object type is found in the archive 
file, the Object Comparison dialog box opens. If a corresponding object type is not found, it does 
not open. 

To compare objects in two different archive files

1 In the Object Explorer, select an object type.

2 In the Object List Editor, select one top-level object. 

3 Choose Tools> Compare Objects > Archive vs. Archive.

The Select Archive File for Left Side of Comparison dialog box opens.
Using Siebel Tools Version 7.8, Rev. B120 



Working with Objects ■ Determining When Records Were Last Created and Updated
4 Select an archive file, and then click Open.

The Select Archive File for Right Side of Comparison dialog box opens.

5 Select an archive file, and then click Open.

The Object Comparison dialog box opens with the left and right side populated with the contents 
of the selected archive files. During the comparison, the two archive files are read-only.

Related Topic
“About the Compare Objects Dialog Box” on page 118

Synchronizing Objects
After you compare two objects, you can use the Compare Objects dialog box controls to synchronize 
those objects.

To synchronize objects

1 Lock the projects that contain the objects you want to synchronize.

2 In the Object Explorer, select any two top-level objects of the same object type.

Make sure the objects are locked.

3 Choose Tools > Compare Objects > Selected. 

The Compare Objects dialog box appears. 

4 Select an object instance in the First Selection box and use the right arrow button to synchronize 
the objects selected in the First Selection box with the object in the Second Selection box. 

If the objects do not exist in the Second Selection box, Siebel Tools creates them. If they do exist, 
Siebel Tools changes their properties to reflect those in the First Selection box.

When you copy an object from one tree applet to the other, the children of the object are copied 
as well.

Determining When Records Were Last 
Created and Updated
You can review the history for a record to see who made the last change and when the record was 
updated.

To determine by whom and when a record was created and last updated

1 Select a record in the Object List Editor.
Using Siebel Tools Version 7.8, Rev. B 121



Working with Objects ■ Determining When Records Were Last Created and Updated
2 Choose Help > About Record. 

The Siebel Tools dialog box appears, displaying when and by whom the record was created and 
last updated.

3 Click Details > to display additional information about the record in the repository.
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This chapter describes the Siebel Script Editors. It contains the following topics:

■ “The Siebel Script Editors” on page 123

■ “Setting Scripting Preferences” on page 124

■ “About the ST eScript Engine” on page 125

■ “Setting the ST eScript Engine Warnings Preference” on page 126

■ “Enabling ST eScript Engine Type Deduction” on page 127

■ “Using the Siebel Script Editor” on page 128

■ “Using Script Assist” on page 129

■ “Setting Script Assist Preferences” on page 131

■ “About the Scripted Flag” on page 132

■ “About the Siebel Debugger” on page 132

■ “Using the Siebel Debugger” on page 132

■ “Setting Debugging and Run-Time Preferences” on page 133

■ “Checking Syntax” on page 134

■ “Tracing Scripts” on page 136

■ “Invoking Compiler and Run-Time Engine” on page 137

The Siebel Script Editors
The Siebel Script Editor is a window-based editor designed to create and maintain Siebel VB, Siebel 
eScript, and Browser Script programs. Scripting is used to implement functionality that cannot be 
achieved declaratively (that is, by changing object properties in the Siebel repository). The Server 
Script Editor and the Browser Script Editor are used to add scripts to Siebel objects. The Server Script 
Editor allows you to create and modify Siebel eScripts and Siebel VB. The Browser Script Editor 
allows you to write and edit Browser Scripts that run within the client. For more detailed information, 
including a list of scriptable events and callable methods on browser objects, see Siebel Object 
Interfaces Reference.

NOTE: There are two versions of the eScript scripting engine available to you. The T eScript engine 
is the traditional, previously available engine. The ST eScript engine, made available with Oracle’s 
Siebel Business Applications, Release 7.8, provides enhancements, including strong typing of 
variables and the Script Assist utility. Except for a few key differences, the ST eScript engine is 
backward-compatible with eScript created with the T eScript engine. In this document, the engines 
are referred to by name only in contexts requiring differentiation. 
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For a list of enhancements contained in the ST eScript engine, and well as instructions on how to 
enable the ST eScript engine, see “About the ST eScript Engine” on page 125.

When creating Siebel custom programs, note the following:

■ Check out or lock the project containing the object definitions being modified. If the project is 
not locked, you will not be able to add any text in the Editor window.

■ Choose Debug > Check Syntax to verify the syntax of your VB or eScript program. The Siebel 
Compiler reports any syntax errors and indicates the lines where they occur. 

■ Choose File > Save when you have finished entering and editing the custom statements to save 
your work. Closing the Siebel Script Editor without saving your work discards the changes.

■ Before you run the application, you must compile the projects that you have modified and 
generate a new SRF file. For information on the Object Compiler, read Siebel Developer’s 
Reference.

■ Run the application with the new application extensions by choosing Debug > Start or clicking 
the Start button in the Debug toolbar. The Siebel application executes with the new modifications 
incorporated. 

■ You may inadvertently create programming errors that, when encountered, halt the execution of 
the extension routine. If you started Siebel applications in debug mode (/H option on the 
command start-up line), a message box opens indicating the nature of the error. You can then 
return to the Script Editor and choose Debug > Check Syntax. For further details, read “Checking 
Syntax” on page 134.

■ When a script error is encountered by an end user, or when the Siebel application is not running 
in Debug mode, the application displays an appropriate error message and returns control back 
to the point in the standard Siebel code just prior to the error. 

Setting Scripting Preferences
You set scripting preferences from the Development Tools Options window. To set scripting options, 
perform the following procedure.

To set scripting options

1 From the Siebel Tools View menu, select Options.

The Development Tools Options window appears.

2 Click the Scripting tab. 

The following table describes the different fields in the Scripting Options Window.

Field Available Options

Font Allows you to set font type and size.

Script Assist Allows you to set Script Assist options. For more information on Script Assist, 
see “Setting Script Assist Preferences” on page 131.
Using Siebel Tools Version 7.8, Rev. B124 



Siebel Script Editors ■ About the ST eScript Engine
About the ST eScript Engine
The Siebel ST eScript engine is compliant with ECMAScript Edition 4. ECMAScript is the standard 
implementation of JavaScript as defined by the ECMA -262 standard. The ST eScript engine, available 
in version 7.8 or higher, provides the following:

■ Improved Performance. Higher throughput with a lower CPU and memory footprint in cases 
where you have implemented a significant amount of script. The result is improved performance 
and lower maintenance on heavily scripted events.

■ Scalability. Better performance than the T engine when many users are concurrently executing 
scripts.

■ Enhanced functionality. ST eScript engine supports ECMAScript Edition 4 compliant strong 
typing. Strongly typed objects allow you more functional scripts and better performance. The T 
eScript engine, which was available in previous Siebel releases, does not support strong typing. 

For a description of the functional differences in the scripting engines, as well as a description of 
Strong Typing syntax, see Siebel eScript Language Reference.

To enable the ST eScript engine, perform the following procedure. 

To enable the ST eScript engine for Siebel Tools

1 In Siebel Tools, click Screens > System Administration > System Preferences.

2 In the System Preferences window, under System Preferences Name, query for Enable ST Script 
Engine. 

3 Set the System Preference Value to TRUE.

4 Recompile your SRF.

NOTE: If you want to revert back to the T eScript engine after enabling the ST eScript engine and 
modifying your code to be strongly typed, you need to undo your strongly typed code changes.

Engine 
Settings

Allows you to enable settings for the ST eScript Engine. You must have the ST 
eScript Engine enabled to use these features. To enable the ST eScript Engine, 
see “To enable the ST eScript engine for Siebel Tools” on page 125. For more 
information on these settings, see “Setting the ST eScript Engine Warnings 
Preference” on page 126.

Language Allows you to specify the default language for your scripts, either eScript or 
Visual Basic. This field also allows you to specify the folder where your browser 
scripts will reside. This also determines where browser scripts are generated, 
such as D:\Program Files\Siebel\7.8\web client\PUBLIC\enu. In this case, 
browser script files are generated to D:\Program Files\Siebel\7.8\web 
client\PUBLIC\enu\<genbscript time stamped folder>\bscripts\all.

Debugging Allows you to set to options for the Siebel Debugger. For more information, see 
“About the Siebel Debugger” on page 132.

Field Available Options
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Setting the ST eScript Engine Warnings 
Preference
This preference is set under Engine Settings in the Development Tools Options window. Click the 
Enable Warnings checkbox to enable this setting.

The ST eScript Engine includes warnings which alert the user of potential problems that may be 
encountered at compile time. Some potential problems are: 

■ References to methods and properties that are not predefined

■ References to undeclared identifiers

■ Variables that can potentially be used before being initialized

■ Double declarations of untyped variables

■ Calling a function that has an insufficient number of arguments

Errors such as those listed previously usually end up causing a run-time failure. Therefore, these 
compilation warnings enable you to fix errors earlier in your development cycle. The ST eScript 
Engine is downward compatible with the T eScript engine, so any scripts you may be running on that 
engine will run in the same way. 

If you do not want these warnings displayed, deselect the Enable Warnings box. 

The following is an example of a compilation warning message generated following a run-time 
failure:

function foo(a)

{

var oApp: Application;

oApp.myMethod ();

return;

}

foo ();

Semantic Warning around line 5:Variable oApp might not be initialized.

Semantic Warning around line 5:No such method myMethod

Semantic Warning around line 10:Calling function foo with insufficient number of 
arguments.

Unhandled Exception: Function expected
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Enabling ST eScript Engine Type 
Deduction
This preference is set under Engine Settings in the Development Tools Options window. Click the 
Deduce Types checkbox to enable this setting.

Type deduction is a feature of the ST eScript Engine which deduces the type of local variables used 
in a script by scanning the assignments made to them. The engine cannot make the type deduction 
under all situations, therefore it is recommended that you strongly type your scripts.

If type deduction can be made, the compiler will perform strict type checks and generate statically 
bound code that runs faster and uses less memory. This may, however, introduce additional 
compilation warnings because of such type checks. 

The following example is of a script that deduces the type of the local variable oDate to the Date and 
subsequently issues a warning about the undefined method MyMethod. The script subsequently fails 
at run time:

function goo()

{

var oDate;

oDate = new Date ()

oDate.myMethod ();

return;

}

goo ()

Semantic Warning around line 19:No such method myMethod

Unhandled Exception: 'myMethod' is not defined
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Using the Siebel Script Editor
Siebel scripts can be attached to the object types application, applet, and business component. 
Figure 20 displays the Siebel Script Editor. To access the Script Editor, see “To access the Siebel Script 
Editor” on page 129.

The Siebel Script Editor is a window-based editor similar to the Windows Notepad editor. The Editor’s 
interface consists of a title bar, a drop-down list for specifying an object, a drop-down list for 
specifying an event, and a text entry window. There are vertical and horizontal scroll bars for 
scrolling within the entry region.

When using the Siebel Script Editor, you can do the following:

■ Cut, copy, and paste the text from one location to another location within or from outside the 
Editor. When pasting into the Editor, avoid having two code blocks with the same name by placing 
the code between the function <Name> {} (eScript) or Sub <Name> / End Sub block (VB).

■ Import and export Siebel scripts.

■ Associate a given Siebel script with a predefined object event, such as a PreSetFieldValue event 
for a Business Component. 

■ Debug a custom routine by invoking the Siebel Debugger. For more information, see “About the 
Siebel Debugger” on page 132.

■ Compile a custom routine by invoking the Siebel Compiler from the Siebel Script Editor. For more 
information, see “Invoking Compiler and Run-Time Engine” on page 137.

The editor functions can be accessed from the title bar menus, keyboard shortcuts, and the Edit 
toolbar. The following are File menu options pertaining to Siebel VB and Siebel eScript:

■ Import. Imports Siebel scripts.

■ Export. Exports Siebel scripts.

■ Save. Saves a Siebel script. Be sure to save your scripts before exiting the editor.

■ Exit. Closes the Siebel Script Editor window.

Figure 20. Siebel Script Editor
Using Siebel Tools Version 7.8, Rev. B128 



Siebel Script Editors ■ Using Script Assist
The following are Edit menu options pertaining to the Siebel Editor:

■ Cut. Deletes selection and saves it to the Clipboard.

■ Copy. Copies selection to the Clipboard.

■ Paste. Copies what is on the Clipboard to the selected area.

■ Delete. Deletes selection.

■ Select All. Selects the entire script.

■ Find. Displays the Find in Script dialog box. You can search for text or white space.

■ Replace. Displays the Replace in Script dialog box. You can search and replace text or white 
space.

To access the Siebel Script Editor

1 In the Object List Editor, select a scriptable object type, such as Applet.

2 Do one of the following:

■ Right click and then select either Edit Server Script, or Edit Browser script.

■ From the application-level menu, select View > Editors > Server Script Editor or Browser 
Script Editor.

Using Script Assist
Script Assist, a component of the ST eScript Engine, aids in the development of scripts by 
introspecting object definitions and making that information available to the user. 

Script Assist provides the following functionality:

■ Method Listing. All methods and properties available for a particular object are listed in the 
Method List window. To display the Method List window, see “Accessing the Script Assist Window” 
on page 130.

■ Auto Complete. After typing a minimum number of unique characters within the Method List 
window, for instance, “Bus” for “BusComp”, Siebel Tools automatically completes the word if a 
match is found. 

■ Auto-Indent. With the Indent property set to Auto, which is the default setting, Siebel Tools 
maintains a running indent. When you press the Return or Enter key, spaces and tabs are 
inserted to line up the insert point under the start of the previous line. 

■ Tool Tips. Within the Script Assist windows, tool tips allow you to see the arguments 
descriptions of methods chosen by a developer. They are particularly helpful as you do not need 
to cross reference a customer function and its required arguments, or the Siebel Bookshelf for 
included methods. 

■ Application Object scripts included for parsing. Scripts written on the Application object can 
be included for parsing by Script Assist. If in the Application drop-down you select the application 
to which this child script (business component, applet, business service) belongs, the scripts 
written on that application object will be available in the Script Assist window.
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■ Custom scripts written in the general section. Scripts written in the general section of the 
script explorer window are available in the Script Assist window. For example, if you were to write 
a helper function called Helper() in the general section of a current script, invoking Script Assist 
will cause Helper() to be included and available in the pop-up window.

Figure 21 displays the Script Assist window which provides a list of methods and properties 
associated with a selected object. To access the Script Assist window, see “Accessing the Script Assist 
Window” on page 130. For a description of icons in the Script Assist window, see Table 37.

Table 37 lists the icons in the Script Assist.

Accessing the Script Assist Window

To access the Script Assist window

1 In Script Editor Explorer window, select the desired object.

Figure 21. Script Assist Window

Table 37. Script Assist Buttons

Button Description

■ Lock icon denotes a read-only property. 

■ Blue square denotes a property.

Denotes a method.
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2 Type CONTROL + SPACE. 

The Method List, shown in Figure 22, appears displaying a list of all methods and properties 
available for the selected object.

Setting Script Assist Preferences
You set preferences for Script Assist in the Development Tools Options window. 

To set Script Assist preferences

1 From the Siebel Tools View menu, select Options.

The Development Tools Options window appears.

2 Click the Scripting tab. 

The following table describes the different fields in the Script Assist Window.

Figure 22. Method List

Field Available Options

Enable Method 
Listing

When checked, a list of declared methods and properties will appear 
in the Script Assist window for each selected object.

NOTE: For Script Assist features to be fully enabled, you must 
check this box.

Enable Auto 
Complete

When checked, Auto Complete is enabled.

NOTE: For Script Assist features to be fully enabled, you must 
check this box.

Auto Indent When checked, each succeeding line is indented to the position set 
by the current line.

Tab Width Set the tab width, in increments of spaces. The default setting is 4.
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About the Scripted Flag
For object types that can have a Siebel script attached to them (applet, application, and business 
component), there is a property in the Object List Editor called Scripted. This property indicates 
whether Siebel scripts are attached to the object definition. A check mark indicates the presence of 
scripts; no check mark indicates that the object definition has no scripts.

About the Siebel Debugger
The Siebel Debugger assists in editing and removing errors from scripts written in Siebel VB and 
Siebel eScript. 

The Siebel Debugger uses the Siebel Script Editor window plus a diagnostic window to display 
program variables and their values. The Debugger helps you locate and correct execution errors in 
custom program routines. You can use it to slow or suspend execution of the program routines so 
that the program flow and variable contents can be examined.

With the Siebel Debugger you can do the following:

■ Set and clear breakpoints in your Siebel script. A breakpoint is a marker on a line of Basic code 
that tells Basic to suspend execution at that line so that the state of the program can be 
examined using the Debugger.

■ Step over a line of code. If the current line is a call to a subroutine or function, the Debugger 
stops at the next line in the current procedure (skipping the subroutine).

■ Step into a subroutine of custom routine code. Step Into is used to execute one line of code in 
the Debugger. If the current line is a call to a subroutine or function, the Debugger stops at the 
first line of that function. Otherwise, the Debugger stops at the next line of the current 
procedure.

■ View the value of custom routine variables. The Siebel Debugger includes a window in which 
variables and their values are displayed. This window can be used to monitor the values of 
specific variables as the custom routine executes.

Using the Siebel Debugger
You can access the Debugger in several ways:

■ You can set breakpoints in the current routine and begin execution by clicking the Start button. 
Execution is suspended when one of the lines that contains a breakpoint is about to be executed. 
The Debugger is activated and it highlights the line containing the breakpoint.

■ If an executing program encounters a run-time error, such as an unhandled Siebel VB or eScript 
error, execution is suspended, the Debugger is activated, and it highlights the line containing the 
error.

Debug options are available from the Debug title bar menu and the Debug toolbar. See the Siebel 
Toolbars and Menus topics for details.
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Topics in This Section
“Setting Debugging and Run-Time Preferences” on page 133

“Checking Syntax” on page 134

“Using Breakpoints” on page 135

“Using the Siebel Calls Window” on page 135

“Tracing Scripts” on page 136

“Invoking Compiler and Run-Time Engine” on page 137

Setting Debugging and Run-Time Preferences
You set debugging preferences and run-time preferences in the Development Tools Options window.

To set debugging preferences

1 From the Siebel Tools View menu, select Options.

The Development Tools Options window appears.

2 Click the Scripting tab. 

The following table describes the different fields in the Debugging box in the Development Tools 
Options window.

To set run-time preferences

1 From the Siebel Tools View menu, select Options.

The Development Tools Options window appears.

Option Description

Adjust breakpoint 
to next valid line 

When breakpoints are deleted on invalid lines, this option creates a 
breakpoint at the next valid line. Click the check box to enable this 
function.

Make debugger 
window active 
when debugging

The Siebel Debugger window appears whenever you are in debug mode. 
Click the check box to enable this function.

Always enter the 
debugger when an 
error occurs

The Siebel Debugger window appears whenever a script error occurs. 
Click the check box to enable this function.
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2 Click the Debug tab. 

The following table describes the different fields in the Debug box in the Development Tools 
Options window.

Checking Syntax
The debugger includes a syntax checker to make sure that your script compiles properly. 

To check the syntax of your script

1 Click the Check Syntax button, or choose Debug > Check Syntax.

Siebel Tools does a test compile. If you have made no errors, you get no response. If there are 
errors in your script, a message box appears describing the error. The message box has two 
buttons: Next Error and Go to Line. If there is more than one error, it is best to handle them one 
at a time. 

2 Click Go to Line.

The cursor is displayed on the line of the script containing the error, with the line highlighted. 

Option Description

Executable Enter the name of the Mobile Web Client executable (Siebel.exe).

CFG file Enter the configuration file to be used by the client.

Browser Enter the path to the browser executable.

Working directory Enter the Siebel root directory (location of DLLs).

Arguments Additional line options for starting the application. Common arguments 
are:

■ /h - to enable local debugging of Server scripts

■ /s <filename> - to enable SQL spooling

Prompt for this 
information each 
time

Click this to display relevant information, such as executable, CFG file, 
browser, and so on, each time you run a debug operation.

Show Workflow 
Primary Business 
Component Data

If checked, the Watch Window in the Workflow Simulator will show all 
fields and their values from the primary Business Component of the 
Business Object associated with the Workflow process being simulated.

User Name Enter the login of the user.

Password Enter the password of the user name.

Data source Enter the default data source. Values listed depend upon the 
configuration file specified in the CFG file parameter.
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3 Correct the code and check the syntax again. 

If the syntax of the line you changed is now correct, the message box displays the next error, if 
any.

4 Repeat Step 2 and Step 3 until you see no more messages.

5 Choose File > Save to save your file, and close the Siebel application. 

6 Press F7 to compile the SRF file.

7 When the compilation finishes, click Run or press F5 to restart the application.

CAUTION: The Check Syntax function checks only for syntax errors and errors that stem from 
failure to properly initialize objects or variables. It does not check other types of errors, and cannot 
trap errors in logic that may cause run-time errors.

At this point, your script should run. Test it to see if it gives you the desired results. The following 
sections describe debugging tools to help you accomplish that end.

CAUTION: The Check Syntax command checks only the script in the active object definition. If there 
are errors in other scripts, you are not able to compile the SRF file.

Using Breakpoints
A breakpoint is a marker on a line of Siebel code that tells the interpreter to suspend execution at 
that line so that the state of the program can be examined using the Debugger. There are two ways 
to set breakpoints on lines of Siebel code when editing, and there is an additional way to set a 
breakpoint when debugging:

■ When editing, place the cursor on the line of code on which to set a breakpoint by clicking on 
that line, or by using the arrow keys. To toggle the breakpoint, press F9, or click the toolbar 
button. If the line already has a breakpoint, pressing F9 or the toolbar button clears the 
breakpoint.

■ When debugging, clicking on a line of Siebel code toggles a breakpoint on that line.

Using the Siebel Calls Window
The Calls window contains a list of subroutine and function calls that were executed prior to the 
current line. To access the Calls window, click the Calls button in the Debugger toolbar when you are 
running the Debugger. A typical Calls window may contain several lines, one for each subroutine 
entered into and not yet completed.

Selecting an entry in this list box causes the interpreter to shift to that entry. The Debugger window 
displays the line of code that made the call, and the Variable window displays the variables that are 
associated with the procedure that made the call.
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Tracing Scripts
As part of debugging scripts you can run a trace on allocations, events, and SQL commands. The 
tracing can be activated for specified user accounts, such as your development team. The Siebel 
Server sends the tracing information to a log file.

To enable logging

1 Navigate to Server Administration > Components.

2 Select a component to log. Not all components support logging, but the majority do.

3 Click the Component Event Configuration tab.

4 Select the Object Manager Extension Language Log record. If this record does not exist, then the 
selected component does not support logging.

5 Set the Log Level to 1. To disable logging when you are done, set the Log Level to 0 (zero).

6 Click the Component Parameters tab.

7 (Optional) To display only the script tracing parameters, query for:
Parameter Alias = Trace*
Subsystem = Object Manager

Changes to the script tracing parameters can take effect immediately. If you want changes to 
take effect now, then make changes to the values in the Current Value column. If you want the 
changes to take effect only after a restart, then make changes to the values in the Value on 
Restart column.

8 Set one or more tracing parameters from the following table.

The following is a sample trace:

2021 2003-04-09 15:37:20 2003-04-09 16:40:52 -0700 00000022 001 001f 0001 09 SCCObjMgr_enu 47126 1680 1584 
C:\sea752\siebsrvr\log\SCCObjMgr_enu_47126.log 7.5.3 [16122] ENU

ObjMgrSessionInfo ObjMgrLogin 3 2003-04-09 15:37:20 Login name : SADMIN

ObjMgrSessionInfo ObjMgrAuth 3 2003-04-09 15:37:20 Authentication name : SADMIN

ObjMgrSessionInfo ObjMgrLogin 3 2003-04-09 15:37:20 Session Type: Regular Session

GenericLog GenericError 1 2003-04-09 15:37:20 Invocation of Applet Menu New 
Service::NewExpense is not allowed.

Information to 
Trace

Parameter 
Alias Settings for Current Value and Value on Restart

Allocations TraceAlloc 0 (zero) to disable logging, 1 to enable logging

Events TraceEvents 0 (zero) to disable logging, 1 to enable logging

SQL Commands TraceSql 0 (zero) to disable logging, 1 to enable logging

Users TraceUser Comma-separated list of user names. Do not use spaces. 
Example:
sadmin,mmasters,hkim,cconnors
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GenericLog GenericError 1 2003-04-09 15:37:20 Invocation of Applet Menu New 
Service::NewTimeSheet is not allowed.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:27 [User: SADMIN] EVENT, BEGIN, BusComp 
[Account], BusComp_Query.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:27 [User: SADMIN] EVENT, END, BusComp 
[Account], BusComp_Query.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:58 [User: SADMIN] EVENT, BEGIN, BusComp 
[Account], BusComp_NewRecord.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:58 [User: SADMIN] EVENT, END, BusComp 
[Account], BusComp_NewRecord.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:39:08 [User: SADMIN] EVENT, BEGIN, BusComp 
[Account], BusComp_PreSetFieldValue.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:39:08 [User: SADMIN] EVENT, END, BusComp 
[Account], BusComp_PreSetFieldValue.

ObjMgrSessionInfo ObjMgrLogin 3 2003-04-09 16:40:52 Username: SADMIN, Login Status: Attempt, 
Session Id: !1.690.b816.3e94a0a0, IP Address: 172.20.94.66

Script tracing is not the same as file-based tracing. For more information on file-based tracing, Siebel 
Object Interfaces Reference.

Invoking Compiler and Run-Time Engine
To invoke the Siebel Compiler and Run-time Engine, click the Compile button on the Debugger 
toolbar, or press F7. You can also invoke it when compiling a project containing object definitions 
with associated Siebel scripts. The Siebel Compiler and Run-time Engine has no user interface of its 
own. When the compiler is invoked, it compiles the custom routines and returns a message when 
completed that indicates success or failure.

Compilation Order Considerations
The Siebel Compiler compiles Siebel VB functions and procedures in alphabetical order within an 
object definition. If a function or procedure calls another function or procedure that has not been 
defined, the compiler generates an error message in the form:

function_name Is An Unknown Function

To avoid this error, use the Declare statement to declare the function or procedure in the (general) 
(declarations) section. For more information, read the VB Language Reference topics within Siebel 
VB Language Reference.

Siebel eScript does not require forward declaration of functions.
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9 Compiling and Testing
This chapter describes compiling and testing. It contains the following topics:

■ “About Compiling” on page 139

■ “Compiling Projects” on page 140

■ “Compiling Single Objects or Groups of Objects” on page 141

■ “Command-Line Interface for Import, Export, and Compilation” on page 141

■ “Testing Changes on Your Local Machine” on page 143

About Compiling
After you have modified objects, you need to compile the changes to an SRF. The SRF file is updated 
with the new objects, which become available in any instances of the Web Client reading that SRF file.

NOTE: An application’s configuration file (CFG) includes a parameter (RepositoryFile) that defines 
the SRF file to read at run time.

You can compile entire projects or individual top-level objects. Compiling projects is more efficient 
when you have many changes in one or more projects. Compiling objects is more efficient when 
changes are isolated to only a few objects. 

NOTE: To be able to compile, Siebel Tools must be connected to a database that has the sort order 
set to binary.

CAUTION: When compiling a new SRF file, make sure all Siebel applications are completely closed. 
Use the Windows Task Manager to verify that no Siebel.exe processes are running. To compile, see 
“To compile projects” on page 140, or “To compile single objects or a group of objects” on page 141. 

Incremental Repository Upgrade Kits
If you are compiling an SRF file to create an incremental (delta) repository upgrade kit, you can 
minimize the size of the kit and the time required to upgrade by specifying a Reference SRF when 
you compile your new SRF. The Reference SRF is a previous (base) version of the SRF. The 
incremental repository upgrade contains the differences between the Reference SRF and the new SRF 
only. To specify a Reference SRF, click the Reference SRF button, and specify the path and file name 
of the previous SRF version. 

For more information about incremental SRF files and upgrades, see Siebel Anywhere Administration 
Guide.
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Compiling Projects
You use the Object Compiler to compile all projects or selected projects only. To be able to compile 
selected projects, you must have compiled all projects at least once. 

CAUTION: Avoid compiling a subset of projects into an SRF file, unless the SRF file was built from 
a full compilation from the same database. 

When you select individual projects to compile, the Object Compiler does not remove inactive top-
level objects from the SRF file, but it does remove inactive child objects. For example, if you 
inactivate the Name list column in the Account List Applet, and then compile the Account SSE project, 
the Name list column is removed from the SRF file. However, if you inactivate the Account List Applet, 
and then compile the Account SSE project, the Account List Applet is not be removed.

To compile projects

1 Choose Tools > Compile Projects.

The Object Compiler dialog box appears with the list of projects displayed.

2 Select the projects you want to compile.

3 In the Siebel Repository File field, click Browse and then select the appropriate SRF file.

Typically you compile to the SRF file used by the local instance of the Web Client that you are 
using to test. The path to this SRF file is specified in the application’s CFG file.

CAUTION: Do not attempt to compile to or modify the default SRF file used by Siebel Tools that 
is displayed in the Object Compiler dialog box—usually siebel.srf located in 
SIEBEL_TOOLS_ROOT\OBJECTS. This file is locked, because the Siebel Tools client is currently 
reading it. If you attempt to compile to this filename and path, you receive an error message.

4 Click the Auto-start Web Client check box, if you want to automatically start a local instance of 
the Web Client when the compile process finishes.

When this option is checked and the Web Client is already open, the client is refreshed with 
changes and opens with same view that was displayed before the compilation.

To automatically start the Web Client, you need to have specified the location of the Siebel 
executable, the application configuration file, and other relevant settings in the Development 
Tools Options dialog box. For information on how to do this, see “Setting Debug Options” on 
page 64.

5 Click Compile.

The objects in your repository are compiled to the SRF file you specified. The changes are 
immediately available in any instances of the Web Client that are reading the SRF file. See 
“Testing Changes on Your Local Machine” on page 143.
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Compiling Single Objects or Groups of 
Objects
You can compile a single object or a group of top-level objects of the same type. For example, if you 
modify the UI for several applets, rather than compiling entire projects, you can compile only the 
applets that have changed.

NOTE: Some repository objects have to be in the production database to function correctly. By 
default, these objects have their no compile flag set to TRUE, thus, they do not get compiled into the 
(.srf) file. Of particular interest are those objects that can be configured. These include Assignment 
Objects and their children, Workflow Policy Objects and their children, Dock Objects and their 
children, and EIM Interface Table objects and their children. Other objects that are not configurable 
but still need to be present in the production database for customer to use various Admin and Batch 
processes include Schema Maintenance objects, Server Component objects and User Key Attribute 
objects. 

To compile single objects or a group of objects

1 In the Object List Editor, select an object or group of objects of a given object type (for example, 
applet).

2 Right-click, and then choose Compile.

The Object Compiler dialog box displays the list of selected objects.

3 In the Object Compiler dialog box, click Browse, and then select the appropriate SRF file.

4 Click Compile.

The objects are compiled to the SRF file you specified. The changes are immediately available in 
any instances of the Web Client that are reading the SRF file. For more information, see “Testing 
Changes on Your Local Machine” on page 143.

Command-Line Interface for Import, 
Export, and Compilation
The command-line interface for import, export, and compiling is invoked from the siebdev 
executable, using these command switches: /batchimport, /batchexport, and /bc. The executable 
file siebdev.exe is located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation 
directory.

Batch Import
The syntax of the /batchimport switch is as follows:

/batchimport <"siebel repository"> <Import Mode - i.e. Overwrite, Merge, Skip> <Sif 
File1, Sif File2, Sif FileN - or Directory containing .sif files> <Log File>

You can specify the archive (SIF) file and the log file by the full path or relative path to the current 
directory.
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The following sample import command imports import1.sif located in the parent directory and 
import2.sif located in the Siebel Tools installation directory into the Siebel repository using the 
overwrite mode. It also logs the results to the import.log.

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" overwrite ..\import1.sif "C:\Program 
Files\Siebel\7.8\Tools\import2.sif" import.log

The following sample import command imports all files under C:\Program 
Files\Siebel\7.8\Tools\importfiledir into the Siebel repository using the merge mode. This command 
also logs the results to import.log file.

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" merge "C:\Program Files\Siebel\7.8\Tools\importfiledir" import.log

Batch Export
For export, the command-line interface provided by the /batchexport switch accepts an input file 
that specifies export objects.

The input file takes a comma-delimited format of Object Type, Object Name Search Expression, and 
the SIF file name. The search expression takes any Siebel Tools accepted query criteria. To specify 
the archive (.sif) file, you can use the absolute file path or the relative file path to the current 
directory.

You can place multiple lines in the input file, each requesting to export multiple objects into one SIF 
file. However, if you specify the same (.sif) export file in multiple lines, only the last export will take 
effect, and the previous exports will be overwritten.

As an example, the following content, in an input file, requests the batchexport switch to export all 
business components whose name is like *Account* into the export.sif file.

"Business Component,*Account*,export.sif"

NOTE: There must be no space before and after commas. 

The syntax for /batchexport switch is as follows:

/batchexport <"siebel repository"> <Input File Name> <Log File>

The following sample export command would export objects specified in the input file, obj.txt. This 
command will also log results into the export.log file.

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchexport "siebel 
repository" obj.txt export.log

Compilation
The syntax of the /bc switch is as follows:

/bc <Repository Name> <SRF Name>
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An example of a compilation command that compiles the Siebel repository into siebel.srf is shown 
below:

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /bc "siebel repository" 
Siebel.srf

If no file path is specified for the.srf file, the file will be compiled into the objects directory under 
Siebel Tools, otherwise, it will be compiled into the specified directory.

Batch Patch
The syntax for the batch patch command-line entry is as follows:

siebdev.exe /u sadmin /p sadmin /d local-dest /applybatchpatch <Siebel Repository 
Name> <Directory that contains the patch files> <Log File Name>

Incremental Import
The syntax for the incremental import command-line entry is as follows:

eximsif.exe /u sadmin /p db2 /d db224001 /A ie /t SIEBEL /f g:\testSifs /R "exp-imp-
0" /n 1 /l ie-0.log /i input.txt

Testing Changes on Your Local Machine
For testing purposes, you must have an instance of the Siebel Mobile Web Client installed on your 
machine. After you compile repository changes to an SRF file, local instances of the Mobile Web Client 
that are open and are reading the SRF file automatically close and then reopen, displaying the 
updated configuration.

For information on installing the Mobile Web Client, see the Siebel Installation Guide for the operating 
system you are using.

When compiling objects and testing the results locally, consider the following:

■ If a local instance of the Web Client is installed but it is not open, you can select an option in the 
Object Compile dialog box to automatically open a local Web Client and read the most current 
repository. For more information, see “Compiling Projects” on page 140.

■ For repository changes to appear in local instances of the Web Client, the Web Client must be 
reading the SRF file to which you compiled.
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10 Working with Archive Files
This chapter describes how to work with archive (SIF) files. It contains the following topics:

■ “About Archive Files” on page 145

■ “Exporting Objects to an Archive File” on page 146

■ “Exporting Objects to an Archive File Using the Command-Line Interface” on page 146

■ “Process of Importing Objects from an Archive File” on page 147

■ “Preparing the Target Repository for Import from an Archive File” on page 147

■ “Importing Objects from an Archive File” on page 148

■ “About the Import Wizard - Review Conflicts and Actions Dialog Box” on page 150

■ “Importing Objects from an Archive File Using the Command-Line Interface” on page 153

About Archive Files
You can export object objects from the repository to an archive (SIF) file and then import objects 
from the archive file back into the repository. Use archive files when you want to back up sets of 
objects or move sets objects to another environment that shares the same physical database schema 
as the source environment.

Archive files are database-independent because they only represent repository information. You can 
use them to exchange repository data between environments with different database platforms, 
including local and server databases, as long as the databases have the same schema.

You can include individual objects or entire projects in archive files. However, the Project property of 
objects is not included in Siebel archive files.

Archive files can be controlled by source-control software. When importing objects from an archive 
file, you can specify conflict resolution rules at the object level, directing Siebel Tools to ignore an 
imported object, replace an existing object with an imported one, or merge the two on a property-
by-property basis.

If you need to back up or move the entire repository to another environment, see “About Exporting 
and Importing Repositories” on page 159.
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Exporting Objects to an Archive File
You can use archive files to export top-level objects such as business components, applets, views, 
and projects to an archive file. Child objects are exported and imported along with their parents. You 
can select an entire project to export or individual objects within a project. When selecting individual 
objects to export, you select all objects of a given object type. For example, first you select all the 
applets you want export, then you can navigate to a second object type to select additional objects, 
and so on.

When exporting repositories, consider the following:

■ Archive files can be exported and imported only among repositories with the same repository 
schema definition.

■ Do not export the Repository Object to export an entire repository. The resulting export file will 
be too large and performance will be slow. Instead, use the task described in “Supported Source 
and Target Databases for Importing and Exporting Repositories” on page 159.

To export objects to an archive file

1 In the Object Explorer, navigate to the object type you want to export.

2 In the Object List Editor, select the object or objects you want to archive.

3 Choose Tools > Add To Archive.

The Export to Archive File dialog box appears.

Status messages appear showing which child objects are being included. When the process 
completes, the selected top-level objects appear in the Objects to Archive list in the Export to 
Archive File dialog box.

4 If you need to add objects of another object type, navigate to that object type in the Object 
Explorer without closing the Export to Archive File dialog box.

5 Repeat Step 2 through Step 4 for each object you want to archive. 

6 When you are finished adding objects to the list, in the Export to Archive file dialog box, enter 
the path and filename of the archive file you want to create. 

7 Click Save. 

A SIF file (archive file) is created in the location you selected.

Exporting Objects to an Archive File 
Using the Command-Line Interface
You can export objects using the command-line interface. You invoke the command-line interface 
from the siebdev executable, using the command switch /batchexport. The executable file 
siebdev.exe is located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation 
directory.

The syntax of the /batchexport switch is:
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siebdev.exe /c <config file> /d <database> /u <user name> /p <password> /batchexport 
<Repository Name> <Input File Name> <Log File>

The command-line interface provided by the /batchexport switch accepts an input file that specifies 
export objects. The input file takes a comma-delimited format of Object Type, Object Name Search 
Expression, and the .sif file name. The search expression takes any Tools accepted query criteria. To 
specify the SIF file, you can use an absolute file path or a relative file path to the current directory.

You can place multiple lines in the input file, each requesting to export multiple objects into different 
SIF file. However, if you specify the same SIF export file in multiple lines, only the last export takes 
effect—the previous exports will be overwritten.

For example, consider the following sample text from an input file. Using this file as input, the switch 
/batchexport would export all business components where the Name property is like “*Account*” 
into a repository file named exports.sif:

"Business Component,*Account*,export.sif"

NOTE: There must be no space before and after commas. 

The following sample export command would export objects specified in the input file, obj.txt. It also 
logs results into export.log:

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchexport "siebel 
repository" obj.txt export.log

Process of Importing Objects from an 
Archive File
You can import objects from an archive file into a local repository.

To import objects from an archive file, perform the following tasks:

1 “Preparing the Target Repository for Import from an Archive File” on page 147

2 “Importing Objects from an Archive File” on page 148

Preparing the Target Repository for 
Import from an Archive File
You need to import into a checked-out project or projects on the local database of a client computer—
do not import to the Server database. Make sure the following conditions exist before importing:

■ The import file is accessible to the local machine by way of the network or local drives.

■ The target repository is open in Siebel Tools and is the active repository.
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■ The projects that will be affected by import have been checked out to the local database. This 
includes any project that any object in the export file is assigned to.

The only exception consists of projects (or their objects) that are in the archive file, but that do 
not exist yet in the target repository. These are not checked out because they do not exist in the 
target repository.

NOTE: In some cases it may be difficult to know in advance which projects need to be checked 
out. The Import wizard informs you of any projects that were not locked but need to be. This 
occurs on the second panel of the Import wizard, after the wizard has analyzed the objects in 
the archive file and compared them to the objects in your repository. 

Importing Objects from an Archive File
After you have exported objects to an archive file, you can import them from the archive file into a 
repository. The repository from which the archive file was created and the repository into which you 
are importing must be the same Siebel release version.

To import objects from an archive file

1 Open the target repository in Siebel Tools, if it is not already open.

2 Choose Tools > Import From Archive.

3 In the Select Archive To Import dialog box, select the archive (SIF) file, and then click Open. 

The Import Wizard - Preview dialog box appears as shown.

This dialog box identifies the projects and the nonproject top-level objects in the archive file you 
have opened, allowing you to preview the contents of the archive file. 
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4 Select an option button in the Conflict Resolution area. 

To specify the default resolution for conflicts between the archive file and the target repository. 
You will have the opportunity in subsequent dialog boxes in the Import Wizard to change this 
choice for individual objects. 

Use the following table to determine your option.

5 Click Next.

One of the following happens:

■ If there are objects you will be replacing or modifying and their projects are not locked, a 
warning message appears, you must cancel the import process, lock the projects, and then 
restart the Import Wizard.

■ If the objects in the SIF file already exist in the repository, and there are no conflicts found, 
no changes are made. A message appears saying that no conflicts were found, and that no 
changes will be made to the repository. In this case, click OK.

■ If the objects in the SIF file already exist in the repository, and if conflicts are found, or if the 
objects do not yet exist in the repository, the Import Wizard - Review Conflicts and Actions 
dialog box appears with information about the differences displayed. In this case, go to 
Step 6 on page 150.

Option Button Description

Overwrite the object 
in the repository

If the same top-level object is found in the archive file and target 
repository, delete the version in the target repository, along with its 
children, and replace them with the object and children from the 
archive file. 

Merge the object 
definitions from the 
archive with the 
definition in the 
repository

Merging is the default, and generally the safest option. When the same 
top-level object exists in both the target repository and the archive file:

■ Replace differing properties in the target top-level and child-level 
with those in the archive file.

■ Add new child objects to the target repository if they are not 
already present. 

■ Do not change child objects in the target repository that are not 
also present in the archive file.

The resulting top-level object has the same properties and children as 
the object in the archive, plus any children that were already present 
in the repository definition. 

Do not import the 
object definition 
from the archive

Do not change the objects in the target repository.
Using Siebel Tools Version 7.8, Rev. B 149



Working with Archive Files ■ About the Import Wizard - Review Conflicts and Actions 
Dialog Box
6 In the Import Wizard - Review Conflicts and Actions dialog box, under Conflicting Objects, select 
an object to see the differences under Object Differences and Attribute Differences.

See “About the Import Wizard - Review Conflicts and Actions Dialog Box” on page 150 for details 
about the dialog box.

7 To make an adjustment, do the following:

a Select an object or attribute difference.

b Right-click and select the action you want to occur.

8 Click Next.

The Summary window appears, and the import process starts.

9 When the import process is completed, click Finish.

A log file named importlog.txt is created in the SIEBEL_TOOLS_ROOT\TEMP directory of your 
Siebel Tools installation directory. It contains the same list of messages that appeared in the 
Summary window. You may find it useful to store this file elsewhere for a record of what changes 
were made to the repository. It is also a good idea to change the filename so it reflects the date 
of the import.

About the Import Wizard - Review 
Conflicts and Actions Dialog Box
When the Import Wizard detects a difference between objects stored in the repository and those 
stored in the SIF file, the Import Wizard - Review Conflicts and Actions dialog box appears. You use 
this dialog box to review differences and to change the action used to resolve the conflict.
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Dialog Box
The dialog box, shown in Figure 23, is divided into three panes: the Conflicting Objects explorer 
control, the Object differences list, and the Attribute differences list.

Conflicting Objects Explorer
The Conflicting Objects Explorer displays the hierarchy of objects for which there are differences. The 
hierarchy displayed mirrors the object type/object definition hierarchy in a Siebel repository, but 
shows only conflicts to resolve rather than all repository or archive objects.

Object Differences List
The Object Differences list displays objects, one for each row. For each object it shows whether it 
exists only in the archive file, only in the target repository, or in both, and what resolution is 
specified. You can change the resolution here.

The objects displayed in the Object Differences dialog box include those at all hierarchical levels, not 
just top-level objects. This lets you make adjustments to the resolution for any affected objects.

The File and Repository columns indicate whether each identified object is present in the archive file 
or target repository. An “X” indicating the object’s presence can appear in the File list column, the 
Repository list column, or both. These list columns are for information only; you cannot change the 
check marks.

Figure 23. Import Wizard - Review Conflicts and Actions
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The Action list column indicates the proposed resolution for each object in the list. This setting is 
initially generated for each object from the default behavior selected in the Conflict Resolution option 
buttons in the Preview pane. You can right-click on the value in the Action list column and select a 
different value from a shortcut menu. The available selections include the following:

■ File. Equivalent to the Overwrite the object definition in the repository selection in the previous 
dialog box.

■ Merge. Equivalent to the Merge the object definitions from the archive with the definition in the 
repository option in the previous dialog box.

The resulting top-level object has the same properties and children as the object in the archive, 
plus any children that were present in the repository definition. 

■ Repository. Equivalent to the Do not import the object definition from the archive option in the 
previous dialog box.

For more information about these options, see “Importing Objects from an Archive File” on page 148.

Attribute Differences List
The Attribute Differences list displays the property value conflicts for the currently selected object in 
the Object Differences dialog box. Those properties are listed only where there is a conflict.

Table 38 describes the columns in the list.

Table 38. Columns in the Attribute Differences List

Column Description

Attribute Name of the property.

File Value of the property in the archive file version of the object.

Repository Value of the property in the target-repository version of the object.

Resolution Value of either File or Repository for each property, depending on whether the 
archive-file or target-repository version of the object is to determine the value 
of the property in the final definition.

This list column can be updated only if the object whose properties are being 
displayed has an Action setting of Merge in the Object Differences list. 
Otherwise, the shortcut menu options are read-only and are unavailable, and 
the value displayed is the same as that in the Action column of the Object 
Differences list.

To change the Resolution value from Repository to File or the reverse, right-
click on the Attribute row to change and then choose Repository or File from 
the shortcut menu.
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Importing Objects from an Archive File 
Using the Command-Line Interface
You can also import objects using the command-line interface. You invoke the command-line 
interface from the siebdev executable, using the command switch /batchimport. The siebdev.exe 
executable file is located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation 
directory.

The syntax of the /batchimport switch is:

siebdev.exe /c <config file> /d <database> /u <user name> /p <password> /batchimport 
<Siebel Repository name> <Import Mode> <.sif file1, .sif file2, .sif fileN; or 
directory where SIF files can be found> <log file>

NOTE: You can specify the SIF file and the log file by the full path or the relative path to the current 
directory.

For example, the following sample import command imports import1.sif, located in the parent 
directory, and import2.sif, located in the Siebel Tools installation directory, into the Siebel repository 
using the overwrite mode. It also logs the results to import.log:

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" overwrite ..\import1.sif "C:\Program 
Files\Siebel\7.8\Tools\import2.sif" import.log

The following sample import command imports all files under C:\Program 
Files\Siebel\7.8\Tools\importfiledir into the Siebel repository using the merge mode. It also logs the 
results to import.log:

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" merge "C:\Program Files\Siebel\7.8\Tools\importfiledir" import.log
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11 Managing Repositories
This chapter describes how to manage repositories. It contains the following topics:

■ “About Repositories” on page 155

■ “Viewing Which Repository Is Currently Open” on page 156

■ “Reviewing Information About the Current Repository” on page 156

■ “Guidelines for Naming Repositories” on page 157

■ “Renaming Repositories” on page 158

■ “Deleting Repositories” on page 158

■ “About Exporting and Importing Repositories” on page 159

■ “Supported Source and Target Databases for Importing and Exporting Repositories” on page 159

■ “About Repository Patch Files” on page 163

■ “Creating Repository Patch Files” on page 164

■ “Applying Repository Patch Files” on page 167

■ “Upgrading Repositories” on page 168

About Repositories
The Siebel repository refers to the set of tables in which Siebel objects and server scripts are stored. 
The set of objects and server scripts stored in the repository define a Siebel application (such as 
Siebel Service or Siebel Sales) and are compiled into a compressed file called a Siebel repository file 
(SRF file). You use Siebel Tools to view data in the Siebel repository.

The Siebel repository is populated with data during the installation process. For more information, 
see the Siebel Installation Guide for the operating system you are using.

The SRF file is a compressed file that contains a compiled version of the Siebel repository. Siebel 
applications read the SRF file at run time. It provides the Siebel applications with much of the 
metadata it needs to define interactions with the enterprise data and software users.

You cannot have multiple repositories in a production environment because some run time 
components read repository objects, such as workflow policies, directly from repository tables 
instead from the SRF file and they assume there is only one repository.

NOTE: Browser scripts are compiled into the browser script compilation folder, which can be 
specified in Siebel Tools on the Scripting tab under View > Options. 
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Viewing Which Repository Is Currently 
Open
Under normal circumstances there is only one repository available on your local database, and one 
available on the server database for your development workgroup. Typically this repository (in either 
location) is called the Siebel repository and is opened by default when you open Siebel Tools and log 
on to the local or server database. However, there are circumstances—especially when your group is 
in the process of upgrading to a new version of Siebel Business Applications—in which multiple 
repositories can be present, especially on the server. 

To view which repository is currently open
■ Choose File > Open Repository.

The Open Repository dialog box appears and lists all repositories in the database to which you 
are connected. 

Reviewing Information About the 
Current Repository
The About SRF option on the Siebel Tools Help menu provides version, compilation, and path 
information about the current repository.

To review information about the current repository
■ In Siebel Tools, choose Help > About SRF.

The About Repository File window appears and displays the following information.

Field/Button Description

Internal version Version number maintained internally at Oracle that changes only when the 
internal format of the SRF file changes, such as at the time of a major 
release. It has no significance for customer developers.

User version Reserved for use by Oracle’s Siebel Anywhere, which maintains this number 
when kits are created that upgrade the SRF file. The value is read when a 
version check occurs.

Full compile 
option button

Select to display information about the most recent full compilation in the 
Compile Information fields.

Last incremental 
compile option 
button

Select to display information about the most recent incremental 
compilation. If there have been no incremental compilations since the last 
full compilation, this option button is unavailable.

When Date of the last compilation—incremental or full, as specified in the option 
buttons.

Machine name Name of the client computer on which the SRF file was compiled.
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Guidelines for Naming Repositories
You must establish and maintain a naming convention for all repositories in their respective 
environments. There are several dependencies on repository names—for example, Siebel servers 
point to a specific repository by name. Also, the procedures for upgrading to new versions of Siebel 
Business Applications depend on repository names. 

A consistent naming convention promotes successful configuration and testing while it minimizes the 
work required to migrate new repositories or perform upgrades. Follow these guidelines when 
determining the naming conventions for your repositories:

■ Use the default name, Siebel Repository, whenever possible. Change this only if you have a 
compelling reason, because the default configuration of Siebel Business Applications and Siebel 
documentation assumes this name is being used.

■ Use the same repository name for the active repository in your test environment and for the 
current working repository in your production environment. Using the same name simplifies the 
process of migrating repositories from development to test and from test to production. It also 
eliminates the need to change your client or application server configurations when you perform 
the migration process.

■ Use descriptive names for the other repositories in your development environment. Typically, 
your development environment has a number of repositories in addition to the current repository 
that is being configured. These may include the initial repository loaded with your Siebel 
application, other repository versions used in Siebel application upgrades, and repositories from 
previous versions of your custom configuration. Give these repositories unique and fully 
descriptive names—for example, Siebel v7.5.3 Original for the initial repository shipped with 
Siebel Business Applications version 7.5.3. 

Language Language code of the language specified for user interface translation.

User name User name (that is, the Microsoft Windows logon name) of the user who 
compiled the repository.

Repository Repository name of the repository that was current when the compilation 
was run, generally Siebel repository.

Tools version The version number and build number of the Siebel Tools software used to 
compile the repository. This is useful information for Siebel Technical 
Services if they are helping you in resolving a problem with your 
configuration.

Schema version Database schema version of the database from which the repository was 
compiled.

File name Name and path of the SRF file being used internally to define the Siebel 
Tools application, located in SIEBEL_TOOLS_ROOT\OBJECTS.

Field/Button Description
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Renaming Repositories
It is recommended that you name the repository in production Siebel Repository. However, in some 
situations you may need to name the repository something different. If you must rename the 
repository, follow the steps described in this topic.

To rename a repository

1 Have all developers check in all projects that have been checked out from the repository you are 
going to rename.

2 Log into Siebel Tools and connect to the server database.

3 In the Object Explorer, select the Repository object type. 

If the Repository object type is not visible, see “Showing and Hiding Object Types in the Object 
Explorer” on page 66 for more information.

4 In the Object List Editor, click in the Name property of the repository you want to rename.

5 Enter the new name, and click outside the record to save your changes.

6 Let developers know what the name of the new repository is and have them perform a Get of all 
projects. 

7 After changing the name of the repository, you must also do the following:

■ Change the value of the enterprise parameter Siebel Repository to the new name of the 
repository. For information about changing enterprise parameters, see Siebel System 
Administration Guide.

■ Change the Application Main Repository Name parameter in the Object Manager.

Deleting Repositories
The delete process remove all records associated with the repository. Be sure to back up the 
repository before you delete it.

CAUTION: Deleting a repository takes a long time and requires resources such as rollback segment, 
cursors, tablespace, and so on. Consult your DBA before deleting a repository.

To delete a repository

1 In the Object Explorer, navigate to the Repository Object type.

2 In the Object List Editor, click anywhere in the row for the repository you want to delete.

3 Choose Edit > Delete Record.

4 Click outside the record to commit the Delete action.
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About Exporting and Importing 
Repositories
You can export and import the entire repository using Export/Import option in the Database 
Configuration Utility. Use this utility when you want to back up your repository, restore your 
repository, or move all repository objects to another environment that shares the same physical 
database schema as the source environment.

If you do not need to export and import the entire repository, but need to export and import sets of 
objects only, use Siebel archive files. For more information, see “Exporting Objects to an Archive File” 
on page 146.

CAUTION: If you need to migrate a customized repository and schema from one environment to 
another, such as migrating a development environment to a test environment, do not use the Export/
Import option in the Database Configuration Utility. Instead, you must use the Repository Migration 
Utility (dev2prod). 

NOTE: After using the Repository Migration Utility, you must reset the Locked and Allow Object 
Locking columns.

For information on repository migration and Repository Migration Utility, see Upgrade Guide and 
Going Live with Siebel Business Applications.

Supported Source and Target Databases for Importing and Exporting 
Repositories
The source and target databases must be configured for the same Siebel version. It is not 
recommended that you migrate a repository between two databases that are on different release or 
patch levels. Siebel applications support importing and exporting repository data from the source 
databases to the target databases listed in Table 39. 

Exporting and Importing Repositories 
Using the Database Configuration Utility
To export and import the entire repository, you use the Database Configuration Utility. This is 
typically used for backing up and restoring and for moving the contents of a repository to a repository 
in an another environment, when both the source and the target environment have the same physical 
database schema and Siebel release version. 

Table 39. Code Pages and Unicode Support for Repository Import and Export

 Source Database Target Database

Code Page Code page

Unicode Unicode

Code Page Unicode
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When importing and exporting using the Database Configuration Utility, consider the following:

■ When you are importing a custom repository (not the standard Siebel repository), all languages 
which were part of the original repository are restored during import. For example, if you archive 
repositories weekly and your development repository contains support for both ENU and DEU, 
then both ENU and DEU are included when one of the archived repositories is imported.

■ Whenever you make a change to the repository, compile all projects that belong to the latest 
version of the repository to create an updated SRF file. Keep a backup of the SRF file, so you can 
be sure the SRF file truly reflects the contents of the updated repository.

■ If you need to back up the entire content of the Siebel database, use the database utilities 
provided by your RDBMS vendor.

■ If your source repository is customized use the Migrate option of the Database Configuration 
Utility. 

For more information on migrating repositories, see Going Live with Siebel Business Applications.

NOTE: When exporting a repository in a Windows or UNIX environment using the Export Repository 
option of the DB Server Configuration wizard, the log files are placed in following directories:

■ Siebel_Server\log\exprep\output

■ Siebel_Server\log\exprep\state

NOTE: The value “exprep” is the default process name for the exprep utility. You can change this 
value to facilitate ease of use.

For information on importing or exporting repositories, see “To import or export a repository in a 
Windows environment” on page 160 or “To import or export a repository in a UNIX environment” on 
page 162 depending on your operating system. 

The “To import or export a repository in a Windows environment” procedure applies to importing or 
exporting a repository, although it presents only the importing case. Exporting is similar, in that you 
identify the repository to export instead of the one to import. 

When exporting a repository using Configure DB Server, all the values specified in the dialog boxes 
are written to the SIEBEL_SERVER_ROOT\master_exprep.ucf file. After the parameters are collected, 
you are prompted to execute the export now or not. If you choose to not export now, you can execute 
the export later by running the following command in the DOS window:

siebupg.exe /m master_exprep.ucf

To import or export a repository in a Windows environment

1 Launch the Database Server Configuration Utility by choosing Start > Programs > Siebel 
Enterprise Server version_number > Configure DB Server.

The Gateway Name Server Address dialog box appears.

2 Specify your Gateway Server Address and Enterprise Server Name and then click Next.

The Installation and Configuration Parameters: Siebel Server Directory dialog box appears.
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3 In the Siebel Server Directory dialog box, either accept the default value or click Browse to select 
a directory, and then click Next.

The Installation and Configuration Parameters: Siebel Database Server Directory dialog box 
appears.

4 Either accept the default value, or click Browse to select a directory, and then click Next.

The Siebel Database Server Options: Siebel Database Operation dialog box appears.

5 In the list of operations, select Import/Export Repository and then click Next.

The Import Repository Parameters: Select Repository Operation dialog box appears.

6 Select Import Repository, and then click Next.

You can also choose the following options: Add language to an existing Repository, or Export 
Repository.

The Import Repository Parameters: Import Selection dialog box appears.

7 Select one of the following, and then click Next:

■ Select Import Standard Repository to select which language string to import. 

This option is useful when more than one base language is to be implemented.

NOTE: You can only select one language string to import.

■ Select Import Custom Repository to import all the languages found in the repository.dat file. 

The following succession of dialog boxes appears:

Dialog Box Description

Installation and Configuration 
Parameters: Language Selection

Select a language and click Next. English is the 
default language.

Installations and Configuration 
Parameters: RDBMS Platform

Select an RDBMS Platform. 

Installation and Configuration 
Parameters: ODBC Data Source Name

Select the ODBC Data Source Name.

Installation and Configuration 
Parameters: Database User Name

Select the Database User Name and Database 
Password.

Installation and Configuration 
Parameters: Database Table Owner

Select the Database Table Owner and Database 
Table Owner Password.

Installation and Configuration 
Parameters: Import Repository Name

Select the name of the repository that you want to 
import and the filename from which you are 
importing.

This will be the name given to the imported 
repository.
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8 In the Configuration Parameter Review, review the list of parameters you entered and then 
accept the configuration by clicking Finish.

To import or export a repository in a UNIX environment

1 Run the following command:

$SIEBEL_ROOT/siebenv.sh (source $SIEBEL_ROOT/siebenv.csh)

By convention, $SIEBEL_ROOT is the absolute path to the Siebel Server installation directory 
(siebsrvr).

LANGUAGE should be set to the language in which the Configuration Wizard prompts appear; for 
example, enu for U.S. English.

If either of these values is incorrect or empty, reset them using one of the following commands, 
as appropriate to the shell you use.

2 Set an appropriate level of detail in the log file for this activity.

3 Navigate to $SIEBEL_ROOT/bin and enter:

dbsrvr_config.ksh

This launches the Database Server Configuration utility.

4 When prompted for the Siebel Server installation directory, either accept the default value or 
enter a new directory.

If either the SIEBEL_ROOT or LANGUAGE value is not set or is incorrect, you must correct them 
before proceeding.

5 When prompted to select the Siebel Database Operation, select Import/Export Repository.

6 Choose Import Repository.

7 Choose Import Standard Siebel Repository or Import Custom Repository.

Shell Command

C setenv LANGUAGE New Value

Korn export LANGUAGE|SIEBEL_ROOT=New Value

Shell Command

C setenv SIEBEL_LOG_EVENTS trace3

Korn export SIEBEL_LOG_EVENTS trace3
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8 The following succession of prompts appears.

9 Review the list of parameters, and then accept the configuration by entering Y.

NOTE: You follow the same procedure for Export Repository except that you choose export instead 
of import in Step 6 on page 162.

About Repository Patch Files
A repository patch file, like an archive file, consists of exported objects. The difference between a 
patch (SPF) file and an archive (SIF) file is that the patch file contains two versions of each object, 
one from the preupgrade source repository and one from the postupgrade. An archive file contains 
only one version of each object, and all objects are from the same repository.

For information on archive (SIF) files, see “About Archive Files” on page 145.

Prompt Description

Language Selection Select a language. English is the default language.

RDBMS Platform Select an RDBMS Platform. 

ODBC Data Source Name Select the ODBC Data Source Name.

Database User Name Select the Database User Name and Database Password.

Database Table Owner Select the Database Table Owner and Database Table Owner 
Password.

Import Repository Name Select the name of the repository that you want to import and 
the filename from which you are importing.

Dialog Box Description

Language Selection Select a language and click Next. English is the default 
language.

RDBMS Platform Select a RDBMS Platform. 

ODBC Data Source Name Select the ODBC Data Source Name.

Database User Name Select the Database User Name and Database Password.

Database Table Owner Select the Database Table Owner and Database Table Owner 
Password.

Import Repository Name Select name of the repository that you want to import and the 
filename from which you are importing.

Configuration Parameter 
Review

Summary dialog box gives a list of your choices. You can accept 
the configuration by entering Y.
Using Siebel Tools Version 7.8, Rev. B 163



Managing Repositories ■ Creating Repository Patch Files
Figure 24 shows how pre- and postupgrade versions of an object are paired in the patch file, and 
then used when applying the patch to the target repository.

The pair of pre- and post-release objects in the patch file provide before and after snapshots of the 
object. The patch application process considers both when determining what changes to make to the 
target repository.

Related Topics
“Creating Repository Patch Files” on page 164

“Applying Repository Patch Files” on page 167

Creating Repository Patch Files
A wizard steps you through the process of creating a patch file.

To create a repository patch file

1 Make sure that both the original source and the modified source repositories are present on the 
client computer. 

2 If you are building a patch file from an archive file, go to Step 3; Otherwise, choose 
File > Open Repository and then select the modified source repository.

Figure 24. How a Patch Works
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3 Choose Tools > Utilities > Build Patch.

The Build Patch - Setup dialog box appears.
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4 Under Select modifications, make your selection using the following table.

5 From the Repository drop-down list, choose the name of the original source repository.

6 In the Patch File field, click Browse to specify a path name and filename for the patch file to 
create.

Option Button Description

Changed objects in current 
repository

Allows you to generate the set of source objects in the patch 
file from all objects in the currently open (modified source) 
repository that have a value of TRUE in their Changed 
property. The Changed property indicates changes to 
property values or child objects for all objects that have 
changed since a specified date. This is an easy way to capture 
all objects that have changed since the start of work on the 
new release.

NOTE: This is useful for creating cumulative patch files—that 
is, if several patches are created over time, each successive 
patch includes all the changes in the previous patches, in 
addition to the most recent changes, as long as the Changed 
Indicator Date is not modified. Keeping the Changed Indicator 
Date accurate during the patch development cycle is critical 
to accumulating all the changes applicable to the patch. 

Archive file Allows you to use an existing archive file to generate the 
same set of objects in the patch file. Use this option when the 
set of patch objects is identical to a recently exported archive 
file, or when you want to explicitly select individual top-level 
objects to be included. In this latter case, generate the 
archive file prior to generating the patch file. Building a patch 
from an archive file may also be preferable when there are 
too many objects with a Changed value of TRUE.

Use the File Name field to specify a pathname and filename 
for the archive file and click the Browse button and select the 
archive file.
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7 Click Next. 

The Build Patch - Summary dialog box appears.

If you selected the Archive file option, the list of objects for the patch loads immediately. 

If you selected the Changed objects option, Siebel Tools pauses while it generates the list 
because it needs to scan through the repository and check all the Changed property values.

8 Click Finish.

The patch file is generated in the directory location you specified in Step 4 on page 166. 

Applying Repository Patch Files
The patch upgrades the repository to which it is applied, similar to the way the Application Upgrader 
upgrades the repository. The difference is that you do not have the opportunity to override the 
default conflict resolution rules. A conflict only occurs if an object property changes in both the 
source and the target repositories simultaneously.

For example, if you create a new Account field based on an extension column in the target repository, 
and then apply a patch from the source repository that includes the Account business component, 
the new field will not be overwritten in the target repository because the same new field has not been 
added in the source.

If you change the sort specification of the Account business component in the target repository, and 
the sort specification has not changed in the source, the new sort specification in the target will 
remain. However, if the sort specification has changed in both the source and the target, then a 
conflict arises for which a resolution is required.

To view the default conflict resolution rules

1 In the Object Explorer, navigate to the Type object type.

2 In the Object List editor, select an object.

3 In the Object List Editor, expand the Type object type and select Attribute.
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4 Review the Attribute property Siebel Wins (or Standard Wins in the Object List Editor).

If this is set to TRUE, the value in the source repository is accepted. 

If FALSE, the value in the target repository is accepted.

To apply a patch

1 In Siebel Tools, choose Tools > Utilities > Apply Patch.

The Select Patch to Apply dialog box appears.

2 Select the Siebel Patch (SPF) file, and then click Open.

The Apply Patch - Preview dialog box appears, and the patch is opened.

3 Click Next.

The Apply Patch - Summary dialog box appears. The patch is loaded, the patch objects are 
compared to their corresponding repository objects, and then the patch is applied.

4 Click Finish to exit.

Upgrading Repositories
The Siebel Application Upgrader reduces the time and cost of version upgrades by allowing you to 
acquire new features from the latest release while preserving the custom configuration changes 
made to the current repository. It notifies system administrators about conflicts between object 
customizations and new releases, automatically merges differences between objects, and allows you 
to manually override and apply any changes. 

The Siebel Application Upgrader allows you to upgrade custom configurations to new releases by 
merging them with a current Siebel Business software release. This capability minimizes the cost of 
application upgrades and allows you to quickly deploy production versions of Siebel Business 
Applications. For more information, see the Upgrade Guide.

The Application Upgrader allows you to accomplish the following:

■ Determine what has changed with new releases of Siebel Business Applications

■ Compare custom configurations with new changes delivered in a new Siebel release

■ Choose which changes to apply, whether made by your company’s developers or by Oracle in the 
new release

NOTE: The Application Upgrader is for merging an entire customized repository with a standard one. 
To merge portions of repositories, use the Import/Export or Patch features.

For more information about the Application Upgrader, see Upgrade Guide.
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Locale-Specific Data
This chapter describes how to work with strings and other locale-specific data. It contains the 
following topics:

■ “About the Symbolic Strings Model” on page 170

■ “Checking In and Checking Out Symbolic Strings” on page 171

■ “Creating Symbolic Strings” on page 171

■ “Modifying Symbolic Strings to Globally Update Display Values” on page 172

■ “Using Symbolic String References” on page 173

■ “Entering String Overrides” on page 174

■ “About Converting and Consolidating Strings” on page 175

■ “About the Symbolic String Conversion Process” on page 176

■ “About the Symbolic String Consolidation Process” on page 178

■ “Running the String Conversion Utility” on page 178

■ “Running the String Consolidation Utility” on page 183

■ “Using Batch Files to Convert and Consolidate Strings” on page 186

■ “Working with Untranslatable Locale-Specific Object Properties” on page 187

■ “Showing or Hiding Locale-Specific Items in Applet Layout” on page 189

■ “Locating Orphaned String References After Upgrade” on page 190

■ “About the Locale Management Utility” on page 191

■ “Finding Untranslated Text Strings” on page 192

■ “Finding Existing Translations” on page 193

■ “Finding Modified Objects” on page 194

■ “Exporting Text Strings and Locale-Specific Attributes” on page 194

■ “Importing Text Strings and Locale-Specific Attributes” on page 195

■ “Identifying Objects Modified Since the Last Export” on page 196

■ “Replacing Strings” on page 197

■ “Running the LMU Using the Command-Line Interface” on page 198
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Model
About the Symbolic Strings Model
The symbolic strings model centralizes all strings, both English and all other languages, which exist 
in the repository into one object type: Symbolic Strings. Translatable text strings are defined once 
and then referred to by multiple user interface objects. Having a centralized mechanism for storing 
and managing repository text strings:

■ Reduces redundancy because many objects can reference one symbolic string

■ Results in a more consistent user interface

■ Simplifies maintenance because you only have to maintain one string for a given word

■ Simplifies translation by eliminating duplicated translations of the same word

■ Reduces translation costs

Prior versions of Siebel Tools stored translatable text strings in the locale objects of a parent object 
type. For example, each applet had a set of child locale records that defined the text for the applet 
title that appears in the user interface.

How the Symbolic Strings Model Is Implemented
Symbolic strings are implemented using a top-level object in the Siebel repository called Symbolic 
Strings and a child object called Symbolic String Locale. Each symbolic string record represents a 
word or phrase, for example Account or Contact, and is language independent. All translations of 
that word or phrase, including English, are stored as child symbolic string locale records. User 
interface objects, such as Applets and Controls, refer to symbolic string records for text strings. The 
literal display value is compiled into the SRF from one of several translations stored as symbolic 
string locale records, based on the current Tools language mode.

The Symbolic Strings object type stores its data in S_SYM_STR table, and the Symbolic String Locale 
stores its data in S_SYM_STR_INTL table. Objects such as applets store foreign key references to 
the records stored in S_SYM_STR table. 

Strings Not Included in the Symbolic Strings Model
The symbolic strings model includes text strings stored in the repository and referenced by UI objects 
such as Control Captions, List Column Display Names, and Applet Titles. The symbolic string model 
does not include other types of strings typically supplied as seed data, such as LOVs, error messages, 
and predefined queries. 

For information on localizing these types of strings, see “About the Locale Management Utility” on 
page 191.

How Translatable String Values Are Calculated
Object properties that display translatable strings, such as the Title property of applets, are compiled 
into the SRF file during compile time according to the following logic: 

■ If a value exists in the string language in which the compile is being run, this string override 
value is compiled to the SRF. 
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■ The compile process checks to see whether a value exists in the string override field for the 
current Siebel Tools Language Mode. If there is no string value in the override field for the 
language in which the compile is being run, the value is calculated using the current language 
mode of Siebel Tools and the String Value property of the associated Symbolic String Locale 
object (child of Symbolic String). 

NOTE: In most cases, a string override does not exist.

Related Topic
“Entering String Overrides” on page 174

Checking In and Checking Out Symbolic 
Strings
The Symbolic String project is very large. Due to its size, checking in or checking out the entire 
project can be very time consuming. Thus it is not recommended that you check out the entire 
Symbolic String Project, rather, create a new project, and store all new or modified strings in that 
project.

When you want to add and work on new strings, create a new project (for example, CompanyXYZ 
New Symbolic String project) and put all your new strings in that project.

NOTE: When you create strings, they will be prefaced with the value specified in the tools.cfg file 
under the SymStrPrefix attribute. This value is set to X_ by default. For example, if you create a new 
symbolic string called NewString it will appear as X_NewString.

To modify existing strings within the Siebel repository, (denoted by the “SBL_” prefix in the Symbolic 
String Name attribute), create a new project (for example, CompanyXYZ Modified SBL_ Symbolic 
String project), select the strings you wish to modify, and put them into the new project you just 
created. This work can be facilitated by selecting the strings, then filtering out the strings you want 
to modify. You can then make a global change to the project attribute with the Change Records 
command on the Edit menu. 

CAUTION: Modifying display values for Siebel-shipped (“SBL_” prefixed strings) must be carefully 
considered as the display values are used globally across the Siebel user interface. For monolingual 
deployments, you risk modifying parts of the user interface you may not intend to modify. For 
multilingual deployments, you risk breaking associations between display values across languages. 
For this reason, it is recommend that you create a new Symbolic String with your desired text value 
as opposed to modifying existing strings.

Creating Symbolic Strings
You create new symbolic strings in Siebel Tools. Symbolic strings created by Siebel are included in 
the Symbolic Strings project. It is recommended that you create a new project to hold all custom 
symbolic strings.

NOTE: To be able to create symbolic strings, the EnableToolsConstrain parameter in the tools.cfg file 
must be set to FALSE.
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To create a symbolic string

1 Check out the project in which you want to create the Symbolic String.

2 Navigate to the Symbolic Strings object type.

3 In the Object List Editor, create a new record using the following table to complete the necessary 
fields.

Related Topic
“Setting the Constrain Mode for Working with Symbolic Strings” on page 68

Modifying Symbolic Strings to Globally 
Update Display Values
You can make global changes to UI display values by modifying child locale objects of symbolic 
strings. For example, your organization may require that all instances of the word Account be 
changed to Customer. Another example is configuring an industry-specific application to be deployed 
in a locale other than English. Text strings may appear in the UI that are not appropriate for the given 
industry. In both cases, you need to make global changes to text strings. 

To globally update user interface display values

1 Set your Tools Language mode to the language you want to configure.

For more information, see “Selecting a Language Mode” on page 53.

2 Navigate to the Symbolic String object type.

3 Select the symbolic string you want to modify.

4 Navigate to the Symbolic String Locale object you want to modify.

5 Change the value for the String Value property.

6 Compile the project or projects associated with the Symbolic String.

Property Description

Name Unique name of the symbolic string. Siebel Tools enforces a predefined 
prefix for the symbolic string name, such as X_. This helps you distinguish 
custom symbolic strings from those created by Siebel (SBL_). The value 
used for the prefix is defined in the SymStrPrefix parameter in the tools.cfg 
file. 

Current String 
Value

Calculated value based on the current Tools language mode and the String 
Value property of the corresponding child Symbolic String Locale object. 

Definition Description of the symbolic string.
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Using Symbolic String References
Symbolic string references allow you to select translatable strings for properties such as Applet titles, 
or Application display names, from a centralized list of strings. There are two ways you can associate 
objects to symbolic string references. You can use the String Reference pick applet or you can type 
directly into the field that displays a translatable text string value.

To select a symbolic string reference using the String Reference pick applet

1 Navigate to the object and property for which you want to define a string, such as Applet Title.

2 Navigate to the Title - String reference field (in the Object List Editor) or the Title field (in the 
Properties window). 

NOTE: The string reference field name can vary, depending on the object you are working on. 
For instance, with the Applet object, the name is displayed in Siebel Tools as described above, 
but with the Application object, the fields are shown as Display Name - String Reference in the 
Object List Editor, and Display Name in the Properties window. 

3 Click the drop-down arrow in either field.

A String-Reference picklist appears. 

4 Search for the appropriate string reference, select it, and then click Pick.

After you associate the string reference, the display value is entered based on the current Tools 
language mode and the Current String Value of the corresponding symbolic string locale record.

If no existing symbolic strings meet your needs, do one of the following:

a Using the Object List Editor, close the pick applet, and enter the string override into the Title - 
String Override field.

b Using the Properties window, click the Use Override button in the pick applet, and focus is shifted 
to the corresponding String Override field in the Properties window. 

To select a symbolic string reference by typing a value into the Object List Editor

1 Navigate to the object and property for which you want to define a string, such as the Title field 
in the Applet object, or the Display Name field in the Application object.

2 Type a value into the field, then tab out of the field.

Siebel Tools searches for a string reference with a Current String Value that matches the value 
entered and one of the following occurs: 

■ If one unique match exists, that string reference is associated with the object and the display 
value is entered based on the current Tools language mode and the Current String Value of 
the corresponding symbolic string locale record.

■ If there are multiple exact matches, or a match does not exist, an error message appears. 
Click OK, and do the following: 

a Click the drop-down arrow in the String References field.

The String References picklist appears. 
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b Select the appropriate reference from the picklist, then click Pick. 

You may also create a new string reference or create an override. 

NOTE: To be able to create symbolic strings or enter values for string override properties, the 
EnableToolsConstrain parameter in the tools.cfg file must be set to FALSE. 

To select a symbolic string reference by typing a value into the Properties window

1 Navigate to the object and property for which you want to define a string, such as the Title field 
in the Applet object, or the Display Name field in the Application object.

2 Type a value into the field, then tab out of the field.

Siebel Tools searches for a string reference with a Current String Value that matches the value 
entered and one of the following occurs: 

■ If one unique match exists, that string reference is associated with the object, and the display 
value is entered, based on the current Tools language mode and the Current String Value of 
the corresponding symbolic string locale record.

■ If there are multiple exact matches, or a match does not exist, the String Reference picklist 
appears, allowing you to choose the appropriate record. 

You may also create a new string reference or create an override. 

NOTE: To be able to create symbolic strings or enter values for string override properties, the 
EnableToolsConstrain parameter in the tools.cfg file must be set to FALSE. 

Related Topics
“Creating Symbolic Strings” on page 171

“Entering String Overrides” on page 174

“Setting the Constrain Mode for Working with Symbolic Strings” on page 68

Entering String Overrides
Each object property that stores a translatable text string, such as the Title property of an applet, 
has a corresponding String Override field, for example Title – String Override. In cases where the 
symbolic string for a given word or phrase does not meet your linguistic requirements, you can 
override it by entering a value in the override field. Values entered into override fields are stored as 
child locale objects of the top-level object type (for example applet) for the current Tools language 
mode. Values stored in string override fields are language-specific and do not affect other references 
to the symbolic strings.

NOTE: To be able to enter string overrides, the EnableToolsConstrain parameter in the tools.cfg file 
must be set to FALSE.

To enter a string override

1 Navigate to the object and property for which you want to enter a translatable text string.
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2 In the string override field, enter the string.

The value entered in the string override property is stored as a child locale record and the value 
automatically populates the translatable text string field, such as the Title property for an applet.

Related Topics
“Setting the Constrain Mode for Working with Symbolic Strings” on page 68

About Converting and Consolidating 
Strings
The string conversion and consolidation processes allows you to covert translatable strings stored as 
child locale records of top-level object types to the symbolic strings model. The symbolic strings 
model stores strings in a centralized table. 

CAUTION: Conversion and consolidation operations are highly intensive processes, and thus require 
a 1 GHz computer or higher. 

Convert and consolidate are useful for customers who:

■ Have upgraded to version 7.8 and have custom translatable text strings that they want to 
migrate to the symbolic strings model.

■ Use string overrides to store text strings and periodically want to convert and consolidate them 
to the symbolic strings model.

When considering whether to convert strings to the symbolic strings model consider the following:

■ Migrating to the symbolic string model reduces the size of repository, makes translations easier, 
and gives you more control over terminology consistency. 

■ The conversion and consolidation processes require that development be frozen and can require 
substantial processing time. 

Related Topics
“About the Symbolic Strings Model” on page 170

“Entering String Overrides” on page 174

“About the Symbolic String Conversion Process” on page 176

“About the Symbolic String Consolidation Process” on page 178
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About the Symbolic String Conversion 
Process
The String Conversion process is comprised of three distinct logical operations. First, new Symbolic 
String records along with their Symbolic String Locale child records, are generated based on the 
string values found in the target objects. Next, the String Reference fields of the target object 
records are set to the names of the new Symbolic Strings. Finally, the string fields in the locale 
records of the target objects are nullified, and, where appropriate, the locale records themselves are 
deleted.

This process is performed in two separate phases—the preparatory Conversion Export phase, 
followed by the lengthier Conversion Import phase, where the data changes actually occur.

The String Conversion process does the following: 

■ Generates new symbolic string records and their corresponding symbolic string locale records 
using string values found in target objects. 

NOTE: The conversion process runs on an object type by object type basis. Because of this, there 
are likely to be duplicate symbolic strings for a given display value. Duplicates are “de-duped” 
during the consolidation process.

■ Sets the String Reference fields of the target object records to the names of the new symbolic 
strings. 

■ Nullifies the string fields in the locale records of the target objects and, where appropriate, 
deletes the locale records.

The conversion process occurs in two phases: the conversion export phase, in which data is prepared 
for conversion, followed by the conversion import phase, in which data changes actually occur.

NOTE: An SRF file compiled before the conversion process will be the same as an SRF file compiled 
after the conversion process. For example, suppose a given applet gets its Title property from a child 
Applet Locale record. When the conversion process is run, it creates a symbolic string, places the 
reference for that symbolic string in the applet Title - String Reference field, and then removes the 
Applet's locale record(s). Now, after the conversion, the applet’s title is derived from the symbolic 
string. However, the Title itself, the display value that is complied to the SRF, is the same as it was 
before the conversion. The reason is that the strings are complied into object definitions and read 
from the SRF file, not referenced from the Symbolic String table during run time.
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Conversion Export
The Conversion Export process identifies records that are candidates for Conversion, and then writes 
all the relevant information to a file. This process is run on an object type by object type basis, and 
can be run against any object type that has translatable strings (for example, controls, list columns, 
and applets). 

NOTE: The Conversion process has to be executed once for each Object Type (both Top-Level and 
Sub-Level Object Types) in the repository that has properties that reference Symbolic Strings. In 
order to determine what Object Types refer to Symbolic Strings, click the Flat Tab in the Object 
Explorer, navigate to Attribute, and search for the string “*String Reference*” in the Name property. 
The Parent Type of the results set is the complete set of object types for which the conversion has 
to be run. Some object types have more than one attribute that refers to Symbolic Strings; for such 
object types, it is necessary to run the conversion process only once. 

The conversion process begins by creating a sorted list of English (ENU) child records for each 
translatable string within a given object type. For those object types with multiple translatable 
strings (such as list columns that have a Display Name and Prompt Text), each is processed 
sequentially. This list is used to generate information about the new symbolic strings. Among sets of 
records with identical ENU translations, the non-ENU records are compared and, where possible, the 
same symbolic string is reused for subsequent records. The output file produced contains information 
about the new symbolic strings, including all the language translations for each, as well as which 
strings will be used as replacements.

NOTE: The Conversion Export file is not a log file so there is no need to review its contents.

Conversion Import
Based on the file produced by the conversion export process, the conversion import process performs 
the changes to the database (inserts, updates, and deletes) that convert the object records to use 
the new symbolic strings. Logically, the process consists of three operations, the end result of which 
is the production of symbolic string and symbolic string locale records, and the deletion of other 
types of locale records. The three operations are:

■ New symbolic string records are created in the database. The export file contains all the 
information about the string, including a unique name and information about each of its locale 
children.

■ References to the new symbolic string records are placed into the relevant fields of the original 
objects. For example, suppose you have 10 applets whose title is My Service Requests. Assuming 
the non-ENU values for all the titles are the same, then the export file contains information about 
one new symbolic string, and instructions for each of the 10 applets to use this new symbolic 
string as its title. After creating the symbolic string record for a string whose ENU value is My 
Service Requests, the Title - String Reference property for each of the 10 applets is set to the 
name of the new symbolic string. At this point, each of the Applets has a String Reference in 
addition to the String Override. The String Override is now superfluous and can be removed. This 
is done by clearing that value from the object Locale children.

■ Records are deleted for which there is no longer any information in the object locale records. 
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About the Symbolic String Consolidation 
Process
The consolidation process eliminates duplicate symbolic strings that may be created during the 
conversion process. Because the conversion process runs on an object type by object type basis, 
duplicate records can, and usually do, occur when the process creates different symbolic strings for 
a display value that occurs in multiple object types. Duplicate symbolic strings can have identical 
sets of locale records or one symbolic string may have more child locale records than the other, but 
the ones they have in common are identical.

CAUTION: File and Object command-line parameters for conversion or consolidation processes are 
case sensitive. However, all other command-line parameters for conversion and consolidation are not 
case sensitive. 

Consolidation Export
The Consolidation Export process scans all symbolic string records and identifies symbolic strings 
whose child records are identical and then writes this information to a file. For symbolic strings that 
have identical child records, one of the strings will be selected arbitrarily as the master record. For 
symbolic strings whose child records are a subset of another symbolic string, the string with the 
largest number of children is selected as the master record. The export process does not modify the 
database.

NOTE: The Consolidation Export file is not a log file so there is no need to review its contents.

Consolidation Import
Based on the file produced during consolidation export process, the redundant symbolic strings are 
eliminated, and all references to these strings from other object types are replaced with a reference 
to the master record. This is a time-consuming process, as there are approximately 80 translatable 
string attributes represented among the various object types in the repository. The end result, 
however, is that the symbolic string table is as compact as possible, and all redundancy has been 
removed.

Running the String Conversion Utility
The conversion process is implemented as a business service. You run it using the Consoleapp.exe 
utility, located in the SIEBEL_TOOLS_ROOT\BIN directory of your Siebel Tools installation directory.

Prior to running the conversion:

■ Make sure you have backed up your database and your repository.

■ Make sure all of the projects are unlocked. While conversion and consolidation are running, no 
other users should be allowed to log on to the development environment.

■ Make sure that the DataSource parameter in the [Siebel] section is the desired database. The 
conversion utility uses this database. 

■ Make sure that the EnableToolsConstrain parameter in the [Siebel] section is set to FALSE.
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■ Make sure that the SymStrPrefix parameter in the [Siebel] section of the tools.cfg file is set to 
the desired prefix. This value is used as the prefix to the name of all newly created symbolic 
strings. It is set to X_ by default, to indicate that it was created by you and not by Siebel (SBL_).

Topics in This Section
“Parameters for Running Consoleapp.exe to Convert Strings” on page 179

“Exporting Candidates for Conversion” on page 179

“Splitting Conversion Export Files into Smaller Files” on page 181

“Importing Converted Symbolic Strings” on page 181

Parameters for Running Consoleapp.exe to Convert 
Strings
The parameters for running Consoleapp.exe to convert existing locale strings to symbolic strings are 
shown in Table 40. The format is:

Consoleapp.exe <Config file> <app lang> <uid> <pw> <Business Service> <Method Name: 
Parameters> 

Table 40 lists the parameters and the descriptions.

Exporting Candidates for Conversion
Follow the procedure below to export candidates for conversion.

Table 40. Parameters for Running Consoleapp.exe to Convert Strings

Parameter Description

Config file The Siebel configuration file, such as Tools.cfg. Note that the default data 
source is used.

app lang Application language, such as ENU

uid User ID

pw Password

Business Service “String Conversion”

Method Name: 
Parameters

Business Service method and the input parameters
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To export conversion candidates for a given object type
■ Launch Consoleapp.exe as described in “Parameters for Running Consoleapp.exe to Convert 

Strings” on page 179, and use the ConversionExport business service method with the 
parameters listed in Table 41. 

For example:

“ConversionExport: Filename=Control.txt, Repository=Siebel Repository, Object=Control, 
LogFile=ControlExport.log, Language=ENU, MatchMin=1"

Table 41. Input Parameters for the ConversionExport Business Service Method

Parameter Required? Description

Filename Y The name of the export file.

Repository Y The Siebel Repository name. 

NOTE: The repository name is case sensitive.

Object Y The Siebel object type whose strings are exported, for example, 
Control.

NOTE: The object name is case sensitive.

LogFile N  The name of the log file.

Language N The language used as the primary language to match when 
searching for duplicate symbolic strings. For example, suppose 
two symbolic strings each have three child records, an English 
(ENU), a French (FRA) and a German (DEU) record. If the 
Language parameter is set to ENU, then the conversion export 
process searches for matches between the ENU records. When 
it finds matches, it checks the other child records of the other 
languages. If all child records match (or if one has a superset 
of the other), they are considered matching symbolic strings.

MatchMin N The minimum number of matches in a set of matching symbolic 
strings before it is written to the file. The default value is 2.

SQLLog N The SQL log file name. When this parameter is set, the 
conversion process logs all SQL that is executed to the specified 
file.

ExcludeNull N True/False value. When set to true, it excludes null value for 
conversion consideration. Default value is True.

UseFullMatch N True/False value. When set to true, records are matched against 
all the other possible match candidates before they are 
discarded. Default is True.
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Splitting Conversion Export Files into Smaller Files
After you generate an export file, you can split the file into smaller, more manageable files. This is 
beneficial for object types such as Control, because it could have up to 130,000 records. To improve 
performance, you can import multiple consolidation files, of either the same object type or of 
differing types, simultaneously. 

NOTE: An average desktop can typically run about only 10 simultaneous conversion import 
processes. 

To split an export file into smaller files
■ Launch Consoleapp.exe as described in “Parameters for Running Consoleapp.exe to Convert 

Strings” on page 179 and use the SplitFile business service method with the parameters listed in 
Table 42. 

For example:

"SplitFile: Filename=Control.txt, Lines=2000"

Importing Converted Symbolic Strings
You initiate the import process using the parameters listed in Table 43 on page 182.

UseExactMatch N A true or false value. When set to true, records are considered 
as match only when they all the same amount of language 
records and for each of the language, they have the same 
values. That's Conversion won't consider partial match. The 
default value of this parameter is False.

SkipInactive N A true or false value. When set to true, the conversion process 
skips all records with the Inactive property =Y. Default value is 
True.

Table 42. Input Parameters for the SplitFile Business Service Method

Parameter Required Description

Filename Y Export file.

Lines Y Approximate number of lines in each file. The application does 
not break up a set of symbolic strings, so the number of lines 
may not match this parameter exactly.

Table 41. Input Parameters for the ConversionExport Business Service Method

Parameter Required? Description
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To import symbolic strings
■ Launch Consoleapp.exe as described in “Parameters for Running Consoleapp.exe to Convert 

Strings” on page 179, and use the SplitFile business service method with the parameters listed 
in Table 43.

For example:

"ConversionImport: Filename=Control.txt, Repository=Siebel Repository, 
LogFile=ConversionImport.log, UnlockProjects=false, SkipParentUpdates=true, 
Project=Symbolic Strings"

Table 43. Input Parameters for the Conversion Import Business Service Method

Parameter Required Description

Filename Y Import file.

Repository Y Siebel Repository name.

LogFile N Log file.

UnlockProjects N True/False value. When set to true, the conversion 
business service unlocks all projects when the process 
finishes. This is useful when there are multiple instances 
of the conversion service running against the same DB. 
The default value is true. 

SkipParentUpdates N True/False value. When set to true, parent objects, such 
as the project of the top-level objects being updated, are 
not updated to use the symbolic string. The default value 
is false.

SQLLog N Log file name. When this parameter is set, the process 
logs all SQL that is executed to the specified file.

Project Y Name of the project in the Repository that contains the 
newly-created strings. Siebel-delivered strings are in the 
Symbolic Strings project. You may want to configure this 
for their custom strings

DeleteLocales N True/False value. When set to true, locale records are 
deleted if all translatable fields are NULL and no language 
override field is set. When set to false, the locale record 
is set to Inactive. Default value is True.

CheckTranslateFlag N True/False value. When set to true, the Conversion Import 
process does not convert objects that have the Translate 
field set to N. Default value is True.

LogErrorRecords N If set to true, all error records are be exported into a 
separate log file. Default value is False.
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Running the String Consolidation Utility
After locale strings have been converted to symbolic strings, you can use the consolidation utility to 
find duplicate symbolic strings and merge them and their references into a single symbolic string. 

The consolidation process is implemented as a business service. You run it using the Consoleapp.exe 
utility, located in the SIEBEL_TOOLS_ROOT\BIN directory of your Siebel Tools installation directory.

Topics in This Section
“Parameters for Running Consoleapp.exe to Consolidate Strings” on page 183

“Exporting Matching Symbolic Strings” on page 183

“Splitting Consolidation Export Files into Smaller Files” on page 185

“Importing Consolidated Strings” on page 185

Parameters for Running Consoleapp.exe to Consolidate 
Strings
The parameters for running Consoleapp.exe to consolidate duplicate symbolic strings are listed in 
Table 44. The format is as follows:

Consoleapp.exe <Config file> <app lang> <uid> <pw> <Business Service> <Method 
Name:Parameters>

Exporting Matching Symbolic Strings

To export a file containing all matching symbolic string sets use the Consolidation Export method of 
the business service. The parameters are shown in Table 45 on page 184.

Table 44. Parameters for Running Consoleapp.exe to Consolidate Strings

Parameter Required Description

Config file Y Name of the Siebel Config file, such as Tools.cfg. Please 
note the default data source will be used.

app lang Y The application language, such as ENU.

uid Y User ID.

pw Y Password.

Business Service Y String Consolidation.

Method 
Name:Parameters

Y Business Service method and the input parameters. 
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To export matching symbolic strings
■ Launch Consoleapp.exe as described in “Parameters for Running Consoleapp.exe to Convert 

Strings” on page 179 and use the Consolidation Export Business Service method with the 
parameters listed in Table 45.

For example:

"ConsolidationExport:Filename=ConsExp.txt,Repository=Siebel 
Repository,LogFile=ConsolidationLog.txt,Language=ENU,MatchMin=2"

Table 45. Parameters for the Consolidation Export Business Service Method

Parameter Required Description

Filename Y The name of the export file.

Repository Y The Siebel Repository name.

LogFile Y The name of the log file.

Language Y The language used as the primary language to match when 
searching for duplicate symbolic strings. For example, 
suppose two symbolic strings each have 3 child records, an 
English (ENU), a French (FRA) and a German (DEU) record. If 
the Language parameter is set to ENU, then the consolidation 
export process searches for matches between the ENU 
records. When it finds matches, it checks the other child 
records of the other languages. If all child records match (or 
if one has a superset of the other) they are considered 
matching symbolic strings.

MatchMin Y The minimum number of matches in a set of matching 
symbolic strings before it is written to the file. The default 
value is 2.

SkipSBLStrings Y Possible values are True, False, or Master Only.

When set to True, all strings starting with SBL_ in the name 
are ignored.

When set to False, Siebel strings can be considered as master 
or deprecated strings. All Siebel and customer strings are 
included in consolidation. 

When set to Master Only, Siebel strings are not deprecated, 
but can be used as Master strings. 

Default value is True.
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Splitting Consolidation Export Files into Smaller Files
When an export file is generated, you can split up into smaller, more manageable files. This is 
beneficial if you have exported a large number of symbolic strings and wish to import them in parallel 
running applications.

To split the consolidation export files into smaller files
■ Launch Consoleapp.exe as described in “Parameters for Running Consoleapp.exe to Consolidate 

Strings” on page 183 and use the SplitFile business service method with the parameters listed in 
Table 46.

For example:

"SplitFile:Filename=ConsExp.txt,Lines=100"

Importing Consolidated Strings
You execute the import process using the parameters listed in Table 47 on page 185.

To import consolidated strings
■ Launch Consoleapp.exe as described in “Parameters for Running Consoleapp.exe to Consolidate 

Strings” on page 183 and use Consolidation Import business service method with the parameters 
listed in Table 47.

For example:

"ConsolidationImport:Filename=ConsExp.txt,Repository=Siebel 
Repository,LogFile=ConsolidationLog.txt,UnlockProjects=false,SkipParentUpdates=true”

Table 46. Parameters for the SplitFile Business Service Method

Parameter Required Description

Filename Y Export file

Lines Y Approximate number of lines in each file. The application does not 
break up a set of symbolic strings, so the exact number of lines 
may not match the value specified with this parameter.

Table 47. Parameters for Consolidation Import Business Service Method

Parameter Required Description

Filename Y Import file name.

Repository Y Siebel Repository name.

LogFile Y Log file name.
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Using Batch Files to Convert and 
Consolidate Strings
The conversion and consolidation utilities can be run from two batch files found in the 
SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation directory. These batch files 
handle conversion and consolidation export, file split, and import. All parameters except the 
parameters listed in Table 48 and Table 49 are set in the batch file. For information about how to run 
the batch files, see the topics below, and see comments in the batch files themselves.

Topics in This Section
“Conversion Batch File” on page 186

“Consolidation Batch File” on page 187

Conversion Batch File
The parameters for running the conversion batch file, strconv.bat, are listed in Table 48. 

Example: strconv "Object_Type" Action User_ID Password

UnlockProjects N True/False value. When set to true, the consolidation 
business service unlocks all projects it had locked. This is 
useful if there are multiple instances of the consolidation 
service running against the same DB. The default value is 
True.

SkipParentUpdates N This turns on or off the updating of parent objects, like the 
project, while updating symbolic string references or 
while deleting deprecated symbolic strings. This should 
only be used when the user is running multiple instances 
of the import simultaneously. If left on with multiple 
instances running some errors may result in which 
updates or deletes are aborted because the project was 
being updated by another instance at the same time.

SQLLog N Log file name. When this parameter is set, the process 
logs all SQL that is executed to the specified file.

Table 47. Parameters for Consolidation Import Business Service Method

Parameter Required Description
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CAUTION: If your Siebel Tools install path contains spaces, the strconv.bat file will return errors. To 
ensure the batch file functions properly your Siebel Tools install path must not contain spaces, or, if 
your install path does contain spaces, you must enclose the path with quotes. 

Consolidation Batch File
The parameters for running the consolidation batch file, strcons.bat, are listed in Table 49. 

Example: strcons Action User_ID Password

Working with Untranslatable Locale-
Specific Object Properties
User interface conventions can vary by locale. For example, one locale may require a different 
sequence of fields than another locale. 

Table 48. Batch File Parameters for Running Conversion Export

Parameter Description

strconv.bat Conversion export, file split, and import batch file.

Object_Type Object type to be converted, for example, Applet, Control, List Column, and 
so on.

Action The options are export or import. When set to export, the conversion process 
will export all convertible locale records. When set to import, the conversion 
process will import the file or files designated by the Object_Type parameter.

User_ID The user name used to log in to the Siebel application.

Password The user’s password.

Table 49. Batch File Parameters for Running Consolidation

Parameter Description

strcons.bat Consolidation export, file split, and import batch file.

Action The options are export or import. When set to export, the consolidation 
process exports all convertible locale records. When set to import, the 
consolidation process imports the files in the working directory designated by 
the TEST_LOCATION parameter set in the batch file. 

User_ID The user name used to login to the Siebel application.

Password The user’s password.
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Locale-specific object properties can be translatable, such as text strings, or non-translatable, such 
as the HTML Sequence, HTML Height, and HTML Width properties of controls. You can configure non-
translatable object properties for specific locales by running Siebel Tools in Language Override mode. 
The Language Override mode allows you to store non-translatable, locale-specific properties as child 
locale records of the parent object. 

For example, your Siebel enterprise contains five languages: Japanese (JPN) and four Western 
European languages. As opposed to Western European, Japanese does not features middle names, 
and name order is last name first. In order to configure this, you would use Siebel Tools to set the 
language to JPN, then set Enable Language Override to ON, then hide the middle name (by setting 
the “Title-String Override” attribute to false), and then rearrange the first and last name to be last 
and first. After compiling into the JPN.serf file, the layout will match the requirement.

CAUTION: If you delete a control or a list column from a web template, it will be deleted from all 
languages, even if you are in Language Override Mode. You hide and show fields through the 
Properties window of the specific object. For information, see “Showing or Hiding Locale-Specific Items 
in Applet Layout” on page 189.

If, however, the Japanese user of Tools did all of the above, but did not enable language override, 
the next time a user compiled any of the Western European languages, the names would be 
formatted in the Japanese fashion, that is no middle name, and last name first. 

NOTE: Siebel Tools does not need to be in Language Override mode to enter string overrides.

To configure untranslatable locale-specific object properties

1 Choose View > Options and then click the Language Settings tab.

2 Set the Tools Language Mode to the language you want to configure and select the Enable and 
use Language Override check box.

3 Navigate to the object type you want to modify.

4 Modify the object properties or work in the layout editor to define locale specific values.

Related Topics
“Selecting a Language Mode” on page 53

“Enabling Language Overrides” on page 53

“Getting Locale-Specific Data Only” on page 75

“About the Symbolic Strings Model” on page 170

“Entering String Overrides” on page 174

“Showing or Hiding Locale-Specific Items in Applet Layout” on page 189
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Showing or Hiding Locale-Specific Items 
in Applet Layout
When working with multiple languages, you may wish to show or hide certain fields based on the 
requirements of a particular locale. You hide controls or list columns using the Visible and Show in 
List properties of the Control and List Column object types, respectively, not in the web templates. 

NOTE: Deleting a control or list column object from the applet layout in the Applet Layout Editor will 
cause that control or list column to be deleted across all languages, even if you are in Language 
Override Mode. 

After setting up your parent language you can then determine the fields you wish to hide for your 
child languages. Table 50 lists the object types, the property names, and provides a description. 

To hide an object for a specific locale

1 In the Object Explorer, choose Applet, then choose one of the following child objects:

■ Control

■ List > List Column

2 Select the specific object.

3 In the Properties window, navigate to one of the following properties:

■ For Control object: Visible-Language Override.

■ For List Column object: Show In List.

See Table 50 for property settings.

Table 50. Objects That Allow Show Override

Object Property Description

Applet > Control Visible Parent setting. Setting this property to TRUE 
will show this control to the user, in the parent 
language and in all other supported languages.

Visible-Language 
Override

Child setting. When operating in Language 
Override Mode, you set this property to:

■ FALSE to hide the column from the user.

■ TRUE to show the column to the user. Also, 
if the parent setting is TRUE you may just 
leave this setting blank, as it will default to 
the parent setting.
Using Siebel Tools Version 7.8, Rev. B 189



Working with Strings and Other Locale-Specific Data ■ Locating Orphaned String 
References After Upgrade
Locating Orphaned String References 
After Upgrade
Upgrades from one release of Oracle’s Siebel Business Applications to another release may result in 
the “disappearance” of certain string references. The Fix Strings Utility allows you to locate these 
orphaned strings, and update them with new references. This process is run as a business service 
through the Consoleapp.exe utility, located in the SIEBEL_TOOLS_ROOT\BIN directory of your Siebel 
Tools installation directory.

You find and report orphaned string references in the Siebel repository using the following procedure.

To locate orphaned string references
■ Launch Consoleapp.exe, and use the Siebel Tools Fix String References business service and the 

FixStringReferences business service method with the parameters listed in Table 51. 

For example:

consoleapp <config file> <language> <user> <password> <Siebel Tools Fix String 
References> <FixStringReferences>:<properties>

Applet > List > List 
Column

Show in List Parent setting. Setting this property to TRUE 
will show this list to the user, in the parent 
language and in all other supported languages.

Show in List-
Language 
Override

Child setting. When operating in Language 
Override Mode, you set this property to:

■ FALSE to hide the column from the user.

■ TRUE to show the column to the user. Also, 
if the parent setting is TRUE you may just 
leave this setting blank, as it will default to 
the parent setting.

Table 51. Parameters for FixStringReferences Business Service Method

Parameter Required Description Default Value

Repository Y The Siebel repository name to fix or 
report invalid string references.

LogFile Y The name of the log file. The log file 
is written to the current working 
directory. An explicit log file path 
may also be entered.

Table 50. Objects That Allow Show Override

Object Property Description
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Examples
This command example shows how you run the utility for the object type Business Service, and write 
information to the fixstrings.log directory, and progress to the command window:

consoleapp SIEBEL_TOOLS_ROOT\bin\enu\tools.cfg ENU jgolding db2 "Siebel Tools Fix 
String References" "FixStringReferences:Repository=Siebel 
Repository,LogFile=fixstrings.log,FixReferences=false,VerboseOutput=true,Object=Bu
siness Service"

This command example shows how you run the utility on all object types, write the results to 
temporary fixstrings.log file:

consoleapp SIEBEL_TOOLS_ROOT\bin\enu\tools.cfg ENU jgolding db2 "Siebel Tools Fix 
String References" "FixStringReferences:Repository=Siebel 
Repository,LogFile=d:\temp\fixstrings.log,FixReferences=false"

About the Locale Management Utility
The Locale Management Utility (LMU) in Siebel Tools helps you manage the process of localizing text 
strings, such as field labels, and other locale-specific attributes, such as the height and width of 
controls. You use the LMU to export text strings to a file, then after the strings in the file have been 
translated or modified, you can use the LMU to import the translated strings back into the repository. 
The LMU also provides search and comparison tools.

NOTE: When importing XML Localization Interchange Field files (.xlf) with the LMU, make sure you 
have a working internet connection at the time of import.

You use the Locale Management Utility to:

■ Find strings that need to be translated.

FixReferences N Set to TRUE to fix invalid references. 
Set to FALSE to have invalid 
references committed to the log file. 

FALSE

Object N The Siebel object type, such as 
Applet, for which you wish to find 
invalid string references. If this 
parameter is not present, invalid 
string references will be found for all 
Siebel object types. 

VerboseOutput N If TRUE, progress information is 
written to the command window. If 
false, no progress information is 
written to the command window. See 
the following examples.

FALSE

Table 51. Parameters for FixStringReferences Business Service Method

Parameter Required Description Default Value
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■ Find existing translations to use for untranslated strings.

■ Export strings and locale-specific attributes to a file (.txt or.xlf) for localization.

■ Import strings and locale-specific attributes from a file back into the repository.

■ Search for strings and locale-specific attributes that have changed since the last export.

■ Compare objects in the repository to the objects stored in the export file.

Finding Untranslated Text Strings
You use the Locale Management Utility to find text strings in the repository that have not been 
translated or need to be retranslated, because the source string has changed since the last 
translation. 

NOTE: The LMU performs search and comparison functions at the object level, not the attribute 
level. Therefore, if a locale object contains multiple string attributes, the search function returns all 
strings contained in the locale object, even if only one of them has been translated.

To find and export untranslated strings

1 Choose Tools > Utilities > Locale Management.

The Locale Management dialog box appears.

2 In the Options tab, under Languages, select the source language and the target languages.

3 Under Objects, select the applications or projects that you want to localize.

4 Click the Untranslated Strings tab.

5 To display strings that have been marked as Redo, select the Report string attributes of objects 
marked with 'redo' flag check box.

The Redo flag is marked when a record in the repository has been changed since the last time 
export occurred and therefore may need to be translated again.

For more information about Redo, see “Identifying Objects Modified Since the Last Export” on 
page 196.

6 Click Find Strings.

The Locale Management Utility searches through the string attributes of objects in the selected 
applications or projects and displays the ones that have not been translated and, if the Report 
string attributes of objects marked with the 'redo' flag check box was selected, the strings that 
need to be retranslated are also displayed.

7 After you find untranslated strings you can perform the following tasks:

■ Find the views that the untranslated strings belong to by clicking the Find View button.

■ Go to the parent object of the string in the Object Explorer by selecting a string, and then 
clicking Go To.

■ Export all untranslated strings to a.txt or.xlf file by clicking Export.
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Finding Existing Translations
You can search through objects in the repository to find existing translations for untranslated strings. 
This allows you to reuse existing translations for user interface objects that you have created or 
modified. 

The LMU compares untranslated strings with string attributes of other objects in the repository. If it 
finds an object with the same string, it searches for a translation in the language that you have 
selected as the target language of the current LMU session. If a translation exists, the LMU displays 
the best candidate for translation and allows you to export it to a file.

For example, suppose you have selected English-American as your source language and Spanish as 
the target language. You have an applet with a title of Customer that has not been translated. After 
clicking the Find Translation button, the LMU searches through the repository for other objects with 
attributes of Customer. If it finds one, it looks for a Spanish translation of the string. If a translation 
already exists, the translation is displayed and you can export it to a file.

If the LMU finds more than one translation for a source string, the following rules apply:

■ If the source string is an attribute of an object that is related to a business component, such as 
Control Caption or List Column Display Name, then translations from the same business 
component are examined first. If multiple translations exist in the same business component, 
the string that occurs the most is selected. If none of the translations exist in the same business 
component, then the translation that occurs the most often from among all business components 
is selected.

For example, suppose Applet A is based on the Account business component. Applet A contains 
a control caption with the value of Account and this value has been translated to Account_FRA 
for French. Now suppose you create a new applet, Applet B, that is also based on the Account 
business component and that also contains a control caption with the value of Account. When 
you run Find Translations, the LMU would find Account_FRA as an existing translation and select 
it as the best candidate for this string.

■ If the source string is not an attribute related to a business component, such as Menu Item 
Caption, the translation that occurs the most is selected as the best candidate.

To find translated strings

1 Choose Tools > Utilities > Locale Management.

The Locale Management dialog box.

2 In the Options tab, under Languages, select the source language and the target language.

3 Under Objects, select the applications or projects that you want to localize.

4 Click the Untranslated Strings tab.

5 Click the Find Translations button.

The LMU compares untranslated strings with strings of other objects in the repository. If other 
objects use the same source string, the LMU looks for existing translations of the string and 
displays the best candidates for translation in the Results window.
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Finding Modified Objects
You can locate previously modified objects in the repository by completing the following task.

To find modified objects

1 Choose Tools > Utilities > Locale Management.

The Locale Management dialog box appears.

2 Click the Options tab, and from the Source Language drop-down list, choose your source and 
target languages. 

NOTE: The source and target language must be different from one another. 

3 Click the appropriate radio button to indicate whether you want to search by application or by 
project, and select the projects or applications you would like to perform the query against.

4 Click the Modified Objects tab, and under Search criteria, click the Changed Since checkbox.

5 Select the date from which you would like to search, then click Start.

Exporting Text Strings and Locale-
Specific Attributes
You use the Locale Management Utility to export strings and other locale-specific attributes to an 
external file. The file type of the external file can be text (.txt) or XML Localization Interchange Field 
(.xlf).

NOTE: Microsoft Excel.xls files are not accepted by the LMU utility.

To export strings and other locale-specific attributes

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select the Source and Target Languages.

NOTE: When exporting strings and other locale-specific attributes, be sure that your Tools 
language mode and the LMU source language are the same.

3 Under Objects, select the applications or projects that you want to export.

4 Click the Export Tab.

5 Select whether you want to export Strings only or all localizable attributes. 

All localizable attribute includes translatable strings and other locale-specific attributes, such as 
the width and height of controls. These attributes may be different for different locales.
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6 Click Export.

The Save As dialog box appears, set to the SIEBEL_TOOLS_ROOT\OBJECTS directory of your 
Siebel Tools installation directory.

7 Enter a file name, choose a file type, and then click Save.

■ If you have selected All localizable attributes, the available file type is.slf.

■ If you have selected String attributes only, the available file types are.txt file or.xlf file.

Related Topic
“Selecting a Language Mode” on page 53

Importing Text Strings and Locale-
Specific Attributes
You use the Locale Management Utility to import translated strings and other locale-specific 
attributes back into the repository. Use the preview functionality to display the results of the import 
process before you actually import them into the repository.

NOTE: When using the LMU to import files with the.xlf extension make sure you are connected to 
the internet. 

To preview the results of the import process

1 Choose Tools > Utilities > Locale Management.

The Locale Management dialog box appears.

2 In the Options tab, under Languages, select a source language and a target language.

3 Click the Import tab.

4 Enter the directory path and name of the file you are going to import.

5 Enter the path and name of the file where you want to store the results for previewing.

The default file name is “preview.log.”

6 Click Preview.

The Locale Management Utility writes the results of the import process to the log file rather than 
to the repository.

NOTE: LMU does not mark changed records with a Redo flag when running in Preview mode.

To import strings and other locale-specific attributes into the repository

1 Choose Tools > Utilities > Locale Management.

The Locale Management dialog box appears.
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2 In the Options tab, under Languages, select a source language and a target language.

3 Click the Import tab.

4 Enter the file name of the file from which you want to import locale-specific attributes.

You can also use the Browse button to find and select the file. The default file name is: 

■ Results.txt if the file contains strings only

■ Results.slf if the file contains all locale-specific attributes

5 Select whether you want to mark records in the repository with the Redo flag that have changed 
since the export occurred.

When the import occurs, the LMU compares the source language records in the repository with 
the source language records in the import file. If the records in the repository have changed since 
the export occurred, the target language records are marked with the Redo flag. This helps you 
identify records that may need to be retranslated.

6 Click Import.

The locale-specific attributes are imported into the repository.

A log file (LMUImportTruncation.log) is created in the SIEBEL_TOOLS_ROOT\OBJECTS directory 
of your Siebel Tools installation directory. This file provides details, including error messages, 
about records that were not imported into the repository.

Identifying Objects Modified Since the 
Last Export
You can use the Locale Management Utility to identify objects that have been modified in the 
repository since the last time you exported strings. This is useful when your development and 
localization efforts occur simultaneously. It helps you keep strings in the repository synchronized 
with the strings that have been exported to a file for localization. 

You can search for modified objects using the following two methods:

■ Base your search on a specific date.

■ Compare objects in the repository with objects in a source file, such as results.txt. 

NOTE: When you base your search on a specific date, and run the search by clicking the Start button, 
all records returned for a modified project are marked as “Redo,” regardless of whether a particular 
locale attribute has changed. This is because the LMU searches for changes at the object level (the 
base record), not the attribute level.

To identify modified objects

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select a source language and a target language.
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3 Click the Modified Objects tab.

4 Define the search criteria you want to use:

■ Select the Changed since check box and then specify a date after which you want to find 
modified objects.

■ Select the Different from file check box and then specify the file to compare the repository 
against.

5 Do one of the following:

■ Click Start to find records that match the search criteria, display the results, and flag records 
returned in the search as Redo. Redo indicates that a record has been changed since the last 
time export occurred and therefore may need to be retranslated.

■ Click Preview to find records that match the search criteria and display the results. Preview 
does not mark records as Redo.

6 After you have identified modified objects, you can perform the following tasks:

■ Click Save to save a result set in a log file.

■ Click Go To to open the Object Explorer and go to the parent object of the string or attribute.

NOTE: The Load button allows you to import a result set from a previously saved file. After 
loading the result set in the display window, you can perform Save or Go-go operations on those 
records. 

Replacing Strings
You can use the LMU to replace strings in a bulk mode. For example, suppose that you need to change 
occurrences of Accounts to Companies for the English locale. You can use the LMU to export the 
strings to a file, manipulate the file so that it contains only Companies instead of Accounts, and then 
import the strings back into the repository. Using the LMU to replace strings is most useful for strings 
stored in string-override fields.

NOTE: Using the LMU to replace strings is useful when working with string overrides. But when 
working with the symbolic strings, follow the procedure described in “Modifying Symbolic Strings to 
Globally Update Display Values” on page 172.

To use the LMU to replace strings

1 Identify the applications or projects or both to which the strings belong. 

2 Export the strings you want to replace to an LMU file. 

Use the procedure described in “Exporting Text Strings and Locale-Specific Attributes” on page 194.

NOTE: Source and target language cannot be the same. 

3 In the LMU file, change the target language so that it is the same as the source language selected 
during the LMU export.

4 Remove strings from the LMU file that you do not want to replace.
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5 In the Target String column of the LMU file, enter the string that you want to substitute for the 
original value.

6 Use the LMU to import the LMU file:

a In Siebel Tools, choose > Utilities > Locale Management.

b In the Options tab, select source and target language (both are the same).

c Select the Import tab and then specify the LMU file path.

d Click Import to replace the strings.

Running the LMU Using the Command-
Line Interface
You can run the LMU from the command-line interface. Commands, syntax, usage, and examples are 
provided in the following sections.

The syntax for the following commands use these conventions:

■ <xxx> is a placeholder for a required parameter.

■ [xxx] is a placeholder for an optional parameter.

■ xxx|yyy is an selection parameter (that is, xxx or yyy)

NOTE: When specifying file names, the absolute path must be provided. For example, if you specify 
LMU file as results.txt for export, it is created under the current directory; that is, assuming an 
installation directory of D:\Program Files\Siebel\7.8\Tools, the file is created under D:\Program 
Files\Siebel\7.8\Tools\BIN, not under D:\Program Files\Siebel\7.8\Tools\OBJECTS.

Exporting Strings and Locale-Specific Attributes

Syntax
/lmu <srclang> <trglang> export <proj|app> <all|string> [<file>]

Usage
This command allows you to export localizable attributes for all projects or for all applications. If you 
specify all, then all attributes (translatable and language override attributes) are exported to a file 
with the extension of.slf; if you specify string, then string attributes only are exported to a file with 
the .txt or .xlf extension. If you do not specify a file name, you receive an error.

Example
siebdev /u sadmin /p db2 /d server /lmu ENU FRA export proj all 
C:\temp\my_proj_results.txt
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This example instructs LMU to export all attributes (string and language override attributes) for all 
projects to a LMU file in C:\temp named my_proj_results.txt. The source language is English-
American and the target language is French.

Importing an LMU File

Syntax
/lmu <srclang> <trglang> import <file>

Usage
This command allows you to import a LMU file and mark all target locale objects as “Redo” if the 
source string from the import file and the repository differ. You must specify the file name (with 
absolute path) to the import file.

Example
siebdev /u sadmin /p db2 /d server /lmu ENU FRA import "D:\Program 
Files\Siebel\7.7\Tools\objects\results.slf"

This example instructs the LMU to import a file called results.slf from the folder D:\Program 
Files\Siebel\7.7\Tools\objects (the installation location for an earlier version). The source language 
of the LMU file is English-American (ENU), and the target language is French (FRA). The LMU file 
contains all localizable attributes (string and language override attributes).

Exporting Strings to Be Translated

Syntax
/lmu <srclang> <trglang> todo <proj|app> [<file>]

Usage
This command allows you to export all untranslated strings and strings marked with the Redo flag to 
an LMU file. You can specify whether you want to export for all projects or all applications. The 
exported LMU file contains the related View Names.

Example
siebdev /u sadmin /p db2 /d server /lmu ENU FRA todo app "D:\Program 
Files\Siebel\7.8\Tools\objects\results.txt"
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This example instructs the LMU to find all untranslated strings and redo strings for all applications 
and export the results to D:\Program Files\Siebel\7.8\Tools\objects\results.txt. The source language 
is English-American (ENU), and the target language is French (FRA).
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