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Preface 
Oracle Retail Data Warehouse 12.0 is deployed using MicroStrategy 8.0.2 as the front-
end tool. This document describes installation steps for MicroStrategy Desktop 8.0.2, 
MicroStrategy Administrator 8.0.2, MicroStrategy Intelligence Server 8.0.2, and 
MicroStrategy Web 8.0.2 products for a typical client configuration. For a comprehensive 
guide to all production system configurations please refer to the MicroStrategy 8 Basic 
Setup Guide. 
We highly recommend that you follow the steps in the order described within the 
chapters of this document. 
RDW recommends the following installation locations: 
 MicroStrategy Intelligence Server should be installed on its own dedicated server 

machine. 
 MicroStrategy Web should be installed on its own dedicated Web server machine. 
 MicroStrategy Desktop and Administrator should be installed on the machine that is 

designated for the administrator’s use. 
 MicroStrategy Desktop should be installed on machines for users who are not 

administrators, but require the Desktop functionality not available in MicroStrategy 
Web. 

 The rest of the products can be installed in varying combinations depending upon 
who uses them and on what machines. 

Audience 
This document is intended for MicroStrategy administrators responsible for installing the 
Oracle Retail Data Warehouse. 

Related Documents 
You can find more information about this product in these resources: 
 Oracle Retail Data Warehouse Data Model 
 Oracle Retail Data Warehouse Database Installation Guide 
 Oracle Retail Data Warehouse Operations Guide 
 Oracle Retail Data Warehouse Release Notes 
 Oracle Retail Data Warehouse User Guide 
 MicroStrategy documentation 

Customer Support 
 https://metalink.oracle.com  

When contacting Customer Support, please provide: 
 Product version and program/module name. 
 Functional and technical description of the problem (include business impact). 
 Detailed step-by-step instructions to recreate. 
 Exact error message received. 
 Screen shots of each step you take. 

https://metalink.oracle.com/
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1 
System Requirements 

This chapter describes the system hardware and software requirements to install 
Microstrategy Intelligence Server 8.0.2, Microstrategy Web 8.0.2, Microstategy Desktop 
8.0.2, and Microstrategy Administrator 8.0.2. See each of the MicroStrategy 8.0.2 
products’ readme file for the most up-to-date requirements as well as its certified and 
supported configurations. For sizing factors, refer to the MicroStrategy 8.0.2 Installation 
and Configuration Guide. 
The following table shows the recommended (and minimum) hardware requirements for 
MicroStrategy products. 

Microstrategy 
Product 

Processor Memory Storage 

Administrator  1 GHz or higher 
 Pentium compatible 

(minimum 450MHz) 

1 GB (minimum256 
MB) 

500 MB 

Desktop Products  1 GHz or higher 
 Pentium compatible 

(minimum 600MHz) 

1 GB (minimum 
512 MB) 

500 MB 

Intelligence Server  1 GHz or higher 
 Pentium compatible 

(minimum 600 MHz) 

2 GB (minimum 
512 MB) 
 

2 GB (minimum 
512 MB) 
 

MicroStrategy Web 

Web Server  1 GHz or higher 
 Pentium compatible 

(minimum 450 MHz) 

1 GB (minimum 
512MB) 

1 GB (minimum 
500 MB) 

Web Client  1 GHz or higher 
 Pentium compatible 

(minimum 450 MHz) 

512 MB or higher 
(minimum 128 MB) 

Additional space 
not required 

In addition to the MicroStrategy products listed above, the database server on which your 
MicroStrategy metadata is hosted should run on a machine with the following minimum 
configuration: 
 Processor: 400 MHz or higher Pentium compatible 
 Memory: 256 MB 
 Storage: 200 MB 

For successful installation of MicroStrategy products, the following product-specific 
software requirements must be satisfied. 
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Microstrategy Product Software Requirements 

Microstrategy Administrator  Microsoft Windows 2000 SP1 or higher 
 Microsoft Windows 2003 Server Standard Edition or 

Enterprise Edition 
 Microsoft Windows XP Professional Edition SP1 (not valid 

for Enterprise Manager) 

Desktop Products  Internet Explorer 4.01 or higher. (Note that to use the 
Document Editor with double-byte languages, you need 
Internet Explorer 5.01.) 

 RealPlayer 8 Basic (installed automatically if not already 
present). 

Microstrategy Intelligence 
Server 

For Windows 2000: 
 Windows 2000 Server SP3 or SP4 
 Windows 2000 Advanced Server SP3 or SP4 
 Internet Explorer 5.01 or higher 

For Windows Server 2003: 
 Windows Server 2003 Enterprise Edition 
 Windows Server 2003 Standard Edition 
 Internet Explorer 6.01 or higher 

Microstategy Web 

Web Server  Microsoft Internet Information Services 5.0 or Higher 

Web Client  Recommended resolution for the monitor is 800 x 600 or 
higher with 256 color palette minimum. 

 Any spreadsheet application that supports the CSV file type 
can be used as an export alternative to Microsoft Excel. 
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Database and ODBC Configurations  
MicroStrategy components are 32-bit applications that require 32-bit drivers to achieve 
ODBC connectivity. The following table shows the recommended ODBC driver for each 
database platform. 

DBMS Recommended Windows 32-Bit 
ODBC Driver 

Windows Status 

Oracle 8.1.7 MicroStrategy ODBC Driver for Oracle 
Wire Protocol 5.10.00.53 

MD: Supported  
WH: Supported  
STATS: Supported 

Oracle 9i and 
9iR2  

MicroStrategy ODBC Driver for Oracle 
Wire Protocol 5.10.00.53 

MD: Certified  
WH: Certified 
STATS: Certified 

Oracle 10g and 
10gR2 

MicroStrategy ODBC Driver for Oracle 
Wire Protocol 5.10.00.53 

MD: Certified  
WH: Certified 
STATS: Certified 
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2 
MicroStrategy Desktop and MicroStrategy 

Administrator Installation and Configuration 
This chapter provides general installation instructions and recommended configuration 
considerations for MicroStrategy Desktop and MicroStrategy Administrator on the 
administrator’s machine. This chapter also provides the steps necessary to be able to 
connect to the RDW 12.0 workbenches.  

Install MicroStrategy Desktop and MicroStrategy 
Administrator 

Note: For step-by-step guidance on how to install 
MicroStrategy Desktop and MicroStrategy Administrator, 
see the Installation section in the ‘Installing MicroStrategy 
on Windows’ chapter of the “MicroStrategy 8.0.2 
Installation and Configuration Guide.” 

When asked what products to install, choose the following components along with their 
sub-components: 
 MicroStrategy Desktop Products 
 MicroStrategy Administrator 

The following sub-components should be installed with the above products: 
 MicroStrategy Desktop Products sub-components: 

 MicroStrategy Desktop Analyst or MicroStrategy Desktop Designer depending 
on your license agreement with MicroStrategy 

 MicroStrategy Architect 
 MicroStrategy Project Builder 
 MicroStrategy Server Administrator 
 RealPlayer 

 MicroStrategy Administrator sub-components: 
 MicroStrategy Command Manager 
 MicroStrategy Object Manager 
 MicroStrategy Enterprise Manager 
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Set Up ODBC 
Note: For detailed information regarding ODBC Setup, 
please see ODBC and DSNs in Appendix D of the 
MicroStrategy 8.0.2 Installation and Configuration Guide. 

Note: Before an ODBC connection can be established with 
the database, please make sure the machine has database 
connectivity to both the metadata repository and warehouse 
databases as outlined in the RDW Database Installation 
Guide. Please contact your database administrator for 
guidance and specifications for these connectivity settings. 

Note: RDW recommends using the Connectivity 
Configuration Wizard that comes with MicroStrategy to set 
up ODBC. You can access this wizard through the Start 
Menu and then navigating through 
Programs>MicroStrategy>Tools>Connectivity 
Configuration Wizard. 

ODBC Setup for Oracle 
When the Connectivity Configuration Wizard displays the list of database drivers, choose 
MicroStrategy ODBC Wire Protocol. On the driver setup page, enter the following 
information in the appropriate boxes for making a connection with the selected database 
driver. Your database administrator should be able to provide you with the appropriate 
values. 
 Data Source Name: Type a string that identifies this Oracle data source configuration 

in the system information, that is, RDW12.0. 
 Host Name: Type the name of the Oracle server to be accessed. 
 SID: Type the Oracle System Identifier that refers to the instance of Oracle running 

on the server. The MicroStrategy driver provides a default SID of ORCL. 
 Port Number: Type the port number of your Oracle listener. Check with your 

database administrator for the correct number. The MicroStrategy driver provides a 
default port number of 1521. 

Note: This guide assumes that you are following the 
Development Database Schema Implementation outlined in 
the RDW Database Installation Guide. If not, you may have 
to set up separate ODBC data sources for the metadata 
repository and the warehouse database. 

Important: The data warehouse DSN should be consistent 
with every machine that needs to connect directly to the 
database. This information is stored in the metadata, and 
therefore must remain consistent across all users. 



Oracle Retail Data Warehouse 12.0 
 

 Middle Tier Installation Guide  7 

Create the Project Source 
A project source contains the information necessary for MicroStrategy products to 
connect to the metadata in which your projects are stored. It stores the location of the 
metadata repository that is used to host the projects.  

Note: The steps below assume that you have already 
installed the RDW 12.0 MicroStrategy metadata as outlined 
in the RDW Database Installation Guide. 

Complete the following steps to create the project source: 
1. Launch MicroStrategy Desktop from Start > Programs > MicroStrategy > Desktop > 

Desktop. 
2. Cancel out of the initial login screen. 
3. Select Tools > Project Source Manager from the Desktop menu bar. 
4. Click Add. 

Note: A project source can be defined for either 2-tier 
(direct) or 3-tier (server) connection. A 2-tier connection is 
only required for project duplication. The backing up of the 
RDW 12.0 workbenches utilizes the MicroStrategy 
duplication process. Thus, at this point, a 2-tier connection is 
required. 

For 2-tier, or direct connection: 
5. Enter a Project Source Name (that is, RDW 12.0 Data Warehouse – Direct). 
6. Select Direct for the connection mode. 
7. Enter the ODBC DSN that you created in the ODBC Setup above, and the username 

and password of the user who has access to the metadata tables (that is, rdw12sys). 
8. Click OK. 
9. You can now log into the RDW 12.0 project source as the administrator without a 

password. At this point, you should be able to see the four (4) RDW 12.0 
workbenches. This verifies that the connection information is correct. It is highly 
recommended that a password be added to the administrator user as soon as possible. 

Remove Unwanted RDW 12.0 Workbenches 
To remove unwanted workbenches: 
1. Right-click on a workbench you did not purchase, then select Delete. 
2. Repeat for every workbench you did not purchase. 
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Update RDW 12.0 Workbenches 
To update workbenches: 
1. Open the RDW 12.0 workbench and Click “Yes” on the below message box. 

 

2. Repeat this step for all the workbenches. 

Back Up the RDW 12.0 Workbenches 
It is vital at this point to create backups of your workbenches. If something happens to 
one or more of your workbenches, you should be able to go back and start from these 
original copies. 

Note: It is highly recommended that you do not only back up 
your workbenches during initial installation. You should also 
establish a backup strategy as you go into production. The 
steps outlined below can be used to create backup copies of 
your workbenches at any time. 

1. From the Schema menu, choose Duplicate Project. The Project Duplication Wizard 
opens. 

2. Review the information on the Welcome page and click Next. 
3. On the Source Project Location page: 

a. Select the project source you have created above.  
b. Under Authentication, choose ‘With the login id and password provided below’ 

and then provide the Administrator user id and password. 
c. Click Next. 

4. On the Source Project Selection page, select the RDW workbench to duplicate and 
click Next. 

5. On the Duplicate Project Location page: 
a. Select the same project source in step 3. 
b. Under Authentication, choose ‘With the login id and password provided below’ 

and then provide the Administrator user id and password. 
c. Click Next. 

6. On the Duplicate Project Creation page, type a name and description for the 
duplicated project (that is, RDW 12.0 Category Management Backup 12012004) and 
click Next. 
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7. On the Duplicate Objects Selection page:  
a. Under Project objects, choose to duplicate All objects. 
b. Under Configuration objects, choose to duplicate “Project Related Objects 

Only.” (Choose All Object if you are duplicating to another project source.) 
c. Under Users and user groups, choose to duplicate “Project related users and 

groups only” and also check the check-box below that option. (Choose All users 
and user groups if you are duplicating to another project source.) 

d. Click Next. 
e. Click Next. 

8. On the Process Options page: 
a. Accept the default choices. 
b. Click Next. 

9. On the Viewing Options page: 
a. Select View event log concurrently to watch the duplication process as it 

happens. 
b. If you choose to view the event log, select Log errors and warnings only or Log 

all events. 
c. Click Next. 

10. On the Log Options page, select the check boxes for each log you want generated: 
a. Under Event log, click Browse to specify the location of the log file. Select the 

Event types to include in the log. 
b. Under Corrupted objects log, click Browse to select the location of the log file. 
c. Under Statistics log, click Browse to select the location of the log file. 
d. Click Next. 

11. On the Summary page, review the list of preferences you chose, and click Finish. 

Note: Duplicating a project is a lengthy process. Two 
progress bars indicate the current status of items transferring 
to the duplicated project and the time elapsed in the 
duplication process.  

12. When the duplication process finishes, click Exit to conclude your activity in the 
Project Duplication Wizard. 

13. The Finish page signals that you have successfully created your duplicate project. 
Click OK to return to the Desktop interface. 

14. Repeat steps 1 to 13 for each RDW workbench you want to back up. 
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Update the Warehouse Database Instance 
The initial MicroStrategy database instance, which is accessed from MicroStrategy 
Desktop under Administration, Database Instance Manager, must be updated if the 
username (that is, rdw12sys), password, or ODBC DSN name in your environment is 
different than the RDW default.  

Note: To avoid connection issues, do not change the name of 
the MicroStrategy database instance unless completely 
necessary. Only update the login and DSN information 
within the object. 

Perform the steps below to update the MicroStrategy Database Instance to reflect your 
environment. 
1. Launch MicroStrategy Desktop from Start > Programs > MicroStrategy > Desktop > 

Desktop. 
2. Log into the project source that contains the RDW 12.0 Workbenches as the 

Administrator, or as a user with administrator privileges. If this is the first time you 
are connecting to the project source, use the username “Administrator” with no 
password. It is recommended that you change this password as soon as possible, for 
security reasons. 

3. Open the Administration folder and select the Database Instance Manager. 
4. Double-click on the database instance object in the right-hand pane. Verify that all of 

the information displayed is correct. 
5. Click the Modify button to edit the database connection. Verify that the correct 

ODBC DSN is being used. 
6. Click the Modify button to edit the login ID and password. Verify that the login ID 

and password are correct. 
7. Click OK on all open dialog boxes. 
8. You must disconnect from the project source and re-connect in order for any changes 

to take effect. 
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Update the Warehouse Catalog Read SQL Statement 
The initial Warehouse Catalog SQL statement must be updated if the warehouse tables’ 
owner in your environment is different than the RDW default (that is, rdw12dm).  
Perform the following steps to update the Warehouse Catalog Read SQL Statement to 
reflect your environment. 
1. Launch MicroStrategy Desktop from Start > Programs > MicroStrategy > Desktop > 

Desktop. 
2. Log into the project source that contains the RDW 12.0 Workbenches as the 

Administrator, or a user with administrator privileges. If this is the first time you are 
connecting to the project source, use the username “Administrator” with no 
password. It is recommended that you change this password as soon as possible, for 
security reasons. 

3. Open a project and then from the Schema menu, choose SQL Generation Options.  
4. From the Project Configuration dialog, access the Warehouse Catalog Options dialog 

box by clicking on the Catalog Options button. 
5. From the Catalog category on the left pane, click on Read Settings. 
6. Click on the Settings button located at the right of the text ‘Customize the SQL 

statements that query directly the database catalog tables’. 
7. Change the warehouse owner by modifying the value of OWNER in the SQL 

statement shown below. Thus, that is, you can change ‘RDW12DM’ below to your 
environment’s warehouse owner. 
SELECT DISTINCT OWNER NAME_SPACE, TABLE_NAME TAB_NAME  FROM ALL_TAB_COLUMNS  
WHERE OWNER = 'RDW12DM' 

8. Click OK to save your changes. 

Manage Users and Security 
Note: For more detailed information regarding users, user 
groups, security roles, permissions and privileges, refer to 
the MicroStrategy 8.0.2 System Administrator Guide. 

To manage security within the RDW workbenches, RDW recommends the following 
approach: 
1. Specify the authentication mode of a project source. 
2. Create security roles. 
3. Create groups. 
4. Assign security roles to groups. 
5. Create users. 
6. Assign users to groups. 
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Authentication Mode 
Standard authentication is the default authentication mode and the simplest to set up. 
Each user has a unique login and password and can be identified in the MicroStrategy 
application uniquely. By default, all users connect to the data warehouse using one 
RDBMS login ID, although you can change this using Connection Mapping. In addition, 
standard authentication is the only authentication mode that allows a user or system 
administrator to change or expire MicroStrategy passwords. 
To specify the authentication mode for your project source: 
1. From the MicroStrategy Desktop Tools menu, select Project Source Manager.  
2. Select the project source and click Modify.  
3. On the Advanced tab, select Standard. 
4. Click OK.  

Security Roles 
Security roles are collections of privileges that can be reused from project to project. 
Security roles enable you to assign a unique set of privileges to users on a per project 
basis. Security roles are created and maintained at the project source level and assigned to 
users at the project level. 
The following security roles are provided with RDW by default: 
 Administrator – This security role gives administrator privileges to a user or user 

group, for a given project.  
 Architect – This security role gives privileges to create and modify schema level 

objects to a user or user group, for a given project. 
 Power User – This security role gives privileges to create and modify public level 

objects, to a user or user group, for a given project. 
 Normal User – This security role has only the privileges defined in the user or user 

group. All users are defaulted to normal user unless otherwise specified. 
To create your own security roles, follow these steps: 
1. From the MicroStrategy Desktop Administration menu, select Projects>Project 

Configuration. 
2. Select Project Access, General, and View. The Security Roles dialog box opens. 
3. Click New. The Security Role Editor opens. 
4. Type a name and description for the security role. 
5. Select the privileges you wish to include in the security role from the Available 

privileges list. 
6. Click OK to create the security role. You are returned to the Security Roles dialog 

box. 
7. Click OK. You are returned to the Project Configuration Editor. The security role is 

now available for you to use. 
8. Click OK. 
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User Groups 
A user group is simply a collection of users. Groups provide a convenient way to manage 
a large number of users. Instead of assigning privileges, such as the ability to create 
reports, to hundreds of users individually, you may assign privileges to a group. Groups 
may also be assigned permissions to objects, such as the ability to add reports to a 
particular folder. 
The following user groups are provided with RDW by default: 
 MicroStrategy Web Reporter – This user group has privileges to search, change user 

preferences, print, change view mode, drill, sort, view history list, and run reports in 
RDW Web. 

 MicroStrategy Web Analyst – This user group inherits the Web Reporter privileges 
and can create new reports, delete objects, export, pivot, save reports, and drill to 
template in RDW web. 

 MicroStrategy Web Professional – This user group inherits the Web Analyst 
privileges and can format grid and graph, re-execute the report, view the report SQL, 
and save templates and filters in RDW Web. 

 MicroStrategy Desktop Reporter – This user group inherits the Web Professional 
privileges and a can create, save, and modify report objects, such as reports, 
templates, filters, and metrics, within its own profile. 

 System Monitors – While this group does not have any project level inherited 
privileges, all users in this group have view privileges to the administration folders. 
These folders monitor the warehouse, connections, users, and cache settings within 
the repository. 

 Developers – This user group inherits the System Monitors privileges and has all 
Web privileges and all Desktop Designer privileges. Users in this group can open and 
view information in schema-level editors as well as create, save, and modify all types 
public of objects. Only Desktop power users should be placed in this group. 

 System Administrator – This group inherits all of the privileges of the project 
administrator. Only the Administrator and Web Administrator should be part of this 
group. 

To create your own groups and assign privileges to each group: 
1. From the MicroStrategy Desktop Folder List, expand Administration and select User 

Manager. 
2. To create a new group, go to the File menu, select New, and then Group. To modify 

an existing group, right-click the group you wish to modify and select Edit. 
3. On the Project Access tab, in the Security Role Selection drop-down list for a project, 

select the security role to be applied to the selected user or group. You may also 
select Custom to apply multiple security roles (the Project Access dialog box opens). 

4. You can select a check box for an individual privilege to override those assigned to 
the user by the selected security roles. This override applies to all projects displayed. 

5. Click OK to save the privileges. 
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Users 
Users are defined in the MicroStrategy metadata and exist across projects. You do not 
have to define users for every project you create in a single metadata repository. 
The following user is provided with RDW by default: 
 Administrator – This is the project administrator for both MicroStrategy Desktop and 

MicroStrategy Web. This user bypasses all object level security.  
To create your own users and assign them to groups: 
1. From the MicroStrategy Desktop Folder List, expand Administration, and select User 

Manager. 
2. Expand User Manager, and select the group directly under User Manager in which 

you wish to create a user. 
3. From the File menu, select New, then User. The User Editor opens. 

Note: If only Group appears as an option, it is because you 
selected the group on the right-hand side of Desktop, and not 
the group name under the Folder List side of Desktop. You 
must select the group name on the left side of Desktop for 
User to appear as an option. 

4. Enter the appropriate information on the General tab. 
5. On the Groups tab, select the groups to which the user belongs. 
6. On the Authentication tab, enter the user’s Login ID or user name (and password for 

the Warehouse Passthrough) that links them to the authentication system. 
7. Click OK to save the user. 

Permissions 
Privileges are assigned to users (either individually, through groups, or with security 
roles), but permissions are assigned to objects. More precisely, each object has an Access 
Control List (ACL) that specifies which permissions various users have on that object. 
That is, in the case of a report, a user may have the permission to view the report 
definition and execute the report, but may not have the permission to modify the report 
definition or delete the report. 
To modify an object’s access control list: 
1. In the desired project within the MicroStrategy Desktop Folder List, locate and select 

the object whose access control list you wish to modify. 
2. From the File menu, select Properties. The Properties dialog box opens. 
3. Make modifications to the access control list in the Security tab. Click Add to add a 

new user or group to the list. Click Delete to remove a user or group from the list. 
4. Click OK to save the settings. 
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Other Important Notes 
 RDW 12.0 supports retail 4-5-4, combined 4-5-4/Gregorian, or 13 period calendar. 

You can choose which calendar to use during database installation. The default 
calendar is retail 4-5-4. To implement either combined 4-5-4/Gregorian or 13 period, 
see the Appendix: Time of this document.  

 In RDW 12.0, Differentiator Types are hard-coded within the attribute names. See 
the Appendix: Item Differentiators for detailed information regarding adding or 
modifying of these attributes. 
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3 
MicroStrategy Intelligence Server Installation and 

Configuration 
This chapter provides general installation instructions and recommended configuration 
considerations for MicroStrategy Intelligence Server on a separate machine.  

Installation Requirements 
Installation of the MicroStrategy Intelligence server requires network connectivity. For 
assistance with this step, refer to the Microsoft Server installation documentation. 
Contact your system administrator for proper network access. 

Install MicroStrategy Intelligence Server 
For step-by-step guidance on how to install MicroStrategy Intelligence Server, see the 
Installation section in the ‘Installing MicroStrategy on Windows’ chapter of the 
“MicroStrategy 8.0.2 Installation and Configuration Guide.” 
When asked what products to install, choose MicroStrategy Intelligence Server. 

Configure Intelligence Server 
For more information regarding the configuration of MicroStrategy Intelligence Server, 
refer to the ‘Setup MicroStrategy Intelligence Server’ section of the ‘Configuring 
Intelligence Server and Connecting to the Data Warehouse’ chapter of the 
“MicroStrategy 8.0.2 Installation and Configuration Guide.” 
1. Once the MicroStrategy 8.0.2 Intelligence Server is installed, select the Configuration 

Wizard from the Start > Programs > MicroStrategy menu on the Intelligence Server 
machine.  

2. Select Set up MicroStrategy Intelligence Server. Click Next. 
3. Select the metadata ODBC DSN (that you have previously created) from the drop-

down menu. Enter the RDW system username and password (that is, rdw12sys). 
4. Enter the MicroStrategy username and password that you will use to connect to the 

Metadata Repository. If this is the first time you are connecting to the Metadata 
Repository, use the username “Administrator” with no password. It is recommended 
that you change this password later for security reasons. 

5. Enter a Server Definition Name and select Create New Server Definition. Click Next. 
6. Enter a Port Number. Click Next. 
7. Select the workbenches that you wish to register, or make available via the 

Intelligence Server. Click Next. 

Note: If you have created backup copies of the RDW 
workbenches, it is recommended that you do not register 
these workbenches, so users connecting through 3-tier do not 
inadvertently modify these projects. It is assumed that only 
the administrator connects through 2-tier and thus is the only 
one who has access to the unregistered workbenches. 
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8. Click Finish. 
9. Start the Intelligence Server service, if it does not start automatically. The 

MicroStrategy Service Manager is launched from the Start Menu by navigating 
through Programs>MicroStrategy>Tools > Service Manager. 
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4 
MicroStrategy Web Server Installation and 

Configuration 
This chapter provides general installation instructions and recommended configuration 
considerations for MicroStrategy Web Server on a separate machine that has Microsoft 
Internet Information Services (IIS) installed.  

Installation requirements 
 Installation of the MicroStrategy Web Server requires network connectivity. For 

assistance with this step, refer to the Microsoft Server installation documentation. 
Contact your System Administrator for proper network access. 

 You must have administrative privileges to deploy using MicroStrategy Web. If this 
is the first time you are logging in and have not changed the default MicroStrategy 
administrative login, then you can use Administrator as the login with no password. 
After the first time, the user name and password should be changed for security 
purposes. 

Install MicroStrategy Web Server 
For step-by-step guidance on how to install MicroStrategy Web Server, see the 
Installation section in the ‘Installing MicroStrategy on Windows’ chapter of the 
“MicroStrategy 8.0.2 Installation and Configuration Guide.” 
When asked what products to install, choose MicroStrategy Web, ASP.Net version along 
with its selected sub-components below: 
 MicroStrategy Web Server (ASP.NET) 
 Microstrategy Web Analyst, MicroStrategy Web Professional or MicroStrategy Web 

Reporter, depending on your license agreement with Microstrategy 

Configure MicroStrategy Web Server 
Note: For more information about configuring and tuning 
MicroStrategy Web, see the MicroStrategy System 
Administration Guide. 

Deploying with MicroStrategy Web requires you to connect MicroStrategy Web to your 
Intelligence Server by performing the following steps: 
1. On the machine where MicroStrategy Web is installed (your Web server machine), 

on the Windows Start menu point to Programs, then to MicroStrategy, then to Web, 
and then choose Web Administrator. The Web Administrator page opens. This is the 
page where you connect MicroStrategy Web to the Intelligence Server. 

2. Enter the name of your Intelligence Server in the “Add a server manually” box on the 
Web Administrator page. 

3. Click Connect. Any projects registered with the Intelligence Server specified are 
now available from MicroStrategy Web. Click the Home icon (in the upper left 
corner of the Web Administrator page) to see the list of projects registered with the 
Intelligence Server you specified. 
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4. Send your users the URL, which is:  
http://webservername/microstrategy/asp/ 
where webservername is the name of the machine hosting your Web server. That is, 
if the name of your Web server machine is Web_Srv1, then the URL your users 
would use to access MicroStrategy Web would be  
http://Web_Srv1/microstrategy/asp 
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5 
MicroStrategy Desktop Installation and Configuration 

This chapter provides MicroStrategy Desktop general installation instructions and 
recommended configuration for users that are not administrators, but require the Desktop 
functionality not available in MicroStrategy Web.  

Install MicroStrategy Desktop 
For step-by-step guidance on how to install MicroStrategy Desktop, see the Installation 
section in the ‘Installing MicroStrategy on Windows’ chapter of the “MicroStrategy 8.0.2 
Installation and Configuration Guide.” 
When asked what products to install, choose MicroStrategy Desktop along with its 
selected sub-components below: 
 MicroStrategy Desktop Analyst or MicroStrategy Desktop Designer depending on 

your license agreement with Microstrategy 
 MicroStrategy Architect 
 RealPlayer 

Note: Non-administrator MicroStrategy Desktop users 
connect through a 3-tier or server connection and do not 
need to set up ODBC. 

Create the Project Source 
A project source contains the information necessary for MicroStrategy products to 
connect to the metadata in which your projects are stored. It stores the location of the 
metadata repository that is used to host the projects.  
Complete the following steps to create the project source: 
1. Launch MicroStrategy Desktop from Start > Programs > MicroStrategy> 

Desktop>Desktop. 
2. Select Tools > Project Source Manager from the Desktop menu bar. 
3. Click Add. 
4. Enter a Project Source Name (that is, RDW 12.0 Data Warehouse). 
5. Select Server for the connection mode. 
6. Enter the server machine name where Intelligence Server is running. 

Note: This is the machine name of the server, not the 
Intelligence Server definition name. 

7. Click OK. 
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A 
Appendix: Time 

Time Calendar (4-5-4) 
RDW provides support for the retail 4-5-4 calendar. The fiscal 4-5-4 calendar is the 
calendar supported by RMS and other Oracle Retail applications and is populated in 
RDW via an extract from RMS. The 4-5-4 calendar is the default calendar used when 
viewing the time dimension via the MicroStrategy middle tier layer of RDW.  

Note: Even if 4-5-4 is the default calendar for RDW, you 
can still see the Gregorian Time attributes and 
transformations from within MicroStrategy. However, you 
can only utilize these objects if you have opted for Gregorian 
calendar during database installation. 

Time Calendar (4-5-4/Gregorian) 
RDW also provides support for the combined 4-5-4 calendar/Gregorian calendar. If a 
client chooses to use the combined 4-5-4/Gregorian calendar, the client must execute the 
batch program that generates the text files needed to populate the Gregorian time 
dimension.  

Note: In order to update RDW to report in combined 4-5-
4/Gregorian calendar, please see the section, ‘Create Time in 
RDW’ of the “RDW Database Installation Guide” for 
specific instructions. Nothing needs to be modified within 
MicroStrategy. 
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Time Calendar (13 period) 
The 13-Period calendar can also be used, but RMS does not support it. If a client chooses 
to use the 13-Period calendar, the client can either provide a flat file with its 13-period 
time, or utilize a sample 13-period time flat file, and then ETL scripts populate the time 
dimension with this file during RDW installation. Within the middle-tier application, all 
references to Month must be manually updated to Period, to comply with the 13 period 
nomenclature. 

Note: In order to update RDW to report in 13 period time, 
follow these steps: 

1. Update the time dimension tables. (For complete instructions, reference the RDW 
Database Installation Guide.) 

2. Within the metadata, delete the attribute Half Year, and re-name the objects 
referencing month. 
 Highlighting the object and pressing the delete key deletes the attribute Half 

Year. All relationships and hierarchies are automatically updated. The table 
TIME_HALF_DM can also be deleted the same way. A full schema update is 
required after this step, which can be done from the Schema drop down menu. 
Only a user with administrator privileges is able to remove attributes and perform 
a schema update. 

 Each metadata object can be re-named by selecting the object and pressing F2. A 
full schema update is required after any changes to objects within the Schema 
Objects folder. Only a user with administrator privileges is able to re-name these 
objects and perform a schema update. 
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The following is a list of objects that would be re-named for 13 period time. 

Object Name Object Type 

Market Measures (Last Month) Folder 

Sales (Last Month) Folder 

Month Attribute 

Last Month Attribute 

No of Months Base Formula 

Month Expression Prompt 

Last Month Filter 

This Month Filter 

This Month’s Days Filter 

Monthly Performance Trend (A) Report 

Cashier Monthly Performance (A) Report 

Salesperson Monthly Performance (A) Report 

Weekly Sales to Date (Loc, Month, Week) (A) Report 

Monthly Performance Trend (A) Template 

Cashier Monthly Performance (A) Template 

Salesperson Monthly Performance (A) Template 

Weekly Sales to Date (Loc, Month, Week) (A) Template 

Year, Month, Week, Day Hierarchy 

Year, Month Hierarchy 

Year, Month, Week Hierarchy 

Year, Season, Month, Week, Day Hierarchy 

% Change Sales Value vs Last Month Metric 

Sales Value (Last Month) Metric 

% Change Sales Units vs Last Month Metric 

% Change No of Sales Transactions vs Last Month Metric 

Avg Frequency per Month Metric 

Sales Units (Last Month) Metric 

No of Sales Transactions (Last Month) Metric 

% of Days Out of Stock to Month Metric 

No of Months Metric 

% Change in Dead Net Cost vs Last Month Metric 
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Object Name Object Type 

% Change in Net Cost vs Last Month Metric 

% Change Base Cost vs Last Month Metric 

% Change Market Sales Value vs Last Month Metric 

Variance No of Sales Transactions vs Last Month Metric 

% Change in Net Net Cost vs Last Month Metric 

Variance Sales Units vs Last Month Metric 

Variance Sales Value vs Last Month Metric 

Difference in Net Net Cost vs Last Month Metric 

Market Sales Units (Last Month) Metric 

Dead Net Cost (Last Month) Metric 

Market Sales Value (Last Month) Metric 

Market Sales Value (Month) Metric 

Difference in Net Cost vs Last Month Metric 

Difference in Base Cost vs Last Month Metric 

Difference in Dead Net Cost vs Last Month Metric 

No of Days (Month) Metric 

Net Cost (Last Month) Metric 

Avg Profit per Month Metric 

Net Net Cost (Last Month) Metric 

Base Cost (Last Month) Metric 

Avg Sales Value per Month Metric 

Month to Date Transformation 

Last Month Transformation 
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B 
Appendix: Item Differentiators 

Diff Attributes 
As part of the RDW install, the first five diff types are hard-coded, in both the 
DIFF_TYPE_DM look-up table and in the names of the attributes that point to them. This 
matches the initial set of pre-defined diff types that are provided within the Oracle Retail 
Merchandising System. This leaves the remaining diff types, and their corresponding 
attributes, to be defined at the client’s discretion at a later date. 
The following is a list of differentiators: 

DIFF_TYPE_KEY Attribute Name 

1 Size 

2 Color 

3 Flavor 

4 Scent 

5 Pattern 

6 Diff 6 

7 Diff 7 

8 Diff 8 

9 Diff 9 

10 Diff 10 

11 Diff 11 

12 Diff 12 

13 Diff 13 

14 Diff 14 

15 Diff 15 

16 Diff 16 

17 Diff 17 

18 Diff 18 

19 Diff 19 

20 Diff 20 

21 Diff 21 

22 Diff 22 

23 Diff 23 
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DIFF_TYPE_KEY Attribute Name 

24 Diff 24 

25 Diff 25 

26 Diff 26 

27 Diff 27 

28 Diff 28 

29 Diff 29 

30 Diff 30 

Creating New Diff Types 
With each additional diff type that is added to the merchandising system, the attribute 
name, within RDW, can be updated to more suitably match the name of the new diff 
type. This is done by completing the following steps. 
Attribute Name Update: 
1. Open the Schema Objects\Attributes\Diffs folder. 
2. Select the desired attribute. The first time, this will be Diff 6. 
3. Press F2 and type the new name over the existing name. 
4. Once completed, choose Update Schema from the Schema drop-down menu to 

update the project.  

Modifying Diff Types 
Functionality exists within the merchandising system to modify existing diff types. This 
can be done by either changing the description of the diff type (that is, change the diff 
type “Size” to “Fashion Size”) or by deleting the diff type altogether.  

Note: All of the 30 possible diff types are defined as 
attributes in RDW, regardless of whether they exist yet in the 
merchandising system. These attributes are generically 
named with the number corresponding to the 
DIFF_TYPE_KEY, as annotated in the table above. 

When the description is changed within the merchandising system, the batch process 
updates the description column within the PROD_DIFF_TYPE_DM table to match this 
new description. The attribute name within the MicroStrategy project must be updated 
manually by completing the attribute name update steps above. 
When deleting a diff type within the merchandising system, the batch process updates the 
description column within the PROD_DIFF_TYPE_DM table to ‘NULL’. The attribute 
name within the MicroStrategy project must be updated manually to the generic name 
corresponding to the DIFF_TYPE_KEY, by completing the attribute name update steps 
above. That is, if Color was deleted, the system updates the name of the Color attribute to 
DIFF 2. 
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