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Preface

Intended Audience
Welcome to Release 12 of the Oracle CADView-3D DeskTop User's Guide.

The purpose of this manual is to describe how to use the CADView-3D DeskTop Web 
browser plug-in and ActiveX control to view CADView-3D models and collaborate 
with other users over the Internet.

This manual is intended for all levels of end users. Basic Web browser and Windows 
computer system knowledge is assumed.

Important: The license cost of CADView-3D includes only Translators 
for the VRML v2 and STL open-source formats. Translators for other 
formats and CAD systems may be available through Oracle partners or 
third-party independent software vendors.

See Related Information Sources on page x for more Oracle Applications product 
information. 

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services 
within the United States of America 24 hours a day, seven days a week. For TTY 
support, call 800.446.2398. 

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 



x

facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading technology 
vendors to address technical obstacles so that our documentation can be accessible to all
of our customers. For more information, visit the Oracle Accessibility Program Web site 
at http://www.oracle.com/accessibility/ . 

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise 
empty line; however, some screen readers may not always read a line of text that 
consists solely of a bracket or brace. 

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any 
representations regarding the accessibility of these Web sites. 

Structure
1  CADVIEW-3D Overview
2  Installing CADView-3D DeskTop 
3  Launching CADView-3D Models
4  DeskTop Interface
5  Moving Around the Model
6  Selecting and Altering Objects
7  Window Menu Features
8  Communicating with Other Users
9  View Menu
10  DeskTop Tools
11  Preferences

Related Information Sources
This manual is intended to be used in conjunction with the other CADView-3D 
manuals. The following documents are also available for the CADView-3D product 
suite: 

• Oracle CADView-3D Studio User Guide

Describes how to install CADView-3D Studio

• Oracle CADView-3D Translators User Guide

Describes how to install CADView-3D Translators used to convert 3D models to 
CADView-3D format and optimize
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Integration Repository
The Oracle Integration Repository is a compilation of information about the service 
endpoints exposed by the Oracle E-Business Suite of applications. It provides a 
complete catalog of Oracle E-Business Suite's business service interfaces. The tool lets 
users easily discover and deploy the appropriate business service interface for 
integration with any system, application, or business partner. 

The Oracle Integration Repository is shipped as part of the E-Business Suite. As your 
instance is patched, the repository is automatically updated with content appropriate 
for the precise revisions of interfaces in your environment. 

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
Browser, database triggers, or any other tool to modify Oracle Applications data unless 
otherwise instructed. 

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of your 
data and you lose the ability to audit changes to your data. 

Because Oracle Applications tables are interrelated, any change you make using an 
Oracle Applications form can update many tables at once. But when you modify Oracle 
Applications data using anything other than Oracle Applications, you may change a 
row in one table without making corresponding changes in related tables. If your tables 
get out of synchronization with each other, you risk retrieving erroneous information 
and you risk unpredictable results throughout Oracle Applications. 

When you use Oracle Applications to modify your data, Oracle Applications 
automatically checks that your changes are valid. Oracle Applications also keeps track 
of who changes information. If you enter information into database tables using 
database tools, you may store invalid information. You also lose the ability to track who
has changed your information because SQL*Plus and other database tools do not keep a
record of changes. 
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1
CADVIEW-3D Overview

This chapter covers the following topics:

• Conventions

• What is CADView-3D DeskTop? 

• CADView-3D System Overview 

Conventions
The following conventions are used in this manual:

Convention Meaning

< > Angle brackets enclose user-defined data in 
filenames and paths as in 
C:\<orant>\CADView-3D\DesktTop\

where <orant> is the name of the Oracle Home
directory defined on your system.

Boldface text Boldface type in text indicates emphasis on a 
particular word or phrase.

Boldface Text With Initial Caps Boldface type with initial capital letters 
indicates a menu item or text in title bar of 
user interface.

What is CADView-3D DeskTop? 
The Oracle CADView-3D DeskTop is a Windows-based Web browser plug-in and 
ActiveX control that allows you to view and interact with 3D models that have been 
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translated from a computer-aided design (CAD) source file and published to a 
CADView-3D Server and Oracle database. The DeskTop viewer uses streaming 
technology to render large models in which you can navigate, query information, and 
interact with other users. 

In a realtime collaboration meeting, a group of users can collectively view the model 
and make group markups containing color-coded comments from each user that are 
stored with the model. 

CADView-3D System Overview 
From the perspective of an end user, the CADView-3D system components work 
together in the following manner when connected to the Oracle E-Business Suite: 
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• A user with a Web browser and the CADView-3D client clicks a link to open a 
document attachment for an item in the Oracle application. 

• An HTML page is created on the fly that points to the AMM data published in the 
Oracle database for that model. 

• CADView-3D DeskTop plug-in is launched. If a more recent version is available, 
you will be prompted to have it installed automatically. 

• AMM data points to records for geometry data, attribute data, and collaboration 
data in the Oracle database. 

• As the user navigates the model, geometry content (3D data) is streamed as needed 
to the DeskTop plug-in. 

• As the user queries the model or views the Parts List or Attributes window, 
attribute data (extracted from the original CAD model during optimization) is 
streamed to the DeskTop plug-in. 

• While viewing the model with DeskTop, users can send collaboration data to the 
database and receive collaboration data stored by other users in their group. 
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2
Installing CADView-3D DeskTop 

This chapter covers the following topics:

• Overview 

• DeskTop Installation 

• Notes About Installation and Auto-Upgrade 

Overview 
For more information about installation and system requirements, see:

• Minimum and Optimal System Requirements

• Oracle E-Business Suite Applications Supported

• DeskTop Installation

Minimum System Requirements
• CPU: Pentium class 500 MHz+ or equivalent

• RAM: 128 Mb+

• Hard disk and I/O: IDE

• Operating System: Windows XP /2000 / 2003 Server

• Web Tools: Internet Explorer v5, Netscape Navigator v4.7+, FireFox Mozilla 1.5.0.1 
or older

• Network Card (if using a network): 10 / 100 MIP

• Modem (if using a modem): 56 Kbs+
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• Video card: SVGA 16 bit

Optimum Configuration
• CPU: Pentium Class 3GHz or equivalent+

• RAM: 512Mb+

• Hard Disk: ATA, SATA, Ultra2 SCSI+ or equivalent

• Operating System: Windows XP / 2000 / 003 Server

• Web Tools: Internet Explorer v5, Netscape Navigator v4.7+, FireFox Mozilla 1.5.0.1 
or older

• Network Card (if using a newtork): 100 / 1 Gb MIP

• Modem (if using a modem):v.90, ISDN, DSL, Cable Model

• Video Card: On-board OpenGL hardware acceleration

Oracle JInitiator Java plug-in version 1.1.8.16 or higher if viewing models published as 
attachments in Oracle E-Business Suite using Forms. 

Note: You will be prompted to install JInitiator automatically when you
first connect to E-Business Suite with your Web browser.

Using CADView-3D DeskTop, you can attach models to certain business objects in the 
following Oracle E-Business Suite applications:

• Oracle Product Lifecycle Management

• Oracle Product Information Manager Data Librarian

• Oracle Enterprise Asset Management

• Oracle Manufacturing family of applications

• Oracle Project Collaboration

• Oracle Project Management

• Oracle Property Manager

• Oracle Service

• Oracle Sourcing
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DeskTop Installation 
CADView-3D DeskTop is provided in a separate Windows-based installer on your 
product CD. 

Alternatively, log in to E-Business Suite with a responsibility that allows you to view 
the CADView-3D application. On the Applications page, choose CADView-3D, click 
View Test Models & CADView-3D Components, and then click Install CADView-3D 
Components. On the Installers page, click CADView-3D DeskTop Installer to install the 
CADView-3D DeskTop plug-in. 

You are also prompted to install or upgrade DeskTop when you click View Test Model 
in the CADView-3D application. 

To install CADVIEW-3D DeskTop:
1. Navigate to the CADView-3DDeskTopSetup.exe fil,e and double-click it. 

2. Note: The DeskTop installer downloaded or launched from E-Business Suite is 
named ddddstin.exe.

3. In the Welcome screen, click Next to continue. 

4. In the Destination Folder screen, accept the default directory or click Change to 
browse to a different location. Click Next to continue. 

5. In the Setup Type screen, accept Default Complete or choose Custom and click Next
to choose a specific module to install. Click Next to continue. 

6. In the Ready to Install Program screen, click the Install button to begin installation 
or click Back to review or change settings. 

7. In the Installing CADView-3D DeskTop screen, the progress bar advances as 
DeskTop is installed by default to the destination folder 
\Orant\CADView-3D\DeskTop\ where Orant is your Oracle Home directory. 

8. In the Setup Completed screen, you can choose to view the "readme" file and click 
Finish to exit setup. The readme.txt file is stored in the installation directory. 

See also: "Notes About Installation and Auto-Upgrade" 

Notes About Installation and Auto-Upgrade 
Note: If you are a Netscape user installing the DeskTop plug-in for the 
first time or you are receiving an auto-upgrade, you will need to click a 
"puzzle piece" plug-in icon in the Web browser to download the 
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"ddddstin.exe" installer to a local drive. You can then double-click this 
file to install CADView-3D DeskTop. 

Note: In the Netscape version 7.0 Web browser, first disable the 
Netscape Plug-in Finder Service in order to download the 
CADView-3D DeskTop plug-in installer. Select 
Edit/Preferences/Navigator/Helper Applications and uncheck "Always 
use the Netscape Plug-in Finder Service (PFS) to get plug-ins."
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3
Launching CADView-3D Models

This chapter covers the following topics:

• Overview of Launching CADView-3D Models

• Launching a CADView-3D Model (stand-alone) 

Overview of Launching CADView-3D Models
Once a 3D model has been translated and published from a CADView-3D Translator 
and CADView-3D Studio, you can view it in a Web browser with the CADView-3D 
DeskTop viewer plug-in. 

Before using CADView-3D DeskTop for the first time you may want to check the color 
depth and resolution of your display. 

To check the color depth and resolution:
1. Click the Windows Start button, go to Settings, and choose Control Panel. 

2. Double-click the Display icon and go to the Settings tab. 

3. Verify that your monitor is set to High Color (16 bit) mode (65536 colors) or higher 
and Screen Area is set to 800x600 or higher. 

4. Click OK. 



3-2    Oracle CADView-3D DeskTop User's Guide

• See: Launching a CADView-3D Model (stand-alone)

• See: Launching a CADView-3D Model from Oracle E-Business Suite

Launching a CADView-3D Model (stand-alone) 

To view a model published to a stand-alone CADView-3D Server and Web 
server:
1. Once the CADView-3D DeskTop software is installed, open the Web page that 

contains the link to the published CADView-3D model. 

2. Click the descriptive link for the model on a Web page created by the person who 
published the CADView-3D models. 
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The CADView-3D plug-in is launched and the model is rendered in a separate Web 
browser window. You will typically see the model's name at the end of the URL as 
in Motorcycle.html below. 
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To Launch a CADView-3D Model from Oracle E-Business Suite:
For example, to view a model published to a CADView-3D Server and attached to a 
business object in Oracle E-Business Suite: 

Open a Web browser and navigate to the login page for E-Business Suite. 

1. Log in with a username and password that allows you to view the CADView-3D 
application. 

2. Choose the application containing the business object to which the CADView-3D 
model is attached. 

3. For example after choosing Items, click Basic Search.
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On the Simple Search page, enter an item name (or partial) and click Search. 

4. In the search results, select the item to which the model is attached. 

5. On the Summary page, click the Attachments tab. 

6. In the Attachment page, read the descriptions and click the corresponding link 
under Name to open the CADView-3D model. A separate Web browser is launched
with the model loaded in the CADView-3D DeskTop viewer. 

Note: The model's name is not displayed in the URL when you 
launch DeskTop from E-Business Suite. Instead, find it in the 
Server/Model Information window. 
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Note: Depending on how the person who created the attachment 
set up the initial view of the model, you may see an animation in 
the model, a path navigating through the model, an isolated part or
group of parts, or a markup image. 

See also: Notes About Installation and Auto-Upgrade.
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4
DeskTop Interface

This chapter covers the following topics:

• DeskTop Interface 

• DeskTop Menus 

• Mouse Action Toolbar 

• Navigation Bar 

• DeskTop Windows 

• Pop-up Menu 

• Tooltips 

• Background Color 

• Server/Model Information 

• Help Content 

• Keyboard Shortcuts 

DeskTop Interface 
The CADView-3D DeskTop interface has been designed for ease of use so that the first 
time user can quickly become productive. All the features are organized in a menu 
system, and can be accessed using icons on the left pane of the window. 

The DeskTop includes support for creating and viewing Change Management objects 
that originate from the E-Business Suite, Product Lifecycle Management, and the 
Product Information Management Data Librarian applications. 

You can view the following for an overview of the new DeskTop interface. Follow the 
links in each section for more detailed information. 

• DeskTop Menus 
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• Mouse Action Toolbar 

• Navigation Bar 

• DeskTop Windows 

• Pop-Up Menu 

• Tooltips 

• Background Color 

• Preferences 

• Help 

• Keyboard Shortcuts 

DeskTop Menus 
New menus have been defined for the icons in the toolbars but their functionality 
remains the same.

• Display menu 

• Window menu 

• Meeting menu

• View menu

• Tools menu

• Preferences men

• Meeting menu 
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When you change the size of the Web browser window, menus on the left side of the 
window will appear/disappear to fill the space available. These menus can also be 
found in the right-click, pop-up menu and by clicking the double-arrow ">>" icon under
the Oracle logo at the top of the screen. 

Mouse Action Toolbar 
The mouse action toolbar provides tools to move through the model and select objects 
to view. 

The top row contains icons used to rotate around, fly through, and pan your view 
across the model. The bottom row contains icons used to zoom into an area of interest, 
to pick objects by dragging a rectangle, and to pick by dragging sphere. To see the name
of a tool, hover the mouse pointer over the tool to see the tooltip. 
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Note: In Fly-through and Pan mode, you can drag the cursor a short 
distance and then stop and hold left mouse button to continue moving 
in that direction.

See: Zooming Into a Window

See: Rotating Your View Around the Model

See: Selecting and Deselecting Objects

Navigation Bar 
The Navigation bar contains arrow icons and other controls to move your view in the 
scene. 

For more information, see: Moving Around in the Model 

DeskTop Windows 
In the main window the various CADView-3D DeskTop windows are docked at the 
edge by default. To undock right click inside the window and choose Undock. To see 
the name of a window in the title bar, undock it. 
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To Dock a window, right click inside the window and choose Dock 

See: Using the Window Menu Features

See also: Creating Markups

Pop-up Menu 
To access the pop-up menu, right click anywhere in the viewing window to open the 
menu and then left click to make a selection. 

This menu provides a shortcut to access frequently used features, such opening 
tools/windows, straightening the camera and fitting the model to view. 
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Tooltips 
Tooltips are text labels that appear when you place the mouse pointer over certain areas
in DeskTop without clicking. 

Tooltips identify each icon on the mouse action toolbar and other toolbars found in 
DeskTop tools and windows. 

Tooltips reveal the part name and centerpoint location of each object. 

When the Dimensioning window is open, tooltips show the distance between the 
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currently selected points in the model. 

Note: You can set Tooltip attributes in the General Preference settings 
tab. 

Background Color 
Depending on the color of your model, you may want to change the background to a 
contrasting color in the viewing window. 

Click any one of the colored circles at the bottom of the screen to change background 
color in the scene. Click the circle with the question mark to open the color palette to 
create a custom color. 

Server/Model Information 
Choose Server/Model Information in the Window menu to open the Server/Model 
Information window. The model name is listed first followed by information about the 
CADView-3D Server and Oracle database. 
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Note: The model name also appears as the top node in the hierarchy in 
the Structure window. 

The model name is created in the CADView-3D Translator. By default, it is a unique 
name generated by the Translator at the time of publishing based on the CAD source 
file prefix, the user login name, and a timestamp (year:month:day:hour:minute:second). 

For example, a model named "engine_blocktjones020315182500" was published from a 
CAD source file "engine_block.xxx" by "tjones" March 15, 2002 at 6:25pm. 

Note: Models published from CAD applications with 2D support will 
have "_2D" or "_3D" appended to the CADView-3D model name as in 
"engine_ blocktjones020315182500_3D"

However, the CADView-3D model name can also can be a unique, user-defined name 
entered in the CADView-3D Translator "CADView-3D Model Name" setting during 
publishing (e.g., "57ChevyEngine" or "Headset"). 

(chap4_12)

Note: If the model was created using the Attachment window, the 
model name may be appended with an additional string as in 
"Headset_Initial-path" to show that an initial path begins to play when 
the model opens. 
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Help Content 
Click Help Topics in the Help menu to open Windows-based Help system in a separate 
window. 

Use the Contents tab to navigate in the topic hierarchy. Double click a topic to display 
the help text in a separate window. 

Use the Find tab to do a keyword search to obtain a list of topics containing that word. 

See also: About Box Version Number 

About Box Version Number 
To find the version number of your CADView-3D DeskTop client, choose About 
CADView-3D DeskTop in the Help menu to open the About box. 

Note: You can also see the version number by choosing Show Statistics 
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in the Preferences menu. 

Keyboard Shortcuts 
You can use the following keyboard shortcuts to perform commonly used commands 
found in DeskTop menus. 

Note: Make sure to first click inside the viewing window before using 
the keyboard command; clicking the browser title bar is not sufficient. 

Action Key

Fit object in view F

Hide selected objects H

Show last object hidden S

Show all hidden object A

Isolate selected objects I

Unisolate all objects U

Clear all selections C

Cycle between Rotate Around, Fly Through 
and Pan model

E

Toggle between last and current viewpoint B

Pick by rectangle CTRL+SHIFT while clicking and dragging 
mouse pointer

Pick by sphere ALT while clicking and dragging mouse 
pointer

Straighten up Spacebar

Zoom in CTRL+ALT while clicking and dragging 
mouse pointer
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Action Key

Exit Full Screen Mode ESC (escape)

Increase navigation speed + (plus)

Decrease navigation speed - (minus)
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5
Moving Around the Model

This chapter covers the following topics:

• Overview of Moving Around in the Model 

• Zooming Into a Window 

• Rotating Your View Around the Model 

Overview of Moving Around in the Model 
You can use the direction arrow icons on the navigation bar to move your viewpoint 
through the model or you can use the mouse action toolbar and click and drag your 
mouse pointer in the window to move in that direction. 

• Click the Straighten Up icon (circle in upper left corner) to level your view. You can 
also press the spacebar on the keyboard to straighten up. 

• Click the Fit icon (circle in upper right corner) to fit the entire model in the viewing 
window. 

• The direction arrow icons "pan" or move your view in one plane like moving along 
a conveyor belt left and right or on an elevator up and down. 

• By dragging the sphere around in the middle you can rotate the model about its 
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centerpoint. 

• Click the Zoom + (plus) and - (minus) buttons to move toward or away from the 
model respectively. 

• You can change the movement speed choosing from Very Fast to Very Slow in the 
Speed menu. You can also click Select to open the Set Speed dialog and drag the 
Speed slider to the right (faster) or to the left (slower). 

See: Zooming Into a Window

See also: Rotating Your View Around the Model

Zooming Into a Window 
You can use the Zoom Window feature to see a closer view of an area in the model. 

To zoom into a window:
1. Click the Zoom Window icon in the mouse action toolbar.

2. Click the upper left corner of the area you want to zoom in to then drag a rectangle 
diagonally downward. 

Objects seen in the selection rectangle will then fill the screen.

Note: When you are in another mode, such as Examine or Fly 
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Through, you can also press and hold the Ctrl and Alt keys and 
drag a Zoom Window. 

To view a larger area of the model again, click the minus Zoom minus - button or 
clear any selected objects and click the Fit icon or press the F key to see the entire 
model. 

Rotating Your View Around the Model 
In normal Fly-Through navigation mode, you can move your viewpoint in any 
direction as you move around the model. 

In Rotate Around navigation mode, the target of your viewpoint is fixed at the center of 
model (or selected objects) as you rotate around or zoom in and out. You typically use 
Rotate Around to examine selected objects from all angles while automatically keeping 
them within your view. 

Rotating Around the Model:

To rotate around the model
1. Select the objects you want to rotate around. 

Note:  If no objects are selected initially, you will rotate around the 
entire model. 

2. Click the Rotate Around icon on the mouse action toolbar or press the E key. 
Selected objects are automatically isolated in wireframe and fit to the center of your 
view. 
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3. Drag the mouse to rotate your view about the centerpoint of the objects. 

Note: With only one object selected, it appears that the object is 
rotating about its own axis and you are stationary. 

4. When rotating around the model is done, click the Fly Through icon to return to 
normal Fly Through navigation mode. 

Note: You can modify the appearance of selected objects by setting 
Pick and Navigation Preference settings. For example, you may 
want objects to appear isolated and not in wireframe.

See: Moving Around in the Model; See also: Moving Your Viewpoint While 
Rotating Around; See also: Adding and Subtracting Objects While Rotating Around

Moving Your Viewpoint While Rotating Around
5. Click the Straighten Up icon or press the keyboard spacebar to return your view to 

the CADView-3D standard orientation of Y-axis up and Z-axis toward you. 

Additionally, you can use the following mouse and keyboard commands to move 
your viewpoint when examining objects: 
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Key Command Movement

Click and drag the mouse pointer. Rotates your view dynamically about the 
center of the objects.

Shift-click and drag the mouse pointer up 
and down.

Moves your view toward or away from the 
objects.

Control-click and drag the mouse pointer. Pans your view across the objects. 

Alt-click and drag the mouse pointer. Moves the center of rotation off axis in 
proportion to the amount of movement. 

F11 (holding) Rotates your view continuously about the 
model when in Rotate Around mode.

F12 (holding)  

Note:  If movement appears too fast or too slow, adjust the speed 
slider accordingly. You can also drag the mouse pointer a short
distance and then press F11 or F12 to slow the rotation and, 
conversely, drag it a longer distance to increase the speed. 

Adding and Subtracting Objects While Rotating Around
Without rotating around objects, you can add or subtract objects from the group you are
examining. 

6. In Preference settings, clear the Navigation option Automatically isolate when 
rotating objects.

7. Click the Rotate Around icon or press the E key. 

8. Control-click the objects you want to add to or subtract from the isolation set. 

9. Click the Fit icon or press the F key to adjust your navigation centerpoint to match 
the center of the new group of objects.

10. When finished rotating around the objects, click the Fly Through icon to return to 
normal navigation mode.
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6
Selecting and Altering Objects

This chapter covers the following topics:

• Selecting Objects and Altering Their Display 

• Selecting and Deselecting Objects 

• Tool Mouse Action 

• Fitting Objects to View 

• Hiding and Showing Objects 

• Isolating Objects 

• Using the Sectioning Plane 

• Using Extended Object View with Large Models 

• Displaying the Model in Wireframe 

• Displaying the Model with High Quality Lighting 

Selecting Objects and Altering Their Display 
You can select objects in the viewing window and then use the Display menu features 
to alter their appearance. For more information see the following topics:

• See: Selecting and Deselecting Objects

• See: Fitting Objects to View

• See: Hiding and Showing Objects

• See: Isolating Objects

• See: Using the Sectioning Plane

• See: Using Extended Object View with Large Models
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• See: Displaying the Model in Wireframe

• See: Displaying the Model with High Quality Lighting

Selecting and Deselecting Objects 
Select or pick a single object by clicking it in the viewing window. To add subsequent 
objects to the selected group, press the Shift or Ctrl key while selecting the objects. 

When you select an object, it appears by default in red triangular wireframe. 

Note:  Modify the appearance of selected objects in Pick Preference 
settings. 

• To deselect all selected objects, you can simply click empty space around the model,
choose the Clear Selection icon on the Display menu, or press the C key. 

• To deselect a single object within a group, press the Ctrl key and click the object. 

• You can also drag the mouse pointer to select groups of objects in the following 
manner: 
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Tool Mouse Action 
To use the tool mouse:

• Click and drag a selection rectangle around a group of objects. 

• Pick by Rectangle icon 

Only objects that fall within the rectangle and are in view (and not behind other objects)
are selected, or hold Ctrl+Shift keys while dragging mouse pointer. 

• Pick by Sphere icon Click and drag a sphere from the object's center point. 

• Every object within or touching the sphere is selected when you release the mouse 
button. 
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Note: There are other tools you can use to select and display objects in 
the model based on attribute values, see Parts List.

Fitting Objects to View 
You can use Fit to change your eyepoint so selected objects are centered in the viewing 
window. 

Select the objects and choose Fit in the Display menu. You can also click the Fit icon on 
the Navigation bar or press the F key. 

If you are zoomed in too far in the model you can click Fit to quickly zoom out again. If 
no objects are selected, the entire model is centered. 

Hiding and Showing Objects 
You can selectively hide and show certain objects to better see objects in the interior of 
the model, for example. 

• To hide an object, select it and choose Show/Hide in the Display menu or press the 
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H key. 

• To display the last hidden object again, select Show/Hide. 

• To display all hidden objects, select Show All in the Display menu or press the A 
key. 

Related Topics
Using the Sectioning Plane

Isolating Objects 
You can select and isolate objects in a model so adjacent objects will not block your 
view. 

• To isolate an object, select it and choose Isolate in the Display menu or press the I 
key. 

• To isolate an object already within a set of isolated objects, select the object and 
choose Isolate in the Display menu again. 

• To unisolate an object, select it and choose Unisolate in the Display menu or press 
the U key. 
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Using the Sectioning Plane 
You can drag a sectioning plane across the 3D model to dynamically cut away slices of 
the model to view cross-sections of interior parts. 

To drag a sectioning plane across a model:
1. If desired, select and isolate a group of objects in the scene. 

2. Navigate to the desired view of the model. 

3. Set a lighter background color if necessary. 

4. Choose Sectioning in the Display menu. The Sectioning screen appears and a plane 
cuts the objects into two sections, creating a visible and an invisible half. 

5. Use the Plane Offset slider on the Sectioning screen to dynamically drag the plane 
across the objects. 
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The following features are available in the Sectioning screen: 

Parameter Description

Plane Specify the axes on which to position the 
plane (xy, yz, zx, General)

Plane Direction Choose the side of the plane on which the 
objects are visible.

Plane Normal Tilt the plane from perpendicular to major 
axes. Try whole unit increments. Click 
Accept to enter values (use with General 
Plane setting)

Plane Position Enter numeric values to move the plane 
along the X Y Z axes from default center 
position . Click Accept enter the values (use 
with General Plane setting).

Plane Normal Tilt the plane from perpendicular to major 
axes. Try whole unit increments. Click 
Accept to enter the values.
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Parameter Description

Plane Offset Slide the PLane Offset slider to move the 
sectioning lane through the model.

Show Model Set Half, All, or None to determine how 
much of the model is displayed as the 
sectioning plane is moved through it.

Show Edges Define the edges of the objects at the 
cross-section in a yellow outline. 

Show Plane Set Wireframe to see only the plane outline. 
Set Transparent to make the plane 
transparent using Plane Color. 

Plane Color Set the color used for plane outline or 
transparency. 

Accept New Selection To add parts to the cross section, select the 
parts in the model and then click Accept 
New Selection. 

Maintain Settings on Close Close the Sectioning dialog but keep the 
sectioning plane visible. You may want to 
section the model before using the 
Dimensioning tools or Markups. 

Using Extended Object View with Large Models 
The Extended Object View feature enables you to quickly navigate very large models by
allowing you to pull in the far clip plane and simplify the display of geometry beyond 
it. You can then navigate at a high frame rate before the model is done loading. 

To navigate at a high frame rate:
1. First fit the entire model in the viewing window. 

2. Choose Extended Object View in the Display menu. 

3. Adjust the Far clip plane slider in Graphics Preference settings to reduce the 
amount of geometry to be rendered. 

The model geometry between the near and far clip planes appears as usual. 
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However, the model beyond the far clip plane is displayed as a set of outline boxes. 

4. Navigate to the desired position in the model and turn off Extended Object View 
and adjust clip planes if necessary. 

You can perform the following actions in the Extended Object View toolbar or with 
the corresponding keyboard shortcuts. 

Action Key

Increase far clip plane (by 1/10th) Right arrow 

Decrease far clip plane (by 1/10th) Left arrow 

Increase resolution Up arrow 

Decrease resolution Down arrow 

Displaying the Model in Wireframe 
By default, CADView-3D DeskTop displays models with Gouraud shading which 
interpolates a smooth surface in place of the underlying triangular wireframe. You can 
also choose to display the wireframe view of the model. 
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Choose Wireframe in the Display menu to view the model in wireframe. 

Displaying the Model with High Quality Lighting 
DeskTop automatically detects whether your graphics card has OpenGL acceleration. If 
so, the High Quality Lighting icon on the Display menu is enabled automatically. 

Example with High Quality Lighting turned off: 

Example with High Quality Lighting turned on:



Selecting and Altering Objects    6-11

Related Topics
Lighting tab in Preference settings
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7
Window Menu Features

This chapter covers the following topics:

• Using the Window Menu Features 

• Structure Window 

• Querying Attributes to Display Parts 

• Parts List Window 

• Attributes Window 

• URLs Window 

• Attachment Window 

• Change Management Window 

• Top and Front View Windows 

Using the Window Menu Features 
CADView-3D DeskTop contains the following features in the Window menu.

• Structure Window

• Parts List Window

• Querying Attributes to Display Parts

• Attributes Window

• URLs Window

• Attachment Window

• Change Management Window
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• Top and Front View Windows

Structure Window 
The Structure window displays tree structure of parts (objects) and assemblies 
(hierarchical groups of objects) that were defined in the CAD source model. You can use
the Structure window to select parts and structures to view, isolate, select, and rotate 
around in the main viewing window. You can also query model attributes and isolate 
specific parts in the model with certain attribute values. 

To display or hide a structure node:
1. Select Structure in the Window menu to display a list of structures (or assemblies) 

in the model. 

Click the + (plus) sign next to a node in the structure to expand the hierarchy. The 
parts belonging to that node appear in the Parts List window if it is open. 

2. Select the checkbox next to a structure node to turn off the display of those parts in 
the viewing window. 

3. To locate a picked part in the structure, select an object in the model.

4. Click the Locate Picked Part in Structure button to highlight the part(s) in the 
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structure. 

To change the way an assembly is displayed:
5. Right-click a node in the structure. 

6. In the menu that appears, select an action such as Rotate Around, Fit, Isolate, 
Change/Revert Color, or Select/Deselect. 

The change will be reflected in the viewing window. 

Querying Attributes to Display Parts 
You can perform an attribute query to find and display a group of related parts in the 
model. Each query can have a default action such as isolate or change color. The query 
node is saved in the structure where you can view it again and share it with other users.

Note: You can also open the Create /Edit Query dialog by 
double-clicking any attribute in the Attributes window. 

To create a query node in the structure:
1. Open the Structure window. 

2. Select a node in the structure.gh

3. Click the Query Database button in the Structure window to open the Insert Query 
at Current Location dialog. 

Note: If no queries have been created previously, you will open the 
Create/Edit Query dialog directly. 

4. Click New Query to open the Create/Edit Query dialog. 

5. To build your query, choose an attribute from the list of all attributes in the model. 

6. Click an operator button, such as = equal to, < less than, > greater than, or <> not 
equal to. 
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7. Enter a value for the search. Queries to the Oracle database are case-sensitive. 

8. Specify the default query action such as Isolate, Rotate Around, Fit, or Change 
Color. 

9. Enter a Query Name and select the Share Query checkbox if you want other users to
view your query. 

10. To perform the query click OK. A node containing the objects that match the query 
appears in the structure. The objects found in the query are displayed in the 
viewing window. 

Note: You cannot edit or delete a query in the Other People's Public
Queries area; however, you can copy it to your list of queries by 
selecting it and inserting it in the structure. 

Note: If you are using E-Business Suite, you can also use the 
Attachment window to set a query as the initial view when the 
model is first opened. 

Reusing Queries in the Structure: Once a query has been created, you can reuse it 
by inserting it in another node in the structure. 

To insert an existing query
11. Open the Structure window. 

12. Select a node in the structure. 

13. Click the Query Database button to open the Insert Query at Current Location 
dialog. 

14. Select an existing query and click Insert Query. 

A node containing the objects that match each query appears in the structure, and 
the objects found in the query are displayed in the viewing window. Queries are 
automatically stored with the model. 

Note: You can select multiple queries by holding the Shift or 
Control key during selection. However, you can only select queries 
of one type - either public or private but not both at once. 
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Parts List Window 
Choose Parts List in the Window menu to display a list of parts with their attributes for 
the currently selected node in the Structure window.

To view the Part List window:
1. Click the + (plus) sign next to a part to display a list of attributes and values. 

2. Right-click a part name and in the menu that appears choose an action such as 
Isolate or Unhighlight to change the display of the object. 
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If the Fit Part on Selection button is set (default), the part is automatically centered 
in your view when chosen. 

3. Click the Toggle ID's button to display part name of ID number.

4. To search for an object by name, enter the name in the blank field and click the 
Search for a Part button next to it. 

Attributes Window 
If parts in the CAD source model contained attributes or parameters such as mass, 
color, or height when translated to CADView-3D format, they were extracted and saved
with the model. You can use the Attributes window to check the attribute values of an 
object or to search for objects with particular attribute values. 
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To view the attributes of a part:
1. Select Attributes in the Window menu to open the Attributes window. 

2. Put the mouse pointer over an object (you do not need to select it). A list of 
attributes and values for that object appears in the Attributes window. 

To query the model for a list of objects with certain attribute values:
3. Double-click the name of an attribute in the list. The Create/Edit Query screen 

appears with the attribute chosen added to the query. 

4. Follow the procedure after Click New Query in the Structure Window topic 
Querying Attributes. This screen can be opened from either location. 

Note: You can also display an object's attributes and values and 
perform other actions in the Parts List. 

URLs Window 
Using the URLs window, you can link a web address (URL) for a document or other 
information online to a selected part or to the model as a whole. Linked URLs can be 
shared (public) or unshared (private).
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To link a URL with a model or part:
1. To link a URL to a part, you must first select it. If no part is selected, the URL will 

be available no matter what object is picked in the model. 

2. Select URLs in the Window menu. The URLs window appears and MyURLs is 
selected. 

3. Click the Add URL icon. 

4. Enter a URL (with or without http:// prefix) and an alias name (required). Users will
see this name in the URLs window and also under URLs in the View menu. 

5. Click either Public or Private. Public URLs are shared with all users. Private URLs 
are available only to you. 

6. Click OK to save the URL with the model. 

To view a linked URL from URLs in the Window menu: 
7. Select URLs in the Window menu to open the URL window. 

8. Select the desired part in the model, if necessary. 

9. Double-click the web address in the URLs window list or highlight the URL and 
click Launch URL. The URL is launched in a separate Web browser window. 

URLs listed under My URLs or under another user's name are linked to a particular
part. That part must be selected in order for the URL to appear in the list. 

Note: Alternatively, pick a part or use the Parts List to locate a part,
and use URLs in the View menu to launch the URL. 
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Attachment Window 
When a model is published to a CADView-3D Server connected to Oracle E-Business 
Suite, Attachments is available in the Window menu. You can attach the model from 
CADView-3D DeskTop to the following business objects in supported Oracle 
applications: 

• Organization 

• Item - item or item revision 

• Asset 

• Project - project or task 

• Quote - quote or quote line 

• Service 

• BOM - primary or alternate 

• Routing - primary, alternate, revision, or sequence 

• Purchase Order 

• RFQ 

• Requisition 

• Location 

• Lease 

Restrictions
To attach the model to an E-Business Suite object: 
1. In CADView-3D DeskTop, choose Attachments in the Window menu. 

2. In the Attachments window, double-click the type of object to which you want the 
model attached (e.g., Item, Asset, Project, etc.). 
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3. In the Attach To screen, accept the default Description or enter a descriptive name 
for the model. 

Note: This name will become the model name in DeskTop's 
Server/Model Information screen. It will also appear on the 
Attachment page in E-Business Suite as the description users view 
to select the model. 

4. Enter the required information for the business object you want to attach the model 
to. You can enter a partial name and use the Search button to query the database to 
select a value. 

Note: All queries to the Oracle database are case-sensitive. 
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5. In the Search Results screen, make a selection and click OK. 

6. You can use the attachment icons to select any of the following to occur when the 
model is opened (optional): 

Query - open the model with an object or set of isolated objects 
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• Viewpoint - open the model and view it from a particular viewpoint 

• Markup- open the model with a markup image visible 

• Path - open the model and immediately play a path

• Animation - open the model with an animation playing in a loop

• Query + 

• Viewpoint - open the model with a particular view of isolated object(s) 
(chap7_20)

Viewpoint - open the model with a particular view of an animation playing 

Note:  When any of the above are selected, text is appended to the 
model name in the Description field. For example, model_name 
becomes model_name_ inspection route.

Animation + 7. Click OK to attach the model to the object in the database in 
E-Business Suite.

Launching a CADView-3D Model from Oracle E-Business Suite
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Note: You can delete an attached model from the Oracle 
application interface; however, the attachment will still appear in 
DeskTop's Attachment window. You cannot delete an attachment 
from the CADView-3D DeskTop viewer interface. 

However, if you are logged into E-Business Suite with a responsibility that allows 
you to view and administer the CADView-3D application, you can delete models in
the Administer CADView-3D Models page. 

Change Management Window 
Using CADView-3D DeskTop you can create a Change Management object (e.g., a 
change request, change order, or issue) in the Oracle Advanced Product Catalog 
application in E-Business Suite. 

To view a Change Management object:
1. Launch CADView-3D DeskTop by opening a model that is attached to an item. 

2. In the Window menu, select Change Management. 
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Note: This menu item is visible only when you launch 
CADView-3D DeskTop from an item in Oracle Advanced Product 
Catalog. 

3. Select a Change Management category and double-click an entry in the list to 
display a page for that change object inside Advanced Product Catalog. 

Note: All change objects that are associated with an item and that 
you have permission to view are displayed. 

To create a Change Management object:
Open CADView-3D DeskTop by launching a model that has been attached to an 
item. 
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4. In the Window menu, select Change Management. 

5. In the Change Management window, select the change object in the Create list and 
click Go. 

6. A corresponding page in Oracle Advanced Product Catalog is opened in a separate 
Web browser window. 

7. Follow the prompts to create the change object. The corresponding change object 
appears in the Change Management window in CADView-3D DeskTop. 

Top and Front View Windows 
You can use the Top View and Front View windows to arrange top and front views of 
the model with specific clip plane settings. 

• Select Top View or Front View in the Window menu to open a small window in 
which the model is seen from above or from the side. 

• To center a part of the model, right-click and drag the view. 

• To zoom in or out, drag the zoom slider. 

• To move your view, left-click to position the white triangle. The view in the main 
viewing window moves accordingly. 

• To rotate your view, hold the Ctrl key while you left-click and drag the triangle 
(view frustum). The view in the main viewing window rotates accordingly. 

• To move the near and far clip planes, put the mouse pointer over the white triangle 
and drag the red lines (clip planes). 

• To update the near and far clip planes and save them with the model, click the 
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Change Near/Far Clip button to modify them in Graphics Preference settings. 



Communicating with Other Users    8-1

8
Communicating with Other Users

This chapter covers the following topics:

• Meeting and Collaborating with Other Users 

• Conducting a Collaboration Meeting 

• Following as Passenger in a Collaboration Meeting 

• Joining a Meeting Already in Progress 

• Transferring Control from Driver to Passenger 

• Leaving a Collaboration Meeting 

• Creating a Group Markup 

• Viewing Location of Other Users with Avatars 

• Chatting with Other Users 

• Viewing the Journal 

Meeting and Collaborating with Other Users 
You can also interact with a model in a collaboration meeting in which there is one 
driver and multiple passengers. While in a meeting, the passengers see what the driver 
sees as the driver uses the DeskTop features. Participants in a meeting can stop to create
a group markup adding markups in realtime on a shared desktop that is visible to 
everyone in the group. 

Any number of collaboration meetings can be active in the model at a given time. You 
choose which meeting you want to join and you will only interact with others in that 
meeting. 

Note: To assure complete interoperability of all features within the 
DeskTop during multiuser collaboration, Oracle recommends that all 
users be on the same release level. R12 users may be able to collaborate 
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with DeskTop users of previous release on certain functions, but such 
type of mixed environment is not certified.

Conducting a Collaboration Meeting 
In a collaboration meeting, the person who starts the meeting acts as driver moving the 
viewpoint and using DeskTop tools, controlling what the passengers see. The driver can
transfer control to a passenger at any time. 

To start a collaboration meeting:
1. Choose Start Meeting in the Meeting menu. 

The Invite your meeting group screen appears showing the meeting name how 
many other users have been invited. You can change the default name if desired. 

Other users receive an invitation screen asking if they would like join the meeting 
and become a passenger. 

If there are users who have not yet accepted or declined, you can click Go with 
current to start the meeting without them. Once the meeting begins, the driver can 
navigate the model as usual and work with the DeskTop tools.

Following as Passenger in a Collaboration Meeting 
After accepting an invitation from a driver to join a meeting, your DeskTop interface 
changes to that of a passenger. As a passenger, you follow what the driver sees while 
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navigating the model.

For passengers, a Meeting toolbar appears, and all other interface controls disappear 
when the driver takes control. 

Joining a Meeting Already in Progress 

To join a meeting already in progress:
1. Choose Join Meeting in the Meeting menu to notify the driver that you would like 

join a meeting already in progress. 

2. The driver will accept or deny your request. 

Note: If a group markup is in progress, you will not be able to join 
the meeting until the driver ends the group markup. 
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Transferring Control from Driver to Passenger 
The driver can transfer control to a passenger at any time during the meeting. 

To transfer control from Driver to Passenger:
1. Choose Transfer Control in the Meeting menu to pass control from driver to a 

designated passenger. 

The passenger will be prompted that control has been transferred to them. 

2. The new driver can in turn pass control to a passenger if another person wants to 
drive the meeting. 

Leaving a Collaboration Meeting 
You can leave a collaboration meeting at any time. 

To leave a Collaboration meeting:
1. Click the Leave Meeting icon on the Meeting toolbar to leave the meeting and 

return to regular navigation of the model. 

Creating a Group Markup 
Markups created during a collaboration meeting are called group markups. By choosing
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Markup in the Tools menu, the driver can start a group markup meeting that includes 
all passengers in the collaboration meeting. 

Group markups differ from individual markups in the following ways: 

• A color-coded legend lists all participants in the collaboration. 

• Since each user is assigned a unique color, you cannot change the color of drawing 
and text. 

• Each user can create and delete their own edits; however, only the driver can 
discard all edits or cancel or save the markup. 

• You should not resize the Web browser window when in a group markup meeting. 

Note: Because of differences in bandwidth and processor speed, at 
times passengers see the model with a slight delay during a group 
markup meeting. For example, the driver may start adding markup to 
an object that is not yet visible to some passengers.

Viewing Location of Other Users with Avatars 
In collaboration meeting, you can view the instantaneous location of other users in the 
model and then jump directly to their viewpoints. 

To view locations:
1. Choose Avatars in the Meeting menu (or on the Meeting toolbar during a meeting) 
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and click in the viewing area to view the location of the other users. 

Note: Each user viewing a model is represented by a colored cone 
and a user name. The cone is pointed in the direction the user is 
viewing.

2. To jump to the viewpoint of another user, choose Jump to Viewpoint in the View 
menu and select the viewpoint of another user. 

Note: During a collaboration meeting, user names appear along 
with predefined viewpoints. When you choose a name in the list, 
you are transported to the viewpoint of that person.

Chatting with Other Users 
Using the chat area of the Meeting window, each user viewing the model can broadcast 
text messages to others in their meeting. The text for each meeting is recorded in the 
Journal and stored with the model. 
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To chat with others:
1. Choose Chat in the Meeting menu. 

2. Type a message in the text box that appears and click the Send button. 

3. Other users in the model will see your message appear in their chat window and 
can reply to you in the same manner. 

4. To save the chat text for your meeting, click the floppy disk icon and save as a .txt 
file to your local drive. 

Viewing the Journal 
The Journal displays the start time/date for all collaboration meetings in the model 
along with the driver and passenger user names. It also contains a text archive of the 
meeting for each collaboration meeting. This information is available at all times to any 
user viewing the model. 

The Journal is saved automatically in the database with the model when you close 
DeskTop. You can also select a portion of the journal and save it on your local drive in a
text (.WRI) file. 

To view the Journal:
1. Choose Journal in the Meeting menu to see a list of all meetings previously logged 

for the model. 

2. Check or uncheck boxes next to dates/times in the left column to see the text 
contents of the meetings on the right. 

3. To save the selected meeting contents in a text (.WRI) file on your local drive, click 
the floppy disk icon. 

4. In the Save As dialog, enter a location and name for the file and click OK to save the
selected portions of the journal to your local drive. 
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9
View Menu

This chapter covers the following topics:

• Using View Menu Features 

• Viewing Markups 

• Replying to a Markup 

• Showing Location of All Markups in Scene 

• Playing Animations 

• Playing Multiple Animations 

• Playing a Path 

• Jumping to a Viewpoint 

• Showing Location of All Viewpoints in Scene 

• Opening a URL for Additional Information 

Using View Menu Features 
You can view markups, animations, paths, viewpoints, and URLs that you and other 
users create with the corresponding DeskTop tools. 

Viewing Markups 
Markups are bitmapped images that provide visual notes about the model that are 
saved with the model to share with other users. 

To view markups from the View menu:
1. In the View menu, choose Markups and then choose the desired markup to display 

the image. 
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2. In the Markup toolbar you can click buttons such as Reply to Markup, Print 
Markup, or Email Markup to open a markup with the markup toolbar. 

3. Click Save and Close Markup to close the image and return to the normal viewing 
window. 

Note: Do not use the Web browser's back button to return to the 
previous screen.

To view markups from the Markup tool
4. In the Tools menu, choose Markups and then choose the desired markup to display 

the image. 

Note: To see more markups in the list, click and drag to raise the 
top border. Scroll through the list using the scroll bar.

5. Click a heading such as Name or Author to sort by that characteristic. 

6. Click a name in the list to display the markup. 
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Note: URLs found in markups are not associated with specifc 
objects. Use the URLs window if you want to link a URL to a 
specific art of the model.

Replying to a Markup 
You can click the Reply to Existing Markup button to add or delete your own markup 
in a copy of an existing markup. 

To reply to a markup from the View menu:
1. Choose Markups in the Views menu. 

2. In the Markup toolbar, choose Reply to Existing Markup to open the markup tools. 

3. Use the tools provided in the Markup Toolbar to add or delete markups. 

4. When done, click the Save and Close Markup button to save the markup in the 
database with the model. 

To reply to a markup from the Markup window
5. Choose Markups in the Tools menu. 

6. Select (highlight) the markup you want to respond to from the list in the Markups 
window. 

7. Click the Reply to Markup button. 
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8. Use the tools provided in the Markup Toolbar to add or delete markups. 

9. When done, click the Save and Close Markup button to save the markup in the 
database with the model. 

A new markup is created with the Re: prefix followed by the existing markup 
name, for example, Re: michaelv13:45. 

Note: If multiple replies exist for one markup, refer to the Author 
field in the list to differentiate them. If a reply is based on an 
existing reply, a prefix number is added, for example, Re(2): 
michaelv13:45.

Showing Location of All Markups in Scene 
If you set the Show All Markups in Scene option in the General Preference tab, labels 
appear in the viewing window for all markups saved with the model. Each label 
contains the name of the author and the time it was created. 

Use this method to display all markups. If you want to create or modify individual 
markups, use the Markups feature in the Tools menu. 

To open a markup from the main window:
1. Click a label to open the markup in the same Web browser. 
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2. To close the markup, right-click the image and return to the main viewing window. 

Note: Do not use the Web browser's Back button; this will return 
you to the web page from which you launched the model.

Playing Animations 
Animations are created to show assembly sequencing or moving parts of a model, for 
example. Using the View menu, you can play back animations previously created with 
the Animation Tool. 

To play an animation:
1. In the View menu, choose Animations, then Play, and then choose an animation 

from a user's list. The animation plays until the end of its timeline. Looped 
animations play continuously. 

2. Choose Track in the Animations menu to keep the animation centered in your view.

3. Choose Reset Timeline to reset animation timeline to the beginning. Choose Skip to 
Next Event to skip ahead to next event in timeline. 

4. Choose Stop to stop playing the animation and return to the initial view of the 
model or turn Continuous Play off to stop playing looped animations when all 
timelines have ended. 

Playing Multiple Animations 
Any number of animations can be selected (made active) and played back together. 
Selected animations are played simultaneously rather than back-to-back. 

To play multiple animations from the View menu:
1. In the View menu, choose Animations, then Play, and then choose an animation 
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from a user's list. 

2. Repeat to add as many animations as you would like to play at one time. 

3. Click OK in a message that appears asking you to confirm that you want to play 
multiple animations. 

4. Click Stop to stop the playback and return to the initial view of the model. 

To play multiple animations from the Animation Tool window
5. In the Animation Tool window, select multiple animations in the list. Active 

animations have a happy face icon. 

6. Click the Active button to play all selected animations together. (chap9_7)

7. Click the Play Timeline icon. All animations play from time zero until the end. 
Looped animations play continuously. 

8. Click Stop to stop the playback and return to the initial view of the model. 

Playing a Path 
Paths are predefined routes through the model created with the Path tool. When you 
play a path, you travel along this route through the model and your point of view is 
directed to different areas. 
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To play a path:
1. Choose Play Paths in the View menu and choose a path from the list. 

2. To pause anywhere along the path, click the Stop Path icon. To stop and view while
paying a path, open the Path Tool window and click the double right-arrow icon; a 
top view of the model appears with an outline of the path. 

The blue dot on the path shows the current position and the red arrows show the 
direction of view. 

3. Drag the Position slider to move your view along the path. When you release the 
slider, the view in the main window changes accordingly. 

Jumping to a Viewpoint 
Viewpoints are particular locations you define in the model to which other users can 
jump to get a better view. 

To jump to a previously created viewpoint

In the View menu, choose Jump to Viewpoint, and then choose one of the following: 

• Choose My Viewpoints and then choose a viewpoint to go to a viewpoint you have 
created. 

• Choose User Viewpoints and then choose another user's name to go to a viewpoint 
that user has created. 

• Choose Last Viewpoint to return to the previous viewpoint from up to 20 
viewpoints you have visited. 
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• Choose Position to enter coordinates for a specific location in the scene. 

• Choose Home to return to the initial view when the model is first opened. 

Note: The Jump to Viewpoint menu uses the Sort setting found in the 
Viewpoint Tool to display submenus under which viewpoints are 
listed. 

For example, if the Sort setting is Author, the submenus display viewpoints under My 
Viewpoints and other user names. If the sort setting is Date, the submenus display the 
dates on which the viewpoints were created. If the sort setting is Viewpoint, the 
submenus display all viewpoints alphabetically by name. 

Showing Location of All Viewpoints in Scene 
In the View menu choose Jump to a Viewpoint and then choose All Viewpoints to see 
labels appear in the viewing window for all viewpoints saved with the model. 

Click a label to jump to that viewpoint from its displayed location in the main viewing 
window. 
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Note: You can also set the Show All Viewpoints in Scene option in the 
General Preference Settings.

Opening a URL for Additional Information 
You can open URLs named and saved with the model or attached to specific parts to get
additional information located at any Web address (URL). To add URLs using DeskTop,
use the URLs tool. 

To open a URL:
1. Select the part with which the URL is connected or leave all parts unselected if the 

URL is available for the whole model. 

2. In the View menu, choose URLs, choose the creator or the method by which the 
URL was created, and then choose the URL alias. A Web page is opened in a 
separate browser window. 
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You can create URLs using the CADView-3D DeskTop client as follows: 

• Using the URLs window - connected to a part (you must select the part to add 
the URL and users must select the part to view the URL) 

• Using the URL window - connected to the whole model (you do not need to 
select a part and users can choose to view the URL at any time with or without 
parts selected) 

• You can create URLs using the CADView-3D Studio application as follows: 

• Using the Authored URLs feature 

• Using the URL Template feature Note: Refer to the CADView-3D Studio help 
file for more information. You can automatically create Attribute URLs from 
CAD source part attributes as follows: 
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10
DeskTop Tools

This chapter covers the following topics:

• Using Tools in DeskTop 

• Creating Markups 

• Editing Your Markup 

• Deleting and Printing Markups 

• Measuring Distance and Angles 

• Using Minimum Distance 

• Using Cardinal Points 

• Creating Animations 

• Creating an Animation Hierarchy 

• Moving Animation Nodes 

• Recording a Path 

• Refining a Recorded Path 

• Creating Viewpoints 

• Sorting Viewpoints 

• Saving, Copying, and Printing Images 

• Sending the Model or Markup by Email 

• Describing Display Sets

• Creating Display Sets

Using Tools in DeskTop 
DeskTop provides tools you can use to create markups, dimensions, animations, paths, 
and viewpoints. Once created, they are saved in the database with the model. Users can 
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view them in the corresponding areas in the View menu.

Note: Dimensions are saved when created inside of a markup. 

Desktop provides tools for the following:

• Creating Markups

• Measuring Distance and Angles

• Creating Animations

• Recording a Path

• Creating Viewpoints

• Saving, Copying, and Printing Images

• Sending the Model or Markup by Email

Creating Markups 
A markup is an image or snapshot of the model in which you can add 2D elements 
including text, notes, and URLs. You can create markups to record your comments for 
yourself or for other users to see. The markups are stored in the database with the 
model and can be made available for other users to view. 

To create a markup:
1. Navigate to the view of the model you want to see in the markup. 

2. Select Markups in the Tools menu to open the Markup window at the bottom of the
screen. 

3. By default, the markup list is displayed in a tree structure or threaded view where 
replies to markups are indented. Click the Toggle View button to switch between 
flat and threaded view. 

4. Click the Add Markup icon to open the Markup toolbar. 
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5. Use the markup tools to draw lines with arrows or outline shapes, for example, to 
highlight areas in the image. 

6. Use the text tool to create text labels or use the note tool to create longer 
descriptions. 

7. While your markup is open, you can pick items, drag them around, and modify line
colors, line weights, and fill. 

8. To make a measurement, click the Dimensioning icon to open a Dimensioning 
toolbar (See also: Measuring the Model for details). 

9. Use the Markup Details button in the toolbar to change the name, add a URL, or 
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type a description for the markup. 

10. Save and Close Markup button to exit and save the markup. 

By default, the name format is AliasTime in which Alias is your username and Time
is the time of day you saved the markup. 

Individuals viewing the model at different times can annotate the model to 
communicate their observations. If the markup is shared, other users can view the 
markup and create a reply with their own markup added, creating a threaded series
of replies in a tree structure. You can perform the following with markups.

• Editing Your Markup

• Replying to a Markup

• Showing Location of All Markups in Scene

• Saving, Copying, and Printing Images

Note: In a collaboration meeting, a group of users can collectively 
view the model and make group markups in realtime containing 
color-coded comments from each user. 

Editing Your Markup 
You can edit any markup you have created previously.

Note: If you are using E-Business Suite, you can also use the 
Attachment window to set a markup as the initial view when the model
is first launched.

To edit a markup:
1. Choose Markups in the View menu and select a markup from My Markups. 

2. Click Edit Markup to open your markup. 
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3. Use the markup tools to modify or delete existing markups or to add new ones. 

4. When done, click the Save and Close Markups button on the toolbar. 

Deleting and Printing Markups 
You can select multiple markups to delete or to print by holding the Control key while 
selecting individual markups or holding the Shift key while selecting continuous 
markups. 

• Click the red "x" Delete Markup button to delete the selected markups. 

• Click Print Markup button to print the selected markups. 

Note: If a markup with replies is selected in threaded view, any replies 
to that markup will be printed or deleted recursively. Conversely, if the
markup is selected in flat view, only the selected markup will be 
printed or deleted. 

Note: Therefore, the only way to print or delete a single markup 
without including any of its replies is to click the Toggle View button to
change to flat view first. When you toggle back to threaded view after 
deleting a markup, any replies will be displayed as top level nodes in 
the hierarchy. 
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Measuring Distance and Angles 
Use the Dimensioning tools to measure and display the distance between object vertices
and surfaces and between angles formed by objects. Measurements are displayed in the 
unit system of the original CAD model. 

Note:  If you want to save an image of the measurement with the 
model, use the dimensioning tools found in the Markup tools.

To measure distance and angles:
1. Navigate to a view of the model that contains all of the objects you want to 

measure. 

2. Choose Dimensioning in the Tools menu. The Dimensioning toolbar appears and 
the normal DeskTop user interface disappears. 

3. Click the Distance button. 

4. Click a point on an object and drag the mouse pointer to a point on another object 
and release. The dimension appears in model units between the arrows defining the
two endpoints. 
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5. To reposition a dimension, click the endpoint and drag the blue arrow to a new 
location. 

6. Click the Angle button to measure an angle formed by three points. 

7. Click to create an angle midpoint. Then click the midpoint and drag the mouse 
pointer to create two arrows defining the angle. 

8. To delete a dimension, click an endpoint and click the Delete button. 

9. Click the close "x" icon on the Dimensioning toolbar to return to normal navigation 
mode. 

Using Minimum Distance 
Using Minimum Distance, you can select whole objects instead of vertices and have 
DeskTop calculate the minimum distance between objects automatically. This provides 
a more accurate measurement in areas that lack vertices. 
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To measure with Minimum Distance:
1. Choose Dimensioning in the Tools menu. 

2. Click the Minimum Distance button. 

3. Pick a point anywhere on the first object and then pick a point anywhere on the 
second object. The two objects are selected in wireframe by default. 

Two arrows appear at the closest points between the two objects, and a dimension 
is displayed in model units. 

Using Cardinal Points 
You can display additional cardinal points on geometric primitive objects (e.g., cubes, 
cones, cylinders) to use as endpoints when measuring distance and angles. 

To use cardinal points:
1. Turn on Simplified Wireframe in Graphics Preferences. The simplified, 

non-triangular outline appears for all geometric primitives present in your model. 

2. Choose Dimensioning in the Tools menu. 

3. Click the Cardinal Points button on the Dimensioning toolbar. 

4. Click any geometric primitive object to display its cardinal points. 

5. Click the Distance or Angle button, click a point on an object and drag the mouse 



DeskTop Tools    10-9

pointer to another point on an object and release. 

When the mouse pointer is directly over a cardinal point, it turns white and the 
arrow snaps to that point. 

The dimension appears in model units between the arrows defining the endpoints. 

Creating Animations 
Using DeskTop's animation tool, you can animate objects in a model and save the 
animation for others to view. Using the editor, you move a collection of objects relative 
to the scene or relative to each other. Animations can be shared (public) or unshared 
(private) and are saved in the database with the model. 

Like a movie, an animation is actually a series of frames or pictures played in sequence. 
If the frames are played back rapidly (near 30 frames/sec.), the motion appears smooth; 
if played back more slowly (15 frames/sec.), motion appears jerky; and if played back at 
5 frames/sec., you will see a series of separate images. Therefore, it is important that 
update rate is kept above 15 frames/sec. as specified in Preference settings in the 
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Performance tab. 

You need to do the following to create an animation:

• Group objects in parent and child nodes 

• Move and position objects in the scene 

• Take snapshots of the objects in different positions 

• Adjust the time interval between the key frames

Note: If you are using E-Business Suite, you can also use the 
Attachment window to set an animation as the initial view when the 
model is first opened.

Creating an Animation Hierarchy 
Parts of the model are grouped in parent and child nodes in a transformation hierarchy.
Then, each node can be transformed (translated and rotated) independently. Parts in a 
child node can be animated as a group while moving along with the parent node. 

For example, if you are animating a car, you may want a window to roll up and down 
in a door as the door opens and closes in the car body. 

To create an animation :
1. Choose Animation in the Tools menu. The Animation Tools window appears. 
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2. Click the Create New Animation button and press Enter. The Edit Animation 
window appears. 
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3. Click the New Animation Node button. A "New Level n" animation node appears 
in the hierarchy. 

4. Right-click the node, choose Rename in the menu that appears and type a 
descriptive name for it if desired. 

5. Select (highlight) the node if it is not already selected. 

Note: Parts are added to the selected node. If a part already exists 
in another node, you are asked if you want to move that part to the 
node selected. A single part can't be listed twice in the hierarchy. 

6. Select model parts from the main viewing window and click Add Parts. A Parts 
node is created with the selected parts listed by name under the selected node. 

The Parts folder and model part names are not editable and you cannot drag and 
drop them in the hierarchy. Set up your Animation Nodes first and then add parts. 

7. To add a child node, select a parent node, and click New Animation Node. 

8. Right-click the node, choose Rename in the menu that appears, and type a 
descriptive name for the node. 

9. Select part(s) in the model and click Add Parts. The parts are listed by name under 
the selected (child) node. 

An example hierarchy for a car may look like this: 
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Moving Animation Nodes 
Once the parts in your model are set up in nodes in the animation hierarchy, you can 
move or transform each node (translate or rotate) to position it for each snapshot. 

Key framing is the process used to set up objects at key points along a path. Once these 
positions are set, the animation tool will work out or interpolate the necessary 
in-between positions over the designated time interval. The longer the time interval 
between snapshots/positions, the more in-between frames will be captured. 

To move an animation node (using translate and rotate) to set up a key 
frame shot:
1. Select (highlight) an Animation Node in the hierarchy. 

2. Click the Translation or Rotation tab to begin. 

3. Click the Snapshot button to take a snapshot of the initial position of the model. A 
red event icon appears at the start (left) in the Timeline. 

4. Use the tools in the Translation and Rotation tabs to move the part(s) in the selected
node to set up a key frame. 
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Translating Animation Nodes 
5. In the Translation tab, type in an offset value in the X, Y, or Z direction and press 

Enter. The parts move the designated number of units along the selected axis. 

6. Alternatively, click the center square in the grid and drag a vector to move the 
selected parts dynamically in the main viewing window. 

Rotating Animation Nodes 
7. In the Rotation tab, click and drag the trackball to rotate the group of parts 

dynamically about a center point. 

8. Alternatively, type separate values for heading, pitch, or roll and press Enter in 
each field. The part(s) move the designated number of degrees. 
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9. When you have moved the parts to the desired key frame position, click the 
Snapshot button again in either Translation or Rotation tab. 

10. A red event icon appears in the timeline. The event icon represents the 
position/orientation of the objects when the snapshot was taken. 

11. Drag the red event icon left or right to create a longer or shorter time interval 
between key frames, as desired.

12. Click the Play button in the Timeline Editor to play back the animation. The parts 
will move in the main viewing window. 

13. This example is one frame from an exploded view of the model. 

14. Repeat the steps above to create as many key frame snapshots as desired. 
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15. Click the "x" close button at top to save your animation, close the Edit Animation 
dialog, and return to the Animation Tool. 

16. In the Animation Tool window, you can explicitly save your animation to a file 
(*.van) on your local drive using the Save Animation to Disk button. 

17. You can rename your animation by right-clicking and choosing Rename. You can 
also type a text description below for each animation. 

By default your animation is shared. Other users can play your animation from the 
main Animation Tool window (see Playing an Animation). If you do not want to 
share your animation with other users viewing the model, deselect the box next to 
it. 
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Recording a Path 
Paths are routes saved in a model that you and other users can walk through at any 
time. You can play paths, loop them, and stop along them to look in different directions.

Restrictions
To create a path by recording your movements: 
1. Choose Paths in the Tools menu. 

2. Navigate a route through the model by dragging the mouse pointer in the viewing 
window 

3. Alternatively, click the double-arrow (>>) icon for Advanced options to display the 
Movement icons and use them to navigate through the model. 

4. Click the Stop icon. A dialog asks you to resample the path. 

5. Click OK to simplify the path, eliminating unnecessary points. 

6. The Path Tools window appears. The new path appears as the last item under My 
Paths in the dialog. 

7. Type a name for the path and press Enter; type a description if desired. 

By default the new path is shared. Deselect it if you do not want it available to other
users. 

Your paths are stored in the My Paths folder. You can also drag a path from another
user's shared folder to copy it into My Paths. 

Note: Your paths are automatically saved in the database with the 
model when you exit DeskTop. If you want to save them all in a 
single .PATH file on your local drive as well, use the Save button to
copy all paths currently listed under My Paths. You can upload 
saved paths from your local drive using the Load button. 

If saving the path fails for some reason, you are prompted to save the .PATH file 
locally. You can also use the Save button to save your file to your local drive. 

8. In the View menu choose Play Paths and select the path to play it in the main 
viewing window. 

Note: If you're using E-Business Suite, you can also use the 
Attachment window to set a path to play in a loop as the initial 
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view when the model is first launched. 

Refining a Recorded Path 
Highlight the path name in Path Tool window and click the double right-arrow button 
to display the path in a top view window. 

• To add a viewpoint, hover the mouse pointer on the path line between two arrows. 
When the cursor changes to a cross, you can click to add a new point. 

• To select a viewpoint, first hover the mouse pointer over the arrow. When the 
cursor changes to a cross with four arrows, click to select the arrow beneath. 

• To move a viewpoint, select the point and drag it. 

• To change your viewing direction at any point along the path, select the point, then 
adjust the Heading and Pitch sliders. 

• To add a point at the end of the path, click a point in space to continue the path in 
that direction. 

• To delete a point, select the point and click the Delete button. 

Creating Viewpoints 
Using the Viewpoint Tool you can create viewpoints that you can easily return to later. 
Once you find an interesting viewpoint, you can save it with the model. You can then 
use Jump to a Viewpoint to select it. 
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You can also jump to viewpoints created by other users.

Restrictions
To create a viewpoint 
1. Navigate to the desired view of the model. 

2. Choose Viewpoints in the Tools menu. 

3. In the Viewpoint Tool window, click the New button. 

The viewpoint appears under My Views as New Viewpoint. 

4. Type a new name and press Enter. 

Note: By default the new viewpoint is shared. Deselect it if you do 
not want it available to other users. 

Your viewpoints are stored in the My Views folder. You can also drag a viewpoint 
from another user's shared folder to copy it into My Views.

Your views are automatically saved with the model when you exit DeskTop. If you 
want to save them all in a single. VIEW file on your local drive as well, use the Save 
button to copy all viewpoints currently listed under My Views. You can upload 
saved viewpoints from your local drive using the Load button. 

Sorting Viewpoints 
Use the Sort by drop-down box in the Viewpoint Tool to choose the way in which 
viewpoints are sorted. Sort by Author, the default, sorts viewpoints under the creator's 
name. You can also sort by "Date and sort alphabetically by Viewpoint name . This sort 
order setting is also used in the Jump to Viewpoint menu. 

Using date sort, you can only rename, delete, or share/unshare viewpoints. Using 
Viewpoint, you can only share/unshare them. 
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Saving, Copying, and Printing Images 
While you are working with the model, you may want to save a snapshot of an image to
your local drive instead of saving it in a database with the model as a viewpoint or 
markup. 

Choose Save in the Tools menu to save the image in the viewing area in the selected 
format, such as .GIF, .BMP, .TGA, or .TIF. 

Alternatively, choose Copy in the Tools menu to copy an image to the Windows 
clipboard which you can then use to paste the image in an external document. 

To print an image of the current screen choose Print in the Tools menu, choose the 
resolution and click OK. 

Sending the Model or Markup by Email 
To send the location of the model or a markup image of the model to someone via 
email, choose Send CADView-3D Model by Email or Send Markups by Email in the 
Tools menu. 

Describing Display Sets
Display sets enable you to select sub-sets of a visual part or item within a CADView-3D 
model, store them together, retreive them quickly, and view them from a particular 
perspective.

You can perform any number of part queries, manual hiding, selection, and 
maneuvering around the model, and then store the view in its entirety for review later 
as a display set.
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Creating Display Sets
You set up and activate display sets using the Display Sets region, which you can access
by selecting the Display Sets option from the Tools menu.

The Display Sets region contains the details about your display sets. This region 
includes the display set name and descriptions, as well as options (icons) that enable 
you to manage your display sets. 

The following graphics depict the Display Sets region, as well as a description of the 
display set management icons.

Display Sets Region 

Display Sets Icon Descriptions

Think of display sets as subsets of complete items. The following examples illustrate a 
complete item (a standard headset), versus a display set (the headset antenna and 
spring), which are components of the item.
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Example of Complete Item

Example of Item Display Set

You can share display sets within a mutltiuser, real-time collaboration session. To share 
display sets, the collaboration leader selects the display set to share, and then the 
selected set appears automatically for all session attendees.

To Create a Display Set:
This procedure assumes that you are creating a display set from the Parts list.

1. From the Tools menu, select Display Sets.
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The Display Sets region appears.

2. If not already visible, select the Parts List from the Window menu.

3. From the Parts list, select the parts that you want to include in your display set.
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Important: Make sure to clear the check boxes of the parts that you 
do not want to appear in the display set.

4. Optionally, select a viewpoint from which to view the display set.

5. In the Display Sets region, click the Add to Display set icon to create the display set.

The Add Display Set window opens.

Note: The parts selected when the Add Display Set window opens 
are the parts that will appear in your display set.

6. Enter a name and an optional description for your display set.

The new display set now appears in the Display Sets panel.

You can create additional display sets by repeating this procedure.

Note: Users can create display sets on both single-stream and 
multistream models. Further, for either single-stream and 
multi-stream models, re-publication of the models containing 
display sets will keep the display sets visible within the 
re-published model. However, should a user add or delete a stream
form a model that previously had display sets associated with it, 
those display sets will be lost.
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To View Display Sets:
1. If not already visible, select Display Sets from the Tools menu.

The Display Sets region appears.

2. To view a specific display set, select the display set, and then click the Activate 
Display Set icon.

Alternatively, double-click the selected display set.

The selected display set appears in the CADView-3D window.

3. To view or return to the complete item or part, click the View All and Reset Colors 
icon.

Alternatively, from the View menu, select Display Sets > View All and Reset Colors.

To Delete a Display Set:
1. Click the Delete Display Set icon.
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11
Preferences

This chapter covers the following topics:

• Overview 

• Modifying Preference Settings 

• Backface Culling 

• Building Maximum Level of Detail 

• Pausing Streaming 

• Changing Object Colors 

• Showing Statistics 

Overview 
You can use the Preferences menu to modify your view and appearance of the model. 
The Preferences menu offers the following features:

• Modifying Preference Settings

• Backface Culling

• Building Maximum Level of Detail

• Pausing Streaming

• Changing Object Colors

• Showing Statistics

Modifying Preference Settings 
Using the preference settings you can set various parameters to modify your view of 
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and interaction with a 3D model. Choose Settings in the Preferences menu or right-click 
in the viewing window and choose Preferences in the menu that opens.

You can customize settings in the following tabs: General, Graphics, Performance, Pick, 
Lighting, Navigation, and Sounds 

Note: User-specified settings are stored in the Windows Registry and 
remain the same for any model you view. However, some 
model-specific settings, such as those for the near and far clip plane, are
stored with and may be different for each model.

Backface Culling 
CADView-3D by default, does not draw the back faces of objects to minimize the time it
takes to load and render the model. 

Choose Backface Culling in the Preferences menu to turn on and off the Backface 
Culling.
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Building Maximum Level of Detail 
CADView-3D DeskTop streams data to load only portions of the model that are 
required for rendering your current view. If necessary, the entire model can be loaded 
into memory in full detail. 

Choose Maximum Level of Detail in the Preferences menu to begin loading the 
maximum level of detail of all objects in the model or in currently isolated objects. 

Note: This process can take several minutes on a complex model, and it 
will slow down or halt navigation. When complete, you can navigate 
and view the entire model without interim reloading.

Pausing Streaming 
CADView-3D uses patented streaming technology to load only what is needed to 
render the current view. However, you may need to pause the streaming and rendering
process if you need to use your network connection and local CPU for another purpose. 
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To pause network traffic and locate CPU:
1. Choose Pause/Resume Streaming in the Preferences menu. 

The viewing window turns white and a message box appears stating that all 
streaming has stopped. 

2. Click OK to resume streaming and return to interacting with the model. 

Changing Object Colors 
You can manually pick a new color to identify certain objects. 

To manually pick a new color:
1. Select an object and choose Change Color in the Preferences menu. 
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2. Choose a new color from the color palette and click OK. 

The new color remains until you choose Revert Color or until you exit DeskTop. It 
is not saved with the model.

See also: Querying Attributes to learn how to display objects in certain colors 
according to attribute values and save them with the model. 

Showing Statistics 
You can display real-time statistics about the model as it is being rendered as well as 
information about CADView-3D DeskTop and your PC system. 

Choose Show Statistics in the Preferences menu. 

The statistics text appears in the corner of the viewing window. 
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