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1 What’s New in This Release

Using Siebel Tools covers how to use Oracle’s Siebel Tools application. It describes the Siebel Tools 
user interface and includes tasks such as customizing the Siebel Tools environment, working with 
objects, checking in and checking out, and compiling. 

Using Siebel Tools does not cover how to configure Oracle’s Siebel applications. For example, it does 
not cover how to extend the data model, define business logic, or build user interface objects. For 
configuration-related information, see Configuring Siebel Business Applications.

The content covered in Using Siebel Tools came from the following documents:

■ Descriptions of menus and toolbars were previously published in Siebel Developer’s Reference.

■ Descriptions of windows, editors, and most tasks were previously published in Siebel Tools 
Reference. (Siebel Tools Reference is no longer published. It has been replaced by Using Siebel 
Tools and Configuring Siebel Business Applications.)

What’s New in Using Siebel Tools, Version 8.0, Rev. A
Table 1 lists changes described in this version of the documentation to version 8.0, Rev. A of the 
software.

Table 1. New Product Features in Using Siebel Tools, Version 8.0, Rev. A

Topic Description

“Setting ST eScript Engine Options” 
on page 144

Added a note near the beginning of the topic.

“Using Script Libraries” on page 152 New topic. Feature introduced in Siebel 8.0.
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What’s New in Using Siebel Tools, Version 8.0
Table 2 lists changes described in this version of the documentation to support version 8.0 of the 
software.

Table 2. New Product Features in Using Siebel Tools, Version 8.0

Chapter Topic/Description

Chapter 2, “About the Siebel Tools 
User Interface”

“About the Improved User Interface.” Changes to the user 
interface to support a multiple-document interface (MDI).

“About the Applets Window.” Changes to the Applets window, 
which displays information about a selected view and allows 
you to add applets to that view.

“About the Palettes Window.” Context-sensitive window 
displayed when the Applet Layout Editor, Task Designer, or 
Workflow Process Designer is launched. Replaces the Web 
Controls toolbar.

“About the Multi Value Property Window.” Context-sensitive 
window displayed, for example, when the Task Designer or 
Workflow Process Designer is launched.

“About the Expression Builder.”. Used to create syntax for the 
Value field of a property.

“About Canvas-Based Designers.” Overview of the three 
similar design environments that allow developers to create 
entity relationships, tasks, and workflow processes.

Chapter 2, “About the Siebel Tools 
User Interface”

“About Dynamic Picklists for User Properties.”. No longer 
necessary to type the name of a valid user property when 
adding one to an object that supports user properties.

“Reports Menu.” List of reports available in version 8.0.

Chapter 3, “Customizing Your Siebel 
Tools Environment”

“Setting Workflow and Task Configuration Options.” Options to 
help developers be more productive when working with tasks 
and workflows.

 “Showing, Hiding, and Docking Windows.” Added flexibility in 
customizing the user interface.

Chapter 7, “Working with Objects” Deleted topic on generating reports about object 
relationships.

Chapter 8, “Creating Workflow 
Processes and Tasks”

New chapter with descriptions of the Workflow Process 
Designer, Task Designer, and Expression Builder, as well as 
basic procedures for creating workflow processes and tasks.



What’s New in This Release ■

Using Siebel Tools Version 8.0, Rev. A 13

Chapter 9, “Siebel Script Editors” “About the ST eScript Engine.” Default eScript scripting engine 
in version 8.0.

“Using Fix and Go.” Ability to edit and test scripts without 
recompiling them and restarting the Siebel Mobile Web Client.

“Using Script Assist.” Enhanced Script Assist functionality, 
including syntax highlighting, repository introspection, 
favorites, and script libraries.

“Using the Watch Window.” Support for more variable types, 
including global variables, profile attributes, and shared 
global variables.

Chapter 11, “Working with Archive 
Files”

Support for exporting objects to Application Deployment 
Manager (ADM) hot-fixes and mid-level releases.

Chapter 12, “Managing 
Repositories”

“Exporting and Importing Repositories Using the Database 
Configuration Wizard.” Updates to both the Windows and UNIX 
procedures.

Chapter 13, “Working with Strings 
and Other Locale-Specific Data”

“Running the LMU Using the Command-Line Interface.” Ability 
to provide a text file with a list of projects to be exported.

“About the Advanced Compile Option.” Inserting “dummy” 
strings where translations are missing so that all functionality 
works, and adding pseudolocalization prefixes to strings to 
make testing easier.

Table 2. New Product Features in Using Siebel Tools, Version 8.0

Chapter Topic/Description
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2 About the Siebel Tools User 
Interface

This chapter describes the Siebel Tools user interface. It contains the following topics:

■ “About Siebel Tools” on page 16

■ “About the Improved User Interface” on page 16

■ “About Siebel Tools Application Windows” on page 17

■ “About the Object Explorer” on page 18

■ “About the Object List Editor” on page 21

■ “About the Properties Window” on page 24

■ “About the Applets Window” on page 24

■ “About the Controls/Columns Window” on page 27

■ “About the Palettes Window” on page 29

■ “About the Bookmarks Window” on page 31

■ “About the Web Template Explorer Window” on page 31

■ “About the Multi Value Property Window” on page 33

■ “About the Expression Builder” on page 33

■ “About Dynamic Picklists for User Properties” on page 34

■ “About the Menu Bar” on page 35

■ “About Toolbars” on page 47

■ “About Right-Click Menus” on page 54

■ “About Layout Editors” on page 55

■ “About New Object Wizards” on page 55

■ “About Canvas-Based Designers” on page 56

■ “About Script Editors” on page 58

■ “About the Command-Line Interface” on page 58
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About Siebel Tools
Siebel Tools is an integrated environment for configuring Siebel applications. You use Siebel Tools to 
modify standard Siebel objects and create new objects to meet your organization’s business 
requirements. For example, you use Siebel Tools to extend the data model, modify business logic, 
and define the user interface.

NOTE: Currently, there is no support to customize Siebel Tools.

Siebel Tools is a declarative configuration tool, not a programming environment. You use Siebel Tools 
to create and modify the object definitions (metadata) that define Siebel applications. You do not 
modify the source code or directly write SQL. 

NOTE: In the context of Siebel applications, the terms object and object definition are not equivalent 
to the terms “object,” “object class,” or “object instance” as they are used in the context of 
programming languages such as C++.

Siebel Tools allows you to develop a single configuration that can be:

■ Deployed across multiple types of clients

■ Used to support multiple Siebel applications and languages

■ Easily maintained

■ Automatically upgraded to future Siebel product releases

You can have installations of Siebel Tools for different product releases on the same local machine.

For information about installing Siebel Tools, see the Siebel Installation Guide for the operating 
system you are using. For system requirements, such as supported versions of Microsoft Windows, 
see Siebel System Requirements and Supported Platforms on Siebel SupportWeb.

In this guide, SIEBEL_TOOLS_ROOT represents the directory into which you installed the Siebel Tools 
client. By default, this directory is C:\Program Files\Siebel\8.0\Tools.

About the Improved User Interface
The Siebel Tools user interface for version 8.0, shown in Figure 1 on page 17, allows complete control 
over the development environment, increasing usability and efficiency.

The improved user interface supports a tab group bar for a multiple-document interface (MDI). The 
tab group can be placed on any side of the application window.

NOTE: Only one tab group is supported.

Multiple editors can be open at once, allowing you to work with multiple objects conveniently. You 
can navigate among them easily by clicking tabs.
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In the example shown in Figure 1, the Object List Editor, Applet Layout Editor, and the Server Script 
Editor are all open. The Object Explorer, Properties window, and the Controls/Columns and Palettes 
windows of the Applet Layout Editor are docked at the left side of the application window as tabs.

For information on customizing the user interface, see Chapter 3, “Customizing Your Siebel Tools 
Environment.”

About Siebel Tools Application Windows
You navigate in Siebel Tools primarily using the following two windows:

■ Object Explorer, shown in Figure 2 on page 18

■ Object List Editor, the main part of the application window shown in Figure 1

The Object Explorer uses a hierarchical tree-structure (similar to that of the Microsoft Windows 
Explorer) that you use to browse the object types that are stored in the Siebel repository.

Figure 1. Siebel Tools Application Window
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Other Siebel Tools windows, like the Object List Editor and Properties windows, show you details 
about individual objects in the Siebel repository.

About the Object Explorer
The Object Explorer, shown in Figure 2, appears when you start Siebel Tools. The Object Explorer 
shows a hierarchical representation of the major object types that you can use to browse the object 
types in the Siebel repository.

By default, the Object Explorer is visible when you start Siebel Tools. The Object Explorer has the 
following parts: the Project drop-down list, the Types tab, the Detail tab, and the Flat tab.

Topics in This Section
“Project Drop-Down List” on page 19

“Types Tab” on page 19

“Detail Tab” on page 20

“Flat Tab” on page 21

Figure 2. Object Explorer
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Project Drop-Down List
Use the Project drop-down list at the top of the Object Explorer to filter objects by project. For 
example, you can set the Project filter so that only the object types associated with the Account 
project appear in the Object Explorer. An example of the values in the drop-down list is shown in 
Figure 3.

Types Tab
The Types tab is selected in the Object Explorer shown in Figure 4 on page 20.

The Types tab shows all top-level object types, listed alphabetically. The Types tab shows the object 
hierarchy—clicking the plus sign (+) to the left of an object type displays all the child object types 
of the top-level object type. Clicking the minus sign (–) to the left of an object type collapses all its 
child object types.

NOTE: By default, not all object types are visible in the Object Explorer. For information on how to 
show and hide objects types, see “Setting Database Options” on page 75.

Some object types have a hierarchy of multiple levels. For example (as shown in Figure 4 on 
page 20):

■ One of the child object types of Applet is List and, at the next lowest level, List Column.

Figure 3. Project Drop-Down List
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■ One of the child object types of Business Component is Field. 

Detail Tab
If you select the Detail tab of the Object Explorer (as shown in Figure 5) and expand an object type, 
all the objects of that type appear in the Object Explorer. If you select an object type in the Detail 
tab, the Object List Editor displays all the objects of that type.

Figure 4. Types Tab

Figure 5. Detail Tab
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Flat Tab
The Flat tab of the Object Explorer, shown in Figure 6, shows all object types (parent and child) in a 
single, alphabetically arranged list, without displaying the parent-child relationship. 

The Flat tab view helps you:

■ Find a child object with an unknown parent.

For example, if you created a new field but do not remember what business component it is in, 
you can select the Field object type in the Flat tab and search the Name property for your field 
name. Each returned record has a parent property that provides the business component name.

■ See how objects and properties are typically used, such as how a predefault value is constructed 
or the syntax for calculated fields.

About the Object List Editor
The Object List Editor displays the objects for the object type currently selected in the Object 
Explorer. If the object selected in the Object Explorer is a second or third-level object, two Object 
List Editors are displayed—the object for the type selected in the Object Explorer is in the bottom 
window. In the example shown in Figure 7 on page 22, the top-level object is Applet, the specific 
applet is Account List Applet, and the available Web templates are Base, Edit (selected), and Edit List.

Figure 6. Flat Tab
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In the same figure, the pencil icon (to the left of the applet name) indicates that the applet has been 
locked by the Siebel Tools user, so that modifications to it can be saved.

Inactive Objects
Inactive objects have the INACTIVE property set to TRUE, which inactivates the record in the 
repository.

In Figure 7, the Edit -- Original applet Web template, shown in red, is inactive.

NOTE: When an object definition becomes obsolete, either due to an update or to a new 
requirement, you must not delete the unused objects. Instead, check the INACTIVE flag. Then, the 
application does not reference the checked Siebel object.

Figure 7. Object List Editor
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Changed Flag
After you edit a record, a check mark appears in the Changed property of the object. This indicates 
that changes have been made to the contents of the corresponding record since a particular date 
and time. If there is no check mark in the Changed property, it means that the object has not been 
changed since the date and time specified in the General tab of the Development Options dialog box. 

The Changed flag cascades upwards through its parents. That is, when an object is edited or created, 
the changed flag is set for its parent object, if any, and for the parent object of that parent, and 
likewise up through the hierarchy. For more information, see “Setting Change Date Preferences” on 
page 60.

Pencil Icon
The pencil icon in the first (W) column of an object indicates that the object is locked and editable. 
In Figure 7 on page 22, all visible objects are locked.

Drilldowns
Property values in the Object List Editor can appear as drilldown fields (hyperlinks) when the value 
is the name of another object. You can click the drilldown to navigate to the associated object type.

To be able to use drilldowns in the Object List Editor, you must be assigned the Developer 
responsibility. Users are assigned responsibilities in the Administration - Application > 
Responsibilities screen of Siebel applications. For more information, see Siebel Security Guide.
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About the Properties Window
The Properties window (shown in Figure 8) displays the property settings for the object currently 
highlighted in the Object List Editor. The name of the active object is shown at the top of the window 
(in Figure 8, Business Component Abs Result). For each property of the object, the Properties window 
shows the name of the property in the left column, and the property’s value in the right column. By 
default, the Properties window appears with the Alphabetic tab active; you can click the Categorized 
tab to see the properties grouped by category.

NOTE: The Properties window does not display the Project and Changed properties.

About the Applets Window
The Applets window (shown in Figure 9 on page 25) displays information about a selected view and 
allows you to add applets to that view. You access the Applets window through the View Layout 
Editor. From there, you can add applets to a view by dragging their icons from the Applets Window 
into the view layout.

The Applets window has the following fields, buttons, and drop-down list:

■ Bus. Object. This field shows the business object associated with the view.

■ Template. This field shows the Web template associated with the view.

■ Change Template. This button opens the Choose Template dialog box that lets you select a 
different Web template.

■ Edit Template. This button opens the template editor you defined as the external Web template 
editor in the options.

■ Mode. This drop-down list shows the view mode, such as Base or Edit.

Figure 8. Properties Window
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The Applets window has two tabs: the Icons tab (shown on the left in Figure 9) and the List tab 
(shown on the right in Figure 9).

For more information on editing views and applets, see Configuring Siebel Business Applications.

To add an applet to a view using the Applets window

1 In the Object List Editor, select a view.

Figure 9. Applets Window with the Icons and List Tabs
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2 Right-click, and then choose Edit Web Layout.

The View Layout Editor and Applets window appear.
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3 Drag and drop an applet icon, for example a form applet, onto a placeholder in the view template 
to add that type of applet to the view.

The Pick Record dialog box appears, listing the applets of that type based on the business 
components in the business object associated with the view.

4 Select an applet, and then click Pick. You can use the Find field to search by applet name or 
associated business component.

The applet is added to the view layout.

5 Double-click the applet to edit it.

The Applet Layout Editor appears, along with the Controls/Columns and Palettes windows.

6 Edit the applet, and then save your changes.

Related Topics
“About the Controls/Columns Window” on page 27

“About the Palettes Window” on page 29

“About Layout Editors” on page 55

About the Controls/Columns Window
The Controls/Columns window displays controls and columns available for configuration when editing 
an applet layout in the Applet Layout Editor, as shown in Figure 10 on page 28. You drag the control 
or column icon into the placeholder in the Applet Layout Editor.
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When you select a control or a column object in the Controls/Columns window, the Properties window 
refreshes to show the properties of the selected object. If no object is selected in the Controls/
Columns window, the Properties window shows the properties of the applet.

The Controls/Columns window has the following fields, buttons, and drop-down list:

■ Applet. This field shows the name of the applet.

■ Template. This field shows the Web template associated with the selected mode.

■ Change Template. This button opens the Choose Template dialog box that lets you select a 
different Web template.

■ Edit Template. This button opens the template editor you defined as the external Web template 
editor in the options.

Figure 10. Applet Layout Editor with Controls/Columns and Palettes Windows
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■ Mode. This drop-down list lets you select the applet mode, such as Base or Edit. Values in the 
drop-down list indicate whether a given mode is active or inactive.

About the Palettes Window
The Palettes window, shown in Figure 10 on page 28, is context sensitive:

■ When the Applet Layout Editor is open, the Palettes window allows you to create user interface 
controls in the Applet Layout Editor. The window supports drag-and-drop behavior for the 
creation and placement of new controls.

■ When the Entity Relationship Designer is open, the Palettes window displays the entity element 
and connectors used to create entity relationships.

■ When the Task Designer is open, the Palettes window displays the operations and connectors 
used to create tasks.

■ When the Workflow Designer is open, the Palettes window displays the operations and connectors 
used to create business processes.

Table 3 describes the Palettes window Web controls used in the Applet Layout Editor. For detailed 
information on the Entity Relationship Designer, see Configuring Siebel Business Applications. For 
detailed information on the Task Designer, see Siebel Business Process Framework: Task UI Guide. 
For detailed information on the Workflow Designer, see Siebel Business Process Framework: 
Workflow Guide.

Table 3. Palettes Window Web Controls

Button Description

CheckBox. Creates a check box.

RadioButton. Creates a radio button.

MiniButton. Creates a mini button.

Field. Creates a field.

FieldLabel. Creates a field label.

ComboBox. Creates a combo box.

RecNavNxt. Creates a control for navigating to the next record.
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RecNavPrv. Creates a control for navigating to the previous record.

Text. Creates a text box.

TextArea. Creates a text area.

FormSection. Creates a section of a form.

Hidden. Creates hidden HTML.

Password. Creates a text box where the user enters a password during logon.

Link. Creates an HTML link control.

MailTo. Creates a mail-to link.

Button. Creates a button.

Label. Creates a label on templates.

URL. Creates a link to an external URL on templates.

ActiveX. Creates an ActiveX control on templates.

Text List Column. Creates a list column that contains HTML text. Available for list applets 
only.

Checkbox List Column. Creates a list column that contains HTML check boxes. Available 
for list applets only.

Custom Control. Creates a custom control on a template. You can select a custom control 
from the Control Type drop-down list, and then drag the Custom Control button to the 
designer to create the custom control.

Table 3. Palettes Window Web Controls

Button Description
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About the Bookmarks Window
The Bookmarks window, shown in Figure 11, lets you navigate to frequently used objects in the 
repository using shortcuts that you add using the buttons on the History toolbar.

Related Topic
“History Toolbar” on page 48

About the Web Template Explorer 
Window
The Web Template Explorer window (shown in Figure 12) is a Windows Explorer–like listing of Web 
templates. Clicking an item in the Web Template Explorer displays the HTML source code of the Siebel 
Web Template (.swt) file for review or editing in the HTML code window (shown in the right part of 
the window in Figure 12).

Figure 11. Bookmarks Window
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The HTML code window displays both parent and child templates in a split view. The Web Template 
drop-down list in the Web Template Explorer window lets you filter the templates that are shown in 
the Web Template Explorer window. You can edit a template file by right-clicking in the HTML code 
window for that template.

Figure 12. Web Template Explorer Window with HTML Code Window
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About the Multi Value Property Window
The Multi Value Property Window, shown in Figure 13, allows you to view and set values for multi-
value properties when using the Entity Relationship Designer, Task Designer, or Workflow Process 
Designer. It is context sensitive, showing the multi-value properties for the relationship, task, or 
workflow being edited, or for an entity, task step, or workflow step when that item is selected.

About the Expression Builder
The Expression Builder is used to create syntax for the Value field of a property:

■ In the Multi Value Property Window of the Workflow Process Designer or Task Designer when the 
value is an expression

■ To assign a value to a user property

Figure 13. Multi Value Property Window
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The Expression Builder works similarly to the Business Rules Designer in Siebel Personalization. For 
more information on using the Expression Builder, see “Using the Expression Builder” on page 137.

NOTE: Validation is not available when using the Expression Builder with user properties.

About Dynamic Picklists for User 
Properties
In Siebel Tools version 8.0, it is no longer necessary to type the name of a valid user property when 
adding one to an object that supports user properties, for example an applet or business component. 
When you click the arrow in the Name field of a new user property record, a dialog box (dynamic 
picklist) appears that shows the valid user properties for the parent object. A business component 
example is shown in Figure 14.

For more information on user properties, see Siebel Developer’s Reference.

Figure 14. Business Component User Property Dynamic Picklist



About the Siebel Tools User Interface ■ About the Menu Bar

Using Siebel Tools Version 8.0, Rev. A 35

About the Menu Bar
The menus in the menu bar operate as standard Microsoft Windows menus. You click a menu to 
display the menu commands. Menu commands that are not available due to the current state of the 
program are disabled. 

Topics in This Section
“File Menu” on page 35

“Edit Menu” on page 36

“View Menu” on page 38

“Screens Menu” on page 40

“Go Menu” on page 40

“Query Menu” on page 41

“Reports Menu” on page 41

“Format Menu” on page 42

“Debug Menu” on page 43

“Tools Menu” on page 44

“Window Menu” on page 46

“Help Menu” on page 47

Related Topics
“About Toolbars” on page 47

File Menu
Table 4 describes the options available on the File menu for repository and object management.

Table 4. File Menu Options

Menu Option
(Shortcut) Description

Open Repository When multiple repositories are present in the development directory, the menu 
option provides the means to open a repository other than the currently open 
one. 
The repository chosen using File > Open Repository becomes the default 
repository opened each time Siebel Tools is launched.

New Object Invokes the New Object Wizard for the creation of a list applet, form applet, 
chart applet, tree applet, business component, report, table, command, 
picklist, MVG, or view.

Close
(CTRL+F4)

Closes the Object List Editor.
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Edit Menu
The Edit menu options apply to individual objects in the Object List Editor. 

You can also display a menu of edit tools by selecting a field and right-clicking while the cursor is 
positioned over the Object List Editor. For more information, see “About Right-Click Menus” on 
page 54.

Table 5 describes the options available on the Edit menu.

Save
(CTRL+S)

Saves changes in the current editing window when you are editing Layout, 
Menu, or Basic Scripts. 

Save All Saves changes in all open editing windows. 

Import Imports text from an external text file into the Siebel VB Editor window. This 
text must be in an SBL file format. SBL format is generated when it is exported 
from the Siebel VB editor.

Export Allows you to create a text file in delimited or HTML format that lists the 
property values of an objects or all objects currently displayed in the Object 
List Editor. 

Print Setup Changes the printer and printing options for printing object visualization view 
diagrams.

Print Preview Opens a print preview window for display of an object visualization view.

Print
(CTRL+P)

Prints the active object visualization view diagram. 

Exit Closes Siebel Tools.

Table 5. Edit Menu Options

Menu Option
(Shortcut) Description

Undo
(CTRL+Z)

Reverses the last change to a property value in the Object List Editor or Property 
window before the object is committed.

Redo
(CTRL+Y)

Reapplies changes after the Undo command has been executed.

Undo Delete After deleting any record in Object List Editor, this menu option appears, allow 
you to undo the delete. 

Undo Record Reverses the creation of new objects or all modifications to existing objects, so 
long as the record has not yet been committed.

Table 4. File Menu Options

Menu Option
(Shortcut) Description
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New Record
(CTRL+N)

Creates a new object in the Object List Editor, with the cursor positioned in the 
first required property.

Copy Record
(CTRL+B)

Creates a new object that is a copy of the currently selected object, and 
duplicates all child objects.

NOTE: Avoid using the Copy Record option, except when the reuse and extension 
of an existing object would be impractical.

Delete Record
(CTRL+D)

Deletes the currently selected object and its child objects. 

NOTE: Avoid using the Delete Record option. If you want to remove an object 
from use, set its Inactive property to TRUE.

Cut
(CTRL+X)

In a text property, copies the selected text to the clipboard and deletes the 
existing text. In the Applet Designer, copies the selected control to the clipboard 
and deletes the existing control.

Copy
(CTRL+C)

In a text property, copies the selected text to the clipboard without deleting it. 
In the Applet Designer, copies the selected control to the clipboard without 
deleting it.

Paste
(CTRL+V)

Inserts text from the clipboard into a text property at the insertion point. Inserts 
a control from the clipboard in the Applet Designer.

Delete
(DEL)

In a text property, deletes the selected text. In the Applet Designer, deletes the 
selected control.

Select All
(CTRL+A)

Selects the entire document. In the Applet Designer, selects all controls in the 
applet.

Change 
Records

Changes multiple records simultaneously.

Find
(CTRL+F)

Finds the specified text in the Siebel Script Editor window.

Replace
(CTRL+H)

Replaces the specified text with different text in the Siebel Script Editor window.

Table 5. Edit Menu Options

Menu Option
(Shortcut) Description
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View Menu
The View menu options are used to change display environment settings, such as which windows and 
toolbars appear. It also invokes visualization views, which are diagrams showing object relationships. 
Table 6 describes the View menu options and suboptions.

Table 6. View Menu Options

Option
(Shortcut)

Suboption
(Shortcut) Description

Windows Palette Shows the Palettes window.

Properties Window Shows the Properties window.

Applets Window Shows the Applets window. 

Controls Window Shows the Controls/Columns window.

Bookmarks Window Shows the Bookmarks window.

Web Templates Window Shows the Web Templates Explorer window.

Multi Value Properties 
Window

Shows the Multi Value Property Window.

Refresh Windows Requeries and updates the state of dockable windows. 

Reset Windows Closes all dockable windows except the Object Explorer 
for the currently active editor. Does not close editor 
windows.

Editors Web Applet Editor Opens the selected applet in the Applet Layout Editor, 
including the Controls/Columns and Palettes windows.

Server Script Editor Opens the Siebel Script Editor. Editor can be specifically 
defined or be set to a default.

Browser Script Editor Opens the Siebel Web Script Editor, which is used to 
access scripts that control the presentation and behavior 
of applet controls and list columns in a Web applet 
template.

Visualize View Details For more information, see “Viewing Object Relationships” 
on page 126.

View Relationships

View Descendents

View Web Hierarchy
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Debug 
Windows

Calls
(CTRL+L)

Opens the Calls window for display of the call stack of the 
Siebel VB or Siebel eScript script currently being 
debugged.

Watch
(SHIFT+F9)

Opens the Watch window for display of the values of local 
variables in the Siebel VB or Siebel eScript script 
currently being debugged.

Errors Opens the Errors window for display of the run-time 
errors in the Siebel VB or Siebel eScript script currently 
being debugged.

Preview The preview of a Web view layout depicts the container 
page, screen bar, and view bar.

ActiveX 
Methods

Allows you to view the methods for the current ActiveX 
control in the Applet Designer.

Toolbars Displays or hides the various toolbars: Edit, History, List, 
Debug, Web Controls, and Configuration Context. 

Status Bar Displays or hides the Status bar at the bottom of the 
Siebel Tools window.

Object 
Explorer
(CTRL+E)

Displays or hides the Object Explorer. 

Options Opens the Development Tools Options dialog box, in 
which you can set general preferences and settings for 
language, check-in and check-out, list views, scripting, 
Web template editor, debugging, visualization, Object 
Explorer, and database.

Siebel Tools options are stored in a user preference file, 
which is located in SIEBEL_TOOLS_ROOT\BIN. The user 
preference filename is loginID&SiebelTools.spf.

Table 6. View Menu Options

Option
(Shortcut)

Suboption
(Shortcut) Description
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Screens Menu
The Screens menu is empty unless you log on to Siebel Tools as a system administrator. If you have 
system administrator rights, the options described in Table 7 appear.

Go Menu
The Go menu contains options for moving through a records list. Primarily, you use the Go menu to 
create and navigate to bookmarks, which flag objects for easy return navigation. Bookmarks are a 
helpful navigation aid, allowing you to move around among the objects of different types you are 
working on. Table 8 describes the Go menu options.

Table 7. Screens Menu Options

Option Suboption Description

Application 
Upgrader

Application Upgrade Object List The Application Upgrades, Object 
Differences, and Attribute Differences lists 
appear in the Object List Editor.

Application Upgrade Database 
Version

For internal use by Siebel.

Application Upgrade Attribute List The Application Upgrades and Attribute 
Differences lists appear in the Object List 
Editor.

System 
Administration

System Preferences Displays system preferences in the Object 
List Editor. This information is similar to 
the System Preferences view in the 
Administration - Application screen in 
Siebel Business Applications.

Analytics Strings For internal use by Siebel.

List of Values Displays lists of values in the development 
database.

Table 8. Go Menu Options

Option
(Shortcut) Description

Back Returns to the previously displayed screen.

Forward Returns to subsequently displayed screen.

Previous Record
(CTRL+UP)

Goes to the objects above the current selection. 

Next Record
(CTRL+DOWN)

Goes to the objects below the current selection. 
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Query Menu
The Query menu options allow you to create and refine Object List Editor queries, which restrict the 
list of objects that appear in the current Object List Editor. An option is provided that lets you change 
the sort order of objects in the window.

Table 9 describes the Query menu options.

Reports Menu
The Reports menu can be empty or list available reports about objects and properties, depending on 
which object type is currently active in the Object Explorer. The following reports are available:

■ Tables. For each table, displays selected properties and lists the columns. The name, physical 
type, length, scale, comments, and various other properties are identified for each column.

First Record
(CTRL+PAGE UP)

Goes to the first objects in the list.

Last Record
(CTRL+PAGE DOWN)

Goes to the last objects in the list.

Add Bookmark Invokes the Add Bookmark dialog box, for creation of a bookmark to the 
currently selected objects.

Bookmark List Opens the Bookmarks dialog box, for selection of an existing bookmark 
to navigate to. You can also use this dialog box to rename or delete 
existing bookmarks.

Table 9. Query Menu Options

Option
(Shortcut) Description

New Query
(CTRL+Q)

Allows you to specify restrictions on the set of objects to be displayed in the 
current Object List Editor.

Refine Query
(CTRL+R)

Allows you to add additional restrictions to the query currently in effect.

Execute Query
(ENTER)

Executes the query you have just specified, causing the restrictions to take 
effect. This has the same effect as pressing ENTER.

Sort Order Invokes the Sort Order dialog box, for specification of sort order criteria for the 
list of objects in the Object List Editor.

Table 8. Go Menu Options

Option
(Shortcut) Description
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■ EIM Interface Tables. For each EIM interface table, lists destination tables, source and 
destination columns, user keys for each destination column, data types for each source column, 
and various other properties.

Two additional reports are available on this menu when the Application Upgrader is active:

■ Application Upgrade Object List. Generates a report listing all object differences between 
repository versions.

■ Application Upgrade Attributes List. Generates a report listing all attribute differences 
between repository versions.

For more information on reports, see Siebel Reports Administration Guide.

Format Menu
The Format menu options in the Applet Layout Editor allow you to align, resize, and reposition 
controls; configure the snap grid; and adjust tab or list column order. Options are also provided for 
performing an Applet Designer Preview.

Table 10 describes the Format menu options.

Table 10. Format Menu Options

Option Description

Align Aligns the selected items with the selected model. 

Make Same Size Makes all selected items the same size as the selected model. 

Horizontal Spacing Adjusts horizontal spacing between items.

Vertical Spacing Adjusts vertical spacing between items.

Center in Applet Centers the selected items horizontally or vertically.

Set Label Alignment Allows you to align labels in applets based on grid layout Web templates.

Set Tab Order Allows you to set the tab order for fields in a form applet. This option is not 
available for list applets.
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Debug Menu
The Debug menu options control the Siebel VB or Siebel eScript debugger, for use when a script is 
open in the Siebel Script Editor. Table 11 describes the Debug menu options.

Table 11. Debug Menu Options

Option
(Shortcut) Description

Check Syntax Compiles the current script and verifies syntax.

Start
(F5)

Starts the application. A dialog box with startup parameters also appears.

Break
(CTRL+BREAK)

Stops the execution of the currently running script. If Siebel VB or Siebel 
eScript is not executing, no operation is performed.

End Stops the execution of the application and returns to the Siebel Script Editor 
window.

Restart
(SHIFT+F5)

Restarts the application if a break has occurred.

Toggle Breakpoint
(F9)

Sets or removes a breakpoint on a specific line of code.

Clear All 
Breakpoints
(CTRL+SHIFT+F9)

Removes all breakpoints from the current script routine.

Watch (SHIFT+F9) Displays script variables and their values. This window can be used to 
monitor the values of specific variables as a script executes.

Calls (CTRL+L) Contains a list of subroutine and function calls that were executed prior to 
the current line. Selecting an entry in the list causes the interpreter to shift 
to that entry.

Step Into
(F8)

Executes the next line of script code. If this is a subroutine or procedure 
call, then execution continues within that procedure.

Step Over
(SHIFT+F8)

Advances the application to the script code line just after the current 
subroutine or procedure. Execution remains at the level of the current 
procedure.

Step To Cursor
(CTRL+F8)

Executes all lines of code up to the line selected by the cursor.
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Tools Menu
Table 12 describes the Tools menu options.

Table 12. Tools Menu Options

Option
(Shortcut) Suboption Description

Compile (F7) Opens the Object Compiler dialog box to compile one or 
more projects, or all projects in the repository, into an 
SRF file. 

Compile Selected Objects
(CTRL+F7)

Opens the Object Compiler dialog box to compile the 
selected objects into an SRF file. 

Check Out
(F10)

Opens the Check Out dialog box, to copy one or more 
projects from the server to the local database.

Check In
(CTRL+F10)

Opens the Check In dialog box, to copy one or more 
projects from the local database to the server.

Lock Project
(ALT+L)

Locks the project that the currently selected object is 
assigned to.

Unlock Project
(ALT+U)

Unlocks the project that the currently selected object is 
assigned to.

Add To Archive Opens the Export To Archive dialog box, for adding the 
selected top-level objects or projects to an archive file.

Import From Archive Initiates the Import wizard for importing objects from 
an archive file.

Compare Objects Selected Compares two selected objects and graphically displays 
similarities and differences (in object type and 
instance), with a list of object properties by name and 
value.

Selected vs. 
Repository

Compares the selected object against the corresponding 
object in the selected repository and graphically 
displays similarities and differences.

Selected vs. 
Archive

Compares the selected object against the corresponding 
object in the selected archive file and graphically 
displays similarities and differences.

Archive vs. 
Archive

Compares two selected archive files and graphically 
displays similarities and differences.

Convert to Grid Layout Converts nongrid layout form applets to grid layout.

Search Repository Opens the Search Repository dialog box for performing 
a search for objects based on the text in their names (or 
other properties) and their object types.
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Validate Object From the Validate dialog box, runs validation on a 
selected object. Lists any errors by severity, rule 
number, object name, and error description. Allows 
changing of options for rules, severity, and 
enforcement. 

Upgrade Maintenance 
Update

Not applicable to version 8.0.

Prepare 
Repository

Used for upgrading from pre-7.x versions to version 8.0. 
The Prepare Repository utility is run before performing 
a repository merge. It migrates strings from the S_MSG 
table, merges labels and fields, and merges templates 
to specified applets for selected languages.

For more information, see the Siebel Database Upgrade 
Guide for the operating system you are using.

Migrate ICL 
Objects to 
Standard

Applicable when the Incorporate Custom Layout (ICL) 
option to preserve the layouts of customized objects had 
been chosen during a previous upgrade.

Before you can perform a subsequent upgrade, you 
must migrate the ICL objects to the standard repository.

For more information, see the Siebel Database Upgrade 
Guide for the operating system you are using.

Upgrade 
Application

Navigates to the Application Objects Upgrade List in the 
Application Upgrader screen of Siebel Tools, and opens 
the Merge Repositories dialog box. Used to merge 
standard and customized repositories.

For more information, see the Siebel Database Upgrade 
Guide for the operating system you are using.

Generate EIM 
Processing 
Columns

Opens the EIM Processing Column Generator dialog box, 
from which you create missing EIM processing columns 
and indexes after merging the repository.

Web Client 
Migration

Used when upgrading from version 6.x to version 7.x or 
8.0. It associates Web templates to a group of selected 
applets and views so that they can be used in the Web 
client.

For more information, see the Siebel Database Upgrade 
Guide for the operating system you are using.

Table 12. Tools Menu Options

Option
(Shortcut) Suboption Description
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Window Menu
The Window menu lists the currently open Object List Editor, Application Designer, visualization view, 
and other windows, and provides the means to navigate to windows that are currently hidden from 
view.

If one of the windows is open, the first option on the menu is Close. This closes the currently active 
window.

Utilities Generate Help 
IDs

Used internally by Siebel Systems to generate the 
sshelp.hm file, containing correspondences between 
context ID numbers and text help identifiers that have 
been specified in Help ID objects. This option is used for 
Tools Online Help.

Locale 
Management

Allows you to import and export translatable text strings 
and locale-specific attributes using the Local 
Management Utility.

Map Fax 
Properties

When the business component object type is selected in 
the Object Explorer, this option opens the Map Fax 
Properties dialog box for the current business 
component object. This dialog box is used to create 
mappings between fields in the business component and 
fax software property sheet properties. These mappings 
support customization of the fax cover sheet and 
message.

Export View 
Previews

Exports view from the Preview mode of the View Layout 
Editor to an HTML file.

Case 
Insensitivity

Used to administer case- and accent-insensitive 
searching on columns in the Siebel schema. Opens the 
Case and Accent Insensitivity Wizard.

For more information, see Configuring Siebel Business 
Applications and the Siebel Database Upgrade Guide for 
the operating system you are using.

Build Patch Initiates the Patch Builder wizard to create a patch file.

Apply Patch Opens the Apply Patch window to initiate the patch 
application process. 

Table 12. Tools Menu Options

Option
(Shortcut) Suboption Description
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Help Menu
Table 13 describes the Help menu options.

About Toolbars
There are several toolbars in Siebel Tools. The toolbars, like menu items, are active only when the 
object type or window that uses them is active. You can show and hide toolbars using the Toolbars 
option in the View menu. You can also rearrange the toolbars using drag-and-drop functionality. 

Topics in This Section
“History Toolbar” on page 48

“List Toolbar” on page 48

“Edit Toolbar” on page 49

“Debug Toolbar” on page 50

“Simulate Toolbar” on page 51

“WF/Task Editor Toolbar” on page 52

“Format Toolbar” on page 52

“Configuration Context Toolbar” on page 54

Related Topics
“About the Menu Bar” on page 35

Table 13. Help Menu Options

Option Description 

Contents Opens the Siebel Tools Online Help. 

Using Help Opens the Siebel Tools Online Help. 

Technical Support Displays the Technical Support Information dialog box, which includes 
information that Technical Support may need, such as the version number 
of your Siebel Tools installation.

About Record Opens a dialog box that displays information about the current object, 
including its creator and creation date. 

About SRF Opens a dialog box that displays information about the most recent full 
incremental compilations. 

About View Opens a dialog box that displays information about the current screen, 
business object, and view, including applet layout. 

About Visible Views Displays the list of views in the repository and whether or not they are 
visible.

About Siebel Tools Opens a dialog box identifying the version of Siebel Tools.
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“Showing and Hiding Toolbars” on page 83

History Toolbar
The History toolbar contains buttons for retracing your steps and for creating and navigating to 
bookmarks, which flag objects for quick return navigation. Bookmarks are a helpful navigation aid, 
allowing you to move around quickly among the different object types with which you are working. 
Table 14 describes the History toolbar buttons.

List Toolbar
The List toolbar contains buttons that apply to objects in the Object List Editor. The buttons let you 
insert new records, move forward and backward, work with queries, and sort objects. Table 15 
describes the List toolbar buttons.

Table 14. History Toolbar Buttons

Button Description

Go Back Returns to the previously displayed screen.

Go Forward Returns to the subsequent displayed screen.

Add Bookmark Opens the Add Bookmark dialog box, so you can add a bookmark for 
the currently selected object.

Bookmark List Opens the Bookmarks window, so you can select a bookmark to 
navigate to. You can also use this window to rename or delete 
existing bookmarks.

Table 15. List Toolbar Buttons

Button Description

Add New Record Creates a new object in the Object List Editor, with the cursor 
positioned in the first required property.

First Record Goes to the first object in the list.

Previous Record Goes to the object above the current selection.

Next Record Goes to the object below the current selection.
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Edit Toolbar
The Edit toolbar contains edit tools, the New Object wizard, and undo and redo options. 

You can also display a menu of edit tools by selecting a field and right-clicking while the cursor is 
positioned over the Object List Editor. For more information, see “About Right-Click Menus” on 
page 54.

Table 16 describes the Edit toolbar buttons.

Last Record Goes to the last object in the list.

New Query Allows you to specify one or more restrictions on the set of 
objects to be displayed in the current Object List Editor.

Execute Query Executes the query you have just specified, causing the 
restrictions to take effect. This has the same effect as pressing 
ENTER.

Sort Ascending Changes the order in which objects appear by sorting them in 
ascending order on the currently selected property column.

Sort Descending Changes the order in which objects appear by sorting them in 
descending order on the currently selected property column.

Filter Version Shows only the most recent version of each task or workflow in 
the Object List Editor.

Table 16. Edit Toolbar Buttons

Button Description

New Invokes the New Object Wizard, which allows you to create applets, 
views, charts, and other objects.

Save Saves changes in the current editing window when you are editing Layout, 
Menu, or Basic Scripts.

Save All Saves changes in all open editing windows.

Cut In a text property, copies the selected text to the clipboard and deletes 
the existing text. In the Applet Designer, copies the selected control to the 
clipboard and deletes the existing control.

Table 15. List Toolbar Buttons

Button Description
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Debug Toolbar
The Debug toolbar contains buttons, described in Table 17, that let you access Siebel VB and Siebel 
eScript debugging tools.

Copy In a text property, copies the selected text to the clipboard without 
deleting it. In the Applet Designer, copies the selected control to the 
clipboard without deleting it. 

Paste Inserts text from the clipboard into a text property at the insertion point. 
In the Applet Designer, inserts a control from the clipboard.

Undo Reverses the last change to a property value in the Object List Editor or 
Property window if the object has not been committed.

Redo Reapplies changes after the Undo command has been executed.

Table 17. Debug Toolbar Buttons

Button Description

Check Syntax Compiles the current script and verifies syntax.

Start Starts the application. A dialog box with startup parameters also 
appears.

Break Stops the execution of the currently running script. If Siebel VB 
or Siebel eScript is not executing, no operation is performed.

End Stops the execution of the application and returns to the Siebel 
Script Editor window.

Toggle Breakpoint Sets or removes a breakpoint on a specific line of code.

Table 16. Edit Toolbar Buttons

Button Description



About the Siebel Tools User Interface ■ About Toolbars

Using Siebel Tools Version 8.0, Rev. A 51

Simulate Toolbar
The Simulate toolbar contains buttons, described in Table 18, that let you simulate workflow 
processes.

Watch Monitors the contents of program variables in the Watch window 
during execution of Siebel VB and Siebel eScript routines.

Calls Displays the list of Siebel VB or Siebel eScript routine calls 
executed up to the point where the application was stopped.

Step Into Executes the next line of script code. If this is a subroutine or 
procedure call, then execution continues within that procedure.

Step Over Advances the application to the script code line just after the 
current subroutine or procedure. Execution remains at the level 
of the current procedure.

Table 18. Simulate Toolbar Buttons

Button Description

Start Simulation Starts the simulation of a workflow process.

Simulate Next Simulates the next workflow process step.

Complete 
Simulation

Completes the simulation of a workflow process.

Stop Simulation Stops the Workflow Simulator.

Table 17. Debug Toolbar Buttons

Button Description
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WF/Task Editor Toolbar
The WF/Task Editor toolbar contains buttons, described in Table 19, that let you publish, activate, 
revise, and expire tasks and workflows.

Format Toolbar
The Format toolbar contains buttons, described in Table 20, that let you apply specific formatting to 
controls for applets based on grid-layout Web templates.

Table 19. WF/Task Editor Toolbar Buttons

Button Description

Publish/Activate Publishes and activates a task during run time in a single step. This 
is only available in the development environment using the Siebel 
Mobile Web Client; you cannot use Publish/Activate to activate tasks 
and workflows in the production environment.

Publish Makes a task available to activate from the run-time client.

Revise Revises a task.

Expire Makes a task inactive.

Table 20. Format Toolbar Buttons

Button Description

Aligns the left edges of controls

Aligns the centers of controls along a vertical axis

Aligns the right edges of controls

Aligns the tops of controls

Aligns the middles of controls along a horizontal axis

Aligns the bottom of controls



About the Siebel Tools User Interface ■ About Toolbars

Using Siebel Tools Version 8.0, Rev. A 53

Makes the controls the same width

Makes the controls the same height

Makes the controls the same size

Makes the horizontal spacing between controls equal

Increases the horizontal spacing between controls

Decreases the horizontal spacing between controls

Removes the horizontal spacing between controls

Makes the vertical spacing between controls equal

Increases the vertical spacing between controls

Decreases the vertical spacing between controls

Removes the vertical spacing between controls

Centers the controls vertically

Centers the controls horizontally

Aligns the labels to the left

Centers the labels

Aligns the labels

Table 20. Format Toolbar Buttons

Button Description
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Configuration Context Toolbar
The Configuration Context toolbar contains drop-down lists, show in Table 21, that let you define 
settings for Web browser layout and scripting.

About Right-Click Menus
Right-click menus in Siebel Tools are context sensitive. They allow you to perform actions such as 
the following:

■ Create, copy, and delete records. You can also undo changes made to a record.

■ Launch the Applet Layout Editor or View Layout Editor from the Object List Editor by right-clicking 
on an Applet or View object, respectively, and then choosing Edit Web Layout.

■ View and edit Web templates by right-clicking on Web Template objects in the Object List Editor, 
and then choosing View Web Layout.

■ Display the names and status of toolbars (similar to using View > Toolbars) by right-clicking on 
any toolbar. You can also customize toolbars.

■ Check out and lock objects.

■ Add objects to archives and hot-fixes.

■ Access New Object wizards specific to the object type active in the Object List Editor.

Table 21. Configuration Context Toolbar Drop-Down Lists

Drop-Down List Description

Target Browser A drop-down list from which you select a target browser for layout editing 
and for scripting.

Application Allows you to configure objects for a specific application. Typically, you 
work with the All Applications selected. When this option is selected, your 
configurations are available in all applications. However, by selecting 
specific applications from the list, you can also configure the layout of 
objects such as applets and views to look or behave a differently for that 
application.

Interactivity Allows you to select High Interactivity or Standard Interactivity. This 
allows you to configure Web layouts differently, depending on the mode 
in which the application runs.

Variable Allows you to specify a given display style for an applet for previewing, 
such as parent, child, or grandchild.

An applet can be rendered differently depending on the underlying Web 
template. For example, the header of an applet might not appear when it 
is rendered as a grandchild.
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About Layout Editors
There are several layout editors in Siebel Tools: the Applet Layout Editor, View Layout Editor, Web 
Page Layout Editor, and Applet Menu Layout Editor. These layout editors let you:

■ Add and map controls and list columns to applet layouts. You can preview applets as they would 
be rendered at run time.

■ Modify existing views and construct new ones by dragging and dropping applets onto the View 
Layout Editor. You can view list and form applets and the container page in the Preview mode. 
No additional specification or code is required for defining the relationships between the applets.

You can launch the Applet Layout Editor directly from the View Layout Editor by double-clicking 
on an applet.

■ Add and delete controls from Web page templates, modify control properties, and map controls 
to placeholders. You can also preview Web pages as they would appear at run time.

■ Visually edit Siebel application menu structures. This is accessed by right-clicking an applet in 
the Object List Editor and selecting Edit Web Menus.

You can launch the Layout Editors directly from an applet, view, or Web page in the Object List Editor 
by right-clicking and choosing Edit Web Layout or Edit Web Menus.

For more information about using layout editors, see Configuring Siebel Business Applications.

Related Topic
“Choosing a Target Browser” on page 77

About New Object Wizards
Various wizards in Siebel Tools step you through the process of creating objects. They prompt you 
for the required property values and configure any dependent object types. Use the New Object 
wizards to create objects whenever possible.

Wizards are available for many object types, including:

■ General objects, such as Applet Method Menu Items, Business Components, Tables, and Views

■ Applet objects, such as List Applets, Form Applets, MVG Applets, and Chart Applets

■ EAI objects, such as Integration Objects

■ Task objects, such as Tasks, Task Applets, Task Views, and Transient Business Components

You can access the New Object Wizards dialog box by choosing File > New Object. You can also right-
click on an object in the Object List Editor and then choose New Object Wizards for a list of wizards 
specific to that object type.

For more information about using New Object wizards, see Configuring Siebel Business Applications.
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About Canvas-Based Designers
Siebel Tools has three canvas-based designers:

■ Entity Relationship Designer

■ Workflow Process Designer

■ Task Designer in the Task UI

These designers share a common design environment, as well as the Palettes and Multi Value 
Property windows. In the design environment, you can drag and drop elements, such as Siebel 
objects in the Entity Relationship Designer and Siebel operations in the Workflow Process and Task 
Designers, and then connect them. In Siebel Tools version 8.0, the connectors automatically form 
right angles and snap to the sides of the design elements.

An example of a canvas-based designer is shown in Figure 15.

Figure 15. Task Designer
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Related Topics
“About the Palettes Window” on page 29

“About the Multi Value Property Window” on page 33

Entity Relationship Designer
The Entity Relationship Designer is a visual modeling tool that allows you to diagram your business 
entities, represent the relationships between them, and then map them to Siebel objects, such as 
business components, links, and joins.

The Entity Relationship Designer is typically used by both Business Analysts and Developers. 
Business analysts diagram a customer’s business and then developers or technical architects map 
the entities in the diagrams to Siebel objects in the repository.

When mapping entities and relationships in the diagram to Siebel objects, the choice of objects 
includes only those that have characteristics that match the context described in the diagram.

For information on creating entity relationship diagrams and mapping them to Siebel objects, see 
Configuring Siebel Business Applications.

Workflow Process Designer
The Siebel Workflow Process Designer allows you to define, manage, and enforce your company's 
business processes. Defining business processes is typically a development task. The Workflow 
Process Designer and the Workflow Simulator are integrated with Siebel Tools, allowing you to define 
and test business processes and related repository objects in a single environment.

The Workflow Process Designer, shown in Figure 25 on page 135, is launched by selecting a Workflow 
Process object, right-clicking, and then choosing Edit Workflow Process.

For information about creating workflows, see Chapter 8, “Creating Workflow Processes and Tasks.” For 
detailed information on using the Workflow Designer and Workflow Simulator, see Siebel Business 
Process Framework: Workflow Guide.

Task Designer in the Task UI
The Siebel Task UI extends business process automation all the way to the point of user interaction. 
Tasks are multiple-step, interactive operations that can include branching and decision logic. Task 
UI’s wizard-like user interface guides the end user through task execution, allows navigation both 
forward and backward within task execution, and allows task execution to be paused and resumed 
as needed.

This combination of features helps Siebel Tasks to increase the efficiency of novice and intermittent 
users by guiding them through the execution of unfamiliar tasks. The Task UI can also increase the 
efficiency of busy veteran users, especially those working in environments that are prone to 
interruption, because it allows for easy switching between multiple tasks throughout the workday.
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The Task Designer in the Task UI, shown in Figure 15 on page 56, is launched automatically when you 
create a Task object using the New Task wizard, or by selecting a Task object, right-clicking, and then 
choosing Edit Task Flow.

For information about creating tasks, see Chapter 8, “Creating Workflow Processes and Tasks.” For 
detailed information on using the Task UI, and on publishing and activating tasks, see Siebel Business 
Process Framework: Task UI Guide.

About Script Editors
Scripting is used to implement functionality that cannot be achieved declaratively (that is, by 
changing object properties). The Server Script Editor and the Browser Script Editor are used to add 
scripts to Siebel objects. Scripting is supported through three features in Siebel applications: Siebel 
VB, Siebel eScript, and Browser Script. 

For more information on Script Editors, including Script Assist, see Chapter 9, “Siebel Script Editors.”

About the Command-Line Interface
You can use the command-line interface to run various tasks, including:

■ “Validating Objects Using the Command-Line Interface” on page 117

■ “Command-Line Interface for Import, Export, and Compilation” on page 165

■ “Exporting Objects to an Archive File Using the Command-Line Interface” on page 171

■ “Exporting Objects to a Hot-Fix Using the Command-Line Interface” on page 173

■ “Importing Objects from an Archive File Using the Command-Line Interface” on page 182

■ “Running the LMU Using the Command-Line Interface” on page 226

■ Converting to grid layout. For more information, see Configuring Siebel Business Applications.
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3 Customizing Your Siebel Tools 
Environment

This chapter describes how to customize the Siebel Tools environment. It contains the following 
topics:

■ “About Development Tools Options” on page 60

■ “Showing and Hiding Confirmation Dialog Boxes” on page 60

■ “Setting Change Date Preferences” on page 60

■ “Setting Workflow and Task Configuration Options” on page 61

■ “Selecting a Language Mode” on page 61

■ “Enabling Language Overrides” on page 62

■ “Process for Integrating with Third-Party Source Control” on page 63

■ “Specifying Data Sources” on page 67

■ “Restarting Editors After Check Out” on page 69

■ “Setting Commit Options for Full Get” on page 69

■ “Defining Object List Editor Display Options” on page 70

■ “Setting Scripting Options” on page 70

■ “Choosing the Web Template Editor” on page 72

■ “Setting Debug Options” on page 72

■ “Customizing Visualization Views” on page 73

■ “Showing and Hiding Object Types in the Object Explorer” on page 74

■ “Setting Database Options” on page 75

■ “Setting the Constrain Mode for Working with Symbolic Strings” on page 76

■ “Choosing a Target Browser” on page 77

■ “Showing, Hiding, and Docking Windows” on page 77

■ “Showing and Hiding Editors” on page 82

■ “Showing Visualization Views” on page 82

■ “Showing and Hiding Debug Windows” on page 83

■ “Showing and Hiding Toolbars” on page 83

■ “Showing and Hiding the Status Bar” on page 84
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About Development Tools Options
Several customization tasks involve choosing View > Options and setting preferences in the 
Development Tools Options dialog box. Whenever you click OK to exit the Development Tools Options 
dialog box, whether you have made changes to the preferences or not, the preferences are saved in 
the devtools.prf file, located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools 
installation directory.

NOTE: If the behavior of the Tools environment is not consistent with the preferences you set, your 
devtools.prf file may be corrupted. Choose View > Options, reset preferences if necessary, then click 
OK. By doing so, the devtools file is regenerated. Alternatively, if you delete the devtools.prf file, 
then relaunch Tools, the default preferences are reset.

Showing and Hiding Confirmation Dialog 
Boxes
You can choose to show or hide dialog boxes that pop up to confirm you want to perform a given 
action, such as delete.

To show or hide confirmation dialog boxes

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the General tab.

3 Under Editing confirmation dialogs, select the check boxes for the confirmation dialog boxes you 
want to see, and clear the check boxes for the confirmation dialog boxes you do not want to see.

4 Click OK.

Setting Change Date Preferences
Records are marked as changed in the Object List Editor when they occur after the date defined under 
the General Tab of the Development Tools Options dialog box.

To set change date preferences

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the General tab.

3 Under Changed date, use the Date and Time fields to set your preferences, and then click OK.
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Setting Workflow and Task 
Configuration Options
These options, shown in Table 22, help developers to be more productive when working with tasks 
and workflows.

To set workflow and task configuration options

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the General tab.

3 Under Workflow and Task Configurations, use the checkboxes to set your preferences, and then 
click OK.

Selecting a Language Mode
The Siebel Tools language mode allows you to work with locale-specific data for languages other than 
English. For example, setting your language mode to German (DEU) allows you to view and edit DEU-
specific data stored in Locale-Objects, such as translated strings. Language mode determines the set 
of locale-specific data that:

■ You can view and edit in the Object List Editor.

■ Is used when compiling the repository (SRF) file.

■ Is transferred during check in and check out processes.

NOTE: If additional languages (other than the language product versions shipped with Siebel 
applications) are added to the Siebel database, the language code must be in all capital letters for 
the code to appear in the Language Mode drop-down list. For more information on adding languages 
not shipped by Oracle, see Siebel Global Deployment Guide.

Table 22. Workflow and Task Configuration Options

Checkbox Description

Automatic revision in WF/Task editor and 
version check

Warns you if you attempt to edit an earlier version 
than what you have already opened.

Automatically revises a workflow/task if you 
invoke the editor for a completed workflow/task. 
Creates a new in-progress object for you.

Automatically close all the previous WF/Task 
versions if Status is Completed, Not In Use or 
Expired

Ensures that you are working on the most current 
workflow/task version.
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To set a language mode

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Language Settings tab.

3 Under Tools Language Mode, select a value from the Language drop-down list, then click OK.

NOTE: Before configuring another language, make sure that the language repository data has 
already been loaded into the repository. If not, load this data before beginning configuration on the 
language in question.

Related Topics
“Enabling Language Overrides” on page 62

“Using the Advanced Compile Option” on page 229

Enabling Language Overrides
Language Overrides are untranslatable locale-specific attributes that may be configured differently 
for different locales. For example, you can configure an address field to appear one height in FRA 
(French) and another height in ENU (English). To be able to configure language overrides, you must 
be in Language Override mode.

NOTE: Enabling language overrides when it is not needed can create unnecessary locale records in 
the repository.

For more information about configuring UI layout, see Configuring Siebel Business Applications.

To enable language overrides

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Language Settings tab.

3 Under Language override, select the Enable and Use Language Override check box, then click OK.

NOTE: The Enable and Use Language Override check box is persistent. You must clear it to return 
to working in base mode.

Related Topics
“Selecting a Language Mode” on page 61

“Working with Untranslatable Locale-Specific Object Properties” on page 215

“Using the Advanced Compile Option” on page 229
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Process for Integrating with Third-Party 
Source Control
You can integrate your repository check in/check out mechanism in Siebel Tools with a third-party 
source code-control system such as Microsoft Visual SourceSafe. When source control integration is 
enabled, each time a project is checked into the server repository, an archive file containing all the 
objects in the project is also checked into the source control system. As a result, successive versions 
of the project are maintained in the source control system. 

To integrate your repository check in/check out with a third-party source control system, perform 
the following tasks:

1 “Setting Source Control Options” on page 63

2 “Configuring the srcctrl.bat File” on page 64

Setting Source Control Options
You enable and partly configure the interface to an external source control system using the 
Development Tools Options dialog box. 

To integrate Siebel Tools with a third-party source control product

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.

3 Use the information in the following table to define your settings under Source control 
integration.

Field/Check Box Description

Enable source control integration Select this check box and specify the location of the 
srcctrl.bat batch file in the Integration batch file text box 
if you want to generate an archive file for each project 
when performing repository check in, and at the 
conclusion of repository check in to run the batch file 
once for each project.

Show execution of the integration 
batch file

Select this check box to launch a DOS window in the 
foreground when the srcctrl.bat batch file is executed. 
This feature is for diagnostic purposes and facilitates 
debugging a customized batch file.

Integration batch file Specifies the location of the srcctrl.bat batch file used by 
Siebel applications to instruct the source control 
software to provide check in or check out of archive files.
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4 Click OK.

Configuring the srcctrl.bat File
The srcctrl.bat batch file contains the sequence of commands to be executed in order to check the 
archived projects in to the source control system. You need to modify the batch file to reflect your 
current development environment and then distribute to all developers at your site.

The name of the archive (SIF) file for the project to be checked in is specified as an argument to the 
batch file, in addition to other arguments. The syntax for the command line that executes the batch 
file is as follows:

SRCCTRL action dir comment_file project_file

The arguments for srcctrl.bat are described in Table 23.

Srcctrl.bat executes once for each project, following the completion of repository check-in. It checks 
the archive file for the project into or out of the source control system. Srcctrl.bat is executed from 
a command line that is internally generated from the Siebel application software. You do not have 
access to the command-line setup, and you cannot modify the command line or the parameters it 
passes.

The following batch file program code is taken from the standard srcctrl.bat file provided with Siebel 
applications, and is designed to work with Microsoft Visual SourceSafe. Comment lines have been 
removed. You need to customize the program code in this batch file, particularly if you are running 
source control software other than Microsoft Visual SourceSafe, or if the path is incorrect:

set PATH=C:\Program Files\DevStudio\Vss\win32\;%PATH%
set SOFTWARE=ss
set CHECKIN=%SOFTWARE% checkin
set CHECKOUT=%SOFTWARE% checkout
set ADD=%SOFTWARE% add
set SETPROJ=%SOFTWARE% cp
set PROJECT=$/PROJPOOL
set SRC_USR=
set SRC_PSWD=

Table 23. Arguments for the srcctrl.bat File

Argument Description

action Check in or check out.

dir Path name of the directory on your local file system where the 
items are located.

comment_file Contains the comment text to be provided to the source 
control software with the project file.

project_file Name of the archive (SIF) file for one project, enclosed in 
double quotes.
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set OPTIONS=-i-y -y%SRC_USR%,%SRC_PSWD%
set COMMENT=-c@
set NON_COMMENT=-c-
set FILE=
set LOGFILE=C:\Temp\xml.log
echo =======================srcctrl.bat========================== >> %LOGFILE%
set ACTION=%1
shift
set DIR=%1
shift
set COMMENT=%COMMENT%%1
shift
set FILE=%1
echo Change local directory to %DIR% >> %LOGFILE%
chdir %DIR% >> %LOGFILE% 2>&1
echo Set %PROJECT% as the working folder at Source Control System >> %LOGFILE%
%SETPROJ% %PROJECT% >> %LOGFILE% 2>&1
if errorlevel 100 goto END
if %ACTION%==checkout goto CHECK_OUT
if %ACTION%==checkin goto CHECK_IN
:CHECK_OUT
echo ============Check out file %FILE% from Source Control System============
if not exist %FILE% echo "New File" >> %FILE%
attrib +r %FILE%
echo Add %FILE% in case it doesn't exist in Source Control System >> %LOGFILE%
%ADD% %FILE% %NON_COMMENT% %OPTIONS% >> %LOGFILE% 2>&1
echo Start checking out %FILE% from Source Control System >> %LOGFILE%
%CHECKOUT% %FILE% %NON_COMMENT% %OPTIONS% >> %LOGFILE% 2>&1
goto END
:CHECK_IN
echo ============Check in file %FILE% into Source Control System============
echo Check in %FILE% into Source Control System >> %LOGFILE%
%CHECKIN% %FILE% %COMMENT% %OPTIONS% >> %LOGFILE% 2>&1
attrib -r %FILE%
goto END
:END
echo ===================End Of srcctrl.bat====================== >> %LOGFILE%



Using Siebel Tools Version 8.0, Rev. A

Customizing Your Siebel Tools Environment ■ Process for Integrating with Third-Party 
Source Control

66 

The variables used in the srcctrl.bat batch file are described in Table 24.

NOTE: The folder to which SIF files are written is specified by the TempDir parameter in the [Siebel] 
section of the tools.cfg file. By default it is set to the SIEBEL_TOOLS_ROOT\TEMP folder of your 
Siebel Tools installation folder. Change this parameter to write the PROJECT directory to another 
location.

For information on archive (SIF) files, see “About Archive Files” on page 169.

Table 24. Variables in srcctrl.bat

Variable Description

PATH Identifies the directory where the source code control software is installed. Modify 
this setting to reflect its actual location on your machine.

SOFTWARE Source control system’s command-line utility. The command-line utility for 
Microsoft Visual SourceSafe is “ss”. 

CHECKIN Command at the start of the command line that calls for check-in into the source 
control system.

CHECKOUT Command at the start of the command line that calls for check-out from the source 
control system. 

ADD Command at the start of the command line that calls for adding files in the source 
control system.

SETPROJ Command at the start of the command line that calls for setting the working folder 
in the source control system. 

PROJECT Project (working folder) in the source control system where the items will be 
checked in/checked out. 

COMMENT Command-line Comments clause for each of the files being checked in or out. This 
is generated from the Comment argument to the batch file.

OPTIONS Text of the Options clause to include in a command line.

SRC_USR User logon name to include in the Options clause. This is a source control software 
user name, not the user name for a Siebel application.

SRC_PSWD User password to include in the Options clause. This is a source control software 
password.

FILE Filename of the archive file, obtained from the argument list of the batch file. This 
file needs to be checked in or out.

LOGFILE Path and filename of the log file that will be generated.
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Example of Integrating with Microsoft Visual 
SourceSafe
The following sections provide you with examples for using Microsoft Visual SourceSafe.

Check In Example
You have two projects checked out that you want to simultaneously check in to the server and to the 
source control software. The projects selected are “ProjectA” and “ProjectB.” The latest version of 
ProjectA.sif in Visual SourceSafe is 6, and the latest version of ProjectB.sif is 5.

When you click the Check In button, the following sequence occurs:

1 ProjectA and ProjectB are checked in to the server repository.

2 SIEBEL_TOOLS_ROOT\BIN\srcctrl.bat is invoked. This carries out steps 3, 4, and 5.

3 ProjectA.sif and ProjectB.sif are checked out and locked in Visual SourceSafe.

4 ProjectA is exported to SIEBEL_TOOLS_ROOT\TEMP\projects\ProjectA.sif, and ProjectB is 
exported to SIEBEL_TOOLS_ROOT\TEMP\projects\ProjectB.sif.

5 ProjectA.sif and ProjectB.sif are checked in to Visual SourceSafe. The version numbers are 
increased so that the latest version of ProjectA.sif in Visual SourceSafe is version 7, while 
ProjectB.sif is version 6.

Revert to Previous Version Example
Consider the situation in which an erroneous definition of ProjectA has been checked in to the server 
repository. This is stored in Microsoft Visual Source Safe as version 5 of ProjectA.sif. You want to 
revert to version 4 of ProjectA, because it does not contain the errors:

1 Check out version 4 of ProjectA.sif from Visual SourceSafe into SIEBEL_TOOLS_ROOT\TEMP.

2 Check out ProjectA from the server repository.

3 Import ProjectA.sif into the local repository using the Overwrite option to resolve object 
definition conflicts. This replaces the existing definition of ProjectA with the archived version. 

4 Check ProjectA in to the server repository. ProjectA.sif is automatically checked in to Visual 
SourceSafe as version 6.

Specifying Data Sources
The Check In/Out tab in the Development Tools Options dialog box provides options for setting up 
server and client data sources.

NOTE: For purposes of development, you should maintain only one local database for use with Tools 
and with your Mobile Web Client, so that changes implemented in Siebel Tools can be viewed with 
the Mobile Web Client. Edit the tools.cfg file and client application .cfg files (such as uagent.cfg) to 
point to the same local database.
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To specify data sources

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.

3 Change the ODBC data source of the server repository by doing the following:

a Under Data sources, in the Server field, click the Change button to change the ODBC data source 
of the server repository.

b Use the information in the following table to define the ODBC data source parameters.

c Click OK.

4 Change the ODBC data source of the local repository by doing the following:

a Under Data sources, in the Client field, click the Change button to change the ODBC data source 
of the local repository.

b Use the information in the following table to define the ODBC data source parameters.

c Click OK.

5 Click OK.

NOTE: When exiting Siebel Tools, changes to the ODBC data source settings are written to 
preference (SPF) files in the SIEBEL_TOOLS_ROOT\BIN directory. These are cached: when you 
relaunch Siebel Tools, the ODBC settings in tools.cfg are not read. Therefore, it is not possible 
to run multiple Siebel Tools applications using a single user ID: only one local data source can 
be open at one time.

Field Description

ODBC data source Full ODBC data source string that provides communication with the 
server repository database. 

User name User logon ID (in all uppercase) used to access the server database.

Password User password (in all uppercase) used to access the server database.

Table owner Table owner name used to access the repository on the server 
database.

Field Description

ODBC data source Full ODBC data source string that provides communication with the 
local repository database. 

User name User logon ID (in all uppercase) used to access the local database.

Password User password (in all uppercase) used to access the local database.

Table owner Table owner name used to access the repository on the local database.
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Restarting Editors After Check Out
You can set an option that automatically restarts any open editors after the check out process 
finishes.

To restart editors after check out

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.

3 Select the Restart the editors after Check Out check box.

Any editors that are open at the time you begin the Check Out process are restarted when the 
Check Out process finishes.

4 Click OK.

Setting Commit Options for Full Get
By default, the Full Get process performs database commits in regular intervals during the process 
rather than a single commit at the end of the process. 

You can disable this option by choosing View > Options, selecting the Check In/Out tab, and then 
clearing the Enable incremental commit during Full Get check box. 

To set commit options for Full Get

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Check In/Out tab.

3 To request a single commit at the end of a Full Get, clear the Enable incremental commit during 
Full Get check box.

4 Click OK.

Related Topics
“About the Get Process” on page 85

“Performing a Full Get” on page 85
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Defining Object List Editor Display 
Options

To define display options for the Object List Editor

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the List Views tab.

3 Use the information in the following table to define your options.

4 Click OK.

Setting Scripting Options
Browser and Server scripts are created in the Script Editor embedded in Siebel Tools. For more 
information on the Script Editor, see Chapter 9, “Siebel Script Editors.” You can set various options for 
working in the Script Editor, including setting a default scripting language, specifying a location for 
compiling browser scripts, and defining options for debugging.

NOTE: The Script Assist settings are available only if you have the ST eScript Engine enabled. See 
“About the ST eScript Engine” on page 142 for more information.

To set scripting options

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Scripting tab.

Area Field Description

List fonts Small/Normal/Large The size of the font used in the list.

List spacing Tight/Normal/Loose The spacing between rows in the list.

Style Horizontal grid lines Show or hide horizontal grid lines in the list.

Vertical grid lines Show or hide vertical grid lines in the list.

Alternating row color Use different colors for every second row.

Mouse focus rectangle Show or hide dotted line that appears around the 
currently selected record.



Customizing Your Siebel Tools Environment ■ Setting Scripting Options

Using Siebel Tools Version 8.0, Rev. A 71

3 Use the information in the following table to define your options.

4 Click OK.

Area Field Description

Font Name Used to select the font name for display of 
scripts.

Size Used to select the font size for display of scripts.

Script Assist Enable Method Listing Enables Script Assist to display a drop-down of all 
methods and properties available for a declared 
object.

Tab width Defines the number of spaces for a tab character. 
The default is four spaces.

Enable Auto Complete When checked, will auto complete a given term 
when the minimal number of unique characters 
have been entered.

Additionally, this setting will auto complete 
method or property names, presenting a drop-
down list for strings that are not unique. 

Auto Indent When checked, each succeeding line is indented 
to the position set by the current line.

Enable Favorites When checked, the most frequently used object, 
method, and property names will appear in italics 
at the top of the Script Assist window.

Engine Settings For more information on these settings, see 
“Setting ST eScript Engine Options” on page 144.

Language Default language for new 
scripts

A drop-down list allows you to choose the 
scripting language, either eScript or Visual Basic.

Browser script 
compilation folder

Specify the folder where your scripts will reside.

Debugging Adjust breakpoint to next 
valid line

When breakpoints are deleted on invalid lines, 
this option creates a breakpoint at the next valid 
line.

Make debugger window 
active when debugging

The Siebel Debugger window appears whenever 
you are in debug mode.

Always enter the 
debugger when an error 
occurs

The Siebel Debugger window appears whenever a 
script error occurs.
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Choosing the Web Template Editor
The Web template editor is an external application that you choose here and that you can open using 
a right-click menu in the Web template explorer. For example, in the Web template explorer, navigate 
to a given Web template, then right-click, and the application chosen as the default editor opens with 
the selected Web template automatically displayed.

To choose the editor for Web template files

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Web Template Editor tab.

3 In the Folder full path field, type the full path to location of your Web template files.

4 Under External Web template editor, do the following:

a Use the Browse button in the Executable full path field to navigate to and select the executable 
for the external Web editor.

b In the Optional parameters field, enter the parameters you want to pass to the executable when 
you launch the external editor.

5 Click OK.

Setting Debug Options
The debug options provide the run-time settings for opening an instance of the Siebel Web Client in 
the following situations:

■ When the Auto-start Web Client option is selected in the object compiler. 

For more information, see “Compiling Projects” on page 164.

■ When starting an instance of the Web Client by selecting Debug > Start. 

You typically use this option when debugging Siebel eScript or Siebel VB. For more information, 
see Siebel eScript Language Reference and Siebel VB Language Reference.

The settings defined the Debug tab of the Development Tools Options dialog are stored in a user 
preference file that is named loginID&SiebelTools.spf and located in SIEBEL_TOOLS_ROOT\BIN. 

To set up Tools to automatically open the Siebel Mobile Web Client

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Debug tab.



Customizing Your Siebel Tools Environment ■ Customizing Visualization Views

Using Siebel Tools Version 8.0, Rev. A 73

3 Use the information in the following table to define your options under Run-time start up 
information.

4 Use the information in the following table to define your options under Login information and then 
click OK.

Customizing Visualization Views
You can customize the font and appearance of visualization views.

To customize visualization views

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Visualization tab.

Field Example Value Description

Executable Siebel.exe Name of the executable 
that is opened in debug 
mode or automatically 
opened after the compile 
process.

CFG file C:\Program Files\Siebel\8.0\web 
client\BIN\ENU\uagent.cfg

Name and location of the 
configuration file for the 
application.

Browser C:\Program Files\Internet 
Explorer\iexplore.exe

Installation location of the 
Microsoft Internet Explorer 
browser. 

Working 
Directory

C:\Program Files\Siebel\8.0\web client\BIN The directory that contains 
the Siebel executable.

Arguments ■ /h – To enable local debugging of Server 
scripts

■ /s <filename> – To enable SQL spooling

Opens the watch window 
that allows you to trace the 
application.

Field Example Value Description

User name SADMIN User name used to log into the test application.

Password SADMIN Password to log in to the test application.

Datasource Sample Local database to which the local Mobile Web Client 
connects. Default data source. Values listed depend 
upon the configuration file you are using.
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3 Use the information in the following table to define your options under Font.

4 Use the information in the following table to define your options under Object style, and then 
click OK.

Showing and Hiding Object Types in the 
Object Explorer
By default, not all objects appear in the Object Explorer.

To show and hide objects

1 Choose View > Options.

The Development Tools Options dialog box appears.

Option Description

Use system 
font

Select this option to let Siebel Tools use a system font for the visualization 
views.

Use a Custom 
Font

Select this option to choose your preferred font for the visualization views. 
When you select this option, you must use the Font, Size, and Zoom drop-
down lists to define your preferences.

Option Description

Boxes with 3D borders Displays boxes with a 3D border.

Icon and name only Displays object name and object icon (the same icon used in the 
Object Explorer).

Simple outline boxes Displays object names in simple boxes.

Always print outline style Prints visualization details in outline style.
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2 Click the Object Explorer tab.

The Object Explorer hierarchy appears as shown.

3 In the Object Explorer Hierarchy box, shown below, select the check boxes for the objects you 
want to show and clear the check boxes for the objects you want to hide.

When you select a top-level object such as Applet, all child objects are automatically selected. 
To hide child objects, you need to expand the parent object and remove the check marks from 
any child objects that you want to hide. The parent check box becomes shaded to indicate that 
it contains child objects that are not selected to show. 

TIP: The state of the check box provides information about the show/hide state of the child 
objects.

4 To restore default settings, click the Default button, then click OK.

Setting Database Options
The Database tab of the Development Tools Options dialog box is used to set database preferences.

Check Box State Description

Current object shown, and all child objects shown.

Current object hidden, and all child objects hidden.

Current object shown, and some child objects shown.
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To set database options

1 Choose View > Options.

The Development Tools Options dialog box appears.

2 Click the Database tab.

3 Use the information in the following table to set your options, and then click OK.

Setting the Constrain Mode for Working 
with Symbolic Strings
Siebel Tools can run in either constrained mode or unconstrained mode:

■ When working in constrained mode, you must choose translatable text strings from the list of 
available string references. You cannot override the string reference by entering a value for a 
string override field, and you cannot create new symbolic string references.

■ When working in unconstrained mode, you are not required to choose translatable text strings 
from the list of string references. You can override the string reference by entering a value in a 
string override field. You can also create new symbolic string references.

The constrain mode is determined by the following CFG file parameter, found in the [Siebel] section 
of the tools.cfg file:

EnableToolsConstrain = FALSE

The default value for EnableToolsConstrain is FALSE, meaning unconstrained mode. Set it to TRUE to 
work in constrained mode.

Related Topics
“About the Symbolic Strings Model” on page 198

“Creating Symbolic Strings” on page 199

Option Description

Developing for deployment on 
DB2 for zSeries

For information about this parameter, see Implementing 
Siebel Business Applications on DB2 UDB for z/OS.

Limit schema object names to 
18 characters

For information about this parameter, see Implementing 
Siebel Business Applications on DB2 UDB for z/OS.

Allow to create column of type 
‘Character’ being greater than 1

Removes constraint on columns of type CHAR, so that they 
can be greater than one character in length. Note that 
defining a column as CHAR when the data being stored can 
be variable in length causes the data to be padded with 
blank spaces in the database.
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Choosing a Target Browser
The target browser group determines how applets appear in the preview mode of the Applet Layout 
Editor. You can include conditional tags in Web templates that are displayed for some browsers but 
not others. Defining a target browser determines how the these conditional tags are expressed in 
the Applet Layout Editor and allows you to preview an applet layout as it would look in a specific 
browser.

To define the configuration context

1 Choose View > Toolbars > Configuration Context.

The Configuration Context toolbar appears.

2 From the Target Browser drop-down list, choose Target Browser Config.

The Target Browser Configuration dialog box appears. The following table describes the parts of 
the dialog box.

3 To add a browser group to the list of selected browsers, double-click the browser in the Available 
browsers list. 

You can also use the right and left arrow buttons to move browsers between the Available and 
Selected lists.

4 Click OK.

The browser groups you added to the list of Selected browsers for layout editing now appear as 
values in the Target Browser drop-down list.

Showing, Hiding, and Docking Windows
You can show windows, including the Object Explorer, from the View menu.

You can let the Object Explorer or Properties, Applets, Controls, Web Template Explorer, or 
Bookmarks windows float, moving and sizing to fit your needs, or dock the window in a corner of the 
main window.

The Siebel Tools version 8.0 user interface allows you to hide docked windows, including the Object 
Explorer, as tabs. They can be shown and rehidden, or docked again.

Field Description

Available browsers List of available browser groups.

Selected browsers 
for layout editing

Specifies which browser groups are affected by subsequent layout 
editing in the Web Layout Editor. 

Capability name and 
value

Specifies what capabilities or properties the currently selected virtual 
browser group has. 
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Topics in This Section
“Showing and Hiding the Object Explorer” on page 78

“Showing and Hiding Windows” on page 78

“Docking Windows” on page 79

“Hiding Docked Windows as Tabs” on page 79

“Stacking Dockable Windows” on page 81

Showing and Hiding the Object Explorer
You can show or hide the Object Explorer.

To show the Object Explorer
■ Choose View > Object Explorer. Alternatively, press CTRL+E.

If the Object Explorer was hidden, it appears.

To hide the Object Explorer
■ Click the Close button in the upper right corner of the Object Explorer.

■ You can also right-click inside the Object Explorer, and then choose Hide.

Showing and Hiding Windows
You show and hide windows using toggles on the View menu.

To show a window

1 Choose View > Windows.

A list of windows appears in a secondary pop-up menu.

2 Select the window you want to show.

If the window was hidden, it appears.

NOTE: To show the Bookmarks window, you can also use the Go menu (Go > Bookmarks List).

To hide a window using its Close button
■ Click the Close button in the upper right corner of the window.

The window no longer appears in the Siebel Tools application window.
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To hide a window using a right-click menu

1 Right-click inside the window you want to hide.

2 From the pop-up menu that appears, choose Hide.

The window no longer appears in the Siebel Tools application window.

Docking Windows
You can dock windows in a corner of the main window.

To dock a window
■ Drag the window to the area of the main window where you want to dock.

■ You can also double-click the window’s title bar. It will dock to the upper left of the Siebel Tools 
application window.

To undock a window
■ Right-click the window, and choose Docked.

■ You can also right-click its title bar, and then choose Floating.

To prevent a window from docking when it is being moved
■ Hold down the CTRL key during the move.

Hiding Docked Windows as Tabs
Docked windows, including the Object Explorer, can be shown as tabs. Tabbed windows can be 
opened and closed, or docked again.
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To hide a docked window as a tab
■ Click the Auto Hide button (pin icon) in the window’s title bar.

The window disappears, and a named tab appears in the corner of the Siebel Tools application 
window where the window had been docked.

■ You can also right-click the window’s title bar, and then choose Auto Hide.

To show a tabbed window
■ Mouse over the window’s tab.

The window appears. It will remain open while the mouse cursor is over the window or the tab. 
You can click objects in the window. When the cursor is moved away, the window closes.

■ To show a window and keep it open persistently, click its tab.

The window will stay open until you show another window by mousing over or clicking its tab.

To dock a tabbed window

1 Mouse over or click a window’s tab to open it.

When the window opens, the Auto Hide button appears as a sideways pin.
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2 Click the Auto Hide icon.

The window is now docked.

Stacking Dockable Windows
You can also stack dockable windows on top of each other when they are floating, as shown in 
Figure 16. Navigate among them by clicking the tabs at the bottom of the stack.

Figure 16. Stacked Windows
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To stack dockable windows

1 Drag a floating window onto another floating window until it displays an outline with a tab at the 
bottom.

2 Release the window.

The windows are stacked with tabs.

Showing and Hiding Editors

To show or hide an editor

1 Choose View > Editors.

A list of editors appears in a secondary pop-up menu. A visible editor is identified with a check 
mark. A hidden editor has no marker. 

2 Select the editor you want to show or hide.

If the editor was hidden, it appears. If the editor was visible, it is hidden.

Showing Visualization Views
You can use the Siebel Tools Visualization views to see how objects relate to one another. 
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To show a visualization view using the View menu

1 Choose View > Visualize.

A list of visualization views appears in a secondary pop-up menu. A visible view is identified with 
a check mark. A hidden view has no marker. 

2 Select the view you want to show or hide.

If the editor was hidden, it appears. If the editor was visible, it is hidden.

To show a visualization view from the Object List Editor

1 Display the relevant object type in the Object List Editor.

2 Right-click an object and choose the Visualization view you want. 

Not all Visualization views are listed for all objects.

Related Topics
“Viewing Object Relationships” on page 126

Showing and Hiding Debug Windows
You can show or hide the debug windows.

To show or hide the Calls window
■ Choose View > Debug Windows > Calls. Alternatively, press CTRL+L.

To show or hide the Watch window
■ Choose View > Debug Windows > Watch. Alternatively, press SHIFT+F9.

To show or hide the Errors window
■ Choose View > Debug Windows > Errors.

Showing and Hiding Toolbars
You show and hide toolbars using toggles on the View menu.

To show or hide a toolbar

1 Choose View > Toolbars. Alternatively, right-click any of the toolbars.

A list of toolbars appears in a secondary pop-up menu. A visible toolbar is identified with a check 
mark. A hidden toolbar has no marker. 
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2 Select the toolbar you want to show or hide.

If the toolbar was hidden, it appears. If the toolbar was visible, it is hidden.

Showing and Hiding the Status Bar

To show or hide the status bar
■ Choose View > Status Bar.

If the status bar was hidden, it appears. If the status bar was visible, it is hidden.
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4 Getting Projects from the Server 
Repository

This chapter describes how to get projects from the server repository. It contains the following 
topics:

■ “About the Get Process” on page 85

■ “Performing a Full Get” on page 85

■ “Getting Projects from the Server Repository” on page 86

■ “Getting Locale-Specific Data Only” on page 87

About the Get Process
The process of copying projects from the server database to your local database is known as 
performing a Get. The Get process differs from checking out in the following ways:

■ Getting projects does not lock them on the server database.

■ Getting projects overrides all the projects on your local database, whether they are locked or not 
locked.

NOTE: The sample database, unlike a local database, cannot receive projects from the server 
database during a Get. The sample database is intended for instructional use only.

Typically you perform a Get to initially populate your local database. This process is known as a Full 
Get. You can also get projects to override objects stored on your local database.

Related Topics
“Performing a Full Get” on page 85

“Getting Projects from the Server Repository” on page 86

“About the Check Out and Check In Process” on page 90

Performing a Full Get
For a newly initialized local database, you need to copy all objects from the server repository to your 
local repository by running a process called a Full Get. You must perform a Full Get before you 
compile, because the SRF file must be based on the comprehensive set of Siebel objects.

You use the Full Get option to synchronize the local database with the modifications done on the 
server.



Using Siebel Tools Version 8.0, Rev. A

Getting Projects from the Server Repository ■ Getting Projects from the Server 
Repository

86 

By default the Full Get process performs database commits in regular intervals, rather than a single 
commit at the end of the process. For information about changing this option, see “Setting Commit 
Options for Full Get” on page 69.

NOTE: To invoke the executable that performs a Get, the user must be the user who installed Tools 
on this local machine, or the ODBC driver that is used to perform the Get must be set to System 
DSN, instead of User DSN, on the operating system so that any user of the machine can perform the 
Get. 

To perform a full Get

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check Out.

3 Choose the name of your development repository from the Repository picklist.

NOTE: The repository that you select is not necessarily the one opened by Siebel Tools.

4 Select All Projects.

5 Click Options. 

6 In the Development Tools Options window, make sure your Server Data Source is pointing to your 
server development database and your Client Data Source is pointing to the local database you 
previously initialized and are currently running against. 

7 In the Check Out dialog box, click Get.

All objects from the server repository are copied to your local repository.

Getting Projects from the Server 
Repository
You can use the Get process to overwrite projects stored in your local repository with versions of the 
projects from the server repository. You may need to do this after you have changed local copies of 
projects and you want to revert back to the versions stored on the server, or after other developers 
check in changes and you need to copy those changes to your local repository.

To overwrite projects stored in your local database

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check Out.

3 Choose the name of your development repository from the Repository picklist.

NOTE: The repository that you select is not necessarily the one opened by Siebel Tools.

4 In the Projects list, select the projects you want to get.

5 Click Options. 
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6 In the Development Tools Options window, make sure your Server Data Source is pointing to your 
server development database and your Client Data Source is pointing to the local database you 
previously initialized and are currently running against. 

7 In the Check Out dialog box, click Get.

All objects associated with the projects are copied from the server repository to your local 
repository.

Related Topics
“About the Get Process” on page 85

Getting Locale-Specific Data Only
After you have performed a Full Get, you can get locale-specific data without having to get parent 
objects too. This is useful when you have been working in one language and then switch to another 
language. For example, suppose you have already populated your local repository with English (ENU) 
data, but now you want to switch to Japanese (JPN). After switching your language mode to JPN, you 
can use the Get Locale-Specific Data option to copy JPN records only from the server repository to 
your local repository.

To get locale-specific data only for projects

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check Out.

3 Choose the name of your development repository from the Repository picklist.

NOTE: The repository that you select is not necessarily the one opened by Siebel Tools.

4 Select the Projects for which you want to get locale-specific data.

5 Click Options. 

6 Make sure your Server Data Source is pointing to your server development database and your 
Client Data Source is pointing to the local database you previously initialized and are currently 
running against. 

7 Click OK to close the Development Tools Options dialog box.

8 In the Check Out dialog box, select the Get Locale Specific Data Only check box.

9 Click Get.

Data stored in child locale objects of the selected projects are copied from the server repository 
to your local repository.
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5 Checking Out and Checking In 
Projects and Objects

This chapter describes how to check out and check in projects and objects. It contains the following 
topics:

■ “About the Check Out and Check In Process” on page 90

■ “Setting Options for Check Out and Check In” on page 90

■ “Guidelines for Check Out and Check In” on page 90

■ “About the Project Check Out Dialog Box” on page 91

■ “About the Object Check Out Dialog Box” on page 94

■ “About the Check In Dialog Box” on page 96

■ “Checking Out and Checking In Projects” on page 98

■ “Checking Out Projects from the Server Repository” on page 98

■ “Checking In Projects to the Server Repository” on page 99

■ “Checking Out and Checking In Objects” on page 99

■ “About Object Check Out and Check In” on page 100

■ “Enabling Object Check Out and Check In” on page 100

■ “Setting Projects to Allow Object Locking” on page 100

■ “Checking Out Objects from the Server Repository” on page 101

■ “Checking In Objects to the Server Repository” on page 102

■ “Locking Objects Locally” on page 103

■ “Limitations of Object Check Out and Check In” on page 103

■ “Viewing Object Differences” on page 103

■ “Undoing Check Out” on page 103
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About the Check Out and Check In 
Process
Check Out and Check In is a source control mechanism for multiple developers working in the same 
repository. It allows you to check out objects from the server and download them to your local 
repository for editing. When you check out objects, they are locked on the server. This prevents other 
developers from checking them out and avoids conflicts that could result from multiple developers 
working on the same objects simultaneously. When you check objects back to the server, the lock is 
removed, and the objects are available for other developers to check out. 

NOTE: You can lock objects directly on your local repository, without checking them out, but changes 
you implement cannot be checked in. See “Locking Projects Directly in the Local Repository” on 
page 107.

Setting Options for Check Out and Check 
In
You use the Development Tools Options dialog box to define options related to the check in and check 
out processes. See the following topics for details about check in and check out options:

■ “Process for Integrating with Third-Party Source Control” on page 63

■ “Specifying Data Sources” on page 67

■ “Restarting Editors After Check Out” on page 69

■ “Setting Commit Options for Full Get” on page 69

Guidelines for Check Out and Check In
Before checking out or checking in projects or objects, consider the following:

■ Password encryption interferes with check out. If you are checking out projects, you need to 
disable password encryption in the client or CFG file when running Siebel Tools.

■ You check out projects and objects in the current Siebel Tools language mode only. For more 
information, see “Selecting a Language Mode” on page 61.

■ The sample database, unlike a local database, cannot receive checked-out objects, and its 
objects cannot be checked in to the server database. The sample database is strictly for 
instructional use.

■ Objects must be checked out and checked in to the server database from which the local 
database was extracted.

■ Before doing a check-in, make sure that the projects and objects you are checking in are in a 
stable state, that all dependent scripting is complete, and the configuration has been tested 
against your local repository.
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■ Check in all dependent projects and objects at the same time to be sure that the configuration 
on the server remains consistent. 

For example, if you create a new Pick List object in the Pick List project and reference that object 
in your Oppty project, check in both projects to the server at the same time.

■ Consider the timing of your check-in and its effect on the work of other developers.

CAUTION: Depending on the size of the project, the check-in process might require some time. Do 
not interrupt the process, because doing so can leave your repository in an unstable state. If for any 
reason the check-in process is interrupted, you must perform it again to complete any unfinished 
tasks and unlock the projects on the server.

About the Project Check Out Dialog Box
The Check Out dialog box lists projects available for check out. It does not list individual objects 
within projects. Figure 17 shows an example of the Project Check Out dialog box. 

Figure 17. Check Out Dialog Box
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Table 25 describes each user interface element of the dialog box.

Table 25. Project Check Out Dialog Box User Interface Elements

Element Description

Repository drop-down list Displays the repositories on the server. The list of projects in 
the projects list reflects the list of projects in the selected 
server repository. If you select a different server repository 
from the one currently open in Siebel Tools locally, a warning 
appears, and you must either get all projects or change the 
repository selection.

Projects list Project Displays the name of each project in the server repository.

Updated A value of Yes appears if the server Locked By and Locked 
Date are different from the client version, indicating that your 
version of the project is out of sync with the server’s version.

Server Locked By Logon ID of the developer who currently has this project 
checked out on the server.

Server Locked 
Date

Date of check out.

Client Locked By Logon ID of the developer who currently has this project 
locked locally.

Client Language The language of the project currently locked on the client. 
Only one language can be locked at one time.

Allow Object 
Locking

A value of Yes appears if the project allows object check-in/
out. The default value is Yes. If you want to restrict object 
check out, see “Enabling Object Check Out and Check In” on 
page 100.

Owner Branch Displays the owner branch for each project. If the project's 
Owner Branch is not blank, the user's assigned Repository 
Branch must match in order to check out the project or any 
of its objects.

This column is hidden in the Object List Editor by default, but 
you can display it by right-clicking the Columns Displayed 
menu option. 



Checking Out and Checking In Projects and Objects ■ About the Project Check Out
Dialog Box

Using Siebel Tools Version 8.0, Rev. A 93

Option 
buttons

Selected projects When this option button is selected, you can select individual 
projects to check out or get.

All projects When this option button is checked, all projects in the 
repository are selected to check out or get.

Updated projects When this option button is active, only projects with an 
Updated value of Yes are selected. This allows you to check 
out or get only those projects on the server that are new or 
different from corresponding projects in the local repository. 
Normally you perform a Get to bring your local repository up 
to date.

Get locale specific data only check 
box

Checking this box gets string translations and locale-specific 
attributes being stored in the locale objects only. It does not 
get data stored in the locale object’s parent object.

Buttons Get Selected projects are copied to the local repository, replacing 
pre-existing versions there, but not locking them on the 
server. You can get any projects on the server, including those 
locked by others.

Check Out Copies all objects in the selected projects to the local 
repository and locks them on the server (and client). 

You cannot check out projects that are currently locked on the 
server by another user. 

Options Opens the Development Tools Options dialog box with the 
Check In/Out tab selected. This is the same dialog box that 
appears when you choose Tools > Options. 

Cancel Cancels the check out and closes the Check Out dialog box.

Table 25. Project Check Out Dialog Box User Interface Elements

Element Description
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About the Object Check Out Dialog Box
The Object Check Out Dialog Box allows you to check out individual objects from the server database. 
Figure 18 shows an example of the Object Check Out dialog box.

Table 26 describes the user interface elements of the Object Check Out Dialog Box.

Figure 18. Object Check Out Dialog Box

Table 26. Object Check Out Dialog Box User Interface Elements

Element Description

Repository Text Box Displays the name of the current repository the user is 
working on.
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Object List Type Displays the type of each new or checked out object in the 
local repository. Objects obtained by the get process are not 
listed, because these are not available for check in. (You can 
check in only projects that you have previously checked out 
or created locally.)

Name Displays the name of each object being checked out.

Updated A value of Yes appears if the server Locked By and Locked 
Date are different from the client version, indicating that your 
version of the object is out of sync with the server's version.

Object Locking A value of Yes appears if this object's parent project allows 
object check-in/out. 

Server Locked By Logon ID of the developer who currently has this object 
checked out on the server.

Server Language The language on which the object is checked out on the 
server. Only one language can be checked out at one time.

Server Locked 
Date

Date of check out.

Client Locked By Logon ID of the developer who currently has this object 
locked locally.

Client Language The language of the object currently locked on the client. 
Only one language can be locked at one time.

Project Locked By Logon ID of the developer who currently has this object's 
parent project checked out on the server.

“Get locale specific data only” 
checkbox

Checking this box gets string translations and locale-specific 
attributes being stored in the locale objects only for the 
objects selected. It does not get data stored in the locale 
object's parent object.

Table 26. Object Check Out Dialog Box User Interface Elements

Element Description
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About the Check In Dialog Box
The Check In dialog box allows you to select projects or objects to check in to the server database. 
Figure 19 shows an example of the Check In dialog box. 

Buttons Get Selected objects are copied to the local repository, replacing 
pre-existing versions there, but not locking them on the 
server. You can get any objects on the server, including those 
locked by others regardless of whether their parent projects 
have the Allow Object Locking field checked.

Check Out Copies all selected objects in the selected objects to the local 
repository and locks them on the server and client.

You cannot check out objects that are currently locked on the 
server by another user, because either their parent projects 
do not allow object locking or their parent projects are locked 
on the server.

Options Opens the Development Tools Options dialog box with the 
Check In/Out tab selected. This is the same dialog box that 
appears when you choose Tools > Options.

Cancel Cancels the check out, and closes the Object Check Out 
dialog box.

Figure 19. Check In Dialog Box

Table 26. Object Check Out Dialog Box User Interface Elements

Element Description
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Table 27 describes each user interface element of the dialog box.

Table 27. Check In Dialog Box User Interface Elements

Element Description

Repository drop-down list Lists repositories in the local database. The list of projects in 
the Projects list reflects the list of projects in the selected 
repository (in addition to locally created projects). 

Projects list Type Displays the type of each new or checked out project or object 
in the local repository. Projects or objects obtained by the get 
process are not listed, because these are not available for 
check in. (You can check in only projects that you have 
previously checked out or created locally.)

Name Name of the checked out object.

Status Contains the value New or Locked for each project, or object 
indicating whether you created it yourself or obtained it 
through check-out.

Lock/Creation 
Date

Displays the date and time when you created the project or 
object, or checked the project or object out from the server.

Language Displays the language in which the project or object was 
checked out.

Option 
buttons

Selected Objects When this option button is checked, you can manually select 
individual projects or objects to check in.

Locked/New 
Objects

Selects all of the projects or objects in the list—that is, all 
those you have created or obtained through check-out.

Maintain lock check box Does not remove object locks on the server or the local 
databases after check in.

Buttons Undo Check Out Does not check in objects to the server. This releases the lock 
on the server, so that another developer can work on those 
objects, but retains the locks on the local database.

Validate Validates selected projects.

Check In Initiates the check-in process.

Diff Opens the Project Differences dialog box that allows you to 
compare the objects you are checking in with the server 
versions of those objects. For more information, see “About 
Validating Objects” on page 116.

Options Opens the Developer Tools Options dialog box where you 
specify check-in/check-out settings, especially server and 
client data source names.

Cancel Closes the Check In dialog box.
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Checking Out and Checking In Projects
This topic contains the following tasks:

■ “Checking Out Projects from the Server Repository” on page 98

■ “Checking In Projects to the Server Repository” on page 99

For information on checking out individual objects, see “About the Object Check Out Dialog Box” on 
page 94.

Checking Out Projects from the Server 
Repository
When you check out projects from the server repository, the following occurs:

■ All objects associated with the projects are locked on the server, preventing other developers 
from checking them out.

■ All objects associated with the projects are copied from the server database to your local 
database.

■ All objects associated with the projects are locked on your local database, allowing you to edit 
them. 

NOTE: If the Allow Object Locking property is set to TRUE, you cannot check out a project from the 
server. You must disable object locking to check out a project from the server.

To check out projects from the server repository

1 Choose Tools > Check Out.

2 In the Check Out dialog box, make sure that the correct repository is selected. 

3 Select the projects you want to check out, then click Options.

4 In the Development Tools Options dialog box, make sure the Server and Client data sources are 
specified correctly. 

5 Click OK.

The Development Tools Options dialog box closes.

6 In the Check Out dialog box, click Check Out.

Objects are checked out of the server database and stored in your local database.

Related Topics
“Guidelines for Check Out and Check In” on page 90

“About the Project Check Out Dialog Box” on page 91

“Setting Options for Check Out and Check In” on page 90
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Checking In Projects to the Server 
Repository
When you check in projects, the following actions occur:

■ Projects and their associated objects are copied from your local repository to the server 
repository, replacing those on the server.

■ Any new objects are added to the server repository.

■ Locks on the projects and all associated objects are removed.

To check in projects to the server repository

1 Choose Tools > Check In.

2 In the Check In dialog box, make sure that the correct repository is selected.

3 Click Options. 

4 In the Development Tools Options dialog box, make sure the server and client Data Sources are 
are correct and then click OK.

5 Do one of the following:

■ To check in selected projects, click the Selected Objects option, and then select the projects 
that you want to check in.

■ To check in all locked projects (new and modified), click the Locked/New Objects option.

6 Click Check In.

The selected projects and associated objects are copied from your local repository to the server 
repository and locks are removed.

Related Topics
“Guidelines for Check Out and Check In” on page 90

“About the Check In Dialog Box” on page 96

“Setting Options for Check Out and Check In” on page 90

Checking Out and Checking In Objects
This topic contains the following tasks:

■ “About Object Check Out and Check In” on page 100

■ “Enabling Object Check Out and Check In” on page 100

■ “Setting Projects to Allow Object Locking” on page 100

■ “Checking Out Objects from the Server Repository” on page 101

■ “Checking In Objects to the Server Repository” on page 102
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■ “Viewing Locked Objects Within Projects” on page 102

■ “Locking Objects Locally” on page 103

■ “Limitations of Object Check Out and Check In” on page 103

About Object Check Out and Check In
With object check out and check in, you can check out and check in only the objects that you need; 
that is, you do not have to check out and check in entire projects.

NOTE: If the Allow Object Locking property is set to TRUE, you cannot check out a project from the 
server. You must set the Allow Object Locking property to FALSE to check out an entire project from 
the server.

Checking out and checking in selected objects:

■ Allows multiple developers to work on objects within a single project

■ Improves check-out and check-in times

■ Reduces network traffic

Enabling Object Check Out and Check In
A configuration file parameter controls whether or not object check out and check in is enabled. To 
enable object check out and check in, add the following parameter to the [Siebel] section of the 
tools.cfg file, and set it to TRUE:

EnableObjectCOCI = TRUE

NOTE: EnableObjectCOCI is set to TRUE by default.

Setting Projects to Allow Object Locking
For each project you can specify whether or not developers are allowed to check out and check in 
individual objects within the project. To allow developers to check out and check in objects, you set 
the project's Allow Object Locking property to TRUE. To modify the Allow Object Locking property, 
you must use the SADMIN user ID to log in, and you must be logged into a server data source. You 
cannot set the Allow Object Locking property in your local repository.

To set the Allow Object Locking property

1 In the Object Explorer, choose Project.
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2 In the Projects window, choose the desired Project object, then right-click and choose Toggle 
Allow Object Locking. 

NOTE: You can only change the Allow Object Locking flag on the Server database using the 
SADMIN login ID.

If a project has the Allow Object Locking configuration file parameter set to TRUE, and the user 
is logged in to the server using the SADMIN user ID, the Toggle Allow Object Locking menu option 
is enabled. When the SADMIN user chooses this option for a project that is already set to allow 
object locking, a check is performed to determine whether any objects are locked on the server 
within the project. If there are objects locked within the project, SADMIN will receive an error 
message. If the project is locked on the server by someone else, the menu option for Toggle Allow 
Object Locking will not appear. 

Checking Out Objects from the Server 
Repository
When the Allow Object Locking property is set to TRUE, you can check out individual objects within 
the project. When you check out individual objects, the objects are:

■ Locked on the server, preventing other developers from checking them out

■ Copied from the server database to your local database

■ Locked on your local database, allowing you to edit them

NOTE: You can check out top-level objects only. 

To check out objects from the server repository

1 Open Siebel Tools, and connect to your local database.

2 In the Object Explorer, navigate to the object type you want to check out.

3 In the Object List Editor, select the object definition, and then right-click and choose Check Out. 

The Check Out Object dialog box appears. 

NOTE: If another developer has the objects checked out or if the parent project has the Allow 
Object Locking property set to FALSE, the Check Out button is disabled. 

4 In the Check Out Object dialog box, select the objects to check out.

5 Click Check Out. 

The object and all its child objects are locked on the server and then copied to your local 
repository.
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Checking In Objects to the Server 
Repository
You check in objects to the server repository the same way you check in projects. When you check 
in objects or projects, Siebel Tools does the following:

■ Copies object definitions from your local repository to the server repository

■ Adds any new objects to the server repository

■ Removes the locks from object definitions

To check in projects or individual objects to the server repository

1 Open Siebel Tools and connect to your local database.

2 Choose Tools > Check In.

3 In the Check In dialog box, make sure that the correct repository is selected.

4 Do one of the following:

■ To check in selected projects or objects, click the Selected Objects option button and then 
select the projects and objects you want to check in.

■ To check in all locked projects and objects, click the Locked/New Objects option button.

5 Click Check In.

Siebel Tools copies the projects and objects from your local repository to the server repository 
and removes the locks.

Viewing Locked Objects Within Projects
When the Allow Object Locking property of a project is set to TRUE, you can view any objects within 
the project that are locked. You can view locked objects in either the server repository or the local 
repository. 

To view locked objects

1 In the Object Explorer, navigate to the Project object type.

2 In the Object List Editor, select the project that contains the objects to view.

3 Right-click and choose one of the following:

■ View Server Locked Objects

■ View Client Locked Objects

The Locked Objects dialog box displays any locked objects associated with the selected project.
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Locking Objects Locally
When a project's Allow Object Locking property is set to TRUE, you can lock individual objects within 
the project in your local repository without having to check them out from the server.

To lock objects locally
■ Select the object, right-click, and then choose Lock Object.

Limitations of Object Check Out and 
Check In
When a project’s Allows Object Locking property is set to TRUE, you cannot perform the following 
tasks on objects checked out from the server repository:

■ Deleting objects

■ Renaming objects

■ Assigning objects to a different project

Viewing Object Differences
Before you check in objects, you can compare the copies stored in your local database to those stored 
in the server database. Siebel Tools compares the current state of the objects with the version of 
these objects at the time of checkout.

To view differences between objects

1 Choose Tools > Check In.

2 In the Check In dialog box, select the project you want to compare.

3 Click Diff.

The Object Comparison dialog box appears and displays the selected projects and any differences 
between objects in the local database and objects in the server database.

Undoing Check Out
After checking out projects you can undo the check out, which does the following:

■ Removes locks on server objects.

■ Objects in the local repository remain locked, and all changes since the objects were checked out 
are retained.



Using Siebel Tools Version 8.0, Rev. A

Checking Out and Checking In Projects and Objects ■ Undoing Check Out

104 

To undo a project check out

1 Choose Tools > Check In.

2 In the Check In dialog box, select the project or objects for which you want to undo check-out, 
and click the Undo Check Out button.

The project or object is unlocked on the server, but not on your local database.

If one of the projects or objects you select is new, the Undo Check Out button is disabled.

You can also use the Get option to: 

■ Overwrite a project that you have checked out from the server database. 

■ Check that project back in to the server to remove the lock for the project.

■ Enable expected projects for Object Check-in/Check-out.

Related Topic
“Getting Projects from the Server Repository” on page 86
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6 Working with Projects

This chapter describes how to work with projects. It contains the following topics:

■ “About Projects” on page 105

■ “Creating New Projects” on page 106

■ “Renaming Projects” on page 106

■ “Associating Objects with Different Projects” on page 107

■ “Locking Projects Directly in the Local Repository” on page 107

■ “Preventing Object Check In and Check Out” on page 108

■ “Unlocking Projects Directly” on page 108

About Projects
Projects are sets of objects that reside in the Siebel repository. They are used group objects based 
on functional areas. Every object is associated with a project. The names of projects that are 
delivered with a standard Siebel application indicate the functional area with which they are 
associated. For example, Account contains objects that pertain to the Account functional area.

A project named without a suffix, such as Account, usually contains business object layer objects 
that span multiple Siebel applications. Project names that have a suffix (for example, Account (SSE)) 
contain user interface or business objects that are specific to the Siebel application indicated by the 
suffix. For example, the suffix SSE in Account (SSE) indicates an entry containing Account user 
interface data for Oracle’s Siebel Sales application. Other examples of suffixes indicating user 
interface data only are SSV for Oracle’s Siebel Service and CC for Oracle’s Siebel Call Center.

The project structure supplied with the Siebel repository is usually well suited to having several 
developers work on the same repository without contention for the same objects. However, when 
developers need access to the same set of objects simultaneously, changing the standard project 
structure may be necessary.

■ Create an application development plan that includes a PERT chart showing dependencies and 
parallel activities.

■ Analyze the plan to see if the project structure interferes with developers who need access to 
objects in the same projects at the same time. If so, break out groups of objects into separate 
projects to enable concurrent development. Alternatively, for projects that are expected to be in 
contention, enable those projects for Object Check-in/Check-out.
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Creating New Projects
You typically create new projects to group related sets of new objects or to break large numbers of 
existing objects into more manageable groups.

If you intend to implement a new project on the server repository, follow this development process:

■ First create the new project on the development server repository. 

■ Perform a Get of the project to the local repository.

■ Check out the project.

■ Modify the new project on the local repository.

■ Check in the project to update the server repository. 

To create a new project

1 In the Object Explorer, select the Project object type.

2 In the Object List Editor, right-click and choose New Record.

3 Enter a Name for the project and then step off the record.

For information on performing a Get, see Chapter 4, “Getting Projects from the Server Repository.”

For information on project check in and check out, see Chapter 5, “Checking Out and Checking In 
Projects and Objects.”

NOTE: You cannot delete projects using Siebel Tools, but you can delete projects using SQL 
commands.

Renaming Projects
You can rename projects that you have created. However, you must rename the projects on the 
server, not on the local database. You cannot change the name of a top-level object that has been 
checked out.

CAUTION: Do not change the name of projects to which Siebel objects are associated.

To rename a project on the server

1 Make sure developers have checked in all checked-out projects.

2 Use Siebel Tools to log into the server database.

3 Choose File > Open Repository, and then select the repository you want to modify.

4 Navigate to the project you want to modify.

5 Lock the project, and then change the Name property.

6 Have developers perform a Get of all projects on the server repository.

7 Have developers perform a full compilation the next time they compile.
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Associating Objects with Different 
Projects
You can associate objects with different projects. This can be useful, for example, when you want to 
break a large project into smaller projects.

To associate an object with a different project

1 Check out both the source and the target project from the server database.

For instructions on how to check out projects, see “Checking Out and Checking In Projects” on 
page 98.

2 Navigate to the object you want to modify and then change the Project property to the name of 
the new project.

For instructions on how to modify objects, see “Modifying Objects” on page 114.

3 Check in the project that was originally associated with the object and then check in the project 
that is currently associated with the object.

CAUTION: Trying to check in both projects at the same time can lead to errors.

For instructions on how to check in projects, see “Checking In Projects to the Server Repository” 
on page 99.

4 Inform other developers that they must do a simultaneous get of the two projects prior to doing 
any subsequent work on the object in either project.

Locking Projects Directly in the Local 
Repository
You can lock projects directly in the local repository, without checking them out from the server. This 
is useful when:

■ You want to test configurations on your local machine, but do not want to prevent others from 
checking out the project from the server database.

■ You intend to discard your work when you are done and therefore, do not have a need to check 
modified objects back into the server.

When locking projects directly in the local repository, consider the following:

■ You cannot check in projects or objects that have been locked on the local database. Projects 
must have been checked out from the server for them to be checked in to the server.

■ Any projects you have locked locally, and all associated objects, will be overwritten the next time 
you get or check out those projects. 
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To lock projects directly

1 Log in to your local database.

2 Do one of the following:

■ Select an object, such as an applet or business component, and then choose Tools > Lock 
Project.

■ Navigate to the project that contains the objects that you want to modify, and click the 
Locked field to set it to TRUE.

All objects associated with the project become available for editing, indicated by a pencil icon 
that appears under the W field, and the Locked property of the project object is set to TRUE.

Preventing Object Check In and Check 
Out
You can prevent developers from checking out and checking in projects by locking the project directly 
on the server repository.

CAUTION: Modifying objects directly on the server repository for purposes other than preventing 
check in and check out is not recommended.

To lock projects directly

1 Log in to the server database.

2 Do one of the following:

■ Select an object, such as an applet or business component, and then choose Tools > Lock 
Project.

■ Navigate to the project that contains the objects that you want to modify, and click the 
Locked field to set it to TRUE.

The project and all objects associated with project are locked. They cannot be checked out.

Unlocking Projects Directly
After you have locked projects directly (without checking them out), you can remove the locks on all 
associated objects by unlocking the projects.

To unlock projects

1 Log in to either the local database or server database, depending on where the locked objects 
reside.
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2 Do one of the following:

■ Select the object you want to unlock, and then choose Tools > Unlock Project.

■ Navigate to the project that contains the objects that you want unlock, and then click the 
Locked field to clear the check mark (sets Locked to FALSE).

The locks are removed from the project and all objects associated with the project.
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7 Working with Objects

This chapter describes how to work with objects. It contains the following topics:

■ “Summary of Tasks for Working with Objects” on page 111

■ “Creating Objects” on page 113

■ “Modifying Objects” on page 114

■ “Copying Objects” on page 115

■ “Deleting Objects” on page 115

■ “About Validating Objects” on page 116

■ “Validating Objects Using the Object List Editor” on page 116

■ “Validating Objects Using the Command-Line Interface” on page 117

■ “About the Validate Dialog Box” on page 117

■ “About the Validation Options Dialog Box” on page 119

■ “Using Queries to List Objects” on page 122

■ “About Simple Queries” on page 123

■ “About Compound Queries” on page 123

■ “Searching the Repository for Objects” on page 124

■ “Viewing Object Relationships” on page 126

■ “About Object Comparison and Synchronization” on page 127

■ “Determining When Records Were Last Created and Updated” on page 131

Summary of Tasks for Working with 
Objects
The process of working with objects varies depending on whether the Allow Object Locking property 
of the parent project is set to TRUE or FALSE. When the property is set to FALSE, you must check 
out the entire project to edit any object definitions within the project. However, if the Allow Object 
Locking property is set to TRUE, you can check out some of the objects in a project, and leave other 
objects unlocked on the server, which are available for other developers to check out. For more 
information on setting this property, see “Setting Projects to Allow Object Locking” on page 100.

Table 28 summarizes the differences for processes, such as create, copy, and modify.
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Links to Tasks for Working with Objects

Table 28. Summary of Processes for Working with Objects

Task Allow Object Locking = False Allow Object Locking = True

Create 
object

1. Check out the project.

2. Create the new object.

3. Check in the project.

1. Lock the project locally.

2. Create the new object.

3. Unlock the project.

4. Check in the object.

Modify 
object

1. Check out the project.

2. Modify the object.

3. Check in the project.

1. Check out the object.

2. Modify the object.

3. Check in the object.

Create new 
object by 
copying an 
existing one

1. Check out projects.

2. Copy the object, and create a new 
one.

3. Check in projects.

1. Check out the object to copy.

2. Lock the object’s parent project locally.

3. Copy the object and assign the project.

This refers to the same project locked in 
step 2, or to a different project that has 
the Allow Object Locking property set to 
TRUE. 

4. Unlock the project locally.

5. Lock the new object locally.

6. Check in the object to the server 
repository.

Delete 
object

1. Check out project.

2. Delete object.

3. Check in project.

Cannot perform. The Allow Object Locking 
property must be set to FALSE.

Rename 
object

1. Check out the project.

2. Rename the object.

3. Check in the project.

Cannot perform. The Allow Object Locking 
property must be set to FALSE.

Assign 
object to 
different 
project

1. Check out Project (source and 
target).

2. Associate object with target project.

3. Check in source first, and target 
second.

Cannot perform. The Allow Object Locking 
property must be set to FALSE.
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The following list links to the summarized tasks listed in Table 28:

■ “Checking Out and Checking In Projects” on page 98

■ “Checking Out and Checking In Objects” on page 99

■ “Locking Projects Directly in the Local Repository” on page 107

■ “Creating Objects” on page 113

■ “Modifying Objects” on page 114

■ “Copying Objects” on page 115

■ Chapter 10, “Compiling and Testing”

■ If you checked out the projects from the server, perform the task described in “Checking In 
Projects to the Server Repository” on page 99.

■ If you locked the project directly, perform the task described in “Unlocking Projects Directly” on 
page 108.

Creating Objects
Use new object wizards to create objects whenever possible. For example, to create a new business 
component, use the Business Component Wizard. 

Wizards step you through the process of configuring a given object, prompting you for the necessary 
property values and automatically configuring any necessary child objects.

When a wizard is not available for the object type you want to create, you can create objects 
manually in the Object List Editor.

For information about using wizards and creating specific objects, see Configuring Siebel Business 
Applications.

To create objects using a new object wizard

1 Choose File > New Object.

2 Choose the appropriate wizard to create the new object.

3 Follow the instructions in the wizard.

To create a new object manually

1 In the Object Explorer, select the relevant object type.

The Object List Editor opens, listing objects of this object type.

2 To make the Object list Editor active, click it. 

3 Choose Edit > New Record, or right-click and choose New Record.

A new record appears.
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4 Enter property values in the new row in the Object List Editor.

At a minimum, you must enter the object’s Name and Project properties.
Typically, other properties are also required. Before you can save the new objects, you must 
complete the required properties.

NOTE: You cannot use punctuation characters as part of an object name.

5 Click anywhere outside the new row or move outside of the row with the UP or DOWN arrow keys.

Siebel Tools saves the new object.

Modifying Objects
You can modify objects using either the Object List Editor or the Properties window.

For guidelines about when to modify objects and when to create new objects, see Configuring Siebel 
Business Applications.

NOTE: If you rename an object, you will get an error message saying:

“Changing the name of a checked out or locked object causes "unique constraint" error during check-
in. To avoid this error, change the name of the object back to the original name. Do you want to 
continue?”

We recommend copying the object instead, and then renaming the copy. For more information, see 
“Copying Objects” on page 115.

To modify objects in the Object List Editor

1 In the Object Explorer, select the object type you want to modify.

2 In the Object List Editor, select the object you want to modify.

3 Use the TAB key to move the cursor to the specific value you want to modify.

NOTE: We recommend that you use the TAB key to move from property column to property 
column in the object—if you use the mouse you might unintentionally change the value of a 
Boolean property.

4 Type in a new value, or pick a value from the picklist (if one is provided).

5 To commit your changes, click anywhere outside the modified row or move outside the row with 
the UP or DOWN arrow.

A check mark appears in the Changed column.

To modify objects using the Properties window

1 In the Object Explorer, select the object type you want to modify.

2 In the Object List Editor, select the object you want to modify.

3 Choose View > Windows > Properties to open the Properties window.
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4 In the Properties window, select the current value, and then type in a new one.

5 To commit your changes, select another property or click anywhere outside the Properties 
window.

A check mark appears in the Changed column in the Object List Editor.

Copying Objects
One method of creating an object is to copy an existing object, and then rename and change 
properties of the copy as necessary.

For guidelines on copying objects and more information on the Upgrade Ancestor property, see 
Configuring Siebel Business Applications.

To create new objects by copying existing objects

1 In the Object Explorer, select the relevant object type.

2 In the Object List Editor, locate the object to copy, and click anywhere in the row to select it.

3 Choose Edit > Copy Record. 

A new row appears above the copied row, containing identical property values. The Changed 
column contains a check mark.

4 Enter a new value for the Name property.

5 In the Project field, click the drop-down arrow. 

The Projects picklist appears.

6 Choose the name of the project to which to assign the new object.

NOTE: Only locked projects are displayed in the Projects picklist.

7 If necessary, modify any other relevant properties and child objects.

8 To commit your changes, click anywhere outside the new row or move outside the row with the 
UP or DOWN arrow keys.

Deleting Objects
Occasionally, you will want to delete an object from a project. To delete an object, you must have 
the Allow Object Locking property set to FALSE.

CAUTION: We strongly recommend that users not delete objects, but instead make them inactive. 
Objects might be used in multiple places in the application, especially standard Siebel objects, so it 
is best to inactivate an object and then test the application.

NOTE: When you delete an object, the deletion does not cascade. For example, deleting a view will 
not delete its associated applets.
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To delete objects

1 Check out the Project from the server.

2 In the Object Explorer, select the desired object.

3 From the Edit menu, select Delete Record. 

About Validating Objects
As you modify or create objects, you must also validate their definitions. Validating objects is one of 
the first things you must do if a configuration change produces a run-time error. Although the 
validation process can be time consuming, you can continue working in Siebel Tools while the 
validation is running.

Validation is based on a set of rules that help make sure that your configuration changes are logically 
consistent with other objects. Validating a parent object validates child objects as well. 

There are many rules used to validate objects. The rule that checks for invalid object references is 
the most important. An invalid object reference occurs when one object (for example, an applet) 
references another object (for example, a business component) that has been inactivated or deleted. 
You can review all validation rules in the Validation Options dialog box.

Related Topics
“Validating Objects Using the Object List Editor” on page 116

“Validating Objects Using the Command-Line Interface” on page 117

“About the Validate Dialog Box” on page 117

“About the Validation Options Dialog Box” on page 119

Validating Objects Using the Object List 
Editor
Siebel Tools includes an option that reviews objects and validates them using a set of predefined 
rules, such as checking for invalid object references.

To validate an object

1 In the Object List Editor, select the object or objects you want to validate.

2 Right-click and then choose Validate, or choose Tools > Validate Object.

The Validate dialog box appears. 

3 Click Options.

The Validation Options dialog box appears. 

4 Select the validation rules to enforce by selecting a row and clicking Enforce or Ignore.
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5 In the Time Filter area, limit the objects you want to validate by selecting one of the following 
check boxes:

■ Last validated. This option validates objects that have been changed since the last time 
validation was run.

■ Custom. Enter a date and time. This option validates objects that have been changed since 
the date and time were entered.

6 In the Action area, use the following check boxes to define the actions to take during the 
validation process:

■ Do not report warnings. When this is selected, only errors are reported, not warnings. The 
Enforce field for warnings is set to No. 

■ Abort validation after. Use this option to abort the validation process after a specified 
number of errors.

7 Click OK.

The Validation Options dialog closes.

8 In the Validate dialog box, click Start.

The Errors list displays violations of the currently enforced rules, as shown in Figure 20 on 
page 118. 

Related Topic
“About Validating Objects” on page 116

“About the Validate Dialog Box” on page 117

“About the Validation Options Dialog Box” on page 119

Validating Objects Using the Command-
Line Interface
You can use the command-line interface to validate objects. You invoke the command-line interface 
from the siebdev executable, using the command switch /bv. The executable file siebdev.exe is 
located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation directory.

The syntax of the /bv switch is:

siebdev.exe /bv

The /bv switch runs all validation rules for the entire repository.

About the Validate Dialog Box
The Validate dialog box describes the results of validation rules applied to objects and shows the 
location of the validation log file.
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Figure 20 shows an example of the Validate dialog box. 

Table 29 describes the Errors area of the Validate dialog box.

Figure 20. Validate Dialog Box

Table 29. User Interface Elements of the Errors Area of the Validate Dialog Box

Field/
Button Description

Errors list Displays the results of the validation process. Each row in the list identifies a rule 
violation for a specific object. To drill down on the object that contains the error, 
double click the error. To sort the rows, click a column heading. To resize columns, 
drag the right or left border of the heading cell. 

Severity 
column

An icon appears in this column for each violation row. It indicates whether the 
violation is a warning (yellow icon with an exclamation mark) or an error (red icon 
with a minus sign). Errors cause the compiled application to generate run-time 
errors.

Rule column An integer value appears in this column, identifying the rule that has been violated. 
Rules are listed in order of the rule number in the Validation Options dialog box 
(shown in Figure 20 on page 118).

Object 
column

The name of the object that failed validation.
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Table 30 describes the Log file area of the Validate dialog box.

About the Validation Options Dialog Box
The Validation Options Dialog box appears when you click the Options button in the Validate dialog 
box.

Description 
column

The description of the error or warning.

Details text 
box

Displays additional information about the error or warning message for the 
currently selected row in the Errors list.

Go To button To navigate to the corresponding object in the Object List Editor, select an error 
message row and click Go To. Alternatively, you can double-click the error 
message.

Table 30. User Interface Elements of the Log file Area of the Validate Dialog Box

Field/
Button Description

Text box Path and filename of a log file containing the list of validation errors and warnings. 
To save a list of validation rows as a log file, click Save As, navigate to where you 
want to save the file, and then specify a filename. You can then reload the list of 
error and warning validations at a later time by using the Load button, rather than 
by repeating the validation process.

Load button Opens a previously saved log file and displays its list of validations in the Errors list.

Save As 
button

Saves the current list of validation rows as a log file. 

Table 29. User Interface Elements of the Errors Area of the Validate Dialog Box

Field/
Button Description
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Figure 21 shows an example of the Validation Options dialog box. 

Table 31 describes the Rules area of the Validation Options dialog box. The repository Validator must 
be used only in conjunction with the Time Filter, to avoid validating objects that are not being used. 

Figure 21. Validation Options Dialog Box

Table 31. User Interface Elements of the Rules Area of the Validation Options Dialog Box

Field/Button Description

Rules list Lists all rules that can be enforced during validation. Each row in the list 
identifies a rule for a specific object type (or All). You can sort the rows by 
by clicking a column heading. You can also resize columns by dragging the 
right or left border of the heading cell. 

Severity column An icon appears in this list column for each rule. It indicates whether the 
rule generates a warning (yellow icon with an exclamation point) or an error 
(red icon with a minus sign). 

Rule column The integer value that identifies this rule.

Object columns Either the single object type that this rule applies to, or All.

Description column The description of the rule. 

Enforce A Yes or No value for each rule. Yes validates all objects of the object type 
identified in the Object column. Yes/No values in this list column are 
changed using the Enforce, Ignore, Enforce All, and Ignore All buttons.
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Table 32 describes the Time Filters area of the Validation Options dialog box.

Table 33 describes the Action area of the Validation Options dialog box.

Save button Saves the current set of rules and their state (enforced or ignored) to a text 
file you specify. Other settings are saved to the preferences file when you 
press ENTER.

Enforce button Changes the Enforce column value in the selected row from No to Yes.

Ignore button Changes the Enforce column value in the selected row from Yes to No.

Enforce All button Changes all values in the Enforce column to Yes. 

Ignore All button Changes all values in the Enforce column to No. This has the effect in the 
next validation of not validating any objects.

Details text box The full text of the rule description for the currently selected row in the 
Rules list.

Table 32. User Interface Elements of the Time Filter Area of the Validation Options Dialog Box

Field Description

Last validated check 
box and date field

When selected, validates only objects changed since the date you enter into 
the corresponding date box.

Custom check box 
and date and time 
fields

When selected, validates only objects changed within the date range you 
enter into the corresponding date boxes.

Table 33. User Interface Elements of the Action Area of the Validation Options Dialog Box

Field Description

Do not report 
warnings check box

When selected, reports errors only, not warnings. It also changes the 
Enforced setting of all warning rules to No.

Abort validation 
after check box and 
text box

When selected and a number is entered in the text box, Siebel Tools stops 
validating after the specified number of errors is reached. By default, the 
validation process continues to run until it is completed or canceled.

Table 31. User Interface Elements of the Rules Area of the Validation Options Dialog Box

Field/Button Description
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Using Queries to List Objects
You can use query-by-example (QBE) to narrow the list of objects displayed in the Object List Editor. 
An Object List Editor query searches for objects based on values in one or more properties of the 
object. The queries can be simple, one-condition queries or compound, multiple-condition queries. 
You can create, refine, and activate queries from the Query menu or from the List toolbar. (Refine 
means to impose a further restriction on the current Object List Editor query by running it again with 
an additional constraint.)

To create and execute an Object List Editor query

1 Navigate to the list of objects that you want to query.

2 Choose Query > New Query.

In the Object List Editor, a single empty query row appears.

3 Define your search criteria in the property cells of the empty query row. 

These values may be single literal values such as Opportunity List Applet, or they may include 
wildcard symbols. In TRUE/FALSE properties, a check mark represents TRUE. 

4 Choose Query > Execute Query.

The list of objects in the Object List Editor is filtered to contain only those objects that meet your 
query criteria.

To restore the Object List Editor to its prequery state

1 Choose Query > New Query.

In the Object List Editor, a single empty query row appears.

2 Choose Query > Execute Query.

The list of objects in the Object List Editor is restored to its prequery state.

Related Topics
“About Simple Queries” on page 123

“About Compound Queries” on page 123
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About Simple Queries
A simple query finds information based on one condition. Table 34 lists the operators you can use to 
create a simple query. 

For more information on search specifications and operators and on Siebel data types, see Siebel 
Developer’s Reference.

About Compound Queries
Compound queries enable you to find information based on two or more conditions. There are three 
ways to create compound queries: 

■ Enter conditions in two or more property columns to find records that meet all the conditions. In 
other words, Siebel applications automatically connect these conditions with the operator AND. 
This method is the easiest way to create a compound query.

■ Enter a compound query within a property field using the operators OR, AND, and NOT to create 
two or more conditions for that property. 

Table 34. Simple Query Operators

Operator Description 

= Equal to 

< Less than 

> Greater than 

<> Not equal to 

<= Less than or equal to 

>= Greater than or equal to 

* Any number of characters (including none) may take the place of the asterisk (*)

? Any one character matches the question mark (?)

IS NOT NULL Searches for nonblank fields

IS NULL Searches for blank fields

LIKE Searches for values starting with the indicated string

NOT LIKE Searches for values not starting with the indicated string

“ ” Searches for strings that contain special characters, such as a comma (,) 

EXISTS ( ) Searches for values in a multi-value group

[~] Forces the case of the text string to whatever follows the tilde (~)
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■ Enter a compound query using more than one field and compound operators AND, OR, and NOT. 
You can enter this type of query in any field. You might find it convenient to use the Description 
or Comments field, because it is typically the longest on a given screen.

When you create a compound query, follow the same basic steps you use to create a simple query. 

Use parentheses to control the order in which a compound search is conducted. Expressions inside 
parentheses are searched for first (as they appear left to right). Table 35 lists the unique operators 
for compound queries. Use these operators in addition to the operators you use to create a simple 
query.

For more information about compound operators, see Siebel Developer’s Reference.

Searching the Repository for Objects
Use the search repository feature to search across all properties of multiple object types using a 
single set of search criteria. This provides a way to locate objects when you know that a given value 
appears in one or more properties. The search repository feature differs from querying in the Object 
List Editor, because when querying you can query only on a single object type and have to define 
search criteria for each property.

NOTE: Searching the repository can be time-consuming.

To find an object using search

1 Choose Tools > Search Repository.

The Search Repository dialog box appears.

2 Under Parameters, in the Search value text box, type the search criteria.

3 If you want only those objects whose property values contain the search string with the same 
capitalization, select the Case sensitive check box.

4 If you want only those objects whose property values exactly match the entire search string, 
select the Exact match check box.

Table 35. Compound Query Operators

Operator Description 

AND All the conditions connected by ANDs must be true for a search to retrieve a record. 

OR At least one of the conditions connected by the OR must be true for a search to 
retrieve a record. 

NOT The condition modified by this operator must be false for a search to retrieve a 
record.
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5 In the Types to search list box, select the object type or types to search for. 

By default, all object types in this list are selected. You can choose a single object type to search 
by selecting it. Use CTRL-click and SHIFT-click to select multiple object types. For better 
performance, search only the object type or types you need.

Use the Select All and Clear All to select or deselect all object types in the Types to search list box.

6 Click Search Now. 

Siebel Tools executes the search and lists the results in the list box at the bottom of the Search 
Repository dialog box. See Figure 22 on page 126 for an example. The list box lists all the objects 
that match your search criteria, with the following columns for each object.

7 To show it in the Object List Editor, double-click an item in the results. 

This has the same effect as running a query in the Object List Editor for the name of the object. 

8 To export the search results to a file, click the Export button.

To cancel a search
■ At any time during the execution of a search, click Cancel. 

Siebel Tools stops the search process. 

Column Description

Type Object type of the object returned by the search.

Name Name of the object returned by the search.

Property Name of the property of the object in which the search value was found.

Value Value of the property of the object in which the search value was found.
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Figure 22 shows an example of the Search Repository dialog box after a search execution.

Viewing Object Relationships
You can use the Visualization views to see how objects relate to one another. 

To show the Visualization views using the View menu
■ Choose View > Visualize > View Details, View Relationships, View Descendents, or View Web 

Hierarchy.

To show the Visualization views from the Object List Editor
■ Right-click an object of the relevant object type in the Object List Editor, and choose the 

Visualization view you want. 

Not all Visualization views are listed for all objects.

Figure 22. Search Repository Dialog Box
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The Visualization views are described in Table 36.

About Object Comparison and 
Synchronization
You can view a side-by-side comparison of any two objects of the same type. Differences are visually 
highlighted through color-coded icons. You can select and copy properties and individual child objects 
from one object to the other.

Using this feature, you can propagate a change made to an ancestor object to its descendents or 
other objects of a similar types. You can assess and adjust differences between objects. You can also 
compare properties of checked-out objects with their counterparts on the server.

For more information about ancestor objects, see Configuring Siebel Business Applications.

Topics in This Section
“About the Compare Objects Dialog Box” on page 128

“Comparing Objects” on page 129

“Synchronizing Objects” on page 131

Table 36. Description of Visualization Views

View Description

Details Generates and displays a Details visualization view for the currently selected 
business component or business object.
The diagram displays how the business component maps to underlying tables 
(directly or through joins) and maps to other business components (through 
links).

Relationships Generates and displays a Relationships visualization view for the currently 
selected business component or table.
For business components, the diagram displays how the business component 
links to other business components using multi-value link objects. For tables, the 
diagram displays how the table joins to other tables using Join objects.

Descendents Shows all objects which have the current object marked as their Upgrade 
Ancestor.

Web Hierarchy Generates and displays a Web Hierarchy visualization view for the currently 
selected applet, application, business component, screen, or view.
The diagram displays the parent-child relationships between the selected object 
and its parent and child objects, as well as the parents of the parent objects and 
children of the child objects, up and down the hierarchy.



Using Siebel Tools Version 8.0, Rev. A

Working with Objects ■ About Object Comparison and Synchronization

128 

About the Compare Objects Dialog Box
To display a side-by-side comparison of any two objects of the same type, Siebel Tools uses the 
Compare Objects dialog box, shown in Figure 23.

Figure 23. Compare Objects Dialog Box
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Table 37 describes the Compare Objects dialog box.

Comparing Objects
You can compare two objects of the same type. The Object Comparison dialog box displays a line-
by-line comparison between the two. You can compare objects defined in the current repository, in 
different repositories, and in archive (SIF) files.

Table 37. Compare Objects Dialog Box User Interface Elements

Field/Button/
Control Description

First Selection The explorer controls in the upper left and right area of the dialog box 
are similar to what you see after clicking the Detail tab of the Object 
Explorer. 

Both controls are always synchronized to show a line-by-line comparison 
between the objects. If you expand or collapse an object in one explorer 
control, its counterpart is automatically expanded or collapsed.

Child objects that do not exist in either object are represented with 
placeholders (a dashed line).

Second Selection

Properties By default, the properties shown in these list boxes are the properties 
that are different for the objects being compared. Which properties 
appear in these list boxes is determined by the settings in the Display 
area.

Display Determines which properties are shown in First Selection and Second 
Selection and in the Properties list boxes:

■ Show All Objects check box. Select to show all child objects in the 
First Selection. Second Selection box: select to show all user 
properties in the Properties list boxes.

■ Show System Properties check box. Select to show specific 
system properties such as Created, Created By, Updated, and 
Updated By in the Properties list boxes.

Use these two buttons to synchronize objects. See “Synchronizing 
Objects” on page 131 for more information.

Use this button to expand the entire tree in the First Selection and 
Second Selection explorer controls.

Use this button to collapse the entire tree in the First Selection and 
Second Selection explorer controls.

Delete button Use this button to delete objects after a comparison.
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To compare two objects in the same repository

1 In the Object Explorer select an object type.

2 In the Object List Editor, select two top-level objects. 

3 Choose Tools > Compare Objects > Selected. 

The Compare Objects dialog box appears.

To compare an object in the current repository with an object in another repository

1 In the Object Explorer, select an object type.

2 In the Object List Editor, select one top-level object. 

3 Choose Tools > Compare Objects > Selected vs. Repository.

The Open Repository dialog box appears.

4 Select the repository that contains the object you want to compare with the currently selected 
object.

The Object Comparison dialog box opens with the object in the current working repository 
displayed in the left applet and the corresponding object in the selected repository in the right 
applet. 

You can update the current working repository or the selected repository from the Object 
Comparison dialog box if you have the appropriate projects locked in both repositories.

To compare an object in the current repository with an object in an archive file

1 In the Object Explorer, select an object type.

2 In the Object List Editor, select one top-level object. 

3 Choose Tools > Compare Objects > Selected vs. Archive Option.

The Select Archive File to Compare Against dialog box opens.

4 Select a SIF file that to use for comparison and then click Open.

The comparison starts at the project level. If a corresponding object type is found in the archive 
file, the Object Comparison dialog box opens. If a corresponding object type is not found, it does 
not open. 

To compare objects in two different archive files

1 In the Object Explorer, select an object type.

2 In the Object List Editor, select one top-level object. 

3 Choose Tools> Compare Objects > Archive vs. Archive.

The Select Archive File for Left Side of Comparison dialog box opens.
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4 Select an archive file, and then click Open.

The Select Archive File for Right Side of Comparison dialog box opens.

5 Select an archive file, and then click Open.

The Object Comparison dialog box opens with the left and right side populated with the contents 
of the selected archive files. During the comparison, the two archive files are read-only.

Related Topic
“About the Compare Objects Dialog Box” on page 128

Synchronizing Objects
After you compare two objects, you can use the Compare Objects dialog box controls to synchronize 
those objects.

To synchronize objects

1 Lock the projects that contain the objects you want to synchronize.

2 In the Object Explorer, select any two top-level objects of the same object type.

Make sure the objects are locked.

3 Choose Tools > Compare Objects > Selected. 

The Compare Objects dialog box appears. 

4 Select an object instance in the First Selection box and use the right arrow button to synchronize 
the objects selected in the First Selection box with the object in the Second Selection box. 

If the objects do not exist in the Second Selection box, Siebel Tools creates them. If they do exist, 
Siebel Tools changes their properties to reflect those in the First Selection box.

When you copy an object from one tree applet to the other, the children of the object are copied 
as well.

Determining When Records Were Last 
Created and Updated
You can review the history for a record to see who made the last change and when the record was 
updated.

To determine by whom and when a record was created and last updated

1 Select a record in the Object List Editor.
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2 Choose Help > About Record. 

The Siebel Tools dialog box appears, displaying when and by whom the record was created and 
last updated.

3 Click Details > to display additional information about the record in the repository.
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8 Creating Workflow Processes 
and Tasks

This chapter describes how to create workflow processes and tasks. It contains the following topics:

■ “About the Workflow Process and Task UI Design Environments” on page 133

■ “Creating a Workflow Process” on page 134

■ “Creating a Task” on page 136

■ “Using the Expression Builder” on page 137

About the Workflow Process and Task UI 
Design Environments
In Siebel Tools version 8.0, workflow processes and tasks are created in similar graphical, drag-and-
drop design environments that share windows, such as the Palettes and Multi Value Property 
windows, and use many of the same steps in the Palettes window, such as Start, Business Service, 
and Siebel Operation.

The Workflow Process Designer allows you to define and test business processes and related 
repository objects. The Task Designer of the Siebel Task UI allows you to define, test, and publish 
(that is, make available to end users) tasks.

For detailed information on workflow processes and tasks, see Siebel Business Process Framework: 
Workflow Guide and Siebel Business Process Framework: Task UI Guide, respectively.
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The Task Designer is shown in Figure 24.

Creating a Workflow Process
Workflow Process objects are created in the Object List Editor. Workflow steps are created as child 
WF Step objects in the Workflow Process Designer.

For more detailed information on creating and editing workflow processes, see Siebel Business 
Process Framework: Workflow Guide.

To create a workflow process

1 In the Object Explorer, choose Workflow Process.

The Workflow Processes list appears.

2 Right-click in the Workflow Processes list, and then choose New Record.

Figure 24. Task Designer
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3 Enter property values in the new row in the Object List Editor.

The Process Name and Project are required.

4 Click anywhere outside the new row or move outside of the row with the UP or DOWN arrow keys.

Siebel Tools saves the new object.

5 Right-click the new record, and then choose Edit Workflow Process.

The Workflow Process Designer appears.

NOTE: The Palettes window is floating by default, but it can be docked or tabbed if desired.

6 Drag and drop workflow steps from the Palettes window, enter their properties in the Multi Value 
Property window, and then connect the steps.

NOTE: In Siebel Tools version 8.0, connectors automatically make right-angle lines and snap to 
the sides of step boxes.

7 Save your changes before exiting the Workflow Process Designer.

Figure 25. Workflow Process Designer
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Creating a Task
Tasks are created using the New Task wizard. (They can also be created in the Object List Editor.) 
Task steps are created as child Task Step objects in the Task Designer.

For more detailed information on creating and editing tasks, see Siebel Business Process Framework: 
Task UI Guide.

To create a task

1 From the File menu, choose New Object.

The New Object Wizards dialog appears.

2 Click the Task tab.

The list of task-related New Object wizards appears.
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3 Click the Task icon, and then click OK.

The New Task wizard appears.

4 Fill in the fields, and then click Finish.

The Task Designer appears, as shown in Figure 24 on page 134.

NOTE: The Palettes window is floating by default, but it can be docked or tabbed if desired.

5 Drag and drop task steps from the Palettes window, enter their properties in the Multi Value 
Property window, and then connect the steps.

Start and End steps are provided by default.

NOTE: In Siebel Tools version 8.0, connectors automatically make right-angle lines and snap to 
the sides of step boxes.

6 Save your changes before exiting the Task Designer.

Using the Expression Builder
The Expression Builder is used to create syntax for the Value field of a property in the Multi Value 
Property Window when the value is an expression. The Expression Builder works similarly to the 
Business Rules Designer in Siebel Personalization, and is available in both the Workflow Process 
Designer and the Task Designer.

To access the Expression Builder

1 Select a workflow or task step in the appropriate designer.
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2 In the Multi Value Property Window, create a new record, such as an output argument.

3 Name the property.

4 In the Type field for the record, choose Expression from the pull-down menu.

5 Click in the Value field for the record, and then click the pull-down arrow.

The Expression Builder appears.

6 Choose elements from the list, and then put them in the Expression window by double-clicking 
them; choose relations between elements by clicking the buttons.

7 When finished building the expression, click Validate. You can display the Error Messages window 
by selecting the Show Errors checkbox.

NOTE: You should test expressions using the application and not rely only on the Validate button 
to catch logical or syntax errors.

8 When the expression has been validated, click OK to place the expression in the Value property 
in the Multi Value Property Window.
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9 Siebel Script Editors

This chapter describes the Siebel Script Editors. It contains the following topics:

■ “About the Siebel Script Editors” on page 139

■ “Setting Scripting Preferences” on page 140

■ “About the ST eScript Engine” on page 142

■ “Setting ST eScript Engine Options” on page 144

■ “Using the Siebel Script Editor” on page 147

■ “Using Script Assist” on page 148

■ “Setting Script Assist Preferences” on page 151

■ “Using Script Libraries” on page 152

■ “About the Scripted Flag” on page 154

■ “About the Siebel Debugger” on page 154

■ “Using the Siebel Debugger” on page 155

About the Siebel Script Editors
The Siebel Script Editor is a window-based editor designed to create and maintain Siebel VB, Siebel 
eScript, and Browser Script programs. Scripting is used to implement functionality that cannot be 
achieved declaratively (that is, by changing object properties in the Siebel repository). The Server 
Script Editor and the Browser Script Editor are used to add scripts to Siebel objects. The Server Script 
Editor allows you to create and modify Siebel eScripts and Siebel VB. The Browser Script Editor 
allows you to write and edit Browser Scripts that run within the client. For more detailed information, 
including a list of scriptable events and callable methods on browser objects, see Siebel Object 
Interfaces Reference.

NOTE: There are two versions of the eScript scripting engine available. The ST eScript engine—
available with Oracle’s Siebel Business Applications, version 7.8 and higher—is the default eScript 
scripting engine in version 8.0. It provides enhancements including strong typing of variables and 
the Script Assist utility. The T eScript engine is the traditional, previously available engine.

Except for a few key differences, the ST eScript engine is backward-compatible with eScript created 
with the T eScript engine. In this document, the engines are referred to by name only in contexts 
requiring differentiation.

For a list of enhancements contained in the ST eScript engine, and well as instructions on how to 
enable the ST eScript engine, see “About the ST eScript Engine” on page 142. For information on 
syntax differences between the two engines, see Siebel eScript Language Reference.
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When creating Siebel custom programs, note the following:

■ Check out or lock the project containing the object definitions being modified. If the project is 
not locked, you will not be able to add any text in the Editor window.

■ Choose Debug > Check Syntax to verify the syntax of your VB or eScript program. The Siebel 
Compiler reports any syntax errors and indicates the lines where they occur. 

■ Choose File > Save when you have finished entering and editing the custom statements to save 
your work. Closing the Siebel Script Editor without saving your work discards the changes.

■ Before you run the application, you must compile the projects that you have modified and 
generate a new SRF file. For more information, see Chapter 10, “Compiling and Testing.”

■ Run the application with the new application extensions by choosing Debug > Start or clicking 
the Start button in the Debug toolbar. The Siebel application executes with the new modifications 
incorporated.

■ You may inadvertently create programming errors that, when encountered, halt the execution of 
the extension routine. If you started Siebel applications in debug mode (/H option on the 
command start-up line), a message box opens indicating the nature of the error. You can then 
return to the Script Editor and choose Debug > Check Syntax. For further details, see “Checking 
Syntax” on page 157.

■ When a script error is encountered by an end user, or when the Siebel application is not running 
in Debug mode, the application displays an appropriate error message with an error code and 
returns control back to the point in the standard Siebel code just before the error.

NOTE: You can suppress the display of the scripting error message code SBL-EXL-00151 in
pop-up error messages raised by the RaiseErrorText application method. Navigate to Screens > 
System Administration > System Preferences, and then set the value of the Suppress Scripting 
Error Code preference to TRUE. The default value is FALSE.

Setting Scripting Preferences
You set scripting preferences from the Development Tools Options window.

To set scripting options

1 From the Siebel Tools View menu, select Options.

The Development Tools Options window appears.

2 Click the Scripting tab. 

The following table describes the fields in the Scripting Options tab.

Area Field Description

Font Name Used to select the font for display of scripts.

Size Used to select the font size for display of scripts.
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Script Assist Allows you to set Script Assist options. For more information on Script Assist, 
see “Setting Script Assist Preferences” on page 151.

NOTE: You must have the ST eScript Engine enabled to use these features. 
For more information, see “About the ST eScript Engine” on page 142.

Enable Method Listing Enables Script Assist to display a drop-down of all 
methods and properties available for a declared 
object.

Tab width Defines the number of spaces for a tab character. 
The default is four spaces.

Enable Auto Complete When checked, will auto complete a given term 
when the minimal number of unique characters 
have been entered.

Additionally, this setting will auto complete 
method or property names, presenting a drop-
down list for strings that are not unique. 

Auto Indent When checked, each succeeding line is indented 
to the position set by the current line.

Enable Favorites When checked, the most frequently used object, 
method, and property names will appear in italics 
at the top of the Script Assist window.

Engine Settings Allows you to set options for the ST eScript 
Engine. For more information on these settings, 
see “Setting ST eScript Engine Options” on 
page 144.

Language Default language for new 
scripts

A drop-down list allows you to choose the 
scripting language, either eScript or Visual Basic.

Browser script 
compilation folder

This field allows you to specify the folder where 
your browser scripts will reside. This also 
determines where browser scripts are generated, 
such as C:\Program Files\Siebel\8.0\web 
client\PUBLIC\enu. In this case, browser script 
files are generated to C:\Program 
Files\Siebel\8.0\web 
client\PUBLIC\enu\<genbscript time stamped 
folder>\bscripts\all.

Area Field Description
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About the ST eScript Engine
The Siebel ST eScript engine is the default eScript scripting engine in version 8.0. It is compliant 
with ECMAScript Edition 4. ECMAScript is the standard implementation of JavaScript as defined by 
the ECMA -262 standard. The ST eScript engine, available in version 7.8 and higher, provides the 
following:

■ Improved Performance. Higher throughput with a lower CPU and memory footprint in cases 
where you have implemented a significant amount of script. The result is improved performance 
and lower maintenance on heavily scripted events.

■ Scalability. Better performance than the T engine when many users are concurrently executing 
scripts.

■ Enhanced functionality. Support for ECMAScript Edition 4 compliant strong typing. Strongly 
typed objects allow you more functional scripts and better performance. The T eScript engine, 
which was available in previous Siebel releases, does not support strong typing.

Functionality such as Script Assist, script libraries, favorites, and Fix and Go is only available with 
the ST eScript engine. For more information, see “Using Fix and Go” on page 146 and “Using Script 
Assist” on page 148.

NOTE: We strongly recommend that customers use the ST eScript engine for the above reasons. In 
version 8.0 and going forward, Siebel Business Applications are developed using only the ST eScript 
engine.

For a description of the functional differences in the scripting engines, as well as a description of 
Strong Typing syntax, see Siebel eScript Language Reference.

Debugging Allows you to set options for the Siebel Debugger. For more information, see 
“About the Siebel Debugger” on page 154.

Adjust breakpoint to next 
valid line

When breakpoints are deleted on invalid lines, 
this option creates a breakpoint at the next valid 
line.

Make debugger window 
active when debugging

The Siebel Debugger window appears whenever 
you are in debug mode.

Always enter the 
debugger when an error 
occurs

The Siebel Debugger window appears whenever a 
script error occurs.

Area Field Description



Siebel Script Editors ■ About the ST eScript Engine

Using Siebel Tools Version 8.0, Rev. A 143

Enabling and Disabling the ST eScript Engine
If you wish to use the older T eScript engine, you can disable the ST eScript engine in Siebel Tools 
by using the system preferences. If the ST eScript engine has been disabled, it can be reenabled the 
same way.

CAUTION: We do not recommend disabling the ST eScript engine. If you wish to do so, you should 
work with Siebel Technical Support to help prevent any unpredicted behavior.

To enable or disable the ST eScript engine for Siebel Tools

1 In Siebel Tools, choose Screens > System Administration > System Preferences.

2 In the System Preferences window, under System Preference Name, query for Enable ST Script 
Engine.

3 Set the System Preference Value:

■ TRUE. Enables the ST eScript engine.

■ FALSE. Disables the ST eScript engine.

NOTE: If you want to revert to the T eScript engine after using the ST eScript engine and 
modifying your code to be strongly typed, you will need to undo your strongly typed code 
changes.

4 Recompile your scripted objects.

5 Exit Siebel Tools, and then relaunch it to use the desired eScript engine.

NOTE: If the ST eScript engine is enabled in the development environment, it should also be enabled 
in the Siebel Business Application. Both environments should have all code compiled using the same 
eScript engine setting, and the engine setting for both environments should be the one in which the 
code was compiled.

For information on setting system preferences in Siebel Business Applications, see Siebel 
Applications Administration Guide.
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Setting ST eScript Engine Options
These options are set under Engine Settings on the Scripting tab of the Development Tools Options 
window. To use these options, the ST eScript engine must be enabled. The following table describes 
the available options.

NOTE: For ease of use, it is recommended that you enable all three of the ST eScript engine settings. 
By default, they are not enabled. 

Setting the ST eScript Engine Warnings Preference
This preference is set under Engine Settings on the Scripting tab of the Development Tools Options 
window. Select the Enable Warnings checkbox to enable this setting.

The ST eScript Engine includes warnings which alert the user of potential problems that may be 
encountered at compile time. Some potential problems are: 

■ References to methods and properties that are not predefined

■ References to undeclared identifiers

■ Variables that can potentially be used before being initialized

■ Double declarations of untyped variables

■ Calling a function that has an insufficient number of arguments

Errors such as those listed previously usually end up causing a run-time failure. Therefore, these 
compilation warnings enable you to fix errors earlier in your development cycle. The ST eScript 
Engine is downward compatible with the T eScript engine, so any scripts you may be running on that 
engine will run in the same way. 

If you do not want these warnings displayed, deselect the Enable Warnings box. 

The following is an example of a compilation warning message generated following a run-time 
failure:

Table 38. ST eScript Engine Settings

Setting Description

Enable Warnings Select this checkbox to display script compilation warning messages. 
For information, see “Setting the ST eScript Engine Warnings Preference” 
on page 144.

Deduce Types Select this checkbox to deduce the type of local variables used in a 
script by scanning the assignments made to them. For more 
information, see “Enabling ST eScript Engine Type Deduction” on 
page 145.

Fix and Go Select this checkbox to allow script testing and debugging without 
having to recompile before restarting the debugger. For more 
information, see “Using Fix and Go” on page 146.
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function foo(a)

{

var oApp: Application;

oApp.myMethod ();

return;

}

foo ();

Semantic Warning around line 5:Variable oApp might not be initialized.

Semantic Warning around line 5:No such method myMethod

Semantic Warning around line 10:Calling function foo with insufficient number of 
arguments.

Unhandled Exception: Function expected

Enabling ST eScript Engine Type Deduction
This preference is set under Engine Settings on the Scripting tab of the Development Tools Options 
window. Select the Deduce Types checkbox to enable this setting.

Type deduction is a feature of the ST eScript Engine which deduces the type of local variables used 
in a script by scanning the assignments made to them. The engine cannot make the type deduction 
under all situations, therefore it is recommended that you strongly type your scripts.

If type deduction can be made, the compiler will perform strict type checks and generate statically 
bound code that runs faster and uses less memory. This may, however, introduce additional 
compilation warnings because of such type checks. 

The following example is of a script that deduces the type of the local variable oDate to the Date and 
subsequently issues a warning about the undefined method MyMethod. The script subsequently fails 
at run time:

function goo()

{

var oDate;

oDate = new Date ()

oDate.myMethod ();

return;

}

goo ()
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Semantic Warning around line 19:No such method myMethod

Unhandled Exception: 'myMethod' is not defined

Using Fix and Go
When Fix and Go is enabled, you can edit scripts in a local Tools session and test the changes on the 
Siebel Mobile Web Client without closing the client and recompiling the scripts. This can save 
significant amounts of time in script development, testing, and debugging, making developers much 
more productive.

Fix and Go can only be used with Server Scripts and the ST eScript Engine. This preference is set 
under Engine Settings on the Scripting tab of the Development Tools Options window. Select the Fix 
and Go checkbox to enable this setting.

To use Fix and Go

1 Enable Fix and Go in the Development Tools Options window.

2 Create a server script in the Siebel Script Editor, save it, and then compile the SRF.

If you try to save a script with syntax errors, you will get a Script Error message and be prompted 
to go to the line or lines with errors to fix them.

3 Execute the script by running the Siebel Debugger.

4 Stop the execution of the script being tested.

5 Make changes, save them, and then execute the script.

You do not need to recompile the SRF.

NOTE: You must save and compile all script changes before exiting Siebel Tools, or else they will be 
lost.
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Using the Siebel Script Editor
Siebel scripts can be attached to the object types application, applet, and business component. 
Figure 26 displays the Siebel Script Editor. To access the Script Editor, see “To access the Siebel Script 
Editor” on page 148.

The Siebel Script Editor is a window-based editor similar to the Windows Notepad editor. The Editor’s 
interface consists of a title bar, a drop-down list for specifying an object, a drop-down list for 
specifying an event, and a text entry window. There are vertical and horizontal scroll bars for 
scrolling within the entry region.

When using the Siebel Script Editor, you can do the following:

■ Cut, copy, and paste the text from one location to another location within or from outside the 
Editor. When pasting into the Editor, avoid having two code blocks with the same name by placing 
the code between function <Name> { and } in eScript or Sub <Name> and End Sub in VB.

■ Import and export Siebel scripts.

■ Associate a given Siebel script with a predefined object event, such as a PreSetFieldValue event 
for a Business Component. 

■ Debug a custom routine by invoking the Siebel Debugger. For more information, see “About the 
Siebel Debugger” on page 154.

■ Compile a custom routine by invoking the Siebel Compiler from the Siebel Script Editor. For more 
information, see “Invoking the Compiler and Run-time Engine” on page 161.

The editor functions can be accessed from the title bar menus, keyboard shortcuts, and the Edit 
toolbar. The following are File menu options pertaining to Siebel VB and Siebel eScript:

■ Import. Imports Siebel scripts.

■ Export. Exports Siebel scripts.

■ Save. Saves a Siebel script. Be sure to save your scripts before exiting the editor.

■ Exit. Closes the Siebel Script Editor window.

Figure 26. Siebel Script Editor
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The following are Edit menu options pertaining to the Siebel Editor:

■ Cut. Deletes selection and saves it to the Clipboard.

■ Copy. Copies selection to the Clipboard.

■ Paste. Copies what is on the Clipboard to the selected area.

■ Delete. Deletes selection.

■ Select All. Selects the entire script.

■ Find. Displays the Find in Script dialog box. You can search for text or white space.

■ Replace. Displays the Replace in Script dialog box. You can search and replace text or white 
space.

To access the Siebel Script Editor

1 In the Object List Editor, select a scriptable object type, such as Applet.

2 Do one of the following:

■ Right click and then select either Edit Server Script, or Edit Browser script.

■ From the application-level menu, select View > Editors > Server Script Editor or Browser 
Script Editor.

Using Script Assist
Script Assist, a component of the ST eScript Engine, aids in the development of scripts by 
introspecting object definitions and making that information available to the user.

Script Assist provides the following functionality:

■ Syntax highlighting. Reserved words, data types, operators, and other syntax in scripts are 
highlighted in color in both VB and eScript. The following table lists the colors:

NOTE: Colors are not customizable.

■ Method listing. All methods and properties available for a particular object are listed in the 
Script Assist window. See “Accessing the Script Assist Window” on page 150.

Syntax Color

Reserved words and VB statements Blue (0, 0, 255; 0xFF0000)

Data types OrangeRed (205, 55, 0; 0xCD3700)

Operators Navy (0, 0, 128; 0x000080)

String literals SteelBlue (70, 130, 180; 0x4682B4)

Delimiters (eScript only) Brown (205, 51, 51; 0xCD3333)

Functions (VB only) Magenta (139, 0, 139; 0x8B008B)
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■ Repository introspection. Script Assist can access objects and object types in the repository 
without the developer having to type string literals. This leads to fewer mistakes in script writing.

Script Assist also understands predefined constants for business component methods.

■ Favorites. The most frequently used object, method, and property names appear in italics in 
the Script Assist window when favorites are enabled in the Development Tools Options window.

NOTE: Favorites are associated with a Siebel Tools session: when you log out of Siebel Tools, the 
favorites are cleared.

■ Script libraries. You can call business service functions directly after declaring a business 
service. You no longer need to declare property sets and make an InvokeMethod call. Script 
libraries facilitate development of reusable, modular components. For more information about 
using script libraries, see “Using Script Libraries” on page 152.

■ Auto complete. After typing a minimum number of unique characters within the Script Assist 
window, for example “Bus” for “BusComp”, Siebel Tools automatically completes the word if a 
match is found.

■ Auto indent. With the Auto Indent checkbox selected, which is the default setting, Siebel Tools 
maintains a running indent. When you press the Return or Enter key, spaces and tabs are 
inserted to line up the insert point under the start of the previous line.

■ Tool tips. Within the Script Assist windows, tool tips allow you to see the arguments descriptions 
of methods chosen by a developer. They are particularly helpful as you do not need to cross 
reference a customer function and its required arguments, or the Siebel Bookshelf for included 
methods. 

■ Application object scripts included for parsing. Scripts written on the Application object can 
be included for parsing by Script Assist. If in the Application drop-down you select the application 
to which this child script (business component, applet, business service) belongs, the scripts 
written on that application object will be available in the Script Assist window.

■ Custom scripts written in the general section. Scripts written in the general section of the 
script explorer window are available in the Script Assist window. For example, if you were to write 
a helper function called Helper() in the general section of a current script, invoking Script Assist 
will cause Helper() to be included and available in the pop-up window.



Using Siebel Tools Version 8.0, Rev. A

Siebel Script Editors ■ Using Script Assist

150 

Figure 27 displays the Script Assist window which provides a list of methods and properties 
associated with a selected object. To access the Script Assist window, see “Accessing the Script Assist 
Window” on page 150. For a description of icons in the Script Assist window, see Table 39.

Table 39 describes the icons in the Script Assist window.

Accessing the Script Assist Window

To access the Script Assist window

1 In the Script Editor Explorer window, select the desired object.

Figure 27. Script Assist Window

Table 39. Script Assist Icons

Icon Description

Read-only property

Changeable property

Method

Class object

Primitive
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2 Press CTRL+SPACE.

The Script Assist window, shown in Figure 28, appears displaying a list of all methods and 
properties available for the selected object. The italicized items are the favorites for the current 
session.

NOTE: If you create a new function, you must add it to the declarations and then save the script 
changes for the function to appear as a favorite.

Setting Script Assist Preferences
You set preferences for Script Assist in the Development Tools Options window. 

To set Script Assist preferences

1 From the Siebel Tools View menu, choose Options.

The Development Tools Options window appears.

Figure 28. Script Editor with Script Assist Window
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2 Click the Scripting tab.

The following table describes the different fields in the Script Assist Window.

Using Script Libraries
Script libraries are a component of the ST eScript Engine that provide a framework for invoking 
methods on business services from within the scripting interface. However, only cached services that 
are marked for external use can be used as a script library. Methods on a newly-created service 
library are available only after the new service is saved in Siebel Tools. 

This topic describes how to make custom methods available to a business service script library and 
how to invoke these methods on the script library.

NOTE: Using script libraries is optional. All code written before Siebel 8.0 is still supported.

For more information about script libraries, see Siebel eScript Language Reference.

Creating Custom Methods and Making Them Available in a Script 
Library
Use the following procedure to create a custom method and make it available in a script library.

To create a custom method and make it available in a script library

1 Create a business service method script in Siebel Tools.

2 Ensure the script does not contain compilation errors.

3 Save the business service method script.

4 Check the External Use flag for the business service object.

The custom method for the service is added to the script library and can be displayed in the Script 
Assist utility. 

Field Available Options

Enable Method 
Listing

When checked, a list of declared methods and properties will appear in the 
Script Assist window for each selected object.

NOTE: For Script Assist features to be fully enabled, you must check this box.

Enable Auto 
Complete

When checked, Auto Complete is enabled.

NOTE: For Script Assist features to be fully enabled, you must check this box.

Auto Indent When checked, each succeeding line is indented to the position set by the 
current line.

Enable 
Favorites

When checked, the most frequently used object, method, and property 
names will appear in italics at the top of the Script Assist window.

Tab Width Set the tab width, in increments of spaces. The default setting is 4.
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Invoking Custom Methods Using a Script Library
After you make a business service available for external use in Siebel Tools, you can then invoke 
methods on the service from other scripts using the script library framework. The available methods in 
a script library also appear in the Script Assist window. For more information about Script Assist, see 
“Using Script Assist” on page 148.

Use the following procedure to invoke a custom method using a script library. 

To invoke a method using a script library

1 Make sure the Enable Method Listing and Enable Auto Complete fields are checked in the Siebel 
Tools scripting options. 

For information on setting these options, see “Setting Script Assist Preferences” on page 151.

2 In the script editor, type the name of a business service object followed by a period (.).

All the default and custom scripted methods available for the business service object appear.

3 Select the method that you want to add to your script.

NOTE: You may want to run a syntax check to detect incorrect method calls. For more 
information about checking syntax, see “Checking Syntax” on page 157.

Example of Using a Script Library
The following is one example of using a script library to invoke a custom method. You may use the 
feature differently, depending on your business model.

Given you have a mathService business service marked for external use with a scripted method 
named square (x):

function square (x)
{
return (x * x);

}

NOTE: For functions called using script libraries, the compiler checks that argument types are valid 
and do not contain incompatibilities.

You can invoke this method using another script by typing the following:

var oBS: Service = TheApplication().GetService ("mathService");
var value = 10;
var square_value = oBS.square (value);
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To see a list of the available methods for the mathService library (as shown in Figure 29), type the 
following:

var square_value = oBS.

About the Scripted Flag
For object types that can have a Siebel script attached to them (Applet, Application, and Business 
Component), there is a property in the Object List Editor called Scripted. This property indicates 
whether Siebel scripts are attached to the object definition. A check mark (TRUE) indicates the 
presence of scripts; no check mark (FALSE) indicates that the object definition has no scripts.

About the Siebel Debugger
The Siebel Debugger assists in editing and removing errors from scripts written in Siebel VB and 
Siebel eScript.

The Siebel Debugger uses the Siebel Script Editor window plus a diagnostic window to display 
program variables and their values. The Debugger helps you locate and correct execution errors in 
custom program routines. You can use it to slow or suspend execution of the program routines so 
that the program flow and variable contents can be examined.

With the Siebel Debugger you can do the following:

■ Set and clear breakpoints in your Siebel script. A breakpoint is a marker on a line of Basic code 
that tells Basic to suspend execution at that line so that the state of the program can be 
examined using the Debugger.

■ Step over a line of code. If the current line is a call to a subroutine or function, the Debugger 
stops at the next line in the current procedure (skipping the subroutine).

■ Step into a subroutine of custom routine code. Step Into is used to execute one line of code in 
the Debugger. If the current line is a call to a subroutine or function, the Debugger stops at the 
first line of that function. Otherwise, the Debugger stops at the next line of the current 
procedure.

Figure 29. Example of a Script Assist Window Showing the Methods Called from a Script Library
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■ View the value of custom routine variables. The Siebel Debugger includes a Watch window in 
which variables and their values are displayed. This window can be used to monitor the values 
of specific variables as the custom routine executes.

Using the Siebel Debugger
You can access the Debugger in several ways:

■ You can set breakpoints in the current routine and begin execution by clicking the Start button. 
Execution is suspended when one of the lines that contains a breakpoint is about to be executed. 
The Debugger is activated and it highlights the line containing the breakpoint.

■ If an executing program encounters a run-time error, such as an unhandled Siebel VB or eScript 
error, execution is suspended, the Debugger is activated, and it highlights the line containing the 
error.

Debug options are available from the Debug title bar menu and the Debug toolbar. See the Siebel 
Toolbars and Menus topics for details.

Topics in This Section
“Setting Debugging and Run-time Preferences” on page 155

“Checking Syntax” on page 157

“Using Breakpoints” on page 158

“Using the Calls Window” on page 158

“Using the Watch Window” on page 158

“Tracing Scripts” on page 159

“Invoking the Compiler and Run-time Engine” on page 161

Setting Debugging and Run-time Preferences
You set debugging preferences and run-time preferences in the Development Tools Options window.

To set debugging preferences

1 From the Siebel Tools View menu, select Options.

The Development Tools Options window appears.
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2 Click the Scripting tab. 

The following table describes the different fields in the Debug box in the Development Tools 
Options window.

To set run-time preferences

1 From the Siebel Tools View menu, select Options.

The Development Tools Options window appears.

2 Click the Debug tab. 

The following table describes the different fields in the Debug box in the Development Tools 
Options window.

Option Description

Adjust breakpoint 
to next valid line 

When breakpoints are deleted on invalid lines, this option creates a 
breakpoint at the next valid line. Click the check box to enable this 
function.

Make debugger 
window active 
when debugging

The Siebel Debugger window appears whenever you are in debug mode. 
Click the check box to enable this function.

Always enter the 
debugger when an 
error occurs

The Siebel Debugger window appears whenever a script error occurs. 
Click the check box to enable this function.

Option Description

Executable Enter the name of the Mobile Web Client executable (Siebel.exe).

CFG file Enter the configuration file to be used by the client.

Browser Enter the path to the browser executable.

Working directory Enter the Siebel root directory (location of DLLs).

Arguments Additional line options for starting the application. Common arguments 
are:

■ /h - to enable local debugging of Server scripts

■ /s <filename> - to enable SQL spooling

Prompt for this 
information each 
time

Click this to display relevant information, such as executable, CFG file, 
browser, and so on, each time you run a debug operation.

Show Workflow 
Primary Business 
Component Data

If checked, the Watch Window in the Workflow Simulator will show all 
fields and their values from the primary Business Component of the 
Business Object associated with the Workflow process being simulated.

User Name Enter the login of the user.
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Checking Syntax
The debugger includes a syntax checker to make sure that your script compiles properly. 

To check the syntax of your script

1 Click the Check Syntax button, or choose Debug > Check Syntax.

Siebel Tools does a test compile. If you have made no errors, you get no response. If there are 
errors in your script, a message box appears describing the error. The message box has two 
buttons: Next Error and Go to Line. If there is more than one error, it is best to handle them one 
at a time. 

2 Click Go to Line.

The cursor is displayed on the line of the script containing the error, with the line highlighted. 

3 Correct the code and check the syntax again. 

If the syntax of the line you changed is now correct, the message box displays the next error, if 
any.

4 Repeat Step 2 and Step 3 until you see no more messages.

5 Choose File > Save to save your file, and close the Siebel application. 

6 Press F7 to compile the SRF file.

7 When the compilation finishes, click Run or press F5 to restart the application.

CAUTION: The Check Syntax function checks only for syntax errors and errors that stem from 
failure to properly initialize objects or variables. It does not check other types of errors, and cannot 
trap errors in logic that may cause run-time errors.

At this point, your script should run. Test it to see if it gives you the desired results. The following 
sections describe debugging tools to help you accomplish that end.

CAUTION: The Check Syntax command checks only the script in the active object definition. If there 
are errors in other scripts, you are not able to compile the SRF file.

Password Enter the password of the user name.

Data source Enter the default data source. Values listed depend upon the 
configuration file specified in the CFG file parameter.

Option Description
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Using Breakpoints
A breakpoint is a marker on a line of Siebel code that tells the interpreter to suspend execution at 
that line so that the state of the program can be examined using the Debugger. There are two ways 
to set breakpoints on lines of Siebel code when editing, and there is an additional way to set a 
breakpoint when debugging:

■ When editing, place the cursor on the line of code on which to set a breakpoint by clicking on 
that line, or by using the arrow keys. To toggle the breakpoint, press F9, or click the toolbar 
button. If the line already has a breakpoint, pressing F9 or the toolbar button clears the 
breakpoint.

■ When debugging, clicking on a line of Siebel code toggles a breakpoint on that line.

Using the Calls Window
The Calls window contains a list of subroutine and function calls that were executed prior to the 
current line. To access the Calls window, click the Calls button in the Debugger toolbar when you are 
running the Debugger. A typical Calls window may contain several lines, one for each subroutine 
entered into and not yet completed.

Selecting an entry in this list box causes the interpreter to shift to that entry. The Debugger window 
displays the line of code that made the call, and the Variable window displays the variables that are 
associated with the procedure that made the call.

Using the Watch Window
The Watch window displays script variables and their values. This window can be used to monitor the 
values of specific variables as a script executes. In version 8.0, the Watch window supports the 
following variable types:

■ Local

■ Global

■ Profile attributes, both persistent and dynamic

■ Shared global

■ Application
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Figure 30 shows a script for the Contact business component being monitored in the Watch window.

To access the Watch window

1 Attach a script to an object, and then compile that object.

2 Start the Mobile Web Client from the Siebel Debugger by pressing F5 or clicking the Start icon 
on the Debug menu. Make sure that the /h argument has been set in the Debug options.

3 Press SHIFT+F9 or click the Watch button (glasses icon) on the Debug toolbar.

The Watch window appears.

Tracing Scripts
As part of debugging scripts you can run a trace on allocations, events, and SQL commands. The 
tracing can be activated for specified user accounts, such as your development team. The Siebel 
Server sends the tracing information to a log file.

Figure 30. Monitoring a Script Using the Watch Window
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To enable logging

1 Navigate to Server Administration > Components.

2 Select a component to log.

Not all components support logging, but the majority do.

3 Click the Component Event Configuration tab.

4 Select the Object Manager Extension Language Log record.

If this record does not exist, then the selected component does not support logging.

5 Set the Log Level to 1. To disable logging when you are done, set the Log Level to 0 (zero).

6 Click the Component Parameters tab.

7 Optional. To display only the script tracing parameters, query for the following:

■ Parameter Alias = Trace*

■ Subsystem = Object Manager

Changes to the script tracing parameters can take effect immediately. If you want changes to 
take effect now, then make changes to the values in the Current Value column. If you want the 
changes to take effect only after a restart, then make changes to the values in the Value on 
Restart column.

8 Set one or more tracing parameters from the following table.

The following is a sample trace:

2021 2003-04-09 15:37:20 2003-04-09 16:40:52 -0700 00000022 001 001f 0001 09 SCCObjMgr_enu 47126 1680 1584 
C:\sea752\siebsrvr\log\SCCObjMgr_enu_47126.log 7.5.3 [16122] ENU

ObjMgrSessionInfo ObjMgrLogin 3 2003-04-09 15:37:20 Login name : SADMIN

ObjMgrSessionInfo ObjMgrAuth 3 2003-04-09 15:37:20 Authentication name : SADMIN

ObjMgrSessionInfo ObjMgrLogin 3 2003-04-09 15:37:20 Session Type: Regular Session

GenericLog GenericError 1 2003-04-09 15:37:20 Invocation of Applet Menu New 
Service::NewExpense is not allowed.

GenericLog GenericError 1 2003-04-09 15:37:20 Invocation of Applet Menu New 
Service::NewTimeSheet is not allowed.

Information to 
Trace

Parameter 
Alias Settings for Current Value and Value on Restart

Allocations TraceAlloc 0 (zero) to disable logging, 1 to enable logging

Events TraceEvents 0 (zero) to disable logging, 1 to enable logging

SQL Commands TraceSql 0 (zero) to disable logging, 1 to enable logging

Users TraceUser Comma-separated list of user names. Do not use spaces. 
Example:
sadmin,mmasters,hkim,cconnors
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ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:27 [User: SADMIN] EVENT, BEGIN, BusComp 
[Account], BusComp_Query.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:27 [User: SADMIN] EVENT, END, BusComp 
[Account], BusComp_Query.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:58 [User: SADMIN] EVENT, BEGIN, BusComp 
[Account], BusComp_NewRecord.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:38:58 [User: SADMIN] EVENT, END, BusComp 
[Account], BusComp_NewRecord.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:39:08 [User: SADMIN] EVENT, BEGIN, BusComp 
[Account], BusComp_PreSetFieldValue.

ObjMgrExtLangLog ObjMgrExtLangLog 0 2003-04-09 15:39:08 [User: SADMIN] EVENT, END, BusComp 
[Account], BusComp_PreSetFieldValue.

ObjMgrSessionInfo ObjMgrLogin 3 2003-04-09 16:40:52 Username: SADMIN, Login Status: Attempt, 
Session Id: !1.690.b816.3e94a0a0, IP Address: 172.20.94.66

Script tracing is not the same as file-based tracing. For more information on file-based tracing, see 
Siebel Object Interfaces Reference.

Invoking the Compiler and Run-time Engine
To invoke the Siebel Compiler and Run-time Engine, click the Compile button on the Debugger 
toolbar, or press F7. You can also invoke it when compiling a project containing object definitions 
with associated Siebel scripts. The Siebel Compiler and Run-time Engine has no user interface of its 
own. When the compiler is invoked, it compiles the custom routines and returns a message when 
completed that indicates success or failure.

Compilation Order Considerations
The Siebel Compiler compiles Siebel VB functions and procedures in alphabetical order within an 
object definition. If a function or procedure calls another function or procedure that has not been 
defined, the compiler generates an error message in the form:

function_name Is An Unknown Function

To avoid this error, use the Declare statement to declare the function or procedure in the (general) 
(declarations) section. For more information, read the VB Language Reference topics within Siebel 
VB Language Reference.

Siebel eScript does not require forward declaration of functions.
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10 Compiling and Testing

This chapter describes compiling and testing. It contains the following topics:

■ “About Compiling” on page 163

■ “Compiling Projects” on page 164

■ “Compiling Single Objects or Groups of Objects” on page 165

■ “Command-Line Interface for Import, Export, and Compilation” on page 165

■ “Testing Changes on Your Local Machine” on page 167

About Compiling
After you have modified objects, you need to compile the changes to an SRF. The SRF file is updated 
with the new objects, which become available in any instances of the Web Client reading that SRF file.

NOTE: An application’s configuration file (CFG) includes a parameter (RepositoryFile) that defines 
the SRF file to read at run time.

You can compile entire projects or individual top-level objects. Compiling projects is more efficient 
when you have many changes in one or more projects. Compiling objects is more efficient when 
changes are isolated to only a few objects. 

NOTE: To be able to compile, Siebel Tools must be connected to a database that has the sort order 
set to binary.

CAUTION: When compiling a new SRF file, make sure all Siebel applications are completely closed. 
Use the Windows Task Manager to verify that no Siebel.exe processes are running. To compile, see 
“Compiling Projects” on page 164 or “Compiling Single Objects or Groups of Objects” on page 165.

Incremental Repository Upgrade Kits
If you are compiling an SRF file to create an incremental (delta) repository upgrade kit, you can 
minimize the size of the kit and the time required to upgrade by specifying a Reference SRF when 
you compile your new SRF. The Reference SRF is a previous (base) version of the SRF. The 
incremental repository upgrade contains the differences between the Reference SRF and the new SRF 
only. To specify a Reference SRF, click the Reference SRF button, and specify the path and file name 
of the previous SRF version. 

For more information about incremental SRF files and upgrades, see Siebel Anywhere Administration 
Guide.
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Compiling Projects
You use the Object Compiler to compile all projects or selected projects only. To be able to compile 
selected projects, you must have compiled all projects at least once.

CAUTION: Avoid compiling a subset of projects into an SRF file, unless the SRF file was built from 
a full compilation from the same database.

When you select individual projects to compile, the Object Compiler does not remove inactive top-
level objects from the SRF file, but it does remove inactive child objects. For example, if you 
inactivate the Name list column in the Account List Applet, and then compile the Account SSE project, 
the Name list column is removed from the SRF file. However, if you inactivate the Account List Applet, 
and then compile the Account SSE project, the Account List Applet is not be removed.

To compile projects

1 Choose Tools > Compile Projects.

The Object Compiler dialog box appears with the list of projects displayed.

2 Select the projects you want to compile.

3 In the Siebel Repository File field, click Browse and then select the appropriate SRF file.

Typically you compile to the SRF file used by the local instance of the Web Client that you are 
using to test. The path to this SRF file is specified in the application’s CFG file.

CAUTION: Do not attempt to compile to or modify the default SRF file used by Siebel Tools that 
is displayed in the Object Compiler dialog box—usually siebel.srf located in 
SIEBEL_TOOLS_ROOT\OBJECTS. This file is locked because the Siebel Tools client is currently 
reading it. If you attempt to compile to this filename and path, you receive an error message.

4 Click the Auto-start Web Client check box if you want to automatically start a local instance of 
the Siebel Web Client when the compile process finishes.

When this option is checked and the Web Client is already open, the client is refreshed with 
changes and opens with same view that was displayed before the compilation.

To automatically start the Web Client, you need to have specified the location of the Siebel 
executable, the application configuration file, and other relevant settings in the Development 
Tools Options dialog box. For information on how to do this, see “Setting Debug Options” on 
page 72.

5 Click Compile.

The objects in your repository are compiled to the SRF file you specified. The changes are 
immediately available in any instances of the Web Client that are reading the SRF file. See 
“Testing Changes on Your Local Machine” on page 167.
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Using the Advanced Compile Option
The Advanced Compile option in Siebel Tools prefixes strings with characters to make the strings 
easier to find, and inserts dummy strings where translations are missing. It is accessed by holding 
down the SHIFT key when choosing Compile Projects from the Tools menu, which causes the Object 
Compiler dialog box to appear with the Advanced button visible.

For more information, see “About the Advanced Compile Option” on page 228.

Compiling Single Objects or Groups of 
Objects
You can compile a single object or a group of top-level objects of the same type. For example, if you 
modify the UI for several applets, rather than compiling entire projects, you can compile only the 
applets that have changed.

NOTE: Some repository objects must be in the production database to function correctly. By default, 
these objects have their No Compile flag set to TRUE, thus, they do not get compiled into the (.srf) 
file. Of particular interest are those objects that can be configured. These include Assignment 
Objects and their children, Workflow Policy Objects and their children, Dock Objects and their 
children, and EIM Interface Table objects and their children. Other objects that are not configurable 
but still need to be present in the production database for customer to use various Admin and Batch 
processes include Schema Maintenance objects, Server Component objects, and User Key Attribute 
objects.

To compile single objects or a group of objects

1 In the Object List Editor, select an object or group of objects of a given object type (for example, 
applet).

2 Right-click, and then choose Compile Selected Objects.

The Object Compiler dialog box displays the list of selected objects.

3 In the Object Compiler dialog box, click Browse, and then select the appropriate SRF file.

4 Click Compile.

The objects are compiled to the SRF file you specified. The changes are immediately available in 
any instances of the Web Client that are reading the SRF file. For more information, see “Testing 
Changes on Your Local Machine” on page 167.

Command-Line Interface for Import, 
Export, and Compilation
The command-line interface for import, export, and compiling is invoked from the siebdev 
executable, using these command switches: /batchimport, /batchexport, and /bc. The executable 
file siebdev.exe is located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation 
directory.
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Batch Import
The syntax of the /batchimport switch is as follows:

/batchimport <"siebel repository"> <Import Mode - i.e. Overwrite, Merge, Skip> <Sif 
File1, Sif File2, Sif FileN - or Directory containing .sif files> <Log File>

You can specify the archive (SIF) file and the log file by the full path or relative path to the current 
directory.

The following sample import command imports import1.sif located in the parent directory and 
import2.sif located in the Siebel Tools installation directory into the Siebel repository using the 
overwrite mode. This command also logs the results to import.log.

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" overwrite ..\import1.sif "C:\Program 
Files\Siebel\8.0\Tools\import2.sif" import.log

The following sample import command imports all files under C:\Program 
Files\Siebel\8.0\Tools\importfiledir into the Siebel repository using the merge mode. This command 
also logs the results to import.log.

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" merge "C:\Program Files\Siebel\8.0\Tools\importfiledir" import.log

Batch Export
For export, the command-line interface provided by the /batchexport switch accepts an input file 
that specifies export objects.

The input file takes a comma-delimited format of Object Type, Object Name Search Expression, and 
the SIF file name. The search expression takes any Siebel Tools accepted query criteria. To specify 
the archive (.sif) file, you can use the absolute file path or the relative file path to the current 
directory.

You can place multiple lines in the input file, each requesting to export multiple objects into one SIF 
file. However, if you specify the same (.sif) export file in multiple lines, only the last export will take 
effect, and the previous exports will be overwritten.

As an example, the following content, in an input file, requests the batchexport switch to export all 
business components whose name is like *Account* into the export.sif file.

"Business Component,*Account*,export.sif"

NOTE: There must be no space before and after commas.

The syntax for /batchexport switch is as follows:

/batchexport <"siebel repository"> <Input File Name> <Log File>

The following sample export command would export objects specified in the input file, obj.txt. This 
command will also log results into the export.log file.

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchexport "siebel 
repository" obj.txt export.log
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Compilation
The syntax of the /bc switch is as follows:

/bc <Repository Name> <SRF Name>

An example of a compilation command that compiles the Siebel repository into siebel.srf is shown 
below:

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /bc "siebel repository" 
Siebel.srf

If no file path is specified for the.srf file, the file will be compiled into the objects directory under 
Siebel Tools, otherwise, it will be compiled into the specified directory.

Batch Patch
The syntax for the batch patch command-line entry is as follows:

siebdev.exe /u sadmin /p sadmin /d local-dest /applybatchpatch <Siebel Repository 
Name> <Directory that contains the patch files> <Log File Name>

Incremental Import
The syntax for the incremental import command-line entry is as follows:

eximsif.exe /u sadmin /p db2 /d db224001 /A ie /t SIEBEL /f g:\testSifs /R "exp-imp-
0" /n 1 /l ie-0.log /i input.txt

Testing Changes on Your Local Machine
For testing purposes, you must have an instance of the Siebel Mobile Web Client installed on your 
machine. After you compile repository changes to an SRF file, local instances of the Mobile Web Client 
that are open and are reading the SRF file automatically close and then reopen, displaying the 
updated configuration.

For information on installing the Mobile Web Client, see the Siebel Installation Guide for the operating 
system you are using.

When compiling objects and testing the results locally, consider the following:

■ If a local instance of the Web Client is installed but it is not open, you can select an option in the 
Object Compile dialog box to automatically open a local Web Client and read the most current 
repository. For more information, see “Compiling Projects” on page 164.

■ For repository changes to appear in local instances of the Web Client, the Web Client must be 
reading the SRF file to which you compiled.
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11 Working with Archive Files

This chapter describes how to work with archive (SIF) files. It contains the following topics:

■ “About Archive Files” on page 169

■ “Exporting Objects to an Archive File” on page 171

■ “Exporting Objects to an Archive File Using the Command-Line Interface” on page 171

■ “About the Application Deployment Manager (ADM)” on page 172

■ “Exporting Objects to a Hot-Fix” on page 172

■ “Exporting Objects to a Hot-Fix Using the Command-Line Interface” on page 173

■ “Generating a Mid-Level Release” on page 175

■ “Process of Importing Objects from an Archive File” on page 177

■ “Preparing the Target Repository for Import from an Archive File” on page 177

■ “Importing Objects from an Archive File” on page 177

■ “About the Import Wizard - Review Conflicts and Actions Dialog Box” on page 180

■ “Importing Objects from an Archive File Using the Command-Line Interface” on page 182

About Archive Files
You can export objects from the repository to an archive (SIF) file and then import objects from the 
archive file back into the repository. Use archive files when you want to back up sets of objects or 
move sets of objects to another environment that shares the same physical database schema as the 
source environment.

Archive files are database-independent because they only represent repository information. You can 
use them to exchange repository data between environments with different database platforms, 
including local and server databases, as long as the databases have the same schema.

You can include individual objects or entire projects in archive files.

Archive files can be controlled by source-control software. When importing objects from an archive 
file, you can specify conflict resolution rules at the object level, directing Siebel Tools to ignore an 
imported object, replace an existing object with an imported one, or merge the two on a property-
by-property basis.

If you need to back up or move the entire repository to another environment, see “About Exporting 
and Importing Repositories” on page 187.
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SIF files are written in XML format. Their structure is a hierarchy of the objects archived, listing all 
of their properties and including any associated scripts: Repository > Project > Object > Child 
Objects. An excerpt from a SIF file generated by adding objects to a hot-fix is given below (see 
“Exporting Objects to a Hot-Fix” on page 172).

<REPOSITORY

NAME="Siebel Repository"

... >

<PROJECT

...

NAME="Account (SSE)"

... >

<APPLET

ASSOCIATE_APPLET="Account Assoc Applet"

BUSINESS_COMPONENT="Account"

CLASS="CSSFrameListBase"

...

NAME="Account List Applet"

... >

<APPLET_METHOD_MENU_ITEM

... >

</APPLET_METHOD_MENU_ITEM>

...

</APPLET>

<BUSINESS_COMPONENT

CACHE_DATA="N"

CLASS="CSSBusComp"

... >

</BUSINESS_COMPONENT>

...

</PROJECT>

</REPOSITORY>
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Exporting Objects to an Archive File
You can use archive files to export top-level objects such as business components, applets, views, 
and projects to an archive file. Child objects are exported and imported along with their parents. You 
can select an entire project to export or individual objects within a project. When selecting individual 
objects to export, you select all objects of a given object type. For example, first you select all the 
applets you want export, then you can navigate to a second object type to select additional objects, 
and so on.

When exporting repositories, consider the following:

■ Archive files can be exported and imported only among repositories with the same repository 
schema definition.

■ Do not export the Repository Object to export an entire repository. The resulting export file will 
be too large and performance will be slow. Instead, use the task described in “Supported Source 
and Target Databases for Importing and Exporting Repositories” on page 187.

To export objects to an archive file

1 In the Object Explorer, navigate to the object type you want to export.

2 In the Object List Editor, select the object or objects you want to archive.

3 Choose Tools > Add To Archive.

The Export to Archive File dialog box appears.

Status messages appear showing which child objects are being included. When the process 
completes, the selected top-level objects appear in the Objects to Archive list in the Export to 
Archive File dialog box.

4 If you need to add objects of another object type, navigate to that object type in the Object 
Explorer without closing the Export to Archive File dialog box.

5 Repeat Step 2 through Step 4 for each object you want to archive. 

6 When you are finished adding objects to the list, in the Export to Archive file dialog box, enter 
the path and filename of the archive file you want to create. 

7 Click Save. 

A SIF file (archive file) is created in the location you selected.

Exporting Objects to an Archive File 
Using the Command-Line Interface
You can export objects using the command-line interface. You invoke the command-line interface 
from the siebdev executable, using the command switch /batchexport. The executable file 
siebdev.exe is located in the SIEBEL_TOOLS_ROOT\BIN directory.

The syntax of the /batchexport switch is:
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siebdev /c <config file> /d <database> /u <user name> /p <password> /batchexport 
<Repository Name> <Input File Name> <Log File>

The command-line interface provided by the /batchexport switch accepts an input file that specifies 
export objects. The input file takes a comma-delimited format of Object Type, Object Name Search 
Expression, and the .sif file name. The search expression takes any Tools accepted query criteria. To 
specify the SIF file, you can use an absolute file path or a relative file path to the current directory.

You can place multiple lines in the input file, each requesting to export multiple objects into different 
SIF file. However, if you specify the same SIF export file in multiple lines, only the last export takes 
effect—the previous exports will be overwritten.

For example, consider the following sample text from an input file. Using this file as input, the switch 
/batchexport would export all business components where the Name property is like “*Account*” 
into a repository file named exports.sif:

"Business Component,*Account*,export.sif"

NOTE: There must be no spaces before or after commas.

The following sample export command would export objects specified in the input file, obj.txt. It also 
logs results into export.log:

siebdev /c tools.cfg /d sample /u sadmin /p sadmin /batchexport "siebel repository" 
obj.txt export.log

About the Application Deployment 
Manager (ADM)
The Application Deployment Manager (ADM) is used to administer the deployment of application 
customizations. Siebel Tools version 8.0 has enhanced support for ADM through the business service 
Siebel Tools Export Support for ADM, allowing you to export individual objects to a hot-fix, or all 
objects changed after a certain date and time to a mid-level release.

For more information on ADM, see Siebel Application Deployment Manager Guide.

Exporting Objects to a Hot-Fix
You can add an object to a hot-fix by right-clicking on it in the Object List Editor and then choosing 
Add to Hot-Fix.

After successful generation of the hot-fix, a subdirectory is created in SIEBEL_TOOLS_ROOT\ADM 
that contains a SIF file, an XML description of the hot-fix contents, and a log file.

NOTE: Task and Workflow Process objects can only be exported if their status is Completed.

To add objects to a hot-fix

1 Select an object in the Object List Editor.
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2 Right-click, and then choose Add to Hot-Fix.

The Generate Hot-Fix dialog box appears, with the selected object in the Objects to include in 
Hot-Fix list.

3 Repeat Step 1 and Step 2 to add more objects to the hot-fix, if desired.

4 Fill in the Hot-Fix Label field.

5 Click Export.

A Siebel message appears stating that the hot-fix has been successfully created in 
SIEBEL_TOOLS_ROOT\ADM\<Hot-Fix Label>.

6 Click OK.

Exporting Objects to a Hot-Fix Using the 
Command-Line Interface
There are two methods supported for command-line export of objects to a hot-fix:

■ Passing all of the arguments in the command line

■ Passing some of the arguments in the command line and the remainder in an XML file
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Passing All of the Arguments in the Command Line
You invoke the command-line interface from the consoleapp executable, located in the 
SIEBEL_TOOLS_ROOT\BIN directory.

The syntax is:

consoleapp <SIEBEL_TOOLS_ROOT\BIN\ENU\ConfigFile.cfg> <Language> <Username> 
<Password> "BusinessServiceName" “MethodName:<ArgumentList>"

For example:

consoleapp "C:\Siebel\8.0\Tools\BIN\ENU\tools.cfg" ENU SADMIN SADMIN "Siebel Tools 
Export Support for ADM" "Export:Repository=Siebel Repository,
LogFile=C:\Siebel\8.0\Tools\ADM\admtest\admtest.log,
ExportFile=C:\Siebel\8.0\Tools\ADM\admtest\admtest.sif,
DescriptorFile=C:\Siebel\8.0\Tools\ADM\admtest\admtest_desc.xml,Object_1=Account 
List Applet,Type_1=Applet,ExportCount=1"

NOTE: There must be no spaces before or after commas.

Passing Some of the Arguments in an XML File
The process is similar to that in “Passing All of the Arguments in the Command Line,” but instead of 
naming the business service, method name, and providing a list of arguments, you use the /f switch 
and provide an XML file with the business service and method name parameters.

The syntax is:

consoleapp <SIEBEL_TOOLS_ROOT\BIN\ENU\ConfigFile.cfg> <Language> <Username> 
<Password> /f <ExportArgFile.xml>

For example:

consoleapp "C:\Siebel\8.0\Tools\BIN\ENU\tools.cfg" ENU SADMIN SADMIN /f 
“C:\Siebel\8.0\Tools\ADM\admtest2\exportargs.xml”

where the XML file contains the following:

<BusinessService Name="Siebel Tools Export Support for ADM" Method="Export”>

<Param Name=”Repository” Value=”Siebel Repository”/>

<Param Name=”LogFile” Value=”C:\Siebel\8.0\Tools\ADM\admtest2\admtest2.log”/>

<Param Name=”ExportFile”Value=”C:\Siebel\8.0\Tools\ADM\admtest2\admtest2.sif”/>

<Param Name=”DescriptorFile” 
Value=”C:\Siebel\8.0\Tools\ADM\admtest2\admtest2_desc.xml”/>

<Param Name=”ExportCount” Value=”3”/>

<ExportObjects>

<Object Name="Account List Applet" Type=”Applet”/>
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<Object Name="Account" Type="Business Component"/>

<Object Name="Contact" Type="Business Component"/>

</ExportObjects>

</BusinessService>

Generating a Mid-Level Release
You can export all objects changed after a certain date and time from the Tools menu in Siebel Tools. 
The date and time are set on the General tab of the Development Options under the View menu.

After successful creation of the mid-level release, a subdirectory is created in 
SIEBEL_TOOLS_ROOT\ADM that contains a SIF file, an XML description of the mid-level release 
contents, and a log file.

NOTE: Task and Workflow Process objects can only be exported if their status is Completed.

To generate a mid-level release

1 From the Tools menu, choose Generate Mid-Level Release.

The Generate Mid-Level Release dialog box appears.
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2 Fill in the Mid-Level Release Label field, and then click Generate List.

The Objects to include in Mid-Level Release list is populated.

3 To remove an object from the list, select it and then press DELETE. You can select multiple 
objects by holding down the CTRL key.

A Siebel message appears asking if you really want to delete the selected objects.

4 Click Yes.

The objects are removed from the list.

5 Click Export in the Generate Mid-Level Release dialog box.

A Siebel message appears stating that the mid-level release has been successfully created in 
SIEBEL_TOOLS_ROOT\ADM\<Mid-Level Release Label>.
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6 Click OK.

Process of Importing Objects from an 
Archive File
You can import objects from an archive file into a local repository.

To import objects from an archive file, perform the following tasks:

1 “Preparing the Target Repository for Import from an Archive File” on page 177

2 “Importing Objects from an Archive File” on page 177

Preparing the Target Repository for 
Import from an Archive File
You need to import into a checked-out project or projects on the local database of a client computer—
do not import to the Server database. Make sure the following conditions exist before importing:

■ The import file is accessible to the local machine by way of the network or local drives.

■ The target repository is open in Siebel Tools and is the active repository.

■ The projects that will be affected by import have been checked out to the local database. This 
includes any project that any object in the export file is assigned to.

The only exception consists of projects (or their objects) that are in the archive file, but that do 
not exist yet in the target repository. These are not checked out because they do not exist in the 
target repository.

NOTE: In some cases it may be difficult to know in advance which projects need to be checked 
out. The Import wizard informs you of any projects that were not locked but need to be. This 
occurs on the second panel of the Import wizard, after the wizard has analyzed the objects in 
the archive file and compared them to the objects in your repository. 

Importing Objects from an Archive File
After you have exported objects to an archive file, you can import them from the archive file into a 
repository. The repository from which the archive file was created and the repository into which you 
are importing must be the same Siebel release version.

To import objects from an archive file

1 Open the target repository in Siebel Tools, if it is not already open.

2 Choose Tools > Import From Archive.
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3 In the Select Archive To Import dialog box, select the archive (SIF) file, and then click Open. 

The Import Wizard - Preview dialog box appears as shown.

This dialog box identifies the projects and the nonproject top-level objects in the archive file you 
have opened, allowing you to preview the contents of the archive file. 

4 Select an option button in the Conflict Resolution area. 

To specify the default resolution for conflicts between the archive file and the target repository. 
You will have the opportunity in subsequent dialog boxes in the Import Wizard to change this 
choice for individual objects. 

Use the following table to determine your option.

Option Button Description

Overwrite the object 
in the repository

If the same top-level object is found in the archive file and target 
repository, delete the version in the target repository, along with its 
children, and replace them with the object and children from the 
archive file. 
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5 Click Next.

One of the following happens:

■ If there are objects you will be replacing or modifying and their projects are not locked, a 
warning message appears, you must cancel the import process, lock the projects, and then 
restart the Import Wizard.

■ If the objects in the SIF file already exist in the repository and no conflicts are found, no 
changes are made. A message appears saying that no conflicts were found, and that no 
changes will be made to the repository. In this case, click OK.

■ If the objects in the SIF file already exist in the repository and conflicts are found, or if the 
objects do not yet exist in the repository, the Import Wizard - Review Conflicts and Actions 
dialog box appears with information about the differences displayed. In this case, go to 
Step 6.

6 In the Import Wizard - Review Conflicts and Actions dialog box, under Conflicting Objects, select 
an object to see the differences under Object Differences and Attribute Differences.

See “About the Import Wizard - Review Conflicts and Actions Dialog Box” on page 180 for details 
about the dialog box.

7 To make an adjustment, do the following:

a Select an object or attribute difference.

b Right-click and select the action you want to occur.

8 Click Next.

The Summary window appears, and the import process starts.

Merge the object 
definitions from the 
archive with the 
definition in the 
repository

Merging is the default, and generally the safest option. When the same 
top-level object exists in both the target repository and the archive file:

■ Replace differing properties in the target top-level and child-level 
with those in the archive file.

■ Add new child objects to the target repository if they are not 
already present. 

■ Do not change child objects in the target repository that are not 
also present in the archive file.

The resulting top-level object has the same properties and children as 
the object in the archive, plus any children that were already present 
in the repository definition. 

Do not import the 
object definition 
from the archive

Do not change the objects in the target repository.

Option Button Description
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9 When the import process is completed, click Finish.

A log file named importlog.txt is created in the SIEBEL_TOOLS_ROOT\TEMP directory of your 
Siebel Tools installation directory. It contains the same list of messages that appeared in the 
Summary window. You may find it useful to store this file elsewhere for a record of what changes 
were made to the repository. It is also a good idea to change the filename so it reflects the date 
of the import.

About the Import Wizard - Review 
Conflicts and Actions Dialog Box
When the Import Wizard detects a difference between objects stored in the repository and those 
stored in the SIF file, the Import Wizard - Review Conflicts and Actions dialog box appears. You use 
this dialog box to review differences and to change the action used to resolve the conflict.

The dialog box, shown in Figure 31, is divided into three panes: the Conflicting Objects explorer 
control, the Object differences list, and the Attribute differences list.

Conflicting Objects Explorer
The Conflicting Objects Explorer displays the hierarchy of objects for which there are differences. The 
hierarchy displayed mirrors the object type/object definition hierarchy in a Siebel repository, but 
shows only conflicts to resolve rather than all repository or archive objects.

Figure 31. Import Wizard - Review Conflicts and Actions
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Object Differences List
The Object Differences list displays objects, one for each row. For each object it shows whether it 
exists only in the archive file, only in the target repository, or in both, and what resolution is 
specified. You can change the resolution here.

The objects displayed in the Object Differences dialog box include those at all hierarchical levels, not 
just top-level objects. This lets you make adjustments to the resolution for any affected objects.

The File and Repository columns indicate whether each identified object is present in the archive file 
or target repository. An “X” indicating the object’s presence can appear in the File list column, the 
Repository list column, or both. These list columns are for information only; you cannot change the 
check marks.

The Action list column indicates the proposed resolution for each object in the list. This setting is 
initially generated for each object from the default behavior selected in the Conflict Resolution option 
buttons in the Preview pane. You can right-click on the value in the Action list column and select a 
different value from a shortcut menu. The available selections include the following:

■ File. Equivalent to the Overwrite the object definition in the repository selection in the previous 
dialog box.

■ Merge. Equivalent to the Merge the object definitions from the archive with the definition in the 
repository option in the previous dialog box.

The resulting top-level object has the same properties and children as the object in the archive, 
plus any children that were present in the repository definition. 

■ Repository. Equivalent to the Do not import the object definition from the archive option in the 
previous dialog box.

For more information about these options, see “Importing Objects from an Archive File” on page 177.

Attribute Differences List
The Attribute Differences list displays the property value conflicts for the currently selected object in 
the Object Differences dialog box. Those properties are listed only where there is a conflict.

Table 40 describes the columns in the list.

Table 40. Columns in the Attribute Differences List

Column Description

Attribute Name of the property.

File Value of the property in the archive file version of the object.
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Importing Objects from an Archive File 
Using the Command-Line Interface
You can also import objects using the command-line interface. You invoke the command-line 
interface from the siebdev executable, using the command switch /batchimport. The siebdev.exe 
executable file is located in the SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation 
directory.

The syntax of the /batchimport switch is:

siebdev.exe /c <config file> /d <database> /u <user name> /p <password> /batchimport 
<Siebel Repository name> <Import Mode> <.sif file1, .sif file2, .sif fileN; or 
directory where SIF files can be found> <log file>

NOTE: You can specify the SIF file and the log file by the full path or the relative path to the current 
directory.

For example, the following sample import command imports import1.sif, located in the parent 
directory, and import2.sif, located in the Siebel Tools installation directory, into the Siebel repository 
using the overwrite mode. It also logs the results to import.log:

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" overwrite ..\import1.sif "C:\Program 
Files\Siebel\8.0\Tools\import2.sif" import.log

The following sample import command imports all files under C:\Program 
Files\Siebel\8.0\Tools\importfiledir into the Siebel repository using the merge mode. It also logs the 
results to import.log:

siebdev.exe /c tools.cfg /d sample /u sadmin /p sadmin /batchimport "siebel 
repository" merge "C:\Program Files\Siebel\8.0\Tools\importfiledir" import.log

Repository Value of the property in the target-repository version of the object.

Resolution Value of either File or Repository for each property, depending on whether the 
archive-file or target-repository version of the object is to determine the value 
of the property in the final definition.

This list column can be updated only if the object whose properties are being 
displayed has an Action setting of Merge in the Object Differences list. 
Otherwise, the shortcut menu options are read-only and are unavailable, and 
the value displayed is the same as that in the Action column of the Object 
Differences list.

To change the Resolution value from Repository to File or the reverse, right-
click on the Attribute row to change and then choose Repository or File from 
the shortcut menu.

Table 40. Columns in the Attribute Differences List

Column Description
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12 Managing Repositories

This chapter describes how to manage repositories. It contains the following topics:

■ “About Repositories” on page 183

■ “Viewing Which Repository Is Currently Open” on page 184

■ “Reviewing Information About the Current Repository” on page 184

■ “Guidelines for Naming Repositories” on page 185

■ “Renaming Repositories” on page 186

■ “Deleting Repositories” on page 186

■ “About Exporting and Importing Repositories” on page 187

■ “Exporting and Importing Repositories Using the Database Configuration Wizard” on page 188

■ “About Repository Patch Files” on page 191

■ “Creating Repository Patch Files” on page 192

■ “Applying Repository Patch Files” on page 194

■ “Upgrading Repositories” on page 195

About Repositories
The Siebel repository refers to the set of tables in which Siebel objects and server scripts are stored. 
The set of objects and server scripts stored in the repository define a Siebel application (such as 
Siebel Service or Siebel Sales) and are compiled into a compressed file called a Siebel repository file 
(SRF file). You use Siebel Tools to view data in the Siebel repository.

The Siebel repository is populated with data during the installation process. For more information, 
see the Siebel Installation Guide for the operating system you are using.

The SRF file is a compressed file that contains a compiled version of the Siebel repository. Siebel 
applications read the SRF file at run time. It provides the Siebel applications with much of the 
metadata it needs to define interactions with the enterprise data and software users.

CAUTION: Use only one Siebel repository in production. Siebel products have been designed on the 
assumption that the compiled Siebel SRF and Siebel repository table data are synchronized. If you 
try to use multiple Siebel repositories in production, you will get unpredictable behavior.

NOTE: Browser scripts are compiled into the browser script compilation folder, which can be 
specified in Siebel Tools on the Scripting tab under View > Options.
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Viewing Which Repository Is Currently 
Open
Under normal circumstances there is only one repository available on your local database, and one 
available on the server database for your development workgroup. Typically this repository (in either 
location) is called the Siebel repository and is opened by default when you open Siebel Tools and log 
on to the local or server database. However, there are circumstances—especially when your group is 
in the process of upgrading to a new version of Siebel Business Applications—in which multiple 
repositories can be present, especially on the server. 

To view which repository is currently open
■ Choose File > Open Repository.

The Open Repository dialog box appears and lists all repositories in the database to which you 
are connected. 

Reviewing Information About the 
Current Repository
The About SRF option on the Siebel Tools Help menu provides version, compilation, and path 
information about the current repository.

To review information about the current repository
■ In Siebel Tools, choose Help > About SRF.

The About Repository File window appears and displays the following information.

Field/Button Description

Internal version Version number maintained internally at Oracle that changes only when the 
internal format of the SRF file changes, such as at the time of a major 
release. It has no significance for customer developers.

User version Reserved for use by Oracle’s Siebel Anywhere, which maintains this number 
when kits are created that upgrade the SRF file. The value is read when a 
version check occurs.

Full compile 
option button

Select to display information about the most recent full compilation in the 
Compile Information fields.

Last incremental 
compile option 
button

Select to display information about the most recent incremental 
compilation. If there have been no incremental compilations since the last 
full compilation, this option button is unavailable.

When Date of the last compilation—incremental or full, as specified in the option 
buttons.

Machine name Name of the client computer on which the SRF file was compiled.
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Guidelines for Naming Repositories
You must establish and maintain a naming convention for all repositories in their respective 
environments. There are several dependencies on repository names—for example, Siebel servers 
point to a specific repository by name. Also, the procedures for upgrading to new versions of Siebel 
Business Applications depend on repository names. 

A consistent naming convention promotes successful configuration and testing while it minimizes the 
work required to migrate new repositories or perform upgrades. Follow these guidelines when 
determining the naming conventions for your repositories:

■ Use the default name, Siebel Repository, whenever possible. Change this only if you have a 
compelling reason, because the default configuration of Siebel Business Applications and Siebel 
documentation assumes this name is being used.

■ Use the same repository name for the active repository in your test environment and for the 
current working repository in your production environment. Using the same name simplifies the 
process of migrating repositories from development to test and from test to production. It also 
eliminates the need to change your client or application server configurations when you perform 
the migration process.

■ Use descriptive names for the other repositories in your development environment. Typically, 
your development environment has a number of repositories in addition to the current repository 
that is being configured. These may include the initial repository loaded with your Siebel 
application, other repository versions used in Siebel application upgrades, and repositories from 
previous versions of your custom configuration. Give these repositories unique and fully 
descriptive names—for example, Siebel v8.0 Original for the initial repository shipped with Siebel 
Business Applications version 8.0.

Language Language code of the language specified for user interface translation.

User name User name (that is, the Microsoft Windows logon name) of the user who 
compiled the repository.

Repository Repository name of the repository that was current when the compilation 
was run, generally Siebel repository.

Tools version The version number and build number of the Siebel Tools software used to 
compile the repository. This is useful information for Siebel Technical 
Services if they are helping you in resolving a problem with your 
configuration.

Schema version Database schema version of the database from which the repository was 
compiled.

File name Name and path of the SRF file being used internally to define the Siebel 
Tools application, located in SIEBEL_TOOLS_ROOT\OBJECTS.

Field/Button Description
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Renaming Repositories
It is recommended that you name the repository in production Siebel Repository. However, in some 
situations you might need to name the repository something different. If you must rename the 
repository, follow the steps described in this topic.

To rename a repository

1 Have all developers check in all projects that have been checked out from the repository you are 
going to rename.

2 Log into Siebel Tools and connect to the server database.

3 In the Object Explorer, select the Repository object type.

If the Repository object type is not visible, see “Showing and Hiding Object Types in the Object 
Explorer” on page 74 for more information.

4 In the Object List Editor, click in the Name property of the repository you want to rename.

5 Enter the new name, and click outside the record to save your changes.

6 Let developers know what the name of the new repository is and have them perform a Get of all 
projects.

7 After changing the name of the repository, you must also do the following:

■ Change the value of the enterprise parameter Siebel Repository to the new name of the 
repository. For information about changing enterprise parameters, see Siebel System 
Administration Guide.

■ Change the Application Main Repository Name parameter in the Object Manager.

Deleting Repositories
The delete process remove all records associated with the repository. Be sure to back up the 
repository before you delete it.

CAUTION: Deleting a repository takes a long time and requires resources such as rollback segment, 
cursors, tablespace, and so on. Consult your DBA before deleting a repository.

To delete a repository

1 In the Object Explorer, navigate to the Repository Object type.

2 In the Object List Editor, click anywhere in the row for the repository you want to delete.

3 Choose Edit > Delete Record.

4 Click outside the record to commit the Delete action.
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About Exporting and Importing 
Repositories
You can export and import the entire repository using Export/Import option in the Database 
Configuration Wizard. Use this utility when you want to back up your repository, restore your 
repository, or move all repository objects to another environment that shares the same physical 
database schema as the source environment.

If you do not need to export and import the entire repository, but need to export and import sets of 
objects only, use Siebel archive files. For more information, see “Exporting Objects to an Archive File” 
on page 171.

CAUTION: If you need to migrate a customized repository and schema from one environment to 
another, such as migrating a development environment to a test environment, do not use the Export/
Import option in the Database Configuration Wizard. Instead, you must use the Repository Migration 
Utility (dev2prod).

NOTE: After using the Repository Migration Utility, you must reset the Locked and Allow Object 
Locking columns.

For information on repository migration and the Repository Migration Utility, see Siebel Database 
Upgrade Guide and Going Live with Siebel Business Applications.

Supported Source and Target Databases for Importing and Exporting 
Repositories
The source and target databases must be configured for the same Siebel version. It is not 
recommended that you migrate a repository between two databases that are on different release or 
patch levels. Siebel applications support importing and exporting repository data from the source 
databases to the target databases listed in Table 41. 

Table 41. Code Pages and Unicode Support for Repository Import and Export

 Source Database Target Database

Code Page Code Page

Unicode Unicode

Code Page Unicode
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Exporting and Importing Repositories 
Using the Database Configuration 
Wizard
To export and import the entire repository, you use the Database Configuration Wizard. This is 
typically used for backing up and restoring and for moving the contents of a repository to a repository 
in an another environment, when both the source and the target environment have the same physical 
database schema and Siebel release version. 

For more information on launching the Database Configuration Wizard, see the Siebel Installation 
Guide for the operating system you are using.

When importing and exporting using the Database Configuration Wizard, consider the following:

■ When you are importing a custom repository (not the standard Siebel repository), all languages 
which were part of the original repository are restored during import. For example, if you archive 
repositories weekly and your development repository contains support for both ENU and DEU, 
then both ENU and DEU are included when one of the archived repositories is imported.

■ Whenever you make a change to the repository, compile all projects that belong to the latest 
version of the repository to create an updated SRF file. Keep a backup of the SRF file, so you can 
be sure the SRF file truly reflects the contents of the updated repository.

■ If you need to back up the entire content of the Siebel database, use the database utilities 
provided by your RDBMS vendor.

■ If your source repository is customized use the Migrate option of the Database Configuration 
Wizard.

For more information on migrating repositories, see Going Live with Siebel Business Applications.

NOTE: When exporting a repository in a Windows or UNIX environment using the Export Repository 
option of the Database Configuration Wizard, the log files are placed in following directories:

■ SIEBSRVR_ROOT\log\exprep\output

■ SIEBSRVR_ROOT\log\exprep\state

NOTE: The value “exprep” is the default process name for the exprep utility. You can change this 
value to facilitate ease of use.

For information on importing or exporting repositories, see “To import a repository in a Windows 
environment” on page 189 or “To import a repository in a UNIX environment” on page 190 depending 
on your operating system.

The importing procedures apply to both importing and exporting, although they present only the 
importing case. Exporting is similar, in that you identify the repository to export instead of the one 
to import.

When exporting a repository using the Database Configuration Wizard, all the values specified in the 
dialog boxes are written to the SIEBSRVR_ROOT\master_exprep.ucf file. After the parameters are 
collected, you are prompted to execute the export now or not. If you choose to not export now, you 
can execute the export later by running the following command in the command line:

siebupg.exe /m master_exprep.ucf
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To import a repository in a Windows environment

1 Stop all Siebel Servers by navigating to Start > Settings > Control Panel > Services.

NOTE: The Database Configuration Wizard runs in live mode only so you must be connected to 
the Gateway Name Server to run it. For further information on Siebel Configuration Wizard 
running modes, see the Siebel Installation Guide for the operating system you are using.

2 Select Start > Programs > Siebel Enterprise Server Configuration 8.0 > Database Server 
configuration.

The first screen of the Database Configuration Wizard appears.

3 Enter the information you are prompted for in each screen, and click Next to continue.

4 Select Import Repository when prompted for a database operation.

5 Specify that you want to import the standard Siebel 8.x repository.

6 When the Configuration is Complete screen appears, select one of the following options, and click 
Next:

■ Yes apply configuration changes now. The configuration information you entered is 
saved and you can choose to launch the Siebel Upgrade Wizard in Step 9.

■ No I will apply configuration changes later. The configuration information is saved but 
you can not choose to launch the Siebel Upgrade Wizard in Step 9.

7 On the Configuration Parameter Review screen, review the configuration values you entered on 
the previous screens. To change any of the values, click Back to return to the screen with the 
parameter you need to change. If the values are correct, click Next to continue.

8 You are prompted as to whether you want to execute the configuration:

■ Click No if you decide you do not want to continue with the upgrade process.The configuration 
information you have entered is not saved. You must enter the database configuration 
parameters again.

■ Click Yes to continue. The configuration information you have entered is saved.

9 Depending on the option you selected in Step 6, do one of the following:

■ If you selected the No I will apply configuration changes later option, click OK to finish. 
The configuration information is saved in a master file located in SIEBEL_ROOT\bin but the 
Upgrade Wizard is not launched. You can restart the configuration and run the Upgrade 
Wizard later. For more information on the Upgrade Wizard, see the Siebel Database Upgrade 
Guide.

■ If you selected the Yes apply configuration changes now option in Step 6, the 
configuration information you entered is saved. Click OK and the Siebel Upgrade Wizard is 
launched; it calls the SQL generator to create or populate SQL scripts.

To export a repository in a Windows environment
■ Follow the same as procedure as for importing a repository, but select Export Repository in 

Step 4.
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To import a repository in a UNIX environment

1 Verify that the Siebel Server is stopped.

NOTE: The Database Configuration Wizard runs in live mode only so you must be connected to 
the Gateway Name Server to run it. For further information on Siebel Configuration Wizard 
running modes, see the Siebel Installation Guide for the operating system you are using.

2 Make $SIEBEL_ROOT the current directory.

3 Source environment variables:

■ Korn: . siebenv.sh

■ C shell: source siebenv.csh

4 Review the values of the following environment variables and confirm the settings are correct:

■ SIEBEL_ROOT. This path must end in siebsrvr, for example /usr/siebel/siebsrvr.

■ LANGUAGE. This is the language in which the Database Configuration Wizard runs. The value 
of this variable is a language identifier string. For example, enu is the identifier string for 
English.

If either $SIEBEL_ROOT or $LANGUAGE is not set or is incorrect, you must correct them before 
proceeding.

5 Start the Database Configuration Wizard by running the following command:

$SIEBEL_ROOT/bin/ssincfgw -args MODEL_FILE=$SIEBEL_ROOT/admin/dbsrvr.scm 
MODE=LIVE

The first Database Configuration Wizard screen appears. Enter the information you are prompted 
for in this screen, and click Next to continue.

6 Enter the information you are prompted for in all subsequent screens. Use the Next and Back 
button to navigate between screens.

7 Select Import Repository when prompted for a database operation.

8 Specify that you want to import the standard Siebel 8.x repository.

9 After you have entered all the requested information, the wizard displays the following message: 

Configuration is complete: configuration parameters will be saved to 
<$Masterfile> file when the wizard completes. Please run the following command 
line after you exit from this configuration wizard. This command will deploy the 
process you configured to the database.

$SIEBEL_ROOT/siebsrvr/bin/srvrupgwiz /m $SIEBEL_ROOT/siebsrvr/bin/<$Masterfile>

10 Click Next to continue. The utility displays the Parameter Review screen listing all the values you 
have entered.

11 To amend any of the configuration values, click Back to return to the appropriate screen and 
make changes. Otherwise, click Next.

12 You are prompted as to whether or not you want to execute the configuration:
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■ Click Yes, and the configuration information is saved in a master file located in 
$SIEBEL_ROOT/bin but the Upgrade Wizard is not launched. For more information on starting 
the Upgrade Wizard, see the Siebel Database Upgrade Guide.

■ Click No, and the configuration information you entered is not saved.

To export a repository in a UNIX environment
■ Follow the same as procedure as for importing a repository, but select Export Repository in Step 7 

on page 190.

About Repository Patch Files
A repository patch file, like an archive file, consists of exported objects. The difference between a 
patch (SPF) file and an archive (SIF) file is that the patch file contains two versions of each object, 
one from the preupgrade source repository and one from the postupgrade. An archive file contains 
only one version of each object, and all objects are from the same repository.

For information on archive (SIF) files, see “About Archive Files” on page 169.

Figure 32 shows how pre- and postupgrade versions of an object are paired in the patch file, and 
then used when applying the patch to the target repository.

Figure 32. How a Patch Works
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The pair of pre- and postrelease objects in the patch file provide before and after snapshots of the 
object. The patch application process considers both when determining what changes to make to the 
target repository.

Related Topics
“Creating Repository Patch Files” on page 192

“Applying Repository Patch Files” on page 194

Creating Repository Patch Files
A wizard steps you through the process of creating a patch file.

To create a repository patch file

1 Make sure that both the original source and the modified source repositories are present on the 
client computer. 

2 If you are building a patch file from an archive file, go to Step 3; Otherwise, choose 
File > Open Repository and then select the modified source repository.

3 Choose Tools > Utilities > Build Patch.

The Build Patch - Setup dialog box appears.
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4 Under Select modifications, make your selection using the following table.

5 From the Repository drop-down list, choose the name of the original source repository.

6 In the Patch File field, click Browse to specify a path name and filename for the patch file to 
create.

Option Button Description

Changed objects in current 
repository

Allows you to generate the set of source objects in the patch 
file from all objects in the currently open (modified source) 
repository that have a value of TRUE in their Changed 
property. The Changed property indicates changes to 
property values or child objects for all objects that have 
changed since a specified date. This is an easy way to capture 
all objects that have changed since the start of work on the 
new release.

NOTE: This is useful for creating cumulative patch files—that 
is, if several patches are created over time, each successive 
patch includes all the changes in the previous patches, in 
addition to the most recent changes, as long as the Changed 
Indicator Date is not modified. Keeping the Changed Indicator 
Date accurate during the patch development cycle is critical 
to accumulating all the changes applicable to the patch. 

Archive file Allows you to use an existing archive file to generate the 
same set of objects in the patch file. Use this option when the 
set of patch objects is identical to a recently exported archive 
file, or when you want to explicitly select individual top-level 
objects to be included. In this latter case, generate the 
archive file prior to generating the patch file. Building a patch 
from an archive file may also be preferable when there are 
too many objects with a Changed value of TRUE.

Use the File Name field to specify a pathname and filename 
for the archive file and click the Browse button and select the 
archive file.
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7 Click Next. 

The Build Patch - Summary dialog box appears.

If you selected the Archive file option, the list of objects for the patch loads immediately. 

If you selected the Changed objects option, Siebel Tools pauses while it generates the list 
because it needs to scan through the repository and check all the Changed property values.

8 Click Finish.

The patch file is generated in the directory location you specified in Step 4 on page 193. 

Applying Repository Patch Files
The patch upgrades the repository to which it is applied, similar to the way the Application Upgrader 
upgrades the repository. The difference is that you do not have the opportunity to override the 
default conflict resolution rules. A conflict only occurs if an object property changes in both the 
source and the target repositories simultaneously.

For example, if you create a new Account field based on an extension column in the target repository, 
and then apply a patch from the source repository that includes the Account business component, 
the new field will not be overwritten in the target repository because the same new field has not been 
added in the source.

If you change the sort specification of the Account business component in the target repository, and 
the sort specification has not changed in the source, the new sort specification in the target will 
remain. However, if the sort specification has changed in both the source and the target, then a 
conflict arises for which a resolution is required.

To view the default conflict resolution rules

1 In the Object Explorer, navigate to the Type object type.

2 In the Object List Editor, select an object.

3 In the Object List Editor, expand the Type object type and select Attribute.
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4 Review the Attribute property Siebel Wins (or Standard Wins in the Object List Editor).

If this is set to TRUE, the value in the source repository is accepted.

If FALSE, the value in the target repository is accepted.

To apply a patch

1 In Siebel Tools, choose Tools > Utilities > Apply Patch.

The Select Patch to Apply dialog box appears.

2 Select the Siebel Patch (SPF) file, and then click Open.

The Apply Patch - Preview dialog box appears, and the patch is opened.

3 Click Next.

The Apply Patch - Summary dialog box appears. The patch is loaded, the patch objects are 
compared to their corresponding repository objects, and then the patch is applied.

4 Click Finish to exit.

Upgrading Repositories
The Siebel Application Upgrader reduces the time and cost of version upgrades by allowing you to 
acquire new features from the latest release while preserving the custom configuration changes 
made to the current repository. It notifies system administrators about conflicts between object 
customizations and new releases, automatically merges differences between objects, and allows you 
to manually override and apply any changes.

The Siebel Application Upgrader allows you to upgrade custom configurations to new releases by 
merging them with a current Siebel Business software release. This capability minimizes the cost of 
application upgrades and allows you to quickly deploy production versions of Siebel Business 
Applications.

The Application Upgrader allows you to accomplish the following:

■ Determine what has changed with new releases of Siebel Business Applications.

■ Compare custom configurations with new changes delivered in a new Siebel release.

■ Choose which changes to apply, whether made by your company’s developers or by Oracle in the 
new release.

■ Merge versioned objects—tasks and workflow processes.

Versions 1 through n from the prior customized repository are copied to the new customized 
repository. They are merged with version 0 from both the prior standard repository and the new 
customized repository; the result becomes version n + 1 in the new customized repository.

NOTE: The Application Upgrader is for merging an entire customized repository with a standard one. 
To merge portions of repositories, use the Import/Export or Patch features.

For more information about the Application Upgrader, see the Siebel Database Upgrade Guide for the 
operating system you are using.
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To upgrade a Siebel Business Application

1 From the Tools menu, choose Upgrade > Upgrade Application.

The Application Upgrader appears, with the Merge Repositories dialog box active.

2 Choose the repositories to merge, and then click Merge.

The upgrade process begins, with object and attribute differences being shown in their respective 
windows.

NOTE: Object and attribute differences between different versions of tasks and workflows will 
also be shown.
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13 Working with Strings and Other 
Locale-Specific Data

This chapter describes how to work with strings and other locale-specific data. It contains the 
following topics:

■ “About the Symbolic Strings Model” on page 198

■ “Checking In and Checking Out Symbolic Strings” on page 199

■ “Creating Symbolic Strings” on page 199

■ “Modifying Symbolic Strings to Globally Update Display Values” on page 200

■ “Using Symbolic String References” on page 201

■ “Entering String Overrides” on page 202

■ “About Converting and Consolidating Strings” on page 203

■ “About the Symbolic String Conversion Process” on page 204

■ “About the Symbolic String Consolidation Process” on page 206

■ “Running the String Conversion Utility” on page 206

■ “Running the String Consolidation Utility” on page 211

■ “Using Batch Files to Convert and Consolidate Strings” on page 214

■ “Working with Untranslatable Locale-Specific Object Properties” on page 215

■ “Showing or Hiding Locale-Specific Items in Applet Layout” on page 217

■ “Locating Orphaned String References After Upgrade” on page 218

■ “About the Locale Management Utility” on page 219

■ “Finding Untranslated Text Strings” on page 220

■ “Finding Existing Translations” on page 221

■ “Finding Modified Objects” on page 222

■ “Exporting Text Strings and Locale-Specific Attributes” on page 222

■ “Importing Text Strings and Locale-Specific Attributes” on page 223

■ “Identifying Objects Modified Since the Last Export” on page 224

■ “Replacing Strings” on page 225

■ “Running the LMU Using the Command-Line Interface” on page 226

■ “About the Advanced Compile Option” on page 228

■ “Using the Advanced Compile Option” on page 229
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About the Symbolic Strings Model
The symbolic strings model centralizes all strings, both English and all other languages, which exist 
in the repository into one object type: Symbolic Strings. Translatable text strings are defined once 
and then referred to by multiple user interface objects. Having a centralized mechanism for storing 
and managing repository text strings:

■ Reduces redundancy because many objects can reference one symbolic string

■ Results in a more consistent user interface

■ Simplifies maintenance because you only have to maintain one string for a given word

■ Simplifies translation by eliminating duplicated translations of the same word

■ Reduces translation costs

Prior versions of Siebel Tools stored translatable text strings in the locale objects of a parent object 
type. For example, each applet had a set of child locale records that defined the text for the applet 
title that appears in the user interface.

How the Symbolic Strings Model Is Implemented
Symbolic strings are implemented using a top-level object in the Siebel repository called Symbolic 
Strings and a child object called Symbolic String Locale. Each symbolic string record represents a 
word or phrase, for example Account or Contact, and is language independent. All translations of 
that word or phrase, including English, are stored as child symbolic string locale records. User 
interface objects, such as Applets and Controls, refer to symbolic string records for text strings. The 
literal display value is compiled into the SRF from one of several translations stored as symbolic 
string locale records, based on the current Tools language mode.

The Symbolic Strings object type stores its data in S_SYM_STR table, and the Symbolic String Locale 
stores its data in S_SYM_STR_INTL table. Objects such as applets store foreign key references to 
the records stored in S_SYM_STR table. 

Strings Not Included in the Symbolic Strings Model
The symbolic strings model includes text strings stored in the repository and referenced by UI objects 
such as Control Captions, List Column Display Names, and Applet Titles. The symbolic string model 
does not include other types of strings typically supplied as seed data, such as LOVs, error messages, 
and predefined queries. 

For information on localizing these types of strings, see “About the Locale Management Utility” on 
page 219.

How Translatable String Values Are Calculated
Object properties that display translatable strings, such as the Title property of applets, are compiled 
into the SRF file during compile time according to the following logic: 

■ If a value exists in the string language in which the compile is being run, this string override 
value is compiled to the SRF. 
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■ The compile process checks to see whether a value exists in the string override field for the 
current Siebel Tools Language Mode. If there is no string value in the override field for the 
language in which the compile is being run, the value is calculated using the current language 
mode of Siebel Tools and the String Value property of the associated Symbolic String Locale 
object (child of Symbolic String). 

NOTE: In most cases, a string override does not exist.

Related Topic
“Entering String Overrides” on page 202

Checking In and Checking Out Symbolic 
Strings
The Symbolic String project is very large. Due to its size, checking in or checking out the entire 
project can be very time consuming. Thus it is not recommended that you check out the entire 
Symbolic String Project, rather, create a new project, and store all new or modified strings in that 
project.

When you want to add and work on new strings, create a new project (for example, CompanyXYZ 
New Symbolic String project) and put all your new strings in that project.

NOTE: When you create strings, they will be prefaced with the value specified in the tools.cfg file 
under the SymStrPrefix attribute. This value is set to X_ by default. For example, if you create a new 
symbolic string called NewString it will appear as X_NewString.

To modify existing strings within the Siebel repository, (denoted by the “SBL_” prefix in the Symbolic 
String Name attribute), create a new project (for example, CompanyXYZ Modified SBL_ Symbolic 
String project), select the strings you wish to modify, and put them into the new project you just 
created. This work can be facilitated by selecting the strings, then filtering out the strings you want 
to modify. You can then make a global change to the project attribute with the Change Records 
command on the Edit menu. 

CAUTION: Modifying display values for Siebel-shipped (“SBL_” prefixed strings) must be carefully 
considered as the display values are used globally across the Siebel user interface. For monolingual 
deployments, you risk modifying parts of the user interface you may not intend to modify. For 
multilingual deployments, you risk breaking associations between display values across languages. 
For this reason, it is recommend that you create a new Symbolic String with your desired text value 
as opposed to modifying existing strings.

Creating Symbolic Strings
You create new symbolic strings in Siebel Tools. Symbolic strings created by Siebel are included in 
the Symbolic Strings project. It is recommended that you create a new project to hold all custom 
symbolic strings.

NOTE: To be able to create symbolic strings, the EnableToolsConstrain parameter in the tools.cfg file 
must be set to FALSE.
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To create a symbolic string

1 Check out the project in which you want to create the Symbolic String.

2 Navigate to the Symbolic Strings object type.

3 In the Object List Editor, create a new record using the following table to complete the necessary 
fields.

NOTE: Trailing spaces, including full-width (Zenkaku) spaces in Japanese, will be truncated 
automatically.

Related Topic
“Setting the Constrain Mode for Working with Symbolic Strings” on page 76

Modifying Symbolic Strings to Globally 
Update Display Values
You can make global changes to UI display values by modifying child locale objects of symbolic 
strings. For example, your organization may require that all instances of the word Account be 
changed to Customer. Another example is configuring an industry-specific application to be deployed 
in a locale other than English. Text strings may appear in the UI that are not appropriate for the given 
industry. In both cases, you need to make global changes to text strings. 

To globally update user interface display values

1 Set your Tools Language mode to the language you want to configure.

For more information, see “Selecting a Language Mode” on page 61.

2 Navigate to the Symbolic String object type.

3 Select the symbolic string you want to modify.

4 Navigate to the Symbolic String Locale object you want to modify.

5 Change the value for the String Value property.

Property Description

Name Unique name of the symbolic string. Siebel Tools enforces a predefined 
prefix for the symbolic string name, such as X_. This helps you distinguish 
custom symbolic strings from those created by Siebel (SBL_). The value 
used for the prefix is defined in the SymStrPrefix parameter in the 
tools.cfg file.

Current String 
Value

Calculated value based on the current Tools language mode and the String 
Value property of the corresponding child Symbolic String Locale object. 

Definition Description of the symbolic string.
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6 Compile the project or projects associated with the Symbolic String.

Using Symbolic String References
Symbolic string references allow you to select translatable strings for properties such as Applet titles, 
or Application display names, from a centralized list of strings. There are two ways you can associate 
objects to symbolic string references. You can use the String Reference pick applet or you can type 
directly into the field that displays a translatable text string value.

To select a symbolic string reference using the String Reference pick applet

1 Navigate to the object and property for which you want to define a string, such as Applet Title.

2 Navigate to the Title - String reference field (in the Object List Editor) or the Title field (in the 
Properties window). 

NOTE: The string reference field name can vary, depending on the object you are working on. 
For instance, with the Applet object, the name is displayed in Siebel Tools as described above, 
but with the Application object, the fields are shown as Display Name - String Reference in the 
Object List Editor, and Display Name in the Properties window. 

3 Click the drop-down arrow in either field.

A String-Reference picklist appears. 

4 Search for the appropriate string reference, select it, and then click Pick.

After you associate the string reference, the display value is entered based on the current Tools 
language mode and the Current String Value of the corresponding symbolic string locale record.

If no existing symbolic strings meet your needs, do one of the following:

a Using the Object List Editor, close the pick applet, and enter the string override into the Title - 
String Override field.

b Using the Properties window, click the Use Override button in the pick applet, and focus is shifted 
to the corresponding String Override field in the Properties window. 

To select a symbolic string reference by typing a value into the Object List Editor

1 Navigate to the object and property for which you want to define a string, such as the Title field 
in the Applet object, or the Display Name field in the Application object.

2 Type a value into the field, then tab out of the field.

Siebel Tools searches for a string reference with a Current String Value that matches the value 
entered and one of the following occurs: 

■ If one unique match exists, that string reference is associated with the object and the display 
value is entered based on the current Tools language mode and the Current String Value of 
the corresponding symbolic string locale record.

■ If there are multiple exact matches, or a match does not exist, an error message appears. 
Click OK, and do the following: 



Using Siebel Tools Version 8.0, Rev. A

Working with Strings and Other Locale-Specific Data ■ Entering String Overrides

202 

a Click the drop-down arrow in the String References field.

The String References picklist appears. 

b Select the appropriate reference from the picklist, then click Pick. 

You may also create a new string reference or create an override. 

NOTE: To be able to create symbolic strings or enter values for string override properties, the 
EnableToolsConstrain parameter in the tools.cfg file must be set to FALSE. 

To select a symbolic string reference by typing a value into the Properties window

1 Navigate to the object and property for which you want to define a string, such as the Title field 
in the Applet object, or the Display Name field in the Application object.

2 Type a value into the field, then tab out of the field.

Siebel Tools searches for a string reference with a Current String Value that matches the value 
entered and one of the following occurs: 

■ If one unique match exists, that string reference is associated with the object, and the display 
value is entered, based on the current Tools language mode and the Current String Value of 
the corresponding symbolic string locale record.

■ If there are multiple exact matches, or a match does not exist, the String Reference picklist 
appears, allowing you to choose the appropriate record. 

You may also create a new string reference or create an override. 

NOTE: To be able to create symbolic strings or enter values for string override properties, the 
EnableToolsConstrain parameter in the tools.cfg file must be set to FALSE. 

Related Topics
“Creating Symbolic Strings” on page 199

“Entering String Overrides” on page 202

“Setting the Constrain Mode for Working with Symbolic Strings” on page 76

Entering String Overrides
Each object property that stores a translatable text string, such as the Title property of an applet, 
has a corresponding String Override field, for example Title – String Override. In cases where the 
symbolic string for a given word or phrase does not meet your linguistic requirements, you can 
override it by entering a value in the override field. Values entered into override fields are stored as 
child locale objects of the top-level object type (for example applet) for the current Tools language 
mode. Values stored in string override fields are language-specific and do not affect other references 
to the symbolic strings.

NOTE: To be able to enter string overrides, the EnableToolsConstrain parameter in the tools.cfg file 
must be set to FALSE.
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To enter a string override

1 Navigate to the object and property for which you want to enter a translatable text string.

2 In the string override field, enter the string.

The value entered in the string override property is stored as a child locale record and the value 
automatically populates the translatable text string field, such as the Title property for an applet.

Related Topic
“Setting the Constrain Mode for Working with Symbolic Strings” on page 76

About Converting and Consolidating 
Strings
The string conversion and consolidation processes allows you to covert translatable strings stored as 
child locale records of top-level object types to the symbolic strings model. The symbolic strings 
model stores strings in a centralized table. 

CAUTION: Conversion and consolidation operations are highly intensive processes. See Siebel 
System Requirements and Supported Platforms on Siebel SupportWeb for computer processing-
speed requirements.

Convert and consolidate are useful for customers who:

■ Have upgraded to version 8.0 and have custom translatable text strings that they want to 
migrate to the symbolic strings model.

■ Use string overrides to store text strings and periodically want to convert and consolidate them 
to the symbolic strings model.

When considering whether to convert strings to the symbolic strings model consider the following:

■ Migrating to the symbolic string model reduces the size of repository, makes translations easier, 
and gives you more control over terminology consistency. 

■ The conversion and consolidation processes require that development be frozen and can require 
substantial processing time. 

Related Topics
“About the Symbolic Strings Model” on page 198

“Entering String Overrides” on page 202

“About the Symbolic String Conversion Process” on page 204

“About the Symbolic String Consolidation Process” on page 206
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About the Symbolic String Conversion 
Process
The String Conversion process comprises three distinct logical operations:

■ New Symbolic String records along with their Symbolic String Locale child records, are generated 
based on the string values found in the target objects.

■ The String Reference fields of the target object records are set to the names of the new Symbolic 
Strings.

■ The string fields in the locale records of the target objects are nullified, and, where appropriate, 
the locale records themselves are deleted.

This process is performed in two separate phases—the preparatory Conversion Export phase, 
followed by the lengthier Conversion Import phase, where the data changes actually occur.

The String Conversion process does the following: 

■ Generates new symbolic string records and their corresponding symbolic string locale records 
using string values found in target objects. 

NOTE: The conversion process runs on an object type by object type basis. Because of this, there 
are likely to be duplicate symbolic strings for a given display value. Duplicates are “de-duped” 
during the consolidation process.

■ Sets the String Reference fields of the target object records to the names of the new symbolic 
strings. 

■ Nullifies the string fields in the locale records of the target objects and, where appropriate, 
deletes the locale records.

The conversion process occurs in two phases: the conversion export phase, in which data is prepared 
for conversion, followed by the conversion import phase, in which data changes actually occur.

NOTE: An SRF file compiled before the conversion process will be the same as an SRF file compiled 
after the conversion process. For example, suppose a given applet gets its Title property from a child 
Applet Locale record. When the conversion process is run, it creates a symbolic string, places the 
reference for that symbolic string in the applet Title - String Reference field, and then removes the 
Applet Locale record(s). Now, after the conversion, the applet’s title is derived from the symbolic 
string. However, the Title itself, the display value that is compiled to the SRF, is the same as it was 
before the conversion. The reason is that the strings are compiled into object definitions and read 
from the SRF file, not referenced from the Symbolic String table during run time.
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Conversion Export
The Conversion Export process identifies records that are candidates for Conversion, and then writes 
all the relevant information to a file. This process is run on an object type by object type basis, and 
can be run against any object type that has translatable strings (for example, controls, list columns, 
and applets).

NOTE: The Conversion process has to be executed once for each Object Type (both Top-Level and 
Sub-Level Object Types) in the repository that has properties that reference Symbolic Strings. In 
order to determine what Object Types refer to Symbolic Strings, click the Flat Tab in the Object 
Explorer, navigate to Attribute, and search for the string “*String Reference*” in the Name property. 
The Parent Type of the results set is the complete set of object types for which the conversion has 
to be run. Some object types have more than one attribute that refers to Symbolic Strings; for such 
object types, it is necessary to run the conversion process only once.

The conversion process begins by creating a sorted list of English (ENU) child records for each 
translatable string within a given object type. For those object types with multiple translatable 
strings (such as list columns that have a Display Name and Prompt Text), each is processed 
sequentially. This list is used to generate information about the new symbolic strings. Among sets of 
records with identical ENU translations, the non-ENU records are compared and, where possible, the 
same symbolic string is reused for subsequent records. The output file produced contains information 
about the new symbolic strings, including all the language translations for each, as well as which 
strings will be used as replacements.

NOTE: The Conversion Export file is not a log file so there is no need to review its contents.

Conversion Import
Based on the file produced by the conversion export process, the conversion import process performs 
the changes to the database (inserts, updates, and deletes) that convert the object records to use 
the new symbolic strings. Logically, the process consists of three operations, the end result of which 
is the production of symbolic string and symbolic string locale records, and the deletion of other 
types of locale records. The three operations are:

■ New symbolic string records are created in the database. The export file contains all the 
information about the string, including a unique name and information about each of its locale 
children.

■ References to the new symbolic string records are placed into the relevant fields of the original 
objects. For example, suppose you have 10 applets whose title is My Service Requests. Assuming 
the non-ENU values for all the titles are the same, then the export file contains information about 
one new symbolic string, and instructions for each of the 10 applets to use this new symbolic 
string as its title. After creating the symbolic string record for a string whose ENU value is My 
Service Requests, the Title - String Reference property for each of the 10 applets is set to the 
name of the new symbolic string. At this point, each of the Applets has a String Reference in 
addition to the String Override. The String Override is now superfluous and can be removed. This 
is done by clearing that value from the object Locale children.

■ Records are deleted for which there is no longer any information in the object locale records. 
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About the Symbolic String Consolidation 
Process
The consolidation process eliminates duplicate symbolic strings that may be created during the 
conversion process. Because the conversion process runs on an object type by object type basis, 
duplicate records can, and usually do, occur when the process creates different symbolic strings for 
a display value that occurs in multiple object types. Duplicate symbolic strings can have identical 
sets of locale records or one symbolic string may have more child locale records than the other, but 
the ones they have in common are identical.

CAUTION: File and Object command-line parameters for conversion or consolidation processes are 
case sensitive. However, all other command-line parameters for conversion and consolidation are not 
case sensitive.

Consolidation Export
The Consolidation Export process scans all symbolic string records and identifies symbolic strings 
whose child records are identical and then writes this information to a file. For symbolic strings that 
have identical child records, one of the strings will be selected arbitrarily as the master record. For 
symbolic strings whose child records are a subset of another symbolic string, the string with the 
largest number of children is selected as the master record. The export process does not modify the 
database.

NOTE: The Consolidation Export file is not a log file so there is no need to review its contents.

Consolidation Import
Based on the file produced during consolidation export process, the redundant symbolic strings are 
eliminated, and all references to these strings from other object types are replaced with a reference 
to the master record. This is a time-consuming process, as there are approximately 80 translatable 
string attributes represented among the various object types in the repository. The end result, 
however, is that the symbolic string table is as compact as possible, and all redundancy has been 
removed.

Running the String Conversion Utility
The conversion process is implemented as a business service. You run it using the consoleapp.exe 
utility, located in the SIEBEL_TOOLS_ROOT\BIN directory of your Siebel Tools installation directory.

Prior to running the conversion:

■ Make sure you have backed up your database and your repository.

■ Make sure all of the projects are unlocked. While conversion and consolidation are running, no 
other users should be allowed to log on to the development environment.

■ Make sure that the DataSource parameter in the [Siebel] section is the desired database. The 
conversion utility uses this database.

■ Make sure that the EnableToolsConstrain parameter in the [Siebel] section is set to FALSE.
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■ Make sure that the SymStrPrefix parameter in the [Siebel] section of the tools.cfg file is set to 
the desired prefix. This value is used as the prefix to the name of all newly created symbolic 
strings. It is set to X_ by default, to indicate that it was created by you and not by Siebel (SBL_).

Topics in This Section
“Parameters for Running consoleapp.exe to Convert Strings” on page 207

“Exporting Candidates for Conversion” on page 207

“Splitting Conversion Export Files into Smaller Files” on page 209

“Importing Converted Symbolic Strings” on page 209

Parameters for Running consoleapp.exe to Convert 
Strings
The parameters for running consoleapp.exe to convert existing locale strings to symbolic strings are 
shown in Table 42. The format is:

consoleapp.exe <Config file> <app lang> <uid> <pw> “Business Service” “Method Name: 
Parameters”

Table 42 lists the parameters and the descriptions.

Exporting Candidates for Conversion
You use consoleapp.exe to export candidates for conversion.

Table 42. Parameters for Running consoleapp.exe to Convert Strings

Parameter Description

Config file The Siebel configuration file, such as Tools.cfg. Note that the default data 
source is used.

app lang Application language, such as ENU

uid User ID

pw Password

Business Service “String Conversion”

Method Name: 
Parameters

Business Service method and the input parameters
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To export conversion candidates for a given object type
■ Launch consoleapp.exe as described in “Parameters for Running consoleapp.exe to Convert 

Strings” on page 207, and use the ConversionExport business service method with the 
parameters listed in Table 43. 

For example:

“ConversionExport: Filename=Control.txt,Repository=Siebel Repository,

Object=Control,LogFile=ControlExport.log,Language=ENU,MatchMin=1"

Table 43. Input Parameters for the ConversionExport Business Service Method

Parameter Required? Description

Filename Y The name of the export file.

Repository Y The Siebel Repository name. 

NOTE: The repository name is case sensitive.

Object Y The Siebel object type whose strings are exported, for example, 
Control.

NOTE: The object name is case sensitive.

LogFile N  The name of the log file.

Language N The language used as the primary language to match when 
searching for duplicate symbolic strings.

For example, suppose two symbolic strings each have three 
child records: English (ENU), French (FRA), and German (DEU). 
If the Language parameter is set to ENU, then the conversion 
export process searches for matches between the ENU records. 
When it finds matches, it checks the other child records of the 
other languages. If all child records match (or if one has a 
superset of the other), they are considered matching symbolic 
strings.

MatchMin N The minimum number of matches in a set of matching symbolic 
strings before it is written to the file. The default value is 2.

SQLLog N The SQL log file name. When this parameter is set, the 
conversion process logs all SQL that is executed to the specified 
file.

ExcludeNull N TRUE/FALSE value. When set to TRUE, it excludes null value for 
conversion consideration.

The default value is TRUE.

UseFullMatch N TRUE/FALSE value. When set to TRUE, records are matched 
against all the other possible match candidates before they are 
discarded.

The default value is TRUE.
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Splitting Conversion Export Files into Smaller Files
After you generate an export file, you can split the file into smaller, more manageable files. This is 
beneficial for object types such as Control, because it could have up to 130,000 records. To improve 
performance, you can import multiple consolidation files, of either the same object type or of 
differing types, simultaneously.

NOTE: An average desktop PC can typically run only 10 simultaneous conversion import processes.

To split an export file into smaller files
■ Launch consoleapp.exe as described in “Parameters for Running consoleapp.exe to Convert 

Strings” on page 207 and use the SplitFile business service method with the parameters listed in 
Table 44.

For example:

"SplitFile: Filename=Control.txt,Lines=2000"

Importing Converted Symbolic Strings
You initiate the import process using the parameters listed in Table 45 on page 210.

UseExactMatch N A TRUE or FALSE value. When set to TRUE, records are 
considered to be a match only when they have all the same 
number of language records and for each language, the same 
values. Partial matches are not considered.

The default value is FALSE.

SkipInactive N A TRUE or FALSE value. When set to TRUE, the conversion 
process skips all records with the Inactive property = Y.

The default value is TRUE.

Table 44. Input Parameters for the SplitFile Business Service Method

Parameter Required Description

Filename Y Export file.

Lines Y Approximate number of lines in each file. The application does 
not break up a set of symbolic strings, so the number of lines 
might not match this parameter exactly.

Table 43. Input Parameters for the ConversionExport Business Service Method

Parameter Required? Description
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To import symbolic strings
■ Launch consoleapp.exe as described in “Parameters for Running consoleapp.exe to Convert 

Strings” on page 207, and use the SplitFile business service method with the parameters listed 
in Table 45.

For example:

"ConversionImport: Filename=Control.txt,Repository=Siebel Repository,
LogFile=ConversionImport.log,UnlockProjects=false,SkipParentUpdates=true,
Project=Symbolic Strings"

Table 45. Input Parameters for the Conversion Import Business Service Method

Parameter Required Description

Filename Y Import file.

Repository Y Siebel Repository name.

LogFile N Log file.

UnlockProjects N TRUE/FALSE value. When set to TRUE, the conversion 
business service unlocks all projects when the process 
finishes. This is useful when there are multiple instances 
of the conversion service running against the same DB. 
The default value is TRUE. 

SkipParentUpdates N TRUE/FALSE value. When set to TRUE, parent objects, 
such as the project of the top-level objects being updated, 
are not updated to use the symbolic string. The default 
value is FALSE.

SQLLog N Log file name. When this parameter is set, the process 
logs all SQL that is executed to the specified file.

Project Y Name of the project in the Repository that contains the 
newly-created strings. Siebel-delivered strings are in the 
Symbolic Strings project. You might want to configure this 
for their custom strings.

DeleteLocales N TRUE/FALSE value. When set to TRUE, locale records are 
deleted if all translatable fields are NULL and no language 
override field is set. When set to FALSE, the locale record 
is set to Inactive. The default value is TRUE.

CheckTranslateFlag N TRUE/FALSE value. When set to TRUE, the Conversion 
Import process does not convert objects that have the 
Translate field set to N. The default value is TRUE.

LogErrorRecords N If set to TRUE, all error records are be exported into a 
separate log file. The default value is FALSE.
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Running the String Consolidation Utility
After locale strings have been converted to symbolic strings, you can use the consolidation utility to 
find duplicate symbolic strings and merge them and their references into a single symbolic string. 

The consolidation process is implemented as a business service. You run it using the Consoleapp.exe 
utility, located in the SIEBEL_TOOLS_ROOT\BIN directory of your Siebel Tools installation directory.

Topics in This Section
“Parameters for Running consoleapp.exe to Consolidate Strings” on page 211

“Exporting Matching Symbolic Strings” on page 211

“Splitting Consolidation Export Files into Smaller Files” on page 213

“Importing Consolidated Strings” on page 213

Parameters for Running consoleapp.exe to Consolidate 
Strings
The parameters for running consoleapp.exe to consolidate duplicate symbolic strings are listed in 
Table 46. The format is as follows:

consoleapp.exe <Config file> <app lang> <uid> <pw> “Business Service” “Method 
Name:Parameters”

Exporting Matching Symbolic Strings

To export a file containing all matching symbolic string sets use the Consolidation Export method of 
the business service. The parameters are shown in Table 47 on page 212.

Table 46. Parameters for Running consoleapp.exe to Consolidate Strings

Parameter Required Description

Config file Y Name of the Siebel Config file, such as tools.cfg. The 
default data source will be used.

app lang Y The application language, such as ENU

uid Y User ID

pw Y Password

Business Service Y “String Consolidation”

Method 
Name:Parameters

Y Business Service method and input parameters
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To export matching symbolic strings
■ Launch consoleapp.exe as described in “Parameters for Running consoleapp.exe to Convert 

Strings” on page 207 and use the Consolidation Export Business Service method with the 
parameters listed in Table 47.

For example:

"ConsolidationExport:Filename=ConsExp.txt,Repository=Siebel 
Repository,LogFile=ConsolidationLog.txt,Language=ENU,MatchMin=2"

Table 47. Parameters for the Consolidation Export Business Service Method

Parameter Required Description

Filename Y The name of the export file.

Repository Y The Siebel Repository name.

LogFile Y The name of the log file.

Language Y The language used as the primary language to match when 
searching for duplicate symbolic strings.

For example, suppose two symbolic strings each have 3 child 
records: English (ENU), French (FRA) and German (DEU). If 
the Language parameter is set to ENU, then the consolidation 
export process searches for matches between the ENU 
records. When it finds matches, it checks the other child 
records of the other languages. If all child records match (or 
if one has a superset of the other) they are considered 
matching symbolic strings.

MatchMin Y The minimum number of matches in a set of matching 
symbolic strings before it is written to the file. The default 
value is 2.

SkipSBLStrings Y Possible values are TRUE, FALSE, or Master Only.

When set to TRUE, all strings starting with SBL_ in the name 
are ignored.

When set to FALSE, Siebel strings can be considered as 
master or deprecated strings. All Siebel and customer strings 
are included in consolidation. 

When set to Master Only, Siebel strings are not deprecated, 
but can be used as Master strings. 

The default value is TRUE.
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Splitting Consolidation Export Files into Smaller Files
When an export file is generated, you can split up into smaller, more manageable files. This is 
beneficial if you have exported a large number of symbolic strings and wish to import them in parallel 
running applications.

To split the consolidation export files into smaller files
■ Launch consoleapp.exe as described in “Parameters for Running consoleapp.exe to Consolidate 

Strings” on page 211 and use the SplitFile business service method with the parameters listed in 
Table 48.

For example:

"SplitFile:Filename=ConsExp.txt,Lines=100"

Importing Consolidated Strings
You use consoleapp.exe to execute the import process.

To import consolidated strings
■ Launch consoleapp.exe as described in “Parameters for Running consoleapp.exe to Consolidate 

Strings” on page 211 and use the Consolidation Import business service method with the 
parameters listed in Table 49.

For example:

"ConsolidationImport:Filename=ConsExp.txt,Repository=Siebel Repository,
LogFile=ConsolidationLog.txt,UnlockProjects=false,SkipParentUpdates=true”

Table 48. Parameters for the SplitFile Business Service Method

Parameter Required Description

Filename Y Export file

Lines Y Approximate number of lines in each file. The application does not 
break up a set of symbolic strings, so the exact number of lines 
may not match the value specified with this parameter.

Table 49. Parameters for Consolidation Import Business Service Method

Parameter Required Description

Filename Y Import file name.

Repository Y Siebel Repository name.

LogFile Y Log file name.
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Using Batch Files to Convert and 
Consolidate Strings
The conversion and consolidation utilities can be run from two batch files found in the 
SIEBEL_TOOLS_ROOT\BIN directory of the Siebel Tools installation directory. These batch files 
handle conversion and consolidation export, file split, and import. All parameters except the 
parameters listed in Table 50 and Table 51 are set in the batch file. For information about how to run 
the batch files, see the topics below, and see comments in the batch files themselves.

Topics in This Section
“Conversion Batch File” on page 214

“Consolidation Batch File” on page 215

Conversion Batch File
The parameters for running the conversion batch file, strconv.bat, are listed in Table 50.

UnlockProjects N TRUE/FALSE value. When set to TRUE, the consolidation 
business service unlocks all projects it had locked. This is 
useful if there are multiple instances of the consolidation 
service running against the same DB. The default value is 
TRUE.

SkipParentUpdates N This turns on or off the updating of parent objects, like the 
project, while updating symbolic string references or 
while deleting deprecated symbolic strings. This should 
only be used when the user is running multiple instances 
of the import simultaneously. If left on with multiple 
instances running some errors may result in which 
updates or deletes are aborted because the project was 
being updated by another instance at the same time.

SQLLog N Log file name. When this parameter is set, the process 
logs all SQL that is executed to the specified file.

Table 49. Parameters for Consolidation Import Business Service Method

Parameter Required Description
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Example: strconv "Object_Type" Action User_ID Password

CAUTION: To ensure that the batch file functions properly, your Siebel Tools installation path must 
be enclosed in quotes if it contains spaces.

Consolidation Batch File
The parameters for running the consolidation batch file, strcons.bat, are listed in Table 51.

Example: strcons Action User_ID Password

Working with Untranslatable Locale-
Specific Object Properties
User interface conventions can vary by locale. For example, one locale might require a different 
sequence of fields from another locale.

Table 50. Batch File Parameters for Running Conversion Export

Parameter Description

strconv.bat Conversion export, file split, and import batch file.

Object_Type Object type to be converted, for example Applet, Control, or List Column.

Action The options are export or import. When set to export, the conversion process 
will export all convertible locale records. When set to import, the conversion 
process will import the file or files designated by the Object_Type parameter.

User_ID The user name used to log in to the Siebel application.

Password The user’s password.

Table 51. Batch File Parameters for Running Consolidation

Parameter Description

strcons.bat Consolidation export, file split, and import batch file.

Action The options are export or import. When set to export, the consolidation 
process exports all convertible locale records. When set to import, the 
consolidation process imports the files in the working directory designated by 
the TEST_LOCATION parameter set in the batch file. 

User_ID The user name used to log in to the Siebel application.

Password The user’s password.
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Locale-specific object properties can be translatable, such as text strings, or nontranslatable, such 
as the HTML Sequence, HTML Height, and HTML Width properties of controls. You can configure 
nontranslatable object properties for specific locales by running Siebel Tools in Language Override 
mode. The Language Override mode allows you to store nontranslatable, locale-specific properties 
as child locale records of the parent object.

For example, your Siebel enterprise contains five languages: Japanese (JPN) and four Western 
European languages. As opposed to Western European languages, Japanese does not feature middle 
names, and name order is last (family) name first. To configure this, you would use Siebel Tools to 
set the language to JPN, set Enable Language Override to ON, hide the middle name (by setting the 
“Title-String Override” attribute to false), and then reverse the order of the first and last names. 
After compiling into the JPN.srf file, the layout will match the requirement.

CAUTION: If you delete a control or a list column from a web template, it will be deleted from all 
languages, even if you are in Language Override Mode. You hide and show fields through the 
Properties window of the specific object. For information, see “Showing or Hiding Locale-Specific Items 
in Applet Layout” on page 217.

If, however, the Japanese user of Siebel Tools did all of the above, but did not enable language 
override, the next time a user compiled any of the Western European languages, the names would 
be formatted in the Japanese fashion, that is no middle name, and last (family) name first.

NOTE: Siebel Tools does not need to be in Language Override mode to enter string overrides.

To configure untranslatable locale-specific object properties

1 Choose View > Options and then click the Language Settings tab.

2 Set the Tools Language Mode to the language you want to configure and select the Enable and 
use Language Override check box.

3 Navigate to the object type you want to modify.

4 Modify the object properties or work in the layout editor to define locale-specific values.

Related Topics
“Selecting a Language Mode” on page 61

“Enabling Language Overrides” on page 62

“Getting Locale-Specific Data Only” on page 87

“About the Symbolic Strings Model” on page 198

“Entering String Overrides” on page 202

“Showing or Hiding Locale-Specific Items in Applet Layout” on page 217
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Showing or Hiding Locale-Specific Items 
in Applet Layout
When working with multiple languages, you may wish to show or hide certain fields based on the 
requirements of a particular locale. You hide controls or list columns using the Visible and Show in 
List properties of the Control and List Column object types, respectively, not in the web templates. 

NOTE: Deleting a control or list column object from the applet layout in the Applet Layout Editor will 
cause that control or list column to be deleted across all languages, even if you are in Language 
Override Mode. 

After setting up your parent language you can then determine the fields you wish to hide for your 
child languages. Table 52 lists the object types, the property names, and provides a description. 

To hide an object for a specific locale

1 In the Object Explorer, choose Applet, then choose one of the following child objects:

■ Control

■ List > List Column

2 Select the specific object.

3 In the Properties window, navigate to one of the following properties:

■ For Control object: Visible-Language Override.

■ For List Column object: Show In List.

See Table 52 for property settings.

Table 52. Objects That Allow Show Override

Object Property Description

Applet > Control Visible Parent setting. Setting this property to TRUE 
will show this control to the user, in the parent 
language and in all other supported languages.

Visible-Language 
Override

Child setting. When operating in Language 
Override Mode, you set this property to:

■ FALSE to hide the column from the user.

■ TRUE to show the column to the user. Also, 
if the parent setting is TRUE you may just 
leave this setting blank, as it will default to 
the parent setting.
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Locating Orphaned String References 
After Upgrade
Upgrades from one release of Oracle’s Siebel Business Applications to another release can result in 
the “disappearance” of certain string references. The Fix Strings Utility allows you to locate these 
orphaned strings, and update them with new references. This process is run as a business service 
through the Consoleapp.exe utility, located in the SIEBEL_TOOLS_ROOT\BIN directory of your Siebel 
Tools installation directory.

To locate and log orphaned string references
■ Launch consoleapp.exe, and use the Siebel Tools Fix String References business service and the 

FixStringReferences business service method with the parameters listed in Table 53.

For example:

consoleapp <config file> <language> <user> <password> “Siebel Tools Fix String 
References” “FixStringReferences:<properties>”

Applet > List > List 
Column

Show in List Parent setting. Setting this property to TRUE 
will show this list to the user, in the parent 
language and in all other supported languages.

Show in List-
Language 
Override

Child setting. When operating in Language 
Override Mode, you set this property to:

■ FALSE to hide the column from the user.

■ TRUE to show the column to the user. Also, 
if the parent setting is TRUE you may just 
leave this setting blank, as it will default to 
the parent setting.

Table 53. Parameters for FixStringReferences Business Service Method

Parameter Required Description Default Value

Repository Y The Siebel repository name to fix or 
report invalid string references.

LogFile Y The name of the log file. The log file 
is written to the current working 
directory. An explicit log file path 
may also be entered.

Table 52. Objects That Allow Show Override

Object Property Description
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Examples
This command example shows how you run the utility for the object type Business Service, and write 
information to the fixstrings.log directory, and progress to the command window:

consoleapp SIEBEL_TOOLS_ROOT\bin\enu\tools.cfg ENU jgolding db2 "Siebel Tools Fix 
String References" "FixStringReferences:Repository=Siebel 
Repository,LogFile=fixstrings.log,FixReferences=false,VerboseOutput=true,Object=Bu
siness Service"

This command example shows how you run the utility on all object types, write the results to 
temporary fixstrings.log file:

consoleapp SIEBEL_TOOLS_ROOT\bin\enu\tools.cfg ENU jgolding db2 "Siebel Tools Fix 
String References" "FixStringReferences:Repository=Siebel 
Repository,LogFile=d:\temp\fixstrings.log,FixReferences=false"

About the Locale Management Utility
The Locale Management Utility (LMU) in Siebel Tools helps you manage the process of localizing text 
strings, such as field labels, and other locale-specific attributes, such as the height and width of 
controls. You use the LMU to export text strings to a file, then after the strings in the file have been 
translated or modified, you can use the LMU to import the translated strings back into the repository. 
The LMU also provides search and comparison tools.

NOTE: When importing XML Localization Interchange Field files (.xlf) with the LMU, make sure you 
have a working Internet connection at the time of import.

You use the Locale Management Utility to:

■ Find strings that need to be translated.

FixReferences N Set to TRUE to fix invalid references. 
Set to FALSE to have invalid 
references committed to the log file. 

FALSE

Object N The Siebel object type, such as 
Applet, for which you wish to find 
invalid string references. If this 
parameter is not present, invalid 
string references will be found for all 
Siebel object types. 

VerboseOutput N If TRUE, progress information is 
written to the command window. If 
false, no progress information is 
written to the command window. See 
the following examples.

FALSE

Table 53. Parameters for FixStringReferences Business Service Method

Parameter Required Description Default Value
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■ Find existing translations to use for untranslated strings.

■ Export strings and locale-specific attributes to a file (.slf, .txt, or .xlf) for localization.

■ Import strings and locale-specific attributes from a file back into the repository.

■ Search for strings and locale-specific attributes that have changed since the last export.

■ Compare objects in the repository to the objects stored in the export file.

Finding Untranslated Text Strings
You use the Locale Management Utility to find text strings in the repository that have not been 
translated, or need to be retranslated because the source string has changed since the last 
translation.

NOTE: The LMU performs search and comparison functions at the object level, not the attribute 
level. Therefore, if a locale object contains multiple string attributes, the search function returns all 
strings contained in the locale object, even if only one of them has been translated.

To find and export untranslated strings

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select the source language and the target languages.

3 Under Objects, select the applications or projects that you want to localize.

4 Click the Untranslated Strings tab.

5 To display strings that have been marked as Redo, select the Report string attributes of objects 
marked with 'redo' flag check box.

The Redo flag is marked when a record in the repository has been changed since the last time 
export occurred and therefore may need to be translated again.

For more information about Redo, see “Identifying Objects Modified Since the Last Export” on 
page 224.

6 Click Find Strings.

The Locale Management Utility searches through the string attributes of objects in the selected 
applications or projects and displays the ones that have not been translated and, if the Report 
string attributes of objects marked with the 'redo' flag check box was selected, the strings that 
need to be retranslated are also displayed.

7 After you find untranslated strings you can perform the following tasks:

■ Find the views that the untranslated strings belong to by clicking the Find View button.

■ Go to the parent object of the string in the Object Explorer by selecting a string, and then 
clicking Go To.

■ Export all untranslated strings to a.txt or.xlf file by clicking Export.
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Finding Existing Translations
You can search through objects in the repository to find existing translations for untranslated strings. 
This allows you to reuse existing translations for user interface objects that you have created or 
modified.

The LMU compares untranslated strings with string attributes of other objects in the repository. If it 
finds an object with the same string, it searches for a translation in the language that you have 
selected as the target language of the current LMU session. If a translation exists, the LMU displays 
the best candidate for translation and allows you to export it to a file.

For example, suppose you have selected English-American as your source language and Spanish as 
the target language. You have an applet with a title of Customer that has not been translated. After 
clicking the Find Translation button, the LMU searches through the repository for other objects with 
attributes of Customer. If it finds one, it looks for a Spanish translation of the string. If a translation 
already exists, the translation is displayed and you can export it to a file.

If the LMU finds more than one translation for a source string, the following rules apply:

■ If the source string is an attribute of an object that is related to a business component, such as 
Control Caption or List Column Display Name, then translations from the same business 
component are examined first. If multiple translations exist in the same business component, 
the string that occurs the most is selected. If none of the translations exist in the same business 
component, then the translation that occurs the most often from among all business components 
is selected.

For example, suppose Applet A is based on the Account business component. Applet A contains 
a control caption with the value of Account and this value has been translated to Account_FRA 
for French. Now suppose you create a new applet, Applet B, that is also based on the Account 
business component and that also contains a control caption with the value of Account. When 
you run Find Translations, the LMU would find Account_FRA as an existing translation and select 
it as the best candidate for this string.

■ If the source string is not an attribute related to a business component, such as Menu Item 
Caption, the translation that occurs the most is selected as the best candidate.

To find translated strings

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select the source language and the target language.

3 Under Objects, select the applications or projects that you want to localize.

4 Click the Untranslated Strings tab.

5 Click the Find Translations button.

The LMU compares untranslated strings with strings of other objects in the repository. If other 
objects use the same source string, the LMU looks for existing translations of the string and 
displays the best candidates for translation in the Results window.
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Finding Modified Objects
You can use the Locale Management Utility to locate previously modified objects in the repository.

To find modified objects

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 Click the Options tab, and from the Source Language drop-down list, choose your source and 
target languages.

NOTE: The source and target language must be different from one another.

3 Click the appropriate radio button to indicate whether you want to search by application or by 
project, and select the projects or applications you would like to perform the query against.

4 Click the Modified Objects tab, and under Search criteria, click the Changed Since checkbox.

5 Select the date from which you would like to search, then click Start.

Exporting Text Strings and Locale-
Specific Attributes
You use the Locale Management Utility to export strings and other locale-specific attributes to an 
external file. The file type of the external file can be .slf, .txt, or .xlf depending on what you export.

NOTE: Microsoft Excel.xls files are not accepted by the LMU utility.

To export strings and other locale-specific attributes

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select the Source and Target Languages.

NOTE: When exporting strings and other locale-specific attributes, be sure that your Tools 
language mode and the LMU source language are the same.

3 Under Objects, select the applications or projects that you want to export.

4 Click the Export Tab.

5 Select whether you want to export string attributes only or all localizable attributes.

All localizable attribute includes translatable strings and other locale-specific attributes, such as 
the width and height of controls. These attributes might be different for different locales.

6 Click Export.

The Save As dialog box appears.
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7 Choose the directory to which to export the files, for example 
SIEBEL_TOOLS_ROOT\OBJECTS\lang_code, where lang_code is the LMU target language.

8 Enter a file name, choose a file type, and then click Save.

■ If you have selected All localizable attributes, the available file type is .slf.

■ If you have selected String attributes only, the available file types are .txt or .xlf.

Related Topic
“Selecting a Language Mode” on page 61

Importing Text Strings and Locale-
Specific Attributes
You use the Locale Management Utility to import translated strings and other locale-specific 
attributes back into the repository. Use the preview functionality to display the results of the import 
process before you actually import them into the repository.

NOTE: When using the LMU to import files with the .xlf extension, make sure you are connected to 
the Internet.

To preview the results of the import process

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select a source language and a target language.

3 Click the Import tab.

4 Enter the directory path and name of the file you are going to import.

5 Enter the path and name of the file where you want to store the results for previewing.

The default file name is preview.log.

6 Click Preview.

The Locale Management Utility writes the results of the import process to the log file rather than 
to the repository.

NOTE: LMU does not mark changed records with a Redo flag when running in Preview mode.

To import strings and other locale-specific attributes into the repository

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select a source language and a target language.
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3 Click the Import tab.

4 Enter the file name of the file from which you want to import locale-specific attributes.

You can also use the Browse button to find and select the file. The default file name is: 

■ Results.txt if the file contains strings only

■ Results.slf if the file contains all locale-specific attributes

5 Select whether you want to mark records in the repository with the Redo flag that have changed 
since the export occurred.

When the import occurs, the LMU compares the source language records in the repository with 
the source language records in the import file. If the records in the repository have changed since 
the export occurred, the target language records are marked with the Redo flag. This helps you 
identify records that may need to be retranslated.

6 Click Import.

The locale-specific attributes are imported into the repository.

A log file (LMUImportTruncation.log) is created in the SIEBEL_TOOLS_ROOT\OBJECTS directory 
of your Siebel Tools installation directory. This file provides details, including error messages, 
about records that were not imported into the repository.

Identifying Objects Modified Since the 
Last Export
You can use the Locale Management Utility to identify objects that have been modified in the 
repository since the last time you exported strings. This is useful when your development and 
localization efforts occur simultaneously. It helps you keep strings in the repository synchronized 
with the strings that have been exported to a file for localization.

You can search for modified objects using the following two methods:

■ Base your search on a specific date.

■ Compare objects in the repository with objects in a source file, such as results.txt. 

NOTE: When you base your search on a specific date, and run the search by clicking the Start button, 
all records returned for a modified project are marked as “Redo,” regardless of whether a particular 
locale attribute has changed. This is because the LMU searches for changes at the object level (the 
base record), not the attribute level.

To identify modified objects

1 Choose Tools > Utilities > Locale Management.

The Locale Management Utility appears.

2 In the Options tab, under Languages, select a source language and a target language.

3 Click the Modified Objects tab.
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4 Define the search criteria you want to use:

■ Select the Changed since check box and then specify a date after which you want to find 
modified objects.

■ Select the Different from file check box and then specify the file to compare the repository 
against.

5 Do one of the following:

■ Click Start to find records that match the search criteria, display the results, and flag records 
returned in the search as Redo. Redo indicates that a record has been changed since the last 
time export occurred and therefore may need to be retranslated.

■ Click Preview to find records that match the search criteria and display the results. Preview 
does not mark records as Redo.

6 After you have identified modified objects, you can perform the following tasks:

■ Click Save to save a result set in a log file.

■ Click Go To to open the Object Explorer and go to the parent object of the string or attribute.

NOTE: The Load button allows you to import a result set from a previously saved file. After 
loading the result set in the display window, you can perform Save or Go-go operations on those 
records. 

Replacing Strings
You can use the LMU to replace strings in a bulk mode. For example, suppose that you need to change 
occurrences of Accounts to Companies for the English locale. You can use the LMU to export the 
strings to a file, manipulate the file so that it contains only Companies instead of Accounts, and then 
import the strings back into the repository. Using the LMU to replace strings is most useful for strings 
stored in string-override fields.

NOTE: Using the LMU to replace strings is useful when working with string overrides. But when 
working with the symbolic strings, follow the procedure described in “Modifying Symbolic Strings to 
Globally Update Display Values” on page 200.

To use the LMU to replace strings

1 Identify the applications or projects or both to which the strings belong. 

2 Export the strings you want to replace to an LMU file. 

Use the procedure described in “Exporting Text Strings and Locale-Specific Attributes” on page 222.

NOTE: Source and target language cannot be the same. 

3 In the LMU file, change the target language so that it is the same as the source language selected 
during the LMU export.

4 Remove strings from the LMU file that you do not want to replace.

5 In the Target String column of the LMU file, enter the string that you want to substitute for the 
original value.
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6 Use the LMU to import the LMU file:

a In Siebel Tools, choose > Utilities > Locale Management.

b In the Options tab, select source and target language (both are the same).

c Select the Import tab and then specify the LMU file path.

d Click Import to replace the strings.

Running the LMU Using the Command-
Line Interface
You can run the LMU from the command-line interface. Commands, syntax, usage, and examples are 
provided in the following sections.

The syntax for the following commands uses these conventions:

■ <xxx> is a placeholder for a required parameter.

■ [xxx] is a placeholder for an optional parameter.

■ <xxx|yyy> is an selection parameter (that is, xxx or yyy)

NOTE: When specifying file names, the absolute path must be provided. For example, if you specify 
the LMU export file as results.txt, it is created under the current directory; for example, if the 
installation directory is C:\Program Files\Siebel\8.0\Tools, the file is created under C:\Program 
Files\Siebel\8.0\Tools\BIN, not under C:\Program Files\Siebel\8.0\Tools\OBJECTS.

Exporting Strings and Locale-Specific Attributes

Syntax
/lmu <srclang> <trglang> export <proj|app> <all|string> <file> [<Project File>]

Usage
This command allows you to export localizable attributes for all projects or for all applications. If you 
specify all, then all attributes (translatable and language override attributes) are exported to a file 
with the extension of .slf; if you specify string, then string attributes only are exported to a file with 
the .txt or .xlf extension. If you do not specify a file name, you receive an error.

In version 8.0, the LMU export process supports a new parameter to specify which projects should 
be exported. The parameter is the name of an ASCII text file containing a list of line feed–separated 
projects. If the <Project File> parameter is not included the export will operate as normal, 
exporting all projects.

The <proj|app> parameter is used for selecting either projects or applications as the method of 
selecting strings to export. To use the new <Project File> parameter, proj must be selected. If app 
is selected and a project file name is supplied, the file will be ignored.
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Example
siebdev /u sadmin /p db2 /d server /lmu ENU FRA export proj all 
C:\temp\my_proj_results.slf C:\temp\proj_to_exp.txt

This example instructs LMU to export all attributes (string and language override attributes) for the 
projects listed in C:temp\proj_to_exp.txt to an LMU file in C:\temp named my_proj_results.txt. The 
source language is English-American and the target language is French.

Importing an LMU File

Syntax
/lmu <srclang> <trglang> import <file>

Usage
This command allows you to import a LMU file and mark all target locale objects as “Redo” if the 
source string from the import file and the repository differ. You must specify the file name (with 
absolute path) to the import file.

Example
siebdev /u sadmin /p db2 /d server /lmu ENU FRA import "C:\Program 
Files\Siebel\8.0\Tools\objects\results.slf"

This example instructs the LMU to import a file called results.slf from the folder C:\Program 
Files\Siebel\8.0\Tools\objects (the installation location for an earlier version). The source language 
of the LMU file is English-American (ENU), and the target language is French (FRA). The LMU file 
contains all localizable attributes (string and language override attributes).

Exporting Strings to Be Translated

Syntax
/lmu <srclang> <trglang> todo <proj|app> [<file>]

Usage
This command allows you to export all untranslated strings and strings marked with the Redo flag to 
an LMU file. You can specify whether you want to export for all projects or all applications. The 
exported LMU file contains the related View Names.
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Example
siebdev /u sadmin /p db2 /d server /lmu ENU FRA todo app "C:\Program 
Files\Siebel\8.0\Tools\objects\results.txt"

This example instructs the LMU to find all untranslated strings and redo strings for all applications 
and export the results to C:\Program Files\Siebel\8.0\Tools\objects\results.txt. The source language 
is English-American (ENU), and the target language is French (FRA).

About the Advanced Compile Option
Developers frequently have the following two problems when localizing repositories:

■ Localization is not complete when testing begins.

Because of project schedules, developers usually start testing configuration changes without 
localized strings, which become available much later. This often means that they must delay 
testing until the localized strings are available.

■ Missing translations can be difficult to find.

Once developers have the localized strings imported, they start testing using a language SRF. 
But they often miss some strings—not all language translations were loaded, development 
continued beyond the localization export date, or some projects were mistakenly not exported.

These missing localized values can cause screens not to appear, tabs to be blank, or field labels 
not to appear—behavior that can be due to a variety of causes, and can be difficult to find and 
diagnose.

The Advanced Compile option in Siebel Tools version 8.0 solves these problems by doing the 
following:

■ Inserting “dummy” strings where translations are missing so that all functionality works.

■ Adding pseudolocalization prefixes to strings. These prefixes can include characters, such as 
accented European letters and Asian characters, to test their appearance in the desired 
languages.

Adding prefixes serves two main purposes:

■ Detection of hard-coded strings. Adding the prefix makes the string different from the original 
English string, so that any code that depends on checking a hard-coded string will break.

For example, if the code checks for the status of a customer to be “ACTIVE” and that string is 
hard-coded within the program, it will not match the modified status string that says 
“ÐØÉ_ACTIVE.”

■ Detection of code that will not accept non-ASCII characters. Any script or add-in product that 
has not been correctly internationalized will most likely cause an error when faced with a string 
such as “ÐØÉ_ACTIVE.” This error would not otherwise be detected until localization has been 
performed, which might be too late in the project cycle to correct immediately.
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An additional benefit of the prefixing option is that strings can be lengthened by up to three 
characters. This allows testing of field and column sizes to make sure that they can accept localized 
strings where the translation is longer than the original text. This commonly occurs in Western 
European languages.

NOTE: The Advanced Compile option does not change the underlying data in the repository, only the 
strings in the compiled SRF file. The Advanced Compile feature only works on strings that are in the 
S_SYM_STR table (that is, strings normally exportable with the LMU tool). It does not work on error 
messages contained in separate products such as Siebel Handheld or in third-party products such as 
Actuate reports.

Using the Advanced Compile Option
Before you can compile in advanced mode, you must set language options in the Development Tools 
Options dialog box.

The Advanced Compile option is accessed by holding down the SHIFT key when choosing Compile 
Projects from the Tools menu.

Setting Language Options
For more information on these options, see “Selecting a Language Mode” on page 61 and “Enabling 
Language Overrides” on page 62.

To set language options

1 From the View menu, choose Options.

The Development Tools Options dialog box appears.
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2 Click the Language Settings tab.

3 Under Tools Language Mode, choose the language you wish to test, for example Swedish. ENU 
(English-American) is the default.

A warning appears, asking you to confirm whether to switch languages.

4 Click Yes.

5 Under Language override, select the Enable and Use Language Override checkbox.
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6 Click OK.

A box appears informing you that the language has changed.

7 Click OK.

Compiling in Advanced Mode
The Advanced Compile option in Siebel Tools prefixes strings with characters to make the strings 
easier to find, and inserts dummy strings where translations are missing. These procedures are 
optional: you can use one or both of them.

CAUTION: Before compiling in advanced mode, make a backup copy of your SRF file.
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To compile in advanced mode

1 While holding down the SHIFT key, choose Compile Projects from the Tools menu.

The Object Compiler dialog box appears with the Advanced button visible.

2 Click Advanced.

3 The Advanced Options dialog box appears.

4 Select the desired options:

■ Enable pseudo-localization. Adds prefixes to strings. Optional.
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■ Pseudo-localization prefix. Type the characters with which to prefix strings if 
pseudolocalization is enabled.

NOTE: If testing a language with characters particular to it, you should include one or more 
of those characters.

■ For missing translations, show LANG_CODE + object name. Inserts dummy strings for 
missing translations. Optional.

5 Click OK.

6 In the Object Compiler dialog box, select the projects to compile.

7 Choose an SRF file to which to compile. This should be the language SRF that you wish to test.

8 Click Compile.

Testing the Localized Application
After the projects are compiled, you must use the Siebel Debugger to test the Oracle Siebel 
application for missing string translations.

For more information, see “Using the Siebel Debugger” on page 155.

To test the localized application

1 Start the debugger by pressing F5 or choosing Start from the Debug menu.

The Siebel Mobile Web Client starts in a new browser window. If both options were chosen, 
strings are prefixed with the chosen characters, and dummy strings contain the chosen 
characters, language code, and object name.

2 Navigate among the screens and views to find missing string translations.
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database commits, setting for full get 69
overwriting projects stored on local 

database 86
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setting options 75
Database Configuration Wizard

using to export/import repositories 188
date, setting change date preferences 60
Debug menu, options 43
Debug toolbar, about and buttons 50
debugger. See Siebel Debugger
debugging

setting options 72
showing/hiding debug windows 83

deleting objects 115
design environments, canvas-based 56
Detail tab, about using 20
Development Tools Options dialog box

checking in/out options 67
docking a window 79
drop-down lists, about 28

E
Edit menu. options 36
Edit toolbar, about and buttons 49
edit tools

displaying from Edit menu 36
displaying from Edit toolbar 49

editors
restarting after check out 69
showing/hiding 82

EIM Interface Tables report 42
Entity Relationship Designer, about 57
environment settings

applying using View menu 38
error messages

function_name Is An Unknown Function, 
about and correcting 161

Errors window, showing/hiding 83
exporting

exporting objects to an archive file 171
objects to an archive file using command-line 

interface 171
repository, in a UNIX environment 191
repository, in a Windows environment 189
strings and locale-specific attributes 226
strings to be translated 227
text strings and attributes 222
using archive files to export/import 

objects 169
Expression Builder

about 33
using 137

F
File menu, options 35
Fix and Go 146

Flat tab, about using 21
Format menu, options 42
Format toolbar, about and buttons 52
full get, setting commit options 69

G
generating mid-level release 175
get process

about performing 85
getting locale-specific data 87
getting projects from the server 

repository 86
performing full get 85

Go menu, options 40

H
Help menu, options 47
hidden windows, navigating to 46
History toolbar, about and buttons 48
hot-fix

exporting individual objects 172
exporting objects using the command-line 

interface 173
HTML source code, displaying for 

templates 31

I
Import Wizard-Review Conflicts and Actions

about 180
Attribute Differences pane 181
Conflicting Objects pane 180
Object Difference pane 181

importing
consolidated strings 213
Import Wizard-Review Conflicts and 

Actions 180
LMU file 227
objects from archive file 177
preparing target repository for import 177
process of importing objects from archive 

file 177
repository, in a UNIX environment 190
repository, in a Windows environment 189
symbolic strings 209
text strings and attributes 223
text strings and attributes into 

repository 223
using archive files to export/import 

objects 169
using Database Configuration Utility to 

export/import repositories 188
importlog.txt, about 180
inactive objects, about 21
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incremental repository upgrade kits, 
about 163

L
languages

enabling language overrides 62
selecting a language mode 61

Layout editors, about 55
List tool bar, about and buttons 48
LMU

See Locale Management Utility
local database, overwriting projects 86
local projects, differences from server 

projects 103
Locale Management Utility

about using 219
exporting strings and attributes 222
finding existing translations 221
finding untranslated text strings 220
identifying modified objects since export 224
importing strings and attributes 223
importing strings and attributes into 

repository 223
note, about modified records for project 

marked as Redo 224
replacing strings 225
running from command line 226

locale object
finding untranslated text strings 220

locale-specific attributes
exporting and strings 226
exporting strings to be translated 227
exporting text strings and attributes 222
importing into the repository 223
importing LMU file 227
importing strings and attributes 223

locale-specific items
showing or hiding 217

localization
See Locale Management Utility

locking projects 107
log file, list of Summary window 

messages 180

M
menu bar

Debug menu 43
displaying menus 35
Edit menu 36
File menu 35
Format menu 42
Go menu 40
Help menu 47

Query menu 41
Reports menu 41
Screen menu 40
Tools menu 44
View menu 38
Window menu 46

mid-level release, generating 175
missing strings, finding by compiling in 

advanced mode 228
Mode drop-down list 28
modified objects, finding 222

N
navigating, using windows 17
New Object wizard

about 49
using to create objects 113

non-translatable locale-specific 
attributes 215

O
Object Check Out dialog box

about using and elements 94
object comparison

about 127
about the Compare Objects dialog box 128
comparing in another repository 130
comparing in current repository and archive 

file 130
comparing in same repository 129
comparing object definition in archive 

files 130
synchronizing object definitions 131

Object Compiler dialog box
accessing 164
caution, about compiling or modifying .srf 

file 164
object definition management

File menu options 35
object definitions

about compound queries 123
about object comparison and 

synchronization 127
about the Compare Objects dialog box 128
about the Validate dialog box 117
about the Validation Options dialog box 119
about validating objects 116
associating with a different project 107
bookmarks 31
comparing in archive files 130
comparing in current repository and archive 

file 130
copying objects 115



Index ■ O

Using Siebel Tools Version 8.0, Rev. A 239

deleting objects 115
determining when records were created and 

updated 131
Edit menu, about using to apply 36
exporting to an archive file 171
flagging with bookmarks 40
List toolbar, about and buttons 48
modifying 114
Object List Editor window, using to 

display 21
objects, comparing in another 

repository 130
objects, comparing in same repository 129
property settings, displaying 24
renaming or reassigning 106
search the repository for objects 124
showing/hiding 74
synchronizing object definitions 131
table of simple queries 123
unlocking projects on local repository 108
using queries to list objects 122
validating objects 117
validating objects procedure 116
viewing object relationships 126
wizards, about using 55

object definitions, working with
about compound queries 123
about object comparison and 

synchronization 127
about simple queries 123
about the Compare Objects dialog box 128
about the Validate dialog box 117
about the Validation Options dialog box 119
about validating objects 116
creating objects 113
determining when records were created and 

updated 131
modifying objects 114
process 111
searching the repository for objects 124
unlocking projects on local repository 108
using queries to list objects 122
validating objects procedure 116
viewing object relationships 126

Object Explorer window
about and example 18
about using 17
Detail tab, about using 20
Flat tab, about using 21
Project drop-down list, about using 19
showing/hiding 78
Type tab, about using 19

Object List Editor window
about and example 21

about using and example 17
Changed field, about 23
defining display options 70
Edit menu, applying object definitions 36
Edit menu, applying objects 36
inactive objects, about 21, 22
List toolbar, about and buttons 48
modifying object definitions 114
pencil icon, about 23
queries, about 41
restoring to prequery state 122
showing Visualization views 82, 126
using queries to list objects 122

object management
File menu options 35

object types
Detail tab, about using to expand 20
Flat tab, using to display 21
Object List Editor window, using to 

display 21
Script flag, about 154
Types tab, using to list 19

objects
about comparison and synchronization 127
about performing a get process 85
about the Compare Objects dialog box 128
associating with a different project 107
bookmarks 31
comparing in another repository 130
comparing in archive files 130
comparing in current repository and archive 

file 130
comparing in same repository 129
compiling single objects or group of 

objects 165
copying objects 115
creating objects 113
deleting objects 115
determining when records were created and 

updated 131
Edit menu, about using to apply 36
exporting to a hot-fix 172
exporting to a hot-fix using the command-line 

interface 173
exporting to an archive file 171
exporting to archive file using command-line 

interface 171
flagging with bookmarks 40
generating a mid-level release 175
identifying modified objects since export 224
Import Wizard-Review Conflicts and 

Actions 180
importing from archive file 177
importing from archive file using command-
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line interface 182
List toolbar, about and buttons 48
merging versioned objects 195
modified objects, finding 222
Object List Editor window, using to 

display 21
preparing target repository for import 177
process for working with 111
process of importing objects from archive 

file 177
property settings, displaying 24
renaming or reassigning 106
searching the repository for objects 124
showing/hiding 74
synchronizing object definitions 131
unlocking projects on local repository 108
using archive files to export/import 169
using Database Configuration Utility to 

export/import repositories 188
using Database Configuration Wizard to 

export/import repositories 188
using queries to list objects 122
validating objects 117
viewing object relationships 126

objects, check out and check in
about 100
Allow Object Locking, setting projects to 

allow 100
enabling 100
limitations 103
locked objects, viewing within projects 102
locking objects locally 103
object differences, viewing 103
server repository, checking in objects to 102
server repository, checking out objects 

from 101

P
Palettes window

about 29
Web controls 29

pencil icon, about 23
Project drop-down list, about using 19
projects

about performing a get process 85
associating object definition with a different 

project 107
caution, about incremental compilations 164
check in/check out options (data sources) 67
checking in to the server repository 99
compiling 164
compiling in advanced mode 231
creating new projects 106

defined and about 105
renaming projects 106
repository, doing full get of all projects 85
suffix names, meaning of 105
undoing checkout 103
unlocking on local repository 108

properties
Properties window, about and example 24
property settings, displaying 24

Q
QBE

See queries
queries

about compound queries 123
table of simple queries 123
using to list objects 122

Query menu, options 41
query-by-example

See queries

R
records

determining when created and updated 131
Redo

about Locale Management Utility marking 
projects 224

renaming projects 106
replacing strings 225
reports

Application Upgrade Attributes List 42
Application Upgrade Object List 42
EIM Interface Tables 42
Tables 41

Reports menu, about 41
repositories

about implementing symbolic strings 
model 198

exporting in a UNIX environment 191
exporting in a Windows environment 189
full get of all projects, doing 85
importing in a UNIX environment 190
importing in a Windows environment 189
importing strings and attributes 223
initial get of all projects, doing 87
management, File menu options 35
merging by using the Application 

Upgrader 195
navigating using bookmarks 31
reviewing current info 184
searching for objects 124
symbolic strings model 198
unlocking projects 108
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upgrading 195
viewing which is open 184

repositories, managing
exporting objects to an archive file 171
Import Wizard-Review Conflicts and 

Actions 180
importing objects from archive file 177
importing objects using command-line 

interface 182
preparing target repository for import 177
process of importing objects from archive 

file 177
using archive files to export/import 

objects 169
results.slf, about 222
results.txt, about 222
right-click menus

about navigation 54
using to hide a window 78

Run-time Engine, invoking 161

S
Screen menu, options 40
Script Assist

about using 148
accessing the Script Assist window 150
using script libraries 152

script editors
about 58, 139

script lbraries, using 152
scripting, setting options 70
searching

finding existing translations 221
for untranslated text strings 220
using to find an object 124
using to find an object definition 124

server repository
objects, checking out from 101
projects, checking out 98

Server Script Editor, about using 58
Server scripting language

setting default 70
Siebel Compiler

Advanced Compile option 228
invoking 161
order considerations and error message 161

Siebel Debugger
about using 154
script variables and values, displaying 158
subroutines and function calls, 

displaying 158
tracing scripts and logging errors 159

Siebel eScript

Debug toolbar, accessing debugger 50
debugger, Debug menu options 43

Siebel Script Editor
about 58
accessing and screen example 148
Scripted flag, about 154
using 147

Siebel VB
Debug toolbar, accessing debugger 50
debugger, Debug menu options 43

Siebel Web Client, automatically opening 72
ST eScript Engine 144

enabling type deduction 145
enabling warnings 144
settings 144
using Fix and Go 146

status bar, showing/hiding 84
string consolidation utility

exporting matching symbolic strings 211
importing consolidated strings 213
parameters 211
running 211
splitting export files into smaller files 213

string conversion utility
exporting candidates for conversion 207
importing converted symbolic strings 209
parameters 207
running 206
splitting export files into smaller files 209

string override, entering 202
String Reference pick applet

symbolic string reference, selecting 201, 
202

symbolic string reference, using to 
select 201

strings
about string conversion process 204
conversion export 205
conversion import 205
exporting and locale-specific attributes 226
exporting strings to be translated 227
exporting text strings and attributes 222
finding existing translations 221
finding missing translations by compiling in 

advanced mode 228
finding multiple attributes 220
finding untranslated text strings 220
guidelines for converting and 

consolidating 203
identifying modified objects since export 224
importing text strings and attributes 223
importing text strings and attributes into 

repository 223
Locale Management Utility, running from 
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command line 226
replacing strings 225
using batch files to convert and 

consolidate 214
Summary window, containing contents of log 

file 180
symbolic string consolidation

about 206
consolidation export 206
consolidation import 206

symbolic strings
running string consolidation utility 211
setting constrain mode 76

symbolic strings model
about 198
about calculating translatable string 

values 198
about implemented 198
strings not included 198

symbolic strings reference
creating 199
selecting by typing value 201, 202
String Reference pick applet, using 201
user interface display values, globally 

update 200
syntax checking 157

T
Tables report 41
target browser, choosing 77
target repository, preparing for import from 

archive file 177
task

WF/Task Editor toolbar, accessing 52
task configuration options, setting 61
Task Designer

about 133
creating a task 136
using the Expression Builder 137

Task UI, about 57
Template drop-down list 28
testing changes 167
text strings

See symbolic strings model
third-party source control, integrating 

with 63
toolbars

about 47
Configuration Context toolbar 54
Controls toolbar 58
Debug toolbar 50
Edit toolbar, about and buttons 49
Format toolbar 52

History toolbar 48
List toolbar 48
showing/hiding 83
Web Controls toolbar 29
WF/Task Editor toolbar 52

Tools menu, options 44
tracing scripts 159
translations

finding existing 221
strings, exporting for 227

Types tab, about using 19

U
unconstrained mode, running Tools in 76
undocking a window 79
unlocking projects on local repository 108
untranslated text strings

finding 220
finding existing translations for 221

V
validate

about the Validate dialog box 117
about the Validate Options dialog box 119
object definitions procedure 116
validating objects procedure 116

Validate Options dialog box, about 119
View Layout Editor, about 55
View menu

options 38
showing Visualization views 82, 126

Visualization views
customizing 73
showing 82, 126

W
Watch window

showing/hiding 83
using to display script variables and 

values 158
Web browser, defining layout 54
Web Controls toolbar

about and buttons 29
Web Page Layout Editor, about 55
Web template editor, choosing 72
Web Template Explorer window

about and example 31
Web templates, displaying list 31
WF/Task Editor toolbar, about and 

buttons 52
Window menu, options 46
windows

docking/undocking 79
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hiding docked windows as tabs 79
showing/hiding 78
stacking dockable windows 81

wizards
using to create objects 55

workflow configuration options, setting 61

Workflow Process Designer
about 57, 133
creating a workflow process 134
using the Expression Builder 137

workflows
WF/Task Editor toolbar, accessing 52
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