Oracle® Demantra
User's Guide
Release 7.3
Part No. E05072-06

November 2010
Send Us Your Comments

Preface

Part 1  Collaborator Workbench

1  Getting Started with Collaborator Workbench

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>First-Time Logon</td>
<td>1-1</td>
</tr>
<tr>
<td>Logging into Collaborator Workbench</td>
<td>1-3</td>
</tr>
<tr>
<td>Illegal Characters in Oracle Demantra</td>
<td>1-4</td>
</tr>
<tr>
<td>A Brief Tour of Collaborator Workbench</td>
<td>1-4</td>
</tr>
<tr>
<td>Managing the Collaborator Workbench Page</td>
<td>1-8</td>
</tr>
<tr>
<td>Typical Use of Collaborator Workbench</td>
<td>1-9</td>
</tr>
<tr>
<td>Logging Off</td>
<td>1-10</td>
</tr>
<tr>
<td>Ending a Hung Session</td>
<td>1-10</td>
</tr>
<tr>
<td>Changing Your Password</td>
<td>1-11</td>
</tr>
</tbody>
</table>

2  Managing Tasks

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Tasks</td>
<td>2-1</td>
</tr>
<tr>
<td>Viewing Tasks Assigned to You</td>
<td>2-3</td>
</tr>
<tr>
<td>Opening a Task</td>
<td>2-4</td>
</tr>
<tr>
<td>Addressing a Task</td>
<td>2-5</td>
</tr>
<tr>
<td>Creating and Sending a Task</td>
<td>2-6</td>
</tr>
<tr>
<td>Resolving a Failed Task</td>
<td>2-8</td>
</tr>
</tbody>
</table>
3 Using Content Panes

Overview of Content Panes ........................................................................................................ 3-1
Types of Content Panes............................................................................................................ 3-2
Displaying a Content Pane ....................................................................................................... 3-10
Refreshing a Content Pane ..................................................................................................... 3-12
Opening the Associated Worksheet ....................................................................................... 3-12
Viewing the Definition of a Content Pane ............................................................................... 3-12

4 Using a Members Browser Content Pane

Introduction to the Members Browser .................................................................................... 4-1
Launching a Filtered Worksheet ............................................................................................... 4-2
Viewing the Attributes of a Member ...................................................................................... 4-2
About Creating, Editing, and Deleting Members .................................................................... 4-3
Creating a Member .................................................................................................................. 4-4
Modifying a Member ............................................................................................................... 4-4
Deleting a Member .................................................................................................................. 4-5
Using Other Right-Click Menu Options .................................................................................. 4-5

5 Personalizing Collaborator Workbench

Overview ..................................................................................................................................... 5-1
Configuring Your Default Layout .............................................................................................. 5-1
Configuring My Tasks ................................................................................................................ 5-3
Configuring My Worksheets ..................................................................................................... 5-4

6 Creating and Redefining Content Panes

Creating or Editing Content Panes .......................................................................................... 6-1
Introduction to the Content Pane Editor .................................................................................. 6-2
Configuring the Basics ............................................................................................................ 6-4
Selecting Series on a Content Pane .......................................................................................... 6-7
Specifying the Time Resolution and Time Span ..................................................................... 6-10
Specifying Aggregation Levels ............................................................................................... 6-12
Using the Advanced Selection Options .................................................................................. 6-14
Changing the Overall Scale or Unit of Measure ..................................................................... 6-17
Filtering the Content .............................................................................................................. 6-18
Applying Exception Filters ..................................................................................................... 6-21
Sharing Content Panes ........................................................................................................... 6-22
Deleting Content Panes .......................................................................................................... 6-23
Worksheet Definition, Layout, and Local Adjustments................................. 10-7

11 Working with the Worksheet Graph
Graph Styles and Variations........................................................................ 11-1
Changing the Graph Style........................................................................... 11-3

12 Working Offline
About Working Offline.............................................................................. 12-1
Setting Up Your Offline Environment.................................................... 12-3
Saving Data for Offline Use...................................................................... 12-6
Accessing an Offline Worksheet.............................................................. 12-8
Reloading Offline Data............................................................................. 12-9

13 Managing Items and Locations
About Managing Items and Locations...................................................... 13-1
Viewing the Attributes of an Item or Location........................................ 13-2
Creating an Item or Location.................................................................. 13-3
Making a New Member Visible............................................................... 13-4
Modifying an Item or Location............................................................... 13-5
Deleting an Item or Location.................................................................. 13-5
Overview of New Product Introduction.................................................... 13-6
Removing Lifecycle Definitions.............................................................. 13-9
Opening an Item or Location in Another Worksheet............................... 13-11
Using Other Right-Click Menu Options................................................... 13-11

14 Creating and Redefining Worksheets
Introduction to Worksheets and Views...................................................... 14-2
Introduction to Levels............................................................................. 14-2
Introduction to Series............................................................................. 14-5
Visual Elements of Worksheet Views...................................................... 14-8
Levels and Layout Variations................................................................. 14-10
Introduction to the Worksheet Editor...................................................... 14-14
Creating or Editing a Worksheet............................................................. 14-16
Configuring the Worksheet Basics......................................................... 14-16
Selecting Series on a Worksheet............................................................ 14-20
Specifying the Time Resolution and Time Span...................................... 14-23
Specifying Aggregation Levels............................................................... 14-25
Using the Advanced Selection Options................................................... 14-26
Changing the Overall Scale or Unit of Measure...................................... 14-29
Part 3 Desktop-Only Tools

15 Member Management

Introduction to Member Management .................................................. 15-1
Starting Member Management ............................................................ 15-3
Introduction to the Member Management Tool .................................... 15-3
Creating a Member .............................................................................. 15-6
Creating a Combination ....................................................................... 15-8
Creating Placeholder Data .................................................................... 15-9
Managing the Lowest-Level Combinations .......................................... 15-10
Moving a Member ................................................................................ 15-13
Copying a Member ............................................................................... 15-13
Renaming a Member ............................................................................ 15-14
Deleting a Member .............................................................................. 15-15

16 Chaining Management

Introduction to Chaining ...................................................................... 16-1
Opening Chaining Management ............................................................ 16-2
Introduction to the Chaining Management Tool .................................... 16-2
Overview of Chaining Options ............................................................... 16-7
Defining a New Chaining Operation ...................................................... 16-10
Performing a Chaining Operation ........................................................ 16-17
Scenario 1: Copying at Lowest Level (No Similarity) ............................ 16-18
Scenario 2: New Product (Location Similarity) ...................................... 16-22
Scenario 3: Merging Two Locations .................................................... 16-25
Scenario 4: Two New Products ............................................................ 16-26
Scenario 5: Multiple Sources .............................................................. 16-27
Part 4 Reference

17 URLs and Shortcuts
   Oracle Demantra URLs........................................................................................................... 17-1
   Keyboard Shortcuts.................................................................................................................. 17-1

18 Product Features
   Product Features Overview............................................................................................... 18-1
   Oracle Demantra Demand Management.............................................................................. 18-2
   Oracle Demantra Advanced Forecasting and Demand Modeling...................................... 18-3
   Oracle Demantra Real-time Sales and Operations Planning........................................... 18-6
   Oracle Demantra Predictive Trade Planning......................................................................... 18-7
   Oracle Demantra Trade Promotion Optimization.............................................................. 18-7
   Oracle Demantra Deductions and Settlement Management............................................. 18-8

Glossary

Index
Oracle welcomes customers' comments and suggestions on the quality and usefulness of this document. Your feedback is important, and helps us to best meet your needs as a user of our products. For example:

- Are the implementation steps correct and complete?
- Did you understand the context of the procedures?
- Did you find any errors in the information?
- Does the structure of the information help you with your tasks?
- Do you need different information or graphics? If so, where, and in what format?
- Are the examples correct? Do you need more examples?

If you find any errors or have any other suggestions for improvement, then please tell us your name, the name of the company who has licensed our products, the title and part number of the documentation and the chapter, section, and page number (if available).

Note: Before sending us your comments, you might like to check that you have the latest version of the document and if any concerns are already addressed. To do this, access the new Oracle E-Business Suite Release Online Documentation CD available on My Oracle Support and www.oracle.com. It contains the most current Documentation Library plus all documents revised or released recently.

Send your comments to us using the electronic mail address: appsdoc_us@oracle.com

Please give your name, address, electronic mail address, and telephone number (optional).

If you need assistance with Oracle software, then please contact your support representative or Oracle Support Services.

If you require training or instruction in using Oracle software, then please contact your Oracle local office and inquire about our Oracle University offerings. A list of Oracle offices is available on our Web site at www.oracle.com.
Preface

Intended Audience

Welcome to Release 7.3 of the Oracle Demantra User’s Guide.

This guide is intended for users of Oracle Demantra.

See Related Information Sources on page xii for more Oracle E-Business Suite product information.

Deaf/Hard of Hearing Access to Oracle Support Services

To reach Oracle Support Services, use a telecommunications relay service (TRS) to call Oracle Support at 1.800.223.1711. An Oracle Support Services engineer will handle technical issues and provide customer support according to the Oracle service request process. Information about TRS is available at http://www.fcc.gov/cgb/consumerfacts/trs.html, and a list of phone numbers is available at http://www.fcc.gov/cgb/dro/trsphonebk.html.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation accessible to all users, including users that are disabled. To that end, our documentation includes features that make information available to users of assistive technology. This documentation is available in HTML format, and contains markup to facilitate access by the disabled community. Accessibility standards will continue to evolve over time, and Oracle is actively engaged with other market-leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. For more information, visit the Oracle Accessibility Program Web site at http://www.oracle.com/accessibility/.
Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, some screen readers may not always read a line of text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. Oracle neither evaluates nor makes any representations regarding the accessibility of these Web sites.

Structure

1 Getting Started with Collaborator Workbench
2 Managing Tasks
3 Using Content Panes
4 Using a Members Browser Content Pane
5 Personalizing Collaborator Workbench
6 Creating and Redefining Content Panes
7 Logging in Remotely
8 Getting Started with Worksheets
9 Working with Data
10 Managing the Screen
11 Working with the Worksheet Graph
12 Working Offline
13 Managing Items and Locations
14 Creating and Redefining Worksheets
15 Member Management
16 Chaining Management
17 URLs and Shortcuts
18 Product Features
Glossary

Related Information Sources

Oracle Demantra products share business and setup information with other Oracle Applications products. Therefore, refer to other user guides when you set up and use Oracle Demantra.

User Guides Related to All Products:

• Oracle Applications User Guide

• Oracle Applications Developer’s Guide
Do Not Use Database Tools to Modify Oracle E-Business Suite Data

Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser, database triggers, or any other tool to modify Oracle E-Business Suite data unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus to modify Oracle E-Business Suite data, you risk destroying the integrity of your data and you lose the ability to audit changes to your data.

Because Oracle E-Business Suite tables are interrelated, any change you make using an Oracle E-Business Suite form can update many tables at once. But when you modify Oracle E-Business Suite data using anything other than Oracle E-Business Suite, you may change a row in one table without making corresponding changes in related tables. If your tables get out of synchronization with each other, you risk retrieving erroneous information and you risk unpredictable results throughout Oracle E-Business Suite.

When you use Oracle E-Business Suite to modify your data, Oracle E-Business Suite
automatically checks that your changes are valid. Oracle E-Business Suite also keeps track of who changes information. If you enter information into database tables using database tools, you may store invalid information. You also lose the ability to track who has changed your information because SQL*Plus and other database tools do not keep a record of changes.
Part 1

Collaborator Workbench
Getting Started with Collaborator Workbench

This chapter covers the following topics:

• First-Time Logon
• Logging into Collaborator Workbench
• Illegal Characters in Oracle Demantra
• A Brief Tour of Collaborator Workbench
• Managing the Collaborator Workbench Page
• Typical Use of Collaborator Workbench
• Logging Off
• Ending a Hung Session
• Changing Your Password

First-Time Logon

The first time you log onto Collaborator Workbench, Oracle Demantra typically downloads and installs software. This operation is quick and occurs only once for each machine you use.

Open Microsoft Internet Explorer or Mozilla Firefox.

You must set your browser's locale. Oracle Demantra needs it to properly use your browser applets and to properly create your Collaborator Workbench pages.

To set your browser's locale in Microsoft Internet Explorer:

• Navigate on the menu bar Tools > Internet Options
• Navigate to tab General
• Click Languages...

• If there are no languages listed, click Add.. and select one. If you are not sure, contact your system administrator.

• Click OK.

To set your browser's locale in Mozilla Firefox:

• Navigate on the menu bar Tools > Options

• Navigate to tab Content

• In the Languages region, click Choose

• Select a language. If you are not sure, contact your system administrator.

• Click OK.

1. Enter the URL supplied by your system administrator. This URL probably has the following format:

   \text{http://server name/virtual directory/portal/loginpage.jsp}

   For example:

   \text{http://frodo/demantra/portal/loginpage.jsp}

   \textbf{Note:} Your Windows Start menu may also include an option for starting Collaborator Workbench, which you can use instead

2. In the Log On dialog box, enter your user name and password.

3. Click Login.

4. If the toolbar includes a link labeled Click here to install Java Web Start, click that link.

   Next, Oracle Demantra prompts you to install JRE.

5. When you are prompted to install JRE, do so. Choose the Typical installation and accept all the default values, unless otherwise advised by your system administrators.

   After you install this software, Collaborator Workbench comes up, displaying your personal page.

   Oracle Demantra displays a dialog box that asks if you want to trust the signed application distributed by Oracle. The dialog box is slightly different depending on your configuration.
Note: This dialog box is sometimes displayed as soon as Collaborator Workbench comes up. In other cases, you do not see it until you click a worksheet name.

Click Yes (or Always) or Start, depending on which dialog box is displayed.

Logging into Collaborator Workbench

If you have already performed the one-time setup (see First Time Login), then log on as follows.

To log into Collaborator Workbench

Your Windows Start menu may include a link to Collaborator Workbench. If so, use that. If not:

1. Open Microsoft Internet Explorer or Mozilla Firefox.
   You must set your browser’s locale if it is not already set. Oracle Demantra needs it to properly use your browser applets and to properly create your Collaborator Workbench pages. To set your browser’s locale, see First Time Login.

2. Enter the URL supplied by your system administrator. This URL probably has the following format:
   • http://server name/virtual directory/portal/loginpage.jsp
     For example:
     http://frodo/demantra/portal/loginpage.jsp

3. In the Log On dialog box, enter your user name and password.

4. Click Login.
   • Collaborator Workbench comes up, displaying your personal page.

Tip

You can use the following URL to bypass the login page:
http://server name/virtual directory/portal/directLogin.jsp?user=current user&pass=password
For example:
http://frodo/demantra/portal/directLogin.jsp?user=dp&pass=dp
See also:
• A Brief Tour of Collaborator Workbench
Illegal Characters in Oracle Demantra

Within Oracle Demantra, do not use the following special characters:

- Single quote (')
- Double quote ("")
- Ampersand (&)

If you use these characters, unexpected results may occur.

A Brief Tour of Collaborator Workbench

Depending on how Collaborator Workbench is configured, it can include some or all of the elements shown in the following figure. You can configure all these elements for your own needs. For example, only a single content pane is shown here, but you can add as many as you need.

You can create and open worksheets only in the web version, not in the desktop version. The available desktop functions are Member Management and Chaining Management.
Menus

Collaborator Workbench includes the following menus:

- The Contents menu lists all the content panes to which you have access and lets you create additional ones; see Displaying a Content Pane and Creating and Redefining Content Panes.

- Depending on how it has been configured, the menus may include links to the following desktop-only tools:

<table>
<thead>
<tr>
<th>Tool</th>
<th>For information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Member Management (Planning Applications menu)</td>
<td>Member Management</td>
</tr>
<tr>
<td>Chaining (Planning Applications menu)</td>
<td>Chaining Management</td>
</tr>
<tr>
<td>Business Modeler (Tools and Applications menu)</td>
<td>Oracle Demantra Implementation Guide</td>
</tr>
</tbody>
</table>

You may or may not be able to use these tools, depending upon your permissions.

If you select a tool that is not installed on your desktop or for which there is a newer version available, Oracle Demantra installs or updates the tools on your desktop. See Oracle Demantra Implementation Guide.

To access a menu item

1. Click the menu title. Then Collaborator Workbench displays the menu items in a small pop-up box.
2. Click the item you want.

To hide the menu
1. Click the menu title again.
2. Or click another menu title, to open a different menu instead.

Links

You use the Administration link to change your password; see Changing Your Password.

The Personalize link brings up a wizard for customizing Collaborator Workbench; see Configuring Your Default Layout.

The other links vary from implementation to implementation and are not documented here.

My Worksheets

My Worksheets lists some or all of the worksheets to which you have access, specifically, the following worksheets:

- Private and public worksheets that you own.
- Public worksheets where you and the owner are in the same collaborative group.

In My Worksheets, you can do several things:
- Click a worksheet to open it. For information on using worksheets, see Introduction
to Oracle Demantra.

- Clicking the refresh button to refresh the list of worksheets.
- Specify which worksheets to display in this pane; see Configuring My Worksheets.
- Send a worksheet as a task to another Collaborator Workbench user; see Creating and Sending a Task.

**Content Panes**

Collaborator Workbench often includes content panes, sometimes called content for short. A content pane displays a graphical view of data associated with a worksheet, to provide you with current, at-a-glance information that meets your needs, as in the following example.

![Pie Chart Example](image)

You can display content in formats such as the following:

- Members Browser, which is a collapsible tree hierarchy of data levels
- Tabular format
- Chart formats including line, bar, and pie charts
- Calendar format

For more information, see

- Using Content Panes
• Types of Content Panes

My Tasks

My Tasks lists tasks that have been assigned to you within Collaborator Workbench.

In Collaborator Workbench, a task is a unit of work associated with a worksheet, which in turn corresponds to a set of data. A task can come either from another user or from automated processes that have been set up especially for your enterprise. When you receive a task, your goal is to open the associated worksheet, examine the data, adjust or approve it as necessary, and then mark the task as done. Then Collaborator Workbench automatically continues with the needed follow-up processes.

In My Tasks, you can do several things:

• Click a task to open it. Then see Managing Tasks.

• Specify how many tasks to display and how to sort them. See Configuring My Tasks.

Who's Online

Who's Online shows the status of other users of Collaborator Workbench who belong to the same collaborative groups as you.

To send an e-mail to a contact

In the Who’s Online pane, double-click the name of the contact that you want to send an e-mail to.

The e-mail application opens with a new message to the contact.

Note: If you do not have an e-mail application installed, then you will receive an error message when you try to send a message to another user.

See also:

• Managing the Collaborator Workbench

• Opening a Worksheet in Collaborator Workbench

• Personalizing Collaborator Workbench

Managing the Collaborator Workbench Page

The Collaborator Workbench page includes a set of panes, each of which you can hide or display as follows.
To minimize a pane
Click the minimize button in the upper right of the pane.
The pane is then hidden apart from its title bar.

To restore a minimize pane
Click the restore button in the upper right of the pane.

To refresh the data in a pane
Click the refresh button in the upper right of the pane.
Not all panes include this feature; Who’s Online and My Tasks are automatically updated with changes. The other panes are updated only when you specifically refresh them.

To close a pane
Click the close button in the upper right of the pane.
To redisplay a pane, see Personalizing Collaborator Workbench.

Typical Use of Collaborator Workbench
With Collaborator Workbench, the overall workflow would typically be as follows:
1. Log onto Collaborator Workbench, as in Logging into Collaborator Workbench.
2. Open a worksheet, as in Opening an Worksheet. When you open a worksheet, you automatically open Oracle Demantra Deduction and Settlement Management, Oracle Demantra Trade Promotion Planning, or Oracle Demantra Demand Management, whichever you are authorized to use.
3. View My Tasks. Each task includes a link to a worksheet that you open and work with as described previously. Open the worksheet and make changes or review the data as necessary. Then mark the task as Done so that the automated workflow can continue.
   See Managing Tasks.
4. Send tasks to other users, as necessary.
5. Log off Collaborator Workbench.

Outside of Collaborator Workbench, you usually receive tasks from the e-mail system that your enterprise uses. The e-mail message includes a link to a worksheet that you open and work with as described previously.
Logging Off

If you log off from Collaborator Workbench, you are automatically logged off from Oracle Demantra Settlement Management, Oracle Demantra Trade Promotion Planning, or Oracle Demantra Demand Management, if you had launched that.

To log off from Collaborator Workbench

Do any of the following:

• Click Logout.

• Click Home.

• Close the browser.

Ending a Hung Session

If your session hangs due to network or other problems, you will not be able to log in again until the session times out. Alternatively, Oracle Demantra provides a tool that you can use to end that session.

If your permission level is lower than System Manager, your own session is the only session you can see.

To end a hung session

1. Browse to the following case-sensitive URL:
   http://server name/virtual directory/portal/userManagement.jsp
   For example:
   http://frodo/demantra/portal/userManagement.jsp
   A login page appears.

2. Type your username and password and then click Log on.
   • Oracle Demantra displays the following screen:
3. Click Logout in the row corresponding to your user ID.

Changing Your Password

To change your password

1. Click the Administration link in the upper right of Collaborator Workbench.

2. Collaborator Workbench displays the following screen:

   ![User Management Console]

   3. Type your old password into Enter old password.

   4. Type your new password into the other two fields.

   5. Click OK.
Managing Tasks

This chapter covers the following topics:

- About Tasks
- Viewing Tasks Assigned to You
- Opening a Task
- Addressing a Task
- Creating and Sending a Task
- Resolving a Failed Task

About Tasks

In Collaborator Workbench, tasks enable you to send work items to other users, to share information and to interact with the automated demand chain processes. Tasks appear in the My Tasks module. A task usually corresponds to a worksheet that you send to another user or receive from another user. The task also can include a short message, links to Web sites, and attached files.

Note: When you receive a task, you might also receive an e-mail notification in your e-mail system, if the sender has selected this as an option.

The underlying Workflow Engine also sends tasks, generally to alert you of exceptions, provide forecasts, or communicate messages and information during appropriate circumstances.

Types of Tasks

There are three types of tasks:

- User tasks, which are sent to bring information to the attention and treatment of
individual users.

- Selection tasks, which present a list of options for you to choose among. Each choice directs the Workflow Engine to continue in a different way.

- Group tasks, which are sent for the attention and treatment of all users from a specific group defined in the workflow instance. Each user in the group receives the task. Users can respond individually to the task.

Only the Workflow Engine can send a selection task or group task; that is, your implementors have set up workflows to include such tasks, to meet the needs of your organization.

Task Timeout Procedures
Tasks that are sent to you by the Workflow Engine may also have a timeout period. This means that if you do not mark the task as done before the due date, then the task will expire or time out. Then the Workflow Engine continues with an alternative procedure.

User Tasks and Selection Tasks
A user task times out if the user does not mark the task as done before the response period has ended. The timeout procedure for a user task is as follows:
1. The user is sent an e-mail notification that the task has timed out.
2. The task is removed from the user’s task list.
3. The Workflow Engine continues with an alternative procedure that has been defined within the workflow for this circumstance.

Group Tasks
A group task times out if one or more of the users in the group do not mark the task as done before the response period has ended. The timeout procedure for a group task is as follows:
1. A user who is responsible for the relevant task receives an e-mail message notification of all the users within the group that have not marked the task as done. For example, this may be the group manager, or a supporting job function.
2. The task stays in the My Tasks module of the users who have not marked it as done.
3. The Workflow Engine continues with an alternative procedure that has been defined within the workflow for this circumstance.

Task Timeout Alert
If you see that a task due date is written in red text, then that is an indication that the
response period has nearly ended and the task is going to time out fairly soon.

See also:

- Viewing Tasks Assigned to You
- Addressing a Task
- Creating and Sending a Task

Viewing Tasks Assigned to You

In Collaborator Workbench, a task is a unit of work, usually associated with a worksheet. A task can come either from another user or from automated workflows that have been set up especially for your enterprise. All unaddressed tasks assigned to you are listed in a module called My Tasks, which looks like the following:

![My Tasks Module](image)

**Note:** If a task due date is shown in red text, that means the response period has nearly ended and the task is going to time out fairly soon.

To refresh My Tasks

Click Save & Refresh in the My Tasks module.

Any changes made in My Tasks are communicated to the Collaborator Workbench engine.

The date and time of your last My Tasks refresh is shown in the lower right corner of the My Tasks display.

The My Tasks module is initialized when it is first displayed, but it is not automatically updated when new tasks arrive. Also, when you make changes in this module, they are not immediately communicated to the Collaborator Workbench engine.
To view all assigned tasks

The My Tasks module does not necessarily display all your tasks. To check for additional tasks:

- Click the More link in the bottom right corner of My Tasks.
- My Tasks fills the wide pane and shows all current tasks.

To display My Tasks

If Collaborator Workbench does not currently display My Tasks, do the following:

1. Click Personalize.
2. Select the check box next to My Tasks and then click Next.
3. Click Next again and then click Finish

See also:

- About Tasks
- Configuring My Tasks
- Opening a Task
- Addressing a Task

Opening a Task

When you are sent a task, it brings with it information that is relevant to you. The information may be a Collaborator Workbench worksheet, an Oracle Demantra component worksheet, a link to another Web site, or an attachment. You should view all the information that is sent with the task before you respond.

For each task, My Tasks includes the following information:

- The Message field. This can contain a link to a Web site or a worksheet.
- An Assign Date field that shows when the task was sent to you.
- A Due Date field that shows the date by which the task should be completed, if applicable. If you do not complete a task by its due date, Oracle Demantra automatically continues with actions as specified by your implementors.
Note: If a task due date is displayed in red, the response period for that task has nearly ended and the task is going to time out fairly soon.

- A description field that describes more details about the task.
- The Attachment button that indicates that a file has been attached to the task. The suitable application for viewing the attachment is started in a separate window.

To open a task

Click the task link in the My Tasks module.

A new browser window opens with the link destination.

The task link can be a Web page that contains more information about the task that you are viewing. If the link is to a worksheet, then Oracle Demantra Demand Management or the Oracle Demantra component will open without requiring a separate login.

To view an attachment to a task

Click the Attachment button beside the task.

The attachment opens with the appropriate application in a new window or a message box appears asking if you want to open the attachment from its source or save it.

See also Addressing a Task.

Addressing a Task

In general, you address a task in two stages:

1. Examining the associated worksheet and editing or approving data as appropriate. How you do this depends upon your organizational needs.

2. Marking the task as done so that the Workflow Engine can continue with the workflow.

   Note: When you receive a task, the Workflow Engine waits until the task status has been changed to Done before continuing with the workflow instance. It is therefore very important that you mark tasks as done after you have attended to the task requirements.

To mark a task as done

Before you mark a task as done, make sure that you have reviewed all the relevant information and that you have addressed any concerns or issues. Then do the following:
1. First:
   - For a regular task, select the check box to the left of the task.
   - For a selection task, select the appropriate response from the dropdown list in the Select value column. The check box next to the task is automatically checked.

2. Click the Save & Refresh link at the bottom of the task list.
   The task is removed from My Tasks and the updated task list is shown.
   
   **Caution:** Click Save & Refresh before you go to another page or log off; otherwise, your changes will be lost.

To cancel the done status

If you have not yet refreshed the My Tasks list, you can cancel your change:

- For a regular task, clear the check box next to the task whose status you want to change from done incomplete.
- For a selection task, use the dropdown box to select a response from the list.

To mark all tasks as read

Click Mark Tasks as Read.

The bold emphasis is removed from the text in the list. This does not occur automatically when a task is marked as Done.

See also Opening a Task.

**Creating and Sending a Task**

Depending on how your Collaborator Workbench has been configured, you may be able to create tasks.

**To create and send a task**

1. Start by doing one of the following:
   - Within My Worksheets, click Send on the worksheet that you want to send.
   - Within My Tasks, click Create Task.
     
     The Send Task to User dialog box appears.
2. Click To..... and select the users and groups to receive the task.

3. In the Message field, type a short text message.
   This will be the task message that the recipient sees. The worksheet that you are sending will be added automatically as a link from the Message text.

4. In the Description field, type a short description.
   This description will be displayed below the task message in the recipient’s My Tasks module.

5. To link the task subject line to a Web page, enter the full path to the file in URL field.
   **Note:** You must enter the full URL, including server name and directory hierarchy. The http:// part will be added automatically if omitted.

6. To attach a file to the task, enter the path to the file in the File Attachment field or click the Browse button to find it.

7. To ensure that this task is completed by a specific time, click Escalate and then provide the following information:
Due Date
Date and time by which this task must be completed

Alert Time
Date and time at which an alert will be displayed

To
Additional e-mail addresses

8. To send an e-mail notification to the recipient of the task, select the Send email list check box. (Depending on how your system has been configured, this option may not be available.)

9. Click Send Task.

When the recipient next logs in (or refreshes My Tasks), he or she will see the new task.

Resolving a Failed Task

When a workflow fails, the Workflow Engine automatically sends a selection task to user who initiated that workflow. This task provides options for continuing. (The Workflow Engine also sends e-mail to the person who initiated that workflow.)

To resolve a failed task

1. Within My Tasks, find the failed task, which is displayed with the options to Retry, Continue, or Abort.

2. Try to identify the cause of the failure.

   A failure can happen for a variety of reasons, for example, an invalid worksheet or user, a database communication error, the Web server being down, or failure of an invoked external application. Check for such error conditions.

3. Specify how to proceed.

   • If you have corrected the underlying problem and you want to rerun the step that failed, click Retry.

   • If you have corrected the underlying problem and have performed the failed step manually, click Continue.

   • If you want to cancel execution of this workflow instance, click Abort.

4. Click the Save & Refresh link at the bottom of the task list.
If you cannot determine the cause, gather as much related information as possible, and contact Oracle Customer Support.
This chapter covers the following topics:

- Overview of Content Panes
- Types of Content Panes
- Displaying a Content Pane
- Refreshing a Content Pane
- Opening the Associated Worksheet
- Viewing the Definition of a Content Pane

**Overview of Content Panes**

In addition to core items (My Tasks, My Worksheets, and Who's Online), you usually display some content panes (or content) within Collaborator Workbench.

A content pane displays a graphical view of data associated with a worksheet, to provide you with current, at-a-glance information that meets your needs. You can display content in formats such as the following:

- Members Browser, which is a collapsible tree hierarchy of data levels
- Tabular format
- Chart formats including line, bar, and pie charts
- Calendar format

You use content panes to view simultaneously many presentations of demand chain information. Each content pane can be filtered to suit your needs. And you can make content panes made available to other users so that you can share your work with your enterprise partners.

**Refresh and Update Dates**
The bottom of each content pane shows two dates:

- Last Refresh is the last date and time when data was reloaded into this pane. Unlike the core panes (My Worksheets, My Tasks, and Who's Online), a content pane is updated only when you refresh the pane. See Refreshing a Content Pane.

- Last Update is the last date and time when this content pane was redefined.

### Worksheets and Content Panes

Worksheets and content panes are related to each other. All content panes are available as worksheets, but not all worksheets are available as content panes. Part of the definition of a worksheet includes a check box that enables the worksheet to be displayed as a content pane; if this check box is enabled, it is possible to specify what the content pane looks like.

See also Creating and Redefining Content Panes.

For information on the worksheets to which you have access, see My Worksheets.

### Editing Data in Content Panes

The data in the panes is read-only (except for in a Members Browser). In order to edit the data, you must open the worksheet associated with it.

See also:

- Displaying a Content Pane
- Configuring Your Default Layout
- Opening the Associated Worksheet

### Types of Content Panes

This section provides an overview of the types of content panes and allowed variations. Any content pane can include filtering and exceptions.

#### Members Browser Content Pane

A Members Browser is a collapsible tree hierarchy of data levels, like the following example:
You use this content pane for the following general purposes:

- To launch worksheets
- To view the attributes of a member.
- To create, edit, and delete members.
- To perform additional operations on members, as defined within your implementation.

See Using a members Browser Content Pane.

Note: This is the only type of content pane where you can make changes. The other content panes are purely informational.

Table Content Pane

A content pane can display data in a tabular format, like the following example:
Here the data is filtered to show a single brand (Snows Ice Cream) and is aggregated across that brand and all locations. In a case like this, it is helpful to use the title of the content pane to indicate how the data is filtered.

A table-style content pane cannot display data in crosstab format; that is, it cannot list SKUs or stores across the x- or y-axis. In contrast, a table in a worksheet can display data in that format.

**Line Chart Content Pane**

A content pane can display data in a line chart. A couple of variations are possible. You can display multiple series for a single member or a single combination, as follows:
Here each line represents a series. The data is filtered to show a single brand (Snows Ice Cream) and is aggregated across that brand and all locations. In a case like this, it is helpful to use the title of the content pane to indicate how the data is filtered.

Alternatively, you can display a single series for multiple members or combinations, as follows:
Here each line represents the forecast for a single SKU, aggregated across all locations where that SKU is sold. Alternatively, the chart could show a single line for each SKU at each store; other variations are possible. To show data separately for multiple items or multiple locations, you can include only one series.

**Stacked Bar Chart Content Pane**

A content pane can display data in a stacked bar chart, as in the following example:
In a content pane of this type, each series is shown in a separate color, chosen by the system. Each member or each combination is shown as a separate bar. In the preceding example, data is shown for three brands, and the chart has three bars. In contrast, in the next example, data is shown for ten SKU-store combinations.
Filtering of Stacked Bar Charts

Because of the limitations of screen space, Oracle Demantra automatically applies a filter to any stacked bar chart. By default, it displays the top ten members (or combinations) that have the highest demand. You can configure this filter to choose, for example, the five stores with the lowest return rates, if your system contains such data.

Time Aggregation

If you select the Content Definition, the time aggregation on the worksheet changes to N/A. Content definition using a stacked bar chart restricts the use of time aggregation. This type of content requires a top filter definition. When defining it, there are top filter fields to the right of Display Type. These fields:

- Have default values
- Define how many combinations to filter--top or bottom--and what series to take as a filter criteria when comparing values.

Such a definition:

- Retrieves the regular query for the worksheet
- Searches all combinations retrieved for the worksheet
- Finds the top n combinations according to the top filter criteria
• Displays their aggregated value

For every combination seen in the worksheet, only the aggregated value in time is displayed. Only the summary of all values for all dates retrieved for the specific combination and series are displayed. Since this is a two dimensional view where time is not a dimension, the time caption has no meaning.

**Pie Chart Content Pane**

A content pane can display data in a pie chart, as in the following example:

![Pie Chart Example](image)

Within a content pane, a pie chart works as follows:

• Only one series may be displayed (it is helpful to include the series name in the title of the content pane).

• You can include any number of aggregation levels. The pie chart displays one wedge for each resulting combination. Colors are chosen by the system.

Within worksheets, pie charts are more somewhat flexible, because more screen space is available.
Calendar Content Pane

A content pane can display a calendar that shows the values of one series, as in the following example:

For this type of content pane, you include a single series, whose values are shown for each time bucket in the calendar. Depending on your implementation, you can choose the size of time bucket to use: week, month, quarter, and so on. It is helpful to use the title of the content pane to indicate which series is displayed and how that is filtered.

Displaying a Content Pane

You can display a content pane in either of two ways:

- By temporarily displaying the pane without affecting your default layout.
- By changing your default layout to include the content pane.

To temporarily display a content pane

You can temporarily display a content pane without changing your default layout.
1. Click the Contents menu and then click the name of the worksheet, from the list of
available content panes.

2. Collaborator Workbench displays the selected content in the wide area (the left side), in place of any other panes in that area.

Note the change in the title bar. Also note that the narrow area is left as is.

3. To restore your default layout, click the My Collaborator Workbench link in the title bar.

To change your default layout to display a content pane

1. Click the Personalize link.

   The Personalize - Modules page appears. This page contains two lists: one for items that can be displayed in the wide pane and one for items that can be displayed in the narrow pane.

2. Select the check box next to the content pane you want to display.

   The Personalize - Order page appears. Like the previous page, this page has one list for the wide pane and one for the narrow pane.

3. Select a module and then click the up or down buttons to change its position in the list.

   The order here is the order in which these modules are shown in Collaborator Workbench.

4. Click Next.
The next page summarizes your choices. You can return to the previous pages to make further alterations.

5. Click Finish to save your changes. Or click Back to go back to the previous pages.

See also:
- Overview of Content Panes
- Creating and Redefining Content Panes
- Opening the Associated Worksheet

## Refreshing a Content Pane

When you first display a content pane, it contains the most recent data. However, after that, the data is static and does not refresh automatically. Also note that the content panes are not refreshed when you use the browser's refresh function.

**To refresh a content pane**

Click the Refresh button at the top of the content pane.

The content pane reloads with the most recent data, and Oracle Demantra changes the Last Refresh date.

---

## Opening the Associated Worksheet

Each content pane is associated with a corresponding worksheet. If you need to edit the data, you must open the worksheet to do so, because the content pane is read-only.

**To open a worksheet associated with a content pane**

Click the open button in the upper right of the pane.

See also Introduction to Oracle Demantra.

## Viewing the Definition of a Content Pane

The Info page displays information about the worksheet whose results are currently being displayed in a content pane.

**To view content information**

Click the information button in the upper right of the content pane.

The Info page appears.
Constraints displays the first exception, even if you have defined more than one.
Using a Members Browser Content Pane

This chapter covers the following topics:

• Introduction to the Members Browser
• Launching a Filtered Worksheet
• Viewing the Attributes of a Member
• About Creating, Editing, and Deleting Members
• Creating a Member
• Modifying a Member
• Deleting a Member
• Using Other Right-Click Menu Options

Introduction to the Members Browser

A content pane may include the Members Browser, which looks like the following:
You use this content pane for the following general purposes:

- To launch worksheets
- To view the attributes of a member.
- To create, edit, and delete members.
- To perform additional operations on members, as defined within your implementation.

These options are available on the right-click menu.

**Launching a Filtered Worksheet**

Depending on how your system has been configured, you may be able to open a worksheet from within a Members Browser; the worksheet is filtered to show only data relevant to the member from which you started.

The specific options are usually different for each aggregation level in your system.

**To open a member in a worksheet**

Do one of the following in a Members Browser:

- Right-click the member and then select **Open**. In this case, you are using the default worksheet associated with this level.

- Right-click the member and then select **Open With** and then select a worksheet.

The worksheet appears in a new window.

**Note:** Depending on how this worksheet is defined, it is filtered in one of two ways:

- Filtered by member, that is, filtered to show the member from which it was launched, aggregating across all combinations. In this case, the name of the worksheet is preceded by the name of the member by which you are filtering it.

- Filtered by combination, that is filtered to show the specific combination from which it was launched. In this case, the name of the worksheet is preceded by the word "Filtered".

**Viewing the Attributes of a Member**

**To view the attributes of a member**
1. In a Members Browser, do the following:

2. Right-click a member and click View (for example, View Ship to).

Oracle Demantra displays a dialog box like the following:

![Dialog Box](image_url)

The attributes shown in red are required. These include the Name attribute and all immediate parents of this member.

**About Creating, Editing, and Deleting Members**

For any level, most or all members are defined by data that is imported into Oracle Demantra. For example, the brands in your system are defined by the imported sales records, which include information about the brand of each item that is sold. The imported data specifies the attributes of the existing members.

Depending on your authorization, you might be able to edit or delete existing members and add new members of a given level. Permission is set separately for each level and potentially for each user.

If you make any of these changes, you should be aware of how Oracle Demantra interacts with your corporate systems. Oracle Demantra periodically imports data about sales, items, and locations from your other systems. Each time data is imported into
your system, the changes you have made to the levels are overwritten, depending on the kind of change.

- You should edit or delete existing members only if you are expecting the same change to occur in the imported data, and you need to see the change right away within Oracle Demantra for some reason.

- If you add members, they will be kept when data is imported.

Creating a Member

To create a member
1. Do one of the following within a Members Browser:
   - Right-click an existing object and then select New (for example, New SKU).
   - Right-click the blank area and then select the appropriate option.
     Demantra displays a window where you specify the name of the new member, as well as its parent levels and other attributes.

2. For Name, specify a unique name.

3. The rest of the fields prompt you for values of attributes associated with this level; the fields shown in red are required. The specific attributes you see depend upon your configuration.

4. Click Create.

   Note: You cannot see the new member in the Members Browser, because the Members Browser displays only item-location combinations that exist and that have sales.

Modifying a Member

You can modify a member by changing its name, the parent members to which it belongs, and any visible attributes.

To modify a member
1. In a Members Browser, do the following:

2. Right-click a member and click Edit (for example, Edit SKU). Then make changes as needed; see Creating a Member for details.

3. Click Finish.
Deleting a Member

To delete a member

1. In a Members Browser, right-click a member and click Delete (for example, Delete SKU).

2. Oracle Demantra prompts you to confirm the action. Click Yes or No.

Using Other Right-Click Menu Options

Depending on your implementation, the right-click menu may include a Methods submenu that includes additional options created by your implementors:

When you click one of these options, Oracle Demantra displays a dialog box like the following:

Select the Save parameters check box if you want to save the attribute changes to the database when the method is run.
For information on any such menu items, please contact your implementors or your designated Oracle Demantra system administrator.
This chapter covers the following topics:

- Overview
- Configuring Your Default Layout
- Configuring My Tasks
- Configuring My Worksheets

Overview

You can set up Collaborator Workbench to display any information you want to see. You can specify which modules you want to see and open as many modules as you like, each module showing different information. By positioning required modules in the wide and narrow panes, you will be able to view information that is important to you together on one page.

You can configure the position of a module on the Web page and also the way the information contained in the modules is presented. You can configure My Tasks and My Worksheets to specify which worksheets are shown and how many tasks are listed.

Configuring Your Default Layout

The Collaborator Workbench page includes a wide pane and a narrow pane, and each pane has a possible set of modules that it can display. You choose the modules and their display order, top to bottom.

**Note:** Your choices here affect your default layout in both Collaborator Workbench and Oracle Demantra Anywhere.

To personalize your default layout
1. Click the Personalize link.

The Personalize - Modules page appears. This page contains two lists: one for items that can be displayed in the wide pane and one for items that can be displayed in the narrow pane.

<table>
<thead>
<tr>
<th>Wide Pane</th>
<th>Narrow Pane</th>
</tr>
</thead>
<tbody>
<tr>
<td>c. Revenue per Regional Manager</td>
<td>c. 12 Months Revenue by Region</td>
</tr>
<tr>
<td>✔ My Worksheets</td>
<td>✔ Who's Online</td>
</tr>
<tr>
<td>✔ My Tasks</td>
<td>✔ c. MY Private Label SKU</td>
</tr>
<tr>
<td>✔ Promotion Status</td>
<td>✔ PE_Test</td>
</tr>
<tr>
<td>✔ Test Table</td>
<td>✔</td>
</tr>
</tbody>
</table>

These lists include the following:

- My Tasks and My Worksheets, which can be displayed only in the wide pane.
- Who's Online, which can be displayed only in the narrow pane.
- Worksheets that have been defined as content and to which you have access. When a worksheet is defined as content, it is defined as belonging to the wide pane or the narrow pane. If you own the worksheet, you can change this; see Creating and Redefining Content Panes.

2. In each list, use the check boxes to select or deselect the modules that you want to see.

3. Click Next.

The Personalize - Order page appears. Like the previous page, this page has one list for the wide pane and one for the narrow pane.
4. Select a module and then click the up or down buttons to change its position in the list.

The order here is the order in which these modules are shown in Collaborator Workbench.

5. Click Next.

The next page summarizes your choices. You can return to the previous pages to make further alterations.

6. Click Finish to save your changes. Or click Back to go back to the previous page.

Configuring My Tasks

You can configure the number of tasks to appear in My Tasks. You can order tasks by the different task fields and decide how many tasks you would like displayed. In this way you can, for instance, show the last few tasks that you have been sent, or the oldest ones.

To configure My Tasks

1. If Collaborator Workbench is not currently displaying My Tasks, then display it as described in Configuring Your Default Layout.

2. In My Tasks module, click the personalize button in the upper right corner of the pane.

Collaborator Workbench displays a page like the following:
3. In the Number of Tasks to View field, type the maximum number of tasks that you want to see in My Tasks.

4. From the Order Tasks by list, select the field by which you want to list the tasks.

5. From the Sort dropdown menu, select the sorting order that you want for the tasks. Task fields can be listed in either ascending or descending order.

6. Click Finish.
   My Collaborator Workbench refreshes with My Tasks in the new configuration.

**Configuring My Worksheets**

You can configure how many and which worksheets are shown in My Worksheets.

**To configure My Worksheets**

1. If Collaborator Workbench is not currently displaying My Worksheets, then display it as described in Configuring Your Default Layout.

2. In My Worksheets module, click the personalize button in the upper right corner. Collaborator Workbench displays a list of all available worksheets. This includes all worksheets you own and all public worksheets.
3. Select the check box next to each worksheet that you want to display.

4. Click Next.

Collaborator Workbench displays a new page where you specify how many worksheets to display as well as the display order for the worksheets you have selected.
5. In the Number of Worksheets to View field, type the maximum number of worksheets that you want to see in My Worksheets.

6. In the Order list, click a worksheet and then click the up or down arrows to specify the display order of that worksheet. Repeat as necessary.

7. Click Finish to save your changes. Or click Back to go back to the previous page.
Creating and Redefining Content Panes

This chapter covers the following topics:

- Creating or Editing Content Panes
- Introduction to the Content Pane Editor
- Configuring the Basics
- Selecting Series on a Content Pane
- Specifying the Time Resolution and Time Span
- Specifying Aggregation Levels
- Using the Advanced Selection Options
- Changing the Overall Scale or Unit of Measure
- Filtering the Content
- Applying Exception Filters
- Sharing Content Panes
- Deleting Content Panes

Creating or Editing Content Panes

To create a new content pane

Click Contents > New...

To edit an existing content pane

1. Display the content pane in Collaborator Workbench; see Displaying a Content Pane.

2. At the top of the pane, click the Edit button.

3. Make changes in the content pane editor; see Introduction to the Content Pane
4. Click Save.

When you change the definition of a content pane, Oracle Demantra changes the Last Update date for that content pane.

---

**Introduction to the Content Pane Editor**

The content pane editor is the same tool that you use to create worksheets (in Oracle Demantra Demand Management, for example), and some of the options apply only to worksheets, as noted in this documentation.

The content pane editor has a set of buttons on the left, which you click to open different pages with different purposes:

<table>
<thead>
<tr>
<th>Button</th>
<th>Purpose</th>
<th>For details, see...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Specify basic information about the content pane.</td>
<td>“Configuring the Basics”</td>
</tr>
<tr>
<td>Series</td>
<td>Select series to include.</td>
<td>“Selecting Series on a Content Pane”</td>
</tr>
<tr>
<td>Time</td>
<td>Specify time resolution of content pane and span of time to consider.</td>
<td>“Specifying the Time Resolution and Time Span”</td>
</tr>
<tr>
<td>Aggregation Levels</td>
<td>Optionally specify aggregation levels to include, which controls which members and combinations are displayed.</td>
<td>“Specifying Aggregation Levels”</td>
</tr>
<tr>
<td>Filters</td>
<td>Optionally filter the data in the content pane.</td>
<td>“Filtering the Content”</td>
</tr>
<tr>
<td>Exceptions</td>
<td>Optionally apply exception filters to further filter the worksheet.</td>
<td>“Applying Exception Filters”</td>
</tr>
</tbody>
</table>
Here you have the following options:

- To move to another page, either click a button on the left side of the page or click Previous or Next.
- To exit the editor and keep your changes, click OK.
- To exit the editor and discard all changes, click Cancel.

**Rules of Types of Content Panes**

Depending on the format of the content pane, you may or may not be able to select multiple series and levels. The following table summarizes the applicable rules for each type of content pane.

<table>
<thead>
<tr>
<th>Type</th>
<th>Aggregation levels</th>
<th>Series</th>
</tr>
</thead>
<tbody>
<tr>
<td>Members Browser</td>
<td>Select any number of levels.</td>
<td>Select one series (required for technical reasons; it is ignored).</td>
</tr>
<tr>
<td>Table</td>
<td>Do not select any levels.</td>
<td>Select any number of series.</td>
</tr>
<tr>
<td>Line chart</td>
<td>Variation 1: Do not select any levels.</td>
<td>Select any number of series.</td>
</tr>
<tr>
<td>Line chart</td>
<td>Variation 2: Select any number of levels.</td>
<td>Select only one series.</td>
</tr>
<tr>
<td>Bar chart</td>
<td>Select any number of levels.</td>
<td>Select any number of series.</td>
</tr>
<tr>
<td>Pie chart</td>
<td>Select any number of levels.</td>
<td>Select one series.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Do not select any levels.</td>
<td>Select one series.</td>
</tr>
</tbody>
</table>

Also:
- For all types of content panes, there are no restrictions on the options on the Time,
Filters, or Exceptions screens.

- The Layout screen has no effect on any content pane.
- For content panes that permit multiple levels, the Aggregation screen controls the order in which the levels are used. (For worksheets, the order of the levels here is ignored, because the Layout screen is used.)

**Working with Lists**

As you create or edit content panes, you will often use pages that present two lists of elements, where you specify your selections. To do so, you move elements from the left list to the right list. The left list always presents the available elements (such as the available series) and the right list always shows your selections.

You can move elements from one list to the other in many equivalent ways, summarized here:

- To move all elements from one list to the other, click one of the double arrow buttons, as appropriate.

- To move a single element from one list to the other, click the element and then click one of the single arrow buttons, as appropriate. Or double-click the element.

- To move several adjacent elements, click the first element, press Shift and click the last element. Then click one of the single arrow buttons, as appropriate.

- To move several elements that are not adjacent, press Ctrl and click each element you want. Then click one of the single arrow buttons, as appropriate.

**Configuring the Basics**

To configure basic information for a content pane

1. Start the content pane editor; see "Creating or Editing Content Panes".

   The first screen lets you specify the following basic information:
Creating and Redefining Content Panes

Name: 000c. Introduction - Multi-view

Description: [Empty]

Access
- Private
- Public

Enable Extra Filters

Cache Worksheet Data

Refresh Type Manual

2. Check Content and then complete the following fields:

**Content Definition**

- **Display Format**: Line Graph
- **Location**: Wide Pane
- **Top/Bottom Filter**: Top 10

**Display Format**

- Specifies the display format to use. See Types of Content Panes.
Location

Select Wide Pane or Narrow Pane to determine where the content pane will be displayed in Collaborator Workbench.

Top/Bottom Filter

(Only for bar charts.) Specifies how to filter the members or combinations for display in the bar chart (to save space, not all members are shown). See "Filtering of Stacked Bar Charts".

Use the dropdown menu to specify whether the filter should apply to the top-ranked or to bottom-ranked members.

In the input field, specify the number of members to be included.

For Criteria Series, select the series that Oracle Demantra should use to rank the members. (This does not control the order in which they are displayed in the chart.)

Note: If multiple items have identical values, all of them are displayed, and they collectively count as 1 towards the total. For example, suppose top values were 200, 150, 150, 100, and 50. If you specified Top/Bottom filter as three, you would see a total of four items: both the 150 items, in addition to the 200 and 100 items.

Tips for titles of content panes

To save space, the content panes do not include as many labels as you see in worksheets. The following table summarizes what is shown in each kind of content pane and provides suggestions for titles that provide the missing information; your actual needs may vary.

<table>
<thead>
<tr>
<th>Type</th>
<th>Labels displayed in the pane</th>
<th>Suggestions for pane title</th>
</tr>
</thead>
<tbody>
<tr>
<td>Members Browser</td>
<td>Names of the level members. For example, if you display SKUs and stores, the SKU and store names are shown.</td>
<td></td>
</tr>
</tbody>
</table>
Creating and Redefining Content Panes

Type Labels displayed in the pane Suggestions for pane title

Table Name of each series. A useful title would indicate how these series are aggregated and filtered.

Line chart with multiple series Name of each series. A useful title would indicate how these series are aggregated and filtered.

Line chart with a single series Name of each member or combination, as appropriate. A useful title would indicate the name of the series.

Bar chart Name of each series. Name of each member or combination, as appropriate.

Pie chart Name of each member or combination, as appropriate. A useful title would indicate the name of the series.

Calendar Name of each time bucket. A useful title would indicate the name of the series.

Selecting Series on a Content Pane

For technical reasons, every content pane must include at least one series. Depending on the format of the content pane, you may or may not be able to select multiple series. The following table summarizes the applicable rules:

<table>
<thead>
<tr>
<th>Type</th>
<th>Series</th>
</tr>
</thead>
<tbody>
<tr>
<td>Members Browser</td>
<td>Select one series (it is ignored).</td>
</tr>
<tr>
<td>Table</td>
<td>Select any number of series.</td>
</tr>
<tr>
<td>Line chart</td>
<td>If you plan to select any levels, select only one series. Otherwise, select any number of series.</td>
</tr>
<tr>
<td>Type</td>
<td>Series</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>Bar chart</td>
<td>Select any number of series.</td>
</tr>
<tr>
<td>Pie chart</td>
<td>Select one series.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Select one series.</td>
</tr>
</tbody>
</table>

To specify the series on a content pane

1. Start the content pane editor; see "Creating or Editing Content Panes".

2. Click Series.

   The system displays the Available Series and Selected Series lists. Each list is a collapsible list of series groups and the series in them.

   ![Available and Selected Series lists](image)

3. Move all series that you want into the Selected Series list. To do so, either double-click each series or drag and drop it. You can also move an entire series group from one list to the other in the same way.

4. Remove any series from the Selected Series list that you do not want to include on the worksheet.

   **Note:** You cannot remove a series from a worksheet if that
Creating and Redefining Content Panes

worksheet uses it as the Criteria Series for bar chart content. See Step 2.

**Note:** Currently, Collaborator Workbench chooses the color to use for each series in the graphs.

---

**Managing the Series Lists**

You may have a very large number of series, and it can be useful to sort and filter these lists so that you can readily find what you need. The system also provides a search mechanism.

**Note:** This section applies only to the series page of the content pane editor.

To sort a list of series

1. Click the Sort button.
   The Sort dialog box is displayed.
2. Drag the list name from the Available Columns to the Sort Columns. Or double-click the list name in the Available Columns list.
3. Click OK.

To filter a list of series

1. Click the Filter button.
   - The Filter page appears.
2. Click Add.
3. Click the arrow to the right of the operator box and select an operator from the dropdown list.
4. In the number box, enter the value by which to filter the list.
5. (Optional) You may filter further by using the AND relationship.
6. Click OK.

To find a series
1. Click the Find button.
   The Find dialog box appears.

2. In the Find where box, select the name of the list to search.

3. In the Find what box, type name of the series.

4. Select Up, Down or All to determine the direction of the search.

5. (Optional) Select one or more of the check boxes:
   • Whole Word: Search for the exact match of a word.
   • Match Case: Search for the exact match of a word (case sensitive).

6. Click Find Next to begin (or continue) searching.

**Specifying the Time Resolution and Time Span**

You use the Time dialog box to specify the time resolution of the content pane and to decide the span of time to which the content pane applies.

To specify time criteria

1. Start the content pane editor; see "Creating or Editing Content Panes".

2. Click Time.
3. In the Time Scale box, specify the time resolution of the content pane. The data in the content pane is aggregated to this time resolution. That is, this option specifies the period of time that each data point in the content pane represents.

4. In the Time Filter box, specify the time period to which the content pane applies:
   - Fixed if you always want the content pane to show a specific time range, regardless of the current date.
   - Relative to Today if you always want the content pane to show a time range relative to today.
   - Relative to Last Sales Date if you always want the content pane to show a time range relative to the last sales date in the loaded data.

5. In the From Date and To Date boxes, enter values depending on the time filter you have chosen, as follows:

<table>
<thead>
<tr>
<th>Time Filter</th>
<th>Box</th>
<th>Action</th>
</tr>
</thead>
</table>
| Relative      | From Date/To Date | Specify periods in both From and To with the current (computer) date as the reference point.  
For example: If the Time Scale is Month, and you want to see results starting from six months before today, enter -6 in From Date. |
| Fixed         | From Date | Enter a specific date as a starting point. To enter a date, click the calendar button and select a date. |
|               | To Date   | Specify the number of periods you want to include, starting from the From date. |

6. To control how dates are displayed in the content pane, click the Advanced button, which brings up the following dialog box:
• In the Format dropdown list, select a display format.

• To offset the displayed dates, optionally specify values for Month Offset or Year Offset.
   For example, to add one month to each displayed date, specify 1 for Month Offset.
   The Preview field shows what the first time bucket in the worksheet would look like with this format and offset.

• Click OK.

Note:
If you change the time scale, the content pane might not show exactly the same aggregate numbers, because the cutoff points for the content pane would not necessarily be the same. For example, suppose your content pane is weekly and displays 48 weeks of data. Then suppose you change it to display quarterly data. A quarter is 13 weeks, and the original span (48 weeks) is not an integer multiple of 13. So the content pane selects a different amount of data and shows different overall results.

Specifying Aggregation Levels
Depending on the format of the content pane, you may or may not be able to select levels; this in turn controls which members and combinations are displayed in the pane. The following table summarizes the applicable rules.
Creating and Redefining Content Panes

<table>
<thead>
<tr>
<th>Type</th>
<th>Aggregation levels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Members Browser</td>
<td>Select any number of levels.</td>
</tr>
<tr>
<td>Table</td>
<td>Do not select any levels.</td>
</tr>
<tr>
<td>Line chart</td>
<td>If you plan to select more than one series, do not select any levels.</td>
</tr>
<tr>
<td>Bar chart</td>
<td>Select any number of levels.</td>
</tr>
<tr>
<td>Pie chart</td>
<td>Select any number of levels.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Do not select any levels.</td>
</tr>
</tbody>
</table>

If you do not specify any aggregation levels in a worksheet, the data is completely aggregated across all items and locations (but of course, it may be filtered; you can filter any kind of content pane).

To specify the aggregation levels in a content pane

1. Start the content pane editor; see "Creating or Editing Content Panes".

2. Click Aggregation.

   The system displays the Available Levels and Selected Levels lists.

3. Move all aggregation levels that you want into the Selected Levels list, using any of the techniques in "Working with Lists".

   **Note:** For content panes that permit multiple levels, this screen controls the order in which the levels are used. (For worksheets, the order of the levels here is ignored, because the Layout screen is used.)

4. Remove any unwanted levels from the Selected Levels list.
See also:

- Using the Advanced Selection Options
- Changing the Overall Scale or Unit of Measure

**Using the Advanced Selection Options**

By default, if a content pane includes a promotion level, the pane selects all the following combinations:

- Combinations that have both sales data and promotions
- Combinations that have sales data, but no promotions
- Combinations that have promotions, but no sales data

The content pane displays placeholders for combinations that do not have promotions. For example:
You can exclude some of these combinations. For example, you might want the pane to include only the combinations that have both sales and promotions, as follows:

To exclude combinations that are normally included
1. Start the content pane editor; see “Creating or Editing Content Panes”
2. Click Aggregation.
3. Make sure that the worksheet includes at least two levels, one of which should be a promotional level. When you do so, the screen displays an Advanced button in the lower right.
4. Click Advanced. Oracle displays a dialog box with additional options.
Include combinations that exist only in Promotion
This option selects combinations that have associated promotions, even if they do not have sales data.

Include combinations that exist only in SALES_DATA
This option selects combinations that have sales data, even if they do not have any associated promotions.

5. To exclude the combinations you do not want to see, select the checkboxes as needed.

See also Specifying Aggregation Levels.

Changing the Overall Scale or Unit of Measure

Any given content pane uses a single overall scaling factor and a single unit of measure. You can change either or both of these. When you make this change, the displayed values for most or all of the series are changed.

**Note:** This change affects only the series that are scaled. Not all series are scaled. For example, a series defined as a percentage is probably not scaled.

**To change the overall scaling factor**

1. Start the content pane editor; see "Creating or Editing Content Panes".

2. Click Aggregation.

   The Levels page includes a section where you specify the overall scale of the content pane, as well as its units of measure.

3. In the Scale Units by box, specify the factor by which all numbers in the content pane are to be divided (for display purposes).

   For example, if you specify a factor of 1000, the displayed data will divided by 1000. So the number 96,000 will be displayed as 96. The vertical axis of the graph is
updated to show the factor in parentheses.

**To change the unit of measure**

1. Start the content pane editor; see "Creating or Editing Content Panes".

2. Click Aggregation.

3. In the Unit Type box, select the unit of measure to display in the worksheet results.
   For example, our items are bottles, and suppose that a case that contains six bottles. If you display the content pane with cases instead, the system will display the number of bottles divided by six.

4. If the Index box is displayed, choose an index from the dropdown list.

   ![Select Units]

   The Index menu lists all the time-dependent indexes and exchange rates that are associated with this unit. Each index or exchange rate is a time-varying factor that the content pane can use. When you select an index, the content pane will automatically multiply all monetary series by the factor for each date. For example, if you choose Consumer Price Index (CPI) as the index, the system will calculate all monetary quantities with relation to the CPI.

   **Note:** These indexes and exchange rates are generally imported from other systems. The set available to you depends upon your implementation.

See also Specifying Aggregation Levels.

**Filtering the Content**

You can filter any kind of content pane. You specify the scope of the content pane by filtering the data that it displays, so that it displays only selected members of specific aggregation levels. These aggregation levels do not have to be the same as the aggregation levels you display in the worksheet.

This filter is applied in addition to any filters associated with your user access.

In contrast to an exception filter (see Applying Exception Filters), this type of filter is
static and behaves the same no matter how the data changes.

**To filter data**

1. Start the content pane editor; see Creating or Editing Content Panes.

2. Click Filters.

   The system displays the Available Filter Levels and Selected Filter Levels lists.

3. Find the aggregation level at which you want to filter data and move it from the Available Filter Levels list into the Selected Filter Levels list, using any of the techniques in Working with Lists.

4. In the Available Members list, find a member that you want to include in the content pane and move it into the Selected Members list, using any of the techniques in Working with Lists.

   At this stage, the content pane includes only data for this member. (Before you applied a filter at this level, the content pane could theoretically include any member of this level.)

5. Continue to move members from the Available Members list into the Selected Members list, until the latter list includes all the members you want.

![Screenshot of available and selected filter levels](image)

**To filter data further**

Once you have applied a filter, the content pane contains only those members that meet the filter criteria that you specified. To avoid performance issues and database errors, there are system limits on the number of members that the each filter can select and that it can display in the Available Filter Level List. Therefore, the visible list may not include all the members that meet the filter criteria that you specified.

You can further filter the data by using either of these techniques:

- Filter member search: You search for a specific member in the visible list and the specific member is highlighted.

- Filter member filter: You apply another filter to the visible list to reduce it further.
When you apply a filter member filter to the results of the first filter, it behaves differently depending on whether the visible list is complete or incomplete.

If the visible list from the first filter is complete, it shows all the members that meet the filter criteria that you specified in the initial filter. The second filter member filter searches on the members in the visible list. For example:

- There is a system limit of 1000 members to display in the visible list.
- You have a worksheet with 10,000 members.
- You apply a filter at the SKU level and 1000 of the members meet the filter criteria. The visible list displays the 1000 members; the visible list is complete.
- You apply a filter member filter for which there are 200 matches in the worksheet using both filters.
- This second filter searches the complete visible list that you retrieved with the first filter and displays the 200 matching members.

If the visible list from the first filter is incomplete, it does not show all the members that meet the filter criteria that you specified in the initial filter. It was subject to system limits. When you apply a further filter to the visible list, the list may not include all the data that you want to filter to. Therefore, this second filter searches on all the members in the full worksheet. For example:

- There is a system limit of 1000 members to display in the visible list.
- You have a worksheet with 10,000 members.
- You apply a filter at the SKU level and 2000 of the members meet the filter criteria. The visible list displays 1000 of the 2000 members because of the system limit; the visible list is incomplete.
- You apply a filter member filter for which there are 200 matches in the worksheet using both filters. However the incomplete variable list only contains 37 members that would match in the worksheet using both filters.
- If this second filter searched on the visible list, it would only display 37 matching members. Instead, it applies both filters to all the members in the full worksheet and displays the 200 matching members.

See also Applying Exception Filters.

**Managing the List of Members**

Depending on how your system has been configured, it might contain a very large number of members. If so, you might want to sort or filter the list or search it. For
Applying Exception Filters

You can apply an exception filter to any kind of content pane. If you do so, Oracle Demantra checks the values of the data and displays only the combinations that meet the exception criteria. In contrast to an explicit filter ("Filtering the Content"), this type of filter is dynamic and can behave differently as the data changes.

Specifically, you define an exception condition that consists of a series, a comparison operator, and a value, for example:

<table>
<thead>
<tr>
<th>Exceptions Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales Plan</td>
</tr>
</tbody>
</table>

When you open the content pane, Oracle Demantra checks each combination in the content pane. For each combination, if the condition is met for any time in the worksheet date range, Oracle Demantra displays that combination. For example, the content pane shows combinations that have Sales Plan values greater than or equal to 150000, within the time range included in the worksheet.

If the condition is not met at any time for any of the worksheet combinations, Oracle Demantra shows the worksheet as empty. That is, if all values in the Sales series are less than 150000 for all combinations, the worksheet comes up empty.

**Note:** If the worksheet includes a promotion level or a promotion series, the behavior is slightly different. In this case, the Members Browser or dropdown list does initially show all combinations. When you click display a combination to display it, the worksheet then checks for exceptions.

You can apply multiple exceptions. When you do so, you can relate them to each other through logical AND or logical OR relationships. For example:

<table>
<thead>
<tr>
<th>Exceptions Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base Frest</td>
</tr>
<tr>
<td>Discount</td>
</tr>
</tbody>
</table>

**To apply an exception filter**

1. Start the content pane editor; see Creating or Editing Content Panes.
2. Click Exceptions.
The Exceptions Filter page appears.

3. Click Add.

4. In the first box in the new row, select a series from the dropdown list.
   
   **Note:** Typically only some series are available for exceptions. If you do not see a series you need, contact your Oracle Demantra administrator or your implementors.

5. In the second box, select an operator from the dropdown list.

6. In the third box, type or choose a value.
   
<table>
<thead>
<tr>
<th>Exceptions Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discount</td>
</tr>
<tr>
<td>&lt;</td>
</tr>
<tr>
<td>50.0</td>
</tr>
</tbody>
</table>
   
   • For a numeric series, type a number.
   
   • For a dropdown series, choose one of the allowed values of this series.
   
   • For a string-type series, type any string. You can use the percent character (%) as a wildcard.
   
   • For a date-type series, type a date or use the calendar control to choose a date.

7. (Optional) You can apply additional exceptions. Click the AND or the OR radio button to specify that the relationship between the exceptions.

**To delete an exception filer**

Click the exception and then click Delete.

See also Filtering the Content.

**Sharing Content Panes**

In general, any content pane is one of the following:

• Private—available only to you
• Public—available to other users as well.

In either case, the original creator of a pane owns it and only that person can change it.

When you do share content panes, however, you should consider data security. Oracle Demantra automatically prevents any user from seeing data for which he or she does not have permissions. If you build a content pane with data that other users do not have permissions to view, then those users will see an empty content pane. Similarly, if a user has partial permissions for the data, then the content pane will open with only those results that are permitted.

See also Configuring the Basics.

Deleting Content Panes

You can delete a content pane if you are its owner.

To delete a content pane

1. Display the content pane in Collaborator Workbench.

2. Click the Delete button.

   Oracle Demantra prompts you to confirm the deletion.

3. Click Yes or No.
This chapter covers the following topics:

- Introduction to Oracle Demantra Anywhere
- Logging Onto Oracle Demantra Anywhere
- Opening a Worksheet in Demantra Anywhere
- Using Worksheets in Oracle Demantra Anywhere

**Introduction to Oracle Demantra Anywhere**

By using Oracle Demantra Anywhere, you can access worksheets remotely and perform many of the same tasks described earlier in this manual.

**Note:** Oracle Demantra Anywhere does not enable you to work offline. That is, you have access to the data only while you are actually logged on. For information on taking a worksheet offline, see Working Offline.

In contrast to the other Oracle Demantra products, Oracle Demantra Anywhere is a true thin Web client and does not require an applet. You can use it to access Oracle Demantra functionality from remote machines, including handheld devices.

On the other hand, Oracle Demantra Anywhere provides less functionality than the other products. It does not show graphs, it does not display any subtabs of a worksheet, and it displays dropdown menus instead of a Members Browser. Other differences are listed below.

**Data Availability in Oracle Demantra Anywhere**

Oracle Demantra Anywhere treats data in the same way as other Oracle Demantra products:

- Information in Oracle Demantra is secured, and different users have permission to view different data. For details, see the Oracle Demantra Implementation Guide.
• The changes you make are not always visible immediately.

• The same tips for session management apply to Oracle Demantra Anywhere.

  • Your session expires if you do not refresh the page periodically. Be sure to refresh the page so that you do not lose data. To do so, click Data > Rerun. If you just mark check boxes or make selections, those actions do not reset the expiration counter.

  • If you try to refresh the page after your session has expired, an error message informs you that the session has expired. Any work that was done since the last refresh will be lost. An automatic logoff is performed and a page opens with a link to return you to the login page.

• Depending on how your system was configured, new data might be available throughout the day. The data is not automatically loaded into your worksheet because that could disrupt your work. To get the latest data, click Data > Rerun.

**Collaboration Features in Oracle Demantra Anywhere**

If you use the Oracle Demantra Anywhere version of Collaborator Workbench, Oracle Demantra Anywhere provides all the options that Collaborator Workbench provides.

If you use the Oracle Demantra Anywhere version of Web client, Oracle Demantra Anywhere does not support any of the options of Collaborator Workbench. For example, it does not include My Tasks or Who’s Online.

**Worksheet and Content Features in Oracle Demantra Anywhere**

The following table summarizes the features in Oracle Demantra Anywhere that relate to worksheets and content panes.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Availability in Oracle Demantra Anywhere</th>
</tr>
</thead>
<tbody>
<tr>
<td>Worksheet elements</td>
<td>If the worksheet includes subtabs, Oracle Demantra Anywhere does not display them.</td>
</tr>
<tr>
<td>Feature</td>
<td>Availability in Oracle Demantra Anywhere</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>Menu bar</td>
<td>Not available. Instead use the icons in the toolbar.</td>
</tr>
<tr>
<td>Right-click menus</td>
<td>Browser menu options only.</td>
</tr>
<tr>
<td>Opening and running worksheets</td>
<td>Can open and close worksheets.</td>
</tr>
<tr>
<td></td>
<td>Can rerun currently open worksheet.</td>
</tr>
<tr>
<td></td>
<td>Cannot view worksheet definition.</td>
</tr>
<tr>
<td></td>
<td>Cannot take worksheets offline or bring back online.</td>
</tr>
<tr>
<td>Managing the screen</td>
<td>If you open multiple worksheets, each is opened in a separate browser.</td>
</tr>
<tr>
<td></td>
<td>Cannot resize different worksheet areas (for example, the table).</td>
</tr>
<tr>
<td></td>
<td>Cannot resize table columns.</td>
</tr>
<tr>
<td>Members Browser content pane</td>
<td>Available as in Collaborator Workbench.</td>
</tr>
<tr>
<td>Editing data</td>
<td>Can edit one cell at a time.</td>
</tr>
<tr>
<td></td>
<td>Can copy and paste data from cell to cell, one cell at a time.</td>
</tr>
<tr>
<td></td>
<td>Can reset manual changes.</td>
</tr>
<tr>
<td></td>
<td>Can save data.</td>
</tr>
<tr>
<td></td>
<td>Cannot undo.</td>
</tr>
<tr>
<td>Printing</td>
<td>Can print the data that is currently displayed.</td>
</tr>
<tr>
<td>Exporting data</td>
<td>Not available.</td>
</tr>
<tr>
<td>Notes</td>
<td>Can view notes.</td>
</tr>
<tr>
<td></td>
<td>Cannot edit or create notes.</td>
</tr>
<tr>
<td></td>
<td>Cannot alter note permissions.</td>
</tr>
<tr>
<td>Creating and redefining worksheets and</td>
<td>Not available.</td>
</tr>
<tr>
<td>content panes</td>
<td></td>
</tr>
</tbody>
</table>
Feature | Availability in Oracle Demantra Anywhere
---|---
Running simulations | Not available.

Other Features in Oracle Demantra Anywhere

The other features in Oracle Demantra Anywhere behave the same as in Collaborator Workbench:

- Menus

- Personalize link (note that your choices here affect both your view of both Collaborator Workbench and Oracle Demantra Anywhere)

Logging Onto Oracle Demantra Anywhere

Oracle Demantra Anywhere requires a license, and you use a different login page depending on whether you also have a license for Collaborator Workbench. Also, the appearance of the Demantra Anywhere page depends on whether you have a license for Collaborator Workbench.

To log onto Oracle Demantra Anywhere

1. Open Microsoft Internet Explorer.
2. Enter the URL supplied by your system administrator.
   - If you have a license for Collaborator Workbench, this URL probably has the following format:
     http://server name/virtual directory/portal/remoteloginpage.jsp For example:
     http://frodo/demantra/portal/remoteloginpage.jsp
   - If you do not have a license for Collaborator Workbench, this URL probably has the following format instead:
     http://server name/virtual directory/portal/anywhereLogin.jsp For example:
     http://frodo/demantra/portal/anywhereLogin.jsp
3. In the login dialog box, enter your user name and password.
4. Click Login.

If you do have a license for Collaborator Workbench, Oracle Demantra Anywhere page looks very much like the Collaborator Workbench page. The words "Demantra Anywhere" appear next to your user name in the yellow bar to remind you that you
have logged in remotely.

If you do not have a license for Collaborator Workbench, the Oracle Demantra Anywhere page looks like this:

### Opening a Worksheet in Demantra Anywhere

To open a worksheet

Click the name of the worksheet.

To run or rerun a worksheet

Depending on how Oracle Demantra was configured, it may or may not automatically run the worksheet that you open.

Within the worksheet, click Data > Rerun.

See also Opening a Worksheet in Collaborator Workbench.
Using Worksheets in Oracle Demantra Anywhere

Within Oracle Demantra Anywhere, you can access any public worksheet created in Oracle Demantra, but the worksheets have a simplified appearance, like this:

<table>
<thead>
<tr>
<th>Time</th>
<th>Final Plan</th>
<th>Ent Override</th>
<th>Demand</th>
<th>Base Fcst</th>
</tr>
</thead>
<tbody>
<tr>
<td>05/06/2002</td>
<td>454,662</td>
<td>436,821</td>
<td></td>
<td></td>
</tr>
<tr>
<td>06/03/2002</td>
<td>273,031</td>
<td>267,803</td>
<td></td>
<td></td>
</tr>
<tr>
<td>07/01/2002</td>
<td>308,400</td>
<td>302,902</td>
<td></td>
<td></td>
</tr>
<tr>
<td>07/20/2002</td>
<td>422,000</td>
<td>371,827</td>
<td></td>
<td></td>
</tr>
<tr>
<td>08/26/2002</td>
<td>262,431</td>
<td>300,791</td>
<td></td>
<td></td>
</tr>
<tr>
<td>09/23/2002</td>
<td>295,961</td>
<td>295,662</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10/21/2002</td>
<td>314,854</td>
<td>328,726</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11/18/2002</td>
<td>353,200</td>
<td>330,570</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12/16/2002</td>
<td>305,263</td>
<td>302,833</td>
<td></td>
<td></td>
</tr>
<tr>
<td>01/13/2003</td>
<td>395,655</td>
<td>348,535</td>
<td></td>
<td></td>
</tr>
<tr>
<td>02/10/2003</td>
<td>358,546</td>
<td>338,203</td>
<td></td>
<td></td>
</tr>
<tr>
<td>03/10/2003</td>
<td>319,103</td>
<td></td>
<td>319,103</td>
<td></td>
</tr>
<tr>
<td>04/07/2003</td>
<td>362,602</td>
<td></td>
<td>362,602</td>
<td></td>
</tr>
</tbody>
</table>

To select a worksheet view

Select the view from the Available Views dropdown list.

To select a different combination to display

Select level members from the level dropdown lists (for example, Brand or Ship to).

To edit worksheet data

1. Click an editable cell.
   - A small editing page appears.
2. Type in the new value and click OK.

To save data

Click the Update Data button.

To reset manual changes since the last time you saved data

Click the Reset Manual Changes button.

To rerun the worksheet

Click the Rerun Worksheet button.

To print the currently displayed data

Click the Print button.

To view a note

1. Click the note icon within the cell.

The Note page appears, displaying a list of all the notes. This list indicates the date of each note, as well as who entered it. The Combination field shows the item-location combinations to which the currently selected note belongs.
2. To see the note details, click Description.

3. To close the Note page, click the X in the upper right corner.
Part 2

Using Worksheets
Getting Started with Worksheets

This chapter covers the following topics:

- Overview
- Opening a Worksheet
- Tutorial: Getting Acquainted with Worksheets
- Worksheet Usage Modes
- User Access

Overview

Oracle Demantra provides real-time access to your sales data, organized into multiple hierarchies that reflect the needs of your organization. An underlying spreadsheet provides a set of calculated (and input) values that you can use at any hierarchy level.

Within Oracle Demantra, you work almost entirely within worksheets. A worksheet retrieves a set of data associated with given hierarchy levels, optionally filtered; the data generally includes raw sales data, the forecast, and intermediate data. After you open a worksheet, you select an item (for example, an SKU or a product family or type) and a location (for example, a store or a region), and then the worksheet displays data for that item-location combination. Worksheets are extremely flexible and can retrieve and display data in a wide variety of ways, as described in Creating and Redefining Worksheets.

You can create and open worksheets only in the web version, not in the desktop version. The available desktop functions are Member Management and Chaining Management.

See also:

- Opening a Worksheet
- Oracle Demantra URLs
Opening a Worksheet

The first time you log onto Oracle Demantra (see First-Time Logon), the system typically downloads and installs software. This operation is quick and occurs only once for each machine you use.

1. After you log on, Oracle Demantra displays a new browser window. The page contains a menu bar, a toolbar, and a workspace that is initially empty.

   The toolbar icons are Create new worksheet and Open existing worksheet.

   ![Toolbar Icons](image)

   2. Click File > Open.

   3. Click a worksheet in the list and then click Open.

   Now the work area displays a worksheet, and the menu bar and toolbar have many more options.

   See also:

   - Creating and Redefining Worksheets
   - Viewing Data

To display My Worksheets

1. Click the Personalize link in the upper right of Collaborator Workbench.

2. Select the check box next to My Worksheets and then click Next.

3. Click Next again and then click Finish.

To open a worksheet from My Worksheets

1. Click a worksheet within My Worksheets. Or click the Open button on the upper
right of a content pane.

2. Depending on how the worksheet was configured, you may now be prompted to filter the data. In this case, one or more selection pages are displayed when the worksheet is opened, as follows:

3. On each selection page, click one or more choices or click Select All to select the whole list.

4. Click Next or click Finish.

For information on using a worksheet, see Introduction to Oracle Demantra.

To run or rerun a worksheet

Depending on how Oracle Demantra was configured, it may or may not automatically run the worksheet that you open.

Within the worksheet, click Data > Rerun.

See also Configuring My Worksheets.

Tutorial: Getting Acquainted with Worksheets

To view and edit data, you work within an environment called a worksheet. Each worksheet is a working environment designed to support specific business processes.
The worksheets in your solution are unique and are not documented here specifically. However, all worksheets share certain common characteristics and behavior. This exercise is meant to help you get acquainted with any worksheet.

1. Click File > Open. Or click the Open button.

2. Click a worksheet in the list and then click Open.

3. In rare cases, you may now be prompted to filter the data. See To prefilter a worksheet.
   Oracle Demantra now displays the worksheet.

4. Scan the worksheet and identify each element of it, using Elements of a Worksheet as a guide.

5. Then select the data to display:

6. If the worksheet uses a Members Browser, click the magnifying glasses to expand the hierarchy and then click the leaf node that you want to view.

7. If the worksheet has selection lists, select from the left list first, then the next list to its right, and so on.
   The rest of the worksheet now shows data relevant to this selection. Notice that the focus has changed to the current selection in each tab or tile of the worksheet.
   Some areas of the worksheet might be at a lower level than your selection. For example, you may have selected a Brand, while a graph shows sales for a given SKU. Because you have not yet selected a SKU, that graph arbitrarily chose a SKU within that brand.

8. If the worksheet includes any table in crosstab format, click a row or column that corresponds to the elements that are shown in that breakout.
   For example, if a worksheet tables shows SKUs as rows in the table, choose a SKU by selecting a row.
   The rest of the worksheet now shows data for this specific selection. This includes any embedded worksheets as well as any other subtabs, if the subtabs are synchronized; see Controlling Subtab Synchronization.

9. Still within a worksheet table, use the keyboard to move from element to element. Notice that in this case, the subtabs are not automatically refreshed, for performance reasons; this is true even if the subtab synchronization is on.

Elements of a Worksheet

Any worksheet contains some or all of the following possible elements:
Selector

Most worksheets contain an area that you use to select the data to display. This area has one of the following forms:

- Members Browser:

![Members Browser Diagram]

- Selection lists:

![Selection Lists Diagram]

Tables

A worksheet table displays data for the current selection.
Some tables display a breakdown by item, location, or other organizational level.

### Time | SKU | Sales | Ttl Evt Yol Act | Final Forecast
--- | --- | --- | --- | ---
11/15/2004 | 2345623489880 | 1,345 | 10 | 1,521
 | 2345623489883 | 1,716 | 0 | 2,046
 | 2345623489877 | 1,838 | 617 | 1,330
 | Summary | 4,901 | 628 | 4,996
12/13/2004 | 2345623489880 | 5,098 | 3,960 | 2,219
 | 2345623489883 | 1,559 | 0 | 1,690
 | 2345623489877 | 1,172 | 0 | 1,126
 | Summary | 5,538 | 3,950 | 5,037
01/10/2005 | 2345623489880 | 1,402 | 12 | 1,880
 | 2345623489883 | 1,628 | 0 | 1,143
 | 2345623489877 | 1,340 | 169 | 1,251
 | Summary | 4,370 | 180 | 4,685

In this example, each SKU in the worksheet is shown side-by-side with the others, inside the table. This table is in crosstab format. Many other variations are possible. For example, the SKUs could be shown across the top of the table instead.

**Graphs**

A worksheet graph displays data for the current selection. By default, the horizontal axis shows time, and the vertical axis shows one or more series.

**Activity Details Subtab**

The Activity Details subtab displays promotions and the promotion hierarchy related to the current selection.
Getting Started with Worksheets

If this is included in your worksheet, it may appear in the lower right. If your worksheet contains multiple tiles, however, it can appear anywhere on the screen.

Notes/Attachments Subtab

The Notes/Attachments subtab displays notes and attachments related to the current selection:

If this is included in your worksheet, it may appear in the lower right. If your worksheet contains multiple tiles, however, it can appear anywhere on the screen.

Embedded Worksheets (Subtab Worksheets)

A worksheet can include embedded worksheets, which can include any of the elements listed here. These may appear in the lower right. If your worksheet contains multiple tiles, however, these embedded worksheets can appear anywhere on the screen. Each embedded worksheet is displayed within a subtab, as follows:
Controlling Subtab Synchronization

The subtabs of a worksheet (included embedded worksheets) may or may not be synchronized with the rest of the worksheet. A worksheet runs faster if synchronization is off. On the other hand, if you are creating or modifying promotions, you might find it less confusing to keep synchronization switched on so that you can immediately see your changes.

To control the synchronization, do one of the following:

- Click one of the following toggle buttons in the toolbar.
  - Automatically synchronize the subtabs with the rest of worksheet
  - Synchronize on demand
- Select Options > Synchronize On Demand or Synchronize Automatically.

Worksheet Usage Modes

You can use a worksheet in three general ways:

- You can use a worksheet in its normal, online mode.
- You can take a worksheet offline, and then edit data and notes without needing access to the Oracle Demantra server. Later you can bring the worksheet back online. Oracle Demantra uploads your changes into the database.
- You can work remotely using a pure HTML user interface, provided that you have access to the Oracle Demantra server. This mode allows you to view and edit data when it is not possible or desirable to download the Oracle Demantra applet and Java.

You can do most of the same activities in any of these modes. For details on the differences, see Working Offline and Logging in Remotely.
User Access

Depending on the implementation and on your access, you might not see the same data as other users of the system. Your access can be different from that of another user in many ways:

- The data you see might be filtered. For example, if you are an account manager, you might not be able to see accounts that are not yours.

- You might not see the same aggregation levels. And you should be able to see only those units of measure that make sense for the levels you see.

- You can see a given promotion only if you have permission to see all item-location combinations with which the promotion is associated.

- You might not see the same series.

- You could belong to different collaboration groups. See Who’s Online.

- You might not have access to all menus listed in the documentation.

- You might have additional menu items, created by your implementors. These menu items would be on the right-click menu.

- You can use only worksheets that are public or that you defined. Only the owner of a worksheet can change its definition.

You should also be aware that an individual worksheet might have additional filters applied to it. You can see those filters at any time.
This chapter covers the following topics:

- Viewing Data
- Editing Data
- Saving and Viewing Changes
- Sorting Worksheet Data
- Copying and Pasting Data
- Copying and Pasting to and from Microsoft Excel
- Exporting Data to Microsoft Excel
- Linking Data into Third-Party Reporting Tools (through DOL)
- Printing
- Viewing Notes
- Editing Notes
- Viewing and Managing Attachments to Notes
- Specifying Note Permissions
- Refreshing the Local Worksheet Cache
- Viewing the Audit Trail

**Viewing Data**

**To view your data**

1. Click File > Open. Or click the Open button.

2. Click a worksheet in the list and then click Open.
   
   Depending on how Oracle Demantra was configured, it may or may not
automatically run the worksheet that you open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the Run button.

To prefILTER a worksheet

Depending on how the worksheet was configured, when you open the worksheet, Oracle Demantra may prompt you to choose how to filter it.

In this case, after you click the worksheet and click Open, one or more selection pages are displayed when the worksheet, as follows:

1. On each selection page, select one or more choices or click Select All to select the whole list.

2. Click Next or click Finish.

To load all data

When you first run a worksheet, Oracle Demantra does not load all the data. Instead, it loads data for the first item-location combination in the worksheet. When you switch to another combination, Oracle Demantra loads data for that combination. It does this so that you can see some data without having to wait for all the combinations to be loaded.

If worksheet was previously offline
If you previously took this worksheet offline and made changes to the data, you will see the following dialog box as soon as you open the worksheet:

![Synchronize Offline Data dialog box]

For information on these options, see Reloading Offline Data.

### Editing Data

You can usually edit data in a worksheet, although not all series are editable. Note that within a given worksheet, if some of the tabs or windows show data at a higher aggregation level, the data is not editable in those tabs or windows.

**Note:** In Oracle Demantra, do not use the special characters single quote (’), double quote ("), and ampersand (&). If you use these characters, unexpected results may occur.

**To change a data value manually**

1. Select an editable data cell (white).
   - The cell appears contained in a box.

2. Edit the value as needed. If the cell contains a date, then you can click the arrow on the right side of the cell and choose a date:
Or if the cell contains a dropdown list, double-click the cell to display the list and then click a list element:

<table>
<thead>
<tr>
<th>Pay Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bill Back</td>
</tr>
<tr>
<td>Auth Deduc</td>
</tr>
<tr>
<td>(None)</td>
</tr>
<tr>
<td>Auth Deduc</td>
</tr>
<tr>
<td>Bill Back</td>
</tr>
<tr>
<td>Off Invoice</td>
</tr>
</tbody>
</table>

To update multiple cells

1. In the table, select a range of cells.

2. Right-click the selection and then select Edit Cells.
   The Edit Cells dialog box appears.

3. In the dialog box, type a new value and then click OK.

To undo

Do one of the following:

- Click Edit > Undo.

- Click Data > Reset Manual Changes. This option restores the worksheet data to the state in which you last saved it.

To redo an action
Click Edit > Redo.

See also:

• Copying and Pasting Data

• Saving and Viewing Changes

**Saving and Viewing Changes**

Apart from minor adjustments to the worksheet layout, the changes you make are not saved automatically.

**Saving Changes**

You save changes to data separately from changes to the worksheet definition:

• To save changes that you have made to the data in the worksheet, including changes to notes, click Data > Save Data. Or click the Save Data button.

• To save changes that you have made to the worksheet definition, click File > Save Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and its initial layout. For information on changing the worksheet definition, see Creating and Redefining Worksheets.

• If you do not own the worksheet, this option saves only your own layout of the worksheet.

See Worksheet Definition, Layout, and Local Adjustments.

**Viewing Pending Changes to Data**

To see pending data changes

1. Click Data > Update to save your data changes.

2. Click Data > Process Monitor. Oracle Demantra displays a screen that shows all data saves that are waiting to be processed:
If you are working at a relatively high level, this takes longer to run.

**Sorting Worksheet Data**

By default, the worksheet table is sorted in ascending order, according to the current contents of the x-axis, which is usually time. You can sort the worksheet table in either ascending or descending order, according to any series that is displayed in the table.

**To sort the worksheet table**

Double-click the header of the column by which you want to sort the worksheet.

Oracle Demantra then sorts the entire worksheet table, putting entries in this column in descending order. A downward arrow is added to the column header, to indicate that the table is sorted by this column.

To resort in ascending order, double-click the column header again. Oracle Demantra resorts the table and changes the direction of the arrow.

**To restore the default sorting order of the worksheet table**

Click View > Reset Table Sort.
Copy and Pasting Data

You can copy and paste data within the worksheet table.

**Note:** From a worksheet, you can also paste data to different Windows products.

**To copy data**
1. Within a worksheet, do one of the following:
   - In the table, select a cell whose value you want to copy.
   - To copy values from more than one cell, click the first cell, and then drag the mouse to select all cells you want to include.

2. Right-click and then select Copy. Or click Edit > Copy.

**To paste data**
1. Do one of the following:
   - In the table, select the cell into which you want to paste the data.
   - To paste values into more than one cell, select the upper left data cell of the block of cells into which you want to paste.

2. Right-click and then select Paste. Or click Edit > Paste.

See also Saving and Viewing Changes.

Copy and Pasting to and from Microsoft Excel

You can copy and paste data from a worksheet to Excel and vice versa.

**To copy and paste data to Excel**
1. Within a worksheet, copy data as described in Copying and pasting Data.

2. Start Microsoft Excel, open a worksheet, and select a cell or block of cells.

3. Right-click and then select Paste.

**To copy and paste data from Excel**
1. Start Microsoft Excel and open a worksheet.

2. Select one or more cells.
3. Right-click and then select Copy.

4. In Oracle Demantra, select the cell or cells into which you want to paste the data.

5. Right-click and then select Paste. Or click Edit > Paste.

See also Exporting Data to Microsoft Excel.

**Exporting Data to Microsoft Excel**

You can export worksheet data to Excel. Your computer’s regional settings can affect the results; see the note.

The export to Microsoft Excel uses memory on the Oracle Demantra server to compliment the memory on your personal computer.

It can export any amount of data. However, for extremely large sets of data, the export process may split the exported data among multiple Excel worksheets. Excel has a limit on the maximum number of rows in a worksheet.

You can continue working while exporting data.

**To export data to Excel**

1. Within a worksheet, click File > Export. Or click the Export to Microsoft Excel button.
   
   An export dialog box appears.

2. Select Current Combination to export all of the data displayed for the selected combination, or Entire Worksheet to export all data from the worksheet.

3. Click OK.
   
   A Save page appears.

4. Define the location where the worksheet data will be saved and enter a name for the file.

5. Click Save.

   **Note:** When receiving data from an external source, Microsoft Excel uses the Regional Options in the Windows Control Panel to determine whether a given cell should be formatted as Currency or General (as is or text). This means that if you export Oracle Demantra data that is formatted with a currency symbol, and if the Windows Control Panel uses a different currency symbol, those cells will appear in Excel as text values.
If you export to Excel and you receive text values where you wanted currency values, do the following:

- Open the Windows Control Panel.
- Double-click Regional and Language Options.
- On the Regional Options tab, make sure that the Currency setting uses the same currency symbol as Oracle Demantra.
- Export again from Oracle Demantra.

Later versions of Excel provide an option for converting problematic cells that it recognizes.

See also Copying and Pasting to and from Microsoft Excel.

**Linking Data into Third-Party Reporting Tools (through DOL)**

When you work within a third-party reporting tool, you can import an Oracle Demantra worksheet through Oracle's Dynamic Open Link (DOL) technology. This technology lets you use any reporting tool that can connect to the Oracle Demantra database (which is either Oracle or SQL Server).

These steps describe how to link Oracle Demantra data into Microsoft Excel, from

- Outside of Microsoft Excel
- Within Microsoft Excel

**Note:** The details here may vary depending on the version of Excel. Consult the Excel documentation for information about "web queries."

To link Oracle Demantra data into Microsoft Excel, from outside

1. Enter the DOL login URL on a browser, for example, http://myserver:8080/demantra/portal/DOLLogin.jsp.

2. Log into Oracle Demantra.

3. Copy the right worksheet URL from the middle column on the received page.

4. Open Microsoft Excel > Data > Import External Data > New Web Query. This is the Microsoft Excel 2003 path.

5. Paste the copied DOL Web Query URL into the address edit field and click Go.
To link Oracle Demantra data into Microsoft Excel, from within

1. Open Microsoft Excel > Data > Import External Data > New Web Query. This is the Microsoft Excel 2003 path.

2. Enter the DOL login URL on a browser, for example, http://myserver:8080/demantra/portal/DOLLogin.jsp.

3. After the table page is loaded, click on the Open URL link of the relevant worksheet.

Printing

When you print a worksheet, the printed results match the screen display (what you see is what you get).

To print the displayed data

1. Click File > Print. Or click the Print button on the toolbar.

   The Print Settings dialog box appears.

   ![Print Settings Dialog Box]

   - **Content Selection**
     - **Current Combination**
     - **Entire View**
     - **Screen**

   - **Layout**
     - **Portrait**
     - **Landscape**

   - **Paper**
     - **Paper Size:** US Letter

   - **Font**
     - **Font:** Arial
     - **Size:** 8

   - **Fit**
     - **Scale width to page**

   ![Print Settings Dialog Box Image]

   Click **OK** or **Cancel**.
2. Select the required options.

<table>
<thead>
<tr>
<th>Content selection</th>
<th>Specify whether to print the currently selected item-location combination, all combinations in the worksheet, or the screen.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layout</td>
<td>Choose portrait or landscape orientation.</td>
</tr>
<tr>
<td>Paper</td>
<td>Choose a paper size.</td>
</tr>
<tr>
<td>Font</td>
<td>Choose a font size.</td>
</tr>
<tr>
<td>Fit</td>
<td>Select Scale width to page to force the columns to print on one page left-to-right, without your having to resize the worksheet columns. The output uses the paper size and print orientation that you choose. It respects the font size that you choose as much as possible but may use a smaller font if necessary to accommodate the paper size and print orientation.</td>
</tr>
</tbody>
</table>

3. If this worksheet includes a Gantt chart, optionally click the Gantt Settings tab. On this tab, specify which promotion attributes to include in the printout.

4. Click OK.

5. Oracle Demantra displays the normal system print dialog box, where you choose the printer to use, the number of copies to make, and so on.

6. Make selections as you would normally do.

7. Click OK.

### Viewing Notes

You can add notes to record comments and reminders. You attach the note to combination and date or dates. The worksheet table displays indicator symbols on those dates, generally in only some of the columns (depending on how your system is configured). The following shows an example of the indicator:
The graph displays an indicator as well:
You can see notes in two different areas:
- In the Notes dialog box.

Notes/Attachments subtab, if this is included in your worksheet. This subtab also displays any associated attachments.
To open the Notes page

Do one of the following:

- In the table, right-click a cell and select Notes...
- In the table, double-click the left (non-scrolling) column. (Depending on how Oracle Demantra is configured, this action may not bring up the Notes page.)
- In the graph, hold the mouse button over a point, right-click and then select Notes...

To display the Notes/Attachments subtab

See Specifying the Worksheet Elements in a View.

- Editing Notes
- Viewing and Managing Attachments to Notes
- Specifying Note permissions

**Editing Notes**

First display the Notes page or the Notes/Attachments subtab; see Viewing Notes. In the upper part of the worksheet, click the element to which you want to attach this note.

**To add a note**

1. If the Note box is gray (uneditable), click the Add button.
2. Type a note in the Note box.
3. If you are working in the Notes/Attachments subtab, you can optionally upload an attachment (see Viewing and Managing Attachments).
4. Click the Save button.

**To edit a note**
1. Select a note and click the Edit button.

2. Type a note in the Note box.

3. If you are working in the Notes/Attachments subtab, you can optionally upload an attachment (see Viewing and Managing Attachments to Notes).

4. Click the Save button.

To delete a note

1. Select a note and click the Delete button.
   The Confirm Delete message box appears.

2. Select one of the following:
   • Partial Deletion (deletes the note only from the current member and date)
   • Total Deletion (deletes the note from all members and dates)

3. Click OK.

4. Click Save.

See also:
• Viewing Notes
• Specifying Note Permissions

Viewing and Managing Attachments to Notes

You can attach files to the notes, and Oracle Demantra uploads those files into the database (in compressed form). To view and manage attachments, you work in the Notes/Attachments subtab of your worksheet.

To add an attachment to a note

1. Click the note.

2. Click Details.

   Oracle Demantra displays the Note Details screen:
3. Click Add.

4. Find the file that you want to attach and then click Open.

   Oracle Demantra uploads a compressed version of the file into the database.

5. Click OK.

   **To remove an attachment from a note**

1. Click the note.

2. Click Details.

   Oracle Demantra displays the Note Details screen:

3. Click the row that lists the attachment and then click Remove.

4. Click OK.

   **To view and download an attachment**

1. Click the note.

2. Click Details.

   Oracle Demantra displays the Note Details screen:
3. Click the row that lists the attachment and then click:
   • View if you want to see the attachment immediately. Oracle Demantra recognizes the attachment file type and opens the application for viewing it.
   • Download... if you want to save it.

See also:
• Viewing Notes
• Specifying the Worksheet Elements in a View

**Specifying Note Permissions**

In general, notes (and their optional attachments) can be viewed by other users. You can specify permissions for the notes, to determine who can read the note and what type of access they are permitted. You can specify permissions for groups or for specific users.

**To specify permissions for a note and its attachments**

1. On the Details tab, select the note.
2. Click the Permissions tab.
3. Select the User Permissions or Group Permissions tab.
4. For each user or group that should have non-default settings for this note, move that user or group from the left list to the right list (Selected Users or Selected Groups). Use any of the techniques in Working with Lists.
   
   **Note:** Read-only is the default setting for non-selected users or groups.

5. Remove any unwanted users or groups from the right list.
6. Then for each user or group in the right list, do the following:
   • Click the user or group.
   • Select a setting from the Permission dropdown list at the bottom of the page. The following options are available:
<table>
<thead>
<tr>
<th>Permission Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read and Write</td>
<td>Enables the user or group to read the notes list, edit notes, and add notes.</td>
</tr>
<tr>
<td>Read Only</td>
<td>Enables the user or group to read the notes list.</td>
</tr>
<tr>
<td>Not Visible</td>
<td>Makes the note list not visible to this user or group.</td>
</tr>
<tr>
<td>Full Control</td>
<td>Enables the user or group to read the notes list, edit notes, add notes, and delete notes.</td>
</tr>
</tbody>
</table>

7. Click Save.

8. Click Close.

**Group and user permission priorities**

User permissions take precedence over permissions of any groups the user belongs to.

If a user belongs to more than one group, the highest level of permissions from the associated groups will be granted.

See also Viewing Notes.

**Refreshing the Local Worksheet Cache**

Depending on the definition of a worksheet, Oracle Demantra may store a local copy of the worksheet data on your machine, for faster performance. Also depending on the worksheet definition, the cache may be refreshed automatically or may require periodic refreshing by you.

To refresh your local worksheet cache

Click Data > Refresh worksheet data cache.

See also:

- Visual Elements of Worksheet Views
- Saving and Viewing Changes
- Configuring Worksheet Basics
- Opening an Item or Location in Another Worksheet
Viewing the Audit Trail

Oracle Demantra automatically records changes in an audit trail. The audit trail includes all changes due to user edits within worksheets, updates created by the Business Logic Engine, copy/paste actions, and changes caused by import.

**Note:** You can see only changes that were made by you or other users who are in the same collaboration groups as you.

Oracle Demantra provides two ways to view the audit trail:

- You can view the changes that have occurred to the item-location combination that is currently displayed in the worksheet.
- You can create and then execute a profile that specifies a wider set of data: multiple combinations, a wider span of time, and so on.

In either case, the audit trail looks like this:

The top part of the page lists the changes. When you select a row in this table, the bottom part of the page lists details corresponding to that row.

- The Series Values tab displays details on the series that were changed.
- The Aggregate Level Population tab displays the specific aggregation levels to which this change applies. The change could have occurred at a different aggregation level.
• The Filtered Population tab displays the filtering that was used at the time of this change.

**Viewing the Audit Trail for a Specific Combination**

**To view the audit trail for a combination**

1. In a given worksheet, select a combination.

2. Click Data > Audit Trail.

   If any changes have occurred to this combination, the Audit Trail screen appears, displaying a table with one row for each recorded change. The following information is displayed:

<table>
<thead>
<tr>
<th>Audit Date</th>
<th>Date when change was made.</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Name</td>
<td>User who made the change.</td>
</tr>
<tr>
<td>Update Mode</td>
<td>Indicates the type of change: Manual, BLE (Business Logic Engine) or Integration.</td>
</tr>
<tr>
<td>Unit Name</td>
<td>Unit of measure that was used at the time of the change.</td>
</tr>
<tr>
<td>Index Name</td>
<td>Index that was used at the time of the change.</td>
</tr>
<tr>
<td>Series List</td>
<td>Series affected by the change.</td>
</tr>
<tr>
<td>Status</td>
<td>In Progress, Fail, or Success.</td>
</tr>
</tbody>
</table>

3. To see specific details on this change, click a change in this table and then click the Series Values tab.

   This tab displays the following information:

<table>
<thead>
<tr>
<th>Series Name</th>
<th>Name of the series that was changed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Series Value</td>
<td>New value used in this series.</td>
</tr>
<tr>
<td>Original Value</td>
<td>Original value in this series.</td>
</tr>
<tr>
<td>From Date</td>
<td>First date in the series when the change occurs.</td>
</tr>
<tr>
<td>-----------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>To Date</td>
<td>Last date in the series when the change occurs.</td>
</tr>
</tbody>
</table>

4. To see the specific aggregation levels to which this change applies, click the Aggregate Level Population tab. The change could have occurred at a different aggregation level.

5. To see the filtering that was used at the time of this change, click the Filtered Population tab.

Viewing the Audit Trail for Other Data

An audit trail profile enables you to select a specific portion of the audit trail so that you can view changes that affect more than one combination.

To create or modify an audit trail profile

1. Click File > Audit Trail.

2. Then:
   - To create a new profile, click New.
   - To modify a profile, click an audit trail profile name and click Modify.
     The wizard displays a properties screen.

3. In the Name and Description fields, type a name and optional description.

4. If you want to share this audit trail profile with others, click Public.

5. Click Next.
   The wizard prompts you for information about the changes you want to see.

6. For Source Type, select the check box for each type of change you want to see. Here, BLE represents the Business Logic Engine.

7. For each user whose changes you want to see, move the name from Available Users to Selected Users.

8. Click Next.
The wizard prompts you for the range of time you are interested in.

9. For Time Filter, select Relative or Fixed, depending on whether you want to define a window of time relative to today.

10. For From Date and To Date, specify a range of dates.

11. Click Next.
   
   The wizard prompts you to specify the aggregation levels you are interested in.

12. For each aggregation level that you are interested in, move that level from Available Filter Levels to Selected Filter Levels.

13. Click Next.
   
   The wizard prompts you to specify the series you are interested in.

14. For each series that you are interested in, move that series from Available Series to Selected Series.

15. Click OK.

16. Click Close to exit the wizard.

**To use an audit trail profile**

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Execute.
   
   Oracle Demantra displays the specified part of the audit trail. See Viewing the Audit Trail for a Specific Combination.

**To delete an audit trail profile**

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Delete.

4. Click Yes.
Managing Multiple Worksheets

Within Oracle Demantra, you can open multiple worksheets and display them in tab mode or window mode. In window mode, you can re-size, position, minimize, maximize, and tile each window as in other software.

To specify how to display worksheets

Do one of the following:

• Select Options > Tabs View/Windows View.

• Click the Tabs/Windows toggle button (Display worksheets as windows or Display worksheets as tabs).

A worksheet contains views, and these views can be displayed as windows or tabs within the worksheet itself. The Tabs/Windows setting discussed here has no effect on the views.

To view a worksheet that has already been opened

In windows view, select the worksheet from the Windows menu.
In tabs view, click the tab corresponding to the worksheet.

To close a worksheet

Do one of the following:

• In windows view, click close (X) in the top right corner of the worksheet window.

• In tabs view, click the close symbol (X) on the tab.

See also:

• Managing Worksheet Views

• Managing View Elements

• Adding and managing Worksheet Views

Managing Worksheet Views

A worksheet can include multiple views, which are displayed as tabs or as windows within the worksheet window itself.

Each view can have a different set of series and a different layout. Within any given worksheet, you can display the views as tabs or as child windows that you can resize and reposition.

Depending on the worksheet definition, the views may or may not be synchronized with each other. If they are synchronized, when you edit in one view, that change automatically appears in the other views.
Note: In a given worksheet, if some of the views show data at a higher aggregation level, the data is not editable in those views.

To manage worksheet views

Within any given worksheet, you can display the worksheet views as tabs or as child windows that you can resize and reposition.

• To create, modify, or delete worksheet views, see Adding and Managing Worksheet Views.

• To change how views are shown within the current worksheet, click Options > Tabs Multiview or Options > MDI Multiview, whichever option is displayed. Or click the corresponding toggle button on the toolbar (Display view as child window or Display view as task).

• If you are currently displaying views as tabs, you can view one tab at a time. Click the tab of the view you want to view.

• When you are displaying views as subwindows, you can resize, reposition, maximize, and minimize each of these subwindows. Also, the Options menu provides options for tiling and cascading the subwindows.

See also:

• Managing Multiple Worksheets

• Managing View Elements

Managing View Elements

To hide or re-display elements of a worksheet view

You can hide elements of a worksheet. To do so, use the Options menu. For example, to hide the graph, click View > Show/Hide Graph.

Note: This menu includes an option to hide the time axis. You typically use this option only if the worksheet also contains time levels. In such a case, it is desirable to hide the time axis, because it is redundant and takes up space on the screen.

Each of these menu items acts as a toggle. To redisplay what you have hidden, click the same menu item again.

To re-size an area in a worksheet view
Drag a divider to the required position.

To expand or contract an area in a worksheet view

There are two snap buttons in the upper left of each worksheet area, one with an up arrow and one with a down arrow. Click the snap button pointing in the required direction.

To resize a data column

Click the vertical divider between two column headers, and drag it horizontally to the required position.

The text of the series header can wrap. If it does not, you can instruct it to by going to View > Wrap Header and selecting the checkbox. The wrapping applies to every crosstab view in a worksheet.

<table>
<thead>
<tr>
<th>View</th>
<th>Options</th>
<th>Data</th>
<th>Help</th>
<th>Window</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

See also:

- Managing Multiple Worksheets
- Managing Worksheet Views
- Adding and Managing Worksheet Views

Managing Empty Rows

To hide or display empty rows in the worksheet table
Click View > Hide Empty Rows. This option is a toggle. If you click it again, you redisplay the empty rows.

**Note:** This option does not affect any graphs in the worksheet.

**Note:** If a worksheet contains a time level or a general level (GL), or it contains a series that is based on a time level or a general level, then empty rows will not appear in the worksheet, even if Hide Empty Rows setting is not selected.

### Examples

In some cases, some of the rows of a worksheet table might not contain data, for example:

<table>
<thead>
<tr>
<th>Account</th>
<th>Time</th>
<th>Revenue $</th>
<th>Market Plan $</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>BJ</strong></td>
<td>03/10/2003</td>
<td>$1,243,435</td>
<td>$1,257,652</td>
</tr>
<tr>
<td></td>
<td>06/09/2003</td>
<td>$1,488,018</td>
<td>$1,771,360</td>
</tr>
<tr>
<td></td>
<td>09/08/2003</td>
<td>$740,175</td>
<td>$901,146</td>
</tr>
<tr>
<td></td>
<td>12/08/2003</td>
<td>$1,031,035</td>
<td>$7,247,500</td>
</tr>
<tr>
<td></td>
<td>03/08/2004</td>
<td>$816,591</td>
<td>$850,507</td>
</tr>
<tr>
<td><strong>Summary</strong></td>
<td></td>
<td>$5,319,254</td>
<td>$12,026,165</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Account</th>
<th>Time</th>
<th>Revenue $</th>
<th>Market Plan $</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Rainbow Company</strong></td>
<td>03/10/2003</td>
<td></td>
<td>$658,800</td>
</tr>
<tr>
<td></td>
<td>06/09/2003</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>09/08/2003</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>12/08/2003</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>03/08/2004</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Summary</strong></td>
<td></td>
<td></td>
<td>$658,800</td>
</tr>
</tbody>
</table>

Note that the status bar at the bottom of worksheet indicates that empty rows are currently being displayed.

When you hide empty rows, the result is as follows:
Worksheet, Layout, and Data

As you work within Oracle Demantra, it is important to remember that worksheets exist independently from the data that they display. For example, the definition of a worksheet specifies which series to display and how to aggregate those series for that worksheet. But the worksheet definition does not specify the values that the series contain.

Accordingly, the worksheets and their layouts are saved separately from changes to the data.

To save changes that you have made to the data in the worksheet, including changes to notes, click Data > Save Data. Or click the Save Data button.

To save changes that you have made to the worksheet definition or to the local layout, click File > Save Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and its initial layout. This affects any users of this worksheet who have not yet saved their own layout for it.

• If you do not own the worksheet, this option saves only your own layout of the worksheet. This has no effect on any other users.

See also:
• Worksheet Definition, Layout, and Local Adjustments
• Saving and Viewing Changes
### Worksheet Definition, Layout, and Local Adjustments

As you work in a worksheet, you often sort columns, hide or display features, and make various other changes. It is useful to understand how these settings are saved.

<table>
<thead>
<tr>
<th>Base Oracle Demantra configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>These settings affect all users and all worksheets.</td>
</tr>
<tr>
<td>- Display format for each series</td>
</tr>
<tr>
<td>- Initial display width of series and levels</td>
</tr>
<tr>
<td>- Colors and graph style for each series</td>
</tr>
<tr>
<td>- Other display colors (generally dependent on a condition)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Worksheet definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>These settings are saved through the File &gt; Save Worksheet menu option. Only the worksheet owner can make these changes.</td>
</tr>
<tr>
<td>- Initial number of views within the worksheet and their initial names</td>
</tr>
<tr>
<td>- Initial elements (Members Browser, table, graph, and so on) in worksheet view</td>
</tr>
<tr>
<td>- View synchronization setting</td>
</tr>
<tr>
<td>- Aggregation levels used in worksheet and initial level layout; advanced selection options</td>
</tr>
<tr>
<td>- Series used in worksheet and initial series layout</td>
</tr>
<tr>
<td>- Time aggregation; time span; time formatting</td>
</tr>
<tr>
<td>- Filtering and exception filtering</td>
</tr>
<tr>
<td>- Unit of measure used in worksheet; overall scale used in worksheet, if any; index or exchange rate, if any</td>
</tr>
</tbody>
</table>
Layout changes

These settings are saved separately for each user if the user clicks File > Save Worksheet. Any user can save these changes, not just the worksheet owner.

- Additional views in the worksheet
- New names of worksheet views
- Level layout: order of levels; placement on axes in each view; whether level is hidden in each view
- Series layout: order of series; where each series is displayed (table, graph, both)
- Hide/show time axis

Local adjustments

These settings are saved automatically separately for each worksheet and each user.

- Use of windows or tabs for views within a worksheet
- Size and position of the Members Browser, table, graph, and so on in each view
- Sorting in the worksheet table
- Graph type; legend; grid lines
- Hide/show empty rows setting
- Activity synchronization setting (Options menu)

Not saved

- Changes to column widths in the worksheet table
- Initial view focus; focus in each worksheet view
- Expansion state in the Members Browser and Activity Browser
- Focus and scroll in all areas
- Zoom setting in Gantt

The autorun option (Options menu) is saved separately for each user, but applies to all worksheets that the user sees.
This chapter covers the following topics:

- Graph Styles and Variations
- Changing the Graph Style

Graph Styles and Variations

This section provides a quick overview of the available graph types. Within a given worksheet, a graph does not necessarily display all the series. The series definition and the worksheet definition both control this.

Data Plots

The line graph, bar chart, data points only, and stacked bar chart format all behave in an obvious manner. The vertical axis is the y-axis, and this usually corresponds to the series in the worksheet, depending on the worksheet layout you have chosen; multiple series can be displayed in different colors (chosen automatically). The horizontal axis (the x-axis) usually corresponds to time. A typical graph looks like this:
Pie Charts

The pie chart format is a little different. It uses the following rules:

- Oracle Demantra includes one pie chart for each graphed category that is on the y-axis.

- Within that pie chart, it shows the percentage breakdown according to each category or unit on the x-axis.

For example, the previous data would appear as follows:

Because the Orders and Demand series are on the y-axis in this worksheet, each of these series is displayed in a separate pie chart. The breakdowns in each pie chart correspond to the time buckets in the worksheet.

More typically, you would prefer to break down the data according to a more interesting category such as some aggregation level. To make the pie charts more useful, you redefine the worksheet layout to put at least one of the aggregation levels on
the x-axis, as follows:

![Pie charts showing data]

See also:
- Defining the View Layout
- Changing the Graph Style

## Changing the Graph Style

To change the style of the graph

Click any of the graph style buttons to the left of the graph:
- line graph
- bar chart
- data points only
- pie charts
- stacked bar chart

To display only one pie chart

Click View > Show Multiple Pie Charts. This option is a toggle. If you click it again, you redisplay the other pie charts.

See also Graph Styles and Variations.
This chapter covers the following topics:

- About Working Offline
- Setting Up Your Offline Environment
- Saving Data for Offline Use
- Accessing an Offline Worksheet
- Reloading Offline Data

About Working Offline

Normally, when you use a worksheet, Oracle Demantra connects directly to the database and retrieves or saves data in response to your actions. Other users also retrieve and save data, and the database always contains the latest changes made by any user. In order to do this, the worksheets use an active connection to the Oracle Demantra server.

However, it is useful to be able to work offline, that is, without a connection to the Oracle Demantra server. When you are online, you save a worksheet (or part of it) for offline use. Then while you have no connection to the Oracle Demantra data, you can use that worksheet and edit data in it. Later you bring the worksheet back online. When you do so, Oracle Demantra saves the data back to the Oracle Demantra database, just the same way it saves data from any other worksheet.

In offline mode, you have access to most worksheet features. The following table summarizes what is available.
<table>
<thead>
<tr>
<th><strong>General Area</strong></th>
<th><strong>Availability in Offline Mode</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Worksheet access</td>
<td>Available options:</td>
</tr>
<tr>
<td></td>
<td>- Opening and closing any worksheet that you have saved offline on this computer.</td>
</tr>
<tr>
<td></td>
<td>- Exporting</td>
</tr>
<tr>
<td></td>
<td>- Printing</td>
</tr>
<tr>
<td></td>
<td>Options that are not available:</td>
</tr>
<tr>
<td></td>
<td>- Opening worksheets that you have not saved offline on this computer.</td>
</tr>
<tr>
<td>Editing</td>
<td>Available options: almost all the same as when working online (copy, paste, edit cell, and so on)</td>
</tr>
<tr>
<td></td>
<td>No option to reset manual changes (to reset manual changes, take the worksheet offline again and discard previous changes)</td>
</tr>
<tr>
<td>Right-click menus</td>
<td>Not available</td>
</tr>
<tr>
<td>Screen management</td>
<td>Available options: same as when working online (hide/show worksheet elements, use of tabs or windows, and so on)</td>
</tr>
<tr>
<td>Worksheet design</td>
<td>Available options:</td>
</tr>
<tr>
<td></td>
<td>- Viewing current worksheet design (Data &gt; Info)</td>
</tr>
<tr>
<td></td>
<td>Options that are not available:</td>
</tr>
<tr>
<td></td>
<td>- Changing worksheet design or layout</td>
</tr>
<tr>
<td></td>
<td>- Creating new worksheets</td>
</tr>
<tr>
<td></td>
<td>- Saving worksheet with new name</td>
</tr>
<tr>
<td>Audit trail</td>
<td>Available only for data within this worksheet</td>
</tr>
<tr>
<td>Analytics</td>
<td>Not available (cannot tune forecast nodes, run simulations, or see forecast details)</td>
</tr>
<tr>
<td>Caching</td>
<td>Not applicable.</td>
</tr>
</tbody>
</table>
Setting Up Your Offline Environment

The first time you save a worksheet offline, Oracle Demantra sets up your offline environment, so that you can work while you do not have access to the Oracle Demantra server. This is a one-time setup, per user, per machine.

**Note:** When you perform these steps, you must have network access to the Oracle Demantra server, which must be running.

If the offline worksheets do not start due to a Java Web Start error, you must set your proxies

- Check for proxy information: Internet Explorer > Tools > Internet Options > Connections > LAN Settings.
- Open Java Webstart: C:\Program Files\Java\jre1.4.2_10\javaws\javaws.exe.
- Open File > Preferences.
- Set your proxy information

**To set up your offline environment**

1. Within a normal worksheet, click File > Export for Offline Use.
   Oracle Demantra displays the following screen:
Here you specify the directory where Oracle Demantra will store your offline information. By default, this is c:/Documents and Settings/username, but you can choose a different location. The offline directory itself is always named Demantra.

2. Specify the offline directory location and click OK.

Oracle Demantra then displays the following screen:

Here you specify which data to take offline. You might want to work with only a single combination, for example.

3. Choose one of the options and click OK.

4. Log off Oracle Demantra.

5. Enter the web address supplied by your system administrator for offline access.
This URL probably has the following format:
http://server name/virtual directory/portal/launchDPWeb.jnlp

For example:
http://frodo/demantra/portal/launchDPWeb.jnlp

Depending on what is already installed on this computer, Oracle Demantra then briefly displays a screen titled Java Web Start, which shows its progress in scanning and downloading the required JAR file.

![Java Web Start 1.2]

After that, Oracle Demantra displays a dialog box that asks if you want to trust the signed application distributed by Oracle:

![Security Warning]

Note: If Oracle Demantra does not display this screen, that means that you have already downloaded the applet to this machine. You do not need to download it again.

Depending on your system configuration, the screen might be slightly
different, with the following options instead: Yes, Always, and No.

6. Click Start or Yes (or Always), depending on which dialog box is displayed. Next, Oracle Demantra displays the following prompt):

![Dialog Box]

7. Click Yes.

Oracle Demantra creates a shortcut labeled Demantra Offline Worksheets, which you use to access your offline worksheets in the future. This shortcut is on your desktop and on your Start menu.

**Note:** For details on this shortcut, see the troubleshooting chapter in the Oracle Demantra Implementation Guide.

You are now configured to use worksheets offline.

See also:

- Saving Data for Office Use
- Accessing an Offline Worksheet

---

**Saving Data for Offline Use**

You can save data from a worksheet (or part of it) in an offline format. Then you can work with the data offline and later upload it to Oracle Demantra.

**Note:** If you have not already taken a worksheet offline on this machine, see Setting Up Your Offline Environment.

**To take worksheet data offline**
1. Within a normal worksheet, click File > Export for Offline Use. Oracle Demantra then displays the following screen:

Here you specify which data to take offline. You might want to work with only a single combination, for example.

2. Choose one of the options and click OK.

3. If you already took this worksheet offline on this machine, Oracle Demantra displays the following screen, which asks how to handle the data changes you already made while offline:

4. Click one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overwrite all values with offline values</td>
<td>Treat the data in the offline worksheet as the latest data and save it all to the database.</td>
</tr>
<tr>
<td>Select changes from log</td>
<td>View the audit trail for the data in this worksheet and select the changes to keep.</td>
</tr>
</tbody>
</table>
5. If you clicked **Select changes from log**, Oracle Demantra displays a screen that shows all the changes to this data.

6. Click OK.

See also Reloading Offline Data.

**Accessing an Offline Worksheet**

You can save data from a worksheet (or part of it) in an offline format. Then you can work with the data offline and later upload it to Oracle Demantra.

*Note:* If you have not already taken a worksheet offline on this machine, see Setting Up Your Offline Environment.

**To access an offline worksheet**

1. Click the Demantra Offline Worksheets shortcut, which is on your desktop, and on your Start menu.

   *Note:* For details on this shortcut, see the troubleshooting chapter in the Oracle Demantra Implementation Guide.

   Oracle Demantra then displays a login dialog box:

   ![Login dialog box](image)

   ![Login dialog box](image)

2. Enter your user name and password and click OK.

3. Click File > Open.
4. Click the worksheet that you took offline earlier. Note that it is shown with the offline icon.

**Note:** If you are currently have network access to the Oracle Demantra server, this list shows all worksheets. If you are offline, it lists only the offline worksheets.

If you currently have network access to the Oracle Demantra server, Oracle Demantra can open the worksheet in either of two modes, as follows:

![Worksheet Mode](image)

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Online Mode</td>
<td>Click this option if you want access to the latest data in the database, irrespective of your offline changes.</td>
</tr>
<tr>
<td>Offline Mode</td>
<td>Click this option if you want access to the data you saved offline earlier, with any changes you made to it.</td>
</tr>
</tbody>
</table>

See also:

- About Working Offline
- Reloading Offline Data

**Reloading Offline Data**

If you worked with data offline, you can reload it into Oracle Demantra. When you bring a worksheet back online, Oracle Demantra saves the data back to the database, just the same way it saves data from any other worksheet.

**Note:** When you reload offline data, Oracle Demantra uses information that it has recorded in an audit trail. When it does so, it moves that audit trail information into the database. This means that the local record of changes is no longer available. In practice, this means that
you should delete an offline worksheet as soon as you reload all the desired data, and then take the worksheet offline again if needed.

To reload offline data

1. In order to reload offline data, you must have network access to the Oracle Demantra server.

2. Open the offline worksheet as follows:
   - First either click the Demantra Offline Worksheets shortcut or log into Oracle Demantra as usual.
   - Click File > Open.
   - Click the worksheet and click Open.
   If you currently have network access to the Oracle Demantra server, Oracle Demantra gives you a choice as follows:
     - Click Online Mode and click Select.

3. Click Data > Synch Offline Data.
   Oracle Demantra displays the following screen:
4. Click one of the following options:

- **Overwrite all values with offline values**
  Treat the data in the offline worksheet as the latest data and save it all to the database.

- **Select changes from log**
  View the audit trail for the data in this worksheet and select the changes to keep.

- **Discard all offline changes**
  Discard all changes made in the offline worksheet.

5. Click Delete offline worksheet when done. You can take the worksheet offline again later if needed.

6. Click OK.

7. If you clicked **Select changes from log**, Oracle Demantra then displays the screen like the following:

   ![Offline Changes Log](image)

   - Select the Accept Change check box for each change you want to keep.
   - Click the Accept Changes button on the right.
     The selected changes are saved immediately.
Note: You can use similar steps to delete other changes, if you want.

- Click Close.

See also Saving Data for Offline Use.
Managing Items and Locations

This chapter covers the following topics:

• About Managing Items and Locations
• Viewing the Attributes of an Item or Location
• Creating an Item or Location
• Making a New Member Visible
• Modifying an Item or Location
• Deleting an Item or Location
• Overview of New Product Introduction
• Removing Lifecycle Definitions
• Opening an Item or Location in Another Worksheet
• Using Other Right-Click Menu Options

About Managing Items and Locations

Depending on your authorization, you have access to options on the right-click menu that enable you to do the following:

• To view the attributes of an item, location, or other objects (known generically as members)
• To create, edit, and delete items, locations, or other objects
• To perform additional operations on members, as defined within your implementation

Permissions are set separately for each level and potentially for each user.

Where to Work with Items and Locations
The right-click menu is available in different areas of a worksheet:

- In the Members Browser
- In the worksheet table

Visibility of New Items or Locations

Oracle Demantra display only the items and locations for which it has data. Specifically, this means two things:

- A worksheet can display only items and locations that exist in combinations in the database. If an item has not been linked to at least one location, for example, that item cannot be seen in a worksheet. This rule results from the fact that, fundamentally, worksheets select and display combinations.

- A worksheet can display only combinations that have data (even zero-value data). For each combination in a worksheet, the system selects records from the database; if there are no records, the combination cannot be shown.

After you create a new item or location, you must use an additional tool (Member Management, which is a desktop tool) to create one or more combinations for it and to insert placeholder data (consisting of zero sales). See Making a New Member Visible.

Interaction with Corporate Systems

If you change or add items or locations, you should be aware of how Oracle Demantra interacts with your corporate systems. Oracle Demantra periodically imports data about sales, items, and locations from your other systems. Each time data is imported into your system, the changes you have made to the levels are overwritten, depending on the kind of change.

- You should edit or delete existing members only if you are expecting the same change to occur in the imported data, and you need to see the change right away within Oracle Demantra for some reason.

- If you add members, they will be kept when data is imported.

Viewing the Attributes of an Item or Location

To view the attributes of an item or location

1. In your worksheet, find an area that is currently displaying the type of object you want to work with; see Where to Work with Items and Locations.

2. Right-click an object and click View (for example, View Ship to).
Oracle Demantra displays a dialog box like the following:

The attributes shown in red are required. These include the Name attribute and all immediate parents of this member. Depending on your implementation, not all attributes are editable.

**Creating an Item or Location**

**To create an item or location**

1. In your worksheet, find an area that is currently displaying the type of object you want to work with; see Where to Work with Items and Locations.

2. Right-click an object and then select New (for example, New SKU).

   Oracle Demantra displays a window where you specify the name of the new member, as well as its parent levels and other attributes.

3. For Name, specify a unique name.

4. The rest of the fields prompt you for values of attributes associated with this level; the fields shown in red are required. The specific attributes you see depend upon
5. Click Create.

6. Click Data > Update to save your changes.

Note: You cannot see the new member in the worksheet, because the worksheet displays only item-location combinations that exist and that have sales.

Making a New Member Visible

You cannot see the new member in the worksheet, because the worksheet displays only item-location combinations that exist and that have sales. So, after you create a new item or location, you must use an additional tool to create one or more combinations for it and to insert placeholder data (consisting of zero sales).

To make a new item or location visible in worksheets

1. Start Member Management, as described in Starting Member Management. This is a desktop utility; you may or may not have access to it.

2. Display members of the item or location level, as described in Displaying Level Members. You can start with either dimension. In this example, you have added a new SKU. So here you display members of the SKU level.

3. Select the member that you are using as the starting point. For this example, click your new SKU.

4. Click the Link to Location or Link to Item button, whichever button is displayed. For this example, click Link to Location.

Now Member Management displays the levels of the other dimension (in this case, the locations).

Note: To return to the previous screen, click Back.

5. Display members of the desired level. For example, display members of the Ship To level.

6. Click the member that you want to combine with previously selected member. For example, click a Ship To location.

7. Now click Insert Values. Oracle Demantra prompts you to confirm the action. Click Yes. Oracle Demantra creates the combination and inserts placeholder historical
data (0 values) into the database. You will then be able to see your new item or location in any worksheet that includes this combination.

**Note:** This option has no effect on existing combinations.

**Note:** The change is immediate and cannot be canceled.

See also:
- Member Management
- Chaining Management

### Modifying an Item or Location

You can modify a member by changing its name, the parent members to which it belongs, and any visible attributes.

**To modify an item or location**

1. In your worksheet, find an area that is currently displaying the type of object you want to work with; see Where to Work with Items and Locations.

2. Right-click an object and then select Edit (for example, Edit SKU). Then make changes as needed; see Creating and Item or Location for details.

3. Click Finish.

4. Click Data > Update to save your changes.

5. Click Data > Rerun to display the changes.

See also About Managing Items and Locations.

### Deleting an Item or Location

**To delete an item or location**

1. In your worksheet, find an area that is currently displaying the type of object you want to work with; see Where to Work with Items and Locations. Note that you cannot delete objects from within the worksheet table.

2. Right-click an object and click Delete (for example, Delete SKU).

3. Oracle Demantra prompts you to confirm the action. Click Yes or No.
Overview of New Product Introduction

Demand Planners occasionally need to add new products to the product assortment, and are responsible for ensuring these items are populated in Demantra as well as receive a statistical forecast. New product introductions have defined lifecycle phases, which includes:

- Product introduction
- Product maturity
- Product phase-out

In many cases, newly created items replace one (or more) existing items. During the introduction period, sales are expected to increase while sales for items being replaced are expected to decline. For a product no forecast is desired before the introduction period or after the phase-out period.

Depending on the type of product being introduced, generating a useful forecast for items and locations with little or no history can be challenging. Traditionally, Demand Planners used manual forecasting and "best guess" methods to determine a demand plan. However, this method can be time consuming and unsuitable for large scale day-to-day planning processes.

Another method of generating a forecast for items lacking history is to use information from other sources. In contrast with user-derived forecasts, which rely on user expertise and judgment, this process attempts to use reliable analytical forecasting methods. In this approach, additional historical information is retrieved and used as pseudo-history for the combinations lacking real history. When selecting pseudo history for an item one or more data streams are copied from an item deemed similar. User expertise is used when defining the data sources from which history is copied. The pseudo history is used for predicting future behavior of the combination until combination specific information is available.

For example, a sports drinks manufacturer wants to introduce a new flavor, Grape. Even though this product is new, it will have very similar demand to other flavors of sports drink. By associating the new flavor with an old one, Demantra can use the existing forecast to predict sales for the new product.

Creating Similar Products:

Use the Create New Product method to add a new product to the available product assortment. The product will be based on an existing product and use the existing product's configuration and context. The new item will be created using the same hierarchal definitions as existing item and be linked to the same locations for which the existing item is sold. Historical data from the existing product can be copied to the new
product and serve as a basis in generating a forecast using pseudo history.

Create similar product process can be used to create new items or modify existing items, with no historical data.

Items created using Create Similar Product will be linked to the same location for which the source product is created. The creation process can be configured to respect worksheet filters when creating the location link. For example, source product is linked to ten retailers, without any filters the new product will be linked to the same ten retailers. If the worksheet from which the method is called is filtered to only include three of these retailers when the method is called then the new product will only be linked to three retailers.

**To create a similar product:**

1. From any Demand Management worksheet, select the item from which you want to create a similar product.

2. Right click the item and then select Create Similar Product.

   The Create Similar Product dialog box appears.

   ![Create Similar Product dialog box](image)

3. In the Code field, enter an item code. A pre-existing item code without historical data may be chosen or new item code entered.

4. In the Description field, give the new item a descriptive name. For example, "500 ml Grape Sport Drink".

5. From the Copy Source Data drop-down list box, indicate whether data from source member should automatically be copied to the member.

6. In the Launch Date field, select the date when the item is being introduced. This date corresponds to when the item will first begin to sell, no forecast will be
generated before this period.

7. In the End Launch Period field, select the date when the item has completed the launch phase. This field is optional and should only be populated if new item is to cannibalize sales from source item.
   The period during which cannibalization is expected is between the Launch Date and End of Launch Period.

8. In the Cannibalization field, enter the percentage of sales that Demantra should take from the original item.
   This input controls both whether cannibalization of source product will occur during launch time frame as well as the rate of cannibalization. A 0 value will result in no cannibalization of the source product.
   **Note:** If you specify a value for the Cannibalization field, then you must enter a value for End Launch Period.

9. Click the Create button.
   Demantra creates the new item, links it to locations and copies historical data from source to item if instructed to do so.

**Updating Product Lifecycle Definitions:**
Once a similar product has been defined, you can later edit the product details for some (or all) locations from the Edit Lifecycle Definitions Item and Org worksheet.

To update a product lifecycle definition:
1. From the Collaborator Workbench, open any worksheet.
   The Worksheet Designer appears.

2. From the File menu, choose Open.
   From the Open Worksheet dialog box, choose Edit Combination Definition Item & Org.

3. From the Open Worksheet dialog box, choose Edit Combination Definition Item & Org.
   Edit Combination Definition Item & Org worksheet appears.
4. Double-click a worksheet cell to edit the current value.

5. From the Data menu, choose Save Data.

6. Initiate the Update Lifecycle Definitions method to propagate changes in lifecycle definition and affect all relevant areas.

Removing Lifecycle Definitions

A change in the business environment or plan may result in large amount of undesired combinations and data rows existing in the system. This may result from a variety of causes including product assortment changes, erroneous data collection or use of create similar product.

Use the Remove Lifecycle Definitions Item and Org worksheet to remove items and locations links. All data for deleted combinations is also deleted.

To remove lifecycle definitions:

1. From the Collaborator Workbench, open any worksheet.

2. From the File menu, choose Open.

3. From the Open Worksheet dialog box, choose Remove Combination Definition Item
The Remove Combination Definition Item & Org worksheet appears.

4. From the Remove Combination Setting drop-down list box, indicate whether or not you want to delete a combination.

5. From the File menu, choose Save Worksheet.

6. Execute the Remove Combinations method.
   The Remove Combinations dialog box appears.

7. To confirm the deletion, choose Yes from the Remove Combinations drop-down list box, and then click the Remove button.

   **Note:** Removing a combination that is set to cannibalize another item will update the cannibalization percentage for the remaining items.

   **Note:** If all combinations for an item are removed the item itself will be deleted.
Opening an Item or Location in Another Worksheet

Depending on how your system has been configured, you may be able to open a worksheet that is filtered to show only data relevant to the member from which you started.

The specific options are usually different for each aggregation level in your system.

To open an item or location in another worksheet

1. In your worksheet, find an area that is currently displaying the type of object you want to work with; see Where to Work with Items and Locations.

2. Then do one of the following:
   • Right-click the item or location and then select Open. In this case, you are using the default worksheet associated with this item or location.
   • Right-click the member and then select Open With and then select a worksheet. The worksheet appears in a new window or tab, depending on how you are currently viewing the worksheets.

Note: Depending on how this worksheet is defined, it is filtered in one of two ways:
   • - Filtered by member, that is, filtered to show the item or location from which it was launched, aggregating across all combinations. In this case, the name of the worksheet is preceded by the name of the member by which you are filtering it.
   • - Filtered by combination, that is filtered to show the specific combination from which it was launched. In this case, the name of the worksheet is preceded by the word "Filtered".

Using Other Right-Click Menu Options

Depending on your implementation, the right-click menu may include a Methods submenu that includes additional options created by your implementors:
When you click one of these options, Oracle Demantra displays a dialog box like the following:

![Example Method: Rainbow Spc Biscuits (Input)](image)

Select the Save parameters check box if you want to save the attribute changes to the database when the method is run.

For information on any such menu items, please contact your implementors or your designated Oracle Demantra system administrator.
Creating and Redefining Worksheets

This chapter covers the following topics:

- Introduction to Worksheets and Views
- Introduction to Levels
- Introduction to Series
- Visual Elements of Worksheet Views
- Levels and Layout Variations
- Introduction to the Worksheet Editor
- Creating or Editing a Worksheet
- Configuring the Worksheet Basics
- Selecting Series on a Worksheet
- Specifying the Time Resolution and Time Span
- Specifying Aggregation Levels
- Using the Advanced Selection Options
- Changing the Overall Scale or Unit of Measure
- Filtering the Worksheet
- Applying Exception Filters
- Defining the View Layout
- Adding and Managing Worksheet Views
- Specifying the Worksheet Elements in a View
- Adding an Embedded Worksheet
- Filtering a Worksheet View
- Sharing Worksheets
- Deleting Worksheets
Introduction to Worksheets and Views

Within Oracle Demantra, you work almost entirely within worksheets. A worksheet is a customized working environment designed especially for your use. Here you can view and edit data. When you save changes back to the database, they become available to other users and to downstream operations.

A worksheet consists of one or more views, usually displayed as tabs within the worksheet. Each view retrieves a set of data that is aggregated in a specific way and that may also be filtered. The following shows an example:

![Worksheet example](image)

Use this tree to select data at some aggregation level. The view aggregates series data to the specified level.

Use this tree to select data at a level of aggregation. The view aggregates series data to the specified level. Here, views are shown as tabs within the worksheet. You can also display views as child windows of the worksheet.

Introduction to Levels

The first interesting feature of any worksheet view is the aggregation level or levels that it uses. For example, you might want to view data at the account level, as follows:
The worksheet might include a dropdown list instead of this tree control. For example:

<table>
<thead>
<tr>
<th></th>
<th>Demand</th>
<th>Price $</th>
<th>Revenue $</th>
<th>Market Plan $</th>
</tr>
</thead>
<tbody>
<tr>
<td>02/04/2002</td>
<td>5,757,460</td>
<td>$10.00</td>
<td>$57,574,600</td>
<td>$19,771,290</td>
</tr>
<tr>
<td>05/06/2002</td>
<td>7,674,924</td>
<td>$10.00</td>
<td>$76,749,240</td>
<td>$19,771,290</td>
</tr>
<tr>
<td>08/05/2002</td>
<td>7,285,984</td>
<td>$9.99</td>
<td>$72,606,928</td>
<td>$19,609,128</td>
</tr>
<tr>
<td>11/04/2002</td>
<td>5,736,909</td>
<td>$9.97</td>
<td>$57,049,760</td>
<td>$19,609,128</td>
</tr>
<tr>
<td>02/03/2003</td>
<td>1,571,396</td>
<td>$9.99</td>
<td>$15,649,532</td>
<td>$36,329,952</td>
</tr>
<tr>
<td>05/02/2003</td>
<td></td>
<td>$10.00</td>
<td>$57,828,136</td>
<td>$58,347,286</td>
</tr>
<tr>
<td>08/04/2003</td>
<td></td>
<td>$10.00</td>
<td>$63,945,560</td>
<td>$57,773,168</td>
</tr>
<tr>
<td>11/03/2003</td>
<td></td>
<td>$10.00</td>
<td>$47,297,200</td>
<td>$46,307,320</td>
</tr>
<tr>
<td>02/02/2004</td>
<td></td>
<td>$10.00</td>
<td>$49,851,088</td>
<td>$48,727,416</td>
</tr>
</tbody>
</table>

In either case, you can view data for any account. For example, for the quarter that started on February 3, 2003, the Demand for the CVS account was 1,571,396 units, and the unit price was $9.99. You can edit any data that is shown in white, such as the price and market plan.

In generic terminology, the word *member* refers to a unit within a level. For example, CVS is a member of the account level.

**Level Types**

Levels can group and aggregate data in many different ways, and Oracle Demantra uses icons to indicate the type of level:
Item-type levels

Item levels group and aggregate data according to characteristics of the items you sell.

Location type levels

Location levels group and aggregate data according to characteristics of the locations where you sell. For example, location levels could describe geography or types of stores.

Combination (or matrix) levels

Combination (or matrix) levels group and aggregate data according to characteristics of the item-location combinations. These are less common than item and location levels.

Time levels

Time levels group and aggregate data by sales date. Normally you use a time level in place of the time axis.

Promotion levels

Promotion levels group and aggregate data by sales promotions. Depending on how your system is implemented, you may have a hierarchy of promotional levels (to organize the promotions), and the higher levels might use different icons.

Unlike other kinds of levels, promotion levels can be displayed within a Gantt chart.

Settlement levels

Settlement levels, which are used only by DSM. If you use a settlement level in a worksheet, you cannot use levels from any other hierarchy in that worksheet.

Check request levels

Check request levels, which are used only by DSM.

In Oracle Demantra, the levels are completely configurable and are easily extended. The levels that you see should make sense to you. Your Oracle Demantra implementors defined levels as required for your organization, and an authorized user can add more.

Level Attributes

A level can have attributes. For example, a Ship To member might have the following attributes:
Apart from the Name attribute, the attributes shown in red are all parents of this member. They are shown in red because they are required.

The other attributes (such as Unit Cost) do not represent levels in the system but contain information used for reporting and other purposes.

**Introduction to Series**

Each worksheet shows series data associated with the combination that you have currently selected in the worksheet. These series were created by your implementors, for your organization’s needs. A worksheet displays the series data in a table, or in a graph, or both. The following shows an example of a worksheet table:
The example here shows series at the lowest level, but you can view data for any given series at any aggregation level.

As you can see from this example, there are many possible variations of series:

- Some series are editable (see Stat Frcst), some are editable only for specific dates (see Pseudo), and some are not editable at all. Generally, editable series are used as input to other series.

- Some series are shown in different colors, depending on the data values. For example, Sales Fcst Bias is displayed in red for any values less than zero.

- Some series are calculated from other series.

- Some are generated by the Analytical Engine, if that is relevant in your Oracle Demantra solution.

- Most series have time-varying values for each combination, but there are other kinds of series as well (discussed below). For example, the series Stat Frcst specifies whether a combination should be used in forecasting or not. As you can see, this series has the same value for all time buckets for a given combination.

- Most series have numeric values, but some have string or date values. For some series, you choose a value from a dropdown list.

### Kinds of Series

Oracle Demantra supports the following kinds of series:

- Sales series contain time-dependent set of data for item-location combinations. That is, each data point in the series corresponds to a given item-location combination at a given point in time. This type of series is the most common type by far.

- Combination series (also called matrix series) store time-independent data for each item-location combination. That is, each data point in the series corresponds to a
given item-location combination. You use combination series to store and maintain information about item-location combinations, mainly flags for the Analytical Engine to use.

- Promotion series store time-dependent data associated with each promotion, at each item-location combination.

- Level series store data associated with a specific level. Each data point in the series corresponds to a given member of that level.

**Series and Summary Rows**

Each series has been configured to be summarized in a specific way, which you can see in the summary row of the worksheet table. The table has at least one summary row; depending on the layout, it may also include subtotal rows. The following shows an example:

<table>
<thead>
<tr>
<th>Product Family</th>
<th>Account</th>
<th>Time</th>
<th>Price $</th>
<th>Revenue $</th>
<th>Discount</th>
<th>Approved</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gourmet</td>
<td>Stop and Shop</td>
<td>03/10/2003</td>
<td>$10.00</td>
<td>$6,563,948</td>
<td>9.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>09/08/2003</td>
<td>$10.00</td>
<td>$3,150,742</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>03/08/2004</td>
<td>$10.00</td>
<td>$3,141,407</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
<td>$10.00</td>
<td>$13,296,097</td>
<td>3.00%</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>$10.00</td>
<td>$13,296,097</td>
<td>3.00%</td>
<td>1</td>
</tr>
<tr>
<td>Regular</td>
<td>Stop and Shop</td>
<td>03/08/2003</td>
<td>$10.00</td>
<td>$52,507,440</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>03/10/2003</td>
<td>$9.14</td>
<td>$47,052,746</td>
<td>3.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>03/08/2004</td>
<td>$10.00</td>
<td>$13,265,270</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
<td>$9.71</td>
<td>$113,145,464</td>
<td>3.00%</td>
<td>3</td>
</tr>
<tr>
<td>McKessen</td>
<td></td>
<td>03/10/2003</td>
<td>$10.00</td>
<td>$70,9117</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>09/08/2003</td>
<td>$10.00</td>
<td>$1,186,671</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>03/08/2004</td>
<td>$10.00</td>
<td>$308,523</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
<td>$10.00</td>
<td>$2,246,312</td>
<td>0.00%</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>$9.86</td>
<td>$115,391,778</td>
<td>1.50%</td>
<td>2</td>
</tr>
<tr>
<td>Slim</td>
<td>Stop and Shop</td>
<td>03/10/2003</td>
<td>$10.00</td>
<td>$22,640,676</td>
<td>3.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>09/08/2003</td>
<td>$10.00</td>
<td>$21,201,430</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>03/08/2004</td>
<td>$10.00</td>
<td>$7,755,903</td>
<td>0.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
<td>$10.00</td>
<td>$51,626,012</td>
<td>3.00%</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>$10.00</td>
<td>$51,626,012</td>
<td>3.00%</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Summary</td>
<td></td>
<td>$9.93</td>
<td>$180,315,888</td>
<td>2.25%</td>
<td>4</td>
</tr>
</tbody>
</table>

As you can see, Oracle Demantra provides different summarizing options. In this example:

- Price and Discount are summarized by averaging.

- Revenue is summarized by adding all the values.
• The Approved series is summarized by counting the number of approvals.

More complex options are also available. A given series can be summarized in different ways within a single worksheet table. Consult your implementors for details on how your series are summarized.

Visual Elements of Worksheet Views

In general, a worksheet view can contain the following common visual elements:

Axes of the View

Each worksheet view has an x-axis and a y-axis.

• In the graph, the x-axis is shown horizontally and the y-axis is shown vertically.

• In the table, the x-axis is displayed vertically and the y-axis is displayed horizontally. (This way, the x-axis displays the same data in the table and in the graph.)

Members Browser or Combination-Selection Lists

As noted earlier, a worksheet view usually includes either a Members Browser or a set of dropdown menus, which you use to choose the data to display in the rest of the worksheet:
Members Browser

In each case, the selected combination is "Low fat products at the BJ account."

In addition to providing a way to select the data to display, the Members Browser enables you to create, edit, and delete the level members. See Managing Items and Locations. Depending on your implementation, you may also be able to perform additional operations on the members; see Using Other Right-Click Menu Options.

In some cases, the worksheet does not include either of these controls. This means one of following is true:

- The worksheet table is in crosstab format, which displays data for multiple items or multiple locations. See Levels and Layout Variations.

- The data in the worksheet is completely aggregated. It may be filtered, however, so it is not necessarily aggregated across all items and locations.

Worksheet Table

A worksheet table shows series data for the item-location combination that you have currently selected in the view. Depending on how the layout is configured, this may appear as an ordinary table or it may appear as a crosstab; see Levels and Layout Variations.

By default, each row in the table corresponds to a point in time, and each column displays the data for a series. As noted earlier, the table also has a summary row. If the
A worksheet is in crosstab layout, the table also includes subtotal rows.

The table can show the same series as the graph or a completely different set of series, but usually some of the same series are displayed in both places. To specify where each series is displayed, see Defining the View Layout.

You can edit data in the white cells. The gray cells are computed and not editable. For details on editing data, see Editing Data.

For a given combination and date, the table may display symbols that indicate that a promotion or a note is associated with that combination and date. These indicator symbols are generally displayed for only some of the series, depending on how Oracle Demantra has been configured.

See Viewing Notes.

**Graph**

A worksheet graph displays data for the current selection. By default, the horizontal axis shows time, and the vertical axis shows one or more series.

**Subtabs**

A worksheet view can contain multiple subtabs.

- The Notes/Attachments subtab displays notes and attachments related to the selected combination. See Viewing Notes.

- The Activity Details subtab displays promotions and the promotion hierarchy. On the left, the Activity Browser displays an expandable tree view of the promotions associated with the currently selected combination. On the right, the Gantt chart displays the promotions associated with the currently selected combination. You can scroll backwards and forwards in time to see the start and end dates of each promotion, and you can zoom in and out in time.

  Here you can create, edit, and delete promotions and higher levels in the promotion hierarchy. See the Oracle Demantra Trade Promotion Planning User's Guide.

- A worksheet can include a subtab that contains a related worksheet. When you select a combination in the worksheet table, the related worksheet shows data associated with that combination. This related worksheet potentially includes different series than the rest of the worksheet and may also be filtered further.

  See also Defining the View Layout.

**Levels and Layout Variations**

A worksheet can include multiple different levels or no levels at all (for a completely aggregated view).
When a level is included in a worksheet, that means you can see data associated with each member of that level.

**Multiple Levels in a Worksheet View**

A worksheet view can include multiple levels, for example:

![Worksheet View with Multiple Levels](image)

The appearance is slightly different if the worksheet includes dropdown lists instead of the Members Browser. For example:

![Worksheet View with Drop-down Lists](image)

When a view includes multiple levels, you have a more detailed view of the data. In the earlier example, data was aggregated across all SKUs for a given account. Here, in contrast, you see data aggregated separately for each SKU.
Level Members Displayed in Cross-tab Format

It is also possible to lay out a worksheet so that the members of a level are all displayed at the same time. This format is called a cross-tab layout, and the table (also known as a pivot table) provides a cross tabulation of all the members.

The following figure shows a worksheet table in cross-tab layout, with a row for each SKU member within each time bucket:

Notice that the Members Browser does not include the SKU level, because all SKUs are displayed at the same time.

For another example, the worksheet could instead display the SKU members across the top of the table rather than down the side, as in the following example:

Cross-tab Definitions

There are ways that you can choose to display data in a table. You can position these entities on either the x- (columns) or y-axis (rows) of the table:

- Level
• Time

• Series: For example, if you want to compare two SKUs and their forecasts side by side, you can arrange the worksheet to display all series as rows and all levels as columns.

You can position the summary at the top, bottom, left, or right side of a worksheet

• If there are many rows in a table, you can place the horizontal worksheet summary at the top of the worksheet and place the horizontal level summary at the top of the worksheet. The summary can be at top or bottom regardless of how many rows display.

• If there are column summaries in a table, you can place the vertical worksheet summary at the left of the worksheet, and place the vertical level summaries at the left of the levels. When series display as rows, you can display the summary row either as the first (at the left) or the last column (at the right) in the table.

• You can place a combination of horizontal and vertical summaries in the same worksheet.

• You do not see a value on the worksheet in cells where horizontal and vertical summaries intersect.

To change the position of the summary row or column:

• In the Worksheet Designer, open the Layout region.

• Right-click on a level or series.

• Select Left/Right, or Top/Bottom.

You can turn off (hide) the display of summaries, for example, if you

• Want to use a separate view for rollups

• Have data that does not summarize meaningfully

• Want to save space on your screen

You can hide:

• Level and worksheet summaries

• Level summaries but display worksheet summaries

• Worksheet summaries but display level summaries

The Worksheet Designer does not automatically hide any summaries. You evaluate the worksheet for meaningless and redundant summaries and hide them. It does, however,
automatically hide repetitious summaries (summaries that summarize only one entity),
for example, a promotion scenario that has only one promotion.

To turn off a summary:

- In the Worksheet Designer, open the View’ region.
- Right-click a level or series and deselected Show Summary

You can freeze a worksheet summary row at the top. It then remains in position when you scroll.

To freeze the worksheet summary row, navigate to View > Freeze Overall Summary.

**Introduction to the Worksheet Editor**

**To create a new worksheet**

Click File > New. Or click the New button.

**To edit an existing worksheet**

1. Click File > Open. Or click the Open button.
2. Click a worksheet and click Open.

The worksheet editor has a set of buttons on the left that you click to open different pages with different purposes:

<table>
<thead>
<tr>
<th>Button</th>
<th>Purpose</th>
<th>For details, see...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display</td>
<td>Specify basic information about the worksheet; specify how to display the content of this worksheet in Collaborator Workbench.</td>
<td>Configuring the Worksheet Basics</td>
</tr>
<tr>
<td>Series</td>
<td>Select series to include.</td>
<td>Selecting Series on a Worksheet</td>
</tr>
<tr>
<td>Time</td>
<td>Specify time resolution of worksheet and span of time to consider.</td>
<td>Specifying the Time Resolution</td>
</tr>
<tr>
<td>Aggregation Levels</td>
<td>Optionally specify aggregation levels to include.</td>
<td>Specifying Aggregation Levels</td>
</tr>
</tbody>
</table>
Creating and Redefining Worksheets

<table>
<thead>
<tr>
<th>Button</th>
<th>Purpose</th>
<th>For details, see...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filters</td>
<td>Optionally filter the data in the worksheet.</td>
<td>Filtering the Worksheet</td>
</tr>
<tr>
<td>Exceptions</td>
<td>Optionally apply exception filters to further filter the worksheet.</td>
<td>Applying Exception Filters</td>
</tr>
<tr>
<td>Layout Designer</td>
<td>Define the layout of the worksheet and its views, including the layout of the worksheet tables, the location of each included series, and the graph format.</td>
<td>Defining the View Layout</td>
</tr>
</tbody>
</table>

Here you have the following options:

- To move to another page, either click a button on the left side of the page or click Previous or Next.
- To exit the worksheet editor and keep your changes, click OK.
- To exit the worksheet editor and discard all changes, click Cancel.

Working with Lists

As you create or edit worksheets, you will often use pages that present two lists of elements, where you specify your selections. To do so, you move elements from the left list to the right list. The left list always presents the available elements (such as the available series) and the right list always shows your selections.

You can move elements from one list to the other in many equivalent ways, summarized here:

- To move all elements from one list to the other, click one of the double arrow buttons, as appropriate.
- To move a single element from one list to the other, click the element and then click one of the single arrow buttons, as appropriate. Or double-click the element.
- To move several adjacent elements, click the first element, press Shift and click the last element. Then click one of the single arrow buttons, as appropriate.
- To move several elements that are not adjacent, press Ctrl and click each element you want. Then click one of the single arrow buttons, as appropriate.
Creating or Editing a Worksheet

To create a new worksheet
Click File > New. Or click the New button.

To edit an existing worksheet
1. Click File > Open. Or click the Open button.
2. Click a worksheet and click Open.
3. Click the Worksheet menu and select one of the menu items. Or click one of the worksheet buttons on the toolbar.
4. Save your changes to the worksheet definition:
   • To save the new definition, click the Save button. Or click File > Save
     Note: In contrast, the Data > Update option saves the data and notes in the worksheet, not the worksheet definition.
   • To save the worksheet with a new name, click the Save As button.
5. Rerun the worksheet to see your changes (unless you have changed only the layout, which is refreshed automatically). To do so, click Data > Rerun. Or click the Run button.

Configuring the Worksheet Basics

To configure basic information for a worksheet
1. Click Worksheet > Display. Or click the Display button.
   The system displays a page where you specify the following basic worksheet information:
Creating and Redefining Worksheets

Name

The title to use in the My Worksheets module and in the worksheet window title.

Description

Provides optional information to display in My Worksheets. This is especially useful in public worksheets for explaining the purpose of the worksheet to other users.

Access

Select Private or Public. Private is for your use only. Public worksheets are available to all users in the group.
| **Enable Extra Filters** | This option adds an extra, user-controlled filter to the worksheet. If you select the Enable Extra Filters check box, that means that when you open the worksheet, you can prefilter the data before seeing the worksheet results; this is especially useful for users who use Oracle Demantra Anywhere.

Normally when you specify aggregation levels to include in the worksheet (as described in Specifying Aggregation Levels), all members of those levels are available in the worksheet.

If you select the Enable Extra Filters check box, that means that when you run the worksheet, Oracle Demantra first prompts you to select the members to display for each level. For an example, see Viewing Data.

This option has no effect on content panes. |
| **Cache Worksheet Data** | Specifies whether Oracle Demantra should cache the data for this worksheet, for each user who works with it. If you cache a worksheet, it will run more quickly in general, but the cache will need to be refreshed periodically. Choose one of the following refresh options:

- Manual: You manually refresh the cache. See To refresh your local worksheet cache.

- Automatic: Oracle Demantra will automatically refresh the cache, as specified by your implementors.

In either case, Oracle Demantra automatically detects when a cache is out of date and behaves appropriately. Oracle Demantra also automatically refreshes the cache when you make certain structural changes to the worksheet. |
Open With Context

Specifies how this worksheet should be filtered when a user opens it through the Open or Open With menu options (on the right-click menu; see Opening an Item or Location in Another Worksheet).

Choose one of the following options:

- Selected Member (this will filter the worksheet to the object from which it was launched, aggregating across all combinations associated with that object)

- Selected Combination (this will filter the worksheet to the combination from which it was launched)

2. To display the content of this worksheet in Collaborator Workbench, check Content and then complete the following fields:

Display Format

Specifies the display format to use. Not all display formats may be possible, depending on the number of levels and series you include.

Currently, Collaborator Workbench chooses the color to use for each series, when displaying series in the graph-type content panes.

Location

Select Wide Pane or Narrow Pane to determine where the content pane will be displayed in Collaborator Workbench.
Top/Bottom Filter

(Only for bar chart content panes.) Specifies how to filter the members or combinations for display in the bar chart (to save space, not all members are shown).

- Use the dropdown menu to specify whether the filter should apply to the top-ranked or to bottom-ranked members.

- In the input field, specify the number of members to be included.

- For **Criteria Series**, select the series that Collaborator Workbench should use to rank the members. (This does not control the order in which they are displayed in the chart.)

**Note:** If multiple items have identical values, all of them are displayed, and they collectively count as 1 towards the total. For example, suppose top values were 200, 150, 150, 100, and 50. If you specified Top/Bottom filter as three, you would see a total of four items: both the 150 items, in addition to the 200 and 100 items.

This option does not affect the worksheet.

3. To specify how the worksheet table should appear, see Defining the View Layout.

### Selecting Series on a Worksheet

Every worksheet must include at least one series.

**Note:** If you use a settlement level in a worksheet, all series in the worksheet must refer to tables used by the settlement hierarchy.

**To specify the series on a worksheet**

1. Click Worksheet > Series. Or click the Series button.

The system displays the Available Series and Selected Series lists. Each list is a collapsible list of series groups and the series in them.

You can instruct Worksheet Manager to display the series in a series group either:

- In alphabetical order
• By the display order that you set in Business Modeler

In Business Modeler, set parameter Sort Series by Display Order. See Oracle Demantra Implementation Guide.

2. Move all series that you want into the Selected Series list. To do so, either double-click each series or drag and drop it. You can also move an entire series group from one list to the other in the same way.

3. Remove any series from the Selected Series list that you do not want to include on the worksheet.

   **Note:** You cannot remove a series from a worksheet if that worksheet uses it as the Criteria Series for bar chart content. See Viewing Pending Changes to Data.

4. To change the order in which the series are displayed, see Defining the View Layout.

   See also Introduction to Series.

**Managing the Series Lists**

You may have a very large number of series, and it can be useful to sort and filter these lists so that you can readily find what you need. The system also provides a search mechanism.
Note: This section applies only to the series page of the worksheet editor (Worksheet > Series). To sort the series as displayed in the worksheet, see To define the layout of a current view.

To sort a list of series

1. Click the Sort button.
   The Sort dialog box is displayed.

2. Drag the list name from the Available Columns to the Sort Columns. Or double-click the list name in the Available Columns list.

3. Click OK.

To filter a list of series

1. Click the Filter button.
   The Filter page appears.

2. Click Add.

3. Click the arrow to the right of the operator box and select an operator from the dropdown list.

4. In the number box, enter the value by which to filter the list.

5. (Optional) You can filter further by using the AND relationship.

6. Click OK.

To find a series

1. Click the Find button.
   The Find dialog box appears.

2. In the Find where box, select the name of the list to search.

3. In the Find what box, type name of the series.

4. Select Up, Down or All to determine the direction of the search.

5. (Optional) Select one or more of the check boxes:
   • Whole Word: Search for the exact match of a word.
- Match Case: Search for the exact match of a word (case sensitive).

6. Click Find Next to begin (or continue) searching.

**Specifying the Time Resolution and Time Span**

Each worksheet selects data for a specified span of time and optionally aggregates it in time. You use the Time dialog box to specify the time resolution of the worksheet results and to decide the span of time to which the worksheet applies.

To specify time criteria

1. Click Worksheet > Time. Or click the Time button.

2. In the Time Scale box, specify the time resolution of the worksheet results. The data in the worksheet is aggregated to this time resolution. That is, this option specifies the period of time that each data point in the line graph represents.

3. In the Time Filter box, specify the time period to which the worksheet applies:
   - Fixed if you always want the worksheet to show a specific time range, regardless of the current date.
   - Relative to Today if you always want the worksheet to show a time range relative to today.
   - Relative to Last Sales Date if you always want the worksheet to show a time range relative to the last sales date in the loaded data.
4. In the From Date and To Date boxes, enter values depending on the time filter you have chosen, as follows:

<table>
<thead>
<tr>
<th>Time Filter</th>
<th>Box</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative</td>
<td>From Date/To Date</td>
<td>Specify periods in both From and To with the current (computer) date as the reference point. For example: If the Time Scale is Month, and you want to see results starting from six months before today, enter -6 in From Date.</td>
</tr>
<tr>
<td>Fixed</td>
<td>From Date</td>
<td>Enter a specific date as a starting point of the worksheet results. To enter a date, click the calendar button and select a date.</td>
</tr>
<tr>
<td>Fixed</td>
<td>To Date</td>
<td>Specify the number of periods you want to include, starting from the From date.</td>
</tr>
</tbody>
</table>

5. To control how dates are displayed in the worksheet, click the Advanced button, which brings up the following dialog box:

   ![Advanced Time Settings dialog box]

   - In the Format dropdown list, select a display format.
2. To offset the displayed dates, optionally specify values for Month Offset or Year Offset. For example, to add one month to each displayed date, specify 1 for Month Offset.

   The Preview field shows what the first time bucket in the worksheet would look like with this format and offset.

3. Click OK.

Note

If you change the time scale, the worksheet might not show exactly the same aggregate numbers, because the cutoff points for the worksheet would not necessarily be the same. For example, suppose your worksheet is weekly and displays 48 weeks of data. Then suppose you change the worksheet to display quarterly data. A quarter is 13 weeks, and the original span (48 weeks) is not an integer multiple of 13. So the worksheet selects a different amount of data and shows different overall results.

Specifying Aggregation Levels

A worksheet usually includes aggregation levels. When you use the worksheet, you can examine data for the item-location combinations associated with those levels.

Based on the levels included in a worksheet, Oracle Demantra automatically determines which item-location combinations the worksheet should include. Depending on which combination you select, the worksheet displays series data associated with that combination. For example, if you select one location level (city) and one item level (SKU), the worksheet will contain series data associated with each city-SKU combination. On the other hand, if you select one location level (city) and you do not specify an item level, the worksheet aggregates data for all items. That is, the worksheet will contain series data associated with each city, aggregated for all products.

- If you do not specify any aggregation levels in a worksheet, the data is completely aggregated across all items and locations.

- If you use a settlement level in a worksheet, you cannot use levels from any other hierarchy in that worksheet.

To specify the aggregation levels in a worksheet

1. Click Worksheet > Aggregation Levels. Or click the Levels button.

   The system displays the Available Levels and Selected Levels lists.

2. Move all aggregation levels that you want into the Selected Levels list, using any of the techniques in Working with Lists.
3. Remove any unwanted levels from the Selected Levels list.

![Selected Levels](image)

The selected levels will now be used on all views of this worksheet, unless you configure the views otherwise; see To specify which levels to use in a worksheet view.

The layout of the worksheet view controls the order in which the levels are used; see Defining the View Layout.

See also:

- Using the Advanced Selection Options
- Introduction to Levels
- Changing the Overall Scale or Unit of Measure

**Using the Advanced Selection Options**

By default, if a worksheet includes a promotion level, the worksheet includes all the following types of combinations:

- Combinations that have both sales data and promotions
- Combinations that have sales data, but no promotions
- Combinations that have promotions, but no sales data

The worksheet displays placeholders for combinations that do not have promotions. For example:
If you move the promotion level to the worksheet axis (see Defining the View Layout), the table will display a similar placeholder.

You can exclude some of these combinations. For example, you might want the worksheet to include only the combinations that have both sales and promotions, as follows:

To exclude combinations with partial data

1. Click Worksheet > Aggregation Levels. Or click the Levels button.

2. Make sure that the worksheet includes at least two levels, one of which should be a promotional level.

   When you do so, the screen displays an Advanced button in the lower right.
3. Click Advanced. Oracle displays a dialog box with additional options.
Include combinations that exist only in Promotion
This option selects combinations that have associated promotions, even if they do not have sales data.

Include combinations that exist only in SALES_DATA
This option selects combinations that have sales data, even if they do not have any associated promotions.

4. To exclude the combinations you do not want to see, select the check boxes as needed.

See also Specifying Aggregation Levels.

Changing the Overall Scale or Unit of Measure
In addition to levels, series, and filtering, a worksheet has the following characteristics:

• A single unit of measure. Typically, most series refer to this unit of measure, but there are exceptions such as percentage values. You can switch the unit of measure, and the displayed values are changed accordingly. The units in your system depend upon your implementation but probably include unit count and dollars. For monetary units, you can also switch to a different index (such as the Consumer Price Index or CPI) or exchange rate, and the worksheet automatically multiplies all values accordingly.

• An overall scale, which defaults to 1. If the displayed values are all large, it can be useful to re-scale the worksheet, for example, to display in amounts of 1000 or 1000000.

You can change either or both of these. When you make this change, the displayed values for most or all of the series in the worksheet are changed.

Note: This change affects only the series that are scaled. Not all series are scaled. For example, a series defined as a percentage is probably not scaled.

To change the overall scaling factor
1. Click Worksheet > Aggregation Levels. Or click the Levels button.

The Levels page includes a section where you specify the overall scale of the worksheet, as well as its units of measure.
2. In the Scale Units by box, specify the factor by which all numbers in the worksheet are to be divided (for display purposes).

For example, if you specify a factor of 1000, the displayed data will divided by 1000. So the number 96,000 will be displayed as 96. The vertical axis of the graph is updated to show the factor in parentheses. For example, if the vertical axis was formerly labeled "units", it will be updated to say "units (1000)" instead.

To change the unit of measure

1. Click Worksheet > Aggregation Levels. Or click the Levels button on the toolbar.

2. In the Unit Type box, select the unit of measure to display in the worksheet results.

For example, our items are bottles, and suppose that a case that contains six bottles. If you display the worksheet with cases instead, the system will display the number of bottles divided by six.

3. If the Index box is displayed, choose an index from the dropdown list.

The Index menu lists all the time-dependent indexes and exchange rates that are associated with this unit. Each index or exchange rate is a time-varying factor that the worksheet can use. When you select an index, the worksheet will automatically multiply all monetary series by the factor for each date. For example, if you choose Consumer Price Index (CPI) as the index, the system will calculate all monetary quantities with relation to the CPI.

Note: These indexes and exchange rates are generally imported from other systems. The set available to you depends upon your implementation.
See also Specifying Aggregation Levels.

Filtering the Worksheet

Filters control the combinations that you are able to see. Filtering can have multiple sources:

- A given worksheet may be filtered. For example, worksheet X might show only Brand X, which means that the worksheet would show only combinations related to Brand X.

- Your user ID may be filtered. For example, if you are an account manager, your user ID might give you access only to your accounts. At any level, you would not be able to see combinations associated with other accounts.

- The data that you share with other users (called the component) might also be filtered. Components divide the data for different sets of users.

Oracle Demantra automatically combines all the filters. In the preceding example, if the component is not filtered, if you use worksheet X, you can see only data for Brand X at your accounts.

In contrast to an exception filter (Applying Exception Filters), this type of filter is static and behaves the same no matter how the data changes.

To apply a filter to a worksheet

1. Click Worksheet > Filters. Or click the Filters button.

   The system displays the Available Filter Levels and Selected Filter Levels lists.

   You can instruct Worksheet Manager to display the level members on the filter screen either by:

   - Code

   - Description

   In Business Modeler, set parameter Sort Member by Code in Filter. See Oracle Demantra Implementation Guide.

2. Find the aggregation level at which you want to filter data and move it from the Available Filter Levels list into the Selected Filter Levels list, using any of the techniques in Working with Lists.

   **Note:** This level does not have to be the same as any of the aggregation levels you display in the worksheet. In fact, typically you filter using a different level than you use to display.
3. In the Available Members list, find a member that you want to include in the worksheet and move it into the Selected Members list, using any of the techniques in Working with Lists.

At this stage, the worksheet includes only data for this member. (Before you applied a filter at this level, the worksheet could theoretically include any member of this level.)

4. Continue to move members from the Available Members list into the Selected Members list, until the latter list includes all the members you want.

To filter data further

Once you have applied a filter, the content pane contains only those members that meet the filter criteria that you specified. To avoid performance issues and database errors, there are system limits on the number of members that the each filter can select and that it can display in the Available Filter Level List. Therefore, the visible list may not include all the members that meet the filter criteria that you specified.

You can further filter the data by using either of these techniques:

- Filter member search: You search for a specific member in the visible list and the specific member is highlighted.

- Filter member filter: You apply another filter to the visible list to reduce it further.

When you apply a filter member filter to the results of the first filter, it behaves differently depending on whether the visible list is complete or incomplete.

If the visible list from the first filter is complete, it shows all the members that meet the filter criteria that you specified in the initial filter. The second filter member filter searches on the members in the visible list. For example:

- There is a system limit of 1000 members to display in the visible list

- You have a worksheet with 10,000 members.

- You apply a filter at the SKU level and 1000 of the members meet the filter criteria. The visible list displays the 1000 members; the visible list is complete.
• You apply a filter member filter for which there are 200 matches in the worksheet using both filters.

• This second filter searches the complete visible list that you retrieved with the first filter and displays the 200 matching members.

If the visible list from the first filter is incomplete, it does not show all the members that meet the filter criteria that you specified in the initial filter. It was subject to system limits. When you apply a further filter to the visible list, the list may not include all the data that you want to filter to. Therefore, this second filter searches on all the members in the full worksheet. For example:

• There is a system limit of 1000 members to display in the visible list

• You have a worksheet with 10,000 members.

• You apply a filter at the SKU level and 2000 of the members meet the filter criteria. The visible list displays 1000 of the 2000 members because of the system limit; the visible list is incomplete.

• You apply a filter member filter for which there are 200 matches in the worksheet using both filters. However the incomplete variable list only contains 37 members that would match in the worksheet using both filters.

• If this second filter searched on the visible list, it would only display 37 matching members. Instead, it applies both filters to all the members in the full worksheet and displays the 200 matching members.

See also Applying Exception Filters.

Managing the List of Members

Depending on how your system has been configured, it might contain a very large number of members. If so, you might want to sort or filter the list or search it. For information, see Managing the Series Lists.

Applying Exception Filters

If you attach an exception filter to a worksheet, Oracle Demantra checks the values of the worksheet data and displays only the combinations that meet the exception criteria. In contrast to an explicit filter (Filtering the Worksheet), this type of filter is dynamic and can behave differently as the data changes.

Specifically, you define an exception condition that consists of a series, a comparison operator, and a value, for example:
When you open the worksheet, Oracle Demantra checks each combination in the worksheet. For each combination, if the condition is met for any time in the worksheet date range, Oracle Demantra displays that combination. For example, the worksheet shows combinations that have Sales Plan values greater than or equal to 150000, within the time range included in the worksheet.

**Note:** Exception filters do not cause filtering in time. If a combination meets the exception criteria, Oracle Demantra displays data for that combination for all time buckets within the time range of the worksheet.

If the condition is not met at any time for any of the worksheet combinations, Oracle Demantra shows the worksheet as empty. That is, if all values in the Sales series are less than 150000 for all combinations, the worksheet comes up empty.

**Note:** If the worksheet includes a promotion level or a promotion series, the behavior is slightly different. In this case, the Members Browser or dropdown list does initially show all combinations. When you click a combination to display it, the worksheet then checks for exceptions.

You can apply multiple exceptions to a worksheet. When you apply multiple exceptions, you can relate them to each other by using logical AND or logical OR relationships. For example:

When you open the worksheet, Oracle Demantra checks each combination in the worksheet. For each combination, if the condition is met for any time in the worksheet date range, Oracle Demantra displays that combination. For example, the worksheet shows combinations that have Sales Plan values greater than or equal to 150000, within the time range included in the worksheet.

**Note:** Exception filters do not cause filtering in time. If a combination meets the exception criteria, Oracle Demantra displays data for that combination for all time buckets within the time range of the worksheet.

If the condition is not met at any time for any of the worksheet combinations, Oracle Demantra shows the worksheet as empty. That is, if all values in the Sales series are less than 150000 for all combinations, the worksheet comes up empty.

**Note:** If the worksheet includes a promotion level or a promotion series, the behavior is slightly different. In this case, the Members Browser or dropdown list does initially show all combinations. When you click a combination to display it, the worksheet then checks for exceptions.

You can apply multiple exceptions to a worksheet. When you apply multiple exceptions, you can relate them to each other by using logical AND or logical OR relationships. For example:

<table>
<thead>
<tr>
<th>Exception Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sales Plan</strong></td>
</tr>
<tr>
<td><strong>&gt;=</strong></td>
</tr>
<tr>
<td><strong>150000.0</strong></td>
</tr>
</tbody>
</table>

**To apply an exception filter**

1. Click Worksheet > Exceptions. Or click the Exceptions button. The Exceptions Filter page appears.

2. Click Add.

3. In the first box in the new row, select a series from the dropdown list.
Note: Typically only some series are available for exceptions. If you do not see a series you need, contact your Oracle Demantra administrator or your implementors.

4. In the second box, select an operator from the dropdown list.

5. In the third box, type or choose a value.

   - For a numeric series, type a number.
   - For a dropdown series, choose one of the allowed values of this series.
   - For a string-type series, type any string. You can use the percent character (%) as a wildcard.
   - For a date-type series, type a date or use the calendar control to choose a date.
   - For a percentage, use decimals. For example, substitute 1.2 for 120% or 0.35 for 35%.

6. (Optional) You can apply additional exceptions. Click the AND or the OR radio button to specify the relationship between the exceptions.

To delete an exception filter
Click the exception and then click Delete.

See also:
- Filtering the Worksheet
- Introduction to Series

Defining the View Layout
To define the layout of a current view
1. Click Worksheet > Layout Designer. Or click the Layout Designer button. 

The system displays a page where you specify the layout. This page displays the following areas:

In addition, this screen displays the following icons:

- An icon for each aggregation level that you have included in the worksheet. By default, these levels are included in the Members Browser or selector lists.
- An icon that represents the time axis. By default, time is shown on the x-axis.
- An icon that represents the series data. Series are shown on the y-axis.

2. To change the worksheet layout, drag the level or time axis icons to the appropriate areas. You cannot move the series icon.

3. To specify the type of graph to use, select a graph type from the Graph Type dropdown list.

4. To specify how to display series in this view:
   1. Click the Sort button.

   The Layout Designer displays a page that shows the order in which this view currently displays the series. The default order of the series is the order that you added the series.
2. To hide a series in this view, click the None option in the dropdown list to the right of the series name.

3. Otherwise, to specify where to display the data for a series, select one of the following options: Table, Graph, Table and Graph.

4. To move a series up or down in this list, click the series name and drag it up or down. If you want to restore the series to their original order, click the Reset layout button.

5. When you are done, click Close.

5. Click Save.

6. Rerun the worksheet to see your changes. To do so, click Data > Rerun.

To specify a crosstab layout

Drag one or more level icons from the Page Item area to x-axis or y-axis areas.

To specify which levels to use in a worksheet view

By default, all levels you include in a worksheet are used on all views of the worksheet. Within a multi-view worksheet, you often hide some of the levels in some views, so that each view is aggregated differently.

1. Right-click within the Page area of the Layout Designer.

The system displays a menu like the following:
2. Click Hide level and then click the name of the level to hide.

   When you hide a level, the worksheet automatically aggregates data across members of that level.

   **Note:** Do not use this option to hide the time axis.

**To revert to the default layout of a worksheet view**

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to reset.

3. Click the Reset button.

   In the default layout, all selected levels are visible and are on the X axis. Also, all series are displayed in the graph and table according to their default definitions.

See also:

- Visual Elements of Worksheet Views
- Levels and Layout Variables
- Specifying the Worksheet Elements in a View
- Adding an Embedded Worksheet
- Filtering a Worksheet View

**Adding and Managing Worksheet Views**

A worksheet can include multiple views, each of which can have a different set of series and a different layout.

**Note:** If you display the worksheet views as tabs, note that Oracle Demantra does not provide a way to change the order in which the tabs
are displayed. The tabs are displayed in the order in which you create them.

**To add a worksheet view**

1. Within the Layout Designer, click the Add Worksheet View button.
2. In the popup dialog box, type the name of the new view.
3. Click OK.

**To control synchronization between the views**

The views of a worksheet may or may not be synchronized with each other. If they are synchronized, when you edit in one view, that change automatically appears in the other views. Because this can affect performance, sometimes it is best to switch off this synchronization.

Within the Layout Designer, click one of the following buttons, whichever is currently displayed:

- Do not force synchronization between views
- Synchronize data between views

**To rename a worksheet view**

1. Within the Layout Designer, click the Rename Worksheet View button.
2. In the popup dialog box, type the new name of the view.
3. Click OK.

**To enable or disable a worksheet view**

1. Within the Layout Designer, click the Hide/Display button.
2. The Layout Designer displays a popup list of all the views associated with this worksheet. A check mark is displayed next to each view that can currently be displayed.
3. For the view interest, select the check box next to the name of the view.
4. Click elsewhere on the screen to close the list of views.

**To delete a worksheet view**

Within the Layout Designer, do one of the following:

- Click the tab that corresponds to the worksheet view. Then click the Delete Worksheet View button.
- Click the Delete All Worksheet View button. Then, at the prompt, click Yes.

See also:

- Defining the View Layout
- Specifying the Worksheet Elements in a View
- Adding an Embedded Worksheet
- Filtering a Worksheet View

**Specifying the Worksheet Elements in a View**

For each worksheet view, you can specify which of the basic worksheet elements are included: the table, the graph, and so on.

**To specify the elements to include in a worksheet view:**

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.
2. Click the tab corresponding to the worksheet view you want to modify.
3. Click Advanced... in the lower right.

   Oracle Demantra displays the following screen:
4. For Combination Selector, click either Tree (to display a Members Browser) or Dropdowns (to display dropdown menus instead).

5. Select the check box next to each element you want to include in this view of the worksheet.

6. Click OK.

Adding an Embedded Worksheet

You can display one or more associated worksheets embedded within a subtab. When you select a member in the view, the embedded worksheet is filtered to show just that member. You typically use an embedded worksheet to drill into further detail.

**Note:** If you use the keyboard to move through the worksheet table, the subtabs are not automatically refreshed, for performance reasons.

To add an embedded worksheet

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view to which you want to add the embedded worksheet.
3. Click Advanced... in the lower right.
   Oracle Demantra displays the Advanced screen.

4. Click the Add WS As Subtabs tab.
   Oracle Demantra displays a screen like the following:

   ![Advanced Screen](image)

   Depending on the level that you select, the bottom part of the screen shows different worksheets that you can add as an embedded worksheet to this worksheet view.

5. For Selected Levels, select the level that is associated with the worksheet you want. In general, a worksheet is associated with the levels where it makes sense to use it; this is controlled by your system configuration. You can choose any of the levels that are used in this worksheet.

6. For Selected Worksheets, select the worksheets that you want to display as embedded worksheets.

7. Click OK.

**Filtering a Worksheet View**

For each worksheet view, you can filter the view to show a subset of the data in the worksheet.
To filter a worksheet view

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to filter.

3. Click Advanced... in the lower right.
   Oracle Demantra displays the Advanced screen.

4. Click the Filter By Level Members tab.
   Oracle Demantra displays a screen like the following:

5. For Selected Filter Levels, select the level by which you want to filter this worksheet view. You can choose any of the levels that are used in this worksheet.

6. For Selected Members, select the level members whose data should be displayed in this worksheet view.

7. Click OK.

Sharing Worksheets

In general, any worksheet is one of the following:

- Private—available only to you
• Public—available to other users as well. (If you are using Collaborator Workbench, this means the worksheet is available to other users within the collaborative group.)

In either case, the original creator of a worksheet owns it and only that person can change it.

When you do share worksheets, however, you should consider data security. Oracle Demantra automatically prevents any user from seeing data for which he or she does not have permissions. If you build a worksheet with data that other users do not have permissions to view, then those users will see an empty worksheet. Similarly, if a user has partial permissions for the data, then the worksheet will open with only those results that are permitted.

See also Configuring the Worksheet Basics.

Deleting Worksheets

You can delete a worksheet if you are its owner.

To delete a worksheet

1. Open the worksheet.

2. Click File > Delete. Or click the Delete button.

   Oracle Demantra prompts you to confirm the deletion.

3. Click Yes or No.

General Tips on Worksheet Design

For performance reasons, don’t select too much data to view, unless there is no other choice.

If you receive a message saying “out of memory,” try the following techniques to reduce the amount of memory that your worksheet selects:

• Remove series if possible

• Reduce the span of time

• Apply filters

Also see the Oracle Demantra Implementation Guide.

If you do need to select a large amount of data, use the levels to your advantage. Specifically, use the levels in the Members Browser or selector lists rather than moving them to a worksheet axis. If levels are in the Members Browser or selector lists, each combination in the worksheet is relatively smaller and will load more quickly.
If you do not plan on working with the Activity Browser, you can switch off the Auto Sync option on the toolbar, and you can also hide the Activity Browser and Gantt chart.

Remember that you can filter the worksheet by any level, including levels that are not shown in the worksheet. For example, you might want to see data at the region level, but exclude any data that does not apply to the Acme territory. To do this, you would filter the worksheet to include only the Acme member of the Territory level, but you would select data at the Region level.

A multi-view worksheet is useful in the following cases:

- If you need to edit data at one aggregation level and see easily how that affects higher aggregation levels.

- If you need to display a large number of series without having to scroll to see each one.

### Viewing the Definition of a Worksheet

**To view the definition of a worksheet**

1. Open the worksheet.

2. Click Data > Info. Or click the Info button.

Oracle Demantra displays a dialog box that summarizes the definition of a worksheet, for example:
This chapter covers the following topics:

- Introduction to Member Management
- Starting Member Management
- Introduction to the Member Management Tool
- Creating a Member
- Creating a Combination
- Creating Placeholder Data
- Managing the Lowest-Level Combinations
- Moving a Member
- Copying a Member
- Renaming a Member
- Deleting a Member

Introduction to Member Management

Most members and combinations in Oracle Demantra are imported and have historical data. When you are planning new products or new sales locations, however, you do not have any imported data to work with. In this case, you can create members and combinations directly in Oracle Demantra, and you can initialize the new combinations with data copied from combinations that you expect to be similar. Then the Analytical Engine can include the planned combinations in the forecast.

This overall process consists of the following steps:

1. Create a new member at any aggregation level, if the member you need does not yet exist. For example, you can create a new SKU or a new distribution center.

2. Create new combinations that include the new member. For example, if you have
created a new SKU, then create combinations of that SKU with various stores that will sell the SKU. Or if you are introducing an existing product to a store where it has not been sold, create a combination of that product and store.

3. Identify some combination that you believe will have a similar sales pattern to the new combinations. Copy data for specified series from those combinations to your new combinations, optionally multiplying by an overall factor.

   **Note:** This step is known as chaining, and is described in Chaining Management.

### Default Members

Oracle Demantra provides a default member within each level, as a placeholder, for example:

![Diagram of hierarchy with default members](image)

These placeholders may or may not be displayed in the worksheets, depending on how those worksheets are filtered.

### Member Status

Member Management displays the status of each member, as follows:

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real (item)</td>
<td>Item member that was created by import and that has sales records.</td>
</tr>
<tr>
<td>Real (location)</td>
<td>Location member that was created by import and that has sales records.</td>
</tr>
<tr>
<td>New</td>
<td>Item or location member that was created by import but that does not yet have sales records. When sales data is loaded for this member, it will become real.</td>
</tr>
</tbody>
</table>
User-defined (also called fictive) Item or location member that was created within through the Member Management or Chaining Management tools. When this member is loaded in the import process, it can become new or real, depending on whether it has sales data.

In a typical system, most members are real.

**Starting Member Management**

To start Member Management

Do one of the following:

- Within Oracle Demantra, click Tools > Member Management.
- Within Collaborator Workbench, click Planning Applications > Member Management.

If this tool is not installed on your desktop or there is a newer version available, Oracle Demantra installs or updates the tools on your desktop. You must have the correct permissions. See *Oracle Demantra Implementation Guide*.

**Introduction to the Member Management Tool**

Before you start to use Member Management, it is useful to become familiar with the user interface, which looks like this.
**Displaying Level Members**

**To display the members of a level**

1. In Active Dimension, click either Items or Locations.
   
   The left window of Member Management displays all the levels of that dimension.

2. In the left window, click the level.

3. Optionally filter the display for performance; see Filtering the Members.

4. Click Show Members.

5. The Member Selection pane displays the members of that level and all submembers.

6. In the Member Selection pane, expand the hierarchy as needed.

   For performance reasons, the maximum number of members displayed is preconfigured for your system. To display more members, click the More Members symbol.

   By default, Member Management displays the descriptions of the members. To see the codes instead, select the Show Members Code check box.
Filtering the Members

You can filter the members that Member Management displays, which can make the Member Selection pane display more quickly, and which can make it easier to find a particular member.

Note: If the list of members is currently filtered in any way, the Filter button is colored red as a reminder.

If you switch from the item dimension to the location dimension and then switch back (or vice versa), Member Management remembers any filters you applied in either window.

You can filter by members of any level of any dimension, no matter whether you are view item members or location members.

For example, suppose you are displaying members of an item level. If your filter includes only the Rainbow brand, then at any item level, you will see only items that belong to the Rainbow brand. If your filter includes only the Northeast region, then you will see only items that are sold in that region.

To filter the displayed members, method 1

1. Click Filter.
   The Filter dialog box appears.

2. In the Select Filters From pane, select a level to be filtered.
   The list of members for that level is displayed in the Select Values From pane.

3. Click the members to be included in the Select Values From pane and click the arrow to move them to the Selected Values pane, for example:
4. Click OK to return to Member Management.

5. Click Show Members.

To filter the displayed members, method 2

If you previously applied a filter to the other dimension (which is not currently displayed), you can copy that filter to this dimension. To do so:

1. Click Bring filters from Location's filters or Bring filters from Item's filters, whichever button is currently shown.

   When you do this, Member Management finds the information about the filter you had applied in the other window and copies it to this window. Then Member Management grays out the Bring filters from Location's filters or Bring filters from Item's filters button and displays the Filter button in red to remind you that a filter has been applied. You can click the Filter button and make changes as usual.

2. Click Show Members.

Creating a Member

You can create a member at any level to which you have access.

   **Note:** At the lowest level, you can also create a member by copying an existing member; see Copying a Member.
To create a member

1. Start Member Management, as described in Starting Member Management.

2. Display members of any level that is directly above the level to which you want to add a member. See Displaying Level Members.

3. In the Member Selection pane, right-click a member to which you want to add a child member.

4. Click Add Member. This option is not available for members at the lowest level.

   The Add Member dialog box appears. This dialog box prompts you for information about all parent levels of the new member, as well as any attributes of the member. The following example does not include attributes.

   The parent member that you chose is shown but is grayed out. Other parent members might also be preselected and grayed out, depending on the filters you applied to the display.

5. If you are creating a new SKU, this window also prompts you for unit data, as follows:

   These numbers tell Oracle Demantra how to scale worksheet data when you switch a worksheet to a different unit of measure. The units displayed depend upon your implementation. For each unit of measure, do the following:

   • For this new SKU, consider the item count per unit of measure. For example, if a case contains eight items, the item count is eight. If a truck contains 2000 items, the item count is 2000.

   • Divide one by the item count: 1/8 or 1/2000, for example.

   • Enter that number: 0.125 or 0.0005.

   Oracle Demantra uses this information to scale worksheet values when you choose to display a worksheet in different units. For example, a worksheet displays numbers in terms of item count and you then switch to truckloads, the displayed numbers should be smaller.

   **Note:** If you are not sure what values to use, find a similar item, note the values it uses, and use the same values here.

6. Click OK to continue.

   **Note:** This change is immediate and cannot be canceled.
Creating a Combination

Before you create a combination, you should know which item member and which location member will be in the combination. These members can be at any aggregation level; higher levels generally correspond to a greater number of lowest-level combinations. You will have a chance to see the corresponding lowest-level combinations.

To create a combination

1. Start Member Management, as described in Starting Member Management.

2. Display members of the item or location level, as described in Displaying Level members. You can start with either dimension. For example, display members of the Brand level.

3. Select the member that you are using as the starting point. For this example, click the Rainbow member to select it.

4. If there are other hierarchies within this dimension, select a member within each of them. For example, suppose that the Member selection list includes two hierarchies of locations, as follows (shown collapsed to save space).

   ![Member selection diagram]

   In this case, you need to select a member within the ship to hierarchy and a member within the source warehouse/plant hierarchy.
   
   You do this so that the new combination can be found within both these hierarchies.

5. Click the Link to Location or Link to Item button, whichever button is displayed. For this example, click Link to Location.

   Now Member Management displays the levels of the other dimension (in this case, the locations).

   **Note:** To return to the previous screen, click Back.
6. Display members of the desired level. For example, display members of the Customer Type level.

7. Click the member that you want to combine with previously selected member. For example, click Customer-dc.

8. If there are other hierarchies within this dimension, select a member within each of them, as described earlier in this procedure.

9. Do either of the following:
   • Click Create Combinations. Oracle Demantra prompts you to confirm the action. Click Yes.
   • Click Insert Values. Oracle Demantra prompts you to confirm the action. Click Yes. In this case, Oracle Demantra creates the combinations (if necessary) and inserts placeholder historical data (0 values) into the database. You will then be able to see this combination in worksheets.

   **Note:** Neither option has any effect on existing combinations.

   **Note:** In either case, the change is immediate and cannot be canceled.

10. Continue as follows:
    • To view the lowest-level combinations, click Combination List. See Managing the Lowest-Level Combinations.
    • To go directly to Chaining Management, click Chaining Management. See Chaining Management.

### Creating Placeholder Data

After you create a combination, you can create placeholder data for it so that the combination can be displayed in worksheets (with empty rows). Specifically, the demand and the forecast are set equal to zero for all dates.

This option has no effect if the combination already exists.

**To create a placeholder (zero) data for a combination**

1. Start Member Management, as described in Starting Member Management.

2. Select a combination in the same way that you create a combination; see Creating a Combination.
3. Click the Insert Values button at the bottom of the screen.

   **Note:** This change is immediate and cannot be canceled.

---

**Managing the Lowest-Level Combinations**

*To manage the lowest-level combinations*

1. Start Member Management, as described in Starting Member Management.

2. Click the Combination List button at the bottom of the screen.

   This button is activated only when both the item and location members to be linked have been selected.

3. In the Combination List, all possible hierarchy links are displayed in three tab windows: New Members; Existing Members, and User Defined Members:
4. Do one or more of the following:

   - To create combinations, select one or more combinations and click Create Combinations.
   
     To add the combinations to the database and create zero histories for them, select one or more combinations and click Insert Values.

     **Tip:** To select more than one member combination, press Shift+Click or Ctrl+Click.

   - To go directly to Chaining Management, click Chaining Management.
   
   - To save changes and close Member Management, click OK.
   
   - To close Member Management without saving changes, click Cancel.

**To filter the displayed combinations**
1. Right-click in the Combination List and then select Filter.  
   A Filter dialog box appears.

2. From the respective dropdown lists, select the expressions by which members will be filtered. To add multiple expressions, click Add and then repeat the process.

3. Click OK.

To sort the displayed combinations

1. Right-click in the Combination List and then select Sort.  
   The Sort dialog box appears.

2. Click the required boxes in Columns Available for Sorting, and drag them to Sort Columns. Or double-click the required box in Columns Available for Sorting.
   
   **Note:** This process can be reversed by dragging the boxes in the opposite direction. Or double-click in the Sort Columns list.

   To sort in ascending order, make sure Ascending is checked. To sort in descending order, clear the box.

3. Click OK.

To delete a user-defined combination

You can delete a combination only if it is user-defined.

1. Click one or more user-defined combinations.

2. Right-click and then select Click Delete.

To search the combination list

1. Right-click in the Combination List and then select Find.  
   The Find dialog box appears.

2. Click the dimension to search from the Find Where dropdown list.

3. Enter text to search in the Find What field.

4. Select up or down in the Search dropdown box.

5. Click one or more from the following, if required:
   - Whole Word
6. Click Find Next.

Moving a Member

You can move a member within to a different parent member at the same level; for example, you can move a SKU to a different brand than the original brand. Remember that the next time data is imported, however, the member may be moved back to its original parent. Generally you should move a member only if you anticipate a change in the enterprise systems with which Oracle Demantra is integrated.

To move a member

1. Start Member Management, as described in Starting Member Management.
2. Display members of the level of interest. See Displaying Level Members.
3. Do either of the following:
   • In the Member Selection pane, drag the member to a new parent member.
   • In the Member Selection pane, right-click the member and select Cut Member. Then right-click the desired parent and select Paste Member.
4. Oracle Demantra prompts you to confirm the change. Click OK.
5. Click OK to save the change and close Member Management. Or click Cancel to discard the change and exit Member Management.

Copy a Member

You can copy and paste a member at the lowest level. This creates a user-defined member.

To cut or copy and paste a member

1. Start Member Management, as described in Starting Member Management.
2. Display members of the level of interest. See Displaying Level Members.
3. In the Member Selection pane, right-click the member of interest and then select Copy Member.
4. Right-click the member that should be the parent of the copy and then select Paste Member.
   
   A confirmation message appears.

5. Click Yes to continue.
   
   Oracle Demantra prompts you for a unique code and description for the new member. If this level has attributes, you can specify values for those as well.

6. Complete the fields and click OK.

   **Note:** This change is immediate and cannot be canceled.

See also Moving a Member.

**Renaming a Member**

You can rename any member. Remember that the next time data is imported, however, the member name will be overwritten. Generally you should rename a member only if you anticipate a change in the enterprise systems with which Oracle Demantra is integrated.

**To rename a member**

1. Start Member Management, as described in Starting Member Management.

2. Display members of the level of interest. See Displaying Level Members.

3. Do one of the following in the Member Selection pane:
   
   • Right-click the member and then select Rename. Then type a new name for the member and click Enter.

     **Note:** This change is immediate and cannot be canceled.

   • Right-click the member and then select Modify Member. Oracle Demantra displays the dialog box where you can change both the description (the name) and the code for this member. Make changes and then click OK.

     Then click OK to save the change and close Member Management. Or click Cancel to discard the change and exit Member Management.

See also:

• Moving a Member

• Copying a Member
Deleting a Member

You can delete a member.

To delete a member

1. Start Member Management, as described in Starting Member Management.

2. Display members of the level of interest. See Displaying Level Members.

3. In the Member Selection pane, right-click the member of interest and then select Delete. This option is available only for user-defined members.
   - A confirmation dialog box appears.

4. Click Yes.

5. Click OK to save the change and close Member Management. Or click Cancel to discard the change and exit Member Management.

See also Member Status.
Chaining Management

This chapter covers the following topics:

- Introduction to Chaining
- Opening Chaining Management
- Introduction to the Chaining Management Tool
- Overview of Chaining Options
- Defining a New Chaining Operation
- Performing a Chaining Operation
- Scenario 1: Copying at Lowest Level (No Similarity)
- Scenario 2: New Product (Location Similarity)
- Scenario 3: Merging Two Locations
- Scenario 4: Two New Products
- Scenario 5: Multiple Sources

Introduction to Chaining

Chaining is the process of copying series data from source combinations to target combinations. Typically, you do this after you have created a new member or new combinations, so that Oracle Demantra has data to use when forecasting. While you set up a chaining operation, you specify each series data to copy, a range of dates to copy from, a date to start pasting to, and an optional multiplicative factor for that series. During the chaining operation, Oracle Demantra aggregates the series data and then splits it across the target combinations, according to your choice of split mechanism.

Oracle Demantra saves the details of the chaining operation, which means that you can run the same operation later if needed.
Opening Chaining Management

To open Chaining Management

1. Do one of the following:
   - If Member Management is open, click Chaining Management.
   - Within Oracle Demantra, click Tools > Chaining Management.
   - Within Collaborator Workbench, click Planning Applications > Member Management.

   The Chaining Management window opens.

   If this tool is not installed on your desktop or there is a newer version available, Oracle Demantra installs or updates the tools on your desktop. You must have the correct permissions. See Oracle Demantra Implementation Guide.

2. Click Retrieve Targets. Chaining Management is updated to display all saved chaining operations.

Introduction to the Chaining Management Tool

Before you start to use Chaining Management, it is useful to become familiar with the user interface. After you start it, click Retrieve Targets. The following window is displayed. In the window, each row of the:

   - Target area represents a saves chaining operation
   - Source area represents a source combination for the selected chaining operation
   - Series area represents a series to copy during the selected chaining operation
In this window, you can do the following:

- Define chaining operations.
- View details of each saved chaining operation. When you click a row in the table at the top of the screen, the rest of the window is updated to show details for that operation.
- Edit a saved chaining operation.
- Send chaining operations to be processed in the background. You can rerun chaining operations that were processed earlier.
- View the status of past chaining operations.

**Selecting Combinations**

As you define chaining operations, you need to select combinations for the target and the source(s). To do so, you use a window that looks very much like the Member Management tool. The general technique is described here, for reference. In this example, we will select the combination Item A at Store 99.

**To select a combination**

1. Display members of the item or location level, as described in Displaying Level Members. You can start with either dimension. For example, display members of the SKU level.
2. Click the member that you are using as the starting point. For this example, click the Item A member.

3. Click the Link to Location or Link to Item button, whichever button is displayed. For this example, click Link to Location.

Now Member Management displays the levels of the other dimension (in this case, the locations).

**Note:** To return to the previous screen and double-check your selection, click Back.

4. Display members of the desired level. For example, display members of the Ship To level.

5. Click the member that constitutes the "other part" of the combination. For example, click Store 99.

6. Optionally filter the combinations as described below. (In this example, filtering does not make sense, because we have selected a single lowest-level combination.)

7. Click Chaining Management to select this combination and return to the Chaining Management user interface.

### Filtering the Selected Combinations

You can filter the lowest-level combinations that you select.

**Note:** If the list of members is currently filtered in any way, the Filter button is colored red as a reminder.

**To filter the combinations**

1. Click Filter.

   The Filter dialog box appears.

2. In the Select Filters From pane, select a level to be filtered.

   The list of members for that level is displayed in the Select Values From pane.

3. Click the members to be included in the Select Values From pane and click the arrow to move them to the Selected Values pane.

4. Click OK.

5. Click Show Members.
Note: There is another way to filter the combinations. If you had previously applied a filter when viewing the other dimension, you can copy that filter to this dimension. To do so, click Bring filters from Location’s filters or Bring filters from Item’s filters, whichever button is currently shown.

Double-checking the Combination

You can view the existing lowest-level source or target combinations for any chaining operation.

To view the existing lowest-level combinations

1. Right-click in the Target area or the Source area and then select All Combinations.

   Note: If this option is not available, save your work, exit Chaining Management and then reopen it.

Chaining Management displays a window like the following:
This window lists all the lowest-level combinations that currently exist. It does not show you any combinations that the chaining operation itself would create.

2. To close the window, click OK.

3. If you need to make changes, do the following:
   - Right-click in the Target area or the Source area and then select Combination List-Item. Oracle Demantra displays a dialog box that lists all the items that you have selected. Specify the items to include and click OK.
   - Right-click in the Target area or the Source area and then select Combination List-Location. Oracle Demantra displays a dialog box that lists all the locations that you have selected. Specify the locations to include and click OK.
   - Double-check the combinations as described in Step 1, if needed.
Overview of Chaining Options

This section provides an overview of the chaining options and explains how they are related to one another.

Target and Source

The Target, Population, and Source options are related to each other; when you set any of these options, you must consider how you have set the other ones. There are essentially three general configurations of these settings that are useful:

- One configuration is for item similarity. Here the source and target combinations both contain the same item member(s), at the lowest level. For example, store 99 sells 1500 items. You have created store 100, which will sell the same 1500 items. In this case, Oracle Demantra automatically creates the implied combinations, if they do not yet exist; you do not need to create those combinations first in Member Management.

- Another configuration is for location similarity. Here the source and target combinations both contain the same location member(s), at the lowest level. For example, item A is sold in region 5, which has ten stores. You want to introduce item B into this region, where it has not been sold previously. In this case, Oracle Demantra automatically creates the implied combinations, if they do not yet exist.

- Another configuration is for dissimilar sources and targets. Here the source and target combinations contain different item and location member(s). In these cases, Chaining Management does not create any combinations; the target combinations must already exist.

The following table summarizes the settings to use for each configuration.

In the table:

- * indicates that this member can be at any aggregation level and can be filtered.

- ** indicates that chaining management ignores any dead source combinations...
<table>
<thead>
<tr>
<th>Case</th>
<th>Settings to use Target Members sku</th>
<th>Settings to use Target membership ship to</th>
<th>Settings to use Population item</th>
<th>Settings to use Population location</th>
<th>Settings to use Source** ship to</th>
<th>Settings to use Source** sku</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item similarity</td>
<td>All</td>
<td>A specific location*</td>
<td>Source</td>
<td>Target</td>
<td>All (In this context, this means all SKUs associated with the source location)</td>
<td>A specific location*, different from the target</td>
</tr>
<tr>
<td>Location similarity</td>
<td>A specific item*</td>
<td>All</td>
<td>Target</td>
<td>Source</td>
<td>A specific item*, different from the target</td>
<td>All (in this context, this means all ship-to’s associated with the source item)</td>
</tr>
<tr>
<td>No similarity</td>
<td>A specific item*</td>
<td>A specific location*</td>
<td>Target</td>
<td>Target</td>
<td>A specific item*, different from the target</td>
<td>A specific location*, different from the target</td>
</tr>
</tbody>
</table>

**Aggregation and Splitting**

For each series (and for each time period), Oracle Demantra aggregates the data from all the source combinations and then splits the value across the target combinations.

**Note:** For each series, you also have the option not to split the aggregated value at all. Instead, you can paste the aggregated value to each target combination.

**Splitting Across Both Items and Locations**

You specify how to split data across items and how to split data across locations. The resulting split proportions are multiplied for each combination. This is best shown by an example.

Suppose that you have four target combinations:
• Item 1 at Store A
• Item 2 at Store A
• Item 1 at Store Z
• Item 2 at Store Z

Now suppose you have specified the following split proportions for the items:

<table>
<thead>
<tr>
<th>Item</th>
<th>Proportion</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>0.6</td>
</tr>
<tr>
<td>Item 2</td>
<td>0.4</td>
</tr>
</tbody>
</table>

Also suppose that you have specified the following split proportions for the locations:

<table>
<thead>
<tr>
<th>Item</th>
<th>Proportion</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store A</td>
<td>0.75</td>
</tr>
<tr>
<td>Store Z</td>
<td>0.25</td>
</tr>
</tbody>
</table>

As a result, the overall proportions for each combination would be as follows:

<table>
<thead>
<tr>
<th>Combination</th>
<th>Proportion</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1 at Store A</td>
<td>0.6 * 0.75 = 0.45</td>
</tr>
<tr>
<td>Item 2 at Store A</td>
<td>0.4 * 0.75 = 0.3</td>
</tr>
<tr>
<td>Item 1 at Store Z</td>
<td>0.6 * 0.25 = 0.15</td>
</tr>
<tr>
<td>Item 2 at Store Z</td>
<td>0.4 * 0.25 = 0.1</td>
</tr>
</tbody>
</table>

**Available Split Options**

Within Chaining Management, you do not actually specify the proportions directly as percentages as in the preceding examples. Instead, you have the following options:

• Target proportions: Use the stored proportions of the existing targets. (This option
applies only when all the specified target combinations already exist.)

**Note:** Stored proportions reflect the relative volume of sales of the different combinations. Oracle Demantra calculates this information automatically.

- Equal proportions: Split the values equally between all lowest level targets. This option is suitable if you have no information about how to split across this dimension.

- Source proportions: Match each target combination to a source combination. Then for each target, use the proportions of the corresponding source.

- Similar proportions: Choose a third set of combinations to use as a reference, and match each target combination to a reference combination. Then for each target, use the proportions of the reference source.

  **Note:** If there are no valid combinations in the target, the chaining will not work and an error message appears. That is, Oracle Demantra must be able to find a reference combination to use for each target combination.

**Series Manipulation and Other Chaining Options**

Within a chaining operation, you can copy data for multiple series. For each series that you copy, you can specify the following:

- Series to paste data into (often but not always the same as the copied series)

- Factor to multiply data before pasting

- Option to paste the same aggregated data to each combination rather than splitting it.

You also specify a range of dates in the source data; Oracle Demantra selects series data in that span of time. And you specify a starting date in the target, where Oracle Demantra starts pasting the selected series.

**Defining a New Chaining Operation**

**Step 1: Specifying the Target**

In this step, you specify the Target Members and Population fields.
To specify the target

1. Start Chaining Management, as described in Opening Chaining Management.

2. In the Name column of the new row, enter a unique name for this chaining operation.

3. Double-click in SKU or Ship to column of the new row.
   Oracle Demantra displays a window where you select a target combination, at any aggregation level.

4. Select a combination, as described in Selecting Combinations. As you do so, optionally apply a filter, if needed.

5. If there is a similarity between target and source, choose source for either Population/Item column or Population/Location column.
   The following table summarizes the settings to use here.
   In the table, * indicates that this member can be at any aggregation level and can be filtered.

<table>
<thead>
<tr>
<th>Case</th>
<th>Target Members SKU</th>
<th>Target Members Ship to</th>
<th>Population item</th>
<th>Population Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item similarity</td>
<td>All</td>
<td>A specific location*</td>
<td>Source</td>
<td>Target</td>
</tr>
<tr>
<td>Location similarity</td>
<td>A specific item*</td>
<td>All</td>
<td>Target</td>
<td>Source</td>
</tr>
<tr>
<td>No similarity</td>
<td>A specific item*</td>
<td>A specific location*</td>
<td>Target</td>
<td>Target</td>
</tr>
</tbody>
</table>

See also Target and Source.

Step 2: Specifying the Sources

You must specify at least one source combination for each chaining operation. You can choose a source at any aggregation level, and you can choose multiple sources. Typically you choose sources that have a demand history that is similar to the target.

To specify a source

1. Right-click in the Source area and then select Insert.
A new row appears in the source area.

2. Double-click in the new row.

Oracle Demantra displays a window where you select a source combination, at any aggregation level.

3. Select a combination, as described in Selecting Combinations. As you do so, optionally apply a filter, if needed.

If there is a similarity between target and source, make sure to choose source combinations that can be matched to the target combinations. The following table summarizes the settings to use here.

In the table:
- * indicates that this member can be at any aggregation level and can be filtered.
- ** indicates that Chaining Management ignores any dead source combinations.

<table>
<thead>
<tr>
<th>Case</th>
<th>Source** SKU</th>
<th>Source** Ship to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item similarity</td>
<td>All (in this context, this means all SKUs associated with the source location)</td>
<td>A specific location*, different from the target location</td>
</tr>
<tr>
<td>Location similarity</td>
<td>A specific item*, different from the target</td>
<td>All (in this context, this means all ship-to's associated with the source item)</td>
</tr>
<tr>
<td>No similarity</td>
<td>A specific item*, different from the target</td>
<td>A specific location*, different from the target</td>
</tr>
</tbody>
</table>

See also Target and Source.

**Step 3: Specifying How to Split Across Target Combinations**

For each series, the data is aggregated across all the source combinations and is then split to the target combinations as specified within the chaining operation. In the Proportions columns, you determine how the split is performed for the items and for the locations. The available split styles are.
### Setting | Meaning
---|---
Target | Use the stored proportions of the existing targets. (This option applies only when all the specified target combinations already exist.)
Equal | Split the values equally between all lowest level targets. This option is suitable if you have no information about how to split across this dimension.
Source | Match each target combination to a source combination. Then for each target, use the proportions of the corresponding source.
Similar | Choose a third set of combinations to use as a reference, and match each target combination to a reference combination. Then for each target, use the proportions of the reference source.

### To specify chaining proportions
1. In the Proportions/Item column, click and select a split style.

   ![Proportions/Item column](image)

   If you clicked Similar, then the Similar Location for Item tab is enabled (in the Source area). Now Oracle Demantra needs a set of reference combinations that contain the same items as the target combinations. To specify these reference combinations, you select another location where the target items are sold.

   - Click the Similar Location for Item tab.
   - Double-click the empty field in this tab. Oracle Demantra displays a window where you select a location at any level.
   - Select a location member as usual.

   **Note:** In this case, you cannot apply a filter when you select the
member.

- Click Chaining Management to accept your selection and return to Chaining Management.

2. In the Proportions/Location column, click and select a split style.

If you clicked Similar, then the Similar Item for Location tab is enabled. Now Oracle Demantra needs a set of reference combinations that contain the same locations as the target combinations. To specify these reference combinations, you select another item that is sold at the same locations as the target items. The steps are similar to the preceding.

**Note:** These options are ignored if you select the Same Value for All Members check box; see Step 5: Specifying the Series to Copy.

### Step 4: Specifying Chaining Dates

For each source, you specify a range of source dates, as well as a date to start pasting. For the source dates, you specify a start date and either an end date or a number of base time buckets.

<table>
<thead>
<tr>
<th>Source</th>
<th>Similar Item for Location</th>
<th>Similar Item for Item</th>
<th>From Date</th>
<th>To Date</th>
<th>Start At</th>
</tr>
</thead>
<tbody>
<tr>
<td>private label chocolate chip</td>
<td>stop and shop store</td>
<td>01/01</td>
<td>03/01</td>
<td>10/01</td>
<td></td>
</tr>
<tr>
<td>private label shortbread</td>
<td>stop and shop store</td>
<td>02/01</td>
<td>04/01</td>
<td>11/01</td>
<td></td>
</tr>
</tbody>
</table>

**To specify the chaining dates**

1. For each row in the Source area, specify the following:

   - **From Date**: Starting date for the source data. (To use a calendar, click the Calendar button.)
   - **Length**: The number of base time buckets for which to copy series data.
   - **To Date**: Ending date for the source data.
   - **Start At**: Date at which to start pasting series data from this source.
Step 5: Specifying the Series to Copy

The Series area of the screen lists the series whose data will be copied during this chaining operation. Note that when you copy data from one series, you can paste into a different series. You can also specify a scaling factor.

To specify the series to copy

For each series whose data you want to copy during this operation, do the following:

1. Right-click in the Series area and then select Insert.
   
   A new row appears.

2. For Source, select the series from which you want to copy data.

3. For Target, select the series into which you want to paste this data.

4. For Factor, optionally specify a factor to multiply this data by before pasting it.

5. If you want to paste the same aggregated data to each target combination rather than splitting it across the combinations, select the Same Value for All Members check box.

   **Note:** If you choose this option, your choices for item and location proportions are ignored.

Step 6: Enabling Partial Chaining Indicators (Optional)

If you have specified item similarity or location similarity, then Oracle Demantra matches up each target combination with one or more corresponding source combinations (depending on the number of chaining sources you choose). However, if the source combinations do not have sales for some or all dates, the chaining operation might be considered incomplete.

To alert yourself of such cases, you might want to enable some or all of the partial chaining indicators, which are internal flags that mark the combinations and dates for which the last chaining operation was incomplete. These indicators are used in different ways depending on the implementation. They are most commonly used as levels, which then group the combinations so that you can readily see which ones require further work.

There are two general types of partial chaining, with subtypes:

- All sources are missing. This occurs when there are issues with all the source combinations. That is, none of the source combinations has data for all the dates. For all the source combinations, the data is either completely missing (no data for...
any dates) or just partially missing (data for only some dates).

- Some sources are missing. This occurs when there are issues with some source combinations. For some of the source combinations, the data is either completely missing (no data for any dates) or just partially missing (data for only some dates). Some of the source combinations, however, do have data for all dates.

Check with your implementor or your system administrator to understand whether your system is set up to take advantage of the partial chaining indicators. If it is, when you define a chaining operation, be sure to enable the indicators for that operation.

**To enable partial chaining indicators**

1. In the Target area of the chaining manager, scroll to the right, to see the following columns:

```
<table>
<thead>
<tr>
<th>Chaining Management</th>
<th>Target</th>
<th>Missing Some Sources - All Dates</th>
<th>Missing Some Sources - Date by Date</th>
<th>Missing All Sources - All Dates</th>
<th>Missing All Sources - Date by Date</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

This area lists four possible indicators; you can enable any or all of them.

2. To enable a partial chaining indicator, select a data column from the dropdown list. The chaining operation will write that type of chaining indicator into the internal data column, in the row for a given target combination, if there is a mismatch between target and source.

Oracle Demantra provides default columns that you can use to store partial chaining indicators. Typically, for any given indicator, you specify the data column that has the same name as the indicator, as follows:

```
<table>
<thead>
<tr>
<th>Chaining Management</th>
<th>Target</th>
<th>Missing Some Sources - All Dates</th>
<th>Missing Some Sources - Date by Date</th>
<th>Missing All Sources - All Dates</th>
<th>Missing All Sources - Date by Date</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

See also Target and Source.

**Final Step: Saving the Chaining Operation**

**To save a chaining operation**

1. Make sure that you have given the chaining operation a good name.

2. Optionally add a description, in the Description column in the far right of the target area.
3. Click Save at the bottom of the screen.

See also Performing a Chaining Operation.

**Performing a Chaining Operation**

You can perform any saved chaining operation. The chaining operation overwrites any existing data for the target combinations, for the chained dates.

**Note:** In order for chaining to occur, the Chaining procedure must be running periodically (a few times a minute).

**To perform a chaining operation**

1. Click Tools > Chaining Management.
   
The Chaining Management window opens.

2. Click Retrieve Targets. Chaining Management is updated to display all past chaining operations.

3. Click the chaining operation that you want to perform.

4. Click Chain.
   
   Oracle Demantra displays a dialog box that summarizes your selections.

5. Click OK.

6. Scroll to the middle of the target area of the screen, to the Process Status column. This column shows the status of each chaining operation.

   The status is one of the following:
Scenario 1: Copying at Lowest Level (No Similarity)

In this scenario, we copy data for one combination at the lowest level and we paste into a user-defined combination, also at the lowest level. This is not a common scenario but is a useful exercise to try.

Example Data

Suppose that SKU 009 is sold in Wal-Mart 001. This combination has the following sales (shown here by quarter):

<table>
<thead>
<tr>
<th>Time</th>
<th>Pseudo</th>
<th>Demand</th>
<th>Base Frct</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/23/2001</td>
<td></td>
<td>34,000</td>
<td>33,952</td>
</tr>
<tr>
<td>07/23/2001</td>
<td></td>
<td>61,200</td>
<td>62,767</td>
</tr>
<tr>
<td>10/22/2001</td>
<td></td>
<td>24,500</td>
<td>28,631</td>
</tr>
<tr>
<td>01/21/2002</td>
<td></td>
<td>0</td>
<td>7,165</td>
</tr>
<tr>
<td>04/22/2002</td>
<td></td>
<td>0</td>
<td>414</td>
</tr>
<tr>
<td>07/22/2002</td>
<td></td>
<td>0</td>
<td>415</td>
</tr>
<tr>
<td>10/21/2002</td>
<td></td>
<td>0</td>
<td>176</td>
</tr>
<tr>
<td>01/20/2003</td>
<td></td>
<td>0</td>
<td>1,179</td>
</tr>
<tr>
<td>04/21/2003</td>
<td></td>
<td>0</td>
<td>3,538</td>
</tr>
<tr>
<td>07/21/2003</td>
<td></td>
<td>0</td>
<td>1,937</td>
</tr>
<tr>
<td>10/20/2003</td>
<td></td>
<td>0</td>
<td>593</td>
</tr>
<tr>
<td>Summary</td>
<td></td>
<td>119,700</td>
<td>140,967</td>
</tr>
</tbody>
</table>

Suppose that we have already used Member Management to create a new item called
SKU 999, and then to create a combination for SKU 999 at Wal-Mart 001.

**The Chaining Operation**

We would like to copy the forecast for SKU 009 and Wal-Mart 011 and use that data as Pseudo for SKU 999 at Wal-Mart 011. We would like to shift the dates, however, by a year.

To copy this data, we set up this chaining operation.

**Target - Members**

<table>
<thead>
<tr>
<th>Member</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>SKU</td>
<td>SKU 999</td>
<td>We have already created this combination in Member Management.</td>
</tr>
<tr>
<td>Ship to</td>
<td>Wal-Mart Store 001</td>
<td>-</td>
</tr>
</tbody>
</table>

**Target - Populations**

<table>
<thead>
<tr>
<th>Member</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td>Target</td>
<td>-</td>
</tr>
<tr>
<td>Location</td>
<td>Source</td>
<td>-</td>
</tr>
</tbody>
</table>

**Target - Proportions**

<table>
<thead>
<tr>
<th>Member</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td>Source</td>
<td>Because there is no sales data yet for the target combination, we cannot use target proportions. However, the proportions do not actually matter, because we are working at the lowest level.</td>
</tr>
</tbody>
</table>
Because there is no sales data yet for the target combination, we cannot use target proportions. However, the proportions do not actually matter, because we are working at the lowest level.

### Source

<table>
<thead>
<tr>
<th>Member or Date</th>
<th>Value</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>SKU</td>
<td>SKU 009</td>
<td></td>
</tr>
<tr>
<td>Ship to</td>
<td>Wal-Mart store 001</td>
<td></td>
</tr>
<tr>
<td>From Date</td>
<td>04/23/01</td>
<td></td>
</tr>
<tr>
<td>To Date</td>
<td>01/05/04</td>
<td></td>
</tr>
<tr>
<td>Start At</td>
<td>04/22/02</td>
<td>This is the date into which we will start copying the requested data. This is approximately a year after the chosen starting date.</td>
</tr>
</tbody>
</table>

### Series

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target</td>
<td>Pseudo</td>
<td>These options copy data for the Base Frct series (for the chosen source), multiply that data by a factor of 1, and then paste the results into the Pseudo series (for the target), shifting the dates as described above.</td>
</tr>
</tbody>
</table>
Setting | Value | Notes
--- | --- | ---
Source | Base Frcst | These options copy data for the Base Frcst series (for the chosen source), multiply that data by a factor of 1, and then paste the results into the Pseudo series (for the target) with shifting the dates.
Factor | 100% | These options copy data for the Base Frcst series (for the chosen source), multiply that data by a factor of 1, and then paste the results into the Pseudo series (for the target) with shifting the dates.

Result

After Oracle Demantra performs the chaining operation, SKU 999 at Wal-Mart 001 has the following data:

<table>
<thead>
<tr>
<th>Time</th>
<th>Pseudo</th>
<th>Demand</th>
<th>Base Frcst</th>
</tr>
</thead>
<tbody>
<tr>
<td>04/23/2001</td>
<td></td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>07/23/2001</td>
<td></td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>10/22/2001</td>
<td></td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>01/21/2002</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>04/22/2002</td>
<td>33,652</td>
<td></td>
<td>33,652</td>
</tr>
<tr>
<td>07/22/2002</td>
<td>62,767</td>
<td></td>
<td>62,767</td>
</tr>
<tr>
<td>10/21/2002</td>
<td>28,631</td>
<td></td>
<td>28,631</td>
</tr>
<tr>
<td>01/20/2003</td>
<td>7,081</td>
<td></td>
<td>7,081</td>
</tr>
<tr>
<td>04/21/2003</td>
<td></td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>07/21/2003</td>
<td></td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>10/20/2003</td>
<td></td>
<td></td>
<td>0</td>
</tr>
<tr>
<td>Summary</td>
<td>132,631</td>
<td>132,630</td>
<td>D</td>
</tr>
</tbody>
</table>

Note that Oracle Demantra does not paste data into Pseudo after 01/20/03; this is because Pseudo is editable only in the history. Also, the value for 01/20/03 is slightly different from the corresponding value in the source because we are viewing data by quarter. If we viewed data at the lowest level (by week), the numbers would be identical.
Scenario 2: New Product (Location Similarity)

We want to introduce a new item to the market. We want this item to be sold in all locations where an existing item is sold, with the same sales data, multiplied by one half and shifted ahead by one year.

Example Data

The item Chocolate Ice Cream is sold in three stores. For example, the demand for this item for the quarter Q1 2003 is as follows:

<table>
<thead>
<tr>
<th>Store</th>
<th>Demand</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store A</td>
<td>1000</td>
</tr>
<tr>
<td>Store B</td>
<td>2000</td>
</tr>
<tr>
<td>Store C</td>
<td>3000</td>
</tr>
</tbody>
</table>

Suppose we just used Member Management to create a new item called Double Chocolate Ice Cream. It will be sold in the same stores as Chocolate Ice Cream, and we believe its sales will be the same.

Also, in Member Management, we created the new item (Double Chocolate Ice Cream), but we did not create any combinations for it.

The Chaining Operation

We would like Double Chocolate Ice Cream to be in combinations with all the same stores as Chocolate Ice Cream. For those combinations, we would like the Oracle Demantra database to contain the same demand data, multiplied by 50% and shifted by a year.

To create the combinations and copy this data, we use the following chaining operation:

Target - Members

<table>
<thead>
<tr>
<th>Option In Chaining Management</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>SKU</td>
<td>Double Chocolate Ice Cream</td>
<td>-</td>
</tr>
<tr>
<td>Ship to</td>
<td>All</td>
<td>-</td>
</tr>
</tbody>
</table>
### Target - Populations

<table>
<thead>
<tr>
<th>Member</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td>Target</td>
<td>-</td>
</tr>
<tr>
<td>Location</td>
<td>Source</td>
<td>-</td>
</tr>
</tbody>
</table>

### Target - Proportions

<table>
<thead>
<tr>
<th>Member</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td>Source</td>
<td>-</td>
</tr>
<tr>
<td>Location</td>
<td>Source</td>
<td>-</td>
</tr>
</tbody>
</table>

### Source

<table>
<thead>
<tr>
<th>Member or Date</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>SKU</td>
<td>Chocolate Ice Cream</td>
<td>-</td>
</tr>
<tr>
<td>Ship to</td>
<td>All</td>
<td>-</td>
</tr>
<tr>
<td>From Date</td>
<td>04/23/01</td>
<td>-</td>
</tr>
<tr>
<td>To Date</td>
<td>01/05/04</td>
<td>-</td>
</tr>
<tr>
<td>Start At</td>
<td>04/22/02</td>
<td>This is the date into which we will start copying the requested data. This is approximately a year after the chosen starting date.</td>
</tr>
</tbody>
</table>

### Series
Setting | Value | Notes
---|---|---
Target | Pseudo | These options copy data for the Base Frcst series (for the chosen source), multiply that data by a factor of 1, and then paste the results into the Pseudo series (for the target) with shifting the dates.

Source | Base Frcst | These options copy data for the Base Frcst series (for the chosen source), multiply that data by a factor of 1, and then paste the results into the Pseudo series (for the target) with shifting the dates.

Factor | 50% | These options copy data for the Base Frcst series (for the chosen source), multiply that data by a factor of 1, and then paste the results into the Pseudo series (for the target), shifting the dates as described above.

**Result**

The Oracle Demantra database now includes the following combinations:

- Double Chocolate Ice Cream at Store A
- Double Chocolate Ice Cream at Store B
- Double Chocolate Ice Cream at Store C

 Also, the database contains data for these combinations. For example, the data includes these values for Pseudo for the quarter Q1:

<table>
<thead>
<tr>
<th>Store</th>
<th>Pseudo</th>
</tr>
</thead>
<tbody>
<tr>
<td>Store A</td>
<td>500</td>
</tr>
</tbody>
</table>
Scenario 3: Merging Two Locations

We have one store in east Manhattan, and one store on the west side of Manhattan. We decided to close down the East location and sell its entire items in the West location (merge two locations into one of them). We expect no change in the total sales of each product.

<table>
<thead>
<tr>
<th>Population Item</th>
<th>Population Location</th>
<th>Proportion Item</th>
<th>Proportion Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source</td>
<td>Target</td>
<td>Source</td>
<td>Target</td>
</tr>
</tbody>
</table>

Before Chaining

<table>
<thead>
<tr>
<th>Source Store East Item</th>
<th>Source Store East Loc</th>
<th>Source Store West Item</th>
<th>Source Store West Loc</th>
<th>Source Store West Quan</th>
<th>Target Store West Item</th>
<th>Target Store West Loc</th>
<th>Target Store West Quan</th>
</tr>
</thead>
<tbody>
<tr>
<td>I1</td>
<td>L1</td>
<td>10</td>
<td>I2</td>
<td>L2</td>
<td>20</td>
<td>I2</td>
<td>L2</td>
</tr>
<tr>
<td>I2</td>
<td>L1</td>
<td>20</td>
<td>I4</td>
<td>L2</td>
<td>40</td>
<td>I4</td>
<td>L2</td>
</tr>
<tr>
<td>I3</td>
<td>L1</td>
<td>30</td>
<td>I3</td>
<td>L2</td>
<td>20</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

After Chaining

<table>
<thead>
<tr>
<th>Target Store West Item</th>
<th>Target Store West Location</th>
<th>Target Store West</th>
</tr>
</thead>
<tbody>
<tr>
<td>I1</td>
<td>L2</td>
<td>10</td>
</tr>
<tr>
<td>I2</td>
<td>L2</td>
<td>20</td>
</tr>
</tbody>
</table>
Scenario 4: Two New Products

We want to introduce a new item to the market. This item has two versions, 'Classic' and 'light'. We want these items to be sold in all locations where an existing item is sold, and we expect these two versions to have similar sales (all together) as existing product.

- I1: Existing product, G2: hierarchy level of I21; I22
- I21;I22: New products (Classic and Light were never chained)
- East coast: L1, L2, L3

Before Chaining

<table>
<thead>
<tr>
<th>Source I1 Item</th>
<th>Source I1 Location</th>
<th>Source I1 Quantity</th>
<th>Target G2 Item</th>
<th>Target G2 Location</th>
<th>Target G2 Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>I1</td>
<td>L1</td>
<td>10</td>
<td>I21</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>
### Source I1 Item  Source I1 Location  Source I1 Quantity  Target G2 Item  Target G2 Location  Target G2 Quantity

<table>
<thead>
<tr>
<th>Item</th>
<th>Location</th>
<th>Quantity</th>
<th>Item</th>
<th>Location</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>I1</td>
<td>L2</td>
<td>20</td>
<td>I22</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>I1</td>
<td>L3</td>
<td>30</td>
<td>-</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

### Target G2 Item  Target G2 Location  Target G2 Quantity

<table>
<thead>
<tr>
<th>Item</th>
<th>Location</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>I21</td>
<td>L1</td>
<td>5</td>
</tr>
<tr>
<td>I21</td>
<td>L2</td>
<td>10</td>
</tr>
<tr>
<td>I21</td>
<td>L3</td>
<td>15</td>
</tr>
<tr>
<td>I22</td>
<td>L1</td>
<td>5</td>
</tr>
<tr>
<td>I22</td>
<td>L2</td>
<td>10</td>
</tr>
<tr>
<td>I22</td>
<td>L3</td>
<td>15</td>
</tr>
</tbody>
</table>

### After Chaining

Each of the new products should be sold in all source locations. Sales data of each source product-location now needs to be split between two products.

The split mechanism for ‘non-low level’ member will be ‘equal’. In case of integer data type and non-integer results when splitting equally (for example, sales: 15, needs to be split between two items), the same mechanism currently being used in ‘Manual update’ of aggregated level query, should be applied here.

### Scenario 5: Multiple Sources

The data from two source items is split with multiple series.

A company is about to introduce Product Z to Saver-Store. Product Z is equivalent to 3 X Product A and 1 X Product B in a different package, but with a price of just 2 X A and 1 X B. Soon after the introduction, the company will execute a campaign with a large nationwide supermarket chain; it will be the same type of campaign as with product A.

The user selects Product Z and Saver-Store as the target. For the sources, the user selects Product A and Product B with Saver-Store as the location.
<table>
<thead>
<tr>
<th>Sources Item</th>
<th>Sources Location</th>
<th>Sources From Series</th>
<th>To Series</th>
<th>Factor %</th>
<th>Target Item</th>
<th>Target Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Saver-Store</td>
<td>Demand</td>
<td>Pseudo</td>
<td>300</td>
<td>Z</td>
<td>Saver-Store</td>
</tr>
<tr>
<td>A</td>
<td>Saver-Store</td>
<td>Price</td>
<td>Price</td>
<td>200</td>
<td>Z</td>
<td>Saver-Store</td>
</tr>
<tr>
<td>A</td>
<td>Saver-Store</td>
<td>Discount</td>
<td>Discount</td>
<td>100</td>
<td>Z</td>
<td>Saver-Store</td>
</tr>
<tr>
<td>A</td>
<td>Saver-Store</td>
<td>Event</td>
<td>Event</td>
<td>100</td>
<td>Z</td>
<td>Saver-Store</td>
</tr>
<tr>
<td>B</td>
<td>Saver-Store</td>
<td>Demand</td>
<td>Pseudo</td>
<td>100</td>
<td>Z</td>
<td>Saver-Store</td>
</tr>
<tr>
<td>B</td>
<td>Saver-Store</td>
<td>Price</td>
<td>Price</td>
<td>100</td>
<td>Z</td>
<td>Saver-Store</td>
</tr>
<tr>
<td>B</td>
<td>Saver-Store</td>
<td>Discount</td>
<td>Discount</td>
<td>100</td>
<td>Z</td>
<td>Saver-Store</td>
</tr>
</tbody>
</table>
This chapter covers the following topics:

- Oracle Demantra URLs
- Keyboard Shortcuts

**Oracle Demantra URLs**

You can use a web browser to access or to directly login to most Oracle Demantra functions.

If you need to use this method, your system administrator will tell you the uniform resource locators (URLs) that you need to use.

For a list of these functions, see the Oracle Demantra Implementation Guide.

**Keyboard Shortcuts**

**Editing**

<table>
<thead>
<tr>
<th>Keyboard Combination</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+c</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl+v</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl+x</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl+z</td>
<td>Undo</td>
</tr>
<tr>
<td>Ctrl+y</td>
<td>Redo</td>
</tr>
</tbody>
</table>

**Menu Access**
<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Menu or Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+f</td>
<td>Open File menu</td>
</tr>
<tr>
<td>Alt+w</td>
<td>Open the Worksheet menu</td>
</tr>
<tr>
<td>Alt+e</td>
<td>Open Edit menu</td>
</tr>
<tr>
<td>Alt+v</td>
<td>Open View menu</td>
</tr>
<tr>
<td>Alt+o</td>
<td>Open Options menu</td>
</tr>
<tr>
<td>Alt+d</td>
<td>Open Data menu</td>
</tr>
</tbody>
</table>

**Display**

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+Shift+r</td>
<td>Reset table sort</td>
</tr>
<tr>
<td>Ctrl+Alt+m</td>
<td>Show or hide the Members Browser</td>
</tr>
<tr>
<td>Ctrl+Alt+r</td>
<td>Show or hide the table</td>
</tr>
<tr>
<td>Ctrl+Alt+g</td>
<td>Show or hide the graph</td>
</tr>
<tr>
<td>Ctrl+Alt+a</td>
<td>Show or hide the Activity Browser and chart</td>
</tr>
<tr>
<td>Ctrl+Alt+t</td>
<td>Show or hide the time axis</td>
</tr>
<tr>
<td>F5</td>
<td>Refresh data</td>
</tr>
</tbody>
</table>

**Worksheets**

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+s</td>
<td>Save worksheet definition</td>
</tr>
<tr>
<td>Ctrl+n</td>
<td>New worksheet</td>
</tr>
<tr>
<td>Ctrl+o</td>
<td>Open worksheet</td>
</tr>
<tr>
<td>Ctrl+r</td>
<td>Run worksheet</td>
</tr>
<tr>
<td>Ctrl+u</td>
<td>Save data changes</td>
</tr>
<tr>
<td>Shortcuts</td>
<td>Functions</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------</td>
</tr>
<tr>
<td>Ctrl+p</td>
<td>Print</td>
</tr>
<tr>
<td>Ctrl+e</td>
<td>Export to Microsoft Excel</td>
</tr>
<tr>
<td>Alt+1</td>
<td>Open the general properties of the Worksheet Designer</td>
</tr>
<tr>
<td>Alt+2</td>
<td>Open the series part of Worksheet Designer</td>
</tr>
<tr>
<td>Alt+3</td>
<td>Open the time criteria part of the Worksheet Designer</td>
</tr>
<tr>
<td>Alt+4</td>
<td>Open the levels part of the Worksheet Designer</td>
</tr>
<tr>
<td>Alt+5</td>
<td>Open the filters part of the Worksheet Designer</td>
</tr>
<tr>
<td>Alt+6</td>
<td>Open the exceptions part of the Worksheet Designer</td>
</tr>
<tr>
<td>Alt+7</td>
<td>Open the layout part of the Worksheet Designer</td>
</tr>
</tbody>
</table>
This chapter covers the following topics:

- Product Features Overview
- Oracle Demantra Demand Management
- Oracle Demantra Advanced Forecasting and Demand Modeling
- Oracle Demantra Real-time Sales and Operations Planning
- Oracle Demantra Predictive Trade Planning
- Oracle Demantra Trade Promotion Optimization
- Oracle Demantra Deductions and Settlement Management

**Product Features Overview**

The Oracle Demantra applications suite contains these products:

- Oracle Demantra Demand Management
- Oracle Demantra Advanced Forecasting and Demand Modeling
- Oracle Demantra Real-time Sales and Operations Planning
- Oracle Demantra Predictive Trade Planning
- Oracle Demantra Trade Promotion Optimization
- Oracle Demantra Deductions and Settlement Management

For detailed information and business examples about the features and functions, see the Oracle Demantra documentation for each product.
Oracle Demantra Demand Management enables an organization to accurately forecast and plan for demand. It uses state-of-the-art Bayesian Markov forecasting, as well as pre-seeded hierarchies, worksheets, and workflows to establish a baseline forecast based on a combination of quantitative or qualitative data. Demand Management offers unlimited hierarchies for multi-dimensional analysis with dynamic reporting capabilities.

**Reporting And Analysis Features**

Predefined Demand Management worksheets:

- Compare and analyze sales history and forecast demand
- Aggregate data in various ways to determine forecast accuracy of previous sales cycles
- Manage and approve demand forecasts

Standard and predefined:

- Hierarchies (levels): Used in worksheets to determine how data is aggregated and organized. Enables users to analyze data at various levels, such as by customer, product, location, and demand class.
- Series: Predefined set of data displayed in a report, table, or graph, at any aggregation level. Included are primary key indicators, forecasts, and accuracy metrics.

Slice-and-dice data capabilities:

- Any dimension and level of granularity
- Customize data views by aggregating and organizing in hierarchies, currencies, and units of measure
- Unlimited hierarchies, levels, and attributes

Workflows, role-based processes that automate specific business flows and tasks:

- Managed forecast approval process
- Integration with Oracle J.D. Edwards Enterprise One (E1) and the Oracle E-Business Suite (EBS)

**Other Features**

Advanced statistical forecasting, including up to 20 causal factors.

Collaboration platform, includes alerts and exceptions.
Evaluate demand from multiple data sources, for example, shipment and order history and sales and marketing data.

Nine forecasting models within the Bayesian framework.

Offline capabilities.

**Oracle Demantra Advanced Forecasting and Demand Modeling**

Oracle Demantra Advanced Forecasting and Demand Modeling includes all of the functionality available in Oracle Demantra Demand Management. It also provides more robust and powerful modeling tools which can address complex analytical questions and provide a complete demand forecast:

**AFDM Features**

- Advanced Statistical Analysis (base and lift decomposition): Decompose the forecast into baseline and lift. See forecast for promoted periods separated into baseline volume and volume associated with the promotion.

- Advanced Lift Decomposition: See what the effects of running a promotion on a product and location have on other products and locations. This type of analysis breaks down the impact of an event into:
  - Baseline (unpromoted volumes)
  - Direct lift
  - Pre-effect (event anticipation)
  - Post-effect (event driven pantry loading)
  - Halo and cannibalization for four different switching types
    - Item
    - Brand
    - Store
    - Channel
  - Cross-correlative analysis
• Unlimited causal factors: With AFDM you can define an unlimited number of causal factors.

• Localized configuration of the Analytical Engine (nodal tuning): Fine tune analytical engine selected models and parameters for a sub-set of items and locations. See Performing Advanced Analytics in the Oracle Demantra Demand Management User Guide.

• Shape modeling: A statistical estimation of product launch rates (shape) based on prior learning. For details, refer to the Oracle Demantra Implementation Guide.

• Promotional and sales calendarization: Normalizing to standard calendar periods.

• Advanced reporting: Gantt charts for deals, trade, promotions, and price breaks and other events.

• Advanced logistic forecasting and ridge regression-type forecasting models (normally used with large numbers of causal factors). These include:
  • Integrated Auto and Linear Regression (ARIX)
  • Auto Regressive Logistic (ARLOGISTIC)
  • Dual Multiplicative Linear Regression (DMULT)
  • Multiplicative Monte Carlo Regression for Intermittent (ICMREGR)
  • Logistic (LOGISTIC)
  • Modified Ridge Regression (MRIDGE)

**Configuring AFDM**

The general procedure for configuring AFDM for a promotion is as follows:
1. Review the following sections in the Oracle Demantra Implementation Guide:
   - Introduction to the Analytical Engine
   - Configuring the Analytical Engine
   - Configuring Promotion Effectiveness
   - Configuring Promotions and Promotional Causal Factors
   - Promotional Lift Coefficients
   - Forecast Decomposition (PE Mode Only)

2. Define and populate your promotional causal factors (see Configuring Promotional Causal Factors in the Oracle Demantra Implementation Guide)

3. Enable the AFDM module for each relevant user. The Demantra system administrator does this in Business Modeler by navigating to Security > Create/Modify User, and then selecting AFDM in the User Modules section.

   Enabling forecast decomposition
   1. Set the RUNMODE parameter to 1 (in init_params_0), and then run the analytical engine. The forecast will include the baseline forecast plus the defined uplift.
   2. Add the relevant promotional series to your worksheets. For example, search the list of available series names for those containing "lift," "Canbl," "cannibalization," and "uplift" (uplift is the most important).
   3. Ensure security allows open analytics to be viewed by users (see step 3, above).
   4. Use the Open Analytics option to configure models and engine parameters, per specific items and locations.
      For details, see:
      - Advanced Analytics (Nodal Tuning)
      - Performing Advanced Analytics (Nodal Tuning), in the Oracle Demantra Demand Management User Guide

   Enabling shape modeling
   1. Create causal factor of type ‘Activity’
   2. Add shape-specific series to worksheet and specify timing of shape.
      For details, see About Activity Shape Modeling.
Enabling advanced analytical models

1. Activate advanced models globally using Business Modeler (refer to the list of models above, in AFDM Features).
   For details, see Enabling Engine Models Globally.

2. Activate advanced models locally using Open Analytics.
   For details, see:
   • Advanced Analytics (Nodal Tuning)
   • Performing Advanced Analytics (Nodal Tuning), in the Oracle Demantra Demand Management User Guide

Oracle Demantra Real-time Sales and Operations Planning

This application provides a collaborative forum in which an organization’s sales, manufacturing, and financial groups work together to reach demand consensus and create a unified business plan.

Predefined Templates Feature

Predefined templates are predefined, function-specific worksheets enable those involved in the sales and operations planning process to collect sales, marketing, manufacturing, and financial data. This data then drives the following collaborative business processes:

• Demand Plan Review: Stakeholders—typically the marketing and sales departments—review the company’s forecast of future demand and use predefined reports to create a Consensus Demand Forecast. This forecast is an input to the Supply Plan Review.

• Supply Plan Review: Stakeholders review the Consensus Demand Forecast and then use appropriate reports to create a plan for meeting the expected demand. This information is used to generate a Consensus Demand Plan. This plan is an input to the Executive Review.

• Executive Review: Senior management uses relevant reports to compare planning data with the company’s budget and reviews key performance indicators. The result is a set of consensus demand and supply plans that drive enterprise resource planning (ERP).

Other Features

Predefined workflows:

• Task notification and approval process for Demand Review and Supply Review
• Preconfigured series and calculations

Oracle Demantra Anywhere: Pure HTML view of data
Dynamic Open Link to Excel to create reports
Enhanced functions for modeling supply side series, calculations, and parameters
Fpos and Fsum functions to:
• Model supply-side series, calculations, and parameters
• Launch workflow-based automation and management approval process

**Oracle Demantra Predictive Trade Planning**
Oracle Demantra Predictive Trade Planning includes all of the functionality available in Oracle Demantra Advanced Forecasting and Demand Modeling. It also provides a fully functioning trade promotion management capability for trade funds, promotion entry, execution, tracking, and analysis. It uses advanced data mining technology, enabling organizations to analyze sales history, efficiently manage trade funds allocation, and understand how promotional strategies shape demand.

**Features**
Post-event analysis: Analyze overall promotion effectiveness
Predict the impact and profitability of future promotions
Predict and monitor trade fund spending
Manage all funds, sales, and account planning:
• Supports multiple fund types and budgets
• Enter funds and rates by territory
• Allocate funds by territory, retailer, brand, or promotion group
Create profitability reports to track costs and benefits of events.
Easily view forecast decomposition between baseline volume (turn volume) and incremental volume: Within incremental volume, define what portion is attributed to cannibalization with other products, pantry loading (pre- and post-effect), market growth, and competitive brand switching
Create pre-event simulations: Perform what-if evaluations against profitability, quota, and allocated budget

**Oracle Demantra Trade Promotion Optimization**
Oracle Demantra Trade Promotion Optimization includes all of the functionality
available in Oracle Demantra Predictive Trade Planning application. It also evaluates past events business-specific objectives and constraints then automatically selects the promotion strategy that will produce the best result, while considering. It develops and maintains modeling coefficients across the various customers and products using historical inputs, attributes, and other relevant data.

Features

Optimize promotions based on goals, for example, maximize profit/revenue/volume, and constraints, for example, maximum budget or minimum retailer margin.

Evaluate effects of pricing, promotion type, and promotion cost via manufacturer and retailer profitability reports

Create and analyze what-if scenarios: Compare alternative promotion strategies to maximize return on investment

Oracle Demantra Deductions and Settlement Management

Oracle Demantra Deductions and Settlement Management is the final step in the trade promotion management process. You can track and reconcile invoice deductions and other settlement methods back to promotional events.

Features

Collaboratively manage the settlement resolution process.

Automatically or manually match deductions and settlement methods with promotional events.

Reconcile deductions and payments with proof of performance from retailers based on promotion terms.

Manage reconciliation of trade and non-trade settlements,

Create status reports of deductions clearing process, for example, Settlement Days Outstanding; Days Outstanding by Account, and Settlement Type.

Create detailed ad-hoc reports and high-level metrics for specific business needs.

Receive, research, and clear:

- Claims
- Deductions
- Off-invoice settlements
4-4-5 calendar
A calendar that consists of financial quarters, in which each quarter consists of a "month" of exactly four weeks, followed by a "month" of exactly four weeks, followed by another "month" of exactly five weeks. In practice, 4-4-5 calendars vary slightly from company to company.

active combination
Item-location combination that is neither dead nor young; see prediction status.

advanced analytics
The process of specifying engine models and engine parameters for different combinations within the forecast tree, rather than using the global settings.

aggregation
The process of adding up or otherwise determining a useful summary of a set of related data. For example, you might add up the sales for all the products in a product group and arrive at an aggregated number for the entire product group. Aggregation does not always mean simple addition; you can aggregate data in other ways.

A/P department
Accounts payable department, the department that receives bills and is responsible for paying them.

approved trade
In general, this refers to settlements that have been matched to promotions and that have approved by a user with sufficient authority. See also unapproved trade.

A/R department
Accounts receivable department, the department that sends bills as needed and receives all payments.
**attachment**

A file, typically in JPEG or PDF format, that you include within a note, as supplemental information. You generally use attachments to provide proof of performance.

**attribute**

A descriptive property associated with the level (and stored internally in the table associated with the level). For example, a Ship To member might have the following attributes:

Apart from the Name attribute, the attributes shown in red are all parents of this member. They are shown in red because they are required.

You use attributes in several different ways:

- To provide extra information to describe members of the level. You can view and edit this information.

- To provide a further subdivision of the level data. To do this, you add an attribute to a level and select an option to create it as a child level. For example, suppose you create an attribute called ABC. If ABC can have the values A, B, or C, and if you create this attribute as a level, then the ABC level would have three members: A, B, and C. The member A, for example, would consist of all the data that had the A
value for this attribute, within the parent level.

- For the purpose of exporting or importing data.
- To describe promotions. Promotion attributes are converted into promotional causal factors. Applies only to Promotion Effectiveness.

**batch mode**
A mode in which you can run the Analytical Engine. In this mode, the Analytical Engine uses the entire forecast tree. See also simulation mode.

**base time buckets**
The time buckets in which data is stored in Oracle Demantra. Each base time bucket contains data corresponding to one base time unit. Users can view data aggregated into larger time buckets as well.

**base time unit**
The smallest possible time unit in your Oracle Demantra implementation. The base time unit determines the time resolution of your system.

**billback**
Request for credit on invoice, due to a promotion.

**broker**
An outside party who negotiates promotional agreements between a manufacturer and the retailers. Applies to DSM.

**cannibalization**
Reduced demand of an existing product caused by a new product introduction or by the increased demand of an existing product due to corporate strategies like promotions. Although cannibalization typically refers to negative effects only, sales interactions like switching of accounts, brands, products, or channel could be either positive or negative. Applies to Promotion Effectiveness.

**causal factor**
Additional information that can explain historical data so that you can improve forecast quality (for example: price, CPI, weather, and so on). Specifically, a causal factor is a time-varying quantity (such as a series) that affects demand. Oracle Demantra provides the following general kinds of causal factors:

- A local causal factor depends on the time, location, and item being sold. For example, it can be a specific discount in a specific store.
• A global causal factor depends only on the time, for example, a holiday. See global factor.

• Promotional causal factors, which apply to different items, locations, and promotions. These causal factors are available only for Promotion Effectiveness.

You configure causal factors in the Business Modeler. Oracle Demantra uses this information to better understand the sales history and make more accurate predictions.

**chaining**

The general process of associating historical patterns of existing series with other series found in a new product or location, with the goal of predicting for the new product or location. To perform chaining, you use Chaining Management (within Demand Planner). You copy data from selected sources to the target combinations.

**chargeback**

A request sent to the customer for payment, typically when a deduction is denied.

**check request**

A request that a CSD representative sends to the company’s A/P department.

**claim**

A kind of settlement, specifically a request from a customer for payment. In these cases, the customer has run the promotion and is requesting to be reimbursed, based on an agreement between you and the retailer. If you approve the claim, you request for your A/P department to send a check to this customer or to the broker, as applicable.

**client expression**

Calculates data at a given level, referring to other data at the same level. You use client expressions to calculate numbers that cannot be calculated by aggregation from lowest-level data.

A client expression takes precedence over a server expression.

Normally, you use a server expression to retrieve data for the series at the lowest aggregation level. For higher aggregation levels, Oracle Demantra Demand Management automatically aggregates the results of the server expression. In cases where that aggregation is not suitable, you use a client expression that explicitly uses the data associated with the higher aggregation level.

**combination**

The combination of an item member (from any hierarchy level) and a location member (from any hierarchy level). Each of the following is a combination:

• Chocolate cookies (at all stores)
• Chocolate cookies at the Fair Haven store
• All cookies at Better Stores, Inc.

The word combination can also refer to the data associated with that combination, for example, all sales of chocolate cookies at the Fair Haven store.

**combination level**
A level that contains time-independent data for combinations. Sometimes called matrix level.

**combination series**
More often called matrix series.

**competitive item group (CI)**
A set of items within an influence range (IR). Typically an influence range includes two CIs: "us" and "them." For example, an influence range could consist of two CIs: one for Acme carbonated beverages ("us") and one for Brand X and Brand Y carbonated beverages ("them"). See also item group. Applies only to Promotion Effectiveness.

**competitive location group (CL)**
A set of locations within an influence range (IR). Each CL typically corresponds to a single competitive distribution channel. See also location group. Applies only to Promotion Effectiveness.

**combination-selection list**
Drop-down list at the top of a worksheet, equivalent to the Members Browser. A worksheet may have several of these, and you use them to specify which item-location combination the worksheet should display.

**component**
A subdivision of the Oracle Demantra data. Each component includes the following items:

• One or more series of data, organized into specific levels.
• Units of measure.
• Optional indexes and exchange rates.
• An owner, who can add additional users.

**content pane**
Pane within Collaborator Workbench that displays a graphical view of data associated
with a worksheet, to provide you with current, at-a-glance information that meets your needs. You can display content in many formats such as the following:

- Members Browser, which is a collapsible tree hierarchy of data levels
- Tabular format
- Chart formats including line, bar, and pie charts
- Calendar format

**crosstab**
A worksheet that has been configured with levels on the x-axis and the y-axis.

**CSD representative**
A member of the customer service department. The primary users of DSM are CSD representatives.

**dead combination**
The sales for this combination are not recent enough and are insufficient for predictions.

**deduction**
A kind of settlement, specifically a short payment on an invoice. In these cases, the customer has run the promotion and has made a short payment on an invoice. By permitting this short payment, you are reimbursing the customer for running the promotion.

**dimension**
Perspective from which a large volume of complex and interrelated data can be viewed and analyzed. Each dimension organizes data in one or more hierarchies of levels, allowing you to view the data in different ways. Your Oracle Demantra application can have any number of dimensions, which you define in the Business Modeler. See also level hierarchy.

**engine profile**
A set of engine parameters with specific values and a profile name. For use only with the Promotion Effectiveness engine.

**exception**
If you attach an exception to a worksheet, Oracle Demantra Demand Management checks the values of the worksheet data and displays only the combinations that meet the exception criteria.

Specifically, you define an exception condition that consists of a series, a comparison
operator (such as equals or greater than), and a value, for example:

Sales > 150000

When you open the worksheet, Oracle Demantra Demand Management checks each combination in the worksheet. For each combination, if the condition is met for any time in the worksheet date range, Oracle Demantra Demand Management displays that combination. For example, the worksheet shows combinations that have Sales values greater than 150000, within the time range included in the worksheet.

If the condition is not met at any time for any of the worksheet combinations, Oracle Demantra Demand Management shows the worksheet as empty. That is, if all values in the Sales series are less than or equal to 15000, the worksheet comes up empty.

You can attach multiple exceptions to a worksheet. When you do so, you can relate them to each other by using logical AND or logical OR relationships.

**fictive**

Placeholder. For example, when you first create a member using Member Management, that member is not yet associated with any sales data and is therefore a fictive member.

**filtering**

The process of limiting the scope of data. Oracle Demantra provides two general types of filters, each of which allows only certain data to be displayed or otherwise used. The more common filters are combination filters. For this type of filter, you specify the following:

- An aggregation level. You can filter data at any level in any dimension.
- Members of that aggregation level that are allowed through the filter; other members are not included.

The net result is that a filter allows Oracle Demantra to display only certain item-location combinations.

In a few places, Oracle Demantra provides a different type of filter, a value-specific filter that allows only data that contains certain values.

**forecast**

Predictions about future sales of items at various locations, as a function of time. The forecast is based upon the demand, which in turn is based upon the historical data. The length of time that the forecast spans is called the forecast horizon.

The Analytical Engine creates the forecast, either as the result of the batch forecast, or when a user runs and approves a simulation.

**forecast model**

Mathematical model used to predict forecast. Oracle Demantra provides about a dozen
forecast models that are in common industry use. To create its forecast, the Analytical
Engine tests each model, sees how well it fits the historical data, and uses a weighted
combination of the results from all the models.

**forecast node**
Node within the forecast tree.

**forecast tree**
A single hierarchy of forecast data, the forecast tree is made up of item-location
combinations at different aggregate levels. Each node in this tree represents a
time-based series that is subject to forecast. The forecast tree does not need to contain all
possible combinations, only those that are relevant to the forecasting process.

**general attribute**
See attribute.

**general level**
An aggregation level that stores time-dependent data for a combination. For example, a
promotion is generally associated with one or more items at one or more locations, and
is associated with specific dates. Oracle Demantra stores the data for this promotion as a
general level.

**global factor**
A causal factor that depends only on the date of the sale. A global factor affects all items
and locations in the system. For example, global oil prices have an impact on the sales
of automobiles. The effect is widespread but changes with time. The effect occurs at all
locations where the automobile is sold, and for all models being sold.

Another possible global factor is a holiday, if all locations in your solution follow the
same holidays.

**group**
Set of users who can work together on the Collaborator Workbench. A user can belong
to multiple groups.

**historical data**
In general, this is the record of sales of different items at all locations, for months or
years in the past. For each sale, you must know the location of the sale, the product
code, price, and quantity. You also typically know information about causal factors
(such as holidays and promotions) that may have affected the sales volume. Oracle
Demantra also uses information about returns, inventory levels, and orders.

**index**
A financial measure used to normalize prices over time. An example is the Consumer
Price Index (CPI).

**influence group (IG)**
A set of item-location combinations in which all items belong to the same item group and all locations belong to the same location group. Within a given influence groups, the influence groups mutually interact. By identifying the influence groups, you determine the coarseness or generalization of causality. Applies only to Promotion Effectiveness.

**influence range (IR)**
Level within the forecast tree that controls how far the Analytical Engine looks for influence when a promotion is run. The influence ranges control how far the Analytical Engine looks for influence when a promotion is run. This determines the breadth of the causality. An influence range consists of multiple influence groups. Applies only to Promotion Effectiveness.

**item**
One of the dimensions by which you view data. Other typical dimensions are location and time. Each dimension consists of one or more hierarchies of data, allowing you to view data organized in different ways. For example, if you are forecasting demand for muffins, the item dimension could contain a product group hierarchy and a flavor hierarchy.

**item group**
A set of items within a competitive item group (CI). For example, within the Acme CI, the item group I1 might consist of orange-flavored soft drinks. Another item group, I2, might consist of colas. Applies only to Promotion Effectiveness.

**level**
An aggregation of data. For example, the Color level might consist of the sales data aggregated by the color of the items. Each level consists of members. The Color level would have one member for each color.

Levels allow you to view the data in different ways. Oracle Demantra supports the following types of levels:

- Item levels organize data in ways that reflect product properties such as product family, color, style, and so on. Each member of an item level represents time-dependent data aggregated according to some attribute of the item being sold.

- Location levels group and aggregate data according to characteristics of the locations where you sell. For example, location levels could describe geography or types of stores.

- Combination (or matrix) levels group and aggregate data according to
characteristics of the item-location combinations. These are less common than item and location levels.

- Time levels group and aggregate data by sales date. Normally you use a time level in place of the time axis.

- Promotion levels group and aggregate data by sales promotions. Depending on how your system is implemented, you may have a hierarchy of promotional levels (to organize the promotions), and the higher levels might use different icons. Unlike other kinds of levels, promotion levels can be displayed within a Gantt chart. Promotion levels are available only with Promotion Effectiveness.

- Settlement levels, which are used only by DSM. In general, a settlement is an outstanding sum of money that needs to be resolved, related to a promotion. If you use a settlement level in a worksheet, you cannot use levels from any other hierarchy in that worksheet.

- Check request levels, which are used only by DSM. A check request is an instruction to send a check to a customer or designated third party. Check requests are exported to the accounting systems that actually perform them.

Item and location levels are the most common.

Levels are organized into hierarchies, and each level can have attributes.

**level hierarchy**

Each level can belong within any number of independent hierarchies, each of which represents a different way of aggregating data. For example, the SKUs could be organized into product families, which in turn could be organized into divisions as follows, as follows:
In this example, Division, Product Family, and SKU are all levels in Oracle Demantra. The SKUs could also be organized into brands as follows:

Note that this hierarchy is independent of the product family hierarchy. That is, there is not necessarily any relationship between brands and product families. Nor is there any relationship between brands and divisions.

Given these relationships, a member can have parents. For example, consider the SKU member Rainbow LF Chocolate Chip. This SKU might have the following parents:

- Regular (parent of this SKU within the product family level)
- Rainbow (parent of this SKU within the brand level)
**level series**
A series that is associated with a specific level. Each data point in the series corresponds to a given member of that level. Data for this series is stored in the table associated with the level.

**live combination**
Item-location combination that is neither dead nor young; see prediction status.

**location**
A dimension by which you view data. Other typical dimensions are item and time. Each dimension consists of one or more hierarchies of data. For example, the location dimension could be broken down into country and then into states and towns.

**location group**
A set of locations within a competitive location group (CL). Applies only to Promotion Effectiveness.

**matrix level**
See combination level.

**matrix series**
A series that consists of time-independent data for each item-location combination. This data is stored in mdp_matrix.

**member**
An element of a level. Each level contains one or more members. For example, at the city level, members may include Paris and London.

Each member corresponds to a set of sales data. Each member has properties that apply to the sales data at that level, such as unit, description, and an identifying code.

There are several types of members.

**member management**
The process of creating, editing, and deleting level members.

**Members Browser**
A collapsible tree hierarchy of item and location levels. Within a Promotion Effectiveness worksheet, you use the Members Browser to specify which item-location combination the worksheet should display.

**method**
An action that can be performed for a specific member within a worksheet. Methods
appear as options within the right-click menu. A method is associated with a specific level and may be available only within a specific worksheet or within all worksheets.

**model**
Mathematical model that the Analytical Engine uses when creating a forecast.

**note**
A comment that you attach to data in a worksheet. A note is generally associated with specific items and locations, on one or more dates. A note can include an attachment.

**off-invoice settlement**
A kind of settlement that represents the case where the customer was billed a lower amount (that is, "off invoice") for the products, as compensation for running the promotion.

**outlier**
An atypical observation, generally infrequent; a data point that does not appear to follow the characteristic distribution of the rest of the data. Outliers may reflect genuine properties of the underlying phenomenon (variable), or may be caused by measurement errors or other anomalies that should not be modeled.

Some of the Oracle Demantra forecast models automatically identify and exclude outliers, and Oracle Demantra indicates when that occurs. You can manually identify outliers as well.

**POS data**
Point-of-sale data.

**prediction status**
When generating forecasts, the engine considers the prediction status of each item-location combination. Prediction status is one of the following:

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Young</td>
<td>Sales for this combination are not recent enough to be used for prediction.</td>
</tr>
<tr>
<td>Dead</td>
<td>Sales for this combination are too new to be used for prediction.</td>
</tr>
<tr>
<td>Live</td>
<td>Neither young nor dead. Also called active.</td>
</tr>
<tr>
<td>Status</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Create Zero Forecast</td>
<td>A user has specified this prediction status manually for this item-location combination, and this status means that this combination should have a forecast consisting of zero values.</td>
</tr>
</tbody>
</table>

The Analytical Engine ignores any young or dead combinations.

**program group**
A collection of menu items, typically related to each other in some way. You create program groups so that you can easily control access to all the menu items in the group. Oracle Demantra provides several predefined program groups, for convenience.

**proof of performance**
Also known as POP. A document that shows that the retailer did run the promotion as required by agreement. POP is usually required before you can approve a settlement. You generally use an attachment to provide proof of performance.

**promotion**
A marketing event associated with specific items at specific locations during a specific time. You generally run promotions in order to increase demand.

**promotion series**
A series that consists of data for each promotion at each item-location combination, at each time bucket.

**promotional causal factor**
A set of time-varying data associated with specific items at specific locations during a specific time. Applies only to Promotion Effectiveness.

**proport**
Mechanism that Oracle Demantra uses for splitting aggregated data across the corresponding lowest-level members. Oracle Demantra splits data on many occasions, including the following:

- When the Analytical Engine generates a forecast at an aggregated level
- When data is imported at an aggregated level
- When users edit aggregated data
• When users perform chaining at an aggregated level.

proportions
Split proportions used by the proport mechanism.

sales series
A series that consists of time-dependent data for each item-location combination. That is, each data point in the series corresponds to a given item-location combination at a given point in time. This type of series is the most common type by far.

seasonality
If historical data has a regular pattern of observations above and below a trend, the data is said to be seasonal. Seasonality is generally observed in data compiled on a less than annual basis (for example, quarterly or monthly).

series
Usually, a time-dependent set of data. For example, sales data and the forecast are both series. Although most series are time-dependent, Oracle Demantra supports other types of special-purpose series: matrix series and level series.

A series can be defined by a server expression, a client expression, or both. In general, the definition of a series describes how data for that series should be calculated at any aggregation level.

• Some series are calculated by aggregated data from the lowest level stored in the database. Data can be aggregated in various ways, for example by totalling it, or by taking the maximum or the minimum value. To see data changes in this kind of series, you must rerun the worksheet.

• Some series are calculated at the level of the worksheet, using data currently available at the worksheet level. Data changes are available immediately.

Also, when you edit data for a series, Oracle Demantra calculates the values for the lowest level and writes that to the database. This means that worksheets run more quickly at lower levels than at higher levels.

server expression
The SQL expression that calculates the series data at any level by aggregating the associated lowest-level data. A very common server expression has the following form:

sum (table_name.update_column_name)

Here table_name.update_column_name is the table and column that stores data for this series. The server expression often includes the unit of measure in which results are expressed.
A client expression takes precedence over a server expression.

**settlement**
An agreement between a manufacturer and a retailer in which the retailer runs a specified promotion (to boost sales of a specific product or products) and the manufacturer agrees to compensate the retailer for this action. In some cases, this agreement is negotiated by a third party, namely, a broker.

See claim, deduction, and off-invoice settlement.

**simulation**
A ‘what if’ scenario in which a user may manipulate measure data (such as History) and examine the way in which the changes affect related measure data (such as Forecasts).

**simulation mode**
A mode in which you can run the Analytical Engine. In this mode, you perform evaluate a scenario, to see what might happen in a given situation. In contrast to batch mode, you use only a small part of the forecast tree and a comparatively small set of data series.

**splitting**
In general, splitting refers to the general process of dividing an aggregated amount into appropriate parts. See proport.

**switching effect**
Generic term for the effect that a sale for a given item-location combination can have on sales for another item-location combination. Applies only to Promotion Effectiveness.

**task**
A unit of work shown in the My Tasks module. A task generally consists of a request for a specific user or set of users to review a given worksheet; the task has a subject line, a description, and a message; it can include a Web link, as well as an attached file. Each task has a status and sometimes a timeout period. After you address the task, you should mark it as done so that the Workflow Engine can continue with the next steps in the workflow.

(The workflow can also send e-mail to a task recipient by external e-mail, but that e-mail has no direct effect on the workflow.)

Depending on how Collaborator Workbench has been configured, users may also be able to create tasks and send them to other users.

**time**
A dimension by which you view data. Other typical dimensions are item and location.
**time bucket**
Depending on context, this phrase refers to any of the following:

- The base time buckets.

- A specific period of time corresponding to a time unit (the week of 1/3/05).

- The data associated with that period of time (the data associated with the week of 1/3/05). If you consider a set of series as a spreadsheet, with time as the horizontal axis, then a time bucket is a vertical slice of the data.

- A time unit (a week).

**time level**
A level that aggregates data across time. Depending on your system, time levels are configured to enable you to analyze data by the specific month of the year, day of the week, and so on.

**time resolution**
In general, time resolution specifies the amount of visible detail for time-dependent data. Specifically, it refers the time unit by which this data is grouped, for example, by months or weeks. See also time unit.

**time unit**
A unit of time in Oracle Demantra, such as day, week, month, and others, including the months of a 4-4-5 calendar.

The base time unit (or minimum time unit) is the smallest length of time that your data model represents. This can be either a day, a week, or a month, by default; smaller buckets are possible but require custom work. The size of the base time unit determines the maximum possible time resolution of your model.

**trend**
The long-term behavior of data, over time.

**unapproved trade**
In general, this refers to settlements that have been matched to promotions and that have not yet approved. See also approved trade.

**unresolved trade**
In general, this refers to settlements that are either new or in progress.

**waterfall chart**
A chart or table that displays both the current version and past versions of the same
data.

**workflow**
An automated sequence of steps, some automatic and some that require user input. A typical workflow sends tasks to users (to appear in My Tasks module) in response to conditions within the demand chain process.

**worksheet**
A set of data retrieved from the Oracle Demantra database. In a worksheet, you specify information such as following:

- At least one series to retrieve from the database
- The levels of aggregation to view in the worksheet
- Optional filtering to set the scope of the worksheet

A worksheet can be public (shared with other Oracle Demantra users) or private. Only the owner of a worksheet can edit it.

A worksheet is also known as a query.

**x-axis**
The horizontal axis of a worksheet graph and correspondingly, the vertical axis of a worksheet table.

**y-axis**
The vertical axis of a worksheet graph and correspondingly, the horizontal axis of a worksheet table.

**young combination**
All sales for this combination are too new and are insufficient for @ prediction

**zero history**
Historical data consist of zero sales. You usually create zero history for combinations you create in Member Management, so that there are placeholder records that you can edit.
## Index

### A

**Activity Browser**
- introduction, 14-10
- shortcut for displaying, 17-2

**aggregation**
- how controlled, Glossary-15
- introduction, 14-2, Glossary-15
- kinds of levels, 14-3

**ampersand, in Demantra Spectrum**, 1-4

**ampersand, in Oracle Demantra Spectrum**, 9-3

**applet**
- installing, 1-1, 8-2, 12-3

**attachment**
- adding, 9-14
- downloading, 9-15
- permissions for, 9-16
- removing, 9-15

**attribute**
- introduction, 14-4
- promotional
  - printing with Gantt chart, 9-10
  - specifying value for new member, 4-4, 13-3
  - viewing value, 4-2, 13-2

**audit trail**
- defining profile for viewing, 9-19
- for a combination, 9-19
- introduction, 9-18

**automatic logoff**, 7-1

**axes of a worksheet**
- introduction, 14-8
- specifying, 14-35

### B

**bar chart content pane**
- configuration rules, 6-3
- introduction, 3-6

**Business Logic Engine (BLE)**
- and audit trail, 9-18

### C

**cache**
- worksheet
  - enabling for a worksheet, 14-18
  - refreshing manually, 9-17

**calendar content pane**
- configuration rules, 6-3
- introduction, 3-10

**chaining**
- closing a location and merging it into another, 16-25
- from Collaborator Workbench, 1-4
- new product introduction, 16-22, 16-26
- partial, 16-15
- performing chaining operation, 16-17
- proportions, 16-8, 16-12
- starting chaining tool, 1-4
- step by step, 16-1

**Chaining Management**
- accessing, 16-2
- defining a chaining profile, 16-10
- introduction to user interface, 16-2
- performing a chaining operation, 16-17

**changes**
saving, 9-5
saving changes to My Tasks, 2-3
saving remotely, 7-7
viewing past, 9-18
characters to avoid, 1-4, 9-3
check request level, 14-4
Collaborator Workbench
and content panes, 14-16
brief tour, 1-4
creating content panes, 6-1
general workflow, 1-9
logging off, 1-10
logging on, 1-3
managing panes, 1-8
My Tasks, 2-3
personalizing, 5-1
types of content panes, 3-2
combination
and matrix series, 14-6
creating, 13-4, 15-8, 15-8, 16-3
creating zero data, 15-9
displaying data for, 14-8
exporting data for, 9-8
including in worksheet, 14-25, 14-26
selecting which to display, 14-8
source for chaining, 16-11
viewing, 15-10
combination level
introduction, 14-4
combination series
introduction, 14-6
component, 14-31
content
adding pane from existing panes, 5-1
closing pane, 1-8
defining new content panes, 6-1
deleting, 6-23
design
applying exception filter, 6-21
basics, 6-4
filtering, 6-18
index used in, 6-17
overview of options, 6-2
rules for different types, 6-3
scale and unit of measure, 6-17
selecting series, 6-8
specifying aggregation, 6-12
specifying time criteria, 6-10
tips for titles of panes, 6-6
units of measure, 6-17
detailed overview, 3-1
displaying in Collaborator Workbench, 3-10
introduction, 1-4, 1-6
maximizing or minimizing pane, 1-8
opening associated worksheet, 3-12
options, 14-19
ownership and sharing, 6-22
refreshing data, 1-9, 3-12
types and examples, 3-2
viewing definition, 3-12
CPI (Consumer Price Index), 14-29
creating similar products, 13-6
cross-tab layout, 14-12

D

data
copying and pasting with Excel, 9-7
copying and pasting within worksheet, 9-7
editing, 9-3
editing in Collaborator Workbench, 3-2
exporting to Excel, 9-8
importing into Excel, 9-9
printing, 9-10
printing remotely, 7-7
refreshing, 1-9
resetting manual changes, 7-7
saving changes, 10-4
viewing in Collaborator Workbench, 1-6
when last refreshed, 3-1
default
combinations in content pane, 6-14
combinations in worksheet, 14-26
filtering of stacked bar charts, 3-8
layout in Collaborator Workbench, 5-1
parent members for manually created member, 15-2
selection of combinations, 6-14
table sort, restoring, 9-6
worksheet associated with a level, 4-2, 13-11
worksheet view layout, 14-35
demand
useful series, 14-5
Demantra Anywhere
opening a worksheet, 7-5
using worksheets, 7-6
DOL
using, 9-9
Dynamic Open Link
using, 9-9

E

e-mail
and task timeout, 2-2
escalating a task, 2-8
relationship to Collaborator Workbench, 1-9
sending from Collaborator Workbench, 1-8
sending notification of task, 2-6
embedded worksheets
adding, 14-41
introduction, 8-7
synchronizing with main worksheet, 8-8
empty rows
controlling display, 10-4
creating, 15-9
saving setting, 10-8
Excel
copying data to, 9-7
exporting data to, 9-8
linking data into via Dynamic Open Link (DOL), 9-9
pasting data from, 9-7
exception filter
applying to content pane, 6-21
applying to worksheet, 14-33
shortcut for, 17-3
exchange rate
introduction, 14-29
used in content pane, 6-18
used in worksheet, 14-30
exiting
Collaborator Workbench, 1-10
extra filters option, 14-18

F

filter
adding for when worksheet opens, 14-18
adding to content pane, 6-20
adding to worksheet, 14-31
adding to worksheet view, 14-42

and Open With menu, 13-11
and other performance tips, 14-44
applied to stacked bar charts, 3-8
filtering series in worksheet editor, 14-22
for bar charts, 14-20
introduction, 14-31
prompting when worksheet opens, 8-2, 8-3, 9-2
shortcut for, 17-3
time, 6-10
finding elements, 14-22

G

Gantt chart
introduction, 14-10
printing, 9-10, 9-10
shortcut for displaying, 17-2
graph
adding series to, 6-7, 14-35
changing style, 11-3
choosing type, 6-5, 14-35
hiding or displaying, 8-6, 14-10
introduction, 8-6, 14-10
not available in Oracle Demantra Anywhere, 7-2
styles and examples, 11-1
time resolution of, 6-10, 14-23
viewing note from within, 9-13

H

Hide Empty Rows, 10-5
hierarchy
introduction, Glossary-10
hung session
ending, 1-10

I

illegal characters, 1-4, 9-3
index (financial)
introduction, 14-29
used in content pane, 6-18
used in worksheet, 14-30
item-location combination
displays for, 14-8
item-type levels
Index-4

K

keyboard shortcuts, 17-1

L

Last Refresh date, 3-1
Last Update date, 3-1
layout
  worksheet
tips, 14-44
layout, Collaborator Workbench
  adding content pane, 3-11
  configuring by user, 5-1
  configuring My Tasks, 5-3
  configuring My Worksheets, 5-4
layout, worksheet
  defining, 14-21, 14-35
  examples, 14-10
  refreshing, 14-16
  restrictions in Oracle Demantra Anywhere, 7-2
  saving changes, 10-4, 10-7
  shortcut, 17-3
level
  adding to content pane, 6-12
  adding to worksheet, 14-25
  in worksheet, 14-25
  on worksheet tab, 14-37
  rules for content panes, 6-3
  specifying for content pane, 6-12
level series, 14-6
lifecycle definitions, removing, 13-9
line chart content pane
  configuration rules, 6-3, 6-3
  introduction, 3-4
links in Collaborator Workbench, 1-4
  adding link within a task, 2-6
location-type level
  introduction, 14-4
logging off, 1-10
  if session hangs, 1-10
logging on, 1-1, 1-3, 7-4, 17-1

M

matrix series

introduction, 14-4
member
  copying, 15-13
  deleting, 4-5, 13-5
  moving, 15-13
  pasting, 15-13
  sending to worksheet, 4-2, 13-11
  types, 15-2
Member Management
  combination list, 15-10
  creating combination, 15-8
  introduction, 15-1
Members Browser
  comparison to selection lists, 14-8
Members Browser content pane
  configuration rules, 6-3
  introduction, 3-2, 4-1
menu
  Collaborator Workbench
    using, 1-5
  right-click
    basic options, 4-1, 13-1
    not available in Oracle Demantra
    Anywhere, 7-3
    other options, 4-5, 13-11
My Tasks, 1-8
  configuring and sorting of number of tasks, 5-3
  marking task as done, 2-5
  refreshing, 2-3, 2-5, 2-8
  user configuration, 5-1
  using, 2-3
My Worksheets, 1-6
  configuring list of worksheets, 5-4
  displaying, 8-2
  sending a worksheet as a task, 2-6
  user configuration, 5-1
  worksheet descriptions in, 14-17

N

new member, 15-2
new product introduction, 16-22, 16-26
new product introductions, 13-6
note
  adding, 9-13
  adding an attachment, 9-14
deleting, 9-14
editing, 9-13
features in Oracle Demantra Anywhere, 7-3
in Demantra Anywhere, 7-7
saving changes, 10-4
setting permissions, 9-16
viewing, 9-13
Notes/Attachments subtab, 9-11, 9-14

O
offline
   accessing offline worksheet, 12-8
   introduction, 12-1
   reloading offline data, 12-9
   saving data for offline use, 12-6
   setting up environment, 12-3
Open With menu
   using, 4-2, 13-11
Oracle Demantra Advanced Forecasting and Demand Modeling, 18-3
Oracle Demantra Anywhere
   logging on, 7-4
   overview of capabilities, 7-1
Oracle Demantra Deductions and Settlement Management, 18-8
Oracle Demantra Demand Management, 18-2
Oracle Demantra Predictive Trade Planning, 18-7
Oracle Demantra Real-time Sales and Operations Planning, 18-6
Oracle Demantra Trade Promotion Optimization, 18-7

P
partial chaining indicators, 16-15
performance
   tips for worksheet design, 14-44
permission level
   in a note, 9-16
personalization
   My Tasks, 5-3
   My Worksheets, 5-4
   overview, 5-1
   wide and narrow panes, 5-1
pie chart content pane
   configuration rules, 6-3
   introduction, 3-9
pivot table, 14-12
placeholder data
   creating, 13-4
   printing, 9-10
   printing remotely, 7-7
product features
   Oracle Demantra Advanced Forecasting and Demand Modeling, 18-3
   Oracle Demantra Deductions and Settlement Management, 18-8
   Oracle Demantra Demand Management, 18-2
   Oracle Demantra Predictive Trade Planning, 18-7
   Oracle Demantra Real-time Sales and Operations Planning, 18-6
   Oracle Demantra Trade Promotion Optimization, 18-7
   overview, 18-1
product lifecycle definitions, 13-8
profile
   for selecting parts of audit trail, 9-20
Promotions Effectiveness
   creating worksheets, 14-16
   introduction to user interface, 14-8
   using worksheets, 9-1
   viewing audit trail, 9-18
promotion series
   introduction, 14-6
proportion
   in chaining, 16-8, 16-12

Q
query, 14-2
quote marks, in Demantra Spectrum, 1-4
quote marks, in Oracle Demantra Spectrum, 9-3

R
real member, 15-2
redo, 9-4
refreshing, 2-3, 2-5, 2-8
remote login, 7-1, 7-4
   editing data, 7-6
   viewing My Worksheets, 7-5
resetting manual changes, 13-9
resizing, 10-3
restoring
  default table sorting, 9-6
right-click menu
  basic options, 4-1, 13-1
  not available in Oracle Demantra Anywhere, 7-3
  other options, 4-5, 13-1

S
Save parameters check box, 4-5
selection task
  canceling selection, 2-6
  marking as done, 2-5
series
  selecting, 6-8, 14-20
  specifying display, 14-35
session
  keeping active, 7-1
settlement level, 14-4
shortcuts, 17-1
simulation
  not available in Oracle Demantra Anywhere, 7-4
sorting
  combinations in Member Management, 15-12
  controlling order of series in table, 14-35
  restoring default table sort, 9-6
  saving sort order, 10-8
series in content pane editor, 6-9
series in worksheet editor, 14-22
sort order in My Tasks, 5-4
worksheet table, 9-6
special characters (to avoid), 1-4, 9-3
splitting
  in chaining, 16-8, 16-12
stacked bar chart content pane, 3-6
starting
  Collaborator Workbench, 1-3
subtabs of worksheet
  Notes/Attachments, 9-11, 9-14
  other worksheet as subtab, 14-41
  overview, 14-10
summary row
  introduction and examples, 14-7
synchronization
  between views, 10-2, 10-7, 14-39
T
table content pane
  configuration rules, 6-3
  introduction, 3-3
tabs versus windows
  for separate worksheets, 10-1
  for worksheet views, 10-3
task
  creating and sending, 2-6
  introduction, 2-1
  marking as done, 2-5
  marking as Done, 1-9
  timeout, 2-2
  viewing, 1-9
time level
  and time axis, 10-3
  introduction, 14-4
timeout
  in workflow, 2-2
time resolution
  specifying for content pane, 6-10
  specifying for worksheet, 14-23
Top/Bottom filter
  overview, 3-8
  specifying, 6-6
troubleshooting
  cannot see new promotion, 8-8
U
undo, 7-7, 9-4
unit data, 15-7
units of measure
  in content pane, 6-17
  introduction, 14-29
  in worksheet, 14-29
updating database remotely, 7-7
updating product lifecycle definitions, 13-8
URLs, 1-1, 1-3, 7-4
user
  forcing logout, 1-10
user-defined member, 15-3
  creating, 15-6
V
view
  adding to worksheet, 14-39
  and worksheet, 10-2, 14-10
  defining layout, 14-21, 14-35, 14-35
  deleting from worksheet, 14-40
  enabling or disabling, 14-39
  hiding worksheet levels, 14-37
  introduction, 10-2
  managing elements of, 10-3
  managing position and size, 10-2
  renaming, 14-39
  restoring default layout, 14-38
  synchronization, 14-39
  x-axis and y-axis, 14-8

W
  who’s Online
    user configuration, 5-1
  Who’s Online
    using, 1-8
  wildcard in exceptions, 14-34
  windows versus tabs
    for separate worksheets, 10-1
    for worksheet views, 10-3
  worksheet
    adding notes, 9-13
    adding to My Worksheets, 5-4
    closing, 10-2
    copying to Excel, 9-7
    creating, 14-16
    data in, 14-5
    deleting, 14-44
    deleting notes, 9-14
    design
      adding an embedded worksheet, 14-41
      aggregating and organizing, 14-25
      basics, 14-16
      caching, 14-18
      changing, 14-16
      exception filter, 14-33
      filtering, 14-31
      filtering individual view, 14-42
      index used in, 14-29
      selecting series, 14-20
      specifying elements to include, 14-40
      time criteria, 14-23

  tips, 14-44
  units of measure, 14-29
  views in, 14-35
  displaying multiple, 10-1
  editing notes, 9-13
  elements of, 14-8
  exporting to Excel, 9-8
  graph types, 11-1
  how aggregated and organized, 14-2
  initial selection prompt, 8-3, 9-2
  layout, 14-35
  linking via Dynamic Open Link (DOL), 9-9
  loading data manually, 7-7, 8-3, 9-1
  notes in, 9-13
  Demantra Anywhere, 7-7
  offline
    accessing, 12-8
    overview, 12-1
    reloading data, 12-9
    setting up environment, 12-3
  opening
    from content pane, 3-12
    from Members Browser, 4-2, 13-11
    in Oracle Demantra Anywhere, 7-5
  ownership and security, 14-43
  printing, 9-10
  saving data for offline use, 12-6
  saving definition, 10-4, 10-7
  saving with new name, 14-16
  sending as task to another user, 2-6
  sorting data, 9-6
  specifying note permissions, 9-16
  table, 14-9
  views in, 14-10
  x-axis and y-axis, 14-8

X
  x-axis
    and default table sorting, 9-6
    introduction, 14-8
    specifying, 14-35

Y
  y-axis
    introduction, 14-8
    specifying, 14-35
units and scale, 6-17, 14-29

Z

zero history and forecast, creating, 15-9