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1 Overview of Siebel Store-and-
Forward Messaging
The following topics are included in this section:

■ �Overview of Siebel Store-and-Forward Messaging Functionality� on page 7

■ �Overview of Siebel Store-and-Forward Messaging Architecture� on page 8

■ �Overview of Siebel Store-and-Forward Messaging Client Modules� on page 11

■ �About IBM WebSphere MQe� on page 11

■ �Overview of Siebel Store-and-Forward Messaging Administration� on page 12

■ �Overview of Siebel Store-and-Forward Messaging in the Siebel Handheld Applications� on page 13

■ �Using Store-and-Forward Messaging with the Siebel Service Handheld Application� on page 14

■ �Overview of Asynchronous Query on the Handheld Device� on page 15

■ �Using Asynchronous Query with the Siebel Service Handheld Application� on page 16

Overview of Siebel Store-and-Forward 
Messaging Functionality
Siebel Store-and-Forward Messaging and Siebel Handheld applications work together allowing you 
to perform critical business processes. For instance, a mobile technician using the Siebel Service 
Handheld application together with Siebel Store-and-Forward Messaging can receive a dispatched 
activity, acknowledge the activity, update the activity�s status, move parts, or debrief the assigned 
activity. During this process, Siebel Store-and-Forward Messaging enables the mobile user to 
communicate all information, in real or near-real time, with the back-end Siebel application server. 

Siebel Store-and-Forward Messaging provides push-based information delivery between Siebel 
eBusiness applications and Siebel Handheld applications. Using Siebel Store-and-Forward 
Messaging, a Siebel eBusiness application can dispatch information such as an activity and its 
associated data to a mobile user with a Siebel Handheld application. The changes made by the mobile 
user on the Siebel Handheld application are delivered to the Siebel application server through Store-
and-Forward Messaging. If the handheld device is connected to the Siebel application server, the 
information is delivered immediately; if the device is disconnected, the information is queued up in 
either the server or the client side and is delivered as soon as the device is reconnected to the server. 
Siebel Store-and-Forward Messaging uses the IBM WebSphere MQ Everyplace queuing system to 
make sure data is delivered and delivered only once. The MQe queuing system is supported on 
wireless or wired networks that can provide TCP/IP connections. 
Siebel Store-and-Forward Messaging Guide Version 7.7 ■ 7
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Additionally, Siebel Store-and-Forward Messaging provides asynchronous query, which allows a 
Siebel Handheld application user to access data not available in the Siebel Handheld application's 
local database. For example, if a mobile user would like to access information on a particular part 
which is not available in his Service Handheld database, the mobile user can send a query to the 
Siebel Application Server and the query result is delivered to his Service Handheld application by way 
of Siebel Store-and-Forward Messaging.

Siebel Store-and-Forward Messaging is available as part of the Siebel Service Handheld application, 
and can be configured to support other Siebel Handheld applications. 

NOTE: Store-and-Forward Messaging is supported for Direct Server Synchronization mode, but not 
for Companion Synchronization. 

For a list of supported handheld devices, see System Requirements and Supported Platforms on 
Siebel SupportWeb.

Overview of Siebel Store-and-Forward 
Messaging Architecture
Siebel Store-and-Forward Messaging consists of server components, client modules and the IBM MQe 
queuing system, which is responsible for queuing messages and delivering messages over a variety 
of wireless or wired networks. 

Store-and-Forward Messaging Logical Architecture
Figure 1 displays the logical architecture for Siebel Store-and-Forward Messaging.

Figure 1. Store-and-Forward Messaging Logical Architecture
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The Siebel Store-and-Forward Messaging Server includes an outbound server component to 
construct and send outbound messages to the server outbound queues; an inbound server 
component to retrieve and process inbound messages; transport service to deliver messages 
between the Siebel application server and server queues; Siebel workflows to orchestrate the 
inbound and outbound server components; and Store-and-Forward Messaging administration to 
manage or administer the Store-and-Forward Messaging server. On the handheld client side, Store-
and-Forward Messaging client modules are integrated with Siebel Handheld applications. 

Store-and-Forward Messaging Server Components
Figure 2 displays the server components for Siebel Store-and-Forward Messaging.

A Siebel application server with Store-and-Forward Messaging enabled can support multiple Siebel 
Handheld applications. Store-and-Forward Messaging includes the following services and server 
components.

Store-and-Forward Messaging Message Service (SMQ Message 
Service) 
The Store-and-Forward Messaging Message Service is called SMQ Message Service. SMQ stands for 
Siebel Messaging and Queuing. The SMQ Message Service consists of the following methods:

1 GenDataMsg method is used to extract data messages based on Siebel Handheld application 
definition. For example, if the Action business component defined for a Siebel Service Handheld 
application includes activity status and activity description, the method extracts activity status 
and activity description data based on the application definition. The extracted data is delivered 
to a Service Handheld application by way of a data message.

2 FormatMsg method is used to convert Siebel data into well-formed XML data or to convert XML 
data to Siebel data.

Figure 2. Siebel Store-and-Forward Messaging Server Components
Siebel Store-and-Forward Messaging Guide Version 7.7 ■ 9



Overview of Siebel Store-and-Forward Messaging ■  Overview of Siebel Store-and-
Forward Messaging Architecture
3 ProcessUserQueue method is used to receive and process server inbound messages. The method 
calls the Siebel Handheld Synchronization engine if the inbound message is a transaction-type 
message.

Store-and-Forward Messaging Transport Service (SMQ Transport 
Service) 
The Store-and-Forward Messaging Transport Service (SMQ Transport Service) is a bidirectional 
transport service which interacts with the MQe queuing system. The transport service sends or 
receives messages to and from the server queues, provides data encryption or decryption and 
performs data compression or decompression. Data is encrypted with the RC4 cipher and 
compressed with a suitable compression algorithm such as GZIP. 

The SMQ Receiver 
The SMQ Receiver is a server component which polls the server inbound queues by way of the 
transport service. Server inbound queues consist of two-level queues, the main application queue 
and individual queues. For each Siebel Handheld application with Store-and-Forward Messaging 
enabled, there is one main application inbound queue; for each application user, there is one 
individual inbound queue. SMQ Receiver dispatches messages from the main application queue into 
the individual user queues and it starts an inbound workflow task for each user to process the 
inbound messages in each individual queue. The inbound workflow calls the inbound message 
handler ProcessUserQueue method, which processes the message based on the message type. For 
example, if the message is a transaction message, the message is passed to the Handheld Sync 
Transaction Apply Services. 

Outbound Workflows
Siebel Store-and-Forward Messaging comes with three sample outbound workflows: SMQ Outbound 
Activity to One Recipient, SMQ Outbound Activity to Primary Owned By, and SMQ Outbound Activity 
to Team. These workflows are defined below.

■ The SMQ Outbound Activity to One Recipient is a basic workflow. It is based on the Action 
business object. This workflow�s main function is to generate a message, format the message, 
send the message to a server outbound queue, and update the message history table. 

■ The SMQ Outbound Activity to Primary Owned By workflow uses the SMQ Outbound Activity to 
One Recipient workflow as a subworkflow. This workflow is triggered by the WriteRecordUpdated 
runtime event in the Action business component. If an activity is assigned to a mobile user or an 
activity owned by a mobile user is updated, the workflow sends a data message to the mobile 
user with the updated activity information and its associated data.

■ The SMQ Outbound Activity to Team workflow also uses the SMQ Outbound Activity to One 
Recipient as a subworkflow. The workflow allows you to send a same activity message to all the 
service technicians on the same team. 
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Inbound Workflow
Siebel Store-and-Forward Messaging comes with one sample inbound workflow, SMQ Process User 
Queue. This workflow picks up server inbound messages from each individual inbound queue and 
processes them.

For greater detail, see �Siebel Store-and-Forward Messaging Sample Workflows� on page 57. In 
addition, these workflows can be examined using Siebel Tools. For more information see, Siebel 
Business Process Designer Administration Guide.

Overview of Siebel Store-and-Forward 
Messaging Client Modules
Store-and-Forward Messaging client modules include client inbound and outbound queues, client 
APIs, and a connectivity management module. Client inbound and outbound queues communicate 
with Store-and-Forward Messaging server inbound and outbound queues to transmit messages. 

The connectivity management module periodically monitors the client connectivity and setup 
connections by way of the Pocket PC Connection Manager. You can, for example, set up a time 
interval that instructs the client module to check whether a connection exists each time the specified 
time interval is hit. If, at the time of checking, the device is connected, the client module transfers 
messages (if any) in both directions then it goes to sleep; if the device is disconnected, the client 
module calls the Pocket PC Connection Manager to set up a connection. The connectivity module does 
not function if the handheld device or the wireless modem equipped with the handheld device does 
not use the Pocket PC Connection Manager to manage connectivity.

Messages are transmitted between the client inbound and outbound queues and the Store-and-
Forward Messaging Server inbound and outbound queues. The client module is responsible for 
transmitting all messages including transactions, asynchronous query requests, and registration 
requests to the server. The client also processes server responses as well as server outbound data 
messages, such as Activity dispatches and updates. The MQe implementation requires that the client 
polls the server periodically to transmit messages. The interval at which polling occurs can be 
configured in the Siebel Handheld installation setup.ini file.

About IBM WebSphere MQe
Siebel Store-and-Forward Messaging transmits messages to and from Siebel Handheld applications 
using IBM WebSphere MQ Everyplace (MQe) as a secure transport. A single instance of MQe is called 
a queue manager. An MQe queue manager contains numerous queues that hold messages being 
passed between the Siebel server and the Siebel Handheld applications. Both the Siebel Server and 
Siebel Handheld applications, which run on Pocket PC devices, communicate with the queue manager 
to exchange messages. 
Siebel Store-and-Forward Messaging Guide Version 7.7 ■ 11
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Overview of Siebel Store-and-Forward 
Messaging Administration
You can administer Siebel Store-and-Forward Messaging from the Administration�Store-and-
Forward screen in a Siebel Web Client.

The Administration�Store-and-Forward screen has the following five views:

■ Message List

■ Store-and-Forward Applications

■ Store-and-Forward Message Timeout

■ Store-and-Forward Message History

■ User List

■ Device Administration

■ Store-and-Forward User Message History

Store-and-Forward Device Administration View
The Device Administration view displays mobile users and their user device�s name, mobile 
application, sync node ID, address type, as well as device address information. This view is populated 
for a user when the user synchronizes a Siebel Handheld application with the Siebel Server for the 
first time.

Table 1 explains the field in the Store-and-Forward Device Administration view.

Table 1. Store-and-Forward Device Administration View Fields

Field Description

Device Name Description of the registered handheld device.

Mobile Application The name of the Siebel Handheld application.

Sync Node ID An ID used by Handheld Sync Server to uniquely identify a device.

Address Type The queuing system used by the Siebel Handheld application, 
which is IBM MQe.

Device Address The device�s inbound queue name. 
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Store-and-Forward Applications View
The Store-and-Forward Applications view displays how the data messages are constructed. The view 
allows you to review Message Objects, Message Components, and Fields. Based on the Siebel 
Handheld application definition, all the information is generated when a user synchronizes his Siebel 
Handheld application with the server for the first time. Not all the data messages listed in the 
Message Objects applet are enabled for Store-and-Forward Messaging. By default, only the 
ActionSHCE data message is enabled for the Siebel Service Handheld application. The ActionSHCE 
message object corresponds to the ActionSHCE business object defined for Service Handheld 
application; its Store-and-Forward Message Components map to the business components defined 
for the ActionSHCE business object; the fields for a particular Message Component map to the fields 
defined for the corresponding business component. 

Store-and-Forward Message Timeout View
The Store-and-Forward Message Timeout view allows you to specify three message timeout 
parameters to make sure messages are delivered in a timely manner. For more information on these 
parameters, see �Setting Outbound Data Message Timeout Parameters� on page 39.

The Store-and-Forward Message History Views
There are two message history views: Store-and-Forward User Message History and Store-and-
Forward Message History. These two views provide administrative information for each inbound or 
outbound message. The Store-and-Forward User Message History View displays the message 
information for a particular user and the Store-and-Forward Message History View displays the 
message information for all the users. These views allow you to view such characteristics of inbound 
or outbound messages as the unique message ID, the application that was used for the message, 
the message direction, the time a message was sent or received, the message size, the message 
status, and so on. From these views, you can track all the inbound and outbound messages for any 
user in your system and use this information to troubleshoot or monitor the application or system 
usage.

Overview of Siebel Store-and-Forward 
Messaging in the Siebel Handheld 
Applications
Siebel Store-and-Forward Messaging is set up for Service Handheld Application and can be 
configured for other Siebel Handheld applications. To set up Store-and-Forward Messaging for a 
Siebel Handheld application, see �Process of Setting Up Siebel Store-and-Forward Messaging on a 
Siebel Handheld Application� on page 43.
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Using Store-and-Forward Messaging 
with the Siebel Service Handheld 
Application
If a Siebel Service Handheld application is enabled with Store-and-Forward Messaging, three icons 
appear on the top-right corner of the screen. They are the Inbound Message Icon, Asynchronous 
Query Icon, and Outbound Message Icon. Figure 3 displays the Store-and-Forward Messaging and 
Asynchronous Query icons.

■ Inbound Message Icon. As soon as an inbound message arrives at the Siebel Handheld 
application, a beep sound sounds and the Inbound Message icon starts to blink. Tapping the icon 
stops the icon blinking and opens the Wireless Alerts List view, which displays the inbound 
messages received by the application in reverse chronological order. When the inbound message 
icon flashes, it means that the information delivered by the message has been stored in the local 
database of the application.

■ Asynchronous Query Icon. For more information, see �Overview of Asynchronous Query on the 
Handheld Device� on page 15. 

Figure 3. Detail of Siebel Store-and-Forward Messaging and Asynchronous Query Icons

Inbound message icon

Asynchronous Query icon

Outbound message icon
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■ Outbound Message Icon. As soon as an outbound message is created and inserted into a user's 
outbound queue on his device, the icon begins blinking. The icon stops blinking when all the 
messages in the user's device outbound queue have been delivered to the server inbound queue.

For example, an activity can be dispatched to a Service Handheld user with Store-and-Forward 
Messaging. Once the activity arrives at the user�s Siebel Handheld application, a beep sounds 
and the Inbound Message icon starts flashing. The user taps the icon to open the Wireless Alerts 
List view, which provides a list of alerts indicating that inbound messages have arrived at the 
device and the time when the messages were received. Closing the window navigates the user 
back to the previous screen or view. If the user makes an update to an activity on the Service 
Handheld application, changing the activity status, for example, a message is created and 
inserted to the user's outbound queue on the device and the Outbound Message Icon starts 
flashing. As soon as the outbound message is delivered to the server inbound queue, the 
Outbound Message Icon stops blinking.

NOTE: After a user performs a handheld synchronization, all the data in the Wireless Alerts List view 
is removed. Figure 4 displays the Wireless Alerts List view.

Overview of Asynchronous Query on the 
Handheld Device
Asynchronous Query allows a Siebel Handheld application user to access data not available in the 
Siebel Handheld application's local database. Asynchronous Query utilizes Siebel Store-and-Forward 
Messaging to transmit data, and allows you to access data not available in the Siebel Handheld 
application's local database. If a user cannot find desired information on a Handheld application's 
local data store, the user can send a query in a format of a request message to the target server. 
The server receives the request message, performs the query, and returns the query results in a data 
message to the requesting Siebel Handheld application. Later on, the data message arrives at the 
Siebel Handheld application and its information is inserted into a temporary table on the Siebel 
Handheld application. The user can then review the query results. Asynchronous Query is set up for 
Service Handheld application and can be configured to support other Siebel Handheld applications. 
To set up Asynchronous Query for a Siebel Handheld Application, see �Process of Configuring 
Asynchronous Query for Siebel Handheld Applications� on page 49.

Figure 4. Wireless Alerts List View
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Using Asynchronous Query with the 
Siebel Service Handheld Application
If a Service Handheld application is enabled with Asynchronous Query, you can perform 
asynchronous query for Products, Assets, Orders, and Solutions.

To perform an asynchronous query

1 Navigate to the Find Dialog window by tapping the View menu, then selecting Find.

The Find Dialog appears as shown below.

2 Tap in the Look In field, and select a Find Object from the drop-down list. 

For example, Products, Assets, Orders or Solutions. Depending on the object you select, the 
window displays the relevant find fields. Available find fields for these Find Objects are shown in 
the following table:

3 Enter the query criteria into the available find fields.

Find Object Available find fields

Assets Asset #, Tag #, and Account Name

Products Product Name, Part #, and Location

Orders Order #, Order Date, and Account Name

Solutions Solution Name, FAQ, and Description
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4 Tap either the Find or Server Find button at the bottom of the window. 

Tapping on the Find button performs a query in the Siebel Handheld application's local database 
and the operation returns the query results in the corresponding view. 

Tapping on the Server Find button sends a request message to the server by way of Store-and-
Forward Messaging and displays the following message to the user: "Your request has been 
queued and will be submitted to the server."

5 The Asynchronous Query icon starts flashing when the query results return and arrive at the 
Siebel Handheld application. Tap the icon to open the Async Query List view to display the 
returned asynchronous query results. The list view provides four columns which are listed in the 
following table.

Column Title Description

Search Specification Displays the search criteria entered.

Object Displays the find object that the query is based on.

Sent Time Displays the time when the asynchronous query 
request message is sent to the server.

Received Time Displays the time when the query results arrive at 
the Siebel Handheld application.
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6 Tap any of the buttons in the Async Query List view. 

The buttons are described in the following table:

NOTE: After a user performs a handheld synchronization, all the data in Async Query List view and 
Async Query Results view is removed.

Button Name Description

Details Opens the Async Query Results view, which displays 
the list of records meeting the query criteria. The 
displayed columns of an Async Query Results view 
depends on the find object that the query is based 
on.

Delete Deletes the selected query record.

Delete All Removes all the queries.

Refresh If a query result message arrives while a user is 
viewing the respective view, the user needs to click 
the Refresh button to display the newly received 
message.

OK Closes the Asynchronous Query List view.
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2 Installation and Configuration 
of Siebel Store-and-Forward 
Messaging
The following topics are included in this section:

■ �Prerequisites for Siebel Store-and-Forward Messaging Installation� on page 19

■ �Process of Installing Siebel Store-and-Forward Messaging� on page 19

■ �Process of Deploying IBM MQe Queue Managers� on page 23

■ �Process of Installing and Configuring Handheld Applications� on page 26

■ �About Setting Up Third-Party Wireless Gateway Servers� on page 30

■ �Troubleshooting Store-and-Forward Messaging Setup and Configuration� on page 31

Prerequisites for Siebel Store-and-
Forward Messaging Installation
Perform the basic Siebel server installation according to the instructions contained in Siebel 
Installation Guide for Microsoft Windows: Servers, Mobile Web Clients, Tools. 

Process of Installing Siebel Store-and-
Forward Messaging
To install Siebel Store-and-Forward Messaging you must perform the following tasks:

■ �Enabling Component Groups for Store-and-Forward Messaging� on page 20

■ �Adding Responsibilities for Store-and-Forward Messaging� on page 20

■ �Entering Information for the Store-and-Forward Messaging Application� on page 20

■ �Creating Store-and-Forward Messaging Message Objects� on page 21

■ �Configuring the Message Delivery Timeout Parameter for Store-and-Forward Messaging� on 
page 22

■ �Optional Step: Configuring Store-and-Forward Messaging Workflows� on page 22

■ �Activating Workflows and Reloading Runtime Events for Store-and-Forward Messaging� on page 23

■ �Testing for Internationalization� on page 23
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Enabling Component Groups for Store-and-Forward 
Messaging
Enable the following component groups if they have not yet been enabled. 

■ Handheld Synchronization component group. Used for Siebel Handheld applications.

■ Workflow Management component group. Used for Store-and-Forward Messaging 
workflows.

■ Enterprise Application Integration component group. Used for Store-and-Forward 
Messaging server components such as SMQReceiver.

■ Field Service component group. Used to enable Siebel Field Service related features.

Adding Responsibilities for Store-and-Forward 
Messaging
The following two responsibilities are related to Store-and-Forward Messaging system administrator 
or users. To set up responsibilities, see Security Guide for Siebel eBusiness Applications.

■ SMQ User. Allows access to the Store-and-Forward Messaging administration views and certain 
Siebel Handheld administration views. 

NOTE: You must add this responsibility to the System Administrator user.

■ Field Technician - Handheld. Allows access to the Service Handheld application views. 

NOTE: You must add this responsibility to both the System Administrator and the users of the 
Siebel Service Handheld application. 

Entering Information for the Store-and-Forward 
Messaging Application
You must enter certain required Store-and-Forward application information in the Store-and-Forward 
Applications administration screen.

To enter Store-and-Forward Messaging application information

1 Log into a Siebel Web Client application as a system administrator.

2 Choose Navigate > Site Map > Administration - Store-and-Forward > Store-and-Forward 
Applications.

3 Select the application for which you would like Store-and-Forward Messaging enabled. 

For example, Siebel Service for CE, which is the Service Handheld.
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4 Enter the Inbound Queue Name for the application. 

This name should also be set in the Siebel Handheld application's registry during the handheld 
application installation. Typically, this value is InboundQ.

5 Enter the Queue Info field with the SMQReceiver Subsystem parameter. 

For example, SmqReceiverSubsys.

6 Save the record.

Creating Store-and-Forward Messaging Message 
Objects
You must populate message object and message component fields in the Store-and-Forward 
Applications view. Doing this allows you to review message objects, message components and fields 
for Siebel Handheld applications, or to set up Store-and-Forward Messaging timeout parameters for 
Siebel Handheld applications.

NOTE: This task can be completed by following the steps below, or if the Siebel Handheld application 
has been enabled to use Store-and-Forward Messaging, the first handheld synchronization session 
can populate the data also. 

To manually create Store-and-Forward Messaging message objects

1 Choose Navigate > Site Map > Administration�Store-and-Forward > Store-and-Forward 
Applications. 

2 From the Store-and-Forward Applications drop-down menu, select Create Message Objects.

3 In the Store-and-Forward Generate Objects Popup applet, enter the following values:

4 Click the Generate button.

5 After the generation process, the message objects, message components, and message fields 
are populated.

In this field... Enter this value...

HH Sync Server Name The Siebel Server name where the handheld 
sync server component runs.

HH Sync Component Name The object manager name for the handheld sync 
component. For example, 
ServiceCEObjMgr_enu for the English version of 
the Siebel Service Handheld application. 
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Configuring the Message Delivery Timeout Parameter 
for Store-and-Forward Messaging
You configure the Message Delivery Timeout Parameter to indicate the timeout period of each 
message object. The default value is zero, so you must change this value in order to provide a 
timeout period for your dispatched messages. 

To configure timeout parameter for Store-and-Forward Messaging message objects

1 Choose Navigate > Site Map > Administration�Store-and-Forward > Store-and-Forward 
Message Timeout.

2 In the Store-and-Forward Applications screen, select the Store-and-Forward Messaging 
application.

For example, Siebel Service for CE.

3 In the Message Timeout view, select the desired message object.

For example, ActionSHCE.

4 In the Store-and-Forward Timeout Administration sub-view, create a new record with the 
following values:

■ Type = Message Delivery Timeout.

■ Default Time = desired time frame, for example, 600. The value entered in the Default Time 
field is in seconds.

Optionally, you may also set up the Message Delivery Timeout parameter based on a particular 
field and its list of values.

Optional Step: Configuring Store-and-Forward 
Messaging Workflows
This task is optional. Siebel Store-and-Forward Messaging provides many preconfigured workflows. 
The typical inbound and outbound preconfigured workflows are as follows:

■ SMQ Process User Queue, an inbound workflow

■ SMQ Outbound Activity to Primary Owned By, an outbound workflow

■ SMQ Outbound Activity to One Recipient, an outbound workflow

■ SMQ Outbound Activity to Team, an outbound workflow

You can configure these workflows to meet specific business requirements. For more information on 
Store-and-Forward Messaging preconfigured workflows, see �Siebel Store-and-Forward Messaging 
Sample Workflows� on page 57.
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Activating Workflows and Reloading Runtime Events for 
Store-and-Forward Messaging
After the workflows are properly configured, you need to activate them and reload runtime events:

To activate workflows and reload runtimes events

1 Choose Navigate > Site Map > Administration-Business Process > Workflow Deployment. 

The Repository Workflow Processes screen appears.

2 In the Active Workflow Processes view, query for all the workflow processes beginning with SMQ. 
If any of the workflows described in �Optional Step: Configuring Store-and-Forward Messaging 
Workflows� on page 22 appear, delete them. 

3 In the Repository Workflow Processes screen, query for all the workflow processes beginning with 
SMQ. 

The workflows described in �Optional Step: Configuring Store-and-Forward Messaging Workflows� 
on page 22 are returned by this query. 

4 Activate the Store-and-Forward Messaging workflows one by one by clicking the Activate button.

The workflow "SMQ Outbound Activities to Primary Owned By" is triggered by the runtime events.

5 Reload the runtime events by choosing Navigate > Site Map > Administration-Runtime Events > 
Events, and select Reload Runtime Events from the command menu.

6 After workflows are activated, you can go back to the SMQ Application View to select the inbound 
workflow �SMQ Process User Queue� for the application.

Testing for Internationalization
When creating an application for any language in the Store-and-Forward Applications View, make 
sure the QueueInfo column for each language has the same value. The SMQReceiver is language 
independent, and the default value, SmqReceiverSubsys, should remain this value for the each 
application in each different languages you create.

Process of Deploying IBM MQe Queue 
Managers
An IBM MQe queue manager runs as a separate process from the Siebel Server. This process can run 
either on the same computer hosting the Siebel Server, or on a different computer in the same 
enterprise. Either way, the Siebel Server and the Siebel Handheld application communicate with the 
queue manager using the TCP/IP network protocol. IBM MQe is a Java-based product, and requires 
certain Java configuration be completed. The tasks are as follows:

■ �Configuring a Queue Manager on the Computer Hosting Siebel Server� on page 24

■ �Configuring a Queue Manager on a Computer Other than the Siebel Server Computer� on page 24
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■ �Enabling the SMQReceiver� on page 25

■ �Optional Step: Creating Additional SMQ Subsystems� on page 26

Configuring a Queue Manager on the Computer Hosting 
Siebel Server
A queue manager is a self-contained process and requires a dedicated TCP/IP port to listen for 
connections from the Siebel Server and the Siebel Handheld client applications. 

To configure a queue manager on the computer hosting Siebel Server

1 Install a Java Runtime Environment (JRE) version 1.3.1 or higher if the computer does not have 
one.

2 Update the Windows system path to contain the directory of java.exe and the directory of jvm.dll. 
Usually these are subdirectories of the Java home directory bin, bin\client and bin\server.

3 Open a command window and navigate to the bin directory of the Siebel Server installation.

4 Use the SET command to verify the SIEBEL_HOME environment variable is set correctly.

5 Run the batch file setupqm.bat and follow the on-screen prompts. 

The default values for queue manager name, directory, and port should be applicable for most 
installations. Check with your IT system administrator to make sure that the default listener port 
8082 is available to use. Alternatively, you can specify a different port number.

6 From the Windows Start menu, choose Settings > Control Panel > Scheduled Tasks. 

7 Right-click the Scheduled Task for the queue manager that you just created and choose Run. 

Verify the task's status has changed to Running in the Scheduled Tasks folder window.

Configuring a Queue Manager on a Computer Other than 
the Siebel Server Computer
You can configure a queue manager on a computer that does not host the Siebel Server. This 
computer can be put in the trusted network or in a DMZ. However, the queue manager host computer 
and port must be accessible to all Siebel Handheld clients and the Siebel Server.

To configure this setup, the same steps must be performed on the computer hosting the Siebel 
Server.

To perform set up on the Siebel Server

1 Open a command window and change to the bin directory of the Siebel Server installation.

2 Run the batch file deployqm.bat and follow the on-screen prompts. 

This step produces a directory tree named C:\SiebelSMQ by default.
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3 Copy the C:\SiebelSMQ folder to the computer that will host the queue manager.

To perform set up of queue manager on the target computer 

1 Install a Java Runtime Environment (JRE) version 1.3.1 or higher if the computer does not 
already have an installed instance. 

2 Update the system path to include the directory containing java.exe. 

Usually this is a directory named bin in the JRE installation.

3 Open a command window and navigate to the bin directory that was copied in �To perform set up 
on the Siebel Server� on page 24.

4 Run the batch file setupqm.bat and follow the on-screen prompts. 

The default values for queue manager name, directory, and port should be applicable for most 
installations. Check with your IT system administrator to be sure the default listener port 8082 
is available to use. Alternatively, you can specify a different port number to use from here.

5 From the Windows Start menu, choose Settings > Control Panel > Scheduled Tasks. 

6 Right-click the Scheduled Task for the queue manager that you just created and choose Run. 

Verify the task's status is changed to Running in the Scheduled Tasks folder window.

Enabling the SMQReceiver
SMQReceiver must be enabled after the IBM MQe Queue Manger is set up and running. You must 
enable the SMQReceiver after the Siebel Server starts running. 

To enable the SMQReceiver

1 Open up the Windows command prompt and start the Siebel Server Manager for the Siebel 
Server using the following command:

srvrmgr /g <gateway server> /e <enterprise> /s <Siebel server> /u <userid> /p 
<password>

NOTE: userid and password are the system administrator's user name and password.

2 From the Siebel server manager run the following command once to start the SMQReceiver. 

start task for comp SMQReceiver with 
ReceiverConnectionSubsystem=SmqReceiverSubsys,
ReceiverDataHandlingSubsystem=SmqDispatchSubsys,
ReceiverMethodName=ReceiveDispatch

Input parameters for the SMQReceiver are defined in the named subsystems. The first named 
subsystem defines the parameters necessary to configure an SMQReceiver for receiving 
messages for a single application (see the predefined named subsystem, SmqReceiverSubsys). 
The second named subsystem identifies the workflow for processing the received messages (see 
the predefined named subsystem, SmqDispatchSubsys).
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3 From the server manager, run the following command once to make sure that the SMQReceiver 
starts itself every time the Siebel Server is restarted:

change param DfltTasks=1 for component SMQReceiver

When the SMQReceiver is running, there is exactly one log file SMQReceiver_xxx.log in the Siebel 
server log directory.

Optional Step: Creating Additional SMQ Subsystems
This step is required if you want to run Siebel Store-and-Forward Messaging for more than one Siebel 
Handheld application. Each Siebel Handheld application should have its own subsystems. This step 
allows each application to receive messages in its own queue, independent of all other applications. 
The following steps illustrate how to create additional subsystems for an application that uses an 
inbound queue named InboundFSQ and a workflow named SMQ Process FS User Queue.

To create additional SMQ subsystems
■ From the server manager, execute the following two commands:

create named subsystem SmqFSReceiverSubsys for subsystem SMQRcvSubsys with 

SmqQueueType=MQe,SmqQueueName=InboundFSQ,SmqQueueManagerName=ServerQM,SmqServerPortNumber=8082,

SmqTransportServiceName="SMQ Transport Service",SmqTransportMethodName=WaitForMessage

and

create named subsystem SmqFSDispatchSubsys for subsystem EAITransportDataHandlingSubsys with 

DispatchWorkflowProcess="SMQ Process FS User Queue"

Process of Installing and Configuring 
Handheld Applications
After setting up the Siebel Server and the queue manager, you are now ready to install and configure 
the Siebel Handheld applications to enable Store-and-Forward Messaging. 

To install and configure the Siebel Handheld applications you need to perform the following tasks:

■ �Preparing for Installation of Siebel Handheld Applications� on page 27

■ �Installing Siebel Handheld Applications� on page 28

■ �Setting Up a Network Connection for Handheld Devices� on page 28

■ �Synchronizing and Registering the Handheld Application for Store-and-Forward Messaging� on 
page 29

■ �Optional Task: Tuning Handheld Application Parameters� on page 29
Siebel Store-and-Forward Messaging Guide Version 7.726 ■



Installation and Configuration of Siebel Store-and-Forward Messaging ■  Process of
Installing and Configuring Handheld Applications
Preparing for Installation of Siebel Handheld 
Applications
Prior to installing a Siebel Handheld application on a handheld device, you must first edit and verify 
the setup.ini parameters. Following this step, you may then install the Siebel Handheld application 
on the handheld device. See the Siebel Handheld Administration Guide for the Siebel Handheld 
application you are using. 

NOTE: Store-and-Forward Messaging is supported for Direct Server Synchronization mode, but not 
for Companion Synchronization. 

To verify and edit the setup.ini parameters

1 Open the application�s setup.ini file.

For information on working with the setup.ini file, see the Siebel Handheld Administration Guide 
for the Siebel Handheld application you are using.

2 Change or verify the following parameter:

■ SyncURL = http://[server IP address]/servicece_enu/

The SyncURL parameter is required to specify the URL to perform Siebel Handheld 
synchronization. This value is saved in registry on device. You can find this parameter in the 
[Siebel] section of the setup.ini file. The server IP address must be specified with the Web 
server's IP address.

3 Change or verify the following parameter values in the [Wireless Messaging] section.

■ QueuingSoftware = MQE

QueuingSoftware can be MQE or NONE (if NONE is used, the Wireless Messaging feature is 
disabled)

■ SMQCompression = GZIP

[Optional parameter] SMQ Compression setting. The valid values could be GZIP or blank. If 
this parameter is blank, no compression is applied.

■ SMQEncryption = RC4

[Optional parameter] SMQ Encryption setting. The valid values could be RC4 or blank. If 
blank, no encryption is applied.

If MQE is selected for QueuingSoftware, the following parameters need to be specified:

■ MQeServerQMgr = ServerQM

MQe server Queue Manager name. The default value is ServerQM. It should be the same as 
the subsystem parameter "SmqQueueManagerName" in the subsystem specified in the 
Queue Info field in Store-and-Forward Applications View.
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■ MQeServerQueue = InboundQ

MQe server Queue name. The default value is InboundQ. It should be the same as the 
subsystem parameter "SmqQueueName" in the subsystem specified in the Queue Info field 
in Store-and-Forward Applications View. 

■ MQeServerAddr = [MQe Server Name]

MQe server address. The server domain name or IP address of the machine running the 
Queue Manager. For information, see �Configuring a Queue Manager on the Computer Hosting 
Siebel Server� on page 24. Make sure the domain name or IP address is resolvable from the 
handheld devices in the deployed environment. 

■ MQeServerPort = 8082

MQe Server Port number. The default value is 8082. It should be the same as the subsystem 
parameter "SmqServerPortNumber" in the subsystem specified in the Queue Info field in 
Store-and-Forward Application View. 

If you do not want to enable Store-and-Forward Messaging for a Siebel Handheld application, 
comment out the entire [WirelessMessaging] section in the setup.ini file for the application.

Installing Siebel Handheld Applications
Install the Siebel Handheld applications by following the instructions contained in the Siebel 
Handheld Administration Guide for the Siebel Handheld application you are using. 

Setting Up a Network Connection for Handheld Devices
After installing the Siebel Handheld application on the handheld device, you need to set up a network 
connection for the handheld device so that the device can communicate with the queue manager by 
way of an IP network through the HTTP protocol.

For example, the queue manager is configured on a computer in your company's network. If you plan 
to use Microsoft ActiveSync to connect your device to a laptop and then to the company trusted 
network, or plan to connect the device to the company network directly, follow these steps:

To set up a network connection

1 Tap Start > Settings, then tap the Connections tab.

2 Tap the Connections icon, and then the Advanced tab.

3 Tap the Select Networks button. 

The Network Management screen appears.
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4 Select My Work Network from the first drop-down list, and tap OK.

NOTE: If you plan to connect the handheld device to the queue manager through a wireless 
network, such as a wireless LAN 802.11 network or a wireless WAN network (for example, a GPRS 
or CDMA network), or a VPN, follow the instructions provided by the device manufacturer, the 
wireless modem manufacturer or the wireless carrier.

Synchronizing and Registering the Handheld 
Application for Store-and-Forward Messaging
If you use ActiveSync to connect your device to the Siebel Server to perform handheld 
synchronization, after the synchronization is completed, it is recommended that you turn off the 
device and turn the device back on to set up a new ActiveSync session which performs the initial 
registration/initialization step.

For information on handheld synchronization, see the Siebel Handheld Administration Guide for the 
Siebel Handheld application you are using. 

After handheld synchronization, launch the Siebel Handheld application. The Siebel Handheld 
application registers itself with the Siebel Server through Store-and-Forward Messaging. The 
registration requires that the Siebel Handheld application performs a successful initialization step 
(INIT) with the Siebel Server Handheld Sync component. 

Optional Task: Tuning Handheld Application Parameters
You can find the following parameters in the device registry. They are used by the Siebel Handheld 
application and can be modified. Siebel Client Registry settings are set during the client install. Some 
of their values can be configured by modifying the setup.ini before installation. 

NOTE: Modifying the registry settings for Siebel Handheld after installation is not recommended. It 
is recommended that you modify the setup.ini parameters prior to installation instead. 
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Table 2 describes the Handheld application parameters.

About Setting Up Third-Party Wireless 
Gateway Servers
IBM WebSphere Everyplace Connection Manager 5.0 has been certified with Siebel Store-and-
Forward Messaging. IBM WebSphere Everyplace Connection Manager provides the following features 
and flexibility to deploy Siebel Store-and-Forward Messaging.

■ Additional security over wireless or wired networks

■ Seamless cross-network roaming

■ Reduced data transmission over wireless networks

For more information, see the related documents provided by IBM.

Table 2. Handheld Application Parameters

Parameter Description

SMQPollingInterval (Optional) Time interval, in seconds, that a Siebel Handheld application 
contacts a server queue manager to check for messages. The default 
value is 30 seconds. You may increase or decrease the value by adding 
this parameter in setup.ini or adding the name/value pair through 
device registry settings. If you decrease the value, it causes the 
application to contact the server more often. It means you may get 
messages faster, but application performance could degrade for non-
messaging related operations. 

CAUTION: Change this value only when it is absolutely needed.

MaxReturnedRecords (Optional) The maximum number of records returned by an 
asynchronous query. The default value is 500 records. You may increase 
or decrease the value by adding the name/value pair through device 
registry settings. This value is used by SMQ server to set the search 
result limit. If the number of search result is more than the setting, no 
records are returned. 

SMQRegisterTimeOut (Optional) Timeout for registration acknowledgement. If the application 
registration does not happen during the specified time frame, a 
message box would pop up asking if the user would like to wait longer. 
The default value is 30 seconds. You can change the default value by 
adding this parameter in setup.ini or adding the name/value pair 
through device registry settings. When you are working on a very slow 
network and find a lot of message boxes popping up before a successful 
registration, it is recommended you increase the value. Otherwise, you 
should avoid setting this optional parameter.
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Troubleshooting Store-and-Forward 
Messaging Setup and Configuration
When a problem occurs for Store-and-Forward Messaging setup and configuration, the issue may 
reside on either the server side or the side of the Siebel Handheld application. 

Siebel Store-and-Forward Messaging Server-Side 
Troubleshooting Checklist:
1 Make sure the server queue manager is running. If you run it from the scheduled tasks, its status 

should be running.

2 Make sure the SMQReceiver is running. You can check the running tasks to verify whether the 
SMQReceiver is running from the Siebel Server Manager command line. To check the status of 
the SMQReceiver, use the following command from the Siebel server manager:

list comp SMQReceiver

When the SMQReceiver is running, there should be a log file SMQReceiver(number).log in the 
Siebel Server log directory.
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3 Make sure the queue directory tree on the queue manager host computer is created and the 
Siebel Handheld application has registered.

NOTE: In the example below, <USERNAME> stands for the user name of the handheld 
application user. <ddd> stands for any three digits.

The default directory structure looks like the following: 

xxx\siebsrvr\smq\mqe\ServerQM\Queues\ServerQM 

AdminQ

AdminReplyQ

InboundQ

[InboundQ.<USERNAME>.<ddd>]  // created when the application registers

[<USERNAME>.<ddd>.SFQ] // created when the Siebel server responds to the registration

When a Siebel Handheld application starts the first time, the application sends a registration 
message to the Siebel Server. The registration message first reaches the queue manager's 
InboundQ directory. The SMQReceiver moves the registration message to the 
InboundQ.UserQueueName directory, for example, InboundQ.<USERNAME>.<ddd>. Here, 
<USERNAME> stands for the mobile user name. The registration message is then processed by 
the Workflow Process Manager and a server response message is generated and placed into the 
user's outbound queue, for example, <USERNAME>.<ddd>.SFQ. You can verify whether the two 
directories have been created for a user and whether there are messages over there.

You can check application registration from the Administration�Store-and-Forward screen. Go 
to User List > Device Administration, query for the user and verify whether a device name shows 
up in the applet. After a proper registration, the device address column in the Store-and-Forward 
Device Addresses view shows the device queue name for the particular user.

4 Check messages sent or received on the Siebel server from the Administration�Store-and-
Forward screen. Choose Navigate > Administration�Store-and-Forward > Store-and-Forward 
User Message History, then query for the user and verify whether any message has been received 
from or sent to the Siebel Handheld application.

5 Check message objects are populated in Siebel Store-and-Forward Application View. If they are 
not populated:

a Choose Navigate > Site Map > Administration�Mobile.

b Click Application Administration view tab.

c Select the application name. For example, Siebel Service for CE.

d Click the Setting view tab, perform the following query: SchemaChangeNotification in the name 
field and see if it exists and if the value is: SMQ Message Service. If not, add it and remove the 
hhsync directory under the siebsrvr directory. 

e Restart the Siebel server and try again. 

If message objects are populated, it may be due to some server components not running. 

If no, check the server-side log file to see if there are any error messages.
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6 Examine the log files such as SMQRecevier log files, WfProcMgr log files, or the Siebel Handheld 
application log files to find more information for troubleshooting. You can enable or increase the 
server logging levels using the Siebel server manager commands. The commands are:

■ For SMQReceiver, change evtloglvl SMQMsgSvc=5 for comp SMQReceiver

■ For Workflow Process Manager,

change evtloglvl SMQMsgSvc=5 for comp WfProcMgr

change evtloglvl EngInv=5 for comp WfProcMgr

change evtloglvl StpExec=5 for comp WfProcMgr

change evtloglvl PrcExec=5 for comp WfProcMgr

change evtloglvl ObjMgrSqlLog=4 for comp WfProcMgr

■ For Siebel Service Handheld application

change evtloglvl HandheldSyncLog=5 for comp ServiceCEObjMgr_enu

7 Test the outbound workflow. Choose Navigate > Site Map > Activities > Activity List > All 
Activities, and create a new activity. Step off the record and go back to the activity, assign the 
owner of the activity to the mobile user. This event triggers the "SMQ Outbound Activity to 
Primary Owned By" workflow and a data message should reach the user's Siebel Handheld 
application if the handheld device is connected to the queue manager. Server outbound messages 
are put in the [UserQueueName].SFQ directory temporarily until the handheld device polls for 
the messages. If there is a network connection issue, the messages sit in this directory until they 
expire. The expiry time is specified by the Message Delivery Timeout parameter in the Store-and-
Forward Timeout Administration applet.

8 Sometimes, the workflow runtime events cannot be triggered after activation. Restarting the 
Siebel Server can fix this problem.

9 The Siebel Server components SRProc and SRBroker are essential for Siebel Store-and-Forward 
Messaging. They can fail for many different reasons. Check their corresponding log files, 
SRProc*.log and SRBroker*.log to see if there are any errors.

10 SMQ Receiver must be enabled after the queue manager is set up and running.
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Siebel Store-and-Forward Messaging Server-Side 
Common Error Messages
Error Message: �The implementation DLL 'ssmqMQe' for queuing system 'MQe' could not be loaded." 
In the SMQReceiver log file.

Usually this means the jvm.dll (used by the Java Virtual Machine) is not in the system path of 
the computer hosting the Siebel server. Store-and-Forward Messaging ssmqmqe.dll has a 
dependency on the jvm.dll. If jvm.dll can not be properly loaded, the ssmqmqe.dll will fail to be 
loaded too. You need to make sure the system path includes a directory containing the jvm.dll. 

The SMQReceiver runs separately from the queue manger and embeds a Java Virtual Machine 
within its process. To embed a JVM the SMQReceiver needs to find the jvm.dll, not java.exe, on 
the system path. The jvm.dll should be in C:\<JavaHome>\jre\bin\server\ if you install a full 
Java SDK. If you install only a Java Runtime Environment (JRE) then this path would be like 
C:\Program Files\Java\<JavaHome>\bin\client\. Make sure you include this path in the system 
path of the computer.

The IBM MQe queue manager and its related ServerQM.bat and Scheduled Tasks are Java 
applications so they need java.exe to be either in the system path or explicitly specified. The 
java.exe is typically in the C:\<JavaHome>\bin\ directory.

Siebel Store-and-Forward Messaging Client-Side 
Troubleshooting Checklist
1 Verify that the following parameters are in the setup.ini file. Table 5 lists the default values.

If any of the parameter values do not match the server configuration, modify the setup.ini file 
and reinstall the Siebel Handheld application with the correct parameters.

2 Examine the Siebel Handheld application log file to find more information for troubleshooting. 
For information on working with the log file, see the Siebel Handheld Guide for the Siebel 
Handheld application you are using. 

Figure 5. Parameter values for setup.ini file

Parameter Default value

MQeServerQMgr ServerQM

MQeServerQueue InboundQ

MQeServerAddr [hostname] or IP address of the computer 
hosting the queue manager

MQeServerPort 8082

QueuingSoftware MQE. For IBM MQe only
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Siebel Store-and-Forward Messaging Client-Side 
Common Error Messages
■ Error Message: �Unable to initialize Wireless Messaging. Cannot connect to the server. Please 

ensure that you have an active connection and try again."

Verify that the device has an active network connection by starting a Pocket Internet Explorer on 
the device and check whether the Pocket Internet Explorer can access a server URL, such as 
http://[hostname]/service_enu/s.swe. 

Microsoft ActiveSync is configured by default to disconnect after an ActiveSync data 
synchronization. If you are connecting a device to the server through ActiveSync, follow these 
steps to maintain connection.

■ On the handheld device, navigate to Start > ActiveSync.

■ Tap the Tools menu in the bottom left corner of the screen. 

■ From the Tools menu tap Options.

■ Make sure you�re in the PC tab, then tap on the Options button.

■ Under the heading titled: �When syncing remotely�, tap the Maintain Connection radio 
button. 

Additionally, occasionally, a network connection by way of an ActiveSync session may have 
domain name resolution issues. If this occurs, replace the MQeServerAddr host name with the 
IP address of the computer hosting the queue manager. 

■ Error Messages: "Wireless Messaging registration is pending. Would you like to continue to wait 
for server confirmation." or "Unable to Initialize Wireless Messaging Timed Out while waiting for 
registration response from the server. Please try again or contact your system administrator." 

These two errors usually mean the device is able to send the first registration message to the 
server queue manager, but the Siebel server is not able to pick up the message from the inbound 
queues, generate a response message and send the response message back to the Siebel 
Handheld application. In this case, review the server-side troubleshooting check list to see if 
there is an error recorded in the log files.
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3 Administration of Siebel Store-
and-Forward Messaging
The following topics are included in this chapter:

■ �Overview of Siebel Store-and-Forward Messaging Administration� on page 37

■ �Process of Administering Applications with Siebel Store-and-Forward Messaging� on page 37

■ �Process of Setting Up Siebel Store-and-Forward Messaging on a Siebel Handheld Application� on 
page 43

■ �Process of Configuring Asynchronous Query for Siebel Handheld Applications� on page 49

Overview of Siebel Store-and-Forward 
Messaging Administration
Siebel Store-and-Forward Messaging administration screens allow you to administer mobile users, 
their Siebel Handheld devices, detailed Store-and-Forward Messaging message information, and 
timeout parameters. Store-and-Forward Messaging administration consists of three functional 
components, User Administration, Message Administration, and Message Repository. 

User Administration displays mobile user, user device address, mobile application and message 
information for each user. 

Message Administration displays how messages are constructed and allows an administrator to 
specify three message timeout parameters. 

Message Repository provides key administrative information about each inbound and outbound 
message.

This chapter presents an overview of tasks you perform when administering Siebel Store-and-
Forward Messaging. You administer Siebel Store-and-Forward Messaging from the Administration�
Store-and-Forward screen in a Siebel Web client. 

NOTE: To access Store-and-Forward Administration screens, you must have the responsibility, "SMQ 
User."

Process of Administering Applications 
with Siebel Store-and-Forward 
Messaging
Siebel Store-and-Forward Messaging supports Siebel Handheld applications which run on Pocket PC 
devices. For more information on Siebel Handheld, see the Siebel Handheld Administration Guide for 
the Siebel Handheld application you are using. For more information on supported devices, see 
System Requirements and Supported Platforms on Siebel SupportWeb. 
Siebel Store-and-Forward Messaging Guide Version 7.7 ■ 37



Administration of Siebel Store-and-Forward Messaging ■  Process of Administering 
Applications with Siebel Store-and-Forward Messaging
In the Administration�Store-and-Forward > Store-and-Forward Applications view, the applications 
listed are identical to the Siebel Handheld applications displayed in the Administration-Mobile > 
Application Administration view. If you plan to configure a Siebel Handheld application and enable it 
to run Siebel Store-and-Forward Messaging, perform the following steps: 

■ �Enabling Applications for Store-and-Forward Messaging� on page 38

■ �Administering Messages in Store-and-Forward Messaging� on page 38

■ �Setting Outbound Data Message Timeout Parameters� on page 39

■ �Administering Handheld Devices for Store-and-Forward Messaging� on page 40

■ �Reviewing Store-and-Forward Messaging Message History� on page 41

Enabling Applications for Store-and-Forward Messaging
CAUTION: The following procedure must be performed before the Pocket PC device with the newly 
configured application synchronizes to the handheld synchronization server for the first time.

To enable an application for Store-and-Forward Messaging

1 Chose Navigate > Site Map > Administration-Mobile > Application Administration.

2 Click the Settings view tab, and create a new record with the following information in the Name 
and Value fields:

■ Name = SchemaChangeNotification

■ Value = SMQ Message Service

NOTE: The application now appears in the Administration�Store-and-Forward > Store-and-
Forward Applications view.

Administering Messages in Store-and-Forward 
Messaging
Once a Siebel Handheld application is enabled for Store-and-Forward Messaging, you must 
administer the data message definition from the Administration�Store-and-Forward screen. 

To administer data messages

1 Choose Navigate > Site Map > Administration�Store-and-Forward > Message List, and select an 
application.

2 The following Administration views and sub-views need to be populated for Store-and-Forward 
function:

■ Message Objects. Each data message object is based on a business object defined in the 
Siebel Handheld application. A message object consists typically of a record in the primary 
business component and all the descendant records in its descendant message components. 
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■ Message Components. A message component consists of various fields. Not all field values 
are included in the message components. 

■ Fields. Only the fields displayed in the message fields are constructed in a data message.

You can populate these views manually, or they will be automatically populated during the first 
handheld synchronization process. 

Manually Populating Message Objects, Components, and Fields
For detailed information on how to manually populate these views, see �Creating Store-and-Forward 
Messaging Message Objects� on page 21. 

Automatically Populating Message Objects, Components and Fields
If a Siebel Handheld application has been enabled for Store-and-Forward Messaging and you have 
successfully installed an instance of the Siebel Handheld application on a Pocket PC device, the first 
handheld synchronization process populates the message objects, message components and fields 
automatically. This initial synchronization process may take longer than usual. For information on 
Siebel Handheld application synchronization, see the Siebel Handheld Administration Guide for the 
application you are using.

Setting Outbound Data Message Timeout Parameters
To make sure server outbound data messages are delivered in a timely manner, Store-and-Forward 
Message Timeout view allows you to specify three message timeout parameters. 

■ Message Delivery Timeout parameter. This parameter determines the amount of time, in 
seconds, allowed for a given outbound data message to be delivered before it is timed out. The 
timeout length can be field-value dependent, for example, different activity messages can have 
different timeouts based on the value entered into the activity priority field. A message is 
removed from the user's server outbound queue if it is not delivered within the defined time 
period. Also, the related activity record's status is changed to Dispatch Failed when the system 
is unable to successfully transmit the message to a device.

■ Message Acceptance Timeout parameter. This parameter determines the amount of time, in 
seconds, within which a server outbound data message needs to be accepted or declined by the 
mobile user. This is an application-level parameter and can be used in a customized workflow or 
business process to define proper actions. The timeout length can be field-value dependent. For 
example, by setting values for activities, you can determine the amount of time, within which a 
service technician needs to tap Accept or Decline after a dispatched activity, received through 
Store-and-Forward Messaging, reaches his or her device. 

NOTE: This parameter is currently not deployed by default in the Service Handheld application. 
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■ Start to Send parameter. This parameter determines a time window, in seconds, within which 
a newly created data message may be sent to a Siebel Handheld application. This is an 
application-level parameter. This parameter needs to be associated with a field, such as the 
Planned Start field for Activity. The value setup for this parameter can be used in a customized 
workflow to define delay of an outbound data message. For example, if the parameter is set to 
36 hours, an outbound data message for a new activity can only be sent to a handheld device 
when the activity's Planned Start time is within 36 hours of the current time.

NOTE: This parameter is not currently deployed for the Service Handheld application. 

The values set for all the three message timeout parameters are in seconds.

To set up outbound data message timeout parameters

1 Choose Navigate > Site Map > Administration�Store-and-Forward > Store-and-Forward 
Applications, and select a Siebel Handheld application.

2 Click the Message Timeout view tab, then highlight the message object for which you would like 
to set a timeout parameter. 

For example, the ActionSHCE message object, which is the data message object defined for the 
Action business object.

3 In the Store-and-Forward Timeout Administration subview, click New.

4 Choose a timeout parameter, either Message Delivery Timeout, Message Acceptance Timeout, or 
Start to Send.

5 In the Field Values and Time Out subview, enter the required fields. 

For example, the timeout values can vary for activity records based on the Priority field. See the 
following table for an example: 

If you do not select a field value, the Default Time value set applies to all the records.

Administering Handheld Devices for Store-and-Forward 
Messaging
When a Siebel Handheld application with Store-and-Forward Messaging enabled is launched the first 
time, the handheld device sends a registration message to register itself on the Siebel server. When 
the Siebel Handheld application is started the first time, make sure that the device has a wired or 
wireless network connection with the queue manager and the Siebel server. After the handheld 
device is registered, the mobile user and device information are populated. You can review the 
mobile user and device information from the Administration�Store-and-Forward > User List view. 

Field Value Time

Priority 1 - ASAP 600

Priority 2 - Important 1200
Siebel Store-and-Forward Messaging Guide Version 7.740 ■



Administration of Siebel Store-and-Forward Messaging ■  Process of Administering
Applications with Siebel Store-and-Forward Messaging
To examine information about a registered handheld device

1 Choose Navigate > Site Map > Administration Store-and-Forward > User List.

2 In the Persons list, highlight a user, then click the Device Administration view tab. 

3 Review the information. 

The following table defines the fields in the Device Administration view.

Reviewing Store-and-Forward Messaging Message 
History
You can review message histories in the Store-and-Forward Message History view for all the inbound 
and outbound messages. You may also review an individual user�s inbound and outbound messages 
in the Personal Message History view. These views allow you to access characteristics of an inbound 
or outbound message, including the unique message ID, the application used for the message, the 
message direction - either from server or from client, the time when the message was received or 
sent, the message size, message status, and any error information. You can use this information to 
troubleshoot or monitor application or system usage.

There are two tasks you can perform to review message history. These tasks are listed below:

■ �To review message history� on page 41

■ �To review user message histories� on page 43

To review message history

1 Choose Navigate > Site Map > Administration�Store-and-Forward > Store-and-Forward 
Message History.

Field Description

Device Name Description of the registered handheld device.

Mobile Application The name of the Siebel Handheld application.

Sync Node ID An ID used by Handheld Sync Server to uniquely 
identify a device.

Address Type The queuing system used by the Siebel Handheld 
application, which is IBM MQe.

Device Address The device�s inbound queue name. 
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2 Review the information.

The data in the message history view is generated automatically, and is read-only. The following 
table lists the fields in the Store-and-Forward Message History view.

Field Description

Message ID The message ID in the screen is the row id of the message history 
table.

Transport ID Transport-level ID used by the system.

User ID User login name.

Application Name The name of the Siebel Handheld application.

Direction The direction the message has traveled. Either from Server or From 
Client.

Time Sent Time a message was sent.

Time Received Time a message was received.

Status ■ Pending: The outbound data message has been created but is 
delayed until the specified Start to Send time.

■ Sent: The server outbound message has been sent to the queuing 
system.

■ Server-Received: The server has received the message from the 
Siebel Handheld application.

■ Client-Received: The handheld client application has received the 
message from the server.

■ Overdue-Not Received: The message is not delivered within the 
Message Delivery Timeout and has been removed from the user's 
server outbound queue.

■ Invalid: A message can no longer be generated due to record being 
deleted or reassigned to a different user. The message appears in 
the message table to log the fact that a workflow has been 
initiated, but something was wrong so a message cannot be 
generated.

■ Send Failed: The server outbound message cannot be delivered 
due to a transport error.

Size The message size, as transported to the queuing system, after 
compression.

Original Message Id ID of the corresponding request message if this message is a response 
message.

Error Message content if this is an ERR (Error) type message.
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To review user message histories

1 Choose Navigate > Site Map > Administration�Store-and-Forward > User List > Message 
History.

2 Review the information. 

The table in the previous step describes the fields in the Store-and-Forward Personal Message 
History view. 

Process of Setting Up Siebel Store-and-
Forward Messaging on a Siebel 
Handheld Application
The Siebel Service Handheld application is configured by default to run Siebel Store-and-Forward 
Messaging. 

To set up Siebel Store-and-Forward Messaging on any other Siebel Handheld application, you must 
perform the following tasks:

■ �Preconfiguring the Siebel Handheld Application� on page 43

■ �Adding Store-and-Forward Messaging Views to the Handheld Application� on page 44

■ �Adding Alter Sound User Properties to the Siebel Handheld Application� on page 45

■ �Adding the Siebel Store-and-Forward Messaging Toolbar to the Handheld Application� on page 45

■ �Adding Application Find to the Handheld Application� on page 46

■ �Compiling Changes Made to the Handheld Application� on page 46

■ �Updating the User�s Responsibilities and Views to Use Store-and-Forward Messaging� on page 47

■ �Adding Settings to Enable Store-and-Forward Messaging� on page 48

■ �Setting up the Siebel Handheld Application Setup.ini File for Store-and-Forward Messaging� on 
page 48

■ �Installing the Siebel Handheld Application� on page 49

Preconfiguring the Siebel Handheld Application
There are two steps to follow when preconfiguring your Siebel Handheld application. They are listed 
below:

To modify the Siebel Tools .cfg file 

1 Open the Siebel Tools configuration file: [install directory]\tools\bin\enu\tools.cfg.

2 Make sure the Siebel Tools database connection information is correct. 

3 In the [Siebel] section, verify that ClientConfigurationMode = All.
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4 Save and close the file.

5 Open Siebel Tools.

To preconfigure an application

1 Launch Siebel Tools and navigate to View > Options > Object Explorer. 

2 In the Development Tools Options box, make sure the following items are checked:

■ Applet

■ Application

■ Business Component

■ Business Object

■ Find

■ Screen

■ Toolbar

■ View

■ Workflow Process

3 Click OK.

4 In the Object Explorer, click the Types tab, then click Application. 

5 Query the application list for your Siebel Handheld application.

For example, Siebel HH LS Medical.

Select the application, then from the Application level menu, select Tools > Lock Project.

Adding Store-and-Forward Messaging Views to the 
Handheld Application
The following task details how to add Store-and-Forward Messaging Views to your Siebel Handheld 
application.

To add Store-and-Forward Messaging views to the application

1 In the Siebel Tools Object Explorer, navigate to the Screen object.

2 Create a new record, or copy the SHCE Service Hidden Views Screen and modify it according to 
the steps below. 

3 Add the following views to the hidden views screen created in the previous step: 

■ SHCE Async Query List view
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■ SHCE Wireless Alerts List view

These two views have been created by default and are available for use. You need to configure 
an Asynchronous Query Results view and an inaccessible view for unsupported business 
components in the tasks which follow. Make sure you have added these newly created views into 
the hidden views screen, as detailed in this task. For more information, see �Process of 
Configuring Asynchronous Query for Siebel Handheld Applications� on page 49.

4 In the Object Explorer, expand the Application list then choose Screen Menu Item. Add the newly 
created screen.

Adding Alter Sound User Properties to the Siebel 
Handheld Application
Different sounds can be associated with the five different alert levels by specifying the .wav file in 
the application user properties.

To add alter sound user properties to a Siebel Handheld application

1 In the Siebel Tools Object Explorer, choose Application > Application User Properties.

2 Select your Siebel Handheld application from the Application list. 

For example, Siebel HH LS Medical.

3 Insert the following new records into the Application User Properties list:

■ WiMeAlertMessage_1_Sound

■ WiMeAlertMessage_2_Sound

■ WiMeAlertMessage_3_Sound

■ WiMeAlertMessage_4_Sound

■ WiMeAsyncMessage_Sound

4 Set the value for each user property to the name of a .wav file that exists on your particular 
handheld device. 

Available .wav files are determined by individual device manufacturers. Consult the 
documentation that accompanied your handheld device.

Adding the Siebel Store-and-Forward Messaging 
Toolbar to the Handheld Application
The Store-and-Forward Messaging Toolbar, which appears in the upper right corner of the Siebel 
Handheld application when Store-and-Forward Messaging is enabled, has been configured by default, 
but must be added to the Siebel Handheld application. The toolbar contains the following icons that 
flash when an event has occurred.
Siebel Store-and-Forward Messaging Guide Version 7.7 ■ 45



Administration of Siebel Store-and-Forward Messaging ■  Process of Setting Up Siebel 
Store-and-Forward Messaging on a Siebel Handheld Application
■ Inbound Message Icon. Indicates that a message has arrived at the Siebel Handheld 
application.

■ Asynchronous Query Icon. Indicates that asynchronous query results have been received from 
the server.

■ Outbound Message Icon. Indicates that an outbound message has been placed in the 
application's outbound queue and awaits delivery. 

To add the toolbar to the Siebel Handheld application, you need to perform the following task:

To add the Store-and-Forward Messaging toolbar to the Siebel Handheld application

1 Open Siebel Tools, and in the Object Explorer, choose Application > Toolbar.

NOTE: If you do not see this choice in the Object Explorer, you have either not made the correct 
changes to the tools.cfg file in �To add the Store-and-Forward Messaging toolbar to the Siebel 
Handheld application� on page 46, or you have not checked all the items that need to be exposed 
in �Preconfiguring the Siebel Handheld Application� on page 43.

2 Select your application from the Application drop-down list.

For example, Siebel HH LS Medical. 

3 Insert a new record in the Application Toolbar list with the following value: SHCE Top.

4 Recompile your project.

Adding Application Find to the Handheld Application
Any Find object configured for asynchronous query must be added to the application object. 

To add application find to application

1 In the Siebel Tools Object Explorer choose Application > Find.

2 Select your application from the Application list.

For example, Siebel HH LS Medical.

3 Insert a new record in the Application Find list for the asynchronous queries that you want to 
support.

Compiling Changes Made to the Handheld Application
You must compile changes made to any objects you change or create.

To compile Siebel Tools changes to the Siebel Handheld application

1 In Siebel Tools, select your Siebel Handheld application in the Application list.
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2 Right-click, and select Compile Selected Objects.

3 Click browse to specify the new .srf file to the appropriate location. 

For example, Siebel Industry Applications use [install directory]\objects\enu\siebel_sia.srf and 
Siebel eBusiness Applications use siebel.srf by default.

4 Make sure there are no applications running and that the database icon is not in your status area 
of the system taskbar (if it is, right-click the database icon, and choose Exit).

5 Select the object shown and click Compile.

6 Replace the server .srf file with your newly compiled .srf file.

Updating the User�s Responsibilities and Views to Use 
Store-and-Forward Messaging
You must update and the responsibilities to the newly created or newly altered views.

To update the user�s responsibilities and views for Store-and-Forward Messaging

1 Log into a Siebel Web Client as a system administrator.

2 Choose Navigate > Site Map > Administration-Application > Responsibilities.

3 Add SADMIN and handheld users to the Siebel Handheld user's responsibility by doing the 
following:

■ Query for the responsibility. 

For example, Medical Sales - HH CE.

■ Insert SADMIN, and the user ID of the handheld users in the Users applet.

4 Add the new views to the handheld user's responsibility by doing the following:

■ Query for the responsibility.

For example, Medical Sales - HH CE.

■ Insert the following new records into the Views applet:

❏ SHCE Async Query List view

❏ SHCE Wireless Alerts List view

NOTE: If you cannot insert the new records into the views applet, you can add these new views 
through Site Map > Administration-Application > Views.

5 Query for the SMQ User responsibility, then insert SADMIN into the Users applet. 

6 Select the Organization for the SMQ User responsibility and verify whether the Siebel Handheld 
user's organization is included.

For example, Medical Products MD ENU is the user SADMIN�s organization.
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Adding Settings to Enable Store-and-Forward 
Messaging
New settings are necessary to properly extract the Store-and-Forward Messaging views.

To add settings to enable Store-and-Forward Messaging

1 Choose Navigate > Site Map > Administration-Mobile > Application Administration > Settings.

2 Query for your Siebel Handheld application.

For example, Siebel HH LS Medical.

3 Create the following new Settings records:

For example, the Solution business component, for the SHCE Service application. For information 
on configuring unsupported business components, see �Configuring Unsupported Business 
Components for Asynchronous Query� on page 54. 

For information on entering information for the Siebel Handheld application, see �Entering 
Information for the Store-and-Forward Messaging Application� on page 20. 

Setting up the Siebel Handheld Application Setup.ini File 
for Store-and-Forward Messaging
To enable Store-and-Forward Messaging for your Siebel Handheld application, you need to make 
certain changes to the setup.ini file of the Siebel Handheld application.

To set up the setup.ini file

1 Make any changes to the [WirelessMessaging] section of the setup.ini file as shown in �Preparing 
for Installation of Siebel Handheld Applications� on page 27.

2 Add the settings for the SyncURL, MQeServerAddr, and MQeServerPort parameters. See �To verify 
and edit the setup.ini parameters� on page 27. 

For more information of installing the Siebel Handheld application, see �Process of Installing and 
Configuring Handheld Applications� on page 26. 

Name Value

NoExtractBusComp SHCE Async Query, Sequence = 1

NoExtractBusComp SHCE Async Query Results, Sequence = 2

NoExtractBusComp SHCE Wireless Alerts, Sequence = 3

NoDatabaseBusComp <name of unsupported business component>, Sequence = 1

SchemaChangeNotification SMQ Message Service, Sequence = 1
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Installing the Siebel Handheld Application 
For instructions on installation of the Siebel Handheld application, see the Siebel Handheld 
Administration Guide for the Siebel Handheld application you are using. 

Process of Configuring Asynchronous 
Query for Siebel Handheld Applications
Asynchronous Query has been configured, by default, for the Siebel Service Handheld application. 
Perform the following tasks to configure Asynchronous Query functionality for any other Siebel 
Handheld application.

■ �Configuring the Find Object in Siebel Tools� on page 49

■ �Creating the Asynchronous Query Results Applet� on page 51

■ �Creating the Asynchronous Query Results View� on page 52

■ �Adding Each New View to the Hidden Screens View� on page 53

■ �Adding Each New View to the Hidden Screens View� on page 53

■ �Adding Each New View and Responsibilities to the Application� on page 53

■ �Configuring Unsupported Business Components for Asynchronous Query� on page 54

Configuring the Find Object in Siebel Tools
The Find dialog on the handheld device, which contains the functionality for local find and server find 
(asynchronous query), is configured in Siebel Tools. For information on configuring Find Objects, see 
Siebel Search Administration Guide. 

You start the configuration process by adding a Find object. There are two views for each Find object. 
One view is rendered when a user performs a local find. The other view is for asynchronous query 
only and is based on the business object: SHCE Async Query. 

When the user taps the Details button in the Asynchronous Query List applet, the Siebel Handheld 
application identifies the Find object of the highlighted row and renders the view that is related to 
the SHCE Async Query business object. This view, and its applet, display the asynchronous query 
results for the Find object.

When the user clicks on the Find button (local find) in the Find dialog, the view that is not related to 
the SHCE Async Query business object is rendered. The visibility of this view is used for 
Asynchronous Query as well.
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To configure the Find object 

1 In the Siebel Tools Object Explorer, click Find, then query for the Find object you wish to enable 
for asynchronous query. 

If the Find object does not exist, create a new record. 

Some fields of the Find object are explained in the table below:

To add Find fields

1 In the Siebel Tools Object Explorer, click Find > Find Field.

The available fields in the Field property associated with the business component of the applet 
specified in the Applet property. For example, the Order-SHCEService Find object uses SHCE 
Service Orders List Applet - Find. The business component of that list applet is Order Entry - 
Orders.

The necessary fields for the Find Field are explained below.

To add Find views

1 In the Object Explorer, click Find > Find View.

Property Description

Applet Describes the applet that is rendered when the user clicks on the local Find 
button. When a user performs a local find (by tapping the Find button in the 
Find dialog on the Siebel Handheld application), the user is navigated to the 
specified applet and a local query is performed.

Display Name The name that is displayed in the Find dialog Look In drop-down list. For 
example, by default the Siebel Service Handheld application contains 
Orders, Assets, Products, and Solutions.

Field Description

Display Name The name displayed in the Find Dialog Look In drop-down list. For 
example, the default Siebel Service Handheld contains Orders, Assets, 
Products, and Solutions.

Display in Entry Indicates that the field is available in the Find Dialog when the parent 
Find Object is selected in the Look In drop-down list. In other words, the 
user can enter query text for this field.

Display in Results Indicates that data is retrieved for this field during an asynchronous 
query. This property is only relevant for asynchronous query (server 
find), as the data returned for local find is dictated by the available 
columns in the applet specified in the Applet property of the Find object.
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2 Add the view.

NOTE: Only two views should be added: one for local find, and one for asynchronous query 
(server find). 

For Local Find. A view that contains the applet specified by the parent Find Object Applet 
property should be added. When a local find is performed in the client Find Dialog, the user is 
navigated to this view. For example, if a local query is done on Orders in the Service Handheld 
application, the user is navigated to SHCE Service Asset List View - Find, which contains the 
applet SHCE Service Assets List Applet - Find that was specified in the parent Find Object local 
properties. Note that the visibility of this view is used by the asynchronous query feature when 
requesting server information. For example, if the visibility is designated as Personal, then the 
server query only returns Personal results.

For Server Find. When a user taps the Asynchronous Query icon in the upper right corner of 
the screen, the SHCE Async Query List view appears. The SHCE Async Query List view has been 
configured and is available for use. From the SHCE Async Query List view or applet, the user can 
highlight a query and tap the Details button. This operation brings up an Asynchronous Query 
Results view or applet, which should be configured and added into the application. For 
information on configuring the Asynchronous Query Results applet and view, see �Creating the 
Asynchronous Query Results Applet� on page 51 and �Creating the Asynchronous Query Results 
View� on page 52. 

Creating the Asynchronous Query Results Applet
Once the Find object has been configured, it is necessary to create the applet that is used to display 
the results to the user. When the user clicks the Server Find button in the Find dialog box, a record 
is added to the SHCE Async Query business component, and can be viewed in the SHCE Async Query 
List view by clicking the Asynchronous Query icon. The Asynchronous Query icon is only visible when 
Store-and-Forward Messaging is enabled. See �Using Asynchronous Query with the Siebel Service 
Handheld Application� on page 16 for an example. When the server returns the results of the 
asynchronous query, they are placed in the SHCE Async Query Results business component, which 
is a child of SHCE Async Query business object. The user can access these results by tapping the 
Details button in the SHCE Async Query List view. 

To create an applet to display asynchronous query results

1 Create a new list applet, or copy an existing Asynchronous Query Result applet, such as SHCE 
Service Async Query Results Asset List applet.

The new or copied applet must have the following attributes:

■ The applet must be a list applet.

■ The business component property must be SHCE Async Query Results. In other words, all 
results applets are based on this business component.

■ This applet should have the following fields checked:

❏ No Insert

❏ No Delete
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❏ No Update.

■ When mapping applet fields to business component fields (Data 1, Data 2, � Data 6 of SHCE 
Async Query Results) it is necessary to make sure that the business component field 
corresponds the correct Find object field. Returned asynchronous query results are populated 
in sequence of the Find object fields that have the 'Display in Results' flag set. In other words, 
Data 5 maps to the 5th find object field with the flag. See the following example:

2 Use the Edit Web Layout feature in Siebel Tools to configure the user interface. 

This determines the order the query result columns appear in the user interface.

Creating the Asynchronous Query Results View
If an Asynchronous Query Results view has not been created, create it by following these steps.

To create the view object

1 In the Siebel Tools Object Explorer, navigate to the View object and create a new record using 
the guideline listed below.

NOTE: The property business object for the view needs to be SHCE Async Query.

2 Add the Async Query Results applet created in �Creating the Asynchronous Query Results Applet� 
on page 51 to this view.

Find Field 
Name

Sequence 
Number

Display in 
Results

Display in 
Entry

Data Column 
Map

A 0 Y Y Data 1

B 1 Y N Data 2

C 2 N Y None (not 
displayed)

D 3 Y Y Data 3

E 4 Y Y Data 4

F 5 N Y None (not 
displayed)

G 6 Y N Data 5
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3 Add the following user properties to the view to implement the pseudo popup behavior. Doing 
this makes the view behave like a popup rather than a view. 

See the SHCE Service Async Query Results Asset List view for more information. If you copy the 
SHCE Service Async Query Results Asset List view, make sure you change the fields for the 
Visibility Applet and the Thread Applet and point them to the newly created Asynchronous Query 
Results applet.

Adding Each New View to the Hidden Screens View
A screen that contains the SHCE Async Query List applet as well as the SHCE Wireless Alerts List 
view should already be added to the Application > Screen Menu Item in the Tools Object Explorer for 
your application. The new views should be added to this screen. By adding the screen in Application 
> Screen Menu Item, the definitions will be extracted during the synchronization process. 

NOTE: To have the screen appear in the dropdown screen menu, you have to add the screen to the 
Application > Page Tab. However, since the default buttons provide navigation to the default views, 
this hidden screen is excluded from the Page Tabs.

For an example, see the SHCE Service Hidden Views Screen.

Adding Each New View and Responsibilities to the 
Application 
You can perform this task by running the dedicated client with the /editseeddata switch or by logging 
into a Siebel Web Client as a system administrator. 

To add the new views

1 Choose Navigate > Site Map > Administration-Application > Views.

2 Add the new views.

To add the views to the responsibilities

1 Choose Navigate > Site Map > Administration-Application > Responsibilities (or Responsibility 
List).

2 Add the views to the responsibilities.

Name Value

SHCEHideNavBar Y

SHCEHideToolBar Y

SHCEPseudoPopup Y
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Configuring Unsupported Business Components for 
Asynchronous Query
An unsupported business component is one that is not supported on the client but is available on the 
server. You can configure the Siebel Handheld application to support asynchronous query on these 
business components.

The Applet property of the Find object is mandatory and dictates the available Find fields that can 
be added. The available fields are the business component fields of the specified Find object. It is 
therefore necessary to create a new view based on the unsupported business component. For more 
information, see �Configuring the Find Object in Siebel Tools� on page 49. Although this view is 
inaccessible to the end user, it provides the visibility information for the server asynchronous query 
operation. You still need to configure the Async Query Results view separately. In summary, there 
are two Find views per Find object for an unsupported business component. One view, the 
inaccessible view, is based on the Find object's business component (such as Accounts, Contacts, 
Solutions, and Orders), which may be an unsupported business component on the Siebel Handheld 
application. The other view is the Async Query Results view that you configure separately. The Async 
Query Results view is used to display the results of asynchronous queries. 

The following two sections provide an example of configuring an inaccessible applet and view for the 
Solutions business component, which is an unsupported business component in the Siebel Service 
Handheld application.

Example for Configuring an Inaccessible Applet
The following is an example for configuring an inaccessible applet.

Creating a New Applet: SHCE Sales Solutions Find Applet 

To create a new applet

1 In Siebel Tools, create a new applet, then specify the business component to the one you wish 
to use. 

For instance, Solution. 

Make sure that you have built a Web template. It need not contain any fields. The sync server 
will not extract the applet if there is no Web template. For information on Web templates, see 
Siebel Developer�s Reference.

Creating a New View: SHCE Sales Solutions Find View

To create a new view

1 Set the applet from the previous task as the view�s default and only applet.
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2 Specify the visibility on the view that you wish to use for asynchronous queries against this 
business component.

3 Make sure to add this view to the user's responsibility. 

You must run the Siebel client application with the /editseeddata switch, add the view and then 
add the responsibility in the Application Administration view. For information, see �Adding Each 
New View and Responsibilities to the Application� on page 53.

4 Create a new Find object called: Solution-SHCESales. 

See �Configuring the Find Object in Siebel Tools� on page 49.

a Specify the applet as the one defined in the SHCE Sales Solutions Find Applet.

b Choose the fields to expose in entry and in the results. 

5 Follow the instructions in the previous sections to do the following:

a Add the Find object to the application. See, �Adding Application Find to the Handheld Application� 
on page 46.

b Add the view to the hidden screen you created earlier in the application. See, �Adding Each New 
View to the Hidden Screens View� on page 53.

c Add the view to the application list of views and add appropriate responsibilities. 

6 Update synchronization settings to avoid extracting the data for the new view. If this is not done, 
then the data for this unsupported business component will be extracted unnecessarily.

a In the Siebel Web client, choose Navigate > Site Map > Administration-Mobile > Application 
Administration. 

b Choose the name of the application(s) that use this unsupported business component, and select 
the Settings tab.

c Add a new record where the Name property = "NoDatabaseBusComp" and the Value contains 
the name of the unsupported business component.
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4 Siebel Store-and-Forward 
Messaging Sample Workflows
The following topics are included in this section:

■ �About Store-and-Forward Messaging Workflows� on page 57

■ �SMQ Outbound Activity to One Recipient� on page 58

■ �SMQ Outbound Activity to Primary Owned By� on page 59

■ �SMQ Outbound Activity to Team� on page 59

■ �SMQ Process User Queue� on page 60

About Store-and-Forward Messaging 
Workflows
Store-and-Forward Messaging provides four sample workflows to demonstrate its functionality. 
These workflows can be customized to meet different business process requirements. The definitions 
of these workflows can be examined in the Siebel Tools. For more information, see Siebel Business 
Process Designer Administration Guide. 

The three outbound workflows are SMQ Outbound Activity to One Recipient, SMQ Outbound Activity 
to Primary Owned By, and SMQ Outbound Activity to Team. 

The SMQ Outbound Activity to One Recipient is a basic workflow. It is based on the Action business 
object. Its main function is to generate a message, format the message, send the message to a 
server outbound queue, and update the message history table. 

The SMQ Outbound Activity to Primary Owned By workflow uses the SMQ Outbound Activity to One 
Recipient workflow as a subworkflow. This workflow is triggered by the WriteRecordUpdated runtime 
event in the Action business component. If an activity is assigned to a mobile user or an activity 
owned by a mobile user is updated, the workflow sends a data message to the mobile user with the 
updated activity information and its associated data.

The SMQ Outbound Activity to Team workflow also uses the SMQ Outbound Activity to One Recipient 
as a subworkflow. The workflow allows sending the identical activity message to all the service 
technicians on the same team. 

The inbound workflow is SMQ Process User Queue. This workflow picks up server inbound messages 
and process them. 
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SMQ Outbound Activity to One Recipient

As seen in Figure 6, the SMQ Outbound Activity to One Recipient workflow is based on the Action 
business object, and is an outbound workflow defined for a mobile service technician. The workflow 
creates a server outbound data message containing the information about a dispatched activity and 
send the message through the Store-and-Forward Messaging.

The main process properties include Application Name, Message Object Name, and Message 
Recipient. The Application Name and Message Object Name must be defined in the Administration- 
Store-and-Forward > Store-and-Forward Applications view.

This workflow contains the following steps:

1 Create Message History: This step creates a message history record in the message history table 
and sets the message status to Pending. 

2 Calculate Delay: The workflow may be put to sleep if a Start to Send parameter is being specified 
in the Store-and-Forward Timeout Administration view.

3 Generate Data Message: This step takes the message object ID as well as the related business 
object name and extracts the related data to construct a server outbound data message.

4 Format Message: This step takes the data extracted and formats it to a well-formed XML 
document.

5 Send Message: This step sends the XML document into the user's server outbound queue.

6 Wait for delivery ack: This step waits for an acknowledgement from the MQe queuing system, 
which indicates whether the message reaches the targeted handheld device.

7 Check Message Status: This step checks the message status. If the status of the message has 
been changed to Client-Received, the message has arrived at the client side.

8 Dispatch Failure: If the status of the message is something else, this step sets the status of the 
activity record to Dispatch Failure.

Figure 6. SMQ Outbound Activity to One Recipient Workflow
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SMQ Outbound Activity to Primary 
Owned By

As shown in Figure 7, this outbound workflow uses the SMQ Outbound Activity to One Recipient 
workflow as a subworkflow. A runtime event is defined in the start step and is triggered by the 
WriteRecordUpdated event in the Action business component. Every time an activity record is 
updated, the workflow is triggered and sends a server outbound data message to the activity's 
primary owner.

This workflow provides three main process properties to the SMQ Outbound Activity to One Recipient 
workflow.

1 Application Name: set to Siebel Service for CE, which is Service Handheld application.

2 Message Object: set to ActionSHCE, which is the business object enabled for Store-and-Forward 
Messaging for the Service Handheld application.

3 Recipient: set to the "Primary Owned By" field value of an activity record. This value identifies 
the primary owner of the activity.

In addition, a condition of "([Updated By]<>[Primary Owner Id]) AND 
[Status]<>LookupValue('Event Status', 'Dispatch Failed')" is specified on the branch following the 
start step. This condition filters out two undesirable triggering events, the record changes that are 
made by the owner himself, and the changes that are made by the workflow itself because the related 
outbound data messages are not delivered within the Message Delivery Timeout.

SMQ Outbound Activity to Team

As shown in Figure 8, the SMQ Outbound Activity to Team workflow also uses the SMQ Outbound 
Activity to One Recipient workflow as a subworkflow. Some customers may need to send the same 
activity record to all the service technicians on the same team. This workflow shows how it can be 
achieved in the following two steps.

Figure 7. SMQ Outbound Activity to Primary Owned By Workflow

Figure 8. SMQ Outbound Activity to Team Workflow
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1 Get Team Recipients: The input argument TeamField specifies a multivalue field to derive the set 
of recipients. Currently the input argument is set to Owned By.

2 Run Workflow for Team: The input argument ProcessName specifies the workflow to be run for 
every technician in the team. This argument is set to SMQ Outbound Activity to One Recipient.

SMQ Process User Queue

As shown in Figure 9, the SMQ Process User Queue is the inbound workflow, which is triggered to 
pick up server inbound messages from each user individual inbound queue and process them. This 
workflow has the following input arguments in the Process User Queue step, which can be 
customized:

1 Application Name: Set to Siebel Service for CE, which is Service Handheld application. 

2 TimeOut: Time to wait for next inbound message's arrival before the workflow ends. It is 
currently set to five seconds. 

Figure 9. SMQ Process User Queue Workflow
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5 Business Services for Siebel 
Store-and-Forward Messaging
The following lists Business Classes and Business Services used in Siebel Store-and-Forward 
Messaging.

SMQ Message Service
This business service consists of the main functions for Store-and-Forward Messaging. Table 3 lists 
the SMQ Message Service methods, and their definitions.

Table 3. SMQ Message Service Methods

Method Definition

CheckMsgStatus Queries the status field of a given message.

CreateMessageHistory Creates a new record in the message history view.

FormatMsg Formats a message to the proper XML format.

GenDataMsg Creates a data message based on a message object.

GetTimeout Calculates any of the three types of time out parameters for 
a given message object.

PingDevice Sends a Ping message to check whether the device is within 
coverage.

ProcessUserQueue Used primarily in the inbound processing. It processes all 
available inbound messages for a given user inbound queue.

RegisterMobileDevice Handles device registration when a registration message is 
received.

RunWorkflowForTeam Executes a workflow process for a set of users.

SendMsg Sends a properly formatted message to the SMQ transport 
service.

UpdateMsgStatus Changes a message status to a given value.
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SMQ Transport Service
This business service provides an interface between Siebel applications and the IBM WebSphere MQe 
Everyplace queuing system. Table 4 lists the SMQ Transport Service methods and their definitions.

Store-and-Forward Messaging Message 
Protocols
Store-and-Forward Messaging messages fall into two basic categories: messages sent from a Siebel 
Server to a Siebel Handheld application and messages sent from a Siebel Handheld application to a 
Siebel Server.

■ Outbound Server Messages. Generated on a Siebel Server for delivery to a Siebel Handheld 
application.

■ Data Message. Contains record-level data from a single business component and its related 
child business components.

■ Ping Message. Used to determine whether a Siebel Handheld application is connected with 
the Siebel Server.

■ Acknowledgement Message. Indicates that a server inbound message has been 
successfully received and processed.

■ Error Message. Informs the target Siebel Handheld application that a server inbound 
message was not successfully handled on the server side or other error conditions.

Table 4. SMQ Transport Service Methods

Method Definition

GetQueues Gets a list of user inbound queues from the queuing system.

WaitForMessage Waits for a message on an application inbound queue.

MoveMessage Moves a message from an application inbound queue to a 
user inbound queue.

PeekMessage Retrieves a copy of the first message on a queue, the 
message remains on the queue.

ReceiveMessage Retrieves the first message on a queue, the message is 
removed from the queue.

RemoveMessage Removes the first message on a queue.

SendMessage Sends a message to an outbound queue representing a client 
device.
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■ Inbound Server Messages. Generated on a Siebel Handheld application for delivery to a Siebel 
Server.

■ Request Message. Used to request data for a single business component record, or a set 
of specific business component records.

■ Invoke Message. Used to invoke a business service command on the server side.

■ Transaction Message. Specifies record-level insertion, update, association, and deletion 
transactions.
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