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Introduction

This guide covers general administration tasks for initial setup and ongoing
maintenance of Siebel eBusiness Applications.

Specialized applications administration tasks are covered in a number of other
books. See the Siebel Bookshelf CD-ROM.

This guide is primarily useful to people whose title or job description matches one
of the following:

Siebel Application Persons responsible for planning, setting up, and maintaining
Administrators  Sjebe] applications possibly adding new functionality.

Siebel Application Persons who plan, implement, and configure Siebel applications,
Developers possibly adding new functionality.

Database Persons who administer the database system, including data
Administrators loading, system monitoring, backup and recovery, space
allocation and sizing, and user account management.

Call Center Persons responsible for setting up and maintaining a call center.
Administrators  Dyties include managing message broadcasts.

Version 7.5, Rev. C Applications Administration Guide 15




‘ Introduction

How This Guide Is Organized

How This Guide Is Organized

The next four chapters of this guide should be read in the order presented. These
chapters will be of interest to most readers.

The remaining chapters contain stand-alone topics about administering specific
features of Siebel eBusiness Applications. These chapters can be read in any order.

There are two appendixes in this guide. One contains a table of system preferences.
The other contains supporting reference material for the Content Center chapter.
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Additional Resources

Additional Resources

You can find information about other administration tasks in the following books:

Version 7.5, Rev. C

Siebel Marketing Guide

Siebel Field Service Guide

Siebel Forecasting Guide

Siebel Professional Services Automation Guide

Siebel Employee Relationship Management Administration Guide
Security Guide for Siebel eBusiness Applications

Global Deployment Guide

Siebel eSales Administration Guide

Siebel Assignment Manager Administration Guide

Siebel Communications Server Administration Guide
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Getting Started 1

Once the Siebel system is successfully installed, you need to enter license keys so
that you and your organization can access the Siebel products that your
organization has purchased. After the license keys have been entered, you will be
ready to set up your Siebel applications.

Before you can begin to use your Siebel applications, the software listed in Table 4
must be correctly installed.

Table 4. Required Software

Software For Information, See

Siebel Gateway Server Siebel Server Installation Guide
Siebel Server
Siebel Database Server

Siebel eBusiness Applications Application-specific administration guide and
this guide.

Either Siebel Dedicated Web Client or Siebel Web Client Administration Guide or
Siebel Tools Siebel Tools Reference

Once these Siebel servers and applications are successfully installed, you can
proceed to enter license keys for specific Siebel applications.
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Starting the Application for the First Time

Starting the Application for the First Time

In order to begin setting up your Siebel application, you must log in with
administrative responsibilities. The Siebel database server installation script creates
a Siebel administrator account that you can use to perform administrative tasks.
The default user ID and password are SADMIN and SADMIN (case-sensitive). Your
database administrator may also have created a user ID and password that allows
you to access the Siebel Server and perform the required setup. To set up entities in
the Group Administration view, you must be connected to the Siebel Server; you
will not have full administrative capabilities for this view if you are connected to
the local database or working in a mobile Web client.

NOTE: The responsibility for the SADMIN ID that comes with Siebel applications
cannot be modified. However, you can copy this responsibility and modify the copy.
For more information, see Security Guide for Siebel eBusiness Applications.

You can start Siebel applications from the Siebel Dedicated Web Client or from the
Siebel Web Client. Instructions for both are described below.

TIP: If you have not yet entered any license keys, you must enter the first license key
from the Siebel Dedicated Web Client or from Siebel Tools. For more information,
see “Entering License Keys” on page 24.

To start a Siebel application from the Siebel Dedicated Web Client for the first time

1 From the Start menu, choose Programs and then choose your Siebel application.
2 Enter SADMIN in the User ID and Password fields.

3 In the Connect to field, choose the server database from the drop-down list and
click OK.

For information about the other databases available in the Connect to drop-
down list, see “Selecting a Datasource” on page 30.

4 If a message tells you that there is no valid license key, click OK.
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Starting the Application for the First Time

5 Inthe License Key dialog box, enter the Siebel eBusiness base application license
key and click OK.

For more information about license keys, see “Entering License Keys” on
page 24. If you need to enter additional license keys, see “Entering an Additional
License Key” on page 26.

To start a Siebel application from the Siebel Web Client for the first time
1 Open your Web browser.
2 Go to the URL for your Siebel Web Client.

The login screen appears.

3 Enter SADMIN in the User ID and Password fields and click OK.

NOTE: If a message tells you that you have not been licensed for this feature, you
must enter a valid license key, using either Siebel Tools or the Siebel Dedicated Web
Client, before you can access the application. For more information, see “Entering
License Keys” on page 24.
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Entering License Keys

Entering License Keys

The Siebel license key is generated so that your organization's users can access the
Siebel products that your organization has purchased. The license key is a series of
numbers (up to 54 digits). Your organization’s specific license key is included in the
Welcome Package. You must enter this license key before you begin to use the Siebel
product, products, or optional modules that your organization has purchased.
Because the license key resides in the database and not on the client machine,
everyone who accesses the Siebel database uses the same license key.

Your license key activates the screens and views associated with the applications
and modules that your organization has purchased. If you have been assigned
multiple license keys, their effect is cumulative, as you enter them.

Customers upgrading from earlier versions of Siebel software may notice differences
between the Siebel product and the products listed in the Welcome Package. These
generally reflects changes in naming and bundling of Siebel products. For example,
a functionality that was previously sold separately might now be bundled into a
single product, or included in a base application, or simply have been renamed. It
is recommended that you run the application itself to verify that all of the
functionality that you expected is there.

Customers using Siebel products which are upgrades from earlier versions may
notice differences between the views in the previous product and the views in the
upgraded product. Reasons for this may include the following:

= The view you are looking for is not available from the application that you have
launched.

= You logged in as a user who does not have responsibilities for the view. In order
to evaluate all of the views available in the product, log in as a Siebel
administrator.

m  The method of accessing the functionality may have changed, or the
functionality may have been replaced by more comprehensive features that
work differently. Consult the Siebel Bookshelf for information on functionality
changes in the latest release.

» The location or name of the screen or view may have changed. You can review
the Site Map or consult the Siebel Bookshelf for information on current view
locations.
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Entering License Keys

However, if you do not see views that you expected, or if you see views that you did
not expect, and feel that it impacts the functionality you have purchased, contact
Siebel Technical Support as soon as possible. If your license key has expired, contact
Siebel Technical Support.

Entering the First License Key

Before you enter the first license key, the following software must be correctly
installed: Siebel Gateway Server, Siebel Server, Siebel Database Server, Siebel
eBusiness Applications, and one of the following: Siebel Dedicated Web Client or
Siebel Tools. After the first Siebel Dedicated Web Client or Siebel Tools installation,
the first user to connect to the Siebel database is required to enter a license key in
order to use the product.

To enter the first license key

1 Start either Siebel Dedicated Web Client or Siebel Tools.

NOTE: You have the choice of entering the first license key in either Siebel
Dedicated Web Client or Siebel Tools. You can enter any Siebel license key in
either Siebel Dedicated Web Client or Siebel Tools.

2 Login as the system administrator and connect to the server database.

Use SADMIN as the login name and SADMIN as the password, and choose
Server in the Connect to drop-down list.

NOTE: If you are the first to log in to Siebel Dedicated Web Client after a new
Siebel installation, you will get the error message “There is no valid license key
in the database.” If you are the first to log in to Siebel Tools after a new Siebel
installation, you will get the error message “No valid license keys were found in
the database.”

3 If you are logged in to Siebel Dedicated Web Client, click OK. If you are logged
in to Siebel Tools, click Add Key.
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Entering License Keys

In the License Key dialog box, enter the Siebel eBusiness base application license
key or the Siebel Tools license key, and then click OK.

CAUTION: Enter only a Siebel eBusiness base application license key or the Siebel
Tools license key. If you enter an optional-module license key without having a
Siebel eBusiness base application license key already entered, an error message
will appear. The error occurs because the Home Page view is required to start
Siebel eBusiness base applications, and Home Page views are not included in
optional module license keys.

Close Siebel Dedicated Web Client or Siebel Tools, whichever you started in
Step 1 on page 25.

Restart the Siebel Server System Service. (For more information, see Siebel Server
Administration Guide.)

Start the Siebel application associated with the license key that you entered.

For example, if your license key is for Siebel Sales, start Siebel Sales; if your
license key is for Siebel Tools, start Siebel Tools.

NOTE: After entering the initial license key, if you discover that you made an error
when entering the license key, you can correct the license key in the Key Value field
in the Application Administration screen, License Key view.

Entering an Additional License Key

After entering the initial key, you can add or delete license keys through Siebel
eBusiness Applications as long as your Siebel user responsibility includes the Siebel
License Key view. You can do this immediately if your purchase included more than
one license key, or you can add license keys as your organization purchases more
Siebel applications or optional modules.

To enter an additional license key using a Siebel application

1 Start the Siebel application—for example, Siebel Call Center. You can use Siebel

Web Client or Siebel Dedicated Web Client.
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Log in as the system administrator and connect to the server database.

Use SADMIN as the login name and SADMIN as the password, and choose
Server in the Connect to drop-down list. If the system administrator’s password
has been changed, use the current password.

From the application-level menu, choose View > Site Map > Application
Administration > License Keys.

Add the new license key:

a In the License Keys list, click New to create a new record.

b In the new record, enter one license key in the Key Value field.
¢ Repeat Step a and Step b for each license key to be entered.
Close the application.

Restart the Siebel Server System Service. (For more information, see Siebel Server
Administration Guide.)

Start any Siebel application or module associated with a license key you have
entered.

If you have any problems installing your license keys, contact Siebel Technical
Support.

To enter an additional license key using Siebel Tools

1
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Start Siebel Tools.

NOTE: To enter additional license keys in Siebel Tools, you must have first entered
the Siebel Tools license key.

Log in as the system administrator and connect to the server database.

Use SADMIN as the login name and SADMIN as the password, and choose
Server in the Connect to drop-down list. If the system administrator’s password
has been changed, use the current password.

Choose Help > Technical Support from the menu bar.
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4 In the Technical Support Information dialog box, click License Key.

5 Add a license key:

a In the License Keys dialog box, click Add Key.

b In the new record, type in one license key and then click OK.

¢ Repeat Steps a and b for each license key to be entered.

6 Close Siebel Tools.

7 Restart the Siebel Server System Service. (For more information, see Siebel Server
Administration Guide.)

Start any Siebel application or module associated with a license key you have

entered.

License Key Fields
Table 5 describes the files in the license key record.

Table 5. Fields in the License Key Record

Field

Key Value

Status

MaxUsers

Expires

Description

The license key from your Welcome Package. Add a new record for
each license key.

Automatically entered based on the license key.
OK means the license key has not expired.

Expired means the license key has expired.

Automatically entered based on the license key.

The maximum number of concurrent users allowed in your license
agreement with Siebel Systems.

Automatically entered based on the license key.

The expiration date for the license key in your license agreement with
Siebel Systems.
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Hiding Access to License Keys

There are two ways that you can hide access to license keys: hiding the License Keys
administrative view within Siebel applications and hiding the License Key button
within Siebel Tools.

= Within Siebel Applications. You may want to hide the License Keys view in the
Application Administration screen, in order to discourage unauthorized users
from attempting to change license keys. To hide the License Keys view, remove
it from the responsibility associated with the users who should not have access
to it. Responsibilities control the views to which users have access. For more
information about creating and modifying responsibilities, see Security Guide for
Siebel eBusiness Applications.

= Within Siebel Tools. You may want to disable the License Key button, found in the
Technical Support Information dialog box (available from the Siebel Tools Help
menu), in order to discourage unauthorized users from attempting to change
license keys. You can disable the License Key button by selecting the Siebel
Administrator responsibility and deleting the Edit License Key view.
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Selecting a Datasource

When you start a Siebel application from the Siebel Dedicated Web Client, you
specify the datasource to which you want to connect.

The following databases are potentially available to administrators and end users:

m  Local. Resides on your local computer. Can be synchronized with the corporate
database. Typically stored on a laptop computer and used by mobile users who
are not connected to a server when working.

= Server. This is your enterprise server database.

= Sample. A database of sample data, stored on your workstation. Using this
database, you can experiment with a Siebel application without risk of damaging
actual organizational data.

You should always perform system administration tasks against the server database.
Although you can perform these tasks against your local database and synchronize,
doing so has the potential to cause errors, including data conflicts. In addition,
performance problems can result from a large local database, and from routing large
numbers of transactions.

About the Sample Database

Siebel eBusiness Applications include a sample database to use in demonstrating,
evaluating, or experimenting with the Siebel client and Siebel Tools. (For more
information, see Siebel Web Client Administration Guide.)

The sample database includes a number of demo user accounts (SADMIN is one of
these). Each of these has a predefined responsibility that reflects the demo user’s

position within the sample organization. If you log in to the sample database as a
demo user, you can access certain views within Siebel eBusiness Applications based
on the demo user’s responsibility.

You do not need to install server components to run the Siebel sample database.
However, you cannot access the Server Administration screen if the server
component is not running. The sample database cannot be copied to the server data
sources.
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To log on as a demo user, double-click the icon for the listed application in the Siebel
client program group. Applications listed as “Demo” automatically log the indicated
user into the sample database. For the other applications, enter the user ID and
password in the logon dialog box and choose Connect to: Sample. For more
information about the sample database, including a list of demo users, see Release
Notes.

The sample database that ships with the Siebel system has a built-in license key that
includes access to all views and modules for a period of a year from the initial ship
date of the product.
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Seed Data

The enterprise database of your default Siebel application contains some built-in
seed data, such as organization, division, position, responsibility, and employee
records. You can use this seed data for training or testing, or as templates for the
real data that you enter. For more information on seed data, including descriptions
of seed data records, see Security Guide for Siebel eBusiness Applications.

32 Applications Administration Guide Version 7.5, Rev. C



Getting Started

Summary of Applications Administration Tasks

Summary of Applications Administration Tasks

Table 6 summarizes the additional application administration tasks necessary to set
up various Siebel eBusiness applications and optional modules.

Table 6. Application Administration Tasks

If You Want to

Use any base
application (for

example, Siebel Sales
or Siebel Call Center)

Control access to views

or data

Launch a global
deployment

Manage global
accounts

Use Application
Services Interfaces
(ASIs) for accounts,
contacts, or
households

Create catalogs for
data, including
products

Use Presentations,
Proposals, and
Correspondence
functionality
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You (May) Need to Perform

Initial Setup tasks.

Ongoing administration tasks.

Establish a strategy for controlling access to
views and data:

» Establish the business environment (such
as organizations, divisions, territories)

= Add employees

= Assign responsibilities to employees

Locale and language administration tasks.

Account administration tasks: Set up global
account hierarchies.

Set up Web services and activate workflows for
the ASIs.

Create catalogs for products, literature,

solutions and auctions.

Set up the Siebel Document Server, and create
templates.

For More Information, See

Chapter 2, “Initial Setup”

Chapter 3, “Ongoing Application
Administration Tasks”

Security Guide for Siebel
eBusiness Applications

“Setting Up Locales” on page 43

“Setting Up Languages” on
page 87

Global Deployment Guide

Chapter 10, “Global Accounts”

Chapter 19, “Integration Using
ASIs”

Siebel eSales Administration
Guide

Chapter 16, “Proposals”
Chapter 15, “Presentations”

Chapter 14, “Correspondence”
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Table 6. Application Administration Tasks

If You Want to

Manage content with
Content Center

Manage a microsite

Use the calendar to set
up resources, such as
conference rooms,
equipment, and
projectors

Use Assignment
Manager to
automatically assign
tasks to appropriate
users

Use Siebel Marketing

Manage lists of
contacts and prospects

Use Competency
Management System

Use Time Sheets and
Expense Reports

Manage Service
schedules, Service
Assets, Warranties

Manage quotas and
employee or partner
incentive
compensation

Manage orders and the
order process

You (May) Need to Perform

Set up a staging environment, set up content
objects and workflows, and set up content

types.

Microsite administration tasks.

Calendar administration tasks.

Create skills and other criteria.

Marketing administration tasks.

List Management tasks.

Skills and competencies administration tasks

Note: These are different skills than those used
by Assignment Manager.

Time Sheet and Expense Report setup tasks,
such as creating work types.

Service administration tasks.

Incentive compensation administration tasks.

Order administration tasks.

For More Information, See

Chapter 8, “Content Center”

Chapter 9, “Microsite
Management”

Chapter 13, “Calendar”

Siebel Assignment Manager
Administration Guide

Siebel Marketing Guide

Siebel Marketing Guide

Siebel Employee Relationship
Management Administration
Guide

Siebel Professional Services
Automation Guide

Siebel Field Service Guide

Siebel Incentive Compensation
Administration Guide

Siebel Order Management Guide
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Once your Siebel products are successfully installed, you need to perform a number
of tasks to set up and administer the application.

Initial setup tasks are those which must be completed in order for your Siebel
applications to work correctly, and then may be done infrequently, for instance, as
your company grows.

Ongoing tasks are done on an occasional or ongoing basis, and are described in
Chapter 3, “Ongoing Application Administration Tasks.”
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Summary of Initial Setup Tasks

Table 7 summarizes the initial setup tasks and the order in which you should

perform them.

Table 7. Required Tasks During Setup

Task

Add any custom views.

Determine access control strategy
and define business environment
structure.

Enter employee records into
system (database and application)
and determine employee access to
views and data.
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Comments

Custom views are created in Siebel Tools and must be
added to your Siebel application. Custom views
should be added to the Views view before you define
responsibilities. For information about adding views,
see “Adding Views to the Application” on page 38.

For information about creating custom views and
about troubleshooting view visibility issues, see
Siebel Tools Reference.

Siebel applications can be set up to support many
strategies for your company to control access to
views and data. These strategies include methods
such as defining your business environment
structure (organizations, internal and external
divisions, and so on), defining employee positions,
and creating access groups so that specific groups of
people have access to specific views and data.

These decisions should be made early in the
deployment process, so that the strategy can be
implemented during the initial setup.

For more information about controlling access to
views and data, and the procedures for
implementing access control, see Security Guide for
Siebel eBusiness Applications.

Enter employee records after you have defined your
business environment structure. You will need to
assign at least one responsibility to each employee,
and you may also assign organizations, positions, or
other access control parameters.

For more information about entering or deactivating
employee records, see Security Guide for Siebel
eBusiness Applications.
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Table 7. Required Tasks During Setup

Task

Complete employee setup.

Set up locales.

Comments

For information about associating additional
information to an employee record, see “Completing
Employee Setup” on page 39.

Locale Codes and parameters are necessary for a
global deployment. For more information, see
“Setting Up Locales” on page 43.
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Adding Views to the Application

Developers create new views through Siebel Tools. In order for the views to become
available for administrators to work with, you must add them to the Views screen
in the application before you define your business environment.

Example: You want to add an Opportunities view in the Reference screen. In Siebel
Tools, you create the view and name it Reference Opportunities. (For details on
creating views, see Siebel Tools Reference.) In your Siebel application, you follow the
steps below and add the Reference Opportunities view in the View Administration
view. After it has been added in both places, the view can be made accessible to the
appropriate users. For details about controlling visibility to views, see Security Guide
for Siebel eBusiness Applications.

To add customized views to the Siebel application

1 From the application-level menu, choose View > Site Map > Application
Administration > Views.

2 In the Views list, add a new record.

3 Enter the view name exactly as it is defined in Siebel Tools, and a description of
the new view.

You generally do not need to modify or delete views that are already listed. You
would only need to modify a view if its name was changed in Siebel Tools. A view
would need to be deleted only if it no longer existed in the data model schema, or
if you did not want anyone to have access to it. Instead of deleting views,
administrators should remove the views from responsibilities and keep them in the
database.

NOTE: Only visibility-level views can be configured to appear in the Site Map. For
more information, see Siebel Tools Reference.
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Completing Employee Setup

After completing the employee setup procedures described in the Security Guide for
Siebel eBusiness Applications, which are required to allow employee access to the
Siebel application, views and data, you complete employee setup by providing
additional information. This can include the following:

Version 7.5, Rev. C

Assignment Rules. Allows you to see and administer the assignment rules for an
employee. For more information on assignment rules, see Siebel Assignment
Manager Administration Guide.

NOTE: You must be logged on to a server database to use the Employee
Assignment Rules view.

Availability. Used for Siebel Professional Services Automation. Lists the projects
for which an employee is on staff, or for which an employee has been requested.
For more information, see Siebel Professional Services Automation Guide.

NOTE: Employees can also change their availability in the Availability view on the
User Preferences screen. The fields Current Status, Until, and Next Status are for
information only; there is no associated logic.

Exception Hours. Specifies what days and hours an employee is not available.

Utilization. Displays a chart with the monthly and quarterly utilization of the
currently selected employee. Managers use this chart for monitoring
professional services projects and employees. For more information about
professional services, see Siebel Professional Services Automation Guide.

Tools. Defines the tools that field service engineers carry with them or have
access to. It allows a call center person to check whether the engineers have the
correct tools for the jobs they are assigned to.

Job Information. Specifies the job profile, salary, compensation ratio, pay
currency, and location of employee.

Calendar administration. Defines the calendar properties and access for an
employee. For more information about Calendar administration, see Chapter 13,
“Calendar.”
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= Assignment Skills. Defines an employee’s skills and skill items, along with their
level of expertise. Skills can be used as assignment criteria in Siebel Assignment
Manager. For more information about how the Siebel application uses skills, see
Siebel Assignment Manager Administration Guide.

Skills can also be used in the Professional Service Automation product for
managing resources. For information about these types of skills, see Siebel
Professional Services Automation Guide.

= Employee Query. Allows queries to identify employees with particular skills and
expertise.

m Service Details. Provides details about the shift start and end locations, hourly
costs, overtime availability and other details for a service employee.

= Competency. Provides a list of areas in which the employee has some
demonstrated level of knowledge or accomplishment.

m Education. Provides details of an employee’s education history.
m Past Work Experience. Provides details of an employee’s work history.
= Honor/Award. Provides list of honors and awards earned by an employee.

=  Membership. Provides details of an employee’s memberships in various
organizations.

m Certification. Provides details of an employee’s certification.

To complete the employee setup

1 From the application-level menu, choose View > Site Map > User
Administration > Employees.

2 In the Employees list, select the employee for whom you want to add additional
information.
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3 In the More Information form complete any necessary fields. Some of the fields
are described in the following table.

Field Description

Configuration  Specifies which Siebel product or group of software components to
associate with the currently selected employee. For more
information, see Siebel Anywhere Administration Guide.

Available Until May be used to indicate the active period of an employee. Used in
conjunction with the Availability, Overtime Availability, and Next
Available fields.

4 Click any other appropriate view tab.
5 Add a new record, if needed.

6 Enter the appropriate information.
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Assigning Skills

At the levels of organizations, positions, and employees, you can add skills. Skills
are used for assigning employees to certain projects, service requests, and so on.
Skills added to an organization apply to all employees assigned to that organization.
Skills assigned to a position apply only to the employee assigned to that position.
You create skills with Siebel Tools.

Employees can track and update their own skill profiles in the User Preferences
Profile view.

For more information about how your Siebel application uses skills, see Siebel
Assignment Manager Administration Guide.
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Setting Up Locales

A locale is a set of rules guiding how common data is displayed to the user or
received from the user. These rules are used to format data from a database before
displaying the resulting information in output fields on the user interface. Siebel
applications support language and geographical conventions for the display
language of picklists, and formatting of data such as dates, time, numbers, and
currency based on locale settings.

The Locale information is stored in the Locale Table (S_LOCALE). The data in this
table is maintained by the administrator using the Locale Administration view.

The locale with which the Component Object Manager processes are initialized is
determined by the value of the parameter Locale Code. Although this is set during
installation, it may be changed to the locale code of any locale that is preconfigured
with the Siebel application or added by the administrator. The Locale Code
parameter can be set at the Enterprise, Server, or Component level.

A number of locales and their parameters come prebuilt with the standard Siebel
application. You can also create and revise locales in the Locale Administration
view.

After a locale and its parameters are defined, you can create translations for locale
names that will display in the locale pick applet, rather than the three letter
acronym locale code. For example, instead of showing ENU as locale name, the
administrator provides English-United States as a translation for English speakers
and Inglese-Stati Uniti d’America for Italian speakers. Only translated locale names
are exposed to end-users on locale pick applets.

NOTE: Whereas the Siebel Web Clients use the locale settings specified in the Locale
Administration view, the Siebel Mobile Web Client and the Siebel Dedicated Web
Client use the locale settings defined in the client operating system’s regional
settings. [

To create a locale

1 From the application-level menu, choose View > Site Map > Application
Administration > Locale.
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2 In the Locale list, create a new record and fill in the necessary fields.

Some of the fields are described in the following table.

Field

Description

Date Separator

International Dialing
Code

List Separator

Locale Code

Designates the symbol that will be used to separate the
components of the date.

Designates the country codes to display in phone numbers,
suppressing the country code for phone numbers that are in
the user’s locale. For example, if the phone numbers for two
accounts are the following:

s +331-2342 34 56, for an account based in France (+ 33
is the country code for France)

= +16502955000, for an account based in the U.S. (+ 1 is
the country code for the U.S.)

To a user based in the U.S.(locale ENU) the International
Dialing Code value is “USA and Canada (1)”, and the above
phone numbers will display as:

s +331-23423456
= (650) 295-5000

Designates the symbol that will be used to separate
consecutive numbers in a list.

For example:

» Inthe U.S., consecutive numbers are separated by a
comma: 1.23,3.57,4.01

= In France, consecutive numbers are separated by a semi-
colon: 1,23;3,57;4,01

Siebel applications use the three letter acronym (TLA) code
conventions of Microsoft for locale name. In most cases, the
TLA is created by taking the two-letter language abbreviation
from the ISO Standard 639 and adding a third letter as
appropriate to form a unique identifier.

For information on Microsoft codes, see your Microsoft
documentation.
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Description

Locale Name

Long Date Format

Negative Currency
Format

Number Decimal
Separator

Number Fractional
Digits

Number Grouping
Separator

Number Leading Zero

Positive Currency
Format

The naming convention is generally Language Name-
Territory, for example, English-United States, English-United
Kingdom, or French-France.

Not supported.

Specifies the location of the negative sign (-) with respect to
the currency symbols and digits (100).

For example:
s ForU.S. format, ($32.45), select (s100)
»  For British format, -£32.40, select -s100

Specifies the symbol used to indicate the decimal place.
For example:
»  French format: 1 234,34 (comma as decimal symbol)

» U.S. format: 1,234.34 (period as decimal symbol)

Designates the number of digits after the decimal separator.
For example, the number 12.340 has a number fractional of
3.

This applies to data fields of type DTYPE_NUMBER.

Designates the symbol used to group numbers.
For example:

»  French format: 1 234 (space as number grouping
separator)

»  German format: 1.234 (period as number grouping
separator)

= U.S. format: 1,234 (comma as number grouping
separator)

Designates whether to display a leading zero in numbers less
than one. For example, .7 or 0.7.

Specifies the location of the currency symbols with respect to
the digits (100).

For example: for U.S. format, $32.45, select s100.
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Field

Description

Short Date Format

Time AM Designator

Time Leading Zero

Time PM Designator

Time Separator

UI Directionality

Specifies the appropriate shortened date format.
For example:

= International format: yymmdd

» U.S. format: mm/dd/yy

»  German format: dd.mm.yy

The forward slash in the string mm/dd/yy is actually a place
holder. It is replaced with the symbol specified in the Date

Separator field. For example, if the Date Separator value is a
dash, -, then April 10, 2002 will be displayed as 04-10-2002.

Note: If you enter a month number greater than 12, it defaults
to 12. If you enter a day number greater than the number of
days in the month, it defaults to the last day of the month.
For example, if you enter 42/99/03 (U.S. format), the date
defaults to 12/31/03.

Specifies the symbol for designating time between 00:00 and
12:00.

For example: AM, a.m., am

Designates whether to display a leading zero in time fields.
For example:

12 hour clock with leading zero: 01:03 AM, 01:03 PM
12 hour clock without leading zero: 1:03 AM, 1:03 PM
24 hour clock with leading zero: 01:03, 13:03

24 hour clock without leading zero: 1:03, 13:03

Specifies the symbol for designating time between 12:00 and
24:00.

For example: PM, p.m., or pm

Specifies the symbol used to separate the hours from the
minutes.

Designates the direction of the text displayed.
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To create a translation for a locale name

1

From the application-level menu, choose View > Site Map > Applications
Administration > Locale, and select the appropriate record.

Click the Locale Name Translation view tab.

On the Locale Name Translation list, create a new record and fill in the necessary
fields, as described in the following table.

Field Description

Language Designates the language code of the translation of the locale name.
For examples of language codes, see Global Deployment Guide.

Translated The exact translation of the locale name to appear in the picklist for

Name users with the designated language code. For example, for the locale

English-United States:
= With ENU language code, the locale name is English-United

States.
= With ITA language code, the locale name is Inglese-Stati Uniti
d’America.
Description Translated description of this locale.

To edit the current locale

1
2
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Edit the locale record. (See “To create a locale” on page 43.)
To have the edits take effect, restart the Application Object Manager.

(For more information about shutting down and starting an unassigned
component such as an Application Object Manager, see Siebel Server
Administration Guide.)
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Setting Up Satmetrix Survey Reports

NOTE: This section only applies to those who have purchased Siebel Satmetrix
eSurveys or who have purchased surveys directly from Satmetrix Systems.

In order to view Satmetrix survey reports through your Siebel application, you need
to:

m  Add the Account Satmetrix Survey View view to the appropriate user
responsibilities. For information about how to add views to responsibilities, see
Security Guide for Siebel eBusiness Applications.

= Enter the secret key string provided by Satmetrix Systems into the Satmetrix Key
Value system preference. For information about how to change system
preferences, see Chapter 3, “Ongoing Application Administration Tasks.”

m Extend the List of Values for WI_ARG_TYPE as described in “To extend the List
of Values for WI_ARG_TYPE.”

= Set up the symbolic URL for access to the Satmetrix reports server, as described
in “To set up the symbolic URL for access to Satmetrix Reports.”

To extend the List of Values for WI_ARG_TYPE

1 From the application-level menu, choose View > Site Map > Application
Administration > List of Values.
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2 C(Create a new record, and complete the fields as shown in the following table.

Field Value

Type WI_ARG_TYPE
Display Value Satmetrix
Language-Independent Code Satmetrix
Active Yes

Translate Yes

Replication Level All

For more information about adding List of Values records, see Chapter 4,
“Working with Lists of Values.”

To set up the symbolic URL for access to Satmetrix Reports

1 From the application-level menu, choose View > Site Map > Integration
Administration > Symbolic URL Administration.

2 In the Symbolic URL list, select SatmetrixSurvey.

3 Make sure the URL is the URL for the reports server provided by Satmetrix
Systems.

4 1In the Symbolic URL Arguments list, complete the fields, using the following
table as a guide.

Required Argument Append as

Name Argument Type Argument Value Argument  Sequence
EncodeUrl Yes Command FALSE Yes 1
version Yes Constant  Obtain from Satmetrix Yes 2
windowsize  Yes Command WebControl Yes 3

width = 1000

height =500

border=1
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Required  Argument Append as
Name Argument Type Argument Value Argument  Sequence
type Yes Constant acct Yes 4
acctid Yes Field Id Yes 5
acctname Yes Field Name Yes 6
contactid Yes Constant * Yes 7
contactname  Yes Constant * Yes 8
user Yes Profile Login Name Yes 9
Attribute
domain Yes Constant  Obtain from Satmetrix Yes 10
model Yes Constant  Obtain from Satmetrix Yes 1
created Yes Field Timestamp Yes 12
token No Satmetrix  Satmetrix Surveys, Yes 13
CalculateToken

50 Applications Administration Guide Version 7.5, Rev. C



Ongoing Application Administration Tasks 3

This chapter assumes that you have successfully installed your Siebel product and
have completed the tasks in Chapter 2, “Initial Setup.”

The tasks described in this chapter set up defaults that are used throughout your
Siebel application. For some implementations, the default settings provided through
the seed data meet a company’s needs without customization. In other cases,
administrators find it useful to make adjustments to these defaults.
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Setting System Preferences

System preferences control how Siebel applications operate in your environment.
You need to review default settings and modify these as appropriate for your
environment.

For a list of the system preferences in Siebel applications, see Appendix A, “System
Preferences.”

To set system preferences

1 From the application-level menu, choose View > Site Map > Application
Administration > System Preferences.

2 Check that the default System Preference Values are correct in your
environment, or change values for system preferences as needed.
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Setting Up Predefined Queries

Predefined queries (PDQ) automate queries that a user can perform online. Rather
than creating a query, entering criteria, and running the query, the user selects a
PDQ from the Queries drop-down list.

Predefined queries can be private (available only to the person who created them)
or they can be public (available to all the users of the application).

Both public and private predefined and user-defined queries are stored in the
database table S_APP_QUERY.

There are two ways to set up predefined queries:
m Create and execute a query in the usual way, and then save the query.
m Create or modify a predefined query in the Predefined Query screen.

For more information about the syntax of Siebel queries, see Fundamentals and
Siebel Tools Reference.

When setting up queries, remember:

»  The Administrator can define a PDQ using both displayed and nondisplayed
fields.

= You can reference only fields from the current applet’s business component in
your query.

= On occasion, using the wildcard * to find all entries in a field may cause a
performance problem. If it does, use IS NOT NULL instead. For more information
about query operators, see Siebel Online Help.

m Predefined queries are defined on a business object. All screens based on the
same business object will display all the predefined queries created for that
business object.
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Do not query on fields of Siebel field data type DTYPE_NOTE.

NOTE: In the preconfigured application, the records shown on the application home
page are determined by the predefined query Default, which is performed on the
object WebCallCenter Home.

To create a predefined query by saving a query

1
2

Navigate to the screen where you will run the query.

Click the Query button in the applet title bar or select New Query from the applet
drop-down menu.

In the applet that is displayed, enter the criteria for the new query.

Click the Go button and then click Run Query.

The query’s results appear.

From the application-level menu, choose Edit > Query > Save As.

In the Save Query As dialog box, enter a name for the query, and click OK.

The query is added to your list of predefined queries. This query is private, and
only you can view it.

If you want to make the query public:

a From the application-level menu, choose View > Site Map > Application
Administration > Predefined Queries.

b In the Predefined Queries list, deselect the Private field in the record for the
query you just created.

To set up a predefined query in the Predefined Query view

1

From the application-level menu, choose View > Site Map > Application
Administration > Predefined Queries.
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2 In the Predefined Queries list, add a new record and complete the necessary

fields.

Some fields are described in the following table.

Field

Comments

Name
Object

Private

Query

Cache Result

This is the name that appears in the predefined query drop-down list.
The object upon which the query is performed.

Marked if the query is available only to the person who created it.

When you unmark a query to make it public, the other users must
first exit the application and reenter before they can see the newly
public query.

The SQL code for the query.

When you create a query for a field that is a multi-value group, you
can use the EXISTS operator to query nonprimary child records.

If this is Y, the query returns all rows up to the value of the
DSMaxFetchArraySize parameter set for the data source.

For information about setting DSMaxFetchArraySize, see about
modifying Named Subsystems in the Siebel Server Administration
Guide.

Note: Setting DSMaxFetchArraySize to -1 and Cache Result to Y may
cause memory problems for queries returning many rows.

About Multi-Value Group Queries in Siebel Industry Applications
In Siebel Industry Applications, the default behavior of queries in Multi-Value
Group (MVG) fields is set to automatically add an EXISTS statement to every MVG
query. This allows detailed cross-business object queries, such as the following
example from Siebel Pharma:

= Find all the Contacts

m  Who are ranked High in a specific therapeutic class

= Who have not been visited for over a month by any sales representative

m  With a best time to call on Monday afternoon
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This MVG behavior, however, also prevents the following query in an MVG field:
EXISTS (A) AND EXISTS (B).

To disable the EXISTS statement
m Set the Default MVG Exists Query system preference to FALSE.

For more information about changing system preferences, see “Setting System
Preferences” on page 52.
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Setting Up Currencies

You specify the currencies your company uses by:

= Making Currencies Active. If the application includes the currency definitions you
need, you make these currencies active.

= Defining Currencies. If you need additional currencies whose definitions the
application does not include, you must also define these currencies.

NOTE: If you use multiple currencies, you must also set up exchange rates before you
import data that contains foreign currencies and before you use any of the Siebel
currency features.

Making Currencies Active
The application includes more than 30 currency definitions. If your currency is one
of these, you need only mark it as active.

To make currencies active

1 From the application-level menu, choose View > Site Map > Applications
Administration > Currencies.

2 For any currency that you want to make active, click the Active column in the
Currencies list.

3 Enter the Start Date and End Date in the More Info form, to specify the date
when this currency becomes active and the date when it is no longer active. This
step is optional.

Defining Currencies
If your company uses any currencies that the application does not include, you must
define them and mark them as active.

If you modify the definition of currencies, you must reconnect to the application
before the modification becomes visible in other screens or in clear cache. For more
information about clear cache, see “Clearing the Cache” on page 104.
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You cannot delete a currency once you have defined it. If you no longer use it, you

can mark it as inactiv

To define a currency

e.

1 From the application-level menu, choose View > Site Map > Applications

Administration >

Currencies.

2 In the More Info form, add a new record and complete the necessary fields.

Some fields are de

Field

scribed in the following table.

Comments

Code

Name

Issuing Country
Symbol

Scale

Smallest
Denomination

EMU
Triangulation

Active

Start Date

A three-letter code for the currency.
The name of the currency.

The country that issues the currency.
The symbol for the currency, such as $.

The number of places after the decimal used for displaying currency
in the interface. For example, U.S. Dollars has a scale of 2 to
accommodate the cents, so an amount would be displayed as
$10.50. If the scale were 1, this same amount would be displayed as
$10.5.

The smallest unit of currency available. For instance, the smallest
unit of currency for the U.S. Dollar is one cent, or .01 dollars. If there
were no cents, the scale would still be 2, but the smallest
denomination would be $0.05.

Check to indicate that this currency must be converted to other
checked currencies using the EMU Triangulation method.

Indicates whether or not the currency can be chosen by the end
user.

The date when the currency becomes active.
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Comments

End Date

Extended Scale

The date when the currency is no longer active.

The number of places after the decimal used for storing currency
data in the database. If the values in the Extended Scale and Scale
fields are different, results of currency calculations, for instance
conversions or discounts, may be different than expected. This is
because the currency values that are stored in the database are used
for these calculations, rather than the displayed values.
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Setting Up Currency Conversion

This section discusses how to set up exchange rates and includes related
background information. It includes the following topics:

= Setting Up Exchange Rates. You must set up exchange rates used to convert
currencies.

= Understanding the Euro and Triangulation. If a currency is part of the European
Monetary Union, you convert it to other currencies through the Euro.

= Currency Conversion Functionality. The currency conversion rates that you set up
are used by a number of features of Siebel applications.

Setting Up Exchange Rates

After you have set up your currencies, but before you use any currency features or
import data with foreign currencies, you must set up exchange rates that are used
to convert currencies.

If you fail to set up an exchange rate, currency will be converted on a 1:1 basis. This
means that the amount stays the same but the currency symbol changes.

NOTE: To calculate exchanges between currencies, you must set up an exchange rate
twice—one for each currency. For instance, if you want to calculate exchange rates
between U.S. dollars and Japanese yen, you must set up an exchange rate for yen
to dollars, and set up another rate for dollars to yen.

To set up exchange rates

1 From the application-level menu, choose View > Site Map > Applications
Administration > Currencies.

2 In the Currencies list, select the currency for which you want to establish
exchange rates.

3 Click the Exchange Rates view tab.
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4 In the Exchange Rates list, add a new record and complete the necessary fields.

Some fields are described in the following table.

Field Comments
Type Currently, Daily is the only type used.
To Currency The currency to which you are converting the currency selected

in the currencies list.
Exchange Rate The conversion rate.

Exchange Date The date of this conversion rate. When converting currencies,
Siebel applications use the exchange rate whose date is closest
to, but not past, the date of the transaction. Depending on the
accuracy that you need and on how much currency values are
fluctuating, you may want to enter a new exchange rate every
week, month, quarter, or year.

Siebel applications use the Exchange Date only to convert
currencies in transactions in which money has been or will be
received. For example, Quote Item Price has an Exchange Date
field, because it represents money that your company will
receive, and your sales representatives should enter the date
when the money will be received.

Repeat this process to add additional exchange rates.

You must restart the Siebel client or use the clear cache command before any
changes to exchange rates can be seen in your Siebel application. For more
information about clearing the cache, see “Clearing the Cache” on page 104.

The Euro and Triangulation

NOTE: As of January 2002, the Euro Triangulation method for converting between
currencies belonging to EMU members is not needed for present and future
currency exchanges. However, the method is still available in Siebel applications, as
are the old currencies, so that historical data can be maintained accurately. The
following description applies only to historical data needing conversion prior to the
2002 switchover to the Euro for the EMU member countries.
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If a country is a member of the European Monetary Union (EMU), you should
convert its currency to other currencies through the Euro. This is called
triangulation, and it is used whenever either currency being converted has EMU
Triangulation checked.

For example, if you are converting from USD to DEM and DEM has EMU
Triangulation checked, you must set up the conversion rates between US dollars and
the Euro and between the Euro and US dollars. You do not have to check the EMU
Triangulation field for USD. The DEM will be converted to EUR according to the
fixed exchange rate set by the European Monetary Union, and then the amount in
EUR will be converted to USD according the exchange rate you set up.

The EMU Triangulation field is already checked for the following European
Monetary Union member nations: Germany (DEM), Belgium (BEF), Spain (ESP),
France (FRF), Ireland (IEP), Italy (ITL), Netherlands (NLG), Austria (ATS), Portugal
(PTE), Finland (FIM), and Luxembourg (LUF). However, you can check or clear this
field. For instance, if the United Kingdom or Sweden joins the EMU, then you can
check the field for that currency.

To calculate triangulation conversion, the conversion rate is always expressed to six
significant figures. Conversions from one national currency unit into another are
made by:

1 Converting the monetary amount from the national currency unit into the Euro.
2 Rounding the result to not less than three decimal places.

3 Converting the result to the target national currency.
4

Rounding the result to the lowest subunit of the target national currency, such
as pfennig for the German mark or centime for the French franc.

NOTE: The EMU Triangulation field should be checked only for currencies that are
subdivisions of the Euro.

Currency Conversion Functionality
Currency conversions currently occur in your Siebel application in various features.
Some examples follow:

62 Applications Administration Guide Version 7.5, Rev. C



Ongoing Application Administration Tasks ‘

Setting Up Currency Conversion

= Quotes. When you change the currency code of a quote, it will convert the
discount amounts and discount prices.

= Forecasting. When you update forecast information from the opportunity, it will
do a currency conversion from the opportunity currency to the forecast currency
if the currencies are different. When you roll up the forecast lines, it will do a
conversion from the forecast line currency to the rollup forecast currency if the
currencies are different.

= Rate lists. When you change the currency code of a rate list, it will prompt you
for an exchange date and convert the prices of all of the price list items.

= Reports. Here are some examples of reports that support currency conversion:

= Opportunity Pipeline Report by Rep. Opportunity revenues created in different
currencies will be converted in the Total and Subtotal fields to the user’s
default currency.

= Euro Expense Report. If expenses have been created in an EMU currency, all
expenses will be displayed in dual currencies.

= Project Limit Summary Report.
»  Forecasting Reports.
»  Current Quotes Report.

= Charts. The following charts support currency conversion:

= Opportunity Current Opportunity Analysis. Opportunity revenue will be
converted to the user’s default currency if both the opportunity currency and
the revenue currency are different from the user’s default currency.

n Forecast Analysis.
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Setting Up Expense Types

When employees create expense reports, they choose an expense type for each line
item in the report. For examples, when employees travel on business, they might
have to enter line items with expense types Food, Airfare, Car Rental, Hotel, and so
on.

When you set up expense types, you specify what expense types are available to
employees in the drop-down list that they use to choose expense types. You also
specify how these expense types will be categorized and summarized in expense
reports.

You can also create establishments that are associated with these expense types. For
example, if the expense type is Airfare, you might associate establishments with it
such as Air Canada and British Airways. For more information about associating
expense types with establishments, see Siebel Professional Services Automation
Guide.

NOTE: Before you can add expense types and establishments, you must add them in
the List of Values Administration screen so that they can be displayed in the drop-
down list. Add expense types under EXP_ITEM_TYPE, and add establishments
under EXP_ITEM_ESTAB. When you add the expense types and establishments in
the Expense Type screen, make sure they are identical to those in the List of Values
Administration screen. For more details about List of Values administration, see
Chapter 4, “Working with Lists of Values.”

To set up expense types

1 From the application-level menu, choose View > Site Map > Applications
Administration > Expense Types.
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2 In the Expense Types list, add a new record and complete the necessary fields.

Version 7.5, Rev. C

Some fields are described in the following table.

Field

Comments

Expense Type

Report Category

Summary

Enter the expense type that the employee will choose in the
Expense Type drop-down list of expense report line items, such
as Airfare.

Enter a category for this expense type. This category will be used
in summary reports, such as Air/Rail Fare.

Enter a larger summary category for this expense type, such as
Travel Cost. This summary category will be used in summary
reports.
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Setting Up Payment Terms

Payment terms are the different terms that you offer to your customers, such as Net
30 days and Net 60 days. You set up payment terms so that they are available in
your Siebel application, for example in the Quotes screen.

To set up a payment term

1 From the application-level menu, choose View > Site Map > Applications
Administration > Payment Terms.

2 In the Payment Terms list, add a new record and complete the necessary fields.

Some fields are described in the following table.

Field

Comments

Payment Term

Net Days

Description

Discount

Discount Days

Due

Integration ID

Enter a name for the payment term, such as Net 30.

If the payment term requires payment in a specific number of
days after the order date, enter the number of days. Optional

Enter a description of the payment term. Optional.

If there is a discount for early payment, enter the amount of the
discount. Optional.

If there is a discount for early payment, enter the number of days
within which a customer must pay to qualify for the discount.
Optional.

If there is a specific due date for payment, enter the due date.
Optional.

Users should not modify this system field. It is a cross-reference
that links the Siebel application to corresponding payment term
information in the back-office application.
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Setting Up Periods

Periods are time periods that are used in your business, such as Q1 2002 or Jan 2001.
Periods are used extensively in the Siebel application, such as in forecasting, time
sheets, incentive compensation, and expense reports.

Be sure to set up periods far enough into the future that forecasting will work. For
example, the default forecast is for seven months ahead. Therefore, if you keep this
default, you must create periods defined for at least seven months from the current
date for forecasting to work correctly.

After setting up a period, you can associate Period Units with it. Period Units allow
you to define one time unit in terms of another. For example, day periods can be
associated with week periods for use in Timesheets. When a new timesheet is
created, based on a week period, each day in that week is also added to the
timesheet. This functionality requires the day periods to be associated as Period
Units with the week period.

To set up periods

1 From the application-level menu, choose View > Site Map > Applications
Administration > Periods.

2 In the Period Definition list, add a new record and complete the necessary fields.

Some fields are described in the following table.

Field Comments

Period Enter a name for the period, such as Q1 2001.

Closed Select this to indicate that the period has already closed.
Start Enter the start date for the period.

End Enter the end date for the period.

Type Select the type of period, such as month, quarter, or year.
Description Enter a description of the period. For example, this text

appears in the column headers of the Line Items list in the
Time Sheet screen, Line Items view.
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To associate period units with a period

1 From the application-level menu, choose View > Site Map > Applications
Administration > Periods, and select the appropriate period.

2 In the Period Units list, click New.

3 In the Period Units dialog box, select all the period units to associate with this
period, and then click OK.
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Specifying Telephone Formats

Default telephone formats are specified in the List of Values view. You can only have
one default telephone number format per country. The default format is applied
when you enter only numbers, without slashes, dashes, or other formatting
symbols.

Before users enter telephone numbers:

= Set the default country. See “Setting Up Locales” on page 43. The default phone
format is determined by the locale setting.

» Define formats for countries outside the default country. See “Specifying Non-
North American Telephone Formats” on page 70.

If a user enters a telephone number from a country for which the format has not yet
been specified, the telephone number may be formatted incorrectly.

NOTE: If you define any new telephone formats, coordinate with communications
administrators who specify CTI functionality and define dialing filters. For more
information, see Siebel Communications Server Administration Guide.

North American Telephone Formats

The default format for North American telephone numbers is (000) 000-0000. The
telephone formatting logic for North American telephone numbers works as
follows:

= If the user enters 10 digits in a telephone number field, it is formatted as (123)
123-1234.

» If the user enters more than 10 digits, the first 10 digits are formatted as (123)
123-1234, and the rest of the digits are used as the extension number. The user
can enter up to 40 digits.

m If the user enters fewer than 10 digits, an error message appears.

= If the user begins the telephone number with a leading zero, an error message
appears.
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This telephone formatting logic is followed even when the default country is not in

North America.

Specifying Non-North American Telephone Formats
If your users need to enter telephone numbers for countries outside North America,
you must specify telephone number formats for those countries.

To specify non-North American telephone formats

1 Choose View > Site Map > Application Administration > List of Values.

2 Query the Type field for the entry PHONE_FORMAT to see existing telephone

formats.

3 Add a new record and complete the necessary fields.

Some fields are described in the following table. For more field information, see
Chapter 4, “Working with Lists of Values.”

Field

Comments

Display Value

Language-
Independent Code

Enter the format string.

Use the number zero (0) to represent required digits, the
character # to represent optional digits, and other formatting
characters to represent how the telephone number should
appear. Do not include any alphanumeric characters other
than 0.

For example, to format an Australian phone number, which
includes a two-digit area code and a six- or eight-digit number,
use (00) 000# 000#.

You do not need to include characters to represent the country
code in the format. When a user enters a number, the country
code is automatically shown if the default country is different
from the country code.

The maximum number of digits allowed in the format is 12.
Any digits beyond 12 are used as the extension number. For
example, even if the format is 000-000-0000-0000, 14 digits
entered as 12345678901234 display as 123-456-7890-12x34.
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Field Comments
Order Enter the country code of the new format.
Type Enter PHONE_FORMAT or choose it in the drop-down list.

4 TFollow the instructions in “Clearing the Cache” on page 104.

International Telephone Formats

To enter an international telephone number (a telephone number for a country
other than the current default country) in a telephone field, the user must specify
the country by preceding the telephone number with a plus sign (+) followed by
the country code (for example, +44). If the user does not enter a country code, the
default country code is assumed.

After the user indicates the country by entering the plus sign and country code, the
telephone formatting logic for international telephone numbers works as follows:

Version 7.5, Rev. C

If the user enters exactly the same number of digits in a telephone number field
as there are in the telephone format for the indicated country, the entry is
formatted as specified.

If the user enters more than the number of digits in the telephone format for the
indicated country, the first digits are formatted as specified and the rest of the
digits are used as an extension number. The user can enter up to 40 digits.

If the user enters fewer than the number of digits in the telephone format for
indicated country, the entry is accepted without an error message. (This is to
accommodate telephone numbers of different lengths.)

If there is no List of Values telephone format entry for the indicated country, the
number is accepted, but not formatted. No error message is returned.
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Unformatted Telephone Numbers

When you change or add a telephone number format, the existing telephone
numbers are not updated automatically.

CAUTION: When entering telephone numbers, users can enter letters in place of
digits, but computer telephony integration (CTI) features, such as outbound dialing,
do not work for these numbers. Queries for such numbers must include the letters,
not the numeric equivalents. Siebel eBusiness Applications do not detect or warn
users if they enter Q or Z (letters that do not appear on all telephones).

Examples

Table 8 shows how telephone numbers would appear under various circumstances.
In this example, the default country is the United States and the default format is

the North American format, (000) 000-0000. Another format has been entered for
England (country code 44): 00.000-000.

Table 8. Telephone Number Format Examples

User Enters Number Is Formatted As

1234567890 (123) 456-7890

1234567890123 (123) 456-7890 x123

123456 Error message: “Invalid data has been entered.”
+4412345678 +44 12.345-678

+441234567890 +44 12.345-678 x90

+4412345 +44 12345

+2512345 + 2512345

20+4412345678 20 +4412345678 (you see the ‘2’ and the ‘0’)
20HelloWorld 20HelloWorld (you see the ‘2 and the ‘0’)

The telephone format has no effect on sort order.
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When performing a query on a telephone number, do not include any format
characters such as (,), -, ., X, or spaces.

You can query for only country 61 by typing + 61* but you cannot query for only
North American telephone numbers this way, because + 1* returns all telephone
numbers. To query for North American telephone numbers, use not |ike +*
instead.

Table 9 gives examples of how to query telephone numbers.

Table 9. Querying Telephone Numbers

Desired Query Result Query Criteria

(123) 456-7890 1234567890

+61 (123) 45.67.89 x0 + 611234567890 (if 61 is defined as a
country code)

Country code 61 telephone numbers +61*

All telephone numbers +1*

415 area code numbers (North America only) 415*

Null telephone numbers is null
415 area code or null (North America only) 415* or is null
(800) SKY-PAGE 800SKY*

When the user performs a query using a telephone number, the country code of the
default country automatically prefixes the query (unless the default country is in
North America, in which case no prefix is added). For example, if the default
country is Germany, and the user types “0181” in the telephone field of a query, the
German country code (+49) is added to the query (that is, +49*0181*).

To find a number for a country other than the default country, the user must specify
the country code in the query. To avoid limiting the query to one country, the user
must refine the query and remove the country code portion of the query
specification.
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To see a demonstration of this behavior, look at the Contacts screen. Every number
for a country other than the default contains a “+n” at the beginning, while every
number for the default country code appears as local (no +). Numbers that have
the “ +n” require explicit queries (country code plus number) while local numbers
are returned normally.

Importing Information with EIM

Siebel Enterprise Integration Manager (EIM) manages the exchange of data between
Siebel database tables and other corporate databases. When you use EIM to import
information that includes international telephone numbers, the numbers are
handled as described in the previous sections.

For more information about EIM, see Siebel Enterprise Integration Manager
Administration Guide.
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Setting Up Pager Companies

Pager companies can be set up so they are available from the File > Send > Page
mentu.

To set up a pager company

1 From the application-level menu, choose View > Site Map > Application
Administration > Pager Companies.

2 In the Pager Companies list, add a new record and complete the necessary fields.

NOTE: The pager companies you use to send pages must support Telocator
Alphanumeric Protocol (TAP), which is an industry standard for sending
alphanumeric pages.

Version 7.5, Rev. C Applications Administration Guide 75



‘ Ongoing Application Administration Tasks

About Date Formats

About Date Formats

For the Siebel Web Client the display format for date and time is determined by the
locale settings of the application server. For more information, see “Setting Up
Locales” on page 43.

For the Siebel Dedicated Web Client and the Siebel Mobile Web Client, the date
format is determined by the specification in the client computer’s operating system.

When a user creates a query using a date field, the user must use the appropriate
date format.
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Setting Up ZIP Codes

ZIP Codes are used to look up address attributes (City, State, and so on). They are
also used to look up nine-digit postal codes based on the street address. Siebel
eBusiness applications ship with a table of United States Postal Service ZIP Codes,
and the table is available for customer use.

To add a ZIP Code

1 From the application-level menu, choose View > Site Map > Application
Administration > ZIP Code Administration.

2 In the ZIP Geocodes list, add a new record.

3 Complete the necessary fields.
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Administering Global Time Zone Support

The time zones records that are shipped with Siebel applications as seed data
include the 74 world time zones. These are the same time zones used by Microsoft
in its operating systems. Use the Time Zone administration view to:

» Edit the text descriptions of time zones and their abbreviations

m  Manage the active status of time zones to control which time zones are available
to end users for use in the applications

= Manage multilingual translations to control how time zone information is
displayed to users in multiple languages

Tasks for administering time zones include:
= “Modifying Time Zones” on page 78
= “Maintaining Translations of Time Zones” on page 79

For more information on global time zone support, see Global Deployment Guide.

Modifying Time Zones

You will rarely need to modify a time zone’s regional settings. However, you may
want to modify other time zone settings such as the display name or daylight
savings rules, as these occasionally change.

NOTE: You cannot add or delete time zones.

To modify time zone settings

1 From the application-level menu, choose View > Site Map > Application
Administration > Time Zone Administration.

2 In the Time Zone list, select the time zone record you want to modify.
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3 Modify the fields as necessary.

Some fields are described in the following table.

Field Description

Name Name of time zone.

Standard Abbreviation The abbreviation for the time zone.

UTC Offset Offset, in minutes, from Coordinated Universal Time (UTC)
when daylight savings is not in effect.

DST Abbreviation The abbreviations for daylight savings time (DST).

DST Bias Incremental DST offset, in minutes, from UTC when DST is

not in effect.

DST Start Ordinal Part of the rule that determines when DST starts. For
example, if the rule is the first Sunday in April, First is defined
in this field.

DST Start Day Part of the rule that determines when DST starts. For
example, if the rule is the first Sunday in April, Sunday is
defined in this field.

DST Start Month Part of the rule that determines when DST starts. For
example, if the rule is the first Sunday in April, April is
defined in this field.

DST Start Time Start time for DST.

Maintaining Translations of Time Zones
You maintain translations of the text-based fields for each time zone using the Time
Zone Administration view.

To maintain translations of time zones

1 From the application-level menu, choose View > Site Map > Application
Administration > Time Zone Administration.

2 In the Time Zone list, select the time zone you want to translate.

3 In the Time Zone Translation list, add a record and complete the necessary
fields, including the translation of the Name field for the selected language.
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4 Repeat Step 3 for each language required for translation.

Date and Time Stamps

The date and time used for time-stamping records are obtained by the Siebel Server.
When a remote user runs the Siebel client in disconnected mode, the Siebel Server
runs on the user’s machine and takes the date and time from that machine.

If global time zone support is enabled, the server converts the date and time value
to UTC.
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Setting Up Email, Fax, and Mail Accounts (Contact Us)

Sales people use the Contact Us screen to answer questions and provide contact
information to customers. If your organization uses Siebel eService, your customers
can access this information directly from a Contact Us page on your Web site.

Creating a Contact Us Account
To help your sales people provide information on a chosen topic, you can create
different accounts, such as Technical Support, Shipping, and Sales.

To add a Contact Us account

1 From the application-level menu, choose View > Site Map > Application
Administration > Contact Us.

2 In the Email, Fax and Mail Accounts list, add a new record.
3 In the More Info form, complete the necessary fields.

Some fields are described in the following table.

Field Description
Account Type Choose the Contact Us type.
Access List Indicates which employees can view the Contact Us account.

Adding Email Addresses and Subjects

If your organization uses Siebel eService, any email addresses you include in
Contact Us accounts appear on a Contact Us page on your Web site. You can create
default email subjects that are added to the user’s Subject line when the user sends
email through your Web site.

For more information, see Siebel eService Administration Guide.
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Using Keyboard Accelerators

Keyboard enablement allows users to operate the Siebel employee applications
using sequences of keystrokes as an alternative to the mouse for executing
commands and navigating through the application. This is accomplished through
the use of keyboard accelerators, specific sequences of keystrokes that are mapped
to commands within the Siebel application environment. Typically, these key
sequences are combinations of the Ctrl, Alt, and Shift keys, along with standard
alphanumeric keys.

A full set of keyboard accelerators ship with the Siebel employee applications.
Accelerators are defined in Siebel Tools and are fully configurable, although care
should be taken when modifying accelerators.

Much of the default keyboard enablement provided natively by Web browsers is
also available for use in the Siebel applications. For example, users can navigate
sequentially through enterable fields within the application views with the Tab key.

For example, keyboard accelerators are provided for the following commands:

= Record manipulation: New Record, Delete Record, Copy Record, Edit Record,
Save Record, Undo Record

= Query management: New Query, Execute Query, Refine Query, Save Query As

= Record navigation: Next Record, Previous Record, Next Page, Previous Page
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Keyboard enablement is available in two modes: extended mode and basic mode.
Extended mode keyboard enablement gives maximum flexibility in defining
accelerators since any key sequence may be mapped to Siebel commands. However,
extended mode keyboard accelerators may not be available to all users. Basic mode
keyboard enablement is accessible to any user running the Siebel applications in
High Interactivity mode. Each accelerator defined in the Siebel Repository can be
specific to one keyboard enablement mode, or it can be common to both modes. For
a list of basic and extended accelerators available, see Fundamentals.

NOTE: Both extended and basic mode keyboard enablement require that the Siebel
applications are running in High Interactivity mode. It is possible that a few applets
within the Siebel applications will not enable High Interactivity mode due to special
applet functionality, even if High Interactivity mode is in effect for the applications
in general. In these cases, keyboard enablement will not be active when the user is
working within one of these specialized applets.

Extended Mode

Extended mode keyboard enablement is the default mode of operation for Siebel
applications. Applications running extended mode keyboard enablement can map
any key sequence to Siebel commands. This includes key sequences that have
default interpretations native to the browser in use (for example, Ctrl + N opens a
new browser window in late versions of Microsoft Internet Explorer). In cases
where both the active Siebel application and the active browser have the identical
key sequence mapped, the Siebel applications will win in extended mode. Extended
mode keyboard enablement also allows accelerator key sequences to include special
keys, such as function keys and the arrow keys.

To provide accelerator access to all available key sequences, extended mode
keyboard enablement uses a lightweight ActiveX control to capture keystrokes in
the browser. Presence of the control is detected automatically and the control is
loaded only if necessary. Once loaded, the control is automatically maintained. It
will not be loaded again unless an upgraded version becomes available on the
application server.

In order for keyboard enablement to be active in extended mode, the following
conditions must be met:
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The line “ExtendedKeyboard = TRUE” must appear in the [SWE] section of the
configuration file for the active application

The user's browser must be able to accept and correctly interpret the ActiveX
control used to capture key sequences

Each client browser must accept the lightweight ActiveX control used to capture
key sequences. Acceptance of the control may be silent, or it may require the
user to explicitly accept the control depending on browser security settings. If
current browser security settings prohibit downloading of ActiveX controls, the
browser security settings will need to be modified to allow ActiveX controls.

Basic Mode

Basic mode keyboard enablement is accessible to all browser clients running the
Siebel applications in High Interactivity mode. No ActiveX control is required to
support basic mode. The functional differences between basic mode and extended
mode keyboard enablement are:

Key sequences mapped natively by the current browser will take precedence
over Siebel keyboard accelerators mapped to the same key sequences. For
example, Ctrl + N in version 5.5 of Microsoft Internet Explorer will open a new
browser window regardless of accelerator mappings for Ctrl + N in the Siebel
applications.

Basic mode keyboard accelerators cannot include special keys in their mapped
key sequences. Special keys include, but are not limited to, function keys and
arrow keys.

Keyboard enablement will be active in basic mode if either of the following is true:

The line “ExtendedKeyboard = FALSE” appears in the [SWE] section of the
configuration file for the active application.
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m  The current browser does not support extended mode keyboard enablement.

NOTE: Siebel applications use automatic browser detection to determine if a browser
is capable of supporting extended mode keyboard enablement. If the current
application is configured to run extended mode keyboard enablement but the
browser on a particular client does not meet the minimum requirements, the
application will be started with basic mode keyboard enablement in effect.

To configure new keyboard accelerators or modify existing ones, see Siebel Tools
Reference.
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Setting Up Industries

You can set up and maintain industry information used throughout the application.
The information in the Industries view populates the Industries drop-down list,
which is found in a variety of screens and views, such as in the Accounts and
References screens. The Industry list can also be used by Siebel Assignment
Manager to assign new leads or service requests to Siebel users. For example, a sales
representative who covers the pharmaceutical industry can be assigned
automatically to new accounts based on a Pharmaceutical Industry value.

To add an industry

1 From the application-level menu, choose View > Site Map > Application
Administration > Industries.

2 In the Industries list, add a new record.

3 Fill in the Industry, SIC Code, and Type fields.

NOTE: The Industry and SIC Code values must be unique. If you add a value that
already exists, you will receive an error message.
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Setting Up Languages

You can set up and maintain language information used throughout the application.
The information in the Languages view populates the Language drop-down list,
which is found in a variety of screens and views, such as in the References and
SmartScripts screens. The Language field can also be used by Siebel Assignment
Manager to give assignments to call center agents who work for international
companies and speak a variety of languages with customers.

For example, a sales representative for a German chemical manufacturing company
could use a Danish SmartScript to make a sales call to a prospective customer in
Copenhagen, and then make the same sales call using an Italian SmartScript when
speaking to a prospective customer in Rome. In these cases, the Language field is
used to identify the language into which each SmartScript has been translated.

To add a language

1 From the application-level menu, choose View > Site Map > Application
Administration > Languages.

2 In the Languages list, add a new record.

3 Complete the Name and Code fields.

NOTE: The Name and Code values must be unique. If you add a value that already
exists, you will receive an error message.

NOTE: Languages cannot be deleted because deleting languages may cause problems
with mobile Web client synchronization. While the delete language command can
be restored using Siebel Tools, this is strongly discouraged. Additionally, ask for
assistance from Siebel Technical Services before modifying any language code.
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About Case Sensitivity

By default, Siebel applications are case sensitive. If you perform a query or search,
there will be a match only if the search criteria you enter are capitalized in the same
way the data is capitalized in the database.

For important information about how case sensitivity affects performance, see
Performance Tuning Guide.

To force a case-sensitive search, use the operator = followed by the criterion in
quotation marks. For example, if the user enters the criterion =’ Conput er’ , the
query will return only records that have “Computer” spelled with a capital C in the
field.

To force a case-insensitive search, use the operator ~ LIKE. For example, if the user
enters the criterion ~LI KE conput er, the query will return all records that have
“computer” in the field, regardless of capitalization.

The user must also use ~ LIKE to force case insensitivity in searches with complex
criteria, regardless of the setting for case sensitivity.

NOTE: You should determine your requirements for case-insensitive searching and
set the appropriate parameters for the application or individual field before users
enter any data.
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Enabling Application-Wide Case Insensitivity

Application-wide case sensitivity is controlled through the Caselnsensitive
parameter of the named subsystem representing the datasource definition.

By default, each of these data source definitions has the following parameter
setting:

Casel nsensitive = FALSE

To enable application-wide case insensitivity, you change this setting to TRUE.

NOTE: There may be a performance degradation when the Caselnsensitive parameter
is set to TRUE. You may want to also change the InsensitivityFactor Parameter to
minimize performance degradation. For more information, see “Modifying the
InsensitivityFactor Parameter” on page 91.

The Caselnsensitive parameter only affects which data is retrieved by queries. It
does not affect the order in which data appears on the screen. The sort sequence is
database-dependent, and independent of the Caselnsensitive parameter.

In addition, the content of SRF files is case-sensitive in most cases and is not
affected by how this parameter is set in the application configuration file.

You change the Caselnsensitive parameter in different ways, depending on whether
you are working with Siebel Web Client or Siebel Dedicated Web Client.

Enabling Application-Wide Case Insensitivity for Siebel Web
Client

For Siebel Web Client, you make changes to the Caselnsensitive parameter in the
Server Administration screen.

To enable application-wide case insensitivity for Siebel Web Client

1 From the application - level menu, choose View > Site Map > Server
Administration > Enterprise Configuration.

2 C(Click the Enterprise Profile Configuration view tab.
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3 In the Component Profiles list, select the Named Subsystem Alias for the data
source.

4 1In the Enterprise Profile Configuration list, change the value of the
DSCaselnsensitiveFlg to True.

5 Optionally, change the InsensitivityFactor Parameter as well, to control
performance degradation.

6 Stop and restart the Siebel Server.

For more information, see “Modifying the InsensitivityFactor Parameter” on
page 91.

Enabling Application-Wide Case Insensitivity for Siebel Dedicated
Web Client

For Siebel Dedicated Web Client, application-wide case sensitivity is controlled
through the Caselnsensitive parameter in the configuration file for your application.

The configuration file for each Siebel application has a section for each one of the
potential data sources for the application. By default, each of these data source
sections has the following line:

Casel nsensitive = FALSE
To enable application-wide case insensitivity for Siebel Dedicated Web Client
1 Use any text editor to open your application configuration (.cfg) file.
2 Change the Caselnsensitive parameter to

Casel nsensitive = TRUE

3 Optionally, change the InsensitivityFactor parameter to control performance
degradation.

The InsensitivityFactor parameter follows the Caselnsensitive parameter in each
application configuration file. For more information, see “Modifying the
InsensitivityFactor Parameter” on page 91.
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Modifying the InsensitivityFactor Parameter

When you change the Caselnsensitive parameter, you may also want to change the
InsensitivityFactor parameter to minimize performance degradation.

The default setting for the InsensitivityFactor parameter is 2.

NOTE: Do not change the default value of InsensitivityFactor for Gateway Datasource
(GatewayDataSrc). Gateway Datasource does not go against a database. Changing
the value may cause problems.

You may want to test a number of values for this parameter with your database,
spool the SQL to see the effect of different settings on response time, and then
choose a value that meets your needs.
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Enabling Field-Specific Case Insensitivity

You can also make individual fields case-insensitive. If you are concerned about
performance, it is better to make a few fields case-insensitive than to enable
application-wide case insensitivity.

You control field-specific case insensitivity with the Use Default Sensitivity property.
This property determines whether the field uses the default property specified by
Caselnsensitive parameter in the .cfg file, described previously. Table 10 illustrates
the relationship between the application-wide Caselnsenstive parameter and the
field-specific Use Default Sensitivity property.

Table 10. Case Sensitivity Behavior

Use Default Sensitivity = Caselnsensitive = TRUE Caselnsensitive = FALSE
TRUE Field is case insensitive Field is case sensitive
FALSE Field is case sensitive Field is case insensitive

To enable case insensitivity for individual fields

1 Leave the Caselnsensitive parameter set to FALSE in the application
configuration file.

2 In Siebel Tools, navigate to the Business Component/Field screen.

3 For each field you want to be case-insensitive, set the Use Default Sensitivity
property in the field object to FALSE for the Field level Object Type.

You can also force the case of data in a field to be UPPER (all uppercase),
LOWER (all lowercase), FIRSTUPPER (first letter of each word is uppercase, or
NONE (unchanged).

4 After doing this for all of the fields you want to control, recompile your .srf file.

5 Replace the .stf file in your Siebel Server installation.
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Adding Web Browser Capabilities

Siebel applications come with a number of browsers configured for use. Generally,
you will not need to make changes to the Web browser settings. However, if you
need to add a capability to a browser, you can do so through the Web Browser
Administration screen.

Web browser capabilities identify what an end user's browser can and cannot do.
They support the Siebel Web Engine's ability to provide different HTML tags and
other markup tags to different browsers, based on what each particular browser is
capable of rendering. This can also allow an administrator or developer to specify
what looks best in a particular browser.

When a user logs into a Siebel Web application, the Siebel Web Engine reads
information encapsulated in the requests coming from the user's browser to
determine the browser’s version and make. It then correlates that information with
the data contained in the Web Browser Administration views to determine the
browser’s capabilities.

One of the primary ways this information is applied is through conditional tags in
Web templates. For example, if some of your users use an older browser that does
not support frames, your template might include a conditional tag that prevents
these users from receiving pages with frames. Conditional Web engine tags that
evaluate browser capabilities can be used in all Siebel Web templates and Web
applications, but are used most prominently in those that support wireless devices.
Conditional Web engine tags that evaluate browser capabilities can be used in all
Siebel Web templates and Web applications, but are used most prominently in those
that support wireless devices. For example, the SWLSDetailApplet.swt template
includes the following conditional tag:

<swe: swi tch>

<swe: case condi ti on="Web Engi ne User Agent, TestCapability,
Def aul t Mar kup: XM." " >

<swe: xsl - styl esheet nanme="SW.SDet ai | Appl et. xsl" node="process"/>

</ swe: case>
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By the time that the Web Engine interprets the swe:case tag, it has already
determined what type of browser the user has. The usage of the tag causes the Web
Engine to call the “TestCapability” method on the “Web Engine User Agent”
business service. The “TestCapability” method will return TRUE if the user’s
browser has a Capability called “DefaultMarkup” with a value of “XML.” When the
condition is met (that is, the method returns TRUE) the tags between < swe:case >
and < /swe:case > are processed. In this example the Web engine is instructed to
use a particular XSL style sheet. For more information about the syntax of
conditional tags, see Siebel Tools Reference.

Adding JumpTab Capability for Internet Explorer 5.0
If you are running your Siebel application on Internet Explorer 5.0, you need to set
the JumpTab capability to True.

(If the JumpTab capability is not set, users need to click the back button twice to
return to the previous page.)

To add the JumpTab capability

1 From the application-level menu, choose View > Site Map > Web Browser
Administration > Capabilities.

2 In the Capabilities list, select the JumpTab capability record.

3 In the More Info form, in the Capability Value field, enter TRUE.

Adding Additional Capabilities

Siebel applications come with a number of predefined capabilities. These
capabilities can be added to any browser. Some examples include:

= FrameSupport. Indicates whether the browser can render frame tags (for example,
< swe:frameset > ).

= CookiesAllowed. Indicates whether the browser supports cookies.

= Highinteract. Indicates whether the browser is among those supported for
Siebel's High Interactivity Web applications (such as Internet Explorer 5.5).

m ActiveX. Indicates whether the browser can support ActiveX controls.
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You can also add other capabilities that are not included in the standard Siebel
application. For example, you could add a capability named SupportsWingDingFont.
New capabilities then become available for use in any browser definition.

To add a capability

1 From the application-level menu, choose View > Site Map > Web Browser
Administration > Capabilities.

2 In the Capabilities list, add a new record.

3 Complete a name and description for the new capability.
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Adding Additional Web Browsers

If you need to add a Web browser definition that is not included in the standard
Siebel application, you can choose between the following two methods.

m  Add a parent browser definition. This definition includes all of the browser
capabilities. Use this method if you need to add a completely new browser (such
as Opera), or a major upgrade release of an existing browser (such as future
releases of Microsoft Internet Explorer or Netscape). For information about this
procedure, see “To add a parent Web browser” on page 97.

= Add a child browser definition. Child browser definitions inherit the capabilities
of the parent browser, and add additional capabilities as necessary. Use this
method for adding interim releases based on a browser that is already defined.
For example, a “dot” release, such as 5.7 or 5.8. For information about this
procedure, see “To add a child Web browser” on page 98.

Required Browser Capabilities
For a browser to work correctly, it must include two capabilities that allow the
browser to be identified at runtime. The required capabilities are:

= User-Agent. This capability names the browser.
= Accept. This capability indicates what types of documents the browser can open.

These capabilities are part of HTTP standard information and appear in HTTP
request headers sent from a browser. For example, a request from a Microsoft
Internet Explorer 5.5 browser sent to a Web application might include the following
lines:

Accept: image/gif, image/x-xbitmap, image/jpeg, inage/pjpedg,
appl i cati on/ vnd. ns- power poi nt, application/vnd. ns-excel,
application/ msword, */*

User-Agent: Mozilla/4.0 (conpatible; MSIE 5.5; Wndows NT 4.0)

In this example, the value for the User-Agent capability would be Mozilla/4.0
(compatible; MSIE 5.5; Windows NT 4.0).
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Both the User-Agent and Accept capabilities must be included. This is because at
runtime, the User-Agent is checked to identify the browser. If the User-Agent is not
recognized, the values for the Accept parameter in the header will be compared to
the Accept parameters of the browsers listed in the Web Browser Administration
screen, to find the browser with the most closely matching Accept parameters.

In addition to the User-Agent and Accept capabilities, if a browser is based on an
existing parent browser, it must include the Parent capability.

NOTE: Parent browsers frequently do not have the User-Agent and Accept
capabilities. This is because parent browsers are intended to serve as containers of
other capabilities that can be inherited. If a browser does not have its own User
Agent and Accept capabilities, then it is acting as a parent of another browser that
has these capabilities.

Adding a Web Browser

Whether you are adding a parent browser or a child browser, the process is similar.
However, in the case of a parent browser, you add all detailed components, and in
the case of a child browser, you base the browser on an existing browser.

NOTE: Although a parent browser may contain the User-Agent and Accept
capabilities, it does not have to. If you use parent browsers as templates for child
browsers, do not include these two capabilities in the parent browser template.

To add a parent Web browser

1 From the application-level menu, choose View > Site Map > Web Browser
Administration > Browsers.

2 In the Browser list, add a new record.
3 Complete a name and description for the new browser.

4 Click the Capabilities view tab.
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5

In the Capabilities list, add records for each of the capabilities for this browser.

NOTE: If there is an existing browser that contains most of the appropriate
capabilities, you can copy it and then make changes. To do so, in Step 2, click the
menu button and choose Copy Record instead of New Record.

To add a child Web browser

1

N A~ W

From the application-level menu, choose View > Site Map > Web Browser
Administration > Browsers.

Scroll through the list of browsers and identify the parent browser (that is, the
one on which you will base the new browser).

Add a new record.

Complete a name and description for the new browser.

Click the Capabilities view tab.

In the Capabilities list, add these three records:

= Parent. Set the capability value to the parent browser you identified in Step 2.
= User-Agent. Enter the appropriate User-Agent.

= Accept. Enter the types of documents that can be opened by the browser.

Add any additional capabilities that are not included in the parent browser or
that differ from those inherited from parent browser.
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This chapter provides guidelines to administrators for working with lists of values
within Siebel applications.

A list of values (LOV) is a set of values that populates a static pick list, which is
accessed when a user clicks a drop-down list in the user interface.

Drop-down lists can be based on two types of pick lists: static pick lists and dynamic
pick lists.

= A static pick list has a selection list that is a static list of values. An example of
a static pick list is a drop-down list containing postal abbreviations for states and
countries.

m A dynamic pick list has a selection list that usually contains transactional data.
An example of a dynamic pick list is a drop-down list containing account names.

As a rule of thumb, dynamic pick lists include all pick lists that do not retrieve
values stored in the S_LST_OF_VAL table. Dynamic pick lists are typically
rendered through a pick applet, such as the pick list used to choose an account
for a contact. However, they can be configured to appear as a drop-down list.

The remainder of this section focuses on static pick lists, whose contents can be
administered from the List of Values views. For information on how to set up a new
list of values and configure both static and dynamic pick lists, see Siebel Tools
Reference.

This section describes how to work with the values that populate static pick lists,
including how to add or modify values in an existing list of values, and inactivate
values when you do not want them to display. In addition, it describes how lists of
values can be constrained by selections in other lists.

NOTE: If you will be creating multilingual lists of values (MLOV), you should also
review Siebel Tools Reference.
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There are two screens in which you can view list-of-values data:
= In alist view in the Application Administration screen, List of Values view

= In an explorer view in the Application Administration screen, List of Values
Explorer view

The values in these two views are the same. Only the format in which the
information is presented is different. The procedures in this section give instructions
that specify using the list view. If you prefer to use the explorer view, you may do so.

Your Siebel applications come with numerous lists of values that support the static
pick lists used throughout Siebel screens. You can use these as they are, or you can
modify them through the List of Values screen to support your organization’s
requirements.
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Adding a New Value to an Existing List of Values

In order to add an item to an existing list of values so that it shows up in a drop-
down list, you must know its type. You can find out the type by querying the List
of Values list to determine the type associated with a specific display value. Then
you can add a new record with that type. For instance, in the Accounts list you can
see the Status drop-down list. Imagine that you use this field to indicate ratings for
your accounts’ reliability. Initial settings are Gold and Silver. You might want to add
another status of Bronze to this list, to give to customers that have a reliable account
rating. The procedure below uses this example.

To identify the list-of-values type for a display value

1
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Navigate to the screen displaying the drop-down list to which you want to add
a value (for example, the Accounts screen).

Select the drop-down list and make note of one of the choices.

For example, in the Accounts screen, select the Status drop-down list and make
note of the value Gold.

TIP: Be sure to note the capitalization and spacing of the choice.

From the application-level menu, choose View > Site Map > Application
Administration > List of Values.

In the List of Values list, perform a query in the Display Value field, using the
value you noted in Step 2.

In the list of records that is returned, identify the appropriate record by reviewing
the entries in the Type field.

List-of-values types usually have names that relate to the field labels in the
screens where they are used. In this example, you would look for a type labeled
something like ACCOUNT_STATUS.

When you create a new value for this list, you will use this type.
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To add a new value to an existing list of values

1 From the application-level menu, choose View > Site Map > Application

Administration > List of Values.

Click New to create a new record, and then enter the list-of-values type in the
Type field.

Enter a new value in the Display Value field.

For example, if Bronze is the status that your organization gives customers that
have a reliable account rating, and you want to make Bronze available as in the
Account Status drop-down, you would add a new record with
ACCOUNT_STATUS as the type and Bronze as the display value.

Make sure that the length of the Display Value you enter does not exceed the
allowed length of the destination column.

Enter a value in the Language Independent Code field. This value is usually the
same as the Display Value.

Make sure that the length of the Language Independent Code you enter does not
exceed the allowed length of the destination column.

NOTE: The Display Name and Language Independent Code must both be unique
within a list-of-values type, except when configuring a multilingual list of values.
If you add a value that already exists, you will get an error message. For example,
there cannot be two ACCOUNT_STATUS records that have a display value of
Bronze. For information about how this differs for multilingual lists of values,
see the definition of the Language Independent Code field in Table 11 on

page 105.

If applicable, in the Order field, you can enter a number to indicate the
numerical order in which the value appears in a drop-down list.

For example, if the order numbers for Gold and Silver are 1 and 2, respectively,
the order number for Bronze would be 3.

If appropriate, fill in the remaining fields in the record.

For a description of these fields, see “List of Values Fields” on page 105.
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7 Clear the LOV cache by clicking the menu button and then choosing Clear LOV
Cache.

After you have cleared the cache, you can navigate to a screen and select the new
value in the related drop-down list. For example, you can navigate to the Accounts
screen, select a record from the Accounts list, and then choose Bronze in the
record’s Account Status drop-down list.
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Clearing the Cache

A particular list of values is cached the first time a user opens a drop-down list that
uses the list of values. This improves performance by avoiding the need to retrieve
the list from the database upon subsequent usage of the drop-down list. However,
this also means that updates to a list of values will not show up in a drop-down list
until you clear the cache. Clearing the cache instructs the Siebel application to read
the updated values out of the database and display them.

Users who log in after you add or change a list of values can see the addition or
change that you made. However, in order for you to see the changes that you made
in real time, you must do one of the following:

= For the Dedicated Web Client, log out of the application and log back in.
m For either the Web Client or the Dedicated Web Client, clear the cache.

To clear the cache (using the Clear Cache button)

1 From the application-level menu, choose View > Site Map > Application
Administration > List of Values.

2 In the List of Values list, click Clear Cache.

To clear the cache (from thesrvrmgr command-line interface)

1 Determine the current value of the parameter Object Manager Data Cache
Version (alias OMDataCacheVersion) for the named subsystem Object Manager
Cache (alias objmgrcache).

2 Increment the value by 1.

3 For information on listing and modifying named subsystem parameters using
srvrmgr, see Siebel Server Administration Guide.
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List of Values Fields

List-of-values records have the fields shown in Table 11. Not all fields for list-of-
values records are displayed in the standard user interface. You can use the Columns
Displayed menu option to see a field that is not displayed.

Some list-of-values fields, such as High, Low, and Weighting Factor, are for use by
specialized Siebel C + + code to store additional information about the selected list
of values record. In addition, pick maps can use list-of-value fields such as High,
Low, and Weighting Factor. Pick maps normally use the Display Value field, which
causes the list item selected by the user to be stored in the database exactly as it
appears in the list. These fields can be used to populate other fields of the business
component in which the pick map is defined.

If you need to use the High or Low fields, or other extra fields, use Siebel Tools to
extend the PickList Generic BusComp by adding fields mapped to the corresponding
columns on the S_LST_OF_VAL table. For example, you could use the High and Low
fields to automatically fill in the high and low temperatures when a user picks a
Month value in a Date drop-down list. To do so, you would add two pick maps to
the Month field by adding the High and Low list of value fields to the Pick List field
of Pick Map. For more information about the PickList Generic BusComp, and about
configuring static pick lists and pick maps, see Siebel Tools Reference.

NOTE: The Target High and Target Low fields are used exclusively with Smart
Reports. For more information, see Siebel Reports Administration Guide.

Table 11. List of Values Fields

Field Description

Type The type of list of values (the field name).

Display Value Value as displayed in the drop-down list.

Translate When checked, indicates that internationalization is needed.

(There is no client or server functionality associated with this
field; for more information, see Siebel Tools Reference.)
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Table 11. List of Values Fields

Field

Multilingual

Language Independent
Code (LIC)

Parent LIC (Language
Independent Code)

Replication Level

106 Applications Administration Guide

Description

When checked, indicates that the list of values is part of a
multilingual list of values (MLOV). (There is no client or server
functionality associated with this field; for more information, see
Siebel Tools Reference.)

Along with the Display Value, the Language Independent Code
uniquely identifies a value for a particular LOV type. In most
cases the Language Independent Code is the same as the Display
Value. However, the Language Independent Code and Display
Value are different for multilingual lists of values (MLOVs).
MLOVs allow a single logical list item to support multiple display
values for users who are accessing the Siebel application in
different languages.

For example if the MR_MS (Personal Title) list of values were
multilingual, there might be three list of values items with a
Language Independent Code of Mr. These might have a display
value and language of Mr. (English-American), Senor (Spanish -
Modern), and Herr (German), respectively. German users would
see Herr in the Personal Title drop-down list, Spanish users
would see Senor and English users would see Mr. Although the
display values vary across language instances, the value stored
in the database when a user selects any one of these will always
be Mr. since that is the Language Independent Code associated
with Herr, Senor, and Mr.

For more information on configuring multilingual lists of values,
see Siebel Tools Reference.

Values entered in the Language Independent Code field are
sometimes referred to as LIVs (language independent values).

The Language Independent Code of a parent list of values. Used
in hierarchical lists of values, where the values that will display
in a drop-down list are constrained by the value selected in the
parent drop-down list of values. For more information, see
“Constrained Lists of Values” on page 111.

There are only parents and children in this hierarchy.
Grandchildren are not allowed. This is enforced by limiting the
values in the Pick Parent dialog box to those values which do not
themselves have parent display values.

Specifies whether the translation is intended for use at all levels
in the translation hierarchy or only at the regional level.
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Table 11. List of Values Fields

Field
High
Low

Order

Active

Language Name

Target Low

Target High

Weighting Factor
Bitmap

Description

Description
Extra field available for use by pick maps or for customization.
Extra field available for use by pick maps or for customization.

The numerical order in which a value is displayed within a drop-
down list.

When checked, indicates that the value is displayed to the end
user. When unchecked, indicates that the value is not displayed
to the end user.

Language used for the list of values Display Value field.

Extra field used in Smart Reports. For more information, see
Siebel Reports Administration Guide.

Extra field used in Smart Reports. For more information, see
Siebel Reports Administration Guide.

Extra field available for use by pick maps or for customization.
Bitmap file that is displayed.

Description of a specific value.
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Modifying a List of Values

CAUTION: Use caution when modifying lists of values that are part of the seed data.
Modifying some list of values fields that are used programmatically by the Siebel

application can adversely impact standard Siebel functionality. However, you can
modify the Display Value field without affecting standard Siebel functionality both
when the list is a multilingual list of values (MLOV) and when it is a standard list
of values.

Modifying some lists of values can adversely impact standard Siebel functionality:

= Do not change the Language Independent Code values for lists of values because
the internal Siebel application uses the Language Independent Code field.

= Some lists of values are for use only by the internal Siebel application and should
not be modified. For example, the List of Values SOURCE_TYPE (Internal) and
list-of-values types that include REPOSITORY in the Type field name are for
internal use only.

m Some list of values modifications can have undesired results. For example,
changing all lists of values in the application to uppercase or changing the
Language Independent Code from the Siebel standard can result in values not
being displayed or being displayed improperly.

NOTE: Modifying a Display Value field does not automatically update records that
have been populated with the old value. For example, if you change Ms. to Miz in
the Display Value field, Miz will show up in the drop-down list, but all contact
records that were previously entered with Ms. in the Personal Title field will still
have Ms. in the Personal Title field.

For more information about multilingual lists of values (MLOVs), see Siebel Tools
Reference.
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In order to modify a value in a drop-down list, you must know its display value and
type. You can find out the type by querying the List of Values list for a specific
display value. For example, if you needed to make a change to the value I-ASAP in
the Priority drop-down list in the Activities screen, you could do so using the
following steps.

To modify an item in a list of values

1 From the application-level menu, choose View > Site Map > Application
Administration > List of Values.

2 Click the menu button, and then choose New Query.

3 Enter the Display Value for the record you want to change in the Display Value
field.

For example, you might enter the value I-ASAP.
4 Click the menu button, and then choose Run Query.

A list of records appears that includes the display value that you entered. More
than one record may appear, and the records may have different types.

5 In the list of records, select the record that you want to modify, and make the
desired change.

6 To see the list of values modification in the application, clear the cache. For
instructions about how to clear the cache, see “To clear the cache (using the
Clear Cache button)” on page 104.
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Inactivating a Value in a List of Values

You can inactivate individual values in a list, but you cannot delete values. Inactive
values are values that the application does not display to end users in a drop-down
list, whereas active values are displayed to end users.

CAUTION: Inactivating some lists of values can adversely impact standard Siebel
functionality.

Do not inactivate list-of-values types or values used internally by the Siebel
application. For example, do not inactivate list-of-values types that include
“Repository” in the Type field name.

Be careful when inactivating a list of values, because the application may depend
on the list of values being present.

Be careful when inactivating individual values as well. For example, if you
inactivate the value Commercial in the Account_Type list of values, but you have
existing or old account data that stored Account Type = Commercial, you may
introduce inconsistencies in your data. If you want to inactivate a display value, you
need to clean up the account records in the database first.

To inactivate a value in a list of values

1 From the application-level menu, choose View > Site Map > Application
Administration > List of Values.

2 If necessary, perform a query to locate the record you want to make inactive.
3 Select the list of values record you want to make inactive.

4 Inthe Active field, click the check mark. When a square containing an x appears,
click the x.

The x disappears and the Active field no longer contains a check mark.

5 To see that the value has been inactivated, click the menu button and then click
Clear LOV Cache.
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Constrained Lists of Values

Some drop-down lists are set up to display a subset of values based on a value set
in another drop-down list. For example, if you have two fields for Service Request,
Area and Subarea, the values shown in the Area drop-down list might include
Network and Upgrade. If the user chooses Network, that user might see a drop-down
list for Subarea that includes Ethernet Card and 3rd Party Software. If on the other
hand the user chooses Upgrade for the Area, that user might see CD-ROM, Disk
Drive, Memory, and Operating System in the Subarea. Setting up this type of filtering
is referred to as setting up a constrained pick list. In such a case, the lists of values
have been configured to be dependent on one another. In this example, the Area
drop-down list is considered to be the parent and the Subarea drop-down list is the
child.

Figure 1 shows the values available in the Area drop-down list, and the values
available in the Subarea list when Network and Upgrade have been selected,
respectively.

Area: Area:
twork = [wetwork >l [uporade 4
Installation -+ Subarea: Subarea:

Metweork
Upgrade

Usage J
User Interface

3rd y VErE
Ethernet Card

Memary T
=~ [T = Disk Drive
CD-ROM

Figure 1. Contents of Drop-Down List Constrained by Parent Drop-Down List

Constrained pick lists (or lists of values) must first be set up through Siebel Tools.
After they are configured through Siebel Tools, specific values in lists can be made
hierarchically dependent through the List of Values screen. This is accomplished by
using the Parent LIC attribute in the list of values record to specify which values will
show up when a value is selected in the parent drop-down list.
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Constrained Lists of Values

For example, the LOV Type SR_AREA is used by both the Area and Subarea drop-
down lists in a Service Request. The values that show up in the Area drop-down list
are constrained to those that have a Parent LIC value of External. Figure 2 shows
how the records for these values appear in the List of Values list, including the
Parent LIC value of External.

Lo

List of Values

€@ 1-110f11 QueryResults

rFs

Type Display Value L Indepe L Hame _ Parent LIC Order
SR_AREAS CTI Hardware CTI Hardware English-American  External

SR_AREAS Configuration Configuration English-American | External

SR_AREAS Solution Search Solution Search English-American | External

SR_AREAS eMail Response eMail Response English-American | External

SR_AREAS Smart Scripts Smart Scripts English-American | External 2
SR_AREAS Inztallation Inztallation English-American | External 3
SR_AREAS Metwork Metwork English-American | External 4
SR_AREAS Upgrade Upgrade English-American | External 5
SR_AREAS Usage Usage English-American | External B
SR_AREAS User Interface User Interface English-American | External 7
SR_AREAS Internet Redistration Reguest Internet Registration English-American | External g

Figure 2. LOV Records with the Same Parent LIC
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The values that show up in the Subarea drop-down list are constrained to those that
have a Parent LIC value that matches the user’s selection for the Area. For example,
if the user selects Network in the Area drop-down, only those values that have the
Parent LIC set to Network show up in the Subarea drop-down list, while if the user
selects Upgrade in the Area drop-down, only those values that have the Parent LIC
set to Upgrade will show in the Subarea drop-down list. Figure 3 shows the records
for the values that are available for both the Network and Upgrade parent values.

L.

List of Values

Dy 1-6of6
Type Display Value Language Indepe Language Hame - Parent LIC - Order Ac »
SR_AREA, CD-ROM CO-ROM English-American  Upgrade £ v
SR_AREA Dizk Drive Disk Drive Endlish-American | Uparade 3 v
SR_AREL Cperating System Operating System  English-&merican  Upgrade 5 o
SR_ARES, Memory Memory English-American  Upgrade El v
SR_ARES Ethernet Card Ethernet Card English-American  Metwork El o
SR_AREA 3rd Party Software 3rd Party Software | Endlish-American  Metwork 3 v

Figure 3. LOV Records Constrained by the Values Upgrade and Network
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If you needed to change the parent Area to which a Subarea list item belongs, you
would modify the Parent LIC code of the Subarea list item. Similarly, to add a new
Subarea list item, you would add a new record, setting the list-of-values type to
SR_AREA and the Display Value, Language Independent Code, and Language as
described in “Adding a New Value to an Existing List of Values” on page 101. Then
you would set the Parent LIC code to the appropriate parent area. By contrast, to
add a new item to the Area drop-down list, you would follow the same steps, but
specify that the Parent LIC code have the value External.

NOTE: The usage of the value External to identify items in the parent drop-down list
is specific to this example. To determine what this value would be for any given pair
of constrained pick lists, reference the underlying configuration in the Tools
Repository.

For information about constraining both static pick lists (maintained through lists
of values) and dynamic pick lists, see Siebel Tools Reference.

NOTE: In the example above using the Area and Subarea drop-down lists, both parent
and child lists of values have the same list-of-values type. While this is not required,
it has the advantage of avoiding EIM unique key violation errors. These errors can
occur when constraining pick lists using Siebel Tools, when the parent and child
lists of values contain different list-of-values types. If you plan to use Siebel EIM to
exchange list of values data, you should consider constraining pick lists by
configuring them so that the parent and child lists of values have the same list-of-
values type.
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Audit Trail creates a history of the changes that have been made to data in Siebel
applications. An audit trail is a record showing who has accessed an item, which
operation was performed, when it was performed, and how the value was changed.
Therefore, it is useful for maintaining security, examining the history of a particular
record, and documenting modifications for future analysis and record keeping.
Audit Trail logs information without requiring any interaction with, or input from,
your users.

Audit Trail can be used for a variety of purposes. In a simple example, a call center
uses an audit trail to track the status change of a service request, who changed it
and when. Audit trail capabilities can also be used to track the time needed to
change the state of an item, such as a service request from open to closed. A
calculation of the time difference can help the call center manager measure and
improve service quality. Audit trail can also be used to reproduce a record at a given
point in time to maintain regulatory compliance by looking at the audit trail records
of changes and the current state of the record.

For any audit trail deployment, the combination of the number of fields audited and
the number of audit records created by a given business process has performance
implications. Auditing a large number of fields on a business component or auditing
fields in a large number of business components may produce unacceptable
performance that is counter to the overall business requirement.

Audit trail works for replication and synchronization. For Siebel Remote and Siebel
Replication users making changes to records, Audit Trail records successfully
committed transactions and also transactions that did not get synchronized to the
server because of conflicts.

The Siebel Web Client supports the following choice of audit trail modes:

»  File auditing. An audit trail can be written to files and later imported into the
database, providing better performance.
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= Database auditing. An audit trail can be written directly into the database,
supporting both remote users and replicated databases. Changes to an audit trail
field are cached in the application. Exiting from the Siebel application and
restarting it writes all cached changes to the database. Alternatively, when the
cache size is reached, all cached entries are automatically written to the
database even without exiting from the application.
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Audit Trail Features

You can configure and activate Audit Trail from an administration screen.

Audit Scope

System administrators can specify the audit scope by the following means:

Operations (such as update, new, delete, and copy) performed on business
components

Operations performed in a specific time period

Only those operations performed by certain responsibilities, positions, or
employees

Audit Trail Content

Audit Trail records the following information in selected business components:

Field

Row ID of the record being changed

Operation being performed (Update/New/Delete/Copy)
Original value

Changed value

User ID performing the operation

Date and time the operation was performed

Audit Trail Constraints
The following cannot be audited:
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The underlying business component not derived from CSSBCBase. This is
because Audit Trail’s functionality resides only in business components of class
CSSBCBase. The procedure “To determine if a business component can be
audited” tells you how to determine whether or not a business component can
be used in Audit Trail.
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Business components based on intersection tables.

Virtual business components, because they are not derived from business
components of class CSSBCBase.

The merge action.
Multivalue fields.

Calculated fields. Typically, the value for a calculated field is derived from a
table-based field. To audit a calculated field, you can audit the table-based field
that was used to derive the calculated field.

Record inserts, updates, and deletes performed through Enterprise Integration
Manager (EIM), Assignment Manager or workflow policy actions (because these
do not go through the Siebel Object Managers).

To determine if a business component can be audited

W N =

Launch Siebel Tools.
In the Object Explorer, navigate to the Business Component object type.
In the Object List Editor, select the business component.

In the Class field, look for CSSBCBase. If the class is CSSBCBase, the business
component can be used for Audit Trail.

CSSBCBase and CSSBusComp are the most basic class types. If there is a value
in the Class field that is not CSSBCBase or CSSBusComp, then there is
specialized functionality that has been written in C+ + related to this class.

To see if this specialized class is related to CSSBCBase, drill down on the Class
hyperlink.
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Audit Trail Features

In the Super Class field, look for CSSBCBase. If the class is not CSSBCBase, drill
down on the Super Class hyperlink.

If the Super Class is...  Then the business component...
CSSBCBase can be audited.
CSSBusComp cannot be audited.

(blank) cannot be audited.

NOTE: Repeat Step 6 until the Super Class field is either CSSBCBase,
CSSBusComp, or blank.

Audit Trail for Siebel Remote and Siebel Replication Users
The following information applies to remote and replication users:

Disconnected users can use Audit Trail as well as connected users. Audit Trail
will stamp transactions with local machine time.

Remote and replication users should not use file auditing mode, only database
auditing mode.

Audit trails are synchronized or replicated along with other data.

If the transaction is rejected during the conflict resolution, the corresponding
audit trail record is not discarded.

File Auditing and Database Auditing Modes

The following information applies to file auditing and database auditing modes:
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Database auditing writes transaction records directly to the database, while file
auditing writes to the Siebel file system. You can later import these files into the
database. (See “To import audit trail items from a file into the Siebel database”
on page 134.) You can schedule import batch processes for these files using
workflow processes. (See the ImportAll method in Table 12 on page 121.)
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= If you use file auditing mode, you have to import files into the database to have
a comprehensive view and to be able to query for the information you need.
Otherwise, you can view records only on a file-by-file basis.

m For systems in which every user is a connected user, file auditing mode yields
better performance. Systems using Siebel Remote should use database auditing.

= Purging and archiving can be done at the database level.

Audit Trail Recovery in File Auditing Mode

When running in file auditing mode, instead of writing to the Siebel file system
every time a new Audit Trail file is created, your Siebel application saves Audit Trail
files to a file directory on the Object Manager to improve performance. When the
Object Manager closes normally, these files are uploaded to the Siebel file system
simultaneously.

If the Object Manager exits abnormally, Audit Trail keeps track of which files have
been uploaded to the Siebel file system and which ones have not. The next time
Audit Trail starts, any files that have not been uploaded are uploaded automatically.

Audit Trail Engine Business Service

The Audit Trail Engine business service is located in the Object Manager and stays
active as long as the Object Manager is active. The purpose of the Audit Trail Engine
business service is to capture changes (updates and deletes) to records and to store
them in the designated format (database or Siebel file system, according to the audit
trail mode selected). For the various data operations, if the auditing condition is
met, the business component being audited triggers the Audit Trail Engine business
service.
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The methods listed in Table 12 are associated with the Audit Trail Engine business
service. The Start, Stop, and ImportAll methods are accessible to an administrator
and allow the performance of certain tasks.

Table 12. Exposed Methods in the Audit Trail Engine Business Service

Method

Start
Stop
ImportAll

AddTrailEntry

CommitTrail

CrashRecover

Kill Unsaved Trail

Mode

Both
Both

File only

Both

Both

File only

Both

Internal

Use Only Description

>

Starts the Audit Trail Engine.
Stops the Audit Trail Engine.

Imports all the associated Audit Trail Item business component
records.

For the person specified, adds an audit trail entry to the pertinent
data structure (unsaved audit list).

Removes the uncommitted elements from the unsaved list and
puts them on the saved list, and writes to the database or file if
the cache size has been reached.

Saves file from local system to the Siebel file system.

Kills the unsaved audit trail; this happens on an UndoRecord.

The easiest way to use these methods is through a workflow process. If you want
to stop or restart the Audit Trail Engine, create a new workflow process or reuse an
existing one, and then create a business service node that implements the Stop
method or the Start method. For more information about workflow processes, see
Siebel Business Process Designer Administration Guide.
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Audit Trail Business Scenario

As an administrator, you have set up the operations, fields, responsibilities,
positions, and employees to be audited (see “Configuring Audit Trail in Siebel
Tools” on page 124). You discover that a record has been accidentally deleted from
the Contact business component. You know when it was deleted but you want to
know who deleted it. You go to the Audit Trail Item list in the Audit Trail Item view.
There you query for the Contact business component records and the day the record
was deleted (see “Viewing Audit Trail Records” on page 134). Audit Trail returns a
set of records. You browse through these records in the Audit Trail Item list. When
you find the applicable record, you view the data before it was deleted and
determine the time it was deleted, and who deleted it.
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Audit Trail Process Flow

Figure 4 shows the process flow for setting up Audit Trail.

Enable Audit Trail in Tools.

h 2

Specify business components
and fields to be audited.

h 2

Restrict Responsiblities,
Positions, and Employees.

k

Check audit trail records and
details in the Audit Trail view.

k

Conditional step applicable
only in File mode. Click Impaort
buttan an Audit Trail view ta
import audit trail files into the
databases as displayed in
Audit Trail items view.

Figure 4. Audit Trail Workflow
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Configuring Audit Trail in Siebel Tools

In the preconfigured Siebel application, the Audit Trail functionality is disabled. By
enabling the Audit Trail business service within Siebel Tools, Audit Trail is enabled
for all application objects. However, you can turn off Audit Trail for individual
applications by inactivating the Audit Trail application event service for that
application’s object. For custom application objects, you must add an Audit Trail
application event service to the application object in order to use Audit Trail.

NOTE: Audit Trail does not create history records for predefault values; predefault
values are assumed to be part of the initial record.

To enable the Audit Trail Engine business service

1 Launch Siebel Tools.

2 In the Object Explorer, select the Business Service object, and then select the
Business Service User Prop object.

3 Select Audit Trail Engine in the Business Services object list.
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4 Configure the Business Service User Properties to use the following values:

Name Field Value Field Description

Audit Source TABLE Can be TABLE or FILE. Signifies the database or
file auditing mode in which you are going to
run Audit Trail.

Cache Entries Size 1 The number of records to cache before writing
the audit trail records for the selected mode. For
example, if this field is set to 10 and Audit
Source is running in FILE mode, then after the
user makes 10 audited changes for a particular
business component, the Audit Trail engine
creates one file in the Siebel file system. When
running in TABLE mode, you should use the
default value of 1 because there is no
performance gain from increasing this value.

Enable TRUE Can be TRUE or FALSE. Determines the current
state of the Audit Trail.

NOTE: Audit Trail data is cached by the business service and only written out
when the number of Audit Trail changes exceeds the specified cache size. You
can also flush cached entries by logging out of the current session and then
logging back in to check the Audit Trail data.

To disable Audit Trail for an application

1 Launch Siebel Tools.

2 Inthe Object Explorer, double-click the Application object to expand it and select
Application Event Services.
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3 Inthe Application Event Services list, inactivate the Audit Trail Engine business

service record. (Look for a record with the following values.)

Name Field Value Field
Business Service Audit Trail Engine
Event Name Start

Method Name Start

Use the following procedure to enable a customized application object for auditing,
or to re-enable an application object that has been turned off.

To configure an application for Audit Trail

1
2

Launch Siebel Tools.

In the Object Explorer, double-click the Application object to expand it and select
Application Event Services.

In the Application Event Services list, add the following record if it does not
already exist.

Name Field Value Field

Business Service Audit Trail Engine

Event Name Start

Method Name Start

Name Start

Sequence 1 or the next available sequence number

About Using Audit Trail with Object Interfaces

When accessing an Application Object Manager through object interfaces such as
COM Data Control and Java Data Bean, Audit Trail is not started automatically. In
these cases, you must invoke the Audit Trail Engine business service explicitly.
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Specifying Business Components and Business
Component Fields for Audit

You administer the business component and the business component fields to be
audited.

To configure the business component and business component fields to be audited

1 From the application-level menu, choose View > Site Map > Audit Trail
Administration > Audit Trail.

2 In the Audit Trail Buscomp list, add a new record and complete the necessary
fields. Some fields are described in the following table.

Field Description
Copy Select if you want to audit the Copy operation.
Delete Select if you want to audit the Delete operation. Clear this field if

you want to make sure that the delete operation was not audited.

End Date Date on which the auditing stops.

To turn Audit Trail off for an individual business component, set
the End Date to a date that has already passed.

New Select if you want to audit the New operation.

Restriction Type Specifies whether or not there is a rule determining who gets
audited.

Start Date Date on which the auditing starts.

Update Select if you want to audit the Update operation.

3 In the Field list, add a new record for the field you want to audit.

4 Repeat Step 3 until the Field list shows all the fields in that business component
that you want to audit.

To disable individual business components

1 From the application-level menu, choose View > Site Map > Audit Trail
Administration > Audit Trail.
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2 Use one of the following methods to disable Audit Trail:

» In the Audit Trail Buscomp list, enter an end date prior to today’s date in the
End Date field.

= In the Audit Trail Buscomp list, delete the record for the business component.
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Specifying Audit Trail Restrictions

You can restrict who gets audited by user, position, or responsibility.

For example, if you set the Restriction Type to “Users” on the Audit Trail Buscomp
Fields view, you then go to the Audit Trail Users View and add the users whom you
want to audit. Restriction by responsibility or position works in the same way.

To restrict by user

1

a £ W N

From the application-level menu, choose View > Site Map > Audit Trail
Administration > Audit Trail.

Click the User tab.

Select a business component entry in the Audit Trail Buscomp list.
Change the Restriction Type field to User.

Select the Audit Trail User list and add records.

Only these users will be audited for the operations on this particular business
component.

To restrict by position

1

a » W N

From the application-level menu, choose View > Site Map > Audit Trail
Administration > Audit Trail.

Click the Position tab.

Select a business component entry in the Audit Trail Buscomp list.
Change the Restriction Type field to Position.

Select the Audit Trail Position list, and add records.

Only these positions will be audited for this particular business component.

To restrict by responsibility

1
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From the application-level menu, choose View > Site Map > Audit Trail
Administration > Audit Trail.

Click the Responsibility tab.
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3 Select a business component entry in the Audit Trail Buscomp list.
4 Change the Restriction Type field to Responsibility.
5 Select the Audit Trail Responsibility list and add records.

Only these responsibilities will be audited for this particular business
component.
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Verifying Audit Trail Configuration

The following steps are part of the verification process to make sure that the
business component and business component fields were specified correctly.

To verify audit trail records

1 In your Siebel application, go to the view for the business component that you
want to audit.

2 Make a change to the data in that view.

3 If you are using database auditing, verify audit creation as follows:

From the application-level menu, choose View > Site Map > Audit Trail >
Audit Trail Items.

In the Audit Trail Items list, make sure there is a new record showing the
changes that you made to the business component by querying the business
component and field values.

4 If you are using file auditing mode, verify audit creation as follows:

Exit and restart the application.

b From the application-level menu, choose View > Site Map > Audit Trail >
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Audit Trail.

NOTE: The Host Computer name in the Audit Trail record is the name of the
machine on which the object manager is running. This field is not
configurable.

Verify that there is a new record in the Audit Trail list from your previous
session and the corresponding Audit Trail Item list displays the changes you
made to the business component.

Applications Administration Guide 131



\ Audit Trail

Linking Audit Trail to a Business Component

Linking Audit Trail to a Business Component

In some circumstances, you might need to link the Audit Trail view to a specific
business component view. For example, a Call Center team might want to see the
Audit Trail records for individual service requests. Using Siebel Tools, you can create
a view that would allow the Call Center team to see these Audit Trail records, if the
following conditions are met:

» Audit Trail must be running in database auditing.

»  You must be able to audit the business component you are linking to Audit Trail.
For information on determining if a business component can be used in Audit
Trail, see “Audit Trail Constraints” on page 117.

NOTE: Because audit trail item records are not routed to mobile Web clients, data in
these linked views can only be displayed in Siebel Web client and the Siebel
Dedicated Web client. Make sure that mobile clients do not have access to views
displaying audit trail data.

To link Audit Trail to a business component

1 Launch Siebel Tools.

2 Create a link between the Audit Trail Item 2 business component and the
business component to which you are linking Audit Trail. Set the parent business
component property of the link to the name of the audited business component.

For example, if you are configuring the view to show the audit trail records for
the Product Defect business component, the parent business component should
be Product Defect. The Child Business Component for the link should be Audit
Trail Item List 2. The Source and Destination Fields for the link should be Id and
Record Id respectively.

3 Modify the business object for the business component to which you are linking
Audit Trail. You need to add Audit Trail Item 2 as one of the business object
components and specify the Link property as the link you created in Step 2.

4 Create a view which has an applet based on the selected business component as
a parent and the Audit Trail Item List 2 applet as a child.
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Linking Audit Trail to a Business Component

Add this view to a screen.
Launch a Siebel employee application.

From the application-level menu, choose View > Site Map > Application
Administration > Views and add the new view to the list of views.

From the Show drop-down list, choose Responsibilities, and add the new view
to applicable responsibilities.
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Viewing Audit Trail Records

After you have set up the fields, operations, responsibilities, positions, and
employees to be audited, you can read the results of the audit trails in the Audit Trail
view and the Audit Trail Items view.

Audit Trail View for File Auditing Mode

When you use file auditing mode, the Audit Trail list in the Audit Trail view provides
a list of files that have been audited for each user, business component, and session.
The Audit Trail Items list gives details of the selected file record. You have to import
files into the database to have a comprehensive view; otherwise, you can view
records on a file-by-file basis only.

CAUTION: You should purge and archive your records from the Siebel audit table
S_AUDIT_ITEM regularly to prevent the table from becoming too large. Carry out
these operations directly at the database level using native SQL. There is no EIM
interface table corresponding to the S_AUDIT_ITEM table.

To import audit trail items from a file into the Siebel database

1 From the application-level menu, choose View > Site Map > Audit Trail >
Audit Trail.

2 Select a record in the Audit Trail Buscomp list.

3 In the Audit Trail Item list, click the menu button and select Import Audit Trail
Item.

The audit trail items are imported into the table.

4 From the Show drop-down list, select Audit Trail Items.

NOTE: If you go back to the Audit Trail view and try to import audit trail items
that you have already imported, you will not be able to import them.
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To view audit trail records and record details

1 From the application-level menu, choose View > Site Map > Audit Trail >
Audit Trail.

2 Select a record in the Audit Trail list.

The Audit Trail Items list displays details of the selected record.

Querying Audit Trail Information

After recording or importing Audit Trail records into the database, you can query
Audit Trail information in the Audit Trail Items view. For example, you can query
Audit Trail items to determine changes made by team members, dates, or operations
performed on a business component.

To query audit trail information

1 From the application-level menu, choose View > Site Map > Audit Trail >
Audit Trail Items.

2 Query the list for Audit Trail items of interest.
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This chapter explains the procedures necessary to administer message broadcasting
and alerts for Siebel applications.

As an administrator, you can use message broadcasting and alerts to make sure that
specific users get the necessary and time-critical information they need, displayed
in a format that does not interfere with their work in progress.

About Message Broadcasting

Message broadcasting provides a platform for administrators and other users with
access to the Message Broadcasts view to send important information directly to
users’ screens. Typically, this information is time-critical, such as a due date, or it
is updated frequently, such as a call queue’s status.

For example, to help agents manage their workflow and respond appropriately to
calls, call centers may try to keep agents up-to-date on key statistics about call
queues, such as the number of calls waiting, the average time in queue, and other
important data. Traditionally, these statistics are displayed on a scrolling LED
“ticker” on the wall. This approach presents several problems:

= Agents have to look away from their screens to view the information.
= Agents can miss important information, if they do not look at the right time.
= Agents often get information that is not relevant to them.

Message Broadcasting addresses these problems by allowing administrators to send
relevant messages to individuals, groups, or an entire team. The messages can be
displayed by one of the following two methods:

= Scroll messages in the message bar across the bottom of a user’s screen, visible
at all times.

= Display messages in a dialog box in the middle of the screen, in addition to
scrolling across the bottom of the screen.
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Message Broadcasts can be created through the administration view, automatically
from Siebel Business Process Designer, or remotely from a third-party application
through Siebel eAl.

Message Broadcast messages are retrieved from the Message table through the
Siebel application server and sent to the message bars of the targeted Siebel Web
client sessions. There is no set order for the messages to appear on the message bar,
that is, the order cannot be controlled by the administrator or the end user.

Users can disable their scrolling message bar, but the administrator can override this
setting for broadcast messages.

About Alerts

Alerts provide a platform for administrators and other users with access to the Alert
Administration view to send long, complex, and customized messages directly to
selected groups of recipients. Typically, these messages are time-critical, but also
need to have associations with data in the company database (for instance,
literature or products) and to be customized for the recipient.

For example, to communicate product pricing changes to a sales team with
members around the world, a sales manager would want to be able to distribute
new pricing structures and product information as soon as they are approved.
Traditionally, this would be done with email messages, phone calls, or mailed
literature. This approach presents some problems:

= To provide the necessary details, a large quantity of information may need to be
distributed, with file attachments or links provided by the manager.

m Different team members may require different price list or product information,
depending on their organization, division, or position.

= Distributing information to remote team members may produce a
communication lag time.

As an administrator, you can use alerts to make sure that the specific users get the
appropriate information that they need.

Features of alerts include the following:
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m The abstract of alert messages are displayed in an applet on the recipients’ home
page, listed in order of the priority specified by the sender. Recipients can click
on the abstract to read the entire message.

m Literature items and products can be associated with alerts.

m  Access to price list and product information available to different team members
may be controlled by organization, division, or position.
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Business Scenario for Using Alerts

This scenario provides an example of a process flow performed by an administrator
and sales manager. Your company may follow a different process flow according to
its business requirements.

A multinational software development corporation uses the Siebel Sales application
to automate their sales workforce. The company is organized geographically by
division for the purpose of access control, and alerts are enabled.

An international sales manager has just been given the go-ahead for a new set of
software product bundles, which include one new product. He needs to
communicate these price changes to his company’s sales force as soon as possible.
Because pricing varies by geography, each of the four major geographical regions
represented by his company’s four sales divisions need to receive a customized
message about the new product bundles. He tells the Siebel administrator the
details of the alert message that needs to be sent.

The Siebel administrator creates the alert message, and associates a price list and
the new product with the message. She creates keywords that users will be able to
search on to find the message at a later date, if necessary.

When the Siebel administrator sends the alert, a customized message is sent to all
members of the international sales force, with the appropriate price list for their
division associated. Each member sees the alert message on their home page upon
login to the Web client or downloads alerts during synchronization. These users can
navigate through the home page or Site Map to read the text and any associated
literature items or products.
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Example Process Flow for Message Broadcasting and
Alerts

This is an example process flow for administering message broadcasting and alerts.
Your company may follow a different process flow according to its business
requirements.

1 Enable message broadcasting. For information, see “Enabling and Disabling
Message Broadcasting” on page 142.

2 Create a Message Broadcast. For information, see “Creating a Message
Broadcast” on page 145.

3 Optionally, create script to automatically update broadcast message text. For
information, see “Creating Broadcast Messages with Multiple Severity Levels”
on page 147.

4 Create an alert. For information, see “Creating Alerts” on page 152.
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Enabling and Disabling Message Broadcasting

By default, message broadcasting is enabled. As an administrator, you can enable
or disable message broadcasting at the server level using the following modes:

= Always enabled
= Always disabled
m  User enabled (default)

To enable or disable message broadcasting at the server level

1 From the application-level menu, choose View > Site Map > Server
Administration > Components.

2 In the Components list, choose the object manager for the application, for
example, Field Service Object Manager (ENU).

3 Click the Component Parameters view tab.
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4 In the Component Parameters list, select the Application Message Bar Flag
record and edit the Current Value field, referring to the following table:

Parameter Value

Description

TRUE

FALSE

User Enable 1

Message broadcasting is always enabled. Users cannot disable
message broadcasting by setting their personal preferences. For a
Web client deployment, the Siebel application will push messages to
users. For mobile client users, messages will be synchronized.

Message broadcasting is always disabled. The message bar and
message broadcast alerts will not appear on users’ screens. For a
Web client deployment, the Siebel application server will not push
messages to users. For a mobile client users, messages will not be
synchronized.

This is the default setting. Message broadcasting is enabled;
however, users can set their user preferences to enable or disable
message broadcasting. When a Web client user disables message
broadcasting, the Siebel application server will not push messages to
the user. When a mobile client user disables message broadcasting,
messages will not be synchronized.

For information on how users can change user preferences, see
Fundamentals.

1. Or any value other than true or false.

NOTE: If you set the Application Message Bar Flag parameter to true, you can
specify the update interval for the message bar by selecting the Application
Message Bar Update parameter and editing the Current Value. The default value
is 120 seconds. (If the update interval is less than the SessionTimeout set in the
eapps.cfg file, sessions will never timeout.) If you set the Application Message
Bar Flag parameter to User Enable, the update interval is a user preference. For
more information, see Fundamentals.

To enable or disable message broadcasting on mobile and dedicated Web clients

1 Use a text editor to open the .cfg file for your Siebel application.
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2 Find the ShowMessageBar parameter in the .cfg file.
For example:
ShowessageBar =" TRUE"
3 Set the parameter value to TRUE, FALSE, or User Enabled.

See Step 4 in the “To enable or disable message broadcasting at the server level”
procedure on page 143 for more information.

NOTE: If you set the ShowMessageBar parameter to true, specify the update

interval for the message bar by adding the following line to the .cfg file:
MessageBar Updat el nt erval = seconds

where seconds is the interval in seconds between message bar updates

(refreshes). The default value is 120 seconds.

4 Save and close the .cfg file.
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Creating a Message Broadcast

When you create a message broadcast, all connected users that you specify will
receive the message immediately upon the date and time you have specified that
the message be activated. Mobile users, such as field representatives, will receive
the activated messages when they synchronize.

NOTE: To send a message broadcast, you must have responsibilities that include
access to the Message Broadcasts view.

To create a message broadcast

1 From the application-level menu, choose View > Site Map > Communications
Administration > Message Broadcasts.

2 In the Message Broadcasts list, add a new record and complete the necessary
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fields.

Some fields are described in the following table.

Field

Comments

Abstract

Activation Date/
Time

All

Briefing Bulletin

Broadcast

A brief description of the message.

Date and time at which you want to start broadcasting the
message. If the Activation field is left blank, the message is
broadcast immediately.

Note: The date and time are taken from the Siebel server (not from
the machine where the client browser is running). Make sure that
the date and time are set correctly on the Siebel server.

Check this option to broadcast the message to all users.

Check this option to distribute the message as a bulletin in Siebel
eBriefings. For more information, see Siebel eBriefings
Administration Guide.

Required to send the message broadcast to recipient’s message bar.
Check this option to broadcast and display the message. If not
checked, the message is not broadcast in the message bar at the
bottom of the screen.
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Field

Comments

Division

Expiration Date/
Time

Message

Recipient

Severity

The broadcast message is sent to all users associated with the
divisions selected in the Divisions dialog box.

This field can be used in combination with the Recipient field.

Date and time at which you want to stop broadcasting the message.
If the Expiration field is left blank, the message will not expire and
the message will continue to be broadcast.

Note: The date and time are taken from the Siebel server (not from
the machine where the client browser is running). Make sure that
the date and time are set correctly on the Siebel server.

Required to create the message broadcast record. The text you
want to send as the message broadcast.This field accepts up to
2,000 characters.

To use severity levels within the message text, see “Creating
Broadcast Messages with Multiple Severity Levels” on page 147.

The broadcast message is sent to all users specified in the
Recipients dialog box.

This field can be used in combination with the Division field.

For an employee name to show up in the Recipient dialog box, the
employee must have a position defined and be marked active for
that position. If multiple employees occupy the same position, the
message will be sent to all of them, even though you only see the
active employee on the list.

Employees with multiple positions see messages sent to any of
their positions, regardless of what position they log in as.

Required to create the message broadcast record. Choose the
severity level to indicate the importance and appearance of the
message.

To force the message broadcast to appear in an alert box in the
middle of the screen, in addition to its appearance on the message
bar, select Urgent with Alert.
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Creating Broadcast Messages with Multiple Severity

Levels

Typically, the appearance of a message broadcast is designated by a single severity
level, as specified in the Severity field. Each severity level is associated with a
different color. The severity level that you choose determines the color of the
message broadcast and how it is delivered.

In addition to using the Severity field to determine the appearance of a message,
you can also combine multiple severity levels to create a message broadcast with
unique formatting. By adding special tags to the text of a message broadcast, you
can change the color of different sections of the message. The following tags are
used to combine severity levels in a message:

= [N] for Normal
= [H] for High
= [U] for Urgent

For example, if your message has a severity of normal, but you want specific text to
be highlighted, you can tag parts of the text with the code for High or Urgent. Here
is an example:

The trunk line from[H Chicago, Illinois [Nis [U DOM

The beginning of the message will appear in the color for the severity of the
message, Normal; the words Chicago, Illinois will appear in the color for High; and
the word DOWN! will appear in the color for Urgent.

To send a message broadcast with multiple severity levels

1 From the application-level menu, choose View > Site Map > Communications
Administration > Message Broadcasts.

2 In the Message Broadcast list, add a new record.
3 Complete the required fields to broadcast your message.

For descriptions of the fields, see the table in Step 2 in the “To create a message
broadcast” procedure on page 145.
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4 In the Message field, enter the message broadcast text you want to send.

5 In the Message field, insert severity level tags as necessary to set the appearance
of the message broadcast text.

For example: [H] All employees [N] must submit expense reports by [U] April 1,
2002.
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Automatically Updating Message Broadcasting Text

As an administrator, you can customize message broadcasting to automatically
update message text that changes frequently. For example, a call center’s queue
statistics frequently change. Every few minutes, an administrator has to update the
statistics to make sure agents have the most accurate information. This manual
approach is very time consuming and inefficient when dealing with frequently
changing data.

You can use Siebel eAl to automatically update message broadcasting text. Your CTI
middleware or ACD switch can provide the data for the Siebel application to
distribute.

The Broadcast Message business component manages the messages. The fields of
this business component are listed and described in Table 13. These field names are
necessary for developing the integration object.

Table 13. Field Names for the Broadcast Message Business Component

Field Description

Abstract Short summary for identifying the purpose of a message, such as
“Calls In Queue”

Activation Date/ When the message broadcasting should begin

Time

All To broadcast the message to all employees with positions defined
Body The text of the message displayed in the message bar

Division Used to set recipients using division

Division Id The internal identification value for Division

Expiration Date/ When the message broadcasting should end

Time

Position Used to set recipients using position

Position Id The internal identification value for Position
Recipient Used to set recipients using employee
Recipient Id The internal identification value for Recipient
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Table 13. Field Names for the Broadcast Message Business Component

Field Description

Type Severity of the message as defined in the List of Values type
BRDCST_MSG_TYPE

Via Broadcasting | To send the message using message broadcasting

Via Interactive To send the message via Siebel eBriefings

A sample Visual Basic (VB) script follows, which demonstrates how to create and
update a broadcast message with information, using the call center queue as an
example. The sample Visual Basic script is generic; your CTI middleware’s API
determines the structure of syntax like the Msg command.

Sample Message Broadcasting Script

The script can be created through a button, an Excel macro, or another VB
application. Because it is a script and not an application, it does not need the VB
Set command. All the commands are standard to VB coding.

This script is designed to update a message without an expiration date, not to create
a new message every time. For more information on how to get or create a Siebel
Application Object, see Siebel Tools Online Help.

CAUTION: The code in this example updates single value fields. For information on
how to update multi-value fields, see Siebel Tools Online Help.

' CGet "Broadcast Message" BusConp
Set BusOhj = Siebel Application. Get BusChj ect (" Br oadcast
Message", err Code)
Set BusConp = BusObj . Get BusConmp( " Broadcast Message", err Code)

"Find "Calls Waiting" nessage
BusConp. Set Sear chSpec "Abstract”, "Calls In Queue", errCode
BusConp. Execut eQuery 0, errCode
I f BusConmp. Fi rst Record(errCode) <> True Then
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"W need to create a new nessage
BusConp. NewRecord 0, err Code
BusConp. Set Fi el dval ue "Abstract"”, "Calls I n Queue", errCode
End |f

‘Prepare nmessage using mddl eware APl info.
Set Msg = "[N]Calls Waiting: [U]10"

"Update the record
BusConp. Set Fi el dval ue "Body", Msg, errCode
BusConp. Set Fi el dvalue "All", "Y', errCode

"Wite the record
BusConp. WiteRecord errCode

In addition to writing a script, you can use Siebel Business Process Designer to
create or update a broadcast message. For more information, see Siebel Business
Process Designer Administration Guide.

Version 7.5, Rev. C Applications Administration Guide 151



‘ Message Broadcasting and Alerts

Creating Alerts

Creating Alerts

When you create an alert, all connected users that you specify will receive the alert
immediately upon its activation date and time. Mobile users, such as a sales force,
will receive an activated alert upon synchronization.

NOTE: Before creating alerts, review Release Notes for information about Alerts
(Message Alerts).

To create and send an alert

1 From the application-level menu, choose View > Site Map > Alert
Administration.

2 In the Alerts list, add a new record and fill in the appropriate fields in the list
and More Info form.

Some fields are described in the following table.

Field Comments

Priority The priority of the message determines where the message appears
in the list of alerts on the users’ home pages. Messages with the
highest priority will be at the top of the list.

Keyword Enter keywords that the user will be able to search on to find this
message.
Type The type chosen from the drop-down list helps determine who will

receive the alert, as follows:

= Employee Home Page Alert: Displays the alert on all employees’
home pages.

» Partner Alert: Displays alerts to employees of registered partner
companies.

= Program Information: Displays the alert to self-registered,
individual partners.

» Public Information: Displays the alert to unregistered,
anonymous users.
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Creating Alerts

Comments

Abstract

Activation
Expiration

Partner Alert

Employee
Alert

All Users

Message Body

Message Body
Preview

Enter a brief abstract that summarizes the message. This will appear
as a hyperlink on the appropriate users’ home pages.

Enter the date when the message will first appear to users.
Enter the date when the message will no longer appear to users.

Indicates that the alert is intended for partner companies. Make sure
that this field is selected so that your alert will be seen.

Indicates that the alert is intended for employee users.

Make sure that this field is selected so that your alert will be seen.

Select this box if you want the alert to appear to all users, as
indicated by the Employee Alert or Partner Alert check boxes.

For example, if the Employee Alert check box is checked, and the All
Users check box is checked, all employees will receive the alert.
Type in the text of the message, including HTML formatting code if
desired.

Alerts can be enhanced by using the following HTML formatting
codes:

s <b>text</b> = bold

®  <u>text</u> = underline
m  <i>text</i> = italics
s <h4>text</h4> = fontsize

»  <a>href="http:text” < /a> = hyperlink to Web page or site

Displays message as it will look to users.

3 If you want to add literature as an attachment to the message:

a Click the Literature view tab.

b In the Literature list, click Add.
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¢ Inthe dialog box, select the Literature record or records you want to add, and
click OK.

NOTE: Only literature of type Sales Tool can be added.

4 If you want to add a product as an attachment to the message:
a Click the Product view tab.
b In the Product list, click Add.

¢ In the dialog box, select the product or products you want to add, and click
OK.

5 If you want to specify the recipients of this message:
a Click the Recipients view tab.

b From the Show drop-down list, select Recipient Divisions or Recipient
Positions, and click Add.

¢ Select the record or records you want to add, and click OK.

Remember, if you selected the All Users check box in Step 2 on page 152, the
message will automatically be sent to all recipients.
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This chapter describes the administrative setup tasks that need to be performed
before the Messages screen and views are used.

For more information about the Messages screen and views, see Siebel Call Center
User Guide.

NOTE: The Messages functionality is unrelated to the message broadcasting and
alerts discussed in Chapter 6, “Message Broadcasting and Alerts.”
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Setting Up the Messages Workflow

To set up workflows for the Messages screen and views

1 Make sure that the Communications Management and the Workflow
Management component groups are enabled.

For information, see Siebel Business Process Designer Administration Guide.

2 Activate the Messages workflow policies. All Messages workflow policies are in
the Siebel Messaging policy group.

For information about activating workflow policies, see Siebel Business Process
Designer Administration Guide.

3 Activate Siebel Message send email and Siebel Message send email for activity
owner workflow processes.

For information about activating workflow processes, see Siebel Business Process
Designer Administration Guide.
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Setting Up Users with the Message User Responsibility

Users with the Message User responsibility have access to the Messages views.
To set up users with the Message User responsibility
1 Navigate to Applications Administration screen > Responsibilities view.

2 Make sure that all users who need access to the Messages views are assigned the
Message User responsibility.

For more information about setting responsibilities for users, read about defining
responsibilities in Security Guide for Siebel eBusiness Applications.
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This chapter describes the features of Content Center.

Content Center allows you to create and manage authored content, which includes
items such as price lists, service solutions, and static Web site content, for Siebel
eBusiness Applications.

Content Center features include:

= Preview and simulation. You can use a content staging environment to preview
and test content before you publish it to your production environment. The
staging environment displays content exactly as it will appear to customers,
employees, and partners in your production environment. The staging
environment runs on a separate database from the production environment.

= Content projects. You can group a set of content items into one content project,
so that related changes can be made together. For example, you can create a
content project to manage all the products, catalog categories, price lists, and
marketing literature for your company’s summer catalog.

= Content Asset Management. You can use the content asset repository for storing
and managing unstructured content as assets and sets of assets. Content Asset
Management establishes check-out and check-in procedures to serialize access
to content, and prevent changes from being lost by users trying to update
content simultaneously. Content can be rolled back to earlier versions if the
changes made were unsatisfactory.

= Approval processes. You can use Siebel Business Process Designer to design
approval processes that allow team members to review a content item before it
is published. Siebel Business Process Designer allows you to assign tasks based
on a predefined list of content contributors and approvers.
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= Publishing. After content is approved, Content Center uses Siebel Business
Process Designer to publish it to a production environment. The XML-based
publication service can handle both complex database content and unstructured
content that is stored in the file system. This component helps maintain
transactional integrity between all the items in a content project.
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Content Center Job Roles and Terms

Descriptions of Content Center job roles are in Table 14, and terms are defined in

Table 15.

Table 14. Content Center Job Roles

Position

Content
Administrator

Content
Contributor

Content
Approver

Responsibilities

One or more people in your business who are authorized to administer
content. These people will need to understand your business
requirements in order to know what types of content and content items
will need to be managed and the appropriate contributor and approver
workflows.

Depending on your business requirements, one or more of these people
may also be responsible for selecting and possibly configuring the
appropriate business components, content objects, and content types.
Alternatively, this may be done by an application developer.

A person in your business who is authorized to contribute content
items. Examples are technical writers, Web designers, and graphic
artists.

A person in your business who is authorized to approve content posted
to your company’s Web site. Examples are managers and your
company’s attorneys.
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Table 15. Content Center Terms

Term

Content

Content Asset

Content Item

Content Object

Definition

The components of the application that are authored, as opposed to
application code. Siebel applications recognize the following classes of
content:

= Business rules, such as personalization rules and assignment rules

= Application content, such as product catalog, price lists, and
product promotions

= Web content, such as Web templates and static Web pages,
typically stored as HTML, XML, and image files

= Documentation, such as product data sheets, forms, and white
papers

Content Center provides content production services for three of the
classes listed above: application content, Web content, and
documentation, while content asset management only applies to Web
content and documentation.

An instance of content managed within Content Center and stored in
the content asset repository. Content assets are typically comprised of
unstructured markups and can be related to other content assets. For
example, an HTML content asset can link to other pages or reference
images.

Represents a transaction (add, update, delete) stored and associated
with a piece of content.

Specifies the information that will be transferred from the staging
environment to the production environment when the content is
published. Each content object is composed of a business object and
an integration object.
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Table 15. Content Center Terms

Term

Content Type

Content Asset
Type

Definition

A set of business rules you define for handling content, including rules
that apply to the approval workflow, contributors, approvers, and the
application views your company uses to edit or preview content. Each
content type is based on a content object, and is associated with an
approval workflow and a group of contributors and approvers.

The following are examples of content types authored in Siebel
applications that can be managed through Content Center:

= Siebel eCatalog: catalog, categories, product, product line, and
product literature

»  Siebel ePricer: price list, pricing factor, rate list, and volume
discount

= Siebel Marketing: offers (Web, phone, eMail, direct mail,
newsletter), campaign, and marketing development fund

» Siebel Service: service solution, decision issue, resolution
document, and smart script

The file type (or filename extension) of a content asset, for example
HTML, GIF image, or plain text.
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Setting Up a Content Staging Environment

A content staging environment is similar to a test environment, except that you use
it to test content rather than application configuration. This allows you to develop
and test new content without affecting your production applications.

After content is approved, Content Center uses Siebel Business Process Designer
and an XML-based content publication service to send it to the production
environment. For more information about Siebel workflows, see Siebel Business
Process Designer Administration Guide.

Required Components for a Content Staging Environment
Content Center requires a separate Siebel eBusiness Applications installation for
your content staging environment. The physical hardware for this environment
should be the appropriate size for supporting the number of content center
administrators, contributors, and approvers who will manage your business
content.

For more information about installing Siebel eBusiness Applications, see the Siebel
Server Installation Guide for the operating system you are using.

Your staging environment should contain the following components:
= Database

»  Gateway Server

= Siebel Server

m File System

m  Web Server and Siebel Web Extension

Maintaining Consistency Between Staging and Production
Environments

It is important that the staging and production environments are consistent when
Content Center is implemented.
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The most important element to keep synchronized is the Siebel repository (.srf) file.
This file defines the structure of the application data, for example, the business
components and the integration objects.

Keeping the data synchronized is not relevant, with the exception of content and
related data. For example, if you use Content Center to manage product literature,
then Content Center synchronizes the content by publishing it from staging to the
production environment. In this case, products could be related data that also need
to be kept synchronized. Although you may have chosen not to manage products
through Content Center, nevertheless you must have a user key, such as product ID,
that exists in both the staging and production environments so that the association
of a piece of literature to a product can be made in the staging area and reproduced
in the production environment.

The following are some tips to help you maintain consistency between your staging
and production environments.

m If your production environment has not yet been installed, the database
administrator should install two separate database instances (one for staging
and one for production) using an identical Siebel repository (.srf) file, and
initialize both instances with the same seed data. This will make sure that the
content object definitions in your staging and production environments are the
same.

For more information, see the Siebel Server Installation Guide for the operating
system you are using and Siebel Tools Reference.

m If your production environment is already active, the database administrator
should install the staging environment using the same Siebel repository (.srf) file
as used for the production environment. Make a copy of your database and use
the copy to initialize your staging environment.

m  Because you will perform most or all content administration tasks in your
staging environment, you should either disable or limit access to the appropriate
content administration views in your production environment. This will help
prevent administrators from accidentally making updates in the production
environment.
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Business Scenario for Using Content Center

This section describes business scenarios for using Content Center.

Business Scenario for Content Center

This scenario provides an example of a business scenario performed by a content
administrator (in this case, the business manager), a Web site designer, an
application developer, and content contributors and approvers. Your company may
follow a different process flow according to its business requirements.

The business manager and Web site designer have designed the company’s Internet
home page. The page includes a section which will display a single targeted Web
offer to customers visiting the site. The contents of this section will require a
managed contribution and approval process to produce accurate and timely display
of product offers.

First the application developer makes an Offer business component that is content-
enabled and defines the Web Offer content type. Then he works with the business
manager to develop some personalization rules to target the Web offers, tests the
home page, and deploys the home page to the production environment.

The business manager is concerned that the graphics contained in various Web
offers may clash with the company logo, so she edits the single approval workflow
for the Web Offer content type. She adds an additional approval step for the site
designer position, and associates the appropriate contributor and approver
positions to those steps in the approval workflow.

Next, she configures the publication workflow, setting the connect string for the
server in the production environment.

She then sets up the content project, adding the content items that make up tasks
required to create the Web offer. These will be routed to the Content Inboxes of the
content contributors and approvers as set up in the approval workflow.

After the content items have been completed and approved, she publishes the
project to the production environment.
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Business Scenario for Content Asset Management

Content Asset Management is typically used in conjunction with other screens in
the Siebel eBusiness Application, for example Microsite Management and Group
News. For sample business scenario where Content Asset Management is used, see
“Business Scenario for Microsite Management” on page 209.
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Example Process Flow for Using Content Center

These are examples of process flows for using Content Center and Content Asset
Management. Your company may follow a different process flow according to its
business requirements.

Figure 5 illustrates the process flow for the “Business Scenario for Content Center”

on page 166.
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Figure 5. Example Process Flow for Content Center
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Configuring Content Objects for Content Center

The content object definition specifies the information that will be transferred from
the staging environment to the production environment when the content is
published.

Content objects are based on business objects and integration objects. Siebel
Systems provides some prebuilt content objects which you can use, or configure to
meet your business needs. See Appendix B, “Content Center Reference” for details
about the prebuilt content object definitions.

You use content objects to create one or several content types. Each content type is
based on a content object, and is associated with an approval workflow and a group
of contributors and approvers. For example, from the Product content object, you

might create two different content types: Software Products and Hardware Products.
These two content types may have different approval workflows, as well as different
contributors and approvers. For more information, see “Setting Up Content Types”
on page 180.

The main steps involved in setting up content objects are:

= Use Siebel Tools to identify or define the business object on which you will base
the content object. For more information, see Siebel Tools Reference.

= Modify the business components to meet the content object requirements. For
instructions, see “Modifying Business Components for Content Center” on
page 170.

s Use the EAI Object Wizard in Siebel Tools to create an integration object. For
instructions, see “Creating Integration Objects for Content Center” on page 172.
For more information, see Siebel Tools Reference.

= Modify the integration object to meet the content object requirements. For
instructions, see “Modifying Integration Objects for Content Center” on
page 173.

NOTE: You do not need to create content objects for content assets. These are
provided with the preconfigured product.
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Modifying Business Components for Content Center

NOTE: This step is potentially recursive. Complete this step before using the EAI
Wizard in Siebel Tools to create integration objects.

After you have identified or defined the business object on which your content
object will be based, check its business components for underlying tables that
contain foreign keys to other tables. If there are business components with foreign
keys, you must modify them to assure the integrity of foreign keys when these
objects are published.

Typically, you need to follow one of the following two processes to modify the
business components.

Modify the business components containing foreign keys:

1 Create a join in the business component from each foreign key column to the
row_id of the foreign key’s table.

2 C(Create fields in the business component for all user key columns in the foreign
key's table. If any of these columns are foreign keys, repeat Step 1.

3 Assign a PickList and fill the PickMap with the foreign key and all related user
key fields, including any intermediate foreign key fields.

4 Add Pick Map UpdOnlyIfNull columns for each Id type column in the Pick Map.

The UpdOnlyIfNull column should be the same one as its parent on the Pick
Map.

Or, if the business component table contains a foreign key to a child (or other
descendent) object in the business object:

1 Create a Multi Value Link to the business component on the foreign key table.

2 Include the entire foreign user key as multi-value fields. Expand foreign keys in
the user key by joining and adding fields to the Multi Value Link business
component.
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3 Set the Primary Id field of the Multi Value Link to the foreign Key column.

NOTE: To resolve foreign keys to child (descendent) objects in the correct order, you
must specify a sequence number and XML sequence number for the resulting
integration object.

If two business components joined by a foreign key contain user key columns of the
same name, create different field names for each user key column. Table 16 shows
an example.

Table 16. Example: How to Handle Identical User Key Column Names

User Key
Business Component Columns Comments
Internal Product Sales = BU_ID This is a foreign key from the Internal Product Sales
Tool Tool business component to the Organization

business component.

NAME This is a _U1 user key column in the Internal
Product Sales Tool business component.

This user key column name is identical to the one in
the Organization business component described
below.

In the Internal Product Sales Tool, create a field
called Name to map to this column.

Organization NAME This is a user key column in the Organization
business component.

This user key column name is identical to the one in
the Internal Product Sales Tool business component
described above.

In the Internal Product Sales Tool, create a field
called Organization Name to join to this column.

NOTE: Later, you will disable all other user keys, so you only need to check for
duplicate names in your business component’s _U1 table user key.
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Creating Integration Objects for Content Center

Integration objects are sometimes called EAI objects, because they use Enterprise
Application Integration (EAI) technology. You use the EAI Object Wizard in Siebel
Tools to create integration objects. For more information, see Integration Platform
Technologies: Siebel eBusiness Application Integration Volume II.

To create an integration object
1 In Siebel Tools, select File > New Object.
2 From the dialog box, select Integration Object.

The EAI Object Wizard guides you through the process of setting up an
integration object.

After you create the integration object, you need to modify it to meet the
requirements for a content object. For instructions, see “Modifying Integration
Objects for Content Center” on page 173.
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Modifying Integration Objects for Content Center

Use the following guidelines to modify integration objects to meet content object
requirements.

To modify integration objects:

= In the integration object, make sure that the link that defines the parent to child
relationships allows update and delete. If the link does not allow those
operations, replace it with a link that does.

= In the integration object user properties, add AdminMode, value Y. This gives
the EAI Siebel Adapter permissions to do synchronization against a Siebel
database.

= Disable these types of integration components:
o All calculated fields.

o All integration components created from Multi-Value Link (MVL)
components, unless your business requires that you transfer those multi-
values to your production environment.

o If more than one field is mapped to a table column, all fields except one.

o For integration components that have file attachments, the field that
stores the file revision number. For example, in the Admin Sales Tool
integration component, disable the LitFileRev field.

= In the integration component, disable:
o The NoDelete, Nolnsert, and NoUpdate user properties.

o All user keys except the one that is based on the _U1 table user key, which
is used for integration between the two Siebel databases.

o Allidentification (Id) fields. (Make sure that each field is listed in the Pick
Map UpdOnlyIfNull list of its entry in the pickmap for the user key of its
join table.)
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Setting Up Content Center Approval Workflows

You can use Siebel Business Process Designer to manage workflows for the content
item approval process. When the Start Project or Request Start Project action is
invoked on a content project, the approval workflows associated with each content
item in the project are instantiated.

Approval workflows allow you to specify the structure for contributing, reviewing,
and approving content. The designated contributors and approvers are notified by
new records in their Content Inbox at the appropriate step in the content production
and approval process. For more information about designating contributors and
approvers, see “Setting Up Content Types” on page 180.

A state model and some workflows are associated with the approval workflow
included in the seed data that is provided in Siebel applications. You can use these
processes in your deployment, modify them to meet the needs of your business, or
simply use them as a guide for creating your own approval workflows.

For more information on creating or modifying workflows, see Siebel Business
Process Designer Administration Guide.

NOTE: All Content Center workflows should be placed into the Content Center group.

About the Content Item State Model

A state model, called Content Item Status, controls the status changes of a content
item.
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Table 17 describes each of the content item states.

Table 17. Content ltem Status

State

Pending Submit

Submitted

Pending Approval

Approved

Rejected

Canceled

Completed

Description

Applied by the workflow process.

If the current task in the workflow is a Contribute task, the workflow
process applies the Pending Submit state to indicate that an end user
is expected to perform some action on the content item.

Applied by an end user.

A content contributor applies the Submitted state to indicate that the
actions associated with this content item have been completed.

Applied by the workflow process.

If the current task in the workflow is an Approval task, the workflow
process applies the Pending Approval state to indicate that an end
user is expected to review the content item.

Applied by an end user.

A content approver applies the Approved state to indicate that the
content item has been reviewed and approved.

Applied by an end user.

A content approver applies the Rejected state to indicate that the
content item has been reviewed and disapproved.

Applied by an end user.

A content contributor or approver applies the Canceled state to
indicate that the content item should no longer be included in the
current content project.

Applied by the workflow process.

This is a terminal state that indicates that the workflow approval
process has been completed for the content item. A content item must
be in the Completed state before it can be published.

About the Content Approval (Single Approver) Workflow

The Content Approval (Single Approver) workflow is a simple workflow that
demonstrates a single approver approval process. You can use this workflow with
or without modification.
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The Content Approval (Single Approver) workflow uses these step types to
construct the business logic for content item approval:

= Content Task Subprocess. This step type is used to indicate that the Content task
assigns the content item to an end user to perform some action. Each Content
task has a type and a sequence number. The task type is either contribution or
approval. The task sequence indicates the Siebel position to which the content
item should be assigned, as specified on the content item. This step calls the
Content task workflow subprocess. For more details about the subprocess, see
“About the Content Task Subprocess.”

= State Decision Point. This step type performs branching logic in the approval
process. The branching logic is based on the state that is applied to the content
item after a Content task. For example, a decision point is used to reassign a
content item to the originator after it is rejected.

m State Update Siebel Operations. The Siebel Operation step type is used to make
updates to the content item state.

You can use these workflow components to create new approval workflows or to
modify the Content Approval (Single Approver) workflow for your business. For
example, if you require two approval tasks, you can add two Content Task
Subprocesses and State Decision Points.

About the Content Task Subprocess

The Content Task Subprocess contains the common logic of assigning a content
item and waiting for a user action. The parent approval process calls this subprocess
each time a content item is assigned to an end user. Calling this task causes the
content item to appear in the Content Inboxes for those users associated with the
current sequence (TaskSeq).

The parent business process must pass in the input arguments shown in Table 18.

Table 18. Parent Approval Process Input Arguments

Input Argument Description

Object Id The content item ID from the parent (Content Approval) to the child
(Content Task) Subprocess.
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Table 18. Parent Approval Process Input Arguments

Input Argument Description

TaskSeq Passes the sequence number of the current task.

TaskType Indicates that the current task is either type Contribute or type
Approve.

The Content Task Subprocess performs these actions:

= Sets the content item state to either Pending Submit or Pending Approve,
depending on the TaskType for the current task.

= Sets the content item Current Approval Sequence Number field to the TaskSeq
value. This makes the content item visible to the appropriate end users in the
Content Inbox view.

= Wiaits for the end user to take action on the content item and make a state
change to the item. When this occurs, the workflow process resumes and returns
control to the parent approval process.

About the Auto Complete Workflow

An approval workflow must be run for each content item before a content project
can be published. (See “To start the project approval workflow” on page 183.) To

publish content without routing it through approvers and contributors, use the Auto
Complete workflow. The Auto Complete workflow is a simple workflow, provided
with the seed data. It sets the status of a content item to Completed immediately so
that the project is ready for publication.
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Setting Up Content Center Publication Workflows

The Siebel XML-based publication service can transfer any data that can be
accessed through a business component: both complex database content and
unstructured content. Transactional integrity is maintained between all the items in
a content project.

Project publishing is controlled by Siebel Business Process Designer in order to
provide flexibility to the workflows in the publishing process. When a business
manager invokes either the Publish or Request Publish action for a project, the
publication workflow associated with the project is instantiated.

Siebel applications provide two predefined publication workflows in the standard
product:

= Content Publish workflow

This workflow publishes a content project from a staging environment to a
production environment. There is only one step in this workflow, which calls the
Content Project business service. You may extend this process to meet your
specific business requirements. For example, you may add additional workflow
steps to integrate with other systems or wait for a specified period of time before
publishing.

» Content Publish to Files workflow

This workflow is similar to the Content Publish workflow, except that the
content project is published to XML files in a specified directory instead of to the
production environment.

You can use these processes in your deployment, modify them to meet the needs of
your business, or simply use them as a guide for creating your own publication
workflows.

For more information on creating or modifying workflows, see Siebel Business
Process Designer Administration Guide.

NOTE: All Content Center workflows should be placed into the Content Center group.
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About the Content Project Business Service

The Content Project business service is designed to publish a content project from
the staging environment to the production environment or to publish the content
items as XML files. In the publication workflow, the Export method of this business
service is called, indicating that the content items in the project will be exported
from the staging environment. The publishing target is set using two method
arguments, specified as workflow properties:

Connect String. A Siebel connect string, specified as:
si ebel : // namesrvr: 2320/ ent er pri se/ obj nmgr/ si ebsrvr

For example: si ebel : // denpsr vr: 2320/ si ebel / SCCObj Myr _enu/ denosr vr

The Content Project business service connects to the specified object manager,
such as SCCObjMgr for Siebel Call Center, as the current user and makes the
appropriate updates, inserts, and deletes for each content item in the project.
These changes are made by the content object in the sequence specified in Siebel
Tools for each content object.

Export Directory. The name of a file system directory into which the XML should
be placed. For example, c:\temp or \\fileserver\publish\export. The directory
must exist and be accessible to the object manager. Specifying this property
exports the content items within the project as a series of Siebel XML files. The
files will use the naming convention:

» Upload content object name.xml—for content items that are to be added.

= Delete content object name.xml—for content items that are to be deleted in
the target system.

NOTE: Detailed information about the other methods in this business service are
given in Appendix B, “Content Center Reference.”
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Setting Up Content Types

Content types define the business rules for managing a class of content through the
creation and approval process.

Each content item is assigned a content type. The content type determines the
following for the content item:

m The approval workflows
m  Which views are used to preview or edit the content

A set of predefined content types are provided. You can also create new content
types according to your business process, as described in the following procedure.

NOTE: Do not confuse content types with content asset types, which fulfill a different
function. For information about content asset types, see “About the Content Asset
Types View” on page 202.

To set up content types

1 From the application-level menu, choose View > Site Map > Content Center
Administration > Content Types.

2 Create a new record and fill in the necessary fields.

Some of the fields are described in the following table.

Field Description

Name Unique name of the content type.

Content Object The object chosen from this MVG specifies the information that is
transferred during publishing.

For more information, see “Configuring Content Objects for Content
Center” on page 169.

Approval Defines the content contribution, review, and approval process for
Workflow this content type. For more information, see “Setting Up Content
Center Approval Workflows” on page 174.
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Description

Content Type
Views

Picklist

Pick Applet

A list of the views used to administer or preview content of this type.
These views determine the end-user navigation from the Content
Inbox. Examples are the destination views for the Item Reference
hyperlink, in Step 4 in the “To contribute (add or edit) a content
item” procedure on page 186 and the Action hyperlink in Step 5 in
the “To contribute (add or edit) a content item” procedure on
page 186.

Determines the drop-down list that will be used to select content of
this type.

Determines the pick applet that will be used to select content of this
type.
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Setting Up Contributors and Approvers

After you set up approval workflows for content objects, you must specify
contributors and approvers for the content.

When you create a content type, you assign default contributors and approvers to
each sequence number. If necessary, these defaults can be overridden (Content Item
detail view) when the content item is created.

To set up a contributor or approver

1

N g A~ W

From the application-level menu, choose View > Site Map > Content Center
Administration > Content Types.

Select the content type for which you would like to create a list of contributors
and approvers.

Click the Contributors and Approvers view tab.

In the Contributors and Approvers list, add a new record.

In the Position field, select a position from the Pick Position dialog box.
In the Seq field, specify a sequence number for the selected position.

You can specify multiple positions for the same sequence number. Doing so will
place the content item into multiple Content Inboxes for this task; however, only
one individual will be able to complete the task.

In the Comment field, add a default comment for each position.

Comments are visible to users when they receive the content item in their inbox.
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Creating Content Projects

You can use a Content Project to manage the process of adding, editing, and deleting
application content. The Content Project provides a virtual folder through which a
set of related content item changes can be managed. You use the Content Projects
view to create projects, start the project approval workflows, and review content
project status.

To create a content project

1

From the application-level menu, choose View > Site Map > Content Center
Administration > Content Projects.

In the Content Projects list, add a new record, specifying a name and
description.

In the More Info form Plan Publication Date field, enter the date you plan to
publish this project.

This date does not automatically publish the project.

In the Publication Workflow field, select the publication workflow that you will
use for this project.

Click the Content Items view tab, add a new record to the Content Items list, and
complete the necessary fields.

For each content item, you must specify a descriptive name, a content type, a
description of the work to be performed, and a status (Add, Update, or Delete).
If the item has a status of Update or Delete, you can also specify the item
reference, which allows you to select the specific piece of content that should be
changed.

NOTE: You can change any contributors or approvers for a content item by editing
the Contributors and Approvers list.

To start the project approval workflow

1
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From the application-level menu, choose View > Site Map > Content Center
Administration > Content Projects.
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2 From the Content Projects list, select the appropriate content project.

3 On the More Info form, click the menu button and select one of the following:

Start Project. This changes the state of the project from Draft to In Process
and instantiates the approval workflows synchronously. This means that
users must wait for all workflow processes to begin before regaining control
of the user interface. For large projects, this could take several minutes.

Request Start Project. This changes the state of the project from Draft to In
Process and instantiates the approval workflows asynchronously on a
separate server component, which returns control to users more quickly. This
is the recommended method to use for projects that contain thirty or more
items. This method requires that the Content Project Start server component
is online. (See Siebel Server Administration Guide for information about
starting server components.)

NOTE: If you add more content items to the project after it is in the In Process state,
invoke the Start Project or Request Start Project action again to start the approval
workflows for the new content items.

To review status of content project and content items

1 From the application-level menu, choose View > Site Map > Content Center
Administration > Content Projects.

2 From the Content Projects list, select the appropriate content project.

The status of the project is given in the More Info form. The table below explains
the Project Status values.

Project Status Description

Draft The project has been created and the approval workflow has not

been started.

In Process The approval workflow has been started.

Published The project has been published.

184 Applications Administration Guide Version 7.5, Rev. C



Content Center

Creating Content Projects

3 Click the Content Items view tab.

You can review the status of each content item, and check or change its
assignment. By clicking the Item Reference for a content item, you can preview
the current state of the content. See Table 17 on page 175 for possible status
values.
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Contributing and Approving Content

The Content Inbox is the screen that Content Contributors and Approvers use to
interact with the approval workflow. In the My Content Items view users will see
any content item currently assigned to their position by the approval workflow, and
will be able to drill down on hyperlinks to the appropriate views to contribute, edit,
preview, and approve content.

To contribute (add or edit) a content item

1
2

Navigate to the Content Inbox screen.
From the Show drop-down menu, select My Content Items.

The Content Items list contains all of the content items currently assigned to you
by the approval workflow.

Items that require contribution can be identified by the status Pending Submit.
Select an item.
For each item, you can perform the following optional actions:

= Click the Contributors and Approvers view tab to see the positions assigned
to the contribution and approval process.

= Click the History view tab to review actions taken on the item to date.
» Drill down on Item Reference hyperlink to preview the content item.

Drill down on the Action hyperlink and use the associated administration view
to add or edit content.

This link will dynamically take you to the Add/Edit view associated with the
content type. If the action is Delete this link is not active. Instead, completion of
a deletion task indicates approval to delete the referenced item.

For more information about editing content assets, see “About Content Assets”
on page 190.

Return to the Content Inbox using the History button.
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If the content item is an Add action, update the Item Reference field on the
content item to reference the content you just created. Clicking the Item
Reference pop-up displays a pick list from which you can select the content
record that you just created.

Click on the Item Reference link to view the item and verify that it is complete
and accurate.

Return to the Content Inbox using the History button.

Add comments as needed to the content item, and change the status of the item
as appropriate. For example, change the status from Pending Submit to
Submitted.

To approve content

1
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View all content items in the Content Inbox and select an item to work on. Items
that require approval can be identified by the status Pending Approval.

For each item, you can perform the following optional actions:

= Click the Contributors and Approvers view tab to see the positions assigned
to the contribution and approval process.

= Click the History view tab to review actions taken on the item to date.
» Drill down on Item Reference hyperlink to preview the content item.

Make any comments to the content item, and change the status of the item as
appropriate. For example, change the status from Pending Approval to Approved
or Rejected.
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Publishing Content Projects

After the content for a project has been added and approved, use the Content Center
publication workflow to publish to your production environment.

Make sure that:

= You have specified the publication workflow for the project. (See Step 4 in the
“To create a content project” procedure on page 183.)

m The status of the project is In Process and the status of each item in the project
is Completed.

188 Applications Administration Guide Version 7.5, Rev. C



Content Center

Publishing Content Projects

To publish a content project

1 From the application-level menu, choose View > Site Map > Content Center
Administration > Content Projects.

2 From the Content Projects list, select the appropriate content project.
3 Click the menu button, and select one of the following:

= Publish. This changes the state of the project to Published and instantiates the
publication workflow synchronously. This means that users must wait for all
workflow processes to begin before regaining control of the user interface.
For large projects, this could take several minutes.

= Request Publish. This instantiates the publication workflow asynchronously
on a separate server component, which returns control to users more quickly.
This is the recommended method to use for projects that contain thirty or
more items. This method requires that the Content Project Publish server
component is online. (See Siebel Server Administration Guide for information
about starting server components.)

4 If you selected Request Publish in Step 3:

a From the application-level menu choose View > Site Map > Server
Administration > Components.

b In the Components list, select the Content Project Publish record, and check
the task state of the component tasks.

If publication fails, the task state is “Exit with Error.”

NOTE: A content project cannot be republished, except by creating a new content
project, for example by copying the published project.
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About Content Assets

Content assets are a special type of content handled by Content Center. Content
assets differ from other types or classes of content in that they are stored in the
Siebel application’s content asset repository. Content Asset Management allows
check-out and check-in control and versioning of the content managed as assets.

Content assets are typically unstructured data such as Web pages, images, Microsoft
Office documents, and text files.
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Defining Content Sets to Contain Content Assets

Content sets are collections of content assets. Every content asset must belong to a
content set and should have a unique name within that set. Content sets cannot be
nested, that is, content sets cannot be contained within other content sets.

After a content set is defined, you can:

Add content assets to the set

Preview the home page asset of the set

Review the history of the set

Establish the locks on content assets in the set

Figure 6 shows part of the Content Explorer view; content assets, locks, and history
information are shown as children of the content set record.

Figure 6. The Content Explorer View
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To create a content set

1 From the application-level menu, choose View > Site Map > Content Center
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Administration > Content Sets.
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2 In the Content Set list, create a new record, and complete the necessary fields.

Some fields are described in the following table.

Field Comments

Name A unique name for the content set record.

Title A short descriptive title for the content set.

Description Text describing the content set.

Home Page This field cannot be filled in until there are content assets in the
content set. See “Setting the Home Page for a Content Set” on
page 195.
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Adding Content Assets to a Content Set

Content assets can only be created as child records of a content set.

To add content assets to a content set

1 If necessary, navigate to the Content Sets view (Step 1 in the “To create a content
set” procedure on page 191).

2 In the Content Set list, select the content set to which you want to add an asset.

3 Click the Assets view tab.

4 In the Assets list, create a new record and complete the necessary fields.

Some fields in the Insert Content dialog box are described in the following table.

Field

Comments

Name

Title

Content (Asset)
Type

Filename or URL

Lock

A name for the content asset record. Enter a name that is unique
within in the content set.

A descriptive title for the content asset.

Leave this field set to Auto-Detect (the default) to have the
application determine the asset type, or select a type from the
dialog box to set a specific type. For more information, see
“About the Content Asset Types View” on page 202.

Click the browse button, and then browse for a file or type a
URL or network path to the content you want to copy into the
Content Asset Management system.

The Retrieve Graphics, Follow Links, Restrict to Subdirectory,
and Max Depth controls apply only a URL or network path. For
more information about these controls, see “Retrieve Graphics”
on page 233.

If you specify a shared network directory in the URL field, there
are restrictions. Graphics and links can only be downloaded
from certain valid shared directories. For more information, see
“About Configuring Content Center” on page 203.

Select this to lock the content asset, so that others cannot edit it.
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Field Comments

Comments Typically used to note information about updates made to the
content asset. These comments are associated with the version
of the content asset.
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Setting the Home Page for a Content Set

After adding content assets to the content set, you can specify one of these assets
to be the home page. The home-page asset displays when the content set is
previewed. Because links on the preview applet are active, if the content set
contains a portal-style HTML page, this is the best page to choose as the home-page
asset.

To set the home page for a content set

1 If necessary, navigate to the Content Sets view (Step 1 in the “To create a content
set” procedure on page 191).

2 For the Content Set record, in the Home Page field use the Pick Home Page dialog
box to select one of the content assets in the set.

3 Click the Preview view tab.

For more information about previewing, see “To review and edit the properties
of a content asset record” on page 196.
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Viewing and Editing Content Asset Properties

The following procedure describes the fields in the Content Assets view and use of
the Preview, Links, Referenced by, Versions, and Access Groups views.

To review and edit the properties of a content asset record

1 From the application-level menu, choose View > Site Map > Content Center
Administration > Content Sets, and select the content set that contains the
content asset.

2 Click the Assets view tab.

3 Drill down on the content asset name.

NOTE: You can also navigate to a particular content asset record by querying in
the Content Assets view or by clicking on the asset-name hyperlinks on the
Content Explorer.

4 Click Edit.
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5 Fill in or edit the fields in the Asset Detail form as required.

Some fields are described in the following table.

Field

Comments

Name

Title

Activation

Expiry

Content (Asset)
Type

Language Code

Private

A name for the content asset record. The name should be
unique within in the content set.

A descriptive title for the content asset.

Sets activation and expiration dates for the content asset.

There is no logic associated with this date in the Content Center
module, but when this content is used by other modules, such
as Microsite Management, these dates are used to determine
whether the content is displayed.

This field is set when the content asset is created and cannot be
modified.

Sets the language code for the content asset.

If a content asset is private, only users on the associated access
groups can view the asset. If this box is not selected, the asset
is public and any user can view the asset, regardless of any
access groups specified for the asset.

CAUTION: The Reset button sets all the fields in the record to null.

6 Click the Preview view tab to preview the content asset.

If the content asset is an HTML file or an image, the asset displays directly in the
Preview applet. For other types of content assets, the title of the asset appears
as a hyperlink, from which you can open the asset in the application that you

choose.
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10

Click the Links view tab to review the links within a content asset.

These may be links to graphics, to HTML pages, or to email addresses. They may
be external links or they may be links to other assets within the content asset
repository (internal).

If the link is internal, Content Center checks whether the link is valid.

Click the Referenced by view tab to review the other content assets that contain
links to this content asset.

Click the Versions view tab to view information about the versions of the asset
stored in the content asset repository.

= To roll back to a previous version, select it and click Restore.
= To download a version to file, select it and click Save to File.

Click the Access Groups view tab to view who has read and write access to the
content asset:

= Read access. If the Private field is set, only those groups listed have read
access. If the Private field is not set, there are no restrictions on who has read
access to the asset.

= Write access. If any access groups have the Allow to Edit field checked, only
they have write access. If the Allow to Edit field is blank for all, there are no
write restrictions on the asset.

For information about creating access groups, see Security Guide for Siebel
eBusiness Applications.

CAUTION: If the Private check box is not selected, all users have read access to the
content asset. For a description of the Private check box, see the table in Step 5
in the “To review and edit the properties of a content asset record” procedure on
page 197.
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Checking Content Assets In and Out

Checking out a content asset downloads the asset file and locks the asset so that
others cannot make changes to it.

Checking in a content asset uploads a new version of the content asset and unlocks
the asset.

To check out a content asset

1 Navigate to the Content Sets view (Step 1 and Step 2 in the “To review and edit
the properties of a content asset record” procedure on page 196), and select an
HTML content-asset record to edit.

NOTE: You can also navigate to a particular content asset record by querying in
the Content Assets view or by clicking on the asset-name hyperlinks on the
Content Explorer.

2 Click Check Out.
Your user ID appears in the Locked by field.
To check in a content asset
1 In the Content Sets view (or the Content Assets view), select the content asset.
2 C(Click Check In.
3 In the Check In Content dialog box:

a Click the browse button and select a file or URL that contains the content
asset you are checking in. (For more information, see “Filename or URL” on
page 193.)

b Click Unlock to allow others to modify this content asset after check in.

¢ Add comments describing how this version differs from the last.
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About the Content Asset Commands on the Menu Button

Most users only need to use the Check Out and Check In buttons. However, other
content asset commands are available on the menu button of the Asset Detail form
in the Content Assets view:

Lock. Locks the content asset by the current user.

Unlock. Unlocks the content asset. For example, you can use this command if you
check out an asset, but then decide that you do not want to make any changes
to it.

Save to File. Downloads the content asset to a file, but does not lock the asset.

Replace. Adds a new version of the content asset. The Replace command is
available only when the asset is locked.

Delete. Deletes the content asset record and is equivalent to the Delete Record
command. This soft delete keeps past versions of the asset in the content asset
repository. Deleted assets can be accessed through the Contents Sets History
view.

200 Applications Administration Guide Version 7.5, Rev. C



Content Center ‘

Editing HTML Content

Editing HTML Content

You can edit content assets of type HTML directly within the Siebel application
using the integrated HTML editor.

NOTE: To edit large or complex HTML files, you may prefer to use a third-party HTML
or text editing application.

To edit HTML content using the integrated HTML editor

1 Navigate to the Content Sets view (Step 1 in the “To create a content set”
procedure on page 191), and select an HTML content-asset record to edit.

2 Click Edit HTML.

The content asset is automatically checked out, and the integrated HTML editor
opens.

3 Click on the edit area, and make changes as required.
For general information about the integrated HTML editor, see Fundamentals.
4 Click Save.

The content asset is automatically checked in.
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About the Content Asset Types View

The Content Asset Types view contains the file types, and associated DTR
(document type rules) files, extensions, and MIME types, that are recognized by
Content Asset Management.

Although you can add new content asset types if necessary, it is unlikely that you
will need to. Many file types are provided with the preconfigured Siebel application.

CAUTION: It is recommended that you do not edit or delete records in this view and
that you do not delete any DTR files from your Siebel installation.
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About Configuring Content Center

Content assets can be added to the Content Center repository by specifying a
filename on a shared directory or by specifying a URL (see “Filename or URL” on
page 193). In both cases, files that are linked-to from the specified file or URL can
be imported by selecting to Follow Links (see “Follow Links” on page 233).

When shared network files are imported to the Content Center repository in this
way, the permissions for the directory access are those of the server process
account. Because the server process account typically has more extensive privileges
than the user, there is a security risk of users importing content from directories to
which they do not have access.

To prevent this, importing from shared directories has been disabled except for
those directories that are listed in the contentbase.ini file. It is recommended that
you limit this list of allowed directories to a set that you can easily monitor and
manage.

On the Windows platform, the contentbase.ini file can be found in
SIEBEL_ROOT\siebsrvr\bin, and, on the UNIX platform, the file can be found in
SIEBEL_ROOT/siebsrvr/lib. The default file looks like this:

[d obal Settings]
| mport Fi | eEnabl ed=1
| mpor t Fi | ePat h=Si ebel Cont ent Shar e

= ImportFileEnabled. If ImportFileEnabled = 1, file import is allowed from
directories identified in the ImportFilePath parameter. If ImportFileEnabled =0
import is allowed only from URLs (where the URL's server enforces security) and
import from shared directories and followed links is disabled.

= ImportFilePath. The value of this parameter determines the directories from
which the user can import files. This value is a string of subpath names,
delimited by semicolons. The directory specified by the user for file import must
contain one of the subpaths listed.

For example, if the ImportFilePath parameter is set to
Si ebel Cont ent Shar e; EngShar e; \\ ori on; sal es\ cont ent, users can import
files from these directories:
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\\ myPQ\ Si ebel Cont ent Shar e

\'\ Ser ver A\ EngShar e\ G oupWeb

\\orion\users\ NewsBul | etins

However, you cannot import files from these directories:
\\ myPQ\ Si ebel Cont ent Shar eAl |

\\ Server A\ Mysal es\ cont ent

NOTE: The network path is interpreted relative to the server machine, not the client
machine. Therefore, local paths like C:\ refer to directories on the server machine.
And, for example, if the server machine is running UNIX, then the UNC path syntax
\\orion\users\ is not valid; instead, it might be /net/orion/users/.

If you use the default (out-of-the-box) contentbase.ini file, the administrator or
individual users need to set up one or more shared directories named
SiebelContentShare to contain those files (and those files that are referenced by the
specified files) that they want to import as content assets.
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This chapter describes how to use Microsite Management to create Web pages and
manage Web page content.

Many companies have multiple content managers whose responsibilities include
adding and modifying data on Web pages. The layout and maintenance of data and
hypertext links must be done as efficiently as possible, without requiring IT
resources. The Microsite Management module is designed to simplify creation and
maintenance of Web pages. Everything from site organization and creation of new
pages through to editing text and graphics is carried out from the Microsite
Management screen.

Both structured and unstructured page items can be included on pages created
within the microsite management module:

= Unstructured Content. Such as HTML files, graphics, and links to documents.
Unstructured content can be authored in a variety of environments, including
Microsoft FrontPage, PowerPoint, and Word and the integrated HTML editor
within the Siebel applications. Placement of structured content on pages is
carried out using Page Designer in the Microsite Manager screen.

m Structured Content. Such as product catalogs and lists of opportunities. In
general, structured content is authored in the Siebel application environment.
Placement of structured content on pages is carried out in Siebel Tools, by
editing applets on views.

Key features of Microsite Management are:

= Page Designer. A graphical drag-and-drop page layout tool that allows page
designers and content managers to quickly create areas for different types of
content anywhere on a page.

= Page Administrator Explorer Tree. Gives a hierarchically organized view of all the
pages in your Web site.
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= Preview. Allows you to preview pages according to content status (for example,
approved or draft) and according to release and expiration dates.

= Access Control. Is set at both the page and page item level so you can control
which access groups can see and edit content.

= Transparent Integration with Content Center. Set up and route the tasks of creating,
editing, and approving with Siebel Content Center. When a link to a file is added
to a page, that file is added to the Siebel content repository as a content asset,
and can be version-controlled with Content Center. For more information, see
Chapter 8, “Content Center.”
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Figure 7 and Figure 8 show the relationship between a finished page and Microsite
Management’s Page Designer layout tool that was used to create the page. The

content on the page is indicated by page item icons in Page Designer. The areas of
the page, such as the navigation bar, are indicated schematically in Page Designer.
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Figure 7. Microsite Page
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Page Title
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Figure 8. The Page Layout Schematic of the Microsite Page in Page Designer
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Business Scenario for Microsite Management

This scenario provides an example of microsite management tasks performed by the
microsite owner and a content author for the microsite. Your company may follow
a different process according to its business requirements.

The microsite owner for the analyst relations group of a large company has been
asked to develop a new microsite on the company intranet. The old Analyst
Relations microsite contains out-of-date information and is hard to maintain. Using
Microsite Management will make setting up the site and maintaining content much
easier. The new site will include links to analysts’ reports, lists of key contacts,
information on the company’s policies, and reports on competitors.

In cooperation with the company intranet administrator, the microsite owner
reviews the existing structure of the company’s Web site. Together they determine
that the new Analyst Relations microsite should be available from the Sales root-
level page. After the company intranet administrator has created the Sales root-level
page, the microsite owner creates the new Analyst Relations page link on the Sales
screen.

The microsite owner creates links to other intranet and Internet pages and to views
within the Siebel application. He adds some text and graphics along with content
created in applications such as Microsoft Word, Microsoft Excel, HMTL, and Adobe
Acrobat.

The microsite owner associates the access groups to each of the page items. He
makes sure that only certain groups of end users will see the items displayed on the
page and also that the right contributors are able to edit the items’ content.

Date ranges are also associated with each of the page items, so that only current
content appears on the page. Because a number of content items require the same
access groups and dates, the microsite owner uses the group properties feature,
which allows him to set the same properties for all selected items together.

At various stages in the page design, the microsite owner previews the page.
Because some of the content is time sensitive, he previews the page as it will appear
on several dates in the future.

In order that users can use the Siebel Search Center to find the page, the microsite
owner creates search indexes on the content.
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As soon as the new Analyst Relations microsite page has been approved and is
displayed to users, the microsite owner deletes the old page.

About Using Content Center with Microsite Management. Depending upon the
complexity of the analyst relations microsite and the approvers (and authors)
involved, the company may choose to use Content Center to streamline the
production of this microsite, as outlined here:

The corporate marketing director in charge of analyst relations creates a content
project which her team uses to create the analyst relations microsite; in the
project she specifies the tasks involved in producing the microsite.

The Content Center workflow routes these tasks to the designated microsite
owner who views them in his Content Inbox.

The microsite owner drills down on the content task and creates the new analyst
relations microsite.

After content has been drafted, the microsite owner submits them for approval
to the designated reviewers in the project’s approval workflow.

When the microsite and its contents have been approved, the microsite is
published from the Content Center’s staging environment to the production
environment.
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Example Process Flow for Microsite Management

This is an example of a simple process flow for Microsite Management. Your
company may follow a different process flow according to its business
requirements.

Figure 9 illustrates the process flow for the “Business Scenario for Microsite
Management” on page 209.

Review the existing structure of the
Web site

b

Optional: Create a root-level page

b

Create a new page linked to the root-
lewvel page

b

Edit the page, adding links and ather
unstructured content

b

lse the group properties feature to
set access groups and activation
dates far content

b

Preview the new page

b

Delete an old page

Figure 9. Example Process Flow for Microsite Management
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Viewing and Editing Page Information

The Page Administration view includes:

s The Page Administration Explorer tree

= A list of pages, displaying those pages at the level selected on the tree

= A form applet displaying fields associated with the page selected in the page list

The root-level pages are the top level of the page hierarchy. All other pages are
children of a root-level page or another page.

This structure helps you organize the pages. However, there are no requirements for,
or restrictions on, hypertext links between child and parent pages.

The position of a page in the hierarchy is determined by the Parent Page field and
the Order field.

Figure 10 shows the Page Administration Explorer tree and the Page list of the Page
Administration view.

- _JPortal Page Page:
[]--D Home: Page
01 Franeerns
[]--D Finance N e o - - o
[]..D Human Resources Page Title - Parent Page - View - Order - Last Modified e
[]"D T Analyst Relations Sales Portal Page Sales Yiew 1 SM 472002 12:00:00 Ak
- () Manutacturing Competitive Intelligence Sales Partal Page Sales View 2 5414/2002 12:00:00 &M
-] Marketing Customer Engagement Madel | Sales Paortal Page Sales View 3 5/14/200212:00:00 &M
=) sales Product Pricing Sales Portal Page Sales Wiew 4 SH 2002 12:00:00 &M
- (1] Analyst Relations RFP Warkhench Sales Paortal Page Sales View 5 5/14/200212:00:00 &M
[ Compettive Inteligence Sales Tools Sales Partal Page Sales View B 5/14/200212:00:00 &M
[ Customer Engagement Mol Section Map Sales Portal Page Sales View |7 SH5/2002 12:00:00 A
=8 j Product Pricing Siebel Products Demonstration | Sales Portal Page Sales View | 3 51412002 120000 &M
B[] RFP Wiorkbench Siehel Technical Publications | Sales Partal Page Sales View | 9 501472002 12:00:00 AM
[#]- j Sales Tools
[#]- j Section Map
[#]- j Siebel Products Demonstration
[#]- j Siebel Technical Publications
&-[Z] ERM Project Home
-] myPage

Figure 10. Page Administration Explorer Tree and Page List Applets
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To find a page in the tree and modify its properties

1 From the application-level menu, choose View > Site Map > Microsite
Management (or Administration) > Page Administration.

2 Use the Page Administration Explorer tree to find and select the page whose
properties you want to modify.

3 In the form, edit fields as required.

Some fields are described in the following table.

Field

Description

Page Title

Parent Page

Access Groups

View

Order

Description

Comments

A title for the page, up to 90 characters long. This title is used to
identify the record but does not appear on the microsite.

The parent page determines where the page is nested in the page
hierarchy.

Use this field to restrict read and read-write (select Editor field)
access to this page.

If this field is blank, there are no restrictions on who can view and
edit this page, provided they have the view responsibilities for the
template view and the Page Designer view.

If no editor is specified, all the access groups can edit this page.

If you do not have access to this page, the Page Title hyperlink is
unavailable in the Page list.

Determines the Siebel view that the page is based on. For information
about how to create new views, see Siebel Tools Reference.

Determines the sequence of the page in its level of the Page
Administration Explorer tree.

Typically used to describe the page.

Typically used to enter comments about changes made to the page.
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Creating a Root-Level Page

The root-level pages are those pages that appear at the top of the Page
Administration Explorer tree. Typically only a few employees should have the
responsibilities required to access the Portal Screen Administration view where
root-level pages can be created.

In general, you will want to have a screen tab for each of the root-level pages. You
can use Siebel Tools to create a screen tab for a new root-level page. For information,
see the page tabs topic in Siebel Tools Reference.

Best practice is to standardize on a limited number of these pages in order to keep
the top root-level of the explorer tree uncluttered and to restrict the number of
screen tabs in the application.

To create a root-level page

1 From the application-level menu, choose View > Site Map > Microsite
Management (or Administration) > Portal Screen Administration.

2 In the Portal Screen list, add a new record and complete the necessary fields.

Some fields are described in the following table.

Field Description

Screen Name for the root-level page.

Default View Determines the Siebel view that the page is based on. For information
Name about how to create new views, see Siebel Tools Reference.

The view that determines the Web template used by this page.

Access Groups  Use this field to restrict read and read-write (select Editor field)
access to this page.

If this field is blank there are no restrictions on who can view and
edit this page, provided they have the view responsibilities for the
template view and the Page Designer view.

If no editor is specified, all the access groups can edit this page.
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Field Description

Order Determines the sequence of the page at the top level of the Page
Administration Explorer tree.

Inactive If the root-level page is inactive:

»  Theroot-level page and its child pages do not appear in the Page
Administration view

»  The page is not displayed in the application

About Page Designer

The Page Designer view is the center of the Microsite Management module. The
Page Designer applet contains a graphical drag-and-drop page layout and tools for
adding unstructured content, such as text, graphics, links to Siebel views, and links
to other pages, to the designated sections of your page.

In the Page Designer Ul, applets that contain structured content (such as an
Activities, Opportunities, or Calendar applet on an employee’s page) are indicated
by the words “Not Editable.”
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The Create New Page Tool

New pages are created in the Page Designer view. This is the only way to create new
pages within Microsite Management. To use the Create New Page tool, you must
begin by choosing a parent page where you want to create link to the new page.
This places the page appropriately in the page hierarchy and makes sure that you
cannot create an orphan page (a page that is not accessible from any other page).

When you create a new child page, it is likely that you want the child page to look
much like the parent page. For example, you might want to keep the same copyright
information in the footer and the same list of links in the navigation bar. When you
create the new page, you can select what content you want to copy from the parent
to the child page.

Similarly, it is likely that you want the child page to inherit the same access controls
as the parent. When you create the new page, you can choose to copy access groups
from the parent.

To create a new page

1 From the application-level menu, choose View > Site Map > Microsite
Management (or Administration) > Page Administration.

2 In the Page list, select the page that will contain a link to the new page, and click
the Page Title hyperlink.

The Page Designer view appears.

3 From the Page Designer toolbar, drag the Create New Page tool to the position
on the layout where you would like the new page link to appear.
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4 In the Create New Page dialog box, complete the fields.

3 Create Hew Page - Microzoft Internet Explorer

Link Settings:
*Name I
Release Date [o5/13,2002 9:28:19 aM H
Expiration Date I []
Indent ID
Access Group I ]
Status IDraﬂ j
Description

Hew Page Settings:

*Title I
Order l_

Copy the following content sections:
Page Title

Havigation Bar
Body |

Quick Picks 7]
Page Footer

All Other Sections 7]

Inherit Access Controls

Open Hew Page

=1 3

Some fields are described in the following table.

Field Description

Name This is the text that appears as the navigation link to the new page.

Release Date

Specifies the date when the link becomes active.

The link appears when the date is between the release date and the
expiration date and the status is Approved.
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Field

Description

Expiration
Date
Indent

Access Group

Status

Description

Title

Order

= Page Title

= Navigation

Bar
= Body
s Quick
Picks

= Page Footer

»  All Other
Sections

Specifies the date when the link will no longer be active.

Determines the indentation, in number of spaces to the right, of the
navigation link on the page.

Use this field to restrict read and read-write (select Editor field)
access to the navigation link.

If this field is blank there are no restrictions on who can view and
edit this navigation link.

If no editor is specified, all the access groups can edit this navigation
link.

The status of the link: Approved, Designed, Draft, Final, Printed,
Shipped, or Submitted.

The Approved and Draft status fields determine what content is
displayed in the page preview. See “Previewing a Page” on page 239.

Contains additional information about the navigation link to the new
page.

A title for the page, up to 90 characters long. This title is used to
identify the record but does not appear on the microsite.

Determines the sequence of the page in its level of the Page
Administration Explorer tree.

A check mark in these boxes indicates the content in the sections of
the current page which are copied into the new page. Sections must
exist on the selected page if they are to be copied to the new page.

If you have used Siebel Tools to configure views with new applet
types that contain unstructured content, then checking All Other
Sections will copy content from those sections to the new page.
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Description

Inherit Access
Controls

Open New
Page

If selected, Access Group values for the new page and any page items
copied are inherited from the current (parent) page.

If not selected, there are no access restrictions on who can view and
edit the new page.

If selected, the new page opens in the Page Designer UI when the link
is saved. If not selected, the Page Designer UI continues to display the
current (parent) page after the link is saved.

5 Click OK.

NOTE: By default, the Parent Page and View are the same as those in the linked-
from page chosen in Step 2 on page 216. These fields as well as the Description
field can be edited in the Page Administration view; see “Viewing and Editing
Page Information” on page 212.
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The Link Existing Page Tool

Using the Link Existing Page tool, you can create navigation links to other pages
within the Microsite Management system.

If you want to create navigation links to external pages, see “The Add Web Link
Tool” on page 224.

To create a navigation link between Microsite Management pages

1 From the application-level menu, choose View > Site Map > Microsite
Management (or Administration) > Page Administration.

2 In the Page list, select the page on which you want to create the navigation link,
and click the Page Title hyperlink.

The Page Designer view appears.

3 From the Page Designer toolbar, drag the Link Existing Page tool to the position
on the layout where you would like the new page navigation link to appear.

4 In the Link Existing Page dialog box, complete the fields.

3 Link Ezxisting Page - Microsoft Internet Explorer [Ei[=] [E3

*Name [ analyst Relations Link

*View-Page IPortaI Page Sales Yiew - Analyst Relations (4

Release Date 05132002 9:32:49 AM H
Expiration Date I []
Indent ID
Access Group I ]
Status IDraﬂ j

Description
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Some fields are described in the following table.

Field

Description

Name

View-Page

Release Date

Expiration Date

Indent

Access Group

This is the text that appears as the navigation link to the new page.

Select the target page for the navigation link. You can select any page
in the application from the Pick Parent Page dialog box.

Specifies the date when the navigation link becomes active.

The link appears when the date is between the release date and the
expiration date and the status is Approved.

Specifies the date when the navigation link will no longer be active.

Determines the indentation, in number of spaces to the right, of the
navigation link on the page.

Use this field to restrict read and read-write (select Editor field)
access to this page.

If this field is blank there are no restrictions on who can view and
edit this page, provided they have the view responsibilities for the
template view and the Page Designer view.

If no editor is specified, all the access groups can edit this page item.

Status The status of the link, for example Approved, Designed, Draft, Final,
Printed, Shipped, or Submitted.
The Approved and Draft status fields determine what content is
displayed in the page preview. See “Previewing a Page” on page 239.
Description Contains additional descriptive information about the navigation
link.
Click OK.
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The Link App View Tool

Using the Link App View tool, you can add links from a page to a particular view

in the Siebel application.

For example, you might want to add a link from your sales representatives’ home
page to the My Expense Reports view on the Expense Reports screen.

To create a link from a page to a view in the Siebel application

1 In the Page Designer view, select the page to which you want to add a link to a
view in the Siebel application. (See Step 1 and Step 2 in the “To create a
navigation link between Microsite Management pages” procedure on page 220.)

2 From the Page Designer toolbar, drag the Link App View tool to the position on
the layout where you would like the application link to appear.

3 In the Link Application View dialog box, complete the fields.

3 Link Application View - Microsoft Internet Exp... [H[=] [E3

*Hame IExpense Reports

*View IExpense List Detail “iewr (8PS)

ReleaseDate [ng/1 32002 9:30:07 &M

Expiration Date I

Indent I 0

Access Group I

Status I Dratt

Deseription [| iry t0 the expense reports detail view.
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Some of the fields are described in the following table.

Field

Description

Name

View

Release Date

Expiration Date

Indent

Access Group

Status

This is the text that appears as the navigation link to the new page.

From the Pick View dialog box, choose the application view that you
want to display when the link is clicked.

Specifies the date when the navigation link becomes active.

The link appears when the date is between the release date and the
expiration date and the status is Approved.

Specifies the date the link will no longer be active.

Determines the indentation, in number of spaces to the right, of the
navigation link on the page.

Use this field to restrict read and read-write (select Editor field)
access to this page item.

If this field is blank there are no restrictions on who can view and
edit this page item.

If no editor is specified, all the access groups can edit this page item.

The status of the link: Approved, Designed, Draft, Final, Printed,
Shipped, or Submitted.

The Approved and Draft status fields determine what content is
displayed in the page preview. See “Previewing a Page” on page 239.
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The Add Web Link Tool

Using the Add Web Link tool, you can link to external pages, identified by a URL.
For example, on your microsite, you might want to provide links to your partners’
Web sites.

There are a number of ways that the external page can be displayed from the
Microsite Management page:

= Frame. Within the frame of the current page.

= In-Line. Directly in the applet on the current page. Displaying pages in-line works
best with simple pages. Large or complex pages, such as those that use
JavaScript, can slow down the system and cause unexpected results. Be sure to
test in-line pages.

= New Window. Launching a new browser window when the link is clicked; this
allows the user to switch between the two pages.

= Window. Displaying the external page in the current browser window.

To create a link from a page to an external page

1 In the Page Designer view, select the page on which you want to add a link to
an external page. (See Step 1 and Step 2 in the “To create a navigation link
between Microsite Management pages” procedure on page 220.)

2 From the Page Designer toolbar, drag the Add Web Link tool to the position on
the layout where you would like the external link to appear.
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3 In the Add Web Link dialog box, complete the fields.

/2 Add Web Link - Microzoft Internet Explorer

*Hame || irk to Siekel com

*URL Ihﬂp:.l’.i\vvww.siebel.com

*HTML Display I Mews VWinclony =l
Release Date |osr1 372002 9:34:50 AM =
Expiration Date I izt
Indent ID
Access Group I b
Status IDraﬂ =l
Description

Some fields are described in the following table.

Field Description
Name This is the text that appears as the navigation link to the new page.
URL Enter the exact URL of the destination for the link.

HTML Display = Choose how the external page is displayed: Frame, In-Line, current
Window, or New Window.

Release Date Specifies the date when the link becomes active.

The link appears when the date is between the release date and the
expiration date and the status is Approved.

Expiration Date Specifies the date when the link will no longer be active.

Indent Determines the indentation, in number of spaces to the right, of the
navigation link on the page.
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Field Description

Access Group Use this field to restrict read and read-write (select Editor field)
access to this page item.

If this field is blank there are no restrictions on who can view and
edit this page item.

If no editor is specified, all the access groups can edit this page item.

Status The status of the link: Approved, Designed, Draft, Final, Printed,
Shipped, or Submitted.

The Approved and Draft status fields determine what content is
displayed in the page preview. See “Previewing a Page” on page 239.

Description Contains additional descriptive information about the navigation
link.

4 Click OK.
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The Create Content Tool

Using the Create Content tool, you can add rich-text content directly to the page
through the integrated HTML editor.

Typically, you would use the Create Content Tool for adding short or simple content,
such as captions or labels.

NOTE: To add complex HTML or large amounts of text, you may prefer to use a third-
party HTML or text editing application to create an HTML file, and then place the
file’s contents on the page using the Insert File tool. See “The Insert File Tool and
the Insert Image Tool” on page 231.

The formatted text entered and saved in the editor is saved as a content asset in the
Content Asset Management’s repository. For more information about the content
assets, see “About Content Assets” on page 190.

For general information about the integrated HTML editor, see Fundamentals.

To add HTML directly to a page

1 Inthe Page Designer view, select the page to which you want to add HTML. (See
Step 1 and Step 2 in the “To create a navigation link between Microsite
Management pages” procedure on page 220.)

2 From the Page Designer toolbar, drag the Create Content tool to the position on
the layout where you want the new content type to appear.

3 In the Create Content dialog box, click Edit HTML.
4 In the editor, type and format text, and add links and graphics.

5 Click Save to save the HTML to the content asset repository and close the HTML
Editor.
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6 Complete the fields in the Create Content dialog box.

/4] Create Content - Microsoft Internet Explorer

*Hame IAnaIys{ Relations Banner

*HTML Display IIn-Line

Release Date 5132002 9:36:09 &M

=l
&

Expiration Date I

Indent I 0

Access Group I

Status I Dratt

Description

=1 3

Some of the fields are described in the table in Step 3 in the “To create a link
from a page to an external page” procedure on page 225.

7 Click OK.
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The Insert Content Tool

Using the Insert Content tool, you can add to your page content assets that stored
in the content asset repository. For more information about the content assets, see
“About Content Assets” on page 190.

For example, there may be a content asset that is a GIF image of your corporate logo,
which you want to use to brand your page. Or, it may contain an Adobe Acrobat
file, describing departmental policies, that you want to link to your page.

To add content assets to a page

1

Version 7.5, Rev. C

In the Page Designer view, select the page to which you want to insert a content
asset. (See Step 1 and Step 2 in the “To create a navigation link between
Microsite Management pages” procedure on page 220.)

From the Page Designer toolbar, drag the Insert Content tool to the position on
the layout where you want to add the content asset.

In the Insert Content dialog box, click the select button in the Asset Name field
and use the Pick Content dialog box to select the content asset you want to add.

/3 Inzert Content - Microzoft Internet Explorer (=1 E
*Hame IAnawst Report
*Asset Hame IRepm 450 &
Version I
*HTML Display ||n-Line j
Release Date 05132002 9:37:44 AM =
Expiration Date I 2
Indent ID
Access Group I &
Status IDraﬂ j

Description
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4 Complete the fields in the Insert Content dialog box.

Some of the fields are described in the table in Step 3 in the “To create a link
from a page to an external page” procedure on page 225.

5 Click OK.

230 Applications Administration Guide Version 7.5, Rev. C



Microsite Management

The Insert File Tool and the Insert Image Tool

The Insert File Tool and the Insert Image Tool

Using these tools, you can insert files (such as HTML files, MS Word files, and
Adobe Acrobat) and graphics files from your local file system, from shared networks
and from the Web.

The difference between using the Insert File tool and the Insert Image tool is that
the HTML display for the Insert Image tool is always set to In-Line.

When these files are added to your page, they are also stored as content assets in
the content asset repository. For more information about the content assets, see
“About Content Assets” on page 190.

To add a file or graphic to a page

1 In the Page Designer view, select the page to which you want to add an image.
(See Step 1 and Step 2 in the “To create a navigation link between Microsite
Management pages” procedure on page 220.)

2 From the Page Designer toolbar, drag the Insert File (or the Insert Image) tool to
a position on the layout.

The Insert File (or the Insert Graphic) dialog box appears.

/3 Inzert File - Microzoft Internet Explorer

*Hame ICorporate Pre=zentation Povwerpoint

*Asset Hame ICorporate Presentation ()
*HTML Display ||n-Line j
Release Date |osr1 2002 93912 AM =
Expiration Date |02r28r2003 124555 PR =
Indent ID
Access Group I i
Status IDraﬂ j

Description
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3 Click the browse button next to the Asset Name field.

The Insert Content dialog box appears.

“} Insert Content - Micros... M=l Ed

Hame: I
Title: I
Content Type: I ]
Filename: I @
URL: I
Lock: [7]
Comments:

4 Click the browse button next to the Filename field.

The Choose File dialog box appears.

43 Choose File - Microsoft Internet Explorer  [Hi[=1E3

Browyse for a file, or specify the URL or netwoark path of 2 Web Page.

Filename: I Browse... |

URL or network path: I
Retrieve Graphics: =
Follow Links: [

Restrict to Subdirectory: -

Max Depth: |2

5 In the Choose File dialog box:

= To select a file from a local directory, click Browse.
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= To select a file on a shared directory or a URL, enter the path name in the
URL or network path field, and complete the fields below. (See “About
Configuring Content Center” on page 203 for information about listing
shared directory names in the contentbase.ini file.)

Some fields are described in the following table.

Field Description

Retrieve Determines if graphics on the specified Web page are copied
Graphics along with the text.

Follow Links Determines if the pages that are linked-to from the specified Web

page are copied, and in turn links to those pages are copied.

Restrict to Indicates that, if links are followed, only links to pages within the
Subdirectory same directory as the specified page are copied.
Max Depth Indicates the level to which links are copied. For example, if Max

Depth = 1, pages that are linked-to from the specified page are
copied, but not pages that they link to.

6 In the Insert Content dialog box, complete the fields.

Some of the fields are described in the following table.

Field Description

Name A name for the content asset record.

Title A descriptive title for the content asset.

Content Leave this field set to Auto-Detect (the default) to have the

(Asset) Type application determine the asset type, or select a type from the dialog

box to set a specific type.

Lock Select this to mark the content asset locked by you.

7 In the Insert File or Insert Image dialog box, complete the fields.

Some of the fields are described in the table in Step 3 in the “To create a link
from a page to an external page” procedure on page 225.
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Editing Page Item Properties

The sections above explained how use the Page Designer Ul to create new page
items, for example, links to pages and graphics.

To edit page item properties, you select a page item on the Page Designer Ul and
modify its properties in the Page Item Properties form. The fields and buttons that
are available in the Page Item Properties view depend upon the type of page item
selected.

Items of type HTML, Web Content, Graphics, and File are content assets and are
stored in the content asset repository. Details about these content assets can be
viewed in the Asset Detail view, and these content assets can also be checked out
for editing.

Some items can be edited using the integrated HTML Editor, launched from the Edit
HTML button on the Page Item Properties form.

To edit a page item

1 In the Page Designer view, select the page that you want to edit. (See Step 1 and
Step 2 in the “To create a navigation link between Microsite Management pages”
procedure on page 220.)

2 In the Page Designer UI, select the page item whose properties you want to edit.

3 In the Page Item Properties form, edit the fields.

NOTE: Those fields and buttons that are not appropriate for the selected page item
are unavailable.

4 Use the Check-Out and Check-In buttons to open and edit content. (For more
information about checking out content assets, see Chapter 8, “Content
Center.”)
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5 Click Asset Details to open the Content Assets view and to:
a See information about the selected item.
b Roll-back to a previous version of the content asset.
¢ Review the content asset for broken links.

For more information about the Content Assets view, see Chapter 8, “Content
Center.”

6 To edit HTML content, click Edit HTML.

For more information about the integrated HTML editor, see Fundamentals.
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Deleting Page Items

Deleting items from a page is done through the Web Designer UI. Any item that has
been saved in the content asset repository remains there even after the associated
page item is deleted.

To delete a page item

1 In the Page Designer view, select the page from which you want to delete items.
(See Step 1 and Step 2 in the “To create a navigation link between Microsite
Management pages” procedure on page 220.)

2 In the Page Designer Ul, select the page item and type CTRL + DEL.
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Saving and Canceling Changes to the Page Layout

In the Page Designer view, page records are saved in the same way that other
records are saved in the application. (See “To save a page record.”)

Use the Cancel button to return page items to their last-saved positions, removing
any just-created page items and adding back any just-deleted page items.

However, changes made to the page item properties (such as Status or Indent) are
not lost when Cancel is clicked.

For example, if you move a link from the navigation bar to quick picks, change its
status from Draft to Approved, and then click Cancel, the link returns to the
navigation bar but its status remains Approved.

To save a page record

m In the Page Designer view do one of the following:
= Click Save.
= Click Preview.
= Select another page.

= Navigate to a different view.

To cancel changes to the page layout

= After making changes to the page layout in the Page Designer UI, click Cancel.

The layout reverts to how it was when the record was last saved.
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Managing Groups of Content ltems

To make page management easier, content items can be grouped and common
properties assigned to them. For instance, certain items may need to be grouped so
that the release dates for all of the page items are identical.

To group page content items

1 In the Page Designer view, select the page you want to edit. (See Step 1 and
Step 2 in the “To create a navigation link between Microsite Management pages”
procedure on page 220.)

2 Select all of the content items you want to manage as a group.

Hold the SHIFT key while clicking on the page items to select multiple items.
3 Click Group Properties.
4 Complete the fields as required in the Page Items Group dialog box.

Only those properties that are common to all types of page items appear in this
dialog box: Indent, Release Date, Expiration Date, Access Group, and Status.
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Previewing a Page

After you have laid out the content on the Page Designer Ul, you will want to
preview the page.

Whether or not content appears on the displayed page depends upon the content
item’s release date, expiration date, and status.

The preview feature in Page Designer allows you to:
m Set a date for the preview (content inactive on that date does not appear).

m  Choose to display only approved content, only draft content, both approved and
draft content, or all content regardless of status.

To preview a page

1 In the Page Designer view, select the page you want to edit. (See Step 1 and
Step 2 in the “To create a navigation link between Microsite Management pages”
procedure on page 220.)

2 In the Page Designer UI:
a Enter a Preview Date.
b Choose a Preview Status (Approved; Approved and Draft; Draft; or All).
¢ Click Preview.
The rendered page appears in preview mode.

3 Return to the Page Designer Ul by clicking the back button on the Siebel
application’s toolbar.
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Deleting a Page

Pages can be deleted from the Page Administration view. Root-level pages can also
be deleted from the Portal Screen Administration view.

When a page is deleted:

The status of any navigation links to that page (on other pages within Microsite
Management) is changed to Draft. This prevents broken links from appearing on
displayed pages.

The Access Group field for any navigation links to the page are reset (no access
restrictions).

The target page (View-Page) for the link is set to NULL. When you edit a link
where the View-Page is NULL, you must specify a valid View-Page before you
can save changes to the link.

To delete a page

1

From the application-level menu, choose View > Site Map > Microsite
Management (or Administration) > Page Administration.

The hierarchical structure of screens and subordinate pages appears on the left,
and the page list and detail form appear on the right. Click the + sign to expand
a folder.

Select the page you want to delete, and delete the record.
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About Creating Search Indexes

Content assets on microsite pages can be integrated with the Siebel Search Center.
This allows users to find pages by searching for keywords. For information about
creating indexes for Search Center, see Siebel Search Administration Guide.

About Configuring Microsite Management

The mmlayout.txt file is used by Page Designer to schematically represent the layout
of the applets in the view (Figure 8 on page 208). The file contains layout
information for all Siebel preconfigured views designed to contain unstructured
content.

The mmlayout.txt file also contains a parameter used to turn page caching on and
off.

On a Windows platform, the mmlayout.txt file can be found in
SIEBEL_ROOT\siebsrvr\bin. On a UNIX platform, the file can be found in
SIEBEL_ROOQOT/siebsrvr/lib.

Adding New View Layouts to the mmlayout.txt File

If you have created new views in your Siebel application, and you want to use these
views as templates for microsite pages, you need to edit the mmlayout.txt file to
schematically describe how the applets in your views are laid out.

NOTE: For information about creating views that can contain unstructured content,
see Siebel Tools Reference.

Turning Microsite Page Caching Off

By default, page caching of microsite pages is turned on.

The advantage of page caching is that microsite pages are rendered faster.
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About Configuring Microsite Management

The disadvantage of page caching is that if you make a change to a page using Page
Designer, the change (although visible in preview mode) does not appear on the
actual page until you log off and back in.

TIP: If you have both a staging and a production environment, consider using page
caching in the production environment, but not in the staging environment.

To turn off microsite page caching

1 Open the mmlayout.txt file in a text editor.

2 Change the line
<Enabl ePageCachi ng>TRUE</ Enabl ePageCachi ng>
to

<Enabl ePageCachi ng>FALSE</ Enabl ePageCachi ng>

NOTE: Because page caching is the default, if you delete the line, page caching
remains on.

3 Save and close the file.
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This chapter describes the administration tasks associated with Siebel Global
Accounts.

Siebel Global Accounts is a module that provides sales professionals with global
account-level visibility into the interactions that the company’s sales organization
and partner’s sales organizations have had with the account. Users can view all
accounts, opportunities, activities, contacts, and account team members across the
account hierarchy on one screen, allowing sales professionals to build a deep
understanding of target accounts.

For information about viewing Global Account information, see Siebel Sales User
Guide.

Global Account hierarchies are not provided out-of-the-box with your Siebel
eBusiness Application. They must be set up by an administrator. There are two
kinds of account hierarchies that can be set up by the administrator:

m Default. This type of account hierarchy is based solely on the accounts’ Parent
fields. This account hierarchy is self-maintaining in that whenever the Parent
field of any account is updated, the default hierarchy is also updated. Once set
up, the default hierarchy is applied to all organizations that do not already have
an organization.

m Custom. This type of hierarchy is created by the administrator, either by
modifying the default hierarchy or from the beginning. Once set up, this
hierarchy is independent of the accounts’ Parent fields, and as such must be
updated by the administrator when changes occur.
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Business Scenario for Global Account Administration

This scenario provides an example of a process flow performed by the accounts
administrator. Your company may follow a different process flow according to its
business requirements.

A large company, Corp 123, wants to view consolidated data at the global account
level. This company has two organizations set up in its Siebel application: a sales
organization and a financial organization. The accounts administrator sets up two
account hierarchies, one for each organization. These hierarchies allow end users
to view the opportunities and contact information associated with parent accounts.

The sales organization uses the default hierarchy, which is based on the Parent
account field. For various reasons, the financial organization requires a modified
version of the account hierarchy. One of these reasons is that some accounts’ billing
structures are different from the accounts’ purchasing structures. For example, in
the case of XYZ Inc. there are four XYZ accounts who are customers of Corp 123:
the XYZ Holding company, two regional subsidiaries, and a financial company. The
123 sales organization wants to view the account hierarchy where all accounts
report to the parent holding company. Because all account billing for the XYZ
companies is funneled through XYZ Financial, Corp 123’s financial organization
wants to view the account hierarchy where all accounts report to the XYZ Financial.
Figure 11 shows the two hierarchies.

®YZ ®YZ
Holding Financial
( 1 — 1
N Z N Z HYL N Z N Z N Z
Financial Europe Asia Holding Europe Asia
Hierarchy for sales Hierarchy for finance

Figure 11. Examples of Account Hierarchies
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The default hierarchy used by the sales organization updates automatically when
new accounts are added or Parent fields are changed. However, the accounts’
administrator updates the finance hierarchy on a weekly basis as new accounts are
added and the structure of existing accounts changes.
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Example Process Flow for Global Accounts
Administration

Figure 12 illustrates the business scenario, “Business Scenario for Global Account
Administration” on page 244.

These tasks should be carried out in the order presented.

Generate a Default Hierarchy

¥

Create a Customn Hierarchy

b

Assign a Custom Hierarchy to an
Organization

¥

Maintain a Custorn Hierarchy

Figure 12. Example Process Flow for Global Account Administration
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Generating a Default Hierarchy

Follow this procedure to set up a default hierarchy. Once generated, this default
hierarchy is automatically assigned to organizations without an account hierarchy.

To change the account hierarchy assigned to an organization, see “Assigning a
Custom Hierarchy to an Organization” on page 250.

To create a default hierarchy

1 From the application-level menu, choose View > Site Map > Data
Administration > Global Accounts, or if you are using SIA (Siebel Industry
Applications), choose View > Site Map > Applications Administration >
Account Hierarchies.

2 In the Account Hierarchy list, click Generate Hierarchy.
A new account hierarchy is created.

Some fields are described in the following table.

Field Comments
Name A default name is generated based on your user ID and the date.
Default Select so that the account hierarchy is the default. The default

hierarchy is assigned to all organizations without an account
hierarchy and is updated when new Parent fields on the account
records are added or modified.

TIP: If the generated hierarchy does not appear in the Account Relationships lists,
refresh the view by navigating to a different view and then returning to the
Global Accounts view.
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3 In the Account Relationships list, review the hierarchy records.

NOTE: If end users are using the application when you generate the account
hierarchy, they must log out and log in again to see the default account hierarchy
in the rollup views.
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Creating a Custom Hierarchy

You can create a custom hierarchy by generating a hierarchy as described in the
preceding section or by starting from the beginning and creating a series of new
records in the Account Relationships list.

To create a custom hierarchy

1 From the application-level menu, choose View > Site Map > Data
Administration > Global Accounts. (If you are using Siebel Industry
Applications, choose View > Site Map > Applications Administration >
Account Hierarchies.)

2 In the Account hierarchy list, create a new record and complete the fields. Do
not check Default.

3 In the Accounts Relationship list:

a Create new records for each of the top level parent accounts. Leave the Parent
Account field blank for each of these.

b Create new records for the child accounts, entering the Parent Account for
each.

To create a custom hierarchy based on the default hierarchy

1 Create an account hierarchy as described in “To create a default hierarchy” on
page 247.

2 Select the account hierarchy record and make sure that the Default field is not
selected.

3 In the Account Relationships list, edit the Parent Account field for existing
accounts and create new relationship records as required.

Accounts without Parent Accounts are at the top of the hierarchy and must be
entered before their child records can be completed.
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Assigning a Custom Hierarchy to an Organization

An organization uses the default hierarchy unless a custom hierarchy has been
assigned to it.

To assign a custom hierarchy to an organization

1 From the application-level menu, choose View > Site Map > Group
Administration > Organizations.

2 Select the organization whose account hierarchy you want to change.

3 In the More Info form, in the Account hierarchy field, select the custom
hierarchy that you want the organization to use when viewing global accounts.
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Maintaining a Custom Hierarchy

Custom hierarchies are static and must be maintained by the administrator. There
are two approaches to updating an account hierarchy:

= Edit the account relationships in the current hierarchy.

= Restore the hierarchy to the default (parent account) hierarchy, and then edit the
account relationships in the hierarchy.

To maintain a custom hierarchy

1 From the application-level menu, choose View > Site Map > Data
Administration > Global Accounts. (If you are using Siebel Industry
Applications, choose View > Site Map > Applications Administration >
Account Hierarchies.)

2 Select the account hierarchy record.
3 Do one of the following:

= In the Account Relationships list, edit the Parent Account fields for existing
accounts and create new relationship records as required.

= In the Account Relationships list, click Restore Hierarchy to return the
hierarchy to the default, and then edit the Parent Account fields for existing
accounts and create new relationship records as required.
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This chapter contains information about activities, activity templates for activity
plans, sales methods and stages, and assessment templates. The chapter focuses on
administrative tasks.

For information about creating activity templates for field service activities, see
Siebel Field Service Guide.

For information about end-user tasks, see Siebel Call Center User Guide and Siebel
Sales User Guide.
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About Activities

Siebel applications use activities to organize, track, and resolve a variety of tasks,
from finding and pursuing opportunities to closing service requests. If a task
requires multiple steps that one or more people may carry out, activities greatly
simplify the job. Activities can help:

Define and assign the task
Provide information to complete the task
Track the progress of the task

Track costs and bill for the task

These are the major advantages of breaking down a task into one or more activities:

The ownership of the problem can remain at the management level, when
required.

The employee looking at assigned activities can identify only the required
information.

Reporting is simplified.

Activities can be assigned to more than one person.

Assignment Methods
Activities, once generated, are assigned to appropriate employees. Activity
assignment can take place in a number of ways:

Manual assignment

Automatic assignment to the creator of the activity (by predefaulting the Owner
field to the activity’s creator)

Automatic assignment using Assignment Manager (see Siebel Assignment
Manager Administration Guide).
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Business Objects Associated with Activities
Siebel activity objects may be associated with other Siebel business objects. Some
common associations are listed in Table 19. In most cases, this association is with
a set of activities defined by an activity plan and individual (or stand-alone)

activities. In a few cases, an object is associated either with an activity template or

with stand-alone activities.

Table 19. Association of Activity Object with Other Siebel Objects

About Activities

Screen Name

Accounts
Agreements
Assets
Campaigns
Contacts
Messages
Opportunities

Orders (Order Line
Items view)

Preventive Maintenance
Programs

Projects

Quality

Repairs

References

Service

Business Object

Account

Service Agreement

Asset Management

Campaign
Contact
Messaging
Opportunity
Order Entry

FS PM Plan Item
Program (DBM)
Project

Product Defect
FS Repair
Reference

Service Request

Stand-Alone Activities Activities from Templates
Yes Yes
Yes Yes
Yes No
Yes No
Yes Yes
Yes No
Yes Yes
Yes Yes
No Yes
No Yes
Yes Yes
Yes No
Yes Yes
Yes No
Yes Yes
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About Activity Templates and Activity Plans

Activity templates are created by an administrator and are blueprints for sets of
activities. Activity templates can be invoked by end users to create activity plans.

Activity plans are collections of activities that are created using the activity
template. They are specific instances of activity templates that have been invoked
by end users.

Each activity template is associated (through its Type value) with a certain business
object. See Table 19 on page 255 for a list of business object and screens that use
activity templates.

In Activity Plans views, only activity templates that have been associated with the
active business object can be invoked. For example, on the Opportunity screen, only
templates for opportunity activities are visible. Selecting a template creates all the
activities defined by that template.

When the activity plan is created from the activity template, activities are created
based on the activity template details defined in the activity template.

Typically, the administrator sets up the activity templates, and the end users apply
the activity templates to create their activity plans.
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About Assessment Templates

An assessment template is a model used to generate an assessment. Assessment
templates can be created to assess opportunities, contacts, and accounts, as well as
other areas of the Siebel applications, such as the Ideal Customer assessment used
by the Strategic Selling® module.

Assessments ask questions (in the form of attributes) and score the answers in order
to determine a single total score or percentage, which measures or ranks a given
opportunity, contact, account, or so forth.

Assessments are made up of one or more attributes. Each attribute has a name, a
weight, a set of allowable values and a description field. For example, a common
attribute for an account might be Credit History. The values for this attribute might
include Excellent, Good, Average, and Poor. Each of these values carries a numerical
score and, optionally, instructions for the end user on how to choose the correct
value.

Typically, the administrator creates assessment templates, and end users apply the
templates and carry out the assessments.
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About Sales Methods

A sales method is an approach used in the sales process. The administrator sets up
sales methods and sales stages that represent the organization’s desired sales
process. A method may encompass every stage associated with the sales process,
from prospecting to forecasting to closing deals. You can set up as many methods
and sales stages as your organization needs. Sales representatives can then use the
method most appropriate for their opportunities.

Sales methods can differ even within one organization. For instance, a sales method
for dealing with complex multimillion dollar opportunities may include as many as
fifteen stages, while a sales method of a low dollar opportunity may require only
four.

Sales methods and stages are only associated with activity templates and
assessment templates of type Opportunity.
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Business Scenarios

This scenario provides an example of a process flows performed by the
administrator and the end users in a sales situation. Your company may follow a
different process flow according to its business requirements.

Business Scenario for Sales

A sales organization has adopted a new sales methodology in order to improve the
effectiveness of its sales people. The business analyst has provided the
administrator with a detailed document describing the sales method, the stages of
the method, and the activities that each salesperson should perform at each stage
of the deal. The outline of the document looks like this:

Qur New Sal es Met hod
> Stage 1, Prospecting, the | ead discovery phase. (Status = Open)

> Stage 2, Qualification of the |l ead and working up the deal .
(Status = Open)

0 Stage 3, Cosing the deal and entering the order. (Status =
Won)

> Activity 1, Prepare the quote within 2 days

> Activity 2, Email the quote to nanager for approval within 3
days

> Activity 3, Create the contract within 1 week
> Stage 4, Lost deal. (Status = Lost)

The administrator creates a new sales method record (New Sales Method) and four
associated sales stage records (Prospecting, Qualification, Closing, and Lost).

Next, she creates four new activity templates, one for each stage. The activity
template describes the activities and milestones that the sales people should
perform at that stage.

Because the sales people enter their own opportunities, the administrator sets up
the activity template details so that the salesperson who enters the opportunity will
be automatically assigned ownership of the activities.
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Business Scenarios

By setting up lead times in the activity template details, the due dates for the
activities will be calculated automatically from the date that the opportunity enters
the sales stage.

Sometimes sales people have too many opportunities to deal with at once. To help
them prioritize, the business analyst has created a standardized assessment
document that he recommends all sales people use to rank their opportunities. The
outline of assessment document looks like this:

Assessing a Lead at the Qualification Stage
> Attribute 1: Adaptability to New Technol ogy, weight =5
O Attribute 2: Nunber of potential users, weight =7
0 to 50, score = 0, Too small
51 to 100, score = 1, Route to telesales
101 to 500, score = 2, Route to middle market
nore than 500, score = 6, Pursue aggressively
O Attribute 3: Sponsor’s stance, weight = 10
Adversarial, score = -5, Strongly against us
Weak, score = 0, Neutral or slight favor another vendor
Moderate, score =5, WIling to recormend our product
Strong, score = 10, Believes we are the best choice
> Attribute 4. Lead' s purchase profile and history, weight =5

The administrator uses the information in this document to create an assessment
template associated with the qualification stage. When a salesperson reaches the
qualification stage of the deal, the Assessments view for that opportunity is
automatically populated with the questions that need to be answered in order to
assess and prioritize the opportunity.

Other Business Scenarios
Activities, activity templates, and assessment templates are used in many ways
throughout Siebel applications. For examples of other scenarios, see:
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n  Siebel Sales User Guide

m Siebel Call Center User Guide

m  Siebel Field Service Guide

m Siebel Professional Services Automation User Guide

m Siebel Order Management Guide
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Example Process Flow for Activities Administration

Administrator Procedures

Defining a Sales
Methodology

Creating an
Activity Template

End-User Procedures

¥

h 2

Creating an
Assessment
Template

Sales teams use

activity templates

to create activity
plans

F

L
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¥

Sales teams
assess the
effectiveness of
the sales
rmethodalogy

Figure 13. Example Process Flow for Sales Business Scenario

Example Process Flow for Activities Administration

Figure 13 illustrates the process flow for the business scenario (“Business Scenario
for Sales” on page 259).

The tasks are typically, but not necessarily, carried out in the order presented.
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Defining a Sales Methodology
There are two parts to creating a sales methodology:
m Creating the sales method record

m Creating a sales stage record for each stage in the methodology

NOTE: Sales methods and stages are associated with activity templates and
assessment templates of type Opportunity. If you are not intending to create a
template of this type, you do not need to define a sales methodology.

You use the Sales Methods view of the Applications Administration screen to define
sales methods and to create and associate sales stages with each of those methods.

To create a sales method and associated sales stages

1 From the application-level menu, choose View > Site Map > Application
Administration > Sales Methods.

2 In the Sales Methods list, create a new record and complete the necessary fields.
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3 In the Sales Stages list, create a new record, and complete the necessary fields.

Some fields are described in the following table.

Field

Comments

Phase

Status

Quota Factor

Order

This value is used for rolling up many different stages into phases.
Select the one that best matches the stage you are currently adding.
For example, a stage called Prospecting would best match the lead
discovery phase.

The choices in this drop-down list are configured by using the
SALES_STAGE_PHASE_TYPE type in the List of Values. For more
information, see Chapter 4, “Working with Lists of Values.”

The default choices are:
» A -Lead Discovery

= B - Working the Deal
= C-Closing

= D-Lost Deal

The choices in this drop-down list are configured by using the
SALES_STAGE_STATUS type in the List of Values. For more
information, see Chapter 4, “Working with Lists of Values.” The
default choices are Open, Won, and Lost.

The amount by which a sales representative’s quota will be multiplied
by for that sales stage.

As you move deals from one stage to another, some deals will fall out
of the pipeline. In order to eventually close $1,000,000 in revenues,
you might need $10,000,000 worth of stage 01 deals, or $5,000,000
worth of stage 04 deals, or $1,500,000 of stage 08 deals. This means
your quota factors in this case will be 10 for stage 01, 5 for stage 04,
and 1.5 for stage 08.

In your Siebel application, a sales representative’s quota is the sum
total of his or her revenue quota objectives on all of his or her active
quota plans.

The default value is 1.

The sales stage’s position in the list of values in the Opportunities
screen.
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Field Comments
Win The probability or likelihood (out of 100) that, after successfully
Probability completing this stage, the deal will eventually be won. In theory, the

later the stage, the higher the win probability should be, because each
stage brings the salesperson closer to winning the deal.

Duration The number of days in a particular stage required for an average deal
under average circumstances.

Stalled Deal The number of days that an opportunity can be in a particular sales

Limit stage. If the opportunity exceeds this limit, you can consider the deal
to be stalled. There is no effect on the sales stage or any other aspect
of the opportunity.

Before the Sales Method and Sales Stage can be used, the cache may need to be
refreshed. For more information, see “Clearing the Cache” on page 104.
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Creating an Activity Template

You use the Activity Templates view of the Applications Administration screen to
create activity templates.

NOTE: For information about creating service activity templates using the Service
Details view, see Siebel Field Service Guide.

To create an activity template without grandchild records

1 From the application-level menu, choose View > Site Map > Application
Administration > Activity Templates.

2 In the Activity Templates list, create a new record and complete the necessary
fields.

Some fields are described in the following table.

Field Comments

Sales Stage If you are creating a template of type Opportunity, select the sales
stage with which you would like to associate the activity template.
When the sales stage is selected, the Sales Method field is
automatically filled in.

When this sales stage (and sales method) are specified for an
opportunity, the activity template is used to automatically populate
the Activity Plan and Activity lists for that opportunity.

For information about creating sales stages and methods, see
“Defining a Sales Methodology” on page 263.

Type Select the type that specifies where you would like the template to
be available. For example, select Account if you want to use this
template to create activity plans for accounts, or Milestone for TAS
customer milestones.

The choices in this drop-down list are configured by using the
TEMPLATE_OBJECT_TYPE type in the List of Values. For more
information, see Chapter 4, “Working with Lists of Values.”
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Creating an Activity Template

Comments

Sales Method

Public

When the sales stage is selected, the Sales Method field is
automatically filled in.

There is no logic associated with this field. You may choose to use it
in conjunction with workflows and search specifications.

3 Click the Activity Template Details view tab.

4 In the Activity Templates Details list, create a new record, and complete the

Version 7.5, Rev. C

fields.

Some fields are described in the following table.

Field Comments

Type The choices in this drop-down list are configured by using the
TODO_TYPE type in the List of Values. For more information,
see Chapter 4, “Working with Lists of Values.”

Duration The time in minutes needed to complete the activity.

Lead The lead time for the activity.

Units Units of time to measure the lead time of the activity.

Employees User names of the people who are to perform the activity.
See “About Activity Assignment” on page 270.

Breakable This is an input parameter to Siebel Scheduler. For more

Lock Schedule

Work Time

Alarm
Category

Lock Assignment

information, see Siebel Field Service Guide.

This field is used for service activity templates. For more
information, see Siebel Field Service Guide.

This field is used for service activity templates. For more
information, see Siebel Field Service Guide.

Whether an alarm should go off when it is time for the activity.
See “About Activity Assignment” on page 270.

Whether the Employees field should be locked. If it is unlocked,
the Assignment Manager can reassign it.
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Field Comments

Required This check box indicates that the activity must be completed.
This is for information only; there is no associated code.

Display In Choose to display the activity in the Calendar screen, the
Activity screen, or in both. This field is not displayed by default.

5 Create a new activity template detail record for each activity associated with the
activity template.
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Deleting an Activity Template

CAUTION: If you delete an activity template, all activities associated with activity
plans that reference the template are also deleted.

To delete an activity template

1 From the application-level menu, choose View > Site Map > Application
Administration > Activity Templates.

2 In the Activity Templates list, select and delete the activity template record.
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About Activity Assignment

Activities created using activity templates can be assigned automatically to:

» The employee who is specified in the template

m The employee who creates the activity, using activity templates (this is usual in
a sales situation)

= No employee (this is recommended when Assignment Manager will be used to
assign the activity)

The assignment is determined by the values in the Employee and Category fields of
the activity record in the Activity Template Details list, according to Table 20.

Table 20. Employee and Category Values Determine Activity Assignment

If Employee Is...

NOT NULL

NULL

NULL

and Category ls...

any value
(NULL or NOT NULL)

Field Engineer Activity
Repair Activity,
Preventive Maintenance, or Other

not Field Engineer Activity, Repair
Activity, Preventative
Maintenance, or Other

Then the Activity Is...

assigned to the employee who is
specified in the Employee field of
the template.

not assigned. The Employee and
Owner fields are blank in the
created activity.

assigned to the employee who
creates the activity (by applying
the activity template).

NOTE: Activities created directly in the Activities screen are similarly affected by the
Category value. If the Category value is changed to Field Engineer Activity, Repair
Activity, Preventive Maintenance, or Other, the values of Owner and Category fields
will be deleted and set to NULL when the record is saved.
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Creating an Assessment Template

You use the Sales Assessment Templates view of the Applications Administration
screen to create assessment templates.

To create an assessment template

1 From the application-level menu, choose View > Site Map > Application
Administration > Sales Assessment Templates.

2 In the Assessment Templates list, add a record, and complete the necessary

fields.

Some fields are described in the following table.

Field

Comments

Assessment

Type

Sales Stages

Sales Method

The name of the template.

Select the type that specifies where you would like the template to
be available. For example, select Contact if you want to use this
template to create an assessment plan for contacts.

The choices in this drop-down list are configured by using the
TEMPLATE_OBJECT_TYPE type in the List of Values. For more
information, see Chapter 4, “Working with Lists of Values.”

If you are creating a template of type Opportunity, select sales
stages with which you would like to associate the assessment
template.

When one of these sales stages (and matching sales method) is
specified for an opportunity, the assessment template is used to
automatically populate the Assessments view for that opportunity.

This field is filled when a sales stage is selected.
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3 In the Assessment Attributes list, add a record for each attribute you want to
assess.

Some fields are described in the following table.

Field Comments

Order The attribute’s position in the Assessment Attributes list.

Name Name of the attribute.

Weight The relative importance of the attribute.

Max Child This field contains the maximum score from the Attribute Values list.

Weight Times  This is the product of the Weight and the Max Child values.
Score

4 TFor each assessment attribute, create a record for each possible value of the
attribute.

Some fields are described in the following table.

Field Comments

Order Indicates the value’s position in the Attribute Values list.

Value The name of the value, for example, Excellent, Good, or Average.
Score The number of points that the value represents.

Description Additional information about the value to help the assessor.

These values will appear in the Pick Attribute Value dialog box when the end
user applies the template. For information about using an assessment template,
see Siebel Sales User Guide or Siebel Call Center User Guide.

272 Applications Administration Guide Version 7.5, Rev. C



Activities, Activity Plans, and Assessments ‘

Creating an Assessment Template

How Assessment Scores Are Calculated
The total score for the assessment is determined by summing weighted scores for
each assessment attribute:

n
Total_Score = E { Weight;){ Score;)
i=1
where n is the number of assessment attributes in the template.

The score is also calculated as a percentage of the maximum score possible:

n
Max_Total_Score = E (Weight ){ Max_Score;)

where Max_Score; is the largest score for any value in the Attribute Values list for
the ith attribute. This is the Max Child value shown in the Assessment Attributes
applet. (For example, in the assessment example in the “Business Scenario for
Sales” on page 259, the largest score for Attribute 2 is 6 and the largest score for
Attribute 3 is 10.)
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About Configuring Activities

This section describes some aspects of the activities that configurators or
administrators may want to change:

»  Configuring Owner and Employee Fields

m Creating TAS Customer Milestone Templates in a Localized Application

Configuring Owner and Employee Fields

Depending on your business process, you may want to configure the Siebel
application so that the Employees and Owner fields for activities are always left
blank when the activity is created. (The Owner field displays the primary from the
Employee field.)

To achieve this, use Siebel Tools to set the pre-default value of the Primary Owned
By field (which maps to the Owner field that appears in the UI) in the Action
business component to blank.

For information about using Siebel Tools, see Siebel Tools Reference.

Creating TAS Customer Milestone Templates in a Localized
Application

The sample TAS Customer Milestone activity template is available only in English.
If you are running a localized version of the Siebel Sales application (that is, a
version in a language other than English) and are using the Target Account Selling
(TAS) module, you need to create an activity template of type Milestone, as outlined
in the following procedure.

To translate a TAS Customer Milestone template for a localized application

1 From the application-level menu, choose View > Site Map > Application
Administration > Activity Templates.
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2 In the Activity Templates list, query for records of type Milestone where
Milestone is the translation of the English word in the localization language.

NOTE: For the translation, see the Interface Terminology Look-up manual for your
language, or, in the List of Values, look for the Display Value that corresponds to
the Language-Independent Code for Milestone. For more information about List
of Values, see Chapter 4, “Working with Lists of Values.”

Six records should be found by the query:
= 1-Request Offering(s)
= 2-Evaluate Offering(s)
= 3-Approve / Select
= 4-Legal / Purchasing
= 5-Implement
= 6-Measure
3 For each of the six templates:
a Click the Activity Templates Detail view tab.

b Make sure that for each detail record, the Type is Recommended Activity
where Recommended Activity is the translation of the English phrase in the
localized language. (See note in Step 2.)

¢ Optional: Translate the Description of each detail record into the localized
language.

4 Follow the procedure for adding a milestone in the Siebel Sales User Guide. Make
sure that the six Activity Templates (Step 2) appear in the Event field drop-down
list.

Version 7.5, Rev. C Applications Administration Guide 275



‘ Activities, Activity Plans, and Assessments

About Configuring Activities
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The Opportunities screen allows you to manage and track information associated
with a potential revenue-generating event. Using the Opportunities screen, you can
gather customer requirements, review information about the customer, assemble a
sales team, review and update information about competitors, track activities, track
private notes and team notes, create quotes, and automatically generate
presentations and proposals.
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About Opportunity Workflows

Opportunity workflows enhance lead routing and provide sales professionals with
greater visibility into their sales activities. These workflows are executed from the
Opportunities screen. An opportunity record describes important information about
the opportunity such as the account, potential revenue of the deal, the probability
of closure, the lead status and sales stage, the sales team primary, and the expected
close date.

The predefined opportunity workflows allow you to use email to capture
information related to the opportunity and distribute timely notifications to key
members of the sales team. These workflows help improve the efficiency and
effectiveness of the sales cycle while also providing sales representatives and sales
managers greater visibility into sales activities. The email notification process is
activated only if the opportunity has a possible revenue of more than $50,000.

The seven predefined opportunity workflows are:
= Opportunity Assigned Notification Process

= Opportunity Inactive Notification Process

= Opportunity Lost Notification Process

= Opportunity Pending Notification Process

= Opportunity Won Notification Process

m Create rerouted Oppty Activity

s Get Manager Email

For information about configuring, implementing, testing, and monitoring
workflows, see Siebel Business Process Designer Administration Guide.
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Setting Up Opportunity Notification Workflows

Follow these steps to correctly set up the opportunity workflows:

Version 7.5, Rev. C

Revise all Siebel workflows so that they are editable and have a status of In
Progress. All Siebel workflows are initially inactive and cannot be edited. Make
any necessary changes and activate the workflows.

Verify that the Workflow Server component and the Communication Manager
component are enabled and running. For detailed instructions, see the system
requirements and supported platform documentation for your Siebel
application.

Set up the communication profile. See “Setting Up the Communications Profile.”
Set up and activate the workflows and policies.

= Activate the opportunity workflow processes. See “Activating the
Opportunity Notification Workflow Processes and Policies” on page 281.

= Modify Opportunity workflows, as necessary. See “Modifying Opportunity
Workflows” on page 286.

= Set up the Create Reroute Oppty Activity. See “Rerouting an Opportunity” on
page 285.

= Set up the Get Manager Email. See “Setting Up the Get Manager Email” on
page 288.

Load runtime events for the emails. See Siebel Business Process Designer
Administration Guide.

Generate the triggers. See Siebel Business Process Designer Administration
Guide.

Run the workflow monitoring agent. See Siebel Business Process Designer
Administration Guide.
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Setting Up the Communications Profile

You must specify the communications profile before using the notification
workflows.

To set up the communications profile

1 From the application level menu, choose View > Site Map > Communications
Administration > Communications Drivers and Profiles.

2 Select the record for the Internet SMTP/POP3 Server driver.

3 Click on the Profiles tab, and create a new profile. Name the profile Opportunity
Notification Profile.

4 In the Profile Parameter Overrides list, enter records and values for the following
fields:

= From Address
s SMTP Server

For more information about implementing and configuring communications
integrations for your Siebel applications, including creating profiles for the Internet
SMTP/POP3 Server driver, see Siebel Communications Server Administration Guide.
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Activating the Opportunity Notification Workflow
Processes and Policies

There are five different workflow processes that will generate automatic emails. All
of these processes need to have the communication profile specified. See “Setting
Up the Communications Profile” on page 280.

Opportunity Assigned Notification Process
Opportunity Inactive Notification Process
Opportunity Pending Notification Process
Opportunity Lost Notification Process

Opportunity Won Notification Process

The following procedure sets up this automatic notification process.

To set up the opportunity workflows

1

W N o a
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From the site menu, choose View > Site Map > Siebel Business Process
Administration > Workflow Processes.

Query for Opportunity *Notification*.
The five processes are displayed.

Select each process and click Revise. Each time you click Revise, a new version
of the process is created with a status of In Progress.

One by one, select each new In Progress process and click Process Properties.
In the Communication Profile field, enter Opportunity Notification Profile.
Make any other necessary modifications to the workflow processes.

Activate each process.

From the application-level menu, choose View > Site Map > Siebel Business
Process Administration > Workflow Policies.

In the Policy Group list, query for Opportunity Workflow Group.
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10 Clear the Expiration field for each of the five workflow policies that result from
the query.

Opportunity Assigned Notification Process

This workflow sends an email message to both the primary sales representative and
the sales representative’s direct manager when a new lead is assigned to a sales
representative. The email provides the basic information about the opportunity,
including the opportunity ID and account, the primary revenue amount, and the
number of days allowed before the lead is withdrawn and rerouted. The sales
representative is directed to the Opportunities screen for further details.

Opportunity Inactive Notification Process

This workflow sends out an email notice when the sales representative has accepted
a lead by changing the Status field to Accept, but has not taken any action on the
lead for 30 consecutive days. An email reminder is sent to both the sales
representative and the sales representatives direct manager. The notice reminds the
sales representative that if no action is taken on the lead within seven days, the lead
will be withdrawn from the queue and rerouted.

The default time lapse between when the lead is accepted (or last worked on) and
when the email is delivered is 30 days. This default can be modified.

To change the time lapse between lead acceptance and inactive notification

1 From the application-level menu, choose View > Site Map > Business Process
Administration > Workflow Processes.

2 Query and select the Opportunity Inactive Notification Process.
3 Click the Process Properties tab.

4 1In the Duration Days column, click the Default Number field, and modify the
number.

By default, the units are in days. To modify this, navigate to the Workflow
Processes and click the Process Designer tab. Double-click the Wait step. In the
Input Arguments applet, change the Sleep Unit value field.

5 In the Workflow Processes view, make sure the Opportunity Inactive
Notification Process is selected.

282 Applications Administration Guide Version 7.5, Rev. C



Opportunities ‘

Activating the Opportunity Notification Workflow Processes and Policies

6 Activate the workflow and run the Workflow Monitor Agent. See Siebel Business
Process Designer Administration Guide.

NOTE: Out-of-the-box reassignment of leads is executed manually. You may want
to create a workflow that automatically reassigns the lead to a sales manager or
administrator after a specified amount of time.

Opportunity Pending Notification Process

This workflow sends an email notice when the sales representative has not
responded or taken action on the opportunity for five days. This occurs when the
sales representative has not changed the Status field from pending to accept, reject,
or reroute. The email is sent to both the primary sales representative and the sales
representative’s direct manager. The email reminds the sales representative to act
on the lead or risk having the lead withdrawn from the queue.

To modify the time lapse between lead assignment and email delivery

1 From the application-level menu, choose View > Site Map > Business Process
Administration > Workflow Policies.

Query for E*N*P* (email notification of pending opportunity).
Verify that the policy is activated.

Select the policy and modify the Duration and Unit(s) fields.

a ~» W N

Activate the workflow and run the Workflow Monitor Agent. See Siebel Business
Process Designer Administration Guide.

Opportunity Lost Notification Process

This workflow sends an email message to both the primary sales representative and
the sales representative’s direct manager when an opportunity is closed with a loss.
The status of the opportunity must change to lost before the email notice is
generated. The email refers to the Opportunities screen and asks the sales
representative to update the Reason field.
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Opportunity Won Notification Process

This workflow sends an email message to both the primary sales representative and
the sales representative’s direct manager when an opportunity is closed with a win.
The status of the opportunity must change to win before the email notice is
generated. The email refers to the Opportunities screen and asks the sales
representative to update the Reason field.
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Rerouting an Opportunity

The Create Rerouted Oppty Activity workflow is executed when a sales
representative receives a lead and changes the Status field to Reroute. The workflow
creates a new Activity record with Type = Reroute for the designated sales operator.
This informs the sales operator that a specific opportunity has been requested for
rerouting. All reassigned opportunities are listed in the Activities view as rerouted
activities.

NOTE: If a sales manager or sales administrator is responsible for rerouting leads, you
can modify the workflow so that the Create Rerouted Oppty Activity is assigned to
the sales manager or administrator. You can also create a workflow that reassigns
the lead to a sales manager or administrator.

To set up the opportunity reroute activity

1 From the Site Map, choose Siebel Business Process Administration > Workflow
Processes.

2 Locate and select the Create Reroute Opportunity Activity workflow process.
3 Click Revise.
4 Click the Process Properties tab.

The Status field should indicate In Progress.

5 In the Sales Operator Login field, replace the default with the login of the sales
operator who will receive the activity. Remember that the login is case-sensitive.

6 Click the All Processes tab.

7 Click Activate.
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Modifying Opportunity Workflows

An administrator can modify the opportunity workflows; the email language can be
modified, the notification time can be changed, and lead notification restrictions
can be set.

NOTE: The opportunity workflows are shipped as seed data. To modify a workflow,
you should make a copy of the original workflow, and then modify the copy.

To modify the language of an opportunity workflow email

1 From the application-level menu, choose View > Site Map > Business Process
Administration.

2 Select Workflow Processes.
3 Select or Query for the workflow you want to modify.
To view all seven opportunity workflows, type “O*N*”.
4 Click the Process Designer tab in the middle applet.
5 Double-click the Send Out Emails rectangle.
The Business Service Input Arguments view appears.

6 In the Input Arguments applet, find the input argument called Message Body
and click on the Value field.

The email message text is displayed.

7 Make any required text changes. The text includes field placeholders for data
from the opportunity record. These placeholders appear as “ + [Placeholder
field] + .

8 Activate the workflow and run the Workflow Monitor Agent. For more
information, see Siebel Business Process Designer Administration Guide.

To restrict conditions for delivery of emails

1 From the application-level menu, choose View > Site Map > Business Process
Administration > Workflow Policies.
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2 Select or Query for the workflow you want to modify.
To view all five email notification policies, type “E*N*”.
3 Select the policy to modify.
4 1In the Conditions applet, select a condition, or add a new condition.
5 Click on the Operation and Value fields and modify the condition.

For example, to send email notifications for leads that have a high lead quality,
add the following condition:

Condition Field = Opportunity Lead Quality
Operation = “="”

Value = “l-excellent”

6 Activate the workflow and run the Workflow Monitor Agent. For more
information, see Siebel Business Process Designer Administration Guide.

To stop sending email notifications to a sales representative’s manager

1 From the application-level menu, choose View > Site Map > Business Process
Administration.

Query for Get Manager Email.
Click Revise.

Click the Process Designer tab.

a & W N

In the designer palette, click the Connector object and drag a connector between
the Start and End boxes.

6 Delete all other arrows.

7 Activate the workflow and run the Workflow Monitor Agent. For more
information, see Siebel Business Process Designer Administration Guide.
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Setting Up the Get Manager Email

This process identifies the manager of the sales representative so that the manager
can receive a copy of the five email notifications that are delivered. Because the Get
Manager Email process is part of the five notification processes, the Get Manager
Email process must be activated for the other processes to function correctly.

An email is sent to the sales representative and the appropriate manager for each of
the notification workflows.

To enter the manager’s email ID

1 From the Site Map, choose Siebel Business Process Administration > Workflow
Processes.

2 Query for the Get Manager Email workflow.
3 Click Revise.
4 Click Activate.
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Opportunity Audit Trail

The Opportunity Audit Trail allows users to track changes that have been made to
the opportunity record. Any time a member of the opportunity sales team creates a
new opportunity record, updates the opportunity, deletes data, or copies the
opportunity, the action is tracked in the Opportunity Audit Trail view.

Initially, changes to the following fields are tracked:
= Revenue class

m  Probability

Stage

Stage ID

= Status

To track additional fields

1 From the Site Map, select Audit Trail Administration.

2 Query for the Opportunity Bus Comp.

3 Click on the Field tab in the bottom applet.

4 Create a new record and select the new field to track from the list of values.

To enable Audit Trail

1 By default, Audit Trail is not activated. To activate it, navigate to Siebel Tools >
Business Services > Audit Trail Engine > User Property.

2 Set Enable to True.
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Setting Up Lead Sources for Opportunities

Lead sources for opportunities are added, modified, and deleted through the Lead
Sources view of the Data Administration screen.

The following procedure describes how to add lead sources so that they can be
associated with opportunities.

In addition, campaigns automatically appear as lead sources of type Marketing
Campaign. For more information about Campaigns, see Siebel Marketing Guide.

To create a lead source

1 From the application-level menu, choose View > Site Map > Data
Administration > Lead Sources.

2 Create a new Lead Sources record and complete the necessary fields.
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This chapter describes the resource and calendar access tasks performed by the
administrator.

About Resources

Resources are typically things such as conference rooms and audio-visual
equipment that are reserved and used by employees for meetings and other
calendar activities. Resources have availability associated with them and can be
invited as participants to calendar activities in much the same way as employees
and contacts are invited to calendar activities. For more information about adding
participants to activities, see Fundamentals. The administrator is responsible for
setting up and maintaining the list of resources.

About Calendar Access

Normally employees grant each other access to their calendars as described in
Fundamentals. However, there are various situations when the administrator may
be required to add, modify, or delete calendar access for employees.
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Business Scenarios for Calendar Administration

These scenarios provide examples of calendar tasks performed by the administrator.
Your company may follow a different process according to its business
requirements.

Resource Administration
Here are two scenarios requiring resource administration:

Before the Siebel application is rolled out to end users, the administrator creates
resource records. He creates resource records for all the conference rooms for the
various floors and buildings of the company’s sites. He also creates resource
records for the audio-visual equipment that employees may want to reserve for
use at their meetings.

After the Siebel application is rolled out, the company grows and more sites and
conferences rooms are added. Old audio-visual equipment is discarded and new
equipment is purchased. The administrator continues to maintain the list of
resources, keeping it up-to-date.

See “To administer resources for calendar activities” on page 295 for the procedure
associated with these scenarios.

Calendar Access Administration
Here are three scenarios requiring calendar access administration:

Employee A is out of the office unexpectedly. Employee B needs to view
Employee A’s calendar so that she can cancel his appointments. Employee B
asks the administrator to give her access to Employee A’s calendar. See “To give
Employee B access to Employee A’s calendar” on page 296.

An executive has been granted access to many of his colleagues calendars. When
the executive moves to a new division, he no longer needs to access to these
employees’ calendars. He asks the administrator to clear the list by removing his
name from all employees’ Calendar Access List views. Alternatively, the
executive could have contacted all the employees whose calendars are on his
Owner drop-down list and asked each of them to remove his name from their
calendar access lists. See “To remove all employees from an employee’s
Calendar Owner drop-down list” on page 298.
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= When an employee leaves the company, the administrator removes the
employee’s name from the Owner lists of other employees. See “To remove an
employee from all employees’ Calendar Access List views” on page 298.
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Example Process Flow for Calendar Administration

Figure 14 illustrates the process flow for the business scenario.

Setting up of resources is completed before the end users begin to set up meetings.
Other tasks are carried out according to the company’s business needs.

Administrator Procedures End-User Procedures
Setting U Using Calendar
Reggu?ceg # screen to setup

meetings
4 +
Adding and Sharing calendar
Madifying access with other
Calendar Access ermployees

h 2

Deleting Calendar
Access

Figure 14. Example Process Flow
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Setting Up Resources

To administer resources for calendar activities

1 From the application-level menu, choose View > Site Map > User
Administration > Resources.

2 In the Resources list, create a new record or select an existing record, and
complete the necessary fields.

Some fields are described in the following table.

Field Comments
Resource # An automatically generated unique number for the resource.
Site The choices in this drop-down list are configured by using the

RESOURCE_SITE type in the List of Values.

Type The choices in this drop-down list are configured by using the
RESOURCE_TYPE type in the List of Values.

TIP: If the Description and Site fields are not sufficient to identify the resource,
other fields can be added to the Resources list applet. For example, your
company may want to add Building Number and Floor fields to help end users
find and identify resources. For information on adding creating and exposing
fields, see Siebel Tools Reference.

3 Delete resource records as required from this list.
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Adding and Modifying Calendar Access

There are two Calendar Administration applets on the Calendar Administration
view; both can be used to modify calendar access:

m  Access Received lists all the calendars that the selected employee can access.

m  Access Granted lists all the employees who can access the selected employee’s
calendar.

You can toggle between these applets using the Access Granted/Access Received
drop-down list in the lower applet.

To give Employee B access to Employee A’s calendar

1 From the application-level menu, choose View > Site Map > User
Administration > Employees.

In the Employees list, select the employee (Employee A).
Click the Calendar Administration view tab.

From the drop-down list on the Calendar list, select Access Granted.
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In the Calendar list, create a new record or select an existing record and
complete the Last Name and Update Access fields.

Field Comments

Last Name This is the name of the Employee B who wants to access
Employee A’s calendar.

Update Access If this is selected and marked Y, Employee B has read/write
access to Employee A’s calendar.

If this is marked N, Employee B has read-only access to
Employee A’s calendar.

To view all the calendars to which an employee has access

1 From the application-level menu, choose View > Site Map > User
Administration > Employees.
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2 In the Employees list, select the employee.
3 Click the Calendar Administration view tab.
4 From the drop-down list on the Calendar list, select Access Received.

The Calendar Administration list shows all calendars to which the employee has
access.

NOTE: Records can be added, modified, and deleted from this view.
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Deleting Calendar Access

For a selected employee, the administrator can delete all employees from the Access
Granted or the Access Received list.

To remove all employees from an employee’s Calendar Owner drop-down list

1

Navigate to the Calendar Administration view by following Step 1 to Step 4 in
“To view all the calendars to which an employee has access” on page 296.

Make sure that you have selected the employee whose Calendar view Owner
drop-down list you want to clear.

From the menu button in the Access Received list, select Delete All.

This command deletes all records in the list. The employee selected in the
Employees list no longer has access to any calendars other than his or her own.

NOTE: Alternatively, you can use the Delete Record command to remove just one
selected employee from the employee’s calendar owner drop-down list.

To remove an employee from all employees’ Calendar Access List views

1

Navigate to the Calendar Administration view by following Step 1 to Step 4 in
“To give Employee B access to Employee A’s calendar” on page 296.

Make sure that you have selected the employee that you want to remove from
all employees’ calendar access lists.

From the menu button in the Access Granted list, select Delete All.

This command deletes all records in the list. The calendar of the employee
selected in the Employees list can not longer be accessed by any other
employees.

NOTE: Alternatively, you can use the Delete Record command to delete the
employee from one selected employee’s calendar access list.
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About Configuring the Calendar

This section describes some aspects of the Calendar feature that configurators or
administrators may want to change:

= Alarm Manager Load Frequency

= About Configuring the Calendar Gantt Chart

= Days for Retroactive Alarms on page 300

= About Changing Required Fields in the eCalendar Detail Applet on page 301

m  Removing the To Do List from the Calendar View on page 301

Alarm Manager Load Frequency

A system preference called Alarm Manager Load Frequency determines how
frequently the calendar alarm queries the server for alarm-enabled appointments.
The default value is 60 minutes, but you may want to change this time to better suit
your business needs: querying the server less frequently results in fewer SQL calls.
However, each SQL call will take longer to execute. In certain cases, this trade-off
will result in improved performance. (Also, if the alarm frequency is less than the
session timeout set in the eapps.cfg file, sessions will never timeout.)

For information on how to edit system preferences, see “Setting System

Preferences” on page 52.

About Configuring the Calendar Gantt Chart

You can edit applet user properties in Siebel Tools to configure the Participant
Availability Gantt chart (Calendar Detail view) as follows:

= Set the number of days displayed in the Gantt chart. By default, the chart displays
the day of the appointment plus the two days following the appointment day
(Gantt Previous Days = 0 and Gantt Lookahead Days = 2).

= Add or delete buttons. By default all four buttons are displayed.
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Configure the HI Gantt Chart Applet by editing the user properties listed in Table 21.

Table 21. User Properties for Days Displayed on the Hl Gantt Chart Applet

Applet User Property Description Allowed Values
Gantt Previous Days Number of days before current date that = 0,1,2,3 ...
will be displayed
Gantt Lookahead Days Number of days after current date that 0,1,2,3...
will be displayed
Enable AddEmployee Enables and disables the Add Employee = Y, N
button
Enable AddContact Enables and disables the Add Contact Y, N
button
Enable AddResource Enables and disables the Add Resource Y, N
button
Enable RemoveParticipant = Enables and disables the Remove Y, N

Participant button

For information about:
m Participant Availability Gantt chart, see Fundamentals.

= Editing user properties, see Siebel Tools Reference.

Days for Retroactive Alarms

Retroactive alarms are alarms for past events that did not display before the event
because the user was not logged in. By default, the application is set to display
retroactive alarms for missed events up to 14 days in the past. You can change the
number of days for retroactive-alarm display by editing the RetroAlarmInterval user
property of the Alarm Manager business service.

For more information about editing user properties, see Siebel Tools Reference.
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About Changing Required Fields in the eCalendar Detail Applet
In the preconfigured application, the Type field is the only required field in the
Calendar Detail form in the Calendar Detail view. If you make other fields required,
you must predefault these fields. This is because when users create a new record or
drill into a record from the calendar grid, an implicit save of the record is triggered.
If any fields are required but not predefaulted, their values will be null when the
implicit save is triggered and an error message will be generated.For more
information about predefaulting fields, see Siebel Tools Reference.

Removing the To Do List from the Calendar View
You can configure the daily, weekly, monthly calendar view (HI Activity Calendar
View) so that the Calendar To Do list applet does not appear.

You might choose to do this if your employees do not use the To Do list or if you
need more space for the calendar applet on the view.
To remove the To Do list from Calendar views

1 Open the CCViewHIC.swt file in a text editor.

For more information about SWT (Siebel Web Template) files, see Siebel Tools
Reference.
2 Comment out the following text (the first line is already commented):
<l--Colum 2 -->
<td valign="top" w dth="21% >
<swe: f or-each count="20" iteratorNane="currentld" startVal ue="201">
<swe: appl et hi nt MapType="Appl et" id="swe:currentld" property="Formatted...
</ swe: f or - each>

</td>

3 Save and close the file.
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Siebel Correspondence allows employees and partners to generate correspondence
from any location with access to the Web. It also makes it easy for them to direct
correspondence to fulfillment centers that print and mail it, so they can produce and
send correspondence even if they are on the road and do not have access to a
printer.

For example, if salespeople want to do mass mailings to customers in cities where
they are giving presentations, Siebel Correspondence allows them to log on from
any location where they have Web access. Then they can create personalized form
letters to invite customers in a specific city to a specific presentation, and direct
these letters to be printed and mailed by a fulfillment center.

First, an administrator creates templates (which are similar to form letters) that
employees and partners can use for their everyday correspondence. Then,
employees and partners can automatically generate correspondence based on this
template and on information in Opportunity and Account records.

This chapter describes how the administrator sets up Siebel Correspondence.

For information about how the end user generates correspondence, see Siebel Sales
User Guide.
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System Requirements for the Web Client

To use Siebel Correspondence, you must have:

= Siebel Document Server, including Siebel Correspondence engine, installed on a
Windows server. The document server can be installed during installation of the
Siebel Server.

= Microsoft Office installed on the server.

= All of the components that are required to use Siebel 7.5 software installed on
the server, such as a Siebel Server and a Web Server.

NOTE: If you are deploying Siebel Server in UNIX and need Siebel Correspondence,
a separate Windows machine is required for Siebel Correspondence.

Siebel Correspondence uses the Document Server, a new component of the Siebel
Server which lets users on the Web work with Word documents that are on the
Server.

Your employees or partners who use Siebel Correspondence need:
m A Web browser to use the product
= Optionally, Microsoft Word to edit documents

For information on the Web browsers that are supported, see Release Notes.

System Requirements for the Remote Web Client

Siebel Correspondence is available for the Siebel Remote Web Client as well as for
the Siebel Web Client. The user interface for Correspondence is identical in the
Remote Web Client and the Web Client.

However, the Remote Web Client processes requests to generate documents locally,
so field sales representatives can generate proposals, presentations, and
correspondences while traveling.

To run Siebel Correspondence on the Remote client, you must have Microsoft Word
installed on the same machine as the Remote Client.
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Installing the Document Server

Siebel Correspondence, Siebel Presentations, and Siebel Proposals all use the Siebel
Document Server to generate Microsoft Word and Microsoft PowerPoint documents
through the Web.

To install the Document Server, perform the following steps:
m Obtain the required hardware.

= Install the Siebel Server.

m Install third-party applications.

After installing the Siebel Server, you may have to follow some of the steps
described in “Configuring the Document Server” on page 307. The Document
Server is a component of Siebel eDocuments, which can be installed during
installation of the Siebel Server. Consult with your system administrator to verify
that the Document Server has been installed and configured according to the
requirements listed in the following sections.

Hardware Requirements

The Document Server is supported on the Windows 2000 platform. To maintain
stability and performance, the Document Server must run on a dedicated host
machine. The Siebel Server on this machine should host one instance of the Siebel
eDocuments component group. No other components should be running other than
required system components.

To support more users, you can run additional instances of the Siebel eDocuments
component group on additional dedicated host machines.

Installing the Siebel Server

Install the Siebel Server on the dedicated host machine of the Document Server. For
more information about installing the Siebel Server, see Siebel Server Installation
Guide for Microsoft Windows.

During installation, you will have the option to enable component groups. Select
the Siebel eDocuments component group. Do not enable any other component
groups.
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This step can also be performed after installation is complete, as described in the
section “Enabling the Component Group” on page 307.

Installing Third-Party Applications
You must install Microsoft Word.

To install Microsoft Office

1 Logon to the server machine using the same user account that the Siebel Server

NT service uses. This user account must belong to the Administrators group.

NOTE: The install must use the same account to be used by the NT Service. The
installer configures COM security settings so that the installing user account will
have the correct permissions to access and launch the application. If the install
uses an account other than the Siebel Server NT service account, errors may
occur when the Document Server tries to launch the application.

Install Microsoft Office using a Typical, or complete, installation. Verify that your
version of Microsoft Office will install the Web Authoring Tools (HTML)
component with the Typical installation. If it does not, you will need to use the
Custom installation option, and install all of the typical components as well as
the Web Authoring Tools (HTML) component.

Start the applications that will be used by the Document Server. This forces the
applications to register themselves.

4 Close the applications.
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Configuring the Document Server

After finishing the installation steps, perform the following steps to configure the
Document Server:

Enable the component group

= Set MaxTasks to 1

m Set the Honor MaxTasks parameter

= Synchronize components

m Configure report generation (optional, only used by Proposals)
= Enable HTML generation (optional)

= Configure application recycle period (optional)

= Specify the target server (optional)

= Enable additional logging (optional)

NOTE: Whenever the Siebel application server is restarted, the Document Server
must also be restarted after the Siebel application server has been brought up.

Enabling the Component Group

If you have not already done so during installation, you must enable the component
group named Siebel eDocuments. This group contains the DocServer component,
which generates Correspondence, Presentations, and Proposals. For more
information about enabling this group, see Siebel Server Administration Guide.

Setting MaxTasks to 1

Due to design limitations, third-party applications can only process one document
at a time. This means that each instance of the Siebel Document Server should only
process one task at a time.
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To set the MaxTasks parameter to 1

= See the section about Siebel Application Object Manager parameters in the Siebel
Server Administration Guide.

NOTE: If MaxTasks is greater than 1, then an error message is sent to the log file as
an alert. Processing of the request continues, but results are unpredictable when
two requests arrive at the same time.

Setting Honor MaxTasks
Honor MaxTasks is a Siebel Application Object Manager parameter that affects the
queuing process and the performance of Document Server. Refer to Table 22.

Table 22. Honor MaxTasks Parameter for the Document Server

Setting Behavior

TRUE ! All requests to Document Servers queue on the SRM_REQUEST table;
requests are not assigned to a Document Server until one is free to take
the request.

FALSE Requests are queued on the DocServer component’s internal queue. If the
Document Server stops processing (for example, crashes) all queued
processes on that server are lost.

1. This is the recommended value.

To set the Honor MaxTasks parameter

m See the section about Siebel Application Object Manager parameters in the Siebel
Server Administration Guide.

Synchronizing Components

This step is not specific to the Document Server, but is a required post-installation
step for the server infrastructure. For information about synchronizing components,
see Siebel Server Administration Guide.
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Configuring Report Generation (Optional)

f you plan to include Report sections in Proposals, you must specify the Actuate
connect string. Set this parameter on each object manager that will be submitting
document requests. The value of the parameter will be included in the request sent
by the object manager to the DocServer. When DocServer begins processing the
request, it will use the parameter to connect back to the object manager to retrieve
data for the report.

To specify the Actuate connect string

1 Start the Server Manager.

2 Change the server parameter ActuateConnStr to contain the following
information:

si ebel . tcpi p: // gat ewayserver: port/enterpriseserver/objectngr/
si ebel server

For example, if \\gtwy is the gateway server host, Sieb01 is the Siebel Server, siebel
is the Enterprise Server, and you want to run your proposal with report section on
callcenter, whose object manager is SCCObjMgr, you should enter the following
command:

srvrngr> change param Actuat eConnStr=si ebel .tcpi p://gtwy/siebel/
SCCOhj Myr/ Si eb01 for conp SCCOoj Myr

The parameter ProposalReportTimeoutInSecond also affects the generation of
reports. This is the time-out setting that controls how long the Document Server
component will wait for a report to be generated. The default value is 1800 seconds.

Enabling HTML Generation (Optional)

By default, correspondence is only saved in document format, not in HTML format.
The user’s View HTML button is unavailable, and the user cannot view the
correspondence in HTML format.
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The server parameter DocumentServerViewHTML specifies whether the Document
Server generates HTML versions of documents. The default value is FALSE. By
default, the Document Server only generates documents in their native format, and
not in HTML. To allow the user to display correspondence in HTML format, you
must edit the parameter DocumentServerViewHTML to give it the value True
instead of False. Any documents generated after the parameter is enabled is saved
in both formats.

When you generate HTML documents, a copy of the generated document is created
in HTML and stored in the Siebel File System. This may affect performance, and it
will increase the storage space required in the File System. The clarity of the HTML
document depends on your Office application’s ability to translate its native format
into HTML.

Entering the following command allows generation of HTML versions of
Correspondence, Proposals, and Presentations.

To enable generation of HTML versions of documents
1 Start the Server Manager.
2 Enter the command:

Srvrngr > change param Documnent Server Vi ewHTM.=True for conp
DocSer ver

NOTE: While this procedure uses the Server Manager, parameters can also be
changed using the Server Administration interface. For more information, see the
Siebel Server Administration Guide.

Configuring Application Recycle Period (Optional)
You use the parameter MSWordLiveCount to control how often the office
applications are restarted.
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Each parameter can be set to a positive integer that specifies the number of
documents to be processed before it shuts down and restarts the corresponding
office application. A value of 0 (the default) indicates that the applications will not
be shut down. If the parameter value is set to any integer other than 0 and the
Document Server fails to launch, the corresponding application will be shut down
and then restarted again.

To change the values of these parameters
1 Start the Server Manager.

2 To change the application recycling period for Microsoft Word, which is used by
Correspondence and Proposals, enter the command:

Srvrngr> change param MSWrdLi veCount =5 for conp DocServer

3 To change the application recycling period for Microsoft PowerPoint, which is
used by Presentations, enter the command:

Srvrngr> change param MSPPLi veCount =5 for conp DocServer

Specifying the Target Server (Optional)

If you are running multiple Document Servers within the same enterprise, then the
server infrastructure will route document requests to different Document Servers in
order to achieve load balancing.

However, it sometimes may be useful to specify that all requests be routed to one
Document Server. For example, you can do this to help diagnose a server problem.

To route all requests to one document server
1 Start the Server Manager.
2 Enter the command:
srvrngr> change param Docunent Ser ver Name=DocSr vr 1
Enabling Additional Logging (Optional)

Optionally, you may want to enable additional logging, which can be helpful for
debugging.

Version 7.5, Rev. C Applications Administration Guide 311



‘ Correspondence

Configuring the Document Server

The event logging system writes events to the log file based on the log level for each
event type. The number you specify indicates the filtering level for logging. The
default value is 3, which means that events with a level of 1, 2, or 3 will be logged,
while events with a level of 4 or 5 will be suppressed. Setting the filtering level to 5
means that all events will be logged.

NOTE: In the final command on the list, the parameter must be in quotation marks,
because it has a space in it. In the other commands, quotation marks are optional
and are not included in the list.

To enable additional logging

1 Start the Server Manager.

2 Enter the following commands:
srvrngr> change evtloglvl CGenericlLog=5 for conp Docserver
srvrngr> change evtl ogl vl Proposal Debug=5 for conp Docserver
srvrngr> change evtloglvl Proposal Detail =5 for conp Docserver
srvrngr> change evtlogl vl PresentationDebug=5 for conp Docserver
srvrngr> change evtl ogl vl PresentationDetail =5 for conp DocServer
srvrngr> change evtl ogl vl DocServer Debug=5 for conp DocServer
srvrngr> change evtlogl vl DocServerDetail =5 for conp DocServer
srvrngr> change evtl ogl vl CorrespbDebug=5 for conp DocServer
srvrngr> change evtloglvl CorrespDetail =5 for conp DocServer
srvrngr> change evtl ogl vl MSProj ect Debug=5 for conp DocServer
srvrngr> change evtloglvl "M ProjectDetail"=5 for conp DocServer

For more information about event logging, see Siebel Server Administration Guide.
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About Working with Correspondence Templates

Siebel correspondence templates are created and edited in Microsoft Word (DOC file
format). Templates contain fixed text and one or more merge field. The merge fields
are placeholders that will be populated with variable information from your Siebel
database, such as a Contact’s name and address, when users generate a
correspondence for one or more recipients.

Users can create their own personal templates, and administrators can create
templates for users. To modify or add a template, Microsoft Word must be installed
on your computer.

The fixed text of each correspondence template is written using specific locale
conventions and language. In order to support Global Deployment, the author of the
template can explicitly indicate the locale and language using the Locale and
Language fields in the template record. The Document Server then uses these
settings to substitute correctly localized data into the mailmerge fields of the
template. The following types of fields are affected:

= MLOV fields
»  Global data fields
m Locale-sensitive fields, such as dates and currencies

The data source for Word merge fields that are available to be included in Siebel
correspondence templates is in the Siebel.html file. Administrators can augment the
set of merge fields available using Siebel Tools. For information, see “Configuring
Additional Merge Fields” on page 325.

Guidelines for working with correspondence templates include the following:

= One correspondence must be generated before the Siebel.html file will appear
for the first time. In most cases, the first generated correspondence template will
be one of the Siebel sample templates. Once the Siebel.html file appears, you can
use it to create custom templates.

= A template must contain at least one merge field in order to generate a
correspondence.

m Each time a user clicks Generate or Generate Label, the Siebel.html file is
overwritten.
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Each time a user clicks Generate or Generate Label, the variable data in the data
file replaces the merge fields in the Siebel.html file, based on the template format
chosen, and a customized correspondence document is created for each
recipient on the list.

Check the status of the document or label by clicking the Update button and
reviewing the Document Status field. See Table 23.

Table 23. Document Status Field

Status Meaning

In Queue Request sent to available document server.

Generating Document server is creating the Word merge document.
Completed Document is available and can be accessed from the Generated

Document field.

Failed Document server encountered errors. Check the Document Error and
Label Error fields for error messages.

It is recommended that you make the template inactive prior to modifying it. You
make the template inactive by deselecting the Active field. This will prevent
other users from attempting to create correspondences using this template at the
same time you are modifying it. After you have finished your modifications,
check the Active field again.

The Siebel.html file is located in the Reports subdirectory on the Siebel Server.

NOTE: You should always perform system administration tasks, such as
administration of correspondence templates, against the server database. Although
you can perform these tasks against your local database and synchronize, doing so
has the potential to cause errors, including data conflicts. In addition, performance
problems can result from a large local database, and from routing large numbers of
transactions.

For information about which versions of Microsoft Word are supported, see Release
Notes and Siebel System Requirements and Supported Platforms for your Siebel
application.
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Using the Sample Correspondence Templates

You should change the text in the sample correspondence templates packaged with
Siebel Correspondence to add text that is specific to your company and business.

You may want to change both the text and the merge fields of these sample
correspondence templates.

Changing the Text of a Correspondence File

If you only want to modify the text of a correspondence template, you can simply
drill down on the template link in Siebel Correspondence to open it and then edit it
in Microsoft Word.

NOTE: Be careful not to change the merge fields when you edit the text.

To change the text of a correspondence template file

1
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From the application-level menu, choose View > Site Map > Document
Administration > Correspondence Template.

In the Templates list, drill down on the Template Name hyperlink.

A dialog box appears asking whether you want to open the file or download it.
Select Open this file from its current location, and click OK.

The template file appears in Microsoft Word.

Edit the text using Microsoft Word.

Choose File and then click Save to save the changes when you are finished.

In the template list, click the icon appearing in the Template Name field.

Click Browse.

Navigate to the saved template and select the file.

In the Add Attachment dialog box, click Add.
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Changing the Merge Fields of a Correspondence Template File
The easiest way to change the merge fields in a correspondence template file is to
use the Mail Merge feature of Microsoft Word together with the Siebel.html file
generated by the Document Server. The siebel.html file contains the names of the
fields that are available for merging. After Microsoft Word reads this file, the fields
can be selected from a drop-down menu.

To change the merge fields of a correspondence template

1

5

In the Correspondence Template list applet, drill down on the Template Name
field and select the template you want to modify.

In the displayed dialog box, select Open this file from its current location and
click OK.

The template file appears in Microsoft Word.

Add merge fields to the template file. (See either “To add merge fields to the
template in Microsoft Word 2000 or “To add merge fields to the template in
Office XP.”)

In the template list, click the icon appearing in the Template Name field of the
template you are modifying.

Use the Add Attachment dialog box to upload the modified template file.

To add merge fields to the template in Microsoft Word 2000

1

In Microsoft Word, choose Tools, and then Mail Merge.
The Microsoft Word Mail Merge Helper window appears.

In the Mail Merge Helper window under the Main Document heading, click the
Create button and choose Form Letters.

In the dialog box that appears, click the Active Window button.

In the Mail Merge Helper window under the Data Source heading, click the Get
Data button and choose Open Data Source.
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In the Open Data Source dialog box, locate and open the
\Siebel\Reports\Siebel.html file.

NOTE: The Siebel.html appears only after the first correspondence template is
generated.

Click the Close button to dismiss the Mail Merge Helper window.

If the template file does not yet have merge fields, an information box states this.
Click Edit Main Document in the box.

If the template file already contains merge fields, no box appears. Click the Close
button to close the window.

When you are finished adding merge fields, click the Mail Merge Helper icon on
the Mail Merge Tool bar. In the Mail Merge Helper window, click Create and
choose Restore to Normal Word Document. Click Yes to continue.

Close the Mail Merge Helper window.
Choose File > Save As and save the file on your hard drive, with a new name.
Close Microsoft Word.

In the template list, click the icon in the Template Name field of the template
you are modifying.

Use the Add Attachment dialog box to upload the modified template file.

To add merge fields to the template in Office XP

1
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In Microsoft Word, choose Tools > Letter and Mailings > Show Mail Merge Tool
bar.

In the tool bar, click Main Document Setup.
In the Main Document Type window, select Letters and click OK.
On the Mail Merge Tool bar, click the Open Data Source icon.

In the Select Data Source window, locate and open the
\Siebel\Reports\Siebel.html file.
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In the Select Table window, click OK.

Edit the text and add merge fields. For each merge field, position the insertion
point at the desired location in the template, click the Insert Merge Fields icon,
and choose the merge field from the menu.

When you have finished adding merge fields, click the Main document setup
icon on the Mail Merge tool bar.

In the Main Document Type window, select Normal Word Document and click
OK.

Choose File > Save As and save the file on your hard drive with a new name.
Close Microsoft Word.

In the template list, click the icon in the Template Name field of the template
you are modifying.

Use the Add Attachment dialog box to upload the modified template file.
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Creating a New Correspondence Template

To add a correspondence template, it is easiest to modify and rename an existing
template. The following three procedures step you through this process, in which
you:

= Open an existing template file.
= Modify and rename the template in Microsoft Word.

=  Add a template record for the new file in Siebel Correspondence.

NOTE: You may create a new correspondence template for a variety of purposes: for
a company description, as a mailing label, and so on.

Opening an Existing Template File
To prepare to create a new template, you must drill down on the template link in
Siebel Correspondence to open an existing template file.

To open an existing template file

1 From the application-level menu, choose View > Site Map > Document
Administration > Correspondence Templates.

2 In the Templates list, drill down on the Template Name hyperlink.
A dialog box appears asking whether you want to open the file or download it.
3 Select Open this file from its current location, and click OK.

The template file appears in Microsoft Word.

Modifying and Renaming the Template

Now that the file has been displayed in Microsoft Word, you use Word’s mail merge
features to modify its merge fields and then save it under a different name. To
modify merge fields, see “Changing the Merge Fields of a Correspondence Template
File.”
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Adding a Correspondence Template Record for the New File

Once you have created a new correspondence template in Word, you need to add a
record in your Siebel application so your users can access the Word file as a
template. Users will see the template in the Template field in the My
Correspondence Requests view.

To add a template record

1
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From the application-level menu, choose View > Site Map > Document
Administration > Correspondence Templates.

In the Templates list, create a new record and complete the necessary fields.

Some fields are described in the following table.

Field

Comments

Active

Update File

Comments

Local

Modified

Template
Name
Personal

Download File

Size

Indicates whether or not the template appears in the Template list in
the My Correspondence Requests view.

A check mark in this field indicates that users want their copy of the
template to be updated automatically each time the original file is
updated.

A description, and information about the template.

Indicates whether or not the template is available on the local hard
disk. If a document is not available locally, you can request it by
selecting the Request field. The file will be downloaded in your next
synchronization session. This field applies to you only if you use
Siebel Remote.

The date that the template file was last modified.

The name of the file. Required.

A check mark in this field specifies that the template will appear in
the Personal Template view.

Allows users to request templates from the server. When a check
mark appears in this field, the document is retrieved during the next
synchronization session. This field applies to you only if you use
Siebel Remote.

The size of the template file.

Version 7.5, Rev. C



Correspondence

Version 7.5, Rev. C

Creating a New Correspondence Template

Field Comments

Type The file type of the template file.

Language The language used by the Document Server to render mail merge
fields based on MLOV and Global Data Business Component fields.
For more information on these types of fields, see Siebel Tools
Reference.

Locale The locale used by the Document Server to render mail merge fields

based on locale-sensitive business component fields, such as dates
and currencies. For more information on these types of fields, see
Siebel Tools Reference.
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Deleting a Template

If a template is no longer valid, you may want to delete it so that no one uses it by
mistake.

To delete a template

1 From the application-level menu, choose View > Site Map > Document
Administration > Correspondence Templates.

2 In the Templates list, select the template to be deleted.
Click the menu button, and then click Delete Record.

4 When the “Are you sure you want to delete the current record?” prompt appears,
click OK.

The Templates List refreshes and appears without the deleted template.
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Inserting Files into Correspondence Templates

The Siebel Correspondence file insertion feature allows you to insert one or more
files into a correspondence template.

You may insert file templates containing generic content into one or many
correspondence templates. For example, you can create a company description in a
separate file insert template and then include it into correspondence templates. If
the description changes, you only have to modify the single insertion template
instead of every template.

The administrator or user may add a comment indicating that the file is an insert
template that should be used by mail merge and inserted into other documents.

You may insert as many files into a correspondence template as necessary. Each file
name must be unique.

Each file must be inserted into the correspondence template independently.
Insertion files can not be nested. For example, you may insert Filel.doc, File2.doc,
and File3.doc into a template named FollowUp.doc. But, you may not insert
Filel.doc into File2.doc, and then insert File2.doc into FollowUp.doc.

You may insert a file template into a public template created by an administrator or
a personal template created by a user. Only Microsoft Word files are inserted into
Microsoft Office templates. This process is described below.

To insert a file into a correspondence template
1 Create the file insert template.
a Using Microsoft Word, create the insert template.

b Under the Document Administration Screen, the Correspondence Templates
view, add a new record and add the new insert template.

2 Open the Correspondence Template in which the new template file is to be
included.

3 Insert a separate line with the following command at the location where the
insert template is to be displayed:
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[[File Name]]

Here, File Name is the name of the file created in Step 1.

4 Save the Correspondence Template locally and then reload the template back
into the Correspondence Template View.

At run time, the new insert template will merge with the Edited Correspondence
Template.
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Configuring Additional Merge Fields

During the document generation process, the Document server exports mail merge
data into the Siebel.html file. Microsoft Word then reads this file and inserts the data
into the merge fields in the template. The exported data is taken from two places:

» If the correspondence was created from a view based on service requests (such
as the Service Request screen in Siebel Sales or the Service screen in Siebel Call
Center), the data is taken from the Service Request Recipient business
component.

m If the correspondence was created by pressing the New button in the
Correspondence list view, or from a view not based on service requests (such as
the Opportunity screen), the data is taken from the Recipients business
component.

New fields in the Recipients Business Component are restricted to those based on
columns in the S_CONTACT table or those obtained through join relationships.
Joins can be added for tables that have a master-detail relationship with
S_CONTACT, where S_CONTACT is the detail table. You need to add the join to the
Recipients Business Component if it does not already exist.

New fields in the Service Request Recipient Business Component are restricted to
those based on columns in the S_ CONTACT table, the S_SRV_REQ table, or columns
available through joins to these tables.
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Table 24 summarizes the contents of the two Business components and the contexts
in which they are used. For more information on adding fields, see Developing and
Deploying Siebel eBusiness Applications and Siebel Tools Reference.

Table 24. Summary of Merge Fields Sources and Uses

Source Business Component Source Tables Used In
Recipients »  S_CONTACT Correspondence created:
» Joins with tables that have a » Directly in the Correspondence List
master-detail relationship with View
S_CONTACT (with S_CONTACT . .
; = From any view not based on service
as the detail table).
requests
Service Request Recipient = S_CONTACT Correspondence created from views
« S_SRV REQ based on service requests.

» Joins with tables that have a
master-detail relationship with
one of these two (with
S_CONTACT or S_SRV_REQ as
the detail table).

To configure an additional merge field

1 Open Siebel Tools.

2 Add the new field to either the Recipients Business Component or the Service
Request Recipient Business component. The steps for this depend on the field
type you are adding. For more information on adding fields, see Developing and
Deploying Siebel eBusiness Applications and Siebel Tools Reference.

3 Add the name of the new field to the Business Component User Prop called
“Export Field #”, where # is an integer. If necessary, create additional user
properties by incrementing the integer.

4 Compile the project to create a new .srf file.

5 Stop the server.
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6 Copy the newly compiled .srf file to the correct location where it will be used by
the server (usually \siebel\objects\lang, where lang is the language code for the
language setting of the server).

7 Restart the server.
8 Generate a new correspondence document to refresh the siebel.html file.

9 To insert fields into a template, see “Changing the Merge Fields of a
Correspondence Template File.”

NOTE: You can configure up to 63 additional merge fields; WinWord does not display
fields beyond this limit.
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About Fulfillment Centers

When your users have completed correspondence and want to send it to the
recipient, either they can print out and mail the letter themselves, or they can direct
their correspondence to a fulfillment center that prints and mails it for them. A
fulfillment center might be a division of your company, such as your marketing
department.

You might want to use a fulfillment center for several reasons:

m To let your users produce correspondence in any location where they can access
the Internet, even if they do not have a printer.

m To save your users time, since they do not have to print out and mail their
correspondence.

= To create consistency in your company’s outgoing correspondence.

m To allow one location to fulfill all requests for collateral and literature materials
included with correspondence as enclosures.

If you have set up fulfillment centers, the user can generate correspondence and
then click Submit to submit the correspondence for fulfillment. When the user
clicks Submit, the Status Field of the correspondence request is given the value
Submitted, and the request is made read-only. You cannot make any further changes
in it without using the Recall command.
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Setting Up Fulfillment Centers

To set up a fulfillment center, you perform the following tasks:
= Add a fulfillment center record.

= Give the fulfillment center access to Siebel Correspondence.

Adding, Modifying, and Deleting Fulfillment Center Records
You must create one or more fulfillment center records, so users can select a
fulfillment center when they create a correspondence request.

To add a fulfillment center

1 From the application-level menu, choose View > Site Map > Data
Administration > Fulfillment Centers.

2 In the Fulfillment Centers list, click the New button.

3 Enter the information described in the following table.

Field Description

Name Enter the name of the fulfillment center.

Main Phone # Enter the telephone of the fulfillment center.
Main Fax # Enter the fax number of the fulfillment center.

Fulfillment Team  Click the select button, and use the Fulfillment Team dialog box to
select one or more employees at the fulfillment center. If necessary,
click New to add employees to this dialog box. After you have
selected the employees, click Close.

These people will be able to view correspondence submitted to
this fulfillment center. If there is no one on a fulfillment team, no
one will be able to see correspondence submitted to this
fulfillment center.

Description Enter a description of the fulfillment center.
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To make other changes
= To modify a fulfillment center record, select a field and change the information.

m To delete a fulfillment center record, select the record, click the menu icon, and
then click Delete Record.

Giving the Fulfillment Center Access to Siebel Correspondence
The fulfillment team at the fulfillment center must monitor pending fulfillment
requests. Everything submitted by a requestor is visible to the fulfillment team in
the Fulfillment screen.

Fulfillment center employees fulfill the request by viewing and printing the
correspondence request and including the enclosures listed. The fulfillment center
employees may either print the enclosure, or get an already-printed copy (if the
enclosure is a glossy brochure, for instance).

If you have licensed Siebel Workflow, you can create a workflow to send email to
the fulfillment center automatically whenever there is a new request for it to fulfill.

To give the fulfillment center access to Siebel Correspondence

1 Set up fulfillment center employees as Siebel Correspondence users, in the same
way that you set up your own employees or your channel partners as Siebel
Correspondence users. For more information about setting up users of Siebel
applications, see Security Guide for Siebel eBusiness Applications.

2 Give fulfillment center employees a responsibility that lets them see the
Fulfillment screen. Use the responsibility in the seed data named Fulfillment
Center Employee. For more information about responsibilities, see Chapter 2,
“Initial Setup.”

3 Tell fulfillment center employees what URL they should use to view
Correspondence through the Internet.
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About Monitoring Fulfiliment

After they have processed a request, the fulfillment center employees click Done.
Clicking Done updates the Status Field of the request to Done, and it creates an
activity for each recipient indicating that correspondence has been sent.

Users monitor the status of their correspondence requests by looking at the entry in
the Status column of the My Correspondence Requests view to see if the status is
Done.

Similarly, a fulfillment center manager monitors the status of pending requests by
looking at the entry in the Status column of records in the Fulfillment screen.
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About Batch Printing

Batch printing simplifies the task of printing multiple correspondence items. The
user first selects one or more Correspondence items, and then selects the Print
option from the applet level menu. The documents are then printed on the
appropriate printer.

Siebel applications support two types of batch printing, server-based and client
based. Initially, the print menu item appearing on the Correspondence and
Fulfillment screens is configured to perform client-based printing. However, the
Administrator can use Siebel Tools to reconfigure these menus to use server-based
batch printing, either in addition to, or instead of, client-based batch printing.

Client-Based Batch Printing

When a user prints a document using client-based batch printing, the Siebel
application launches Microsoft Word on the user’s client system. It then retrieves
the document from the Siebel File System and prints it to the default printer
configured for the user’s desktop session.

For this feature to work correctly, the end user must configure the browser to allow
the Siebel application to launch Microsoft Word. This requires changing the security
option called “Initialize and script ActiveX controls not marked safe” to either
Enable or Prompt for the security zone containing the Siebel application URL.
Typically, this is either the “Local intranet” zone or the “Trusted” zone. Users should
verify that any other URL in this zone can be trusted with this security privilege.

Server-Based Batch Printing

When a user prints a document using server-based batch printing, a request is sent
to the DocServer server component. This component then prints the document to
the printer specified by the user in User Preferences. If the user has not specified a
preference, the document is printed on the default printer configured on the
DocServer machine by the System Administrator.
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Setting Up Batch Printing for Administrators and Users

Table 25 lists procedures for setting up batch printing for both administrators and
users. Administrators need to set up server-based batch printing; users need to set
up both server-based and client-based batch printing.

Table 25. Procedures for Setting Up Batch Printing

Setup Procedures for Administrators Setup Procedures for Users

Add server Print menu items on the Verify system requirements for client-based
Correspondence and Fulfillment screens batch printing

Set up the printer configuration Configure Internet Explorer to permit client-

based batch printing

Add a printer connection to the DocServer = Add a printer connection to the desktop for
machine client-based batch printing

Change the default printer (if necessary) Change the default printer (if necessary)

Specify a printer for server-based batch
printing
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Batch Printing Instructions for the Administrator

As an administrator, you need to set up the server-based batch printing function.

To add server Print menu items on the Correspondence and Fulfillment screens

1
2
3

10
11

12

Start Siebel Tools.
In the Object Explorer window, under Siebel Objects, select Applet.

In the Applets window on the right, enter “Correspondence List Applet” in the
Name column and click Query.

In the Object Explorer, select Applet Method Menu Item.

In the Applet Method Menu Item window, enter “Server Printer” in the Menu
Text column and click Query.

Highlight the record and uncheck the Inactive check box in the Inactive column.

In the Applet Method Menu Item window, enter “Server Print Label” in the
Menu Text column and click Query.

Highlight the record, and deselect the Inactive check box in the Inactive column.

In the Application menu, click Tools and select Compile Projects. In the Project
Selection window, pick project “Corresp (SSE)”.

Browse and select the appropriate siebel.srf file, and click Compile.

Repeat Step 3 to Step 10 for the Fulfillment screen, querying for “Fulfillment List
Applet” in the Applet window.

Verify that “Server Printer” and “Server Print Label” menu items appear in the
applet menus of the Correspondence and Fulfillment screens.
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Configuring Printers for Server-Based Batch Printing

When a user invokes server-based batch printing on a correspondence document,
a request is sent to the DocServer component. This request contains the values for
the Default Printer and Printer Driver preferences the user has selected on the
Correspondence User Preference screen. After receiving the request, DocServer uses
Microsoft Word to convert the document into a PostScript file. The style of
PostScript generated is determined by the value for the Printer Driver user
preference. This parameter specifies the name of a network printer. The PostScript
file generated by Microsoft Word is suitable for this printer and all other printers of
the same model. After the PostScript file is generated, DocServer sends the file to
the printer specified in the Default Printer user preference.

As an administrator, you need to complete the following tasks to support server-
based batch printing.

1 Identify the printer models within your enterprise that will be used for server-
based batch printing.

2 For each model, select one network printer and add a printer connection to it on
the DocServer machine.

3 Designate one configured printer as the default printer for the DocServer
machine.

4 Provide the list of configured printers to end users, who will use this list to select
a Printer Driver in User Preferences.

For example, an organization has five Xerox Model A printers, named xrx001 to
xrx005, and five Canon Model B printers, named cnn001 to cnn005. A printer server
named hqgsrvr is used to route requests to all of the printers. The administrator
decides to use xrx005 to represent the Xerox Model A printers and c¢cnn005 to
represent the Canon Model B printers, then adds printer connections on the
DocServer machine for each. The xrx005 printer is chosen as the default printer.
These connections are used by the DocServer component to generate PostScript
files. Only one printer for each model is actually configured on the DocServer
machine. After creating the printer connections, the administrator notifies the end
users of the network names of the configured printers (in this case: \\hgsrvr\xrx005
and \\hgsrvr\cnn005).
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Continuing the example, a user now wants the cnn003 printer for her personal batch
printing requests. To do this, she goes to the User Preference Screen,
Correspondence View and enters \\hgsrvr\cnn003 in the Default Printer field and
\\hgsrvr\cnn005 in the Printer Driver field. All subsequent batch printing requests
she submits are sent to the cnn003 printer.

If a user does not specify a User Preference, batch printing requests submitted by
that user are sent to the default printer configured by the administrator on the
DocServer machine.

To add a printer connection to the DocServer machine

1 Login to the DocServer machine using the same User ID used by the Windows
Service running the Siebel Server.

Select Start > Settings > Printers.
Double click the Add Printer icon.

On the Welcome screen, click Next.

2
3
4
5 On the Local or Network Printer screen, select Network Printer and click Next.
6 On the Locate Your Printer screen, select Network Printer and click Next.

7 On the Default Printer screen, select either Yes or No and click Next.

8

Click Finish.

To change the default printer

1 Login to the docServer machine using the same User ID as used by the Windows
Service running the Siebel Server.

2 Navigate to Start Menu > Settings > Printers.

3 In the printer list, right click on the desired printer and choose Set as Default.
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Batch Printing Instructions for the End User

To batch print, you select correspondence items and then select the Print option
from the applet menu. The Print menu item is active only if all selected
correspondence records have a value of Completed in the Document Status column.

Initially the Print menu item on the Correspondence and Fulfillment screens is
configured to perform client-based printing. However, your administrator can
configure server-based printing in addition to, or instead of, client-based printing.

Using Client-Based Batch Printing

When you use client-based batch printing, the Siebel application launches
Microsoft Word on your client system. It retrieves the document from the Siebel File
System and prints it to the default printer configured for your desktop session. To
use this feature, you need the following:

m  Microsoft Word must be installed on the client system.

= Internet Explorer must be configured to launch Microsoft Word.
s The default printer must be configured for your desktop.

To configure Internet Explorer to allow client-based batch printing
1 Start Internet Explorer and log on to the Siebel application.

2 In the Internet Explorer, select Tools > Internet Options.

3 Select the Security Tab. The security zone used by Siebel applications is
highlighted (either Local intranet or Trusted). Verify that any other URL in this
zone can be trusted with extra security privileges.

4 Select Custom Level.

5 In the Security Settings dialog box, find “Initialize and script ActiveX controls
not marked safe.” Change the setting to either Enable or Prompt.

D

Click OK.

7 To the question, “Are you sure you want to change the security for this zone?”
click Yes.
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8 In the Internet Options dialog box, click OK.

To add a printer connection to your desktop

[

Select Start Menu > Settings > Printers.

2 Double-click the Add Printer icon.

3 Click Next on the Welcome screen.

4 On the Local or Network Printer screen, select Network Printer and click Next.
5

On the Locate Your Printer screen, select Type the Printer Name and either type
the network name of the printer, or click Browse and select the printer.

6 Click Next.

7 On the Default Printer screen, choose either Yes, or No. Click Next.
8 On the Completing the Add Printer Wizard screen, click Finish.

To change the default printer

1 Select Start Menu > Settings > Printers.

2 The current default printer is marked with a check. To select a new default
printer, right click on the desired printer and choose Set as Default.

To print documents using client-based printing

1 From the application-level menu, choose View > Site Map > Correspondence
or Fulfillment.

2 Close any Word files.

3 Select one or more rows in the Correspondence List Applet. All selected rows
must have a Document Status of Completed.

4 In the applet menu, select Print.

The selected documents are printed to the configured default printer.
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Using Server-Based Batch Printing

Server-based batch printing sends a printing request to the Siebel Document Server.
The document is then sent to the printer specified in User Preferences. If you do not
specify a printer, the document is printed on the default printer configured by the
System Administrator.

To specify a printer for server-based batch printing

1 From the application-level menu, choose View > Site Map > User Preference
> Correspondence.

2 In the Default Printer field, enter the network name of the printer used for
Correspondence. The network name should contain both the printer server
name and the printer name as follows:

\\printer_server_name\printer_name

3 In the Printer Driver field, enter the name of the printer driver used to generate
an intermediate file during the printing process. The System Administrator
should provide you with a list of printer drivers and their associated printer
types. Select the Printer Driver associated with the printer you previously
specified in Step 2.

4 Click Save.

To print documents using server-based printing

1 From the application-level menu, choose View > Site Map > Correspondence
or Fulfillment.

2 Select one or more rows in the Correspondence List Applet. All selected rows
must have a Document Status of Completed.

3 In the applet menu, select Print.

The selected documents are printed to the default printer specified in User
Preferences.
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Siebel Presentations allows your sales representatives to create presentations (and
other types of documents) based on templates that you create in Microsoft
PowerPoint.

Traditionally, salespeople create presentations by starting with a presentation that
worked in the past and then modifying it for the current prospect. Salespeople must
not only change such basic information as the customer’s name, but also possibly
restructure the presentation so that it fits this new prospect’s unique needs. For
example, the original presentation may have been focused on price, whereas the
new prospect is more concerned with other decision criteria, such as speed or extra
functionality.

With Siebel Presentations, once the presentation administrator has created the right
templates, the salesperson can click one button to build the correct presentation for
a specific account or opportunity. Siebel Presentations uses information that
salespersons have entered in the early stages of an opportunity to create the
presentation.

Salespeople can add deal-specific information to the presentation without worrying
about formatting or presentation. Using the Presentation Library, salespeople can
find any additional information and automatically insert it into the presentation.
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System Requirements for the Siebel Web Client

To use Siebel Presentations, you must have:

m  All of the components that are required to run Siebel 7.5, including a Siebel
Server and a Web Server

m  The Document Server installed on one or more Windows machines

m  Microsoft Office

NOTE: If you are deploying the Siebel Server in UNIX and want to use Presentations,
a separate Windows machine is required for the Document Server.

Siebel Presentations uses the Document Server, which is a component of the Siebel
Server which lets users on the Web work with Word, and PowerPoint documents on
the server.

For more information on installing the components required to use Siebel 7.5
software, see Siebel Server Installation Guide for the operating system you are using.

Your employees or partners who use Siebel Presentations need:
= A Web browser to use the product
»  Optionally, Microsoft Office to edit documents

For information on the Web browsers that are supported by Siebel applications, see
Siebel System Requirements and Supported Platforms.

System Requirements for the Siebel Remote Web Client

Siebel Presentations is available for the Siebel Remote Web Client as well as for the
Siebel Web Client. The user interface for Presentations is identical in the Siebel
Remote Web Client and the Siebel Web Client.

However the Siebel Remote Web Client processes requests to generate documents
locally, so field sales representatives can generate correspondences, proposals, and
presentations when they are out of the office.

To run Siebel Presentations on the Siebel Remote Web Client, you must have
Microsoft Office installed on the same machine as the Siebel Remote Web Client.
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Setting Up the Document Server

Siebel Correspondence, Siebel Presentations, and Siebel Proposals all use the Siebel
Document Server to generate Microsoft Word and Microsoft PowerPoint documents
through the Web.

After installing your Siebel applications, you have to enable the Document Server.

For more information, see “Installing the Document Server” on page 305.
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The Process of Creating Templates
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To create templates, you go through the following stages (shown in Figure 15):

Create Add Create
Presentation * Template * Presentation
Slides Record Structure
J
Add Define Frepare
Components » Presentation Field »  Presentation
to Sections Mappings Library

Figure 15. Siebel Presentation Process Flow

Create Microsoft PowerPoint slides. To create the slides needed by the template,
you must write their content and insert bookmarks for such variables as
company, contact name, address.

Add a template record. Use your Siebel application to create a single record for the
template.

Create the presentation structure. Specify which sections the presentation should
contain.

Add components to the sections. Specify which components each section should
contain.

Use conditions in sections or components. Optionally, you can add conditions to
specify that sections or components are included in the presentation only under
certain circumstances.

Define presentation field mappings. Specify which Siebel objects correspond to
each bookmark in your PowerPoint component slides. You also specify the name
of this mapping in the template record.

Prepare the Presentation Library. In this optional step, which can be done at any
time, you create a separate library of slides that salespeople can draw upon to
customize their presentations.
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Creating Template Slides in Microsoft PowerPoint

The first step is to create slides in Microsoft PowerPoint. These slides consist of one
style slide and multiple component slides, as shown in Figure 16.

Title Page and
Background Slide

/ Header
Formats
Logo Footer
Companent
Slides
g B h
e S N I —— Benefit 1 Us Them
Feature¥ | | = ==emeeeee Benafit 2
Feature Z | | = =meeeeee Benefit 3
Product Description Corporate ; Cornpetitive

Slides Owerview Slides Benefit Slides Landscape

Figure 16. PowerPoint Slides That Can Make Up a Presentation Template

Version 7.5, Rev. C Applications Administration Guide 345



‘ Presentations

Creating Template Slides in Microsoft PowerPoint

The components shown in Figure 16 on page 345 are only examples. You could
have other components, such as a table of contents or a set of collateral, and you
could omit the quotes or product descriptions. However, a template must have a
presentation background slide and one or more component slides.

NOTE: See Release Notes for information about which versions of Microsoft
PowerPoint are supported.

NOTE: Presentations can only use fields from one business object. If you want to
include additional fields, you must use Siebel Tools to add the Business
Components that include these fields to the Business Object that is the basis of the
presentation.

To create the template slides, you go through the following stages:
= Planning the template. Decide what components the template should have.

= Creating the style slide. Create the slide that gives all the template components a
standard formatting.

m Creating the component slides. Create a slide for each component of the template.

Planning the Template

Before you create the slides in PowerPoint, you must determine how the
presentation should look and what type of information it should contain. Begin by
looking at previous successful presentations to see what sections they contained.
For example, did they all contain an agenda, a executive overview slide, and a
product summary slide? Next, look to see what current slides you have on hand,
and what customer questions these pieces answer. Then decide how to organize
your information. What topics could be standard across all presentations? What
topics are specific to certain presentations? What is the best order for the pieces in
the presentation you are creating? Finally, decide what fields to insert to customize
their presentations (for example, contact name, account name, industry). You will
use this information to create bookmarks in your PowerPoint slides.
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Creating a Presentation Background Slide

After you plan your templates, work on the presentation background slide for this
template, which is the slide that serves as your title slide and also specifies the
background layout and formatting of the entire presentation. This background slide
may contain your company logo, special colors and background designs, and
headers and footers.

To set up styles for your template

1
2

Version 7.5, Rev. C

Create a new slide in Microsoft PowerPoint.

Since this slide will also serve as your title slide, you may want to select the title
slide layout template and enter the title of the presentation.

Select the background colors and font size.

Choose View > Header and Footer, and create and apply a header and a footer
for your template.

Switch to the Master Slide view, and select formatting options that will apply to
your whole presentation.

Close the Master Slide view, and return to the Slide view (choose View > Slide).
Save the file:

= Choose a name that uses only alphanumeric characters.

= Use the .ppt extension for PowerPoint.

Close the file.
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Creating Components
The next step in developing your template is to create components, the slides that
make up the body of your presentation.

A component is the Siebel Presentations term for a Microsoft PowerPoint that
includes standard text and personalized data.

To create a component, you type the standard text and then create bookmarks, or
Microsoft PowerPoint placeholders for custom data. When a salesperson generates
a presentation, these bookmarks will be replaced with data from the Siebel
application.

To create a component with bookmarks

NOTE: This procedure may vary slightly, depending on your version of Microsoft
Word.

1 Create a new slide in Microsoft PowerPoint.

2 Type the standard text, pictures, bulleted information, and so on that belongs in
this component.

3 Place the cursor where you want to create a bookmark.

4 Enter the following text:
[[“name of bookmark”]]
For example, to create a bookmark for the company name, type:
[ [ Conmpany] ]

5 Write down the name of the bookmark, because you will need it later when you
map the bookmark to a Siebel field names.

6 Repeat Step 3 through Step 5 for every bookmark you want to insert.

NOTE: If the same field is being inserted in several places, you can copy its
bookmark and paste it into other parts of the document.

7 Save the component slide as a .ppt file.
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Creating a Record for the Template

After you have created your template slides in PowerPoint, you can use Siebel
Presentations to specify how they are assembled in the template.

To create a record for the template

1 From the application-level menu, choose View > Site Map > Document
Administration > Presentation Templates.

2 In the Templates list, add a new record and complete the fields.

Some fields are described in the following table.

Field

Comment

Name

Default

Category

Mapping Name

Template File
Name

Enter a name for the template.

If you want this template to be the default presentation template,
place a check mark in the Default field. When the user clicks Auto
Presentation, Siebel Presentations uses the default template if there
are no decision issues that match the theme of a presentation. You
can only select one Opportunity Presentation default and one
Account Presentation default.

Select one of the following types of templates:

= Opportunity Presentation templates are available only when you
are working with Opportunities.

= Account Presentation templates are available only when you are
working with Accounts.

Used to indicate the group of bookmark fields to be used with this
template. You can leave this field blank for now, until you create a

mapping.
Attach the template file.
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Field Comment

Theme If you want to associate the template with a particular decision issue,
click the Decision Issue list in the Theme field, and select a theme
from the Decision Issue dialog box. When you give your presentation
template a theme, you associate it with a particular decision issue
that is important for your opportunity. When a presentation theme
matches the number one decision issue for the current opportunity,
Siebel Presentations automatically selects the correct template when
the user clicks Auto Presentation. Users can also select a theme
template if they want.

Because accounts do not relate to decision issues, the Theme field is
not applicable for Account Presentation templates. It only applies to
Opportunity Presentation templates.

Description Enter a description of the template.
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About Creating the Template Structure

Once you have created your PowerPoint slides and a record for your template,
define the structure of your presentation template.

A presentation is made up of sections, which divide and subdivide your
presentation. Depending on your needs, a single section might contain multiple
components or a single component.

The type of a section depends on what type of data it contains. For example, file
sections contain slides, chart sections reference Siebel charts, and so on.
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Defining Template Sections

You define the structure of the presentation template by creating sections in the
Presentation Template Administration view, which are associated with the Template
record you created for this template. You must create top-level sections, and you can
add subsections to these top-level sections. Your presentation structure can have
multiple levels of sections, since a subsection can contain other subsections.

Creating Top-Level Sections
First, you must create top-level sections.

To create top-level sections

1

From the application-level menu, choose View > Site Map > Document
Administration > Presentation Templates.

In the Template Explorer, in the left frame, click the + icon next to the icon
representing this template.

The Sections folder appears in the list.

In the Explorer list, click the + icon next to the Sections folder.

The Sections list appears in the right frame.

In the Sections list, add a new record.

In the Name field, enter a name for this section.

The Section name is the title of the slide for some types, such as Bullet Slide.

In the Sequence field, specify the order in which this section should appear in
the presentation.
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7 In the Section Type field, indicate the type of section you are creating. The
following table describes the different section types available to you.

Type

Comments

File

Chart

Bullet Slide

Locator

Organization Chart

Table

Two-column Slide

Contains only presentation slides or text. If you are using
PowerPoint, they must be in PPT, DOC, or TXT format. If you
indicate text, it creates a slide and inserts the text.

Creates a slide and inserts a Siebel chart. The chart is
automatically centered, and you can change X, y, and z axes.

Creates a slide and inserts a list of Siebel data in bullet format—
for example, a list of products the opportunity is interested in.

This section name is used as the slide title.

Pulls in slides or text (PPT slides or TXT files) from the Siebel
Encyclopedia. For example, if you create a locator section, Siebel
Presentations can dynamically pull in slides from the marketing
encyclopedia that relate to the products the opportunity is
interested in. For example, if you want the presentation to
dynamically insert slides related to the products on the
opportunity, use a Locator.

The file types must be PPT, TXT, or RTF. If more than one
marketing slide meets the Locator criteria you specify, Siebel
Presentations inserts each.

Creates a slide and pulls in Organization charts for the Account
or Opportunity associated with the template. Charts are
automatically centered.

Creates a slide and pulls Siebel data into a table format. You
select fields to be included, the sequence of the fields, and the
column length. Tables are automatically centered. By selecting a
Table Section, you also enable creation of a Related Table section.
See “Adding Related Table Subsections” on page 359.

Creates a slide that puts two sections next to each other. You can,
for example, show a list of key features of a product (a Bullet
Slide section) next to a picture of the product (a File section). You
specify the two subsections, which can be any of the other
section types.
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8 Complete the fields applicable to your section type. Table 26 on page 355
describes the fields that you should complete for each type of section.

9 Repeat Step 4 on page 352 through Step 8 to add all the top-level sections that
are needed.
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Table 26. Selected Fields for the Presentation Template Administration View

Section Type

Bullet Slide

File

Chart

Version 7.5, Rev. C

Field

Business Object

N/A

Business Object

Chart or Table

Name

Search Spec

Category

Function

Series

Comments

The Siebel business object from which the information is taken.

Select from the list, which contains all available business objects
from your repository, or enter the name in the field. For example,
to include a Bullet List of products offered with the quantity and
ship date for the opportunity, the business object is Opportunity.

You do not need to complete any fields for this type of section.

The Siebel business object the chart information is coming from
(for example, Opportunity). Select from the Business Object list,
which lists all available business objects from your repository, or
enter the name in the field.

The name of the chart applet you want to insert into this section
(for example, “Opportunity Chart Applet - Current Opportunity
Analysis”). The list also contains all available applets from your
repository.

Any search criteria you want to use to restrict data for the chart
(for example, Revenue > 500000).

With charts that contain multiple X-axis options, this field allows
you to set which option to use for the X-axis. For example, in the
Lead Analysis by Rep chart, the X-axis can be Sales Representative
or Quality.

With charts that contain multiple Y-axis options, this field allows
you to set which option to use for the Y-axis. For example, in the
Lead Analysis by Rep chart, the Y-axis can be Number of
Opportunities, Opportunity Revenue, or Average Opportunity
Revenue.

This field allows you to set the Z-axis you wish to use for charts
that contain multiple Z-axis options.
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Table 26. Selected Fields for the Presentation Template Administration View

Section Type Field

Locator Information
Retrieval Method

Retrieved
Literature
Category

Organization Chart = Business Object

Chart or Table
Name

Comments

Select which relationship to use to find the literature (for example,
Oppty Competitor, which are the slides on competitors associated
with the opportunity).

To associate literature with a product, competitor, or partner, use
the Literature Administration view (or the Decision Issue,
Competitor, or Product Administration views). See Chapter 17,
“Literature” for more information.

Indicate what type of literature you are looking for (for example,
brochures, specification sheets, and so on).

This helps you to filter out the slides from the rest of the
documents in the marketing encyclopedia, to be included in your
presentation.

The Siebel object from which the information is taken. Select from
the picklist, which contains all available business objects from
your repository, or enter the name in the field.

The name of the applet that contains the organization chart data
(for example, the Opportunity Organization Analysis applet).
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Table 26. Selected Fields for the Presentation Template Administration View

Section Type

Table
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Field

Business Object

Chart or Table
Name

Width

Table Fields

Comments

This is the Siebel business object from which the information is
taken. Select from the list, which contains all available business
objects from your repository, or enter the name in the field.

For example, if you want to include a table of products being
offered, with the quantity and ship date for the opportunity, the
business object is Opportunity.

The name of the applet where the table data is stored.

In the example used for Business Object, the applet is Opportunity
Product Applet.

Width represents a percentage of the space available between the
template margins. If you choose 100, that equates to 100% of the
space between the Template margins. If you enter 125, that
represents 125% of the space between the borders.

If left blank, the width of the columns in the table is based on
pixels.

Click the ellipsis button to bring up the Table Fields dialog box;
then, for each field you want in the table, click New and enter the
following information:

»  The Field Name of the field; for example, Product.
= The Sequence in which you want the field listed.

s The Width of the column; the default (and minimum) width is
100 pixels. A second way to define column width is by
percentage of the table width. When a value is entered into
table width, column width equates to percentage of total table
width. For example, if there are three fields and table width is
set to 100, field widths of 25, 65, and 35 would equate to 25 %,
65%, and 35% of the total width of the table. In this example,
if the table width was not set, the field widths would equate to
25, 65, and 35 pixels.

= The Alignment of the data in the field: Left, Center, Right.
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Table 26. Selected Fields for the Presentation Template Administration View

Section Type Field Comments

Two-Column Slide N/A Create two subsections under the section you have designated as
Two-Column Slide. For each subsection, complete the fields
appropriate to that type of section. For example, if you want to
show a Chart section next to a Table section, create a subsection
of the Chart section type (and complete the Chart-related fields
shown in this table) and create a subsection of the Table type (and
complete the Table-related fields shown in this table).
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Adding Subsections
After adding top-level sections, you may want to add subsections to one or more of
them.

To add subsections to an existing section

1 From the application-level menu, choose View > Site Map > Document
Administration > Presentation Templates.

2 In the Template Explorer, in the left frame, click the + icon next to the template
to which you want to add a subsection.

The template’s Sections folder appears.

3 In the Template Explorer, click the + icon next to the Sections folder for this
template.

The Explorer displays the sections for this template, and the Sections list is
displayed to the right.

4 1In the Template Explorer, click the + icon next to the section to which you want
to add a subsection.

The Sections and Components folders appear for this template.
5 Click the + icon next to the Sections folder for this section.
The Sections list appears, listing all subsections under this section.

6 Use the Sections list to add a subsection in the same way you used it to add a
top-level section, as described in “Creating Top-Level Sections” on page 352.

NOTE: When a presentation generates, a section generates before any of its
subsections and is displayed prior to a subsection in the finished presentation.

Adding Related Table Subsections

After adding a Table Name subsection, you can add related tables that provide
detailed information for the first table. For example, if the tables subsection contains
a quote record, the related table can contain the quote line items. The relationship
between the information is essentially a parent-child-grandchild relationship; the
opportunity is the parent record, the quote table is the child, and the related table
containing the quote line items is the grandchild.
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To add a related table

1

N oo a s

From the application-level menu, choose View > Site Map > Document
Administration > Presentation Templates.

In the Template Explorer list, in the left frame, click the + icon next to the
template to which you want to add a related table.

The Sections folder appears in the list.

In the Explorer list, click the + icon next to the Sections folder.
The sections list appears in the right frame.

In the Sections list, add a new section or edit an existing section.
In the Section Type field, select Table and enter the Table Name.
Complete all necessary fields.

In the Explorer list, click the + icon next to the Related Tables folder.

NOTE: The Related Table folder in the Template Explorer is used only for the Table
section type. This folder can be edited only if a table is already added.

In the Related Tables dialog box, complete the fields as described in the
following table.

Field Comments

Business Object Select the Siebel object to which this table is related.
Table Name Select the name of the related table applet.

Field Name Select the fields that will be displayed in this table. If none are
selected, all fields appear.
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Adding Components to Template Sections

Now that you have defined the structure of your document, you must specify the
location of the component slides that will probably make up the bulk of your
presentation.

For sections that draw upon data from a Siebel database (such as Chart and Report),
you have specified all the information necessary for Siebel Presentations to generate
the appropriate contents. However, the component documents, which you created
earlier in PowerPoint, are not part of the presentation until you add them to the
appropriate sections.

NOTE: Components can be added to any kind of section (not just a File section), and
a section can contain multiple components.

Components can be PPT or DOC, TXT, or RTF files. When they are not PPT files,
Siebel Presentations creates a slide (with your template background) and imports
the text into the slide. PowerPoint inserts the .txt and .doc files based on how you
have formatted the documents. For example, PowerPoint inserts TXT or DOC
paragraphs in the slide as paragraphs, but if your file contains TXT or DOC indented
or bulleted paragraphs, PowerPoint attempts to create a slide for each bullet point,
or one slide for all bullet points, depending on the formatting and carriage returns
in your document.

To make sure that TXT or DOC files are inserted correctly in your PowerPoint
presentation, open the text or PowerPoint document itself in PowerPoint and verify
that the format is correct. The format you see when you open the file in PowerPoint
will be the same format Siebel applications use in the presentation.

To add a component to a presentation template

1 From the application-level menu, choose View > Site Map > Document
Administration > Presentation Templates.

2 In the Templates Explorer, in the left frame, select the template to which you
want to add a component.

The Sections and Components folders appear for the template.
3 Click the + icon for the Components folder.

The Components list appears on the right.
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In the Component list, add a new record.
The Add Sales Tools dialog box appears.
In the Add Sales Tools dialog box, perform one of the following actions:
= Select the component you want to add and click Add.
= If your component does not appear in the dialog box, click New.
Enter the component fields, as described below.
When the component appears in the Components list, click the Edit button.

Complete the component fields (described in the following table), and click
Save.

Field Comments

Name Enter a name for the component.

Sequence Specify the order in which this component should appear in the
section.

Attachment Name This field was filled in automatically when you selected a file from
the Add Sales Tool dialog box.

Condition Enter a condition and this component will be displayed only when
the condition is true.
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Using Conditions in Templates

You can add query conditions to a section or a component to specify the conditions
under which the section or component will be used in the presentation. For
example, if you have two executive summaries—one for deals of over $100,000 and
another for smaller deals—you can use the condition field in each Executive
Summary section to allow Siebel Presentations to insert the appropriate executive
summary based on which condition is true.

Entering Criteria

You can enter query criteria in a section or component record’s Condition field
(such as [Revenue] > 100000). If the condition is TRUE, the section or component
is included. If the condition is FALSE, the section of component is not included.

If you do not specify a condition, the section or component is always used.

You can create conditions for any field that relates to the business object of your
presentation; use Opportunity fields for opportunity presentations, and Account
fields for account presentations. If the definition of a condition needs to be based
on fields from another business object, then you must add those fields to the
Opportunity or Account business object through either a link or a join. The syntax
for conditions is similar to the syntax for Siebel queries. For more information about
the syntax of Siebel queries, see Fundamentals and Siebel Tools Reference.
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Examples of Criteria
The following examples illustrate the syntax for conditions:

If the opportunity is for a Pentium computer, you want to insert a component
about the advantages of the Pentium chip. In the Condition field for this
component, type the following condition:

EXI STS [ Product] LIKE "Pentiunmt"

This condition would look at the products listed for the opportunity. If the
product name begins with Pentium, Siebel Presentations would insert the
component. Otherwise, Siebel Presentations would leave out this component.

NOTE: To use a product in a condition, the product must have entered using the
Products view of the Opportunity screen. The condition will not work with
products that were entered as Quote line items.

If the account is located in Georgia, you want to enter a section with terms and
conditions limited to that state. In the section’s Condition field, you would enter
the following:

EXI STS ([State] = "GA")

or
[State] = "GA"

You would use the first line if the account is located only in GA, and the second
line if the account is located in GA and another location.

This condition will look at the state for the account, and if the state is GA then
the section would be included in the presentation; otherwise, Siebel
Presentations would skip this section and move on to the next.

If the opportunity has a revenue amount greater than $1,000,000 and it is
expected to close this year, you want to insert a component on a special program
for this type of customer. Enter the following condition in the Condition field for
the component:

[ Revenue] > 1000000 AND [Cl ose Date] <= ("12/31/02") AND [d ose
Date] >= ("1/1/02")
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After you enter a condition, test it as a query on the view you are going to use it on.
For example, the above example involving Revenue and Close Date can be tested as
a query on the My Opportunities view. If the query returns the data you expect, the
query is probably in the correct format for your condition field.

Defining Presentation Field Mappings

When you created the component slides of your presentation, you probably
included bookmarks for personalized fields. You must map the bookmarks in the
template’s components to Siebel fields.

This mapping tells Siebel Presentations which Siebel field to use for substituting
data for a particular bookmark in your presentation template. For example, by
mapping the bookmark Company to the Account field, you tell Siebel Presentations
to replace each Company bookmark with the value of the Account field.

You cannot map fields to a bookmark in the template’s header or footer, unless that
bookmark is also somewhere else in the content of the template, other than in the
footer or header.

Since you may be working with multiple presentation templates, you can have
multiple sets of bookmarks. You could have one mapping for one presentation
template and another mapping for another presentation, or you could use a single
mapping for several presentation templates. In either case, you must specify a
mapping name in your template record to associate the template with a specific
mapping.

If you map a bookmark to multi-value field, the primary record of the group is
retrieved. If you want to retrieve multiple values from a multi-value field, you can
add a Table section to the document template. This section type will retrieve
multiple values from the multi-value field in table format.

To map the bookmarks in a template’s components to fields, you must:
» Create a mapping

m Associate a template with the mapping
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Creating a Mapping
To create a field mapping, first create a record for the mapping, and then map the
fields.

To create a record for a mapping

1 From the application-level menu, choose View > Site Map > Document
Administration > Presentation Field Mappings.

The Business Objects view appears.
2 In the Business Objects list, add a new record.

3 Complete the fields (described in the following table).

Field Comments

Mapping Name Enter a name for the mapping.

Business Object Click the select button in the Business Object field, and use the
dialog box that appears to select the business object that contains
fields used in the presentation, and then click OK. For example, if
you are creating an opportunity presentation, select Opportunity in
the Business Object field.

Description Enter a description of the mapping for your own use.

4 In the Business Objects Explorer, in the left frame, click the + icon next to the
business object for which you created a mapping.

5 Select the Business Components folder.

6 In the Business Component list, add a new record and complete the fields.

NOTE: You can associate more than one Business Component mapping with an
Object. For example, if you are creating an opportunity presentation, you would
select the Opportunity Business Component. You could also select the TAS Account
Business Component to create mappings for views under the Opportunity TAS view.
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To map the fields

1 Navigate to the business component that contains the fields to be mapped.
2 Click the + icon next to the Business Component name.
The Business Component Fields folder appears.
3 Click the + icon next to the Business Component Fields icon.
The Business Component Fields list appears.
4 1In the Business Component Fields list, add a new record and complete the fields.
5 Complete the fields and click Save.

6 Repeat Step 4 and Step 5 for each field that needs to be mapped.
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Associating a Mapping with a Template

After you have created a mapping, you must associate it with a template to make it
apply to all the components in that template. You can associate a mapping with one
or more templates.

To associate a mapping with a template

1 From the application-level menu, choose View > Site Map > Document
Administration > Presentation Templates.

2 In the Templates list, select the template record with which you want to
associate the mapping.

3 In the Mapping Name field, select the mapping you created earlier.
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Creating the Presentation Library

As a presentation administrator, you create and maintain the Presentation Library,
which consists of slides that sales representatives can add to their presentations.

Slides in the Presentation Library are different from the other components you
created earlier, because components are part of the presentation template, which
are automatically included in presentations generated from that template. Slides in
the Presentation Library are available to sales representatives only on an as-needed
basis. As an administrator, you can also recommend documents to include in the
templates.

After sales representatives create a default presentation automatically, they can add
more slides from the Library or use the Edit Layout command to customize the
presentation. The Presentation Library allows multiple presentations created from
the same template to have different contents.

As an administrator, you place the various components in the Library and maintain
the information. When the sales representatives need additional slides to add to a
presentation, they review the Library, select the component they want to insert, and
automatically insert it into the presentation.

The sales force cannot update the information in the Library. The only sections and
components available to sales representatives are those you provide for them.

To prepare the presentation library, you must:

m Create Microsoft PowerPoint files for the library
= Add sections for the presentation library

= Add components to the library sections

= Recommend documents to be included in templates

Version 7.5, Rev. C Applications Administration Guide 369



‘ Presentations

Creating the Presentation Library

Creating Presentation Files for the Library

You create presentation files for the library in the same way that you create the
presentation templates themselves. Use Microsoft PowerPoint to enter text,
graphics, and bookmarks, and then map these bookmarks to fields in your Siebel
database.

NOTE: The only type of component that can be included in the Presentation Library
is of the File section type. Other section types (Charts, Reports, and so on) can be
included only in the initial template.

Adding Sections to the Presentation Library

Sections are used to organize slides in the Presentation Library. For example, if some
of the slides in the library are marketing pieces and others are technical, you may
want to create a section for each of these. Then the users will be able to browse
through the marketing pieces and through the technical pieces separately. You must
add at least one section to the Presentation Library. For more information about
creating presentation sections, see “Defining Template Sections” on page 352.

To add sections to the Document Library

1 From the application-level menu, choose View > Site Map > Document
Administration > Presentation Library.

2 In the Library Explorer, in the left frame, click the + icon of Presentation Library
folder.

The Sections folder appears under the Library.
3 Add the sections to this folder that you added sections for the presentation.
Adding Components to the Presentation Library
After adding sections to the presentation library, you add components to them.

For more information about adding presentation components, see “Adding
Components to Template Sections” on page 361.
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To add components to the Presentation Library

1

From the application-level menu, choose View > Site Map > Document
Administration > Presentation Library.

Use the Library Explorer to navigate to the section to which you want to add a
component.

Add the component to the library just as you would add a component to a
presentation.

Recommending Content for a Presentation
As the administrator, you can simplify the process of creating a quick presentation
by associating recommended content with the presentation template.

To associate recommended content with a presentation

1

N OO g AW
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From the application-level menu, choose View > Site Map > Document
Administration > Presentation Library.

Use the Library Explorer to navigate to the section to which you want to add
recommended content.

Open the selected section folder.

Click on the + icon of the Components folder.

Select a component.

In the Components record, click on the Recommended Templates field.

Add a Recommended Template to the Component record. You can recommend a
component to one template or to many templates. For example, a legal clause
might be required in all templates.

Repeat Step 5, Step 6, and Step 7 for each component that needs recommended
content.

NOTE: Recommended templates are displayed when a Presentation is edited
using the Edit Layout command and the Show Recommended Only box is
clicked on. See “Allowing Users to Quickly Customize Presentations.”
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Allowing Users to Quickly Customize Presentations

The end user can quickly select and modify the contents and section sequence of a
presentation so that the presentation reflects the immediate sales needs of the
situation. Presentations can be customized and created by the end user, and then
quickly restructured and recreated to reflect a new situation.

To create a quick, customized presentation
1 From the application-level menu, choose View > Site Map > Opportunities.
2 Select an existing opportunity or create a new opportunity.
3 Click the Presentations tab.
4 Click the Auto Presentation button.
The template associated with the decision issue appears.
5 Click the Edit Layout button.
The dialog box displays two columns:

= The Contents library lists the components in the Presentation Library that
can be included in the presentation.

= The Table of Contents column lists the components in the Presentation
Library that are selected for the presentation and the order in which they will
be displayed.

372 Applications Administration Guide Version 7.5, Rev. C



Presentations

6

Version 7.5, Rev. C

Creating the Presentation Library

In the Contents column, use the directional buttons to move selected sections
from the Contents column into the Sections column. If you make a mistake, click
Reset Layout to undo all changes to the Table of Contents column.

NOTE: If the Show Recommended Only box is checked, only those components
recommended by the Administrator are displayed. If this box is not checked, all
available components are displayed. For more information, see “Allowing Users
to Display Presentations in HTML Format” on page 374.

In the Sections column, use the directional buttons to move a selected section to
the desired sequence order. Use the X button to completely remove a section
from the presentation.

NOTE: The Section column displays only top-level sections. User modifications to
subsections must be done through the Presentation Table of Contents.
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Allowing Users to Display Presentations in HTML Format

By default, presentations is only saved in document format, and not in HTML
format. The user’s View HTML button is unavailable, and the user cannot view the
presentations in HTML format.

To let the user display presentations in HTML format, you must edit the parameter
DocumentServerViewHTML to give it the value True instead of False.

NOTE: Users of the Remote Client cannot view presentations in HTML format.

To allow users to display presentations in HTML format
1 Start the Server Manager.
2 Enter the command:

Srvrngr> change param Docunent Server Vi ewHTM.=True for conp
DocSer ver

NOTE: While this procedure uses the Server Manager, parameters can also be
changed using the Server Administration interface. For more information, see Siebel
Server Administration Guide.
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Sample Templates

Siebel eBusiness Applications come with a sample database. The Document
Template Administration view includes several sample document templates.

These sample presentations can be used as a reference when defining your own
presentation template. In this sample database you will find the following Siebel
Presentations sample presentations:

= Corporate Presentation (Opportunity category)

= Corporate Presentation - Account (Account category)
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Siebel Proposals allows your sales representatives to create proposals (and other
types of documents) based on templates that you create in Microsoft Word.

Traditionally, sales representatives create proposals by starting with a proposal that
worked in the past and then modifying it for the current prospect. Sales
representatives must not only change such basic information as the customer’s
name, but also possibly restructure the proposal so that it fits the new prospect’s
unique needs. For example, the original proposal may have been focused on price,
whereas the new prospect is more concerned with other decision criteria, such as
speed or extra functionality.

With Siebel Proposals, after the proposal administrator has created the right
templates, the sales representative can click one button to build the correct proposal
for a specific account or opportunity. Siebel Proposals uses information that sales
representatives have entered in the early stages of an opportunity to create the
proposal.

Sales representatives can add deal-specific information to the proposal without
worrying about formatting or presentation. Using the Proposal Library, sales
representatives can find any additional information and automatically insert it into
the proposal.

NOTE: The Siebel proposal document engine is also used to create agreement
documents. Administrators who create the agreement templates can follow the
steps in this chapter for creating proposals. Users are then able to select the
agreement template and generate an agreement document.
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System Requirements for the Siebel Web Client

To use Siebel Proposals, you must have:

= All the components that are required to run Siebel 7.5, including a Siebel Server
and a Web Server

m  The Document Server installed on one or more Windows machines

m  Microsoft Office installed on the Document Server machine

NOTE: If you are deploying the Siebel Server in UNIX and want to use Siebel
Proposals, a separate Windows machine is required for the Document Server.

Siebel Proposals uses the Document Server, which is a new component of the Siebel
Server that lets users on the Web work with Word documents that are on the server.

Your employees or partners who use Siebel Proposals need:
» A Web browser to use the product
= Optionally, Microsoft Office to edit documents

For information on the Web browsers that are supported by Siebel applications, see
Siebel System Requirements and Supported Platforms.

System Requirements for the Siebel Remote Web Client

Siebel Proposals is available for the Siebel Remote Web Client as well as for the
Siebel Web Client. The user interface for Proposals is identical in the Siebel Remote
Web Client and the Web Client.

However, the Siebel Remote Web Client processes requests to generate documents
locally, so that field sales representatives can generate correspondences, proposals,
and presentations while traveling.

To run Siebel Proposals on the Remote Web client, you must have Microsoft Office
installed on the same machine as the Remote Web Client.
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Setting Up the Document Server

Siebel Correspondence, Siebel Presentations, and Siebel Proposals all use the Siebel
Document Server to generate Microsoft Word and Microsoft PowerPoint documents
through the Web.

After installing your Siebel applications, you must enable the Document Server.

For more information, see “Installing the Document Server” on page 305.

The Process of Creating Templates

To create templates, you perform the tasks shown in Figure 17.

Create Word
Document

¥

Add Ternplate
Record

Create Proposal
Structure

¢

Add Components
to Sections

Define Document
Field Mappings

.| Prepare Document

Library

Figure 17. Siebel Proposal Process Flow
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Create Microsoft Word documents. To create the documents needed by the
template, you must write the text and insert bookmarks for such variables as
company, contact name, and address.

Add a template record. Use your Siebel application to create a single record for the
template.

Create the proposal structure. Specify which sections the proposal should contain.

Add components to the sections. Specify which components each section should
contain.
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= Use conditions in sections or components. Optionally, you can add conditions to
specify that sections or components are included in the proposal only under
certain circumstances.

= Define document field mappings. Specify which Siebel objects correspond to each
bookmark in your Word component documents. You also specify the name of
this mapping in the template record.

= Prepare the Proposal Library. In this optional step, which can be performed at any
time, you create a separate library of documents that sales representatives can
draw upon to customize their proposals.
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Creating Template Documents in Microsoft Word

The first step is to create documents in Microsoft Word. These documents consist
of one style document and multiple component documents, as shown in Figure 18.

Styles Docurment

Header Logo

Rl

F Y

Margins

Footer

Component

Dncments

Report

Cover Letter Executive Product
Corparate Overview sSummary Descriptions
Marketing Analysis

Quotes

Figure 18. Word Documents That Can Make Up a Proposal Template

The components shown in Figure 18 are only examples. You could have other
components, such as a table of contents or a set of collateral, and you could omit
the quotes or product descriptions, for example. However, a template must have a
style document and one or more component documents.

NOTE: See Release Notes for information about which versions of Microsoft Word are
supported.
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To create the template documents, you perform the following tasks:
= Planning the template. Decide what components the template should have.

= Creating the style document. Create the document that gives all the template’s
components a standard format.

m Creating the component documents. Create a document for each component of the
template.

Planning the Template
Before you create the documents in Word, you must determine how the proposal
should look and what type of information it should contain.

Begin by looking at previous successful proposals to see what sections they
included. For example, did they all have a cover letter, an executive summary, and
a quote? Also, look at the documents your company currently has on hand, and the
customer questions these pieces answer. Then decide how to organize your
information. What topics could be standard across all proposals? What topics are
specific to certain proposals? What is the best order for the pieces in the proposal
you are creating? Finally, decide what fields to insert to customize their proposals
(for example, contact name, account name, and industry). You will use this
information to create bookmarks in your Word documents.

As part of your planning, you should look at the sample templates that come with
Siebel Proposals, which are described in “Sample Data: Field Mappings and
Templates” on page 413.

NOTE: Proposals use fields from only one business object. If you want to include
additional fields, you must use Siebel Tools to add the business components that
include these fields to the business object that is the basis of the proposal.
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Creating a Styles Document

After you plan your templates, you work on the styles document for this template.
This Word document will define the layout of your proposal and may include such
things as headers, footers, your logo, and special margins.

The layout options you specify will automatically be applied to all the components
used in the proposal.

NOTE: Do not type any content into this document. The content will come from the
individual component documents that you will create later.

To set up styles for your template

1 Create a new document in Microsoft Word.

2 Set up margins, headers, footers, fonts, and other layout options for your
template.

3 When you are finished creating styles, save the file:
= Choose a name that uses only alphanumeric characters.
= Use the .doc extension for Microsoft Word.

4 Close the file.

Creating Components
The next step in developing your template is to create components, which are the
text pieces that make up the body of your proposal.

A component is a Microsoft Word document that includes standard text and
personalized data. For example, a cover letter component includes your standard
cover-letter text and personalized data such as the name and address of the contact
to whom the letter is addressed.

To create a component, you type the standard text and then create bookmarks, or
Microsoft Word placeholders for custom data. When a sales representative
generates a proposal, these bookmarks will be replaced with data from the Siebel
application.
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To create a component with bookmarks in Microsoft Word

NOTE: This procedure may vary slightly, depending on your version of Microsoft
Word.

1 Create a new blank document in Microsoft Word.
2 Type the standard text that belongs in this component.

3 Place the cursor where you want to create a bookmark, and choose Insert >

Field.
Field HE
Cateqaries: Field names:
(Al AutoText -
Date and Time AukoTextlist
Document Automation Hyperlink
Dacurnent Information IncludePickure
Equations and Formulas IncludeText
Index and Tables Link

Links and References MoteRef

Mail Merge
Mumbering
User Information

Field codes:  REF Bookmark [Switches]
Type the name of your
IREF Company bookmark after REF.

Description
Insert the text marked by a bookmark

W Ereserve formatting during Updates

[al'4 I Zancel | Qphions. .. |

4 Click Links and References in the Categories list, and then click Ref in the Field
Names list.

REF appears in the Description box.
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5 In the Comments box, enter the name of your bookmark after REF.

For example, you might type Company for company name, so that the
Comments box contains:

REF Conpany

The bookmark name cannot begin with a number.

NOTE: If the text inserted into a bookmark contains double quotes ("), the
inserted text will automatically be preceded by a backslash (\). If you do not
want the backslash to appear in the inserted text, change the double quotes to
single quotes in the Siebel software.

6 Note the name of the bookmark, because you will need it when you map the
bookmark to a Siebel field names.

7 Click the Preserve Formatting During Updates check box if you want to maintain
the format of the merged text.

8 Click OK to insert the field.
In your document, the following message appears:
Error! Reference source not found.

This message is Word’s normal bookmarking convention. The error text will be
replaced by appropriate data at the time of draft generation.

9 Repeat Step 3 on page 384 through Step 8 to add bookmarks for every field you
want to insert in the text.

NOTE: If the same field is being inserted in several places, you can copy its
bookmark and paste it into other parts of the document.

10 Save the component document as a .doc file.
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Creating a Record for the Template

After you have created your template documents in Word, you can use Siebel
Proposals to specify how they are assembled in the template.

To create a record for the template

1 From the application-level menu, choose View > Site Map > Document
Administration > Proposal Templates.

2 In the Templates list, add a new record and complete the fields.

Some fields are described in the following table.

Field

Comment

Name

Default

Category

Mapping Name

Template File
Name

Enter a name for the template.

If you want this template to be the default proposal template, place
a check mark in the Default field. When the user clicks Auto
Proposal, Siebel Proposals uses the default template if there are no
decision issues that match the theme of a proposal. You can select
only one Opportunity Proposal default and one Account Proposal
default.

Select one of the following types of templates:

= Opportunity Proposal templates are available only when you are
working with Opportunities.

= Account Proposal templates are available only when you are
working with Accounts.

= Agreement templates are available when you are working with
Siebel Professional Services Agreements.

Used to indicate the group of bookmark fields to be used with this
template. Leave this field blank until you create a mapping.

The Word template document.
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Field Comment

Theme If you want to associate the template with a particular decision
issue, click Decision Issue List in the Theme field, and select a theme
from the Decision Issue dialog box. When you give your proposal
template a theme, you associate it with a particular decision issue
that is important for your opportunity. When a proposal theme
matches the number one decision issue for the current opportunity,
Siebel Proposals automatically selects the correct template when the
user clicks Auto Proposal. Users can also select a theme template if
they want.

Because accounts and agreements are not related to decision issues,
the Theme field is not applicable for Account Proposal and
Agreement templates. It is used only for Opportunity Proposal

templates.
Description Enter a description of the template.
Language The language in which the template was written.
Locale The template is specific to the locale.
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About Creating the Template Structure

After you have created your Word documents and a record for your template, define
the structure of your proposal template.

A proposal is made up of sections, which divide and subdivide your proposal.
Depending on your needs, a single section might contain multiple components or a
single component.

The type of a section depends on the nature of the data it contains. For example, file
sections contain documents, chart sections reference Siebel charts, report sections
reference Siebel reports, and so on.
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Defining Template Sections

You define the structure of the proposal template by creating sections in the
Proposal Template Administration view, which are associated with the Template
record you created for this template. You must create top-level sections. Optionally,
you can add subsections to these. Your proposal structure can have multiple levels
of sections, because a subsection can contain other subsections.

Creating Top-Level Sections
First, you must create top-level sections.

To create top-level sections

1

Version 7.5, Rev. C

From the application-level menu, choose View > Site Map > Document
Administration > Proposal Templates.

In the Template Explorer list, in the left frame, click the + icon next to the
template record that you created for this proposal.

The Sections folder appears in the list.

In the Explorer list, click the + icon next to the Sections folder.
The Sections list appears in the right frame.

In the Sections list, add a new record.

In the Name field, enter a name for the section, which will not appear in the
proposal itself.

In the Sequence field, specify the order in which this section should appear in
the proposal.

In the Section Type field, indicate the type of section you are creating. The
following table describes the section types available.

Type Comments
File Contains only proposal text in DOC or TXT format.
Chart Inserts a Siebel chart. The chart can be placed in the left margin, right

margin or centered, and you can change the x, y, and z axes.
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Type

Comments

Locator

Organization
Chart

Report

Table

Pulls in documents from the Siebel Encyclopedia. For example, if you
create a locator section, Siebel Proposals can dynamically pull in
documents from the encyclopedia that are related to the products the
opportunity is interested in. For instance, if you want the proposal to
dynamically insert text related to the products on the opportunity, use
a Locator. The file types must be DOC, TXT, or RTF. If more than one
marketing document meets the Locator criteria you specify, Siebel
Proposals inserts each.

Creates a slide and pulls in organization charts for the account or
opportunity associated with the template. Charts are automatically
centered.

Dynamically inserts a Siebel report (such as Siebel Quote).

When inserting reports, the Proposal engine converts the Actuate
report to HTML and inserts the HTML version as a table in your
proposal. When designing your reports to be included in Siebel
Proposals, you may want to review headers and footers, because
HTML sometimes crops these.

Only Actuate reports can be included. Microsoft Access reports
cannot be included.

Pulls Siebel application data into a table format. You select fields to
be included, the sequence of the fields, and the column length. By
selecting a Table Section, you also allow creation of a Related Table
section. See “Adding Related Table Subsections” on page 396

8 Complete the fields applicable to your section type. Table 27 describes the fields
that you should complete for each type of section.

9 Repeat Step 4 on page 389 through Step 8 to add all the top level sections that

are needed.

Table 27. Selected Fields in the Proposal Template Administration View

Section Type Field
All Condition
File N/A

Comments

Conditions can be applied to all section types. For
information about conditions, see “Using Conditions
in Templates” on page 400.

Only the Condition field is applicable.
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Table 27. Selected Fields in the Proposal Template Administration View

Section Type Field

Chart Business Object

Chart or Table Name

Search Spec

Width

Height

Category

Function

Series

Chart Location

Version 7.5, Rev. C

Comments

The Siebel business object from which the chart
information is coming (for example, Opportunity).
Select from the Business Object list, which lists all
available Siebel business objects.

The name of the chart applet you want to insert into
this section (for example, “Opportunity Chart Applet -
Current Opportunity Analysis”). The list contains all

available applets.

Any search criteria you want to use to restrict data for
the chart (for example, Revenue > 500000).

How wide the chart should be in the proposal
document. The default width is 400 pixels.

How high the chart should be in the proposal
document. The default height is 300 pixels.

With charts that provide multiple X-axis options, this
field allows you to set the option to use for the X-axis.
For example, in the Lead Analysis by Rep chart, the X-
axis can be Sales Representative or Quality.

With charts that provide multiple Y-axis options, this
field allows you to set the option to use for the Y-axis.
For example, in the Lead Analysis by Rep chart, the Y-
axis can be Number of Opportunities, Opportunity
Revenue, or Average Opportunity Revenue.

This field allows you to set the Z-axis you wish to use
for charts that provide multiple Z-axis options.

Location of the chart on the proposal page: Left, Right,
or Center. Any text components you include in your
chart section will wrap around the chart. For example,
if you put your chart on the left, the text component
will be inserted to the right of the chart.

Applications Administration Guide 391



Proposals

Defining Template Sections

Table 27. Selected Fields in the Proposal Template Administration View

Section Type Field

Locator Information Retrieval Method

Retrieved Literature Category
Organization Chart

Business Object

Chart or Table Name

392 Applications Administration Guide

Comments

Select the relationship to use to find the literature (for
example, Oppty Competitor Lit, which is the literature
on competitors associated with the opportunity).

Indicate the type of literature you are looking for (for
example, brochures, or specification sheets). This
helps you to filter out the documents from the
encyclopedia that you want to include in the proposal.

The Siebel object from which the information is taken.
Select from the picklist, which contains all available
business objects from your repository, or enter the
name in the field.

The name of the applet that contains the organization
chart data (for example, the Opportunity Organization
Analysis applet).
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Table 27. Selected Fields in the Proposal Template Administration View

Section Type Field

Report Business Object

Report Name

Link Spec

Search Spec

Version 7.5, Rev. C

Comments

The Siebel business object from which the report
information is coming (for example, Opportunity).
Select from the Business Object list, which lists all
available Siebel business objects.

For example, to include a quote report in your
proposal, you would select Quote.

The name of the report you want to insert in this
section. Select from the list, which shows all available
reports.

For example, you might choose Proposal Quote.

Specifies the data to insert in your report. In the
previous quote example, the Link Spec is Opportunity,
Id/Quote, Opportunity Id. The syntax of the Link Spec
is:

<Par ent Busi ness Component
Nanme><Coma><Parent-1D Fi el d
Nane><S| ash><Chi | d Busi ness Conponent
Nanme><Comma><Chi | d- 1 D Fi el d Nane>

Descriptions of these fields can be found in Siebel Tools
Online Help. The Child-ID-Field-Name may vary,
depending on whether the relationship between your
parent business component and child business
component is one-to-many or many-to-many. You or
your system administrator can find Link Spec
information in the Siebel Repository.

You can include only Actuate reports.

The search criteria. For example, if you want to insert
only the Active Quotes for the Opportunity, your
Search Spec is Active = ‘Y".
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Table 27. Selected Fields in the Proposal Template Administration View

Section Type Field

Table Business Object

Chart or Table Name

Width

Table Fields

Comments

This is the Siebel object from which the information is
taken. Select from the list, which contains all available
business objects from your repository, or enter the
name in the field.

For example, if you want to include a list of products
being offered to the opportunity, the Business Object is
Opportunity.

This is the name of the applet where the table data is
stored.

In the example used for Business Object, the applet is
Opportunity Product Applet.

Width represents a percentage of the space available
between the template margins. If you choose 100, that
equates to 100% of the space between the Template
margins. If you enter 125, that represents 125% of the
space between the borders.

If left blank, the width of the columns in the table is
based on pixels.

Click the Select button to bring up the Table Fields
dialog box; then, for each field you want in the table,
click New and enter the following information:

»  The Field Name of the field; for example, Product.
= The Sequence in which you want the field listed.

»  The Width of the column in the table; column
Width is measure in pixels. The default (and
minimum) column width is 100 pixels. A second
way to define column width is by percentage of the
table width. When a value is entered into table
width, column width equates to percentage of total
table width. For example, if there are three fields
and table width is set to 100, field widths of 25, 65,
and 35 would equate to 25%, 65 %, and 35% of the
total width of the table. In this example, if the table
width was not set, the field widths would equate to
25, 65, and 35 pixels.

= The Alignment of the data in the field: Left, Center,
Right.
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Adding Subsections

After adding top-level sections, you may want to add subsections to one or more of
them.

To add subsections to an existing section

1 From the application-level menu, choose View > Site Map > Document
Administration > Proposal Templates.

2 In the Template Explorer list, in the left frame, click the + icon next to the
template to which you want to add a subsection.

The Sections folder appears in the list.

3 In the Template Explorer, click the + icon next to the Sections folder for this
template.

The Explorer list shows the sections for this template, and the Sections list
appears to the right.

4 1In the Template Explorer, click the + icon next to the section to which you want
to add a subsection.

The Sections, Related Table, and Components folders for this section appear in
the list.

5 Click the + icon next to the Sections folder for this section.
The Sections list appears, listing all subsections under this section.

6 Use the Sections list to add a subsection in the same way you used it to add a
top-level section, as described in “To create top-level sections” on page 389.

NOTE: When a proposal is generated, a section is generated before any of its
subsections and is displayed above a subsection in the finished document.
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Adding Related Table Subsections

After adding a Table Name subsection, you can add related tables that provide
detailed information for the first table. For example, if the tables subsection contains
a quote record, the related table can contain the quote line items. The relationship
between the information is essentially a parent-child-grandchild relationship; the
opportunity is the parent record, the quote table is the child, and the related table
containing the quote line items is the grandchild.

To add a related table

1

N oo a s

From the application-level menu, choose View > Site Map > Document
Administration > Proposal Templates.

In the Template Explorer list in the left frame, click the + icon next to the
template to which you want to add a related table.

The Sections folder appears in the list.

In the Explorer list, click the + icon next to the Sections folder.
The Sections list appears in the right frame.

In the Sections list, add a new section or edit an existing section.
In the Section Type field, select Table and enter the table name.
Complete all necessary fields.

In the Explorer list, click the + icon next to the Related Tables folder.

NOTE: The Related Table folder in the Template Explorer is used only for the Table
section type. This folder can be edited only if a table has already been added.

In the Related Tables dialog box, complete the fields as described in the
following table.

Field Comments
Business Select the Siebel object to which this table is related.
Object
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Field Comments
Table Name  Select the name of the related table applet.
Field Name Select the fields to be displayed in this table. If none are selected, all

fields appear. The width is interpreted the same way as the parent table
section. If the width of the table section is set, the width of the fields is
used as percentages instead of pixels.
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Adding Components to Template Sections

Now that you have defined the structure of your document, you must specify the
location of the component documents that will probably make up the bulk of your
proposal.

For sections that draw on data from a Siebel database (such as Chart and Report),
you have specified all the information necessary for Siebel Proposals to generate the
appropriate contents. However, the component documents, which you created
earlier in Word, are not part of the proposal until you add them to the appropriate
sections.

NOTE: Components can be added to any kind of section (not just a File section), and
a section can contain multiple components.

To add a component to a proposal template

1 From the application-level menu, choose View > Site Map > Document
Administration > Proposal Templates.

2 In the Templates Explorer, in the left frame, click the + icon next to the template
to which you want to add a component.

3 Click the + icon next to the Sections folder.

4 Click the + icon next to the particular section that will include a component.
The Sections, Related Table, and Components folders appear.

5 Click the + icon for the Components folder.
The Components list appears on the right.

6 In the Components list, add a new record.
The Add Sales Tools dialog box appears.

7 In the Add Sales Tools dialog box, select the component you want to add and
click Add. If your component does not appear in the list, click New to add it. In
the new entry applet, complete the fields as described in Step 9 on page 399.

A new record is added to the Components list.
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8 In the Components list, select the new record, and then click the Edit button.

9 Complete the fields, as described in the following table.
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Field Comments

Name Enter a name for the component.

File Name This field was filled in automatically when you selected a file from the
Add Sales Tool dialog box.

Sequence Specify the order in which this component should appear in the
section.

Condition Enter a condition and this component will be displayed only when the

condition is true.
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Using Conditions in Templates

You can add query conditions to a section or a component to specify the conditions
under which the section or component will be used in the proposal. For example, if
you have two executive summaries—one for deals of over $100,000 and another for
smaller deals—you can use the Condition field in each Executive Summary section
to allow Siebel Proposals to insert the appropriate executive summary based on the
condition that is true.

Entering Criteria

You can enter query criteria in a section or component record’s Condition field
(such as [Revenue] > 100000). If the condition is TRUE, the section or component
is included. If the condition is FALSE, the section or component is not included.

If you do not specify a condition, the section or component is always used.

You can create conditions for any field that is related to the business object of your
proposal; use Opportunity fields for opportunity proposals, and Account fields for
account proposals. If the definition of a condition needs to be based on fields from
another business object, you must add those fields to the Opportunity or Account
business object through either a link or a join.

The syntax for conditions is similar to the syntax for Siebel queries.

For more information about the syntax of Siebel queries, see Fundamentals and
Siebel Tools Reference.

400 Applications Administration Guide Version 7.5, Rev. C



Proposals

Using Conditions in Templates

Examples of Criteria
The following examples illustrate the syntax for conditions:

» If the opportunity is for a Pentium computer, you want to insert a component
about the advantages of the new Pentium II chip. In the Condition field for this
component, type the following condition:

EXI STS [ Product] LIKE "Pentiunt"

This condition would look at the products listed for the opportunity. If the
product name began with Pentium, Siebel Proposals would insert the
component. Otherwise, Siebel Proposals would leave out this component.

NOTE: For you to use a product in a condition, the product must have been
entered using the Products view of the Opportunity screen. The condition will
not work with products that were entered as Quote line items.

= If the account is located in Georgia, you should enter a section with terms and
conditions limited to that state. In the section’s Condition field, you enter the
following:

EXISTS ([State] = "GA")
or
[State] = "GA"

You use the first line if the account is located only in Georgia, and the second
line if the account is located in Georgia and another location.

This condition will look at the state for the account. If the state is Georgia, then
the section is included in the proposal. Otherwise, Siebel Proposals skips this
section and moves on to the next.
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= If the opportunity has a revenue amount greater than $1,000,000 and it is
expected to close this year, you should insert a component on a special program
for this type of customer. Enter the following condition in the Condition field for
the component:

[ Revenue] > 1000000 AND [ Cl ose Date] <= ("12/31/2003") AND [ O ose
Date] >= ("1/1/2003")

After you enter a condition, test it as a query in the view you are going to use it
in. For example, the above example involving Revenue and Close Date can be
tested as a query in the My Opportunities view. If the query returns the data you
expect, the query is probably in the correct format for your Condition field.
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Defining Document Field Mappings

When you created the component documents of your proposal, you probably
included bookmarks for personalized fields. You must map the bookmarks in the
template’s components to Siebel fields.

This mapping tells Siebel Proposals which Siebel field to use for substituting data
for a particular bookmark in your proposal template. For example, by mapping the
bookmark Company to the Account field, you tell Siebel Proposals to replace each
Company bookmark with the value of the Account field.

You cannot map fields to a bookmark in the template’s header or footer unless that
bookmark is also somewhere else in the content of the template, other than in the
footer or header.

Because you may be working with multiple proposal templates, you can have
multiple sets of bookmarks. Therefore, you might have one mapping for one
proposal template and another mapping for another proposal. Or you might use a
single mapping for several proposal templates. In either case, you must specify a
mapping name in your template record to associate the template with a specific

mapping.

If you map a bookmark to a multi-value field, the primary record of the group is
retrieved. If you want to retrieve multiple values from a multi-value field, you can
add a Table section to the proposal template. This section type will retrieve multiple
values from the multi-value field in table format.

To map the bookmarks in a template’s components to fields, you must perform the
following tasks:

= Create a mapping

= Associate a template with the mapping

NOTE: You may want to base your mappings on the sample mappings that come with
Siebel Proposals, which are described in “Sample Field Mappings” on page 413.
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Creating a Mapping
To create a field mapping, first create a record for the mapping, and then map the
fields.

To create a record for a mapping

1 From the application-level menu, choose View > Site Map > Document
Administration > Proposal Field Mappings.

2 In the Business Objects list, add a new record, and complete the fields.

The fields are described in the following table.

Field Comments

Mapping Name Enter a name for the mapping.

Business Object  Select the business object that contains fields used in the proposal.
For example, if you are creating an opportunity proposal, select
Opportunity in the Business Object field.

Description Enter a description of the mapping for your own use.

3 Inthe Business Objects Explorer, click the + icon next to the business object for
which you just created a mapping.

The Business Components folder for this business object appears.
4 Click the + icon next to this Business Components folder.
The Business Components list for this business object appears.

5 In the Business Component list, add a new record, and complete the fields.

NOTE: You can associate more than one Business Component mapping to an Object.
For example, if you are creating an opportunity proposal, you select the Opportunity
Business Component. You can also select the TAS Account Business Component to
create mappings for views under the Opportunity TAS view.

To map the fields

1 Navigate to the Business Component that contains the fields to be mapped.
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2 Click the + icon next to the Business Component name.
The Business Component Fields folder appears.
3 Click the + icon next to the Business Component Fields icon.
The Business Component Fields list appears.
4 1In the Business Component fields list, add a new record, and complete the fields.
5 Repeat Step 4 for each field that needs to be mapped.

For samples, see “Sample Field Mappings” on page 413.
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Associating a Mapping with a Template

After you have created a mapping, you must associate it with a template to make it
apply to all the components in that template. You can associate a mapping with one
or more templates.

To associate a mapping with a template

1 From the application-level menu, choose View > Site Map > Document
Administration > Proposal Templates.

2 In the Templates list, select the record for the template with which you want to
associate the mapping.

3 In the Mapping Name field, select the mapping you created earlier.
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Creating the Proposal Library

As a proposal administrator, you create and maintain the Proposal Library, which
consists of pieces of text that sales representatives can add to their proposals. In the
Siebel system, these pieces of text are components of the File section type.

Documents in the Proposal Library are different from the other components you
created earlier, because components are parts of the proposal template, which are
automatically included in proposals generated from that template. Documents in
the Proposal Library are available to sales representatives only on an as-needed
basis. As an administrator, you can also recommend documents to include in the
templates.

After sales representatives create a default proposal automatically, they can add
more documents from the Library or use the Edit Layout command to customize the
proposal. The Proposal Library allows multiple proposals created from the same
template to have different contents, and it can help sales representatives find
answers to specific Request for Proposal (RFP) questions.

As an administrator, you place the various components in the Library and maintain
the information. When the sales representatives need additional text to add to a
proposal, they review the documents in the Library, select the component they want
to insert, and automatically insert it into the proposal.

The sales force cannot update the information in the Library. The only sections and
components available to sales representatives are those you provide for them.

To prepare the proposal library, you must:
m  Create document files for the library
= Add sections for the proposal library
= Add components to the library sections

= Recommend documents to be included in templates
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Creating Document Files

You create document files for the library in the same way that you create the
proposal templates themselves. Use Microsoft Word to enter text and bookmarks,
and then map these bookmarks to fields in your Siebel database.

NOTE: The only type of component that can be included in the Proposal Library is of
the File section type. Other section types (Charts, Reports, and so on) can be
included only in the template as described in “Defining Template Sections” on
page 389.

Adding Sections to the Proposal Library

Sections are used to organize documents in the Proposal Library. For example, if
some of the documents in the library are white papers and others are specifications,
you may want to create a section for each of these. Then the users will be able to
browse through the white papers and through the specifications separately. You
must add at least one section to the Proposal Library. For more information about
adding sections, see “Defining Template Sections” on page 389.

To add sections to the Proposal Library

1 From the application-level menu, choose View > Site Map > Document
Administration > Proposal Library.

2 In the Library Explorer, in the left frame, click the + icon of the Library folder,
if that folder is not already open.

3 Click the + icon of the Proposal Library folder.
The Sections folder appears under it.

4 Add sections to this folder just as you added sections for the proposal.
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Adding Components to the Proposal Library

After adding sections to the proposal library, you add components to them.

To add components to the Proposal Library

1

From the application-level menu, choose View > Site Map > Document
Administration > Proposal Library.

Use the Library Explorer to navigate to the section to which you want to add a
component.

Add the component to the library just as you would add a component to a
proposal.

Recommending Content for a Proposal
As the administrator, you can simplify the process of creating a quick proposal by
associating recommended content with the proposal template.

To associate recommended content with a proposal

1

N OO g AW
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From the application-level menu, choose View > Site Map > Document
Administration > Proposal Library.

Use the Library Explorer to navigate to the section to which you want to add
recommended content.

Open the selected section folder.

Click the + icon of the Components folder.

Select a component.

In the Components record, click the Recommended Templates field.

Add a Recommended Template to the Component record. You can recommend a
component to one template or to many templates. For example, a legal clause
might be required in all templates.

Repeat Step 5, Step 6, and Step 7 for each component that needs recommended
content.

NOTE: Recommended contents are displayed when a proposal is edited using the
Edit Layout command and the Show Recommended Only box is selected. See
“Allowing Users to Customize Proposals” on page 410.
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Allowing Users to Customize Proposals

The end user can select and modify the contents and section sequence of a proposal
so that the proposal reflects the immediate sales needs of the situation. Proposals
can be customized and created by the end user, and then quickly restructured and
recreated to reflect a new situation.

To create a customized proposal
1 From the application-level menu, choose View > Site Map > Opportunities.
2 Select an existing opportunity or create a new opportunity.
3 Click the Proposals tab.
4 Click the Auto Proposal button.
The template associated with the decision issue appears.
5 Click the Edit Layout button.

The dialog box displays two columns:

= The Contents Library lists the components in the Proposal Library that can
be included in the proposal.

= The Table of Contents column lists the components that are selected for the
proposal and the order in which they will be displayed.
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In the Contents column, use the directional buttons to move selected sections
from the Contents column into the Sections column. If you make a mistake, click
Reset Layout to undo all changes to the Table of Contents column and begin
again.

NOTE: If the Show Recommended Only box is checked, only those component
templates recommended by the administrator are displayed. If this box is not
checked, all available components are displayed. For more information, see
“Allowing Users to Display Proposals in HTML Format” on page 412.

In the Sections column, use the directional buttons to move a selected section to
the desired sequence order. Use the X button to completely remove a section
from the proposal.

NOTE: The Section column displays only top-level sections. User modifications to
subsections must be done through the Proposal Table of Contents.
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Allowing Users to Display Proposals in HTML Format

By default, proposals are saved only in document format, not in HTML format. The
user’s View HTML button is unavailable, and the user cannot view the proposals in
HTML format.

To let the user display proposals in HTML format, you must edit the parameter
DocumentServerViewHTML to give it the value True instead of False.

NOTE: Users of the Remote Client cannot view proposals in HTML format.

To allow users to display proposals in HTML format
1 Start the Server Manager.
2 Enter the command:

Srvrngr> change param Docunent Server Vi ewHTM.=True for conp
DocSer ver

NOTE: While this procedure uses the Server Manager, parameters can also be
changed using the Server Administration interface. For more information, see Siebel
Server Administration Guide.
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Sample Data: Field Mappings and Templates

To help you create your first proposal, your Siebel application includes sample data.

Sample Field Mappings

The Document Field Mappings Administration view includes two mappings:
Opportunity and Account. These mappings list common fields you can use in
creating your proposal. Table 28 and Table 29 show these mappings.

Table 28. For Business Object: Opportunity, Business Component: Opportunity

Bookmark
Company
Address
City

State
ZipCode
Country

Industry

Business Component Field

Account
Street Address
City

State

Postal Code
Country

Industry

Table 29. For Business Object: Account, Business Component: Account

Bookmark
Company
Address
City

State
ZipCode
Country
Industry

Account Type

Business Component Field

Account
Street Address
City

State

Postal Code
Country

Industry

Type
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Use the Bookmark name in your Word document when you create a bookmark (for
example, REF Company) and select this mapping for the Proposal Templates you
create. It will match to the Siebel Business Component field (for example, Account)
in your proposal draft with that assigned mapping.

Sample Templates

Siebel eBusiness Applications come with a sample database. The Document
Template Administration view includes several sample proposal templates for
Microsoft Word.

These sample proposals can be used as a reference when you define your own
proposal template. In this sample database, you will find the following Siebel
Proposals sample proposals:

= Standard

= Standard Account

m Strategic

= Quality Strategic Account

The sample templates fall into the following categories:
m Standard: Oppty Ppsl

s Standard Account: Acct Ppsl

= Strategic: Oppty Ppsl

= Opportunity Account Plan: Oppty Ppsl

»  Quality Strategic Account: Acct Ppsl

Seed Templates

Customers using the Target Account Selling Module (TAS) can run an Opportunity
Plan report in Microsoft Word using the TAS Opportunity Plan template. This
proposal template is available in the seed database. For more information on setting
up the TAS Opportunity Plan template, see the Upgrade Guide for the operating
system you are using.
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Siebel Literature allows you to give your users access to sales and marketing
literature, such as product brochures, white papers, data sheets, and other types of
literature items. Users view these documents using the application that created
them, for example, Microsoft Word, Lotus Word Pro, or Adobe Acrobat.

Literature items may also be grouped into literature kits. Literature kits may include
items not normally thought of as literature, such as promotional hats, coffee mugs,
or T-Shirts. These kits may then be made available for distribution through
fulfillment centers. Literature kits are covered later in this chapter. Fulfillment is
covered in Chapter 14, “Correspondence.”

After you create literature records and associate documents with them, your
employees can use literature in several ways:

= Employees can use the Literature or Infocenter screen to search through all the
literature that is available to them.

= You can associate literature with business objects such as products or decision
issues. Then users can display the literature when they are looking at the record
for the associated business object. For example, the user can navigate to the
Product screen, select a product, and click the Product Literature view tab to find
all literature items associated with that product.

= When your employees use the Correspondence screen to create correspondence,
they can include literature as enclosures. The user or fulfillment center may print
out this literature document, or it may use preprinted copies of literature such
as glossy brochures. It may also enclose promotional items that are parts of
literature kits.

= Employees can track literature associated with products, industries, accounts
and competitors so that they appear on your Briefing pages.
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About Setting Up Literature Files

To set up a literature file, you must
»  Create the document in another program

m Add a Literature record that includes the document in your Siebel application

NOTE: You may want to create a literature record without associating a document
with it. For example, if the record represents an item such as a hat or cup, which is
part of a literature kit, you need not associate a document with it.
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Creating and Modifying Literature Files

Literature files can be created or saved using many kinds of software. The following
file types are among the most common:

Adobe Acrobat (.pdf)
Excel (.xls)

Word (.doc)
PowerPoint (.ppt)
Bitmap (.bmp)

JPEG (.jpg)

To create a new literature file

1
2

Create a literature file in the appropriate software application.

Save the file on your hard drive.

To modify an existing literature file

1

Version 7.5, Rev. C

From the application-level menu, choose View > Site Map > Document
Administration > Literature.

Click the literature file that you want to modify.

Information about the file is displayed in the More Info form. You can use this
form to change existing comments or characteristics; for example, Distribution
Method.

The actual literature file opens in the type of tool that was used to create it; for
example, Word.

Modify the file, and save it locally.

Upload the modified file to the existing Literature record.
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Adding Literature Records

After you have created a literature file, you need to create a literature record in the
Siebel database, in order to make the file available to Siebel applications users.

To add a literature record

1 From the application-level menu, choose View > Site Map > Document
Administration > Literature.

2 In the Literature list, add a record and attach the literature file.

The new file is added to the available literature. Appropriate information is
displayed in the Literature list and the More Info form.

3 Enter the rest of the information required in the Literature list blank row and the
More Info form of the new record. The following table briefly describes each

field in the view.

Field

Comments

Name

Description

Literature Type

Size

File Type

Modified

Enter a name for the literature record.

Enter a description of the document. Because literature items
can be in any language, you may want to indicate the language
of the item in this field (or in the Name field).

Select the type of the literature. You can create new literature
types in the List of Values Administration view.

Because the Literature Type field is used to filter literature items
in various applets (by setting the Search Specification property
for the applet in Siebel Tools), you should be careful when
editing the Literature Type field.

The size of the literature file. The information is automatically
entered based on the size of the file that you select.

The file type of the literature file, for example DOC or PDF. The
information is automatically entered based on the type of the
file that you select.

The date that the literature file was last modified. The
information is automatically updated whenever the file is
updated.
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Comments

Update File

File Name

Synopsis
Web Display

Release Date

Expiration Date

Author

Accounts

Competitors

A check mark in this field indicates that users’ copies of the
literature will be updated automatically each time the original
file is updated.

Click Browse and, in the Choose File dialog box, select the
document file. You can also enter the file name manually.

Optionally, enter a synopsis of the document’s content.

If the literature item is a Web document, select the type of Web
display—Frame, In-Line, New Window, or Window. This
property is only for use by eBriefings and ERM.

The release date when the document will first be displayed in
My Briefings. For more information about eBriefings, see Siebel
eBriefings Administration Guide.

The expiration date when the document will no longer be
displayed in My Briefings. For more information about
eBriefings, see Siebel eBriefings Administration Guide.

Optionally, click the select button and select the document’s
author.

Select accounts with which the literature is associated. The
literature is displayed in the Account Briefing if this account is
tracked by the user. For more information, see Siebel eBriefings
Administration Guide.

Select competitors with which the literature is associated. Use
this field to allow the user to display the literature using the
Competitors screen.

If you also select the Internal field, this literature will be
displayed in the Comparative Literature view of the
Competitors screen. If you do not select the Internal field, this
literature will be displayed in the Competitor’s Literature view
of the Competitors screen.

The literature is also displayed in a Competitor Briefing, if this
competitor is tracked by the user. For more information, see
Siebel eBriefings Administration Guide.
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Field

Comments

Internal

Local

Request

Distribution Method

Industries

Products

Organization

Select this field if the document is internally sensitive and not
intended for public distribution.

If Internal is selected, the literature will not be available as an
enclosure in the Correspondence screen, and it will be
displayed in the Comparative Literature list of the Competitors
screen.

If Internal is not selected, the literature will be available as an
enclosure in the Correspondence screen, and it will be
displayed in the Competitive Literature list of the Competitors
screen.

For users of the Remote Client, this fields specifies whether the
document is available on the local File System. If a document is
not available locally, the user can request it by selecting the
Request field.

For users of the Remote Client, if this check box is selected, the
literature will be downloaded during each synchronization
session.

Use this drop-down list to specify whether or not the file is
automatically downloaded to users of the Remote Client.

Publish: During each synchronization session, if your user does
nothing, the file is downloaded automatically. If your user
explicitly skips the file, the file is not downloaded in that
synchronization session.

By Request: During synchronization, the user receives the
record, but not the actual file. To receive the file, the user must
select the Request field.

Select any industries associated with the literature. The
literature is displayed in My Briefing if the user tracks the
industry.

Select any products associated with the literature. Use this field
to allow the user to display the literature using the Products
screen. The literature is displayed in My Briefing if the user
tracks the product.

Select organizations that will have visibility to this data.
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Adding Translation Records

Translated literature files can be created using any of the previously listed software
tools. (See “Creating and Modifying Literature Files.”) You can create a record in the
Siebel application for any translated file associated with your document.

To associate a translated document with a literature record

1 From the application-level menu, choose View > Site Map > Document
Administration > Literature.

2 In the Literature list, select an existing record.
3 Click the Translations view tab.
4 1n the Translation list, add a record and attach the translated document.

Make sure that the file name clearly indicates that this is the translated file.
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Adding Literature Item Kits

After you have created more than one literature file, you can combine individual
files and other material to create literature item Kits. This feature allows you to
combine individual literature items into groups, so you can work with the group
instead of with of the individual files. Literature item Kkits are used only as
enclosures in correspondence.

For instance, you might have a set of literature items for prospective customers,
including promotional brochures for your most popular products. You might also
include items that are not documents: for example, a promotional kit for one of your
products might include a brochure, a specifications sheet, a coffee cup, and a T-
shirt.

Creating a literature item kit makes it easier to send this information out. When the
user adds an attachment to correspondence, the user only has to select one
literature item kit instead of all the individual items. Then the fulfillment center can
mail all the items with the correspondence.

When you create a literature item Kit, you create a Literature record that represents
the entire kit, and you associate Literature Item records with it that represent the
items in the Kkit. The fulfillment center can view the Literature record, but cannot
view the Literature Item records. To let the fulfillment center know which items
make up the Kkit, you can:

= Pack kits together at the fulfillment center. For example, you have a kit named
Sales Promo that includes a brochure and a hat. The brochure and hat might be
be shrink wrapped together at the fulfillment center or they might be stored in
one bin at the fulfillment center, so the fulfillment center can select one of each
item in the bin. Then, when the fulfillment center sees that they must fulfill the
Sales Promo literature record, they would mail out this shrink-wrapped package
or the items from this bin.
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= Make the Literature record a bill of materials. You can include a document in the
Literature record that describes all the Literature Items in the kit, or use the
Literature records Description or Synopsis field to list all the Literature Items in
the kit. For example, if the kit consists of a sales brochure and a hat, you would
create a Literature record that represents the entire kit, you would attach two
Literature Item records to it that represent the brochure and the hat, and you
might also use the description field of the Literature record to say the kit includes
a brochure and a hat. Then the fulfillment center would read the description
field and mail out the items listed.

To add a literature item kit

1 From the application-level menu, choose View > Site Map > Document
Administration > Literature.

2 In the Literature list, add a new record, or select an existing record. This record
represents the literature item kit, so you should give it a name that indicates the
kit contents.

3 Click the Literature Items tab.

The fields previously displayed in More Info are shown under the Literature list
at the top. The fields in the Literature Items list, in the middle of the view,
display specific item information. The Component Items list appears at the
bottom of the view.

4 1In the Literature Items list, add a record and complete the necessary fields.

Some fields are described in the following table.

Field Comments

Primary Indicates whether this is the primary item in the kit.

Physical Form A description of the item’s physical form. This field supports
multiple values to allow for multiple physical forms. For a document,
you might choose 8 1/2 x 11 and Microfiche.

# of Pages The number of pages in the document, if applicable.
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Field Comments

In Stock Select the check box to specify whether the item is in stock, if
applicable.

Part # The item’s part number, if applicable.

5 In the Component Items list, add a new record.
6 Select the record to be added, and then click Add.

7 Inthe Component Items list, add any other new records that are needed to create
the kit.
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About Making Literature Visible to Users

You can make literature visible to users in the following ways:

Version 7.5, Rev. C

The Products Screen. You can associate literature with a product, and the user can
display it using the Products screen.

The Competitors Screen. You can associate literature with a competitor, and the
user can display it using the Competitors screen.

The Decision Issues Screen. You can associate literature with a decision issue, and
the user can display it using the Decision Issues screen.

The Correspondence Screen. You can deselect the Internal field of a literature
record and the user can select it as an enclosure in correspondence.

eBriefings. You can associate literature with an account competitor, product, or
industry. Literature is displayed in the Account Briefing, Competitor Briefing, or
My Briefing page as a hyperlink.

The Literature Screen or Infocenter. You can make literature visible to users, so it
is included in the list of literature that they display in the Literature or Infocenter
screen.
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Sharing Literature Through the Products Screen

End users who are salespeople find it useful to view literature about your products
when they are viewing other information about the products. If you associate
literature with a product, end users can view this literature when they view the
product record in the Products screen.

To share literature through the Products screen

1 From the application-level menu, choose View > Site Map > Document
Administration > Literature.

2 In the Literature list, select a literature record or add a new literature record.
3 In the More Info form, click the select button in the Products field.

4 In the dialog box, select a Product and Part # to be associated with the literature
record, and then click OK.

If no Products were previously associated with the literature record, you can use
the Associated Products dialog to set up a new association.
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Sharing Literature Through the Competitors Screen

Salespeople find it useful to view their competitors’ literature or to view literature
that your company has prepared that compares your products with your
competitors. If you associate literature with a competitor, end users can view this
literature when they view the competitor record in the Competitors screen.

To share literature through the Competitors screen, you must associate it with a
competitor. You must also decide whether to select the Internal flag, which
determines whether it is displayed in the Comparative Literature List or the
Competitive Literature list of the Competitors screen:

If you select the Internal flag, the literature will appear in the Comparative
Literature list, and it will not be available as an enclosure in the Correspondence
screen.

If you do not select the Internal flag, the literature will appear in the Competitive
Literature list, and it will be available as an enclosure in the Correspondence
screen.

Whether you select Internal depends on what type of literature it is:
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Competitors’ literature. Your salespeople may want to use literature produced by
competitors, such as sales brochures, to help them compare your products with
what the competition is offering, However, you would not want to distribute this
literature outside your company. You should select Internal, so the literature will
not be available in the Enclosures list of the Correspondence screen, but it will
appear in the Comparative Literature in the Competitors screen.

Comparative literature for internal use. You may develop comparative literature
internally, such as competitive intelligence, that is meant for use by your sales
people and that you do not want to distribute outside your company. You should
select Internal, so the literature will not be available in the Enclosures list of the
Correspondence screen, but it will appear in Comparative Literature in the
Competitors screen.
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Comparative literature for external use. You may develop comparative literature
internally that is aimed at your customers, or you may have third party
comparative reports that you want to distribute to your customers. You should
not select Internal, so the literature will be available in the Enclosures list of the
Correspondence screen, and it will also appear in Competitive Literature in the
Competitors screen.

To share literature through the Competitors screen

1

From the application-level menu, choose View > Site Map > Document
Administration > Literature.

In the Literature list, select a literature record or add a new literature record.
In the More Info form, click the select button in the Competitors field.

If the competitors that you want to list appear in the dialog box, select the
competitors, and then click Close.

If the specific competitors are not listed in the dialog box, click New.

The Competitors dialog box changes, now listing all possible competitors. You
can use the Find button to locate a specific company.

In the Competitors dialog box, select the competitors and click OK.

When users display this competitor record in the Competitors screen, they will
be able to display the literature in Comparative Literature list if you selected
Internal or in the Competitive Literature list if you did not select Internal.
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Sharing Literature Through the Decision Issues Screen

End users who are salespeople find it useful to view literature about a decision issue
when they are viewing other information about the decision issue. If you associate
literature with a decision issue, end users can view this literature when they view
the decision issue.

To share literature through the Decision Issues screen

1 From the application-level menu, choose View > Site Map > Data
Administration > Decision Issues.

2 In the Decision Issues list, select the decision issue that you want to associate
the literature with.

The More Info list shows information about the issue. Existing literature records
are listed under the Literature tab.

3 In the Literature list, add a new record.

4 Select the literature item that you want to associate with the decision issue, and
click OK.

The Literature list shows the selected literature item.
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Sharing Literature Through the Correspondence Screen

End users may want to use literature as enclosures in correspondence. They may
also use literature records that represent literature item Kkits as enclosures in
correspondence.

Literature is available to users in the correspondence screen if the Internal field of
the Literature record is not selected.

To share literature through the Correspondence screen

1 From the application-level menu, choose View > Site Map > Document
Administration > Literature.

2 In the Literature list, select a literature record or add a new literature record.
Make sure the Internal field of this record is not selected.

When users create correspondence, they will be able to add this literature as an
enclosure.
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Sharing Literature Through eBriefings

Siebel eBriefings are personalized pages that combine information from the Siebel
database, such as links with a user’s new opportunities or new service requests,
with background information about businesses the user works with. The user can
choose which customer accounts and competitors to track, and information about
those businesses will appear in the Account Briefing and Competitor Briefing view
of that user’s eBriefings screen. You can include links to literature about the account
or competitor.

To share literature through eBriefings, you can associate it with Accounts,
Competitors, Industries, or Products.

For more information about Briefings, see Siebel eBriefings Administration Guide.

To share literature through eBriefings

1 From the application-level menu, choose View > Site Map > Document
Administration > Literature.

2 In the Literature list, select a literature record or add a new literature record.

3 If you want to display the literature in Account Briefings, in the More Info
Accounts field, select the accounts with which the literature is associated. The
end users who are tracking that account will see the literature item in the
Account Briefing.

4 If you want to display the literature in Competitor Briefings, in the More Info
form’s Accounts field, select the competitors with which the literature is
associated. End users must track that competitor for it to appear in Competitor
Briefing.

5 In the Release Date field, enter the first date when the literature will appear in
briefings. Literature associated with products or industries appears in My
Briefing if the end user tracks those products and industries.

6 In the Expiration Data field, enter the last date that you want the literature to
appear in briefings.
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Sharing Literature Through Literature or Infocenter

Your end users may work with literature by displaying the Literature screen or
Infocenter screen and searching the Literature list in that screen for the piece of
literature they need.

You generally share literature with users by associating the user with access groups
and associating literature with categories. Before you can do this, you must create
categories that include literature, create access groups that include end users, and
associate the categories with the access groups. For more information, see Security
Guide for Siebel eBusiness Applications.

After you have completed this preliminary work, you can assign literature to end
users as follows:

= When you produce new literature, associate it with the appropriate category and
it will be visible to all end users in access groups associated with that category.

= When you hire new employees, associate them to with the appropriate access
group and they will have visibility to all the literature in categories associated
with that category.

A business manager who administers literature makes it visible to users by
associating it with the appropriate category in either the Literature Administration
screen or the Catalog Administration screen. After it is assigned in either of these
ways, users in access groups associated with this category will be able to display it
in the Literature screen.

To associate literature with a category using the Literature Administration screen

1 From the application-level menu, choose View > Site Map > Document
Administration > Literature.

2 In the Literature list, select the record for the literature you want to associate
with a category.

3 In the Category form, add a new record.

4 1In the dialog box, select the item to be associated with the category, and then
click OK.

The literature is associated with the category.
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To associate literature with a category using the Catalog Administration screen

1
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From the application-level menu, choose View > Site Map > Catalog
Administration > Catalog Administration.

In the Catalogs list, drill down on the Name of the catalog to be associated with
the literature.

A Categories list appears.
Click the Literature view tab.
In the Literature list, add a new record.

In the dialog box, enter identifying information about the literature (for example,
the document Name), and then click Go.

When the dialog box reappears listing the needed literature, select the literature
item and click OK.

The literature is associated with the category.
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This chapter describes the integration of D&B data with your Siebel application.
Some topics included in this chapter are:

Version 7.5, Rev. C

Business scenarios for using D&B data within your Siebel application.
Overview information about loading D&B data into the Siebel database.

Procedures for setting up the symbolic URL to allow real-time searches and on-
line report access.

Maps of D&B data to Siebel data fields.
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About D&B Data

D&B is a leading provider of business information. D&B’s information and
technology solutions help businesses find profitable customers, reduce credit risk,
manage receivables, and manage vendors. D&B’s database of commercial
information consists of over 75 million records world wide.

For connected users, you can use your Siebel application to integrate with D&B data
and reports. As a mobile client, you can access D&B data for accounts and contacts
that have been promoted from D&B marketing data.

This allows you to:

s Use D&B marketing data within your Siebel application.

m  Access D&B business and credit reports from within your Siebel application.
You can use this D&B data to support the following:

= New Business or Customer Acquisition. By querying on company size, line of
business, and other criteria provided by D&B, you can generate lists of prospects
to add to the sales pipeline or to support outbound marketing programs. By
using the D&B corporate family linkage information, you can identify new
prospects and opportunities within a company’s extended family.

= Customer Segmentation and Penetration. You can profile specific market segments
such as geography, industry, size, and other criteria to identify untapped
opportunities or better align sales territories.

= Customer Qualification. Use your access to D&B business and credit reports to
obtain detailed background and risk information on a company in order to focus
sales efforts on higher-probability accounts and shorten the sales cycle.

NOTE: This chapter describes how the administrator loads and updates D&B data.
For information about viewing and using D&B data within the Siebel application,
see Siebel Sales User Guide.
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Business Scenarios

The following scenarios describe how you can use D&B data in your company.

Build and Grow Current Customer Relationships

D&B data can help you find out how many relationships you already have within
the complete corporate family structure. Use the D&B D-U-N-S number to view the
organizational hierarchy of your clients and also to aggregate account attributes at
all levels within your clients.

For example, you are selling to 20 IBM locations and you find out that there are
locations that you have never contacted.

Following the completion of a successful sales engagement, use D&B demographic
data to query your existing customer base for other customers in the same industry
who are approximately the same size. This gives you a targeted population for
replicating the success and driving revenue.

New Business or Customer Acquisition

Despite best efforts by an organization’s marketing department, the sales
organization is constantly asking for more leads. To partially address the issue, the
company provides all salespeople access to the companies in the D&B database so
they can generate prospects in their territory.

Individual salespeople can query the D&B database using criteria matching their
ideal target to find new leads. After generating a list of leads, salespeople can
automatically add the companies and contacts to their accounts.

Additionally, D&B demographic data can be used to analyze customer buying habits
and then applied to the business universe to provide targeted marketing lists for
specific campaigns or for distribution to the sales force.

Customer Satisfaction and Account Planning

Standardizing customer information on the D&B D-U-N-S number gives you a
means for house-holding your customer data and eliminating duplicate customer
records. This increases your ability to manage existing customer relationships
because all opportunities for a customer are linked to the same customer record.
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Add D&B’s corporate family linkage, and you have the ability to manage and plan
for customers at a local and global level. For example, you may want to see a roll
up of all opportunities and potential revenue for all companies and locations related
to Coca-Cola worldwide.
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Understanding the D&B D-U-N-S Number

The D-U-N-S (Data Universal Numbering System) number is a crucial component
of D&B data. A D&B D-U-N-S number is a nonindicative, nine-digit number assigned
to each business location in the D&B database. Each D-U-N-S number has a unique,
separate, and distinct operation, and is maintained solely by D&B. Industries and

organizations around the world use the D&B D-U-N-S number as a global standard
for business identification and tracking.

Each company has a unique D&B D-U-N-S number associated with it. It acts as a
unique identifier for a company in the D&B database.

To uniquely identify the association between different companies in the D&B
database, each company also has associated D&B D-U-N-S numbers.

Several categories of D&B D-U-N-S numbers exist:

»  D&B D-U-N-S Number—each unique business location listed in the D&B
database is assigned a D&B D-U-N-S number. This column is called simply DUNS
Number in your Siebel application.

= Global Ultimate D-U-N-S—the D&B D-U-N-S number belonging to a business’s
worldwide ultimate parent company.

s Domestic Ultimate D-U-N-S—the D&B D-U-N-S number belonging to the
highest-level family member within a specific country.

» Parent/HQ D-U-N-S—the D&B D-U-N-S number belonging to a business’s
immediate headquarters or parent.

These numbers allow D&B to establish the relationships between different
companies.
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Process for Integrating D&B Data

The process of integrating D&B data into the D&B Account tables and the Siebel
Account tables in the Siebel database involves the following steps:

= Obtaining D&B Data
» Loading D&B Data into staging tables in the Siebel database

= Running the Siebel Update Server Components
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Obtaining D&B Data

You must obtain three data files from D&B:
»  The Marketing Data file

m  The MRC file

= The SIC file

Request these files in Siebel format, also referred to as 2202 or GDMDI data file
format. D&B should be able to provide files in this format without difficulty.

To obtain MRC and SIC files, send email to:
dnb4siebel@dnb.com

In addition to these files, you can request D&B data layout documentation from
D&B.

The Marketing Data File. This file contains detailed company information, such as the
company’s legal name, address, contact information, and so forth.

The MRC and SIC Files. These are both reference files required by the Siebel D&B
modules. Both files contain information referenced by the demographic company
data provided by D&B.

MRC stands for Management Responsibility Code. The MRC file contains a list of
lookup values for the contacts and their positions such as CEO, Vice President of
Marketing, and so on. Each contact has an associated numerical code that is
referenced by the D&B marketing data to determine the title or position of a
company contact.

SIC stands for Standard Industrial Classification, and is a code developed by the
Federal government to describe the type of activity performed by the business at
this location. The SIC file contains a list of SIC codes assigned and maintained by
D&B along with their definitions. D&B’s Primary SIC code indicates the line of
business that provides the largest revenue contribution to the business. D&B also
maintains and assigns six levels of subsidiary SIC codes to describe in greater detail
additional lines of business activity for a given company. By default, the SIC code
provided in the SIC file and the Marketing Data file is the 4-digit SIC code.
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Loading D&B Data

After you have obtained the three D&B data files, you can start to load the data into
the Siebel database. You can load the files in any order, but you must load all three
files before running the Siebel update server component.

When creating your data loading scripts, refer to the documentation provided by
D&B and to Siebel Data Model Reference.

The scripts and processes differ according to your database platform.

NOTE: When you integrate D&B data for the first time, you may want to contact
Siebel Professional Services to obtain sample loading scripts for use as templates.
See “Loading D&B Data Using Sample Scripts” on page 444.

The scripts load D&B data into staging tables in the Siebel database, as shown in
Table 30.

Table 30. Staging Tables for Uploading D&B Data

File Upload Location

Marketing Data file = S_DNB_UPDATE table

This table is used as a staging area for the un-normalized D&B
Marketing data.

SIC file S_DNB_SIC table
MRC file S_DNB_MRC table

NOTE: Definitions of these tables can be found in Siebel Data Model Reference.

Because SIC and MRC files change only rarely, updating D&B data usually requires
deleting and reloading the D&B marketing data in the S_DNB_UPDATE table alone.

If you need to load new versions of the SIC and MRC files, you must delete the
previously used staging tables.
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Table 31 lists what D&B data to delete and what to load.

Table 31. Loading or Reloading D&B Data

If You Are...

Loading D&B data for the first time

Updating D&B data with a new
Marketing Data file, but the SIC and
MRC files have not changed

Updating D&B data with new
Marketing Data, SIC, and MRC files

Then...

Load the three D&B data files: Marketing Data
file, SIC file, and MRC file.

Delete data from the S_DNB_UPDATE table.
Load the Marketing file.

Delete data from the S_DNB_UPDATE, the
S_DNB_SIC, and the S_DNB_MRC tables.

Load the three D&B data files: Marketing Data
file, SIC file, and MRC file.

After loading files, you must run the D&B Update Manager (D&B) and the D&B
Update Manager (Siebel) as described in “About Siebel Update Server Components”

on page 448.
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Loading D&B Data Using Sample Scripts

This section provides some guidance on how to load D&B data on Oracle, DB2, and
Microsoft SQL Server platforms using sample scripts. These scripts are not provided
as part of the Siebel product, but may be obtained from Siebel Professional Services.

CAUTION: Before running scripts, you should check them against the D&B data layout
documentation and against the S_DNB_UPDATE table columns documented in
Siebel Data Model Reference. Then, modify the scripts as required.

Loading D&B Data on Oracle

Oracle installations require you to run SQLLOADER control files. You need the
following control files:

= s_dnb_update.ctl (for loading Marketing Data file into S_DNB_UPDATE table)
m s_dnb_sic.ctl (only required if loading the SIC file)
m s_dnb_mrc.ctl (only required if loading the MRC file)

NOTE: This procedure is based on the assumption that you understand how to run
SQLLOADER. SQLLOADER is described in the Oracle documentation.

To load D&B data if you are using Oracle

1 Verify that the column order of your D&B file matches the column requirements
in the .ctl file before running the loading script.

2 Truncate the appropriate staging tables (see Table 31 on page 443).

To optimize loading performance, drop all indexes on the S_DNB_UPDATE table
and re-create them after the scripts have completed. This can be done using
Siebel utilities ddlexp (to back up the indexes before dropping) and ddlimp (to
re-create them).

3 Modify the .sql file as appropriate for:

= The name of your database
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= The D&B filename and directory location
= The database table owner

= The user ID and password (with loading privileges) that you are using to load
the data

4 Run SQLLOADER.

Loading D&B Data on DB2
DB2 installations require you to run DB2 IMPORT. You need the following .sql files:

» imp_update_new.sql (for loading Marketing Data file into S_DNB_UPDATE
table)

m imp_sic_new.sql (only required if loading the SIC file)

m imp_mrc_new.sql (only required if loading the MRC file)

NOTE: This procedure is based on the assumption that you understand how to run
DB2 IMPORT. DB2 IMPORT is described in the DB2 documentation.

To load D&B data if you are using DB2

1 Verify that the column order of your D&B file matches the column requirements
in the .sql file before running the loading script.

2 Truncate the appropriate staging tables (see Table 31 on page 443).

To optimize loading performance, drop all indexes on the S_DNB_UPDATE table
and re-create them after the scripts have completed. This can be done using
Siebel utilities ddlexp (to back up the indexes before dropping) and ddlimp (to
re-create them).

3 Modify the .sql file as appropriate for:
= The name of your database
» The D&B filenames and directory location

= The database table owner
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= The user ID and password (with loading privileges) that you are using to load
the data

4 Run DB2 IMPORT.

5 Optional: After running the import scripts, update the DB2 catalog statistics by
executing RUNSTATS on the three tables that received the D&B data
(S_DNB_MRC, S_DNB_SIC, S_DNB_UPDATE).

Loading D&B Data on Microsoft SQL Server

Microsoft SQL Server installations require you to run SQL scripts. You need the
following format files and SQL scripts:

m For loading the Marketing Data file:

= S_DNB_UPDATE.fmt—a format file to load the data into the
tempS_DNB_UPDATE table

= S_DNB_UPDATE.sql—an SQL script that loads the data into S_DNB_UPDATE
table

m For loading the SIC file:
= S_DNB_SIC.fmt—a format file to load the data into the tempS_DNB_SIC table
= S_DNB_SIC.sql—an SQL script that loads the data into the S_DNB_SIC table
m For loading the MRC file:

= S_DNB_MRC.fmt—a format file to load the data into the tempS_DNB_MRC
table

= S_DNB_MRC.sql—an SQL script that loads the data into the S_DNB_MRC
table

NOTE: This procedure is based on the assumption that you understand how to run
bep (bulk copy process) or similar data-loading utility. The bcp utility is described
in the Microsoft SQL Server documentation.
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To load D&B data if you are using Microsoft SQL Server

1
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Verify that the column order of your D&B file matches the column requirements
in the .sql file before running the loading script.

Truncate the appropriate staging tables (see Table 31 on page 443).

To optimize loading performance, drop all indexes on the S_DNB_UPDATE table
and re-create them after the scripts have completed. This can be done using
Siebel utilities ddlexp (to back up the indexes before dropping) and ddlimp (to
re-create them).

Modify the .sql file as appropriate for:

= The name of your database

= The D&B filename and directory location
= The database table owner

= The user ID and password (with loading privileges) that you are using to load
the data

Run bcp or another data loading utility.
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About Siebel Update Server Components

Whenever you load or reload D&B data, you must update the D&B Account tables
and the Siebel Account tables in the Siebel database. This update is accomplished
by running server components:

D&B Update Manager (D&B): Moving D&B marketing data from the staging table
(S_DNB_UPDATE) into the normalized D&B Account tables, which are the basis
for the D&B All Accounts View (Figure 19 on page 450).

D&B Update Manager (Siebel): Updating the records in the Siebel Account tables
for accounts with matching D-U-N-S numbers (Figure 20 on page 451).

A third component, D&B Update Manager MultiTask, is also provided. This
component can be used in place of D&B Update Manager (D&B) or D&B Update
Manager (Siebel) to run the update using multiple, parallel processes (“About
the Multiple Task Siebel Update Server Component” on page 451).

Overview of the Update Process
This section outlines the process of loading D&B data from the staging tables to the
D&B Account tables and through to updating the Siebel account tables.

This process recommends using the D&B Update Manager MultiTask server
component to run server component tasks in parallel. However, use of the single
task D&B Update Manager (D&B) and D&B Update Manager (Siebel) server
components is also documented in this chapter.

1

Make sure you have loaded the D&B data into the staging tables as discussed in
“Loading D&B Data” on page 442 and “Loading D&B Data Using Sample Scripts”
on page 444.

Update the D&B Account tables with data from the staging tables:
= To optimize performance, you may choose to do one of the following:

o For first time data loading, that is, when there are no D&B records in the
database, drop the indexes on these D&B Account tables: S_DNB_ORG,
S_DNB_ORG_SIC, S_DNB_CON_MRC, and S_PRSP_CONTACT.
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o For subsequent updates, drop the indexes on the S_DNB_ORG table only,
all except for the indexes S_DNB_ORG_U1 (DUNS_NUM),
S_DNB_ORG_P1 (ROW_ID), and S_DNB_ORG_MO01 (the clustered index)
on this table.

= Create a search specification on the D-U-N-S number to set up your preferred
batch sizes and determine the corresponding D-U-N-S number ranges per
batch for loading the data from the staging tables to the D&B Account tables.

= Execute concurrent D&B Update Manager (D&B) server tasks by running the
D&B Update Manager MultiTask server component. See “About the Multiple
Task Siebel Update Server Component” on page 451 and “Running the Siebel
Update Server Components” on page 455.

= Continue to execute the concurrent D&B Update Manager (D&B) server tasks
until all data is loaded into the D&B Account tables.

» If you dropped indexes on the D&B Account tables, re-create them. This can
be done using Siebel utilities ddlexp (to back up the indexes before dropping)
and ddlimp (to re-create them).

Update the Siebel Account tables from the D&B Account tables for accounts with
matching D-U-N-S numbers by executing concurrent D&B Update Manager
(Siebel) server tasks using the D&B Update Manager MultiTask server
component. See “Multiple D&B Update Manager (Siebel) Processes” on

page 453 and “Running the Siebel Update Server Components” on page 455.
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About the Single Task Siebel Update Server Components

The update server components are part of the Dun and Bradstreet Enterprise
Component Group. This group and each of its D&B Batch Components must be
enabled. Once enabled, each component can be run as a batch task. Figure 19
shows how the staging tables are mapped to the D&B Account tables.

Staging Tables D&B Account Tables
5_DMEBE_SIC table S_DMB_DORG_SIC table
—
b S_DNE_DORG table
D&B Update
S _DME UPDATE table —m Manager —
[D&B)
F—w S_PRSP_CONTACT table
—
=_DMNB_MRC table =_DMB_COMN_MRC table

Figure 19. D&B Update Manager (D&B) Table Names
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Figure 20 shows how the D&B Account tables are mapped to the Siebel Account

tables.
[&B Account Tables Siebel Account Tables
5_DNB_DORG_SIC table  —, —w 5 0ORG_INDUST table
j—— D&E Update — S _PARTY tables including
S DNB ORGtable |— w  Manager — =_ORG_EAT,
LB (Siehglj S ORG_EXT ¥, and
— — S CONTACT
S_PREP_CONTACT ] ) s S ADDR ORG table

tahle

Figure 20. D&B Update Manager (Siebel) Table Names

“Field Mapping for the D&B Update Manager Process” on page 466 lists the default
table mapping from the D&B Account tables to the Siebel Account tables that are
used by the D&B Update Manager (Siebel) server component.

About the Multiple Task Siebel Update Server Component

You can use the server component DNBUpMgrMultiTask to spawn multiple Update
Manager processes. Running several parallel processes helps you maximize your
performance with large data loads and gives you greater scheduling flexibility. You
can control the number of processes that are created by editing the dnbtask.cfg file.
The dnbtask.cfg file contains two sections, one to set tasks for the D&B Update
Manager (D&B) process and the second to set tasks for the D&B Update Manager
(Siebel) process.

Version 7.5, Rev. C Applications Administration Guide 451



\ D&B Integration

About Siebel Update Server Components

The dnbtask.cfg file is located in the sqltempl subdirectory, in the server installation
directory.

Multiple D&B Update Manager (D&B) Processes

By default the dnbtask.cfg file sets up three simultaneous tasks, based on D-U-N-§
number ranges. The DNBUpMgrDNB portion of the file looks like this:

[ DNB]

Task1l

, 100000000
Task2 = 100000000, 200000000

Task3

200000000,

These four ranges translate into four DNBUpMgrDNB tasks, each taking care of
loading records within a particular D-U-N-S number range:

,L100000000 means D-U-N-S numbers < 100000000
100000000,200000000 means D-U-N-S numbers > =100000000 and < 200000000
200000000, means D-U-N-S numbers > =200000000

Edit the file to change the number of parallel processes created or the range of
D-U-N-S numbers updated.

CAUTION: If you use DNBUpMgrMultiTask to run multiple UpdateMgr processes, you
must make sure that processes running at the same time have mutually exclusive
ranges. Unpredictable results will occur if multiple processes collide.

Multiple D&B Update Manager (D&B) Processes with First Time
Data Loading

The first time you load D&B data, that is, when there are no D&B records in the
database, you may use a special .sql file (dnbinitial.sql) which is optimized to do
only inserts. This results in faster loading of data than using the dnbmaps.tsq file.
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To use the dnbinitial.sql file, set the server component parameter DNBConfigFile to
dnbinitial.sql. (For examples, see Step 4 in the “To run the D&B Update Manager
(D&B) server component from within your Siebel application (multiple task
process)” procedure on page 457 and Step 2 in the “To run the D&B Update
Manager (D&B) server component from a command line (single or multiple task
process)” procedure on page 458.) This can be done from Server Manager or from
your Siebel application.

For subsequent updates, the DNBConfigFile should be set to dnbmaps.tsq.

NOTE: The dnbinitial.sql file assumes that you dropped the indexes on the D&B
Account tables (Step 2 in the “To load D&B data if you are using Microsoft SQL
Server” procedure on page 448).

Multiple D&B Update Manager (Siebel) Processes
By default the dnbtask.cfg file sets up five simultaneous tasks, based on tables
updated. The DNBUpMgrSieb portion of the file looks like this:

[ Si ebel ]

Task1l

UPDATE_SI EBEL_ ACCOUNT

Task2 = UPDATE_I NDUST, COWM T, UPDATE_SI EBEL_| NDUST, COW T,
UPDATE_SI EBEL_SYNONYM

Task3 = UPDATE_SI EBEL_ADDR PHY, COVWM T, UPDATE_SI EBEL_ADDR MAI L

Task4

UPDATE_SI EBEL_CONTACT

Task5 = UPDATE_SI EBEL_LOC1, COW T, UPDATE_SI EBEL_LOC2, COW T,
UPDATE_SI EBEL_LOC3
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You may edit the file to change the number of parallel processes created. However,
note that the order of the updates within individual tasks is important; for example
UPDATE_INDUST should be done before UPDATE_SIEBEL_INDUST. Use caution
when updating the DNBUpMgrSieb portion of the dnbtask.cfg file.

CAUTION: If you have modified the RTI configuration file to insert new accounts into
the Siebel Accounts table, do not run the multiple task process. Instead you must
run the single task D&B Update Mgr (Siebel) server component. Make sure you have
modified the dnbmaps.sql file used by the single task server component. The order
of the updates is critical to data integrity if new accounts are being added.
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Running the Siebel Update Server Components

There are two ways to run the Siebel update server components:
= From within the Siebel application
m From a command line interface, using Server Manager

Procedures for running the update processes from both within the Siebel
application and from the command line. (Whatever procedures you choose to
follow, make sure that the D&B Update Manager (D&B) process is complete before
you start the D&B Update Manager (Siebel) process.)

= “To run the D&B Update Manager (D&B) server component from within your
Siebel application (single task process)” on page 456

= “To run the D&B Update Manager (D&B) server component from within your
Siebel application (multiple task process)” on page 457

= “To run the D&B Update Manager (Siebel) server component from within your
Siebel application (single task process)” on page 457

= “To run the D&B Update Manager (Siebel) server component from within your
Siebel application (multiple task process)” on page 458

= “To run the D&B Update Manager (D&B) server component from a command
line (single or multiple task process)” on page 458
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= “To run the D&B Update Manager (Siebel) server component from a command
line (single or multiple task process)” on page 459

NOTE: If you have just installed the Siebel Server or if you have made changes to the
Siebel Name Server, you need to synchronize before running the Siebel update
server component. For more information about synchronizing server components,
see Siebel Server Administration Guide.

TIP: If you are going to run the D&B Update Mgr (Multi-task) component, make sure
that the maximum number of tasks (MaxTasks parameter) is set correctly to
accommodate the number of tasks that you specified in the dnbtask.cfg file. For
information about MaxTasks, see Siebel Server Administration Guide.

To run the D&B Update Manager (D&B) server component from within your Siebel
application (single task process)

1 Check the state and mode for the Update Mgr component:

a From the application-level menu, choose View > Site Map > Server
Administration > Enterprise Configuration.

b Click the Enterprise Component Groups view tab.

¢ In the Enterprise Component Groups list, select the Dun and Bradstreet
component group.

d For the Dun and Bradstreet record, make sure that the state is Enabled.

If it is not enabled, enable it by clicking the menu button in the Enterprise
Component Groups list and clicking Enable Component Group. Then
synchronize. For more information on enabling component groups and
synchronizing server components, see Siebel Server Administration Guide.

2 From the Show drop-down list, select Enterprise Operations.
3 Click the Component Requests view tab.

4 In the Component Requests list, click New.
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5 In the Component Requests form, in the Component/ Job field, select D&B
Update Mgr (D&B). Make sure the Mode is set to Asynchronous.

6 In the Component Requests form, click the menu button and click Submit
Request.

7 When the D&B Update Mgr (D&B) is done, open the log directory. If there have
been problems with the process, there will be a log file, which you should
review. The log file is named DNBUpMgrDNB_TaskNumber.log.

To run the D&B Update Manager (D&B) server component from within your Siebel
application (multiple task process)

1 Follow Step 1 to Step 4 in the “To run the D&B Update Manager (D&B) server
component from within your Siebel application (single task process)” procedure
on page 456.

2 In the Component Requests form, in the Component/ Job field, select D&B
Update Mgr (Multi-task). Make sure the Mode is set to Asynchronous.

3 In the Component Request Parameters list, add a new record, set the Name field
to DNBTaskCode, and in the Value field enter DNB.

4 If data is being loaded for the first time, add a second new request parameters
record, set the Name field to DNBConfigFile and in the Value field enter
dnbinitial.sql

5 In the Component Requests form, click the menu button and click Submit
Request.

6 When the process is done, open the log directory. If there have been problems
with the process, there will be a log file, which you should review.

To run the D&B Update Manager (Siebel) server component from within your Siebel
application (single task process)

»  Follow the procedure “To run the D&B Update Manager (D&B) server component
from within your Siebel application (single task process)” on page 456, except
that at Step 5, set the Component/ Job field to D&B Update Mgr (Siebel).
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To run the D&B Update Manager (Siebel) server component from within your Siebel
application (multiple task process)

1

Follow Step 1 to Step 4 in the “To run the D&B Update Manager (D&B) server
component from within your Siebel application (single task process)” procedure
on page 456.

In the Component Requests form, in the Component/ Job field, select D&B
Update Mgr (Multi-task). Make sure the Mode is set to Asynchronous.

In the Component Request Parameters list, add a new record, set the Name field
to DNBTaskCode and in the Value field enter Siebel.

In the Component Requests form, click the menu button and click Submit
Request.

When the process is done, open the log directory. If there have been problems
with the process, there will be a log file, which you should review.

To run the D&B Update Manager (D&B) server component from a command line
(single or multiple task process)

1

Log in to the server using Server Manager. Use a command with this format:

SI EBEL_ROOT\ si ebsrvr\bi n\>srvrngr /g gateway /e enterprise_nane /
u db_usernane /p password /s siebserver

Examples:
>srvrngr /g evlab6 /e siebel /u sadnin /p sadnmin /s evlab6

>srvrngr /g snte420s053: 2321 /e siebel /u sadmin /p sadmin /s
snt e420s053

2 At the srvrmgr prompt, enter one of the following commands:

= start task for conp DNBUpMyr DNB (for single task process)

= start task for conp DNBUpMyr Ml ti Task wit h DNBTaskCode=DNB (for
multitask process)

m start task for conp DNBUpMgrMul ti Task with DNBTaskCode=DNB,
DNBConf i gFi | e=dnbi nitial . sql (for initial data loading; see “Multiple
D&B Update Manager (D&B) Processes with First Time Data Loading” on
page 452)
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3 During the DNBUpMgrDNB or DNBUpMgrMultiTask server process, monitor the
status by entering the list task command:

list task for conp DNB%

4 When the D&B Update Mgr (D&B) or D&B Update Mgr (Multi-task) server
process is finished, open the log directory. If there have been problems with the
process, there will be a log file, which you should review. The log files are named
DNBUpMgrDNB_TaskNumber.log or DNBUpMgrMultiTask_TaskNumber.log.

To run the D&B Update Manager (Siebel) server component from a command line

(single or multiple task process)

= Follow the procedure “To run the D&B Update Manager (D&B) server component
from a command line (single or multiple task process).” At the srvrmgr prompt
(Step 2 in the “To run the D&B Update Manager (D&B) server component from
a command line (single or multiple task process)” procedure on page 458), enter
one of the following commands:

= start task for conp DNBUpMyr Sl EB (for single task process)

s start task for conp DNBUpMgrMul ti Task with DNBTaskCode=Si ebel
(for multitask process)
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Setting Up the Symbolic URL for Access to the D&B
Database

When you have a connection to the Internet and have a D&B account set up already
(with a user ID and password), you can:

= Obtain the most current account information by invoking real-time searches of
the D&B database and online purchase

m  Access and order D&B business and credit reports

For more information about D&B reports and about searching D&B for new
accounts, see Siebel Call Center User Guide.

To access D&B data live from your Siebel application through the D&B Web site, you
must first contact D&B for a user ID, password, and payment options. Then you can
set up your Siebel application to access the D&B database.

To set up the symbolic URL for D&B real-time search and update

1 From the application-level menu, choose View > Site Map > Integration
Administration > Symbolic URL Administration.

2 In the Symbolic URL list, select DNBGlobalAccess.
3 Make sure the URL is https://globalaccess.dnb.com/access/scripts/broker.asp
4 In the Symbolic URL Arguments list:

a Select the USERID record, and enter the user ID provided by D&B in the
Argument Value field.

NOTE: This field is not case-sensitive.

b Select the USERPASS record, and enter the password provided by D&B in the
Argument Value field.

To set up the symbolic URL for D&B report ordering

1 From the application-level menu, choose View > Site Map > Integration
Administration > Symbolic URL Administration.
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2 In the Symbolic URL list, select DNBReport.

3 Make sure the URL is https://reportserver/scripts/ProductRetriever and that the
Host Name is www.dnb.com.

4 In the Symbolic URL Arguments list:

a Select the USERID record, and enter the user ID provided by D&B in the
Argument Value field.

NOTE: This field is not case-sensitive.

b Select the USERPSWD record, and enter the password provided by D&B in
the Argument Value field.

5 From the Show drop-down list, select Host Administration.

6 In the HTTP Host list, make sure that there is a record where Name is
www.dnb.com and Virtual Name is reportserver.

NOTE: If you are using Siebel eBriefings and want to enable a link from briefing
documents to the D&B report ordering site, see Siebel eBriefings Administration
Guide.
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About Configuring D&B Integration

For general guidance on configuration, refer to Table 32.

Table 32. What to Configure?

If You Need to Customize the... Then...
Single task server processes for D&B » Edit the dnbmaps.sql file in the
Update Manager (D&B) or D&B Update ...\siebelserver\SQLTEMPL directory.

M Siebel . .
anager (Siebel) = Determine and make, if necessary,

corresponding changes for account
promotion.

Multiple task server processes for D&B = Edit the dnbmaps.tsq file in the
Update Manager (D&B) or D&B Update ...\siebelserver\SQLTEMPL directory.

M Siebel . .
anager (Siebel) = Determine and make, if necessary,

corresponding changes for account
promotion.

Account promotion = Configure the maps listed in Table 38.

= Determine and make, if necessary,
corresponding changes in the update
SEIver processes.

A number of specific configuration topics are discussed in this section:
= Update Server Process Configuration
»  Account Promotion and Prospect List Creation Configuration on page 463

= Running the D&B Update Manager (Siebel) Process Without Updating Account
Name or Account Location on page 464

Update Server Process Configuration

The D&B update server processes use the Batch Real-Time Integration (RTI)
technology and the RTI configuration files (dnbmaps.sql for single task and
dnbmaps.tsq for multiple tasks). You can edit the RTI configuration files to suit your
business requirements.

The general syntax of the RTI maps specified in the configuration files is as follows:
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UPDATE_SOVE_TABLE. MOD1TABLE = [Target Tabl e to update]

UPDATE_SOVE_TABLE. MOD1VWHERE [ A WHERE cl ause]

UPDATE_SOVE_TABLE. MODLI NSERT = [ TRUE/ FALSE]

UPDATE_SOVE_TABLE. MOD1UPDATE = [ TRUE/ FALSE]

UPDATE_SOVE_TABLE. MOD1DELETE = [ TRUE/ FALSE]

UPDATE_SOVE_TABLE. MOD1SQL = [A Valid SQL Query]

The RTI configuration files are located in the ...\siebelserver\SQLTEMPL directory.

“Field Mapping for the D&B Update Manager Process” on page 466 lists the default
mapping for the D&B Update Manager (Siebel) server component.

Use caution when making changes to these RTI configuration files. It is
recommended that you engage a qualified professional for your customization
process.

CAUTION: Do not change the default DELETE setting in the existing UPDATE*
sections. Do not set DELETE to TRUE. If your business need necessitates deleting
rows in the target table as part of the D&B Update Manager process, consult Siebel
Professional Services for help with this customization process.

Account Promotion and Prospect List Creation Configuration
You can select specific fields that will be populated by the D&B promotion to a
Siebel account or by the D&B list-creation process. These are controlled by maps in
the business component user properties within the DNB Account and DNB Contact
business components. These maps are listed in Table 38 on page 472.

Using Siebel Tools, you can change, add, or delete source and destination field
mapping. Reference the map descriptions given in Table 38 on page 472 to
determine which map to use for a given set of source and destination fields.
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Use caution when making changes to these maps. It is recommended that you
engage a qualified professional for your customization process.

CAUTION: Although the delete capability is available, it is recommended that you
deactivate unwanted map entries instead of deleting them. This is safer and can be
accomplished by checking or clicking the deactivate column for the undesired entry.

You can add an entry using the following syntax:

Name Col urm: [ MAP NAME]: [ DESTI NATI ON FI ELD]
Val ue Col umm: [ D&B SOURCE FI ELD]

NOTE: Each map works only with a specific Destination Business Component and a
specific Source Business Component.

Running the D&B Update Manager (Siebel) Process Without
Updating Account Name or Account Location

Depending on your business process, you may want to run the D&B Update
Manager (Siebel) server component without updating the existing account names
and account locations. This is done by editing the RTI configuration file.

TIP: When debugging in your test environment, increase the event log level to 4 to
see more details in the log file. However, it is strongly recommended that you set

the level to 1 (the default) when you run in a production environment in order to
prevent the log file from overflowing. For information on event logging, see Siebel
Server Administration Guide.

To edit the RTI configuration file so that account names are not updated

1 Open the RTI configuration file (dnbmaps.sql for single task or dnbmaps.tsq for
multiple task) in a text editor.

2 Search for UPDATE_SI EBEL_ACCOUNT. MOD1SQL under the Oracle, Microsoft SQL
Server, or DB2 SQL statements.
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3 Search for dnb. BUSI NESS_NAME within the UPDATE_SI EBEL_ ACCOUNT. MOD1SQL
SELECT statement.

4 Comment out the line that begins dnb.BUSINESS_NAME... as shown.
UPDATE_SI EBEL_ACCOUNT. MOD1SQL =
SELECT acct. RONI D ROW I D,
; dnb. BUSI NESS_NAME NANME,

5 Save and close the file.

To edit the RTI configuration file so that account locations are not updated (single
task)

1 Open the dnbmaps.sql file in a text editor.

2 Search for the UPDATE_SI EBEL = UPDATE_SI EBEL_ADDR_PHY...statement. This
statement specifies the Siebel Table Groups to be updated when D&B Update
Manager (Siebel) server component is run.

3 Within this statement, remove COVMM T, UPDATE_SI EBEL_LOCl1, COWM T,
UPDATE_SI EBEL_LOC2, COWM T, UPDATE_SI EBEL_LOC3.

4 Save and close the file.

To edit the RTI configuration file so that account locations are not updated
(multiple task)

1 Open the dnbtask.cfg file in a text editor.

2 Under the [ Si ebel ] section, comment out the line that begins Tasks5... as
shown.

;; Task5 = UPDATE_SI EBEL_LOC1, COMM T, UPDATE_SI EBEL_LOC2, COMWM T,
UPDATE_SI EBEL_LOC3

3 Save and close the file.
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Field Mappings for Configuration of D&B Integration

This section provides field mapping information for three types of D&B integration
processes:

» Field Mapping for the D&B Update Manager Process
m Field Mapping for D&B Real-Time Updates

= Field Mapping for Account Promotion and Prospect Lists

Field Mapping for the D&B Update Manager Process

D&B Update Manager (D&B) server component. For the table mapping for the D&B
Update Manager (D&B) component, examine the appropriate tables (Figure 19 on
page 450) using Siebel Tools. The default field mappings can be determined by
examining the UPDATE_DNB* sections of the RTI configuration file (dnbmaps.sql
or dnbmaps.tsq).

D&B Update Manager (Siebel) server component. When the D&B Update Manager
(Siebel) server component is run (Figure 20 on page 451), the fields listed in
Table 33, Table 34 on page 468, and Table 35 on page 468 are mapped. The field
mappings can also be determined by examining the UPDATE_SIEBEL* sections of
the RTI configuration file.

For information about changing these default mappings, see “Update Server Process
Configuration” on page 462.

Table 33. S_DNB_ORG Table Mapping for D&B Update Manager (Siebel)

From Column To Table To Column
DUNS_NUM S_ORG_EXT DUNS_NUMBER
BUSINESS_NAME S_ORG_EXT NAME
TRADESTYLE S_ORG_SYN NAME
SCND_TRADESTYLE S_ORG_SYN NAME
PHYS_STREET_ADDR S_ADDR_ORG ADDR
SECOND_STREET_ADDR S_ADDR_ORG ADDR
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Table 33. S_DNB_ORG Table Mapping for D&B Update Manager (Siebel)

From Column

PHYSICAL_CITY
PHYSICAL_STATE
PHYSICAL_ZIP
COUNTRY_NAME
COUNTY_NAME
MAIL_ADDRESS
MAIL_ADDRESS_2
MAIL_CITY
MAIL_STATE
MAIL_ZIP
TELEPHONE
FAX_NUMBER
ANNL_SLS_AMT
CURRENCY_CODE
EMPLOYEES_TOTAL
EMPLOYEES_HERE
YEAR_STARTED
LOC_TYPE_STAT_IND
PUBLIC_PRIVATE_IND
GLBLULT_DUNS_NUM
DOM_ULT_DUNS_NUM
PAR_DUNS_NUM
LINE_OF_BUSINESS
PCT_GROWTH_SLS_3YR

To Table

S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ADDR_ORG
S_ORG_EXT
S_ORG_EXT
S_ORG_EXT_X
S_ORG_EXT
S_ORG_EXT_X
S_ORG_EXT
S_ORG_EXT_X
S_ORG_EXT
S_ORG_EXT_X
S_ORG_EXT
S_ORG_EXT
S_ORG_EXT
S_ORG_EXT_X
S_ORG_EXT_X

To Column

CITY

PROVINCE or STATE
ZIPCODE

COUNTRY

COUNTY

ADDR

ADDR

CITY

STATE

ZIPCODE

PH_NUM
FAX_PH_NUM
ATTRIB_14
BASE_CURCY_CD
ATTRIB_26
EMP_COUNT
ATTRIB_27

included in LOC
ATTRIB_08
GLBLULT_DUNS_NUM
DOM_ULT_DUNS_NUM
PAR_DUNS_NUM
ATTRIB 03
ATTRIB_15
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The S_PRSP_CONTACT table contains information about the D&B contacts such as
the name of the CEO and various company executives. D&B provides up to four
contacts per D&B account.

Table 34. S_PRSP_CONTACT Table Mapping for D&B Update Manager

From Column To Table To Column
LAST_NAME S_CONTACT LAST_NAME
FST_NAME S_CONTACT FST_NAME
MID_NAME S_CONTACT MID_NAME
PER_TITLE S_CONTACT PER_TITLE
PER_TITLE_SUFFIX S_CONTACT PER_TITLE_SUFFIX
JOB_TITLE S_CONTACT JOB_TITLE
SEX_MF S_CONTACT SEX_MF

The S_DNB_ORG_SIC table contains the Standard Industrial Classification (SIC)
code developed by the US Government. The code is assigned to businesses and
other organizations by classifying and subdividing the activity performed by that
establishment at that location. D&B provides up to six SICs per D&B account. In the
D&B Update Manager process, the primary SIC code is mapped to the S_INDUST
table and all SIC codes are mapped to the S_ORG_INDUST table.

Table 35. S_DNB_ORG_SIC Table Mapping for D&B Update Manager

From Column To Table To Column
ROW_ID S_INDUST PR_INDUST_ID
S_ORG_INDUST INDUST_ID
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Table 36 describes how address and contact information is updated by the D&B
Update Manager (Siebel) process.

Table 36. Update Rules for Addresses and Contacts

If This D&B Information Changes... Then...

Street address A new address record is added to the
. Address table.

City

(Abbreviated) state

Address information other than street The address record is updated in the

address, city, or state Address table.

Phone number The address record is updated in the

Address table.
Fax number

Contact first name or A new contact record is added to the

Contact last name Contact table.

Contact information other than first or last = The contact record is updated in the Contact
name table.

Field Mapping for D&B Real-Time Updates

When you purchase account information through the D&B Web site using the D&B
real-time search and update feature in the Siebel application, certain fields in the
Siebel business components are populated. These fields are a subset of the fields
that are populated by the D&B Update Manager (D&B) server component. For
example, D&B does not provide the contact first, last, and middle names fields in
the real-time update.
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Table 37 lists the fields that may be populated or updated when you purchase
account information using the D&B real-time search and update feature.

Table 37. Fields Populated by D&B Real-Time Search and Update

D&B WorldBase Marketing Plus with
Linkage

Business Structure Code (Location
Type)

Domestic Ultimate Name

Global Ultimate Name

Parent/HQ Business Name

Physical State

Business Name

Trade Style

Street Address

Mail Address

City Name

Mail City Name

Physical State/Province Abbreviation
Mailing State/Province Abbreviation
ZIP/Postal Code

Mail Postal/ZIP Code

Country Name

D&B D-U-N-S Number

Telephone Number

Cable/Telex Code

Facsimile Number
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Siebel Business Component Name.Field Name

DNB Account.Location Type

DNB Account.Domestic Ultimate Business
Name

DNB Account.Global Ultimate Business Name
DNB Account.Parent HQ Name

DNB Account.State Name

DNB Account.Business Name

DNB Account.Trade Style

DNB Account.Physical Address

DNB Account.Mail Address

DNB Account.Physical City

DNB Account.Mail City

DNB Account.Physical State

DNB Account.Mail State

DNB Account.Physical Zip

DNB Account.Mail Zip

DNB Account.Country Name

DNB Account.DUNS Number

DNB Account.Main Phone 2

DNB Account.Cable Telex Number

DNB Account.Main Fax 2
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Table 37. Fields Populated by D&B Real-Time Search and Update

D&B WorldBase Marketing Plus with
Linkage

National ID

SIC Code

Primary Local Activity Code
Year Started

Employees Here

Employees Total

Annual Sales US Dollars
Annual Sales Local

Legal Status

Subsidiary Code

Import / Export / Agent Ind.
Global Ultimate D&B D-U-N-S Number
Global Ultimate Indicator

Global Ultimate WorldBase Country
Code

Domestic Ultimate D&B D-U-N-S
Number

Headquarter/Parent D&B D-U-N-S
Number

HQ/Parent WorldBase Country Code

Siebel Business Component Name.Field Name

DNB Account.National Identification Number 2
DNB Account.SIC Code

DNB Account.Primary Local Activity Code
DNB Account.Year Started 1

DNB Account.Employee Here

DNB Account.Employee Total

DNB Account.Sales Volume

DNB Account.Annual Sales Local Currency
DNB Account.Legal Status

DNB Account.Subsidiary Indicator

DNB Account.Import Export Code

DNB Account.Global Ultimate DUNS

DNB Account.Global Ultimate Indicator

DNB Account.Global Ultimate Country Code

DNB Account.Domestic Ultimate DUNS

DNB Account.Parent HQ DUNS

DNB Account.Parent/HQ Country Code

Field Mapping for Account Promotion and Prospect Lists

When end users promote D&B accounts or create prospect lists from the D&B
screen, fields in the DNB Account and DNB Contact business components are
mapped to fields in other business components. These maps are listed in Table 38
and can be viewed in detail in the Business Component User Properties window of

Siebel Tools.
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For information about promoting accounts and creating prospect lists, see Siebel
Sales User Guide.

Table 38. Maps of D&B to Siebel Fields for Promotion and List Creation

Siebel
User Property D&B Source Destination
Prefix and Map Business Business
Name Component Component Process and Description
Account Map DNB Account Account Promotion
Specifies the fields in DNB
Account that will be copied to
Account business component
Contact Map DNB Contact Contact Promotion
Specifies the fields in DNB
Contact that will be copied to
Contact business component
Mailing Address DNB Account Business Promotion
Map Address Specifies the mailing address
fields in DNB Account that will
be copied to Business Address
Physical Address DNB Account Business Promotion
Map Address Specifies the physical address
fields in DNB Account that will
be copied to Business Address
Prospect Info Map | DNB Contact List Mgmt Create Prospect List
Prospective Specifies the biological
Contact . .
information (such as last name,
first name, and so forth)
Prospect Contact DNB Account List Mgmt Create Prospect List
Info Map Prospective Specifies the contact information
Contact

(such as company, address,
phone number, and so forth)
fields in the DNB Account that
will be copied into the List Mgmt
Prospective Contact
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ASlIs allow you to integrate Siebel applications with other applications in real time.

The Accounts, Contacts, or Households screens use ASIs to exchange data with any
external system such as a back-office application. These are listed in Table 39.

You must set up these ASIs shipped with your Siebel application before they can be
used. This chapter provides the procedures that you must perform to set up these
ASIs. Depending on your business needs, you may choose to set up ASIs and
activate workflows for some or all of the GUI commands listed in Table 39.

For general information about ASIs, see Application Services Interface Reference.

Table 39. ASls for Accounts, Contacts, and Households

Screen

Accounts
Accounts (Credit
Profile view)

Contacts

Households

Outbound and End-User
GUI Command Workflow Inbound ASI Pairs Information
Update External Synchronize External Account Siebel Call Center

System

Refresh

Update External
System

Update External
System

Account ASI

Get Account ASI

Synchronize
Contact ASI

Synchronize
Household ASI

Siebel Account

External Contact
Siebel Contact

External
Household

Siebel Household

User Guide

Siebel Sales User
Guide

Siebel Call Center
User Guide

Siebel Sales User
Guide

Siebel Call Center
User Guide
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Setting Up Account, Contact, and Household ASls

This section describes how to set up the prebuilt ASIs for Accounts, Contacts, and
Households:

1 Set up outbound and inbound Web services. See Setting Up Web Services for
Account, Contact, and Household ASlIs.

2 Activate workflows. See Activate Workflows for Account, Contact, and Household
ASIs on page 476.

Other tasks you may want to perform are:
= Extending ASls. See Application Services Interface Reference.
= Deactivating fields in the ASls. See Application Services Interface Reference.

= Customizing ASI workflows. See Siebel Business Process Designer Administration
Guide.

Setting Up Web Services for Account, Contact, and Household
ASls

To set up the Web services, you must set up both outbound and inbound Web
services for the ASIs. The procedures below show you the steps required for each
ASI.

To set up an outbound Web service

1 From the application level menu, choose View > Site Map > Web Services
Administration > Outbound Web Services.

2 In the Outbound Web Services list, create a query to display the record with
External Account, External Contact, or External Household in the Name field.
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3 Verify that the fields in the Outbound Web Services list match those in the
following table.

Namespace Name Status

http://siebel.com/asi/ One of the following: Active
External Account
External Contact

External Household

4 In the Service Ports list, click New, and enter the following values in the fields
of the new record.

Field Comments

Name Enter a name for the port.

Port Type Enter External Account, External Contact, or External Household.

Transport Select from the drop-down list.

Address When you select a transport, the field will be populated with a
template address. Edit the address based on where you are sending
the data.

Binding If a SOAP header is expected by the receiving application, select
SOAP_RPC.

To set up an inbound Web service

1 From Show drop-down list, select Inbound Web Service.

2 In the Inbound Web Service list, create a query to display the record with Siebel
Account, Siebel Contact, or Siebel Household in the Name field.
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3 Verify that the fields in the Inbound Web Services list match those in the
following table.

Namespace Name Status

http://siebel.com/asi/ One of the following: Active
Siebel Account
Siebel Contact
Siebel Household

4 1In the Service Ports list, review the information in the fields for the service port
and make any changes required for your system.

5 In the Operations list, review the information shown and make any changes
required for your system.

Activate Workflows for Account, Contact, and Household ASls
You must activate the following workflow processes used for real-time integration
of account, contact and household data:

s Synchronize Account ASI

= Get Account ASI

»  Synchronize Contact ASI

= Synchronize Household ASI

For a description of these workflows, see “ASI Workflow Descriptions” on page 478.

To activate workflows used by Account, Contact, and Household ASIs

1 From the application level menu, choose View > Site Map > Business Process
Administration > Workflow Processes.

2 In the Workflow Processes list, use a query to find all processes where the Name
field contains the word ASI. You can query on *ASI*.

3 For the workflows listed above, activate each workflow process that has the
status Inactive.
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Select the workflow process record.
Click Revise.

A copy of the workflow process record is created with a status of In Progress.
The copy is automatically selected.

Click Activate.

Verify that the Status is Active.

4 When you are finished activating the workflow processes, restart the server.

For more information about workflow processes, see Siebel Business Process
Designer Administration Guide.
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ASI Workflow Descriptions

This section describes the workflow processes that are used to invoke the ASIs for
account processes.

It is not necessary to modify these workflows, but you can modify them to suit your
business model.

Synchronize Account ASI
This workflow submits the account information to the outside system to
synchronize the information between the two systems.

= Query For Account By Id: Queries for the account on the current system using
the object ID. Returns an account property set containing the account
information.

=»  External Account Proxy: Calls the Synchronize method on the outside system,
passing in the account property set. This step returns an account property set,
which will contain any changes the outside system made to the account.

= Synchronize Account: Takes the account property set returned by the previous
step and synchronizes it with the account in the current system.

Synchronize Contact ASI
The Synchronize Contact ASI process is essentially the same as the Synchronize
Account ASI process, except that contact replaces account.

Synchronize Household ASI
The Synchronize Household ASI process is essentially the same as the Synchronize
Account ASI process, except that household replaces account.

Get Account ASI

This workflow queries the outside system to retrieve the latest information on the
account. It returns the new information and synchronizes the account on the
current system.

= Query Account By Id: Queries for the account on the current system using the
object ID. Returns an account property set containing the account information.
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Isolate Integration Id: In the next step, the workflow uses a query by example.
Query by example takes the property set and looks for an account with exactly
the same values for the fields in the property set. If the account has changed on
the outside system, those values will no longer match. The workflow needs to
query by a value that does not change, that is, the integration ID. Isolate
Integration Id takes in a property set and removes all the fields, except the
integration ID.

External Account Proxy: Using the property set, which only has an integration
ID now, this step queries by example on the outside systems. Once it finds the
account with that integration ID, it returns an account property set containing
the account information.

Synchronize Account: Takes the account property set returned by the previous
step and synchronizes it with the account in the current system.
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Table 40 lists the system preferences provided throughout your Siebel applications.
For information about how to change system preferences, see Chapter 3, “Ongoing
Application Administration Tasks.”

Table 40. System Preferences

Preference

Alarm Manager Load Frequency

AllocationRule

Always Show Message Bar Alerts

Auto Mgr Calendar Access

Version 7.5, Rev. C

Description

Number of minutes the system waits before rechecking for alarms.
Default: 60

Substitution rule specified by value. Specify “1”, “2”, or “3” to control
substitution behavior:

= Always allocate a substitute before going to the next inventory
location.

= Allocate a substitute only if it allows shipment from a single
inventory location.

= Never allocate a substitute if the exact product can be found in
another inventory location.

For more information, see Siebel Field Service Guide.
This system preference has no effect.

Allow employee’s manager access to the employee’s calendar, even if
the employee does not explicitly give the manager access.

Note: If multiple employees share a position, only the calendar of the
primary employee is accessible.

Default: True
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Table 40. System Preferences

Preference

BucketAvailCDtobeCounted

BucketStatusCDtobeCounted

CSM Logging

DB2: Default Opt Level

DBX Vis Rules per Statement 1

DBX Vis Rules per Statement N

Default Campaign Source Code

Default Offer Code

Description

Valid values for the buckets’ availability code. The values should be
selected from the Bucket Availability Code LOV, comma separated, and
individual values should be language independent values (LIVs).
Values must be delineated with single quotes, such as ‘On Hand’.

For more information, see Siebel Field Service Guide.

Valid values for the buckets’ status code. The values should be selected
from the Bucket Status Code LOV, comma separated, and individual
values should be language independent values (LIVs).Values must be
delineated with single quotes, such as ‘Good”.

For more information, see Siebel Field Service Guide.

Enables logging of merge transactions. Merge transactions are created
when connected users combine or merge two or more business
components such as accounts or opportunities into one.

Information from this log can be used to relink orphaned records
created when the merge process is crossed with an update process
during a synchronization.

This is only applicable if the installation uses Siebel Remote or
Replication Manager.

Default: False

Default optimization level which defines the optimizing algorithm that
DB2 will use to execute SQL statements.

Number of visibility or routing rules checked per SQL statement
processed by the Database Extract component for the first SQL
statement with header information.

Number of visibility or routing rules checked per SQL statement
processed by the Database Extract component for other SQL
statements.

Default campaign for Web offers used in Siebel eMarketing. All offers
that are a part of the default campaign will appear in the Featured
Offers Applet in Siebel eMarketing.

Code to track the click path of a customer on the eMarketing Web site
who does not select a specific offer.
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Table 40. System Preferences

Preference

Default Time Zone

DefaultFulfilllnvloc

Docking: Get All PostnCon rows

Docking: Transaction Logging

eAuc:AllowTimeStampAdvantage

eAuc:AsyncNoticeCalls

eAuc:AuctionURLRoot

Version 7.5, Rev. C

Description

Default time zone for all users of that database.

When a user logs in, the Time Zone field of the User business
component is checked. If it is empty, the Default Time Zone system
preference is checked.

Default: UTC

Value that represents the default inventory location to use as a source
inventory location for the Fulfillment Engine and Part Locator. Used as
the Source Inventory Location if the user does not specify a Source
Inventory Location at run time.

The value must be the Row ID of the service inventory location. To find
this ID, use the following procedure:

1. In any Service Inventory view, select an inventory location.
2. From the Help menu, select About Record.

3. In the dialog box, click Details.

The Row # field contains the Row ID.

For more information, see Siebel Field Service Guide.

Enables the Transaction Router and Database Extract component to get
allrecords in S_POSTN_CON table for a contact. Use this parameter to
improve Siebel Remote performance. For more information, see Siebel
Remote and Replication Manager Administration Guide.

Default: False

Enables docking transaction logging.

For more information, see Siebel Remote and Replication Manager
Administration Guide.

Default: False

Give an advantage to a bid based on when the bid was made.
Default: True

Invoke notice workflows through asynchronous request manager.
Default: False

The URL placed in email messages for auction events. Default: http://
WWWw. < yourDomain > .com
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Table 40. System Preferences

Preference

eAuc:AutoApproveBidder

eAuc:AutoApproveLister

eAuc:AutobidToReservePrice

eAuc:BidIncrementMultiple

eAuc:BidIncrMultipleTolerance

eAuc:BidTimeTieBreakOption

eAuc:DynamicCloseEnabled

eAuc:DynamicCloseMaxDelay

Description

Automatically approve a user’s request to become a bidder.

Default: True

Automatically approve a user’s request to become a lister.
Default: True
When a bid is placed, if it does not meet an auction’s reserve price and

the bid has an AutoBid amount, then automatically adjust the bid to
come as close to or match the reserve price.

Default: False

A floating point number that determines the minimum monetary unit
increment (or decrement) for bids.

Default: 0.01

A floating point number between 0 and 0.005 which specifies the
allowed deviation from an exact multiple of the
eAuc:BidIncrementMultiple property. This provides accommodation
for math rounding errors that could result if the BidIncrementMultiple
is set to certain problematic number values (such as 0.17).Default:
0.005

Preference specified as either 1, 2, or 3:

= If 1, then users who have prior winning bids have their follow-up
bids time-stamped to the time of the prior winning bid.

= If 2, then users who have placed any prior bid have their follow-up
bids time-stamped to the time of the prior bid.

= If 3, new and replacement bids and AutoBids are time-stamped
when placed

Default: 1

Allow extending an auction past its posted end time according to its
dynamic close properties.

The maximum number of minutes an auction’s end time can be
delayed because of dynamic close extensions. (Works in conjunction
with eAuc:DynamicCloseEnabled set to True.)

Default: 60
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Table 40. System Preferences

Preference

eAuc:EnforceExactBidIncrement

eAuc:MaxMoneyValueAccepted

eAuc:MaxRatingsPerSale

eAuc:MaxThirdPartyListingDays

eAuc:Notice Wf-Auction Alert

eAuc:Notice Wf-Autobid

eAuc:Notice Wf-Bid

eAuc:Notice Wf-ListerBidAccept

eAuc:Notice Wi-ListerClose

eAuc:Notice Wi-ListerInvoiced

Version 7.5, Rev. C

Description
Enforce bids to be exact multiples of an auction’s bid increment (or
decrement).

Default: True

The maximum monetary value accepted for an auction’s starting price,
an auction’s bid increment (or decrement), a bid, or a lister fee.

Default: 1000000000

The number of times a user is allowed to rate another user per auction.
This property applies to both bidders and listers.Default:2

The maximum number of days between a third-party auction’s start
and end times

Default:14.

Name of workflow process used to notify user that an Auction Alert
has triggered.

Default: eAuction Alert Notice

Name of workflow process used to notify user that they have
successfully registered to participate in auctions.

Default: eAuction Autobid Notice

Name of workflow process used to notify Bidder that they have placed
an acceptable bid.

Default: eAuction Bid Notice

Name of workflow process used to notify Lister that a Bid has been
placed on one of their Items.

Default: eAuction Bid Accepted Notice

Name of workflow process used to notify Lister that their Auction has
closed.

Default: eAuction Lister Close Notice

Name of workflow process used to notify Lister that their Auction has
been invoiced.

Default: eAuction Lister Invoiced Notice
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Table 40. System Preferences

Preference

eAuc:Notice Wf-Outbid

eAuc:Notice Wi-PartialOutbid

eAuc:Notice W{-UserStatus

eAuc:Notice Wf-UserWelcome

eAuc:Notice Wf-Winner

Entitlement: Verify Consumer

Entitlement: Verify Dates

Description

Name of workflow process used to notify Bidder that they have been
outbid.

Default: eAuction Outbid Notice

Name of workflow process used to notify Bidder that they have been
outbid on some number of items.

Default: eAuction Partially Outbid Notice

Name of workflow process used to notify User of their status.

Default: eAuction User Status Notice

Name of workflow process used to notify User that they have been
accepted into an auction.

Default: eAuction User Welcome Notice

Name of workflow process used to notify Bidder that they have won.

Default: eAuction Win Notice

Check the authorization of the contact requesting service. If preference
is set to TRUE, the entitlements displayed must meet one of these
criteria:

»  The contact for the entitlement matches the service request
contact.

= The entitlement account is set to All Contacts, and the entitlement
account matches the service request account or the account for the
contact for the service request.

If no contact is selected, Siebel Field Service tries to verify the
entitlement using the other entitlement settings.

For more information, see Siebel Field Service Guide.

Check that the service request falls within the time span of the
entitlement. If the preference is set to TRUE, then the entitlements
displayed are only those that provide coverage on the date the service
request was opened: a date between the start and end dates for the
entitlement.

If the entitlement has no start or end date, it is not displayed.

For more information, see Siebel Field Service Guide.
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Table 40. System Preferences

Preference

Entitlement: Verify Product

ETL Analysis End
ETL Analysis Start
ETL Date Format

ETL Base Exchange Currency

ETL Default Continent

Version 7.5, Rev. C

Description

Check that the asset or product is entitled to service. If the preference
is set to TRUE, the agreements displayed must meet one of these
criteria:

» The entitlement asset matches an asset in the service request.

»  The entitlement product matches a product in the service request
(no asset or serial number specified).

= The entitlement is set to All Products and the product or asset for
the entitlement matches the product or asset for the service
request.

If no product is selected, Siebel Field Service tries to verify the
entitlement using the other Entitlement settings.

For more information, see Siebel Field Service Guide.

ETL Date format indicates the way dates need to be interpreted. The
other two parameters mention the date range for which the Exchange
Rates will be adjusted. This does not indicate that only the data created
within this range will be extracted. Select the earliest date for the
Analysis Start Date—that is, when the transactions may have begun.
In addition to considering the created and modified dates, consider
other relevant dates such as order date. Setting this to an early value
such as 19700101 (January 1, 1970) does not affect the processing time.
A similar logic applies for choosing Analysis End Date. Note that the
values need to be entered in the format defined by ETL Date Format.

Default Analysis End: 20101231
Default Analysis Start: 19940101

Default Date Format: YYYYMMDD.
Currency in which all the financial data will be converted. While the
OLTP supports transactions in many different currencies, the data in

the OLAP is converted to a single currency for analysis purposes. The
Exchange rates are derived from the Exchange Rates table in the OLTP.

Default: USD.

Value for any address that does not have Continent defined. Set this to
a value, which will be used if the value of Continent is not defined in
the OLTP.

Default: North America.
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Table 40. System Preferences

Preference

ETL Default Country

ETL Default Currency

ETL Default Language

ETL LOV Maximum Value
ETL LOV Minimum Value

ETL Unknown Exchange Rate

Forecast: Auto-Forecast

Forecast: Use Server Task

FSDB:Override Service Region

FSPrevMnt: Def Act Owner ID

488 Applications Administration Guide

Description

Value for any address that does not have the Country defined. Set this
to a value, which will be used if the value of Country is not defined in
the OLTP.

Default: USA.

Value for currency code that will be used if the currency code for a
specific financial transaction is not set.

Default: USA.

Language code used when language translation occurs when looking
up the List of Values table.

Default: ENU.

In some fields, bucketing of values happens. Instead of saying the
number of employees at an account is 45, 96, the values can be
bucketed to 0-50, 50-100 and so on. In the List of Values, if the

minimum and maximum values are not specified, the values of these
parameters will be used.

Defaults: 9999999999 and 0.

Value used when an exchange rate for a currency to the Datamart
Default Currency is undefined in the OLTP.
Default: 1.

Creates subordinates’ forecasts to be used in a rollup forecast, if the
subordinates have not created forecasts themselves.

Send forecast processing requests to the Siebel Server for batch
processing. If the value is False, requests are processed locally.

Maximum monetary value accepted in Auction Item, Bid, and Fee
currency fields.

The value of this system preference is used when creating activities
from a template in which the activity owner (Employees) has not been
defined. The value specified should be the ROW_ID of the desired
employee.

For more information, see Siebel Field Service Guide.
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Table 40. System Preferences

Preference

FSPrevMnt: Default Org ID

InventoryTypeForPT

InvLocTypeForReplenishRelation

LOGMGR:Vis Rules per Statement

MRG:Docking Timestamp Source

MRG:System Conflict Resolution

MRG:Txns per Commit

Version 7.5, Rev. C

Description

ROW_ID of the default organization. This default organization is
stamped on generated service requests when the asset for which the
service request is being generated does not have a specified account.
If the owner account is specified for the asset, then the account’s
BU_ID is used.

For more information, see Siebel Field Service Guide.

Inventory location type. The values should be from the Inventory
location type LOV and individual values should be any of the language
independent values (LIVs).

For more information, see Siebel Field Service Guide.

Default replenishment level. Orders to replenish any level of an
inventory location have this value as their Destination.Value should be
from the Inventory Location Type LIV.

For more information, see Siebel Field Service Guide.

Set to 50 by default. For implementations that use any database other
than Oracle, you should change this value to 20.

Specifies whether the timestamp is based on the time a change was
made on the client or on the server. For more information, see Siebel
Remote and Replication Manager Administration Guide.

Sets the rule to be used for resolving database update conflicts. The
rule may be either Server Wins (the default) or Client Wins. For more
information, see Siebel Remote and Replication Manager
Administration Guide.

Number of database transactions the Transaction Merger processes
before it issues a database commit. Setting a low value (1) reduces the
frequency with which users encounter a locked database row and
reduces the risk of deadlock. Setting a high value (10) minimizes
processing overhead.

For more information, see Siebel Remote and Replication Manager
Administration Guide.

Default DB2: 10.
Default Microsoft SQL Server: 1.
Default Oracle: 1.
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Preference

MRG:User Friendly Notification

OrderltemStatusForOnOrderQty

OrderltemStatusToBeFulfilled

OrderStatusForOnOrderQty

OrderStatusToBeFulfilled

OrderTypeForOnOrderQty

OrderTypeToBeFulfilled

Description

Determines whether Siebel Remote writes information about database
updates to the Siebel Remote Status view on the Mobile Web Client. If
the value is TRUE, Siebel Remote writes information about database
updates. If the value is CONFLICTS, Siebel Remote writes information
about database updates that caused conflicts. If the value is FALSE,
Siebel Remote does not write any information about database updates.

For more information, see Siebel Remote and Replication Manager
Administration Guide.

Specifies the valid values for the existing order item status. The values
should be from the Order Item Status LOV and individual values
should be language independent values (LIVs).

For more information, see Siebel Field Service Guide.

Specifies the valid values for Order Item Status. The values are from
the Order Item Status LOV and the individual values are language
independent values (LIVs).

For more information, see Siebel Field Service Guide.

Specifies the valid values for the existing order status. The values
should be from the Order Status LOV and individual values should be
LIVs.

For more information, see Siebel Field Service Guide.

Specifies the valid values for Order Status. The values should be from
the Order Status LOV and individual values can be any of the language
independent values (LIVs).

For more information, see Siebel Field Service Guide.

Specifies the valid values for the existing order type. The values should
be from the Order Type LOV and individual values should be language
independent values (LIVs).

For more information, see Siebel Field Service Guide.

Specifies the valid values for Order Type. The values should be from
the Order Type LOV and individual values can be any of the language
independent values (LIVs).

For more information, see Siebel Field Service Guide.
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Table 40. System Preferences

Preference

ReplenishOrderPriority

Satmetrix Key Value

Sch:Break Time Id

Sch:Default Constraint Set

Sch:Default Cost Function

Sch:Default Parameter Set
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Description

Specifies the default order priority. The values should be from the
Order Priority LOV and individual values should be language
independent values (LIVs).

For more information, see Siebel Field Service Guide.

A string provided by Satmetrix to customers of Siebel Satmetrix
eSurveys. Required for generating encrypted tokens that are part of
URLs for displaying survey reports.

Specifies the Row ID of the work type to be used when calculating the
schedule cost where activities contain breaks. The default value is -1.

To find the Row ID, navigate to the Application Administration
screen > Work Type Administration view, select the record, choose
About Record from the Help menu, and note the Row # value.

Specifies the Row ID of the constraint set to be used where no
constraint set is associated with the service region loaded. The default
value is -1.

To find the Row ID, navigate to the Scheduling Administration
screen > Constraint Sets view, select the record, select About Record
from the Help menu and note the Row # value.

Specifies the Row ID of the cost function to be used where no cost
function is associated with the service region loaded. The default value
is -1.

To find the Row ID, navigate to the Scheduling Administration screen
> Cost Functions view, select the record, select About Record from the
Help menu and note the Row # value.

Specifies the Row ID of the parameter set to be used where no cost
function is associated with the service region loaded. The default value
is -1.

To find the Row ID, navigate to the Scheduling Administration
screen > Parameter Sets view, select the record, select About Record
from the Help menu and note the Row # value.
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Preference Description

Sch:Default Time Window Specifies the Row ID of the time window to be used where no cost
function is associated with the service region loaded. The default value
is -1.

To find the Row ID, navigate to the Scheduling Administration screen
> Time Window view, select the record, select About Record from the
Help menu and note the Row # value.

SecExternalUserAdministration An entry of FALSE allows administration of the directory through the
Siebel application. For more information, see Security Guide for Siebel
eBusiness Applications.

SecThickClientExtAuthent Allow changes to user data done on the dedicated client to propagate
to the directory. Set this parameter to TRUE only on the dedicated Web
client.

For more information, see Security Guide for Siebel eBusiness
Applications.

Security Adapter CRC Calculate the checksum value for your security adapter DLL, and enter
the calculated value here.

For more information, see Security Guide for Siebel eBusiness
Applications.

SM Weblntelligence Server The URL that points to the Web Intelligence server that serves up
reports for Siebel Analytics.

SqlStyle Indicate which SQL statements are to be used with this
implementation—Oracle, Microsoft SQL Server, Informix, or Sybase.
Case-sensitive.

SubSqlStyle An SQLStyle that falls within a family of similar database products.

Technical Support (Alt. 1) Specifies the telephone numbers to display in the Siebel Technical
Support dialog box. Update this number to match your internal help
desk number. The alternate numbers (Alt. 1 and Alt. 2) provide
expansion for pager numbers and email addresses.

Set a value to None to leave it blank in the dialog box.

Technical Support (Alt. 2) Specifies the telephone numbers to display in the Siebel Technical
Support dialog box. Update this number to match your internal help
desk number. The alternate numbers (Alt. 1 and Alt. 2) provide
expansion for pager numbers and email addresses.

Set a value to None to leave it blank in the dialog box.
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Table 40. System Preferences

Preference

Technical Support (FAX)

Technical Support (URL)

Technical Support (Voice)

Universal Time Coordinated

Description

Specifies the fax number to display in the Siebel Technical Support
dialog box. Update this number to match your internal help desk fax
number.

Set a value to None to leave it blank in the dialog box.

Specifies the support URL to display in the Siebel Technical Support
dialog box. Update this URL to match your internal help desk Web
address.

Set a value to None to leave it blank in the dialog box.

Specifies the voice number to display in the Siebel Technical Support
dialog box. Update this number to match your internal help desk
number.

Set a value to None to leave it blank in the dialog box.

Turns on global time zone support for the entire system. Set this
preference to TRUE to enable global time zone support. The default
setting is TRUE.

Note: This is a one-time setting. Once you have turned on global time
zone support in a production environment, you should not turn it off.

If you intend to operate your deployment with the Global Time Zone
feature enabled, you must also set the operating system of your
database servers to UTC time, or its equivalent. Failure to set the OS to
UTC when the UTC parameter is set to TRUE will result in
asynchronous server request errors.

For more information on enabling Global Time Zone, see Global
Deployment Guide. Although enabling this feature is optional, it is
strongly recommended that you operate your production environment
with Global Time Zone enabled.
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This appendix provides detailed information on two subjects:
= Prebuilt Content Objects for Content Center on page 496

= Content Project Business Service on page 511
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Prebuilt Content Objects for Content Center

Prebuilt Content Objects for Content Center

Each Content Object is based on a business object that was derived from an existing
business object by removing unnecessary fields. You can modify these content
objects according to your business needs.

Table 41 lists each content object, the primary business object on which it is based,
and its primary business component.

Table 41. Prebuilt Content Objects

Content Object

Catalog Content Object

Catalog Category Content Object

ContentBase Content Asset
Content Object

ContentBase Content Set Content
Object

ContentBase Content Type
Content Object

ERM Group News Item Content
Object

Literature Content Object

Microsite Management Page
Content Object

Microsite Management Page Item
Content Object

Price List Content Object

Product Content Object

Business Object

Product Catalog

(Content Management)

Catalog Category

(Content Management)

ContentBase Asset EAI

ContentBase Content Set EAI

ContentBase Content Type EAI

ERM Group News Item EAI

Admin Sales Tool

(Content Management)

ePortal MM Page EAI

ePortal MM Page Item EAI

Price List (Content Management)

Product Admin Definition

(Content Management)

496 Applications Administration Guide

Primary Business Component

Product Catalog

Catalog Category Admin

ContentBase Asset (Content
Management)

ContentBase Content Set (Content
Management)

ContentBase Content Type (Content
Management)
ERM Group News Item EAI

Admin Sales Tool

ePortal MM Page EAI

ePortal MM Page Item EAI

Price List

Internal Product
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Table 41. Prebuilt Content Objects

Content Object Business Object Primary Business Component
Product Class Content Object XA Authoring Object XA Class
Product Feature Content Object Product Feature Product Feature

(Content Management)

Product Line Content Object Admin Product Line Admin Product Line

(Content Management)

Resolution Item Content Object Resolution Item SR Resolution Item
Solution Content Object Solution Solution
Volume Discount Content Object = Volume Discount Volume Discount

(Content Management)

The tables below describe the data that is transferred for each business component
that is included in the content object.

Catalog Content Object

Catalog is a prebuilt content object based on the business object Product Catalog
(Content Management). Table 42 lists the business components for the prebuilt
content object Catalog.

Table 42. Prebuilt Content Object: Catalog

Business Components Transferred Data Links

Product Catalog Catalog Information Primary

Product Catalog Translation = Language Translations of Catalog Information = Product Catalog/Product
Catalog Translation
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Catalog Category Content Object

Catalog Category is a prebuilt content object based on the business object Catalog
Category. Table 43 lists the business components for the prebuilt content object
Catalog Category.

Table 43. Prebuilt Content Object: Catalog Category

Business Components Transferred Data

Catalog Category Catalog Category

Catalog Subcategory

Internal Product

Links

Primary

Association relationships = Catalog Category/Catalog Subcategory

Association relationships = Catalog Category/Internal Product

ContentBase Content Asset Content Object

ContentBase Content Asset is a prebuilt content object based on the business object
ContentBase Asset EAI. Table 44 lists the business components for the prebuilt
content object Content Asset.

Table 44. Prebuilt Content Object: ContentBase Content Asset

Business Components

ContentBase Asset (Content

Management)

ContentBase Asset (Content
Management)_Access Group

ContentBase Asset (Content

Management)_Current
Version

ContentBase Version
(Content Management)

ContentBase Data (Content

Management)

Transferred Data

ContentBase Asset identity

ContentBase Access Group
relationship

ContentBase Asset current
version identification

Asset revision information

Content stored in database
repository
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Links

Primary

ContentBase Asset (Content Management)/
ContentBase Version (Content
Management)

ContentBase Version (Content
Management)/ContentBase Data (Content
Management)
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Table 44. Prebuilt Content Object: ContentBase Content Asset

Business Components Transferred Data

ContentBase Namespace XML namespace information
Aliases (Content

Management)

ContentBase Version File Content stored in file system
Attachment (Content

Management)

ContentBase Version for Asset version interrelations

Version Children

ContentBase Ref (Content Links to other assets
Management)

Links

ContentBase Version (Content
Management)/ContentBase Namespace
Aliases (Content Management)

ContentBase Version (Content
Management)/ContentBase Version File
Attachment (Content Management)

ContentBase Asset (Content Management)/
ContentBase Version for Version Children

ContentBase Version for Version Children/
ContentBase Ref (Content Management)

ContentBase Content Set Content Object

ContentBase Content Set is a prebuilt content object based on the business object
ContentBase Content Set EAI. Table 45 lists the business components for the
prebuilt content object ContentBase Content Set.

Table 45. Prebuilt Content Object: ContentBase Content Set

Business Components Transferred Data Links

ContentBase Content Set Set identity Primary

(Content Management)

ContentBase Content Set Home page identification

(Content Management)_Pr.

Asset

ContentBase Asset (Content = Asset identity ContentBase Content Set (Content
Management) Management)/ContentBase Asset (Content

Management)

ContentBase Asset (Content = ContentBase Access Group
Management)_Access Group = relationship

ContentBase Asset (Content = ContentBase Asset current
Management)_Current version identification
Version

Version 7.5, Rev. C
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Prebuilt Content Objects for Content Center

Table 45. Prebuilt Content Object: ContentBase Content Set

Business Components

ContentBase Version
(Content Management)

ContentBase Data (Content
Management)

ContentBase Namespace
Aliases (Content
Management)

ContentBase Version File
Attachment (Content
Management)

ContentBase Version for
Version Children

ContentBase Ref (Content
Management)

Transferred Data

Asset revision information

Content stored in database
repository

XML namespace
information

Content stored in file
system

Asset version
interrelations

Links to other assets

Links

ContentBase Asset (Content Management)/
ContentBase Version (Content Management)

ContentBase Version (Content Management)/
ContentBase Data (Content Management)

ContentBase Version (Content Management)/
ContentBase Namespace Aliases (Content
Management)

ContentBase Version (Content Management)/
ContentBase Version File Attachment (Content
Management)

ContentBase Content Set (Content
Management)/ContentBase Version for Version
Children

ContentBase Version for Version Children/
ContentBase Ref (Content Management)

ContentBase Content Type Content Object

ContentBase Content Type is a prebuilt content object based on the business object
ContentBase Content Type EAI. Table 46 lists the business components for the
prebuilt content object ContentBase Content Type.

Table 46. Prebuilt Content Object: ContentBase Content Type

Business Components

ContentBase Content Type
(Content Management)

ContentBase DocType
(Content Management)

Transferred Data

ContentBase Asset data type

SGML document type
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Links

Primary

ContentBase Content Type (Content
Management)/ContentBase DocType
(Content Management)
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Table 46. Prebuilt Content Object: ContentBase Content Type

Business Components

ContentBase Namespace
(Content Management)

ContentBase NS Node Type
(Content Management)

Transferred Data

XML namespace information

Namespace node information

Links

ContentBase Content Type (Content

Management)/ContentBase Namespace
(Content Management)

ContentBase Namespace (Content

Management)/ContentBase NS Node Type
(Content Management)

ERM Group News Item Content Object

ERM Group News Item is a prebuilt content object based on the business object
ERM Group News Item EAI. Table 47 lists the business components for the prebuilt
content object ERM Group News Item.

Table 47. Prebuilt Content Object: ERM Group News Item

Business Components

ERM Group News Item

EAI

ERM Group News
Content Path EAI

ERM Group News
Content Path Stages
EAI

ERM Group News
Position EAI

Access Group

ERM Group News

Access Group Member

EAI

ContentBase Content

Set (Content
Management)

Version 7.5, Rev. C

Transferred Data

News Item identity,
content references

Publication stages for
news item

Publication stage details

Publication approvers for
news item

Contentbase Asset access
groups

Group News access
group information

Set identity

Applications Administration Guide

Links

Primary

ERM Group News Item EAI/ERM
Group News Content Path EAI

ERM Group News Content Path EAI/
ERM Group News Content Path
Stages EAI

ERM Group News Content Path EAI/
ERM Group News Position EAI

ContentBase Asset (Content
Management)/Access Group

Access Group/ERM Group News
Access Group Member EAI

ERM Group News Item EAI/
ContentBase Content Set (Content
Management)
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Table 47. Prebuilt Content Object: ERM Group News ltem

Business Components

ContentBase Content
Set (Content
Management)_Pr.
Asset

ContentBase Asset
(Content
Management)

ContentBase Asset
(Content
Management)_Access
Group

ContentBase Asset
(Content

Management)_Current

Version

ContentBase Version
(Content
Management)

ContentBase Data
(Content
Management)

ContentBase
Namespace Aliases
(Content
Management)

ContentBase Version
File Attachment
(Content
Management)

ContentBase Version
for Version Children

ContentBase Ref
(Content
Management)

Transferred Data

Home page identification

Asset identity

ContentBase Access
Group relationship

ContentBase Asset
current version
identification

Asset revision
information

Content stored in
database repository

XML namespace
information

Content stored in file
system

Asset version
interrelations

Links to other assets

Links

ContentBase Content Set (Content
Management) /ContentBase Asset
(Content Management)

ContentBase Asset (Content
Management)/ContentBase Version
(Content Management)

ContentBase Version (Content
Management)/ContentBase Data
(Content Management)

ContentBase Version (Content
Management)/ContentBase
Namespace Aliases (Content
Management)

ContentBase Version (Content
Management)/ContentBase Version
File Attachment (Content
Management)

ContentBase Content Set (Content
Management)/ContentBase Version
for Version Children

ContentBase Version for Version
Children/ContentBase Ref (Content
Management)
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Prebuilt Content Objects for Content Center

Literature Content Object

Literature is a prebuilt content object based on the business object Admin Sales
Tool. Table 48 lists the business components for the prebuilt content object
Literature.

Table 48. Prebuilt Content Object: Literature

Business Components Transferred Data Links

Admin Sales Tool Literature record and Primary
associated files

Literature Item Detailed relationships Admin Sales Tool/Literature Item

Literature Component = Association relationships = Literature Item/Literature
Item Component Item - Admin

Microsite Management Page Content Object

Microsite Management Page is a prebuilt content object based on the business
object ePortal MM Page EAI. Table 49 lists the business components for the prebuilt
content object Microsite Management Page.

Views associated with this content object are:
= Add/Edit - ePortal MM Page Administration

s Preview - ePortal MM Page Designer View

Table 49. Prebuilt Content Object: Microsite Management Page

Business Components Transferred Data Links

EPortal MM Page EAI | Page identity Primary

ePortal MM Page Page layout information = ePortal MM Page EAl/ePortal MM
Section EAI Page Section EAI

ePortal MM Page Item | Page Item display ePortal MM Page Section EAI/
EAI information ePortal MM Page Item EAI
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Prebuilt Content Objects for Content Center

Table 49. Prebuilt Content Object: Microsite Management Page

Business Components

ContentBase Content
Set (Content
Management)

ContentBase Content
Set (Content
Management)_Pr.
Asset

ContentBase Asset
(Content
Management)

ContentBase Asset
(Content
Management)_Access
Group

ContentBase Asset
(Content
Management)_Current
Version

ContentBase Version
(Content
Management)

ContentBase Data
(Content
Management)

ContentBase
Namespace Aliases
(Content
Management)

ContentBase Version
File Attachment
(Content
Management)
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Transferred Data

Set identity

Home page identification

Asset identity

ContentBase Access
Group relationship

ContentBase Asset
current version
identification

Asset revision
information

Content stored in
database repository

XML namespace
information

Content stored in file
system

Links

ePortal MM Page EAI/ContentBase
Content Set (Content Management)

ContentBase Content Set (Content
Management) /ContentBase Asset
(Content Management)

ContentBase Asset (Content
Management)/ContentBase Version
(Content Management)

ContentBase Version (Content
Management)/ContentBase Data
(Content Management)

ContentBase Version (Content
Management)/ContentBase
Namespace Aliases (Content
Management)

ContentBase Version (Content
Management)/ContentBase Version
File Attachment (Content
Management)
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Table 49. Prebuilt Content Object: Microsite Management Page

Business Components

ContentBase Version
for Version Children

ContentBase Ref
(Content
Management)

Transferred Data Links

Asset version ContentBase Content Set (Content

interrelations Management)/ContentBase Version
for Version Children

Links to other assets ContentBase Version for Version
Children/ContentBase Ref (Content
Management)

Microsite Management Page Item Content Object

Microsite Management Page Item is a prebuilt content object based on the business
object ePortal MM Page Item EAI. Table 50 lists the business components for the
prebuilt content object Microsite Management Page Item.

Views associated with this content object are:

m» Add/Edit - ePortal MM Page Administration

m Preview - ePortal MM Page Designer View

Table 50. Prebuilt Content Object: Microsite Management Page ltem

Business Components

ePortal MM Page Item
EAI

ContentBase Asset
(Content
Management)

ContentBase Asset
(Content
Management)_Access
Group

ContentBase Asset
(Content
Management)_Current
Version

Version 7.5, Rev. C

Transferred Data Links

Page Item display Primary

information and asset

link

Asset identity ePortal MM Page Item EAI/
ContentBase Asset (Content
Management)

ContentBase Access
Group relationship

ContentBase Asset
current version
identification

Applications Administration Guide 505



‘ Content Center Reference

Prebuilt Content Objects for Content Center

Table 50. Prebuilt Content Object: Microsite Management Page ltem

Business Components

ContentBase Version
(Content
Management)

ContentBase Data
(Content
Management)

ContentBase
Namespace Aliases
(Content
Management)

ContentBase Version
File Attachment
(Content
Management)

ContentBase Version
for Version Children

ContentBase Ref
(Content
Management)

Transferred Data

Asset revision
information

Content stored in
database repository

XML namespace
information

Content stored in file
system

Asset version
interrelations

Links to other assets

Links

ContentBase Asset (Content
Management)/ContentBase Version
(Content Management)

ContentBase Version (Content
Management)/ContentBase Data
(Content Management)

ContentBase Version (Content
Management)/ContentBase
Namespace Aliases (Content
Management)

ContentBase Version (Content
Management)/ContentBase Version
File Attachment (Content
Management)

ContentBase Asset (Content
Management)/ContentBase Version
for Version Children

ContentBase Version for Version
Children/ContentBase Ref (Content
Management)

Price List Content Object

Price List is a prebuilt content object based on the business object Price List.
Table 51 lists the business components for the prebuilt content object Price List.

Table 51. Prebuilt Content Object: Price List

Business Components

Price List

Transferred Data

Price List

Association relationships

to Organizations

Links

Primary
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Prebuilt Content Objects for Content Center

Product is a prebuilt content object based on the business object Product Admin
Definition. Table 52 lists the business components for the prebuilt content object

Product.

Table 52. Prebuilt Content Object: Product

Business Components

Internal Product

Admin Product
Definition (Content
Management)

Component Product

FS Inventory Options

FS Product
Measurement
Characteristics

Internal Product Sales
Tool

Key Feature

Price List

Transferred Data

Internal Product

Association relationships

Defined in the
intersection table: Rank
column; Value column

Association relationships

Defined in the
intersection table:
Relation Type

Association relationships

Association relationships

Association relationships

Association relationships

Association relationships

Defined in the
intersection table: some
columns

Links

Primary

Internal Product/Admin Product
Comparison - Admin (Content
Management)

Internal Product/Component
Product - Admin

Internal Product/FS Inventory
Options

Internal Product/FS Product
Measurement Characteristics

Internal Product/Internal Product
Sales Tool - Admin

Internal Product/Key Feature -
Admin

Internal Product/Price List - Admin
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Product Class Content Object

Product Class is a prebuilt content object based on the business object XA
Authoring Object. Table 53 lists the business components for the prebuilt content
object Product Class.

Table 53. Prebuilt Content Object: Product Class

Business Components Transferred Data Links

XA Class Product Class Primary

XA Class Translation Product Class Language = XA Class/XA Class Translation
Translations

XA Attribute Product Class Child XA Class/XA Attribute
Attributes

XA Attribute Product Class Child XA Attribute/XA Attribute

Translation Attribute Language Translation
Translations

Product Feature Content Object

Product Feature is a prebuilt content object based on the business object Product
Feature (Content Management). Table 54 lists the business components for the
prebuilt content object Product Feature.

Table 54. Prebuilt Content Object: Product Feature

Business Components Transferred Data Links
Product Feature Product Feature Primary
Product Feature_Product Line Association of Features to N/A

Product Line
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Product Line Content Object

Product Line is a prebuilt content object based on the business object Admin
Product Line (Content Management). Table 55 lists the business components for the
prebuilt content object Product Line.

Table 55. Prebuilt Content Object: Product Line

Business Components Transferred Data Links
Admin Product Line Product Line Primary
Admin Product Line_Position Association to Position N/A

Resolution Item Content Object

Resolution Item is a prebuilt content object based on the business object Resolution
Item. Table 56 lists the business components for the prebuilt content object
Resolution Item.

Table 56. Prebuilt Content Object: Resolution Item

Business Components Transferred Data Links
SR Resolution Item Resolution Item Primary
Solution Association relationships SR Resolution Item/Solution

Solution Content Object

Solution is a prebuilt content object based on the business object Solution. Table 57
lists the business components for the prebuilt content object Solution.

Table 57. Prebuilt Content Object: Solution

Business Components Transferred Data Links

Solution Solution Primary

Related Solution Association relationships Solution/Related Solution
SR Resolution Item Association relationships Solution/SR Resolution Item
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Volume Discount Content Object

Volume Discount is a prebuilt content object based on the business object Volume
Discount. Table 58 lists the business components for the prebuilt content object
Volume Discount.

Table 58. Prebuilt Content Object: Volume Discount

Business Components Transferred Data Links
Volume Discount Volume Discount Primary
Volume Discount Item = Detailed relationships Volume Discount/Volume Discount

Item - Admin
(This link has no restriction on
insert/update.)

Price List Association relationships = Internal Product/Price List - Admin

Defined in the
intersection table: some
columns
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Content Project Business Service

The Content Project business service allows clients to perform various operations
on Siebel Content Projects. Business service scripts, workflow-driven services, and
business components can call the Content Project business service methods to
manipulate Content Projects. It can be used to start and publish a content project
and to add, delete, and update a content project or a content item.

AddContentltem Method

This method adds a content item to the specified project. First it searches the project
in the Content Project business component, and then it searches content type name,
pick applet, picklist name, and source field name in the Content Type business
component.

Table 59 lists the arguments for the AddContentltem method.

Table 59. Arguments for the AddContentltem Method

Argument Type Description Required
Projectld Input The project ID to add a content item X
ItemName Input The item name to add X
ItemAction Input The action for item to perform X
ItemDescription Input The description for the item

ItemTypeld Input Type ID for the item X
ItemReference Input The reference for the item

ItemId Output The item ID for the added item
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AddProject Method

This method creates a new content project.

Table 60 lists the arguments for the AddProject method.

Table 60. Arguments for the AddProject Method

Argument

ProjName
ProjectDescription
ProjectOwnerld

ProjectPlanPublicationD
ate

ProjectPublicationWorkfl
owld

Projectld

Type

Input
Input
Input

Input

Input

Output

Description Required

The project name to create X
The description for the project
The owner ID for the project

The planning publication date for the
project

The publication workflow ID for the
project

The project ID for the created project

Export Method

If Connect String is not empty, this method exports the project from the staging
environment to the production environment. If Connect String is empty and Export
Directory is not empty, the method exports the project to the export directory. The
method fails if both Connect String and Export Directory are empty.

Table 61 lists the arguments for the Export method.

Table 61. Arguments for the Export Method

Argument
Content Project Id
Connect String

Export Directory

Type
Input
Input

Input

Description Required
The project ID to export X
Connect string to export

The directory to export
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Import Method

This method imports a project which has been exported using Export method.

Table 62 lists the arguments for the Import method.

Table 62. Arguments for the Import Method

Argument Type Description Required
Content Project Id Input The project ID to import into X
Export Directory Input The directory containing the export

project

PublishProject Method

This method publishes the project by calling the methods RequestPublish and
Publish of Content Project business component. If SynchronousIndicator = “N”, the
method calls the RequestPublish method. Otherwise, it calls the Publish method.

Table 63 lists the arguments for the PublishProject method.

Table 63. Arguments for the PublishProject Method

Argument Type Description Required
Projectld Input The project ID to publish X
SynchronousIndicator Input Indicator for sync (Y or N; default is Y)

Version 7.5, Rev. C Applications Administration Guide 513



‘ Content Center Reference

Content Project Business Service

RemoveContentlitem Method

This method removes a content item. If Itemld is provided, Projectld and ItemName
are not necessary. Otherwise, Projectld and ItemName are required.

Table 64 lists the arguments for the RemoveContentItem method.

Table 64. Arguments for the RemoveContentltem Method

Argument Type Description

Projectld Input The project ID from which the content
item is removed

ItemName Input The item name to remove

ItemlId Input The item ID to remove

RemoveProject Method

This method removes a content project.

Table 65 lists the arguments for the RemoveProject method.

Table 65. Arguments for the RemoveProject Method

Argument Type Description Required

Projectld Input The project ID to remove X
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StartProject Method

This method starts the project by calling the methods RequestStartProject and
StartProject of the Content Project business component. If SynchronousIndicator =
“N”, the method calls the RequestStartProject method. Otherwise, the method calls
the StartProject method.

Table 66 lists the arguments for the StartProject method.

Table 66. Arguments for the StartProject Method

Argument Type Description Required
Projectld Input The project ID to start X
SynchronousIndicator Input Indicator for sync (Y or N; default is Y)

UpdateContentltem Method

This method updates a content item. If Itemld is provided, Projectld and I[temName
are not necessary and the item name can be updated. Otherwise, Projectld and
ItemName are required. If ItemTypeld is provided, the method searches content
type name, pick applet, picklist name, and source field name in Content Type
business component.

Table 67 lists the arguments for the UpdateContentltem method.

Table 67. Arguments for the UpdateContentltem Method

Argument Type Description

Projectld Input The proj.ect ID where update the
content item

ItemName Input The item name to update

ItemlId Input The item ID to update

ItemAction Input The action for item to update

ItemDescription Input The description to update

ItemTypeld Input Type ID to update
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Table 67. Arguments for the UpdateContentltem Method

Argument Type Description
ItemReference Input The reference to update
ItemStatus Input The item status to update

UpdateProject Method

This method updates a content project.

Table 68 lists the arguments for the UpdateProject method.

Table 68. Arguments for the UpdateProject Method

Argument Type Description Required
Projectld Input The project ID for updating X
ProjName Input The project name to update

ProjectDescription Input The description to update

ProjectOwnerld Input The owner ID to update

ProjectPlanPublicationD | Input The planning publication date to

ate update

ProljgctPublicationkaﬂ Input The publication workflow ID to update

ow
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Symbols
.sql (dnbinitial.sql), using to load D&B data
452

A

accounts
account hierarchy, changing 247
custom hierarchy, maintaining 251
hierarchies, types of 243
ActiveX, browser support of 94
activities
See also activity templates; activities,
information for configurators;
assessment templates; sales methods
about 254
activity assignment, about and employee
and category values (table) 270
activity plans, about 256
assignment methods 254
business objects, associated with (table)
255
business scenario for sales 259
note, about changing Category value 270
opportunity reroute activity, setting up
285
process flow for activities administration,
example 262
activities, information for configurators
See also activities
Owner and Employee fields, configurating
274
TAS Customer Milestone template,
creating in a localized application 274
activity assignment
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See activities; activities, information for
configurators; activity templates

activity plans, about 256
activity templates

See also activities; activities, information
for configurators

about 256

creating without grandchild records 266

deleting an activity template 269

details, adding to 267

TAS Customer Milestone template,
creating in a localized application 274

Actuate connect string, specifying 309
Add Web Link tool, creating link to external

pages 224

administration tasks

application-wide case insensitivity,
enabling 89

browser, adding additional Web Browsers
96

case sensitivity, about and Siebel
applications 88

Contact Us account, adding 81

currencies, setting up 57

currency conversions, setting up 60

date formats, about 76

email address and subjects, about adding
81

expense types, setting up 64

field-specific case insensitivity, enabling
92

global time zone support, administering
78

industry, adding 86
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InsensitivityFactor parameter, modifying
91
keyboard accelerators, about using and
examples 82
language, adding 87
pager companies, setting up 75
payment terms, setting up 66
periods, setting up 67
predefined queries, about setting up 53
predefined queries, creating by saving a
query 54
Predefined Query view, setting up
predefined query in 54
system preferences, setting 52
telephone formats, specifying 69
Web browser capabilities, adding 93
ZIP Codes, adding 77
alerts
See also message broadcasting
about and example 138
business scenario, using alerts 140
creating and sending 152
process flow example 141
Application Message Bar Flag parameter,
about setting to true 143
ASIs
See integration using ASIs
assessment score, calculation of 273
assessment templates
See also activities
about 257
assessment scores, calculation of 273
creating 271
audience of guide 15
audit scope, about 117
audit trail

Audit Trail Engine business service,
enabling 124

audit trail records and record details,
viewing 134

audit trail recovery in file auditing mode,
about 120

business component and fields,
configuring to be audited 127

business component, determining
whether it can be audited 118

business component, disabling 127

business component, linking to 132

business scenario 122

cache, clearing 125

content of 117

customer application, configuring for
Audit Trail 124

disabling for application 125

file auditing and database auditing, about
119

importing items into Siebel database 134

position, restricting by (procedure) 129

process flow (diagram) 123

querying audit trail information 135

records, verifying 131

responsibility, restricting by (procedure)
129

restrictions, list of 117

Siebel Remote and Siebel Replication
users, about using 119

user, restricting by (procedure) 129

Audit Trail Buscomp, fields in list 127
Audit Trail Engine business service

about and exposed methods (table) 120
enabling (procedure) 124

See also opportunities, Opportunity Audit B

Trail basic mode keyboard enablement, about
audit scope, about 117 and differences with extended mode 84
audit table, about purging records 134 batch printing
Audit Trail Engine business service, about See also client-based batch printing;

and exposed methods (table) 120 server-based batch printing
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server print menu items, adding on
Correspondence and Fulfillment
screens 334
setting up, about 333
bep utility, about loading D&B data on
Microsoft SQL server 446
bookmarks
component documents, defining 403
mapping to Siebel fields 365
presentation field mappings, defining 365
template slides, creating 348
Broadcast Message business component
fields, table of 149
bulk copy process (bcp) utility 446
business components
See also individual business component
entries
audit trail, disabling for individual
business component 127
audit trail, linking to 132
audited, configuring for 127
audited, determining whether it can be
audited 118
business components containing foreign
keys to a child, modifying 170
business components containing foreign
keys, modifying 170
identical user key column names,
example of handling (table) 171
primary business components (table) 496
proposal field mappings, sample 413
business objects
prebuilt content objects, relation to
(table) 496
in presentations 346
proposal field mappings, sample data 413

C

cache, clearing 104

caching, about turning off microsite page
caching 241

calendar

Version 7.5, Rev. C

See also calendar, information for
configurators
business scenario calendar access
administration 292
business scenario resource administration
292
calendar activities, administering
resources 295
calendar view, removing To Do List 301
calendars to which an employee has
access, viewing 296
employee’s Calendar Owner drop-down
list, removing all employees from 298
employee’s calendar, giving another
employee access to 296
employees’ Calendar Access List views,
removing an employee from 298
process flow for calendar administration,
example 294
resources, about 291
Calendar Access List views, removing an
employee from 298
Calendar Detail applet, about changing
required fields 301
Calendar Owner drop-down list, removing
all employees from 298
calendar, information for configurators
See also calendar
Calendar Detail applet, about changing
required fields 301
days displayed in Calendar Gantt chart,
changing 299
retroactive alarms, about changing
number of days for 300
To Do List, removing from the calendar
view 301
case sensitivity
about and Siebel applications 88
case insensitivity, enabling application
wide 89
case insensitivity, enabling application
wide Siebel Dedicated Web Client 90
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case insensitivity, enabling Siebel Web
Client 89
field-specific case insensitivity, enabling
92
InsensitivityFactor parameter, modifying
91
catalog category content object, about and
business components 498
catalog content object, about and business
components 497
charts, supporting currency conversion 63
See also currency conversion, setting up
child Web browser, adding 98
client-based batch printing
See also printing
about 332
default printer, changing 338
Internet Explorer, configuring to allow
printing 337
printer connection, adding to your
desktop 338
printing documents (procedure) 338
component documents
mapping fields, procedure 404

mappings and templates, associating 406

presentation field mapping, creating a
record for mapping 366

presentation field mappings, defining 365
proposal field mapping, creating a record

for mapping 404
proposal mapping bookmarks, defining
403
components
compared to Presentation Library
documents 369
presentation templates, adding to 361
Proposal Library, adding to 409
proposal templates, adding to 398
configuring
Multi-Value Group fields, controlling
query behavior 55
constrained list of values
See list of values, constrained
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constrained pick lists
See list of values, constrained
Contact Us account, adding 81
content
See also Content Center
content item, adding or editing 186
content, approving 187
contributors and approvers, setting up
182
defined 162
Content Asset Management, business
scenario 167
Content Asset Type, defined 163
content assets
See also Content Center; content sets
checking in and out 199
configurators, information for 203
Content Asset commands, list of 200
content asset record properties, reviewing
and editing 196
Content Asset Types view, about 202
content set, adding content assets to 193
content sets, defining to contain contents
assets 191
defined 162, 190
HTML content, editing 201
page, adding to 229
search indexes, about creating 241
Content Center
See also content assets; content objects;
content sets
about and features 159
auto complete workflow, about 177
business components containing foreign
keys to a child, modifying 170
business components containing foreign
keys, modifying 170
business components, handling identical
user key column names (table) 171
business scenario for Content Asset
Management 167
business scenario for Content Center 166
configurators, information for 203
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content approval process (single
approver) workflow, about 175
content item approval process, about
setting up workflows 174
content item state model, about 174
content item, adding or editing 186
Content Project business service, about
and arguments 179
content project status, publishing 188
content project status, reviewing 184
content projects approval workflow,
starting 183
content projects publication workflow,
starting 189
content projects, creating 183
content staging environment, required
components for 164
Content Task Subprocess, about 176
content type, setting up 180
content, approving 187
contributors and approvers, setting up
182
integration object, creating 172
integration objects, modifying 173
job roles and terms, table of 161
process flow example (diagram) 168
publication workflows, setting up 178
staging and production environment,
maintaining consistency 164
staging to production transfer, process
overview 169
terminology, table 162
content item approval process, setting up
about 174
auto complete workflow, about 177
content approval (single approver)
workflow, about 175
Content Task Subprocess, about 176
state model, about 174
content item, defined 162
content objects
See also Content Center
catalog category content object 498
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catalog content object 497
ContentBase Asset content object 498
ContentBase Set content object 499
ContentBase Type content object 500
defined 162
ERM Group News Item content object 501
integration objects, creating 172
literature content object 503
microsite management page content
object 503
microsite management page item content
object 505
prebuilt content objects (table) 496
price list content object 506
product class content object 508
product content object 507
Product Feature content object, about and
business components 508
product line content object 509
resolution item content object 509
solution content object 509
transfer process, overview 169
volume discount content object 510
Content Project business service, about and
arguments 179
content projects
approval workflow, starting 183
creating 183
project status, reviewing 184
publication workflow, starting 189
publishing 188
content sets
See also Content Center; content assets
content assets, adding to 193
content assets, defining to contain 191
home page, setting for 195
content staging environment, setting up
required components 164
staging and production environments,
maintaining consistency 164
content types
defined 163
setting up 180
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ContentBase Content Asset content object,
about and business components 498
ContentBase Content Type, about and
business components 500
ContentBase Set content object, about and
business components 499
CookiesAllowed, additional browser
capabilities 94
correspondence
See also correspondence templates, using;
correspondence templates, creating;
printing; fulfillment centers; Siebel
Document Server
about 303
batch printing, about 332
batch printing, about setting up 333
Microsoft Office, installing 306
Remote Web Client, system requirements
304
server print menu items, adding on
Correspondence and Fulfillment
screens 334
server-based batch printing, configuring
335
Siebel Document Server, hardware
requirements 305
Siebel Document Server, installing 305
Siebel Document Server, steps to install
305
correspondence templates, creating
See also correspondence; correspondence
templates, using
deleting a template 322
existing template file, opening 319
template record, adding 320
template, about modifying and renaming
319
correspondence templates, using
See also correspondence; correspondence
templates, creating
deleting a template 322
file, inserting into a template 323
merge fields, adding in Office XP 317
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merge fields, adding using Microsoft
Word 2000 316
merge fields, changing 316
text, changing of a template file 315
working with, about 313
Create Content tool, using to add HTML
directly to a page 227
Create Rerouted Oppty Activity workflow,
setting up 285
currencies, setting up
See also currency conversion, setting up
active, making currencies active 57
currencies, defining 57
currency conversion, setting up
See also currencies, setting up
Euro Triangulation method, about 61
exchange rates, setting up 60
Siebel applications, conversion occurs in
62
triangulation conversion, process of 62
custom hierarchy
about 243
creating 249
creating based on default hierarchy 249
maintaining 251
organization, assigning custom hierarchy
to 250

D
D&B data
initial load and SQL files 452
initial load scripts 452
Update Manager table names diagrams
450
D&B integration
See also D&B Update Manager
account promotion and prospect list
creation configuration 463
Account Promotion and Prospect Lists,
field mapping for 471
business scenarios 437
configuration guidelines (table) 462
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D&B real-time search and update, setting
up symbolic URL for 460
D&B real-time search, updating field
mapping for 469
D&B report ordering, setting up symbolic
URL for 460
D&B Update Manager process, field
mapping for 466
DB2, loading D&B data on 445
D-U-N-S number, understanding 439
files required from D&B 441
loading an deleting data, table of 443
loading D&B data, staging tables for 442
Microsoft SQL Server, loading D&B data
on 446
Oracle, loading D&B data on 444
server components, updating 448
Siebel update server component, about
running 455
update server process configuration 462
D&B reports, accessing 460
D&B Update Manager
D&B server (multiple task process),
running with Siebel application 457
D&B server (single task process), running
within your Siebel application 456
D&B server component (single or multiple
task process), running from a
command line 458
Siebel Server (multiple task process),
running from within Siebel
application 458
Siebel Server (single or multiple task
process), running from a command
line 459
Siebel Server (single task process),
running with Siebel application 457
Siebel, running without updating account
name or location 464
D&B, integrating data
files and format, required 441
loading, about 442
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multiple processes and D-U-N-S number
processing 452
data
import, list of values, considerations 114
seed data, about 32
data and time stamps, about 80
Data Universal Numbering System number
See D-U-N-S number
database auditing
about 119
Siebel Web Client, audit trail option 115
databases, selecting 30
date formats, about 76
DB2, loading D&B data on 445
debugging, enabling additional logging 311
dedicated Web clients
application-wide case insensitivity,
enabling 90
databases, selecting 30
error message, first time logging in 25
license key, entering 25
message broadcasting, enabling or
disabling 143
Siebel application, starting for the first
time 22
default hierarchy
about 243
creating 247
Delete command, about 200
deleting
activity template 269
correspondence template 322
employee from all employee’s Calendar
Access List views 298
employees from Calendar Owner drop-
down list 298
languages, about and mobile Web client
synchronization 87
page 240
page item 236
To Do List, removing from the calendar
view 301
demo user, logging on 31
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Display Value field, about modifying and
updating records 108
dnbinitial.sql file, using to load D&B data
452
Document Server
requests, routing all requests to 311
Siebel Presentations, about setting up 343
document templates, sample database 375
DocumentServerViewHTML parameter,
about 310
D-U-N-S number
about 439
warning about multiple processes 452
dynamic pick lists
constraining, about 114
using, about 99

EAI objects
See integration objects
eBriefing Bulletin, about option to distribute
messages as bulletins 145
email address, about adding 81
email, automatic notification
See notification workflows
employee setup
completing (procedure) 40
list of 39
employees
activity assignment methods, about 254
Enterprise Application Integration (EAI)
See integration objects
ERM Group News Item, about and business
components 501
Euro Trangulation method
about 61
triangulation conversion, process of 62
European Monetary Union (EMU),
triangulation, about 62
exchange rates
multiple currencies, about setting up for
57

524 Applications Administration Guide

setting up 60
EXISTS statement, disabling 55
expense types, setting up
about and pretasks 64
expense types, setting up (procedure) 64
extended mode keyboard enablement,
about and conditions 83

F
field mappings
associating with presentation templates
368
associating with templates 406
mapping records for presentation,
creating 366
mapping records for proposals, creating
404
presentations fields, mapping procedure
367
presentations, about 365
proposals, about 403
proposals, creating 404
field-specific case insensitivity, enabling 92
file auditing
about 119
audit trail recovery, about 120
Siebel Web Client, audit trail option 115
file, adding to a page 231
forecasting, about currency conversion 63
See also currency conversion, setting up
FrameSupport, additional browser
capabilities 94
fulfillment centers
adding 329
fulfillment center records, modifying or
deleting 330
literature item Kkit, about and viewing 422
monitoring fulfillment, about 331
reasons for using 328
Siebel correspondence, giving access to
330
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G
Get Account ASI, about 478
Get Manager Email process, setting up 288
global accounts
account hierarchies, types of 243
business scenario for global account
administration 244
custom hierarchy based on the default
hierarchy, creating 249
custom hierarchy, assigning to an
organization 250
custom hierarchy, creating 249
custom hierarchy, maintaining 251
default hierarchy, creating 247
process flow for global account
administration, example 246
global time zone support
See time zone support, administering
graphic, adding to page 231
guide
audience of 15
organization of 16

hierarchy
See global accounts
High Interactivity mode, and keyboard
accelerators 83
[H] high message, severity level 147
Highlnteract, additional browser
capabilities 94
home page, setting for a content sets 195
HTML
content, editing 201
documents, enabling (procedure) 310
enabling generation, about 309
page, adding directly to 227
Siebel Presentations, display in HTML
format 374
Siebel Proposals, display in HTML format
412
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|
importing audit trail items into Siebel
database 134
industries, adding an industry 86
InsensitivityFactor parameter, modifying 91
Insert Content tool, using to add content
assets to a page 229
Insert File tool, using to insert file to a page
231
Insert Image tool, using to insert graphic to
a page 231
installation
Document Server, hardware requirements
305
Document Server, installing Siebel Server
on host machine 305
Document Server, steps to install 305
software required, table 21
integration objects
creating 172
modifying 173
integration using ASIs
inbound Web service, setting up 475
outbound Web service, setting up 474
workflow descriptions 478
workflows, activating 476
international telephone formats, about
entering and format logic 71
Internet Explorer 5.0, adding JumpTab
capability 94

J

JumpTab capability, adding for Internet
Explorer 5.0 94

K

keyboard accelerators
about using and examples 82
basic mode, about and differences 84
extended mode, about and conditions 83
note, automatic browser detection for
keyboard enablement 85
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L

Language Independent Code
list of values, about changing 108
list-of-values type, about within the 102
language independent values (LIV)
Language Independent Code field, about
106
list of values, about changing 108
languages, adding 87
leads, rerouting 285
license keys
about 24
correcting errors 26
fields, table of 28
first license key, entering 25
hiding access to 29
option module license key 25
Siebel application, entering additional
license keys using 26
Siebel application, starting the first time
22
Siebel Tools, entering additional license
keys using 27
Link App View tool, using to create link
from page to view in Siebel app 222
Link Existing Page tool, using to create link
between microsite management pages
220
list of values (LOV)
about 99
cache, clearing 104
caution, modifying seed data 108
inactivating a value, about and procedure
110
items, modifying 109
Language Independent Code values (LIV)
108
list-of-values type, identifying for a
display value 101
LOV data, viewing 100
LOV record, fields in (table) 105
modifying, about 108
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new value, adding to an existing list 102
list of values, constrained
about 111
Parent LIC attribute, about changing
parent Area 114
Parent LIC attribute, about making values
hierarchically dependent 111
Siebel EIM considerations 114
literature
See Siebel Literature
literature item kit
See Siebel Literature, literature item kit
literature prebuilt content object, about and
business components 503
LIVs
Language Independent Code field, about
106
list of values, about changing for 108
local database, about 30
locales, setting up
about 43
creating (procedure) 43
locale name, creating translation for 47
Lock command, about 200
logging on as demo user 31
logging, enabling additional logging 311
LOV
See list of values (LOV); list of values,
constrained

M
Management Responsibility Code, about
441
Marketing Data file, about 441
merge fields
See also correspondence templates,
creating
about 313
additional merge field, configuring
(procedure) 326
configuring, about 325
sources and uses, summary of (table) 326
message broadcasting
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alert messages, about and example 138

alert messages, creating and sending 152

Broadcast Message business component
fields, table of 149

business scenario, using alerts 140

message broadcast script, sample of 150

message text, about automatically
updating 149

messages, creating and sending 145

mobile and dedicated Web clients,
enabling or disabling 143

multiple severity levels, sending 147

overview 137

process flow example 141

server level, enabling/disabling message
broadcasting 142

severity level, about using to format
message text and tags 147

severity levels 147

microsite management

business scenario 209

configurators information 241

content assets, adding to a page 229

Content Center, about using with 210

features 205

file or graphic, adding to a page 231

HTML, adding directly to a page 227

link to external pages, creating 224

link, creating between microsite
management pages 220

link, creating from page to view in Siebel
app 222

microsite management page content
object, about and business
components 503

microsite management page item content
object, about and business
components 505

microsite page example 207

new page, creating using Page Designer
view 216

Page Administration Explorer tree,
example 212
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Page Designer view, about 215
process flow example 211
root-level page, creating 214
search indexes, about creating 241
structured content, about 205
unstructured content, about 205
microsite page caching, about turning off
241
Microsoft Office, installing 306
Microsoft PowerPoint
presentation templates, about creating in
345
Siebel software used to generate Web
documents 379
Microsoft SQL Server, loading D&B data on
446
Microsoft Word
correspondence template text, changing
315
correspondence templates, using,
changing merge fields 316
correspondence, use in 304
merge fields, adding to the template 316
proposal template components, creating
with bookmarks 384
proposal templates, creating in 381
Siebel software used to generate Web
documents 379
mobile Web clients, enabling or disabling
message broadcasting 143
MRC file, about 441
MSWordLiveCount, using to configure
application recycle period 310
multiple currencies, about setting up
exchange rates for 57
multiple processes and D-U-N-S number
processing 452
Multi-Value Group fields, controlling query
behavior 55

non-North American telephone formats,
specifying 70
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[N] normal message, severity level 147
North American telephone formats, default
format for 69

notification workflows

communications profile, setting up 280

delivery of emails, restricting conditions
for 286

email notifications, stop sending 287

Get Manager Email process, setting up
288

opportunities lost notification process,
about 283

opportunity assigned notification process,
about 282

opportunity inactive notification process
282

opportunity won notification process 284

opportunity workflow email, modifying
the language of 286

opportunity workflows, setting up
(procedure) 281

setup steps 279

time lapse between lead acceptance and
inactive notification, changing 282

time lapse between lead assignment and
email delivery, modifying 283

Opportunity Audit Trail, enabling and
tracking additional fields 289

opportunity inactive notification process,
about 282

opportunity lost notification process,
about 283

opportunity reroute activity, setting up
285

opportunity won notification process,
about 284

opportunity workflow email, modifying
the language of 286

opportunity workflows, setting up
(procedure) 281

time lapse between lead acceptance and
inactive notification, changing 282

time lapse between lead assignment and
email delivery, modifying 283

Oracle, loading D&B data on 444
organization
custom hierarchy, assigning to 250
guide, of 16

P

page
See also microsite management
content assets, adding to a page 229

0 deleting a page 240

Office XP, adding merge fields to the file or graphic, adding to a page 231
correspondence template 317 HTML, adding directly to a page 227

opportunities new page, creating 216

about and predefined opportunities, list
of 278

communications profile, setting up 280

delivery of emails, restricting conditions
for 286

email notifications, stop sending 287

Get Manager Email process, setting up
288

notification workflows, setup steps 279

opportunity assigned notification process,
about 282
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page content items, grouping 238
page item, editing 234
page layout, canceling changes to 237
page record, saving 237
previewing 239
root-level page, creating 214
root-level pages and structure 212
tree, finding in and modifying properties
213
Page Administration Explorer tree, example
212
See also microsite management
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Page Designer view
See also microsite management
about 215
new page, creating 216
page item
deleting page item 236
editing 234
pager company, setting up 75
Parent LIC attribute
list of values, about making values
hierarchically dependent 111
parent Area, about changing 114
parent Web browser, adding 97
password and default user ID 22
payment terms, setting up (procedure) 66
periods, setting up
about 67
period units, associating with a period 68
setting up (procedure) 67
pick lists
See dynamic pick lists; static pick lists
position
audit trail, restricting by position
(procedure) 129
PowerPoint
See Microsoft PowerPoint
prebuilt content objects, about and business
components (table) 496
predefined queries, setting up
about 53
creating by saving a query 54
Predefined Query view, setting up
predefined query in 54
preferences, system (table of) 481
Presentation Library
See also presentation templates; Siebel
Presentations
about 369
components, adding 371
content, recommending 371
customized presentation, creating 372
presentation files, about creating 370
sections, adding to 370
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types of documents available 369
presentation templates
See also Presentation Library; Siebel
Presentations
components, adding to templates sections
361
components, creating 348
creating, process of (diagram) 344
field mapping, procedure 367
field mappings, associating with 368
mapping bookmarks, about 365
mapping records, creating 366
Microsoft PowerPoint, about creating in
345
planning the template 346
query conditions, about 363
sample document templates 375
sections, defined 351
styles, creating 347
subsections, adding to 359
table subsections, adding related table
360
template records, creating 349
top-level section, creating 352
top-level section, fields in 355
price lists
price list content object, about and
business components 506
pricing, volume discount content object 510
printing
batch printing correspondence 332
batch printing, about setting up 333
client-based batch printing, changing
default printer 338
client-based printing, printing documents
(procedure) 338
DocServer machine, adding printer
connection to 336
Internet Explorer, configuring to allow
client-batch printing 337
printing connection, adding to your
desktop 338
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server print menu items, adding on
Correspondence and Fulfillment
screens 334
server-based batch printer, changing
default printer 336
server-based batch printing, specifying a
printer 339
server-based printing, printing
(procedure) 339
Product Feature, about and business
components 508
products
product class content object, about and
business components 508
product content object, about and
business components 507
product line content object, about and
business components 509
Proposal Library
See also proposal templates; Siebel
Proposals
about 407
components, adding 409
documents, creating 408
organizing 408
proposal content, recommending 409
proposal templates
See also Proposal Library; Siebel
Proposals
components, adding 398
components, creating with Microsoft
Word 384
creating, process overview 379
Document Template Administration view,
fields 390
mapping bookmarks, about 403
mapping fields, procedure 404
mapping records, creating 404
mappings and templates, associating 406
Microsoft Word, creating in 381
planning the template 382
proposal content, recommending 409
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query conditions, about 400

sample templates 414

sections, defined 388

styles document for templates, creating
383

subsections, adding to an existing section
395

table subsections, adding related 396

TAS Opportunity Plan templates, about
using 414

template documents, assembling 386

top-level sections, creating 389

proposals, configuring report generation
309

Q

queries
audit trail information (procedure) 135
presentation templates, using in 363
proposal templates, using in 400
telephone number, examples (table) 73
telephone numbers, about using and

example 73

quotes, about changing currency code 63

See also currency conversion, setting up

rate lists, about currency conversion 63
See also currency conversion, setting up
remote
See Siebel Remote
Replace command, about 200
replication (Siebel Replication), about using
audit trail 119
reports
currency conversion supported in 63
generation, configuring (used by
Proposals) 309
resolution item content object, about and
business components 509
resources, about 291
See also calendar
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responsibility, restricting audit trail by
(procedure) 129
retroactive alarms, about changing the
number of days 300
root-level page
about 212
creating 214

S

S_audit_item table, purging 134
SADMIN ID, about modifying responsibility
22
sales methods
about 258
creating and associated sales stages 263
sales stage, defining 264
sample database, about and logging in 30
Satmetrix survey reports, setting up
about 48
access to Satmetrix Reports, setting up
symbolic URL for 49
WI_ARG-TYPE, extending the List of
Values for 48
Save to File command, about 200
script, sample message broadcasting script
150
search indexes, about creating 241
sections, presentations
See also presentation templates;
Presentation Library
adding components to 361
defined 351
Presentation Library, adding sections 370
top-level section, creating 352
sections, proposals, defined 388
See also proposal templates
seed data
about 32
list of values, modifying 108
server database, about 30
server-based batch printing
See also printing
about 332
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configurating printers for 335
default printer, changing 336
DocServer machine, adding a printer
connection 336
documents, printing 339
printer, specifying 339
setup tasks
application administration tasks, table of
33
employee setup, completing (list of) 39
employee setup, completing (procedure)
40
locale name, creating translation for 47
locales, about setting up 43
locales, creating (procedure) 43
Satmetrix survey reports, setting up 48
skills, associating with an organization 42
summary of (table) 36
views, defining 38
severity levels, about using for message
broadcasting 147
ShowMessageBar parameter, about setting
to true 144
SIC (Standard Industrial Classification code)
file, about and D&B data 441
Siebel applications, hiding access to license
keys 29
Siebel correspondence
See correspondence
Siebel Dedicated Web Client
See dedicated Web clients
Siebel Document Server
additional logging, enabling 311
application recycle period, configuring
310
component group, about enabling 307
components, about synchronizing step
308
configuration process overview 307
hardware requirements 305
HTML generation, about enabling 309
HTML generation, enabling (procedure)
310
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installation process overview 305

proposal configuration requirement 309

Siebel Server, about installing on
dedicated host machine 305

Siebel software used to generate Web
documents 379

steps to install 305

target server, specifying 311

UNIX requirement 378

Siebel eBriefings

eBriefing Bulletin, about option to
distribute messages as bulletins 145

literature, sharing 431

ordering D&B reports 461

Siebel Literature

category, associating literature with a
category using the Catalog
Administration screen 433

category, associating literature with a
category using the Literature
Administration screen 432

existing literature file, modifying 417

item Kits, about and fulfillment center 422

literature files, creating new 417

literature item kit, adding 423

literature Kkits, about 415

literature record, adding 418

sharing literature though eBriefings 431

sharing literature though the
Correspondence screen 430

sharing literature though the Decisions
Issues screen 429

sharing though the Product screen 426

sharing through the Competitors screen
427

translated document, associating with a
literature record 421

Siebel objects, association with activity

objects (table) 255

Siebel OLE Automation, about 149

See also message broadcasting

Siebel Presentations
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See also Presentation Library;
presentation templates
customized presentation, creating 372
Document Server, about setting up 343
HTML format, displaying in 374
Siebel Remote Web Client system
requirements 342
Siebel Web Client system requirements
342
Siebel Proposals
See also Proposal Library; proposal
templates
document server, about using Siebel
Server in UNIX 378
field mappings, sample data 413
HTML format, displaying in 412
Siebel Remote Web Client system
requirements 378
Siebel Web Client system requirements
378
TAS Opportunity Plan template, about
using 414
templates, process overview 379
templates, samples 414
Siebel Remote
audit trail, about using 119
Siebel Correspondence, system
requirements 304
Siebel Presentations, system
requirements 342
Siebel Replication, about using audit trail
119
Siebel Sales Assistant
new sales method, defining 263
sales methods, described 258
sales stage, defining 263
Siebel Tools
Audit Trail Engine business service,
enabling 124
audit trail, configuring customer
application for 124
license keys, entering additional using
Tools 27
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license keys, hiding access to 29
Siebel Web Client
application-wide case insensitivity,
enabling 89
Siebel Presentations, system
requirements 342
starting application, first time 23
Siebel XML-based publication service,
setting up Content Center publication
workflows 178
skills
about assigning 42
software required, table 21
solution, prebuilt content object (table) 509
.sq!l (dnbinitial.sql), using to load D&B data
452
Standard Industrial Classification code,
about and D&B data 441
static pick lists
about 99
constraining, about 111
structured content about 205
Synchronization Account ASI, about 478
system preferences
setting 52
table of 481

T

TAS Customer Milestone activity template,
creating in a localized application 274
TAS Opportunity Plan template, about using
414
telephone formats, specifying
See also telephone numbers
default telephone formats, about 69
EIM, about importing information with
74
international telephone formats, about
entering and format logic 71
non-North American telephone formats,
specifying 70
North American telephone formats,
default format for 69
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queries, using, about and example 73
querying for telephone numbers, table of
examples 73
telephone number format examples
(table) 72
telephone numbers, entering numbers in
place of digits 72
unformatted telephone numbers, about
adding or changing number format 72
telephone numbers
See also telephone formats, specifying
caution, entering letters in place of digits
72
queries using, about and example 73
Telocator Alphanumeric Protocol (TAP),
pager support of 75
templates
See correspondence templates, creating;
correspondence templates, using;
proposal templates
third-party applications
See Microsoft Office; Microsoft
PowerPoint; Microsoft Word
time zone support, administering
about 78
date and time stamps, about 80
time zone settings, modifying 78
translations of time zones, maintaining 79
To Do List, removing from the calendar view
301

U

Unlock command, about 200
unstructured content, about 205

[U] urgent message, severity level 147
user ID and password, default 22
user, restricting audit trail by user 129

vV

views
defining, about and procedure 38
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mmlayout.txt file, adding new views to
241

volume discount content object, about and

business components 510

w

Web browser
additional, adding Web browsers 96
capabilities, about adding 93
capability, adding (procedure) 95
capability, adding JumpTab 94
child Web browser, adding 98
extended capabilities, list of 94
parent Web browser, adding 97
required browser capabilities 96
Web pages, managing
See microsite management
Word
See Microsoft Word
workflows
auto complete 177
communications profile, setting up 280
content approval (single approver)
workflow 175
content item approval process, about
setting up 174
content item state model, about 174
Content Task Subprocess, about 176
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Create Rerouted Oppty Activity, setting up
285

delivery of emails, restricting conditions
for 286

email notifications, stop sending 287

Get Manager Email process, setting up
288

opportunity assigned notification process,
about 282

opportunity inactive notification process,
about 282

opportunity lost notification process,
about 283

opportunity notification workflow, setup
steps 279

opportunity won notification process 284

opportunity workflow email, modifying
the language of 286

opportunity workflows, setting up
(procedure) 281

publication workflows, setting up 178

time lapse between lead acceptance and
inactive notification, changing 282

time lapse between lead assignment and
email delivery, modifying 283

ZIP Codes, adding 77
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