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Introduction
This guide explains how to set up and administer Siebel Employee Relationship 
Management (ERM).

Although job titles and duties at your company might differ from the positions listed 
in the following table, the audience for this guide consists primarily of employees 
in these categories.

Compensation 
Planning 
Administrator

Persons who administer and manage the Compensation Planning 
application.

Content Manager Persons who have access to the Group News Authoring views and 
who are responsible for authoring and approving news stories. 

ERM Group News 
Administrator

Persons who have access to the Group News Administration views 
and who are responsible for creating content paths and editing 
submitted or completed news stories. 

HelpDesk Agent Persons responsible for administrating the Siebel knowledge base, 
changing the status of Alerts Online, and for setting up Assets 
Management. Persons with this responsibility have the ability to 
provide full-level support (Tier 1 and Tier 2).

Human Resources 
Administrator

Many organizations have Human Resources administrators to 
assist with creating and maintaining employee profiles. This 
individual can be responsible for setting up employees and 
handling employee requests to change profile information.

Marketing 
Administrators

Persons responsible for setting up and maintaining a marketing 
department. Duties include designing and managing campaigns, 
product marketing information, and product distribution lists.

Siebel Application 
Administrators

Persons responsible for planning, setting up, and maintaining 
Siebel applications.

Siebel Application 
Developers 

Persons who plan, implement, and configure Siebel applications, 
possibly adding new functionality.

Siebel System 
Administrators

Persons responsible for the whole system, including installing, 
maintaining, and upgrading Siebel applications. 
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 11



Introduction

How This Guide Is Organized
To benefit from the configuration sections of this book, you should have an 
understanding of the Siebel environment, Siebel applications, and the Web 
environment. You should also feel comfortable working with Siebel Tools.

How This Guide Is Organized
This guide covers general setup and administrative procedures for each Siebel ERM 
module. Each section explains a Siebel ERM module.
12 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Introduction

Additional Resources
Additional Resources 
The following Siebel application guides include information that may be relevant to 
your use of Siebel Employee Relationship Management:

■ For development resources and information, see Siebel Tools Reference and Siebel 
Tools Online Help.

■ For information about installing Siebel applications or general Siebel 
parameters, see Siebel Server Installation Guide for Microsoft Windows, Siebel 
Server Installation Guide for UNIX, and Siebel Web Client Administration Guide.

■ For more information about the zero-footprint architecture, see Siebel Web Client 
Administration Guide.

■ For more information about configuring Web services and setting up 
demonstration scripts, see Integration Platform Technologies: Siebel eBusiness 
Application Integration Volume II.

■ For information about creating Predefined Queries (PDQs), Microsites, D&B 
reports and services, and other administrative procedures, see Applications 
Administration Guide.

■ For more information about responsibilities and visibility rules, see the Security 
Guide for Siebel eBusiness Applications.

■ For more information about tracking profiles, see Siebel eBriefings 
Administration Guide .

■ For information about course registration, course catalog, curriculum planning, 
skills testing and certification, see Siebel eTraining Guide.

■ For more information on Workforce Analytics, see Siebel Analytics User Guide.
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Introduction

Revision History
Revision History
Siebel Employee Relationship Management Administration Guide, Version 7.5, 
Rev. A

January 2003 Bookshelf
Table 1. Changes Made in Rev. A for January 2003 Bookshelf

Topic Revision

“Administrator Setup Tasks” on page 46 Revised format for tasks from text to 
table. Configuration information moved 
to separate chapter, Chapter 15, 
“Configuring Siebel ERM.” 

Business Scenarios Business scenarios revised, and minor 
edits throughout book completed.

Example Process sections Example Process section added for each 
chapter of the book, with cross-
references to procedures.

Procedures order Order of procedures changed 
throughout document to reflect process 
flow.
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Overview of Siebel ERM 1
Siebel ERM is an integrated suite of more than 25 Web-based applications designed 
for use by employees within an organization. This chapter provides an overview of 
the applications that make up Siebel ERM.
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Overview of Siebel ERM

Key Features of Siebel ERM
Key Features of Siebel ERM
Siebel Employee Relationship Management (ERM) provides a single point of access 
to a variety of information resources within an organization.

Siebel ERM helps the organizations communicate news, deliver training, and 
support employee productivity and satisfaction. In addition, Siebel ERM helps 
employees align their objectives with those of the organization and provides access 
to application data, news, business information, productivity tools, employee self-
service solutions, and other resources in a personalized Web environment. 

Siebel ERM provides the following features:

■ Employee Directory. Siebel Employee Directory allows users and administrators to 
manage and view employee profile information. For more information, see 
Chapter 3, “Setting Up Employee Directory.”

■ Competency Management and career planning. Siebel Competency Management 
allows employees and managers associate specific skills with job and employee 
profiles. For more information, see Chapter 5, “Setting Up Competency 
Management.”

■ Objectives and Reviews. Siebel Objectives and Reviews is used to set employee 
objectives and assess performance using periodic and annual reviews. For more 
information, see Chapter 4, “Setting Up Objectives and Reviews.”

■ Compensation Planning. Siebel Compensation Planning is a compensation 
planning application that allows organizations to plan for merit-based and 
promotion-based salary increases, cash bonuses, and stock grants. For more 
information, see Chapter 6, “Setting Up Compensation Planning.”

■ Group News. Siebel Group News allows the organization’s authors to create, edit, 
approve, preview, and publish real-time news content. For more information, see 
Chapter 8, “Managing Group News.”

■ Unified Help Desk. Siebel HelpDesk allows employees to submit and track service 
requests using the organization intranet and solve problems by providing access 
to FAQs and interactive diagnostic tools. For more information, see Chapter 10, 
“Setting Up Siebel HelpDesk.”
16 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Overview of Siebel ERM

Key Features of Siebel ERM
■ Employee Self-Service. Siebel Employee Self-Service (ESS) allows employees to 
process routine and frequent transactions using the Web. This application 
provides automated processes that guide users through necessary steps, 
incorporate relevant data, accept user input, and are automatically routed for 
processing and approvals. For more information, see Chapter 11, “Setting Up 
Employee Self-Service.”

■ Unified Approvals Inbox. The Unified Approvals Inbox allows managers and 
employees with review tasks to view and act on approval requests from a single 
unified screen. Approvals Inbox also allows administrators to create and manage 
approval flows. For more information, see Chapter 12, “Setting Up Unified 
Approvals Inbox.”

■ Projects. Siebel Projects provides a shared company workspace that allows 
employees within an organization, regardless of physical location, to organize, 
coordinate and manage their formal and ad-hoc project assignments. For more 
information, see Chapter 13, “Setting Up Siebel Projects.”

■ Microsite Management. Microsite Management allows administrators to create 
and maintain Web pages within a Siebel application. For more information about 
microsites, see Applications Administration Guide.

■ Customer Content. Customer content includes several briefing pages that provide 
users with important business information about accounts, competitors, and 
other organizations. For more information, see “ERM Briefing Pages” on 
page 28.
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Siebel ERM corporate content applications help organizations create and manage 
content, while providing employees with the tools to access product, customer, and 
industry information from a single, central location. Siebel ERM corporate content 
aggregates business data from multiple sources, such as your Siebel database, the 
Internet, legacy systems, and third-party news services. 

As an administrator, you can configure your Siebel application to show this data in 
one of the following types of Web pages:

■ Home page. This page provides employees with information such as new 
opportunities, service requests, company news, and literature from the Siebel 
Encyclopedia.

NOTE: Siebel Encyclopedia is a feature that aggregates the files and attachments 
used in your Siebel application, such as literature, images, and products. To 
access the Siebel Encyclopedia, users can use one of the predefined views, such 
as Literature, Catalog, or Pricing in the application.

From the Home page, users can search the Web using Internet search engines, 
track expense reports, and view personalized news topics. Users can customize 
and personalize the content that appears on the home page.

■ Briefing pages. These pages provide employees with a briefing-style summary of 
important business information about accounts, competitors, and other 
organizations, and can include recent news, relevant data from the Siebel 
database, and company profiles provided by Siebel eContent Services.

■ Microsite pages. These pages provide employees with information, such as 
corporate announcements, links to literature files, links to HTML files, and other 
key resources. Microsite pages are flexible, giving administrators the ability to 
integrate unstructured content on the same page with Siebel data. Siebel ERM 
ships with several preconfigured Microsite pages, such as the Human Resources 
page.

Siebel ERM also provides a framework for integrating external content in context 
with your Siebel application. 
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Modules and Options
Many Siebel eBusiness Applications modules can be purchased and used with 
Siebel ERM. In addition, optional modules specific to Siebel ERM can be purchased 
to provide enhanced functionality for various business processes.

For information on the optional modules that can be used with Siebel ERM, contact 
your Siebel sales representative or local Siebel Sales Office.

The exact configuration of Siebel applications screens, views, and fields depends on 
your company’s configuration of the application.

For introductory information on using the Siebel applications standard interface, see 
Fundamentals and Online Help.

eEvents Management
The Siebel eEvents Management module lets you plan, execute, and evaluate 
marketing events and set up an eEvents Management Web site where users can 
learn about and register for events. For more information, see Siebel eEvents 
Management Guide.

eAdvisor
The eAdvisor application is intended for users who need advice and guidance to 
configure products, create quotes, or purchase products from Siebel Customer and 
Partner Application Web sites. For more information, see Siebel Interactive Designer 
Administration Guide.

eTraining
Siebel eTraining provides a Learning Management System (LMS) for hosting and 
managing end-user training throughout an organization. Siebel eTraining provides 
a Course Registration System, Course Catalog, Curriculum Planning, Skills Testing 
and Certification System as well as a Training Library. A variety of delivery methods 
are supported, including Web-based, instructor-led, pre-recorded and virtual 
classroom training. For more information about setting up or managing eTraining, 
see Siebel eTraining Guide.
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Distance Learning and Employee Training
The Siebel Distance Learning module lets users host training sessions, view a list of 
scheduled training sessions, play recorded presentations, and participate in 
instructor-led training sessions using corporate intranets or the Internet. For more 
information, see Siebel Distance Learning Guide.

Siebel eTraining provides a Learning Management System (LMS) for hosting and 
managing end-user training throughout an organization. Siebel eTraining provides 
a Course Registration System, Course Catalog, Curriculum Planning, Skills Testing 
and Certification System as well as a Training Library. For more information, see 
Siebel eTraining Guide.

Workforce Analytics
Workforce Analytics allows users to analyze, query, send alerts, and report on data 
using the HelpDesk, Performance Management, and eTraining modules. For more 
information on Workforce Analytics, see Siebel Analytics User Guide.
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The Siebel ERM Environment 
Siebel ERM users access the application using a standard Web browser. Siebel ERM 
accesses servers outside your company’s firewall to provide end users with 
information from external content providers, such as Siebel eContent Services. 
Figure 1 shows the Siebel ERM architecture. The Web browser connects to the Web 
server. The Web server connects to the Siebel Gateway, which in turn connects to 
other Siebel servers. The Siebel servers are connected to a database and, through 
the Internet, to eContent Services.

Figure 1. Siebel ERM Architecture
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For more information, see Siebel Web Client Administration Guide.

Siebel eContent Services
Siebel eContent Services is a news subscription service that is integrated with Siebel 
ERM. Customers who subscribe to Siebel eContent Services receive premium news 
and company information from multiple sources that are preconfigured for Siebel 
ERM. Administrators can configure Siebel eContent Services so that relevant 
content is delivered to the appropriate individuals. By associating specific types of 
content with specific groups of users, content can be targeted.

Siebel eContent Services includes leading newswires, business magazines, 
newspapers, and trade journals. It provides news, company profiles, corporate 
relationship information, market data, and other relevant content that appear in 
context with your Siebel data. For more information, see Chapter 9, “Setting Up 
eContent Services.”

Siebel ERM Home Page
When users log in to their Siebel ERM application, the first screen that appears is 
the home page. The home page, a combination of lists and forms, can include 
service requests, recent news about selected accounts and competitors, news about 
the organization, a daily calendar, a graphical announcement that you can 
customize for your organization, and so on.

The ERM home page, shown in Figure 2 on page 23, is personalized for each user. 
When an employee logs in to the application, a personalized message appears on 
the home page.
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In Figure 2, the Corporate Announcements and My News section appear on the left. 
On the right, the My Calendar section appears.

Siebel ERM filters the data and content a user can view based on the visibility rules 
defined in the Siebel application and the user preferences set by the user in a 
tracking profile. Only data targeted for the user appears on the employee’s home 
page.

Figure 2. ERM Home Page
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For more information about visibility rules, see the Security Guide for Siebel 
eBusiness Applications. For more information on tracking profiles, see “Using 
Tracking Profile to Control ERM Home Page Information” on page 40.

Home Page Sections
The internal sections of the home page are described in Table 2. The search and sort 
specifications for internal sections are defined in the predefined query called Home. 
For more information about predefined queries, see “Modifying Siebel ERM 
Predefined Queries” on page 284. 

Table 2. ERM Home Page Siebel Data Sections

Section Description
Controlled by 
Tracking Profile

Account/
Competitor News

Displays recent news articles specifically relating to 
an individual user’s tracked accounts and 
competitors. This content only appears if the 
organization subscribes to Siebel eContent Services.

Yes

Analytics Report Displays personalized or organization-wide reports 
from Siebel Analytics.

Yes

Corporate 
Announcements

Displays links to Web pages, Web pages (appears in-
line), or HTML. These records are entered in the 
Content Layout view with the following attributes: 

■ View = Portal Page Home View

■ Page = Home

■ Section = Body

For more information on microsite management, 
see Applications Administration Guide.

No

Feature Articles Displays new stories, Web pages, or HTML. These 
records are entered in the Content Layout view with 
the following attributes:

■ View = Portal Page Home View

■ Page = Home

■ Section = Body

See “ERM Microsite Pages” on page 38 for more 
information.

No
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Literature Displays links to literature items in the Siebel 
Encyclopedia. Literature topics are defined in the 
user’s tracking profile. The current date must be 
between the release and expiration dates. 

Yes

Map Search Allows users to retrieve maps, directions, and travel 
distance information.

No

My Calendar Allows users to view and maintain their Siebel 
calendars from the home page. The calendar can 
appear in a daily, weekly, or monthly format. Click 
the Time field to enter new activities.

No

My Customer’s 
Service Requests

Displays open service requests created within the 
data duration date that are associated with the 
accounts to which the user is assigned.

No

My Events Allows users to view a list of events for which they 
can register. This section also shows events to 
which users have an open invitation.

No

My News Displays a list of news headlines. The user specifies 
the categories, topics, and related search items. The 
administrator can specify the number of past days 
to search for news stories (history) and the 
maximum number of stories to be returned. Content 
is provided by Siebel eContent Services.

No

My Opportunities Displays the user’s opportunities that have not been 
closed. Opportunities are sorted by new column, 
and then by revenue column in descending order.

No

My Stocks Allows users to select the stocks they want to 
appear. This page can be configured with the user’s 
tracking profile. Allows administrators to embed the 
market information in a section on the home page. 
The section is populated using the information 
provided by a third-party vendor of the customer’s 
choice.

Yes

New Accounts Displays accounts to which the user is assigned and 
that are marked as new. Accounts are sorted by 
name. 

No

Table 2. ERM Home Page Siebel Data Sections

Section Description
Controlled by 
Tracking Profile
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New Bulletins Used to alert users of important company 
announcements. Displays broadcast messages 
defined in the Administration view. Messages that 
are created between the activation and expiration 
dates and designated for Siebel eBriefings appear as 
bulletins in this section. Messages are sorted by 
creation date and then by abstract.

No

New Contacts Displays contacts for whom the user is listed as a 
secondary user. Contacts are sorted by last name 
and then by first name.

No

New Service 
Requests

Displays open service requests associated with the 
accounts to which the user is assigned and that 
were created within the data duration date. Service 
requests are sorted by status, and then by severity.

No

Recommended 
Links

Displays links to recommended Web pages. 
Recommended links are defined as literature items 
in the Siebel Encyclopedia. The literature type is 
Recommended Link and the Web display method is 
not In-Line.

Yes

Today’s Headlines Displays today’s headlines. No

Top Story Displays the top story. No

Weather Displays a current weather summary for the ZIP 
code selected on the user’s tracking profile.

Yes

Web Clips Displays the target Web page of a recommended 
link in-line with other sections. Web clips are 
recommended links stored in the Siebel 
Encyclopedia with a Web display method defined as 
In-Line.

Yes

Web Search Allows users to search the Internet using leading 
search engines.

No

Yellow Pages 
Search

Allows users to locate businesses by address and 
telephone number.

No

Table 2. ERM Home Page Siebel Data Sections

Section Description
Controlled by 
Tracking Profile
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Home Page Sections Containing External Data
Table 3 describes the ERM home page sections that include information from Siebel 
eContent Services.

Table 3. ERM Home Page External Data Sections

Section Description
Controlled by 
Tracking Profile

Company Search Allows users to search the Siebel Company 
database to locate a company and obtain a 
Company Briefing that includes information such 
as Company Profiles and current news.

No

Our Company in 
the News

Displays recent news articles from Siebel eContent 
Services news providers about the user’s 
company.

No

Web Search Allows users to search the Web using a leading 
Internet search engine.

No
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ERM Briefing Pages
Siebel ERM includes several briefing pages that provide users with critical business 
information about accounts, competitors, and other companies.

These briefing pages include:

■ Account briefings. For more information, see “Account Briefings.”

■ Competitor briefings. For more information, see “Competitor Briefings” on 
page 33.

■ Company briefings. For more information, see “Company Briefings” on page 35.
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Account Briefings
Account Briefings help users prepare for customer calls by keeping them informed 
about aspects of their accounts. An Account Briefing is a single Web page that 
summarizes interactions with the customer and includes news and company profile 
information. It also gives users access to related literature in the Siebel 
Encyclopedia, such as presentations, brochures, and recommended links.

Users can access Account Briefings from several views. Each view provides the user 
with a different subset of account records. The views include:

■ My Tracked Accounts. This view shows the accounts selected by users in their 
tracking profiles.

■ My Accounts. This view shows the user’s assigned accounts.

■ My Team’s Account. This view shows the user’s accounts and accounts for which 
the primary sales team member is a direct subordinate of the user.

■ All Accounts. This view shows the accounts to which the user has access based 
on visibility rules.

NOTE: Access to views is based on each user’s responsibilities. Not all users have 
the views listed in this section. For example, only managers have access to My 
Team’s Accounts. For more information about responsibilities and views, see 
Security Guide for Siebel eBusiness Applications.
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Figure 3 shows an example of an Account Briefing. Sample data files have been 
created for some links and literature items (for example, Web Clips) to illustrate the 
ways external data is integrated into eBriefings if the application has a live Internet 
connection using the Siebel eContent datahost. Some links do not appear to work 
because a sample data file has not been created for that link or list. With a live 
connection, you can see the way the functionality works after configuring eBriefings 
to integrate the third-party content you are interested in viewing.

Figure 3. Account Briefing
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Account Briefing Sections with Siebel Data 
Table 4 describes the Account Briefing sections that include data from your Siebel 
database. The search and sort specifications for internal sections are defined in the 
predefined query called Account. For more information about predefined queries, 
see “Modifying Siebel ERM Predefined Queries” on page 284.

Table 4. Account Briefings Siebel Data Sections

Section Description

Account Team Members Displays employees who are on the sales team for the account.

Activities Displays account activities for the last 30 days. Activities are 
sorted by type and then description.

Contacts Displays the contacts related to the account. Contacts are 
sorted by last name and then first name.

Header Displays the name of the current company and a link to the 
company’s home page. It also includes an Edit Layout button 
that allows users to modify the layout of the Account Briefing.

Opportunities Displays account opportunities created in the last 30 days. 
Opportunities are sorted by revenue and then by probability 
percentage, based on the primary user.

Quotes Displays the quotes related to the account. Quotes are sorted 
by end date. Quotes that are less than 30 days old appear.

Recommended Links Displays links to recommended Web pages. Recommended 
links are defined as literature items in the Siebel Encyclopedia. 
The literature type is Recommended Link, and the Web display 
method is not In-Line.

Recommended Literature Displays links to literature items in the Siebel Encyclopedia 
related to the account. The current date must be between the 
release and expiration dates.

Service Agreements Displays the service agreements related to the account. Service 
agreements are sorted by end date. Service agreements that are 
less than 30 days old appear.

Service Requests Displays the service requests related to the account. Service 
requests are sorted by status, creation date, and then severity.
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Account Briefing Sections with External Data 
Table 5 describes the Account Briefing sections that include information from Siebel 
eContent Services.

Table of Contents Displays Account Briefing sections. Sections that include 
available data appear as hyperlinks.

Web Clips Displays a Web page related to this account in-line with other 
sections. Web Clips are recommended links defined in the 
Siebel Encyclopedia with a Web display method of In-Line.

Table 5. Account Briefing External Data Sections

Section Description

Additional Information Links to stock chart and SEC filings for the account and links to 
Internet search engines. When users click these links, the 
search arguments are passed to the target site and a search is 
automatically performed for information about the current 
account.

Corporate Relationships Displays affiliated companies sorted by name.

Market Information Displays stock information such as the current price, last trade, 
the net change for the day, trading volume, 52-week high and 
low, and other market-related data.

News News about the account from external news wires. The number 
of articles and duration of news postings can be configured in 
the Administration view.

Profile Summary of company data provided by a Siebel eContent 
Services content provider.

Table 4. Account Briefings Siebel Data Sections

Section Description
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Competitor Briefings
The Competitor Briefing, shown in Figure 4, helps employees stay informed by 
gathering information about competitors. It provides users with current market 
information, product information, company information, a list of corporate 
affiliations, and access to related literature from the Siebel Encyclopedia.

Users access Competitor Briefings using one of the two following views:

■ My Tracked Competitors. This view shows the accounts selected by users in their 
tracking profiles.

■ All Competitors. This view shows accounts to which the user has access based on 
visibility rules.

Figure 4. Competitor Briefing
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Competitor Briefing Sections with Siebel Data
Table 6 describes the Competitor Briefing sections that display data from the Siebel 
database. The search and sort specifications for internal sections are defined in the 
predefined query called Competitor. For more information about predefined 
queries, see “Modifying Siebel ERM Predefined Queries” on page 284.

Table 6. Competitor Briefing Siebel Data Sections

Section Description

Competitor Literature Displays literature from the Siebel Encyclopedia that has been 
associated with the competitor. Competitor Literature is sorted 
by sales tool type and then by name.

Products Displays a list of competitor products sorted by name. 

Recommended Links Displays links to recommended Web pages. Recommended 
links are defined as literature items in the Siebel Encyclopedia. 
The literature type is Recommended Link, and the Web 
display method is not In-Line.

Recommended Literature Displays links to literature items in the Siebel Encyclopedia 
related to the competitor. The current date must be between 
the literature item’s release and expiration dates. Literature is 
sorted by sales tool type and then by name.

Web Clips Displays a Web page related to this competitor in-line with 
other sections. Web clips are recommended links defined in 
the Siebel Encyclopedia with a Web display method of In-Line.
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Competitor Briefing Sections with External Data
Table 7 describes the Competitor Briefing data sections that include external data 
from Siebel eContent Services.

Company Briefings
Siebel eContent Services publishes a database of thousands of public and private 
companies. Users can get Company Briefings for any of these companies using the 
Company Search form on the home page, as shown in Figure 5. When a user 
initiates a query in the Company Search form by specifying company name and 
search type criteria, matching records from the Siebel eContent Company Database 
appear in the Search Results section with links to Company Briefings. This allows 
users to gather information about organizations that are competitors or accounts.

Table 7. Competitor Briefing External Data Sections

Section Description

Additional Information Links to stock charts, SEC filings, and Internet search engines. 
When users click these links, the search arguments are passed 
to the target site and a search is automatically performed.

Corporate Relationships Displays affiliated companies sorted by name. Users can view 
Company Briefings for these companies. 

Market Information Displays stock information such as the current price, last trade, 
the net change for the day, trading volume, 52-week high and 
low, and other market-related data.

News Displays recent news related to the competitor from Siebel 
eContent Services news providers.

Profile Summary of company data provided by a Siebel eContent 
Services content provider.

Figure 5. Company Search Form
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After the query results are returned, the user can click the name of a company, and 
a Company Briefing appears, as shown in Figure 6. Company Briefings provide 
external information about the company (such as news, a company profile, 
information about corporate affiliates, and links to additional information on the 
Internet).

Figure 6. Company Briefing
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Company Briefing Sections with External Data
Table 8 describes the external data sections that appear in Company Briefings.

Table 8. Company Briefing External Data Sections

Section Description

Additional Information Links to SEC filings for the company and links to Internet 
search engines or other relevant information. When users click 
these links, the search criteria are passed to the target site and 
the search is performed automatically.

Company News Displays recent news articles related to the company from 
Siebel eContent Service news providers.

Company Profile Summary of company data provided by a Siebel eContent 
Service content provider.

Corporate Relationships Displays affiliated companies sorted by name.

Market Information Displays stock information such as the current price, last trade, 
net change for the day, trading volume, 52-week high and low, 
and other market related data.
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ERM Microsite Pages
Siebel ERM includes several template views that allow you to structure and present 
information to users. For example, you might dedicate some of these views to 
publishing department-specific information, such as human resources and sales 
information. You might dedicate other pages to publishing information about cross-
functional topics, such as products and partners.

For more information about microsites, see Applications Administration Guide.
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Figure 7 shows a sample microsite page for Marketing. As illustrated, the Siebel 
application can include microsite pages. The illustration shows the Manufacturing 
microsite that includes several sections on the page. On the left is the Section Map, 
which includes a list of section links to relevant information. The middle section 
includes Feature Articles. On the right of the page are the Top Story section and the 
Quick Picks section, which provide a list of links to other relevant pages and 
information.

Figure 7. Sample Microsite Page
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Using Tracking Profile to Control ERM Home Page Information
The tracking profile allows users to control much of the information that appears 
on the ERM home page in their My Briefing document. Users choose the topics that 
they want to track. For example, users can select the accounts that they want to 
receive news about. Only the information related to the selected topics appears on 
the ERM home page. This allows users to filter out information that is not relevant 
to their interests and responsibilities.

When users first use Siebel ERM, their tracking profiles do not include the accounts, 
competitors, industries, or products that the users want to track. Users must set 
preferences to receive, view, or access the following services:

■ External and internal news and information about tracked accounts and 
competitors 

■ Literature associated with their preferred accounts, products, competitors, and 
industries

■ Market information about selected stocks in the My Stocks section

■ Account or competitor briefings from the Tracked Account or Tracked 
Competitor views

The tracking profile allows users to select:

■ Accounts

■ Competitors

■ Industries 

■ Products

■ News topics

Figure 8 shows the Tracked Accounts list of records. The columns in the list are 
Account Name, Site, and Web Site.

Users can access their tracking profiles by navigating to the Profile screen.
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For more information about tracking profiles, see Siebel eBriefings Administration 
Guide .

Literature from the Siebel Encyclopedia, news, recommended links, and related 
Web clips appear in the user’s ERM home page after the user has subscribed to 
specific accounts.

For example, Figure 9 shows literature items that might appear based on the 
tracking profile defined in Figure 8 on page 41.

The tracking profile controls the following sections of the ERM home page:

■ Account/Competitor News

■ Literature

■ Recommended Links

■ Web Clips

■ My News

For more information about sections on the home page, see Table 2 on page 24 and 
Table 3 on page 27.

Figure 8. Tracked Accounts

Figure 9. Literature List
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Page Layout Preferences and ERM Home Page 
Users can control the layout of the home page and briefing-style pages (Account 
Briefing, Competitor Briefing, and Company Briefing). 

The Content Selection and Layout view, shown in Figure 10, allows users to see the 
order of lists and forms, and whether the lists and forms are visible or hidden. This 
view also allows users to show lists or forms, reposition them, and to return the 
page layout to the default setting. The Content Selection and Layout view appears 
when you click the Edit Layout button at the top of the ERM home page.

Layout preferences are stored as part of the user profile and are independent of the 
client machine being used. For information about providing layout controls for end 
users, see “Setting Up Layout Controls for ERM” on page 288.

Figure 10. Content Selection and Layout View
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Bulletins and ERM Home Page
Bulletins are internal company broadcast messages that alert users to important 
internal events and announcements from your company. Bulletins appear in the 
New Bulletins section of users’ ERM home page. Users see bulletins that are 
associated with their user name or division, or bulletins that are broadcast to the 
entire organization. Typically, bulletins are generated by a system administrator or 
designated employees who have privileges to publish bulletins.

For more information about creating Bulletins, see “Publishing Bulletins on ERM 
Home Page” on page 139.

My Calendar
The My Calendar form appears on the home page and provides users with a 
calendar in daily, weekly, or monthly format. Users can view and maintain 
appointments, as well as view and maintain the calendars of team members who 
have granted access to their calendar. 

Web Search
The Web Search form allows users to search the Internet. Users enter the search 
terms in the Web Search form on the home page, and the results appear in a new 
browser window.

Siebel Search
Users can search the Siebel database by clicking the small binoculars button in the 
upper-right area of the ERM window. Table 9 summarizes the data types you can 
search for and the fields on which you can search.

Table 9. Siebel Search 

You can search for... By entering... Siebel database searched for...

Accounts Account name Accounts in the user’s organization

Contacts Last name All contacts
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ERM Recommended Links
Recommended links are hyperlinks that appear in ERM pages. Administrators 
define and publish recommended links using the Literature Administration views in 
the Siebel application. Recommended links are stored in the Siebel Encyclopedia.

For information on publishing recommended links, see “Publishing Web Clips and 
Recommended Links” on page 135.

ERM Web Clips
Web clips are static Web pages that appear in ERM. Marketing administrators define 
and publish Web clips using the Marketing Administration views in the Siebel 
application. Web clips are stored in the Siebel Encyclopedia as a specialized type of 
recommended link. For more information, see “Publishing Web Clips and 
Recommended Links” on page 135.

Employee by 
previous employer

First name, last 
name, industry, 
previous employer, 
business title, or 
business unit

All previous employers entries

Employee by skill First name, last 
name, skill name, 
or skill level

All skill entries

Employees First name or last 
name

All employees

Literature Name, description, 
or author

All literature in the Siebel Encyclopedia

Objectives First name or last 
name

All completed objectives

Opportunities Name Entries in My Opportunities

Service requests Service request 
number

All service requests in the user’s organization

An answer A question All solutions, literature, and resolution items

Table 9. Siebel Search 

You can search for... By entering... Siebel database searched for...
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This chapter lists the applications administration tasks that are specific to Siebel 
ERM. Use this chapter in combination with Applications Administration Guide.

Applications Administration Guide covers the setup tasks that are common to all 
Siebel eBusiness Applications, such as using license keys, defining employees, and 
defining your company’s structure. It also provides the information that you need 
to perform data administration and document administration tasks.

This guide assumes that you have already installed or completed the upgrade of 
Siebel ERM. If you have not, go to the Server Installation and Upgrade section of the 
Siebel Bookshelf and click the links to the guides that are relevant to your 
company’s implementation.

The Siebel Server Administration Guide describes how to create the Siebel 
Administrator account that is used to perform the tasks described in this guide.
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Table 10 lists and describes the administrative setup tasks that are specific to Siebel 
ERM. The table also directs you to documentation that provides information about 
each task.

When setting up your application, use Table 10 in combination with Applications 
Administration Guide.

Table 10. Administrative Setup Tasks

Administrative Task Description For More Information

Install servers and 
applications, and then 
enter license keys for 
specific Siebel 
applications.

Install Siebel Gateway, Siebel 
Server, Siebel Database Server, 
and Siebel Web Servers.

Refer to Siebel Server 
Installation Guide for the 
operating system you are 
using.

Set up the Application 
Services Interface (ASI) 
to synchronize data 
between ERM and a 
third-party system. 
(Optional)

Configure Web Services, 
activate the Employee ASI 
Workflow, and set up 
synchronization between 
ERM and the third-party 
system.

Chapter 16, “Setting Up an 
Application Services 
Interface.”

Configure ERM for the 
GUESTERM user.

 This user ID verifies that each 
user logging in to Siebel ERM 
sees the proper Home Page 
with the correct page tab. 

“Configuring Siebel ERM for 
GUESTRM User” on page 282

Activate user layout 
control

Activate the home page 
controls that allow users to 
change ERM home page 
layout.

“Setting Up Layout Controls 
for ERM” on page 288

Verify plug-ins and 
viewers

Plug-ins and viewers make it 
possible for users to access 
and work with files created 
using a software application 
such as Microsoft Word or 
Adobe Acrobat when the full 
software application is not 
installed on the user 
computer.

Verify that your users have the 
plug-ins and viewers 
necessary to work with the 
file types they need to access 
while working in Siebel ERM 
and Siebel eBusiness 
Applications.
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Modify Siebel ERM 
Predefined Queries 
(Optional)

Siebel ERM is preconfigured 
with several PDQs that 
administrators can modify.

“Modifying Siebel ERM 
Predefined Queries” on 
page 284.

Set up D&B user 
credentials

If your organization is using 
D&B, you must set up the 
credentials that allow users to 
access reports.

“Establishing D&B User 
Credentials for ERM” on 
page 286.

Table 10. Administrative Setup Tasks

Administrative Task Description For More Information
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The Siebel Employee Directory is a Siebel ERM module that allows users and 
administrators to manage and view employee profile information. This section 
describes the Employee Directory feature and explains how to set up and manage 
employee profiles.
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Managing Information with Employee Directory
Siebel Employee Directory has two key areas of functionality, Employee Profile and 
Employee Locator.

Employee Profile
Siebel Employee Directory uses an employee profile repository to store information 
about each employee in an organization. An employee’s profile includes the 
following types of information:

■ Bio. The Bio view allows employees in an organization to enter short 
biographical information about themselves. This information is then made 
visible within the Siebel Employee Directory. The biography can help employees 
better understand the background of their co-workers.

■ Credentials. The Credentials view allows you to display and manage the 
credentials associated with an employee. The credentials data is structured and 
includes the following types of information about an employee:

■ Memberships

■ Honors and awards

■ Certifications

■ Resume. The Resume view allows you to view and manage the resume of each 
employee in an organization. Visibility to resumes can be limited by the 
administrator to select groups of employees. The resume data is structured and 
includes two elements:

■ Education

■ Past work experience

■ Profile. The Profile view allows you to view and manage an employee’s details, 
such as name, manager, and address.

■ Skills. The Skills view allows you to manage and view an employee’s skills. 
Managers can use this view to track skills gaps and build teams based on project 
skill needs.
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The Employee Directory includes several additional views, from which you can 
manage employee-related information. The following tabs appear in the Employee 
Directory:

■ Calendar

■ Objectives

■ Training

■ Service Request

■ Projects

■ Activities

■ Opportunities

■ Customers

■ Accounts

For more information about these view tabs, see Applications Administration Guide.

The information stored in the employee profile repository is used by other Siebel 
applications and modules. For example, the skills in an employee’s profile are used 
by Competency Management to calculate skills gaps, which helps to identify areas 
in which an employee needs to update his or her skills. The Employee Details are 
used by the Employee Locator when you search for an employee. 

You can restrict visibility of an employee profile view based on the responsibilities 
of the employee. For more information about visibility and responsibilities, see 
Security Guide for Siebel eBusiness Applications. 

Table 11 describes the views available in the Employee Directory screen.

Table 11. Employee Directory Views

View Comments

All Employees Lists employees within the selected organizations.

All Employees Across Organizations Lists the employees for all organizations.
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Employee Locator
Employee Locator can be used to find employees based on the employee’s profile 
data. You can base an employee search on the following types of employee profile 
information:

■ Employee details

■ Skills

■ Previous employment

For more information about using the search feature, see Fundamentals.

All Users Lists users and associated responsibilities.

My Profile Lists the personal profile view for an employee.

My Team Lists employees associated with a project.

Table 11. Employee Directory Views

View Comments
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Business Scenario for Employee Directory
This scenario provides an example of a process performed by a Siebel administrator, 
an HR employee administrator, and an employee. Your company may follow a 
different process according to its business requirements.

Administrator
An administrator at a software company needs to create a responsibility that allows 
a designated employee in the Human Resources department to manage employees. 

First, the administrator creates the new responsibility, titled Employee 
Administrator, which allows access to the Employee Administration Screen. Then, 
the administrator assigns the appropriate employee to the new responsibility.

Employee Administrator
The software company has hired a number of programmers. The HR employee 
administrator has been asked to set up the profiles for each employee and save their 
pictures with their profiles. The administrator already has a digital picture of each 
employee stored on the network for use as security badge photos. Using Siebel 
Employee Directory, the employee administrator creates a profile for each employee. 
She also adds the security badge picture to the profile and makes sure to make them 
visible so that other users can see the images in the Employee Locator.

Employee
As soon as the employee profiles are entered, the new employees begin updating 
their profile information as needed in the My Profile view.
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Example Process for Employee Directory
The following section describes the process administrators might follow to set up 
Employee Directory, and the process an end user might follow to use Employee 
Directory. Your company may follow a different process according to its business 
requirements.

Administrator Procedure
The Siebel administrator requires administrative responsibilities to:

■ Set up the Employee Administrator. The administrator creates the Employee 
Administrator responsibility, and then assigns the employee to the responsibility. 
For more information, see “Setting Up the Employee Administrator” on page 55 
and Security Guide for Siebel eBusiness Applications.

Employee Administrator Procedures
The employee administrator is assigned the responsibility that allows the employee 
administrator to:

1 Set up and modify employee profiles. For more information, see “Setting Up and 
Modifying an Employee Profile” on page 56.

2 Add an employee picture to each profile. The employee administrator adds the 
image files as a literature item, and then associates each employee image with 
an employee profile. For more information, see “Adding an Employee Picture to 
a Profile” on page 57.

End-User Procedures
The end user, an employee, uses Employee Directory to:

1 Update employee profile. The end user accesses the employee profile to add or 
update basic information. For more information, see “Updating a User Profile 
(End User)” on page 59.

2 Use employee locator. The end user uses the employee locator to review contact 
information about a co-worker on a project. For more information, see “Finding 
Employees Using Employee Locator (End User)” on page 60.
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Setting Up the Employee Administrator
Before an HR employee administrator can work with employee profiles in the Siebel 
ERM application, the employee must be associated with the appropriate 
responsibilities. You can assign employees additional responsibilities that allow 
them to administer employee profiles. 

To set up an employee administrator, first create a responsibility that provides 
access to the Employee Administration screen, and then associate the responsibility 
with the appropriate employee. For more information on creating employee 
responsibilities, see Security Guide for Siebel eBusiness Applications.
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Setting Up and Modifying an Employee Profile
As an administrator, you manage employee profiles by adding employees, and then 
associating positions, responsibilities, organizations, territories, skills, credentials, 
and a resume with each employee. You can also edit and omit information 
associated with an employee profile.

For more information on setting up an employee see Security Guide for Siebel 
eBusiness Applications and Applications Administration Guide.

To modify an employee profile

1 From the application-level menu, choose View > Site Map > Employee 
Administration > Employees.

2 In the Employees list, query to find the employee profile you want.

3 Select the employee profile, and then modify the profile.
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Adding an Employee Picture to a Profile
You can use the Employee Directory to store images of each employee. When an 
image is associated with an employee profile, other users see the image when they 
use the Employee Locator feature to find an employee. You can use the following 
image formats for an employee image: 

■ BMP

■ JPG

■ GIF

To add an employee picture as a literature file

1 From the application-level menu, choose View > Site Map > Portal 
Administration > Literature.

2 In the Literature list, add a new record, and then complete the name and 
description fields.

TIP: To help later identify the literature item as an employee picture, use a 
naming convention that makes use of an employee’s user ID or another 
employee detail.

3 In the new record, click the select button in the File Name field, and in Add 
Attachment dialog box, click the Browse button.

4 In the Choose file window, select the image, and then click Open.

5 In the Add Attachment dialog box, click Add.

The file name appears in the File Name field, and the associated fields are 
automatically populated. A copy of the image is added to the Siebel File System. 

6 In the More Info form, select the Internal check box.

To associate the image with an employee

1 From the application-level menu, choose View > Site Map > Employee 
Administration > Employees.
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2 In the Employees list, select the employee, and in the More Info form, click the 
select button in the Image File Name field.

3 In the Employee Image dialog box, query for the image you saved as a literature 
item, select the image, and then click OK.

4 In the More Info form, select the Include Image check box.

NOTE: In the My Profile view, employees can choose to exclude or include the 
picture in their profile.
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Updating a User Profile (End User)
Users can update their profiles from the Employee Directory screen. 

To update an employee profile

1 Navigate to the Employee Directory screen, and from the Show drop-down list, 
select My Profile.

2 In the Employee Profile form, click the show more button.

3 Update and add information to the fields as needed.

For more information about working with employee data, see Fundamentals.
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Finding Employees Using Employee Locator (End User)
The Employee Locator search feature can help users locate other employees based 
on the employee’s profile data. The user can base an employee search on the 
following types of employee profile information: 

■ Employee details

■ Skills

■ Previous employment

For more information about using the search feature, see Fundamentals.
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Using Siebel Objectives and Reviews, completion of performance reviews becomes 
a collaborative process between management and employees. The organization 
provides feedback on employees’ goals and objectives using periodic and annual 
reviews, 360-degree evaluations, and skills assessments.

Objectives and Reviews includes the following features:

■ Employee and corporate objectives management

■ Cascading objectives

■ Objectives templates

■ Periodic and annual performance reviews

■ 360-degree evaluations

■ Skills assessments and training plans
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Business Scenario for Objectives and Reviews
This scenario provides an example of a process performed by an administrator using 
Objectives and Reviews. Your company may follow a different process flow 
according to its business requirements.

Administrator
Before an employee or manager can use the Objectives and Reviews system, the 
administrator sets up the system accordingly to the organization's performance 
management policies and procedures. For example, an organization may choose 
different components to make up a review. The administrator defines those 
components to match the organization's performance management goals.

The administrator defines review periods, review components, organizational 
hierarchy and rating scales, and so on.
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Example Process for Objectives and Reviews
The following section describes the process an administrator might follow to set up 
objectives and reviews. Your company may follow a different process according to 
its business requirements.

Administrator Procedures
The Siebel administrator requires administrative responsibilities to perform the 
following Objectives and Reviews tasks:

1 Define rating scale. The administrator sets up a rating scale to help managers 
evaluate employee progress on objectives and skills. For more information, see 
“Defining a Rating Scale with Rating Values” on page 65.

2 Define review periods. The administrator defines review periods and rollups of 
periodic reviews. For more information, see “Defining Review Periods and 
Rollups” on page 67. 

3 Define review components. The administrator defines the components of the 
review, which may include employee objectives, and skills assessments. For 
more information, see “Defining Review Components” on page 69.

4 Create objectives templates. The administrator creates objectives templates, 
which allow organizations to distribute predefined objectives. For more 
information, see “Creating Objectives Templates” on page 72.

5 Define evaluation forms. The administrator defines 360-degree evaluation forms 
using Siebel SmartScript. For more information, see “Defining 360-Degree 
Evaluation Forms” on page 73.

6 Create review definitions. The administrator creates review definitions which 
include the review type, required approval levels, and review components. For 
more information, see “Creating Review Definitions” on page 75.

7 Manage objectives and reviews by organizations. The administrator sets up different 
objectives and review periods for each organization. For more information, see 
“Managing Objectives and Reviews by Organization” on page 78.

8 Publish corporate objectives. The administrator publishes the corporate objectives 
to the ERM Corporate Objectives view. For more information, see “Publishing 
Corporate Objectives” on page 80.
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9 Update objectives and reviews. The administrator periodically updates the status 
and details of an employee’s objectives and reviews. For more information, see 
“Updating Objectives and Reviews” on page 81.

10 Manage all-employees objectives hierarchy. The administrator structures and 
manages the objectives hierarchy, which shows the relationship between an 
employee's position and the parent position. The hierarchy controls the approval 
routing for objectives and reviews. For more information, see “Managing the All-
Employee Objective Hierarchy” on page 84.
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Defining a Rating Scale with Rating Values
When completing periodic and annual reviews, managers rate employees on 
individual objectives, shared objectives, and skills. To support this process, one or 
more rating scales are designed and administered within the application.

You can create multiple rating scales for use with different review definitions, and 
you can define different review components within a review definition. During a 
performance review, ratings for each objective are multiplied by the objectives' 
weightings, and then summed to give the overall calculated rating for the review.

For Siebel Competency Management, a rating scale can be defined for a different 
skill or shared across numerous skills. Ratings are used to define employee skill 
levels and to determine skill gaps.

To define a rating scale

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > Rating Scales.

2 In the Rating Scales list, add a new record, and then complete the fields.

The following table describes the fields in the rating scale record.

To create rating values for the rating scale

1 In the Rating Scales list, select the rating scale record.

Field Comments

Name Enter a name for the rating scale.

Description Enter descriptive text for the rating scale.

Type Select the type of rating scale. Options are Performance Management 
which is used for rating performance on objectives, and Competency 
Management, which is used for competencies and skills levels.

Active Automatically populated with a check mark that indicates the rating 
scale is active.
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2 In the Ratings List, add a new record, and then complete the fields.

TIP: Click Query to search for an existing rating record.

The following table describes the fields in the rating record.

Repeat this procedure to add ratings and values to the rating scale.

Field Comments

Name Enter a name for the rating scale.

Description Enter descriptive text for the rating scale.

Rating Enter a whole number value for the rating. For example, the rating 
Did Not Meet Objective (0%) might have a rating of 1, and the rating 
Substantially Exceeded Objective (110%+) might have a value of 5.
66 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up Objectives and Reviews

Defining Review Periods and Rollups
Defining Review Periods and Rollups
Siebel Objectives and Reviews allows organizations to conduct annual reviews that 
include components such as shared objectives (for example, the organization’s core 
values), skills assessments, 360-degree evaluations, and rollups of periodic reviews. 

Periodic reviews are used to evaluate the performance of each employee multiple 
times during the year. A typical periodic review cycle is assessment conducted on a 
quarterly basis. 

If a review period definition include a rollup of periodic reviews, the rollup period 
type for the review period record must be defined.

For example, if previous quarterly reviews are rolled up into an annual review, the 
Rollup Period Type for the Year period record is defined as Quarter. Then the annual 
review ratings for the defined period include a rollup (the average) of the overall 
ratings from any completed quarterly reviews falling within the annual period.

NOTE: Review Periods and period units are defined using the Applications 
Administration screen. For more information, see Applications Administration 
Guide.

To change the rollup period type of a review period

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > Review Periods.
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2 In the Review Periods list, select the record you want to edit, and then choose a 
value in the Rollup Period Type field.

The following table describes the fields in the review period record.

Field Comments

Name This read-only field provides the name of the review period.

Description This read-only field provides a description of the review period, for 
example, October through December of 2002.

Period Type This read-only field specifies the type of review period. The options are 
Day, Week, Bi-weekly, Month, Quarter, Half-Year, and Year.

Rollup 
Period Type

This field is optional. Leave this field empty unless you intend to use 
the review period to roll up other reviews.

If you want to roll up reviews, specify the type of period to roll up for 
this period type.

A Period Type and Rollup Period Type combination of Year and Quarter 
specifies that the annual review overall rating can include a rollup 
(average) of the overall ratings from quarterly reviews completed 
during the year.

Start Date This read-only field provides the start date for the period.

End Date This read-only field provides the end date for the period.
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Periodic and annual reviews include one or more review components. Examples of 
review components include employee objectives, shared objectives such as 
company-wide core values, and skills assessments.

You can define review components using the Review Components view. After 
review components are defined, the components are associated with review 
definitions and are accessible to users during the objectives and review processes. 
For more information, see “Creating Review Definitions” on page 75.

You can also translate review component display names, such as tabs, into other 
languages. For more information, see “Translating Review Component Display 
Names” on page 71.

To create a review component

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > Review Components.
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2 In the Review Components list, add a new record, and then complete the fields.

The following table describes the fields in the review component record.

Field Comments

Type Specify the type of review component, choosing from the 
following options.

■ Individual Objective 1-5. Objectives that are defined by 
individual employees. These objectives should only be used 
within a periodic review definition.

■ Shared Objective 1-5. Objectives that are predefined by the 
organization. These objectives not editable by the employee. 
The review component can be used within a periodic or 
annual review definition.

■ Rollup. Includes the average of previous periodic review 
ratings in the overall review rating.

■ Skills. Assessment of employee skills that automatically 
updates the employee competencies within Competency 
Management when the review is approved. Skills assessment 
can be used within a periodic or annual review definition.

■ Training Plan. Displays training course enrollments from the 
eTraining module. This review component can be used 
within a periodic or annual review definition.

■ 360 Degree Evaluation. 360 degree evaluations can be used 
within a periodic or annual review definition.

Name Enter a descriptive name.

Default Display Specify the display name of the component tab as it appears to 
the user.

Effective Date Specify the start date for the review component. This is the date 
on which the review component becomes active.

Active A check mark indicates the review component is active.
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Translating Review Component Display Names
You can use the Display Translation view to translate review component display 
names, such as tabs, into other languages. This feature is useful when Siebel 
Objectives and Reviews is deployed within a multilingual environment. If the 
display translation is defined, end users who access the application with a foreign 
language pack see a translated display name for the tab. If the display translation is 
not defined for a user's language pack, the Default Display from the review 
component definition appears.

To define display translations

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > Review Components.

2 In the Review Components list select the review component, and then click the 
Display Translation view tab.

3 In the Display Translation list, add a new record, and then click the select button 
in the Language field.

4 In the Pick Language Name dialog box select the desired language, and then 
click OK.

5 In the Display field, enter the translated text for the review component display 
name, and then click Save.
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Objectives Templates allow organizations to create and distribute predefined 
objectives. Employees whose review definitions include a review component with 
an objectives template automatically inherit the predefined objectives. 

Objectives templates should only be used for Individual Objectives and Shared 
Objectives review component types.

To create an objectives template

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > Review Components.

2 In the Review Components list select the review component, and then click the 
Objectives Template view tab.

NOTE: Objectives templates should only be created for Individual Objectives 1-5 
or Shared Objectives 1-5 type review components. Individual Objectives can be 
edited by the employee. Shared Objectives are not editable by the employee.

3 In the Objectives Templates list, add a new record, and then complete the fields.

The following table describes the fields in the objectives template record.

4 When you have finished defining the objectives template, click Save.

Field Comments

Name Enter a name for the objective template.

Description Enter a description.

Sequence Enter the sequence of the objective.

Weight Enter the weight of the objective.

Weights for an objective template with a review component type 
Shared Objective should always add up to 100.
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Defining 360-Degree Evaluation Forms
You use the Evaluation Forms view to associate 360-degree evaluation-type review 
components with specific evaluation forms. You can define a different 360-degree 
evaluation form for each type of work relationship that exists between evaluators 
and individuals who are evaluated.

For example, the form used for a peer evaluation can differ significantly from the 
form used for an upward evaluation. The definition of the 360-degree evaluation 
forms is administered using Siebel SmartScript. For more information, see Siebel 
SmartScript Administration Guide.

To define evaluation forms

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > Review Components.

2 In the Review Components list, select the review component, and then click the 
Evaluation Forms view tab.

3 In the Evaluation Forms list, add a new record, complete the fields, and then 
click Save.

The following table describes the fields in the evaluation form record.

Field Comments

Name Enter the name of the 360-degree evaluation type.

Sequence Enter the sequence number of the evaluation type.
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Repeat this procedure to create as many evaluation forms as necessary.

Figure 11 shows the Evaluation Forms list including peer, colleague, subordinate, 
and manager evaluation types.

Type Select one of the following as the type of 360-degree evaluation.

Manager. The evaluator is the superior to the employee that is being 
evaluated (downward evaluation).

Subordinate. The evaluator is the subordinate of the employee that is 
being evaluated (upward evaluation).

Peer. The evaluator is a peer of the employee that is being evaluated 
(peer evaluations).

Colleague. The employee that is being evaluated is a colleague of the 
evaluator.

Form Click the select button to choose the SmartScript that is used as the 360-
degree evaluation form for the 360 degree evaluation type. The Pick 
SmartScript dialog box only lists SmartScripts with a 360 Evaluation 
type of SmartScripts.

Figure 11. Evaluation Forms List 

Field Comments
74 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up Objectives and Reviews

Creating Review Definitions
Creating Review Definitions
Review Definitions control the format and underlying processes used within 
objectives and reviews. These processes include the review type, required approval 
levels, and review components. Review definitions can also be created for specific 
organizations, divisions, and job families.

CAUTION: Do not modify or delete a review definition that has been used previously 
during an objectives and review cycle. Instead, create a new review definition with 
the desired effective date and inactivate the previous review definition. A review 
definition should not have more than one component of the same Objective Type.

The selection of review components within a review definition determines the 
format of the objectives and reviews process. For example, if Individual Objectives, 
Shared Objectives, and the Training Plan review components are added to a review 
definition, these components are accessible to employees during the objectives and 
review process.

The rating scale assigned to an Individual Objectives or Shared Objectives review 
component determines which rating scale the manager uses when rating the 
employee's performance in meeting those objectives. By defining the weights of the 
Individual Objectives and Shared Objectives review components as 75 percent and 
25 percent, respectively, the resulting aggregate scores of each component are 
weighted accordingly when determining the calculated overall rating.

To create a review definition

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > Review Definitions.
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2 In the Review Definitions list, add a new record, and then complete the fields.

 The following table describes the fields in the review definition record.

Field Comments

Review Type Specify the type of review. For a periodic review, the type 
must be Periodic Review. For an annual review, the 
review type must be annual review.

Name Enter a name for the review definition.

Description Enter a description of the review definition.

Organization Click the select button and choose the organization for 
which the review definition is defined.

Period Type Choose the period type for the review. For example, to 
create an annual review, set the period type to Year. To 
create a quarterly review, set the period type to Quarter.

Sequence Enter the sequence of the review definition. If more than 
one review definition with the same Period Type exists 
for an organization, the review definition with the 
highest sequence number applies.

Objectives Approval Levels Specify the level of management approval required for 
periodic reviews. Options are 0, 1, or 2. These values 
correspond to the number of managers who must review 
and approve an employee's periodic review.

Review Approval Levels Specify the level of management approval required for 
annual reviews. Options are 0, 1, or 2. These values 
correspond to the number of managers who must review 
and approve an employee's annual review.

Minimum 360 Evaluators Minimum number of 360-degree evaluators that can be 
selected by an employee. If an employee submits a list of 
360- degree evaluators with fewer than the minimum 
number, an error message appears.

Maximum 360 Evaluators Maximum number of 360-degree evaluators that can be 
selected by an employee. If an employee submits a list of 
360- degree evaluators exceeding the maximum number, 
an error message appears.
76 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up Objectives and Reviews

Creating Review Definitions
NOTE: Only the objectives from the review component type Individual Objectives 1 
appears within the All Employee Objectives and My Team's Objectives tree views. 
For employee objectives to appear in these views, you must create a Individual 
Objectives 1 review component and associate it with the desired review definition.

Organizations can control which review definitions are used by different employee 
subgroups by associating Divisions and Job Families with a review definition. The 
employee attributes are matched with review definition attributes, as indicated in 
the following list, to make sure the appropriate review definition is selected for each 
employee.

■ The review definition is matched with the Organization, Division and Job 
Family.

■ The review definition is matched with the Organization and Division.

■ The review definition is matched with the Organization Job Family.

■ The review definition is matched with the Organization.

Effective Date Specify the start date for the review definition. This is the 
date on which the review definition becomes active.

Active A check mark indicates the review definition is active.

Effective Date Effective date of the review definition.

Name Name of the review component.

Component Type Type of review component.

Rating Scale Select the rating scale to be used when a manager 
assesses an employee's performance. Rating scales 
should only be defined for Individual Objectives and 
Shared Objectives component types.

Weight Assign a weight for the review component. The weight 
determines how much the component contributes to the 
overall review score. Weights should only be defined for 
Individual Objectives, Shared Objectives, and Rollup 
component types.

Field Comments
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Managing Objectives and Reviews by Organization
Siebel Objectives and Reviews allows the objectives and review periods to differ by 
organization. For example, Organization A might have semiannual objectives and 
reviews and Organization B might have quarterly objectives and reviews.

By managing attributes at the organization level, you can control which objectives 
and reviews appear on the Performance Management Dashboard, All Employee 
Objectives, and My Team's Objectives views. In addition, you can also control the 
availability of the annual review by organization from the Performance 
Management Dashboard.

To manage organizations for Objectives and Reviews

1 From the application-level menu, choose View > Site Map > Group 
Administration > Organizations.

2 In the Organizations list, select the organization to modify.

3 In the More Info form, click the show more button to expose additional fields.

4 Complete the fields to configure the organization setting.

The following table describes the fields in the organization record.

Field Comments

Current Objectives Period Specify the name of the current objectives period. This 
name identifies which objectives period appears in the 
Performance Management Dashboard, All Employees 
Objectives and My Team’s Objectives views. This value 
should match a value in the Name field in the Review 
Period Administration view.

Current Review Period Specify the name of the review period. This name 
identifies which review period appears in the 
Performance Management Dashboard. This value should 
match the Name field value in the Review Period 
Administration view.
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Annual Review Start Offset Specify the number of days before an employee’s Next 
Annual Review that the annual review link is active in the 
Performance Management Dashboard. A value of -N 
specifies that the annual review link is active N days 
before the employee's next annual review date.

Annual Review End Offset Specify the number of days before an employee’s Next 
Annual Review that the annual review link on the 
Performance Management Dashboard remains active. A 
value of +N specifies that the annual review link 
remains active N days after the employee's next annual 
review date.

Field Comments
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Publishing Corporate Objectives
Publishing corporate objectives to the ERM Corporate Objectives view is 
administered using Siebel Microsite pages. For more information, see “ERM 
Microsite Pages” on page 38 and the Applications Administration Guide.
80 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up Objectives and Reviews

Updating Objectives and Reviews
Updating Objectives and Reviews
When necessary, you can update the status and details (including ratings and 
comments) for any employee's objectives and reviews. For example, you can 
override the status of an employee's review if it was mistakenly submitted. Because 
of the sensitivity of employee review data, it is recommended that access to the All 
Employees Performance view is only granted to authorized personnel.

To override review status

1 From the application-level menu, choose View > Site Map > Performance 
Management Administration > All Employees Performance.

2 In the All Employees Performance list, locate the employee whose objective or 
review status you plan to update, and then drill down on the Last Name 
hyperlink in the record.

3 In the Employee list of records, select the review record to be updated.
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4 In the review record change the Objective Status or Review Status as desired, 
and then click Save.

The following table provides status information associated with objectives.

The following table provides status information associated with reviews.

Objectives Status Comments

Not Started Objectives have not been started by the employee.

Employee in Progress Objectives are being defined by the employee.

Employee Submitted Objectives have been submitted by the employee, and are 
waiting for approval.

Manager Declined Objectives have been declined by the manager, and are 
accessible to the employee.

Manager Approved Objectives have been approved by the manager, and are 
awaiting approval by the next level manager. This status is 
only valid when the objectives require two levels of manager 
approval.

2nd Manager Declined Objectives have been declined by the next level manager, and 
are accessible by the manager.

Completed Objectives have received the required approvals and are 
posted to the All Employees Objectives and My Team’s 
Objectives views.

Not Required Objectives are not required. Objectives that are not required 
are counted in the Department Status Report.

Review Status Comments

Not Started The employee has not started the self-review.

Employee in Progress The employee has begun the self-review.

Employee Submitted The employee has submitted the self-review to the 
manager. The manager is responsible for completing the 
review.

Manager in Progress The manager is in the process of completing the review.
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Manager Declined The manager has declined the employee’s self-review. The 
self-review is accessible to the employee.

Manager Approved The review has been approved the manager and is 
awaiting approval by the next-level manager. This status is 
only valid when reviews require two levels of manager 
approval.

2nd Manager in Progress The next-level manager is in the process of completing the 
review.

2nd Manager Declined The next-level manager has declined the review. The 
review is accessible by the manager.

2nd Manager Approved The next level manager has approved the review. The 
review is ready for release to the employee by the 
manager.

Completed The review has received all necessary approvals and is 
released to the employee for acknowledgement.

Acknowledged The completed review has been acknowledged by the 
employee.

Not Required The review is not required. Reviews that are not required 
are counted in the Department Status Report.

Evaluator List in Progress The employee is in the process of completing the list of 
360-degree evaluators.

Evaluator List Submitted The list of 360-degree evaluators has been submitted for 
approval by the employee.

Evaluator List Approved The list of 360 degree evaluators has been approved by the 
manager. Links to the 360-degree evaluation appear on the 
evaluator’s Performance Management Dashboard, and the 
employee can begin the self-review.

Evaluator List Declined The list of 360-degree evaluators has been declined by the 
manager and is accessible to the employee.

Review Status Comments
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 83



Setting Up Objectives and Reviews

Managing the All-Employee Objective Hierarchy
Managing the All-Employee Objective Hierarchy
The employee hierarchy is defined using Siebel Position Administration. The 
relationship between an employee’s position and the corresponding parent position 
controls the approval routing for objectives and reviews, as well as the hierarchy 
within the All Employees Objectives and My Team’s Objectives views. Employees 
whose positions do not have parent positions appear at the top level of the All 
Employees Objectives view and automatically bypass the manager approval process 
for both objectives and reviews.

To use Siebel Performance Management, users must have an active employee record 
and an active position. When an employee holds multiple positions, only the 
employee’s primary position is used in the All Employees Objectives and My Team’s 
Objectives views and when routing approvals.

NOTE: Each employee must have a different primary position. In other words, no 
other employee can have the same primary position. When more than one 
employee occupies the same position, the employee whose name comes first 
alphabetically appears in the All Employee Objectives and My Team’s Objectives 
views. For more information on position administration, see Applications 
Administration Guide.
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Siebel Competency Management is a Siebel module that is used by managers to 
associate specific skills with job profiles, by training administrators to associate 
specific skills with training objectives, and by employees to associate specific skills 
with their employee profile. This chapter describes setting up and managing 
competencies.
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Using Competencies to Measure Skills and Achievements
Your Siebel application saves employee information within groups of records. 
Combined, these records make up an employee profile. An employee profile 
includes information that identifies an employee, such as name, address, manager, 
and phone number. Also included in an employee profile are sets of skills and 
abilities that are associated with an employee. These sets of abilities, called 
competencies, are determined by tests or ratings and the stored in your Siebel 
application. The following competencies are used within CMS to help measure the 
abilities and achievements of employees:

■ Skills. Skills are attributes that are measurable using proficiency levels. Skills 
may include language proficiency, a business proficiency such as project 
management, and technical proficiency such as programming knowledge.

■ Credentials. Credentials can include qualifications, honors, rewards, and past 
education.

■ Experience. Experience can include past work, industry and project experience.

■ Other relevant competencies. Other competencies can include personal traits such 
as leadership, business acumen, decision-making experience, personal traits, 
communication skills, and so on.
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These competencies are used across various modules within a Siebel application:

■ Training and Development. Skills and competencies are associated with courses 
and classes offered through your Siebel eTraining application. When employees 
successfully complete a course, their profiles are automatically updated with the 
skills associated with the course. 

■ Career Management. The Career Management feature allows employees to view 
their job profiles, browse potential career paths and define their next career step. 
The skills associated with an employee’s profile are compared to the skills 
associated with jobs in the employee’s career path. The Competency 
Management feature calculates the skills gaps that exist between an employee 
and other job profiles. The skill gap analysis indicates skill deficiencies and 
provides employees with indications of which skills they need to acquire.

■ Team Competency Planning. The Siebel Competency Management feature 
provides managers with the ability to manage competencies and skills within 
their groups. Managers can analyze their team’s current skill-set, the required 
skill-set based on the employee’s job profile, and can view individual 
competency profiles of team members. The skill gap analysis of a team’s current 
strengths and weaknesses allows managers to provide training suggestions or 
define future hiring requirements. Managers can set competency objectives and 
monitor employee progression towards these goals.

■ Organizational Planning / Strategic Headcount Management. Managers can review 
the level of competency in their organization and identify strengths and areas of 
vulnerability using the skills gap analysis provided by the Competency 
Management feature. 

■ Performance Management. Competencies can be included in the formal 
performance management process. Employees can include specific 
competencies in their performance setting process and managers can review and 
access these ratings as part of the overall assessment process.

■ Compensation and Rewards. Competencies can be associated with employee 
performance. Managers can review and evaluate employee performance 
periodically and annually. Based on the evaluation, an employee can be 
recommended for specific compensation and rewards.
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You can use the Competency Management feature to set up and manage 
competencies, and to build multilevel hierarchies of categories and skills relevant 
to your organization’s industry. You build a hierarchy by associating skills with 
categories through parent-child relationships. Defining skills involves setting up the 
necessary categories. 

As illustrated in Figure 12, the Competency Administration screen provides a Skills 
Hierarchy on the left, which is represented by a folder. Expanded below the folder 
are several skills categories, which are represented by file icons. The skills 
categories include other categories and skills. The right section of the screen 
includes the Category/Skill list, which shows records based on the selection in the 
Skills Hierarchy. Below the Category/Skill list is the Child Items list, which includes 
the records associated with the child records.

Figure 12. Competency Management Hierarchy
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Using the Competency Administration screen, you can perform the following 
procedures:

■ Review existing skills and categories

■ Create and edit skills categories

■ Create, edit, and copy unique skills

■ Assign skills to categories

■ Assign rating types to skills

■ Deactivate and activate skills

■ Provide a default skills set library
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Business Scenario for Competency Management
This scenario provides an example of a process performed by an administrator. Your 
company may follow a different process according to its business requirements.

Administrator
An administrator at a software company is in charge of setting up and maintaining 
the organization’s competency management system. The administrator’s 
organization is developing a new product line with three new management 
positions to manage the new product. The executive team outlines the skills and 
requirements for each position and delivers the requirements to the administrator.

The administrator reviews the preconfigured set of more than 1,000 skills in the 
Skills Library, and then creates some additional skills and categories required by the 
organization. Following guidelines developed by the organization, the administrator 
defines a hierarchy of skills, providing a top-down approach from very generic skills 
to very specific and detailed skills.

The administrator then creates job profiles, which characterize all available job 
positions within the software organization. The manager links the job profiles 
together, and associates competencies to the job profiles to establish a career 
development plan that can be used by the organization to structure the personal 
career development of each employee.
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Example Process for Competency Management
The following section describes a process an administrator might follow to set up 
competency management. Your company may follow a different process according 
to its business requirements.

Administrator Procedures
The Siebel administrator requires administrative responsibilities to perform the 
following competency management procedures:

1 Review the skills library. The administrator searches the skills library for 
applicable skills and categories that can be used as-is, or modified. For more 
information, see “Reviewing Skills and Categories” on page 92.

2 Create skills. The administrator creates new skills and edits existing skills to meet 
requirements. For more information, see “Creating and Modifying a Skill” on 
page 93.

3 Create categories for grouped skills. The administrator sets up categories to 
logically group related skills. For more information, see “Creating Categories for 
Grouped Skills” on page 95.

4 Create job profiles. The administrator creates job profiles that define the purpose, 
responsibilities, and requirements of a specific job. For more information, see 
“Creating Job Profiles” on page 97.

5 Associate job profiles with skills. The administrator associates job profiles with 
specific skills, which creates competencies. For more information, see 
“Associating a Job Profiles with Competencies” on page 99.

6 Set up career path options. The administrator links job profiles to create career 
paths. For more information, see “Creating Career Path Options” on page 100.
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Reviewing Skills and Categories
Your Siebel application is preconfigured to include the skills and categories that are 
typically used by human resource administrators. Before adding a new skill or 
category you should query the skills library to determine whether the skill or 
category you need already exists. 

To access the skills library

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Competency Administration.

2 In the Skill Hierarchy explorer, select a parent category.

3 In the Category/Skill list, query to find the skill or category you want.

If the skill or category you need does not exist, you can create it. For more 
information about creating a skill, see “Creating and Modifying a Skill” on 
page 93.

You can associate an existing skill or category with more than one category at a 
time. For example, you can have multiple categories that include the same skill. The 
presentation skill can be included in the Training category and it can also be 
included in the Sales category. 
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Creating and Modifying a Skill
A skill is a specific asset that an employee possesses or desires. For example, Oracle 
DBA, Presentation Skills, Leadership Ability, and Siebel ERM Administration are 
valid skills that an employee can possess. Some skills are subjective and are based 
more on the judgment or discretion of a manager. Other skills are objective and are 
based on an employee’s successful completion of specific goals. Administrators can 
create the skills that are used for competency management.

NOTE: You cannot create a skill using the name of an existing skill. Skill names must 
be unique within your Siebel application. You can, however, associate the same skill 
with multiple categories. 

To create a skill

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Competency Administration.

2 In the Skill Hierarchy explorer, select a parent category.

3 In the Child Items list, add a new record, and then complete the fields.

4 In the Type field, select Skill.

After the appropriate categories and skills have been created, you can assign 
specific skills to employees. You can also associate specific skills with training.

Editing a Skill
When you edit a skill, the changes you make affect each category that includes the 
modified skill. For example, Presentation Skill can exist within the Training 
Category and the Power Point Category. If you make changes to the Presentation 
Skill within the Training Category, the same changes appear in the Presentation Skill 
within the Power Point Category.

To edit a skill or category

1 From the application-level menu choose View > Site Map > Competency 
Administration > Competency Administration.
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2 In the Skill Hierarchy explorer, navigate to a category or skill to edit, and then 
edit the fields as needed.

The changes you make to a skill or category affect each occurrence of the 
selected item within Competency Management.

Deactivating a Skill
You can deactivate a category or skill to make it unavailable to employees.

To deactivate a category or skill

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Competency Administration.

2 In the Skill Hierarchy explorer, select a category or skill to deactivate.

3 In the Category/Skill list, select the Inactive check box for the record.
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Creating Categories for Grouped Skills
After you have identified the additional skills and categories that are required for 
your competency management system, you can add them from the Competency 
Administration screen.

NOTE: If the rating scale you want to use does not already exist, you can create it. 
For more information on creating a rating scale, see Chapter 4, “Setting Up 
Objectives and Reviews.”

The Competency Administration Category list is used to classify skills. Related skills 
are grouped logically, using categories and subcategories. Categories define the 
structure through which skills are ordered.

To create a new category

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Competency Administration.

2 In the Skill Hierarchy explorer, select a parent category.

3 In the Category/Skill list, add a new record, and then complete the fields.

The following table describes the fields in the category/skill record.

Field Comments

Description Enter a brief description about this category or skill.

Inactive A check mark indicates that a category or skill is inactive. Inactivating 
or activating a root category does affect the subcategories and skills 
within the category.

Name The name of the category or skill.

Rating Type Select the appropriate rating type.

Type Select Category or Skill to indicate the type of record you are creating.
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To create a child category

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Competency Administration.

2 In the Skill Hierarchy explorer, select a parent category.

3 In the Child Items list add a new record, and then complete the fields.
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Creating Job Profiles
A job profile is a collection of job-related information, or properties, that define the 
purpose, responsibilities, and requirements of a specific job role. In the process of 
defining a job profile, you create required competencies by associating existing 
skills with a job profile. These required competencies allow managers to determine 
whether employees meet the required skill levels for specific jobs. 

Siebel ERM compares an employee’s skill levels with the skill levels associated with 
a specific job profile. The skills associated with a job profile can also be used during 
performance management to help determine whether an employee meets the job 
requirements. The Human Resources department can use the required 
competencies to determine whether job applicants meet the minimum requirements 
for an open position. It is important to associate the appropriate skills and minimum 
skill levels with job profiles so that employees, managers, and administrators can 
integrate skills analysis and management across the entire work force.

Job profiles can be imported to Siebel ERM using eAI. For more information about 
importing job profile information using eAI, see Overview: Siebel eBusiness 
Application Integration Volume I. Job profiles can also be created in Siebel ERM 
using the Administration screens. 

To create a job profile, the relevant job code, job family, salary grade, EEO Category, 
and FLSA must already exist. For more information on creating job codes, job 
families, and salary grades, see Chapter 6, “Setting Up Compensation Planning.”

To create a job profile

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Job Profile Administration.

NOTE: Before you create a new job profile, make sure the job profile you want to 
create does not already exist. Query the Job Profile list using the name of the job 
profile you want to create. If no records are returned, you can create the new job 
profile.
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 97



Setting Up Competency Management

Creating Job Profiles
2 In the Job Profile list, add a new record, and then complete the fields.

The following table describes the fields in the job profile record.

Field Comments

Essential Functions A brief description of job duties and functions.

Job Code The job code associated with the job profile. The Job Code Name 
and the Job Family fields are automatically populated based on 
the job code.

Job Profile Name The name of the job profile.

Main Purpose Description of the job’s main purpose.

Total Number of 
Reports

Specify the total number of reports.

Travel Indicate the percentage of time spent away from the home office.
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Associating a Job Profiles with Competencies
After the appropriate job profiles and competencies are created, you can associate 
these two types of records with one another. A job profile can be associated with 
multiple competencies. A competency can also be associated with multiple job 
profiles.

To associate a job profile with a competency

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Job Profile Administration.

2 Click the Required Competencies view tab, and in the Required Competencies 
list, add a new record.

3 In the new record, click the select button in the Name field.

4 In the Skills list, query for the skill you want to associate with the job profile, 
and then click OK.

5 From the Required Level drop-down list, select a competency level of the skill 
required for the job profile. 

For example, if you are associating a product knowledge competency with a 
Receptionist job profile, you can require a lower level than you would if you were 
setting up the Customer Support Specialist job profile.

6 From the Criticality drop-down list, select a rating that indicates the importance 
of the selected skill for the job profile.
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Creating Career Path Options
After the appropriate job profiles are created, you can associate them with other job 
profiles to create career paths. A career path is the hierarchical representation of job 
profiles. Each job profile can be associated with other job profiles. These 
associations represent valid career options for employees in the current job. After 
several job profiles are associated with one another, employees and managers can 
use the Career Planning feature to navigate through the hierarchy and determine a 
career path.

To create a career path option

1 From the application-level menu, choose View > Site Map > Competency 
Administration > Job Profile Administration.

2 Click the Career Path Options view tab.

3 In the Career Path Options list, add a new record. 

4 In the new record, click the select button in the Name field.

5 In the Job Profiles list, query to find the job profile you want to designate as a 
valid career option, and then click OK.

NOTE: The primary flag indicates the default career option for currently selected 
job profile.
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Siebel Compensation Planning allows organizations to plan merit-based and 
promotion-based salary increases, cash bonuses, and stock grants. Organizations 
can define compensation budgets, guidelines, and eligibility rules. Managers can 
develop compensation plans for their direct and indirect reports, and then submit 
the plans for multiple levels of approval. The following sections explain the 
procedures for setting up and administering Siebel Compensation Planning.

Siebel Compensation Planning provides the following features:

■ Planning for merits, promotions, bonuses, and stock

■ Budget management

■ Compensation guidelines

■ Eligibility rules

■ Automatic and manual rollups

■ Support for multiple currencies

■ Charts
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Business Scenario for Compensation Planning
This scenario provides an example of a process performed by a compensation plan 
administrator. Your company may follow a different process flow according to its 
business requirements.

Administrator
A compensation administrator uses the guidelines provided by his organization to 
structure the company’s employee and financial information as part of the 
compensation planning process.

The administrator establishes salary grades and salary plans, defines individual job 
codes and job family categories, verifies that employee information is up-to-date, 
and creates compensation guidelines and eligibility rules. The administrator defines 
the planning cycles with associated components, and then creates budgets for each 
type of compensation that will be included in the compensation plan.

After the definition process is completed, the administrator generates compensation 
plans for use by each manager participating in the planning process. The 
administrator reviews the compensation plans as well as the compensation history 
for each employee in the organization.
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Example Process for Compensation Planning
The following section describe the process an administrator might follow to set up 
compensation planning. Your company may follow a different process according to 
its business requirements. 

Administrator Procedures
The Siebel administrator requires administrative responsibilities to:

1 Create salary grades and associated salary plans. The administrator creates salary 
grades as the first step in establishing salary ranges within the organization, and 
then the administrator creates salary plans to define the salary range for each 
salary grade. For more information, see “Creating a Salary Grade” on page 105, 
and “Creating a Salary Plan” on page 106.

2 Create job families and job codes. The administrator defines families to group job 
codes that have a common function but may differ in complexity, scope, or level, 
and then creates job codes to identify job types and titles. For more information 
see “Creating a Job Family” on page 108 and “Creating a Job Code” on page 109.

3 Verify and update employee information. The administrator verifies and maintains 
employee job information for accurate compensation results. For more 
information, see “Updating Employee Job Information” on page 110.

4 Define compensation guidelines. The administrator creates guidelines for merit, 
variable pay and stock compensation. For more information, see “Establishing 
Compensation Guidelines” on page 112.

5 Define compensation eligibility rules. The administrator establishes eligibility rules 
to determine which employees are eligible for specific types of compensation. 
For more information, see “Defining Compensation Eligibility Rules” on 
page 115.

6 Define the compensation plan rollout participants. The administrator selects the 
management levels within the organization that will participate in the 
compensation planning process. For more information, see “Defining the 
Compensation Plan Rollout” on page 116.
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7 Define the compensation budgets and associated employees. The administrator 
creates compensation type budgets with expressions that are used when 
calculating the budget, and then adds employees to the compensation budget. 
For more information, see “Managing Compensation Budgets” on page 118.

8 Create the planning cycle and add compensation type components. The 
administrator defines the period, budget guidelines, eligibility rules and so on 
that are incorporated into the planning cycle for the compensation plan. For 
more information, see “Defining Planning Cycles” on page 123.

9 Generate the compensation plans. The administrator creates the compensation 
plans for use by managers participating in the Rollout. For more information, see 
“Generating Compensation Plans” on page 126.
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Creating a Salary Grade
You can create salary grades to establish salary ranges within your organization.

To create a salary grade

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Salary Grades.

2 In the Salary Grades list, add a new record, and then complete the name and 
description fields.

3 Select the check box in the Active field to activate the salary grade.
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Creating a Salary Plan
Salary plans define the salary range associated with each salary grade. To create the 
association between an employee and a salary range, each employee must have a 
salary plan and salary grade specified within Employee Administration.

To create a salary plan

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Salary Plans.

2 In the Salary Plans list, add a new record, and then complete the name and 
description fields.

3 In the Salary Plan record, select the check box in the Active field to activate the 
salary plan.

To add a salary grade to the salary plan

1 In the Salary Plans list, select the salary plan.

2 In the Salary Grades list, add a new record, and then click the select button in 
the Salary Grade field.

3 In the Pick Salary Grade dialog box, query to locate a salary grade to include 
with the salary plan, and then click OK.

4 Complete the remaining fields for the salary grade.

The following table describes the fields in the salary grade record.

Fields Comments

Active Select the check box to activate the salary.

Currency Select the appropriate currency code for the salary plan.

Effective Date Enter the date on which the salary grade is active. The Active 
check box must be selected for the salary grade to be activated 
on the specified date.

Max Salary Range Enter the maximum salary for the salary grade.

Min Salary Range Enter the minimum salary for the salary grades.
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Repeat this procedure for each salary grade you want to add to the salary plan.

NOTE: To modify an existing salary range within a salary plan, create a new effective 
dated row within the Salary Plan’s Salary Grade list.

Salary Range 25th 
Percentile

Enter the 25th percentile salary for the salary grade.

Salary Range 75th 
Percentile

Enter the 75th percentile salary for the salary grade.

Salary Range 
Midpoint

Enter the midpoint salary for the salary grade. This value is 
used to calculate a compa ratio for the employee.

Fields Comments
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 107



Setting Up Compensation Planning

Creating a Job Family
Creating a Job Family
Job families can be created to categorize job codes and group employees when 
defining eligibility rules for compensation.

To create a job family

1 From the application-level menu, choose View > Site Map > Application 
Administration > Job Families.

2 In the Job Families list, add a new record, and then complete the fields.

The following table describes the fields in the job family record.

Field Comments

Active A check mark indicates that the job family is active.

Description Enter a description for the job family.

Effective date The date on which the selected job family becomes available.

Job Family Enter a name for the job family.
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Creating a Job Code
You can create job codes to link employees with specific job attributes defined by 
your organization. Job code attributes can include a salary grade, job family, Fair 
Labor Standards Act (FLSA) status, and Equal Employment Opportunity (EEO) 
category. Job codes are a common attribute in most HRMS applications.

To create a job code

1 From the application-level menu, choose View > Site Map > Application 
Administration > Job Codes.

2 In the Job Codes list, add a new record, and then complete the fields.

The following tables describes the fields in the job code record.

Fields Comments

Active Select the check box to activate the salary.

Currency Select the appropriate currency code for the salary plan.

Effective Date Enter the date on which the salary grade is active. The Active 
check box must be selected for the salary grade to be activated 
on the specified date.

Max Salary Range Enter the maximum salary for the salary grade.

Min Salary Range Enter the minimum salary for the salary grades.

Salary Range 25th 
Percentile

Enter the 25th percentile salary for the salary grade.

Salary Range 75th 
Percentile

Enter the 75th percentile salary for the salary grade.

Salary Range 
Midpoint

Enter the midpoint salary for the salary grade. This value is 
used to calculate a compa ratio for the employee.
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Updating Employee Job Information
As part of the administrative process, employee job information should be 
maintained within the Siebel application. Employee job information such as 
Employment Status, Employee Type, Job Code, Salary, and so on, must be kept 
current to produce accurate results for the compensation planning process.

To update an employee’s job information

1 From the application-level menu, choose View > Site Map > Employee 
Administration > Employees.

2 Click the Job Information view tab.

3 In the Employees list, query to find the employee whose job information you 
want to update.
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4 Complete the applicable fields for the employee records.

The following table describes the fields in the employee record.

NOTE: Make updates to employee job information before creating the plan in the 
Planning Cycles view. Subsequent changes to an employee’s job information are 
not reflected in existing compensation plans.

Field Comments

Bonus Target % Percentage of the employee’s salary that is the targeted bonus 
amount.

Compensation 
Final Approver

Indicates that the employee has final approver authority. When 
users with final approver authority approve a compensation 
plan, the plan receives a Final Approval status and does not 
require any further approvals.

Currency Currency code associated with the salary

Employee Type Employee type of the employee. Only those with Employee Type 
of Employee are included during compensation plan creation.

Employment Status Employment status of the employee. Terminated employees are 
not included during compensation plan creation.

Job Code Employee’s job code.

Salary Employee’s salary.

Salary Plan Employee’s salary plan.
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Establishing Compensation Guidelines
Siebel Compensation Planning allows organizations to establish compensation 
guidelines for merit, variable pay, and stock. These compensation guidelines are 
specific to a salary plan and salary grade combination, and can be based on factors 
such as annual review ratings, company ratio, and salary quartiles. Managers can 
use these guidelines during the planning process when deciding merit increases, 
bonus amounts, and stock grants for each employee.

This section includes procedures for the following topics:

■ Creating a Compensation Guideline

■ Defining Compensation Guideline Ranges

■ Associating a Salary Plan and Grade with the Guideline Table

Creating a Compensation Guideline
Use the following procedure to establish guidelines for compensation.

To create a guideline

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Guidelines.

2 In the Guidelines list, add a new record, and then complete the fields.

The following table describes the fields in the guideline record.

Field Comments

Name Enter a descriptive name for the guideline.

Description Enter a description for the guideline.

Type Select the guideline type from the list. Options are Merit, Variable 
Pay, Promotion, and Stock.

Effective Date Specify the effective date of the guideline.

Active Select the check box to activate the guideline.
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Defining Compensation Guideline Ranges
Guideline Ranges determine the minimum, maximum, and target guideline values 
for merits, variable pay, and stock. For merits and variable pay, the minimum, 
maximum, and target amounts entered should represent a percentage. For stock, the 
amounts entered should represent the actual number of shares.

To set guideline ranges

1 In the Guidelines list, select the guideline.

2 In the Guideline Table list, select the guideline for which ranges will be defined.

3 In the Guideline Ranges list, add a new record and complete the fields.

The following table describes the fields in the guideline ranges record.

Associating a Salary Plan and Grade with the Guideline Table
The Guideline Table is used to associate salary plan and salary grade combinations 
with specific compensation guidelines and their corresponding factors.

Field Comments

Factor 1 - Low Value Enter the low value of the range for Factor 1.

Factor 1 - High Value Enter the high value of the range for Factor 1.

Factor 2 - Low Value Enter the low value of the range for Factor 2.

Factor 2 - High Value Enter the high value of the range for Factor 2.

Minimum Enter the guideline minimum amount.

Maximum Enter the guideline maximum amount.

Target Enter the guideline target amount.

Default Select the default row to be used when an employee's Factor 
1 and Factor 2 combination do not match a row in the table.
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To associate salary information with guidelines

1 In the Guidelines list, select the guideline.

2 In the Guideline Table list, add a new record and complete the fields.

The following table describes the fields in the guideline table record.

Field Comments

Salary Plan Select the salary plan for which the guideline applies. The 
salary plan is used in combination with the selected salary 
grade.

Salary Grade Select the salary grade for which the guideline applies. The 
salary grade is used in combination with the selected salary 
plan.

Factor 1 Select the factor for determining the guideline.

The options are:

Periodic Review. The most recent periodic review rating from 
Siebel Objectives and Reviews

Annual Review. The most recent annual review rating from 
Siebel Objectives and Reviews

Compa-Ratio. The salary and salary range midpoint

Salary Quartile. The salary quartile based on the salary range

Factor 2 (Optional) Select a second factor for determining the 
guideline.
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Defining Compensation Eligibility Rules
Employee eligibility for compensation changes can vary from one compensation 
type to another, as well as from one planning cycle to the next. You can define 
eligibility rules to determine which employees are eligible for which types of 
compensation change. Eligibility rules can also be used to control which employees 
have budgets calculated for them.

To create an eligibility rule

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Eligibility Rules.

2 In the Employee list, click Query.

3 In the Query form, enter the criteria to find the employees that are included in 
the eligibility rule, and then click Go.

The list of employees is the result of the eligibility rule.

4 Click the menu button and then choosing Save Query As (ALT + S) to save the 
eligibility rule.

In the Save Query As dialog box, enter a name for the eligibility rule and then 
click OK.

You can refine the eligibility rule criteria by clicking the menu button, and 
choosing Refine Query.

After an eligibility rule has been saved, you select it from the Planning Cycles and 
Budgets views. For more information, see “Managing Compensation Budgets” on 
page 118 and “Defining Planning Cycles” on page 123.

NOTE: Eligibility determines the ability to plan compensation changes for specific 
employees. You can manually override eligibility for specific employees within a 
compensation plan by accessing the plan through the All Compensation Plans or All 
Compensation Plans Across Organizations views.
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Defining the Compensation Plan Rollout
Siebel Compensation Planning allows organizations to select the management 
levels within the organizational hierarchy that participate in the compensation 
planning process. The term plan rollout refers to the determination and control over 
which managers participate in the planning process. A compensation plan is 
automatically created for each manager who participates in the planning process. 
For more information, see “Defining Planning Cycles” on page 123.

Participation in the compensation planning process is defined within Position 
Administration. The designation is accomplished by first identifying positions as 
business unit leaders, and then specifying the number of levels below the business 
unit leaders that participate in the planning process.

Figure 13 shows an identified business unit with levels. In this example, if John's 
position (Level 1) is selected as a business unit leader with one level below, then 
Mark, Jane, and Chris (Level 2) would also have compensation plans created for 
them. Employees in Level 3 and Level 4 are automatically rolled up into Level 2 
compensation plans during the plan creation process.

To define compensation plan rollout

1 From the application-level menu, choose View > Site Map > Group 
Administration > Positions.

2 In the Positions list, query to find the position of the employee you want to 
designate as a business unit leader.

Figure 13. Business Unit with Levels
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3 In the form, specify the number of levels that will participate in the planning 
process in the Compensation Plan Rollout field.

Include the business unit leader and each level below the position in the number 
that you enter.

The following table describes the values you can use when planning the 
compensation plan rollout.

Value Comments

1 Only this position is able to plan.

2 through N This position and positions N - 1 levels below are able to plan.

NULL The position inherits plan rollout from parent position.

0 This position cannot plan. Positions below with Compensation Plan 
Rollout = NULL continues to inherit plan rollout from parent 
position.

-1 This manager cannot plan. Positions below with Compensation Plan 
Rollout = NULL cannot plan.
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Managing Compensation Budgets
Compensation planning involves creating and maintaining budgets for each type of 
compensation. Before the planning process can begin, you must define a budget for 
each type of compensation included in the compensation plan. For each 
compensation type, you can create a logical expression to calculate the budgeted 
amount for each employee. During the budget calculation process, a record is 
created for each employee within the Employees list using the evaluated expression. 
This section includes information and procedures for the following topics:

■ Creating a Compensation Budget

■ Defining Compensation Budget Expressions

■ Calculating the Compensation Budget

■ Locking the Compensation Budget

■ Adding an Employee to the Compensation Budget

Creating a Compensation Budget
Budget records are only created for employees who meet the following criteria:

■ The employee has an employee type of Employee.

■ The employee has an employment status of Active, Leave of Absence, or Paid 
Leave of Absence.

■ The employee meets each eligibility rule applied to the budgeting process.

To create a budget

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Budgets.
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2 In the Budgets list, add a new record and complete the fields.

The following table describes the fields in the budget record.

To create budget types for the budget

1 In the Budgets list, select the budget.

2 In the Budget Types list, add a new record and complete the fields.

The following table describes the fields in the budget type record.

Field Comments

Active Select the check box to activate the budget.

Currency Select the appropriate currency code for the budget.

Last Run Indicates the date and time of the last budget calculation.

Name Enter a name for the budget.

Organization Click the select button to choose the organization associated with 
the budget.

Period Select the period that the budget covers. The Start and End fields 
are populated after you select a period.

Status A system-generated value. Values are New, Calculated and Locked. 
For more information, see “Locking the Compensation Budget” on 
page 121. 

Field Comments

Budget The total budget amount. This field is automatically completed 
when the budget is calculated. The application aggregates budget 
amounts for the employees associated with the selected budget 
type in the selected period.

Budget Spent The total budget spent amount. The application aggregates budget 
spent amounts for the employees associated with the selected 
budget type in the selected period.

Eligibility Rule Select an eligibility rule to indicate which employees have budgets 
created for them.
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Defining Compensation Budget Expressions
You can create budget expressions that are used to calculate the budgets. A budget 
expression is a formula that can include any field within the ERM Employee 
business component including Employee Salary, Employee Job Code, Employee 
Salary Grade, and so on.

Several standard functions are supported, allowing budget calculations to include 
arithmetic, Boolean, and conditional operators. For more information on syntax and 
functions that can be used in budget expressions, see Siebel Tools Reference.

NOTE: If the employee salary has been stored in the Job Information view using a 
currency different from the budget currency, the employee salary is converted to the 
budget currency during the calculation of the budget amount. The Employee Salary 
field must be the first field to appear within the expression for the currency 
conversion to be successful.

Calculating the Compensation Budget
After the budget definition (including the desired budget expressions) have been 
defined, you can begin the budget calculation.

NOTE: The budget calculation process should only be run in a server environment. 
Running the budget calculation process on a mobile or dedicated client is not 
recommended. 

The budget calculation can take several minutes to complete depending on the 
number of employees and complexity of the budget expressions. During the 
calculation process, you can periodically press ALT + ENTER to refresh the screen 
and update the budget status.

Expression Enter an expression to calculate the budget amount.

Type Select the compensation type for which you want to calculate a 
budget. Values include Merit, Promotion, Variable Pay, and Stock.

Field Comments
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To calculate the budget

1 In the budgets list, select the budget and then click Calculate.

2 Verify that the budget calculation is completed by reviewing the status field in 
the budget record.

When completed, the budget status is Calculated.

Locking the Compensation Budget
After a budget is calculated, you can lock the budget record to prevent further 
calculations. Budget Types and Employee records can be manually updated as 
needed by temporarily unlocking the budget record.

Locked budgets can be linked to one or more planning cycles for incorporation into 
the associated compensation plans. After final approval of a compensation plan, the 
approved compensation change amounts for an employee are reflected in the 
Budget Spent fields in the Budget Types and Employees lists.

CAUTION: Running the budget calculation process results in the unrecoverable loss 
of the Budget and Budget Spent amounts for any previously calculated budget 
records. When necessary, individual Budget and Budget Spent amounts can be 
manually updated.

To lock a budget

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Budgets.

2 In the Budgets list, query to find the budget you want to lock.

3 In the Budget record, choose Locked from the Status field drop-down list.

NOTE: Budgets can be unlocked by changing the status back to Calculated.
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Adding an Employee to the Compensation Budget
Employees can be added to the compensation budget.

To add an employee to a budget

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Budgets.

2 In the Budgets list, query to find the budget you want to unlock.

3 In the budget record, choose Unlocked from the Status field drop-down list.

4 In the Budget Types list, select the appropriate compensation type you want to 
calculate for the employee.

5 In the Employees list, add a new record and then click the select button in the 
Last Name field.

6 In the Pick Employee dialog box, query to locate the employee you want to add, 
and then click OK.

7 Complete the rest of the fields.
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Defining Planning Cycles
You must create a planning cycle before initiating the compensation planning 
process. A planning cycle definition determines which period, budget, guidelines, 
eligibility rules, and compensation types are incorporated into a compensation 
planning cycle. After a planning cycle has been defined, the associated 
compensation plans can be created and released to the managers to begin the 
planning process.

To create a planning cycle

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Planning Cycles.

2 In the Planning Cycles list, add a new record and complete the fields.

The following table describes the fields in the planning cycle record.

Field Comments

Name Enter the name of the planning cycle (for example, Q2 2002 Merits 
and Promotions).

Description Enter a description of the planning cycle.

Organization This field is automatically populated with the organization 
associated with the planning cycle based on the budget.

Budget Select the budget record associated with the planning.

Exchange Date Select the currency exchange date used in the planning cycle. This 
date must be specified when multi-currency planning occurs.

Period Select the compensation plan period. This choice provides the values 
for the Plan Start and Plan End fields.

Plan Start This read-only field shows the start date of the compensation plan 
period, based on the period selection.
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A planning cycle must have at least one compensation type associated with it. For 
each planning cycle, the list of associated components determines which 
component tabs (Merits, Promotions, Variable Pay, Stock, and so on) are accessible 
to managers during the planning process.

To associate a compensation type with a planning cycle

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Planning Cycles.

2 In the Planning Cycles list, select the planning cycle.

3 In the Components list, add a new record and complete the fields.

The following table describes the fields in the component record.

Plan End This read-only field shows the end date of the compensation plan 
period, based on the period selection.

Status This field displays the planning cycle status. The following values 
indicate status:

■ New. The plan creation process has not been invoked.

■ In Progress. The plan creation process is in progress.

■ Done. The plans have been created, but have not been released to 
managers for planning.

■ Locked. The plans have been created and released to managers 
for planning.

Field Comments

Field Comments

Name Enter a name for the compensation component.

Type Select the compensation type (for example, Merit, 
Promotion, Variable Pay, Stock).

Guidelines Select the guideline that applies to the compensation 
component.
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Eligibility Rule Select the eligibility rule that applies to the compensation 
component.

Transaction Effective 
Date

Select the transaction effective dates of a merit, promotion, 
bonus, or stock grant transaction. Specifying one or more 
of these dates per compensation type provides control of 
dates from which managers can select when determining 
the effective dates of salary increases, promotions, bonus 
payouts, and stock grants.

Field Comments
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Generating Compensation Plans
After the planning cycle definition is completed, the actual compensation plans can 
be generated. The compensation plan generation process creates a plan for each 
manager participating in the planning process, in accordance with the 
compensation plan rollout settings. For more information, see “Defining the 
Compensation Plan Rollout” on page 116.

NOTE: The plan creation process should only be run in a server environment. 
Running the plan creation process on a mobile or dedicated client is not 
recommended.

When the plan creation process is complete, the planning cycle can be locked, 
thereby releasing the generated compensation plans so that managers can begin 
planning. Planning cycles should not be locked until after the cycles have been 
verified as ready for release.

To generate compensation plans

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > Planning Cycles.

2 In the Planning Cycles list, select the planning cycle, and then click Create Plans.

■ During compensation plan creation, a status of In Progress appears in the 
Status field. When the compensation plan creation process is completed, 
Done appears in the status field.

■ After the plans are created, they are accessible in the All Compensation Plans 
view. The plans must be released so that managers can begin the planning 
process.

To release compensation plans

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration >All Compensation Plans.

2 In the All Compensation Plans list, locate the compensation plan.
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3 In the compensation plan record, change the status to Locked in the Status field.

CAUTION: Running the plan creation process for a planning cycle that is locked 
results in the unrecoverable loss of any previously planned compensation within 
that planning cycle.
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Accessing All Compensation Plans
You access compensation plans using the All Compensation Plans and All 
Compensation Plans Across Organizations views. The All Compensation Plans view 
lists compensation plans associated with users in the organization. The All 
Compensation Plans Across Organizations view shows each compensation plan 
across all organizations. Compensation plans accessed through these views are 
editable and can be submitted, approved, and declined as needed.

To access the All Compensation Plans view

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > All Compensation Plans.

2 In the All Compensation Plans list, select the compensation plan and then drill 
down on the hyperlink in the Name field to view details.
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Viewing Employee Compensation History
The compensation plan history for each employee can be accessed in the All 
Employees Compensation History view. This view is useful when assessing 
compensation planning results for a specific employee.

To view the compensation planning history for an employee

1 From the application-level menu, choose View > Site Map > Compensation 
Planning Administration > All Employees Compensation History.

2 In the Employees list, query to find the employee whose history you want to 
view.

3 In the History list, query to locate specific information.
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Currency Exchange Rates for Compensation Planning
When planning compensation that uses multiple currencies, the associated 
currency exchange rates must be defined and accurately maintained within the 
Siebel application.

The exchange rates from one currency to another must be defined with reciprocity 
within currency administration. For example, the exchange rate between U.S. 
Dollars to Japanese Yen and Japanese Yen to U.S. Dollars must both be defined.

For more information on setting up currencies, see Applications Administration 
Guide.
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Siebel ERM allows administrators to publish literature and links within the 
appropriate views in their Siebel application. This section describes the procedures 
used to publish and administer literature and links within Siebel ERM.
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Publishing Literature, Links and Bulletins
Using the Message Broadcasts and the Literature features, you can publish product 
literature, distribute Web clips, provide links to Web sites, and post bulletins on the 
ERM home page. Users receive this information based on subscription information 
in their tracking profile. 

For more information about tracking profiles, see “Using Tracking Profile to Control 
ERM Home Page Information” on page 40.

Publishing Literature
You can distribute literature items such as sales brochures, marketing presentations, 
and price sheets to a targeted audience of users. When you create a literature record 
in the Siebel Encyclopedia, you identify the accounts, competitors, industries, and 
products associated with the contents of the file. Users who have selected those 
topics in their tracking profile receive a link to the literature file. When a user clicks 
the link, the program that was used to create the file opens and the file appears.

You can use the release and expiration date in the Literature view to control when 
literature items are posted.

As shown in Figure 14, literature associated with accounts and competitors 
automatically appears in the literature section of Account and Competitor Briefing 
pages, also known as Customer Content. If the literature items are deleted from the 
Siebel Encyclopedia, then the items are removed from Account or Competitor 
Briefings.

NOTE: Users must have the appropriate applications installed to view literature 
items. For example, to view .pdf files, the user must have Adobe Acrobat Reader.
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For detailed information about literature, see Applications Administration Guide.

Figure 14. Literature Section on the ERM Home Page
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Example Process for Publishing Links and Bulletins
The following section describes the process an administrator might follow to 
distribute literature, recommended links and bulletins to users. Your company may 
follow a different process flow according to its business requirements.

Administrator Procedures
The Siebel administrator requires administrative responsibilities to:

1 Create literature records. The administrator creates literature records and specifies 
the literature type to create a recommended link or Web clip. The administrator 
then associates the literature records with accounts, competitors and products. 
For more information, see “Publishing Web Clips and Recommended Links” on 
page 135.

2 Create company bulletins. The administrator uses Message Broadcasts to create 
bulletins for company announcements and alerts. For more information, see 
“Publishing Bulletins on ERM Home Page” on page 139.
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Publishing Web Clips and Recommended Links
Recommended Links allow you to distribute useful Web pages to users. You can 
include the linked page in the Web Clips section in-line or as a hyperlink.

When you publish recommended links, you target a specific audience by 
associating recommended links with accounts, competitors, industries, and 
products. The recommended link is distributed to users who have subscribed to 
these topics in their tracking profile. You control the release and expiration date 
using the Portal Administration > Literature view. 

Figure 15 shows a recommended link with the display type of new window. The 
link appears in users’ ERM home pages. When users click the link, the Web page 
opens in a new window.

To publish Web Clips and Recommended Links

1 From the application-level menu, choose View > Site Map > Portal 
Administration > Literature.

Figure 15. Recommended Link
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2 In the Literature list, add a new record, enter a name and description, and 
complete the fields.

The following table describes some of the fields.

Field Comments

Author Click the select button to select the author’s name.

Distribution Method Indicates whether or not the file is automatically distributed to 
users.

Publish. Sends the record to the user and begins the 
transmission of the file. If your user does nothing during a 
synchronization session, the file downloads automatically. If 
your user explicitly skips the file, the file is not downloaded 
during the synchronization session. During the next 
synchronization session, downloading again does not occur.

By Request. The user gets the record, but not the actual file. 
The user must request the file by selecting the Request field.

Expiration Date To post the literature item on the user’s ERM Home page, enter 
an expiration date.

File Name Enter the name of the file or a URL. URLs must include the 
protocol, for example, http://.

File Type The file type is automatically entered.

Internal Indicates whether or not the document is about your company 
and not intended for public distribution (internal).

■ Select the check box if the document is internal.

■ Clear the check box if the document is about another 
company (external) or is intended for public distribution. 

■ If the literature is internal, it does not appear as a choice in 
the Enclosure list in the My Correspondence Requests view 
or in the Literature list in the Product Detail Administration 
view. To change this behavior, remove the Search 
Specification, Internal = Y on the appropriate Business 
Component. For more information on changing Business 
Components, see Siebel Tools Reference.
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Literature Type Specify the type of link you are creating.

For example, if you are creating a recommended link or Web 
clip, select Recommended Link.

If you are creating a link to a file, select the appropriate type for 
the file. For example, for a sales presentation, you might select 
Sales Tool: Presentation.

Local This check box is visible only when you are logged in to a local 
database.

Indicates whether the document is available on the local hard 
disk. If a document is not available locally, you can request it 
by selecting the Request field. The file is downloaded during 
your next synchronization session.

Modified The date and time of the last file modification is automatically 
entered.

Organization Select the organization to which you want to distribute the 
literature item.

Release Date To post the literature item in the ERM Home page, enter a 
release date.

Size The file size is automatically entered.

Synopsis Enter a summary of the literature item. Text in the Synopsis 
field appears on the user’s ERM Home page. If nothing is 
entered in the Synopsis field, the contents of the Description 
field appear instead.

Field Comments
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3 Select or add accounts, competitors, industries, and products associated with the 
literature item.

If the literature item is associated with an account or competitor, it appears in 
the Literature section of the Account or Competitor Briefing page.

For users who have included the associated topics in their tracking profile, a link 
to the literature item appears in the Literature section on the ERM Home page.

Update File A check mark in this check box indicates that the copy of the 
literature should be updated automatically each time the 
original file is updated.

Web Display If you are linking to a Web page, use this field to determine how 
to display it.

Frame. Displays a link to the Web page. When the user clicks 
the link, the page appears in the current frame.

Window. Displays a link to the Web page. When the user clicks 
the link, the page appears in an expanded window. The user 
must use the Web browser’s Back button to return to Siebel 
ERM.

New Window. Displays a link to the Web page. When the user 
clicks the link, the page is displayed in a new browser window, 
allowing the user to switch between Siebel ERM and the Web 
page.

In-Line. Displays the entire Web page in the selected section of 
the portal page. 

Displaying Web pages in-line works best with simple Web 
pages. Large or complex pages, such as those that use 
JavaScript, can slow down the system and cause unexpected 
results. Be sure to test in-line pages before distributing them to 
users.

Field Comments
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Publishing Bulletins on ERM Home Page
Bulletins are internal company messages that alert users to company 
announcements. Bulletins appear in the New Bulletins section of the ERM home 
page. Figure 16 shows an example of the New Bulletins view tab on the home page, 
with bulletin text and headline.

To publish bulletins

1 From the application-level menu, choose View > Site Map > Communications 
Administration > Message Broadcasts.

2 In the Message Broadcasts list, add a new record and complete the fields.

The following table describes the fields in a message broadcast record.

Figure 16. New Bulletins

Field Comments

Abstract Enter the bulletin’s title. Text in the Abstract field appears 
in bold and can be up to 100 characters.

Activation Date Select the activation date and time for the bulletin to 
appear. 

All Users Select the All Users check box to send the bulletin to users.

Briefing Bulletin Select the Briefing Bulletin check box if you want the 
bulletin to appear in the New Bulletins section of the ERM 
home page.

Broadcast Select this check box to make the bulletin available for 
broadcast.
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For more information about Message Broadcasting, see the chapter about message 
broadcasting in Applications Administration Guide.

Division To send the bulletin to users in a specific Division, click 
Select button, and then in the dialog box that appears, 
select or create the Divisions you want to receive the 
bulletin.

Division Select the division to which the bulletin should be sent.

Expiration Date Select the expiration date and time for the bulletin.

If there is no expiration date specified, the bulletin appears 
indefinitely. To remove a bulletin that does not have an 
expiration, delete the bulletin’s Activate Date.

Message Enter the text of broadcast message. This text appears as 
the body of the bulletin and can be any number of 
characters in length.

Recipient To send the bulletin to specific users, click the Select 
button. In the dialog box, select or add the users you want 
to receive the bulletin.

Recipient Select the recipients to whom the bulletin should be sent.

Severity Select the Severity of the message. Options are Normal, 
High, Urgent, or Urgent with Alert. Normal is the least 
severe, and Urgent with Alert is the most severe.

Field Comments
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Using Group News, an organization’s news authors and content managers can 
create, edit, approve, preview, and publish dynamic real-time content within the 
Siebel application. 

This section describes the how to set up and manage Group News authoring, and 
perform the following procedures:

■ Create, import, and edit dynamic content using Siebel Content Editor

■ Create a news story and publish it in multiple formats throughout the 
application

■ Preview news articles in multiple formats

■ Submit content for approval, based on workflow technology

■ Review and roll back to previous article versions

■ Control end-user access to content, based on roles and responsibilities

■ Automate the publishing, expiration, and archiving of content
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Business Scenario for Group News
This scenario provides an example of a process performed by the Group News 
administrator. Your company may follow a different process according to its 
business requirements.

Administrator
The CEO of an organization determines that important news stories should 
originate in the Top Story section on the Home Page and move to the Feature 
Articles section on day two and the Archive section on day three. This business 
requirement is communicated to the Group News administrator responsible for 
creating content paths. As part of the content path creation process, the news 
administrator designates authors and approvers through responsibilities, 
determines the approver workflow, the set of approvers, and the employee access 
groups that have visibility rights to the news story. After the content paths are 
created, the news administrator defines three stages, one for each of the sections in 
which a news story associated with this content path will be published—Top Story, 
Feature Articles, and News Archive. 
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Example Process for Group News
The following section describes the processes an administrator and an end user 
might follow to set up and use Group News. Your company may follow a different 
process according to its business requirements.

Administrator Procedures
The Siebel administrator requires administrative responsibilities to:

■ Set up group news users and responsibilities. The administrator assigns 
responsibilities to administrators, managers and authors, allowing these users to 
work with news content. For more information, see “Setting Up News 
Administrators, Authors, and Approvers” on page 145.

■ Set up workflow. The administrator defines routing and approver workflow 
processes for Group News content. For more information, see “Setting Up Group 
News Approver Workflow” on page 147.

■ Create content paths. The administrator creates the content paths which authors 
associate with news stories. For more information, see “Creating a Content Path” 
on page 148.

■ Create stages. The administrator creates stages so that news can be published in 
multiple locations. For more information, see “Creating Stages for the Group 
News Content Path” on page 150.

■ Select levels of approvers. The administrator sets up the approval process that 
routes content from the author to the approvers. For more information, see 
“Designating Group News Approvers” on page 152.

■ Set up Group News access. The administrator sets up which employee groups 
have access rights. For more information, see “Setting Up Access to Group 
News” on page 154.
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End-User Procedures
The end user, a content manager and approver, requires the appropriate 
responsibilities to:

1 Create and submit a news story. The content manager creates a news story, selects 
a content path, and submits it for approval. For more information, see “Creating 
a News Story (End User)” on page 155.

2 Preview the new story. For more information, see “Previewing a News Story (End 
User)” on page 160.

3 Submit the news for approval. For more information, see “Submitting a News Story 
for Approval (End User)” on page 161.

4 Approver approves news story for publication. The approver modifies the news 
story, and approves it for publication. For more information, see “Approving a 
News Story (End User)” on page 162.
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Setting Up News Administrators, Authors, and Approvers
Before a user can author and approve news stories, the administrator must associate 
the user with the appropriate responsibilities.

Siebel ERM is preconfigured with several responsibilities specific to Group News, 
which organizations can use to set up Group News users. Table 12 describes the 
preconfigured Group News responsibilities.

Table 12. Preconfigured Group News Responsibilities

Responsibility Comments

ERM Group News 
Administrator

Users with the Group News Administrator responsibility can access 
the Group News Administration views and can perform the 
following tasks:

■ Create a content path, which includes selecting an approver 
workflow, defining content stages, assigning approvers, and 
designating access groups.

■ Edit submitted or completed news stories.

Content Manager Users with the Content Manager responsibility can access the Group 
News Authoring views and can author and approve news stories. An 
ERM Content Manager can approve a specific news story only if the 
manager is designated as an approver for the content path 
associated with the news story.

ERM Manager Users with the ERM Manager or ERM User responsibility can access 
the News Archive on myPage and departmental portal pages. For 
more information on portal page access, see Applications 
Administration Guide.

ERM User Users with the ERM Manager or ERM User responsibility can access 
the News Archive on myPage and departmental portal pages. For 
more information on portal page access, see Applications 
Administration Guide.
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To set up an administrator, author, or approver for Group News

1 From the application-level menu, choose View > Site Map > Application 
Administration > Responsibilities.

2 In the Responsibilities list, query to find the responsibility with which you want 
to associate an employee:

■ ERM User 

■ ERM Manager

■ Content Manager

■ ERM Group News Administrator

NOTE: The Views tab at the bottom of the screen includes the views that a user 
assigned to the selected responsibility can access. You can add or remove views 
according to your organization’s needs, or you can create a new responsibility. 
For more information on creating and modifying responsibilities, see the Security 
Guide for Siebel eBusiness Applications. 

3 In the Users list, click New.

4 In the Add Users dialog box, query to find the user you want to add, and then 
click OK.

The user you add is associated with the Group News responsibility you selected.
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Setting Up Group News Approver Workflow
As an administrator you can define routing and approver workflow processes for 
Group News content. The approver workflow process determines the way the Siebel 
application handles content associated with the workflow. Siebel Group News is 
preconfigured with a Group News workflow that has two approval levels. This 
workflow allows Siebel to automatically send content from the creator, to the first 
level approver, then to the second level approver, and finally to the appropriate page 
views for publishing. At each point in the workflow process the content can be 
modified or approved. Approver workflows streamline the approval process, 
helping news authors to publish time-sensitive content for immediate employee 
review.

You can use the preconfigured workflow titled Group News Approver Workflow or 
you can create a new workflow. For more information about workflow modification 
and creation, see Siebel Business Process Designer Administration Guide. 

To set up a Group News workflow

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 In the Workflow Processes list, query to find *Group News*.

3 Select the Group News approver workflow process you want to use.

4 In the Status field, verify that the workflow is Active.

NOTE: To create a workflow with additional levels of approval, copy the existing 
Group News Approver Workflow and add the additional business processes as 
needed. For more information about creating and modifying workflows, see 
Siebel Business Process Designer Administration Guide. 
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A Content Path defines a set of attributes for the news story or news stories 
associated with the Content Path. These attributes include:

■ The business process (approver workflow) that automates the approval process

■ When the news story is published within the application 

News stories can be scheduled for publication in multiple locations, or stages, 
throughout the application.

■ The format in which the news story is published

■ When the news story is published in each of the stages

■ The approvers scheduled to approve the news story

■ The group of ERM users or access groups that have visibility rights to the news 
story

Group News administrators create content paths in the Group News Administration 
views; news authors associate content paths with news stories. Content Paths allow 
news authors to automate many of the processes associated with publishing a news 
story.

To create a content path

1 From the application-level menu, choose View > Site Map > Group News 
Administration > Content Path.

2 In the Content Path list, add a new record, and complete the name and 
description fields.

The content path name and description should help news authors determine the 
appropriate content path for news stories.

TIP: As part of the description, include information on which access groups are 
receiving the content.

3 In the WorkFlow field, click the select button.
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4 In the Workflow Process Definition dialog box, query to find the appropriate 
Group News workflow approver process, and then click OK.

■ To make the content available to employees, click to remove the check mark 
from the Private field. 

■ To make the content available only to specific groups of employees, click to 
check the Private Field. 

■ You can specify the specific employee groups from the Access Groups view 
tab.
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Creating Stages for the Group News Content Path
News stories can be scheduled for publication in multiple locations, or stages 
throughout the application.

To create the stages for the content path

1 Create a Content Path record, using the procedure “Creating a Content Path” on 
page 148.

2 In the Content Path list, select the record and click the Stages view tab.
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3 In the Stages list, add a new record and complete the fields. 

The following table describes the fields in the stage record.

Field Comment

Description A brief description of the stage.

End Day Determines, in conjunction with the go-live date specified by the 
author, the expiration date for any given stage. To remove a news 
story from the selected stage five days after the go-live date, for 
example, enter 5.

Page Specifies the Siebel page for the content. 

Section Specifies the section on a page for the content. The Section field 
shows the available sections in the Siebel application. You should 
make sure that the section you select is an active section on the 
selected view.

Start Day Determines, in conjunction with the go-live date specified by the 
author, the publication date for any given stage. For example, to 
publish a news story in the selected stage on the go-live date enter 0.

View Indicates the page view on which the content appears. 
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The Group News approver workflow allows you to automatically send content from 
the creator to the first level approver, and then to the second level approver.

When setting up approvers, make sure that the number of approvers entered in the 
Approvers list equals the number of approvers required by the selected approver 
workflow. If you select fewer approvers than required by the approver workflow, the 
news story is not routed for approvals or published. If an administrator selects more 
approvers than required by the approver workflow, the news story is not routed to 
the extraneous approvers.

To select the group news approvers

1 Create a Content Path record, using the procedure “To create a content path” on 
page 148.

2 Create the stages for the content path, using the procedure “To create the stages 
for the content path” on page 150.

3 In the Content Path list, select the record and click the Approvers view tab.

4 In the Approvers list, add a new record, and then complete the fields.

a In the Position field, click the select button.

b In the Pick Position list, query for the employee you want to designate as an 
approver, select the employee, and then click OK.

c In the Sequence field, enter a sequence number for the approver. 

The sequence number indicates the order in which approvers approve the 
news story. The first approver has a sequence number of 1.

Repeat this procedure for each approver level in the selected workflow.
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Modifying a Content Path to Change an Approver
You can modify a content path to change the associated approver. 

To change an approver associated with a content path

1 From the application-level menu, choose View > Site Map > Group News 
Administration > Content Path.

2 In the Content Path list, query to find the content path you want to modify.

3 Click the Approvers view tab.

4 In the Approvers list, select the record of the approver you want to change.

5 In the Position field, click the select button.

6 In the Pick Position list, query for the employee you want to designate as an 
approver, and then click OK.

7 In the Sequence field, enter a sequence number for the approver. 

The sequence number indicates the order in which approvers approve the news 
story. The first approver has a sequence number of 1. 
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Setting Up Access to Group News
You can establish which employee access groups have visibility rights to the news 
story.

To set up access to news

1 From the application-level menu, choose View > Site Map > Group News 
Administration > Content Path.

2 In the Content Path list, query to find the content path you want to modify.

3 In the Content Path list, select the record and verify that the Private Flag check 
box includes a check mark. 

4 Click the Access Groups view tab, and then in the Access Groups list, add a new 
record.

a In the Add Access Groups list, query to find the access group you want to 
add.

b Click OK to add the access group to the Access Groups list.

Repeat this step for each access group you want to add.

5 In Content Path list, select the Content Path record and in the Status field select 
Active from the drop-down list.

A status of Active allows news authors to access the content path.
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Creating a News Story (End User)
The Siebel Group News module allows organizations to publish news stories in one 
of the following formats:

■ Top Story. News published to this section appears as a large abstract with a large 
graphic and a link to the full story.

■ Feature Articles. News published to this section appears as a small abstract with 
a small graphic and a link to the full story.

■ Today’s Headlines. News published to this section appears as a link to the full 
story.

■ My News. News published to this section appears as an abstract with a small 
graphic and a link to the full story.

■ News Archive. News published to this section appears as a small abstract with a 
small graphic and a link to the full story. In the News Archive form, end users 
can query for articles based on user-specified search criterion.

Authors can publish news in the Top Story, Feature Articles and Today’s Headlines 
sections on the Home Page or on any of the microsite pages. The My News and 
News Archive sections are located on the myPage.

To create a news story

1 From the application-level menu, choose View > Site Map > Group News 
Authoring > News Inbox.

2 Click the Information view tab, and then in the Information form click New.

3 Complete the fields to provide information about the news story.

The following table describes the fields in the Information form.

Field Comments

Author Provide the name of the author. This field defaults to the current user 
and is not made visible to readers.

By-Line Specify the by-line text for the story as it should appear to readers. 

Content Path Specify the content path to associate with the news story.
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Creating Content for a News Story
After the news story is created, authors can enter and edit content for the story, or 
import content that was previously created in an external HTML editor. For 
information on importing content, see “To import a news story” on page 158.

Content Type Specify the priority of the news story. The content type can be used 
internally to help categorize news stories by priority level. The content 
type does not affect the appearance of the news story to readers.

Department Specify the department of the author or news story.

Go-Live Date Specify the date on which the content is activated. This field defaults 
to the current date and time. The value in this field is also used in 
combination with the content path Start Day and End Day values to 
further define the time content becomes active.

Headline Specify a headline for the news story as it should appear to readers.

Name Specify a name for the news story. The name is not made visible to 
readers.

Region Specify the region of the author or news story.

Field Comments
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To create the news story content

1 From the application-level menu, choose View > Site Map > Group News 
Authoring > News Inbox.

2 In the News Stories list, select a news story, and then click the Content Editing 
view tab.

For more information, see “To create a news story” on page 155. 

3 In the Content Editor field, enter the news story content.

When you click in the Content Editor field, the integrated HTML editor toolbar 
appears at the bottom of the field. The toolbar provides special editing controls, 
which allow you to use supported HTML formatting and standard editing 
features. For more information, see Fundamentals.

4 Complete the remaining fields as needed.

Depending on the content path selected for the news story, some fields may not 
be required. A Top Story, for example, uses the Long Abstract and Large Image 
fields. Feature Articles and My News stories use the Small Image and Short 
Abstract fields. Today’s Headlines stories do not use the abstract or image fields.

The following table describes some of the fields.

Field Comments

Large Image Select a large image for news stories that will be published in the Top 
Story section.

Long Abstract Create a long abstract for news stories that will be published in the Top 
Story section. 

Short 
Abstract

Enter a short abstract for news stories that will be published in the 
Feature Articles or My News sections.

Small Image Select a small image for news stories that will be published in the 
Feature Articles or My News sections.
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Importing a News Story
Use the following procedure to import content for news stories.

To import a news story 

1 From the application-level menu, choose View > Site Map > Group News 
Authoring > News Inbox.

2 In the News Inbox form, click New, and then complete the fields to add the news 
details.

The following table describes the fields in the News Inbox record.

3 Click the Content Editing view tab, and then in the Content Editing form, click 
Import Article.

4 In the Pick Content dialog box, click New.

Field Comments

Author Provide the name of the author. This field defaults to the current user 
and is not made visible to readers.

By-Line Specify the by-line text for the story as it should appear to readers. 

Content Path Specify the content path to associate with the news story.

Content Type Specify the priority of the news story. The content type can be used 
internally to help categorize news stories by priority level. The content 
type does not affect the appearance of news story to readers.

Department Specify the department of the author or news story.

Go-Live Date Specify the date on which the content becomes live. This field defaults 
to the current date and time. The value in this field is also used in 
combination with the content path Start Day and End Day values to 
further define the time content becomes active.

Headline Specify a headline for the news story as it should appear to readers.

Name Specify a name for the news story. The name is not made visible to 
readers.

Region Specify the region of the author or news story.
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5 In the Insert Content dialog box, complete the fields.

The following table describes some of the fields in the Insert Content dialog box.

6 Click OK in the Insert Content dialog box, and then click OK again from the Pick 
Content dialog box.

The imported news story appears in the Content Editing field. Authors and 
approvers can edit imported content using the Content Editor.

Field Comments

Comments Type additional comments to describe the content.

Content Type Specify the type of content you are adding. A list of available types 
appears when you click the select button.

Filename Browse to the content you want to import.

Lock A check mark in this field indicates that the content cannot be edited. 

Name Specify the name to use to be saved in Siebel Content Base.

Title Specify the title to be saved in Siebel Content Base.

URL Specify the URL that references the content you are importing.
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 159



Managing Group News

Previewing a News Story (End User)
Previewing a News Story (End User)
To view the news story before routing it for approval, use the Preview view tab in 
the Group News Authoring screen.

To preview the news story

1 From the application-level menu, choose View > Site Map > Group News 
Authoring > News Inbox.

2 In the News Stories list, select the news story you want to preview.

3 Click the Preview view tab to view the news story.
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Submitting a News Story for Approval (End User)
After a news story is complete, the news author submits it for approval. The news 
story immediately appears in the first approver's News Inbox according to the 
approver workflow associated with the news story.

To submit a news story for approval

1 From the application-level menu, choose View > Site Map > Group News 
Authoring > News Inbox.

2 In the News Stories list, query to find the news story you want to submit.

3 Make sure the story you want is selected.

4 In the Status drop-down list, select Submitted. 
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Approving a News Story (End User)
News approvers must have the Content Manager responsibility. For more 
information on setting up approvers with the appropriate responsibilities, see 
“Setting Up News Administrators, Authors, and Approvers” on page 145. Approvers 
access news stories that require their approval by navigating to their news inboxes 
in the Group News Authoring screen. 

To approve a news story

1 From the application-level menu, choose View > Site Map > Group News 
Authoring > News Inbox.

2 In the News Stories list, select the news story you want to approve.

3 Click the Content Editing view tab, and in the Status field, choose Completed 
from the drop-down list.
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Siebel eContent Services is a news and company information subscription service 
that is preintegrated with Siebel ERM. 

Siebel eContent Services presents personalized external news about selected 
accounts, competitors, industries, and customizable subscription topics that are 
most relevant to your business and each individual employee’s job. Business news 
and company profiles are integrated, filtered, and presented in context for each 
employee and combined with relevant company internal data drawn from the 
Siebel customer database. Using a process that maps businesses directly to news 
sources, eContent Services provides only the relevant new for businesses and 
topics, such as your customers, competitors, prospects, and partners. 

This chapter describes the administration procedures necessary to include industry 
news content in a Siebel application.
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Business Scenario for eContent Services
This scenario provides an example of a process performed by an administrator or 
topic manager and end users. Your company may follow a different process 
according to its business requirements.

Administrator
A financial organization using Siebel ERM has signed a contract with a new client, 
a computer software company. The representatives in client services who are 
responsible for supporting the new client, send a request to the news topic manager 
to create a news topics for the software company. 

The administrator first designates the news topic administrator, creates access 
groups that can access the news content, and establishes host and authentication 
credentials.

Since the client is a software company, the administrator creates the news topic 
within the High Technology news package. The administrator also creates a new 
access group and assigns the appropriate client service representatives to the group. 
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Example Process for eContent Services
The following section describes the process an administrator might follow to set up 
eContent Services. Your company may follow a different process according to its 
business requirements.

Administrator Procedures
The Siebel administrator requires administrative responsibilities to:

1 Assign News Topic Administrator responsibilities. The administrator assigns 
responsibilities to the employee who will administer news topics. For more 
information, see “Assigning News Topic Administrator Responsibilities” on 
page 166.

2 Create access groups. The administrator creates access groups so that relevant 
content can be directed to specific groups of users. For more information, see 
“Creating Access Groups for eContent News Services” on page 167.

3 Set up host and authentication credentials. The administrator establishes the 
content host name, user name, and password that allow access to the Siebel 
application-hosted data. For more information, see “Setting Up eContent Host 
and Authentication Credentials” on page 168.

4 Create news packages. The administrator sets up news packages—subscriptions 
to third-party content sources offered by Siebel eContent Services. For more 
information, see “Creating a News Package” on page 169.

5 Create news topics. The administrator sets up news topics to locate topics of 
interest within the news packages. For more information, see “Managing News 
Topics” on page 170.

6 Associate accounts and competitors with news topics. The administrator associates 
accounts and competitors to new topics to create briefings. For more 
information, see “Retrieving Account and Competitor News for Briefings” on 
page 173 and “Associating Accounts and Competitors with News Topics” on 
page 176.

7 Associate your company with a news topic. The administrator associates his 
organization with a news topic to display company news on the company’s 
Briefings page. For more information, see “Associating Your Company with a 
News Topic” on page 177.
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Assigning News Topic Administrator Responsibilities
Before a topic manager can administer the user- or administrator-defined content in 
Siebel eContent Services, the employee must be associated with the appropriate 
responsibilities. You can assign employees additional responsibilities that allow the 
employees to administer news topics.

To set up a news topic administrator, create a responsibility that provides access to 
the News Topics Manager screen, and associate it with the appropriate employee. 
For more information on creating employee responsibilities, see Security Guide for 
Siebel eBusiness Applications.
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Creating Access Groups for eContent News Services 
Before you configure or create a news topic, consider which groups within your 
organization should have access to news services provided by eContent Services. 
For example, if your organization has purchased seats of eContent Services for a 
subset of employees, only those employees should have access to the external 
content. In addition, depending on the employee’s role in an organization, or the 
types of clients with which the employee works, an employee may need access to 
certain industry sources and content topics. Rather than configure topics within 
eContent Services so that the topics are visible to any user, you can configure 
content so that it is visible to specific groups of users. You must associate an access 
group with a news package when you set up the package. As a result, you should 
create the appropriate access groups for your topics before you set up eContent 
Services.

Listed below are general procedures you should complete before setting up 
eContent Services. 

1 Make a list of each organization requesting access to each news package (for 
example, specific industry sources and content topics).

2 Create an access group for each news package, unless an appropriate group 
already exists.

3 Associate employees with the access groups used for eContent Services.

NOTE: When setting up a news package, use these access groups to target the 
package to a specific group of users.

For more information about setting up access groups, see the Security Guide for 
Siebel eBusiness Applications.
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Setting Up eContent Host and Authentication Credentials
During Siebel Server installation, the administrator installing the application is 
asked if the organization has purchased Siebel ERM, Siebel ERM and Siebel 
eContent Services, or neither. When you select Siebel ERM or Siebel ERM and Siebel 
eContent Services, you are asked to enter the assigned content host name, user 
name, and password that allows you to access the Siebel application-hosted data. 
Siebel application-hosted data consists of company profiles, corporation 
relationship information, premium external news feeds, and productivity content 
from leading content producers and providers. You can also edit these parameters 
within the application using the following procedures.

NOTE: The host name, user name, and password credentials are provided in the 
license key letter distributed to each customer after purchase. 

To set up eContent host and authentication credentials

1 From the application-level menu, choose Site Map > Integration Administration 
> Host Administration.

2 In the HTTP Host list, add a new record and complete the fields.

You can also modify the default entry in the host table. 

The following table describes the fields in the HTTP host record.

3 Restart your server.

Field Comments

Authentication Type Set authentication type to NCSA Basic.

Authentication Value Enter the authentication value in the format 
username:password as shown in your letter.

Name Provide a name for the external host. Change the host entry 
[ServerName] to the eContent host name provided in your 
letter.

Virtual Name A virtual name for the external host. This information is 
provided in your letter.
168 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up eContent Services

Creating a News Package
Creating a News Package
A News Package is a subscription to a collection of third-party content sources 
offered by Siebel eContent Services. Your organization may subscribe to several 
news packages in several different languages. For example, your organization may 
subscribe to general sources in French, English, or Spanish languages or to specific 
sources for your industry, such as Finance, High Technology, and Life Sciences. As 
an administrator, you must set up your Siebel ERM application to include content 
from the news packages to which you subscribe.

To create a news package

1 From the application-level menu, choose Site Map > Portal Administration > 
News Topic Manager.

2 In the News Packages list, click New to create a news package record.

The following table describes the fields in the new package record.

After you set up a news package, you can create the news topics. For more 
information on creating a news topic, see “Managing News Topics” on page 170.

Field Comments

Access Group Select the access groups that have access to the news package.

Inactive A check mark in this field indicates that the news package is 
not available to employees.

Name Provide a name for the external news package. It is 
recommended that you use the package name provided in 
your letter.

Parameter Enter the parameter exactly as it is provided in your letter. This 
parameter indicates to the Siebel Server the precise content to 
retrieve. 
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A News Topic is a set of search criteria used to find current news on topics of 
interest within a news package. Table 13 describes the types of news topics 
available in Siebel ERM.

Creating a News Topic 
As an administrator, you can create, modify, and delete administrator and user- 
defined news topics.

To create a news topic

1 From the application-level menu, choose Site Map > Portal Administration > 
News Topic Manager.

2 In the News Packages list, query to find the news package for which you want 
to create a news topic.

Table 13. Siebel eContent Services News Topic Types

News Topic Type Comments

Administrator-
Defined

Siebel ERM allows you to create news topics based on the criteria 
you specify. News topics that you create in the Administrator-
Defined view are available to employees within the access groups 
associated with the news group. Employees with access to the 
selected news group can choose to include the news topic on a 
personalized view in the Siebel ERM application.

Predefined ERM delivers a predefined set of search topics that allow end users 
to receive current news on topics of interest to them (based on their 
tracking profile selections). Search topics include headline news, 
local and regional news, industry news, business topics, sports, 
health, and more. The search criteria for predefined topics cannot 
be modified. The topics can only be inactivated or activated. If the 
topics are inactivated, they will not appear as choices for the end 
user in the My News Topics view.

User-Defined Siebel ERM allows users who are associated with the appropriate 
news group to create news topics based on specified criteria. 
Administrators can view and manage news topics created by users 
in the User Defined view.
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3 Click one of the following view tabs:

■ Administrator-Defined

■ User-Defined

4 In the News Topics list, add a new record and complete the fields.

The following table describes the fields for the News Topic record.

5 Click Preview to see the topic final format.

Editing a New Topic
Use the following procedure to modify an news topic.

To edit a news topic

1 From the application-level menu, choose Site Map > Portal Administration > 
News Topic Manager.

Field Comments

Inactive Click the check box to inactivate or activate the selected news topic. 
A check mark appears in this column when the news topic is 
inactive. Users can select only active news topics in their tracking 
profile.

If you later mark a user-subscribed news topic as inactive, the user 
no longer sees news for that topic.

Name Enter an identifying name for the topic. Users see this text 
description in the Add News Topics form. If the user selects this news 
topic, this text also appears as a section heading in the My News 
section of their My Briefing page.

Query Enter the query to be submitted in the news topic search. Queries 
can be expressed as simple words or strings, as is customary with 
advanced search syntaxes in most search engines. Multiple terms 
that do not contain a Boolean expression (and, or) are treated as a 
phrase. Boolean operators (and, or) are recognized. Quote marks can 
be used to demark a phrase. When an operator occurs within quotes 
it is treated as part of the phrase. 
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 171



Setting Up eContent Services

Managing News Topics
2 In the News Packages list, query to find the news package associated with the 
news topic.

3 Click one of the following view tabs:

■ Administrator-Defined

■ User-Defined

4 In the News Topics list, query to find the news topic.

5 In the news topic record, modify the fields as needed.

Inactivating a News Topic
News topics are preconfigured as active. You can use the News Topics 
Administration screen to inactivate or activate news topics.

To inactivate a news topic

1 From the application-level menu, choose Site Map > Portal Administration > 
News Topic Manager.

2 In the News Packages list, query to find the news topic.

3 Click one of the following view tabs:

■ Administrator-Defined

■ Predefined

■ User-Defined

4 In the News Topics list, query to find the news topic.

5 In the Inactive field, select the check box.
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Retrieving Account and Competitor News for Briefings
Siebel eContent Services allows you to include briefings about your accounts, 
competitors, other organizations, and so on, in your Siebel ERM application. These 
briefings are retrieved from data within your Siebel application, as well as from 
external news sources based on your organization’s subscriptions with Siebel 
eContent Services. 

As an administrator you can create account topics, which are used to associate your 
Siebel accounts and competitors with external content. You also can associate your 
organization with a news topic to display company news on the My Briefings page. 
For more information, see “Associating Accounts and Competitors with News 
Topics” on page 176 and “Associating Your Company with a News Topic” on 
page 177.

Siebel ERM can use the account topics you create to search Siebel eContent Services 
for information about your accounts and competitors.

Siebel ERM uses D&B as its standard for company topics. You use the Account Topic 
Manager to associate accounts and competitors to D-U-N-S numbers. D-U-N-S 
numbers are a standard way for external content providers to index company 
information. If you search using an indexed term, such as the D-U-N-S number, 
rather than a more generic search term, such as company name, then your search 
results are more likely to be accurate and relevant.

NOTE: D-U-N-S numbers that have been assigned and populated to an account do 
not always appear. To find out if the D-U-N-S has been assigned, click the drop-
down list for the DUNS field. If the D-U-N-S record has already been assigned, it 
appears in this drop-down list. Click OK and the D-U-N-S record appears in the field.

By associating your accounts and competitors with topics, you also gain access to 
Siebel Company Vocabulary, which provides access to other common company 
identifiers, such as its stock ticker symbol. This gives you the ability to configure 
portal agents to submit different search terms to different content providers—for 
example, the D-U-N-S number to one content provider, the stock ticker symbol to 
another.

For more information about portal agents, see Siebel Portal Framework Guide.
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You can associate multiple accounts from your Siebel database to a single topic. 
This is an appropriate section when external content services consider several 
accounts in your Siebel database as a single entity. For example, you can have 
several divisions of Acme, Inc. (Acme West, Acme East, and Acme South) listed as 
unique accounts in your Siebel database, while an external content provider may 
index news based on the parent company, Acme, Inc.
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You link accounts to topics using the Accounts Topic Manager screen, shown in 
Figure 17. The illustration shows the Accounts list at the top of a Siebel application 
screen. At the bottom of the screen is the Company Search list.

Figure 17. Account Topic Manager
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Associating Accounts and Competitors with News Topics 
For news and company information to appear on the My Briefing page, you must 
link accounts and competitors in your Siebel database to a topic. D-U-N-S numbers 
are the standard topics used by Siebel eContent Services to identify companies. You 
link accounts and competitors to topics using the Account Topic Manager.

To create or change a topic association

1 From the application-level menu, choose View > Site Map > Portal 
Administration > Account Topic Manager.

The accounts and competitors from your Siebel database appear in the Accounts 
list. Name and Location are read-only. If the company is marked as a Competitor 
in your Siebel database, there is a check mark in the Competitor column.

2 In the Accounts list, query for and select the account or competitor you want to 
associate with a topic. 

3 In the Company Search form, query for the account or competitor name in the 
Company Name field. 

Matching records from the Siebel eContent Services company database (or your 
selected external content provider database) appear. For example, you might see 
multiple listings of a company because each location or subsidiary might have 
its own D-U-N-S number assigned to allow specific searches on that location or 
subsidiary.

4 In the search results list, choose the specific company you want to define for 
your account or competitor, and click the Assign DUNS button.

The corresponding company name and D-U-N-S number are entered in the 
Accounts list for the record that was previously selected.

NOTE: If your company has purchased Siebel eContent Services, you can click 
the Company Briefing button on the Company Search form to retrieve a briefing 
on the selected company.
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Associating Your Company with a News Topic
To be able to receive news about your own company in the Our Company section 
of the My Briefing page, you must associate your company with a topic. To perform 
this procedure using the Account Topic Manager, you associate a record called Our 
Company with your company’s D-U-N-S number.

To associate a topic with your company

1 From the application-level menu, choose View > Site Map > Portal 
Administration > Account Topic Manager.

2 In the Accounts list, query for and select the account or competitor you want to 
associate with a topic.

3 In the Company Search list, query for the account or competitor name in the 
Company Name field.

4 In the search results list, choose the specific company you want to define for 
your account or competitor, and click the Assign DUNS button.

The corresponding company name and D-U-N-S number are entered in the 
Accounts list for the record that was previously selected.

NOTE: If there is no company news available, the Our Company in the News section 
does not appear.
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D& B Account Rationalization Services and News Topics
The D&B Account Rationalization Services automates the association of accounts 
and topics by matching your account records to D-U-N-S numbers in batch. A link 
to D&B’s Web site appears on the Account Topic Manager view.

For more information, see Applications Administration Guide.
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Siebel HelpDesk allows employees to submit and track service requests through the 
organization’s intranet, and solve problems without assistance by providing access 
to frequently asked questions (FAQs) and interactive diagnostic tools. Employees 
can also use employee self-service features such as Alerts Online and Assets Online 
to get help. This chapter describes setting up and using Siebel HelpDesk.
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Siebel HelpDesk and Support Organizations
Siebel HelpDesk is a suite of support solutions which allows organizations to 
manage service for their internal support organizations. The Siebel HelpDesk 
module is designed to reduce support agent workload while increasing first-contact 
resolution rates. Siebel Automated Solutions allows employees to fix applications, 
run automated diagnostics scripts on their computers to remotely analyze other 
employees’ computers, chat electronically with other employees, and audit the 
network for hardware and software inventories.

Siebel HelpDesk allows organizations to create new help desks to capture 
information for each internal service situation. Each help desk can include its own 
subareas and routing rules, and is configurable by administrators. This allows the 
organization to provide a single, consistent interface to the support function across 
departments.

In addition, Siebel HelpDesk provides the tools for asset inventory, digital ID 
inventory, auto-assignment and other support automation features to reduce the 
need for intervention by support specialists.

Using Siebel HelpDesk, problems can be tracked and measured against a single 
service-level agreement (SLA). This allows each employee to receive a consistent 
level of service, and issues are recognized and escalated to facilitate a resolution.

Siebel HelpDesk helps organizations create and maintain a single repository of 
information so that employees can access the most current answers to questions. 
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Business Scenario for Siebel Help Desk
This scenario provides an example of a process performed by a Siebel HelpDesk 
administrator, agent, support representative, and a help desk requestor. Your 
company may follow a different process according to its business requirements.

Administrator
An organization using Siebel ERM hires a new employee. The administrator assigns 
the appropriate responsibilities to the employee so that the employee can access the 
help desk. The administrator assigns the employee a laptop computer and records 
the asset distribution using Siebel HelpDesk. 

During the day, the administrator prepares for an upcoming systems upgrade by 
adding the affected systems to Alerts Online so that employees automatically 
receive notification of system outages. The administrator also creates a number of 
solution records, which include answers to frequently asked questions (FAQs) about 
the organization’s 401(k) retirement plan.

To assess the effectiveness of the help desk in resolving problems, the administrator 
modifies the employee satisfaction survey before it is sent to users.
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Example Process for Siebel HelpDesk
The following section describes the process an administrator might follow to set up 
Siebel HelpDesk. Your company may follow a different process according to its 
business requirements.

Administrator Procedures
The Siebel administrator requires administrative responsibilities to:

■ Set up help desk agents and entitlements. The administrator associates support 
agents with responsibilities, and then sets up employee entitlements. For more 
information, see “Setting Up Siebel HelpDesk Responsibilities” on page 183 and 
“Setting Up Siebel HelpDesk Entitlements” on page 185. 

■ Manage and Allocate Assets. The administrator adds new assets to the Assets 
database, and allocates assets to employees. For more information, see 
“Managing and Allocating Assets” on page 186.

■ Set up Alerts Online. The administrator adds systems and subsystems to Alerts 
Online, which provides system status information to employees. For more 
information, see “Setting Up Alerts Online” on page 188.

■ Set up Solution FAQs. The administrator creates frequently asked questions 
(FAQs) for the Solutions database that employees can use to search for answers 
to common problems. For more information, see “Creating Siebel HelpDesk 
FAQs for Solutions Database” on page 190.

■ Prepare employee satisfaction survey. The administrator modifies the list of 
selectable responses for the HelpDesk employee satisfaction survey that will be 
sent to HelpDesk users. For more information, see “Modifying Selectable 
Responses for Employee Surveys” on page 194.
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Setting Up Siebel HelpDesk Responsibilities
Before a user can run Siebel HelpDesk, you must associate the user with the 
appropriate responsibilities.

Siebel ERM is preconfigured with several responsibilities that are specific to Siebel 
HelpDesk. Organizations can use these preconfigured responsibilities to set up help 
desk users. Table 14 describes the preconfigured help desk responsibilities.

The responsibilities can be used as is during a deployment, they can be modified to 
meet the needs of the particular organization, and the responsibilities can be used 
as a guide for creating new responsibilities.

Table 14. Preconfigured Siebel HelpDesk Responsibilities

Responsibility Comments

HelpDesk Agent Users with this responsibility can access the Siebel HelpDesk views.

Universal Agent Users with this responsibility can access the Call Center views.

ERM User Users with the ERM Manager or ERM User responsibility can access 
the Siebel HelpDesk.
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To set up a Siebel HelpDesk agent

1 From the application-level menu, choose View > Site Map > Application 
Administration > Responsibilities.

2 In the Responsibilities list, query to find the responsibility with which you want 
to associate an employee.

The responsibilities are:

■ ERM User 

■ Universal Agent

■ HelpDesk Agent

NOTE: The Views tab at the bottom of the screen includes the views that a user 
assigned to the selected responsibility can access. You can add or remove views 
according to your organization’s needs, or you can create a new responsibility. 
For more information on creating and modifying responsibilities, see the Security 
Guide for Siebel eBusiness Applications. 

3 In the Users subview list, add a new record.

4 In the Add Users dialog box, query to find the user you want to add, and then 
click OK.

The user is associated with the selected responsibility.
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Setting Up Siebel HelpDesk Entitlements
Siebel HelpDesk provides service entitlement verification of registered users in 
addition to the standard contact authentication at login. If entitlement verification 
is active when a user tries to create, update, or view a service request, the 
application verifies that the user is listed as a contact for a currently valid service 
entitlement. 

To add an employee to an entitlement 

1 From the application-level menu, choose View > Site Map > Agreements > All 
Agreements Across Organizations.

2 In the Agreements list, select the agreement to which the entitlement belongs 
and drill down on the Name hyperlink.

The Agreement form appears.

3 Click the Entitlements view tab.

4 In the Entitlements list, select an existing entitlement from the current 
agreement, and then complete the necessary fields.

5 Click the Contacts view tab, and in the Contacts list, add a record.

6 In the Add Contacts dialog box, select a contact, and then click OK.

7 In the Contacts list, click in the Internet field to activate the Internet flag.

NOTE: You can also create a new record or new entitlement as needed in from 
the All Employees - HelpDesk view.

For more information on setting up service-level agreements, see Siebel Field Service 
Guide.
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Managing and Allocating Assets 
As an administrator, you can assign assets, such as laptops and RSA tokens, and 
track assets assigned to each employee.

Adding Products to Assets Online
Using the Product Administration screens, you can add products, and then make the 
products available as assets.

To add a new product

1 From the application-level menu, choose View > Site Map > Product 
Administration > Products.

2 In the Products list click Query, enter the query criteria, and then click Go.

The products that meet the criteria appear in the Products list.

3 Select the product and then click the More Info view tab.

4 In the Sales Product field, click the check box to make sure that the product 
appears in the Assets list.

For more information about working with products, see Siebel Field Service 
Guide.

Managing New Assets
You can track and store asset information associated with employees using the 
Asset Management screen. For example, if your organization provides laptop 
computers to remote employees, you can track these assets using your Siebel 
application. For more information about assets, see Siebel Field Service Guide.

To add a new asset

1 From the application-level menu, choose View > Site Map > Asset 
Management > All Assets.

2 In the Assets list, add a new record.

3 In the Pick Product dialog box, query for the product, and then click OK.

4 Complete the necessary fields for the new asset.
186 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up Siebel HelpDesk

Managing and Allocating Assets
Allocating an Asset to an Employee
Using the Employee Administration screen’s All Employees – HelpDesk view, you 
can allocate assets to a specific employee.

To add an asset to an employee

1 From the application-level menu, choose View > Site Map > Employees> All 
Employees - HelpDesk.

2 In the Employees list, query to find the employee associated with the asset.

3 Click the Assets view tab.

4 In the Assets list, add a new record.

5 In the Add Assets dialog box, enter query criteria and click Go.

6 In the Add Assets dialog box, select the asset, and then click Add.

The new asset appears in the Employee Assets list.

7 Complete the fields as needed for the employee asset.
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 187



Setting Up Siebel HelpDesk

Setting Up Alerts Online
Setting Up Alerts Online
The Alerts Online module allows employees to monitor the status of critical 
infrastructure systems. Status for different systems appears in the Alerts Online 
view from the Siebel HelpDesk page. Employees can click a system hyperlink to 
view status details.

As an administrator, you use the Application Administration view to add, delete, 
and edit systems and subsystems and their status. 

Adding Systems to Alerts Online
The Alerts Online administration screen allows you to add systems to the Alerts 
Online section of the HelpDesk home page. You can add, delete, and edit systems 
and subsystems in the System Status and Subsystem Status views.

To add a system to Alerts Online

1 From the application-level menu, choose View > Site Map > Application 
Administration > Alerts Online.

2 In the System Status list, add a new record and complete the fields.

3 In the Name field, enter the name of the system you want to track.

4 From the Status drop-down list, select the appropriate status of the system.

The Status field options are Currently Available, Current Outage, and 
Diminished Service.

Adding Subsystems to Alerts Online
The Alerts Online administration screens allow you to define the subsystems you 
want to track. You can add, delete, and edit systems and subsystems in the System 
Status and Subsystem Status views.

To add a subsystem to Alerts Online

1 From the application-level menu, choose View > Site Map > Application 
Administration > Alerts Online.

2 In the System Status list, query to find the system to which you want to add a 
subsystem.
188 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up Siebel HelpDesk

Setting Up Alerts Online
3 In the Enterprise Subsystem list, add a new record and complete the fields.

The following table describes the fields in the substation record.

The status information is updated when you step off the record. 

4 Refresh the page to see the changes to the status information.

Field Comments

Description A description of the status. 

ETA The estimated date and time when the system is available 
again.

Location The location of the subsystem.

Reported The date and time when the status was last updated.

Reported By The name of the user who reported the status.

Severity The severity of the problem. For example, Critical, High, 
Medium, Low.

Status The status of the system. For example, Currently Available, 
Current Outage, and Diminished Service.

Subsystem The name of the subsystem you are tracking.
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Creating Siebel HelpDesk FAQs for Solutions Database
The Siebel HelpDesk application is built on a collection of problem resolution 
histories. This database includes a single repository for trouble tickets and 
resolutions logged throughout the organization. Employees can search the database 
and retrieve solutions to common problems without having to wait for help desk 
personnel to become available.

This section describes the procedures used to create and categorize frequently 
asked questions (FAQs). For more information on catalog and category 
administration, see Siebel eSales Administration Guide. 

Creating FAQs
To publish FAQs (Siebel Solutions records), you must first create the FAQs and then 
categorize them in the appropriate Siebel ERM catalogs. After they are categorized, 
the FAQs appear in the appropriate views. To restrict user access to specific 
categories, you can apply access control to the categorized FAQs.

To create FAQs

1 From the application-level menu, choose View > Site Map > Solutions 
Administration > Solutions.

2 In the Solutions list, add a new record and complete the fields.

The following table describes the fields in the solution record.

Fields Comments

Description Enter the FAQ answer that you want to appear to Siebel 
HelpDesk users.

FAQ Enter the FAQ question that you want to appear to Siebel 
HelpDesk users.

Name Specify the name of the FAQ. The title name does not appear to 
Siebel HelpDesk users, it is the name used to save the record to 
the Siebel file system.

Status Select the status of the FAQ.

Type Select Solution to indicate the record as an FAQ solution record.
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After the FAQ record is created, you must associate the record with the appropriate 
category. For more information on categorizing an FAQ, see “Categorizing FAQs.”.

Categorizing FAQs
You can use the Catalog Administration view to associate existing FAQs with a 
category. To display FAQs in the General FAQs list in Siebel HelpDesk, the FAQs must 
be categorized in the catalog called ERM Catalog. To display FAQs in the Top FAQs 
list in Siebel HelpDesk, the FAQs must be categorized in the catalog called ERM Top 
Solutions and the category called ERM Top Solutions.

For more information on creating an FAQ, see “Creating FAQs” on page 190.

To add FAQs to a Siebel ERM Category

1 From the application-level menu, choose View > Site Map > Catalog 
Administration > Catalog Administration.

2 In the Catalog list, query to find ERM Catalog.

3 Click the catalog name hyperlink.

4 From the Categories list, select the category to which the FAQ will be added. 

5 Click the Solutions view tab, and in the Solutions list, add a new record.

6 In the Add Solutions dialog box select the FAQ you want to add to the category, 
and then click OK.

The selected FAQ is associated with the selected category.

Creating a Resolution
A resolution is a content item, typically a text document or product literature item, 
that includes information that is relevant to solving a specific service request. To 
make a resolution available to Siebel HelpDesk users, you must perform the 
following tasks:

■ Add the desired content to the literature catalog. You can specify a path, browse 
for a file, or link to the file through a URL.

■ Provide a name for the resolution item.

■ Specify the type of the resolution item that has been added.
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■ Optionally, associate the resolution item with a catalog category.

■ Associate the literature that has been added to the catalog to one or more catalog 
categories.

For more information on catalog and category administration, see Siebel eSales 
Administration Guide.

To add a resolution item to the Siebel HelpDesk

1 From the application-level menu, choose View > Site Map > Resolutions 
Document Administration > Resolutions Document Administration.

2 From the Resolutions Documents list, add a new record and complete the fields. 

The following table describes some of the fields in the resolution document 
record.

Categorizing a Resolution
You can use the Catalog Administration view to associate existing resolutions with 
a category. For more information on creating an resolution, see “Creating a 
Resolution” on page 191.

To add a resolution to a category

1 From the application-level menu, choose View > Site Map > Catalog 
Administration.

2 In the Catalogs list, query to find ERM Catalog or the ERM Top Solutions. 

3 Drill down on the hyperlink in the catalog Name field.

Fields Comments

 Type The resolution type.

Description A brief description about the resolution item. The description 
can be seen by Siebel HelpDesk users.

File Name The resolution item you want to add.

Name The name of the resolution item. The name is visible to Siebel 
HelpDesk users.
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4 In the Categories list, select the category with which you want to associate the 
resolution.

5 Click the Resolution Item view tab.

6 In the Resolution Items list, add a new record and complete the fields.
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Modifying Selectable Responses for Employee Surveys
The Siebel HelpDesk Employee Satisfaction survey allows you to obtain employee 
feedback using employee self-service. The survey is a Web-based form linked to a 
service request. The employee completes the form, submits it, and the help desk 
analyzes the results. 

An administrator can modify the list of selectable responses for each survey 
question. For instructions on configuring control properties for the Employee 
Satisfaction Survey, see “Setting Up an Employee Satisfaction Survey.”

To modify an employee satisfaction survey

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values.

2 Click Query, and in the Type field, type CS_* and then click Go.

A list of customer satisfaction values appears. 

3 Modify the existing values as needed. 

The following tables describes some List of Values fields.

Setting Up an Employee Satisfaction Survey
The Siebel HelpDesk Customer Satisfaction survey allows you to use an online 
survey to obtain employee feedback. The survey is used to solicit feedback on a 
specific service request the employee has submitted. This type of survey is 
accessible through the Service Request’s detailed view. The survey results can then 
be analyzed and reports can also be generated within Siebel HelpDesk Agent. 

Field Comments

Active field This field must be checked to be active.

Displayed Value This is the answer that appears in the drop-down list of values.

Order field This determines the order in which the answer appears in the 
drop-down list. Enter 1 to create the first value on the list, and so 
on.
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To modify the Siebel HelpDesk Customer Satisfaction Survey questions and labels, 
you need to use Siebel Tools to configure control properties of the Customer Survey. 
For more information on configuring control properties, see Siebel Tools Reference.
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Siebel HelpDesk Administrator Resources 
The following resources are available for the administrator responsible for setting 
up and configuring Siebel HelpDesk.

Administrator Activity Templates
Siebel HelpDesk agents often perform tasks that require multiple steps. As an 
administrator, you can create activity templates that provide the framework for 
agents to complete multistep tasks. The templates that you create can provide 
detailed steps or instructions for common issues. Siebel HelpDesk agents can follow 
the instructions or tasks within an activity template to resolve customer issues. For 
more information on setting up Activity Templates with associated activities, see 
Applications Administration Guide. 

Automatic Creation of Attachments
When filling out a service request, Siebel HelpDesk users can describe each issue 
in a description field. When the number of characters in the description is greater 
than the configured number of characters (the default is 2,000 characters) Siebel 
HelpDesk automatically creates a text file attachment and stores the file to the Siebel 
file system. The Description field can map to any database column with a character 
maximum of any specified number, defined by the database table.

To modify this functionality, you use Siebel Tools to configure the Max Description 
Length user property of the Service Request (eService) business component and 
specify a value for the maximum number of characters for the auto file attachment 
creation. For detailed instructions on mapping business component fields to 
database fields other than the default ones, see Siebel Tools Reference.

Email Notification for Alerts and Email Response
Using Siebel Workflow, you can define business rules that automate your business 
processes and procedures. For example, you may want to send email notification to 
alert employees when the status their service requests have changed. For detailed 
information on setting up email notification, see Siebel eService Administration 
Guide.

For information on setting up Siebel eMail Response, see Siebel eMail Response 
Administration Guide.
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Troubleshooting Processes and Siebel SmartScript
Siebel SmartScript allows users to perform self-directed question-and-answer 
sessions that simulate the experience of talking directly with an expert. The sessions 
can have a predefined process flow, or the flow can be designed to change 
dynamically according to the customer’s response. The process flow can also 
populate the Siebel database with customer input, creating service requests and 
completing applications. 

As an administrator, you can use Siebel SmartScripts and Siebel eService to create 
and administer these types of business processes. For more information, see Siebel 
eService Administration Guide. For creating troubleshooting guides and scripts for a 
help desk agent, see Siebel SmartScript Administration Guide.

Siebel Smart Answer and Siebel HelpDesk
Siebel Smart Answer uses linguistic analysis techniques and content analysis 
algorithms to perform natural language searches to retrieve solution data. The 
system has multichannel self-learning capabilities that allows it to adapt successful 
interactions over the Web, through email, or the Call Center.

If you plan on implementing Siebel Smart Answer, consider the following:

■ Siebel Smart Answer is recommended with Siebel HelpDesk when Siebel Smart 
Answer is already in use with Siebel eMail Response.

■ Siebel Smart Answer searches and displays solution records. The Knowledge 
Base used with Smart Answer should have solutions associated with available 
categories.

■ You can train the Knowledge Base using email messages and using FAQs 
converted into comma-separated value (CSV) files.

■ Check SupportWeb for recommendations on ways to refine accuracy for Siebel 
Smart Answer.

For information on set up and implementation of Siebel Smart Answer, see Siebel 
eMail Response Administration Guide.

Assignment Manager
For information on assigning service requests using Siebel Assignment Manager, see 
Siebel Assignment Manager Administration Guide.
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Escalation and Notification
To use the escalation and notification engine, see Siebel Business Process Designer 
Administration Guide.

CTI Integration and CTI Connect
For more information on configuring and setting up the communications server for 
Siebel HelpDesk, see Siebel Communications Server Administration Guide.

For more information on configuring and setting up communication middleware, 
see Siebel Communications Server Administration Guide.

Universal Queue
For more information on universal queuing, see Siebel Universal Queuing 
Administration Guide.
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Automated Diagnostics Setup for Siebel HelpDesk
For Automated Diagnostics and Automated Desktop Support installation 
instructions, see the third-party documentation that came with SupportSoft.

Support Center Installation
Install the Support Center application on your local computer. For information 
about installing Support Center, see the SupportSoft documentation in the third-
party documentation section of the Siebel eBusiness Third-Party Bookshelf.

Foundry Synchronization
When you first start up the Foundry, you navigate to the Utilities page and 
synchronize actions. You then can use the Support Actions shipped with your Siebel 
application.

For information about synchronizing the Foundry, see the SupportSoft 
documentation in the third-party documentation section of the Siebel eBusiness 
Third-Party Bookshelf.

Foundry Implementation
The Foundry is the central repository for Support Action authoring, maintenance, 
and modification within the support environment of an enterprise. Therefore, it is 
crucial that minimal Web access security to the Foundry be implemented before 
final production. Access to the Foundry should be granted only to a small set of 
authorized users, such as support administrators and support action authors. 

For information about securing the Foundry, see the documentation titled 
Implementing Basic Foundry Secure Web Access in the third-party documentation 
section of the Siebel eBusiness Third-Party Bookshelf.

Script Center
Script Center is an editor that you can use to write Visual Basic and Java scripts and 
is used by the Foundry for automated solutions. To use Script Center, you must first 
install the application using the Foundry.
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For Script Center installation instructions, see Siebel Automated Solutions 
Installation Guide in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

For information on using the Script Center, see the documentation titled Building 
Protections in the third-party documentation section of the Siebel eBusiness Third-
Party Bookshelf.

DNA Editor
The DNA Editor is an editor that allows you to create and edit scripts used to install 
and protect applications, network and printer settings. To use DNA Editor, you must 
install the applications using the Foundry.

For DNA Editor installation instructions, see Siebel Automated Solutions Installation 
Guide in the SupportSoft documentation in the third-party documentation section 
of the Siebel eBusiness Third-Party Bookshelf.

Protection Building
Building a good infrastructure foundation is essential when creating effective 
protections.

The six-step protection-building process is described in the white paper included in 
the SupportSoft documentation in the third-party documentation section of the 
Siebel eBusiness Third-Party Bookshelf.

For more information on ways to build protections, see the section titled Building 
Protections in the SupportSoft documentation in the third-party documentation 
section of the Siebel eBusiness Third-Party Bookshelf.

CD Vault
A CD vault minimizes the amount of data stored in a user’s local vault. A CD vault 
is useful for remote users and those users with computers that have limited hard 
disk space. The vault data is transferred to a CD-ROM image, which can be used at 
a later time to repair a computer system.

For more information on ways to build a CD Vault, see the SupportSoft 
documentation section titled CD Vault (CD_Vault.pdf) in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.
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SupportSoft Config File
Support Automation’s config.cfg controls the configuration of the Support 
Automation DNA server, Web server, Nexus information, Support.com Agent 
polling and posting, directory mapping, vault ordering, and so on.

For more information on the config.cfg file, see the SupportSoft documentation 
section titled Purpose of the Config.cfg File (Config_cfg.pdf) in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

Config File Location
Config.cfg is located in the <install root>\support.com\global directory. While 
there are other config.cfg files located within the Support.com directory structure, 
the config.cfg files do not control Support.com Global server settings.
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Config File Management
When necessary, the config.cfg should be managed through the Admin Console. 
The config.cfg can also be edited directly through the Support Portal Hub (Servers 
tab) or any text editor.

It is recommended that you make a backup copy of the config.cfg file before editing 
it. 

NOTE: Make sure that the line returns in the file are not deleted when saving the file. 
If the line returns are deleted, the file is not parsed correctly and the application 
does not function correctly. If you notice that some features no longer work as 
expected after modifying the config.cfg file, check to make sure the file still includes 
line returns. If the line returns have been deleted, you can insert the line returns 
using a text editor.

Default Reports
Automated Diagnostics provides a set of default reports that generate scorecards for 
specific performance appraisal questions. These reports provide statistics that are 
typically difficult to measure. The information presented in these reports assists 
your organization in gathering data concerning user and analyst use of the system. 
Your enterprise can also configure the time frame in which the reports appear.

The Default Reports include five sections:

■ Issue Creation Report. This report displays configured links to SmartIssues.

■ Scorecard Metrics Report. This report summarizes SmartIssues and customer 
satisfaction information.

■ SupportActions Report. This report shows available SupportActions as well as 
statistics on SupportActions use.

■ Analyst Report. This reports provides details of analysts using the system.

■ User Report. This report provides details of users who have submitted 
SmartIssues to the system.
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Unlike Advanced Reports, Default Reports provide preconfigured information. 
Based on customer requests, the Default Reports have been formatted to include 
statistics that include the most frequently asked questions about user interaction 
with the system. 

For detailed explanations of the five reports available at the Default Reports site and 
instructions for maximizing their use, see Default Reports (Default_Reports.pdf) in 
the SupportSoft documentation in the third-party documentation section of the 
Siebel eBusiness Third-Party Bookshelf.

Drivers and Services Management
The following categories provide strategies for managing driver protection:

■ Out-of-the-box protection strategy. Use the drivers and services protection scheme 
to protect drivers. This scheme is a standard feature of the Siebel Administration 
Console and protects drivers and services installed on a machine. The DNA 
created from this protection scheme is used to repair drivers and services on 
customer systems. This is the simplest strategy to implement.

■ Custom protection strategy. Use the Administration Console to create custom 
protection schemes that protect individual drivers on a machine. The utility 
program generates a list of files referenced in a driver’s *.inf file. This list of files 
is then used to create a custom protection scheme to protect the individual 
driver. The DNA created from this custom scheme is used to repair the driver on 
customer systems. This technique is more flexible when repairing driver 
problems, but takes more initial setup time.

■ Custom SupportAction strategy. Use SupportActions to manage driver versions 
and known driver conflicts. Its advantage is it provides a means to test for driver 
versions, reinstall drivers, and update drivers. It also leverages future OS 
supported signed driver installation techniques. This strategy is also very 
flexible when repairing problems, but requires SupportAction development time.

For more information on managing drivers and services, see Managing Drivers and 
Services (Drv_Srv.pdf) in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.
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Diagnostic Information Definition Extension
Support providers can extend the Automated Diagnostic definition by capturing 
information unique to the supported applications and environments and the type of 
support services they provide. 

For more information on extending the diagnostic definition, see Extensible 
SmartIssues (Exten_SI.pdf) in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

Healing Console Installation and Configuration
There are many ways to deploy the Healing Console to support analysts. The 
method you choose depends on the requirements of your organization. The 
methods are:

■ From the Siebel CD-ROM. This is used to deploy the standard Healing Console to 
a small number of support analysts. 

■ Without the Siebel CD-ROM using a script / batch file. This method is used to deploy 
the Healing Console to a large number of support analysts with a modified 
program shortcut.

■ Without the Siebel CD-ROM using a custom administration console job. This method 
is used to deploy the Healing Console to a large number of support analysts with 
a modified program shortcut. 

■ Without the Siebel CD-ROM using a custom SupportAction. This method is used to 
deploy the Healing Console to a large number of support analysts with a 
modified program shortcut. 

After installation, the Healing Console functions are configured using the 
Administration Console, the configuration file, and launch control parameters. For 
more information on installing and configuring the Healing Console, see Installing 
and Configuring the Healing Console (HC_Config.pdf) in the SupportSoft 
documentation in the third-party documentation section of the Siebel eBusiness 
Third-Party Bookshelf.
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Automated Desktop Support and Diagnostics
Siebel Automated Desktop Support and Diagnostics products can be configured to 
work in environments that include proxy servers, firewalls, NATs, or other type of 
Internet security.

For more information, see Support.com Technical Reports (npconnect.pdf) in the 
SupportSoft documentation in the third-party documentation section of the Siebel 
eBusiness Third-Party Bookshelf.

Nexus Server
The Siebel Support Automation Nexus Server is an optional component that 
facilitates socket-level communication between two computers in which one, or 
both, reside behind a firewall, Network Address Translation (NAT) router, or other 
type of Internet security mechanism. The Nexus server facilitates secure two-way 
communication and file access between systems behind a firewall and their other 
users that can be located behind a different firewall. In a typical enterprise 
deployment of the Siebel Nexus, support analysts connect to the Siebel Agent on a 
customer’s system using a secure socket connection over direct IP. However, when 
a support analyst needs to connect to an end user deployed on an extranet or over 
the Internet, a direct IP connection may be unavailable because of firewall security 
issues. In this example, both the Healing Agent on the customer’s system and the 
support analyst using the can communicate with each other through the Siebel 
Nexus. 

For more information on using Siebel Nexus, see Nexus Settings and Configuration 
(Inside_Nexus.pdf) in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

Nexus Registration
For information on registering a Nexus server, see Nexus Registration 
(Nexusreg.pdf) in the SupportSoft documentation in the third-party documentation 
section of the Siebel eBusiness Third-Party Bookshelf.
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Vault Setup
Each Siebel Automated Solutions Server should use the default vault located in the 
\backup directory below the server root as its read/write vault.

This vault includes the user customizations and specific changes. Over time, it may 
be necessary to add additional vaults to each server. The additional vaults may be 
located on the same or separate machines.

For more information on setting up additional vaults, see Inside the Vault 
(Inside_Vault.pdf) in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

Support Automation MTS Package Setup
If you experience MTS errors, consider recreating the Support Automation MTS 
Package. 

For more information on setting up or recreating MTS packages, see Troubleshooting 
Installation, Recreating MTS Package (MTS_Trouble.pdf) in the SupportSoft 
documentation in the third-party documentation section of the Siebel eBusiness 
Third-Party Bookshelf.
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Automated Desktop Support Installation
For Automated Desktop Support installation instructions, see the Siebel Automated 
Solutions Installation Guide (Siebel Automated Solutions Installation.pdf) in the 
SupportSoft documentation in the third-party documentation section of the Siebel 
eBusiness Third-Party Bookshelf.

Context Response
ContextResponse Technology gathers, analyzes, and responds to information to 
personalize and automate the support process. Its direct interaction with the user 
and the system results in a support experience tailored to the user’s environment 
and support needs. ContextResponse Technology builds on several other 
technologies, including DNA, SmartIssue, SupportTriggers, Context Profiles, and the 
SmartResult System.

DNA Technology provides each user with a personalized knowledge base of support 
solutions. The characteristics of each user’s software applications and operating 
system components are identified and tracked over time. ContextResponse 
Technology uses this information to provide a personalized diagnosis and repair by 
analyzing the results of diagnostics and comparing the user’s current system 
configuration to a previous working configuration.

SmartIssues Technology automatically gathers information that otherwise requires 
an interaction between the user and the support professional. For example, instead 
of asking the user to identify system information, ContextResponse Technology 
automatically gathers this data and electronically relays the information to the 
support professional.

SupportTriggers provide information about the user’s application when a support 
request is initiated. ContextResponse Technology uses this information to return a 
relevant solution from a custom Web page.

Context Profiles make a customizable subset of SmartIssue information available to 
match to Profile Scripts. Only SupportActions matching the Context Profile are 
returned as Personalized Solutions in the User Center.
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The SmartResult System combines SmartIssue information with statistical-based 
solution retrieval technology to guide users to solutions. Its natural language query 
provides users with answers that are based on the specific context of their problem 
without significant tuning and data structuring by the support organization on the 
front end.

For more information on Context Response, see Context Response (Context_rsp.pdf) 
in the SupportSoft documentation in the third-party documentation section of the 
Siebel eBusiness Third-Party Bookshelf.

Process Command-Line Parameters
For more information on the command-line parameters, see Process Command-Line 
Parameters (Cmdline.pdf) in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

Launch Control Parameters
The launch control for Support.com WIN32 components is cont.exe. This program 
determines which component is executed. Specifying optional parameters also 
controls some features of the component.

For more information on the Launch Control parameters, see Launch Control 
Parameters (Lcp.pdf) in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

Automated Desktop Support and Support Triggers
There are several benefits of using the Siebel Automated Desktop Support Suite to 
generate SupportTriggers. 

For more information on the Support Triggers, see SupportTriggers 
(SupportTriggers.pdf) in the SupportSoft documentation in the third-party 
documentation section of the Siebel eBusiness Third-Party Bookshelf.

Automated Desktop Support Repair for Windows NT and 2000
TgSrvc is Siebel Automated Desktop Support Repair Service for Microsoft Windows 
NT and 2000 systems. TgSrvc is a service for the Support.com Resolution Suite and 
is associated with other Siebel Automated Desktop Support application modules, 
including the ActionRunner and the SmartIssue Control.
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In a locked-down environment, using Siebel Automated Desktop Support software 
to repair registry and application files can be difficult because of user permissions. 
A user can have permissions on a personal network share, but not on the local 
system. In this example the user can only modify files in the c:\WINNT\Temp 
folder. Even though the user cannot modify local files or registry settings, these files 
and settings can be corrupted through an automatic software deployment job or 
application use. As a result, these files and settings, as well as those on the user's 
network share must be repaired. One solution to repair the files is to run a file 
service, TgSrvc, to change or restore locked-down local files and registry values.

NOTE: TgSrvc cannot be used to replace or repair registry keys larger than 4,096 
bytes.

For more information on the TGSrvc, see TGSrvc – Repair Service (TGSRVC.pdf) in 
the SupportSoft documentation in the third-party documentation section of the 
Siebel eBusiness Third-Party Bookshelf.
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Configuring Siebel HelpDesk to Use SupportSoft
You can use Siebel Tools to configure your Siebel HelpDesk to use SupportSoft.

To configure Siebel HelpDesk to use SupportSoft

1 Use Siebel Tools to set up the Diagnostic Option.

a Create an image control with the following properties:

Name = ImageDiagnostics

HTML Bitmap = HM_PG_FORM_LIBRARY

HTML Display Mode = EncodeData

HTML Type = ImageButton

Method Invoked = GotoUrl

Visible - Language Override = Y

b Add a User Property to the ImageDiagnostics controls with the following 
properties:

Name = Url

Value = http://localhost/siebel/diagnostics.asp

c Create a link control with the following properties:

Name = LinkDiagnostics

Label = Diagnose a Problem

HTML Display Mode = EncodeData

HTML Type = Text

Method Invoked = GotoUrl

Visible - Language Override = Y

d Add a User Property to the LinkDiagnostics controls with the following 
properties:

Name = Url
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Value = http://localhost/siebel/diagnostics.asp

e Create a label control with the following properties:

Name = LabelDiagnostics

Label = Diagnose a problem with your IT equipment

HTML Display Mode = EncodeData

HTML Type = Label

Visible - Language Override = Y

2 Use Siebel Tools to set up the Quick Fix Option.

a Create an image control with the following properties:

Name = ImageQuickFix

HTML Bitmap = HM_PG_TROUBLESHOOT

HTML Display Mode = EncodeData

HTML Type = ImageButton

Method Invoked = GotoUrl

Visible - Language Override = Y

b Add a User Property to the ImageQuickFix controls with the following 
properties:

Name = Url

Value = http://localhost/siebel/quickfix.asp

c Create a link control with the following properties:

Name = LinkQuickFix

Label = Fix an Application

HTML Display Mode = EncodeData

HTML Type = Text

Method Invoked = GotoUrl
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Visible - Language Override = Y

d Add a User Property to the LinkQuickFix controls with the following 
properties:

Name = Url

Value = http://localhost/siebel/quickfix.asp

e Create a label control with the following properties:

Name = LabelQuickFix

Label = Fix an application or a system setting

HTML Display Mode = EncodeData

HTML Type = Label

Visible - Language Override = Y

For more information on using Siebel Tools, see Siebel Tools Reference.
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Siebel Employee Self-Service (ESS) helps managers and employees process routine 
and frequent transactions such as completing an employee address change or 
transferring an employee. Employee Self-Service guides users through the necessary 
procedures, incorporates relevant data, accepts user input, and automatically routes 
transactions for processing and approvals.

This chapter provides information on creating and maintaining employee self-
service processes. For examples of forms, see Appendix A, “Employee Self-Service 
Reference.” 
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Business Scenario for Employee Self-Service
This scenario provides an example of processes performed by a Human Resources 
department administrator and Human Resources representatives. Your company 
may follow a different process according to its business requirements.

Administrator
The Human Resources administrator for a financial organization spends a lot of 
time entering information collected on employee transaction forms into the 
company’s databases. Because the administrator designs and administers the forms 
for the HR department, she receives queries from employees uncertain about which 
fields in the forms are relevant to the particular transaction. She also notes that 
some users complete too many fields in the form, and others leave required fields 
uncompleted, which results in the forms being returned to the employees for 
amplification.

To resolve these problems, the HR administrator uses Employee Self-Service to 
implement a process that can handle personnel actions, which include changes in 
the employee’s business title, division, position, manager, location, and so on. In 
this example, the Personnel Action Form (PAF), is available preconfigured in 
Employee Self-Service. The personnel action form is typically used by managers to 
request changes for a person reporting to them, or for a prospective report.

Manager
A manager at the organization wants to promote one of her direct reports. She logs 
in to her Siebel application and navigates to the HelpDesk, which provides a link to 
the Employee Self-Service forms library. She finds the link for the Personnel Action 
Form (PAF) and reviews the screens adding information when necessary. She 
submits the form, which is automatically routed for approval.

Approver
The organization’s approvers—line managers, HR representatives, and functional 
groups—must accept the employee change before it can be implemented.

When the final approval is acquired, the Siebel ERM application sends the updated 
data to the appropriate systems.
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Employee
The promoted employee logs in to the Siebel application. He navigates to his 
employee profile and sees that his title has changed.
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Example Process for Employee Self-Service
Figure 18 on page 217 shows the process an administrator and an end user might 
follow to set up and use Employee Self-Service. Your company may follow a 
different process according to its business requirements.

Administrator Procedures
An administrator can import and customize preconfigured forms and create new 
forms. As Figure 18 shows, the administrator process has two paths. The first path 
illustrates importing and customizing preconfigured Employee Self-Service forms. 
The second path is for creating requestor and summary forms. After importing or 
creating the forms, the administrative process proceeds to testing and releasing the 
forms.

Use Employee Self-Service to perform the following tasks:

■ Import a preconfigured form. For more information, see “Importing a 
Preconfigured Employee Self-Service Form” on page 221.

■ Customize a preconfigured form. For more information, see “Customizing a 
Preconfigured Self-Service Form” on page 223.

■ Create a requestor form. For more information, see “Creating an Employee Self-
Service Requestor Form” on page 224.

■ Create a summary form. For more information, see “Creating an Employee Self-
Service Summary Form” on page 230.

■ Linking self-service forms. For more information, see “Linking Self-Service Forms 
to the Approvals Inbox” on page 233.

■ Release, test, and rerelease forms. For more information, see “Releasing and 
Testing Employee Self-Service Forms” on page 236.

End-User Procedures
The end-user process has a single path for requestors. As Figure 18 shows, the first 
item in the process is for a requestor to choose a form. The process leads to the type 
of changes the requestor wants, after which the submit process is activated. The 
form is then routed to the approver’s Unified Approvals Inbox.
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Use Employee Self-Service to perform the following tasks:

■ Access, complete, and submit forms. For more information, see “Accessing and 
Submitting Self-Service Forms (End User)” on page 237.

Figure 18. Business Process for Employee Self-Service
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Creating Employee Self-Service Forms
You can use the Employee Self-Service feature to create employee self-service 
processes (or forms), or you can use preconfigured forms provided with your Siebel 
application. 

NOTE: Siebel Employee Self-Service uses Siebel SmartScript to create forms. For 
more information on creating and implementing SmartScripts, see Siebel 
SmartScript Administration Guide.

An employee self-service process starts with an electronic document or form that 
includes input fields to collect information from users. Based on the information 
entered, the form logically presents options that can be used to obtain additional 
user information. The automated logic used in employee self-service processes is 
also known as branching logic.
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As illustrated in Figure 19, branching logic is used in employee self-service 
processes. The illustration shows an employee self-service form with two pages. 
The first page has process arrows pointing to four questions. The first question 
leads to three possible answers. The first answer leads to the second page. The 
second answer leads to the fourth question. The third answer leads to the third 
question. Based on a user’s entries in an employee self-service form, there can be 
one of several outcomes.

Figure 19. Example of Branching Logic for Employee Self-Service
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Employee Self-Service allows you to build employee self-service processes that 
include the following attributes:

■ The processes use branching logic that targets specific user needs.

■ The processes are prepopulated with data from Siebel applications and other 
databases.

■ The processes accept input from users, and send relevant changes to the 
underlying databases after approval.

■ The processes can be routed through a graphical workflow editor for further 
processing and approvals.

Employee Self-Service also includes a preconfigured set of self-service forms. These 
forms address common issues such as personnel and personal data changes.

After creating an employee self-service form, you can use the Unified Approvals 
Inbox functionality to create an Approvals process that automatically routes the 
form to specific users for approval. Based on the data entered in the form, updates 
can be made to your Siebel application or another application. For more 
information, see Chapter 12, “Setting Up Unified Approvals Inbox.” 
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Importing a Preconfigured Employee Self-Service Form
Siebel Employee Self-Service is preconfigured with several employee forms. These 
preconfigured forms can be imported to your Siebel application as SmartScripts. 
After they are imported, the forms can be verified and then released so that you can 
use them within your Siebel application.

Table 15 describes the preconfigured forms for Employee Self-Service and the types 
of changes addressed in each form.

To import a preconfigured employee self-service form

1 Export the desired forms (SmartScripts) from the sample database.

a Log in to your Siebel application using the sample database.

b From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

c In the Scripts list, select one of the following forms (SmartScripts) to export 
to your production environment:

❏ Personnel Action Form (PAF)

❏ Personal Data Change

Table 15. Preconfigured Employee Self-Service Forms

Form Comments

Personnel Action 
Form

This form is used for changes to:

■ business title

■ job transfer (Position/Manager/Division Change)

■ location

Personal Data Form This form is used for changes to:

■ name

■ address

■ telephone number

Time Off Form This form is used for vacation and other time-off requests
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❏ Time Off Request

d In the Scripts list, click the menu button, and then choose Export Script.

The Export Script form appears.

e Click the form (SmartScript) name hyperlink, and then save the form 
(SmartScript) to a temporary location so that you can import it into your 
production environment. 

Repeat Step b through Step e for each form (SmartScript) you want to use in 
your production environment, and then log out of your Siebel application.

2 Import the desired form to the production environment.

a Log in to your Siebel application again, using the production database.

b From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

c In the Scripts list, click the menu button, and then choose Import Script.

The Import Script form appears.

d From the In case of error drop-down list, select Update. 

NOTE: When importing preconfigured employee self-service forms, choose 
the Update option. If a script with the same name already exists, the newly 
imported script replaces the old one. 

e In the File Name field, click the select button.

f In the Add Attachment dialog box click Browse, and then select the form 
(SmartScript) you previously saved in Step 1 on page 221.

g When the Add Attachment dialog box appears with the name of the selected 
file, click Add.

h In the Import Script form, click Import File.

i Test and release the script.
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Customizing a Preconfigured Self-Service Form
You can customize the preconfigured employee self-service forms to meet your 
organization’s needs. For example, you can change the sequencing of the pages and 
questions, and you can add, delete, and change questions.

To customize a preconfigured employee self-service form

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, query to find the script you want to change.

3 Select the script, and then click the Designer view tab.

The graphical layout for the preconfigured form appears. 

4 Update the questions and pages as needed, and then test and release the script.

For more information, see “Releasing and Testing Employee Self-Service Forms” 
on page 236.

NOTE: For more information about updating a SmartScript, see Siebel SmartScript 
Administration Guide.
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Creating an Employee Self-Service Requestor Form
The Employee Self-Service Requestor Form is used by a manager or an employee to 
request a change in employment information. The change might be a personnel 
action such as a promotion, or a change to an employee’s marital status. Requestor 
forms are grouped in the Forms Library, which is accessible from the HelpDesk 
home page.

As an administrator, you can use Siebel SmartScripts to define the requestor forms 
used within your application. Before you define a form, verify that the following 
prerequisites are met:

■ You are familiar with Siebel application user interface standards.

■ You are familiar with Siebel SmartScript. For more information on SmartScript, 
see Siebel SmartScript Administration Guide.

■ If you are planning advanced scripting initiatives, you are familiar with Siebel 
Visual Basic or Siebel eScript programming, and have an understanding of your 
company’s Siebel application installation.

■ If the script is run in multiple languages, you have access to translations of script 
elements for each language.

Before you begin

Before you actually create a form, create the questions and pages used in the form. 
For information on creating questions and pages, see Siebel SmartScript 
Administration Guide.

Design on paper the requestor form you want to create. Use the flow diagram 
example shown in Figure 19 on page 219 to determine the pages to include within 
your form (SmartScript), and the questions you want to include in each page.

To create a form for a requestor

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, add a new record and complete the fields.

a In the Name field, enter a name for the script.
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b In the Type drop-down list, select Employee Self-Service. 

NOTE: SmartScripts that are set to the Employee Self-Service type 
automatically appear in the Forms Library. When creating a form in a 
language other than English, choose the type that corresponds to Employee 
Self-Service.

c In the First Page field, click the select button.

d In the Pick Page list, select the first page you created for the form, and then 
click OK.

e Complete the remaining fields as needed.

3 Click the Designer view tab.

The graphical editor appears. 

4 Insert questions and pages as needed from the set that you previously created.

To route the submitted forms to the Unified Approvals Inbox, see “Linking Self-
Service Forms to the Approvals Inbox” on page 233.

NOTE: For tips on using eScript to enhance a requestor form, see “Effective 
Scripting for Employee Self-Service Requestor Forms” on page 226.

5 Release the script, test it, and, if necessary, make changes and re-release the 
script.

For more information, see “Releasing and Testing Employee Self-Service Forms” 
on page 236.
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Effective Scripting for Employee Self-Service Requestor Forms
Using scripting is not required within Employee Self-Service, however, the 
functionality of the Employee Self-Service forms can be enhanced through the use 
of eScript or VBScript. This section provides procedures and tips for using eScript 
within requestor forms. You can also use VBScript.

NOTE: You can use the eScripts within the preconfigured forms as examples. For 
more information on scripting, see Siebel SmartScript Administration Guide.

Making a Field Read-Only. 
You may want to make some fields in a requestor form read-only to provide 
information to requestors, but prevent them from making any changes to the data 
in the field.
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To make a field read-only in a requestor form

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, query to find the Employee Self-Service form (SmartScript) 
you want to modify.

3 Click the Programs view tab.

The scripting area appears.

4 In the Programs list, select Script_Open.

5 In the Program Language drop-down list, select eScript, and then click Save.

In the Scripts form, use the script function SetQuestionEnable(false) to set the 
question to read-only.

For example, the following eScript program converts a question titled Display 
Employee Last Name within a page titled PAF Change. When this question 
displays a value extracted from a database, the value is read-only.

function Script_Open ()

{

var P1 // SmartScriptPage

var P1Q1 // SmartScriptQuestion

P1 = GetPage("PAF Which Change");

P1Q1 = P1.GetQuestion("Display Employee Last Name");

P1Q1.SetQuestionEnable(false); 

}

6 Verify that each read-only field has a SetQuestionEnable(false) statement 
attached to it. 

7 Click the Check Syntax button to highlight any syntax problems.

8 In the Programs list, click Save.
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Preventing Duplicate Record Creation
When the form is submitted, field values mapped to a business component field are 
automatically written to the actual fields by SmartScript. To prevent your Siebel 
application from writing to the business component field and creating duplicate 
records, include the Cancel() function within the script_finish program. 

To prevent duplicate record creation

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, query to find the script you want to modify.

3 Click the Programs view tab.

The scripting area appears.

4 In the Programs list, select Script_Finish.

5 In the Program Language drop-down list, select eScript, and then click Save.

6 In the Script field, include the Cancel() function.

For example, the following statement runs the entire SmartScript, but no updates 
are saved to the database, even after the user chooses Submit.

function Script_Finish ()

{

// Cancel saving everything to the database   

   Cancel ();

}

7 To make sure that users’ data entries are always saved, whether the form is 
complete or incomplete, in the Save Session field select Always. 

Choose Finished to save users’ data entries only when the form is completed.

NOTE: Selecting Finished or Always from the Save Session field forces your Siebel 
application to write the values to the SmartScript session tables. 
228 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Setting Up Employee Self-Service

Creating an Employee Self-Service Requestor Form
8 Click the Check Syntax button to highlight any syntax issues.

9 In the Programs list, click Save.

Populating a Field in a Form
You can use eScript to automatically populate a form.

To populate a field in a form

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, query to find the script you want to modify.

3 Click the Programs view tab.

The scripting area appears.

4 In the Programs list, select Script_Open.

5 Use the eScript function SetCurrentValue for each field you want to populate.

6 Click the Check Syntax button to locate any syntax issues.

7 In the Programs list, click Save.
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Creating an Employee Self-Service Summary Form
A summary form is used to provide a read-only, summary version of a completed 
form to an approver. The approver can review the information in a summary form, 
and then decide whether to approve or deny the request. As an administrator, you 
can use the Employee Self-Service module to create a summary form.

Before you create a form, map out the summary form you want to create. Use the 
flow diagram example shown in Figure 19 on page 219 to help decide the pages to 
include in your form, and the questions you want within each page. The questions 
within a summary form are only used to display data to the user. Use the requestor 
form that you previously created to help you determine which questions you want 
to use in the summary form. Typically, a summary form shows the approver only a 
subset of the most relevant responses from the requestor form.

Before you begin

Determine the questions and the pages used in the summary form. For more 
information on creating SmartScript questions and pages, see Siebel SmartScript 
Administration Guide.

If you plan to copy a question from the requestor form, add the word Summary to 
the title, as you cannot use the same names for both the requestor form question 
and the summary form question. This naming convention rule also applies to 
naming pages and the SmartScript itself.

To create a summary form for an approver

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 Create a new Script.

a In the Scripts list, add a new record, and enter a name in the name field.

The name should identify the form as a summary form. Do not use the same 
name as the requestor form. 
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b Leave the Type field empty.

Do not set the Type field to Employee Self-Service because the summary form 
would then become visible to requestors. Two forms with similar names can 
confuse the requestors.

c Complete the remaining fields as needed. 

3 When the script record is created, click the Programs view tab, and add a new 
program record.

4 In the Name field, choose Script_Open from the drop-down list.

5 In the Program Language field, choose eScript from the drop-down list.

6 Use eScript (or VBScript) to set up the summary form.

7 After you finish scripting, release the script, test it, and then make necessary 
changes and re-release the script.

Importing Field Values to a Summary Form
After the summary form is filled in and submitted by the user, the questions and 
answers are saved in SmartScript session table. For a summary form, the 
Script_Open script is used to read the values and assign them to the questions.

To import field values from requestor to summary form (without page breaks)

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, query to find the script you want to modify.

3 Click the Programs view tab, and in the Programs list, select Script_Open.
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4 In the Program Language drop-down list, select eScript.

NOTE: If you access a business component within your summary form, any 
operation to that business component creates a page break within the summary 
form. To avoid the page break, get the handle to the business component in the 
eScript. Perform any desired operations on it within the eScript. See the 
comment, Get the handles to the page and the questions, in the “Example 
eScript for Summary Form” on page 307.

5 To set a question to read-only, use the eScript function SetQuestionEnable(false) 
at Script_Open. 

For more information, see “To make a field read-only in a requestor form” on 
page 227.

6 In the Script form, use the GetParameter function to get the script session ID. 

For more information on using GetParameter, see “Example eScript for Summary 
Form” on page 307.

7 Query for the Call Scripts business object with Call Script Run Answers business 
component. 

For more information on ways to get the Call Scripts business object, see 
“Example eScript for Summary Form” on page 307.

8 In the Programs list, click Save.
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Linking Self-Service Forms to the Approvals Inbox
To route an employee self-service form to the Unified Approvals Inbox, the form and 
the inbox must be linked. Figure 20 shows the business process used when linking 
the form and inbox.

As an administrator, you can create an approval type to link a form to the inbox. 
After the approval type is configured, you can reference the approval type name 
within the employee self-service requestor form. For information about creating an 
approval type, see Chapter 12, “Setting Up Unified Approvals Inbox.” 

Figure 20. Linking Employee Self-Service Form to Unified Approvals Inbox
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Use the following procedure to link an employee self-service form to an existing 
approval type. 

NOTE: This procedure is required only for new Employee Self-Service forms, not for 
preconfigured forms. For more information on creating an Employee Self-Service 
form, see “Creating an Employee Self-Service Requestor Form” on page 224.

To link employee self-service forms to the Unified Approvals Inbox

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, query to find the Employee Self-Service form (SmartScript) 
you want to link to the Unified Approvals Inbox.

3 Click the Programs view tab, and in the Programs list, add a new record and 
complete the fields.

a In Name field, select Script_Finish from the drop-down list.

b In the Program Language field, select eScript from the drop-down list, and 
then click Save.

4 In the Scripts form, enter the script as shown in “Example eScript for Requestor 
Form” on page 305.

NOTE: The Scripts form appears at the bottom of the screen. You may need to 
scroll down to see the complete form.
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5 In the Script field, change the indata.SetProperty (“ItemType”, ““) parameters as 
needed. 

The second parameter of the function should equal the name of the appropriate 
approval type. For example:

// Approvals Inbox Administration screen

indata.SetProperty ("ItemType", "PAFChange");

NOTE: For more information on approval types, see Chapter 12, “Setting Up 
Unified Approvals Inbox.”

6 Click the Check Syntax button to highlight any syntax issues.

7 In the Programs list, click Save.
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Releasing and Testing Employee Self-Service Forms
After you finish scripting the employee self-service form, you must first release the 
script, test it to make sure that it works as anticipated, and release the script again 
if you have made changes.

To release a script

1 From the application-level menu, choose View > Site Map > SmartScript 
Administration > Scripts.

2 In the Scripts list, select the script, click the menu button, and then choose 
Release.

3 Test the form to make sure that it works as desired.

For more information, see “Accessing and Submitting Self-Service Forms (End 
User)” on page 237. 

NOTE: Examine the logic in the forms to determine whether any customizing is 
required. For more information on making changes to preconfigured forms, see 
“Customizing a Preconfigured Self-Service Form” on page 223.

4 After you have tested the form, make any necessary changes to the form, and 
then release it again.
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Accessing and Submitting Self-Service Forms (End User)
End users can access forms in the Self-Service area of the Help Desk home page, or 
from the Employee Self-Service tab on the site map. After a user selects the 
appropriate form, the form can be completed and submitted for approval. 

NOTE: As an administrator, you can use this procedure to test the forms before final 
release.

Accessing Self-Service Forms
End users can access self-service forms using the Help Desk home page.

To access an employee self-service form

1 Navigate to the HelpDesk home page.

2 From the Show drop-down list, select Forms Library.

3 In the Available Forms list, drill down on the hyperlink in the name field for the 
form you want to access.

4 In the form, complete the necessary fields, and then click Submit.

Required questions are flagged with an asterisk (*).

NOTE: Both incomplete and complete forms can be saved and submitted at a 
later time. To save the form and the information you have entered, click Submit 
Later. You can access a saved form from the My Saved Forms view.

If the form is linked to the Unified Approvals Inbox, the form is sent on to the 
first approver.

Accessing a Saved Self-Service Form
Use the following procedure to access a saved employee self-service form.

To access a saved form

1 Navigate to the HelpDesk home page.
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2 In the Self Service list, click Forms Library.

3 From the Show drop-down list, select My Saved Forms.

4 In the Saved Forms list, select the form you want to access.

5 Click Resume to continue filling out the form.

Accessing a Submitted Self-Service Form
Use the following procedure to access a submitted employee self-service form.

To access a submitted form

1 Navigate to your myPage screen.

2 From the Show drop-down list, select My Submitted Items.

3 In the list, select the submitted item.

You can check the status and approval history for items from this view. You can 
also access a summary of the form you completed. 

To see the entire form, including your answers to questions, navigate to the My 
Finished Forms view within the Forms Library.
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The Unified Approvals Inbox feature allows managers and employees with review 
responsibilities to view and act on approval requests from a single unified screen. 
Approvals Inbox also allows administrators to create and manage approval flows. 
This section describes the Unified Approvals Inbox and explains setting up and 
managing approval flows for forms generated within the Employee Self-Service 
application.

Unified Approvals Inbox Overview
The Approval Inbox provides a unified view of the approval items requiring 
manager response. As an administrator, you use preconfigured workflows and 
scripts to set up different approval items that are generated within the Employee 
Self-Service application.

Using the Siebel Unified Approvals Inbox, you can specify business process 
(workflow) logic to define where Employee Self-Service items need to be routed for 
approval. The graphical workflow editor allows you to define multiple stages of 
approvals required for an item. The approval process can be designed to branch to 
the next step based on preset decision criteria. After final approval is received, 
updated data can be sent to the underlying Siebel database and external databases 
through the appropriate connectors.

An administrative screen allows you to specify approval item types and the 
associated workflow processes. When the specified type of object appears in the 
Siebel Unified Approvals Inbox, it is routed automatically according to the workflow 
process you defined. 

Forms from the Employee Self-Service application can be shown as approval items 
in a user’s Approvals Inbox.
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Business Scenario for Approvals Inbox
This scenario provides an example of processes performed by an administrator and 
an end user. Your company may follow a different process according to its business 
requirements.

Administrator
The Human Resources manager at a company has outlined new time off policies for 
employees. Management has mandated that personnel change requests be filed 
electronically. An HR representative for the employee’s department must first check 
and approve the request, followed by an approval from the employee’s immediate 
supervisor, and the departmental vice president. This new policy is handed off to a 
Siebel administrator for implementation.

After using the Employee Self-Service feature to set up and activate the 
preintegrated Personnel Action Form (PAF), the administrator designs the approval 
flows for the business object. Using the Approvals Inbox, the administrator creates 
the required approval type, and approval flow. When a user requests an approval 
for this particular item, the approval type created by the administrator invokes the 
approval workflow process.

End User
An employee at the company submits a Request for Time Off form. The form is 
routed to the human resources representative, then the manager, and finally the vice 
president of marketing. Each approver can reject the form and send it back to the 
requestor. If approved, the process flow results in an update of data fields.
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Example Process for Approvals Inbox
The following section describes the processes an administrator and an end user 
might follow to set up the Unified Approvals Inbox. Your company may follow a 
different process according to its business requirements.

Administrator Procedures
The Siebel administrator requires administrative responsibilities to:

1 Create requestor and summary forms. The administrator creates the Requestor and 
Summary Self-Service forms as described in Chapter 11, “Setting Up Employee 
Self-Service.” 

2 Create the approval business process. For more information, see “Creating an 
Approval Business Process (Workflow)” on page 242.

3 Create the Approval Type. For more information, see “Creating an Approval Type” 
on page 243.

4 Reference the Approval Type. For more information, see “Referencing an Approval 
Type in a Requestor Form” on page 245.

End-User Procedures
The end user, an employee, manager or approver, uses Employee Directory to:

1 Review Submitted Items. The end user reviews submitted items, For more 
information, see “Reviewing Submitted Items (End-User)” on page 247.

2 Take Action on submitted items. The approver approves or rejects the submitted 
items. For more information, see “Approving and Rejecting Submitted Items 
(End User)” on page 248.

3 Review approved items. The employee or manager reviews approved items. For 
more information, see “Reviewing Approved Items (End User)” on page 249.
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Creating an Approval Business Process (Workflow)
The approval business process defines the exact sequence that an approval item 
must follow. Administrators can define business services, sub-processes, and 
decision steps within the business process, to build detailed approval flows. For 
more details on building business processes (workflows), see Siebel Business 
Process Designer Administration Guide.

To create an approval business process (workflow)

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 Create a new workflow record, design the workflow, and then save the record.

3 Activate the workflow.
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Creating an Approval Type
The approval type is the link between Employee Self-Service Forms (and other items 
requiring approval) and the Unified Approvals Inbox. The approval type record can 
be associated with different approval items. This allows a single business process 
to be shared among many different approval items.

Before creating the approval type to be used with a approval business object, the 
appropriate business object must be created and defined. Siebel ERM is 
preconfigured with several business objects that your organization can use. For 
more information on using a preconfigured form, see Chapter 11, “Setting Up 
Employee Self-Service.” You can also create a new business object to use with Siebel 
Unified Approvals Inbox. For more information on creating a business object, see 
Siebel SmartScript Administration Guide.

NOTE: This approval type name must be referenced within the Script_Finish of the 
Employee Self-Service Requestor Form to link the form with the Unified Approvals 
Inbox.

To create an approval type

1 From the application-level menu, choose View > Site Map > Approvals Inbox 
Administration > Approval Types.

2 In the Approval Types list, add a new record and complete the fields.

The following table describes the fields in the approval type record.

Field Comments

Business Object Select a business object for this approval type (optional).

Business Process Specify the approval business process to use. Use the 
approval business process you created.

Comments Enter a brief description to describe the approval type.

Default Queue Duration Enter a default queue duration for this approval type 
(optional).

Form Name Specify the Employee Self-Service Summary Form here.
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Integration Object Select an integration object for this approval type (optional).

Name Enter a descriptive name for the approval type.

This name must be referenced within the Script_Finish of 
the Employee Self-Service Requestor Form.

Status Type Select a status type for this approval type (optional).

View For employee self-service forms, use EmpSS Form Player 
View.

Field Comments
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Referencing an Approval Type in a Requestor Form
After the approval type is configured and the employee self-service form is created, 
you can reference the approval type name within the employee self-service 
requestor form. For information about referencing an approval type within the 
employee self-service requestor form, see “Linking Self-Service Forms to the 
Approvals Inbox” in Chapter 11, “Setting Up Employee Self-Service.”
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Linking the Approvals Inbox to a Non-ESS Process
The Unified Approvals Inbox can also be linked to items other than Employee Self 
Service processes using the Universal Inbox business service.

There are three ways to link to this business service: 

1 Runtime events (at the Object Manager level)

2 Workflow monitor

3 Business component-level server script

The business service has two Universal Inbox methods, Initialize (<IN> 
Argument, <OUT> Argument), and Route to Approver. The route to approver 
method is typically used when the approver is known, as it reduces the need for an 
additional workflow.
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Reviewing Submitted Items (End-User)
Use the following procedures to review submitted forms, and items that previously 
were approved or rejected.

To review a submitted form

1 Navigate to the myPage screen, and from the Show drop-down list, select My 
Submitted Items.

Choose My Team’s Submitted Items from the Show drop-down list, if you are 
reviewing items for your team.

2 In the Submitted Items list, click the Name hyperlink of the form you want to 
review. 

The selected summary form appears.

Requestors and managers can trace previous approvers of an item using the History 
view tab. The History view provides:

■ Information on the previous approvers

■ The date on which the approvers approved the item

■ Comments approvers have inserted

Administrators also have access to All Submitted Items, which includes items in the 
organization submitted for approval.
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Approving and Rejecting Submitted Items (End User)
Managers can approve or reject items that are sent to them for approval.

To approve or reject an employee self-service form

1 Navigate to the myPage screen.

2 From the Show drop-down list, select My Approval Items or My Team’s Approval 
Items.

3 In the Approval Items list, select the item you want to approve or reject.

NOTE: You can click the Name hyperlink to review the summary form.

4 In the Status field, select Approved or Rejected.

5 (Optional) In the Comments field, enter a brief explanation.

The record is routed appropriately based on your action.
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Reviewing Approved Items (End User)
The History view lets managers track the progress of the items through each stage 
of the approval process. Managers can review the approval decision and comments 
made by each approver. Administrators also have access to All Approved Items, 
which includes items in the organization that have been approved.

To review items that have been previously approved

1 Navigate to the myPage screen.

2 From the Show drop-down list, select My Approved Items or My Team’s 
Approved Items.

3 In the Approved Items List, select the item you want to review.

NOTE: Click the Name hyperlink to review the summary form. You cannot 
change the approval decision at this point.
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Siebel Projects is a Siebel module that provides a shared company workspace that 
employees within an organization can use to organize, coordinate and manage 
formal and ad-hoc project assignments with other employees, regardless of physical 
location. Employees, managers, and executives can collaborate to create, staff, 
manage, calibrate, and achieve overall company objectives. 

This chapter describes setting up and managing the features in the Siebel Projects 
module.
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Managing Projects Collaborations
Siebel Projects centralizes key project information including membership, project 
schedules and milestones, activity assignments and delivery dates, project 
commentary and notes, and the most current project presentations, business 
models, competitive reports, emails, and marketing collateral. 

Siebel Projects includes the following features:

■ Shared workspace and file storage

■ Project summary pages

■ Project KPIs

■ Threaded discussions

■ Shared project calendar

■ Project member availability scheduling

■ Attribute-based project staffing

■ Access control

■ Syndicated news content

■ Time and expense report integration

■ Virtual meeting and instant messaging integration

■ Activity delegation and alerts

■ Project activity charts

■ Ad-hoc performance reviews
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Business Scenario for Siebel Projects
This scenario provides an example of processes performed by an administrator, 
manager, and end user. Your company may follow a different process according to 
its business requirements.

Projects Administrator
A projects administrator for a software company is asked to help plan and 
implement his organization’s new corporate marketing program. The global 
campaign requires the development of numerous cross-functional projects. The 
administrator designs an activity template that can be used by other Siebel Projects 
users to create individual activity plans that incorporate the activities necessary to 
manage the marketing campaign rollout. He assigns the template to Projects, 
allowing access to anyone using the Siebel Projects application. The administrator 
then creates a series of corresponding activities with suggested start and end dates 
and descriptive information. The administrator then sets up virtual collaboration 
and the Project Home and Project Summary pages.

The administrator launches the campaign by giving an overview presentation to the 
designated global project leads, using the virtual collaboration application within 
Siebel Projects. The administrator explains how each project moderator can create 
a cross-functional project plan to execute and manage the rollout for each 
geographic region. The administrator demonstrates that after a project is created 
and staffed, the project lead can develop an plan to complete the project objectives 
by selecting the marketing rollout activity template from the Projects screen’s 
Activity Plan view. Once selected, the activity template automatically displays the 
associated activities and completion timeframes for the campaign. Each project 
moderator can then assign activities to the appropriate project members.

Project Moderator
A project moderator at a financial organization is asked to coordinate a cross-
functional project to develop a series of APIs that will allow the organization’s 
software to better integrate with third-party products. The moderator requires 
assistance from several other groups in the organization such as Development, 
Product Marketing, and Global Services as well as from external contacts.
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The moderator begins by browsing existing projects in the All Projects view. He 
selects the General Engineering project and then a sub-project called Future Product 
Requirements. The moderator creates a new project, enters the key project details 
and sets the project’s delivery status and access type to convey the health of the 
project and visibility rights. Finally, the moderator adds a graphic to the Project 
Summary page to personalize the project.

After the project is created, the moderator staffs the project using employees with 
the appropriate skills. The manager then accesses the Activity Plans tab and selects 
an activity plan template that automatically creates a series of activities and tasks 
for the project. He enters a few additional activities, and then assigns the activities 
to the project members so they can begin working the project.

Project Member
A product marketer has been added to a project to develop a series of APIs for her 
organization’s software project. This project is a cross-functional, global project and 
includes employees located in several different countries and time zones. The 
marketer uses Siebel Projects to pose questions, obtain answers, and share 
information and best practices with the projects team members. 

The product marketer accesses the Project Summary page of this project and 
reviews key project information such as project description and objectives, key 
project indicators, project news, related projects, new project notes, and activities 
that help her to understand the project and her individual responsibilities.
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Example Process Flow for Siebel Projects
The following section describes the process administrator and manager might 
follow to set up Siebel Projects. Your company may follow a different process 
according to its business requirements.

Administrator Setup Process
The Siebel administrator requires administrative responsibilities to:

1 Set up project activity plans and activities. The administrator creates project 
activity plan templates with associated activities to maintain project consistency 
across the entire organization. For more information on setting up activity plans, 
and assigning the activities to projects, see and Applications Administration 
Guide.

2 Set up virtual collaboration. The administrator sets up virtual collaboration within 
Siebel ERM to allow coworkers to communicate in real time over the Web. For 
more information, see “Virtual Collaboration and the Project Center” on 
page 258.

3 Set up Project page layouts. Administrators use the Microsite Management feature 
to configure and manage the layouts for the ERM Project Home and ERM Project 
Summary pages. For more information, see “Project Summary and Project 
Center Pages” on page 260, and Applications Administration Guide.

End-User Process
The end user, a project moderator or member, with appropriate responsibilities, 
uses Employee Directory to:

1 Create a new project. For more information, see “Browsing Projects Using 
Explorer (End User)” on page 261 and “Creating Projects (End User)” on 
page 262.

2 Add team members. For more information, see “Adding Project Team Members 
(End User)” on page 263.

3 Adds information and activities. For more information, see “Creating a Project 
Activity Plan (End User)” on page 264 and “Adding a Description to the Project 
Summary (End User)” on page 265.
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4 Update project progress. For more information, see “Updating and Tracking 
Project Information (End User)” on page 266.

5 Add a graphic to the project summary page. For more information, see “Adding 
Graphics to Project Summary Pages (End User)” on page 267.

6 Adding News Content to the Summary Page. The project member adds content to 
the Project Summary page. For more information, see “Adding News Content to 
a Project (End User)” on page 268.
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Creating Project Activity Templates and Activities
You can create activity templates that provide the framework that is used to 
complete multistep tasks for your projects using the Application Administration 
screen’s Activity Templates and Activity Template Details views. Typically, the 
administrator sets up the activity templates, and the end users apply the predefined 
templates to create their activity plans. 

For more information on activity templates, associated activities, and activity 
assignment, see Applications Administration Guide.

To create an activity template for projects

1 From the application-level menu, choose View > Site Map > Application 
Administration > Activity Templates.

2 In the Activity Templates list, add a new record.

3 In the Types field, select Project from the drop-down list.

The Types field specifies where you want the template to be available.

4 Complete the rest of the fields.

To create activities for the project activity template

1 In the Activity Template list, select the project activity template, and click the 
Activity Template Details view tab.

2 In the Activity Template details form, click New.

3 In the Type field, choose an activity type.

For example, for a project-related activity type, you might choose Project - 
Design, Project - Deployment, or Project - Management.

4 Complete the remaining fields.

For more information about activity templates and field descriptions, see 
Applications Administration Guide.
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 257



Setting Up Siebel Projects

Virtual Collaboration and the Project Center
Virtual Collaboration and the Project Center
Integrating synchronous, real-time collaboration applications into the Project Center 
page allows project users to collaborate with each another in real time over the 
Internet or your organization’s intranet. Integrated applications can include third-
party applications or another Siebel application such as Distance Learning.

The Project Center page incorporates a collaboration section which includes a set 
of predefined virtual collaboration views. When these views are set up, the user is 
automatically logged into the virtual collaboration application.

During virtual collaboration setup, portal agents retrieve data by sending HTTP 
requests to external applications. The HTML results appear in the Siebel application 
or in a Siebel Web page. 

Portal agents are administered using the Integration Administration screen and 
associated views. These views allow you to define the external host, the ways that 
links should be handled, and to specify the HTTP request that is sent to the external 
host. 

For more information on setting up portal agents, see Siebel Portal Framework 
Guide.

Process Guidelines for Setting Up Virtual Collaboration
Use the following process guideline to set up virtual collaboration in Siebel ERM:

■ Define content fixup. Links that appear in third-party Web applications may be 
inappropriately configured for display in another application, such as your 
Siebel application. For example, the links in an instant-messaging application 
may be defined as relative links. If you include these links in the Project Center 
page the links do not work. The Fixup Administration view allows you to define 
how links embedded within external HTML content should be rendered in the 
Siebel user interface. Your Siebel application is preconfigured with several fixup 
types, however, you can define a new one for your needs.
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■ Define the external host. You define the external data hosts in the Host 
Administration view. Defining the external host allows you to also create 
symbolic URLs to reference the external host, such as SSO Server, rather than 
typing in the specific host information. This is useful because you can have 
multiple symbolic URLs that reference the same external data host. If the 
external host information changes, you only need to change the server location 
in the Host Administration view rather than edit each symbolic URL. This view 
allows you to:

■ maintain external host names in a single place

■ specify NCSA Basic authentication credentials

■ define how links should be handled (fixed-up) after external HTML content 
is rendered

■ Define Web applications. Web applications allow multiple Symbolic URLs to send 
requests to the same Web application and share the same session. This is useful 
if you have two different applet controls that use Symbolic URLs to submit 
requests to the same Web application. You can associate these Symbolic URLs 
to a single Web application and define whether or not sharing occurs during the 
same session.

■ Define Symbolic URLs. You use the Symbolic URL Administration view to specify 
how the HTTP request to the external application is constructed and to define 
any arguments and values to be sent as part of the request.

■ Define Symbolic URL Arguments. Symbolic URL Arguments allow you to configure 
portal agents in several ways. You use symbolic URL arguments to define data 
that is sent to an external host and to submit commands to SWE that affect the 
behavior of portal agents.
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Project Summary and Project Center Pages
The Siebel Projects module includes two preconfigured project pages, Project Home 
and Project Summary, that include information relevant to employees’ projects. 
Administrators use the Microsite Management feature to configure and manage the 
layouts for these pages, adding links to other Siebel applications, other Siebel portal 
pages, or important messages. For more information on managing the content and 
layout for the Siebel project pages, see Applications Administration Guide.

Project Home Page
The Siebel Project home page (the Project Center page) provides employees, 
managers, and executives with an overview of their projects, highlighting key 
project information such as delivery status, and new activities that have been 
assigned to them across all their projects. The Siebel Projects home page also acts 
as a platform for integrating real-time collaboration technologies, such as online 
meetings and presentation capabilities from Siebel Distance Learning or instant 
messaging and conferencing services.

When your organization subscribes to Siebel eContent Services, you can access 
Siebel application-hosted data to personalize the delivery of external news content 
to the Siebel project pages. Siebel application-hosted data consists of company 
profiles, corporation relationship information, premium external news feeds, and 
productivity content from content producers and providers. For more information 
on setting up external news content, see Chapter 9, “Setting Up eContent Services.”

Project Summary Page
The Siebel Project summary page provides employees with a summary view of 
events occurring within a particular project. The project summary page provides 
specific performance indicators, as well as a forum for conveying project objectives, 
highlighting required actions, delivering information, and providing relevant third-
party news.
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Browsing Projects Using Explorer (End User)
The Projects Explorer provides a hierarchical view that allows the user to browse 
the organizational structure of existing projects in the left view of the screen, and 
see details for the selected project in the view at the right side of the screen.

To browse projects using Project Explorer

1 Navigate to the Projects screen, and from the Show drop-down list, choose 
Explorer.

2 In the Explorer list, drill down on the Project hierarchy to view existing projects.
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Creating Projects (End User)
Use the following procedure to create a new project. Only administrators and users 
with appropriate responsibilities can modify and delete projects.

To create a new project

1 Navigate to the Projects screen.

2 In the Projects list, add a new record and complete the necessary fields.

Some fields, such as Project # and Created Date are automatically completed. 
Other fields such as Status and Access contain default values.

■ In the Access Type field, select Public or Public Read-Only to make the project 
visible to project team members.

■ In the Status field, choose Active to launch the project.

■ In the Delivery field, choose an indicator for the project progress.

To delete a project

1 From the application-level menu, choose View > Site Map > Data 
Administration > Projects.

2 In the Projects list, select the project you want to delete.

3 Click the menu button, then choose Delete Record.

4 Click OK to confirm the deletion.
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Adding Project Team Members (End User)
Use the Members view to add team members to the project. The default and primary 
member of the team is the project creator. Only administrators and users with the 
appropriate responsibilities can modify or delete project teams.

To add project members

1 Navigate to the Projects screen, and in the Projects list, select the project.

2 Click the Members view tab, and in the Members list, click New.

3 From the Add Employees dialog box, select team members, and then click OK.

4 In the members list, select the primary member of the team, and then click the 
check box in the Primary field.

You must step off the record to save the change from the default primary 
member to the new primary member.
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Creating a Project Activity Plan (End User)
When you select an activity plan template using the Activity Plans view, the 
template’s corresponding activities automatically appear in the Activities view.

To create an activity plan with activities

1 Navigate to the Projects screen.

2 In the Projects list, select the project, and then click the Activity Plans view tab.

3 In the Activity Plans list, create a new record.

The Planned Start field is automatically populated with a default date and time. 
Change these values if desired.

4 In the Template field, select the activity template.

To appear in the template list, the activity template type must be set to project. 
For more information, see “Creating Project Activity Templates and Activities” 
on page 257.

5 In the Activity Plans list, click Save, and then click the Activities view tab to 
review activities associated with the activity plan template.
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Adding a Description to the Project Summary (End User)
Employees with the appropriate responsibilities can add a project description to the 
Project Summary page. The project description appears in the following locations:

■ Project Home Page. The first 100 characters used in the project description appear 
under the project’s link on Project Home page. Any additional text formatting 
that is applied to your text appears.

■ Project Summary Page. The full project description appears on the Project 
Summary page.

■ Related Projects Section. When it is associated with another project, the first 50 
characters used in the description appear in the Related Projects section on the 
Project Summary page.

■ Project Description Field. The full project description appears in the Project form 
in the View Detail.

To add a project description

1 Navigate to the Project Summary page of the project to which you want to add 
a description.

2 Click the View Details button.

3 In the Project form, click the show more button to expand the form.

4 Click in the Description field.

NOTE: When you click in the Description field, the integrated HTML editor 
toolbar appears at the bottom of the field. The toolbar provides special editing 
controls, which allow you to use supported HTML formatting, and also provide 
some standard editing features such as cut and paste. For more information 
about using the HTML editor, see Fundamentals.

5 When finished, click the View Summary button.

The description appear in the Project Summary page.
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Updating and Tracking Project Information (End User)
Use the Project Summary and Project Center pages, and other views such as Notes, 
and Tasks to review progress, and update project status, information and initiatives.

To add or view project information

1 Navigate to the Projects screen, and in the Projects list, select the project.

2 Perform any of the following action:

■ Click the appropriate view tab to add or view information about the project. 

■ Click View Summary to display the Project Summary view, and then click 
View Details to add information.

■ Click the Projects global link to open the Project Center, then click on the 
hyperlinks in the Project Center layout to navigate to relevant views.
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Adding Graphics to Project Summary Pages (End User)
Administrators and end users with the appropriate responsibilities can add a 
graphic image to the Project Summary page. 

To add a project graphic

1 Navigate to the Projects screen, and in the Projects list, select the project.

2 In the Project form, click the select button in the Project Summary Graphic field.

3 In the Image Attachments dialog box, click New.

4 In the Attachment Name field, click the select button, navigate to the image, and 
then click Add.

The image name appears in the Attachment Name field. You can edit the image 
name to give it a descriptive label.

5 Click Save.

The image name appears as a record in the Image Attachments dialog box.

6 In the Primary field, select the check box, and then click OK.

7 In the Project form, click the View Summary button to review the image on the 
Project Summary page.
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Adding News Content to a Project (End User)
Siebel ERM applications are already integrated with Siebel eContent Services, an 
online news and information subscription service that accesses information from 
several industry news services. When your organization subscribes to Siebel 
eContent Services, you can personalize the delivery of external news content to 
specific sections within your project pages. 

Creating a News Topic
You can use eContent Services to create news topics, which are records that specify 
the search criteria used to find current news on topics relevant to your project. For 
more information about creating a news topic, see Chapter 9, “Setting Up eContent 
Services.” 

Adding a News Topic
After the appropriate news topics are created, you can add the news topics to your 
project. Siebel Projects application uses the news topics you add to the project to 
retrieve relevant news stories and include the links in the Project News section on 
your Project Summary page.

To add a news topic to a project

1 Navigate to the Project Summary page of the project to which you want to add 
a news topic.

2 If the Project News section does not appears in your Project Summary page, add 
it to the Project Summary layout.

a Click the Edit Layout button.

b In the Project Summary Layout view, click the show button in the Project 
News section.

c Click Done.

The Project Summary page appears with the Project News section.

3 In the Project Summary page, click View Details.

The Project form appears.
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4 In the Project form, click the select button in the Project News field.

5 In the Related News Topics dialog box, click New to add a news topic.

NOTE: You can also remove exiting topics from your Project Summary page by 
selecting the topic, and clicking Delete.

6 In the Add News Topics dialog box, query to find the news topic you want to 
add, and then click Add.

7 Click OK to add the news topic to the Related News Topics dialog box.

8 When finished, click the View Summary button.

The selected news topics appear in the Project News section.
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Administrators are responsible for creating types of expenses and activities available 
to users for creating expense reports and time sheets, creating global mappings 
between activities and expense report categories, and setting up expense report time 
periods. This chapter describes basic setup procedures for using expenses and 
timesheets with Siebel ERM.

An administrator is also responsible for creating state models, which are used for 
determining the appropriate status for an expense report and time sheet. For more 
information on expense reports and time sheets, see Siebel Professional Services 
Automation User Guide. For more information on state models in general, see Siebel 
Business Process Designer Administration Guide.
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Creating Expense Types and Establishments
Your Siebel application comes with default expense types and associated 
establishments. These types and establishments appear in picklists in the expense 
report views.

For instance, you will see an expense type called Airfare and associated 
establishments such as Air Canada and British Airways. You can add new expense 
types and new establishments to suit your company’s expense report needs.

In the List of Values Explorer, EXP_ITEM_ESTAB is a child of EXP_ITEM_TYPE.

To create a new expense type

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values.

2 In the List of Values list, click the menu button and choose New Query.

3 In the Type field, select EXP_ITEM_TYPE from the drop-down list. Click the 
menu button, and then click Run Query.

All existing expense types appear.

4 In the List of Values list, add a record.

5 In the List of Values form, select EXP_ITEM_TYPE in the Type field.

6 In the Display Value and Language Independent Code field, enter the name of 
the new expense type.

7 In the Translate field, click the check box.

8 In the Language Name field, select the appropriate language from the Language 
Name dialog box, and then click OK.

9 Verify that the Active field is checked.

NOTE: For more information on using the list of values for a global deployment, 
see Global Deployment Guide.
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To create a new establishment

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values.

2 In the List of Values list, click the menu button, and then choose New Query.

3 In the Type field, select EXP_ITEM_ESTAB from the drop-down list, and then run 
the query.

Existing expense types appear.

4 In the List of Values list, add a record.

5 In the List of Values form, choose EXP_ITEM_ESTAB in the Type field.

6 In the Display Value and Language Independent Code field, enter the name of 
the new expense type.

7 In the Translate field, select the check box.

8 In the Language Name field, click the select button, choose the language from 
the Language Name dialog box, and then click OK.

NOTE: Establishments must have an parent of the type EXP_ITEM_TYPE.

9 Choose the appropriate Parent Language Independent Code.

NOTE: For more information on using the list of values for a global deployment, 
see Global Deployment Guide.

To add establishments to the List of Values Explorer view

1 From the application-level menu, choose View > Site Map > Application 
Administration > LOV Explorer.

2 In the List of Values-Type list, click Query.

3 In the List of Values-Type form, enter EXP_ITEM_TYPE in the Type field and 
click Go.

Existing expense types appear, both in the list and the explorer.
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4 In the Explorer view, click the plus sign (+) to expand the expense type you 
want. 

5 Drill down on the Expense Item Type.

6 Click the plus sign (+) next to the Child List of Values folder.

All establishments for that expense type are listed.

7 In the Child List of Values list, add a new record.

8 In the Child List of Values form, select EXP_ITEM_ESTAB in the Type field.

9 In the Name field, click the select button, and choose the establishment to add.

For more information on configuring the list of values, see Siebel Tools Reference. 

NOTE: To use the new expense type created on the list of values, you must map it 
to a report. For more information about mapping expense types to reports, please 
see “Mapping Expense Types for Reports” on page 275.
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Mapping Expense Types for Reports
As an administrator, you modify expense types using the Application 
Administration screen, Expense Types view. Expense types show the ways that the 
expenses are rolled up in the expense report. For example, Airfare rolls up to the 
Air/Rail column in the Expense Report. It then rolls up to the Travel category in the 
Expense Summary Report.

You also determine the Expense Report and the Summary category to be associated 
with the Expense Type. You can modify the way expenses are rolled up and which 
expenses are rolled up into which categories.

NOTE: To make further changes or additions to expense reports, including modifying 
the layout, you must use Actuate and Siebel Tools. 

To specify expense type reports and summary categories

1 From the application-level menu, choose View > Site Map > Application 
Administration > Expense Types.

2 In the Expense Type list, click the menu button, and then choose New Record.

3 In the Expense Types form, select an Expense Type from the Expense Type drop-
down list. 

4 In the Report Category field, select a Report Category from the drop-down list.

This determines the Expense Report category this type rolls up to. 

NOTE: The report categories are created in the List of Values, with a type of 
EXP_ITEM_CAT. You can create more report categories in the List of Values. If 
you create a new report category, however, you must use Actuate and Siebel 
Tools to include it in an Expense Report report.
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5 In the Summary field, select a Summary from the drop-down list. 

This determines the Expense Summary Report category this type rolls up to. 

NOTE: The summary categories are created in the List of Values, with a type of 
EXP_ITEM_SUMCAT. You can create more summary categories in the List of 
Values. If you create a new summary category, however, you must use Actuate 
and Siebel Tools to include it in an Expense Report report.

You can modify or delete any existing expense type category specifications from 
this view.
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Expense Reports and the Euro
An expense report is automatically assumed to be reimbursed in the default 
currency, which is the currency of the user’s country. However, a user may need to 
be reimbursed in a different currency, or may have expense report line items in 
different currencies.

Table 16 shows examples of how different rules apply to the exchange rate that 
appears automatically for expense reports, and whether or not the rules allow you 
to change the exchange rate. These rules depend on whether or not the currency 
being exchanged is a member of the European Monetary Union (EMU).

Table 16. Exchange Rate Behavior for Expense Reports

Incurred 
Currency

Reimbursement 
Currency

Exchange 
Rate 
Provided?

Exchange 
Rate 
Changeable? Comments

EMU EMU Yes No The currencies have a fixed 
exchange rate through the 
Euro, and use a conversion 
process called 
triangulation.

Not EMU EMU Yes Yes You provide the exchange 
rate.

EMU Not EMU Yes Yes You provide the exchange 
rate.

Not EMU Not EMU Yes Yes You provide the exchange 
rate.

Any 
currency

Same as 
incurred 
currency

Yes; the 
exchange 
rate is 1

No Because the two currencies 
are the same, you cannot 
change the exchange rate.
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Using a Different Expense Period Type
When creating an expense report, you select the period the expense report covers. 
The Pick Period dialog box shows only periods of the type Week. If you have not 
defined any periods with this type, then the periods do not appear in the Pick Period 
dialog box. 

Do not use the Period Type Weekly if this does not suit your implementation. 

The Period Type of Week is specified in three places in the repository:

1 Search-Spec of applet 'Period Pick Applet-Open': [Closed Flag] = 'N' and 
[Period Type] = LookupValue("PERIOD_TYPE", "Week")

2 Field [Period Type Default] of 'Time Sheet' BusComp: 
LookupValue("PERIOD_TYPE", "Week")

3 Field [Period Type Default] of 'Expense Report' BusComp: 
LookupValue("PERIOD_TYPE", "Week")

If you need a Period Type other than Week, then the previous three items must be 
modified in Siebel Tools to indicate the new Period Type. You can allow users to pick 
from multiple types of periods if the search specification is similar to ‘Type-1 OR 
Type-2’. For more information on using Siebel Tools, see Siebel Tools Reference.

You can use only one Period Type with auto-generation of expense reporting. These 
expense reports use the second and third items in the preceding list to find a period 
when creating a new expense report or time sheet for a single period type.
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Setting User Approval Limits for Time and Expense
Based on the reporting structure of your organization, you will need to set up the 
proper expense report limits and hours limits for the expense reports and time 
sheets approval process.

To set expense report approval limits

1 From the application-level menu, choose View > Site Map > User 
Administration > Employees.

2 In the Employees list, select the employee associated with the approval limit.

3 In the More Info form, click the show more button to expand the form.

4 In the Expense Approval Limit field, enter the approval limit.

To set time sheet hours approval limits

1 From the application-level menu, choose View > Site Map > User 
Administration > Employees.

2 In the Employees list, select the employee associated with the approval limit.

3 In the More Info form, click the show more button to expand the form.

4 In the Time Sheet Hours Approval Limit field, enter the hours limit.
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Creating Time Sheet Work Types
Work Types are used in time sheets as a way to analyze how your time is spent 
when it is not being reported against a specific project. Examples of work types are 
vacation time, travel time, or sick days. 

To create work types

1 From the application-level menu, choose View > Site Map > Application 
Administration > Work Types.

2 In the Work Types list, click the menu button, and then choose New Record.

3 In the Work Types list, complete the following fields:

■ Name (example: vacation)

■ Start (the date you want the work type to be active)

■ End (the date you want the work type to be inactive)

NOTE: Users must be set up in the access list field to be able to access the work 
type in their time sheet.
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This section describes configuration tasks that are necessary to use some Siebel 
ERM modules. Configuration tasks include procedures for:

■ Establishing the GUESTERM User

■ Modifying ERM Predefined Queries

■ Establishing D&B user credentials to allow access to D&B’s detailed business and 
credit reports

■ Activating ERM layout controls for end users.

For information about installing Siebel applications or general Siebel parameters, 
see Siebel Server Installation Guide for Microsoft Windows, Siebel Server Installation 
Guide for UNIX, and Siebel Web Client Administration Guide.

For general information about configuring Siebel applications, see Siebel eSales 
Administration Guide.
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Configuring Siebel ERM for GUESTRM User
After installing the server and application, you must configure the application for 
the GUESTERM user. This user ID verifies that each user logging in to Siebel ERM 
sees the proper Home Page with the correct page tab. 

To set up the GUESTERM user

1 Using the appropriate database software for your database, create a database 
login with the following parameters.

Login = GUESTERM

Password = DBPASSWORD 

(DBPASSWORD represents a password that you provide)

This step creates the GUESTERM user database account, as required for your 
RDBMS system.

NOTE: The password is only required for db2 and non DOCI MSSQL databases.

2 Stop the Web server.

3 Open the eapps.cfg file from SWEApp\BIN directory.

NOTE: The eapps.cfg file is installed on the Web server, within the Siebel 
directory.

The SWEApp\bin\eapps.cfg file includes definitions that allow unregistered 
user access.
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4 Locate the following ERM section of the eapps.cfg file. 

[/ERM]

AnonUserName  = sadmin

AnonPassword  = password

ConnectString = ...

StartCommand  = SWECmd=GotoView&SWEView=Portal+Page+Home+View

5 Enter the following values.

AnonUserName  = GUESTERM

AnonPassword  = DBPASSWORD

6 Save the eapps.cfg file.

Restart the Web server.
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Modifying Siebel ERM Predefined Queries
A predefined query (PDQ) is a query with specific criteria already defined. Typically, 
the criteria includes information on which records to search for and in what order 
the records should appear. The conditional expression within a query that 
determines the set of retrieved records is called a search specification. The sort 
specification is the conditional expression within the query that determines the 
order of the retrieved records. 

Predefined queries are set up by the system administrator and cannot be deleted or 
modified by end users. Siebel ERM is preconfigured with several PDQs, and some 
of these predefined queries are used in sections on the home page.

There is one predefined query for each of the main business objects in Siebel ERM. 
Other pages in Siebel ERM also use predefined queries. You can modify the PDQs 
to change the default search or sort specifications. Table 17 shows the PDQs that 
are included with Siebel ERM and the associated ERM page and business object for 
each PDQ.

See Siebel Tools Reference for more information about search and sort specifications.

Table 17. Siebel ERM Predefined Queries

PDQ Name Page Business Object

Account Account Briefing ePortal Account

All Approvals Compensation Plan Users ERM CompPlan Approval

All Plans My Compensation Plans ERM CompPlan Workbook

Approvals Delegated to Me Compensation Plan Users ERM CompPlan Approval

Competitor Competitor Briefing ePortal Competitor

Corporate Marketing Corporate Marketing ePortal Cat Corporate 
Marketing

Employee Self-Service 
Forms

SmartScript Administration SmartScripts

ERM Corporate Objectives Corporate Objectives ERM Corporate Objectives

HR HR ePortal Cat HR
284 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Configuring Siebel ERM

Modifying Siebel ERM Predefined Queries
You can modify PDQs using the Predefined Queries view.

To modify a predefined query

1 From the application-level menu, choose View > Site Map > Application 
Administration > Predefined Queries.

2 In the Predefined Queries list, query to locate the PDQ record.

3 Click the menu button and then choose Copy Record to create a backup copy of 
the predefined query.

4 Complete the fields for the PDQ record.

NOTE: Modifying a PDQ in the Predefined Queries view changes the query for all 
users.

For more information about creating and modifying PDQs, see Applications 
Administration Guide.

Industries Industries ePortal Cat Industries

IT IT ePortal Cat IT

My Approvals Compensation Plan Users ERM CompPlan Approval

My Briefings Home Page ePortal Employee

My Plans My Compensation Plans ERM CompPlan Workbook

Partners Partners ePortal Cat Partners

Plans Delegated to Me My Compensation Plans ERM CompPlan Workbook

Products Products ePortal Cat Products

Project Home Page Query Project Home Page Project

Sales Sales ePortal Cat Sales

Training Training ePortal Cat Training

Table 17. Siebel ERM Predefined Queries

PDQ Name Page Business Object
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In addition to D&B Company Profiles that appear on Account, Competitor, and 
Company Briefings, Siebel Systems and D&B offer a cobranded Web site that allows 
Siebel customers to access D&B’s detailed business and credit reports through their 
Siebel application. These reports include Business Background Reports, Financial 
Profiles, Payment Analysis Reports, and Supplier Evaluations.

You have two options for providing users with access to D&B business and credit 
reports:

■ Credit card access. This default option requires the user to enter credit card 
information for payment.

■ Contract access. Contract Access requires customers to sign a contract with D&B. 
Customers are then given logon credentials to use each time they want to order 
D&B reports, and the price of the report is billed against the contract.

If your company has a contract with D&B to purchase these reports, you can 
configure your Siebel ERM application to allow users contract access to the D&B 
company report site. This allows your employees to click a D&B link in the 
Additional Information section of Briefing documents and enter the D&B Report site 
with contract access. 

To activate the D&B link, you enter your company’s D&B account name and 
password in the Host Administration list in the Administration view.

To allow contract access to the D&B report Web site

1 From the application-level menu, choose View > Site Map > Integration 
Administration > Symbolic URL Administration.

2 In the Symbolic URL list, select the AccountAdditionalInfo content agent.
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3 In the Symbolic URL Arguments list, create URL arguments for the selected 
content agent.

The following tables shows argument names, such as DNBLink, and each 
argument’s associated value.

4 In the Symbolic URL list, select the CompanyAdditionalInfo content agent.

Repeat Step 3 and Step 4.

When users click the D&B link that appears in Account, Competitor, or Company 
Briefings, they enter the D&B Company Report site with contract access.

For more information about D&B reports and services, see Applications 
Administration Guide.

Argument Name Argument Value

DNBLink Enter the name of the contract.

DNBPassword Enter the password from the logon credentials issued by D&B.

DNBUser Enter the user name from the logon credentials issued by D&B.
Version 7.5, Rev. A Siebel Employee Relationship Management Administration Guide 287



Configuring Siebel ERM

Setting Up Layout Controls for ERM
Setting Up Layout Controls for ERM
To activate user layout control, Siebel ERM includes a SWE tag <swe:layout> and 
supporting configuration file settings and applet control objects in Siebel Tools.

NOTE: Siebel Web Template Files (.swt) are located in the webtempl directory of 
your Siebel Server installation directory.

The swe:layout Tag
The end user can reorder and hide applets. The swe:layout tag is used to 
conditionally determine the HTML content that appears based on the current view’s 
layout mode and the user’s layout preferences.

Usage
<swe:layout viewDisplayMode="xxx" appletDisplayMode="xxx" 
appletDisplaySize="xxx" />

Attributes
viewDisplayMode: This is optional. It can have values Layout or Show. If 
viewDisplayMode is Layout, the tag is only shown if the user is in Edit View Layout 
mode. If viewDisplayMode is Show, the tag is only shown if the user is not in Edit 
View Layout mode. If viewDisplayMode is not specified, the tag is shown whether 
or not the user is in Edit View Layout mode.

appletDisplayMode: This is optional. It can have the value Show or Hide. If 
appletDisplayMode is Show, the tag is shown only if the applet is visible. If 
appletDisplayMode is Hide, the tag is shown only if the applet is hidden. If 
appletDisplayMode is not specified, the tag is shown regardless of applet visibility.

appletDisplaySize: This is optional. It can have the value of Min or Max. If 
appletDisplaySize is Min, the tag is shown only if the applet is minimized. If 
appletDisplaySize is Max, the tag is shown only if the applet is maximized. If 
appletDisplaySize is not specified, the tag is shown regardless of applet display 
size.

Restrictions
Restrictions can only be used only within Applet Web Templates. At least one of the 
attributes must be specified.
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Examples
The following examples show sample SWE tags and describes how the HTML 
content appears.

<swe:layout appletDisplayMode="Show">

This text is shown only when the applet is visible, whether or not the user is in Edit 
View Layout mode.

</swe:layout>

<swe:layout viewDisplayMode="Show">

This text is shown only when the user is not in Edit View Layout mode.

<swe:layout appletDisplayMode="Show" appletDisplaySize="Max">

This text is shown only when the user is not in Edit View Layout mode and the 
applet is visible and the applet is maximized.

</swe:layout>

<swe:layout appletDisplayMode="Hide">

This text is shown only when the user is not in Edit View Layout mode and the 
applet is hidden.

</swe:layout>

</swe:layout> <!-- viewDisplayMode="Show" -->

Applet Controls
Each applet that will be moved or hidden has controls that render the appropriate 
image (for example, Move Down image) and call the appropriate InvokeMethod (for 
example, MoveAppletDown). The controls include:

■ ButtonHideApplet

■ ButtonMaximizeApplet

■ ButtonMinimizeApplet

■ ButtonMoveAppletDown
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■ ButtonMoveAppletUp

■ ButtonShowApplet

There are also general layout controls that allow the user to perform certain 
operations (through InvokeMethods). These controls include edit the view layout, 
show the view layout, reset the default layout, show all applets, hide all applets, 
minimize all applets, maximize all applets. These layout controls are typically 
added to the first applet in a view. General layout controls include:

■ ButtonEditViewLayout

■ ButtonShowViewLayout

■ ButtonResetViewLayout

■ ButtonHideAllApplets

■ ButtonShowAllApplets

■ ButtonMinimizeAllApplets

■ ButtonMaximizeAllApplets

For more information about modifying SWE templates, see Siebel Tools Reference.
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Siebel ERM includes an Application Services Interface (ASI) that help an 
organization to integrate and synchronize employee and position data between 
Siebel ERM and the following HRMS applications:

■ PeopleSoft HR 8.0, 7.5, or 7.0

■ SAP HR

■ Oracle HR

Both Siebel ERM and the third-party HRMS can store data that is fundamentally the 
same; however, each system maintains a separate database.

This chapter describes how to set up an Application Services Interface (ASI), and 
synchronize the data.
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Example Process Flow for ERM ASI Setup
The following section describes the process an administrator might follow to set up 
a third-party Human Resources Management System for use with Siebel ERM 
Applications Services Interface.(ASI). Your company may follow a different process 
according to its business requirements.

Administrator Procedures
When setting up ASI, you should perform the following procedures in the order 
presented:

Perform the procedures in the following order:

■ Configure Web Services. The administrator configures Web services for each 
employee. For more information, see “Configuring Web Services” on page 293.

■ Activate the workflows. The administrator verifies that the Synchronize Employee 
ASI workflow is active. For more information, see “Activating the Employee ASI 
Workflow” on page 295.

■ Synchronize data. The administrator synchronizes ERM and third-party HRM 
employee data. For more information, see “Synchronizing ERM and Third-Party 
Employee Data” on page 296.
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Configuring Web Services
Web services are used to direct the inbound and outbound messages to and from 
the third-party HRMS. Verify that the Web service is correctly configured for each 
employee. 

To configure the Web services for an employee

1 From the application-level menu, choose View > Site Map > Web Services 
Administration > Outbound Web Services.

2 In the Outbound Web Services list, query to find the External Employee Web 
service.

3 Verify that the fields in the Outbound Web Services list match the information 
in the following table.

4 In the Service Ports list, add a new record, and then complete the fields.

The following table describes the fields in the service port record.

Namespace Name Status

http://siebel.com/asi/ External Position Active

Field Comments

Address When you select a transport, the field is populated with a template 
address. For example, the root of the address can be different 
depending on your environment.

Binding If a SOAP header is expected by the receiving application, select 
SOAP_RPC.

Name Enter a descriptive name for the port.

Port Type Enter External Employee.

Transport Select File from the drop-down list.
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For more information about configuring Web Services and setting up demonstration 
scripts, see Integration Platform Technologies: Siebel eBusiness Application 
Integration Volume II.
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Activating the Employee ASI Workflow
The Synchronize Employee ASI workflow must be active for synchronization to 
occur.

To activate the workflow for an employee

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 In the Workflow Processes list, query to find the Synchronize Employee ASI 
workflow.

3 In the Status field, verify that the workflow is Active. If the status is Inactive, 
change the status to Active.

NOTE: After you have activated the workflow for employee data, restart your 
server.
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Synchronizing ERM and Third-Party Employee Data
After ASI setup is completed, you can synchronize ERM and third-party HRM 
employee data.

To synchronize employee data with a third-party application

1 From the application-level menu, choose View > Site Map > Employee 
Administration > Employees.

2 In the Employee list, query to find the record you want to update.

You can edit the record before you synchronize. The changes you make are 
updated in both systems after synchronization.

3 Click the menu button and then select Synchronize.

TIP: Choose Synchronize All if you have made changes to several records. 
Synchronize All synchronizes the changes on multiple records at one time.
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This chapter helps you troubleshoot common problems related to Siebel ERM.
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ERM Troubleshooting Topics
The following troubleshooting topics are addressed in this section:

■ External News and Data Do Not Appear on page 299

■ News Does Not Appear in the Our Company Section on page 301

■ Not Found Error in the Siebel Mobile Web Client on page 302

■ Users Receive Too Much News on page 302

■ Literature and Bulletins Are Out of Date on page 303
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External News and Data Do Not Appear
Your company has purchased Siebel eContent Services and you are able to access 
the Web from your workstation, but you do not receive external news and data on 
the ERM home page. In this example, the problem may be that a proxy server is 
being used to insulate your network from the Internet and is not allowing the Siebel 
application to pass requests through and return data to the application.

Verify Connectivity with Siebel eContent Services Data Host
Verify connectivity with the Siebel eContent Services data host using network 
utilities, such as ping, nslookup, and tracert.

If you do not know the name of the Siebel eContent Services data host, you can find 
it in the license key letter that Siebel Systems sent to your company.

Verify Your Web Connection and User Credentials
Verify that you have a valid Web connection and that your Siebel eContent Services 
credentials are valid.

To verify your Web connection and credentials

1 Open a Web browser on your Siebel server.

2 Enter one of the following URLs: 

■ for eContent customers:

http://{eContent_hostname}/eContent/
GetCompanyNames?FIND=Siebel

Change {eContent_hostname} to the name of your content host.

■ for ContentBroker customers:

http://{ContentBroker_hostname}/eContent/
GetCompanyMID?FIND=Siebel

Change {ContentBroker_hostname} to the name of your content host.

A dialog box appears prompting you for your Siebel eContent Services user 
credentials. You can find your user credentials in the license key letter that Siebel 
Systems sent to your company.
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3 Enter your user credentials.

Company information about Siebel should appear. If it does, your user 
credentials are valid. Skip the next step.

If you receive an “Access Denied” message or other type of message, the proxy 
server may not be allowing access to the Internet. 

4 If you have received an error message, try to access the URL using a browser on 
a machine that does not go through the proxy server or firewall and repeat Step 1 
through Step 3.

If company information about Siebel Systems appears, then the problem lies 
with the Siebel server passing through the proxy server to retrieve data through 
the Internet. Contact your network administrators to resolve the issue.

Verify Server Configuration
If you could access the Siebel company information using the previous procedure, 
then the problem may be in the configuration settings for the proxy server or in the 
Siebel ERM server configuration files.

To test your configuration settings

1 Start the twsiebel client in your browser. 

2 Open a second browser window at the same time and enter the following URL:

http://localhost/start.swe?SWECmd=
GotoView&SWEView=SI+Com+Company+Briefing+View&MID=808856512

NOTE: URLs are case-sensitive.

3 Enter valid login credentials, and then click Login.

If external content does not appear, this indicates a configuration problem, either 
with the proxy server or within the server configuration file. 

If the problem is not resolved after checking your configuration settings, follow the 
instructions in the next section, and then contact Siebel Technical Support to resolve 
the issue.
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Gather Information for Siebel Technical Support
If you have completed the steps previously described and cannot resolve the issue, 
contact Siebel Technical Support. To assist Siebel Technical Support in diagnosing 
the issue, please gather the following information.

If you are using Windows NT Server, use the following procedure to extract proxy 
server registry settings.

To copy registry settings

1 Choose Start > Run.

2 Open the Registry Editor by typing “regedit” in the Open field.

3 Navigate to the following directory:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings

4 Copy the contents of the following two keys into a text file:

ProxyServer

ProxyOverride

5 Save the text file to send to Siebel Technical Support.

6 Navigate to the following directory:

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\In
ternet Settings

7 Copy the contents of the following two keys into a text file:

ProxyServer

ProxyOverride

8 Save the file to send to Siebel Technical Support.

News Does Not Appear in the Our Company Section
If news does not appear in the Our Company In The News section of the ERM home 
page, but it does appear in other news sections, it is likely that you did not assign 
an account topic to the special “_Our Company_” record.
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For more information, see “Retrieving Account and Competitor News for Briefings” 
on page 173.

Not Found Error in the Siebel Mobile Web Client
If users receive a “404 Not Found” error after clicking Company Lookup in the 
Account Topic Manager, then the constructed external URL went to a valid host 
name but specified a URL path that does not exist. This usually indicates that a 
Symbolic URL is not correctly defined.

For more information on ways to resolve this problem, see Chapter 9, “Setting Up 
eContent Services.” 

Users Receive Too Much News 
If the amount of news and data that is published on a regular basis in Siebel ERM 
becomes too large, you can change the number of days that news and data are 
published by changing the argument values in the Integration 
Administration > Symbolic URL view. This will decrease the amount of 
information by removing older items.

The number of days for which articles are published is controlled by the HIST 
argument value in content agents. Table 18 provides an example of the Symbolic 
URL HIST argument values.

The default setting for HIST is 90 days.

Table 18. Symbolic URL HIST Argument

Symbolic URL 
Name URL

Argument 
Name Required

Sequence 
Number

Argument 
Type

Argument 
Value

CompanyNews http://datahost/
eContent/GetHeadlines

HIST N 1 Constant 90
302 Siebel Employee Relationship Management Administration Guide Version 7.5, Rev. A



Support and Troubleshooting

ERM Troubleshooting Topics
You can also change the number of articles that appear. The number of articles that 
appear is controlled by the MAX argument value in content agents. Table 19 
provides an example of the Symbolic URL MAX argument values.

The default setting for MAX is 20 days.

If users are receiving news and information about too many accounts or 
competitors, they can reduce their list of tracked accounts and competitors by 
modifying their tracking profile.

Literature and Bulletins Are Out of Date
If a literature item or bulletin is no longer useful or it is replaced by a more recent 
version and the original item has not yet reached its expiration date, you can change 
the item’s expiration date to the current date. This removes the item from the ERM 
home page.

Table 19. Symbolic URL MAX Argument

Symbolic URL 
Name URL

Argument 
Name Required

Sequence 
Number

Argument 
Type

Argument 
Value

CompanyNews http://datahost/
eContent/GetHeadlines

MAX N 1 Constant 20
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This appendix includes information and sample scripts used to administer 
Employee Self-Service.

Example eScript for Requestor Form
The following script is used to link an employee self-service business process to the 
unified approvals inbox. In this example, the script is linked to the approval type 
called PAFChange.

function Script_Finish ()

{

   var szScriptSessionId;

   var szRequester;

   var svc;

   var indata;

   var outdata;

// Cancel saving everything to the database   

   Cancel ();

indata =TheApplication ().NewPropertySet ();

   outdata = TheApplication ().NewPropertySet ();

// Get the login name of the user

   szRequester = TheApplication ().LoginName ();

   // Get SmartScript Save Session table Id.

   szScriptSessionId = GetSessionId ();

// ItemObjectId, ItemType, ItemSubmittedBy, and ItemDescription are the
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   // required input arguments for the "Universal Inbox.Initialize"

   indata.SetProperty ("ItemObjectId", szScriptSessionId);

   // Item Type is the Approvals Inbox type defined in the

   // Approvals Inbox Administration screen

   indata.SetProperty ("ItemType", "PAFChange");

   // Short Description of the inbox item

   indata.SetProperty ("ItemDescription", szScriptSessionId);

   indata.SetProperty ("ItemSubmittedBy", szRequester);

// ItemQueueDuration, ItemPriority, and ItemComments are the

   // optional input arguments for the "Universal Inbox.Initialize"

   indata.SetProperty ("ItemQueueDuration", "129600");

   indata.SetProperty ("ItemPriority", "High");

   indata.SetProperty ("ItemComments", "Comments from Employee Self-Service");

   svc = TheApplication ().GetService ("Universal Inbox");

   svc.InvokeMethod("Initialize", indata, outdata);

}
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The following script is used by summary forms.

function Script_Open ()

{

   var PageFirstPage;

   var QuestLastName;

   var szLastName = "";

   var szScriptSessionId = "";

   var boCallScripts;

   var bcCSRunAnswer;

// Get the handles to the page and the questions

   PageFirstPage = GetPage ("PAF Summary");

   QuestLastName = PageFirstPage.GetQuestion ("PAF Summary Employee Last Name");

// Set all the questions read-only

   QuestLastName.SetQuestionEnable (false);

// Get the script session run id

   szScriptSessionId = GetParameter ("Session.ScriptSessionId");

// Get the "Call Scripts" busobj and "Call Script Run Answers" buscomp

   boCallScripts = TheApplication().GetBusObject ("Call Scripts");

   bcCSRunAnswer = boCallScripts.GetBusComp("Call Script Run Answers");

// Query for the employee's last name

   with (bcCSRunAnswer)

   {

      SetViewMode (AllView);

      ClearToQuery ();

      ActivateField ("Run Id");

      ActivateField ("Page Name");

      ActivateField ("Question Name" );
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      ActivateField ("Answer Text" );

      SetSearchSpec ("Run Id", szScriptSessionId);

      SetSearchSpec ("Page Name", "PAF Which Change");

      SetSearchSpec ("Question Name", "Display Employee Last Name");

      ExecuteQuery (ForwardOnly);

      if (FirstRecord () != 0)

         szLastName = GetFieldValue ("Answer Text");

   }

bcCSRunAnswer = null;

   boCallScripts = null;

// Set the values of each question by the scripting

   QuestLastName.SetCurrentValue (szLastName);

   return;

}
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Headcount Management competency, 
about 87

organizations
objectives and reviews, managing 78
review definitions, controlling which are 

used 77
Our Company section, news does not 

appear 301

P
page layout, about 42
Performance Management competency, 

about 87
Period Type Weekly expense type, places 

used in the repository 278
plan rollout

defined 116
defining compensation plan rollout 116

planning cycle, associating compensation 
type with a planning cycle 124

portal pages
described 18
topic, associating with a company 177

preconfigured employee self-service form
customizing 223
importing 221

predefined queries (PDQs)
about modifying and table of 284
ERM predefined queries, table of 285
modifying (procedure) 285
predefined queries, table of 284

primary position, note about employees and 
unique primary position 84

products, adding to assets online 186
project activity template, creating activities 

for the template 257
Project Center

Siebel Project home page, about 260
virtual collaboration, and 258

Project Explorer, using to browse 
projects 261
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project graphic, adding to Project Summary 
pages 267

Project home page, about 260
project information, adding or 

viewing 266
project members, adding 263
Project Summary page

See also Siebel Projects, setting up
about 260
project descriptions, adding 265
project descriptions, locations where they 

appear 265
project graphic, adding 267
removing news topics 269

projects
 See also Siebel Projects, setting up
news topic, adding to project 268

protection-building process, about 200
publishing

bulletins 139
Web clips and recommend links, 

adding 135

R
rating scale

rating values, creating for the rating 
scale 65

values, about defining with 65
values, defining with (procedure) 65

recommended links
about 44
publishing, about 135

registry setting, copying 301
reports

Automated Diagnostics, set of default 
reports 202

expense types, mapping to reports 275
requestor form

approval type, referencing in a requestor 
form 245

eScript example 305
resolution

adding to Siebel HelpDesk 192

category, adding to 192
defined and about creating 191

resources, additional 13
responsibilities, giving users access to 

views 29
review component display names, 

translating 71
review components, defining

about 69
creating (procedure) 69
display transactions, defining 71

review definitions
about and caution 75
creating (procedure) 75
organizations, controlling which review 

definitions are used 77
review periods

about and example 67
rollup period type, changing of review 

period 67
review status, overriding 81
rollups

about defining and example 67
rollup period type, changing of review 

period 67

S
salary grade

creating a salary grade 105
salary plan, adding to salary grade 106

salary information, associating with 
compensation guidelines 113

salary plan
creating a salary plan 106
salary grade, adding to salary plan 106

salary range, about modifying an existing 
range 107

Scorecard Metrics Report, about 202
Script Center editor, about 199
scripts

DNA Editor, using to edit scripts 200
eScript for requestor form, example 305
eScript for summary form, example 307
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search specification, defined 284
searching

Company Briefings, performing queries 
for 35

Employee Locator, about using to locate 
employees 60

News Topics types (table) 170
Siebel Search, about and searching 

techniques (table) 43
Web Search applet, about 43

server configuration, verifying 300
setup tasks, administrative tasks 

(table) 46
Shared Objectives, about using to create a 

review definition 75
Siebel Automated Desktop Support and 

Diagnostics products. See Automated 
Desktop Support and Diagnostics 
products

Siebel Calendar, about 43
Siebel Company Vocabulary, about and 

accessing 173
Siebel Compensation Planning. See 

compensation planning, setting up
Siebel Competency Management. See 

competency management, setting up
Siebel data sections

Account Briefings sections displaying 
Siebel data (table) 31

Competitor Briefings section displaying 
Siebel data (table) 34

Siebel Distance Learning module, 
about 20

Siebel eAdvisor, about 19
Siebel eContent Services. See eContent 

Services, setting up
Siebel eEvents Management, about 19
Siebel Employee Directory, setting up

business scenario 53
employee administrator, setting up 55
Employee Locator, about and types of 

search information 52
employee picture, adding to a profile 57

employee profile, about and types of 
information 50

employee profile, modifying 56
employee profile, updating profile 59
picture, associating with an 

employee 57
views, managing employee-related 

information 51
workflow process example 54

Siebel Employee Directory, setting views 
available (table) 51

Siebel Employee Self-Service (ESS). See 
employee self-service, setting up

Siebel Encyclopedia, about 18
Siebel eTraining, about 19
Siebel HelpDesk

See also help desk, setting up
preconfigured responsibilities 

(table) 183
Siebel HelpDesk agent, setting up 

(procedure) 184
SupportSoft, configuring to use 210

Siebel mobile Web client. See mobile Web 
client

Siebel Objectives and Review. See objectives 
and reviews, setting up

Siebel Performance Management, about 
using 84

Siebel Project home page
about 260
Project Center, and virtual 

collaboration 258
Siebel Projects, setting up

See also Project Summary page
about 251
activities, creating for project activity 

template 257
activity plan, creating with 

activities 264
activity template, creating for 

projects 257
business scenario 253
new projects, creating 262
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news topic, adding to a project 268
news topics, removing from Project 

Summary page 269
Project home page, about 260
project information, adding or 

viewing 266
project members, adding 263
project, deleting 262
projects, browsing using the Project 

explorer 261
virtual collaboration and the Project 

Center 258
workflow example 255

Siebel Search, about and searching 
techniques (table) 43

Siebel SmartScript, about and 
troubleshooting processes 197

Siebel Technical Support, gathering 
information for 301

Siebel Universal Queuing, about 198
Siebel Web Template Files (.swt), location 

of 288
single service-level agreement (SLA), about 

using Siebel HelpDesk to track 
problems 180

skills
competencies, about 86
creating (procedure) 93
deactivating a skill 94
defined and example 93
editing a skill 93
library, accessing 92

Smart Answer, about and implementation 
considerations 197

SmartIssues Technology, about 207
SmartResult System, about 208
solutions database, creating FAQs 190
summary form, eScript example 307
Support Automation MTS Package, about 

recreating for MTS errors 206
Support Center installation, about 199
SupportActions Report, about 202

SupportTriggers
about 207
about generating 208

surveys
employee satisfaction survey, 

modifying 194
employee satisfaction survey, setting 

up 194
.swe:layout tag, about usage, and 

attributes 288
.swt files, location of 288
Symbolic URL HIST argument, about using 

to limit the amount of news 302
Symbolic URL MAX, about using to limit the 

amount of news 303
Synchronize All, about when to 

choose 296

T
Team Competency Planning competency, 

about 87
technical support, gathering information 

for 301
templates

activity template, creating for 
projects 257

administrator activity templates, 
about 196

objective templates, creating 72
project activity template, creating 

activities for 257
TgSrvc, about Siebel Automated Desktop 

Support Repair Service for 
Windows 208

third-party applications, synchronizing with 
employee data 296

time sheets
hours approval limits, setting 279
work types, creating 280

Today’s Headlines news story format, 
about 155

Top Story news story format, about 155
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topic association, creating or 
changing 176

Tracked Accounts view, description of 29
tracking profile

about and examples 40
sections controlled by 41

Training and Development competency, 
about 87

troubleshooting 301
404 Not Found error, about and 

resolving 302
external news and data does not 

appear 299
literature and bulletins are out of 

data 303
processes and Siebel SmartScript 197
users receive too much news, about and 

resolving 302

U
Unified Approvals Inbox, setting up

approval business process (workflow), 
creating 242

approval type, creating 243
business scenario 240
employee self-service form, approving or 

rejecting 248
overview 239
previously approved items, 

reviewing 249
requestor form, referencing an approval 

type in 245
submitted form, reviewing 247

workflow example 241
universal queuing, about 198
User Report, about 202
user tracking profiles

about and examples 40
sections controlled by 41

V
views

access, about giving 29
Employee Portal Account Views 29

virtual collaboration
guidelines for setting up 258
Project Center, and 258

Visual Basic, about using Script Center to 
edit 199

W
Web clips

about 44
Web clips and links, about 

publishing 135
Web connection, verifying and 

credentials 299
Web pages, types of 18
Web Search, about 43
Web services, configuring for an 

employee 293
Windows. automated desktop support 

repair for 208
work types, creating 280
Workforce Analytics, about 20
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