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Introduction
This guide covers administrative and end-user tasks specific to Siebel Forecasting. 
Use this guide in combination with Applications Administration Guide.

The audience for this guide consists primarily of employees in the following 
categories:

NOTE: Job titles and duties at your company may differ from those listed in this 
table. 

Siebel Application 
Administrators

Persons responsible for planning, setting up, and maintaining 
Siebel applications.

Siebel Application 
Developers 

Persons who plan, implement, and configure Siebel applications, 
possibly adding new functionality.

Siebel System 
Administrators

Persons responsible for the whole system, including installing, 
maintaining, and upgrading Siebel applications. 

Sales 
Representatives

Persons responsible for creating, reviewing, and submitting 
forecasts.

Sales Managers 
and Executives

Persons responsible for managing revenue and forecasting data.

Sales Operations 
Managers or 
Executives

Persons responsible for managing the pipeline and forecast 
processes across sales channels.
Version 7.5, Rev. A Siebel Forecasting Guide 9



Introduction

How This Guide Is Organized
How This Guide Is Organized
This guide covers prerequisite and administrative tasks of Siebel Forecasting. It also 
covers end-user tasks specific to using Siebel Forecasting. Use this guide in 
combination with Applications Administration Guide.

Applications Administration Guide covers the setup tasks that are common to each 
Siebel eBusiness Application, such as using license keys, defining employees, and 
defining your company’s structure. It also provides you with the information you 
need to perform data administration and document administration tasks.

This guide assumes that you have already installed or completed the upgrade of 
Siebel Forecasting. If you have not, go to the Installation/Upgrade section of the 
Siebel Bookshelf and click the links to the guides that are relevant to your company’s 
implementation.

The Siebel database server installation script creates a Siebel administrator account 
that can be used to perform the tasks described in this guide. For information about 
this process, see Siebel Server Administration Guide and the Siebel server 
installation guide for the operating system you are using.

NOTE: Some chapters in this guide are for end users, some are for administrators, 
and some are for both.

If you are an administrator, it is recommended that you read Chapter 2, “Getting 
Started,” and Chapter 3, “Forecasting Migration,” first. These chapters provide 
information administrators need to know before using Siebel Forecasting.
10 Siebel Forecasting Guide Version 7.5, Rev. A



Introduction

Revision History
Revision History
Siebel Forecasting Guide, Version 7.5, Rev. A

January 2003 Bookshelf
Table 1. Changes Made in Rev. A for January 2003 Bookshelf

Topic Revision

“Changing the Visibility of My 
Team’s Opportunities View 
(Administrator)”

Updated incorrect cross-reference to additional 
information.

“Setting Up System Preferences for 
Forecasting (Administrator)”

Added more information about the Forecast 
Service Manager server component. Moved 
information from third paragraph to a new fourth 
paragraph.

“Upgrading Using the Data 
Migration Utility (Administrator)”

Corrected list of dll files in Step 1.

“Forecasting User Properties” Added new appendix.
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Overview of Forecasting 1
Siebel Forecasting allows customers to manage their revenues across each channel 
and to take periodic forecast snapshots of those revenues as they mature. The 
Revenues screen and views allow for straightforward pipeline management. They 
allow a sales professional, sales manager, or sales executive to retrieve revenue 
information in real time. The Forecasts screen is used to create new forecasts, 
snapshots of live revenue records, and then analyze and evaluate those saved 
forecasts over time.

The total forecast process encompasses a range of activities across many 
organizations. Also, the business requirements, and the approaches to forecasting 
can vary dramatically from time-to-time and division-to-division. While forecasting 
may only involve a simple query in some companies, it can be a planning process 
in other companies. Forecasting may be very high level in some organizations, and 
very detailed in other organizations. For some organizations, margin is a critical 
element of forecasting. For other organizations, it is revenue that matters, or the 
quantity of a product to be built, the quantity of product to be shipped, the monthly 
bookings, or the quarterly billings. Siebel Forecasting can address a wide range of 
forecasting requirements.

NOTE: The relationship between forecast items and revenue items is a many-to-
many relationship. Siebel Tools provides a Link representing this relationship: 
“Forecast 2000 -- Forecast Item Detail Flat/Revenue”. This Link can be used to 
retrieve revenue data from forecast items.
Version 7.5, Rev. A Siebel Forecasting Guide 13



Overview of Forecasting

Key Features of Forecasting
Key Features of Forecasting
Siebel Forecasting allows you to:

■ Report revenues by account, opportunity, product, product line, employee, 
partner, division, organization, or project

■ Create snapshots of revenue information over time for historical analysis

■ Perform real-time analysis of revenues using charts and reports

■ Access projected margins, cost, best case, and worst case

■ Use multiple currencies and multiple organizations

■ Perform auto-forecasts for absentee employees when appropriate

■ Create recurring revenues by account, project, and opportunity

■ Split credit of sales revenue across multiple positions and products

■ Perform matrixed revenue analysis and forecasting

■ Import and export data from the Revenues screen
14 Siebel Forecasting Guide Version 7.5, Rev. A



Overview of Forecasting

Business Functions of Screens in Forecasting
Business Functions of Screens in Forecasting
The Forecast Administration screen includes a Forecast Administration view, which 
allows you to create and define forecasts series, and a Revenue Templates view, 
which allows you to create and define revenue templates.

The Revenues screen includes every revenue to which you have access. These 
revenues may be associated with opportunities, accounts, projects, and so on. 
When you add a revenue to a Revenues view in a screen such as Opportunities, it 
appears where you add it, and it appears in the Revenues screen. You can analyze 
your revenues from the Revenues screen without performing a forecast.

The Forecasts screen includes your forecasts of revenues over time. From the 
Forecasts screen you can create new forecasts, adjust forecasts, submit forecasts, 
and perform analysis on your forecasts.

NOTE: The exact configuration of Siebel applications screens, views, and fields 
depends on your company’s configuration of the application.
Version 7.5, Rev. A Siebel Forecasting Guide 15



Overview of Forecasting

Forecasting Terms
Forecasting Terms
Table 1 describes some terms which will be helpful as you learn about and use 
Siebel Forecasting.

Table 1. Forecasting Terms

Term Definition

Forecast period The period of a forecast series from start to end date. For example, 
quarterly.

Summary period The summary period defines the periodic buckets for the Summary 
view in the Forecasts screen. Some integer number of these exists for 
each forecast period (for example, monthly). 

Summary 
Revenues

Each summary period has one summary revenue amount.

Interval period Period between creation of new forecasts; their frequency. For 
example, weekly.

Total Forecast 
Revenue

Sum of each summary record. Each summary period is a summary 
record bucket.

Detail Revenues Can be either of summary type or detail type depending on the type 
of forecast. For more information about forecast types, see “Forecast 
Types” on page 17.

Rollup Sums details and synchronizes totals with summaries.
16 Siebel Forecasting Guide Version 7.5, Rev. A



Overview of Forecasting

Forecast Types
Forecast Types
You can perform a number of different types of forecasts. Siebel Forecasting allows 
the administrator to define summary depth or detail depth forecasts based on the 
level of information that managers and executives want to see about their 
subordinates’ revenues in their forecasts. The type of forecast set up determines 
whether end users’ final adjustments should be completed in the Details view or 
the Summary view in the Forecasts screen. Administrators also define whether or 
not a forecast is rollup, snapshot, or hybrid.

Detail and Summary Forecast Types
Every forecast is either detail depth or summary depth.

In a detail depth forecast, each revenue line item in the Details view in the Forecasts 
screen is rolled up through the reporting hierarchy. As a result, senior management 
has access to every forecast detail revenue item for their review. In this scenario, 
end users should make sure that adjustments are made in the Details view of the 
forecast. After adjusting the details, end users must select Rollup to recalculate the 
modified forecast. To view the forecast details by periodic summary, use the 
Summary view tab.

In a summary depth forecast, each record in the Summary view is rolled up to a 
user’s direct manager. As a result, a manager can see his own detailed line item 
records and the summary records of his direct subordinates from the Details view 
in his forecast. Users can adjust detail records and click Rollup to calculate the 
modified forecast. They can then further adjust those records from the Summary 
view.

NOTE: If an administrator selects a summary depth forecast, executives will have 
less granularity of information for analysis, but will have greater performance.

Rollup, Corporate Snapshot, and Hybrid Forecast Types
A rollup forecast is one that moves up through a hierarchy. It involves many 
participants and facilitates sales and forecast management. A personal forecast with 
details is an example of a rollup forecast. For more information see, “Creating a 
Personal Forecast Series With Details (Administrator)” on page 57.
Version 7.5, Rev. A Siebel Forecasting Guide 17



Overview of Forecasting

Forecast Types
A corporate snapshot allows you to avoid forecasting altogether. It provides you with 
an instant way of seeing your revenues over time. It requires no participants. A 
global forecast is an example of a corporate snapshot. For more information see, 
“Creating a Global Forecast Series (Administrator)” on page 62.

A hybrid forecast allows you to have more than one visibility in one forecast and 
thus to combine a rollup and snapshot forecast, if appropriate. For example, one 
manager does not want his team to create individual forecasts, but another does. A 
hybrid forecast allows both managers to forecast their own way; snapshot and 
rollup, and still rollup to their VP. For more information see, “Creating a Hybrid 
Forecast Series (Administrator)” on page 66.
18 Siebel Forecasting Guide Version 7.5, Rev. A



Getting Started 2
This chapter describes concepts useful for defining Siebel Forecasting requirements 
and design for administrators. You should define your company’s forecasting 
requirements before performing these administration setup tasks. Use this chapter 
in combination with Applications Administration Guide.
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Getting Started

Gathering Forecasting Requirements (Administrator)
Gathering Forecasting Requirements (Administrator)
Siebel Forecasting provides you with many implementation options. With the 
importance that forecasting plays in most organizations, and the variety of 
implementation choices available, an administrator must fully understand the 
choices that are under consideration. A thorough understanding of your company’s 
business requirements can make sure that you have the information needed to 
improve your organization’s technology and business offerings for the entire sales 
organization.

The ultimate goal is to address the business requirements with less overhead and a 
higher level of accuracy in a more timely manner. Sometimes, the best way to 
understand the requirements is to look at your company’s existing process to make 
sure you cover the basics, and then to evaluate possible opportunities for 
improvement. You can begin gathering requirements with a list of the reports, 
screens, systems, and processes that are currently in place. From there, you can drill 
down on the business process to get a better understanding of the overall objectives 
and process.
20 Siebel Forecasting Guide Version 7.5, Rev. A



Getting Started

Forecasting Process Design (Administrator)
Forecasting Process Design (Administrator)
Forecasting process design is a way of evaluating the numerous forecasting options 
available to you. It consists of questions that assist you with requirements gathering 
and help you to design a streamlined, reliable, and timely forecasting process.

The questions asked during this process are:

■ Who Forecasts?

To determine who forecasts, compile a list of the major participants in the 
forecasting process. These participants may include account managers, regional 
or geographic sales professionals, product specialists, industry specialists, 
overlay sales representatives, and sales managers. Each group is likely to have a 
different set of requirements. You may select one forecasting approach for one 
group, and a different forecasting approach for another group.

In some companies, the district managers create a forecast and roll it up to their 
managers with a committed monthly total for the sales representative. The 
product specialists and overlay sales representatives may rely on a less formal 
process by querying against the All Revenues list view to find the information 
they are looking for, and then using a report, a chart, or exporting to Microsoft 
Excel to collaborate or capture the information for later use.

■ Why Do They Forecast?

Understanding the overriding goals, principles, and objectives behind a forecast 
is critical. These objectives may vary from one group to another. For instance, 
the sales department might want to identify potential lags in revenue to redeploy 
resources faster. Manufacturing might want to avoid production bottlenecks by 
adequately predicting demand. Professional services might need to use their 
internal resources more efficiently. Product management might want to provide 
directors with visibility into the sales pipeline to better drive product specific 
sales.

Once you clarify the goals of the various forecasting constituents, select an 
approach that works for each group. In general, use the simplest, most straight-
forward option that meets the objectives of each group. Sometimes, a single 
approach works for everyone; often, several approaches are needed.
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Getting Started

Forecasting Process Design (Administrator)
■ What kind of information is required?

The information requirements in sales are often very different from the 
information requirements in manufacturing and accounting. While it is useful to 
have the right level of detail, too much information can be overwhelming. 
Typically, sales organizations focus on total revenues for each representative, or 
opportunity, partner, or account specific revenues. Accounting and 
manufacturing usually want more detail; they need to know how much of 
product X was booked last quarter, or how much of product Y is being shipped 
this quarter.

Each organization will have access to the appropriate level of information. You 
might set up a revenue query for sales which shows only opportunity or account 
specific information, while setting up a more detailed query for manufacturing 
that provides users with details on each of the products within a given product 
line. Apply this same line of logic to the design of your forecast search 
specifications, so that they pull in the right level of information for the users 
involved.

■ How often is the information needed?

While a weekly forecast is fine for some organizations, a monthly forecast is 
better for others. The Revenues screen allows a sales professional, partner 
manager, sales manager, or executive to retrieve information in real time, while 
the Forecasts screen provides users with a way of copying a set of revenues and 
saving it for future use.

Find a balance between a more structured, scheduled forecasting process, and a 
less structured, less scheduled forecasting process. With the charts and reports 
available in the Revenues screen, you can perform an analysis without ever 
creating a forecast. You can reserve the forecasting process for organizations 
that really need a snapshot of the information at appropriate points in time.
22 Siebel Forecasting Guide Version 7.5, Rev. A



Getting Started

Forecasting Process Design (Administrator)
■ Is management intervention and adjustment required in forecasting?

In many organizations, a snapshot of the information in the Revenues screen, 
with some criteria applied to filter out extraneous records, is a sufficient 
forecasting method. In other organizations, some level of management 
intervention and adjustment is required as the forecast rolls up to management 
and executive levels.

In general, it is best to streamline the forecasting process. With fewer 
intermediaries and adjustments, the forecasting process becomes more timely 
and less cumbersome. Where possible, the manager and the sales representative 
are advised to agree on the revenue amount, the close date, the win probability, 
and the commit status in the Revenues screen, so that the manager does not 
need to intervene in the forecasting process. This allows an organization to take 
one snapshot of the information without intermediate steps as the forecast rolls 
up the management chain. It also confirms a level of agreement between the 
sales representative and the manager, so that the queries in the Revenues screen 
accurately reflect the level of anticipated business.
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Getting Started

Forecasting Process Design (Administrator)
■ Do sales representatives need to adjust their total dollars forecasted?

Often, the total dollar amount that a sales representative forecasts is equal to the 
sum total of his or her forecastable revenues, on a monthly or quarterly basis. 
In these cases, running a query in the revenue list view, or running a snapshot 
of the revenues for forecasting purposes is enough to produce a corporate 
forecast. However, there are organizations in which sales professionals are 
expected to commit to a monthly or quarterly revenue amount that does not 
equal the sum of their forecasted opportunities.

Perhaps a sales representative wants to include a hundred thousand dollars 
worth of opportunities in a forecast, even though the representative is only 
willing to commit to fifty thousand dollars in revenue. The Forecasts screen 
allows the sales representative to include $100,000 in opportunities, while 
adjusting the total revenue amount on a monthly or quarterly basis to $50,000. 
Although this can be useful in some situations, it means that the value of the 
revenues and the value of what the sales representative is willing to forecast do 
not agree.

NOTE: Siebel Forecasting allows sales team members to enter negative integers 
in their forecasts.
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Performance Considerations (Administrator)
Forecasting performance can vary from one company to another based on network 
bandwidth, server capacity, database tuning, and a variety of other variables. 
Investigate these possible causes whenever performance issues arise. 

As a preemptive move, you may want to consider the following performance 
objectives for forecasting:

■ Minimize the number of records that end up in the forecasting table.

■ Minimize the number of participants involved in forecasting.

■ Minimize the duplication of data as the forecast rolls up from subordinate to 
manager.

■ Minimize the complexity of the forecasting process in general.

These objectives are described in the following sections.

Minimize the Number of Records in Forecasting Table
Use a restrictive Auto Forecast Search Spec. Do not include product or revenue line 
item details for an opportunity unless they are needed. Only include opportunities 
that are committed or that meet some minimal criteria.

Consider implementing a process that batches up the revenue records or 
summarizes the information in the revenues table before the creation of the forecast 
itself. A customer with hundreds of thousands of detailed revenue line items might 
want to summarize the related revenue line items into higher level revenue line 
items before creating the weekly or monthly forecast. This keeps unnecessary detail 
out of the forecast.

Minimize the Number of Participants
Consider the list of people who really need to forecast in your organization. 

If you are creating a global snapshot, you may want only one or two people in the 
Forecast Series Participants list that do not have a manager-subordinate 
relationship. Otherwise, the auto-forecasting feature will create a manager’s 
forecast with the revenues in your company that qualify for forecasting, and a 
subordinate’s forecast with the same data.
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If you are using the departmental forecast, you may not want to include managers 
and their subordinates at the same time.

Minimize the Duplication of Data
Consider using global snapshots or departmental forecasts. If you are using personal 
forecasts, consider the personal forecast without details. The manager can still view 
the details by drilling down on subordinates, and you reduce the number of copies 
of revenue information.

Minimize the Complexity of the Forecasting Process
Consider using the Revenues view for many of your day-to-day operations. You can 
provide overlay sales organizations and product managers with access to the 
Revenues views, while restricting the use of forecasting to organizations that really 
need it. In the global forecast scenario, you only need one forecast. Overlay sales 
organizations still have access to the information they need without having to make 
copies of the database on a weekly or monthly basis.
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If you are migrating data from previous versions of Siebel Sales, you need to 
determine if you will upgrade automatically or if you will use the data migration 
utility.

The automatic upgrade feature of Siebel Sales migrates opportunities, opportunity 
product information, and select opportunity sales team information from older 
versions. The automatic upgrade does not, however, migrate old forecasting 
information. For many Siebel customers, there is sufficient information in the 
opportunity and opportunity product tables in Siebel Sales to begin the forecasting 
process without the old forecasts.

The automatic upgrade feature is sufficient if your organization:

■ Does not use Siebel Forecasting yet.

■ Uses revenue forecasting for simple opportunities with one close date and one 
revenue amount.

■ Uses the Opportunities list or the Opportunities Products list to enter most 
forecast information.

■ Uses the New button when forecasting, rather than the Copy button.

Some Siebel customers may need to also run the data migration tool provided with 
the new Siebel installation. This tool migrates information from old forecasting 
tables into new revenue tables. You must use the data migration tool if your 
organization:

■ Uses Siebel Forecasting.

■ Uses revenue forecasting with more complex opportunities that include 
recurring revenues over many months.

■ Uses the Forecasts screen to enter most forecast information (instead of the 
Opportunities list or Opportunities Products list).
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■ Uses the Copy button when forecasting, rather than the New button.

The following sections describe the Automatic Upgrade feature and the Data 
Migration tool. Please read both sections carefully before upgrading to Siebel 7.0.
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Upgrading Automatically (Administrator)
In previous versions of Siebel applications, the opportunity close date, win 
probability, commit status, and revenue amount were stored on the intersection 
table between the opportunity and its sales team members. In newer versions of 
Siebel applications, each opportunity has only one close date, win probability, 
commit status, and revenue amount. This information is stored in the Revenue 
table, on a special primary revenue record for that opportunity. This portion of the 
upgrade is automatic.

In previous versions of Siebel applications, opportunity products were stored in the 
opportunity product intersection table. In Siebel 7.0, opportunity products are 
stored in the Revenue table, along with the primary revenue record. For each 
opportunity product migrated from a previous version, a revenue record is created. 
The product name, part number, quantity, price, and extended revenue is copied 
from the old opportunity product record to the new revenue record. Other 
attributes, such as the win probability, the primary sales representative’s name, and 
the opportunity name, are copied in from the opportunity record.

Before you upgrade from a previous version of Siebel applications, decide whether 
the revenues for nonprimary sales team members should be upgraded. You may 
want to consider upgrading nonprimary sales team members’ revenues if your 
organization:

■ Uses nonprimary forecasting and wants to continue using a similar nonprimary 
forecasting approach. (Running queries on the Revenue table may not be 
adequate to meet this need.)

■ Wants each sales team member to have a different opinion on the close date and 
revenue amount for each opportunity.

■ Wants to assign some portion of each opportunity that is not related to a specific 
product or some percentage of the overall opportunity value to each sales team 
member.

For each opportunity migrated from a previous version, the automatic upgrade 
evaluates the opportunity sales team records for nonprimary sales team members. 
Each sales team member record is used to create a revenue record in Siebel 7.5, if:

■ The primary flag is not checked.
Version 7.5, Rev. A Siebel Forecasting Guide 29



Forecasting Migration

Upgrading Automatically (Administrator)
■ The revenue amount is nonzero.

■ The commit flag is checked.

Before you upgrade, make sure that your opportunity sales team records are 
appropriately marked as committed (to upgrade them) or not committed (to ignore 
them during the automatic upgrade process). Most customers do not need to 
upgrade these uncommitted sales team records.
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Upgrading Using the Data Migration Utility 
(Administrator)

The data migration tool is designed for customers with recurring revenues entered 
directly into the Forecasts screen. 

NOTE: Because of the data model changes in forecasting, it is recommended that you 
print out your old forecasts before upgrading. Those forecasts are no longer visible 
in this version of the Siebel application. Although the data migration described here 
moves your data, you may want to double-check the results when the migration is 
finished.

To use the Data Migration Utility

1 In the default bin directory on the server, there is a file called fcstcnvrt.exe. This 
is the program that is used to migrate information from old Siebel forecasting 
tables to the new Siebel Revenue table. Also in this directory is a set of DLL files 
used by the data migration utility:

sslcshar.dll

sslcfom.dll

sscfdm.dll

sscfcmn.dll

sscacmbc.dll

sslcsym.dll

sslcosd.dll

Once you have located these files and made sure that they are available for data 
migration, clean up your existing data.
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2 You may need to perform some data cleanup on your old Siebel database. 
Specifically, check for and remove duplicate periods from the periods table, if 
they exist.

To check for duplicate periods, manually review the periods view in Siebel, or 
run the following SQL:

select t1.row_id || ' CONFLICTS WITH ' || t2.row_id || 
' (' || t1.period_cd || ',' || t1.start_dt || ')'
from s_period t1, s_period t2
where t1.period_cd = t2.period_cd
and t1.start_dt = t2.start_dt
and t1.row_id <> t2.row_id 

If you do have duplicate periods, and you find that they have been used in 
creating old Siebel forecasts, work with Siebel Systems to address this issue 
before proceeding to the next step.

3 At the command prompt, enable logging using the following commands:

set SIEBEL_LOG_EVENTS=errors
set ForecastUpgdEvent=errors

To log all events instead of just errors, set each of the preceding variables to “All” 
instead of “errors.”

4 To run the data migration, use fcstcnvrt.exe. The syntax for this command is:

fcstcnvrt/u username /p password /d datasource /m 
masterForecast /date date [/c cfgFile] [/l language] [/postn 
postn] [/login login] [/sspec searchSpec] [/r revision] [/
submitted [/Opportunity [/OpportunityProduct [/OpptyProduct [/
NP] [/Period period] [/UseStartDate] [/Desc description]

or
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fcstcnvrt[/help]

The following table describes each of these:

Switch Description Comments

/u username
/p password

Required. System 
Administrator’s 
username and password.

These are the same username and 
password that you use to log in to 
the Siebel server database.

/d datasource Required. The name of 
the datasource.

/c cfgFile The name of the 
configuration file.

/l language The language being 
used.

/m masterForecast
/date date

Required. Specify which 
forecasts to upgrade, 
using masterForecast and 
date as search specs.

1. masterForecast must be the 
name of a valid master forecast.

2. date must be a valid date. The 
format for the date field is: MM/
DD/YYYY. For example, 01/05/
2001.

/postn postn Specifies a position to 
upgrade.

To specify more than one position, 
use /sspec

/postn takes priority over /login

/login login Specifies a login to 
upgrade.

Applied in conjunction with other 
search specs. 

/sspec searchSpec Limits the forecast 
records by search spec.

searchSpec must be a valid search 
spec for a personal forecast.

/r revision Limits the forecast 
records by revision.

revision can be a valid number, or 
one of {Earliest|Latest}.

/submitted Limits the forecast 
records to those which 
have been submitted.
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5 The data migration utility takes a few minutes to run. Some messages may 
appear while the upgrade is running. You might see something like this:

-> "Upgrading forecast for CCONWAY Revision 1.. Success".
-> "Upgrading forecast for CCONWAY Revision 2.. Failure".
-> "*******Upgrade complete**************"
-> "Errors were encountered. Please see the logfile in 

d:\log\siebel.log for
more details"

/Opportunity 
/OpportunityProduct 
/OpptyProduct

Specifies the business 
component to upgrade.

1. Only the specified business 
components are upgraded.

2. You can upgrade a child 
business component without 
upgrading its parent (for example, 
Opportunity Product without 
Opportunity).

/NP Indicates whether to 
upgrade the nonprimary 
counterpart of the 
specified business 
component (for example, 
opportunity personal 
forecast).

The primary business component 
must be specified for the 
nonprimary business component 
to be upgraded.

/Period period 
/UseStartDate 
/Desc Description

Specify how to create 
Revenues.

1. period must be a valid period 
type, (for example, Month or Year)

2. If /UseStartDate is specified, 
the revenues are created using the 
start date of the period in which 
they fall. Otherwise, the default is 
the end date. 

3. If /Desc is specified, the 
revenues are created with 
description as their description.

/help Lists the parameters 
described here.

Switch Description Comments
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The forecasting module is dependent on a number of prerequisites, such as periods, 
currencies, exchange rates, an employee reporting structure, and appropriate lists 
of values for revenue types and revenue classes. These prerequisites are described 
in the following section.
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Using the Periods Table (Administrator)
The periods table includes buckets of time such as weeks, months, quarters, and 
years. While some organizations use standard calendar reporting periods, other 
organizations use fiscal reporting periods. Siebel eBusiness Applications provide 
flexibility in this area, so organizations can set up periods that make sense for them.

Because forecasting often goes months or years into the future, it is important to 
establish periods not just for the current month or quarter, but for several quarters 
or years in advance. Ideally, enough periods should be created to allow at least a 
few months of forecasting without having to go back into the period’s table every 
time someone needs to forecast.

Generally, periods should be contiguous (one period ends on January 31st and the 
next period begins on February 1st), and regular (periods are whole calendar 
months or always go from the 15th of one month to the 14th of the next month). 

Typically, the smaller buckets, such as months, fit into the larger buckets, such as 
quarters. The beginning of a month often coincides with the beginning of a quarter, 
or the end of a month coincides with the end of a quarter.

Table 2 illustrates how the periods defined for forecasting might look.

While there are many other ways to establish periods in Siebel applications, 
contiguous, regular small periods, which fit nicely into the larger periods, are 
recommended. For information on how to set up periods, see the chapter that 
discusses ongoing administrative tasks in Applications Administration Guide.

Table 2. Example Forecasting Periods

Period Name Period Type Start Date End Date

Jan 01 Month 1/1/2001 1/31/2001

Feb 01 Month 2/1/2001 2/28/2001

Mar 01 Month 3/1/2001 3/31/2001

Q1 01 Quarter 1/1/2001 3/31/2001

Y 01 Year 1/1/2001 12/31/2001
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Using the Currencies Table (Administrator)
The currencies table includes each of the currencies that an organization refers to 
when creating opportunities, quotes, orders, and forecasts in Siebel eBusiness 
Applications. 

Currencies can be assigned to divisions. The employees belonging to those divisions 
have that currency as their default currency. When those employees create new 
opportunities, the opportunities use the default (divisional) currency for that 
employee. The employee can accept the default currency for the majority of their 
opportunities, and can change the currency for occasional exceptions to the rule.

For example, an employee working in Germany might typically manage 
opportunities with German companies in Deutsche marks. That same employee 
might occasionally manage opportunities with French companies in French francs. 
The employee’s divisional currency is Deutsche marks, but the employee can also 
create opportunities denominated in French francs.

Charts, reports, and forecasts in Siebel Forecasting refer to divisional currencies. 
When opportunities and products are shown, they are shown in their native 
currency, that is the currency that was entered by the end user. Native currencies 
are converted automatically for end users into their divisional currencies when 
displayed in a chart or report, or when displayed as totals for an employee in a 
forecast.

Organizations that use multiple currencies must set up exchange rates to convert 
monetary data from one currency to another. For more information on setting up 
currencies, see the chapter that discusses ongoing administrative tasks in 
Applications Administration Guide.
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Setting Up Currency Exchange Rates (Administrator)
The Siebel application uses Currency Exchange Rates to convert monetary amounts 
from one currency to another. To calculate exchanges between currencies, you must 
set up an exchange rate twice—one for each currency. For instance, if you want to 
calculate the exchange rate between the U.S. dollar and the Japanese yen, you must 
set up an exchange rate for yen to dollars, and set up another rate for dollars to yen.

Currency exchange rates not found in Siebel applications are assumed to be on a 
1:1 basis. If you fail to set up an exchange rate, the amounts will stay the same when 
converting, but the currency symbol will change. Note that not every exchange rate 
needs to be entered into Siebel. Euro Triangulation can be used to get from one 
currency to another through common EMU currency - the Euro. For additional 
information, see the chapter that discusses ongoing administrative tasks in 
Applications Administration Guide.
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Setting Up Employee Positions and Employee Reporting 
Structure (Administrator)

Siebel Forecasting relies on employee positions and positional hierarchies when 
creating a forecast. The user must appear in the employee table and have a position 
to create a forecast. Employee relationships between a manager and an employee 
are established by way of the parent position field on the employee’s position 
record.

For more information on adding employees and employee relationships, see the 
chapter that discusses initial setup in Applications Administration Guide.
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Using Revenue Classes and Revenue Types 
(Administrator)

An opportunity, account, project, or campaign can be related to many different 
kinds of revenue at the same time. For instance, an opportunity might have a 
Booked revenue amount which is realized when the opportunity is closed, and that 
same opportunity might have Billed revenue amounts as services are provided to a 
customer over time. 

The Revenue Class and Revenue Type fields allow users to categorize their revenues 
for grouping, sorting, and summarization purposes. By default, the Revenue Class 
field includes values like 1-Pipeline, 2-Upside, 3-Expected, 4-Committed, and 5-
Closed. The Revenue Type field includes values like Booked, Billed, Shipped, 
Projected, Quota, and Actual.

CAUTION: Inspect the values in the Revenue Type and Revenue Class fields before 
rolling out Siebel Sales and avoid changing these lists of values after users have 
begun using Siebel Sales, as data integrity issues may result. If you must change 
these values after Siebel Sales is deployed, be sure to clean up the revenue records 
in the database that refer to the obsolete values.

For more information about setting up list of values, see the chapter that discusses 
ongoing administrative tasks in Applications Administration Guide.
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Setting Up System Preferences for Forecasting 
(Administrator)

You can create forecasts on the client or the server. For mobile (local database) 
users, create forecasts on the client. For connected (zero footprint) users, create 
forecasts on the server. The system preference “Forecast: Use Server” has no impact 
on forecasts in these two cases. 

When you use the Siebel mobile client in a connected mode, the system preference 
“Forecast: Use Server” determines whether the forecast is run on the server. By 
default, it is set to FALSE. If TRUE, you can run forecasts on the server instead of the 
client when your mobile users are operating in a connected mode. 

Before changing this setting, make sure that you provide the correct information in 
the configuration (.cfg) files on each client machine. In the ServerDataSrc section, 
make sure that you provide the correct settings for the GatewayAddress, 
EnterpriseServer, and RequestServer. 

You should also make sure that the Forecast Service Manager server component is 
enabled on enough application servers (at least one) to handle the amount of people 
who will forecast. The Forecast Service Manager server component is a batch mode 
server component used to submit forecasts to the server when Forecast: Use Server 
Task system preference is enabled, when forecasts are not running on a local 
database, and when the user is either a manager or the view mode is other than My. 
The Forecast Service Manager server component allows users to create forecasts on 
the server in the background. In general it is a good idea to enable this server 
component. One reason not to enable it is if your forecasts are very small and can 
be done while a user waits. As such, if your organization will be creating corporate 
snapshots, or forecasts with details, the server component should be enabled.

For more information about setting system preferences, see the chapter that 
discusses ongoing administrative tasks in Applications Administration Guide.

NOTE: If you use Resonate, you do not need to specify the RequestServer parameter.
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You can accept the default forecast series provided with Siebel Forecasting or create 
new forecast series.

A forecast series defines the rules for forecasting in Siebel Forecasting. Typically, a 
forecast series involves a unique group of individuals with some unique set of 
forecasting requirements. The following example illustrates the concepts involved 
in the forecast series. 

At company XYZ, the sales organization consists of district managers who forecast 
aggregate revenues once a week. The sales managers and executives have requested 
that each sales representative list their opportunities and provide a committed total 
which may or may not equal the sum total of the opportunities that they have listed.

The manufacturing organization at this same company wants a monthly snapshot 
of what is in the pipeline, at a product line level, without allowing sales 
representatives or sales management to make adjustments. They want to see how 
the forecast changes from month to month, and want access to historical 
information on earlier months’ forecasts.

In this situation, the administrator might set up two separate forecast series: one 
series would be for the sales representatives and the other would be for 
manufacturing. The sales forecast series would have a weekly frequency, with every 
sales representative as a participant, and a search specification that finds only 
opportunity revenue records. The manufacturing forecast series would have a 
monthly frequency, an administrator or manufacturing manager as the participant, 
and a search specification that finds just product specific revenue records.
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In general, a small number of forecast series is better than a large number of 
forecast series. It is easier to maintain and explain just two or three forecast series 
rather than 10 or 12. In the preceding example, the administrator would not want 
manufacturing product managers and sales managers both creating forecasts in the 
same series because they would end up double-counting the revenues involved. 
(The product managers would count an opportunity once as a set of products. The 
sales representatives would end up counting that opportunity twice.) 

NOTE: If you think you may end up double-counting, or if your company has groups 
with fairly different requirements, or you have overlays, you may want to consider 
adding additional forecast series.
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Business Scenario for Forecasting Setup
This scenario is an example of a process performed by a forecast administrator. Your 
company may follow a different process according to its business requirements. 

The forecast administrator has been told to create a number of different forecast 
series that the company will use for different sets of business requirements. He 
needs to create a forecast series and include search specs, forecast dates, and 
forecast participants or organizations. He creates a number of different forecast 
series: a personal forecast series with details, a personal forecast series without 
details, a global forecast series, a departmental forecast series, a hybrid forecast 
series, and a partner forecast series. 

For each of the forecast series the administrator has created, the auto-forecast 
feature is turned on by default. This means that whenever a manager creates a 
forecast, any absentee subordinates’ forecasts are created automatically. He decides 
to turn off this feature for the global forecast series. 

Spreadsheet views will help end users to better work with revenues and forecasts. 
Spreadsheet views are set up automatically in the default Siebel application so that 
end users can view revenue data for revenues and forecasts. In order to for end 
users to access spreadsheet views with additional or different data such as revenue 
and best case or quantity or price, the administrator needs to configure these views.

Finally, the administrator sets up the forecast series dates to move ahead 
automatically, to make it easier for users when they need to create the same 
forecast month after month. Setting up the dates to move ahead means that end 
users do not have to manually change the dates each time they create a forecast 
using this forecast series.

NOTE: This scenario, and the examples used throughout this chapter, illustrates the 
function of Siebel Forecasting in various customer environments. Each forecast 
series described addresses a different approach to forecasting and a different set of 
business requirements. Usually, no single company would create every one of these 
different forecast series.
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Example Process for Forecasting Setup
This is an example of a process an administrator might follow to set up forecasting. 
Your company may follow a different process according to its business 
requirements.

1 Create a forecast series. For information, see “Creating a Forecast Series 
(Administrator)” on page 48.

2 Create search specs for a forecast series. For information, see “Creating Search 
Specs for Forecast Series (Administrator)” on page 51.

3 Define a forecast series date. For information, see “Defining Forecast Series Dates 
(Administrator)” on page 53.

4 Add a forecast series participant. For information, see “Adding Forecast Series 
Participants (Administrator)” on page 55.

5 Add a forecast series organization. For information, see “Adding Forecast Series 
Organizations (Administrator)” on page 56.

6 Create a personal forecast series with details. For information, see “Creating a 
Personal Forecast Series With Details (Administrator)” on page 57.

7 Create a personal forecast series without details. For information, see “Creating a 
Personal Forecast Series Without Details (Administrator)” on page 59.

8 Create a global forecast series. For information, see “Creating a Global Forecast 
Series (Administrator)” on page 62.

9 Create a departmental forecast series. For information, see “Creating a 
Departmental Forecast Series (Administrator)” on page 64.

10 Create a hybrid forecast series. For information, see “Creating a Hybrid Forecast 
Series (Administrator)” on page 66.

11 Create a partner forecast series. For information, see “Creating a Partner Forecast 
Series (Administrator)” on page 68.

12 Inactivate auto-forecast. For information, see “Inactivating Auto-Forecast 
(Administrator)” on page 69.
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13 Configure a spreadsheet. For information, see “Revenue and Forecast Spreadsheet 
Configuration (Administrator)” on page 70.

14 Change the configuration of a spreadsheet applet for a new view. For information, see 
“Changing the Configuration of Spreadsheet Applets for New Views 
(Administrator)” on page 72.

15 Configure spreadsheet scrolling buttons. For information, see “Configuring 
Scrolling Buttons on Forecast and Revenue Spreadsheets (Administrator)” on 
page 76.

16 Add a dynamic column to a spreadsheet. For information, see “Adding a Dynamic 
Column to the Spreadsheet (Administrator)” on page 80.

17 Move forecast dates ahead automatically. For information, see “Moving Forecast 
Dates Ahead Automatically (Administrator)” on page 82.
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Creating a Forecast Series (Administrator)
The following procedure explains how to create a forecast series.

To create a forecast series

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 In the More Info form, click New.

3 Fill in the fields, using the following table as a guide.

Field Name Comments

Name Typically gives some insight as to how the forecast series 
is used, what the forecast series includes, or how often it 
is run.

Auto Forecast Search Spec Determines which revenue items are automatically 
included when a forecast is created. If a query is not 
specified here, then the sales representative’s revenue 
records (within the applicable date range) are included in 
the forecast. For more information, see “Auto Forecast 
Search Spec and Associate Search Spec” on page 51.

Associate Search Spec The filter that is applied to the Add New Records list on 
the Forecast Details view. This field determines which 
revenue items the end user can manually add to a 
forecast. For more information, see “Auto Forecast Search 
Spec and Associate Search Spec” on page 51.

Rollup Search Spec Indicates which detail records are included in the forecast 
summary amounts. The Rollup Search Spec can vary 
from one forecast series to another, and may be based on 
revenue type, revenue class, probability, or any other field 
on the forecast detail record.

Tip: For Rollup Search Spec to pull in fields, the field 
needs to come from the Forecast 2000 -- Forecast Item 
Detail flat business component, not revenue. For 
example, the committed spec is [Commit] = ‘Y’. 
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Active Indicates whether the forecast series is available for 
forecasting purposes to anyone listed in the Forecast 
Series Participants list on the dates indicated on the 
Forecast Series Dates list. By default, this box is checked.

Detail Depth Choices are: Revenue Detail and Summary Only. 
Determines whether the user’s forecast details are copied 
into the manager’s forecast or simply summarized in a set 
total. The default value for this field, Summary Only, is 
the recommended setting for most customers.

Visibility This is the visibility mode applied to the revenue table in 
the selection of forecast records. Choices are: My 
Revenues, My Team’s Revenues, All, and All Across 
Organizations. (These views are described in Table 3 on 
page 50.)

The default value for this field is My Revenues.

Public Access Read-only. When checked, allows each employee within 
the selected organization to access the forecast and create 
a forecast. It is only selected when an organization is 
added.

Interval When used in conjunction with the Interval Period Type 
field, this field determines the default amount of time that 
passes between forecasts of a given series. The default 
interval is 1, meaning that forecasts in this series have an 
interval of one unit of time indicated by the Interval 
Period Type.

Interval Period Type The type of forecast interval period (includes Day, Week, 
Month, Year, and Quarter). The default type is Month.

Summary Period Type Determines the buckets into which revenues are 
aggregated for each forecast in this series. Choices are 
based on period types and may include periods from a 
day to a year. The default type is Month, meaning that the 
Forecast Summary view shows monthly totals.

Field Name Comments
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4 Add dates and participants.

For instructions, see “Defining Forecast Series Dates (Administrator)” on 
page 53 and “Adding Forecast Series Participants (Administrator)” on page 55.

NOTE: A hybrid forecast uses My Revenues and My Team’s Revenues simultaneously 
by adjusting the Visibility field in the Forecast Series Participants view. For more 
information about hybrid forecasts, see “Creating a Hybrid Forecast Series 
(Administrator)” on page 66.

Table 3. Forecast Visibility

Visibility Description

My Revenues This mode allows the forecast access only to records assigned to the 
sales representative who owns the revenues that are included in the 
forecast. My Revenues is used for standard forecasts.

My Team’s 
Revenues

This mode allows the forecast access to each revenue record attributed 
to the end user’s subordinates. This mode is recommended for 
departmental or group forecasts in which a manager wants a snapshot 
of the revenues attributed to their department or group.

Use caution when using the My Team’s Revenues setting; limit the 
number of participants to only one level of the forecast tree (that is, only 
directors or only VPs or only first level managers). If a manager and a 
subordinate are both listed as participants in a forecast series with this 
setting, the subordinate’s revenue records are counted at least twice: 
once at the subordinate level and then a second time at the manager’s 
level, and so on up the tree for every level in which there is a participant 
listed.

All This mode allows the forecast access to each revenue record within the 
organization. This mode is recommended for organizational snapshots, 
in which just one person (typically an administrator) creates one 
forecast with a snapshot of each forecastable revenue record within that 
organization.

All Across 
Organizations

This mode allows the forecast access to each revenue record in the 
Siebel database, across all organizations. This mode is recommended for 
global snapshots, in which just one person (typically an administrator) 
creates one forecast with a snapshot of each forecastable revenue record 
within the Siebel database.
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Creating Search Specs for Forecast Series 
(Administrator)

The following section explains how to build an Auto Forecast Search Spec and an 
Associate Search Spec.

Auto Forecast Search Spec and Associate Search Spec
The Auto Forecast Search Spec determines which revenue line items are 
automatically copied into the forecast when it is created. The Associate Search Spec 
determines which revenue line items can be manually added to the forecast by the 
sales representative after the forecast has been created. The Auto Forecast Search 
Spec and the Associate Search Spec can vary from one forecast series to another, 
and may be based on revenue type, revenue class, probability, or any other field on 
the revenue record. The end user sees the results of the Associate Search Spec 
displayed as a list of records in the Add New Records pop-up on the Forecast Details 
form.

The Auto Forecast Search Spec uses the same syntax and grammar that the 
Associated Search Spec uses. However, it is usually more restrictive in scope. For 
example, you can create a forecast series with the following search specifications:

Associate Search Spec: [Revenue Type] = 'Shipped' or [Revenue 
Type] = 'Booked'

Auto Forecast Search Spec: ([Revenue Type] = 'Shipped' or [Revenue 
Type] = 'Booked') and [Committed] = 'Y'

In this example, the end user can manually copy into the forecast any revenue 
record with a Revenue Class of Shipped or Booked, whether it is committed or not. 
However, the automatically included forecast details only include revenue records 
that were actually marked as committed.

As in this example, typically the Associate Search Spec is slightly less restrictive 
than the Auto Forecast Search Spec, allowing end users to copy into their forecast 
some revenue records that did not meet the more restrictive Auto Forecast Search 
Spec criteria.
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Table 4 shows some common search specs.

NOTE: Test the search spec before deploying the forecast. To test the spec, navigate 
to the Revenues screen and create a new query. Type or paste the exact search spec 
into the Description field in the query and then run the query to see if it delivers 
the correct results.

Table 4. Common Forecast Search Specs

Search Spec Description

[Committed] = 'Y' Allows the end user to add committed revenue records.

[Committed] = 'Y' 
and ([Revenue 
Type] = 'Shipped' 
or [Revenue Type] 
= 'Booked')

Allows the end user to add committed revenue records with 
Revenue Types of Shipped or Booked.

[Calculated 
Primary Flag] = 
'Y'

Allows the end user to add only primary revenue records into 
the forecast. Each opportunity has one primary revenue record 
associated with it. The primary revenue line includes the 
revenue amount for the opportunity as a whole. The 
opportunity can have other revenue records, but those line 
items have [Calculated Primary Flag] set to null or ‘N’.

[Partner] is NULL Allows the end user to manually add revenue records in which 
the partner field is null.

[Product] is NULL Allows the end user to manually add revenue records in which 
the product field is null.
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Defining Forecast Series Dates (Administrator)
Forecast series dates determine when each forecast of that series occurs. Create a 
record in the Forecast Series Dates view for each date a forecast is to be run in that 
series. Forecasts typically occur according to a set pattern or frequency (for 
example: weekly, monthly, or quarterly) determined by the Interval and Interval 
Period Type fields in the Forecast Series form, and include some range of revenue 
records (for example, January 1 through June 30).

Forecasts can be static, with the end user almost always seeing the same range of 
dates, or rolling, with the end user seeing the effective date range for the forecast 
move each week or month. Typically, forecasts within a series involve some set 
amount of time, covering a range of six months or one year.

The forecast Start Date, End Date, History View Date, and History Edit Date are 
established using entries in the Siebel Periods table (see “Using the Periods Table 
(Administrator)” on page 36). While the Start Date and End Date provide the range 
of dates for active (future) forecasting, the History View Date and History Edit Date 
provide the range of dates for historical forecasting. The historical information 
allows the end user to spot trends in opportunity-, account-, or product-related 
revenues when creating a forecast.

To define dates for a forecast series

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 In the Forecast Series list, select the forecast series for which you want to define 
dates.

3 Click the Forecast Series Dates view tab.

4 In the Forecast Series Dates list, click New.
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5 Fill in the fields, using the following table as a guide.

NOTE: When you change the value in the Start Date field, the value in the End Date 
field is updated automatically. However, when you change the value in the End Date 
field, the value in the Start Date field remains the same.

TIP: To produce multiple forecast start dates, you can copy the first record and it 
automatically moves the forecast date forward according to the defined interval.

Field Name Comments

Archive Date The Archive Date should be used only to freeze a forecast 
snapshot completely so that it can be pulled into the Siebel 
Analytics data warehouse. Once the forecast has passed the 
archive date, the forecast is not editable or usable and the archive 
date is not editable as well.

Description This field can be used for comments related to the forecast.

End Date The end of the date range for a selected forecast. The last date for 
which revenues should be pulled into the forecast.

Forecast Date The date for which the forecast is being created. Typically, this is 
the beginning or end of some logical period. Some organizations 
forecast on the first of every month. Other organizations forecast 
at the end of each week.

History Edit Date The first date for which forecast information is editable. Typically, 
the History Edit Date occurs a period or two before the Forecast 
Start Date. This allows a user to fill in actuals from the earlier 
period during the current forecast.

History View Date The first date for which forecast information appears in the 
forecast. The periods between this date and the History Edit Date 
are read-only. This allows users to view their earlier month’s 
performance when creating a new forecast.

Start Date The beginning of the date range for a selected forecast. This is the 
first date for which Siebel Forecasting pulls revenue records into 
the forecast.
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Adding Forecast Series Participants (Administrator)
The Forecast Series Participants view lists the employees who will participate in the 
forecast series. The participant determines: 

■ Whether an employee can create a forecast within a given series. 

■ The list of individuals for whom an auto-forecast is created when a manager 
creates a forecast.

Although the Forecast Series Participants view appears person-based, it is actually 
position-based. As employees move from one job to another, Siebel Forecasting 
maintains the correct participant links.

To add participants to a forecast series

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 In the Forecast Series list, select a series.

3 Click the Forecast Series Participants view tab.

4 In the Forecast Series Participants list, click the menu button, and then click 
New Record.

5 In the Add Participants dialog box, select participants, and then click OK.

The new participants are added to the Forecast Series Participants list. 
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Adding Forecast Series Organizations (Administrator)
The Forecast Series Organizations view lists the organizations who will participate 
in the forecast series. It is useful when you are creating a forecast for a large set of 
participants. Like the Forecast Series Participants view, the organization 
determines: 

■ Whether an employee can create a forecast within a given series. 

To add an organization to a series

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 In the Forecast Series list, select a forecast series.

3 Click the Forecast Series Organizations tab.

4 In the Forecast Series Organizations list, click the menu button, and then click 
New Record.

5 In the Add Organization dialog box, select the organization, and then click OK.

The new organization is added to the Forecast Series Organizations list. Note 
that the Public Access checkbox is now selected.

NOTE: Organization-defined forecasts do not use auto-forecast as this could cause 
confusion in very large organizations. Because auto-forecast is not enabled for 
organization-defined forecasts, make sure that your forecast series process allows 
that end users create their own forecasts or that managers create and add absentee 
forecasts when appropriate.
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Creating a Personal Forecast Series With Details 
(Administrator)

The personal forecast with details assumes that sales representatives and their 
managers want to participate in the forecasting process. After a personal forecast is 
created, other managers are allowed to adjust the forecast. The personal forecast 
with details is an example of a rollup forecast.

The personal forecast with details:

■ Is hierarchical and structured, allowing visibility to an entire organization’s 
forecast efforts. 

■ Rolls up from the bottom to the top of an organization.

■ Allows sales representatives, sales managers, and their subordinates to create 
their own forecasts.

Use the personal forecast with details if:

■ Your company has a small number of opportunities with high revenue potential. 

■ Managers are involved with every aspect of the opportunities and want the 
ability to change a forecast’s line items.

■ You want to be able to view several forecasting perspectives.

Do not use the personal forecast with details if:

■ Management is not interested in an opportunity’s specific details.

■ The amount of work involved with creating the forecast has no real advantage.
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Example: A sales representative creates a forecast for an opportunity that is 
predicted to be worth $1 million dollars and will close in January. The sales 
representative’s manager can review the forecast, and change the value of the 
opportunity and the closing date. The manager’s manager can review the forecast 
and make additional changes. See Figure 1 for an illustrated example of this 
process.

To create a personal forecast series with details

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 Create a forecast series.

For information, see “Creating a Forecast Series (Administrator)” on page 48.

3 In the Forecast Series list, select the newly created forecast series.

4 From the Detail Depth drop-down list, select Revenue Details. 

This causes the end user’s forecast detail records to be copied into his or her 
manager’s forecast without being summarized.

5 From the Visibility field, select My Revenues.

This limits the end user’s forecast to his or her own revenue records.

6 Click the Forecast Series Dates view tab and add forecast dates.

For information about adding dates, see “Defining Forecast Series Dates 
(Administrator)” on page 53.

7 Click the Forecast Series Participants view tab and add the appropriate end 
users.

For information about adding participants, see “Adding Forecast Series 
Participants (Administrator)” on page 55.

Figure 1. Example of a Forecast Process
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Creating a Personal Forecast Series Without Details 
(Administrator)

The personal forecast without details allows sales representatives and managers to 
participate in the forecasting process. The personal forecast without details is an 
example of a rollup forecast.

The personal forecast without details offers a compromise between the global 
forecast and the personal forecast with details. It is faster than the personal forecast 
with details, while allowing less intervention and adjustment.

The personal forecast without details:

■ Rolls up from the bottom to the top of an organization, one level at a time.

■ Automatically creates missing subordinate forecasts when the manager 
forecasts.

■ Summarizes subordinates’ forecast information for the manager.

■ Allows a manager to prorate an end user’s contribution to the manager’s 
forecast totals.

■ Provides the manager with forecast details for subordinates only when they drill 
down into the subordinate’s forecast record.

The sales managers may not be especially concerned about the details; they are 
primarily interested in the revenue potential of each subordinate. 

Like the personal forecast with details, the personal forecast without details has 
many participants, each of whom must create a forecast or have one created for 
them. In large organizations, this approach to forecasting can take a long time, as 
each level of the reporting structure needs some time to create, review, and adjust 
their forecasts.

NOTE: Personal forecasts tend to have fairly high maintenance requirements. 
Although the participant lists are position-based, they still require updating as 
positions are added or removed from the Siebel application.

Use the personal forecast without details if:
Version 7.5, Rev. A Siebel Forecasting Guide 59



Forecasting Setup

Creating a Personal Forecast Series Without Details (Administrator)
■ Managers will only adjust the total revenues, and not the sales representative’s 
forecast details.

■ There are many opportunities, with fairly low revenue amounts.

■ Managers want the forecast summaries rolled up on a monthly basis. 

Do not use the personal forecast without details if:

■ Managers need to be more involved with opportunities.

■ Managers need to adjust the details without the end user’s knowledge.

Because the managers do not have access to the details, they cannot change the 
details. Managers can only add a subordinate’s contribution to their forecast. 
Forecast details are revenue line items, and there is a forecast summary that is 
rolled up monthly.

Example: Company XYZ closes a large number of opportunities each quarter. Each 
opportunity has a small dollar value. The managers are rarely involved in these 
opportunities, and would prefer summary level information to seeing every detail. 
The manager and the sales representative review the Revenues list view on a 
regular basis and make their changes directly in that view. The managers want to 
see, for each of their subordinates, a monthly commit number which is somewhat 
arbitrary and not always based on the end user’s forecastable revenues for that 
forecast period.

To create a personal forecast series without details

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 Create a forecast series.

For information, see “Creating a Forecast Series (Administrator)” on page 48.

3 In the Forecast Series list, select the newly created forecast series.

4 From the Detail Depth drop-down list, select Summary Only. 

This causes the end user’s forecast detail records to be summarized in the 
manager’s forecast.
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5 From the Visibility drop-down list, select My Revenues.

This restricts the end user’s forecast to his or her own revenue records.

6 Click the Forecast Series Dates view tab and add forecast dates.

For information about adding dates, see “Defining Forecast Series Dates 
(Administrator)” on page 53.

7 Click the Forecast Series Participants view tab and add the appropriate end 
users.

For information about adding participants, see “Adding Forecast Series 
Participants (Administrator)” on page 55.
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Creating a Global Forecast Series (Administrator)
The global forecast allows a user to take a snapshot of the corporate revenues that 
qualify for forecasting. Organizations using the global forecasting approach place a 
high level of emphasis on the Revenues screen, and a low level of emphasis on the 
Forecasting views. The global forecast is an example of a corporate snapshot type 
of forecast.

The global forecast:

■ Allows an individual user to take a snapshot of corporate revenues. 

■ Does not require user or management intervention.

■ Captures the revenue that meets the forecast series criteria, including partner 
and third-party related revenues.

■ Avoids a lengthy and involved adjustment process as forecasts are rolled from 
manager to manager to executive.

Sales managers and executives review revenues in real time using queries in the My 
Team’s Revenues view. Using this view, sales managers conduct their weekly or 
monthly one-on-one meetings with their account managers or sales representatives, 
before the global forecast. 

The sales manager, along with the sales representative, adjusts the revenues, close 
dates, win probabilities, and commit statuses in the Revenues view so that the sales 
representative and the manager have a single consensus opinion on the revenue 
items that end up in the forecast. They finish this process before the deadline of the 
corporate forecast. 

As administrator, you create the forecast and make it available to high-level 
managers and executives from the All Forecasts view.

Use global forecasts if:

■ Your sales representative is likely to have the most accurate perspective on the 
value of an opportunity, account, partner, project, or product line over time. 

■ The manager is unlikely to adjust the sales representative’s forecast, or if the 
manager is able to adjust the sales representative’s projected revenues before 
the creation of the corporate forecast.
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■ You want to reduce the amount of overhead and time spent in forecasting.

Do not use global forecasts if:

■ The manager wants the opportunity to adjust revenues without the sales 
representative’s knowledge.

■ It is very important for sales representatives to actually visit the forecast form 
and submit their forecasts to a manager.

■ Sales representatives must make a revenue commitment that is different from 
the sum of the revenue line items they are tracking in Siebel.

To create a global forecast series

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 In the Forecast Series list, select the forecast that is to become global.

If you need to create a new forecast series, see “Creating a Forecast Series 
(Administrator)” on page 48.

3 From the Visibility drop-down list, select All or All Across Organizations.

This causes the manager’s view to include each of the subordinates’ revenue 
records.

4 Click the Forecast Series Dates view tab and add forecast dates.

For information about adding dates, see “Defining Forecast Series Dates 
(Administrator)” on page 53.

5 Click the Forecast Series Participants view tab and add one or more forecast 
series participants, such as yourself or another administrator who will run the 
forecast for the company.

For information about adding participants, see “Adding Forecast Series 
Participants (Administrator)” on page 55.
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Creating a Departmental Forecast Series (Administrator)
The departmental forecast can be used as a supplement to other forecasting 
methods mentioned in this chapter. In many companies, the global forecast may 
only be available to a few individuals. The departmental forecast provides 
divisional or departmental managers with a way of taking a snapshot of their 
revenues for historical or analytical purposes. The departmental forecast is an 
example of a corporate snapshot type of forecast.

The departmental forecast:

■ Allows an individual user to take a snapshot of each departmental revenue at 
once. 

■ Requires no end user or management intervention.

■ Captures each revenue that meets the forecast series criteria, including partner 
and third-party related revenues.

■ Avoids a lengthy and involved adjustment process as forecasts are rolled from 
manager to manager to executive.

Compared to the personal forecasts, the departmental forecast requires a very low 
amount of overhead and almost no administration. It gives timely information with 
no requirement for intervention and adjustment.

Example: At company DEFG, there is an overlay sales group for every product line.  
The managers of these sales groups need periodic snapshots of their product 
specific revenues. Although each manager runs a small business, no individual 
manager is allowed to see how the other product lines are doing. When the 
managers do not think a revenue item is realistic, they ask the end user to change 
it. The end user’s committed forecast total is equal to the sum of each of their 
revenues that meet the company’s forecasting rules.

Use the departmental forecast if:

■ One manager wants to forecast for an entire team.

■ Periodic snapshots of data are necessary. 

Do not use the departmental forecast if:
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■ Data needs to be rolled up, or different levels of management need access to the 
snapshot.

■ You do not need a midmanagement view of forecasting.

To create a departmental forecast series

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 Create a forecast series.

For information, see “Creating a Forecast Series (Administrator)” on page 48.

3 In the Forecast Series list, select the newly created forecast series.

4 From the Visibility drop-down list, select My Team’s Revenues.

This causes the manager’s view to include each of the subordinates’ revenue 
records.

5 Click the Forecast Series Dates view tab and add forecast dates.

For information about adding dates, see “Defining Forecast Series Dates 
(Administrator)” on page 53.

6 Click the Forecast Series Participants view tab and add a few forecast series 
participants, including only one level of the hierarchy.

For information about adding participants, see “Adding Forecast Series 
Participants (Administrator)” on page 55.
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Creating a Hybrid Forecast Series (Administrator)
A hybrid forecast allows you to have My Revenues and My Team’s Revenues 
visibility in the same Forecast series, thus combining a rollup and departmental 
snapshot forecast.

The hybrid forecast:

■ Allows for a forecast process to include both a rollup forecast and a 
departmental forecast in the same forecast series.

Use the hybrid forecast if:

■ One manager does not want or cannot have his subordinates create a formal 
forecast each period, yet another manager wants to have his subordinates run a 
formal forecast rollup.

Do not use the hybrid forecast if:

■ Both managers want either just a rollup or departmental forecast.

To create a hybrid forecast series

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Forecast Administration.

2 Create a forecast series.

For information, see “Creating a Forecast Series (Administrator)” on page 48.

3 In the Forecast Series list, select the newly created forecast series.

4 Click the Forecast Series Participants view tab and add the appropriate end 
users.

For information about adding participants, see “Adding Forecast Series 
Participants (Administrator)” on page 55.
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5 Once you have added a participant, choose their visibility from the Visibility 
drop-down list by selecting either My Revenues or My Team’s Revenues.

CAUTION: Do not select My Team’s Revenues for a manager that has included a 
participant as this results in double-counting.

NOTE: If you cannot see the Visibility field in the Forecast Series Participants list, 
check to see which columns are being displayed.
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Creating a Partner Forecast Series (Administrator)
Siebel Forecasting supports numerous partner forecasting scenarios. These 
scenarios include rollup forecasts, forecasts run by the partner only, forecasts of 
each partner, and forecasts of individual partner organizations. For details on 
setting up forecast series to support each of these scenarios, see Siebel Partner 
Relationship Management Administration Guide.
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Inactivating Auto-Forecast (Administrator)
By default, the system preference “Forecast: Auto-Forecast” is set to true. This 
means that if you are a manager, when you forecast, the application automatically 
creates forecasts for subordinate’s who are listed as participants of that series that 
have not already forecasted. You can disable this feature if you want.

To inactivate auto-forecast

1 From the application-level menu, choose View > Site Map > Application 
Administration > System Preferences.

2 In the System Preferences list, select the Forecast: Auto-Forecast record.

3 Change the System Preference Value to FALSE.

4 Restart the server.
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Revenue and Forecast Spreadsheet Configuration 
(Administrator)

Spreadsheets in Siebel applications allow the end user to view a list of values 
consolidated into a more concise format. For example, instead of seeing a long list 
of services delivered over a period of many months, the end user sees just one row 
of information with the revenues listed out over time, with a series of dates as 
column headers. 

The revenue spreadsheets are combined with revenue lists and revenue charts in 
Revenues views. You can move between the different displays by selecting the 
desired display from the Show drop-down list in a Revenues view. This ability to 
view information in a variety of formats (list, chart, or spreadsheet) is useful when 
dealing with recurring revenues over time. This is especially true in cases where 
multiple products, employees, or revenue classes are involved in one user view.

Revenue and forecasting forms, lists, and charts are configured in Siebel Tools, 
using the standard properties and configuration techniques typically used for forms, 
charts, and lists. You can add columns, remove columns, change column headings, 
and apply calculations in Siebel Tools, using the same approach that you would use 
for almost any other Siebel applet. 

Some revenue and forecast data displays in a spreadsheet-like applet. Spreadsheet 
applets are configured differently from forms, lists, and charts. This section 
explains how to make changes to Revenue and Forecasting spreadsheet applets.

Spreadsheet Column Types
Revenue and forecasting spreadsheets contain a set of static, or nonrepeating, 
columns on the left, followed by a set of dynamic, or repeating, columns on the 
right. In the default Siebel application configuration, the Opportunity Revenues 
spreadsheet view consists of static columns including the Product Name and the 
Revenue Class on the left, followed by a repeating Revenue field on the right. The 
Revenue field is a dynamic column that repeats once for each date in the 
Opportunity Revenues list.
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You can configure both the static columns and the dynamic columns in the 
spreadsheet using Siebel Tools. You can add, hide, or change the order of columns 
in the spreadsheet. While the default configuration has just one repeating column, 
it is possible to have several repeating columns such as quantity, price, and 
revenue, or to have just margin and revenue, for example.

The Add Column button in the spreadsheet view allows users to dynamically add 
a new date column. The new column must be a valid date, such as 1/1/01. After 
the creation of the new date column, a new revenue record in the List view is 
automatically created with the appropriate default values consistent with the parent 
record, for instance Opportunity Name or Account Name.

Spreadsheet Groups
In the Opportunity and Account Revenue screens, when users click the Revenues 
view tab, the items in the spreadsheet are automatically grouped together using a 
field called Dynamic Group Number. Items entered in the spreadsheet on the same 
row automatically receive the same Dynamic Group Number. Although these items 
are really individual records in the Revenue list and the Revenue table, they are 
grouped together in the spreadsheet using the Group Number. In the Forecasting 
views, it is the Forecast Item ID that ties the items in a row together.

When a user enters a value into a repeating cell in a Revenue and Forecasting 
spreadsheet view, a revenue record is automatically created with the appropriate 
default values. Typically, the default values include the static information in the 
spreadsheet, plus a few additional attributes. Changing the static values in the list 
can cause a revenue item to look different from other members of its group. In the 
default configuration of Siebel Sales, such records are automatically moved into 
their own groups. Changes to static values in the spreadsheet are automatically 
propagated to each of the corresponding revenue records. While the general 
behavior of the spreadsheet and list applets has already been defined, you can 
configure the content of these applets to meet end-user requirements.
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Changing the Configuration of Spreadsheet Applets for 
New Views (Administrator)

The following procedure explains how to change the configuration of a spreadsheet 
applet so that end users can use spreadsheets in views other than Revenues, 
Forecasts, or Time Sheets.

To change the configuration of a spreadsheet applet 

1 Identify the business component that includes the static information of the 
spreadsheet. This is the primary business component.

2 Identify the business component that includes the dynamic information of the 
spreadsheet. This is the data business component.

NOTE: In some cases, the primary business component already exists in Siebel 
Sales, while the data business component has to be created or modified so that 
it includes the columns that you want displayed in a repeating fashion.

3 The primary and data business components may sit on the same table. If they 
do, the property DC Data SameAsPrimary must be set to Y. The primary 
business component must include the subclass CSSBCDynCol. The Data 
Business component must include a subclass CSSBusiness component. 

4 Configure the display applet to include the static columns and a required control 
called eDynamicColumns. This control acts as a placeholder for the data 
business component columns. Make sure that the primary business component 
is based on a subclass of CSSBCDynCol.

5 For the primary business component, configure a Web applet based on 
CSSSWEFrameDynCol (or subclass of CSSSWEFrameDynCol). Include controls 
for the static fields, followed by the eDynamicColumns control.
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6 Configure the business components.

The following table gives instructions for configuring the user properties on the 
primary business component.

User Property Value Description

Dynamic Columns 
Enabled

Dynamic Columns 
Enabled

Required. Indicates that the applet 
uses the dynamic columns feature.

DC Pri RowKey A field on the primary 
business component

Required. The primary key for 
grouping the items together on the 
same row in the spreadsheet. 

For example, in the Opportunity 
Revenues spreadsheet view, this 
property is Dynamic Group Number.

DC 1 Data BCName The name of the data 
business component

Required. This business component 
must be in the same BusObj as the 
primary business component. 

DC 1 Data 
DynColRowKey

Row name Required. Indicates in which 
spreadsheet row a data record 
appears, by matching 
Data.[DynColRowKey] with 
Primary.[DynColRowKey].

For example, in the Opportunity 
Revenues view, the DynColRowKey is 
the same as the DC Pri RowKey 
(Dynamic Group Number). However, 
in the Forecast Details view, these 
values are different.

DC 1 Data 
DynColHdrKey

Field name Required. Indicates the data to be 
displayed as headers on recurring 
columns of the spreadsheet.

For example, in the Opportunity 
Revenues view, the field name is Date, 
so each date in the group causes a new 
column to be displayed.
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DC 1 Data 
DynColCellValue

Field, Model Required. Field identifies the data to 
be displayed as the cell value in the 
spreadsheet. Model identifies the field 
on the primary business component 
that provides cell formatting 
information.

DC 1 Data SubCol 
N (N ≥ 1)

Field, Model Use this property if you want to 
display more than one repeating 
column.

Field identifies another column to be 
displayed after the column indicated 
by DynColHdrKey. Model identifies the 
field on the primary business 
component that provides formatting 
information for this field.

DC 1 DataLink Link Specifies the link to be used for driving 
records to be displayed in the 
spreadsheet. Typically, this is the link 
between the parent of the List applet 
and the data business component.

For example, on the Opportunity or 
Account Revenues spreadsheet, this 
field is blank and the Siebel 
application uses the default parent 
link.

DC 1 Data 
SameAsPrimary

Y or N If specified and set to Y, the Data 1 
business component maps to the same 
table as the primary and uses the same 
fields for DynColRowKey, 
DynColHdrKey, DynColCellValue, and 
DynColCellValueId.

This setting is necessary in a 
spreadsheet because every row 
displayed has at least one nonempty 
cell. This implies existence of a record 
in both the primary and data business 
components that includes that row key 
(master record). When the table is the 
same, only one record is needed.

User Property Value Description
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NOTE: To configure static columns in the spreadsheet so that they make universal 
changes to each record in Group ID, modify the user properties in business 
component Revenue DynCol using Siebel Tools. Find user properties like DC 1 Data 
Field Default #, [FieldName], Primary.[FieldName]. Remove fields you do not want 
and add other fields as desired. For example, the request for Revenue Type is added 
as DC 1 Data Field Default 9, Revenue Type, Primary.Revenue Type. Also, you need 
to modify the same user properties in the business component Revenue Plan Item 
DynCol to maintain the same Dynamic Column grouping behavior.

DC 1 Data 
SearchSpec

Valid search 
specification

If specified, only records in the data 
business component that match the 
search specification are visible.

DC 1 Data SortSpec Valid sort specification The sort specification affecting the 
order of the dynamic columns in the 
spreadsheet, from left to right.

For example, in the Opportunity 
Revenues spreadsheet, this property is 
Date, causing the columns to be sorted 
in ascending order by date. To sort in 
descending order by date, use “Date 
(DESC).”

DC TotalsOnRight TRUE If specified and set to TRUE, the total 
for each row appears in an additional 
column to the right of the dynamic 
columns. 

DC 
DeleteDataRecords

Y or N Affects the behavior of the 
spreadsheet when the user deletes a 
record. It is recommended that you set 
this property to Y.

If set to Y, records corresponding to 
nonempty cells in the row are deleted.

If set to N (default), only the primary 
record for the row is deleted. The row 
no longer appears in the spreadsheet.

User Property Value Description
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Configuring Scrolling Buttons on Forecast and Revenue 
Spreadsheets (Administrator)

Scrolling buttons appear in the upper right corner of spreadsheets in both the 
Forecasts and Revenues screens. These buttons allow users to view records 
containing multiple columns. Table 5 describes the buttons:

The static columns found on the spreadsheet view such as, Opportunity, Product, 
Currency, and so on, are fixed and do not move when the date columns are 
scrolled. Similarly, persistent columns such as the Total column and any new 
columns that are added using the Add Column button are retained as the user 
scrolls. Newly added date columns are persistent until the next time the 
spreadsheet is refreshed at which time it becomes dynamic like the other date 
columns.

Administrators can enable or disable spreadsheet scrolling buttons and set the Set 
Size, which controls the number of dynamic columns to scroll at any one time, and 
the Window Size, which controls the number of dynamic columns which can be 
displayed on one screen. Window Size, as defined, does not include static or 
persistent columns.

To configure spreadsheet scrolling buttons

1 From Siebel Tools set the following values in Applet >User Properties:

Table 5. Spreadsheet Scrolling Buttons

Button Name Description

Previous column set Click to view a set number of the previous 
columns to the left.

Previous column Click to view the previous column to the left.

Next column Click to view the next column to the right.

Next column set Click to view a set number of the next columns 
to the right.
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■ DC Scrolling: Enabled 

■ DC Scrolling: Set Size (Default = 6)

■ DC Scrolling: Window Size (Default = 6)

NOTE: Set Size and Window Size should be equal so that the functionality is 
predictable to end users. If the Set Size is greater than the Window Size, some 
records that the end user might expect to see are not displayed by default. For 
example, if the SetSize = 8 and the WindowSize = 6, clicking the next column 
set button would cause the window not to display the first two columns in the 
SetSize. The user would have to click the previous column button to see those 
columns. Likewise, if the Set Size is less than the Window Size, the window will 
display more records than the user might expect. For example, if SetSize = 4, 
WindowSize = 6, using the next column set button would display the next four 
records to be returned as well as the last two columns of the existing window.

To configure scrolling buttons to jump to the end or the beginning of the 
spreadsheet

■ Set the SetSize to a large number. For example, if SetSize = 1000, the scrolling 
button will jump to the end of the spreadsheet, assuming there are fewer than 
1000 columns. The end user can then use the previous column button to see 
columns to the left.

To inactivate scrolling spreadsheet buttons

1 Locate the following applets:

■ Forecast 2000 -- Forecast Summary List Applet DC

■ Forecast 2000 -- Forecast Item List Applet DC (ExecWS)

■ Account Revenue Schedule List Applet DC

■ Opportunity Revenue Schedule List Applet DC

2 For each applet, inactivate the following Applet >User Properties:

■ DC Scrolling: Enabled

■ DC Scrolling: Set Size
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■ DC Scrolling: Window Size

3 For each applet, inactivate the following Applet >Controls:

■ GotoNextHorColumn

■ GotoNextHorSet

■ GotoPrevHorColumn

■ GotoPrevHorSet

4 For each applet, inactivate the corresponding Applet >Web Template >Web 
Template items:

■ Opportunity Revenue Schedule List Applet DC: 

❏ GotoNextHorColumn (item identifier 150)

❏ GotoNextSet (item identifier 151)

❏ GotoPrevHorColumn (item identifier 164)

❏ GotoPrevSet (item identifier 163)

■ Account Revenue Schedule List Applet DC: 

❏ GotoNextHorColumn (item identifier 150)

❏ GotoNextSet (item identifier 151)

❏ GotoPrevHorColumn (item identifier 164)

❏ GotoPrevSet (item identifier 163)

■ Forecast 2000 -- Forecast Summary List Applet DC:

❏    GotoNextHorColumn (item identifier 150)

❏    GotoNextSet (item identifier 151)

❏    GotoPrevHorColumn (item identifier 164)

❏    GotoPrevSet (item identifier 163)

■ Forecast 2000 -- Forecast Item List Applet DC (ExecWS)
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❏    GotoNextHorColumn (item identifier 150)

❏    GotoNextSet (item identifier 151)

❏    GotoPrevHorColumn (item identifier 164)

❏    GotoPrevSet (item identifier 163)
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Adding a Dynamic Column to the Spreadsheet 
(Administrator)

The following procedure explains how to add or change a dynamic column on a 
spreadsheet view. For example, end users may want to add Price and Quantity or 
Cost in addition to Revenue, which is the one dynamic column on the Revenue 
spreadsheet that is preconfigured. The following procedure uses the Quantity field 
as its example and is based on a standard configuration environment.

To add a dynamic column to a spreadsheet

1 Change the business component Revenue DynCol as follows:

a Rename the User Property: DC 1 Data SubCol 1 to DC 1 Data SubCol 1x

This is the dynamic column with the Value: Price, Price. Make sure it is set 
to inactive.

b Rename the User Property: DC 1 Data SubCol 2 to DC 1 Data SubCol 1

This is the dynamic column with the Value: Quantity, Quantity. Make this 
active (the inactive property should be FALSE).

2 Verify that the Quantity field is active on the data business component, 
Revenue. The Inactive property for this field should be FALSE.

3 Verify the following for the applet: Opportunity Revenue Schedule List Applet 
DC. The properties for the List Column, Quantity should be:

Available: TRUE

Inactive: FALSE

Show In List: TRUE

4 Verify the following for the applet: Opportunity Revenue Schedule List Applet 
DC:

a Edit the Web Layout. 

b Verify that the Quantity column is mapped into the Edit List Web template. 
(The location does not matter.)
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5 Compile the changes.

The Quantity field is visible as a dynamic column in the Revenues Spreadsheet 
view. 
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Moving Forecast Dates Ahead Automatically 
(Administrator)

In the Forecast Administration screen, when you create a new forecast series, the 
start and end dates, as well as history and edit dates, can be set up to move ahead 
automatically.

Modify the value of the user property, Auto-Set Start/End Dates in the business 
component, Forecast 2000 - Forecast Series Date. The values of the Auto-Set Start/
End Dates user property are shown in Table 6.

NOTE: This user property is set to N by default.

For a list of the user properties associated with forecasting, see “Forecasting User 
Properties” on page 160

Table 6. Values of the User Property Auto-Set Start/End Dates

Value Description

Y Copying the forecast sets the start and end dates so that the first period 
within the interval will encompass the forecast date and the interval 
will be the same length.

N Copying the forecast does not preset the start and end dates. They 
remain the same as the original that was copied.
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The Revenues screen provides users with a convenient place to perform updates for 
important information. It offers managers and sales professionals a useful, 
cumulative view of the business across a range of revenue records.

Forecasts are simply snapshots in time of revenue data. It is recommended that 
revenue information be updated on a regular basis during the course of normal 
business activities. This provides the application with the information that 
managers and executives need when they are ready to review revenues or create 
forecasts.

End users can add and analyze revenue data from the Revenues view in a number 
of screens including, Opportunities, Accounts, Projects, Partners, Products, 
Contacts, Agreements, and Campaigns.

TIP: To guarantee forecast consistency, make modifications to revenue records 
rather than adjusting a forecast. Forecasts are based on current revenue data. 
Adjustments to forecast records are not replicated in subsequent forecasts, resulting 
in extra work as the same items are adjusted week after week. Choose Update 
Revenue Item from the menu button in the Forecasts screen to make sure key 
adjustments in forecasts are updated in the live revenues.
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Business Scenario for Revenues
This scenario provides you with an example of a process performed by forecast 
administrators and sales representatives. Your company may follow a different 
process according to its business requirements.

The forecast administrator for a large company needs to make sure users can use 
the Revenues screen to analyze their revenues. If necessary, he configures revenue 
SmartScripts so that users can add recurring revenues to the application, and he 
creates revenue plan templates. SmartScripts configuration is optional and is 
already set up in the default Siebel application. He also creates a revenue template 
so that the sales representatives in his district can create sets of recurring revenues 
that include a product bundle as well as scheduled services and maintenance 
activities.

The company’s district manager manages multiple recurring revenues for each of 
his opportunities. From the Revenues view in the Opportunities screen he adds 
multiple product revenues to an opportunity using SmartScripts. He also has two 
sales representatives working on the same opportunity revenue item. As such, he 
goes into the opportunity and splits this revenue.

The vice president of sales has a number of choices for monitoring the business. 
The Revenues screen offers up-to-the-minute data on revenue opportunities across 
divisions, partners, products, and service offerings. With the aid of several 
predefined queries, the vice president can view revenues by product line or sales 
representative, margins by partner, and upside by account or opportunity. She can 
also view revenue spreadsheets and use revenue charts to gain further information 
about each revenue. When she examines the revenues, she may find that she needs 
to make modifications to some of them. She does this directly in the Revenues view, 
as she feels that making changes to revenue records rather than adjusting a forecast 
allows for more consistent forecasting.
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Example Process for Revenues
This is an example of a process for revenues. Your company may follow a different 
process according to its business requirements.

Administrator Procedures
1 Configure a revenue SmartScript. For information, see “Configuring Revenue 

SmartScripts (Administrator)” on page 86.

2 Create a revenue plan template. For information, see “Creating Revenue Plan 
Templates (Administrator)” on page 87.

End-User Procedures
3 Add a new revenue to an opportunity. For information, see “Adding a New Revenue 

to an Opportunity” on page 89.

4 Add multiple and recurring revenues using SmartScripts. For information, see 
“Adding Multiple or Recurring Revenues Using SmartScripts” on page 91.

5 Add a split revenue. For information, see “Adding a Split Revenue” on page 93.

6 Use a revenue plan. For information, see “Using a Revenue Plan” on page 94.

7 Review revenues. For information, see “Reviewing Revenues” on page 95.

8 Modify a revenue item. For information, see “Modifying a Revenue Item” on 
page 96.

9 View the revenue spreadsheet. For information, see “Viewing the Revenue 
Spreadsheet” on page 97.

10 Use revenue charts to report. For information, see “Using Revenue Charts for 
Reporting” on page 98.

11 Using revenue reports. For information, see “Using Revenue Reports” on page 99.

12 Distinguish between revenues. For information, see “Distinguishing Between 
Revenues” on page 100.
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Configuring Revenue SmartScripts (Administrator)
Using the SmartScripts Administration screen, you can edit the behavior of the 
Script command in the Revenues list. 

You can make changes to:

■ The order in which questions are asked.

■ The appearance of the questions: font style, color, and grouping of questions on 
the pages.

■ Which business object, business component, and field answers are set.

■ What questions are asked. You can only create questions that directly set 
revenue fields based on the answers. No special logic can be built on answers to 
questions you create.

You cannot make changes to:

■ The default values for questions.

■ The special logic that handles the revenue creation. (For example, questions like 
“How many revenues do you want to create?” and “Remove existing revenues?” 
and processes such as the one used to divide total revenue into periodic 
revenues.)

NOTE: If more complicated logic is desired, you can build a VB script that will be 
invoked during the execution of the SmartScript.

For information about:

■ Using the Script command, see Siebel Sales User Guide

■ Using the SmartScripts Administration screen, see Siebel SmartScript 
Administration Guide

■ Writing VB routines, see Siebel Tools Online Help
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Creating Revenue Plan Templates (Administrator)
Revenue plans allow sales managers to create predefined revenue templates that 
can be used by sales representatives to create a series of recurring revenues or a 
particular group of revenues. A predefined product or service package that consists 
of recurring revenues could be a revenue plan. The Revenue Plans view is available 
in each screen that has a Revenues view, such as Opportunities, Accounts, and 
Projects. Use revenue plans only for simple grouped revenues.

To create a revenue plan template

1 From the application-level menu, choose View > Site Map > Forecast 
Administration > Revenue Templates.

2 In the Revenue Templates list, click New.

3 Fill in the appropriate fields. Some fields are described in the following table. 

4 Click the Revenue Template Details view tab to associate the revenue line items 
with the parent template.

Field Name Comments

Units Choose from Hours, Days, Weeks, Months, 
Quarters, and Years.

Public Check the box if you want this revenue plan to be 
accessible to each user.
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5 Fill in the appropriate fields. Some fields are described in the following table.

NOTE: The multiplier is the amount by which the revenue plan revenue, price, or 
quantity is to be multiplied by. This number is defined by the end user. For 
example, if the Revenue Multiplier = 1, and the end user enters $1,000 for the 
revenue plan’s revenue, then each revenue is $1,000. If the Price or Qty have a 
multiplier, then both of these fields are changed and the revenue for that line item 
is the result of the new Price and Qty calculation. This is true even if the revenue 
multiplier is equal to one or is blank. If the revenue has a multiplier on it, it 
overrides Price and Qty changes regardless of their multipliers.

Field Name Comments

From Enter number at which specified unit begins.

To Enter number at which specified unit ends.

Price Multiplier The rate at which the price changes from the 
original price.

Qty Multiplier The rate at which the quantity changes from the 
original quantity.

Revenue Multiplier The rate at which revenue changes from the 
original revenue.

Product Enter the name of the product associated with this 
revenue item.

Sales Rep Enter the name of the sales representative 
associated with this revenue item.
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Adding a New Revenue to an Opportunity
Revenues associated with opportunities, accounts, projects, and so on appear in 
forecasts.

To add new revenue to an opportunity

1 From the application-level menu choose View > Site Map > Opportunities > 
My Opportunities.

2 In the Opportunities list, select the opportunity to which the revenue is being 
added.

3 Click the Revenues view tab.

4 In the Revenues list, click the menu button, and then click New Record.
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5 In the new record, complete the necessary fields, using the following table as a 
guide.

NOTE: End users can also add revenues from screens other than Opportunities. 
These include Accounts, Projects, Contacts, Products, Partners, Campaigns, and 
Agreements.

Field Name Comments

Commit Checking this box indicates that there is a high 
probability the deal will close and that it should be 
included in forecasts.

Product Use the selection dialog box to associate this revenue 
with a product.

Product Line Use the selection dialog box to associate this revenue 
with a product line.

Qty Enter the amount of product or service being purchased.

Price Enter the unit price of the product or service being 
purchased.

Revenue Enter the total revenue this will produce.

Probability Enter the percentage likelihood of winning this revenue 
for this opportunity.

Best Case Enter a best case estimate of what revenue will be 
produced.

Worst Case Enter a worst case estimate of what revenue will be 
produced.

Expected Revenue Number based on the value in the Probability field.

Revenue Class Choose from 1-Pipeline, 2-Upside, 3-Expected, 4-
Committed, and 5-Closed.

Revenue Type Choose from Actual, Shipped, Billed, Booked, Projected, 
and Quota.

Quote If this is checked, product revenue is included in the auto-
quote function in the Quotes module.
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Adding Multiple or Recurring Revenues Using 
SmartScripts

End users can add multiple or recurring revenues from any screen where the 
Revenues view is found, for example Opportunities, Accounts, Projects, Contacts, 
Products, Partners, and Agreements. Multiple or recurring revenues can be added 
using SmartScripts. SmartScripts are accessed by choosing Script from the menu 
button in the Revenues view. Revenues created using SmartScripts reside in the 
same spreadsheet record.

NOTE: End users can add recurring revenues from any screen that has a Revenues 
view. The Opportunities screen is used in the following procedure as an example.

To add multiple or recurring revenues using SmartScripts

1 From the application-level menu choose View > Site Map > Opportunities > 
My Opportunities.

2 Click the Revenues view tab, and click the menu button, and then click Script.

3 In the SmartScripts screen in the Revenue Schedule - Date Range form, complete 
the necessary fields, and then click Next.

4 In the Revenue Schedule - Default Values form, complete the necessary fields, 
and then click Next.

5 In the Revenue Schedule - Default Values form, complete the necessary fields, 
and then click Next.
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6 In the Revenue Schedule - Amounts form, complete the necessary fields, and 
then click Finish.

The appropriate revenue records are calculated and added to the Revenues list. 

A set of revenues created using SmartScripts includes the same Group ID and 
thus are each included in the same spreadsheet record when the end user 
navigates to the spreadsheet view.

NOTE: A substantial number of the Script’s fields may not be necessary for the end 
user’s specific needs and are not required if not marked. In addition, the script has 
a built-in calculation function. The application calculates the correct end date, 
frequency, or period. If the Replace Existing Revenues check box in the Revenue 
Schedule Default Values screen has been checked, the script function replaces only 
the items added or owned by the user. It does not replace account revenues 
associated with other positions. 
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Adding a Split Revenue
A revenue split allows an end user to forecast an opportunity revenue that is split 
between multiple sales representatives. Split revenues can only be added from the 
Opportunities screen.

To set up a revenue split

1 From the application-level menu, choose View > Site Map > Opportunities > 
My Opportunities.

2 Click the Revenues view tab.

3 From the Show drop-down list in the Revenues view, choose Splits.

4 Click New.

5 Complete the appropriate fields. For information on the fields, see “Adding a 
New Revenue to an Opportunity” on page 89.

NOTE: Once a revenue split record is created, a read-only split flag is checked in 
both the parent opportunity and the revenue line item. To include or exclude 
these records from a forecast, craft the forecast’s search specs accordingly. For 
information about creating search specs, see “Creating Search Specs for Forecast 
Series (Administrator)” on page 51.
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Using a Revenue Plan
A revenue plan allows sales managers to create predefined revenue templates that 
can be used by sales representatives to create a series of recurring revenues or a 
particular group of revenues. Revenue plan templates are created and activated by 
the Siebel administrator. Access revenue plans from any screen where Revenues 
views are found, for example Opportunities, Accounts, Projects, Contacts, 
Products, Partners, and Agreements. Revenue plans are created by the forecast 
administrator. Data updated at the parent level of the plan updates each of the child 
revenues automatically, unless locked.

■ Values entered by end users at the Revenue Plan level for quantity, price, and 
revenue are multiplied by the value in the Multiplier field defined by the 
administrator in the revenue template, and the results populate the detail 
records.

■ Use the Lock field to prevent selected revenue details from being updated.

■ Use Update All to update each record with the parent-level changes, even if the 
detail records are locked.

To use a revenue plan

1 From the application-level menu choose View > Site Map > Opportunities > 
My Opportunities.

2 Select the opportunity you want to associate with a revenue plan, and then click 
the Revenue Plans view tab.

3 Click New in the Revenue Plans list.

4 In the new record, select a revenue plan template from the Template drop-down 
list.

The applicable revenue items and proposed period appear in the Revenues 
subview beneath the Revenue Plans list.

NOTE: End users can override the revenue plan detail data as needed.
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Reviewing Revenues
The Revenues screen offers a useful management tool for monitoring the health of 
the business. With the appropriate predefined queries, this screen offers real-time 
insight to the revenue attainment status of the sales organization. End users need 
to define the search spec or define appropriate criteria for a query to select the 
correct revenue records for forecasting. For details on defining the search spec, see 
Table 4 on page 52.

End users must define the appropriate criteria for a query or search spec to identify 
the following:

■ To view only Opportunity Revenues use:

[Calculated Primary Flag] = ‘Y’

■ To view each of the Revenue line items that are not opportunities use:

[Calculated Primary Flag] = ‘N’

■ To view just product, partner, or project revenues use, for example:

[Product] is not NULL

NOTE: Once the appropriate query criteria is defined and the appropriate revenue 
records have been found, use the Charts view to further analyze the revenues.

To review My Team’s Revenues

1 From the application-level menu choose View > Site Map > Revenues > My 
Team’s Revenues.

2 Select a predefined query from the Queries drop-down list to view specific sets 
of revenue, or create your own query.

For more information on how to create basic queries, see Fundamentals.
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Modifying a Revenue Item
Making changes to revenue records rather than adjusting a forecast allows for more 
consistent forecasting. Forecasts are based on current revenue data. Adjustments to 
forecast records are not replicated in subsequent forecasts, resulting in extra work 
as the end user adjusts the same item week after week.

To modify a revenue item

1 From the application-level menu choose View > Site Map > Revenues > My 
Team’s Revenues.

2 In the Revenues list, select the revenue item you want to modify.

3 In the More Info form, change the necessary fields.
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Viewing the Revenue Spreadsheet
End users may want to display revenue information using the spreadsheet view for 
easy data entry and visibility of recurring items. Revenue spreadsheets are available 
in the following screens: Opportunities, Accounts, and Projects.

To view the revenue spreadsheet

1 From the application-level menu choose View > Site Map > Opportunities > 
My Opportunities.

2 From the Show drop-down list, select My Opportunities.

3 In the Opportunities list, select the opportunity for which the information will 
be displayed.

4 Click the Revenues view tab.

5 In the Revenues list, from the Show drop-down list, select Spreadsheet.

The information is grouped by certain product types and displayed accordingly.

NOTE: To make sure revenues are grouped in rows as intended in the 
spreadsheet, revenue data should be entered either into the spreadsheet directly, 
by using the script feature available from the menu button, or by using revenue 
plans.
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Using Revenue Charts for Reporting
The Charts view provides end users with a graphical representation which allows 
them to analyze revenue data. For example, it is possible, using the chart, to show 
opportunity revenues by month or opportunity margin by partner.

TIP: In queries, include all Calculated Primary Flag records = Y to view only 
opportunity-level revenue records. Include all Calculated Primary Flag records = N 
to view all revenue records that are not opportunities.

To view revenue in a chart

1 From the application-level menu choose View > Site Map > Opportunities > 
My Opportunities.

2 In the Opportunities list, select the opportunity with which the information will 
be displayed.

3 Click the Revenues view tab.

4 In the Revenues list, from the Show drop-down list, select Chart.

Data is displayed in graphical format. Summary values for each chart element 
are displayed when using the mouse-over feature. 

Use the By and Then drop-down lists in the Chart view to summarize data by a 
variety of segments.
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Using Revenue Reports
End users can create revenue reports from the Revenues screen and from the 
Revenues view tab in any screen. For more information about reports, see 
Fundamentals.
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Distinguishing Between Revenues
Use Revenue Type list of values (LOVs) or Channel LOVs to distinguish between 
indirect, direct, and other specially-noted revenues.

Sales representatives can select values from the Channel and Revenue Type fields 
for each opportunity or product revenue. In this way, when users run their forecast 
or a predefined query, they can view charts or reports which allow them to divide 
the data by Revenue Type or Channel.

NOTE: The Siebel administrator must add correct LOVs if there is specific 
terminology. For information about adding LOVs, see the chapter which discusses 
working with LOVs in Applications Administration Guide.
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This chapter describes end-user procedures for creating, adjusting, and working 
with forecasts.
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Business Scenario for Forecasting
The following scenario provides an example of a process performed by a sales 
representative and a sales manager. Your company may follow a different process 
according to its business requirements.

A sales representative at a large company is responsible for forecasting. She creates 
a periodic forecast by selecting a predefined forecast series. The application 
automatically creates her forecast by applying the forecast search rules, or a query 
to the account, opportunity, and partner-related revenue that she is managing. The 
sales representative analyzes the forecast data, viewing the anticipated revenues by 
product line and then by account. She then adds a revenue item and modifies an 
existing revenue item before submitting the forecast to her manager.

After the sales team members have submitted their forecasts, the sales manager 
runs the same forecast series, which aggregates the teams’ submissions. In this way, 
the sales organization can poll its members for their projected results for the period. 
The manager modifies the results of the forecast by adjusting one of the individual 
forecasts submitted. This change to a forecast will not carry over to any 
corresponding revenue records. To keep his data accurate, the sales manager 
updates the corresponding live revenue records with the changes he made to the 
forecast. 

The sales manager then remembers that the last time he created this same forecast, 
he made changes to it as well. He selects Auto-adjust to automatically apply the 
changes made in the most recent forecast to this forecast. This makes sure that any 
adjustments that were made in the last forecast (the most recent forecast date 
available) are automatically added to the current forecast. Finally, he analyzes the 
forecast using charts and reports, and when he is satisfied with it, he submits the 
forecast to his manager.
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Example Process for Forecasting
This is an example of a process an end user might follow to use forecasting. Your 
company may follow a different process according to its business requirements.

1 Create a forecast. For information, see “Creating a Forecast” on page 105.

2 View forecast details. For information, see “Viewing Forecast Details” on 
page 108.

3 Add forecast details. For information, see “Adding Forecast Details” on page 109.

4 View a forecast summary. For information, see “Viewing Forecast Summary” on 
page 110.

5 View a subordinate’s forecast. For information, see “Viewing Subordinate’s 
Forecasts” on page 111.

6 Working with subordinate’s forecasts from Siebel Remote Web Client. For 
information, see “Viewing and Creating Subordinate’s Forecasts Remotely” on 
page 112.

7 Creating a partner forecast. For information, see “Creating a Partner Forecast” on 
page 113.

8 Rolling up a forecast. For information, see “Rolling Up Forecasts” on page 114.

9 Adjust a detail depth forecast. For information, see “Adjusting a Detail Depth 
Forecast” on page 116.

10 Adjust a summary depth forecast. For information, see “Adjusting a Summary 
Depth Forecast” on page 118.

11 Auto-adjust a forecast. For information, see “Auto-Adjusting a Forecast” on 
page 119.

12 Unadjust a forecast. For information, see “Unadjusting a Forecast” on page 120.

13 Adjust a subordinate’s forecast. For information, see “Adjusting a Subordinate’s 
Forecast” on page 121.

14 Update a revenue from a forecast. For information, see “Updating Revenues from 
a Forecast” on page 123.
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15 Update a forecast with a revenue item. For information, see “Updating a Forecast 
with a Revenue Item” on page 124.

16 Analyze a forecast. For information, see “Analyzing Forecasts” on page 125.

17 Submit a forecast. For information, see “Submitting a Forecast” on page 126.
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Creating a Forecast
A forecast is a snapshot of revenues over time. The following procedure explains 
how to create a forecast. 

To create a forecast

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecasts list, click the menu button, and then click New Record.

3 Click the Forecast Series select button.

4 In the Pick Forecast Series dialog box, select the forecast series you are basing 
this forecast on, and then click OK.

5 Click the Forecast Date select button.

NOTE: By default, when a forecast is issued for the first time, the Siebel 
application uses the system date as well as the date for the master forecast and 
bases the forecast on the nearest future date. For instance, the end user creates 
a master forecast, named Revenue, and enters three master forecast dates: 05/
01/2001, 06/01/2001, and 07/01/2001. If the end user forecasts on 5/22/01, 
then the forecast is for the period 06/01/2001. If the end user forecasts on 06/
01/2001, then the forecast is for the period 06/01/2001. Forecasting always uses 
a future date. End users can override the forecast date by changing it. End users 
can even change one that is for a date that has already passed, and then generate 
the forecast.
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6 In the Pick Forecast Date dialog box, select the forecast date you want to apply 
to this forecast, and then click OK.

Step off the forecast or save the record to generate the forecast.

The forecast record’s revenue fields (revenue, cost, margin, and expected 
revenue) are calculated. See the following table for more information about 
what information is contained in each field:

Field Name Comments

Forecast Date Indicates the start range of the forecast.

Forecast Series Indicates the forecast series this forecast is based on.

Owner Indicates the person who owns or is responsible for this 
forecast.

Position Read-only. Indicates the position of the owner of this 
forecast.

Organization Read-only. Indicates what organization the owner of this 
forecast belongs to.

Total Forecast Revenue Read-only. The sum the revenues included in this 
forecast.

Cost Read-only. Expense associated with an opportunity.

Margin Read-only. A calculated field that displays the revenue 
figure minus the cost.

Best Case Read-only. A best case estimate of what revenue will be 
produced by an opportunity.

Worst Case Read-only. A worst case estimate of what revenue will be 
produced by an opportunity.

Status Choose from Pending, Active, and Submitted.

Created By Read-only. Indicates the name of the person who created 
the forecast. In some cases the owner of a forecast is not 
the creator of the forecast.
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NOTE: When a manager forecasts, the application automatically creates forecasts for 
subordinates who are listed as participants of that series that have not already been 
forecasted. To disable this feature, see “Inactivating Auto-Forecast (Administrator)” 
on page 69.

Submitted By Read-only. Indicates the name of the person who 
submitted the forecast.

Updated Read-only. Indicates the date and time the forecast was 
last changed.

Field Name Comments
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Viewing Forecast Details
Forecast details define the elements that sum to the total forecast amount. At the 
sales representative level, the details include each of the revenue items queried into 
the forecast. The manager’s forecast details can include summary amounts for 
immediate subordinates, if it is a summary type forecast, and direct revenue from 
the manager’s own deals. The manager’s forecast can include subordinates’ forecast 
details, for a detail type forecast, instead of summaries depending on how the 
forecast series is set up.

Details can be adjusted. To view the adjustment history click the Date hyperlink. 
Also, from the menu button end users can unadjust, update from revenue, update 
to revenue, auto-adjust an item from the last forecast, and see net revenue change 
from the last forecast.

NOTE: The forecast owner can modify the revenue values displayed in the Details 
view. However, these changes are not automatically aggregated into the forecast 
total. The end user must click the menu button, and then click Rollup Parent 
Forecast to recalculate total forecast revenue.

Three options are available for viewing the details of a forecast.

■ List

■ Spreadsheet

■ Chart

To view forecast details

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecasts list, select the forecast for which you want to view the details.

3 Click the Details view tab.

4 From the Show drop-down list, select List, Spreadsheet, or Chart.

The information is displayed based on your selection.
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Adding Forecast Details
Occasionally, the forecast that has been created does not include each of the 
revenue items that it should. Additional revenue records can be added manually.

To add forecast details

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecast list, select the forecast to which details will be added.

3 Click the Details view tab.

4 In the Details list, click the menu button, and then click New Record.

5 In the Add Revenue Items dialog box, select the item and click OK.

NOTE: End users can add many revenue items at the same time by holding down 
CTRL or SHIFT and selecting the appropriate items. End users can also run a 
query and select each of the returned records.
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Viewing Forecast Summary
The Forecast Summary view displays the total forecast’s revenue aggregated into the 
periods specified by the forecast series. These summary periods are indicated by 
their respective start dates. For example, the calendar month of November 2001 is 
displayed as 11/01/2001 in the Summary view. The owner can modify the summary 
revenue values of the forecast. Changes to these values are immediately visible in 
the forecast record’s Total Forecast Revenue field.

NOTE: The Details view does not reflect changes made in the Summary view. If 
modifications have been made to the summary values, those values are overwritten 
when Rollup is selected.
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Viewing Subordinate’s Forecasts
From the Subordinates view, end users can add or delete forecast participants who 
report to them, and they can drill into a subordinate’s forecasts by using the Owner 
Position hyperlink. For summary forecasts, managers can make broad percentage 
adjustments. For more information, see “Adjusting a Subordinate’s Forecast” on 
page 121.

NOTE: To create and add a subordinate’s forecast, create the forecast from the My 
Team’s forecast, and then add the subordinate from the Subordinates view.
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Viewing and Creating Subordinate’s Forecasts Remotely
Managers can create a forecast and see their subordinates’ forecasts that have 
already been created and synchronized over to the local database when the 
manager was docked.

A manager cannot create a subordinate’s forecast using auto-forecast on the Siebel 
Remote Web Client as the manager can when using the connected client. Therefore, 
there can be no duplication of effort between the manager and the subordinate, and 
synchronization confusion is avoided.

If a sales representative’s forecast has not already been created, then the manager, 
after creating the representative’s forecast remotely and then docking, will need to 
associate the subordinate’s forecast using the Subordinates view in the Forecasts 
screen. 

NOTE: Preconfigured Siebel Remote Web Client users have local access to Revenues 
and Revenue Plans in the Opportunities screen, and to the My Revenues view. 
However, they do not have access to Revenues from accounts, products, or contacts 
remotely as they do when they are connected. These views can be added to Siebel 
Remote Web Client with the assistance of Siebel Expert Services.
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Creating a Partner Forecast
Siebel Forecasting supports numerous partner forecasting scenarios. These 
scenarios include rollup forecasts, forecasts run by the partner only, forecasts of 
each partner, and forecasts of individual partner organizations. For details on 
setting up forecast series to support each of these scenarios, see Siebel Partner 
Relationship Management Administration Guide.
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Rolling Up Forecasts
When end users click Rollup in the Forecasts screen, the forecast detail item records 
in the Details view (that match the Rollup Search Spec) are summed up in the 
Summary view. As the summary records are updated by the forecast details, the 
total forecasted revenue is also updated. Changes that had been made to the detail 
records, such as revenue or quantity adjustments are then part of the summary 
record totals and the total forecasted revenue. Additionally, when Rollup is 
selected, any adjustments made earlier to summary records are lost when new 
values are brought in from the detail records. For information about setting the 
Rollup Search Spec, see “Creating a Forecast Series (Administrator)” on page 48.
114 Siebel Forecasting Guide Version 7.5, Rev. A



Forecasting

Forecast Adjustments
Forecast Adjustments
Managers can adjust subordinate forecasts in one of the following three ways:

■ At the detail level from the Forecast > Details view tab for a detail type forecast.

■ By summary period from the Forecast > Summary view tab for a summary type 
forecast.

■ By subordinate for percentage adjustments for summary type forecasts.

When a sales representative clicks Rollup for a specific forecast while in the 
forecast’s Details view, the forecast is summed into the corresponding periodic 
summary records, which is displayed from the Summary view tab. When summary 
records are updated by the rollup process or manually, the Total Forecast Revenue 
field automatically calculates the values of the summary records. When a sales 
representative clicks Rollup, any prior adjustments to the summary records are 
overwritten with the new values brought in from the detail records.
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Adjusting a Detail Depth Forecast
In a detail depth forecast, each revenue line item in the Details view is rolled up 
through the reporting hierarchy. As a result, senior management has access to every 
forecast detail revenue item for its review. In this scenario, users should make sure 
that every adjustment is made in the Details view. After adjusting the details, end 
users must click Rollup to recalculate the modified forecast. To see forecast details 
by periodic summary, end users can view the forecast from the Summary view tab.

Once a manager adjusts a subordinate’s detail record, the Siebel application 
maintains an adjustment history. Levels of management above can view the 
adjustment history, however, the subordinate, whose forecast record was adjusted 
cannot view the adjustment. 

NOTE: If end users are unclear about the forecast type their company uses, they 
should see their Siebel administrator or a member of their sales operations team.

To adjust a detail depth forecast

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 Select the forecast you want to adjust in the Forecast list.

3 Click the Details tab.

4 Select the revenue line item detail you want to adjust.

5 Adjust the revenue, quantity, price, or other value you want to modify.

6 Repeat Step 4 through Step 5 for each line item you want to adjust.

7 Click the menu button, and then click Rollup Parent Forecast to recalculate the 
forecast.

The adjusted forecast amount is posted by period to the Summary list on the 
Summary view tab.
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8 (Optional) From the Summary view tab, view the summary list by period. 
Adjustments made here are not displayed in the manager’s forecast.

NOTE: Any adjustments to the summary records are not rolled up in a detail depth 
forecast. Managers can view the summary record adjustments by drilling into their 
subordinates’ forecasts.
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Adjusting a Summary Depth Forecast
In a summary depth forecast, each record in the Summary view is rolled up to your 
direct manager. As a result, a manager can see his own detailed line item records 
and the summary records of his direct subordinates from his forecast Details view. 
Users can adjust detail records and click Rollup to calculate the modified forecast. 
They can then further adjust those records from the Summary view.

A manager can make an additional adjustment to a subordinate’s forecast from the 
Subordinates view in the Forecasts screen. In this view, a manager can see the total 
forecast revenue amount for his direct subordinates. A manager can also make a 
broad percentage adjustment. This percentage adjustment is calculated into the 
rollup for each subordinate when the Rollup button is clicked. For more 
information, see “Adjusting a Subordinate’s Forecast” on page 121.

NOTE: A subordinate’s forecast cannot be adjusted from the Subordinates view in a 
detail type forecast.

To adjust a summary depth forecast

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 Select the forecast you want to adjust in the Forecast list.

3 Click the Summary tab.

4 Select the summary record you want to adjust.

5 Adjust the Revenue, Best Case, Worst Case, or other value you want to modify.

6 Repeat Step 4 through Step 5 for each line item you want to adjust.

The total adjusted forecast amount appears in the Total Forecast Revenue field, 
but no adjustments appear in the detail forecast for the subordinate.

NOTE: Any adjustments made to the detail records are not captured in the summary 
records until you click Rollup.
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Auto-Adjusting a Forecast
Auto-adjust applies to forecasts with details only. Use auto-adjust to apply any 
changes made in the most recent forecast to the current forecast. Once auto-adjust 
is selected, any adjustments that were made in the last forecast (the most recent 
forecast date available) are automatically added to the current forecast. Fields such 
as Probability, Qty (quantity), Revenue, Expected Revenue, Price, Commit, Close 
Date, Best Case, Worst Case, Margin, and Cost that may have been changed are 
updated in the current record.

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecast list, select the forecast to be updated.

3 Click the Details view tab.

4 Select the revenue line item or items you want to apply adjustments to.

5 Click the menu button, and then click Auto-Adjust Selected Details.

NOTE: Auto-adjust is only visible as an option if there is a past forecast to be 
compared to.
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Unadjusting a Forecast
After using auto-adjust or making an adjustment to another user’s record, end users 
can use unadjust. Unadjusting a forecast only applies to forecasts with details.

To unadjust a forecast

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecast list, select the forecast to be updated.

3 Click the Details view tab.

4 Select the record or records you want to unadjust.

5 Click the menu button, and then click Un-Adjust Selected Details.
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Adjusting a Subordinate’s Forecast
When the sales manager creates a forecast, the Subordinates view is populated with 
the total value of each of the manager’s subordinates’ forecasts.

This view offers the manager the ability to adjust the aggregate value of each 
subordinate’s forecasts by a percentage based on the individual’s historical 
forecasting accuracy. The percentage adjustment is entered manually into the 
Adjust % field. The Revenue field is factored by this percentage and the result is 
displayed in the Adjusted Revenue field. 

NOTE: Managers can only adjust a subordinate’s forecast from the Subordinates 
view if the forecast is a summary type forecast.

To see the details of a subordinate’s forecast, drill down on the Owner Position 
hyperlink.

TIP: The Siebel administrator or sales manager can change the status of a submitted 
forecast to allow an end user to revise a forecast and submit it again. This simplifies 
the process of revising a forecast.

To adjust a subordinate’s forecast

1 From the application-level menu choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecast list, select the summary forecast that includes subordinate 
forecasts.

3 Click the Subordinates view tab.

4 In the Subordinates list, locate the record that requires adjustment and select the 
Adjust % field.
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5 In the Adjust % field, enter the appropriate percentage in whole numbers.

The Adjusted Revenue field displays the value of the revenue field factored by 
the percentage adjusted. (The Adjusted Revenue field is a calculated field. No 
data entry is allowed.)

NOTE: In Siebel 2000, managers used a Revise Forecast button to adjust forecasts 
after they had been submitted. In Siebel 7.0, the Revise button is no longer needed 
to revise subordinate forecasts because end users can delete their active forecasts. 
Also, managers can submit or unsubmit a subordinate’s forecast by changing the 
Status field in the forecast from Active to Submitted or vice versa.
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Updating Revenues from a Forecast
Updating revenues from a forecast allows an end user to update live revenue records 
with the current forecast updates. This eliminates a number of steps. Updating 
revenues from a forecast only applies to forecasts with details.

To update revenue items from a forecast

1 From the application-level menu choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecast list, select the forecast to be updated.

3 Click the Details tab.

4 Select the revenue item to be updated.

5 Click the menu button, and then click Update Revenue Item.

This updates the revenue item with the most recent adjustment from the 
Forecasts screen.
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Updating a Forecast with a Revenue Item
Updating a forecast with a revenue item updates the selected forecast with the most 
recent adjustment in the live revenue records. Updating a forecast with a revenue 
item only applies to forecasts with details.

To update a forecast with a revenue item

1 From the application-level menu choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecast list, select the forecast to be updated.

3 Click the Details tab.

4 Select the revenue line item or items you want to update.

5 Click the menu button, and then click Update Detail with Revenue Item.
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Analyzing Forecasts
Forecasts can be analyzed a number of ways.

Using Charts to Analyze Forecasts
End users can view forecasts using the chart view in either the Details view or the 
Summary view in the Forecasts screen. It is possible to view forecasts by month, 
quarter, or year from the chart view. Also, depending on access privileges, end 
users can compare individual forecasts from the My Forecast Analysis view, the My 
Team’s Forecast Analysis view, and the All Forecast Analysis view. In the Forecast 
Analysis view, end users can select or highlight the forecasts they want to compare 
and the summary data is automatically aggregated. Then they can use the charts to 
see, for example, revenue by forecast by month.

Using Reports to Analyze Forecasts
For information about running reports, see Fundamentals.

Using Analytics to Analyze Forecasting
For information about analytics, see Siebel Analytics User Guide.
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Submitting a Forecast
The last step in creating a forecast is to submit it to the manager for review.

To submit a forecast

1 From the application-level menu choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecast list, select the forecast to be submitted.

3 In the More Info form, from the Status drop-down list, select Submitted.
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A sales team may consist of individuals from many organizations, groups, and 
divisions. The team typically includes an account manager or field sales 
professional, a telesales professional, a sales consultant, a product specialist, and 
an industry specialist. These individuals may report to different managers, each of 
whom need visibility into the business pipeline.

By default, a manager has visibility, through the My Team’s views, into every 
opportunity, account, and contact a subordinate can access. For example, with the 
My Team’s Opportunities view, a manager can see every opportunity on which one 
of their subordinates is primary.

Therefore, the primary sales representative’s manager has visibility into the 
subordinates’ opportunities through the My Team’s view. The other managers 
(overlay managers such as the telesales professional’s manager or the product 
specialist’s manager) need another way to see these opportunities and revenues.

In this instance, you can use one of the following methods to provide visibility:

■ Change the visibility of the My Team’s Opportunities view.

■ Use the My Team’s Revenues view.

■ Use the All and All Across Organizations views.

■ Add overlay managers to the sales team.

These options are discussed further in the following sections.
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Changing the Visibility of My Team’s Opportunities View 
(Administrator)

You can change the visibility of the My Team’s Opportunities view using Siebel 
Tools so that it shows every opportunity in which a subordinate is listed in the sales 
team (instead of the opportunities where a subordinate is primary).

This approach allows overlay sales managers to see what is going on in the 
opportunity pipeline, at the expense of system performance and synchronization 
times. You avoid the additional administration involved in adding overlay sales 
managers to the sales team, but managers may experience slower connected 
response times using this view and slower synchronization times in the Siebel 
Mobile Web Client.

For information on changing visibility, see the Manager List Mode user property 
information in Siebel Tools Online Help.
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Using the My Team’s Revenues View
The My Team’s Revenues view allows a manager to see the revenue items for which 
a subordinate is listed as the sales representative. A revenue item is a portion of an 
opportunity. Using the Opportunities screen’s Revenues view, the members of the 
sales team can allocate specific portions of the overall opportunity to individual 
sales team members. This allows each of their managers to see their portion of the 
overall opportunity by using the My Team’s Revenues view.

The primary sales representative is already listed as the owner of the overall 
opportunity. The telesales representative might also take credit for some portion of 
the opportunity, while each product specialist takes credit for their product-related 
revenues. Their respective managers would see, in the My Team’s Revenues view, 
each of their subordinate’s level of involvement in that opportunity. For more 
information about using the My Team’s Revenues view, see “Reviewing Revenues” 
on page 95.
Version 7.5, Rev. A Siebel Forecasting Guide 129



Matrixed Sales Organization

Using the All and All Across Organization Views
Using the All and All Across Organization Views
This approach allows sales managers, directors, and executives to find the 
opportunities or revenues that they are looking for by using a predefined query on 
the All or All Across Organizations views. The query includes some unique criteria 
that designates the type of opportunity or revenue the overlay sales manager can 
use to find the appropriate set of records.

For example, a product manager for a given product line might use a product-
specific query on the All Revenues or All Revenues Across Organizations view to 
find each revenue related to their product line. A country manager for Germany 
might run a query on the All Opportunities view for every opportunity with the 
country code for Germany. 

For more information about the All and All Across Organization views and forecast 
visibility, see Table 3 on page 50.
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Adding Overlay Managers to the Sales Team
This option guarantees that overlay sales managers can see their subordinates’ 
opportunities, but it means that a large number of people will end up on the sales 
team, a large number of opportunities will be synchronized, and you will have to 
do a lot of territory administration work when reporting relationships change. 

Mobile sales organizations may want to consider the impact on synchronization 
times. You may end up providing the overlay sales managers with more information 
than they really want on a mobile client.
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Adding Overlay Managers to the Sales Team
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Importing and Exporting 9
This chapter explains how end users can import and export forecast and revenue 
information. It also discusses administrative maintenance of import and export 
functionality.
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Business Scenario for Importing and Exporting
This scenario provides an example of a process performed by a sales manager and 
a sales representative. Your company may follow a different process according to its 
business requirements.

A sales manager at a large company is working on a presentation. She plans to 
export data from both the Revenues screen and the Forecasts screen into Microsoft 
Excel so that she can use current revenues and forecasts in her presentation. Later 
that week, she is given new revenues in the form of a Microsoft Excel spreadsheet 
which she imports into Siebel Forecasting.

The company’s forecast administrator has learned that the display name of a field 
in the Revenues screen has been changed and that a new field has been added. As 
a result of this change, the administrator now needs to update the mapping in the 
Revenue Import process.
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Example Process for Importing and Exporting
Figure 2 is an example of a process an end user and an administrator might follow 
for importing and exporting in Siebel Forecasting. Your company may follow a 
different process according to its business requirements.

Figure 2. Example Process for Importing and Exporting
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Exporting Forecast Data
You can export forecast data from the Forecasts screen.

To export forecast data

1 From the application-level menu, choose View > Site Map > Forecasts > My 
Forecasts.

2 In the Forecasts list, select the forecast information you want to export.

3 Click the menu button, and then click Export.

4 In the Export dialog box, set up the export rules and click Next.

5 In the File Download dialog box, click Open this file from its current location or 
click Save this file to disk, and then click OK.

The file is opened or you have to save it to a location on your machine depending 
on your instructions.

6 Close the Export dialog box by clicking Close.
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Importing Revenue Data
Modified revenue files can be imported back into the application.

To import revenue data

1 From the application-level menu, choose View > Site Map > Revenues > My 
Revenues.

2 In the Revenues list, click the menu button, and then click Import.

3 In the Import dialog box, click Browse next to the Input File field to select the 
file you are importing.

4 In the Choose File dialog box, select the file you want to import and click Open.

5 In the Import dialog box, from the Input Format field, select the format you 
prefer: Comma Separated Text File or Tab Delimited Text File.

CAUTION: Be sure that the file you are importing has been saved in the same 
format you select from the Input Format field.

6 From the Input Source field, select Predefined Mapping. 

7 From the drop-down list beneath the Input Source field, select Opportunity 
Revenue or Default. 

NOTE: If you originally exported the revenues from the Revenues view in the 
Opportunities screen, select Opportunity Revenue. If you originally exported the 
revenues from the Revenues screen, select Default.
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8 From the Conflict Resolution Method field, select the method you prefer to use 
should the import encounter a conflict between records: Reject Import Record, 
Overwrite Existing Record, or Create Additional Record.

9 Click Next.

■ If the import was successful, click OK.

■ If the import was unsuccessful, click View Log.

NOTE: Any blank data fields you import into revenues are left unchanged in an 
import. If you want the blank records to be imported as 0 values then you need to 
replace each blank with a 0.
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Exporting Revenue Data
Data can be queried on an ad hoc basis in the Revenues screen. The resulting 
records can be exported in a variety of formats. 

NOTE: If you are exporting files into more than one file format type, you must 
perform separate exports for each file type.

To export revenue data

1 From the application-level menu, choose View > Site Map > Revenues > My 
Revenues.

2 In the Revenues list, locate the revenue information you want to export.

NOTE: You may want to perform a query or use your predefined query to locate 
the revenue information.

3 In the Revenues list, click the menu button, and then click Export.

4 In the Export dialog box, set up the export rules, and then click Next.

5 In the File Download dialog box, click Open this file from its current location or 
click Save this file to disk, and then click OK.

The file is opened or you have to save it to a location on your machine depending 
on your instructions.

6 Close the Export dialog box by clicking Close.

CAUTION: Do not select Visible Columns when you export revenue data or you will 
be unable to import that same data back into revenues. Instead, export All Columns 
and import those same All Columns when you return data, as these map to the 
Default Predefined Mapping.
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Updating Predefined Mapping in Revenue Import 
Process (Administrator)

Whenever a display name of a field in the Revenues screen is changed or a new field 
is added, you must update the mapping in the Revenue Import process.

Updating a Display Name
When an end user changes the display name of a list column of the applet, you must 
also update this new name for the Import Field Column. For example, if an end user 
changes the Revenue Analysis List Applet List Column Upside display name to Best 
Case, then you have to make the following changes in Siebel Tools:

Import Object > Revenue > Import Source (In Revenue's case is Default) > Import 
Field Map > find the corresponding field (Upside) > Import Field Column > 
change column to Best Case.

Updating a New Field
When an end user adds a new field to the Revenue Analysis List Applet, you must 
also add that field as an Import Field column.

After adding the field to the Revenue Analysis List Applet, add the new field to 
Import Field Map under the corresponding Import Source. You must also specify the 
Import Field Column of this field (this is the display name of the list column in the 
list applet).

NOTE: Make sure the Import Field Column of the import field is same as the Display 
Name of this field in the List Column defined in the List Applet, if you want to first 
export and then import it.

After making changes in Siebel Tools, you must recompile the SRF file.
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This appendix describes some solutions to problems you may encounter as you use 
Siebel Forecasting.
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Forecast Troubleshooting
The following issues may be encountered when you are working with forecasts.

Error Creating a Forecast
When creating a forecast, a user may experience the following error: 

[1] An error occurred while creating your forecast. Forecast may not include all 
revenues or subordinate details. Please check the log file or contact your system 
administrator for details.

To find the source of this problem, administrators should check the forecast log file 
on their server. These files are typically located as follows: 

If the instance is a Siebel Mobile Client (siebel.exe) installation:

■ xxx: $install/log directory

■ yyy: siebel.log, or siebel_N.log, if the client has been run N times since the crash 
occurred. (The names of the logfiles are incremented by one each run, for 
example, siebel.log is renamed siebel_01.log, siebel01.log is renamed 
siebel02.log.)

If the instance is a Microsoft Windows server:

■ xxx:$install/siebsrvr/log

■ yyy: SrvrComponent_ProcessId.log, for example, SSEObjMgr_50231.log

If the instance is a UNIX server:

■ xxx: $install/siebsrvr/enterprises/$enterprise_name/$srvr_name/log

■ yyy: SrvrComponent_TaskId.log, e.g. SSEObjMgr_50231.log

A component can have many tasks running and generating logs. See Siebel Server 
Administration Guide for information about the location of log files.

In the log file, you will find records like this:

FCSTLOG_EVENT Error 1 2001-10-30 16:16:02 <WW Sales, 10/01/2001, 
Product Line Manager-00004456, BGROVES>   Error occurred when 
setting field ‘Revenue Class” to value “Backlog”
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The error in the previous example occurred on October 30th, 2001, when running a 
WW Sales forecast for a regional sales manager with the user ID of MSTERN. The 
error occurred because a revenue record that was to be included in the forecast 
included an invalid value for the Revenue Class picklist. In this example, the error 
can be corrected by adjusting the Revenue Class LOV to include a value called 
BackLog, or by changing the Revenue Class on the offending record to a choice that 
is still valid.

NOTE: It is most likely in this example that the valid values for the Revenue Class 
field were changed and the old data was never cleaned up.

Once this issue is corrected, the forecast can be deleted and rerun, or the missing 
revenue record can be added manually.

Queries on the Forecast Detail View Affect Summary Views
Queries run in the Details view in the Forecasts screen affect the information shown 
in the Summary view in the Forecasts screen. End users may have to requery to see 
each of the forecast summary records after running a query on the forecast details.

Forecast Details View Shows Product Line Items That Were 
Deleted Before Creating the Forecast
While it is unlikely that any best practice would include the deletion of an 
opportunity that included revenue estimates, you do have the ability to delete an 
opportunity. If you delete an opportunity, but do not delete the associated revenues, 
then those revenues are maintained, and will be included in your next forecast. You 
should delete each revenue associated with the opportunity before deleting the 
opportunity if those revenues are not meant to be forecasted.

Forecasting a Global Account or Product
A global account or product can be forecasted three ways.
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Global Account Forecast Snapshot
Perform a global forecast that pulls in only data from the key accounts or one 
account. Set the forecast’s visibility to All Revenues and the Auto Forecast Search 
Spec to Account = ‘CompanyName*’.

NOTE: This can also be done for a Product Line or Division.

Ad Hoc Global Account Revenues Screen
Predefined query is saved in the Revenues screen and used for EIS reporting, 
analytics, and exporting.

Define and save a predefined query in the Revenues screen as follows: Account = 
CompanyName and [Calculated Primary Flag] = ‘Y’ (for opportunity level revenue 
management).

NOTE: This can also be done for a Product Line or Division.

Account Revenues Management
Manage and evaluate revenues associated with an account from the Revenues view 
in the Accounts screen.

NOTE: This can also be done by Product, Contact, Partner, or Project.

Adding a New Opportunity to a Forecast
When you add a new opportunity to a particular forecast (in the Person Opportunity 
Forecast Applet), this record will be updated to the S_OPTY_FCSTWD table. 
Specifically, each revenue detail is being stored in the specific DATAxx (DATA01, 
DATA02, and so on) columns in the table. Depending on which monthly bucket the 
revenue is falling in, the corresponding column (DATA01, DATA02, and so on) will 
be updated accordingly. The logic of deciding which column to be updated is hard-
coded within the specialized class that the Forecast module is based on and is not 
configurable. The same logic is applied when you click the Rollup option to update 
the revenue in the forecast (in Person Forecast Stagger Chart Applet) except that the 
data is being stored in the S_PER_FCSTWD table instead.
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Relationship Between Opportunities and Expected Delivery Date
The expected delivery date in the Opportunities screen Products view determines 
the column (month) into which that product falls in the forecasting views. For 
example, several opportunity products can be combined into one product forecast 
record. The value that is seen for January for product x might be an aggregation of 
several opportunity product records. If the date on one of those records is changed, 
thereby knocking it out of the forecast, other records might still remain with slightly 
lower quantities or a slightly different average price.
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Revenues Troubleshooting
The following issues may be encountered when you are working with revenues.

Revenues in the Opportunities Screen Revenues View Do Not Show 
Up in the Parent Account
End users will find that if they create an opportunity and assign revenues to it before 
they define the parent account, then those revenues will not be associated with the 
parent account. If end users set the parent account in the opportunity first and then 
create the revenues, the revenues will be correctly associated with the parent 
account.
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This appendix provides you with examples of the ways in which forecasts can be 
used. Using a number of scenarios, it offers a glimpse into the requirements of 
different situations. It also describes how administrators and end users can create 
and use these different forecasts. Use this appendix after learning the details of how 
to create forecasts using the Siebel application. This appendix is designed to 
familiarize you with how forecasts are used. Use the rest of this guide to learn how 
to forecast.
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Common High-Level Forecast Usage Scenarios
The following scenarios are examples of situations in which you may want to 
forecast. Each specific situation discusses in general terms what steps an 
administrator and end user would perform to forecast a certain way. Each scenario 
is not detailed enough to allow you to perform each task. You should use this 
section to gain an understanding of how forecasts work with regard to the data you 
want to analyze.

Opportunity Forecasting
Users often need a sales pipeline and actuals to proactively manage key deals, 
allocate sales resources, manage sales costs, and respond to competitive or industry 
trends.

Forecast Requirements
■ Opportunity management

■ Use of sales methodology

Administrator Usage Scenario
The administrator defines a WW Sales forecast series. The Auto Forecast Search 
Spec is set as follows: [Calculated Primary Flag] = 'Y'. This search pulls 
opportunity level revenue items into the forecast.

End User Revenue Scenario
■ Add a new opportunity.

■ Maintain relevant opportunity data consistent with your company’s sales 
methodology, for example, sales stage, revenue class, and probability.

■ (Optional) Use revenue type attributes in each revenue item to add booked, 
billed, and actual status as revenue data is actualized over time. End users can 
use revenue class attributes to add service/hardware/software attributes for 
each revenue item.

End User Forecast Scenario
■ Create a new WW Sales forecast.

■ In the Details view, end users can see opportunities they are working on being 
automatically pulled into their forecast.
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■ Make adjustments and view adjustment history.

■ Submit the forecast.

Service Forecasting
Often end users need a service pipeline, backlog, and actuals for capacity planning, 
resource allocation, and service product planning.

Forecast Requirements
The forecast needs to include revenue scheduling, spreadsheets, services as 
products, easy to add recurring revenues, as well as forecasts that pull scheduled 
revenue into the correct time buckets.

Administrator Usage Scenario
The administrator defines a service forecast series. The Auto Forecast Search Spec 
is set as follows: [Product] IS NOT NULL and [Calculated Primary Flag] = 'N'. This 
search pulls revenue line items that have a product indicated into the forecast.

End User Revenue Scenario
■ Create a new opportunity or project.

■ Associate and create revenues using revenue scripts or revenue plans to 
establish a revenue group ID.

■ Use the revenue spreadsheet to view and maintain revenues over the scheduled 
time. As revenues become backlog or actuals they should be updated by the 
practice manager.

■ Use revenue charts and reports to graphically display data and to perform ad hoc 
analysis.

End User Forecast Scenario
■ Create a service forecast.

■ In the Details view, use the spreadsheet and chart views to evaluate and adjust 
scheduled revenues.

■ Use predefined queries to see details by service.

■ Submit the forecast.
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Product Level Forecast
Often end users need product level forecasts for demand planning (product and 
quantities), revenue management (price and revenue), margin management (cost 
and margin analysis), operations planning (inventory and demand) and product 
marketing decisions (product mix, discount analysis, and pricing strategies).

Forecast Requirements
Need to associate multiple products to one opportunity or account; need the ability 
to auto-quote from opportunity revenues; need spreadsheet-like functionality to 
manage recurring revenue products or milestone-based product deliveries; need the 
ability to add product price, quantity, cost and margin; and need to see product 
hierarchy.

Administrator Usage Scenario
The administrator defines a product forecast series. The Auto Forecast Search Spec 
is set as follows: [Product] IS NOT NULL and [Calculated Primary Flag] = 'N'. This 
search pulls product revenue line items that have a product indicated into the 
forecast.

End User Revenue Scenario
■ Create a new opportunity or account.

■ Associate and create product revenue line items using the New Record 
command, revenue scripts, or revenue plans.

■ Use the revenue list or spreadsheet views to edit and maintain product revenues. 
Add values in the following fields: Qty, Cost, Margin, Price, and Product Line.

■ Use revenue charts and reports to graphically display data and to perform ad hoc 
analysis. For example, create charts and reports with parameters of:

■ Quantity by product line by month

OR

■ Margin by product by quarter

End User Forecast Scenario
■ Create a product forecast.

■ In the Details view, use the spreadsheet and chart views to evaluate and adjust 
product revenues.
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■ Uses forecast detail filters to see details by product.

■ Use charts and reports to perform analysis.

■ Submit the forecast.

NOTE: To rollup total quantity, the administrator needs to expose the quantity rollup 
in the total forecast. This is a simple configuration procedure.

Cost-Margin Forecast
The company emphasizes cost and margin analysis in product planning and sales 
strategy. The company wants to use cost and margin analysis to drive lifetime value.

Forecast Requirements
End users want to evaluate costs and margins on each opportunity or product 
revenue to determine the value of a deal. There is a need to evaluate these costs 
and margins over a series of scheduled revenues, as some opportunities may lose 
money initially, but over the long term are highly profitable.

Administrator Usage Scenario
The administrator defines a product cost/margin forecast series. The Auto Forecast 
Search Spec is set as follows: [Product] IS NOT NULL and [Calculated Primary Flag] 
= 'N'. This search pulls product revenue line items that have a product indicated 
into the forecast.

End User Revenue Scenario
■ Create a new opportunity or account.

■ Associate and create product revenue line items using the New Record 
command, Revenue Scripts, or Revenue Plans.

■ Instead of adding just revenue information, end users should add cost data for 
every product added.
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■ Using the revenue spreadsheet view, end users can view each product and its 
cost and margin expectations by month or week. These cost and margins can be 
modified accordingly and can be graphically viewed using the Charts view.

NOTE: The spreadsheet needs to be configured so that Cost and Margin are exposed 
for each date.

End User Forecast Scenario
■ Create a new product cost/margin forecast.

■ In Forecast Details they see the revenues they are working on automatically 
pulled into their forecast. 

■ End users can view the total revenue expected from each of these revenues from 
the Forecast Details list view or they can see the cost and margin expectations 
over time for each product using the spreadsheet view.

■ View a graphical presentation of this data using the Charts view or by creating 
reports.

■ They can adjust and submit the forecast.

NOTE: This scenario requires minor configuration to the revenue spreadsheet view 
to see the Cost and Margin by each date. For more information about configuring 
the revenue spreadsheet view, see “Revenue and Forecast Spreadsheet 
Configuration (Administrator)” on page 70.

Worst, Expected, Best (WEB) Forecasts
Sometimes there is a need for WEB analysis to evaluate the current state of business 
and to better allocate sales resources. WEB analysis examines the values in the 
following fields: Worst Case, Expected Revenues, and Best Case.

Forecast Requirements
Company wants to evaluate each opportunity, product revenue, or service revenue 
using WEB analysis.
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Administrator Usage Scenario
The administrator defines a WEB forecast series. The Worst Case, Expected 
Revenue, and Best Case data is preconfigured to be pulled into the forecast.

End User Revenue Scenario
■ Create a new opportunity or account and associate the Worst Case, Expected 

Revenue, and Best Case values to the opportunity revenue or the associated 
product revenue.

End User Forecast Scenario
■ Create a new WEB forecast which automatically pulls in the correct revenues 

with their WEB data and rolls up that data into a WEB.

■ Adjust and submit forecast.

Partner Forecast Option I: Partner Portal
A partner’s revenues are a large part of a company’s overall revenues, and they want 
to be more proactive in managing such revenues, measuring the partners, and 
allocating resources to the channel partners.

Forecast Requirements
The company needs to incorporate partner opportunities and revenues into 
forecasts automatically.

Administrator Usage Scenario
The administrator defines the WW Sales forecast series. The Auto Forecast Search 
Spec is set up as follows to include partner revenues: [Partner] IS NOT NULL and 
[Committed] = 'Y'. The administrator makes sure the correct participant’s name or 
organization is associated with the forecast series. For more information, see Siebel 
Partner Relationship Management Administration Guide.

End User Revenue Scenario
■ Partner enters revenues using the Partner Portal and creates appropriate 

opportunities and product revenues.

■ Partner can create scheduled revenues and use the charts view to see data 
graphically.
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End User Forecast Scenario
■ Partner creates a standard forecast as if he or she were part of the sales force, 

WW Sales.

■ Partner makes adjustments and submits the forecasts to his or her appropriate 
internal partner manager.

■ Partner manager creates his or her own forecast.

■ Partner manager reviews, and adjusts the partner’s forecast (which is 
automatically pulled into the partner manager’s forecast), and submits it.

For more information, see Siebel Partner Relationship Management Administration 
Guide.

Partner Forecast Option II: Triggered by Partner Manager
In some instances, a partner's revenues are a large part of a company’s revenues 
and the company needs to be more proactive in managing these revenues, 
measuring the partners, and allocating resources to the channels partners.

Forecast Requirements
Company needs to incorporate partner opportunities and revenues into forecasts 
using an internal source, such as a partner manager, to minimize partner's 
responsibilities.

Administrator Usage Scenario
The administrator defines the partner forecast series. The Auto Forecast Search Spec 
is set up as follows: [Partner] IS NOT NULL OR [Opportunity Primary Organization 
Partner Flag] = 'Y'. For more information, see Siebel Partner Relationship 
Management Administration Guide. Then, the administrator makes sure the partner 
manager is associated with the forecast and that the partner manager’s positional 
hierarchy rolls up correctly for the forecast process.

End User Revenue Scenario
■ Partner revenues are entered by the partner manager or imported into the Siebel 

application.

■ Partner manager then maintains and manage the partner specific revenues in the 
Partner > Revenues view or the Account or Opportunity > Revenues view.
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End User Forecast Scenario
■ Partner manager can create his or her partner forecast or sales forecast and the 

partner revenues are automatically pulled into the forecast.

■ Partner manager can review, adjust, and submit the forecast to his or her 
manager.

For more information, see Siebel Partner Relationship Management Administration 
Guide.

Opportunity Product Forecasting
A company needs to forecast both opportunity and product revenues related to 
opportunities, but only wants to see forecast details by opportunity.

Administrator Usage Scenario
The administrator defines an opportunity product forecast series. The Auto Forecast 
Search Spec is set as follows: [Product] IS NOT NULL and [Calculated Primary Flag] 
= 'N'. This search pulls product revenue line items that have a product indicated 
into the forecast.

End User Revenue Scenario
■ Create a new opportunity.

■ Associate and create product revenue line items using either the New Record 
command, revenue scripts, or revenue plans.

■ Use the Revenues list or spreadsheet views to edit and maintain product 
revenues (add quantity, cost, margin, price, and product line).

■ Use revenue charts and reports to graphically display data and to perform ad hoc 
analysis. For example, create charts and reports with the parameters revenue by 
opportunity or quantity by opportunity.

End User Forecast Scenario
■ Create an opportunity product forecast.

■ In the Details view, use the spreadsheet and chart views to evaluate and adjust 
product revenues.

■ Use charts and reports to view product revenues by opportunity and to see 
aggregates of product quantity and revenue by opportunity.
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■ Use queries to view live forecast details by opportunity. Preconfigured, these 
queries are set up to query by product. 

■ Adjust and submit forecasts.

NOTE: To rollup total quantity, the administrator needs to expose the quantity rollup 
in the total forecast. This is a simple configuration procedure. Also to use the 
forecast queries to filter opportunities, the administrator needs to configure this.

Weighted Average—Expected Revenue Forecast
End users often have a large set of opportunities or products and want to manage 
total forecast by evaluating the probability of each deal.

Forecast Requirements
The company wants to perform expected value forecasting using revenue, 
probabilities (driven by sales stages), and expected revenue.

Administrator Usage Scenario
The administrator defines an expected revenue forecast series. The forecast series 
search definition depends on the specific data need. Critical to the success of this 
method is the need for the sales operations team to clearly define the following:

■ Proper sales stages.

■ The criteria necessary to move with the next sales stage.

■ The probabilities that should be associated with each sales stage. Sales 
operations need to modify the probabilities as the process and market 
environment change. 

■ A method for managers and sales representatives to keep these sales stages 
accurate.

End User Revenue Scenario
■ Create a new opportunity or revenue items.

■ Associate the proper sales stage with each opportunity or revenue item. The 
probabilities should be automatically created and the expected revenue is 
automatically calculated.
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End User Forecast Scenario
■ End user creates a new expected revenue forecast which automatically pulls in 

the correct revenues with his or her probabilities, sales stages, and expected 
revenues.

■ User adjusts and submits forecast.
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The appendix lists the user properties available for Siebel Forecasting.
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Forecasting user properties are found in Siebel Tools. For more information about 
user properties, see Siebel Tools Reference.

CAUTION: Some Siebel Forecasting user properties are for internal use only. 
Adjusting user properties marked for internal use can affect the behavior of 
adjustments. Internal use only user properties should not be modified. They are 
included in this appendix for informational purposes only. 

Table 7 describes the user properties associated with the business component: 
Forecast 2000 - Forecast.

Table 7. Forecast 2000 - Forecast

User Property Value Comments

Associate: 
Completion 
Timeout (Client)

120 (default) Maximum amount of time (in seconds) to 
wait on the client for a subordinate’s 
forecast to finish before skipping the 
association and returning an error.

Associate: 
Completion 
Timeout (Server)

1200 (default) Maximum amount of time to wait (in 
seconds) on the server for a subordinate's 
forecast to finish before skipping the 
association and returning an error.

Associate: Sleep 
Time Between 
Attempts

5 (default) Amount of time to wait (in seconds) 
between checks for completion of 
subordinate's forecast.

Forecast Analysis 
BC

Forecast 2000 - Forecast 
Item Detail Flat

The business component whose records 
are displayed in the child applet in the 
Analysis view, when parent records are 
selected for comparison.
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Forecast Rollup [Link Type] = 
LookupValue 
('FCST_FCSTITEM_LIN
K_TYPE', 'Own Item') 
or [Link Type] = 
LookupValue 
('FCST_FCSTITEM_LIN
K_TYPE', 'Item')

If active, this search spec is applied on the 
Forecast Detail BusComp during rollup.

Named Search: 
Forecast Series 
Date Range

[Date] >= 
'&FCST_DATE_LOWER
_BOUND' and [Date] 
<= 
'&FCST_END_DATE'

If active, this search spec is applied to the 
Revenue BusComp during forecast 
creation. This is usually active to make 
sure that the revenues are within the 
Forecast Date range.

If not active, administrators need to modify 
the Auto and Assoc search specs of the 
Forecast Series to include similar criteria if 
they want the revenues that enter the 
forecast to be limited by date. This search 
spec (as well as the Auto and Assoc search 
specs) can use special variables as defined 
in the Forecast Series and Forecast Series 
Date BusComps. 

Revenue 
Aggregation Field 
(N)

Field names on the 
Forecast 2000 - Forecast 
Item Detail Flat 
BusComp

The fields which are aggregated during 
forecast rollup. Rollup aggregates the 
forecast details by forecast period, and 
sums up the fields configured here when 
creating each summary record.

Skip Existing 
Forecast Series 
Date

Y If enabled, will not show dates for which 
forecasts of the currently selected series 
already exist.

Table 7. Forecast 2000 - Forecast

User Property Value Comments
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Table 8 describes the user properties associated with the business component: 
Forecast 2000 - Forecast Item.

Table 8. Forecast 2000 - Forecast Item

User Property Value Comments

Adjustment: 
Adjustable

Y Indicates that adjustments are enabled on 
Forecast Item BusComp. 

An adjustable business component 
supports the concept of hierarchical 
information sharing. When a manager 
modifies a subordinate's record, the 
changes are made to a copy of the record, 
not the actual subordinate record. 
Therefore, changes are not visible to the 
subordinate.

Also, the manager's record is visible to the 
positions above him, for example his 
change shadows the original record. The 
record created by the manager is called an 
adjustment of the original.

If adjustments are disabled, changes are 
made on the same record and are visible 
throughout the hierarchy.

Adjustment: 
Adjustable Field (N)

Field names on 
the Forecast 2000 - 
Forecast Item 
BusComp

Fields which managers can adjust.

If a field is not configured here, it will 
appear to be uneditable to managers when 
they view forecast details included from 
subordinate forecasts.

Adjustment: 
Adjustment Allowed 
Field Name

Adjustment 
Allowed

Used internally.

Should not be disabled.
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Adjustment: 
Adjustment Context BC 
Name

Forecast 2000 - 
Forecast

Used internally.

Value is the business component which 
includes information indicating the 
ownership/level of an adjustment record.

This is used to support copy-on-write 
implementation of adjustments. In 
Forecasting, the same record is visible in 
both manager and subordinate forecasts 
before adjustments and its context is the 
forecast it is being viewed under. When an 
adjustment is made, the adjusted record 
then takes its ownership from its context 
(the manager's forecast).

Adjustment: 
Adjustment Context Id 
Field Name

Owner Forecast Id Used internally.

Field on Context BusComp which indicates 
position of owner.

Adjustment: 
Adjustment Flag Field 
Name

Adjusted Flag Used internally.

Indicates if a record has been adjusted and 
is used in other methods. For example, it is 
used for determining if the user can invoke 
the Unadjust Record method.

Adjustment: 
Adjustment For Id 
Field Name

Adjustment For Id Used internally.

Field which stores base record identifier 
(usually, but not necessarily the value of 
row_id) that this record is an adjustment 
for. 

Adjustment: 
Adjustment for Id 
Matching Field Name

Forecast Item 
Number

Used internally.

Field which, when matched against 
[Adjustment For Id], determines if a record 
has been adjusted. This is part of the 
criteria used in calculating the value of the 
Adjustment Flag.

Table 8. Forecast 2000 - Forecast Item

User Property Value Comments
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Adjustment: Context 
BC Position Id Field 
Name

Owner Position Id Used internally.

Field on the Context BusComp which 
stores the position of the owner. Because 
Siebel Forecasting is position-based, this 
links the user to the forecast record 
created. The position is used when 
calculating whether a record is visible.

Adjustment: InterTable Y Used internally (default N).

Indicates whether this adjustable business 
component’s visibility is determined by an 
intertable. The code would potentially 
need to modify the intertable when 
creating adjustments.

Adjustment: InterTable 
BC

Forecast 2000 - 
Forecast/Forecast 
Item

Used internally. 

Indicates the business component that sits 
on the intertable.

Adjustment: InterTable 
Child Field Name

Forecast Item Id Used internally.

Indicates the field on the intertable that 
stores the pointer id to this business 
component.

Adjustment: InterTable 
Parent Field Name

Forecast Id Used internally.

Indicates the field on the intertable that 
stores the pointer to the parent (context) 
business component.

Adjustment: InterTable 
Update

Y Used internally.

Indicates whether or not the intertable 
should be updated during adjustments.

Adjustment: Owner 
Position Id Field Name

Owner Position Id. Used internally.

Field on this business component which 
stores the owner’s Position Id. 

Table 8. Forecast 2000 - Forecast Item

User Property Value Comments
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Table 9 describes the user properties associated with the business component: 
Forecast 2000 - Forecast Item Detail.

Revenue Associate List Y When active, the associate applet will 
show the revenue, and not a standard child 
business component. It also applies the 
Associate Search Spec and the Forecast 
Date Range search when querying the 
Revenue BusComp.

When inactive, the behavior defaults to 
standard association and the business 
component will be as defined in the 
associate applet.

Revenue Field Map: 
<Forecast Item Field>

<Revenue Field> Maps fields from the Revenue BusComp to 
the Forecast Item BusComp, which are 
copied when creating the forecast.

This is most commonly configured by 
administrators who have added fields to 
the Revenue BusComp and want the fields 
to be carried over in the forecast.

Table 9. Forecast 2000 - Forecast Item Detail

User Property Value Comments

Adjustment: 
Adjustable

Y Used internally.

Adjustment: 
Adjustable Field (N)

<Forecast Item 
Detail field>

See Forecast Item: Adjustable Field (N) in 
Table 8.

Adjustment: 
Adjustment Allowed 
Field Name

Adjustment 
Allowed

Used internally.

See Forecast Item: Adjustment Allowed 
Field Name in Table 8.

Adjustment: 
Adjustment Context BC 
Name

Forecast 2000 - 
Forecast

Used internally.

See Forecast Item: Adjustment Context BC 
Name in Table 8.

Table 8. Forecast 2000 - Forecast Item

User Property Value Comments
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Table 10 describes the user properties associated with the business component: 
Forecast 2000 - Forecast Item Detail Flat.

Adjustment: 
Adjustment Context Id 
Field Name

Owner Forecast Id Used internally.

See Forecast Item: Adjustment Context Id 
Field Name in Table 8.

Adjustment: 
Adjustment Flag Field 
Name

Adjusted Flag Used internally.

See Forecast Item:Adjustment Flag Field 
Name in Table 8.

Adjustment: 
Adjustment For Id 
Field Name

Adjustment For Id Used internally.

See Forecast Item: Adjustment For Id Field 
Name in Table 8.

Adjustment: Context 
BC Position Id Field 
Name

Owner Position Id Used internally. 

See Forecast Item: Context BC Position Id 
Field Name in Table 8.

Revenue Field Map: 
<Forecast Item Detail 
Field>

<Revenue Field> See Forecast Item: Revenue Field Map in 
Table 8.

Table 10. Forecast 2000 - Forecast Item Detail Flat

User Property Value Comments

Adjustment: 
Adjustable

Y Used internally. 

See Forecast Item: Adjustable in Table 8.

Adjustment: 
Adjustable Field (N)

<Forecast Item 
Detail Flat field>

See Forecast Item: Adjustable Field (N) in 
Table 8.

Adjustment: 
Adjustment Allowed 
Field Name

Adjustment 
Allowed

Used internally.

See Forecast Item: Adjustment Allowed 
Field Name in Table 8.

Table 9. Forecast 2000 - Forecast Item Detail

User Property Value Comments
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Adjustment: 
Adjustment Context BC 
Name

Forecast 2000 - 
Forecast

Used internally.

See Forecast Item: Adjustment Context BC 
Name in Table 8.

Adjustment: 
Adjustment Context Id 
Field Name

Owner Forecast Id Used internally.

See Forecast Item: Adjustment Context Id 
Field Name in Table 8.

Adjustment: 
Adjustment Flag Field 
Name

Adjusted Flag Used internally.

See Forecast Item: Adjustment Flag Field 
Name in Table 8.

Adjustment: 
Adjustment For Id 
Field Name

Adjustment For Id Used internally.

See Forecast Item: Adjustment For Id Field 
Name in Table 8.

Adjustment: Context 
BC Position Id Field 
Name

Owner Position Id Used internally.

See Forecast Item: Context BC Position Id 
Field Name in Table 8.

Adjustment: Owner 
Position Id Field Name

Owner Position Id Used internally.

See Forecast Item: Owner Position Id in 
Table 8.

Adjustment: Force 
Unadjust Parent BC

Forecast 2000 - 
Forecast Item

Used internally.

When unadjusting this buscomp, the 
parent buscomp may also need to be 
unadjusted, e.g. if it drives the visibility of 
this buscomp.

Adjustment: Force 
Unadjust Parent BC Id 
Field Name

Forecast Item Id Used internally.

When unadjusting this buscomp, the field 
on this buscomp which links to the parent 
buscomp that it should unadjust.

Table 10. Forecast 2000 - Forecast Item Detail Flat

User Property Value Comments
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Table 11 describes the user properties associated with the business component: 
Forecast 2000 - Forecast Item DynCol.

Revenue Associate List Y See Forecast Item: Revenue Associate List 
in Table 8.

Revenue Field Map: 
<Forecast Item Detail 
Field>

<Revenue Field> See Forecast Item: Revenue Field Map in 
Table 8.

Table 11. Forecast 2000 - Forecast Item DynCol

User Property Value Comments

Adjustment: 
Adjustable

Y Used internally.

See Forecast Item: Adjustable in Table 8.

Adjustment: 
Adjustable Field (N)

Field names on 
the Forecast 2000 - 
Forecast Item 
buscomp

See Forecast Item: Adjustable Field (N in 
Table 8).

Adjustment: 
Adjustment Allowed 
Field Name

Adjustment 
Allowed

Used internally.

See Forecast Item: Adjustment Allowed 
Field Name in Table 8.

Adjustment: 
Adjustment Context BC 
Name

Forecast 2000 - 
Forecast

Used internally.

See Forecast Item: Adjustment Context BC 
Name in Table 8.

Adjustment: 
Adjustment Context Id 
Field Name

Owner Forecast Id Used internally.

See Forecast Item: Adjustment Context Id 
Field Name in Table 8.

Adjustment: 
Adjustment Flag Field 
Name

Adjusted Flag Used internally.

See Forecast Item: Adjustment Flag Field 
Name in Table 8.

Table 10. Forecast 2000 - Forecast Item Detail Flat

User Property Value Comments
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Adjustment: 
Adjustment For Id 
Field Name

Adjustment For Id Used internally.

See Forecast Item: Adjustment For Id Field 
Name in Table 8.

Adjustment: 
Adjustment for Id 
Matching Field Name

Forecast Item 
Number

Used internally.

See Forecast Item: Adjustment For Id 
Matching Field Name in Table 8.

Adjustment: Context 
BC Position Id Field 
Name.

Owner Position Id Used internally.

See Forecast Item: Context BC Position Id 
Field Name in Table 8.

Adjustment: InterTable Y Used internally.

See Forecast Item: Adjustment InterTable 
in Table 8.

Adjustment: InterTable 
BC

Forecast 2000 - 
Forecast/Forecast 
Item

Used internally.

See Forecast Item: Adjustment InterTable 
BC in Table 8.

Adjustment: InterTable 
Child Field Name

Forecast Item Id Used internally.

See Forecast Item:Adjustment InterTable 
Child Field in Table 8.

Adjustment: InterTable 
Parent Field Name

Forecast Id Used internally.

See Forecast Item: Adjustment InterTable 
Parent Field in Table 8.

Adjustment: InterTable 
Update

Y Used internally.

See Forecast Item: Adjustment InterTable 
Update in Table 8.

Revenue Associate List Used internally.

See Forecast Item: Revenue Associate List 
in Table 8.

Revenue Field Map: 
<Forecast Item Field>

<Revenue Field> See Forecast Item: Revenue Field Map in 
Table 8.

Table 11. Forecast 2000 - Forecast Item DynCol

User Property Value Comments
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Table 12 describes the user properties associated with the business component: 
Forecast 2000 - Forecast Series.

Table 13 describes the user properties associated with the business component: 
Forecast 2000 - Forecast Series Date.

Table 12. Forecast 2000 - Forecast Series

User Property Value Comments

Series Subst Var: 
SERIES_NAME

Name Special variable available for use in Auto, 
Assoc, and Date Range search specs. Using 
this variable, administrators can access the 
Forecast Series Name.

Table 13. Forecast 2000 - Forecast Series Date

User Property Value Comments

Auto-Set Start/
End Dates

N If enabled, when the user creates a new 
record and sets the Forecast Date field, 
Start Date will automatically default to the 
period that the Forecast Date falls in. Also, 
if the user is copying a record, the End date 
will default so that the difference (number 
of periods) between the source record's 
start date and end date will be maintained.

Series Subst Var: 
FCST_DATE_LOW
ER_BOUND

Date - Lower Bound Special variable available for use in Auto, 
Assoc, and Date Range search specs. Using 
this variable, administrators can access the 
lower bound of the Forecast Series Date 
record, for example the earliest of {History 
View Date, History Edit Date, Start Date}, 
some of which can be null.

Series Subst Var: 
FCST_EFFECTIVE
_DATE

Forecast Date Special variable available for use in Auto, 
Assoc, and Date Range search specs. Using 
this variable, administrators can access the 
Forecast Date.
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■ When entering user properties or search specs for forecast administration, make 
sure that the quote symbols (') are not formatted to be directional. The 
beginning and ending quotations should appear identical. Formatting is 
automatically done by some editors, for example Microsoft Word, but such 
formatted quotes are not recognized by the Siebel parser. 

■ The “Forecast 2000 - Forecast Item Detail” business component is used 
internally by the forecast engine, while the “Forecast 2000 - Forecast Item Detail 
Flat” business component joins both the Forecast Item and Forecast Item Detail 
business components to form a flat view (the Forecast Item BusComp usually 
stores the non-numeric properties which can be shared by child details). In 
general, this means that new fields, and user properties referencing that field, 
should be added to both business components.

Series Subst Var: 
FCST_END_DATE

End Date Special variable available for use in Auto, 
Assoc, Date Range search specs. Through 
this variable, administrators can access the 
End Date.

Series Subst Var: 
FCST_HISTE_STA
RT_DATE

History Edit Date Special variable available for use in Auto, 
Assoc, and Date Range search specs. Using 
this variable, administrators can access the 
History Edit Date, which can be null. The 
History Edit Date defaults to History View 
if defined, otherwise it defaults to Start 
Date.

Series Subst Var: 
FCST_HISTV_STA
RT_DATE

History View Date Special variable available for use in Auto, 
Assoc, and Date Range search specs. Using 
this variable, administrators can access the 
History View Date, which can be null. The 
History View Date defaults to the earlier of 
{History Edit, Start}.

Series Subst Var: 
FCST_START_DA
TE

Start Date Special variable available for use in Auto, 
Assoc, and Date Range search specs. Using 
this variable, administrators can access the 
Start Date, which cannot be null.

Table 13. Forecast 2000 - Forecast Series Date

User Property Value Comments
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■ The “Forecast 2000 - Forecast Item” business component is used internally by 
the forecast engine, while the “Forecast 2000 - Forecast Item DynCol” business 
component is used to display the Forecast Details spreadsheet. Each record in 
the Forecast Item DynCol business component corresponds to a row in the 
spreadsheet, with the child forecast details forming the dynamic columns 
(dates). For information on the dynamic columns user properties, see “Changing 
the Configuration of Spreadsheet Applets for New Views (Administrator)” on 
page 72.
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